  • Main Page
  • Classes
  • Files
  • Directories
  • Alphabetical List
  • Class List
  • Class Hierarchy
  • Class Members

ACTIV C++ SDK Class List

Here are the classes, structs, unions and interfaces with brief descriptions:
Activ::Address | Address
Activ::Address::Proxy | Address proxy class. Used where an Address or ScopedAddress can be passed to a function
Activ::AgentApplication | Agent application class
Activ::AgentApplication::Settings | Agent settings
Activ::Application | Base application class
Activ::Application::Settings | Settings
Activ::AtomicInteger | Atomic integer class
Activ::AtomicPointer< T > | Atomic pointer class
Activ::BaseException | ActivBase exception class
Activ::BaseTime | Base time class
Activ::BaseTime::Duration | Duration class
Activ::Binary< T, N, B > | Convert a binary representation of a number
Activ::BinaryArray | Binary array class
Activ::BinaryString | Binary string class
Activ::BitField< T, OFFSET_VALUE, LENGTH_VALUE > | Bit field helper class
Activ::Blob | Blob class
Activ::CaseInsensitiveLessThanStringComparisonObject | Case-insensitive less than string comparison object
Activ::ChildService< T > | Child service class
Activ::CommandLineParser | Command line parser class
Activ::CommandLineParserDetail::BooleanSwitchDescription | Description of a boolean command line switch
Activ::CommandLineParserDetail::CommandLineParserImpl | Implementation details of CommandLineParser
Activ::CommandLineParserDetail::DefaultDescription< T > | Description of a command line parameter/switch with default value
Activ::CommandLineParserDetail::Description< T > | Description of a command line parameter/switch
Activ::CommandLineParserDetail::DescriptionAppender | Helper class to build description
Activ::CommandLineParserDetail::MandatoryParameterDescription< T > | Description of a mandatory command line parameter
Activ::CommandLineParserDetail::MandatorySwitchDescription< T > | Description of a mandatory command line switch
Activ::CommandLineParserDetail::OptionalParameterDescription< T > | Description of an optional command line parameter
Activ::CommandLineParserDetail::OptionalSwitchDescription< T > | Description of an optional command line switch
Activ::CommandLineParserDetail::ValueStore< T > | Default action to take for a command line value
Activ::Component | Component class
Activ::ConsoleWindow | Console window class
Activ::ConsoleWindow::Coord | Cursor coordinate
Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient | Content gateway client class
Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::ApiInfo | Information returned from GetApiInfo()
Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::ConnectParameters | Parameters for Connect()
Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::Settings | Settings for ContentGatewayClient class
Activ::ContentPlatform::ContentGatewayApi::ContentGatewayInfo | Information about the ContentGateway
Activ::ContentPlatform::ContentGatewayApi::DataPointAddress | Address of an individual data point
Activ::ContentPlatform::ContentGatewayApi::FieldData | Opaque field data block
Activ::ContentPlatform::ContentGatewayApi::FieldListValidator | Field list validator class
Activ::ContentPlatform::ContentGatewayApi::FieldSet | Field Set base class
Activ::ContentPlatform::ContentGatewayApi::HistoryBar | History Bar Field Set class
Activ::ContentPlatform::ContentGatewayApi::INewsResponses | Interface for news response callbacks
Activ::ContentPlatform::ContentGatewayApi::IntradayBar | Intraday Bar Field Set class
Activ::ContentPlatform::ContentGatewayApi::IRealtimeResponses | Interface for realtime data response callbacks
Activ::ContentPlatform::ContentGatewayApi::ISymbolDirectoryResponses | Interface for symbol directory response callbacks
Activ::ContentPlatform::ContentGatewayApi::ITimeSeriesResponses | Interface for time series request callbacks
Activ::ContentPlatform::ContentGatewayApi::MatchRequestParameters | Request parameters for match request
Activ::ContentPlatform::ContentGatewayApi::MetaDataRequestHelper | Metadata request helper class
Activ::ContentPlatform::ContentGatewayApi::NewsRequestHelper | News request helper class
Activ::ContentPlatform::ContentGatewayApi::NewsRequestParameters | News request parameters
Activ::ContentPlatform::ContentGatewayApi::NewsResponseParameters | News response parameters
Activ::ContentPlatform::ContentGatewayApi::NewsStory | News story class
Activ::ContentPlatform::ContentGatewayApi::NewsUpdate | News update class
Activ::ContentPlatform::ContentGatewayApi::NewsUpdateHelper | News update helper class
Activ::ContentPlatform::ContentGatewayApi::OptionBar | Option Bar Field Set class
Activ::ContentPlatform::ContentGatewayApi::PatternMatchListRequestParameters | Request parameters for pattern match on symbol based requests
Activ::ContentPlatform::ContentGatewayApi::PatternMatchRequestParameters | Request parameters for pattern match on symbol based requests
Activ::ContentPlatform::ContentGatewayApi::Period | Period of a series
Activ::ContentPlatform::ContentGatewayApi::PermissionInfo | Information about client's permissioning
Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestHelper< MESSAGE_TYPE_VALUE, REQUEST_PARAMETERS > | Realtime request helper class
Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters | Request parameters that apply to all requests
Activ::ContentPlatform::ContentGatewayApi::RealtimeResponseParameters | Response parameters from a realtime request
Activ::ContentPlatform::ContentGatewayApi::RecordUpdate | Record update
Activ::ContentPlatform::ContentGatewayApi::RecordUpdateHelper | Record update helper class
Activ::ContentPlatform::ContentGatewayApi::RelationshipInfo | Info about available relationship ids
Activ::ContentPlatform::ContentGatewayApi::RequestBlock | Request block
Activ::ContentPlatform::ContentGatewayApi::ResponseBlock | Response block
Activ::ContentPlatform::ContentGatewayApi::SubscribeFeedParameters | Parameters for SubscribeToFeed() method
Activ::ContentPlatform::ContentGatewayApi::SubscribeParameters | Parameters for specifying subscription options
Activ::ContentPlatform::ContentGatewayApi::SubscribeTableParameters | Parameters for SubscribeToTable() method
Activ::ContentPlatform::ContentGatewayApi::SubscriptionInfo | Info returned about subscriptions
Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryRequestHelper | Symbol directory helper class
Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryRequestParameters | Get Symbols Request parameters
Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryResponseParameters | Symbol directory response parameters
Activ::ContentPlatform::ContentGatewayApi::SymbolId | Symbol id
Activ::ContentPlatform::ContentGatewayApi::SymbolIdCountRequestParameters | Request parameters for SymbolId based requests with count (for get next, previous)
Activ::ContentPlatform::ContentGatewayApi::SymbolIdListMatchRequestParameters | Request parameters for multiple match request with multiple symbols
Activ::ContentPlatform::ContentGatewayApi::SymbolIdListRequestParameters | Request parameters for SymbolIdList based requests
Activ::ContentPlatform::ContentGatewayApi::SymbolIdMatchRequestParameters | Request parameters for match request with single symbol
Activ::ContentPlatform::ContentGatewayApi::SymbolIdRequestParameters | Request parameters for SymbolId based requests
Activ::ContentPlatform::ContentGatewayApi::SymbolResponse | Symbol directory response parameters
Activ::ContentPlatform::ContentGatewayApi::TableInfo | Info about available tables
Activ::ContentPlatform::ContentGatewayApi::TableNumberRequestParameters | Request parameters for table number based requests
Activ::ContentPlatform::ContentGatewayApi::Tick | Tick Field Set class
Activ::ContentPlatform::ContentGatewayApi::TimeSeriesCookie | Cookie passed between history manager and client for multi part requests
Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestHelper< FIRST_MESSAGE_TYPE_VALUE, NEXT_MESSAGE_TYPE_VALUE, FIELD_SET_TYPE > | Time series helper class
Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestParameters | Request parameters
Activ::ContentPlatform::ContentGatewayApi::TimeSeriesResponseParametersTemplate< FIELD_SET_TYPE > | Time series response parameters
Activ::ContentPlatform::ContentServerApi::ContentServerClient | Content server client class
Activ::ContentPlatform::ContentServerApi::ContentServerClient::ApiInfo | Information returned from GetApiInfo()
Activ::ContentPlatform::ContentServerApi::ContentServerClient::MessageStats | Message stats class
Activ::ContentPlatform::ContentServerApi::ContentServerClient::Settings | Settings for ContentServerClient class
Activ::ContentPlatform::ContentServerApi::ContentServerClient::UpdateFilter | Update Filter
Activ::ContentPlatform::ContentServerApi::ContentServerClient::UpdateFilterMap | Update filter map class
Activ::ContentPlatform::ContentServerApi::FieldListValidator | Field list validator class
Activ::ContentPlatform::ContentServerApi::RecordUpdate | Record update class
Activ::ContentPlatform::ContentServerApi::RecordUpdateHelper< MESSAGE_VALIDATOR > | Record update helper class
Activ::ContentPlatform::ContentServerApi::SymbolRecordUpdate | Symbol record update class
Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient | Contribution gateway client class
Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::ApiInfo | Information returned from GetApiInfo()
Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::ConnectParameters | Parameters for Connect()
Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::Settings | Settings for ContributionGatewayClient class
Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayInfo | Information about the ContributionGateway
Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayResponseParameters | Base response parameters
Activ::ContentPlatform::ContributionGatewayApi::PermissionInfo | Information about users permissioning
Activ::ContentPlatform::ContributionGatewayApi::PublishField | Publish field class
Activ::ContentPlatform::ContributionGatewayApi::PublishRecordBaseParameters | Base parameters for publishing a record
Activ::ContentPlatform::ContributionGatewayApi::PublishRecordParameters | Parameters for publishing a record
Activ::ContentPlatform::ContributionGatewayApi::PublishRecordResponseParameters | Response parameters from a publish request
Activ::ContentPlatform::ContributionGatewayApi::PublishRecordResponseParameters::FieldError | Field error class
Activ::ContentPlatform::ContributionGatewayApi::PublishRequestHelper< MESSAGE_TYPE_VALUE, REQUEST_PARAMETERS, RESPONSE_PARAMETERS > | Publish request helper class
Activ::ContentPlatform::ContributionGatewayApi::PublishSymbolRecordParameters | Parameters for publishing a symbol record
Activ::ContentPlatform::ContributionGatewayApi::PublishSymbolRecordParameters::Field | Field class
Activ::ContentPlatform::ContributionServerApi::ContributionServerClient | Contribution server client class
Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::ApiInfo | Information returned from GetApiInfo()
Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::RecordMessageBuilder | Record message builder class
Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::Settings | Settings for contribution api class
Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::SymbolRecordMessageBuilder | Symbol record message builder class
Activ::ContentPlatform::Feed::CombinedQuoteMessageHeaderDefinitions | Combined quote message header definitions class
Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessage | Compressed Combined quote message class
Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageDefinitions | Compressed combined quote message definitions class
Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderDefinitions | Comrpessed combined quote message header definitions class
Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator | Compressed combined quote message header validator class
Activ::ContentPlatform::Feed::CompressedMessage | Compressed message class
Activ::ContentPlatform::Feed::CompressedMessageDefinitions | Compressed message definitions class
Activ::ContentPlatform::Feed::CompressedMessageDefinitions::FieldHeaderBuilder | Field header builder class
Activ::ContentPlatform::Feed::CompressedMessageDefinitions::FieldHeaderValidator | Field header validator class
Activ::ContentPlatform::Feed::CompressedMessageDefinitions::FieldSpecification | Field specification class
Activ::ContentPlatform::Feed::CompressedMessageHeaderDefinitions | Compressed message header definitions class
Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator | Compressed message header validator class
Activ::ContentPlatform::Feed::CompressedSymbol | Compressed symbol class
Activ::ContentPlatform::Feed::CompressedUsEquityOptionSymbol | Compressed us equity option symbol class
Activ::ContentPlatform::Feed::CopyOnReset | Copy on reset class
Activ::ContentPlatform::Feed::EntityTypeHelper | Entity type helper class
Activ::ContentPlatform::Feed::EventTypeHelper | Event type helper class
Activ::ContentPlatform::Feed::Field | Field class
Activ::ContentPlatform::Feed::Field::Specification | Specification class
Activ::ContentPlatform::Feed::FieldHeaderDefinitions | Field header definitions class
Activ::ContentPlatform::Feed::Index::IndexFieldSpecification | Index field specification class
Activ::ContentPlatform::Feed::Index::Specification | Specification class
Activ::ContentPlatform::Feed::IndexSpecification::Field | Index field class
Activ::ContentPlatform::Feed::MessageHeaderDefinitions | Message header definitions class
Activ::ContentPlatform::Feed::PermissionIdHelper | Permission id helper class
Activ::ContentPlatform::Feed::PermissionInfo | Information about a user's permissioning
Activ::ContentPlatform::Feed::PermissionInfo::PermissionIdInfo | Information about a particular permission id for the client
Activ::ContentPlatform::Feed::PermissionLevelData |
Activ::ContentPlatform::Feed::RecordFieldListBuilder | Record field list builder class
Activ::ContentPlatform::Feed::RecordFieldListValidator | Record field list validator class
Activ::ContentPlatform::Feed::RecordFieldListValidator::ConstIterator | Const iterator class
Activ::ContentPlatform::Feed::RecordKeyFieldListBuilder | Record key Field list builder class
Activ::ContentPlatform::Feed::RecordKeyFieldListValidator | Record key field list validator class
Activ::ContentPlatform::Feed::RecordKeyFieldListValidator::ConstIterator | Const iterator class
Activ::ContentPlatform::Feed::RecordMessageBuilder | Record message builder class
Activ::ContentPlatform::Feed::RecordMessageHeaderDefinitions | Record message header definitions class
Activ::ContentPlatform::Feed::RecordMessageHeaderValidator | Record message header validator class
Activ::ContentPlatform::Feed::RecordMessageValidator | Record message validator class
Activ::ContentPlatform::Feed::RelationshipIdHelper | Relationship id helper class
Activ::ContentPlatform::Feed::Rule | Rule class
Activ::ContentPlatform::Feed::Rule::CloseFields | Close fields class
Activ::ContentPlatform::Feed::Rule::CopyToFields | Copy To fields class
Activ::ContentPlatform::Feed::Rule::HighFields | High fields class
Activ::ContentPlatform::Feed::Rule::LowFields | Low fields class
Activ::ContentPlatform::Feed::Rule::OpenFields | Open fields class
Activ::ContentPlatform::Feed::Rule::PriceFields | Price fields class
Activ::ContentPlatform::Feed::Rule::VolumeFields | Volume fields class
Activ::ContentPlatform::Feed::Symbol | Symbol class
Activ::ContentPlatform::Feed::SymbolRecordField | Symbol record field class
Activ::ContentPlatform::Feed::SymbolRecordField::PartialUpdate | Partial update class
Activ::ContentPlatform::Feed::SymbolRecordFieldHeaderDefinitions | Symbol record field header definitions class
Activ::ContentPlatform::Feed::SymbolRecordFieldListBuilder | Symbol record field list builder class
Activ::ContentPlatform::Feed::SymbolRecordFieldListValidator | Symbol record symbol record field list validator class
Activ::ContentPlatform::Feed::SymbolRecordFieldListValidator::ConstIterator | Const iterator class
Activ::ContentPlatform::Feed::SymbolRecordMessageBuilder | Symbol record message builder class
Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions | Symbol record message header definitions class
Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator | Symbol record message header validator class
Activ::ContentPlatform::Feed::SymbolRecordMessageValidator | Symbol record message validator class
Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions | Symbol record rules definitions class
Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ContentServerRuleSet | Content server rule set
Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::TranslatorRuleSet | Translator rule set
Activ::ContentPlatform::Feed::TableTemplate | Table template class
Activ::ContentPlatform::Feed::TableTemplate::ConstCopyOnResetIterator | Const CopyOnReset iterator class
Activ::ContentPlatform::Feed::TableTemplate::ConstFieldIterator | Const field iterator class
Activ::ContentPlatform::Feed::TableTemplate::ConstIndexIterator | Const index iterator class
Activ::ContentPlatform::Feed::TableTemplate::ConstRuleIterator | Const rule iterator class
Activ::ContentPlatform::Feed::TableTemplate::ConstUndefineOnResetIterator | Const UndefineOnReset iterator class
Activ::ContentPlatform::Feed::TableTemplate::FieldSpecification | Field specification class
Activ::ContentPlatform::Feed::TableTemplate::Specification | Specification class
Activ::ContentPlatform::Feed::TableTemplateAddition | Table template addition class
Activ::ContentPlatform::Feed::TableTemplateException | Table template exception
Activ::ContentPlatform::Feed::TableTemplateField | Table template field class
Activ::ContentPlatform::Feed::TableTemplateFieldListValidator | Table template field list validator class
Activ::ContentPlatform::Feed::TableTemplateFieldListValidator::ConstIterator | Const iterator class
Activ::ContentPlatform::Feed::TableTemplateIndex | Table template field list validator class
Activ::ContentPlatform::Feed::TableTemplateIndexListValidator | Table template index list validator class
Activ::ContentPlatform::Feed::TableTemplateList | Table template list class
Activ::ContentPlatform::Feed::TableTemplateList::ConstIterator | Const iterator class
Activ::ContentPlatform::Feed::TableTemplateList::Settings | Settings
Activ::ContentPlatform::Feed::TableTemplateList::TableTemplateSpecification | Table template specification class
Activ::ContentPlatform::Feed::TableTemplateMessageHeaderDefinitions | Table template message header definitions class
Activ::ContentPlatform::Feed::TableTemplateMessageValidator | Table template message validator class
Activ::ContentPlatform::Feed::UniversalFieldHelper | Universal field helper class
Activ::ContentPlatform::Feed::UniversalFieldList | Universal field list class
Activ::ContentPlatform::Feed::UniversalFieldList::ConstIterator | Const iterator class
Activ::ContentPlatform::FeedApi::FieldListValidator | Field list validator class
Activ::ContentPlatform::FeedApi::FieldListValidator::ConstIterator | Const iterator class
Activ::ContentPlatform::FeedApi::FieldListValidator::Field | Field class
Activ::ContentPlatform::FeedApi::SymbolPatternHelper | Symbol pattern helper
Activ::CrcBlob | Crc blob class
Activ::CrtException | C runtime exception class
Activ::CtrlHandler | Ctrl handler class
Activ::CurlFtpHelper | CurlFtpHelper class
Activ::CurlFtpHelper::CurlInitializeHelper | CurlInitializeHelper class
Activ::Database::Database | Database class
Activ::Database::Database::ConstIterator | Const iterator class
Activ::Database::Database::Iterator | Iterator class
Activ::Database::DatabaseException | Database exception class
Activ::Database::DatabaseSpecification | Database specification structure
Activ::Database::DatabaseSpecification::DatabaseTableSpecification | Database table specification structure
Activ::Database::FieldList | Declaration of the field list class
Activ::Database::FieldList::ConstIterator | Const iterator class
Activ::Database::FieldListObject | Field list object class
Activ::Database::FieldSpecification | Field specification structure
Activ::Database::IIndex | Abstract base index class
Activ::Database::IndexSpecification | Index Specification structure
Activ::Database::IndexSpecification::Field | Index field specification structure
Activ::Database::ITable | Abstract base table class
Activ::Database::Key | Key class
Activ::Database::ManagedTableFactory | Managed table factory class
Activ::Database::Record | Database record class
Activ::Database::RemoteTableFactory | Remote table factory class
Activ::Database::TableSpecification | Table specification structure
Activ::Database::UnmanagedTableFactory | Unmanaged table factory class
Activ::Date | Date class
Activ::Date::Days | Days class
Activ::DateTime | Date / time class
Activ::DeferredScopedMutexLocker | Deferred acquire mutex helper class
Activ::DeleteAssociativeObject | Delete associative object
Activ::DeleteObject | Delete object
Activ::DeleteObjectArray | Delete object array
Activ::Des3Helper::Key | Wrapper class for DES keys
Activ::Des3Helper::KeyBundle | Class containing three DES key schedules
Activ::DesHelper::Key | Wrapper class for DES keys
Activ::DirectoryRemover | Directory remover class
Activ::DirectoryWalker | Directory walker class
Activ::DirectoryWatchApi | Api to the agent's directory watching service
Activ::DirectoryWatchApi::Event | File/directory change event
Activ::DllFunctionWrapper< NAME, TYPE, THROW_ON_ERROR > | Function wrapper
Activ::DynamicLibraryLoader< T > | Main dynamic library loader class
Activ::EndPointSubject | Endpoint subject
Activ::EqualToPairComparisonObject< Pair > | Equal to pair comparison function object
Activ::Exception | Base Activ exception class
Activ::Fiber | Fiber class
Activ::FieldTypeFactory | Field type factory class
Activ::FieldTypeToClass<> | Template to map from FIELD_TYPE_* values to concrete IFieldType class
Activ::FieldTypeToClass< FIELD_TYPE_BINARY_ARRAY > | Template specialization to map from FIELD_TYPE_BINARY_ARRAY to BinaryArray class
Activ::FieldTypeToClass< FIELD_TYPE_BINARY_STRING > | Template specialization to map from FIELD_TYPE_BINARY_STRING to BinaryString class
Activ::FieldTypeToClass< FIELD_TYPE_BLOB > | Template specialization to map from FIELD_TYPE_BLOB to Blob class
Activ::FieldTypeToClass< FIELD_TYPE_CRC_BLOB > | Template specialization to map from FIELD_TYPE_CRC_BLOB to CrcBlob class
Activ::FieldTypeToClass< FIELD_TYPE_DATE > | Template specialization to map from FIELD_TYPE_DATE to Date class
Activ::FieldTypeToClass< FIELD_TYPE_DATE_TIME > | Template specialization to map from FIELD_TYPE_DATE_TIME to DateTime class
Activ::FieldTypeToClass< FIELD_TYPE_RATIONAL > | Template specialization to map from FIELD_TYPE_RATIONAL to Rational class
Activ::FieldTypeToClass< FIELD_TYPE_SINT > | Template specialization to map from FIELD_TYPE_SINT to SInt class
Activ::FieldTypeToClass< FIELD_TYPE_TEXT_ARRAY > | Template specialization to map from FIELD_TYPE_TEXT_ARRAY to TextArray class
Activ::FieldTypeToClass< FIELD_TYPE_TEXT_STRING > | Template specialization to map from FIELD_TYPE_TEXT_STRING to TextString class
Activ::FieldTypeToClass< FIELD_TYPE_TIME > | Template specialization to map from FIELD_TYPE_TIME to Time class
Activ::FieldTypeToClass< FIELD_TYPE_TRATIONAL > | Template specialization to map from FIELD_TYPE_TRATIONAL to TRational class
Activ::FieldTypeToClass< FIELD_TYPE_UINT > | Template specialization to map from FIELD_TYPE_UINT to UInt class
Activ::File | File class
Activ::FileInfo | FileInfo class
Activ::FileMappedMemoryFactory | File mapped memory factory class
Activ::FirstBitField< T, LENGTH_VALUE > | Initial (0 offset) bit field helper class
Activ::FtpHelper | FtpHelper class
Activ::Greater< T, RHS > | Greater than comparison object where the right hand side is constant
Activ::HandleManager< T > | HandleManager class
Activ::HeapMessage | Heap message class
Activ::HeapMessage::Iterator | Heap message iterator class
Activ::HeapMessage::ReadHelper | Heap message read helper class
Activ::HeapMessage::Stats | Status for a single HeapMessage, ignoring chaining
Activ::HeapMessage::WriteHelper | Heap message write helper class
Activ::HeapMessageBuilder | Helper class to build directly into a contiguous HeapMessage
Activ::HeapMessageDeserializer< MESSAGE_TYPE, BUFFER_SIZE > | Template class to wrap up deserializing a HeapMessage
Activ::HeapPool | Heap pool
Activ::IEndPoint | Abstract endpoint interface class
Activ::IEndPoint::Stats | Stats for an endpoint
Activ::IEvent | Abstract base event class
Activ::IFieldType | Field type interface class
Activ::IFileMappedMemory | Abstract base file mapped memory class
Activ::IFtpHelper | FtpHelper class
Activ::IHeap | Abstract heap interface class
Activ::IHeap::BucketInfo | Heap bucket size information
Activ::IHeap::Stats | Heap stats
Activ::IHeap::Stats::BucketStats | Individual Bucket stats
Activ::IHeap::Stats::RequestDistributionStats | Request distribution stats
Activ::IMappedMemory | Abstract base mapped memory class
Activ::IMutex | Mutex interface class
Activ::IniFileParser | Ini file parser
Activ::IniFileParser::ConstKeyIterator | Const iterator to section keys
Activ::IniFileParser::ConstSectionIterator | Const iterator to ini file sections
Activ::IniFileParser::ParseException | Exception generated by parse errors
Activ::IntervalTimer | Interval timer class
Activ::IntervalTimer::Scoped | Helper class to measure time whilst in scope
Activ::IoCompletionManager | I/O completion manager class
Activ::IoCompletionManager::Overlapped | Overlapped class
Activ::IpAddress | Protocol independant ip address information
Activ::IpException | Ip exception class
Activ::IpManager | Ip manager base class
Activ::IpManager::InterfaceInfo | Information on a network interface
Activ::IpManager::Settings | Settings
Activ::IProcess | Process interface class
Activ::IProcess::Stats | Process stats
Activ::IpSocket | Base ip socket class
Activ::IpSocket::RxOverlapped | Overlapped class for reads
Activ::IpSocket::Settings | Settings
Activ::IpSocket::Stats | Stats
Activ::IpSocket::TxOverlapped | Overlapped class for writes
Activ::ISemaphore | Abstract base semaphore class
Activ::ISerializableMessage | Serializable message interface
Activ::ISyncEndPoint | Endpoint interface class with sync call support
Activ::ISyncEndPoint::Stats | Stats for a shared endpoint
Activ::ISystem | Abstract system interface class
Activ::ISystem::IEndPointEnumerator | Endpoint enumerator callback interface
Activ::ISystem::IHeapEnumerator | Heap enumerator callback interface
Activ::ISystem::IProcessEnumerator | Process enumerator callback interface
Activ::ISystem::Settings | Settings
Activ::ISystem::SystemInfo | System information
Activ::LengthToIntegralType< N, S > | Template to determine ACTIV integral type from length of integral in bytes
Activ::Less< T, RHS > | Less than comparison object where the right hand side is constant
Activ::LessThanPairComparisonObject< Pair > | Less than pair comparison function object
Activ::LicenseServiceApi | Api to agent's license service
Activ::LocalTime | Local time class
Activ::LoggerDefinitions | Logger definitions class
Activ::LoggerServiceApi | Api to the agent's logger service
Activ::ManagedEndPoint | Managed endpoint class
Activ::ManagedEndPoint::RunHelper | Helper class to run an endpoint
Activ::ManagedEndPoint::Settings | Settings for the endpoint
Activ::MessageBuilder | Message builder class
Activ::MessageBuilderVariableLengthRangeCheck< S > | Class template to check a value is in the acceptable range of a variable number of bytes
Activ::MessageBuilderVariableLengthRangeCheck< false > | Specialization to check an unsigned value is in the acceptable range of a variable number of bytes
Activ::MessageBuilderVariableLengthRangeCheck< true > | Specialization to check a signed value is in the acceptable range of a variable number of bytes
Activ::MessageHandler | Base class for validator and builder
Activ::MessageHandler::ScopedVersion | Helper class to scope changes to message version
Activ::MessageRateThrottler | Message rate throttler class
Activ::MessageValidator | Message validator class
Activ::NextBitField< PREVIOUS_FIELD, LENGTH_VALUE > | Next bitfield helper class
Activ::NullObject | Do-nothing function object
Activ::ObjectPool< T, INITIAL_FREE_LIST_SIZE, MAX_FREE_LIST_SIZE > | Object pool
Activ::ObjectPool< T, INITIAL_FREE_LIST_SIZE, MAX_FREE_LIST_SIZE >::Stats | Pool statistics
Activ::OpenServiceRequest | Open service request
Activ::OpenServiceResponse | Open service response. The response implicitly matches the version of the request
Activ::OsException | OS exception class
Activ::PagingFileMappedMemoryFactory | Paging file mapped memory factory class
Activ::Port | Port class
Activ::Port::Enabler | Helper class to enable & disable a Port
Activ::PostMessageHelper | Helper class to post messages
Activ::PrivateEventFactory | Private event factory class
Activ::PrivateMutexFactory | Private mutex factory class
Activ::PrivateSemaphoreFactory | Private semaphore factory class
Activ::Process | Process class
Activ::PubSubServiceApi | Api to the agent's pubsub service
Activ::Rational | Rational class
Activ::Rational::DenominatorType | Denominator type
Activ::ReferenceCounter | Intrusive ptr reference counter
Activ::RegistryHelper | Registry helper class
Activ::RequestId | Request id class
Activ::RouterServiceApi | Api to the agent's router service
Activ::RouterServiceApi::Tcp | Tcp related apis
Activ::RouterServiceApi::Tcp::SocketStats | Socket stats
Activ::RouterServiceApi::Udp | Udp related apis
Activ::ScatterBufferHelper | Scatter buffer helper class
Activ::ScatterBufferHelper::ConstIterator | Scatter buffer const iterator class
Activ::ScatterBufferHelper::ScatterBuffer | Scatter buffer class
Activ::ScopedAddress | Scoped address
Activ::ScopedAddress::Proxy | ScopedAddress proxy class
Activ::ScopedFd | Scoped file-descriptor helper
Activ::ScopedFile | Scoped FILE helper
Activ::ScopedHandle | Scoped HANDLE helper
Activ::ScopedHandle::IsValidHandle | Function object to check for a valid handle
Activ::ScopedHelper< T, D > | Class which will call a function in its destructor based on a condition
Activ::ScopedHelper< T, D >::True | Simple unary function that returns true
Activ::ScopedMemory< T > | Scoped memory helper
Activ::ScopedMutexLocker | Scoped mutex locking helper class
Activ::ScopedMutexTryLocker | Try acquire mutex helper class
Activ::ScopedPooledObject< T > | Helper class to get an object from an ObjectPool and return it when the helper goes out of scope
Activ::ScopedSocket | Scoped socket helper
Activ::ScopedSubscription | Scoped subscription helper
Activ::SelectFirst< P > | Unary function object to return the first element of a pair
Activ::SelectFirstFromSecond< P > | Unary function object to return the first element of a pair, given the second element
Activ::SelectSecond< P > | Unary function object to return the second element of a pair
Activ::SerializableBuffer< LENGTH_TYPE, MIN_LENGTH, MAX_LENGTH > | Serializable buffer template
Activ::SerializableContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER > | Helper class to serialize STL containers
Activ::SerializableContainerHelper< hash_map< KEY_TYPE, MAPPED_TYPE, HASH_FN >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER > | Specialization for hash_map containers
Activ::SerializableContainerHelper< std::list< OBJECT_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER > | Specialization for list containers
Activ::SerializableContainerHelper< std::map< KEY_TYPE, MAPPED_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER > | Specialization for map containers
Activ::SerializableContainerHelper< std::set< OBJECT_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER > | Specialization for set containers
Activ::SerializableContainerHelper< std::vector< OBJECT_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER > | SerializableContainerHelper specialization for std::vector containers
Activ::SerializableObjectContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH > | Helper class to serialize containers of objects
Activ::SerializableObjectContainerHelper< hash_map< KEY_TYPE, MAPPED_TYPE, HASH_FN >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH > | Partial specialization of SerializableObjectContainerHelper to serialize hash_maps of objects
Activ::SerializableObjectContainerHelper< std::map< KEY_TYPE, MAPPED_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH > | Partial specialization of SerializableObjectContainerHelper to serialize maps of objects
Activ::SerializableObjectHelper< OBJECT_TYPE > | Helper class to (de)serialize objects
Activ::SerializableRawPointerContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH > | Helper class to serialize containers of raw pointers to objects
Activ::SerializableRawPointerContainerHelper< hash_map< KEY_TYPE, MAPPED_TYPE, HASH_FN >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH > | Partial specialization of SerializableRawPointerContainerHelper to serialize hash_maps of raw pointers to objects
Activ::SerializableRawPointerContainerHelper< std::map< KEY_TYPE, MAPPED_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH > | Partial specialization of SerializableRawPointerContainerHelper to serialize maps of raw pointers to objects
Activ::SerializableRawPointerHelper< POINTER_TYPE > | Helper class to (de)serialize raw pointers to objects
Activ::SerializableSmartPointerContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH > | Helper class to serialize containers of smart pointers to objects
Activ::SerializableSmartPointerContainerHelper< hash_map< KEY_TYPE, MAPPED_TYPE, HASH_FN >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH > | Partial specialization of helper class to serialize hash_maps of smart pointers to objects
Activ::SerializableSmartPointerContainerHelper< std::map< KEY_TYPE, MAPPED_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH > | Partial specialization of helper class to serialize maps of smart pointers to objects
Activ::SerializableSmartPointerHelper< POINTER_TYPE > | Helper class to (de)serialize smart pointers to objects
Activ::Service | Service class
Activ::ServiceAccessPoint | Service access point class
Activ::ServiceApi | Api to the access services
Activ::ServiceHandle | Parameters to OpenService() apis
Activ::ServiceId | Service id class
Activ::ServiceInstance | Class representing an instance of a service and its locations
Activ::ServiceSubject | Service subject type. By subscribing to this subject, a component can receive notifications of service registration / deregistration
Activ::SharedCompletionPortEventFactory | Shared completion-port based event factory class
Activ::SharedEventFactory | Shared event factory class
Activ::SharedMutexFactory | Shared mutex factory class
Activ::SharedObject< T > | Templatized shared object class
Activ::SharedSemaphoreFactory | Shared semaphore factory class
Activ::Shell | Command-line abstraction
Activ::ShutdownSubject | Shutdown subject
Activ::Singleton< T > | Singleton template
Activ::SInt | Signed integer class
Activ::SmtpHelper | Smtp helper class
Activ::SmtpHelper::Email | Email class
Activ::SocketWrapper | Socket wrapper class
Activ::StaticAlignValueToProcessorWordBoundary< T, input > | Compile-time template to align a value to a processor word size boundary
Activ::StatusCodeException | StatusCode exception class
Activ::StatusCodeHelper | StatusCodeHelper class
Activ::StringHashCompare< TRAITS > | Hash compare class for STL hash containers where the key is a string
Activ::Subject | Subject class
Activ::SyncRequestId | Synchronous request id class
Activ::SystemException | ActivSystem exception class
Activ::SystemFactory | System factory class
Activ::SystemInfo | System information
Activ::SystemMessageEndPointIdSet | SYSTEM_MESSAGE_ENDPOINT_SHUTDOWN, SYSTEM_MESSAGE_ENDPOINT_DIE
Activ::SystemMonitor | System monitor class
Activ::SystemMonitor::Stats | Collected stats
Activ::SystemMonitor::Stats::DiskInfo | Per-disk info
Activ::SystemMonitor::Stats::ProcessInfo | Per-process info
Activ::SystemProxy | Proxy class for ISystem interface
Activ::TcpListener | TCP listener class
Activ::TcpSocket | TCP socket class
Activ::TcpSocket::Settings | Settings
Activ::TcpSocket::Stats | Stats
Activ::TextArray | Text array class
Activ::TextString | Text string class
Activ::ThinApplication | Thin application class
Activ::ThinApplication::Settings | Settings
Activ::Thread | Thread base class
Activ::ThreadSpecificData< TYPE, CLEANUP > | Thread specific data helper class
Activ::ThreadSpecificDataBase< TYPE, DERIVED > | Thread specific data helper base class
Activ::ThreadSpecificFastPoolAllocator< T, UserAllocator, NextSize > | Boost::fast_pool_allocator like std allocator, except pool is thread local rather than process wide
Activ::ThreadSpecificPoolAllocator< T, UserAllocator, NextSize > | Boost::pool_allocator like std allocator, except the pool is thread local rather than process wide
Activ::Time | Time class
Activ::Time::Hours | Hours class
Activ::Time::Milliseconds | Milliseconds class
Activ::Time::Minutes | Minutes class
Activ::Time::Seconds | Seconds class
Activ::Timeband | Timeband class
Activ::Timeband::Settings | Settings class
Activ::Timeout | Timeout handler function object class
Activ::TimerServiceApi | Api to the agent's timer service
Activ::TRational | Trended rational class
Activ::TRational::SerializedTrendDefinitions | Serialized trend definitions
Activ::TypeToIntegralType< T > | Template to determine ACTIV integral type from an arbitrary type, if possible
Activ::UdpComponent | Udp ingest component
Activ::UdpSocket | UDP socket class
Activ::UdpSocket::Settings | Settings
Activ::UdpSocket::Stats | Stats
Activ::UiComponent | Ui component class
Activ::UiIo | Ui io class. Provides methods to get input from and post input to a user
Activ::UiIo::Attribute | ANSI display attribute wrapper
Activ::UiIo::Columnizer | Helper class to calculate the column sizes to display a number of items
Activ::UiIo::CompletionHelper | Base class to handle tab-completion in the ui
Activ::UiIo::DynamicCompletionHelper | Class to handle tab-completion with a dynamic list of strings that may be different each time tab is hit
Activ::UiIo::StaticCompletionHelper | Class to handle tab-completion with a fixed list of strings
Activ::UiMainComponent | Main ui component
Activ::UiMainComponent::Menu | Main menu
Activ::UiMenu | Ui menu class
Activ::UiMenu::OptionAttributes | Option attributes
Activ::UInt | Unsigned integer class
Activ::UiPermissions | Ui permissions class
Activ::Url | Url parser & builder class
Activ::UtcTime | Utc time class
Activ::Uuid | Uuid class
Activ::WsaBufHelper | WSABUF helper class
Generated on Wed Oct 8 14:01:51 2008 for ACTIV C++ SDK by doxygen 1.5.4


  • Alphabetical List
  • Class List
  • Class Hierarchy
  • Class Members
Activ::Address

Activ::Address Class Reference

Address. More...

#include <ActivMiddleware/ActivSystem/Address.h>

List of all members.

Public Member Functions

ACTIV_SYSTEM_INLINE_API | Address (const EndPointId endPointId, const PortId portId)
Constructor.
ACTIV_SYSTEM_INLINE_API | Address ()
Default constructor.
ACTIV_SYSTEM_INLINE_API void | Clear ()
Clear the address.
ACTIV_SYSTEM_INLINE_API StatusCode | Deserialize (MessageValidator &messageValidator)
Deserialize the address.
ACTIV_SYSTEM_INLINE_API EndPointId | GetEndPointId () const
Get the endpoint id.
ACTIV_SYSTEM_INLINE_API PortId | GetPortId () const
Get the port id.
ACTIV_SYSTEM_INLINE_API bool | IsValid () const
Is this a valid address?
ACTIV_SYSTEM_INLINE_API bool | operator!= (const Address &rhs) const
'!=' operator.
ACTIV_SYSTEM_INLINE_API bool | operator< (const Address &rhs) const
'<' operator.
ACTIV_SYSTEM_INLINE_API bool | operator== (const Address &rhs) const
'==' operator.
ACTIV_SYSTEM_INLINE_API StatusCode | Serialize (MessageBuilder &messageBuilder) const
Serialize the address.
ACTIV_SYSTEM_INLINE_API void | Set (const EndPointId endPointId, const PortId portId)
Set the endpoint and port id.
ACTIV_SYSTEM_INLINE_API void | SetEndPointId (const EndPointId endPointId)
Set the endpoint id.
ACTIV_SYSTEM_INLINE_API void | SetPortId (const PortId portId)
Set the port id.
ACTIV_SYSTEM_INLINE_API std::string | ToString () const
Convert the address to a string.

Static Public Member Functions

static ACTIV_SYSTEM_INLINE_API
size_t 		GetSerializedLength ()
Get the serialized length of an Address object.

Classes

class | Proxy
Address proxy class. Used where an Address or ScopedAddress can be passed to a function. More...

Detailed Description

Address.

Definition at line 27 of file Address.h.

Constructor & Destructor Documentation

Activ::Address::Address ( ) [inline]

Default constructor.

The endpoint id is set to INVALID_ENDPOINT_ID and the port id to INVALID_PORT_ID.

Definition at line 217 of file Address.h.

References Clear().

Activ::Address::Address | ( | const EndPointId | endPointId,
 |  | const PortId | portId |
 | ) |  |  | [inline]

Constructor.

Parameters:
endPointId
portId

Definition at line 224 of file Address.h.

References SetEndPointId(), and SetPortId().

Member Function Documentation

void Activ::Address::Clear ( ) [inline]

Clear the address.

The endpoint id is set to INVALID_ENDPOINT_ID and the port id to INVALID_PORT_ID.

Definition at line 261 of file Address.h.

References SetEndPointId(), and SetPortId().

Referenced by Address(), Activ::RequestId::Clear(), Activ::ScopedAddress::operator=(), Activ::ScopedAddress::Release(), and Activ::RequestId::Set().

StatusCode Activ::Address::Deserialize ( MessageValidator & messageValidator ) [inline]

Deserialize the address.

Parameters:
messageValidator
Returns:
STATUS_CODE_SUCCESS or an error status code.

Definition at line 242 of file Address.h.

References ACTIV_RETURN_RESULT_IF, Activ::MessageHandler::ENDIAN_LITTLE, and Activ::MessageValidator::ValidateBinaryIntegral().

Referenced by Activ::RequestId::Deserialize().

EndPointId Activ::Address::GetEndPointId ( ) const [inline]

Get the endpoint id.

Returns:
the endpoint id.

Definition at line 269 of file Address.h.

Referenced by ToString().

PortId Activ::Address::GetPortId ( ) const [inline]

Get the port id.

Returns:
the port id.

Definition at line 283 of file Address.h.

Referenced by ToString().

size_t Activ::Address::GetSerializedLength ( ) [inline, static]

Get the serialized length of an Address object.

Returns:
The serialized length in bytes.

Definition at line 254 of file Address.h.

References ACTIV_FIELD_SIZE.

bool Activ::Address::IsValid ( ) const [inline]

Is this a valid address?

A valid address is one where endPointId is not INVALID_ENDPOINT_ID and portId is not INVALID_PORT_ID.

Returns:
Boolean.

Definition at line 315 of file Address.h.

Referenced by Activ::ScopedAddress::IsValid(), and Activ::RequestId::Set().

bool Activ::Address::operator!= ( const Address & rhs ) const [inline]

'!=' operator.

Parameters:
rhs Address to compare.
Returns:
Boolean.

Definition at line 329 of file Address.h.

bool Activ::Address::operator< ( const Address & rhs ) const [inline]

'<' operator.

Parameters:
rhs Address to compare.
Returns:
Boolean.

Definition at line 336 of file Address.h.

References m_endPointId, and m_portId.

bool Activ::Address::operator== ( const Address & rhs ) const [inline]

'==' operator.

Parameters:
rhs Address to compare.
Returns:
Boolean.

Definition at line 322 of file Address.h.

References m_endPointId, and m_portId.

StatusCode Activ::Address::Serialize ( MessageBuilder & messageBuilder ) const [inline]

Serialize the address.

Parameters:
messageBuilder
Returns:
STATUS_CODE_SUCCESS or an error status code.

Definition at line 232 of file Address.h.

References ACTIV_RETURN_RESULT_IF, Activ::MessageBuilder::Append(), and Activ::MessageHandler::ENDIAN_LITTLE.

Referenced by Activ::RequestId::Serialize().

void Activ::Address::Set | ( | const EndPointId | endPointId,
 |  | const PortId | portId |
 | ) |  |  | [inline]

Set the endpoint and port id.

Parameters:
endPointId | the endpoint id.
portId | the port id.

Definition at line 297 of file Address.h.

void Activ::Address::SetEndPointId ( const EndPointId endPointId ) [inline]

Set the endpoint id.

Parameters:
endPointId the endpoint id.

Definition at line 276 of file Address.h.

Referenced by Address(), and Clear().

void Activ::Address::SetPortId ( const PortId portId ) [inline]

Set the port id.

Parameters:
portId the port id.

Definition at line 290 of file Address.h.

Referenced by Address(), and Clear().

std::string Activ::Address::ToString ( ) const [inline]

Convert the address to a string.

Returns:
String representation of the address, in the form "endPointId:portId".

Definition at line 305 of file Address.h.

References ACTIV_ARRAY_SIZE, GetEndPointId(), and GetPortId().

Referenced by Activ::ScopedAddress::ToString().

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivSystem/Address.h
Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


  • Class Members
Activ::Address::Proxy

Activ::Address::Proxy Class Reference

Address proxy class. Used where an Address or ScopedAddress can be passed to a function. More...

#include <ActivMiddleware/ActivSystem/Address.h>

Inheritance diagram for Activ::Address::Proxy:

Activ::ScopedAddress::Proxy

List of all members.

Public Member Functions

ACTIV_SYSTEM_INLINE_API | operator Address & ()
Address reference cast operator.
ACTIV_SYSTEM_INLINE_API | Proxy (Address &address)
Constructor.

Detailed Description

Address proxy class. Used where an Address or ScopedAddress can be passed to a function.

E.g.

void SomeFunction(Address::Proxy address);

ScopedAddress scopedAddress(...); Address address(...);

SomeFunction(scopedAddress); SomeFunction(address);

Note the prototype of SomeFunction() uses Address::Proxy by value, not reference.

Definition at line 45 of file Address.h.

Constructor & Destructor Documentation

Activ::Address::Proxy::Proxy ( Address & address ) [inline]

Constructor.

Parameters:
address reference to the Address this object is to be a proxy for.

Definition at line 350 of file Address.h.

Member Function Documentation

Activ::Address::Proxy::operator Address & ( ) [inline]

Address reference cast operator.

Returns:
Reference to the Address this object is a proxy for.

Definition at line 358 of file Address.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivSystem/Address.h
Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::AgentApplication

Activ::AgentApplication Class Reference

Agent application class. More...

#include <ActivMiddleware/ActivAgentApplication/AgentApplication.h>

Inheritance diagram for Activ::AgentApplication:

Activ::Application Activ::SystemProxy Activ::ManagedEndPoint Activ::Component Activ::ISystem Activ::Port

List of all members.

Public Member Functions

ACTIV_AGENT_APPLICATION_API | AgentApplication (const Settings &settings=Settings(), const std::string &componentId=defaultComponentId)
Create a system.
ACTIV_AGENT_APPLICATION_API bool | IsSystemRestartable ()
Is the system restartable?
ACTIV_AGENT_APPLICATION_API
StatusCode 		RestartSystem ()
Initiate a system restart.
virtual ACTIV_AGENT_APPLICATION_API | ~AgentApplication ()
Destructor.

Protected Member Functions

virtual
ACTIV_AGENT_APPLICATION_API
bool 		CanThreadExit ()
Ok to exit this thread?
virtual
ACTIV_AGENT_APPLICATION_API
void 		OnCtrlEvent (const CtrlHandler::EventType eventType)
Application has received a ctrl event.
virtual
ACTIV_AGENT_APPLICATION_API
StatusCode 		OnMessage (HeapMessage &message)
Message callback.

Classes

class | Settings
Agent settings. More...

Detailed Description

Agent application class.

The AgentApplication class should be used when creating a shared memory system or stand alone process. It provides always on timer, logger, directory, router and pub-sub services.

Definition at line 38 of file AgentApplication.h.

Constructor & Destructor Documentation

ACTIV_AGENT_APPLICATION_API Activ::AgentApplication::AgentApplication | ( | const Settings & | settings = Settings(),
 |  | const std::string & | componentId = defaultComponentId
 | ) |  |

Create a system.

Parameters:
settings | agent settings.
componentId | the component id.
Exceptions:
Exception.

Member Function Documentation

virtual ACTIV_AGENT_APPLICATION_API bool Activ::AgentApplication::CanThreadExit ( ) [protected, virtual]

Ok to exit this thread?

Once a thread has received an exit message, CanThreadExit() will subsequently be invoked after processing of any message by that thread to determine if the thread can actually exit. Default behaviour is to return true.

Return values:
true | this thread can exit
false | this thread cannot exit

Reimplemented from Activ::ManagedEndPoint.

ACTIV_AGENT_APPLICATION_API bool Activ::AgentApplication::IsSystemRestartable ( )

Is the system restartable?

Returns:
true if system can be restarted.

virtual ACTIV_AGENT_APPLICATION_API void Activ::AgentApplication::OnCtrlEvent ( const CtrlHandler::EventType eventType ) [protected, virtual]

Application has received a ctrl event.

Parameters:
eventType the type of ctrl event.

Reimplemented from Activ::Application.

virtual ACTIV_AGENT_APPLICATION_API StatusCode Activ::AgentApplication::OnMessage ( HeapMessage & message ) [protected, virtual]

Message callback.

If you override this method, please call the base class method for any unrecognized message types.

Parameters:
message the message.
Return values:
STATUS_CODE_SUCCESS | the message was recognized.
STATUS_CODE_UNRECOGNIZED | the message was not recognized.
STATUS_CODE_THREAD_EXIT | received a thread-die message.
...

Reimplemented from Activ::Application.

ACTIV_AGENT_APPLICATION_API StatusCode Activ::AgentApplication::RestartSystem ( )

Initiate a system restart.

Returns:
STATUS_CODE_SUCCESS or error status if unable to initiate restart.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivAgentApplication/AgentApplication.h
Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::AgentApplication::Settings

Activ::AgentApplication::Settings Class Reference

Agent settings. More...

#include <ActivMiddleware/ActivAgentApplication/AgentApplication.h>

Inheritance diagram for Activ::AgentApplication::Settings:

Activ::Application::Settings Activ::ISystem::Settings

List of all members.

Public Member Functions

ACTIV_AGENT_APPLICATION_API
StatusCode 		Read (const IniFileParser &iniFileParser)
Read settings from an ini file.
ACTIV_AGENT_APPLICATION_API | Settings ()
Default constructor.
ACTIV_AGENT_APPLICATION_API | ~Settings ()
Default destructor.

Public Attributes

bool | m_createSystemLog
whether to create system log
DirectoryService::Settings | m_directoryServiceSettings
settings for directory service
bool | m_enableUiService
enable ui service (default == false)
bool | m_extendedUiShutdown
extended ui shutdown validation (default == false)
LicenseService::Settings | m_licenseServiceSettings
settings for license service
LoggerService::Settings | m_loggerServiceSettings
settings for logger service
MonitorService::Settings | m_monitorServiceSettings
monitor service settings
std::string | m_processStartupIniFile
ini file for processes to launch
PubSubService::Settings | m_pubSubServiceSettings
pubsub service settings
RouterService::Settings | m_routerServiceSettings
settings for router service
std::string | m_serviceLocationIniFile
service location ini file
IHeap::BucketInfoVector m_systemHeapBucketInfo
size of the system heap
uint64_t | m_systemLogMaxSize
max size if rolling log
size_t | m_systemLogNumberOfBackups
number of backups to keep for rolling log
LoggerDefinitions::FileType m_systemLogType
type of system log (rolling, daily etc)
bool | m_systemLogUniqueName
unique name for log
std::string | m_systemVersion
optional version of the system
TimerService::Settings | m_timerServiceSettings
settings for timer service
UiService::Settings | m_uiServiceSettings
settings for ui service

Detailed Description

Agent settings.

Definition at line 44 of file AgentApplication.h.

Member Function Documentation

ACTIV_AGENT_APPLICATION_API StatusCode Activ::AgentApplication::Settings::Read ( const IniFileParser & iniFileParser )

Read settings from an ini file.

Parameters:
iniFileParser already parsed ini file to get settings from.
Return values:
STATUS_CODE_SUCCESS
...

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivAgentApplication/AgentApplication.h
Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Application

Activ::Application Class Reference

Base application class. More...

#include <ActivMiddleware/ActivFramework/Application.h>

Inheritance diagram for Activ::Application:

Activ::SystemProxy Activ::ManagedEndPoint Activ::Component Activ::ISystem Activ::Port Activ::AgentApplication Activ::ThinApplication

List of all members.

Public Types

enum ShutdownReason {
SHUTDOWN_REASON_API, SHUTDOWN_REASON_UI, SHUTDOWN_REASON_UI_RESTART, SHUTDOWN_REASON_LOGOFF,
SHUTDOWN_REASON_PROCESS_KILLED, SHUTDOWN_REASON_UPDATING, SHUTDOWN_REASON_NOT_LICENSED
}
Shutdown reasons. More...

Public Member Functions

ACTIV_FRAMEWORK_API IHeap * | GetMonitorServiceHeap () const
Get the monitor service heap.
const Private & | GetPrivate () const
Get private implementation.
ACTIV_FRAMEWORK_API void | Shutdown ()
Initiate a shutdown.
virtual ACTIV_FRAMEWORK_API | ~Application ()
Destructor.

Static Public Member Functions

static ACTIV_FRAMEWORK_API
const std::string & 		GetUiServiceName ()
Get the name of the default ui service.

Protected Member Functions

virtual ACTIV_FRAMEWORK_API void | OnCtrlEvent (const CtrlHandler::EventType eventType)
Application has received a ctrl event.
virtual ACTIV_FRAMEWORK_API
StatusCode 		OnMessage (HeapMessage &message)
Message callback.
virtual ACTIV_FRAMEWORK_API void | OnShutdown (const ShutdownReason shutdownReason)
Shutdown has been invoked.

Friends

class | AgentApplication
class | ThinApplication

Classes

class | Settings
Settings. More...

Detailed Description

Base application class.

The base application class provides the ISystem interface to create and open heaps, endpoints. It also provides always on router and timer functionality and creates a default endpoint which is given the name of the process.

Do not use the Application class directly. AgentApplication is provided for processes which are to create a shared memory system or standalone private memory application, and ThinApplication for those which link into an existing shared memory system.

Definition at line 100 of file Application.h.

Member Enumeration Documentation

enum Activ::Application::ShutdownReason

Shutdown reasons.

Enumerator:
SHUTDOWN_REASON_API | Shutdown() called on Application object.
SHUTDOWN_REASON_UI | system shutdown initiated from UI service
SHUTDOWN_REASON_UI_RESTART | system restart initiated from UI service
SHUTDOWN_REASON_LOGOFF | system shutdown initiated due to OS shutting down / user logging off
SHUTDOWN_REASON_PROCESS_KILLED | ctrl-c, process close button, etc., has been hit
SHUTDOWN_REASON_UPDATING | UpdateService is shutting down, updating and restarting system.
SHUTDOWN_REASON_NOT_LICENSED | system is not licensed

Definition at line 144 of file Application.h.

Member Function Documentation

ACTIV_FRAMEWORK_API IHeap* Activ::Application::GetMonitorServiceHeap ( ) const

Get the monitor service heap.

The monitor service heap should be used for publishing monitoring messages.

Returns:
Heap used by the monitor service.

const Application::Private & Activ::Application::GetPrivate ( ) const [inline]

Get private implementation.

Returns:
Const reference to private implementation object.

Definition at line 249 of file Application.h.

static ACTIV_FRAMEWORK_API const std::string& Activ::Application::GetUiServiceName ( ) [static]

Get the name of the default ui service.

This name should be used when adding components to the ui service. See UiComponent.h.

Returns:
The name of the default ui service.

virtual ACTIV_FRAMEWORK_API void Activ::Application::OnCtrlEvent ( const CtrlHandler::EventType eventType ) [protected, virtual]

Application has received a ctrl event.

Parameters:
eventType the type of ctrl event.

Reimplemented in Activ::AgentApplication.

virtual ACTIV_FRAMEWORK_API StatusCode Activ::Application::OnMessage ( HeapMessage & message ) [protected, virtual]

Message callback.

If you override this method, please call the base class method for any unrecognized message types.

Parameters:
message the message.
Return values:
STATUS_CODE_SUCCESS | the message was recognized.
STATUS_CODE_UNRECOGNIZED | the message was not recognized.
STATUS_CODE_THREAD_EXIT | received a thread-die message.
...

Reimplemented from Activ::Component.

Reimplemented in Activ::AgentApplication, and Activ::ThinApplication.

virtual ACTIV_FRAMEWORK_API void Activ::Application::OnShutdown ( const ShutdownReason shutdownReason ) [protected, virtual]

Shutdown has been invoked.

This callback is invoked for all processes when a system is shutdown (i.e. the Agent has called AgentApplication::Shutdown()), or for a single application if it itself calls ThinApplication::Shutdown().

When overriding, call the base class method at the end of the override.

Parameters:
shutdownReason the reason for the shutdown.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivFramework/Application.h
Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Application::Settings

Activ::Application::Settings Class Reference

Settings. More...

#include <ActivMiddleware/ActivFramework/Application.h>

Inheritance diagram for Activ::Application::Settings:

Activ::ISystem::Settings Activ::AgentApplication::Settings Activ::ThinApplication::Settings

List of all members.

Public Types

enum | ExceptionHandlerType { EXCEPTION_HANDLER_TYPE_NONE, EXCEPTION_HANDLER_TYPE_NORMAL, EXCEPTION_HANDLER_TYPE_FULL_MEMORY }
List of exception handler types. More...

Public Member Functions

ACTIV_FRAMEWORK_API StatusCode | Read (const IniFileParser::ConstSectionIterator &sectionIterator)
Read settings from an ini file section.
ACTIV_FRAMEWORK_API | Settings ()
Default constructor.

Public Attributes

bool | m_enableCtrlHandler
default: true
ExceptionHandlerType m_exceptionHandlerType
default: EXCEPTION_HANDLER_TYPE_NONE
ManagedEndPoint::Settings m_managedEndPointSettings
settings for default application endpoint

Detailed Description

Settings.

Definition at line 106 of file Application.h.

Member Enumeration Documentation

enum Activ::Application::Settings::ExceptionHandlerType

List of exception handler types.

Exception handler on available on Windows platform.

Enumerator:
EXCEPTION_HANDLER_TYPE_NONE | no exception handler
EXCEPTION_HANDLER_TYPE_NORMAL | don't dump entire address space
EXCEPTION_HANDLER_TYPE_FULL_MEMORY | do dump address space

Definition at line 114 of file Application.h.

Member Function Documentation

ACTIV_FRAMEWORK_API StatusCode Activ::Application::Settings::Read ( const IniFileParser::ConstSectionIterator & sectionIterator )

Read settings from an ini file section.

Parameters:
sectionIterator iterator to an ini file section.
Return values:
STATUS_CODE_SUCCESS
...

Reimplemented from Activ::ISystem::Settings.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivFramework/Application.h
Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::AtomicInteger

Activ::AtomicInteger Class Reference

Atomic integer class. More...

#include <ActivMiddleware/ActivBase/Atomic.h>

List of all members.

Public Types

typedef long | Type

Public Member Functions

ACTIV_BASE_INLINE_API | AtomicInteger (const Type value)
Constructor.
ACTIV_BASE_INLINE_API | AtomicInteger ()
Default constructor.
ACTIV_BASE_INLINE_API Type | Exchange (const Type value)
Atomically exchange the value of the integer with a new value.
ACTIV_BASE_INLINE_API Type | Get () const
Get the value.
ACTIV_BASE_INLINE_API | operator Type () const
Cast to underlying type operator.
ACTIV_BASE_INLINE_API Type | operator++ (int)
Post-increment operator.
ACTIV_BASE_INLINE_API Type | operator++ ()
Pre-increment operator.
ACTIV_BASE_INLINE_API Type | operator-- (int)
Pre-decrement operator.
ACTIV_BASE_INLINE_API Type | operator-- ()
Pre-decrement operator.

Detailed Description

Atomic integer class.

Definition at line 22 of file Atomic.h.

Constructor & Destructor Documentation

Activ::AtomicInteger::AtomicInteger ( const Type value ) [inline, explicit]

Constructor.

Parameters:
value initial value of the integer.

Definition at line 101 of file Atomic.h.

References Exchange().

Member Function Documentation

AtomicInteger::Type Activ::AtomicInteger::Exchange ( const Type value ) [inline]

Atomically exchange the value of the integer with a new value.

Parameters:
value new value.
Returns:
The original value.

Definition at line 108 of file Atomic.h.

Referenced by AtomicInteger().

AtomicInteger::Type Activ::AtomicInteger::Get ( ) const [inline]

Get the value.

Returns:
The current value.

Definition at line 115 of file Atomic.h.

Referenced by operator Type().

AtomicInteger::Type Activ::AtomicInteger::operator++ ( int ) [inline]

Post-increment operator.

Returns:
The value of the integer before the increment.

Definition at line 129 of file Atomic.h.

AtomicInteger::Type Activ::AtomicInteger::operator++ ( ) [inline]

Pre-increment operator.

Returns:
The value of the integer after the increment.

Definition at line 122 of file Atomic.h.

AtomicInteger::Type Activ::AtomicInteger::operator-- ( int ) [inline]

Pre-decrement operator.

Returns:
The value of the integer before the decrement.

Definition at line 143 of file Atomic.h.

AtomicInteger::Type Activ::AtomicInteger::operator-- ( ) [inline]

Pre-decrement operator.

Returns:
The value of the integer after the decrement.

Definition at line 136 of file Atomic.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivBase/Atomic.h
Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::AtomicPointer

Activ::AtomicPointer< T > Class Template Reference

Atomic pointer class. More...

#include <ActivMiddleware/ActivBase/Atomic.h>

List of all members.

Public Types

typedef T * | Pointer

Public Member Functions

ACTIV_BASE_INLINE_API | AtomicPointer (const Pointer pointer)
Constructor.
ACTIV_BASE_INLINE_API | AtomicPointer ()
Default constructor.
ACTIV_BASE_INLINE_API Pointer | Exchange (const Pointer value)
Atomically exchange the value of the pointer with a new value.
ACTIV_BASE_INLINE_API | operator Pointer () const
Cast to underlying type operator.
ACTIV_BASE_INLINE_API Pointer | operator-> () const
Indirection operator.
ACTIV_BASE_INLINE_API
AtomicPointer & 		operator= (const Pointer value)
Set the value.

Detailed Description

template<typename T>
class Activ::AtomicPointer< T >

Atomic pointer class.

Parameters:
T type to point to.

Definition at line 164 of file Atomic.h.

Constructor & Destructor Documentation

template<typename T>
Activ::AtomicPointer< T >::AtomicPointer ( const Pointer pointer ) [inline, explicit]

Constructor.

Parameters:
pointer initial value of the pointer.

Definition at line 226 of file Atomic.h.

Member Function Documentation

template<typename T>
T * Activ::AtomicPointer< T >::Exchange ( const Pointer value ) [inline]

Atomically exchange the value of the pointer with a new value.

Parameters:
value new value.
Returns:
The original value.

Definition at line 234 of file Atomic.h.

Referenced by Activ::AtomicPointer< T >::operator=().

template<typename T>
T * Activ::AtomicPointer< T >::operator-> ( ) const [inline]

Indirection operator.

Returns:
Underlying pointer.

Definition at line 278 of file Atomic.h.

template<typename T>
AtomicPointer< T > & Activ::AtomicPointer< T >::operator= ( const Pointer value ) [inline]

Set the value.

Parameters:
value new value.
Returns:
*this.

Definition at line 260 of file Atomic.h.

References Activ::AtomicPointer< T >::Exchange().

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivBase/Atomic.h
Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::BaseException

Activ::BaseException Class Reference

ActivBase exception class. More...

#include <ActivMiddleware/ActivBase/BaseException.h>

Inheritance diagram for Activ::BaseException:

Activ::Exception

List of all members.

Public Types

enum | { ACTIV_DECLARE_ELEMENT_1_WITH_COMMA }
Enumeration of all BaseException errors.

Public Member Functions

ACTIV_BASE_EXPORTED_API | BaseException (const char *file, const char *function, const uint_fast32_t line, const uint_fast32_t errorCode)
Default constructor.
virtual
ACTIV_BASE_EXPORTED_API
std::string 		ToString () const
Convert the exception error code to a string.

Detailed Description

ActivBase exception class.

An exception of class BaseException is thrown only by classes inside ActivBase.

Definition at line 43 of file BaseException.h.

Constructor & Destructor Documentation

ACTIV_BASE_EXPORTED_API Activ::BaseException::BaseException | ( | const char * | file,
 |  | const char * | function,
 |  | const uint_fast32_t | line,
 |  | const uint_fast32_t | errorCode
 | ) |  |

Default constructor.

Parameters:
file | the file which raised the exception.
function | the function which raised the exception.
line | the line number which raised the exception.
errorCode | the exception specific error code.

Member Function Documentation

virtual ACTIV_BASE_EXPORTED_API std::string Activ::BaseException::ToString ( ) const [virtual]

Convert the exception error code to a string.

Classes derived from Exception are required to implement ToString() to convert their error codes to a readable string.

Returns:
the error code as a string.

Reimplemented from Activ::Exception.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivBase/BaseException.h
Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::BaseTime

Activ::BaseTime Class Reference

Base time class. More...

#include <ActivMiddleware/ActivFramework/TimeHelper.h>

Inheritance diagram for Activ::BaseTime:

Activ::LocalTime Activ::UtcTime

List of all members.

Public Types

typedef uint8_t | DayOfWeek
day of week type

Public Member Functions

ACTIV_FRAMEWORK_API std::string | DateToString () const
Convert date to a string.
ACTIV_FRAMEWORK_API StatusCode | Deserialize (MessageValidator &messageValidator)
Deserialize.
uint8_t | GetDay () const
Get the day.
DayOfWeek | GetDayOfWeek () const
Get the day of the week.
uint8_t | GetHour () const
Get the hour.
uint32_t | GetJulianTime () const
Get julian time (second resolution).
uint16_t | GetMillisecond () const
Get the millisecond.
uint8_t | GetMinute () const
Get the minute.
uint8_t | GetMonth () const
Get the month.
uint8_t | GetSecond () const
Get the second.
uint16_t | GetYear () const
Get the year.
bool | IsUtc () const
Is utc time?
ACTIV_FRAMEWORK_API bool | operator!= (const BaseTime &rhs) const
!= operator.
ACTIV_FRAMEWORK_API BaseTime & | operator+= (const Duration &duration)
+= operator.
ACTIV_FRAMEWORK_API BaseTime & | operator+= (const int64_t numberOfMilliseconds)
+= operator.
ACTIV_FRAMEWORK_API BaseTime & | operator-= (const Duration &duration)
-= operator.
ACTIV_FRAMEWORK_API BaseTime & | operator-= (const int64_t numberOfMilliseconds)
-= operator.
ACTIV_FRAMEWORK_API bool | operator< (const BaseTime &rhs) const
< operator.
ACTIV_FRAMEWORK_API bool | operator<= (const BaseTime &rhs) const
<= operator.
ACTIV_FRAMEWORK_API BaseTime & | operator= (const BaseTime &rhs)
Assignment operator.
ACTIV_FRAMEWORK_API bool | operator== (const BaseTime &rhs) const
== operator.
ACTIV_FRAMEWORK_API bool | operator> (const BaseTime &rhs) const
> operator.
ACTIV_FRAMEWORK_API bool | operator>= (const BaseTime &rhs) const
>= operator.
ACTIV_FRAMEWORK_API StatusCode | Serialize (MessageBuilder &messageBuilder) const
Serialize.
ACTIV_FRAMEWORK_API std::string | TimeToString (const bool shouldFormatMilliseconds=false) const
Convert time to a string.
ACTIV_FRAMEWORK_API std::string | ToString (const bool shouldFormatMilliseconds=false) const
Convert to a string.
virtual ACTIV_FRAMEWORK_API | ~BaseTime ()
Destructor.

Static Public Member Functions

static ACTIV_FRAMEWORK_API
std::string 		DayOfWeekToString (const DayOfWeek dayOfWeek, bool isShort=false)
Get day of week in string form.
static ACTIV_FRAMEWORK_API
std::string 		MonthToString (const uint8_t month, bool isShort=false)
Get month in string form.

Static Public Attributes

static const DayOfWeek | FRIDAY = 5
static const uint32_t | millisecondsPerDay = secondsPerDay * millisecondsPerSecond
static const uint32_t | millisecondsPerHour = secondsPerHour * millisecondsPerSecond
static const uint32_t | millisecondsPerMinute = secondsPerMinute * millisecondsPerSecond
static const uint32_t | millisecondsPerSecond = 1000
static const DayOfWeek | MONDAY = 1
static const DayOfWeek | SATURDAY = 6
static const uint32_t | secondsPerDay = 24 * secondsPerHour
static const uint32_t | secondsPerHour = 60 * secondsPerMinute
static const uint32_t | secondsPerMinute = 60
static const DayOfWeek | SUNDAY = 0
static const DayOfWeek | THURSDAY = 4
static const DayOfWeek | TUESDAY = 2
static const DayOfWeek | WEDSDAY = 3

Friends

class | LocalTime
class | UtcTime

Classes

class | Duration
Duration class. More...

Detailed Description

Base time class.

This class maintains both time in utc format and "formatted" format (local or utc).

Definition at line 26 of file TimeHelper.h.

Member Function Documentation

ACTIV_FRAMEWORK_API std::string Activ::BaseTime::DateToString ( ) const

Convert date to a string.

Returns:
A string containing date in current locale format.

static ACTIV_FRAMEWORK_API std::string Activ::BaseTime::DayOfWeekToString | ( | const DayOfWeek | dayOfWeek,
 |  | bool | isShort = false |
 | ) |  |  | [static]

Get day of week in string form.

Parameters:
dayOfWeek
isShort return short form of day of week.
Returns:
String representation of dayOfWeek.

ACTIV_FRAMEWORK_API StatusCode Activ::BaseTime::Deserialize ( MessageValidator & messageValidator )

Deserialize.

Parameters:
messageValidator validator to deserialize with.
Return values:
STATUS_CODE_SUCCESS.
...

uint8_t Activ::BaseTime::GetDay ( ) const [inline]

Get the day.

Returns:
The day.

Definition at line 489 of file TimeHelper.h.

Referenced by Activ::LocalTime::Get().

BaseTime::DayOfWeek Activ::BaseTime::GetDayOfWeek ( ) const [inline]

Get the day of the week.

Returns:
The day of the week.

Definition at line 496 of file TimeHelper.h.

uint8_t Activ::BaseTime::GetHour ( ) const [inline]

Get the hour.

Returns:
The hour.

Definition at line 503 of file TimeHelper.h.

Referenced by Activ::LocalTime::Get(), and GetJulianTime().

uint32_t Activ::BaseTime::GetJulianTime ( ) const [inline]

Get julian time (second resolution).

Returns:
Julian time.

Definition at line 531 of file TimeHelper.h.

References GetHour(), GetMinute(), and GetSecond().

uint16_t Activ::BaseTime::GetMillisecond ( ) const [inline]

Get the millisecond.

Returns:
The millisecond.

Definition at line 524 of file TimeHelper.h.

Referenced by Activ::LocalTime::Get().

uint8_t Activ::BaseTime::GetMinute ( ) const [inline]

Get the minute.

Returns:
The minute.

Definition at line 510 of file TimeHelper.h.

Referenced by Activ::LocalTime::Get(), and GetJulianTime().

uint8_t Activ::BaseTime::GetMonth ( ) const [inline]

Get the month.

Returns:
The month.

Definition at line 482 of file TimeHelper.h.

Referenced by Activ::LocalTime::Get().

uint8_t Activ::BaseTime::GetSecond ( ) const [inline]

Get the second.

Returns:
The second.

Definition at line 517 of file TimeHelper.h.

Referenced by Activ::LocalTime::Get(), and GetJulianTime().

uint16_t Activ::BaseTime::GetYear ( ) const [inline]

Get the year.

Returns:
The year.

Definition at line 475 of file TimeHelper.h.

Referenced by Activ::LocalTime::Get().

bool Activ::BaseTime::IsUtc ( ) const [inline]

Is utc time?

Returns:
True if Utc time, false for local.

Definition at line 538 of file TimeHelper.h.

static ACTIV_FRAMEWORK_API std::string Activ::BaseTime::MonthToString | ( | const uint8_t | month,
 |  | bool | isShort = false |
 | ) |  |  | [static]

Get month in string form.

Parameters:
month
isShort return short form of month.
Returns:
String representation of month.

ACTIV_FRAMEWORK_API bool Activ::BaseTime::operator!= ( const BaseTime & rhs ) const

!= operator.

Parameters:
rhs BaseTime object to compare with.
Returns:
boolean.

ACTIV_FRAMEWORK_API BaseTime& Activ::BaseTime::operator+= ( const Duration & duration )

+= operator.

Parameters:
duration duration to add to the time.
Returns:
boolean.

ACTIV_FRAMEWORK_API BaseTime& Activ::BaseTime::operator+= ( const int64_t numberOfMilliseconds )

+= operator.

Parameters:
numberOfMilliseconds number of milliseconds to add to the time.
Returns:
boolean.

ACTIV_FRAMEWORK_API BaseTime& Activ::BaseTime::operator-= ( const Duration & duration )

-= operator.

Parameters:
duration duration to subtract from the time.
Returns:
boolean.

ACTIV_FRAMEWORK_API BaseTime& Activ::BaseTime::operator-= ( const int64_t numberOfMilliseconds )

-= operator.

Parameters:
numberOfMilliseconds number of milliseconds to subtract from the time.
Returns:
boolean.

ACTIV_FRAMEWORK_API bool Activ::BaseTime::operator< ( const BaseTime & rhs ) const

< operator.

Parameters:
rhs BaseTime object to compare with.
Returns:
boolean.

ACTIV_FRAMEWORK_API bool Activ::BaseTime::operator<= ( const BaseTime & rhs ) const

<= operator.

Parameters:
rhs BaseTime object to compare with.
Returns:
boolean.

ACTIV_FRAMEWORK_API BaseTime& Activ::BaseTime::operator= ( const BaseTime & rhs )

Assignment operator.

Parameters:
rhs to copy from.
Returns:
*this.

ACTIV_FRAMEWORK_API bool Activ::BaseTime::operator== ( const BaseTime & rhs ) const

== operator.

Parameters:
rhs BaseTime object to compare with.
Returns:
boolean.

ACTIV_FRAMEWORK_API bool Activ::BaseTime::operator> ( const BaseTime & rhs ) const

> operator.

Parameters:
rhs BaseTime object to compare with.
Returns:
boolean.

ACTIV_FRAMEWORK_API bool Activ::BaseTime::operator>= ( const BaseTime & rhs ) const

>= operator.

Parameters:
rhs BaseTime object to compare with.
Returns:
boolean.

ACTIV_FRAMEWORK_API StatusCode Activ::BaseTime::Serialize ( MessageBuilder & messageBuilder ) const

Serialize.

Parameters:
messageBuilder builder to serialize with.
Return values:
STATUS_CODE_SUCCESS.
...

ACTIV_FRAMEWORK_API std::string Activ::BaseTime::TimeToString ( const bool shouldFormatMilliseconds = false ) const

Convert time to a string.

Parameters:
shouldFormatMilliseconds whether to put the millisecond portion in the string.
Returns:
A string containing time.

ACTIV_FRAMEWORK_API std::string Activ::BaseTime::ToString ( const bool shouldFormatMilliseconds = false ) const

Convert to a string.

Parameters:
shouldFormatMilliseconds whether to put the millisecond portion in the string.
Returns:
A string containing date and time in current locale.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivFramework/TimeHelper.h
Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::BaseTime::Duration

Activ::BaseTime::Duration Class Reference

Duration class. More...

#include <ActivMiddleware/ActivFramework/TimeHelper.h>

List of all members.

Public Member Functions

ACTIV_FRAMEWORK_API | Duration (const int32_t days, const int32_t hours, const int32_t minutes=0, const int32_t seconds=0, const int32_t milliseconds=0)
Constructor.
ACTIV_FRAMEWORK_API | Duration (const int64_t duration)
Constructor.
ACTIV_FRAMEWORK_API int64_t | GetTotalMilliseconds () const
Get the duration in milliseconds.
ACTIV_FRAMEWORK_API std::string | ToString () const
Convert the object to a string.

Detailed Description

Duration class.

Definition at line 51 of file TimeHelper.h.

Constructor & Destructor Documentation

ACTIV_FRAMEWORK_API Activ::BaseTime::Duration::Duration ( const int64_t duration )

Constructor.

Parameters:
duration in milliseconds.

ACTIV_FRAMEWORK_API Activ::BaseTime::Duration::Duration | ( | const int32_t | days,
 |  | const int32_t | hours,
 |  | const int32_t | minutes = 0,
 |  | const int32_t | seconds = 0,
 |  | const int32_t | milliseconds = 0
 | ) |  |

Constructor.

Parameters:
days | total days of duration.
hours | additional or total hours of duration.
minutes | additional or total minutes of duration.
seconds | additional or total seconds of duration.
milliseconds | additional or total milliseconds of duration.

Member Function Documentation

ACTIV_FRAMEWORK_API std::string Activ::BaseTime::Duration::ToString ( ) const

Convert the object to a string.

Returns:
the object as a string.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivFramework/TimeHelper.h
Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Binary

Activ::Binary< T, N, B > Class Template Reference

Convert a binary representation of a number. More...

#include <ActivMiddleware/BasicTypes.h>

List of all members.

Public Member Functions

BOOST_STATIC_ASSERT ((N%10)<=1)

Static Public Attributes

static const T value = (2 * (Binary<T, (N / 10), B + 1>::value)) + (N % 10)

Detailed Description

template<typename T, uint64_t N, uint8_t B = 0>
class Activ::Binary< T, N, B >

Convert a binary representation of a number.

T is the type to convert to. N is the binary value to convert. Do not have any leading 0s, otherwise the compiler will assume the value is octal. B is an implementation detail (leave as default).

Usage: uint32_t someValue = Binary<uin32_t, 10101010>::value; assert(someValue == 170);

Definition at line 812 of file BasicTypes.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/BasicTypes.h
Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::BinaryArray

Activ::BinaryArray Class Reference

Binary array class. More...

#include <ActivMiddleware/ActivFieldTypes/BinaryArray.h>

Inheritance diagram for Activ::BinaryArray:

Activ::IFieldType

List of all members.

Public Member Functions

BinaryArray (const BinaryArray &rhs)
Copy constructor.
BinaryArray (const uint8_t *const pData, const size_t size)
Constructor.
BinaryArray ()
Default constructor.
virtual void | Clear ()
Clear the object.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		Compare (const void *const pRhsSerializedBody, const size_t rhsSerializedBodyLength, int &result) const
Compare.
ACTIV_FIELD_TYPES_API StatusCode | Compare (const BinaryArray &rhs, int &result) const
Compare.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		Convert (const IFieldType *const pIFieldType)
Convert another IFieldType object to this type.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		Deserialize (MessageValidator &messageValidator, const size_t maxSerializedBodyLength)
Deserialize the object from the supplied message validator.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		DeserializeBody (const void *const pSerializedBody, const size_t serializedBodyLength)
Deserialize the object's body from the supplied data buffer.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		DeserializeLengthAndBody (MessageValidator &messageValidator, const size_t maxSerializedBodyLength=MAX_SERIALIZED_BODY_LENGTH_UNDEFINED)
Deserialize the object's length and body from the supplied message validator.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		FromString (MessageValidator &messageValidator)
Convert the object from a string.
StatusCode | Get (const uint8_t *&pData, size_t &size) const
Get the data and size.
const uint8_t * | GetData () const
Get the data.
virtual ACTIV_FIELD_TYPES_API
std::string 		GetFromStringFormat () const
Get a usage string for the format supported by FromString().
virtual size_t | GetSerializedBodyLength () const
Get the serialized length of the object's body.
virtual size_t | GetSerializedLength () const
Get the serialized length of the object.
size_t | GetSize () const
Get the size.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		IsDifferent (const void *const pRhsSerializedBody, const size_t rhsSerializedBodyLength, bool &isDifferent) const
Is different.
BinaryArray & | operator= (const BinaryArray &rhs)
Assignment operator.
virtual void | Reset ()
Reset the object.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		Serialize (MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength) const
Serialize the object into the supplied message builder.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		SerializeBody (void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength) const
Serialize the object's body into the supplied data buffer.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		SerializeLengthAndBody (MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength=MAX_SERIALIZED_BODY_LENGTH_UNDEFINED) const
Serialize the object's length and body into the supplied message builder.
StatusCode | Set (const uint8_t *const pData, const size_t size)
Set the data and size.
virtual ACTIV_FIELD_TYPES_API
std::string 		ToString (const bool isHexFormat) const
Convert the object to a string.
virtual ACTIV_FIELD_TYPES_API
std::string 		ToString () const
Convert the object to a string.
virtual | ~BinaryArray ()
Destructor.

Static Public Member Functions

static ACTIV_FIELD_TYPES_API
StatusCode 		Compare (const void *const pLhsSerializedBody, const size_t lhsSerializedBodyLength, const void *const pRhsSerializedBody, const size_t rhsSerializedBodyLength, int &result)
Compare two objects serialized bodies.
static ACTIV_FIELD_TYPES_API
StatusCode 		Deserialize (MessageValidator &messageValidator, const size_t maxSerializedBodyLength, const uint8_t *&pData, size_t &size)
Deserialize the object from the supplied message validator.
static ACTIV_FIELD_TYPES_API
StatusCode 		DeserializeBody (const void *const pSerializedBody, const size_t serializedBodyLength, const uint8_t *&pData, size_t &size)
Deserialize the object's body from the supplied data buffer.
static ACTIV_FIELD_TYPES_API
StatusCode 		DeserializeLengthAndBody (MessageValidator &messageValidator, const size_t maxSerializedBodyLength, const uint8_t *&pData, size_t &size)
Deserialize the object's length and body from the supplied message validator.
static size_t | GetMaxSerializedBodyLength (const size_t size)
Get the maximum serialized length of the object's body.
static size_t | GetMaxSerializedLength (const size_t size)
Get the maximum serialized length of the object.
static bool | IsValidSerializedBodyLength (const size_t serializedBodyLength)
Is valid serialized body length.
static ACTIV_FIELD_TYPES_API
StatusCode 		Serialize (MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength, const uint8_t *const pData, const size_t size)
Serialize the object into the supplied message builder.
static ACTIV_FIELD_TYPES_API
StatusCode 		SerializeBody (void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength, const uint8_t *const pData, const size_t size)
Serialize the object's body into the supplied data buffer.
static ACTIV_FIELD_TYPES_API
StatusCode 		SerializeLengthAndBody (MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength, const uint8_t *const pData, const size_t size)
Serialize the object's length and body into the supplied message builder.
static ACTIV_FIELD_TYPES_API
StatusCode 		ValidateSerializedLengthAndBody (MessageValidator &messageValidator, size_t &serializedBodyOffset, size_t &serializedBodyLength)
Validate the serialized length and body.

Static Public Attributes

static const FieldType | FIELD_TYPE = FIELD_TYPE_BINARY_ARRAY
The field type.

Detailed Description

Binary array class.

Definition at line 30 of file BinaryArray.h.

Constructor & Destructor Documentation

Activ::BinaryArray::BinaryArray | ( | const uint8_t *const | pData,
 |  | const size_t | size |
 | ) |  |  | [inline]

Constructor.

Parameters:
pData | pointer to the data.
size | the size of the data.
Exceptions:
StatusCodeException

Definition at line 329 of file BinaryArray.h.

References ACTIV_THROW_RESULT_IF, and Set().

Activ::BinaryArray::BinaryArray ( const BinaryArray & rhs ) [inline]

Copy constructor.

Parameters:
rhs the value to assign to this object.

Definition at line 339 of file BinaryArray.h.

References ACTIV_THROW_RESULT_IF, Activ::IFieldType::IsInitialized(), Activ::IFieldType::m_isInitialized, m_pData, m_size, and Set().

Member Function Documentation

static ACTIV_FIELD_TYPES_API StatusCode Activ::BinaryArray::Compare | ( | const void *const | pLhsSerializedBody,
 |  | const size_t | lhsSerializedBodyLength,
 |  | const void *const | pRhsSerializedBody,
 |  | const size_t | rhsSerializedBodyLength,
 |  | int & | result |
 | ) |  |  | [static]

Compare two objects serialized bodies.

Parameters:
pLhsSerializedBody | the buffer containing the lhs serialized version of the object's body in.
lhsSerializedBodyLength | the lhs serialized body length.
pRhsSerializedBody | the buffer containing the rhs serialized version of the object's body in.
rhsSerializedBodyLength | the rhs serialized body length.
result | the result of the comparison.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::BinaryArray::Compare | ( | const void *const | pRhsSerializedBody,
 |  | const size_t | rhsSerializedBodyLength,
 |  | int & | result |
 | ) |  |  | const [virtual]

Compare.

Parameters:
pRhsSerializedBody | the buffer containing the rhs serialized version of the object's body in.
rhsSerializedBodyLength | the rhs serialized body length.
result | the result of the comparison.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

ACTIV_FIELD_TYPES_API StatusCode Activ::BinaryArray::Compare | ( | const BinaryArray & | rhs,
 |  | int & | result |
 | ) |  |  | const

Compare.

Parameters:
rhs | the object to compare with.
result | the result of the comparison.
Return values:
STATUS_CODE_SUCCESS

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::BinaryArray::Convert ( const IFieldType *const pIFieldType ) [virtual]

Convert another IFieldType object to this type.

Parameters:
pIFieldType the value to assign from.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_MISMATCH
...

Implements Activ::IFieldType.

static ACTIV_FIELD_TYPES_API StatusCode Activ::BinaryArray::Deserialize | ( | MessageValidator & | messageValidator,
 |  | const size_t | maxSerializedBodyLength,
 |  | const uint8_t *& | pData,
 |  | size_t & | size |
 | ) |  |  | [static]

Deserialize the object from the supplied message validator.

Parameters:
messageValidator | the message validator from which the object will be extracted.
maxSerializedBodyLength | the maximum serialized body length.
pData | pointer to the data.
size | the size of the data.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
...

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::BinaryArray::Deserialize | ( | MessageValidator & | messageValidator,
 |  | const size_t | maxSerializedBodyLength |
 | ) |  |  | [virtual]

Deserialize the object from the supplied message validator.

Parameters:
messageValidator | the message validator from which the object will be extracted.
maxSerializedBodyLength | the maximum serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

static ACTIV_FIELD_TYPES_API StatusCode Activ::BinaryArray::DeserializeBody | ( | const void *const | pSerializedBody,
 |  | const size_t | serializedBodyLength,
 |  | const uint8_t *& | pData,
 |  | size_t & | size |
 | ) |  |  | [static]

Deserialize the object's body from the supplied data buffer.

Parameters:
pSerializedBody | the buffer from which the object's body will be extracted.
serializedBodyLength | the serialized body length.
pData | pointer to the data.
size | the size of the data.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::BinaryArray::DeserializeBody | ( | const void *const | pSerializedBody,
 |  | const size_t | serializedBodyLength |
 | ) |  |  | [virtual]

Deserialize the object's body from the supplied data buffer.

Parameters:
pSerializedBody | the buffer from which the object's body will be extracted.
serializedBodyLength | the serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

static ACTIV_FIELD_TYPES_API StatusCode Activ::BinaryArray::DeserializeLengthAndBody | ( | MessageValidator & | messageValidator,
 |  | const size_t | maxSerializedBodyLength,
 |  | const uint8_t *& | pData,
 |  | size_t & | size |
 | ) |  |  | [static]

Deserialize the object's length and body from the supplied message validator.

Parameters:
messageValidator | the message validator from which the object will be extracted.
maxSerializedBodyLength | the maximum serialized body length.
pData | pointer to the data.
size | the size of the data.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
...

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::BinaryArray::DeserializeLengthAndBody | ( | MessageValidator & | messageValidator,
 |  | const size_t | maxSerializedBodyLength = MAX_SERIALIZED_BODY_LENGTH_UNDEFINED |
 | ) |  |  | [virtual]

Deserialize the object's length and body from the supplied message validator.

Parameters:
messageValidator | the message validator from which the object will be extracted.
maxSerializedBodyLength | the maximum serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::BinaryArray::FromString ( MessageValidator & messageValidator ) [virtual]

Convert the object from a string.

Parameters:
messageValidator the message validator.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

StatusCode Activ::BinaryArray::Get | ( | const uint8_t *& | pData,
 |  | size_t & | size |
 | ) |  |  | const [inline]

Get the data and size.

Parameters:
pData | pointer to the data.
size | the size of the data.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED

Definition at line 406 of file BinaryArray.h.

References Activ::IFieldType::IsInitialized().

const uint8_t * Activ::BinaryArray::GetData ( ) const [inline]

Get the data.

Returns:
the pointer to the data.
Exceptions:
StatusCodeException

Definition at line 419 of file BinaryArray.h.

References ACTIV_THROW, and Activ::IFieldType::IsInitialized().

virtual ACTIV_FIELD_TYPES_API std::string Activ::BinaryArray::GetFromStringFormat ( ) const [virtual]

Get a usage string for the format supported by FromString().

Returns:
String, may be empty.

Implements Activ::IFieldType.

size_t Activ::BinaryArray::GetMaxSerializedBodyLength ( const size_t size ) [inline, static]

Get the maximum serialized length of the object's body.

Parameters:
size the size of the data.
Returns:
the maximum serialized length of the object's body.

Definition at line 481 of file BinaryArray.h.

Referenced by GetMaxSerializedLength(), and GetSerializedBodyLength().

size_t Activ::BinaryArray::GetMaxSerializedLength ( const size_t size ) [inline, static]

Get the maximum serialized length of the object.

Parameters:
size the size of the data.
Returns:
the maximum serialized length of the object.

Definition at line 474 of file BinaryArray.h.

References GetMaxSerializedBodyLength().

Referenced by GetSerializedLength().

size_t Activ::BinaryArray::GetSerializedBodyLength ( ) const [inline, virtual]

Get the serialized length of the object's body.

Returns:
the serialized length of the object's body.

Implements Activ::IFieldType.

Definition at line 467 of file BinaryArray.h.

References GetMaxSerializedBodyLength(), and Activ::IFieldType::IsInitialized().

size_t Activ::BinaryArray::GetSerializedLength ( ) const [inline, virtual]

Get the serialized length of the object.

Returns:
the serialized length of the object.

Implements Activ::IFieldType.

Definition at line 460 of file BinaryArray.h.

References GetMaxSerializedLength(), and Activ::IFieldType::IsInitialized().

size_t Activ::BinaryArray::GetSize ( ) const [inline]

Get the size.

Returns:
the size of the data.
Exceptions:
StatusCodeException

Definition at line 429 of file BinaryArray.h.

References ACTIV_THROW, and Activ::IFieldType::IsInitialized().

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::BinaryArray::IsDifferent | ( | const void *const | pRhsSerializedBody,
 |  | const size_t | rhsSerializedBodyLength,
 |  | bool & | isDifferent |
 | ) |  |  | const [virtual]

Is different.

Parameters:
pRhsSerializedBody | the buffer containing the rhs serialized version of the object's body in.
rhsSerializedBodyLength | the rhs serialized body length.
isDifferent | indicates whether the two objects are different.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

bool Activ::BinaryArray::IsValidSerializedBodyLength ( const size_t serializedBodyLength ) [inline, static]

Is valid serialized body length.

Parameters:
serializedBodyLength the serialized body length.
Returns:
whether the serialized body length is valid.

Definition at line 488 of file BinaryArray.h.

BinaryArray & Activ::BinaryArray::operator= ( const BinaryArray & rhs ) [inline]

Assignment operator.

Parameters:
rhs the value to assign to this object.
Returns:
a reference to this object.

Definition at line 360 of file BinaryArray.h.

References ACTIV_THROW_RESULT_IF, Activ::IFieldType::IsInitialized(), m_pData, m_size, Reset(), and Set().

static ACTIV_FIELD_TYPES_API StatusCode Activ::BinaryArray::Serialize | ( | MessageBuilder & | messageBuilder,
 |  | const size_t | maxSerializedBodyLength,
 |  | const uint8_t *const | pData,
 |  | const size_t | size |
 | ) |  |  | [static]

Serialize the object into the supplied message builder.

Parameters:
messageBuilder | the message builder to store a serialized version of the object in.
maxSerializedBodyLength | the maximum serialized body length.
pData | pointer to the data.
size | the size of the data.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
...

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::BinaryArray::Serialize | ( | MessageBuilder & | messageBuilder,
 |  | const size_t | maxSerializedBodyLength |
 | ) |  |  | const [virtual]

Serialize the object into the supplied message builder.

Parameters:
messageBuilder | the message builder to store a serialized version of the object in.
maxSerializedBodyLength | the maximum serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

static ACTIV_FIELD_TYPES_API StatusCode Activ::BinaryArray::SerializeBody | ( | void * | pSerializedBody,
 |  | const size_t | maxSerializedBodyLength,
 |  | size_t & | serializedBodyLength,
 |  | const uint8_t *const | pData,
 |  | const size_t | size |
 | ) |  |  | [static]

Serialize the object's body into the supplied data buffer.

Parameters:
pSerializedBody | the buffer to store a serialized version of the object's body in.
maxSerializedBodyLength | the maximum serialized body length.
serializedBodyLength | the serialized body length.
pData | pointer to the data.
size | the size of the data.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
...

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::BinaryArray::SerializeBody | ( | void * | pSerializedBody,
 |  | const size_t | maxSerializedBodyLength,
 |  | size_t & | serializedBodyLength |
 | ) |  |  | const [virtual]

Serialize the object's body into the supplied data buffer.

Parameters:
pSerializedBody | the buffer to store a serialized version of the object's body in.
maxSerializedBodyLength | the maximum serialized body length.
serializedBodyLength | the serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

static ACTIV_FIELD_TYPES_API StatusCode Activ::BinaryArray::SerializeLengthAndBody | ( | MessageBuilder & | messageBuilder,
 |  | const size_t | maxSerializedBodyLength,
 |  | const uint8_t *const | pData,
 |  | const size_t | size |
 | ) |  |  | [static]

Serialize the object's length and body into the supplied message builder.

Parameters:
messageBuilder | the message builder to store a serialized version of the object in.
maxSerializedBodyLength | the maximum serialized body length.
pData | pointer to the data.
size | the size of the data.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
...

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::BinaryArray::SerializeLengthAndBody | ( | MessageBuilder & | messageBuilder,
 |  | const size_t | maxSerializedBodyLength = MAX_SERIALIZED_BODY_LENGTH_UNDEFINED |
 | ) |  |  | const [virtual]

Serialize the object's length and body into the supplied message builder.

Parameters:
messageBuilder | the message builder to store a serialized version of the object in.
maxSerializedBodyLength | the maximum serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

StatusCode Activ::BinaryArray::Set | ( | const uint8_t *const | pData,
 |  | const size_t | size |
 | ) |  |  | [inline]

Set the data and size.

Parameters:
pData | pointer to the data.
size | the size of the data.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_HEAP_EMPTY
STATUS_CODE_INVALID_PARAMETER

Definition at line 379 of file BinaryArray.h.

References Activ::IFieldType::m_isInitialized.

Referenced by BinaryArray(), and operator=().

virtual ACTIV_FIELD_TYPES_API std::string Activ::BinaryArray::ToString ( const bool isHexFormat ) const [virtual]

Convert the object to a string.

Parameters:
isHexFormat indicates whether the data is copied in hex format.
Returns:
the object as a string.

virtual ACTIV_FIELD_TYPES_API std::string Activ::BinaryArray::ToString ( ) const [virtual]

Convert the object to a string.

Returns:
the object as a string.

Implements Activ::IFieldType.

static ACTIV_FIELD_TYPES_API StatusCode Activ::BinaryArray::ValidateSerializedLengthAndBody | ( | MessageValidator & | messageValidator,
 |  | size_t & | serializedBodyOffset,
 |  | size_t & | serializedBodyLength |
 | ) |  |  | [static]

Validate the serialized length and body.

Parameters:
messageValidator | the message validator.
serializedBodyOffset | the serialized body offset.
serializedBodyLength | the serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivFieldTypes/BinaryArray.h
Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::BinaryString

Activ::BinaryString Class Reference

Binary string class. More...

#include <ActivMiddleware/ActivFieldTypes/BinaryString.h>

Inheritance diagram for Activ::BinaryString:

Activ::IFieldType

List of all members.

Public Member Functions

BinaryString (const BinaryString &rhs)
Copy constructor.
BinaryString (const uint8_t *const pData, const size_t size)
Constructor.
BinaryString ()
Default constructor.
virtual void | Clear ()
Clear the object.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		Compare (const void *const pRhsSerializedBody, const size_t rhsSerializedBodyLength, int &result) const
Compare.
ACTIV_FIELD_TYPES_API StatusCode | Compare (const BinaryString &rhs, int &result) const
Compare.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		Convert (const IFieldType *const pIFieldType)
Convert another IFieldType object to this type.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		Deserialize (MessageValidator &messageValidator, const size_t maxSerializedBodyLength)
Deserialize the object from the supplied message validator.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		DeserializeBody (const void *const pSerializedBody, const size_t serializedBodyLength)
Deserialize the object's body from the supplied data buffer.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		DeserializeLengthAndBody (MessageValidator &messageValidator, const size_t maxSerializedBodyLength=MAX_SERIALIZED_BODY_LENGTH_UNDEFINED)
Deserialize the object's length and body from the supplied message validator.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		FromString (MessageValidator &messageValidator)
Convert the object from a string.
StatusCode | Get (const uint8_t *&pData, size_t &size) const
Get the data and size.
const uint8_t * | GetData () const
Get the data.
virtual ACTIV_FIELD_TYPES_API
std::string 		GetFromStringFormat () const
Get a usage string for the format supported by FromString().
virtual size_t | GetSerializedBodyLength () const
Get the serialized length of the object's body.
virtual size_t | GetSerializedLength () const
Get the serialized length of the object.
size_t | GetSize () const
Get the size.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		IsDifferent (const void *const pRhsSerializedBody, const size_t rhsSerializedBodyLength, bool &isDifferent) const
Is different.
BinaryString & | operator= (const BinaryString &rhs)
Assignment operator.
virtual void | Reset ()
Reset the object.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		Serialize (MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength) const
Serialize the object into the supplied message builder.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		SerializeBody (void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength) const
Serialize the object's body into the supplied data buffer.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		SerializeLengthAndBody (MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength=MAX_SERIALIZED_BODY_LENGTH_UNDEFINED) const
Serialize the object's length and body into the supplied message builder.
StatusCode | Set (const uint8_t *const pData, const size_t size)
Set the data and size.
virtual ACTIV_FIELD_TYPES_API
std::string 		ToString (const bool isHexFormat) const
Convert the object to a string.
virtual ACTIV_FIELD_TYPES_API
std::string 		ToString () const
Convert the object to a string.
virtual | ~BinaryString ()
Destructor.

Static Public Member Functions

static ACTIV_FIELD_TYPES_API
StatusCode 		Compare (const void *const pLhsSerializedBody, const size_t lhsSerializedBodyLength, const void *const pRhsSerializedBody, const size_t rhsSerializedBodyLength, int &result)
Compare two objects serialized bodies.
static ACTIV_FIELD_TYPES_API
StatusCode 		Deserialize (MessageValidator &messageValidator, const size_t maxSerializedBodyLength, const uint8_t *&pData, size_t &size)
Deserialize the object from the supplied message validator.
static ACTIV_FIELD_TYPES_API
StatusCode 		DeserializeBody (const void *const pSerializedBody, const size_t serializedBodyLength, const uint8_t *&pData, size_t &size)
Deserialize the object's body from the supplied data buffer.
static ACTIV_FIELD_TYPES_API
StatusCode 		DeserializeLengthAndBody (MessageValidator &messageValidator, const size_t maxSerializedBodyLength, const uint8_t *&pData, size_t &size)
Deserialize the object's length and body from the supplied message validator.
static size_t | GetMaxSerializedBodyLength (const size_t size)
Get the maximum serialized length of the object's body.
static size_t | GetMaxSerializedLength (const size_t size)
Get the maximum serialized length of the object.
static bool | IsValidSerializedBodyLength (const size_t serializedBodyLength)
Is valid serialized body length.
static ACTIV_FIELD_TYPES_API
StatusCode 		Serialize (MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength, const uint8_t *const pData, const size_t size)
Serialize the object into the supplied message builder.
static ACTIV_FIELD_TYPES_API
StatusCode 		SerializeBody (void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength, const uint8_t *const pData, const size_t size)
Serialize the object's body into the supplied data buffer.
static ACTIV_FIELD_TYPES_API
StatusCode 		SerializeLengthAndBody (MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength, const uint8_t *const pData, const size_t size)
Serialize the object's length and body into the supplied message builder.
static ACTIV_FIELD_TYPES_API
StatusCode 		ValidateSerializedLengthAndBody (MessageValidator &messageValidator, size_t &serializedBodyOffset, size_t &serializedBodyLength)
Validate the serialized length and body.

Static Public Attributes

static const FieldType | FIELD_TYPE = FIELD_TYPE_BINARY_STRING
The field type.

Detailed Description

Binary string class.

Definition at line 30 of file BinaryString.h.

Constructor & Destructor Documentation

Activ::BinaryString::BinaryString | ( | const uint8_t *const | pData,
 |  | const size_t | size |
 | ) |  |  | [inline]

Constructor.

Parameters:
pData | pointer to the data.
size | the size of the data.
Exceptions:
StatusCodeException

Definition at line 327 of file BinaryString.h.

References ACTIV_THROW_RESULT_IF, and Set().

Activ::BinaryString::BinaryString ( const BinaryString & rhs ) [inline]

Copy constructor.

Parameters:
rhs the value to assign to this object.

Definition at line 337 of file BinaryString.h.

References ACTIV_THROW_RESULT_IF, Activ::IFieldType::IsInitialized(), Activ::IFieldType::m_isInitialized, m_pData, m_size, and Set().

Member Function Documentation

static ACTIV_FIELD_TYPES_API StatusCode Activ::BinaryString::Compare | ( | const void *const | pLhsSerializedBody,
 |  | const size_t | lhsSerializedBodyLength,
 |  | const void *const | pRhsSerializedBody,
 |  | const size_t | rhsSerializedBodyLength,
 |  | int & | result |
 | ) |  |  | [static]

Compare two objects serialized bodies.

Parameters:
pLhsSerializedBody | the buffer containing the lhs serialized version of the object's body in.
lhsSerializedBodyLength | the lhs serialized body length.
pRhsSerializedBody | the buffer containing the rhs serialized version of the object's body in.
rhsSerializedBodyLength | the rhs serialized body length.
result | the result of the comparison.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::BinaryString::Compare | ( | const void *const | pRhsSerializedBody,
 |  | const size_t | rhsSerializedBodyLength,
 |  | int & | result |
 | ) |  |  | const [virtual]

Compare.

Parameters:
pRhsSerializedBody | the buffer containing the rhs serialized version of the object's body in.
rhsSerializedBodyLength | the rhs serialized body length.
result | the result of the comparison.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

ACTIV_FIELD_TYPES_API StatusCode Activ::BinaryString::Compare | ( | const BinaryString & | rhs,
 |  | int & | result |
 | ) |  |  | const

Compare.

Parameters:
rhs | the object to compare with.
result | the result of the comparison.
Return values:
STATUS_CODE_SUCCESS

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::BinaryString::Convert ( const IFieldType *const pIFieldType ) [virtual]

Convert another IFieldType object to this type.

Parameters:
pIFieldType the value to assign from.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_MISMATCH
...

Implements Activ::IFieldType.

static ACTIV_FIELD_TYPES_API StatusCode Activ::BinaryString::Deserialize | ( | MessageValidator & | messageValidator,
 |  | const size_t | maxSerializedBodyLength,
 |  | const uint8_t *& | pData,
 |  | size_t & | size |
 | ) |  |  | [static]

Deserialize the object from the supplied message validator.

Parameters:
messageValidator | the message validator from which the object will be extracted.
maxSerializedBodyLength | the maximum serialized body length.
pData | pointer to the data.
size | the size of the data.
Return values:
STATUS_CODE_SUCCESS
...

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::BinaryString::Deserialize | ( | MessageValidator & | messageValidator,
 |  | const size_t | maxSerializedBodyLength |
 | ) |  |  | [virtual]

Deserialize the object from the supplied message validator.

Parameters:
messageValidator | the message validator from which the object will be extracted.
maxSerializedBodyLength | the maximum serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

static ACTIV_FIELD_TYPES_API StatusCode Activ::BinaryString::DeserializeBody | ( | const void *const | pSerializedBody,
 |  | const size_t | serializedBodyLength,
 |  | const uint8_t *& | pData,
 |  | size_t & | size |
 | ) |  |  | [static]

Deserialize the object's body from the supplied data buffer.

Parameters:
pSerializedBody | the buffer from which the object's body will be extracted.
serializedBodyLength | the serialized body length.
pData | pointer to the data.
size | the size of the data.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::BinaryString::DeserializeBody | ( | const void *const | pSerializedBody,
 |  | const size_t | serializedBodyLength |
 | ) |  |  | [virtual]

Deserialize the object's body from the supplied data buffer.

Parameters:
pSerializedBody | the buffer from which the object's body will be extracted.
serializedBodyLength | the serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

static ACTIV_FIELD_TYPES_API StatusCode Activ::BinaryString::DeserializeLengthAndBody | ( | MessageValidator & | messageValidator,
 |  | const size_t | maxSerializedBodyLength,
 |  | const uint8_t *& | pData,
 |  | size_t & | size |
 | ) |  |  | [static]

Deserialize the object's length and body from the supplied message validator.

Parameters:
messageValidator | the message validator from which the object will be extracted.
maxSerializedBodyLength | the maximum serialized body length.
pData | pointer to the data.
size | the size of the data.
Return values:
STATUS_CODE_SUCCESS
...

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::BinaryString::DeserializeLengthAndBody | ( | MessageValidator & | messageValidator,
 |  | const size_t | maxSerializedBodyLength = MAX_SERIALIZED_BODY_LENGTH_UNDEFINED |
 | ) |  |  | [virtual]

Deserialize the object's length and body from the supplied message validator.

Parameters:
messageValidator | the message validator from which the object will be extracted.
maxSerializedBodyLength | the maximum serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::BinaryString::FromString ( MessageValidator & messageValidator ) [virtual]

Convert the object from a string.

Parameters:
messageValidator the message validator.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

StatusCode Activ::BinaryString::Get | ( | const uint8_t *& | pData,
 |  | size_t & | size |
 | ) |  |  | const [inline]

Get the data and size.

Parameters:
pData | pointer to the data.
size | the size of the data.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED

Definition at line 404 of file BinaryString.h.

References Activ::IFieldType::IsInitialized().

const uint8_t * Activ::BinaryString::GetData ( ) const [inline]

Get the data.

Returns:
the pointer to the data.
Exceptions:
StatusCodeException

Definition at line 417 of file BinaryString.h.

References ACTIV_THROW, and Activ::IFieldType::IsInitialized().

virtual ACTIV_FIELD_TYPES_API std::string Activ::BinaryString::GetFromStringFormat ( ) const [virtual]

Get a usage string for the format supported by FromString().

Returns:
String, may be empty.

Implements Activ::IFieldType.

size_t Activ::BinaryString::GetMaxSerializedBodyLength ( const size_t size ) [inline, static]

Get the maximum serialized length of the object's body.

Parameters:
size the size of the data.
Returns:
the maximum serialized length of the object's body.

Definition at line 479 of file BinaryString.h.

Referenced by GetMaxSerializedLength(), and GetSerializedBodyLength().

size_t Activ::BinaryString::GetMaxSerializedLength ( const size_t size ) [inline, static]

Get the maximum serialized length of the object.

Parameters:
size the size of the data.
Returns:
the maximum serialized length of the object.

Definition at line 472 of file BinaryString.h.

References GetMaxSerializedBodyLength().

Referenced by GetSerializedLength().

size_t Activ::BinaryString::GetSerializedBodyLength ( ) const [inline, virtual]

Get the serialized length of the object's body.

Returns:
the serialized length of the object's body.

Implements Activ::IFieldType.

Definition at line 465 of file BinaryString.h.

References GetMaxSerializedBodyLength(), and Activ::IFieldType::IsInitialized().

size_t Activ::BinaryString::GetSerializedLength ( ) const [inline, virtual]

Get the serialized length of the object.

Returns:
the serialized length of the object.

Implements Activ::IFieldType.

Definition at line 458 of file BinaryString.h.

References GetMaxSerializedLength(), and Activ::IFieldType::IsInitialized().

size_t Activ::BinaryString::GetSize ( ) const [inline]

Get the size.

Returns:
the size of the data.
Exceptions:
StatusCodeException

Definition at line 427 of file BinaryString.h.

References ACTIV_THROW, and Activ::IFieldType::IsInitialized().

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::BinaryString::IsDifferent | ( | const void *const | pRhsSerializedBody,
 |  | const size_t | rhsSerializedBodyLength,
 |  | bool & | isDifferent |
 | ) |  |  | const [virtual]

Is different.

Parameters:
pRhsSerializedBody | the buffer containing the rhs serialized version of the object's body in.
rhsSerializedBodyLength | the rhs serialized body length.
isDifferent | indicates whether the two objects are different.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

bool Activ::BinaryString::IsValidSerializedBodyLength ( const size_t serializedBodyLength ) [inline, static]

Is valid serialized body length.

Parameters:
serializedBodyLength the serialized body length.
Returns:
whether the serialized body length is valid.

Definition at line 486 of file BinaryString.h.

BinaryString & Activ::BinaryString::operator= ( const BinaryString & rhs ) [inline]

Assignment operator.

Parameters:
rhs the value to assign to this object.
Returns:
a reference to this object.

Definition at line 358 of file BinaryString.h.

References ACTIV_THROW_RESULT_IF, Activ::IFieldType::IsInitialized(), m_pData, m_size, Reset(), and Set().

static ACTIV_FIELD_TYPES_API StatusCode Activ::BinaryString::Serialize | ( | MessageBuilder & | messageBuilder,
 |  | const size_t | maxSerializedBodyLength,
 |  | const uint8_t *const | pData,
 |  | const size_t | size |
 | ) |  |  | [static]

Serialize the object into the supplied message builder.

Parameters:
messageBuilder | the message builder to store a serialized version of the object in.
maxSerializedBodyLength | the maximum serialized body length.
pData | pointer to the data.
size | the size of the data.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
...

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::BinaryString::Serialize | ( | MessageBuilder & | messageBuilder,
 |  | const size_t | maxSerializedBodyLength |
 | ) |  |  | const [virtual]

Serialize the object into the supplied message builder.

Parameters:
messageBuilder | the message builder to store a serialized version of the object in.
maxSerializedBodyLength | the maximum serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

static ACTIV_FIELD_TYPES_API StatusCode Activ::BinaryString::SerializeBody | ( | void * | pSerializedBody,
 |  | const size_t | maxSerializedBodyLength,
 |  | size_t & | serializedBodyLength,
 |  | const uint8_t *const | pData,
 |  | const size_t | size |
 | ) |  |  | [static]

Serialize the object's body into the supplied data buffer.

Parameters:
pSerializedBody | the buffer to store a serialized version of the object's body in.
maxSerializedBodyLength | the maximum serialized body length.
serializedBodyLength | the serialized body length.
pData | pointer to the data.
size | the size of the data.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
...

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::BinaryString::SerializeBody | ( | void * | pSerializedBody,
 |  | const size_t | maxSerializedBodyLength,
 |  | size_t & | serializedBodyLength |
 | ) |  |  | const [virtual]

Serialize the object's body into the supplied data buffer.

Parameters:
pSerializedBody | the buffer to store a serialized version of the object's body in.
maxSerializedBodyLength | the maximum serialized body length.
serializedBodyLength | the serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

static ACTIV_FIELD_TYPES_API StatusCode Activ::BinaryString::SerializeLengthAndBody | ( | MessageBuilder & | messageBuilder,
 |  | const size_t | maxSerializedBodyLength,
 |  | const uint8_t *const | pData,
 |  | const size_t | size |
 | ) |  |  | [static]

Serialize the object's length and body into the supplied message builder.

Parameters:
messageBuilder | the message builder to store a serialized version of the object in.
maxSerializedBodyLength | the maximum serialized body length.
pData | pointer to the data.
size | the size of the data.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
...

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::BinaryString::SerializeLengthAndBody | ( | MessageBuilder & | messageBuilder,
 |  | const size_t | maxSerializedBodyLength = MAX_SERIALIZED_BODY_LENGTH_UNDEFINED |
 | ) |  |  | const [virtual]

Serialize the object's length and body into the supplied message builder.

Parameters:
messageBuilder | the message builder to store a serialized version of the object in.
maxSerializedBodyLength | the maximum serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

StatusCode Activ::BinaryString::Set | ( | const uint8_t *const | pData,
 |  | const size_t | size |
 | ) |  |  | [inline]

Set the data and size.

Parameters:
pData | pointer to the data.
size | the size of the data.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_HEAP_EMPTY
STATUS_CODE_INVALID_PARAMETER

Definition at line 377 of file BinaryString.h.

References Activ::IFieldType::m_isInitialized.

Referenced by BinaryString(), and operator=().

virtual ACTIV_FIELD_TYPES_API std::string Activ::BinaryString::ToString ( const bool isHexFormat ) const [virtual]

Convert the object to a string.

Parameters:
isHexFormat indicates whether the data is copied in hex format.
Returns:
the object as a string.

virtual ACTIV_FIELD_TYPES_API std::string Activ::BinaryString::ToString ( ) const [virtual]

Convert the object to a string.

Returns:
the object as a string.

Implements Activ::IFieldType.

static ACTIV_FIELD_TYPES_API StatusCode Activ::BinaryString::ValidateSerializedLengthAndBody | ( | MessageValidator & | messageValidator,
 |  | size_t & | serializedBodyOffset,
 |  | size_t & | serializedBodyLength |
 | ) |  |  | [static]

Validate the serialized length and body.

Parameters:
messageValidator | the message validator.
serializedBodyOffset | the serialized body offset.
serializedBodyLength | the serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivFieldTypes/BinaryString.h
Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::BitField

Activ::BitField< T, OFFSET_VALUE, LENGTH_VALUE > Class Template Reference

Bit field helper class. More...

#include <ActivMiddleware/Misc/BitFields.h>

List of all members.

Public Types

typedef T | Bitmap

Public Member Functions

BOOST_STATIC_ASSERT ((OFFSET+LENGTH)<=(sizeof(Bitmap)*CHAR_BIT))

Static Public Member Functions

static Bitmap | GetMaxValue ()
Get the maximum value a bit field can hold.
static Bitmap | GetShifted (const Bitmap bitmap)
Get the right-shifted value of a bitfield.
static Bitmap | GetUnshifted (const Bitmap bitmap)
Get the unshifted value of a bitfield.
static void | Set (Bitmap &bitmap, const Bitmap value)
Set the value of a bitfield.

Static Public Attributes

static const size_t | LENGTH = LENGTH_VALUE
static const Bitmap | MASK = ((Bitmap(1) << LENGTH) - 1) << OFFSET
static const size_t | OFFSET = OFFSET_VALUE

Detailed Description

template<typename T, size_t OFFSET_VALUE, size_t LENGTH_VALUE>
class Activ::BitField< T, OFFSET_VALUE, LENGTH_VALUE >

Bit field helper class.

Generally this class won't be used directly. The derived FirstBitField and NextBitField would be used, e.g.

struct MyBitmap { typedef FirstBitField<uint8_t, 2> Length; typedef NextBitField<Length, 4> MessageType; typedef NextBitField<MessageType, 2> UserData; };

Parameters:
T | type of the bitmap (uint8_t, uint16_t, etc.).
OFFSET_VALUE | 0 based offset of the bitfield within the bitmap.
LENGTH_VALUE | length of the bitfield in bits.

Definition at line 36 of file BitFields.h.

Member Function Documentation

template<typename T, size_t OFFSET_VALUE, size_t LENGTH_VALUE>
T Activ::BitField< T, OFFSET_VALUE, LENGTH_VALUE >::GetMaxValue ( ) [inline, static]

Get the maximum value a bit field can hold.

Returns:
The max value.

Definition at line 121 of file BitFields.h.

Referenced by Activ::BitField< T, OFFSET_VALUE, LENGTH_VALUE >::Set().

template<typename T, size_t OFFSET_VALUE, size_t LENGTH_VALUE>
T Activ::BitField< T, OFFSET_VALUE, LENGTH_VALUE >::GetShifted ( const Bitmap bitmap ) [inline, static]

Get the right-shifted value of a bitfield.

E.g. MyBitmap::BitmapType bitmap = 0; MyBitmap::MessageType::Set(bitmap, 0x0f); MyBitmap::MessageType::GetShifted(bitmap) == 0x0f

Parameters:
bitmap the bitmap from which to retrieve the field.
Returns:
The bitmap with all other fields masked away and shifted to the right.

Definition at line 102 of file BitFields.h.

template<typename T, size_t OFFSET_VALUE, size_t LENGTH_VALUE>
T Activ::BitField< T, OFFSET_VALUE, LENGTH_VALUE >::GetUnshifted ( const Bitmap bitmap ) [inline, static]

Get the unshifted value of a bitfield.

E.g. MyBitmap::BitmapType bitmap = 0; MyBitmap::MessageType::Set(bitmap, 0x0f); MyBitmap::MessageType::GetUnshifted(bitmap) == 0x3c

Parameters:
bitmap the bitmap from which to retrieve the field.
Returns:
The bitmap with all other fields masked away.

Definition at line 94 of file BitFields.h.

template<typename T, size_t OFFSET_VALUE, size_t LENGTH_VALUE>
void Activ::BitField< T, OFFSET_VALUE, LENGTH_VALUE >::Set | ( | Bitmap & | bitmap,
 |  | const Bitmap | value |
 | ) |  |  | [inline, static]

Set the value of a bitfield.

Parameters:
bitmap | the bitmap in which to set the bitfield.
value | the value of the field to set.

Definition at line 110 of file BitFields.h.

References Activ::BitField< T, OFFSET_VALUE, LENGTH_VALUE >::GetMaxValue().

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/Misc/BitFields.h
Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Blob

Activ::Blob Class Reference

Blob class. More...

#include <ActivMiddleware/ActivFieldTypes/Blob.h>

Inheritance diagram for Activ::Blob:

Activ::IFieldType

List of all members.

Public Member Functions

Blob (const Blob &rhs)
Copy constructor.
Blob (const uint8_t *const pData, const size_t size)
Constructor.
Blob (const uint8_t *const pData, const size_t size, const size_t sizeWhenDecompressed)
Constructor.
Blob ()
Default constructor.
virtual void | Clear ()
Clear the object.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		Compare (const void *const pRhsSerializedBody, const size_t rhsSerializedBodyLength, int &result) const
Compare.
ACTIV_FIELD_TYPES_API StatusCode | Compare (const Blob &rhs, int &result) const
Compare.
StatusCode | Compress (bool shouldSerializeCompressed, bool shouldForceSerializeCompressed=false)
Compress.
StatusCode | Compress () const
Compress.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		Convert (const IFieldType *const pIFieldType)
Convert another IFieldType object to this type.
StatusCode | Decompress (bool shouldSerializeDecompressed)
Decompress.
StatusCode | Decompress () const
Decompress.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		Deserialize (MessageValidator &messageValidator, const size_t maxSerializedBodyLength)
Deserialize the object from the supplied message validator.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		DeserializeBody (const void *const pSerializedBody, const size_t serializedBodyLength)
Deserialize the object's body from the supplied data buffer.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		DeserializeLengthAndBody (MessageValidator &messageValidator, const size_t maxSerializedBodyLength=MAX_SERIALIZED_BODY_LENGTH_UNDEFINED)
Deserialize the object's length and body from the supplied message validator.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		FromString (MessageValidator &messageValidator)
Convert the object from a string.
StatusCode | Get (const uint8_t *&pData, size_t &size) const
Get the data and size.
StatusCode | Get (const uint8_t *&pData, size_t &size, size_t &sizeWhenDecompressed) const
Get the data, size and decompressed size.
const uint8_t * | GetData () const
Get the data.
const uint8_t * | GetDataCompressed () const
Get the data compressed.
const uint8_t * | GetDataDecompressed () const
Get the data decompressed.
virtual ACTIV_FIELD_TYPES_API
std::string 		GetFromStringFormat () const
Get a usage string for the format supported by FromString().
virtual size_t | GetSerializedBodyLength () const
Get the serialized length of the object's body.
virtual size_t | GetSerializedLength () const
Get the serialized length of the object.
size_t | GetSize () const
Get the size of the data.
size_t | GetSizeCompressed () const
Get the size of the data compressed.
size_t | GetSizeDecompressed () const
Get the size of the data decompressed.
size_t | GetSizeWhenDecompressed () const
Get the size when decompressed.
bool | IsCompressed () const
Is the data compressed.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		IsDifferent (const void *const pRhsSerializedBody, const size_t rhsSerializedBodyLength, bool &isDifferent) const
Is different.
Blob & | operator= (const Blob &rhs)
Assignment operator.
virtual void | Reset ()
Reset the object.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		Serialize (MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength) const
Serialize the object into the supplied message builder.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		SerializeBody (void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength) const
Serialize the object's body into the supplied data buffer.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		SerializeLengthAndBody (MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength=MAX_SERIALIZED_BODY_LENGTH_UNDEFINED) const
Serialize the object's length and body into the supplied message builder.
StatusCode | Set (const uint8_t *const pData, const size_t size)
Set the data and size.
StatusCode | Set (const uint8_t *const pData, const size_t size, const size_t sizeWhenDecompressed)
Set the data, size and decompressed size.
virtual ACTIV_FIELD_TYPES_API
std::string 		ToString (const bool isHexFormat) const
Convert the object to a string.
virtual ACTIV_FIELD_TYPES_API
std::string 		ToString () const
Convert the object to a string.
virtual | ~Blob ()
Destructor.

Static Public Member Functions

static ACTIV_FIELD_TYPES_API
StatusCode 		Compare (const void *const pLhsSerializedBody, const size_t lhsSerializedBodyLength, const void *const pRhsSerializedBody, const size_t rhsSerializedBodyLength, int &result)
Compare two objects serialized bodies.
static StatusCode | Compress (const uint8_t *const pSource, const size_t sourceLength, uint8_t *const pTarget, const size_t targetSize, size_t &targetLength)
Compress a buffer.
static StatusCode | Decompress (const uint8_t *const pSource, const size_t sourceLength, uint8_t *const pTarget, const size_t targetSize, size_t &targetLength)
Decompress a buffer.
static ACTIV_FIELD_TYPES_API
StatusCode 		Deserialize (MessageValidator &messageValidator, const size_t maxSerializedBodyLength, const uint8_t *&pData, size_t &size, size_t &sizeWhenDecompressed)
Deserialize the object from the supplied message validator.
static ACTIV_FIELD_TYPES_API
StatusCode 		DeserializeBody (const void *const pSerializedBody, const size_t serializedBodyLength, const uint8_t *&pData, size_t &size, size_t &sizeWhenDecompressed)
Deserialize the object's body from the supplied data buffer.
static ACTIV_FIELD_TYPES_API
StatusCode 		DeserializeLengthAndBody (MessageValidator &messageValidator, const size_t maxSerializedBodyLength, const uint8_t *&pData, size_t &size, size_t &sizeWhenDecompressed)
Deserialize the object's length and body from the supplied message validator.
static size_t | GetMaxSerializedBodyLength (const size_t size)
Get the maximum serialized length of the object's body.
static size_t | GetMaxSerializedLength (const size_t size)
Get the maximum serialized length of the object.
static bool | IsValidSerializedBodyLength (const size_t serializedBodyLength)
Is valid serialized body length.
static ACTIV_FIELD_TYPES_API
StatusCode 		Serialize (MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength, const uint8_t *const pData, const size_t size, const size_t sizeWhenDecompressed=0)
Serialize the object into the supplied message builder.
static ACTIV_FIELD_TYPES_API
StatusCode 		SerializeBody (void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength, const uint8_t *const pData, const size_t size, const size_t sizeWhenDecompressed=0)
Serialize the object's body into the supplied data buffer.
static ACTIV_FIELD_TYPES_API
StatusCode 		SerializeLengthAndBody (MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength, const uint8_t *const pData, const size_t size, const size_t sizeWhenDecompressed=0)
Serialize the object's length and body into the supplied message builder.
static ACTIV_FIELD_TYPES_API
StatusCode 		ValidateSerializedLengthAndBody (MessageValidator &messageValidator, size_t &serializedBodyOffset, size_t &serializedBodyLength)
Validate the serialized length and body.

Static Public Attributes

static const FieldType | FIELD_TYPE = FIELD_TYPE_BLOB
The field type.

Detailed Description

Blob class.

Definition at line 33 of file Blob.h.

Constructor & Destructor Documentation

Activ::Blob::Blob | ( | const uint8_t *const | pData,
 |  | const size_t | size,
 |  | const size_t | sizeWhenDecompressed |
 | ) |  |  | [inline]

Constructor.

Parameters:
pData | pointer to the data.
size | the size of the data.
sizeWhenDecompressed | indicates the size of the data when decompressed (zero indicates uncompressed).
Exceptions:
StatusCodeException

Definition at line 513 of file Blob.h.

References ACTIV_THROW_RESULT_IF, and Set().

Activ::Blob::Blob | ( | const uint8_t *const | pData,
 |  | const size_t | size |
 | ) |  |  | [inline]

Constructor.

The data will be stored compressed (if size >= compressed size).

Parameters:
pData | pointer to the data.
size | the size of the data.
Exceptions:
StatusCodeException

Definition at line 523 of file Blob.h.

References ACTIV_THROW_RESULT_IF, and Set().

Activ::Blob::Blob ( const Blob & rhs ) [inline]

Copy constructor.

Parameters:
rhs the value to assign to this object.

Definition at line 533 of file Blob.h.

References ACTIV_THROW_RESULT_IF, Activ::IFieldType::IsInitialized(), Activ::IFieldType::m_isInitialized, m_pData, m_size, m_sizeWhenDecompressed, and Set().

Member Function Documentation

static ACTIV_FIELD_TYPES_API StatusCode Activ::Blob::Compare | ( | const void *const | pLhsSerializedBody,
 |  | const size_t | lhsSerializedBodyLength,
 |  | const void *const | pRhsSerializedBody,
 |  | const size_t | rhsSerializedBodyLength,
 |  | int & | result |
 | ) |  |  | [static]

Compare two objects serialized bodies.

Parameters:
pLhsSerializedBody | the buffer containing the lhs serialized version of the object's body in.
lhsSerializedBodyLength | the lhs serialized body length.
pRhsSerializedBody | the buffer containing the rhs serialized version of the object's body in.
rhsSerializedBodyLength | the rhs serialized body length.
result | the result of the comparison.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::Blob::Compare | ( | const void *const | pRhsSerializedBody,
 |  | const size_t | rhsSerializedBodyLength,
 |  | int & | result |
 | ) |  |  | const [virtual]

Compare.

Parameters:
pRhsSerializedBody | the buffer containing the rhs serialized version of the object's body in.
rhsSerializedBodyLength | the rhs serialized body length.
result | the result of the comparison.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

ACTIV_FIELD_TYPES_API StatusCode Activ::Blob::Compare | ( | const Blob & | rhs,
 |  | int & | result |
 | ) |  |  | const

Compare.

Parameters:
rhs | the object to compare with.
result | the result of the comparison.
Return values:
STATUS_CODE_SUCCESS

StatusCode Activ::Blob::Compress | ( | const uint8_t *const | pSource,
 |  | const size_t | sourceLength,
 |  | uint8_t *const | pTarget,
 |  | const size_t | targetSize,
 |  | size_t & | targetLength |
 | ) |  |  | [inline, static]

Compress a buffer.

Parameters:
pSource | the source buffer.
sourceLength | the source buffer length.
pTarget | the target buffer.
targetSize | the size of the target buffer.
targetLength | the target buffer length.
Return values:
STATUS_CODE_SUCCESS
...

Definition at line 895 of file Blob.h.

StatusCode Activ::Blob::Compress | ( | bool | shouldSerializeCompressed,
 |  | bool | shouldForceSerializeCompressed = false |
 | ) |  |  | [inline]

Compress.

Parameters:
shouldSerializeCompressed | indicates whether the object should be serialized compressed (only if compressed size < decompressed size).
shouldForceSerializeCompressed | indicates whether should force the object should be serialized compressed.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_HEAP_EMPTY
STATUS_CODE_NOT_INITIALIZED
...

Definition at line 808 of file Blob.h.

References ACTIV_RETURN_RESULT_IF, and Compress().

StatusCode Activ::Blob::Compress ( ) const [inline]

Compress.

Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_HEAP_EMPTY
STATUS_CODE_NOT_INITIALIZED
...

Definition at line 779 of file Blob.h.

References ACTIV_RETURN_RESULT_IF, and Activ::IFieldType::IsInitialized().

Referenced by Compress(), GetDataCompressed(), GetSizeCompressed(), and Set().

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::Blob::Convert ( const IFieldType *const pIFieldType ) [virtual]

Convert another IFieldType object to this type.

Parameters:
pIFieldType the value to assign from.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_MISMATCH
...

Implements Activ::IFieldType.

StatusCode Activ::Blob::Decompress | ( | const uint8_t *const | pSource,
 |  | const size_t | sourceLength,
 |  | uint8_t *const | pTarget,
 |  | const size_t | targetSize,
 |  | size_t & | targetLength |
 | ) |  |  | [inline, static]

Decompress a buffer.

Parameters:
pSource | the source buffer.
sourceLength | the source buffer length.
pTarget | the target buffer.
targetSize | the size of the target buffer.
targetLength | the target buffer length.
Return values:
STATUS_CODE_SUCCESS
...

Definition at line 902 of file Blob.h.

StatusCode Activ::Blob::Decompress ( bool shouldSerializeDecompressed ) [inline]

Decompress.

Parameters:
shouldSerializeDecompressed indicates whether the object should be serialized decompressed.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_HEAP_EMPTY
STATUS_CODE_NOT_INITIALIZED
...

Definition at line 851 of file Blob.h.

References ACTIV_RETURN_RESULT_IF, and Decompress().

StatusCode Activ::Blob::Decompress ( ) const [inline]

Decompress.

Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_HEAP_EMPTY
STATUS_CODE_NOT_INITIALIZED
...

Definition at line 824 of file Blob.h.

References ACTIV_RETURN_RESULT_IF, and Activ::IFieldType::IsInitialized().

Referenced by Decompress(), Get(), GetDataDecompressed(), and GetSizeDecompressed().

static ACTIV_FIELD_TYPES_API StatusCode Activ::Blob::Deserialize | ( | MessageValidator & | messageValidator,
 |  | const size_t | maxSerializedBodyLength,
 |  | const uint8_t *& | pData,
 |  | size_t & | size,
 |  | size_t & | sizeWhenDecompressed |
 | ) |  |  | [static]

Deserialize the object from the supplied message validator.

Parameters:
messageValidator | the message validator from which the object will be extracted.
maxSerializedBodyLength | the maximum serialized body length.
pData | pointer to the data.
size | the size of the data.
sizeWhenDecompressed | indicates the size of the data when decompressed (zero indicates uncompressed).
Return values:
STATUS_CODE_SUCCESS
...

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::Blob::Deserialize | ( | MessageValidator & | messageValidator,
 |  | const size_t | maxSerializedBodyLength |
 | ) |  |  | [virtual]

Deserialize the object from the supplied message validator.

Parameters:
messageValidator | the message validator from which the object will be extracted.
maxSerializedBodyLength | the maximum serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

static ACTIV_FIELD_TYPES_API StatusCode Activ::Blob::DeserializeBody | ( | const void *const | pSerializedBody,
 |  | const size_t | serializedBodyLength,
 |  | const uint8_t *& | pData,
 |  | size_t & | size,
 |  | size_t & | sizeWhenDecompressed |
 | ) |  |  | [static]

Deserialize the object's body from the supplied data buffer.

Parameters:
pSerializedBody | the buffer from which the object's body will be extracted.
serializedBodyLength | the serialized body length.
pData | pointer to the data.
size | the size of the data.
sizeWhenDecompressed | indicates the size of the data when decompressed (zero indicates uncompressed).
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
...

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::Blob::DeserializeBody | ( | const void *const | pSerializedBody,
 |  | const size_t | serializedBodyLength |
 | ) |  |  | [virtual]

Deserialize the object's body from the supplied data buffer.

Parameters:
pSerializedBody | the buffer from which the object's body will be extracted.
serializedBodyLength | the serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

static ACTIV_FIELD_TYPES_API StatusCode Activ::Blob::DeserializeLengthAndBody | ( | MessageValidator & | messageValidator,
 |  | const size_t | maxSerializedBodyLength,
 |  | const uint8_t *& | pData,
 |  | size_t & | size,
 |  | size_t & | sizeWhenDecompressed |
 | ) |  |  | [static]

Deserialize the object's length and body from the supplied message validator.

Parameters:
messageValidator | the message validator from which the object will be extracted.
maxSerializedBodyLength | the maximum serialized body length.
pData | pointer to the data.
size | the size of the data.
sizeWhenDecompressed | indicates the size of the data when decompressed (zero indicates uncompressed).
Return values:
STATUS_CODE_SUCCESS
...

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::Blob::DeserializeLengthAndBody | ( | MessageValidator & | messageValidator,
 |  | const size_t | maxSerializedBodyLength = MAX_SERIALIZED_BODY_LENGTH_UNDEFINED |
 | ) |  |  | [virtual]

Deserialize the object's length and body from the supplied message validator.

Parameters:
messageValidator | the message validator from which the object will be extracted.
maxSerializedBodyLength | the maximum serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::Blob::FromString ( MessageValidator & messageValidator ) [virtual]

Convert the object from a string.

Parameters:
messageValidator the message validator.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

StatusCode Activ::Blob::Get | ( | const uint8_t *& | pData,
 |  | size_t & | size |
 | ) |  |  | const [inline]

Get the data and size.

The data will be returned uncompressed.

Parameters:
pData | pointer to the data.
size | the size of the data.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_HEAP_EMPTY
STATUS_CODE_NOT_INITIALIZED
...

Definition at line 661 of file Blob.h.

References ACTIV_RETURN_RESULT_IF, and Decompress().

StatusCode Activ::Blob::Get | ( | const uint8_t *& | pData,
 |  | size_t & | size,
 |  | size_t & | sizeWhenDecompressed |
 | ) |  |  | const [inline]

Get the data, size and decompressed size.

Parameters:
pData | pointer to the data.
size | the size of the data.
sizeWhenDecompressed | indicates the size of the data when decompressed (zero indicates uncompressed).
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED

Definition at line 647 of file Blob.h.

References Activ::IFieldType::IsInitialized().

const uint8_t * Activ::Blob::GetData ( ) const [inline]

Get the data.

Returns:
the pointer to the data.
Exceptions:
StatusCodeException

Definition at line 673 of file Blob.h.

References ACTIV_THROW, and Activ::IFieldType::IsInitialized().

const uint8_t * Activ::Blob::GetDataCompressed ( ) const [inline]

Get the data compressed.

Returns:
the pointer to the data compressed.
Exceptions:
StatusCodeException

Definition at line 703 of file Blob.h.

References ACTIV_THROW_RESULT_IF, and Compress().

const uint8_t * Activ::Blob::GetDataDecompressed ( ) const [inline]

Get the data decompressed.

Returns:
the pointer to the data decompressed.
Exceptions:
StatusCodeException

Definition at line 721 of file Blob.h.

References ACTIV_THROW_RESULT_IF, and Decompress().

virtual ACTIV_FIELD_TYPES_API std::string Activ::Blob::GetFromStringFormat ( ) const [virtual]

Get a usage string for the format supported by FromString().

Returns:
String, may be empty.

Implements Activ::IFieldType.

size_t Activ::Blob::GetMaxSerializedBodyLength ( const size_t size ) [inline, static]

Get the maximum serialized length of the object's body.

Parameters:
size the size of the data.
Returns:
the maximum serialized length of the object's body.

Definition at line 881 of file Blob.h.

Referenced by GetMaxSerializedLength(), GetSerializedBodyLength(), and IsValidSerializedBodyLength().

size_t Activ::Blob::GetMaxSerializedLength ( const size_t size ) [inline, static]

Get the maximum serialized length of the object.

Parameters:
size the size of the data.
Returns:
the maximum serialized length of the object.

Definition at line 874 of file Blob.h.

References GetMaxSerializedBodyLength().

Referenced by GetSerializedLength().

size_t Activ::Blob::GetSerializedBodyLength ( ) const [inline, virtual]

Get the serialized length of the object's body.

Returns:
the serialized length of the object's body.

Implements Activ::IFieldType.

Definition at line 772 of file Blob.h.

References GetMaxSerializedBodyLength(), and Activ::IFieldType::IsInitialized().

size_t Activ::Blob::GetSerializedLength ( ) const [inline, virtual]

Get the serialized length of the object.

Returns:
the serialized length of the object.

Implements Activ::IFieldType.

Definition at line 765 of file Blob.h.

References GetMaxSerializedLength(), and Activ::IFieldType::IsInitialized().

size_t Activ::Blob::GetSize ( ) const [inline]

Get the size of the data.

Returns:
the size of the data.
Exceptions:
StatusCodeException

Definition at line 683 of file Blob.h.

References ACTIV_THROW, and Activ::IFieldType::IsInitialized().

size_t Activ::Blob::GetSizeCompressed ( ) const [inline]

Get the size of the data compressed.

Returns:
the size of the data compressed.
Exceptions:
StatusCodeException

Definition at line 712 of file Blob.h.

References ACTIV_THROW_RESULT_IF, and Compress().

size_t Activ::Blob::GetSizeDecompressed ( ) const [inline]

Get the size of the data decompressed.

Returns:
the size of the data decompressed.
Exceptions:
StatusCodeException

Definition at line 730 of file Blob.h.

References ACTIV_THROW_RESULT_IF, and Decompress().

size_t Activ::Blob::GetSizeWhenDecompressed ( ) const [inline]

Get the size when decompressed.

Returns:
the size of the data when decompressed.
Exceptions:
StatusCodeException

Definition at line 693 of file Blob.h.

References ACTIV_THROW, and Activ::IFieldType::IsInitialized().

bool Activ::Blob::IsCompressed ( ) const [inline]

Is the data compressed.

Returns:
whether the data is compressed.

Definition at line 867 of file Blob.h.

References Activ::IFieldType::IsInitialized().

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::Blob::IsDifferent | ( | const void *const | pRhsSerializedBody,
 |  | const size_t | rhsSerializedBodyLength,
 |  | bool & | isDifferent |
 | ) |  |  | const [virtual]

Is different.

Parameters:
pRhsSerializedBody | the buffer containing the rhs serialized version of the object's body in.
rhsSerializedBodyLength | the rhs serialized body length.
isDifferent | indicates whether the two objects are different.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

bool Activ::Blob::IsValidSerializedBodyLength ( const size_t serializedBodyLength ) [inline, static]

Is valid serialized body length.

Parameters:
serializedBodyLength the serialized body length.
Returns:
whether the serialized body length is valid.

Definition at line 888 of file Blob.h.

References GetMaxSerializedBodyLength().

Blob & Activ::Blob::operator= ( const Blob & rhs ) [inline]

Assignment operator.

Parameters:
rhs the value to assign to this object.
Returns:
a reference to this object.

Definition at line 556 of file Blob.h.

References ACTIV_THROW_RESULT_IF, Activ::IFieldType::IsInitialized(), m_pData, m_size, m_sizeWhenDecompressed, Reset(), and Set().

static ACTIV_FIELD_TYPES_API StatusCode Activ::Blob::Serialize | ( | MessageBuilder & | messageBuilder,
 |  | const size_t | maxSerializedBodyLength,
 |  | const uint8_t *const | pData,
 |  | const size_t | size,
 |  | const size_t | sizeWhenDecompressed = 0 |
 | ) |  |  | [static]

Serialize the object into the supplied message builder.

Parameters:
messageBuilder | the message builder to store a serialized version of the object in.
maxSerializedBodyLength | the maximum serialized body length.
pData | pointer to the data.
size | the size of the data.
sizeWhenDecompressed | indicates the size of the data when decompressed (zero indicates uncompressed).
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
...

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::Blob::Serialize | ( | MessageBuilder & | messageBuilder,
 |  | const size_t | maxSerializedBodyLength |
 | ) |  |  | const [virtual]

Serialize the object into the supplied message builder.

Parameters:
messageBuilder | the message builder to store a serialized version of the object in.
maxSerializedBodyLength | the maximum serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

static ACTIV_FIELD_TYPES_API StatusCode Activ::Blob::SerializeBody | ( | void * | pSerializedBody,
 |  | const size_t | maxSerializedBodyLength,
 |  | size_t & | serializedBodyLength,
 |  | const uint8_t *const | pData,
 |  | const size_t | size,
 |  | const size_t | sizeWhenDecompressed = 0 |
 | ) |  |  | [static]

Serialize the object's body into the supplied data buffer.

Parameters:
pSerializedBody | the buffer to store a serialized version of the object's body in.
maxSerializedBodyLength | the maximum serialized body length.
serializedBodyLength | the serialized body length.
pData | pointer to the data.
size | the size of the data.
sizeWhenDecompressed | indicates the size of the data when decompressed (zero indicates uncompressed).
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
...

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::Blob::SerializeBody | ( | void * | pSerializedBody,
 |  | const size_t | maxSerializedBodyLength,
 |  | size_t & | serializedBodyLength |
 | ) |  |  | const [virtual]

Serialize the object's body into the supplied data buffer.

Parameters:
pSerializedBody | the buffer to store a serialized version of the object's body in.
maxSerializedBodyLength | the maximum serialized body length.
serializedBodyLength | the serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

static ACTIV_FIELD_TYPES_API StatusCode Activ::Blob::SerializeLengthAndBody | ( | MessageBuilder & | messageBuilder,
 |  | const size_t | maxSerializedBodyLength,
 |  | const uint8_t *const | pData,
 |  | const size_t | size,
 |  | const size_t | sizeWhenDecompressed = 0 |
 | ) |  |  | [static]

Serialize the object's length and body into the supplied message builder.

Parameters:
messageBuilder | the message builder to store a serialized version of the object in.
maxSerializedBodyLength | the maximum serialized body length.
pData | pointer to the data.
size | the size of the data.
sizeWhenDecompressed | indicates the size of the data when decompressed (zero indicates uncompressed).
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
...

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::Blob::SerializeLengthAndBody | ( | MessageBuilder & | messageBuilder,
 |  | const size_t | maxSerializedBodyLength = MAX_SERIALIZED_BODY_LENGTH_UNDEFINED |
 | ) |  |  | const [virtual]

Serialize the object's length and body into the supplied message builder.

Parameters:
messageBuilder | the message builder to store a serialized version of the object in.
maxSerializedBodyLength | the maximum serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

StatusCode Activ::Blob::Set | ( | const uint8_t *const | pData,
 |  | const size_t | size |
 | ) |  |  | [inline]

Set the data and size.

The data will be stored compressed (only if compressed size < decompressed size).

Parameters:
pData | pointer to the data.
size | the size of the data.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_HEAP_EMPTY
STATUS_CODE_INVALID_PARAMETER
...

Definition at line 636 of file Blob.h.

References ACTIV_RETURN_RESULT_IF, Compress(), and Set().

StatusCode Activ::Blob::Set | ( | const uint8_t *const | pData,
 |  | const size_t | size,
 |  | const size_t | sizeWhenDecompressed |
 | ) |  |  | [inline]

Set the data, size and decompressed size.

Parameters:
pData | pointer to the data.
size | the size of the data.
sizeWhenDecompressed | indicates the size of the data when decompressed (zero indicates uncompressed).
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_HEAP_EMPTY
STATUS_CODE_INVALID_PARAMETER

Definition at line 575 of file Blob.h.

References Activ::IFieldType::m_isInitialized.

Referenced by Blob(), operator=(), and Set().

virtual ACTIV_FIELD_TYPES_API std::string Activ::Blob::ToString ( const bool isHexFormat ) const [virtual]

Convert the object to a string.

Parameters:
isHexFormat indicates whether the data is copied in hex format.
Returns:
the object as a string.
Exceptions:
StatusCodeException

virtual ACTIV_FIELD_TYPES_API std::string Activ::Blob::ToString ( ) const [virtual]

Convert the object to a string.

Returns:
the object as a string.

Implements Activ::IFieldType.

static ACTIV_FIELD_TYPES_API StatusCode Activ::Blob::ValidateSerializedLengthAndBody | ( | MessageValidator & | messageValidator,
 |  | size_t & | serializedBodyOffset,
 |  | size_t & | serializedBodyLength |
 | ) |  |  | [static]

Validate the serialized length and body.

Parameters:
messageValidator | the message validator.
serializedBodyOffset | the serialized body offset.
serializedBodyLength | the serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivFieldTypes/Blob.h
Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::CaseInsensitiveLessThanStringComparisonObject

Activ::CaseInsensitiveLessThanStringComparisonObject Class Reference

Case-insensitive less than string comparison object. More...

#include <ActivMiddleware/Misc/FunctionObjects.h>

List of all members.

Public Member Functions

bool operator() (const std::string &lhs, const std::string &rhs) const
Function operator.

Detailed Description

Case-insensitive less than string comparison object.

Definition at line 233 of file FunctionObjects.h.

Member Function Documentation

bool Activ::CaseInsensitiveLessThanStringComparisonObject::operator() | ( | const std::string & | lhs,
 |  | const std::string & | rhs |
 | ) |  |  | const [inline]

Function operator.

Parameters:
lhs | a reference to the lhs object.
rhs | a reference to the rhs object.
Returns:
whether the lhs object is less than rhs object.

Definition at line 244 of file FunctionObjects.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/Misc/FunctionObjects.h
Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ChildService

Activ::ChildService< T > Class Template Reference

Child service class. More...

#include <ActivMiddleware/ActivFramework/ChildService.h>

Inheritance diagram for Activ::ChildService< T >:

Activ::Service Activ::Component Activ::Port

List of all members.

Public Member Functions

ChildService (T &parentService, ManagedEndPoint &managedEndPoint, IHeap *const pHeap=0, const std::string &portName=Port::anonymousName)
Constructor.

Public Attributes

T & m_parentService
Reference back to the parent service.

Detailed Description

template<typename T>
class Activ::ChildService< T >

Child service class.

A child service is attached to another service. The child service is given the same service id as the parent.

Definition at line 24 of file ChildService.h.

Constructor & Destructor Documentation

template<typename T>
Activ::ChildService< T >::ChildService | ( | T & | parentService,
 |  | ManagedEndPoint & | managedEndPoint,
 |  | IHeap *const | pHeap = 0,
 |  | const std::string & | portName = Port::anonymousName |
 | ) |  |  | [inline]

Constructor.

Attaches the child service to a managed endpoint at the next available slot with the service of the parent service.

Parameters:
parentService | reference to the parent service.
managedEndPoint | reference to a ManagedEndPoint object to which this port is to be attached.
pHeap | heap to use for messaging, or 0 for the parent service heap.
portName | name of the Port, local to the endpoint.
Exceptions:
Exception.

Definition at line 49 of file ChildService.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivFramework/ChildService.h
Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::CommandLineParser

Activ::CommandLineParser Class Reference

Command line parser class. More...

#include <ActivMiddleware/ActivBase/CommandLineParser.h>

List of all members.

Public Member Functions

ACTIV_BASE_EXPORTED_API
CommandLineParserDetail::DescriptionAppender & 		AddDescriptions ()
Get object to help with appending descriptions.
ACTIV_BASE_EXPORTED_API | CommandLineParser ()
Default constructor.
ACTIV_BASE_EXPORTED_API bool | IsDefaultValue (const std::string &name) const
Determines if the element has been set to a default value or from the command line.
virtual
ACTIV_BASE_EXPORTED_API void 		PrintUsage (const std::string &argv0, std::ostream &outStream) const
Print usage display.
ACTIV_BASE_EXPORTED_API bool | Process (const int argc, char *argv[], std::ostream &outStream=std::cout)
Process a command line.
virtual ACTIV_BASE_EXPORTED_API | ~CommandLineParser ()
Destructor.

Static Public Member Functions

static ACTIV_BASE_EXPORTED_API
CommandLineParserDetail::BooleanSwitchDescription 		BooleanSwitch (const std::string &name, const std::string &description, boost::function< void(const bool &)> notifier)
Helper function to construct a boolean switch description and arbitrary action.
static ACTIV_BASE_EXPORTED_API
CommandLineParserDetail::BooleanSwitchDescription 		BooleanSwitch (const std::string &name, const std::string &description, bool &value)
Helper function to construct a boolean switch description and default store action.
template<typename T>
static
CommandLineParserDetail::OptionalParameterDescription
< T > 		Parameter (const std::string &name, const std::string &description, const T &defaultValue, boost::function< void(const T &)> notifier)
Helper function to construct an optional parameter description with a default value and arbitrary action.
template<typename T>
static
CommandLineParserDetail::OptionalParameterDescription
< T > 		Parameter (const std::string &name, const std::string &description, const T &defaultValue, T &value)
Helper function to construct an optional parameter description with default value and store action.
template<typename T>
static
CommandLineParserDetail::MandatoryParameterDescription
< T > 		Parameter (const std::string &name, const std::string &description, boost::function< void(const T &)> notifier)
Helper function to construct a mandatory parameter description with arbitrary action.
template<typename T>
static
CommandLineParserDetail::MandatoryParameterDescription
< T > 		Parameter (const std::string &name, const std::string &description, T &value)
Helper function to construct a mandatory parameter description with default store action.
template<typename T>
static
CommandLineParserDetail::OptionalSwitchDescription
< T > 		Switch (const std::string &name, const std::string &description, const T &defaultValue, boost::function< void(const T &)> notifier)
Helper function to construct an optional switch description with default value and arbitrary action.
template<typename T>
static
CommandLineParserDetail::OptionalSwitchDescription
< T > 		Switch (const std::string &name, const std::string &description, const T &defaultValue, T &value)
Helper function to construct an optional switch description with default value and default store action.
template<typename T>
static
CommandLineParserDetail::MandatorySwitchDescription
< T > 		Switch (const std::string &name, const std::string &description, boost::function< void(const T &)> notifier)
Helper function to construct a mandatory switch description with arbitrary action.
template<typename T>
static
CommandLineParserDetail::MandatorySwitchDescription
< T > 		Switch (const std::string &name, const std::string &description, T &value)
Helper function to construct a mandatory switch description with default store action.

Detailed Description

Command line parser class.

This is a wrapper over the more complete boost::program_options library.

A "help" switch (short form '?') is implictly added.

Definition at line 24 of file CommandLineParser.h.

Member Function Documentation

ACTIV_BASE_EXPORTED_API CommandLineParserDetail::DescriptionAppender& Activ::CommandLineParser::AddDescriptions ( )

Get object to help with appending descriptions.

Returns:
DescriptionAppender helper object reference.

static ACTIV_BASE_EXPORTED_API CommandLineParserDetail::BooleanSwitchDescription Activ::CommandLineParser::BooleanSwitch | ( | const std::string & | name,
 |  | const std::string & | description,
 |  | boost::function< void(const bool &)> | notifier |
 | ) |  |  | [static]

Helper function to construct a boolean switch description and arbitrary action.

Parameters:
name | name of the switch.
description | descriptive text of the switch.
notifier | function to invoke with the switch's value.

static ACTIV_BASE_EXPORTED_API CommandLineParserDetail::BooleanSwitchDescription Activ::CommandLineParser::BooleanSwitch | ( | const std::string & | name,
 |  | const std::string & | description,
 |  | bool & | value |
 | ) |  |  | [static]

Helper function to construct a boolean switch description and default store action.

Parameters:
name | name of the switch.
description | descriptive text of the switch.
value

ACTIV_BASE_EXPORTED_API bool Activ::CommandLineParser::IsDefaultValue ( const std::string & name ) const

Determines if the element has been set to a default value or from the command line.

Parameters:
name is the string to check if it is defaulted or not. This string must match the long name of the Parameter, Switch etc... that you wish to check.
Returns:
true if it is defaulted.

template<typename T>
static CommandLineParserDetail::OptionalParameterDescription<T> Activ::CommandLineParser::Parameter | ( | const std::string & | name,
 |  | const std::string & | description,
 |  | const T & | defaultValue,
 |  | boost::function< void(const T &)> | notifier |
 | ) |  |  | [inline, static]

Helper function to construct an optional parameter description with a default value and arbitrary action.

Parameters:
name | name of the parameter.
description | descriptive text of the parameter.
defaultValue | the default value to assign for this parameter if none is provided.
notifier | function to invoke with the parameter's value.

Definition at line 131 of file CommandLineParser.h.

template<typename T>
static CommandLineParserDetail::OptionalParameterDescription<T> Activ::CommandLineParser::Parameter | ( | const std::string & | name,
 |  | const std::string & | description,
 |  | const T & | defaultValue,
 |  | T & | value |
 | ) |  |  | [inline, static]

Helper function to construct an optional parameter description with default value and store action.

Parameters:
name | name of the parameter.
description | descriptive text of the parameter.
defaultValue | the default value to assign for this parameter if none is provided.
value | location to store the parameter's value.

Definition at line 115 of file CommandLineParser.h.

template<typename T>
static CommandLineParserDetail::MandatoryParameterDescription<T> Activ::CommandLineParser::Parameter | ( | const std::string & | name,
 |  | const std::string & | description,
 |  | boost::function< void(const T &)> | notifier |
 | ) |  |  | [inline, static]

Helper function to construct a mandatory parameter description with arbitrary action.

Parameters:
name | name of the parameter.
description | descriptive text of the parameter.
notifier | function to invoke with the parameter's value.

Definition at line 100 of file CommandLineParser.h.

template<typename T>
static CommandLineParserDetail::MandatoryParameterDescription<T> Activ::CommandLineParser::Parameter | ( | const std::string & | name,
 |  | const std::string & | description,
 |  | T & | value |
 | ) |  |  | [inline, static]

Helper function to construct a mandatory parameter description with default store action.

Parameters:
name | name of the parameter.
description | descriptive text of the parameter.
value | location to store the parameter's value.

Definition at line 85 of file CommandLineParser.h.

virtual ACTIV_BASE_EXPORTED_API void Activ::CommandLineParser::PrintUsage | ( | const std::string & | argv0,
 |  | std::ostream & | outStream |
 | ) |  |  | const [virtual]

Print usage display.

Parameters:
argv0 | argv[0] from main().
outStream | iostream to print usage to.

ACTIV_BASE_EXPORTED_API bool Activ::CommandLineParser::Process | ( | const int | argc,
 |  | char * | argv[],
 |  | std::ostream & | outStream = std::cout
 | ) |  |

Process a command line.

Parameters:
argc | as passed to main(),
argv | as passed to main().
outStream | iostream to print usage to, default std::cout.
Return values:
true | command line parsed.
false | help switch was passed. PrintUsage() has been called.
Exceptions:
Exception.
boost::program_options::error.

template<typename T>
static CommandLineParserDetail::OptionalSwitchDescription<T> Activ::CommandLineParser::Switch | ( | const std::string & | name,
 |  | const std::string & | description,
 |  | const T & | defaultValue,
 |  | boost::function< void(const T &)> | notifier |
 | ) |  |  | [inline, static]

Helper function to construct an optional switch description with default value and arbitrary action.

Parameters:
name | name of the switch.
description | descriptive text of the switch.
defaultValue | the default value to assign for this switch if none is provided.
notifier | function to invoke with the switch's value.

Definition at line 191 of file CommandLineParser.h.

template<typename T>
static CommandLineParserDetail::OptionalSwitchDescription<T> Activ::CommandLineParser::Switch | ( | const std::string & | name,
 |  | const std::string & | description,
 |  | const T & | defaultValue,
 |  | T & | value |
 | ) |  |  | [inline, static]

Helper function to construct an optional switch description with default value and default store action.

Parameters:
name | name of the switch.
description | descriptive text of the switch.
defaultValue | the default value to assign for this switch if none is provided.
value | location to store the switch's value.

Definition at line 175 of file CommandLineParser.h.

template<typename T>
static CommandLineParserDetail::MandatorySwitchDescription<T> Activ::CommandLineParser::Switch | ( | const std::string & | name,
 |  | const std::string & | description,
 |  | boost::function< void(const T &)> | notifier |
 | ) |  |  | [inline, static]

Helper function to construct a mandatory switch description with arbitrary action.

Parameters:
name | name of the switch.
description | descriptive text of the switch.
notifier | function to invoke with the switch's value.

Definition at line 160 of file CommandLineParser.h.

template<typename T>
static CommandLineParserDetail::MandatorySwitchDescription<T> Activ::CommandLineParser::Switch | ( | const std::string & | name,
 |  | const std::string & | description,
 |  | T & | value |
 | ) |  |  | [inline, static]

Helper function to construct a mandatory switch description with default store action.

Parameters:
name | name of the switch.
description | descriptive text of the switch.
value | location to store the switch's value.

Definition at line 145 of file CommandLineParser.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivBase/CommandLineParser.h
Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::CommandLineParserDetail::BooleanSwitchDescription

Activ::CommandLineParserDetail::BooleanSwitchDescription Class Reference

Description of a boolean command line switch. More...

#include <ActivMiddleware/ActivBase/Detail/CommandLineParserDetail.h>

Inheritance diagram for Activ::CommandLineParserDetail::BooleanSwitchDescription:

Activ::CommandLineParserDetail::Description< bool >

List of all members.

Public Member Functions

BooleanSwitchDescription (const std::string &name, const std::string &description, boost::function< void(const bool &)> notifier)
Constructor.

Detailed Description

Description of a boolean command line switch.

Definition at line 214 of file CommandLineParserDetail.h.

Constructor & Destructor Documentation

Activ::CommandLineParserDetail::BooleanSwitchDescription::BooleanSwitchDescription | ( | const std::string & | name,
 |  | const std::string & | description,
 |  | boost::function< void(const bool &)> | notifier |
 | ) |  |  | [inline]

Constructor.

Parameters:
name | name of the switch.
description | descriptive text of the switch.
notifier | action to take when switch is seen on the command line.

Definition at line 224 of file CommandLineParserDetail.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivBase/Detail/CommandLineParserDetail.h
Generated on Wed Oct 8 14:02:02 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::CommandLineParserDetail::CommandLineParserImpl

Activ::CommandLineParserDetail::CommandLineParserImpl Class Reference

Implementation details of CommandLineParser. More...

#include <ActivMiddleware/ActivBase/Detail/CommandLineParserDetail.h>

List of all members.

Public Member Functions

CommandLineParserImpl (CommandLineParser &commandLineParser)
Constructor.
bool | IsDefaultValue (const std::string &name) const
Determines if the element has been set to a default value or from the command line.
void | PrintUsage (const std::string &argv0, std::ostream &outStream) const
Print usage display.
bool | Process (const int argc, char *argv[], std::ostream &outStream)
Process a command line.

Friends

class | DescriptionAppender

Detailed Description

Implementation details of CommandLineParser.

Definition at line 240 of file CommandLineParserDetail.h.

Constructor & Destructor Documentation

Activ::CommandLineParserDetail::CommandLineParserImpl::CommandLineParserImpl ( CommandLineParser & commandLineParser )

Constructor.

Parameters:
commandLineParser

Member Function Documentation

bool Activ::CommandLineParserDetail::CommandLineParserImpl::IsDefaultValue ( const std::string & name ) const

Determines if the element has been set to a default value or from the command line.

Parameters:
name is the string to check if it is defaulted or not. This string must match the long name of the Parameter, Switch etc... that you wish to check.
Returns:
true if it is defaulted.

void Activ::CommandLineParserDetail::CommandLineParserImpl::PrintUsage | ( | const std::string & | argv0,
 |  | std::ostream & | outStream |
 | ) |  |  | const

Print usage display.

Parameters:
argv0 | argv[0] from main().
outStream | iostream to print usage to.

bool Activ::CommandLineParserDetail::CommandLineParserImpl::Process | ( | const int | argc,
 |  | char * | argv[],
 |  | std::ostream & | outStream
 | ) |  |

Process a command line.

Parameters:
argc | as passed to main(),
argv | as passed to main().
outStream | iostream to print usage to.
Return values:
true | command line parsed.
false | help switch was passed. PrintUsage() has been called.
Exceptions:
Exception.
boost::program_options::error.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivBase/Detail/CommandLineParserDetail.h
Generated on Wed Oct 8 14:02:02 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::CommandLineParserDetail::DefaultDescription

Activ::CommandLineParserDetail::DefaultDescription< T > Class Template Reference

Description of a command line parameter/switch with default value. More...

#include <ActivMiddleware/ActivBase/Detail/CommandLineParserDetail.h>

Inheritance diagram for Activ::CommandLineParserDetail::DefaultDescription< T >:

Activ::CommandLineParserDetail::Description< T > Activ::CommandLineParserDetail::OptionalParameterDescription< T > Activ::CommandLineParserDetail::OptionalSwitchDescription< T >

List of all members.

Public Member Functions

DefaultDescription (const std::string &name, const std::string &description, const T &defaultValue, boost::function< void(const T &)> notifier)
Constructor.

Public Attributes

const T m_defaultValue
the default value to use if not provided on the command line

Detailed Description

template<typename T>
class Activ::CommandLineParserDetail::DefaultDescription< T >

Description of a command line parameter/switch with default value.

Definition at line 94 of file CommandLineParserDetail.h.

Constructor & Destructor Documentation

template<typename T>
Activ::CommandLineParserDetail::DefaultDescription< T >::DefaultDescription | ( | const std::string & | name,
 |  | const std::string & | description,
 |  | const T & | defaultValue,
 |  | boost::function< void(const T &)> | notifier |
 | ) |  |  | [inline]

Constructor.

Parameters:
name | name of the parameter/switch.
description | descriptive text of the parameter/switch.
defaultValue | the default value to use if not provided on the command line.
notifier | action to take when parameter/switch is seen on the command line.

Definition at line 105 of file CommandLineParserDetail.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivBase/Detail/CommandLineParserDetail.h
Generated on Wed Oct 8 14:02:02 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::CommandLineParserDetail::Description

Activ::CommandLineParserDetail::Description< T > Class Template Reference

Description of a command line parameter/switch. More...

#include <ActivMiddleware/ActivBase/Detail/CommandLineParserDetail.h>

Inheritance diagram for Activ::CommandLineParserDetail::Description< T >:

Activ::CommandLineParserDetail::DefaultDescription< T > Activ::CommandLineParserDetail::MandatoryParameterDescription< T > Activ::CommandLineParserDetail::MandatorySwitchDescription< T > Activ::CommandLineParserDetail::OptionalParameterDescription< T > Activ::CommandLineParserDetail::OptionalSwitchDescription< T >

List of all members.

Public Member Functions

Description (const std::string &name, const std::string &description, boost::function< void(const T &)> notifier)
Constructor.

Public Attributes

const std::string | m_description
descriptive text of the parameter/switch
const std::string | m_name
name of the parameter/switch
const boost::function< void(const
T &)> 		m_notifier
action to take when parameter/switch is seen on the command line

Detailed Description

template<typename T>
class Activ::CommandLineParserDetail::Description< T >

Description of a command line parameter/switch.

Definition at line 65 of file CommandLineParserDetail.h.

Constructor & Destructor Documentation

template<typename T>
Activ::CommandLineParserDetail::Description< T >::Description | ( | const std::string & | name,
 |  | const std::string & | description,
 |  | boost::function< void(const T &)> | notifier |
 | ) |  |  | [inline]

Constructor.

Parameters:
name | name of the parameter/switch.
description | descriptive text of the parameter/switch.
notifier | action to take when parameter/switch is seen on the command line.

Definition at line 75 of file CommandLineParserDetail.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivBase/Detail/CommandLineParserDetail.h
Generated on Wed Oct 8 14:02:02 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::CommandLineParserDetail::DescriptionAppender

Activ::CommandLineParserDetail::DescriptionAppender Class Reference

Helper class to build description. More...

#include <ActivMiddleware/ActivBase/Detail/CommandLineParserDetail.h>

List of all members.

Public Member Functions

DescriptionAppender (CommandLineParserImpl &commandLineParserImpl)
Constructor.
DescriptionAppender & | operator() (const BooleanSwitchDescription &booleanSwitchDescription)
Append a boolean switch description.
template<typename T>
DescriptionAppender & | operator() (const OptionalSwitchDescription< std::vector< T > > &switchDescription)
Append an optional switch list description with default value.
template<typename T>
DescriptionAppender & | operator() (const OptionalSwitchDescription< T > &switchDescription)
Append an optional switch description with default value.
template<typename T>
DescriptionAppender & | operator() (const MandatorySwitchDescription< std::vector< T > > &switchDescription)
Append a mandatory switch list description.
template<typename T>
DescriptionAppender & | operator() (const MandatorySwitchDescription< T > &switchDescription)
Append a mandatory switch description.
template<typename T>
DescriptionAppender & | operator() (const OptionalParameterDescription< std::vector< T > > &parameterDescription)
Append an optional parameter list description.
template<typename T>
DescriptionAppender & | operator() (const OptionalParameterDescription< T > &parameterDescription)
Append an optional parameter description.
template<typename T>
DescriptionAppender & | operator() (const MandatoryParameterDescription< std::vector< T > > &parameterDescription)
Append a mandatory parameter list description.
template<typename T>
DescriptionAppender & | operator() (const MandatoryParameterDescription< T > &parameterDescription)
Append a mandatory parameter description.

Detailed Description

Helper class to build description.

Definition at line 321 of file CommandLineParserDetail.h.

Constructor & Destructor Documentation

Activ::CommandLineParserDetail::DescriptionAppender::DescriptionAppender ( CommandLineParserImpl & commandLineParserImpl )

Constructor.

Parameters:
commandLineParserImpl CommandLineParserImpl to append descriptions to.

Member Function Documentation

DescriptionAppender& Activ::CommandLineParserDetail::DescriptionAppender::operator() ( const BooleanSwitchDescription & booleanSwitchDescription ) [inline]

Append a boolean switch description.

Parameters:
booleanSwitchDescription BooleanSwitchDescription to append.
Returns:
*this.

Definition at line 526 of file CommandLineParserDetail.h.

References Activ::CommandLineParserDetail::Description< T >::m_description, Activ::CommandLineParserDetail::Description< T >::m_name, Activ::CommandLineParserDetail::Description< T >::m_notifier, and Activ::CommandLineParserDetail::CommandLineParserImpl::m_optionalSwitchDescriptions.

template<typename T>
DescriptionAppender& Activ::CommandLineParserDetail::DescriptionAppender::operator() ( const OptionalSwitchDescription< std::vector< T > > & switchDescription ) [inline]

Append an optional switch list description with default value.

Parameters:
switchDescription OptionalSwitchDescription to append.
Returns:
*this.

Definition at line 507 of file CommandLineParserDetail.h.

References Activ::CommandLineParserDetail::CommandLineParserImpl::m_optionalSwitchDescriptions.

template<typename T>
DescriptionAppender& Activ::CommandLineParserDetail::DescriptionAppender::operator() ( const OptionalSwitchDescription< T > & switchDescription ) [inline]

Append an optional switch description with default value.

Parameters:
switchDescription OptionalSwitchDescription to append.
Returns:
*this.

Definition at line 487 of file CommandLineParserDetail.h.

References Activ::CommandLineParserDetail::DefaultDescription< T >::m_defaultValue, Activ::CommandLineParserDetail::Description< T >::m_description, Activ::CommandLineParserDetail::Description< T >::m_name, Activ::CommandLineParserDetail::Description< T >::m_notifier, and Activ::CommandLineParserDetail::CommandLineParserImpl::m_optionalSwitchDescriptions.

template<typename T>
DescriptionAppender& Activ::CommandLineParserDetail::DescriptionAppender::operator() ( const MandatorySwitchDescription< std::vector< T > > & switchDescription ) [inline]

Append a mandatory switch list description.

Parameters:
switchDescription MandatorySwitchDescription to append.
Returns:
*this.

Definition at line 467 of file CommandLineParserDetail.h.

References Activ::CommandLineParserDetail::CommandLineParserImpl::m_mandatorySwitchDescriptions.

template<typename T>
DescriptionAppender& Activ::CommandLineParserDetail::DescriptionAppender::operator() ( const MandatorySwitchDescription< T > & switchDescription ) [inline]

Append a mandatory switch description.

Parameters:
switchDescription MandatorySwitchDescription to append.
Returns:
*this.

Definition at line 447 of file CommandLineParserDetail.h.

References Activ::CommandLineParserDetail::Description< T >::m_description, Activ::CommandLineParserDetail::CommandLineParserImpl::m_mandatorySwitchDescriptions, Activ::CommandLineParserDetail::Description< T >::m_name, and Activ::CommandLineParserDetail::Description< T >::m_notifier.

template<typename T>
DescriptionAppender& Activ::CommandLineParserDetail::DescriptionAppender::operator() ( const OptionalParameterDescription< std::vector< T > > & parameterDescription ) [inline]

Append an optional parameter list description.

Parameters:
parameterDescription OptionalParameterDescription to append.
Returns:
*this.

Definition at line 418 of file CommandLineParserDetail.h.

References ACTIV_THROW, Activ::CommandLineParserDetail::CommandLineParserImpl::m_optionalParameterDescriptions, and Activ::CommandLineParserDetail::CommandLineParserImpl::m_positionalDescriptions.

template<typename T>
DescriptionAppender& Activ::CommandLineParserDetail::DescriptionAppender::operator() ( const OptionalParameterDescription< T > & parameterDescription ) [inline]

Append an optional parameter description.

Parameters:
parameterDescription OptionalParameterDescription to append.
Returns:
*this.

Definition at line 389 of file CommandLineParserDetail.h.

References ACTIV_THROW, Activ::CommandLineParserDetail::DefaultDescription< T >::m_defaultValue, Activ::CommandLineParserDetail::Description< T >::m_description, Activ::CommandLineParserDetail::Description< T >::m_name, Activ::CommandLineParserDetail::Description< T >::m_notifier, Activ::CommandLineParserDetail::CommandLineParserImpl::m_optionalParameterDescriptions, and Activ::CommandLineParserDetail::CommandLineParserImpl::m_positionalDescriptions.

template<typename T>
DescriptionAppender& Activ::CommandLineParserDetail::DescriptionAppender::operator() ( const MandatoryParameterDescription< std::vector< T > > & parameterDescription ) [inline]

Append a mandatory parameter list description.

Parameters:
parameterDescription ParameterDescription to append.
Returns:
*this.

Definition at line 364 of file CommandLineParserDetail.h.

References ACTIV_THROW, Activ::CommandLineParserDetail::CommandLineParserImpl::m_mandatoryParameterDescriptions, and Activ::CommandLineParserDetail::CommandLineParserImpl::m_positionalDescriptions.

template<typename T>
DescriptionAppender& Activ::CommandLineParserDetail::DescriptionAppender::operator() ( const MandatoryParameterDescription< T > & parameterDescription ) [inline]

Append a mandatory parameter description.

Parameters:
parameterDescription ParameterDescription to append.
Returns:
*this.

Definition at line 339 of file CommandLineParserDetail.h.

References ACTIV_THROW, Activ::CommandLineParserDetail::Description< T >::m_description, Activ::CommandLineParserDetail::CommandLineParserImpl::m_mandatoryParameterDescriptions, Activ::CommandLineParserDetail::Description< T >::m_name, Activ::CommandLineParserDetail::Description< T >::m_notifier, and Activ::CommandLineParserDetail::CommandLineParserImpl::m_positionalDescriptions.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivBase/Detail/CommandLineParserDetail.h
Generated on Wed Oct 8 14:02:02 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::CommandLineParserDetail::MandatoryParameterDescription

Activ::CommandLineParserDetail::MandatoryParameterDescription< T > Class Template Reference

Description of a mandatory command line parameter. More...

#include <ActivMiddleware/ActivBase/Detail/CommandLineParserDetail.h>

Inheritance diagram for Activ::CommandLineParserDetail::MandatoryParameterDescription< T >:

Activ::CommandLineParserDetail::Description< T >

List of all members.

Public Member Functions

MandatoryParameterDescription (const std::string &name, const std::string &description, boost::function< void(const T &)> notifier)
Constructor.

Detailed Description

template<typename T>
class Activ::CommandLineParserDetail::MandatoryParameterDescription< T >

Description of a mandatory command line parameter.

Definition at line 121 of file CommandLineParserDetail.h.

Constructor & Destructor Documentation

template<typename T>
Activ::CommandLineParserDetail::MandatoryParameterDescription< T >::MandatoryParameterDescription | ( | const std::string & | name,
 |  | const std::string & | description,
 |  | boost::function< void(const T &)> | notifier |
 | ) |  |  | [inline]

Constructor.

Parameters:
name | name of the parameter.
description | descriptive text of the parameter.
notifier | action to take when parameter is seen on the command line.

Definition at line 131 of file CommandLineParserDetail.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivBase/Detail/CommandLineParserDetail.h
Generated on Wed Oct 8 14:02:02 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::CommandLineParserDetail::MandatorySwitchDescription

Activ::CommandLineParserDetail::MandatorySwitchDescription< T > Class Template Reference

Description of a mandatory command line switch. More...

#include <ActivMiddleware/ActivBase/Detail/CommandLineParserDetail.h>

Inheritance diagram for Activ::CommandLineParserDetail::MandatorySwitchDescription< T >:

Activ::CommandLineParserDetail::Description< T >

List of all members.

Public Member Functions

MandatorySwitchDescription (const std::string &name, const std::string &description, boost::function< void(const T &)> notifier)
Constructor.

Detailed Description

template<typename T>
class Activ::CommandLineParserDetail::MandatorySwitchDescription< T >

Description of a mandatory command line switch.

Definition at line 168 of file CommandLineParserDetail.h.

Constructor & Destructor Documentation

template<typename T>
Activ::CommandLineParserDetail::MandatorySwitchDescription< T >::MandatorySwitchDescription | ( | const std::string & | name,
 |  | const std::string & | description,
 |  | boost::function< void(const T &)> | notifier |
 | ) |  |  | [inline]

Constructor.

Parameters:
name | name of the switch.
description | descriptive text of the switch.
notifier | action to take when switch is seen on the command line.

Definition at line 178 of file CommandLineParserDetail.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivBase/Detail/CommandLineParserDetail.h
Generated on Wed Oct 8 14:02:02 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::CommandLineParserDetail::OptionalParameterDescription

Activ::CommandLineParserDetail::OptionalParameterDescription< T > Class Template Reference

Description of an optional command line parameter. More...

#include <ActivMiddleware/ActivBase/Detail/CommandLineParserDetail.h>

Inheritance diagram for Activ::CommandLineParserDetail::OptionalParameterDescription< T >:

Activ::CommandLineParserDetail::DefaultDescription< T > Activ::CommandLineParserDetail::Description< T >

List of all members.

Public Member Functions

OptionalParameterDescription (const std::string &name, const std::string &description, const T &defaultValue, boost::function< void(const T &)> notifier)
Constructor.

Detailed Description

template<typename T>
class Activ::CommandLineParserDetail::OptionalParameterDescription< T >

Description of an optional command line parameter.

Definition at line 144 of file CommandLineParserDetail.h.

Constructor & Destructor Documentation

template<typename T>
Activ::CommandLineParserDetail::OptionalParameterDescription< T >::OptionalParameterDescription | ( | const std::string & | name,
 |  | const std::string & | description,
 |  | const T & | defaultValue,
 |  | boost::function< void(const T &)> | notifier |
 | ) |  |  | [inline]

Constructor.

Parameters:
name | name of the parameter.
description | descriptive text of the parameter.
defaultValue | the default value to use if not provided on the command line.
notifier | action to take when parameter is seen on the command line.

Definition at line 155 of file CommandLineParserDetail.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivBase/Detail/CommandLineParserDetail.h
Generated on Wed Oct 8 14:02:02 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::CommandLineParserDetail::OptionalSwitchDescription

Activ::CommandLineParserDetail::OptionalSwitchDescription< T > Class Template Reference

Description of an optional command line switch. More...

#include <ActivMiddleware/ActivBase/Detail/CommandLineParserDetail.h>

Inheritance diagram for Activ::CommandLineParserDetail::OptionalSwitchDescription< T >:

Activ::CommandLineParserDetail::DefaultDescription< T > Activ::CommandLineParserDetail::Description< T >

List of all members.

Public Member Functions

OptionalSwitchDescription (const std::string &name, const std::string &description, const T &defaultValue, boost::function< void(const T &)> notifier)
Constructor.

Detailed Description

template<typename T>
class Activ::CommandLineParserDetail::OptionalSwitchDescription< T >

Description of an optional command line switch.

Definition at line 191 of file CommandLineParserDetail.h.

Constructor & Destructor Documentation

template<typename T>
Activ::CommandLineParserDetail::OptionalSwitchDescription< T >::OptionalSwitchDescription | ( | const std::string & | name,
 |  | const std::string & | description,
 |  | const T & | defaultValue,
 |  | boost::function< void(const T &)> | notifier |
 | ) |  |  | [inline]

Constructor.

Parameters:
name | name of the switch.
description | descriptive text of the switch.
defaultValue | the default value to use if not provided on the command line.
notifier | action to take when switch is seen on the command line.

Definition at line 202 of file CommandLineParserDetail.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivBase/Detail/CommandLineParserDetail.h
Generated on Wed Oct 8 14:02:02 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::CommandLineParserDetail::ValueStore

Activ::CommandLineParserDetail::ValueStore< T > Class Template Reference

Default action to take for a command line value. More...

#include <ActivMiddleware/ActivBase/Detail/CommandLineParserDetail.h>

List of all members.

Public Member Functions

void operator() (const T &value)
Function operator.
ValueStore (T &value)
Constructor.

Detailed Description

template<typename T>
class Activ::CommandLineParserDetail::ValueStore< T >

Default action to take for a command line value.

Definition at line 31 of file CommandLineParserDetail.h.

Constructor & Destructor Documentation

template<typename T>
Activ::CommandLineParserDetail::ValueStore< T >::ValueStore ( T & value ) [inline]

Constructor.

Parameters:
value where to store the value.

Definition at line 39 of file CommandLineParserDetail.h.

Member Function Documentation

template<typename T>
void Activ::CommandLineParserDetail::ValueStore< T >::operator() ( const T & value ) [inline]

Function operator.

Parameters:
value value to store in the location provided to the constructor.

Definition at line 49 of file CommandLineParserDetail.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivBase/Detail/CommandLineParserDetail.h
Generated on Wed Oct 8 14:02:02 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Component

Activ::Component Class Reference

Component class. More...

#include <ActivMiddleware/ActivFramework/Component.h>

Inheritance diagram for Activ::Component:

Activ::Port Activ::Application Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient Activ::ContentPlatform::ContentServerApi::ContentServerClient Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient Activ::ContentPlatform::ContributionServerApi::ContributionServerClient Activ::Service Activ::UdpComponent Activ::UiComponent

List of all members.

Public Member Functions

ACTIV_FRAMEWORK_API | Component (Application &application, ManagedEndPoint &managedEndPoint, const std::string &name=anonymousName, IHeap *const pHeap=0, const std::string &componentId=defaultComponentId)
Constructor.
ACTIV_FRAMEWORK_API Application & | GetApplication () const
Get a reference to the application object.
ACTIV_FRAMEWORK_API | ~Component ()
Destructor.

Static Public Attributes

static ACTIV_FRAMEWORK_API
const std::string 		defaultComponentId
the default component id

Protected Member Functions

virtual ACTIV_FRAMEWORK_API
StatusCode 		OnAccept (HeapMessage &acceptMessage)
A client is attempting to connect.
virtual ACTIV_FRAMEWORK_API
StatusCode 		OnBreak (HeapMessage &breakMessage)
A circuit has broken under our feet.
virtual ACTIV_FRAMEWORK_API
StatusCode 		OnConnect (HeapMessage &connectMessage)
A circuit has been established.
virtual ACTIV_FRAMEWORK_API
StatusCode 		OnConnectFailed (HeapMessage &connectFailMessage)
A circuit has failed to connect.
virtual ACTIV_FRAMEWORK_API
StatusCode 		OnData (HeapMessage &heapMessage)
Raw data received.
virtual ACTIV_FRAMEWORK_API
StatusCode 		OnDisconnect (HeapMessage &disconnectMessage)
A circuit has been closed after an asynchronous Disconnect() call.
virtual ACTIV_FRAMEWORK_API
StatusCode 		OnMessage (HeapMessage &message)
Message callback.
virtual ACTIV_FRAMEWORK_API
StatusCode 		OnRequest (HeapMessage &request)
Request callback.
virtual ACTIV_FRAMEWORK_API
StatusCode 		OnTimer (const Address &timerAddress, const BaseTime &time)
Timer callback.

Detailed Description

Component class.

Extends Port by adding callbacks for various core service notifications.

Definition at line 28 of file Component.h.

Constructor & Destructor Documentation

ACTIV_FRAMEWORK_API Activ::Component::Component | ( | Application & | application,
 |  | ManagedEndPoint & | managedEndPoint,
 |  | const std::string & | name = anonymousName,
 |  | IHeap *const | pHeap = 0,
 |  | const std::string & | componentId = defaultComponentId
 | ) |  |

Constructor.

Attaches this object to a managed endpoint at the next available slot.

Parameters:
application | Application object to attach to.
managedEndPoint | reference to a ManagedEndPoint object to which this port is to be attached.
name | name of the port, local to the endpoint.
pHeap | heap to use for messaging, or 0 for the system heap.
componentId | the component id.
Exceptions:
Exception.

Member Function Documentation

ACTIV_FRAMEWORK_API Application& Activ::Component::GetApplication ( ) const

Get a reference to the application object.

Returns:
Reference to the application object.

virtual ACTIV_FRAMEWORK_API StatusCode Activ::Component::OnAccept ( HeapMessage & acceptMessage ) [protected, virtual]

A client is attempting to connect.

The source address of acceptMessage contains the address of the circuit that is attempting to connect. This address should be used to communicate with the client.

The ip address embedded in acceptMessage (accessible with acceptMessage.GetIpAddress()) contains the ip address of the client attempting to connect.

The acceptMessage must be replied to, using PostResponse(statusCode, acceptMessage). Passing STATUS_CODE_SUCCESS allows the client access, any other other value refuses the client.

The acceptMessage itself can be forwarded to another component instead of being replied to immediately. That component will then have OnAccept() called, from which it can PostResponse(). The established circuit will then be to that component and not the original receiver of the OnAccept().

If acceptMessage is set to another HeapMessage from a different heap, the router will use the new heap for received messages on the connection, rather than the original heap. NB the contents of acceptMessage must be copied to the new HeapMessage.

The default Component::OnAccept() behaviour is to call PostResponse(STATUS_CODE_SUCCESS, acceptMessage) to accept the client.

Parameters:
acceptMessage
Returns:
The return value is not used by the framework and is provided as a helper for overriding.

Reimplemented in Activ::Service.

virtual ACTIV_FRAMEWORK_API StatusCode Activ::Component::OnBreak ( HeapMessage & breakMessage ) [protected, virtual]

A circuit has broken under our feet.

When overriding, please call the base class version for any unrecognized circuit.

Parameters:
breakMessage the address of the circuit that is now not connected is breakMessage.GetSourceAddress(). A reason for the break can be found in breakMessage.GetStatusCode().
Returns:
The return value is not used by the framework, but may be used by an application to pass values between parent and sub class versions of this function. Returns STATUS_CODE_UNRECOGNIZED by default.

Reimplemented in Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient, and Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient.

virtual ACTIV_FRAMEWORK_API StatusCode Activ::Component::OnConnect ( HeapMessage & connectMessage ) [protected, virtual]

A circuit has been established.

When overriding, please call the base class version for any unrecognized circuit.

This is called for a successful asynchronous connection. connectMessage.GetSourceAddress() is the circuit that has established.

The message may contain response data from an user data that was sent in the circuit establishment, if the underlying protocol supports it.

For example, if this is the result of an asynchronous OpenService() call, ValidateOpenServiceResponse() should be called.

Parameters:
connectMessage
Returns:
The return value is not used by the framework, but may be used by an application to pass values between parent and sub class versions of this function. Returns STATUS_CODE_UNRECOGNIZED by default.

Reimplemented in Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient, and Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient.

virtual ACTIV_FRAMEWORK_API StatusCode Activ::Component::OnConnectFailed ( HeapMessage & connectFailMessage ) [protected, virtual]

A circuit has failed to connect.

When overriding, please call the base class version for any unrecognized circuit.

The callback is for informational purposes only. If an asynchronous connection attempts fails, the OnConnectFailed() callback will be invoked but the router service will automatically attempt to connect again on a lazy basis until the circuit is Disconnect()ed. No OnConnectFailed() is called for a synchronous connect (the connect call will just timeout after the specified period with an error status code).

Parameters:
connectFailMessage the circuit that has failed to connect is connectFailMessage.GetSourceAddress(), a reason for the failed connect is connectFailMessage.GetStatusCode().
Returns:
The return value is not used by the framework, but may be used by an application to pass values between parent and sub class versions of this function. Returns STATUS_CODE_UNRECOGNIZED by default.

Reimplemented in Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient, and Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient.

virtual ACTIV_FRAMEWORK_API StatusCode Activ::Component::OnData ( HeapMessage & heapMessage ) [protected, virtual]

Raw data received.

When overriding, please call the base class version if the data is from an unknown address.

Parameters:
heapMessage heap message containing the received data.
Returns:
The return value is not used by the framework, but may be used by an application to pass values between parent and sub class versions of this function. Returns STATUS_CODE_UNRECOGNIZED by default.

virtual ACTIV_FRAMEWORK_API StatusCode Activ::Component::OnDisconnect ( HeapMessage & disconnectMessage ) [protected, virtual]

A circuit has been closed after an asynchronous Disconnect() call.

When overriding, please call the base class version for any unrecognized circuit.

This is called for a successful asynchronous disconnect completion. disconnectMessage.GetSourceAddress() is the circuit that has been established.

The message may contain response data from any user data that was sent in the disconnect, if the underlying protocol supports it.

Parameters:
disconnectMessage
Returns:
The return value is not used by the framework, but may be used by an application to pass values between parent and sub class versions of this function. Returns STATUS_CODE_UNRECOGNIZED by default.

Reimplemented in Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient, and Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient.

virtual ACTIV_FRAMEWORK_API StatusCode Activ::Component::OnMessage ( HeapMessage & message ) [protected, virtual]

Message callback.

If you override this method, please call the base class method for any unrecognized message types.

Parameters:
message the message.
Return values:
STATUS_CODE_SUCCESS | the message was recognized.
STATUS_CODE_UNRECOGNIZED | the message was not recognized.
STATUS_CODE_THREAD_EXIT | received a thread-die message.
...

Reimplemented from Activ::Port.

Reimplemented in Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient, Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient, Activ::AgentApplication, Activ::Application, Activ::ThinApplication, and Activ::UdpComponent.

virtual ACTIV_FRAMEWORK_API StatusCode Activ::Component::OnRequest ( HeapMessage & request ) [protected, virtual]

Request callback.

If you override this method, please call the base class method for any unrecognized request types. Note the request is automatically replied to with the returned status value if the status is other than STATUS_CODE_SUCCESS or STATUS_CODE_THREAD_EXIT.

If an overriden OnRequest() throws an exception out of OnRequest(), the request is automatically replied to if request still has an attached message.

If the exception is of type StatusCodeException, the status of the response is the exception error code, otherwise STATUS_CODE_UNHANDLED_EXCEPTION.

If this is not required behaviour, for example if the request has been replied to before an exception is thrown, ensure the exception is not allowed out of the scope of the OnRequest() override, or that request no longer has a message attached at the point the exception is thrown.

Parameters:
request the request message.
Return values:
STATUS_CODE_SUCCESS | the message was recognized.
STATUS_CODE_UNRECOGNIZED | the message was not recognized.
STATUS_CODE_THREAD_EXIT | received a thread-die message.
...

Reimplemented from Activ::Port.

virtual ACTIV_FRAMEWORK_API StatusCode Activ::Component::OnTimer | ( | const Address & | timerAddress,
 |  | const BaseTime & | time |
 | ) |  |  | [protected, virtual]

Timer callback.

When overriding, please call the base class version for any unrecognized timer.

Parameters:
timerAddress | the timer address.
time | the date/time of the timer.
Returns:
The return value is not used by the framework, but may be used by an application to pass values between parent and sub class versions of this function. Returns STATUS_CODE_UNRECOGNIZED by default.

Reimplemented in Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient, Activ::ContentPlatform::ContentServerApi::ContentServerClient, and Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivFramework/Component.h
Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ConsoleWindow

Activ::ConsoleWindow Class Reference

Console window class. More...

#include <ActivMiddleware/ActivBase/ConsoleWindow.h>

List of all members.

Public Types

typedef uint32_t | Flags
Flags type.

Public Member Functions

ACTIV_BASE_EXPORTED_API StatusCode | ClearFrom (const Coord &coord)
Clear the console from a coordinate to the end.
ACTIV_BASE_EXPORTED_API | ConsoleWindow (const Flags flags=FLAG_NONE)
Constructor.
ACTIV_BASE_EXPORTED_API StatusCode | GetBufferSize (Coord &size) const
Get the console buffer size. The buffer size may be larger than the visible display.
ACTIV_BASE_EXPORTED_API StatusCode | GetCursorPosition (Coord &coord) const
Get the current cursor position.
ACTIV_BASE_EXPORTED_API StatusCode | GetDisplaySize (Coord &size) const
Get the visible console display size.
ACTIV_BASE_EXPORTED_API void | Printf (const char *const pStr,...) const
Write formatted output to the console from the current cursor position.
ACTIV_BASE_EXPORTED_API StatusCode | ReadLine (std::string &input) const
Read a complete line from the console. Note returned buffer will not contain terminating cr / lf characters. This is a blocking call.
ACTIV_BASE_EXPORTED_API StatusCode | SetBufferSize (const Coord &size)
Set the console buffer size. The buffer size may be larger than the visible display.
ACTIV_BASE_EXPORTED_API StatusCode | SetCursorPosition (const Coord &coord)
Set the cursor position.
ACTIV_BASE_EXPORTED_API StatusCode | SetCursorVisibility (const bool isVisible)
Set the cursor visibility.
ACTIV_BASE_EXPORTED_API StatusCode | SetDisplaySize (const Coord &size)
Set the visible console display size.
ACTIV_BASE_EXPORTED_API StatusCode | WaitForInput (const TimeoutPeriod timeoutPeriod=100) const
Wait for input on the console.
ACTIV_BASE_EXPORTED_API StatusCode | WriteAt (const Coord &coord, const char *const pStr, const size_t length=0)
Write a string beginning at a specified coordinate.
ACTIV_BASE_EXPORTED_API | ~ConsoleWindow ()
Destructor.

Static Public Member Functions

static ACTIV_BASE_EXPORTED_API void | SetTitle (const std::string &title)
Set title of console.

Static Public Attributes

static const Flags | FLAG_IMMEDIATE_REFRESH = 0x00000002
Refresh display immediately after a write.
static const Flags | FLAG_NO_AUTOSCROLL = 0x00000001
Don't scroll the window when output reaches the bottom.
static const Flags | FLAG_NONE = 0x00000000

Classes

class | Coord
Cursor coordinate. More...

Detailed Description

Console window class.

Definition at line 32 of file ConsoleWindow.h.

Constructor & Destructor Documentation

ACTIV_BASE_EXPORTED_API Activ::ConsoleWindow::ConsoleWindow ( const Flags flags = FLAG_NONE )

Constructor.

Parameters:
flags flags defining console behaviour.

Member Function Documentation

ACTIV_BASE_EXPORTED_API StatusCode Activ::ConsoleWindow::ClearFrom ( const Coord & coord )

Clear the console from a coordinate to the end.

Note the current cursor position will not be altered by this call.

Parameters:
coord the coordinate to clear from.
Return values:
STATUS_CODE_SUCCESS
...

ACTIV_BASE_EXPORTED_API StatusCode Activ::ConsoleWindow::GetBufferSize ( Coord & size ) const

Get the console buffer size. The buffer size may be larger than the visible display.

Parameters:
size to receive the size.
Return values:
STATUS_CODE_SUCCESS
...

ACTIV_BASE_EXPORTED_API StatusCode Activ::ConsoleWindow::GetCursorPosition ( Coord & coord ) const

Get the current cursor position.

Parameters:
coord to receive the cursor position.
Return values:
STATUS_CODE_SUCCESS
...

ACTIV_BASE_EXPORTED_API StatusCode Activ::ConsoleWindow::GetDisplaySize ( Coord & size ) const

Get the visible console display size.

Parameters:
size to receive the size.
Return values:
STATUS_CODE_SUCCESS
...

ACTIV_BASE_EXPORTED_API void Activ::ConsoleWindow::Printf | ( | const char *const | pStr,
 |  |  | ... |
 | ) |  |  | const

Write formatted output to the console from the current cursor position.

Parameters:
pStr the format string.
... args.

ACTIV_BASE_EXPORTED_API StatusCode Activ::ConsoleWindow::ReadLine ( std::string & input ) const

Read a complete line from the console. Note returned buffer will not contain terminating cr / lf characters. This is a blocking call.

Parameters:
input reference to a string to receive input.
Return values:
STATUS_CODE_SUCCESS.
... did not read a complete line.

ACTIV_BASE_EXPORTED_API StatusCode Activ::ConsoleWindow::SetBufferSize ( const Coord & size )

Set the console buffer size. The buffer size may be larger than the visible display.

If the requested console buffer size is smaller in either dimension than the current display size, it is increased.

Parameters:
size the new size.
Return values:
STATUS_CODE_SUCCESS
...

ACTIV_BASE_EXPORTED_API StatusCode Activ::ConsoleWindow::SetCursorPosition ( const Coord & coord )

Set the cursor position.

Parameters:
coord the position to place the cursor.
Return values:
STATUS_CODE_SUCCESS
...

ACTIV_BASE_EXPORTED_API StatusCode Activ::ConsoleWindow::SetCursorVisibility ( const bool isVisible )

Set the cursor visibility.

Parameters:
isVisible true to make cursor visible, false to make invisible.
Return values:
STATUS_CODE_SUCCESS
...

ACTIV_BASE_EXPORTED_API StatusCode Activ::ConsoleWindow::SetDisplaySize ( const Coord & size )

Set the visible console display size.

If the current buffer size is smaller in either dimension than the requested display size, it is increased.

Parameters:
size the new size.
Return values:
STATUS_CODE_SUCCESS
...

static ACTIV_BASE_EXPORTED_API void Activ::ConsoleWindow::SetTitle ( const std::string & title ) [static]

Set title of console.

Parameters:
title

ACTIV_BASE_EXPORTED_API StatusCode Activ::ConsoleWindow::WaitForInput ( const TimeoutPeriod timeoutPeriod = 100 ) const

Wait for input on the console.

Note the resolution of the timeout on Win32 is around 10ms, and on Linux is 100ms.

Parameters:
timeoutPeriod how long to wait for input, in ms.
Return values:
STATUS_CODE_SUCCESS | there is input queued on the console.
STATUS_CODE_TIMEOUT | no input queued in the timeout period.
STATUS_CODE_FAILURE | an error occured.

ACTIV_BASE_EXPORTED_API StatusCode Activ::ConsoleWindow::WriteAt | ( | const Coord & | coord,
 |  | const char *const | pStr,
 |  | const size_t | length = 0
 | ) |  |

Write a string beginning at a specified coordinate.

Note the current cursor position will not be altered by this call.

Parameters:
coord | the coordinate to start writing from.
pStr | the string to write.
length | number of characters in string to write, default is all.
Return values:
STATUS_CODE_SUCCESS
...

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivBase/ConsoleWindow.h
Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ConsoleWindow::Coord

Activ::ConsoleWindow::Coord Class Reference

Cursor coordinate. More...

#include <ActivMiddleware/ActivBase/ConsoleWindow.h>

List of all members.

Public Member Functions

ACTIV_BASE_INLINE_API | Coord (const int16_t x, const int16_t y)
Constructor.
ACTIV_BASE_INLINE_API | Coord ()
Default constructor. x & y coordinates set to 0.
ACTIV_BASE_EXPORTED_API StatusCode | Deserialize (MessageValidator &messageValidator)
Deserialize from a MessageValidator into this object.
ACTIV_BASE_INLINE_API bool | operator!= (const Coord &rhs) const
Inequality operator.
ACTIV_BASE_INLINE_API bool | operator== (const Coord &rhs) const
Equality operator.
ACTIV_BASE_EXPORTED_API StatusCode | Serialize (MessageBuilder &messageBuilder) const
Serialize to a MessageBuilder.

Public Attributes

int16_t | m_x
int16_t | m_y

Detailed Description

Cursor coordinate.

Definition at line 38 of file ConsoleWindow.h.

Constructor & Destructor Documentation

Activ::ConsoleWindow::Coord::Coord | ( | const int16_t | x,
 |  | const int16_t | y |
 | ) |  |  | [inline]

Constructor.

Parameters:
x | coordinate.
y | coordinate.

Definition at line 293 of file ConsoleWindow.h.

Member Function Documentation

ACTIV_BASE_EXPORTED_API StatusCode Activ::ConsoleWindow::Coord::Deserialize ( MessageValidator & messageValidator )

Deserialize from a MessageValidator into this object.

Parameters:
messageValidator to deserialize from.
Returns:
STATUS_CODE_SUCCESS or an error code.

bool Activ::ConsoleWindow::Coord::operator!= ( const Coord & rhs ) const [inline]

Inequality operator.

Parameters:
rhs to compare with.
Returns:
boolean.

Definition at line 308 of file ConsoleWindow.h.

References operator==().

bool Activ::ConsoleWindow::Coord::operator== ( const Coord & rhs ) const [inline]

Equality operator.

Parameters:
rhs to compare with.
Returns:
boolean.

Definition at line 301 of file ConsoleWindow.h.

References m_x, and m_y.

Referenced by operator!=().

ACTIV_BASE_EXPORTED_API StatusCode Activ::ConsoleWindow::Coord::Serialize ( MessageBuilder & messageBuilder ) const

Serialize to a MessageBuilder.

Parameters:
messageBuilder to serialize into.
Returns:
STATUS_CODE_SUCCESS or an error code.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivBase/ConsoleWindow.h
Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient

Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient Class Reference

Content gateway client class. More...

#include <ActivContentPlatform/ActivContentGatewayApi/ContentGatewayClient.h>

Inheritance diagram for Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient:

Activ::Component Activ::ContentPlatform::ContentGatewayApi::IRealtimeResponses Activ::ContentPlatform::ContentGatewayApi::ITimeSeriesResponses Activ::ContentPlatform::ContentGatewayApi::ISymbolDirectoryResponses Activ::ContentPlatform::ContentGatewayApi::INewsResponses Activ::Port

List of all members.

Public Types

typedef RealtimeRequestHelper
< GATEWAY_REQUEST_GET_EQUAL,
SymbolIdRequestParameters > 		GetEqual
typedef RealtimeRequestHelper
< GATEWAY_REQUEST_GET_FIRST,
TableNumberRequestParameters > 		GetFirst
typedef
TimeSeriesRequestHelper
< GATEWAY_REQUEST_GET_FIRST_HISTORY,
GATEWAY_REQUEST_GET_NEXT_HISTORY,
HistoryBarList > 		GetHistory
typedef
TimeSeriesRequestHelper
< GATEWAY_REQUEST_GET_FIRST_INTRADAY,
GATEWAY_REQUEST_GET_NEXT_INTRADAY,
IntradayBarList > 		GetIntraday
typedef RealtimeRequestHelper
< GATEWAY_REQUEST_GET_LAST,
TableNumberRequestParameters > 		GetLast
typedef RealtimeRequestHelper
< GATEWAY_REQUEST_GET_MATCH,
SymbolIdMatchRequestParameters > 		GetMatch
typedef RealtimeRequestHelper
< GATEWAY_REQUEST_GET_MULTIPLE_EQUAL,
SymbolIdListRequestParameters > 		GetMultipleEqual
typedef RealtimeRequestHelper
< GATEWAY_REQUEST_GET_MULTIPLE_MATCH,
SymbolIdListMatchRequestParameters > 		GetMultipleMatch
typedef RealtimeRequestHelper
< GATEWAY_REQUEST_GET_MULTIPLE_PATTERN_MATCH,
PatternMatchRequestParameters > 		GetMultiplePatternMatch
typedef RealtimeRequestHelper
< GATEWAY_REQUEST_GET_MULTIPLE_PATTERN_MATCH_LIST,
PatternMatchListRequestParameters > 		GetMultiplePatternMatchList
typedef NewsRequestHelper | GetNewsStories
typedef RealtimeRequestHelper
< GATEWAY_REQUEST_GET_NEXT,
SymbolIdCountRequestParameters > 		GetNext
typedef RealtimeRequestHelper
< GATEWAY_REQUEST_GET_PREVIOUS,
SymbolIdCountRequestParameters > 		GetPrevious
typedef
SymbolDirectoryRequestHelper 		GetSymbols
typedef
TimeSeriesRequestHelper
< GATEWAY_REQUEST_GET_FIRST_TICKS,
GATEWAY_REQUEST_GET_NEXT_TICKS,
TickList > 		GetTicks
typedef MetaDataRequestHelper | MetaData
enum | State { ACTIV_DECLARE_ELEMENT_1_WITH_COMMA }
Enumeration of client states.

Public Member Functions

ACTIV_CONTENT_GATEWAY_API
StatusCode 		Connect (const ConnectParameters &connectParameters, const TimeoutPeriod timeoutPeriod=Port::defaultTimeout)
Connect to a content gateway.
ACTIV_CONTENT_GATEWAY_API | ContentGatewayClient (Application &application, ManagedEndPoint &managedEndPoint, const Settings &settings=Settings(), const std::string &componentId=defaultComponentId)
Constructor.
ACTIV_CONTENT_GATEWAY_API
StatusCode 		Disconnect ()
Disconnect from a content gateway.
ACTIV_CONTENT_GATEWAY_API ApiInfo | GetApiInfo () const
Return information about the API.
ACTIV_CONTENT_GATEWAY_API
StatusCode 		GetContentGatewayInfo (ContentGatewayInfo &contentGatewayInfo) const
Get information about the ContentGateway the API is connected to.
ACTIV_CONTENT_GATEWAY_API
std::string 		GetServiceLocation () const
Return the url of the service we are connected, or connecting, to.
ACTIV_CONTENT_GATEWAY_API State | GetState () const
Get connection state.
ACTIV_CONTENT_GATEWAY_API
StatusCode 		GetSubscriptionInfo (const Feed::PermissionLevel permissionLevel, SubscriptionInfo &subscriptionInfo) const
Get info about current subscriptions at a particular permission level.
ACTIV_CONTENT_GATEWAY_API
StatusCode 		SubscribeToFeed (const SubscribeFeedParameters &subscribeFeedParameters, SubscriptionCookie &subscriptionCookie) const
Subscribe to updates on the feed.
ACTIV_CONTENT_GATEWAY_API
StatusCode 		SubscribeToTable (const SubscribeTableParameters &subscribeTableParameters, SubscriptionCookie &subscriptionCookie) const
Subscribe to updates to a table.
ACTIV_CONTENT_GATEWAY_API
StatusCode 		Unsubscribe (const SubscriptionCookieList &subscriptionCookieList) const
Unsubscribe from the results of multiple requests.
ACTIV_CONTENT_GATEWAY_API
StatusCode 		Unsubscribe (const SubscriptionCookie subscriptionCookie, const SymbolIdList &sourceSymbolIdList) const
Unsubscribe from the results of a request.
ACTIV_CONTENT_GATEWAY_API
StatusCode 		Unsubscribe (const SubscriptionCookie subscriptionCookie) const
Unsubscribe from the results of a request.
ACTIV_CONTENT_GATEWAY_API
StatusCode 		Unsubscribe () const
Unsubscribe from the results of all requests.
virtual ACTIV_CONTENT_GATEWAY_API | ~ContentGatewayClient ()
Destructor.

Static Public Member Functions

static bool | IsCompleteResponse (const HeapMessage &response)
Check if received response message is complete.
static bool | IsValidResponse (const HeapMessage &response)
Check if received response message is valid (complete or partially complete).
static
ACTIV_CONTENT_GATEWAY_API
std::string 		StateToString (const State state)
Convert client state to a string representation.

Protected Member Functions

virtual
ACTIV_CONTENT_GATEWAY_API
StatusCode 		OnBreak (HeapMessage &breakMessage)
A circuit has broken under our feet.
virtual
ACTIV_CONTENT_GATEWAY_API
StatusCode 		OnConnect (HeapMessage &connectMessage)
A circuit has been established.
virtual
ACTIV_CONTENT_GATEWAY_API
StatusCode 		OnConnectFailed (HeapMessage &connectFailMessage)
A circuit has failed to connect.
virtual
ACTIV_CONTENT_GATEWAY_API void 		OnContentGatewayInfoUpdate (const ContentGatewayInfo &contentGatewayInfo)
Callback on content gateway status update from gateway.
virtual
ACTIV_CONTENT_GATEWAY_API
StatusCode 		OnDisconnect (HeapMessage &disconnectMessage)
A circuit has been closed after an asynchronous Disconnect() call.
virtual
ACTIV_CONTENT_GATEWAY_API void 		OnGetEqualResponse (HeapMessage &response)
Called on receiving an asynchronous GetEqual::PostRequest() response.
virtual
ACTIV_CONTENT_GATEWAY_API void 		OnGetFirstHistoryResponse (HeapMessage &response)
Called on receiving an asynchronous GetHistory::PostGetFirstRequest() response.
virtual
ACTIV_CONTENT_GATEWAY_API void 		OnGetFirstIntradayResponse (HeapMessage &response)
Called on receiving an asynchronous GetIntraday::PostGetFirstRequest() response.
virtual
ACTIV_CONTENT_GATEWAY_API void 		OnGetFirstResponse (HeapMessage &response)
Called on receiving an asynchronous GetFirst::PostRequest() response.
virtual
ACTIV_CONTENT_GATEWAY_API void 		OnGetFirstTicksResponse (HeapMessage &response)
Called on receiving an asynchronous GetTicks::PostGetFirstRequest() response.
virtual
ACTIV_CONTENT_GATEWAY_API void 		OnGetLastResponse (HeapMessage &response)
Called on receiving an asynchronous GetLast::PostRequest() response.
virtual
ACTIV_CONTENT_GATEWAY_API void 		OnGetMatchResponse (HeapMessage &response)
Called on receiving an asynchronous GetMatch::PostRequest() response.
virtual
ACTIV_CONTENT_GATEWAY_API void 		OnGetMultipleEqualResponse (HeapMessage &response)
Called on receiving an asynchronous GetMultipleEqual::PostRequest() response.
virtual
ACTIV_CONTENT_GATEWAY_API void 		OnGetMultipleMatchResponse (HeapMessage &response)
Called on receiving an asynchronous GetMultipleMatch::PostRequest() response.
virtual
ACTIV_CONTENT_GATEWAY_API void 		OnGetMultiplePatternMatchListResponse (HeapMessage &response)
Called on receiving an asynchronous GetMultiplePatternMatchList::PostRequest() response.
virtual
ACTIV_CONTENT_GATEWAY_API void 		OnGetMultiplePatternMatchResponse (HeapMessage &response)
Called on receiving an asynchronous GetMultiplePatternMatch::PostRequest() response.
virtual
ACTIV_CONTENT_GATEWAY_API void 		OnGetNewsStoriesResponse (HeapMessage &response)
Called on receiving an asynchronous GetNewsStories::PostRequest() response.
virtual
ACTIV_CONTENT_GATEWAY_API void 		OnGetNextHistoryResponse (HeapMessage &response)
Called on receiving an asynchronous GetHistory::PostGetNextRequest() response.
virtual
ACTIV_CONTENT_GATEWAY_API void 		OnGetNextIntradayResponse (HeapMessage &response)
Called on receiving an asynchronous GetIntraday::PostGetNextRequest() response.
virtual
ACTIV_CONTENT_GATEWAY_API void 		OnGetNextResponse (HeapMessage &response)
Called on receiving an asynchronous GetNext::PostRequest() response.
virtual
ACTIV_CONTENT_GATEWAY_API void 		OnGetNextTicksResponse (HeapMessage &response)
Called on receiving an asynchronous GetTicks::PostGetNextRequest() response.
virtual
ACTIV_CONTENT_GATEWAY_API void 		OnGetPreviousResponse (HeapMessage &response)
Called on receiving an asynchronous GetPrevious::PostRequest() response.
virtual
ACTIV_CONTENT_GATEWAY_API void 		OnGetSymbolsResponse (HeapMessage &response)
Called on receiving an asynchronous GetSymbols::PostRequest() response.
virtual
ACTIV_CONTENT_GATEWAY_API
StatusCode 		OnMessage (HeapMessage &message)
Message callback.
virtual
ACTIV_CONTENT_GATEWAY_API void 		OnNewsUpdate (HeapMessage &update)
Called on receiving a news update.
virtual
ACTIV_CONTENT_GATEWAY_API void 		OnRecordUpdate (HeapMessage &update)
Called on receiving a record update.
virtual
ACTIV_CONTENT_GATEWAY_API void 		OnReportMessage (const std::string &reportMessage)
Callback on report message from gateway.
virtual
ACTIV_CONTENT_GATEWAY_API
StatusCode 		OnResponse (HeapMessage &response)
Response callback.
virtual
ACTIV_CONTENT_GATEWAY_API
StatusCode 		OnTimer (const Address &timerAddress, const BaseTime &time)
Timer callback.

Classes

class | ApiInfo
Information returned from GetApiInfo(). More...
class | ConnectParameters
Parameters for Connect(). More...
class | Settings
Settings for ContentGatewayClient class. More...

Detailed Description

Content gateway client class.

Definition at line 35 of file ContentGatewayClient.h.

Constructor & Destructor Documentation

ACTIV_CONTENT_GATEWAY_API Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::ContentGatewayClient | ( | Application & | application,
 |  | ManagedEndPoint & | managedEndPoint,
 |  | const Settings & | settings = Settings(),
 |  | const std::string & | componentId = defaultComponentId
 | ) |  |

Constructor.

Parameters:
application | reference to an application.
managedEndPoint | endpoint to attach to.
settings | settings.
componentId | component id.
Exceptions:
Exception.

Member Function Documentation

ACTIV_CONTENT_GATEWAY_API StatusCode Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::Connect | ( | const ConnectParameters & | connectParameters,
 |  | const TimeoutPeriod | timeoutPeriod = Port::defaultTimeout
 | ) |  |

Connect to a content gateway.

Parameters:
connectParameters | connection parameters.
timeoutPeriod | timeout in ms. A timeout of 0 implies an asynchronous connect.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_WRONG_STATE | client must be in state STATE_INITIALIZED in order to connect
STATUS_CODE_INVALID_USER | unknown user id
STATUS_CODE_INVALID_PASSWORD | incorrect password for user id
STATUS_CODE_IN_USE | provided user id is already logged on
STATUS_CODE_FULL | the content gateway cannot accept any more clients.
STATUS_CODE_BUSY | the content gateway is too busy to accept a new client.

ACTIV_CONTENT_GATEWAY_API StatusCode Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::Disconnect ( )

Disconnect from a content gateway.

A disconnect is always asynchronous, as data from the current connection may be queued up on the endpoint. An OnDisconnect() callback will be invoked when the connection is fully cleaned up, UNLESS the connection has broken already, in which case an OnBreak() will be invoked, and not OnDisconnect().

Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_CONNECTED

ACTIV_CONTENT_GATEWAY_API ApiInfo Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::GetApiInfo ( ) const

Return information about the API.

Returns:
The api information.

ACTIV_CONTENT_GATEWAY_API StatusCode Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::GetContentGatewayInfo ( ContentGatewayInfo & contentGatewayInfo ) const

Get information about the ContentGateway the API is connected to.

Parameters:
contentGatewayInfo to receive info about the ContentGateway.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_CONNECTED
...

ACTIV_CONTENT_GATEWAY_API std::string Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::GetServiceLocation ( ) const

Return the url of the service we are connected, or connecting, to.

Returns:
The service url.

ACTIV_CONTENT_GATEWAY_API State Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::GetState ( ) const

Get connection state.

Returns:
Connection state.

ACTIV_CONTENT_GATEWAY_API StatusCode Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::GetSubscriptionInfo | ( | const Feed::PermissionLevel | permissionLevel,
 |  | SubscriptionInfo & | subscriptionInfo |
 | ) |  |  | const

Get info about current subscriptions at a particular permission level.

Parameters:
permissionLevel | the permission level to get subscription info at.
subscriptionInfo | to receive the set of current subscriptions.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_CONNECTED
...

bool Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::IsCompleteResponse ( const HeapMessage & response ) [inline, static]

Check if received response message is complete.

Parameters:
response HeapMessage containing a serialized response.
Returns:
true if this is a complete response.

Definition at line 431 of file ContentGatewayClient.h.

References Activ::HeapMessage::GetStatusCode().

bool Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::IsValidResponse ( const HeapMessage & response ) [inline, static]

Check if received response message is valid (complete or partially complete).

Parameters:
response HeapMessage containing a serialized response.
Returns:
true if this is a valid response.

Definition at line 422 of file ContentGatewayClient.h.

References Activ::HeapMessage::GetStatusCode().

virtual ACTIV_CONTENT_GATEWAY_API StatusCode Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::OnBreak ( HeapMessage & breakMessage ) [protected, virtual]

A circuit has broken under our feet.

When overriding, please call the base class version for any unrecognized circuit.

Parameters:
breakMessage the address of the circuit that is now not connected is breakMessage.GetSourceAddress(). A reason for the break can be found in breakMessage.GetStatusCode().
Returns:
The return value is not used by the framework, but may be used by an application to pass values between parent and sub class versions of this function. Returns STATUS_CODE_UNRECOGNIZED by default.

Reimplemented from Activ::Component.

virtual ACTIV_CONTENT_GATEWAY_API StatusCode Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::OnConnect ( HeapMessage & connectMessage ) [protected, virtual]

A circuit has been established.

When overriding, please call the base class version for any unrecognized circuit.

This is called for a successful asynchronous connection. connectMessage.GetSourceAddress() is the circuit that has established.

The message may contain response data from an user data that was sent in the circuit establishment, if the underlying protocol supports it.

For example, if this is the result of an asynchronous OpenService() call, ValidateOpenServiceResponse() should be called.

Parameters:
connectMessage
Returns:
The return value is not used by the framework, but may be used by an application to pass values between parent and sub class versions of this function. Returns STATUS_CODE_UNRECOGNIZED by default.

Reimplemented from Activ::Component.

virtual ACTIV_CONTENT_GATEWAY_API StatusCode Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::OnConnectFailed ( HeapMessage & connectFailMessage ) [protected, virtual]

A circuit has failed to connect.

When overriding, please call the base class version for any unrecognized circuit.

The callback is for informational purposes only. If an asynchronous connection attempts fails, the OnConnectFailed() callback will be invoked but the router service will automatically attempt to connect again on a lazy basis until the circuit is Disconnect()ed. No OnConnectFailed() is called for a synchronous connect (the connect call will just timeout after the specified period with an error status code).

Parameters:
connectFailMessage the circuit that has failed to connect is connectFailMessage.GetSourceAddress(), a reason for the failed connect is connectFailMessage.GetStatusCode().
Returns:
The return value is not used by the framework, but may be used by an application to pass values between parent and sub class versions of this function. Returns STATUS_CODE_UNRECOGNIZED by default.

Reimplemented from Activ::Component.

virtual ACTIV_CONTENT_GATEWAY_API void Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::OnContentGatewayInfoUpdate ( const ContentGatewayInfo & contentGatewayInfo ) [protected, virtual]

Callback on content gateway status update from gateway.

Parameters:
contentGatewayInfo current status of gateway.

virtual ACTIV_CONTENT_GATEWAY_API StatusCode Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::OnDisconnect ( HeapMessage & disconnectMessage ) [protected, virtual]

A circuit has been closed after an asynchronous Disconnect() call.

When overriding, please call the base class version for any unrecognized circuit.

This is called for a successful asynchronous disconnect completion. disconnectMessage.GetSourceAddress() is the circuit that has been established.

The message may contain response data from any user data that was sent in the disconnect, if the underlying protocol supports it.

Parameters:
disconnectMessage
Returns:
The return value is not used by the framework, but may be used by an application to pass values between parent and sub class versions of this function. Returns STATUS_CODE_UNRECOGNIZED by default.

Reimplemented from Activ::Component.

virtual ACTIV_CONTENT_GATEWAY_API void Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::OnGetEqualResponse ( HeapMessage & response ) [protected, virtual]

Called on receiving an asynchronous GetEqual::PostRequest() response.

The response can be deserialized using GetEqual::Deserialize() if it is valid. The validity of the response can be determined using ContentGatewayClient::IsValidResponse(). If this is the final (or only) part of a response, ContentGatewayClient::IsCompleteResponse() will return true.

Parameters:
response HeapMessage containing the serialized response.

Implements Activ::ContentPlatform::ContentGatewayApi::IRealtimeResponses.

virtual ACTIV_CONTENT_GATEWAY_API void Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::OnGetFirstHistoryResponse ( HeapMessage & response ) [protected, virtual]

Called on receiving an asynchronous GetHistory::PostGetFirstRequest() response.

The response can be deserialized using GetHistory::Deserialize() if it is valid. The validity of the response can be determined using ContentGatewayClient::IsValidResponse().

Parameters:
response HeapMessage containing the serialized response.

Implements Activ::ContentPlatform::ContentGatewayApi::ITimeSeriesResponses.

virtual ACTIV_CONTENT_GATEWAY_API void Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::OnGetFirstIntradayResponse ( HeapMessage & response ) [protected, virtual]

Called on receiving an asynchronous GetIntraday::PostGetFirstRequest() response.

The response can be deserialized using GetIntraday::Deserialize() if it is valid. The validity of the response can be determined using ContentGatewayClient::IsValidResponse().

Parameters:
response HeapMessage containing the serialized response.

Implements Activ::ContentPlatform::ContentGatewayApi::ITimeSeriesResponses.

virtual ACTIV_CONTENT_GATEWAY_API void Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::OnGetFirstResponse ( HeapMessage & response ) [protected, virtual]

Called on receiving an asynchronous GetFirst::PostRequest() response.

The response can be deserialized using GetFirst::Deserialize() if it is valid. The validity of the response can be determined using ContentGatewayClient::IsValidResponse(). If this is the final (or only) part of a response, ContentGatewayClient::IsCompleteResponse() will return true.

Parameters:
response HeapMessage containing the serialized response.

Implements Activ::ContentPlatform::ContentGatewayApi::IRealtimeResponses.

virtual ACTIV_CONTENT_GATEWAY_API void Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::OnGetFirstTicksResponse ( HeapMessage & response ) [protected, virtual]

Called on receiving an asynchronous GetTicks::PostGetFirstRequest() response.

The response can be deserialized using GetTicks::Deserialize() if it is valid. The validity of the response can be determined using ContentGatewayClient::IsValidResponse().

Parameters:
response HeapMessage containing the serialized response.

Implements Activ::ContentPlatform::ContentGatewayApi::ITimeSeriesResponses.

virtual ACTIV_CONTENT_GATEWAY_API void Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::OnGetLastResponse ( HeapMessage & response ) [protected, virtual]

Called on receiving an asynchronous GetLast::PostRequest() response.

The response can be deserialized using GetLast::Deserialize() if it is valid. The validity of the response can be determined using ContentGatewayClient::IsValidResponse(). If this is the final (or only) part of a response, ContentGatewayClient::IsCompleteResponse() will return true.

Parameters:
response HeapMessage containing the serialized response.

Implements Activ::ContentPlatform::ContentGatewayApi::IRealtimeResponses.

virtual ACTIV_CONTENT_GATEWAY_API void Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::OnGetMatchResponse ( HeapMessage & response ) [protected, virtual]

Called on receiving an asynchronous GetMatch::PostRequest() response.

The response can be deserialized using GetMatch::Deserialize() if it is valid. The validity of the response can be determined using ContentGatewayClient::IsValidResponse(). If this is the final (or only) part of a response, ContentGatewayClient::IsCompleteResponse() will return true.

Parameters:
response HeapMessage containing the serialized response.

Implements Activ::ContentPlatform::ContentGatewayApi::IRealtimeResponses.

virtual ACTIV_CONTENT_GATEWAY_API void Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::OnGetMultipleEqualResponse ( HeapMessage & response ) [protected, virtual]

Called on receiving an asynchronous GetMultipleEqual::PostRequest() response.

The response can be deserialized using GetMultipleEqual::Deserialize() if it is valid. The validity of the response can be determined using ContentGatewayClient::IsValidResponse(). If this is the final (or only) part of a response, ContentGatewayClient::IsCompleteResponse() will return true.

Parameters:
response HeapMessage containing the serialized response.

Implements Activ::ContentPlatform::ContentGatewayApi::IRealtimeResponses.

virtual ACTIV_CONTENT_GATEWAY_API void Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::OnGetMultipleMatchResponse ( HeapMessage & response ) [protected, virtual]

Called on receiving an asynchronous GetMultipleMatch::PostRequest() response.

The response can be deserialized using GetMultipleMatch::Deserialize() if it is valid. The validity of the response can be determined using ContentGatewayClient::IsValidResponse(). If this is the final (or only) part of a response, ContentGatewayClient::IsCompleteResponse() will return true.

Parameters:
response HeapMessage containing the serialized response.

Implements Activ::ContentPlatform::ContentGatewayApi::IRealtimeResponses.

virtual ACTIV_CONTENT_GATEWAY_API void Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::OnGetMultiplePatternMatchListResponse ( HeapMessage & response ) [protected, virtual]

Called on receiving an asynchronous GetMultiplePatternMatchList::PostRequest() response.

The response can be deserialized using GetMultiplePatternMatchList::Deserialize() if it is valid. The validity of the response can be determined using ContentGatewayClient::IsValidResponse(). If this is the final (or only) part of a response, ContentGatewayClient::IsCompleteResponse() will return true.

Parameters:
response HeapMessage containing the serialized response.

Implements Activ::ContentPlatform::ContentGatewayApi::IRealtimeResponses.

virtual ACTIV_CONTENT_GATEWAY_API void Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::OnGetMultiplePatternMatchResponse ( HeapMessage & response ) [protected, virtual]

Called on receiving an asynchronous GetMultiplePatternMatch::PostRequest() response.

The response can be deserialized using GetMultiplePatternMatch::Deserialize() if it is valid. The validity of the response can be determined using ContentGatewayClient::IsValidResponse(). If this is the final (or only) part of a response, ContentGatewayClient::IsCompleteResponse() will return true.

Parameters:
response HeapMessage containing the serialized response.

Implements Activ::ContentPlatform::ContentGatewayApi::IRealtimeResponses.

virtual ACTIV_CONTENT_GATEWAY_API void Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::OnGetNewsStoriesResponse ( HeapMessage & response ) [protected, virtual]

Called on receiving an asynchronous GetNewsStories::PostRequest() response.

The response can be deserialized using GetNewsStories::Deserialize() if it is valid. The validity of the response can be determined using ContentGatewayClient::IsValidResponse().

Parameters:
response HeapMessage containing the serialized response.

Implements Activ::ContentPlatform::ContentGatewayApi::INewsResponses.

virtual ACTIV_CONTENT_GATEWAY_API void Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::OnGetNextHistoryResponse ( HeapMessage & response ) [protected, virtual]

Called on receiving an asynchronous GetHistory::PostGetNextRequest() response.

The response can be deserialized using GetHistory::Deserialize() if it is valid. The validity of the response can be determined using ContentGatewayClient::IsValidResponse().

Parameters:
response HeapMessage containing the serialized response.

Implements Activ::ContentPlatform::ContentGatewayApi::ITimeSeriesResponses.

virtual ACTIV_CONTENT_GATEWAY_API void Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::OnGetNextIntradayResponse ( HeapMessage & response ) [protected, virtual]

Called on receiving an asynchronous GetIntraday::PostGetNextRequest() response.

The response can be deserialized using GetIntraday::Deserialize() if it is valid. The validity of the response can be determined using ContentGatewayClient::IsValidResponse().

Parameters:
response HeapMessage containing the serialized response.

Implements Activ::ContentPlatform::ContentGatewayApi::ITimeSeriesResponses.

virtual ACTIV_CONTENT_GATEWAY_API void Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::OnGetNextResponse ( HeapMessage & response ) [protected, virtual]

Called on receiving an asynchronous GetNext::PostRequest() response.

The response can be deserialized using GetNext::Deserialize() if it is valid. The validity of the response can be determined using ContentGatewayClient::IsValidResponse(). If this is the final (or only) part of a response, ContentGatewayClient::IsCompleteResponse() will return true.

Parameters:
response HeapMessage containing the serialized response.

Implements Activ::ContentPlatform::ContentGatewayApi::IRealtimeResponses.

virtual ACTIV_CONTENT_GATEWAY_API void Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::OnGetNextTicksResponse ( HeapMessage & response ) [protected, virtual]

Called on receiving an asynchronous GetTicks::PostGetNextRequest() response.

The response can be deserialized using GetTicks::Deserialize() if it is valid. The validity of the response can be determined using ContentGatewayClient::IsValidResponse().

Parameters:
response HeapMessage containing the serialized response.

Implements Activ::ContentPlatform::ContentGatewayApi::ITimeSeriesResponses.

virtual ACTIV_CONTENT_GATEWAY_API void Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::OnGetPreviousResponse ( HeapMessage & response ) [protected, virtual]

Called on receiving an asynchronous GetPrevious::PostRequest() response.

The response can be deserialized using GetPrevious::Deserialize() if it is valid. The validity of the response can be determined using ContentGatewayClient::IsValidResponse(). If this is the final (or only) part of a response, ContentGatewayClient::IsCompleteResponse() will return true.

Parameters:
response HeapMessage containing the serialized response.

Implements Activ::ContentPlatform::ContentGatewayApi::IRealtimeResponses.

virtual ACTIV_CONTENT_GATEWAY_API void Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::OnGetSymbolsResponse ( HeapMessage & response ) [protected, virtual]

Called on receiving an asynchronous GetSymbols::PostRequest() response.

The response can be deserialized using GetSymbols::Deserialize() if it is valid. The validity of the response can be determined using ContentGatewayClient::IsValidResponse().

Parameters:
response HeapMessage containing the serialized response.

Implements Activ::ContentPlatform::ContentGatewayApi::ISymbolDirectoryResponses.

virtual ACTIV_CONTENT_GATEWAY_API StatusCode Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::OnMessage ( HeapMessage & message ) [protected, virtual]

Message callback.

If you override this method, please call the base class method for any unrecognized message types.

Parameters:
message the message.
Return values:
STATUS_CODE_SUCCESS | the message was recognized.
STATUS_CODE_UNRECOGNIZED | the message was not recognized.
STATUS_CODE_THREAD_EXIT | received a thread-die message.
...

Reimplemented from Activ::Component.

virtual ACTIV_CONTENT_GATEWAY_API void Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::OnNewsUpdate ( HeapMessage & update ) [protected, virtual]

Called on receiving a news update.

The message can be deserialized using NewsUpdateHelper::Deserialize().

Parameters:
update HeapMessage containing the serialized update message.

Implements Activ::ContentPlatform::ContentGatewayApi::INewsResponses.

virtual ACTIV_CONTENT_GATEWAY_API void Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::OnRecordUpdate ( HeapMessage & update ) [protected, virtual]

Called on receiving a record update.

The message can be deserialized using RecordUpdateHelper::Deserialize().

Parameters:
update HeapMessage containing the serialized update message.

Implements Activ::ContentPlatform::ContentGatewayApi::IRealtimeResponses.

virtual ACTIV_CONTENT_GATEWAY_API void Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::OnReportMessage ( const std::string & reportMessage ) [protected, virtual]

Callback on report message from gateway.

Parameters:
reportMessage message from gateway.

virtual ACTIV_CONTENT_GATEWAY_API StatusCode Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::OnResponse ( HeapMessage & response ) [protected, virtual]

Response callback.

If you override this method, please call the base class method for any unrecognized request types.

Parameters:
response the response message.
Return values:
STATUS_CODE_SUCCESS | the message was recognized.
STATUS_CODE_UNRECOGNIZED | the message was not recognized.
STATUS_CODE_THREAD_EXIT | received a thread-die message.
...

Reimplemented from Activ::Port.

virtual ACTIV_CONTENT_GATEWAY_API StatusCode Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::OnTimer | ( | const Address & | timerAddress,
 |  | const BaseTime & | time |
 | ) |  |  | [protected, virtual]

Timer callback.

When overriding, please call the base class version for any unrecognized timer.

Parameters:
timerAddress | the timer address.
time | the date/time of the timer.
Returns:
The return value is not used by the framework, but may be used by an application to pass values between parent and sub class versions of this function. Returns STATUS_CODE_UNRECOGNIZED by default.

Reimplemented from Activ::Component.

static ACTIV_CONTENT_GATEWAY_API std::string Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::StateToString ( const State state ) [static]

Convert client state to a string representation.

Parameters:
state a client state.
Returns:
String representation of state.

ACTIV_CONTENT_GATEWAY_API StatusCode Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::SubscribeToFeed | ( | const SubscribeFeedParameters & | subscribeFeedParameters,
 |  | SubscriptionCookie & | subscriptionCookie |
 | ) |  |  | const

Subscribe to updates on the feed.

If a previous SubscribeToFeed() had been made, the event type filter will be overwritten with the new parameters.

Parameters:
subscribeFeedParameters | subscription parameters.
subscriptionCookie | cookie returned on success that can be passed to Unsubscribe().
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_CONNECTED
...

ACTIV_CONTENT_GATEWAY_API StatusCode Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::SubscribeToTable | ( | const SubscribeTableParameters & | subscribeTableParameters,
 |  | SubscriptionCookie & | subscriptionCookie |
 | ) |  |  | const

Subscribe to updates to a table.

Parameters:
subscribeTableParameters | subscription parameters.
subscriptionCookie | cookie returned on success that can be passed to Unsubscribe().
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_CONNECTED
...

ACTIV_CONTENT_GATEWAY_API StatusCode Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::Unsubscribe ( const SubscriptionCookieList & subscriptionCookieList ) const

Unsubscribe from the results of multiple requests.

All target symbols from the requests corresponding to subscriptionCookieList are unsubscribed.

Parameters:
subscriptionCookieList a list of SubscriptionCookie as returned by a realtime responses.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_CONNECTED
...

ACTIV_CONTENT_GATEWAY_API StatusCode Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::Unsubscribe | ( | const SubscriptionCookie | subscriptionCookie,
 |  | const SymbolIdList & | sourceSymbolIdList |
 | ) |  |  | const

Unsubscribe from the results of a request.

Only target symbols from the request corresponding to subscriptionCookie where the source symbols are sourceSymbolIdList are unsubscribed.

Parameters:
subscriptionCookie | SubscriptionCookie as returned by a realtime response.
sourceSymbolIdList | source symbol list.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_CONNECTED
...

ACTIV_CONTENT_GATEWAY_API StatusCode Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::Unsubscribe ( const SubscriptionCookie subscriptionCookie ) const

Unsubscribe from the results of a request.

All target symbols from the request corresponding to subscriptionCookie are unsubscribed.

Parameters:
subscriptionCookie SubscriptionCookie as returned by a realtime response.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_CONNECTED
...

ACTIV_CONTENT_GATEWAY_API StatusCode Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::Unsubscribe ( ) const

Unsubscribe from the results of all requests.

Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_CONNECTED
...

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivContentGatewayApi/ContentGatewayClient.h
Generated on Wed Oct 8 14:02:02 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::ApiInfo

Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::ApiInfo Class Reference

Information returned from GetApiInfo(). More...

#include <ActivContentPlatform/ActivContentGatewayApi/ContentGatewayClient.h>

List of all members.

Public Attributes

std::string | m_buildConfiguration
Build configuration, e.g. x86_win32_vc71_mdi.
std::string | m_buildDateTime
Date and time api was built.
std::string | m_version
Version.

Detailed Description

Information returned from GetApiInfo().

Definition at line 156 of file ContentGatewayClient.h.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivContentGatewayApi/ContentGatewayClient.h
Generated on Wed Oct 8 14:02:02 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::ConnectParameters

Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::ConnectParameters Class Reference

Parameters for Connect(). More...

#include <ActivContentPlatform/ActivContentGatewayApi/ContentGatewayClient.h>

List of all members.

Public Types

enum | Policy { ACTIV_DECLARE_VALUE_WITH_COMMA }

Public Member Functions

ACTIV_CONTENT_GATEWAY_API | ConnectParameters ()
Default constructor.

Public Attributes

AgentScope | m_agentScope
The agent scope to use when failing over.
std::string | m_attributeQuery
The attribute query to use when failing over.
uint16_t | m_failoverSeconds
Find alternative server after this number of seconds if connection down.
std::string | m_infoString
String to pass to the ContenGateway for informational purposes.
LogonFlags | m_logonFlags
See definitions in include/ActivContentPlatform/ActivContentGatewayApiCommon/Types.h.
std::string | m_password
Password.
Policy m_policy
Action to take on a connection break.
ServiceId m_serviceId
Id of service to connect to.
std::string | m_url
Url of service.
std::string | m_userId
User id.
UserType | m_userType
User type.

Static Public Attributes

static const uint16_t | DEFAULT_FAILOVER_SECONDS = 15

Detailed Description

Parameters for Connect().

Definition at line 115 of file ContentGatewayClient.h.

Member Enumeration Documentation

enum Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::ConnectParameters::Policy

Attempt to reconnect to a randomly chosen gateway

Definition at line 126 of file ContentGatewayClient.h.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivContentGatewayApi/ContentGatewayClient.h
Generated on Wed Oct 8 14:02:02 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::Settings

Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::Settings Class Reference

Settings for ContentGatewayClient class. More...

#include <ActivContentPlatform/ActivContentGatewayApi/ContentGatewayClient.h>

List of all members.

Public Member Functions

ACTIV_CONTENT_GATEWAY_API | Settings ()
Default constructor.
ACTIV_CONTENT_GATEWAY_API | ~Settings ()
Destructor.

Public Attributes

bool | m_createMutex
Client methods to be called from multiple threads.
IHeap::BucketInfoVector m_heapBucketInfoVector
Size of heap to use for client.
IHeap * m_pHeap
Heap to use for messaging.

Detailed Description

Settings for ContentGatewayClient class.

Definition at line 86 of file ContentGatewayClient.h.

Constructor & Destructor Documentation

ACTIV_CONTENT_GATEWAY_API Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::Settings::Settings ( )

Default constructor.

Default settings are: m_createMutex true m_heapBucketInfoVector see ACTIV_CONTENT_GATEWAY_CLIENT_DEFAULT_HEAP_SIZE m_pHeap 0 (create a heap of size m_heapBucketInfoVector). Set to non 0 to override.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivContentGatewayApi/ContentGatewayClient.h
Generated on Wed Oct 8 14:02:02 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::ContentGatewayInfo

Activ::ContentPlatform::ContentGatewayApi::ContentGatewayInfo Class Reference

Information about the ContentGateway. More...

#include <ActivContentPlatform/ActivContentGatewayApiCommon/Types.h>

List of all members.

Public Types

typedef uint8_t | Flags
Update flags.
typedef std::vector
< Feed::PermissionLevel > 		PermissionLevelList

Public Attributes

Flags m_flags
bool | m_isHistoryServiceAvailable
bool | m_isNewsServerServiceAvailable
bool | m_isSymbolDirectoryServiceAvailable
PermissionLevelList | m_permissionLevelList
available permission levels on the CG
ISystem::SystemInfo m_systemInfo
info about the CG machine
std::string | m_version
ContentGateway version.

Static Public Attributes

static const Flags | FLAG_HISTORY_SERVICE_CHANGED = 0x01
static const Flags | FLAG_NEWS_SERVER_SERVICE_CHANGED = 0x04
static const Flags | FLAG_NONE = 0x00
static const Flags | FLAG_SYMBOL_DIRECTORY_SERVICE_CHANGED = 0x02

Detailed Description

Information about the ContentGateway.

Definition at line 286 of file Types.h.

Member Typedef Documentation

typedef uint8_t Activ::ContentPlatform::ContentGatewayApi::ContentGatewayInfo::Flags

Update flags.

The availabilty of the news server service has changed

Definition at line 297 of file Types.h.

Member Data Documentation

const Flags Activ::ContentPlatform::ContentGatewayApi::ContentGatewayInfo::FLAG_HISTORY_SERVICE_CHANGED = 0x01 [static]

Nothing has changed

Definition at line 298 of file Types.h.

const Flags Activ::ContentPlatform::ContentGatewayApi::ContentGatewayInfo::FLAG_NEWS_SERVER_SERVICE_CHANGED = 0x04 [static]

The availabilty of the symbol directory service has changed

Definition at line 298 of file Types.h.

const Flags Activ::ContentPlatform::ContentGatewayApi::ContentGatewayInfo::FLAG_SYMBOL_DIRECTORY_SERVICE_CHANGED = 0x02 [static]

The availabilty of the history service has changed

Definition at line 298 of file Types.h.

Flags Activ::ContentPlatform::ContentGatewayApi::ContentGatewayInfo::m_flags

The availabilty of the news server service has changed

Definition at line 300 of file Types.h.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivContentGatewayApiCommon/Types.h
Generated on Wed Oct 8 14:02:02 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::DataPointAddress

Activ::ContentPlatform::ContentGatewayApi::DataPointAddress Class Reference

Address of an individual data point. More...

#include <ActivContentPlatform/ActivContentGatewayApiCommon/TimeSeriesTypes.h>

List of all members.

Public Types

typedef uint16_t | Flags
Request flags type.
typedef uint32_t | SectorNumber
typedef uint16_t | SequenceNumber

Public Member Functions

ACTIV_CONTENT_GATEWAY_API_COMMON_API
StatusCode 		Deserialize (MessageValidator &messageValidator)
Deserialize.
ACTIV_CONTENT_GATEWAY_API_COMMON_API
bool 		operator== (const DataPointAddress &rhs) const
Equality operator.
ACTIV_CONTENT_GATEWAY_API_COMMON_API
StatusCode 		Serialize (MessageBuilder &messageBuilder) const
Serialize.

Public Attributes

DateTime | m_dateTime
Flags | m_internalFlag
SectorNumber | m_sectorNumber
SequenceNumber | m_sequenceNumber

Detailed Description

Address of an individual data point.

Definition at line 189 of file TimeSeriesTypes.h.

Member Function Documentation

ACTIV_CONTENT_GATEWAY_API_COMMON_API StatusCode Activ::ContentPlatform::ContentGatewayApi::DataPointAddress::Deserialize ( MessageValidator & messageValidator )

Deserialize.

Parameters:
messageValidator message validator.
Return values:
STATUS_CODE_SUCCESS.
...

ACTIV_CONTENT_GATEWAY_API_COMMON_API bool Activ::ContentPlatform::ContentGatewayApi::DataPointAddress::operator== ( const DataPointAddress & rhs ) const

Equality operator.

Parameters:
rhs the object to test against.
Returns:
whether the two objects are equal.

ACTIV_CONTENT_GATEWAY_API_COMMON_API StatusCode Activ::ContentPlatform::ContentGatewayApi::DataPointAddress::Serialize ( MessageBuilder & messageBuilder ) const

Serialize.

Parameters:
messageBuilder message builder.
Return values:
STATUS_CODE_SUCCESS.
...

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivContentGatewayApiCommon/TimeSeriesTypes.h
Generated on Wed Oct 8 14:02:02 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::FieldData

Activ::ContentPlatform::ContentGatewayApi::FieldData Class Reference

Opaque field data block. More...

#include <ActivContentPlatform/ActivContentGatewayApiCommon/Types.h>

List of all members.

Public Types

typedef SerializableBuffer
< uint16_t > 		Buffer
Serialized field data buffer type.

Public Member Functions

bool IsEmpty () const
Is field data empty?

Public Attributes

Buffer m_buffer
Buffer containing field data.
MessageHandler::MessageVersion m_messageVersion
Version of serialized field data.

Detailed Description

Opaque field data block.

Definition at line 213 of file Types.h.

Member Function Documentation

bool Activ::ContentPlatform::ContentGatewayApi::FieldData::IsEmpty ( ) const [inline]

Is field data empty?

Returns:
true if there is no field data.

Definition at line 231 of file Types.h.

References Activ::SerializableBuffer< LENGTH_TYPE, MIN_LENGTH, MAX_LENGTH >::GetDataLength(), and m_buffer.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivContentGatewayApiCommon/Types.h
Generated on Wed Oct 8 14:02:02 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::FieldListValidator

Activ::ContentPlatform::ContentGatewayApi::FieldListValidator Class Reference

Field list validator class. More...

#include <ActivContentPlatform/ActivContentGatewayApi/FieldListValidator.h>

Inheritance diagram for Activ::ContentPlatform::ContentGatewayApi::FieldListValidator:

Activ::ContentPlatform::FeedApi::FieldListValidator

List of all members.

Public Member Functions

ACTIV_CONTENT_GATEWAY_API
StatusCode 		ApplyUpdate (const FieldData &fieldData)
Apply fields to this.
ACTIV_CONTENT_GATEWAY_API
StatusCode 		ApplyUpdateToExistingFieldsOnly (const FieldData &fieldData)
Apply only the fields from a FieldData to this that already exist in this.
ACTIV_CONTENT_GATEWAY_API | FieldListValidator (const FieldData &fieldData)
Constructor.
ACTIV_CONTENT_GATEWAY_API | FieldListValidator (const FieldListValidator &rhs)
Copy constructor.
ACTIV_CONTENT_GATEWAY_API | FieldListValidator ()
Default constructor.
ACTIV_CONTENT_GATEWAY_API
StatusCode 		Initialize (const FieldData &fieldData)
Initialize.

Public Attributes

MessageValidator m_messageValidator
to validate serialized data

Detailed Description

Field list validator class.

Note this class is not thread safe. Do not make concurrent calls to its methods from multiple threads.

Definition at line 29 of file FieldListValidator.h.

Constructor & Destructor Documentation

ACTIV_CONTENT_GATEWAY_API Activ::ContentPlatform::ContentGatewayApi::FieldListValidator::FieldListValidator ( const FieldListValidator & rhs )

Copy constructor.

Parameters:
rhs a FieldListValidator to copy fields from.

ACTIV_CONTENT_GATEWAY_API Activ::ContentPlatform::ContentGatewayApi::FieldListValidator::FieldListValidator ( const FieldData & fieldData )

Constructor.

Parameters:
fieldData reference to a FieldData object containing serialized field data with which to initialize this object.
Exceptions:
StatusCodeException.

Member Function Documentation

ACTIV_CONTENT_GATEWAY_API StatusCode Activ::ContentPlatform::ContentGatewayApi::FieldListValidator::ApplyUpdate ( const FieldData & fieldData )

Apply fields to this.

This call differs from an Initialize() call in that existing fields are not cleared. Note fields in fieldData that have the rule RULE_DOES_NOT_UPDATE_LAST_VALUE will not be applied to this.

Parameters:
fieldData the fields to apply.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT
STATUS_CODE_HEAP_EMPTY
...

ACTIV_CONTENT_GATEWAY_API StatusCode Activ::ContentPlatform::ContentGatewayApi::FieldListValidator::ApplyUpdateToExistingFieldsOnly ( const FieldData & fieldData )

Apply only the fields from a FieldData to this that already exist in this.

This call differs from an Initialize() call in that existing fields are not cleared. Note fields in fieldData that have the rule RULE_DOES_NOT_UPDATE_LAST_VALUE will not be applied to this.

Parameters:
fieldData the fields to apply.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT
STATUS_CODE_HEAP_EMPTY
...

ACTIV_CONTENT_GATEWAY_API StatusCode Activ::ContentPlatform::ContentGatewayApi::FieldListValidator::Initialize ( const FieldData & fieldData )

Initialize.

This call clears any fields currently in this object. New fields are then added from the fieldData object.

Parameters:
fieldData reference to a FieldData object containing serialized field data.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT
...

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivContentGatewayApi/FieldListValidator.h
Generated on Wed Oct 8 14:02:02 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::FieldSet

Activ::ContentPlatform::ContentGatewayApi::FieldSet Class Reference

Field Set base class. More...

#include <ActivContentPlatform/ActivContentGatewayApiCommon/FieldSet.h>

Inheritance diagram for Activ::ContentPlatform::ContentGatewayApi::FieldSet:

Activ::ContentPlatform::ContentGatewayApi::HistoryBar Activ::ContentPlatform::ContentGatewayApi::IntradayBar Activ::ContentPlatform::ContentGatewayApi::OptionBar Activ::ContentPlatform::ContentGatewayApi::Tick

List of all members.

Public Types

enum | FieldSetListFindMode { ACTIV_DECLARE_ELEMENT_1_WITH_COMMA }
enum | FilterStatus { ACTIV_DECLARE_ELEMENT_1_WITH_COMMA }
enum | UpdateFieldSetStatus { ACTIV_DECLARE_ELEMENT_1_WITH_COMMA }
Update return status.

Public Member Functions

virtual
ACTIV_CONTENT_GATEWAY_API_COMMON_API
StatusCode 		Deserialize (MessageValidator &messageValidator)
Deserialize the object from the supplied message validator.
FieldSet ()
Constructor.
virtual
ACTIV_CONTENT_GATEWAY_API_COMMON_API
StatusCode 		FromString (const std::string &inputStr, const std::string &deliminator=DEFAULT_STRING_FIELD_SEPARATER)
Set the object value from a string.
virtual
ACTIV_CONTENT_GATEWAY_API_COMMON_API
StatusCode 		GetField (const Feed::FieldId fieldId, IFieldType &field) const
Get a field.
byte_t | GetSequence () const
Get the sequence number used to identify the position in the block.
virtual
ACTIV_CONTENT_GATEWAY_API_COMMON_API
size_t 		GetSerializedLength () const
Get the serialized length of the object.
virtual
ACTIV_CONTENT_GATEWAY_API_COMMON_API
FieldSetType 		GetType () const
Get the field set type.
StatusCode | ProcessSplit (const int sharesBefore, const int sharesAfter, const Rational::Denominator type)
split adjust
virtual void | Reset ()
Reset all values in the field set.
virtual
ACTIV_CONTENT_GATEWAY_API_COMMON_API
StatusCode 		Serialize (MessageBuilder &messageBuilder) const
Serialize the object into the supplied message builder.
virtual
ACTIV_CONTENT_GATEWAY_API_COMMON_API
StatusCode 		SetField (const Feed::FieldId fieldId, const IFieldType &field)
Get a field.
void | SetSequence (byte_t sequence)
Set the sequence number used to identify the position in the block.
virtual
ACTIV_CONTENT_GATEWAY_API_COMMON_API
std::string 		ToString (const std::string &deliminator=DEFAULT_STRING_FIELD_SEPARATER) const
Convert the object to a string.
virtual
ACTIV_CONTENT_GATEWAY_API_COMMON_API 		~FieldSet ()
Destructor.

Static Public Member Functions

static StatusCode | FindContentSubstring (const std::string &input, const std::string &deliminator, std::string::size_type &startPos, std::string &subStringOut)
static
ACTIV_CONTENT_GATEWAY_API_COMMON_API
size_t 		GetMaxSerializedLength ()
Get the maximum serialized length.
static
ACTIV_CONTENT_GATEWAY_API_COMMON_API
char * 		RationalToDoubleString (const Rational &rational, char *buffer)
static
ACTIV_CONTENT_GATEWAY_API_COMMON_API
StatusCode 		ReadDate (const std::string &input, const std::string &deliminator, std::string::size_type &startingPos, Date &dateOut)
helper function to read in delimiated date
static
ACTIV_CONTENT_GATEWAY_API_COMMON_API
StatusCode 		ReadDateTime (const std::string &input, const std::string &deliminator, std::string::size_type &startPos, DateTime &dateTimeOut)
helper function to read in delimiated dateTime
static StatusCode | ReadInteger (const std::string &input, const std::string &deliminator, std::string::size_type &startPos, uint32_t &uintOut)
helper function to read in delimiated integer
static
ACTIV_CONTENT_GATEWAY_API_COMMON_API
StatusCode 		ReadRationalFromDoubleString (const std::string &input, const std::string &deliminator, std::string::size_type &startPos, Rational &rationalOut)
helper function to read delimiated double string into rational
static
ACTIV_CONTENT_GATEWAY_API_COMMON_API
StatusCode 		ReadTime (const std::string &input, const std::string &deliminator, std::string::size_type &startingPos, Time &timeOut)
helper function to read in delimiated date

Static Public Attributes

static
ACTIV_CONTENT_GATEWAY_API_COMMON_API
const std::string 		DEFAULT_STRING_FIELD_SEPARATER

Detailed Description

Field Set base class.

Definition at line 100 of file FieldSet.h.

Member Function Documentation

virtual ACTIV_CONTENT_GATEWAY_API_COMMON_API StatusCode Activ::ContentPlatform::ContentGatewayApi::FieldSet::Deserialize ( MessageValidator & messageValidator ) [virtual]

Deserialize the object from the supplied message validator.

Parameters:
messageValidator the message validator from which the object will be extracted.
Return values:
STATUS_CODE_SUCCESS
...

Reimplemented in Activ::ContentPlatform::ContentGatewayApi::HistoryBar, Activ::ContentPlatform::ContentGatewayApi::IntradayBar, Activ::ContentPlatform::ContentGatewayApi::OptionBar, and Activ::ContentPlatform::ContentGatewayApi::Tick.

virtual ACTIV_CONTENT_GATEWAY_API_COMMON_API StatusCode Activ::ContentPlatform::ContentGatewayApi::FieldSet::FromString | ( | const std::string & | inputStr,
 |  | const std::string & | deliminator = DEFAULT_STRING_FIELD_SEPARATER |
 | ) |  |  | [virtual]

Set the object value from a string.

Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
......

Reimplemented in Activ::ContentPlatform::ContentGatewayApi::HistoryBar, Activ::ContentPlatform::ContentGatewayApi::IntradayBar, and Activ::ContentPlatform::ContentGatewayApi::Tick.

virtual ACTIV_CONTENT_GATEWAY_API_COMMON_API StatusCode Activ::ContentPlatform::ContentGatewayApi::FieldSet::GetField | ( | const Feed::FieldId | fieldId,
 |  | IFieldType & | field |
 | ) |  |  | const [virtual]

Get a field.

Parameters:
fieldId | field's id.
field | actual field.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FIELD
STATUS_CODE_UNDEFINED_FIELD

Reimplemented in Activ::ContentPlatform::ContentGatewayApi::HistoryBar, Activ::ContentPlatform::ContentGatewayApi::IntradayBar, Activ::ContentPlatform::ContentGatewayApi::OptionBar, and Activ::ContentPlatform::ContentGatewayApi::Tick.

static ACTIV_CONTENT_GATEWAY_API_COMMON_API size_t Activ::ContentPlatform::ContentGatewayApi::FieldSet::GetMaxSerializedLength ( ) [static]

Get the maximum serialized length.

Returns:
the maximum serialized length.

Reimplemented in Activ::ContentPlatform::ContentGatewayApi::HistoryBar, Activ::ContentPlatform::ContentGatewayApi::IntradayBar, Activ::ContentPlatform::ContentGatewayApi::OptionBar, and Activ::ContentPlatform::ContentGatewayApi::Tick.

byte_t Activ::ContentPlatform::ContentGatewayApi::FieldSet::GetSequence ( ) const [inline]

Get the sequence number used to identify the position in the block.

Return values:
sequence number

Definition at line 474 of file FieldSet.h.

virtual ACTIV_CONTENT_GATEWAY_API_COMMON_API size_t Activ::ContentPlatform::ContentGatewayApi::FieldSet::GetSerializedLength ( ) const [virtual]

Get the serialized length of the object.

Returns:
the serialized length of the object.

Reimplemented in Activ::ContentPlatform::ContentGatewayApi::HistoryBar, Activ::ContentPlatform::ContentGatewayApi::IntradayBar, Activ::ContentPlatform::ContentGatewayApi::OptionBar, and Activ::ContentPlatform::ContentGatewayApi::Tick.

virtual ACTIV_CONTENT_GATEWAY_API_COMMON_API FieldSetType Activ::ContentPlatform::ContentGatewayApi::FieldSet::GetType ( ) const [virtual]

Get the field set type.

Returns:
the field type.

Reimplemented in Activ::ContentPlatform::ContentGatewayApi::HistoryBar, Activ::ContentPlatform::ContentGatewayApi::IntradayBar, Activ::ContentPlatform::ContentGatewayApi::OptionBar, and Activ::ContentPlatform::ContentGatewayApi::Tick.

StatusCode Activ::ContentPlatform::ContentGatewayApi::FieldSet::ProcessSplit | ( | const int | sharesBefore,
 |  | const int | sharesAfter,
 |  | const Rational::Denominator | type |
 | ) |  |  | [inline]

split adjust

Parameters:
sharesBefore | Shares before adjusting
sharesAfter | Shares after adjusting
type | the Rational::Denominator type
Return values:
STATUS_CODE_SUCCESS

Reimplemented in Activ::ContentPlatform::ContentGatewayApi::HistoryBar, Activ::ContentPlatform::ContentGatewayApi::IntradayBar, and Activ::ContentPlatform::ContentGatewayApi::Tick.

Definition at line 507 of file FieldSet.h.

static ACTIV_CONTENT_GATEWAY_API_COMMON_API StatusCode Activ::ContentPlatform::ContentGatewayApi::FieldSet::ReadDate | ( | const std::string & | input,
 |  | const std::string & | deliminator,
 |  | std::string::size_type & | startingPos,
 |  | Date & | dateOut |
 | ) |  |  | [static]

helper function to read in delimiated date

Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
...

static ACTIV_CONTENT_GATEWAY_API_COMMON_API StatusCode Activ::ContentPlatform::ContentGatewayApi::FieldSet::ReadDateTime | ( | const std::string & | input,
 |  | const std::string & | deliminator,
 |  | std::string::size_type & | startPos,
 |  | DateTime & | dateTimeOut |
 | ) |  |  | [static]

helper function to read in delimiated dateTime

Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
...

StatusCode Activ::ContentPlatform::ContentGatewayApi::FieldSet::ReadInteger | ( | const std::string & | input,
 |  | const std::string & | deliminator,
 |  | std::string::size_type & | startPos,
 |  | uint32_t & | uintOut |
 | ) |  |  | [inline, static]

helper function to read in delimiated integer

Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
...

Definition at line 497 of file FieldSet.h.

References ACTIV_RETURN_RESULT_IF.

static ACTIV_CONTENT_GATEWAY_API_COMMON_API StatusCode Activ::ContentPlatform::ContentGatewayApi::FieldSet::ReadRationalFromDoubleString | ( | const std::string & | input,
 |  | const std::string & | deliminator,
 |  | std::string::size_type & | startPos,
 |  | Rational & | rationalOut |
 | ) |  |  | [static]

helper function to read delimiated double string into rational

Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
...

static ACTIV_CONTENT_GATEWAY_API_COMMON_API StatusCode Activ::ContentPlatform::ContentGatewayApi::FieldSet::ReadTime | ( | const std::string & | input,
 |  | const std::string & | deliminator,
 |  | std::string::size_type & | startingPos,
 |  | Time & | timeOut |
 | ) |  |  | [static]

helper function to read in delimiated date

Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
...

virtual ACTIV_CONTENT_GATEWAY_API_COMMON_API StatusCode Activ::ContentPlatform::ContentGatewayApi::FieldSet::Serialize ( MessageBuilder & messageBuilder ) const [virtual]

Serialize the object into the supplied message builder.

Parameters:
messageBuilder the message builder to store a serialized version of the object in.
Return values:
STATUS_CODE_SUCCESS
...

Reimplemented in Activ::ContentPlatform::ContentGatewayApi::HistoryBar, Activ::ContentPlatform::ContentGatewayApi::IntradayBar, Activ::ContentPlatform::ContentGatewayApi::OptionBar, and Activ::ContentPlatform::ContentGatewayApi::Tick.

virtual ACTIV_CONTENT_GATEWAY_API_COMMON_API StatusCode Activ::ContentPlatform::ContentGatewayApi::FieldSet::SetField | ( | const Feed::FieldId | fieldId,
 |  | const IFieldType & | field |
 | ) |  |  | [virtual]

Get a field.

Parameters:
fieldId | field's id.
field | actual field.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FIELD
STATUS_CODE_UNDEFINED_FIELD

Reimplemented in Activ::ContentPlatform::ContentGatewayApi::HistoryBar, Activ::ContentPlatform::ContentGatewayApi::IntradayBar, Activ::ContentPlatform::ContentGatewayApi::OptionBar, and Activ::ContentPlatform::ContentGatewayApi::Tick.

void Activ::ContentPlatform::ContentGatewayApi::FieldSet::SetSequence ( byte_t sequence ) [inline]

Set the sequence number used to identify the position in the block.

Parameters:
sequence sequence number to set to

Definition at line 467 of file FieldSet.h.

virtual ACTIV_CONTENT_GATEWAY_API_COMMON_API std::string Activ::ContentPlatform::ContentGatewayApi::FieldSet::ToString ( const std::string & deliminator = DEFAULT_STRING_FIELD_SEPARATER ) const [virtual]

Convert the object to a string.

Returns:
the object as a string.

Reimplemented in Activ::ContentPlatform::ContentGatewayApi::HistoryBar, Activ::ContentPlatform::ContentGatewayApi::IntradayBar, and Activ::ContentPlatform::ContentGatewayApi::Tick.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivContentGatewayApiCommon/FieldSet.h
Generated on Wed Oct 8 14:02:02 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::HistoryBar

Activ::ContentPlatform::ContentGatewayApi::HistoryBar Class Reference

History Bar Field Set class. More...

#include <ActivContentPlatform/ActivContentGatewayApiCommon/HistoryBar.h>

Inheritance diagram for Activ::ContentPlatform::ContentGatewayApi::HistoryBar:

Activ::ContentPlatform::ContentGatewayApi::FieldSet

List of all members.

Public Types

enum | HistoryAdjustmentType { ACTIV_DECLARE_ELEMENT_1_WITH_COMMA }

Public Member Functions

ACTIV_IMPORT_DLL void | Adjust (const HistoryAdjustmentType adjustmentType, const Rational &amount, const Rational::Denominator denominator)
Adjust data, by dataquality group.
virtual ACTIV_IMPORT_DLL StatusCode | BuildClosedSessionBarFromRecord (const Database::Record &record)
StatusCode | Compare (const HistoryBar &rhs, int &result) const
compares dateTime only
ACTIV_IMPORT_DLL bool | Compare (const HistoryBar &rhs) const
Full compare.
virtual ACTIV_IMPORT_DLL StatusCode | Deserialize (MessageValidator &messageValidator)
Deserialize the object from the supplied message validator.
ACTIV_IMPORT_DLL void | ForceDecimalType (const Rational::Denominator type)
Force Decimal Type of price to a given type if it has more decimal than the given one The type have to be WHOLE to 9DP. Otherwise, nothing happens.
virtual ACTIV_IMPORT_DLL StatusCode | FromString (const std::string &inputStr, const std::string &deliminator=DEFAULT_STRING_FIELD_SEPARATER)
Set the object value from a string.
virtual ACTIV_IMPORT_DLL StatusCode | FromStringSpecial (const std::string &inputStr)
Set the object value from a string.
StatusCode | GetClosePrice (double &price) const
Get the close price.
StatusCode | GetClosePrice (Rational &price) const
Get the close price.
StatusCode | GetDate (Date &date) const
Get the date.
StatusCode | GetDateTime (DateTime &dateTime) const
Get the date.
virtual ACTIV_IMPORT_DLL StatusCode | GetField (const Feed::FieldId fieldId, IFieldType &field) const
Get a field.
StatusCode | GetHighPrice (double &price) const
Get the high price.
StatusCode | GetHighPrice (Rational &price) const
Get the high price.
StatusCode | GetLowPrice (double &price) const
Get the low price.
StatusCode | GetLowPrice (Rational &price) const
Get the low price.
StatusCode | GetOpenInterest (uint32_t &openInterest) const
Get the bar's total volume.
StatusCode | GetOpenPrice (double &price) const
Get the open price.
StatusCode | GetOpenPrice (Rational &price) const
Get the open price.
virtual ACTIV_IMPORT_DLL size_t | GetSerializedLength () const
Get the serialized length of the object.
StatusCode | GetTotalPrice (double &totalPrice) const
Get the bar's total price.
StatusCode | GetTotalPrice (Rational &totalPrice) const
Get the bar's total price.
StatusCode | GetTotalValue (double &totalValue) const
Get the bar's total value.
StatusCode | GetTotalValue (Rational &totalValue) const
Get the bar's total value.
StatusCode | GetTotalVolume (Rational &volume) const
Get the bar's total volume.
StatusCode | GetTotalVolume (uint64_t &volume) const
Get the bar's total volume.
virtual ACTIV_IMPORT_DLL
FieldSetType 		GetType () const
Get the field set type.
ACTIV_IMPORT_DLL | HistoryBar ()
Constructor.
bool | IsOpenValid ()
check to see if the open is between high and low.
bool | operator!= (const HistoryBar &rhs) const
Inequality operator.
bool | operator< (const DateTime &dateTime) const
< operator
bool | operator< (const HistoryBar &rhs) const
Less than operator (date only).
bool | operator<= (const DateTime &dateTime) const
bool | operator<= (const HistoryBar &rhs) const
Less than or equal operator (date only).
bool | operator== (const DateTime &dateTime) const
== operator
bool | operator== (const HistoryBar &rhs) const
Equality operator.
bool | operator> (const DateTime &dateTime) const
>= operator
bool | operator> (const HistoryBar &rhs) const
Greater than operator (date only).
bool | operator>= (const DateTime &dateTime) const
bool | operator>= (const HistoryBar &rhs) const
Greater than or equal operator (date only).
ACTIV_IMPORT_DLL StatusCode | ProcessSplit (const int sharesBefore, const int sharesAfter, const Rational::Denominator type)
split adjust
virtual ACTIV_IMPORT_DLL void | Reset ()
Reset all values in the field set.
virtual ACTIV_IMPORT_DLL StatusCode | Serialize (MessageBuilder &messageBuilder) const
Serialize the object into the supplied message builder.
StatusCode | SetClosePrice (const Rational &price)
Set the close price.
StatusCode | SetDate (const Date &date)
Set the date.
virtual ACTIV_IMPORT_DLL StatusCode | SetField (const Feed::FieldId fieldId, const IFieldType &field)
Get a field.
StatusCode | SetHighPrice (const Rational &price)
Set the high price.
StatusCode | SetLowPrice (const Rational &price)
Set the low price.
StatusCode | SetOpenInterest (const uint32_t openInterest)
Set the bar's total volume.
StatusCode | SetOpenPrice (const Rational &price)
Set the open price.
void | SetToMiniBar ()
Set the extra value fields to 0.
StatusCode | SetTotalPrice (Rational &totalPrice)
Set the bar's total price.
StatusCode | SetTotalValue (Rational &totalValue)
Set the bar's total value.
StatusCode | SetTotalVolume (const Rational &volume)
Set the bar's total volume.
StatusCode | SetTotalVolume (const uint64_t volume)
Set the bar's total volume.
virtual ACTIV_IMPORT_DLL
std::string 		ToString (const std::string &deliminator=DEFAULT_STRING_FIELD_SEPARATER) const
Convert the object to a string.
ACTIV_IMPORT_DLL
FieldSet::UpdateFieldSetStatus 		Update (const SeriesType period, const HistoryBar &dailyBar)
Build/update a bar with this bar.
virtual ACTIV_IMPORT_DLL | ~HistoryBar ()
Destructor.

Static Public Member Functions

static ACTIV_IMPORT_DLL StatusCode | BuildBarFromRecord (const Database::Record &record, HistoryBar &dailyBar)
static ACTIV_IMPORT_DLL size_t | GetMaxSerializedLength ()
Get the maximum serialized length.

Detailed Description

History Bar Field Set class.

Definition at line 57 of file HistoryBar.h.

Member Function Documentation

StatusCode Activ::ContentPlatform::ContentGatewayApi::HistoryBar::Compare | ( | const HistoryBar & | rhs,
 |  | int & | result |
 | ) |  |  | const [inline]

compares dateTime only

Parameters:
rhs | the object to compare with.
result | the result of the comparison. 0 date time is the same. 1 date time is later than rhs's. -1 date time is earlier than rhs's
Return values:
STATUS_CODE_SUCCESS
...

Definition at line 654 of file HistoryBar.h.

References Activ::Date::Compare(), and m_date.

ACTIV_IMPORT_DLL bool Activ::ContentPlatform::ContentGatewayApi::HistoryBar::Compare ( const HistoryBar & rhs ) const

Full compare.

Parameters:
rhs the object to compare with.
Returns:
the result of the test.

virtual ACTIV_IMPORT_DLL StatusCode Activ::ContentPlatform::ContentGatewayApi::HistoryBar::Deserialize ( MessageValidator & messageValidator ) [virtual]

Deserialize the object from the supplied message validator.

Parameters:
messageValidator the message validator from which the object will be extracted.
Return values:
STATUS_CODE_SUCCESS
...

Reimplemented from Activ::ContentPlatform::ContentGatewayApi::FieldSet.

virtual ACTIV_IMPORT_DLL StatusCode Activ::ContentPlatform::ContentGatewayApi::HistoryBar::FromString | ( | const std::string & | inputStr,
 |  | const std::string & | deliminator = DEFAULT_STRING_FIELD_SEPARATER |
 | ) |  |  | [virtual]

Set the object value from a string.

Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
......

Reimplemented from Activ::ContentPlatform::ContentGatewayApi::FieldSet.

virtual ACTIV_IMPORT_DLL StatusCode Activ::ContentPlatform::ContentGatewayApi::HistoryBar::FromStringSpecial ( const std::string & inputStr ) [virtual]

Set the object value from a string.

Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
......

StatusCode Activ::ContentPlatform::ContentGatewayApi::HistoryBar::GetClosePrice ( double & price ) const [inline]

Get the close price.

Parameters:
price the close price of the bar.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 839 of file HistoryBar.h.

References Activ::Rational::GetDouble().

StatusCode Activ::ContentPlatform::ContentGatewayApi::HistoryBar::GetClosePrice ( Rational & price ) const [inline]

Get the close price.

Parameters:
price the close price of the bar.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 831 of file HistoryBar.h.

StatusCode Activ::ContentPlatform::ContentGatewayApi::HistoryBar::GetDate ( Date & date ) const [inline]

Get the date.

Parameters:
date the date of the bar.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 738 of file HistoryBar.h.

StatusCode Activ::ContentPlatform::ContentGatewayApi::HistoryBar::GetDateTime ( DateTime & dateTime ) const [inline]

Get the date.

Parameters:
dateTime the date/time of the bar.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 746 of file HistoryBar.h.

References Activ::DateTime::Set().

virtual ACTIV_IMPORT_DLL StatusCode Activ::ContentPlatform::ContentGatewayApi::HistoryBar::GetField | ( | const Feed::FieldId | fieldId,
 |  | IFieldType & | field |
 | ) |  |  | const [virtual]

Get a field.

Parameters:
fieldId | field's id.
field | actual field.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FIELD
STATUS_CODE_UNDEFINED_FIELD

Reimplemented from Activ::ContentPlatform::ContentGatewayApi::FieldSet.

StatusCode Activ::ContentPlatform::ContentGatewayApi::HistoryBar::GetHighPrice ( double & price ) const [inline]

Get the high price.

Parameters:
price the high price of the bar.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 793 of file HistoryBar.h.

References Activ::Rational::GetDouble().

StatusCode Activ::ContentPlatform::ContentGatewayApi::HistoryBar::GetHighPrice ( Rational & price ) const [inline]

Get the high price.

Parameters:
price the high price of the bar.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 785 of file HistoryBar.h.

StatusCode Activ::ContentPlatform::ContentGatewayApi::HistoryBar::GetLowPrice ( double & price ) const [inline]

Get the low price.

Parameters:
price the low price of the bar.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 816 of file HistoryBar.h.

References Activ::Rational::GetDouble().

StatusCode Activ::ContentPlatform::ContentGatewayApi::HistoryBar::GetLowPrice ( Rational & price ) const [inline]

Get the low price.

Parameters:
price the low price of the bar.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 808 of file HistoryBar.h.

static ACTIV_IMPORT_DLL size_t Activ::ContentPlatform::ContentGatewayApi::HistoryBar::GetMaxSerializedLength ( ) [static]

Get the maximum serialized length.

Returns:
the maximum serialized length.

Reimplemented from Activ::ContentPlatform::ContentGatewayApi::FieldSet.

StatusCode Activ::ContentPlatform::ContentGatewayApi::HistoryBar::GetOpenInterest ( uint32_t & openInterest ) const [inline]

Get the bar's total volume.

Parameters:
openInterest the open interest of the bar.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 938 of file HistoryBar.h.

StatusCode Activ::ContentPlatform::ContentGatewayApi::HistoryBar::GetOpenPrice ( double & price ) const [inline]

Get the open price.

Parameters:
price the open price of the bar.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 770 of file HistoryBar.h.

References Activ::Rational::GetDouble().

StatusCode Activ::ContentPlatform::ContentGatewayApi::HistoryBar::GetOpenPrice ( Rational & price ) const [inline]

Get the open price.

Parameters:
price the open price of the bar.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 762 of file HistoryBar.h.

virtual ACTIV_IMPORT_DLL size_t Activ::ContentPlatform::ContentGatewayApi::HistoryBar::GetSerializedLength ( ) const [virtual]

Get the serialized length of the object.

Returns:
the serialized length of the object.

Reimplemented from Activ::ContentPlatform::ContentGatewayApi::FieldSet.

StatusCode Activ::ContentPlatform::ContentGatewayApi::HistoryBar::GetTotalPrice ( double & totalPrice ) const [inline]

Get the bar's total price.

Parameters:
totalPrice the total price of the bar.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 900 of file HistoryBar.h.

References Activ::Rational::GetDouble().

StatusCode Activ::ContentPlatform::ContentGatewayApi::HistoryBar::GetTotalPrice ( Rational & totalPrice ) const [inline]

Get the bar's total price.

Parameters:
totalPrice the total price of the bar.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 892 of file HistoryBar.h.

StatusCode Activ::ContentPlatform::ContentGatewayApi::HistoryBar::GetTotalValue ( double & totalValue ) const [inline]

Get the bar's total value.

Parameters:
totalValue the total value of the bar.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 923 of file HistoryBar.h.

References Activ::Rational::GetDouble().

StatusCode Activ::ContentPlatform::ContentGatewayApi::HistoryBar::GetTotalValue ( Rational & totalValue ) const [inline]

Get the bar's total value.

Parameters:
totalValue the total value of the bar.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 915 of file HistoryBar.h.

StatusCode Activ::ContentPlatform::ContentGatewayApi::HistoryBar::GetTotalVolume ( Rational & volume ) const [inline]

Get the bar's total volume.

Parameters:
volume the total volume of the bar.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 876 of file HistoryBar.h.

StatusCode Activ::ContentPlatform::ContentGatewayApi::HistoryBar::GetTotalVolume ( uint64_t & volume ) const [inline]

Get the bar's total volume.

Parameters:
volume the total volume of the bar.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 854 of file HistoryBar.h.

References ACTIV_RETURN_RESULT_IF, Activ::Rational::GetDenominator(), Activ::Rational::GetDouble(), and Activ::Rational::GetNumerator().

virtual ACTIV_IMPORT_DLL FieldSetType Activ::ContentPlatform::ContentGatewayApi::HistoryBar::GetType ( ) const [virtual]

Get the field set type.

Returns:
the field set type.

Reimplemented from Activ::ContentPlatform::ContentGatewayApi::FieldSet.

bool Activ::ContentPlatform::ContentGatewayApi::HistoryBar::operator!= ( const HistoryBar & rhs ) const [inline]

Inequality operator.

Parameters:
rhs the object to compare with.
Returns:
the result of the test.

Definition at line 668 of file HistoryBar.h.

References m_date.

bool Activ::ContentPlatform::ContentGatewayApi::HistoryBar::operator< ( const DateTime & dateTime ) const [inline]

< operator

Parameters:
dateTime dateTime to compare
Return values:
true/false

Definition at line 703 of file HistoryBar.h.

References Activ::DateTime::GetDate().

bool Activ::ContentPlatform::ContentGatewayApi::HistoryBar::operator< ( const HistoryBar & rhs ) const [inline]

Less than operator (date only).

Parameters:
rhs the object to compare with.
Returns:
the result of the test.

Definition at line 675 of file HistoryBar.h.

References m_date.

bool Activ::ContentPlatform::ContentGatewayApi::HistoryBar::operator<= ( const HistoryBar & rhs ) const [inline]

Less than or equal operator (date only).

Parameters:
rhs the object to compare with.
Returns:
the result of the test.

Definition at line 682 of file HistoryBar.h.

References m_date.

bool Activ::ContentPlatform::ContentGatewayApi::HistoryBar::operator== ( const DateTime & dateTime ) const [inline]

== operator

Parameters:
dateTime dateTime to compare
Return values:
true/false

Definition at line 717 of file HistoryBar.h.

References Activ::DateTime::GetDate().

bool Activ::ContentPlatform::ContentGatewayApi::HistoryBar::operator== ( const HistoryBar & rhs ) const [inline]

Equality operator.

Parameters:
rhs the object to compare with.
Returns:
the result of the test.

Definition at line 661 of file HistoryBar.h.

References m_date.

bool Activ::ContentPlatform::ContentGatewayApi::HistoryBar::operator> ( const DateTime & dateTime ) const [inline]

>= operator

Parameters:
dateTime dateTime to compare
Return values:
true/false

Definition at line 724 of file HistoryBar.h.

References Activ::DateTime::GetDate().

bool Activ::ContentPlatform::ContentGatewayApi::HistoryBar::operator> ( const HistoryBar & rhs ) const [inline]

Greater than operator (date only).

Parameters:
rhs the object to compare with.
Returns:
the result of the test.

Definition at line 689 of file HistoryBar.h.

References m_date.

bool Activ::ContentPlatform::ContentGatewayApi::HistoryBar::operator>= ( const HistoryBar & rhs ) const [inline]

Greater than or equal operator (date only).

Parameters:
rhs the object to compare with.
Returns:
the result of the test.

Definition at line 696 of file HistoryBar.h.

References m_date.

ACTIV_IMPORT_DLL StatusCode Activ::ContentPlatform::ContentGatewayApi::HistoryBar::ProcessSplit | ( | const int | sharesBefore,
 |  | const int | sharesAfter,
 |  | const Rational::Denominator | type
 | ) |  |

split adjust

Parameters:
sharesBefore | Shares before adjusting
sharesAfter | Shares after adjusting
type | the Rational::Denominator type
Return values:
STATUS_CODE_SUCCESS

Reimplemented from Activ::ContentPlatform::ContentGatewayApi::FieldSet.

virtual ACTIV_IMPORT_DLL StatusCode Activ::ContentPlatform::ContentGatewayApi::HistoryBar::Serialize ( MessageBuilder & messageBuilder ) const [virtual]

Serialize the object into the supplied message builder.

Parameters:
messageBuilder the message builder to store a serialized version of the object in.
Return values:
STATUS_CODE_SUCCESS
...

Reimplemented from Activ::ContentPlatform::ContentGatewayApi::FieldSet.

StatusCode Activ::ContentPlatform::ContentGatewayApi::HistoryBar::SetClosePrice ( const Rational & price ) [inline]

Set the close price.

Parameters:
price the close price of the bar.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 846 of file HistoryBar.h.

StatusCode Activ::ContentPlatform::ContentGatewayApi::HistoryBar::SetDate ( const Date & date ) [inline]

Set the date.

Parameters:
date the date of the bar.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 754 of file HistoryBar.h.

virtual ACTIV_IMPORT_DLL StatusCode Activ::ContentPlatform::ContentGatewayApi::HistoryBar::SetField | ( | const Feed::FieldId | fieldId,
 |  | const IFieldType & | field |
 | ) |  |  | [virtual]

Get a field.

Parameters:
fieldId | field's id.
field | actual field.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FIELD
STATUS_CODE_UNDEFINED_FIELD

Reimplemented from Activ::ContentPlatform::ContentGatewayApi::FieldSet.

StatusCode Activ::ContentPlatform::ContentGatewayApi::HistoryBar::SetHighPrice ( const Rational & price ) [inline]

Set the high price.

Parameters:
price the high price of the bar.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 800 of file HistoryBar.h.

StatusCode Activ::ContentPlatform::ContentGatewayApi::HistoryBar::SetLowPrice ( const Rational & price ) [inline]

Set the low price.

Parameters:
price the low price of the bar.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 823 of file HistoryBar.h.

StatusCode Activ::ContentPlatform::ContentGatewayApi::HistoryBar::SetOpenInterest ( const uint32_t openInterest ) [inline]

Set the bar's total volume.

Parameters:
openInterest the open interest of the bar.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 946 of file HistoryBar.h.

StatusCode Activ::ContentPlatform::ContentGatewayApi::HistoryBar::SetOpenPrice ( const Rational & price ) [inline]

Set the open price.

Parameters:
price the open price of the bar.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 777 of file HistoryBar.h.

StatusCode Activ::ContentPlatform::ContentGatewayApi::HistoryBar::SetTotalPrice ( Rational & totalPrice ) [inline]

Set the bar's total price.

Parameters:
totalPrice the total price of the bar.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 907 of file HistoryBar.h.

StatusCode Activ::ContentPlatform::ContentGatewayApi::HistoryBar::SetTotalValue ( Rational & totalValue ) [inline]

Set the bar's total value.

Parameters:
totalValue the total value of the bar.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 930 of file HistoryBar.h.

StatusCode Activ::ContentPlatform::ContentGatewayApi::HistoryBar::SetTotalVolume ( const Rational & volume ) [inline]

Set the bar's total volume.

Parameters:
volume the volume of the bar.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 884 of file HistoryBar.h.

StatusCode Activ::ContentPlatform::ContentGatewayApi::HistoryBar::SetTotalVolume ( const uint64_t volume ) [inline]

Set the bar's total volume.

Parameters:
volume the volume of the bar.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 869 of file HistoryBar.h.

References Activ::Rational::Set().

virtual ACTIV_IMPORT_DLL std::string Activ::ContentPlatform::ContentGatewayApi::HistoryBar::ToString ( const std::string & deliminator = DEFAULT_STRING_FIELD_SEPARATER ) const [virtual]

Convert the object to a string.

Returns:
the object as a string.

Reimplemented from Activ::ContentPlatform::ContentGatewayApi::FieldSet.

ACTIV_IMPORT_DLL FieldSet::UpdateFieldSetStatus Activ::ContentPlatform::ContentGatewayApi::HistoryBar::Update | ( | const SeriesType | period,
 |  | const HistoryBar & | dailyBar
 | ) |  |

Build/update a bar with this bar.

Parameters:
period | target bar's period.
dailyBar | daily bar to be added.
Return values:
UPDATE_STATUS_OK
UPDATE_STATUS_FLUSH
UPDATE_STATUS_IGNORE

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivContentGatewayApiCommon/HistoryBar.h
Generated on Wed Oct 8 14:02:02 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::INewsResponses

Activ::ContentPlatform::ContentGatewayApi::INewsResponses Class Reference

Interface for news response callbacks. More...

#include <ActivContentPlatform/ActivContentGatewayApi/INewsResponses.h>

Inheritance diagram for Activ::ContentPlatform::ContentGatewayApi::INewsResponses:

Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient

List of all members.

Public Member Functions

virtual void | OnGetNewsStoriesResponse (HeapMessage &response)=0
Called on receiving an asynchronous GetNewsStories::PostRequest() response.
virtual void | OnNewsUpdate (HeapMessage &update)=0
Called on receiving a news update.
virtual | ~INewsResponses ()=0
Destructor.

Detailed Description

Interface for news response callbacks.

Definition at line 27 of file INewsResponses.h.

Member Function Documentation

virtual void Activ::ContentPlatform::ContentGatewayApi::INewsResponses::OnGetNewsStoriesResponse ( HeapMessage & response ) [pure virtual]

Called on receiving an asynchronous GetNewsStories::PostRequest() response.

The response can be deserialized using GetNewsStories::Deserialize() if it is valid. The validity of the response can be determined using ContentGatewayClient::IsValidResponse().

Parameters:
response HeapMessage containing the serialized response.

Implemented in Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient.

virtual void Activ::ContentPlatform::ContentGatewayApi::INewsResponses::OnNewsUpdate ( HeapMessage & update ) [pure virtual]

Called on receiving a news update.

The message can be deserialized using NewsUpdateHelper::Deserialize().

Parameters:
update HeapMessage containing the serialized update message.

Implemented in Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivContentGatewayApi/INewsResponses.h
Generated on Wed Oct 8 14:02:02 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::IntradayBar

Activ::ContentPlatform::ContentGatewayApi::IntradayBar Class Reference

Intraday Bar Field Set class. More...

#include <ActivContentPlatform/ActivContentGatewayApiCommon/IntradayBar.h>

Inheritance diagram for Activ::ContentPlatform::ContentGatewayApi::IntradayBar:

Activ::ContentPlatform::ContentGatewayApi::FieldSet

List of all members.

Public Member Functions

StatusCode | Compare (const IntradayBar &rhs, int &result) const
Compare dateTime only.
ACTIV_IMPORT_DLL bool | Compare (const IntradayBar &rhs) const
Full compare.
virtual ACTIV_IMPORT_DLL StatusCode | Deserialize (MessageValidator &messageValidator)
Deserialize the object from the supplied message validator.
virtual ACTIV_IMPORT_DLL StatusCode | FromString (const std::string &inputStr, const std::string &deliminator=DEFAULT_STRING_FIELD_SEPARATER)
Set the object value from a string.
StatusCode | GetClosePrice (double &price) const
Get the close price.
StatusCode | GetClosePrice (Rational &price) const
Get the close price.
StatusCode | GetDateTime (DateTime &dateTime) const
Get the date and time.
virtual ACTIV_IMPORT_DLL StatusCode | GetField (const Feed::FieldId fieldId, IFieldType &field) const
Get a field.
StatusCode | GetFlag (byte_t &flag) const
Get the bar's flag.
StatusCode | GetHighPrice (double &price) const
Get the high price.
StatusCode | GetHighPrice (Rational &price) const
Get the high price.
StatusCode | GetLowPrice (double &price) const
Get the low price.
StatusCode | GetLowPrice (Rational &price) const
Get the low price.
StatusCode | GetOpenPrice (double &price) const
Get the open price.
StatusCode | GetOpenPrice (Rational &price) const
Get the open price.
virtual ACTIV_IMPORT_DLL size_t | GetSerializedLength () const
Get the serialized length of the object.
StatusCode | GetTickCount (uint32_t &count) const
Get the bar's tick count.
StatusCode | GetTotalPrice (double &totalPrice) const
Get the bar's total price.
StatusCode | GetTotalPrice (Rational &totalPrice) const
Get the bar's total price.
StatusCode | GetTotalValue (double &totalValue) const
Get the bar's total value.
StatusCode | GetTotalValue (Rational &totalValue) const
Get the bar's total value.
StatusCode | GetTotalVolume (Rational &volume) const
Get the bar's total volume.
StatusCode | GetTotalVolume (uint32_t &volume) const
Get the bar's total volume.
virtual ACTIV_IMPORT_DLL
FieldSetType 		GetType () const
Get the field set type.
bool | HasTick () const
Check if the bar has any trade in it.
ACTIV_IMPORT_DLL | IntradayBar ()
Constructor.
bool | IsRegularHour () const
Check if the bar has regular trade in it.
bool | IsVWAPOnly () const
Check if the bar only has vwap info but no high, low, open, close data (in case of speical trade only).
bool | operator!= (const IntradayBar &rhs) const
Inequality operator.
bool | operator< (const DateTime &dateTime) const
< operator
bool | operator< (const IntradayBar &rhs) const
Less than operator (date only).
bool | operator<= (const DateTime &dateTime) const
bool | operator<= (const IntradayBar &rhs) const
Less than or equal operator (date only).
bool | operator== (const DateTime &dateTime) const
== operator
bool | operator== (const IntradayBar &rhs) const
Equality operator.
bool | operator> (const DateTime &dateTime) const
> operator
bool | operator> (const IntradayBar &rhs) const
Greater than operator (date only).
bool | operator>= (const DateTime &dateTime) const
bool | operator>= (const IntradayBar &rhs) const
Greater than or equal operator (date only).
ACTIV_IMPORT_DLL StatusCode | ProcessSplit (const int sharesBefore, const int sharesAfter, const Rational::Denominator type)
split addjust
ACTIV_IMPORT_DLL StatusCode | RemoveTrade (const Tick &canceledTrade)
remove a trade (for canceled trade.
virtual ACTIV_IMPORT_DLL void | Reset ()
Reset all values in the field set.
virtual ACTIV_IMPORT_DLL StatusCode | Serialize (MessageBuilder &messageBuilder) const
Serialize the object into the supplied message builder.
StatusCode | SetClosePrice (const Rational &price)
Set the close price.
StatusCode | SetDate (const Date &date)
Set the date.
StatusCode | SetDateTime (const DateTime &dateTime)
Set the date and time.
virtual ACTIV_IMPORT_DLL StatusCode | SetField (const Feed::FieldId fieldId, const IFieldType &field)
Get a field.
StatusCode | SetFlag (const byte_t flag)
Set the bar's flag.
StatusCode | SetHighPrice (const Rational &price)
Set the high price.
StatusCode | SetLowPrice (const Rational &price)
Set the low price.
StatusCode | SetOpenPrice (const Rational &price)
Set the open price.
StatusCode | SetTickCount (const uint32_t count)
Set the bar's tick count.
StatusCode | SetTime (const Time &time)
Set the time.
void | SetToMiniBar ()
Set the extra value fields to 0.
StatusCode | SetTotalPrice (Rational &totalPrice)
Set the bar's total price.
StatusCode | SetTotalValue (Rational &totalValue)
Set the bar's total value.
StatusCode | SetTotalVolume (const Rational &volume)
Set the bar's total volume.
StatusCode | SetTotalVolume (const uint32_t volume)
Get the bar's total volume.
virtual ACTIV_IMPORT_DLL
std::string 		ToString (const std::string &deliminator=DEFAULT_STRING_FIELD_SEPARATER) const
Convert the object to a string.
ACTIV_IMPORT_DLL
FieldSet::UpdateFieldSetStatus 		Update (const unsigned period, const IntradayBar &bar)
add bar to an existing bar, e.g., building a 5 minute bar from 1 minute bars
ACTIV_IMPORT_DLL
FieldSet::UpdateFieldSetStatus 		Update (const unsigned period, const Tick &tick, bool updateHighLow, bool updateVwap)
Build/update a bar with this tick.
virtual ACTIV_IMPORT_DLL | ~IntradayBar ()
Destructor.

Static Public Member Functions

static ACTIV_IMPORT_DLL size_t | GetMaxSerializedLength ()
Get the maximum serialized length.

Static Public Attributes

static const byte_t | NONE_REGULAR_HOUR_TRADE_BIT = 0x01
static const byte_t | VWAP_ONLY_BIT = 0x02

Detailed Description

Intraday Bar Field Set class.

Definition at line 43 of file IntradayBar.h.

Member Function Documentation

StatusCode Activ::ContentPlatform::ContentGatewayApi::IntradayBar::Compare | ( | const IntradayBar & | rhs,
 |  | int & | result |
 | ) |  |  | const [inline]

Compare dateTime only.

Parameters:
rhs | the object to compare with.
result | the result of the comparison. 0 date time is the same. 1 date time is later than rhs's. -1 date time is earlier than rhs's
Return values:
STATUS_CODE_SUCCESS
...

Definition at line 660 of file IntradayBar.h.

References Activ::DateTime::Compare(), and m_dateTime.

ACTIV_IMPORT_DLL bool Activ::ContentPlatform::ContentGatewayApi::IntradayBar::Compare ( const IntradayBar & rhs ) const

Full compare.

Parameters:
rhs the object to compare with.
Returns:
the result of the test.

virtual ACTIV_IMPORT_DLL StatusCode Activ::ContentPlatform::ContentGatewayApi::IntradayBar::Deserialize ( MessageValidator & messageValidator ) [virtual]

Deserialize the object from the supplied message validator.

Parameters:
messageValidator the message validator from which the object will be extracted.
Return values:
STATUS_CODE_SUCCESS
...

Reimplemented from Activ::ContentPlatform::ContentGatewayApi::FieldSet.

virtual ACTIV_IMPORT_DLL StatusCode Activ::ContentPlatform::ContentGatewayApi::IntradayBar::FromString | ( | const std::string & | inputStr,
 |  | const std::string & | deliminator = DEFAULT_STRING_FIELD_SEPARATER |
 | ) |  |  | [virtual]

Set the object value from a string.

Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
......

Reimplemented from Activ::ContentPlatform::ContentGatewayApi::FieldSet.

StatusCode Activ::ContentPlatform::ContentGatewayApi::IntradayBar::GetClosePrice ( double & price ) const [inline]

Get the close price.

Parameters:
price the close price of the bar.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 853 of file IntradayBar.h.

References Activ::Rational::GetDouble().

StatusCode Activ::ContentPlatform::ContentGatewayApi::IntradayBar::GetClosePrice ( Rational & price ) const [inline]

Get the close price.

Parameters:
price the close price of the bar.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 845 of file IntradayBar.h.

StatusCode Activ::ContentPlatform::ContentGatewayApi::IntradayBar::GetDateTime ( DateTime & dateTime ) const [inline]

Get the date and time.

Parameters:
dateTime the date and time of the bar.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 744 of file IntradayBar.h.

virtual ACTIV_IMPORT_DLL StatusCode Activ::ContentPlatform::ContentGatewayApi::IntradayBar::GetField | ( | const Feed::FieldId | fieldId,
 |  | IFieldType & | field |
 | ) |  |  | const [virtual]

Get a field.

Parameters:
fieldId | field's id.
field | actual field.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FIELD
STATUS_CODE_UNDEFINED_FIELD

Reimplemented from Activ::ContentPlatform::ContentGatewayApi::FieldSet.

StatusCode Activ::ContentPlatform::ContentGatewayApi::IntradayBar::GetFlag ( byte_t & flag ) const [inline]

Get the bar's flag.

Parameters:
flag retrived flag
Return values:
STATUS_CODE_SUCCESS

Definition at line 976 of file IntradayBar.h.

StatusCode Activ::ContentPlatform::ContentGatewayApi::IntradayBar::GetHighPrice ( double & price ) const [inline]

Get the high price.

Parameters:
price the high price of the bar.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 807 of file IntradayBar.h.

References Activ::Rational::GetDouble().

StatusCode Activ::ContentPlatform::ContentGatewayApi::IntradayBar::GetHighPrice ( Rational & price ) const [inline]

Get the high price.

Parameters:
price the high price of the bar.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 799 of file IntradayBar.h.

StatusCode Activ::ContentPlatform::ContentGatewayApi::IntradayBar::GetLowPrice ( double & price ) const [inline]

Get the low price.

Parameters:
price the low price of the bar.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 830 of file IntradayBar.h.

References Activ::Rational::GetDouble().

StatusCode Activ::ContentPlatform::ContentGatewayApi::IntradayBar::GetLowPrice ( Rational & price ) const [inline]

Get the low price.

Parameters:
price the low price of the bar.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 822 of file IntradayBar.h.

static ACTIV_IMPORT_DLL size_t Activ::ContentPlatform::ContentGatewayApi::IntradayBar::GetMaxSerializedLength ( ) [static]

Get the maximum serialized length.

Returns:
the maximum serialized length.

Reimplemented from Activ::ContentPlatform::ContentGatewayApi::FieldSet.

StatusCode Activ::ContentPlatform::ContentGatewayApi::IntradayBar::GetOpenPrice ( double & price ) const [inline]

Get the open price.

Parameters:
price the open price of the bar.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 784 of file IntradayBar.h.

References Activ::Rational::GetDouble().

StatusCode Activ::ContentPlatform::ContentGatewayApi::IntradayBar::GetOpenPrice ( Rational & price ) const [inline]

Get the open price.

Parameters:
price the open price of the bar.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 776 of file IntradayBar.h.

virtual ACTIV_IMPORT_DLL size_t Activ::ContentPlatform::ContentGatewayApi::IntradayBar::GetSerializedLength ( ) const [virtual]

Get the serialized length of the object.

Returns:
the serialized length of the object.

Reimplemented from Activ::ContentPlatform::ContentGatewayApi::FieldSet.

StatusCode Activ::ContentPlatform::ContentGatewayApi::IntradayBar::GetTickCount ( uint32_t & count ) const [inline]

Get the bar's tick count.

Parameters:
count the tick count of the bar.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 952 of file IntradayBar.h.

StatusCode Activ::ContentPlatform::ContentGatewayApi::IntradayBar::GetTotalPrice ( double & totalPrice ) const [inline]

Get the bar's total price.

Parameters:
totalPrice the total price of the bar.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 914 of file IntradayBar.h.

References Activ::Rational::GetDouble().

StatusCode Activ::ContentPlatform::ContentGatewayApi::IntradayBar::GetTotalPrice ( Rational & totalPrice ) const [inline]

Get the bar's total price.

Parameters:
totalPrice the total price of the bar.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 906 of file IntradayBar.h.

StatusCode Activ::ContentPlatform::ContentGatewayApi::IntradayBar::GetTotalValue ( double & totalValue ) const [inline]

Get the bar's total value.

Parameters:
totalValue the total value of the bar.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 937 of file IntradayBar.h.

References Activ::Rational::GetDouble().

StatusCode Activ::ContentPlatform::ContentGatewayApi::IntradayBar::GetTotalValue ( Rational & totalValue ) const [inline]

Get the bar's total value.

Parameters:
totalValue the total value of the bar.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 929 of file IntradayBar.h.

StatusCode Activ::ContentPlatform::ContentGatewayApi::IntradayBar::GetTotalVolume ( Rational & volume ) const [inline]

Get the bar's total volume.

Parameters:
volume the total volume of the bar.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 890 of file IntradayBar.h.

StatusCode Activ::ContentPlatform::ContentGatewayApi::IntradayBar::GetTotalVolume ( uint32_t & volume ) const [inline]

Get the bar's total volume.

Parameters:
volume the total volume of the bar.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 868 of file IntradayBar.h.

References ACTIV_RETURN_RESULT_IF, Activ::Rational::GetDenominator(), Activ::Rational::GetDouble(), and Activ::Rational::GetNumerator().

virtual ACTIV_IMPORT_DLL FieldSetType Activ::ContentPlatform::ContentGatewayApi::IntradayBar::GetType ( ) const [virtual]

Get the field set type.

Returns:
the field set type.

Reimplemented from Activ::ContentPlatform::ContentGatewayApi::FieldSet.

bool Activ::ContentPlatform::ContentGatewayApi::IntradayBar::operator!= ( const IntradayBar & rhs ) const [inline]

Inequality operator.

Parameters:
rhs the object to compare with.
Returns:
the result of the test.

Definition at line 674 of file IntradayBar.h.

References m_dateTime.

bool Activ::ContentPlatform::ContentGatewayApi::IntradayBar::operator< ( const DateTime & dateTime ) const [inline]

< operator

Parameters:
dateTime dateTime to compare
Return values:
true/false

Definition at line 709 of file IntradayBar.h.

bool Activ::ContentPlatform::ContentGatewayApi::IntradayBar::operator< ( const IntradayBar & rhs ) const [inline]

Less than operator (date only).

Parameters:
rhs the object to compare with.
Returns:
the result of the test.

Definition at line 681 of file IntradayBar.h.

References m_dateTime.

bool Activ::ContentPlatform::ContentGatewayApi::IntradayBar::operator<= ( const IntradayBar & rhs ) const [inline]

Less than or equal operator (date only).

Parameters:
rhs the object to compare with.
Returns:
the result of the test.

Definition at line 688 of file IntradayBar.h.

References m_dateTime.

bool Activ::ContentPlatform::ContentGatewayApi::IntradayBar::operator== ( const DateTime & dateTime ) const [inline]

== operator

Parameters:
dateTime dateTime to compare
Return values:
true/false

Definition at line 723 of file IntradayBar.h.

bool Activ::ContentPlatform::ContentGatewayApi::IntradayBar::operator== ( const IntradayBar & rhs ) const [inline]

Equality operator.

Parameters:
rhs the object to compare with.
Returns:
the result of the test.

Definition at line 667 of file IntradayBar.h.

References m_dateTime.

bool Activ::ContentPlatform::ContentGatewayApi::IntradayBar::operator> ( const DateTime & dateTime ) const [inline]

> operator

Parameters:
dateTime dateTime to compare
Return values:
true/false

Definition at line 730 of file IntradayBar.h.

bool Activ::ContentPlatform::ContentGatewayApi::IntradayBar::operator> ( const IntradayBar & rhs ) const [inline]

Greater than operator (date only).

Parameters:
rhs the object to compare with.
Returns:
the result of the test.

Definition at line 695 of file IntradayBar.h.

References m_dateTime.

bool Activ::ContentPlatform::ContentGatewayApi::IntradayBar::operator>= ( const IntradayBar & rhs ) const [inline]

Greater than or equal operator (date only).

Parameters:
rhs the object to compare with.
Returns:
the result of the test.

Definition at line 702 of file IntradayBar.h.

References m_dateTime.

ACTIV_IMPORT_DLL StatusCode Activ::ContentPlatform::ContentGatewayApi::IntradayBar::ProcessSplit | ( | const int | sharesBefore,
 |  | const int | sharesAfter,
 |  | const Rational::Denominator | type
 | ) |  |

split addjust

Parameters:
sharesBefore | Shares before adjusting
sharesAfter | Shares after adjusting
type | the Rational::Denominator type
Return values:
STATUS_CODE_SUCCESS

Reimplemented from Activ::ContentPlatform::ContentGatewayApi::FieldSet.

ACTIV_IMPORT_DLL StatusCode Activ::ContentPlatform::ContentGatewayApi::IntradayBar::RemoveTrade ( const Tick & canceledTrade )

remove a trade (for canceled trade.

Parameters:
canceledTrade trade to remove
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER

virtual ACTIV_IMPORT_DLL StatusCode Activ::ContentPlatform::ContentGatewayApi::IntradayBar::Serialize ( MessageBuilder & messageBuilder ) const [virtual]

Serialize the object into the supplied message builder.

Parameters:
messageBuilder the message builder to store a serialized version of the object in.
Return values:
STATUS_CODE_SUCCESS
...

Reimplemented from Activ::ContentPlatform::ContentGatewayApi::FieldSet.

StatusCode Activ::ContentPlatform::ContentGatewayApi::IntradayBar::SetClosePrice ( const Rational & price ) [inline]

Set the close price.

Parameters:
price the close price of the bar.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 860 of file IntradayBar.h.

StatusCode Activ::ContentPlatform::ContentGatewayApi::IntradayBar::SetDate ( const Date & date ) [inline]

Set the date.

Parameters:
date the date of the bar.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 760 of file IntradayBar.h.

References Activ::DateTime::GetTime(), and Activ::DateTime::Set().

StatusCode Activ::ContentPlatform::ContentGatewayApi::IntradayBar::SetDateTime ( const DateTime & dateTime ) [inline]

Set the date and time.

Parameters:
dateTime the date and time of the bar.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 752 of file IntradayBar.h.

virtual ACTIV_IMPORT_DLL StatusCode Activ::ContentPlatform::ContentGatewayApi::IntradayBar::SetField | ( | const Feed::FieldId | fieldId,
 |  | const IFieldType & | field |
 | ) |  |  | [virtual]

Get a field.

Parameters:
fieldId | field's id.
field | actual field.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FIELD
STATUS_CODE_UNDEFINED_FIELD

Reimplemented from Activ::ContentPlatform::ContentGatewayApi::FieldSet.

StatusCode Activ::ContentPlatform::ContentGatewayApi::IntradayBar::SetFlag ( const byte_t flag ) [inline]

Set the bar's flag.

Parameters:
flag flag to set
Return values:
STATUS_CODE_SUCCESS

Definition at line 968 of file IntradayBar.h.

StatusCode Activ::ContentPlatform::ContentGatewayApi::IntradayBar::SetHighPrice ( const Rational & price ) [inline]

Set the high price.

Parameters:
price the high price of the bar.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 814 of file IntradayBar.h.

StatusCode Activ::ContentPlatform::ContentGatewayApi::IntradayBar::SetLowPrice ( const Rational & price ) [inline]

Set the low price.

Parameters:
price the low price of the bar.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 837 of file IntradayBar.h.

StatusCode Activ::ContentPlatform::ContentGatewayApi::IntradayBar::SetOpenPrice ( const Rational & price ) [inline]

Set the open price.

Parameters:
price the open price of the bar.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 791 of file IntradayBar.h.

StatusCode Activ::ContentPlatform::ContentGatewayApi::IntradayBar::SetTickCount ( const uint32_t count ) [inline]

Set the bar's tick count.

Parameters:
count the tick count of the bar.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 960 of file IntradayBar.h.

StatusCode Activ::ContentPlatform::ContentGatewayApi::IntradayBar::SetTime ( const Time & time ) [inline]

Set the time.

Parameters:
time the time of the bar.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 768 of file IntradayBar.h.

References Activ::DateTime::GetDate(), and Activ::DateTime::Set().

StatusCode Activ::ContentPlatform::ContentGatewayApi::IntradayBar::SetTotalPrice ( Rational & totalPrice ) [inline]

Set the bar's total price.

Parameters:
totalPrice the total price of the bar.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 921 of file IntradayBar.h.

StatusCode Activ::ContentPlatform::ContentGatewayApi::IntradayBar::SetTotalValue ( Rational & totalValue ) [inline]

Set the bar's total value.

Parameters:
totalValue the total value of the bar.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 944 of file IntradayBar.h.

StatusCode Activ::ContentPlatform::ContentGatewayApi::IntradayBar::SetTotalVolume ( const Rational & volume ) [inline]

Set the bar's total volume.

Parameters:
volume the volume of the bar.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 898 of file IntradayBar.h.

StatusCode Activ::ContentPlatform::ContentGatewayApi::IntradayBar::SetTotalVolume ( const uint32_t volume ) [inline]

Get the bar's total volume.

Parameters:
volume the total volume of the bar.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 883 of file IntradayBar.h.

References Activ::Rational::Set().

virtual ACTIV_IMPORT_DLL std::string Activ::ContentPlatform::ContentGatewayApi::IntradayBar::ToString ( const std::string & deliminator = DEFAULT_STRING_FIELD_SEPARATER ) const [virtual]

Convert the object to a string.

Returns:
the object as a string.

Reimplemented from Activ::ContentPlatform::ContentGatewayApi::FieldSet.

ACTIV_IMPORT_DLL FieldSet::UpdateFieldSetStatus Activ::ContentPlatform::ContentGatewayApi::IntradayBar::Update | ( | const unsigned | period,
 |  | const IntradayBar & | bar
 | ) |  |

add bar to an existing bar, e.g., building a 5 minute bar from 1 minute bars

Parameters:
period | target bar's period
bar | new bar to be added.
Return values:
UPDATE_STATUS_OK
UPDATE_STATUS_FLUSH
UPDATE_STATUS_IGNORE

ACTIV_IMPORT_DLL FieldSet::UpdateFieldSetStatus Activ::ContentPlatform::ContentGatewayApi::IntradayBar::Update | ( | const unsigned | period,
 |  | const Tick & | tick,
 |  | bool | updateHighLow,
 |  | bool | updateVwap
 | ) |  |

Build/update a bar with this tick.

Parameters:
period | target bar's period.
tick | tick to apply.
updateHighLow
updateVwap
Return values:
UPDATE_STATUS_OK
UPDATE_STATUS_FLUSH
UPDATE_STATUS_IGNORE

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivContentGatewayApiCommon/IntradayBar.h
Generated on Wed Oct 8 14:02:03 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::IRealtimeResponses

Activ::ContentPlatform::ContentGatewayApi::IRealtimeResponses Class Reference

Interface for realtime data response callbacks. More...

#include <ActivContentPlatform/ActivContentGatewayApi/IRealtimeResponses.h>

Inheritance diagram for Activ::ContentPlatform::ContentGatewayApi::IRealtimeResponses:

Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient

List of all members.

Public Member Functions

virtual void | OnGetEqualResponse (HeapMessage &response)=0
Called on receiving an asynchronous GetEqual::PostRequest() response.
virtual void | OnGetFirstResponse (HeapMessage &response)=0
Called on receiving an asynchronous GetFirst::PostRequest() response.
virtual void | OnGetLastResponse (HeapMessage &response)=0
Called on receiving an asynchronous GetLast::PostRequest() response.
virtual void | OnGetMatchResponse (HeapMessage &response)=0
Called on receiving an asynchronous GetMatch::PostRequest() response.
virtual void | OnGetMultipleEqualResponse (HeapMessage &response)=0
Called on receiving an asynchronous GetMultipleEqual::PostRequest() response.
virtual void | OnGetMultipleMatchResponse (HeapMessage &response)=0
Called on receiving an asynchronous GetMultipleMatch::PostRequest() response.
virtual void | OnGetMultiplePatternMatchListResponse (HeapMessage &response)=0
Called on receiving an asynchronous GetMultiplePatternMatchList::PostRequest() response.
virtual void | OnGetMultiplePatternMatchResponse (HeapMessage &response)=0
Called on receiving an asynchronous GetMultiplePatternMatch::PostRequest() response.
virtual void | OnGetNextResponse (HeapMessage &response)=0
Called on receiving an asynchronous GetNext::PostRequest() response.
virtual void | OnGetPreviousResponse (HeapMessage &response)=0
Called on receiving an asynchronous GetPrevious::PostRequest() response.
virtual void | OnRecordUpdate (HeapMessage &update)=0
Called on receiving a record update.
virtual | ~IRealtimeResponses ()=0
Destructor.

Detailed Description

Interface for realtime data response callbacks.

Definition at line 26 of file IRealtimeResponses.h.

Member Function Documentation

virtual void Activ::ContentPlatform::ContentGatewayApi::IRealtimeResponses::OnGetEqualResponse ( HeapMessage & response ) [pure virtual]

Called on receiving an asynchronous GetEqual::PostRequest() response.

The response can be deserialized using GetEqual::Deserialize() if it is valid. The validity of the response can be determined using ContentGatewayClient::IsValidResponse(). If this is the final (or only) part of a response, ContentGatewayClient::IsCompleteResponse() will return true.

Parameters:
response HeapMessage containing the serialized response.

Implemented in Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient.

virtual void Activ::ContentPlatform::ContentGatewayApi::IRealtimeResponses::OnGetFirstResponse ( HeapMessage & response ) [pure virtual]

Called on receiving an asynchronous GetFirst::PostRequest() response.

The response can be deserialized using GetFirst::Deserialize() if it is valid. The validity of the response can be determined using ContentGatewayClient::IsValidResponse(). If this is the final (or only) part of a response, ContentGatewayClient::IsCompleteResponse() will return true.

Parameters:
response HeapMessage containing the serialized response.

Implemented in Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient.

virtual void Activ::ContentPlatform::ContentGatewayApi::IRealtimeResponses::OnGetLastResponse ( HeapMessage & response ) [pure virtual]

Called on receiving an asynchronous GetLast::PostRequest() response.

The response can be deserialized using GetLast::Deserialize() if it is valid. The validity of the response can be determined using ContentGatewayClient::IsValidResponse(). If this is the final (or only) part of a response, ContentGatewayClient::IsCompleteResponse() will return true.

Parameters:
response HeapMessage containing the serialized response.

Implemented in Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient.

virtual void Activ::ContentPlatform::ContentGatewayApi::IRealtimeResponses::OnGetMatchResponse ( HeapMessage & response ) [pure virtual]

Called on receiving an asynchronous GetMatch::PostRequest() response.

The response can be deserialized using GetMatch::Deserialize() if it is valid. The validity of the response can be determined using ContentGatewayClient::IsValidResponse(). If this is the final (or only) part of a response, ContentGatewayClient::IsCompleteResponse() will return true.

Parameters:
response HeapMessage containing the serialized response.

Implemented in Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient.

virtual void Activ::ContentPlatform::ContentGatewayApi::IRealtimeResponses::OnGetMultipleEqualResponse ( HeapMessage & response ) [pure virtual]

Called on receiving an asynchronous GetMultipleEqual::PostRequest() response.

The response can be deserialized using GetMultipleEqual::Deserialize() if it is valid. The validity of the response can be determined using ContentGatewayClient::IsValidResponse(). If this is the final (or only) part of a response, ContentGatewayClient::IsCompleteResponse() will return true.

Parameters:
response HeapMessage containing the serialized response.

Implemented in Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient.

virtual void Activ::ContentPlatform::ContentGatewayApi::IRealtimeResponses::OnGetMultipleMatchResponse ( HeapMessage & response ) [pure virtual]

Called on receiving an asynchronous GetMultipleMatch::PostRequest() response.

The response can be deserialized using GetMultipleMatch::Deserialize() if it is valid. The validity of the response can be determined using ContentGatewayClient::IsValidResponse(). If this is the final (or only) part of a response, ContentGatewayClient::IsCompleteResponse() will return true.

Parameters:
response HeapMessage containing the serialized response.

Implemented in Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient.

virtual void Activ::ContentPlatform::ContentGatewayApi::IRealtimeResponses::OnGetMultiplePatternMatchListResponse ( HeapMessage & response ) [pure virtual]

Called on receiving an asynchronous GetMultiplePatternMatchList::PostRequest() response.

The response can be deserialized using GetMultiplePatternMatchList::Deserialize() if it is valid. The validity of the response can be determined using ContentGatewayClient::IsValidResponse(). If this is the final (or only) part of a response, ContentGatewayClient::IsCompleteResponse() will return true.

Parameters:
response HeapMessage containing the serialized response.

Implemented in Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient.

virtual void Activ::ContentPlatform::ContentGatewayApi::IRealtimeResponses::OnGetMultiplePatternMatchResponse ( HeapMessage & response ) [pure virtual]

Called on receiving an asynchronous GetMultiplePatternMatch::PostRequest() response.

The response can be deserialized using GetMultiplePatternMatch::Deserialize() if it is valid. The validity of the response can be determined using ContentGatewayClient::IsValidResponse(). If this is the final (or only) part of a response, ContentGatewayClient::IsCompleteResponse() will return true.

Parameters:
response HeapMessage containing the serialized response.

Implemented in Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient.

virtual void Activ::ContentPlatform::ContentGatewayApi::IRealtimeResponses::OnGetNextResponse ( HeapMessage & response ) [pure virtual]

Called on receiving an asynchronous GetNext::PostRequest() response.

The response can be deserialized using GetNext::Deserialize() if it is valid. The validity of the response can be determined using ContentGatewayClient::IsValidResponse(). If this is the final (or only) part of a response, ContentGatewayClient::IsCompleteResponse() will return true.

Parameters:
response HeapMessage containing the serialized response.

Implemented in Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient.

virtual void Activ::ContentPlatform::ContentGatewayApi::IRealtimeResponses::OnGetPreviousResponse ( HeapMessage & response ) [pure virtual]

Called on receiving an asynchronous GetPrevious::PostRequest() response.

The response can be deserialized using GetPrevious::Deserialize() if it is valid. The validity of the response can be determined using ContentGatewayClient::IsValidResponse(). If this is the final (or only) part of a response, ContentGatewayClient::IsCompleteResponse() will return true.

Parameters:
response HeapMessage containing the serialized response.

Implemented in Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient.

virtual void Activ::ContentPlatform::ContentGatewayApi::IRealtimeResponses::OnRecordUpdate ( HeapMessage & update ) [pure virtual]

Called on receiving a record update.

The message can be deserialized using RecordUpdateHelper::Deserialize().

Parameters:
update HeapMessage containing the serialized update message.

Implemented in Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivContentGatewayApi/IRealtimeResponses.h
Generated on Wed Oct 8 14:02:03 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::ISymbolDirectoryResponses

Activ::ContentPlatform::ContentGatewayApi::ISymbolDirectoryResponses Class Reference

Interface for symbol directory response callbacks. More...

#include <ActivContentPlatform/ActivContentGatewayApi/ISymbolDirectoryResponses.h>

Inheritance diagram for Activ::ContentPlatform::ContentGatewayApi::ISymbolDirectoryResponses:

Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient

List of all members.

Public Member Functions

virtual void | OnGetSymbolsResponse (HeapMessage &response)=0
Called on receiving an asynchronous GetSymbols::PostRequest() response.
virtual | ~ISymbolDirectoryResponses ()=0
Destructor.

Detailed Description

Interface for symbol directory response callbacks.

Definition at line 26 of file ISymbolDirectoryResponses.h.

Member Function Documentation

virtual void Activ::ContentPlatform::ContentGatewayApi::ISymbolDirectoryResponses::OnGetSymbolsResponse ( HeapMessage & response ) [pure virtual]

Called on receiving an asynchronous GetSymbols::PostRequest() response.

The response can be deserialized using GetSymbols::Deserialize() if it is valid. The validity of the response can be determined using ContentGatewayClient::IsValidResponse().

Parameters:
response HeapMessage containing the serialized response.

Implemented in Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivContentGatewayApi/ISymbolDirectoryResponses.h
Generated on Wed Oct 8 14:02:03 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::ITimeSeriesResponses

Activ::ContentPlatform::ContentGatewayApi::ITimeSeriesResponses Class Reference

Interface for time series request callbacks. More...

#include <ActivContentPlatform/ActivContentGatewayApi/ITimeSeriesResponses.h>

Inheritance diagram for Activ::ContentPlatform::ContentGatewayApi::ITimeSeriesResponses:

Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient

List of all members.

Public Member Functions

virtual void | OnGetFirstHistoryResponse (HeapMessage &response)=0
Called on receiving an asynchronous GetHistory::PostGetFirstRequest() response.
virtual void | OnGetFirstIntradayResponse (HeapMessage &response)=0
Called on receiving an asynchronous GetIntraday::PostGetFirstRequest() response.
virtual void | OnGetFirstTicksResponse (HeapMessage &response)=0
Called on receiving an asynchronous GetTicks::PostGetFirstRequest() response.
virtual void | OnGetNextHistoryResponse (HeapMessage &response)=0
Called on receiving an asynchronous GetHistory::PostGetNextRequest() response.
virtual void | OnGetNextIntradayResponse (HeapMessage &response)=0
Called on receiving an asynchronous GetIntraday::PostGetNextRequest() response.
virtual void | OnGetNextTicksResponse (HeapMessage &response)=0
Called on receiving an asynchronous GetTicks::PostGetNextRequest() response.
virtual | ~ITimeSeriesResponses ()=0
Destructor.

Detailed Description

Interface for time series request callbacks.

Definition at line 26 of file ITimeSeriesResponses.h.

Member Function Documentation

virtual void Activ::ContentPlatform::ContentGatewayApi::ITimeSeriesResponses::OnGetFirstHistoryResponse ( HeapMessage & response ) [pure virtual]

Called on receiving an asynchronous GetHistory::PostGetFirstRequest() response.

The response can be deserialized using GetHistory::Deserialize() if it is valid. The validity of the response can be determined using ContentGatewayClient::IsValidResponse().

Parameters:
response HeapMessage containing the serialized response.

Implemented in Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient.

virtual void Activ::ContentPlatform::ContentGatewayApi::ITimeSeriesResponses::OnGetFirstIntradayResponse ( HeapMessage & response ) [pure virtual]

Called on receiving an asynchronous GetIntraday::PostGetFirstRequest() response.

The response can be deserialized using GetIntraday::Deserialize() if it is valid. The validity of the response can be determined using ContentGatewayClient::IsValidResponse().

Parameters:
response HeapMessage containing the serialized response.

Implemented in Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient.

virtual void Activ::ContentPlatform::ContentGatewayApi::ITimeSeriesResponses::OnGetFirstTicksResponse ( HeapMessage & response ) [pure virtual]

Called on receiving an asynchronous GetTicks::PostGetFirstRequest() response.

The response can be deserialized using GetTicks::Deserialize() if it is valid. The validity of the response can be determined using ContentGatewayClient::IsValidResponse().

Parameters:
response HeapMessage containing the serialized response.

Implemented in Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient.

virtual void Activ::ContentPlatform::ContentGatewayApi::ITimeSeriesResponses::OnGetNextHistoryResponse ( HeapMessage & response ) [pure virtual]

Called on receiving an asynchronous GetHistory::PostGetNextRequest() response.

The response can be deserialized using GetHistory::Deserialize() if it is valid. The validity of the response can be determined using ContentGatewayClient::IsValidResponse().

Parameters:
response HeapMessage containing the serialized response.

Implemented in Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient.

virtual void Activ::ContentPlatform::ContentGatewayApi::ITimeSeriesResponses::OnGetNextIntradayResponse ( HeapMessage & response ) [pure virtual]

Called on receiving an asynchronous GetIntraday::PostGetNextRequest() response.

The response can be deserialized using GetIntraday::Deserialize() if it is valid. The validity of the response can be determined using ContentGatewayClient::IsValidResponse().

Parameters:
response HeapMessage containing the serialized response.

Implemented in Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient.

virtual void Activ::ContentPlatform::ContentGatewayApi::ITimeSeriesResponses::OnGetNextTicksResponse ( HeapMessage & response ) [pure virtual]

Called on receiving an asynchronous GetTicks::PostGetNextRequest() response.

The response can be deserialized using GetTicks::Deserialize() if it is valid. The validity of the response can be determined using ContentGatewayClient::IsValidResponse().

Parameters:
response HeapMessage containing the serialized response.

Implemented in Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivContentGatewayApi/ITimeSeriesResponses.h
Generated on Wed Oct 8 14:02:03 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::MatchRequestParameters

Activ::ContentPlatform::ContentGatewayApi::MatchRequestParameters Class Reference

Request parameters for match request. More...

#include <ActivContentPlatform/ActivContentGatewayApiCommon/RealtimeTypes.h>

Inheritance diagram for Activ::ContentPlatform::ContentGatewayApi::MatchRequestParameters:

Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters Activ::ContentPlatform::ContentGatewayApi::SymbolIdListMatchRequestParameters Activ::ContentPlatform::ContentGatewayApi::SymbolIdMatchRequestParameters

List of all members.

Public Types

enum MatchType { ACTIV_DECLARE_VALUE_WITH_COMMA }

Public Attributes

MatchType m_matchType
Match type.

Detailed Description

Request parameters for match request.

Definition at line 346 of file RealtimeTypes.h.

Member Enumeration Documentation

enum Activ::ContentPlatform::ContentGatewayApi::MatchRequestParameters::MatchType

Look for primary symbol

Enumerator:
ACTIV_DECLARE_VALUE_WITH_COMMA The match types.

The number of match types.

Definition at line 356 of file RealtimeTypes.h.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivContentGatewayApiCommon/RealtimeTypes.h
Generated on Wed Oct 8 14:02:03 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::MetaDataRequestHelper

Activ::ContentPlatform::ContentGatewayApi::MetaDataRequestHelper Class Reference

Metadata request helper class. More...

#include <ActivContentPlatform/ActivContentGatewayApi/MetaDataRequestHelper.h>

List of all members.

Static Public Member Functions

static
ACTIV_CONTENT_GATEWAY_API
StatusCode 		GetPermissionInfo (const ContentGatewayClient &contentGatewayClient, PermissionInfo &permissionInfo)
Get permission information.
static
ACTIV_CONTENT_GATEWAY_API
const StatusCode 		GetRelationshipInfoList (const ContentGatewayClient &contentGatewayClient, const Feed::Context context, RelationshipInfoList &relationshipInfoList)
Get list of all available relationships, or for a given source context.
static
ACTIV_CONTENT_GATEWAY_API
StatusCode 		GetTableInfoList (const ContentGatewayClient &contentGatewayClient, const Feed::PermissionLevel permissionLevel, TableInfoList &tableInfoList)
Get a list of tables that can be accessed.
static
ACTIV_CONTENT_GATEWAY_API
StatusCode 		GetTableSpecification (const ContentGatewayClient &contentGatewayClient, const Feed::PermissionLevel permissionLevel, const Feed::TableNo tableNumber, Database::TableSpecification &tableSpecification)
Get the specification of a table.
static
ACTIV_CONTENT_GATEWAY_API
const
Feed::UniversalFieldHelper & 		GetUniversalFieldHelper (const ContentGatewayClient &contentGatewayClient, const std::string &codeIdentifier)
Get the universal field helper from a code identifier.
static
ACTIV_CONTENT_GATEWAY_API
const
Feed::UniversalFieldHelper & 		GetUniversalFieldHelper (const ContentGatewayClient &contentGatewayClient, const Feed::FieldId fieldId)
Get the universal field helper for a specific field id.
static
ACTIV_CONTENT_GATEWAY_API
const UniversalFieldHelperMap & 		GetUniversalFieldHelperMap (const ContentGatewayClient &contentGatewayClient)
Get a map of all known fields.

Detailed Description

Metadata request helper class.

Definition at line 33 of file MetaDataRequestHelper.h.

Member Function Documentation

static ACTIV_CONTENT_GATEWAY_API StatusCode Activ::ContentPlatform::ContentGatewayApi::MetaDataRequestHelper::GetPermissionInfo | ( | const ContentGatewayClient & | contentGatewayClient,
 |  | PermissionInfo & | permissionInfo |
 | ) |  |  | [static]

Get permission information.

Parameters:
contentGatewayClient | reference to ContentGatewayClient.
permissionInfo | to receive permission information for this user.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_CONNECTED
...

static ACTIV_CONTENT_GATEWAY_API const StatusCode Activ::ContentPlatform::ContentGatewayApi::MetaDataRequestHelper::GetRelationshipInfoList | ( | const ContentGatewayClient & | contentGatewayClient,
 |  | const Feed::Context | context,
 |  | RelationshipInfoList & | relationshipInfoList |
 | ) |  |  | [static]

Get list of all available relationships, or for a given source context.

Parameters:
contentGatewayClient | reference to ContentGatewayClient.
context | the source context to return the valid relationships for, or Feed::CONTEXT_UNDEFINED to return all.
relationshipInfoList | to receive the list of relationships.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_CONNECTED
STATUS_CODE_UNRECOGNIZED | the ContentGateway does not support this call
STATUS_CODE_NOT_FOUND | no relationships exist for the given source context.
...

static ACTIV_CONTENT_GATEWAY_API StatusCode Activ::ContentPlatform::ContentGatewayApi::MetaDataRequestHelper::GetTableInfoList | ( | const ContentGatewayClient & | contentGatewayClient,
 |  | const Feed::PermissionLevel | permissionLevel,
 |  | TableInfoList & | tableInfoList |
 | ) |  |  | [static]

Get a list of tables that can be accessed.

Parameters:
contentGatewayClient | reference to ContentGatewayClient.
permissionLevel | the permission level to get the list of table from, e.g. Feed::PERMISSION_LEVEL_REALTIME.
tableInfoList | to receive the list of TableInfo objects describing the tables available at permission level permissionLevel.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_CONNECTED
STATUS_CODE_UNRECOGNIZED | the ContentGateway does not support this call
STATUS_CODE_INVALID_PARAMETER | permissionLevel is not available on the ContentGateway
...

static ACTIV_CONTENT_GATEWAY_API StatusCode Activ::ContentPlatform::ContentGatewayApi::MetaDataRequestHelper::GetTableSpecification | ( | const ContentGatewayClient & | contentGatewayClient,
 |  | const Feed::PermissionLevel | permissionLevel,
 |  | const Feed::TableNo | tableNumber,
 |  | Database::TableSpecification & | tableSpecification |
 | ) |  |  | [static]

Get the specification of a table.

Parameters:
contentGatewayClient | reference to ContentGatewayClient.
permissionLevel | the permission level to get table specification from, e.g. Feed::PERMISSION_LEVEL_REALTIME.
tableNumber | the table number to get the specification of.
tableSpecification | to receive the list of fields and other relevant info in table tableNumber.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_CONNECTED
STATUS_CODE_UNRECOGNIZED | the ContentGateway does not support this call
STATUS_CODE_INVALID_PARAMETER | permissionLevel is not available on the ContentGateway
STATUS_CODE_INVALID_TABLE | tableNumber is not available on the ContentGateway
...

static ACTIV_CONTENT_GATEWAY_API const Feed::UniversalFieldHelper& Activ::ContentPlatform::ContentGatewayApi::MetaDataRequestHelper::GetUniversalFieldHelper | ( | const ContentGatewayClient & | contentGatewayClient,
 |  | const std::string & | codeIdentifier |
 | ) |  |  | [static]

Get the universal field helper from a code identifier.

Parameters:
contentGatewayClient | reference to ContentGatewayClient.
codeIdentifier | the field's C++ style code identifier (e.g. "FID_NAME").
Returns:
Const reference to a Feed::UniversalFieldHelper object.

static ACTIV_CONTENT_GATEWAY_API const Feed::UniversalFieldHelper& Activ::ContentPlatform::ContentGatewayApi::MetaDataRequestHelper::GetUniversalFieldHelper | ( | const ContentGatewayClient & | contentGatewayClient,
 |  | const Feed::FieldId | fieldId |
 | ) |  |  | [static]

Get the universal field helper for a specific field id.

Parameters:
contentGatewayClient | reference to ContentGatewayClient.
fieldId | the field id.
Returns:
Const reference to a Feed::UniversalFieldHelper object.

static ACTIV_CONTENT_GATEWAY_API const UniversalFieldHelperMap& Activ::ContentPlatform::ContentGatewayApi::MetaDataRequestHelper::GetUniversalFieldHelperMap ( const ContentGatewayClient & contentGatewayClient ) [static]

Get a map of all known fields.

If the ContentGateway supports it, this method will return a map of all fields available across all tables. Otherwise it will return those fields known about at the time the library was compiled.

Parameters:
contentGatewayClient reference to ContentGatewayClient.
Returns:
Const reference to a UniversalFieldHelperMap object, which is a map from Feed::FieldId to Feed::UniversalFieldHelper.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivContentGatewayApi/MetaDataRequestHelper.h
Generated on Wed Oct 8 14:02:03 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::NewsRequestHelper

Activ::ContentPlatform::ContentGatewayApi::NewsRequestHelper Class Reference

News request helper class. More...

#include <ActivContentPlatform/ActivContentGatewayApi/NewsRequestHelper.h>

List of all members.

Public Types

typedef NewsRequestParameters | RequestParameters
typedef NewsResponseParameters | ResponseParameters

Static Public Member Functions

static
ACTIV_CONTENT_GATEWAY_API
StatusCode 		Deserialize (const ContentGatewayClient &client, const HeapMessage &response, ResponseParameters &responseParameters)
Deserialize a news response.
static
ACTIV_CONTENT_GATEWAY_API
StatusCode 		GetResponse (const ContentGatewayClient &client, SyncRequestId &syncRequestId, ResponseParameters &responseParameters, const TimeoutPeriod timeoutPeriod)
Wait or poll for a response message from a sync request id object.
static
ACTIV_CONTENT_GATEWAY_API
StatusCode 		PostRequest (const ContentGatewayClient &client, const RequestId &requestId, const RequestParameters &requestParameters)
Get news asynchronously.
static
ACTIV_CONTENT_GATEWAY_API
StatusCode 		SendRequest (const ContentGatewayClient &client, SyncRequestId &syncRequestId, const RequestParameters &requestParameters)
Get news synchronously without blocking.
static
ACTIV_CONTENT_GATEWAY_API
StatusCode 		SendRequest (const ContentGatewayClient &client, const RequestParameters &requestParameters, ResponseParameters &responseParameters, const TimeoutPeriod timeoutPeriod=Port::defaultTimeout)
Get news synchronously.

Detailed Description

News request helper class.

Definition at line 30 of file NewsRequestHelper.h.

Member Function Documentation

static ACTIV_CONTENT_GATEWAY_API StatusCode Activ::ContentPlatform::ContentGatewayApi::NewsRequestHelper::Deserialize | ( | const ContentGatewayClient & | client,
 |  | const HeapMessage & | response,
 |  | ResponseParameters & | responseParameters |
 | ) |  |  | [static]

Deserialize a news response.

Parameters:
client | reference to ContentGatewayClient.
response | HeapMessage as passed to ContentGatewayClient::On*Response() or returned by SyncRequestId::GetResponse().
responseParameters | reference to a ResponseParameters object to receive deserialized response.
Return values:
STATUS_CODE_SUCCESS | response successfully deserialized
STATUS_CODE_UNRECOGNIZED | not a response of the correct type
... failed to deserialize response

static ACTIV_CONTENT_GATEWAY_API StatusCode Activ::ContentPlatform::ContentGatewayApi::NewsRequestHelper::GetResponse | ( | const ContentGatewayClient & | client,
 |  | SyncRequestId & | syncRequestId,
 |  | ResponseParameters & | responseParameters,
 |  | const TimeoutPeriod | timeoutPeriod |
 | ) |  |  | [static]

Wait or poll for a response message from a sync request id object.

Parameters:
client | reference to ContentGatewayClient.
syncRequestId | SyncRequestId object as returned by a successful Send() call.
responseParameters | to receive the returned data.
timeoutPeriod | timeout in ms.
Return values:
STATUS_CODE_SUCCESS | responseParameters contains the deserialized data and there is no more to follow
STATUS_CODE_PENDING | responseParameters contains the deserialized data and there more data to follow
STATUS_CODE_TIMEOUT
...

static ACTIV_CONTENT_GATEWAY_API StatusCode Activ::ContentPlatform::ContentGatewayApi::NewsRequestHelper::PostRequest | ( | const ContentGatewayClient & | client,
 |  | const RequestId & | requestId,
 |  | const RequestParameters & | requestParameters |
 | ) |  |  | [static]

Get news asynchronously.

Parameters:
client | reference to ContentGatewayClient.
requestId | RequestId object for the request.
requestParameters | RequestParameters object describing the request.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_CONNECTED
...

static ACTIV_CONTENT_GATEWAY_API StatusCode Activ::ContentPlatform::ContentGatewayApi::NewsRequestHelper::SendRequest | ( | const ContentGatewayClient & | client,
 |  | SyncRequestId & | syncRequestId,
 |  | const RequestParameters & | requestParameters |
 | ) |  |  | [static]

Get news synchronously without blocking.

Parameters:
client | reference to ContentGatewayClient.
syncRequestId | reference to a SyncRequestId object that can be used to poll for responses after this call.
requestParameters | parameters describing the request.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_CONNECTED
...

static ACTIV_CONTENT_GATEWAY_API StatusCode Activ::ContentPlatform::ContentGatewayApi::NewsRequestHelper::SendRequest | ( | const ContentGatewayClient & | client,
 |  | const RequestParameters & | requestParameters,
 |  | ResponseParameters & | responseParameters,
 |  | const TimeoutPeriod | timeoutPeriod = Port::defaultTimeout |
 | ) |  |  | [static]

Get news synchronously.

Parameters:
client | reference to ContentGatewayClient.
requestParameters | parameters describing the request.
responseParameters | to receive the returned data.
timeoutPeriod | timeout in ms.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_CONNECTED
STATUS_CODE_TIMEOUT
...

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivContentGatewayApi/NewsRequestHelper.h
Generated on Wed Oct 8 14:02:03 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::NewsRequestParameters

Activ::ContentPlatform::ContentGatewayApi::NewsRequestParameters Class Reference

News request parameters. More...

#include <ActivContentPlatform/ActivContentGatewayApiCommon/NewsTypes.h>

List of all members.

Public Types

typedef uint8_t | Flags
Response flags type.

Public Member Functions

ACTIV_CONTENT_GATEWAY_API_COMMON_API | NewsRequestParameters ()
Default constructor.

Public Attributes

Date m_endDate
The end date of the query.
Feed::FieldIdList | m_fieldIdList
Field list.
Flags m_flags
Request flags.
RecordsPerResponseCount | m_maxRecordsPerResponse
Maximum number of records in each response.
uint16_t | m_numberOfRecords
Number of news records to return.
Feed::PermissionLevel | m_permissionLevel
Requested permission level.
std::string | m_query
The query string.
Date m_startDate
The start date of the query.
std::string | m_startSymbol
The symbol to start from.

Static Public Attributes

static const
RecordsPerResponseCount 		DEFAULT_MAX_RECORDS_PER_RESPONSE = 64
static const Flags | FLAG_INCLUDE_EXPIRED = 0x02
static const Flags | FLAG_NONE = 0x00
static const Flags | FLAG_SUBSCRIBE = 0x01

Detailed Description

News request parameters.

Definition at line 39 of file NewsTypes.h.

Member Typedef Documentation

typedef uint8_t Activ::ContentPlatform::ContentGatewayApi::NewsRequestParameters::Flags

Response flags type.

Include expired stories in response

Definition at line 57 of file NewsTypes.h.

Constructor & Destructor Documentation

ACTIV_CONTENT_GATEWAY_API_COMMON_API Activ::ContentPlatform::ContentGatewayApi::NewsRequestParameters::NewsRequestParameters ( )

Default constructor.

m_numberOfRecords is set to 1 m_maxRecordsPerResponse is set to DEFAULT_MAX_RECORDS_PER_RESPONSE m_flags is set to FLAG_NONE m_permissionLevel is set to Feed::PERMISSION_LEVEL_DEFAULT

Member Data Documentation

const RecordsPerResponseCount Activ::ContentPlatform::ContentGatewayApi::NewsRequestParameters::DEFAULT_MAX_RECORDS_PER_RESPONSE = 64 [static]

Include expired stories in response

Definition at line 60 of file NewsTypes.h.

const Flags Activ::ContentPlatform::ContentGatewayApi::NewsRequestParameters::FLAG_INCLUDE_EXPIRED = 0x02 [static]

Subscribe to this news query

Definition at line 58 of file NewsTypes.h.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivContentGatewayApiCommon/NewsTypes.h
Generated on Wed Oct 8 14:02:03 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::NewsResponseParameters

Activ::ContentPlatform::ContentGatewayApi::NewsResponseParameters Class Reference

News response parameters. More...

#include <ActivContentPlatform/ActivContentGatewayApiCommon/NewsTypes.h>

List of all members.

Public Member Functions

ACTIV_CONTENT_GATEWAY_API_COMMON_API | NewsResponseParameters ()
Default constructor.

Public Attributes

NewsStoryList | m_storyList
SubscriptionCookie | m_subscriptionCookie

Detailed Description

News response parameters.

Definition at line 100 of file NewsTypes.h.

Constructor & Destructor Documentation

ACTIV_CONTENT_GATEWAY_API_COMMON_API Activ::ContentPlatform::ContentGatewayApi::NewsResponseParameters::NewsResponseParameters ( )

Default constructor.

m_subscriptionCookie is set to SUBSCRIPTION_COOKIE_UNDEFINED

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivContentGatewayApiCommon/NewsTypes.h
Generated on Wed Oct 8 14:02:03 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::NewsStory

Activ::ContentPlatform::ContentGatewayApi::NewsStory Class Reference

News story class. More...

#include <ActivContentPlatform/ActivContentGatewayApiCommon/NewsTypes.h>

List of all members.

Public Attributes

FieldData m_fieldData
serialized field data
Feed::PermissionIdList | m_permissionIdList
list of permission ids of the story
std::string | m_symbol
symbol for story

Detailed Description

News story class.

Definition at line 79 of file NewsTypes.h.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivContentGatewayApiCommon/NewsTypes.h
Generated on Wed Oct 8 14:02:03 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::NewsUpdate

Activ::ContentPlatform::ContentGatewayApi::NewsUpdate Class Reference

News update class. More...

#include <ActivContentPlatform/ActivContentGatewayApiCommon/NewsTypes.h>

List of all members.

Public Types

typedef uint8_t | Flags
Update flags.

Public Member Functions

bool | IsDelete () const
Is the update a delete?
bool | IsNewRecord () const
Is the update a new record update?

Static Public Member Functions

static
ACTIV_CONTENT_GATEWAY_API_COMMON_API
std::string 		FlagsToString (const Flags flags)
Convert flags to a printable string. Mainly for debugging purposes.

Public Attributes

Flags m_flags
Update flags.
NewsStory m_newsStory
The news story.
SubscriptionCookieList | m_subscriptionCookieList
List of subscription cookies this news story matches.
Feed::UpdateId | m_updateId
Update id.

Static Public Attributes

static const Flags | FLAG_DELETE = 0x01
static const Flags | FLAG_NONE = 0x00

Detailed Description

News update class.

Definition at line 120 of file NewsTypes.h.

Member Typedef Documentation

typedef uint8_t Activ::ContentPlatform::ContentGatewayApi::NewsUpdate::Flags

Update flags.

Update is a delete for a record

Definition at line 127 of file NewsTypes.h.

Member Function Documentation

static ACTIV_CONTENT_GATEWAY_API_COMMON_API std::string Activ::ContentPlatform::ContentGatewayApi::NewsUpdate::FlagsToString ( const Flags flags ) [static]

Convert flags to a printable string. Mainly for debugging purposes.

Update is a delete for a record

Parameters:
flags update flags.
Returns:
String representation of flags.

bool Activ::ContentPlatform::ContentGatewayApi::NewsUpdate::IsDelete ( ) const [inline]

Is the update a delete?

Returns:
true if a delete.

Definition at line 168 of file NewsTypes.h.

References FLAG_DELETE, and m_flags.

bool Activ::ContentPlatform::ContentGatewayApi::NewsUpdate::IsNewRecord ( ) const [inline]

Is the update a new record update?

Returns:
true if new record.

Definition at line 161 of file NewsTypes.h.

References m_updateId.

Member Data Documentation

const Flags Activ::ContentPlatform::ContentGatewayApi::NewsUpdate::FLAG_DELETE = 0x01 [static]

Nominal update

Definition at line 128 of file NewsTypes.h.

Referenced by IsDelete().

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivContentGatewayApiCommon/NewsTypes.h
Generated on Wed Oct 8 14:02:03 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::NewsUpdateHelper

Activ::ContentPlatform::ContentGatewayApi::NewsUpdateHelper Class Reference

News update helper class. More...

#include <ActivContentPlatform/ActivContentGatewayApi/NewsUpdateHelper.h>

List of all members.

Static Public Member Functions

static
ACTIV_CONTENT_GATEWAY_API
StatusCode 		Deserialize (const ContentGatewayClient &client, const HeapMessage &update, NewsUpdate &newsUpdate)
Deserialize a news update.

Detailed Description

News update helper class.

Definition at line 30 of file NewsUpdateHelper.h.

Member Function Documentation

static ACTIV_CONTENT_GATEWAY_API StatusCode Activ::ContentPlatform::ContentGatewayApi::NewsUpdateHelper::Deserialize | ( | const ContentGatewayClient & | client,
 |  | const HeapMessage & | update,
 |  | NewsUpdate & | newsUpdate |
 | ) |  |  | [static]

Deserialize a news update.

Parameters:
client | reference to ContentGatewayClient.
update | HeapMessage containing record update.
newsUpdate | reference to a NewsUpdate object to receive deserialized data.
Return values:
STATUS_CODE_SUCCESS | response successfully deserialized.
STATUS_CODE_UNRECOGNIZED | not a record update message.
... failed to deserialize response.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivContentGatewayApi/NewsUpdateHelper.h
Generated on Wed Oct 8 14:02:03 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::OptionBar

Activ::ContentPlatform::ContentGatewayApi::OptionBar Class Reference

Option Bar Field Set class. More...

#include <ActivContentPlatform/ActivContentGatewayApiCommon/OptionBar.h>

Inheritance diagram for Activ::ContentPlatform::ContentGatewayApi::OptionBar:

Activ::ContentPlatform::ContentGatewayApi::FieldSet

List of all members.

Public Member Functions

bool | Compare (const OptionBar &rhs) const
Full compare.
virtual StatusCode | Deserialize (MessageValidator &messageValidator)
Deserialize the object from the supplied message validator.
StatusCode | GetAskPrice (double &price) const
Get the ask price.
StatusCode | GetAskPrice (Rational &price) const
Get the ask price.
StatusCode | GetBidPrice (double &price) const
Get the bid price.
StatusCode | GetBidPrice (Rational &price) const
Get the bid price.
StatusCode | GetDate (Date &date) const
Get the date.
Rational::Denominator | GetDenominator () const
Get the denominator.
StatusCode | GetExpirationDate (Date &date) const
Get the expiration date.
virtual StatusCode | GetField (const Feed::FieldId fieldId, IFieldType &field) const
Get a field.
StatusCode | GetOpenInterest (unsigned &openInterest) const
Get the bar's total volume.
virtual size_t | GetSerializedLength () const
Get the serialized length of the object.
StatusCode | GetStrikePrice (double &price) const
Get the strike price.
StatusCode | GetStrikePrice (Rational &price) const
Get the strike price.
StatusCode | GetTotalVolume (unsigned &volume) const
Get the bar's total volume.
virtual FieldSetType | GetType () const
Get the field type.
StatusCode | GetUnderlyingPrice (double &price) const
Get the underlying price.
StatusCode | GetUnderlyingPrice (Rational &price) const
Get the underlying price.
bool | operator!= (const OptionBar &rhs) const
Inequality operator.
bool | operator< (const OptionBar &rhs) const
Less than operator (date only).
bool | operator<= (const OptionBar &rhs) const
Less than or equal operator (date only).
bool | operator== (const OptionBar &rhs) const
Equality operator.
bool | operator> (const OptionBar &rhs) const
Greater than operator (date only).
bool | operator>= (const OptionBar &rhs) const
Greater than or equal operator (date only).
OptionBar ()
Constructor.
void | Reduce (const Rational::Denominator minDenominator=Rational::DENOMINATOR_2DP)
Reduce all prices.
virtual void | Reset ()
Reset all values in the field set.
virtual StatusCode | Serialize (MessageBuilder &messageBuilder) const
Serialize the object into the supplied message builder.
StatusCode | SetAskPrice (const Rational &price)
Set the ask price.
StatusCode | SetBidPrice (const Rational &price)
Set the bid price.
StatusCode | SetDate (const Date &date)
Set the date.
StatusCode | SetDenominator (const Rational::Denominator denominator)
Set the denominator.
StatusCode | SetExpirationDate (const Date &date)
Set the expiration date.
virtual StatusCode | SetField (const Feed::FieldId fieldId, const IFieldType &field)
Get a field.
StatusCode | SetOpenInterest (const unsigned openInterest)
Set the bar's total volume.
StatusCode | SetStrikePrice (const Rational &price)
Set the strike price.
StatusCode | SetTotalVolume (const unsigned volume)
Set the bar's total volume.
StatusCode | SetUnderlyingPrice (const Rational &price)
Set the underlying price.
virtual std::string | ToString () const
Convert the object to a string.
virtual | ~OptionBar ()
Destructor.

Static Public Member Functions

static size_t | GetMaxSerializedLength ()
Get the maximum serialized length.

Detailed Description

Option Bar Field Set class.

Definition at line 37 of file OptionBar.h.

Member Function Documentation

bool Activ::ContentPlatform::ContentGatewayApi::OptionBar::Compare ( const OptionBar & rhs ) const

Full compare.

Parameters:
rhs the object to compare with.
Returns:
the result of the test.

Referenced by operator!=(), and operator==().

virtual StatusCode Activ::ContentPlatform::ContentGatewayApi::OptionBar::Deserialize ( MessageValidator & messageValidator ) [virtual]

Deserialize the object from the supplied message validator.

Parameters:
messageValidator the message validator from which the object will be extracted.
Return values:
STATUS_CODE_SUCCESS
...

Reimplemented from Activ::ContentPlatform::ContentGatewayApi::FieldSet.

StatusCode Activ::ContentPlatform::ContentGatewayApi::OptionBar::GetAskPrice ( double & price ) const [inline]

Get the ask price.

Parameters:
price the ask price of the bar.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 625 of file OptionBar.h.

References ACTIV_RETURN_RESULT_IF, Activ::Rational::GetDenominatorType(), Activ::Rational::DenominatorType::GetDivisor(), Activ::Rational::DenominatorType::GetMultiplier(), Activ::Rational::DenominatorType::IsDivisor(), and Activ::Rational::DenominatorType::IsMultiplier().

StatusCode Activ::ContentPlatform::ContentGatewayApi::OptionBar::GetAskPrice ( Rational & price ) const [inline]

Get the ask price.

Parameters:
price the ask price of the bar.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 618 of file OptionBar.h.

References Activ::Rational::Set().

StatusCode Activ::ContentPlatform::ContentGatewayApi::OptionBar::GetBidPrice ( double & price ) const [inline]

Get the bid price.

Parameters:
price the bid price of the bar.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 586 of file OptionBar.h.

References ACTIV_RETURN_RESULT_IF, Activ::Rational::GetDenominatorType(), Activ::Rational::DenominatorType::GetDivisor(), Activ::Rational::DenominatorType::GetMultiplier(), Activ::Rational::DenominatorType::IsDivisor(), and Activ::Rational::DenominatorType::IsMultiplier().

StatusCode Activ::ContentPlatform::ContentGatewayApi::OptionBar::GetBidPrice ( Rational & price ) const [inline]

Get the bid price.

Parameters:
price the bid price of the bar.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 579 of file OptionBar.h.

References Activ::Rational::Set().

StatusCode Activ::ContentPlatform::ContentGatewayApi::OptionBar::GetDate ( Date & date ) const [inline]

Get the date.

Parameters:
date the date of the bar.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 524 of file OptionBar.h.

Rational::Denominator Activ::ContentPlatform::ContentGatewayApi::OptionBar::GetDenominator ( ) const [inline]

Get the denominator.

Returns:
the denominator.

Definition at line 505 of file OptionBar.h.

StatusCode Activ::ContentPlatform::ContentGatewayApi::OptionBar::GetExpirationDate ( Date & date ) const [inline]

Get the expiration date.

Parameters:
date the expiration date of the option.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 689 of file OptionBar.h.

virtual StatusCode Activ::ContentPlatform::ContentGatewayApi::OptionBar::GetField | ( | const Feed::FieldId | fieldId,
 |  | IFieldType & | field |
 | ) |  |  | const [virtual]

Get a field.

Parameters:
fieldId | field's id.
field | actual field.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FIELD
STATUS_CODE_UNDEFINED_FIELD

Reimplemented from Activ::ContentPlatform::ContentGatewayApi::FieldSet.

static size_t Activ::ContentPlatform::ContentGatewayApi::OptionBar::GetMaxSerializedLength ( ) [static]

Get the maximum serialized length.

Returns:
the maximum serialized length.

Reimplemented from Activ::ContentPlatform::ContentGatewayApi::FieldSet.

StatusCode Activ::ContentPlatform::ContentGatewayApi::OptionBar::GetOpenInterest ( unsigned & openInterest ) const [inline]

Get the bar's total volume.

Parameters:
openInterest the open interest of the bar.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 673 of file OptionBar.h.

virtual size_t Activ::ContentPlatform::ContentGatewayApi::OptionBar::GetSerializedLength ( ) const [virtual]

Get the serialized length of the object.

Returns:
the serialized length of the object.

Reimplemented from Activ::ContentPlatform::ContentGatewayApi::FieldSet.

StatusCode Activ::ContentPlatform::ContentGatewayApi::OptionBar::GetStrikePrice ( double & price ) const [inline]

Get the strike price.

Parameters:
price the strike price of the bar.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 713 of file OptionBar.h.

References ACTIV_RETURN_RESULT_IF, Activ::Rational::GetDenominator(), Activ::Rational::GetDenominatorType(), Activ::Rational::DenominatorType::GetDivisor(), Activ::Rational::DenominatorType::GetMultiplier(), Activ::Rational::GetNumerator(), Activ::Rational::DenominatorType::IsDivisor(), and Activ::Rational::DenominatorType::IsMultiplier().

StatusCode Activ::ContentPlatform::ContentGatewayApi::OptionBar::GetStrikePrice ( Rational & price ) const [inline]

Get the strike price.

Parameters:
price the strike price of the bar.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 705 of file OptionBar.h.

StatusCode Activ::ContentPlatform::ContentGatewayApi::OptionBar::GetTotalVolume ( unsigned & volume ) const [inline]

Get the bar's total volume.

Parameters:
volume the total volume of the bar.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 657 of file OptionBar.h.

virtual FieldSetType Activ::ContentPlatform::ContentGatewayApi::OptionBar::GetType ( ) const [virtual]

Get the field type.

Returns:
the field type.

Reimplemented from Activ::ContentPlatform::ContentGatewayApi::FieldSet.

StatusCode Activ::ContentPlatform::ContentGatewayApi::OptionBar::GetUnderlyingPrice ( double & price ) const [inline]

Get the underlying price.

Parameters:
price the underlying price of the bar.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 547 of file OptionBar.h.

References ACTIV_RETURN_RESULT_IF, Activ::Rational::GetDenominatorType(), Activ::Rational::DenominatorType::GetDivisor(), Activ::Rational::DenominatorType::GetMultiplier(), Activ::Rational::DenominatorType::IsDivisor(), and Activ::Rational::DenominatorType::IsMultiplier().

StatusCode Activ::ContentPlatform::ContentGatewayApi::OptionBar::GetUnderlyingPrice ( Rational & price ) const [inline]

Get the underlying price.

Parameters:
price the underlying price of the bar.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 540 of file OptionBar.h.

References Activ::Rational::Set().

bool Activ::ContentPlatform::ContentGatewayApi::OptionBar::operator!= ( const OptionBar & rhs ) const [inline]

Inequality operator.

Parameters:
rhs the object to compare with.
Returns:
the result of the test.

Definition at line 458 of file OptionBar.h.

References Compare().

bool Activ::ContentPlatform::ContentGatewayApi::OptionBar::operator< ( const OptionBar & rhs ) const [inline]

Less than operator (date only).

Parameters:
rhs the object to compare with.
Returns:
the result of the test.

Definition at line 465 of file OptionBar.h.

References m_date.

bool Activ::ContentPlatform::ContentGatewayApi::OptionBar::operator<= ( const OptionBar & rhs ) const [inline]

Less than or equal operator (date only).

Parameters:
rhs the object to compare with.
Returns:
the result of the test.

Definition at line 475 of file OptionBar.h.

References m_date.

bool Activ::ContentPlatform::ContentGatewayApi::OptionBar::operator== ( const OptionBar & rhs ) const [inline]

Equality operator.

Parameters:
rhs the object to compare with.
Returns:
the result of the test.

Definition at line 451 of file OptionBar.h.

References Compare().

bool Activ::ContentPlatform::ContentGatewayApi::OptionBar::operator> ( const OptionBar & rhs ) const [inline]

Greater than operator (date only).

Parameters:
rhs the object to compare with.
Returns:
the result of the test.

Definition at line 485 of file OptionBar.h.

References m_date.

bool Activ::ContentPlatform::ContentGatewayApi::OptionBar::operator>= ( const OptionBar & rhs ) const [inline]

Greater than or equal operator (date only).

Parameters:
rhs the object to compare with.
Returns:
the result of the test.

Definition at line 495 of file OptionBar.h.

References m_date.

void Activ::ContentPlatform::ContentGatewayApi::OptionBar::Reduce ( const Rational::Denominator minDenominator = Rational::DENOMINATOR_2DP )

Reduce all prices.

Parameters:
minDenominator minimum denominator to reduce to.

virtual StatusCode Activ::ContentPlatform::ContentGatewayApi::OptionBar::Serialize ( MessageBuilder & messageBuilder ) const [virtual]

Serialize the object into the supplied message builder.

Parameters:
messageBuilder the message builder to store a serialized version of the object in.
Return values:
STATUS_CODE_SUCCESS
...

Reimplemented from Activ::ContentPlatform::ContentGatewayApi::FieldSet.

StatusCode Activ::ContentPlatform::ContentGatewayApi::OptionBar::SetAskPrice ( const Rational & price ) [inline]

Set the ask price.

Parameters:
price the ask price of the bar.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 643 of file OptionBar.h.

References ACTIV_RETURN_RESULT_IF, Activ::Rational::GetDenominator(), and Activ::Rational::GetNumerator().

StatusCode Activ::ContentPlatform::ContentGatewayApi::OptionBar::SetBidPrice ( const Rational & price ) [inline]

Set the bid price.

Parameters:
price the bid price of the bar.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 604 of file OptionBar.h.

References ACTIV_RETURN_RESULT_IF, Activ::Rational::GetDenominator(), and Activ::Rational::GetNumerator().

StatusCode Activ::ContentPlatform::ContentGatewayApi::OptionBar::SetDate ( const Date & date ) [inline]

Set the date.

Parameters:
date the date of the bar.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 532 of file OptionBar.h.

StatusCode Activ::ContentPlatform::ContentGatewayApi::OptionBar::SetDenominator ( const Rational::Denominator denominator ) [inline]

Set the denominator.

Parameters:
denominator the Rational::Denominator of various prices in the bar.
Return values:
STATUS_CODE_SUCCESS

Definition at line 512 of file OptionBar.h.

References ACTIV_RETURN_RESULT_IF.

StatusCode Activ::ContentPlatform::ContentGatewayApi::OptionBar::SetExpirationDate ( const Date & date ) [inline]

Set the expiration date.

Parameters:
date the expiration date of the option.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 697 of file OptionBar.h.

virtual StatusCode Activ::ContentPlatform::ContentGatewayApi::OptionBar::SetField | ( | const Feed::FieldId | fieldId,
 |  | const IFieldType & | field |
 | ) |  |  | [virtual]

Get a field.

Parameters:
fieldId | field's id.
field | actual field.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FIELD
STATUS_CODE_UNDEFINED_FIELD

Reimplemented from Activ::ContentPlatform::ContentGatewayApi::FieldSet.

StatusCode Activ::ContentPlatform::ContentGatewayApi::OptionBar::SetOpenInterest ( const unsigned openInterest ) [inline]

Set the bar's total volume.

Parameters:
openInterest the open interest of the bar.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 681 of file OptionBar.h.

StatusCode Activ::ContentPlatform::ContentGatewayApi::OptionBar::SetStrikePrice ( const Rational & price ) [inline]

Set the strike price.

Parameters:
price the strike price of the bar.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 731 of file OptionBar.h.

StatusCode Activ::ContentPlatform::ContentGatewayApi::OptionBar::SetTotalVolume ( const unsigned volume ) [inline]

Set the bar's total volume.

Parameters:
volume the volume of the bar.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 665 of file OptionBar.h.

StatusCode Activ::ContentPlatform::ContentGatewayApi::OptionBar::SetUnderlyingPrice ( const Rational & price ) [inline]

Set the underlying price.

Parameters:
price the underlying price of the bar.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 565 of file OptionBar.h.

References ACTIV_RETURN_RESULT_IF, Activ::Rational::GetDenominator(), and Activ::Rational::GetNumerator().

virtual std::string Activ::ContentPlatform::ContentGatewayApi::OptionBar::ToString ( ) const [virtual]

Convert the object to a string.

Returns:
the object as a string.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivContentGatewayApiCommon/OptionBar.h
Generated on Wed Oct 8 14:02:03 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::PatternMatchListRequestParameters

Activ::ContentPlatform::ContentGatewayApi::PatternMatchListRequestParameters Class Reference

Request parameters for pattern match on symbol based requests. More...

#include <ActivContentPlatform/ActivContentGatewayApiCommon/RealtimeTypes.h>

Inheritance diagram for Activ::ContentPlatform::ContentGatewayApi::PatternMatchListRequestParameters:

Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters

List of all members.

Public Types

typedef uint16_t | RequestFlags
Flags for this request only.

Public Member Functions

ACTIV_CONTENT_GATEWAY_API_COMMON_API | PatternMatchListRequestParameters ()
Default constructor.

Public Attributes

RequestFlags | m_requestFlags
std::vector< std::string > | m_symbolPatternList
Feed::TableNo | m_tableNumber

Static Public Attributes

static const RequestFlags | REQUEST_FLAG_NONE = 0x0000
static const RequestFlags | REQUEST_FLAG_REVERSE_ORDER = 0x0002
static const RequestFlags | REQUEST_FLAG_WATCH = 0x0001

Detailed Description

Request parameters for pattern match on symbol based requests.

Definition at line 316 of file RealtimeTypes.h.

Member Typedef Documentation

typedef uint16_t Activ::ContentPlatform::ContentGatewayApi::PatternMatchListRequestParameters::RequestFlags

Flags for this request only.

Return the results in reverse order

Definition at line 332 of file RealtimeTypes.h.

Constructor & Destructor Documentation

ACTIV_CONTENT_GATEWAY_API_COMMON_API Activ::ContentPlatform::ContentGatewayApi::PatternMatchListRequestParameters::PatternMatchListRequestParameters ( )

Default constructor.

m_tableNumber is set to Feed::TABLE_NO_UNDEFINED m_requestFlags is set to REQUEST_FLAG_NONE

Member Data Documentation

Feed::TableNo Activ::ContentPlatform::ContentGatewayApi::PatternMatchListRequestParameters::m_tableNumber

Return the results in reverse order

Definition at line 335 of file RealtimeTypes.h.

const RequestFlags Activ::ContentPlatform::ContentGatewayApi::PatternMatchListRequestParameters::REQUEST_FLAG_REVERSE_ORDER = 0x0002 [static]

Watch for new matches to the pattern

Definition at line 333 of file RealtimeTypes.h.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivContentGatewayApiCommon/RealtimeTypes.h
Generated on Wed Oct 8 14:02:03 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::PatternMatchRequestParameters

Activ::ContentPlatform::ContentGatewayApi::PatternMatchRequestParameters Class Reference

Request parameters for pattern match on symbol based requests. More...

#include <ActivContentPlatform/ActivContentGatewayApiCommon/RealtimeTypes.h>

Inheritance diagram for Activ::ContentPlatform::ContentGatewayApi::PatternMatchRequestParameters:

Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters

List of all members.

Public Types

typedef uint16_t | RequestFlags
Flags for this request only.

Public Member Functions

ACTIV_CONTENT_GATEWAY_API_COMMON_API | PatternMatchRequestParameters ()
Default constructor.

Public Attributes

RequestFlags | m_requestFlags
std::string | m_symbolPattern
Feed::TableNo | m_tableNumber

Static Public Attributes

static const RequestFlags | REQUEST_FLAG_NONE = 0x0000
static const RequestFlags | REQUEST_FLAG_REVERSE_ORDER = 0x0002
static const RequestFlags | REQUEST_FLAG_WATCH = 0x0001

Detailed Description

Request parameters for pattern match on symbol based requests.

Definition at line 286 of file RealtimeTypes.h.

Member Typedef Documentation

typedef uint16_t Activ::ContentPlatform::ContentGatewayApi::PatternMatchRequestParameters::RequestFlags

Flags for this request only.

Return the results in reverse order

Definition at line 302 of file RealtimeTypes.h.

Constructor & Destructor Documentation

ACTIV_CONTENT_GATEWAY_API_COMMON_API Activ::ContentPlatform::ContentGatewayApi::PatternMatchRequestParameters::PatternMatchRequestParameters ( )

Default constructor.

m_tableNumber is set to Feed::TABLE_NO_UNDEFINED m_requestFlags is set to REQUEST_FLAG_NONE

Member Data Documentation

Feed::TableNo Activ::ContentPlatform::ContentGatewayApi::PatternMatchRequestParameters::m_tableNumber

Return the results in reverse order

Definition at line 305 of file RealtimeTypes.h.

const RequestFlags Activ::ContentPlatform::ContentGatewayApi::PatternMatchRequestParameters::REQUEST_FLAG_REVERSE_ORDER = 0x0002 [static]

Watch for new matches to the pattern

Definition at line 303 of file RealtimeTypes.h.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivContentGatewayApiCommon/RealtimeTypes.h
Generated on Wed Oct 8 14:02:03 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::Period

Activ::ContentPlatform::ContentGatewayApi::Period Class Reference

Period of a series. More...

#include <ActivContentPlatform/ActivContentGatewayApiCommon/TimeSeriesTypes.h>

List of all members.

Public Member Functions

ACTIV_CONTENT_GATEWAY_API_COMMON_API
StatusCode 		Deserialize (MessageValidator &messageValidator)
Deserialize.
bool | IsAbsolutePeriod () const
Check if the Period is an absolute type.
bool | IsRelativeCount () const
Check if the Period is a count of data points.
bool | IsRelativePeriod () const
Check if the Period is a relative type.
ACTIV_CONTENT_GATEWAY_API_COMMON_API
bool 		operator== (const Period &rhs) const
Equality operator.
ACTIV_CONTENT_GATEWAY_API_COMMON_API
StatusCode 		Serialize (MessageBuilder &messageBuilder) const
Serialize.

Public Attributes

uint16_t | m_count
Count for this period.
DataPointAddress m_dataPointAddress
Data point address.
DateTime m_dateTime
Date and time for this period.
PeriodType | m_periodType
Type of this period.

Detailed Description

Period of a series.

Definition at line 237 of file TimeSeriesTypes.h.

Member Function Documentation

ACTIV_CONTENT_GATEWAY_API_COMMON_API StatusCode Activ::ContentPlatform::ContentGatewayApi::Period::Deserialize ( MessageValidator & messageValidator )

Deserialize.

Parameters:
messageValidator message validator.
Return values:
STATUS_CODE_SUCCESS.
...

bool Activ::ContentPlatform::ContentGatewayApi::Period::IsAbsolutePeriod ( ) const [inline]

Check if the Period is an absolute type.

Returns:
true/false

Definition at line 298 of file TimeSeriesTypes.h.

References m_periodType.

bool Activ::ContentPlatform::ContentGatewayApi::Period::IsRelativeCount ( ) const [inline]

Check if the Period is a count of data points.

Returns:
true/false

Definition at line 316 of file TimeSeriesTypes.h.

References m_periodType.

bool Activ::ContentPlatform::ContentGatewayApi::Period::IsRelativePeriod ( ) const [inline]

Check if the Period is a relative type.

Returns:
true/false

Definition at line 309 of file TimeSeriesTypes.h.

References m_periodType.

ACTIV_CONTENT_GATEWAY_API_COMMON_API bool Activ::ContentPlatform::ContentGatewayApi::Period::operator== ( const Period & rhs ) const

Equality operator.

Parameters:
rhs the object to test against.
Returns:
whether the two objects are equal.

ACTIV_CONTENT_GATEWAY_API_COMMON_API StatusCode Activ::ContentPlatform::ContentGatewayApi::Period::Serialize ( MessageBuilder & messageBuilder ) const

Serialize.

Parameters:
messageBuilder messageBuilder.
Return values:
STATUS_CODE_SUCCESS.
...

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivContentGatewayApiCommon/TimeSeriesTypes.h
Generated on Wed Oct 8 14:02:03 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::PermissionInfo

Activ::ContentPlatform::ContentGatewayApi::PermissionInfo Class Reference

Information about client's permissioning. More...

#include <ActivContentPlatform/ActivContentGatewayApiCommon/MetaDataTypes.h>

Inheritance diagram for Activ::ContentPlatform::ContentGatewayApi::PermissionInfo:

Activ::ContentPlatform::Feed::PermissionInfo

List of all members.

Public Attributes

UInt m_symbolSubscriptionQuota
Maximum number of symbol subscriptions allowed. Undefined is no limit.

Detailed Description

Information about client's permissioning.

See include/ActivContentPlatform/ActivFeedCommon/ActivFeedPermissioning/PermissionInfo.h.

Definition at line 37 of file MetaDataTypes.h.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivContentGatewayApiCommon/MetaDataTypes.h
Generated on Wed Oct 8 14:02:03 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestHelper

Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestHelper< MESSAGE_TYPE_VALUE, REQUEST_PARAMETERS > Class Template Reference

Realtime request helper class. More...

#include <ActivContentPlatform/ActivContentGatewayApi/RealtimeRequestHelper.h>

List of all members.

Public Types

typedef REQUEST_PARAMETERS | RequestParameters
Request paramters type.
typedef RealtimeResponseParameters | ResponseParameters
Response parameters type.

Static Public Member Functions

static
ACTIV_CONTENT_GATEWAY_API
StatusCode 		Deserialize (const ContentGatewayClient &client, const HeapMessage &response, ResponseParameters &responseParameters)
Deserialize a response.
static
ACTIV_CONTENT_GATEWAY_API
StatusCode 		GetResponse (const ContentGatewayClient &client, SyncRequestId &syncRequestId, ResponseParameters &responseParameters, const TimeoutPeriod timeoutPeriod=Port::defaultTimeout)
Wait or poll for a response message from a sync request id object.
static
ACTIV_CONTENT_GATEWAY_API
StatusCode 		PostRequest (const ContentGatewayClient &client, const RequestId &requestId, const RequestParameters &requestParameters)
Get items asynchronously.
static
ACTIV_CONTENT_GATEWAY_API
StatusCode 		SendRequest (const ContentGatewayClient &client, SyncRequestId &syncRequestId, const RequestParameters &requestParameters)
Get items synchronously without blocking.
static
ACTIV_CONTENT_GATEWAY_API
StatusCode 		SendRequest (const ContentGatewayClient &client, const RequestParameters &requestParameters, ResponseParameters &responseParameters, const TimeoutPeriod timeoutPeriod=Port::defaultTimeout)
Get items synchronously.

Static Public Attributes

static const MessageType | MESSAGE_TYPE = MESSAGE_TYPE_VALUE
Message type of this request type.

Detailed Description

template<MessageType MESSAGE_TYPE_VALUE, typename REQUEST_PARAMETERS>
class Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestHelper< MESSAGE_TYPE_VALUE, REQUEST_PARAMETERS >

Realtime request helper class.

Parameters:
MESSAGE_TYPE_VALUE | type of message for requests.
REQUEST_PARAMETERS | type of request parameters.

Definition at line 34 of file RealtimeRequestHelper.h.

Member Function Documentation

template<MessageType MESSAGE_TYPE_VALUE, typename REQUEST_PARAMETERS>
static ACTIV_CONTENT_GATEWAY_API StatusCode Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestHelper< MESSAGE_TYPE_VALUE, REQUEST_PARAMETERS >::Deserialize | ( | const ContentGatewayClient & | client,
 |  | const HeapMessage & | response,
 |  | ResponseParameters & | responseParameters |
 | ) |  |  | [static]

Deserialize a response.

This function should only be called if the received response is valid. This can be determined using ContentGatewayClient::IsValidResponse(). Note the response block list is not cleared down by this function, so it is possible to build a complete ResponseBlockList from multiple partial responses.

Parameters:
client | reference to ContentGatewayClient.
response | HeapMessage as passed to ContentGatewayClient::On*Response() or returned by SyncRequestId::GetResponse().
responseParameters | reference to a ResponseParameters object to receive deserialized response blocks.
Return values:
STATUS_CODE_SUCCESS | response successfully deserialized
STATUS_CODE_UNRECOGNIZED | not a MESSAGE_TYPE response message
... failed to deserialize response

template<MessageType MESSAGE_TYPE_VALUE, typename REQUEST_PARAMETERS>
static ACTIV_CONTENT_GATEWAY_API StatusCode Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestHelper< MESSAGE_TYPE_VALUE, REQUEST_PARAMETERS >::GetResponse | ( | const ContentGatewayClient & | client,
 |  | SyncRequestId & | syncRequestId,
 |  | ResponseParameters & | responseParameters,
 |  | const TimeoutPeriod | timeoutPeriod = Port::defaultTimeout |
 | ) |  |  | [static]

Wait or poll for a response message from a sync request id object.

Parameters:
client | reference to ContentGatewayClient.
syncRequestId | SyncRequestId object as returned by a successful Send() call.
responseParameters | to receive the returned data.
timeoutPeriod | timeout in ms.
Return values:
STATUS_CODE_SUCCESS | responseParameters contains the deserialized data and there is no more to follow
STATUS_CODE_PENDING | responseParameters contains the deserialized data and there is more data to follow
STATUS_CODE_TIMEOUT
...

template<MessageType MESSAGE_TYPE_VALUE, typename REQUEST_PARAMETERS>
static ACTIV_CONTENT_GATEWAY_API StatusCode Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestHelper< MESSAGE_TYPE_VALUE, REQUEST_PARAMETERS >::PostRequest | ( | const ContentGatewayClient & | client,
 |  | const RequestId & | requestId,
 |  | const RequestParameters & | requestParameters |
 | ) |  |  | [static]

Get items asynchronously.

Parameters:
client | reference to ContentGatewayClient.
requestId | request id.
requestParameters | parameters describing the request.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_CONNECTED
...

template<MessageType MESSAGE_TYPE_VALUE, typename REQUEST_PARAMETERS>
static ACTIV_CONTENT_GATEWAY_API StatusCode Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestHelper< MESSAGE_TYPE_VALUE, REQUEST_PARAMETERS >::SendRequest | ( | const ContentGatewayClient & | client,
 |  | SyncRequestId & | syncRequestId,
 |  | const RequestParameters & | requestParameters |
 | ) |  |  | [static]

Get items synchronously without blocking.

Parameters:
client | reference to ContentGatewayClient.
syncRequestId | reference to a SyncRequestId object that can be used to poll for responses after this call.
requestParameters | parameters describing the request.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_CONNECTED
...

template<MessageType MESSAGE_TYPE_VALUE, typename REQUEST_PARAMETERS>
static ACTIV_CONTENT_GATEWAY_API StatusCode Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestHelper< MESSAGE_TYPE_VALUE, REQUEST_PARAMETERS >::SendRequest | ( | const ContentGatewayClient & | client,
 |  | const RequestParameters & | requestParameters,
 |  | ResponseParameters & | responseParameters,
 |  | const TimeoutPeriod | timeoutPeriod = Port::defaultTimeout |
 | ) |  |  | [static]

Get items synchronously.

Parameters:
client | reference to ContentGatewayClient.
requestParameters | parameters describing the request.
responseParameters | to receive the returned data.
timeoutPeriod | timeout in ms.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_CONNECTED
STATUS_CODE_TIMEOUT
...

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivContentGatewayApi/RealtimeRequestHelper.h
Generated on Wed Oct 8 14:02:03 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters

Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters Class Reference

Request parameters that apply to all requests. More...

#include <ActivContentPlatform/ActivContentGatewayApiCommon/RealtimeTypes.h>

Inheritance diagram for Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters:

Activ::ContentPlatform::ContentGatewayApi::MatchRequestParameters Activ::ContentPlatform::ContentGatewayApi::PatternMatchListRequestParameters Activ::ContentPlatform::ContentGatewayApi::PatternMatchRequestParameters Activ::ContentPlatform::ContentGatewayApi::SymbolIdCountRequestParameters Activ::ContentPlatform::ContentGatewayApi::SymbolIdListRequestParameters Activ::ContentPlatform::ContentGatewayApi::SymbolIdRequestParameters Activ::ContentPlatform::ContentGatewayApi::TableNumberRequestParameters Activ::ContentPlatform::ContentGatewayApi::SymbolIdListMatchRequestParameters Activ::ContentPlatform::ContentGatewayApi::SymbolIdMatchRequestParameters

List of all members.

Public Types

typedef uint16_t | Flags
flags type

Public Member Functions

ACTIV_CONTENT_GATEWAY_API_COMMON_API
void 		Clear ()
Clear down request block list. All other members are left alone.
ACTIV_CONTENT_GATEWAY_API_COMMON_API | RealtimeRequestParameters ()
Default constructor.

Public Attributes

Flags m_flags
Flags for the request.
ResponseBlockCount | m_maxResponseBlocks
Max response blocks.
Feed::PermissionLevel | m_permissionLevel
Requested permission level.
RequestBlockList | m_requestBlockList
List of request blocks for this request.
SubscribeParameters m_subscribeParameters
Options for subscribing to results of request.

Static Public Attributes

static const ResponseBlockCount | DEFAULT_MAX_RESPONSE_BLOCKS = 64
static const Flags | FLAG_IGNORE_ALIAS = 0x0001
static const Flags | FLAG_NONE = 0x0000

Detailed Description

Request parameters that apply to all requests.

Definition at line 182 of file RealtimeTypes.h.

Member Typedef Documentation

typedef uint16_t Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters::Flags

flags type

Any aliasing will be ignored. The response will be the alias record, rather than the target of the alias

Definition at line 203 of file RealtimeTypes.h.

Constructor & Destructor Documentation

ACTIV_CONTENT_GATEWAY_API_COMMON_API Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters::RealtimeRequestParameters ( )

Default constructor.

m_flags is set to FLAG_NONE m_permissionLevel is set to PERMISSION_LEVEL_DEFAULT m_maxResponseBlocks is set to DEFAULT_MAX_RESPONSE_BLOCKS

Member Data Documentation

const ResponseBlockCount Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters::DEFAULT_MAX_RESPONSE_BLOCKS = 64 [static]

Any aliasing will be ignored. The response will be the alias record, rather than the target of the alias

Definition at line 206 of file RealtimeTypes.h.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivContentGatewayApiCommon/RealtimeTypes.h
Generated on Wed Oct 8 14:02:03 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::RealtimeResponseParameters

Activ::ContentPlatform::ContentGatewayApi::RealtimeResponseParameters Class Reference

Response parameters from a realtime request. More...

#include <ActivContentPlatform/ActivContentGatewayApiCommon/RealtimeTypes.h>

List of all members.

Public Member Functions

ACTIV_CONTENT_GATEWAY_API_COMMON_API
void 		Clear ()
Clear.
ACTIV_CONTENT_GATEWAY_API_COMMON_API | RealtimeResponseParameters ()
Default constructor.

Public Attributes

ResponseBlockList | m_responseBlockList
List of response blocks from the request.
SubscriptionCookie | m_subscriptionCookie
Cookie that can be used to unsubscribe from response keys.

Detailed Description

Response parameters from a realtime request.

Definition at line 533 of file RealtimeTypes.h.

Constructor & Destructor Documentation

ACTIV_CONTENT_GATEWAY_API_COMMON_API Activ::ContentPlatform::ContentGatewayApi::RealtimeResponseParameters::RealtimeResponseParameters ( )

Default constructor.

m_subscriptionCookie is set to SUBSCRIPTION_COOKIE_UNDEFINED.

Member Function Documentation

ACTIV_CONTENT_GATEWAY_API_COMMON_API void Activ::ContentPlatform::ContentGatewayApi::RealtimeResponseParameters::Clear ( )

Clear.

m_responseBlockList is emptied. m_subscriptionCookie is set to SUBSCRIPTION_COOKIE_UNDEFINED.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivContentGatewayApiCommon/RealtimeTypes.h
Generated on Wed Oct 8 14:02:03 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::RecordUpdate

Activ::ContentPlatform::ContentGatewayApi::RecordUpdate Class Reference

Record update. More...

#include <ActivContentPlatform/ActivContentGatewayApiCommon/RealtimeTypes.h>

List of all members.

Public Types

typedef uint8_t | Flags
Update flags.

Public Member Functions

bool | IsDelete () const
Is the update a delete?
bool | IsNewRecord () const
Is the update a new record update?

Static Public Member Functions

static
ACTIV_CONTENT_GATEWAY_API_COMMON_API
std::string 		FlagsToString (const Flags flags)
Convert flags to a printable string. Mainly for debugging purposes.

Public Attributes

Feed::EventType | m_eventType
Event type.
FieldData m_fieldData
Field data.
Flags m_flags
Update flags.
Feed::PermissionId | m_permissionId
Permission if of the update.
Feed::PermissionLevel | m_permissionLevel
Permission level of the update.
Feed::PermissionLevelData m_permissionLevelData
Permission level specific data (eg delay period).
Feed::RelationshipId | m_relationshipId
Relationship id (if FLAG_RELATIONSHIP_ID).
SymbolId m_requestKey
Original requested key (if FLAG_REQUEST_KEY).
SymbolId m_symbolId
Symbol of the updated record.
Feed::UpdateId | m_updateId
Update id.

Static Public Attributes

static const Flags | FLAG_DELETE = 0x01
static const Flags | FLAG_NONE = 0x00
static const Flags | FLAG_REFRESH = 0x04
static const Flags | FLAG_RELATIONSHIP_ID = 0x10
static const Flags | FLAG_REQUEST_KEY = 0x08
static const Flags | FLAG_STALE = 0x02

Detailed Description

Record update.

Definition at line 561 of file RealtimeTypes.h.

Member Typedef Documentation

typedef uint8_t Activ::ContentPlatform::ContentGatewayApi::RecordUpdate::Flags

Update flags.

Update contains relationship id

Definition at line 572 of file RealtimeTypes.h.

Member Function Documentation

static ACTIV_CONTENT_GATEWAY_API_COMMON_API std::string Activ::ContentPlatform::ContentGatewayApi::RecordUpdate::FlagsToString ( const Flags flags ) [static]

Convert flags to a printable string. Mainly for debugging purposes.

Update contains relationship id

Parameters:
flags update flags.
Returns:
String representation of flags.

bool Activ::ContentPlatform::ContentGatewayApi::RecordUpdate::IsDelete ( ) const [inline]

Is the update a delete?

Returns:
true if a delete.

Definition at line 619 of file RealtimeTypes.h.

References FLAG_DELETE, and m_flags.

bool Activ::ContentPlatform::ContentGatewayApi::RecordUpdate::IsNewRecord ( ) const [inline]

Is the update a new record update?

Returns:
true if new record.

Definition at line 612 of file RealtimeTypes.h.

References m_updateId.

Member Data Documentation

const Flags Activ::ContentPlatform::ContentGatewayApi::RecordUpdate::FLAG_DELETE = 0x01 [static]

Nominal update

Definition at line 573 of file RealtimeTypes.h.

Referenced by IsDelete().

const Flags Activ::ContentPlatform::ContentGatewayApi::RecordUpdate::FLAG_REFRESH = 0x04 [static]

Fields, other than those in this update, are potentially out of date

Definition at line 573 of file RealtimeTypes.h.

const Flags Activ::ContentPlatform::ContentGatewayApi::RecordUpdate::FLAG_RELATIONSHIP_ID = 0x10 [static]

Update contains requested key

Definition at line 573 of file RealtimeTypes.h.

const Flags Activ::ContentPlatform::ContentGatewayApi::RecordUpdate::FLAG_REQUEST_KEY = 0x08 [static]

Update is a refresh

Definition at line 573 of file RealtimeTypes.h.

const Flags Activ::ContentPlatform::ContentGatewayApi::RecordUpdate::FLAG_STALE = 0x02 [static]

Update is a delete for a record

Definition at line 573 of file RealtimeTypes.h.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivContentGatewayApiCommon/RealtimeTypes.h
Generated on Wed Oct 8 14:02:03 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::RecordUpdateHelper

Activ::ContentPlatform::ContentGatewayApi::RecordUpdateHelper Class Reference

Record update helper class. More...

#include <ActivContentPlatform/ActivContentGatewayApi/RecordUpdateHelper.h>

List of all members.

Static Public Member Functions

static
ACTIV_CONTENT_GATEWAY_API
StatusCode 		Deserialize (const ContentGatewayClient &client, const HeapMessage &update, RecordUpdate &recordUpdate, FieldListValidator &fieldListValidator)
Deserialize a record update including field contents.
static
ACTIV_CONTENT_GATEWAY_API
StatusCode 		Deserialize (const ContentGatewayClient &client, const HeapMessage &update, RecordUpdate &recordUpdate)
Deserialize a record update.

Detailed Description

Record update helper class.

Definition at line 31 of file RecordUpdateHelper.h.

Member Function Documentation

static ACTIV_CONTENT_GATEWAY_API StatusCode Activ::ContentPlatform::ContentGatewayApi::RecordUpdateHelper::Deserialize | ( | const ContentGatewayClient & | client,
 |  | const HeapMessage & | update,
 |  | RecordUpdate & | recordUpdate,
 |  | FieldListValidator & | fieldListValidator |
 | ) |  |  | [static]

Deserialize a record update including field contents.

Parameters:
client | reference to ContentGatewayClient.
update | HeapMessage containing record update.
recordUpdate | reference to a RecordUpdate object to receive deserialized data.
fieldListValidator | reference to a FieldListValidator to call Initialize() on with the field contents of recordUpdate.
Return values:
STATUS_CODE_SUCCESS | response successfully deserialized.
STATUS_CODE_UNRECOGNIZED | not a record update message.
... failed to deserialize response.

static ACTIV_CONTENT_GATEWAY_API StatusCode Activ::ContentPlatform::ContentGatewayApi::RecordUpdateHelper::Deserialize | ( | const ContentGatewayClient & | client,
 |  | const HeapMessage & | update,
 |  | RecordUpdate & | recordUpdate |
 | ) |  |  | [static]

Deserialize a record update.

Parameters:
client | reference to ContentGatewayClient.
update | HeapMessage containing record update.
recordUpdate | reference to a RecordUpdate object to receive deserialized data.
Return values:
STATUS_CODE_SUCCESS | response successfully deserialized.
STATUS_CODE_UNRECOGNIZED | not a record update message.
... failed to deserialize response.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivContentGatewayApi/RecordUpdateHelper.h
Generated on Wed Oct 8 14:02:03 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::RelationshipInfo

Activ::ContentPlatform::ContentGatewayApi::RelationshipInfo Class Reference

Info about available relationship ids. More...

#include <ActivContentPlatform/ActivContentGatewayApiCommon/MetaDataTypes.h>

List of all members.

Public Attributes

std::string | m_codeIdentifier
e.g. RELATIONSHIP_ID_INDEX
Feed::Context | m_context
e.g. 0
std::string | m_name
e.g. USListing_Index
Feed::RelationshipId | m_relationshipId
e.g. 102

Detailed Description

Info about available relationship ids.

Definition at line 76 of file MetaDataTypes.h.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivContentGatewayApiCommon/MetaDataTypes.h
Generated on Wed Oct 8 14:02:03 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::RequestBlock

Activ::ContentPlatform::ContentGatewayApi::RequestBlock Class Reference

Request block. More...

#include <ActivContentPlatform/ActivContentGatewayApiCommon/RealtimeTypes.h>

List of all members.

Public Types

typedef uint16_t | Flags
flags type

Public Member Functions

ACTIV_CONTENT_GATEWAY_API_COMMON_API
void 		Clear ()
Clear down.
ACTIV_CONTENT_GATEWAY_API_COMMON_API
StatusCode 		Deserialize (MessageValidator &messageValidator)
Deserialize.
ACTIV_CONTENT_GATEWAY_API_COMMON_API | RequestBlock ()
Default constructor.
ACTIV_CONTENT_GATEWAY_API_COMMON_API
StatusCode 		Serialize (MessageBuilder &messageBuilder) const
Serialize.

Public Attributes

Feed::FieldIdList | m_fieldIdList
field list
Flags m_flags
flags for this request block
Feed::RelationshipId | m_relationshipId
relationship id

Static Public Attributes

static const Flags | FLAG_ALL_FIELDS = 0x0001
static const Flags | FLAG_NONE = 0x0000

Detailed Description

Request block.

Definition at line 119 of file RealtimeTypes.h.

Member Typedef Documentation

typedef uint16_t Activ::ContentPlatform::ContentGatewayApi::RequestBlock::Flags

flags type

return all fields permissioned for

Definition at line 161 of file RealtimeTypes.h.

Constructor & Destructor Documentation

ACTIV_CONTENT_GATEWAY_API_COMMON_API Activ::ContentPlatform::ContentGatewayApi::RequestBlock::RequestBlock ( )

Default constructor.

m_flags is set to FLAG_NONE; m_relationshipId is set to Feed::RELATIONSHIP_ID_NONE

Member Function Documentation

ACTIV_CONTENT_GATEWAY_API_COMMON_API void Activ::ContentPlatform::ContentGatewayApi::RequestBlock::Clear ( )

Clear down.

Clears field list, resets flags and relationship id to RELATIONSHIP_ID_NONE.

ACTIV_CONTENT_GATEWAY_API_COMMON_API StatusCode Activ::ContentPlatform::ContentGatewayApi::RequestBlock::Deserialize ( MessageValidator & messageValidator )

Deserialize.

Parameters:
messageValidator message validator.
Return values:
STATUS_CODE_SUCCESS
...

ACTIV_CONTENT_GATEWAY_API_COMMON_API StatusCode Activ::ContentPlatform::ContentGatewayApi::RequestBlock::Serialize ( MessageBuilder & messageBuilder ) const

Serialize.

Parameters:
messageBuilder message builder.
Return values:
STATUS_CODE_SUCCESS
...

Member Data Documentation

Flags Activ::ContentPlatform::ContentGatewayApi::RequestBlock::m_flags

flags for this request block

return all fields permissioned for

Definition at line 164 of file RealtimeTypes.h.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivContentGatewayApiCommon/RealtimeTypes.h
Generated on Wed Oct 8 14:02:03 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::ResponseBlock

Activ::ContentPlatform::ContentGatewayApi::ResponseBlock Class Reference

Response block. More...

#include <ActivContentPlatform/ActivContentGatewayApiCommon/RealtimeTypes.h>

List of all members.

Public Types

typedef uint8_t | Flags
Response block flags.
typedef uint8_t | Status
Status type.

Public Member Functions

bool | IsResponseKeyDefined () const
Is response key defined in this response block?
bool | IsValidResponse () const
Is this a valid response?

Static Public Member Functions

static
ACTIV_CONTENT_GATEWAY_API_COMMON_API
std::string 		FlagsToString (const Flags flags)
Convert flags to a printable string. Mainly for debugging purposes.
static
ACTIV_CONTENT_GATEWAY_API_COMMON_API
std::string 		StatusToString (const Status status)
Return string representation of a response status.

Public Attributes

FieldData m_fieldData
field data
Flags m_flags
flags
Feed::PermissionId | m_permissionId
permission id of the record
Feed::PermissionLevel | m_permissionLevel
permission level of the record
Feed::PermissionLevelData m_permissionLevelData
permission level specific data (eg delay period)
Feed::RelationshipId | m_relationshipId
relationship id
SymbolId m_resolvedKey
fully resolved key
SymbolId m_responseKey
response key
Status m_status
status

Static Public Attributes

static const Flags | FLAG_NONE = 0x00
Flag constants.
static const Flags | FLAG_STALE = 0x01
static const Status | STATUS_INTERNAL_ERROR = 10
static const Status | STATUS_INVALID_SOURCE_TABLE = 11
static const Status | STATUS_NAVIGATION_NOT_FOUND = 6
static const Status | STATUS_NAVIGATION_NOT_PERMISSIONED = 7
static const Status | STATUS_PERMISSION_LEVEL_NOT_AVAILABLE = 12
static const Status | STATUS_RELATIONSHIP_NOT_FOUND = 4
static const Status | STATUS_RELATIONSHIP_NOT_PERMISSIONED = 5
static const Status | STATUS_SOURCE_NOT_FOUND = 2
static const Status | STATUS_SOURCE_NOT_PERMISSIONED = 3
static const Status | STATUS_SUCCESS = 0
Status code constants.
static const Status | STATUS_TARGET_NOT_FOUND = 8
static const Status | STATUS_TARGET_NOT_PERMISSIONED = 9

Detailed Description

Response block.

Definition at line 395 of file RealtimeTypes.h.

Member Function Documentation

static ACTIV_CONTENT_GATEWAY_API_COMMON_API std::string Activ::ContentPlatform::ContentGatewayApi::ResponseBlock::FlagsToString ( const Flags flags ) [static]

Convert flags to a printable string. Mainly for debugging purposes.

Parameters:
flags update flags.
Returns:
String representation of flags.

bool Activ::ContentPlatform::ContentGatewayApi::ResponseBlock::IsResponseKeyDefined ( ) const [inline]

Is response key defined in this response block?

Some error response status values will not have m_responseKey defined.

Returns:
True if m_responseKey is set.

Definition at line 505 of file RealtimeTypes.h.

References m_status, and STATUS_SUCCESS.

bool Activ::ContentPlatform::ContentGatewayApi::ResponseBlock::IsValidResponse ( ) const [inline]

Is this a valid response?

Returns:
True if status is STATUS_SUCCESS.

Definition at line 491 of file RealtimeTypes.h.

References m_status, and STATUS_SUCCESS.

static ACTIV_CONTENT_GATEWAY_API_COMMON_API std::string Activ::ContentPlatform::ContentGatewayApi::ResponseBlock::StatusToString ( const Status status ) [static]

Return string representation of a response status.

Field data is potentially out of date

Parameters:
status value to convert.
Returns:
String representation of status.

Member Data Documentation

const Flags Activ::ContentPlatform::ContentGatewayApi::ResponseBlock::FLAG_STALE = 0x01 [static]

Nominal response

Definition at line 484 of file RealtimeTypes.h.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivContentGatewayApiCommon/RealtimeTypes.h
Generated on Wed Oct 8 14:02:03 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::SubscribeFeedParameters

Activ::ContentPlatform::ContentGatewayApi::SubscribeFeedParameters Class Reference

Parameters for SubscribeToFeed() method. More...

#include <ActivContentPlatform/ActivContentGatewayApiCommon/RealtimeTypes.h>

Inheritance diagram for Activ::ContentPlatform::ContentGatewayApi::SubscribeFeedParameters:

Activ::ContentPlatform::ContentGatewayApi::SubscribeParameters

List of all members.

Public Member Functions

ACTIV_CONTENT_GATEWAY_API_COMMON_API | SubscribeFeedParameters ()
Default constructor.

Public Attributes

Feed::PermissionLevel | m_permissionLevel
Permission level to subscribe to feed with.

Detailed Description

Parameters for SubscribeToFeed() method.

Definition at line 77 of file RealtimeTypes.h.

Constructor & Destructor Documentation

ACTIV_CONTENT_GATEWAY_API_COMMON_API Activ::ContentPlatform::ContentGatewayApi::SubscribeFeedParameters::SubscribeFeedParameters ( )

Default constructor.

m_type is set to TYPE_FULL m_permissionLevel is set to Feed::PERMISSION_LEVEL_REALTIME

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivContentGatewayApiCommon/RealtimeTypes.h
Generated on Wed Oct 8 14:02:03 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::SubscribeParameters

Activ::ContentPlatform::ContentGatewayApi::SubscribeParameters Class Reference

Parameters for specifying subscription options. More...

#include <ActivContentPlatform/ActivContentGatewayApiCommon/RealtimeTypes.h>

Inheritance diagram for Activ::ContentPlatform::ContentGatewayApi::SubscribeParameters:

Activ::ContentPlatform::ContentGatewayApi::SubscribeFeedParameters Activ::ContentPlatform::ContentGatewayApi::SubscribeTableParameters

List of all members.

Public Types

typedef std::vector
< Feed::EventType > 		EventTypeList
Type of list of event types.
enum | Type { ACTIV_DECLARE_VALUE_WITH_COMMA }

Public Member Functions

ACTIV_CONTENT_GATEWAY_API_COMMON_API | SubscribeParameters ()
Default constructor.

Public Attributes

EventTypeList m_eventTypeList
List of event types to filter by, if TYPE_EVENT_TYPE_FILTER_(IN/EX)CLUDE_LIST.
Type m_type
Type of subscription.

Detailed Description

Parameters for specifying subscription options.

Definition at line 42 of file RealtimeTypes.h.

Member Enumeration Documentation

enum Activ::ContentPlatform::ContentGatewayApi::SubscribeParameters::Type

Subscribe to all updates

Enumerator:
ACTIV_DECLARE_VALUE_WITH_COMMA The types.

The number of types.

Definition at line 59 of file RealtimeTypes.h.

Constructor & Destructor Documentation

ACTIV_CONTENT_GATEWAY_API_COMMON_API Activ::ContentPlatform::ContentGatewayApi::SubscribeParameters::SubscribeParameters ( )

Default constructor.

m_type is set to TYPE_NONE

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivContentGatewayApiCommon/RealtimeTypes.h
Generated on Wed Oct 8 14:02:03 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::SubscribeTableParameters

Activ::ContentPlatform::ContentGatewayApi::SubscribeTableParameters Class Reference

Parameters for SubscribeToTable() method. More...

#include <ActivContentPlatform/ActivContentGatewayApiCommon/RealtimeTypes.h>

Inheritance diagram for Activ::ContentPlatform::ContentGatewayApi::SubscribeTableParameters:

Activ::ContentPlatform::ContentGatewayApi::SubscribeParameters

List of all members.

Public Member Functions

ACTIV_CONTENT_GATEWAY_API_COMMON_API | SubscribeTableParameters ()
Default constructor.

Public Attributes

Feed::PermissionLevel | m_permissionLevel
Permission level to subscribe to the tables with.
Feed::TableNoList | m_tableNumberList
List of table numbers to subscribe to.
RequestId m_updateRequestId
Id of this request for Workstation Service use.

Detailed Description

Parameters for SubscribeToTable() method.

Definition at line 97 of file RealtimeTypes.h.

Constructor & Destructor Documentation

ACTIV_CONTENT_GATEWAY_API_COMMON_API Activ::ContentPlatform::ContentGatewayApi::SubscribeTableParameters::SubscribeTableParameters ( )

Default constructor.

m_type is set to TYPE_FULL m_permissionLevel is set to Feed::PERMISSION_LEVEL_REALTIME

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivContentGatewayApiCommon/RealtimeTypes.h
Generated on Wed Oct 8 14:02:03 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::SubscriptionInfo

Activ::ContentPlatform::ContentGatewayApi::SubscriptionInfo Class Reference

Info returned about subscriptions. More...

#include <ActivContentPlatform/ActivContentGatewayApiCommon/Types.h>

List of all members.

Public Types

typedef std::map< std::string,
uint32_t > 		NewsSubscriptionMap
typedef std::map< SymbolId,
uint32_t > 		SymbolSubscriptionMap
typedef std::map
< Feed::TableNo, uint32_t > 		TableSubscriptionMap

Public Attributes

uint32_t | m_feedSubscriptionCount
number of times subscribed to whole feed
NewsSubscriptionMap | m_newsSubscriptionMap
map from query string -> number of times subscribed to it
SymbolSubscriptionMap | m_symbolSubscriptionMap
map from symbol -> number of times subscribed to it
TableSubscriptionMap | m_tableSubscriptionMap
map from table number -> number of times subscribed to it

Detailed Description

Info returned about subscriptions.

Definition at line 334 of file Types.h.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivContentGatewayApiCommon/Types.h
Generated on Wed Oct 8 14:02:03 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryRequestHelper

Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryRequestHelper Class Reference

Symbol directory helper class. More...

#include <ActivContentPlatform/ActivContentGatewayApi/SymbolDirectoryRequestHelper.h>

List of all members.

Public Types

typedef
SymbolDirectoryRequestParameters 		RequestParameters
typedef
SymbolDirectoryResponseParameters 		ResponseParameters

Static Public Member Functions

static
ACTIV_CONTENT_GATEWAY_API
StatusCode 		Deserialize (const ContentGatewayClient &client, const HeapMessage &response, ResponseParameters &responseParameters)
Deserialize a symbol directory response.
static
ACTIV_CONTENT_GATEWAY_API
StatusCode 		GetResponse (const ContentGatewayClient &client, SyncRequestId &syncRequestId, ResponseParameters &responseParameters, const TimeoutPeriod timeoutPeriod)
Wait or poll for a response message from a sync request id object.
static
ACTIV_CONTENT_GATEWAY_API
StatusCode 		PostRequest (const ContentGatewayClient &client, const RequestId &requestId, const RequestParameters &requestParameters)
Get symbols asynchronously.
static
ACTIV_CONTENT_GATEWAY_API
StatusCode 		SendRequest (const ContentGatewayClient &client, SyncRequestId &syncRequestId, const RequestParameters &requestParameters)
Get symbol synchronously without blocking.
static
ACTIV_CONTENT_GATEWAY_API
StatusCode 		SendRequest (const ContentGatewayClient &client, const RequestParameters &requestParameters, ResponseParameters &responseParameters, const TimeoutPeriod timeoutPeriod=Port::defaultTimeout)
Get symbols synchronously.

Detailed Description

Symbol directory helper class.

Definition at line 30 of file SymbolDirectoryRequestHelper.h.

Member Function Documentation

static ACTIV_CONTENT_GATEWAY_API StatusCode Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryRequestHelper::Deserialize | ( | const ContentGatewayClient & | client,
 |  | const HeapMessage & | response,
 |  | ResponseParameters & | responseParameters |
 | ) |  |  | [static]

Deserialize a symbol directory response.

Parameters:
client | reference to ContentGatewayClient.
response | HeapMessage as passed to ContentGatewayClient::On*Response() or returned by SyncRequestId::GetResponse().
responseParameters | reference to a ResponseParameters object to receive deserialized response.
Return values:
STATUS_CODE_SUCCESS | response successfully deserialized
STATUS_CODE_UNRECOGNIZED | not a response of the correct type
... failed to deserialize response

static ACTIV_CONTENT_GATEWAY_API StatusCode Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryRequestHelper::GetResponse | ( | const ContentGatewayClient & | client,
 |  | SyncRequestId & | syncRequestId,
 |  | ResponseParameters & | responseParameters,
 |  | const TimeoutPeriod | timeoutPeriod |
 | ) |  |  | [static]

Wait or poll for a response message from a sync request id object.

Parameters:
client | reference to ContentGatewayClient.
syncRequestId | SyncRequestId object as returned by a successful Send() call.
responseParameters | to receive the returned data.
timeoutPeriod | timeout in ms.
Return values:
STATUS_CODE_SUCCESS | responseParameters contains the deserialized data and there is no more to follow
STATUS_CODE_PENDING | responseParameters contains the deserialized data and there more data to follow
STATUS_CODE_TIMEOUT
...

static ACTIV_CONTENT_GATEWAY_API StatusCode Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryRequestHelper::PostRequest | ( | const ContentGatewayClient & | client,
 |  | const RequestId & | requestId,
 |  | const RequestParameters & | requestParameters |
 | ) |  |  | [static]

Get symbols asynchronously.

Parameters:
client | reference to ContentGatewayClient.
requestId | RequestId object for the request.
requestParameters | RequestParameters describing the request.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_CONNECTED
...

static ACTIV_CONTENT_GATEWAY_API StatusCode Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryRequestHelper::SendRequest | ( | const ContentGatewayClient & | client,
 |  | SyncRequestId & | syncRequestId,
 |  | const RequestParameters & | requestParameters |
 | ) |  |  | [static]

Get symbol synchronously without blocking.

Parameters:
client | reference to ContentGatewayClient.
syncRequestId | reference to a SyncRequestId object that can be used to poll for responses after this call.
requestParameters | parameters describing the request.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_CONNECTED
...

static ACTIV_CONTENT_GATEWAY_API StatusCode Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryRequestHelper::SendRequest | ( | const ContentGatewayClient & | client,
 |  | const RequestParameters & | requestParameters,
 |  | ResponseParameters & | responseParameters,
 |  | const TimeoutPeriod | timeoutPeriod = Port::defaultTimeout |
 | ) |  |  | [static]

Get symbols synchronously.

Parameters:
client | reference to ContentGatewayClient.
requestParameters | parameters describing the request.
responseParameters | to receive the returned data.
timeoutPeriod | timeout in ms.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_CONNECTED
STATUS_CODE_TIMEOUT
...

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivContentGatewayApi/SymbolDirectoryRequestHelper.h
Generated on Wed Oct 8 14:02:03 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryRequestParameters

Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryRequestParameters Class Reference

Get Symbols Request parameters. More...

#include <ActivContentPlatform/ActivContentGatewayApiCommon/SymbolDirectoryTypes.h>

List of all members.

Public Types

typedef std::vector
< Feed::EntityType > 		EntityTypeList
enum | FilterType { ACTIV_DECLARE_VALUE_WITH_COMMA }
enum | MatchType { ACTIV_DECLARE_VALUE_WITH_COMMA }

Public Member Functions

ACTIV_CONTENT_GATEWAY_API_COMMON_API
StatusCode 		Deserialize (MessageValidator &messageValidator)
Deserialize.
ACTIV_CONTENT_GATEWAY_API_COMMON_API
StatusCode 		Serialize (MessageBuilder &messageBuilder) const
Serialize.
ACTIV_CONTENT_GATEWAY_API_COMMON_API | SymbolDirectoryRequestParameters ()
Default constructor.

Public Attributes

EntityTypeList | m_entityTypeList
Entity type list to filter on.
Feed::FieldId | m_fieldId
Field to search on.
FilterType m_filterType
Filter type, default FILTER_TYPE_FULL.
MatchType m_matchType
Match type, default MATCH_TYPE_ANY.
std::string | m_searchString
String to search on.

Detailed Description

Get Symbols Request parameters.

Definition at line 32 of file SymbolDirectoryTypes.h.

Member Enumeration Documentation

enum Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryRequestParameters::FilterType

Exclude these Entity Types from the response

Enumerator:
ACTIV_DECLARE_VALUE_WITH_COMMA The filter types.

The match types.

The number of filter types.

The number of match types.

Definition at line 67 of file SymbolDirectoryTypes.h.

enum Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryRequestParameters::MatchType

Exact match on string

Enumerator:
ACTIV_DECLARE_VALUE_WITH_COMMA The filter types.

The match types.

The number of filter types.

The number of match types.

Definition at line 77 of file SymbolDirectoryTypes.h.

Member Function Documentation

ACTIV_CONTENT_GATEWAY_API_COMMON_API StatusCode Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryRequestParameters::Deserialize ( MessageValidator & messageValidator )

Deserialize.

Parameters:
messageValidator message validator.
Return values:
STATUS_CODE_SUCCESS
...

ACTIV_CONTENT_GATEWAY_API_COMMON_API StatusCode Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryRequestParameters::Serialize ( MessageBuilder & messageBuilder ) const

Serialize.

Parameters:
messageBuilder
Return values:
STATUS_CODE_SUCCESS.
...

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivContentGatewayApiCommon/SymbolDirectoryTypes.h
Generated on Wed Oct 8 14:02:03 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryResponseParameters

Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryResponseParameters Class Reference

Symbol directory response parameters. More...

#include <ActivContentPlatform/ActivContentGatewayApiCommon/SymbolDirectoryTypes.h>

List of all members.

Public Types

typedef std::vector
< SymbolResponse > 		SymbolResponseList

Public Member Functions

ACTIV_CONTENT_GATEWAY_API_COMMON_API
void 		Clear ()
Clear down response symbol list.
ACTIV_CONTENT_GATEWAY_API_COMMON_API
StatusCode 		Deserialize (MessageValidator &messageValidator)
Deserialize.
ACTIV_CONTENT_GATEWAY_API_COMMON_API
StatusCode 		Serialize (MessageBuilder &messageBuilder) const
Serialize.

Public Attributes

Feed::FieldId | m_fieldId
Field searched on.
SymbolResponseList | m_symbolResponseList
List of all found symbols (+ info).

Detailed Description

Symbol directory response parameters.

Definition at line 137 of file SymbolDirectoryTypes.h.

Member Function Documentation

ACTIV_CONTENT_GATEWAY_API_COMMON_API StatusCode Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryResponseParameters::Deserialize ( MessageValidator & messageValidator )

Deserialize.

Parameters:
messageValidator message validator.
Return values:
STATUS_CODE_SUCCESS.
...

ACTIV_CONTENT_GATEWAY_API_COMMON_API StatusCode Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryResponseParameters::Serialize ( MessageBuilder & messageBuilder ) const

Serialize.

Parameters:
messageBuilder
Return values:
STATUS_CODE_SUCCESS.
...

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivContentGatewayApiCommon/SymbolDirectoryTypes.h
Generated on Wed Oct 8 14:02:04 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::SymbolId

Activ::ContentPlatform::ContentGatewayApi::SymbolId Class Reference

Symbol id. More...

#include <ActivContentPlatform/ActivContentGatewayApiCommon/Types.h>

List of all members.

Public Types

typedef std::string | Symbol
underlying symbol type

Public Member Functions

bool | operator!= (const SymbolId &rhs) const
Inequality operator.
bool | operator< (const SymbolId &rhs) const
Less than operator.
bool | operator== (const SymbolId &rhs) const
Equality operator.
SymbolId (const Feed::TableNo tableNumber, const Symbol &symbol)
Constructor.
SymbolId (const Symbol &symbol)
Constructor. Table number is set to TABLE_NO_UNDEFINED.
SymbolId ()
Default constructor. Table number is set to TABLE_NO_UNDEFINED.

Public Attributes

Symbol m_symbol
symbol string
Feed::TableNo | m_tableNumber
table number

Detailed Description

Symbol id.

Definition at line 100 of file Types.h.

Constructor & Destructor Documentation

Activ::ContentPlatform::ContentGatewayApi::SymbolId::SymbolId ( const Symbol & symbol ) [inline]

Constructor. Table number is set to TABLE_NO_UNDEFINED.

Parameters:
symbol symbol string.

Definition at line 165 of file Types.h.

Activ::ContentPlatform::ContentGatewayApi::SymbolId::SymbolId | ( | const Feed::TableNo | tableNumber,
 |  | const Symbol & | symbol |
 | ) |  |  | [inline]

Constructor.

Parameters:
tableNumber | table number.
symbol | symbol string.

Definition at line 173 of file Types.h.

Member Function Documentation

bool Activ::ContentPlatform::ContentGatewayApi::SymbolId::operator!= ( const SymbolId & rhs ) const [inline]

Inequality operator.

Parameters:
rhs SymbolId to compare to.
Returns:
true if this != rhs. Only m_symbol takes part in the comparison as it is unique.

Definition at line 195 of file Types.h.

bool Activ::ContentPlatform::ContentGatewayApi::SymbolId::operator< ( const SymbolId & rhs ) const [inline]

Less than operator.

Parameters:
rhs SymbolId to compare to.
Returns:
true if this < rhs. Only m_symbol takes part in the comparison as it is unique.

Definition at line 188 of file Types.h.

References m_symbol.

bool Activ::ContentPlatform::ContentGatewayApi::SymbolId::operator== ( const SymbolId & rhs ) const [inline]

Equality operator.

Parameters:
rhs SymbolId to compare to.
Returns:
true if this == rhs. Only m_symbol takes part in the comparison as it is unique.

Definition at line 181 of file Types.h.

References m_symbol.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivContentGatewayApiCommon/Types.h
Generated on Wed Oct 8 14:02:04 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::SymbolIdCountRequestParameters

Activ::ContentPlatform::ContentGatewayApi::SymbolIdCountRequestParameters Class Reference

Request parameters for SymbolId based requests with count (for get next, previous). More...

#include <ActivContentPlatform/ActivContentGatewayApiCommon/RealtimeTypes.h>

Inheritance diagram for Activ::ContentPlatform::ContentGatewayApi::SymbolIdCountRequestParameters:

Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters

List of all members.

Public Member Functions

ACTIV_CONTENT_GATEWAY_API_COMMON_API | SymbolIdCountRequestParameters ()
Default constructor.

Public Attributes

uint16_t | m_numberOfRecords
Number of records to return.
SymbolId m_symbolId
Symbol to start from.

Detailed Description

Request parameters for SymbolId based requests with count (for get next, previous).

Definition at line 254 of file RealtimeTypes.h.

Constructor & Destructor Documentation

ACTIV_CONTENT_GATEWAY_API_COMMON_API Activ::ContentPlatform::ContentGatewayApi::SymbolIdCountRequestParameters::SymbolIdCountRequestParameters ( )

Default constructor.

m_numberOfRecords is set to 1

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivContentGatewayApiCommon/RealtimeTypes.h
Generated on Wed Oct 8 14:02:04 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::SymbolIdListMatchRequestParameters

Activ::ContentPlatform::ContentGatewayApi::SymbolIdListMatchRequestParameters Class Reference

Request parameters for multiple match request with multiple symbols. More...

#include <ActivContentPlatform/ActivContentGatewayApiCommon/RealtimeTypes.h>

Inheritance diagram for Activ::ContentPlatform::ContentGatewayApi::SymbolIdListMatchRequestParameters:

Activ::ContentPlatform::ContentGatewayApi::MatchRequestParameters Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters

List of all members.

Public Attributes

SymbolIdList m_symbolIdList
List of partial symbols to search for.

Detailed Description

Request parameters for multiple match request with multiple symbols.

Definition at line 383 of file RealtimeTypes.h.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivContentGatewayApiCommon/RealtimeTypes.h
Generated on Wed Oct 8 14:02:04 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::SymbolIdListRequestParameters

Activ::ContentPlatform::ContentGatewayApi::SymbolIdListRequestParameters Class Reference

Request parameters for SymbolIdList based requests. More...

#include <ActivContentPlatform/ActivContentGatewayApiCommon/RealtimeTypes.h>

Inheritance diagram for Activ::ContentPlatform::ContentGatewayApi::SymbolIdListRequestParameters:

Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters

List of all members.

Public Attributes

SymbolIdList m_symbolIdList

Detailed Description

Request parameters for SymbolIdList based requests.

Definition at line 274 of file RealtimeTypes.h.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivContentGatewayApiCommon/RealtimeTypes.h
Generated on Wed Oct 8 14:02:04 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::SymbolIdMatchRequestParameters

Activ::ContentPlatform::ContentGatewayApi::SymbolIdMatchRequestParameters Class Reference

Request parameters for match request with single symbol. More...

#include <ActivContentPlatform/ActivContentGatewayApiCommon/RealtimeTypes.h>

Inheritance diagram for Activ::ContentPlatform::ContentGatewayApi::SymbolIdMatchRequestParameters:

Activ::ContentPlatform::ContentGatewayApi::MatchRequestParameters Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters

List of all members.

Public Attributes

SymbolId m_symbolId
Partial symbol to search for.

Detailed Description

Request parameters for match request with single symbol.

Definition at line 371 of file RealtimeTypes.h.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivContentGatewayApiCommon/RealtimeTypes.h
Generated on Wed Oct 8 14:02:04 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::SymbolIdRequestParameters

Activ::ContentPlatform::ContentGatewayApi::SymbolIdRequestParameters Class Reference

Request parameters for SymbolId based requests. More...

#include <ActivContentPlatform/ActivContentGatewayApiCommon/RealtimeTypes.h>

Inheritance diagram for Activ::ContentPlatform::ContentGatewayApi::SymbolIdRequestParameters:

Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters

List of all members.

Public Attributes

SymbolId m_symbolId

Detailed Description

Request parameters for SymbolId based requests.

Definition at line 242 of file RealtimeTypes.h.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivContentGatewayApiCommon/RealtimeTypes.h
Generated on Wed Oct 8 14:02:04 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::SymbolResponse

Activ::ContentPlatform::ContentGatewayApi::SymbolResponse Class Reference

Symbol directory response parameters. More...

#include <ActivContentPlatform/ActivContentGatewayApiCommon/SymbolDirectoryTypes.h>

List of all members.

Public Types

typedef uint16_t | Flags
Response flags type.

Public Member Functions

bool | SameAsLastCheck (const SymbolResponse &symbolResponse) const
Checks if the fieldType and matchData are the same or the flag is set.

Public Attributes

Feed::EntityType | m_entityType
The entity type of the found symbol.
Flags m_flags
Response Flags.
std::string | m_matchData
The match data.
SymbolId m_symbolId
The found symbol.

Static Public Attributes

static const Flags | FLAG_NONE = 0x0000
static const Flags | FLAG_SAME_AS_LAST = 0x0001

Detailed Description

Symbol directory response parameters.

Definition at line 99 of file SymbolDirectoryTypes.h.

Member Typedef Documentation

typedef uint16_t Activ::ContentPlatform::ContentGatewayApi::SymbolResponse::Flags

Response flags type.

The field type and match data are the same as the previous response

Definition at line 115 of file SymbolDirectoryTypes.h.

Member Function Documentation

bool Activ::ContentPlatform::ContentGatewayApi::SymbolResponse::SameAsLastCheck ( const SymbolResponse & symbolResponse ) const [inline]

Checks if the fieldType and matchData are the same or the flag is set.

Parameters:
symbolResponse the SymbolResponse to check against.
Return values:
true if the same

Definition at line 126 of file SymbolDirectoryTypes.h.

References m_flags, and m_matchData.

Member Data Documentation

SymbolId Activ::ContentPlatform::ContentGatewayApi::SymbolResponse::m_symbolId

The found symbol.

The field type and match data are the same as the previous response

Definition at line 118 of file SymbolDirectoryTypes.h.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivContentGatewayApiCommon/SymbolDirectoryTypes.h
Generated on Wed Oct 8 14:02:04 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::TableInfo

Activ::ContentPlatform::ContentGatewayApi::TableInfo Class Reference

Info about available tables. More...

#include <ActivContentPlatform/ActivContentGatewayApiCommon/MetaDataTypes.h>

List of all members.

Public Attributes

std::string | m_tableCodeIdentifier
e.g. TABLE_NO_US_LISTING
std::string | m_tableName
e.g. UsListing
Feed::TableNo | m_tableNumber
e.g. 0
Feed::TableType | m_tableType

Detailed Description

Info about available tables.

Definition at line 49 of file MetaDataTypes.h.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivContentGatewayApiCommon/MetaDataTypes.h
Generated on Wed Oct 8 14:02:04 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::TableNumberRequestParameters

Activ::ContentPlatform::ContentGatewayApi::TableNumberRequestParameters Class Reference

Request parameters for table number based requests. More...

#include <ActivContentPlatform/ActivContentGatewayApiCommon/RealtimeTypes.h>

Inheritance diagram for Activ::ContentPlatform::ContentGatewayApi::TableNumberRequestParameters:

Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters

List of all members.

Public Member Functions

ACTIV_CONTENT_GATEWAY_API_COMMON_API | TableNumberRequestParameters ()
Default constructor.

Public Attributes

uint16_t | m_numberOfRecords
Number of records to return.
Feed::TableNo | m_tableNumber
Table to search.

Detailed Description

Request parameters for table number based requests.

Definition at line 221 of file RealtimeTypes.h.

Constructor & Destructor Documentation

ACTIV_CONTENT_GATEWAY_API_COMMON_API Activ::ContentPlatform::ContentGatewayApi::TableNumberRequestParameters::TableNumberRequestParameters ( )

Default constructor.

m_tableNumber is set to Feed::TABLE_NO_UNDEFINED m_numberOfRecords is set to 1

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivContentGatewayApiCommon/RealtimeTypes.h
Generated on Wed Oct 8 14:02:04 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::Tick

Activ::ContentPlatform::ContentGatewayApi::Tick Class Reference

Tick Field Set class. More...

#include <ActivContentPlatform/ActivContentGatewayApiCommon/Tick.h>

Inheritance diagram for Activ::ContentPlatform::ContentGatewayApi::Tick:

Activ::ContentPlatform::ContentGatewayApi::FieldSet

List of all members.

Public Member Functions

virtual StatusCode | Compare (const Tick &rhs, int &result) const
Compare dateTime only.
virtual StatusCode | Compare (const DateTime &dateTime, int &result) const
compares dateTime
virtual bool | Compare (const Tick &rhs) const
Compare content and time to see if a match for cancel is found (NOTE millisecond part is not compared).
virtual bool | CompareContentOnly (const Tick &rhs) const
compares all fields except tick type and datetime.
virtual
ACTIV_CONTENT_GATEWAY_API_COMMON_API
StatusCode 		Deserialize (MessageValidator &messageValidator)
Deserialize the object from the supplied message validator.
virtual
ACTIV_CONTENT_GATEWAY_API_COMMON_API
StatusCode 		FromString (const std::string &inputStr, const std::string &deliminator=DEFAULT_STRING_FIELD_SEPARATER)
Set the object value from a string.
ACTIV_CONTENT_GATEWAY_API_COMMON_API
StatusCode 		GetBuyerId (char *pBuyerId, const size_t idMaxLength, size_t &actualSize) const
Get the buyerId.
StatusCode | GetConditions (byte_t *pConditions, const size_t conditionsLength, size_t &conditionsSize) const
Get the conditions.
StatusCode | GetDateTime (DateTime &dateTime) const
Get the date and time.
const std::string & | GetExchange () const
Get the exchange.
StatusCode | GetExchange (std::string &exchange) const
Get the exchange.
virtual
ACTIV_CONTENT_GATEWAY_API_COMMON_API
StatusCode 		GetField (const Feed::FieldId fieldId, IFieldType &field) const
Get a field.
StatusCode | GetPrice (Rational &price) const
Get the price as a 64 bit signed integer.
StatusCode | GetPrice (double &price) const
Get the price.
ACTIV_CONTENT_GATEWAY_API_COMMON_API
StatusCode 		GetSellerId (char *pSellerId, const size_t idMaxLength, size_t &actualSize) const
Get the sellerId.
virtual
ACTIV_CONTENT_GATEWAY_API_COMMON_API
size_t 		GetSerializedLength () const
Get the serialized length of the object.
StatusCode | GetSize (uint32_t &size) const
Get the tick's size.
StatusCode | GetSize (Rational &size) const
Get the tick's size.
TickType | GetTickType () const
Get the tick's type.
ACTIV_CONTENT_GATEWAY_API_COMMON_API
char 		GetTradeThroughExemptFlag () const
Get the Trade through exempt flag.
virtual
ACTIV_CONTENT_GATEWAY_API_COMMON_API
FieldSetType 		GetType () const
Get the field set type.
Feed::UpdateId | GetUpdateId () const
Get the sequence number of the tick.
StatusCode | GetUpdateId (Feed::UpdateId &updateId) const
Get the sequence number of the tick.
bool | IsOutOfSequence () const
check if this tick is out of sequence in terms of time
bool | IsRegularHourTrade () const
check if this tick is a regular hour trade
bool | IsTrade () const
check if this tick is a trade
bool | operator!= (const Tick &rhs) const
Inequality operator. Comparing date time only.
bool | operator< (const DateTime &dateTime) const
<= operator
bool | operator< (const Tick &rhs) const
Less than operator (date and time only).
bool | operator<= (const DateTime &dateTime) const
virtual bool | operator<= (const Tick &rhs) const
Less than or equal operator (date and time only).
bool | operator== (const DateTime &dateTime) const
== operator
bool | operator== (const Tick &rhs) const
Equality operator. Comparing date time only. Use Compare and CompareContent if content comapre is needed.
bool | operator> (const DateTime &dateTime) const
bool | operator> (const Tick &rhs) const
Greater than operator (date and time only).
bool | operator>= (const DateTime &dateTime) const
>= operator
bool | operator>= (const Tick &rhs) const
Greater than or equal operator (date and time only).
ACTIV_CONTENT_GATEWAY_API_COMMON_API
StatusCode 		ProcessSplit (const int sharesBefore, const int sharesAfter, const Rational::Denominator type)
split addjust
virtual
ACTIV_CONTENT_GATEWAY_API_COMMON_API
void 		Reset ()
Reset all values in the field set.
virtual
ACTIV_CONTENT_GATEWAY_API_COMMON_API
StatusCode 		Serialize (MessageBuilder &messageBuilder) const
Serialize the object into the supplied message builder.
ACTIV_CONTENT_GATEWAY_API_COMMON_API
StatusCode 		SetBuyerId (const IFieldType &field)
Set the buyerId.
ACTIV_CONTENT_GATEWAY_API_COMMON_API
StatusCode 		SetBuyerId (const char *pBuyerId, const size_t idLength)
Set the buyerId.
StatusCode | SetConditions (const IFieldType &field)
Set the conditions.
StatusCode | SetConditions (const byte_t *pConditions, const size_t conditionsLength)
Set the conditions.
StatusCode | SetDate (const Date &date)
Set the date.
StatusCode | SetDateTime (const Date &date, const Time &time)
Set the time.
StatusCode | SetDateTime (const DateTime &dateTime)
Set the date and time.
StatusCode | SetExchange (const std::string &exchange)
Set the exchange.
virtual
ACTIV_CONTENT_GATEWAY_API_COMMON_API
StatusCode 		SetField (const Feed::FieldId fieldId, const IFieldType &field)
Get a field.
void | SetOutOfSequence ()
check if this tick is out of sequence in terms of time
StatusCode | SetPrice (const IFieldType &field)
Set price.
StatusCode | SetPrice (const Rational &price)
Set the price.
ACTIV_CONTENT_GATEWAY_API_COMMON_API
StatusCode 		SetSellerId (const IFieldType &field)
Set the sellerId.
ACTIV_CONTENT_GATEWAY_API_COMMON_API
StatusCode 		SetSellerId (const char *pSellerId, const size_t idLength)
Set the sellerId.
StatusCode | SetSize (const uint32_t size)
Set the tick's size.
StatusCode | SetSize (const IFieldType &field)
Set size.
StatusCode | SetSize (const Rational &size)
Set the tick's size.
StatusCode | SetTickType (const TickType type)
Set the tick's type.
StatusCode | SetTime (const Time &time)
Set the time.
ACTIV_CONTENT_GATEWAY_API_COMMON_API
StatusCode 		SetTradeThroughExemptFlag (const char flag)
Set Trade through exempt flag.
StatusCode | SetUpdateId (const Feed::UpdateId updateId)
Set the sequence number of the tick.
ACTIV_CONTENT_GATEWAY_API_COMMON_API | Tick ()
Constructor.
virtual
ACTIV_CONTENT_GATEWAY_API_COMMON_API
std::string 		ToShortString (const std::string &deliminator=DEFAULT_STRING_FIELD_SEPARATER) const
Convert the object to a string. This one w/o date and updateId.
virtual
ACTIV_CONTENT_GATEWAY_API_COMMON_API
std::string 		ToString (const std::string &deliminator=DEFAULT_STRING_FIELD_SEPARATER) const
Convert the object to a string.
virtual
ACTIV_CONTENT_GATEWAY_API_COMMON_API 		~Tick ()
Destructor.

Static Public Member Functions

static
ACTIV_CONTENT_GATEWAY_API_COMMON_API
size_t 		GetMaxSerializedLength ()
Get the maximum serialized length.

Static Public Attributes

static const size_t | CONDITION_LENGTH = 4
static const byte_t | OPTIONAL_DATA_HAS_BUYER_ID = 0x01
static const byte_t | OPTIONAL_DATA_HAS_OTHER_LENGTH = 0x80
static const byte_t | OPTIONAL_DATA_HAS_SELLER_ID = 0x02
static const byte_t | OPTIONAL_DATA_HAS_TRADE_EXEPTION_FLAG = 0x04
static const byte_t | QUOTE_NO_CONDITION = 0x08
static const byte_t | QUOTE_SAME_CONDITION = 0x04
static const byte_t | QUOTE_SAME_EXCHANGE_BIT = 0x02
static const byte_t | TICK_CONDITION_LENGTH_MASK = 0x70
static const byte_t | TICK_DAY_MASK = 0x1F
static const byte_t | TICK_KNOWN_EXCHANGE_BIT = 0x40
static const byte_t | TICK_OPTIONAL_DATA_BIT = 0x80
static const byte_t | TICK_OUT_SEQUENCE_MASK = 0x80
static const byte_t | TICK_SIZE_BYTE1 = 0x10
static const byte_t | TICK_SIZE_BYTE2 = 0x20
static const byte_t | TICK_TYPE_MASK = 0x0F
static const size_t | TRADER_ID_LENGTH = 4

Protected Attributes

char | m_buyerId [TRADER_ID_LENGTH]
buyer id
byte_t | m_conditions [CONDITION_LENGTH]
tick conditions.
DateTime m_dateTime
date of the tick.
std::string | m_exchange
exchange code.
bool | m_outSequence
if the time is out of sequence
Rational m_price
tick price.
char | m_sellerId [TRADER_ID_LENGTH]
seller id
Rational m_size
size.
TickType | m_tickType
tick type.
char | m_tradeThroughExemptFlag
trade through exempt flag
Feed::UpdateId | m_updateId
sequence number of the tick.

Friends

class | TimeSeries::TickBlockHelper

Detailed Description

Tick Field Set class.

Definition at line 70 of file Tick.h.

Member Function Documentation

StatusCode Activ::ContentPlatform::ContentGatewayApi::Tick::Compare | ( | const Tick & | rhs,
 |  | int & | result |
 | ) |  |  | const [inline, virtual]

Compare dateTime only.

Parameters:
rhs | the object to compare with.
result | the result of the comparison. 0 date time is the same. 1 date time is later than rhs's. -1 date time is earlier than rhs's
Return values:
STATUS_CODE_SUCCESS
...

Definition at line 754 of file Tick.h.

References Activ::DateTime::Compare(), and m_dateTime.

StatusCode Activ::ContentPlatform::ContentGatewayApi::Tick::Compare | ( | const DateTime & | dateTime,
 |  | int & | result |
 | ) |  |  | const [inline, virtual]

compares dateTime

Parameters:
dateTime the DateTime object to compare with.
result
Returns:
true if the same, otherwise false

Definition at line 747 of file Tick.h.

References Activ::DateTime::Compare(), and m_dateTime.

bool Activ::ContentPlatform::ContentGatewayApi::Tick::Compare ( const Tick & rhs ) const [inline, virtual]

Compare content and time to see if a match for cancel is found (NOTE millisecond part is not compared).

Parameters:
rhs the object to compare with.
Returns:
true if the same, otherwise false

Definition at line 761 of file Tick.h.

References CompareContentOnly(), Activ::Time::Get(), Activ::DateTime::GetDate(), Activ::DateTime::GetTime(), and m_dateTime.

bool Activ::ContentPlatform::ContentGatewayApi::Tick::CompareContentOnly ( const Tick & rhs ) const [inline, virtual]

compares all fields except tick type and datetime.

Parameters:
rhs the object to compare with.
Returns:
true if the same, otherwise false

Definition at line 770 of file Tick.h.

References m_exchange, m_price, and m_size.

Referenced by Compare().

virtual ACTIV_CONTENT_GATEWAY_API_COMMON_API StatusCode Activ::ContentPlatform::ContentGatewayApi::Tick::Deserialize ( MessageValidator & messageValidator ) [virtual]

Deserialize the object from the supplied message validator.

Parameters:
messageValidator the message validator from which the object will be extracted.
Return values:
STATUS_CODE_SUCCESS
...

Reimplemented from Activ::ContentPlatform::ContentGatewayApi::FieldSet.

virtual ACTIV_CONTENT_GATEWAY_API_COMMON_API StatusCode Activ::ContentPlatform::ContentGatewayApi::Tick::FromString | ( | const std::string & | inputStr,
 |  | const std::string & | deliminator = DEFAULT_STRING_FIELD_SEPARATER |
 | ) |  |  | [virtual]

Set the object value from a string.

Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
......

Reimplemented from Activ::ContentPlatform::ContentGatewayApi::FieldSet.

ACTIV_CONTENT_GATEWAY_API_COMMON_API StatusCode Activ::ContentPlatform::ContentGatewayApi::Tick::GetBuyerId | ( | char * | pBuyerId,
 |  | const size_t | idMaxLength,
 |  | size_t & | actualSize |
 | ) |  |  | const

Get the buyerId.

Parameters:
pBuyerId | id buffer provided by caller.
idMaxLength | max size can be copied to buffer.
actualSize | actual size copied.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

StatusCode Activ::ContentPlatform::ContentGatewayApi::Tick::GetConditions | ( | byte_t * | pConditions,
 |  | const size_t | conditionsLength,
 |  | size_t & | conditionsSize |
 | ) |  |  | const [inline]

Get the conditions.

Parameters:
pConditions | conditions buffer.
conditionsLength | size of conditions buffer.
conditionsSize | length of conditions.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 816 of file Tick.h.

References m_conditions.

StatusCode Activ::ContentPlatform::ContentGatewayApi::Tick::GetDateTime ( DateTime & dateTime ) const [inline]

Get the date and time.

Parameters:
dateTime the DateTime of the tick.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 927 of file Tick.h.

References m_dateTime.

const std::string & Activ::ContentPlatform::ContentGatewayApi::Tick::GetExchange ( ) const [inline]

Get the exchange.

Returns:
return the exchange of the tick.

Definition at line 897 of file Tick.h.

References m_exchange.

StatusCode Activ::ContentPlatform::ContentGatewayApi::Tick::GetExchange ( std::string & exchange ) const [inline]

Get the exchange.

Parameters:
exchange the exchange of the tick.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 889 of file Tick.h.

References m_exchange.

virtual ACTIV_CONTENT_GATEWAY_API_COMMON_API StatusCode Activ::ContentPlatform::ContentGatewayApi::Tick::GetField | ( | const Feed::FieldId | fieldId,
 |  | IFieldType & | field |
 | ) |  |  | const [virtual]

Get a field.

Parameters:
fieldId | field's id.
field | actual field.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FIELD
STATUS_CODE_UNDEFINED_FIELD

Reimplemented from Activ::ContentPlatform::ContentGatewayApi::FieldSet.

static ACTIV_CONTENT_GATEWAY_API_COMMON_API size_t Activ::ContentPlatform::ContentGatewayApi::Tick::GetMaxSerializedLength ( ) [static]

Get the maximum serialized length.

Returns:
the maximum serialized length.

Reimplemented from Activ::ContentPlatform::ContentGatewayApi::FieldSet.

Referenced by GetSerializedLength().

StatusCode Activ::ContentPlatform::ContentGatewayApi::Tick::GetPrice ( Rational & price ) const [inline]

Get the price as a 64 bit signed integer.

Returns:
price.

Definition at line 854 of file Tick.h.

References m_price.

StatusCode Activ::ContentPlatform::ContentGatewayApi::Tick::GetPrice ( double & price ) const [inline]

Get the price.

Parameters:
price the price of the tick.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 862 of file Tick.h.

References Activ::Rational::GetDouble(), and m_price.

ACTIV_CONTENT_GATEWAY_API_COMMON_API StatusCode Activ::ContentPlatform::ContentGatewayApi::Tick::GetSellerId | ( | char * | pSellerId,
 |  | const size_t | idMaxLength,
 |  | size_t & | actualSize |
 | ) |  |  | const

Get the sellerId.

Parameters:
pSellerId | id buffer provided by caller.
idMaxLength | max size can be copied to buffer.
actualSize | actual size copied.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

size_t Activ::ContentPlatform::ContentGatewayApi::Tick::GetSerializedLength ( ) const [inline, virtual]

Get the serialized length of the object.

Returns:
the serialized length of the object.

Reimplemented from Activ::ContentPlatform::ContentGatewayApi::FieldSet.

Definition at line 1064 of file Tick.h.

References GetMaxSerializedLength(), m_buyerId, m_sellerId, and m_tradeThroughExemptFlag.

StatusCode Activ::ContentPlatform::ContentGatewayApi::Tick::GetSize ( uint32_t & size ) const [inline]

Get the tick's size.

Parameters:
size the size of the tick.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 991 of file Tick.h.

References ACTIV_RETURN_RESULT_IF, Activ::Rational::GetDenominator(), Activ::Rational::GetDouble(), Activ::Rational::GetNumerator(), and m_size.

StatusCode Activ::ContentPlatform::ContentGatewayApi::Tick::GetSize ( Rational & size ) const [inline]

Get the tick's size.

Parameters:
size the size of the tick.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 964 of file Tick.h.

References m_size.

TickType Activ::ContentPlatform::ContentGatewayApi::Tick::GetTickType ( ) const [inline]

Get the tick's type.

Returns:
return the tick type.

Definition at line 912 of file Tick.h.

References m_tickType.

ACTIV_CONTENT_GATEWAY_API_COMMON_API char Activ::ContentPlatform::ContentGatewayApi::Tick::GetTradeThroughExemptFlag ( ) const

Get the Trade through exempt flag.

Return values:
flag as a char.

virtual ACTIV_CONTENT_GATEWAY_API_COMMON_API FieldSetType Activ::ContentPlatform::ContentGatewayApi::Tick::GetType ( ) const [virtual]

Get the field set type.

Returns:
the field set type.

Reimplemented from Activ::ContentPlatform::ContentGatewayApi::FieldSet.

StatusCode Activ::ContentPlatform::ContentGatewayApi::Tick::GetUpdateId ( Feed::UpdateId & updateId ) const [inline]

Get the sequence number of the tick.

Parameters:
updateId the sequence number of the tick.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 1013 of file Tick.h.

References m_updateId.

bool Activ::ContentPlatform::ContentGatewayApi::Tick::IsOutOfSequence ( ) const [inline]

check if this tick is out of sequence in terms of time

Return values:
true/false

Definition at line 1050 of file Tick.h.

References m_outSequence.

bool Activ::ContentPlatform::ContentGatewayApi::Tick::IsRegularHourTrade ( ) const [inline]

check if this tick is a regular hour trade

Return values:
true/false

Definition at line 1036 of file Tick.h.

References m_tickType.

bool Activ::ContentPlatform::ContentGatewayApi::Tick::IsTrade ( ) const [inline]

check if this tick is a trade

Return values:
true/false

Definition at line 1043 of file Tick.h.

References m_tickType.

bool Activ::ContentPlatform::ContentGatewayApi::Tick::operator!= ( const Tick & rhs ) const [inline]

Inequality operator. Comparing date time only.

Parameters:
rhs the object to compare with.
Returns:
the result of the test.

Definition at line 712 of file Tick.h.

References m_dateTime.

bool Activ::ContentPlatform::ContentGatewayApi::Tick::operator< ( const DateTime & dateTime ) const [inline]

<= operator

Parameters:
dateTime dateTime to compare
Return values:
true/false

Definition at line 781 of file Tick.h.

References m_dateTime.

bool Activ::ContentPlatform::ContentGatewayApi::Tick::operator< ( const Tick & rhs ) const [inline]

Less than operator (date and time only).

Parameters:
rhs the object to compare with.
Returns:
the result of the test.

Definition at line 719 of file Tick.h.

References m_dateTime.

bool Activ::ContentPlatform::ContentGatewayApi::Tick::operator<= ( const Tick & rhs ) const [inline, virtual]

Less than or equal operator (date and time only).

Parameters:
rhs the object to compare with.
Returns:
the result of the test.

Definition at line 726 of file Tick.h.

References m_dateTime.

bool Activ::ContentPlatform::ContentGatewayApi::Tick::operator== ( const DateTime & dateTime ) const [inline]

== operator

Parameters:
dateTime dateTime to compare
Return values:
true/false

Definition at line 795 of file Tick.h.

References m_dateTime.

bool Activ::ContentPlatform::ContentGatewayApi::Tick::operator== ( const Tick & rhs ) const [inline]

Equality operator. Comparing date time only. Use Compare and CompareContent if content comapre is needed.

Parameters:
rhs the object to compare with.
Returns:
the result of the test.

Definition at line 705 of file Tick.h.

bool Activ::ContentPlatform::ContentGatewayApi::Tick::operator> ( const Tick & rhs ) const [inline]

Greater than operator (date and time only).

Parameters:
rhs the object to compare with.
Returns:
the result of the test.

Definition at line 733 of file Tick.h.

References m_dateTime.

bool Activ::ContentPlatform::ContentGatewayApi::Tick::operator>= ( const DateTime & dateTime ) const [inline]

>= operator

Parameters:
dateTime dateTime to compare
Return values:
true/false

Definition at line 809 of file Tick.h.

References m_dateTime.

bool Activ::ContentPlatform::ContentGatewayApi::Tick::operator>= ( const Tick & rhs ) const [inline]

Greater than or equal operator (date and time only).

Parameters:
rhs the object to compare with.
Returns:
the result of the test.

Definition at line 740 of file Tick.h.

References m_dateTime.

ACTIV_CONTENT_GATEWAY_API_COMMON_API StatusCode Activ::ContentPlatform::ContentGatewayApi::Tick::ProcessSplit | ( | const int | sharesBefore,
 |  | const int | sharesAfter,
 |  | const Rational::Denominator | type
 | ) |  |

split addjust

Parameters:
sharesBefore | Shares before adjusting
sharesAfter | Shares after adjusting
type | the Rational::Denominator type
Return values:
STATUS_CODE_SUCCESS

Reimplemented from Activ::ContentPlatform::ContentGatewayApi::FieldSet.

virtual ACTIV_CONTENT_GATEWAY_API_COMMON_API StatusCode Activ::ContentPlatform::ContentGatewayApi::Tick::Serialize ( MessageBuilder & messageBuilder ) const [virtual]

Serialize the object into the supplied message builder.

Parameters:
messageBuilder the message builder to store a serialized version of the object in.
Return values:
STATUS_CODE_SUCCESS
...

Reimplemented from Activ::ContentPlatform::ContentGatewayApi::FieldSet.

ACTIV_CONTENT_GATEWAY_API_COMMON_API StatusCode Activ::ContentPlatform::ContentGatewayApi::Tick::SetBuyerId ( const IFieldType & field )

Set the buyerId.

Parameters:
field field data
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

ACTIV_CONTENT_GATEWAY_API_COMMON_API StatusCode Activ::ContentPlatform::ContentGatewayApi::Tick::SetBuyerId | ( | const char * | pBuyerId,
 |  | const size_t | idLength
 | ) |  |

Set the buyerId.

Parameters:
pBuyerId | buyer id.
idLength | length of id.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

StatusCode Activ::ContentPlatform::ContentGatewayApi::Tick::SetConditions ( const IFieldType & field ) [inline]

Set the conditions.

Parameters:
field field data
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 840 of file Tick.h.

References Activ::IFieldType::GetType(), and SetConditions().

StatusCode Activ::ContentPlatform::ContentGatewayApi::Tick::SetConditions | ( | const byte_t * | pConditions,
 |  | const size_t | conditionsLength |
 | ) |  |  | [inline]

Set the conditions.

Parameters:
pConditions | conditions buffer.
conditionsLength | length of conditions.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 828 of file Tick.h.

References m_conditions.

Referenced by SetConditions().

StatusCode Activ::ContentPlatform::ContentGatewayApi::Tick::SetDate ( const Date & date ) [inline]

Set the date.

Parameters:
date the Date of the tick.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 950 of file Tick.h.

References Activ::DateTime::GetTime(), m_dateTime, and Activ::DateTime::Set().

StatusCode Activ::ContentPlatform::ContentGatewayApi::Tick::SetDateTime | ( | const Date & | date,
 |  | const Time & | time |
 | ) |  |  | [inline]

Set the time.

Parameters:
date | the Date of the tick
time | the Time of the tick.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 943 of file Tick.h.

References m_dateTime, and Activ::DateTime::Set().

StatusCode Activ::ContentPlatform::ContentGatewayApi::Tick::SetDateTime ( const DateTime & dateTime ) [inline]

Set the date and time.

Parameters:
dateTime the DateTime of the tick.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 935 of file Tick.h.

References m_dateTime.

StatusCode Activ::ContentPlatform::ContentGatewayApi::Tick::SetExchange ( const std::string & exchange ) [inline]

Set the exchange.

Parameters:
exchange the exchange of the tick.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 904 of file Tick.h.

References m_exchange.

virtual ACTIV_CONTENT_GATEWAY_API_COMMON_API StatusCode Activ::ContentPlatform::ContentGatewayApi::Tick::SetField | ( | const Feed::FieldId | fieldId,
 |  | const IFieldType & | field |
 | ) |  |  | [virtual]

Get a field.

Parameters:
fieldId | field's id.
field | actual field.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FIELD
STATUS_CODE_UNDEFINED_FIELD

Reimplemented from Activ::ContentPlatform::ContentGatewayApi::FieldSet.

void Activ::ContentPlatform::ContentGatewayApi::Tick::SetOutOfSequence ( ) [inline]

check if this tick is out of sequence in terms of time

Return values:
true/false

Definition at line 1057 of file Tick.h.

References m_outSequence.

StatusCode Activ::ContentPlatform::ContentGatewayApi::Tick::SetPrice ( const IFieldType & field ) [inline]

Set price.

Parameters:
field field data
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 877 of file Tick.h.

References Activ::IFieldType::GetType(), and SetPrice().

StatusCode Activ::ContentPlatform::ContentGatewayApi::Tick::SetPrice ( const Rational & price ) [inline]

Set the price.

Parameters:
price the price of the tick.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 869 of file Tick.h.

References m_price.

Referenced by SetPrice().

ACTIV_CONTENT_GATEWAY_API_COMMON_API StatusCode Activ::ContentPlatform::ContentGatewayApi::Tick::SetSellerId ( const IFieldType & field )

Set the sellerId.

Parameters:
field field data
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

ACTIV_CONTENT_GATEWAY_API_COMMON_API StatusCode Activ::ContentPlatform::ContentGatewayApi::Tick::SetSellerId | ( | const char * | pSellerId,
 |  | const size_t | idLength
 | ) |  |

Set the sellerId.

Parameters:
pSellerId | seller id.
idLength | length of id.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

StatusCode Activ::ContentPlatform::ContentGatewayApi::Tick::SetSize ( const uint32_t size ) [inline]

Set the tick's size.

Parameters:
size the size of the tick.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 1006 of file Tick.h.

References m_size, and Activ::Rational::Set().

StatusCode Activ::ContentPlatform::ContentGatewayApi::Tick::SetSize ( const IFieldType & field ) [inline]

Set size.

Parameters:
field field data
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 980 of file Tick.h.

References Activ::IFieldType::GetType(), and SetSize().

StatusCode Activ::ContentPlatform::ContentGatewayApi::Tick::SetSize ( const Rational & size ) [inline]

Set the tick's size.

Parameters:
size the size of the tick.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 972 of file Tick.h.

References m_size.

Referenced by SetSize().

StatusCode Activ::ContentPlatform::ContentGatewayApi::Tick::SetTickType ( const TickType type ) [inline]

Set the tick's type.

Parameters:
type the tick's type.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 919 of file Tick.h.

References m_tickType.

StatusCode Activ::ContentPlatform::ContentGatewayApi::Tick::SetTime ( const Time & time ) [inline]

Set the time.

Parameters:
time the time of the tick.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 957 of file Tick.h.

References Activ::DateTime::GetDate(), m_dateTime, and Activ::DateTime::Set().

ACTIV_CONTENT_GATEWAY_API_COMMON_API StatusCode Activ::ContentPlatform::ContentGatewayApi::Tick::SetTradeThroughExemptFlag ( const char flag )

Set Trade through exempt flag.

Parameters:
flag the Trade through exempt flag
Return values:
STATUS_CODE_SUCCESS

StatusCode Activ::ContentPlatform::ContentGatewayApi::Tick::SetUpdateId ( const Feed::UpdateId updateId ) [inline]

Set the sequence number of the tick.

Parameters:
updateId the sequence number of the tick.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Definition at line 1028 of file Tick.h.

References m_updateId.

virtual ACTIV_CONTENT_GATEWAY_API_COMMON_API std::string Activ::ContentPlatform::ContentGatewayApi::Tick::ToShortString ( const std::string & deliminator = DEFAULT_STRING_FIELD_SEPARATER ) const [virtual]

Convert the object to a string. This one w/o date and updateId.

Returns:
the object as a string.

virtual ACTIV_CONTENT_GATEWAY_API_COMMON_API std::string Activ::ContentPlatform::ContentGatewayApi::Tick::ToString ( const std::string & deliminator = DEFAULT_STRING_FIELD_SEPARATER ) const [virtual]

Convert the object to a string.

Returns:
the object as a string.

Reimplemented from Activ::ContentPlatform::ContentGatewayApi::FieldSet.

Member Data Documentation

byte_t Activ::ContentPlatform::ContentGatewayApi::Tick::m_conditions[CONDITION_LENGTH] [protected]

tick conditions.

bid size is 1 byte

Definition at line 686 of file Tick.h.

Referenced by GetConditions(), and SetConditions().

const byte_t Activ::ContentPlatform::ContentGatewayApi::Tick::OPTIONAL_DATA_HAS_BUYER_ID = 0x01 [static]

share the same field with out of sequence, 5 bits

Definition at line 683 of file Tick.h.

const byte_t Activ::ContentPlatform::ContentGatewayApi::Tick::OPTIONAL_DATA_HAS_OTHER_LENGTH = 0x80 [static]

Trade through exemption falg bit

Definition at line 683 of file Tick.h.

const byte_t Activ::ContentPlatform::ContentGatewayApi::Tick::OPTIONAL_DATA_HAS_SELLER_ID = 0x02 [static]

buyer/bid center id bit

Definition at line 683 of file Tick.h.

const byte_t Activ::ContentPlatform::ContentGatewayApi::Tick::OPTIONAL_DATA_HAS_TRADE_EXEPTION_FLAG = 0x04 [static]

sellerr/ask center id bit

Definition at line 683 of file Tick.h.

const byte_t Activ::ContentPlatform::ContentGatewayApi::Tick::QUOTE_NO_CONDITION = 0x08 [static]

Bid and ask condition codes are the same

Definition at line 683 of file Tick.h.

const byte_t Activ::ContentPlatform::ContentGatewayApi::Tick::QUOTE_SAME_CONDITION = 0x04 [static]

note 0x01(OPTIONAL_DATA_HAS_BUYER_ID) is used. Quote is for bid and ask together. Exchange the same for bid and ask.

Definition at line 683 of file Tick.h.

const byte_t Activ::ContentPlatform::ContentGatewayApi::Tick::QUOTE_SAME_EXCHANGE_BIT = 0x02 [static]

if we need to add anything in the future we need to set this for back compatibility

Definition at line 683 of file Tick.h.

const byte_t Activ::ContentPlatform::ContentGatewayApi::Tick::TICK_CONDITION_LENGTH_MASK = 0x70 [static]

used to share flags with ticktype byte for serialized data, 4 bits

Definition at line 683 of file Tick.h.

const byte_t Activ::ContentPlatform::ContentGatewayApi::Tick::TICK_DAY_MASK = 0x1F [static]

Size is 2 bytes. in this case, the size is saved as bytes instead of rational

Definition at line 683 of file Tick.h.

const byte_t Activ::ContentPlatform::ContentGatewayApi::Tick::TICK_KNOWN_EXCHANGE_BIT = 0x40 [static]

share the same byte with day 1 bit

Definition at line 683 of file Tick.h.

const byte_t Activ::ContentPlatform::ContentGatewayApi::Tick::TICK_OPTIONAL_DATA_BIT = 0x80 [static]

share the same field with ticktype, 3 bit max of 7

Definition at line 683 of file Tick.h.

const byte_t Activ::ContentPlatform::ContentGatewayApi::Tick::TICK_OUT_SEQUENCE_MASK = 0x80 [static]

This is currently not set can be set in the future so we can add data

Definition at line 683 of file Tick.h.

const byte_t Activ::ContentPlatform::ContentGatewayApi::Tick::TICK_SIZE_BYTE1 = 0x10 [static]

has no bid condition

Definition at line 683 of file Tick.h.

const byte_t Activ::ContentPlatform::ContentGatewayApi::Tick::TICK_SIZE_BYTE2 = 0x20 [static]

sahre the same byte wtih day. If the exchnage is a known one, stored as just one byte 1 bit

Definition at line 683 of file Tick.h.

const byte_t Activ::ContentPlatform::ContentGatewayApi::Tick::TICK_TYPE_MASK = 0x0F [static]

bid size is 1 byte

Definition at line 683 of file Tick.h.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivContentGatewayApiCommon/Tick.h
Generated on Wed Oct 8 14:02:04 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::TimeSeriesCookie

Activ::ContentPlatform::ContentGatewayApi::TimeSeriesCookie Class Reference

Cookie passed between history manager and client for multi part requests. More...

#include <ActivContentPlatform/ActivContentGatewayApiCommon/TimeSeriesTypes.h>

List of all members.

Public Member Functions

ACTIV_CONTENT_GATEWAY_API_COMMON_API
StatusCode 		Deserialize (MessageValidator &messageValidator)
Deserialize.
ACTIV_CONTENT_GATEWAY_API_COMMON_API
const DataPointAddress & 		GetDataPointAddress () const
Get the data point address.
ACTIV_CONTENT_GATEWAY_API_COMMON_API
const SymbolId & 		GetSymbolId () const
Get the symbol.
ACTIV_CONTENT_GATEWAY_API_COMMON_API
StatusCode 		Serialize (MessageBuilder &messageBuilder) const
Serialize.

Public Attributes

DataPointAddress | m_dataPointAddress
TimeSeriesRequestParameters | m_requestParameters

Detailed Description

Cookie passed between history manager and client for multi part requests.

Definition at line 394 of file TimeSeriesTypes.h.

Member Function Documentation

ACTIV_CONTENT_GATEWAY_API_COMMON_API StatusCode Activ::ContentPlatform::ContentGatewayApi::TimeSeriesCookie::Deserialize ( MessageValidator & messageValidator )

Deserialize.

Parameters:
messageValidator message validator.
Return values:
STATUS_CODE_SUCCESS.
...

ACTIV_CONTENT_GATEWAY_API_COMMON_API const DataPointAddress& Activ::ContentPlatform::ContentGatewayApi::TimeSeriesCookie::GetDataPointAddress ( ) const

Get the data point address.

Returns:
Reference to the data point address.

ACTIV_CONTENT_GATEWAY_API_COMMON_API const SymbolId& Activ::ContentPlatform::ContentGatewayApi::TimeSeriesCookie::GetSymbolId ( ) const

Get the symbol.

Returns:
Reference to the symbol.

ACTIV_CONTENT_GATEWAY_API_COMMON_API StatusCode Activ::ContentPlatform::ContentGatewayApi::TimeSeriesCookie::Serialize ( MessageBuilder & messageBuilder ) const

Serialize.

Parameters:
messageBuilder
Return values:
STATUS_CODE_SUCCESS.
...

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivContentGatewayApiCommon/TimeSeriesTypes.h
Generated on Wed Oct 8 14:02:04 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestHelper

Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestHelper< FIRST_MESSAGE_TYPE_VALUE, NEXT_MESSAGE_TYPE_VALUE, FIELD_SET_TYPE > Class Template Reference

Time series helper class. More...

#include <ActivContentPlatform/ActivContentGatewayApi/TimeSeriesRequestHelper.h>

List of all members.

Public Types

typedef TimeSeriesRequestParameters RequestParameters
typedef
TimeSeriesResponseParametersTemplate
< FIELD_SET_TYPE > 		ResponseParameters

Static Public Member Functions

static
ACTIV_CONTENT_GATEWAY_API
StatusCode 		Deserialize (const ContentGatewayClient &client, const HeapMessage &response, TimeSeriesCookie &cookie, ResponseParameters &responseParameters)
Deserialize a time series response.
static
ACTIV_CONTENT_GATEWAY_API
StatusCode 		PostGetFirstRequest (const ContentGatewayClient &client, const RequestId &requestId, const RequestParameters &requestParameters)
Get time series asynchronously.
static
ACTIV_CONTENT_GATEWAY_API
StatusCode 		PostGetNextRequest (const ContentGatewayClient &client, const RequestId &requestId, const TimeSeriesCookie &cookie)
Get next time series asynchronously.
static
ACTIV_CONTENT_GATEWAY_API
StatusCode 		SendGetFirstRequest (const ContentGatewayClient &client, const RequestParameters &requestParameters, TimeSeriesCookie &cookie, ResponseParameters &responseParameters, const TimeoutPeriod timeoutPeriod=Port::defaultTimeout)
Get time series synchronously.
static
ACTIV_CONTENT_GATEWAY_API
StatusCode 		SendGetNextRequest (const ContentGatewayClient &client, TimeSeriesCookie &cookie, ResponseParameters &responseParameters, const TimeoutPeriod timeoutPeriod=Port::defaultTimeout)
Get next time series synchronously.

Detailed Description

template<MessageType FIRST_MESSAGE_TYPE_VALUE, MessageType NEXT_MESSAGE_TYPE_VALUE, typename FIELD_SET_TYPE>
class Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestHelper< FIRST_MESSAGE_TYPE_VALUE, NEXT_MESSAGE_TYPE_VALUE, FIELD_SET_TYPE >

Time series helper class.

Parameters:
FIRST_MESSAGE_TYPE_VALUE | type of message for get first requests.
NEXT_MESSAGE_TYPE_VALUE | type of message for get next requests.
FIELD_SET_TYPE | type of data returned.

Definition at line 35 of file TimeSeriesRequestHelper.h.

Member Function Documentation

template<MessageType FIRST_MESSAGE_TYPE_VALUE, MessageType NEXT_MESSAGE_TYPE_VALUE, typename FIELD_SET_TYPE>
static ACTIV_CONTENT_GATEWAY_API StatusCode Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestHelper< FIRST_MESSAGE_TYPE_VALUE, NEXT_MESSAGE_TYPE_VALUE, FIELD_SET_TYPE >::Deserialize | ( | const ContentGatewayClient & | client,
 |  | const HeapMessage & | response,
 |  | TimeSeriesCookie & | cookie,
 |  | ResponseParameters & | responseParameters |
 | ) |  |  | [static]

Deserialize a time series response.

Parameters:
client | reference to ContentGatewayClient.
response | HeapMessage as passed to ContentGatewayClient::On*Response() or returned by SyncRequestId::GetResponse().
cookie | reference to a TimeSeriesCookie object to receive deserialized cookie.
responseParameters | reference to a ResponseParameters object to receive deserialized response.
Return values:
STATUS_CODE_SUCCESS | response successfully deserialized
STATUS_CODE_UNRECOGNIZED | not a response of the correct type
... failed to deserialize response

template<MessageType FIRST_MESSAGE_TYPE_VALUE, MessageType NEXT_MESSAGE_TYPE_VALUE, typename FIELD_SET_TYPE>
static ACTIV_CONTENT_GATEWAY_API StatusCode Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestHelper< FIRST_MESSAGE_TYPE_VALUE, NEXT_MESSAGE_TYPE_VALUE, FIELD_SET_TYPE >::PostGetFirstRequest | ( | const ContentGatewayClient & | client,
 |  | const RequestId & | requestId,
 |  | const RequestParameters & | requestParameters |
 | ) |  |  | [static]

Get time series asynchronously.

Parameters:
client | reference to ContentGatewayClient.
requestId | RequestId object for the request.
requestParameters | RequestParameters object describing the request.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_CONNECTED
...

template<MessageType FIRST_MESSAGE_TYPE_VALUE, MessageType NEXT_MESSAGE_TYPE_VALUE, typename FIELD_SET_TYPE>
static ACTIV_CONTENT_GATEWAY_API StatusCode Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestHelper< FIRST_MESSAGE_TYPE_VALUE, NEXT_MESSAGE_TYPE_VALUE, FIELD_SET_TYPE >::PostGetNextRequest | ( | const ContentGatewayClient & | client,
 |  | const RequestId & | requestId,
 |  | const TimeSeriesCookie & | cookie |
 | ) |  |  | [static]

Get next time series asynchronously.

Parameters:
client | reference to ContentGatewayClient.
requestId | RequestId object for the request.
cookie | reference to a TimeSeriesCookie from a previous time series request.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_CONNECTED
...

template<MessageType FIRST_MESSAGE_TYPE_VALUE, MessageType NEXT_MESSAGE_TYPE_VALUE, typename FIELD_SET_TYPE>
static ACTIV_CONTENT_GATEWAY_API StatusCode Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestHelper< FIRST_MESSAGE_TYPE_VALUE, NEXT_MESSAGE_TYPE_VALUE, FIELD_SET_TYPE >::SendGetFirstRequest | ( | const ContentGatewayClient & | client,
 |  | const RequestParameters & | requestParameters,
 |  | TimeSeriesCookie & | cookie,
 |  | ResponseParameters & | responseParameters,
 |  | const TimeoutPeriod | timeoutPeriod = Port::defaultTimeout |
 | ) |  |  | [static]

Get time series synchronously.

Parameters:
client | reference to ContentGatewayClient.
requestParameters | parameters describing the request.
cookie | reference to a TimeSeriesCookie object to receive the cookie that can be used in a GetNext().
responseParameters | to receive the returned data.
timeoutPeriod | timeout in ms.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_CONNECTED
STATUS_CODE_TIMEOUT
...

template<MessageType FIRST_MESSAGE_TYPE_VALUE, MessageType NEXT_MESSAGE_TYPE_VALUE, typename FIELD_SET_TYPE>
static ACTIV_CONTENT_GATEWAY_API StatusCode Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestHelper< FIRST_MESSAGE_TYPE_VALUE, NEXT_MESSAGE_TYPE_VALUE, FIELD_SET_TYPE >::SendGetNextRequest | ( | const ContentGatewayClient & | client,
 |  | TimeSeriesCookie & | cookie,
 |  | ResponseParameters & | responseParameters,
 |  | const TimeoutPeriod | timeoutPeriod = Port::defaultTimeout |
 | ) |  |  | [static]

Get next time series synchronously.

Parameters:
client | reference to ContentGatewayClient.
cookie | reference to a TimeSeriesCookie object.
responseParameters | to receive the returned data.
timeoutPeriod | timeout in ms.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_CONNECTED
STATUS_CODE_TIMEOUT
...

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivContentGatewayApi/TimeSeriesRequestHelper.h
Generated on Wed Oct 8 14:02:04 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestParameters

Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestParameters Class Reference

Request parameters. More...

#include <ActivContentPlatform/ActivContentGatewayApiCommon/TimeSeriesTypes.h>

List of all members.

Public Types

typedef uint16_t | Flags
Request flags type.

Public Member Functions

ACTIV_CONTENT_GATEWAY_API_COMMON_API
void 		Clear ()
Clear down period list.
ACTIV_CONTENT_GATEWAY_API_COMMON_API
StatusCode 		Deserialize (MessageValidator &messageValidator)
Deserialize.
ACTIV_CONTENT_GATEWAY_API_COMMON_API
StatusCode 		Serialize (MessageBuilder &messageBuilder) const
Serialize.
ACTIV_CONTENT_GATEWAY_API_COMMON_API | TimeSeriesRequestParameters ()
Default constructor.

Public Attributes

uint8_t | m_delayPeriod
Delay in minutes.
FieldFilterType | m_fieldFilterType
Filter to apply to fields.
Flags m_flags
Request flags.
size_t | m_maxFieldSets
Max results to return in one response.
PeriodList | m_periodList
List of periods to apply to.
RecordFilterType | m_recordFilterType
Filter to apply to records.
SeriesType | m_seriesType
Series type.
uint8_t | m_specifiedInterval
for series type of INTRADAY_SERIES_TYPE_SPECIFIED_MINUTE only, valid values are 1, 2, 3, 5, 6, 10, 15, 30, 60
SymbolId m_symbolId
Symbol to request on.

Static Public Attributes

static const size_t | DEFAULT_MAX_FIELD_SETS = 1000
Default max number of results in one response.
static const Flags | FLAG_IGNORE_ALIAS = 0x0002
static const Flags | FLAG_NONE = 0x0000
static const Flags | FLAG_REVERSE = 0x0001

Detailed Description

Request parameters.

Definition at line 334 of file TimeSeriesTypes.h.

Member Typedef Documentation

typedef uint16_t Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestParameters::Flags

Request flags type.

Don't resolve alias

Definition at line 372 of file TimeSeriesTypes.h.

Member Function Documentation

ACTIV_CONTENT_GATEWAY_API_COMMON_API StatusCode Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestParameters::Deserialize ( MessageValidator & messageValidator )

Deserialize.

Parameters:
messageValidator message validator.
Return values:
STATUS_CODE_SUCCESS
...

ACTIV_CONTENT_GATEWAY_API_COMMON_API StatusCode Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestParameters::Serialize ( MessageBuilder & messageBuilder ) const

Serialize.

Parameters:
messageBuilder
Return values:
STATUS_CODE_SUCCESS.
...

Member Data Documentation

const size_t Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestParameters::DEFAULT_MAX_FIELD_SETS = 1000 [static]

Default max number of results in one response.

Don't resolve alias

Definition at line 375 of file TimeSeriesTypes.h.

const Flags Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestParameters::FLAG_IGNORE_ALIAS = 0x0002 [static]

Reverse series

Definition at line 373 of file TimeSeriesTypes.h.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivContentGatewayApiCommon/TimeSeriesTypes.h
Generated on Wed Oct 8 14:02:04 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::TimeSeriesResponseParametersTemplate

Activ::ContentPlatform::ContentGatewayApi::TimeSeriesResponseParametersTemplate< FIELD_SET_TYPE > Class Template Reference

Time series response parameters. More...

#include <ActivContentPlatform/ActivContentGatewayApiCommon/TimeSeriesTypes.h>

List of all members.

Public Types

typedef FIELD_SET_TYPE | FieldSetList
Field set list type.

Public Member Functions

ACTIV_CONTENT_GATEWAY_API_COMMON_API
void 		Clear ()
Clear down response field set list.
ACTIV_CONTENT_GATEWAY_API_COMMON_API
StatusCode 		Deserialize (MessageValidator &messageValidator)
Deserialize.
ACTIV_CONTENT_GATEWAY_API_COMMON_API
StatusCode 		Serialize (MessageBuilder &messageBuilder) const
Serialize.

Public Attributes

FieldSetList | m_fieldSetList

Detailed Description

template<typename FIELD_SET_TYPE>
class Activ::ContentPlatform::ContentGatewayApi::TimeSeriesResponseParametersTemplate< FIELD_SET_TYPE >

Time series response parameters.

Parameters:
FIELD_SET_TYPE type of result list.

Definition at line 445 of file TimeSeriesTypes.h.

Member Function Documentation

template<typename FIELD_SET_TYPE>
ACTIV_CONTENT_GATEWAY_API_COMMON_API StatusCode Activ::ContentPlatform::ContentGatewayApi::TimeSeriesResponseParametersTemplate< FIELD_SET_TYPE >::Deserialize ( MessageValidator & messageValidator )

Deserialize.

Parameters:
messageValidator message validator.
Return values:
STATUS_CODE_SUCCESS.
...

template<typename FIELD_SET_TYPE>
ACTIV_CONTENT_GATEWAY_API_COMMON_API StatusCode Activ::ContentPlatform::ContentGatewayApi::TimeSeriesResponseParametersTemplate< FIELD_SET_TYPE >::Serialize ( MessageBuilder & messageBuilder ) const

Serialize.

Parameters:
messageBuilder
Return values:
STATUS_CODE_SUCCESS.
...

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivContentGatewayApiCommon/TimeSeriesTypes.h
Generated on Wed Oct 8 14:02:04 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentServerApi::ContentServerClient

Activ::ContentPlatform::ContentServerApi::ContentServerClient Class Reference

Content server client class. More...

#include <ActivContentPlatform/ActivContentServerApi/ContentServerClient.h>

Inheritance diagram for Activ::ContentPlatform::ContentServerApi::ContentServerClient:

Activ::Component Activ::Port

List of all members.

Public Types

typedef std::list< MessageStats > | MessageStatsList
typedef std::list
< UpdateFilterMap > 		UpdateFilterMapList

Public Member Functions

ACTIV_CONTENT_SERVER_API StatusCode | AddUpdateFilter (const UpdateFilter &updateFilter, SubscriptionCookie &subscriptionCookie, const std::string &providerName="")
Add an update filter.
ACTIV_CONTENT_SERVER_API | ContentServerClient (Application &application, ManagedEndPoint &managedEndPoint, const Settings &settings, const std::string &componentLicenseId=defaultComponentId)
Constructor.
ACTIV_CONTENT_SERVER_API const
ApiInfo 		GetApiInfo () const
Return information about the API.
ACTIV_CONTENT_SERVER_API const
MessageStatsList 		GetMessageStatsList () const
Get the list of message statistics for each feed.
ACTIV_CONTENT_SERVER_API const
Feed::PermissionInfo 		GetPermissionInfo () const
Get the permission information.
ACTIV_CONTENT_SERVER_API const
MessageStats 		GetTotalMessageStats () const
Get the total message statistics from each feed.
ACTIV_CONTENT_SERVER_API const
UpdateFilterMapList 		GetUpdateFilterMapList () const
Get the list of update filter maps for each feed.
ACTIV_CONTENT_SERVER_API bool | IsUserLoggedOn () const
Is user logged on.
ACTIV_CONTENT_SERVER_API void | Logoff ()
Logoff from the server (i.e. no longer process the updates).
ACTIV_CONTENT_SERVER_API StatusCode | Logon (const std::string &userId, const std::string &password)
Attempt to process the logon and begin receiving updates.
virtual
ACTIV_CONTENT_SERVER_API void 		OnFlush (const std::string &providerName)
Called on receiving the end of packet.
virtual
ACTIV_CONTENT_SERVER_API
StatusCode 		OnRecordUpdate (const std::string &providerName, RecordUpdate &recordUpdate)
Called on receiving a symbol record update.
virtual
ACTIV_CONTENT_SERVER_API
StatusCode 		OnSymbolRecordUpdate (const std::string &providerName, SymbolRecordUpdate &symbolRecordUpdate)
Called on receiving a record update.
ACTIV_CONTENT_SERVER_API StatusCode | RemoveUpdateFilter (const SubscriptionCookie subscriptionCookie)
Remove an update filter.
virtual ACTIV_CONTENT_SERVER_API | ~ContentServerClient ()
Destructor.

Protected Member Functions

ACTIV_CONTENT_SERVER_API StatusCode | OnTimer (const Address &timerAddress, const BaseTime &time)
Timer callback.

Friends

class | ContentServerOutput
class | FieldListValidator

Classes

class | ApiInfo
Information returned from GetApiInfo(). More...
class | MessageStats
message stats class. More...
class | Settings
Settings for ContentServerClient class. More...
class | UpdateFilter
Update Filter. More...
class | UpdateFilterMap
Update filter map class. More...

Detailed Description

Content server client class.

Definition at line 38 of file ContentServerClient.h.

Constructor & Destructor Documentation

ACTIV_CONTENT_SERVER_API Activ::ContentPlatform::ContentServerApi::ContentServerClient::ContentServerClient | ( | Application & | application,
 |  | ManagedEndPoint & | managedEndPoint,
 |  | const Settings & | settings,
 |  | const std::string & | componentLicenseId = defaultComponentId
 | ) |  |

Constructor.

Parameters:
application | reference to an application.
managedEndPoint | endpoint to attach to.
settings | settings.
componentLicenseId | component license id.
Exceptions:
Exception.

Member Function Documentation

ACTIV_CONTENT_SERVER_API StatusCode Activ::ContentPlatform::ContentServerApi::ContentServerClient::AddUpdateFilter | ( | const UpdateFilter & | updateFilter,
 |  | SubscriptionCookie & | subscriptionCookie,
 |  | const std::string & | providerName = ""
 | ) |  |

Add an update filter.

Parameters:
updateFilter | the update filter.
subscriptionCookie | the subscription cookie.
providerName | the name of the feed to filter on (default of empty will filter on all feeds).
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_ALREADY_EXISTS

ACTIV_CONTENT_SERVER_API const ApiInfo Activ::ContentPlatform::ContentServerApi::ContentServerClient::GetApiInfo ( ) const

Return information about the API.

Returns:
The api information.

ACTIV_CONTENT_SERVER_API const MessageStatsList Activ::ContentPlatform::ContentServerApi::ContentServerClient::GetMessageStatsList ( ) const

Get the list of message statistics for each feed.

Returns:
The message statistics list.

ACTIV_CONTENT_SERVER_API const Feed::PermissionInfo Activ::ContentPlatform::ContentServerApi::ContentServerClient::GetPermissionInfo ( ) const

Get the permission information.

Returns:
The permission information.

ACTIV_CONTENT_SERVER_API const MessageStats Activ::ContentPlatform::ContentServerApi::ContentServerClient::GetTotalMessageStats ( ) const

Get the total message statistics from each feed.

Returns:
The total message statistics.

ACTIV_CONTENT_SERVER_API const UpdateFilterMapList Activ::ContentPlatform::ContentServerApi::ContentServerClient::GetUpdateFilterMapList ( ) const

Get the list of update filter maps for each feed.

Returns:
The filter map list.

ACTIV_CONTENT_SERVER_API bool Activ::ContentPlatform::ContentServerApi::ContentServerClient::IsUserLoggedOn ( ) const

Is user logged on.

Returns:
Whether the user is logged on.

ACTIV_CONTENT_SERVER_API StatusCode Activ::ContentPlatform::ContentServerApi::ContentServerClient::Logon | ( | const std::string & | userId,
 |  | const std::string & | password
 | ) |  |

Attempt to process the logon and begin receiving updates.

Parameters:
userId | the user id.
password | the password.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_ALREADY_CONNECTED
STATUS_CODE_INVALID_USER
STATUS_CODE_INVALID_PASSWORD
STATUS_CODE_OUT_OF_RANGE
STATUS_CODE_EXPIRED
...

virtual ACTIV_CONTENT_SERVER_API void Activ::ContentPlatform::ContentServerApi::ContentServerClient::OnFlush ( const std::string & providerName ) [virtual]

Called on receiving the end of packet.

This method indicates that an end of packet has been received.

Parameters:
providerName the provider name.

virtual ACTIV_CONTENT_SERVER_API StatusCode Activ::ContentPlatform::ContentServerApi::ContentServerClient::OnRecordUpdate | ( | const std::string & | providerName,
 |  | RecordUpdate & | recordUpdate |
 | ) |  |  | [virtual]

Called on receiving a symbol record update.

The message can be deserialized using PermissionFieldListValidator::Initialize() or ApplyUpdate().

Parameters:
providerName | the provider name.
recordUpdate | the object containg the symbol record update data.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_IGNORED
...

virtual ACTIV_CONTENT_SERVER_API StatusCode Activ::ContentPlatform::ContentServerApi::ContentServerClient::OnSymbolRecordUpdate | ( | const std::string & | providerName,
 |  | SymbolRecordUpdate & | symbolRecordUpdate |
 | ) |  |  | [virtual]

Called on receiving a record update.

The message can be deserialized using PermissionFieldListValidator::Initialize() or ApplyUpdate().

Parameters:
providerName | the provider name.
symbolRecordUpdate | the object containg the record update data.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_IGNORED
...

ACTIV_CONTENT_SERVER_API StatusCode Activ::ContentPlatform::ContentServerApi::ContentServerClient::OnTimer | ( | const Address & | timerAddress,
 |  | const BaseTime & | time |
 | ) |  |  | [protected, virtual]

Timer callback.

When overriding, please call the base class version for any unrecognized timer.

Parameters:
timerAddress | the timer address.
time | the date/time of the timer.
Returns:
The return value is not used by the framework, but may be used by an application to pass values between parent and sub class versions of this function. Returns STATUS_CODE_UNRECOGNIZED by default.

Reimplemented from Activ::Component.

ACTIV_CONTENT_SERVER_API StatusCode Activ::ContentPlatform::ContentServerApi::ContentServerClient::RemoveUpdateFilter ( const SubscriptionCookie subscriptionCookie )

Remove an update filter.

Parameters:
subscriptionCookie the subscription cookie to remove.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_FOUND

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivContentServerApi/ContentServerClient.h
Generated on Wed Oct 8 14:02:04 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentServerApi::ContentServerClient::ApiInfo

Activ::ContentPlatform::ContentServerApi::ContentServerClient::ApiInfo Class Reference

Information returned from GetApiInfo(). More...

#include <ActivContentPlatform/ActivContentServerApi/ContentServerClient.h>

List of all members.

Public Attributes

std::string | m_buildConfiguration
Build configuration, e.g. x86_win32_vc71_mdi.
std::string | m_buildDateTime
Date and time api was built.
std::string | m_version
Version.

Detailed Description

Information returned from GetApiInfo().

Definition at line 80 of file ContentServerClient.h.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivContentServerApi/ContentServerClient.h
Generated on Wed Oct 8 14:02:04 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentServerApi::ContentServerClient::MessageStats

Activ::ContentPlatform::ContentServerApi::ContentServerClient::MessageStats Class Reference

message stats class. More...

#include <ActivContentPlatform/ActivContentServerApi/ContentServerClient.h>

List of all members.

Public Member Functions

ACTIV_CONTENT_SERVER_API | MessageStats ()
Default constructor.

Public Attributes

std::string | m_name
Name of the feed handler.
uint32_t | m_receivedUpdateCount
Number of received messages.
uint32_t | m_totalErrorCount
Total failed to process from the number received.
uint32_t | m_totalIgnoredCount
Total ingored from the number received.
uint32_t | m_totalProcessedCount
Total processed from the number received.
uint32_t | m_unrecognizedUpdateCount
Number of unrecognised messages.

Detailed Description

message stats class.

Definition at line 91 of file ContentServerClient.h.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivContentServerApi/ContentServerClient.h
Generated on Wed Oct 8 14:02:04 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentServerApi::ContentServerClient::Settings

Activ::ContentPlatform::ContentServerApi::ContentServerClient::Settings Class Reference

Settings for ContentServerClient class. More...

#include <ActivContentPlatform/ActivContentServerApi/ContentServerClient.h>

List of all members.

Public Member Functions

ACTIV_CONTENT_SERVER_API StatusCode | Read (const IniFileParser::ConstSectionIterator &sectionIterator)
Read settings from an ini file section.
ACTIV_CONTENT_SERVER_API | Settings ()
Default constructor.
ACTIV_CONTENT_SERVER_API | ~Settings ()
Destructor.

Public Attributes

boost::shared_ptr< Private > | m_pPrivateSettings
Time m_resetTime
The reset time.
std::string | m_tableTemplateServiceId
The table template service id.

Detailed Description

Settings for ContentServerClient class.

Definition at line 44 of file ContentServerClient.h.

Member Function Documentation

ACTIV_CONTENT_SERVER_API StatusCode Activ::ContentPlatform::ContentServerApi::ContentServerClient::Settings::Read ( const IniFileParser::ConstSectionIterator & sectionIterator )

Read settings from an ini file section.

Parameters:
sectionIterator iterator to an ini file section.
Return values:
STATUS_CODE_SUCCESS
...

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivContentServerApi/ContentServerClient.h
Generated on Wed Oct 8 14:02:04 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentServerApi::ContentServerClient::UpdateFilter

Activ::ContentPlatform::ContentServerApi::ContentServerClient::UpdateFilter Class Reference

Update Filter. More...

#include <ActivContentPlatform/ActivContentServerApi/ContentServerClient.h>

List of all members.

Public Types

typedef std::vector
< Feed::EventType > 		EventTypeList
The event type list type.
typedef std::vector< std::string > SymbolPatternList
The symbol pattern list type.
typedef std::vector
< Feed::TableNo > 		TableNumberList
The table number list type.

Public Attributes

EventTypeList m_eventTypeList
The event type list.
SymbolPatternList m_symbolPatternList
The symbol pattern list.
TableNumberList m_tableNumberList
The table number list.

Detailed Description

Update Filter.

Definition at line 112 of file ContentServerClient.h.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivContentServerApi/ContentServerClient.h
Generated on Wed Oct 8 14:02:04 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentServerApi::ContentServerClient::UpdateFilterMap

Activ::ContentPlatform::ContentServerApi::ContentServerClient::UpdateFilterMap Class Reference

Update filter map class. More...

#include <ActivContentPlatform/ActivContentServerApi/ContentServerClient.h>

List of all members.

Public Attributes

std::string m_name
Name of the feed handler.
std::map< SubscriptionCookie,
UpdateFilter > 		m_updateFilterMap
The update filter map.

Detailed Description

Update filter map class.

Definition at line 127 of file ContentServerClient.h.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivContentServerApi/ContentServerClient.h
Generated on Wed Oct 8 14:02:04 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentServerApi::FieldListValidator

Activ::ContentPlatform::ContentServerApi::FieldListValidator Class Reference

Field list validator class. More...

#include <ActivContentPlatform/ActivContentServerApi/FieldListValidator.h>

Inheritance diagram for Activ::ContentPlatform::ContentServerApi::FieldListValidator:

Activ::ContentPlatform::FeedApi::FieldListValidator

List of all members.

Public Member Functions

ACTIV_CONTENT_SERVER_API StatusCode | ApplyUpdate (Feed::BaseUpdateMessageValidator &baseUpdateMessageValidator)
Apply fields to this.
ACTIV_CONTENT_SERVER_API StatusCode | ApplyUpdate (RecordUpdate &recordUpdate)
Apply fields to this.
ACTIV_CONTENT_SERVER_API StatusCode | ApplyUpdate (SymbolRecordUpdate &symbolRecordUpdate)
Apply fields to this.
ACTIV_CONTENT_SERVER_API | FieldListValidator (ContentServerClient &contentServerClient, RecordUpdate &recordUpdate)
Constructor.
ACTIV_CONTENT_SERVER_API | FieldListValidator (ContentServerClient &contentServerClient, SymbolRecordUpdate &symbolRecordUpdate)
Constructor.
ACTIV_CONTENT_SERVER_API | FieldListValidator (const FieldListValidator &rhs)
Copy constructor.
ACTIV_CONTENT_SERVER_API | FieldListValidator (ContentServerClient &contentServerClient)
Constructor.
ACTIV_CONTENT_SERVER_API StatusCode | Initialize (RecordUpdate &recordUpdate)
Initialize.
ACTIV_CONTENT_SERVER_API StatusCode | Initialize (SymbolRecordUpdate &symbolRecordUpdate)
Initialize.

Detailed Description

Field list validator class.

Note this class is not thread safe. Do not make concurrent calls to its methods from multiple threads.

Definition at line 43 of file FieldListValidator.h.

Constructor & Destructor Documentation

ACTIV_CONTENT_SERVER_API Activ::ContentPlatform::ContentServerApi::FieldListValidator::FieldListValidator ( ContentServerClient & contentServerClient )

Constructor.

Parameters:
contentServerClient reference to the content server client.

ACTIV_CONTENT_SERVER_API Activ::ContentPlatform::ContentServerApi::FieldListValidator::FieldListValidator ( const FieldListValidator & rhs )

Copy constructor.

Parameters:
rhs the value to assign to this object.

ACTIV_CONTENT_SERVER_API Activ::ContentPlatform::ContentServerApi::FieldListValidator::FieldListValidator | ( | ContentServerClient & | contentServerClient,
 |  | SymbolRecordUpdate & | symbolRecordUpdate
 | ) |  |

Constructor.

Parameters:
contentServerClient | reference to the content server client.
symbolRecordUpdate | object containing serialized field data.
Exceptions:
StatusCodeException.

ACTIV_CONTENT_SERVER_API Activ::ContentPlatform::ContentServerApi::FieldListValidator::FieldListValidator | ( | ContentServerClient & | contentServerClient,
 |  | RecordUpdate & | recordUpdate
 | ) |  |

Constructor.

Parameters:
contentServerClient | reference to the content server client.
recordUpdate | object containing serialized field data.
Exceptions:
StatusCodeException.

Member Function Documentation

ACTIV_CONTENT_SERVER_API StatusCode Activ::ContentPlatform::ContentServerApi::FieldListValidator::ApplyUpdate ( Feed::BaseUpdateMessageValidator & baseUpdateMessageValidator )

Apply fields to this.

This call differs from an Initialize() call in that existing fields are not cleared. Note fields in fieldData that have the rule RULE_DOES_NOT_UPDATE_LAST_VALUE will not be applied to this.

Parameters:
baseUpdateMessageValidator object containing serialized field data.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT
STATUS_CODE_HEAP_EMPTY
...

ACTIV_CONTENT_SERVER_API StatusCode Activ::ContentPlatform::ContentServerApi::FieldListValidator::ApplyUpdate ( RecordUpdate & recordUpdate )

Apply fields to this.

This call differs from an Initialize() call in that existing fields are not cleared. Note fields in fieldData that have the rule RULE_DOES_NOT_UPDATE_LAST_VALUE will not be applied to this.

Parameters:
recordUpdate object containing serialized field data.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT
STATUS_CODE_HEAP_EMPTY
...

ACTIV_CONTENT_SERVER_API StatusCode Activ::ContentPlatform::ContentServerApi::FieldListValidator::ApplyUpdate ( SymbolRecordUpdate & symbolRecordUpdate )

Apply fields to this.

This call differs from an Initialize() call in that existing fields are not cleared. Note fields in fieldData that have the rule RULE_DOES_NOT_UPDATE_LAST_VALUE will not be applied to this.

Parameters:
symbolRecordUpdate object containing serialized field data.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT
STATUS_CODE_HEAP_EMPTY
...

ACTIV_CONTENT_SERVER_API StatusCode Activ::ContentPlatform::ContentServerApi::FieldListValidator::Initialize ( RecordUpdate & recordUpdate )

Initialize.

This call clears any fields currently in this object. New fields are then added from the fieldData object.

Parameters:
recordUpdate object containing serialized field data.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT
...

ACTIV_CONTENT_SERVER_API StatusCode Activ::ContentPlatform::ContentServerApi::FieldListValidator::Initialize ( SymbolRecordUpdate & symbolRecordUpdate )

Initialize.

This call clears any fields currently in this object. New fields are then added from the fieldData object.

Parameters:
symbolRecordUpdate object containing serialized field data.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT
...

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivContentServerApi/FieldListValidator.h
Generated on Wed Oct 8 14:02:04 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentServerApi::RecordUpdate

Activ::ContentPlatform::ContentServerApi::RecordUpdate Class Reference

Record update class. More...

#include <ActivContentPlatform/ActivContentServerApi/RecordUpdateHelper.h>

Inheritance diagram for Activ::ContentPlatform::ContentServerApi::RecordUpdate:

Activ::ContentPlatform::ContentServerApi::RecordUpdateHelper< Feed::UpdateMessageValidator >

List of all members.

Public Types

typedef
KeyFieldList::const_iterator 		ConstKeyFieldIterator
Const iterator to key field.
typedef std::pair
< Feed::FieldId, IFieldType * > 		KeyField
The key field type definition.
typedef std::vector< KeyField > | KeyFieldList
The key field list type definition.

Public Member Functions

ACTIV_CONTENT_SERVER_API
ConstKeyFieldIterator 		BeginKeyField () const
Get an iterator to the first key field in the message.
ACTIV_CONTENT_SERVER_API
ConstKeyFieldIterator 		EndKeyField () const
Get an iterator that points to beyond the last key field in the message.
ACTIV_CONTENT_SERVER_API
Feed::IndexNumber 		GetIndexNumber () const
Get the index number.
ACTIV_CONTENT_SERVER_API size_t | GetNumberOfKeyFields () const
Get the number of key fields.
RecordUpdate (Feed::UpdateMessageValidator &updateMessageValidator)
Constructor.

Detailed Description

Record update class.

Definition at line 147 of file RecordUpdateHelper.h.

Constructor & Destructor Documentation

Activ::ContentPlatform::ContentServerApi::RecordUpdate::RecordUpdate ( Feed::UpdateMessageValidator & updateMessageValidator )

Constructor.

Parameters:
updateMessageValidator reference to the update message validator.

Member Function Documentation

ACTIV_CONTENT_SERVER_API ConstKeyFieldIterator Activ::ContentPlatform::ContentServerApi::RecordUpdate::BeginKeyField ( ) const

Get an iterator to the first key field in the message.

Returns:
an iterator object.

ACTIV_CONTENT_SERVER_API ConstKeyFieldIterator Activ::ContentPlatform::ContentServerApi::RecordUpdate::EndKeyField ( ) const

Get an iterator that points to beyond the last key field in the message.

Returns:
an iterator object.

ACTIV_CONTENT_SERVER_API Feed::IndexNumber Activ::ContentPlatform::ContentServerApi::RecordUpdate::GetIndexNumber ( ) const

Get the index number.

Returns:
The index number.

ACTIV_CONTENT_SERVER_API size_t Activ::ContentPlatform::ContentServerApi::RecordUpdate::GetNumberOfKeyFields ( ) const

Get the number of key fields.

Returns:
The number of key fields in the update.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivContentServerApi/RecordUpdateHelper.h
Generated on Wed Oct 8 14:02:04 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentServerApi::RecordUpdateHelper

Activ::ContentPlatform::ContentServerApi::RecordUpdateHelper< MESSAGE_VALIDATOR > Class Template Reference

Record update helper class. More...

#include <ActivContentPlatform/ActivContentServerApi/RecordUpdateHelper.h>

List of all members.

Public Member Functions

ACTIV_CONTENT_SERVER_API
Feed::EventType 		GetEventType () const
Get the event type.
ACTIV_CONTENT_SERVER_API
Feed::PermissionId 		GetPermissionId () const
Get the permission id.
ACTIV_CONTENT_SERVER_API
Feed::TableNo 		GetTableNumber () const
Get the table number.
ACTIV_CONTENT_SERVER_API
Feed::UpdateId 		GetUpdateId () const
Get the update id.
ACTIV_CONTENT_SERVER_API bool | IsDelete () const
Is this a delete message?
ACTIV_CONTENT_SERVER_API bool | IsNewRecord () const
Is this a new record?
ACTIV_CONTENT_SERVER_API bool | IsRefresh () const
Is this a refresh message?
ACTIV_CONTENT_SERVER_API bool | IsStale () const
Is this a stale message?
ACTIV_CONTENT_SERVER_API | RecordUpdateHelper (MESSAGE_VALIDATOR &messageValidator)
Constructor.

Protected Attributes

MESSAGE_VALIDATOR & | m_messageValidator

Friends

class | FieldListValidator

Detailed Description

template<typename MESSAGE_VALIDATOR>
class Activ::ContentPlatform::ContentServerApi::RecordUpdateHelper< MESSAGE_VALIDATOR >

Record update helper class.

Definition at line 41 of file RecordUpdateHelper.h.

Constructor & Destructor Documentation

template<typename MESSAGE_VALIDATOR>
ACTIV_CONTENT_SERVER_API Activ::ContentPlatform::ContentServerApi::RecordUpdateHelper< MESSAGE_VALIDATOR >::RecordUpdateHelper ( MESSAGE_VALIDATOR & messageValidator )

Constructor.

Parameters:
messageValidator reference to the message validator.

Member Function Documentation

template<typename MESSAGE_VALIDATOR>
ACTIV_CONTENT_SERVER_API Feed::EventType Activ::ContentPlatform::ContentServerApi::RecordUpdateHelper< MESSAGE_VALIDATOR >::GetEventType ( ) const

Get the event type.

Returns:
The event type.

template<typename MESSAGE_VALIDATOR>
ACTIV_CONTENT_SERVER_API Feed::PermissionId Activ::ContentPlatform::ContentServerApi::RecordUpdateHelper< MESSAGE_VALIDATOR >::GetPermissionId ( ) const

Get the permission id.

Returns:
The permission id.

template<typename MESSAGE_VALIDATOR>
ACTIV_CONTENT_SERVER_API Feed::TableNo Activ::ContentPlatform::ContentServerApi::RecordUpdateHelper< MESSAGE_VALIDATOR >::GetTableNumber ( ) const

Get the table number.

Returns:
The table number.

template<typename MESSAGE_VALIDATOR>
ACTIV_CONTENT_SERVER_API Feed::UpdateId Activ::ContentPlatform::ContentServerApi::RecordUpdateHelper< MESSAGE_VALIDATOR >::GetUpdateId ( ) const

Get the update id.

Returns:
The update id.

template<typename MESSAGE_VALIDATOR>
ACTIV_CONTENT_SERVER_API bool Activ::ContentPlatform::ContentServerApi::RecordUpdateHelper< MESSAGE_VALIDATOR >::IsDelete ( ) const

Is this a delete message?

Returns:
whether this is a delete message.

template<typename MESSAGE_VALIDATOR>
ACTIV_CONTENT_SERVER_API bool Activ::ContentPlatform::ContentServerApi::RecordUpdateHelper< MESSAGE_VALIDATOR >::IsNewRecord ( ) const

Is this a new record?

Returns:
whether this is a new record.

template<typename MESSAGE_VALIDATOR>
ACTIV_CONTENT_SERVER_API bool Activ::ContentPlatform::ContentServerApi::RecordUpdateHelper< MESSAGE_VALIDATOR >::IsRefresh ( ) const

Is this a refresh message?

Returns:
whether this is a refresh message.

template<typename MESSAGE_VALIDATOR>
ACTIV_CONTENT_SERVER_API bool Activ::ContentPlatform::ContentServerApi::RecordUpdateHelper< MESSAGE_VALIDATOR >::IsStale ( ) const

Is this a stale message?

Returns:
whether this is a stale message.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivContentServerApi/RecordUpdateHelper.h
Generated on Wed Oct 8 14:02:04 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentServerApi::SymbolRecordUpdate

Activ::ContentPlatform::ContentServerApi::SymbolRecordUpdate Class Reference

Symbol record update class. More...

#include <ActivContentPlatform/ActivContentServerApi/RecordUpdateHelper.h>

Inheritance diagram for Activ::ContentPlatform::ContentServerApi::SymbolRecordUpdate:

Activ::ContentPlatform::ContentServerApi::RecordUpdateHelper< Feed::BaseUpdateMessageValidator >

List of all members.

Public Member Functions

ACTIV_CONTENT_SERVER_API const
std::string & 		GetSymbol () const
Get the symbol.
SymbolRecordUpdate (Feed::BaseUpdateMessageValidator &baseUpdateMessageValidator, const std::string &symbol)
Constructor.

Detailed Description

Symbol record update class.

Definition at line 119 of file RecordUpdateHelper.h.

Constructor & Destructor Documentation

Activ::ContentPlatform::ContentServerApi::SymbolRecordUpdate::SymbolRecordUpdate | ( | Feed::BaseUpdateMessageValidator & | baseUpdateMessageValidator,
 |  | const std::string & | symbol
 | ) |  |

Constructor.

Parameters:
baseUpdateMessageValidator | reference to the base update message validator.
symbol | reference to the symbol.

Member Function Documentation

ACTIV_CONTENT_SERVER_API const std::string& Activ::ContentPlatform::ContentServerApi::SymbolRecordUpdate::GetSymbol ( ) const

Get the symbol.

Returns:
A reference to the symbol.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivContentServerApi/RecordUpdateHelper.h
Generated on Wed Oct 8 14:02:04 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient

Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient Class Reference

Contribution gateway client class. More...

#include <ActivContentPlatform/ActivContributionGatewayApi/ContributionGatewayClient.h>

Inheritance diagram for Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient:

Activ::Component Activ::Port

List of all members.

Public Types

typedef PublishRequestHelper
< CONTRIBUTION_GATEWAY_REQUEST_PUBLISH_RECORD,
PublishRecordParameters,
PublishRecordResponseParameters > 		PublishRecord
typedef PublishRequestHelper
< CONTRIBUTION_GATEWAY_REQUEST_PUBLISH_SYMBOL_RECORD,
PublishSymbolRecordParameters,
PublishRecordResponseParameters > 		PublishSymbolRecord
enum | State { ACTIV_DECLARE_ELEMENT_1_WITH_COMMA }
Enumeration of client states.

Public Member Functions

ACTIV_CONTRIBUTION_GATEWAY_API
StatusCode 		Connect (const ConnectParameters &connectParameters, const TimeoutPeriod timeoutPeriod=Port::defaultTimeout)
Connect to a contribution gateway.
ACTIV_CONTRIBUTION_GATEWAY_API | ContributionGatewayClient (Application &application, ManagedEndPoint &managedEndPoint, const Settings &settings=Settings(), const std::string &componentId=defaultComponentId)
Constructor.
ACTIV_CONTRIBUTION_GATEWAY_API
StatusCode 		Disconnect ()
Disconnect from a content gateway.
ACTIV_CONTRIBUTION_GATEWAY_API
ApiInfo 		GetApiInfo () const
Return information about the API.
ACTIV_CONTRIBUTION_GATEWAY_API
StatusCode 		GetContributionGatewayInfo (ContributionGatewayInfo &contributionGatewayInfo) const
Get information about the ContributionGateway the API is connected to.
ACTIV_CONTRIBUTION_GATEWAY_API
StatusCode 		GetPermissionInfo (PermissionInfo &permissionInfo) const
Get information about permisions.
ACTIV_CONTRIBUTION_GATEWAY_API
std::string 		GetServiceLocation () const
Return the url of the service we are connected, or connecting, to.
ACTIV_CONTRIBUTION_GATEWAY_API
State 		GetState () const
Get connection state.
virtual
ACTIV_CONTRIBUTION_GATEWAY_API 		~ContributionGatewayClient ()
Destructor.

Static Public Member Functions

static bool | IsValidResponse (const HeapMessage &response)
Check if received response message is valid (complete or partially complete).
static
ACTIV_CONTRIBUTION_GATEWAY_API
std::string 		StateToString (const State state)
Convert client state to a string representation.

Protected Member Functions

virtual
ACTIV_CONTRIBUTION_GATEWAY_API
StatusCode 		OnBreak (HeapMessage &breakMessage)
A circuit has broken under our feet.
virtual
ACTIV_CONTRIBUTION_GATEWAY_API
StatusCode 		OnConnect (HeapMessage &connectMessage)
A circuit has been established.
virtual
ACTIV_CONTRIBUTION_GATEWAY_API
StatusCode 		OnConnectFailed (HeapMessage &connectFailMessage)
A circuit has failed to connect.
virtual
ACTIV_CONTRIBUTION_GATEWAY_API
StatusCode 		OnDisconnect (HeapMessage &disconnectMessage)
A circuit has been closed after an asynchronous Disconnect() call.
virtual
ACTIV_CONTRIBUTION_GATEWAY_API
StatusCode 		OnMessage (HeapMessage &message)
Message callback.
virtual
ACTIV_CONTRIBUTION_GATEWAY_API
void 		OnPublishRecordResponse (HeapMessage &update)
virtual
ACTIV_CONTRIBUTION_GATEWAY_API
void 		OnPublishSymbolRecordResponse (HeapMessage &update)
virtual
ACTIV_CONTRIBUTION_GATEWAY_API
void 		OnReportMessage (const std::string &reportMessage)
Callback on report message from gateway.
virtual
ACTIV_CONTRIBUTION_GATEWAY_API
StatusCode 		OnResponse (HeapMessage &response)
Response callback.
virtual
ACTIV_CONTRIBUTION_GATEWAY_API
StatusCode 		OnTimer (const Address &timerAddress, const BaseTime &time)
Timer callback.

Classes

class | ApiInfo
Information returned from GetApiInfo(). More...
class | ConnectParameters
Parameters for Connect(). More...
class | Settings
Settings for ContributionGatewayClient class. More...

Detailed Description

Contribution gateway client class.

Definition at line 27 of file ContributionGatewayClient.h.

Constructor & Destructor Documentation

ACTIV_CONTRIBUTION_GATEWAY_API Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::ContributionGatewayClient | ( | Application & | application,
 |  | ManagedEndPoint & | managedEndPoint,
 |  | const Settings & | settings = Settings(),
 |  | const std::string & | componentId = defaultComponentId
 | ) |  |

Constructor.

Parameters:
application | reference to an application.
managedEndPoint | endpoint to attach to.
settings | settings.
componentId | component id.
Exceptions:
Exception.

Member Function Documentation

ACTIV_CONTRIBUTION_GATEWAY_API StatusCode Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::Connect | ( | const ConnectParameters & | connectParameters,
 |  | const TimeoutPeriod | timeoutPeriod = Port::defaultTimeout
 | ) |  |

Connect to a contribution gateway.

Parameters:
connectParameters | connection parameters.
timeoutPeriod | timeout in ms. A timeout of 0 implies an asynchronous connect.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_WRONG_STATE | client must be in state STATE_INITIALIZED in order to connect
STATUS_CODE_INVALID_USER | unknown user id
STATUS_CODE_INVALID_PASSWORD | incorrect password for user id
STATUS_CODE_IN_USE | provided user id is already logged on

ACTIV_CONTRIBUTION_GATEWAY_API StatusCode Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::Disconnect ( )

Disconnect from a content gateway.

A disconnect is always asynchronous, as data from the current connection may be queued up on the endpoint. An OnDisconnect() callback will be invoked when the connection is fully cleaned up, UNLESS the connection has broken already, in which case an OnBreak() will be invoked, and not OnDisconnect().

Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_CONNECTED

ACTIV_CONTRIBUTION_GATEWAY_API ApiInfo Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::GetApiInfo ( ) const

Return information about the API.

Returns:
The api information.

ACTIV_CONTRIBUTION_GATEWAY_API StatusCode Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::GetContributionGatewayInfo ( ContributionGatewayInfo & contributionGatewayInfo ) const

Get information about the ContributionGateway the API is connected to.

Parameters:
contributionGatewayInfo to receive info about the ContributionGateway.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_CONNECTED
...

ACTIV_CONTRIBUTION_GATEWAY_API StatusCode Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::GetPermissionInfo ( PermissionInfo & permissionInfo ) const

Get information about permisions.

Parameters:
permissionInfo to receive info about the user's permissions.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_CONNECTED
...

ACTIV_CONTRIBUTION_GATEWAY_API std::string Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::GetServiceLocation ( ) const

Return the url of the service we are connected, or connecting, to.

Returns:
The service url.

ACTIV_CONTRIBUTION_GATEWAY_API State Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::GetState ( ) const

Get connection state.

Returns:
Connection state.

bool Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::IsValidResponse ( const HeapMessage & response ) [inline, static]

Check if received response message is valid (complete or partially complete).

Parameters:
response HeapMessage containing a serialized response.
Returns:
true if this is a valid response.

Definition at line 264 of file ContributionGatewayClient.h.

References Activ::HeapMessage::GetStatusCode().

virtual ACTIV_CONTRIBUTION_GATEWAY_API StatusCode Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::OnBreak ( HeapMessage & breakMessage ) [protected, virtual]

A circuit has broken under our feet.

When overriding, please call the base class version for any unrecognized circuit.

Parameters:
breakMessage the address of the circuit that is now not connected is breakMessage.GetSourceAddress(). A reason for the break can be found in breakMessage.GetStatusCode().
Returns:
The return value is not used by the framework, but may be used by an application to pass values between parent and sub class versions of this function. Returns STATUS_CODE_UNRECOGNIZED by default.

Reimplemented from Activ::Component.

virtual ACTIV_CONTRIBUTION_GATEWAY_API StatusCode Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::OnConnect ( HeapMessage & connectMessage ) [protected, virtual]

A circuit has been established.

When overriding, please call the base class version for any unrecognized circuit.

This is called for a successful asynchronous connection. connectMessage.GetSourceAddress() is the circuit that has established.

The message may contain response data from an user data that was sent in the circuit establishment, if the underlying protocol supports it.

For example, if this is the result of an asynchronous OpenService() call, ValidateOpenServiceResponse() should be called.

Parameters:
connectMessage
Returns:
The return value is not used by the framework, but may be used by an application to pass values between parent and sub class versions of this function. Returns STATUS_CODE_UNRECOGNIZED by default.

Reimplemented from Activ::Component.

virtual ACTIV_CONTRIBUTION_GATEWAY_API StatusCode Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::OnConnectFailed ( HeapMessage & connectFailMessage ) [protected, virtual]

A circuit has failed to connect.

When overriding, please call the base class version for any unrecognized circuit.

The callback is for informational purposes only. If an asynchronous connection attempts fails, the OnConnectFailed() callback will be invoked but the router service will automatically attempt to connect again on a lazy basis until the circuit is Disconnect()ed. No OnConnectFailed() is called for a synchronous connect (the connect call will just timeout after the specified period with an error status code).

Parameters:
connectFailMessage the circuit that has failed to connect is connectFailMessage.GetSourceAddress(), a reason for the failed connect is connectFailMessage.GetStatusCode().
Returns:
The return value is not used by the framework, but may be used by an application to pass values between parent and sub class versions of this function. Returns STATUS_CODE_UNRECOGNIZED by default.

Reimplemented from Activ::Component.

virtual ACTIV_CONTRIBUTION_GATEWAY_API StatusCode Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::OnDisconnect ( HeapMessage & disconnectMessage ) [protected, virtual]

A circuit has been closed after an asynchronous Disconnect() call.

When overriding, please call the base class version for any unrecognized circuit.

This is called for a successful asynchronous disconnect completion. disconnectMessage.GetSourceAddress() is the circuit that has been established.

The message may contain response data from any user data that was sent in the disconnect, if the underlying protocol supports it.

Parameters:
disconnectMessage
Returns:
The return value is not used by the framework, but may be used by an application to pass values between parent and sub class versions of this function. Returns STATUS_CODE_UNRECOGNIZED by default.

Reimplemented from Activ::Component.

virtual ACTIV_CONTRIBUTION_GATEWAY_API StatusCode Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::OnMessage ( HeapMessage & message ) [protected, virtual]

Message callback.

If you override this method, please call the base class method for any unrecognized message types.

Parameters:
message the message.
Return values:
STATUS_CODE_SUCCESS | the message was recognized.
STATUS_CODE_UNRECOGNIZED | the message was not recognized.
STATUS_CODE_THREAD_EXIT | received a thread-die message.
...

Reimplemented from Activ::Component.

virtual ACTIV_CONTRIBUTION_GATEWAY_API void Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::OnReportMessage ( const std::string & reportMessage ) [protected, virtual]

Callback on report message from gateway.

Parameters:
reportMessage message from gateway.

virtual ACTIV_CONTRIBUTION_GATEWAY_API StatusCode Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::OnResponse ( HeapMessage & response ) [protected, virtual]

Response callback.

If you override this method, please call the base class method for any unrecognized request types.

Parameters:
response the response message.
Return values:
STATUS_CODE_SUCCESS | the message was recognized.
STATUS_CODE_UNRECOGNIZED | the message was not recognized.
STATUS_CODE_THREAD_EXIT | received a thread-die message.
...

Reimplemented from Activ::Port.

virtual ACTIV_CONTRIBUTION_GATEWAY_API StatusCode Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::OnTimer | ( | const Address & | timerAddress,
 |  | const BaseTime & | time |
 | ) |  |  | [protected, virtual]

Timer callback.

When overriding, please call the base class version for any unrecognized timer.

Parameters:
timerAddress | the timer address.
time | the date/time of the timer.
Returns:
The return value is not used by the framework, but may be used by an application to pass values between parent and sub class versions of this function. Returns STATUS_CODE_UNRECOGNIZED by default.

Reimplemented from Activ::Component.

static ACTIV_CONTRIBUTION_GATEWAY_API std::string Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::StateToString ( const State state ) [static]

Convert client state to a string representation.

Parameters:
state a client state.
Returns:
String representation of state.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivContributionGatewayApi/ContributionGatewayClient.h
Generated on Wed Oct 8 14:02:04 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::ApiInfo

Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::ApiInfo Class Reference

Information returned from GetApiInfo(). More...

#include <ActivContentPlatform/ActivContributionGatewayApi/ContributionGatewayClient.h>

List of all members.

Public Attributes

std::string | m_buildConfiguration
Build configuration, e.g. x86_win32_vc71_mdi.
std::string | m_buildDateTime
Date and time api was built.
std::string | m_version
Version.

Detailed Description

Information returned from GetApiInfo().

Definition at line 122 of file ContributionGatewayClient.h.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivContributionGatewayApi/ContributionGatewayClient.h
Generated on Wed Oct 8 14:02:04 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::ConnectParameters

Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::ConnectParameters Class Reference

Parameters for Connect(). More...

#include <ActivContentPlatform/ActivContributionGatewayApi/ContributionGatewayClient.h>

List of all members.

Public Types

enum | Policy { ACTIV_DECLARE_VALUE_WITH_COMMA }

Public Member Functions

ACTIV_CONTRIBUTION_GATEWAY_API | ConnectParameters ()
Default constructor.

Public Attributes

AgentScope | m_agentScope
The agent scope to use when failing over.
std::string | m_attributeQuery
The attribute query to use when failing over.
uint16_t | m_failoverSeconds
Find alternative server after this number of seconds if connection down.
std::string | m_infoString
String to pass to the ContributionGateway for informational purposes.
std::string | m_password
Password.
Policy m_policy
Action to take on a connection break.
ServiceId m_serviceId
Id of service to connect to.
std::string | m_url
Url of service.
std::string | m_userId
User id.
UserType | m_userType
User type.

Static Public Attributes

static const uint16_t | DEFAULT_FAILOVER_SECONDS = 15

Detailed Description

Parameters for Connect().

Definition at line 83 of file ContributionGatewayClient.h.

Member Enumeration Documentation

enum Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::ConnectParameters::Policy

Attempt to connect to a randomly chosen gateway

Enumerator:
ACTIV_DECLARE_VALUE_WITH_COMMA The policies.

The number of policies.

Definition at line 94 of file ContributionGatewayClient.h.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivContributionGatewayApi/ContributionGatewayClient.h
Generated on Wed Oct 8 14:02:04 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::Settings

Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::Settings Class Reference

Settings for ContributionGatewayClient class. More...

#include <ActivContentPlatform/ActivContributionGatewayApi/ContributionGatewayClient.h>

List of all members.

Public Member Functions

ACTIV_CONTRIBUTION_GATEWAY_API | Settings ()
Default constructor.
ACTIV_CONTRIBUTION_GATEWAY_API | ~Settings ()
Destructor.

Public Attributes

bool | m_createMutex
Client methods to be called from multiple threads.
IHeap::BucketInfoVector m_heapBucketInfoVector
Size of heap to use for client.
IHeap * m_pHeap
Heap to use for messaging.

Detailed Description

Settings for ContributionGatewayClient class.

Definition at line 55 of file ContributionGatewayClient.h.

Constructor & Destructor Documentation

ACTIV_CONTRIBUTION_GATEWAY_API Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::Settings::Settings ( )

Default constructor.

Default settings are: m_createMutex true m_heapBucketInfoVector see ACTIV_CONTENT_GATEWAY_CLIENT_DEFAULT_HEAP_SIZE m_pHeap 0 (create a heap of size m_heapBucketInfoVector). Set to non 0 to override.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivContributionGatewayApi/ContributionGatewayClient.h
Generated on Wed Oct 8 14:02:04 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayInfo

Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayInfo Class Reference

Information about the ContributionGateway. More...

#include <ActivContentPlatform/ActivContributionGatewayApiCommon/Types.h>

List of all members.

Public Attributes

ISystem::SystemInfo m_systemInfo
info about the PG machine

Detailed Description

Information about the ContributionGateway.

Definition at line 82 of file Types.h.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivContributionGatewayApiCommon/Types.h
Generated on Wed Oct 8 14:02:05 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayResponseParameters

Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayResponseParameters Class Reference

Base response parameters. More...

#include <ActivContentPlatform/ActivContributionGatewayApiCommon/PublishTypes.h>

Inheritance diagram for Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayResponseParameters:

Activ::ContentPlatform::ContributionGatewayApi::PublishRecordResponseParameters

List of all members.

Public Types

typedef uint8_t | Status
Status type.

Static Public Member Functions

static
ACTIV_CONTRIBUTION_GATEWAY_API_COMMON_API
std::string 		StatusToString (const Status status)
Return string representation of a response status.

Public Attributes

Status m_status
status

Static Public Attributes

static const Status | STATUS_FAILURE = 2
static const Status | STATUS_FAILURE_WITH_ERRORS = 3
static const Status | STATUS_INVALID_TABLE = 4
static const Status | STATUS_NOT_PERMISSIONED = 5
static const Status | STATUS_SUCCESS = 0
Status code constants.
static const Status | STATUS_SUCCESS_WITH_ERRORS = 1

Detailed Description

Base response parameters.

Definition at line 269 of file PublishTypes.h.

Member Function Documentation

static ACTIV_CONTRIBUTION_GATEWAY_API_COMMON_API std::string Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayResponseParameters::StatusToString ( const Status status ) [static]

Return string representation of a response status.

Parameters:
status value to convert.
Returns:
String representation of status.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivContributionGatewayApiCommon/PublishTypes.h
Generated on Wed Oct 8 14:02:05 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContributionGatewayApi::PermissionInfo

Activ::ContentPlatform::ContributionGatewayApi::PermissionInfo Class Reference

Information about users permissioning. More...

#include <ActivContentPlatform/ActivContributionGatewayApiCommon/Types.h>

List of all members.

Public Types

typedef std::list< std::string > | ExchangeCodeList
typedef uint8_t | Flags
flags type

Public Attributes

ExchangeCodeList | m_exchangeCodeList
Flags | m_flags
Feed::PermissionIdList | m_permissionIdList
Feed::TableNoList | m_tableNumberList

Static Public Attributes

static const Flags | FLAG_ALL_EXCHANGE_CODES = 0x04
static const Flags | FLAG_ALL_PERMISSION_IDS = 0x01
static const Flags | FLAG_ALL_TABLE_NUMBERS = 0x02
static const Flags | FLAG_NONE = 0x00

Detailed Description

Information about users permissioning.

Definition at line 96 of file Types.h.

Member Data Documentation

const Flags Activ::ContentPlatform::ContributionGatewayApi::PermissionInfo::FLAG_ALL_EXCHANGE_CODES = 0x04 [static]

All table numbers

Definition at line 108 of file Types.h.

const Flags Activ::ContentPlatform::ContributionGatewayApi::PermissionInfo::FLAG_ALL_TABLE_NUMBERS = 0x02 [static]

All permision ids

Definition at line 108 of file Types.h.

const Flags Activ::ContentPlatform::ContributionGatewayApi::PermissionInfo::FLAG_NONE = 0x00 [static]

All exchange codes

Definition at line 108 of file Types.h.

Feed::PermissionIdList Activ::ContentPlatform::ContributionGatewayApi::PermissionInfo::m_permissionIdList

All exchange codes

Definition at line 110 of file Types.h.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivContributionGatewayApiCommon/Types.h
Generated on Wed Oct 8 14:02:05 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContributionGatewayApi::PublishField

Activ::ContentPlatform::ContributionGatewayApi::PublishField Class Reference

Publish field class. More...

#include <ActivContentPlatform/ActivContributionGatewayApiCommon/PublishTypes.h>

Inheritance diagram for Activ::ContentPlatform::ContributionGatewayApi::PublishField:

Activ::ContentPlatform::ContributionGatewayApi::PublishSymbolRecordParameters::Field

List of all members.

Public Member Functions

ACTIV_CONTRIBUTION_GATEWAY_API_COMMON_API
const IFieldType * 		GetFieldContents () const
Get the IFieldType object.
ACTIV_CONTRIBUTION_GATEWAY_API_COMMON_API | PublishField (Feed::FieldId fieldId, IFieldType *pIFieldType)
Constructor.
ACTIV_CONTRIBUTION_GATEWAY_API_COMMON_API | PublishField ()
Default constructor.
ACTIV_CONTRIBUTION_GATEWAY_API_COMMON_API
StatusCode 		SetFieldContents (IFieldType *pIFieldType)
Set the IFieldType object.

Public Attributes

Feed::FieldId | m_fieldId
field id

Detailed Description

Publish field class.

Definition at line 40 of file PublishTypes.h.

Constructor & Destructor Documentation

ACTIV_CONTRIBUTION_GATEWAY_API_COMMON_API Activ::ContentPlatform::ContributionGatewayApi::PublishField::PublishField | ( | Feed::FieldId | fieldId,
 |  | IFieldType * | pIFieldType
 | ) |  |

Constructor.

Parameters:
fieldId
pIFieldType

Member Function Documentation

ACTIV_CONTRIBUTION_GATEWAY_API_COMMON_API const IFieldType* Activ::ContentPlatform::ContributionGatewayApi::PublishField::GetFieldContents ( ) const

Get the IFieldType object.

Returns:
pIFieldType.

ACTIV_CONTRIBUTION_GATEWAY_API_COMMON_API StatusCode Activ::ContentPlatform::ContributionGatewayApi::PublishField::SetFieldContents ( IFieldType * pIFieldType )

Set the IFieldType object.

Parameters:
pIFieldType

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivContributionGatewayApiCommon/PublishTypes.h
Generated on Wed Oct 8 14:02:05 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContributionGatewayApi::PublishRecordBaseParameters

Activ::ContentPlatform::ContributionGatewayApi::PublishRecordBaseParameters Class Reference

Base parameters for publishing a record. More...

#include <ActivContentPlatform/ActivContributionGatewayApiCommon/PublishTypes.h>

Inheritance diagram for Activ::ContentPlatform::ContributionGatewayApi::PublishRecordBaseParameters:

Activ::ContentPlatform::ContributionGatewayApi::PublishRecordParameters Activ::ContentPlatform::ContributionGatewayApi::PublishSymbolRecordParameters

List of all members.

Public Types

typedef uint8_t | Flags
flags type

Public Member Functions

ACTIV_CONTRIBUTION_GATEWAY_API_COMMON_API | PublishRecordBaseParameters (Feed::TableNo tableNumber, Feed::EventType eventType, Feed::PermissionId permissionId, Flags flags, Feed::UpdateId updateId)
Constructor.
ACTIV_CONTRIBUTION_GATEWAY_API_COMMON_API | PublishRecordBaseParameters ()
Default constructor.

Public Attributes

Feed::EventType | m_eventType
Flags | m_flags
Feed::PermissionId | m_permissionId
Feed::TableNo | m_tableNumber
Feed::UpdateId | m_updateId

Static Public Attributes

static const Flags | FLAG_BEST_EFFORT = 0x01
static const Flags | FLAG_DELETE = 0x02
static const Flags | FLAG_NONE = 0x00

Detailed Description

Base parameters for publishing a record.

Definition at line 86 of file PublishTypes.h.

Member Data Documentation

const Flags Activ::ContentPlatform::ContributionGatewayApi::PublishRecordBaseParameters::FLAG_DELETE = 0x02 [static]

Perform 'best effort' contribution

Definition at line 107 of file PublishTypes.h.

const Flags Activ::ContentPlatform::ContributionGatewayApi::PublishRecordBaseParameters::FLAG_NONE = 0x00 [static]

Delete the record

Definition at line 107 of file PublishTypes.h.

Feed::TableNo Activ::ContentPlatform::ContributionGatewayApi::PublishRecordBaseParameters::m_tableNumber

Delete the record

Definition at line 109 of file PublishTypes.h.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivContributionGatewayApiCommon/PublishTypes.h
Generated on Wed Oct 8 14:02:05 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContributionGatewayApi::PublishRecordParameters

Activ::ContentPlatform::ContributionGatewayApi::PublishRecordParameters Class Reference

Parameters for publishing a record. More...

#include <ActivContentPlatform/ActivContributionGatewayApiCommon/PublishTypes.h>

Inheritance diagram for Activ::ContentPlatform::ContributionGatewayApi::PublishRecordParameters:

Activ::ContentPlatform::ContributionGatewayApi::PublishRecordBaseParameters

List of all members.

Public Types

typedef std::vector< PublishField > | FieldList

Public Member Functions

ACTIV_CONTRIBUTION_GATEWAY_API_COMMON_API | PublishRecordParameters (Feed::TableNo tableNumber, Feed::EventType eventType, Feed::PermissionId permissionId, Flags flags, Feed::UpdateId updateId=Feed::UPDATE_ID_COUNT_UNKNOWN)
Constructor.
ACTIV_CONTRIBUTION_GATEWAY_API_COMMON_API | PublishRecordParameters ()
Default constructor.

Public Attributes

FieldList | m_fieldList
The list of fields in this update.
uint8_t | m_indexNumber
The index number of this record update.
FieldList | m_keyFieldList
The list of key fields in the index of this record, must be in the same order as the table.

Detailed Description

Parameters for publishing a record.

Definition at line 237 of file PublishTypes.h.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivContributionGatewayApiCommon/PublishTypes.h
Generated on Wed Oct 8 14:02:05 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContributionGatewayApi::PublishRecordResponseParameters

Activ::ContentPlatform::ContributionGatewayApi::PublishRecordResponseParameters Class Reference

Response parameters from a publish request. More...

#include <ActivContentPlatform/ActivContributionGatewayApiCommon/PublishTypes.h>

Inheritance diagram for Activ::ContentPlatform::ContributionGatewayApi::PublishRecordResponseParameters:

Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayResponseParameters

List of all members.

Public Types

typedef std::vector< FieldError > | FieldErrorList

Public Attributes

FieldErrorList | m_fieldErrorList
List of field errors.

Classes

class | FieldError
Field error class. More...

Detailed Description

Response parameters from a publish request.

Definition at line 315 of file PublishTypes.h.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivContributionGatewayApiCommon/PublishTypes.h
Generated on Wed Oct 8 14:02:05 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContributionGatewayApi::PublishRecordResponseParameters::FieldError

Activ::ContentPlatform::ContributionGatewayApi::PublishRecordResponseParameters::FieldError Class Reference

Field error class. More...

#include <ActivContentPlatform/ActivContributionGatewayApiCommon/PublishTypes.h>

List of all members.

Public Types

typedef uint8_t | FieldStatus

Static Public Member Functions

static
ACTIV_CONTRIBUTION_GATEWAY_API_COMMON_API
std::string 		FieldStatusToString (const FieldStatus fieldStatus)
Return string representation of a response status.

Public Attributes

Feed::FieldId | m_fieldId
FieldStatus | m_fieldStatus

Static Public Attributes

static const FieldStatus | FIELD_STATUS_FAILURE = 3
static const FieldStatus | FIELD_STATUS_INVALID_LENGTH = 1
static const FieldStatus | FIELD_STATUS_INVALID_TYPE = 0
Status code constants.
static const FieldStatus | FIELD_STATUS_NOT_FOUND = 2
static const FieldStatus | FIELD_STATUS_NOT_PERMISSIONED = 4

Detailed Description

Field error class.

Definition at line 321 of file PublishTypes.h.

Member Function Documentation

static ACTIV_CONTRIBUTION_GATEWAY_API_COMMON_API std::string Activ::ContentPlatform::ContributionGatewayApi::PublishRecordResponseParameters::FieldError::FieldStatusToString ( const FieldStatus fieldStatus ) [static]

Return string representation of a response status.

Parameters:
fieldStatus value to convert.
Returns:
String representation of status.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivContributionGatewayApiCommon/PublishTypes.h
Generated on Wed Oct 8 14:02:05 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContributionGatewayApi::PublishRequestHelper

Activ::ContentPlatform::ContributionGatewayApi::PublishRequestHelper< MESSAGE_TYPE_VALUE, REQUEST_PARAMETERS, RESPONSE_PARAMETERS > Class Template Reference

Publish request helper class. More...

#include <ActivContentPlatform/ActivContributionGatewayApi/PublishRequestHelper.h>

List of all members.

Public Types

typedef REQUEST_PARAMETERS | RequestParameters
Request paramters type.
typedef RESPONSE_PARAMETERS | ResponseParameters
Response parameters type.

Static Public Member Functions

static
ACTIV_CONTRIBUTION_GATEWAY_API
StatusCode 		Deserialize (const ContributionGatewayClient &client, const HeapMessage &response, ResponseParameters &responseParameters)
Deserialize a response.
static
ACTIV_CONTRIBUTION_GATEWAY_API
StatusCode 		GetResponse (const ContributionGatewayClient &client, SyncRequestId &syncRequestId, ResponseParameters &responseParameters, const TimeoutPeriod timeoutPeriod=Port::defaultTimeout)
Wait or poll for a response message from a sync request id object.
static
ACTIV_CONTRIBUTION_GATEWAY_API
StatusCode 		PostRequest (const ContributionGatewayClient &client, const RequestId &requestId, const RequestParameters &requestParameters)
Get items asynchronously.
static
ACTIV_CONTRIBUTION_GATEWAY_API
StatusCode 		SendRequest (const ContributionGatewayClient &client, SyncRequestId &syncRequestId, const RequestParameters &requestParameters)
Get items synchronously without blocking.
static
ACTIV_CONTRIBUTION_GATEWAY_API
StatusCode 		SendRequest (const ContributionGatewayClient &client, const RequestParameters &requestParameters, ResponseParameters &responseParameters, const TimeoutPeriod timeoutPeriod=Port::defaultTimeout)
Get items synchronously.

Detailed Description

template<MessageType MESSAGE_TYPE_VALUE, typename REQUEST_PARAMETERS, typename RESPONSE_PARAMETERS>
class Activ::ContentPlatform::ContributionGatewayApi::PublishRequestHelper< MESSAGE_TYPE_VALUE, REQUEST_PARAMETERS, RESPONSE_PARAMETERS >

Publish request helper class.

Parameters:
MESSAGE_TYPE_VALUE | type of message for requests.
REQUEST_PARAMETERS | type of request parameters.

Definition at line 34 of file PublishRequestHelper.h.

Member Function Documentation

template<MessageType MESSAGE_TYPE_VALUE, typename REQUEST_PARAMETERS, typename RESPONSE_PARAMETERS>
static ACTIV_CONTRIBUTION_GATEWAY_API StatusCode Activ::ContentPlatform::ContributionGatewayApi::PublishRequestHelper< MESSAGE_TYPE_VALUE, REQUEST_PARAMETERS, RESPONSE_PARAMETERS >::Deserialize | ( | const ContributionGatewayClient & | client,
 |  | const HeapMessage & | response,
 |  | ResponseParameters & | responseParameters |
 | ) |  |  | [static]

Deserialize a response.

This function should only be called if the received response is valid. This can be determined using ContentGatewayClient::IsValidResponse(). Note the response block list is not cleared down by this function, so it is possible to build a complete ResponseBlockList from multiple partial responses.

Parameters:
client | reference to ContributionGatewayClient.
response | HeapMessage as passed to ContentGatewayClient::On*Response() or returned by SyncRequestId::GetResponse().
responseParameters | reference to a ResponseParameters object to receive deserialized response blocks.
Return values:
STATUS_CODE_SUCCESS | response successfully deserialized
STATUS_CODE_UNRECOGNIZED | not a MESSAGE_TYPE response message
... failed to deserialize response

template<MessageType MESSAGE_TYPE_VALUE, typename REQUEST_PARAMETERS, typename RESPONSE_PARAMETERS>
static ACTIV_CONTRIBUTION_GATEWAY_API StatusCode Activ::ContentPlatform::ContributionGatewayApi::PublishRequestHelper< MESSAGE_TYPE_VALUE, REQUEST_PARAMETERS, RESPONSE_PARAMETERS >::GetResponse | ( | const ContributionGatewayClient & | client,
 |  | SyncRequestId & | syncRequestId,
 |  | ResponseParameters & | responseParameters,
 |  | const TimeoutPeriod | timeoutPeriod = Port::defaultTimeout |
 | ) |  |  | [static]

Wait or poll for a response message from a sync request id object.

Parameters:
client | reference to ContributionGatewayClient.
syncRequestId | SyncRequestId object as returned by a successful Send() call.
responseParameters | to receive the returned data.
timeoutPeriod | timeout in ms.
Return values:
STATUS_CODE_SUCCESS | responseParameters contains the deserialized data and there is no more to follow
STATUS_CODE_PENDING | responseParameters contains the deserialized data and there more data to follow
STATUS_CODE_TIMEOUT
...

template<MessageType MESSAGE_TYPE_VALUE, typename REQUEST_PARAMETERS, typename RESPONSE_PARAMETERS>
static ACTIV_CONTRIBUTION_GATEWAY_API StatusCode Activ::ContentPlatform::ContributionGatewayApi::PublishRequestHelper< MESSAGE_TYPE_VALUE, REQUEST_PARAMETERS, RESPONSE_PARAMETERS >::PostRequest | ( | const ContributionGatewayClient & | client,
 |  | const RequestId & | requestId,
 |  | const RequestParameters & | requestParameters |
 | ) |  |  | [static]

Get items asynchronously.

Parameters:
client | reference to ContributionGatewayClient.
requestId | request id.
requestParameters | parameters describing the request.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_CONNECTED
...

template<MessageType MESSAGE_TYPE_VALUE, typename REQUEST_PARAMETERS, typename RESPONSE_PARAMETERS>
static ACTIV_CONTRIBUTION_GATEWAY_API StatusCode Activ::ContentPlatform::ContributionGatewayApi::PublishRequestHelper< MESSAGE_TYPE_VALUE, REQUEST_PARAMETERS, RESPONSE_PARAMETERS >::SendRequest | ( | const ContributionGatewayClient & | client,
 |  | SyncRequestId & | syncRequestId,
 |  | const RequestParameters & | requestParameters |
 | ) |  |  | [static]

Get items synchronously without blocking.

Parameters:
client | reference to ContributionGatewayClient.
syncRequestId | reference to a SyncRequestId object that can be used to poll for responses after this call.
requestParameters | parameters describing the request.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_CONNECTED
...

template<MessageType MESSAGE_TYPE_VALUE, typename REQUEST_PARAMETERS, typename RESPONSE_PARAMETERS>
static ACTIV_CONTRIBUTION_GATEWAY_API StatusCode Activ::ContentPlatform::ContributionGatewayApi::PublishRequestHelper< MESSAGE_TYPE_VALUE, REQUEST_PARAMETERS, RESPONSE_PARAMETERS >::SendRequest | ( | const ContributionGatewayClient & | client,
 |  | const RequestParameters & | requestParameters,
 |  | ResponseParameters & | responseParameters,
 |  | const TimeoutPeriod | timeoutPeriod = Port::defaultTimeout |
 | ) |  |  | [static]

Get items synchronously.

Parameters:
client | reference to ContributionGatewayClient.
requestParameters | parameters describing the request.
responseParameters | to receive the returned data.
timeoutPeriod | timeout in ms.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_CONNECTED
STATUS_CODE_TIMEOUT
...

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivContributionGatewayApi/PublishRequestHelper.h
Generated on Wed Oct 8 14:02:05 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContributionGatewayApi::PublishSymbolRecordParameters

Activ::ContentPlatform::ContributionGatewayApi::PublishSymbolRecordParameters Class Reference

Parameters for publishing a symbol record. More...

#include <ActivContentPlatform/ActivContributionGatewayApiCommon/PublishTypes.h>

Inheritance diagram for Activ::ContentPlatform::ContributionGatewayApi::PublishSymbolRecordParameters:

Activ::ContentPlatform::ContributionGatewayApi::PublishRecordBaseParameters

List of all members.

Public Types

typedef std::vector< Field > | FieldList

Public Member Functions

ACTIV_CONTRIBUTION_GATEWAY_API_COMMON_API | PublishSymbolRecordParameters (Feed::TableNo tableNumber, const Symbol &symbol, Feed::EventType eventType, Feed::PermissionId permissionId, Flags flags, Feed::UpdateId updateId=Feed::UPDATE_ID_COUNT_UNKNOWN, uint8_t defaultRuleSet=Feed::SymbolRecordRuleDefinitions::RULE_SET_NONE)
Constructor.
ACTIV_CONTRIBUTION_GATEWAY_API_COMMON_API | PublishSymbolRecordParameters ()
Default constructor.

Public Attributes

uint8_t | m_defaultRuleSet
The default rule set to apply to this update.
FieldList | m_fieldList
The list of fields in this update.
Symbol | m_symbol
The symbol of the record to update/add.

Classes

class | Field
Field class. More...

Detailed Description

Parameters for publishing a symbol record.

Definition at line 122 of file PublishTypes.h.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivContributionGatewayApiCommon/PublishTypes.h
Generated on Wed Oct 8 14:02:05 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContributionGatewayApi::PublishSymbolRecordParameters::Field

Activ::ContentPlatform::ContributionGatewayApi::PublishSymbolRecordParameters::Field Class Reference

Field class. More...

#include <ActivContentPlatform/ActivContributionGatewayApiCommon/PublishTypes.h>

Inheritance diagram for Activ::ContentPlatform::ContributionGatewayApi::PublishSymbolRecordParameters::Field:

Activ::ContentPlatform::ContributionGatewayApi::PublishField

List of all members.

Public Member Functions

ACTIV_CONTRIBUTION_GATEWAY_API_COMMON_API | Field (Feed::FieldId fieldId, uint8_t ruleSet, uint8_t rules, IFieldType *pIFieldType)
Constructor.
ACTIV_CONTRIBUTION_GATEWAY_API_COMMON_API | Field (Feed::FieldId fieldId, IFieldType *pIFieldType)
Constructor.
ACTIV_CONTRIBUTION_GATEWAY_API_COMMON_API | Field ()
Default constructor.
ACTIV_CONTRIBUTION_GATEWAY_API_COMMON_API
uint8_t 		GetRules () const
Get the rules.
ACTIV_CONTRIBUTION_GATEWAY_API_COMMON_API
uint8_t 		GetRuleSet () const
Get the rule set.
ACTIV_CONTRIBUTION_GATEWAY_API_COMMON_API
bool 		IsRulesPresent () const
Have the rule set and rules been set?.
ACTIV_CONTRIBUTION_GATEWAY_API_COMMON_API
StatusCode 		SetRuleSet (uint8_t ruleSet, uint8_t rules=0)
Set the rule set and rules.

Detailed Description

Field class.

Definition at line 140 of file PublishTypes.h.

Constructor & Destructor Documentation

ACTIV_CONTRIBUTION_GATEWAY_API_COMMON_API Activ::ContentPlatform::ContributionGatewayApi::PublishSymbolRecordParameters::Field::Field | ( | Feed::FieldId | fieldId,
 |  | IFieldType * | pIFieldType
 | ) |  |

Constructor.

Parameters:
fieldId
pIFieldType

ACTIV_CONTRIBUTION_GATEWAY_API_COMMON_API Activ::ContentPlatform::ContributionGatewayApi::PublishSymbolRecordParameters::Field::Field | ( | Feed::FieldId | fieldId,
 |  | uint8_t | ruleSet,
 |  | uint8_t | rules,
 |  | IFieldType * | pIFieldType
 | ) |  |

Constructor.

Parameters:
fieldId
ruleSet
rules
pIFieldType

Member Function Documentation

ACTIV_CONTRIBUTION_GATEWAY_API_COMMON_API StatusCode Activ::ContentPlatform::ContributionGatewayApi::PublishSymbolRecordParameters::Field::SetRuleSet | ( | uint8_t | ruleSet,
 |  | uint8_t | rules = 0
 | ) |  |

Set the rule set and rules.

Parameters:
ruleSet
rules

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivContributionGatewayApiCommon/PublishTypes.h
Generated on Wed Oct 8 14:02:05 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContributionServerApi::ContributionServerClient

Activ::ContentPlatform::ContributionServerApi::ContributionServerClient Class Reference

Contribution server client class. More...

#include <ActivContentPlatform/ActivContributionServerApi/ContributionServerClient.h>

Inheritance diagram for Activ::ContentPlatform::ContributionServerApi::ContributionServerClient:

Activ::Component Activ::Port

List of all members.

Public Member Functions

ACTIV_CONTRIBUTION_SERVER_API | ContributionServerClient (Application &application, ManagedEndPoint &managedEndPoint, const Settings &settings=Settings(), const std::string &componentId=defaultComponentId)
Constructor.
ACTIV_CONTRIBUTION_SERVER_API
ApiInfo 		GetApiInfo () const
Return information about the API.
ACTIV_CONTRIBUTION_SERVER_API
const Feed::TableNo & 		GetMaximumTableNumber () const
Get the maximum table number.
ACTIV_CONTRIBUTION_SERVER_API
const Feed::TableNo & 		GetMinimumTableNumber () const
Get the minimum table number.
ACTIV_CONTRIBUTION_SERVER_API
RecordMessageBuilder & 		GetRecordMessageBuilder ()
Get the record message builder.
ACTIV_CONTRIBUTION_SERVER_API
const Settings & 		GetSettings () const
Get the object's settings.
ACTIV_CONTRIBUTION_SERVER_API
SymbolRecordMessageBuilder & 		GetSymbolRecordMessageBuilder ()
Get the symbol record message builder.
ACTIV_CONTRIBUTION_SERVER_API
Feed::TableTemplateList & 		GetTableTemplateList ()
Get the table template list.
ACTIV_CONTRIBUTION_SERVER_API
const Feed::TableTemplateList & 		GetTableTemplateList () const
Get the table template list.
ACTIV_CONTRIBUTION_SERVER_API | ~ContributionServerClient ()
Destructor.

Static Public Member Functions

static
ACTIV_CONTRIBUTION_SERVER_API
std::string 		GetDefaultName ()
Get the default name.

Classes

class | ApiInfo
Information returned from GetApiInfo(). More...
class | RecordMessageBuilder
Record message builder class. More...
class | Settings
Settings for contribution api class. More...
class | SymbolRecordMessageBuilder
Symbol record message builder class. More...

Detailed Description

Contribution server client class.

Definition at line 43 of file ContributionServerClient.h.

Constructor & Destructor Documentation

ACTIV_CONTRIBUTION_SERVER_API Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::ContributionServerClient | ( | Application & | application,
 |  | ManagedEndPoint & | managedEndPoint,
 |  | const Settings & | settings = Settings(),
 |  | const std::string & | componentId = defaultComponentId
 | ) |  |

Constructor.

Parameters:
application | reference to an application.
managedEndPoint | endpoint to attach to.
settings | settings.
componentId | component id.
Exceptions:
Exception.

Member Function Documentation

ACTIV_CONTRIBUTION_SERVER_API ApiInfo Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::GetApiInfo ( ) const

Return information about the API.

Returns:
The api information.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivContributionServerApi/ContributionServerClient.h
Generated on Wed Oct 8 14:02:05 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::ApiInfo

Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::ApiInfo Class Reference

Information returned from GetApiInfo(). More...

#include <ActivContentPlatform/ActivContributionServerApi/ContributionServerClient.h>

List of all members.

Public Attributes

std::string | m_buildConfiguration
Build configuration, e.g. x86_win32_vc71_mdi.
std::string | m_buildDateTime
Date and time api was built.
std::string | m_version
Version.

Detailed Description

Information returned from GetApiInfo().

Definition at line 94 of file ContributionServerClient.h.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivContributionServerApi/ContributionServerClient.h
Generated on Wed Oct 8 14:02:05 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::RecordMessageBuilder

Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::RecordMessageBuilder Class Reference

Record message builder class. More...

#include <ActivContentPlatform/ActivContributionServerApi/ContributionServerClient.h>

List of all members.

Public Member Functions

ACTIV_CONTRIBUTION_SERVER_API
StatusCode 		AppendField (const Feed::FieldId fieldId, const IFieldType &iFieldType)
Append a field.
ACTIV_CONTRIBUTION_SERVER_API
StatusCode 		AppendHeader (const bool isDelete, const bool isRefresh, const Feed::TableId tableId, const Feed::PermissionId permissionId, const Feed::EventType eventType, const Feed::UpdateId updateId=Feed::UPDATE_ID_COUNT_UNKNOWN)
Append the header.
ACTIV_CONTRIBUTION_SERVER_API
StatusCode 		AppendIndexNumber (const Feed::IndexNumber indexNumber)
Append the index number.
ACTIV_CONTRIBUTION_SERVER_API
StatusCode 		AppendKeyField (const Feed::FieldId fieldId, const IFieldType &iFieldType)
Append a key field.
ACTIV_CONTRIBUTION_SERVER_API
StatusCode 		AppendUndefinedField (const Feed::FieldId fieldId)
Append an undefined field.
ACTIV_CONTRIBUTION_SERVER_API
StatusCode 		AppendUndefinedKeyField (const Feed::FieldId fieldId)
Append an undefined key field.
ACTIV_CONTRIBUTION_SERVER_API
StatusCode 		Flush ()
Flush any queued data now.
ACTIV_CONTRIBUTION_SERVER_API bool | IsInitialized () const
Is the object initialized.
ACTIV_CONTRIBUTION_SERVER_API | RecordMessageBuilder (ContributionServerClient &contributionServerClient)
Constructor.
ACTIV_CONTRIBUTION_SERVER_API void | Reset ()
Reset.
ACTIV_CONTRIBUTION_SERVER_API
std::string 		ToString () const
Convert the record message builder to a string.
ACTIV_CONTRIBUTION_SERVER_API
StatusCode 		Write (bool flush=true)
Write a message.
ACTIV_CONTRIBUTION_SERVER_API | ~RecordMessageBuilder ()
Destructor.

Detailed Description

Record message builder class.

Definition at line 105 of file ContributionServerClient.h.

Member Function Documentation

ACTIV_CONTRIBUTION_SERVER_API StatusCode Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::RecordMessageBuilder::AppendField | ( | const Feed::FieldId | fieldId,
 |  | const IFieldType & | iFieldType
 | ) |  |

Append a field.

Parameters:
fieldId | the field id.
iFieldType | a reference to the field.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED
...

ACTIV_CONTRIBUTION_SERVER_API StatusCode Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::RecordMessageBuilder::AppendHeader | ( | const bool | isDelete,
 |  | const bool | isRefresh,
 |  | const Feed::TableId | tableId,
 |  | const Feed::PermissionId | permissionId,
 |  | const Feed::EventType | eventType,
 |  | const Feed::UpdateId | updateId = Feed::UPDATE_ID_COUNT_UNKNOWN
 | ) |  |

Append the header.

Parameters:
isDelete | whether this is a delete message.
isRefresh | whether this is a refresh message.
tableId | the table template id.
permissionId | the permission id.
eventType | the event type.
updateId | the update id.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED
...

ACTIV_CONTRIBUTION_SERVER_API StatusCode Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::RecordMessageBuilder::AppendIndexNumber ( const Feed::IndexNumber indexNumber )

Append the index number.

Parameters:
indexNumber the index number.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED
...

ACTIV_CONTRIBUTION_SERVER_API StatusCode Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::RecordMessageBuilder::AppendKeyField | ( | const Feed::FieldId | fieldId,
 |  | const IFieldType & | iFieldType
 | ) |  |

Append a key field.

Parameters:
fieldId | the field id.
iFieldType | a reference to the field.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED
...

ACTIV_CONTRIBUTION_SERVER_API StatusCode Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::RecordMessageBuilder::AppendUndefinedField ( const Feed::FieldId fieldId )

Append an undefined field.

Parameters:
fieldId the field id.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED
...

ACTIV_CONTRIBUTION_SERVER_API StatusCode Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::RecordMessageBuilder::AppendUndefinedKeyField ( const Feed::FieldId fieldId )

Append an undefined key field.

Parameters:
fieldId the field id.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED
...

ACTIV_CONTRIBUTION_SERVER_API StatusCode Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::RecordMessageBuilder::Flush ( )

Flush any queued data now.

Return values:
STATUS_CODE_SUCCESS
...

ACTIV_CONTRIBUTION_SERVER_API bool Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::RecordMessageBuilder::IsInitialized ( ) const

Is the object initialized.

Returns:
whether the object is initialized.

ACTIV_CONTRIBUTION_SERVER_API std::string Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::RecordMessageBuilder::ToString ( ) const

Convert the record message builder to a string.

Returns:
the record message builder as a string.
Exceptions:
StatusCodeException if there are duplicate fields

ACTIV_CONTRIBUTION_SERVER_API StatusCode Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::RecordMessageBuilder::Write ( bool flush = true )

Write a message.

Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_HEAP_EMPTY
STATUS_CODE_DISABLED

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivContributionServerApi/ContributionServerClient.h
Generated on Wed Oct 8 14:02:05 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::Settings

Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::Settings Class Reference

Settings for contribution api class. More...

#include <ActivContentPlatform/ActivContributionServerApi/ContributionServerClient.h>

List of all members.

Public Member Functions

ACTIV_CONTRIBUTION_SERVER_API
StatusCode 		Read (const IniFileParser &iniFileParser, const std::string &sectionName)
Read settings.
ACTIV_CONTRIBUTION_SERVER_API | Settings ()
Default constructor.

Static Public Member Functions

static
ACTIV_CONTRIBUTION_SERVER_API
Settings 		GetFromIniFile (const std::string &iniFileName, const std::string &sectionName=ContributionServerClient::GetDefaultName())
Get settings from an ini file.

Public Attributes

std::string | m_iniFileName
The ini file name.
size_t | m_messageRate
The message rate that the throttler uses.
std::string | m_sectionName
The section name within the ini file.
Feed::TableTemplateList::Settings m_tableTemplateListSettings
The table template list settings.
UdpTransmitter::Settings | m_udpSettings
The udp settings.

Detailed Description

Settings for contribution api class.

Definition at line 51 of file ContributionServerClient.h.

Member Function Documentation

static ACTIV_CONTRIBUTION_SERVER_API Settings Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::Settings::GetFromIniFile | ( | const std::string & | iniFileName,
 |  | const std::string & | sectionName = ContributionServerClient::GetDefaultName() |
 | ) |  |  | [static]

Get settings from an ini file.

Parameters:
iniFileName | the file name of the ini file.
sectionName | the section name within the ini file.
Returns:
a copy of a settings object.
Exceptions:
StatusCodeException

ACTIV_CONTRIBUTION_SERVER_API StatusCode Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::Settings::Read | ( | const IniFileParser & | iniFileParser,
 |  | const std::string & | sectionName
 | ) |  |

Read settings.

Parameters:
iniFileParser | ini file to read from.
sectionName | the section name within the ini file.
Return values:
STATUS_CODE_SUCCESS
...

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivContributionServerApi/ContributionServerClient.h
Generated on Wed Oct 8 14:02:05 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::SymbolRecordMessageBuilder

Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::SymbolRecordMessageBuilder Class Reference

Symbol record message builder class. More...

#include <ActivContentPlatform/ActivContributionServerApi/ContributionServerClient.h>

List of all members.

Public Member Functions

ACTIV_CONTRIBUTION_SERVER_API
StatusCode 		AppendField (const Feed::FieldId fieldId, const IFieldType &iFieldType)
Append a field with the default rule set.
ACTIV_CONTRIBUTION_SERVER_API
StatusCode 		AppendFieldWithContentServerRuleSet (const Feed::FieldId fieldId, const uint8_t fieldRules, const IFieldType &iFieldType)
Append a field with the content server rule set.
ACTIV_CONTRIBUTION_SERVER_API
StatusCode 		AppendFieldWithNoneRuleSet (const Feed::FieldId fieldId, const IFieldType &iFieldType)
Append a field with the none rule set.
ACTIV_CONTRIBUTION_SERVER_API
StatusCode 		AppendFieldWithTranslatorRuleSet (const Feed::FieldId fieldId, const uint8_t fieldRules, const IFieldType &iFieldType)
Append a field with the translator rule set.
ACTIV_CONTRIBUTION_SERVER_API
StatusCode 		AppendHeader (const bool isDelete, const Feed::TableId tableId, const Feed::PermissionId permissionId, const Feed::EventType eventType, const void *const pSymbol, const size_t symbolLength, uint8_t defaultRuleSet=Feed::SymbolRecordRuleDefinitions::RULE_SET_NONE, const Feed::UpdateId updateId=Feed::UPDATE_ID_COUNT_UNKNOWN)
Append the header.
ACTIV_CONTRIBUTION_SERVER_API
StatusCode 		AppendUndefinedField (const Feed::FieldId fieldId)
Append an undefined field.
ACTIV_CONTRIBUTION_SERVER_API
StatusCode 		Flush ()
Flush any queued data now.
ACTIV_CONTRIBUTION_SERVER_API bool | IsInitialized () const
Is the object initialized.
ACTIV_CONTRIBUTION_SERVER_API void | Reset ()
Reset.
ACTIV_CONTRIBUTION_SERVER_API | SymbolRecordMessageBuilder (ContributionServerClient &contributionServerClient)
Constructor.
ACTIV_CONTRIBUTION_SERVER_API
std::string 		ToString () const
Convert the symbol record message builder to a string.
ACTIV_CONTRIBUTION_SERVER_API
StatusCode 		Write (bool flush=true)
Write a message.
ACTIV_CONTRIBUTION_SERVER_API | ~SymbolRecordMessageBuilder ()
Destructor.

Detailed Description

Symbol record message builder class.

Definition at line 244 of file ContributionServerClient.h.

Member Function Documentation

ACTIV_CONTRIBUTION_SERVER_API StatusCode Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::SymbolRecordMessageBuilder::AppendField | ( | const Feed::FieldId | fieldId,
 |  | const IFieldType & | iFieldType
 | ) |  |

Append a field with the default rule set.

Parameters:
fieldId | the field id.
iFieldType | a reference to the field.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED
...

ACTIV_CONTRIBUTION_SERVER_API StatusCode Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::SymbolRecordMessageBuilder::AppendFieldWithContentServerRuleSet | ( | const Feed::FieldId | fieldId,
 |  | const uint8_t | fieldRules,
 |  | const IFieldType & | iFieldType
 | ) |  |

Append a field with the content server rule set.

Parameters:
fieldId | the field id.
fieldRules | the field rules.
iFieldType | a reference to the field.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED
...

ACTIV_CONTRIBUTION_SERVER_API StatusCode Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::SymbolRecordMessageBuilder::AppendFieldWithNoneRuleSet | ( | const Feed::FieldId | fieldId,
 |  | const IFieldType & | iFieldType
 | ) |  |

Append a field with the none rule set.

Parameters:
fieldId | the field id.
iFieldType | a reference to the field.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED
...

ACTIV_CONTRIBUTION_SERVER_API StatusCode Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::SymbolRecordMessageBuilder::AppendFieldWithTranslatorRuleSet | ( | const Feed::FieldId | fieldId,
 |  | const uint8_t | fieldRules,
 |  | const IFieldType & | iFieldType
 | ) |  |

Append a field with the translator rule set.

Parameters:
fieldId | the field id.
fieldRules | the field rules.
iFieldType | a reference to the field.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED
...

ACTIV_CONTRIBUTION_SERVER_API StatusCode Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::SymbolRecordMessageBuilder::AppendHeader | ( | const bool | isDelete,
 |  | const Feed::TableId | tableId,
 |  | const Feed::PermissionId | permissionId,
 |  | const Feed::EventType | eventType,
 |  | const void *const | pSymbol,
 |  | const size_t | symbolLength,
 |  | uint8_t | defaultRuleSet = Feed::SymbolRecordRuleDefinitions::RULE_SET_NONE,
 |  | const Feed::UpdateId | updateId = Feed::UPDATE_ID_COUNT_UNKNOWN
 | ) |  |

Append the header.

Parameters:
isDelete | whether this is a delete message.
tableId | the table template id.
permissionId | the permission id.
eventType | the event type.
pSymbol | the symbol.
symbolLength | the symbol length.
defaultRuleSet | the default rule set.
updateId | the update id.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED
...

ACTIV_CONTRIBUTION_SERVER_API StatusCode Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::SymbolRecordMessageBuilder::AppendUndefinedField ( const Feed::FieldId fieldId )

Append an undefined field.

Parameters:
fieldId the field id.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED
...

ACTIV_CONTRIBUTION_SERVER_API StatusCode Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::SymbolRecordMessageBuilder::Flush ( )

Flush any queued data now.

Return values:
STATUS_CODE_SUCCESS
...

ACTIV_CONTRIBUTION_SERVER_API bool Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::SymbolRecordMessageBuilder::IsInitialized ( ) const

Is the object initialized.

Returns:
whether the object is initialized.

ACTIV_CONTRIBUTION_SERVER_API std::string Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::SymbolRecordMessageBuilder::ToString ( ) const

Convert the symbol record message builder to a string.

Returns:
the symbol record message builder as a string.
Exceptions:
StatusCodeException if there are duplicate fields

ACTIV_CONTRIBUTION_SERVER_API StatusCode Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::SymbolRecordMessageBuilder::Write ( bool flush = true )

Write a message.

Return values:
STATUS_CODE_SUCCESS.
STATUS_CODE_HEAP_EMPTY.
STATUS_CODE_DISABLED

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivContributionServerApi/ContributionServerClient.h
Generated on Wed Oct 8 14:02:05 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::CombinedQuoteMessageHeaderDefinitions

Activ::ContentPlatform::Feed::CombinedQuoteMessageHeaderDefinitions Class Reference

Combined quote message header definitions class. More...

#include <ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/CombinedQuoteMessageHeaderDefinitions.h>

List of all members.

Public Types

typedef uint8_t | Flags
The flags type definition.

Static Public Member Functions

static void | ExtractFlags (const Flags flags, bool &isCompositeBid, bool &isCompositeAsk, bool &isCompositeBidAppendage, bool &isCompositeAskAppendage)
Extract flags.
static Flags | GetFlags (const bool isCompositeBid, const bool isCompositeAsk, const bool isCompositeBidAppendage, const bool isCompositeAskAppendage)
Get the flags.
static
MessageHeaderDefinitions::MessageHeader 		GetMessageHeader (const MessageType messageType=MESSAGE_TYPE)
Get the message header.
static bool | IsCompositeAsk (const Flags flags)
Is this a composite ask.
static bool | IsCompositeAskAppendage (const Flags flags)
Is this a composite ask appendage.
static bool | IsCompositeBid (const Flags flags)
Is this a composite bid.
static bool | IsCompositeBidAppendage (const Flags flags)
Is this a composite bid appendage.
static bool | IsValidMessageType (const MessageHeaderDefinitions::MessageHeader messageHeader)
Is valid message type.

Static Public Attributes

static const Flags | FLAGS_COMPOSITE_ASK_APPENDAGE_BIT_MASK = static_cast<Flags>((1 << FLAGS_COMPOSITE_ASK_APPENDAGE_LENGTH) - 1)
static const size_t | FLAGS_COMPOSITE_ASK_APPENDAGE_BIT_SHIFT = (sizeof(Flags) * CHAR_BIT) - (FLAGS_COMPOSITE_ASK_APPENDAGE_OFFSET + FLAGS_COMPOSITE_ASK_APPENDAGE_LENGTH)
static const size_t | FLAGS_COMPOSITE_ASK_APPENDAGE_LENGTH = 1
The flags composite ask appendage length.
static const size_t | FLAGS_COMPOSITE_ASK_APPENDAGE_OFFSET = (FLAGS_COMPOSITE_BID_APPENDAGE_OFFSET + FLAGS_COMPOSITE_BID_APPENDAGE_LENGTH)
The flags composite ask appendage offset.
static const Flags | FLAGS_COMPOSITE_ASK_BIT_MASK = static_cast<Flags>((1 << FLAGS_COMPOSITE_ASK_LENGTH) - 1)
static const size_t | FLAGS_COMPOSITE_ASK_BIT_SHIFT = (sizeof(Flags) * CHAR_BIT) - (FLAGS_COMPOSITE_ASK_OFFSET + FLAGS_COMPOSITE_ASK_LENGTH)
static const size_t | FLAGS_COMPOSITE_ASK_LENGTH = 1
The flags composite ask length.
static const size_t | FLAGS_COMPOSITE_ASK_OFFSET = (FLAGS_COMPOSITE_BID_OFFSET + FLAGS_COMPOSITE_BID_LENGTH)
The flags composite ask offset.
static const Flags | FLAGS_COMPOSITE_BID_APPENDAGE_BIT_MASK = static_cast<Flags>((1 << FLAGS_COMPOSITE_BID_APPENDAGE_LENGTH) - 1)
static const size_t | FLAGS_COMPOSITE_BID_APPENDAGE_BIT_SHIFT = (sizeof(Flags) * CHAR_BIT) - (FLAGS_COMPOSITE_BID_APPENDAGE_OFFSET + FLAGS_COMPOSITE_BID_APPENDAGE_LENGTH)
static const size_t | FLAGS_COMPOSITE_BID_APPENDAGE_LENGTH = 1
The flags composite bid appendage length.
static const size_t | FLAGS_COMPOSITE_BID_APPENDAGE_OFFSET = (FLAGS_COMPOSITE_ASK_OFFSET + FLAGS_COMPOSITE_ASK_LENGTH)
The flags composite bid appendage offset.
static const Flags | FLAGS_COMPOSITE_BID_BIT_MASK = static_cast<Flags>((1 << FLAGS_COMPOSITE_BID_LENGTH) - 1)
static const size_t | FLAGS_COMPOSITE_BID_BIT_SHIFT = (sizeof(Flags) * CHAR_BIT) - (FLAGS_COMPOSITE_BID_OFFSET + FLAGS_COMPOSITE_BID_LENGTH)
static const size_t | FLAGS_COMPOSITE_BID_LENGTH = 1
The flags composite bid length.
static const size_t | FLAGS_COMPOSITE_BID_OFFSET = 0
The flags composite bid offset.
static const size_t | MAX_SYMBOL_LENGTH = 32
The maximum symbol length.
static const MessageType | MESSAGE_TYPE = MESSAGE_TYPE_COMBINED_QUOTE
The message type.

Detailed Description

Combined quote message header definitions class.

Definition at line 28 of file CombinedQuoteMessageHeaderDefinitions.h.

Member Function Documentation

void Activ::ContentPlatform::Feed::CombinedQuoteMessageHeaderDefinitions::ExtractFlags | ( | const Flags | flags,
 |  | bool & | isCompositeBid,
 |  | bool & | isCompositeAsk,
 |  | bool & | isCompositeBidAppendage,
 |  | bool & | isCompositeAskAppendage |
 | ) |  |  | [inline, static]

Extract flags.

Parameters:
flags | the flags to extract from.
isCompositeBid | set equal to true if this is a composite bid.
isCompositeAsk | set equal to true if this is a composite ask.
isCompositeBidAppendage | set equal to true if this is a composite bid appendage.
isCompositeAskAppendage | set equal to true if this is a composite ask appendage.

Definition at line 156 of file CombinedQuoteMessageHeaderDefinitions.h.

References IsCompositeAsk(), IsCompositeAskAppendage(), IsCompositeBid(), and IsCompositeBidAppendage().

CombinedQuoteMessageHeaderDefinitions::Flags Activ::ContentPlatform::Feed::CombinedQuoteMessageHeaderDefinitions::GetFlags | ( | const bool | isCompositeBid,
 |  | const bool | isCompositeAsk,
 |  | const bool | isCompositeBidAppendage,
 |  | const bool | isCompositeAskAppendage |
 | ) |  |  | [inline, static]

Get the flags.

Parameters:
isCompositeBid | whether this is a composite bid.
isCompositeAsk | whether this is a composite ask.
isCompositeBidAppendage | whether this is a composite bid appendage.
isCompositeAskAppendage | whether this is a composite ask appendage.
Returns:
the flags.

Definition at line 149 of file CombinedQuoteMessageHeaderDefinitions.h.

MessageHeaderDefinitions::MessageHeader Activ::ContentPlatform::Feed::CombinedQuoteMessageHeaderDefinitions::GetMessageHeader ( const MessageType messageType = MESSAGE_TYPE ) [inline, static]

Get the message header.

Parameters:
messageType the message type.
Returns:
the message header.

Definition at line 135 of file CombinedQuoteMessageHeaderDefinitions.h.

References Activ::ContentPlatform::Feed::MessageHeaderDefinitions::GetMessageHeader().

bool Activ::ContentPlatform::Feed::CombinedQuoteMessageHeaderDefinitions::IsCompositeAsk ( const Flags flags ) [inline, static]

Is this a composite ask.

Parameters:
flags the flags.
Returns:
whether this is a composite ask.

Definition at line 173 of file CombinedQuoteMessageHeaderDefinitions.h.

Referenced by ExtractFlags().

bool Activ::ContentPlatform::Feed::CombinedQuoteMessageHeaderDefinitions::IsCompositeAskAppendage ( const Flags flags ) [inline, static]

Is this a composite ask appendage.

Parameters:
flags the flags.
Returns:
whether this is a composite ask appendage.

Definition at line 187 of file CombinedQuoteMessageHeaderDefinitions.h.

Referenced by ExtractFlags().

bool Activ::ContentPlatform::Feed::CombinedQuoteMessageHeaderDefinitions::IsCompositeBid ( const Flags flags ) [inline, static]

Is this a composite bid.

Parameters:
flags the flags.
Returns:
whether this is a composite bid.

Definition at line 166 of file CombinedQuoteMessageHeaderDefinitions.h.

Referenced by ExtractFlags().

bool Activ::ContentPlatform::Feed::CombinedQuoteMessageHeaderDefinitions::IsCompositeBidAppendage ( const Flags flags ) [inline, static]

Is this a composite bid appendage.

Parameters:
flags the flags.
Returns:
whether this is a composite bid appendage.

Definition at line 180 of file CombinedQuoteMessageHeaderDefinitions.h.

Referenced by ExtractFlags().

bool Activ::ContentPlatform::Feed::CombinedQuoteMessageHeaderDefinitions::IsValidMessageType ( const MessageHeaderDefinitions::MessageHeader messageHeader ) [inline, static]

Is valid message type.

Parameters:
messageHeader the message header.
Returns:
whether the message type is valid.

Definition at line 142 of file CombinedQuoteMessageHeaderDefinitions.h.

References Activ::ContentPlatform::Feed::MessageHeaderDefinitions::IsValidMessageType(), and MESSAGE_TYPE.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/CombinedQuoteMessageHeaderDefinitions.h
Generated on Wed Oct 8 14:02:05 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessage

Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessage Class Reference

Compressed Combined quote message class. More...

#include <ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/CompressedCombinedQuoteMessage.h>

Inheritance diagram for Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessage:

Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator

List of all members.

Public Member Functions

template<Activ::ContentPlatform::Feed::MessageType MT>
StatusCode | ValidateCompressedCombinedQuote (MessageValidator &messageValidator)
Validate the message header.

Protected Attributes

CompressedCombinedQuoteMessageDefinitions::CompositeState m_compositeAskState
The composite ask state.
CompressedCombinedQuoteMessageDefinitions::CompositeState m_compositeBidState
The composite bid state.
UpdateId | m_compositeUpdateId
The composite update id.
bool | m_isComposite
Whether the composite is affected by this message.
bool | m_isCompositeAsk
Whether the regional ask is also the composite ask.
bool | m_isCompositeBid
Whether the regional bid is also the composite bid.
PermissionId | m_permissionId
The permission id of the message.
std::string | m_symbol
The symbol.
TableNo | m_tableNumber
The table number.
UpdateId | m_updateId
The update id.

Detailed Description

Compressed Combined quote message class.

Definition at line 29 of file CompressedCombinedQuoteMessage.h.

Member Function Documentation

template<Activ::ContentPlatform::Feed::MessageType MT>
StatusCode Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessage::ValidateCompressedCombinedQuote ( MessageValidator & messageValidator ) [inline]

Validate the message header.

Parameters:
messageValidator the message validator.
Return values:
STATUS_CODE_SUCCESS
...

Definition at line 65 of file CompressedCombinedQuoteMessage.h.

References ACTIV_RETURN_RESULT_IF, Activ::ContentPlatform::Feed::Symbol::Deserialize(), Activ::ContentPlatform::Feed::CompressedSymbol::Deserialize(), Activ::MessageHandler::ENDIAN_LITTLE, Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageDefinitions::ExtractCompressedCompositeAskState(), Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageDefinitions::ExtractCompressedUpdateId(), Activ::MessageValidator::Get(), Activ::MessageValidator::GetOffset(), Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderDefinitions::IsComposite(), Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderDefinitions::IsCompressedSymbol(), Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderDefinitions::IsUsEquityOption(), m_compositeAskState, m_compositeBidState, m_compositeUpdateId, m_isComposite, m_permissionId, m_symbol, m_tableNumber, m_updateId, Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderDefinitions::MAX_SYMBOL_LENGTH, Activ::MessageValidator::Reset(), and Activ::MessageValidator::ValidateBinaryIntegral().

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/CompressedCombinedQuoteMessage.h
Generated on Wed Oct 8 14:02:05 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageDefinitions

Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageDefinitions Class Reference

Compressed combined quote message definitions class. More...

#include <ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/CompressedCombinedQuoteMessageDefinitions.h>

Inheritance diagram for Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageDefinitions:

Activ::ContentPlatform::Feed::CompressedMessageDefinitions

List of all members.

Public Types

enum | { COMPOSITE_STATE_NO_CHANGE, COMPOSITE_STATE_REGIONAL_IS_BEST, COMPOSITE_STATE_NO_BEST, COMPOSITE_STATE_APPENDAGE }
Composite state flags.
typedef uint8_t | CompositeState
Composite state type definition.

Static Public Member Functions

static void | ExtractCompressedCompositeAskState (const uint8_t compressedCompositeAskState, CompositeState &compositeAskState)
Extract the compressed composite ask state.
static void | ExtractCompressedUpdateId (const uint8_t compressedUpdateId, UpdateId &updateId, UpdateId &compositeUpdateId, CompositeState &compositeBidState)
Extract the compressed update id.
static void | ExtractCompressedUpdateId (const uint8_t compressedUpdateId, UpdateId &updateId, CompositeState &compositeBidState)
Extract the compressed update id.
static uint8_t | GetCompressedCompositeAskState (const CompositeState compositeAskState)
Get the compressed composite ask state.
static uint8_t | GetCompressedUpdateId (const UpdateId updateId, const UpdateId compositeUpdateId, const CompositeState compositeBidState)
Get the compressed update id.
static uint8_t | GetCompressedUpdateId (const UpdateId updateId, const CompositeState compositeBidState)
Get the compressed update id.

Static Public Attributes

static const uint8_t | COMPRESSED_COMPOSITE_ASK_STATE_BIT_MASK = (1 << COMPRESSED_COMPOSITE_ASK_STATE_LENGTH) - 1
static const size_t | COMPRESSED_COMPOSITE_ASK_STATE_BIT_SHIFT = (sizeof(uint8_t) * CHAR_BIT - (COMPRESSED_COMPOSITE_ASK_STATE_OFFSET + COMPRESSED_COMPOSITE_ASK_STATE_LENGTH))
static const size_t | COMPRESSED_COMPOSITE_ASK_STATE_LENGTH = 2
static const size_t | COMPRESSED_COMPOSITE_ASK_STATE_OFFSET = 0
static const uint8_t | COMPRESSED_COMPOSITE_BID_STATE_BIT_MASK = (1 << COMPRESSED_COMPOSITE_BID_STATE_LENGTH) - 1
static const size_t | COMPRESSED_COMPOSITE_BID_STATE_BIT_SHIFT = (sizeof(uint8_t) * CHAR_BIT - (COMPRESSED_COMPOSITE_BID_STATE_OFFSET + COMPRESSED_COMPOSITE_BID_STATE_LENGTH))
static const size_t | COMPRESSED_COMPOSITE_BID_STATE_LENGTH = 2
static const size_t | COMPRESSED_COMPOSITE_BID_STATE_OFFSET = (COMPRESSED_COMPOSITE_UPDATE_ID_OFFSET + COMPRESSED_COMPOSITE_UPDATE_ID_LENGTH)
static const uint8_t | COMPRESSED_COMPOSITE_UPDATE_ID_BIT_MASK = (1 << COMPRESSED_COMPOSITE_UPDATE_ID_LENGTH) - 1
static const size_t | COMPRESSED_COMPOSITE_UPDATE_ID_BIT_SHIFT = (sizeof(uint8_t) * CHAR_BIT - (COMPRESSED_COMPOSITE_UPDATE_ID_OFFSET + COMPRESSED_COMPOSITE_UPDATE_ID_LENGTH))
static const size_t | COMPRESSED_COMPOSITE_UPDATE_ID_LENGTH = 3
static const size_t | COMPRESSED_COMPOSITE_UPDATE_ID_OFFSET = (COMPRESSED_UPDATE_ID_OFFSET + COMPRESSED_UPDATE_ID_LENGTH)
static const uint8_t | COMPRESSED_UPDATE_ID_BIT_MASK = (1 << COMPRESSED_UPDATE_ID_LENGTH) - 1
static const size_t | COMPRESSED_UPDATE_ID_BIT_SHIFT = (sizeof(uint8_t) * CHAR_BIT - (COMPRESSED_UPDATE_ID_OFFSET + COMPRESSED_UPDATE_ID_LENGTH))
static const size_t | COMPRESSED_UPDATE_ID_LENGTH = 3
static const size_t | COMPRESSED_UPDATE_ID_OFFSET = 0

Detailed Description

Compressed combined quote message definitions class.

Definition at line 26 of file CompressedCombinedQuoteMessageDefinitions.h.

Member Function Documentation

void Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageDefinitions::ExtractCompressedCompositeAskState | ( | const uint8_t | compressedCompositeAskState,
 |  | CompositeState & | compositeAskState |
 | ) |  |  | [inline, static]

Extract the compressed composite ask state.

Parameters:
compressedCompositeAskState | the compressed composite ask state.
compositeAskState | set equal to the composite ask state.

Definition at line 160 of file CompressedCombinedQuoteMessageDefinitions.h.

Referenced by Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessage::ValidateCompressedCombinedQuote().

void Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageDefinitions::ExtractCompressedUpdateId | ( | const uint8_t | compressedUpdateId,
 |  | UpdateId & | updateId,
 |  | UpdateId & | compositeUpdateId,
 |  | CompositeState & | compositeBidState |
 | ) |  |  | [inline, static]

Extract the compressed update id.

Parameters:
compressedUpdateId
updateId | set equal to the update id.
compositeUpdateId | set equal to the composite update id.
compositeBidState | set equal to the composite bid state.

Definition at line 144 of file CompressedCombinedQuoteMessageDefinitions.h.

void Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageDefinitions::ExtractCompressedUpdateId | ( | const uint8_t | compressedUpdateId,
 |  | UpdateId & | updateId,
 |  | CompositeState & | compositeBidState |
 | ) |  |  | [inline, static]

Extract the compressed update id.

Parameters:
compressedUpdateId
updateId | set equal to the update id.
compositeBidState | set equal to the composite bid state.

Definition at line 136 of file CompressedCombinedQuoteMessageDefinitions.h.

Referenced by Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessage::ValidateCompressedCombinedQuote().

uint8_t Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageDefinitions::GetCompressedCompositeAskState ( const CompositeState compositeAskState ) [inline, static]

Get the compressed composite ask state.

Parameters:
compositeAskState the composite ask state.
Returns:
the compressed composite ask state.

Definition at line 153 of file CompressedCombinedQuoteMessageDefinitions.h.

uint8_t Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageDefinitions::GetCompressedUpdateId | ( | const UpdateId | updateId,
 |  | const UpdateId | compositeUpdateId,
 |  | const CompositeState | compositeBidState |
 | ) |  |  | [inline, static]

Get the compressed update id.

Parameters:
updateId | the update id.
compositeUpdateId | the composite update id.
compositeBidState | the composite bid state.
Returns:
the compressed update id.

Definition at line 129 of file CompressedCombinedQuoteMessageDefinitions.h.

uint8_t Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageDefinitions::GetCompressedUpdateId | ( | const UpdateId | updateId,
 |  | const CompositeState | compositeBidState |
 | ) |  |  | [inline, static]

Get the compressed update id.

Parameters:
updateId | the update id.
compositeBidState | the composite bid state.
Returns:
the compressed update id.

Definition at line 122 of file CompressedCombinedQuoteMessageDefinitions.h.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/CompressedCombinedQuoteMessageDefinitions.h
Generated on Wed Oct 8 14:02:05 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderDefinitions

Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderDefinitions Class Reference

Comrpessed combined quote message header definitions class. More...

#include <ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/CompressedCombinedQuoteMessageHeaderDefinitions.h>

List of all members.

Static Public Member Functions

static
MessageHeaderDefinitions::MessageHeader 		GetMessageHeader (const bool isComposite, const bool isUsEquityOption, const bool isCompressedSymbol)
Get the message header.
static bool | IsComposite (const MessageHeaderDefinitions::MessageHeader messageHeader)
Is composite.
static bool | IsCompressedSymbol (const MessageHeaderDefinitions::MessageHeader messageHeader)
Is compressed symbol.
static bool | IsUsEquityOption (const MessageHeaderDefinitions::MessageHeader messageHeader)
Is us equity option.
static bool | IsValidMessageType (const MessageHeaderDefinitions::MessageHeader messageHeader)
Is valid message type.

Static Public Attributes

static const size_t | MAX_SYMBOL_LENGTH = 32
The maximum symbol length.
static const
MessageHeaderDefinitions::MessageHeader 		MESSAGE_HEADER_FLAGS_COMPOSITE_BIT_MASK = static_cast<MessageHeaderDefinitions::MessageHeader>((1 << MESSAGE_HEADER_FLAGS_COMPOSITE_LENGTH) - 1)
static const size_t | MESSAGE_HEADER_FLAGS_COMPOSITE_BIT_SHIFT = MessageHeaderDefinitions::FLAGS_LENGTH - (MESSAGE_HEADER_FLAGS_COMPOSITE_OFFSET + MESSAGE_HEADER_FLAGS_COMPOSITE_LENGTH)
static const size_t | MESSAGE_HEADER_FLAGS_COMPOSITE_LENGTH = 1
The message header flags composite length.
static const size_t | MESSAGE_HEADER_FLAGS_COMPOSITE_OFFSET = 0
The message header flags composite offset.
static const
MessageHeaderDefinitions::MessageHeader 		MESSAGE_HEADER_FLAGS_COMPRESSED_SYMBOL_BIT_MASK = static_cast<MessageHeaderDefinitions::MessageHeader>((1 << MESSAGE_HEADER_FLAGS_COMPRESSED_SYMBOL_LENGTH) - 1)
static const size_t | MESSAGE_HEADER_FLAGS_COMPRESSED_SYMBOL_BIT_SHIFT = MessageHeaderDefinitions::FLAGS_LENGTH - (MESSAGE_HEADER_FLAGS_COMPRESSED_SYMBOL_OFFSET + MESSAGE_HEADER_FLAGS_COMPRESSED_SYMBOL_LENGTH)
static const size_t | MESSAGE_HEADER_FLAGS_COMPRESSED_SYMBOL_LENGTH = 1
The message header flags compressed symbol length.
static const size_t | MESSAGE_HEADER_FLAGS_COMPRESSED_SYMBOL_OFFSET = (MESSAGE_HEADER_FLAGS_US_EQUITY_OPTION_OFFSET + MESSAGE_HEADER_FLAGS_US_EQUITY_OPTION_LENGTH)
The message header flags compressed symbol offset.
static const
MessageHeaderDefinitions::MessageHeader 		MESSAGE_HEADER_FLAGS_US_EQUITY_OPTION_BIT_MASK = static_cast<MessageHeaderDefinitions::MessageHeader>((1 << MESSAGE_HEADER_FLAGS_US_EQUITY_OPTION_LENGTH) - 1)
static const size_t | MESSAGE_HEADER_FLAGS_US_EQUITY_OPTION_BIT_SHIFT = MessageHeaderDefinitions::FLAGS_LENGTH - (MESSAGE_HEADER_FLAGS_US_EQUITY_OPTION_OFFSET + MESSAGE_HEADER_FLAGS_US_EQUITY_OPTION_LENGTH)
static const size_t | MESSAGE_HEADER_FLAGS_US_EQUITY_OPTION_LENGTH = 1
The message header flags us equity option length.
static const size_t | MESSAGE_HEADER_FLAGS_US_EQUITY_OPTION_OFFSET = (MESSAGE_HEADER_FLAGS_COMPOSITE_OFFSET + MESSAGE_HEADER_FLAGS_COMPOSITE_LENGTH)
The message header flags us equity option offset.
static const MessageType | MESSAGE_TYPE = MESSAGE_TYPE_COMPRESSED_COMBINED_QUOTE
The message type.

Detailed Description

Comrpessed combined quote message header definitions class.

Definition at line 28 of file CompressedCombinedQuoteMessageHeaderDefinitions.h.

Member Function Documentation

MessageHeaderDefinitions::MessageHeader Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderDefinitions::GetMessageHeader | ( | const bool | isComposite,
 |  | const bool | isUsEquityOption,
 |  | const bool | isCompressedSymbol |
 | ) |  |  | [inline, static]

Get the message header.

Parameters:
isComposite | whether a composite message is being sent.
isUsEquityOption | whether this is a message for a US equity option.
isCompressedSymbol | whether a compressed symbol is being sent.
Returns:
the message header.

Definition at line 99 of file CompressedCombinedQuoteMessageHeaderDefinitions.h.

References Activ::ContentPlatform::Feed::MessageHeaderDefinitions::GetMessageHeader(), and MESSAGE_TYPE.

bool Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderDefinitions::IsComposite ( const MessageHeaderDefinitions::MessageHeader messageHeader ) [inline, static]

Is composite.

Parameters:
messageHeader the message header.
Returns:
whether a composite message is being sent.

Definition at line 113 of file CompressedCombinedQuoteMessageHeaderDefinitions.h.

References Activ::ContentPlatform::Feed::MessageHeaderDefinitions::GetFlags().

Referenced by Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessage::ValidateCompressedCombinedQuote().

bool Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderDefinitions::IsCompressedSymbol ( const MessageHeaderDefinitions::MessageHeader messageHeader ) [inline, static]

Is compressed symbol.

Parameters:
messageHeader the message header.
Returns:
whether a compressed symbol is included in the message.

Definition at line 127 of file CompressedCombinedQuoteMessageHeaderDefinitions.h.

References Activ::ContentPlatform::Feed::MessageHeaderDefinitions::GetFlags().

Referenced by Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessage::ValidateCompressedCombinedQuote().

bool Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderDefinitions::IsUsEquityOption ( const MessageHeaderDefinitions::MessageHeader messageHeader ) [inline, static]

Is us equity option.

Parameters:
messageHeader the message header.
Returns:
whether this is a us equity option message.

Definition at line 120 of file CompressedCombinedQuoteMessageHeaderDefinitions.h.

References Activ::ContentPlatform::Feed::MessageHeaderDefinitions::GetFlags().

Referenced by Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessage::ValidateCompressedCombinedQuote().

bool Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderDefinitions::IsValidMessageType ( const MessageHeaderDefinitions::MessageHeader messageHeader ) [inline, static]

Is valid message type.

Parameters:
messageHeader the message header.
Returns:
whether the message type is valid.

Definition at line 106 of file CompressedCombinedQuoteMessageHeaderDefinitions.h.

References Activ::ContentPlatform::Feed::MessageHeaderDefinitions::GetMessageType(), and MESSAGE_TYPE.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/CompressedCombinedQuoteMessageHeaderDefinitions.h
Generated on Wed Oct 8 14:02:05 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator

Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator Class Reference

compressed combined quote message header validator class. More...

#include <ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/CompressedCombinedQuoteMessageHeaderValidator.h>

Inheritance diagram for Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator:

Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessage

List of all members.

Public Member Functions

ACTIV_FEED_MESSAGE_HANDLER_API
std::string 		CompositeAskStateToString () const
Composite ask state copied to string.
ACTIV_FEED_MESSAGE_HANDLER_API
std::string 		CompositeBidStateToString () const
Composite bid state copied to string.
ACTIV_FEED_MESSAGE_HANDLER_API
std::string 		CompositeUpdateIdToString () const
Composite update id copied to string.
ACTIV_FEED_MESSAGE_HANDLER_API | CompressedCombinedQuoteMessageHeaderValidator (const TableTemplateList &tableTemplateList)
Constructor.
ACTIV_FEED_MESSAGE_HANDLER_API | CompressedCombinedQuoteMessageHeaderValidator (const TableTemplateList &tableTemplateList, MessageValidator &messageValidator, Activ::ContentPlatform::Feed::MessageType messageType)
Constructor.
ACTIV_FEED_MESSAGE_HANDLER_API | CompressedCombinedQuoteMessageHeaderValidator ()
Default constructor.
ACTIV_FEED_MESSAGE_HANDLER_API
std::string 		DefaultRuleSetToString () const
DefaultRuleSet copied to string.
ACTIV_FEED_MESSAGE_HANDLER_API
std::string 		EventTypeToString () const
Event type copied to string.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		GetCompositeAskState (CompressedCombinedQuoteMessageDefinitions::CompositeState &compositeAskState) const
Get the composite ask state.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		GetCompositeBidState (CompressedCombinedQuoteMessageDefinitions::CompositeState &compositeBidState) const
Get the composite bid state.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		GetCompositeUpdateId (UpdateId &compositeUpdateId) const
Get the composite update id.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		GetEventType (EventType &eventType) const
Get the event type.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		GetPermissionId (PermissionId &permissionId) const
Get the permission id.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		GetSymbol (std::string &symbol) const
Get the symbol.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		GetTableNumber (TableNo &tableNumber) const
Get the table number.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		GetTableTemplate (const TableTemplate *&pTableTemplate) const
Get the table template.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		GetUpdateId (UpdateId &updateId) const
Get the update id.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		Initialize (MessageValidator &messageValidator, Activ::ContentPlatform::Feed::MessageType messageType)
Initialize with a new header validator.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		Initialize (const TableTemplateList &tableTemplateList)
Initialize with a new table template list (and reset the object).
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		Initialize (const TableTemplateList &tableTemplateList, MessageValidator &messageValidator, Activ::ContentPlatform::Feed::MessageType messageType)
Initialize with a new table template list and header validator.
ACTIV_FEED_MESSAGE_HANDLER_API bool | IsComposite () const
Is this a composite update.
ACTIV_FEED_MESSAGE_HANDLER_API bool | IsCompositeAsk () const
Is this a composite ask update.
ACTIV_FEED_MESSAGE_HANDLER_API
std::string 		IsCompositeAskToString () const
Is this a composite ask message copied to string.
ACTIV_FEED_MESSAGE_HANDLER_API bool | IsCompositeBid () const
Is this a composite bid update.
ACTIV_FEED_MESSAGE_HANDLER_API
std::string 		IsCompositeBidToString () const
Is this a composite bid message copied to string.
ACTIV_FEED_MESSAGE_HANDLER_API
std::string 		IsCompositeToString () const
Is this a composite message copied to string.
ACTIV_FEED_MESSAGE_HANDLER_API bool | IsInitialized () const
Is the object initialized.
ACTIV_FEED_MESSAGE_HANDLER_API
std::string 		PermissionIdToString () const
Permission id copied to string.
ACTIV_FEED_MESSAGE_HANDLER_API void | Reset ()
Reset.
ACTIV_FEED_MESSAGE_HANDLER_API
std::string 		SymbolToString () const
Symbol copied to string.
ACTIV_FEED_MESSAGE_HANDLER_API
std::string 		TableTemplateIdToString () const
Table template id copied to string.
ACTIV_FEED_MESSAGE_HANDLER_API
std::string 		TableTemplateNameToString () const
Table template name copied to string.
ACTIV_FEED_MESSAGE_HANDLER_API
std::string 		ToString () const
Message Header copied to string.
ACTIV_FEED_MESSAGE_HANDLER_API
std::string 		UpdateIdToString () const
Update id copied to string.
ACTIV_FEED_MESSAGE_HANDLER_API | ~CompressedCombinedQuoteMessageHeaderValidator ()
Destructor.

Detailed Description

compressed combined quote message header validator class.

Definition at line 33 of file CompressedCombinedQuoteMessageHeaderValidator.h.

Constructor & Destructor Documentation

ACTIV_FEED_MESSAGE_HANDLER_API Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator::CompressedCombinedQuoteMessageHeaderValidator | ( | const TableTemplateList & | tableTemplateList,
 |  | MessageValidator & | messageValidator,
 |  | Activ::ContentPlatform::Feed::MessageType | messageType
 | ) |  |

Constructor.

Parameters:
tableTemplateList | the table template list.
messageValidator | the header validator.
messageType | the message type.
Exceptions:
StatusCodeException

ACTIV_FEED_MESSAGE_HANDLER_API Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator::CompressedCombinedQuoteMessageHeaderValidator ( const TableTemplateList & tableTemplateList )

Constructor.

Parameters:
tableTemplateList the table template list.
Exceptions:
StatusCodeException

Member Function Documentation

std::string Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator::CompositeAskStateToString ( ) const [inline]

Composite ask state copied to string.

Returns:
formatted string.

Definition at line 348 of file CompressedCombinedQuoteMessageHeaderValidator.h.

References Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessage::m_compositeAskState.

Referenced by ToString().

std::string Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator::CompositeBidStateToString ( ) const [inline]

Composite bid state copied to string.

Returns:
formatted string.

Definition at line 341 of file CompressedCombinedQuoteMessageHeaderValidator.h.

References Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessage::m_compositeBidState.

Referenced by ToString().

std::string Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator::CompositeUpdateIdToString ( ) const [inline]

Composite update id copied to string.

Returns:
formatted string.

Definition at line 397 of file CompressedCombinedQuoteMessageHeaderValidator.h.

References Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessage::m_compositeUpdateId.

Referenced by ToString().

ACTIV_FEED_MESSAGE_HANDLER_API std::string Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator::DefaultRuleSetToString ( ) const

DefaultRuleSet copied to string.

Returns:
formatted string.

ACTIV_FEED_MESSAGE_HANDLER_API std::string Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator::EventTypeToString ( ) const

Event type copied to string.

Returns:
formatted string.

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator::GetCompositeAskState ( CompressedCombinedQuoteMessageDefinitions::CompositeState & compositeAskState ) const

Get the composite ask state.

Parameters:
compositeAskState the composite ask state.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator::GetCompositeBidState ( CompressedCombinedQuoteMessageDefinitions::CompositeState & compositeBidState ) const

Get the composite bid state.

Parameters:
compositeBidState the composite bid state.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator::GetCompositeUpdateId ( UpdateId & compositeUpdateId ) const

Get the composite update id.

Parameters:
compositeUpdateId the composite update id.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_FAILURE
STATUS_CODE_NOT_INITIALIZED

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator::GetEventType ( EventType & eventType ) const

Get the event type.

Parameters:
eventType the event type.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator::GetPermissionId ( PermissionId & permissionId ) const

Get the permission id.

Parameters:
permissionId the permission id.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator::GetSymbol ( std::string & symbol ) const

Get the symbol.

Parameters:
symbol the symbol.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator::GetTableNumber ( TableNo & tableNumber ) const

Get the table number.

Parameters:
tableNumber the table number.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator::GetTableTemplate ( const TableTemplate *& pTableTemplate ) const

Get the table template.

Parameters:
pTableTemplate a pointer to the table template.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator::GetUpdateId ( UpdateId & updateId ) const

Get the update id.

Parameters:
updateId the update id.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_FAILURE
STATUS_CODE_NOT_INITIALIZED

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator::Initialize | ( | MessageValidator & | messageValidator,
 |  | Activ::ContentPlatform::Feed::MessageType | messageType
 | ) |  |

Initialize with a new header validator.

Parameters:
messageValidator | the header validator.
messageType | the message type.
Return values:
STATUS_CODE_SUCCESS
...

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator::Initialize ( const TableTemplateList & tableTemplateList )

Initialize with a new table template list (and reset the object).

Parameters:
tableTemplateList the table template list.
Return values:
STATUS_CODE_SUCCESS

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator::Initialize | ( | const TableTemplateList & | tableTemplateList,
 |  | MessageValidator & | messageValidator,
 |  | Activ::ContentPlatform::Feed::MessageType | messageType
 | ) |  |

Initialize with a new table template list and header validator.

Parameters:
tableTemplateList | the table template list.
messageValidator | the header validator.
messageType | the message type.
Return values:
STATUS_CODE_SUCCESS
...

ACTIV_FEED_MESSAGE_HANDLER_API bool Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator::IsComposite ( ) const

Is this a composite update.

Returns:
whether this is a composite update.

ACTIV_FEED_MESSAGE_HANDLER_API bool Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator::IsCompositeAsk ( ) const

Is this a composite ask update.

Returns:
whether this is a composite update.

std::string Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator::IsCompositeAskToString ( ) const [inline]

Is this a composite ask message copied to string.

Returns:
formatted string.

Definition at line 369 of file CompressedCombinedQuoteMessageHeaderValidator.h.

References Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessage::m_isCompositeAsk.

Referenced by ToString().

ACTIV_FEED_MESSAGE_HANDLER_API bool Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator::IsCompositeBid ( ) const

Is this a composite bid update.

Returns:
whether this is a composite update.

std::string Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator::IsCompositeBidToString ( ) const [inline]

Is this a composite bid message copied to string.

Returns:
formatted string.

Definition at line 362 of file CompressedCombinedQuoteMessageHeaderValidator.h.

References Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessage::m_isCompositeBid.

Referenced by ToString().

std::string Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator::IsCompositeToString ( ) const [inline]

Is this a composite message copied to string.

Returns:
formatted string.

Definition at line 355 of file CompressedCombinedQuoteMessageHeaderValidator.h.

References Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessage::m_isComposite.

Referenced by ToString().

ACTIV_FEED_MESSAGE_HANDLER_API bool Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator::IsInitialized ( ) const

Is the object initialized.

Returns:
whether the object is initialized.

std::string Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator::PermissionIdToString ( ) const [inline]

Permission id copied to string.

Returns:
formatted string.

Definition at line 404 of file CompressedCombinedQuoteMessageHeaderValidator.h.

References Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessage::m_permissionId.

Referenced by ToString().

std::string Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator::SymbolToString ( ) const [inline]

Symbol copied to string.

Returns:
formatted string.

Definition at line 411 of file CompressedCombinedQuoteMessageHeaderValidator.h.

References Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessage::m_symbol.

Referenced by ToString().

std::string Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator::TableTemplateIdToString ( ) const [inline]

Table template id copied to string.

Returns:
formatted string.

Definition at line 376 of file CompressedCombinedQuoteMessageHeaderValidator.h.

References Activ::ContentPlatform::Feed::TableTemplate::GetId().

Referenced by ToString().

std::string Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator::TableTemplateNameToString ( ) const [inline]

Table template name copied to string.

Returns:
formatted string.

Definition at line 383 of file CompressedCombinedQuoteMessageHeaderValidator.h.

References Activ::ContentPlatform::Feed::TableTemplate::GetName().

Referenced by ToString().

std::string Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator::ToString ( ) const [inline]

Message Header copied to string.

Returns:
formatted string.

Definition at line 418 of file CompressedCombinedQuoteMessageHeaderValidator.h.

References CompositeAskStateToString(), CompositeBidStateToString(), CompositeUpdateIdToString(), IsCompositeAskToString(), IsCompositeBidToString(), IsCompositeToString(), Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessage::m_isComposite, PermissionIdToString(), SymbolToString(), TableTemplateIdToString(), TableTemplateNameToString(), and UpdateIdToString().

std::string Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator::UpdateIdToString ( ) const [inline]

Update id copied to string.

Returns:
formatted string.

Definition at line 390 of file CompressedCombinedQuoteMessageHeaderValidator.h.

References Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessage::m_updateId.

Referenced by ToString().

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/CompressedCombinedQuoteMessageHeaderValidator.h
Generated on Wed Oct 8 14:02:05 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::CompressedMessage

Activ::ContentPlatform::Feed::CompressedMessage Class Reference

Compressed message class. More...

#include <ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/CompressedMessage.h>

Inheritance diagram for Activ::ContentPlatform::Feed::CompressedMessage:

Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator

List of all members.

Public Member Functions

StatusCode | ValidateCompressed (MessageValidator &messageValidator)
Validate the message header.

Protected Attributes

UpdateId | m_compositeUpdateId
The composite update id.
bool | m_isComposite
Indicates whether this is a composite update.
bool | m_isDelete
Indicates whether this is a delete message.
PermissionId | m_permissionId
The permission id of the message.
std::string | m_symbol
The symbol.
TableNo | m_tableNumber
The table number.
UpdateId | m_updateId
The update id.

Detailed Description

Compressed message class.

Definition at line 29 of file CompressedMessage.h.

Member Function Documentation

StatusCode Activ::ContentPlatform::Feed::CompressedMessage::ValidateCompressed ( MessageValidator & messageValidator ) [inline]

Validate the message header.

Parameters:
messageValidator the message validator.
Return values:
STATUS_CODE_SUCCESS
...

Definition at line 59 of file CompressedMessage.h.

References ACTIV_RETURN_RESULT_IF, Activ::ContentPlatform::Feed::Symbol::Deserialize(), Activ::ContentPlatform::Feed::CompressedSymbol::Deserialize(), Activ::MessageHandler::ENDIAN_LITTLE, Activ::ContentPlatform::Feed::CompressedMessageDefinitions::GetShortTableNumber(), Activ::ContentPlatform::Feed::CompressedMessageHeaderDefinitions::IsComposite(), Activ::ContentPlatform::Feed::CompressedMessageDefinitions::IsCompressedSymbolDefined(), Activ::ContentPlatform::Feed::CompressedMessageHeaderDefinitions::IsDelete(), Activ::ContentPlatform::Feed::CompressedMessageDefinitions::IsPermissionIdDefined(), m_compositeUpdateId, m_isComposite, m_isDelete, m_permissionId, m_symbol, m_tableNumber, m_updateId, Activ::ContentPlatform::Feed::CompressedMessageHeaderDefinitions::MAX_SYMBOL_LENGTH, and Activ::MessageValidator::ValidateBinaryIntegral().

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/CompressedMessage.h
Generated on Wed Oct 8 14:02:05 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::CompressedMessageDefinitions

Activ::ContentPlatform::Feed::CompressedMessageDefinitions Class Reference

Compressed message definitions class. More...

#include <ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/CompressedMessageDefinitions.h>

Inheritance diagram for Activ::ContentPlatform::Feed::CompressedMessageDefinitions:

Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageDefinitions

List of all members.

Public Types

typedef uint8_t | CompressedNumeratorLength
Compressed numerator length type definition.
enum | FieldState { FIELD_STATE_SAME_AS_PREVIOUS, FIELD_STATE_SAME_AS_TWIN, FIELD_STATE_UNDEFINED, FIELD_STATE_DIFFERENT }
Field state enumeration.
typedef uint8_t | Header
Header type definition.

Static Public Member Functions

static CompressedNumeratorLength | GetCompressedNumeratorLength (const size_t numeratorLength)
Get the compressed numerator length from the actual numerator length.
static Header | GetHeader (const TableNo tableNumber, const bool isPermissionIdDefined, const bool isCompressedSymbolDefined)
Get the header.
static size_t | GetNumeratorLength (const CompressedNumeratorLength compressedNumeratorLength)
Get the actual length of the numerator from the compressed version.
static bool | GetShortTableNumber (const Header header, TableNo &tableNumber)
Get the short table number from a header.
static bool | IsCompressedSymbolDefined (const Header header)
Is compressed symbol defined.
static bool | IsPermissionIdDefined (const Header header)
Is permission id defined.
static bool | IsShortTableNumber (const TableNo tableNumber)
Is short table number.
static bool | IsShortTableNumberDefined (const Header header)
Is short table number defined.

Static Public Attributes

static const byte_t | FIELD_HEADER_BIT_MASK = (1 << FIELD_HEADER_LENGTH) - 1
static const size_t | FIELD_HEADER_LENGTH = 2
static const size_t | FIELD_HEADERS_PER_BYTE = sizeof(byte_t) * CHAR_BIT / FIELD_HEADER_LENGTH
static const Header | HEADER_COMPRESSED_SYMBOL_DEFINED_BIT_MASK = (1 << HEADER_FLAGS_COMPRESSED_SYMBOL_DEFINED_LENGTH) - 1
static const size_t | HEADER_COMPRESSED_SYMBOL_DEFINED_BIT_SHIFT = (sizeof(Header) * CHAR_BIT - (HEADER_FLAGS_COMPRESSED_SYMBOL_DEFINED_OFFSET + HEADER_FLAGS_COMPRESSED_SYMBOL_DEFINED_LENGTH))
static const size_t | HEADER_FLAGS_COMPRESSED_SYMBOL_DEFINED_LENGTH = 1
static const size_t | HEADER_FLAGS_COMPRESSED_SYMBOL_DEFINED_OFFSET = (HEADER_FLAGS_PERMISSION_ID_DEFINED_OFFSET + HEADER_FLAGS_PERMISSION_ID_DEFINED_LENGTH)
static const size_t | HEADER_FLAGS_PERMISSION_ID_DEFINED_LENGTH = 1
static const size_t | HEADER_FLAGS_PERMISSION_ID_DEFINED_OFFSET = (HEADER_FLAGS_SHORT_TABLE_NUMBER_DEFINED_LENGTH + HEADER_FLAGS_SHORT_TABLE_NUMBER_DEFINED_OFFSET)
static const size_t | HEADER_FLAGS_RESERVED_LENGTH = 1
static const size_t | HEADER_FLAGS_RESERVED_OFFSET = (HEADER_FLAGS_COMPRESSED_SYMBOL_DEFINED_OFFSET + HEADER_FLAGS_COMPRESSED_SYMBOL_DEFINED_LENGTH)
static const size_t | HEADER_FLAGS_SHORT_TABLE_NUMBER_DEFINED_LENGTH = 1
static const size_t | HEADER_FLAGS_SHORT_TABLE_NUMBER_DEFINED_OFFSET = 0
static const size_t | HEADER_FLAGS_SHORT_TABLE_NUMBER_LENGTH = 4
static const size_t | HEADER_FLAGS_SHORT_TABLE_NUMBER_OFFSET = (HEADER_FLAGS_RESERVED_OFFSET + HEADER_FLAGS_RESERVED_LENGTH)
static const Header | HEADER_PERMISSION_ID_DEFINED_BIT_MASK = (1 << HEADER_FLAGS_PERMISSION_ID_DEFINED_LENGTH) - 1
static const size_t | HEADER_PERMISSION_ID_DEFINED_BIT_SHIFT = (sizeof(Header) * CHAR_BIT - (HEADER_FLAGS_PERMISSION_ID_DEFINED_OFFSET + HEADER_FLAGS_PERMISSION_ID_DEFINED_LENGTH))
static const Header | HEADER_SHORT_TABLE_NUMBER_BIT_MASK = (1 << HEADER_FLAGS_SHORT_TABLE_NUMBER_LENGTH) - 1
static const size_t | HEADER_SHORT_TABLE_NUMBER_BIT_SHIFT = (sizeof(Header) * CHAR_BIT - (HEADER_FLAGS_SHORT_TABLE_NUMBER_OFFSET + HEADER_FLAGS_SHORT_TABLE_NUMBER_LENGTH))
static const Header | HEADER_SHORT_TABLE_NUMBER_DEFINED_BIT_MASK = (1 << HEADER_FLAGS_SHORT_TABLE_NUMBER_DEFINED_LENGTH) - 1
static const size_t | HEADER_SHORT_TABLE_NUMBER_DEFINED_BIT_SHIFT = (sizeof(Header) * CHAR_BIT - (HEADER_FLAGS_SHORT_TABLE_NUMBER_DEFINED_OFFSET + HEADER_FLAGS_SHORT_TABLE_NUMBER_DEFINED_LENGTH))
static const
CompressedNumeratorLength 		NUMERATOR_LENGTH_16_BITS = 1
The compressed length of 16 bit numerators.
static const
CompressedNumeratorLength 		NUMERATOR_LENGTH_32_BITS = 2
The compressed length of 32 bit numerators.
static const
CompressedNumeratorLength 		NUMERATOR_LENGTH_64_BITS = 3
The compressed length of 64 bit numerators.
static const
CompressedNumeratorLength 		NUMERATOR_LENGTH_8_BITS = 0
The compressed length of 8 bit numerators.

Classes

class | FieldHeaderBuilder
Field header builder class. More...
class | FieldHeaderValidator
Field header validator class. More...
class | FieldSpecification
Field specification class. More...

Detailed Description

Compressed message definitions class.

Definition at line 37 of file CompressedMessageDefinitions.h.

Member Function Documentation

CompressedMessageDefinitions::CompressedNumeratorLength Activ::ContentPlatform::Feed::CompressedMessageDefinitions::GetCompressedNumeratorLength ( const size_t numeratorLength ) [inline, static]

Get the compressed numerator length from the actual numerator length.

Parameters:
numeratorLength the numerator length.
Returns:
the compressed numerator length.

Definition at line 330 of file CompressedMessageDefinitions.h.

References NUMERATOR_LENGTH_16_BITS, NUMERATOR_LENGTH_32_BITS, NUMERATOR_LENGTH_64_BITS, and NUMERATOR_LENGTH_8_BITS.

CompressedMessageDefinitions::Header Activ::ContentPlatform::Feed::CompressedMessageDefinitions::GetHeader | ( | const TableNo | tableNumber,
 |  | const bool | isPermissionIdDefined,
 |  | const bool | isCompressedSymbolDefined |
 | ) |  |  | [inline, static]

Get the header.

Parameters:
tableNumber | the table number.
isPermissionIdDefined | whether a permission id will be included in the message.
isCompressedSymbolDefined | whether a compressed symbol will be included in the message.
Returns:
the header.

Definition at line 303 of file CompressedMessageDefinitions.h.

size_t Activ::ContentPlatform::Feed::CompressedMessageDefinitions::GetNumeratorLength ( const CompressedNumeratorLength compressedNumeratorLength ) [inline, static]

Get the actual length of the numerator from the compressed version.

Parameters:
compressedNumeratorLength
Returns:
the actual numerator length.

Definition at line 323 of file CompressedMessageDefinitions.h.

bool Activ::ContentPlatform::Feed::CompressedMessageDefinitions::GetShortTableNumber | ( | const Header | header,
 |  | TableNo & | tableNumber |
 | ) |  |  | [inline, static]

Get the short table number from a header.

Parameters:
header | the header.
tableNumber | the table number.
Returns:
true if the header contains a short table number, false otherwise.

Definition at line 310 of file CompressedMessageDefinitions.h.

References IsShortTableNumberDefined().

Referenced by Activ::ContentPlatform::Feed::CompressedMessage::ValidateCompressed().

bool Activ::ContentPlatform::Feed::CompressedMessageDefinitions::IsCompressedSymbolDefined ( const Header header ) [inline, static]

Is compressed symbol defined.

Parameters:
header the header.
Returns:
whether a compressed symbol is present in the message.

Definition at line 373 of file CompressedMessageDefinitions.h.

Referenced by Activ::ContentPlatform::Feed::CompressedMessage::ValidateCompressed().

bool Activ::ContentPlatform::Feed::CompressedMessageDefinitions::IsPermissionIdDefined ( const Header header ) [inline, static]

Is permission id defined.

Parameters:
header the header.
Returns:
whether a permission id is present in the message.

Definition at line 366 of file CompressedMessageDefinitions.h.

Referenced by Activ::ContentPlatform::Feed::CompressedMessage::ValidateCompressed().

bool Activ::ContentPlatform::Feed::CompressedMessageDefinitions::IsShortTableNumber ( const TableNo tableNumber ) [inline, static]

Is short table number.

Parameters:
tableNumber the table number to check.
Returns:
whether the supplied table number is short.

Definition at line 359 of file CompressedMessageDefinitions.h.

bool Activ::ContentPlatform::Feed::CompressedMessageDefinitions::IsShortTableNumberDefined ( const Header header ) [inline, static]

Is short table number defined.

Parameters:
header the header.
Returns:
whether the header contains a short table number.

Definition at line 352 of file CompressedMessageDefinitions.h.

Referenced by GetShortTableNumber().

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/CompressedMessageDefinitions.h
Generated on Wed Oct 8 14:02:05 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::CompressedMessageDefinitions::FieldHeaderBuilder

Activ::ContentPlatform::Feed::CompressedMessageDefinitions::FieldHeaderBuilder Class Reference

Field header builder class. More...

#include <ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/CompressedMessageDefinitions.h>

List of all members.

Public Member Functions

void | Append (byte_t *&pMessage)
Append.
FieldHeaderBuilder ()
Default constructor.
void | Initialize (const size_t nFieldHeaders, const size_t startingBitOffset=0)
Initialize.
void | Serialize (const CompressedNumeratorLength compressedNumeratorLength)
Serialize a compressed numerator length.
void | Serialize (const FieldState fieldState)
Serialize a field state.

Detailed Description

Field header builder class.

Definition at line 113 of file CompressedMessageDefinitions.h.

Member Function Documentation

void Activ::ContentPlatform::Feed::CompressedMessageDefinitions::FieldHeaderBuilder::Append ( byte_t *& pMessage ) [inline]

Append.

Pointer to the message is incremented by the required number of bytes as determined by the number of field headers.

Parameters:
pMessage reference to a pointer to the current position in the message.

Definition at line 417 of file CompressedMessageDefinitions.h.

void Activ::ContentPlatform::Feed::CompressedMessageDefinitions::FieldHeaderBuilder::Initialize | ( | const size_t | nFieldHeaders,
 |  | const size_t | startingBitOffset = 0 |
 | ) |  |  | [inline]

Initialize.

Parameters:
nFieldHeaders | the number of field headers.
startingBitOffset | the starting offset within the current byte.

Definition at line 409 of file CompressedMessageDefinitions.h.

void Activ::ContentPlatform::Feed::CompressedMessageDefinitions::FieldHeaderBuilder::Serialize ( const CompressedNumeratorLength compressedNumeratorLength ) [inline]

Serialize a compressed numerator length.

Parameters:
compressedNumeratorLength the compressed numerator length.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_OUT_OF_RANGE

Definition at line 445 of file CompressedMessageDefinitions.h.

void Activ::ContentPlatform::Feed::CompressedMessageDefinitions::FieldHeaderBuilder::Serialize ( const FieldState fieldState ) [inline]

Serialize a field state.

Parameters:
fieldState the field state.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_OUT_OF_RANGE

Definition at line 427 of file CompressedMessageDefinitions.h.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/CompressedMessageDefinitions.h
Generated on Wed Oct 8 14:02:05 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::CompressedMessageDefinitions::FieldHeaderValidator

Activ::ContentPlatform::Feed::CompressedMessageDefinitions::FieldHeaderValidator Class Reference

Field header validator class. More...

#include <ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/CompressedMessageDefinitions.h>

List of all members.

Public Member Functions

void | Deserialize (CompressedNumeratorLength &compressedNumeratorLength)
Deserialize a numerator length.
void | Deserialize (FieldState &fieldState)
Deserialize a field state.
FieldHeaderValidator ()
Default constructor.
void | Initialize (const size_t nFieldHeaders, const size_t startingBitOffset=0)
Initialize.
StatusCode | Validate (MessageValidator &messageValidator)
Validate.

Detailed Description

Field header validator class.

Definition at line 170 of file CompressedMessageDefinitions.h.

Member Function Documentation

void Activ::ContentPlatform::Feed::CompressedMessageDefinitions::FieldHeaderValidator::Deserialize ( CompressedNumeratorLength & compressedNumeratorLength ) [inline]

Deserialize a numerator length.

Parameters:
compressedNumeratorLength set equal to the deserialized compressed numerator length.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_OUT_OF_RANGE

Definition at line 510 of file CompressedMessageDefinitions.h.

void Activ::ContentPlatform::Feed::CompressedMessageDefinitions::FieldHeaderValidator::Deserialize ( FieldState & fieldState ) [inline]

Deserialize a field state.

Parameters:
fieldState set equal to the deserialized field state.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_OUT_OF_RANGE

Definition at line 495 of file CompressedMessageDefinitions.h.

void Activ::ContentPlatform::Feed::CompressedMessageDefinitions::FieldHeaderValidator::Initialize | ( | const size_t | nFieldHeaders,
 |  | const size_t | startingBitOffset = 0 |
 | ) |  |  | [inline]

Initialize.

Parameters:
nFieldHeaders | the number of field headers.
startingBitOffset | the starting offset within the current byte.

Definition at line 475 of file CompressedMessageDefinitions.h.

StatusCode Activ::ContentPlatform::Feed::CompressedMessageDefinitions::FieldHeaderValidator::Validate ( MessageValidator & messageValidator ) [inline]

Validate.

Parameters:
messageValidator the message validator.
Return values:
STATUS_CODE_SUCCESS
...

Definition at line 483 of file CompressedMessageDefinitions.h.

References Activ::MessageValidator::GetMessage(), Activ::MessageValidator::GetOffset(), and Activ::MessageValidator::ValidateBytes().

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/CompressedMessageDefinitions.h
Generated on Wed Oct 8 14:02:05 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::CompressedMessageDefinitions::FieldSpecification

Activ::ContentPlatform::Feed::CompressedMessageDefinitions::FieldSpecification Class Reference

Field specification class. More...

#include <ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/CompressedMessageDefinitions.h>

List of all members.

Public Member Functions

FieldSpecification (const FieldId fieldId, const bool isSizeField, const FieldId twinFieldId=FID_UNDEFINED)
Constructor.
size_t | GetNumberOfFieldHeaders () const
Get the number of field headers.

Public Attributes

const FieldId | m_fieldId
The id of the field.
const bool | m_isSizeField
Whether this is a size field.
const FieldId | m_twinFieldId
The id of the twin field.

Detailed Description

Field specification class.

Definition at line 86 of file CompressedMessageDefinitions.h.

Constructor & Destructor Documentation

Activ::ContentPlatform::Feed::CompressedMessageDefinitions::FieldSpecification::FieldSpecification | ( | const FieldId | fieldId,
 |  | const bool | isSizeField,
 |  | const FieldId | twinFieldId = FID_UNDEFINED |
 | ) |  |  | [inline]

Constructor.

Parameters:
fieldId | the id of the field.
isSizeField | whether the field is a size field.
twinFieldId | the id of the twin field.

Definition at line 381 of file CompressedMessageDefinitions.h.

Member Function Documentation

size_t Activ::ContentPlatform::Feed::CompressedMessageDefinitions::FieldSpecification::GetNumberOfFieldHeaders ( ) const [inline]

Get the number of field headers.

Returns:
the number of field headers used by the field specification.

Definition at line 390 of file CompressedMessageDefinitions.h.

References m_isSizeField.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/CompressedMessageDefinitions.h
Generated on Wed Oct 8 14:02:05 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::CompressedMessageHeaderDefinitions

Activ::ContentPlatform::Feed::CompressedMessageHeaderDefinitions Class Reference

Compressed message header definitions class. More...

#include <ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/CompressedMessageHeaderDefinitions.h>

List of all members.

Static Public Member Functions

static
MessageHeaderDefinitions::MessageHeader 		GetMessageHeader (const bool isDelete, const bool isComposite, const MessageType messageType)
Get the message header.
static bool | IsComposite (const MessageHeaderDefinitions::MessageHeader messageHeader)
Is this a composite message.
static bool | IsDelete (const MessageHeaderDefinitions::MessageHeader messageHeader)
Is this a delete message.
static bool | IsValidMessageType (const MessageHeaderDefinitions::MessageHeader messageHeader, const MessageType messageType)
Is valid message type.

Static Public Attributes

static const size_t | MAX_SYMBOL_LENGTH = 32
The maximum symbol length.
static const
MessageHeaderDefinitions::MessageHeader 		MESSAGE_HEADER_FLAGS_COMPOSITE_BIT_MASK = static_cast<MessageHeaderDefinitions::MessageHeader>((1 << MESSAGE_HEADER_FLAGS_COMPOSITE_LENGTH) - 1)
static const size_t | MESSAGE_HEADER_FLAGS_COMPOSITE_BIT_SHIFT = MessageHeaderDefinitions::FLAGS_LENGTH - (MESSAGE_HEADER_FLAGS_COMPOSITE_OFFSET + MESSAGE_HEADER_FLAGS_COMPOSITE_LENGTH)
static const size_t | MESSAGE_HEADER_FLAGS_COMPOSITE_LENGTH = 1
The message header flags composite length.
static const size_t | MESSAGE_HEADER_FLAGS_COMPOSITE_OFFSET = (MESSAGE_HEADER_FLAGS_DELETE_OFFSET + MESSAGE_HEADER_FLAGS_DELETE_LENGTH)
The message header flags composite offset.
static const
MessageHeaderDefinitions::MessageHeader 		MESSAGE_HEADER_FLAGS_DELETE_BIT_MASK = static_cast<MessageHeaderDefinitions::MessageHeader>((1 << MESSAGE_HEADER_FLAGS_DELETE_LENGTH) - 1)
static const size_t | MESSAGE_HEADER_FLAGS_DELETE_BIT_SHIFT = MessageHeaderDefinitions::FLAGS_LENGTH - (MESSAGE_HEADER_FLAGS_DELETE_OFFSET + MESSAGE_HEADER_FLAGS_DELETE_LENGTH)
static const size_t | MESSAGE_HEADER_FLAGS_DELETE_LENGTH = 1
The message header flags delete length.
static const size_t | MESSAGE_HEADER_FLAGS_DELETE_OFFSET = 0
The message header flags delete offset.

Detailed Description

Compressed message header definitions class.

Definition at line 28 of file CompressedMessageHeaderDefinitions.h.

Member Function Documentation

MessageHeaderDefinitions::MessageHeader Activ::ContentPlatform::Feed::CompressedMessageHeaderDefinitions::GetMessageHeader | ( | const bool | isDelete,
 |  | const bool | isComposite,
 |  | const MessageType | messageType |
 | ) |  |  | [inline, static]

Get the message header.

Parameters:
isDelete | whether this is a delete message.
isComposite | whether this is a composite message.
messageType | the message type.
Returns:
the message header.

Definition at line 85 of file CompressedMessageHeaderDefinitions.h.

References Activ::ContentPlatform::Feed::MessageHeaderDefinitions::GetMessageHeader().

bool Activ::ContentPlatform::Feed::CompressedMessageHeaderDefinitions::IsComposite ( const MessageHeaderDefinitions::MessageHeader messageHeader ) [inline, static]

Is this a composite message.

Parameters:
messageHeader the message header.
Returns:
whether this is a composite message.

Definition at line 106 of file CompressedMessageHeaderDefinitions.h.

References Activ::ContentPlatform::Feed::MessageHeaderDefinitions::GetFlags().

Referenced by Activ::ContentPlatform::Feed::CompressedMessage::ValidateCompressed().

bool Activ::ContentPlatform::Feed::CompressedMessageHeaderDefinitions::IsDelete ( const MessageHeaderDefinitions::MessageHeader messageHeader ) [inline, static]

Is this a delete message.

Parameters:
messageHeader the message header.
Returns:
whether this is a delete message.

Definition at line 99 of file CompressedMessageHeaderDefinitions.h.

References Activ::ContentPlatform::Feed::MessageHeaderDefinitions::GetFlags().

Referenced by Activ::ContentPlatform::Feed::CompressedMessage::ValidateCompressed().

bool Activ::ContentPlatform::Feed::CompressedMessageHeaderDefinitions::IsValidMessageType | ( | const MessageHeaderDefinitions::MessageHeader | messageHeader,
 |  | const MessageType | messageType |
 | ) |  |  | [inline, static]

Is valid message type.

Parameters:
messageHeader | the message header.
messageType | the message type.
Returns:
whether the message type is valid.

Definition at line 92 of file CompressedMessageHeaderDefinitions.h.

References Activ::ContentPlatform::Feed::MessageHeaderDefinitions::GetMessageType().

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/CompressedMessageHeaderDefinitions.h
Generated on Wed Oct 8 14:02:06 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator

Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator Class Reference

compressed message header validator class. More...

#include <ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/CompressedMessageHeaderValidator.h>

Inheritance diagram for Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator:

Activ::ContentPlatform::Feed::CompressedMessage

List of all members.

Public Member Functions

ACTIV_FEED_MESSAGE_HANDLER_API
std::string 		CompositeUpdateIdToString () const
Composite Update ID copied to string.
ACTIV_FEED_MESSAGE_HANDLER_API | CompressedMessageHeaderValidator (const TableTemplateList &tableTemplateList)
Constructor.
ACTIV_FEED_MESSAGE_HANDLER_API | CompressedMessageHeaderValidator (const TableTemplateList &tableTemplateList, MessageValidator &messageValidator, Activ::ContentPlatform::Feed::MessageType messageType)
Constructor.
ACTIV_FEED_MESSAGE_HANDLER_API | CompressedMessageHeaderValidator ()
Default constructor.
ACTIV_FEED_MESSAGE_HANDLER_API
std::string 		DefaultRuleSetToString () const
DefaultRuleSet copied to string.
ACTIV_FEED_MESSAGE_HANDLER_API
std::string 		EventTypeToString () const
EventType copied to string.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		GetCompositeUpdateId (UpdateId &compositeUpdateId) const
Get the composite update id.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		GetEventType (EventType &eventType) const
Get the event type.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		GetPermissionId (PermissionId &permissionId) const
Get the permission id.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		GetSymbol (std::string &symbol) const
Get the symbol.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		GetTableNumber (TableNo &tableNumber) const
Get the table number.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		GetTableTemplate (const TableTemplate *&pTableTemplate) const
Get the table template.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		GetUpdateId (UpdateId &updateId) const
Get the update id.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		Initialize (MessageValidator &messageValidator, Activ::ContentPlatform::Feed::MessageType messageType)
Initialize with a new header validator.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		Initialize (const TableTemplateList &tableTemplateList)
Initialize with a new table template list (and reset the object).
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		Initialize (const TableTemplateList &tableTemplateList, MessageValidator &messageValidator, Activ::ContentPlatform::Feed::MessageType messageType)
Initialize with a new table template list and header validator.
ACTIV_FEED_MESSAGE_HANDLER_API bool | IsComposite () const
Is this a composite update.
ACTIV_FEED_MESSAGE_HANDLER_API
std::string 		IsCompositeToString () const
Is this a composite message copied to string.
ACTIV_FEED_MESSAGE_HANDLER_API bool | IsDelete () const
Is this a delete message.
ACTIV_FEED_MESSAGE_HANDLER_API
std::string 		IsDeleteToString () const
Convert message header to string.
ACTIV_FEED_MESSAGE_HANDLER_API bool | IsInitialized () const
Is the object initialized.
ACTIV_FEED_MESSAGE_HANDLER_API
std::string 		PermissionIdToString () const
Permission ID copied to string.
ACTIV_FEED_MESSAGE_HANDLER_API void | Reset ()
Reset.
ACTIV_FEED_MESSAGE_HANDLER_API
std::string 		SymbolToString () const
Symbol copied to string.
ACTIV_FEED_MESSAGE_HANDLER_API
std::string 		TableTemplateIdToString () const
TableTemplate ID copied to string.
ACTIV_FEED_MESSAGE_HANDLER_API
std::string 		TableTemplateNameToString () const
TableTemplate Name copied to string.
ACTIV_FEED_MESSAGE_HANDLER_API
std::string 		ToString () const
Message Header copied to string.
ACTIV_FEED_MESSAGE_HANDLER_API
std::string 		UpdateIdToString () const
Update ID copied to string.
ACTIV_FEED_MESSAGE_HANDLER_API | ~CompressedMessageHeaderValidator ()
Destructor.

Detailed Description

compressed message header validator class.

Definition at line 35 of file CompressedMessageHeaderValidator.h.

Constructor & Destructor Documentation

ACTIV_FEED_MESSAGE_HANDLER_API Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator::CompressedMessageHeaderValidator | ( | const TableTemplateList & | tableTemplateList,
 |  | MessageValidator & | messageValidator,
 |  | Activ::ContentPlatform::Feed::MessageType | messageType
 | ) |  |

Constructor.

Parameters:
tableTemplateList | the table template list.
messageValidator | the header validator.
messageType | the message type.
Exceptions:
StatusCodeException

ACTIV_FEED_MESSAGE_HANDLER_API Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator::CompressedMessageHeaderValidator ( const TableTemplateList & tableTemplateList )

Constructor.

Parameters:
tableTemplateList the table template list.
Exceptions:
StatusCodeException

Member Function Documentation

std::string Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator::CompositeUpdateIdToString ( ) const [inline]

Composite Update ID copied to string.

Returns:
formatted string

Definition at line 330 of file CompressedMessageHeaderValidator.h.

References Activ::ContentPlatform::Feed::CompressedMessage::m_compositeUpdateId.

Referenced by ToString().

ACTIV_FEED_MESSAGE_HANDLER_API std::string Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator::DefaultRuleSetToString ( ) const

DefaultRuleSet copied to string.

Returns:
formatted string

ACTIV_FEED_MESSAGE_HANDLER_API std::string Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator::EventTypeToString ( ) const

EventType copied to string.

Returns:
formatted string

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator::GetCompositeUpdateId ( UpdateId & compositeUpdateId ) const

Get the composite update id.

Parameters:
compositeUpdateId the composite update id.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_FAILURE
STATUS_CODE_NOT_INITIALIZED

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator::GetEventType ( EventType & eventType ) const

Get the event type.

Parameters:
eventType the event type.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator::GetPermissionId ( PermissionId & permissionId ) const

Get the permission id.

Parameters:
permissionId the permission id.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator::GetSymbol ( std::string & symbol ) const

Get the symbol.

Parameters:
symbol the symbol.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator::GetTableNumber ( TableNo & tableNumber ) const

Get the table number.

Parameters:
tableNumber the table number.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator::GetTableTemplate ( const TableTemplate *& pTableTemplate ) const

Get the table template.

Parameters:
pTableTemplate a pointer to the table template.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator::GetUpdateId ( UpdateId & updateId ) const

Get the update id.

Parameters:
updateId the update id.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_FAILURE
STATUS_CODE_NOT_INITIALIZED

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator::Initialize | ( | MessageValidator & | messageValidator,
 |  | Activ::ContentPlatform::Feed::MessageType | messageType
 | ) |  |

Initialize with a new header validator.

Parameters:
messageValidator | the header validator.
messageType | the message type.
Return values:
STATUS_CODE_SUCCESS
...

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator::Initialize ( const TableTemplateList & tableTemplateList )

Initialize with a new table template list (and reset the object).

Parameters:
tableTemplateList the table template list.
Return values:
STATUS_CODE_SUCCESS

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator::Initialize | ( | const TableTemplateList & | tableTemplateList,
 |  | MessageValidator & | messageValidator,
 |  | Activ::ContentPlatform::Feed::MessageType | messageType
 | ) |  |

Initialize with a new table template list and header validator.

Parameters:
tableTemplateList | the table template list.
messageValidator | the header validator.
messageType | the message type.
Return values:
STATUS_CODE_SUCCESS
...

ACTIV_FEED_MESSAGE_HANDLER_API bool Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator::IsComposite ( ) const

Is this a composite update.

Returns:
whether this is a composite update.

std::string Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator::IsCompositeToString ( ) const [inline]

Is this a composite message copied to string.

Returns:
formatted string

Definition at line 302 of file CompressedMessageHeaderValidator.h.

References Activ::ContentPlatform::Feed::CompressedMessage::m_isComposite.

Referenced by ToString().

ACTIV_FEED_MESSAGE_HANDLER_API bool Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator::IsDelete ( ) const

Is this a delete message.

Returns:
whether this is a delete message.

std::string Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator::IsDeleteToString ( ) const [inline]

Convert message header to string.

Returns:
formatted string

Definition at line 295 of file CompressedMessageHeaderValidator.h.

References Activ::ContentPlatform::Feed::CompressedMessage::m_isDelete.

Referenced by ToString().

ACTIV_FEED_MESSAGE_HANDLER_API bool Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator::IsInitialized ( ) const

Is the object initialized.

Returns:
whether the object is initialized.

std::string Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator::PermissionIdToString ( ) const [inline]

Permission ID copied to string.

Returns:
formatted string

Definition at line 337 of file CompressedMessageHeaderValidator.h.

References Activ::ContentPlatform::Feed::CompressedMessage::m_permissionId.

Referenced by ToString().

std::string Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator::SymbolToString ( ) const [inline]

Symbol copied to string.

Returns:
formatted string

Definition at line 344 of file CompressedMessageHeaderValidator.h.

References Activ::ContentPlatform::Feed::CompressedMessage::m_symbol.

Referenced by ToString().

std::string Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator::TableTemplateIdToString ( ) const [inline]

TableTemplate ID copied to string.

Returns:
formatted string

Definition at line 309 of file CompressedMessageHeaderValidator.h.

References Activ::ContentPlatform::Feed::TableTemplate::GetId().

Referenced by ToString().

std::string Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator::TableTemplateNameToString ( ) const [inline]

TableTemplate Name copied to string.

Returns:
formatted string

Definition at line 316 of file CompressedMessageHeaderValidator.h.

References Activ::ContentPlatform::Feed::TableTemplate::GetName().

Referenced by ToString().

std::string Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator::ToString ( ) const [inline]

Message Header copied to string.

Returns:
formatted string

Definition at line 351 of file CompressedMessageHeaderValidator.h.

References CompositeUpdateIdToString(), IsCompositeToString(), IsDeleteToString(), Activ::ContentPlatform::Feed::CompressedMessage::m_isComposite, Activ::ContentPlatform::Feed::CompressedMessage::m_isDelete, PermissionIdToString(), SymbolToString(), TableTemplateIdToString(), TableTemplateNameToString(), and UpdateIdToString().

std::string Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator::UpdateIdToString ( ) const [inline]

Update ID copied to string.

Returns:
formatted string

Definition at line 323 of file CompressedMessageHeaderValidator.h.

References Activ::ContentPlatform::Feed::CompressedMessage::m_updateId.

Referenced by ToString().

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/CompressedMessageHeaderValidator.h
Generated on Wed Oct 8 14:02:06 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::CompressedSymbol

Activ::ContentPlatform::Feed::CompressedSymbol Class Reference

Compressed symbol class. More...

#include <ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/CompressedSymbol.h>

List of all members.

Static Public Member Functions

static StatusCode | Deserialize (const TableNo tableNumber, MessageValidator &messageValidator, std::string &symbol)
Deserialize the supplied symbol.
static StatusCode | Serialize (const Feed::TableNo tableNumber, byte_t *&pMessage, const std::string &symbol)
Serialize the supplied symbol.

Detailed Description

Compressed symbol class.

Definition at line 30 of file CompressedSymbol.h.

Member Function Documentation

StatusCode Activ::ContentPlatform::Feed::CompressedSymbol::Deserialize | ( | const TableNo | tableNumber,
 |  | MessageValidator & | messageValidator,
 |  | std::string & | symbol |
 | ) |  |  | [inline, static]

Deserialize the supplied symbol.

Parameters:
tableNumber | the table number.
messageValidator | the message validator.
symbol | set equal to the deserialized symbol.
Return values:
STATUS_CODE_SUCCESS.
...

Definition at line 135 of file CompressedSymbol.h.

References Activ::ContentPlatform::Feed::CompressedUsEquityOptionSymbol::Deserialize().

Referenced by Activ::ContentPlatform::Feed::CompressedMessage::ValidateCompressed(), and Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessage::ValidateCompressedCombinedQuote().

StatusCode Activ::ContentPlatform::Feed::CompressedSymbol::Serialize | ( | const Feed::TableNo | tableNumber,
 |  | byte_t *& | pMessage,
 |  | const std::string & | symbol |
 | ) |  |  | [inline, static]

Serialize the supplied symbol.

Parameters:
tableNumber | the table number.
pMessage | the message to serialize the symbol into.
symbol | the symbol to serialize.
Return values:
STATUS_CODE_SUCCESS.
...

Definition at line 128 of file CompressedSymbol.h.

References Activ::ContentPlatform::Feed::CompressedUsEquityOptionSymbol::Serialize().

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/CompressedSymbol.h
Generated on Wed Oct 8 14:02:06 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::CompressedUsEquityOptionSymbol

Activ::ContentPlatform::Feed::CompressedUsEquityOptionSymbol Class Reference

Compressed us equity option symbol class. More...

#include <ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/CompressedUsEquityOptionSymbol.h>

List of all members.

Static Public Member Functions

static StatusCode | Deserialize (MessageValidator &messageValidator, std::string &symbol)
Serialize the supplied symbol.
static StatusCode | Serialize (byte_t *&pMessage, const std::string &symbol)
Serialize the supplied symbol.

Classes

class | CStringLessFunctor
C string less than comparision function object.

Detailed Description

Compressed us equity option symbol class.

Definition at line 28 of file CompressedUsEquityOptionSymbol.h.

Member Function Documentation

static StatusCode Activ::ContentPlatform::Feed::CompressedUsEquityOptionSymbol::Deserialize | ( | MessageValidator & | messageValidator,
 |  | std::string & | symbol |
 | ) |  |  | [static]

Serialize the supplied symbol.

Parameters:
messageValidator | the message validator.
symbol | set equal to the deserialized symbol.
Return values:
STATUS_CODE_SUCCESS.
...

Referenced by Activ::ContentPlatform::Feed::CompressedSymbol::Deserialize().

static StatusCode Activ::ContentPlatform::Feed::CompressedUsEquityOptionSymbol::Serialize | ( | byte_t *& | pMessage,
 |  | const std::string & | symbol |
 | ) |  |  | [static]

Serialize the supplied symbol.

Parameters:
pMessage | the message to serialize the symbol into.
symbol | the symbol to serialize.
Return values:
STATUS_CODE_SUCCESS.
...

Referenced by Activ::ContentPlatform::Feed::CompressedSymbol::Serialize().

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/CompressedUsEquityOptionSymbol.h
Generated on Wed Oct 8 14:02:06 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::CopyOnReset

Activ::ContentPlatform::Feed::CopyOnReset Class Reference

Copy on reset class. More...

#include <ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/Reset.h>

List of all members.

Public Member Functions

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API | CopyOnReset ()
Default constructor.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
bool 		operator!= (const CopyOnReset &rhs) const
Inequality operator.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
bool 		operator== (const CopyOnReset &rhs) const
Equality operator.

Public Attributes

bool | m_copyIfUndefined
Whether to copy the field if it is undefined.
FieldId | m_source
The source field id.
FieldId | m_target
The target field id.

Detailed Description

Copy on reset class.

Definition at line 30 of file Reset.h.

Member Function Documentation

bool Activ::ContentPlatform::Feed::CopyOnReset::operator!= ( const CopyOnReset & rhs ) const [inline]

Inequality operator.

Parameters:
rhs the object to test against.
Returns:
whether the two objects are not equal.

Definition at line 91 of file Reset.h.

bool Activ::ContentPlatform::Feed::CopyOnReset::operator== ( const CopyOnReset & rhs ) const [inline]

Equality operator.

Parameters:
rhs the object to test against.
Returns:
whether the two objects are equal.

Definition at line 75 of file Reset.h.

References m_copyIfUndefined, m_source, and m_target.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/Reset.h
Generated on Wed Oct 8 14:02:06 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::EntityTypeHelper

Activ::ContentPlatform::Feed::EntityTypeHelper Class Reference

Entity type helper class. More...

#include <ActivContentPlatform/ActivFeedCommon/EntityTypeHelper.h>

List of all members.

Public Member Functions

EntityTypeHelper (const EntityType entityType, const char *const pName, const char *const pCodeIdentifier)
Constructor.
EntityTypeHelper ()
Default constructor.

Public Attributes

std::string | m_codeIdentifier
The code identifier for the entity type.
EntityType | m_entityType
The entity type.
std::string | m_name
The name of the entity type.

Detailed Description

Entity type helper class.

Definition at line 28 of file EntityTypeHelper.h.

Constructor & Destructor Documentation

Activ::ContentPlatform::Feed::EntityTypeHelper::EntityTypeHelper | ( | const EntityType | entityType,
 |  | const char *const | pName,
 |  | const char *const | pCodeIdentifier |
 | ) |  |  | [inline]

Constructor.

Parameters:
entityType | the entity type.
pName | the name of the entity type.
pCodeIdentifier | the code identifer for the entity type.

Definition at line 59 of file EntityTypeHelper.h.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivFeedCommon/EntityTypeHelper.h
Generated on Wed Oct 8 14:02:06 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::EventTypeHelper

Activ::ContentPlatform::Feed::EventTypeHelper Class Reference

Event type helper class. More...

#include <ActivContentPlatform/ActivFeedCommon/EventTypeHelper.h>

List of all members.

Public Member Functions

EventTypeHelper (const EventType eventType, const char *const pName, const char *const pCodeIdentifier)
Constructor.
EventTypeHelper ()
Default constructor.

Public Attributes

std::string | m_codeIdentifier
The code identifier for the event type.
EventType | m_eventType
The event type.
std::string | m_name
The name of the event type.

Detailed Description

Event type helper class.

Definition at line 28 of file EventTypeHelper.h.

Constructor & Destructor Documentation

Activ::ContentPlatform::Feed::EventTypeHelper::EventTypeHelper | ( | const EventType | eventType,
 |  | const char *const | pName,
 |  | const char *const | pCodeIdentifier |
 | ) |  |  | [inline]

Constructor.

Parameters:
eventType | the event type.
pName | the name of the event type.
pCodeIdentifier | the code identifer for the event type.

Definition at line 59 of file EventTypeHelper.h.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivFeedCommon/EventTypeHelper.h
Generated on Wed Oct 8 14:02:06 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::Field

Activ::ContentPlatform::Feed::Field Class Reference

Field class. More...

#include <ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/Field.h>

List of all members.

Public Member Functions

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API | Field (const Specification &specification)
Constructor.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API | Field ()
Default constructor.
uint8_t | GetAmfFieldIndex () const
Get the amf field index.
uint8_t | GetAmfRowIndex () const
Get the amf row index.
uint8_t | GetAmfRowOffset () const
Get the amf row offset.
const std::string & | GetCodeIdentifier () const
Get the code identifier.
const std::string & | GetDescription () const
Get the description.
FieldId | GetId () const
Get the field id.
size_t | GetMaxLength () const
Get the maximum allowed field length.
const std::string & | GetName () const
Get the field name.
const FieldType | GetType () const
Get the field type.
bool | IsAmfField () const
Is the field in the amf message format?
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
bool 		operator!= (const Field &rhs) const
Inequality operator.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
Field & 		operator= (const Field &rhs)
Assignment operator.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
bool 		operator== (const Field &rhs) const
Equality operator.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
std::string 		ToString () const
Convert the specification to a C-style string.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API | ~Field ()
Destructor.

Static Public Member Functions

static
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
std::string 		GetUiHeading ()
Get the user interface heading.

Classes

class | Specification
Specification class. More...

Detailed Description

Field class.

Definition at line 34 of file Field.h.

Constructor & Destructor Documentation

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API Activ::ContentPlatform::Feed::Field::Field ( const Specification & specification )

Constructor.

Parameters:
specification the object specification.

Member Function Documentation

uint8_t Activ::ContentPlatform::Feed::Field::GetAmfFieldIndex ( ) const [inline]

Get the amf field index.

Returns:
the amf field index.

Definition at line 277 of file Field.h.

uint8_t Activ::ContentPlatform::Feed::Field::GetAmfRowIndex ( ) const [inline]

Get the amf row index.

Returns:
the amf row index.

Definition at line 263 of file Field.h.

uint8_t Activ::ContentPlatform::Feed::Field::GetAmfRowOffset ( ) const [inline]

Get the amf row offset.

Returns:
the amf row offset.

Definition at line 270 of file Field.h.

const std::string & Activ::ContentPlatform::Feed::Field::GetCodeIdentifier ( ) const [inline]

Get the code identifier.

Returns:
the field code identifier.

Definition at line 228 of file Field.h.

const std::string & Activ::ContentPlatform::Feed::Field::GetDescription ( ) const [inline]

Get the description.

Returns:
the field description.

Definition at line 235 of file Field.h.

FieldId Activ::ContentPlatform::Feed::Field::GetId ( ) const [inline]

Get the field id.

Returns:
the field id.

Definition at line 214 of file Field.h.

size_t Activ::ContentPlatform::Feed::Field::GetMaxLength ( ) const [inline]

Get the maximum allowed field length.

Returns:
the the maximum allowed field length.

Definition at line 249 of file Field.h.

const std::string & Activ::ContentPlatform::Feed::Field::GetName ( ) const [inline]

Get the field name.

Returns:
the field name.

Definition at line 221 of file Field.h.

const FieldType Activ::ContentPlatform::Feed::Field::GetType ( ) const [inline]

Get the field type.

Returns:
the field type.

Definition at line 242 of file Field.h.

static ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API std::string Activ::ContentPlatform::Feed::Field::GetUiHeading ( ) [static]

Get the user interface heading.

Return values:
string the user interface heading

bool Activ::ContentPlatform::Feed::Field::IsAmfField ( ) const [inline]

Is the field in the amf message format?

Returns:
whether the field is in the amf message format.

Definition at line 256 of file Field.h.

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API bool Activ::ContentPlatform::Feed::Field::operator!= ( const Field & rhs ) const

Inequality operator.

Parameters:
rhs the object to test against.
Returns:
whether the two objects are not equal.

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API bool Activ::ContentPlatform::Feed::Field::operator== ( const Field & rhs ) const

Equality operator.

Parameters:
rhs the object to test against.
Returns:
whether the two objects are equal.

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API std::string Activ::ContentPlatform::Feed::Field::ToString ( ) const

Convert the specification to a C-style string.

Returns:
the specification as a string.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/Field.h
Generated on Wed Oct 8 14:02:06 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::Field::Specification

Activ::ContentPlatform::Feed::Field::Specification Class Reference

Specification class. More...

#include <ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/Field.h>

List of all members.

Public Member Functions

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API | Specification (const FieldId id, const std::string &name, const std::string &codeIdentifier, const std::string &description, const FieldType type, const size_t maxLength, const bool isAmfField=false, const uint8_t amfRowIndex=0, const uint8_t amfRowOffset=0, const uint8_t amfFieldIndex=0)
Constructor.

Public Attributes

uint8_t | m_amfFieldIndex
The field index in an amf message row.
uint8_t | m_amfRowIndex
The row index in an amf message.
uint8_t | m_amfRowOffset
The offset in an amf message row.
std::string | m_codeIdentifier
The code identifier.
std::string | m_description
The description.
FieldId | m_id
The field id.
bool | m_isAmfField
Whether the field is in the amf message format.
size_t | m_maxLength
The maximum allowed field length.
std::string | m_name
The field name.
FieldType | m_type
The field type.

Detailed Description

Specification class.

This is used in construction of the object.

Definition at line 42 of file Field.h.

Constructor & Destructor Documentation

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API Activ::ContentPlatform::Feed::Field::Specification::Specification | ( | const FieldId | id,
 |  | const std::string & | name,
 |  | const std::string & | codeIdentifier,
 |  | const std::string & | description,
 |  | const FieldType | type,
 |  | const size_t | maxLength,
 |  | const bool | isAmfField = false,
 |  | const uint8_t | amfRowIndex = 0,
 |  | const uint8_t | amfRowOffset = 0,
 |  | const uint8_t | amfFieldIndex = 0
 | ) |  |

Constructor.

Parameters:
id | the field id.
name | the field name.
codeIdentifier | the code identifier.
description | the description.
type | the field type.
maxLength | the maximum allowed field length.
isAmfField | whether the field is in the amf message format.
amfRowIndex | the row index in an amf message.
amfRowOffset | the offset in an amf message row.
amfFieldIndex | the field index in an amf message row.
Exceptions:
StatusCodeException

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/Field.h
Generated on Wed Oct 8 14:02:06 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::FieldHeaderDefinitions

Activ::ContentPlatform::Feed::FieldHeaderDefinitions Class Reference

Field header definitions class. More...

#include <ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/FieldHeaderDefinitions.h>

Inheritance diagram for Activ::ContentPlatform::Feed::FieldHeaderDefinitions:

Activ::ContentPlatform::Feed::SymbolRecordFieldHeaderDefinitions

List of all members.

Public Types

typedef uint16_t | FieldHeader
The field header type definition.

Static Public Member Functions

static FieldHeader | GetFieldHeader (const FieldId fieldId, const bool isFieldDefined)
Get the field header.
static FieldId | GetFieldId (const FieldHeader fieldHeader)
Get the field id.
static bool | IsFieldDefined (const FieldHeader fieldHeader)
Is field defined.

Static Public Attributes

static const size_t | FIELD_ID_LENGTH = 14
The field id length.
static const size_t | FIELD_ID_OFFSET = (FIELD_RESERVED_OFFSET + FIELD_RESERVED_LENGTH)
The field id offset.
static const size_t | FIELD_RESERVED_LENGTH = 1
The field reserved length.
static const size_t | FIELD_RESERVED_OFFSET = (FIELD_UNDEFINED_OFFSET + FIELD_UNDEFINED_LENGTH)
The field reserved offset.
static const size_t | FIELD_UNDEFINED_LENGTH = 1
The field undefined length.
static const size_t | FIELD_UNDEFINED_OFFSET = 0
The field undefined offset.

Detailed Description

Field header definitions class.

Definition at line 28 of file FieldHeaderDefinitions.h.

Member Function Documentation

FieldHeaderDefinitions::FieldHeader Activ::ContentPlatform::Feed::FieldHeaderDefinitions::GetFieldHeader | ( | const FieldId | fieldId,
 |  | const bool | isFieldDefined |
 | ) |  |  | [inline, static]

Get the field header.

Parameters:
fieldId | the field id.
isFieldDefined | whether the field is defined.
Returns:
the field id.

Definition at line 71 of file FieldHeaderDefinitions.h.

References FIELD_ID_LENGTH, FIELD_ID_OFFSET, FIELD_UNDEFINED_LENGTH, and FIELD_UNDEFINED_OFFSET.

Referenced by Activ::ContentPlatform::Feed::SymbolRecordFieldHeaderDefinitions::GetFieldHeader().

FieldId Activ::ContentPlatform::Feed::FieldHeaderDefinitions::GetFieldId ( const FieldHeader fieldHeader ) [inline, static]

Get the field id.

Parameters:
fieldHeader the field header.
Returns:
the field id.

Definition at line 78 of file FieldHeaderDefinitions.h.

References FIELD_ID_LENGTH, and FIELD_ID_OFFSET.

bool Activ::ContentPlatform::Feed::FieldHeaderDefinitions::IsFieldDefined ( const FieldHeader fieldHeader ) [inline, static]

Is field defined.

Parameters:
fieldHeader the field header.
Returns:
whether the field is defined.

Definition at line 85 of file FieldHeaderDefinitions.h.

References FIELD_UNDEFINED_LENGTH, and FIELD_UNDEFINED_OFFSET.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/FieldHeaderDefinitions.h
Generated on Wed Oct 8 14:02:06 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::Index::IndexFieldSpecification

Activ::ContentPlatform::Feed::Index::IndexFieldSpecification Class Reference

Index field specification class. More...

#include <ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/Index.h>

List of all members.

Public Member Functions

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API | IndexFieldSpecification (const FieldId id)
Constructor.

Public Attributes

FieldId | m_id
The field id.

Detailed Description

Index field specification class.

This is used in construction of the field object.

Definition at line 51 of file Index.h.

Constructor & Destructor Documentation

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API Activ::ContentPlatform::Feed::Index::IndexFieldSpecification::IndexFieldSpecification ( const FieldId id )

Constructor.

Parameters:
id the field id.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/Index.h
Generated on Wed Oct 8 14:02:06 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::Index::Specification

Activ::ContentPlatform::Feed::Index::Specification Class Reference

Specification class. More...

#include <ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/Index.h>

List of all members.

Public Member Functions

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API | Specification (const IndexNumber number, const std::string &name, const IndexType type, const IndexProperties properties, const IndexFieldSpecificationList &indexFieldSpecificationList)
Constructor.

Public Attributes

IndexFieldSpecificationList | m_indexFieldSpecificationList
The index field specification list.
std::string | m_name
Name of the index.
IndexNumber | m_number
Number of the index.
IndexProperties | m_properties
Properties of the index.
IndexType | m_type
Type of the index.

Detailed Description

Specification class.

This is used in construction of the index object.

Definition at line 71 of file Index.h.

Constructor & Destructor Documentation

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API Activ::ContentPlatform::Feed::Index::Specification::Specification | ( | const IndexNumber | number,
 |  | const std::string & | name,
 |  | const IndexType | type,
 |  | const IndexProperties | properties,
 |  | const IndexFieldSpecificationList & | indexFieldSpecificationList
 | ) |  |

Constructor.

Parameters:
number | index number.
name | index name.
type | index type.
properties | index properties.
indexFieldSpecificationList

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/Index.h
Generated on Wed Oct 8 14:02:06 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::IndexSpecification::Field

Activ::ContentPlatform::Feed::IndexSpecification::Field Class Reference

Index field class. More...

#include <ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/IndexSpecification.h>

List of all members.

Public Member Functions

Field (const FieldId fieldId, const uint8_t sequence=0, const uint16_t properties=0)
Constructor.
Field ()
Constructor.

Public Attributes

FieldId | m_fieldId
Field id.
uint16_t | m_properties
Field properties.
uint8_t | m_sequence
Field sequence.

Detailed Description

Index field class.

Definition at line 59 of file IndexSpecification.h.

Constructor & Destructor Documentation

Activ::ContentPlatform::Feed::IndexSpecification::Field::Field | ( | const FieldId | fieldId,
 |  | const uint8_t | sequence = 0,
 |  | const uint16_t | properties = 0 |
 | ) |  |  | [inline, explicit]

Constructor.

Parameters:
fieldId | the identifier of the key field.
sequence | i've no idea what this is.
properties | properties of the key field.

Definition at line 292 of file IndexSpecification.h.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/IndexSpecification.h
Generated on Wed Oct 8 14:02:06 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::MessageHeaderDefinitions

Activ::ContentPlatform::Feed::MessageHeaderDefinitions Class Reference

Message header definitions class. More...

#include <ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/MessageHeaderDefinitions.h>

List of all members.

Public Types

typedef uint8_t | MessageHeader
The message header type definition.

Static Public Member Functions

static uint32_t | GetFlags (const MessageHeader messageHeader)
Get the flags.
static MessageHeader | GetMessageHeader (const uint32_t flags, const MessageType messageType)
Get the message header.
static MessageType | GetMessageType (const MessageHeader messageHeader)
Get the message type.
static bool | IsValidMessageType (const MessageHeader messageHeader, const MessageType messageType)
Is valid message type.

Static Public Attributes

static const
MessageHeaderDefinitions::MessageHeader 		FLAGS_BIT_MASK = static_cast<MessageHeaderDefinitions::MessageHeader>((1 << FLAGS_LENGTH) - 1)
static const size_t | FLAGS_BIT_SHIFT = (sizeof(MessageHeader) * CHAR_BIT) - (FLAGS_OFFSET + FLAGS_LENGTH)
static const size_t | FLAGS_LENGTH = 3
The flags length.
static const size_t | FLAGS_OFFSET = 0
The flags offset.
static const
MessageHeaderDefinitions::MessageHeader 		MESSAGE_TYPE_BIT_MASK = static_cast<MessageHeaderDefinitions::MessageHeader>((1 << MESSAGE_TYPE_LENGTH) - 1)
static const size_t | MESSAGE_TYPE_BIT_SHIFT = (sizeof(MessageHeader) * CHAR_BIT) - (MESSAGE_TYPE_OFFSET + MESSAGE_TYPE_LENGTH)
static const size_t | MESSAGE_TYPE_LENGTH = 5
The type length.
static const size_t | MESSAGE_TYPE_OFFSET = (FLAGS_OFFSET + FLAGS_LENGTH)
The type offset.

Detailed Description

Message header definitions class.

Definition at line 29 of file MessageHeaderDefinitions.h.

Member Function Documentation

uint32_t Activ::ContentPlatform::Feed::MessageHeaderDefinitions::GetFlags ( const MessageHeader messageHeader ) [inline, static]

Get the flags.

Parameters:
messageHeader the message header.
Returns:
the flags.

Definition at line 99 of file MessageHeaderDefinitions.h.

Referenced by Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions::IsComposite(), Activ::ContentPlatform::Feed::CompressedMessageHeaderDefinitions::IsComposite(), Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderDefinitions::IsComposite(), Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderDefinitions::IsCompressedSymbol(), Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions::IsDelete(), Activ::ContentPlatform::Feed::RecordMessageHeaderDefinitions::IsDelete(), Activ::ContentPlatform::Feed::CompressedMessageHeaderDefinitions::IsDelete(), Activ::ContentPlatform::Feed::RecordMessageHeaderDefinitions::IsRefresh(), and Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderDefinitions::IsUsEquityOption().

MessageHeaderDefinitions::MessageHeader Activ::ContentPlatform::Feed::MessageHeaderDefinitions::GetMessageHeader | ( | const uint32_t | flags,
 |  | const MessageType | messageType |
 | ) |  |  | [inline, static]

Get the message header.

Parameters:
flags | the flags.
messageType | the message type.
Returns:
the message header.

Definition at line 85 of file MessageHeaderDefinitions.h.

Referenced by Activ::ContentPlatform::Feed::TableTemplateMessageHeaderDefinitions::GetMessageHeader(), Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions::GetMessageHeader(), Activ::ContentPlatform::Feed::RecordMessageHeaderDefinitions::GetMessageHeader(), Activ::ContentPlatform::Feed::CompressedMessageHeaderDefinitions::GetMessageHeader(), Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderDefinitions::GetMessageHeader(), and Activ::ContentPlatform::Feed::CombinedQuoteMessageHeaderDefinitions::GetMessageHeader().

MessageType Activ::ContentPlatform::Feed::MessageHeaderDefinitions::GetMessageType ( const MessageHeader messageHeader ) [inline, static]

Get the message type.

Parameters:
messageHeader the message header.
Returns:
the message type.

Definition at line 106 of file MessageHeaderDefinitions.h.

Referenced by Activ::ContentPlatform::Feed::TableTemplateMessageHeaderDefinitions::IsValidMessageType(), IsValidMessageType(), Activ::ContentPlatform::Feed::CompressedMessageHeaderDefinitions::IsValidMessageType(), and Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderDefinitions::IsValidMessageType().

bool Activ::ContentPlatform::Feed::MessageHeaderDefinitions::IsValidMessageType | ( | const MessageHeader | messageHeader,
 |  | const MessageType | messageType |
 | ) |  |  | [inline, static]

Is valid message type.

Parameters:
messageHeader | the message header.
messageType | the message type.
Returns:
whether the message type is valid.

Definition at line 92 of file MessageHeaderDefinitions.h.

References GetMessageType().

Referenced by Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions::IsValidMessageType(), Activ::ContentPlatform::Feed::RecordMessageHeaderDefinitions::IsValidMessageType(), and Activ::ContentPlatform::Feed::CombinedQuoteMessageHeaderDefinitions::IsValidMessageType().

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/MessageHeaderDefinitions.h
Generated on Wed Oct 8 14:02:06 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::PermissionIdHelper

Activ::ContentPlatform::Feed::PermissionIdHelper Class Reference

Permission id helper class. More...

#include <ActivContentPlatform/ActivFeedCommon/PermissionIdHelper.h>

List of all members.

Public Member Functions

PermissionIdHelper (const PermissionId permissionId, const char *const pName, const char *const pCodeIdentifier)
Constructor.
PermissionIdHelper ()
Default constructor.

Public Attributes

std::string | m_codeIdentifier
The code identifier for the permission id.
std::string | m_name
The name of the permission id.
PermissionId | m_permissionId
The permission id.

Detailed Description

Permission id helper class.

Definition at line 28 of file PermissionIdHelper.h.

Constructor & Destructor Documentation

Activ::ContentPlatform::Feed::PermissionIdHelper::PermissionIdHelper | ( | const PermissionId | permissionId,
 |  | const char *const | pName,
 |  | const char *const | pCodeIdentifier |
 | ) |  |  | [inline]

Constructor.

Parameters:
permissionId | the permission id.
pName | the name of the permission id.
pCodeIdentifier | the code identifer for the permission id.

Definition at line 59 of file PermissionIdHelper.h.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivFeedCommon/PermissionIdHelper.h
Generated on Wed Oct 8 14:02:06 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::PermissionInfo

Activ::ContentPlatform::Feed::PermissionInfo Class Reference

Information about a user's permissioning. More...

#include <ActivContentPlatform/ActivFeedCommon/ActivFeedPermissioning/PermissionInfo.h>

Inheritance diagram for Activ::ContentPlatform::Feed::PermissionInfo:

Activ::ContentPlatform::ContentGatewayApi::PermissionInfo

List of all members.

Public Types

typedef std::map
< Feed::PermissionId,
PermissionIdInfo > 		PermissionIdInfoMap
Type of map from permission id to which fields are available.

Public Attributes

PermissionIdInfoMap | m_permissionLevelInfo [Feed::PERMISSION_LEVEL_COUNT]
Map from permission id to which fields are available for each permission level.

Classes

class | PermissionIdInfo
Information about a particular permission id for the client. More...

Detailed Description

Information about a user's permissioning.

Definition at line 27 of file PermissionInfo.h.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivFeedCommon/ActivFeedPermissioning/PermissionInfo.h
Generated on Wed Oct 8 14:02:06 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::PermissionInfo::PermissionIdInfo

Activ::ContentPlatform::Feed::PermissionInfo::PermissionIdInfo Class Reference

Information about a particular permission id for the client. More...

#include <ActivContentPlatform/ActivFeedCommon/ActivFeedPermissioning/PermissionInfo.h>

List of all members.

Public Types

enum | Type { TYPE_INCLUDE_FIELDS, TYPE_ALL_FIELDS, TYPE_EXCLUDE_FIELDS }

Public Attributes

Feed::FieldIdList | m_fieldIdList
List of fields permissioned for this permission id, if not TYPE_ALL_FIELDS.
std::string | m_name
Name of permission id.
Type m_type
Partial or full permissioning?

Detailed Description

Information about a particular permission id for the client.

Definition at line 33 of file PermissionInfo.h.

Member Enumeration Documentation

enum Activ::ContentPlatform::Feed::PermissionInfo::PermissionIdInfo::Type

Enumerator:
TYPE_INCLUDE_FIELDS | Permissioned fields are in m_fieldIdList.
TYPE_ALL_FIELDS | All fields are permissioned, m_fieldIdList will be empty.
TYPE_EXCLUDE_FIELDS | Unpermissioned fields are in m_fieldIdList.

Definition at line 36 of file PermissionInfo.h.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivFeedCommon/ActivFeedPermissioning/PermissionInfo.h
Generated on Wed Oct 8 14:02:06 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::PermissionLevelData

Activ::ContentPlatform::Feed::PermissionLevelData Union Reference

#include <ActivContentPlatform/ActivFeedCommon/PermissionLevels.h>

List of all members.

Public Attributes

byte_t m_delayPeriod
for PERMISSION_LEVEL_DELAYED, delay period in minutes

Detailed Description

Union of permission level data.

Definition at line 33 of file PermissionLevels.h.

The documentation for this union was generated from the following file:
  • include/ActivContentPlatform/ActivFeedCommon/PermissionLevels.h
Generated on Wed Oct 8 14:02:06 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::RecordFieldListBuilder

Activ::ContentPlatform::Feed::RecordFieldListBuilder Class Reference

Record field list builder class. More...

#include <ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/RecordFieldListBuilder.h>

List of all members.

Public Member Functions

ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		AppendField (const FieldId fieldId, const void *const pSerializedBody, const size_t serializedBodyLength)
Append a field.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		AppendField (const FieldId fieldId, const IFieldType &iFieldType)
Append a field.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		AppendUndefinedField (const FieldId fieldId)
Append an undefined field.
ACTIV_FEED_MESSAGE_HANDLER_API void | Clear ()
Clear.
ACTIV_FEED_MESSAGE_HANDLER_API void | Initialize (const TableTemplate &tableTemplate, MessageBuilder &messageBuilder)
Initialize with a new table template and message builder.
ACTIV_FEED_MESSAGE_HANDLER_API bool | IsInitialized () const
Is the object initialized.
ACTIV_FEED_MESSAGE_HANDLER_API | RecordFieldListBuilder (const TableTemplate &tableTemplate, MessageBuilder &messageBuilder)
Constructor.
ACTIV_FEED_MESSAGE_HANDLER_API | RecordFieldListBuilder ()
Default constructor.
ACTIV_FEED_MESSAGE_HANDLER_API void | Reset ()
Reset.
ACTIV_FEED_MESSAGE_HANDLER_API | ~RecordFieldListBuilder ()
Destructor.

Detailed Description

Record field list builder class.

Definition at line 33 of file RecordFieldListBuilder.h.

Constructor & Destructor Documentation

ACTIV_FEED_MESSAGE_HANDLER_API Activ::ContentPlatform::Feed::RecordFieldListBuilder::RecordFieldListBuilder | ( | const TableTemplate & | tableTemplate,
 |  | MessageBuilder & | messageBuilder
 | ) |  |

Constructor.

Parameters:
tableTemplate | the table template.
messageBuilder | the message builder.

Member Function Documentation

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::RecordFieldListBuilder::AppendField | ( | const FieldId | fieldId,
 |  | const void *const | pSerializedBody,
 |  | const size_t | serializedBodyLength
 | ) |  |

Append a field.

Parameters:
fieldId | the field id.
pSerializedBody | the serialized body.
serializedBodyLength | the serialized body length.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED
...

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::RecordFieldListBuilder::AppendField | ( | const FieldId | fieldId,
 |  | const IFieldType & | iFieldType
 | ) |  |

Append a field.

Parameters:
fieldId | the field id.
iFieldType | a reference to the field.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED
...

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::RecordFieldListBuilder::AppendUndefinedField ( const FieldId fieldId )

Append an undefined field.

Parameters:
fieldId the field id.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED
...

ACTIV_FEED_MESSAGE_HANDLER_API void Activ::ContentPlatform::Feed::RecordFieldListBuilder::Initialize | ( | const TableTemplate & | tableTemplate,
 |  | MessageBuilder & | messageBuilder
 | ) |  |

Initialize with a new table template and message builder.

Parameters:
tableTemplate | the table template.
messageBuilder | the message builder.

ACTIV_FEED_MESSAGE_HANDLER_API bool Activ::ContentPlatform::Feed::RecordFieldListBuilder::IsInitialized ( ) const

Is the object initialized.

Returns:
whether the object is initialized.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/RecordFieldListBuilder.h
Generated on Wed Oct 8 14:02:06 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::RecordFieldListValidator

Activ::ContentPlatform::Feed::RecordFieldListValidator Class Reference

Record field list validator class. More...

#include <ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/RecordFieldListValidator.h>

List of all members.

Public Member Functions

ACTIV_FEED_MESSAGE_HANDLER_API
ConstIterator 		Begin () const
Get an iterator to the first field in the message.
ACTIV_FEED_MESSAGE_HANDLER_API void | Clear ()
Clear.
ACTIV_FEED_MESSAGE_HANDLER_API
ConstIterator 		End () const
Get an iterator that points to beyond the last field in the message.
ACTIV_FEED_MESSAGE_HANDLER_API
std::string 		FieldContentsToString (const IFieldType *pIFieldType) const
Copy Field ID to string.
ACTIV_FEED_MESSAGE_HANDLER_API
std::string 		FieldIdToString (const FieldId &fieldId) const
Copy Field ID to string.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		GetField (const FieldId fieldId, const IFieldType *&pIFieldType) const
Get a field.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		Initialize (const TableTemplate &tableTemplate, MessageValidator &messageValidator, const bool shouldIgnoreUndefinedMissingFields=false)
Initialize.
ACTIV_FEED_MESSAGE_HANDLER_API bool | IsInitialized () const
Is the object initialized.
ACTIV_FEED_MESSAGE_HANDLER_API | RecordFieldListValidator (const TableTemplate &tableTemplate, MessageValidator &messageValidator, const bool shouldIgnoreUndefinedMissingFields=false)
Constructor.
ACTIV_FEED_MESSAGE_HANDLER_API | RecordFieldListValidator ()
Default constructor.
ACTIV_FEED_MESSAGE_HANDLER_API void | Reset ()
Reset.
ACTIV_FEED_MESSAGE_HANDLER_API
std::string 		ToString () const
Put fields into string.
ACTIV_FEED_MESSAGE_HANDLER_API | ~RecordFieldListValidator ()
Destructor.

Static Public Member Functions

static
ACTIV_FEED_MESSAGE_HANDLER_API
std::string 		ContentsPrefixToString ()
Copy "Contents" Prefix to string.
static
ACTIV_FEED_MESSAGE_HANDLER_API
std::string 		FieldListTitleToString ()
Copy "Field List" title to string.
static
ACTIV_FEED_MESSAGE_HANDLER_API
std::string 		NamePrefixToString ()
Copy "Name" Prefix to string.
static
ACTIV_FEED_MESSAGE_HANDLER_API
std::string 		UndefinedFieldContentsToString ()
Copy Undefined Contents to string.

Classes

class | ConstIterator
Const iterator class. More...

Detailed Description

Record field list validator class.

Definition at line 39 of file RecordFieldListValidator.h.

Constructor & Destructor Documentation

ACTIV_FEED_MESSAGE_HANDLER_API Activ::ContentPlatform::Feed::RecordFieldListValidator::RecordFieldListValidator | ( | const TableTemplate & | tableTemplate,
 |  | MessageValidator & | messageValidator,
 |  | const bool | shouldIgnoreUndefinedMissingFields = false
 | ) |  |

Constructor.

Parameters:
tableTemplate | the table template.
messageValidator | the message validator.
shouldIgnoreUndefinedMissingFields | whether the undefined fields missing from the table template should be ignored or not.
Exceptions:
StatusCodeException

Member Function Documentation

ACTIV_FEED_MESSAGE_HANDLER_API ConstIterator Activ::ContentPlatform::Feed::RecordFieldListValidator::Begin ( ) const

Get an iterator to the first field in the message.

Returns:
an iterator object.
Exceptions:
StatusCodeException

static ACTIV_FEED_MESSAGE_HANDLER_API std::string Activ::ContentPlatform::Feed::RecordFieldListValidator::ContentsPrefixToString ( ) [static]

Copy "Contents" Prefix to string.

Returns:
string.

ACTIV_FEED_MESSAGE_HANDLER_API ConstIterator Activ::ContentPlatform::Feed::RecordFieldListValidator::End ( ) const

Get an iterator that points to beyond the last field in the message.

Returns:
an iterator object.
Exceptions:
StatusCodeException

ACTIV_FEED_MESSAGE_HANDLER_API std::string Activ::ContentPlatform::Feed::RecordFieldListValidator::FieldContentsToString ( const IFieldType * pIFieldType ) const

Copy Field ID to string.

Returns:
string.

ACTIV_FEED_MESSAGE_HANDLER_API std::string Activ::ContentPlatform::Feed::RecordFieldListValidator::FieldIdToString ( const FieldId & fieldId ) const

Copy Field ID to string.

Returns:
string.

static ACTIV_FEED_MESSAGE_HANDLER_API std::string Activ::ContentPlatform::Feed::RecordFieldListValidator::FieldListTitleToString ( ) [static]

Copy "Field List" title to string.

Returns:
string.

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::RecordFieldListValidator::GetField | ( | const FieldId | fieldId,
 |  | const IFieldType *& | pIFieldType |
 | ) |  |  | const

Get a field.

Parameters:
fieldId | the field id.
pIFieldType | a pointer to the field.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_FOUND
STATUS_CODE_NOT_INITIALIZED

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::RecordFieldListValidator::Initialize | ( | const TableTemplate & | tableTemplate,
 |  | MessageValidator & | messageValidator,
 |  | const bool | shouldIgnoreUndefinedMissingFields = false
 | ) |  |

Initialize.

Parameters:
tableTemplate | a reference to the table template.
messageValidator | the message validator.
shouldIgnoreUndefinedMissingFields | whether the undefined fields missing from the table template should be ignored or not.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_HEAP_EMPTY
STATUS_CODE_INVALID_FORMAT
...

ACTIV_FEED_MESSAGE_HANDLER_API bool Activ::ContentPlatform::Feed::RecordFieldListValidator::IsInitialized ( ) const

Is the object initialized.

Returns:
whether the object is initialized.

static ACTIV_FEED_MESSAGE_HANDLER_API std::string Activ::ContentPlatform::Feed::RecordFieldListValidator::NamePrefixToString ( ) [static]

Copy "Name" Prefix to string.

Returns:
string.

ACTIV_FEED_MESSAGE_HANDLER_API std::string Activ::ContentPlatform::Feed::RecordFieldListValidator::ToString ( ) const

Put fields into string.

Returns:
string.

static ACTIV_FEED_MESSAGE_HANDLER_API std::string Activ::ContentPlatform::Feed::RecordFieldListValidator::UndefinedFieldContentsToString ( ) [static]

Copy Undefined Contents to string.

Returns:
string.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/RecordFieldListValidator.h
Generated on Wed Oct 8 14:02:06 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::RecordFieldListValidator::ConstIterator

Activ::ContentPlatform::Feed::RecordFieldListValidator::ConstIterator Class Reference

Const iterator class. More...

#include <ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/RecordFieldListValidator.h>

List of all members.

Public Member Functions

ConstIterator ()
Default constructor.
const IFieldType * | GetField () const
Get the field.
FieldId | GetFieldId () const
Get the field id.
bool | operator!= (const ConstIterator &rhs) const
Inequality operator.
const ConstIterator | operator++ (int)
Postfix increment operator.
ConstIterator & operator++ ()
Prefix increment operator.
bool | operator== (const ConstIterator &rhs) const
Equality operator.

Friends

class | RecordFieldListValidator

Detailed Description

Const iterator class.

Definition at line 45 of file RecordFieldListValidator.h.

Member Function Documentation

const IFieldType * Activ::ContentPlatform::Feed::RecordFieldListValidator::ConstIterator::GetField ( ) const [inline]

Get the field.

Returns:
a pointer to the field.

Definition at line 351 of file RecordFieldListValidator.h.

References Activ::ContentPlatform::Feed::RecordFieldListValidator::GetCachedField().

FieldId Activ::ContentPlatform::Feed::RecordFieldListValidator::ConstIterator::GetFieldId ( ) const [inline]

Get the field id.

Returns:
the field id.

Definition at line 344 of file RecordFieldListValidator.h.

bool Activ::ContentPlatform::Feed::RecordFieldListValidator::ConstIterator::operator!= ( const ConstIterator & rhs ) const [inline]

Inequality operator.

Parameters:
rhs the object to test against.
Returns:
whether the two objects are not equal.

Definition at line 337 of file RecordFieldListValidator.h.

const RecordFieldListValidator::ConstIterator Activ::ContentPlatform::Feed::RecordFieldListValidator::ConstIterator::operator++ ( int ) [inline]

Postfix increment operator.

Returns:
a copy of the original object.

Definition at line 319 of file RecordFieldListValidator.h.

RecordFieldListValidator::ConstIterator & Activ::ContentPlatform::Feed::RecordFieldListValidator::ConstIterator::operator++ ( ) [inline]

Prefix increment operator.

Returns:
a reference to the updated object.

Definition at line 310 of file RecordFieldListValidator.h.

bool Activ::ContentPlatform::Feed::RecordFieldListValidator::ConstIterator::operator== ( const ConstIterator & rhs ) const [inline]

Equality operator.

Parameters:
rhs the object to test against.
Returns:
whether the two objects are equal.

Definition at line 330 of file RecordFieldListValidator.h.

References m_iterator, and m_pRecordFieldListValidator.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/RecordFieldListValidator.h
Generated on Wed Oct 8 14:02:06 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::RecordKeyFieldListBuilder

Activ::ContentPlatform::Feed::RecordKeyFieldListBuilder Class Reference

Record key Field list builder class. More...

#include <ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/RecordKeyFieldListBuilder.h>

List of all members.

Public Member Functions

ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		AppendField (const FieldId fieldId, const void *const pSerializedBody, const size_t serializedBodyLength)
Append a field.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		AppendField (const FieldId fieldId, const IFieldType &iFieldType)
Append a keyfield.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		AppendUndefinedField (const FieldId fieldId)
Append an undefined key field.
ACTIV_FEED_MESSAGE_HANDLER_API void | Clear ()
Clear.
ACTIV_FEED_MESSAGE_HANDLER_API void | Initialize (const Index &index, MessageBuilder &messageBuilder)
Initialize with a new index and message builder.
ACTIV_FEED_MESSAGE_HANDLER_API bool | IsComplete () const
Is the object complete.
ACTIV_FEED_MESSAGE_HANDLER_API bool | IsInitialized () const
Is the object initialized.
ACTIV_FEED_MESSAGE_HANDLER_API | RecordKeyFieldListBuilder (const Index &index, MessageBuilder &messageBuilder)
Constructor.
ACTIV_FEED_MESSAGE_HANDLER_API | RecordKeyFieldListBuilder ()
Default constructor.
ACTIV_FEED_MESSAGE_HANDLER_API void | Reset ()
Reset.
ACTIV_FEED_MESSAGE_HANDLER_API | ~RecordKeyFieldListBuilder ()
Destructor.

Detailed Description

Record key Field list builder class.

Definition at line 33 of file RecordKeyFieldListBuilder.h.

Constructor & Destructor Documentation

ACTIV_FEED_MESSAGE_HANDLER_API Activ::ContentPlatform::Feed::RecordKeyFieldListBuilder::RecordKeyFieldListBuilder | ( | const Index & | index,
 |  | MessageBuilder & | messageBuilder
 | ) |  |

Constructor.

Parameters:
index | a reference to the index.
messageBuilder | the message builder.

Member Function Documentation

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::RecordKeyFieldListBuilder::AppendField | ( | const FieldId | fieldId,
 |  | const void *const | pSerializedBody,
 |  | const size_t | serializedBodyLength
 | ) |  |

Append a field.

Parameters:
fieldId | the field id.
pSerializedBody | the serialized body.
serializedBodyLength | the serialized body length.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED
...

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::RecordKeyFieldListBuilder::AppendField | ( | const FieldId | fieldId,
 |  | const IFieldType & | iFieldType
 | ) |  |

Append a keyfield.

Parameters:
fieldId | the field id.
iFieldType | a reference to the field.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED
...

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::RecordKeyFieldListBuilder::AppendUndefinedField ( const FieldId fieldId )

Append an undefined key field.

Parameters:
fieldId the field id.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED
...

ACTIV_FEED_MESSAGE_HANDLER_API void Activ::ContentPlatform::Feed::RecordKeyFieldListBuilder::Initialize | ( | const Index & | index,
 |  | MessageBuilder & | messageBuilder
 | ) |  |

Initialize with a new index and message builder.

Parameters:
index | a reference to the index.
messageBuilder | the message builder.

ACTIV_FEED_MESSAGE_HANDLER_API bool Activ::ContentPlatform::Feed::RecordKeyFieldListBuilder::IsComplete ( ) const

Is the object complete.

Returns:
whether the object is complete.

ACTIV_FEED_MESSAGE_HANDLER_API bool Activ::ContentPlatform::Feed::RecordKeyFieldListBuilder::IsInitialized ( ) const

Is the object initialized.

Returns:
whether the object is initialized.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/RecordKeyFieldListBuilder.h
Generated on Wed Oct 8 14:02:06 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::RecordKeyFieldListValidator

Activ::ContentPlatform::Feed::RecordKeyFieldListValidator Class Reference

Record key field list validator class. More...

#include <ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/RecordKeyFieldListValidator.h>

List of all members.

Public Member Functions

ACTIV_FEED_MESSAGE_HANDLER_API
ConstIterator 		Begin () const
Get an iterator to the first field in the message.
ACTIV_FEED_MESSAGE_HANDLER_API void | Clear ()
Clear.
ACTIV_FEED_MESSAGE_HANDLER_API
ConstIterator 		End () const
Get an iterator that points to beyond the last field in the message.
ACTIV_FEED_MESSAGE_HANDLER_API
std::string 		FieldContentsToString (const IFieldType *pIFieldType) const
Copy Field ID to string.
ACTIV_FEED_MESSAGE_HANDLER_API
std::string 		FieldIdToString (const FieldId &fieldId) const
Copy Field ID to string.
ACTIV_FEED_MESSAGE_HANDLER_API
std::string 		FieldNameToString (const FieldId &fieldId) const
Copy Field ID to string.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		GetField (const FieldId fieldId, const IFieldType *&pIFieldType) const
Get a field.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		Initialize (const Index &index, MessageValidator &messageValidator)
Initialize.
ACTIV_FEED_MESSAGE_HANDLER_API bool | IsInitialized () const
Is the object initialized.
ACTIV_FEED_MESSAGE_HANDLER_API | RecordKeyFieldListValidator (const Index &index, MessageValidator &messageValidator)
Constructor.
ACTIV_FEED_MESSAGE_HANDLER_API | RecordKeyFieldListValidator ()
Default constructor.
ACTIV_FEED_MESSAGE_HANDLER_API void | Reset ()
Reset.
ACTIV_FEED_MESSAGE_HANDLER_API
std::string 		ToString () const
Put fields into string.
ACTIV_FEED_MESSAGE_HANDLER_API | ~RecordKeyFieldListValidator ()
Destructor.

Static Public Member Functions

static
ACTIV_FEED_MESSAGE_HANDLER_API
std::string 		ContentsPrefixToString ()
Copy "Contents" Prefix to string.
static
ACTIV_FEED_MESSAGE_HANDLER_API
std::string 		KeyFieldListTitleToString ()
Copy "Key field list" title to string.
static
ACTIV_FEED_MESSAGE_HANDLER_API
std::string 		NamePrefixToString ()
Copy "Name" Prefix to string.
static
ACTIV_FEED_MESSAGE_HANDLER_API
std::string 		UndefinedFieldContentsToString ()
Copy Undefined Contents to string.

Classes

class | ConstIterator
Const iterator class. More...

Detailed Description

Record key field list validator class.

Definition at line 38 of file RecordKeyFieldListValidator.h.

Constructor & Destructor Documentation

ACTIV_FEED_MESSAGE_HANDLER_API Activ::ContentPlatform::Feed::RecordKeyFieldListValidator::RecordKeyFieldListValidator | ( | const Index & | index,
 |  | MessageValidator & | messageValidator
 | ) |  |

Constructor.

Parameters:
index | a reference to the index.
messageValidator | the message validator.
Exceptions:
StatusCodeException

Member Function Documentation

ACTIV_FEED_MESSAGE_HANDLER_API ConstIterator Activ::ContentPlatform::Feed::RecordKeyFieldListValidator::Begin ( ) const

Get an iterator to the first field in the message.

Returns:
an iterator object.
Exceptions:
StatusCodeException

static ACTIV_FEED_MESSAGE_HANDLER_API std::string Activ::ContentPlatform::Feed::RecordKeyFieldListValidator::ContentsPrefixToString ( ) [static]

Copy "Contents" Prefix to string.

Returns:
string.

ACTIV_FEED_MESSAGE_HANDLER_API ConstIterator Activ::ContentPlatform::Feed::RecordKeyFieldListValidator::End ( ) const

Get an iterator that points to beyond the last field in the message.

Returns:
an iterator object.
Exceptions:
StatusCodeException

ACTIV_FEED_MESSAGE_HANDLER_API std::string Activ::ContentPlatform::Feed::RecordKeyFieldListValidator::FieldContentsToString ( const IFieldType * pIFieldType ) const

Copy Field ID to string.

Returns:
string.

ACTIV_FEED_MESSAGE_HANDLER_API std::string Activ::ContentPlatform::Feed::RecordKeyFieldListValidator::FieldIdToString ( const FieldId & fieldId ) const

Copy Field ID to string.

Returns:
string.

ACTIV_FEED_MESSAGE_HANDLER_API std::string Activ::ContentPlatform::Feed::RecordKeyFieldListValidator::FieldNameToString ( const FieldId & fieldId ) const

Copy Field ID to string.

Returns:
string.

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::RecordKeyFieldListValidator::GetField | ( | const FieldId | fieldId,
 |  | const IFieldType *& | pIFieldType |
 | ) |  |  | const

Get a field.

Parameters:
fieldId | the field id.
pIFieldType | a pointer to the field.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_FOUND
STATUS_CODE_NOT_INITIALIZED

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::RecordKeyFieldListValidator::Initialize | ( | const Index & | index,
 |  | MessageValidator & | messageValidator
 | ) |  |

Initialize.

Parameters:
index | a reference to the index.
messageValidator | the message validator.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_HEAP_EMPTY
STATUS_CODE_INVALID_FORMAT
...

ACTIV_FEED_MESSAGE_HANDLER_API bool Activ::ContentPlatform::Feed::RecordKeyFieldListValidator::IsInitialized ( ) const

Is the object initialized.

Returns:
whether the object is initialized.

static ACTIV_FEED_MESSAGE_HANDLER_API std::string Activ::ContentPlatform::Feed::RecordKeyFieldListValidator::KeyFieldListTitleToString ( ) [static]

Copy "Key field list" title to string.

Returns:
string.

static ACTIV_FEED_MESSAGE_HANDLER_API std::string Activ::ContentPlatform::Feed::RecordKeyFieldListValidator::NamePrefixToString ( ) [static]

Copy "Name" Prefix to string.

Returns:
string.

ACTIV_FEED_MESSAGE_HANDLER_API std::string Activ::ContentPlatform::Feed::RecordKeyFieldListValidator::ToString ( ) const

Put fields into string.

Returns:
string.

static ACTIV_FEED_MESSAGE_HANDLER_API std::string Activ::ContentPlatform::Feed::RecordKeyFieldListValidator::UndefinedFieldContentsToString ( ) [static]

Copy Undefined Contents to string.

Returns:
string.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/RecordKeyFieldListValidator.h
Generated on Wed Oct 8 14:02:06 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::RecordKeyFieldListValidator::ConstIterator

Activ::ContentPlatform::Feed::RecordKeyFieldListValidator::ConstIterator Class Reference

Const iterator class. More...

#include <ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/RecordKeyFieldListValidator.h>

List of all members.

Public Member Functions

ConstIterator ()
Default constructor.
const IFieldType * | GetField () const
Get the field.
FieldId | GetFieldId () const
Get the field id.
bool | operator!= (const ConstIterator &rhs) const
Inequality operator.
const ConstIterator | operator++ (int)
Postfix increment operator.
ConstIterator & operator++ ()
Prefix increment operator.
bool | operator== (const ConstIterator &rhs) const
Equality operator.

Friends

class | RecordKeyFieldListValidator

Detailed Description

Const iterator class.

Definition at line 44 of file RecordKeyFieldListValidator.h.

Member Function Documentation

const IFieldType * Activ::ContentPlatform::Feed::RecordKeyFieldListValidator::ConstIterator::GetField ( ) const [inline]

Get the field.

Returns:
a pointer to the field.

Definition at line 341 of file RecordKeyFieldListValidator.h.

FieldId Activ::ContentPlatform::Feed::RecordKeyFieldListValidator::ConstIterator::GetFieldId ( ) const [inline]

Get the field id.

Returns:
the field id.

Definition at line 334 of file RecordKeyFieldListValidator.h.

bool Activ::ContentPlatform::Feed::RecordKeyFieldListValidator::ConstIterator::operator!= ( const ConstIterator & rhs ) const [inline]

Inequality operator.

Parameters:
rhs the object to test against.
Returns:
whether the two objects are not equal.

Definition at line 327 of file RecordKeyFieldListValidator.h.

const RecordKeyFieldListValidator::ConstIterator Activ::ContentPlatform::Feed::RecordKeyFieldListValidator::ConstIterator::operator++ ( int ) [inline]

Postfix increment operator.

Returns:
a copy of the original object.

Definition at line 309 of file RecordKeyFieldListValidator.h.

RecordKeyFieldListValidator::ConstIterator & Activ::ContentPlatform::Feed::RecordKeyFieldListValidator::ConstIterator::operator++ ( ) [inline]

Prefix increment operator.

Returns:
a reference to the updated object.

Definition at line 300 of file RecordKeyFieldListValidator.h.

bool Activ::ContentPlatform::Feed::RecordKeyFieldListValidator::ConstIterator::operator== ( const ConstIterator & rhs ) const [inline]

Equality operator.

Parameters:
rhs the object to test against.
Returns:
whether the two objects are equal.

Definition at line 320 of file RecordKeyFieldListValidator.h.

References m_iterator, and m_pRecordKeyFieldListValidator.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/RecordKeyFieldListValidator.h
Generated on Wed Oct 8 14:02:06 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::RecordMessageBuilder

Activ::ContentPlatform::Feed::RecordMessageBuilder Class Reference

Record message builder class. More...

#include <ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/RecordMessageBuilder.h>

List of all members.

Public Member Functions

ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		AppendField (const FieldId fieldId, const void *const pSerializedBody, const size_t serializedBodyLength)
Append a field.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		AppendField (const FieldId fieldId, const IFieldType &iFieldType)
Append a field.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		AppendHeader (const bool isDelete, const bool isRefresh, const TableId tableId, const UpdateId updateId, const PermissionId permissionId, const EventType eventType)
Append the header.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		AppendIndexNumber (const IndexNumber indexNumber)
Append the index number.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		AppendKeyField (const FieldId fieldId, const void *const pSerializedBody, const size_t serializedBodyLength)
Append a key field.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		AppendKeyField (const FieldId fieldId, const IFieldType &iFieldType)
Append a key field.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		AppendUndefinedField (const FieldId fieldId)
Append an undefined field.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		AppendUndefinedKeyField (const FieldId fieldId)
Append an undefined key field.
ACTIV_FEED_MESSAGE_HANDLER_API void | Initialize (MessageBuilder &messageBuilder)
Initialize with a new message builder.
ACTIV_FEED_MESSAGE_HANDLER_API void | Initialize (const TableTemplateList &tableTemplateList)
Initialize with a new table template list (and reset the object).
ACTIV_FEED_MESSAGE_HANDLER_API void | Initialize (const TableTemplateList &tableTemplateList, MessageBuilder &messageBuilder)
Initialize with a new table template list and message builder.
ACTIV_FEED_MESSAGE_HANDLER_API bool | IsInitialized () const
Is the object initialized.
ACTIV_FEED_MESSAGE_HANDLER_API | RecordMessageBuilder (const TableTemplateList &tableTemplateList)
Constructor.
ACTIV_FEED_MESSAGE_HANDLER_API | RecordMessageBuilder (const TableTemplateList &tableTemplateList, MessageBuilder &messageBuilder)
Constructor.
ACTIV_FEED_MESSAGE_HANDLER_API | RecordMessageBuilder ()
Default constructor.
ACTIV_FEED_MESSAGE_HANDLER_API void | Reset ()
Reset.
ACTIV_FEED_MESSAGE_HANDLER_API | ~RecordMessageBuilder ()
Destructor.

Detailed Description

Record message builder class.

Definition at line 39 of file RecordMessageBuilder.h.

Constructor & Destructor Documentation

ACTIV_FEED_MESSAGE_HANDLER_API Activ::ContentPlatform::Feed::RecordMessageBuilder::RecordMessageBuilder | ( | const TableTemplateList & | tableTemplateList,
 |  | MessageBuilder & | messageBuilder
 | ) |  |

Constructor.

Parameters:
tableTemplateList | the table template list.
messageBuilder | the message builder.

ACTIV_FEED_MESSAGE_HANDLER_API Activ::ContentPlatform::Feed::RecordMessageBuilder::RecordMessageBuilder ( const TableTemplateList & tableTemplateList )

Constructor.

Parameters:
tableTemplateList the table template list.

Member Function Documentation

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::RecordMessageBuilder::AppendField | ( | const FieldId | fieldId,
 |  | const void *const | pSerializedBody,
 |  | const size_t | serializedBodyLength
 | ) |  |

Append a field.

Parameters:
fieldId | the field id.
pSerializedBody | the serialized body.
serializedBodyLength | the serialized body length.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED
...

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::RecordMessageBuilder::AppendField | ( | const FieldId | fieldId,
 |  | const IFieldType & | iFieldType
 | ) |  |

Append a field.

Parameters:
fieldId | the field id.
iFieldType | a reference to the field.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED
...

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::RecordMessageBuilder::AppendHeader | ( | const bool | isDelete,
 |  | const bool | isRefresh,
 |  | const TableId | tableId,
 |  | const UpdateId | updateId,
 |  | const PermissionId | permissionId,
 |  | const EventType | eventType
 | ) |  |

Append the header.

Parameters:
isDelete | whether this is a delete message.
isRefresh | whether this is a refresh message.
tableId | the table template id.
updateId | the update id.
permissionId | the permission id.
eventType | the event type.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED
...

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::RecordMessageBuilder::AppendIndexNumber ( const IndexNumber indexNumber )

Append the index number.

Parameters:
indexNumber the index number.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED
...

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::RecordMessageBuilder::AppendKeyField | ( | const FieldId | fieldId,
 |  | const void *const | pSerializedBody,
 |  | const size_t | serializedBodyLength
 | ) |  |

Append a key field.

Parameters:
fieldId | the field id.
pSerializedBody | the serialized body.
serializedBodyLength | the serialized body length.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED
...

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::RecordMessageBuilder::AppendKeyField | ( | const FieldId | fieldId,
 |  | const IFieldType & | iFieldType
 | ) |  |

Append a key field.

Parameters:
fieldId | the field id.
iFieldType | a reference to the field.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED
...

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::RecordMessageBuilder::AppendUndefinedField ( const FieldId fieldId )

Append an undefined field.

Parameters:
fieldId the field id.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED
...

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::RecordMessageBuilder::AppendUndefinedKeyField ( const FieldId fieldId )

Append an undefined key field.

Parameters:
fieldId the field id.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED
...

ACTIV_FEED_MESSAGE_HANDLER_API void Activ::ContentPlatform::Feed::RecordMessageBuilder::Initialize ( MessageBuilder & messageBuilder )

Initialize with a new message builder.

Parameters:
messageBuilder the message builder.

ACTIV_FEED_MESSAGE_HANDLER_API void Activ::ContentPlatform::Feed::RecordMessageBuilder::Initialize ( const TableTemplateList & tableTemplateList )

Initialize with a new table template list (and reset the object).

Parameters:
tableTemplateList the table template list.

ACTIV_FEED_MESSAGE_HANDLER_API void Activ::ContentPlatform::Feed::RecordMessageBuilder::Initialize | ( | const TableTemplateList & | tableTemplateList,
 |  | MessageBuilder & | messageBuilder
 | ) |  |

Initialize with a new table template list and message builder.

Parameters:
tableTemplateList | the table template list.
messageBuilder | the message builder.

ACTIV_FEED_MESSAGE_HANDLER_API bool Activ::ContentPlatform::Feed::RecordMessageBuilder::IsInitialized ( ) const

Is the object initialized.

Returns:
whether the object is initialized.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/RecordMessageBuilder.h
Generated on Wed Oct 8 14:02:06 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::RecordMessageHeaderDefinitions

Activ::ContentPlatform::Feed::RecordMessageHeaderDefinitions Class Reference

Record message header definitions class. More...

#include <ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/RecordMessageHeaderDefinitions.h>

List of all members.

Public Types

typedef uint8_t | Flags
The flags type definition.

Static Public Member Functions

static void | ExtractFlags (const Flags flags, bool &isExpandedFormat, bool &isDoNotAdd)
Extract flags.
static Flags | GetFlags (const bool isExpandedFormat, const bool isDoNotAdd)
Get the flags.
static
MessageHeaderDefinitions::MessageHeader 		GetMessageHeader (const bool isDelete, const bool isRefresh, const MessageType messageType=MESSAGE_TYPE)
Get the message header.
static bool | IsDelete (const MessageHeaderDefinitions::MessageHeader messageHeader)
Is this a delete message.
static bool | IsDoNotAdd (const Flags flags)
Is this a do not add.
static bool | IsExpandedFormat (const Flags flags)
Is this a expanded format.
static bool | IsRefresh (const MessageHeaderDefinitions::MessageHeader messageHeader)
Is this a refresh message.
static bool | IsValidMessageType (const MessageHeaderDefinitions::MessageHeader messageHeader)
Is valid message type.

Static Public Attributes

static const Flags | FLAGS_DO_NOT_ADD_BIT_MASK = static_cast<Flags>((1 << FLAGS_DO_NOT_ADD_LENGTH) - 1)
static const size_t | FLAGS_DO_NOT_ADD_BIT_SHIFT = (sizeof(Flags) * CHAR_BIT) - (FLAGS_DO_NOT_ADD_OFFSET + FLAGS_DO_NOT_ADD_LENGTH)
static const size_t | FLAGS_DO_NOT_ADD_LENGTH = 1
The flags do not add length.
static const size_t | FLAGS_DO_NOT_ADD_OFFSET = (FLAGS_EXPANDED_FORMAT_OFFSET + FLAGS_EXPANDED_FORMAT_LENGTH)
The flags do not add offset.
static const Flags | FLAGS_EXPANDED_FORMAT_BIT_MASK = static_cast<Flags>((1 << FLAGS_EXPANDED_FORMAT_LENGTH) - 1)
static const size_t | FLAGS_EXPANDED_FORMAT_BIT_SHIFT = (sizeof(Flags) * CHAR_BIT) - (FLAGS_EXPANDED_FORMAT_OFFSET + FLAGS_EXPANDED_FORMAT_LENGTH)
static const size_t | FLAGS_EXPANDED_FORMAT_LENGTH = 1
The flags expanded format length.
static const size_t | FLAGS_EXPANDED_FORMAT_OFFSET = 0
The flags expanded format offset.
static const
MessageHeaderDefinitions::MessageHeader 		MESSAGE_HEADER_FLAGS_DELETE_BIT_MASK = static_cast<MessageHeaderDefinitions::MessageHeader>((1 << MESSAGE_HEADER_FLAGS_DELETE_LENGTH) - 1)
static const size_t | MESSAGE_HEADER_FLAGS_DELETE_BIT_SHIFT = MessageHeaderDefinitions::FLAGS_LENGTH - (MESSAGE_HEADER_FLAGS_DELETE_OFFSET + MESSAGE_HEADER_FLAGS_DELETE_LENGTH)
static const size_t | MESSAGE_HEADER_FLAGS_DELETE_LENGTH = 1
The message header flags delete length.
static const size_t | MESSAGE_HEADER_FLAGS_DELETE_OFFSET = 0
The message header flags delete offset.
static const
MessageHeaderDefinitions::MessageHeader 		MESSAGE_HEADER_FLAGS_REFRESH_BIT_MASK = static_cast<MessageHeaderDefinitions::MessageHeader>((1 << MESSAGE_HEADER_FLAGS_REFRESH_LENGTH) - 1)
static const size_t | MESSAGE_HEADER_FLAGS_REFRESH_BIT_SHIFT = MessageHeaderDefinitions::FLAGS_LENGTH - (MESSAGE_HEADER_FLAGS_REFRESH_OFFSET + MESSAGE_HEADER_FLAGS_REFRESH_LENGTH)
static const size_t | MESSAGE_HEADER_FLAGS_REFRESH_LENGTH = 1
The message header flags refresh length.
static const size_t | MESSAGE_HEADER_FLAGS_REFRESH_OFFSET = (MESSAGE_HEADER_FLAGS_DELETE_OFFSET + MESSAGE_HEADER_FLAGS_DELETE_LENGTH)
The message header flags refresh offset.
static const MessageType | MESSAGE_TYPE = MESSAGE_TYPE_RECORD
The message type.

Detailed Description

Record message header definitions class.

Definition at line 28 of file RecordMessageHeaderDefinitions.h.

Member Function Documentation

void Activ::ContentPlatform::Feed::RecordMessageHeaderDefinitions::ExtractFlags | ( | const Flags | flags,
 |  | bool & | isExpandedFormat,
 |  | bool & | isDoNotAdd |
 | ) |  |  | [inline, static]

Extract flags.

Parameters:
flags | the flags to extract from.
isExpandedFormat | set equal to true if this is a expanded format.
isDoNotAdd | set equal to true if this is a do not add.

Definition at line 168 of file RecordMessageHeaderDefinitions.h.

References IsDoNotAdd(), and IsExpandedFormat().

RecordMessageHeaderDefinitions::Flags Activ::ContentPlatform::Feed::RecordMessageHeaderDefinitions::GetFlags | ( | const bool | isExpandedFormat,
 |  | const bool | isDoNotAdd |
 | ) |  |  | [inline, static]

Get the flags.

Parameters:
isExpandedFormat | whether this is a expanded format.
isDoNotAdd | whether this is a do not add.
Returns:
the flags.

Definition at line 161 of file RecordMessageHeaderDefinitions.h.

MessageHeaderDefinitions::MessageHeader Activ::ContentPlatform::Feed::RecordMessageHeaderDefinitions::GetMessageHeader | ( | const bool | isDelete,
 |  | const bool | isRefresh,
 |  | const MessageType | messageType = MESSAGE_TYPE |
 | ) |  |  | [inline, static]

Get the message header.

Parameters:
isDelete | whether this is a delete message.
isRefresh | whether this is a refresh message.
messageType | the message type.
Returns:
the message header.

Definition at line 133 of file RecordMessageHeaderDefinitions.h.

References Activ::ContentPlatform::Feed::MessageHeaderDefinitions::GetMessageHeader().

bool Activ::ContentPlatform::Feed::RecordMessageHeaderDefinitions::IsDelete ( const MessageHeaderDefinitions::MessageHeader messageHeader ) [inline, static]

Is this a delete message.

Parameters:
messageHeader the message header.
Returns:
whether this is a delete message.

Definition at line 147 of file RecordMessageHeaderDefinitions.h.

References Activ::ContentPlatform::Feed::MessageHeaderDefinitions::GetFlags().

bool Activ::ContentPlatform::Feed::RecordMessageHeaderDefinitions::IsDoNotAdd ( const Flags flags ) [inline, static]

Is this a do not add.

Parameters:
flags the flags.
Returns:
whether this is a do not add.

Definition at line 183 of file RecordMessageHeaderDefinitions.h.

Referenced by ExtractFlags().

bool Activ::ContentPlatform::Feed::RecordMessageHeaderDefinitions::IsExpandedFormat ( const Flags flags ) [inline, static]

Is this a expanded format.

Parameters:
flags the flags.
Returns:
whether this is a expanded format.

Definition at line 176 of file RecordMessageHeaderDefinitions.h.

Referenced by ExtractFlags().

bool Activ::ContentPlatform::Feed::RecordMessageHeaderDefinitions::IsRefresh ( const MessageHeaderDefinitions::MessageHeader messageHeader ) [inline, static]

Is this a refresh message.

Parameters:
messageHeader the message header.
Returns:
whether this is a refresh message.

Definition at line 154 of file RecordMessageHeaderDefinitions.h.

References Activ::ContentPlatform::Feed::MessageHeaderDefinitions::GetFlags().

bool Activ::ContentPlatform::Feed::RecordMessageHeaderDefinitions::IsValidMessageType ( const MessageHeaderDefinitions::MessageHeader messageHeader ) [inline, static]

Is valid message type.

Parameters:
messageHeader the message header.
Returns:
whether the message type is valid.

Definition at line 140 of file RecordMessageHeaderDefinitions.h.

References Activ::ContentPlatform::Feed::MessageHeaderDefinitions::IsValidMessageType(), and MESSAGE_TYPE.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/RecordMessageHeaderDefinitions.h
Generated on Wed Oct 8 14:02:07 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::RecordMessageHeaderValidator

Activ::ContentPlatform::Feed::RecordMessageHeaderValidator Class Reference

Record message header validator class. More...

#include <ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/RecordMessageHeaderValidator.h>

List of all members.

Public Types

typedef
RecordKeyFieldListValidator::ConstIterator 		ConstKeyFieldIterator
Definition of the const key field iterator type.

Public Member Functions

ACTIV_FEED_MESSAGE_HANDLER_API
ConstKeyFieldIterator 		BeginKeyField () const
Get an iterator to the first key field in the message.
ACTIV_FEED_MESSAGE_HANDLER_API void | Clear ()
Clear.
ACTIV_FEED_MESSAGE_HANDLER_API
std::string 		CompositeUpdateIdToString () const
Copy Composite Update ID to string.
ACTIV_FEED_MESSAGE_HANDLER_API
ConstKeyFieldIterator 		EndKeyField () const
Get an iterator that points to beyond the last key field in the message.
ACTIV_FEED_MESSAGE_HANDLER_API
std::string 		EventTypeToString () const
Copy Event Type to string.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		GetEventType (EventType &eventType) const
Get the event type.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		GetIndexNumber (IndexNumber &indexNumber) const
Get the index number.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		GetKeyField (const FieldId fieldId, const IFieldType *&pIFieldType) const
Get a key field.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		GetPermissionId (PermissionId &permissionId) const
Get the permission id.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		GetTableTemplate (const TableTemplate *&pTableTemplate) const
Get the table template.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		GetUpdateId (UpdateId &updateId) const
Get the update id.
ACTIV_FEED_MESSAGE_HANDLER_API
std::string 		IndexNameToString (const Index *pIndex) const
Copy Index Name to string.
ACTIV_FEED_MESSAGE_HANDLER_API
std::string 		IndexNumberToString () const
Copy Index Number to string.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		Initialize (MessageValidator &messageValidator)
Initialize with a new message header validator.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		Initialize (const TableTemplateList &tableTemplateList, const bool shouldIgnoreMissingTableTemplate=false)
Initialize with a new table template list (and reset the object).
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		Initialize (const TableTemplateList &tableTemplateList, MessageValidator &messageValidator, const bool shouldIgnoreMissingTableTemplate=false)
Initialize with a new table template list and message header validator.
ACTIV_FEED_MESSAGE_HANDLER_API bool | IsDelete () const
Is this a delete message.
ACTIV_FEED_MESSAGE_HANDLER_API
std::string 		IsDeleteToString () const
Copy m_isDelete to string.
ACTIV_FEED_MESSAGE_HANDLER_API bool | IsInitialized () const
Is the object initialized.
ACTIV_FEED_MESSAGE_HANDLER_API bool | IsRefresh () const
Is this a refresh message.
ACTIV_FEED_MESSAGE_HANDLER_API
std::string 		IsRefreshToString () const
Copy m_isRefresh to string.
ACTIV_FEED_MESSAGE_HANDLER_API
std::string 		PermissionIdToString () const
Copy Permission ID to string.
ACTIV_FEED_MESSAGE_HANDLER_API | RecordMessageHeaderValidator (const TableTemplateList &tableTemplateList, const bool shouldIgnoreMissingTableTemplate=false)
Constructor.
ACTIV_FEED_MESSAGE_HANDLER_API | RecordMessageHeaderValidator (const TableTemplateList &tableTemplateList, MessageValidator &messageValidator, const bool shouldIgnoreMissingTableTemplate=false)
Constructor.
ACTIV_FEED_MESSAGE_HANDLER_API | RecordMessageHeaderValidator ()
Default constructor.
ACTIV_FEED_MESSAGE_HANDLER_API void | Reset ()
Reset.
ACTIV_FEED_MESSAGE_HANDLER_API
std::string 		TableTemplateIdToString () const
Copy TableTemplate ID to string.
ACTIV_FEED_MESSAGE_HANDLER_API
std::string 		TableTemplateNameToString () const
Copy TableTemplate Name to string.
ACTIV_FEED_MESSAGE_HANDLER_API
std::string 		ToString () const
Copy Record Message Header to string.
ACTIV_FEED_MESSAGE_HANDLER_API
std::string 		UpdateIdToString () const
Copy Update ID Name to string.
ACTIV_FEED_MESSAGE_HANDLER_API | ~RecordMessageHeaderValidator ()
Destructor.

Friends

class | RecordMessageValidator

Detailed Description

Record message header validator class.

Definition at line 33 of file RecordMessageHeaderValidator.h.

Constructor & Destructor Documentation

ACTIV_FEED_MESSAGE_HANDLER_API Activ::ContentPlatform::Feed::RecordMessageHeaderValidator::RecordMessageHeaderValidator | ( | const TableTemplateList & | tableTemplateList,
 |  | MessageValidator & | messageValidator,
 |  | const bool | shouldIgnoreMissingTableTemplate = false
 | ) |  |

Constructor.

Parameters:
tableTemplateList | the table template list.
messageValidator | the message header validator.
shouldIgnoreMissingTableTemplate | whether a message for a table template missing from the table template list should be ignored.
Exceptions:
StatusCodeException

ACTIV_FEED_MESSAGE_HANDLER_API Activ::ContentPlatform::Feed::RecordMessageHeaderValidator::RecordMessageHeaderValidator | ( | const TableTemplateList & | tableTemplateList,
 |  | const bool | shouldIgnoreMissingTableTemplate = false
 | ) |  |

Constructor.

Parameters:
tableTemplateList | the table template list.
shouldIgnoreMissingTableTemplate | whether a message for a table template missing from the table template list should be ignored.
Exceptions:
StatusCodeException

Member Function Documentation

ACTIV_FEED_MESSAGE_HANDLER_API ConstKeyFieldIterator Activ::ContentPlatform::Feed::RecordMessageHeaderValidator::BeginKeyField ( ) const

Get an iterator to the first key field in the message.

Returns:
an iterator object.
Exceptions:
StatusCodeException

ACTIV_FEED_MESSAGE_HANDLER_API std::string Activ::ContentPlatform::Feed::RecordMessageHeaderValidator::CompositeUpdateIdToString ( ) const

Copy Composite Update ID to string.

Returns:
formatted string

ACTIV_FEED_MESSAGE_HANDLER_API ConstKeyFieldIterator Activ::ContentPlatform::Feed::RecordMessageHeaderValidator::EndKeyField ( ) const

Get an iterator that points to beyond the last key field in the message.

Returns:
an iterator object.
Exceptions:
StatusCodeException

ACTIV_FEED_MESSAGE_HANDLER_API std::string Activ::ContentPlatform::Feed::RecordMessageHeaderValidator::EventTypeToString ( ) const

Copy Event Type to string.

Returns:
formatted string

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::RecordMessageHeaderValidator::GetEventType ( EventType & eventType ) const

Get the event type.

Parameters:
eventType the event type.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::RecordMessageHeaderValidator::GetIndexNumber ( IndexNumber & indexNumber ) const

Get the index number.

Parameters:
indexNumber the index number.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::RecordMessageHeaderValidator::GetKeyField | ( | const FieldId | fieldId,
 |  | const IFieldType *& | pIFieldType |
 | ) |  |  | const

Get a key field.

Parameters:
fieldId | the field id.
pIFieldType | a pointer to the field.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED
...

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::RecordMessageHeaderValidator::GetPermissionId ( PermissionId & permissionId ) const

Get the permission id.

Parameters:
permissionId the permission id.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::RecordMessageHeaderValidator::GetTableTemplate ( const TableTemplate *& pTableTemplate ) const

Get the table template.

Parameters:
pTableTemplate a pointer to the table template.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::RecordMessageHeaderValidator::GetUpdateId ( UpdateId & updateId ) const

Get the update id.

Parameters:
updateId the update id.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_FAILURE
STATUS_CODE_NOT_INITIALIZED

ACTIV_FEED_MESSAGE_HANDLER_API std::string Activ::ContentPlatform::Feed::RecordMessageHeaderValidator::IndexNameToString ( const Index * pIndex ) const

Copy Index Name to string.

Returns:
formatted string

ACTIV_FEED_MESSAGE_HANDLER_API std::string Activ::ContentPlatform::Feed::RecordMessageHeaderValidator::IndexNumberToString ( ) const

Copy Index Number to string.

Returns:
formatted string

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::RecordMessageHeaderValidator::Initialize ( MessageValidator & messageValidator )

Initialize with a new message header validator.

Parameters:
messageValidator the message header validator.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_IGNORED
...

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::RecordMessageHeaderValidator::Initialize | ( | const TableTemplateList & | tableTemplateList,
 |  | const bool | shouldIgnoreMissingTableTemplate = false
 | ) |  |

Initialize with a new table template list (and reset the object).

Parameters:
tableTemplateList | the table template list.
shouldIgnoreMissingTableTemplate | whether a message for a table template missing from the table template list should be ignored.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_IGNORED
...

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::RecordMessageHeaderValidator::Initialize | ( | const TableTemplateList & | tableTemplateList,
 |  | MessageValidator & | messageValidator,
 |  | const bool | shouldIgnoreMissingTableTemplate = false
 | ) |  |

Initialize with a new table template list and message header validator.

Parameters:
tableTemplateList | the table template list.
messageValidator | the message header validator.
shouldIgnoreMissingTableTemplate | whether a message for a table template missing from the table template list should be ignored.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_IGNORED
...

ACTIV_FEED_MESSAGE_HANDLER_API bool Activ::ContentPlatform::Feed::RecordMessageHeaderValidator::IsDelete ( ) const

Is this a delete message.

Returns:
whether this is a delete message.

ACTIV_FEED_MESSAGE_HANDLER_API std::string Activ::ContentPlatform::Feed::RecordMessageHeaderValidator::IsDeleteToString ( ) const

Copy m_isDelete to string.

Returns:
formatted string

ACTIV_FEED_MESSAGE_HANDLER_API bool Activ::ContentPlatform::Feed::RecordMessageHeaderValidator::IsInitialized ( ) const

Is the object initialized.

Returns:
whether the object is initialized.

ACTIV_FEED_MESSAGE_HANDLER_API bool Activ::ContentPlatform::Feed::RecordMessageHeaderValidator::IsRefresh ( ) const

Is this a refresh message.

Returns:
whether this is a refresh message.

ACTIV_FEED_MESSAGE_HANDLER_API std::string Activ::ContentPlatform::Feed::RecordMessageHeaderValidator::IsRefreshToString ( ) const

Copy m_isRefresh to string.

Returns:
formatted string

ACTIV_FEED_MESSAGE_HANDLER_API std::string Activ::ContentPlatform::Feed::RecordMessageHeaderValidator::PermissionIdToString ( ) const

Copy Permission ID to string.

Returns:
formatted string

ACTIV_FEED_MESSAGE_HANDLER_API std::string Activ::ContentPlatform::Feed::RecordMessageHeaderValidator::TableTemplateIdToString ( ) const

Copy TableTemplate ID to string.

Returns:
formatted string

ACTIV_FEED_MESSAGE_HANDLER_API std::string Activ::ContentPlatform::Feed::RecordMessageHeaderValidator::TableTemplateNameToString ( ) const

Copy TableTemplate Name to string.

Returns:
formatted string

ACTIV_FEED_MESSAGE_HANDLER_API std::string Activ::ContentPlatform::Feed::RecordMessageHeaderValidator::ToString ( ) const

Copy Record Message Header to string.

Returns:
formatted string

ACTIV_FEED_MESSAGE_HANDLER_API std::string Activ::ContentPlatform::Feed::RecordMessageHeaderValidator::UpdateIdToString ( ) const

Copy Update ID Name to string.

Returns:
formatted string

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/RecordMessageHeaderValidator.h
Generated on Wed Oct 8 14:02:07 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::RecordMessageValidator

Activ::ContentPlatform::Feed::RecordMessageValidator Class Reference

Record message validator class. More...

#include <ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/RecordMessageValidator.h>

List of all members.

Public Types

typedef
RecordFieldListValidator::ConstIterator 		ConstFieldIterator
Definition of the const field iterator type.
typedef
RecordKeyFieldListValidator::ConstIterator 		ConstKeyFieldIterator
Definition of the const key field iterator type.

Public Member Functions

ACTIV_FEED_MESSAGE_HANDLER_API
ConstFieldIterator 		BeginField () const
Get an iterator to the first field in the message.
ACTIV_FEED_MESSAGE_HANDLER_API
ConstKeyFieldIterator 		BeginKeyField () const
Get an iterator to the first key field in the message.
ACTIV_FEED_MESSAGE_HANDLER_API void | Clear ()
Clear.
ACTIV_FEED_MESSAGE_HANDLER_API
ConstFieldIterator 		EndField () const
Get an iterator that points to beyond the last field in the message.
ACTIV_FEED_MESSAGE_HANDLER_API
ConstKeyFieldIterator 		EndKeyField () const
Get an iterator that points to beyond the last key field in the message.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		GetEventType (EventType &eventType) const
Get the event type.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		GetField (const FieldId fieldId, const IFieldType *&pIFieldType) const
Get a field.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		GetIndexNumber (IndexNumber &indexNumber) const
Get the index number.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		GetKeyField (const FieldId fieldId, const IFieldType *&pIFieldType) const
Get a key field.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		GetPermissionId (PermissionId &permissionId) const
Get the permission id.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		GetTableTemplate (const TableTemplate *&pTableTemplate) const
Get the table template.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		GetUpdateId (UpdateId &updateId) const
Get the update id.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		Initialize (MessageValidator &messageValidator, const bool shouldIgnoreUndefinedMissingFields=false)
Initialize with a new message validator.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		Initialize (const TableTemplateList &tableTemplateList, const bool shouldIgnoreMissingTableTemplate=false)
Initialize with a new table template list (and reset the object).
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		Initialize (const TableTemplateList &tableTemplateList, MessageValidator &messageValidator, const bool shouldIgnoreMissingTableTemplate=false, const bool shouldIgnoreUndefinedMissingFields=false)
Initialize with a new table template list and message validator.
ACTIV_FEED_MESSAGE_HANDLER_API bool | IsDelete () const
Is this a delete message.
ACTIV_FEED_MESSAGE_HANDLER_API bool | IsInitialized () const
Is the object initialized.
ACTIV_FEED_MESSAGE_HANDLER_API bool | IsRefresh () const
Is this a refresh message.
ACTIV_FEED_MESSAGE_HANDLER_API | RecordMessageValidator (const TableTemplateList &tableTemplateList, const bool shouldIgnoreMissingTableTemplate=false)
Constructor.
ACTIV_FEED_MESSAGE_HANDLER_API | RecordMessageValidator (const TableTemplateList &tableTemplateList, MessageValidator &messageValidator, const bool shouldIgnoreMissingTableTemplate=false, const bool shouldIgnoreUndefinedMissingFields=false)
Constructor.
ACTIV_FEED_MESSAGE_HANDLER_API | RecordMessageValidator ()
Default constructor.
ACTIV_FEED_MESSAGE_HANDLER_API void | Reset ()
Reset.
ACTIV_FEED_MESSAGE_HANDLER_API
std::string 		ToString () const
Copy Record Message to string.
ACTIV_FEED_MESSAGE_HANDLER_API | ~RecordMessageValidator ()
Destructor.

Detailed Description

Record message validator class.

Definition at line 41 of file RecordMessageValidator.h.

Constructor & Destructor Documentation

ACTIV_FEED_MESSAGE_HANDLER_API Activ::ContentPlatform::Feed::RecordMessageValidator::RecordMessageValidator | ( | const TableTemplateList & | tableTemplateList,
 |  | MessageValidator & | messageValidator,
 |  | const bool | shouldIgnoreMissingTableTemplate = false,
 |  | const bool | shouldIgnoreUndefinedMissingFields = false
 | ) |  |

Constructor.

Parameters:
tableTemplateList | the table template list.
messageValidator | the message validator.
shouldIgnoreMissingTableTemplate | whether a message for a table template missing from the table template list should be ignored.
shouldIgnoreUndefinedMissingFields | whether undefined fields in the message that are missing from the table template should be ignored.
Exceptions:
StatusCodeException

ACTIV_FEED_MESSAGE_HANDLER_API Activ::ContentPlatform::Feed::RecordMessageValidator::RecordMessageValidator | ( | const TableTemplateList & | tableTemplateList,
 |  | const bool | shouldIgnoreMissingTableTemplate = false
 | ) |  |

Constructor.

Parameters:
tableTemplateList | the table template list.
shouldIgnoreMissingTableTemplate | whether a message for a table template missing from the table template list should be ignored.
Exceptions:
StatusCodeException

Member Function Documentation

ACTIV_FEED_MESSAGE_HANDLER_API ConstFieldIterator Activ::ContentPlatform::Feed::RecordMessageValidator::BeginField ( ) const

Get an iterator to the first field in the message.

Returns:
an iterator object.
Exceptions:
StatusCodeException

ACTIV_FEED_MESSAGE_HANDLER_API ConstKeyFieldIterator Activ::ContentPlatform::Feed::RecordMessageValidator::BeginKeyField ( ) const

Get an iterator to the first key field in the message.

Returns:
an iterator object.
Exceptions:
StatusCodeException

ACTIV_FEED_MESSAGE_HANDLER_API ConstFieldIterator Activ::ContentPlatform::Feed::RecordMessageValidator::EndField ( ) const

Get an iterator that points to beyond the last field in the message.

Returns:
an iterator object.
Exceptions:
StatusCodeException

ACTIV_FEED_MESSAGE_HANDLER_API ConstKeyFieldIterator Activ::ContentPlatform::Feed::RecordMessageValidator::EndKeyField ( ) const

Get an iterator that points to beyond the last key field in the message.

Returns:
an iterator object.
Exceptions:
StatusCodeException

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::RecordMessageValidator::GetEventType ( EventType & eventType ) const

Get the event type.

Parameters:
eventType the event type.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::RecordMessageValidator::GetField | ( | const FieldId | fieldId,
 |  | const IFieldType *& | pIFieldType |
 | ) |  |  | const

Get a field.

Parameters:
fieldId | the field id.
pIFieldType | a pointer to the field.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED
...

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::RecordMessageValidator::GetIndexNumber ( IndexNumber & indexNumber ) const

Get the index number.

Parameters:
indexNumber the index number.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::RecordMessageValidator::GetKeyField | ( | const FieldId | fieldId,
 |  | const IFieldType *& | pIFieldType |
 | ) |  |  | const

Get a key field.

Parameters:
fieldId | the field id.
pIFieldType | a pointer to the field.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED
...

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::RecordMessageValidator::GetPermissionId ( PermissionId & permissionId ) const

Get the permission id.

Parameters:
permissionId the permission id.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::RecordMessageValidator::GetTableTemplate ( const TableTemplate *& pTableTemplate ) const

Get the table template.

Parameters:
pTableTemplate a pointer to the table template.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::RecordMessageValidator::GetUpdateId ( UpdateId & updateId ) const

Get the update id.

Parameters:
updateId the update id.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_FAILURE
STATUS_CODE_NOT_INITIALIZED

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::RecordMessageValidator::Initialize | ( | MessageValidator & | messageValidator,
 |  | const bool | shouldIgnoreUndefinedMissingFields = false
 | ) |  |

Initialize with a new message validator.

Parameters:
messageValidator | the message validator.
shouldIgnoreUndefinedMissingFields | whether undefined fields in the message that are missing from the table template should be ignored.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_IGNORED
...

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::RecordMessageValidator::Initialize | ( | const TableTemplateList & | tableTemplateList,
 |  | const bool | shouldIgnoreMissingTableTemplate = false
 | ) |  |

Initialize with a new table template list (and reset the object).

Parameters:
tableTemplateList | the table template list.
shouldIgnoreMissingTableTemplate | whether a message for a table template missing from the table template list should be ignored.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_IGNORED
...

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::RecordMessageValidator::Initialize | ( | const TableTemplateList & | tableTemplateList,
 |  | MessageValidator & | messageValidator,
 |  | const bool | shouldIgnoreMissingTableTemplate = false,
 |  | const bool | shouldIgnoreUndefinedMissingFields = false
 | ) |  |

Initialize with a new table template list and message validator.

Parameters:
tableTemplateList | the table template list.
messageValidator | the message validator.
shouldIgnoreMissingTableTemplate | whether a message for a table template missing from the table template list should be ignored.
shouldIgnoreUndefinedMissingFields | whether undefined fields in the message that are missing from the table template should be ignored.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_IGNORED
...

ACTIV_FEED_MESSAGE_HANDLER_API bool Activ::ContentPlatform::Feed::RecordMessageValidator::IsDelete ( ) const

Is this a delete message.

Returns:
whether this is a delete message.

ACTIV_FEED_MESSAGE_HANDLER_API bool Activ::ContentPlatform::Feed::RecordMessageValidator::IsInitialized ( ) const

Is the object initialized.

Returns:
whether the object is initialized.

ACTIV_FEED_MESSAGE_HANDLER_API bool Activ::ContentPlatform::Feed::RecordMessageValidator::IsRefresh ( ) const

Is this a refresh message.

Returns:
whether this is a refresh message.

ACTIV_FEED_MESSAGE_HANDLER_API std::string Activ::ContentPlatform::Feed::RecordMessageValidator::ToString ( ) const

Copy Record Message to string.

Returns:
string.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/RecordMessageValidator.h
Generated on Wed Oct 8 14:02:07 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::RelationshipIdHelper

Activ::ContentPlatform::Feed::RelationshipIdHelper Class Reference

Relationship id helper class. More...

#include <ActivContentPlatform/ActivFeedCommon/RelationshipIdHelper.h>

List of all members.

Public Member Functions

RelationshipIdHelper (const RelationshipId relationshipId, const char *const pName, const char *const pCodeIdentifier)
Constructor.
RelationshipIdHelper ()
Default constructor.

Public Attributes

std::string | m_codeIdentifier
The code identifier for the relationship id.
std::string | m_name
The name of the relationship id.
RelationshipId | m_relationshipId
The relationship id.

Detailed Description

Relationship id helper class.

Definition at line 28 of file RelationshipIdHelper.h.

Constructor & Destructor Documentation

Activ::ContentPlatform::Feed::RelationshipIdHelper::RelationshipIdHelper | ( | const RelationshipId | relationshipId,
 |  | const char *const | pName,
 |  | const char *const | pCodeIdentifier |
 | ) |  |  | [inline]

Constructor.

Parameters:
relationshipId | the relationship id.
pName | the name of the relationship id.
pCodeIdentifier | the code identifer for the relationship id.

Definition at line 59 of file RelationshipIdHelper.h.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivFeedCommon/RelationshipIdHelper.h
Generated on Wed Oct 8 14:02:07 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::Rule

Activ::ContentPlatform::Feed::Rule Class Reference

Rule class. More...

#include <ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/Rule.h>

List of all members.

Public Member Functions

void | Clear ()
Clear the contents.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
StatusCode 		Initialize (const TableTemplate &tableTemplate, const xercesc::DOMNode &domNode)
Initialize from the dom node in the xml file.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
StatusCode 		Initialize (const TableTemplate &tableTemplate, const FieldId source, const FieldId size, const FieldId condition, const FieldId time, const FieldId date, const FieldId exchange, const FieldId previousDayTrend, const CopyToFields &copyToFields, const HighFields &highFields, const LowFields &lowFields, const OpenFields &openFields, const CloseFields &closeFields, const PriceFields &priceFields, const VolumeFields &volumeFields)
Initialize from the fields ids.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
StatusCode 		InitializeSourceFields (const xercesc::DOMNode &domNode)
Initialize source fields from the dom node in the xml file.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
bool 		operator!= (const Rule &rhs) const
Inequality operator.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
bool 		operator== (const Rule &rhs) const
Equality operator.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API | Rule (const TableTemplate &tableTemplate, const xercesc::DOMNode &domNode)
Construct from the dom node in the xml file.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API | Rule (const TableTemplate &tableTemplate, const FieldId source, const FieldId size, const FieldId condition, const FieldId time, const FieldId date, const FieldId exchange, const FieldId previousDayTrend, const CopyToFields &copyToFields, const HighFields &highFields, const LowFields &lowFields, const OpenFields &openFields, const CloseFields &closeFields, const PriceFields &priceFields, const VolumeFields &volumeFields)
Construct from the dom node in the xml file.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API | Rule ()
Default constructor.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
std::string 		ToString () const
Convert the specification to a C-style string.

Static Public Member Functions

static bool | IsDefined (const FieldId fieldId)
Check whether the field is defined.

Public Attributes

CloseFields m_closeFields
The close fields.
FieldId | m_condition
The condition field.
CopyToFields m_copyToFields
The copy to fields.
FieldId | m_date
The date field.
std::string | m_error
The error string.
FieldId | m_exchange
The exchange field.
HighFields m_highFields
The high fields.
LowFields m_lowFields
The low fields.
OpenFields m_openFields
The open fields.
FieldId | m_previousDayTrend
The previous day trend field.
PriceFields m_priceFields
The price fields.
const TableTemplate * | m_pTableTemplate
The table template.
FieldId | m_size
The size field.
FieldId | m_source
The source the source field.
FieldId | m_time
The time field.
VolumeFields m_volumeFields
The volume fields.

Classes

class | CloseFields
Close fields class. More...
class | CopyToFields
Copy To fields class. More...
class | HighFields
High fields class. More...
class | LowFields
Low fields class. More...
class | OpenFields
Open fields class. More...
class | PriceFields
Price fields class. More...
class | VolumeFields
Volume fields class. More...

Detailed Description

Rule class.

Definition at line 36 of file Rule.h.

Constructor & Destructor Documentation

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API Activ::ContentPlatform::Feed::Rule::Rule | ( | const TableTemplate & | tableTemplate,
 |  | const FieldId | source,
 |  | const FieldId | size,
 |  | const FieldId | condition,
 |  | const FieldId | time,
 |  | const FieldId | date,
 |  | const FieldId | exchange,
 |  | const FieldId | previousDayTrend,
 |  | const CopyToFields & | copyToFields,
 |  | const HighFields & | highFields,
 |  | const LowFields & | lowFields,
 |  | const OpenFields & | openFields,
 |  | const CloseFields & | closeFields,
 |  | const PriceFields & | priceFields,
 |  | const VolumeFields & | volumeFields
 | ) |  |

Construct from the dom node in the xml file.

Parameters:
tableTemplate | the table template.
source | the source field.
size | the size field.
condition | the condition field.
time | the time field.
date | the date field.
exchange | the exchange field.
previousDayTrend | the previous day trend field.
copyToFields | the copy to fields.
highFields | the high fields
lowFields | the low fields
openFields | the open fields
closeFields | the close fields.
priceFields | the price fields.
volumeFields | the volume fields.

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API Activ::ContentPlatform::Feed::Rule::Rule | ( | const TableTemplate & | tableTemplate,
 |  | const xercesc::DOMNode & | domNode
 | ) |  |

Construct from the dom node in the xml file.

Parameters:
tableTemplate | the table template.
domNode | the dom node.

Member Function Documentation

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::Rule::Initialize | ( | const TableTemplate & | tableTemplate,
 |  | const xercesc::DOMNode & | domNode
 | ) |  |

Initialize from the dom node in the xml file.

Parameters:
tableTemplate | the table template.
domNode | the dom node.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_FAILURE

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::Rule::Initialize | ( | const TableTemplate & | tableTemplate,
 |  | const FieldId | source,
 |  | const FieldId | size,
 |  | const FieldId | condition,
 |  | const FieldId | time,
 |  | const FieldId | date,
 |  | const FieldId | exchange,
 |  | const FieldId | previousDayTrend,
 |  | const CopyToFields & | copyToFields,
 |  | const HighFields & | highFields,
 |  | const LowFields & | lowFields,
 |  | const OpenFields & | openFields,
 |  | const CloseFields & | closeFields,
 |  | const PriceFields & | priceFields,
 |  | const VolumeFields & | volumeFields
 | ) |  |

Initialize from the fields ids.

Parameters:
tableTemplate | the table template.
source | the source field.
size | the size field.
condition | the condition field.
time | the time field.
date | the date field.
exchange | the exchange field.
previousDayTrend | the previous day trend field.
copyToFields | the copy to fields.
highFields | the high fields
lowFields | the low fields
openFields | the open fields
closeFields | the close fields.
priceFields | the price fields.
volumeFields | the volume fields.
Return values:
STATUS_CODE_SUCCESS

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::Rule::InitializeSourceFields ( const xercesc::DOMNode & domNode )

Initialize source fields from the dom node in the xml file.

Parameters:
domNode the dom node.

static bool Activ::ContentPlatform::Feed::Rule::IsDefined ( const FieldId fieldId ) [inline, static]

Check whether the field is defined.

Parameters:
fieldId the field id to check.
Returns:
true if the field id is defined, false otherwise.

Definition at line 869 of file Rule.h.

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API bool Activ::ContentPlatform::Feed::Rule::operator!= ( const Rule & rhs ) const

Inequality operator.

Parameters:
rhs the object to test against.
Returns:
whether the two objects are not equal.

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API bool Activ::ContentPlatform::Feed::Rule::operator== ( const Rule & rhs ) const

Equality operator.

Parameters:
rhs the object to test against.
Returns:
whether the two objects are equal.

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API std::string Activ::ContentPlatform::Feed::Rule::ToString ( ) const

Convert the specification to a C-style string.

Returns:
the specification as a string.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/Rule.h
Generated on Wed Oct 8 14:02:07 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::Rule::CloseFields

Activ::ContentPlatform::Feed::Rule::CloseFields Class Reference

Close fields class. More...

#include <ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/Rule.h>

List of all members.

Public Member Functions

void | Clear ()
Clear the contents.
CloseFields (const TableTemplate &tableTemplate, const xercesc::DOMNode &domNode)
Construct from the dom node in the xml file.
CloseFields (const TableTemplate &tableTemplate, const FieldId target, const FieldId condition, const FieldId status, const FieldId date, const FieldId exchange)
Construct from the fields ids.
CloseFields ()
Default constructor.
StatusCode | Initialize (const TableTemplate &tableTemplate, const xercesc::DOMNode &domNode)
Initialize from the dom node in the xml file.
StatusCode | Initialize (const TableTemplate &tableTemplate, const FieldId target, const FieldId condition, const FieldId status, const FieldId date, const FieldId exchange)
Initialize from the fields ids.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
bool 		operator!= (const CloseFields &rhs) const
Inequality operator.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
bool 		operator== (const CloseFields &rhs) const
Equality operator.
std::string | ToString () const
Convert the fields to a C-style string.

Public Attributes

FieldId | m_condition
The close condition.
FieldId | m_date
The close date field.
std::string | m_error
The error string.
FieldId | m_exchange
The close exchange field.
const TableTemplate * | m_pTableTemplate
The table template.
FieldId | m_status
The close status field.
FieldId | m_target
The close field.

Detailed Description

Close fields class.

Definition at line 430 of file Rule.h.

Constructor & Destructor Documentation

Activ::ContentPlatform::Feed::Rule::CloseFields::CloseFields | ( | const TableTemplate & | tableTemplate,
 |  | const FieldId | target,
 |  | const FieldId | condition,
 |  | const FieldId | status,
 |  | const FieldId | date,
 |  | const FieldId | exchange
 | ) |  |

Construct from the fields ids.

Parameters:
tableTemplate | the table template.
target | the target close field.
condition | the close condition field.
status | the close status field.
date | the close date field.
exchange | the close exchange field.

Activ::ContentPlatform::Feed::Rule::CloseFields::CloseFields | ( | const TableTemplate & | tableTemplate,
 |  | const xercesc::DOMNode & | domNode
 | ) |  |

Construct from the dom node in the xml file.

Parameters:
tableTemplate | the table template.
domNode | the dom node.

Member Function Documentation

StatusCode Activ::ContentPlatform::Feed::Rule::CloseFields::Initialize | ( | const TableTemplate & | tableTemplate,
 |  | const xercesc::DOMNode & | domNode
 | ) |  |

Initialize from the dom node in the xml file.

Parameters:
tableTemplate | the table template.
domNode | the dom node.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_FAILURE

StatusCode Activ::ContentPlatform::Feed::Rule::CloseFields::Initialize | ( | const TableTemplate & | tableTemplate,
 |  | const FieldId | target,
 |  | const FieldId | condition,
 |  | const FieldId | status,
 |  | const FieldId | date,
 |  | const FieldId | exchange
 | ) |  |

Initialize from the fields ids.

Parameters:
tableTemplate | the table template.
target | the target close field.
condition | the close condition.
status | the close status field.
date | the close date field.
exchange | the close exchange field.
Return values:
STATUS_CODE_SUCCESS

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API bool Activ::ContentPlatform::Feed::Rule::CloseFields::operator!= ( const CloseFields & rhs ) const

Inequality operator.

Parameters:
rhs the object to test against.
Returns:
whether the two objects are not equal.

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API bool Activ::ContentPlatform::Feed::Rule::CloseFields::operator== ( const CloseFields & rhs ) const

Equality operator.

Parameters:
rhs the object to test against.
Returns:
whether the two objects are equal.

std::string Activ::ContentPlatform::Feed::Rule::CloseFields::ToString ( ) const

Convert the fields to a C-style string.

Returns:
the specification as a string.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/Rule.h
Generated on Wed Oct 8 14:02:07 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::Rule::CopyToFields

Activ::ContentPlatform::Feed::Rule::CopyToFields Class Reference

Copy To fields class. More...

#include <ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/Rule.h>

List of all members.

Public Member Functions

void | Clear ()
Clear the contents.
CopyToFields (const TableTemplate &tableTemplate, const xercesc::DOMNode &domNode)
Construct from the dom node in the xml file.
CopyToFields (const TableTemplate &tableTemplate, const FieldId target, const FieldId size, const FieldId condition, const FieldId time, const FieldId date, const FieldId exchange)
Construct from the fields ids.
CopyToFields ()
Default constructor.
StatusCode | Initialize (const TableTemplate &tableTemplate, const xercesc::DOMNode &domNode)
Initialize from the dom node in the xml file.
StatusCode | Initialize (const TableTemplate &tableTemplate, const FieldId target, const FieldId size, const FieldId condition, const FieldId time, const FieldId date, const FieldId exchange)
Initialize from the fields ids.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
bool 		operator!= (const CopyToFields &rhs) const
Inequality operator.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
bool 		operator== (const CopyToFields &rhs) const
Equality operator.
std::string | ToString () const
Convert the fields to a C-style string.

Public Attributes

FieldId | m_condition
The copy to condition field.
FieldId | m_date
The copy to date field.
std::string | m_error
The error string.
FieldId | m_exchange
The copy to exchange field.
const TableTemplate * | m_pTableTemplate
The table template.
FieldId | m_size
The copy to size field.
FieldId | m_target
The copy to field.
FieldId | m_time
The copy to time field.

Detailed Description

Copy To fields class.

Definition at line 42 of file Rule.h.

Constructor & Destructor Documentation

Activ::ContentPlatform::Feed::Rule::CopyToFields::CopyToFields | ( | const TableTemplate & | tableTemplate,
 |  | const FieldId | target,
 |  | const FieldId | size,
 |  | const FieldId | condition,
 |  | const FieldId | time,
 |  | const FieldId | date,
 |  | const FieldId | exchange
 | ) |  |

Construct from the fields ids.

Parameters:
tableTemplate | the table template.
target | the target copy to field.
size | the copy to size field.
condition | the copy to condition field.
time | the copy to time field.
date | the copy to date field.
exchange | the copy to exchange field.

Activ::ContentPlatform::Feed::Rule::CopyToFields::CopyToFields | ( | const TableTemplate & | tableTemplate,
 |  | const xercesc::DOMNode & | domNode
 | ) |  |

Construct from the dom node in the xml file.

Parameters:
tableTemplate | the table template.
domNode | the dom node.

Member Function Documentation

StatusCode Activ::ContentPlatform::Feed::Rule::CopyToFields::Initialize | ( | const TableTemplate & | tableTemplate,
 |  | const xercesc::DOMNode & | domNode
 | ) |  |

Initialize from the dom node in the xml file.

Parameters:
tableTemplate | the table template.
domNode | the dom node.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_FAILURE

StatusCode Activ::ContentPlatform::Feed::Rule::CopyToFields::Initialize | ( | const TableTemplate & | tableTemplate,
 |  | const FieldId | target,
 |  | const FieldId | size,
 |  | const FieldId | condition,
 |  | const FieldId | time,
 |  | const FieldId | date,
 |  | const FieldId | exchange
 | ) |  |

Initialize from the fields ids.

Parameters:
tableTemplate | the table template.
target | the target copy to field.
size | the copy to size field.
condition | the copy to condition field.
time | the copy to time field.
date | the copy to date field.
exchange | the copy to exchange field.
Return values:
STATUS_CODE_SUCCESS

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API bool Activ::ContentPlatform::Feed::Rule::CopyToFields::operator!= ( const CopyToFields & rhs ) const

Inequality operator.

Parameters:
rhs the object to test against.
Returns:
whether the two objects are not equal.

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API bool Activ::ContentPlatform::Feed::Rule::CopyToFields::operator== ( const CopyToFields & rhs ) const

Equality operator.

Parameters:
rhs the object to test against.
Returns:
whether the two objects are equal.

std::string Activ::ContentPlatform::Feed::Rule::CopyToFields::ToString ( ) const

Convert the fields to a C-style string.

Returns:
the specification as a string.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/Rule.h
Generated on Wed Oct 8 14:02:07 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::Rule::HighFields

Activ::ContentPlatform::Feed::Rule::HighFields Class Reference

High fields class. More...

#include <ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/Rule.h>

List of all members.

Public Member Functions

void | Clear ()
Clear the contents.
HighFields (const TableTemplate &tableTemplate, const xercesc::DOMNode &domNode)
Construct from the dom node in the xml file.
HighFields (const TableTemplate &tableTemplate, const FieldId target, const FieldId condition, const FieldId time, const FieldId date, const FieldId exchange)
Construct from the fields ids.
HighFields ()
Default constructor.
StatusCode | Initialize (const TableTemplate &tableTemplate, const xercesc::DOMNode &domNode)
Initialize from the dom node in the xml file.
StatusCode | Initialize (const TableTemplate &tableTemplate, const FieldId target, const FieldId condition, const FieldId time, const FieldId date, const FieldId exchange)
Initialize from the fields ids.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
bool 		operator!= (const HighFields &rhs) const
Inequality operator.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
bool 		operator== (const HighFields &rhs) const
Equality operator.
std::string | ToString () const
Convert the fields to a C-style string.

Public Attributes

FieldId | m_condition
The high condition field.
FieldId | m_date
The high date field.
std::string | m_error
The error string.
FieldId | m_exchange
The high exchange field.
const TableTemplate * | m_pTableTemplate
The table template.
FieldId | m_target
The high field.
FieldId | m_time
The high time field.

Detailed Description

High fields class.

Definition at line 142 of file Rule.h.

Constructor & Destructor Documentation

Activ::ContentPlatform::Feed::Rule::HighFields::HighFields | ( | const TableTemplate & | tableTemplate,
 |  | const FieldId | target,
 |  | const FieldId | condition,
 |  | const FieldId | time,
 |  | const FieldId | date,
 |  | const FieldId | exchange
 | ) |  |

Construct from the fields ids.

Parameters:
tableTemplate | the table template.
target | the target high field.
condition | the high condition field.
time | the high time field.
date | the high date field.
exchange | the high exchange field.

Activ::ContentPlatform::Feed::Rule::HighFields::HighFields | ( | const TableTemplate & | tableTemplate,
 |  | const xercesc::DOMNode & | domNode
 | ) |  |

Construct from the dom node in the xml file.

Parameters:
tableTemplate | the table template.
domNode | the dom node.

Member Function Documentation

StatusCode Activ::ContentPlatform::Feed::Rule::HighFields::Initialize | ( | const TableTemplate & | tableTemplate,
 |  | const xercesc::DOMNode & | domNode
 | ) |  |

Initialize from the dom node in the xml file.

Parameters:
tableTemplate | the table template.
domNode | the dom node.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_FAILURE

StatusCode Activ::ContentPlatform::Feed::Rule::HighFields::Initialize | ( | const TableTemplate & | tableTemplate,
 |  | const FieldId | target,
 |  | const FieldId | condition,
 |  | const FieldId | time,
 |  | const FieldId | date,
 |  | const FieldId | exchange
 | ) |  |

Initialize from the fields ids.

Parameters:
tableTemplate | the table template.
target | the target high field.
condition | the high condition field.
time | the high time field.
date | the high date field.
exchange | the high exchange field.
Return values:
STATUS_CODE_SUCCESS

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API bool Activ::ContentPlatform::Feed::Rule::HighFields::operator!= ( const HighFields & rhs ) const

Inequality operator.

Parameters:
rhs the object to test against.
Returns:
whether the two objects are not equal.

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API bool Activ::ContentPlatform::Feed::Rule::HighFields::operator== ( const HighFields & rhs ) const

Equality operator.

Parameters:
rhs the object to test against.
Returns:
whether the two objects are equal.

std::string Activ::ContentPlatform::Feed::Rule::HighFields::ToString ( ) const

Convert the fields to a C-style string.

Returns:
the specification as a string.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/Rule.h
Generated on Wed Oct 8 14:02:07 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::Rule::LowFields

Activ::ContentPlatform::Feed::Rule::LowFields Class Reference

Low fields class. More...

#include <ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/Rule.h>

List of all members.

Public Member Functions

void | Clear ()
Clear the contents.
StatusCode | Initialize (const TableTemplate &tableTemplate, const xercesc::DOMNode &domNode)
Initialize from the dom node in the xml file.
StatusCode | Initialize (const TableTemplate &tableTemplate, const FieldId target, const FieldId condition, const FieldId time, const FieldId date, const FieldId exchange)
Initialize from the fields ids.
LowFields (const TableTemplate &tableTemplate, const xercesc::DOMNode &domNode)
Construct from the dom node in the xml file.
LowFields (const TableTemplate &tableTemplate, const FieldId target, const FieldId condition, const FieldId time, const FieldId date, const FieldId exchange)
Construct from the fields ids.
LowFields ()
Default constructor.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
bool 		operator!= (const LowFields &rhs) const
Inequality operator.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
bool 		operator== (const LowFields &rhs) const
Equality operator.
std::string | ToString () const
Convert the fields to a C-style string.

Public Attributes

FieldId | m_condition
The low condition field.
FieldId | m_date
The low date field.
std::string | m_error
The error string.
FieldId | m_exchange
The low exchange field.
const TableTemplate * | m_pTableTemplate
The table template.
FieldId | m_target
The low field.
FieldId | m_time
The low time field.

Detailed Description

Low fields class.

Definition at line 239 of file Rule.h.

Constructor & Destructor Documentation

Activ::ContentPlatform::Feed::Rule::LowFields::LowFields | ( | const TableTemplate & | tableTemplate,
 |  | const FieldId | target,
 |  | const FieldId | condition,
 |  | const FieldId | time,
 |  | const FieldId | date,
 |  | const FieldId | exchange
 | ) |  |

Construct from the fields ids.

Parameters:
tableTemplate | the table template.
target | the target low field.
condition | the low condition field.
time | the low time field.
date | the low date field.
exchange | the low exchange field.

Activ::ContentPlatform::Feed::Rule::LowFields::LowFields | ( | const TableTemplate & | tableTemplate,
 |  | const xercesc::DOMNode & | domNode
 | ) |  |

Construct from the dom node in the xml file.

Parameters:
tableTemplate | the table template.
domNode | the dom node.

Member Function Documentation

StatusCode Activ::ContentPlatform::Feed::Rule::LowFields::Initialize | ( | const TableTemplate & | tableTemplate,
 |  | const xercesc::DOMNode & | domNode
 | ) |  |

Initialize from the dom node in the xml file.

Parameters:
tableTemplate | the table template.
domNode | the dom node.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_FAILURE

StatusCode Activ::ContentPlatform::Feed::Rule::LowFields::Initialize | ( | const TableTemplate & | tableTemplate,
 |  | const FieldId | target,
 |  | const FieldId | condition,
 |  | const FieldId | time,
 |  | const FieldId | date,
 |  | const FieldId | exchange
 | ) |  |

Initialize from the fields ids.

Parameters:
tableTemplate | the table template.
target | the target low field.
condition | the low condition field.
time | the low time field.
date | the low date field.
exchange | the low exchange field.
Return values:
STATUS_CODE_SUCCESS

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API bool Activ::ContentPlatform::Feed::Rule::LowFields::operator!= ( const LowFields & rhs ) const

Inequality operator.

Parameters:
rhs the object to test against.
Returns:
whether the two objects are not equal.

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API bool Activ::ContentPlatform::Feed::Rule::LowFields::operator== ( const LowFields & rhs ) const

Equality operator.

Parameters:
rhs the object to test against.
Returns:
whether the two objects are equal.

std::string Activ::ContentPlatform::Feed::Rule::LowFields::ToString ( ) const

Convert the fields to a C-style string.

Returns:
the specification as a string.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/Rule.h
Generated on Wed Oct 8 14:02:07 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::Rule::OpenFields

Activ::ContentPlatform::Feed::Rule::OpenFields Class Reference

Open fields class. More...

#include <ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/Rule.h>

List of all members.

Public Member Functions

void | Clear ()
Clear the contents.
StatusCode | Initialize (const TableTemplate &tableTemplate, const xercesc::DOMNode &domNode)
Initialize from the dom node in the xml file.
StatusCode | Initialize (const TableTemplate &tableTemplate, const FieldId target, const FieldId condition, const FieldId time, const FieldId exchange)
Initialize from the fields ids.
OpenFields (const TableTemplate &tableTemplate, const xercesc::DOMNode &domNode)
Construct from the dom node in the xml file.
OpenFields (const TableTemplate &tableTemplate, const FieldId target, const FieldId condition, const FieldId time, const FieldId exchange)
Construct from the fields ids.
OpenFields ()
Default constructor.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
bool 		operator!= (const OpenFields &rhs) const
Inequality operator.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
bool 		operator== (const OpenFields &rhs) const
Equality operator.
std::string | ToString () const
Convert the fields to a C-style string.

Public Attributes

FieldId | m_condition
The open condition field.
std::string | m_error
The error string.
FieldId | m_exchange
The open exchange field.
const TableTemplate * | m_pTableTemplate
The table template.
FieldId | m_target
The open field.
FieldId | m_time
The open time field.

Detailed Description

Open fields class.

Definition at line 336 of file Rule.h.

Constructor & Destructor Documentation

Activ::ContentPlatform::Feed::Rule::OpenFields::OpenFields | ( | const TableTemplate & | tableTemplate,
 |  | const FieldId | target,
 |  | const FieldId | condition,
 |  | const FieldId | time,
 |  | const FieldId | exchange
 | ) |  |

Construct from the fields ids.

Parameters:
tableTemplate | the table template.
target | the target open field.
condition | the open condition field.
time | the open time field.
exchange | the open exchange field.

Activ::ContentPlatform::Feed::Rule::OpenFields::OpenFields | ( | const TableTemplate & | tableTemplate,
 |  | const xercesc::DOMNode & | domNode
 | ) |  |

Construct from the dom node in the xml file.

Parameters:
tableTemplate | the table template.
domNode | the dom node.

Member Function Documentation

StatusCode Activ::ContentPlatform::Feed::Rule::OpenFields::Initialize | ( | const TableTemplate & | tableTemplate,
 |  | const xercesc::DOMNode & | domNode
 | ) |  |

Initialize from the dom node in the xml file.

Parameters:
tableTemplate | the table template.
domNode | the dom node.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_FAILURE

StatusCode Activ::ContentPlatform::Feed::Rule::OpenFields::Initialize | ( | const TableTemplate & | tableTemplate,
 |  | const FieldId | target,
 |  | const FieldId | condition,
 |  | const FieldId | time,
 |  | const FieldId | exchange
 | ) |  |

Initialize from the fields ids.

Parameters:
tableTemplate | the table template.
target | the target open field.
condition | the open condition field.
time | the open time field.
exchange | the open exchange field.
Return values:
STATUS_CODE_SUCCESS

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API bool Activ::ContentPlatform::Feed::Rule::OpenFields::operator!= ( const OpenFields & rhs ) const

Inequality operator.

Parameters:
rhs the object to test against.
Returns:
whether the two objects are not equal.

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API bool Activ::ContentPlatform::Feed::Rule::OpenFields::operator== ( const OpenFields & rhs ) const

Equality operator.

Parameters:
rhs the object to test against.
Returns:
whether the two objects are equal.

std::string Activ::ContentPlatform::Feed::Rule::OpenFields::ToString ( ) const

Convert the fields to a C-style string.

Returns:
the specification as a string.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/Rule.h
Generated on Wed Oct 8 14:02:07 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::Rule::PriceFields

Activ::ContentPlatform::Feed::Rule::PriceFields Class Reference

Price fields class. More...

#include <ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/Rule.h>

List of all members.

Public Member Functions

void | Clear ()
Clear the contents.
StatusCode | Initialize (const TableTemplate &tableTemplate, const xercesc::DOMNode &domNode)
Initialize from the dom node in the xml file.
StatusCode | Initialize (const TableTemplate &tableTemplate, const FieldId previousDayChange, const FieldId netChange, const FieldId percentChange, const FieldId cumulativePrice, const FieldId count)
Initialize from the fields ids.
StatusCode | InitializeChangeFields (const xercesc::DOMNode &domNode)
Initialize change fields from the dom node in the xml file.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
bool 		operator!= (const PriceFields &rhs) const
Inequality operator.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
bool 		operator== (const PriceFields &rhs) const
Equality operator.
PriceFields (const TableTemplate &tableTemplate, const xercesc::DOMNode &domNode)
Construct from the dom node in the xml file.
PriceFields (const TableTemplate &tableTemplate, const FieldId previousDayChange, const FieldId netChange, const FieldId percentChange, const FieldId cumulativePrice, const FieldId count)
Construct from the fields ids.
PriceFields ()
Default constructor.
std::string | ToString () const
Convert the fields to a C-style string.

Public Attributes

FieldId | m_count
The count field.
FieldId | m_cumulativePrice
The cumulative price field.
std::string | m_error
The error string.
FieldId | m_netChange
The net change field.
FieldId | m_percentChange
The percent change field.
FieldId | m_previousDayChange
The previous day change field.
const TableTemplate * | m_pTableTemplate
The table template.

Detailed Description

Price fields class.

Definition at line 527 of file Rule.h.

Constructor & Destructor Documentation

Activ::ContentPlatform::Feed::Rule::PriceFields::PriceFields | ( | const TableTemplate & | tableTemplate,
 |  | const FieldId | previousDayChange,
 |  | const FieldId | netChange,
 |  | const FieldId | percentChange,
 |  | const FieldId | cumulativePrice,
 |  | const FieldId | count
 | ) |  |

Construct from the fields ids.

Parameters:
tableTemplate
previousDayChange | the previous day change field.
netChange | the net change field.
percentChange | the percent change field.
cumulativePrice | the cumulative price field.
count | the count field.

Activ::ContentPlatform::Feed::Rule::PriceFields::PriceFields | ( | const TableTemplate & | tableTemplate,
 |  | const xercesc::DOMNode & | domNode
 | ) |  |

Construct from the dom node in the xml file.

Parameters:
tableTemplate | the table template.
domNode | the dom node.

Member Function Documentation

StatusCode Activ::ContentPlatform::Feed::Rule::PriceFields::Initialize | ( | const TableTemplate & | tableTemplate,
 |  | const xercesc::DOMNode & | domNode
 | ) |  |

Initialize from the dom node in the xml file.

Parameters:
tableTemplate | the table template.
domNode | the dom node.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_FAILURE

StatusCode Activ::ContentPlatform::Feed::Rule::PriceFields::Initialize | ( | const TableTemplate & | tableTemplate,
 |  | const FieldId | previousDayChange,
 |  | const FieldId | netChange,
 |  | const FieldId | percentChange,
 |  | const FieldId | cumulativePrice,
 |  | const FieldId | count
 | ) |  |

Initialize from the fields ids.

Parameters:
tableTemplate | the table template.
previousDayChange | the previous day change field.
netChange | the net change field.
percentChange | the percent change field.
cumulativePrice | the cumulative price field.
count | the count field.
Return values:
STATUS_CODE_SUCCESS

StatusCode Activ::ContentPlatform::Feed::Rule::PriceFields::InitializeChangeFields ( const xercesc::DOMNode & domNode )

Initialize change fields from the dom node in the xml file.

Parameters:
domNode the dom node.

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API bool Activ::ContentPlatform::Feed::Rule::PriceFields::operator!= ( const PriceFields & rhs ) const

Inequality operator.

Parameters:
rhs the object to test against.
Returns:
whether the two objects are not equal.

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API bool Activ::ContentPlatform::Feed::Rule::PriceFields::operator== ( const PriceFields & rhs ) const

Equality operator.

Parameters:
rhs the object to test against.
Returns:
whether the two objects are equal.

std::string Activ::ContentPlatform::Feed::Rule::PriceFields::ToString ( ) const

Convert the fields to a C-style string.

Returns:
the specification as a string.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/Rule.h
Generated on Wed Oct 8 14:02:07 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::Rule::VolumeFields

Activ::ContentPlatform::Feed::Rule::VolumeFields Class Reference

Volume fields class. More...

#include <ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/Rule.h>

List of all members.

Public Member Functions

void | Clear ()
Clear the contents.
StatusCode | Initialize (const TableTemplate &tableTemplate, const xercesc::DOMNode &domNode)
Initialize from the dom node in the xml file.
StatusCode | Initialize (const TableTemplate &tableTemplate, const FieldId add1Volume, const FieldId add1Price, const FieldId add1CumulativeValue, const FieldId add2Volume, const FieldId add2Price, const FieldId add2CumulativeValue)
Initialize from the fields ids.
StatusCode | InitializeAdd1CumulativeValueFields (const xercesc::DOMNode &domNode)
Initialize add 1 cumulative value fields from the dom node in the xml file.
StatusCode | InitializeAdd1Fields (const xercesc::DOMNode &domNode)
Initialize add 1 fields from the dom node in the xml file.
StatusCode | InitializeAdd2CumulativeValueFields (const xercesc::DOMNode &domNode)
Initialize add 2 cumulative value fields from the dom node in the xml file.
StatusCode | InitializeAdd2Fields (const xercesc::DOMNode &domNode)
Initialize add 2 fields from the dom node in the xml file.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
bool 		operator!= (const VolumeFields &rhs) const
Inequality operator.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
bool 		operator== (const VolumeFields &rhs) const
Equality operator.
std::string | ToString () const
Convert the fields to a C-style string.
VolumeFields (const TableTemplate &tableTemplate, const xercesc::DOMNode &domNode)
Construct from the dom node in the xml file.
VolumeFields (const TableTemplate &tableTemplate, const FieldId add1Volume, const FieldId add1Price, const FieldId add1CumulativeValue, const FieldId add2Volume, const FieldId add2Price, const FieldId add2CumulativeValue)
Construct from the fields ids.
VolumeFields ()
Default constructor.

Public Attributes

FieldId | m_add1CumulativeValue
The add 1 cumulative value field.
FieldId | m_add1Price
The add 1 price field.
FieldId | m_add1Volume
The add 1 volume field.
FieldId | m_add2CumulativeValue
The add 2 cumulative value field.
FieldId | m_add2Price
The add 2 price field.
FieldId | m_add2Volume
The add 2 volume field.
std::string | m_error
The error string.
const TableTemplate * | m_pTableTemplate
The table template.

Detailed Description

Volume fields class.

Definition at line 631 of file Rule.h.

Constructor & Destructor Documentation

Activ::ContentPlatform::Feed::Rule::VolumeFields::VolumeFields | ( | const TableTemplate & | tableTemplate,
 |  | const FieldId | add1Volume,
 |  | const FieldId | add1Price,
 |  | const FieldId | add1CumulativeValue,
 |  | const FieldId | add2Volume,
 |  | const FieldId | add2Price,
 |  | const FieldId | add2CumulativeValue
 | ) |  |

Construct from the fields ids.

Parameters:
tableTemplate
add1Volume | the add1 volume field.
add1Price | the add1 price field.
add1CumulativeValue | the add1 cumulative value field.
add2Volume | the add2 volume field.
add2Price | the add2 price field.
add2CumulativeValue | the add2 cumulative value field.

Activ::ContentPlatform::Feed::Rule::VolumeFields::VolumeFields | ( | const TableTemplate & | tableTemplate,
 |  | const xercesc::DOMNode & | domNode
 | ) |  |

Construct from the dom node in the xml file.

Parameters:
tableTemplate | the table template.
domNode | the dom node.

Member Function Documentation

StatusCode Activ::ContentPlatform::Feed::Rule::VolumeFields::Initialize | ( | const TableTemplate & | tableTemplate,
 |  | const xercesc::DOMNode & | domNode
 | ) |  |

Initialize from the dom node in the xml file.

Parameters:
tableTemplate | the table template.
domNode | the dom node.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_FAILURE

StatusCode Activ::ContentPlatform::Feed::Rule::VolumeFields::Initialize | ( | const TableTemplate & | tableTemplate,
 |  | const FieldId | add1Volume,
 |  | const FieldId | add1Price,
 |  | const FieldId | add1CumulativeValue,
 |  | const FieldId | add2Volume,
 |  | const FieldId | add2Price,
 |  | const FieldId | add2CumulativeValue
 | ) |  |

Initialize from the fields ids.

Parameters:
tableTemplate | the table template.
add1Volume | the add1 volume field.
add1Price | the add1 price.
add1CumulativeValue | the add1 cumulative value.
add2Volume | the add2 volume field.
add2Price | the add2 price.
add2CumulativeValue | the add2 cumulative value.
Return values:
STATUS_CODE_SUCCESS

StatusCode Activ::ContentPlatform::Feed::Rule::VolumeFields::InitializeAdd1CumulativeValueFields ( const xercesc::DOMNode & domNode )

Initialize add 1 cumulative value fields from the dom node in the xml file.

Parameters:
domNode the dom node.

StatusCode Activ::ContentPlatform::Feed::Rule::VolumeFields::InitializeAdd1Fields ( const xercesc::DOMNode & domNode )

Initialize add 1 fields from the dom node in the xml file.

Parameters:
domNode the dom node.

StatusCode Activ::ContentPlatform::Feed::Rule::VolumeFields::InitializeAdd2CumulativeValueFields ( const xercesc::DOMNode & domNode )

Initialize add 2 cumulative value fields from the dom node in the xml file.

Parameters:
domNode the dom node.

StatusCode Activ::ContentPlatform::Feed::Rule::VolumeFields::InitializeAdd2Fields ( const xercesc::DOMNode & domNode )

Initialize add 2 fields from the dom node in the xml file.

Parameters:
domNode the dom node.

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API bool Activ::ContentPlatform::Feed::Rule::VolumeFields::operator!= ( const VolumeFields & rhs ) const

Inequality operator.

Parameters:
rhs the object to test against.
Returns:
whether the two objects are not equal.

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API bool Activ::ContentPlatform::Feed::Rule::VolumeFields::operator== ( const VolumeFields & rhs ) const

Equality operator.

Parameters:
rhs the object to test against.
Returns:
whether the two objects are equal.

std::string Activ::ContentPlatform::Feed::Rule::VolumeFields::ToString ( ) const

Convert the fields to a C-style string.

Returns:
the specification as a string.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/Rule.h
Generated on Wed Oct 8 14:02:07 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::Symbol

Activ::ContentPlatform::Feed::Symbol Class Reference

Symbol class. More...

#include <ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/Symbol.h>

List of all members.

Static Public Member Functions

static StatusCode | Deserialize (MessageValidator &messageValidator, const size_t maxSymbolLength, std::string &symbol)
Deserialize the supplied symbol.
static void | Serialize (byte_t *&pMessage, const std::string &symbol)
Serialize the supplied symbol.

Detailed Description

Symbol class.

Definition at line 30 of file Symbol.h.

Member Function Documentation

StatusCode Activ::ContentPlatform::Feed::Symbol::Deserialize | ( | MessageValidator & | messageValidator,
 |  | const size_t | maxSymbolLength,
 |  | std::string & | symbol |
 | ) |  |  | [inline, static]

Deserialize the supplied symbol.

Parameters:
messageValidator | the message validator.
maxSymbolLength | the maximum symbol length.
symbol | set equal to the deserialized symbol.
Return values:
STATUS_CODE_SUCCESS.
...

Definition at line 72 of file Symbol.h.

References ACTIV_RETURN_RESULT_IF, Activ::MessageHandler::ENDIAN_LITTLE, Activ::MessageValidator::ValidateBinaryIntegral(), and Activ::MessageValidator::ValidateBytes().

Referenced by Activ::ContentPlatform::Feed::CompressedMessage::ValidateCompressed(), and Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessage::ValidateCompressedCombinedQuote().

void Activ::ContentPlatform::Feed::Symbol::Serialize | ( | byte_t *& | pMessage,
 |  | const std::string & | symbol |
 | ) |  |  | [inline, static]

Serialize the supplied symbol.

Parameters:
pMessage | the message to serialize the symbol into.
symbol | the symbol to serialize.
Return values:
STATUS_CODE_SUCCESS.
...

Definition at line 59 of file Symbol.h.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/Symbol.h
Generated on Wed Oct 8 14:02:07 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::SymbolRecordField

Activ::ContentPlatform::Feed::SymbolRecordField Class Reference

Symbol record field class. More...

#include <ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/SymbolRecordField.h>

List of all members.

Public Types

typedef std::vector
< PartialUpdate > 		PartialBitUpdateList
Partial bit update list type definition.
typedef std::vector
< PartialUpdate > 		PartialByteUpdateList
Partial byte update list type definition.

Public Member Functions

ACTIV_FEED_MESSAGE_HANDLER_API
std::string 		CompositeFieldRulesToString () const
Copy Composite Field Rules to string.
ACTIV_FEED_MESSAGE_HANDLER_API
std::string 		FieldContentsToString () const
Copy Field to string.
ACTIV_FEED_MESSAGE_HANDLER_API
std::string 		FieldRulesToString () const
Copy Field rules to string.
StatusCode | GetCompositeFieldRules (uint8_t &compositeFieldRules) const
Get the composite field rules.
StatusCode | GetField (const IFieldType *&pIFieldType) const
Get the field.
StatusCode | GetFieldRules (uint8_t &fieldRules) const
Get the field rules.
StatusCode | GetPartialBitUpdateList (const PartialBitUpdateList *&pPartialBitUpdateList) const
Get the partial bit update list.
StatusCode | GetRuleSet (uint8_t &ruleSet) const
Get the rule set.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		Initialize (const Field &field, const bool isComposite, const uint8_t defaultRuleSet, const bool isFieldRulesPresent, MessageValidator &messageValidator)
Initialize.
void | InitializeUndefined (const Field &field)
Initialize undefined.
bool | IsComposite () const
Is this a composite update.
bool | IsDefined () const
Is the field defined.
bool | IsInitialized () const
Is the object initialized.
ACTIV_FEED_MESSAGE_HANDLER_API
std::string 		PartialUpdateToString (PartialUpdate &partialUpdate) const
Copy Partial Update to string.
ACTIV_FEED_MESSAGE_HANDLER_API void | Reset ()
Reset.
ACTIV_FEED_MESSAGE_HANDLER_API
std::string 		RuleSetToString () const
Copy Rule set to string.
ACTIV_FEED_MESSAGE_HANDLER_API | SymbolRecordField (const Field &field, const bool isComposite, const uint8_t defaultRuleSet, const bool isFieldRulesPresent, MessageValidator &messageValidator)
Constructor.
ACTIV_FEED_MESSAGE_HANDLER_API | SymbolRecordField ()
Default constructor.
ACTIV_FEED_MESSAGE_HANDLER_API
std::string 		ToString () const
Copy Symbol Field to string.
ACTIV_FEED_MESSAGE_HANDLER_API | ~SymbolRecordField ()
Destructor.

Static Public Member Functions

static
ACTIV_FEED_MESSAGE_HANDLER_API
std::string 		ContentsPrefixToString ()
Copy "Contents" Prefix to string.
static
ACTIV_FEED_MESSAGE_HANDLER_API
std::string 		FieldIdToString (const FieldId &fieldId)
Copy Field ID to string.
static
ACTIV_FEED_MESSAGE_HANDLER_API
std::string 		FieldNameToString (const Field *pField)
Copy Field name to string.
static
ACTIV_FEED_MESSAGE_HANDLER_API
std::string 		UndefinedFieldContentsToString ()
Copy Undefined Field to string.

Classes

class | PartialUpdate
Partial update class. More...

Detailed Description

Symbol record field class.

Definition at line 37 of file SymbolRecordField.h.

Constructor & Destructor Documentation

ACTIV_FEED_MESSAGE_HANDLER_API Activ::ContentPlatform::Feed::SymbolRecordField::SymbolRecordField | ( | const Field & | field,
 |  | const bool | isComposite,
 |  | const uint8_t | defaultRuleSet,
 |  | const bool | isFieldRulesPresent,
 |  | MessageValidator & | messageValidator
 | ) |  |

Constructor.

Parameters:
field | the field.
isComposite | whether this is a composite update.
defaultRuleSet | the default rule set.
isFieldRulesPresent | whether the field rules are present.
messageValidator | the message validator.
Exceptions:
StatusCodeException

Member Function Documentation

ACTIV_FEED_MESSAGE_HANDLER_API std::string Activ::ContentPlatform::Feed::SymbolRecordField::CompositeFieldRulesToString ( ) const

Copy Composite Field Rules to string.

Returns:
string.

static ACTIV_FEED_MESSAGE_HANDLER_API std::string Activ::ContentPlatform::Feed::SymbolRecordField::ContentsPrefixToString ( ) [static]

Copy "Contents" Prefix to string.

Returns:
string.

ACTIV_FEED_MESSAGE_HANDLER_API std::string Activ::ContentPlatform::Feed::SymbolRecordField::FieldContentsToString ( ) const

Copy Field to string.

Returns:
string.

static ACTIV_FEED_MESSAGE_HANDLER_API std::string Activ::ContentPlatform::Feed::SymbolRecordField::FieldIdToString ( const FieldId & fieldId ) [static]

Copy Field ID to string.

Returns:
string.

static ACTIV_FEED_MESSAGE_HANDLER_API std::string Activ::ContentPlatform::Feed::SymbolRecordField::FieldNameToString ( const Field * pField ) [static]

Copy Field name to string.

Returns:
string.

ACTIV_FEED_MESSAGE_HANDLER_API std::string Activ::ContentPlatform::Feed::SymbolRecordField::FieldRulesToString ( ) const

Copy Field rules to string.

Returns:
string.

StatusCode Activ::ContentPlatform::Feed::SymbolRecordField::GetCompositeFieldRules ( uint8_t & compositeFieldRules ) const [inline]

Get the composite field rules.

Parameters:
compositeFieldRules the composite field rules.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_FAILURE
STATUS_CODE_NOT_INITIALIZED

Definition at line 315 of file SymbolRecordField.h.

References IsComposite(), and IsInitialized().

StatusCode Activ::ContentPlatform::Feed::SymbolRecordField::GetField ( const IFieldType *& pIFieldType ) const [inline]

Get the field.

Parameters:
pIFieldType a pointer to the field.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_FAILURE
STATUS_CODE_NOT_INITIALIZED

Definition at line 330 of file SymbolRecordField.h.

References IsInitialized(), Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::RULE_SET_CONTENT_SERVER, Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::RULE_SET_NONE, and Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::RULE_SET_TRANSLATOR.

StatusCode Activ::ContentPlatform::Feed::SymbolRecordField::GetFieldRules ( uint8_t & fieldRules ) const [inline]

Get the field rules.

Parameters:
fieldRules the field rules.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED

Definition at line 303 of file SymbolRecordField.h.

References IsInitialized().

StatusCode Activ::ContentPlatform::Feed::SymbolRecordField::GetPartialBitUpdateList ( const PartialBitUpdateList *& pPartialBitUpdateList ) const [inline]

Get the partial bit update list.

Parameters:
pPartialBitUpdateList set to point to the partial bit update list.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_FAILURE
STATUS_CODE_NOT_INITIALIZED

Definition at line 352 of file SymbolRecordField.h.

References IsInitialized(), and Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::RULE_SET_PARTIAL_BIT_UPDATE.

StatusCode Activ::ContentPlatform::Feed::SymbolRecordField::GetRuleSet ( uint8_t & ruleSet ) const [inline]

Get the rule set.

Parameters:
ruleSet the rule set.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED

Definition at line 291 of file SymbolRecordField.h.

References IsInitialized().

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::SymbolRecordField::Initialize | ( | const Field & | field,
 |  | const bool | isComposite,
 |  | const uint8_t | defaultRuleSet,
 |  | const bool | isFieldRulesPresent,
 |  | MessageValidator & | messageValidator
 | ) |  |

Initialize.

Parameters:
field | the field.
isComposite | whether this is a composite update.
defaultRuleSet | the default rule set.
isFieldRulesPresent | whether the field rules are present.
messageValidator | the message validator.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT
STATUS_CODE_HEAP_EMPTY
...

void Activ::ContentPlatform::Feed::SymbolRecordField::InitializeUndefined ( const Field & field ) [inline]

Initialize undefined.

Parameters:
field the field.

Definition at line 281 of file SymbolRecordField.h.

References ACTIV_ENHANCED_DEBUG_ONLY, and UndefinedFieldContentsToString().

bool Activ::ContentPlatform::Feed::SymbolRecordField::IsComposite ( ) const [inline]

Is this a composite update.

Returns:
whether this is a composite update.

Definition at line 381 of file SymbolRecordField.h.

References IsInitialized().

Referenced by GetCompositeFieldRules().

bool Activ::ContentPlatform::Feed::SymbolRecordField::IsDefined ( ) const [inline]

Is the field defined.

Returns:
whether the object is defined.

Definition at line 374 of file SymbolRecordField.h.

References IsInitialized().

bool Activ::ContentPlatform::Feed::SymbolRecordField::IsInitialized ( ) const [inline]

Is the object initialized.

Returns:
whether the object is initialized.

Definition at line 367 of file SymbolRecordField.h.

Referenced by GetCompositeFieldRules(), GetField(), GetFieldRules(), GetPartialBitUpdateList(), GetRuleSet(), IsComposite(), and IsDefined().

ACTIV_FEED_MESSAGE_HANDLER_API std::string Activ::ContentPlatform::Feed::SymbolRecordField::PartialUpdateToString ( PartialUpdate & partialUpdate ) const

Copy Partial Update to string.

Returns:
string.

ACTIV_FEED_MESSAGE_HANDLER_API std::string Activ::ContentPlatform::Feed::SymbolRecordField::RuleSetToString ( ) const

Copy Rule set to string.

Returns:
string.

ACTIV_FEED_MESSAGE_HANDLER_API std::string Activ::ContentPlatform::Feed::SymbolRecordField::ToString ( ) const

Copy Symbol Field to string.

Returns:
string.

static ACTIV_FEED_MESSAGE_HANDLER_API std::string Activ::ContentPlatform::Feed::SymbolRecordField::UndefinedFieldContentsToString ( ) [static]

Copy Undefined Field to string.

Returns:
string.

Referenced by InitializeUndefined().

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/SymbolRecordField.h
Generated on Wed Oct 8 14:02:07 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::SymbolRecordField::PartialUpdate

Activ::ContentPlatform::Feed::SymbolRecordField::PartialUpdate Class Reference

Partial update class. More...

#include <ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/SymbolRecordField.h>

List of all members.

Public Member Functions

PartialUpdate (const uint8_t offset=0, const uint8_t value=0)
Constructor.

Public Attributes

uint8_t | m_offset
uint8_t | m_value

Detailed Description

Partial update class.

Definition at line 43 of file SymbolRecordField.h.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/SymbolRecordField.h
Generated on Wed Oct 8 14:02:07 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::SymbolRecordFieldHeaderDefinitions

Activ::ContentPlatform::Feed::SymbolRecordFieldHeaderDefinitions Class Reference

Symbol record field header definitions class. More...

#include <ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/SymbolRecordFieldHeaderDefinitions.h>

Inheritance diagram for Activ::ContentPlatform::Feed::SymbolRecordFieldHeaderDefinitions:

Activ::ContentPlatform::Feed::FieldHeaderDefinitions

List of all members.

Static Public Member Functions

static FieldHeader | GetFieldHeader (const FieldId fieldId, const bool isFieldDefined, const bool isFieldRulesPresent=false)
Get the field header.
static bool | IsFieldRulesPresent (const FieldHeader fieldHeader)
Is field rules present.

Static Public Attributes

static const size_t | FIELD_RULES_PRESENT_LENGTH = FIELD_RESERVED_LENGTH
The field rules present length.
static const size_t | FIELD_RULES_PRESENT_OFFSET = FIELD_RESERVED_OFFSET
The field rules present offset.

Detailed Description

Symbol record field header definitions class.

Definition at line 26 of file SymbolRecordFieldHeaderDefinitions.h.

Member Function Documentation

SymbolRecordFieldHeaderDefinitions::FieldHeader Activ::ContentPlatform::Feed::SymbolRecordFieldHeaderDefinitions::GetFieldHeader | ( | const FieldId | fieldId,
 |  | const bool | isFieldDefined,
 |  | const bool | isFieldRulesPresent = false |
 | ) |  |  | [inline, static]

Get the field header.

Parameters:
fieldId | the field id.
isFieldDefined | whether the field is defined.
isFieldRulesPresent | whether the field rules are present.
Returns:
the field id.

Definition at line 55 of file SymbolRecordFieldHeaderDefinitions.h.

References FIELD_RULES_PRESENT_LENGTH, FIELD_RULES_PRESENT_OFFSET, and Activ::ContentPlatform::Feed::FieldHeaderDefinitions::GetFieldHeader().

bool Activ::ContentPlatform::Feed::SymbolRecordFieldHeaderDefinitions::IsFieldRulesPresent ( const FieldHeader fieldHeader ) [inline, static]

Is field rules present.

Parameters:
fieldHeader the field header.
Returns:
whether the field rules are present.

Definition at line 62 of file SymbolRecordFieldHeaderDefinitions.h.

References FIELD_RULES_PRESENT_LENGTH, and FIELD_RULES_PRESENT_OFFSET.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/SymbolRecordFieldHeaderDefinitions.h
Generated on Wed Oct 8 14:02:07 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::SymbolRecordFieldListBuilder

Activ::ContentPlatform::Feed::SymbolRecordFieldListBuilder Class Reference

Symbol record field list builder class. More...

#include <ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/SymbolRecordFieldListBuilder.h>

List of all members.

Public Member Functions

ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		AppendField (const FieldId fieldId, const void *const pSerializedBody, const size_t serializedBodyLength)
Append a field with the default rule set.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		AppendField (const FieldId fieldId, const IFieldType &iFieldType)
Append a field with the default rule set.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		AppendFieldWithContentServerRuleSet (const FieldId fieldId, const uint8_t fieldRules, const uint8_t compositeFieldRules, const void *const pSerializedBody, const size_t serializedBodyLength)
Append a field with the content server rule set.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		AppendFieldWithContentServerRuleSet (const FieldId fieldId, const uint8_t fieldRules, const uint8_t compositeFieldRules, const IFieldType &iFieldType)
Append a field with the content server rule set.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		AppendFieldWithContentServerRuleSet (const FieldId fieldId, const uint8_t fieldRules, const void *const pSerializedBody, const size_t serializedBodyLength)
Append a field with the content server rule set.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		AppendFieldWithContentServerRuleSet (const FieldId fieldId, const uint8_t fieldRules, const IFieldType &iFieldType)
Append a field with the content server rule set.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		AppendFieldWithNoneRuleSet (const FieldId fieldId, const void *const pSerializedBody, const size_t serializedBodyLength)
Append a field with the none rule set.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		AppendFieldWithNoneRuleSet (const FieldId fieldId, const IFieldType &iFieldType)
Append a field with the none rule set.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		AppendFieldWithTranslatorRuleSet (const FieldId fieldId, const uint8_t fieldRules, const uint8_t compositeFieldRules, const void *const pSerializedBody, const size_t serializedBodyLength)
Append a field with the translator rule set.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		AppendFieldWithTranslatorRuleSet (const FieldId fieldId, const uint8_t fieldRules, const uint8_t compositeFieldRules, const IFieldType &iFieldType)
Append a field with the translator rule set.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		AppendFieldWithTranslatorRuleSet (const FieldId fieldId, const uint8_t fieldRules, const void *const pSerializedBody, const size_t serializedBodyLength)
Append a field with the translator rule set.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		AppendFieldWithTranslatorRuleSet (const FieldId fieldId, const uint8_t fieldRules, const IFieldType &iFieldType)
Append a field with the translator rule set.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		AppendUndefinedField (const FieldId fieldId)
Append an undefined field.
ACTIV_FEED_MESSAGE_HANDLER_API void | Clear ()
Clear.
ACTIV_FEED_MESSAGE_HANDLER_API void | Initialize (const TableTemplate &tableTemplate, const bool isComposite, const uint8_t defaultRuleSet, MessageBuilder &messageBuilder)
Initialize with a new table template and message builder.
ACTIV_FEED_MESSAGE_HANDLER_API bool | IsInitialized () const
Is the object initialized.
ACTIV_FEED_MESSAGE_HANDLER_API void | Reset ()
Reset.
ACTIV_FEED_MESSAGE_HANDLER_API | SymbolRecordFieldListBuilder (const TableTemplate &tableTemplate, const bool isComposite, const uint8_t defaultRuleSet, MessageBuilder &messageBuilder)
Constructor.
ACTIV_FEED_MESSAGE_HANDLER_API | SymbolRecordFieldListBuilder ()
Default constructor.
ACTIV_FEED_MESSAGE_HANDLER_API | ~SymbolRecordFieldListBuilder ()
Destructor.

Detailed Description

Symbol record field list builder class.

Definition at line 33 of file SymbolRecordFieldListBuilder.h.

Constructor & Destructor Documentation

ACTIV_FEED_MESSAGE_HANDLER_API Activ::ContentPlatform::Feed::SymbolRecordFieldListBuilder::SymbolRecordFieldListBuilder | ( | const TableTemplate & | tableTemplate,
 |  | const bool | isComposite,
 |  | const uint8_t | defaultRuleSet,
 |  | MessageBuilder & | messageBuilder
 | ) |  |

Constructor.

Parameters:
tableTemplate | the table template.
isComposite | whether this is a composite update.
defaultRuleSet | the default rule set.
messageBuilder | the message builder.

Member Function Documentation

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::SymbolRecordFieldListBuilder::AppendField | ( | const FieldId | fieldId,
 |  | const void *const | pSerializedBody,
 |  | const size_t | serializedBodyLength
 | ) |  |

Append a field with the default rule set.

Parameters:
fieldId | the field id.
pSerializedBody | the serialized body.
serializedBodyLength | the serialized body length.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED
...

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::SymbolRecordFieldListBuilder::AppendField | ( | const FieldId | fieldId,
 |  | const IFieldType & | iFieldType
 | ) |  |

Append a field with the default rule set.

Parameters:
fieldId | the field id.
iFieldType | a reference to the field.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED
...

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::SymbolRecordFieldListBuilder::AppendFieldWithContentServerRuleSet | ( | const FieldId | fieldId,
 |  | const uint8_t | fieldRules,
 |  | const uint8_t | compositeFieldRules,
 |  | const void *const | pSerializedBody,
 |  | const size_t | serializedBodyLength
 | ) |  |

Append a field with the content server rule set.

Parameters:
fieldId | the field id.
fieldRules | the field rules.
compositeFieldRules | the composite field rules.
pSerializedBody | the serialized body.
serializedBodyLength | the serialized body length.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED
...

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::SymbolRecordFieldListBuilder::AppendFieldWithContentServerRuleSet | ( | const FieldId | fieldId,
 |  | const uint8_t | fieldRules,
 |  | const uint8_t | compositeFieldRules,
 |  | const IFieldType & | iFieldType
 | ) |  |

Append a field with the content server rule set.

Parameters:
fieldId | the field id.
fieldRules | the field rules.
compositeFieldRules | the composite field rules.
iFieldType | a reference to the field.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED
...

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::SymbolRecordFieldListBuilder::AppendFieldWithContentServerRuleSet | ( | const FieldId | fieldId,
 |  | const uint8_t | fieldRules,
 |  | const void *const | pSerializedBody,
 |  | const size_t | serializedBodyLength
 | ) |  |

Append a field with the content server rule set.

Parameters:
fieldId | the field id.
fieldRules | the field rules.
pSerializedBody | the serialized body.
serializedBodyLength | the serialized body length.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED
...

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::SymbolRecordFieldListBuilder::AppendFieldWithContentServerRuleSet | ( | const FieldId | fieldId,
 |  | const uint8_t | fieldRules,
 |  | const IFieldType & | iFieldType
 | ) |  |

Append a field with the content server rule set.

Parameters:
fieldId | the field id.
fieldRules | the field rules.
iFieldType | a reference to the field.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED
...

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::SymbolRecordFieldListBuilder::AppendFieldWithNoneRuleSet | ( | const FieldId | fieldId,
 |  | const void *const | pSerializedBody,
 |  | const size_t | serializedBodyLength
 | ) |  |

Append a field with the none rule set.

Parameters:
fieldId | the field id.
pSerializedBody | the serialized body.
serializedBodyLength | the serialized body length.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED
...

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::SymbolRecordFieldListBuilder::AppendFieldWithNoneRuleSet | ( | const FieldId | fieldId,
 |  | const IFieldType & | iFieldType
 | ) |  |

Append a field with the none rule set.

Parameters:
fieldId | the field id.
iFieldType | a reference to the field.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED
...

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::SymbolRecordFieldListBuilder::AppendFieldWithTranslatorRuleSet | ( | const FieldId | fieldId,
 |  | const uint8_t | fieldRules,
 |  | const uint8_t | compositeFieldRules,
 |  | const void *const | pSerializedBody,
 |  | const size_t | serializedBodyLength
 | ) |  |

Append a field with the translator rule set.

Parameters:
fieldId | the field id.
fieldRules | the field rules.
compositeFieldRules | the composite field rules.
pSerializedBody | the serialized body.
serializedBodyLength | the serialized body length.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED
...

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::SymbolRecordFieldListBuilder::AppendFieldWithTranslatorRuleSet | ( | const FieldId | fieldId,
 |  | const uint8_t | fieldRules,
 |  | const uint8_t | compositeFieldRules,
 |  | const IFieldType & | iFieldType
 | ) |  |

Append a field with the translator rule set.

Parameters:
fieldId | the field id.
fieldRules | the field rules.
compositeFieldRules | the composite field rules.
iFieldType | a reference to the field.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED
...

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::SymbolRecordFieldListBuilder::AppendFieldWithTranslatorRuleSet | ( | const FieldId | fieldId,
 |  | const uint8_t | fieldRules,
 |  | const void *const | pSerializedBody,
 |  | const size_t | serializedBodyLength
 | ) |  |

Append a field with the translator rule set.

Parameters:
fieldId | the field id.
fieldRules | the field rules.
pSerializedBody | the serialized body.
serializedBodyLength | the serialized body length.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED
...

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::SymbolRecordFieldListBuilder::AppendFieldWithTranslatorRuleSet | ( | const FieldId | fieldId,
 |  | const uint8_t | fieldRules,
 |  | const IFieldType & | iFieldType
 | ) |  |

Append a field with the translator rule set.

Parameters:
fieldId | the field id.
fieldRules | the field rules.
iFieldType | a reference to the field.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED
...

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::SymbolRecordFieldListBuilder::AppendUndefinedField ( const FieldId fieldId )

Append an undefined field.

Parameters:
fieldId the field id.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED
...

ACTIV_FEED_MESSAGE_HANDLER_API void Activ::ContentPlatform::Feed::SymbolRecordFieldListBuilder::Initialize | ( | const TableTemplate & | tableTemplate,
 |  | const bool | isComposite,
 |  | const uint8_t | defaultRuleSet,
 |  | MessageBuilder & | messageBuilder
 | ) |  |

Initialize with a new table template and message builder.

Parameters:
tableTemplate | the table template.
isComposite | whether this is a composite update.
defaultRuleSet | the default rule set.
messageBuilder | the message builder.

ACTIV_FEED_MESSAGE_HANDLER_API bool Activ::ContentPlatform::Feed::SymbolRecordFieldListBuilder::IsInitialized ( ) const

Is the object initialized.

Returns:
whether the object is initialized.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/SymbolRecordFieldListBuilder.h
Generated on Wed Oct 8 14:02:07 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::SymbolRecordFieldListValidator

Activ::ContentPlatform::Feed::SymbolRecordFieldListValidator Class Reference

Symbol record symbol record field list validator class. More...

#include <ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/SymbolRecordFieldListValidator.h>

List of all members.

Public Member Functions

ACTIV_FEED_MESSAGE_HANDLER_API
ConstIterator 		Begin () const
Get an iterator to the first field in the message.
ACTIV_FEED_MESSAGE_HANDLER_API void | Clear ()
Clear.
ACTIV_FEED_MESSAGE_HANDLER_API
ConstIterator 		End () const
Get an iterator that points to beyond the last field in the message.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		GetSymbolRecordField (const FieldId fieldId, const SymbolRecordField *&pSymbolRecordField) const
Get a symbol record field.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		Initialize (const SymbolRecordMessageHeaderValidator &symbolRecordMessageHeaderValidator, MessageValidator &messageValidator, const bool shouldIgnoreUndefinedMissingFields=false)
Initialize.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		Initialize (const TableTemplate &tableTemplate, const bool isComposite, const uint8_t defaultRuleSet, MessageValidator &messageValidator, const bool shouldIgnoreUndefinedMissingFields=false)
Initialize.
ACTIV_FEED_MESSAGE_HANDLER_API bool | IsInitialized () const
Is the object initialized.
ACTIV_FEED_MESSAGE_HANDLER_API void | Reset ()
Reset.
ACTIV_FEED_MESSAGE_HANDLER_API | SymbolRecordFieldListValidator (const SymbolRecordMessageHeaderValidator &symbolRecordMessageHeaderValidator, MessageValidator &messageValidator, const bool shouldIgnoreUndefinedMissingFields=false)
Constructor.
ACTIV_FEED_MESSAGE_HANDLER_API | SymbolRecordFieldListValidator (const TableTemplate &tableTemplate, const bool isComposite, const uint8_t defaultRuleSet, MessageValidator &messageValidator, const bool shouldIgnoreUndefinedMissingFields=false)
Constructor.
ACTIV_FEED_MESSAGE_HANDLER_API | SymbolRecordFieldListValidator ()
Default constructor.
ACTIV_FEED_MESSAGE_HANDLER_API
std::string 		ToString () const
Put fields into string.
ACTIV_FEED_MESSAGE_HANDLER_API | ~SymbolRecordFieldListValidator ()
Destructor.

Classes

class | ConstIterator
Const iterator class. More...

Detailed Description

Symbol record symbol record field list validator class.

Definition at line 41 of file SymbolRecordFieldListValidator.h.

Constructor & Destructor Documentation

ACTIV_FEED_MESSAGE_HANDLER_API Activ::ContentPlatform::Feed::SymbolRecordFieldListValidator::SymbolRecordFieldListValidator | ( | const TableTemplate & | tableTemplate,
 |  | const bool | isComposite,
 |  | const uint8_t | defaultRuleSet,
 |  | MessageValidator & | messageValidator,
 |  | const bool | shouldIgnoreUndefinedMissingFields = false
 | ) |  |

Constructor.

Parameters:
tableTemplate | the table template.
isComposite | whether this is a composite message.
defaultRuleSet | the default rule set.
messageValidator | the message validator.
shouldIgnoreUndefinedMissingFields | whether undefined fields in the message that are missing from the table template should be ignored.
Exceptions:
StatusCodeException

ACTIV_FEED_MESSAGE_HANDLER_API Activ::ContentPlatform::Feed::SymbolRecordFieldListValidator::SymbolRecordFieldListValidator | ( | const SymbolRecordMessageHeaderValidator & | symbolRecordMessageHeaderValidator,
 |  | MessageValidator & | messageValidator,
 |  | const bool | shouldIgnoreUndefinedMissingFields = false
 | ) |  |

Constructor.

Parameters:
symbolRecordMessageHeaderValidator | the symbol record message header validator.
messageValidator | the message validator.
shouldIgnoreUndefinedMissingFields | whether undefined fields in the message that are missing from the table template should be ignored.
Exceptions:
StatusCodeException

Member Function Documentation

ACTIV_FEED_MESSAGE_HANDLER_API ConstIterator Activ::ContentPlatform::Feed::SymbolRecordFieldListValidator::Begin ( ) const

Get an iterator to the first field in the message.

Returns:
an iterator object.
Exceptions:
StatusCodeException

ACTIV_FEED_MESSAGE_HANDLER_API ConstIterator Activ::ContentPlatform::Feed::SymbolRecordFieldListValidator::End ( ) const

Get an iterator that points to beyond the last field in the message.

Returns:
an iterator object.
Exceptions:
StatusCodeException

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::SymbolRecordFieldListValidator::GetSymbolRecordField | ( | const FieldId | fieldId,
 |  | const SymbolRecordField *& | pSymbolRecordField |
 | ) |  |  | const

Get a symbol record field.

Parameters:
fieldId | the field id.
pSymbolRecordField | a pointer to the symbol record field.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_FOUND
STATUS_CODE_NOT_INITIALIZED

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::SymbolRecordFieldListValidator::Initialize | ( | const SymbolRecordMessageHeaderValidator & | symbolRecordMessageHeaderValidator,
 |  | MessageValidator & | messageValidator,
 |  | const bool | shouldIgnoreUndefinedMissingFields = false
 | ) |  |

Initialize.

Parameters:
symbolRecordMessageHeaderValidator | the symbol record message header validator.
messageValidator | the message validator.
shouldIgnoreUndefinedMissingFields | whether undefined fields in the message that are missing from the table template should be ignored.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_HEAP_EMPTY
STATUS_CODE_INVALID_FORMAT
STATUS_CODE_NOT_INITIALIZED
...

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::SymbolRecordFieldListValidator::Initialize | ( | const TableTemplate & | tableTemplate,
 |  | const bool | isComposite,
 |  | const uint8_t | defaultRuleSet,
 |  | MessageValidator & | messageValidator,
 |  | const bool | shouldIgnoreUndefinedMissingFields = false
 | ) |  |

Initialize.

Parameters:
tableTemplate | a reference to the table template.
isComposite | whether this is a composite message.
defaultRuleSet | the default rule set.
messageValidator | the message validator.
shouldIgnoreUndefinedMissingFields | whether undefined fields in the message that are missing from the table template should be ignored.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_HEAP_EMPTY
STATUS_CODE_INVALID_FORMAT
...

ACTIV_FEED_MESSAGE_HANDLER_API bool Activ::ContentPlatform::Feed::SymbolRecordFieldListValidator::IsInitialized ( ) const

Is the object initialized.

Returns:
whether the object is initialized.

ACTIV_FEED_MESSAGE_HANDLER_API std::string Activ::ContentPlatform::Feed::SymbolRecordFieldListValidator::ToString ( ) const

Put fields into string.

Returns:
string.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/SymbolRecordFieldListValidator.h
Generated on Wed Oct 8 14:02:07 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::SymbolRecordFieldListValidator::ConstIterator

Activ::ContentPlatform::Feed::SymbolRecordFieldListValidator::ConstIterator Class Reference

Const iterator class. More...

#include <ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/SymbolRecordFieldListValidator.h>

List of all members.

Public Member Functions

ConstIterator ()
Default constructor.
FieldId | GetFieldId () const
Get the field id.
const SymbolRecordField * | GetSymbolRecordField () const
Get the symbol record field.
bool | operator!= (const ConstIterator &rhs) const
Inequality operator.
const ConstIterator | operator++ (int)
Postfix increment operator.
ConstIterator & operator++ ()
Prefix increment operator.
bool | operator== (const ConstIterator &rhs) const
Equality operator.

Friends

class | SymbolRecordFieldListValidator

Detailed Description

Const iterator class.

Definition at line 47 of file SymbolRecordFieldListValidator.h.

Member Function Documentation

FieldId Activ::ContentPlatform::Feed::SymbolRecordFieldListValidator::ConstIterator::GetFieldId ( ) const [inline]

Get the field id.

Returns:
the field id.

Definition at line 336 of file SymbolRecordFieldListValidator.h.

const SymbolRecordField * Activ::ContentPlatform::Feed::SymbolRecordFieldListValidator::ConstIterator::GetSymbolRecordField ( ) const [inline]

Get the symbol record field.

Returns:
a pointer to the symbol record field.

Definition at line 343 of file SymbolRecordFieldListValidator.h.

References Activ::ContentPlatform::Feed::SymbolRecordFieldListValidator::GetCachedField().

bool Activ::ContentPlatform::Feed::SymbolRecordFieldListValidator::ConstIterator::operator!= ( const ConstIterator & rhs ) const [inline]

Inequality operator.

Parameters:
rhs the object to test against.
Returns:
whether the two objects are not equal.

Definition at line 329 of file SymbolRecordFieldListValidator.h.

const SymbolRecordFieldListValidator::ConstIterator Activ::ContentPlatform::Feed::SymbolRecordFieldListValidator::ConstIterator::operator++ ( int ) [inline]

Postfix increment operator.

Returns:
a copy of the original object.

Definition at line 311 of file SymbolRecordFieldListValidator.h.

SymbolRecordFieldListValidator::ConstIterator & Activ::ContentPlatform::Feed::SymbolRecordFieldListValidator::ConstIterator::operator++ ( ) [inline]

Prefix increment operator.

Returns:
a reference to the updated object.

Definition at line 302 of file SymbolRecordFieldListValidator.h.

bool Activ::ContentPlatform::Feed::SymbolRecordFieldListValidator::ConstIterator::operator== ( const ConstIterator & rhs ) const [inline]

Equality operator.

Parameters:
rhs the object to test against.
Returns:
whether the two objects are equal.

Definition at line 322 of file SymbolRecordFieldListValidator.h.

References m_iterator, and m_pSymbolRecordFieldListValidator.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/SymbolRecordFieldListValidator.h
Generated on Wed Oct 8 14:02:08 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::SymbolRecordMessageBuilder

Activ::ContentPlatform::Feed::SymbolRecordMessageBuilder Class Reference

Symbol record message builder class. More...

#include <ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/SymbolRecordMessageBuilder.h>

List of all members.

Public Member Functions

ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		AppendField (const FieldId fieldId, const void *const pSerializedBody, const size_t serializedBodyLength)
Append a field with the default rule set.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		AppendField (const FieldId fieldId, const IFieldType &iFieldType)
Append a field with the default rule set.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		AppendFieldWithContentServerRuleSet (const FieldId fieldId, const uint8_t fieldRules, const uint8_t compositeFieldRules, const void *const pSerializedBody, const size_t serializedBodyLength)
Append a field with the content server rule set.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		AppendFieldWithContentServerRuleSet (const FieldId fieldId, const uint8_t fieldRules, const uint8_t compositeFieldRules, const IFieldType &iFieldType)
Append a field with the content server rule set.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		AppendFieldWithContentServerRuleSet (const FieldId fieldId, const uint8_t fieldRules, const void *const pSerializedBody, const size_t serializedBodyLength)
Append a field with the content server rule set.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		AppendFieldWithContentServerRuleSet (const FieldId fieldId, const uint8_t fieldRules, const IFieldType &iFieldType)
Append a field with the content server rule set.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		AppendFieldWithNoneRuleSet (const FieldId fieldId, const void *const pSerializedBody, const size_t serializedBodyLength)
Append a field with the none rule set.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		AppendFieldWithNoneRuleSet (const FieldId fieldId, const IFieldType &iFieldType)
Append a field with the none rule set.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		AppendFieldWithTranslatorRuleSet (const FieldId fieldId, const uint8_t fieldRules, const uint8_t compositeFieldRules, const void *const pSerializedBody, const size_t serializedBodyLength)
Append a field with the translator rule set.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		AppendFieldWithTranslatorRuleSet (const FieldId fieldId, const uint8_t fieldRules, const uint8_t compositeFieldRules, const IFieldType &iFieldType)
Append a field with the translator rule set.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		AppendFieldWithTranslatorRuleSet (const FieldId fieldId, const uint8_t fieldRules, const void *const pSerializedBody, const size_t serializedBodyLength)
Append a field with the translator rule set.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		AppendFieldWithTranslatorRuleSet (const FieldId fieldId, const uint8_t fieldRules, const IFieldType &iFieldType)
Append a field with the translator rule set.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		AppendHeader (const bool isDelete, const TableId tableId, const UpdateId updateId, const UpdateId compositeUpdateId, const PermissionId permissionId, const EventType eventType, const void *const pSymbol, const size_t symbolLength, uint8_t defaultRuleSet=SymbolRecordRuleDefinitions::RULE_SET_NONE)
Append the header.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		AppendHeader (const bool isDelete, const TableId tableId, const UpdateId updateId, const PermissionId permissionId, const EventType eventType, const void *const pSymbol, const size_t symbolLength, uint8_t defaultRuleSet=SymbolRecordRuleDefinitions::RULE_SET_NONE)
Append the header.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		AppendUndefinedField (const FieldId fieldId)
Append an undefined field.
ACTIV_FEED_MESSAGE_HANDLER_API void | Initialize (MessageBuilder &messageBuilder)
Initialize with a new message builder.
ACTIV_FEED_MESSAGE_HANDLER_API void | Initialize (const TableTemplateList &tableTemplateList)
Initialize with a new table template list (and reset the object).
ACTIV_FEED_MESSAGE_HANDLER_API void | Initialize (const TableTemplateList &tableTemplateList, MessageBuilder &messageBuilder)
Initialize with a new table template list and message builder.
ACTIV_FEED_MESSAGE_HANDLER_API bool | IsInitialized () const
Is the object initialized.
ACTIV_FEED_MESSAGE_HANDLER_API void | Reset ()
Reset.
ACTIV_FEED_MESSAGE_HANDLER_API | SymbolRecordMessageBuilder (const TableTemplateList &tableTemplateList)
Constructor.
ACTIV_FEED_MESSAGE_HANDLER_API | SymbolRecordMessageBuilder (const TableTemplateList &tableTemplateList, MessageBuilder &messageBuilder)
Constructor.
ACTIV_FEED_MESSAGE_HANDLER_API | SymbolRecordMessageBuilder ()
Default constructor.
ACTIV_FEED_MESSAGE_HANDLER_API | ~SymbolRecordMessageBuilder ()
Destructor.

Detailed Description

Symbol record message builder class.

Definition at line 39 of file SymbolRecordMessageBuilder.h.

Constructor & Destructor Documentation

ACTIV_FEED_MESSAGE_HANDLER_API Activ::ContentPlatform::Feed::SymbolRecordMessageBuilder::SymbolRecordMessageBuilder | ( | const TableTemplateList & | tableTemplateList,
 |  | MessageBuilder & | messageBuilder
 | ) |  |

Constructor.

Parameters:
tableTemplateList | the table template list.
messageBuilder | the message builder.

ACTIV_FEED_MESSAGE_HANDLER_API Activ::ContentPlatform::Feed::SymbolRecordMessageBuilder::SymbolRecordMessageBuilder ( const TableTemplateList & tableTemplateList )

Constructor.

Parameters:
tableTemplateList the table template list.

Member Function Documentation

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::SymbolRecordMessageBuilder::AppendField | ( | const FieldId | fieldId,
 |  | const void *const | pSerializedBody,
 |  | const size_t | serializedBodyLength
 | ) |  |

Append a field with the default rule set.

Parameters:
fieldId | the field id.
pSerializedBody | the serialized body.
serializedBodyLength | the serialized body length.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED
...

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::SymbolRecordMessageBuilder::AppendField | ( | const FieldId | fieldId,
 |  | const IFieldType & | iFieldType
 | ) |  |

Append a field with the default rule set.

Parameters:
fieldId | the field id.
iFieldType | a reference to the field.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED
...

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::SymbolRecordMessageBuilder::AppendFieldWithContentServerRuleSet | ( | const FieldId | fieldId,
 |  | const uint8_t | fieldRules,
 |  | const uint8_t | compositeFieldRules,
 |  | const void *const | pSerializedBody,
 |  | const size_t | serializedBodyLength
 | ) |  |

Append a field with the content server rule set.

Parameters:
fieldId | the field id.
fieldRules | the field rules.
compositeFieldRules | the composite field rules.
pSerializedBody | the serialized body.
serializedBodyLength | the serialized body length.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED
...

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::SymbolRecordMessageBuilder::AppendFieldWithContentServerRuleSet | ( | const FieldId | fieldId,
 |  | const uint8_t | fieldRules,
 |  | const uint8_t | compositeFieldRules,
 |  | const IFieldType & | iFieldType
 | ) |  |

Append a field with the content server rule set.

Parameters:
fieldId | the field id.
fieldRules | the field rules.
compositeFieldRules | the composite field rules.
iFieldType | a reference to the field.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED
...

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::SymbolRecordMessageBuilder::AppendFieldWithContentServerRuleSet | ( | const FieldId | fieldId,
 |  | const uint8_t | fieldRules,
 |  | const void *const | pSerializedBody,
 |  | const size_t | serializedBodyLength
 | ) |  |

Append a field with the content server rule set.

Parameters:
fieldId | the field id.
fieldRules | the field rules.
pSerializedBody | the serialized body.
serializedBodyLength | the serialized body length.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED
...

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::SymbolRecordMessageBuilder::AppendFieldWithContentServerRuleSet | ( | const FieldId | fieldId,
 |  | const uint8_t | fieldRules,
 |  | const IFieldType & | iFieldType
 | ) |  |

Append a field with the content server rule set.

Parameters:
fieldId | the field id.
fieldRules | the field rules.
iFieldType | a reference to the field.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED
...

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::SymbolRecordMessageBuilder::AppendFieldWithNoneRuleSet | ( | const FieldId | fieldId,
 |  | const void *const | pSerializedBody,
 |  | const size_t | serializedBodyLength
 | ) |  |

Append a field with the none rule set.

Parameters:
fieldId | the field id.
pSerializedBody | the serialized body.
serializedBodyLength | the serialized body length.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED
...

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::SymbolRecordMessageBuilder::AppendFieldWithNoneRuleSet | ( | const FieldId | fieldId,
 |  | const IFieldType & | iFieldType
 | ) |  |

Append a field with the none rule set.

Parameters:
fieldId | the field id.
iFieldType | a reference to the field.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED
...

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::SymbolRecordMessageBuilder::AppendFieldWithTranslatorRuleSet | ( | const FieldId | fieldId,
 |  | const uint8_t | fieldRules,
 |  | const uint8_t | compositeFieldRules,
 |  | const void *const | pSerializedBody,
 |  | const size_t | serializedBodyLength
 | ) |  |

Append a field with the translator rule set.

Parameters:
fieldId | the field id.
fieldRules | the field rules.
compositeFieldRules | the composite field rules.
pSerializedBody | the serialized body.
serializedBodyLength | the serialized body length.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED
...

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::SymbolRecordMessageBuilder::AppendFieldWithTranslatorRuleSet | ( | const FieldId | fieldId,
 |  | const uint8_t | fieldRules,
 |  | const uint8_t | compositeFieldRules,
 |  | const IFieldType & | iFieldType
 | ) |  |

Append a field with the translator rule set.

Parameters:
fieldId | the field id.
fieldRules | the field rules.
compositeFieldRules | the composite field rules.
iFieldType | a reference to the field.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED
...

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::SymbolRecordMessageBuilder::AppendFieldWithTranslatorRuleSet | ( | const FieldId | fieldId,
 |  | const uint8_t | fieldRules,
 |  | const void *const | pSerializedBody,
 |  | const size_t | serializedBodyLength
 | ) |  |

Append a field with the translator rule set.

Parameters:
fieldId | the field id.
fieldRules | the field rules.
pSerializedBody | the serialized body.
serializedBodyLength | the serialized body length.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED
...

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::SymbolRecordMessageBuilder::AppendFieldWithTranslatorRuleSet | ( | const FieldId | fieldId,
 |  | const uint8_t | fieldRules,
 |  | const IFieldType & | iFieldType
 | ) |  |

Append a field with the translator rule set.

Parameters:
fieldId | the field id.
fieldRules | the field rules.
iFieldType | a reference to the field.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED
...

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::SymbolRecordMessageBuilder::AppendHeader | ( | const bool | isDelete,
 |  | const TableId | tableId,
 |  | const UpdateId | updateId,
 |  | const UpdateId | compositeUpdateId,
 |  | const PermissionId | permissionId,
 |  | const EventType | eventType,
 |  | const void *const | pSymbol,
 |  | const size_t | symbolLength,
 |  | uint8_t | defaultRuleSet = SymbolRecordRuleDefinitions::RULE_SET_NONE
 | ) |  |

Append the header.

Parameters:
isDelete | whether this is a delete message.
tableId | the table template id.
updateId | the update id.
compositeUpdateId | the update id.
permissionId | the permission id.
eventType | the event type.
pSymbol | the symbol.
symbolLength | the symbol length.
defaultRuleSet | the default rule set.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED
...

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::SymbolRecordMessageBuilder::AppendHeader | ( | const bool | isDelete,
 |  | const TableId | tableId,
 |  | const UpdateId | updateId,
 |  | const PermissionId | permissionId,
 |  | const EventType | eventType,
 |  | const void *const | pSymbol,
 |  | const size_t | symbolLength,
 |  | uint8_t | defaultRuleSet = SymbolRecordRuleDefinitions::RULE_SET_NONE
 | ) |  |

Append the header.

Parameters:
isDelete | whether this is a delete message.
tableId | the table template id.
updateId | the update id.
permissionId | the permission id.
eventType | the event type.
pSymbol | the symbol.
symbolLength | the symbol length.
defaultRuleSet | the default rule set.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED
...

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::SymbolRecordMessageBuilder::AppendUndefinedField ( const FieldId fieldId )

Append an undefined field.

Parameters:
fieldId the field id.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED
...

ACTIV_FEED_MESSAGE_HANDLER_API void Activ::ContentPlatform::Feed::SymbolRecordMessageBuilder::Initialize ( MessageBuilder & messageBuilder )

Initialize with a new message builder.

Parameters:
messageBuilder the message builder.

ACTIV_FEED_MESSAGE_HANDLER_API void Activ::ContentPlatform::Feed::SymbolRecordMessageBuilder::Initialize ( const TableTemplateList & tableTemplateList )

Initialize with a new table template list (and reset the object).

Parameters:
tableTemplateList the table template list.

ACTIV_FEED_MESSAGE_HANDLER_API void Activ::ContentPlatform::Feed::SymbolRecordMessageBuilder::Initialize | ( | const TableTemplateList & | tableTemplateList,
 |  | MessageBuilder & | messageBuilder
 | ) |  |

Initialize with a new table template list and message builder.

Parameters:
tableTemplateList | the table template list.
messageBuilder | the message builder.

ACTIV_FEED_MESSAGE_HANDLER_API bool Activ::ContentPlatform::Feed::SymbolRecordMessageBuilder::IsInitialized ( ) const

Is the object initialized.

Returns:
whether the object is initialized.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/SymbolRecordMessageBuilder.h
Generated on Wed Oct 8 14:02:08 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions

Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions Class Reference

Symbol record message header definitions class. More...

#include <ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/SymbolRecordMessageHeaderDefinitions.h>

List of all members.

Public Types

typedef uint8_t | Flags
The flags type definition.

Static Public Member Functions

static void | ExtractFlags (const Flags flags, bool &isExpandedFormat, bool &isDoNotAdd)
Extract flags.
static Flags | GetFlags (const bool isExpandedFormat, const bool isDoNotAdd)
Get the flags.
static
MessageHeaderDefinitions::MessageHeader 		GetMessageHeader (const bool isDelete, const bool isComposite, const MessageType messageType=MESSAGE_TYPE)
Get the message header.
static bool | IsComposite (const MessageHeaderDefinitions::MessageHeader messageHeader)
Is this a composite message.
static bool | IsDelete (const MessageHeaderDefinitions::MessageHeader messageHeader)
Is this a delete message.
static bool | IsDoNotAdd (const Flags flags)
Is this a do not add.
static bool | IsExpandedFormat (const Flags flags)
Is this a expanded format.
static bool | IsValidMessageType (const MessageHeaderDefinitions::MessageHeader messageHeader)
Is valid message type.

Static Public Attributes

static const Flags | FLAGS_DO_NOT_ADD_BIT_MASK = static_cast<Flags>((1 << FLAGS_DO_NOT_ADD_LENGTH) - 1)
static const size_t | FLAGS_DO_NOT_ADD_BIT_SHIFT = (sizeof(Flags) * CHAR_BIT) - (FLAGS_DO_NOT_ADD_OFFSET + FLAGS_DO_NOT_ADD_LENGTH)
static const size_t | FLAGS_DO_NOT_ADD_LENGTH = 1
The flags do not add length.
static const size_t | FLAGS_DO_NOT_ADD_OFFSET = (FLAGS_EXPANDED_FORMAT_OFFSET + FLAGS_EXPANDED_FORMAT_LENGTH)
The flags do not add offset.
static const Flags | FLAGS_EXPANDED_FORMAT_BIT_MASK = static_cast<Flags>((1 << FLAGS_EXPANDED_FORMAT_LENGTH) - 1)
static const size_t | FLAGS_EXPANDED_FORMAT_BIT_SHIFT = (sizeof(Flags) * CHAR_BIT) - (FLAGS_EXPANDED_FORMAT_OFFSET + FLAGS_EXPANDED_FORMAT_LENGTH)
static const size_t | FLAGS_EXPANDED_FORMAT_LENGTH = 1
The flags expanded format length.
static const size_t | FLAGS_EXPANDED_FORMAT_OFFSET = 0
The flags expanded format offset.
static const size_t | MAX_SYMBOL_LENGTH = 255
The maximum symbol length.
static const
MessageHeaderDefinitions::MessageHeader 		MESSAGE_HEADER_FLAGS_COMPOSITE_BIT_MASK = static_cast<MessageHeaderDefinitions::MessageHeader>((1 << MESSAGE_HEADER_FLAGS_COMPOSITE_LENGTH) - 1)
static const size_t | MESSAGE_HEADER_FLAGS_COMPOSITE_BIT_SHIFT = MessageHeaderDefinitions::FLAGS_LENGTH - (MESSAGE_HEADER_FLAGS_COMPOSITE_OFFSET + MESSAGE_HEADER_FLAGS_COMPOSITE_LENGTH)
static const size_t | MESSAGE_HEADER_FLAGS_COMPOSITE_LENGTH = 1
The message header flags composite length.
static const size_t | MESSAGE_HEADER_FLAGS_COMPOSITE_OFFSET = (MESSAGE_HEADER_FLAGS_DELETE_OFFSET + MESSAGE_HEADER_FLAGS_DELETE_LENGTH)
The message header flags composite offset.
static const
MessageHeaderDefinitions::MessageHeader 		MESSAGE_HEADER_FLAGS_DELETE_BIT_MASK = static_cast<MessageHeaderDefinitions::MessageHeader>((1 << MESSAGE_HEADER_FLAGS_DELETE_LENGTH) - 1)
static const size_t | MESSAGE_HEADER_FLAGS_DELETE_BIT_SHIFT = MessageHeaderDefinitions::FLAGS_LENGTH - (MESSAGE_HEADER_FLAGS_DELETE_OFFSET + MESSAGE_HEADER_FLAGS_DELETE_LENGTH)
static const size_t | MESSAGE_HEADER_FLAGS_DELETE_LENGTH = 1
The message header flags delete length.
static const size_t | MESSAGE_HEADER_FLAGS_DELETE_OFFSET = 0
The message header flags delete offset.
static const MessageType | MESSAGE_TYPE = MESSAGE_TYPE_SYMBOL_RECORD
The message type.

Detailed Description

Symbol record message header definitions class.

Definition at line 28 of file SymbolRecordMessageHeaderDefinitions.h.

Member Function Documentation

void Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions::ExtractFlags | ( | const Flags | flags,
 |  | bool & | isExpandedFormat,
 |  | bool & | isDoNotAdd |
 | ) |  |  | [inline, static]

Extract flags.

Parameters:
flags | the flags to extract from.
isExpandedFormat | set equal to true if this is a expanded format.
isDoNotAdd | set equal to true if this is a do not add.

Definition at line 170 of file SymbolRecordMessageHeaderDefinitions.h.

References IsDoNotAdd(), and IsExpandedFormat().

SymbolRecordMessageHeaderDefinitions::Flags Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions::GetFlags | ( | const bool | isExpandedFormat,
 |  | const bool | isDoNotAdd |
 | ) |  |  | [inline, static]

Get the flags.

Parameters:
isExpandedFormat | whether this is a expanded format.
isDoNotAdd | whether this is a do not add.
Returns:
the flags.

Definition at line 163 of file SymbolRecordMessageHeaderDefinitions.h.

MessageHeaderDefinitions::MessageHeader Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions::GetMessageHeader | ( | const bool | isDelete,
 |  | const bool | isComposite,
 |  | const MessageType | messageType = MESSAGE_TYPE |
 | ) |  |  | [inline, static]

Get the message header.

Parameters:
isDelete | whether this is a delete message.
isComposite | whether this is a composite message.
messageType | the message type.
Returns:
the message header.

Definition at line 135 of file SymbolRecordMessageHeaderDefinitions.h.

References Activ::ContentPlatform::Feed::MessageHeaderDefinitions::GetMessageHeader().

bool Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions::IsComposite ( const MessageHeaderDefinitions::MessageHeader messageHeader ) [inline, static]

Is this a composite message.

Parameters:
messageHeader the message header.
Returns:
whether this is a composite message.

Definition at line 156 of file SymbolRecordMessageHeaderDefinitions.h.

References Activ::ContentPlatform::Feed::MessageHeaderDefinitions::GetFlags().

bool Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions::IsDelete ( const MessageHeaderDefinitions::MessageHeader messageHeader ) [inline, static]

Is this a delete message.

Parameters:
messageHeader the message header.
Returns:
whether this is a delete message.

Definition at line 149 of file SymbolRecordMessageHeaderDefinitions.h.

References Activ::ContentPlatform::Feed::MessageHeaderDefinitions::GetFlags().

bool Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions::IsDoNotAdd ( const Flags flags ) [inline, static]

Is this a do not add.

Parameters:
flags the flags.
Returns:
whether this is a do not add.

Definition at line 185 of file SymbolRecordMessageHeaderDefinitions.h.

Referenced by ExtractFlags().

bool Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions::IsExpandedFormat ( const Flags flags ) [inline, static]

Is this a expanded format.

Parameters:
flags the flags.
Returns:
whether this is a expanded format.

Definition at line 178 of file SymbolRecordMessageHeaderDefinitions.h.

Referenced by ExtractFlags().

bool Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions::IsValidMessageType ( const MessageHeaderDefinitions::MessageHeader messageHeader ) [inline, static]

Is valid message type.

Parameters:
messageHeader the message header.
Returns:
whether the message type is valid.

Definition at line 142 of file SymbolRecordMessageHeaderDefinitions.h.

References Activ::ContentPlatform::Feed::MessageHeaderDefinitions::IsValidMessageType(), and MESSAGE_TYPE.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/SymbolRecordMessageHeaderDefinitions.h
Generated on Wed Oct 8 14:02:08 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator

Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator Class Reference

Symbol record message header validator class. More...

#include <ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/SymbolRecordMessageHeaderValidator.h>

List of all members.

Public Member Functions

ACTIV_FEED_MESSAGE_HANDLER_API void | Clear ()
Clear.
ACTIV_FEED_MESSAGE_HANDLER_API
std::string 		CompositeUpdateIdToString () const
Composite Update ID copied to string.
ACTIV_FEED_MESSAGE_HANDLER_API
std::string 		DefaultRuleSetToString () const
DefaultRuleSet copied to string.
ACTIV_FEED_MESSAGE_HANDLER_API
std::string 		EventTypeToString () const
EventType copied to string.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		GetCompositeUpdateId (UpdateId &compositeUpdateId) const
Get the composite update id.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		GetDefaultRuleSet (uint8_t &defaultRuleSet) const
Get the default rule set.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		GetEventType (EventType &eventType) const
Get the event type.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		GetPermissionId (PermissionId &permissionId) const
Get the permission id.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		GetSymbol (const TextString *&pSymbol) const
Get the symbol.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		GetTableTemplate (const TableTemplate *&pTableTemplate) const
Get the table template.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		GetUpdateId (UpdateId &updateId) const
Get the update id.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		Initialize (MessageValidator &messageValidator)
Initialize with a new header validator.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		Initialize (const TableTemplateList &tableTemplateList, const bool shouldIgnoreMissingTableTemplate=false)
Initialize with a new table template list (and reset the object).
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		Initialize (const TableTemplateList &tableTemplateList, MessageValidator &messageValidator, const bool shouldIgnoreMissingTableTemplate=false)
Initialize with a new table template list and header validator.
ACTIV_FEED_MESSAGE_HANDLER_API bool | IsComposite () const
Is this a composite update.
ACTIV_FEED_MESSAGE_HANDLER_API
std::string 		IsCompositeToString () const
Is this a composite message copied to string.
ACTIV_FEED_MESSAGE_HANDLER_API bool | IsDelete () const
Is this a delete message.
ACTIV_FEED_MESSAGE_HANDLER_API
std::string 		IsDeleteToString () const
Convert message header to string.
ACTIV_FEED_MESSAGE_HANDLER_API bool | IsInitialized () const
Is the object initialized.
ACTIV_FEED_MESSAGE_HANDLER_API
std::string 		PermissionIdToString () const
Permission ID copied to string.
ACTIV_FEED_MESSAGE_HANDLER_API void | Reset ()
Reset.
ACTIV_FEED_MESSAGE_HANDLER_API | SymbolRecordMessageHeaderValidator (const TableTemplateList &tableTemplateList, const bool shouldIgnoreMissingTableTemplate=false)
Constructor.
ACTIV_FEED_MESSAGE_HANDLER_API | SymbolRecordMessageHeaderValidator (const TableTemplateList &tableTemplateList, MessageValidator &messageValidator, const bool shouldIgnoreMissingTableTemplate=false)
Constructor.
ACTIV_FEED_MESSAGE_HANDLER_API | SymbolRecordMessageHeaderValidator ()
Default constructor.
ACTIV_FEED_MESSAGE_HANDLER_API
std::string 		SymbolToString () const
Symbol copied to string.
ACTIV_FEED_MESSAGE_HANDLER_API
std::string 		TableTemplateIdToString () const
TableTemplate ID copied to string.
ACTIV_FEED_MESSAGE_HANDLER_API
std::string 		TableTemplateNameToString () const
TableTemplate Name copied to string.
ACTIV_FEED_MESSAGE_HANDLER_API
std::string 		ToString () const
Message Header copied to string.
ACTIV_FEED_MESSAGE_HANDLER_API
std::string 		UpdateIdToString () const
Update ID copied to string.
ACTIV_FEED_MESSAGE_HANDLER_API | ~SymbolRecordMessageHeaderValidator ()
Destructor.

Friends

class | SymbolRecordFieldListValidator

Detailed Description

Symbol record message header validator class.

Definition at line 33 of file SymbolRecordMessageHeaderValidator.h.

Constructor & Destructor Documentation

ACTIV_FEED_MESSAGE_HANDLER_API Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator::SymbolRecordMessageHeaderValidator | ( | const TableTemplateList & | tableTemplateList,
 |  | MessageValidator & | messageValidator,
 |  | const bool | shouldIgnoreMissingTableTemplate = false
 | ) |  |

Constructor.

Parameters:
tableTemplateList | the table template list.
messageValidator | the header validator.
shouldIgnoreMissingTableTemplate | whether a message for a table template missing from the table template list should be ignored.
Exceptions:
StatusCodeException

ACTIV_FEED_MESSAGE_HANDLER_API Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator::SymbolRecordMessageHeaderValidator | ( | const TableTemplateList & | tableTemplateList,
 |  | const bool | shouldIgnoreMissingTableTemplate = false
 | ) |  |

Constructor.

Parameters:
tableTemplateList | the table template list.
shouldIgnoreMissingTableTemplate | whether a message for a table template missing from the table template list should be ignored.
Exceptions:
StatusCodeException

Member Function Documentation

ACTIV_FEED_MESSAGE_HANDLER_API std::string Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator::CompositeUpdateIdToString ( ) const

Composite Update ID copied to string.

Returns:
formatted string

ACTIV_FEED_MESSAGE_HANDLER_API std::string Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator::DefaultRuleSetToString ( ) const

DefaultRuleSet copied to string.

Returns:
formatted string

ACTIV_FEED_MESSAGE_HANDLER_API std::string Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator::EventTypeToString ( ) const

EventType copied to string.

Returns:
formatted string

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator::GetCompositeUpdateId ( UpdateId & compositeUpdateId ) const

Get the composite update id.

Parameters:
compositeUpdateId the composite update id.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_FAILURE
STATUS_CODE_NOT_INITIALIZED

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator::GetDefaultRuleSet ( uint8_t & defaultRuleSet ) const

Get the default rule set.

Parameters:
defaultRuleSet the default rule set.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator::GetEventType ( EventType & eventType ) const

Get the event type.

Parameters:
eventType the event type.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator::GetPermissionId ( PermissionId & permissionId ) const

Get the permission id.

Parameters:
permissionId the permission id.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator::GetSymbol ( const TextString *& pSymbol ) const

Get the symbol.

Parameters:
pSymbol a pointer to the symbol.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator::GetTableTemplate ( const TableTemplate *& pTableTemplate ) const

Get the table template.

Parameters:
pTableTemplate a pointer to the table template.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator::GetUpdateId ( UpdateId & updateId ) const

Get the update id.

Parameters:
updateId the update id.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_FAILURE
STATUS_CODE_NOT_INITIALIZED

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator::Initialize ( MessageValidator & messageValidator )

Initialize with a new header validator.

Parameters:
messageValidator the header validator.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_IGNORED
...

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator::Initialize | ( | const TableTemplateList & | tableTemplateList,
 |  | const bool | shouldIgnoreMissingTableTemplate = false
 | ) |  |

Initialize with a new table template list (and reset the object).

Parameters:
tableTemplateList | the table template list.
shouldIgnoreMissingTableTemplate | whether a message for a table template missing from the table template list should be ignored.
Return values:
STATUS_CODE_SUCCESS

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator::Initialize | ( | const TableTemplateList & | tableTemplateList,
 |  | MessageValidator & | messageValidator,
 |  | const bool | shouldIgnoreMissingTableTemplate = false
 | ) |  |

Initialize with a new table template list and header validator.

Parameters:
tableTemplateList | the table template list.
messageValidator | the header validator.
shouldIgnoreMissingTableTemplate | whether a message for a table template missing from the table template list should be ignored.
Return values:
STATUS_CODE_SUCCESS
...

ACTIV_FEED_MESSAGE_HANDLER_API bool Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator::IsComposite ( ) const

Is this a composite update.

Returns:
whether this is a composite update.

ACTIV_FEED_MESSAGE_HANDLER_API std::string Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator::IsCompositeToString ( ) const

Is this a composite message copied to string.

Returns:
formatted string

ACTIV_FEED_MESSAGE_HANDLER_API bool Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator::IsDelete ( ) const

Is this a delete message.

Returns:
whether this is a delete message.

ACTIV_FEED_MESSAGE_HANDLER_API std::string Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator::IsDeleteToString ( ) const

Convert message header to string.

Returns:
formatted string

ACTIV_FEED_MESSAGE_HANDLER_API bool Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator::IsInitialized ( ) const

Is the object initialized.

Returns:
whether the object is initialized.

ACTIV_FEED_MESSAGE_HANDLER_API std::string Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator::PermissionIdToString ( ) const

Permission ID copied to string.

Returns:
formatted string

ACTIV_FEED_MESSAGE_HANDLER_API std::string Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator::SymbolToString ( ) const

Symbol copied to string.

Returns:
formatted string

ACTIV_FEED_MESSAGE_HANDLER_API std::string Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator::TableTemplateIdToString ( ) const

TableTemplate ID copied to string.

Returns:
formatted string

ACTIV_FEED_MESSAGE_HANDLER_API std::string Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator::TableTemplateNameToString ( ) const

TableTemplate Name copied to string.

Returns:
formatted string

ACTIV_FEED_MESSAGE_HANDLER_API std::string Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator::ToString ( ) const

Message Header copied to string.

Returns:
formatted string

ACTIV_FEED_MESSAGE_HANDLER_API std::string Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator::UpdateIdToString ( ) const

Update ID copied to string.

Returns:
formatted string

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/SymbolRecordMessageHeaderValidator.h
Generated on Wed Oct 8 14:02:08 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::SymbolRecordMessageValidator

Activ::ContentPlatform::Feed::SymbolRecordMessageValidator Class Reference

Symbol record message validator class. More...

#include <ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/SymbolRecordMessageValidator.h>

List of all members.

Public Types

typedef
SymbolRecordFieldListValidator::ConstIterator 		ConstIterator
The const iterator type definition.

Public Member Functions

ACTIV_FEED_MESSAGE_HANDLER_API
ConstIterator 		Begin () const
Get an iterator to the first field in the message.
ACTIV_FEED_MESSAGE_HANDLER_API void | Clear ()
Clear.
ACTIV_FEED_MESSAGE_HANDLER_API
ConstIterator 		End () const
Get an iterator that points to beyond the last field in the message.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		GetCompositeUpdateId (UpdateId &compositeUpdateId) const
Get the composite update id.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		GetDefaultRuleSet (uint8_t &defaultRuleSet) const
Get the default rule set.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		GetEventType (EventType &eventType) const
Get the event type.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		GetPermissionId (PermissionId &permissionId) const
Get the permission id.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		GetSymbol (const TextString *&pSymbol) const
Get the symbol.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		GetSymbolRecordField (const FieldId fieldId, const SymbolRecordField *&pSymbolRecordField) const
Get a symbol record field.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		GetTableTemplate (const TableTemplate *&pTableTemplate) const
Get the table template.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		GetUpdateId (UpdateId &updateId) const
Get the update id.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		Initialize (MessageValidator &messageValidator, const bool shouldIgnoreUndefinedMissingFields=false)
Initialize with a new message validator.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		Initialize (const TableTemplateList &tableTemplateList, const bool shouldIgnoreMissingTableTemplate=false)
Initialize with a new table template list (and reset the object).
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		Initialize (const TableTemplateList &tableTemplateList, MessageValidator &messageValidator, const bool shouldIgnoreMissingTableTemplate=false, const bool shouldIgnoreUndefinedMissingFields=false)
Initialize with a new table template list and message validator.
ACTIV_FEED_MESSAGE_HANDLER_API bool | IsComposite () const
Is this a composite update.
ACTIV_FEED_MESSAGE_HANDLER_API bool | IsDelete () const
Is this a delete message.
ACTIV_FEED_MESSAGE_HANDLER_API bool | IsInitialized () const
Is the object initialized.
ACTIV_FEED_MESSAGE_HANDLER_API void | Reset ()
Reset.
ACTIV_FEED_MESSAGE_HANDLER_API | SymbolRecordMessageValidator (const TableTemplateList &tableTemplateList, const bool shouldIgnoreMissingTableTemplate=false)
Constructor.
ACTIV_FEED_MESSAGE_HANDLER_API | SymbolRecordMessageValidator (const TableTemplateList &tableTemplateList, MessageValidator &messageValidator, const bool shouldIgnoreMissingTableTemplate=false, const bool shouldIgnoreUndefinedMissingFields=false)
Constructor.
ACTIV_FEED_MESSAGE_HANDLER_API | SymbolRecordMessageValidator ()
Default constructor.
ACTIV_FEED_MESSAGE_HANDLER_API
std::string 		ToString () const
Copy Symbol Record Message to string.
ACTIV_FEED_MESSAGE_HANDLER_API | ~SymbolRecordMessageValidator ()
Destructor.

Detailed Description

Symbol record message validator class.

Definition at line 40 of file SymbolRecordMessageValidator.h.

Constructor & Destructor Documentation

ACTIV_FEED_MESSAGE_HANDLER_API Activ::ContentPlatform::Feed::SymbolRecordMessageValidator::SymbolRecordMessageValidator | ( | const TableTemplateList & | tableTemplateList,
 |  | MessageValidator & | messageValidator,
 |  | const bool | shouldIgnoreMissingTableTemplate = false,
 |  | const bool | shouldIgnoreUndefinedMissingFields = false
 | ) |  |

Constructor.

Parameters:
tableTemplateList | the table template list.
messageValidator | the message validator.
shouldIgnoreMissingTableTemplate | whether a message for a table template missing from the table template list should be ignored.
shouldIgnoreUndefinedMissingFields | whether undefined fields in the message that are missing from the table template should be ignored.
Exceptions:
StatusCodeException if there are duplicate fields in messageValidator

ACTIV_FEED_MESSAGE_HANDLER_API Activ::ContentPlatform::Feed::SymbolRecordMessageValidator::SymbolRecordMessageValidator | ( | const TableTemplateList & | tableTemplateList,
 |  | const bool | shouldIgnoreMissingTableTemplate = false
 | ) |  |

Constructor.

Parameters:
tableTemplateList | the table template list.
shouldIgnoreMissingTableTemplate | whether a message for a table template missing from the table template list should be ignored.
Exceptions:
StatusCodeException

Member Function Documentation

ACTIV_FEED_MESSAGE_HANDLER_API ConstIterator Activ::ContentPlatform::Feed::SymbolRecordMessageValidator::Begin ( ) const

Get an iterator to the first field in the message.

Returns:
an iterator object.
Exceptions:
StatusCodeException

ACTIV_FEED_MESSAGE_HANDLER_API ConstIterator Activ::ContentPlatform::Feed::SymbolRecordMessageValidator::End ( ) const

Get an iterator that points to beyond the last field in the message.

Returns:
an iterator object.
Exceptions:
StatusCodeException

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::SymbolRecordMessageValidator::GetCompositeUpdateId ( UpdateId & compositeUpdateId ) const

Get the composite update id.

Parameters:
compositeUpdateId the composite update id.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_FAILURE
STATUS_CODE_NOT_INITIALIZED

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::SymbolRecordMessageValidator::GetDefaultRuleSet ( uint8_t & defaultRuleSet ) const

Get the default rule set.

Parameters:
defaultRuleSet the default rule set.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::SymbolRecordMessageValidator::GetEventType ( EventType & eventType ) const

Get the event type.

Parameters:
eventType the event type.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::SymbolRecordMessageValidator::GetPermissionId ( PermissionId & permissionId ) const

Get the permission id.

Parameters:
permissionId the permission id.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::SymbolRecordMessageValidator::GetSymbol ( const TextString *& pSymbol ) const

Get the symbol.

Parameters:
pSymbol a pointer to the symbol.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::SymbolRecordMessageValidator::GetSymbolRecordField | ( | const FieldId | fieldId,
 |  | const SymbolRecordField *& | pSymbolRecordField |
 | ) |  |  | const

Get a symbol record field.

Parameters:
fieldId | the field id.
pSymbolRecordField | a pointer to the symbol record field.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED
...

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::SymbolRecordMessageValidator::GetTableTemplate ( const TableTemplate *& pTableTemplate ) const

Get the table template.

Parameters:
pTableTemplate a pointer to the table template.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::SymbolRecordMessageValidator::GetUpdateId ( UpdateId & updateId ) const

Get the update id.

Parameters:
updateId the update id.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_FAILURE
STATUS_CODE_NOT_INITIALIZED

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::SymbolRecordMessageValidator::Initialize | ( | MessageValidator & | messageValidator,
 |  | const bool | shouldIgnoreUndefinedMissingFields = false
 | ) |  |

Initialize with a new message validator.

Parameters:
messageValidator | the message validator.
shouldIgnoreUndefinedMissingFields | whether undefined fields in the message that are missing from the table template should be ignored.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_IGNORED
...

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::SymbolRecordMessageValidator::Initialize | ( | const TableTemplateList & | tableTemplateList,
 |  | const bool | shouldIgnoreMissingTableTemplate = false
 | ) |  |

Initialize with a new table template list (and reset the object).

Parameters:
tableTemplateList | the table template list.
shouldIgnoreMissingTableTemplate | whether a message for a table template missing from the table template list should be ignored.
Return values:
STATUS_CODE_SUCCESS

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::SymbolRecordMessageValidator::Initialize | ( | const TableTemplateList & | tableTemplateList,
 |  | MessageValidator & | messageValidator,
 |  | const bool | shouldIgnoreMissingTableTemplate = false,
 |  | const bool | shouldIgnoreUndefinedMissingFields = false
 | ) |  |

Initialize with a new table template list and message validator.

Parameters:
tableTemplateList | the table template list.
messageValidator | the message validator.
shouldIgnoreMissingTableTemplate | whether a message for a table template missing from the table template list should be ignored.
shouldIgnoreUndefinedMissingFields | whether undefined fields in the message that are missing from the table template should be ignored.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_IGNORED
...

ACTIV_FEED_MESSAGE_HANDLER_API bool Activ::ContentPlatform::Feed::SymbolRecordMessageValidator::IsComposite ( ) const

Is this a composite update.

Returns:
whether this is a composite update.

ACTIV_FEED_MESSAGE_HANDLER_API bool Activ::ContentPlatform::Feed::SymbolRecordMessageValidator::IsDelete ( ) const

Is this a delete message.

Returns:
whether this is a delete message.

ACTIV_FEED_MESSAGE_HANDLER_API bool Activ::ContentPlatform::Feed::SymbolRecordMessageValidator::IsInitialized ( ) const

Is the object initialized.

Returns:
whether the object is initialized.

ACTIV_FEED_MESSAGE_HANDLER_API std::string Activ::ContentPlatform::Feed::SymbolRecordMessageValidator::ToString ( ) const

Copy Symbol Record Message to string.

Returns:
string.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/SymbolRecordMessageValidator.h
Generated on Wed Oct 8 14:02:08 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions

Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions Class Reference

Symbol record rules definitions class. More...

#include <ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/SymbolRecordRuleDefinitions.h>

List of all members.

Public Types

enum {
RULE_SET_NONE, RULE_SET_TRANSLATOR, RULE_SET_CONTENT_SERVER, RULE_SET_COPY,
RULE_SET_PARTIAL_BIT_UPDATE, RULE_SET_PARTIAL_BYTE_UPDATE, NUMBER_OF_RULE_SETS
}
Rule sets. More...

Static Public Member Functions

static uint8_t | ClearFieldRules (const uint8_t fieldRules, const uint8_t initialFieldRules=FIELD_RULE_SET_ALL)
Clear the field rules.
static uint8_t | SetFieldRules (const uint8_t fieldRules, const uint8_t initialFieldRules=FIELD_RULE_CLEAR_ALL)
Set the field rules.

Static Public Attributes

static const uint8_t | FIELD_RULE_CLEAR_ALL = 0
Apply all field rules.
static const uint8_t | FIELD_RULE_SET_ALL = ~0
Apply no field rules.

Classes

class | ContentServerRuleSet
content server rule set. More...
class | TranslatorRuleSet
Translator rule set. More...

Detailed Description

Symbol record rules definitions class.

Definition at line 28 of file SymbolRecordRuleDefinitions.h.

Member Enumeration Documentation

anonymous enum

Rule sets.

Enumerator:
RULE_SET_NONE | The none rule set.
RULE_SET_TRANSLATOR | The translator rule set.
RULE_SET_CONTENT_SERVER | The content server rule set.
RULE_SET_COPY | The copy rule set.
RULE_SET_PARTIAL_BIT_UPDATE | The partial bit update rule set.
RULE_SET_PARTIAL_BYTE_UPDATE | The partial byte update rule set.
NUMBER_OF_RULE_SETS | The number of rule sets.

Definition at line 34 of file SymbolRecordRuleDefinitions.h.

Member Function Documentation

uint8_t Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ClearFieldRules | ( | const uint8_t | fieldRules,
 |  | const uint8_t | initialFieldRules = FIELD_RULE_SET_ALL |
 | ) |  |  | [inline, static]

Clear the field rules.

Parameters:
fieldRules | the field rules to clear.
initialFieldRules | the initial state of the field rules.
Returns:
the field rules.

Definition at line 304 of file SymbolRecordRuleDefinitions.h.

uint8_t Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::SetFieldRules | ( | const uint8_t | fieldRules,
 |  | const uint8_t | initialFieldRules = FIELD_RULE_CLEAR_ALL |
 | ) |  |  | [inline, static]

Set the field rules.

Parameters:
fieldRules | the field rules to set.
initialFieldRules | the initial state of the field rules.
Returns:
the field rules.

Definition at line 297 of file SymbolRecordRuleDefinitions.h.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/SymbolRecordRuleDefinitions.h
Generated on Wed Oct 8 14:02:08 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ContentServerRuleSet

Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ContentServerRuleSet Class Reference

content server rule set. More...

#include <ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/SymbolRecordRuleDefinitions.h>

List of all members.

Public Types

enum {
FIELD_RULE_BIT_DO_NOT_UPDATE_FIELD, FIELD_RULE_BIT_IS_HIGH, FIELD_RULE_BIT_IS_LOW, FIELD_RULE_BIT_IS_OPEN,
FIELD_RULE_BIT_DO_NOT_APPLY_ADD_RULE_1, FIELD_RULE_BIT_DO_NOT_APPLY_ADD_RULE_2, FIELD_RULE_BIT_APPLY_TRENDING, FIELD_RULE_BIT_DO_NOT_APPLY_CHANGE_RULE
}
Field rule bits. More...

Static Public Member Functions

static uint8_t | GetFieldRules (const bool shouldUpdateField, const bool isHigh, const bool isLow, const bool isOpen, const bool shouldApplyAddRule1, const bool shouldApplyAddRule2, const bool shouldApplyTrending, const bool shouldApplyChangeRule)
Get the field rules.
static bool | IsHigh (const uint8_t fieldRules)
Should the high be updated.
static bool | IsLow (const uint8_t fieldRules)
Should the low be updated.
static bool | IsOpen (const uint8_t fieldRules)
Should the open be updated.
static bool | ShouldApplyAddRule1 (const uint8_t fieldRules)
Should the add rules 1 be applied.
static bool | ShouldApplyAddRule2 (const uint8_t fieldRules)
Should the add rules 2 be applied.
static bool | ShouldApplyChangeRule (const uint8_t fieldRules)
Should the change rule be applied.
static bool | ShouldApplyTrending (const uint8_t fieldRules)
Should the trending be applied.
static bool | ShouldUpdateField (const uint8_t fieldRules)
Should the field be updated.

Static Public Attributes

static const uint8_t | FIELD_RULE_APPLY_TRENDING = (1 << ((sizeof(uint8_t) * CHAR_BIT) - (FIELD_RULE_BIT_APPLY_TRENDING + 1)))
The "apply trending" field rule.
static const uint8_t | FIELD_RULE_BITMASK_IS_HIGH = (1 << ((sizeof(uint8_t) * CHAR_BIT) - (FIELD_RULE_BIT_IS_HIGH + 1)))
The "is high" field rule.
static const uint8_t | FIELD_RULE_BITMASK_IS_LOW = (1 << ((sizeof(uint8_t) * CHAR_BIT) - (FIELD_RULE_BIT_IS_LOW + 1)))
The "is low" field rule.
static const uint8_t | FIELD_RULE_BITMASK_IS_OPEN = (1 << ((sizeof(uint8_t) * CHAR_BIT) - (FIELD_RULE_BIT_IS_OPEN + 1)))
The "is open" field rule.
static const uint8_t | FIELD_RULE_DO_NOT_APPLY_ADD_RULE_1 = (1 << ((sizeof(uint8_t) * CHAR_BIT) - (FIELD_RULE_BIT_DO_NOT_APPLY_ADD_RULE_1 + 1)))
The "do not apply add rules (1)" field rule.
static const uint8_t | FIELD_RULE_DO_NOT_APPLY_ADD_RULE_2 = (1 << ((sizeof(uint8_t) * CHAR_BIT) - (FIELD_RULE_BIT_DO_NOT_APPLY_ADD_RULE_2 + 1)))
The "do not apply add rules (2)" field rule.
static const uint8_t | FIELD_RULE_DO_NOT_APPLY_CHANGE_RULE = (1 << ((sizeof(uint8_t) * CHAR_BIT) - (FIELD_RULE_BIT_DO_NOT_APPLY_CHANGE_RULE + 1)))
The "do not apply change rule" field rule.
static const uint8_t | FIELD_RULE_DO_NOT_UPDATE_FIELD = (1 << ((sizeof(uint8_t) * CHAR_BIT) - (FIELD_RULE_BIT_DO_NOT_UPDATE_FIELD + 1)))
The "do not update field" field rule.

Detailed Description

content server rule set.

Definition at line 155 of file SymbolRecordRuleDefinitions.h.

Member Enumeration Documentation

anonymous enum

Field rule bits.

Enumerator:
FIELD_RULE_BIT_DO_NOT_UPDATE_FIELD | The "do not update field" field rule bit.
FIELD_RULE_BIT_IS_HIGH | The "is high" field rule bit.
FIELD_RULE_BIT_IS_LOW | The "is low" field rule bit.
FIELD_RULE_BIT_IS_OPEN | The "is open" field rule bit.
FIELD_RULE_BIT_DO_NOT_APPLY_ADD_RULE_1 | The "do not apply add rules (1)" field rule bit.
FIELD_RULE_BIT_DO_NOT_APPLY_ADD_RULE_2 | The "do not apply add rules (2)" field rule bit.
FIELD_RULE_BIT_APPLY_TRENDING | The "apply trending" field rule bit.
FIELD_RULE_BIT_DO_NOT_APPLY_CHANGE_RULE | The "do not apply change rule" field rule bit.

Definition at line 161 of file SymbolRecordRuleDefinitions.h.

Member Function Documentation

uint8_t Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ContentServerRuleSet::GetFieldRules | ( | const bool | shouldUpdateField,
 |  | const bool | isHigh,
 |  | const bool | isLow,
 |  | const bool | isOpen,
 |  | const bool | shouldApplyAddRule1,
 |  | const bool | shouldApplyAddRule2,
 |  | const bool | shouldApplyTrending,
 |  | const bool | shouldApplyChangeRule |
 | ) |  |  | [inline, static]

Get the field rules.

Parameters:
shouldUpdateField | whether the field should be updated.
isHigh | whether the high should be updated.
isLow | whether the low should be updated.
isOpen | whether the open should be updated.
shouldApplyAddRule1 | whether the add rules 1 should be applied.
shouldApplyAddRule2 | whether the add rules 2 should be applied.
shouldApplyTrending | whether the trending should be applied.
shouldApplyChangeRule | whether the change rule should be applied.
Returns:
the rules.

Definition at line 369 of file SymbolRecordRuleDefinitions.h.

References FIELD_RULE_APPLY_TRENDING, FIELD_RULE_BITMASK_IS_HIGH, FIELD_RULE_BITMASK_IS_LOW, FIELD_RULE_BITMASK_IS_OPEN, FIELD_RULE_DO_NOT_APPLY_ADD_RULE_1, FIELD_RULE_DO_NOT_APPLY_ADD_RULE_2, FIELD_RULE_DO_NOT_APPLY_CHANGE_RULE, and FIELD_RULE_DO_NOT_UPDATE_FIELD.

bool Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ContentServerRuleSet::IsHigh ( const uint8_t fieldRules ) [inline, static]

Should the high be updated.

Parameters:
fieldRules the field rules.
Returns:
whether the high should be updated.

Definition at line 383 of file SymbolRecordRuleDefinitions.h.

References FIELD_RULE_BITMASK_IS_HIGH.

bool Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ContentServerRuleSet::IsLow ( const uint8_t fieldRules ) [inline, static]

Should the low be updated.

Parameters:
fieldRules the field rules.
Returns:
whether the low should be updated.

Definition at line 390 of file SymbolRecordRuleDefinitions.h.

References FIELD_RULE_BITMASK_IS_LOW.

bool Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ContentServerRuleSet::IsOpen ( const uint8_t fieldRules ) [inline, static]

Should the open be updated.

Parameters:
fieldRules the field rules.
Returns:
whether the open should be updated.

Definition at line 397 of file SymbolRecordRuleDefinitions.h.

References FIELD_RULE_BITMASK_IS_OPEN.

bool Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ContentServerRuleSet::ShouldApplyAddRule1 ( const uint8_t fieldRules ) [inline, static]

Should the add rules 1 be applied.

Parameters:
fieldRules the field rules.
Returns:
whether the add rules 1 should be applied.

Definition at line 404 of file SymbolRecordRuleDefinitions.h.

References FIELD_RULE_DO_NOT_APPLY_ADD_RULE_1.

bool Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ContentServerRuleSet::ShouldApplyAddRule2 ( const uint8_t fieldRules ) [inline, static]

Should the add rules 2 be applied.

Parameters:
fieldRules the field rules.
Returns:
whether the add rules 2 should be applied.

Definition at line 411 of file SymbolRecordRuleDefinitions.h.

References FIELD_RULE_DO_NOT_APPLY_ADD_RULE_2.

bool Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ContentServerRuleSet::ShouldApplyChangeRule ( const uint8_t fieldRules ) [inline, static]

Should the change rule be applied.

Parameters:
fieldRules the field rules.
Returns:
whether the trending should be applied.

Definition at line 425 of file SymbolRecordRuleDefinitions.h.

References FIELD_RULE_DO_NOT_APPLY_CHANGE_RULE.

bool Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ContentServerRuleSet::ShouldApplyTrending ( const uint8_t fieldRules ) [inline, static]

Should the trending be applied.

Parameters:
fieldRules the field rules.
Returns:
whether the trending should be applied.

Definition at line 418 of file SymbolRecordRuleDefinitions.h.

References FIELD_RULE_APPLY_TRENDING.

bool Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ContentServerRuleSet::ShouldUpdateField ( const uint8_t fieldRules ) [inline, static]

Should the field be updated.

Parameters:
fieldRules the field rules.
Returns:
whether the field should be updated.

Definition at line 376 of file SymbolRecordRuleDefinitions.h.

References FIELD_RULE_DO_NOT_UPDATE_FIELD.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/SymbolRecordRuleDefinitions.h
Generated on Wed Oct 8 14:02:08 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::TranslatorRuleSet

Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::TranslatorRuleSet Class Reference

Translator rule set. More...

#include <ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/SymbolRecordRuleDefinitions.h>

List of all members.

Public Types

enum {
FIELD_RULE_BIT_DO_NOT_UPDATE_FIELD, FIELD_RULE_BIT_DO_NOT_TEST_HIGH_LOW, FIELD_RULE_BIT_DO_NOT_TEST_OPEN, FIELD_RULE_BIT_DO_NOT_APPLY_ADD_RULE_1,
FIELD_RULE_BIT_DO_NOT_APPLY_ADD_RULE_2, FIELD_RULE_BIT_DO_NOT_APPLY_TRENDING, FIELD_RULE_BIT_DO_NOT_APPLY_CHANGE_RULE
}
Field rule bits. More...

Static Public Member Functions

static uint8_t | GetFieldRules (const bool shouldUpdateField, const bool shouldTestHighLow, const bool shouldTestOpen, const bool shouldApplyAddRule1, const bool shouldApplyAddRule2, const bool shouldApplyTrending, const bool shouldApplyChangeRule)
Get the field rules.
static bool | ShouldApplyAddRule1 (const uint8_t fieldRules)
Should the add rules 1 be applied.
static bool | ShouldApplyAddRule2 (const uint8_t fieldRules)
Should the add rules 2 be applied.
static bool | ShouldApplyChangeRule (const uint8_t fieldRules)
Should the change rule be applied.
static bool | ShouldApplyTrending (const uint8_t fieldRules)
Should the trending be applied.
static bool | ShouldTestHighLow (const uint8_t fieldRules)
Should the high/low be tested.
static bool | ShouldTestOpen (const uint8_t fieldRules)
Should the open be tested.
static bool | ShouldUpdateField (const uint8_t fieldRules)
Should the field be updated.

Static Public Attributes

static const uint8_t | FIELD_RULE_DO_NOT_APPLY_ADD_RULE_1 = (1 << ((sizeof(uint8_t) * CHAR_BIT) - (FIELD_RULE_BIT_DO_NOT_APPLY_ADD_RULE_1 + 1)))
The "do not apply add rules (1)" field rule.
static const uint8_t | FIELD_RULE_DO_NOT_APPLY_ADD_RULE_2 = (1 << ((sizeof(uint8_t) * CHAR_BIT) - (FIELD_RULE_BIT_DO_NOT_APPLY_ADD_RULE_2 + 1)))
The "do not apply add rules (2)" field rule.
static const uint8_t | FIELD_RULE_DO_NOT_APPLY_CHANGE_RULE = (1 << ((sizeof(uint8_t) * CHAR_BIT) - (FIELD_RULE_BIT_DO_NOT_APPLY_CHANGE_RULE + 1)))
The "do not apply change" field rule.
static const uint8_t | FIELD_RULE_DO_NOT_APPLY_TRENDING = (1 << ((sizeof(uint8_t) * CHAR_BIT) - (FIELD_RULE_BIT_DO_NOT_APPLY_TRENDING + 1)))
The "do not apply trending" field rule.
static const uint8_t | FIELD_RULE_DO_NOT_TEST_HIGH_LOW = (1 << ((sizeof(uint8_t) * CHAR_BIT) - (FIELD_RULE_BIT_DO_NOT_TEST_HIGH_LOW + 1)))
The "do not test high/low" field rule.
static const uint8_t | FIELD_RULE_DO_NOT_TEST_OPEN = (1 << ((sizeof(uint8_t) * CHAR_BIT) - (FIELD_RULE_BIT_DO_NOT_TEST_OPEN + 1)))
The "do not test open" field rule.
static const uint8_t | FIELD_RULE_DO_NOT_UPDATE_FIELD = (1 << ((sizeof(uint8_t) * CHAR_BIT) - (FIELD_RULE_BIT_DO_NOT_UPDATE_FIELD + 1)))
The "do not update field" field rule.

Detailed Description

Translator rule set.

Definition at line 48 of file SymbolRecordRuleDefinitions.h.

Member Enumeration Documentation

anonymous enum

Field rule bits.

Enumerator:
FIELD_RULE_BIT_DO_NOT_UPDATE_FIELD | The "do not update field" field rule bit.
FIELD_RULE_BIT_DO_NOT_TEST_HIGH_LOW | The "do not test high/low" field rule bit.
FIELD_RULE_BIT_DO_NOT_TEST_OPEN | The "do not test open" field rule bit.
FIELD_RULE_BIT_DO_NOT_APPLY_ADD_RULE_1 | The "do not apply add rules (1)" field rule bit.
FIELD_RULE_BIT_DO_NOT_APPLY_ADD_RULE_2 | The "do not apply add rules (2)" field rule bit.
FIELD_RULE_BIT_DO_NOT_APPLY_TRENDING | The "do not apply trending" field rule bit.
FIELD_RULE_BIT_DO_NOT_APPLY_CHANGE_RULE | The "do not apply change" field rule bit.

Definition at line 54 of file SymbolRecordRuleDefinitions.h.

Member Function Documentation

uint8_t Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::TranslatorRuleSet::GetFieldRules | ( | const bool | shouldUpdateField,
 |  | const bool | shouldTestHighLow,
 |  | const bool | shouldTestOpen,
 |  | const bool | shouldApplyAddRule1,
 |  | const bool | shouldApplyAddRule2,
 |  | const bool | shouldApplyTrending,
 |  | const bool | shouldApplyChangeRule |
 | ) |  |  | [inline, static]

Get the field rules.

Parameters:
shouldUpdateField | whether the field should be updated.
shouldTestHighLow | whether the high/low should be tested.
shouldTestOpen | whether the open should be tested.
shouldApplyAddRule1 | whether the add rules 1 should be applied.
shouldApplyAddRule2 | whether the add rules 2 should be applied.
shouldApplyTrending | whether the trending should be applied.
shouldApplyChangeRule | whether the change rule should be applied.
Returns:
the rules.

Definition at line 312 of file SymbolRecordRuleDefinitions.h.

References FIELD_RULE_DO_NOT_APPLY_ADD_RULE_1, FIELD_RULE_DO_NOT_APPLY_ADD_RULE_2, FIELD_RULE_DO_NOT_APPLY_CHANGE_RULE, FIELD_RULE_DO_NOT_APPLY_TRENDING, FIELD_RULE_DO_NOT_TEST_HIGH_LOW, FIELD_RULE_DO_NOT_TEST_OPEN, and FIELD_RULE_DO_NOT_UPDATE_FIELD.

bool Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::TranslatorRuleSet::ShouldApplyAddRule1 ( const uint8_t fieldRules ) [inline, static]

Should the add rules 1 be applied.

Parameters:
fieldRules the field rules.
Returns:
whether the add rules 1 should be applied.

Definition at line 340 of file SymbolRecordRuleDefinitions.h.

References FIELD_RULE_DO_NOT_APPLY_ADD_RULE_1.

bool Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::TranslatorRuleSet::ShouldApplyAddRule2 ( const uint8_t fieldRules ) [inline, static]

Should the add rules 2 be applied.

Parameters:
fieldRules the field rules.
Returns:
whether the add rules 2 should be applied.

Definition at line 347 of file SymbolRecordRuleDefinitions.h.

References FIELD_RULE_DO_NOT_APPLY_ADD_RULE_2.

bool Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::TranslatorRuleSet::ShouldApplyChangeRule ( const uint8_t fieldRules ) [inline, static]

Should the change rule be applied.

Parameters:
fieldRules the field rules.
Returns:
whether the change rule should be applied.

Definition at line 361 of file SymbolRecordRuleDefinitions.h.

References FIELD_RULE_DO_NOT_APPLY_CHANGE_RULE.

bool Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::TranslatorRuleSet::ShouldApplyTrending ( const uint8_t fieldRules ) [inline, static]

Should the trending be applied.

Parameters:
fieldRules the field rules.
Returns:
whether the trending should be applied.

Definition at line 354 of file SymbolRecordRuleDefinitions.h.

References FIELD_RULE_DO_NOT_APPLY_TRENDING.

bool Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::TranslatorRuleSet::ShouldTestHighLow ( const uint8_t fieldRules ) [inline, static]

Should the high/low be tested.

Parameters:
fieldRules the field rules.
Returns:
whether the high/low should be tested.

Definition at line 326 of file SymbolRecordRuleDefinitions.h.

References FIELD_RULE_DO_NOT_TEST_HIGH_LOW.

bool Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::TranslatorRuleSet::ShouldTestOpen ( const uint8_t fieldRules ) [inline, static]

Should the open be tested.

Parameters:
fieldRules the field rules.
Returns:
whether the open should be tested.

Definition at line 333 of file SymbolRecordRuleDefinitions.h.

References FIELD_RULE_DO_NOT_TEST_OPEN.

bool Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::TranslatorRuleSet::ShouldUpdateField ( const uint8_t fieldRules ) [inline, static]

Should the field be updated.

Parameters:
fieldRules the field rules.
Returns:
whether the field should be updated.

Definition at line 319 of file SymbolRecordRuleDefinitions.h.

References FIELD_RULE_DO_NOT_UPDATE_FIELD.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/SymbolRecordRuleDefinitions.h
Generated on Wed Oct 8 14:02:08 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::TableTemplate

Activ::ContentPlatform::Feed::TableTemplate Class Reference

Table template class. More...

#include <ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/TableTemplate.h>

Inheritance diagram for Activ::ContentPlatform::Feed::TableTemplate:

Activ::ContentPlatform::Feed::TableTemplateAddition

List of all members.

Public Types

typedef std::vector
< FieldSpecification > 		FieldSpecificationList
The field specification list type definition.

Public Member Functions

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
StatusCode 		ApplyTableTemplateAddition (const TableTemplate &tableTemplateAddition)
Apply table template additional values.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
ConstCopyOnResetIterator 		BeginCopyOnReset () const
Get an iterator to the first copy on reset in the table template.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
ConstFieldIterator 		BeginField () const
Get an iterator to the first field in the table template.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
ConstIndexIterator 		BeginIndex () const
Get an iterator to the first index in the table template.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
ConstRuleIterator 		BeginRule () const
Get an iterator to the first rule in the table template.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
ConstUndefineOnResetIterator 		BeginUndefineOnReset () const
Get an iterator to the first undefine on reset in the table template.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
void 		Clear ()
Clear the contents.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
std::string 		CopyOnResetToString () const
Copy on reset to string.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
ConstCopyOnResetIterator 		EndCopyOnReset () const
Get an iterator that points to beyond the last copy on reset in the table template.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
ConstFieldIterator 		EndField () const
Get an iterator that points to beyond the last field in the table template.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
ConstIndexIterator 		EndIndex () const
Get an iterator that points to beyond the last index in the table template.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
ConstRuleIterator 		EndRule () const
Get an iterator that points to beyond the last rule in the table template.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
ConstUndefineOnResetIterator 		EndUndefineOnReset () const
Get an iterator that points to beyond the last undefine on reset in the table template.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
std::string 		FieldsToString () const
Fields to string.
uint8_t | GetAmfRecordSize () const
Get amf record size.
uint8_t | GetAmfTableId () const
Get amf table id.
size_t | GetCacheSize () const
Get the cache size.
const std::string & | GetCodeIdentifier () const
Get the table code identifier.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
std::string 		GetError () const
Get the error string.
const Field * | GetField (const FieldId fieldId) const
Get a field.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
StatusCode 		GetField (const FieldId fieldId, const Field *&pField) const
Get a field.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
StatusCode 		GetFirstField (const Field *&pField) const
Get the first field.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
StatusCode 		GetFirstIndex (const Index *&pIndex) const
Get the first index.
TableId | GetId () const
Get the table id.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
StatusCode 		GetIndex (const IndexNumber indexNumber, const Index *&pIndex) const
Get an index.
size_t | GetInitialMaxRecords () const
Get initial maximum records.
const std::string & | GetName () const
Get the table name.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
StatusCode 		GetNextField (const Field *&pField) const
Get the next field.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
StatusCode 		GetNextIndex (const Index *&pIndex) const
Get the next index.
TableNo | GetNumber () const
Get the table number.
size_t | GetNumberOfGrowRecords () const
Get the number of grow records.
size_t | GetNumberOfPurgeDays () const
Get the number of purge days.
TableResetType | GetResetType () const
Get reset type.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
StatusCode 		GetRule (const FieldId fieldId, const Rule *&pRule) const
Get a rule.
TableType | GetType () const
Get the table type.
TableVersion | GetVersion () const
Get the table version.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
std::string 		IndexesToString () const
Indexes to string.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
StatusCode 		Initialize (const UniversalFieldList &universalFieldList, Application &application, const ServiceHandle &serviceHandle, const Database::Record &record, IHeap *const pHeap=0, const std::string &componentId=Component::defaultComponentId)
Initialize.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
StatusCode 		Initialize (const UniversalFieldList &universalFieldList, const std::string &xmlFileName)
Initialize.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
StatusCode 		Initialize (const UniversalFieldList &universalFieldList, const Specification &specification)
Initialize.
bool | IsAmfTable () const
Is amf table?
bool | IsContributed () const
Is contributed.
bool | IsDiskBased () const
Is disk based.
bool | IsLatestVersion () const
Is latest version.
bool | IsPurged () const
Is purged.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
bool 		operator!= (const TableTemplate &rhs) const
Inequality operator.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
bool 		operator== (const TableTemplate &rhs) const
Equality operator.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
std::string 		RulesToString () const
Rules to string.
void | SetLatestVersion (const bool isLatestVersion)
Set the latest version bool.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API | TableTemplate (const UniversalFieldList &universalFieldList, Application &application, const ServiceHandle &serviceHandle, const Database::Record &record, IHeap *const pHeap=0)
Constructor.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API | TableTemplate (const UniversalFieldList &universalFieldList, const std::string &xmlFileName)
Constructor.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API | TableTemplate (const UniversalFieldList &universalFieldList, const Specification &specification)
Constructor.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API | TableTemplate ()
Default constructor.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
std::string 		ToString (bool shouldDisplayFields=false, bool shouldDisplayIndices=false, bool shouldDisplayRules=false, bool shouldDisplayCopyOnReset=false, bool shouldDisplayUndefineOnReset=false) const
Convert the Table Template List to a C-style string.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
std::string 		UndefineOnResetToString () const
Undefine on reset to string.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API | ~TableTemplate ()
Destructor.

Static Public Member Functions

static TableId | GetId (const TableNo number, const TableVersion version)
Get the table id.
static const size_t | GetMaxNumber ()
Get the max table number possible.
static const size_t | GetMaxVersion ()
Get the max version number possible.
static TableNo | GetNumber (const TableId id)
Get the table number.
static
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
std::string 		GetUiHeading ()
Get the user interface heading.
static TableVersion | GetVersion (const TableId id)
Get the table version.
static bool | IsContributed (const TableId id)
Is contributed.
static bool | IsTableTemplate (const std::string &xmlFileName)
Checks if a file is a table template.

Friends

class | TableTemplateAddition

Classes

class | ConstCopyOnResetIterator
Const CopyOnReset iterator class. More...
class | ConstFieldIterator
Const field iterator class. More...
class | ConstIndexIterator
Const index iterator class. More...
class | ConstRuleIterator
Const rule iterator class. More...
class | ConstUndefineOnResetIterator
Const UndefineOnReset iterator class. More...
class | FieldSpecification
Field specification class. More...
class | Specification
Specification class. More...

Detailed Description

Table template class.

Definition at line 39 of file TableTemplate.h.

Constructor & Destructor Documentation

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API Activ::ContentPlatform::Feed::TableTemplate::TableTemplate | ( | const UniversalFieldList & | universalFieldList,
 |  | const Specification & | specification
 | ) |  |

Constructor.

Creates a table template from the given universal field list and the specification.

Parameters:
universalFieldList | the universal field list to build the table template with.
specification | the object specification.
Exceptions:
StatusCodeException

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API Activ::ContentPlatform::Feed::TableTemplate::TableTemplate | ( | const UniversalFieldList & | universalFieldList,
 |  | const std::string & | xmlFileName
 | ) |  |

Constructor.

Creates a table template from the universal field list and the xml file name.

Parameters:
universalFieldList | the universal field list to build the table template with.
xmlFileName | the file name of the xml table template.
Exceptions:
TableTemplateException

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API Activ::ContentPlatform::Feed::TableTemplate::TableTemplate | ( | const UniversalFieldList & | universalFieldList,
 |  | Application & | application,
 |  | const ServiceHandle & | serviceHandle,
 |  | const Database::Record & | record,
 |  | IHeap *const | pHeap = 0
 | ) |  |

Constructor.

Creates a table template from the universal field list, the service id to connect to using table service and a record containing the table details.

Parameters:
universalFieldList | the universal field list to build the table template with.
application | the application.
serviceHandle | the service handle to connect to using table service.
record | the table template list record that contains the table details.
pHeap | the heap to use for table client. Default implies the system heap.
Exceptions:
TableTemplateException

Member Function Documentation

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::TableTemplate::ApplyTableTemplateAddition ( const TableTemplate & tableTemplateAddition )

Apply table template additional values.

Parameters:
tableTemplateAddition the table template addition to apply to the table template.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_FAILURE

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API ConstCopyOnResetIterator Activ::ContentPlatform::Feed::TableTemplate::BeginCopyOnReset ( ) const

Get an iterator to the first copy on reset in the table template.

Returns:
an iterator object.

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API ConstFieldIterator Activ::ContentPlatform::Feed::TableTemplate::BeginField ( ) const

Get an iterator to the first field in the table template.

Returns:
an iterator object.

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API ConstIndexIterator Activ::ContentPlatform::Feed::TableTemplate::BeginIndex ( ) const

Get an iterator to the first index in the table template.

Returns:
an iterator object.

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API ConstRuleIterator Activ::ContentPlatform::Feed::TableTemplate::BeginRule ( ) const

Get an iterator to the first rule in the table template.

Returns:
an iterator object.

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API ConstUndefineOnResetIterator Activ::ContentPlatform::Feed::TableTemplate::BeginUndefineOnReset ( ) const

Get an iterator to the first undefine on reset in the table template.

Returns:
an iterator object.

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API std::string Activ::ContentPlatform::Feed::TableTemplate::CopyOnResetToString ( ) const

Copy on reset to string.

Returns:
the copy on reset as a string.

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API ConstCopyOnResetIterator Activ::ContentPlatform::Feed::TableTemplate::EndCopyOnReset ( ) const

Get an iterator that points to beyond the last copy on reset in the table template.

Returns:
an iterator object.

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API ConstFieldIterator Activ::ContentPlatform::Feed::TableTemplate::EndField ( ) const

Get an iterator that points to beyond the last field in the table template.

Returns:
an iterator object.

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API ConstIndexIterator Activ::ContentPlatform::Feed::TableTemplate::EndIndex ( ) const

Get an iterator that points to beyond the last index in the table template.

Returns:
an iterator object.

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API ConstRuleIterator Activ::ContentPlatform::Feed::TableTemplate::EndRule ( ) const

Get an iterator that points to beyond the last rule in the table template.

Returns:
an iterator object.

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API ConstUndefineOnResetIterator Activ::ContentPlatform::Feed::TableTemplate::EndUndefineOnReset ( ) const

Get an iterator that points to beyond the last undefine on reset in the table template.

Returns:
an iterator object.

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API std::string Activ::ContentPlatform::Feed::TableTemplate::FieldsToString ( ) const

Fields to string.

Returns:
the fields as a string.

uint8_t Activ::ContentPlatform::Feed::TableTemplate::GetAmfRecordSize ( ) const [inline]

Get amf record size.

Returns:
the amf format record size.

Definition at line 1364 of file TableTemplate.h.

uint8_t Activ::ContentPlatform::Feed::TableTemplate::GetAmfTableId ( ) const [inline]

Get amf table id.

Returns:
the amf format table id.

Definition at line 1357 of file TableTemplate.h.

size_t Activ::ContentPlatform::Feed::TableTemplate::GetCacheSize ( ) const [inline]

Get the cache size.

Returns:
the cache size.

Definition at line 1413 of file TableTemplate.h.

const std::string & Activ::ContentPlatform::Feed::TableTemplate::GetCodeIdentifier ( ) const [inline]

Get the table code identifier.

Returns:
the table code identifier.

Definition at line 1336 of file TableTemplate.h.

std::string Activ::ContentPlatform::Feed::TableTemplate::GetError ( ) const [inline]

Get the error string.

Returns:
the error as a string.

Definition at line 1427 of file TableTemplate.h.

const Field * Activ::ContentPlatform::Feed::TableTemplate::GetField ( const FieldId fieldId ) const [inline]

Get a field.

Parameters:
fieldId the field id.
Returns:
pointer to the field.
Exceptions:
StatusCodeException

Definition at line 1441 of file TableTemplate.h.

References ACTIV_THROW_RESULT_IF, and GetField().

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::TableTemplate::GetField | ( | const FieldId | fieldId,
 |  | const Field *& | pField |
 | ) |  |  | const

Get a field.

Parameters:
fieldId | the field id.
pField | pointer to the field.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_FOUND

Referenced by GetField().

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::TableTemplate::GetFirstField ( const Field *& pField ) const

Get the first field.

Parameters:
pField a pointer to the field.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_FOUND
...

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::TableTemplate::GetFirstIndex ( const Index *& pIndex ) const

Get the first index.

Parameters:
pIndex set to point to the first index.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_FOUND
...

TableId Activ::ContentPlatform::Feed::TableTemplate::GetId | ( | const TableNo | number,
 |  | const TableVersion | version |
 | ) |  |  | [inline, static]

Get the table id.

Parameters:
number | the table number.
version | the table version.
Returns:
the table id.

Definition at line 1478 of file TableTemplate.h.

TableId Activ::ContentPlatform::Feed::TableTemplate::GetId ( ) const [inline]

Get the table id.

Returns:
the table id.

Definition at line 1301 of file TableTemplate.h.

Referenced by GetNumber(), GetVersion(), IsContributed(), Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator::TableTemplateIdToString(), and Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator::TableTemplateIdToString().

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::TableTemplate::GetIndex | ( | const IndexNumber | indexNumber,
 |  | const Index *& | pIndex |
 | ) |  |  | const

Get an index.

Parameters:
indexNumber | the index number.
pIndex | a pointer to the index.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_FOUND
...

size_t Activ::ContentPlatform::Feed::TableTemplate::GetInitialMaxRecords ( ) const [inline]

Get initial maximum records.

Returns:
the initial maximum records.

Definition at line 1371 of file TableTemplate.h.

const size_t Activ::ContentPlatform::Feed::TableTemplate::GetMaxNumber ( ) [inline, static]

Get the max table number possible.

Return values:
string the user interface heading

Definition at line 1464 of file TableTemplate.h.

const size_t Activ::ContentPlatform::Feed::TableTemplate::GetMaxVersion ( ) [inline, static]

Get the max version number possible.

Return values:
string the user interface heading

Definition at line 1471 of file TableTemplate.h.

const std::string & Activ::ContentPlatform::Feed::TableTemplate::GetName ( ) const [inline]

Get the table name.

Returns:
the table name.

Definition at line 1329 of file TableTemplate.h.

Referenced by Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator::TableTemplateNameToString(), and Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator::TableTemplateNameToString().

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::TableTemplate::GetNextField ( const Field *& pField ) const

Get the next field.

Parameters:
pField a pointer to the field.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_FOUND
STATUS_CODE_INVALID_PARAMETER
...

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::TableTemplate::GetNextIndex ( const Index *& pIndex ) const

Get the next index.

Parameters:
pIndex set to point to the next index.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_FOUND
STATUS_CODE_INVALID_PARAMETER
...

TableNo Activ::ContentPlatform::Feed::TableTemplate::GetNumber ( const TableId id ) [inline, static]

Get the table number.

Parameters:
id the table id.
Returns:
the table number.

Definition at line 1485 of file TableTemplate.h.

TableNo Activ::ContentPlatform::Feed::TableTemplate::GetNumber ( ) const [inline]

Get the table number.

Returns:
the table number.

Definition at line 1308 of file TableTemplate.h.

References GetId().

Referenced by IsContributed().

size_t Activ::ContentPlatform::Feed::TableTemplate::GetNumberOfGrowRecords ( ) const [inline]

Get the number of grow records.

Returns:
the number of grow records.

Definition at line 1378 of file TableTemplate.h.

size_t Activ::ContentPlatform::Feed::TableTemplate::GetNumberOfPurgeDays ( ) const [inline]

Get the number of purge days.

Returns:
the number of purge days.

Definition at line 1392 of file TableTemplate.h.

TableResetType Activ::ContentPlatform::Feed::TableTemplate::GetResetType ( ) const [inline]

Get reset type.

Returns:
the reset type.

Definition at line 1399 of file TableTemplate.h.

StatusCode Activ::ContentPlatform::Feed::TableTemplate::GetRule | ( | const FieldId | fieldId,
 |  | const Rule *& | pRule |
 | ) |  |  | const [inline]

Get a rule.

Parameters:
fieldId | the field id.
pRule | pointer to the rule.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_FOUND

Definition at line 1450 of file TableTemplate.h.

TableType Activ::ContentPlatform::Feed::TableTemplate::GetType ( ) const [inline]

Get the table type.

Returns:
the table type.

Definition at line 1343 of file TableTemplate.h.

static ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API std::string Activ::ContentPlatform::Feed::TableTemplate::GetUiHeading ( ) [static]

Get the user interface heading.

Return values:
string the user interface heading

TableVersion Activ::ContentPlatform::Feed::TableTemplate::GetVersion ( const TableId id ) [inline, static]

Get the table version.

Parameters:
id the table id.
Returns:
the table version.

Definition at line 1492 of file TableTemplate.h.

TableVersion Activ::ContentPlatform::Feed::TableTemplate::GetVersion ( ) const [inline]

Get the table version.

Returns:
the table version.

Definition at line 1315 of file TableTemplate.h.

References GetId().

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API std::string Activ::ContentPlatform::Feed::TableTemplate::IndexesToString ( ) const

Indexes to string.

Returns:
the indexes as a string.

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::TableTemplate::Initialize | ( | const UniversalFieldList & | universalFieldList,
 |  | Application & | application,
 |  | const ServiceHandle & | serviceHandle,
 |  | const Database::Record & | record,
 |  | IHeap *const | pHeap = 0,
 |  | const std::string & | componentId = Component::defaultComponentId
 | ) |  |

Initialize.

Initializes the table template from the universal field list, the service id to connect to using table service and a record containing the table details.

Parameters:
universalFieldList | the universal field list to build the table template with.
application | the application.
serviceHandle | the service handle to connect to using table service.
record | the table template list record that contains the table details.
pHeap | the heap to use for table client. Default implies the system heap.
componentId | the component id.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_FAILURE

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::TableTemplate::Initialize | ( | const UniversalFieldList & | universalFieldList,
 |  | const std::string & | xmlFileName
 | ) |  |

Initialize.

Initializes the table template from the universal field list and the xml file name.

Parameters:
universalFieldList | the universal field list to build the table template with.
xmlFileName | the file name of the xml for the table template.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_FAILURE

Reimplemented in Activ::ContentPlatform::Feed::TableTemplateAddition.

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::TableTemplate::Initialize | ( | const UniversalFieldList & | universalFieldList,
 |  | const Specification & | specification
 | ) |  |

Initialize.

Initializes the table template list from the default header file definitions.

Parameters:
universalFieldList | the universal field list to build the table template with.
specification | the object specification.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER

bool Activ::ContentPlatform::Feed::TableTemplate::IsAmfTable ( ) const [inline]

Is amf table?

Returns:
whether this table is support in the amf format.

Definition at line 1350 of file TableTemplate.h.

bool Activ::ContentPlatform::Feed::TableTemplate::IsContributed ( const TableId id ) [inline, static]

Is contributed.

Parameters:
id the table id.
Returns:
whether the table number is contributed.

Definition at line 1499 of file TableTemplate.h.

References GetNumber().

bool Activ::ContentPlatform::Feed::TableTemplate::IsContributed ( ) const [inline]

Is contributed.

Returns:
whether the table template is contributed.

Definition at line 1322 of file TableTemplate.h.

References GetId().

bool Activ::ContentPlatform::Feed::TableTemplate::IsDiskBased ( ) const [inline]

Is disk based.

Returns:
whether the table template is disk based.

Definition at line 1406 of file TableTemplate.h.

bool Activ::ContentPlatform::Feed::TableTemplate::IsLatestVersion ( ) const [inline]

Is latest version.

Returns:
whether this version of the table template is the latest of those with matching table number.

Definition at line 1420 of file TableTemplate.h.

bool Activ::ContentPlatform::Feed::TableTemplate::IsPurged ( ) const [inline]

Is purged.

Returns:
whether the table template is purged.

Definition at line 1385 of file TableTemplate.h.

static bool Activ::ContentPlatform::Feed::TableTemplate::IsTableTemplate ( const std::string & xmlFileName ) [static]

Checks if a file is a table template.

Parameters:
xmlFileName the xml file name to check.
Exceptions:
ActivFeedTableTemplateHandlerException.

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API bool Activ::ContentPlatform::Feed::TableTemplate::operator!= ( const TableTemplate & rhs ) const

Inequality operator.

Parameters:
rhs the object to test against.
Returns:
whether the two objects are not equal.

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API bool Activ::ContentPlatform::Feed::TableTemplate::operator== ( const TableTemplate & rhs ) const

Equality operator.

Parameters:
rhs the object to test against.
Returns:
whether the two objects are equal.

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API std::string Activ::ContentPlatform::Feed::TableTemplate::RulesToString ( ) const

Rules to string.

Returns:
the rules as a string.

void Activ::ContentPlatform::Feed::TableTemplate::SetLatestVersion ( const bool isLatestVersion ) [inline]

Set the latest version bool.

Parameters:
isLatestVersion the is Latest Version boolean.

Definition at line 1434 of file TableTemplate.h.

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API std::string Activ::ContentPlatform::Feed::TableTemplate::ToString | ( | bool | shouldDisplayFields = false,
 |  | bool | shouldDisplayIndices = false,
 |  | bool | shouldDisplayRules = false,
 |  | bool | shouldDisplayCopyOnReset = false,
 |  | bool | shouldDisplayUndefineOnReset = false |
 | ) |  |  | const

Convert the Table Template List to a C-style string.

Parameters:
shouldDisplayFields | whether the fields should be displayed.
shouldDisplayIndices | whether the indices should be displayed.
shouldDisplayRules | whether the rules should be displayed.
shouldDisplayCopyOnReset | whether the fields that are copied at reset should be displayed.
shouldDisplayUndefineOnReset | whether the fields that are undefined at reset should be displayed.
Returns:
the specification as a string.

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API std::string Activ::ContentPlatform::Feed::TableTemplate::UndefineOnResetToString ( ) const

Undefine on reset to string.

Returns:
the undefine on reset as a string.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/TableTemplate.h
Generated on Wed Oct 8 14:02:09 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::TableTemplate::ConstCopyOnResetIterator

Activ::ContentPlatform::Feed::TableTemplate::ConstCopyOnResetIterator Class Reference

Const CopyOnReset iterator class. More...

#include <ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/TableTemplate.h>

List of all members.

Public Member Functions

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API | ConstCopyOnResetIterator ()
Default constructor.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
const CopyOnReset & 		operator * () const
Dereference operator.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
bool 		operator!= (const ConstCopyOnResetIterator &rhs) const
Inequality operator.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
const ConstCopyOnResetIterator 		operator++ (int)
Postfix increment operator.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
ConstCopyOnResetIterator & 		operator++ ()
Prefix increment operator.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
const CopyOnReset * 		operator-> () const
Member access operator.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
bool 		operator== (const ConstCopyOnResetIterator &rhs) const
Equality operator.

Friends

class | TableTemplate

Detailed Description

Const CopyOnReset iterator class.

Definition at line 353 of file TableTemplate.h.

Member Function Documentation

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API const CopyOnReset& Activ::ContentPlatform::Feed::TableTemplate::ConstCopyOnResetIterator::operator * ( ) const

Dereference operator.

Returns:
Reference to the current FieldId.

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API bool Activ::ContentPlatform::Feed::TableTemplate::ConstCopyOnResetIterator::operator!= ( const ConstCopyOnResetIterator & rhs ) const

Inequality operator.

Parameters:
rhs the object to test against.
Returns:
whether the two objects are not equal.

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API const ConstCopyOnResetIterator Activ::ContentPlatform::Feed::TableTemplate::ConstCopyOnResetIterator::operator++ ( int )

Postfix increment operator.

Returns:
a copy of the original object.

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API ConstCopyOnResetIterator& Activ::ContentPlatform::Feed::TableTemplate::ConstCopyOnResetIterator::operator++ ( )

Prefix increment operator.

Returns:
a reference to the updated object.

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API const CopyOnReset* Activ::ContentPlatform::Feed::TableTemplate::ConstCopyOnResetIterator::operator-> ( ) const

Member access operator.

Returns:
Pointer to the current FieldId.

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API bool Activ::ContentPlatform::Feed::TableTemplate::ConstCopyOnResetIterator::operator== ( const ConstCopyOnResetIterator & rhs ) const

Equality operator.

Parameters:
rhs the object to test against.
Returns:
whether the two objects are equal.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/TableTemplate.h
Generated on Wed Oct 8 14:02:09 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::TableTemplate::ConstFieldIterator

Activ::ContentPlatform::Feed::TableTemplate::ConstFieldIterator Class Reference

Const field iterator class. More...

#include <ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/TableTemplate.h>

List of all members.

Public Member Functions

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API | ConstFieldIterator ()
Default constructor.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
const Field & 		GetField () const
Get the field.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
FieldId 		GetFieldId () const
Get the field id.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
const Field & 		operator * () const
Dereference operator.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
bool 		operator!= (const ConstFieldIterator &rhs) const
Inequality operator.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
const ConstFieldIterator 		operator++ (int)
Postfix increment operator.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
ConstFieldIterator & 		operator++ ()
Prefix increment operator.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
const Field * 		operator-> () const
Member access operator.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
bool 		operator== (const ConstFieldIterator &rhs) const
Equality operator.

Friends

class | TableTemplate

Detailed Description

Const field iterator class.

Definition at line 111 of file TableTemplate.h.

Member Function Documentation

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API const Field& Activ::ContentPlatform::Feed::TableTemplate::ConstFieldIterator::GetField ( ) const

Get the field.

Returns:
the field.

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API FieldId Activ::ContentPlatform::Feed::TableTemplate::ConstFieldIterator::GetFieldId ( ) const

Get the field id.

Returns:
the field id.

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API const Field& Activ::ContentPlatform::Feed::TableTemplate::ConstFieldIterator::operator * ( ) const

Dereference operator.

Returns:
Reference to the current field.

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API bool Activ::ContentPlatform::Feed::TableTemplate::ConstFieldIterator::operator!= ( const ConstFieldIterator & rhs ) const

Inequality operator.

Parameters:
rhs the object to test against.
Returns:
whether the two objects are not equal.

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API const ConstFieldIterator Activ::ContentPlatform::Feed::TableTemplate::ConstFieldIterator::operator++ ( int )

Postfix increment operator.

Returns:
a copy of the original object.

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API ConstFieldIterator& Activ::ContentPlatform::Feed::TableTemplate::ConstFieldIterator::operator++ ( )

Prefix increment operator.

Returns:
a reference to the updated object.

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API const Field* Activ::ContentPlatform::Feed::TableTemplate::ConstFieldIterator::operator-> ( ) const

Member access operator.

Returns:
Pointer to the current field.

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API bool Activ::ContentPlatform::Feed::TableTemplate::ConstFieldIterator::operator== ( const ConstFieldIterator & rhs ) const

Equality operator.

Parameters:
rhs the object to test against.
Returns:
whether the two objects are equal.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/TableTemplate.h
Generated on Wed Oct 8 14:02:09 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::TableTemplate::ConstIndexIterator

Activ::ContentPlatform::Feed::TableTemplate::ConstIndexIterator Class Reference

Const index iterator class. More...

#include <ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/TableTemplate.h>

List of all members.

Public Member Functions

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API | ConstIndexIterator ()
Default constructor.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
const Index & 		operator * () const
Dereference operator.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
bool 		operator!= (const ConstIndexIterator &rhs) const
Inequality operator.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
const ConstIndexIterator 		operator++ (int)
Postfix increment operator.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
ConstIndexIterator & 		operator++ ()
Prefix increment operator.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
const Index * 		operator-> () const
Member access operator.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
bool 		operator== (const ConstIndexIterator &rhs) const
Equality operator.

Friends

class | TableTemplate

Detailed Description

Const index iterator class.

Definition at line 199 of file TableTemplate.h.

Member Function Documentation

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API const Index& Activ::ContentPlatform::Feed::TableTemplate::ConstIndexIterator::operator * ( ) const

Dereference operator.

Returns:
Reference to the current index.

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API bool Activ::ContentPlatform::Feed::TableTemplate::ConstIndexIterator::operator!= ( const ConstIndexIterator & rhs ) const

Inequality operator.

Parameters:
rhs the object to test against.
Returns:
whether the two objects are not equal.

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API const ConstIndexIterator Activ::ContentPlatform::Feed::TableTemplate::ConstIndexIterator::operator++ ( int )

Postfix increment operator.

Returns:
a copy of the original object.

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API ConstIndexIterator& Activ::ContentPlatform::Feed::TableTemplate::ConstIndexIterator::operator++ ( )

Prefix increment operator.

Returns:
a reference to the updated object.

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API const Index* Activ::ContentPlatform::Feed::TableTemplate::ConstIndexIterator::operator-> ( ) const

Member access operator.

Returns:
Pointer to the current index.

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API bool Activ::ContentPlatform::Feed::TableTemplate::ConstIndexIterator::operator== ( const ConstIndexIterator & rhs ) const

Equality operator.

Parameters:
rhs the object to test against.
Returns:
whether the two objects are equal.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/TableTemplate.h
Generated on Wed Oct 8 14:02:09 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::TableTemplate::ConstRuleIterator

Activ::ContentPlatform::Feed::TableTemplate::ConstRuleIterator Class Reference

Const rule iterator class. More...

#include <ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/TableTemplate.h>

List of all members.

Public Member Functions

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API | ConstRuleIterator ()
Default constructor.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
FieldId 		GetFieldId () const
Get the field id.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
const Rule & 		GetRule () const
Get the rule.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
const Rule & 		operator * () const
Dereference operator.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
bool 		operator!= (const ConstRuleIterator &rhs) const
Inequality operator.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
const ConstRuleIterator 		operator++ (int)
Postfix increment operator.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
ConstRuleIterator & 		operator++ ()
Prefix increment operator.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
const Rule * 		operator-> () const
Member access operator.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
bool 		operator== (const ConstRuleIterator &rhs) const
Equality operator.

Friends

class | TableTemplate

Detailed Description

Const rule iterator class.

Definition at line 269 of file TableTemplate.h.

Member Function Documentation

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API FieldId Activ::ContentPlatform::Feed::TableTemplate::ConstRuleIterator::GetFieldId ( ) const

Get the field id.

Returns:
the field id.

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API const Rule& Activ::ContentPlatform::Feed::TableTemplate::ConstRuleIterator::GetRule ( ) const

Get the rule.

Returns:
the rule.

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API const Rule& Activ::ContentPlatform::Feed::TableTemplate::ConstRuleIterator::operator * ( ) const

Dereference operator.

Returns:
Reference to the current index.

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API bool Activ::ContentPlatform::Feed::TableTemplate::ConstRuleIterator::operator!= ( const ConstRuleIterator & rhs ) const

Inequality operator.

Parameters:
rhs the object to test against.
Returns:
whether the two objects are not equal.

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API const ConstRuleIterator Activ::ContentPlatform::Feed::TableTemplate::ConstRuleIterator::operator++ ( int )

Postfix increment operator.

Returns:
a copy of the original object.

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API ConstRuleIterator& Activ::ContentPlatform::Feed::TableTemplate::ConstRuleIterator::operator++ ( )

Prefix increment operator.

Returns:
a reference to the updated object.

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API const Rule* Activ::ContentPlatform::Feed::TableTemplate::ConstRuleIterator::operator-> ( ) const

Member access operator.

Returns:
Pointer to the current index.

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API bool Activ::ContentPlatform::Feed::TableTemplate::ConstRuleIterator::operator== ( const ConstRuleIterator & rhs ) const

Equality operator.

Parameters:
rhs the object to test against.
Returns:
whether the two objects are equal.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/TableTemplate.h
Generated on Wed Oct 8 14:02:09 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::TableTemplate::ConstUndefineOnResetIterator

Activ::ContentPlatform::Feed::TableTemplate::ConstUndefineOnResetIterator Class Reference

Const UndefineOnReset iterator class. More...

#include <ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/TableTemplate.h>

List of all members.

Public Member Functions

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API | ConstUndefineOnResetIterator ()
Default constructor.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
const FieldId & 		operator * () const
Dereference operator.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
bool 		operator!= (const ConstUndefineOnResetIterator &rhs) const
Inequality operator.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
const
ConstUndefineOnResetIterator 		operator++ (int)
Postfix increment operator.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
ConstUndefineOnResetIterator & 		operator++ ()
Prefix increment operator.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
const FieldId * 		operator-> () const
Member access operator.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
bool 		operator== (const ConstUndefineOnResetIterator &rhs) const
Equality operator.

Friends

class | TableTemplate

Detailed Description

Const UndefineOnReset iterator class.

Definition at line 423 of file TableTemplate.h.

Member Function Documentation

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API const FieldId& Activ::ContentPlatform::Feed::TableTemplate::ConstUndefineOnResetIterator::operator * ( ) const

Dereference operator.

Returns:
Reference to the current FieldId.

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API bool Activ::ContentPlatform::Feed::TableTemplate::ConstUndefineOnResetIterator::operator!= ( const ConstUndefineOnResetIterator & rhs ) const

Inequality operator.

Parameters:
rhs the object to test against.
Returns:
whether the two objects are not equal.

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API const ConstUndefineOnResetIterator Activ::ContentPlatform::Feed::TableTemplate::ConstUndefineOnResetIterator::operator++ ( int )

Postfix increment operator.

Returns:
a copy of the original object.

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API ConstUndefineOnResetIterator& Activ::ContentPlatform::Feed::TableTemplate::ConstUndefineOnResetIterator::operator++ ( )

Prefix increment operator.

Returns:
a reference to the updated object.

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API const FieldId* Activ::ContentPlatform::Feed::TableTemplate::ConstUndefineOnResetIterator::operator-> ( ) const

Member access operator.

Returns:
Pointer to the current FieldId.

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API bool Activ::ContentPlatform::Feed::TableTemplate::ConstUndefineOnResetIterator::operator== ( const ConstUndefineOnResetIterator & rhs ) const

Equality operator.

Parameters:
rhs the object to test against.
Returns:
whether the two objects are equal.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/TableTemplate.h
Generated on Wed Oct 8 14:02:09 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::TableTemplate::FieldSpecification

Activ::ContentPlatform::Feed::TableTemplate::FieldSpecification Class Reference

Field specification class. More...

#include <ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/TableTemplate.h>

List of all members.

Public Member Functions

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API | FieldSpecification (const FieldId id, const size_t maxLength, const bool isAmfField=false, const uint8_t amfRowIndex=0, const uint8_t amfRowOffset=0, const uint8_t amfFieldIndex=0)
Constructor.

Public Attributes

uint8_t | m_amfFieldIndex
The field index in an amf message row.
uint8_t | m_amfRowIndex
The row index in an amf message.
uint8_t | m_amfRowOffset
The offset in an amf message row.
FieldId | m_id
The field id.
bool | m_isAmfField
Whether the field is in the amf message format.
size_t | m_maxLength
The maximum allowed field length.

Detailed Description

Field specification class.

This is used in construction of the field object.

Definition at line 47 of file TableTemplate.h.

Constructor & Destructor Documentation

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API Activ::ContentPlatform::Feed::TableTemplate::FieldSpecification::FieldSpecification | ( | const FieldId | id,
 |  | const size_t | maxLength,
 |  | const bool | isAmfField = false,
 |  | const uint8_t | amfRowIndex = 0,
 |  | const uint8_t | amfRowOffset = 0,
 |  | const uint8_t | amfFieldIndex = 0
 | ) |  |

Constructor.

Parameters:
id | the field id.
maxLength | the maximum allowed field length
isAmfField | whether the field is in the amf message format.
amfRowIndex | the row index in an amf message.
amfRowOffset | the offset in an amf message row.
amfFieldIndex | the field index in an amf message row.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/TableTemplate.h
Generated on Wed Oct 8 14:02:09 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::TableTemplate::Specification

Activ::ContentPlatform::Feed::TableTemplate::Specification Class Reference

Specification class. More...

#include <ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/TableTemplate.h>

List of all members.

Public Member Functions

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API | Specification (const TableId id, const std::string &name, const std::string &codeIdentifier, const TableType type, const bool isLatestVersion, const TableTemplate::FieldSpecificationList &fieldSpecificationList, const Index::IndexSpecificationList &indexSpecificationList, const bool isAmfTable=false, const uint8_t amfTableId=0, const uint8_t amfRecordSize=0)
Constructor.

Public Attributes

const uint8_t | m_amfRecordSize
Size of amf record in rows.
const uint8_t | m_amfTableId
Amf table id.
const std::string | m_codeIdentifier
The table code identifier.
const FieldSpecificationList | m_fieldSpecificationList
The field specification list.
const TableId | m_id
The table id.
const Index::IndexSpecificationList | m_indexSpecificationList
The index specification list.
const bool | m_isAmfTable
Whether table supports amf format.
const bool | m_isLatestVersion
Whether this is the latest version of the table template with matching table number.
const std::string | m_name
The table name.
const TableType | m_type
The table type.

Detailed Description

Specification class.

This is used in construction of the object.

Definition at line 77 of file TableTemplate.h.

Constructor & Destructor Documentation

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API Activ::ContentPlatform::Feed::TableTemplate::Specification::Specification | ( | const TableId | id,
 |  | const std::string & | name,
 |  | const std::string & | codeIdentifier,
 |  | const TableType | type,
 |  | const bool | isLatestVersion,
 |  | const TableTemplate::FieldSpecificationList & | fieldSpecificationList,
 |  | const Index::IndexSpecificationList & | indexSpecificationList,
 |  | const bool | isAmfTable = false,
 |  | const uint8_t | amfTableId = 0,
 |  | const uint8_t | amfRecordSize = 0
 | ) |  |

Constructor.

Parameters:
id | the table id.
name | the table name.
codeIdentifier | the table code identifier.
type | the table type.
isLatestVersion | whether this is the latest version of the table templates with matching table number.
fieldSpecificationList | the field specification list.
indexSpecificationList | the index specification list.
isAmfTable | whether table supports amf format.
amfTableId | amf table id.
amfRecordSize | size of amf record in rows.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/TableTemplate.h
Generated on Wed Oct 8 14:02:09 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::TableTemplateAddition

Activ::ContentPlatform::Feed::TableTemplateAddition Class Reference

Table template addition class. More...

#include <ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/TableTemplate.h>

Inheritance diagram for Activ::ContentPlatform::Feed::TableTemplateAddition:

Activ::ContentPlatform::Feed::TableTemplate

List of all members.

Public Member Functions

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
StatusCode 		Initialize (const UniversalFieldList &universalFieldList, const std::string &xmlFileName)
Initialize.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API | TableTemplateAddition (const UniversalFieldList &universalFieldList, const std::string &xmlFileName)
Constructor.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API | TableTemplateAddition ()
Default constructor.

Static Public Member Functions

static bool | IsTableTemplateAddition (const std::string &xmlFileName)
Checks if a file is a table template addition.

Detailed Description

Table template addition class.

Definition at line 1244 of file TableTemplate.h.

Constructor & Destructor Documentation

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API Activ::ContentPlatform::Feed::TableTemplateAddition::TableTemplateAddition | ( | const UniversalFieldList & | universalFieldList,
 |  | const std::string & | xmlFileName
 | ) |  |

Constructor.

Creates a table template addition from the universal field list and the xml file name.

Parameters:
universalFieldList | the universal field list to build the table template addition with.
xmlFileName | the file name of the xml table template addition.
Exceptions:
TableTemplateException

Member Function Documentation

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::TableTemplateAddition::Initialize | ( | const UniversalFieldList & | universalFieldList,
 |  | const std::string & | xmlFileName
 | ) |  |

Initialize.

Initializes the table template addition from the universal field list and the xml file name.

Parameters:
universalFieldList | the universal field list to build the table template addition with.
xmlFileName | the file name of the xml for the table template addition.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_FAILURE

Reimplemented from Activ::ContentPlatform::Feed::TableTemplate.

static bool Activ::ContentPlatform::Feed::TableTemplateAddition::IsTableTemplateAddition ( const std::string & xmlFileName ) [static]

Checks if a file is a table template addition.

Parameters:
xmlFileName the xml file name to check.
Exceptions:
ActivFeedTableTemplateHandlerException.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/TableTemplate.h
Generated on Wed Oct 8 14:02:09 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::TableTemplateException

Activ::ContentPlatform::Feed::TableTemplateException Class Reference

Table template exception. More...

#include <ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/TableTemplateException.h>

Inheritance diagram for Activ::ContentPlatform::Feed::TableTemplateException:

Activ::Exception

List of all members.

Public Member Functions

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API TableTemplateException (const char *file, const char *function, const uint_fast32_t line, const std::string &error)
Constructor.
virtual
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
std::string 		ToString () const
Convert the exception error code to a string.

Detailed Description

Table template exception.

Definition at line 55 of file TableTemplateException.h.

Constructor & Destructor Documentation

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API Activ::ContentPlatform::Feed::TableTemplateException::TableTemplateException | ( | const char * | file,
 |  | const char * | function,
 |  | const uint_fast32_t | line,
 |  | const std::string & | error
 | ) |  |

Constructor.

Parameters:
file | the file which raised the exception
function | the function which raised the exception
line | the line number which raised the exception
error | the error as a string

Member Function Documentation

virtual ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API std::string Activ::ContentPlatform::Feed::TableTemplateException::ToString ( ) const [virtual]

Convert the exception error code to a string.

Classes derived from Exception are required to implement ToString() to convert their error codes to a readable string.

Returns:
the error code as a string.

Reimplemented from Activ::Exception.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/TableTemplateException.h
Generated on Wed Oct 8 14:02:09 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::TableTemplateField

Activ::ContentPlatform::Feed::TableTemplateField Class Reference

Table template field class. More...

#include <ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/TableTemplateField.h>

List of all members.

Public Member Functions

ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		GetMaxLength (uint32_t &maxLength) const
Get the maximum length.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		Initialize (const UniversalField &universalField, MessageValidator &messageValidator)
Initialize.
ACTIV_FEED_MESSAGE_HANDLER_API bool | IsInitialized () const
Is the object initialized.
ACTIV_FEED_MESSAGE_HANDLER_API void | Reset ()
Reset.
ACTIV_FEED_MESSAGE_HANDLER_API | TableTemplateField (const UniversalField &universalField, MessageValidator &messageValidator)
Constructor.
ACTIV_FEED_MESSAGE_HANDLER_API | TableTemplateField ()
Default constructor.
ACTIV_FEED_MESSAGE_HANDLER_API | ~TableTemplateField ()
Destructor.

Detailed Description

Table template field class.

Definition at line 30 of file TableTemplateField.h.

Constructor & Destructor Documentation

ACTIV_FEED_MESSAGE_HANDLER_API Activ::ContentPlatform::Feed::TableTemplateField::TableTemplateField | ( | const UniversalField & | universalField,
 |  | MessageValidator & | messageValidator
 | ) |  |

Constructor.

Parameters:
universalField | the universal field.
messageValidator | the message validator.
Exceptions:
StatusCodeException

Member Function Documentation

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::TableTemplateField::GetMaxLength ( uint32_t & maxLength ) const

Get the maximum length.

Parameters:
maxLength the maximum length.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::TableTemplateField::Initialize | ( | const UniversalField & | universalField,
 |  | MessageValidator & | messageValidator
 | ) |  |

Initialize.

Parameters:
universalField | the universal field.
messageValidator | the message validator.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT
STATUS_CODE_HEAP_EMPTY
...

ACTIV_FEED_MESSAGE_HANDLER_API bool Activ::ContentPlatform::Feed::TableTemplateField::IsInitialized ( ) const

Is the object initialized.

Returns:
whether the object is initialized.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/TableTemplateField.h
Generated on Wed Oct 8 14:02:09 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::TableTemplateFieldListValidator

Activ::ContentPlatform::Feed::TableTemplateFieldListValidator Class Reference

Table template field list validator class. More...

#include <ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/TableTemplateFieldListValidator.h>

List of all members.

Public Member Functions

ACTIV_FEED_MESSAGE_HANDLER_API
ConstIterator 		Begin () const
Get an iterator to the first field in the message.
ACTIV_FEED_MESSAGE_HANDLER_API
ConstIterator 		End () const
Get an iterator that points to beyond the last field in the message.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		GetTableTemplateField (const FieldId fieldId, const TableTemplateField *&pTableTemplateField) const
Get a table template field.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		Initialize (const UniversalFieldList &universalFieldList, MessageValidator &messageValidator)
Initialize.
ACTIV_FEED_MESSAGE_HANDLER_API bool | IsInitialized () const
Is the object initialized.
ACTIV_FEED_MESSAGE_HANDLER_API void | Reset ()
Reset.
ACTIV_FEED_MESSAGE_HANDLER_API | TableTemplateFieldListValidator (const UniversalFieldList &universalFieldList, MessageValidator &messageValidator)
Constructor.
ACTIV_FEED_MESSAGE_HANDLER_API | TableTemplateFieldListValidator ()
Default constructor.
ACTIV_FEED_MESSAGE_HANDLER_API | ~TableTemplateFieldListValidator ()
Destructor.

Classes

class | ConstIterator
Const iterator class. More...

Detailed Description

Table template field list validator class.

Definition at line 37 of file TableTemplateFieldListValidator.h.

Constructor & Destructor Documentation

ACTIV_FEED_MESSAGE_HANDLER_API Activ::ContentPlatform::Feed::TableTemplateFieldListValidator::TableTemplateFieldListValidator | ( | const UniversalFieldList & | universalFieldList,
 |  | MessageValidator & | messageValidator
 | ) |  |

Constructor.

Parameters:
universalFieldList | the universal field list.
messageValidator | the message validator.
Exceptions:
StatusCodeException

Member Function Documentation

ACTIV_FEED_MESSAGE_HANDLER_API ConstIterator Activ::ContentPlatform::Feed::TableTemplateFieldListValidator::Begin ( ) const

Get an iterator to the first field in the message.

Returns:
an iterator object.
Exceptions:
StatusCodeException

ACTIV_FEED_MESSAGE_HANDLER_API ConstIterator Activ::ContentPlatform::Feed::TableTemplateFieldListValidator::End ( ) const

Get an iterator that points to beyond the last field in the message.

Returns:
an iterator object.
Exceptions:
StatusCodeException

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::TableTemplateFieldListValidator::GetTableTemplateField | ( | const FieldId | fieldId,
 |  | const TableTemplateField *& | pTableTemplateField |
 | ) |  |  | const

Get a table template field.

Parameters:
fieldId | the field id.
pTableTemplateField | a pointer to the table template field.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_FOUND
STATUS_CODE_NOT_INITIALIZED

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::TableTemplateFieldListValidator::Initialize | ( | const UniversalFieldList & | universalFieldList,
 |  | MessageValidator & | messageValidator
 | ) |  |

Initialize.

Parameters:
universalFieldList | the universal field list.
messageValidator | the message validator.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_HEAP_EMPTY
STATUS_CODE_INVALID_FORMAT
...

ACTIV_FEED_MESSAGE_HANDLER_API bool Activ::ContentPlatform::Feed::TableTemplateFieldListValidator::IsInitialized ( ) const

Is the object initialized.

Returns:
whether the object is initialized.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/TableTemplateFieldListValidator.h
Generated on Wed Oct 8 14:02:09 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::TableTemplateFieldListValidator::ConstIterator

Activ::ContentPlatform::Feed::TableTemplateFieldListValidator::ConstIterator Class Reference

Const iterator class. More...

#include <ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/TableTemplateFieldListValidator.h>

List of all members.

Public Member Functions

ACTIV_FEED_MESSAGE_HANDLER_API | ConstIterator ()
Default constructor.
ACTIV_FEED_MESSAGE_HANDLER_API
FieldId 		GetFieldId () const
Get the field id.
ACTIV_FEED_MESSAGE_HANDLER_API
const TableTemplateField * 		GetTableTemplateField () const
Get the table template field.
ACTIV_FEED_MESSAGE_HANDLER_API bool | operator!= (const ConstIterator &rhs) const
Inequality operator.
ACTIV_FEED_MESSAGE_HANDLER_API
const ConstIterator 		operator++ (int)
Postfix increment operator.
ACTIV_FEED_MESSAGE_HANDLER_API
ConstIterator & 		operator++ ()
Prefix increment operator.
ACTIV_FEED_MESSAGE_HANDLER_API bool | operator== (const ConstIterator &rhs) const
Equality operator.

Friends

class | TableTemplateFieldListValidator

Detailed Description

Const iterator class.

Definition at line 43 of file TableTemplateFieldListValidator.h.

Member Function Documentation

ACTIV_FEED_MESSAGE_HANDLER_API FieldId Activ::ContentPlatform::Feed::TableTemplateFieldListValidator::ConstIterator::GetFieldId ( ) const

Get the field id.

Returns:
the field id.

ACTIV_FEED_MESSAGE_HANDLER_API const TableTemplateField* Activ::ContentPlatform::Feed::TableTemplateFieldListValidator::ConstIterator::GetTableTemplateField ( ) const

Get the table template field.

Returns:
a pointer to the table template field.

ACTIV_FEED_MESSAGE_HANDLER_API bool Activ::ContentPlatform::Feed::TableTemplateFieldListValidator::ConstIterator::operator!= ( const ConstIterator & rhs ) const

Inequality operator.

Parameters:
rhs the object to test against.
Returns:
whether the two objects are not equal.

ACTIV_FEED_MESSAGE_HANDLER_API const ConstIterator Activ::ContentPlatform::Feed::TableTemplateFieldListValidator::ConstIterator::operator++ ( int )

Postfix increment operator.

Returns:
a copy of the original object.

ACTIV_FEED_MESSAGE_HANDLER_API ConstIterator& Activ::ContentPlatform::Feed::TableTemplateFieldListValidator::ConstIterator::operator++ ( )

Prefix increment operator.

Returns:
a reference to the updated object.

ACTIV_FEED_MESSAGE_HANDLER_API bool Activ::ContentPlatform::Feed::TableTemplateFieldListValidator::ConstIterator::operator== ( const ConstIterator & rhs ) const

Equality operator.

Parameters:
rhs the object to test against.
Returns:
whether the two objects are equal.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/TableTemplateFieldListValidator.h
Generated on Wed Oct 8 14:02:09 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::TableTemplateIndex

Activ::ContentPlatform::Feed::TableTemplateIndex Class Reference

Table template field list validator class. More...

#include <ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/TableTemplateIndex.h>

List of all members.

Public Types

typedef std::vector< FieldId >
::const_iterator 		ConstIterator

Public Member Functions

ACTIV_FEED_MESSAGE_HANDLER_API
ConstIterator 		Begin () const
Get an iterator to the first field in the index.
ACTIV_FEED_MESSAGE_HANDLER_API
ConstIterator 		End () const
Get an iterator that points to beyond the last field in the index.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		GetName (const TextString *&pName) const
Get the name.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		GetNumber (IndexNumber &number) const
Get the index number.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		GetProperties (IndexProperties &properties) const
Get the index properties.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		GetType (IndexType &type) const
Get the index type.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		Initialize (const TableTemplateFieldListValidator &tableTemplateFieldListValidator, MessageValidator &messageValidator)
Initialize.
ACTIV_FEED_MESSAGE_HANDLER_API bool | IsInitialized () const
Is the object initialized.
ACTIV_FEED_MESSAGE_HANDLER_API void | Reset ()
Reset.
ACTIV_FEED_MESSAGE_HANDLER_API | TableTemplateIndex (const TableTemplateFieldListValidator &tableTemplateFieldListValidator, MessageValidator &messageValidator)
Constructor.
ACTIV_FEED_MESSAGE_HANDLER_API | TableTemplateIndex ()
Default constructor.
ACTIV_FEED_MESSAGE_HANDLER_API | ~TableTemplateIndex ()
Destructor.

Detailed Description

Table template field list validator class.

Definition at line 40 of file TableTemplateIndex.h.

Constructor & Destructor Documentation

ACTIV_FEED_MESSAGE_HANDLER_API Activ::ContentPlatform::Feed::TableTemplateIndex::TableTemplateIndex | ( | const TableTemplateFieldListValidator & | tableTemplateFieldListValidator,
 |  | MessageValidator & | messageValidator
 | ) |  |

Constructor.

Parameters:
tableTemplateFieldListValidator | the table template field list validator.
messageValidator | the message validator.
Exceptions:
StatusCodeException

Member Function Documentation

ACTIV_FEED_MESSAGE_HANDLER_API ConstIterator Activ::ContentPlatform::Feed::TableTemplateIndex::Begin ( ) const

Get an iterator to the first field in the index.

Returns:
an iterator object.
Exceptions:
StatusCodeException

ACTIV_FEED_MESSAGE_HANDLER_API ConstIterator Activ::ContentPlatform::Feed::TableTemplateIndex::End ( ) const

Get an iterator that points to beyond the last field in the index.

Returns:
an iterator object.
Exceptions:
StatusCodeException

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::TableTemplateIndex::GetName ( const TextString *& pName ) const

Get the name.

Parameters:
pName set to point to the name of the index.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::TableTemplateIndex::GetNumber ( IndexNumber & number ) const

Get the index number.

Parameters:
number the index number.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::TableTemplateIndex::GetProperties ( IndexProperties & properties ) const

Get the index properties.

Parameters:
properties the index properties.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::TableTemplateIndex::GetType ( IndexType & type ) const

Get the index type.

Parameters:
type the index type.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::TableTemplateIndex::Initialize | ( | const TableTemplateFieldListValidator & | tableTemplateFieldListValidator,
 |  | MessageValidator & | messageValidator
 | ) |  |

Initialize.

Parameters:
tableTemplateFieldListValidator | the table template field list validator.
messageValidator | the message validator.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_HEAP_EMPTY
STATUS_CODE_INVALID_FORMAT
...

ACTIV_FEED_MESSAGE_HANDLER_API bool Activ::ContentPlatform::Feed::TableTemplateIndex::IsInitialized ( ) const

Is the object initialized.

Returns:
whether the object is initialized.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/TableTemplateIndex.h
Generated on Wed Oct 8 14:02:09 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::TableTemplateIndexListValidator

Activ::ContentPlatform::Feed::TableTemplateIndexListValidator Class Reference

Table template index list validator class. More...

#include <ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/TableTemplateIndexListValidator.h>

List of all members.

Public Types

typedef std::vector
< TableTemplateIndex >
::const_iterator 		ConstIterator

Public Member Functions

ACTIV_FEED_MESSAGE_HANDLER_API
ConstIterator 		Begin () const
Get an iterator to the first index in the list.
ACTIV_FEED_MESSAGE_HANDLER_API
ConstIterator 		End () const
Get an iterator that points to beyond the last index in the list.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		GetTableTemplateIndex (const IndexNumber indexNumber, const TableTemplateIndex *&pTableTemplateIndex) const
Get a table template index.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		Initialize (const TableTemplateFieldListValidator &tableTemplateFieldListValidator, MessageValidator &messageValidator)
Initialize.
ACTIV_FEED_MESSAGE_HANDLER_API bool | IsInitialized () const
Is the object initialized.
ACTIV_FEED_MESSAGE_HANDLER_API void | Reset ()
Reset.
ACTIV_FEED_MESSAGE_HANDLER_API | TableTemplateIndexListValidator (const TableTemplateFieldListValidator &tableTemplateFieldListValidator, MessageValidator &messageValidator)
Constructor.
ACTIV_FEED_MESSAGE_HANDLER_API | TableTemplateIndexListValidator ()
Default constructor.
ACTIV_FEED_MESSAGE_HANDLER_API | ~TableTemplateIndexListValidator ()
Destructor.

Detailed Description

Table template index list validator class.

Definition at line 33 of file TableTemplateIndexListValidator.h.

Constructor & Destructor Documentation

ACTIV_FEED_MESSAGE_HANDLER_API Activ::ContentPlatform::Feed::TableTemplateIndexListValidator::TableTemplateIndexListValidator | ( | const TableTemplateFieldListValidator & | tableTemplateFieldListValidator,
 |  | MessageValidator & | messageValidator
 | ) |  |

Constructor.

Parameters:
tableTemplateFieldListValidator | the table template field list validator.
messageValidator | the message validator.
Exceptions:
StatusCodeException

Member Function Documentation

ACTIV_FEED_MESSAGE_HANDLER_API ConstIterator Activ::ContentPlatform::Feed::TableTemplateIndexListValidator::Begin ( ) const

Get an iterator to the first index in the list.

Returns:
an iterator object.
Exceptions:
StatusCodeException

ACTIV_FEED_MESSAGE_HANDLER_API ConstIterator Activ::ContentPlatform::Feed::TableTemplateIndexListValidator::End ( ) const

Get an iterator that points to beyond the last index in the list.

Returns:
an iterator object.
Exceptions:
StatusCodeException

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::TableTemplateIndexListValidator::GetTableTemplateIndex | ( | const IndexNumber | indexNumber,
 |  | const TableTemplateIndex *& | pTableTemplateIndex |
 | ) |  |  | const

Get a table template index.

Parameters:
indexNumber | the index number.
pTableTemplateIndex | a pointer to the table template index.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_FOUND
STATUS_CODE_NOT_INITIALIZED

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::TableTemplateIndexListValidator::Initialize | ( | const TableTemplateFieldListValidator & | tableTemplateFieldListValidator,
 |  | MessageValidator & | messageValidator
 | ) |  |

Initialize.

Parameters:
tableTemplateFieldListValidator | the table template field list validator.
messageValidator | the message validator.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_HEAP_EMPTY
STATUS_CODE_INVALID_FORMAT
...

ACTIV_FEED_MESSAGE_HANDLER_API bool Activ::ContentPlatform::Feed::TableTemplateIndexListValidator::IsInitialized ( ) const

Is the object initialized.

Returns:
whether the object is initialized.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/TableTemplateIndexListValidator.h
Generated on Wed Oct 8 14:02:09 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::TableTemplateList

Activ::ContentPlatform::Feed::TableTemplateList Class Reference

Table template list class. More...

#include <ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/TableTemplateList.h>

List of all members.

Public Member Functions

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
StatusCode 		ApplyTableTemplateAddition (const TableTemplateAddition &tableTemplateAddition)
Remove a table template from the list.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
ConstIterator 		Begin () const
Get an iterator to the first table template in the list.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
void 		Clear ()
Clear the contents.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
ConstIterator 		End () const
Get an iterator that points to beyond the last table template in the list.
std::string | GetError () const
Get the error string.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
StatusCode 		GetFirstTableTemplate (const TableTemplate *&pTableTemplate) const
Get the first table template.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
StatusCode 		GetLatestTableTemplate (const TableNo tableNumber, const TableTemplate *&pTableTemplate) const
Get the latest table template.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
StatusCode 		GetLatestTableTemplateId (const TableNo tableNumber, TableId &tableId) const
Get the latest table template id.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
StatusCode 		GetNextTableTemplate (const TableTemplate *&pTableTemplate) const
Get the next table template.
size_t | GetSize () const
Get size.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
StatusCode 		GetTableTemplate (const TableId tableId, const TableTemplate *&pTableTemplate) const
Get a table template.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
StatusCode 		GetUniversalField (const FieldId fieldId, const UniversalField *&pUniversalField) const
Get a universal field.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
const UniversalFieldList & 		GetUniversalFieldList () const
Get the universal field list.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
StatusCode 		Initialize (Application &application, const ServiceHandleList &serviceHandleList, IHeap *const pHeap=0, const std::string &componentId=Component::defaultComponentId)
Initialize.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
StatusCode 		Initialize (Application &application, const ServiceIdList &serviceIdList, IHeap *const pHeap=0, const std::string &componentId=Component::defaultComponentId)
Initialize.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
StatusCode 		Initialize (const PathList &pathList)
Initialize.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
StatusCode 		Initialize (const std::string &path)
Initialize.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
StatusCode 		Initialize (Application &application, const Settings &settings, IHeap *const pHeap, const std::string &componentId=Component::defaultComponentId)
Initialize.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
StatusCode 		Initialize (bool shouldInitializeUniversalFieldList=true)
Initialize.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
StatusCode 		InsertTableTemplate (const TableTemplate &tableTemplate, bool updateLatestVersion=false)
Insert a table template in the list.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
StatusCode 		RemoveTableTemplate (const TableId tableId)
Remove a table template from the list.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
void 		Reset ()
Reset the table template list.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API | TableTemplateList (Application &application, const ServiceHandleList &serviceHandleList, IHeap *const pHeap=0)
Constructor.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API | TableTemplateList (Application &application, const ServiceIdList &serviceIdList, IHeap *const pHeap=0)
Constructor.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API | TableTemplateList (const PathList &pathList)
Constructor.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API | TableTemplateList (const std::string &path)
Constructor.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API | TableTemplateList (Application &application, const Settings &settings)
Constructor.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API | TableTemplateList ()
Default constructor.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
std::string 		ToString (bool shouldDisplayInitializeType=false) const
Convert the Table Template List to a C-style string.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
void 		UiAddAllOptions (UiMenu &uiMenu, const std::string &sectionName=std::string())
Add all options.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
void 		UiDisplayTableTemplateFields (const Activ::UiIo &uiIo)
Display the fields of a table template.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
void 		UiDisplayTableTemplatesList (const Activ::UiIo &uiIo)
Display the table template list.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
void 		UiDisplayUniversalFieldList (const Activ::UiIo &uiIo)
Display the universal field list.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
void 		UiReInitializeTableTemplateListFromHeaders (const Activ::UiIo &uiIo)
Re-initialize the table template list from the headers.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
void 		UiReInitializeTableTemplateListFromPathList (const Activ::UiIo &uiIo)
Re-initialize the table template list from a path list.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
void 		UiReInitializeTableTemplateListFromSettingsObject (const Activ::UiIo &uiIo)
Re-initialize the table template list from the settings object.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API | ~TableTemplateList ()
Destructor.

Classes

class | ConstIterator
Const iterator class. More...
class | Settings
Settings. More...
class | TableTemplateSpecification
Table template specification class. More...

Detailed Description

Table template list class.

Definition at line 34 of file TableTemplateList.h.

Constructor & Destructor Documentation

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API Activ::ContentPlatform::Feed::TableTemplateList::TableTemplateList ( )

Default constructor.

Creates the table template list from the default header file definitions.

Exceptions:
StatusCodeException

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API Activ::ContentPlatform::Feed::TableTemplateList::TableTemplateList | ( | Application & | application,
 |  | const Settings & | settings
 | ) |  |

Constructor.

Creates a table template list and universal field list using the settings object.

Parameters:
application | the application.
settings | the settings.
Exceptions:
TableTemplateException

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API Activ::ContentPlatform::Feed::TableTemplateList::TableTemplateList ( const std::string & path )

Constructor.

Creates a table template list and universal field list using the xml files in the given path.

Parameters:
path the path containing the xml files for the universal field list and table templates.
Exceptions:
TableTemplateException

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API Activ::ContentPlatform::Feed::TableTemplateList::TableTemplateList ( const PathList & pathList )

Constructor.

Creates a table template list and universal field list using the xml files in the given list of paths.

Parameters:
pathList the list of paths containing the xml files for the universal field list and table templates.
Exceptions:
TableTemplateException

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API Activ::ContentPlatform::Feed::TableTemplateList::TableTemplateList | ( | Application & | application,
 |  | const ServiceIdList & | serviceIdList,
 |  | IHeap *const | pHeap = 0
 | ) |  |

Constructor.

Creates a table template list and universal field list using a list of service ids from the service location to connect to using table service.

Parameters:
application | the application.
serviceIdList | the list of service ids to connect to using table service.
pHeap | the heap to use for table client. Default implies the system heap.
Exceptions:
TableTemplateException

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API Activ::ContentPlatform::Feed::TableTemplateList::TableTemplateList | ( | Application & | application,
 |  | const ServiceHandleList & | serviceHandleList,
 |  | IHeap *const | pHeap = 0
 | ) |  |

Constructor.

Creates a table template list and universal field list using a list of service handles to connect to using table service.

Parameters:
application | the application.
serviceHandleList | the list of service handles to connect to using table service.
pHeap | the heap to use for table client. Default implies the system heap.
Exceptions:
TableTemplateException

Member Function Documentation

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::TableTemplateList::ApplyTableTemplateAddition ( const TableTemplateAddition & tableTemplateAddition )

Remove a table template from the list.

Parameters:
tableTemplateAddition the table template addition to apply.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_FOUND

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API ConstIterator Activ::ContentPlatform::Feed::TableTemplateList::Begin ( ) const

Get an iterator to the first table template in the list.

Returns:
an iterator object.

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API ConstIterator Activ::ContentPlatform::Feed::TableTemplateList::End ( ) const

Get an iterator that points to beyond the last table template in the list.

Returns:
an iterator object.

std::string Activ::ContentPlatform::Feed::TableTemplateList::GetError ( ) const [inline]

Get the error string.

Returns:
the error as a string.

Definition at line 627 of file TableTemplateList.h.

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::TableTemplateList::GetFirstTableTemplate ( const TableTemplate *& pTableTemplate ) const

Get the first table template.

Parameters:
pTableTemplate a pointer to the table template.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_FOUND
...

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::TableTemplateList::GetLatestTableTemplate | ( | const TableNo | tableNumber,
 |  | const TableTemplate *& | pTableTemplate |
 | ) |  |  | const

Get the latest table template.

Parameters:
tableNumber | the table number.
pTableTemplate | pointer to the table template.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_FOUND

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::TableTemplateList::GetLatestTableTemplateId | ( | const TableNo | tableNumber,
 |  | TableId & | tableId |
 | ) |  |  | const

Get the latest table template id.

Parameters:
tableNumber | the table number.
tableId | the id of the latest table template.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_FOUND

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::TableTemplateList::GetNextTableTemplate ( const TableTemplate *& pTableTemplate ) const

Get the next table template.

Parameters:
pTableTemplate a pointer to the table template.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_FOUND
STATUS_CODE_INVALID_PARAMETER
...

size_t Activ::ContentPlatform::Feed::TableTemplateList::GetSize ( ) const [inline]

Get size.

Returns:
the number of table templates in the table template list.

Definition at line 620 of file TableTemplateList.h.

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::TableTemplateList::GetTableTemplate | ( | const TableId | tableId,
 |  | const TableTemplate *& | pTableTemplate |
 | ) |  |  | const

Get a table template.

Parameters:
tableId | the table id.
pTableTemplate | pointer to the table template.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_FOUND

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::TableTemplateList::GetUniversalField | ( | const FieldId | fieldId,
 |  | const UniversalField *& | pUniversalField |
 | ) |  |  | const

Get a universal field.

Parameters:
fieldId | the field id.
pUniversalField | pointer to the universal field.
Return values:
STATUS_CODE_SUCCESS
...

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API const UniversalFieldList& Activ::ContentPlatform::Feed::TableTemplateList::GetUniversalFieldList ( ) const

Get the universal field list.

Returns:
the universal field list

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::TableTemplateList::Initialize | ( | Application & | application,
 |  | const ServiceHandleList & | serviceHandleList,
 |  | IHeap *const | pHeap = 0,
 |  | const std::string & | componentId = Component::defaultComponentId
 | ) |  |

Initialize.

Initializes the table template list and universal field list using a list of service ids to connect to using table service.

Parameters:
application | the application.
serviceHandleList | the list of service handles to connect to using table service.
pHeap | the heap to use for table client. Default implies the system heap.
componentId | the component id.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_FAILURE

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::TableTemplateList::Initialize | ( | Application & | application,
 |  | const ServiceIdList & | serviceIdList,
 |  | IHeap *const | pHeap = 0,
 |  | const std::string & | componentId = Component::defaultComponentId
 | ) |  |

Initialize.

Initializes the table template list and universal field list using a list of service ids from the service location to connect to using table service.

Parameters:
application | the application.
serviceIdList | the list of service ids to connect to using table service.
pHeap | the heap to use for table client. Default implies the system heap.
componentId | the component id.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_FAILURE

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::TableTemplateList::Initialize ( const PathList & pathList )

Initialize.

Initializes the table template list and universal field list using the xml files in the given list of paths.

Parameters:
pathList the list of paths containing the xml files for the universal field list and table templates.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_FAILURE

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::TableTemplateList::Initialize ( const std::string & path )

Initialize.

Initializes the table template list and universal field list using the xml files in the given path.

Parameters:
path the path containing the xml files for the universal field list and table templates.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_FAILURE

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::TableTemplateList::Initialize | ( | Application & | application,
 |  | const Settings & | settings,
 |  | IHeap *const | pHeap,
 |  | const std::string & | componentId = Component::defaultComponentId
 | ) |  |

Initialize.

Initializes the table template list and universal field list using the settings object.

Parameters:
application | the application.
settings | the settings.
pHeap | the heap to use for table client. Default implies the system heap.
componentId | the component id.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::TableTemplateList::Initialize ( bool shouldInitializeUniversalFieldList = true )

Initialize.

Initializes the table template list from the default header file definitions.

Parameters:
shouldInitializeUniversalFieldList whether to initialize the universal field list.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::TableTemplateList::InsertTableTemplate | ( | const TableTemplate & | tableTemplate,
 |  | bool | updateLatestVersion = false
 | ) |  |

Insert a table template in the list.

Parameters:
tableTemplate | the table template to add to the list.
updateLatestVersion | allows the method to unset previous latest version.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_ALREADY_EXISTS

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::TableTemplateList::RemoveTableTemplate ( const TableId tableId )

Remove a table template from the list.

Parameters:
tableId the id of the table template to remove.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_FOUND

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API std::string Activ::ContentPlatform::Feed::TableTemplateList::ToString ( bool shouldDisplayInitializeType = false ) const

Convert the Table Template List to a C-style string.

Parameters:
shouldDisplayInitializeType whether the initialize type should be displayed.
Returns:
the specification as a string.

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API void Activ::ContentPlatform::Feed::TableTemplateList::UiAddAllOptions | ( | UiMenu & | uiMenu,
 |  | const std::string & | sectionName = std::string()
 | ) |  |

Add all options.

Parameters:
uiMenu | the user interface menu to add the options to.
sectionName | the section name.

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API void Activ::ContentPlatform::Feed::TableTemplateList::UiDisplayTableTemplateFields ( const Activ::UiIo & uiIo )

Display the fields of a table template.

Parameters:
uiIo the user interface i/o object.

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API void Activ::ContentPlatform::Feed::TableTemplateList::UiDisplayTableTemplatesList ( const Activ::UiIo & uiIo )

Display the table template list.

Parameters:
uiIo the user interface i/o object.

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API void Activ::ContentPlatform::Feed::TableTemplateList::UiDisplayUniversalFieldList ( const Activ::UiIo & uiIo )

Display the universal field list.

Parameters:
uiIo the user interface i/o object.

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API void Activ::ContentPlatform::Feed::TableTemplateList::UiReInitializeTableTemplateListFromHeaders ( const Activ::UiIo & uiIo )

Re-initialize the table template list from the headers.

Parameters:
uiIo the user interface i/o object.

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API void Activ::ContentPlatform::Feed::TableTemplateList::UiReInitializeTableTemplateListFromPathList ( const Activ::UiIo & uiIo )

Re-initialize the table template list from a path list.

Parameters:
uiIo the user interface i/o object.

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API void Activ::ContentPlatform::Feed::TableTemplateList::UiReInitializeTableTemplateListFromSettingsObject ( const Activ::UiIo & uiIo )

Re-initialize the table template list from the settings object.

Parameters:
uiIo the user interface i/o object.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/TableTemplateList.h
Generated on Wed Oct 8 14:02:09 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::TableTemplateList::ConstIterator

Activ::ContentPlatform::Feed::TableTemplateList::ConstIterator Class Reference

Const iterator class. More...

#include <ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/TableTemplateList.h>

List of all members.

Public Member Functions

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API | ConstIterator ()
Default constructor.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
TableId 		GetTableId () const
Get the table id.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
const TableTemplate & 		GetTableTemplate () const
Get the table template.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
const TableTemplate & 		operator * () const
Dereference operator.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
bool 		operator!= (const ConstIterator &rhs) const
Inequality operator.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
const ConstIterator 		operator++ (int)
Postfix increment operator.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
ConstIterator & 		operator++ ()
Prefix increment operator.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
const TableTemplate * 		operator-> () const
Member access operator.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
bool 		operator== (const ConstIterator &rhs) const
Equality operator.

Friends

class | TableTemplateList

Detailed Description

Const iterator class.

Definition at line 118 of file TableTemplateList.h.

Member Function Documentation

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API TableId Activ::ContentPlatform::Feed::TableTemplateList::ConstIterator::GetTableId ( ) const

Get the table id.

Returns:
the table id.

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API const TableTemplate& Activ::ContentPlatform::Feed::TableTemplateList::ConstIterator::GetTableTemplate ( ) const

Get the table template.

Returns:
the table template.

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API const TableTemplate& Activ::ContentPlatform::Feed::TableTemplateList::ConstIterator::operator * ( ) const

Dereference operator.

Returns:
Reference to the current table template.

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API bool Activ::ContentPlatform::Feed::TableTemplateList::ConstIterator::operator!= ( const ConstIterator & rhs ) const

Inequality operator.

Parameters:
rhs the object to test against.
Returns:
whether the two objects are not equal.

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API const ConstIterator Activ::ContentPlatform::Feed::TableTemplateList::ConstIterator::operator++ ( int )

Postfix increment operator.

Returns:
a copy of the original object.

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API ConstIterator& Activ::ContentPlatform::Feed::TableTemplateList::ConstIterator::operator++ ( )

Prefix increment operator.

Returns:
a reference to the updated object.

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API const TableTemplate* Activ::ContentPlatform::Feed::TableTemplateList::ConstIterator::operator-> ( ) const

Member access operator.

Returns:
Pointer to the current table template.

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API bool Activ::ContentPlatform::Feed::TableTemplateList::ConstIterator::operator== ( const ConstIterator & rhs ) const

Equality operator.

Parameters:
rhs the object to test against.
Returns:
whether the two objects are equal.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/TableTemplateList.h
Generated on Wed Oct 8 14:02:09 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::TableTemplateList::Settings

Activ::ContentPlatform::Feed::TableTemplateList::Settings Class Reference

Settings. More...

#include <ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/TableTemplateList.h>

List of all members.

Public Member Functions

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
StatusCode 		Read (const IniFileParser::ConstSectionIterator &sectionIterator)
Read settings from an ini file section.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API | Settings ()
Default constructor.

Static Public Member Functions

static
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
Settings 		GetFromIniFile (const std::string &iniFileName, const std::string &sectionName)
Get settings from an ini file.

Public Attributes

PathList | m_pathList
The list of paths containing the xml table templates.
ServiceHandleList | m_serviceHandleList
The list of service handles from which to download the table templates.
ServiceIdList | m_serviceIdList
The list of service id's from which to download the table templates.
bool | m_shouldReInitializeOnReset
Whether the reset method should re-initialize the table templates.
bool | m_shouldTerminateOnError
Whether the TableTemplateList should terminate if there is an error in Initialize() or try the next possible Initialize().
IHeap::BucketInfoVector m_tableClientHeapBucketInfo
The size of the table client heap.

Detailed Description

Settings.

Definition at line 40 of file TableTemplateList.h.

Member Function Documentation

static ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API Settings Activ::ContentPlatform::Feed::TableTemplateList::Settings::GetFromIniFile | ( | const std::string & | iniFileName,
 |  | const std::string & | sectionName |
 | ) |  |  | [static]

Get settings from an ini file.

Parameters:
iniFileName | the file name of the int file.
sectionName | the section name within the ini file.
Returns:
a copy of a settings object.
Exceptions:
Exception

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::TableTemplateList::Settings::Read ( const IniFileParser::ConstSectionIterator & sectionIterator )

Read settings from an ini file section.

Parameters:
sectionIterator iterator to an ini file section.
Return values:
STATUS_CODE_SUCCESS
...

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/TableTemplateList.h
Generated on Wed Oct 8 14:02:09 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::TableTemplateList::TableTemplateSpecification

Activ::ContentPlatform::Feed::TableTemplateList::TableTemplateSpecification Class Reference

Table template specification class. More...

#include <ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/TableTemplateList.h>

List of all members.

Public Member Functions

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API | TableTemplateSpecification (const TableNo number, const TableVersion version, const std::string &name, const std::string &codeIdentifier, const TableType type, const bool isLatestVersion, const TableTemplate::FieldSpecificationList &fieldSpecificationList, const Index::IndexSpecificationList &indexSpecificationList)
Constructor.

Public Attributes

std::string | m_codeIdentifier
The table code identifier.
TableTemplate::FieldSpecificationList m_fieldSpecificationList
The field specification list.
Index::IndexSpecificationList | m_indexSpecificationList
The index specification list.
bool | m_isLatestVersion
Whether this is the latest version of the table template with matching table number.
std::string | m_name
The table name.
TableNo | m_number
The table number.
TableType | m_type
The table type.
TableVersion | m_version
The table version.

Detailed Description

Table template specification class.

This is used in construction of the table object.

Definition at line 83 of file TableTemplateList.h.

Constructor & Destructor Documentation

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API Activ::ContentPlatform::Feed::TableTemplateList::TableTemplateSpecification::TableTemplateSpecification | ( | const TableNo | number,
 |  | const TableVersion | version,
 |  | const std::string & | name,
 |  | const std::string & | codeIdentifier,
 |  | const TableType | type,
 |  | const bool | isLatestVersion,
 |  | const TableTemplate::FieldSpecificationList & | fieldSpecificationList,
 |  | const Index::IndexSpecificationList & | indexSpecificationList
 | ) |  |

Constructor.

Parameters:
number | the table number.
version | the table version.
name | the table name.
codeIdentifier | the table codeIdentifier.
type | the table type.
isLatestVersion | whether this is the latest version the table templates with this table number.
fieldSpecificationList | the field specification list.
indexSpecificationList | the index specification list.
Exceptions:
StatusCodeException

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/TableTemplateList.h
Generated on Wed Oct 8 14:02:09 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::TableTemplateMessageHeaderDefinitions

Activ::ContentPlatform::Feed::TableTemplateMessageHeaderDefinitions Class Reference

Table template message header definitions class. More...

#include <ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/TableTemplateMessageHeaderDefinitions.h>

List of all members.

Static Public Member Functions

static
MessageHeaderDefinitions::MessageHeader 		GetMessageHeader ()
Get the message header.
static bool | IsValidMessageType (const MessageHeaderDefinitions::MessageHeader messageHeader)
Is valid message type.

Static Public Attributes

static const size_t | MAX_INDEX_NAME_LENGTH = 32
The maximum index name length.
static const size_t | MAX_NAME_LENGTH = 32
The maximum name length.
static const size_t | MESSAGE_HEADER_FLAGS_RESERVED_LENGTH = 2
The message header flags reserved length.
static const size_t | MESSAGE_HEADER_FLAGS_RESERVED_OFFSET = 0
The message header flags reserved offset.
static const MessageType | MESSAGE_TYPE = MESSAGE_TYPE_TABLE_TEMPLATE
The message type.

Detailed Description

Table template message header definitions class.

Definition at line 28 of file TableTemplateMessageHeaderDefinitions.h.

Member Function Documentation

MessageHeaderDefinitions::MessageHeader Activ::ContentPlatform::Feed::TableTemplateMessageHeaderDefinitions::GetMessageHeader ( ) [inline, static]

Get the message header.

Returns:
the message header.

Definition at line 58 of file TableTemplateMessageHeaderDefinitions.h.

References Activ::ContentPlatform::Feed::MessageHeaderDefinitions::GetMessageHeader(), and MESSAGE_TYPE.

bool Activ::ContentPlatform::Feed::TableTemplateMessageHeaderDefinitions::IsValidMessageType ( const MessageHeaderDefinitions::MessageHeader messageHeader ) [inline, static]

Is valid message type.

Parameters:
messageHeader the message header.
Returns:
whether the message type is valid.

Definition at line 65 of file TableTemplateMessageHeaderDefinitions.h.

References Activ::ContentPlatform::Feed::MessageHeaderDefinitions::GetMessageType(), and MESSAGE_TYPE.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/TableTemplateMessageHeaderDefinitions.h
Generated on Wed Oct 8 14:02:10 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::TableTemplateMessageValidator

Activ::ContentPlatform::Feed::TableTemplateMessageValidator Class Reference

Table template message validator class. More...

#include <ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/TableTemplateMessageValidator.h>

List of all members.

Public Types

typedef
TableTemplateFieldListValidator::ConstIterator 		ConstFieldIterator
The table template field iterator type definition.
typedef
TableTemplateIndexListValidator::ConstIterator 		ConstIndexIterator
The table template index iterator type definition.

Public Member Functions

ACTIV_FEED_MESSAGE_HANDLER_API
ConstFieldIterator 		BeginField () const
Get an iterator to the first field in the table template.
ACTIV_FEED_MESSAGE_HANDLER_API
ConstIndexIterator 		BeginIndex () const
Get an iterator to the first index in the table template.
ACTIV_FEED_MESSAGE_HANDLER_API
ConstFieldIterator 		EndField () const
Get an iterator that points to beyond the last field in the table template.
ACTIV_FEED_MESSAGE_HANDLER_API
ConstIndexIterator 		EndIndex () const
Get an iterator that points to beyond the last index in the table template.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		GetName (const TextString *&pName) const
Get the name.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		GetTableId (TableId &tableId) const
Get the table id.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		GetTableTemplateField (const FieldId fieldId, const TableTemplateField *&pTableTemplateField) const
Get a table template field.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		GetTableTemplateIndex (const IndexNumber indexNumber, const TableTemplateIndex *&pTableTemplateIndex) const
Get a table template index.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		Initialize (MessageValidator &messageValidator)
Initialize with a new message validator.
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		Initialize (const UniversalFieldList &universalFieldList)
Initialize with a new universal field list (and reset the object).
ACTIV_FEED_MESSAGE_HANDLER_API
StatusCode 		Initialize (const UniversalFieldList &universalFieldList, MessageValidator &messageValidator)
Initialize with a new table template list and message validator.
ACTIV_FEED_MESSAGE_HANDLER_API bool | IsInitialized () const
Is the object initialized.
ACTIV_FEED_MESSAGE_HANDLER_API void | Reset ()
Reset.
ACTIV_FEED_MESSAGE_HANDLER_API | TableTemplateMessageValidator (const UniversalFieldList &universalFieldList)
Constructor.
ACTIV_FEED_MESSAGE_HANDLER_API | TableTemplateMessageValidator (const UniversalFieldList &universalFieldList, MessageValidator &messageValidator)
Constructor.
ACTIV_FEED_MESSAGE_HANDLER_API | TableTemplateMessageValidator ()
Default constructor.
ACTIV_FEED_MESSAGE_HANDLER_API | ~TableTemplateMessageValidator ()
Destructor.

Detailed Description

Table template message validator class.

Definition at line 41 of file TableTemplateMessageValidator.h.

Constructor & Destructor Documentation

ACTIV_FEED_MESSAGE_HANDLER_API Activ::ContentPlatform::Feed::TableTemplateMessageValidator::TableTemplateMessageValidator | ( | const UniversalFieldList & | universalFieldList,
 |  | MessageValidator & | messageValidator
 | ) |  |

Constructor.

Parameters:
universalFieldList | the universal field list.
messageValidator | the message validator.
Exceptions:
StatusCodeException

ACTIV_FEED_MESSAGE_HANDLER_API Activ::ContentPlatform::Feed::TableTemplateMessageValidator::TableTemplateMessageValidator ( const UniversalFieldList & universalFieldList )

Constructor.

Parameters:
universalFieldList the universal field list.
Exceptions:
StatusCodeException

Member Function Documentation

ACTIV_FEED_MESSAGE_HANDLER_API ConstFieldIterator Activ::ContentPlatform::Feed::TableTemplateMessageValidator::BeginField ( ) const

Get an iterator to the first field in the table template.

Returns:
an iterator object.
Exceptions:
StatusCodeException

ACTIV_FEED_MESSAGE_HANDLER_API ConstIndexIterator Activ::ContentPlatform::Feed::TableTemplateMessageValidator::BeginIndex ( ) const

Get an iterator to the first index in the table template.

Returns:
an iterator object.
Exceptions:
StatusCodeException

ACTIV_FEED_MESSAGE_HANDLER_API ConstFieldIterator Activ::ContentPlatform::Feed::TableTemplateMessageValidator::EndField ( ) const

Get an iterator that points to beyond the last field in the table template.

Returns:
an iterator object.
Exceptions:
StatusCodeException

ACTIV_FEED_MESSAGE_HANDLER_API ConstIndexIterator Activ::ContentPlatform::Feed::TableTemplateMessageValidator::EndIndex ( ) const

Get an iterator that points to beyond the last index in the table template.

Returns:
an iterator object.
Exceptions:
StatusCodeException

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::TableTemplateMessageValidator::GetName ( const TextString *& pName ) const

Get the name.

Parameters:
pName the name of the table template.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::TableTemplateMessageValidator::GetTableId ( TableId & tableId ) const

Get the table id.

Parameters:
tableId the table id.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::TableTemplateMessageValidator::GetTableTemplateField | ( | const FieldId | fieldId,
 |  | const TableTemplateField *& | pTableTemplateField |
 | ) |  |  | const

Get a table template field.

Parameters:
fieldId | the field id .
pTableTemplateField | a pointer to the table template field.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_FOUND
STATUS_CODE_NOT_INITIALIZED

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::TableTemplateMessageValidator::GetTableTemplateIndex | ( | const IndexNumber | indexNumber,
 |  | const TableTemplateIndex *& | pTableTemplateIndex |
 | ) |  |  | const

Get a table template index.

Parameters:
indexNumber | the index number.
pTableTemplateIndex | a pointer to the table template index.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_FOUND
STATUS_CODE_NOT_INITIALIZED

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::TableTemplateMessageValidator::Initialize ( MessageValidator & messageValidator )

Initialize with a new message validator.

Parameters:
messageValidator the message validator.
Return values:
STATUS_CODE_SUCCESS
...

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::TableTemplateMessageValidator::Initialize ( const UniversalFieldList & universalFieldList )

Initialize with a new universal field list (and reset the object).

Parameters:
universalFieldList the universal field list.
Return values:
STATUS_CODE_SUCCESS

ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::TableTemplateMessageValidator::Initialize | ( | const UniversalFieldList & | universalFieldList,
 |  | MessageValidator & | messageValidator
 | ) |  |

Initialize with a new table template list and message validator.

Parameters:
universalFieldList | the universal field list.
messageValidator | the message validator.
Return values:
STATUS_CODE_SUCCESS
...

ACTIV_FEED_MESSAGE_HANDLER_API bool Activ::ContentPlatform::Feed::TableTemplateMessageValidator::IsInitialized ( ) const

Is the object initialized.

Returns:
whether the object is initialized.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/TableTemplateMessageValidator.h
Generated on Wed Oct 8 14:02:10 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::UniversalFieldHelper

Activ::ContentPlatform::Feed::UniversalFieldHelper Class Reference

Universal field helper class. More...

#include <ActivContentPlatform/ActivFeedCommon/UniversalFieldHelper.h>

List of all members.

Public Member Functions

UniversalFieldHelper (const FieldId fieldId, const char *const pName, const char *const pCodeIdentifier, const char *const pDescription, const FieldType type, const size_t maxLength)
Constructor.
UniversalFieldHelper ()
Default constructor.

Public Attributes

std::string | m_codeIdentifier
The code identifier for the field.
std::string | m_description
A description of the field.
FieldId | m_fieldId
The id of the field.
size_t | m_maxLength
The maximum length.
std::string | m_name
The name of the field.
FieldType | m_type
The type of the field.

Detailed Description

Universal field helper class.

Definition at line 28 of file UniversalFieldHelper.h.

Constructor & Destructor Documentation

Activ::ContentPlatform::Feed::UniversalFieldHelper::UniversalFieldHelper | ( | const FieldId | fieldId,
 |  | const char *const | pName,
 |  | const char *const | pCodeIdentifier,
 |  | const char *const | pDescription,
 |  | const FieldType | type,
 |  | const size_t | maxLength |
 | ) |  |  | [inline]

Constructor.

Parameters:
fieldId | the id of the field.
pName | the name of the field.
pCodeIdentifier | the code identifer for the field.
pDescription | the description of the field.
type | the type of the field.
maxLength | the maximum length of the field.

Definition at line 68 of file UniversalFieldHelper.h.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivFeedCommon/UniversalFieldHelper.h
Generated on Wed Oct 8 14:02:10 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::UniversalFieldList

Activ::ContentPlatform::Feed::UniversalFieldList Class Reference

Universal field list class. More...

#include <ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/UniversalFieldList.h>

List of all members.

Public Member Functions

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
ConstIterator 		Begin () const
Get an iterator to the first table template in the list.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
void 		Clear ()
Clear the contents.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
ConstIterator 		End () const
Get an iterator that points to beyond the last table template in the list.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
std::string 		GetError () const
Get the error string.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
StatusCode 		GetUniversalField (const FieldId fieldId, const UniversalField *&pUniversalField) const
Get a universal field.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
StatusCode 		Initialize (Application &application, const ServiceHandleList &serviceHandleList, IHeap *const pHeap=0, const std::string &componentId=Component::defaultComponentId)
Initialize.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
StatusCode 		Initialize (const PathList &pathList)
Initialize.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
StatusCode 		Initialize (const std::string &path)
Initialize.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
StatusCode 		Initialize (const UniversalFieldSpecificationList &universalFieldSpecificationList)
Initialize.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
StatusCode 		Initialize ()
Initialize.
StatusCode | InitializeList (const std::string &xmlFileName)
Initialize list from the xml file.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
bool 		IsEmpty () const
Is the universal field list empty.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
std::string 		ToString () const
Convert the Universal Field List to a C-style string.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API | UniversalFieldList (Application &application, const ServiceHandleList &serviceHandleList)
Constructor.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API | UniversalFieldList (const PathList &pathList)
Constructor.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API | UniversalFieldList (const std::string &path)
Constructor.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API | UniversalFieldList (const UniversalFieldSpecificationList &universalFieldSpecificationList)
Constructor.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API | UniversalFieldList ()
Default constructor.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API | ~UniversalFieldList ()
Destructor.

Static Public Member Functions

static bool | IsContributedUniversalFieldList (const std::string &xmlFileName)
Checks if a file is a contributed universal field list, if the fields are not in the contributed range it throws an exception.

Static Public Attributes

static const std::string | DEFAULT_FILENAME
The default filename.

Classes

class | ConstIterator
Const iterator class. More...

Detailed Description

Universal field list class.

Definition at line 38 of file UniversalFieldList.h.

Constructor & Destructor Documentation

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API Activ::ContentPlatform::Feed::UniversalFieldList::UniversalFieldList ( )

Default constructor.

Creates the universal field list from the default header file definitions.

Exceptions:
StatusCodeException

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API Activ::ContentPlatform::Feed::UniversalFieldList::UniversalFieldList ( const UniversalFieldSpecificationList & universalFieldSpecificationList )

Constructor.

Creates a universal field list from the given universal field list specification.

Parameters:
universalFieldSpecificationList the universal field specification list.
Exceptions:
StatusCodeException

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API Activ::ContentPlatform::Feed::UniversalFieldList::UniversalFieldList ( const std::string & path )

Constructor.

Creates a universal field list using the xml files in the given path.

Parameters:
path the path containing the xml files for the universal field list and table templates.
Exceptions:
TableTemplateException

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API Activ::ContentPlatform::Feed::UniversalFieldList::UniversalFieldList ( const PathList & pathList )

Constructor.

Creates a universal field list using the xml files in the given list of paths.

Parameters:
pathList the list of paths containing the xml files for the universal field list.
Exceptions:
TableTemplateException

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API Activ::ContentPlatform::Feed::UniversalFieldList::UniversalFieldList | ( | Application & | application,
 |  | const ServiceHandleList & | serviceHandleList
 | ) |  |

Constructor.

Creates a universal field list using a list of service ids to connect to using table service.

Parameters:
application | the application.
serviceHandleList | the list of service handles to connect to using table service.
Exceptions:
TableTemplateException

Member Function Documentation

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API ConstIterator Activ::ContentPlatform::Feed::UniversalFieldList::Begin ( ) const

Get an iterator to the first table template in the list.

Returns:
an iterator object.

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API ConstIterator Activ::ContentPlatform::Feed::UniversalFieldList::End ( ) const

Get an iterator that points to beyond the last table template in the list.

Returns:
an iterator object.

std::string Activ::ContentPlatform::Feed::UniversalFieldList::GetError ( ) const [inline]

Get the error string.

Returns:
the error as a string.

Definition at line 340 of file UniversalFieldList.h.

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::UniversalFieldList::GetUniversalField | ( | const FieldId | fieldId,
 |  | const UniversalField *& | pUniversalField |
 | ) |  |  | const

Get a universal field.

Parameters:
fieldId | the field id.
pUniversalField | pointer to the universal field.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_FOUND

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::UniversalFieldList::Initialize | ( | Application & | application,
 |  | const ServiceHandleList & | serviceHandleList,
 |  | IHeap *const | pHeap = 0,
 |  | const std::string & | componentId = Component::defaultComponentId
 | ) |  |

Initialize.

Initializes the universal field list using a list of service ids to connect to using table service.

Parameters:
application | the application.
serviceHandleList | the list of service handles to connect to using table service.
pHeap | the heap to use for table client. Default implies the system heap.
componentId | the component id.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_FAILURE

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::UniversalFieldList::Initialize ( const PathList & pathList )

Initialize.

Initializes the universal field list using the xml files in the given list of paths.

Parameters:
pathList the list of paths containing the xml files for the universal field list.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_FAILURE

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::UniversalFieldList::Initialize ( const std::string & path )

Initialize.

Initializes the universal field list using the xml files in the given path.

Parameters:
path the path containing the xml files for the universal field list and table templates.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_FAILURE

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::UniversalFieldList::Initialize ( const UniversalFieldSpecificationList & universalFieldSpecificationList )

Initialize.

Initializes the universal field list from the given universal field list specification.

Parameters:
universalFieldSpecificationList the universal field specification list.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API StatusCode Activ::ContentPlatform::Feed::UniversalFieldList::Initialize ( )

Initialize.

Initializes the table template list from the default header file definitions.

Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER

StatusCode Activ::ContentPlatform::Feed::UniversalFieldList::InitializeList ( const std::string & xmlFileName )

Initialize list from the xml file.

Parameters:
xmlFileName the xml file name to parse.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_FAILURE

static bool Activ::ContentPlatform::Feed::UniversalFieldList::IsContributedUniversalFieldList ( const std::string & xmlFileName ) [static]

Checks if a file is a contributed universal field list, if the fields are not in the contributed range it throws an exception.

Parameters:
xmlFileName the xml file name to check.
Exceptions:
ActivFeedTableTemplateHandlerException.

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API std::string Activ::ContentPlatform::Feed::UniversalFieldList::ToString ( ) const

Convert the Universal Field List to a C-style string.

Returns:
the specification as a string.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/UniversalFieldList.h
Generated on Wed Oct 8 14:02:10 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::UniversalFieldList::ConstIterator

Activ::ContentPlatform::Feed::UniversalFieldList::ConstIterator Class Reference

Const iterator class. More...

#include <ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/UniversalFieldList.h>

List of all members.

Public Member Functions

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API | ConstIterator ()
Default constructor.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
const UniversalField & 		operator * () const
Dereference operator.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
bool 		operator!= (const ConstIterator &rhs) const
Inequality operator.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
const ConstIterator 		operator++ (int)
Postfix increment operator.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
ConstIterator & 		operator++ ()
Prefix increment operator.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
const UniversalField * 		operator-> () const
Member access operator.
ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
bool 		operator== (const ConstIterator &rhs) const
Equality operator.

Friends

class | UniversalFieldList

Detailed Description

Const iterator class.

Definition at line 46 of file UniversalFieldList.h.

Member Function Documentation

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API const UniversalField& Activ::ContentPlatform::Feed::UniversalFieldList::ConstIterator::operator * ( ) const

Dereference operator.

Returns:
Reference to the current universal field.

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API bool Activ::ContentPlatform::Feed::UniversalFieldList::ConstIterator::operator!= ( const ConstIterator & rhs ) const

Inequality operator.

Parameters:
rhs the object to test against.
Returns:
whether the two objects are not equal.

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API const ConstIterator Activ::ContentPlatform::Feed::UniversalFieldList::ConstIterator::operator++ ( int )

Postfix increment operator.

Returns:
a copy of the original object.

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API ConstIterator& Activ::ContentPlatform::Feed::UniversalFieldList::ConstIterator::operator++ ( )

Prefix increment operator.

Returns:
a reference to the updated object.

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API const UniversalField* Activ::ContentPlatform::Feed::UniversalFieldList::ConstIterator::operator-> ( ) const

Member access operator.

Returns:
Pointer to the current universal field.

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API bool Activ::ContentPlatform::Feed::UniversalFieldList::ConstIterator::operator== ( const ConstIterator & rhs ) const

Equality operator.

Parameters:
rhs the object to test against.
Returns:
whether the two objects are equal.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/UniversalFieldList.h
Generated on Wed Oct 8 14:02:10 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::FeedApi::FieldListValidator

Activ::ContentPlatform::FeedApi::FieldListValidator Class Reference

Field list validator class. More...

#include <ActivContentPlatform/ActivFeedApiCommon/FieldListValidator.h>

Inheritance diagram for Activ::ContentPlatform::FeedApi::FieldListValidator:

Activ::ContentPlatform::ContentGatewayApi::FieldListValidator Activ::ContentPlatform::ContentServerApi::FieldListValidator

List of all members.

Public Member Functions

ACTIV_FEED_API_COMMON_API
StatusCode 		ApplyUpdate (const FieldListValidator &fieldListValidator)
Apply all fields in another FieldListValidator to this.
ACTIV_FEED_API_COMMON_API
StatusCode 		ApplyUpdateToExistingFieldsOnly (const FieldListValidator &fieldListValidator)
Apply only the fields from another FieldListValidator to this that already exist in this.
ACTIV_FEED_API_COMMON_API
ConstIterator 		Begin () const
Get an iterator to the first field in the message.
ACTIV_FEED_API_COMMON_API void | Clear ()
Clear.
ACTIV_FEED_API_COMMON_API
ConstIterator 		End () const
Get an iterator that points to beyond the last field in the message.
ACTIV_FEED_API_COMMON_API | FieldListValidator (const FieldListValidator &rhs)
Copy constructor.
ACTIV_FEED_API_COMMON_API | FieldListValidator ()
Default constructor.
template<typename T>
const T * | GetActivFieldType (const Feed::FieldId fieldId) const
Get ACTIV field type.
template<typename T>
StatusCode | GetActivFieldType (const Feed::FieldId fieldId, const T *&pFieldType) const
Get ACTIV field type.
StatusCode | GetField (const Feed::FieldId fieldId, const Field *&pField) const
Get a field.
size_t | GetNumberOfFields () const
Get the number of fields present.
bool | IsFieldPresent (const Feed::FieldId fieldId) const
Is a field present?
bool | IsInitialized () const
Is the object initialized.
bool | IsPartialSubset (const FieldListValidator &rhs) const
Are any of the fields in this FieldListValidator present in rhs?
bool | IsSubset (const FieldListValidator &rhs) const
Are the fields in this FieldListValidator a subset of the fields in rhs?
ACTIV_FEED_API_COMMON_API
FieldListValidator & 		operator= (const FieldListValidator &rhs)
Assignment operator.
ACTIV_FEED_API_COMMON_API void | Reset ()
Reset.
ACTIV_FEED_API_COMMON_API | ~FieldListValidator ()
Destructor.

Friends

class | ContentGateway::FieldListValidator
class | ContentGatewayApi::FieldListValidator
class | ContentServerApi::FieldListValidator

Classes

class | CachedField
class | ConstIterator
Const iterator class. More...
class | Field
Field class. More...

Detailed Description

Field list validator class.

Note this class is not thread safe. Do not make concurrent calls to its methods from multiple threads.

Definition at line 38 of file FieldListValidator.h.

Constructor & Destructor Documentation

ACTIV_FEED_API_COMMON_API Activ::ContentPlatform::FeedApi::FieldListValidator::FieldListValidator ( const FieldListValidator & rhs )

Copy constructor.

Parameters:
rhs the value to assign to this object.

Member Function Documentation

ACTIV_FEED_API_COMMON_API StatusCode Activ::ContentPlatform::FeedApi::FieldListValidator::ApplyUpdate ( const FieldListValidator & fieldListValidator )

Apply all fields in another FieldListValidator to this.

This call differs from an Initialize() call in that existing fields are not cleared. Note fields in fieldListValidator that have the rule RULE_DOES_NOT_UPDATE_LAST_VALUE will not be applied to this.

Parameters:
fieldListValidator the fields to apply.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT
STATUS_CODE_HEAP_EMPTY
...

ACTIV_FEED_API_COMMON_API StatusCode Activ::ContentPlatform::FeedApi::FieldListValidator::ApplyUpdateToExistingFieldsOnly ( const FieldListValidator & fieldListValidator )

Apply only the fields from another FieldListValidator to this that already exist in this.

This call differs from an Initialize() call in that existing fields are not cleared. Note fields in fieldListValidator that have the rule RULE_DOES_NOT_UPDATE_LAST_VALUE will not be applied to this.

Parameters:
fieldListValidator the fields to apply.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT
STATUS_CODE_HEAP_EMPTY
...

ACTIV_FEED_API_COMMON_API ConstIterator Activ::ContentPlatform::FeedApi::FieldListValidator::Begin ( ) const

Get an iterator to the first field in the message.

Returns:
an iterator object.
Exceptions:
StatusCodeException

ACTIV_FEED_API_COMMON_API void Activ::ContentPlatform::FeedApi::FieldListValidator::Clear ( )

Clear.

Clears all cached fields.

ACTIV_FEED_API_COMMON_API ConstIterator Activ::ContentPlatform::FeedApi::FieldListValidator::End ( ) const

Get an iterator that points to beyond the last field in the message.

Returns:
an iterator object.
Exceptions:
StatusCodeException

template<typename T>
const T * Activ::ContentPlatform::FeedApi::FieldListValidator::GetActivFieldType ( const Feed::FieldId fieldId ) const [inline]

Get ACTIV field type.

Parameters:
fieldId the field id.
Returns:
Const pointer to a concrete ACTIV field type object.
Exceptions:
StatusCodeException,where m_errorCode is: STATUS_CODE_UNDEFINED field is undefined STATUS_CODE_NOT_FOUND field not present in record STATUS_CODE_INVALID_FIELD_TYPE template type T does not match the type of the field STATUS_CODE_ACCESS_DENIED not permissioned to see this field STATUS_CODE_NOT_INITIALIZED FieldListValidator not initialized STATUS_CODE_FAILURE some other failure

Definition at line 527 of file FieldListValidator.h.

References ACTIV_THROW_RESULT_IF, and GetActivFieldType().

template<typename T>
StatusCode Activ::ContentPlatform::FeedApi::FieldListValidator::GetActivFieldType | ( | const Feed::FieldId | fieldId,
 |  | const T *& | pFieldType |
 | ) |  |  | const [inline]

Get ACTIV field type.

Parameters:
fieldId | the field id.
pFieldType | reference to a pointer to a concrete ACTIV field type object.
Return values:
STATUS_CODE_SUCCESS | field is defined and pFieldType is set
STATUS_CODE_UNDEFINED | field is undefined
STATUS_CODE_NOT_FOUND | field not present
STATUS_CODE_INVALID_FIELD_TYPE | template type T does not match the type of the field
STATUS_CODE_ACCESS_DENIED | not permissioned to see this field
STATUS_CODE_NOT_INITIALIZED | FieldListValidator not initialized
STATUS_CODE_FAILURE

Definition at line 513 of file FieldListValidator.h.

References IsFieldPresent(), and IsInitialized().

Referenced by GetActivFieldType().

StatusCode Activ::ContentPlatform::FeedApi::FieldListValidator::GetField | ( | const Feed::FieldId | fieldId,
 |  | const Field *& | pField |
 | ) |  |  | const [inline]

Get a field.

Parameters:
fieldId | the field id.
pField | a pointer to the field.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_FOUND
STATUS_CODE_NOT_INITIALIZED

Definition at line 497 of file FieldListValidator.h.

References IsFieldPresent(), and IsInitialized().

size_t Activ::ContentPlatform::FeedApi::FieldListValidator::GetNumberOfFields ( ) const [inline]

Get the number of fields present.

Returns:
Number of fields in the object.

Definition at line 490 of file FieldListValidator.h.

bool Activ::ContentPlatform::FeedApi::FieldListValidator::IsFieldPresent ( const Feed::FieldId fieldId ) const [inline]

Is a field present?

Returns:
whether the specified field is present in the field list validator.

Definition at line 545 of file FieldListValidator.h.

Referenced by GetActivFieldType(), and GetField().

bool Activ::ContentPlatform::FeedApi::FieldListValidator::IsInitialized ( ) const [inline]

Is the object initialized.

Returns:
whether the object is initialized.

Definition at line 538 of file FieldListValidator.h.

Referenced by GetActivFieldType(), and GetField().

bool Activ::ContentPlatform::FeedApi::FieldListValidator::IsPartialSubset ( const FieldListValidator & rhs ) const [inline]

Are any of the fields in this FieldListValidator present in rhs?

Returns:
True if *any* of the fields present in this are present in rhs.

Definition at line 562 of file FieldListValidator.h.

References m_fieldIdPresentBitmap.

bool Activ::ContentPlatform::FeedApi::FieldListValidator::IsSubset ( const FieldListValidator & rhs ) const [inline]

Are the fields in this FieldListValidator a subset of the fields in rhs?

Returns:
True if *all* the fields present in this are present in rhs.

Definition at line 552 of file FieldListValidator.h.

References m_fieldIdPresentBitmap.

ACTIV_FEED_API_COMMON_API FieldListValidator& Activ::ContentPlatform::FeedApi::FieldListValidator::operator= ( const FieldListValidator & rhs )

Assignment operator.

Parameters:
rhs the value to assign to this object.
Returns:
a reference to this object.

ACTIV_FEED_API_COMMON_API void Activ::ContentPlatform::FeedApi::FieldListValidator::Reset ( )

Reset.

Resets list of fields present in message.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivFeedApiCommon/FieldListValidator.h
Generated on Wed Oct 8 14:02:10 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::FeedApi::FieldListValidator::ConstIterator

Activ::ContentPlatform::FeedApi::FieldListValidator::ConstIterator Class Reference

Const iterator class. More...

#include <ActivContentPlatform/ActivFeedApiCommon/FieldListValidator.h>

List of all members.

Public Member Functions

ConstIterator ()
Default constructor.
const Field & | GetField () const
Get the field.
Feed::FieldId | GetFieldId () const
Get the field id.
bool | operator!= (const ConstIterator &rhs) const
Inequality operator.
const ConstIterator | operator++ (int)
Postfix increment operator.
ConstIterator & operator++ ()
Prefix increment operator.
bool | operator== (const ConstIterator &rhs) const
Equality operator.

Friends

class | FieldListValidator

Detailed Description

Const iterator class.

Definition at line 98 of file FieldListValidator.h.

Member Function Documentation

const FieldListValidator::Field & Activ::ContentPlatform::FeedApi::FieldListValidator::ConstIterator::GetField ( ) const [inline]

Get the field.

Returns:
a reference to the field.

Definition at line 709 of file FieldListValidator.h.

References Activ::ContentPlatform::FeedApi::FieldListValidator::m_cachedFieldList.

Feed::FieldId Activ::ContentPlatform::FeedApi::FieldListValidator::ConstIterator::GetFieldId ( ) const [inline]

Get the field id.

Returns:
the field id.

Definition at line 702 of file FieldListValidator.h.

bool Activ::ContentPlatform::FeedApi::FieldListValidator::ConstIterator::operator!= ( const ConstIterator & rhs ) const [inline]

Inequality operator.

Parameters:
rhs the object to test against.
Returns:
whether the two objects are not equal.

Definition at line 695 of file FieldListValidator.h.

const FieldListValidator::ConstIterator Activ::ContentPlatform::FeedApi::FieldListValidator::ConstIterator::operator++ ( int ) [inline]

Postfix increment operator.

Returns:
a copy of the original object.

Definition at line 677 of file FieldListValidator.h.

FieldListValidator::ConstIterator & Activ::ContentPlatform::FeedApi::FieldListValidator::ConstIterator::operator++ ( ) [inline]

Prefix increment operator.

Returns:
a reference to the updated object.

Definition at line 668 of file FieldListValidator.h.

bool Activ::ContentPlatform::FeedApi::FieldListValidator::ConstIterator::operator== ( const ConstIterator & rhs ) const [inline]

Equality operator.

Parameters:
rhs the object to test against.
Returns:
whether the two objects are equal.

Definition at line 688 of file FieldListValidator.h.

References m_iterator, and m_pFieldListValidator.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivFeedApiCommon/FieldListValidator.h
Generated on Wed Oct 8 14:02:10 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::FeedApi::FieldListValidator::Field

Activ::ContentPlatform::FeedApi::FieldListValidator::Field Class Reference

Field class. More...

#include <ActivContentPlatform/ActivFeedApiCommon/FieldListValidator.h>

List of all members.

Public Types

typedef uint8_t | Rules
field rules type

Public Member Functions

ACTIV_FEED_API_COMMON_API | Field (const Feed::FieldId fieldId)
Constructor.
template<typename T>
const T * | GetActivFieldType () const
Get ACTIV field type.
template<typename T>
StatusCode | GetActivFieldType (const T *&pFieldType) const
Get ACTIV field type.

Public Attributes

const Feed::FieldId | m_fieldId
id of this field
FeedApi::FieldStatus | m_fieldStatus
status of this field
IFieldType * m_pIFieldType
field data, if FIELD_STATUS_DEFINED
Rules m_rules
rules for this field

Static Public Attributes

static const Rules | RULE_DOES_NOT_UPDATE_LAST_VALUE = 0x01
this is not the latest value for this field (e.g. a late trade)
static const Rules | RULE_NONE = 0x00

Detailed Description

Field class.

Definition at line 44 of file FieldListValidator.h.

Constructor & Destructor Documentation

ACTIV_FEED_API_COMMON_API Activ::ContentPlatform::FeedApi::FieldListValidator::Field::Field ( const Feed::FieldId fieldId )

Constructor.

Parameters:
fieldId

Member Function Documentation

template<typename T>
const T * Activ::ContentPlatform::FeedApi::FieldListValidator::Field::GetActivFieldType ( ) const [inline]

Get ACTIV field type.

Returns:
Const pointer to a concrete ACTIV field type object.
Exceptions:
StatusCodeException,where m_errorCode is: STATUS_CODE_UNDEFINED field is undefined STATUS_CODE_NOT_FOUND field not present in record STATUS_CODE_INVALID_FIELD_TYPE template type T does not match the type of the field STATUS_CODE_ACCESS_DENIED not permissioned to see this field STATUS_CODE_FAILURE some other failure

Definition at line 649 of file FieldListValidator.h.

References ACTIV_THROW_RESULT_IF.

template<typename T>
StatusCode Activ::ContentPlatform::FeedApi::FieldListValidator::Field::GetActivFieldType ( const T *& pFieldType ) const [inline]

Get ACTIV field type.

Parameters:
pFieldType reference to a const pointer to a concrete ACTIV field type object.
Return values:
STATUS_CODE_SUCCESS | field is defined and pFieldType is set
STATUS_CODE_UNDEFINED | field is undefined
STATUS_CODE_NOT_FOUND | field not present in record
STATUS_CODE_INVALID_FIELD_TYPE | template type T does not match the type of the field
STATUS_CODE_ACCESS_DENIED | not permissioned to see this field
STATUS_CODE_FAILURE | some other failure

Definition at line 621 of file FieldListValidator.h.

References Activ::IFieldType::GetType(), m_fieldStatus, and m_pIFieldType.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivFeedApiCommon/FieldListValidator.h
Generated on Wed Oct 8 14:02:10 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::FeedApi::SymbolPatternHelper

Activ::ContentPlatform::FeedApi::SymbolPatternHelper Class Reference

Symbol pattern helper. More...

#include <ActivContentPlatform/ActivContentServerApi/SymbolPatternHelper.h>

List of all members.

Public Member Functions

ACTIV_CONTENT_SERVER_API StatusCode | Initialize (const std::string &pattern)
Parse a pattern string and initialize.
ACTIV_CONTENT_SERVER_API bool | IsMatch (const std::string &str, const size_t fromPart) const
Match a string against the pattern, ignoring the first section of the pattern.
ACTIV_CONTENT_SERVER_API bool | IsPattern () const
Check if the pattern has a wildcard in it.
ACTIV_CONTENT_SERVER_API | SymbolPatternHelper ()
Default constructor.
virtual ACTIV_CONTENT_SERVER_API | ~SymbolPatternHelper ()
Destructor.

Detailed Description

Symbol pattern helper.

Parses symbol patterns and matches symbols against the pattern.

Definition at line 34 of file SymbolPatternHelper.h.

Member Function Documentation

ACTIV_CONTENT_SERVER_API StatusCode Activ::ContentPlatform::FeedApi::SymbolPatternHelper::Initialize ( const std::string & pattern )

Parse a pattern string and initialize.

Parameters:
pattern the string to parse. Format is A*B* Escape * with \*
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT

ACTIV_CONTENT_SERVER_API bool Activ::ContentPlatform::FeedApi::SymbolPatternHelper::IsMatch | ( | const std::string & | str,
 |  | const size_t | fromPart |
 | ) |  |  | const

Match a string against the pattern, ignoring the first section of the pattern.

Parameters:
str | the string to match.
fromPart | which part of the pattern to match from.
Returns:
true if matches.

ACTIV_CONTENT_SERVER_API bool Activ::ContentPlatform::FeedApi::SymbolPatternHelper::IsPattern ( ) const

Check if the pattern has a wildcard in it.

Returns:
true if pattern has wildcard.

The documentation for this class was generated from the following file:
  • include/ActivContentPlatform/ActivContentServerApi/SymbolPatternHelper.h
Generated on Wed Oct 8 14:02:10 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::CrcBlob

Activ::CrcBlob Class Reference

Crc blob class. More...

#include <ActivMiddleware/ActivFieldTypes/CrcBlob.h>

Inheritance diagram for Activ::CrcBlob:

Activ::IFieldType

List of all members.

Public Member Functions

virtual void | Clear ()
Clear the object.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		Compare (const void *const pRhsSerializedBody, const size_t rhsSerializedBodyLength, int &result) const
Compare.
ACTIV_FIELD_TYPES_API StatusCode | Compare (const CrcBlob &rhs, int &result) const
Compare.
StatusCode | Compress (bool shouldSerializeCompressed, bool shouldForceSerializeCompressed=false)
Compress.
StatusCode | Compress () const
Compress.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		Convert (const IFieldType *const pIFieldType)
Convert another IFieldType object to this type.
CrcBlob (const CrcBlob &rhs)
Copy constructor.
CrcBlob (const uint8_t *const pData, const size_t size)
Constructor.
CrcBlob (const uint32_t crc, const uint8_t *const pData, const size_t size, const size_t sizeWhenDecompressed)
Constructor.
CrcBlob ()
Default constructor.
StatusCode | Decompress (bool shouldSerializeDecompressed)
Decompress.
StatusCode | Decompress () const
Decompress.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		Deserialize (MessageValidator &messageValidator, const size_t maxSerializedBodyLength)
Deserialize the object from the supplied message validator.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		DeserializeBody (const void *const pSerializedBody, const size_t serializedBodyLength)
Deserialize the object's body from the supplied data buffer.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		DeserializeLengthAndBody (MessageValidator &messageValidator, const size_t maxSerializedBodyLength=MAX_SERIALIZED_BODY_LENGTH_UNDEFINED)
Deserialize the object's length and body from the supplied message validator.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		FromString (MessageValidator &messageValidator)
Convert the object from a string.
StatusCode | Get (const uint8_t *&pData, size_t &size) const
Get the data and size.
StatusCode | Get (uint32_t &crc, const uint8_t *&pData, size_t &size, size_t &sizeWhenDecompressed) const
Get the crc, data, size and decompressed size.
uint32_t | GetCrc () const
Get the crc of the data.
uint32_t | GetCrcCompressed () const
Get the crc of the data compressed.
uint32_t | GetCrcDecompressed () const
Get the crc of the data decompressed.
const uint8_t * | GetData () const
Get the data.
const uint8_t * | GetDataCompressed () const
Get the data compressed.
const uint8_t * | GetDataDecompressed () const
Get the data decompressed.
virtual ACTIV_FIELD_TYPES_API
std::string 		GetFromStringFormat () const
Get a usage string for the format supported by FromString().
virtual size_t | GetSerializedBodyLength () const
Get the serialized length of the object's body.
virtual size_t | GetSerializedLength () const
Get the serialized length of the object.
size_t | GetSize () const
Get the size of the data.
size_t | GetSizeCompressed () const
Get the size of the data compressed.
size_t | GetSizeDecompressed () const
Get the size of the data decompressed.
size_t | GetSizeWhenDecompressed () const
Get the size when decompressed.
bool | IsCompressed () const
Is the data compressed.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		IsDifferent (const void *const pRhsSerializedBody, const size_t rhsSerializedBodyLength, bool &isDifferent) const
Is different.
CrcBlob & | operator= (const CrcBlob &rhs)
Assignment operator.
virtual void | Reset ()
Reset the object.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		Serialize (MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength) const
Serialize the object into the supplied message builder.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		SerializeBody (void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength) const
Serialize the object's body into the supplied data buffer.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		SerializeLengthAndBody (MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength=MAX_SERIALIZED_BODY_LENGTH_UNDEFINED) const
Serialize the object's length and body into the supplied message builder.
StatusCode | Set (const uint8_t *const pData, const size_t size)
Set the data and size.
StatusCode | Set (const uint32_t crc, const uint8_t *const pData, const size_t size, const size_t sizeWhenDecompressed)
Set the crc, data, size and decompressed size.
virtual ACTIV_FIELD_TYPES_API
std::string 		ToString (const bool isHexFormat) const
Convert the object to a string.
virtual ACTIV_FIELD_TYPES_API
std::string 		ToString () const
Convert the object to a string.
virtual | ~CrcBlob ()
Destructor.

Static Public Member Functions

static ACTIV_FIELD_TYPES_API
uint32_t 		CalculateCrc (const uint8_t *const pData, const size_t size, const uint32_t intitialCrc=0)
Calculate the crc.
static ACTIV_FIELD_TYPES_API
StatusCode 		Compare (const void *const pLhsSerializedBody, const size_t lhsSerializedBodyLength, const void *const pRhsSerializedBody, const size_t rhsSerializedBodyLength, int &result)
Compare two objects serialized bodies.
static StatusCode | Compress (const uint8_t *const pSource, const size_t sourceLength, uint8_t *const pTarget, const size_t targetSize, size_t &targetLength)
Compress a buffer.
static StatusCode | Decompress (const uint8_t *const pSource, const size_t sourceLength, uint8_t *const pTarget, const size_t targetSize, size_t &targetLength)
Decompress a buffer.
static ACTIV_FIELD_TYPES_API
StatusCode 		Deserialize (MessageValidator &messageValidator, const size_t maxSerializedBodyLength, uint32_t &crc, const uint8_t *&pData, size_t &size, size_t &sizeWhenDecompressed)
Deserialize the object from the supplied message validator.
static ACTIV_FIELD_TYPES_API
StatusCode 		DeserializeBody (const void *const pSerializedBody, const size_t serializedBodyLength, uint32_t &crc, const uint8_t *&pData, size_t &size, size_t &sizeWhenDecompressed)
Deserialize the object's body from the supplied data buffer.
static ACTIV_FIELD_TYPES_API
StatusCode 		DeserializeLengthAndBody (MessageValidator &messageValidator, const size_t maxSerializedBodyLength, uint32_t &crc, const uint8_t *&pData, size_t &size, size_t &sizeWhenDecompressed)
Deserialize the object's length and body from the supplied message validator.
static size_t | GetMaxSerializedBodyLength (const size_t size)
Get the maximum serialized length of the object's body.
static size_t | GetMaxSerializedLength (const size_t size)
Get the maximum serialized length of the object.
static bool | IsValidSerializedBodyLength (const size_t serializedBodyLength)
Is valid serialized body length.
static ACTIV_FIELD_TYPES_API
StatusCode 		Serialize (MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength, const uint32_t crc, const uint8_t *const pData, const size_t size, const size_t sizeWhenDecompressed=0)
Serialize the object into the supplied message builder.
static ACTIV_FIELD_TYPES_API
StatusCode 		SerializeBody (void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength, const uint32_t crc, const uint8_t *const pData, const size_t size, const size_t sizeWhenDecompressed=0)
Serialize the object's body into the supplied data buffer.
static ACTIV_FIELD_TYPES_API
StatusCode 		SerializeLengthAndBody (MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength, const uint32_t crc, const uint8_t *const pData, const size_t size, const size_t sizeWhenDecompressed=0)
Serialize the object's length and body into the supplied message builder.
static ACTIV_FIELD_TYPES_API
StatusCode 		ValidateSerializedLengthAndBody (MessageValidator &messageValidator, size_t &serializedBodyOffset, size_t &serializedBodyLength)
Validate the serialized length and body.

Static Public Attributes

static const FieldType | FIELD_TYPE = FIELD_TYPE_CRC_BLOB
The field type.

Detailed Description

Crc blob class.

Definition at line 33 of file CrcBlob.h.

Constructor & Destructor Documentation

Activ::CrcBlob::CrcBlob | ( | const uint32_t | crc,
 |  | const uint8_t *const | pData,
 |  | const size_t | size,
 |  | const size_t | sizeWhenDecompressed |
 | ) |  |  | [inline]

Constructor.

Parameters:
crc | the crc.
pData | pointer to the data.
size | the size of the data.
sizeWhenDecompressed | indicates the size of the data when decompressed (zero indicates not compressed).
Exceptions:
StatusCodeException

Definition at line 555 of file CrcBlob.h.

References ACTIV_THROW_RESULT_IF, and Set().

Activ::CrcBlob::CrcBlob | ( | const uint8_t *const | pData,
 |  | const size_t | size |
 | ) |  |  | [inline]

Constructor.

The data will be stored compressed (if size >= compressed size).

Parameters:
pData | pointer to the data.
size | the size of the data.
Exceptions:
StatusCodeException

Definition at line 565 of file CrcBlob.h.

References ACTIV_THROW_RESULT_IF, and Set().

Activ::CrcBlob::CrcBlob ( const CrcBlob & rhs ) [inline]

Copy constructor.

Parameters:
rhs the value to assign to this object.

Definition at line 575 of file CrcBlob.h.

References ACTIV_THROW_RESULT_IF, Activ::IFieldType::IsInitialized(), m_crc, Activ::IFieldType::m_isInitialized, m_pData, m_size, m_sizeWhenDecompressed, and Set().

Member Function Documentation

static ACTIV_FIELD_TYPES_API uint32_t Activ::CrcBlob::CalculateCrc | ( | const uint8_t *const | pData,
 |  | const size_t | size,
 |  | const uint32_t | intitialCrc = 0 |
 | ) |  |  | [static]

Calculate the crc.

Parameters:
pData | pointer to the data.
size | the size of the data.
intitialCrc | the initial crc value to be used.
Returns:
the crc.

Referenced by Compress(), Decompress(), and Set().

static ACTIV_FIELD_TYPES_API StatusCode Activ::CrcBlob::Compare | ( | const void *const | pLhsSerializedBody,
 |  | const size_t | lhsSerializedBodyLength,
 |  | const void *const | pRhsSerializedBody,
 |  | const size_t | rhsSerializedBodyLength,
 |  | int & | result |
 | ) |  |  | [static]

Compare two objects serialized bodies.

Parameters:
pLhsSerializedBody | the buffer containing the lhs serialized version of the object's body in.
lhsSerializedBodyLength | the lhs serialized body length.
pRhsSerializedBody | the buffer containing the rhs serialized version of the object's body in.
rhsSerializedBodyLength | the rhs serialized body length.
result | the result of the comparison.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::CrcBlob::Compare | ( | const void *const | pRhsSerializedBody,
 |  | const size_t | rhsSerializedBodyLength,
 |  | int & | result |
 | ) |  |  | const [virtual]

Compare.

Parameters:
pRhsSerializedBody | the buffer containing the rhs serialized version of the object's body in.
rhsSerializedBodyLength | the rhs serialized body length.
result | the result of the comparison.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

ACTIV_FIELD_TYPES_API StatusCode Activ::CrcBlob::Compare | ( | const CrcBlob & | rhs,
 |  | int & | result |
 | ) |  |  | const

Compare.

Parameters:
rhs | the object to compare with.
result | the result of the comparison.
Return values:
STATUS_CODE_SUCCESS

StatusCode Activ::CrcBlob::Compress | ( | const uint8_t *const | pSource,
 |  | const size_t | sourceLength,
 |  | uint8_t *const | pTarget,
 |  | const size_t | targetSize,
 |  | size_t & | targetLength |
 | ) |  |  | [inline, static]

Compress a buffer.

Parameters:
pSource | the source buffer.
sourceLength | the source buffer length.
pTarget | the target buffer.
targetSize | the size of the target buffer.
targetLength | the target buffer length.
Return values:
STATUS_CODE_SUCCESS
...

Definition at line 976 of file CrcBlob.h.

StatusCode Activ::CrcBlob::Compress | ( | bool | shouldSerializeCompressed,
 |  | bool | shouldForceSerializeCompressed = false |
 | ) |  |  | [inline]

Compress.

Parameters:
shouldSerializeCompressed | indicates whether the object should be serialized compressed (only if compressed size < decompressed size).
shouldForceSerializeCompressed | indicates whether should force the object should be serialized compressed.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_HEAP_EMPTY
STATUS_CODE_NOT_INITIALIZED
...

Definition at line 885 of file CrcBlob.h.

References ACTIV_RETURN_RESULT_IF, and Compress().

StatusCode Activ::CrcBlob::Compress ( ) const [inline]

Compress.

Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_HEAP_EMPTY
STATUS_CODE_NOT_INITIALIZED
...

Definition at line 854 of file CrcBlob.h.

References ACTIV_RETURN_RESULT_IF, CalculateCrc(), and Activ::IFieldType::IsInitialized().

Referenced by Compress(), GetCrcCompressed(), GetDataCompressed(), GetSizeCompressed(), and Set().

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::CrcBlob::Convert ( const IFieldType *const pIFieldType ) [virtual]

Convert another IFieldType object to this type.

Parameters:
pIFieldType the value to assign from.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_MISMATCH
...

Implements Activ::IFieldType.

StatusCode Activ::CrcBlob::Decompress | ( | const uint8_t *const | pSource,
 |  | const size_t | sourceLength,
 |  | uint8_t *const | pTarget,
 |  | const size_t | targetSize,
 |  | size_t & | targetLength |
 | ) |  |  | [inline, static]

Decompress a buffer.

Parameters:
pSource | the source buffer.
sourceLength | the source buffer length.
pTarget | the target buffer.
targetSize | the size of the target buffer.
targetLength | the target buffer length.
Return values:
STATUS_CODE_SUCCESS
...

Definition at line 983 of file CrcBlob.h.

StatusCode Activ::CrcBlob::Decompress ( bool shouldSerializeDecompressed ) [inline]

Decompress.

Parameters:
shouldSerializeDecompressed indicates whether the object should be serialized decompressed.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_HEAP_EMPTY
STATUS_CODE_NOT_INITIALIZED
...

Definition at line 931 of file CrcBlob.h.

References ACTIV_RETURN_RESULT_IF, and Decompress().

StatusCode Activ::CrcBlob::Decompress ( ) const [inline]

Decompress.

Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_HEAP_EMPTY
STATUS_CODE_NOT_INITIALIZED
...

Definition at line 902 of file CrcBlob.h.

References ACTIV_RETURN_RESULT_IF, CalculateCrc(), and Activ::IFieldType::IsInitialized().

Referenced by Decompress(), Get(), GetCrcDecompressed(), GetDataDecompressed(), and GetSizeDecompressed().

static ACTIV_FIELD_TYPES_API StatusCode Activ::CrcBlob::Deserialize | ( | MessageValidator & | messageValidator,
 |  | const size_t | maxSerializedBodyLength,
 |  | uint32_t & | crc,
 |  | const uint8_t *& | pData,
 |  | size_t & | size,
 |  | size_t & | sizeWhenDecompressed |
 | ) |  |  | [static]

Deserialize the object from the supplied message validator.

Parameters:
messageValidator | the message validator from which the object will be extracted.
maxSerializedBodyLength | the maximum serialized body length.
crc | the crc.
pData | pointer to the data.
size | the size of the data.
sizeWhenDecompressed | indicates the size of the data when decompressed (zero indicates not compressed).
Return values:
STATUS_CODE_SUCCESS
...

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::CrcBlob::Deserialize | ( | MessageValidator & | messageValidator,
 |  | const size_t | maxSerializedBodyLength |
 | ) |  |  | [virtual]

Deserialize the object from the supplied message validator.

Parameters:
messageValidator | the message validator from which the object will be extracted.
maxSerializedBodyLength | the maximum serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

static ACTIV_FIELD_TYPES_API StatusCode Activ::CrcBlob::DeserializeBody | ( | const void *const | pSerializedBody,
 |  | const size_t | serializedBodyLength,
 |  | uint32_t & | crc,
 |  | const uint8_t *& | pData,
 |  | size_t & | size,
 |  | size_t & | sizeWhenDecompressed |
 | ) |  |  | [static]

Deserialize the object's body from the supplied data buffer.

Parameters:
pSerializedBody | the buffer from which the object's body will be extracted.
serializedBodyLength | the serialized body length.
crc | the crc.
pData | pointer to the data.
size | the size of the data.
sizeWhenDecompressed | indicates the size of the data when decompressed (zero indicates not compressed).
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
...

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::CrcBlob::DeserializeBody | ( | const void *const | pSerializedBody,
 |  | const size_t | serializedBodyLength |
 | ) |  |  | [virtual]

Deserialize the object's body from the supplied data buffer.

Parameters:
pSerializedBody | the buffer from which the object's body will be extracted.
serializedBodyLength | the serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

static ACTIV_FIELD_TYPES_API StatusCode Activ::CrcBlob::DeserializeLengthAndBody | ( | MessageValidator & | messageValidator,
 |  | const size_t | maxSerializedBodyLength,
 |  | uint32_t & | crc,
 |  | const uint8_t *& | pData,
 |  | size_t & | size,
 |  | size_t & | sizeWhenDecompressed |
 | ) |  |  | [static]

Deserialize the object's length and body from the supplied message validator.

Parameters:
messageValidator | the message validator from which the object will be extracted.
maxSerializedBodyLength | the maximum serialized body length.
crc | the crc.
pData | pointer to the data.
size | the size of the data.
sizeWhenDecompressed | indicates the size of the data when decompressed (zero indicates not compressed).
Return values:
STATUS_CODE_SUCCESS
...

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::CrcBlob::DeserializeLengthAndBody | ( | MessageValidator & | messageValidator,
 |  | const size_t | maxSerializedBodyLength = MAX_SERIALIZED_BODY_LENGTH_UNDEFINED |
 | ) |  |  | [virtual]

Deserialize the object's length and body from the supplied message validator.

Parameters:
messageValidator | the message validator from which the object will be extracted.
maxSerializedBodyLength | the maximum serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::CrcBlob::FromString ( MessageValidator & messageValidator ) [virtual]

Convert the object from a string.

Parameters:
messageValidator the message validator.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

StatusCode Activ::CrcBlob::Get | ( | const uint8_t *& | pData,
 |  | size_t & | size |
 | ) |  |  | const [inline]

Get the data and size.

The data will be returned uncompressed.

Parameters:
pData | pointer to the data.
size | the size of the data.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_HEAP_EMPTY
STATUS_CODE_NOT_INITIALIZED
...

Definition at line 708 of file CrcBlob.h.

References ACTIV_RETURN_RESULT_IF, and Decompress().

StatusCode Activ::CrcBlob::Get | ( | uint32_t & | crc,
 |  | const uint8_t *& | pData,
 |  | size_t & | size,
 |  | size_t & | sizeWhenDecompressed |
 | ) |  |  | const [inline]

Get the crc, data, size and decompressed size.

Parameters:
crc | the crc.
pData | pointer to the data.
size | the size of the data.
sizeWhenDecompressed | indicates the size of the data when decompressed (zero indicates not compressed).
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED

Definition at line 693 of file CrcBlob.h.

References Activ::IFieldType::IsInitialized().

uint32_t Activ::CrcBlob::GetCrc ( ) const [inline]

Get the crc of the data.

Returns:
the crc of the data.
Exceptions:
StatusCodeException

Definition at line 720 of file CrcBlob.h.

References ACTIV_THROW, and Activ::IFieldType::IsInitialized().

uint32_t Activ::CrcBlob::GetCrcCompressed ( ) const [inline]

Get the crc of the data compressed.

Returns:
the crc of the data compressed.
Exceptions:
StatusCodeException

Definition at line 760 of file CrcBlob.h.

References ACTIV_THROW_RESULT_IF, and Compress().

uint32_t Activ::CrcBlob::GetCrcDecompressed ( ) const [inline]

Get the crc of the data decompressed.

Returns:
the crc of the data decompressed.
Exceptions:
StatusCodeException

Definition at line 787 of file CrcBlob.h.

References ACTIV_THROW_RESULT_IF, and Decompress().

const uint8_t * Activ::CrcBlob::GetData ( ) const [inline]

Get the data.

Returns:
the pointer to the data.
Exceptions:
StatusCodeException

Definition at line 730 of file CrcBlob.h.

References ACTIV_THROW, and Activ::IFieldType::IsInitialized().

const uint8_t * Activ::CrcBlob::GetDataCompressed ( ) const [inline]

Get the data compressed.

Returns:
the pointer to the data compressed.
Exceptions:
StatusCodeException

Definition at line 769 of file CrcBlob.h.

References ACTIV_THROW_RESULT_IF, and Compress().

const uint8_t * Activ::CrcBlob::GetDataDecompressed ( ) const [inline]

Get the data decompressed.

Returns:
the pointer to the data decompressed.
Exceptions:
StatusCodeException

Definition at line 796 of file CrcBlob.h.

References ACTIV_THROW_RESULT_IF, and Decompress().

virtual ACTIV_FIELD_TYPES_API std::string Activ::CrcBlob::GetFromStringFormat ( ) const [virtual]

Get a usage string for the format supported by FromString().

Returns:
String, may be empty.

Implements Activ::IFieldType.

size_t Activ::CrcBlob::GetMaxSerializedBodyLength ( const size_t size ) [inline, static]

Get the maximum serialized length of the object's body.

Parameters:
size the size of the data.
Returns:
the maximum serialized length of the object's body.

Definition at line 962 of file CrcBlob.h.

Referenced by GetMaxSerializedLength(), GetSerializedBodyLength(), and IsValidSerializedBodyLength().

size_t Activ::CrcBlob::GetMaxSerializedLength ( const size_t size ) [inline, static]

Get the maximum serialized length of the object.

Parameters:
size the size of the data.
Returns:
the maximum serialized length of the object.

Definition at line 955 of file CrcBlob.h.

References GetMaxSerializedBodyLength().

Referenced by GetSerializedLength().

size_t Activ::CrcBlob::GetSerializedBodyLength ( ) const [inline, virtual]

Get the serialized length of the object's body.

Returns:
the serialized length of the object's body.

Implements Activ::IFieldType.

Definition at line 847 of file CrcBlob.h.

References GetMaxSerializedBodyLength(), and Activ::IFieldType::IsInitialized().

size_t Activ::CrcBlob::GetSerializedLength ( ) const [inline, virtual]

Get the serialized length of the object.

Returns:
the serialized length of the object.

Implements Activ::IFieldType.

Definition at line 840 of file CrcBlob.h.

References GetMaxSerializedLength(), and Activ::IFieldType::IsInitialized().

size_t Activ::CrcBlob::GetSize ( ) const [inline]

Get the size of the data.

Returns:
the size of the data.
Exceptions:
StatusCodeException

Definition at line 740 of file CrcBlob.h.

References ACTIV_THROW, and Activ::IFieldType::IsInitialized().

size_t Activ::CrcBlob::GetSizeCompressed ( ) const [inline]

Get the size of the data compressed.

Returns:
the size of the data compressed.
Exceptions:
StatusCodeException

Definition at line 778 of file CrcBlob.h.

References ACTIV_THROW_RESULT_IF, and Compress().

size_t Activ::CrcBlob::GetSizeDecompressed ( ) const [inline]

Get the size of the data decompressed.

Returns:
the size of the data decompressed.
Exceptions:
StatusCodeException

Definition at line 805 of file CrcBlob.h.

References ACTIV_THROW_RESULT_IF, and Decompress().

size_t Activ::CrcBlob::GetSizeWhenDecompressed ( ) const [inline]

Get the size when decompressed.

Returns:
the size of the data when decompressed (zero indicates not compressed).
Exceptions:
StatusCodeException

Definition at line 750 of file CrcBlob.h.

References ACTIV_THROW, and Activ::IFieldType::IsInitialized().

bool Activ::CrcBlob::IsCompressed ( ) const [inline]

Is the data compressed.

Returns:
whether the data is compressed.

Definition at line 948 of file CrcBlob.h.

References Activ::IFieldType::IsInitialized().

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::CrcBlob::IsDifferent | ( | const void *const | pRhsSerializedBody,
 |  | const size_t | rhsSerializedBodyLength,
 |  | bool & | isDifferent |
 | ) |  |  | const [virtual]

Is different.

Parameters:
pRhsSerializedBody | the buffer containing the rhs serialized version of the object's body in.
rhsSerializedBodyLength | the rhs serialized body length.
isDifferent | indicates whether the two objects are different.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

bool Activ::CrcBlob::IsValidSerializedBodyLength ( const size_t serializedBodyLength ) [inline, static]

Is valid serialized body length.

Parameters:
serializedBodyLength the serialized body length.
Returns:
whether the serialized body length is valid.

Definition at line 969 of file CrcBlob.h.

References GetMaxSerializedBodyLength().

CrcBlob & Activ::CrcBlob::operator= ( const CrcBlob & rhs ) [inline]

Assignment operator.

Parameters:
rhs the value to assign to this object.
Returns:
a reference to this object.

Definition at line 598 of file CrcBlob.h.

References ACTIV_THROW_RESULT_IF, Activ::IFieldType::IsInitialized(), m_crc, m_pData, m_size, m_sizeWhenDecompressed, Reset(), and Set().

static ACTIV_FIELD_TYPES_API StatusCode Activ::CrcBlob::Serialize | ( | MessageBuilder & | messageBuilder,
 |  | const size_t | maxSerializedBodyLength,
 |  | const uint32_t | crc,
 |  | const uint8_t *const | pData,
 |  | const size_t | size,
 |  | const size_t | sizeWhenDecompressed = 0 |
 | ) |  |  | [static]

Serialize the object into the supplied message builder.

Parameters:
messageBuilder | the message builder to store a serialized version of the object in.
maxSerializedBodyLength | the maximum serialized body length.
crc | the crc.
pData | pointer to the data.
size | the size of the data.
sizeWhenDecompressed | indicates the size of the data when decompressed (zero indicates not compressed).
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
...

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::CrcBlob::Serialize | ( | MessageBuilder & | messageBuilder,
 |  | const size_t | maxSerializedBodyLength |
 | ) |  |  | const [virtual]

Serialize the object into the supplied message builder.

Parameters:
messageBuilder | the message builder to store a serialized version of the object in.
maxSerializedBodyLength | the maximum serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

static ACTIV_FIELD_TYPES_API StatusCode Activ::CrcBlob::SerializeBody | ( | void * | pSerializedBody,
 |  | const size_t | maxSerializedBodyLength,
 |  | size_t & | serializedBodyLength,
 |  | const uint32_t | crc,
 |  | const uint8_t *const | pData,
 |  | const size_t | size,
 |  | const size_t | sizeWhenDecompressed = 0 |
 | ) |  |  | [static]

Serialize the object's body into the supplied data buffer.

Parameters:
pSerializedBody | the buffer to store a serialized version of the object's body in.
maxSerializedBodyLength | the maximum serialized body length.
serializedBodyLength | the serialized body length.
crc | the crc.
pData | pointer to the data.
size | the size of the data.
sizeWhenDecompressed | indicates the size of the data when decompressed (zero indicates not compressed).
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
...

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::CrcBlob::SerializeBody | ( | void * | pSerializedBody,
 |  | const size_t | maxSerializedBodyLength,
 |  | size_t & | serializedBodyLength |
 | ) |  |  | const [virtual]

Serialize the object's body into the supplied data buffer.

Parameters:
pSerializedBody | the buffer to store a serialized version of the object's body in.
maxSerializedBodyLength | the maximum serialized body length.
serializedBodyLength | the serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

static ACTIV_FIELD_TYPES_API StatusCode Activ::CrcBlob::SerializeLengthAndBody | ( | MessageBuilder & | messageBuilder,
 |  | const size_t | maxSerializedBodyLength,
 |  | const uint32_t | crc,
 |  | const uint8_t *const | pData,
 |  | const size_t | size,
 |  | const size_t | sizeWhenDecompressed = 0 |
 | ) |  |  | [static]

Serialize the object's length and body into the supplied message builder.

Parameters:
messageBuilder | the message builder to store a serialized version of the object in.
maxSerializedBodyLength | the maximum serialized body length.
crc | the crc.
pData | pointer to the data.
size | the size of the data.
sizeWhenDecompressed | indicates the size of the data when decompressed (zero indicates not compressed).
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
...

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::CrcBlob::SerializeLengthAndBody | ( | MessageBuilder & | messageBuilder,
 |  | const size_t | maxSerializedBodyLength = MAX_SERIALIZED_BODY_LENGTH_UNDEFINED |
 | ) |  |  | const [virtual]

Serialize the object's length and body into the supplied message builder.

Parameters:
messageBuilder | the message builder to store a serialized version of the object in.
maxSerializedBodyLength | the maximum serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

StatusCode Activ::CrcBlob::Set | ( | const uint8_t *const | pData,
 |  | const size_t | size |
 | ) |  |  | [inline]

Set the data and size.

The data will be stored compressed (only if compressed size < decompressed size).

Parameters:
pData | pointer to the data.
size | the size of the data.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_HEAP_EMPTY
STATUS_CODE_INVALID_PARAMETER
...

Definition at line 682 of file CrcBlob.h.

References ACTIV_RETURN_RESULT_IF, CalculateCrc(), Compress(), and Set().

StatusCode Activ::CrcBlob::Set | ( | const uint32_t | crc,
 |  | const uint8_t *const | pData,
 |  | const size_t | size,
 |  | const size_t | sizeWhenDecompressed |
 | ) |  |  | [inline]

Set the crc, data, size and decompressed size.

Parameters:
crc | the crc.
pData | pointer to the data.
size | the size of the data.
sizeWhenDecompressed | indicates the size of the data when decompressed (zero indicates not compressed).
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_HEAP_EMPTY
STATUS_CODE_INVALID_PARAMETER

Definition at line 617 of file CrcBlob.h.

References Activ::IFieldType::m_isInitialized.

Referenced by CrcBlob(), operator=(), and Set().

virtual ACTIV_FIELD_TYPES_API std::string Activ::CrcBlob::ToString ( const bool isHexFormat ) const [virtual]

Convert the object to a string.

Parameters:
isHexFormat indicates whether the data is copied in hex format.
Returns:
the object as a string.
Exceptions:
StatusCodeException

virtual ACTIV_FIELD_TYPES_API std::string Activ::CrcBlob::ToString ( ) const [virtual]

Convert the object to a string.

Returns:
the object as a string.

Implements Activ::IFieldType.

static ACTIV_FIELD_TYPES_API StatusCode Activ::CrcBlob::ValidateSerializedLengthAndBody | ( | MessageValidator & | messageValidator,
 |  | size_t & | serializedBodyOffset,
 |  | size_t & | serializedBodyLength |
 | ) |  |  | [static]

Validate the serialized length and body.

Parameters:
messageValidator | the message validator.
serializedBodyOffset | the serialized body offset.
serializedBodyLength | the serialized body length.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_HEAP_EMPTY
STATUS_CODE_INVALID_PARAMETER
...

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivFieldTypes/CrcBlob.h
Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::CrtException

Activ::CrtException Class Reference

C runtime exception class. More...

#include <ActivMiddleware/ActivBase/CrtException.h>

Inheritance diagram for Activ::CrtException:

Activ::Exception

List of all members.

Public Member Functions

ACTIV_BASE_EXPORTED_API CrtException (const char *file, const char *function, uint_fast32_t line, const uint_fast32_t errorCode)
Default constructor.
virtual
ACTIV_BASE_EXPORTED_API
std::string 		ToString () const
Convert the exception error code to a string.

Detailed Description

C runtime exception class.

CrtException encapsulates errors from c run time library calls.

Definition at line 22 of file CrtException.h.

Constructor & Destructor Documentation

ACTIV_BASE_EXPORTED_API Activ::CrtException::CrtException | ( | const char * | file,
 |  | const char * | function,
 |  | uint_fast32_t | line,
 |  | const uint_fast32_t | errorCode
 | ) |  |

Default constructor.

Parameters:
file | the file which raised the exception.
function | the function which raised the exception.
line | the line number which raised the exception.
errorCode | the exception specific error code.

Member Function Documentation

virtual ACTIV_BASE_EXPORTED_API std::string Activ::CrtException::ToString ( ) const [virtual]

Convert the exception error code to a string.

Classes derived from Exception are required to implement ToString() to convert their error codes to a readable string.

Returns:
the error code as a string.

Reimplemented from Activ::Exception.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivBase/CrtException.h
Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::CtrlHandler

Activ::CtrlHandler Class Reference

Ctrl handler class. More...

#include <ActivMiddleware/ActivBase/CtrlHandler.h>

List of all members.

Public Types

enum EventType {
CTRL_C, CTRL_BREAK, CTRL_EXIT_PROCESS, CTRL_LOGOFF_USER,
CTRL_SHUTDOWN_MACHINE
}
List of ctrl event types.

Public Member Functions

ACTIV_BASE_EXPORTED_API | CtrlHandler ()
Constructor.
virtual ACTIV_BASE_EXPORTED_API | ~CtrlHandler ()
Destructor.

Protected Member Functions

virtual
ACTIV_BASE_EXPORTED_API bool 		OnEvent (const EventType eventType)
Callback when a ctrl event occurs.

Detailed Description

Ctrl handler class.

Note only one instance of CtrlHandler is allowed on the Windows platform (per process).

Definition at line 31 of file CtrlHandler.h.

Constructor & Destructor Documentation

ACTIV_BASE_EXPORTED_API Activ::CtrlHandler::CtrlHandler ( )

Constructor.

Exceptions:
Exception if the handler could not be installed.

Member Function Documentation

virtual ACTIV_BASE_EXPORTED_API bool Activ::CtrlHandler::OnEvent ( const EventType eventType ) [protected, virtual]

Callback when a ctrl event occurs.

No guarantees are provided about which thread will invoke this callback.

Parameters:
eventType the type of ctrl event that has occured.
Return values:
true | if the event has been handled.
false | if the event has not been handled.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivBase/CtrlHandler.h
Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::CurlFtpHelper

Activ::CurlFtpHelper Class Reference

CurlFtpHelper class. More...

#include <ActivMiddleware/Misc/CurlFtpHelper.h>

Inheritance diagram for Activ::CurlFtpHelper:

Activ::IFtpHelper

List of all members.

Public Member Functions

virtual StatusCodeHelper | Connect ()
Connect to the server.
CurlFtpHelper (const std::string &server, const std::string &username="", const std::string &password="", uint32_t port=IFtpHelper::DEFAULT_FTP_PORT, bool useEpsv=false, const std::string &curlLogFilename="", uint32_t timeout=IFtpHelper::DEFAULT_FTP_TIMEOUT, uint32_t lowSpeedLimit=IFtpHelper::DEFAULT_FTP_LOW_SPEED_LIMIT, uint32_t lowSpeedTime=IFtpHelper::DEFAULT_FTP_LOW_SPEED_TIME)
Constuctor.
virtual StatusCodeHelper | DeleteFile (const FileInfoList &fileInfoList, const std::string &remoteDirectory="")
Delete list of file.
virtual StatusCodeHelper | DeleteFile (const std::string &remoteFilename, const std::string &remoteDirectory="")
Delete a file.
virtual StatusCodeHelper | Disconnect ()
Disconnects from the server.
virtual StatusCodeHelper | GetAndDeleteFile (const std::string &remoteFilename, const std::string &localFilename, const std::string &remoteDirectory="")
Get and delete a file.
virtual StatusCodeHelper | GetFile (const std::string &remoteFilename, const std::string &localFilename, const std::string &remoteDirectory="")
Get a file.
virtual StatusCodeHelper | GetFileList (FileInfoList &fileInfoList, const std::string &remoteDirectory="")
Get the names of files from the server.
uint32_t | GetLowSpeedLimit () const
uint32_t | GetLowSpeedTime () const
uint32_t | GetTimeout () const
Get functions.
bool | GetUseEpsv () const
virtual bool | IsConnected () const
Is connected.
void | SetCurlLogFilename (const std::string &logFilename)
void | SetLowSpeedLimit (uint32_t lowSpeedLimit)
void | SetLowSpeedTime (uint32_t lowSpeedTime)
void | SetTimeout (uint32_t timeout)
Set functions.
void | SetUseEpsv (bool useEpsv)

Static Public Member Functions

static void | CleanUp ()
CleanUp the curl lib, once per app.
static void | Initialize ()
Initialize the curl lib, once per app.

Classes

class | CallbackData
class | CurlInitializeHelper
CurlInitializeHelper class. More...
class | FileListCallbackData
class | GetFileCallbackData

Detailed Description

CurlFtpHelper class.

Definition at line 34 of file CurlFtpHelper.h.

Constructor & Destructor Documentation

Activ::CurlFtpHelper::CurlFtpHelper | ( | const std::string & | server,
 |  | const std::string & | username = "",
 |  | const std::string & | password = "",
 |  | uint32_t | port = IFtpHelper::DEFAULT_FTP_PORT,
 |  | bool | useEpsv = false,
 |  | const std::string & | curlLogFilename = "",
 |  | uint32_t | timeout = IFtpHelper::DEFAULT_FTP_TIMEOUT,
 |  | uint32_t | lowSpeedLimit = IFtpHelper::DEFAULT_FTP_LOW_SPEED_LIMIT,
 |  | uint32_t | lowSpeedTime = IFtpHelper::DEFAULT_FTP_LOW_SPEED_TIME |
 | ) |  |  | [inline]

Constuctor.

Parameters:
server | the name of the ftp server.
username | the user name if required.
password | the password if required.
port | the ftp port to connect to.
useEpsv | something to do with 32 bit or 64 bit ip address etc
curlLogFilename | for detail curl ftp log
timeout
lowSpeedLimit
lowSpeedTime

Definition at line 182 of file CurlFtpHelper.h.

References Activ::IFtpHelper::m_password, and Activ::IFtpHelper::m_username.

Member Function Documentation

StatusCodeHelper Activ::CurlFtpHelper::DeleteFile | ( | const FileInfoList & | fileInfoList,
 |  | const std::string & | remoteDirectory = "" |
 | ) |  |  | [inline, virtual]

Delete list of file.

Parameters:
fileInfoList | file list
remoteDirectory | where the remoteFilename lives

Implements Activ::IFtpHelper.

Definition at line 384 of file CurlFtpHelper.h.

References ACTIV_THROW_RESULT_IF, Disconnect(), IsConnected(), and Activ::Exception::m_errorCode.

StatusCodeHelper Activ::CurlFtpHelper::DeleteFile | ( | const std::string & | remoteFilename,
 |  | const std::string & | remoteDirectory = "" |
 | ) |  |  | [inline, virtual]

Delete a file.

Parameters:
remoteFilename | the name of the file to delete
remoteDirectory | where the remoteFilename lives

Implements Activ::IFtpHelper.

Definition at line 347 of file CurlFtpHelper.h.

References ACTIV_THROW_RESULT_IF, Disconnect(), IsConnected(), and Activ::Exception::m_errorCode.

StatusCodeHelper Activ::CurlFtpHelper::GetAndDeleteFile | ( | const std::string & | remoteFilename,
 |  | const std::string & | localFilename,
 |  | const std::string & | remoteDirectory = "" |
 | ) |  |  | [inline, virtual]

Get and delete a file.

Parameters:
remoteFilename | the name of the file to get and delete
localFilename | the save as name of the remoteFilename
remoteDirectory | where the remoteFilename lives

Implements Activ::IFtpHelper.

Definition at line 424 of file CurlFtpHelper.h.

References ACTIV_THROW_RESULT_IF, Disconnect(), IsConnected(), and Activ::Exception::m_errorCode.

StatusCodeHelper Activ::CurlFtpHelper::GetFile | ( | const std::string & | remoteFilename,
 |  | const std::string & | localFilename,
 |  | const std::string & | remoteDirectory = "" |
 | ) |  |  | [inline, virtual]

Get a file.

Parameters:
remoteFilename | the name of the file to get
localFilename | the save as name of the remoteFilename
remoteDirectory | where the remoteFilename lives

Implements Activ::IFtpHelper.

Definition at line 317 of file CurlFtpHelper.h.

References ACTIV_THROW_RESULT_IF, Disconnect(), IsConnected(), and Activ::Exception::m_errorCode.

StatusCodeHelper Activ::CurlFtpHelper::GetFileList | ( | FileInfoList & | fileList,
 |  | const std::string & | remoteDirectory = "" |
 | ) |  |  | [inline, virtual]

Get the names of files from the server.

Parameters:
fileList | the names of the files found on the server.
remoteDirectory | the from which to get the file names from

Implements Activ::IFtpHelper.

Definition at line 287 of file CurlFtpHelper.h.

References ACTIV_THROW_RESULT_IF, Disconnect(), IsConnected(), and Activ::Exception::m_errorCode.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/Misc/CurlFtpHelper.h
Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::CurlFtpHelper::CurlInitializeHelper

Activ::CurlFtpHelper::CurlInitializeHelper Class Reference

CurlInitializeHelper class. More...

#include <ActivMiddleware/Misc/CurlFtpHelper.h>

List of all members.

Public Member Functions

CurlInitializeHelper ()
Constuctor.
~CurlInitializeHelper ()
Destructor.

Detailed Description

CurlInitializeHelper class.

Definition at line 41 of file CurlFtpHelper.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/Misc/CurlFtpHelper.h
Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Database::Database

Activ::Database::Database Class Reference

Database class. More...

#include <ActivMiddleware/ActivDatabase/Database.h>

List of all members.

Public Member Functions

ACTIV_DATABASE_API StatusCode | AttachTable (const DatabaseSpecification::TableId tableId, ITable *pTable)
Attach a table to the database.
Iterator Begin ()
Get an iterator to the first table in the database.
ConstIterator | Begin () const
Get a const iterator to the first table in the database.
ACTIV_DATABASE_API | Database (const std::string &name=std::string(), const DatabaseSpecification::Properties properties=DatabaseSpecification::PROPERTY_NONE)
Default constructor.
ACTIV_DATABASE_API StatusCode | DetachTable (const DatabaseSpecification::TableId tableId, ITable *&pTable)
Detach a table from the database.
Iterator End ()
Get an iterator that points to beyond the last table in the list.
ConstIterator | End () const
Get a const iterator that points to beyond the last table in the list.
StatusCode | GetEqual (const ITable *pTable, const IndexSpecification::Number indexNo, const Key &key, Record &record) const
Get record from specified table and index matching supplied key information.
ACTIV_DATABASE_API StatusCode | GetEqual (const Key &key, Record &record) const
Get record from first table with matching supplied key information.
Mode | GetMode () const
Get mode.
ACTIV_DATABASE_API std::string | GetName () const
Get the name of the database.
ACTIV_DATABASE_API size_t | GetNumberOfTables () const
Get the number of tables in the database.
TableIdList | GetSearchOrder () const
Get search order.
ACTIV_DATABASE_API
DatabaseSpecification 		GetSpecification () const
Get the specification.
ACTIV_DATABASE_API StatusCode | GetTable (const DatabaseSpecification::TableId tableId, ITable *&pTable) const
Get the table matching the specified identifier.
TableIdList | GetTableIdList () const
Get a list of all table ids in the database.
ACTIV_DATABASE_API StatusCode | SerializeSpecification (MessageBuilder &messageBuilder) const
Serialize the specification into a message.
void | SetMode (const Mode mode)
Set mode.
StatusCode | SetSearchOrder (const TableIdList &tableIdList)
Set the search order of the tables in the database.
ACTIV_DATABASE_API | ~Database ()
Default destructor.

Friends

class | ConstIterator
class | Iterator

Classes

class | ConstIterator
Const iterator class. More...
class | Iterator
Iterator class. More...

Detailed Description

Database class.

Definition at line 33 of file Database.h.

Constructor & Destructor Documentation

ACTIV_DATABASE_API Activ::Database::Database::Database | ( | const std::string & | name = std::string(),
 |  | const DatabaseSpecification::Properties | properties = DatabaseSpecification::PROPERTY_NONE
 | ) |  |

Default constructor.

Parameters:
name | the name of the database.
properties | the properties.
Exceptions:
DatabaseException

Member Function Documentation

ACTIV_DATABASE_API StatusCode Activ::Database::Database::AttachTable | ( | const DatabaseSpecification::TableId | tableId,
 |  | ITable * | pTable
 | ) |  |

Attach a table to the database.

The database object will be responsible for deleting the table object if this call succeeds.

Parameters:
tableId | the identifier for this table. Must be unique for each table in the database.
pTable | a pointer to the table to be added.

Database::Iterator Activ::Database::Database::Begin ( ) [inline]

Get an iterator to the first table in the database.

Returns:
an iterator object.

Definition at line 444 of file Database.h.

Database::ConstIterator Activ::Database::Database::Begin ( ) const [inline]

Get a const iterator to the first table in the database.

Returns:
a const iterator object.

Definition at line 430 of file Database.h.

ACTIV_DATABASE_API StatusCode Activ::Database::Database::DetachTable | ( | const DatabaseSpecification::TableId | tableId,
 |  | ITable *& | pTable
 | ) |  |

Detach a table from the database.

The database object is no longer responsible for deleting the table object if this call succeeds.

Parameters:
tableId | the identifier for the table.
pTable | the detached table pointer is stored in this variable.

Database::Iterator Activ::Database::Database::End ( ) [inline]

Get an iterator that points to beyond the last table in the list.

Returns:
an iterator object.

Definition at line 451 of file Database.h.

Database::ConstIterator Activ::Database::Database::End ( ) const [inline]

Get a const iterator that points to beyond the last table in the list.

Returns:
a const iterator object.

Definition at line 437 of file Database.h.

StatusCode Activ::Database::Database::GetEqual | ( | const ITable * | pTable,
 |  | const IndexSpecification::Number | indexNo,
 |  | const Key & | key,
 |  | Record & | record |
 | ) |  |  | const

Get record from specified table and index matching supplied key information.

The function assumes that the field ids and field types of the key fields supplied are consistent across the tables to be searched in the database. It will only search a particular index if all of the key fields can be copied from the supplied key.

Parameters:
pTable | the table to be searched.
indexNo | the index to be searched.
key | key information which will be searched for.
record | matching record information will be stored in this parameter.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_KEY
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_HEAP_EMPTY
STATUS_CODE_NOT_FOUND
STATUS_CODE_NOT_INITIALIZED
STATUS_CODE_OUT_OF_RANGE

ACTIV_DATABASE_API StatusCode Activ::Database::Database::GetEqual | ( | const Key & | key,
 |  | Record & | record |
 | ) |  |  | const

Get record from first table with matching supplied key information.

The function assumes that the field ids and field types of the key fields supplied are consistent across the tables to be searched in the database. It will only search a particular index if all of the key fields can be copied from the supplied key. It also searches the primary index of any table first.

Parameters:
key | key information which will be searched for.
record | matching record information will be stored in this parameter.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_KEY
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_HEAP_EMPTY
STATUS_CODE_NOT_FOUND
STATUS_CODE_NOT_INITIALIZED
STATUS_CODE_OUT_OF_RANGE

Mode Activ::Database::Database::GetMode ( ) const [inline]

Get mode.

Returns:
the mode of the database.

Definition at line 423 of file Database.h.

ACTIV_DATABASE_API std::string Activ::Database::Database::GetName ( ) const

Get the name of the database.

Returns:
the name of the database

ACTIV_DATABASE_API size_t Activ::Database::Database::GetNumberOfTables ( ) const

Get the number of tables in the database.

Returns:
the number of tables.

TableIdList Activ::Database::Database::GetSearchOrder ( ) const

Get search order.

Returns:
the ordered list of table ids.

ACTIV_DATABASE_API DatabaseSpecification Activ::Database::Database::GetSpecification ( ) const

Get the specification.

Returns:
the specification.

ACTIV_DATABASE_API StatusCode Activ::Database::Database::GetTable | ( | const DatabaseSpecification::TableId | tableId,
 |  | ITable *& | pTable |
 | ) |  |  | const

Get the table matching the specified identifier.

Parameters:
tableId | the identifier of the table to be retrieved.
pTable | the retrieved table pointer is stored in this variable.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_FOUND

TableIdList Activ::Database::Database::GetTableIdList ( ) const [inline]

Get a list of all table ids in the database.

Returns:
a list of table ids.

Definition at line 409 of file Database.h.

ACTIV_DATABASE_API StatusCode Activ::Database::Database::SerializeSpecification ( MessageBuilder & messageBuilder ) const

Serialize the specification into a message.

Parameters:
messageBuilder the message builder which the specification will be put in.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED
STATUS_CODE_FAILURE

void Activ::Database::Database::SetMode ( const Mode mode ) [inline]

Set mode.

Parameters:
mode the new mode of the database.

Definition at line 416 of file Database.h.

StatusCode Activ::Database::Database::SetSearchOrder ( const TableIdList & tableIdList )

Set the search order of the tables in the database.

Any table that is attached to the database after a search order is set will be appended to the end of the list.

Parameters:
tableIdList the ordered list of table ids.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_FOUND

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivDatabase/Database.h
Generated on Wed Oct 8 14:02:10 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Database::Database::ConstIterator

Activ::Database::Database::ConstIterator Class Reference

Const iterator class. More...

#include <ActivMiddleware/ActivDatabase/Database.h>

List of all members.

Public Member Functions

ACTIV_DATABASE_API const ITable * | GetTable () const
Get the table.
ACTIV_DATABASE_API
DatabaseSpecification::TableId 		GetTableId () const
Get the table id.
ACTIV_DATABASE_API bool | operator!= (const ConstIterator &rhs) const
Inequality operator.
ACTIV_DATABASE_API const
ConstIterator 		operator++ (int)
Postfix increment operator.
ACTIV_DATABASE_API ConstIterator & | operator++ ()
Prefix increment operator.
ACTIV_DATABASE_API bool | operator== (const ConstIterator &rhs) const
Equality operator.

Friends

class | Database

Detailed Description

Const iterator class.

Definition at line 43 of file Database.h.

Member Function Documentation

const ITable * Activ::Database::Database::ConstIterator::GetTable ( ) const [inline]

Get the table.

Returns:
a pointer to the table.

Definition at line 501 of file Database.h.

DatabaseSpecification::TableId Activ::Database::Database::ConstIterator::GetTableId ( ) const [inline]

Get the table id.

Returns:
the table id.

Definition at line 494 of file Database.h.

bool Activ::Database::Database::ConstIterator::operator!= ( const ConstIterator & rhs ) const [inline]

Inequality operator.

Parameters:
rhs the object to test against.
Returns:
whether the two objects are not equal.

Definition at line 486 of file Database.h.

const Database::ConstIterator Activ::Database::Database::ConstIterator::operator++ ( int ) [inline]

Postfix increment operator.

Returns:
a copy of the original object.

Definition at line 468 of file Database.h.

Database::ConstIterator & Activ::Database::Database::ConstIterator::operator++ ( ) [inline]

Prefix increment operator.

Returns:
a reference to the updated object.

Definition at line 459 of file Database.h.

bool Activ::Database::Database::ConstIterator::operator== ( const ConstIterator & rhs ) const [inline]

Equality operator.

Parameters:
rhs the object to test against.
Returns:
whether the two objects are equal.

Definition at line 479 of file Database.h.

References m_iterator.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivDatabase/Database.h
Generated on Wed Oct 8 14:02:10 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Database::Database::Iterator

Activ::Database::Database::Iterator Class Reference

Iterator class. More...

#include <ActivMiddleware/ActivDatabase/Database.h>

List of all members.

Public Member Functions

ACTIV_DATABASE_API ITable * | GetTable ()
Get the table.
ACTIV_DATABASE_API
DatabaseSpecification::TableId 		GetTableId () const
Get the table id.
ACTIV_DATABASE_API bool | operator!= (const Iterator &rhs) const
Inequality operator.
ACTIV_DATABASE_API const Iterator | operator++ (int)
Postfix increment operator.
ACTIV_DATABASE_API Iterator & | operator++ ()
Prefix increment operator.
ACTIV_DATABASE_API bool | operator== (const Iterator &rhs) const
Equality operator.

Friends

class | Database

Detailed Description

Iterator class.

Definition at line 110 of file Database.h.

Member Function Documentation

ITable * Activ::Database::Database::Iterator::GetTable ( ) [inline]

Get the table.

Returns:
a pointer to the table.

Definition at line 559 of file Database.h.

DatabaseSpecification::TableId Activ::Database::Database::Iterator::GetTableId ( ) const [inline]

Get the table id.

Returns:
the table id.

Definition at line 552 of file Database.h.

bool Activ::Database::Database::Iterator::operator!= ( const Iterator & rhs ) const [inline]

Inequality operator.

Parameters:
rhs the object to test against.
Returns:
whether the two objects are not equal.

Definition at line 544 of file Database.h.

const Database::Iterator Activ::Database::Database::Iterator::operator++ ( int ) [inline]

Postfix increment operator.

Returns:
a copy of the original object.

Definition at line 526 of file Database.h.

Database::Iterator & Activ::Database::Database::Iterator::operator++ ( ) [inline]

Prefix increment operator.

Returns:
a reference to the updated object.

Definition at line 517 of file Database.h.

bool Activ::Database::Database::Iterator::operator== ( const Iterator & rhs ) const [inline]

Equality operator.

Parameters:
rhs the object to test against.
Returns:
whether the two objects are equal.

Definition at line 537 of file Database.h.

References m_iterator.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivDatabase/Database.h
Generated on Wed Oct 8 14:02:10 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Database::DatabaseException

Activ::Database::DatabaseException Class Reference

Database exception class. More...

#include <ActivMiddleware/ActivDatabase/DatabaseException.h>

Inheritance diagram for Activ::Database::DatabaseException:

Activ::Exception

List of all members.

Public Types

enum | Errors { ACTIV_DECLARE_ELEMENT_1_WITH_COMMA }
Enumeration of all database exception errors.

Public Member Functions

ACTIV_DATABASE_API | DatabaseException (const char file[], const char function[], const uint_fast32_t line, const uint_fast32_t errorCode, const char format[],...)
Constructor that takes an error code and error string.
ACTIV_DATABASE_API | DatabaseException (const char file[], const char function[], const uint_fast32_t line, const uint_fast32_t errorCode)
Constructor that takes an error code.
virtual ACTIV_DATABASE_API
std::string 		ToString () const
Convert the exception error code to a C-style string.

Detailed Description

Database exception class.

Definition at line 50 of file DatabaseException.h.

Constructor & Destructor Documentation

ACTIV_DATABASE_API Activ::Database::DatabaseException::DatabaseException | ( | const char | file[],
 |  | const char | function[],
 |  | const uint_fast32_t | line,
 |  | const uint_fast32_t | errorCode
 | ) |  |

Constructor that takes an error code.

Parameters:
file | the file which raised the exception.
function | the function which raised the exception.
line | the line number which raised the exception.
errorCode | the exception specific error code.

ACTIV_DATABASE_API Activ::Database::DatabaseException::DatabaseException | ( | const char | file[],
 |  | const char | function[],
 |  | const uint_fast32_t | line,
 |  | const uint_fast32_t | errorCode,
 |  | const char | format[],
 |  |  | ...
 | ) |  |

Constructor that takes an error code and error string.

Parameters:
file | the file which raised the exception.
function | the function which raised the exception.
line | the line number which raised the exception.
errorCode | the exception specific error code.
format | pointer to a sprintf-style format string.
... variable arguments for the format string.

Member Function Documentation

virtual ACTIV_DATABASE_API std::string Activ::Database::DatabaseException::ToString ( ) const [virtual]

Convert the exception error code to a C-style string.

Returns:
the error code as a string.

Reimplemented from Activ::Exception.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivDatabase/DatabaseException.h
Generated on Wed Oct 8 14:02:10 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Database::DatabaseSpecification

Activ::Database::DatabaseSpecification Class Reference

Database specification structure. More...

#include <ActivMiddleware/ActivDatabase/DatabaseSpecification.h>

List of all members.

Public Types

enum | { PROPERTY_NONE = 0x00000000, PROPERTY_CREATE_MUTEX = 0x00000001 }
Properties. More...
typedef std::vector
< DatabaseTableSpecification > 		DatabaseTableSpecificationList
Database table specification list type definition.
typedef uint32_t | Properties
Definition of the properties of the database.
typedef uint16_t | TableId
Unique identifier for tables.

Public Member Functions

ACTIV_DATABASE_API | DatabaseSpecification (const std::string &name=std::string(), const Properties properties=PROPERTY_NONE, const DatabaseTableSpecificationList &databaseTableSpecificationList=DatabaseTableSpecificationList())
Constructor.
ACTIV_DATABASE_API StatusCode | Deserialize (MessageValidator &messageValidator)
Deserialize a database specification from a message.
ACTIV_DATABASE_API StatusCode | Serialize (MessageBuilder &messageBuilder) const
Serialize the database specification into a message.
ACTIV_DATABASE_API std::string | ToString () const
Convert the specification to a C-style string.

Static Public Member Functions

static ACTIV_DATABASE_API bool | ShouldCreateMutex (const Properties properties)
Should create mutex.

Public Attributes

DatabaseTableSpecificationList m_databaseTableSpecificationList
The list of database table specifications.
std::string | m_name
Name.
Properties m_properties
Properties.

Static Public Attributes

static const TableId | UNDEFINED_TABLE_ID = ~0
Undefined table id.
static const uint8_t | VERSION = 1
Version of the specification.

Classes

class | DatabaseTableSpecification
Database table specification structure. More...

Detailed Description

Database specification structure.

Definition at line 37 of file DatabaseSpecification.h.

Member Enumeration Documentation

anonymous enum

Properties.

Enumerator:
PROPERTY_CREATE_MUTEX Create a mutex to control access to the database. Locking occurs over the whole database.

Definition at line 102 of file DatabaseSpecification.h.

Constructor & Destructor Documentation

ACTIV_DATABASE_API Activ::Database::DatabaseSpecification::DatabaseSpecification | ( | const std::string & | name = std::string(),
 |  | const Properties | properties = PROPERTY_NONE,
 |  | const DatabaseTableSpecificationList & | databaseTableSpecificationList = DatabaseTableSpecificationList()
 | ) |  |

Constructor.

Parameters:
name | set equal to the name of the table.
properties | set equal to the database properties.
databaseTableSpecificationList | the list database table specifications.
Exceptions:
DatabaseException

Member Function Documentation

ACTIV_DATABASE_API StatusCode Activ::Database::DatabaseSpecification::Deserialize ( MessageValidator & messageValidator )

Deserialize a database specification from a message.

Parameters:
messageValidator the message validator from which the database specification is extracted.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_HEAP_EMPTY
STATUS_CODE_NOT_INITIALIZED

ACTIV_DATABASE_API StatusCode Activ::Database::DatabaseSpecification::Serialize ( MessageBuilder & messageBuilder ) const

Serialize the database specification into a message.

Parameters:
messageBuilder the message builder used for constructing the message.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED
STATUS_CODE_FAILURE

static ACTIV_DATABASE_API bool Activ::Database::DatabaseSpecification::ShouldCreateMutex ( const Properties properties ) [static]

Should create mutex.

Parameters:
properties the properties to check.
Returns:
true if the mutex should be created.

ACTIV_DATABASE_API std::string Activ::Database::DatabaseSpecification::ToString ( ) const

Convert the specification to a C-style string.

Returns:
the specification as a string.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivDatabase/DatabaseSpecification.h
Generated on Wed Oct 8 14:02:10 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Database::DatabaseSpecification::DatabaseTableSpecification

Activ::Database::DatabaseSpecification::DatabaseTableSpecification Class Reference

Database table specification structure. More...

#include <ActivMiddleware/ActivDatabase/DatabaseSpecification.h>

List of all members.

Public Member Functions

ACTIV_DATABASE_API | DatabaseTableSpecification (const TableId tableId=UNDEFINED_TABLE_ID, const TableSpecification &tableSpecification=TableSpecification(), const IndexSpecificationList &indexSpecificationList=IndexSpecificationList())
Constructor.
ACTIV_DATABASE_API StatusCode | Deserialize (MessageValidator &messageValidator)
Deserialize a database specification from a message.
ACTIV_DATABASE_API StatusCode | Serialize (MessageBuilder &messageBuilder) const
Serialize the database specification into a message.
ACTIV_DATABASE_API std::string | ToString () const
Convert the specification to a C-style string.

Public Attributes

IndexSpecificationList | m_indexSpecificationList
The list of index specifications for the table.
TableId m_tableId
The id used for the table in this database.
TableSpecification m_tableSpecification
The table specification.

Detailed Description

Database table specification structure.

Definition at line 48 of file DatabaseSpecification.h.

Constructor & Destructor Documentation

ACTIV_DATABASE_API Activ::Database::DatabaseSpecification::DatabaseTableSpecification::DatabaseTableSpecification | ( | const TableId | tableId = UNDEFINED_TABLE_ID,
 |  | const TableSpecification & | tableSpecification = TableSpecification(),
 |  | const IndexSpecificationList & | indexSpecificationList = IndexSpecificationList()
 | ) |  |

Constructor.

Parameters:
tableId | the id of the table.
tableSpecification | the specification of the table
indexSpecificationList | the list of index specifications.
Exceptions:
DatabaseException

Member Function Documentation

ACTIV_DATABASE_API StatusCode Activ::Database::DatabaseSpecification::DatabaseTableSpecification::Deserialize ( MessageValidator & messageValidator )

Deserialize a database specification from a message.

Parameters:
messageValidator the message validator from which the database specification is extracted.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_HEAP_EMPTY
STATUS_CODE_NOT_INITIALIZED

ACTIV_DATABASE_API StatusCode Activ::Database::DatabaseSpecification::DatabaseTableSpecification::Serialize ( MessageBuilder & messageBuilder ) const

Serialize the database specification into a message.

Parameters:
messageBuilder the message builder used for constructing the message.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED
STATUS_CODE_FAILURE

ACTIV_DATABASE_API std::string Activ::Database::DatabaseSpecification::DatabaseTableSpecification::ToString ( ) const

Convert the specification to a C-style string.

Returns:
the specification as a string.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivDatabase/DatabaseSpecification.h
Generated on Wed Oct 8 14:02:10 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Database::FieldList

Activ::Database::FieldList Class Reference

Declaration of the field list class. More...

#include <ActivMiddleware/ActivDatabase/FieldList.h>

List of all members.

Public Member Functions

ConstIterator | Begin () const
Get an iterator to the first field in the container.
ACTIV_DATABASE_API int | Compare (const size_t fieldNo, const byte_t *pLhsData, const byte_t *pRhsData) const
Compare the specified field in two data buffers of the same format.
ACTIV_DATABASE_API int | Compare (const byte_t *pLhsData, const byte_t *pRhsData, const size_t lastFieldNo, const size_t lastCompareLength) const
Partially compare two data buffers of the same format.
ACTIV_DATABASE_API int | Compare (const byte_t *pLhsData, const byte_t *pRhsData, const size_t lastFieldNo) const
Partially compare two data buffers of the same format.
ACTIV_DATABASE_API int | Compare (const byte_t *pLhsData, const byte_t *pRhsData) const
Compare two data buffers of the same format.
virtual ACTIV_DATABASE_API
StatusCode 		CompareField (const FieldSpecification::Id lhsFieldId, const byte_t *pLhsData, const FieldList &rhsFieldList, const FieldSpecification::Id rhsFieldId, const byte_t *pRhsData, int &result) const
Compare two fields of the same type.
virtual ACTIV_DATABASE_API
StatusCode 		CompareField (const FieldSpecification::Id fieldId, const byte_t *pLhsData, const std::string &value, int &result) const =0
Compare a field in a field list with a supplied string.
virtual ACTIV_DATABASE_API
StatusCode 		CompareField (const FieldSpecification::Id fieldId, const byte_t *pLhsData, const IFieldType &iFieldType, int &result) const =0
Compare a field in a field list with a supplied field.
ACTIV_DATABASE_API int | CompareKey (const byte_t *pLhsData, const byte_t *pRhsData, const size_t lastFieldNo, const size_t lastCompareLength) const
Partially compare two data buffers of the same format.
ACTIV_DATABASE_API int | CompareKey (const byte_t *pLhsData, const byte_t *pRhsData, const size_t lastFieldNo) const
Partially compare two data buffers of the same format.
ACTIV_DATABASE_API int | CompareKey (const byte_t *pLhsData, const byte_t *pRhsData) const
Compare two key data buffers of the same format.
StatusCode | CopyField (const FieldSpecification::Id targetFieldId, byte_t *pTargetData, const FieldList &sourceFieldList, const FieldSpecification::Id sourceFieldId, const byte_t *pSourceData, bool &isDifferent) const
Copy a field from source field list data.
ACTIV_DATABASE_API StatusCode | CopyField (const FieldSpecification::Id targetFieldId, byte_t *pTargetData, const FieldList &sourceFieldList, const FieldSpecification::Id sourceFieldId, const byte_t *pSourceData) const
Copy a field from source field list data.
StatusCode | CopyField (const FieldSpecification::Id fieldId, byte_t *pTargetData, const FieldList &sourceFieldList, const byte_t *pSourceData, bool &isDifferent) const
Copy a field from source field list data.
ACTIV_DATABASE_API StatusCode | CopyField (const FieldSpecification::Id fieldId, byte_t *pTargetData, const FieldList &sourceFieldList, const byte_t *pSourceData) const
Copy a field from source field list data.
ACTIV_DATABASE_API StatusCode | CopyFields (byte_t *pTargetData, const FieldList &sourceFieldList, const byte_t *pSourceData, const bool copyAllFields=false) const
Copy all matching fields from source field list data.
void | CreateFieldIdLookupList (const FieldSpecificationList &fieldSpecificationList)
Create a lookup list for the field identifiers.
void | CreateFieldIdMap (const FieldSpecificationList &fieldSpecificationList)
Create a map of field identifiers to field numbers.
virtual void | DefineField (const size_t fieldNo, byte_t *pTargetData) const =0
Define field.
virtual ACTIV_DATABASE_API
StatusCode 		DefineField (byte_t *pTargetData, const FieldSpecification::Id fieldId, const size_t fieldLength=~0) const =0
Define a field.
virtual ACTIV_DATABASE_API
StatusCode 		Deserialize (MessageValidator &messageValidator, byte_t *pTargetData) const =0
Deserialize the field list data information from a message.
ConstIterator | End () const
Get an iterator that points to beyond the last field in the container.
FieldList ()
Default constructor.
size_t | GetDataLength () const
Get the length of data stored using this field list.
ACTIV_DATABASE_API StatusCode | GetField (const byte_t *pSourceData, const ConstIterator &iterator, FieldSpecification::Id &fieldId, FieldSpecification::Type &type, const void *&pField, size_t &fieldLength) const
Get an id and type and a const pointer to and the length of a field within the source data.
ACTIV_DATABASE_API StatusCode | GetField (const byte_t *pSourceData, const ConstIterator &iterator, const void *&pField, size_t &fieldLength) const
Get a const pointer to and the length of a field within the source data.
template<typename T>
StatusCode | GetField (const byte_t *pSourceData, const FieldSpecification::Id fieldId, T &value) const
Get a field.
ACTIV_DATABASE_API StatusCode | GetField (byte_t *pSourceData, const FieldSpecification::Id fieldId, void *&pField, size_t &fieldLength) const
Get a pointer to and the length of a field within the source data.
ACTIV_DATABASE_API StatusCode | GetField (const byte_t *pSourceData, const FieldSpecification::Id fieldId, const void *&pField, size_t &fieldLength) const
Get a const pointer to and the length of a field within the source data.
StatusCode | GetField (const size_t fieldNo, const byte_t *pSourceData, const void *&pField, size_t &fieldLength) const
Get a pointer to and the length of a field within the source data.
ACTIV_DATABASE_API StatusCode | GetField (const byte_t *pSourceData, const FieldSpecification::Id fieldId, void *pField, const size_t fieldSize, size_t &fieldLength) const
Get the matching field from the source data and copy its contents to the provided field buffer.
const Field & | GetFieldDefinition (const size_t fieldNo) const
Get the definition of the field object for the specified field number.
ACTIV_DATABASE_API FieldIdList | GetFieldIdList () const
Get the list of all field identifiers.
virtual ACTIV_DATABASE_API size_t | GetFieldLength (const size_t fieldNo, const byte_t *pSourceData) const =0
Get field length.
ACTIV_DATABASE_API bool | GetFieldNumber (const FieldSpecification &fieldSpecification, size_t &fieldNo) const
Get the field number of the field with the matching field specification.
bool | GetFieldNumber (const FieldSpecification::Id fieldId, size_t &fieldNo) const
Get the field number of the field with the matching field identifier.
ACTIV_DATABASE_API StatusCode | GetFieldSpecification (const FieldSpecification::Id fieldId, size_t &fieldNo, const FieldSpecification *&pFieldSpecification) const
Get the specification of a field.
ACTIV_DATABASE_API StatusCode | GetFieldSpecification (const FieldSpecification::Id fieldId, FieldSpecification &fieldSpecification) const
Get the specification of a field.
ACTIV_DATABASE_API
FieldSpecificationList 		GetFieldSpecificationList () const
Get the list of all field specifications.
ACTIV_DATABASE_API void | GetFirstFieldId (FieldSpecification::Id &fieldId) const
Get the id of the first field in the field list object.
ACTIV_DATABASE_API void | GetFirstFieldSpecification (FieldSpecification &fieldSpecification) const
Get the field specification of the first field in the field list.
ACTIV_DATABASE_API StatusCode | GetNextFieldId (FieldSpecification::Id &fieldId) const
Get the id of the next field in the field list object.
ACTIV_DATABASE_API StatusCode | GetNextFieldSpecification (FieldSpecification &fieldSpecification) const
Get the field specification of the next field in the field list.
size_t | GetNumberOfFields () const
Get the number of fields in the field list.
ACTIV_DATABASE_API StatusCode | GetType (const FieldSpecification::Id fieldId, FieldSpecification::Type &type) const
Get the field type for the field id specified.
virtual bool | IsFieldDefined (const size_t fieldNo, const byte_t *pSourceData) const =0
Check whether a field is defined.
virtual ACTIV_DATABASE_API
StatusCode 		IsFieldDefined (const byte_t *pSourceData, const FieldSpecification::Id fieldId, bool &result) const =0
Check whether a field is defined.
ACTIV_DATABASE_API StatusCode | IsFieldDifferent (const FieldSpecification::Id lhsFieldId, const byte_t *pLhsData, const FieldList &rhsFieldList, const FieldSpecification::Id rhsFieldId, const byte_t *pRhsData, bool &result) const
Check whether a field is different between two data buffers.
ACTIV_DATABASE_API StatusCode | IsFieldDifferent (const FieldSpecification::Id fieldId, const byte_t *pLhsData, const FieldList &rhsFieldList, const byte_t *pRhsData, bool &result) const
Check whether a field is different between two data buffers.
ACTIV_DATABASE_API StatusCode | IsFieldDifferent (const FieldSpecification::Id fieldId, const byte_t *pLhsData, const std::string &value, bool &result) const
Check whether a field is different than a supplied string.
ACTIV_DATABASE_API StatusCode | IsFieldDifferent (const FieldSpecification::Id fieldId, const byte_t *pLhsData, const IFieldType &iFieldType, bool &result) const
Check whether a field is different than a supplied field.
ACTIV_DATABASE_API StatusCode | IsFieldDifferent (const FieldSpecification::Id fieldId, const byte_t *pLhsData, const void *pField, const size_t fieldLength, bool &result) const
Check whether a field is different than a supplied field buffer and length.
bool | IsFound (const FieldSpecification::Id fieldId) const
Check whether a field id is valid for this field list object.
virtual ACTIV_DATABASE_API void | ResetData (byte_t *pTargetData) const =0
Reset data.
virtual ACTIV_DATABASE_API
StatusCode 		Serialize (MessageBuilder &messageBuilder, const byte_t *pSourceData) const =0
Serialize the field list data into a message.
ACTIV_DATABASE_API StatusCode | SerializeSpecification (MessageBuilder &messageBuilder) const
Put the field list specification into a message.
virtual ACTIV_DATABASE_API
StatusCode 		SetField (byte_t *pTargetData, const FieldSpecification::Id fieldId, const bool value) const =0
Set a field from a boolean value.
template<typename T>
StatusCode | SetField (byte_t *pTargetData, const FieldSpecification::Id fieldId, const T &value, bool &isDifferent) const
Set a field and determine whether the field's value changed.
template<typename T>
StatusCode | SetField (byte_t *pTargetData, const FieldSpecification::Id fieldId, const T &value) const
Set a field.
ACTIV_DATABASE_API StatusCode | SetField (byte_t *pTargetData, const FieldSpecification::Id fieldId, const void *pField, const size_t fieldLength, bool &isDifferent) const
Set field by field id from a supplied pointer and length.
ACTIV_DATABASE_API StatusCode | SetField (byte_t *pTargetData, const FieldSpecification::Id fieldId, const void *pField, const size_t fieldLength) const
Set field by field id from a supplied pointer and length.
virtual StatusCode | SetField (const size_t fieldNo, byte_t *pTargetData, const void *pField, const size_t fieldLength) const =0
Set field by field number from a supplied pointer and length.
virtual StatusCode | SetField (const size_t targetFieldNo, byte_t *pTargetData, const size_t sourceFieldNo, const FieldList &sourceFieldList, const byte_t *pSourceData) const =0
Set field by source field list and source field number.
ACTIV_DATABASE_API std::string | ToLogString (const byte_t *pSourceData) const
Convert a list of fields to a log string.
ACTIV_DATABASE_API std::string | ToString (const byte_t *pSourceData) const
Convert a list of fields to a string.
virtual void | UndefineField (const size_t fieldNo, byte_t *pTargetData) const =0
Undefine field.
virtual ACTIV_DATABASE_API
StatusCode 		UndefineField (byte_t *pTargetData, const FieldSpecification::Id fieldId, bool &isDifferent) const =0
Undefine a field.
virtual ACTIV_DATABASE_API
StatusCode 		UndefineField (byte_t *pTargetData, const FieldSpecification::Id fieldId) const =0
Undefine a field.
virtual | ~FieldList ()
Destructor.

Static Public Member Functions

static ACTIV_DATABASE_API
StatusCode 		DeserializeSpecification (MessageValidator &messageValidator, FieldSpecificationList &fieldSpecificationList)
Get the field list specification out of a message.

Protected Types

typedef hash_map
< FieldSpecification::Id,
size_t > 		FieldIdMap
Definition of a map of field identifiers to field numbers.

Protected Attributes

size_t | m_dataLength
Total length of all fields.
FieldIdMap m_fieldIdMap
Map of field identifiers to field numbers.
std::vector< Field > & | m_fieldList
List of fields in the field list.
std::vector< size_t > | m_fieldNoList
Sparsely populated list of field numbers used for field id lookups.
size_t | m_nFields
Number of fields in the field list.

Static Protected Attributes

static const size_t | UNDEFINED_FIELD_NUMBER = ~0
Undefined field number.

Classes

class | ConstIterator
Const iterator class. More...

Detailed Description

Declaration of the field list class.

Definition at line 53 of file FieldList.h.

Constructor & Destructor Documentation

Activ::Database::FieldList::FieldList ( )

Default constructor.

Exceptions:
bad_alloc

Member Function Documentation

FieldList::ConstIterator Activ::Database::FieldList::Begin ( ) const [inline]

Get an iterator to the first field in the container.

Returns:
an iterator object.

Definition at line 1102 of file FieldList.h.

References m_fieldList.

Referenced by Activ::Database::FieldListObject::Begin().

ACTIV_DATABASE_API int Activ::Database::FieldList::Compare | ( | const size_t | fieldNo,
 |  | const byte_t * | pLhsData,
 |  | const byte_t * | pRhsData |
 | ) |  |  | const

Compare the specified field in two data buffers of the same format.

Parameters:
fieldNo | the field number of the field to be compared.
pLhsData | left hand data to compare.
pRhsData | right hand data to compare.
Returns:
negative value if left hand data is less than right hand data, positive if left is greater than right and 0 otherwise.

ACTIV_DATABASE_API int Activ::Database::FieldList::Compare | ( | const byte_t * | pLhsData,
 |  | const byte_t * | pRhsData,
 |  | const size_t | lastFieldNo,
 |  | const size_t | lastCompareLength |
 | ) |  |  | const

Partially compare two data buffers of the same format.

Parameters:
pLhsData | left hand data to compare.
pRhsData | right hand data to compare.
lastFieldNo | the field number of the last field to be compared.
lastCompareLength | the amount of the last field that should be compared.
Returns:
negative value if left hand data is less than right hand data, positive if left is greater than right and 0 otherwise.

ACTIV_DATABASE_API int Activ::Database::FieldList::Compare | ( | const byte_t * | pLhsData,
 |  | const byte_t * | pRhsData,
 |  | const size_t | lastFieldNo |
 | ) |  |  | const

Partially compare two data buffers of the same format.

Parameters:
pLhsData | left hand data to compare.
pRhsData | right hand data to compare.
lastFieldNo | the field number of the last field to be compared.
Returns:
negative value if left hand data is less than right hand data, positive if left is greater than right and 0 otherwise.

ACTIV_DATABASE_API int Activ::Database::FieldList::Compare | ( | const byte_t * | pLhsData,
 |  | const byte_t * | pRhsData |
 | ) |  |  | const

Compare two data buffers of the same format.

Parameters:
pLhsData | left hand data to compare.
pRhsData | right hand data to compare.
Returns:
negative value if left hand data is less than right hand data, positive if left is greater than right and 0 otherwise.

virtual ACTIV_DATABASE_API StatusCode Activ::Database::FieldList::CompareField | ( | const FieldSpecification::Id | lhsFieldId,
 |  | const byte_t * | pLhsData,
 |  | const FieldList & | rhsFieldList,
 |  | const FieldSpecification::Id | rhsFieldId,
 |  | const byte_t * | pRhsData,
 |  | int & | result |
 | ) |  |  | const [virtual]

Compare two fields of the same type.

Parameters:
lhsFieldId | the id of the left hand field to compare.
pLhsData | left hand data to compare.
rhsFieldList | the right hand field list.
rhsFieldId | the id of the right hand field to compare.
pRhsData | pointer to right hand data to compare.
result
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FIELD_TYPE
STATUS_CODE_NOT_FOUND

virtual ACTIV_DATABASE_API StatusCode Activ::Database::FieldList::CompareField | ( | const FieldSpecification::Id | fieldId,
 |  | const byte_t * | pLhsData,
 |  | const std::string & | value,
 |  | int & | result |
 | ) |  |  | const [pure virtual]

Compare a field in a field list with a supplied string.

Only works for string and array based fields.

Parameters:
fieldId | the id of the field to compare.
pLhsData | left hand data to compare.
value | the field to compare with the record.
result | the result of the comparison.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FIELD_TYPE
STATUS_CODE_NOT_FOUND

virtual ACTIV_DATABASE_API StatusCode Activ::Database::FieldList::CompareField | ( | const FieldSpecification::Id | fieldId,
 |  | const byte_t * | pLhsData,
 |  | const IFieldType & | iFieldType,
 |  | int & | result |
 | ) |  |  | const [pure virtual]

Compare a field in a field list with a supplied field.

Parameters:
fieldId | the id of the field to compare.
pLhsData | left hand data to compare.
iFieldType | the field to compare with the record.
result | the result of the comparison.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FIELD_TYPE
STATUS_CODE_NOT_FOUND

Referenced by Activ::Database::FieldListObject::CompareField().

ACTIV_DATABASE_API int Activ::Database::FieldList::CompareKey | ( | const byte_t * | pLhsData,
 |  | const byte_t * | pRhsData,
 |  | const size_t | lastFieldNo,
 |  | const size_t | lastCompareLength |
 | ) |  |  | const

Partially compare two data buffers of the same format.

Parameters:
pLhsData | left hand data to compare.
pRhsData | right hand data to compare.
lastFieldNo | the field number of the last field to be compared.
lastCompareLength | the amount of the last field that should be compared.
Returns:
negative value if left hand data is less than right hand data, positive if left is greater than right and 0 otherwise.

ACTIV_DATABASE_API int Activ::Database::FieldList::CompareKey | ( | const byte_t * | pLhsData,
 |  | const byte_t * | pRhsData,
 |  | const size_t | lastFieldNo |
 | ) |  |  | const

Partially compare two data buffers of the same format.

Parameters:
pLhsData | left hand data to compare.
pRhsData | right hand data to compare.
lastFieldNo | the field number of the last field to be compared.
Returns:
negative value if left hand data is less than right hand data, positive if left is greater than right and 0 otherwise.

ACTIV_DATABASE_API int Activ::Database::FieldList::CompareKey | ( | const byte_t * | pLhsData,
 |  | const byte_t * | pRhsData |
 | ) |  |  | const

Compare two key data buffers of the same format.

Parameters:
pLhsData | left hand data to compare.
pRhsData | right hand data to compare.
Returns:
negative value if left hand data is less than right hand data, positive if left is greater than right and 0 otherwise.

StatusCode Activ::Database::FieldList::CopyField | ( | const FieldSpecification::Id | targetFieldId,
 |  | byte_t * | pTargetData,
 |  | const FieldList & | sourceFieldList,
 |  | const FieldSpecification::Id | sourceFieldId,
 |  | const byte_t * | pSourceData,
 |  | bool & | isDifferent |
 | ) |  |  | const [inline]

Copy a field from source field list data.

Parameters:
targetFieldId | the identifier of the field to set.
pTargetData | pointer to target data where the field will be copied to.
sourceFieldList | the source field list.
sourceFieldId | the identifier of the field to copy.
pSourceData | pointer to source data where field is copied from.
isDifferent | set to true if the field changed as a result of the call.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FIELD_TYPE
STATUS_CODE_NOT_FOUND

Definition at line 1067 of file FieldList.h.

References ACTIV_RETURN_RESULT_IF, CopyField(), and IsFieldDifferent().

ACTIV_DATABASE_API StatusCode Activ::Database::FieldList::CopyField | ( | const FieldSpecification::Id | targetFieldId,
 |  | byte_t * | pTargetData,
 |  | const FieldList & | sourceFieldList,
 |  | const FieldSpecification::Id | sourceFieldId,
 |  | const byte_t * | pSourceData |
 | ) |  |  | const

Copy a field from source field list data.

Parameters:
targetFieldId | the identifier of the field to set.
pTargetData | pointer to target data where the field will be copied to.
sourceFieldList | the source field list.
sourceFieldId | the identifier of the field to copy.
pSourceData | pointer to source data where field is copied from.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FIELD_TYPE
STATUS_CODE_NOT_FOUND

StatusCode Activ::Database::FieldList::CopyField | ( | const FieldSpecification::Id | fieldId,
 |  | byte_t * | pTargetData,
 |  | const FieldList & | sourceFieldList,
 |  | const byte_t * | pSourceData,
 |  | bool & | isDifferent |
 | ) |  |  | const [inline]

Copy a field from source field list data.

Parameters:
fieldId | the id of the field to copy.
pTargetData | pointer to target data where the field will be copied to.
sourceFieldList | the source field list.
pSourceData | pointer to source data where field is copied from.
isDifferent | set to true if the field changed as a result of the call.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH
STATUS_CODE_NOT_FOUND

Definition at line 1058 of file FieldList.h.

References ACTIV_RETURN_RESULT_IF, CopyField(), and IsFieldDifferent().

ACTIV_DATABASE_API StatusCode Activ::Database::FieldList::CopyField | ( | const FieldSpecification::Id | fieldId,
 |  | byte_t * | pTargetData,
 |  | const FieldList & | sourceFieldList,
 |  | const byte_t * | pSourceData |
 | ) |  |  | const

Copy a field from source field list data.

Parameters:
fieldId | the id of the field to copy.
pTargetData | pointer to target data where the field will be copied to.
sourceFieldList | the source field list.
pSourceData | pointer to source data where field is copied from.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH
STATUS_CODE_NOT_FOUND

Referenced by Activ::Database::FieldListObject::CopyField(), and CopyField().

ACTIV_DATABASE_API StatusCode Activ::Database::FieldList::CopyFields | ( | byte_t * | pTargetData,
 |  | const FieldList & | sourceFieldList,
 |  | const byte_t * | pSourceData,
 |  | const bool | copyAllFields = false |
 | ) |  |  | const

Copy all matching fields from source field list data.

Parameters:
pTargetData | pointer to target data where the field will be copied to.
sourceFieldList | the source field list.
pSourceData | pointer to source data where field is copied from.
copyAllFields | whether all fields must be found in the source field list.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH
STATUS_CODE_INVALID_FIELD
STATUS_CODE_INVALID_PARAMETER

Referenced by Activ::Database::FieldListObject::CopyFields().

void Activ::Database::FieldList::CreateFieldIdLookupList ( const FieldSpecificationList & fieldSpecificationList )

Create a lookup list for the field identifiers.

Parameters:
fieldSpecificationList list of field specifications in the field list.

void Activ::Database::FieldList::CreateFieldIdMap ( const FieldSpecificationList & fieldSpecificationList )

Create a map of field identifiers to field numbers.

Parameters:
fieldSpecificationList list of field specifications in the field list.

virtual void Activ::Database::FieldList::DefineField | ( | const size_t | fieldNo,
 |  | byte_t * | pTargetData |
 | ) |  |  | const [pure virtual]

Define field.

Parameters:
fieldNo | the number of the field to define.
pTargetData | pointer to target data where the field will be defined.

virtual ACTIV_DATABASE_API StatusCode Activ::Database::FieldList::DefineField | ( | byte_t * | pTargetData,
 |  | const FieldSpecification::Id | fieldId,
 |  | const size_t | fieldLength = ~0 |
 | ) |  |  | const [pure virtual]

Define a field.

Parameters:
pTargetData | pointer to target data where the field will be defined.
fieldId | the identifier of the field to define.
fieldLength | the length of the field being defined. The default sets the field length to the maximum.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH
STATUS_CODE_NOT_FOUND

Referenced by Activ::Database::FieldListObject::DefineField().

virtual ACTIV_DATABASE_API StatusCode Activ::Database::FieldList::Deserialize | ( | MessageValidator & | messageValidator,
 |  | byte_t * | pTargetData |
 | ) |  |  | const [pure virtual]

Deserialize the field list data information from a message.

Parameters:
messageValidator | message validator containing the field list data.
pTargetData | pointer to target.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER

static ACTIV_DATABASE_API StatusCode Activ::Database::FieldList::DeserializeSpecification | ( | MessageValidator & | messageValidator,
 |  | FieldSpecificationList & | fieldSpecificationList |
 | ) |  |  | [static]

Get the field list specification out of a message.

Parameters:
messageValidator | the message validator containing the field list specification.
fieldSpecificationList | field specification list.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_HEAP_EMPTY
STATUS_CODE_NOT_INITIALIZED

FieldList::ConstIterator Activ::Database::FieldList::End ( ) const [inline]

Get an iterator that points to beyond the last field in the container.

Returns:
an iterator object.

Definition at line 1109 of file FieldList.h.

References UNDEFINED_FIELD_NUMBER.

Referenced by Activ::Database::FieldListObject::End().

size_t Activ::Database::FieldList::GetDataLength ( ) const [inline]

Get the length of data stored using this field list.

Returns:
the length of the data.

Definition at line 1088 of file FieldList.h.

References m_dataLength.

ACTIV_DATABASE_API StatusCode Activ::Database::FieldList::GetField | ( | const byte_t * | pSourceData,
 |  | const ConstIterator & | iterator,
 |  | FieldSpecification::Id & | fieldId,
 |  | FieldSpecification::Type & | type,
 |  | const void *& | pField,
 |  | size_t & | fieldLength |
 | ) |  |  | const

Get an id and type and a const pointer to and the length of a field within the source data.

Parameters:
pSourceData | pointer to the source of the field.
iterator | an iterator to the field to retrieve.
fieldId | set equal to the field's id.
type | set equal to the type of the field.
pField | pointer that will be set to the position of the field within the record.
fieldLength | the retrieved field's length.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED
STATUS_CODE_NOT_FOUND

ACTIV_DATABASE_API StatusCode Activ::Database::FieldList::GetField | ( | const byte_t * | pSourceData,
 |  | const ConstIterator & | iterator,
 |  | const void *& | pField,
 |  | size_t & | fieldLength |
 | ) |  |  | const

Get a const pointer to and the length of a field within the source data.

Parameters:
pSourceData | pointer to the source of the field.
iterator | an iterator to the field to retrieve.
pField | pointer that will be set to the position of the field within the record.
fieldLength | the retrieved field's length.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED
STATUS_CODE_NOT_FOUND

template<typename T>
StatusCode Activ::Database::FieldList::GetField | ( | const byte_t * | pSourceData,
 |  | const FieldSpecification::Id | fieldId,
 |  | T & | value |
 | ) |  |  | const [inline]

Get a field.

Parameters:
pSourceData | pointer to target.
fieldId | the identifier of the field to retrieve.
value | value to receive the field contents.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FIELD_TYPE
STATUS_CODE_INVALID_LENGTH
STATUS_CODE_NOT_FOUND
STATUS_CODE_UNDEFINED_FIELD

Definition at line 1051 of file FieldList.h.

ACTIV_DATABASE_API StatusCode Activ::Database::FieldList::GetField | ( | byte_t * | pSourceData,
 |  | const FieldSpecification::Id | fieldId,
 |  | void *& | pField,
 |  | size_t & | fieldLength |
 | ) |  |  | const

Get a pointer to and the length of a field within the source data.

Parameters:
pSourceData | pointer to the source of the field.
fieldId | the identifier of the field to retrieve.
pField | pointer that will be set to the position of the field within the record.
fieldLength | the retrieved field's length.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_FOUND

ACTIV_DATABASE_API StatusCode Activ::Database::FieldList::GetField | ( | const byte_t * | pSourceData,
 |  | const FieldSpecification::Id | fieldId,
 |  | const void *& | pField,
 |  | size_t & | fieldLength |
 | ) |  |  | const

Get a const pointer to and the length of a field within the source data.

Parameters:
pSourceData | pointer to the source of the field.
fieldId | the identifier of the field to retrieve.
pField | pointer that will be set to the position of the field within the record.
fieldLength | the retrieved field's length.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_FOUND

StatusCode Activ::Database::FieldList::GetField | ( | const size_t | fieldNo,
 |  | const byte_t * | pSourceData,
 |  | const void *& | pField,
 |  | size_t & | fieldLength |
 | ) |  |  | const

Get a pointer to and the length of a field within the source data.

Parameters:
fieldNo | the number of the field to retrieve.
pSourceData | pointer to the source of the field.
pField | pointer that will be set to the position of the field within the record.
fieldLength | the retrieved field's length.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_FOUND

ACTIV_DATABASE_API StatusCode Activ::Database::FieldList::GetField | ( | const byte_t * | pSourceData,
 |  | const FieldSpecification::Id | fieldId,
 |  | void * | pField,
 |  | const size_t | fieldSize,
 |  | size_t & | fieldLength |
 | ) |  |  | const

Get the matching field from the source data and copy its contents to the provided field buffer.

Parameters:
pSourceData | pointer to the source of the field.
fieldId | the identifier of the field to retrieve.
pField | the matching field's contents will be copied to here.
fieldSize | length of the buffer the field will be stored in.
fieldLength | the retrieved field's length.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_BUFFER_OVERFLOW
STATUS_CODE_NOT_FOUND

Referenced by Activ::Database::FieldListObject::GetField().

const Field& Activ::Database::FieldList::GetFieldDefinition ( const size_t fieldNo ) const

Get the definition of the field object for the specified field number.

Parameters:
fieldNo the field number.
Returns:
a copy of the matching field object.

ACTIV_DATABASE_API FieldIdList Activ::Database::FieldList::GetFieldIdList ( ) const

Get the list of all field identifiers.

Returns:
the field identifier list.

Referenced by Activ::Database::FieldListObject::GetFieldIdList().

virtual ACTIV_DATABASE_API size_t Activ::Database::FieldList::GetFieldLength | ( | const size_t | fieldNo,
 |  | const byte_t * | pSourceData |
 | ) |  |  | const [pure virtual]

Get field length.

Parameters:
fieldNo | the field number of the field whose length is to be returned.
pSourceData | pointer to source.
Returns:
length of the field.

ACTIV_DATABASE_API bool Activ::Database::FieldList::GetFieldNumber | ( | const FieldSpecification & | fieldSpecification,
 |  | size_t & | fieldNo |
 | ) |  |  | const

Get the field number of the field with the matching field specification.

Parameters:
fieldSpecification | the field specification to find in the field list.
fieldNo | set equal to the field number of the matching field.
Returns:
true if the field identifier is found in the field list, false otherwise.

bool Activ::Database::FieldList::GetFieldNumber | ( | const FieldSpecification::Id | fieldId,
 |  | size_t & | fieldNo |
 | ) |  |  | const [inline]

Get the field number of the field with the matching field identifier.

Parameters:
fieldId | the field identifier to find in the field list.
fieldNo | set equal to the field number of the matching field.
Returns:
true if the field identifier is found in the field list, false otherwise.

Definition at line 1076 of file FieldList.h.

References m_fieldNoList, and UNDEFINED_FIELD_NUMBER.

Referenced by IsFound().

ACTIV_DATABASE_API StatusCode Activ::Database::FieldList::GetFieldSpecification | ( | const FieldSpecification::Id | fieldId,
 |  | size_t & | fieldNo,
 |  | const FieldSpecification *& | pFieldSpecification |
 | ) |  |  | const

Get the specification of a field.

Parameters:
fieldId | the field identifier to find in the field list.
fieldNo | set equal to the field number of the matching field.
pFieldSpecification | set to point to the field specification of the matching field.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_FOUND

ACTIV_DATABASE_API StatusCode Activ::Database::FieldList::GetFieldSpecification | ( | const FieldSpecification::Id | fieldId,
 |  | FieldSpecification & | fieldSpecification |
 | ) |  |  | const

Get the specification of a field.

Parameters:
fieldId | the field identifier to find in the field list.
fieldSpecification | set equal to the field specification of the matching field.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_FOUND

Referenced by Activ::Database::FieldListObject::GetFieldSpecification().

ACTIV_DATABASE_API FieldSpecificationList Activ::Database::FieldList::GetFieldSpecificationList ( ) const

Get the list of all field specifications.

Returns:
the field specification list.

Referenced by Activ::Database::FieldListObject::GetFieldSpecificationList().

ACTIV_DATABASE_API void Activ::Database::FieldList::GetFirstFieldId ( FieldSpecification::Id & fieldId ) const

Get the id of the first field in the field list object.

Parameters:
fieldId set equal to the first field id in the field list object

Referenced by Activ::Database::FieldListObject::GetFirstFieldId().

ACTIV_DATABASE_API void Activ::Database::FieldList::GetFirstFieldSpecification ( FieldSpecification & fieldSpecification ) const

Get the field specification of the first field in the field list.

Parameters:
fieldSpecification variable to store field specification in.

ACTIV_DATABASE_API StatusCode Activ::Database::FieldList::GetNextFieldId ( FieldSpecification::Id & fieldId ) const

Get the id of the next field in the field list object.

Parameters:
fieldId set equal to the next field id in the field list object
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_FOUND

Referenced by Activ::Database::FieldListObject::GetNextFieldId().

ACTIV_DATABASE_API StatusCode Activ::Database::FieldList::GetNextFieldSpecification ( FieldSpecification & fieldSpecification ) const

Get the field specification of the next field in the field list.

Parameters:
fieldSpecification variable to store field specification in.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_FOUND

size_t Activ::Database::FieldList::GetNumberOfFields ( ) const [inline]

Get the number of fields in the field list.

Returns:
the number of fields in the field list.

Definition at line 1095 of file FieldList.h.

References m_nFields.

ACTIV_DATABASE_API StatusCode Activ::Database::FieldList::GetType | ( | const FieldSpecification::Id | fieldId,
 |  | FieldSpecification::Type & | type |
 | ) |  |  | const

Get the field type for the field id specified.

Parameters:
fieldId | the id of the field whose specification is to be retrieved.
type | set equal to the type of the field.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_FOUND

Referenced by Activ::Database::FieldListObject::GetType().

virtual bool Activ::Database::FieldList::IsFieldDefined | ( | const size_t | fieldNo,
 |  | const byte_t * | pSourceData |
 | ) |  |  | const [pure virtual]

Check whether a field is defined.

Parameters:
fieldNo | the number of the field to check.
pSourceData | pointer to source data where the field will be checked.
Returns:
true if the specified field is defined, false otherwise.

virtual ACTIV_DATABASE_API StatusCode Activ::Database::FieldList::IsFieldDefined | ( | const byte_t * | pSourceData,
 |  | const FieldSpecification::Id | fieldId,
 |  | bool & | result |
 | ) |  |  | const [pure virtual]

Check whether a field is defined.

Parameters:
pSourceData | pointer to source data where the field will be checked.
fieldId | the identifier of the field to define.
result | set equal to true if the field is defined, false otherwise.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_FOUND

Referenced by Activ::Database::FieldListObject::IsFieldDefined().

ACTIV_DATABASE_API StatusCode Activ::Database::FieldList::IsFieldDifferent | ( | const FieldSpecification::Id | lhsFieldId,
 |  | const byte_t * | pLhsData,
 |  | const FieldList & | rhsFieldList,
 |  | const FieldSpecification::Id | rhsFieldId,
 |  | const byte_t * | pRhsData,
 |  | bool & | result |
 | ) |  |  | const

Check whether a field is different between two data buffers.

Parameters:
lhsFieldId | the id of the left hand field to compare.
pLhsData | left hand data to compare.
rhsFieldList | the right hand field list to compare with.
rhsFieldId | the id of the right hand field to compare.
pRhsData | right hand data to compare.
result | set equal to true if the field has been modified, false otherwise.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_FOUND

ACTIV_DATABASE_API StatusCode Activ::Database::FieldList::IsFieldDifferent | ( | const FieldSpecification::Id | fieldId,
 |  | const byte_t * | pLhsData,
 |  | const FieldList & | rhsFieldList,
 |  | const byte_t * | pRhsData,
 |  | bool & | result |
 | ) |  |  | const

Check whether a field is different between two data buffers.

Parameters:
fieldId | the id of the field to compare.
pLhsData | left hand data to compare.
rhsFieldList | the right hand field list to compare with.
pRhsData | right hand data to compare.
result | set equal to true if the field has been modified, false otherwise.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_FOUND

ACTIV_DATABASE_API StatusCode Activ::Database::FieldList::IsFieldDifferent | ( | const FieldSpecification::Id | fieldId,
 |  | const byte_t * | pLhsData,
 |  | const std::string & | value,
 |  | bool & | result |
 | ) |  |  | const

Check whether a field is different than a supplied string.

Only works for string and array based fields.

Parameters:
fieldId | the id of the field to compare.
pLhsData | left hand data to compare.
value | the field to compare with the record.
result | set equal to true if the field has been modified, false otherwise.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FIELD_TYPE
STATUS_CODE_NOT_FOUND

ACTIV_DATABASE_API StatusCode Activ::Database::FieldList::IsFieldDifferent | ( | const FieldSpecification::Id | fieldId,
 |  | const byte_t * | pLhsData,
 |  | const IFieldType & | iFieldType,
 |  | bool & | result |
 | ) |  |  | const

Check whether a field is different than a supplied field.

Parameters:
fieldId | the id of the field to compare.
pLhsData | left hand data to compare.
iFieldType | the field to compare with the record.
result | set equal to true if the field has been modified, false otherwise.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FIELD_TYPE
STATUS_CODE_NOT_FOUND

ACTIV_DATABASE_API StatusCode Activ::Database::FieldList::IsFieldDifferent | ( | const FieldSpecification::Id | fieldId,
 |  | const byte_t * | pLhsData,
 |  | const void * | pField,
 |  | const size_t | fieldLength,
 |  | bool & | result |
 | ) |  |  | const

Check whether a field is different than a supplied field buffer and length.

Parameters:
fieldId | the id of the field to compare.
pLhsData | left hand data to compare.
pField | pointer to field.
fieldLength | field length.
result | set equal to true if the field has been modified, false otherwise.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FIELD_TYPE
STATUS_CODE_NOT_FOUND

Referenced by CopyField(), and Activ::Database::FieldListObject::IsFieldDifferent().

bool Activ::Database::FieldList::IsFound ( const FieldSpecification::Id fieldId ) const [inline]

Check whether a field id is valid for this field list object.

Returns:
true if the field id can be found, false otherwise.

Definition at line 1116 of file FieldList.h.

References GetFieldNumber().

Referenced by Activ::Database::FieldListObject::IsFound().

virtual ACTIV_DATABASE_API void Activ::Database::FieldList::ResetData ( byte_t * pTargetData ) const [pure virtual]

Reset data.

Parameters:
pTargetData pointer to target data.

Referenced by Activ::Database::Record::Reset().

virtual ACTIV_DATABASE_API StatusCode Activ::Database::FieldList::Serialize | ( | MessageBuilder & | messageBuilder,
 |  | const byte_t * | pSourceData |
 | ) |  |  | const [pure virtual]

Serialize the field list data into a message.

Parameters:
messageBuilder | the message builder into which the field list data will be placed.
pSourceData | pointer to source.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_BUFFER_OVERFLOW
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_HEAP_EMPTY

ACTIV_DATABASE_API StatusCode Activ::Database::FieldList::SerializeSpecification ( MessageBuilder & messageBuilder ) const

Put the field list specification into a message.

Parameters:
messageBuilder the message builder into which the field specification is put.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED
STATUS_CODE_FAILURE

virtual ACTIV_DATABASE_API StatusCode Activ::Database::FieldList::SetField | ( | byte_t * | pTargetData,
 |  | const FieldSpecification::Id | fieldId,
 |  | const bool | value |
 | ) |  |  | const [pure virtual]

Set a field from a boolean value.

This function fails if the identified field's type is not boolean.

Parameters:
pTargetData | pointer to target data where the field will be stored.
fieldId | the identifier of the field to set.
value | boolean value to store in the field.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FIELD_TYPE
STATUS_CODE_INVALID_LENGTH
STATUS_CODE_NOT_FOUND

template<typename T>
StatusCode Activ::Database::FieldList::SetField | ( | byte_t * | pTargetData,
 |  | const FieldSpecification::Id | fieldId,
 |  | const T & | value,
 |  | bool & | isDifferent |
 | ) |  |  | const [inline]

Set a field and determine whether the field's value changed.

This function fails if the identified field's type is not signed integral.

Parameters:
pTargetData | pointer to target data where the field will be stored.
fieldId | the identifier of the field to set.
value | integral value to store in the field.
isDifferent | set to true if the field changed as a result of the call.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FIELD_TYPE
STATUS_CODE_INVALID_LENGTH
STATUS_CODE_NOT_FOUND

Definition at line 1043 of file FieldList.h.

template<typename T>
StatusCode Activ::Database::FieldList::SetField | ( | byte_t * | pTargetData,
 |  | const FieldSpecification::Id | fieldId,
 |  | const T & | value |
 | ) |  |  | const [inline]

Set a field.

This function fails if the identified field's type is not signed integral.

Parameters:
pTargetData | pointer to target data where the field will be stored.
fieldId | the identifier of the field to set.
value | integral value to store in the field.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FIELD_TYPE
STATUS_CODE_INVALID_LENGTH
STATUS_CODE_NOT_FOUND

Definition at line 1035 of file FieldList.h.

ACTIV_DATABASE_API StatusCode Activ::Database::FieldList::SetField | ( | byte_t * | pTargetData,
 |  | const FieldSpecification::Id | fieldId,
 |  | const void * | pField,
 |  | const size_t | fieldLength,
 |  | bool & | isDifferent |
 | ) |  |  | const

Set field by field id from a supplied pointer and length.

Parameters:
pTargetData | pointer to target data where the field will be stored.
fieldId | the identifier of the field to set.
pField | pointer to the field to be set in the target data.
fieldLength | the length of the field to be set in the target data.
isDifferent | set to true if the field changed as a result of the call.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_FOUND
STATUS_CODE_INVALID_LENGTH

ACTIV_DATABASE_API StatusCode Activ::Database::FieldList::SetField | ( | byte_t * | pTargetData,
 |  | const FieldSpecification::Id | fieldId,
 |  | const void * | pField,
 |  | const size_t | fieldLength |
 | ) |  |  | const

Set field by field id from a supplied pointer and length.

Parameters:
pTargetData | pointer to target data where the field will be stored.
fieldId | the identifier of the field to set.
pField | pointer to the field to be set in the target data.
fieldLength | the length of the field to be set in the target data.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_FOUND
STATUS_CODE_INVALID_LENGTH

virtual StatusCode Activ::Database::FieldList::SetField | ( | const size_t | fieldNo,
 |  | byte_t * | pTargetData,
 |  | const void * | pField,
 |  | const size_t | fieldLength |
 | ) |  |  | const [pure virtual]

Set field by field number from a supplied pointer and length.

Parameters:
fieldNo | the number of the field to set.
pTargetData | pointer to target data where the field will be stored.
pField | pointer to the field to be set in the target data.
fieldLength | the length of the field to be set in the target data.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

virtual StatusCode Activ::Database::FieldList::SetField | ( | const size_t | targetFieldNo,
 |  | byte_t * | pTargetData,
 |  | const size_t | sourceFieldNo,
 |  | const FieldList & | sourceFieldList,
 |  | const byte_t * | pSourceData |
 | ) |  |  | const [pure virtual]

Set field by source field list and source field number.

Parameters:
targetFieldNo | the target field number.
pTargetData | a pointer to the target data where the field will be stored.
sourceFieldNo | the source field number.
sourceFieldList | source field list.
pSourceData | pointer to source.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH

Referenced by Activ::Database::FieldListObject::SetField().

ACTIV_DATABASE_API std::string Activ::Database::FieldList::ToLogString ( const byte_t * pSourceData ) const

Convert a list of fields to a log string.

Parameters:
pSourceData field data to display.
Returns:
the fields converted to a string.

Referenced by Activ::Database::FieldListObject::ToLogString().

ACTIV_DATABASE_API std::string Activ::Database::FieldList::ToString ( const byte_t * pSourceData ) const

Convert a list of fields to a string.

Parameters:
pSourceData field data to display.
Returns:
the fields converted to a string.

Referenced by Activ::Database::FieldListObject::ToString().

virtual void Activ::Database::FieldList::UndefineField | ( | const size_t | fieldNo,
 |  | byte_t * | pTargetData |
 | ) |  |  | const [pure virtual]

Undefine field.

Parameters:
fieldNo | the number of the field to undefine.
pTargetData | pointer to target data where the field will be defined.

virtual ACTIV_DATABASE_API StatusCode Activ::Database::FieldList::UndefineField | ( | byte_t * | pTargetData,
 |  | const FieldSpecification::Id | fieldId,
 |  | bool & | isDifferent |
 | ) |  |  | const [pure virtual]

Undefine a field.

Parameters:
pTargetData | pointer to target data where the field will be undefined.
fieldId | the identifier of the field to undefine.
isDifferent | set to true if the field changed as a result of the call.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_FOUND
STATUS_CODE_NOT_SUPPORTED

virtual ACTIV_DATABASE_API StatusCode Activ::Database::FieldList::UndefineField | ( | byte_t * | pTargetData,
 |  | const FieldSpecification::Id | fieldId |
 | ) |  |  | const [pure virtual]

Undefine a field.

Parameters:
pTargetData | pointer to target data where the field will be undefined.
fieldId | the identifier of the field to undefine.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_FOUND
STATUS_CODE_NOT_SUPPORTED

Referenced by Activ::Database::FieldListObject::UndefineField().

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivDatabase/FieldList.h
Generated on Wed Oct 8 14:02:10 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Database::FieldList::ConstIterator

Activ::Database::FieldList::ConstIterator Class Reference

Const iterator class. More...

#include <ActivMiddleware/ActivDatabase/FieldList.h>

List of all members.

Public Member Functions

ConstIterator (const ConstIterator &rhs)
Copy constructor.
ConstIterator ()
Default constructor.
ACTIV_DATABASE_API
FieldSpecification::Id 		GetId () const
Get the id of the field.
ACTIV_DATABASE_API std::string | GetName () const
Get the name of the field.
ACTIV_DATABASE_API
FieldSpecification 		GetSpecification () const
Get the specification of the field.
ACTIV_DATABASE_API
FieldSpecification::Type 		GetType () const
Get the type of the field.
bool | IsInitialized () const
Is initialised.
bool | operator!= (const ConstIterator &rhs) const
Inequality operator.
const ConstIterator | operator++ (int)
Postfix increment operator.
ACTIV_DATABASE_API ConstIterator & | operator++ ()
Prefix increment operator.
bool | operator== (const ConstIterator &rhs) const
Equality operator.

Friends

class | FieldList
list of fields.

Detailed Description

Const iterator class.

Definition at line 59 of file FieldList.h.

Constructor & Destructor Documentation

Activ::Database::FieldList::ConstIterator::ConstIterator ( const ConstIterator & rhs ) [inline]

Copy constructor.

Parameters:
rhs the value to assign to this object.
Exceptions:
DatabaseException

Definition at line 1134 of file FieldList.h.

Member Function Documentation

ACTIV_DATABASE_API FieldSpecification::Id Activ::Database::FieldList::ConstIterator::GetId ( ) const

Get the id of the field.

Returns:
the id of the field.

ACTIV_DATABASE_API std::string Activ::Database::FieldList::ConstIterator::GetName ( ) const

Get the name of the field.

Returns:
the name of the field.

ACTIV_DATABASE_API FieldSpecification Activ::Database::FieldList::ConstIterator::GetSpecification ( ) const

Get the specification of the field.

Returns:
the specification of the field.

ACTIV_DATABASE_API FieldSpecification::Type Activ::Database::FieldList::ConstIterator::GetType ( ) const

Get the type of the field.

Returns:
the type of the field.

bool Activ::Database::FieldList::ConstIterator::IsInitialized ( ) const [inline]

Is initialised.

Returns:
true if the iterator is initialised.

Definition at line 1167 of file FieldList.h.

bool Activ::Database::FieldList::ConstIterator::operator!= ( const ConstIterator & rhs ) const [inline]

Inequality operator.

Parameters:
rhs the object to test against.
Returns:
whether the two objects are not equal.

Definition at line 1160 of file FieldList.h.

const FieldList::ConstIterator Activ::Database::FieldList::ConstIterator::operator++ ( int ) [inline]

Postfix increment operator.

Returns:
a copy of the original object.

Definition at line 1142 of file FieldList.h.

ACTIV_DATABASE_API ConstIterator& Activ::Database::FieldList::ConstIterator::operator++ ( )

Prefix increment operator.

Returns:
a reference to the updated object.

bool Activ::Database::FieldList::ConstIterator::operator== ( const ConstIterator & rhs ) const [inline]

Equality operator.

Parameters:
rhs the object to test against.
Returns:
whether the two objects are equal.

Definition at line 1153 of file FieldList.h.

References m_fieldNo, and m_pFieldContainer.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivDatabase/FieldList.h
Generated on Wed Oct 8 14:02:10 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Database::FieldListObject

Activ::Database::FieldListObject Class Reference

Field list object class. More...

#include <ActivMiddleware/ActivDatabase/FieldListObject.h>

Inheritance diagram for Activ::Database::FieldListObject:

Activ::Database::Key Activ::Database::Record

List of all members.

Public Types

typedef FieldList::ConstIterator | ConstIterator
Definition of an iterator through the field list object.

Public Member Functions

ConstIterator | Begin () const
Get an iterator to the first field in the list.
StatusCode | CompareField (const FieldSpecification::Id lhsFieldId, const FieldListObject &rhsFieldListObject, const FieldSpecification::Id rhsFieldId, int &result) const
Compare two fields of the same type in two field list objects.
StatusCode | CompareField (const FieldSpecification::Id fieldId, const FieldListObject &rhsFieldListObject, int &result) const
Compare a field in two field list objects.
StatusCode | CompareField (const FieldSpecification::Id fieldId, const std::string &value, int &result) const
Compare a field in a field list object with a supplied string.
StatusCode | CompareField (const FieldSpecification::Id fieldId, const IFieldType &iFieldType, int &result) const
Compare a field in a field list object with a supplied field.
StatusCode | CopyField (const FieldSpecification::Id targetFieldId, const FieldListObject &sourceFieldListObject, const FieldSpecification::Id sourceFieldId, bool &isDifferent)
Copy a field from a supplied field list object.
StatusCode | CopyField (const FieldSpecification::Id targetFieldId, const FieldListObject &sourceFieldListObject, const FieldSpecification::Id sourceFieldId)
Copy a field from a supplied field list object.
StatusCode | CopyField (const FieldSpecification::Id fieldId, const FieldListObject &sourceFieldListObject, bool &isDifferent)
Copy a field.
StatusCode | CopyField (const FieldSpecification::Id fieldId, const FieldListObject &sourceFieldListObject)
Copy a field.
virtual StatusCode | CopyFields (const FieldListObject &sourceFieldListObject, const bool copyAllFields=false)
Copy all matching fields from a supplied field list object.
StatusCode | DefineField (const FieldSpecification::Id fieldId, const size_t fieldLength=~0)
Define a field.
virtual StatusCode | Deserialize (ITable *pTable, MessageValidator &messageValidator)=0
Deserialize the field list object information from a message.
ConstIterator | End () const
Get an iterator that points to beyond the last field in the list.
FieldListObject ()
Constructor.
const byte_t * | Get () const
Get a pointer to the beginning of the field list object data buffer.
byte_t * | Get ()
Get a pointer to the beginning of the field list object data buffer.
StatusCode | GetField (const ConstIterator &iterator, FieldSpecification::Id &fieldId, FieldSpecification::Type &type, const void *&pField, size_t &fieldLength) const
Get an id and type and a pointer to and the length of a field within the record.
StatusCode | GetField (const ConstIterator &iterator, const void *&pField, size_t &fieldLength) const
Get a pointer to and the length of a field within the record.
template<typename T>
StatusCode | GetField (const FieldSpecification::Id fieldId, T &value) const
Get a field.
StatusCode | GetField (const FieldSpecification::Id fieldId, void *&pField, size_t &fieldLength)
Get a pointer to and the length of a field within the record.
StatusCode | GetField (const FieldSpecification::Id fieldId, const void *&pField, size_t &fieldLength) const
Get a pointer to and the length of a field within the record.
StatusCode | GetField (const FieldSpecification::Id fieldId, void *pField, const size_t fieldSize, size_t &fieldLength) const
Get the matching field from the record and copy its contents to the provided field buffer.
StatusCode | GetFieldIdList (FieldIdList &fieldIdList) const
Get the list of field identifiers.
StatusCode | GetFieldSpecification (const FieldSpecification::Id fieldId, FieldSpecification &fieldSpecification) const
Get the field specification for the field id specified.
StatusCode | GetFieldSpecificationList (FieldSpecificationList &fieldSpecificationList) const
Get the list of field specifications.
StatusCode | GetFirstFieldId (FieldSpecification::Id &fieldId) const
Get the id of the first field in the field list object.
DataId | GetId () const
Get the current identifier stored in this field list object.
ACTIV_DATABASE_API StatusCode | GetMatchingFieldsById (FieldIdList &fieldIdList, const FieldListObject &rhsFieldListObject)
Get the matching fields in two records by id.
ACTIV_DATABASE_API StatusCode | GetMatchingFieldsByName (FieldIdList &lhsFieldIdList, const FieldListObject &rhsFieldListObject, FieldIdList &rhsFieldIdList)
Get the matching fields in two records by name.
StatusCode | GetNextFieldId (FieldSpecification::Id &fieldId) const
Get the id of the next field in the field list object.
StatusCode | GetTablePointer (ITable *&pTable) const
Get a pointer to the table.
StatusCode | GetType (const FieldSpecification::Id fieldId, FieldSpecification::Type &type) const
Get the field type for the field id specified.
StatusCode | Initialize (ITable *pTable, const FieldList *pFieldList, const size_t requiredBufferSize)
Initialize.
void | Initialize ()
Initialize.
StatusCode | IsFieldDefined (const FieldSpecification::Id fieldId, bool &result) const
Check whether a field is defined.
StatusCode | IsFieldDifferent (const FieldSpecification::Id lhsFieldId, const FieldListObject &rhsFieldListObject, const FieldSpecification::Id rhsFieldId, bool &result) const
Check whether two fields of the same type are different between two field list objects.
StatusCode | IsFieldDifferent (const FieldSpecification::Id fieldId, const FieldListObject &rhsFieldListObject, bool &result) const
Check whether a field is different between two field list objects.
StatusCode | IsFieldDifferent (const FieldSpecification::Id fieldId, const std::string &value, bool &result) const
Check whether a field is different than a supplied string.
StatusCode | IsFieldDifferent (const FieldSpecification::Id fieldId, const IFieldType &iFieldType, bool &result) const
Check whether a field is different than a supplied field.
StatusCode | IsFieldDifferent (const FieldSpecification::Id fieldId, const void *pField, const size_t fieldLength, bool &result) const
Check whether a field is different than a supplied field buffer and length.
bool | IsFound (const FieldSpecification::Id fieldId) const
Check whether a field id is valid for this field list object.
bool | IsInitialized () const
Is the field list object initialized.
virtual StatusCode | Reset ()=0
Reset the contents of the field list object data buffer.
virtual StatusCode | Serialize (MessageBuilder &messageBuilder) const =0
Serialize the field list object information into a message.
template<typename T>
StatusCode | SetField (const FieldSpecification::Id fieldId, const T &value, bool &isDifferent)
Set a field.
template<typename T>
StatusCode | SetField (const FieldSpecification::Id fieldId, const T &value)
Set a field.
StatusCode | SetField (const FieldSpecification::Id fieldId, const void *pField, const size_t fieldLength, bool &isDifferent)
Set a field from a supplied pointer and length.
StatusCode | SetField (const FieldSpecification::Id fieldId, const void *pField, const size_t fieldLength)
Set a field from a supplied pointer and length.
void | SetId (const DataId id) const
Set the record id in this field list object.
std::string | ToLogString () const
Convert the field list object to a log string.
std::string | ToString () const
Convert the field list object to a string.
StatusCode | UndefineField (const FieldSpecification::Id fieldId, bool &isDifferent)
Undefine a field.
StatusCode | UndefineField (const FieldSpecification::Id fieldId)
Undefine a field.
virtual | ~FieldListObject ()=0
Destructor.

Protected Member Functions

StatusCode | AllocateBuffer (const size_t requiredBufferSize)
Allocate the buffer for storing the field list object data.
const FieldList & | GetFieldList () const
Get the field list associated with the object.

Protected Attributes

size_t | m_bufferSize
Current size of the record buffer.
byte_t | m_defaultBuffer [DEFAULT_BUFFER_SIZE]
Default buffer used to store the record data if record length is less than the buffer size.
DataId | m_id
Identifier of the record in the data store.
bool | m_isInitialized
Flag indicating whether the field list object is initialized.
byte_t * | m_pData
Pointer to record data. Either points to the data buffer or to dynamically allocated memory.
const FieldList * | m_pFieldList
Pointer to the field list.
ITable * m_pTable
Table the record relates to.
ITable::Identity m_tableIdentity
Identity of the table. Cached for efficiency.

Static Protected Attributes

static const size_t | DEFAULT_BUFFER_SIZE = 1024

Friends

class | FieldList::ConstIterator

Detailed Description

Field list object class.

Definition at line 33 of file FieldListObject.h.

Member Function Documentation

StatusCode Activ::Database::FieldListObject::AllocateBuffer ( const size_t requiredBufferSize ) [inline, protected]

Allocate the buffer for storing the field list object data.

Parameters:
requiredBufferSize the required size of the buffer.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_HEAP_EMPTY

Definition at line 746 of file FieldListObject.h.

References m_bufferSize, m_defaultBuffer, and m_pData.

Referenced by Initialize().

FieldListObject::ConstIterator Activ::Database::FieldListObject::Begin ( ) const [inline]

Get an iterator to the first field in the list.

Returns:
an iterator object.

Definition at line 1119 of file FieldListObject.h.

References Activ::Database::FieldList::Begin(), GetFieldList(), and IsInitialized().

StatusCode Activ::Database::FieldListObject::CompareField | ( | const FieldSpecification::Id | lhsFieldId,
 |  | const FieldListObject & | rhsFieldListObject,
 |  | const FieldSpecification::Id | rhsFieldId,
 |  | int & | result |
 | ) |  |  | const [inline]

Compare two fields of the same type in two field list objects.

Parameters:
lhsFieldId | the id of the left hand field to compare.
rhsFieldListObject | the right hand field list object to compare against.
rhsFieldId | the id of the right hand field to compare.
result | the result of the comparison.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FIELD_TYPE
STATUS_CODE_NOT_FOUND
STATUS_CODE_NOT_INITIALIZED

Definition at line 916 of file FieldListObject.h.

References Activ::Database::FieldList::CompareField(), Get(), GetFieldList(), and IsInitialized().

StatusCode Activ::Database::FieldListObject::CompareField | ( | const FieldSpecification::Id | fieldId,
 |  | const FieldListObject & | rhsFieldListObject,
 |  | int & | result |
 | ) |  |  | const [inline]

Compare a field in two field list objects.

Parameters:
fieldId | the id of the field to compare.
rhsFieldListObject | the right hand field list object to compare against.
result | the result of the comparison.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FIELD_TYPE
STATUS_CODE_NOT_FOUND
STATUS_CODE_NOT_INITIALIZED

Definition at line 906 of file FieldListObject.h.

References Activ::Database::FieldList::CompareField(), Get(), GetFieldList(), and IsInitialized().

StatusCode Activ::Database::FieldListObject::CompareField | ( | const FieldSpecification::Id | fieldId,
 |  | const std::string & | value,
 |  | int & | result |
 | ) |  |  | const [inline]

Compare a field in a field list object with a supplied string.

Only works for string and array based fields.

Parameters:
fieldId | the id of the field to compare.
value | the string to compare with the record.
result | the result of the comparison.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FIELD_TYPE
STATUS_CODE_NOT_FOUND
STATUS_CODE_NOT_INITIALIZED

Definition at line 896 of file FieldListObject.h.

References Activ::Database::FieldList::CompareField(), Get(), GetFieldList(), and IsInitialized().

StatusCode Activ::Database::FieldListObject::CompareField | ( | const FieldSpecification::Id | fieldId,
 |  | const IFieldType & | iFieldType,
 |  | int & | result |
 | ) |  |  | const [inline]

Compare a field in a field list object with a supplied field.

Parameters:
fieldId | the id of the field to compare.
iFieldType | the field to compare with the record.
result | the result of the comparison.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FIELD_TYPE
STATUS_CODE_NOT_FOUND
STATUS_CODE_NOT_INITIALIZED

Definition at line 886 of file FieldListObject.h.

References Activ::Database::FieldList::CompareField(), Get(), GetFieldList(), and IsInitialized().

StatusCode Activ::Database::FieldListObject::CopyField | ( | const FieldSpecification::Id | targetFieldId,
 |  | const FieldListObject & | sourceFieldListObject,
 |  | const FieldSpecification::Id | sourceFieldId,
 |  | bool & | isDifferent |
 | ) |  |  | [inline]

Copy a field from a supplied field list object.

Parameters:
targetFieldId | the identifier of the field to set.
sourceFieldListObject | the field list object the field is copied from.
sourceFieldId | the identifier of the field to copy.
isDifferent | set to true if the field changed as a result of the call.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FIELD_TYPE
STATUS_CODE_INVALID_LENGTH
STATUS_CODE_NOT_FOUND
STATUS_CODE_NOT_INITIALIZED

Definition at line 876 of file FieldListObject.h.

References Activ::Database::FieldList::CopyField(), Get(), GetFieldList(), and IsInitialized().

StatusCode Activ::Database::FieldListObject::CopyField | ( | const FieldSpecification::Id | targetFieldId,
 |  | const FieldListObject & | sourceFieldListObject,
 |  | const FieldSpecification::Id | sourceFieldId |
 | ) |  |  | [inline]

Copy a field from a supplied field list object.

Parameters:
targetFieldId | the identifier of the field to set.
sourceFieldListObject | the field list object the field is copied from.
sourceFieldId | the identifier of the field to copy.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FIELD_TYPE
STATUS_CODE_INVALID_LENGTH
STATUS_CODE_NOT_FOUND
STATUS_CODE_NOT_INITIALIZED

Definition at line 866 of file FieldListObject.h.

References Activ::Database::FieldList::CopyField(), Get(), GetFieldList(), and IsInitialized().

StatusCode Activ::Database::FieldListObject::CopyField | ( | const FieldSpecification::Id | fieldId,
 |  | const FieldListObject & | sourceFieldListObject,
 |  | bool & | isDifferent |
 | ) |  |  | [inline]

Copy a field.

Parameters:
fieldId | the id of the field to copy.
sourceFieldListObject | the field list object the field is copied from.
isDifferent | set to true if the field changed as a result of the call.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH
STATUS_CODE_NOT_FOUND
STATUS_CODE_NOT_INITIALIZED

Definition at line 856 of file FieldListObject.h.

References Activ::Database::FieldList::CopyField(), Get(), GetFieldList(), and IsInitialized().

StatusCode Activ::Database::FieldListObject::CopyField | ( | const FieldSpecification::Id | fieldId,
 |  | const FieldListObject & | sourceFieldListObject |
 | ) |  |  | [inline]

Copy a field.

Parameters:
fieldId | the id of the field to copy.
sourceFieldListObject | the field list object the field is copied from.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH
STATUS_CODE_NOT_FOUND
STATUS_CODE_NOT_INITIALIZED

Definition at line 846 of file FieldListObject.h.

References Activ::Database::FieldList::CopyField(), Get(), GetFieldList(), and IsInitialized().

StatusCode Activ::Database::FieldListObject::CopyFields | ( | const FieldListObject & | sourceFieldListObject,
 |  | const bool | copyAllFields = false |
 | ) |  |  | [inline, virtual]

Copy all matching fields from a supplied field list object.

Parameters:
sourceFieldListObject | the field list object where fields are copied from.
copyAllFields | whether all fields must be found in the source record.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED

Definition at line 836 of file FieldListObject.h.

References Activ::Database::FieldList::CopyFields(), Get(), GetFieldList(), and IsInitialized().

StatusCode Activ::Database::FieldListObject::DefineField | ( | const FieldSpecification::Id | fieldId,
 |  | const size_t | fieldLength = ~0 |
 | ) |  |  | [inline]

Define a field.

Parameters:
fieldId | the identifier of the field to define.
fieldLength | the length of the field being defined. The default sets the field length to the maximum.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH
STATUS_CODE_NOT_FOUND
STATUS_CODE_NOT_INITIALIZED

Definition at line 976 of file FieldListObject.h.

References Activ::Database::FieldList::DefineField(), Get(), GetFieldList(), and IsInitialized().

virtual StatusCode Activ::Database::FieldListObject::Deserialize | ( | ITable * | pTable,
 |  | MessageValidator & | messageValidator |
 | ) |  |  | [pure virtual]

Deserialize the field list object information from a message.

Parameters:
pTable | table the object will be stored in.
messageValidator | message validator containing the field list object data.
Return values:
STATUS_CODE_SUCCESS
...

Implemented in Activ::Database::Key, and Activ::Database::Record.

FieldListObject::ConstIterator Activ::Database::FieldListObject::End ( ) const [inline]

Get an iterator that points to beyond the last field in the list.

Returns:
an iterator object.

Definition at line 1126 of file FieldListObject.h.

References Activ::Database::FieldList::End(), GetFieldList(), and IsInitialized().

const byte_t * Activ::Database::FieldListObject::Get ( ) const [inline]

Get a pointer to the beginning of the field list object data buffer.

Returns:
a pointer to the beginning of the field list object data buffer.

Definition at line 1084 of file FieldListObject.h.

References m_pData.

byte_t * Activ::Database::FieldListObject::Get ( ) [inline]

Get a pointer to the beginning of the field list object data buffer.

Returns:
a pointer to the beginning of the field list object data buffer.

Definition at line 1077 of file FieldListObject.h.

References m_pData.

Referenced by CompareField(), CopyField(), CopyFields(), DefineField(), GetField(), IsFieldDefined(), IsFieldDifferent(), SetField(), ToLogString(), ToString(), and UndefineField().

StatusCode Activ::Database::FieldListObject::GetField | ( | const ConstIterator & | iterator,
 |  | FieldSpecification::Id & | fieldId,
 |  | FieldSpecification::Type & | type,
 |  | const void *& | pField,
 |  | size_t & | fieldLength |
 | ) |  |  | const [inline]

Get an id and type and a pointer to and the length of a field within the record.

Parameters:
iterator | an iterator to the field to retrieve.
fieldId | set equal to the field's id.
type | set equal to the type of the field.
pField | pointer that will be set to the position of the field within the record.
fieldLength | the retrieved field's length.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_FOUND
STATUS_CODE_NOT_INITIALIZED
STATUS_CODE_UNDEFINED_FIELD

Definition at line 829 of file FieldListObject.h.

References Get(), Activ::Database::FieldList::GetField(), GetFieldList(), and IsInitialized().

StatusCode Activ::Database::FieldListObject::GetField | ( | const ConstIterator & | iterator,
 |  | const void *& | pField,
 |  | size_t & | fieldLength |
 | ) |  |  | const [inline]

Get a pointer to and the length of a field within the record.

Parameters:
iterator | an iterator to the field to retrieve.
pField | pointer that will be set to the position of the field within the record.
fieldLength | the retrieved field's length.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_FOUND
STATUS_CODE_NOT_INITIALIZED
STATUS_CODE_UNDEFINED_FIELD

Definition at line 822 of file FieldListObject.h.

References Get(), Activ::Database::FieldList::GetField(), GetFieldList(), and IsInitialized().

template<typename T>
StatusCode Activ::Database::FieldListObject::GetField | ( | const FieldSpecification::Id | fieldId,
 |  | T & | value |
 | ) |  |  | const [inline]

Get a field.

Parameters:
fieldId | the identifier of the field to retrieve.
value | extracted field is stored in this variable.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FIELD_TYPE
STATUS_CODE_NOT_FOUND
STATUS_CODE_NOT_INITIALIZED
STATUS_CODE_UNDEFINED_FIELD

Definition at line 815 of file FieldListObject.h.

References Get(), Activ::Database::FieldList::GetField(), GetFieldList(), and IsInitialized().

StatusCode Activ::Database::FieldListObject::GetField | ( | const FieldSpecification::Id | fieldId,
 |  | void *& | pField,
 |  | size_t & | fieldLength |
 | ) |  |  | [inline]

Get a pointer to and the length of a field within the record.

The field length is set to zero if the field is undefined.

Parameters:
fieldId | the identifier of the field to retrieve.
pField | pointer that will be set to the position of the field within the record.
fieldLength | the retrieved field's length.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_FOUND
STATUS_CODE_NOT_INITIALIZED
STATUS_CODE_UNDEFINED_FIELD

Definition at line 807 of file FieldListObject.h.

References Get(), Activ::Database::FieldList::GetField(), GetFieldList(), and IsInitialized().

StatusCode Activ::Database::FieldListObject::GetField | ( | const FieldSpecification::Id | fieldId,
 |  | const void *& | pField,
 |  | size_t & | fieldLength |
 | ) |  |  | const [inline]

Get a pointer to and the length of a field within the record.

Parameters:
fieldId | the identifier of the field to retrieve.
pField | pointer that will be set to the position of the field within the record.
fieldLength | the retrieved field's length.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_FOUND
STATUS_CODE_NOT_INITIALIZED
STATUS_CODE_UNDEFINED_FIELD

Definition at line 800 of file FieldListObject.h.

References Get(), Activ::Database::FieldList::GetField(), GetFieldList(), and IsInitialized().

StatusCode Activ::Database::FieldListObject::GetField | ( | const FieldSpecification::Id | fieldId,
 |  | void * | pField,
 |  | const size_t | fieldSize,
 |  | size_t & | fieldLength |
 | ) |  |  | const [inline]

Get the matching field from the record and copy its contents to the provided field buffer.

Parameters:
fieldId | the identifier of the field to retrieve.
pField | the matching field's contents will be copied to here.
fieldSize | size of the buffer the field will be stored in.
fieldLength | the retrieved field's length.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_BUFFER_OVERFLOW
STATUS_CODE_NOT_FOUND
STATUS_CODE_NOT_INITIALIZED
STATUS_CODE_UNDEFINED_FIELD

Definition at line 793 of file FieldListObject.h.

References Get(), Activ::Database::FieldList::GetField(), GetFieldList(), and IsInitialized().

StatusCode Activ::Database::FieldListObject::GetFieldIdList ( FieldIdList & fieldIdList ) const [inline]

Get the list of field identifiers.

Parameters:
fieldIdList set equal to the field identifiers used for this field list object.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED

Definition at line 1024 of file FieldListObject.h.

References Activ::Database::FieldList::GetFieldIdList(), GetFieldList(), and IsInitialized().

const FieldList & Activ::Database::FieldListObject::GetFieldList ( ) const [inline, protected]

Get the field list associated with the object.

Returns:
a reference to the field list of the object.

Definition at line 1147 of file FieldListObject.h.

References m_pFieldList.

Referenced by Begin(), CompareField(), CopyField(), CopyFields(), DefineField(), End(), GetField(), GetFieldIdList(), GetFieldSpecification(), GetFieldSpecificationList(), GetFirstFieldId(), GetNextFieldId(), GetType(), IsFieldDefined(), IsFieldDifferent(), IsFound(), Activ::Database::Record::Reset(), SetField(), ToLogString(), ToString(), and UndefineField().

StatusCode Activ::Database::FieldListObject::GetFieldSpecification | ( | const FieldSpecification::Id | fieldId,
 |  | FieldSpecification & | fieldSpecification |
 | ) |  |  | const [inline]

Get the field specification for the field id specified.

Parameters:
fieldId | the id of the field whose specification is to be retrieved.
fieldSpecification | the variable that will hold the retrieved field specification.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_FOUND
STATUS_CODE_NOT_INITIALIZED

Definition at line 1017 of file FieldListObject.h.

References GetFieldList(), Activ::Database::FieldList::GetFieldSpecification(), and IsInitialized().

StatusCode Activ::Database::FieldListObject::GetFieldSpecificationList ( FieldSpecificationList & fieldSpecificationList ) const [inline]

Get the list of field specifications.

Parameters:
fieldSpecificationList field specification list.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED

Definition at line 1004 of file FieldListObject.h.

References GetFieldList(), Activ::Database::FieldList::GetFieldSpecificationList(), and IsInitialized().

StatusCode Activ::Database::FieldListObject::GetFirstFieldId ( FieldSpecification::Id & fieldId ) const [inline]

Get the id of the first field in the field list object.

Parameters:
fieldId set equal to the first field id in the field list object
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED

Definition at line 1037 of file FieldListObject.h.

References GetFieldList(), Activ::Database::FieldList::GetFirstFieldId(), and IsInitialized().

DataId Activ::Database::FieldListObject::GetId ( ) const [inline]

Get the current identifier stored in this field list object.

Returns:
the identifier of the field list object.

Definition at line 1098 of file FieldListObject.h.

References m_id.

ACTIV_DATABASE_API StatusCode Activ::Database::FieldListObject::GetMatchingFieldsById | ( | FieldIdList & | fieldIdList,
 |  | const FieldListObject & | rhsFieldListObject
 | ) |  |

Get the matching fields in two records by id.

Parameters:
fieldIdList | the list of field ids that match.
rhsFieldListObject | the right hand field list object to compare against.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED

ACTIV_DATABASE_API StatusCode Activ::Database::FieldListObject::GetMatchingFieldsByName | ( | FieldIdList & | lhsFieldIdList,
 |  | const FieldListObject & | rhsFieldListObject,
 |  | FieldIdList & | rhsFieldIdList
 | ) |  |

Get the matching fields in two records by name.

Parameters:
lhsFieldIdList | the left hand field id list.
rhsFieldListObject | the right hand field list object to compare against.
rhsFieldIdList | the right hand field id list.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED

StatusCode Activ::Database::FieldListObject::GetNextFieldId ( FieldSpecification::Id & fieldId ) const [inline]

Get the id of the next field in the field list object.

Parameters:
fieldId set equal to the next field id in the field list object
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_FOUND
STATUS_CODE_NOT_INITIALIZED

Definition at line 1050 of file FieldListObject.h.

References GetFieldList(), Activ::Database::FieldList::GetNextFieldId(), and IsInitialized().

StatusCode Activ::Database::FieldListObject::GetTablePointer ( ITable *& pTable ) const [inline]

Get a pointer to the table.

Parameters:
pTable set equal to the table pointer.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED

Definition at line 1064 of file FieldListObject.h.

References IsInitialized(), and m_pTable.

StatusCode Activ::Database::FieldListObject::GetType | ( | const FieldSpecification::Id | fieldId,
 |  | FieldSpecification::Type & | type |
 | ) |  |  | const [inline]

Get the field type for the field id specified.

Parameters:
fieldId | the id of the field whose specification is to be retrieved.
type | set equal to the type of the field.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_FOUND
STATUS_CODE_NOT_INITIALIZED

Definition at line 1057 of file FieldListObject.h.

References GetFieldList(), Activ::Database::FieldList::GetType(), and IsInitialized().

StatusCode Activ::Database::FieldListObject::Initialize | ( | ITable * | pTable,
 |  | const FieldList * | pFieldList,
 |  | const size_t | requiredBufferSize |
 | ) |  |  | [inline]

Initialize.

Parameters:
pTable | the table to initialize the field list object for.
pFieldList | the field list.
requiredBufferSize | the required buffer size.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_HEAP_EMPTY
STATUS_CODE_INVALID_PARAMETER

Definition at line 731 of file FieldListObject.h.

References ACTIV_RETURN_RESULT_IF, AllocateBuffer(), Activ::Database::ITable::GetIdentity(), m_bufferSize, m_isInitialized, m_pFieldList, m_pTable, and m_tableIdentity.

StatusCode Activ::Database::FieldListObject::IsFieldDefined | ( | const FieldSpecification::Id | fieldId,
 |  | bool & | result |
 | ) |  |  | const [inline]

Check whether a field is defined.

Parameters:
fieldId | the identifier of the field to define.
result | set equal to true if the field is defined, false otherwise.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_FOUND
STATUS_CODE_NOT_INITIALIZED

Definition at line 997 of file FieldListObject.h.

References Get(), GetFieldList(), Activ::Database::FieldList::IsFieldDefined(), and IsInitialized().

StatusCode Activ::Database::FieldListObject::IsFieldDifferent | ( | const FieldSpecification::Id | lhsFieldId,
 |  | const FieldListObject & | rhsFieldListObject,
 |  | const FieldSpecification::Id | rhsFieldId,
 |  | bool & | result |
 | ) |  |  | const [inline]

Check whether two fields of the same type are different between two field list objects.

Parameters:
lhsFieldId | the id of the left hand field to compare.
rhsFieldListObject | the right hand field list object to compare against.
rhsFieldId | the id of the right hand field to compare.
result | set equal to true if the field is different, false otherwise.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_FOUND

Definition at line 966 of file FieldListObject.h.

References Get(), GetFieldList(), Activ::Database::FieldList::IsFieldDifferent(), and IsInitialized().

StatusCode Activ::Database::FieldListObject::IsFieldDifferent | ( | const FieldSpecification::Id | fieldId,
 |  | const FieldListObject & | rhsFieldListObject,
 |  | bool & | result |
 | ) |  |  | const [inline]

Check whether a field is different between two field list objects.

Parameters:
fieldId | the id of the field to compare.
rhsFieldListObject | the right hand field list object to compare against.
result | set equal to true if the field is different, false otherwise.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_FOUND

Definition at line 956 of file FieldListObject.h.

References Get(), GetFieldList(), Activ::Database::FieldList::IsFieldDifferent(), and IsInitialized().

StatusCode Activ::Database::FieldListObject::IsFieldDifferent | ( | const FieldSpecification::Id | fieldId,
 |  | const std::string & | value,
 |  | bool & | result |
 | ) |  |  | const [inline]

Check whether a field is different than a supplied string.

Only works for string and array based fields.

Parameters:
fieldId | the id of the field to compare.
value | the string to compare with the record.
result | set equal to true if the field is different, false otherwise.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FIELD_TYPE
STATUS_CODE_NOT_FOUND
STATUS_CODE_NOT_INITIALIZED

Definition at line 946 of file FieldListObject.h.

References Get(), GetFieldList(), Activ::Database::FieldList::IsFieldDifferent(), and IsInitialized().

StatusCode Activ::Database::FieldListObject::IsFieldDifferent | ( | const FieldSpecification::Id | fieldId,
 |  | const IFieldType & | iFieldType,
 |  | bool & | result |
 | ) |  |  | const [inline]

Check whether a field is different than a supplied field.

Parameters:
fieldId | the id of the field to compare.
iFieldType | the field to compare with the record.
result | set equal to true if the field is different, false otherwise.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FIELD_TYPE
STATUS_CODE_NOT_FOUND
STATUS_CODE_NOT_INITIALIZED

Definition at line 936 of file FieldListObject.h.

References Get(), GetFieldList(), Activ::Database::FieldList::IsFieldDifferent(), and IsInitialized().

StatusCode Activ::Database::FieldListObject::IsFieldDifferent | ( | const FieldSpecification::Id | fieldId,
 |  | const void * | pField,
 |  | const size_t | fieldLength,
 |  | bool & | result |
 | ) |  |  | const [inline]

Check whether a field is different than a supplied field buffer and length.

Parameters:
fieldId | the id of the field to compare.
pField | pointer to field.
fieldLength | field length.
result | set equal to true if the field is different, false otherwise.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FIELD_TYPE
STATUS_CODE_NOT_FOUND
STATUS_CODE_NOT_INITIALIZED

Definition at line 926 of file FieldListObject.h.

References Get(), GetFieldList(), Activ::Database::FieldList::IsFieldDifferent(), and IsInitialized().

bool Activ::Database::FieldListObject::IsFound ( const FieldSpecification::Id fieldId ) const [inline]

Check whether a field id is valid for this field list object.

Returns:
true if the field id can be found, false otherwise.

Definition at line 1140 of file FieldListObject.h.

References GetFieldList(), Activ::Database::FieldList::IsFound(), and IsInitialized().

bool Activ::Database::FieldListObject::IsInitialized ( ) const [inline]

Is the field list object initialized.

Returns:
true if the field list object has been initialized, false otherwise.

Definition at line 1133 of file FieldListObject.h.

References Activ::Database::ITable::GetIdentity(), m_isInitialized, m_pTable, and m_tableIdentity.

Referenced by Begin(), CompareField(), CopyField(), CopyFields(), DefineField(), End(), Activ::Database::Record::GetDataLength(), Activ::Database::Key::GetDataLength(), GetField(), GetFieldIdList(), GetFieldSpecification(), GetFieldSpecificationList(), GetFirstFieldId(), Activ::Database::Key::GetIndexNumber(), Activ::Database::Key::GetIndexPointer(), Activ::Database::Key::GetIndexSpecification(), GetNextFieldId(), GetTablePointer(), GetType(), IsFieldDefined(), IsFieldDifferent(), IsFound(), Activ::Database::Key::operator<(), Activ::Database::Key::operator<=(), Activ::Database::Key::operator==(), Activ::Database::Key::operator>=(), Activ::Database::Record::Reset(), Activ::Database::Key::Reset(), Activ::Database::Record::Set(), Activ::Database::Key::Set(), SetField(), Activ::Database::Record::SetIndexFields(), Activ::Database::Key::SetIndexFields(), ToLogString(), ToString(), UndefineField(), and Activ::Database::Key::Validate().

virtual StatusCode Activ::Database::FieldListObject::Reset ( ) [pure virtual]

Reset the contents of the field list object data buffer.

Return values:
STATUS_CODE_SUCCESS
...

Implemented in Activ::Database::Key, and Activ::Database::Record.

virtual StatusCode Activ::Database::FieldListObject::Serialize ( MessageBuilder & messageBuilder ) const [pure virtual]

Serialize the field list object information into a message.

Parameters:
messageBuilder the message builder into which the field list object data will be placed.
Return values:
STATUS_CODE_SUCCESS
...

Implemented in Activ::Database::Key, and Activ::Database::Record.

template<typename T>
StatusCode Activ::Database::FieldListObject::SetField | ( | const FieldSpecification::Id | fieldId,
 |  | const T & | value,
 |  | bool & | isDifferent |
 | ) |  |  | [inline]

Set a field.

Parameters:
fieldId | the identifier of the field to set.
value | the value to store in the field.
isDifferent | set to true if the field changed as a result of the call.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FIELD_TYPE
STATUS_CODE_INVALID_LENGTH
STATUS_CODE_NOT_FOUND
STATUS_CODE_NOT_INITIALIZED

Definition at line 786 of file FieldListObject.h.

References Get(), GetFieldList(), IsInitialized(), and Activ::Database::FieldList::SetField().

template<typename T>
StatusCode Activ::Database::FieldListObject::SetField | ( | const FieldSpecification::Id | fieldId,
 |  | const T & | value |
 | ) |  |  | [inline]

Set a field.

Parameters:
fieldId | the identifier of the field to set.
value | the value to store in the field.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FIELD_TYPE
STATUS_CODE_INVALID_LENGTH
STATUS_CODE_NOT_FOUND
STATUS_CODE_NOT_INITIALIZED

Definition at line 778 of file FieldListObject.h.

References Get(), GetFieldList(), IsInitialized(), and Activ::Database::FieldList::SetField().

StatusCode Activ::Database::FieldListObject::SetField | ( | const FieldSpecification::Id | fieldId,
 |  | const void * | pField,
 |  | const size_t | fieldLength,
 |  | bool & | isDifferent |
 | ) |  |  | [inline]

Set a field from a supplied pointer and length.

Parameters:
fieldId | the identifier of the field to set.
pField | pointer to the field to be set in the record.
fieldLength | the length of the field to be set in the record.
isDifferent | set to true if the field changed as a result of the call.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH
STATUS_CODE_NOT_INITIALIZED
STATUS_CODE_NOT_FOUND

Definition at line 770 of file FieldListObject.h.

References Get(), GetFieldList(), IsInitialized(), and Activ::Database::FieldList::SetField().

StatusCode Activ::Database::FieldListObject::SetField | ( | const FieldSpecification::Id | fieldId,
 |  | const void * | pField,
 |  | const size_t | fieldLength |
 | ) |  |  | [inline]

Set a field from a supplied pointer and length.

Parameters:
fieldId | the identifier of the field to set.
pField | pointer to the field to be set in the record.
fieldLength | the length of the field to be set in the record.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH
STATUS_CODE_NOT_INITIALIZED
STATUS_CODE_NOT_FOUND

Definition at line 763 of file FieldListObject.h.

References Get(), GetFieldList(), IsInitialized(), and Activ::Database::FieldList::SetField().

void Activ::Database::FieldListObject::SetId ( const DataId id ) const [inline]

Set the record id in this field list object.

Parameters:
id the identifier to store with the field list object.

Definition at line 1091 of file FieldListObject.h.

References m_id.

std::string Activ::Database::FieldListObject::ToLogString ( ) const [inline]

Convert the field list object to a log string.

Returns:
the field list object as a log string.

Definition at line 1112 of file FieldListObject.h.

References Get(), GetFieldList(), IsInitialized(), and Activ::Database::FieldList::ToLogString().

std::string Activ::Database::FieldListObject::ToString ( ) const [inline]

Convert the field list object to a string.

Returns:
the field list object as a string.

Definition at line 1105 of file FieldListObject.h.

References Get(), GetFieldList(), IsInitialized(), and Activ::Database::FieldList::ToString().

Referenced by operator<<().

StatusCode Activ::Database::FieldListObject::UndefineField | ( | const FieldSpecification::Id | fieldId,
 |  | bool & | isDifferent |
 | ) |  |  | [inline]

Undefine a field.

Parameters:
fieldId | the identifier of the field to undefine.
isDifferent | set to true if the field changed as a result of the call.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_FOUND
STATUS_CODE_NOT_INITIALIZED

Definition at line 990 of file FieldListObject.h.

References Get(), GetFieldList(), IsInitialized(), and Activ::Database::FieldList::UndefineField().

StatusCode Activ::Database::FieldListObject::UndefineField ( const FieldSpecification::Id fieldId ) [inline]

Undefine a field.

Parameters:
fieldId the identifier of the field to undefine.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_FOUND
STATUS_CODE_NOT_INITIALIZED

Definition at line 983 of file FieldListObject.h.

References Get(), GetFieldList(), IsInitialized(), and Activ::Database::FieldList::UndefineField().

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivDatabase/FieldListObject.h
Generated on Wed Oct 8 14:02:11 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Database::FieldSpecification

Activ::Database::FieldSpecification Class Reference

Field specification structure. More...

#include <ActivMiddleware/ActivDatabase/FieldSpecification.h>

List of all members.

Public Types

enum | { PROPERTY_NONE = 0x0000000 }
Field properties.
typedef uint16_t | Id
Unique identifier for fields.
typedef uint32_t | Properties
Definition of the field properties.
enum Type {
TYPE_NONE, TYPE_BINARY_ARRAY, TYPE_BINARY_STRING, TYPE_BITMAP,
TYPE_BLOB, TYPE_DATE, TYPE_DATE_TIME, TYPE_POINTER,
TYPE_RATIONAL, TYPE_SIGNED_INTEGRAL, TYPE_TEXT_ARRAY, TYPE_TEXT_STRING,
TYPE_TIME, TYPE_TRATIONAL, TYPE_UNSIGNED_INTEGRAL, TYPE_BOOLEAN,
TYPE_CRC_BLOB, NUMBER_OF_TYPES
}
Types.

Public Member Functions

ACTIV_DATABASE_API StatusCode | Deserialize (MessageValidator &messageValidator)
Deserialize a field specification from a message.
ACTIV_DATABASE_API | FieldSpecification (const Id id, const std::string &name, const Type type, const size_t maxLength, const size_t offset=0, const Properties properties=PROPERTY_NONE)
Constructor.
ACTIV_DATABASE_API | FieldSpecification ()
Constructor.
ACTIV_DATABASE_API bool | IsMatch (const FieldSpecification &rhs) const
Is a match.
ACTIV_DATABASE_API bool | operator!= (const FieldSpecification &rhs) const
Inequality operator.
ACTIV_DATABASE_API bool | operator< (const FieldSpecification &rhs) const
Less than operator.
ACTIV_DATABASE_API bool | operator== (const FieldSpecification &rhs) const
Equality operator.
ACTIV_DATABASE_API StatusCode | Serialize (MessageBuilder &messageBuilder) const
Serialize the field specification into a message.
ACTIV_DATABASE_API std::string | ToFormattedString () const
To formatted string.
ACTIV_DATABASE_API std::string | ToString () const
Convert the specification to a C-style string.
ACTIV_DATABASE_API void | Validate () const
Validate a field specification.

Static Public Member Functions

static ACTIV_DATABASE_API
StatusCode 		GetActivFieldType (const FieldSpecification::Type databaseFieldType, FieldType &activFieldType)
Get an Activ field type from a database field type.
static ACTIV_DATABASE_API
StatusCode 		GetDatabaseFieldType (const FieldType activFieldType, FieldSpecification::Type &databaseFieldType)
Get a database field type from an Activ field type.
static ACTIV_DATABASE_API
std::string 		ToFormattedHeaderString ()
To formatted header string.

Public Attributes

Id m_id
Unique field identifier.
size_t | m_maxLength
Maximum allowed length.
std::string | m_name
Name.
size_t | m_offset
Offset within record buffer. Automatically calculated for managed tables.
uint32_t | m_properties
Properties.
Type m_type
Type.

Static Public Attributes

static const Id | UNDEFINED_FIELD_ID = ~0
Undefined field id.

Detailed Description

Field specification structure.

Definition at line 64 of file FieldSpecification.h.

Constructor & Destructor Documentation

ACTIV_DATABASE_API Activ::Database::FieldSpecification::FieldSpecification | ( | const Id | id,
 |  | const std::string & | name,
 |  | const Type | type,
 |  | const size_t | maxLength,
 |  | const size_t | offset = 0,
 |  | const Properties | properties = PROPERTY_NONE
 | ) |  |

Constructor.

Parameters:
id | unique identifier for the field.
name | name of the field.
type | type of the field.
maxLength | maximum length of the field.
offset | offset of the field.
properties | properties of the field.
Exceptions:
DatabaseException

Member Function Documentation

ACTIV_DATABASE_API StatusCode Activ::Database::FieldSpecification::Deserialize ( MessageValidator & messageValidator )

Deserialize a field specification from a message.

Parameters:
messageValidator the message validator from which the field specification is extracted.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_HEAP_EMPTY
STATUS_CODE_NOT_INITIALIZED

static ACTIV_DATABASE_API StatusCode Activ::Database::FieldSpecification::GetActivFieldType | ( | const FieldSpecification::Type | databaseFieldType,
 |  | FieldType & | activFieldType |
 | ) |  |  | [static]

Get an Activ field type from a database field type.

Parameters:
databaseFieldType | the database field type to convert to an Activ field type.
activFieldType | set equal to the matching Activ field type.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FIELD_TYPE

static ACTIV_DATABASE_API StatusCode Activ::Database::FieldSpecification::GetDatabaseFieldType | ( | const FieldType | activFieldType,
 |  | FieldSpecification::Type & | databaseFieldType |
 | ) |  |  | [static]

Get a database field type from an Activ field type.

Parameters:
activFieldType | the Activ field type to convert to a database field type.
databaseFieldType | set equal to the matching database field type.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FIELD_TYPE

ACTIV_DATABASE_API bool Activ::Database::FieldSpecification::IsMatch ( const FieldSpecification & rhs ) const

Is a match.

Parameters:
rhs the object to compare with.
Returns:
true if this field specification matches the criteria specified in the supplied field specification.

ACTIV_DATABASE_API bool Activ::Database::FieldSpecification::operator!= ( const FieldSpecification & rhs ) const

Inequality operator.

Parameters:
rhs the object to compare with.
Returns:
the result of the test.

ACTIV_DATABASE_API bool Activ::Database::FieldSpecification::operator< ( const FieldSpecification & rhs ) const

Less than operator.

Parameters:
rhs the object to compare with.
Returns:
the result of the test.

ACTIV_DATABASE_API bool Activ::Database::FieldSpecification::operator== ( const FieldSpecification & rhs ) const

Equality operator.

Parameters:
rhs the object to compare with.
Returns:
the result of the test.

ACTIV_DATABASE_API StatusCode Activ::Database::FieldSpecification::Serialize ( MessageBuilder & messageBuilder ) const

Serialize the field specification into a message.

Parameters:
messageBuilder the message builder used for constructing the message.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED
STATUS_CODE_FAILURE

static ACTIV_DATABASE_API std::string Activ::Database::FieldSpecification::ToFormattedHeaderString ( ) [static]

To formatted header string.

Returns:
the specification as a formatted header string.

ACTIV_DATABASE_API std::string Activ::Database::FieldSpecification::ToFormattedString ( ) const

To formatted string.

Returns:
the specification as a formatted string.

ACTIV_DATABASE_API std::string Activ::Database::FieldSpecification::ToString ( ) const

Convert the specification to a C-style string.

Returns:
the specification as a string.

ACTIV_DATABASE_API void Activ::Database::FieldSpecification::Validate ( ) const

Validate a field specification.

Exceptions:
DatabaseException

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivDatabase/FieldSpecification.h
Generated on Wed Oct 8 14:02:11 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Database::IIndex

Activ::Database::IIndex Class Reference

Abstract base index class. More...

#include <ActivMiddleware/ActivDatabase/IIndex.h>

List of all members.

Public Member Functions

virtual StatusCode | BuildKey (Key &targetKey, const Key &sourceKey) const =0
Build a key using another key.
virtual StatusCode | BuildKey (Key &key, const byte_t *pRecordData, const DataId recordId) const =0
Build key using record pointer and record identifier.
virtual void | CheckIntegrity () const =0
Check the integrity of the index.
virtual int | Compare (const Key &lhs, const Key &rhs) const =0
Compare keys.
virtual size_t | GetCurrentRecords () const =0
Get the number of records.
virtual FieldIdList | GetFieldIdList () const =0
Get the list of all field identifiers.
virtual const FieldList & | GetFieldList () const =0
Get a reference to the field list of the index.
virtual FieldSpecificationList | GetFieldSpecificationList () const =0
Get the list of all field specifications.
virtual size_t | GetKeyLength () const =0
Get key length.
virtual std::string | GetName () const =0
Get name.
virtual IndexSpecification::Number | GetNumber () const =0
Get number of the index.
virtual IndexSpecification | GetSpecification () const =0
Get the specification of the index.
virtual bool | IsDuplicate () const =0
Is this a duplicate index.
virtual bool | IsPrimaryUnique () const =0
Is this the primary unique index.
virtual bool | IsTree () const =0
Is this a tree index.
virtual bool | IsUnique () const =0
Is this a unique index.
virtual void | ResetKey (Key &key) const =0
Reset key.
virtual StatusCode | SetFields (Key &key, const ScatterBufferHelper &scatterBufferHelper) const =0
Set the index fields in the key, starting with the first field in the index.
virtual StatusCode | SetFields (Record &record, const ScatterBufferHelper &scatterBufferHelper) const =0
Set the index fields in the record, starting with the first field in the index.
virtual | ~IIndex ()=0
Default destructor.

Detailed Description

Abstract base index class.

Definition at line 36 of file IIndex.h.

Member Function Documentation

virtual StatusCode Activ::Database::IIndex::BuildKey | ( | Key & | targetKey,
 |  | const Key & | sourceKey |
 | ) |  |  | const [pure virtual]

Build a key using another key.

Parameters:
targetKey | built key is stored in this parameter.
sourceKey | key from which fields will be copied.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_FOUND
STATUS_CODE_INVALID_LENGTH

virtual StatusCode Activ::Database::IIndex::BuildKey | ( | Key & | key,
 |  | const byte_t * | pRecordData,
 |  | const DataId | recordId |
 | ) |  |  | const [pure virtual]

Build key using record pointer and record identifier.

Parameters:
key | built key is stored in this parameter.
pRecordData | a pointer to the record data from which the key fields will be copied.
recordId | record indentifier of matching key in the index.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_FOUND
STATUS_CODE_INVALID_LENGTH

virtual void Activ::Database::IIndex::CheckIntegrity ( ) const [pure virtual]

Check the integrity of the index.

Exceptions:
DatabaseException.

virtual int Activ::Database::IIndex::Compare | ( | const Key & | lhs,
 |  | const Key & | rhs |
 | ) |  |  | const [pure virtual]

Compare keys.

Parameters:
lhs | left hand key.
rhs | right hand key.
Returns:
negative value if left hand data is less than right hand data, positive if left is greater than right and 0 otherwise.

Referenced by Activ::Database::Key::operator<(), Activ::Database::Key::operator<=(), Activ::Database::Key::operator==(), and Activ::Database::Key::operator>=().

virtual size_t Activ::Database::IIndex::GetCurrentRecords ( ) const [pure virtual]

Get the number of records.

Returns:
the number of records in the index.
Exceptions:
StatusCodeException

virtual FieldIdList Activ::Database::IIndex::GetFieldIdList ( ) const [pure virtual]

Get the list of all field identifiers.

Returns:
the field identifier list.

virtual const FieldList& Activ::Database::IIndex::GetFieldList ( ) const [pure virtual]

Get a reference to the field list of the index.

Returns:
the field list of the index.

virtual FieldSpecificationList Activ::Database::IIndex::GetFieldSpecificationList ( ) const [pure virtual]

Get the list of all field specifications.

Returns:
the field specification list.

virtual size_t Activ::Database::IIndex::GetKeyLength ( ) const [pure virtual]

Get key length.

Returns:
length of key.

Referenced by Activ::Database::Key::GetDataLength().

virtual std::string Activ::Database::IIndex::GetName ( ) const [pure virtual]

Get name.

Returns:
name of index.

Referenced by Activ::Database::Key::operator<(), Activ::Database::Key::operator<=(), and Activ::Database::Key::operator>=().

virtual IndexSpecification::Number Activ::Database::IIndex::GetNumber ( ) const [pure virtual]

Get number of the index.

Returns:
number of the index.

virtual IndexSpecification Activ::Database::IIndex::GetSpecification ( ) const [pure virtual]

Get the specification of the index.

Returns:
the specification of the index.

Referenced by Activ::Database::Key::GetIndexSpecification().

virtual bool Activ::Database::IIndex::IsDuplicate ( ) const [pure virtual]

Is this a duplicate index.

Returns:
true if added keys have can be duplicated in the index, false otherwise.

virtual bool Activ::Database::IIndex::IsPrimaryUnique ( ) const [pure virtual]

Is this the primary unique index.

Returns:
true if this is the primary unqiue index, false otherwise.

virtual bool Activ::Database::IIndex::IsTree ( ) const [pure virtual]

Is this a tree index.

Returns:
true if the index is a tree and therefore supports in order walks, false otherwise.

virtual bool Activ::Database::IIndex::IsUnique ( ) const [pure virtual]

Is this a unique index.

Returns:
true if added keys have to be unique, false otherwise.

virtual void Activ::Database::IIndex::ResetKey ( Key & key ) const [pure virtual]

Reset key.

Parameters:
key key to reset.

Referenced by Activ::Database::Key::Reset().

virtual StatusCode Activ::Database::IIndex::SetFields | ( | Key & | key,
 |  | const ScatterBufferHelper & | scatterBufferHelper |
 | ) |  |  | const [pure virtual]

Set the index fields in the key, starting with the first field in the index.

Parameters:
key | the key in which the index fields will be stored.
scatterBufferHelper | a scatter buffer helper containing the fields to copy to the record.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH
STATUS_CODE_INVALID_PARAMETER

virtual StatusCode Activ::Database::IIndex::SetFields | ( | Record & | record,
 |  | const ScatterBufferHelper & | scatterBufferHelper |
 | ) |  |  | const [pure virtual]

Set the index fields in the record, starting with the first field in the index.

Parameters:
record | the record in which the index fields will be stored.
scatterBufferHelper | a scatter buffer helper containing the fields to copy to the record.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH
STATUS_CODE_INVALID_PARAMETER

Referenced by Activ::Database::Key::SetIndexFields().

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivDatabase/IIndex.h
Generated on Wed Oct 8 14:02:11 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Database::IndexSpecification

Activ::Database::IndexSpecification Class Reference

Index Specification structure. More...

#include <ActivMiddleware/ActivDatabase/IndexSpecification.h>

List of all members.

Public Types

enum | { PROPERTY_NONE = 0x00000001, PROPERTY_UNIQUE = 0x00000002, PROPERTY_DUPLICATE = 0x00000004, PROPERTY_PRIMARY_UNIQUE = 0x00000008 }
Properties of the index.
typedef uint16_t | Number
Unique number for an index.
typedef uint32_t | Properties
Definition of the index properties.
enum | Type { TYPE_NONE, TYPE_HASH, TYPE_RED_BLACK_TREE }
Type of the index.

Public Member Functions

ACTIV_DATABASE_API StatusCode | Deserialize (MessageValidator &messageValidator)
Deserialize an index specification from a message.
IndexSpecification (const std::string &name, const Type type, const Properties properties, const std::vector< IndexSpecification::Field > &indexFieldSpecificationList, const std::vector< uint16_t > &cachedFieldIdList)
Constructor.
ACTIV_DATABASE_API | IndexSpecification (const std::string &name, const Type type, const Properties properties, const std::vector< IndexSpecification::Field > &indexFieldSpecificationList)
Constructor.
ACTIV_DATABASE_API | IndexSpecification ()
Constructor.
ACTIV_DATABASE_API bool | IsDuplicate () const
Is this a duplicate index.
ACTIV_DATABASE_API bool | IsHash () const
Is this a hash index.
ACTIV_DATABASE_API bool | IsMatch (const IndexSpecification &rhs) const
Is a match.
ACTIV_DATABASE_API bool | IsPrimaryUnique () const
Is this the primary unique index.
ACTIV_DATABASE_API bool | IsTree () const
Is this a tree index.
ACTIV_DATABASE_API bool | IsUnique () const
Is this a unique index.
ACTIV_DATABASE_API bool | operator!= (const IndexSpecification &rhs) const
Inequality operator.
bool | operator< (const IndexSpecification &rhs) const
Less than operator.
ACTIV_DATABASE_API bool | operator== (const IndexSpecification &rhs) const
Equality operator.
ACTIV_DATABASE_API StatusCode | Serialize (MessageBuilder &messageBuilder) const
Serialize the index specification into a message.
ACTIV_DATABASE_API std::string | ToString () const
Convert the specification to a C-style string.
ACTIV_DATABASE_API void | Validate () const
Validate the index specification.

Public Attributes

std::vector
< FieldSpecification::Id > 		m_cachedFieldIdList
List of ids of cached fields.
std::vector< Field > | m_indexFieldSpecificationList
List of fields in the index.
std::string | m_name
Name of the index.
Number m_number
Number of the index.
Properties m_properties
Properties of the index.
Type m_type
Type of the index.

Static Public Attributes

static const Number | UNDEFINED_INDEX_NUMBER = ~0
Reserved value used to identify undefined index identifier.

Friends

class | Index

Classes

class | Field
Index field specification structure. More...

Detailed Description

Index Specification structure.

Definition at line 43 of file IndexSpecification.h.

Constructor & Destructor Documentation

ACTIV_DATABASE_API Activ::Database::IndexSpecification::IndexSpecification | ( | const std::string & | name,
 |  | const Type | type,
 |  | const Properties | properties,
 |  | const std::vector< IndexSpecification::Field > & | indexFieldSpecificationList
 | ) |  |

Constructor.

Parameters:
name | name of index.
type | index type.
properties | index properties.
indexFieldSpecificationList | list of index field specifications.
Exceptions:
DatabaseException

Activ::Database::IndexSpecification::IndexSpecification | ( | const std::string & | name,
 |  | const Type | type,
 |  | const Properties | properties,
 |  | const std::vector< IndexSpecification::Field > & | indexFieldSpecificationList,
 |  | const std::vector< uint16_t > & | cachedFieldIdList
 | ) |  |

Constructor.

Parameters:
name | name of index.
type | index type.
properties | index properties.
indexFieldSpecificationList | list of index field specifications.
cachedFieldIdList | list of ids of cached fields.
Exceptions:
DatabaseException

Member Function Documentation

ACTIV_DATABASE_API StatusCode Activ::Database::IndexSpecification::Deserialize ( MessageValidator & messageValidator )

Deserialize an index specification from a message.

Parameters:
messageValidator the message validator from which the specification is extracted.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_HEAP_EMPTY
STATUS_CODE_NOT_INITIALIZED

ACTIV_DATABASE_API bool Activ::Database::IndexSpecification::IsDuplicate ( ) const

Is this a duplicate index.

Returns:
true if added keys have can be duplicated in the index, false otherwise.

ACTIV_DATABASE_API bool Activ::Database::IndexSpecification::IsHash ( ) const

Is this a hash index.

Returns:
true if this is a hash index, false otherwise.

ACTIV_DATABASE_API bool Activ::Database::IndexSpecification::IsMatch ( const IndexSpecification & rhs ) const

Is a match.

Parameters:
rhs the object to compare with.
Returns:
true if this index matches the criteria specified in the supplied index specification.

ACTIV_DATABASE_API bool Activ::Database::IndexSpecification::IsPrimaryUnique ( ) const

Is this the primary unique index.

Returns:
true if this is the primary unqiue index, false otherwise.

ACTIV_DATABASE_API bool Activ::Database::IndexSpecification::IsTree ( ) const

Is this a tree index.

Returns:
true if this is a tree index, false otherwise.

ACTIV_DATABASE_API bool Activ::Database::IndexSpecification::IsUnique ( ) const

Is this a unique index.

Returns:
true if added keys have to be unique, false otherwise.

ACTIV_DATABASE_API bool Activ::Database::IndexSpecification::operator!= ( const IndexSpecification & rhs ) const

Inequality operator.

Parameters:
rhs the object to compare with.
Returns:
the result of the test.

bool Activ::Database::IndexSpecification::operator< ( const IndexSpecification & rhs ) const

Less than operator.

Parameters:
rhs the object to compare with.
Returns:
the result of the test.
Exceptions:
StatusCodeException

ACTIV_DATABASE_API bool Activ::Database::IndexSpecification::operator== ( const IndexSpecification & rhs ) const

Equality operator.

Parameters:
rhs the object to compare with.
Returns:
the result of the test.

ACTIV_DATABASE_API StatusCode Activ::Database::IndexSpecification::Serialize ( MessageBuilder & messageBuilder ) const

Serialize the index specification into a message.

Parameters:
messageBuilder the message builder used for constructing the message.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED
STATUS_CODE_FAILURE

ACTIV_DATABASE_API std::string Activ::Database::IndexSpecification::ToString ( ) const

Convert the specification to a C-style string.

Returns:
the specification as a string.

ACTIV_DATABASE_API void Activ::Database::IndexSpecification::Validate ( ) const

Validate the index specification.

Exceptions:
DatabaseException

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivDatabase/IndexSpecification.h
Generated on Wed Oct 8 14:02:11 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Database::IndexSpecification::Field

Activ::Database::IndexSpecification::Field Class Reference

Index field specification structure. More...

#include <ActivMiddleware/ActivDatabase/IndexSpecification.h>

List of all members.

Public Types

enum | { PROPERTY_NONE = 0x00000000, PROPERTY_ASCENDING = PROPERTY_NONE, PROPERTY_DESCENDING = 0x80000000 }
Index Field Properties.
typedef uint32_t | Properties
Field properties type definition.

Public Member Functions

StatusCode | Deserialize (MessageValidator &messageValidator)
Deserialize an index field specification from a message.
Field (const FieldSpecification::Id fieldId, const Properties properties=PROPERTY_NONE)
Constructor.
Field ()
Constructor.
bool | operator!= (const Field &rhs) const
Inequality operator.
bool | operator== (const Field &rhs) const
Equality operator.
StatusCode | Serialize (MessageBuilder &messageBuilder) const
Serialize the index field specification into a message.

Static Public Member Functions

static bool | IsAscending (const Properties properties)
Is ascending.
static bool | IsDescending (const Properties properties)
Is descending.

Public Attributes

FieldSpecification::Id m_fieldId
Field identifier for matching field within the record field list.
Properties m_properties
Properties.

Detailed Description

Index field specification structure.

Definition at line 73 of file IndexSpecification.h.

Constructor & Destructor Documentation

Activ::Database::IndexSpecification::Field::Field | ( | const FieldSpecification::Id | fieldId,
 |  | const Properties | properties = PROPERTY_NONE |
 | ) |  |  | [explicit]

Constructor.

Parameters:
fieldId | the identifier of the key field.
properties | properties of the key field.

Member Function Documentation

StatusCode Activ::Database::IndexSpecification::Field::Deserialize ( MessageValidator & messageValidator )

Deserialize an index field specification from a message.

Parameters:
messageValidator the message validator from which the field specification is extracted.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_HEAP_EMPTY
STATUS_CODE_NOT_INITIALIZED

static bool Activ::Database::IndexSpecification::Field::IsAscending ( const Properties properties ) [static]

Is ascending.

Parameters:
properties the field properties to check.
Returns:
true if the field should be ordered in ascending value.

static bool Activ::Database::IndexSpecification::Field::IsDescending ( const Properties properties ) [static]

Is descending.

Parameters:
properties the field properties to check.
Returns:
true if the field should be ordered in descending value.

bool Activ::Database::IndexSpecification::Field::operator!= ( const Field & rhs ) const

Inequality operator.

Parameters:
rhs the object to compare with.
Returns:
the result of the test.

bool Activ::Database::IndexSpecification::Field::operator== ( const Field & rhs ) const

Equality operator.

Parameters:
rhs the object to compare with.
Returns:
the result of the test.

StatusCode Activ::Database::IndexSpecification::Field::Serialize ( MessageBuilder & messageBuilder ) const

Serialize the index field specification into a message.

Parameters:
messageBuilder the message builder used for constructing the message.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED
STATUS_CODE_FAILURE

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivDatabase/IndexSpecification.h
Generated on Wed Oct 8 14:02:11 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Database::ITable

Activ::Database::ITable Class Reference

Abstract base table class. More...

#include <ActivMiddleware/ActivDatabase/ITable.h>

List of all members.

Public Types

typedef ITable * | Identity
Identity of a table. Allows different tables to behave as if they were the same.

Public Member Functions

virtual StatusCode | Add (Record &record, Record &originalRecord)=0
Add record to table.
virtual StatusCode | Add (Record &record, const FieldIdList &modifiedFieldIdList)=0
Add record to table.
virtual StatusCode | Add (Record &record)=0
Add record to table.
virtual void | CheckIntegrity () const =0
Check the integrity of the table.
virtual StatusCode | Clear ()=0
Clear the table of all records contained in it.
virtual ITable * | Clone (const std::string &directory=std::string(), const bool createMutex=false, const bool copyRecords=true, size_t recordsPerRequest=20) const =0
Clone a table.
virtual StatusCode | CloseRecordFile ()=0
Close the table record file.
virtual StatusCode | Convert ()=0
Convert a table's data according to the new specification.
virtual StatusCode | Copy (const ITable *pSourceTable, const bool clearTargetTable=true, size_t recordsPerRequest=20)=0
Copy all records from one table to another.
virtual StatusCode | CopyFiles (const std::string &sourceDirectory, const std::string &targetDirectory) const =0
Copy the files for this table.
virtual void | CreateIndexes (IndexSpecificationList &indexSpecificationList)=0
Create all permanent indexes on the data.
void | CreateIndexes (IndexSpecification indexSpecificationList[], const size_t nIndexSpecifications)
Create all permanent indexes on the data.
virtual void | CreateRecordFile ()=0
Create the table record file.
virtual void | CreateTemporaryIndex (IndexSpecification &indexSpecification)=0
Create a temporary index on the data stored in this table.
virtual StatusCode | Delete (const Key &key, Record &record)=0
Delete record with specified key from this table and retrieve the deleted record.
virtual StatusCode | Delete (const Key &key)=0
Delete record from table.
virtual StatusCode | Deserialize (MessageValidator &messageValidator, std::vector< StatusCode > &statusCodeList, RecordList &recordList) const =0
Deserialize a list of status codes and records from a message.
virtual StatusCode | Deserialize (MessageValidator &messageValidator, DataId &recordId, size_t &maxResponseRecords) const =0
Deserialize record id and maximum response records used to return multiple records.
virtual StatusCode | Deserialize (MessageValidator &messageValidator, RecordList &recordList) const =0
Deserialize a list of records from a message.
virtual StatusCode | Deserialize (MessageValidator &messageValidator, KeyList &keyList) const =0
Deserialize a list of keys from a message.
virtual std::string | GetBasicFileName () const =0
Get the basic file name used for storing table record data.
virtual StatusCode | GetCurrentRecords (size_t &nRecords) const =0
Get the current number of records.
virtual std::string | GetDirectory () const =0
Get the name of the directory used to persist information.
virtual StatusCode | GetEqual (const KeyList &keyList, std::vector< StatusCode > &statusCodeList, RecordList &recordList) const =0
Get multiple records from specified indexes matching supplied key information.
virtual StatusCode | GetEqual (const Key &key, Record &record) const =0
Get record from specified index matching supplied key information.
virtual FieldIdList | GetFieldIdList () const =0
Get the list of all field identifiers.
virtual const FieldList & | GetFieldList () const =0
Get a reference to the field list of the table.
virtual StatusCode | GetFieldSpecification (const FieldSpecification::Id fieldId, FieldSpecification &fieldSpecification) const =0
Get the field specification for the field id specified.
virtual bool | GetFieldSpecificationList (const FieldSpecification &fieldSpecification, FieldSpecificationList &matchingFieldSpecificationList) const =0
Get the list of field specifications that match the criteria specified in the field specification parameter.
virtual FieldSpecificationList | GetFieldSpecificationList () const =0
Get the list of all field specifications.
virtual StatusCode | GetFirst (Key &key, RecordList &recordList, const size_t maxResponseRecords=0) const =0
Get multiple records from the first.
virtual StatusCode | GetFirst (Key &key, Record &record) const =0
Get the first record in the table on the specified index.
virtual void | GetFirstFieldId (FieldSpecification::Id &fieldId) const =0
Get the id of the first field in the field list object.
virtual void | GetFirstFieldSpecification (FieldSpecification &fieldSpecification) const =0
Get the field specification of the first field in the record.
virtual StatusCode | GetFirstPartial (Key &key, RecordList &recordList, const FieldSpecification::Id lastKeyFieldId, const size_t lastKeyCompareLength=FIELD_COMPARE_LENGTH_WHOLE, const size_t maxResponseRecords=0) const =0
Get multiple records from the first that matches the partially specified key.
virtual StatusCode | GetFirstPartial (Key &key, Record &record, const FieldSpecification::Id lastKeyFieldId, const size_t lastKeyCompareLength=FIELD_COMPARE_LENGTH_WHOLE) const =0
Get the first record that matches the partially specified key.
Identity | GetIdentity () const
Get the identity of the table.
virtual StatusCode | GetIndexPointer (const IndexSpecification::Number indexNo, IIndex *&pIndex) const =0
Get an index pointer.
virtual StatusCode | GetIndexSpecification (const IndexSpecification::Number indexNo, IndexSpecification &indexSpecification) const =0
Get the index specification for the specified index number.
virtual bool | GetIndexSpecificationList (const IndexSpecification &indexSpecification, IndexSpecificationList &matchingIndexSpecificationList) const =0
Get the list of index specifications that match the criteria specified in the index specification parameter.
virtual IndexSpecificationList | GetIndexSpecificationList () const =0
Get the list of all index specifications.
virtual StatusCode | GetLast (Key &key, RecordList &recordList, const size_t maxResponseRecords=0) const =0
Get multiple records from the last.
virtual StatusCode | GetLast (Key &key, Record &record) const =0
Get the last record in the table for the specified index.
virtual StatusCode | GetLastPartial (Key &key, RecordList &recordList, const FieldSpecification::Id lastKeyFieldId, const size_t lastKeyCompareLength=FIELD_COMPARE_LENGTH_WHOLE, const size_t maxResponseRecords=0) const =0
Get multiple records from the last that matches the partially specified key.
virtual StatusCode | GetLastPartial (Key &key, Record &record, const FieldSpecification::Id lastKeyFieldId, const size_t lastKeyCompareLength=FIELD_COMPARE_LENGTH_WHOLE) const =0
Get the last record that matches the partially specified key.
virtual StatusCode | GetMaxRecords (size_t &maxRecords) const =0
Get the maximum number of records.
Mode | GetMode () const
Get mode.
virtual std::string | GetName () const =0
Get name.
virtual StatusCode | GetNext (Key &key, RecordList &recordList, const size_t maxResponseRecords=0) const =0
Get multiple records from the next one to the specified key.
virtual StatusCode | GetNext (Key &key, Record &record) const =0
Get the next record in the table for the specified index.
virtual StatusCode | GetNextFieldId (FieldSpecification::Id &fieldId) const =0
Get the id of the next field in the field list object.
virtual StatusCode | GetNextFieldSpecification (FieldSpecification &fieldSpecification) const =0
Get the field specification of the next field in the record.
virtual StatusCode | GetNextPartial (Key &key, RecordList &recordList, const FieldSpecification::Id lastKeyFieldId, const size_t lastKeyCompareLength=FIELD_COMPARE_LENGTH_WHOLE, const size_t maxResponseRecords=0) const =0
Get multiple next records that match the partially specified key.
virtual StatusCode | GetNextPartial (Key &key, Record &record, const FieldSpecification::Id lastKeyFieldId, const size_t lastKeyCompareLength=FIELD_COMPARE_LENGTH_WHOLE) const =0
Get the next record that matches the partially specified key.
virtual size_t | GetNumberOfIndexes () const =0
Get number of indexes.
virtual StatusCode | GetPrevious (Key &key, RecordList &recordList, const size_t maxResponseRecords=0) const =0
Get multiple records from the previous one to the specified key.
virtual StatusCode | GetPrevious (Key &key, Record &record) const =0
Get the previous record in the table.
virtual StatusCode | GetPreviousPartial (Key &key, RecordList &recordList, const FieldSpecification::Id lastKeyFieldId, const size_t lastKeyCompareLength=FIELD_COMPARE_LENGTH_WHOLE, const size_t maxResponseRecords=0) const =0
Get multiple previous records that match the partially specified key.
virtual StatusCode | GetPreviousPartial (Key &key, Record &record, const FieldSpecification::Id lastKeyFieldId, const size_t lastKeyCompareLength=FIELD_COMPARE_LENGTH_WHOLE) const =0
Get the previous record that matches the partially specified key.
virtual IndexSpecification::Number | GetPrimaryIndexNumber () const =0
Get the number of the primary index.
virtual size_t | GetRecordLength () const =0
Get Record Length.
virtual TableSpecification | GetTableSpecification () const =0
Get the table specification.
virtual StatusCode | GetType (const FieldSpecification::Id fieldId, FieldSpecification::Type &type) const =0
Get the field type for the field id specified.
virtual bool | IsAdd (const Record &record, const Record &originalRecord) const =0
Is add.
virtual bool | IsFound (const FieldSpecification::Id fieldId) const =0
Check whether a field id is valid for this table.
virtual bool | IsManaged () const =0
Is this a managed table.
virtual bool | IsRecordFileOpen () const =0
Is the record file open.
virtual bool | IsTemporary () const =0
Is this a temporary table.
virtual bool | IsUpdate (const Record &record, const Record &originalRecord) const =0
Is update.
ITable ()
Default destructor.
virtual StatusCode | OpenRecordFile ()=0
Open the table record file.
virtual StatusCode | ResetRecord (Record &record) const =0
Reset record.
virtual StatusCode | Save (const std::string &directory)=0
Save the table data to a given location.
virtual StatusCode | Serialize (MessageBuilder &messageBuilder, const std::vector< StatusCode > &statusCodeList, const RecordList &recordList) const =0
Serialize a list of status codes and records into a message.
virtual StatusCode | Serialize (MessageBuilder &messageBuilder, const RecordList &recordList) const =0
Serialize a list of records into a message.
virtual StatusCode | Serialize (MessageBuilder &messageBuilder, const KeyList &keyList) const =0
Serialize a list of keys into a message.
virtual StatusCode | SerializeSpecification (MessageBuilder &messageBuilder) const =0
Serialize the specification into a message.
void | SetIdentity (const Identity identity=0)
Set the identity of the table.
virtual StatusCode | SetIndexFields (Record &record, const IndexSpecification::Number indexNo, const ScatterBufferHelper &scatterBufferHelper) const =0
Set the index fields in the record, starting with the first field in the index.
void | SetMode (const Mode mode)
Set mode.
virtual StatusCode | StepFirst (DataId &recordId, RecordList &recordList, const size_t maxResponseRecords=0) const =0
Step to the first record in the table and get multiple records after it.
virtual StatusCode | StepFirst (DataId &recordId, Record &record) const =0
Step to the first record in the table.
virtual StatusCode | StepNext (DataId &recordId, RecordList &recordList, const size_t maxResponseRecords=0) const =0
Step to the next multiple records from the next one.
virtual StatusCode | StepNext (DataId &recordId, Record &record) const =0
Step to the next record in the table.
virtual | ~ITable ()=0
Default destructor.

Protected Attributes

Identity m_identity
The identity of the table.
Mode | m_mode
The mode of the table.

Detailed Description

Abstract base table class.

Definition at line 45 of file ITable.h.

Member Function Documentation

virtual StatusCode Activ::Database::ITable::Add | ( | Record & | record,
 |  | Record & | originalRecord |
 | ) |  |  | [pure virtual]

Add record to table.

Parameters:
record | record to add to table.
originalRecord | the original version of the record. Not initialized if no record is found.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_INDEX
STATUS_CODE_INVALID_LENGTH
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_HEAP_EMPTY
STATUS_CODE_NO_PRIMARY_KEY
STATUS_CODE_NOT_FOUND
STATUS_CODE_NOT_INITIALIZED
STATUS_CODE_OUT_OF_RANGE

virtual StatusCode Activ::Database::ITable::Add | ( | Record & | record,
 |  | const FieldIdList & | modifiedFieldIdList |
 | ) |  |  | [pure virtual]

Add record to table.

Parameters:
record | record to add to table.
modifiedFieldIdList | list of field ids to be added to the record.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NO_PRIMARY_KEY
STATUS_CODE_INVALID_INDEX
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_HEAP_EMPTY
STATUS_CODE_NOT_FOUND
STATUS_CODE_NOT_INITIALIZED
STATUS_CODE_INVALID_LENGTH
STATUS_CODE_OUT_OF_RANGE

virtual StatusCode Activ::Database::ITable::Add ( Record & record ) [pure virtual]

Add record to table.

Parameters:
record record to add to table.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NO_PRIMARY_KEY
STATUS_CODE_INVALID_INDEX
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_HEAP_EMPTY
STATUS_CODE_NOT_FOUND
STATUS_CODE_NOT_INITIALIZED
STATUS_CODE_INVALID_LENGTH
STATUS_CODE_OUT_OF_RANGE

virtual void Activ::Database::ITable::CheckIntegrity ( ) const [pure virtual]

Check the integrity of the table.

Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_FOUND

virtual StatusCode Activ::Database::ITable::Clear ( ) [pure virtual]

Clear the table of all records contained in it.

Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_OPEN

virtual ITable* Activ::Database::ITable::Clone | ( | const std::string & | directory = std::string(),
 |  | const bool | createMutex = false,
 |  | const bool | copyRecords = true,
 |  | size_t | recordsPerRequest = 20 |
 | ) |  |  | const [pure virtual]

Clone a table.

The table record file will always be created when a table is cloned.

Parameters:
directory | name of directory in which to store persistent table files, or empty to create a temporary version of the table.
createMutex | flag indicating whether a mutex should be created for the table.
copyRecords | flag indicating whether any existing records should be copied to the new table.
recordsPerRequest | number of records to copy at a time
Returns:
a pointer to the cloned table.
Exceptions:
StatusCodeException
BaseException
DatabaseException
OsException

virtual StatusCode Activ::Database::ITable::CloseRecordFile ( ) [pure virtual]

Close the table record file.

Return values:
STATUS_CODE_SUCCESS
...

virtual StatusCode Activ::Database::ITable::Convert ( ) [pure virtual]

Convert a table's data according to the new specification.

Return values:
STATUS_CODE_SUCCESS
f knows

virtual StatusCode Activ::Database::ITable::Copy | ( | const ITable * | pSourceTable,
 |  | const bool | clearTargetTable = true,
 |  | size_t | recordsPerRequest = 20 |
 | ) |  |  | [pure virtual]

Copy all records from one table to another.

Parameters:
pSourceTable | table to copy records from.
clearTargetTable | flag indicating whether the target table should be emptied before copying records.
recordsPerRequest | number of records to copy at a time
If the target table isn't cleared before copying and a record in the source table has keys that match a record in the target table, the source record will overwrite the matching entry in the target table.

Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_INDEX
STATUS_CODE_INVALID_KEY
STATUS_CODE_INVALID_LENGTH
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_HEAP_EMPTY
STATUS_CODE_NO_PRIMARY_KEY
STATUS_CODE_NOT_INITIALIZED
STATUS_CODE_NOT_OPEN
STATUS_CODE_OUT_OF_RANGE

virtual StatusCode Activ::Database::ITable::CopyFiles | ( | const std::string & | sourceDirectory,
 |  | const std::string & | targetDirectory |
 | ) |  |  | const [pure virtual]

Copy the files for this table.

Parameters:
sourceDirectory | the source directory.
targetDirectory | the target directory.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_FAILURE
STATUS_CODE_NOT_OPEN

virtual void Activ::Database::ITable::CreateIndexes ( IndexSpecificationList & indexSpecificationList ) [pure virtual]

Create all permanent indexes on the data.

Parameters:
indexSpecificationList list of index specifications.
Exceptions:
DatabaseException

void Activ::Database::ITable::CreateIndexes | ( | IndexSpecification | indexSpecificationList[],
 |  | const size_t | nIndexSpecifications |
 | ) |  |  | [inline]

Create all permanent indexes on the data.

Parameters:
indexSpecificationList | list of index specifications.
nIndexSpecifications | the number of index specifications.
Exceptions:
DatabaseException

Definition at line 1153 of file ITable.h.

References Activ::Database::IndexSpecification::m_number.

virtual void Activ::Database::ITable::CreateRecordFile ( ) [pure virtual]

Create the table record file.

Exceptions:
DatabaseException

virtual void Activ::Database::ITable::CreateTemporaryIndex ( IndexSpecification & indexSpecification ) [pure virtual]

Create a temporary index on the data stored in this table.

Parameters:
indexSpecification the specification of the index.
Exceptions:
StatusCodeException
DatabaseException
OsException

virtual StatusCode Activ::Database::ITable::Delete | ( | const Key & | key,
 |  | Record & | record |
 | ) |  |  | [pure virtual]

Delete record with specified key from this table and retrieve the deleted record.

Parameters:
key | key of record to be deleted.
record | the contents of the record prior to deletion is stored in this parameter.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_INVALID_RECORD
STATUS_CODE_HEAP_EMPTY
STATUS_CODE_NOT_FOUND
STATUS_CODE_NOT_INITIALIZED
STATUS_CODE_OUT_OF_RANGE

virtual StatusCode Activ::Database::ITable::Delete ( const Key & key ) [pure virtual]

Delete record from table.

Parameters:
key key of record to be deleted.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_KEY
STATUS_CODE_INVALID_LENGTH
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_HEAP_EMPTY
STATUS_CODE_NOT_FOUND
STATUS_CODE_NOT_INITIALIZED
STATUS_CODE_OUT_OF_RANGE

virtual StatusCode Activ::Database::ITable::Deserialize | ( | MessageValidator & | messageValidator,
 |  | std::vector< StatusCode > & | statusCodeList,
 |  | RecordList & | recordList |
 | ) |  |  | const [pure virtual]

Deserialize a list of status codes and records from a message.

Parameters:
messageValidator | the message validator from which the key and record data is extracted.
statusCodeList | a list of status codes returned from table lookups.
recordList | a list of records returned from table lookups.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_KEY
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_INVALID_RECORD
STATUS_CODE_HEAP_EMPTY
STATUS_CODE_NOT_INITIALIZED

virtual StatusCode Activ::Database::ITable::Deserialize | ( | MessageValidator & | messageValidator,
 |  | DataId & | recordId,
 |  | size_t & | maxResponseRecords |
 | ) |  |  | const [pure virtual]

Deserialize record id and maximum response records used to return multiple records.

Parameters:
messageValidator | the message validator from which key and partial search data is extracted.
recordId | the id of the record to use in the search of the table.
maxResponseRecords | the maximum number of records to include in the response. Default of zero implies all matching records will be returned.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_KEY
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_HEAP_EMPTY
STATUS_CODE_NOT_INITIALIZED

virtual StatusCode Activ::Database::ITable::Deserialize | ( | MessageValidator & | messageValidator,
 |  | RecordList & | recordList |
 | ) |  |  | const [pure virtual]

Deserialize a list of records from a message.

Parameters:
messageValidator | the message validator from which the key and record data is extracted.
recordList | a list of records returned from table lookups.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_KEY
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_INVALID_RECORD
STATUS_CODE_HEAP_EMPTY
STATUS_CODE_NOT_INITIALIZED

virtual StatusCode Activ::Database::ITable::Deserialize | ( | MessageValidator & | messageValidator,
 |  | KeyList & | keyList |
 | ) |  |  | const [pure virtual]

Deserialize a list of keys from a message.

Parameters:
messageValidator | the message validator from which key data is extracted.
keyList | the list of key information extracted from the message.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_KEY
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_HEAP_EMPTY
STATUS_CODE_NOT_INITIALIZED

virtual std::string Activ::Database::ITable::GetBasicFileName ( ) const [pure virtual]

Get the basic file name used for storing table record data.

Returns:
the basic file name.

virtual StatusCode Activ::Database::ITable::GetCurrentRecords ( size_t & nRecords ) const [pure virtual]

Get the current number of records.

Parameters:
nRecords set equal to the current number of records.
Return values:
STATUS_CODE_SUCCESS

virtual std::string Activ::Database::ITable::GetDirectory ( ) const [pure virtual]

Get the name of the directory used to persist information.

Returns:
the name of the directory.

virtual StatusCode Activ::Database::ITable::GetEqual | ( | const KeyList & | keyList,
 |  | std::vector< StatusCode > & | statusCodeList,
 |  | RecordList & | recordList |
 | ) |  |  | const [pure virtual]

Get multiple records from specified indexes matching supplied key information.

Parameters:
keyList | list of key information that will be searched for.
statusCodeList | the status code associated with each look up is stored in this parameter.
recordList | the record matching each supplied key information is stored in this parameter, or a blank record if no match is found.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_KEY
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_HEAP_EMPTY
STATUS_CODE_NOT_FOUND
STATUS_CODE_NOT_INITIALIZED
STATUS_CODE_OUT_OF_RANGE

virtual StatusCode Activ::Database::ITable::GetEqual | ( | const Key & | key,
 |  | Record & | record |
 | ) |  |  | const [pure virtual]

Get record from specified index matching supplied key information.

Parameters:
key | key information which will be searched for.
record | matching record information will be stored in this parameter.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_KEY
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_HEAP_EMPTY
STATUS_CODE_NOT_FOUND
STATUS_CODE_NOT_INITIALIZED
STATUS_CODE_OUT_OF_RANGE

virtual FieldIdList Activ::Database::ITable::GetFieldIdList ( ) const [pure virtual]

Get the list of all field identifiers.

Returns:
the field identifier list.

virtual const FieldList& Activ::Database::ITable::GetFieldList ( ) const [pure virtual]

Get a reference to the field list of the table.

Returns:
the field list of the table.

Referenced by Activ::Database::Record::Initialize().

virtual StatusCode Activ::Database::ITable::GetFieldSpecification | ( | const FieldSpecification::Id | fieldId,
 |  | FieldSpecification & | fieldSpecification |
 | ) |  |  | const [pure virtual]

Get the field specification for the field id specified.

Parameters:
fieldId | the id of the field whose specification is to be retrieved.
fieldSpecification | the variable that will hold the retrieved field specification.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_FOUND

virtual bool Activ::Database::ITable::GetFieldSpecificationList | ( | const FieldSpecification & | fieldSpecification,
 |  | FieldSpecificationList & | matchingFieldSpecificationList |
 | ) |  |  | const [pure virtual]

Get the list of field specifications that match the criteria specified in the field specification parameter.

Parameters:
fieldSpecification | the criteria used to match specifications.
matchingFieldSpecificationList | set equal to the matched field specification list.
Return values:
true if at least one matching field specification is found.

virtual FieldSpecificationList Activ::Database::ITable::GetFieldSpecificationList ( ) const [pure virtual]

Get the list of all field specifications.

Returns:
the field specification list.

virtual StatusCode Activ::Database::ITable::GetFirst | ( | Key & | key,
 |  | RecordList & | recordList,
 |  | const size_t | maxResponseRecords = 0 |
 | ) |  |  | const [pure virtual]

Get multiple records from the first.

Parameters:
key | set equal to the first key.
recordList | all located records are stored in this parameter.
maxResponseRecords | the maximum number of records to include in the response. Default of zero implies all matching records will be returned.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_KEY
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_HEAP_EMPTY
STATUS_CODE_NOT_FOUND
STATUS_CODE_NOT_INITIALIZED
STATUS_CODE_OUT_OF_RANGE

virtual StatusCode Activ::Database::ITable::GetFirst | ( | Key & | key,
 |  | Record & | record |
 | ) |  |  | const [pure virtual]

Get the first record in the table on the specified index.

Parameters:
key | set equal to the first key.
record | matching record information will be stored in this parameter.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_KEY
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_HEAP_EMPTY
STATUS_CODE_NOT_FOUND
STATUS_CODE_NOT_INITIALIZED
STATUS_CODE_OUT_OF_RANGE

virtual void Activ::Database::ITable::GetFirstFieldId ( FieldSpecification::Id & fieldId ) const [pure virtual]

Get the id of the first field in the field list object.

Parameters:
fieldId set equal to the first field id in the field list object

virtual void Activ::Database::ITable::GetFirstFieldSpecification ( FieldSpecification & fieldSpecification ) const [pure virtual]

Get the field specification of the first field in the record.

Parameters:
fieldSpecification the variable that will hold the retrieved field specification.

virtual StatusCode Activ::Database::ITable::GetFirstPartial | ( | Key & | key,
 |  | RecordList & | recordList,
 |  | const FieldSpecification::Id | lastKeyFieldId,
 |  | const size_t | lastKeyCompareLength = FIELD_COMPARE_LENGTH_WHOLE,
 |  | const size_t | maxResponseRecords = 0 |
 | ) |  |  | const [pure virtual]

Get multiple records from the first that matches the partially specified key.

Parameters:
key | key information which will be searched for.
recordList | all records matching the supplied key information are stored in this parameter.
lastKeyFieldId | the field identifier of the last key field to be used for the partial search.
lastKeyCompareLength | the amount of the last key field that should be used in the partial key comparisons.
maxResponseRecords | the maximum number of records to include in the response. Default of zero implies all matching records will be returned.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FIELD
STATUS_CODE_INVALID_KEY
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_HEAP_EMPTY
STATUS_CODE_NOT_FOUND
STATUS_CODE_NOT_INITIALIZED
STATUS_CODE_OUT_OF_RANGE

virtual StatusCode Activ::Database::ITable::GetFirstPartial | ( | Key & | key,
 |  | Record & | record,
 |  | const FieldSpecification::Id | lastKeyFieldId,
 |  | const size_t | lastKeyCompareLength = FIELD_COMPARE_LENGTH_WHOLE |
 | ) |  |  | const [pure virtual]

Get the first record that matches the partially specified key.

Parameters:
key | key information which will be searched for.
record | matching record information will be stored in this parameter.
lastKeyFieldId | the field identifier of the last key field to be used for the partial search.
lastKeyCompareLength | the amount of the last key field that should be used in the partial key comparisons.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FIELD
STATUS_CODE_INVALID_KEY
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_HEAP_EMPTY
STATUS_CODE_NOT_FOUND
STATUS_CODE_NOT_INITIALIZED
STATUS_CODE_OUT_OF_RANGE

ITable::Identity Activ::Database::ITable::GetIdentity ( ) const [inline]

Get the identity of the table.

Returns:
the identity of the table.

Definition at line 1175 of file ITable.h.

References m_identity.

Referenced by Activ::Database::Record::Initialize(), Activ::Database::FieldListObject::Initialize(), Activ::Database::FieldListObject::IsInitialized(), Activ::Database::Key::operator<(), Activ::Database::Key::operator<=(), Activ::Database::Key::operator==(), Activ::Database::Key::operator>=(), Activ::Database::Record::Validate(), and Activ::Database::Key::Validate().

virtual StatusCode Activ::Database::ITable::GetIndexPointer | ( | const IndexSpecification::Number | indexNo,
 |  | IIndex *& | pIndex |
 | ) |  |  | const [pure virtual]

Get an index pointer.

Parameters:
indexNo | the number of the index.
pIndex | set equal to the index pointer of the requested index.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_INDEX

virtual StatusCode Activ::Database::ITable::GetIndexSpecification | ( | const IndexSpecification::Number | indexNo,
 |  | IndexSpecification & | indexSpecification |
 | ) |  |  | const [pure virtual]

Get the index specification for the specified index number.

Parameters:
indexNo | the number of the index whose specification is to be retrieved.
indexSpecification | set equal to the retrieved index specification.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_FOUND

virtual bool Activ::Database::ITable::GetIndexSpecificationList | ( | const IndexSpecification & | indexSpecification,
 |  | IndexSpecificationList & | matchingIndexSpecificationList |
 | ) |  |  | const [pure virtual]

Get the list of index specifications that match the criteria specified in the index specification parameter.

Parameters:
indexSpecification | the criteria used to match specifications.
matchingIndexSpecificationList | set equal to the matched index specification list.
Return values:
true if at least one matching index specification is found.

virtual IndexSpecificationList Activ::Database::ITable::GetIndexSpecificationList ( ) const [pure virtual]

Get the list of all index specifications.

Returns:
the index specification list.

virtual StatusCode Activ::Database::ITable::GetLast | ( | Key & | key,
 |  | RecordList & | recordList,
 |  | const size_t | maxResponseRecords = 0 |
 | ) |  |  | const [pure virtual]

Get multiple records from the last.

Parameters:
key | set equal to the last key.
recordList | all located records are stored in this parameter.
maxResponseRecords | the maximum number of records to include in the response. Default of zero implies all matching records will be returned.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_KEY
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_HEAP_EMPTY
STATUS_CODE_NOT_FOUND
STATUS_CODE_NOT_INITIALIZED
STATUS_CODE_OUT_OF_RANGE

virtual StatusCode Activ::Database::ITable::GetLast | ( | Key & | key,
 |  | Record & | record |
 | ) |  |  | const [pure virtual]

Get the last record in the table for the specified index.

Parameters:
key | key information which will be searched for.
record | matching record information will be stored in this parameter.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_KEY
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_HEAP_EMPTY
STATUS_CODE_NOT_FOUND
STATUS_CODE_NOT_INITIALIZED
STATUS_CODE_OUT_OF_RANGE

virtual StatusCode Activ::Database::ITable::GetLastPartial | ( | Key & | key,
 |  | RecordList & | recordList,
 |  | const FieldSpecification::Id | lastKeyFieldId,
 |  | const size_t | lastKeyCompareLength = FIELD_COMPARE_LENGTH_WHOLE,
 |  | const size_t | maxResponseRecords = 0 |
 | ) |  |  | const [pure virtual]

Get multiple records from the last that matches the partially specified key.

Parameters:
key | key information which will be searched for.
recordList | all records matching the supplied key information are stored in this parameter.
lastKeyFieldId | the field identifier of the last key field to be used for the partial search.
lastKeyCompareLength | the amount of the last key field that should be used in the partial key comparisons.
maxResponseRecords | the maximum number of records to include in the response. Default of zero implies all matching records will be returned.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FIELD
STATUS_CODE_INVALID_KEY
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_HEAP_EMPTY
STATUS_CODE_NOT_FOUND
STATUS_CODE_NOT_INITIALIZED
STATUS_CODE_OUT_OF_RANGE

virtual StatusCode Activ::Database::ITable::GetLastPartial | ( | Key & | key,
 |  | Record & | record,
 |  | const FieldSpecification::Id | lastKeyFieldId,
 |  | const size_t | lastKeyCompareLength = FIELD_COMPARE_LENGTH_WHOLE |
 | ) |  |  | const [pure virtual]

Get the last record that matches the partially specified key.

Parameters:
key | key information which will be searched for.
record | matching record information will be stored in this parameter.
lastKeyFieldId | the field identifier of the last key field to be used for the partial search.
lastKeyCompareLength | the amount of the last key field that should be used in the partial key comparisons.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FIELD
STATUS_CODE_INVALID_KEY
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_HEAP_EMPTY
STATUS_CODE_NOT_FOUND
STATUS_CODE_OUT_OF_RANGE

virtual StatusCode Activ::Database::ITable::GetMaxRecords ( size_t & maxRecords ) const [pure virtual]

Get the maximum number of records.

Parameters:
maxRecords set equal to the maximum number of records.
Return values:
STATUS_CODE_SUCCESS

Mode Activ::Database::ITable::GetMode ( ) const [inline]

Get mode.

Returns:
the mode of the table.

Definition at line 1189 of file ITable.h.

References m_mode.

virtual std::string Activ::Database::ITable::GetName ( ) const [pure virtual]

Get name.

Returns:
the name of the table.

Referenced by Activ::Database::Key::operator<(), Activ::Database::Key::operator<=(), and Activ::Database::Key::operator>=().

virtual StatusCode Activ::Database::ITable::GetNext | ( | Key & | key,
 |  | RecordList & | recordList,
 |  | const size_t | maxResponseRecords = 0 |
 | ) |  |  | const [pure virtual]

Get multiple records from the next one to the specified key.

Parameters:
key | set equal to the first key.
recordList | all located records are stored in this parameter.
maxResponseRecords | the maximum number of records to include in the response. Default of zero implies all matching records will be returned.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_KEY
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_HEAP_EMPTY
STATUS_CODE_NOT_FOUND
STATUS_CODE_NOT_INITIALIZED
STATUS_CODE_OUT_OF_RANGE

virtual StatusCode Activ::Database::ITable::GetNext | ( | Key & | key,
 |  | Record & | record |
 | ) |  |  | const [pure virtual]

Get the next record in the table for the specified index.

Parameters:
key | key information which will be searched for.
record | matching record information will be stored in this parameter.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_KEY
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_HEAP_EMPTY
STATUS_CODE_NOT_FOUND
STATUS_CODE_NOT_INITIALIZED
STATUS_CODE_OUT_OF_RANGE

virtual StatusCode Activ::Database::ITable::GetNextFieldId ( FieldSpecification::Id & fieldId ) const [pure virtual]

Get the id of the next field in the field list object.

Parameters:
fieldId set equal to the next field id in the field list object
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_FOUND

virtual StatusCode Activ::Database::ITable::GetNextFieldSpecification ( FieldSpecification & fieldSpecification ) const [pure virtual]

Get the field specification of the next field in the record.

Parameters:
fieldSpecification the variable that will hold the retrieved field specification.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_FOUND

virtual StatusCode Activ::Database::ITable::GetNextPartial | ( | Key & | key,
 |  | RecordList & | recordList,
 |  | const FieldSpecification::Id | lastKeyFieldId,
 |  | const size_t | lastKeyCompareLength = FIELD_COMPARE_LENGTH_WHOLE,
 |  | const size_t | maxResponseRecords = 0 |
 | ) |  |  | const [pure virtual]

Get multiple next records that match the partially specified key.

Parameters:
key | key information which will be searched for.
recordList | all records matching the supplied key information are stored in this parameter.
lastKeyFieldId | the field identifier of the last key field to be used for the partial search.
lastKeyCompareLength | the amount of the last key field that should be used in the partial key comparisons.
maxResponseRecords | the maximum number of records to include in the response. Default of zero implies all matching records will be returned.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FIELD
STATUS_CODE_INVALID_INDEX
STATUS_CODE_INVALID_KEY
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_HEAP_EMPTY
STATUS_CODE_NOT_FOUND
STATUS_CODE_NOT_INITIALIZED
STATUS_CODE_OUT_OF_RANGE

virtual StatusCode Activ::Database::ITable::GetNextPartial | ( | Key & | key,
 |  | Record & | record,
 |  | const FieldSpecification::Id | lastKeyFieldId,
 |  | const size_t | lastKeyCompareLength = FIELD_COMPARE_LENGTH_WHOLE |
 | ) |  |  | const [pure virtual]

Get the next record that matches the partially specified key.

Parameters:
key | key information which will be searched for.
record | matching record information will be stored in this parameter.
lastKeyFieldId | the field identifier of the last key field to be used for the partial search.
lastKeyCompareLength | the amount of the last key field that should be used in the partial key comparisons.
Return values:
ACTVI_STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FIELD
STATUS_CODE_INVALID_INDEX
STATUS_CODE_INVALID_KEY
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_HEAP_EMPTY
STATUS_CODE_NOT_FOUND
STATUS_CODE_OUT_OF_RANGE

virtual size_t Activ::Database::ITable::GetNumberOfIndexes ( ) const [pure virtual]

Get number of indexes.

Returns:
number of indexes.

virtual StatusCode Activ::Database::ITable::GetPrevious | ( | Key & | key,
 |  | RecordList & | recordList,
 |  | const size_t | maxResponseRecords = 0 |
 | ) |  |  | const [pure virtual]

Get multiple records from the previous one to the specified key.

Parameters:
key | set equal to the first key.
recordList | all located records are stored in this parameter.
maxResponseRecords | the maximum number of records to include in the response. Default of zero implies all matching records will be returned.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_KEY
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_FOUND
STATUS_CODE_HEAP_EMPTY
STATUS_CODE_NOT_INITIALIZED
STATUS_CODE_OUT_OF_RANGE

virtual StatusCode Activ::Database::ITable::GetPrevious | ( | Key & | key,
 |  | Record & | record |
 | ) |  |  | const [pure virtual]

Get the previous record in the table.

Parameters:
key | key information which will be searched for.
record | matching record information will be stored in this parameter.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_KEY
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_HEAP_EMPTY
STATUS_CODE_NOT_FOUND
STATUS_CODE_NOT_INITIALIZED
STATUS_CODE_OUT_OF_RANGE

virtual StatusCode Activ::Database::ITable::GetPreviousPartial | ( | Key & | key,
 |  | RecordList & | recordList,
 |  | const FieldSpecification::Id | lastKeyFieldId,
 |  | const size_t | lastKeyCompareLength = FIELD_COMPARE_LENGTH_WHOLE,
 |  | const size_t | maxResponseRecords = 0 |
 | ) |  |  | const [pure virtual]

Get multiple previous records that match the partially specified key.

Parameters:
key | key information which will be searched for.
recordList | all records matching the supplied key information are stored in this parameter.
lastKeyFieldId | the field identifier of the last key field to be used for the partial search.
lastKeyCompareLength | the amount of the last key field that should be used in the partial key comparisons.
maxResponseRecords | the maximum number of records to include in the response. Default of zero implies all matching records will be returned.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FIELD
STATUS_CODE_INVALID_INDEX
STATUS_CODE_INVALID_KEY
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_HEAP_EMPTY
STATUS_CODE_NOT_FOUND
STATUS_CODE_NOT_INITIALIZED
STATUS_CODE_OUT_OF_RANGE

virtual StatusCode Activ::Database::ITable::GetPreviousPartial | ( | Key & | key,
 |  | Record & | record,
 |  | const FieldSpecification::Id | lastKeyFieldId,
 |  | const size_t | lastKeyCompareLength = FIELD_COMPARE_LENGTH_WHOLE |
 | ) |  |  | const [pure virtual]

Get the previous record that matches the partially specified key.

Parameters:
key | key information which will be searched for.
record | matching record information will be stored in this parameter.
lastKeyFieldId | the field identifier of the last key field to be used for the partial search.
lastKeyCompareLength | the amount of the last key field that should be used in the partial key comparisons.
Return values:
ACTVI_STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FIELD
STATUS_CODE_INVALID_INDEX
STATUS_CODE_INVALID_KEY
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_HEAP_EMPTY
STATUS_CODE_NOT_FOUND
STATUS_CODE_OUT_OF_RANGE

virtual IndexSpecification::Number Activ::Database::ITable::GetPrimaryIndexNumber ( ) const [pure virtual]

Get the number of the primary index.

Returns:
the number of the primary index.

virtual size_t Activ::Database::ITable::GetRecordLength ( ) const [pure virtual]

Get Record Length.

Returns:
record length.

Referenced by Activ::Database::Record::GetDataLength(), and Activ::Database::Record::Initialize().

virtual TableSpecification Activ::Database::ITable::GetTableSpecification ( ) const [pure virtual]

Get the table specification.

Returns:
the table specification.

virtual StatusCode Activ::Database::ITable::GetType | ( | const FieldSpecification::Id | fieldId,
 |  | FieldSpecification::Type & | type |
 | ) |  |  | const [pure virtual]

Get the field type for the field id specified.

Parameters:
fieldId | the id of the field whose specification is to be retrieved.
type | set equal to the type of the field.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_KEY
STATUS_CODE_NOT_FOUND

virtual bool Activ::Database::ITable::IsAdd | ( | const Record & | record,
 |  | const Record & | originalRecord |
 | ) |  |  | const [pure virtual]

Is add.

Returns whether an update to a table resulted in a new record being added.

Parameters:
record | the new version of the record.
originalRecord | the original version of the record.
Returns:
whether this is an add.

virtual bool Activ::Database::ITable::IsFound ( const FieldSpecification::Id fieldId ) const [pure virtual]

Check whether a field id is valid for this table.

Returns:
true if the field id can be found, false otherwise.

virtual bool Activ::Database::ITable::IsManaged ( ) const [pure virtual]

Is this a managed table.

Returns:
true if this is a managed table, false otherwise.

virtual bool Activ::Database::ITable::IsRecordFileOpen ( ) const [pure virtual]

Is the record file open.

Returns:
true if the record file is open, false otherwise.

virtual bool Activ::Database::ITable::IsTemporary ( ) const [pure virtual]

Is this a temporary table.

Returns:
true if this is a temporary table, false otherwise.

virtual bool Activ::Database::ITable::IsUpdate | ( | const Record & | record,
 |  | const Record & | originalRecord |
 | ) |  |  | const [pure virtual]

Is update.

Returns whether an update to a table resulted in a record being updated.

Parameters:
record | the new version of the record.
originalRecord | the original version of the record.
Returns:
whether this is an update.

virtual StatusCode Activ::Database::ITable::OpenRecordFile ( ) [pure virtual]

Open the table record file.

Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_FAILURE
STATUS_CODE_NOT_FOUND

virtual StatusCode Activ::Database::ITable::ResetRecord ( Record & record ) const [pure virtual]

Reset record.

Parameters:
record record to reset.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_RECORD

Referenced by Activ::Database::Record::Initialize().

virtual StatusCode Activ::Database::ITable::Save ( const std::string & directory ) [pure virtual]

Save the table data to a given location.

Parameters:
directory the directory to store the table data in.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_FAILURE
STATUS_CODE_NOT_OPEN

virtual StatusCode Activ::Database::ITable::Serialize | ( | MessageBuilder & | messageBuilder,
 |  | const std::vector< StatusCode > & | statusCodeList,
 |  | const RecordList & | recordList |
 | ) |  |  | const [pure virtual]

Serialize a list of status codes and records into a message.

Parameters:
messageBuilder | the message builder used for constructing a message.
statusCodeList | a list of status codes returned from table lookups.
recordList | a list of records returned from table lookups.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_BUFFER_OVERFLOW
STATUS_CODE_INVALID_KEY
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_INVALID_RECORD
STATUS_CODE_HEAP_EMPTY
STATUS_CODE_NOT_INITIALIZED
STATUS_CODE_FAILURE

virtual StatusCode Activ::Database::ITable::Serialize | ( | MessageBuilder & | messageBuilder,
 |  | const RecordList & | recordList |
 | ) |  |  | const [pure virtual]

Serialize a list of records into a message.

Parameters:
messageBuilder | the message builder used for constructing a message.
recordList | a list of records returned from table lookups.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_BUFFER_OVERFLOW
STATUS_CODE_INVALID_KEY
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_INVALID_RECORD
STATUS_CODE_HEAP_EMPTY
STATUS_CODE_NOT_INITIALIZED
STATUS_CODE_FAILURE

virtual StatusCode Activ::Database::ITable::Serialize | ( | MessageBuilder & | messageBuilder,
 |  | const KeyList & | keyList |
 | ) |  |  | const [pure virtual]

Serialize a list of keys into a message.

Parameters:
messageBuilder | the message builder used for constructing a message.
keyList | the list of key information to be stored in the message.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_BUFFER_OVERFLOW
STATUS_CODE_INVALID_KEY
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_HEAP_EMPTY
STATUS_CODE_NOT_INITIALIZED
STATUS_CODE_FAILURE

virtual StatusCode Activ::Database::ITable::SerializeSpecification ( MessageBuilder & messageBuilder ) const [pure virtual]

Serialize the specification into a message.

Parameters:
messageBuilder the message builder which the specification will be put in.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED
STATUS_CODE_FAILURE

void Activ::Database::ITable::SetIdentity ( const Identity identity = 0 ) [inline]

Set the identity of the table.

Parameters:
identity the new identity of the table.

Definition at line 1168 of file ITable.h.

References m_identity.

virtual StatusCode Activ::Database::ITable::SetIndexFields | ( | Record & | record,
 |  | const IndexSpecification::Number | indexNo,
 |  | const ScatterBufferHelper & | scatterBufferHelper |
 | ) |  |  | const [pure virtual]

Set the index fields in the record, starting with the first field in the index.

Parameters:
record | the record in which the index fields will be stored.
indexNo | the number of the index which the fields will be set for.
scatterBufferHelper | a scatter buffer helper containing the fields to copy to the record.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_INDEX
STATUS_CODE_INVALID_LENGTH
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_INVALID_RECORD

Referenced by Activ::Database::Record::SetIndexFields().

void Activ::Database::ITable::SetMode ( const Mode mode ) [inline]

Set mode.

Parameters:
mode the new mode of the table.

Definition at line 1182 of file ITable.h.

References m_mode.

virtual StatusCode Activ::Database::ITable::StepFirst | ( | DataId & | recordId,
 |  | RecordList & | recordList,
 |  | const size_t | maxResponseRecords = 0 |
 | ) |  |  | const [pure virtual]

Step to the first record in the table and get multiple records after it.

Parameters:
recordId | the id of the last record retrieved from the table.
recordList | all located records are stored in this parameter.
maxResponseRecords | the maximum number of records to include in the response. Default of zero implies all matching records will be returned.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_INVALID_RECORD
STATUS_CODE_HEAP_EMPTY
STATUS_CODE_NOT_FOUND
STATUS_CODE_NOT_OPEN

virtual StatusCode Activ::Database::ITable::StepFirst | ( | DataId & | recordId,
 |  | Record & | record |
 | ) |  |  | const [pure virtual]

Step to the first record in the table.

Parameters:
recordId | set equal to the id of the first record retrieved from the table.
record | set equal to the first record information retrieved from the table.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_INVALID_RECORD
STATUS_CODE_HEAP_EMPTY
STATUS_CODE_NOT_FOUND
STATUS_CODE_NOT_OPEN

virtual StatusCode Activ::Database::ITable::StepNext | ( | DataId & | recordId,
 |  | RecordList & | recordList,
 |  | const size_t | maxResponseRecords = 0 |
 | ) |  |  | const [pure virtual]

Step to the next multiple records from the next one.

Parameters:
recordId | the id of the last record retrieved from the table.
recordList | all located records are stored in this parameter.
maxResponseRecords | the maximum number of records to include in the response. Default of zero implies all matching records will be returned.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_INVALID_RECORD
STATUS_CODE_HEAP_EMPTY
STATUS_CODE_NOT_FOUND
STATUS_CODE_NOT_OPEN

virtual StatusCode Activ::Database::ITable::StepNext | ( | DataId & | recordId,
 |  | Record & | record |
 | ) |  |  | const [pure virtual]

Step to the next record in the table.

Parameters:
recordId | set equal to the id of the next record retrieved from the table.
record | matching record information will be stored in this parameter.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_INVALID_RECORD
STATUS_CODE_NOT_FOUND
STATUS_CODE_NOT_OPEN

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivDatabase/ITable.h
Generated on Wed Oct 8 14:02:11 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Database::Key

Activ::Database::Key Class Reference

Key class. More...

#include <ActivMiddleware/ActivDatabase/Key.h>

Inheritance diagram for Activ::Database::Key:

Activ::Database::FieldListObject

List of all members.

Public Member Functions

ACTIV_DATABASE_API StatusCode | BuildKey (const Record &record)
Build a key using the supplied record data.
virtual ACTIV_DATABASE_API
StatusCode 		CopyFields (const Record &sourceRecord, const bool copyAllFields=false)
Copy all fields from a supplied record.
virtual ACTIV_DATABASE_API
StatusCode 		CopyFields (const Key &sourceKey, const bool copyAllFields=false)
Copy all fields from a supplied key.
virtual ACTIV_DATABASE_API
StatusCode 		Deserialize (ITable *pTable, MessageValidator &messageValidator)
Deserialize the key information from a message.
size_t | GetDataLength () const
Get data length.
StatusCode | GetIndexNumber (IndexSpecification::Number &indexNo) const
Get the index number of the key.
StatusCode | GetIndexPointer (IIndex *&pIndex) const
Get a pointer to the key's index.
StatusCode | GetIndexSpecification (IndexSpecification &indexSpecification) const
Get the index specification.
ACTIV_DATABASE_API StatusCode | Initialize (const IndexSpecification::Number indexNo, const Record &record)
Initialize with information contained in a record.
ACTIV_DATABASE_API StatusCode | Initialize (const Key &rhs)
Initialize with information contained in another key.
ACTIV_DATABASE_API StatusCode | Initialize (ITable *pTable, const IndexSpecification::Number indexNo)
Initialize key object for specified table and index number.
void | Initialize ()
Initialize to an undefined table and index.
ACTIV_DATABASE_API | Key (const Key &rhs)
Copy constructor.
ACTIV_DATABASE_API | Key (const IndexSpecification::Number indexNo, const Record &record)
Constructor that initializes the key with data from a record for the specified index.
ACTIV_DATABASE_API | Key (ITable *pTable, const IndexSpecification::Number indexNo)
Constructor that initializes the key for the specified table and index.
Key ()
Default constructor.
bool | operator!= (const Key &rhs) const
Inequality operator.
bool | operator< (const Key &rhs) const
Less than operator.
bool | operator<= (const Key &rhs) const
Less than or equal to operator.
ACTIV_DATABASE_API Key & | operator= (const Key &rhs)
Assignment operator.
bool | operator== (const Key &rhs) const
Equality operator.
bool | operator> (const Key &rhs) const
Greater than operator.
bool | operator>= (const Key &rhs) const
Greater than or equal to operator.
virtual ACTIV_DATABASE_API
StatusCode 		Reset ()
Reset the contents of the key data buffer.
virtual ACTIV_DATABASE_API
StatusCode 		Serialize (MessageBuilder &messageBuilder) const
Put the key information into a message.
StatusCode | Set (const void *pRhsData)
Set the contents of the key data buffer equal to the provided data buffer.
StatusCode | SetIndexFields (const ScatterBufferHelper &scatterBufferHelper)
Set the index fields in the key, starting with the first field in the index.
StatusCode | Validate (const ITable *pTable, const size_t nIndexes) const
Check whether the key is valid with respect to the specified table.
StatusCode | Validate (const ITable *pTable) const
Check whether the key is valid with respect to the specified table.
~Key ()
Destructor.

Detailed Description

Key class.

Definition at line 37 of file Key.h.

Constructor & Destructor Documentation

ACTIV_DATABASE_API Activ::Database::Key::Key | ( | ITable * | pTable,
 |  | const IndexSpecification::Number | indexNo
 | ) |  |

Constructor that initializes the key for the specified table and index.

Parameters:
pTable | table key will relate to.
indexNo | index number the key will relate to.
Exceptions:
DatabaseException

ACTIV_DATABASE_API Activ::Database::Key::Key | ( | const IndexSpecification::Number | indexNo,
 |  | const Record & | record
 | ) |  |

Constructor that initializes the key with data from a record for the specified index.

Parameters:
indexNo | index number the key will relate to.
record | the record to copy information from.
Exceptions:
DatabaseException

ACTIV_DATABASE_API Activ::Database::Key::Key ( const Key & rhs )

Copy constructor.

Parameters:
rhs the value to assign to this object.
Exceptions:
DatabaseException

Member Function Documentation

ACTIV_DATABASE_API StatusCode Activ::Database::Key::BuildKey ( const Record & record )

Build a key using the supplied record data.

Parameters:
record record to use to build the key.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH
STATUS_CODE_INVALID_RECORD
STATUS_CODE_NOT_INITIALIZED

virtual ACTIV_DATABASE_API StatusCode Activ::Database::Key::CopyFields | ( | const Record & | sourceRecord,
 |  | const bool | copyAllFields = false |
 | ) |  |  | [virtual]

Copy all fields from a supplied record.

The supplied record does not have to be for the same table.

Parameters:
sourceRecord | the record fields are copied from.
copyAllFields | whether all fields must be found in the source record.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_INVALID_RECORD
STATUS_CODE_NOT_FOUND
STATUS_CODE_NOT_INITIALIZED

virtual ACTIV_DATABASE_API StatusCode Activ::Database::Key::CopyFields | ( | const Key & | sourceKey,
 |  | const bool | copyAllFields = false |
 | ) |  |  | [virtual]

Copy all fields from a supplied key.

The supplied key does not have to be for the same table.

Parameters:
sourceKey | the key fields are copied from.
copyAllFields | whether all fields must be found in the source key.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_INDEX
STATUS_CODE_INVALID_LENGTH
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_HEAP_EMPTY
STATUS_CODE_NOT_INITIALIZED

virtual ACTIV_DATABASE_API StatusCode Activ::Database::Key::Deserialize | ( | ITable * | pTable,
 |  | MessageValidator & | messageValidator |
 | ) |  |  | [virtual]

Deserialize the key information from a message.

Parameters:
pTable | table key will relate to.
messageValidator | the message validator from which key data will be extracted.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_HEAP_EMPTY
STATUS_CODE_NOT_INITIALIZED

Implements Activ::Database::FieldListObject.

size_t Activ::Database::Key::GetDataLength ( ) const [inline]

Get data length.

Returns:
the length of the key data.

Definition at line 530 of file Key.h.

References Activ::Database::IIndex::GetKeyLength(), and Activ::Database::FieldListObject::IsInitialized().

Referenced by Set().

StatusCode Activ::Database::Key::GetIndexNumber ( IndexSpecification::Number & indexNo ) const [inline]

Get the index number of the key.

Parameters:
indexNo set to the index number that the key is initialized for.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED

Definition at line 537 of file Key.h.

References Activ::Database::FieldListObject::IsInitialized().

StatusCode Activ::Database::Key::GetIndexPointer ( IIndex *& pIndex ) const [inline]

Get a pointer to the key's index.

Parameters:
pIndex set equal to the index pointer of the key.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED

Definition at line 494 of file Key.h.

References Activ::Database::FieldListObject::IsInitialized().

StatusCode Activ::Database::Key::GetIndexSpecification ( IndexSpecification & indexSpecification ) const [inline]

Get the index specification.

Parameters:
indexSpecification set to the index specification associated with the key.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED

Definition at line 505 of file Key.h.

References Activ::Database::IIndex::GetSpecification(), and Activ::Database::FieldListObject::IsInitialized().

ACTIV_DATABASE_API StatusCode Activ::Database::Key::Initialize | ( | const IndexSpecification::Number | indexNo,
 |  | const Record & | record
 | ) |  |

Initialize with information contained in a record.

Parameters:
indexNo | index number the key will relate to.
record | the record to copy information from.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_LENGTH
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_INVALID_RECORD
STATUS_CODE_HEAP_EMPTY
STATUS_CODE_NOT_FOUND

ACTIV_DATABASE_API StatusCode Activ::Database::Key::Initialize ( const Key & rhs )

Initialize with information contained in another key.

Parameters:
rhs key to copy information from.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_HEAP_EMPTY

ACTIV_DATABASE_API StatusCode Activ::Database::Key::Initialize | ( | ITable * | pTable,
 |  | const IndexSpecification::Number | indexNo
 | ) |  |

Initialize key object for specified table and index number.

Parameters:
pTable | table key will relate to.
indexNo | index number the key will relate to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_HEAP_EMPTY

bool Activ::Database::Key::operator!= ( const Key & rhs ) const [inline]

Inequality operator.

Parameters:
rhs the object to compare with.
Returns:
the result of the test.

Definition at line 388 of file Key.h.

bool Activ::Database::Key::operator< ( const Key & rhs ) const [inline]

Less than operator.

Parameters:
rhs the object to compare with.
Returns:
the result of the test.

Definition at line 395 of file Key.h.

References Activ::Database::IIndex::Compare(), Activ::Database::ITable::GetIdentity(), Activ::Database::IIndex::GetName(), Activ::Database::ITable::GetName(), Activ::Database::FieldListObject::IsInitialized(), m_pIndex, and Activ::Database::FieldListObject::m_pTable.

bool Activ::Database::Key::operator<= ( const Key & rhs ) const [inline]

Less than or equal to operator.

Parameters:
rhs the object to compare with.
Returns:
the result of the test.

Definition at line 416 of file Key.h.

References Activ::Database::IIndex::Compare(), Activ::Database::ITable::GetIdentity(), Activ::Database::IIndex::GetName(), Activ::Database::ITable::GetName(), Activ::Database::FieldListObject::IsInitialized(), m_pIndex, and Activ::Database::FieldListObject::m_pTable.

ACTIV_DATABASE_API Key& Activ::Database::Key::operator= ( const Key & rhs )

Assignment operator.

Parameters:
rhs the value to assign to this object.
Returns:
a reference to this object.
Exceptions:
DatabaseException

bool Activ::Database::Key::operator== ( const Key & rhs ) const [inline]

Equality operator.

Parameters:
rhs the object to compare with.
Returns:
the result of the test.

Definition at line 370 of file Key.h.

References Activ::Database::IIndex::Compare(), Activ::Database::ITable::GetIdentity(), Activ::Database::FieldListObject::IsInitialized(), m_pIndex, and Activ::Database::FieldListObject::m_pTable.

bool Activ::Database::Key::operator> ( const Key & rhs ) const [inline]

Greater than operator.

Parameters:
rhs the object to compare with.
Returns:
the result of the test.

Definition at line 437 of file Key.h.

bool Activ::Database::Key::operator>= ( const Key & rhs ) const [inline]

Greater than or equal to operator.

Parameters:
rhs the object to compare with.
Returns:
the result of the test.

Definition at line 444 of file Key.h.

References Activ::Database::IIndex::Compare(), Activ::Database::ITable::GetIdentity(), Activ::Database::IIndex::GetName(), Activ::Database::ITable::GetName(), Activ::Database::FieldListObject::IsInitialized(), m_pIndex, and Activ::Database::FieldListObject::m_pTable.

StatusCode Activ::Database::Key::Reset ( ) [inline, virtual]

Reset the contents of the key data buffer.

Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED

Implements Activ::Database::FieldListObject.

Definition at line 474 of file Key.h.

References Activ::Database::FieldListObject::IsInitialized(), Activ::Database::FieldListObject::m_id, and Activ::Database::IIndex::ResetKey().

virtual ACTIV_DATABASE_API StatusCode Activ::Database::Key::Serialize ( MessageBuilder & messageBuilder ) const [virtual]

Put the key information into a message.

Parameters:
messageBuilder the message builder in which key data will be placed.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED
STATUS_CODE_FAILURE

Implements Activ::Database::FieldListObject.

StatusCode Activ::Database::Key::Set ( const void * pRhsData ) [inline]

Set the contents of the key data buffer equal to the provided data buffer.

Parameters:
pRhsData pointer to data.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER

Definition at line 516 of file Key.h.

References GetDataLength(), Activ::Database::FieldListObject::IsInitialized(), and Activ::Database::FieldListObject::m_pData.

StatusCode Activ::Database::Key::SetIndexFields ( const ScatterBufferHelper & scatterBufferHelper ) [inline]

Set the index fields in the key, starting with the first field in the index.

Parameters:
scatterBufferHelper a scatter buffer helper containing the fields to copy to the record.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_INDEX
STATUS_CODE_INVALID_LENGTH
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED

Definition at line 487 of file Key.h.

References Activ::Database::FieldListObject::IsInitialized(), and Activ::Database::IIndex::SetFields().

StatusCode Activ::Database::Key::Validate | ( | const ITable * | pTable,
 |  | const size_t | nIndexes |
 | ) |  |  | const [inline]

Check whether the key is valid with respect to the specified table.

Parameters:
pTable | pointer to table.
nIndexes | number of indexes in the specified table.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_KEY

Definition at line 557 of file Key.h.

References Activ::Database::ITable::GetIdentity(), Activ::Database::FieldListObject::IsInitialized(), and Activ::Database::FieldListObject::m_tableIdentity.

StatusCode Activ::Database::Key::Validate ( const ITable * pTable ) const [inline]

Check whether the key is valid with respect to the specified table.

Parameters:
pTable pointer to table.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_KEY

Definition at line 550 of file Key.h.

References Activ::Database::ITable::GetIdentity(), Activ::Database::FieldListObject::IsInitialized(), and Activ::Database::FieldListObject::m_tableIdentity.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivDatabase/Key.h
Generated on Wed Oct 8 14:02:11 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Database::ManagedTableFactory

Activ::Database::ManagedTableFactory Class Reference

Managed table factory class. More...

#include <ActivMiddleware/ActivDatabase/ManagedTableFactory.h>

Inheritance diagram for Activ::Database::ManagedTableFactory:

Activ::Singleton< T >

List of all members.

Public Member Functions

ACTIV_DATABASE_API ITable * | Create (const std::string &name, const std::string &directory, const TableSpecification::Properties properties, const FieldSpecificationList &fieldSpecificationList, const size_t initialMaxRecords, const size_t nGrowRecords=TableSpecification::GROW_RECORDS_DEFAULT, const size_t cacheSize=TableSpecification::CACHE_COMPLETE)
Create a persistent managed table using supplied field specification structures.
ACTIV_DATABASE_API ITable * | Create (const std::string &name, const std::string &directory, const TableSpecification::Properties properties, const FieldSpecification fieldSpecificationList[], const size_t nFields, const size_t initialMaxRecords, const size_t nGrowRecords=TableSpecification::GROW_RECORDS_DEFAULT, const size_t cacheSize=TableSpecification::CACHE_COMPLETE)
Create a persistent managed table using supplied field specification structures.
ACTIV_DATABASE_API ITable * | Create (const std::string &name, const TableSpecification::Properties properties, const FieldSpecificationList &fieldSpecificationList, const size_t initialMaxRecords, const size_t nGrowRecords=TableSpecification::GROW_RECORDS_DEFAULT, const size_t cacheSize=TableSpecification::CACHE_COMPLETE)
Create a temporary managed table using supplied field specification structures.
ACTIV_DATABASE_API ITable * | Create (const std::string &name, const TableSpecification::Properties properties, const FieldSpecification fieldSpecificationList[], const size_t nFields, const size_t initialMaxRecords, const size_t nGrowRecords=TableSpecification::GROW_RECORDS_DEFAULT, const size_t cacheSize=TableSpecification::CACHE_COMPLETE)
Create a temporary managed table using supplied field specification structures.

Static Public Member Functions

static ACTIV_DATABASE_API
ManagedTableFactory & 		GetInstance ()
Get a reference to the singleton instance.

Friends

class | Singleton< ManagedTableFactory >

Detailed Description

Managed table factory class.

Definition at line 32 of file ManagedTableFactory.h.

Member Function Documentation

ACTIV_DATABASE_API ITable* Activ::Database::ManagedTableFactory::Create | ( | const std::string & | name,
 |  | const std::string & | directory,
 |  | const TableSpecification::Properties | properties,
 |  | const FieldSpecificationList & | fieldSpecificationList,
 |  | const size_t | initialMaxRecords,
 |  | const size_t | nGrowRecords = TableSpecification::GROW_RECORDS_DEFAULT,
 |  | const size_t | cacheSize = TableSpecification::CACHE_COMPLETE
 | ) |  |

Create a persistent managed table using supplied field specification structures.

Parameters:
name | name of table.
directory | name of directory in which to store files.
properties | table properties.
fieldSpecificationList | specification list for fields.
initialMaxRecords | initial maximum allowed number of records.
nGrowRecords | the number of records to grow the table by. Zero implies the table should remain a fixed size.
cacheSize | the size of the cache, in kilobytes.
Exceptions:
StatusCodeException
BaseException
DatabaseException
OsException

ACTIV_DATABASE_API ITable* Activ::Database::ManagedTableFactory::Create | ( | const std::string & | name,
 |  | const std::string & | directory,
 |  | const TableSpecification::Properties | properties,
 |  | const FieldSpecification | fieldSpecificationList[],
 |  | const size_t | nFields,
 |  | const size_t | initialMaxRecords,
 |  | const size_t | nGrowRecords = TableSpecification::GROW_RECORDS_DEFAULT,
 |  | const size_t | cacheSize = TableSpecification::CACHE_COMPLETE
 | ) |  |

Create a persistent managed table using supplied field specification structures.

Parameters:
name | name of the table.
directory | name of the directory in which to store files.
properties | table properties.
fieldSpecificationList | specification list for fields.
nFields | number of table fields.
initialMaxRecords | initial maximum allowed number of records.
nGrowRecords | the number of records to grow the table by. Zero implies the table should remain a fixed size.
cacheSize | the size of the cache, in kilobytes.
Exceptions:
StatusCodeException
BaseException
DatabaseException
OsException

ACTIV_DATABASE_API ITable* Activ::Database::ManagedTableFactory::Create | ( | const std::string & | name,
 |  | const TableSpecification::Properties | properties,
 |  | const FieldSpecificationList & | fieldSpecificationList,
 |  | const size_t | initialMaxRecords,
 |  | const size_t | nGrowRecords = TableSpecification::GROW_RECORDS_DEFAULT,
 |  | const size_t | cacheSize = TableSpecification::CACHE_COMPLETE
 | ) |  |

Create a temporary managed table using supplied field specification structures.

Parameters:
name | name of the table.
properties | table properties.
fieldSpecificationList | specification list for fields.
initialMaxRecords | initial maximum allowed number of records.
nGrowRecords | the number of records to grow the table by. Zero implies the table should remain a fixed size.
cacheSize | the size of the cache, in kilobytes.
Exceptions:
StatusCodeException
BaseException
DatabaseException
OsException

ACTIV_DATABASE_API ITable* Activ::Database::ManagedTableFactory::Create | ( | const std::string & | name,
 |  | const TableSpecification::Properties | properties,
 |  | const FieldSpecification | fieldSpecificationList[],
 |  | const size_t | nFields,
 |  | const size_t | initialMaxRecords,
 |  | const size_t | nGrowRecords = TableSpecification::GROW_RECORDS_DEFAULT,
 |  | const size_t | cacheSize = TableSpecification::CACHE_COMPLETE
 | ) |  |

Create a temporary managed table using supplied field specification structures.

Parameters:
name | name of the table.
properties | table properties.
fieldSpecificationList | specification list for fields.
nFields | number of table fields.
initialMaxRecords | initial maximum allowed number of records.
nGrowRecords | the number of records to grow the table by. Zero implies the table should remain a fixed size.
cacheSize | the size of the cache, in kilobytes.
Exceptions:
StatusCodeException
BaseException
DatabaseException
OsException

static ACTIV_DATABASE_API ManagedTableFactory& Activ::Database::ManagedTableFactory::GetInstance ( ) [static]

Get a reference to the singleton instance.

Returns:
Reference.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivDatabase/ManagedTableFactory.h
Generated on Wed Oct 8 14:02:12 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Database::Record

Activ::Database::Record Class Reference

Database record class. More...

#include <ActivMiddleware/ActivDatabase/Record.h>

Inheritance diagram for Activ::Database::Record:

Activ::Database::FieldListObject

List of all members.

Public Member Functions

virtual ACTIV_DATABASE_API
StatusCode 		Deserialize (ITable *pTable, MessageValidator &messageValidator)
Deserialize the record information from a message.
size_t | GetDataLength () const
Get the length of the record.
ACTIV_DATABASE_API Key | GetKey (const IndexSpecification::Number indexNo) const
Get a copy of the key created for the specified index.
ACTIV_DATABASE_API Key | GetPrimaryKey () const
Get a copy of the primary key.
ACTIV_DATABASE_API StatusCode | Initialize (const Key &key)
Initialize with information contained in a key.
ACTIV_DATABASE_API StatusCode | Initialize (const Record &rhs)
Initialize with information contained in another record.
StatusCode | Initialize (ITable *pTable, const void *pSourceData, const DataId id)
Initialize for a specified table.
StatusCode | Initialize (ITable *pTable)
Initialize for a specified table.
ACTIV_DATABASE_API bool | operator!= (const Record &rhs) const
Inequality operator.
ACTIV_DATABASE_API Record & | operator= (const Record &rhs)
Assignment operator.
ACTIV_DATABASE_API bool | operator== (const Record &rhs) const
Equality operator.
ACTIV_DATABASE_API | Record (const Key &key)
Constructor that initializes the record with data from a key.
ACTIV_DATABASE_API | Record (const Record &rhs)
Copy constructor.
Record (ITable *pTable, const void *pSourceData, const DataId id)
Constructor that initializes record with provided record data.
ACTIV_DATABASE_API | Record (ITable *pTable)
Constructor that initializes record for the specified table.
Record ()
Constructor.
virtual ACTIV_DATABASE_API
StatusCode 		Reset ()
Reset the contents of the record data buffer.
virtual ACTIV_DATABASE_API
StatusCode 		Serialize (MessageBuilder &messageBuilder) const
Serialize the record information into a message.
StatusCode | Set (const void *pSourceData)
Set the contents of the record data buffer equal to the provided data buffer.
StatusCode | SetIndexFields (const IndexSpecification::Number indexNo, const ScatterBufferHelper &scatterBufferHelper)
Set the index fields in the record, starting with the first field in the index.
StatusCode | Validate (const ITable *pTable) const
Check whether the key is valid with respect to the specified table.
virtual | ~Record ()
Destructor.

Detailed Description

Database record class.

Definition at line 37 of file Record.h.

Constructor & Destructor Documentation

ACTIV_DATABASE_API Activ::Database::Record::Record ( ITable * pTable )

Constructor that initializes record for the specified table.

Parameters:
pTable table the record will be stored in.
Exceptions:
DatabaseException

Activ::Database::Record::Record | ( | ITable * | pTable,
 |  | const void * | pSourceData,
 |  | const DataId | id
 | ) |  |

Constructor that initializes record with provided record data.

Parameters:
pTable | table the record will be stored in.
pSourceData | pointer to data to store in the record.
id | the identifier to store with the record.
Exceptions:
DatabaseException

ACTIV_DATABASE_API Activ::Database::Record::Record ( const Record & rhs )

Copy constructor.

Parameters:
rhs the value to assign to this object.
Exceptions:
DatabaseException

ACTIV_DATABASE_API Activ::Database::Record::Record ( const Key & key )

Constructor that initializes the record with data from a key.

Parameters:
key the key to copy information from.
Exceptions:
DatabaseException

Member Function Documentation

virtual ACTIV_DATABASE_API StatusCode Activ::Database::Record::Deserialize | ( | ITable * | pTable,
 |  | MessageValidator & | messageValidator |
 | ) |  |  | [virtual]

Deserialize the record information from a message.

Parameters:
pTable | table the record will be stored in.
messageValidator | message validator containing the record data.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_HEAP_EMPTY
STATUS_CODE_NOT_INITIALIZED

Implements Activ::Database::FieldListObject.

size_t Activ::Database::Record::GetDataLength ( ) const [inline]

Get the length of the record.

Returns:
the length of the record.

Definition at line 326 of file Record.h.

References Activ::Database::ITable::GetRecordLength(), Activ::Database::FieldListObject::IsInitialized(), and Activ::Database::FieldListObject::m_pTable.

Referenced by Set().

ACTIV_DATABASE_API Key Activ::Database::Record::GetKey ( const IndexSpecification::Number indexNo ) const

Get a copy of the key created for the specified index.

Parameters:
indexNo the index number to create the key on.
Returns:
a key created from the record for the specified index.
Exceptions:
DatabaseException

ACTIV_DATABASE_API Key Activ::Database::Record::GetPrimaryKey ( ) const

Get a copy of the primary key.

Returns:
a key created from the record for the primary index.
Exceptions:
DatabaseException

ACTIV_DATABASE_API StatusCode Activ::Database::Record::Initialize ( const Key & key )

Initialize with information contained in a key.

Parameters:
key the key to copy information from.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_KEY
STATUS_CODE_INVALID_LENGTH
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_INVALID_RECORD
STATUS_CODE_HEAP_EMPTY

ACTIV_DATABASE_API StatusCode Activ::Database::Record::Initialize ( const Record & rhs )

Initialize with information contained in another record.

Parameters:
rhs the value to assign to this object.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_HEAP_EMPTY

StatusCode Activ::Database::Record::Initialize | ( | ITable * | pTable,
 |  | const void * | pSourceData,
 |  | const DataId | id
 | ) |  |

Initialize for a specified table.

Parameters:
pTable | table the record will be stored in.
pSourceData | pointer to data to store in the record.
id | the identifier to store with the record.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_HEAP_EMPTY

StatusCode Activ::Database::Record::Initialize ( ITable * pTable ) [inline]

Initialize for a specified table.

Parameters:
pTable table the record will be stored in.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_HEAP_EMPTY

Definition at line 280 of file Record.h.

References ACTIV_RETURN_RESULT_IF, Activ::Database::ITable::GetFieldList(), Activ::Database::ITable::GetIdentity(), Activ::Database::ITable::GetRecordLength(), Activ::Database::FieldListObject::Initialize(), Activ::Database::FieldListObject::m_pTable, and Activ::Database::ITable::ResetRecord().

ACTIV_DATABASE_API bool Activ::Database::Record::operator!= ( const Record & rhs ) const

Inequality operator.

Returns:
whether the two objects are not equal.

ACTIV_DATABASE_API Record& Activ::Database::Record::operator= ( const Record & rhs )

Assignment operator.

Parameters:
rhs the value to assign to this object.
Returns:
a reference to this object.
Exceptions:
DatabaseException

ACTIV_DATABASE_API bool Activ::Database::Record::operator== ( const Record & rhs ) const

Equality operator.

Returns:
whether the two objects are equal.

StatusCode Activ::Database::Record::Reset ( ) [inline, virtual]

Reset the contents of the record data buffer.

Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED

Implements Activ::Database::FieldListObject.

Definition at line 292 of file Record.h.

References Activ::Database::FieldListObject::GetFieldList(), Activ::Database::FieldListObject::IsInitialized(), Activ::Database::FieldListObject::m_id, Activ::Database::FieldListObject::m_pData, and Activ::Database::FieldList::ResetData().

virtual ACTIV_DATABASE_API StatusCode Activ::Database::Record::Serialize ( MessageBuilder & messageBuilder ) const [virtual]

Serialize the record information into a message.

Parameters:
messageBuilder the message builder into which the record data will be placed.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED
STATUS_CODE_FAILURE

Implements Activ::Database::FieldListObject.

StatusCode Activ::Database::Record::Set ( const void * pSourceData ) [inline]

Set the contents of the record data buffer equal to the provided data buffer.

Parameters:
pSourceData pointer to data to store in the record.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER

Definition at line 312 of file Record.h.

References GetDataLength(), Activ::Database::FieldListObject::IsInitialized(), and Activ::Database::FieldListObject::m_pData.

StatusCode Activ::Database::Record::SetIndexFields | ( | const IndexSpecification::Number | indexNo,
 |  | const ScatterBufferHelper & | scatterBufferHelper |
 | ) |  |  | [inline]

Set the index fields in the record, starting with the first field in the index.

Parameters:
indexNo | the number of the index which the fields will be set for.
scatterBufferHelper | a scatter buffer helper containing the fields to copy to the record.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_INDEX
STATUS_CODE_INVALID_LENGTH
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED

Definition at line 305 of file Record.h.

References Activ::Database::FieldListObject::IsInitialized(), Activ::Database::FieldListObject::m_pTable, and Activ::Database::ITable::SetIndexFields().

StatusCode Activ::Database::Record::Validate ( const ITable * pTable ) const [inline]

Check whether the key is valid with respect to the specified table.

This function does not check whether the supplied table pointer is valid.

Parameters:
pTable pointer to table.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_RECORD

Definition at line 333 of file Record.h.

References Activ::Database::ITable::GetIdentity(), and Activ::Database::FieldListObject::m_tableIdentity.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivDatabase/Record.h
Generated on Wed Oct 8 14:02:12 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Database::RemoteTableFactory

Activ::Database::RemoteTableFactory Class Reference

Remote table factory class. More...

#include <ActivMiddleware/ActivDatabase/RemoteTableFactory.h>

Inheritance diagram for Activ::Database::RemoteTableFactory:

Activ::Singleton< T >

List of all members.

Public Member Functions

ACTIV_DATABASE_API ITable * | Create (MessageValidator &messageValidator)
Create a remote table.

Static Public Member Functions

static ACTIV_DATABASE_API
RemoteTableFactory & 		GetInstance ()
Get a reference to the singleton instance.

Friends

class | Singleton< RemoteTableFactory >

Detailed Description

Remote table factory class.

Definition at line 31 of file RemoteTableFactory.h.

Member Function Documentation

ACTIV_DATABASE_API ITable* Activ::Database::RemoteTableFactory::Create ( MessageValidator & messageValidator )

Create a remote table.

Parameters:
messageValidator the message validator containing the remote table specification.
Returns:
a pointer to an interface to a table.
Exceptions:
DatabaseException

static ACTIV_DATABASE_API RemoteTableFactory& Activ::Database::RemoteTableFactory::GetInstance ( ) [static]

Get a reference to the singleton instance.

Returns:
Reference.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivDatabase/RemoteTableFactory.h
Generated on Wed Oct 8 14:02:12 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Database::TableSpecification

Activ::Database::TableSpecification Class Reference

Table specification structure. More...

#include <ActivMiddleware/ActivDatabase/TableSpecification.h>

List of all members.

Public Types

enum | { PROPERTY_NONE = 0x00000000, PROPERTY_CREATE_RECORD_FILE = 0x00000001, PROPERTY_CREATE_MUTEX = 0x00000002, PROPERTY_CONVERT = 0x00000004 }
Properties. More...
typedef uint32_t | Properties
Definition of the properties of the table.

Public Member Functions

ACTIV_DATABASE_API ITable * | CreateTable (const std::string &directory=std::string()) const
Create a table from a table specification.
ACTIV_DATABASE_API StatusCode | Deserialize (MessageValidator &messageValidator)
Deserialize a table specification from a message.
ACTIV_DATABASE_API bool | operator!= (const TableSpecification &rhs) const
Inequality operator.
ACTIV_DATABASE_API bool | operator== (const TableSpecification &rhs) const
Equality operator.
ACTIV_DATABASE_API StatusCode | Serialize (MessageBuilder &messageBuilder, const uint8_t version=VERSION) const
Serialize the table specification into a message.
TableSpecification (const std::string &name, const bool isManaged, const Properties properties, const FieldSpecificationList &fieldSpecificationList, const size_t initialMaxRecords, const size_t recordLength, const size_t nGrowRecords, const size_t cacheSize)
Constructor for unmanaged tables.
ACTIV_DATABASE_API | TableSpecification (const std::string &name, const Properties properties, const FieldSpecificationList &fieldSpecificationList, const size_t initialMaxRecords, const size_t recordLength, const size_t nGrowRecords=GROW_RECORDS_DEFAULT, const size_t cacheSize=CACHE_COMPLETE)
Constructor for unmanaged tables.
ACTIV_DATABASE_API | TableSpecification (const std::string &name, const Properties properties, const FieldSpecificationList &fieldSpecificationList, const size_t initialMaxRecords, const size_t nGrowRecords=GROW_RECORDS_DEFAULT, const size_t cacheSize=CACHE_COMPLETE)
Constructor for managed tables.
ACTIV_DATABASE_API | TableSpecification ()
Constructor.
ACTIV_DATABASE_API std::string | ToString () const
Convert the specification to a C-style string.

Static Public Member Functions

static ACTIV_DATABASE_API
StatusCode 		Serialize (MessageBuilder &messageBuilder, ITable *pTable, const uint8_t version=VERSION)
Serialize the table specification into a message.
static ACTIV_DATABASE_API bool | ShouldConvert (const Properties properties)
Should convert.
static ACTIV_DATABASE_API bool | ShouldCreateMutex (const Properties properties)
Should create mutex.
static ACTIV_DATABASE_API bool | ShouldCreateRecordFile (const Properties properties)
Should create record file.

Public Attributes

size_t | m_cacheSize
The size, in kb, of the record cache.
FieldSpecificationList | m_fieldSpecificationList
Field specification list.
size_t | m_initialMaxRecords
Initial maximum number of records.
bool | m_isManaged
Indicates whether the table is managed.
std::string | m_name
Name.
size_t | m_nGrowRecords
Number of records to grow the table by.
Properties m_properties
Properties.
size_t | m_recordLength
Record length.

Static Public Attributes

static const size_t | CACHE_COMPLETE = ~0
Cache the complete contents of the table.
static const size_t | GROW_RECORDS_DEFAULT = ~0
Table will grow by the default number of records when it becomes full.
static const uint8_t | VERSION = 1
Version of the specification.

Detailed Description

Table specification structure.

Definition at line 34 of file TableSpecification.h.

Member Enumeration Documentation

anonymous enum

Properties.

Enumerator:
PROPERTY_CREATE_RECORD_FILE | If not specified hands control of creating the record data store to the user so that errors can be reported.
PROPERTY_CREATE_MUTEX | Create a mutex to control access to the table. Locking occurs over the whole table.
PROPERTY_CONVERT | Persisted table data is converted if the specification for a table changes.

Definition at line 45 of file TableSpecification.h.

Constructor & Destructor Documentation

ACTIV_DATABASE_API Activ::Database::TableSpecification::TableSpecification | ( | const std::string & | name,
 |  | const Properties | properties,
 |  | const FieldSpecificationList & | fieldSpecificationList,
 |  | const size_t | initialMaxRecords,
 |  | const size_t | nGrowRecords = GROW_RECORDS_DEFAULT,
 |  | const size_t | cacheSize = CACHE_COMPLETE
 | ) |  |

Constructor for managed tables.

Parameters:
name | set equal to the name of the table.
properties | set equal to the table properties.
fieldSpecificationList | set equal to the field specification list.
initialMaxRecords | set equal to the initial maxmimum number of records.
nGrowRecords | the number of records to grow the table by.
cacheSize | set equal to the cache size.
Exceptions:
DatabaseException

ACTIV_DATABASE_API Activ::Database::TableSpecification::TableSpecification | ( | const std::string & | name,
 |  | const Properties | properties,
 |  | const FieldSpecificationList & | fieldSpecificationList,
 |  | const size_t | initialMaxRecords,
 |  | const size_t | recordLength,
 |  | const size_t | nGrowRecords = GROW_RECORDS_DEFAULT,
 |  | const size_t | cacheSize = CACHE_COMPLETE
 | ) |  |

Constructor for unmanaged tables.

Parameters:
name | set equal to the name of the table.
properties | set equal to the table properties.
fieldSpecificationList | set equal to the field specification list.
initialMaxRecords | set equal to the initial maxmimum number of records.
recordLength | the length of a record.
nGrowRecords | the number of records to grow the table by.
cacheSize | set equal to the cache size.
Exceptions:
DatabaseException

Activ::Database::TableSpecification::TableSpecification | ( | const std::string & | name,
 |  | const bool | isManaged,
 |  | const Properties | properties,
 |  | const FieldSpecificationList & | fieldSpecificationList,
 |  | const size_t | initialMaxRecords,
 |  | const size_t | recordLength,
 |  | const size_t | nGrowRecords,
 |  | const size_t | cacheSize
 | ) |  |

Constructor for unmanaged tables.

Parameters:
name | the name of the table.
isManaged | indicates whether the table is managed.
properties | set equal to the table properties.
fieldSpecificationList | set equal to the field specification list.
initialMaxRecords | set equal to the initial maxmimum number of records.
recordLength | the length of a record.
nGrowRecords | the number of records to grow the table by.
cacheSize | set equal to the cache size.
Exceptions:
DatabaseException

Member Function Documentation

ACTIV_DATABASE_API ITable* Activ::Database::TableSpecification::CreateTable ( const std::string & directory = std::string() ) const

Create a table from a table specification.

Parameters:
directory name of directory in which to store persistent table files, or empty to create a temporary version of the table.
Returns:
a pointer to the created table.
Exceptions:
StatusCodeException
BaseException
DatabaseException
OsException

ACTIV_DATABASE_API StatusCode Activ::Database::TableSpecification::Deserialize ( MessageValidator & messageValidator )

Deserialize a table specification from a message.

Parameters:
messageValidator the message validator from which the table specification is extracted.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_HEAP_EMPTY
STATUS_CODE_NOT_INITIALIZED

ACTIV_DATABASE_API bool Activ::Database::TableSpecification::operator!= ( const TableSpecification & rhs ) const

Inequality operator.

Parameters:
rhs the object to compare with.
Returns:
the result of the test.

ACTIV_DATABASE_API bool Activ::Database::TableSpecification::operator== ( const TableSpecification & rhs ) const

Equality operator.

This function only uses the fields that affect the format of a record to determine equality. For example, m_initialMaxRecords and m_cacheSize do not affect the format of a record, so two table specifications are considered the same even if these fields differ between the two. Strictly speaking, name falls into this category but is in fact still included in the check because of the difference that field can have on the serialized length of the specification.

Parameters:
rhs the object to compare with.
Returns:
the result of the test.

ACTIV_DATABASE_API StatusCode Activ::Database::TableSpecification::Serialize | ( | MessageBuilder & | messageBuilder,
 |  | const uint8_t | version = VERSION |
 | ) |  |  | const

Serialize the table specification into a message.

Parameters:
messageBuilder | the message builder used for constructing the message.
version | the version to serialize to (default latest).
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED
STATUS_CODE_FAILURE

static ACTIV_DATABASE_API StatusCode Activ::Database::TableSpecification::Serialize | ( | MessageBuilder & | messageBuilder,
 |  | ITable * | pTable,
 |  | const uint8_t | version = VERSION |
 | ) |  |  | [static]

Serialize the table specification into a message.

Parameters:
messageBuilder | the message builder used for constructing the message.
pTable | the table for which the specification is to be serialized.
version | the version to serialize to (default latest).
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED
STATUS_CODE_FAILURE

static ACTIV_DATABASE_API bool Activ::Database::TableSpecification::ShouldConvert ( const Properties properties ) [static]

Should convert.

Parameters:
properties the properties to check.
Returns:
true if the table data should be converted.

static ACTIV_DATABASE_API bool Activ::Database::TableSpecification::ShouldCreateMutex ( const Properties properties ) [static]

Should create mutex.

Parameters:
properties the properties to check.
Returns:
true if the mutex should be created.

static ACTIV_DATABASE_API bool Activ::Database::TableSpecification::ShouldCreateRecordFile ( const Properties properties ) [static]

Should create record file.

Parameters:
properties the properties to check.
Returns:
true if the record file should be created.

ACTIV_DATABASE_API std::string Activ::Database::TableSpecification::ToString ( ) const

Convert the specification to a C-style string.

Returns:
the specification as a string.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivDatabase/TableSpecification.h
Generated on Wed Oct 8 14:02:12 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Database::UnmanagedTableFactory

Activ::Database::UnmanagedTableFactory Class Reference

Unmanaged table factory class. More...

#include <ActivMiddleware/ActivDatabase/UnmanagedTableFactory.h>

Inheritance diagram for Activ::Database::UnmanagedTableFactory:

Activ::Singleton< T >

List of all members.

Public Member Functions

ACTIV_DATABASE_API ITable * | Create (const std::string &name, const std::string &directory, const TableSpecification::Properties properties, const FieldSpecificationList &fieldSpecificationList, const size_t initialMaxRecords, const size_t recordLength, const size_t nGrowRecords=TableSpecification::GROW_RECORDS_DEFAULT, const size_t cacheSize=TableSpecification::CACHE_COMPLETE)
Create a persistent database table using supplied field specification structures.
ACTIV_DATABASE_API ITable * | Create (const std::string &name, const std::string &directory, const TableSpecification::Properties properties, const FieldSpecification fieldSpecificationList[], const size_t nFields, const size_t initialMaxRecords, const size_t recordLength, const size_t nGrowRecords=TableSpecification::GROW_RECORDS_DEFAULT, const size_t cacheSize=TableSpecification::CACHE_COMPLETE)
Create a persistent database table using supplied field specification structures.
ACTIV_DATABASE_API ITable * | Create (const std::string &name, const TableSpecification::Properties properties, const FieldSpecificationList &fieldSpecificationList, const size_t initialMaxRecords, const size_t recordLength, const size_t nGrowRecords=TableSpecification::GROW_RECORDS_DEFAULT, const size_t cacheSize=TableSpecification::CACHE_COMPLETE)
Create a temporary table using supplied field specification structures.
ACTIV_DATABASE_API ITable * | Create (const std::string &name, const TableSpecification::Properties properties, const FieldSpecification fieldSpecificationList[], const size_t nFields, const size_t initialMaxRecords, const size_t recordLength, const size_t nGrowRecords=TableSpecification::GROW_RECORDS_DEFAULT, const size_t cacheSize=TableSpecification::CACHE_COMPLETE)
Create a temporary table using supplied field specification structures.

Static Public Member Functions

static ACTIV_DATABASE_API
UnmanagedTableFactory & 		GetInstance ()
Get a reference to the singleton instance.

Friends

class | Singleton< UnmanagedTableFactory >

Detailed Description

Unmanaged table factory class.

Definition at line 32 of file UnmanagedTableFactory.h.

Member Function Documentation

ACTIV_DATABASE_API ITable* Activ::Database::UnmanagedTableFactory::Create | ( | const std::string & | name,
 |  | const std::string & | directory,
 |  | const TableSpecification::Properties | properties,
 |  | const FieldSpecificationList & | fieldSpecificationList,
 |  | const size_t | initialMaxRecords,
 |  | const size_t | recordLength,
 |  | const size_t | nGrowRecords = TableSpecification::GROW_RECORDS_DEFAULT,
 |  | const size_t | cacheSize = TableSpecification::CACHE_COMPLETE
 | ) |  |

Create a persistent database table using supplied field specification structures.

Parameters:
name | name of table.
directory | name of directory in which to store files.
properties | table properties.
fieldSpecificationList | specification list for fields.
initialMaxRecords | initial maximum allowed number of records.
recordLength | length of record.
nGrowRecords | the number of records to grow the table by. Zero implies the table should remain a fixed size.
cacheSize | the size of the cache, in kilobytes.
Exceptions:
StatusCodeException
BaseException
DatabaseException
OsException

ACTIV_DATABASE_API ITable* Activ::Database::UnmanagedTableFactory::Create | ( | const std::string & | name,
 |  | const std::string & | directory,
 |  | const TableSpecification::Properties | properties,
 |  | const FieldSpecification | fieldSpecificationList[],
 |  | const size_t | nFields,
 |  | const size_t | initialMaxRecords,
 |  | const size_t | recordLength,
 |  | const size_t | nGrowRecords = TableSpecification::GROW_RECORDS_DEFAULT,
 |  | const size_t | cacheSize = TableSpecification::CACHE_COMPLETE
 | ) |  |

Create a persistent database table using supplied field specification structures.

Parameters:
name | name of table.
directory | name of directory in which to store files.
properties | table properties.
fieldSpecificationList | specification list for fields.
nFields | number of table fields.
initialMaxRecords | initial maximum allowed number of records.
recordLength | length of record.
nGrowRecords | the number of records to grow the table by. Zero implies the table should remain a fixed size.
cacheSize | the size of the cache, in kilobytes.
Exceptions:
StatusCodeException
BaseException
DatabaseException
OsException

ACTIV_DATABASE_API ITable* Activ::Database::UnmanagedTableFactory::Create | ( | const std::string & | name,
 |  | const TableSpecification::Properties | properties,
 |  | const FieldSpecificationList & | fieldSpecificationList,
 |  | const size_t | initialMaxRecords,
 |  | const size_t | recordLength,
 |  | const size_t | nGrowRecords = TableSpecification::GROW_RECORDS_DEFAULT,
 |  | const size_t | cacheSize = TableSpecification::CACHE_COMPLETE
 | ) |  |

Create a temporary table using supplied field specification structures.

Parameters:
name | name of table.
properties | table properties.
fieldSpecificationList | specification list for fields.
initialMaxRecords | initial maximum allowed number of records.
recordLength | length of record.
nGrowRecords | the number of records to grow the table by. Zero implies the table should remain a fixed size.
cacheSize | the size of the cache, in kilobytes.
Exceptions:
StatusCodeException
BaseException
DatabaseException
OsException

ACTIV_DATABASE_API ITable* Activ::Database::UnmanagedTableFactory::Create | ( | const std::string & | name,
 |  | const TableSpecification::Properties | properties,
 |  | const FieldSpecification | fieldSpecificationList[],
 |  | const size_t | nFields,
 |  | const size_t | initialMaxRecords,
 |  | const size_t | recordLength,
 |  | const size_t | nGrowRecords = TableSpecification::GROW_RECORDS_DEFAULT,
 |  | const size_t | cacheSize = TableSpecification::CACHE_COMPLETE
 | ) |  |

Create a temporary table using supplied field specification structures.

Parameters:
name | name of table.
properties | table properties.
fieldSpecificationList | specification list for fields.
nFields | number of table fields.
initialMaxRecords | initial maximum allowed number of records.
recordLength | length of record.
nGrowRecords | the number of records to grow the table by. Zero implies the table should remain a fixed size.
cacheSize | the size of the cache, in kilobytes.
Exceptions:
StatusCodeException
BaseException
DatabaseException
OsException

static ACTIV_DATABASE_API UnmanagedTableFactory& Activ::Database::UnmanagedTableFactory::GetInstance ( ) [static]

Get a reference to the singleton instance.

Returns:
Reference.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivDatabase/UnmanagedTableFactory.h
Generated on Wed Oct 8 14:02:12 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Date

Activ::Date Class Reference

Date class. More...

#include <ActivMiddleware/ActivFieldTypes/Date.h>

Inheritance diagram for Activ::Date:

Activ::IFieldType

List of all members.

Public Types

enum | { ACTIV_DECLARE_ELEMENT_1_WITH_COMMA }
Day enumeration.
enum | { ACTIV_DECLARE_ELEMENT_1_WITH_COMMA }
Month enumeration.

Public Member Functions

ACTIV_FIELD_TYPES_API StatusCode | Add (const Days &days)
Add.
virtual void | Clear ()
Clear the object.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		Compare (const void *const pRhsSerializedBody, const size_t rhsSerializedBodyLength, int &result) const
Compare.
ACTIV_FIELD_TYPES_API StatusCode | Compare (const Date &rhs, int &result) const
Compare.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		Convert (const IFieldType *const pIFieldType)
Convert another IFieldType object to this type.
Date (const std::tm &tm)
Constructor.
Date (const int32_t julianDate)
Constructor.
Date (const uint32_t year, const uint32_t month, const uint32_t day)
Constructor.
Date ()
Default constructor.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		Deserialize (MessageValidator &messageValidator, const size_t maxSerializedBodyLength)
Deserialize the object from the supplied message validator.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		DeserializeBody (const void *const pSerializedBody, const size_t serializedBodyLength)
Deserialize the object's body from the supplied data buffer.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		DeserializeLengthAndBody (MessageValidator &messageValidator, const size_t maxSerializedBodyLength=MAX_SERIALIZED_BODY_LENGTH_UNDEFINED)
Deserialize the object's length and body from the supplied message validator.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		FromString (MessageValidator &messageValidator)
Convert the object from a string.
StatusCode | Get (std::tm &tm) const
Get the date.
StatusCode | Get (int32_t &julianDate) const
Get the date.
StatusCode | Get (uint32_t &year, uint32_t &month, uint32_t &day) const
Get the date.
int32_t | Get () const
Get the julian date.
uint32_t | GetDay () const
Get the day.
uint32_t | GetDayOfWeek () const
Get the day of the week.
uint32_t | GetDayOfYear () const
Get the day of the year.
virtual ACTIV_FIELD_TYPES_API
std::string 		GetFromStringFormat () const
Get a usage string for the format supported by FromString().
uint32_t | GetMonth () const
Get the month.
virtual size_t | GetSerializedBodyLength () const
Get the serialized length of the object's body.
virtual size_t | GetSerializedLength () const
Get the serialized length of the object.
uint32_t | GetWeekOfYear () const
Get the week of the year.
uint32_t | GetYear () const
Get the year.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		IsDifferent (const void *const pRhsSerializedBody, const size_t rhsSerializedBodyLength, bool &isDifferent) const
Is different.
bool | operator!= (const Date &rhs) const
Inequality operator.
template<typename T>
const Date | operator+ (const T &rhs) const
Addition operator.
template<typename T>
Date & | operator+= (const T &rhs)
Addition assignment operator.
template<typename T>
const Date | operator- (const T &rhs) const
Subtraction operator.
template<typename T>
Date & | operator-= (const T &rhs)
Subtraction assignment operator.
bool | operator< (const Date &rhs) const
Less than operator.
bool | operator<= (const Date &rhs) const
Less than or equal to operator.
bool | operator== (const Date &rhs) const
Equality operator.
bool | operator> (const Date &rhs) const
Greater than operator.
bool | operator>= (const Date &rhs) const
Greater than or equal to operator.
virtual void | Reset ()
Reset the object.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		Serialize (MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength) const
Serialize the object into the supplied message builder.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		SerializeBody (void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength) const
Serialize the object's body into the supplied data buffer.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		SerializeLengthAndBody (MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength=MAX_SERIALIZED_BODY_LENGTH_UNDEFINED) const
Serialize the object's length and body into the supplied message builder.
StatusCode | Set (const std::tm &tm)
Store a new date.
StatusCode | Set (const int32_t julianDate)
Store a new date.
StatusCode | Set (const uint32_t year, const uint32_t month, const uint32_t day)
Store a new date.
ACTIV_FIELD_TYPES_API StatusCode | Subtract (const Days &days)
Subtract.
virtual ACTIV_FIELD_TYPES_API
std::string 		ToString () const
Convert the object to a string.
virtual | ~Date ()
Destructor.

Static Public Member Functions

static ACTIV_FIELD_TYPES_API
StatusCode 		Compare (const void *const pLhsSerializedBody, const size_t lhsSerializedBodyLength, const void *const pRhsSerializedBody, const size_t rhsSerializedBodyLength, int &result)
Compare two objects serialized bodies.
static ACTIV_FIELD_TYPES_API
int32_t 		ConvertGregorianToJulianDate (const int32_t year, const int32_t month, const int32_t day)
Convert gregorian to julian date.
static ACTIV_FIELD_TYPES_API void | ConvertJulianToGregorianDate (const int32_t julianDate, int32_t &year, int32_t &month, int32_t &day)
Convert julian to gregorian date.
static ACTIV_FIELD_TYPES_API Date | CreateLocalDate ()
Create an object intitialized with the current local date.
static ACTIV_FIELD_TYPES_API Date | CreateUtcDate ()
Create an object intitialized with the current UTC date.
static ACTIV_FIELD_TYPES_API
std::string 		DayOfWeekToString (const uint32_t dayOfWeek)
Convert the day of the week to a string.
static ACTIV_FIELD_TYPES_API
uint32_t 		GetDayOfWeek (const uint32_t year, const uint32_t month, const uint32_t day)
Get the day of the week.
static ACTIV_FIELD_TYPES_API
uint32_t 		GetDayOfYear (const uint32_t year, const uint32_t month, const uint32_t day)
Get the day of the year.
static ACTIV_FIELD_TYPES_API
uint32_t 		GetDaysInMonth (const uint32_t year, const uint32_t month)
Get the number of days in a month.
static size_t | GetMaxSerializedBodyLength ()
Get the maximum serialized length of the object's body.
static size_t | GetMaxSerializedLength ()
Get the maximum serialized length of the object.
static ACTIV_FIELD_TYPES_API
uint32_t 		GetWeekOfYear (const uint32_t year, const uint32_t month, const uint32_t day)
Get the week of the year.
static ACTIV_FIELD_TYPES_API bool | IsLeapYear (const uint32_t year)
Is the year a leap year.
static bool | IsValidSerializedBodyLength (const size_t serializedBodyLength)
Is valid serialized body length.
static ACTIV_FIELD_TYPES_API
std::string 		MonthToString (const uint32_t month)
Convert the month to a string.
static ACTIV_FIELD_TYPES_API
StatusCode 		ValidateSerializedLengthAndBody (MessageValidator &messageValidator, size_t &serializedBodyOffset, size_t &serializedBodyLength)
Validate the serialized length and body.

Static Public Attributes

static const uint32_t | DAYS_PER_MONTH = 31
The number of days in a month.
static const uint32_t | DAYS_PER_WEEK = 7
The number of days in a week.
static const FieldType | FIELD_TYPE = FIELD_TYPE_DATE
The field type.
static const uint32_t | MONTHS_PER_YEAR = 12
The number of months in an year.

Friends

class | DateTime

Classes

class | Days
Days class. More...

Detailed Description

Date class.

Definition at line 60 of file Date.h.

Constructor & Destructor Documentation

Activ::Date::Date | ( | const uint32_t | year,
 |  | const uint32_t | month,
 |  | const uint32_t | day |
 | ) |  |  | [inline]

Constructor.

Parameters:
year | the year.
month | the month.
day | the day.
Exceptions:
StatusCodeException

Definition at line 633 of file Date.h.

References ACTIV_THROW_RESULT_IF, and Set().

Activ::Date::Date ( const int32_t julianDate ) [inline, explicit]

Constructor.

Parameters:
julianDate the julian date.
Exceptions:
StatusCodeException

Definition at line 641 of file Date.h.

References ACTIV_THROW_RESULT_IF, and Set().

Activ::Date::Date ( const std::tm & tm ) [inline]

Constructor.

Uses the tm_year, tm_mon and tm_mday fields of the provided tm structure.

Parameters:
tm reference to a tm structure specifying the date.
Exceptions:
StatusCodeException

Definition at line 649 of file Date.h.

References ACTIV_THROW_RESULT_IF, and Set().

Member Function Documentation

ACTIV_FIELD_TYPES_API StatusCode Activ::Date::Add ( const Days & days )

Add.

Parameters:
days the number of days to add to this object.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED

Referenced by Activ::DateTime::Add(), and operator+=().

static ACTIV_FIELD_TYPES_API StatusCode Activ::Date::Compare | ( | const void *const | pLhsSerializedBody,
 |  | const size_t | lhsSerializedBodyLength,
 |  | const void *const | pRhsSerializedBody,
 |  | const size_t | rhsSerializedBodyLength,
 |  | int & | result |
 | ) |  |  | [static]

Compare two objects serialized bodies.

Parameters:
pLhsSerializedBody | the buffer containing the lhs serialized version of the object's body in.
lhsSerializedBodyLength | the lhs serialized body length.
pRhsSerializedBody | the buffer containing the rhs serialized version of the object's body in.
rhsSerializedBodyLength | the rhs serialized body length.
result | the result of the comparison.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::Date::Compare | ( | const void *const | pRhsSerializedBody,
 |  | const size_t | rhsSerializedBodyLength,
 |  | int & | result |
 | ) |  |  | const [virtual]

Compare.

Parameters:
pRhsSerializedBody | the buffer containing the rhs serialized version of the object's body in.
rhsSerializedBodyLength | the rhs serialized body length.
result | the result of the comparison.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

ACTIV_FIELD_TYPES_API StatusCode Activ::Date::Compare | ( | const Date & | rhs,
 |  | int & | result |
 | ) |  |  | const

Compare.

Parameters:
rhs | the object to compare with.
result | the result of the comparison.
Return values:
STATUS_CODE_SUCCESS

Referenced by Activ::ContentPlatform::ContentGatewayApi::HistoryBar::Compare(), operator<(), operator==(), and operator>().

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::Date::Convert ( const IFieldType *const pIFieldType ) [virtual]

Convert another IFieldType object to this type.

Parameters:
pIFieldType the value to assign from.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_MISMATCH
...

Implements Activ::IFieldType.

static ACTIV_FIELD_TYPES_API int32_t Activ::Date::ConvertGregorianToJulianDate | ( | const int32_t | year,
 |  | const int32_t | month,
 |  | const int32_t | day |
 | ) |  |  | [static]

Convert gregorian to julian date.

Algorithm only valid for non-negative julian date number (gregorian date on or after -4713/11/24).

Parameters:
year | the year.
month | the month.
day | the day.
Returns:
the julian date.

Referenced by Activ::DateTime::ConvertGregorianToJulianDateTime(), and Get().

static ACTIV_FIELD_TYPES_API void Activ::Date::ConvertJulianToGregorianDate | ( | const int32_t | julianDate,
 |  | int32_t & | year,
 |  | int32_t & | month,
 |  | int32_t & | day |
 | ) |  |  | [static]

Convert julian to gregorian date.

Algorithm only valid for non-negative julian date number (gregorian date on or after -4713/11/24).

Parameters:
julianDate | the julian date.
year | the year.
month | the month.
day | the day.

Referenced by Activ::DateTime::ConvertJulianToGregorianDateTime(), and Set().

static ACTIV_FIELD_TYPES_API Date Activ::Date::CreateLocalDate ( ) [static]

Create an object intitialized with the current local date.

Returns:
the initialized object.

static ACTIV_FIELD_TYPES_API Date Activ::Date::CreateUtcDate ( ) [static]

Create an object intitialized with the current UTC date.

Returns:
the initialized object.

static ACTIV_FIELD_TYPES_API std::string Activ::Date::DayOfWeekToString ( const uint32_t dayOfWeek ) [static]

Convert the day of the week to a string.

Parameters:
dayOfWeek the day of the week to convert.
Returns:
the day of the week as a string.

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::Date::Deserialize | ( | MessageValidator & | messageValidator,
 |  | const size_t | maxSerializedBodyLength |
 | ) |  |  | [virtual]

Deserialize the object from the supplied message validator.

Parameters:
messageValidator | the message validator from which the object will be extracted.
maxSerializedBodyLength | the maximum serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::Date::DeserializeBody | ( | const void *const | pSerializedBody,
 |  | const size_t | serializedBodyLength |
 | ) |  |  | [virtual]

Deserialize the object's body from the supplied data buffer.

Parameters:
pSerializedBody | the buffer from which the object's body will be extracted.
serializedBodyLength | the serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::Date::DeserializeLengthAndBody | ( | MessageValidator & | messageValidator,
 |  | const size_t | maxSerializedBodyLength = MAX_SERIALIZED_BODY_LENGTH_UNDEFINED |
 | ) |  |  | [virtual]

Deserialize the object's length and body from the supplied message validator.

Parameters:
messageValidator | the message validator from which the object will be extracted.
maxSerializedBodyLength | the maximum serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::Date::FromString ( MessageValidator & messageValidator ) [virtual]

Convert the object from a string.

Parameters:
messageValidator the message validator.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

StatusCode Activ::Date::Get ( std::tm & tm ) const [inline]

Get the date.

Only sets the tm_year, tm_mon and tm_mday fields of the provided tm structure.

Parameters:
tm reference to a tm structure to receive the date.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED

Definition at line 823 of file Date.h.

References Activ::IFieldType::IsInitialized().

StatusCode Activ::Date::Get ( int32_t & julianDate ) const [inline]

Get the date.

Parameters:
julianDate the julian date.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED

Definition at line 811 of file Date.h.

References ConvertGregorianToJulianDate(), and Activ::IFieldType::IsInitialized().

StatusCode Activ::Date::Get | ( | uint32_t & | year,
 |  | uint32_t & | month,
 |  | uint32_t & | day |
 | ) |  |  | const [inline]

Get the date.

Parameters:
year | the year.
month | the month.
day | the day.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED

Definition at line 797 of file Date.h.

References Activ::IFieldType::IsInitialized().

int32_t Activ::Date::Get ( ) const [inline]

Get the julian date.

Returns:
the julian date.
Exceptions:
StatusCodeException

Definition at line 787 of file Date.h.

References ACTIV_THROW, ConvertGregorianToJulianDate(), and Activ::IFieldType::IsInitialized().

Referenced by Activ::DateTime::Get().

uint32_t Activ::Date::GetDay ( ) const [inline]

Get the day.

Returns:
the day.
Exceptions:
StatusCodeException

Definition at line 857 of file Date.h.

References ACTIV_THROW, and Activ::IFieldType::IsInitialized().

Referenced by Activ::DateTime::GetDay().

static ACTIV_FIELD_TYPES_API uint32_t Activ::Date::GetDayOfWeek | ( | const uint32_t | year,
 |  | const uint32_t | month,
 |  | const uint32_t | day |
 | ) |  |  | [static]

Get the day of the week.

Parameters:
year | the year.
month | the month.
day | the day.
Returns:
the day of the week (Sunday = 0, Monday = 1, ..., Saturday = 6).

uint32_t Activ::Date::GetDayOfWeek ( ) const [inline]

Get the day of the week.

Returns:
the day of the week.
Exceptions:
StatusCodeException

Definition at line 867 of file Date.h.

References ACTIV_THROW, and Activ::IFieldType::IsInitialized().

Referenced by Activ::DateTime::GetDayOfWeek().

static ACTIV_FIELD_TYPES_API uint32_t Activ::Date::GetDayOfYear | ( | const uint32_t | year,
 |  | const uint32_t | month,
 |  | const uint32_t | day |
 | ) |  |  | [static]

Get the day of the year.

Parameters:
year | the year.
month | the month.
day | the day.
Returns:
the day of the year (Jan 1st = 1, Jan 2nd = 2, ..., Dec 31st = 365).

uint32_t Activ::Date::GetDayOfYear ( ) const [inline]

Get the day of the year.

Returns:
the day of the year.
Exceptions:
StatusCodeException

Definition at line 877 of file Date.h.

References ACTIV_THROW, and Activ::IFieldType::IsInitialized().

Referenced by Activ::DateTime::GetDayOfYear().

static ACTIV_FIELD_TYPES_API uint32_t Activ::Date::GetDaysInMonth | ( | const uint32_t | year,
 |  | const uint32_t | month |
 | ) |  |  | [static]

Get the number of days in a month.

Parameters:
year | the year.
month | the month.
Returns:
the number of days in the month.

Referenced by Set().

virtual ACTIV_FIELD_TYPES_API std::string Activ::Date::GetFromStringFormat ( ) const [virtual]

Get a usage string for the format supported by FromString().

Returns:
String, may be empty.

Implements Activ::IFieldType.

size_t Activ::Date::GetMaxSerializedBodyLength ( ) [inline, static]

Get the maximum serialized length of the object's body.

Returns:
the maximum serialized length of the object's body.

Definition at line 932 of file Date.h.

Referenced by Activ::DateTime::GetMaxSerializedBodyLength(), GetMaxSerializedLength(), Activ::DateTime::GetSerializedBodyLength(), GetSerializedBodyLength(), Activ::DateTime::GetSerializedLength(), and IsValidSerializedBodyLength().

size_t Activ::Date::GetMaxSerializedLength ( ) [inline, static]

Get the maximum serialized length of the object.

Returns:
the maximum serialized length of the object.

Definition at line 925 of file Date.h.

References GetMaxSerializedBodyLength().

Referenced by Activ::DateTime::GetMaxSerializedLength(), and Activ::DateTime::GetSerializedLength().

uint32_t Activ::Date::GetMonth ( ) const [inline]

Get the month.

Returns:
the month.
Exceptions:
StatusCodeException

Definition at line 847 of file Date.h.

References ACTIV_THROW, and Activ::IFieldType::IsInitialized().

Referenced by Activ::DateTime::GetMonth().

size_t Activ::Date::GetSerializedBodyLength ( ) const [inline, virtual]

Get the serialized length of the object's body.

Returns:
the serialized length of the object's body.

Implements Activ::IFieldType.

Definition at line 918 of file Date.h.

References GetMaxSerializedBodyLength(), and Activ::IFieldType::IsInitialized().

Referenced by Activ::DateTime::GetSerializedBodyLength(), and GetSerializedLength().

size_t Activ::Date::GetSerializedLength ( ) const [inline, virtual]

Get the serialized length of the object.

Returns:
the serialized length of the object.

Implements Activ::IFieldType.

Definition at line 911 of file Date.h.

References GetSerializedBodyLength().

Referenced by Activ::DateTime::GetSerializedLength().

static ACTIV_FIELD_TYPES_API uint32_t Activ::Date::GetWeekOfYear | ( | const uint32_t | year,
 |  | const uint32_t | month,
 |  | const uint32_t | day |
 | ) |  |  | [static]

Get the week of the year.

Parameters:
year | the year.
month | the month.
day | the day.
Returns:
the week of the year (the week containing January 4th = 1)

uint32_t Activ::Date::GetWeekOfYear ( ) const [inline]

Get the week of the year.

Returns:
the week of the year.
Exceptions:
StatusCodeException

Definition at line 887 of file Date.h.

References ACTIV_THROW, and Activ::IFieldType::IsInitialized().

Referenced by Activ::DateTime::GetWeekOfYear().

uint32_t Activ::Date::GetYear ( ) const [inline]

Get the year.

Returns:
the year.
Exceptions:
StatusCodeException

Definition at line 837 of file Date.h.

References ACTIV_THROW, and Activ::IFieldType::IsInitialized().

Referenced by Activ::DateTime::GetYear().

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::Date::IsDifferent | ( | const void *const | pRhsSerializedBody,
 |  | const size_t | rhsSerializedBodyLength,
 |  | bool & | isDifferent |
 | ) |  |  | const [virtual]

Is different.

Parameters:
pRhsSerializedBody | the buffer containing the rhs serialized version of the object's body in.
rhsSerializedBodyLength | the rhs serialized body length.
isDifferent | indicates whether the two objects are different.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

static ACTIV_FIELD_TYPES_API bool Activ::Date::IsLeapYear ( const uint32_t year ) [static]

Is the year a leap year.

Parameters:
year the year.
Returns:
whether the year is a leap year.

bool Activ::Date::IsValidSerializedBodyLength ( const size_t serializedBodyLength ) [inline, static]

Is valid serialized body length.

Parameters:
serializedBodyLength the serialized body length.
Returns:
whether the serialized body length is valid.

Definition at line 939 of file Date.h.

References GetMaxSerializedBodyLength().

Referenced by Activ::DateTime::IsValidSerializedBodyLength().

static ACTIV_FIELD_TYPES_API std::string Activ::Date::MonthToString ( const uint32_t month ) [static]

Convert the month to a string.

Parameters:
month the month to convert.
Returns:
the month as a string.

bool Activ::Date::operator!= ( const Date & rhs ) const [inline]

Inequality operator.

Parameters:
rhs the object to compare with.
Returns:
the result of the test.
Exceptions:
StatusCodeException

Definition at line 673 of file Date.h.

template<typename T>
const Date Activ::Date::operator+ ( const T & rhs ) const [inline]

Addition operator.

Parameters:
rhs the value to add to this object.
Returns:
an object containing the result of the operation.
Exceptions:
StatusCodeException

Definition at line 714 of file Date.h.

References Date().

template<typename T>
Date & Activ::Date::operator+= ( const T & rhs ) [inline]

Addition assignment operator.

Parameters:
rhs the value to add to this object.
Returns:
a reference to this object.
Exceptions:
StatusCodeException

Definition at line 721 of file Date.h.

References ACTIV_THROW_RESULT_IF, and Add().

template<typename T>
const Date Activ::Date::operator- ( const T & rhs ) const [inline]

Subtraction operator.

Parameters:
rhs the value to subtract from this object.
Returns:
an object containing the result of the operation.
Exceptions:
StatusCodeException

Definition at line 730 of file Date.h.

References Date().

template<typename T>
Date & Activ::Date::operator-= ( const T & rhs ) [inline]

Subtraction assignment operator.

Parameters:
rhs the value to subtract from this object.
Returns:
a reference to this object.
Exceptions:
StatusCodeException

Definition at line 737 of file Date.h.

References ACTIV_THROW_RESULT_IF, and Subtract().

bool Activ::Date::operator< ( const Date & rhs ) const [inline]

Less than operator.

Parameters:
rhs the object to compare with.
Returns:
the result of the test.
Exceptions:
StatusCodeException

Definition at line 680 of file Date.h.

References ACTIV_THROW_RESULT_IF, and Compare().

bool Activ::Date::operator<= ( const Date & rhs ) const [inline]

Less than or equal to operator.

Parameters:
rhs the object to compare with.
Returns:
the result of the test.
Exceptions:
StatusCodeException

Definition at line 690 of file Date.h.

bool Activ::Date::operator== ( const Date & rhs ) const [inline]

Equality operator.

Parameters:
rhs the object to compare with.
Returns:
the result of the test.
Exceptions:
StatusCodeException

Definition at line 663 of file Date.h.

References ACTIV_THROW_RESULT_IF, and Compare().

bool Activ::Date::operator> ( const Date & rhs ) const [inline]

Greater than operator.

Parameters:
rhs the object to compare with.
Returns:
the result of the test.
Exceptions:
StatusCodeException

Definition at line 697 of file Date.h.

References ACTIV_THROW_RESULT_IF, and Compare().

bool Activ::Date::operator>= ( const Date & rhs ) const [inline]

Greater than or equal to operator.

Parameters:
rhs the object to compare with.
Returns:
the result of the test.
Exceptions:
StatusCodeException

Definition at line 707 of file Date.h.

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::Date::Serialize | ( | MessageBuilder & | messageBuilder,
 |  | const size_t | maxSerializedBodyLength |
 | ) |  |  | const [virtual]

Serialize the object into the supplied message builder.

Parameters:
messageBuilder | the message builder to store a serialized version of the object in.
maxSerializedBodyLength | the maximum serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::Date::SerializeBody | ( | void * | pSerializedBody,
 |  | const size_t | maxSerializedBodyLength,
 |  | size_t & | serializedBodyLength |
 | ) |  |  | const [virtual]

Serialize the object's body into the supplied data buffer.

Parameters:
pSerializedBody | the buffer to store a serialized version of the object's body in.
maxSerializedBodyLength | the maximum serialized body length.
serializedBodyLength | the serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::Date::SerializeLengthAndBody | ( | MessageBuilder & | messageBuilder,
 |  | const size_t | maxSerializedBodyLength = MAX_SERIALIZED_BODY_LENGTH_UNDEFINED |
 | ) |  |  | const [virtual]

Serialize the object's length and body into the supplied message builder.

Parameters:
messageBuilder | the message builder to store a serialized version of the object in.
maxSerializedBodyLength | the maximum serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

StatusCode Activ::Date::Set ( const std::tm & tm ) [inline]

Store a new date.

Uses the tm_year, tm_mon and tm_mday fields of the provided tm structure.

Parameters:
tm reference to a tm structure specifying the date.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER

Definition at line 780 of file Date.h.

References Set().

StatusCode Activ::Date::Set ( const int32_t julianDate ) [inline]

Store a new date.

Parameters:
julianDate the julian date.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER

Definition at line 761 of file Date.h.

References ConvertJulianToGregorianDate(), GetDaysInMonth(), Activ::IFieldType::m_isInitialized, and MONTHS_PER_YEAR.

StatusCode Activ::Date::Set | ( | const uint32_t | year,
 |  | const uint32_t | month,
 |  | const uint32_t | day |
 | ) |  |  | [inline]

Store a new date.

Parameters:
year | the year.
month | the month.
day | the day.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER

Definition at line 746 of file Date.h.

References GetDaysInMonth(), Activ::IFieldType::m_isInitialized, and MONTHS_PER_YEAR.

Referenced by Date(), Activ::DateTime::Set(), and Set().

ACTIV_FIELD_TYPES_API StatusCode Activ::Date::Subtract ( const Days & days )

Subtract.

Parameters:
days the number of days to subtract from this object.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED

Referenced by operator-=(), and Activ::DateTime::Subtract().

virtual ACTIV_FIELD_TYPES_API std::string Activ::Date::ToString ( ) const [virtual]

Convert the object to a string.

Returns:
the object as a string.

Implements Activ::IFieldType.

static ACTIV_FIELD_TYPES_API StatusCode Activ::Date::ValidateSerializedLengthAndBody | ( | MessageValidator & | messageValidator,
 |  | size_t & | serializedBodyOffset,
 |  | size_t & | serializedBodyLength |
 | ) |  |  | [static]

Validate the serialized length and body.

Parameters:
messageValidator | the message validator.
serializedBodyOffset | the serialized body offset.
serializedBodyLength | the serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivFieldTypes/Date.h
Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Date::Days

Activ::Date::Days Class Reference

Days class. More...

#include <ActivMiddleware/ActivFieldTypes/Date.h>

List of all members.

Public Member Functions

Days (const int32_t value)
Constructor.

Public Attributes

const int32_t m_value
The value;.

Detailed Description

Days class.

Definition at line 98 of file Date.h.

Constructor & Destructor Documentation

Activ::Date::Days::Days ( const int32_t value ) [inline, explicit]

Constructor.

Parameters:
value the value.

Definition at line 947 of file Date.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivFieldTypes/Date.h
Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::DateTime

Activ::DateTime Class Reference

Date / time class. More...

#include <ActivMiddleware/ActivFieldTypes/DateTime.h>

Inheritance diagram for Activ::DateTime:

Activ::IFieldType

List of all members.

Public Types

typedef Date::Days | Days
The days type definition.
typedef Time::Hours | Hours
The hours type definition.
typedef Time::Milliseconds | Milliseconds
The milliseconds type definition.
typedef Time::Minutes | Minutes
The minutes type definition.
typedef Time::Seconds | Seconds
The seconds type definition.

Public Member Functions

ACTIV_FIELD_TYPES_API StatusCode | Add (const Milliseconds &milliseconds)
Add.
StatusCode | Add (const Seconds &seconds)
Add.
StatusCode | Add (const Minutes &minutes)
Add.
StatusCode | Add (const Hours &hours)
Add.
StatusCode | Add (const Days &days)
Add.
StatusCode | Add (const Time &rhs)
Add.
virtual void | Clear ()
Clear the object.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		Compare (const void *const pRhsSerializedBody, const size_t rhsSerializedBodyLength, int &result) const
Compare.
ACTIV_FIELD_TYPES_API StatusCode | Compare (const DateTime &rhs, int &result) const
Compare.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		Convert (const IFieldType *const pIFieldType)
Convert another IFieldType object to this type.
DateTime (const Date &date, const Time &time)
Constructor.
DateTime (const std::tm &tm, const uint32_t millisecond=0)
Constructor.
DateTime (const int64_t julianDateTime, const uint32_t millisecond=0)
Constructor.
DateTime (const uint32_t year, const uint32_t month, const uint32_t day, const uint32_t hour, const uint32_t minute, const uint32_t second, const uint32_t millisecond=0)
Constructor.
DateTime ()
Default constructor.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		Deserialize (MessageValidator &messageValidator, const size_t maxSerializedBodyLength)
Deserialize the object from the supplied message validator.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		DeserializeBody (const void *const pSerializedBody, const size_t serializedBodyLength)
Deserialize the object's body from the supplied data buffer.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		DeserializeLengthAndBody (MessageValidator &messageValidator, const size_t maxSerializedBodyLength=MAX_SERIALIZED_BODY_LENGTH_UNDEFINED)
Deserialize the object's length and body from the supplied message validator.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		FromString (MessageValidator &messageValidator)
Convert the object from a string.
StatusCode | Get (std::tm &tm, uint32_t &millisecond) const
Get the date / time.
StatusCode | Get (std::tm &tm) const
Get the date / time.
StatusCode | Get (int64_t &julianDateTime, uint32_t &millisecond) const
Get the date / time.
StatusCode | Get (int64_t &julianDateTime) const
Get the date / time.
StatusCode | Get (uint32_t &year, uint32_t &month, uint32_t &day, uint32_t &hour, uint32_t &minute, uint32_t &second, uint32_t &millisecond) const
Get the date / time.
StatusCode | Get (uint32_t &year, uint32_t &month, uint32_t &day, uint32_t &hour, uint32_t &minute, uint32_t &second) const
Get the date / time.
int64_t | Get () const
Get the julian date / time.
const Date & | GetDate () const
Get the date.
uint32_t | GetDay () const
Get the day.
uint32_t | GetDayOfWeek () const
Get the day of the week.
uint32_t | GetDayOfYear () const
Get the day of the year.
virtual ACTIV_FIELD_TYPES_API
std::string 		GetFromStringFormat () const
Get a usage string for the format supported by FromString().
uint32_t | GetHour () const
Get the hour.
DateTime | GetLocal () const
Get the local date / time.
uint32_t | GetMillisecond () const
Get the millisecond.
uint32_t | GetMinute () const
Get the minute.
uint32_t | GetMonth () const
Get the month.
uint32_t | GetSecond () const
Get the second.
virtual size_t | GetSerializedBodyLength () const
Get the serialized length of the object's body.
virtual size_t | GetSerializedLength () const
Get the serialized length of the object.
const Time & | GetTime () const
Get the time.
uint64_t | GetTotalMilliseconds () const
Get the total milliseconds.
DateTime | GetUtc () const
Get the UTC date / time.
uint32_t | GetWeekOfYear () const
Get the week of the year.
uint32_t | GetYear () const
Get the year.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		IsDifferent (const void *const pRhsSerializedBody, const size_t rhsSerializedBodyLength, bool &isDifferent) const
Is different.
operator const Date & () const
Date conversion operator.
operator const Time & () const
Time conversion operator.
bool | operator!= (const DateTime &rhs) const
Inequality operator.
template<typename T>
const DateTime | operator+ (const T &rhs) const
Addition operator.
template<typename T>
DateTime & | operator+= (const T &rhs)
Addition assignment operator.
template<typename T>
const DateTime | operator- (const T &rhs) const
Subtraction operator.
template<typename T>
DateTime & | operator-= (const T &rhs)
Subtraction assignment operator.
bool | operator< (const DateTime &rhs) const
Less than operator.
bool | operator<= (const DateTime &rhs) const
Less than or equal to operator.
bool | operator== (const DateTime &rhs) const
Equality operator.
bool | operator> (const DateTime &rhs) const
Greater than operator.
bool | operator>= (const DateTime &rhs) const
Greater than or equal to operator.
virtual void | Reset ()
Reset the object.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		Serialize (MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength) const
Serialize the object into the supplied message builder.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		SerializeBody (void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength) const
Serialize the object's body into the supplied data buffer.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		SerializeLengthAndBody (MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength=MAX_SERIALIZED_BODY_LENGTH_UNDEFINED) const
Serialize the object's length and body into the supplied message builder.
StatusCode | Set (const Date &date, const Time &time)
Store a new date / time.
StatusCode | Set (const std::tm &tm, const uint32_t millisecond=0)
Store a new date / time.
StatusCode | Set (const int64_t julianDateTime, const uint32_t millisecond=0)
Store a new date / time.
StatusCode | Set (const uint32_t year, const uint32_t month, const uint32_t day, const uint32_t hour, const uint32_t minute, const uint32_t second, const uint32_t millisecond=0)
Store a new date / time.
ACTIV_FIELD_TYPES_API StatusCode | Subtract (const Milliseconds &milliseconds)
Subtract.
StatusCode | Subtract (const Seconds &seconds)
Subtract.
StatusCode | Subtract (const Minutes &minutes)
Subtract.
StatusCode | Subtract (const Hours &hours)
Subtract.
StatusCode | Subtract (const Days &days)
Subtract.
StatusCode | Subtract (const Time &rhs)
Subtract.
ACTIV_FIELD_TYPES_API std::string | ToString (const bool shouldDisplayMilliseconds) const
Convert the object to a string.
virtual ACTIV_FIELD_TYPES_API
std::string 		ToString () const
Convert the object to a string.
virtual | ~DateTime ()
Destructor.

Static Public Member Functions

static ACTIV_FIELD_TYPES_API
StatusCode 		Compare (const void *const pLhsSerializedBody, const size_t lhsSerializedBodyLength, const void *const pRhsSerializedBody, const size_t rhsSerializedBodyLength, int &result)
Compare two objects serialized bodies.
static int64_t | ConvertGregorianToJulianDateTime (const int32_t year, const int32_t month, const int32_t day, const int32_t hour, const int32_t minute, const int32_t second)
Convert gregorian to julian date / time.
static void | ConvertJulianToGregorianDateTime (const int64_t julianDateTime, int32_t &year, int32_t &month, int32_t &day, int32_t &hour, int32_t &minute, int32_t &second)
Convert julian to gregorian date / time.
static ACTIV_FIELD_TYPES_API
DateTime 		CreateLocalDateTime (const bool shouldSetMilliseconds=false)
Create an object intitialised with the current local date / time.
static ACTIV_FIELD_TYPES_API
DateTime 		CreateUtcDateTime (const bool shouldSetMilliseconds=false)
Create an object intitialised with the current UTC date / time.
static int32_t | GetJulianDate (const int64_t julianDateTime)
Get the julian date.
static int32_t | GetJulianTime (const int64_t julianDateTime)
Get the julian time.
static size_t | GetMaxSerializedBodyLength (const bool shouldSerializeMilliseconds)
Get the maximum serialized length of the object's body.
static size_t | GetMaxSerializedLength (const bool shouldSerializeMilliseconds)
Get the maximum serialized length of the object.
static size_t | GetSerializedBodyLength (const void *const pSerializedBody)
Get the maximum serialized length of the object's body.
static size_t | GetSerializedLength (const void *const pSerializedBody)
Get the maximum serialized length of the object.
static ACTIV_FIELD_TYPES_API
int32_t 		GetTimeZoneOffset ()
Get the time zone offset (from local to UTC).
static bool | IsValidSerializedBodyLength (const size_t serializedBodyLength)
Is valid serialized body length.
static ACTIV_FIELD_TYPES_API
StatusCode 		ValidateSerializedLengthAndBody (MessageValidator &messageValidator, size_t &serializedBodyOffset, size_t &serializedBodyLength)
Validate the serialized length and body.

Static Public Attributes

static const FieldType | FIELD_TYPE = FIELD_TYPE_DATE_TIME
The field type.

Detailed Description

Date / time class.

Definition at line 30 of file DateTime.h.

Constructor & Destructor Documentation

Activ::DateTime::DateTime | ( | const uint32_t | year,
 |  | const uint32_t | month,
 |  | const uint32_t | day,
 |  | const uint32_t | hour,
 |  | const uint32_t | minute,
 |  | const uint32_t | second,
 |  | const uint32_t | millisecond = 0 |
 | ) |  |  | [inline]

Constructor.

Parameters:
year | the year.
month | the month.
day | the day.
hour | the hour.
minute | the minute.
second | the second.
millisecond | the millisecond.
Exceptions:
StatusCodeException

Definition at line 841 of file DateTime.h.

References Activ::IFieldType::m_isInitialized.

Activ::DateTime::DateTime | ( | const int64_t | julianDateTime,
 |  | const uint32_t | millisecond = 0 |
 | ) |  |  | [inline, explicit]

Constructor.

Parameters:
julianDateTime | the julian date / time.
millisecond | the millisecond.
Exceptions:
StatusCodeException

Definition at line 851 of file DateTime.h.

References Activ::IFieldType::m_isInitialized.

Activ::DateTime::DateTime | ( | const std::tm & | tm,
 |  | const uint32_t | millisecond = 0 |
 | ) |  |  | [inline]

Constructor.

Uses the tm_year, tm_mon, tm_mday, tm_hour, tm_min and tm_sec fields of the provided tm structure.

Parameters:
tm | reference to a tm structure specifying the time.
millisecond | the millisecond.
Exceptions:
StatusCodeException

Definition at line 861 of file DateTime.h.

References Activ::IFieldType::m_isInitialized.

Activ::DateTime::DateTime | ( | const Date & | date,
 |  | const Time & | time |
 | ) |  |  | [inline]

Constructor.

Parameters:
date | the date.
time | the time.
Exceptions:
StatusCodeException

Definition at line 871 of file DateTime.h.

References ACTIV_THROW, Activ::IFieldType::IsInitialized(), and Activ::IFieldType::m_isInitialized.

Member Function Documentation

ACTIV_FIELD_TYPES_API StatusCode Activ::DateTime::Add ( const Milliseconds & milliseconds )

Add.

Parameters:
milliseconds the number of milliseconds to add to this object.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED

StatusCode Activ::DateTime::Add ( const Seconds & seconds ) [inline]

Add.

Parameters:
seconds the number of seconds to add to this object.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED

Definition at line 1257 of file DateTime.h.

References Add(), Activ::Time::Seconds::m_value, and Activ::Time::Milliseconds::NUMBER_PER_SECOND.

StatusCode Activ::DateTime::Add ( const Minutes & minutes ) [inline]

Add.

Parameters:
minutes the number of minutes to add to this object.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED

Definition at line 1250 of file DateTime.h.

References Add(), Activ::Time::Minutes::m_value, and Activ::Time::Milliseconds::NUMBER_PER_MINUTE.

StatusCode Activ::DateTime::Add ( const Hours & hours ) [inline]

Add.

Parameters:
hours the number of hours to add to this object.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED

Definition at line 1243 of file DateTime.h.

References Add(), Activ::Time::Hours::m_value, and Activ::Time::Milliseconds::NUMBER_PER_HOUR.

StatusCode Activ::DateTime::Add ( const Days & days ) [inline]

Add.

Parameters:
days the number of days to add to this object.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED

Definition at line 1236 of file DateTime.h.

References Activ::Date::Add(), and Activ::Date::Days::m_value.

StatusCode Activ::DateTime::Add ( const Time & rhs ) [inline]

Add.

Parameters:
rhs the value to add to this object.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED

Definition at line 1226 of file DateTime.h.

References Activ::Time::GetTotalMilliseconds(), and Activ::IFieldType::IsInitialized().

Referenced by Add(), and operator+=().

static ACTIV_FIELD_TYPES_API StatusCode Activ::DateTime::Compare | ( | const void *const | pLhsSerializedBody,
 |  | const size_t | lhsSerializedBodyLength,
 |  | const void *const | pRhsSerializedBody,
 |  | const size_t | rhsSerializedBodyLength,
 |  | int & | result |
 | ) |  |  | [static]

Compare two objects serialized bodies.

Parameters:
pLhsSerializedBody | the buffer containing the lhs serialized version of the object's body in.
lhsSerializedBodyLength | the lhs serialized body length.
pRhsSerializedBody | the buffer containing the rhs serialized version of the object's body in.
rhsSerializedBodyLength | the rhs serialized body length.
result | the result of the comparison.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::DateTime::Compare | ( | const void *const | pRhsSerializedBody,
 |  | const size_t | rhsSerializedBodyLength,
 |  | int & | result |
 | ) |  |  | const [virtual]

Compare.

Parameters:
pRhsSerializedBody | the buffer containing the rhs serialized version of the object's body in.
rhsSerializedBodyLength | the rhs serialized body length.
result | the result of the comparison.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

ACTIV_FIELD_TYPES_API StatusCode Activ::DateTime::Compare | ( | const DateTime & | rhs,
 |  | int & | result |
 | ) |  |  | const

Compare.

Parameters:
rhs | the object to compare with.
result | the result of the comparison.
Return values:
STATUS_CODE_SUCCESS

Referenced by Activ::ContentPlatform::ContentGatewayApi::Tick::Compare(), Activ::ContentPlatform::ContentGatewayApi::IntradayBar::Compare(), operator<(), operator==(), and operator>().

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::DateTime::Convert ( const IFieldType *const pIFieldType ) [virtual]

Convert another IFieldType object to this type.

Parameters:
pIFieldType the value to assign from.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_MISMATCH
...

Implements Activ::IFieldType.

int64_t Activ::DateTime::ConvertGregorianToJulianDateTime | ( | const int32_t | year,
 |  | const int32_t | month,
 |  | const int32_t | day,
 |  | const int32_t | hour,
 |  | const int32_t | minute,
 |  | const int32_t | second |
 | ) |  |  | [inline, static]

Convert gregorian to julian date / time.

Parameters:
year | the year.
month | the month.
day | the day.
hour | the hour.
minute | the minute.
second | the second.
Returns:
the julian date / time.

Definition at line 1370 of file DateTime.h.

References Activ::Date::ConvertGregorianToJulianDate(), Activ::Time::ConvertGregorianToJulianTime(), and Activ::Time::Seconds::NUMBER_PER_DAY.

Referenced by Get(), and GetTotalMilliseconds().

void Activ::DateTime::ConvertJulianToGregorianDateTime | ( | const int64_t | julianDateTime,
 |  | int32_t & | year,
 |  | int32_t & | month,
 |  | int32_t & | day,
 |  | int32_t & | hour,
 |  | int32_t & | minute,
 |  | int32_t & | second |
 | ) |  |  | [inline, static]

Convert julian to gregorian date / time.

Parameters:
julianDateTime | the julian date / time.
year | the year.
month | the month.
day | the day.
hour | the hour.
minute | the minute.
second | the second.

Definition at line 1362 of file DateTime.h.

References Activ::Date::ConvertJulianToGregorianDate(), Activ::Time::ConvertJulianToGregorianTime(), GetJulianDate(), and GetJulianTime().

static ACTIV_FIELD_TYPES_API DateTime Activ::DateTime::CreateLocalDateTime ( const bool shouldSetMilliseconds = false ) [static]

Create an object intitialised with the current local date / time.

Parameters:
shouldSetMilliseconds indicates whether milliseconds should be set.
Returns:
the initialized object.

static ACTIV_FIELD_TYPES_API DateTime Activ::DateTime::CreateUtcDateTime ( const bool shouldSetMilliseconds = false ) [static]

Create an object intitialised with the current UTC date / time.

Parameters:
shouldSetMilliseconds indicates whether milliseconds should be set.
Returns:
the initialized object.

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::DateTime::Deserialize | ( | MessageValidator & | messageValidator,
 |  | const size_t | maxSerializedBodyLength |
 | ) |  |  | [virtual]

Deserialize the object from the supplied message validator.

Parameters:
messageValidator | the message validator from which the object will be extracted.
maxSerializedBodyLength | the maximum serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::DateTime::DeserializeBody | ( | const void *const | pSerializedBody,
 |  | const size_t | serializedBodyLength |
 | ) |  |  | [virtual]

Deserialize the object's body from the supplied data buffer.

Parameters:
pSerializedBody | the buffer from which the object's body will be extracted.
serializedBodyLength | the serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::DateTime::DeserializeLengthAndBody | ( | MessageValidator & | messageValidator,
 |  | const size_t | maxSerializedBodyLength = MAX_SERIALIZED_BODY_LENGTH_UNDEFINED |
 | ) |  |  | [virtual]

Deserialize the object's length and body from the supplied message validator.

Parameters:
messageValidator | the message validator from which the object will be extracted.
maxSerializedBodyLength | the maximum serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::DateTime::FromString ( MessageValidator & messageValidator ) [virtual]

Convert the object from a string.

Parameters:
messageValidator the message validator.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

StatusCode Activ::DateTime::Get | ( | std::tm & | tm,
 |  | uint32_t & | millisecond |
 | ) |  |  | const [inline]

Get the date / time.

Only sets the tm_year, tm_mon, tm_mday, tm_hour, tm_min and tm_sec fields of the provided tm structure.

Parameters:
tm | reference to a tm structure to receive the date / time.
millisecond | the millisecond.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED

Definition at line 1101 of file DateTime.h.

References ACTIV_RETURN_RESULT_IF, Get(), and Activ::Time::m_millisecond.

StatusCode Activ::DateTime::Get ( std::tm & tm ) const [inline]

Get the date / time.

Only sets the tm_year, tm_mon, tm_mday, tm_hour, tm_min and tm_sec fields of the provided tm structure.

Parameters:
tm reference to a tm structure to receive the date / time.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED

Definition at line 1091 of file DateTime.h.

References ACTIV_RETURN_RESULT_IF, Activ::Time::Get(), and Activ::Date::Get().

StatusCode Activ::DateTime::Get | ( | int64_t & | julianDateTime,
 |  | uint32_t & | millisecond |
 | ) |  |  | const [inline]

Get the date / time.

Parameters:
julianDateTime | the julian date / time.
millisecond | the millisecond.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED

Definition at line 1080 of file DateTime.h.

References ACTIV_RETURN_RESULT_IF, Get(), and Activ::Time::m_millisecond.

StatusCode Activ::DateTime::Get ( int64_t & julianDateTime ) const [inline]

Get the date / time.

Parameters:
julianDateTime the julian date / time.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED

Definition at line 1068 of file DateTime.h.

References ConvertGregorianToJulianDateTime(), Activ::IFieldType::IsInitialized(), Activ::Date::m_day, Activ::Time::m_hour, Activ::Time::m_minute, Activ::Date::m_month, Activ::Time::m_second, and Activ::Date::m_year.

StatusCode Activ::DateTime::Get | ( | uint32_t & | year,
 |  | uint32_t & | month,
 |  | uint32_t & | day,
 |  | uint32_t & | hour,
 |  | uint32_t & | minute,
 |  | uint32_t & | second,
 |  | uint32_t & | millisecond |
 | ) |  |  | const [inline]

Get the date / time.

Parameters:
year | the year.
month | the month.
day | the day.
hour | the hour.
minute | the minute.
second | the second.
millisecond | the millisecond.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED

Definition at line 1057 of file DateTime.h.

References ACTIV_RETURN_RESULT_IF, Get(), and Activ::Time::m_millisecond.

StatusCode Activ::DateTime::Get | ( | uint32_t & | year,
 |  | uint32_t & | month,
 |  | uint32_t & | day,
 |  | uint32_t & | hour,
 |  | uint32_t & | minute,
 |  | uint32_t & | second |
 | ) |  |  | const [inline]

Get the date / time.

Parameters:
year | the year.
month | the month.
day | the day.
hour | the hour.
minute | the minute.
second | the second.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED

Definition at line 1047 of file DateTime.h.

References ACTIV_RETURN_RESULT_IF, Activ::Time::Get(), and Activ::Date::Get().

int64_t Activ::DateTime::Get ( ) const [inline]

Get the julian date / time.

Return values:
the julian date / time.
Exceptions:
StatusCodeException

Definition at line 1037 of file DateTime.h.

References ACTIV_THROW, ConvertGregorianToJulianDateTime(), Activ::IFieldType::IsInitialized(), Activ::Date::m_day, Activ::Time::m_hour, Activ::Time::m_minute, Activ::Date::m_month, Activ::Time::m_second, and Activ::Date::m_year.

Referenced by Get().

const Date & Activ::DateTime::GetDate ( ) const [inline]

Get the date.

Returns:
the date.
Exceptions:
StatusCodeException

Definition at line 1112 of file DateTime.h.

Referenced by Activ::ContentPlatform::ContentGatewayApi::Tick::Compare(), Activ::ContentPlatform::ContentGatewayApi::HistoryBar::operator<(), Activ::ContentPlatform::ContentGatewayApi::HistoryBar::operator==(), Activ::ContentPlatform::ContentGatewayApi::HistoryBar::operator>(), Activ::ContentPlatform::ContentGatewayApi::Tick::SetTime(), and Activ::ContentPlatform::ContentGatewayApi::IntradayBar::SetTime().

uint32_t Activ::DateTime::GetDay ( ) const [inline]

Get the day.

Returns:
the day.
Exceptions:
StatusCodeException

Definition at line 1140 of file DateTime.h.

References Activ::Date::GetDay().

uint32_t Activ::DateTime::GetDayOfWeek ( ) const [inline]

Get the day of the week.

Returns:
the day of the week.
Exceptions:
StatusCodeException

Definition at line 1147 of file DateTime.h.

References Activ::Date::GetDayOfWeek().

uint32_t Activ::DateTime::GetDayOfYear ( ) const [inline]

Get the day of the year.

Returns:
the day of the year.
Exceptions:
StatusCodeException

Definition at line 1154 of file DateTime.h.

References Activ::Date::GetDayOfYear().

virtual ACTIV_FIELD_TYPES_API std::string Activ::DateTime::GetFromStringFormat ( ) const [virtual]

Get a usage string for the format supported by FromString().

Returns:
String, may be empty.

Implements Activ::IFieldType.

uint32_t Activ::DateTime::GetHour ( ) const [inline]

Get the hour.

Returns:
the hour.
Exceptions:
StatusCodeException

Definition at line 1168 of file DateTime.h.

References Activ::Time::GetHour().

int32_t Activ::DateTime::GetJulianDate ( const int64_t julianDateTime ) [inline, static]

Get the julian date.

Parameters:
julianDateTime the julian date / time.
Returns:
the julian date.

Definition at line 1377 of file DateTime.h.

References Activ::Time::Seconds::NUMBER_PER_DAY.

Referenced by ConvertJulianToGregorianDateTime(), and Set().

int32_t Activ::DateTime::GetJulianTime ( const int64_t julianDateTime ) [inline, static]

Get the julian time.

Parameters:
julianDateTime the julian date / time.
Returns:
the julian time.

Definition at line 1384 of file DateTime.h.

References Activ::Time::Seconds::NUMBER_PER_DAY.

Referenced by ConvertJulianToGregorianDateTime(), and Set().

DateTime Activ::DateTime::GetLocal ( ) const [inline]

Get the local date / time.

Assumes the date / time is stored as UTC timezone.

Returns:
the local date / time.
Exceptions:
StatusCodeException

Definition at line 1216 of file DateTime.h.

References ACTIV_THROW, GetTimeZoneOffset(), and Activ::IFieldType::IsInitialized().

size_t Activ::DateTime::GetMaxSerializedBodyLength ( const bool shouldSerializeMilliseconds ) [inline, static]

Get the maximum serialized length of the object's body.

Parameters:
shouldSerializeMilliseconds indicates whether milliseconds should be serialized.
Returns:
the maximum serialized length of the object's body.

Definition at line 1355 of file DateTime.h.

References Activ::Time::GetMaxSerializedBodyLength(), and Activ::Date::GetMaxSerializedBodyLength().

size_t Activ::DateTime::GetMaxSerializedLength ( const bool shouldSerializeMilliseconds ) [inline, static]

Get the maximum serialized length of the object.

Parameters:
shouldSerializeMilliseconds indicates whether milliseconds should be serialized.
Returns:
the maximum serialized length of the object.

Definition at line 1348 of file DateTime.h.

References Activ::Time::GetMaxSerializedLength(), and Activ::Date::GetMaxSerializedLength().

uint32_t Activ::DateTime::GetMillisecond ( ) const [inline]

Get the millisecond.

Returns:
the millisecond.
Exceptions:
StatusCodeException

Definition at line 1189 of file DateTime.h.

References Activ::Time::GetMillisecond().

uint32_t Activ::DateTime::GetMinute ( ) const [inline]

Get the minute.

Returns:
the minute.
Exceptions:
StatusCodeException

Definition at line 1175 of file DateTime.h.

References Activ::Time::GetMinute().

uint32_t Activ::DateTime::GetMonth ( ) const [inline]

Get the month.

Returns:
the month.
Exceptions:
StatusCodeException

Definition at line 1133 of file DateTime.h.

References Activ::Date::GetMonth().

uint32_t Activ::DateTime::GetSecond ( ) const [inline]

Get the second.

Returns:
the second.
Exceptions:
StatusCodeException

Definition at line 1182 of file DateTime.h.

References Activ::Time::GetSecond().

size_t Activ::DateTime::GetSerializedBodyLength ( const void *const pSerializedBody ) [inline, static]

Get the maximum serialized length of the object's body.

Parameters:
pSerializedBody a pointer to the serialized body.
Returns:
the maximum serialized length of the object's body.

Definition at line 1341 of file DateTime.h.

References Activ::Date::GetMaxSerializedBodyLength(), and Activ::Time::GetSerializedBodyLength().

size_t Activ::DateTime::GetSerializedBodyLength ( ) const [inline, virtual]

Get the serialized length of the object's body.

Returns:
the serialized length of the object's body.

Implements Activ::IFieldType.

Definition at line 1327 of file DateTime.h.

References Activ::Time::GetSerializedBodyLength(), and Activ::Date::GetSerializedBodyLength().

size_t Activ::DateTime::GetSerializedLength ( const void *const pSerializedBody ) [inline, static]

Get the maximum serialized length of the object.

Parameters:
pSerializedBody a pointer to the serialized body.
Returns:
the maximum serialized length of the object.

Definition at line 1334 of file DateTime.h.

References Activ::Date::GetMaxSerializedBodyLength(), Activ::Date::GetMaxSerializedLength(), and Activ::Time::GetSerializedLength().

size_t Activ::DateTime::GetSerializedLength ( ) const [inline, virtual]

Get the serialized length of the object.

Returns:
the serialized length of the object.

Implements Activ::IFieldType.

Definition at line 1320 of file DateTime.h.

References Activ::Time::GetSerializedLength(), and Activ::Date::GetSerializedLength().

const Time & Activ::DateTime::GetTime ( ) const [inline]

Get the time.

Returns:
the time.
Exceptions:
StatusCodeException

Definition at line 1119 of file DateTime.h.

Referenced by Activ::ContentPlatform::ContentGatewayApi::Tick::Compare(), Activ::ContentPlatform::ContentGatewayApi::Tick::SetDate(), and Activ::ContentPlatform::ContentGatewayApi::IntradayBar::SetDate().

static ACTIV_FIELD_TYPES_API int32_t Activ::DateTime::GetTimeZoneOffset ( ) [static]

Get the time zone offset (from local to UTC).

Returns the offset from local to UTC. For example, New York's time zone offset would be +5 hours.

Returns:
the time zone offset.

Referenced by GetLocal(), and GetUtc().

uint64_t Activ::DateTime::GetTotalMilliseconds ( ) const [inline]

Get the total milliseconds.

Returns:
the total milliseconds.
Exceptions:
StatusCodeException

Definition at line 1196 of file DateTime.h.

References ACTIV_THROW, ConvertGregorianToJulianDateTime(), Activ::IFieldType::IsInitialized(), Activ::Date::m_day, Activ::Time::m_hour, Activ::Time::m_millisecond, Activ::Time::m_minute, Activ::Date::m_month, Activ::Time::m_second, Activ::Date::m_year, and Activ::Time::Milliseconds::NUMBER_PER_SECOND.

DateTime Activ::DateTime::GetUtc ( ) const [inline]

Get the UTC date / time.

Assumes the date / time is stored as local timezone.

Returns:
the UTC date / time.
Exceptions:
StatusCodeException

Definition at line 1206 of file DateTime.h.

References ACTIV_THROW, GetTimeZoneOffset(), and Activ::IFieldType::IsInitialized().

uint32_t Activ::DateTime::GetWeekOfYear ( ) const [inline]

Get the week of the year.

Returns:
the week of the year.
Exceptions:
StatusCodeException

Definition at line 1161 of file DateTime.h.

References Activ::Date::GetWeekOfYear().

uint32_t Activ::DateTime::GetYear ( ) const [inline]

Get the year.

Returns:
the year.
Exceptions:
StatusCodeException

Definition at line 1126 of file DateTime.h.

References Activ::Date::GetYear().

Referenced by Activ::ContentPlatform::ContentGatewayApi::IntradayBar::HasTick().

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::DateTime::IsDifferent | ( | const void *const | pRhsSerializedBody,
 |  | const size_t | rhsSerializedBodyLength,
 |  | bool & | isDifferent |
 | ) |  |  | const [virtual]

Is different.

Parameters:
pRhsSerializedBody | the buffer containing the rhs serialized version of the object's body in.
rhsSerializedBodyLength | the rhs serialized body length.
isDifferent | indicates whether the two objects are different.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

bool Activ::DateTime::IsValidSerializedBodyLength ( const size_t serializedBodyLength ) [inline, static]

Is valid serialized body length.

Parameters:
serializedBodyLength the serialized body length.
Returns:
whether the serialized body length is valid.

Definition at line 1391 of file DateTime.h.

References ACTIV_RETURN_FALSE_IF, Activ::Time::IsValidSerializedBodyLength(), and Activ::Date::IsValidSerializedBodyLength().

bool Activ::DateTime::operator!= ( const DateTime & rhs ) const [inline]

Inequality operator.

Parameters:
rhs the object to compare with.
Returns:
the result of the test.
Exceptions:
StatusCodeException

Definition at line 914 of file DateTime.h.

template<typename T>
const DateTime Activ::DateTime::operator+ ( const T & rhs ) const [inline]

Addition operator.

Parameters:
rhs the value to add to this object.
Returns:
an object containing the result of the operation.
Exceptions:
StatusCodeException

Definition at line 955 of file DateTime.h.

References DateTime().

template<typename T>
DateTime & Activ::DateTime::operator+= ( const T & rhs ) [inline]

Addition assignment operator.

Parameters:
rhs the value to add to this object.
Returns:
a reference to this object.
Exceptions:
StatusCodeException

Definition at line 962 of file DateTime.h.

References ACTIV_THROW_RESULT_IF, and Add().

template<typename T>
const DateTime Activ::DateTime::operator- ( const T & rhs ) const [inline]

Subtraction operator.

Parameters:
rhs the value to subtract from this object.
Returns:
an object containing the result of the operation.
Exceptions:
StatusCodeException

Definition at line 971 of file DateTime.h.

References DateTime().

template<typename T>
DateTime & Activ::DateTime::operator-= ( const T & rhs ) [inline]

Subtraction assignment operator.

Parameters:
rhs the value to subtract from this object.
Returns:
a reference to this object.
Exceptions:
StatusCodeException

Definition at line 978 of file DateTime.h.

References ACTIV_THROW_RESULT_IF, and Subtract().

bool Activ::DateTime::operator< ( const DateTime & rhs ) const [inline]

Less than operator.

Parameters:
rhs the object to compare with.
Returns:
the result of the test.
Exceptions:
StatusCodeException

Definition at line 921 of file DateTime.h.

References ACTIV_THROW_RESULT_IF, and Compare().

bool Activ::DateTime::operator<= ( const DateTime & rhs ) const [inline]

Less than or equal to operator.

Parameters:
rhs the object to compare with.
Returns:
the result of the test.
Exceptions:
StatusCodeException

Definition at line 931 of file DateTime.h.

bool Activ::DateTime::operator== ( const DateTime & rhs ) const [inline]

Equality operator.

Parameters:
rhs the object to compare with.
Returns:
the result of the test.
Exceptions:
StatusCodeException

Definition at line 904 of file DateTime.h.

References ACTIV_THROW_RESULT_IF, and Compare().

bool Activ::DateTime::operator> ( const DateTime & rhs ) const [inline]

Greater than operator.

Parameters:
rhs the object to compare with.
Returns:
the result of the test.
Exceptions:
StatusCodeException

Definition at line 938 of file DateTime.h.

References ACTIV_THROW_RESULT_IF, and Compare().

bool Activ::DateTime::operator>= ( const DateTime & rhs ) const [inline]

Greater than or equal to operator.

Parameters:
rhs the object to compare with.
Returns:
the result of the test.
Exceptions:
StatusCodeException

Definition at line 948 of file DateTime.h.

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::DateTime::Serialize | ( | MessageBuilder & | messageBuilder,
 |  | const size_t | maxSerializedBodyLength |
 | ) |  |  | const [virtual]

Serialize the object into the supplied message builder.

Parameters:
messageBuilder | the message builder to store a serialized version of the object in.
maxSerializedBodyLength | the maximum serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::DateTime::SerializeBody | ( | void * | pSerializedBody,
 |  | const size_t | maxSerializedBodyLength,
 |  | size_t & | serializedBodyLength |
 | ) |  |  | const [virtual]

Serialize the object's body into the supplied data buffer.

Parameters:
pSerializedBody | the buffer to store a serialized version of the object's body in.
maxSerializedBodyLength | the maximum serialized body length.
serializedBodyLength | the serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::DateTime::SerializeLengthAndBody | ( | MessageBuilder & | messageBuilder,
 |  | const size_t | maxSerializedBodyLength = MAX_SERIALIZED_BODY_LENGTH_UNDEFINED |
 | ) |  |  | const [virtual]

Serialize the object's length and body into the supplied message builder.

Parameters:
messageBuilder | the message builder to store a serialized version of the object in.
maxSerializedBodyLength | the maximum serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

StatusCode Activ::DateTime::Set | ( | const Date & | date,
 |  | const Time & | time |
 | ) |  |  | [inline]

Store a new date / time.

Parameters:
date | the date.
time | the time.
Return values:
STATUS_CODE_SUCCESS

Definition at line 1026 of file DateTime.h.

References Activ::IFieldType::m_isInitialized.

StatusCode Activ::DateTime::Set | ( | const std::tm & | tm,
 |  | const uint32_t | millisecond = 0 |
 | ) |  |  | [inline]

Store a new date / time.

Uses the tm_year, tm_mon, tm_mday, tm_hour, tm_min and tm_sec fields of the provided tm structure.

Parameters:
tm | reference to a tm structure specifying the date and time.
millisecond | the millisecond.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER

Definition at line 1013 of file DateTime.h.

References ACTIV_RETURN_RESULT_IF, Set(), and Activ::Date::Set().

StatusCode Activ::DateTime::Set | ( | const int64_t | julianDateTime,
 |  | const uint32_t | millisecond = 0 |
 | ) |  |  | [inline]

Store a new date / time.

Parameters:
julianDateTime | the julian date / time.
millisecond | the millisecond.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER

Definition at line 1000 of file DateTime.h.

References ACTIV_RETURN_RESULT_IF, GetJulianDate(), GetJulianTime(), Set(), and Activ::Date::Set().

StatusCode Activ::DateTime::Set | ( | const uint32_t | year,
 |  | const uint32_t | month,
 |  | const uint32_t | day,
 |  | const uint32_t | hour,
 |  | const uint32_t | minute,
 |  | const uint32_t | second,
 |  | const uint32_t | millisecond = 0 |
 | ) |  |  | [inline]

Store a new date / time.

Parameters:
year | the year.
month | the month.
day | the day.
hour | the hour.
minute | the minute.
second | the second.
millisecond | the millisecond.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER

Definition at line 987 of file DateTime.h.

References ACTIV_RETURN_RESULT_IF, and Activ::Date::Set().

Referenced by Activ::ContentPlatform::ContentGatewayApi::HistoryBar::GetDateTime(), Set(), Activ::ContentPlatform::ContentGatewayApi::Tick::SetDate(), Activ::ContentPlatform::ContentGatewayApi::IntradayBar::SetDate(), Activ::ContentPlatform::ContentGatewayApi::Tick::SetDateTime(), Activ::ContentPlatform::ContentGatewayApi::Tick::SetTime(), and Activ::ContentPlatform::ContentGatewayApi::IntradayBar::SetTime().

ACTIV_FIELD_TYPES_API StatusCode Activ::DateTime::Subtract ( const Milliseconds & milliseconds )

Subtract.

Parameters:
milliseconds the number of milliseconds to subtract from this object.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED

StatusCode Activ::DateTime::Subtract ( const Seconds & seconds ) [inline]

Subtract.

Parameters:
seconds the number of seconds to subtract from this object.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED

Definition at line 1295 of file DateTime.h.

References Activ::Time::Seconds::m_value, Activ::Time::Milliseconds::NUMBER_PER_SECOND, and Subtract().

StatusCode Activ::DateTime::Subtract ( const Minutes & minutes ) [inline]

Subtract.

Parameters:
minutes the number of minutes to subtract from this object.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED

Definition at line 1288 of file DateTime.h.

References Activ::Time::Minutes::m_value, Activ::Time::Milliseconds::NUMBER_PER_MINUTE, and Subtract().

StatusCode Activ::DateTime::Subtract ( const Hours & hours ) [inline]

Subtract.

Parameters:
hours the number of hours to subtract from this object.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED

Definition at line 1281 of file DateTime.h.

References Activ::Time::Hours::m_value, Activ::Time::Milliseconds::NUMBER_PER_HOUR, and Subtract().

StatusCode Activ::DateTime::Subtract ( const Days & days ) [inline]

Subtract.

Parameters:
days the number of days to subtract from this object.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED

Definition at line 1274 of file DateTime.h.

References Activ::Date::Days::m_value, and Activ::Date::Subtract().

StatusCode Activ::DateTime::Subtract ( const Time & rhs ) [inline]

Subtract.

Parameters:
rhs the value to subtract from this object.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED

Definition at line 1264 of file DateTime.h.

References Activ::Time::GetTotalMilliseconds(), and Activ::IFieldType::IsInitialized().

Referenced by operator-=(), and Subtract().

ACTIV_FIELD_TYPES_API std::string Activ::DateTime::ToString ( const bool shouldDisplayMilliseconds ) const

Convert the object to a string.

Parameters:
shouldDisplayMilliseconds indicates whether the milliseconds should be displayed.
Returns:
the object as a string.

virtual ACTIV_FIELD_TYPES_API std::string Activ::DateTime::ToString ( ) const [virtual]

Convert the object to a string.

Returns:
the object as a string.

Implements Activ::IFieldType.

static ACTIV_FIELD_TYPES_API StatusCode Activ::DateTime::ValidateSerializedLengthAndBody | ( | MessageValidator & | messageValidator,
 |  | size_t & | serializedBodyOffset,
 |  | size_t & | serializedBodyLength |
 | ) |  |  | [static]

Validate the serialized length and body.

Parameters:
messageValidator | the message validator.
serializedBodyOffset | the serialized body offset.
serializedBodyLength | the serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivFieldTypes/DateTime.h
Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::DeferredScopedMutexLocker

Activ::DeferredScopedMutexLocker Class Reference

Deferred acquire mutex helper class. More...

#include <ActivMiddleware/ActivBase/MutexHelper.h>

List of all members.

Public Member Functions

ACTIV_BASE_INLINE_API void | Acquire ()
Acquire the mutex.
ACTIV_BASE_INLINE_API | DeferredScopedMutexLocker (const IMutex *const pMutex)
Constructor.
ACTIV_BASE_INLINE_API | operator bool () const
Is the mutex locked?
ACTIV_BASE_INLINE_API bool | operator! () const
Is the mutex NOT locked?
ACTIV_BASE_INLINE_API bool | Try ()
Attempt to acquire the mutex.
ACTIV_BASE_INLINE_API | ~DeferredScopedMutexLocker ()
Destructor releases the mutex lock, if the lock was acquired.

Detailed Description

Deferred acquire mutex helper class.

This version does not attempt to acquire the mutex in the constructor, it is left to a later method call.

Definition at line 170 of file MutexHelper.h.

Constructor & Destructor Documentation

Activ::DeferredScopedMutexLocker::DeferredScopedMutexLocker ( const IMutex *const pMutex ) [inline]

Constructor.

Parameters:
pMutex pointer to the mutex to be locked. It can be null. If a null mutex is provided, Try() and operator bool() will return true.

Definition at line 225 of file MutexHelper.h.

Member Function Documentation

Activ::DeferredScopedMutexLocker::operator bool ( ) const [inline]

Is the mutex locked?

Returns:
boolean.

Definition at line 274 of file MutexHelper.h.

bool Activ::DeferredScopedMutexLocker::operator! ( ) const [inline]

Is the mutex NOT locked?

Returns:
boolean.

Definition at line 281 of file MutexHelper.h.

bool Activ::DeferredScopedMutexLocker::Try ( ) [inline]

Attempt to acquire the mutex.

Returns:
True if the mutex was already locked by this thread, or was successfully locked.

Definition at line 254 of file MutexHelper.h.

References Activ::IMutex::Try().

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivBase/MutexHelper.h
Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::DeleteAssociativeObject

Activ::DeleteAssociativeObject Class Reference

Delete associative object. More...

#include <ActivMiddleware/Misc/FunctionObjects.h>

List of all members.

Public Member Functions

template<typename Pair>
void operator() (const Pair &pair) const
Function operator.

Detailed Description

Delete associative object.

Can be used in conjunction with for_each() to destroy an associative container of pointers, for instance.

Definition at line 84 of file FunctionObjects.h.

Member Function Documentation

template<typename Pair>
void Activ::DeleteAssociativeObject::operator() ( const Pair & pair ) const [inline]

Function operator.

Parameters:
pair a reference to the object to delete.

Definition at line 93 of file FunctionObjects.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/Misc/FunctionObjects.h
Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::DeleteObject

Activ::DeleteObject Class Reference

Delete object. More...

#include <ActivMiddleware/Misc/FunctionObjects.h>

List of all members.

Public Member Functions

template<typename T>
void operator() (const T *ptr) const
Function operator.

Detailed Description

Delete object.

Can be used in conjunction with for_each() to destroy a sequence container of pointers, for instance.

Definition at line 38 of file FunctionObjects.h.

Member Function Documentation

template<typename T>
void Activ::DeleteObject::operator() ( const T * ptr ) const [inline]

Function operator.

Parameters:
ptr a pointer to the object to delete.

Definition at line 47 of file FunctionObjects.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/Misc/FunctionObjects.h
Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::DeleteObjectArray

Activ::DeleteObjectArray Class Reference

Delete object array. More...

#include <ActivMiddleware/Misc/FunctionObjects.h>

List of all members.

Public Member Functions

template<typename T>
void operator() (const T *ptr) const
Function operator.

Detailed Description

Delete object array.

Can be used in conjunction with for_each() to destroy a sequence container of array pointers, for instance.

Definition at line 61 of file FunctionObjects.h.

Member Function Documentation

template<typename T>
void Activ::DeleteObjectArray::operator() ( const T * ptr ) const [inline]

Function operator.

Parameters:
ptr a pointer to the object array to delete.

Definition at line 70 of file FunctionObjects.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/Misc/FunctionObjects.h
Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Des3Helper::Key

Activ::Des3Helper::Key Class Reference

Wrapper class for DES keys. More...

#include <ActivMiddleware/Misc/Des3Helper.h>

List of all members.

Public Member Functions

const DES_cblock & | GetKeyBlock () const
Get the underlying DES key block for the key.
const DES_key_schedule & | GetKeySchedule () const
Get the underlying DES key schedule for the key.
bool | IsInitialized () const
Is the key initialized?
Key (const std::string &hexString)
Constructor. Constructs keys from a hex string.
Key (const DES_cblock &keyBlock)
Constructor. Constructs key from a DES key block.
Key ()
Default constructor. Creates an uninitialized key.
StatusCode | Randomize ()
Randomize the key.
StatusCode | SetKey (const std::string &hexString)
Set the key from a hex string.
StatusCode | SetKey (const DES_cblock &keyBlock)
Set the key from a DES key block.
void | SetKey (const Key &key)
Set the key from another key.
std::string | ToString () const
Output key block as a hex string.

Detailed Description

Wrapper class for DES keys.

Definition at line 29 of file Des3Helper.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/Misc/Des3Helper.h
Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Des3Helper::KeyBundle

Activ::Des3Helper::KeyBundle Class Reference

class containing three DES key schedules More...

#include <ActivMiddleware/Misc/Des3Helper.h>

List of all members.

Public Member Functions

KeyBundle (const Des3Helper::Key &key1, const Des3Helper::Key &key2, const Des3Helper::Key &key3)
Constructor. Constructs bundle of specified keys.
KeyBundle ()
Default constructor. Creates a bundle of uninitialized keys.
StatusCode | Randomize ()
Randomize all the keys in the bundle.
void | SetKeys (const Des3Helper::Key &key1, const Des3Helper::Key &key2, const Des3Helper::Key &key3)
Set all three keys with specified keys.

Public Attributes

Des3Helper::Key m_key1
key 1
Des3Helper::Key m_key2
key 2
Des3Helper::Key m_key3
key 3

Detailed Description

class containing three DES key schedules

Definition at line 97 of file Des3Helper.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/Misc/Des3Helper.h
Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::DesHelper::Key

Activ::DesHelper::Key Class Reference

Wrapper class for DES keys. More...

#include <ActivMiddleware/Misc/DesHelper.h>

List of all members.

Public Member Functions

const DES_cblock & | GetKeyBlock () const
Get the underlying DES key block for the key.
const DES_key_schedule & | GetKeySchedule () const
Get the underlying DES key schedule for the key.
bool | IsInitialized () const
Is the key initialized?
Key (const std::string &hexString)
Constructor. Constructs keys from a hex string.
Key (const DES_cblock &keyBlock)
Constructor. Constructs key from a DES key block.
Key ()
Default constructor. Creates an uninitialized key.
StatusCode | Randomize ()
Randomize the key.
StatusCode | SetKey (const std::string &hexString)
Set the key from a hex string.
StatusCode | SetKey (const DES_cblock &keyBlock)
Set the key from a DES key block.
void | SetKey (const Key &key)
Set the key from another key.
std::string | ToString () const
Output key block as a hex string.

Detailed Description

Wrapper class for DES keys.

Definition at line 38 of file DesHelper.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/Misc/DesHelper.h
Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::DirectoryRemover

Activ::DirectoryRemover Class Reference

Directory remover class. More...

#include <ActivMiddleware/ActivBase/DirectoryRemover.h>

Inheritance diagram for Activ::DirectoryRemover:

Activ::DirectoryWalker

List of all members.

Public Member Functions

ACTIV_BASE_EXPORTED_API | DirectoryRemover ()
Default constructor.
ACTIV_BASE_EXPORTED_API StatusCode | Remove (const std::string &path, const bool shouldRecurseDirectory)
Remove files from a directory tree.
virtual ACTIV_BASE_EXPORTED_API | ~DirectoryRemover ()
Destructor.

Protected Member Functions

virtual
ACTIV_BASE_EXPORTED_API bool 		OnDirectory (const std::string &path, const std::string &name)
Callback function for when directories are located in the directory walk.
virtual
ACTIV_BASE_EXPORTED_API bool 		OnFile (const std::string &path, const std::string &name)
Callback function for when files are located in a directory walk.

Detailed Description

Directory remover class.

Definition at line 20 of file DirectoryRemover.h.

Member Function Documentation

virtual ACTIV_BASE_EXPORTED_API bool Activ::DirectoryRemover::OnDirectory | ( | const std::string & | path,
 |  | const std::string & | name |
 | ) |  |  | [protected, virtual]

Callback function for when directories are located in the directory walk.

Parameters:
path | the path to the directory.
name | the name of the directory.
Returns:
true to continue, false to stop (interrupt) the walk.

Reimplemented from Activ::DirectoryWalker.

virtual ACTIV_BASE_EXPORTED_API bool Activ::DirectoryRemover::OnFile | ( | const std::string & | path,
 |  | const std::string & | name |
 | ) |  |  | [protected, virtual]

Callback function for when files are located in a directory walk.

Parameters:
path | the path to the file.
name | the name of the file.
Returns:
true to continue, false to stop (interrupt) the walk.

Reimplemented from Activ::DirectoryWalker.

ACTIV_BASE_EXPORTED_API StatusCode Activ::DirectoryRemover::Remove | ( | const std::string & | path,
 |  | const bool | shouldRecurseDirectory
 | ) |  |

Remove files from a directory tree.

Parameters:
path | the path to the directory to remove.
shouldRecurseDirectory | indicates whether the directory should be recursed.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_FAILURE
STATUS_CODE_NOT_FOUND

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivBase/DirectoryRemover.h
Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::DirectoryWalker

Activ::DirectoryWalker Class Reference

Directory walker class. More...

#include <ActivMiddleware/ActivBase/DirectoryWalker.h>

Inheritance diagram for Activ::DirectoryWalker:

Activ::DirectoryRemover

List of all members.

Public Member Functions

ACTIV_BASE_EXPORTED_API | DirectoryWalker ()
Constructor.
ACTIV_BASE_EXPORTED_API StatusCode | Walk (const std::string &path, const std::string &wildcardPattern=std::string())
Walk a directory tree.
virtual ACTIV_BASE_EXPORTED_API | ~DirectoryWalker ()
Destructor.

Protected Member Functions

virtual
ACTIV_BASE_EXPORTED_API bool 		OnDirectory (const std::string &path, const std::string &name)
Callback function for when directories are located in the directory walk.
virtual
ACTIV_BASE_EXPORTED_API bool 		OnFile (const std::string &path, const std::string &name)
Callback function for when files are located in a directory walk.

Detailed Description

Directory walker class.

Do not assume any ordering of OnDirectory() or OnFile() callbacks.

Definition at line 24 of file DirectoryWalker.h.

Member Function Documentation

virtual ACTIV_BASE_EXPORTED_API bool Activ::DirectoryWalker::OnDirectory | ( | const std::string & | path,
 |  | const std::string & | name |
 | ) |  |  | [protected, virtual]

Callback function for when directories are located in the directory walk.

Parameters:
path | the path to the directory.
name | the name of the directory.
Returns:
true to continue, false to stop (interrupt) the walk.

Reimplemented in Activ::DirectoryRemover.

virtual ACTIV_BASE_EXPORTED_API bool Activ::DirectoryWalker::OnFile | ( | const std::string & | path,
 |  | const std::string & | name |
 | ) |  |  | [protected, virtual]

Callback function for when files are located in a directory walk.

Parameters:
path | the path to the file.
name | the name of the file.
Returns:
true to continue, false to stop (interrupt) the walk.

Reimplemented in Activ::DirectoryRemover.

ACTIV_BASE_EXPORTED_API StatusCode Activ::DirectoryWalker::Walk | ( | const std::string & | path,
 |  | const std::string & | wildcardPattern = std::string()
 | ) |  |

Walk a directory tree.

Parameters:
path | the path to the directory to walk.
wildcardPattern | only return files/directories matching this wildcard pattern (leave blank to return everything)
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_FAILURE
STATUS_CODE_NOT_FOUND
STATUS_CODE_INTERRUPTED

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivBase/DirectoryWalker.h
Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::DirectoryWatchApi

Activ::DirectoryWatchApi Class Reference

Api to the agent's directory watching service. More...

#include <ActivMiddleware/ActivFramework/DirectoryWatchApi.h>

List of all members.

Public Types

typedef std::vector< Event > | EventList
list of events
enum | EventType { EVENT_TYPE_ADDED, EVENT_TYPE_DELETED, EVENT_TYPE_MODIFIED }
List of event types that can be received. More...
typedef uint32_t | WatchType

Static Public Member Functions

static ACTIV_FRAMEWORK_API
StatusCode 		AddWatch (const Component &component, const std::string &directoryPath, const WatchType watchType, Address::Proxy watchAddress)
Add a directory watch.
static ACTIV_FRAMEWORK_API
StatusCode 		CancelWatch (const Component &component, Address &watchAddress)
Cancel a directory watch.
static ACTIV_FRAMEWORK_API
StatusCode 		Deserialize (const HeapMessage &heapMessage, EventList &eventList)
Deserialize a directory watch message.
static ACTIV_FRAMEWORK_API
std::string 		EventTypeToString (const EventType eventType)
Convert an event type to a string.

Static Public Attributes

static const MessageType | MESSAGE_TYPE = ROUTER_MESSAGE_USER_NOTIFY_DIRECTORY_WATCH_EVENTS
Message type received in OnMessage() by the component adding a directory watch when a change happens.
static const WatchType | WATCH_TYPE_ADDS_DELETES = 0x00000002
watch for file & directory additions / deletions
static const WatchType | WATCH_TYPE_ATTRIBUTES = 0x00000004
watch for changes in attributes (size, access times etc.) of files & directories
static const WatchType | WATCH_TYPE_RECURSIVE = 0x00000001
watch sub-directories?

Classes

class | Event
File/directory change event. More...

Detailed Description

Api to the agent's directory watching service.

Definition at line 27 of file DirectoryWatchApi.h.

Member Enumeration Documentation

enum Activ::DirectoryWatchApi::EventType

List of event types that can be received.

Enumerator:
EVENT_TYPE_ADDED | file or directory has been added
EVENT_TYPE_DELETED | file or directory has been deleted
EVENT_TYPE_MODIFIED | some attribute of the file or directory has changed

Definition at line 44 of file DirectoryWatchApi.h.

Member Function Documentation

static ACTIV_FRAMEWORK_API StatusCode Activ::DirectoryWatchApi::AddWatch | ( | const Component & | component,
 |  | const std::string & | directoryPath,
 |  | const WatchType | watchType,
 |  | Address::Proxy | watchAddress |
 | ) |  |  | [static]

Add a directory watch.

Change notifications will be received in the OnMessage() callback of component, with message type DirectoryWatchApi::MESSAGE_TYPE. Call DirectoryWatchApi::Deserialize() to get a list of Event objects.

Parameters:
component | the component wanting to create the watch.
directoryPath | path of a directory to watch.
watchType | type of watch to start.
watchAddress | reference to an Address object to receive the address of the new watch.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_TIMEOUT
STATUS_CODE_NOT_A_DIRECTORY path provided isn't a directory or doesn't exist
...

static ACTIV_FRAMEWORK_API StatusCode Activ::DirectoryWatchApi::CancelWatch | ( | const Component & | component,
 |  | Address & | watchAddress |
 | ) |  |  | [static]

Cancel a directory watch.

Note the cancel is asynchronous: you may still have some events from the watch queued up to be processed after calling this api.

Parameters:
component | the component that created the watch.
watchAddress | reference to an Address to holding the address of a watch. This is cleared down on success.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER watchAddress is not valid
...

static ACTIV_FRAMEWORK_API StatusCode Activ::DirectoryWatchApi::Deserialize | ( | const HeapMessage & | heapMessage,
 |  | EventList & | eventList |
 | ) |  |  | [static]

Deserialize a directory watch message.

Parameters:
heapMessage | message containing the serialized events.
eventList | to receive the deserialized events.
Returns:
STATUS_CODE_SUCCESS or an error status code.

static ACTIV_FRAMEWORK_API std::string Activ::DirectoryWatchApi::EventTypeToString ( const EventType eventType ) [static]

Convert an event type to a string.

Parameters:
eventType the EventType to convert.
Returns:
String representation of eventType.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivFramework/DirectoryWatchApi.h
Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::DirectoryWatchApi::Event

Activ::DirectoryWatchApi::Event Class Reference

File/directory change event. More...

#include <ActivMiddleware/ActivFramework/DirectoryWatchApi.h>

List of all members.

Public Attributes

EventType m_eventType
type of event that has happened
std::string m_path
path of file or directory that has changed

Detailed Description

File/directory change event.

Definition at line 54 of file DirectoryWatchApi.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivFramework/DirectoryWatchApi.h
Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::DllFunctionWrapper

Activ::DllFunctionWrapper< NAME, TYPE, THROW_ON_ERROR > Class Template Reference

Function wrapper. More...

#include <ActivMiddleware/Misc/Detail/DynamicLibraryLoaderDetail.h>

List of all members.

Public Types

typedef TYPE | Type

Public Member Functions

DllFunctionWrapper ()
Constructor.
void | FindFunction (const DllHandle dllHandle)
Find the address of the function.

Protected Attributes

Type * | m_pFunction

Detailed Description

template<typename NAME, typename TYPE, bool THROW_ON_ERROR>
class Activ::DllFunctionWrapper< NAME, TYPE, THROW_ON_ERROR >

Function wrapper.

Definition at line 26 of file DynamicLibraryLoaderDetail.h.

Constructor & Destructor Documentation

template<typename NAME, typename TYPE, bool THROW_ON_ERROR>
Activ::DllFunctionWrapper< NAME, TYPE, THROW_ON_ERROR >::DllFunctionWrapper ( ) [inline]

Constructor.

Set function pointer to NULL.

Definition at line 52 of file DynamicLibraryLoaderDetail.h.

Member Function Documentation

template<typename NAME, typename TYPE, bool THROW_ON_ERROR>
void Activ::DllFunctionWrapper< NAME, TYPE, THROW_ON_ERROR >::FindFunction ( const DllHandle dllHandle ) [inline]

Find the address of the function.

Parameters:
dllHandle handle to the library.

Definition at line 60 of file DynamicLibraryLoaderDetail.h.

References ACTIV_THROW.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/Misc/Detail/DynamicLibraryLoaderDetail.h
Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::DynamicLibraryLoader

Activ::DynamicLibraryLoader< T > Class Template Reference

Main dynamic library loader class. More...

#include <ActivMiddleware/Misc/DynamicLibraryLoader.h>

List of all members.

Public Member Functions

DynamicLibraryLoader (const std::string &libraryName)
Loads the library.
template<typename F>
boost::function< typename F::Type > | Get () const
Get function pointer.
bool | HasAllAvailable () const
Were all the functions found?
~DynamicLibraryLoader ()
Destructor.

Classes

class | DllFunctionLoader
Helper class to find function pointer for each base of a DynamicLibraryLoader.

Detailed Description

template<typename T>
class Activ::DynamicLibraryLoader< T >

Main dynamic library loader class.

The class is templatized by a boost::mpl::vector of DllFunctionWrapper classes. For example:

typedef int (WINAPI getaddrinfo_type)(const char FAR *, const char FAR *, const struct addrinfo FAR *, struct addrinfo FAR *FAR *); ACTIV_DECLARE_DLL_FUNCTION(getaddrinfo, getaddrinfo_type, true); typedef void (WINAPI freeaddrinfo_type)(struct addrinfo FAR *); ACTIV_DECLARE_DLL_FUNCTION(freeaddrinfo, freeaddrinfo_type, true);

typedef DynamicLibraryLoader<boost::mpl::vector<getaddrinfo, freeaddrinfo> > WinsockLoader;

Instantiating a WinsockLoader by passing "ws2_32.dll" to the constructor will attempt to open the Winsock library and find the function pointers for "getaddrinfo" and "freeaddrinfo".

Different library names can be provided by passing in a semi-colon delimited list, e.g. "libssl.so.6;libssl.0.9.8;libssl.so". The names are opened in order until a successful open.

These function pointers can then be accessed using Get(): winsockLoader.Get<getaddrinfo>()(...);

Definition at line 79 of file DynamicLibraryLoader.h.

Constructor & Destructor Documentation

template<typename T>
Activ::DynamicLibraryLoader< T >::DynamicLibraryLoader ( const std::string & libraryName ) [inline]

Loads the library.

Parameters:
libraryName a semi-colon delimited list of names of this library to attempt to open.

Definition at line 90 of file DynamicLibraryLoaderDetail.h.

template<typename T>
Activ::DynamicLibraryLoader< T >::~DynamicLibraryLoader ( ) [inline]

Destructor.

Unloads the library.

Definition at line 103 of file DynamicLibraryLoaderDetail.h.

Member Function Documentation

template<typename T>
template<typename F>
boost::function<typename F::Type> Activ::DynamicLibraryLoader< T >::Get ( ) const [inline]

Get function pointer.

Template parameter F is a DllFunctionWrapper class from ACTIV_DECLARE_DLL_FUNCTION. Usage is, for example: winsockLoader.Get<freeaddrinfo>()(...);

Returns:
Function pointer, or NULL if function wasn't found.

Definition at line 118 of file DynamicLibraryLoader.h.

template<typename T>
bool Activ::DynamicLibraryLoader< T >::HasAllAvailable ( ) const [inline]

Were all the functions found?

Returns:
boolean.

Definition at line 118 of file DynamicLibraryLoaderDetail.h.

The documentation for this class was generated from the following files:
  • include/ActivMiddleware/Misc/DynamicLibraryLoader.h
  • include/ActivMiddleware/Misc/Detail/DynamicLibraryLoaderDetail.h
Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::EndPointSubject

Activ::EndPointSubject Class Reference

Endpoint subject. More...

#include <ActivMiddleware/ActivFramework/Subjects.h>

Inheritance diagram for Activ::EndPointSubject:

Activ::Subject

List of all members.

Public Member Functions

EndPointSubject ()
Constructor.

Detailed Description

Endpoint subject.

Definition at line 20 of file Subjects.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivFramework/Subjects.h
Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::EqualToPairComparisonObject

Activ::EqualToPairComparisonObject< Pair > Class Template Reference

Equal to pair comparison function object. More...

#include <ActivMiddleware/Misc/FunctionObjects.h>

List of all members.

Public Member Functions

bool | operator() (const typename Pair::first_type &lhs, const Pair &rhs) const
Function operator.
bool | operator() (const Pair &lhs, const typename Pair::first_type &rhs) const
Function operator.
bool | operator() (const Pair &lhs, const Pair &rhs) const
Function operator.

Detailed Description

template<typename Pair>
class Activ::EqualToPairComparisonObject< Pair >

Equal to pair comparison function object.

Definition at line 170 of file FunctionObjects.h.

Member Function Documentation

template<typename Pair>
bool Activ::EqualToPairComparisonObject< Pair >::operator() | ( | const typename Pair::first_type & | lhs,
 |  | const Pair & | rhs |
 | ) |  |  | const [inline]

Function operator.

Parameters:
lhs | a reference to the lhs object.
rhs | a reference to the rhs object.
Returns:
whether the lhs object is less than rhs object.

Definition at line 207 of file FunctionObjects.h.

template<typename Pair>
bool Activ::EqualToPairComparisonObject< Pair >::operator() | ( | const Pair & | lhs,
 |  | const typename Pair::first_type & | rhs |
 | ) |  |  | const [inline]

Function operator.

Parameters:
lhs | a reference to the lhs object.
rhs | a reference to the rhs object.
Returns:
whether the lhs object is equal to the rhs object.

Definition at line 194 of file FunctionObjects.h.

template<typename Pair>
bool Activ::EqualToPairComparisonObject< Pair >::operator() | ( | const Pair & | lhs,
 |  | const Pair & | rhs |
 | ) |  |  | const [inline]

Function operator.

Parameters:
lhs | a reference to the lhs object.
rhs | a reference to the rhs object.
Returns:
whether the lhs object is equal to the rhs object.

Definition at line 181 of file FunctionObjects.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/Misc/FunctionObjects.h
Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Exception

Activ::Exception Class Reference

Base Activ exception class. More...

#include <ActivMiddleware/ActivBase/Exception.h>

Inheritance diagram for Activ::Exception:

Activ::BaseException Activ::ContentPlatform::Feed::TableTemplateException Activ::CrtException Activ::Database::DatabaseException Activ::IniFileParser::ParseException Activ::IpException Activ::OsException Activ::StatusCodeException Activ::SystemException

List of all members.

Public Member Functions

ACTIV_BASE_EXPORTED_API void | AddException (Exception *pException) const
Attach another exception to the chain.
ACTIV_BASE_EXPORTED_API | Exception (const Exception &rhs)
Copy constructor.
ACTIV_BASE_EXPORTED_API | Exception (const char *file, const char *function, const uint_fast32_t line, const uint_fast32_t errorCode=0)
Default constructor.
virtual
ACTIV_BASE_EXPORTED_API void 		ToStream (std::ostream &os) const
Stream output method.
virtual
ACTIV_BASE_EXPORTED_API
std::string 		ToString () const
Convert the exception error code to a string.
virtual ACTIV_BASE_EXPORTED_API | ~Exception ()
Virtual destructor.

Public Attributes

const uint_fast32_t | m_errorCode
The exception specific error code.
const char *const | m_file
The file that raised the exception.
const char *const | m_function
The function that raised the excetpion.
const uint_fast32_t | m_line
The line number that raised the exception.

Detailed Description

Base Activ exception class.

Definition at line 58 of file Exception.h.

Constructor & Destructor Documentation

ACTIV_BASE_EXPORTED_API Activ::Exception::Exception | ( | const char * | file,
 |  | const char * | function,
 |  | const uint_fast32_t | line,
 |  | const uint_fast32_t | errorCode = 0
 | ) |  |

Default constructor.

Parameters:
file | the file which raised the exception.
function | the function which raised the exception.
line | the line number which raised the exception.
errorCode | the exception specific error code.

Member Function Documentation

ACTIV_BASE_EXPORTED_API void Activ::Exception::AddException ( Exception * pException ) const

Attach another exception to the chain.

Parameters:
pException the exception to add to the chain.

virtual ACTIV_BASE_EXPORTED_API void Activ::Exception::ToStream ( std::ostream & os ) const [virtual]

Stream output method.

ToStream() allows writing of the exception to an ostream object. The file, function, line, error code and error string will be written to the ostream.

Parameters:
os the ostream to write the exception to.

virtual ACTIV_BASE_EXPORTED_API std::string Activ::Exception::ToString ( ) const [virtual]

Convert the exception error code to a string.

Classes derived from Exception are required to implement ToString() to convert their error codes to a readable string.

Returns:
the error code as a string.

Reimplemented in Activ::ContentPlatform::Feed::TableTemplateException, Activ::BaseException, Activ::CrtException, Activ::IniFileParser::ParseException, Activ::OsException, Activ::StatusCodeException, Activ::Database::DatabaseException, Activ::IpException, and Activ::SystemException.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivBase/Exception.h
Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Fiber

Activ::Fiber Class Reference

Fiber class. More...

#include <ActivMiddleware/ActivBase/Fiber.h>

List of all members.

Public Member Functions

ACTIV_BASE_EXPORTED_API | Fiber (void *const pData=0, const size_t stackSize=defaultStackSize)
Constructor.
ACTIV_BASE_EXPORTED_API void | Return ()
Return to the calling fiber.
ACTIV_BASE_EXPORTED_API void | Switch ()
Switch to this fiber.
virtual ACTIV_BASE_EXPORTED_API | ~Fiber ()
Destructor.

Static Public Attributes

static const size_t | defaultStackSize = 102400

Protected Member Functions

virtual
ACTIV_BASE_EXPORTED_API void 		Process (void *const pData)=0
Actual fiber function (override this for your own processing).

Detailed Description

Fiber class.

Definition at line 31 of file Fiber.h.

Constructor & Destructor Documentation

ACTIV_BASE_EXPORTED_API Activ::Fiber::Fiber | ( | void *const | pData = 0,
 |  | const size_t | stackSize = defaultStackSize
 | ) |  |

Constructor.

Parameters:
pData | user data that will get passed to Process() when the fiber is initially switched to.
stackSize | initial size of stack to commit.
Exceptions:
Exception.

Member Function Documentation

virtual ACTIV_BASE_EXPORTED_API void Activ::Fiber::Process ( void *const pData ) [protected, pure virtual]

Actual fiber function (override this for your own processing).

Parameters:
pData user data pointer.

ACTIV_BASE_EXPORTED_API void Activ::Fiber::Return ( )

Return to the calling fiber.

This call just returns if this object has not been Switch()ed to.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivBase/Fiber.h
Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::FieldTypeFactory

Activ::FieldTypeFactory Class Reference

Field type factory class. More...

#include <ActivMiddleware/ActivFieldTypes/FieldTypeFactory.h>

Inheritance diagram for Activ::FieldTypeFactory:

Activ::Singleton< T >

List of all members.

Public Member Functions

ACTIV_FIELD_TYPES_API IFieldType * | Clone (const IFieldType *const pIFieldType) const
Clone an existing field type object.
ACTIV_FIELD_TYPES_API IFieldType * | Convert (const FieldType fieldType, const IFieldType *const pIFieldType) const
Convert an existing field type object.
ACTIV_FIELD_TYPES_API IFieldType * | Create (const FieldType fieldType) const
Create a field type object.

Static Public Member Functions

static ACTIV_FIELD_TYPES_API
FieldTypeFactory & 		GetInstance ()
Get a reference to the singleton instance.

Friends

class | Singleton< FieldTypeFactory >

Detailed Description

Field type factory class.

Definition at line 27 of file FieldTypeFactory.h.

Member Function Documentation

ACTIV_FIELD_TYPES_API IFieldType* Activ::FieldTypeFactory::Clone ( const IFieldType *const pIFieldType ) const

Clone an existing field type object.

Parameters:
pIFieldType the object to clone.
Returns:
a pointer to the cloned object (0 on failure).

ACTIV_FIELD_TYPES_API IFieldType* Activ::FieldTypeFactory::Convert | ( | const FieldType | fieldType,
 |  | const IFieldType *const | pIFieldType |
 | ) |  |  | const

Convert an existing field type object.

Parameters:
fieldType | the field type.
pIFieldType | the object to clone.
Returns:
a pointer to the converted object (0 on failure).

ACTIV_FIELD_TYPES_API IFieldType* Activ::FieldTypeFactory::Create ( const FieldType fieldType ) const

Create a field type object.

Parameters:
fieldType the field type.
Returns:
a pointer to the created object (0 on failure).

static ACTIV_FIELD_TYPES_API FieldTypeFactory& Activ::FieldTypeFactory::GetInstance ( ) [static]

Get a reference to the singleton instance.

Returns:
Reference.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivFieldTypes/FieldTypeFactory.h
Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::FieldTypeToClass

Activ::FieldTypeToClass<> Class Template Reference

Template to map from FIELD_TYPE_* values to concrete IFieldType class. More...

#include <ActivMiddleware/ActivFieldTypes/ActivFieldTypes.h>

Detailed Description

template<FieldType>
class Activ::FieldTypeToClass<>

Template to map from FIELD_TYPE_* values to concrete IFieldType class.

Definition at line 70 of file ActivFieldTypes.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivFieldTypes/ActivFieldTypes.h
Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::FieldTypeToClass< FIELD_TYPE_BINARY_ARRAY >

Activ::FieldTypeToClass< FIELD_TYPE_BINARY_ARRAY > Class Template Reference

Template specialization to map from FIELD_TYPE_BINARY_ARRAY to BinaryArray class. More...

#include <ActivMiddleware/ActivFieldTypes/BinaryArray.h>

List of all members.

Public Types

typedef BinaryArray Type

Detailed Description

template<>
class Activ::FieldTypeToClass< FIELD_TYPE_BINARY_ARRAY >

Template specialization to map from FIELD_TYPE_BINARY_ARRAY to BinaryArray class.

Definition at line 500 of file BinaryArray.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivFieldTypes/BinaryArray.h
Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::FieldTypeToClass< FIELD_TYPE_BINARY_STRING >

Activ::FieldTypeToClass< FIELD_TYPE_BINARY_STRING > Class Template Reference

Template specialization to map from FIELD_TYPE_BINARY_STRING to BinaryString class. More...

#include <ActivMiddleware/ActivFieldTypes/BinaryString.h>

List of all members.

Public Types

typedef BinaryString Type

Detailed Description

template<>
class Activ::FieldTypeToClass< FIELD_TYPE_BINARY_STRING >

Template specialization to map from FIELD_TYPE_BINARY_STRING to BinaryString class.

Definition at line 498 of file BinaryString.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivFieldTypes/BinaryString.h
Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::FieldTypeToClass< FIELD_TYPE_BLOB >

Activ::FieldTypeToClass< FIELD_TYPE_BLOB > Class Template Reference

Template specialization to map from FIELD_TYPE_BLOB to Blob class. More...

#include <ActivMiddleware/ActivFieldTypes/Blob.h>

List of all members.

Public Types

typedef Blob Type

Detailed Description

template<>
class Activ::FieldTypeToClass< FIELD_TYPE_BLOB >

Template specialization to map from FIELD_TYPE_BLOB to Blob class.

Definition at line 914 of file Blob.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivFieldTypes/Blob.h
Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::FieldTypeToClass< FIELD_TYPE_CRC_BLOB >

Activ::FieldTypeToClass< FIELD_TYPE_CRC_BLOB > Class Template Reference

Template specialization to map from FIELD_TYPE_CRC_BLOB to CrcBlob class. More...

#include <ActivMiddleware/ActivFieldTypes/CrcBlob.h>

List of all members.

Public Types

typedef CrcBlob Type

Detailed Description

template<>
class Activ::FieldTypeToClass< FIELD_TYPE_CRC_BLOB >

Template specialization to map from FIELD_TYPE_CRC_BLOB to CrcBlob class.

Definition at line 995 of file CrcBlob.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivFieldTypes/CrcBlob.h
Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::FieldTypeToClass< FIELD_TYPE_DATE >

Activ::FieldTypeToClass< FIELD_TYPE_DATE > Class Template Reference

Template specialization to map from FIELD_TYPE_DATE to Date class. More...

#include <ActivMiddleware/ActivFieldTypes/Date.h>

List of all members.

Public Types

typedef Date Type

Detailed Description

template<>
class Activ::FieldTypeToClass< FIELD_TYPE_DATE >

Template specialization to map from FIELD_TYPE_DATE to Date class.

Definition at line 959 of file Date.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivFieldTypes/Date.h
Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::FieldTypeToClass< FIELD_TYPE_DATE_TIME >

Activ::FieldTypeToClass< FIELD_TYPE_DATE_TIME > Class Template Reference

Template specialization to map from FIELD_TYPE_DATE_TIME to DateTime class. More...

#include <ActivMiddleware/ActivFieldTypes/DateTime.h>

List of all members.

Public Types

typedef DateTime Type

Detailed Description

template<>
class Activ::FieldTypeToClass< FIELD_TYPE_DATE_TIME >

Template specialization to map from FIELD_TYPE_DATE_TIME to DateTime class.

Definition at line 1428 of file DateTime.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivFieldTypes/DateTime.h
Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::FieldTypeToClass< FIELD_TYPE_RATIONAL >

Activ::FieldTypeToClass< FIELD_TYPE_RATIONAL > Class Template Reference

Template specialization to map from FIELD_TYPE_RATIONAL to Rational class. More...

#include <ActivMiddleware/ActivFieldTypes/Rational.h>

List of all members.

Public Types

typedef Rational Type

Detailed Description

template<>
class Activ::FieldTypeToClass< FIELD_TYPE_RATIONAL >

Template specialization to map from FIELD_TYPE_RATIONAL to Rational class.

Definition at line 1495 of file Rational.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivFieldTypes/Rational.h
Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::FieldTypeToClass< FIELD_TYPE_SINT >

Activ::FieldTypeToClass< FIELD_TYPE_SINT > Class Template Reference

Template specialization to map from FIELD_TYPE_SINT to SInt class. More...

#include <ActivMiddleware/ActivFieldTypes/SInt.h>

List of all members.

Public Types

typedef SInt Type

Detailed Description

template<>
class Activ::FieldTypeToClass< FIELD_TYPE_SINT >

Template specialization to map from FIELD_TYPE_SINT to SInt class.

Definition at line 665 of file SInt.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivFieldTypes/SInt.h
Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::FieldTypeToClass< FIELD_TYPE_TEXT_ARRAY >

Activ::FieldTypeToClass< FIELD_TYPE_TEXT_ARRAY > Class Template Reference

Template specialization to map from FIELD_TYPE_TEXT_ARRAY to TextArray class. More...

#include <ActivMiddleware/ActivFieldTypes/TextArray.h>

List of all members.

Public Types

typedef TextArray Type

Detailed Description

template<>
class Activ::FieldTypeToClass< FIELD_TYPE_TEXT_ARRAY >

Template specialization to map from FIELD_TYPE_TEXT_ARRAY to TextArray class.

Definition at line 492 of file TextArray.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivFieldTypes/TextArray.h
Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::FieldTypeToClass< FIELD_TYPE_TEXT_STRING >

Activ::FieldTypeToClass< FIELD_TYPE_TEXT_STRING > Class Template Reference

Template specialization to map from FIELD_TYPE_TEXT_STRING to TextString class. More...

#include <ActivMiddleware/ActivFieldTypes/TextString.h>

List of all members.

Public Types

typedef TextString Type

Detailed Description

template<>
class Activ::FieldTypeToClass< FIELD_TYPE_TEXT_STRING >

Template specialization to map from FIELD_TYPE_TEXT_STRING to TextString class.

Definition at line 490 of file TextString.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivFieldTypes/TextString.h
Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::FieldTypeToClass< FIELD_TYPE_TIME >

Activ::FieldTypeToClass< FIELD_TYPE_TIME > Class Template Reference

Template specialization to map from FIELD_TYPE_TIME to Time class. More...

#include <ActivMiddleware/ActivFieldTypes/Time.h>

List of all members.

Public Types

typedef Time Type

Detailed Description

template<>
class Activ::FieldTypeToClass< FIELD_TYPE_TIME >

Template specialization to map from FIELD_TYPE_TIME to Time class.

Definition at line 1275 of file Time.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivFieldTypes/Time.h
Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::FieldTypeToClass< FIELD_TYPE_TRATIONAL >

Activ::FieldTypeToClass< FIELD_TYPE_TRATIONAL > Class Template Reference

Template specialization to map from FIELD_TYPE_TRATIONAL to TRational class. More...

#include <ActivMiddleware/ActivFieldTypes/TRational.h>

List of all members.

Public Types

typedef TRational Type

Detailed Description

template<>
class Activ::FieldTypeToClass< FIELD_TYPE_TRATIONAL >

Template specialization to map from FIELD_TYPE_TRATIONAL to TRational class.

Definition at line 1170 of file TRational.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivFieldTypes/TRational.h
Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::FieldTypeToClass< FIELD_TYPE_UINT >

Activ::FieldTypeToClass< FIELD_TYPE_UINT > Class Template Reference

Template specialization to map from FIELD_TYPE_UINT to UInt class. More...

#include <ActivMiddleware/ActivFieldTypes/UInt.h>

List of all members.

Public Types

typedef UInt Type

Detailed Description

template<>
class Activ::FieldTypeToClass< FIELD_TYPE_UINT >

Template specialization to map from FIELD_TYPE_UINT to UInt class.

Definition at line 675 of file UInt.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivFieldTypes/UInt.h
Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::File

Activ::File Class Reference

File class. More...

#include <ActivMiddleware/ActivBase/File.h>

List of all members.

Public Types

typedef uint32_t | AccessFlags
The access flags type definition.
enum | SeekMethod { SEEK_METHOD_BEGIN, SEEK_METHOD_END, SEEK_METHOD_CURRENT }
Seek method.
typedef uint32_t | ShareFlags
The share modes type definition.

Public Member Functions

ACTIV_BASE_EXPORTED_API StatusCode | Close ()
Close the file.
ACTIV_BASE_EXPORTED_API StatusCode | Create (const std::string &fileName, const AccessFlags accessFlags, const ShareFlags shareFlags)
Create the file.
ACTIV_BASE_EXPORTED_API | File ()
Default constructor.
ACTIV_BASE_EXPORTED_API StatusCode | GetCreationDateTime (std::tm &tm) const
Get the creation date time of the file.
ACTIV_BASE_EXPORTED_API StatusCode | GetFileName (std::string &fileName) const
Get the file name.
ACTIV_BASE_INLINE_API HANDLE | GetHandle () const
Get the underlying file handle.
ACTIV_BASE_EXPORTED_API StatusCode | GetLastAccessDateTime (std::tm &tm) const
Get the last access date time of the file.
ACTIV_BASE_EXPORTED_API StatusCode | GetLastWriteDateTime (std::tm &tm) const
Get the last write date time of the file.
ACTIV_BASE_EXPORTED_API StatusCode | GetPosition (int64_t &position) const
Get the current position within the file.
ACTIV_BASE_EXPORTED_API StatusCode | GetSize (int64_t &size) const
Get the size of the file.
ACTIV_BASE_EXPORTED_API bool | IsOpen () const
Is the file open.
ACTIV_BASE_EXPORTED_API StatusCode | Open (const std::string &fileName, const AccessFlags accessFlags, const ShareFlags shareFlags)
Open the file.
ACTIV_BASE_EXPORTED_API StatusCode | Read (void *pBuffer, const size_t nBytesToRead)
Read from a file.
ACTIV_BASE_EXPORTED_API StatusCode | Read (void *pBuffer, const size_t nBytesToRead, size_t &nBytesRead)
Read from a file.
ACTIV_BASE_EXPORTED_API StatusCode | ReadLine (std::string &line, std::string &endOfLine)
Read a line from a file.
ACTIV_BASE_EXPORTED_API StatusCode | SetPosition (int64_t position, const SeekMethod seekMethod=SEEK_METHOD_BEGIN)
Set the current position within the file.
ACTIV_BASE_EXPORTED_API StatusCode | SetSize (int64_t size)
Set the size of the file.
ACTIV_BASE_EXPORTED_API StatusCode | Write (const void *pBuffer, const size_t nBytesToWrite)
Write to a file.
ACTIV_BASE_EXPORTED_API StatusCode | Write (const void *pBuffer, const size_t nBytesToWrite, size_t &nBytesWritten)
Write to a file.
ACTIV_BASE_EXPORTED_API | ~File ()
Destructor.

Static Public Member Functions

static ACTIV_BASE_EXPORTED_API
StatusCode 		Copy (const std::string &sourceFileName, const std::string &targetFileName, bool replaceExisting=false)
Copy a file.
static ACTIV_BASE_EXPORTED_API
std::string 		ExpandPath (const std::string &path)
Expand ~ in a path.
static ACTIV_BASE_EXPORTED_API
StatusCode 		GetCreationDateTime (const std::string &fileName, std::tm &tm)
Get the creation date time of a file.
static ACTIV_BASE_EXPORTED_API char | GetDirectorySeparator ()
Get directory separator character for this platform.
static ACTIV_BASE_EXPORTED_API
const std::string & 		GetEndOfLine ()
Get the end of line characters for this platform.
static ACTIV_BASE_EXPORTED_API
StatusCode 		GetLastAccessDateTime (const std::string &fileName, std::tm &tm)
Get the last access date time of a file.
static ACTIV_BASE_EXPORTED_API
StatusCode 		GetLastWriteDateTime (const std::string &fileName, std::tm &tm)
Get the last write date time of a file.
static ACTIV_BASE_EXPORTED_API
StatusCode 		GetSize (const std::string &fileName, int64_t &size)
Get the size of a file.
static ACTIV_BASE_EXPORTED_API
std::string 		GetTemporaryPath ()
Get temporary directory path.
static ACTIV_BASE_EXPORTED_API bool | IsDirectory (const std::string &pathName)
Is a path a directory?
static ACTIV_BASE_EXPORTED_API bool | IsFileNameOnly (const std::string &pathName)
Is the provided path name just a file name?
static ACTIV_BASE_EXPORTED_API bool | IsFound (const std::string &fileName)
Does a file exist?
static ACTIV_BASE_EXPORTED_API
std::string 		MakeAbsolutePath (const std::string &path)
Create an absolute path from a relative one.
static ACTIV_BASE_EXPORTED_API
std::string 		MakePath (const std::string &directory, const std::string &fileName)
Create a path from directory and file name.
static ACTIV_BASE_EXPORTED_API
StatusCode 		Remove (const std::string &fileName)
Remove a file.
static ACTIV_BASE_EXPORTED_API
StatusCode 		Rename (const std::string &sourceFileName, const std::string &targetFileName, bool replaceExisting=false)
Rename a file.
static ACTIV_BASE_EXPORTED_API
StatusCode 		SearchPath (const std::string &fileName, std::string &fullyQualifiedFileName)
Search the current path for a file.
static ACTIV_BASE_EXPORTED_API void | SplitPath (const std::string &path, std::string &directory, std::string &fileName)
Get the directory and filename from a path.

Static Public Attributes

static const AccessFlags | ACCESS_FLAG_READ = 0x00000001
Open/create file with read access.
static const AccessFlags | ACCESS_FLAG_WRITE = 0x00000002
Open/create file with write access.
static const ShareFlags | SHARE_FLAG_READ = 0x00000001
Open/create file with read sharing access.
static const ShareFlags | SHARE_FLAG_WRITE = 0x00000002
Open/create file with write sharing access.

Detailed Description

File class.

Definition at line 22 of file File.h.

Member Function Documentation

ACTIV_BASE_EXPORTED_API StatusCode Activ::File::Close ( )

Close the file.

Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_OPEN
...

static ACTIV_BASE_EXPORTED_API StatusCode Activ::File::Copy | ( | const std::string & | sourceFileName,
 |  | const std::string & | targetFileName,
 |  | bool | replaceExisting = false |
 | ) |  |  | [static]

Copy a file.

Parameters:
sourceFileName | the name of the existing file.
targetFileName | the name of the new file.
replaceExisting | whether an existing file should be overwritten.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_FAILURE
...

ACTIV_BASE_EXPORTED_API StatusCode Activ::File::Create | ( | const std::string & | fileName,
 |  | const AccessFlags | accessFlags,
 |  | const ShareFlags | shareFlags
 | ) |  |

Create the file.

Parameters:
fileName | the file name.
accessFlags | the file access flags.
shareFlags | the file sharing flags.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_ALREADY_OPEN
...

static ACTIV_BASE_EXPORTED_API std::string Activ::File::ExpandPath ( const std::string & path ) [static]

Expand ~ in a path.

Parameters:
path the path to expand.
Returns:
The path with a leading ~ expanded, if possible.

static ACTIV_BASE_EXPORTED_API StatusCode Activ::File::GetCreationDateTime | ( | const std::string & | fileName,
 |  | std::tm & | tm |
 | ) |  |  | [static]

Get the creation date time of a file.

Parameters:
fileName | the file name.
tm | reference to a tm structure to receive the UTC date / time.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_OPEN
...

ACTIV_BASE_EXPORTED_API StatusCode Activ::File::GetCreationDateTime ( std::tm & tm ) const

Get the creation date time of the file.

Parameters:
tm reference to a tm structure to receive the UTC date / time.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_OPEN
...

static ACTIV_BASE_EXPORTED_API char Activ::File::GetDirectorySeparator ( ) [static]

Get directory separator character for this platform.

Returns:
Directory separator character.

static ACTIV_BASE_EXPORTED_API const std::string& Activ::File::GetEndOfLine ( ) [static]

Get the end of line characters for this platform.

Returns:
the end of line characters.

ACTIV_BASE_EXPORTED_API StatusCode Activ::File::GetFileName ( std::string & fileName ) const

Get the file name.

Parameters:
fileName the file name.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_OPEN

HANDLE Activ::File::GetHandle ( ) const [inline]

Get the underlying file handle.

Returns:
the file handle

Definition at line 484 of file File.h.

static ACTIV_BASE_EXPORTED_API StatusCode Activ::File::GetLastAccessDateTime | ( | const std::string & | fileName,
 |  | std::tm & | tm |
 | ) |  |  | [static]

Get the last access date time of a file.

Parameters:
fileName | the file name.
tm | reference to a tm structure to receive the UTC date / time.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_OPEN
...

ACTIV_BASE_EXPORTED_API StatusCode Activ::File::GetLastAccessDateTime ( std::tm & tm ) const

Get the last access date time of the file.

Parameters:
tm reference to a tm structure to receive the UTC date / time.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_OPEN
...

static ACTIV_BASE_EXPORTED_API StatusCode Activ::File::GetLastWriteDateTime | ( | const std::string & | fileName,
 |  | std::tm & | tm |
 | ) |  |  | [static]

Get the last write date time of a file.

Parameters:
fileName | the file name.
tm | reference to a tm structure to receive the UTC date / time.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_OPEN
...

ACTIV_BASE_EXPORTED_API StatusCode Activ::File::GetLastWriteDateTime ( std::tm & tm ) const

Get the last write date time of the file.

Parameters:
tm reference to a tm structure to receive the UTC date / time.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_OPEN
...

ACTIV_BASE_EXPORTED_API StatusCode Activ::File::GetPosition ( int64_t & position ) const

Get the current position within the file.

Parameters:
position the position within the file.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_OPEN
...

static ACTIV_BASE_EXPORTED_API StatusCode Activ::File::GetSize | ( | const std::string & | fileName,
 |  | int64_t & | size |
 | ) |  |  | [static]

Get the size of a file.

Parameters:
fileName | the file name.
size | the size of the file.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_OPEN
STATUS_CODE_FAILURE
...

ACTIV_BASE_EXPORTED_API StatusCode Activ::File::GetSize ( int64_t & size ) const

Get the size of the file.

Parameters:
size the size of the file.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_OPEN
STATUS_CODE_FAILURE
...

static ACTIV_BASE_EXPORTED_API std::string Activ::File::GetTemporaryPath ( ) [static]

Get temporary directory path.

Note the returned path may or may not contain a trailing directory separator, so use File::MakePath() to construct the path of a file in the temporary directory.

Returns:
Temporary directory path.

static ACTIV_BASE_EXPORTED_API bool Activ::File::IsDirectory ( const std::string & pathName ) [static]

Is a path a directory?

Parameters:
pathName path to check.
Returns:
boolean.

static ACTIV_BASE_EXPORTED_API bool Activ::File::IsFileNameOnly ( const std::string & pathName ) [static]

Is the provided path name just a file name?

Parameters:
pathName path to check.
Returns:
true if pathName is just a file name.

static ACTIV_BASE_EXPORTED_API bool Activ::File::IsFound ( const std::string & fileName ) [static]

Does a file exist?

Parameters:
fileName the file to find.
Returns:
whether the file exists.

ACTIV_BASE_EXPORTED_API bool Activ::File::IsOpen ( ) const

Is the file open.

Returns:
whether the file is open.

static ACTIV_BASE_EXPORTED_API std::string Activ::File::MakeAbsolutePath ( const std::string & path ) [static]

Create an absolute path from a relative one.

Parameters:
path The relative path.
Returns:
Absolute pathname.

static ACTIV_BASE_EXPORTED_API std::string Activ::File::MakePath | ( | const std::string & | directory,
 |  | const std::string & | fileName |
 | ) |  |  | [static]

Create a path from directory and file name.

Parameters:
directory | the directory.
fileName | the file name.
Returns:
Full pathname.

ACTIV_BASE_EXPORTED_API StatusCode Activ::File::Open | ( | const std::string & | fileName,
 |  | const AccessFlags | accessFlags,
 |  | const ShareFlags | shareFlags
 | ) |  |

Open the file.

Parameters:
fileName | the file name.
accessFlags | the file access flags.
shareFlags | the file sharing flags.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_ALREADY_OPEN
...

ACTIV_BASE_EXPORTED_API StatusCode Activ::File::Read | ( | void * | pBuffer,
 |  | const size_t | nBytesToRead
 | ) |  |

Read from a file.

Parameters:
pBuffer | the buffer to read into.
nBytesToRead | the number of bytes to read.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_OPEN
STATUS_CODE_FAILURE
...

ACTIV_BASE_EXPORTED_API StatusCode Activ::File::Read | ( | void * | pBuffer,
 |  | const size_t | nBytesToRead,
 |  | size_t & | nBytesRead
 | ) |  |

Read from a file.

Parameters:
pBuffer | the buffer to read into.
nBytesToRead | the number of bytes to read.
nBytesRead | the number of bytes read.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_OPEN
...

ACTIV_BASE_EXPORTED_API StatusCode Activ::File::ReadLine | ( | std::string & | line,
 |  | std::string & | endOfLine
 | ) |  |

Read a line from a file.

Parameters:
line | the buffer to read the line into.
endOfLine | the buffer to read the end of line into.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_OPEN
STATUS_CODE_END_OF_DATA
...

static ACTIV_BASE_EXPORTED_API StatusCode Activ::File::Remove ( const std::string & fileName ) [static]

Remove a file.

Parameters:
fileName the file to remove.
Return values:
STATUS_CODE_SUCCESS
...

static ACTIV_BASE_EXPORTED_API StatusCode Activ::File::Rename | ( | const std::string & | sourceFileName,
 |  | const std::string & | targetFileName,
 |  | bool | replaceExisting = false |
 | ) |  |  | [static]

Rename a file.

Parameters:
sourceFileName | the name of the existing file.
targetFileName | the name of the new file.
replaceExisting | whether an existing file should be overwritten.
Return values:
STATUS_CODE_SUCCESS
...

static ACTIV_BASE_EXPORTED_API StatusCode Activ::File::SearchPath | ( | const std::string & | fileName,
 |  | std::string & | fullyQualifiedFileName |
 | ) |  |  | [static]

Search the current path for a file.

NB the current directory is always included in the search.

Parameters:
fileName | the file (without any directory component) to search for.
fullyQualifiedFileName | reference to a string to receive the path + filename of the found file.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_FOUND
STATUS_CODE_FAILURE
...

ACTIV_BASE_EXPORTED_API StatusCode Activ::File::SetPosition | ( | int64_t | position,
 |  | const SeekMethod | seekMethod = SEEK_METHOD_BEGIN
 | ) |  |

Set the current position within the file.

Parameters:
position | the position within the file.
seekMethod | the seek method.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_OPEN
...

ACTIV_BASE_EXPORTED_API StatusCode Activ::File::SetSize ( int64_t size )

Set the size of the file.

Parameters:
size the size of the file.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_OPEN
...

static ACTIV_BASE_EXPORTED_API void Activ::File::SplitPath | ( | const std::string & | path,
 |  | std::string & | directory,
 |  | std::string & | fileName |
 | ) |  |  | [static]

Get the directory and filename from a path.

SplitPath() will not append a trailing directory separator to directory unless it is a root directory. Some examples:

    path                    directory       fileName
    c:                      c:
    c:\                     c:\
    \                       \
    \file                   \               file
    ..\..\                  ..\..
    c:\dir1\dir2\file       c:\dir1\dir2    file
    dir1\dir2\file          dir1\dir2       file

    /                       /
    /file                   /               file
    ../../                  ../..
    /dir1/dir2/file         /dir1/dir2      file
    dir1/dir2/file          dir1/dir2       file
    ~                       ~
    ~/file                  ~               file
    ~/dir/                  ~/dir
    ~/dir/file              ~/dir           file
    ~user                   ~user
    ~user/file              ~user           file
    ~user/dir/              ~user/dir
    ~user/dir/file          ~user/dir       file

    SplitPath() does not do any checking that the trailing path component is in fact a file.
    For instance, the following is possible:

    /dir1/dir2/dir3         /dir1/dir2      dir3
Parameters:
path | the path to split.
directory | to receive the directory component of path.
fileName | to receive the file name component of path.

ACTIV_BASE_EXPORTED_API StatusCode Activ::File::Write | ( | const void * | pBuffer,
 |  | const size_t | nBytesToWrite
 | ) |  |

Write to a file.

Parameters:
pBuffer | the buffer to write from.
nBytesToWrite | the number of bytes to write.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_OPEN
STATUS_CODE_FAILURE
...

ACTIV_BASE_EXPORTED_API StatusCode Activ::File::Write | ( | const void * | pBuffer,
 |  | const size_t | nBytesToWrite,
 |  | size_t & | nBytesWritten
 | ) |  |

Write to a file.

Parameters:
pBuffer | the buffer to write from.
nBytesToWrite | the number of bytes to write.
nBytesWritten | the number of bytes written.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_OPEN
...

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivBase/File.h
Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::FileInfo

Activ::FileInfo Class Reference

FileInfo class. More...

#include <ActivMiddleware/Misc/IFtpHelper.h>

List of all members.

Public Member Functions

FileInfo ()
Default constructor.
bool | operator!= (const FileInfo &fileInfo) const
compare the time of two FileInfo to deterimine if they are not equal.
bool | operator== (const FileInfo &fileInfo) const
compare the time of two FileInfo to deterimine if they are equal.

Static Public Member Functions

static bool | IsNameGreater (const FileInfo &first, const FileInfo &second)
compare the names of two FileInfo to deterimine which one is greater.
static bool | IsSizeGreater (const FileInfo &first, const FileInfo &second)
compare the size of two FileInfo to deterimine which one is greater.
static bool | IsTimeGreater (const FileInfo &first, const FileInfo &second)
compare the time of two FileInfo to deterimine which one is greater.
static bool | IsTimeLess (const FileInfo &first, const FileInfo &second)
compare the time of two FileInfo to deterimine which one is lesser.

Public Attributes

std::string | m_directory
The name of the directory.
DateTime m_fileTime
The modification date and time.
std::string | m_name
The name of the file.
int64_t | m_size
The size of the file.

Detailed Description

FileInfo class.

This FileInfo class wraps up file info from curllib

Definition at line 33 of file IFtpHelper.h.

Member Function Documentation

bool Activ::FileInfo::IsNameGreater | ( | const FileInfo & | first,
 |  | const FileInfo & | second |
 | ) |  |  | [inline, static]

compare the names of two FileInfo to deterimine which one is greater.

Parameters:
first | the first FileInfo
second | the second FileInfo
return true if greater

Definition at line 273 of file IFtpHelper.h.

References m_name.

bool Activ::FileInfo::IsSizeGreater | ( | const FileInfo & | first,
 |  | const FileInfo & | second |
 | ) |  |  | [inline, static]

compare the size of two FileInfo to deterimine which one is greater.

Parameters:
first | the first FileInfo
second | the second FileInfo
return true if greater

Definition at line 280 of file IFtpHelper.h.

References m_size.

bool Activ::FileInfo::IsTimeGreater | ( | const FileInfo & | first,
 |  | const FileInfo & | second |
 | ) |  |  | [inline, static]

compare the time of two FileInfo to deterimine which one is greater.

Parameters:
first | the first FileInfo
second | the second FileInfo
return true if greater

Definition at line 287 of file IFtpHelper.h.

References m_fileTime.

bool Activ::FileInfo::IsTimeLess | ( | const FileInfo & | first,
 |  | const FileInfo & | second |
 | ) |  |  | [inline, static]

compare the time of two FileInfo to deterimine which one is lesser.

Parameters:
first | the first FileInfo
second | the second FileInfo
return true if lesser

Definition at line 294 of file IFtpHelper.h.

References m_fileTime.

bool Activ::FileInfo::operator!= ( const FileInfo & fileInfo ) const [inline]

compare the time of two FileInfo to deterimine if they are not equal.

Parameters:
fileInfo the fileInfo to compare
return true if equal

Definition at line 308 of file IFtpHelper.h.

bool Activ::FileInfo::operator== ( const FileInfo & fileInfo ) const [inline]

compare the time of two FileInfo to deterimine if they are equal.

Parameters:
fileInfo the fileInfo to compare
return true if equal

Definition at line 301 of file IFtpHelper.h.

References m_name.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/Misc/IFtpHelper.h
Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::FileMappedMemoryFactory

Activ::FileMappedMemoryFactory Class Reference

File mapped memory factory class. More...

#include <ActivMiddleware/ActivBase/FileMappedMemoryFactory.h>

Inheritance diagram for Activ::FileMappedMemoryFactory:

Activ::Singleton< T >

List of all members.

Public Member Functions

ACTIV_BASE_EXPORTED_API
IFileMappedMemory * 		Create (const std::string &fileName, const size_t size, const bool canShare, const IFileMappedMemory::FileFlags fileFlags=IFileMappedMemory::FILE_FLAG_NONE, const IMappedMemory::MappingFlags mappingFlags=IMappedMemory::MAPPING_FLAG_NONE)
Create a memory mapped file that can be shared via name.
ACTIV_BASE_EXPORTED_API
IFileMappedMemory * 		Open (const std::string &fileName, const IFileMappedMemory::FileFlags fileFlags=IFileMappedMemory::FILE_FLAG_NONE, const IMappedMemory::MappingFlags mappingFlags=IMappedMemory::MAPPING_FLAG_NONE, Timeout &timeout=Timeout::GetInfinite())
Open an existing memory mapped file.

Static Public Member Functions

static ACTIV_BASE_EXPORTED_API
FileMappedMemoryFactory & 		GetInstance ()
Get a reference to the singleton instance.

Friends

class Singleton< FileMappedMemoryFactory >

Detailed Description

File mapped memory factory class.

Definition at line 25 of file FileMappedMemoryFactory.h.

Member Function Documentation

ACTIV_BASE_EXPORTED_API IFileMappedMemory* Activ::FileMappedMemoryFactory::Create | ( | const std::string & | fileName,
 |  | const size_t | size,
 |  | const bool | canShare,
 |  | const IFileMappedMemory::FileFlags | fileFlags = IFileMappedMemory::FILE_FLAG_NONE,
 |  | const IMappedMemory::MappingFlags | mappingFlags = IMappedMemory::MAPPING_FLAG_NONE
 | ) |  |

Create a memory mapped file that can be shared via name.

Parameters:
fileName | the name of the file to map into memory.
size | the size to the memory segment to be mapped.
canShare | flag indicating whether the memory mapped file can be shared.
fileFlags | flags to use when creating or opening the file.
mappingFlags | flags to use when creating the mapped memory segment.
Returns:
Pointer to an object providing an IFileMappedMemory interface.
Exceptions:
Exception

static ACTIV_BASE_EXPORTED_API FileMappedMemoryFactory& Activ::FileMappedMemoryFactory::GetInstance ( ) [static]

Get a reference to the singleton instance.

Returns:
Reference.

ACTIV_BASE_EXPORTED_API IFileMappedMemory* Activ::FileMappedMemoryFactory::Open | ( | const std::string & | fileName,
 |  | const IFileMappedMemory::FileFlags | fileFlags = IFileMappedMemory::FILE_FLAG_NONE,
 |  | const IMappedMemory::MappingFlags | mappingFlags = IMappedMemory::MAPPING_FLAG_NONE,
 |  | Timeout & | timeout = Timeout::GetInfinite()
 | ) |  |

Open an existing memory mapped file.

Parameters:
fileName | the name of the file to map into memory.
fileFlags | flags to use when creating or opening the file.
mappingFlags | flags to use when creating the mapped memory segment.
timeout | object specifying how long to wait for the memory mapped file to exist, in ms.
Returns:
pointer to an object providing an IFileMappedMemory interface.
Exceptions:
Exception

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivBase/FileMappedMemoryFactory.h
Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::FirstBitField

Activ::FirstBitField< T, LENGTH_VALUE > Class Template Reference

Initial (0 offset) bit field helper class. More...

#include <ActivMiddleware/Misc/BitFields.h>

Inheritance diagram for Activ::FirstBitField< T, LENGTH_VALUE >:

Activ::BitField< T, 0, LENGTH_VALUE >

List of all members.

Detailed Description

template<typename T, size_t LENGTH_VALUE>
class Activ::FirstBitField< T, LENGTH_VALUE >

Initial (0 offset) bit field helper class.

Parameters:
T | type of the bitmap (uin8_t, uint16_t, etc.).
LENGTH_VALUE | length of the bitfield in bits.

Definition at line 136 of file BitFields.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/Misc/BitFields.h
Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::FtpHelper

Activ::FtpHelper Class Reference

FtpHelper class. More...

#include <ActivMiddleware/Misc/FtpHelper.h>

List of all members.

Public Types

enum | FtpType { CURL_FTP, WIN_FTP }
Ftp type.

Public Member Functions

StatusCodeHelper Connect ()
Connect to the server.
StatusCodeHelper | DeleteFile (const FileInfoList &fileInfoList, const std::string &remoteDirectory="")
StatusCodeHelper | DeleteFile (const std::string &remoteFilename, const std::string &remoteDirectory="")
Delete a file.
StatusCodeHelper Disconnect ()
Disconnects from the server.
FtpHelper (const std::string &server, const std::string &username="", const std::string &password="", uint32_t port=IFtpHelper::DEFAULT_FTP_PORT, FtpType ftpType=CURL_FTP)
Constuctor.
StatusCodeHelper | GetAndDeleteFile (const std::string &remoteFilename, const std::string &localFilename, const std::string &remoteDirectory="")
Get and delete a file.
StatusCodeHelper | GetFile (const std::string &remoteFilename, const std::string &localFilename, const std::string &remoteDirectory="")
Get a file.
StatusCodeHelper | GetFileList (FileInfoList &fileList, const std::string &remoteDirectory="")
Get the names of files from the server.
bool | IsConnected () const
Is connected.
~FtpHelper ()
Destructor.

Protected Attributes

IFtpHelper * m_pFtpHelper
ftp helper

Detailed Description

FtpHelper class.

Definition at line 38 of file FtpHelper.h.

Constructor & Destructor Documentation

Activ::FtpHelper::FtpHelper | ( | const std::string & | server,
 |  | const std::string & | username = "",
 |  | const std::string & | password = "",
 |  | uint32_t | port = IFtpHelper::DEFAULT_FTP_PORT,
 |  | FtpType | ftpType = CURL_FTP |
 | ) |  |  | [inline]

Constuctor.

Parameters:
server | the name of the ftp server.
username | the user name if required.
password | the password if required.
port | the ftp port to connect to.
ftpType | the FtpType

Definition at line 127 of file FtpHelper.h.

References ACTIV_THROW, and m_pFtpHelper.

Member Function Documentation

StatusCodeHelper Activ::FtpHelper::DeleteFile | ( | const std::string & | remoteFilename,
 |  | const std::string & | remoteDirectory = "" |
 | ) |  |  | [inline]

Delete a file.

Parameters:
remoteFilename | the name of the file to delete
remoteDirectory | where the remoteFilename lives

Definition at line 192 of file FtpHelper.h.

References Activ::IFtpHelper::DeleteFile(), and m_pFtpHelper.

StatusCodeHelper Activ::FtpHelper::GetAndDeleteFile | ( | const std::string & | remoteFilename,
 |  | const std::string & | localFilename,
 |  | const std::string & | remoteDirectory = "" |
 | ) |  |  | [inline]

Get and delete a file.

Parameters:
remoteFilename | the name of the file to get and delete
localFilename | the save as name of the remoteFilename
remoteDirectory | where the remoteFilename lives

Definition at line 206 of file FtpHelper.h.

References Activ::IFtpHelper::GetAndDeleteFile(), and m_pFtpHelper.

StatusCodeHelper Activ::FtpHelper::GetFile | ( | const std::string & | remoteFilename,
 |  | const std::string & | localFilename,
 |  | const std::string & | remoteDirectory = "" |
 | ) |  |  | [inline]

Get a file.

Parameters:
remoteFilename | the name of the file to get
localFilename | the save as name of the remoteFilename
remoteDirectory | where the remoteFilename lives

Definition at line 185 of file FtpHelper.h.

References Activ::IFtpHelper::GetFile(), and m_pFtpHelper.

StatusCodeHelper Activ::FtpHelper::GetFileList | ( | FileInfoList & | fileList,
 |  | const std::string & | remoteDirectory = "" |
 | ) |  |  | [inline]

Get the names of files from the server.

Parameters:
fileList | the names of the files found on the server.
remoteDirectory | the from which to get the file names from

Definition at line 178 of file FtpHelper.h.

References Activ::IFtpHelper::GetFileList(), and m_pFtpHelper.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/Misc/FtpHelper.h
Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Greater

Activ::Greater< T, RHS > Class Template Reference

Greater than comparison object where the right hand side is constant. More...

#include <ActivMiddleware/BasicTypes.h>

List of all members.

Public Member Functions

BOOST_STATIC_ASSERT (boost::is_integral< T >::value)
bool operator() (const T lhs) const

Detailed Description

template<typename T, T RHS>
class Activ::Greater< T, RHS >

Greater than comparison object where the right hand side is constant.

This is a long winded work around GCC warning "comparison is always false due to limited range of data type"

Definition at line 919 of file BasicTypes.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/BasicTypes.h
Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::HandleManager

Activ::HandleManager< T > Class Template Reference

HandleManager class. More...

#include <ActivMiddleware/Misc/HandleManager.h>

List of all members.

Public Member Functions

HandleManager (HANDLE *pHandles, const size_t numberOfHandles)
Constructor.
HandleManager ()
Default constructor.
void | Initialize (HANDLE *pHandles, const size_t numberOfHandles)
Initialize.
StatusCode | Wait (const TimeoutPeriod timeoutPeriod)
Wait for notification on handles.

Detailed Description

template<typename T>
class Activ::HandleManager< T >

HandleManager class.

T should be a class that derives from HandleManager and provides a void OnEvent(size_t index) function which will be invoked for each signalled handle during a Wait() call, eg:

class MyHandleManager : public HandleManager<MyHandleManager> { public: void OnEvent(const size_t index) { // index is the index into the HANDLE array (as passed to the constructor or Initialize() call) // of the signalled handle. } };

Definition at line 38 of file HandleManager.h.

Constructor & Destructor Documentation

template<typename T>
Activ::HandleManager< T >::HandleManager | ( | HANDLE * | pHandles,
 |  | const size_t | numberOfHandles |
 | ) |  |  | [inline]

Constructor.

Parameters:
pHandles | pointer to an array of handles to manage.
numberOfHandles | size of pHandles.

Definition at line 107 of file HandleManager.h.

References Activ::HandleManager< T >::Initialize().

Member Function Documentation

template<typename T>
void Activ::HandleManager< T >::Initialize | ( | HANDLE * | pHandles,
 |  | const size_t | numberOfHandles |
 | ) |  |  | [inline]

Initialize.

Parameters:
pHandles | pointer to an array of handles to manage.
numberOfHandles | size of pHandles.

Definition at line 116 of file HandleManager.h.

Referenced by Activ::HandleManager< T >::HandleManager().

template<typename T>
StatusCode Activ::HandleManager< T >::Wait ( const TimeoutPeriod timeoutPeriod ) [inline]

Wait for notification on handles.

For each signalled handle, T::OnEvent(index) will be invoked.

Parameters:
timeoutPeriod in ms.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_TIMEOUT
...

Definition at line 145 of file HandleManager.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/Misc/HandleManager.h
Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::HeapMessage

Activ::HeapMessage Class Reference

Heap message class. More...

#include <ActivMiddleware/ActivSystem/HeapMessage.h>

List of all members.

Public Member Functions

ACTIV_SYSTEM_EXPORTED_API
StatusCode 		Append (const void *pData, const size_t dataLength)
Append data.
ACTIV_SYSTEM_EXPORTED_API
StatusCode 		Attach (HeapMessage &heapMessage)
Attach another message to this object.
ACTIV_SYSTEM_INLINE_API Iterator | Begin () const
Get an iterator to the first message in the container.
ACTIV_SYSTEM_EXPORTED_API
StatusCode 		Clone (const HeapMessage &sourceHeapMessage, IHeap *const pHeap=0)
Clone another message.
ACTIV_SYSTEM_EXPORTED_API
StatusCode 		Copy (MessageBuilder &messageBuilder, size_t &dataLength) const
Copy data.
ACTIV_SYSTEM_EXPORTED_API
StatusCode 		Copy (const size_t offset, MessageBuilder &messageBuilder, const size_t dataLength) const
Copy data.
ACTIV_SYSTEM_EXPORTED_API
StatusCode 		Copy (void *pData, const size_t dataSize, size_t &dataLength) const
Copy data.
ACTIV_SYSTEM_EXPORTED_API
StatusCode 		Copy (const size_t offset, void *pData, const size_t dataLength) const
Copy data.
ACTIV_SYSTEM_INLINE_API Iterator | End () const
Get an iterator that points to beyond the last message in the container.
ACTIV_SYSTEM_EXPORTED_API
StatusCode 		Erase (const size_t offset, const size_t dataLength)
Erase data.
ACTIV_SYSTEM_EXPORTED_API
StatusCode 		Extend (const size_t size)
Extend the message.
ACTIV_SYSTEM_EXPORTED_API
StatusCode 		Get (ScatterBufferHelper &scatterBufferHelper, size_t &dataLength) const
Get data.
ACTIV_SYSTEM_EXPORTED_API
StatusCode 		Get (const size_t offset, ScatterBufferHelper &scatterBufferHelper, const size_t dataLength) const
Get data.
ACTIV_SYSTEM_EXPORTED_API
StatusCode 		Get (const size_t offset, const void *&pData, const size_t dataLength, size_t &dataLengthRead) const
Get data.
ACTIV_SYSTEM_EXPORTED_API
StatusCode 		Get (const void *&pData, size_t &dataLength, void *pGetBuffer=0, const size_t getBufferSize=0) const
Get data.
ACTIV_SYSTEM_EXPORTED_API
StatusCode 		Get (const size_t offset, const void *&pData, const size_t dataLength, void *pGetBuffer=0) const
Get data.
ACTIV_SYSTEM_EXPORTED_API size_t | GetCapacity () const
Get the current maximum message length.
ACTIV_SYSTEM_EXPORTED_API Address & | GetDestinationAddress () const
Get the destination address.
ACTIV_SYSTEM_EXPORTED_API
const HeapId 		GetHeapId () const
Get the heap id.
ACTIV_SYSTEM_EXPORTED_API
IpAddress & 		GetIpAddress () const
Get the ip address.
ACTIV_SYSTEM_EXPORTED_API size_t | GetLength () const
Get the message length.
ACTIV_SYSTEM_EXPORTED_API
RequestId & 		GetRequestId () const
Get the request id.
ACTIV_SYSTEM_EXPORTED_API Address & | GetReturnAddress () const
Get the return address.
ACTIV_SYSTEM_EXPORTED_API Address & | GetSourceAddress () const
Get the source address.
ACTIV_SYSTEM_EXPORTED_API
StatusCode 		GetStatusCode () const
Get the message status code.
ACTIV_SYSTEM_EXPORTED_API Subject & | GetSubject () const
Get a reference to the message subject.
ACTIV_SYSTEM_EXPORTED_API
const MessageType 		GetType () const
Get the message type.
ACTIV_BASE_INLINE_API | HeapMessage (HeapMessage &rhs)
Copy constructor.
ACTIV_BASE_INLINE_API | HeapMessage (Proxy proxy)
Constructor.
ACTIV_BASE_INLINE_API | HeapMessage ()
Default Constructor.
ACTIV_SYSTEM_EXPORTED_API
StatusCode 		IncrementLength (size_t length)
Increment the message length.
ACTIV_SYSTEM_EXPORTED_API
StatusCode 		Insert (const size_t offset, const void *pData, const size_t dataLength)
Insert data.
ACTIV_SYSTEM_INLINE_API bool | IsMessageAttached () const
Is a message attached.
ACTIV_BASE_INLINE_API | operator bool () const
Boolean cast operator.
ACTIV_SYSTEM_INLINE_API | operator Proxy ()
Cast to Proxy object operator.
ACTIV_BASE_INLINE_API bool | operator! () const
Logical not operator.
ACTIV_BASE_INLINE_API bool | operator!= (const HeapMessage &rhs) const
Inequality operator.
ACTIV_BASE_INLINE_API HeapMessage & | operator= (HeapMessage &rhs)
Assignment operator.
ACTIV_BASE_INLINE_API HeapMessage & | operator= (Proxy proxy)
Assignment operator.
ACTIV_BASE_INLINE_API bool | operator== (const HeapMessage &rhs) const
Equality operator.
ACTIV_SYSTEM_EXPORTED_API
StatusCode 		Overwrite (const size_t offset, const void *pData, const size_t dataLength)
Overwrite data.
ACTIV_SYSTEM_INLINE_API void | Release ()
Release the message pointer.
ACTIV_SYSTEM_INLINE_API void | Return ()
Return a message to its heap if one is attached.
ACTIV_SYSTEM_EXPORTED_API void | SetDestinationAddress (const Address &destinationAddress)
Set the destination address.
ACTIV_SYSTEM_EXPORTED_API void | SetIpAddress (const IpAddress &ipAddress)
Set the ip address.
ACTIV_SYSTEM_EXPORTED_API
StatusCode 		SetLength (size_t length)
Set the message length.
ACTIV_SYSTEM_EXPORTED_API void | SetRequestId (const RequestId requestId)
Set the syncronous request id.
ACTIV_SYSTEM_EXPORTED_API void | SetReturnAddress (const Address &returnAddress)
Set the return address.
ACTIV_SYSTEM_EXPORTED_API void | SetSourceAddress (const Address &sourceAddress)
Set the source address.
ACTIV_SYSTEM_EXPORTED_API void | SetStatusCode (const StatusCode statusCode)
Set the message status code.
ACTIV_SYSTEM_EXPORTED_API void | SetSubject (const Subject &subject)
Set the message subject.
ACTIV_SYSTEM_EXPORTED_API void | SetType (const MessageType type)
Set the message type.
ACTIV_SYSTEM_EXPORTED_API
std::string 		ToHexDumpString (const size_t bytesPerLine=16) const
Build a hex dump of a message contents.
ACTIV_BASE_INLINE_API | ~HeapMessage ()
Destructor.

Friends

class | HeapMessageAccessor
class | PrivateHeap
class | SharedHeap

Classes

class | Iterator
Heap message iterator class. More...
class | Proxy
Proxy class for non-const copy construction.
class | ReadHelper
Heap message read helper class. More...
class | Stats
Status for a single HeapMessage, ignoring chaining. More...
class | WriteHelper
Heap message write helper class. More...

Detailed Description

Heap message class.

Definition at line 33 of file HeapMessage.h.

Constructor & Destructor Documentation

Activ::HeapMessage::HeapMessage ( Proxy proxy ) [inline]

Constructor.

Parameters:
proxy Proxy object to construct from.

Definition at line 1125 of file HeapMessage.h.

Activ::HeapMessage::HeapMessage ( HeapMessage & rhs ) [inline]

Copy constructor.

Parameters:
rhs the value to assign to this object.

Definition at line 1114 of file HeapMessage.h.

References Release().

Member Function Documentation

ACTIV_SYSTEM_EXPORTED_API StatusCode Activ::HeapMessage::Append | ( | const void * | pData,
 |  | const size_t | dataLength
 | ) |  |

Append data.

Parameters:
pData | the address of the data to append to the message.
dataLength | the length of the data to append to the message.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_FAILURE

ACTIV_SYSTEM_EXPORTED_API StatusCode Activ::HeapMessage::Attach ( HeapMessage & heapMessage )

Attach another message to this object.

Parameters:
heapMessage reference to the message to be attached.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER

HeapMessage::Iterator Activ::HeapMessage::Begin ( ) const [inline]

Get an iterator to the first message in the container.

Returns:
an iterator object.

Definition at line 1227 of file HeapMessage.h.

Referenced by Activ::HeapMessage::WriteHelper::Initialize(), Activ::HeapMessage::ReadHelper::Initialize(), Activ::HeapMessage::ReadHelper::ReadHelper(), and Activ::HeapMessage::WriteHelper::WriteHelper().

ACTIV_SYSTEM_EXPORTED_API StatusCode Activ::HeapMessage::Clone | ( | const HeapMessage & | sourceHeapMessage,
 |  | IHeap *const | pHeap = 0
 | ) |  |

Clone another message.

Parameters:
sourceHeapMessage | reference to the message to be cloned.
pHeap | heap to get message copy from. Default is same heap as sourceHeapMessage.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_HEAP_EMPTY
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_FAILURE

ACTIV_SYSTEM_EXPORTED_API StatusCode Activ::HeapMessage::Copy | ( | MessageBuilder & | messageBuilder,
 |  | size_t & | dataLength |
 | ) |  |  | const

Copy data.

Parameters:
messageBuilder | the message builder.
dataLength | the length copied.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_HEAP_EMPTY

ACTIV_SYSTEM_EXPORTED_API StatusCode Activ::HeapMessage::Copy | ( | const size_t | offset,
 |  | MessageBuilder & | messageBuilder,
 |  | const size_t | dataLength |
 | ) |  |  | const

Copy data.

Parameters:
offset | the offset at which to copy data from the message.
messageBuilder | the message builder.
dataLength | the length to copy.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_HEAP_EMPTY

ACTIV_SYSTEM_EXPORTED_API StatusCode Activ::HeapMessage::Copy | ( | void * | pData,
 |  | const size_t | dataSize,
 |  | size_t & | dataLength |
 | ) |  |  | const

Copy data.

Parameters:
pData | the address to copy data to.
dataSize | the size of data.
dataLength | the length copied.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER

ACTIV_SYSTEM_EXPORTED_API StatusCode Activ::HeapMessage::Copy | ( | const size_t | offset,
 |  | void * | pData,
 |  | const size_t | dataLength |
 | ) |  |  | const

Copy data.

Parameters:
offset | the offset at which to copy data from the message.
pData | the address to copy data to.
dataLength | the length to copy.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER

HeapMessage::Iterator Activ::HeapMessage::End ( ) const [inline]

Get an iterator that points to beyond the last message in the container.

Returns:
an iterator object.

Definition at line 1234 of file HeapMessage.h.

ACTIV_SYSTEM_EXPORTED_API StatusCode Activ::HeapMessage::Erase | ( | const size_t | offset,
 |  | const size_t | dataLength
 | ) |  |

Erase data.

Parameters:
offset | the offset at which to erase in the message.
dataLength | the length of the data to erase from the message.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER

ACTIV_SYSTEM_EXPORTED_API StatusCode Activ::HeapMessage::Extend ( const size_t size )

Extend the message.

Parameters:
size the size to extend the message by.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_HEAP_EMPTY

ACTIV_SYSTEM_EXPORTED_API StatusCode Activ::HeapMessage::Get | ( | ScatterBufferHelper & | scatterBufferHelper,
 |  | size_t & | dataLength |
 | ) |  |  | const

Get data.

Parameters:
scatterBufferHelper | the scatter buffer helper.
dataLength | the length got.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_HEAP_EMPTY

ACTIV_SYSTEM_EXPORTED_API StatusCode Activ::HeapMessage::Get | ( | const size_t | offset,
 |  | ScatterBufferHelper & | scatterBufferHelper,
 |  | const size_t | dataLength |
 | ) |  |  | const

Get data.

Parameters:
offset | the offset at which to copy data from the message.
scatterBufferHelper | the scatter buffer helper.
dataLength | the length to get.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_HEAP_EMPTY

ACTIV_SYSTEM_EXPORTED_API StatusCode Activ::HeapMessage::Get | ( | const size_t | offset,
 |  | const void *& | pData,
 |  | const size_t | dataLength,
 |  | size_t & | dataLengthRead |
 | ) |  |  | const

Get data.

If the requested data is in a contiguous block, then dataLengthRead will be dataLength, otherwise dataLengthRead will be the size of the available contiguous portion. In both cases, pData will point to within the message.

Parameters:
offset | the offset at which to copy data from the message.
pData | reference to the address of the data.
dataLength | the length to get.
dataLengthRead | the length read.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER

ACTIV_SYSTEM_EXPORTED_API StatusCode Activ::HeapMessage::Get | ( | const void *& | pData,
 |  | size_t & | dataLength,
 |  | void * | pGetBuffer = 0,
 |  | const size_t | getBufferSize = 0 |
 | ) |  |  | const

Get data.

If the requested data is in a contiguous block, then no copying is required and pData will be point to within the message. If not, the requested data will be copied into either pGetBuffer (if it's non zero and big enough) or a newly allocated block of memory and pData will point to that.

Parameters:
pData | reference to the address of the data.
dataLength | the length got.
pGetBuffer | buffer to be used if data not contiguous.
getBufferSize | the size of the get buffer.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_HEAP_EMPTY

ACTIV_SYSTEM_EXPORTED_API StatusCode Activ::HeapMessage::Get | ( | const size_t | offset,
 |  | const void *& | pData,
 |  | const size_t | dataLength,
 |  | void * | pGetBuffer = 0 |
 | ) |  |  | const

Get data.

If the requested data is in a contiguous block, then no copying is required and pData will be point to within the message. If not, the requested data will be copied into either pGetBuffer (if it's non zero) or a newly allocated block of memory and pData will point to that.

Parameters:
offset | the offset at which to copy data from the message.
pData | reference to the address of the data.
dataLength | the length to get.
pGetBuffer | buffer to be used if data not contiguous.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_HEAP_EMPTY

Referenced by Activ::HeapMessageDeserializer< MESSAGE_TYPE, BUFFER_SIZE >::Initialize().

ACTIV_SYSTEM_EXPORTED_API size_t Activ::HeapMessage::GetCapacity ( ) const

Get the current maximum message length.

Returns:
The current maximum message length.

ACTIV_SYSTEM_EXPORTED_API Address& Activ::HeapMessage::GetDestinationAddress ( ) const

Get the destination address.

Returns:
The destination address.

ACTIV_SYSTEM_EXPORTED_API const HeapId Activ::HeapMessage::GetHeapId ( ) const

Get the heap id.

Returns:
The heap id.

ACTIV_SYSTEM_EXPORTED_API IpAddress& Activ::HeapMessage::GetIpAddress ( ) const

Get the ip address.

Returns:
The ip address stored in the message.

ACTIV_SYSTEM_EXPORTED_API size_t Activ::HeapMessage::GetLength ( ) const

Get the message length.

Returns:
The current message length.

Referenced by Activ::HeapMessage::WriteHelper::GetLength(), and Activ::HeapMessage::ReadHelper::GetLength().

ACTIV_SYSTEM_EXPORTED_API RequestId& Activ::HeapMessage::GetRequestId ( ) const

Get the request id.

Returns:
A reference to the request id.

ACTIV_SYSTEM_EXPORTED_API Address& Activ::HeapMessage::GetReturnAddress ( ) const

Get the return address.

Returns:
The return address.

ACTIV_SYSTEM_EXPORTED_API Address& Activ::HeapMessage::GetSourceAddress ( ) const

Get the source address.

Returns:
The source address.

ACTIV_SYSTEM_EXPORTED_API StatusCode Activ::HeapMessage::GetStatusCode ( ) const

Get the message status code.

Returns:
The message status code.

Referenced by Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::IsCompleteResponse(), Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::IsValidResponse(), and Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::IsValidResponse().

ACTIV_SYSTEM_EXPORTED_API Subject& Activ::HeapMessage::GetSubject ( ) const

Get a reference to the message subject.

Returns:
Reference to the message subject.

ACTIV_SYSTEM_EXPORTED_API const MessageType Activ::HeapMessage::GetType ( ) const

Get the message type.

Returns:
The message type.

ACTIV_SYSTEM_EXPORTED_API StatusCode Activ::HeapMessage::IncrementLength ( size_t length )

Increment the message length.

Parameters:
length the amount to increment the message length by.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER

ACTIV_SYSTEM_EXPORTED_API StatusCode Activ::HeapMessage::Insert | ( | const size_t | offset,
 |  | const void * | pData,
 |  | const size_t | dataLength
 | ) |  |

Insert data.

Parameters:
offset | the offset at which to insert in the message.
pData | the address of the data to place in the message.
dataLength | the length of the data to place in the message.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_FAILURE

bool Activ::HeapMessage::IsMessageAttached ( ) const [inline]

Is a message attached.

Returns:
whether a message is attached to this object.

Definition at line 1220 of file HeapMessage.h.

Referenced by operator bool(), and operator!().

Activ::HeapMessage::operator bool ( ) const [inline]

Boolean cast operator.

Returns:
whether a message is attached to the object.

Definition at line 1198 of file HeapMessage.h.

References IsMessageAttached().

bool Activ::HeapMessage::operator! ( ) const [inline]

Logical not operator.

Returns:
whether a message is attached to the object.

Definition at line 1191 of file HeapMessage.h.

References IsMessageAttached().

bool Activ::HeapMessage::operator!= ( const HeapMessage & rhs ) const [inline]

Inequality operator.

Returns:
whether the two objects are not equal.

Definition at line 1184 of file HeapMessage.h.

HeapMessage & Activ::HeapMessage::operator= ( HeapMessage & rhs ) [inline]

Assignment operator.

Parameters:
rhs the value to assign to this object.
Returns:
a reference to this object.

Definition at line 1157 of file HeapMessage.h.

References Activ::HeapMessage::WriteHelper::Initialize(), Activ::HeapMessage::ReadHelper::Initialize(), m_pMessage, m_pSystem, Release(), and Return().

HeapMessage & Activ::HeapMessage::operator= ( Proxy proxy ) [inline]

Assignment operator.

Parameters:
proxy Proxy object to assign from.
Returns:
a reference to this object.

Definition at line 1142 of file HeapMessage.h.

References Activ::HeapMessage::WriteHelper::Initialize(), Activ::HeapMessage::ReadHelper::Initialize(), and Return().

bool Activ::HeapMessage::operator== ( const HeapMessage & rhs ) const [inline]

Equality operator.

Returns:
whether the two objects are equal.

Definition at line 1177 of file HeapMessage.h.

References m_pMessage, and m_pSystem.

ACTIV_SYSTEM_EXPORTED_API StatusCode Activ::HeapMessage::Overwrite | ( | const size_t | offset,
 |  | const void * | pData,
 |  | const size_t | dataLength
 | ) |  |

Overwrite data.

Parameters:
offset | the offset at which to overwrite in the message.
pData | the address of the data to place in the message.
dataLength | the length of the data to place in the message.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_FAILURE

ACTIV_SYSTEM_EXPORTED_API void Activ::HeapMessage::SetDestinationAddress ( const Address & destinationAddress )

Set the destination address.

Parameters:
destinationAddress the destination address.

ACTIV_SYSTEM_EXPORTED_API void Activ::HeapMessage::SetIpAddress ( const IpAddress & ipAddress )

Set the ip address.

Parameters:
ipAddress the ip address to set.

ACTIV_SYSTEM_EXPORTED_API StatusCode Activ::HeapMessage::SetLength ( size_t length )

Set the message length.

Parameters:
length the length of the message.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER

Referenced by Activ::HeapMessageBuilder::GetHeapMessage().

ACTIV_SYSTEM_EXPORTED_API void Activ::HeapMessage::SetRequestId ( const RequestId requestId )

Set the syncronous request id.

Parameters:
requestId the synchronous request id.

ACTIV_SYSTEM_EXPORTED_API void Activ::HeapMessage::SetReturnAddress ( const Address & returnAddress )

Set the return address.

Parameters:
returnAddress the return address.

ACTIV_SYSTEM_EXPORTED_API void Activ::HeapMessage::SetSourceAddress ( const Address & sourceAddress )

Set the source address.

Parameters:
sourceAddress the source address.

ACTIV_SYSTEM_EXPORTED_API void Activ::HeapMessage::SetStatusCode ( const StatusCode statusCode )

Set the message status code.

Parameters:
statusCode the new message status code.

ACTIV_SYSTEM_EXPORTED_API void Activ::HeapMessage::SetSubject ( const Subject & subject )

Set the message subject.

Parameters:
subject reference to subject to set.

ACTIV_SYSTEM_EXPORTED_API void Activ::HeapMessage::SetType ( const MessageType type )

Set the message type.

Parameters:
type the message type.

ACTIV_SYSTEM_EXPORTED_API std::string Activ::HeapMessage::ToHexDumpString ( const size_t bytesPerLine = 16 ) const

Build a hex dump of a message contents.

Parameters:
bytesPerLine number of bytes to display per line.
Returns:
Formatted hex dump of the message.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivSystem/HeapMessage.h
Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::HeapMessage::Iterator

Activ::HeapMessage::Iterator Class Reference

Heap message iterator class. More...

#include <ActivMiddleware/ActivSystem/HeapMessage.h>

List of all members.

Public Member Functions

ACTIV_SYSTEM_INLINE_API | Iterator ()
Default constructor.
ACTIV_SYSTEM_INLINE_API
MessageImpl & 		operator * ()
Dereference operator.
ACTIV_SYSTEM_INLINE_API bool | operator!= (const Iterator &rhs) const
Inequality operator.
ACTIV_SYSTEM_INLINE_API const
Iterator 		operator++ (int)
Postfix increment operator.
ACTIV_SYSTEM_EXPORTED_API
Iterator & 		operator++ ()
Prefix increment operator.
ACTIV_SYSTEM_INLINE_API
MessageImpl * 		operator-> ()
Member access operator.
ACTIV_SYSTEM_INLINE_API bool | operator== (const Iterator &rhs) const
Equality operator.

Friends

class | HeapMessage

Detailed Description

Heap message iterator class.

Definition at line 56 of file HeapMessage.h.

Member Function Documentation

MessageImpl & Activ::HeapMessage::Iterator::operator * ( ) [inline]

Dereference operator.

Returns:
Reference to the current message.

Definition at line 1271 of file HeapMessage.h.

bool Activ::HeapMessage::Iterator::operator!= ( const Iterator & rhs ) const [inline]

Inequality operator.

Parameters:
rhs the object to test against.
Returns:
whether the two objects are not equal.

Definition at line 1303 of file HeapMessage.h.

const HeapMessage::Iterator Activ::HeapMessage::Iterator::operator++ ( int ) [inline]

Postfix increment operator.

Returns:
Copy of the original object.

Definition at line 1285 of file HeapMessage.h.

ACTIV_SYSTEM_EXPORTED_API Iterator& Activ::HeapMessage::Iterator::operator++ ( )

Prefix increment operator.

Returns:
Reference to the updated object.

MessageImpl * Activ::HeapMessage::Iterator::operator-> ( ) [inline]

Member access operator.

Returns:
Pointer to the current message.

Definition at line 1278 of file HeapMessage.h.

bool Activ::HeapMessage::Iterator::operator== ( const Iterator & rhs ) const [inline]

Equality operator.

Parameters:
rhs the object to test against.
Returns:
whether the two objects are equal.

Definition at line 1296 of file HeapMessage.h.

References m_pHeapMessage, and m_pMessage.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivSystem/HeapMessage.h
Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::HeapMessage::ReadHelper

Activ::HeapMessage::ReadHelper Class Reference

Heap message read helper class. More...

#include <ActivMiddleware/ActivSystem/HeapMessage.h>

List of all members.

Public Member Functions

ACTIV_SYSTEM_EXPORTED_API
StatusCode 		AdjustGetBufferSize (const size_t getBufferSize) const
Adjust the get buffer size.
ACTIV_SYSTEM_EXPORTED_API
StatusCode 		Copy (MessageBuilder &messageBuilder, const size_t dataLength)
Copy data from the message.
ACTIV_SYSTEM_EXPORTED_API
StatusCode 		Copy (WriteHelper &writeHelper, const size_t dataLength)
Copy data from the message.
ACTIV_SYSTEM_EXPORTED_API
StatusCode 		Copy (void *pData, const size_t dataLength)
Copy data from the message.
ACTIV_SYSTEM_EXPORTED_API
StatusCode 		Get (ScatterBufferHelper &scatterBufferHelper, const size_t dataLength)
Get data from the message.
ACTIV_SYSTEM_EXPORTED_API
StatusCode 		Get (const void *&pData, const size_t dataLength, size_t &dataLengthRead)
Get data from the message.
ACTIV_SYSTEM_EXPORTED_API
StatusCode 		Get (const void *&pData, const size_t dataLength, void *pGetBuffer=0)
Get data from the message.
ACTIV_SYSTEM_INLINE_API size_t | GetLength () const
Get the the message length.
ACTIV_SYSTEM_INLINE_API size_t | GetOffset () const
Get the offset within the message.
ACTIV_SYSTEM_EXPORTED_API
StatusCode 		IncrementOffset (const size_t increment)
Increment the offset within the message.
ACTIV_SYSTEM_INLINE_API void | Initialize ()
Initialize with the existing heap message object.
ACTIV_SYSTEM_INLINE_API void | Initialize (const HeapMessage &heapMessage)
Initialize with a new heap message object.
ACTIV_SYSTEM_INLINE_API
ReadHelper & 		operator= (const ReadHelper &rhs)
Assignment operator.
ACTIV_SYSTEM_INLINE_API | ReadHelper (const WriteHelper &rhs)
Constructor.
ACTIV_SYSTEM_INLINE_API | ReadHelper (const ReadHelper &rhs)
Copy constructor.
ACTIV_SYSTEM_INLINE_API | ReadHelper (const HeapMessage &heapMessage)
Constructor.
ACTIV_SYSTEM_INLINE_API | ReadHelper ()
Default constructor.
ACTIV_SYSTEM_EXPORTED_API
StatusCode 		SetOffset (const size_t offset)
Set the offset within the message.
ACTIV_SYSTEM_INLINE_API | ~ReadHelper ()
Destructor.

Friends

class | WriteHelper

Detailed Description

Heap message read helper class.

Definition at line 138 of file HeapMessage.h.

Constructor & Destructor Documentation

Activ::HeapMessage::ReadHelper::ReadHelper ( const HeapMessage & heapMessage ) [inline]

Constructor.

Parameters:
heapMessage the underlying heap message object.

Definition at line 1330 of file HeapMessage.h.

References Activ::HeapMessage::Begin().

Activ::HeapMessage::ReadHelper::ReadHelper ( const ReadHelper & rhs ) [inline]

Copy constructor.

Parameters:
rhs the value to assign to this object.
Exceptions:
StatusCodeException

Definition at line 1342 of file HeapMessage.h.

Activ::HeapMessage::ReadHelper::ReadHelper ( const WriteHelper & rhs ) [inline]

Constructor.

Parameters:
rhs the value to assign to this object.

Definition at line 1354 of file HeapMessage.h.

Member Function Documentation

ACTIV_SYSTEM_EXPORTED_API StatusCode Activ::HeapMessage::ReadHelper::AdjustGetBufferSize ( const size_t getBufferSize ) const

Adjust the get buffer size.

Parameters:
getBufferSize the size of the get buffer.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_HEAP_EMPTY

ACTIV_SYSTEM_EXPORTED_API StatusCode Activ::HeapMessage::ReadHelper::Copy | ( | MessageBuilder & | messageBuilder,
 |  | const size_t | dataLength
 | ) |  |

Copy data from the message.

Parameters:
messageBuilder | the message builder.
dataLength | the length to copy.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
...

ACTIV_SYSTEM_EXPORTED_API StatusCode Activ::HeapMessage::ReadHelper::Copy | ( | WriteHelper & | writeHelper,
 |  | const size_t | dataLength
 | ) |  |

Copy data from the message.

Parameters:
writeHelper | the place to copy to.
dataLength | the length to copy.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_FAILURE

ACTIV_SYSTEM_EXPORTED_API StatusCode Activ::HeapMessage::ReadHelper::Copy | ( | void * | pData,
 |  | const size_t | dataLength
 | ) |  |

Copy data from the message.

Parameters:
pData | the address to copy to.
dataLength | the length to copy.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER

ACTIV_SYSTEM_EXPORTED_API StatusCode Activ::HeapMessage::ReadHelper::Get | ( | ScatterBufferHelper & | scatterBufferHelper,
 |  | const size_t | dataLength
 | ) |  |

Get data from the message.

Parameters:
scatterBufferHelper | the scatter buffer helper.
dataLength | the length to get.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_HEAP_EMPTY

ACTIV_SYSTEM_EXPORTED_API StatusCode Activ::HeapMessage::ReadHelper::Get | ( | const void *& | pData,
 |  | const size_t | dataLength,
 |  | size_t & | dataLengthRead
 | ) |  |

Get data from the message.

Parameters:
pData | reference to the address of the data.
dataLength | the length to get.
dataLengthRead | the length read.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER

ACTIV_SYSTEM_EXPORTED_API StatusCode Activ::HeapMessage::ReadHelper::Get | ( | const void *& | pData,
 |  | const size_t | dataLength,
 |  | void * | pGetBuffer = 0
 | ) |  |

Get data from the message.

Parameters:
pData | reference to the address of the data.
dataLength | the length to get.
pGetBuffer | buffer to be used if data not contiguous.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_HEAP_EMPTY

size_t Activ::HeapMessage::ReadHelper::GetLength ( ) const [inline]

Get the the message length.

Returns:
the message length.

Definition at line 1408 of file HeapMessage.h.

References Activ::HeapMessage::GetLength().

size_t Activ::HeapMessage::ReadHelper::GetOffset ( ) const [inline]

Get the offset within the message.

Returns:
the offset within the message.

Definition at line 1415 of file HeapMessage.h.

ACTIV_SYSTEM_EXPORTED_API StatusCode Activ::HeapMessage::ReadHelper::IncrementOffset ( const size_t increment )

Increment the offset within the message.

Parameters:
increment the value to increment the offset by.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER

void Activ::HeapMessage::ReadHelper::Initialize ( const HeapMessage & heapMessage ) [inline]

Initialize with a new heap message object.

Parameters:
heapMessage the underlying heap message object.

Definition at line 1389 of file HeapMessage.h.

References Activ::HeapMessage::Begin().

Referenced by Activ::HeapMessage::operator=().

HeapMessage::ReadHelper & Activ::HeapMessage::ReadHelper::operator= ( const ReadHelper & rhs ) [inline]

Assignment operator.

Parameters:
rhs the value to assign to this object.
Returns:
a reference to this object.
Exceptions:
StatusCodeException

Definition at line 1374 of file HeapMessage.h.

References m_absoluteOffset, m_iterator, m_pHeapMessage, and m_relativeOffset.

ACTIV_SYSTEM_EXPORTED_API StatusCode Activ::HeapMessage::ReadHelper::SetOffset ( const size_t offset )

Set the offset within the message.

Parameters:
offset the value to set the offset to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivSystem/HeapMessage.h
Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::HeapMessage::Stats

Activ::HeapMessage::Stats Class Reference

Status for a single HeapMessage, ignoring chaining. More...

#include <ActivMiddleware/ActivSystem/HeapMessage.h>

List of all members.

Public Attributes

BucketId | m_bucketId
Address | m_destinationAddress
size_t | m_freeSpace
HeapId | m_heapId
std::string | m_hexDump
Hex dump of message body.
IpAddress | m_ipAddress
MessageId | m_messageId
RequestId | m_requestId
Address | m_returnAddress
Address | m_sourceAddress
StatusCode | m_statusCode
Subject | m_subject
size_t | m_totalSpace
MessageType | m_type

Detailed Description

Status for a single HeapMessage, ignoring chaining.

Definition at line 514 of file HeapMessage.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivSystem/HeapMessage.h
Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::HeapMessage::WriteHelper

Activ::HeapMessage::WriteHelper Class Reference

Heap message write helper class. More...

#include <ActivMiddleware/ActivSystem/HeapMessage.h>

List of all members.

Public Member Functions

ACTIV_SYSTEM_EXPORTED_API
StatusCode 		Copy (ReadHelper &readHelper, const size_t dataLength)
Copy data to the message.
ACTIV_SYSTEM_EXPORTED_API
StatusCode 		Copy (const void *pData, const size_t dataLength)
Copy data to the message.
ACTIV_SYSTEM_EXPORTED_API
StatusCode 		Get (void *&pData, const size_t dataLength, size_t &dataLengthWritten)
Get data from the message.
ACTIV_BASE_INLINE_API size_t | GetLength () const
Get the the message length.
ACTIV_BASE_INLINE_API size_t | GetOffset () const
Get the offset within the message.
ACTIV_SYSTEM_EXPORTED_API
StatusCode 		IncrementOffset (const size_t increment, const bool updateLength=false)
Increment the offset within the message.
ACTIV_BASE_INLINE_API void | Initialize ()
Initialize with the existing heap message object.
ACTIV_BASE_INLINE_API void | Initialize (HeapMessage &heapMessage)
Initialize with a new heap message object.
ACTIV_SYSTEM_EXPORTED_API
StatusCode 		SetOffset (const size_t offset, const bool updateLength=false)
Set the offset within the message.
ACTIV_BASE_INLINE_API | WriteHelper (const ReadHelper &rhs)
Constructor.
ACTIV_BASE_INLINE_API | WriteHelper (HeapMessage &heapMessage)
Constructor.
ACTIV_BASE_INLINE_API | WriteHelper ()
Default constructor.

Friends

class | ReadHelper

Detailed Description

Heap message write helper class.

Definition at line 365 of file HeapMessage.h.

Constructor & Destructor Documentation

Activ::HeapMessage::WriteHelper::WriteHelper ( HeapMessage & heapMessage ) [inline]

Constructor.

Parameters:
heapMessage the underlying heap message object.

Definition at line 1432 of file HeapMessage.h.

References Activ::HeapMessage::Begin().

Activ::HeapMessage::WriteHelper::WriteHelper ( const ReadHelper & rhs ) [inline]

Constructor.

Parameters:
rhs the value to assign to this object.

Definition at line 1442 of file HeapMessage.h.

Member Function Documentation

ACTIV_SYSTEM_EXPORTED_API StatusCode Activ::HeapMessage::WriteHelper::Copy | ( | ReadHelper & | readHelper,
 |  | const size_t | dataLength
 | ) |  |

Copy data to the message.

Parameters:
readHelper | the place to copy from.
dataLength | the length to copy.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_FAILURE

ACTIV_SYSTEM_EXPORTED_API StatusCode Activ::HeapMessage::WriteHelper::Copy | ( | const void * | pData,
 |  | const size_t | dataLength
 | ) |  |

Copy data to the message.

Parameters:
pData | the address to copy from.
dataLength | the length to copy.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_FAILURE

ACTIV_SYSTEM_EXPORTED_API StatusCode Activ::HeapMessage::WriteHelper::Get | ( | void *& | pData,
 |  | const size_t | dataLength,
 |  | size_t & | dataLengthWritten
 | ) |  |

Get data from the message.

Parameters:
pData | reference to the address of the data.
dataLength | the length got.
dataLengthWritten | the length written.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_FAILURE

size_t Activ::HeapMessage::WriteHelper::GetLength ( ) const [inline]

Get the the message length.

Returns:
the message length.

Definition at line 1471 of file HeapMessage.h.

References Activ::HeapMessage::GetLength().

size_t Activ::HeapMessage::WriteHelper::GetOffset ( ) const [inline]

Get the offset within the message.

Returns:
the offset within the message.

Definition at line 1478 of file HeapMessage.h.

ACTIV_SYSTEM_EXPORTED_API StatusCode Activ::HeapMessage::WriteHelper::IncrementOffset | ( | const size_t | increment,
 |  | const bool | updateLength = false
 | ) |  |

Increment the offset within the message.

Parameters:
increment | the value to increment the offset by.
updateLength | whether the message length can be updated.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_FAILURE

void Activ::HeapMessage::WriteHelper::Initialize ( HeapMessage & heapMessage ) [inline]

Initialize with a new heap message object.

Parameters:
heapMessage the underlying heap message object.

Definition at line 1452 of file HeapMessage.h.

References Activ::HeapMessage::Begin().

Referenced by Activ::HeapMessage::operator=().

ACTIV_SYSTEM_EXPORTED_API StatusCode Activ::HeapMessage::WriteHelper::SetOffset | ( | const size_t | offset,
 |  | const bool | updateLength = false
 | ) |  |

Set the offset within the message.

Parameters:
offset | the value to set the offset to.
updateLength | whether the message length can be updated.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_FAILURE

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivSystem/HeapMessage.h
Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::HeapMessageBuilder

Activ::HeapMessageBuilder Class Reference

Helper class to build directly into a contiguous HeapMessage. More...

#include <ActivMiddleware/ActivSystem/HeapMessageBuilder.h>

List of all members.

Public Member Functions

void GetHeapMessage (HeapMessage &heapMessage)
Get the built HeapMessage.
MessageBuilder & GetMessageBuilder ()
Get the underlying MessageBuilder.
HeapMessageBuilder (IHeap *const pHeap, const size_t approximateSize, const MessageBuilder::MessageVersion messageVersion=MessageBuilder::MESSAGE_VERSION_UNDEFINED)
Constructor.

Detailed Description

Helper class to build directly into a contiguous HeapMessage.

Definition at line 23 of file HeapMessageBuilder.h.

Constructor & Destructor Documentation

Activ::HeapMessageBuilder::HeapMessageBuilder | ( | IHeap *const | pHeap,
 |  | const size_t | approximateSize,
 |  | const MessageBuilder::MessageVersion | messageVersion = MessageBuilder::MESSAGE_VERSION_UNDEFINED |
 | ) |  |  | [inline]

Constructor.

Parameters:
pHeap | the heap to get the HeapMessage from.
approximateSize | the approximate size of the message that will be built. A HeapMessage of size approximateSize will be allocated from pHeap.
messageVersion | optional version passed through to the underlying MessageBuilder.

Definition at line 67 of file HeapMessageBuilder.h.

References ACTIV_THROW, and Activ::MessageBuilder::Initialize().

Member Function Documentation

void Activ::HeapMessageBuilder::GetHeapMessage ( HeapMessage & heapMessage ) [inline]

Get the built HeapMessage.

Returns:
HeapMessage reference. On error, no message will be attached to heapMessage (heapMessage.IsMessageAttached() will return false).

Definition at line 96 of file HeapMessageBuilder.h.

References Activ::MessageBuilder::GetLength(), Activ::IHeap::GetMessage(), Activ::MessageBuilder::GetMessage(), and Activ::HeapMessage::SetLength().

MessageBuilder & Activ::HeapMessageBuilder::GetMessageBuilder ( ) [inline]

Get the underlying MessageBuilder.

Returns:
Reference to MessageBuilder.

Definition at line 89 of file HeapMessageBuilder.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivSystem/HeapMessageBuilder.h
Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::HeapMessageDeserializer

Activ::HeapMessageDeserializer< MESSAGE_TYPE, BUFFER_SIZE > Class Template Reference

Template class to wrap up deserializing a HeapMessage. More...

#include <ActivMiddleware/ActivSystem/HeapMessageDeserializer.h>

List of all members.

Public Member Functions

ACTIV_SYSTEM_INLINE_API StatusCode | Deserialize (MESSAGE_TYPE &message)
Deserialize from the current position.
ACTIV_SYSTEM_INLINE_API StatusCode | Initialize (const HeapMessage &heapMessage, const MessageHandler::MessageVersion messageVersion=MessageHandler::MESSAGE_VERSION_UNDEFINED)
Initialize by getting a pointer to a contiguous block containing the contents of a HeapMessage.
ACTIV_SYSTEM_INLINE_API bool | IsEndOfMessage () const
Has all data been deserialized from the HeapMessage?
ACTIV_SYSTEM_INLINE_API StatusCode | operator() (const HeapMessage &heapMessage, MESSAGE_TYPE &message, const MessageHandler::MessageVersion messageVersion=MessageHandler::MESSAGE_VERSION_UNDEFINED)
Deserialize a the contents of a HeapMessage into an object.

Detailed Description

template<typename MESSAGE_TYPE, size_t BUFFER_SIZE>
class Activ::HeapMessageDeserializer< MESSAGE_TYPE, BUFFER_SIZE >

Template class to wrap up deserializing a HeapMessage.

Parameters:
MESSAGE_TYPE | type of message to deserialize. Must have a StatusCode Deserialize(MessageValidator &) method.
BUFFER_SIZE | default size of the internal buffer to use when message body is not contiguous.

Definition at line 25 of file HeapMessageDeserializer.h.

Member Function Documentation

template<typename MESSAGE_TYPE, size_t BUFFER_SIZE>
StatusCode Activ::HeapMessageDeserializer< MESSAGE_TYPE, BUFFER_SIZE >::Deserialize ( MESSAGE_TYPE & message ) [inline]

Deserialize from the current position.

Parameters:
message object to deserialize into.
Return values:
STATUS_CODE_SUCCESS
...

Definition at line 101 of file HeapMessageDeserializer.h.

Referenced by Activ::HeapMessageDeserializer< MESSAGE_TYPE, BUFFER_SIZE >::operator()().

template<typename MESSAGE_TYPE, size_t BUFFER_SIZE>
StatusCode Activ::HeapMessageDeserializer< MESSAGE_TYPE, BUFFER_SIZE >::Initialize | ( | const HeapMessage & | heapMessage,
 |  | const MessageHandler::MessageVersion | messageVersion = MessageHandler::MESSAGE_VERSION_UNDEFINED |
 | ) |  |  | [inline]

Initialize by getting a pointer to a contiguous block containing the contents of a HeapMessage.

Parameters:
heapMessage | the HeapMessage to initialize from.
messageVersion | optional message version.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_HEAP_EMPTY

Definition at line 89 of file HeapMessageDeserializer.h.

References ACTIV_RETURN_RESULT_IF, Activ::HeapMessage::Get(), and Activ::MessageValidator::Initialize().

Referenced by Activ::HeapMessageDeserializer< MESSAGE_TYPE, BUFFER_SIZE >::operator()().

template<typename MESSAGE_TYPE, size_t BUFFER_SIZE>
bool Activ::HeapMessageDeserializer< MESSAGE_TYPE, BUFFER_SIZE >::IsEndOfMessage ( ) const [inline]

Has all data been deserialized from the HeapMessage?

Return values:
true
false

Definition at line 121 of file HeapMessageDeserializer.h.

References Activ::MessageValidator::IsEndOfMessage().

Referenced by Activ::HeapMessageDeserializer< MESSAGE_TYPE, BUFFER_SIZE >::operator()().

template<typename MESSAGE_TYPE, size_t BUFFER_SIZE>
StatusCode Activ::HeapMessageDeserializer< MESSAGE_TYPE, BUFFER_SIZE >::operator() | ( | const HeapMessage & | heapMessage,
 |  | MESSAGE_TYPE & | message,
 |  | const MessageHandler::MessageVersion | messageVersion = MessageHandler::MESSAGE_VERSION_UNDEFINED |
 | ) |  |  | [inline]

Deserialize a the contents of a HeapMessage into an object.

Use this method if the HeapMessage contains only one instance of a message.

Parameters:
heapMessage | the HeapMessage to initialize from.
message | object to deserialize into.
messageVersion | optional message version.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT
STATUS_CODE_HEAP_EMPTY
...

Definition at line 109 of file HeapMessageDeserializer.h.

References ACTIV_RETURN_RESULT_IF, Activ::HeapMessageDeserializer< MESSAGE_TYPE, BUFFER_SIZE >::Deserialize(), Activ::HeapMessageDeserializer< MESSAGE_TYPE, BUFFER_SIZE >::Initialize(), and Activ::HeapMessageDeserializer< MESSAGE_TYPE, BUFFER_SIZE >::IsEndOfMessage().

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivSystem/HeapMessageDeserializer.h
Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::HeapPool

Activ::HeapPool Class Reference

Heap pool. More...

#include <ActivMiddleware/ActivSystem/HeapPool.h>

List of all members.

Public Member Functions

ACTIV_SYSTEM_EXPORTED_API size_t | Extend (const size_t numberOfHeaps)
Extend the number of heaps in the pool.
ACTIV_SYSTEM_EXPORTED_API IHeap * | Get ()
Get a heap from the pool.
ACTIV_SYSTEM_EXPORTED_API
HeapMessage 		GetMessage (const size_t dataLength, const void *const pData)
Get a message from the pool of free heaps.
ACTIV_SYSTEM_EXPORTED_API | HeapPool (ISystem *const pSystem, const IHeap::BucketInfoVector &bucketInfoVector, const size_t initialSize, const std::string &namePrefix)
Constructor.
ACTIV_SYSTEM_EXPORTED_API bool | Return (IHeap *const pHeap)
Return a heap to the pool.

Detailed Description

Heap pool.

Definition at line 23 of file HeapPool.h.

Constructor & Destructor Documentation

ACTIV_SYSTEM_EXPORTED_API Activ::HeapPool::HeapPool | ( | ISystem *const | pSystem,
 |  | const IHeap::BucketInfoVector & | bucketInfoVector,
 |  | const size_t | initialSize,
 |  | const std::string & | namePrefix
 | ) |  |

Constructor.

Parameters:
pSystem | system to create heaps in.
bucketInfoVector | size of heaps to create.
initialSize | number of heaps to create initially.
namePrefix | prefix to give to heap names.

Member Function Documentation

ACTIV_SYSTEM_EXPORTED_API size_t Activ::HeapPool::Extend ( const size_t numberOfHeaps )

Extend the number of heaps in the pool.

Parameters:
numberOfHeaps number of heaps to create.
Returns:
Number of heaps actually created.

ACTIV_SYSTEM_EXPORTED_API IHeap* Activ::HeapPool::Get ( )

Get a heap from the pool.

If no heaps are in the pool, a new heap is created.

Returns:
Pointer to a heap, or 0 if failed to create a heap.

ACTIV_SYSTEM_EXPORTED_API HeapMessage Activ::HeapPool::GetMessage | ( | const size_t | dataLength,
 |  | const void *const | pData
 | ) |  |

Get a message from the pool of free heaps.

Parameters:
dataLength
pData
Returns:
HeapMessage.

ACTIV_SYSTEM_EXPORTED_API bool Activ::HeapPool::Return ( IHeap *const pHeap )

Return a heap to the pool.

Parameters:
pHeap the heap to return.
Returns:
true if the heap was returned to the pool, or false if the heap wasn't created by this pool (and therefore has not been returned to it).

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivSystem/HeapPool.h
Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::IEndPoint

Activ::IEndPoint Class Reference

Abstract endpoint interface class. More...

#include <ActivMiddleware/ActivSystem/IEndPoint.h>

Inheritance diagram for Activ::IEndPoint:

Activ::ISyncEndPoint

List of all members.

Public Types

enum | NotificationType { ACTIV_DECLARE_ELEMENT_1_WITH_COMMA, NOTIFICATION_TYPE_MULTIPLEX = NOTIFICATION_TYPE_DEFAULT }
Endpoint data notification types.
enum | State { ACTIV_DECLARE_ELEMENT_1_WITH_COMMA }
Endpoint states.

Public Member Functions

virtual void | Clear ()=0
Remove all messages from the endpoint and return them to their heaps.
virtual void | ClearAllHighCounts ()=0
Clear all high message and byte counts.
virtual void | ClearDailyHighCounts ()=0
Clear daily high message and byte counts.
virtual void | ClearLastHighCounts ()=0
Clear last high message and byte counts.
virtual StatusCode | GetMessage (HeapMessage &heapMessage, const TimeoutPeriod timeout=ACTIV_WAIT_INFINITE)=0
Get a message from the head of the endpoint.
virtual StatusCode | GetMessages (IEndPoint *const pEndPoint, const TimeoutPeriod timeout=ACTIV_WAIT_INFINITE, size_t minBytesToRemove=0)=0
Get multiple messages from the endpoint and add to the tail of a second endpoint.
virtual StatusCode | GetNotificationHandle (HANDLE &handle) const =0
Get the underlying message notification handle, if available.
virtual State | GetState () const =0
Get the current state of the endpoint.
virtual void | GetStats (Stats &stats) const =0
Get endpoint stats.
virtual ISystem * | GetSystem () const =0
Get the system that created the endpoint.
virtual StatusCode | PostMessage (HeapMessage &heapMessage)=0
Add a message to the tail of the endpoint.
virtual StatusCode | PostMessages (IEndPoint *const pEndPoint, size_t minBytesToRemove=0)=0
Add a chain of messages to the tail of the endpoint.
virtual void | SetMaxByteCount (const size_t maxByteCount)=0
Set the maximum bytes allowed on an endpoint.
virtual void | SetState (const State state)=0
Set the state of the endpoint.
virtual StatusCode | TryPostMessages (IEndPoint *const pEndPoint)=0
Try to add a chain of messages to the tail of the endpoint.
virtual | ~IEndPoint ()=0
Destructor.

Static Public Member Functions

static
ACTIV_SYSTEM_EXPORTED_API
std::string 		NotificationTypeToString (const NotificationType notificationType)
Return an endpoint notification type in string form.
static
ACTIV_SYSTEM_EXPORTED_API
std::string 		StateToString (const State state)
Return an endpoint state in string form.
static
ACTIV_SYSTEM_EXPORTED_API
StatusCode 		StringToNotificationType (const std::string &str, NotificationType &notificationType)
Convert string to notification type.

Classes

class | Stats
Stats for an endpoint. More...

Detailed Description

Abstract endpoint interface class.

Definition at line 46 of file IEndPoint.h.

Member Function Documentation

virtual StatusCode Activ::IEndPoint::GetMessage | ( | HeapMessage & | heapMessage,
 |  | const TimeoutPeriod | timeout = ACTIV_WAIT_INFINITE |
 | ) |  |  | [pure virtual]

Get a message from the head of the endpoint.

Parameters:
heapMessage | reference to a HeapMessage object to receive the head message.
timeout | how long to wait for a message on the endpoint, in ms. Will be ignored if the object was not created with a data notification mechanism.
Return values:
STATUS_CODE_SUCCESS.
STATUS_CODE_TIMEOUT no messages on this endpoint in the timeout period, heapMessage unaffected. Note this return value is possible even with timeout set to ACTIV_WAIT_INFINITE. heapMessage will only contain a retrieved message if the return value is STATUS_CODE_SUCCESS.

virtual StatusCode Activ::IEndPoint::GetMessages | ( | IEndPoint *const | pEndPoint,
 |  | const TimeoutPeriod | timeout = ACTIV_WAIT_INFINITE,
 |  | size_t | minBytesToRemove = 0 |
 | ) |  |  | [pure virtual]

Get multiple messages from the endpoint and add to the tail of a second endpoint.

Parameters:
pEndPoint | the endpoint to add messages to.
timeout | how long to wait for a message on this endpoint, in ms. Will be ignored if the object was not created with a data notification mechanism.
minBytesToRemove | the minimum number of bytes to remove from endpoint (0 to remove all messages).
Return values:
STATUS_CODE_SUCCESS.
STATUS_CODE_DISABLED | pEndPoint is not accepting messages, all returned to their heap.
STATUS_CODE_TIMEOUT | no messages on this endpoint in the timeout period, pEndPoint unaffected.

virtual StatusCode Activ::IEndPoint::GetNotificationHandle ( HANDLE & handle ) const [pure virtual]

Get the underlying message notification handle, if available.

Parameters:
handle reference to receive the handle.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_SUPPORTED the notification type for this endpoint does not support an exportable handle.

virtual State Activ::IEndPoint::GetState ( ) const [pure virtual]

Get the current state of the endpoint.

Returns:
The state of the endpoint.

virtual void Activ::IEndPoint::GetStats ( Stats & stats ) const [pure virtual]

Get endpoint stats.

Parameters:
stats reference to a Stats object.

Implemented in Activ::ISyncEndPoint.

virtual ISystem* Activ::IEndPoint::GetSystem ( ) const [pure virtual]

Get the system that created the endpoint.

Returns:
An ISystem interface.

static ACTIV_SYSTEM_EXPORTED_API std::string Activ::IEndPoint::NotificationTypeToString ( const NotificationType notificationType ) [static]

Return an endpoint notification type in string form.

Parameters:
notificationType to convert.
Returns:
Notification type state as a string.

virtual StatusCode Activ::IEndPoint::PostMessage ( HeapMessage & heapMessage ) [pure virtual]

Add a message to the tail of the endpoint.

Parameters:
heapMessage the message to add.
Return values:
STATUS_CODE_SUCCESS | heapMessage added to the endpoint.
STATUS_CODE_DISABLED | the endpoint is not accepting messages. heapMessage returned to its heap.
STATUS_CODE_FULL | the endpoint maximum byte count has been reached. heapMessage returned to its heap.

virtual StatusCode Activ::IEndPoint::PostMessages | ( | IEndPoint *const | pEndPoint,
 |  | size_t | minBytesToRemove = 0 |
 | ) |  |  | [pure virtual]

Add a chain of messages to the tail of the endpoint.

Parameters:
pEndPoint | the chain of messages to add.
minBytesToRemove | minimum number of bytes to remove from pEndPoint and add to this endpoint.
Return values:
STATUS_CODE_SUCCESS | heapMessage added to the endpoint.
STATUS_CODE_DISABLED | the endpoint is not accepting messages. All messages returned to their heap.
STATUS_CODE_FULL | the endpoint maximum byte count has been reached. All messages returned to their heap.

virtual void Activ::IEndPoint::SetMaxByteCount ( const size_t maxByteCount ) [pure virtual]

Set the maximum bytes allowed on an endpoint.

By default there is no limit, but if set to a non 0 value, posting a message to an endpoint which takes the number of bytes on the endpoint to over maxByteCount, the call will return STATUS_CODE_FULL.

Parameters:
maxByteCount max bytes to allow on the endpoint, or 0 for no limit.

virtual void Activ::IEndPoint::SetState ( const State state ) [pure virtual]

Set the state of the endpoint.

Parameters:
state the state to set the endpoint to.

static ACTIV_SYSTEM_EXPORTED_API std::string Activ::IEndPoint::StateToString ( const State state ) [static]

Return an endpoint state in string form.

Parameters:
state to convert.
Returns:
Endpoint state as a string.

static ACTIV_SYSTEM_EXPORTED_API StatusCode Activ::IEndPoint::StringToNotificationType | ( | const std::string & | str,
 |  | NotificationType & | notificationType |
 | ) |  |  | [static]

Convert string to notification type.

Parameters:
str | the string to convert.
notificationType | to receive the notification type value.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_FOUND

virtual StatusCode Activ::IEndPoint::TryPostMessages ( IEndPoint *const pEndPoint ) [pure virtual]

Try to add a chain of messages to the tail of the endpoint.

Parameters:
pEndPoint the chain of messages to add. This must be a non-mutexed, non-notification endpoint.
Return values:
STATUS_CODE_SUCCESS | heapMessage added to the endpoint.
STATUS_CODE_FAILURE | unable to acquire mutex. Messages are left on pEndPoint.
STATUS_CODE_DISABLED | the endpoint is not accepting messages. All messages returned to their heap.
STATUS_CODE_FULL | the endpoint maximum byte count has been reached. All messages returned to their heap.
STATUS_CODE_INVALID_PARAMETER | pEndPoint isn't an endpoint that can be used with this method.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivSystem/IEndPoint.h
Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::IEndPoint::Stats

Activ::IEndPoint::Stats Class Reference

Stats for an endpoint. More...

#include <ActivMiddleware/ActivSystem/IEndPoint.h>

Inheritance diagram for Activ::IEndPoint::Stats:

Activ::ISyncEndPoint::Stats

List of all members.

Public Member Functions

ACTIV_SYSTEM_EXPORTED_API
StatusCode 		Deserialize (MessageValidator &messageValidator)
Deserialize.
ACTIV_SYSTEM_EXPORTED_API
StatusCode 		Serialize (MessageBuilder &messageBuilder) const
Serialize.

Public Attributes

size_t | m_byteCount
current number of bytes on endpoint
size_t | m_byteCountDailyHigh
daily high number of bytes on endpoint
size_t | m_byteCountHigh
all-time high number of bytes on endpoint
size_t | m_byteCountLastHigh
high number of bytes on endpoint in last stats interval
ProcessId | m_creatorProcessId
pid of the process that created the endpoint
bool | m_hasMutex
does the endpoint have a mutex?
size_t | m_messageCount
current number of messages on endpoint
size_t | m_messageCountDailyHigh
daily high number of messages on endpoint
size_t | m_messageCountHigh
all-time high number of messages on endpoint
size_t | m_messageCountLastHigh
high number of messages on endpoint in last stats interval
size_t | m_mutexContentionCount
approx. contentions on the endpoint's mutex
NotificationType m_notificationType
message notification type
State | m_state

Detailed Description

Stats for an endpoint.

Definition at line 76 of file IEndPoint.h.

Member Function Documentation

ACTIV_SYSTEM_EXPORTED_API StatusCode Activ::IEndPoint::Stats::Deserialize ( MessageValidator & messageValidator )

Deserialize.

Parameters:
messageValidator
Return values:
STATUS_CODE_SUCCESS
...

Reimplemented in Activ::ISyncEndPoint::Stats.

ACTIV_SYSTEM_EXPORTED_API StatusCode Activ::IEndPoint::Stats::Serialize ( MessageBuilder & messageBuilder ) const

Serialize.

Parameters:
messageBuilder
Return values:
STATUS_CODE_SUCCESS
...

Reimplemented in Activ::ISyncEndPoint::Stats.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivSystem/IEndPoint.h
Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::IEvent

Activ::IEvent Class Reference

Abstract base event class. More...

#include <ActivMiddleware/ActivBase/IEvent.h>

List of all members.

Public Types

typedef uint32_t | Flags
Flags for event creation.

Public Member Functions

virtual StatusCode | Clear ()=0
Clear the event.
virtual StatusCode | GetHandle (HANDLE &handle) const =0
Get the underlying handle, if available.
virtual StatusCode | Set ()=0
Set the event.
virtual StatusCode | Wait (const TimeoutPeriod timeout=ACTIV_WAIT_INFINITE)=0
Wait for the event to be signaled.
virtual | ~IEvent ()=0
Destructor.

Static Public Attributes

static const Flags | FLAG_MANUAL = 0x00000001
Manual reset event.
static const Flags | FLAG_NONE = 0x00000000

Detailed Description

Abstract base event class.

Definition at line 20 of file IEvent.h.

Member Function Documentation

virtual StatusCode Activ::IEvent::Clear ( ) [pure virtual]

Clear the event.

Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_FAILURE

virtual StatusCode Activ::IEvent::GetHandle ( HANDLE & handle ) const [pure virtual]

Get the underlying handle, if available.

Parameters:
handle reference to receive the handle.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_SUPPORTED the object does not support an exportable handle.

virtual StatusCode Activ::IEvent::Set ( ) [pure virtual]

Set the event.

Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_FAILURE

virtual StatusCode Activ::IEvent::Wait ( const TimeoutPeriod timeout = ACTIV_WAIT_INFINITE ) [pure virtual]

Wait for the event to be signaled.

Parameters:
timeout how long to wait for the event, in ms.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_FAILURE
STATUS_CODE_TIMEOUT

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivBase/IEvent.h
Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::IFieldType

Activ::IFieldType Class Reference

Field type interface class. More...

#include <ActivMiddleware/ActivFieldTypes/IFieldType.h>

Inheritance diagram for Activ::IFieldType:

Activ::BinaryArray Activ::BinaryString Activ::Blob Activ::CrcBlob Activ::Date Activ::DateTime Activ::Rational Activ::SInt Activ::TextArray Activ::TextString Activ::Time Activ::TRational Activ::UInt

List of all members.

Public Member Functions

ACTIV_FIELD_TYPES_API StatusCode | Assign (const IFieldType *const pIFieldType)
Assign the value of this from another IFieldType object.
virtual void | Clear ()=0
Clear the object.
virtual StatusCode | Compare (const void *const pRhsSerializedBody, const size_t rhsSerializedBodyLength, int &result) const =0
Compare.
virtual StatusCode | Convert (const IFieldType *const pIFieldType)=0
Convert another IFieldType object to this type.
virtual StatusCode | Deserialize (MessageValidator &messageValidator, const size_t maxSerializedBodyLength)=0
Deserialize the object from the supplied message validator.
ACTIV_FIELD_TYPES_API StatusCode | Deserialize (const FieldType fieldType, MessageValidator &messageValidator, const size_t maxSerializedBodyLength)
Deserialize the object from the supplied message validator.
virtual StatusCode | DeserializeBody (const void *const pSerializedBody, const size_t serializedBodyLength)=0
Deserialize the object's body from the supplied data buffer.
ACTIV_FIELD_TYPES_API StatusCode | DeserializeBody (const FieldType fieldType, const void *const pSerializedBody, const size_t serializedBodyLength)
Deserialize the object's body from the supplied data buffer.
virtual StatusCode | DeserializeLengthAndBody (MessageValidator &messageValidator, const size_t maxSerializedBodyLength=MAX_SERIALIZED_BODY_LENGTH_UNDEFINED)=0
Deserialize the object's length and body from the supplied message validator.
ACTIV_FIELD_TYPES_API StatusCode | DeserializeLengthAndBody (const FieldType fieldType, MessageValidator &messageValidator, const size_t maxSerializedBodyLength=MAX_SERIALIZED_BODY_LENGTH_UNDEFINED)
Deserialize the object's length and body from the supplied message validator.
StatusCode | FromString (const std::string &field)
Convert the object from a string.
virtual StatusCode | FromString (MessageValidator &messageValidator)=0
Convert the object from a string.
virtual std::string | GetFromStringFormat () const =0
Get a usage string for the format supported by FromString().
virtual size_t | GetSerializedBodyLength () const =0
Get the serialized length of the object's body.
virtual size_t | GetSerializedLength () const =0
Get the serialized length of the object.
FieldType | GetType () const
Get the field type.
virtual StatusCode | IsDifferent (const void *const pRhsSerializedBody, const size_t rhsSerializedBodyLength, bool &isDifferent) const =0
Is different.
bool | IsInitialized () const
Is the object initialized.
virtual void | Reset ()=0
Reset the object.
virtual StatusCode | Serialize (MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength) const =0
Serialize the object into the supplied message builder.
ACTIV_FIELD_TYPES_API StatusCode | Serialize (const FieldType fieldType, MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength) const
Serialize the object into the supplied message builder.
virtual StatusCode | SerializeBody (void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength) const =0
Serialize the object's body into the supplied data buffer.
ACTIV_FIELD_TYPES_API StatusCode | SerializeBody (const FieldType fieldType, void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength) const
Serialize the object's body into the supplied data buffer.
virtual StatusCode | SerializeLengthAndBody (MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength=MAX_SERIALIZED_BODY_LENGTH_UNDEFINED) const =0
Serialize the object's length and body into the supplied message builder.
ACTIV_FIELD_TYPES_API StatusCode | SerializeLengthAndBody (const FieldType fieldType, MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength=MAX_SERIALIZED_BODY_LENGTH_UNDEFINED) const
Serialize the object's length and body into the supplied message builder.
virtual std::string | ToString () const =0
Convert the object to a string.
virtual | ~IFieldType ()=0
Destructor.

Static Public Member Functions

static ACTIV_FIELD_TYPES_API bool | IsValidSerializedBodyLength (const FieldType fieldType, const size_t serializedBodyLength)
Is valid serialized body length.
static ACTIV_FIELD_TYPES_API
StatusCode 		Serialize (const FieldType fieldType, MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength, const uint8_t *const pData, const size_t size)
Serialize the object into the supplied message builder.
static ACTIV_FIELD_TYPES_API
StatusCode 		SerializeBody (const FieldType fieldType, void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength, const uint8_t *const pData, const size_t size)
Serialize the object's body into the supplied data buffer.
static ACTIV_FIELD_TYPES_API
StatusCode 		SerializeLengthAndBody (const FieldType fieldType, MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength, const uint8_t *const pData, const size_t size)
Serialize the object's length and body into the supplied message builder.
static ACTIV_FIELD_TYPES_API
StatusCode 		ValidateSerializedLengthAndBody (const FieldType fieldType, MessageValidator &messageValidator, size_t &serializedBodyOffset, size_t &serializedBodyLength)
Validate the serialized length and body.

Static Public Attributes

static const size_t | MAX_SERIALIZED_BODY_LENGTH_UNDEFINED = static_cast<const size_t>(~0)
The undefined max serialized body length.

Protected Member Functions

IFieldType (const FieldType fieldType)
Constructor.

Protected Attributes

bool | m_isInitialized
Indicates whether the object is initialized.

Detailed Description

Field type interface class.

Definition at line 29 of file IFieldType.h.

Constructor & Destructor Documentation

Activ::IFieldType::IFieldType ( const FieldType fieldType ) [inline, explicit, protected]

Constructor.

Parameters:
fieldType the field type.

Definition at line 415 of file IFieldType.h.

Member Function Documentation

ACTIV_FIELD_TYPES_API StatusCode Activ::IFieldType::Assign ( const IFieldType *const pIFieldType )

Assign the value of this from another IFieldType object.

Parameters:
pIFieldType the value to assign from.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_MISMATCH
...

virtual StatusCode Activ::IFieldType::Compare | ( | const void *const | pRhsSerializedBody,
 |  | const size_t | rhsSerializedBodyLength,
 |  | int & | result |
 | ) |  |  | const [pure virtual]

Compare.

Parameters:
pRhsSerializedBody | the buffer containing the rhs serialized version of the object's body in.
rhsSerializedBodyLength | the rhs serialized body length.
result | the result of the comparison.
Return values:
STATUS_CODE_SUCCESS
...

Implemented in Activ::BinaryArray, Activ::BinaryString, Activ::Blob, Activ::CrcBlob, Activ::Date, Activ::DateTime, Activ::Rational, Activ::SInt, Activ::TextArray, Activ::TextString, Activ::Time, Activ::TRational, and Activ::UInt.

virtual StatusCode Activ::IFieldType::Convert ( const IFieldType *const pIFieldType ) [pure virtual]

Convert another IFieldType object to this type.

Parameters:
pIFieldType the value to assign from.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_MISMATCH
...

Implemented in Activ::BinaryArray, Activ::BinaryString, Activ::Blob, Activ::CrcBlob, Activ::Date, Activ::DateTime, Activ::Rational, Activ::SInt, Activ::TextArray, Activ::TextString, Activ::Time, Activ::TRational, and Activ::UInt.

virtual StatusCode Activ::IFieldType::Deserialize | ( | MessageValidator & | messageValidator,
 |  | const size_t | maxSerializedBodyLength |
 | ) |  |  | [pure virtual]

Deserialize the object from the supplied message validator.

Parameters:
messageValidator | the message validator from which the object will be extracted.
maxSerializedBodyLength | the maximum serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

Implemented in Activ::BinaryArray, Activ::BinaryString, Activ::Blob, Activ::CrcBlob, Activ::Date, Activ::DateTime, Activ::Rational, Activ::SInt, Activ::TextArray, Activ::TextString, Activ::Time, Activ::TRational, and Activ::UInt.

ACTIV_FIELD_TYPES_API StatusCode Activ::IFieldType::Deserialize | ( | const FieldType | fieldType,
 |  | MessageValidator & | messageValidator,
 |  | const size_t | maxSerializedBodyLength
 | ) |  |

Deserialize the object from the supplied message validator.

Parameters:
fieldType | the field type.
messageValidator | the message validator from which the object will be extracted.
maxSerializedBodyLength | the maximum serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

virtual StatusCode Activ::IFieldType::DeserializeBody | ( | const void *const | pSerializedBody,
 |  | const size_t | serializedBodyLength |
 | ) |  |  | [pure virtual]

Deserialize the object's body from the supplied data buffer.

Parameters:
pSerializedBody | the buffer from which the object's body will be extracted.
serializedBodyLength | the serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

Implemented in Activ::BinaryArray, Activ::BinaryString, Activ::Blob, Activ::CrcBlob, Activ::Date, Activ::DateTime, Activ::Rational, Activ::SInt, Activ::TextArray, Activ::TextString, Activ::Time, Activ::TRational, and Activ::UInt.

ACTIV_FIELD_TYPES_API StatusCode Activ::IFieldType::DeserializeBody | ( | const FieldType | fieldType,
 |  | const void *const | pSerializedBody,
 |  | const size_t | serializedBodyLength
 | ) |  |

Deserialize the object's body from the supplied data buffer.

Parameters:
fieldType | the field type.
pSerializedBody | the buffer from which the object's body will be extracted.
serializedBodyLength | the serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

virtual StatusCode Activ::IFieldType::DeserializeLengthAndBody | ( | MessageValidator & | messageValidator,
 |  | const size_t | maxSerializedBodyLength = MAX_SERIALIZED_BODY_LENGTH_UNDEFINED |
 | ) |  |  | [pure virtual]

Deserialize the object's length and body from the supplied message validator.

Parameters:
messageValidator | the message validator from which the object will be extracted.
maxSerializedBodyLength | the maximum serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

Implemented in Activ::BinaryArray, Activ::BinaryString, Activ::Blob, Activ::CrcBlob, Activ::Date, Activ::DateTime, Activ::Rational, Activ::SInt, Activ::TextArray, Activ::TextString, Activ::Time, Activ::TRational, and Activ::UInt.

ACTIV_FIELD_TYPES_API StatusCode Activ::IFieldType::DeserializeLengthAndBody | ( | const FieldType | fieldType,
 |  | MessageValidator & | messageValidator,
 |  | const size_t | maxSerializedBodyLength = MAX_SERIALIZED_BODY_LENGTH_UNDEFINED
 | ) |  |

Deserialize the object's length and body from the supplied message validator.

Parameters:
fieldType | the field type.
messageValidator | the message validator from which the object will be extracted.
maxSerializedBodyLength | the maximum serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

StatusCode Activ::IFieldType::FromString ( const std::string & field ) [inline]

Convert the object from a string.

Parameters:
field the field as a string.
Return values:
STATUS_CODE_SUCCESS
...

Definition at line 399 of file IFieldType.h.

References FromString().

virtual StatusCode Activ::IFieldType::FromString ( MessageValidator & messageValidator ) [pure virtual]

Convert the object from a string.

Parameters:
messageValidator the message validator.
Return values:
STATUS_CODE_SUCCESS
...

Implemented in Activ::BinaryArray, Activ::BinaryString, Activ::Blob, Activ::CrcBlob, Activ::Date, Activ::DateTime, Activ::Rational, Activ::SInt, Activ::TextArray, Activ::TextString, Activ::Time, Activ::TRational, and Activ::UInt.

Referenced by FromString().

virtual std::string Activ::IFieldType::GetFromStringFormat ( ) const [pure virtual]

Get a usage string for the format supported by FromString().

Returns:
String, may be empty.

Implemented in Activ::BinaryArray, Activ::BinaryString, Activ::Blob, Activ::CrcBlob, Activ::Date, Activ::DateTime, Activ::Rational, Activ::SInt, Activ::TextArray, Activ::TextString, Activ::Time, Activ::TRational, and Activ::UInt.

virtual size_t Activ::IFieldType::GetSerializedBodyLength ( ) const [pure virtual]

Get the serialized length of the object's body.

Returns:
the serialized length of the object's body.

Implemented in Activ::BinaryArray, Activ::BinaryString, Activ::Blob, Activ::CrcBlob, Activ::Date, Activ::DateTime, Activ::Rational, Activ::SInt, Activ::TextArray, Activ::TextString, Activ::Time, Activ::TRational, and Activ::UInt.

virtual size_t Activ::IFieldType::GetSerializedLength ( ) const [pure virtual]

Get the serialized length of the object.

Returns:
the serialized length of the object.

Implemented in Activ::BinaryArray, Activ::BinaryString, Activ::Blob, Activ::CrcBlob, Activ::Date, Activ::DateTime, Activ::Rational, Activ::SInt, Activ::TextArray, Activ::TextString, Activ::Time, Activ::TRational, and Activ::UInt.

FieldType Activ::IFieldType::GetType ( ) const [inline]

Get the field type.

Returns:
the field type.

Definition at line 392 of file IFieldType.h.

Referenced by Activ::ContentPlatform::FeedApi::FieldListValidator::Field::GetActivFieldType(), Activ::ContentPlatform::ContentGatewayApi::Tick::SetConditions(), Activ::ContentPlatform::ContentGatewayApi::Tick::SetPrice(), and Activ::ContentPlatform::ContentGatewayApi::Tick::SetSize().

virtual StatusCode Activ::IFieldType::IsDifferent | ( | const void *const | pRhsSerializedBody,
 |  | const size_t | rhsSerializedBodyLength,
 |  | bool & | isDifferent |
 | ) |  |  | const [pure virtual]

Is different.

Parameters:
pRhsSerializedBody | the buffer containing the rhs serialized version of the object's body in.
rhsSerializedBodyLength | the rhs serialized body length.
isDifferent | indicates whether the two objects are different.
Return values:
STATUS_CODE_SUCCESS
...

Implemented in Activ::BinaryArray, Activ::BinaryString, Activ::Blob, Activ::CrcBlob, Activ::Date, Activ::DateTime, Activ::Rational, Activ::SInt, Activ::TextArray, Activ::TextString, Activ::Time, Activ::TRational, and Activ::UInt.

bool Activ::IFieldType::IsInitialized ( ) const [inline]

Is the object initialized.

Returns:
whether the object has been initialized.

Definition at line 408 of file IFieldType.h.

References m_isInitialized.

Referenced by Activ::Time::Add(), Activ::DateTime::Add(), Activ::BinaryArray::BinaryArray(), Activ::BinaryString::BinaryString(), Activ::Blob::Blob(), Activ::Rational::Compress(), Activ::CrcBlob::Compress(), Activ::Blob::Compress(), Activ::CrcBlob::CrcBlob(), Activ::DateTime::DateTime(), Activ::CrcBlob::Decompress(), Activ::Blob::Decompress(), Activ::UInt::Get(), Activ::TRational::Get(), Activ::Time::Get(), Activ::TextString::Get(), Activ::TextArray::Get(), Activ::SInt::Get(), Activ::Rational::Get(), Activ::DateTime::Get(), Activ::Date::Get(), Activ::CrcBlob::Get(), Activ::Blob::Get(), Activ::BinaryString::Get(), Activ::BinaryArray::Get(), Activ::CrcBlob::GetCrc(), Activ::TextString::GetData(), Activ::TextArray::GetData(), Activ::CrcBlob::GetData(), Activ::Blob::GetData(), Activ::BinaryString::GetData(), Activ::BinaryArray::GetData(), Activ::Date::GetDay(), Activ::Date::GetDayOfWeek(), Activ::Date::GetDayOfYear(), Activ::Rational::GetDenominator(), Activ::Time::GetHour(), Activ::Time::GetLocal(), Activ::DateTime::GetLocal(), Activ::Time::GetMillisecond(), Activ::Time::GetMinute(), Activ::Date::GetMonth(), Activ::Rational::GetNumerator(), Activ::Time::GetSecond(), Activ::UInt::GetSerializedBodyLength(), Activ::Time::GetSerializedBodyLength(), Activ::TextString::GetSerializedBodyLength(), Activ::TextArray::GetSerializedBodyLength(), Activ::SInt::GetSerializedBodyLength(), Activ::Rational::GetSerializedBodyLength(), Activ::Date::GetSerializedBodyLength(), Activ::CrcBlob::GetSerializedBodyLength(), Activ::Blob::GetSerializedBodyLength(), Activ::BinaryString::GetSerializedBodyLength(), Activ::BinaryArray::GetSerializedBodyLength(), Activ::UInt::GetSerializedLength(), Activ::TextString::GetSerializedLength(), Activ::TextArray::GetSerializedLength(), Activ::SInt::GetSerializedLength(), Activ::CrcBlob::GetSerializedLength(), Activ::Blob::GetSerializedLength(), Activ::BinaryString::GetSerializedLength(), Activ::BinaryArray::GetSerializedLength(), Activ::TextString::GetSize(), Activ::TextArray::GetSize(), Activ::CrcBlob::GetSize(), Activ::Blob::GetSize(), Activ::BinaryString::GetSize(), Activ::BinaryArray::GetSize(), Activ::CrcBlob::GetSizeWhenDecompressed(), Activ::Blob::GetSizeWhenDecompressed(), Activ::TRational::GetTick(), Activ::Time::GetTotalMilliseconds(), Activ::DateTime::GetTotalMilliseconds(), Activ::TRational::GetTrendOnDay(), Activ::TRational::GetTrendOnPrevious(), Activ::Time::GetUtc(), Activ::DateTime::GetUtc(), Activ::Date::GetWeekOfYear(), Activ::Date::GetYear(), Activ::CrcBlob::IsCompressed(), Activ::Blob::IsCompressed(), Activ::TextString::operator=(), Activ::TextArray::operator=(), Activ::CrcBlob::operator=(), Activ::Blob::operator=(), Activ::BinaryString::operator=(), Activ::BinaryArray::operator=(), Activ::TRational::Set(), Activ::Rational::SetDenominator(), Activ::TRational::SetTick(), Activ::TRational::SetTrendOnDay(), Activ::TRational::SetTrendOnPrevious(), Activ::Time::Subtract(), Activ::DateTime::Subtract(), Activ::TextArray::TextArray(), and Activ::TextString::TextString().

static ACTIV_FIELD_TYPES_API bool Activ::IFieldType::IsValidSerializedBodyLength | ( | const FieldType | fieldType,
 |  | const size_t | serializedBodyLength |
 | ) |  |  | [static]

Is valid serialized body length.

Parameters:
fieldType | the field type.
serializedBodyLength | the serialized body length.
Returns:
whether the serialized body length is valid.

static ACTIV_FIELD_TYPES_API StatusCode Activ::IFieldType::Serialize | ( | const FieldType | fieldType,
 |  | MessageBuilder & | messageBuilder,
 |  | const size_t | maxSerializedBodyLength,
 |  | const uint8_t *const | pData,
 |  | const size_t | size |
 | ) |  |  | [static]

Serialize the object into the supplied message builder.

Parameters:
fieldType | the field type.
messageBuilder | the message builder to store a serialized version of the object in.
maxSerializedBodyLength | the maximum serialized body length.
pData | pointer to the data.
size | the size of the data.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_SUPPORTED
...

virtual StatusCode Activ::IFieldType::Serialize | ( | MessageBuilder & | messageBuilder,
 |  | const size_t | maxSerializedBodyLength |
 | ) |  |  | const [pure virtual]

Serialize the object into the supplied message builder.

Parameters:
messageBuilder | the message builder to store a serialized version of the object in.
maxSerializedBodyLength | the maximum serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

Implemented in Activ::BinaryArray, Activ::BinaryString, Activ::Blob, Activ::CrcBlob, Activ::Date, Activ::DateTime, Activ::Rational, Activ::SInt, Activ::TextArray, Activ::TextString, Activ::Time, Activ::TRational, and Activ::UInt.

ACTIV_FIELD_TYPES_API StatusCode Activ::IFieldType::Serialize | ( | const FieldType | fieldType,
 |  | MessageBuilder & | messageBuilder,
 |  | const size_t | maxSerializedBodyLength |
 | ) |  |  | const

Serialize the object into the supplied message builder.

Parameters:
fieldType | the field type.
messageBuilder | the message builder to store a serialized version of the object in.
maxSerializedBodyLength | the maximum serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

static ACTIV_FIELD_TYPES_API StatusCode Activ::IFieldType::SerializeBody | ( | const FieldType | fieldType,
 |  | void * | pSerializedBody,
 |  | const size_t | maxSerializedBodyLength,
 |  | size_t & | serializedBodyLength,
 |  | const uint8_t *const | pData,
 |  | const size_t | size |
 | ) |  |  | [static]

Serialize the object's body into the supplied data buffer.

Parameters:
fieldType | the field type.
pSerializedBody | the buffer to store a serialized version of the object's body in.
maxSerializedBodyLength | the maximum serialized body length.
serializedBodyLength | the serialized body length.
pData | pointer to the data.
size | the size of the data.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_SUPPORTED
...

virtual StatusCode Activ::IFieldType::SerializeBody | ( | void * | pSerializedBody,
 |  | const size_t | maxSerializedBodyLength,
 |  | size_t & | serializedBodyLength |
 | ) |  |  | const [pure virtual]

Serialize the object's body into the supplied data buffer.

Parameters:
pSerializedBody | the buffer to store a serialized version of the object's body in.
maxSerializedBodyLength | the maximum serialized body length.
serializedBodyLength | the serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

Implemented in Activ::BinaryArray, Activ::BinaryString, Activ::Blob, Activ::CrcBlob, Activ::Date, Activ::DateTime, Activ::Rational, Activ::SInt, Activ::TextArray, Activ::TextString, Activ::Time, Activ::TRational, and Activ::UInt.

ACTIV_FIELD_TYPES_API StatusCode Activ::IFieldType::SerializeBody | ( | const FieldType | fieldType,
 |  | void * | pSerializedBody,
 |  | const size_t | maxSerializedBodyLength,
 |  | size_t & | serializedBodyLength |
 | ) |  |  | const

Serialize the object's body into the supplied data buffer.

Parameters:
fieldType | the field type.
pSerializedBody | the buffer to store a serialized version of the object's body in.
maxSerializedBodyLength | the maximum serialized body length.
serializedBodyLength | the serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

static ACTIV_FIELD_TYPES_API StatusCode Activ::IFieldType::SerializeLengthAndBody | ( | const FieldType | fieldType,
 |  | MessageBuilder & | messageBuilder,
 |  | const size_t | maxSerializedBodyLength,
 |  | const uint8_t *const | pData,
 |  | const size_t | size |
 | ) |  |  | [static]

Serialize the object's length and body into the supplied message builder.

Parameters:
fieldType | the field type.
messageBuilder | the message builder to store a serialized version of the object in.
maxSerializedBodyLength | the maximum serialized body length.
pData | pointer to the data.
size | the size of the data.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_SUPPORTED
...

virtual StatusCode Activ::IFieldType::SerializeLengthAndBody | ( | MessageBuilder & | messageBuilder,
 |  | const size_t | maxSerializedBodyLength = MAX_SERIALIZED_BODY_LENGTH_UNDEFINED |
 | ) |  |  | const [pure virtual]

Serialize the object's length and body into the supplied message builder.

Parameters:
messageBuilder | the message builder to store a serialized version of the object in.
maxSerializedBodyLength | the maximum serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

Implemented in Activ::BinaryArray, Activ::BinaryString, Activ::Blob, Activ::CrcBlob, Activ::Date, Activ::DateTime, Activ::Rational, Activ::SInt, Activ::TextArray, Activ::TextString, Activ::Time, Activ::TRational, and Activ::UInt.

ACTIV_FIELD_TYPES_API StatusCode Activ::IFieldType::SerializeLengthAndBody | ( | const FieldType | fieldType,
 |  | MessageBuilder & | messageBuilder,
 |  | const size_t | maxSerializedBodyLength = MAX_SERIALIZED_BODY_LENGTH_UNDEFINED |
 | ) |  |  | const

Serialize the object's length and body into the supplied message builder.

Parameters:
fieldType | the field type.
messageBuilder | the message builder to store a serialized version of the object in.
maxSerializedBodyLength | the maximum serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

virtual std::string Activ::IFieldType::ToString ( ) const [pure virtual]

Convert the object to a string.

Returns:
the object as a string.

Implemented in Activ::BinaryArray, Activ::BinaryString, Activ::Blob, Activ::CrcBlob, Activ::Date, Activ::DateTime, Activ::Rational, Activ::SInt, Activ::TextArray, Activ::TextString, Activ::Time, Activ::TRational, and Activ::UInt.

static ACTIV_FIELD_TYPES_API StatusCode Activ::IFieldType::ValidateSerializedLengthAndBody | ( | const FieldType | fieldType,
 |  | MessageValidator & | messageValidator,
 |  | size_t & | serializedBodyOffset,
 |  | size_t & | serializedBodyLength |
 | ) |  |  | [static]

Validate the serialized length and body.

Parameters:
fieldType | the field type.
messageValidator | the message validator.
serializedBodyOffset | the serialized body offset.
serializedBodyLength | the serialized body length.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
...

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivFieldTypes/IFieldType.h
Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::IFileMappedMemory

Activ::IFileMappedMemory Class Reference

Abstract base file mapped memory class. More...

#include <ActivMiddleware/ActivBase/IFileMappedMemory.h>

Inheritance diagram for Activ::IFileMappedMemory:

Activ::IMappedMemory

List of all members.

Public Types

typedef uint32_t | FileFlags

Public Member Functions

virtual void | Flush (const size_t nBytesToFlush=0) const =0
Flush the memory mapped file to the disk.
virtual void * | Resize (const size_t size)=0
Resize a memory mapped file.
virtual | ~IFileMappedMemory ()=0
Destructor.

Static Public Attributes

static const FileFlags | FILE_FLAG_CREATE_ALWAYS = 0x00000001
Always create new file.
static const FileFlags | FILE_FLAG_DELETE_AT_CLOSE = 0x00000008
Delete the file when the handle to it is closed.
static const FileFlags | FILE_FLAG_NONE = 0x00000000
static const FileFlags | FILE_FLAG_OPEN_EXISTING = 0x00000002
Open existing file, fail if file doesn't exist.
static const FileFlags | FILE_FLAG_READ_ONLY = 0x00000004
Open file in read only mode.
static const size_t | USE_CURRENT_FILE_SIZE = 0
Used for creating a mapping of the current file size.

Detailed Description

Abstract base file mapped memory class.

Definition at line 21 of file IFileMappedMemory.h.

Member Function Documentation

virtual void Activ::IFileMappedMemory::Flush ( const size_t nBytesToFlush = 0 ) const [pure virtual]

Flush the memory mapped file to the disk.

Parameters:
nBytesToFlush the number of bytes to flush, starting from the beginning of the file. Default flush all.
Exceptions:
Exception

virtual void* Activ::IFileMappedMemory::Resize ( const size_t size ) [pure virtual]

Resize a memory mapped file.

Parameters:
size the new size of the memory mapped file.
Returns:
a pointer to the new mapped memory region.
Exceptions:
Exception

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivBase/IFileMappedMemory.h
Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::IFtpHelper

Activ::IFtpHelper Class Reference

FtpHelper class. More...

#include <ActivMiddleware/Misc/IFtpHelper.h>

Inheritance diagram for Activ::IFtpHelper:

Activ::CurlFtpHelper

List of all members.

Public Member Functions

virtual StatusCodeHelper | Connect ()=0
Connect to the server.
virtual StatusCodeHelper | DeleteFile (const FileInfoList &fileInfoList, const std::string &remoteDirectory="")=0
Delete list of file.
virtual StatusCodeHelper | DeleteFile (const std::string &remoteFilename, const std::string &remoteDirectory="")=0
Delete a file.
virtual StatusCodeHelper | Disconnect ()=0
Disconnects from the server.
virtual StatusCodeHelper | GetAndDeleteFile (const std::string &remoteFilename, const std::string &localFilename, const std::string &remoteDirectory="")=0
Get and delete a file.
virtual StatusCodeHelper | GetFile (const std::string &remoteFilename, const std::string &localFilename, const std::string &remoteDirectory="")=0
Get a file.
virtual StatusCodeHelper | GetFileList (FileInfoList &fileList, const std::string &remoteDirectory="")=0
Get the names of files from the server.
IFtpHelper (const std::string &server, const std::string &username="", const std::string &password="", uint32_t port=DEFAULT_FTP_PORT)
Constuctor.
virtual bool | IsConnected () const =0
Is connected.
void | SetPassword (const std::string &password)
void | SetPort (const uint32_t &port)
void | SetServer (const std::string &server)
void | SetUsername (const std::string &username)
virtual | ~IFtpHelper ()
Destructor.

Static Public Attributes

static const uint32_t | DEFAULT_FTP_LOW_SPEED_LIMIT = 5
The default ftp low speed limit.
static const uint32_t | DEFAULT_FTP_LOW_SPEED_TIME = 120
The default ftp low speed time.
static const uint32_t | DEFAULT_FTP_PORT = 21
The default ftp port.
static const uint32_t | DEFAULT_FTP_TIMEOUT = 300
The default ftp timeout.

Protected Attributes

std::string | m_password
The password.
uint32_t | m_port
The port number normally 21.
std::string | m_server
The name of the ftp server.
std::string | m_username
The username.

Detailed Description

FtpHelper class.

Definition at line 171 of file IFtpHelper.h.

Constructor & Destructor Documentation

Activ::IFtpHelper::IFtpHelper | ( | const std::string & | server,
 |  | const std::string & | username = "",
 |  | const std::string & | password = "",
 |  | uint32_t | port = DEFAULT_FTP_PORT |
 | ) |  |  | [inline]

Constuctor.

Parameters:
server | the name of the ftp server.
username | the user name if required.
password | the password if required.
port | the ftp port to connect to.

Definition at line 355 of file IFtpHelper.h.

Member Function Documentation

virtual StatusCodeHelper Activ::IFtpHelper::DeleteFile | ( | const FileInfoList & | fileInfoList,
 |  | const std::string & | remoteDirectory = "" |
 | ) |  |  | [pure virtual]

Delete list of file.

Parameters:
fileInfoList | file list
remoteDirectory | where the remoteFilename lives

Implemented in Activ::CurlFtpHelper.

virtual StatusCodeHelper Activ::IFtpHelper::DeleteFile | ( | const std::string & | remoteFilename,
 |  | const std::string & | remoteDirectory = "" |
 | ) |  |  | [pure virtual]

Delete a file.

Parameters:
remoteFilename | the name of the file to delete
remoteDirectory | where the remoteFilename lives

Implemented in Activ::CurlFtpHelper.

Referenced by Activ::FtpHelper::DeleteFile().

virtual StatusCodeHelper Activ::IFtpHelper::GetAndDeleteFile | ( | const std::string & | remoteFilename,
 |  | const std::string & | localFilename,
 |  | const std::string & | remoteDirectory = "" |
 | ) |  |  | [pure virtual]

Get and delete a file.

Parameters:
remoteFilename | the name of the file to get and delete
localFilename | the save as name of the remoteFilename
remoteDirectory | where the remoteFilename lives

Implemented in Activ::CurlFtpHelper.

Referenced by Activ::FtpHelper::GetAndDeleteFile().

virtual StatusCodeHelper Activ::IFtpHelper::GetFile | ( | const std::string & | remoteFilename,
 |  | const std::string & | localFilename,
 |  | const std::string & | remoteDirectory = "" |
 | ) |  |  | [pure virtual]

Get a file.

Parameters:
remoteFilename | the name of the file to get
localFilename | the save as name of the remoteFilename
remoteDirectory | where the remoteFilename lives

Implemented in Activ::CurlFtpHelper.

Referenced by Activ::FtpHelper::GetFile().

virtual StatusCodeHelper Activ::IFtpHelper::GetFileList | ( | FileInfoList & | fileList,
 |  | const std::string & | remoteDirectory = "" |
 | ) |  |  | [pure virtual]

Get the names of files from the server.

Parameters:
fileList | the names of the files found on the server.
remoteDirectory | the from which to get the file names from

Implemented in Activ::CurlFtpHelper.

Referenced by Activ::FtpHelper::GetFileList().

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/Misc/IFtpHelper.h
Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::IHeap

Activ::IHeap Class Reference

Abstract heap interface class. More...

#include <ActivMiddleware/ActivSystem/IHeap.h>

List of all members.

Public Types

typedef std::vector< BucketInfo > | BucketInfoVector
bucket info vector type

Public Member Functions

virtual HeapId | GetId () const =0
Get the unique system wide heap id.
virtual HeapMessage | GetMessage (const size_t size, const void *pData, const TimeoutPeriod timeoutPeriod)=0
Get a message or chain of messages from the heap and block if the heap is empty.
virtual HeapMessage | GetMessage (const size_t size, const void *pData)=0
Get a message or chain of messages from the heap.
virtual HeapMessage | GetMessage (const size_t size)=0
Get a message or chain of messages from the heap.
virtual std::string | GetName () const =0
Get the name of the heap.
virtual bool | GetRequestDistributionLogging () const =0
Get request distribution logging state.
virtual void | GetStats (Stats &stats) const =0
Get heap stats.
virtual ISystem * | GetSystem () const =0
Get the system that created the heap.
virtual void | ResetStats ()=0
Reset heap stats.
virtual void | SetRequestDistributionLogging (const bool shouldEnable)=0
Enable or disable request distribution logging.
virtual | ~IHeap ()=0
Destructor.

Static Public Member Functions

static
ACTIV_SYSTEM_EXPORTED_API
HeapMessage 		GetMessageFromList (const size_t size,...)
Get a message or chain of messages from a list of heaps.
static
ACTIV_SYSTEM_EXPORTED_API
StatusCode 		ReadBucketInfoVector (const IniFileParser::ConstSectionIterator &sectionIterator, IHeap::BucketInfoVector &bucketInfoVector)
Parse an ini file section and build vector of bucket infos.

Classes

class | BucketInfo
Heap bucket size information. More...
class | Stats
Heap stats. More...

Detailed Description

Abstract heap interface class.

Definition at line 29 of file IHeap.h.

Member Function Documentation

virtual HeapId Activ::IHeap::GetId ( ) const [pure virtual]

Get the unique system wide heap id.

Returns:
The heap id.

virtual HeapMessage Activ::IHeap::GetMessage | ( | const size_t | size,
 |  | const void * | pData,
 |  | const TimeoutPeriod | timeoutPeriod |
 | ) |  |  | [pure virtual]

Get a message or chain of messages from the heap and block if the heap is empty.

Parameters:
size | the maximum number of bytes the message will hold.
pData | pointer to data to copy into the message (up to size bytes).
timeoutPeriod | timeout.
Returns:
a HeapMessage object. If message allocation or data copy failed, the HeapMessage will not have an attached message.

virtual HeapMessage Activ::IHeap::GetMessage | ( | const size_t | size,
 |  | const void * | pData |
 | ) |  |  | [pure virtual]

Get a message or chain of messages from the heap.

Parameters:
size | the maximum number of bytes the message will hold.
pData | pointer to data to copy into the message (up to size bytes).
Returns:
a HeapMessage object. If message allocation or data copy failed, the HeapMessage will not have an attached message.

virtual HeapMessage Activ::IHeap::GetMessage ( const size_t size ) [pure virtual]

Get a message or chain of messages from the heap.

Parameters:
size the maximum number of bytes the message will hold.
Returns:
a HeapMessage object. If message allocation failed, the HeapMessage will not have an attached message.

Referenced by Activ::HeapMessageBuilder::GetHeapMessage().

static ACTIV_SYSTEM_EXPORTED_API HeapMessage Activ::IHeap::GetMessageFromList | ( | const size_t | size,
 |  |  | ... |
 | ) |  |  | [static]

Get a message or chain of messages from a list of heaps.

Parameters:
size the maximum number of bytes the message will hold.
... a 0 terminated list of IHeap pointers.
GetMessage() will be called on each heap until a successful allocation.

Returns:
a HeapMessage object. If message allocation fails, the HeapMessage will not have an attached message.

virtual std::string Activ::IHeap::GetName ( ) const [pure virtual]

Get the name of the heap.

Returns:
A string object containing the name of the heap.

virtual bool Activ::IHeap::GetRequestDistributionLogging ( ) const [pure virtual]

Get request distribution logging state.

Returns:
true if request distribution loggin is enabled.

virtual void Activ::IHeap::GetStats ( Stats & stats ) const [pure virtual]

Get heap stats.

Parameters:
stats reference to a stats object.

virtual ISystem* Activ::IHeap::GetSystem ( ) const [pure virtual]

Get the system that created the heap.

Returns:
An ISystem interface.

static ACTIV_SYSTEM_EXPORTED_API StatusCode Activ::IHeap::ReadBucketInfoVector | ( | const IniFileParser::ConstSectionIterator & | sectionIterator,
 |  | IHeap::BucketInfoVector & | bucketInfoVector |
 | ) |  |  | [static]

Parse an ini file section and build vector of bucket infos.

Keys in the section are of the form SIZE = NUMBER_OF_BLOCKS. The vector is NOT cleared initially, and only has BucketInfo values appended if the whole section is parsed successfully.

Parameters:
sectionIterator | iterator to an ini file section.
bucketInfoVector | vector to populate.
Return values:
STATUS_CODE_SUCCESS.
...

virtual void Activ::IHeap::SetRequestDistributionLogging ( const bool shouldEnable ) [pure virtual]

Enable or disable request distribution logging.

Parameters:
shouldEnable true to enable.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivSystem/IHeap.h
Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::IHeap::BucketInfo

Activ::IHeap::BucketInfo Class Reference

Heap bucket size information. More...

#include <ActivMiddleware/ActivSystem/IHeap.h>

List of all members.

Public Attributes

size_t | m_blockSize
size of message body in bucket
size_t | m_numBlocks
number of messages in bucket

Detailed Description

Heap bucket size information.

Definition at line 35 of file IHeap.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivSystem/IHeap.h
Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::IHeap::Stats

Activ::IHeap::Stats Class Reference

Heap stats. More...

#include <ActivMiddleware/ActivSystem/IHeap.h>

List of all members.

Public Types

typedef std::vector< BucketStats > | BucketStatsVector
typedef std::vector
< RequestDistributionStats > 		DistributionVector

Public Member Functions

ACTIV_SYSTEM_EXPORTED_API
StatusCode 		Deserialize (MessageValidator &messageValidator)
Deserialize.
ACTIV_SYSTEM_EXPORTED_API
StatusCode 		Serialize (MessageBuilder &messageBuilder) const
Serialize.

Public Attributes

BucketStatsVector | m_bucketStatsVector
stats per bucket
ProcessId | m_creatorProcessId
DistributionVector | m_distributionVector
request stats distribution
DateTime m_firstFailLocalDateTime
local date/time of first fail
HeapId | m_id
size_t | m_idealBucketFails
number of requests for a message larger than largest block size
DateTime m_lastFailLocalDateTime
local date/time of last fail
size_t | m_maxRequestSize
size of max request
size_t | m_memoryUsage
mem usage of this heap
size_t | m_mutexContentionCount
approx. contentions on the heap's mutex
std::string | m_name
size_t | m_totalCurrentFreeBlocks
current free blocks across all buckets
size_t | m_totalFails
number of GetMessage() requests that have failed
size_t | m_totalLowFreeBlocks
low of free blocks across all buckets
size_t | m_totalNumberOfBlocks

Classes

class | BucketStats
Individual Bucket stats. More...
class | RequestDistributionStats
Request distribution stats. More...

Detailed Description

Heap stats.

Definition at line 47 of file IHeap.h.

Member Function Documentation

ACTIV_SYSTEM_EXPORTED_API StatusCode Activ::IHeap::Stats::Deserialize ( MessageValidator & messageValidator )

Deserialize.

Parameters:
messageValidator
Return values:
STATUS_CODE_SUCCESS
...

ACTIV_SYSTEM_EXPORTED_API StatusCode Activ::IHeap::Stats::Serialize ( MessageBuilder & messageBuilder ) const

Serialize.

Parameters:
messageBuilder
Return values:
STATUS_CODE_SUCCESS
...

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivSystem/IHeap.h
Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::IHeap::Stats::BucketStats

Activ::IHeap::Stats::BucketStats Class Reference

Individual Bucket stats. More...

#include <ActivMiddleware/ActivSystem/IHeap.h>

List of all members.

Public Member Functions

ACTIV_SYSTEM_EXPORTED_API | BucketStats ()
Default constructor.
ACTIV_SYSTEM_EXPORTED_API
StatusCode 		Deserialize (MessageValidator &messageValidator)
Deserialize.
ACTIV_SYSTEM_EXPORTED_API
StatusCode 		Serialize (MessageBuilder &messageBuilder) const
Serialize.

Public Attributes

BucketInfo | m_bucketInfo
size_t | m_firstRunFails
number of fails when most ideal sized block
size_t | m_lowFreeBlocks
lowest number of free blocks
size_t | m_numFreeBlocks
number of free blocks
size_t | m_secondRunFails
number of fails when > ideal sized block

Detailed Description

Individual Bucket stats.

Definition at line 86 of file IHeap.h.

Member Function Documentation

ACTIV_SYSTEM_EXPORTED_API StatusCode Activ::IHeap::Stats::BucketStats::Deserialize ( MessageValidator & messageValidator )

Deserialize.

Parameters:
messageValidator
Return values:
STATUS_CODE_SUCCESS
...

ACTIV_SYSTEM_EXPORTED_API StatusCode Activ::IHeap::Stats::BucketStats::Serialize ( MessageBuilder & messageBuilder ) const

Serialize.

Parameters:
messageBuilder
Return values:
STATUS_CODE_SUCCESS
...

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivSystem/IHeap.h
Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::IHeap::Stats::RequestDistributionStats

Activ::IHeap::Stats::RequestDistributionStats Class Reference

Request distribution stats. More...

#include <ActivMiddleware/ActivSystem/IHeap.h>

List of all members.

Public Member Functions

ACTIV_SYSTEM_EXPORTED_API
StatusCode 		Deserialize (MessageValidator &messageValidator)
Deserialize.
ACTIV_SYSTEM_EXPORTED_API
StatusCode 		Serialize (MessageBuilder &messageBuilder) const
Serialize.

Public Attributes

size_t | m_count
number of requests >= m_minSize and <= m_maxSize
size_t | m_maxSize
maximum size of request
size_t | m_minSize
minimum size of request

Detailed Description

Request distribution stats.

Definition at line 53 of file IHeap.h.

Member Function Documentation

ACTIV_SYSTEM_EXPORTED_API StatusCode Activ::IHeap::Stats::RequestDistributionStats::Deserialize ( MessageValidator & messageValidator )

Deserialize.

Parameters:
messageValidator
Return values:
STATUS_CODE_SUCCESS
...

ACTIV_SYSTEM_EXPORTED_API StatusCode Activ::IHeap::Stats::RequestDistributionStats::Serialize ( MessageBuilder & messageBuilder ) const

Serialize.

Parameters:
messageBuilder
Return values:
STATUS_CODE_SUCCESS
...

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivSystem/IHeap.h
Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::IMappedMemory

Activ::IMappedMemory Class Reference

Abstract base mapped memory class. More...

#include <ActivMiddleware/ActivBase/IMappedMemory.h>

Inheritance diagram for Activ::IMappedMemory:

Activ::IFileMappedMemory

List of all members.

Public Types

typedef uint32_t | MappingFlags

Public Member Functions

virtual void * | GetPointer () const =0
Get pointer to mapped memory.
virtual size_t | GetSize () const =0
Get size of mapped memory.
virtual | ~IMappedMemory ()=0
Destructor.

Static Public Attributes

static const MappingFlags | MAPPING_FLAG_NONE = 0x00000000
static const MappingFlags | MAPPING_FLAG_READ_ONLY = 0x00000001
Read only access to the mapped memory segment.
static const MappingFlags | MAPPING_FLAG_UNIQUE = 0x00000002
A named segment cannot already exist when creating.

Detailed Description

Abstract base mapped memory class.

Definition at line 20 of file IMappedMemory.h.

Member Function Documentation

virtual void* Activ::IMappedMemory::GetPointer ( ) const [pure virtual]

Get pointer to mapped memory.

Returns:
Pointer to mapped memory.

Referenced by Activ::SharedObject< T >::Create(), and Activ::SharedObject< T >::Open().

virtual size_t Activ::IMappedMemory::GetSize ( ) const [pure virtual]

Get size of mapped memory.

Returns:
Size.

Referenced by Activ::SharedObject< T >::GetSize().

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivBase/IMappedMemory.h
Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::IMutex

Activ::IMutex Class Reference

Mutex interface class. More...

#include <ActivMiddleware/ActivBase/IMutex.h>

List of all members.

Public Member Functions

virtual StatusCode | Acquire () const =0
Acquire the mutex lock.
virtual size_t | GetContentionCount () const =0
Get approximate contention count for the mutex.
virtual StatusCode | Release () const =0
Release the mutex lock.
virtual StatusCode | Try () const =0
Try to obtain the mutex lock.
virtual | ~IMutex ()=0
Destructor.

Detailed Description

Mutex interface class.

Definition at line 20 of file IMutex.h.

Member Function Documentation

virtual StatusCode Activ::IMutex::Acquire ( ) const [pure virtual]

Acquire the mutex lock.

Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_FAILURE
STATUS_CODE_NOT_SUPPORTED

Referenced by Activ::DeferredScopedMutexLocker::Acquire(), Activ::ScopedMutexTryLocker::Acquire(), and Activ::ScopedMutexLocker::ScopedMutexLocker().

virtual size_t Activ::IMutex::GetContentionCount ( ) const [pure virtual]

Get approximate contention count for the mutex.

The count is approximate as it doesn't use an atomic counter - if multiple threads attempt to lock the mutex at the "same" time and the mutex is already locked, the counter may not be incremented correctly.

Note not all mutex implementations may provide this value, in which case this function will return 0. For mutexes that do, the value is incremented if Try() fails or Acquire() blocks.

This is provided for informational purposes only.

Returns:
approximate contention count.

virtual StatusCode Activ::IMutex::Release ( ) const [pure virtual]

Release the mutex lock.

Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_FAILURE

Referenced by Activ::DeferredScopedMutexLocker::~DeferredScopedMutexLocker(), Activ::ScopedMutexLocker::~ScopedMutexLocker(), and Activ::ScopedMutexTryLocker::~ScopedMutexTryLocker().

virtual StatusCode Activ::IMutex::Try ( ) const [pure virtual]

Try to obtain the mutex lock.

Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_FAILURE

Referenced by Activ::DeferredScopedMutexLocker::Try().

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivBase/IMutex.h
Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::IniFileParser

Activ::IniFileParser Class Reference

Ini file parser. More...

#include <ActivMiddleware/ActivBase/IniFileParser.h>

List of all members.

Public Member Functions

ACTIV_BASE_EXPORTED_API
ConstSectionIterator 		BeginSection () const
Get an iterator to the first section in the ini file.
ACTIV_BASE_EXPORTED_API StatusCode | Deserialize (MessageValidator &messageValidator)
Deserialize from a MessageValidator into this object.
ACTIV_BASE_EXPORTED_API
ConstSectionIterator 		EndSection () const
Get an iterator to past the last section in the ini file.
ACTIV_BASE_EXPORTED_API
ConstSectionIterator 		FindSection (const std::string &sectionName, const size_t matchLength=MATCH_LENGTH_COMPLETE) const
Find a section in the ini file by name.
ACTIV_BASE_EXPORTED_API StatusCode | GetBooleanValue (const std::string &sectionName, const std::string &keyName, bool &value) const
Get boolean value for a (section, key).
ACTIV_BASE_EXPORTED_API StatusCode | GetRealValue (const std::string &sectionName, const std::string &keyName, double &value) const
Get a real value for a (section, key).
ACTIV_BASE_EXPORTED_API StatusCode | GetRealValueList (const std::string &sectionName, const std::string &keyName, std::vector< double > &valueList, const std::string &delimiterList=std::string(",")) const
Get list of real values for a (section, key).
template<typename T>
StatusCode | GetSignedValue (const std::string &sectionName, const std::string &keyName, T &value) const
Get a signed integral value for a (section, key).
template<typename T>
StatusCode | GetSignedValueList (const std::string &sectionName, const std::string &keyName, std::vector< T > &valueList, const std::string &delimiterList=std::string(",")) const
Get list of signed integral values for a (section, key).
ACTIV_BASE_EXPORTED_API StatusCode | GetStringValue (const std::string &sectionName, const std::string &keyName, std::string &value) const
Get string value for a (section, key).
ACTIV_BASE_EXPORTED_API StatusCode | GetStringValueList (const std::string &sectionName, const std::string &keyName, std::vector< std::string > &valueList, const std::string &delimiterList=std::string(",")) const
Get list of strings for a (section, key).
template<typename T>
StatusCode | GetUnsignedValue (const std::string &sectionName, const std::string &keyName, T &value) const
Get an unsigned integral value for a (section, key).
template<typename T>
StatusCode | GetUnsignedValueList (const std::string &sectionName, const std::string &keyName, std::vector< T > &valueList, const std::string &delimiterList=std::string(",")) const
Get list of unsigned integral values for a (section, key).
ACTIV_BASE_EXPORTED_API | IniFileParser (const byte_t *const pBuffer, const size_t bufferLength)
Constructor. Parses an ini file from a buffer.
ACTIV_BASE_EXPORTED_API | IniFileParser (const std::string &iniFileName)
Constructor. Parses the ini file.
ACTIV_BASE_EXPORTED_API | IniFileParser ()
Default constructor.
ACTIV_BASE_EXPORTED_API StatusCode | Serialize (MessageBuilder &messageBuilder) const
Serialize to a MessageBuilder.
ACTIV_BASE_EXPORTED_API | ~IniFileParser ()
Destructor.

Static Public Member Functions

static ACTIV_BASE_EXPORTED_API
std::string 		GetSectionName (const size_t count,...)
Build a section name from a list of sub-section names.

Static Public Attributes

static const size_t | MATCH_LENGTH_COMPLETE = static_cast<size_t>(~0)
static const char | SECTION_DELIMITER = ':'
Sub-sections are delimited with this, eg [Section:SubSection].

Classes

class | ConstKeyIterator
Const iterator to section keys. More...
class | ConstSectionIterator
Const iterator to ini file sections. More...
class | KeySerializer
Key serializer class.
class | ParseException
Exception generated by parse errors. More...
class | SectionSerializer
Section serializer class.

Detailed Description

Ini file parser.

Note all section and key searches are case insensitive.

Definition at line 32 of file IniFileParser.h.

Constructor & Destructor Documentation

ACTIV_BASE_EXPORTED_API Activ::IniFileParser::IniFileParser ( const std::string & iniFileName )

Constructor. Parses the ini file.

Parameters:
iniFileName ini file to parse.
Exceptions:
StatusCodeException
ParseException

ACTIV_BASE_EXPORTED_API Activ::IniFileParser::IniFileParser | ( | const byte_t *const | pBuffer,
 |  | const size_t | bufferLength
 | ) |  |

Constructor. Parses an ini file from a buffer.

Parameters:
pBuffer | pointer to the buffer.
bufferLength | the length of the buffer.
Exceptions:
StatusCodeException
ParseException

Member Function Documentation

ACTIV_BASE_EXPORTED_API ConstSectionIterator Activ::IniFileParser::BeginSection ( ) const

Get an iterator to the first section in the ini file.

Returns:
Iterator to the first section in the ini file. If the ini file contains no sections, will be equal to EndSection().

ACTIV_BASE_EXPORTED_API StatusCode Activ::IniFileParser::Deserialize ( MessageValidator & messageValidator )

Deserialize from a MessageValidator into this object.

Parameters:
messageValidator to deserialize from.
Returns:
STATUS_CODE_SUCCESS or an error code.

ACTIV_BASE_EXPORTED_API ConstSectionIterator Activ::IniFileParser::EndSection ( ) const

Get an iterator to past the last section in the ini file.

Returns:
Iterator to past the last section in the ini file.

Referenced by GetSignedValue(), GetSignedValueList(), GetUnsignedValue(), and GetUnsignedValueList().

ACTIV_BASE_EXPORTED_API ConstSectionIterator Activ::IniFileParser::FindSection | ( | const std::string & | sectionName,
 |  | const size_t | matchLength = MATCH_LENGTH_COMPLETE |
 | ) |  |  | const

Find a section in the ini file by name.

Parameters:
sectionName | name of the section name to find.
matchLength | how much of sectionName to match on. Default is complete match
Returns:
Iterator to the section. Will equal EndSection() if the section doesn't exist.

Referenced by GetSignedValue(), GetSignedValueList(), GetUnsignedValue(), and GetUnsignedValueList().

ACTIV_BASE_EXPORTED_API StatusCode Activ::IniFileParser::GetBooleanValue | ( | const std::string & | sectionName,
 |  | const std::string & | keyName,
 |  | bool & | value |
 | ) |  |  | const

Get boolean value for a (section, key).

Parameters:
sectionName | section to look for key.
keyName | key to get value of.
value | reference to a boolean variable to receive the value.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT | parsed value is not a boolean value.
STATUS_CODE_NOT_FOUND | section or key not found

ACTIV_BASE_EXPORTED_API StatusCode Activ::IniFileParser::GetRealValue | ( | const std::string & | sectionName,
 |  | const std::string & | keyName,
 |  | double & | value |
 | ) |  |  | const

Get a real value for a (section, key).

Parameters:
sectionName | section to look for key.
keyName | key to get value of.
value | reference to a variable to receive the value.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT | parsed value is not a real value.
STATUS_CODE_NOT_FOUND | section or key not found

ACTIV_BASE_EXPORTED_API StatusCode Activ::IniFileParser::GetRealValueList | ( | const std::string & | sectionName,
 |  | const std::string & | keyName,
 |  | std::vector< double > & | valueList,
 |  | const std::string & | delimiterList = std::string(",") |
 | ) |  |  | const

Get list of real values for a (section, key).

Parameters:
sectionName | section to look for key.
keyName | key to get values of.
valueList | reference to a vector to append the values to.
delimiterList | list of valid value delimiter characters.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_OUT_OF_RANGE | a parsed value is out of range of type T
STATUS_CODE_INVALID_FORMAT | a parsed value is not a real value.
STATUS_CODE_NOT_FOUND | section or key not found

static ACTIV_BASE_EXPORTED_API std::string Activ::IniFileParser::GetSectionName | ( | const size_t | count,
 |  |  | ... |
 | ) |  |  | [static]

Build a section name from a list of sub-section names.

Parameters:
count the count of sub-sections.
... list of count sub-section names of type const char *.
Returns:
the section name in the form A:B:C.

template<typename T>
StatusCode Activ::IniFileParser::GetSignedValue | ( | const std::string & | sectionName,
 |  | const std::string & | keyName,
 |  | T & | value |
 | ) |  |  | const [inline]

Get a signed integral value for a (section, key).

Parameters:
sectionName | section to look for key.
keyName | key to get value of.
value | reference to a variable to receive the value.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_OUT_OF_RANGE | parsed value is out of range of type T
STATUS_CODE_INVALID_FORMAT | parsed value is not a signed value
STATUS_CODE_NOT_FOUND | section or key not found

Definition at line 762 of file IniFileParser.h.

References EndSection(), FindSection(), and Activ::IniFileParser::ConstSectionIterator::GetSignedValue().

template<typename T>
StatusCode Activ::IniFileParser::GetSignedValueList | ( | const std::string & | sectionName,
 |  | const std::string & | keyName,
 |  | std::vector< T > & | valueList,
 |  | const std::string & | delimiterList = std::string(",") |
 | ) |  |  | const [inline]

Get list of signed integral values for a (section, key).

Parameters:
sectionName | section to look for key.
keyName | key to get values of.
valueList | reference to a vector to append the values to.
delimiterList | list of valid value delimiter characters.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_OUT_OF_RANGE | a parsed value is out of range of type T
STATUS_CODE_INVALID_FORMAT | a parsed value is not a signed value.
STATUS_CODE_NOT_FOUND | section or key not found

Definition at line 775 of file IniFileParser.h.

References EndSection(), FindSection(), and Activ::IniFileParser::ConstSectionIterator::GetSignedValueList().

ACTIV_BASE_EXPORTED_API StatusCode Activ::IniFileParser::GetStringValue | ( | const std::string & | sectionName,
 |  | const std::string & | keyName,
 |  | std::string & | value |
 | ) |  |  | const

Get string value for a (section, key).

Parameters:
sectionName | section to look for key.
keyName | key to get value of.
value | reference to a string variable to receive the value.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_FOUND section or key not found

ACTIV_BASE_EXPORTED_API StatusCode Activ::IniFileParser::GetStringValueList | ( | const std::string & | sectionName,
 |  | const std::string & | keyName,
 |  | std::vector< std::string > & | valueList,
 |  | const std::string & | delimiterList = std::string(",") |
 | ) |  |  | const

Get list of strings for a (section, key).

Parameters:
sectionName | section to look for key.
keyName | key to get values of.
valueList | reference to a vector to append the strings to.
delimiterList | list of valid value delimiter characters.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT | parsed value is not a string value.
STATUS_CODE_NOT_FOUND | section or key not found

template<typename T>
StatusCode Activ::IniFileParser::GetUnsignedValue | ( | const std::string & | sectionName,
 |  | const std::string & | keyName,
 |  | T & | value |
 | ) |  |  | const [inline]

Get an unsigned integral value for a (section, key).

Parameters:
sectionName | section to look for key.
keyName | key to get value of.
value | reference to a variable to receive the value.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_OUT_OF_RANGE | parsed value is out of range of type T
STATUS_CODE_INVALID_FORMAT | parsed value is not an unsigned value
STATUS_CODE_NOT_FOUND | section or key not found

Definition at line 788 of file IniFileParser.h.

References EndSection(), FindSection(), and Activ::IniFileParser::ConstSectionIterator::GetUnsignedValue().

template<typename T>
StatusCode Activ::IniFileParser::GetUnsignedValueList | ( | const std::string & | sectionName,
 |  | const std::string & | keyName,
 |  | std::vector< T > & | valueList,
 |  | const std::string & | delimiterList = std::string(",") |
 | ) |  |  | const [inline]

Get list of unsigned integral values for a (section, key).

Parameters:
sectionName | section to look for key.
keyName | key to get values of.
valueList | reference to a vector to append the values to.
delimiterList | list of valid value delimiter characters.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_OUT_OF_RANGE | a parsed value is out of range of type T
STATUS_CODE_INVALID_FORMAT | a parsed value is not an unsigned value.
STATUS_CODE_NOT_FOUND | section or key not found

Definition at line 801 of file IniFileParser.h.

References EndSection(), FindSection(), and Activ::IniFileParser::ConstSectionIterator::GetUnsignedValueList().

ACTIV_BASE_EXPORTED_API StatusCode Activ::IniFileParser::Serialize ( MessageBuilder & messageBuilder ) const

Serialize to a MessageBuilder.

Parameters:
messageBuilder to serialize into.
Returns:
STATUS_CODE_SUCCESS or an error code.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivBase/IniFileParser.h
Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::IniFileParser::ConstKeyIterator

Activ::IniFileParser::ConstKeyIterator Class Reference

Const iterator to section keys. More...

#include <ActivMiddleware/ActivBase/IniFileParser.h>

List of all members.

Public Member Functions

ACTIV_BASE_EXPORTED_API StatusCode | GetBooleanValue (bool &value) const
Get boolean value for this key.
ACTIV_BASE_EXPORTED_API const
std::string 		GetName () const
Get the key name.
ACTIV_BASE_EXPORTED_API StatusCode | GetRealValue (double &value) const
Get a real value for this key.
ACTIV_BASE_EXPORTED_API StatusCode | GetRealValueList (std::vector< double > &valueList, const std::string &delimiterList=std::string(",")) const
Get a list of real values for this key.
template<typename T>
ACTIV_BASE_EXPORTED_API StatusCode | GetSignedValue (T &value) const
Get a signed integral value for this key.
template<typename T>
ACTIV_BASE_EXPORTED_API StatusCode | GetSignedValueList (std::vector< T > &valueList, const std::string &delimiterList=std::string(",")) const
Get a list of signed integral values for this key.
ACTIV_BASE_EXPORTED_API StatusCode | GetStringValue (std::string &value) const
Get string value for this key.
ACTIV_BASE_EXPORTED_API StatusCode | GetStringValueList (std::vector< std::string > &valueList, const std::string &delimiterList=std::string(",")) const
Get a list of string values for this key.
template<typename T>
ACTIV_BASE_EXPORTED_API StatusCode | GetUnsignedValue (T &value) const
Get an unsigned integral value for this key.
template<typename T>
ACTIV_BASE_EXPORTED_API StatusCode | GetUnsignedValueList (std::vector< T > &valueList, const std::string &delimiterList=std::string(",")) const
Get a list of unsigned integral values for this key.
ACTIV_BASE_EXPORTED_API bool | operator!= (const ConstKeyIterator &rhs) const
Inequality operator.
ACTIV_BASE_EXPORTED_API
ConstKeyIterator & 		operator++ ()
Advance to the next key in the section.
ACTIV_BASE_EXPORTED_API bool | operator== (const ConstKeyIterator &rhs) const
Equality operator.

Friends

class | ConstSectionIterator
Allow section iterator access.

Detailed Description

Const iterator to section keys.

Definition at line 73 of file IniFileParser.h.

Member Function Documentation

ACTIV_BASE_EXPORTED_API StatusCode Activ::IniFileParser::ConstKeyIterator::GetBooleanValue ( bool & value ) const

Get boolean value for this key.

Parameters:
value reference to a boolean variable to receive the value.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT parsed value is not a boolean value

ACTIV_BASE_EXPORTED_API const std::string Activ::IniFileParser::ConstKeyIterator::GetName ( ) const

Get the key name.

Returns:
The key name.

ACTIV_BASE_EXPORTED_API StatusCode Activ::IniFileParser::ConstKeyIterator::GetRealValue ( double & value ) const

Get a real value for this key.

Parameters:
value reference to a variable to receive the value.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT parsed value is not a real value.

ACTIV_BASE_EXPORTED_API StatusCode Activ::IniFileParser::ConstKeyIterator::GetRealValueList | ( | std::vector< double > & | valueList,
 |  | const std::string & | delimiterList = std::string(",") |
 | ) |  |  | const

Get a list of real values for this key.

Parameters:
valueList | reference to a vector to append the values to.
delimiterList | list of valid value delimiter characters.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_OUT_OF_RANGE | a parsed value is out of range of type T
STATUS_CODE_INVALID_FORMAT | a parsed value is not a real value

template<typename T>
ACTIV_BASE_EXPORTED_API StatusCode Activ::IniFileParser::ConstKeyIterator::GetSignedValue ( T & value ) const [inline]

Get a signed integral value for this key.

Parameters:
value reference to a variable to receive the value.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_OUT_OF_RANGE | parsed value is out of range of type T
STATUS_CODE_INVALID_FORMAT | parsed value is not a signed value

Referenced by Activ::IniFileParser::ConstSectionIterator::GetSignedValue().

template<typename T>
ACTIV_BASE_EXPORTED_API StatusCode Activ::IniFileParser::ConstKeyIterator::GetSignedValueList | ( | std::vector< T > & | valueList,
 |  | const std::string & | delimiterList = std::string(",") |
 | ) |  |  | const [inline]

Get a list of signed integral values for this key.

Parameters:
valueList | reference to a vector to append the values to.
delimiterList | list of valid value delimiter characters.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_OUT_OF_RANGE | a parsed value is out of range of type T
STATUS_CODE_INVALID_FORMAT | a parsed value is not a signed value

Referenced by Activ::IniFileParser::ConstSectionIterator::GetSignedValueList().

ACTIV_BASE_EXPORTED_API StatusCode Activ::IniFileParser::ConstKeyIterator::GetStringValue ( std::string & value ) const

Get string value for this key.

Parameters:
value reference to a string variable to receive the value.
Return values:
STATUS_CODE_SUCCESS

ACTIV_BASE_EXPORTED_API StatusCode Activ::IniFileParser::ConstKeyIterator::GetStringValueList | ( | std::vector< std::string > & | valueList,
 |  | const std::string & | delimiterList = std::string(",") |
 | ) |  |  | const

Get a list of string values for this key.

Parameters:
valueList | reference to a vector to append the strings to.
delimiterList | list of valid value delimiter characters.
Return values:
STATUS_CODE_SUCCESS

template<typename T>
ACTIV_BASE_EXPORTED_API StatusCode Activ::IniFileParser::ConstKeyIterator::GetUnsignedValue ( T & value ) const [inline]

Get an unsigned integral value for this key.

Parameters:
value reference to a variable to receive the value.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_OUT_OF_RANGE | parsed value is out of range of type T
STATUS_CODE_INVALID_FORMAT | parsed value is not an unsigned value

Referenced by Activ::IniFileParser::ConstSectionIterator::GetUnsignedValue().

template<typename T>
ACTIV_BASE_EXPORTED_API StatusCode Activ::IniFileParser::ConstKeyIterator::GetUnsignedValueList | ( | std::vector< T > & | valueList,
 |  | const std::string & | delimiterList = std::string(",") |
 | ) |  |  | const [inline]

Get a list of unsigned integral values for this key.

Parameters:
valueList | reference to a vector to append the values to.
delimiterList | list of valid value delimiter characters.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_OUT_OF_RANGE | a parsed value is out of range of type T
STATUS_CODE_INVALID_FORMAT | a parsed value is not an unsigned value

Referenced by Activ::IniFileParser::ConstSectionIterator::GetUnsignedValueList().

ACTIV_BASE_EXPORTED_API bool Activ::IniFileParser::ConstKeyIterator::operator!= ( const ConstKeyIterator & rhs ) const

Inequality operator.

Parameters:
rhs KeyIterator to compare to.
Returns:
boolean.

ACTIV_BASE_EXPORTED_API ConstKeyIterator& Activ::IniFileParser::ConstKeyIterator::operator++ ( )

Advance to the next key in the section.

Returns:
*this.

ACTIV_BASE_EXPORTED_API bool Activ::IniFileParser::ConstKeyIterator::operator== ( const ConstKeyIterator & rhs ) const

Equality operator.

Parameters:
rhs KeyIterator to compare to.
Returns:
boolean.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivBase/IniFileParser.h
Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::IniFileParser::ConstSectionIterator

Activ::IniFileParser::ConstSectionIterator Class Reference

Const iterator to ini file sections. More...

#include <ActivMiddleware/ActivBase/IniFileParser.h>

List of all members.

Public Member Functions

ACTIV_BASE_EXPORTED_API
ConstKeyIterator 		BeginKey () const
Get an iterator to the first key in the section. If there are no keys, will equal EndKey().
ACTIV_BASE_EXPORTED_API
ConstSectionIterator 		BeginSubSection () const
Get an iterator to the first sub section in the section.
ACTIV_BASE_EXPORTED_API
ConstKeyIterator 		EndKey () const
Get an iterator to past the last key in the section.
ACTIV_BASE_EXPORTED_API
ConstSectionIterator 		EndSection () const
Get an iterator to past the last section in the ini file.
ACTIV_BASE_EXPORTED_API
ConstSectionIterator 		EndSubSection () const
Get an iterator to past the last sub section in the section.
ACTIV_BASE_EXPORTED_API
ConstKeyIterator 		FindKey (const std::string &keyName, const size_t matchLength=MATCH_LENGTH_COMPLETE) const
Find a key by name.
ACTIV_BASE_EXPORTED_API
ConstSectionIterator 		FindSubSection (const std::string &subSectionName, const size_t matchLength=MATCH_LENGTH_COMPLETE) const
Find a sub section of this section. Sub section names are delimited with sectionDelimiter.
ACTIV_BASE_EXPORTED_API StatusCode | GetBooleanValue (const std::string &keyName, bool &value) const
Get boolean value for a key in this section.
ACTIV_BASE_EXPORTED_API const
std::string & 		GetName () const
Get the complete name of the section.
ACTIV_BASE_EXPORTED_API StatusCode | GetRealValue (const std::string &keyName, double &value) const
Get a real value for a key in this section.
ACTIV_BASE_EXPORTED_API StatusCode | GetRealValueList (const std::string &keyName, std::vector< double > &valueList, const std::string &delimiterList=std::string(",")) const
Get a list of real values for a key in this section.
template<typename T>
StatusCode | GetSignedValue (const std::string &keyName, T &value) const
Get a signed integral value for a key in this section.
template<typename T>
StatusCode | GetSignedValueList (const std::string &keyName, std::vector< T > &valueList, const std::string &delimiterList=std::string(",")) const
Get a list of signed integral values for a key in this section.
ACTIV_BASE_EXPORTED_API StatusCode | GetStringValue (const std::string &keyName, std::string &value) const
Get string value for a key in this section.
ACTIV_BASE_EXPORTED_API StatusCode | GetStringValueList (const std::string &keyName, std::vector< std::string > &valueList, const std::string &delimiterList=std::string(",")) const
Get a list of string values for a key in this section.
ACTIV_BASE_EXPORTED_API std::string | GetSubName () const
Get just the sub section name (for a top level section this == GetName()).
template<typename T>
StatusCode | GetUnsignedValue (const std::string &keyName, T &value) const
Get an unsigned integral value for a key in this section.
template<typename T>
StatusCode | GetUnsignedValueList (const std::string &keyName, std::vector< T > &valueList, const std::string &delimiterList=std::string(",")) const
Get a list of unsigned integral values for a key in this section.
ACTIV_BASE_EXPORTED_API bool | operator!= (const ConstSectionIterator &rhs) const
Inequality operator.
ACTIV_BASE_EXPORTED_API
ConstSectionIterator & 		operator++ ()
Advance to the next section in the ini file.
ACTIV_BASE_EXPORTED_API bool | operator== (const ConstSectionIterator &rhs) const
Equality operator.

Friends

class | IniFileParser
Allow IniFileParser access.

Detailed Description

Const iterator to ini file sections.

Definition at line 234 of file IniFileParser.h.

Member Function Documentation

ACTIV_BASE_EXPORTED_API ConstKeyIterator Activ::IniFileParser::ConstSectionIterator::BeginKey ( ) const

Get an iterator to the first key in the section. If there are no keys, will equal EndKey().

Returns:
Iterator to the first key in this section.

ACTIV_BASE_EXPORTED_API ConstSectionIterator Activ::IniFileParser::ConstSectionIterator::BeginSubSection ( ) const

Get an iterator to the first sub section in the section.

Returns:
Iterator to the first sub section in the section. If the section contains no sub-sections, will be equal to EndSubSection().

ACTIV_BASE_EXPORTED_API ConstKeyIterator Activ::IniFileParser::ConstSectionIterator::EndKey ( ) const

Get an iterator to past the last key in the section.

Returns:
Iterator to past the last key in the section.

Referenced by GetSignedValue(), GetSignedValueList(), GetUnsignedValue(), and GetUnsignedValueList().

ACTIV_BASE_EXPORTED_API ConstSectionIterator Activ::IniFileParser::ConstSectionIterator::EndSection ( ) const

Get an iterator to past the last section in the ini file.

Returns:
Iterator to past the last section in the ini file.

ACTIV_BASE_EXPORTED_API ConstSectionIterator Activ::IniFileParser::ConstSectionIterator::EndSubSection ( ) const

Get an iterator to past the last sub section in the section.

Returns:
Iterator to past the last sub section in the section.

ACTIV_BASE_EXPORTED_API ConstKeyIterator Activ::IniFileParser::ConstSectionIterator::FindKey | ( | const std::string & | keyName,
 |  | const size_t | matchLength = MATCH_LENGTH_COMPLETE |
 | ) |  |  | const

Find a key by name.

Parameters:
keyName | key to find.
matchLength | how much of keyName to match on. Default is complete match
Returns:
Iterator to the key. Will equal EndKey() if not found.

Referenced by GetSignedValue(), GetSignedValueList(), GetUnsignedValue(), and GetUnsignedValueList().

ACTIV_BASE_EXPORTED_API ConstSectionIterator Activ::IniFileParser::ConstSectionIterator::FindSubSection | ( | const std::string & | subSectionName,
 |  | const size_t | matchLength = MATCH_LENGTH_COMPLETE |
 | ) |  |  | const

Find a sub section of this section. Sub section names are delimited with sectionDelimiter.

Parameters:
subSectionName | name of the sub section.
matchLength | how much of subSectionName to match on. Default is complete match
Returns:
Iterator to sub section or EndSection() if not found.

ACTIV_BASE_EXPORTED_API StatusCode Activ::IniFileParser::ConstSectionIterator::GetBooleanValue | ( | const std::string & | keyName,
 |  | bool & | value |
 | ) |  |  | const

Get boolean value for a key in this section.

Parameters:
keyName | key to get value of.
value | reference to a boolean variable to receive the value.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT | parsed value is not a boolean value
STATUS_CODE_NOT_FOUND | key not found

ACTIV_BASE_EXPORTED_API const std::string& Activ::IniFileParser::ConstSectionIterator::GetName ( ) const

Get the complete name of the section.

Returns:
The section name.

ACTIV_BASE_EXPORTED_API StatusCode Activ::IniFileParser::ConstSectionIterator::GetRealValue | ( | const std::string & | keyName,
 |  | double & | value |
 | ) |  |  | const

Get a real value for a key in this section.

Parameters:
keyName | key to get value of.
value | reference to a variable to receive the value.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT | parsed value is not a real value
STATUS_CODE_NOT_FOUND | key not found

ACTIV_BASE_EXPORTED_API StatusCode Activ::IniFileParser::ConstSectionIterator::GetRealValueList | ( | const std::string & | keyName,
 |  | std::vector< double > & | valueList,
 |  | const std::string & | delimiterList = std::string(",") |
 | ) |  |  | const

Get a list of real values for a key in this section.

Parameters:
keyName | key to get values of.
valueList | reference to a vector to append the values to.
delimiterList | list of valid value delimiter characters.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT | parsed value is not a real value
STATUS_CODE_NOT_FOUND | key not found

template<typename T>
StatusCode Activ::IniFileParser::ConstSectionIterator::GetSignedValue | ( | const std::string & | keyName,
 |  | T & | value |
 | ) |  |  | const [inline]

Get a signed integral value for a key in this section.

Parameters:
keyName | key to get value of.
value | reference to a variable to receive the value.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_OUT_OF_RANGE | parsed value is out of range of type T
STATUS_CODE_INVALID_FORMAT | parsed value is not a signed value
STATUS_CODE_NOT_FOUND | key not found

Definition at line 815 of file IniFileParser.h.

References EndKey(), FindKey(), and Activ::IniFileParser::ConstKeyIterator::GetSignedValue().

Referenced by Activ::IniFileParser::GetSignedValue().

template<typename T>
StatusCode Activ::IniFileParser::ConstSectionIterator::GetSignedValueList | ( | const std::string & | keyName,
 |  | std::vector< T > & | valueList,
 |  | const std::string & | delimiterList = std::string(",") |
 | ) |  |  | const [inline]

Get a list of signed integral values for a key in this section.

Parameters:
keyName | key to get values of.
valueList | reference to a vector to append the values to.
delimiterList | list of valid value delimiter characters.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_OUT_OF_RANGE | a parsed value is out of range of type T
STATUS_CODE_INVALID_FORMAT | a parsed value is not a signed value
STATUS_CODE_NOT_FOUND | key not found

Definition at line 828 of file IniFileParser.h.

References EndKey(), FindKey(), and Activ::IniFileParser::ConstKeyIterator::GetSignedValueList().

Referenced by Activ::IniFileParser::GetSignedValueList().

ACTIV_BASE_EXPORTED_API StatusCode Activ::IniFileParser::ConstSectionIterator::GetStringValue | ( | const std::string & | keyName,
 |  | std::string & | value |
 | ) |  |  | const

Get string value for a key in this section.

Parameters:
keyName | key to get value of.
value | reference to a string variable to receive the value.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_FOUND key not found

ACTIV_BASE_EXPORTED_API StatusCode Activ::IniFileParser::ConstSectionIterator::GetStringValueList | ( | const std::string & | keyName,
 |  | std::vector< std::string > & | valueList,
 |  | const std::string & | delimiterList = std::string(",") |
 | ) |  |  | const

Get a list of string values for a key in this section.

Parameters:
keyName | key to get values of.
valueList | reference to a vector to append the strings to.
delimiterList | list of valid value delimiter characters.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_FOUND key not found

ACTIV_BASE_EXPORTED_API std::string Activ::IniFileParser::ConstSectionIterator::GetSubName ( ) const

Get just the sub section name (for a top level section this == GetName()).

Returns:
The sub section name.

template<typename T>
StatusCode Activ::IniFileParser::ConstSectionIterator::GetUnsignedValue | ( | const std::string & | keyName,
 |  | T & | value |
 | ) |  |  | const [inline]

Get an unsigned integral value for a key in this section.

Parameters:
keyName | key to get value of.
value | reference to a variable to receive the value.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_OUT_OF_RANGE | parsed value is out of range of type T
STATUS_CODE_INVALID_FORMAT | parsed value is not an unsigned value
STATUS_CODE_NOT_FOUND | key not found

Definition at line 841 of file IniFileParser.h.

References EndKey(), FindKey(), and Activ::IniFileParser::ConstKeyIterator::GetUnsignedValue().

Referenced by Activ::IniFileParser::GetUnsignedValue().

template<typename T>
StatusCode Activ::IniFileParser::ConstSectionIterator::GetUnsignedValueList | ( | const std::string & | keyName,
 |  | std::vector< T > & | valueList,
 |  | const std::string & | delimiterList = std::string(",") |
 | ) |  |  | const [inline]

Get a list of unsigned integral values for a key in this section.

Parameters:
keyName | key to get values of.
valueList | reference to a vector to append the values to.
delimiterList | list of valid value delimiter characters.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_OUT_OF_RANGE | a parsed value is out of range of type T
STATUS_CODE_INVALID_FORMAT | a parsed value is not an unsigned value
STATUS_CODE_NOT_FOUND | key not found

Definition at line 854 of file IniFileParser.h.

References EndKey(), FindKey(), and Activ::IniFileParser::ConstKeyIterator::GetUnsignedValueList().

Referenced by Activ::IniFileParser::GetUnsignedValueList().

ACTIV_BASE_EXPORTED_API bool Activ::IniFileParser::ConstSectionIterator::operator!= ( const ConstSectionIterator & rhs ) const

Inequality operator.

Parameters:
rhs SectionIterator to compare to.
Returns:
boolean.

ACTIV_BASE_EXPORTED_API ConstSectionIterator& Activ::IniFileParser::ConstSectionIterator::operator++ ( )

Advance to the next section in the ini file.

Returns:
*this.

ACTIV_BASE_EXPORTED_API bool Activ::IniFileParser::ConstSectionIterator::operator== ( const ConstSectionIterator & rhs ) const

Equality operator.

Parameters:
rhs SectionIterator to compare to.
Returns:
boolean.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivBase/IniFileParser.h
Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::IniFileParser::ParseException

Activ::IniFileParser::ParseException Class Reference

Exception generated by parse errors. More...

#include <ActivMiddleware/ActivBase/IniFileParser.h>

Inheritance diagram for Activ::IniFileParser::ParseException:

Activ::Exception

List of all members.

Public Member Functions

ACTIV_BASE_EXPORTED_API | ParseException (const char *file, const char *function, const uint_fast32_t line, const size_t offset, const std::string &validPart)
Constructor.
virtual
ACTIV_BASE_EXPORTED_API
std::string 		ToString () const
Convert the exception error code to a string.

Public Attributes

const size_t | m_offset
Offset in the file where parsing failed.
const std::string | m_validPart
Parsing failed at end of this.

Detailed Description

Exception generated by parse errors.

Definition at line 44 of file IniFileParser.h.

Constructor & Destructor Documentation

ACTIV_BASE_EXPORTED_API Activ::IniFileParser::ParseException::ParseException | ( | const char * | file,
 |  | const char * | function,
 |  | const uint_fast32_t | line,
 |  | const size_t | offset,
 |  | const std::string & | validPart
 | ) |  |

Constructor.

Parameters:
file
function
line
offset
validPart

Member Function Documentation

virtual ACTIV_BASE_EXPORTED_API std::string Activ::IniFileParser::ParseException::ToString ( ) const [virtual]

Convert the exception error code to a string.

Classes derived from Exception are required to implement ToString() to convert their error codes to a readable string.

Returns:
the error code as a string.

Reimplemented from Activ::Exception.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivBase/IniFileParser.h
Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::IntervalTimer

Activ::IntervalTimer Class Reference

Interval timer class. More...

#include <ActivMiddleware/ActivBase/IntervalTimer.h>

List of all members.

Public Member Functions

ACTIV_BASE_INLINE_API uint64_t | GetFrequency () const
Get the timer frequency.
ACTIV_BASE_EXPORTED_API | IntervalTimer ()
Default constructor.
ACTIV_BASE_INLINE_API double | ScaleTimeStamp (const uint64_t time) const
Scale a timestamp to a time in seconds.

Static Public Member Functions

static ACTIV_BASE_EXPORTED_API
uint32_t 		GetTickCount ()
Get the number of milliseconds that have elapsed since the system was started.
static ACTIV_BASE_EXPORTED_API
uint64_t 		GetTimeStamp ()
Get the current time stamp.

Classes

class | Scoped
Helper class to measure time whilst in scope. More...

Detailed Description

Interval timer class.

Definition at line 21 of file IntervalTimer.h.

Constructor & Destructor Documentation

ACTIV_BASE_EXPORTED_API Activ::IntervalTimer::IntervalTimer ( )

Default constructor.

Exceptions:
Exception.

Member Function Documentation

uint64_t Activ::IntervalTimer::GetFrequency ( ) const [inline]

Get the timer frequency.

Returns:
Returns the timer frequency.

Definition at line 94 of file IntervalTimer.h.

static ACTIV_BASE_EXPORTED_API uint32_t Activ::IntervalTimer::GetTickCount ( ) [static]

Get the number of milliseconds that have elapsed since the system was started.

Returns:
Time since system started, in ms.

static ACTIV_BASE_EXPORTED_API uint64_t Activ::IntervalTimer::GetTimeStamp ( ) [static]

Get the current time stamp.

Returns:
Returns the current time stamp.

Referenced by Activ::IntervalTimer::Scoped::~Scoped().

double Activ::IntervalTimer::ScaleTimeStamp ( const uint64_t time ) const [inline]

Scale a timestamp to a time in seconds.

Returns:
Returns the scaled time stamp.

Definition at line 101 of file IntervalTimer.h.

Referenced by Activ::IntervalTimer::Scoped::~Scoped().

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivBase/IntervalTimer.h
Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::IntervalTimer::Scoped

Activ::IntervalTimer::Scoped Class Reference

Helper class to measure time whilst in scope. More...

#include <ActivMiddleware/ActivBase/IntervalTimer.h>

List of all members.

Public Member Functions

Scoped (IntervalTimer &intervalTimer, double &time)
Constructor.
~Scoped ()
Destructor.

Detailed Description

Helper class to measure time whilst in scope.

Definition at line 27 of file IntervalTimer.h.

Constructor & Destructor Documentation

Activ::IntervalTimer::Scoped::Scoped | ( | IntervalTimer & | intervalTimer,
 |  | double & | time |
 | ) |  |  | [inline]

Constructor.

"Starts" the timer.

Parameters:
intervalTimer | reference to an IntervalTimer to do the timing.
time | reference to a double to receive the time this object is in scope, in seconds.

Definition at line 109 of file IntervalTimer.h.

Activ::IntervalTimer::Scoped::~Scoped ( ) [inline]

Destructor.

"Stops" the timer and stores the time in the double provided to the constructor.

Definition at line 118 of file IntervalTimer.h.

References Activ::IntervalTimer::GetTimeStamp(), and Activ::IntervalTimer::ScaleTimeStamp().

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivBase/IntervalTimer.h
Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::IoCompletionManager

Activ::IoCompletionManager Class Reference

I/O completion manager class. More...

#include <ActivMiddleware/ActivBase/Windows/IoCompletionManager.h>

Inheritance diagram for Activ::IoCompletionManager:

Activ::IpManager

List of all members.

Public Member Functions

ACTIV_BASE_EXPORTED_API void | AttachHandle (const HANDLE handle) const
Attach a handle to the completion port.
ACTIV_BASE_EXPORTED_API | IoCompletionManager (const size_t numberOfIoThreads=0)
Constructor.
ACTIV_BASE_EXPORTED_API | ~IoCompletionManager ()
Destructor.

Classes

class | IoThread
Io thread.
class | Overlapped
Overlapped class. More...

Detailed Description

I/O completion manager class.

Definition at line 29 of file IoCompletionManager.h.

Constructor & Destructor Documentation

ACTIV_BASE_EXPORTED_API Activ::IoCompletionManager::IoCompletionManager ( const size_t numberOfIoThreads = 0 )

Constructor.

Parameters:
numberOfIoThreads the number of io threads to launch. If 0, let the object decide how many threads to launch.
Exceptions:
Exception

Member Function Documentation

ACTIV_BASE_EXPORTED_API void Activ::IoCompletionManager::AttachHandle ( const HANDLE handle ) const

Attach a handle to the completion port.

Parameters:
handle the handle to attach.
Exceptions:
OsException.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivBase/Windows/IoCompletionManager.h
Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::IoCompletionManager::Overlapped

Activ::IoCompletionManager::Overlapped Class Reference

Overlapped class. More...

#include <ActivMiddleware/ActivBase/Windows/IoCompletionManager.h>

Inheritance diagram for Activ::IoCompletionManager::Overlapped:

Activ::IpSocket::RxOverlapped Activ::IpSocket::TxOverlapped

List of all members.

Public Member Functions

DWORD | GetNumberOfBytes () const
Get number of bytes in completion.
bool | IsPending () const
Check if i/o is pending for this object.
Overlapped (IoCompletionManager &ioCompletionManager, IMutex *const pMutex)
Constructor.
bool | PostIoCompletion (DWORD numberOfBytes)
Post an i/o completion to the completion port. See Windows PostQueuedCompletionStatus().
void | SetPending (const bool isPending)
Set the pending status for this object.
bool | WasSuccessfulCompletion () const
Check if i/o was successful.

Protected Member Functions

virtual void | OnIoCompletion ()=0
Overlapped i/o has completed.

Friends

class | IoCompletionManager
allow manager access

Detailed Description

Overlapped class.

Extends the Windows OVERLAPPED structure and adds a virtual callback for i/o completions.

Definition at line 37 of file IoCompletionManager.h.

Constructor & Destructor Documentation

Activ::IoCompletionManager::Overlapped::Overlapped | ( | IoCompletionManager & | ioCompletionManager,
 |  | IMutex *const | pMutex |
 | ) |  |  | [inline]

Constructor.

Parameters:
ioCompletionManager | reference to manager.
pMutex | mutex to acquire before invoking OnIoCompletion() callback, or 0 if not required.

Definition at line 173 of file IoCompletionManager.h.

Member Function Documentation

DWORD Activ::IoCompletionManager::Overlapped::GetNumberOfBytes ( ) const [inline]

Get number of bytes in completion.

Should be called when processing an OnIoCompletion() callback.

Returns:
Number of bytes transferred in i/o operation.

Definition at line 213 of file IoCompletionManager.h.

bool Activ::IoCompletionManager::Overlapped::IsPending ( ) const [inline]

Check if i/o is pending for this object.

Returns:
boolean.

Definition at line 192 of file IoCompletionManager.h.

Referenced by Activ::IpSocket::PreLockedRead(), and Activ::IpSocket::PreLockedWrite().

virtual void Activ::IoCompletionManager::Overlapped::OnIoCompletion ( ) [protected, pure virtual]

Overlapped i/o has completed.

Note if a mutex was provided to the constructor of the object, it will be acquired before invoking this callback.

bool Activ::IoCompletionManager::Overlapped::PostIoCompletion ( DWORD numberOfBytes ) [inline]

Post an i/o completion to the completion port. See Windows PostQueuedCompletionStatus().

Causes OnIoCompletion() to be invoked from a manager thread.

Parameters:
numberOfBytes
Returns:
boolean.

Definition at line 185 of file IoCompletionManager.h.

References Activ::IoCompletionManager::m_completionPort.

void Activ::IoCompletionManager::Overlapped::SetPending ( const bool isPending ) [inline]

Set the pending status for this object.

SetPending(true) after an i/o operation has successfully been initiated using this object.

Parameters:
isPending

Definition at line 199 of file IoCompletionManager.h.

bool Activ::IoCompletionManager::Overlapped::WasSuccessfulCompletion ( ) const [inline]

Check if i/o was successful.

Should be called when processing an OnIoCompletion() callback.

Returns:
boolean.

Definition at line 206 of file IoCompletionManager.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivBase/Windows/IoCompletionManager.h
Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::IpAddress

Activ::IpAddress Class Reference

Protocol independant ip address information. More...

#include <ActivMiddleware/ActivIp/IpAddress.h>

List of all members.

Public Member Functions

int | Compare (const IpAddress &rhs) const
Compare two IpAddress objects.
ACTIV_IP_API StatusCode | Deserialize (MessageValidator &messageValidator)
Deserialize.
ACTIV_IP_API uint32_t | GetInterfaceIndex () const
Get the interface index of a local ipv6 address.
ACTIV_IP_API uint16_t | GetPort () const
Get the port number, in local endian.
IpAddress (const int socketType, const int protocol, const int family=AF_UNSPEC)
Constructor.
IpAddress (const int family=AF_UNSPEC)
Constructor.
ACTIV_IP_API bool | IsLoopback () const
Is this a loopback address?
ACTIV_IP_API bool | IsMulticast () const
Is this a multicast address?
ACTIV_IP_API bool | IsUnspecified () const
Is this an unspecified address (aka an 'any' address)?
bool | operator!= (const IpAddress &rhs) const
Inequality operator.
bool | operator< (const IpAddress &rhs) const
Less than operator.
bool | operator== (const IpAddress &rhs) const
Equality operator.
ACTIV_IP_API StatusCode | Serialize (MessageBuilder &messageBuilder) const
Serialize.
ACTIV_IP_API std::string | ToString (const bool shouldShowPort=true) const
Convert address to a string.

Public Attributes

union {
sockaddr Address
sockaddr_in AddressIn
sockaddr_in6 AddressIn6
} m_address
socklen_t | m_addressLength
Size of useful info in m_address.
uint32_t | m_protocol
Protocol specific to address family.
uint32_t | m_type
Socket type.

Detailed Description

Protocol independant ip address information.

Currently supports ipv4 and ipv6 addresses.

Definition at line 31 of file IpAddress.h.

Constructor & Destructor Documentation

Activ::IpAddress::IpAddress ( const int family = AF_UNSPEC ) [inline]

Constructor.

The socket type and protocol are initialized to 0.

Parameters:
family the address family.

Definition at line 185 of file IpAddress.h.

Activ::IpAddress::IpAddress | ( | const int | socketType,
 |  | const int | protocol,
 |  | const int | family = AF_UNSPEC |
 | ) |  |  | [inline]

Constructor.

Parameters:
socketType | the socket type.
protocol | the socket protocol.
family | the address family.

Definition at line 196 of file IpAddress.h.

Member Function Documentation

int Activ::IpAddress::Compare ( const IpAddress & rhs ) const [inline]

Compare two IpAddress objects.

Parameters:
rhs reference to an IpAddress object to compare.
Return values:
-ve | if this is less than rhs.
0 | if this equal to rhs.
+ve | if this is greater than rhs.

Definition at line 207 of file IpAddress.h.

References m_address, and m_addressLength.

Referenced by operator!=(), operator<(), and operator==().

ACTIV_IP_API StatusCode Activ::IpAddress::Deserialize ( MessageValidator & messageValidator )

Deserialize.

Parameters:
messageValidator
Return values:
STATUS_CODE_SUCCESS
...

ACTIV_IP_API uint32_t Activ::IpAddress::GetInterfaceIndex ( ) const

Get the interface index of a local ipv6 address.

Exceptions:
Exception.

ACTIV_IP_API uint16_t Activ::IpAddress::GetPort ( ) const

Get the port number, in local endian.

Returns:
Port number.
Exceptions:
Exception if the address isn't an ipv4 or ipv6 address.

ACTIV_IP_API bool Activ::IpAddress::IsLoopback ( ) const

Is this a loopback address?

Returns:
Whether this is a loopback address.
Exceptions:
Exception if the address isn't an ipv4 or ipv6 address.

ACTIV_IP_API bool Activ::IpAddress::IsMulticast ( ) const

Is this a multicast address?

Returns:
Whether this is a multicast address.
Exceptions:
Exception if the address isn't an ipv4 or ipv6 address.

ACTIV_IP_API bool Activ::IpAddress::IsUnspecified ( ) const

Is this an unspecified address (aka an 'any' address)?

Returns:
Whether this is an unspecified address.
Exceptions:
Exception if the address isn't an ipv4 or ipv6 address.

bool Activ::IpAddress::operator!= ( const IpAddress & rhs ) const [inline]

Inequality operator.

Parameters:
rhs reference to an IpAddress object to compare.
Return values:
true | if this is not equal to rhs.
false | if this is equal to rhs.

Definition at line 234 of file IpAddress.h.

References Compare().

bool Activ::IpAddress::operator< ( const IpAddress & rhs ) const [inline]

Less than operator.

Parameters:
rhs reference to an IpAddress object to compare.
Return values:
true | if this is less than rhs.
false | if this is greater than or equal to rhs.

Definition at line 241 of file IpAddress.h.

References Compare().

bool Activ::IpAddress::operator== ( const IpAddress & rhs ) const [inline]

Equality operator.

Parameters:
rhs reference to an IpAddress object to compare.
Return values:
true | if this is equal to rhs.
false | if this is not equal to rhs.

Definition at line 227 of file IpAddress.h.

References Compare().

ACTIV_IP_API StatusCode Activ::IpAddress::Serialize ( MessageBuilder & messageBuilder ) const

Serialize.

Parameters:
messageBuilder
Return values:
STATUS_CODE_SUCCESS
...

ACTIV_IP_API std::string Activ::IpAddress::ToString ( const bool shouldShowPort = true ) const

Convert address to a string.

Parameters:
shouldShowPort whether to include the port number in the string.
Returns:
The string form of the address, or an empty string is returned if the address cannot be converted.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivIp/IpAddress.h
Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::IpException

Activ::IpException Class Reference

Ip exception class. More...

#include <ActivMiddleware/ActivIp/IpException.h>

Inheritance diagram for Activ::IpException:

Activ::Exception

List of all members.

Public Types

enum | { ACTIV_DECLARE_ELEMENT_1_WITH_COMMA }
Enumeration of all IpException errors.

Public Member Functions

ACTIV_IP_API | IpException (const char *file, const char *function, const uint_fast32_t line, const uint_fast32_t errorCode)
Default constructor.
virtual ACTIV_IP_API std::string | ToString () const
Convert the exception error code to a string.

Detailed Description

Ip exception class.

Definition at line 43 of file IpException.h.

Constructor & Destructor Documentation

ACTIV_IP_API Activ::IpException::IpException | ( | const char * | file,
 |  | const char * | function,
 |  | const uint_fast32_t | line,
 |  | const uint_fast32_t | errorCode
 | ) |  |

Default constructor.

Parameters:
file | the file which raised the exception.
function | the function which raised the exception.
line | the line number which raised the exception.
errorCode | the exception specific error code.

Member Function Documentation

virtual ACTIV_IP_API std::string Activ::IpException::ToString ( ) const [virtual]

Convert the exception error code to a string.

Classes derived from Exception are required to implement ToString() to convert their error codes to a readable string.

Returns:
the error code as a string.

Reimplemented from Activ::Exception.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivIp/IpException.h
Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::IpManager

Activ::IpManager Class Reference

Ip manager base class. More...

#include <ActivMiddleware/ActivIp/Windows/IpManager.h>

Inheritance diagram for Activ::IpManager:

Activ::IoCompletionManager

List of all members.

Public Types

typedef std::vector
< InterfaceInfo > 		InterfaceInfoList
type of list of InterfaceInfo objects

Public Member Functions

const Settings & | GetSettings () const
Get reference to settings.
ACTIV_IP_API | IpManager (const Settings &settings)
Default constructor.
ACTIV_IP_API | ~IpManager ()
Destructor.

Static Public Member Functions

static ACTIV_IP_API void | CreateNonInheritableSocket (const IpAddress &ipAddress, SocketWrapper &socketWrapper)
Create a non-inheritable socket.
static ACTIV_IP_API void | GetExtensionFunction (const SOCKET socket, void *fnStorage, const DWORD fnStorageSize, void *fnGuid, const DWORD fnGuidSize)
Get the address of a winsock extension function.
static ACTIV_IP_API bool | GetHostAndPort (const std::string &hostAndPort, std::string &host, uint16_t &portNumber)
Get the hostname and port from a string of the form "host:port".
static ACTIV_IP_API const
std::string & 		GetHostName ()
Get the hostname.
static ACTIV_IP_API void | GetHostsFileEntries (std::vector< std::string > &result)
Build a list of all the lines from all hosts files.
static ACTIV_IP_API StatusCode | GetInterfaceInfoList (const int family, InterfaceInfoList &interfaceInfoList)
Get a list of information for network interfaces in the machine.
static ACTIV_IP_API void | GetIpAddress (const std::string &nodeName, const uint16_t portNumber, IpAddress &ipAddress, const int flags=0)
Resolve a string into an ip address.
static ACTIV_IP_API StatusCode | GetLocalIpAddressList (const std::string &localAddress, const uint16_t portNumber, IpAddressList &ipAddressList)
Get a list of local address.

Classes

class | InterfaceInfo
Information on a network interface. More...
class | Settings
Settings. More...

Detailed Description

Ip manager base class.

Definition at line 27 of file IpManager.h.

Constructor & Destructor Documentation

ACTIV_IP_API Activ::IpManager::IpManager ( const Settings & settings )

Default constructor.

Parameters:
settings reference to a Settings object.
Exceptions:
Exception

Member Function Documentation

static ACTIV_IP_API void Activ::IpManager::CreateNonInheritableSocket | ( | const IpAddress & | ipAddress,
 |  | SocketWrapper & | socketWrapper |
 | ) |  |  | [static]

Create a non-inheritable socket.

Parameters:
ipAddress | describing type of socket to create.
socketWrapper | to reveive the socket.
Exceptions:
Exception.

static ACTIV_IP_API void Activ::IpManager::GetExtensionFunction | ( | const SOCKET | socket,
 |  | void * | fnStorage,
 |  | const DWORD | fnStorageSize,
 |  | void * | fnGuid,
 |  | const DWORD | fnGuidSize |
 | ) |  |  | [static]

Get the address of a winsock extension function.

Parameters:
socket | the socket to find the extension function for.
fnStorage | pointer to place to store the function pointer.
fnStorageSize | the size of the function pointer storage.
fnGuid | pointer to the guid for the function to find.
fnGuidSize | size of the guid.
Exceptions:
Exception

static ACTIV_IP_API bool Activ::IpManager::GetHostAndPort | ( | const std::string & | hostAndPort,
 |  | std::string & | host,
 |  | uint16_t & | portNumber |
 | ) |  |  | [static]

Get the hostname and port from a string of the form "host:port".

If there is no "port" portion of the input string, portNumber is left unchanged.

Parameters:
hostAndPort | a string of the form "host:port".
host | reference to a string to receive the host portion of the input string.
portNumber | reference to a variable to receive the port number portion of the input string.
Return values:
true.
false hostAndPort could not be parsed.

static ACTIV_IP_API const std::string& Activ::IpManager::GetHostName ( ) [static]

Get the hostname.

Note hostname changes will not be picked up by this function.

Returns:
The hostname.

Referenced by Activ::SmtpHelper::GetHostname().

static ACTIV_IP_API void Activ::IpManager::GetHostsFileEntries ( std::vector< std::string > & result ) [static]

Build a list of all the lines from all hosts files.

Parameters:
result

static ACTIV_IP_API StatusCode Activ::IpManager::GetInterfaceInfoList | ( | const int | family,
 |  | InterfaceInfoList & | interfaceInfoList |
 | ) |  |  | [static]

Get a list of information for network interfaces in the machine.

Parameters:
family | AF_INET, AF_INET6 or AF_UNSPEC to not filter results.
interfaceInfoList | to receive the list of interface information.
Returns:
STATUS_CODE_SUCCESS or an error status code.

static ACTIV_IP_API void Activ::IpManager::GetIpAddress | ( | const std::string & | nodeName,
 |  | const uint16_t | portNumber,
 |  | IpAddress & | ipAddress,
 |  | const int | flags = 0 |
 | ) |  |  | [static]

Resolve a string into an ip address.

The string can be a hostname or ip address.

Parameters:
nodeName | the name of the node.
portNumber | the port number.
ipAddress | reference to an IpAddress object to store the ip address.
flags | AI_PASSIVE, AI_CANONNAME, AI_NUMERICHOST.
Exceptions:
Exception

static ACTIV_IP_API StatusCode Activ::IpManager::GetLocalIpAddressList | ( | const std::string & | localAddress,
 |  | const uint16_t | portNumber,
 |  | IpAddressList & | ipAddressList |
 | ) |  |  | [static]

Get a list of local address.

Parameters:
localAddress | the address to resolve. If localAddress is empty or the hostname, all configured interfaces are returned. If localAddress is one of the "any" addresses (i.e. "0.0.0.0" or "::"), all configured interfaces for that protocol (i.e. ipv4 or ipv6) are returned. localaddress can also be one of the configured interface addresses (eg "172.16.16.2") then only that address will be returned.
portNumber | optional port to give the returned addresses. Can be 0.
ipAddressList | to receive the results.
Return values:
STATUS_CODE_SUCCESS
...

const IpManager::Settings & Activ::IpManager::GetSettings ( ) const [inline]

Get reference to settings.

Returns:
Reference to settings as passed to constructor.

Definition at line 24 of file IpManager.h.

The documentation for this class was generated from the following files:
  • include/ActivMiddleware/ActivIp/Windows/IpManager.h
  • include/ActivMiddleware/ActivIp/IpManager.h
Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::IpManager::InterfaceInfo

Activ::IpManager::InterfaceInfo Class Reference

Information on a network interface. More...

#include <ActivMiddleware/ActivIp/Windows/IpManager.h>

List of all members.

Public Member Functions

ACTIV_IP_API | InterfaceInfo ()
Default constructor.

Public Attributes

size_t | m_bitsPerSecond
0 is unknown
std::string | m_description
IpAddressList | m_ipAddressList
list of configured ip addresses on this interface
std::string | m_macAddress
size_t | m_mtu
std::string | m_name

Detailed Description

Information on a network interface.

Definition at line 58 of file IpManager.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivIp/Windows/IpManager.h
Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::IpManager::Settings

Activ::IpManager::Settings Class Reference

Settings. More...

#include <ActivMiddleware/ActivIp/Windows/IpManager.h>

List of all members.

Public Member Functions

ACTIV_IP_API StatusCode | Read (const IniFileParser::ConstSectionIterator &sectionIterator)
Read settings from an ini file.
ACTIV_IP_API | Settings ()
Default constructor.

Public Attributes

bool | m_enableWindowsOverlappedOperations
default true
size_t | m_numberOfIoThreads
default 0, let the system decide

Detailed Description

Settings.

Definition at line 33 of file IpManager.h.

Member Function Documentation

ACTIV_IP_API StatusCode Activ::IpManager::Settings::Read ( const IniFileParser::ConstSectionIterator & sectionIterator )

Read settings from an ini file.

Parameters:
sectionIterator iterator to an ini file section.
Return values:
STATUS_CODE_SUCCESS
...

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivIp/Windows/IpManager.h
Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::IProcess

Activ::IProcess Class Reference

Process interface class. More...

#include <ActivMiddleware/ActivSystem/IProcess.h>

List of all members.

Public Types

typedef Process::Id | OsProcessId
enum | State { ACTIV_DECLARE_ELEMENT_1_WITH_COMMA }
Process states.

Public Member Functions

virtual ProcessId | GetId () const =0
Get the system unique process id for this process.
virtual std::string | GetName () const =0
Get the name of this process.
virtual OsProcessId | GetOsId () const =0
Get the os process id for this process.
virtual State | GetState () const =0
Get the process state.
virtual void | GetStats (Stats &stats) const =0
Get process stats.
virtual ISystem * | GetSystem () const =0
Get the system that created the process.
virtual const Uuid & | GetUuid () const =0
Get UUID of this process.
virtual void | SetState (const State state)=0
Set the state of the process.
virtual StatusCode | WaitForState (const State state, Timeout &timeout=Timeout::GetInfinite())=0
Wait for the state of the process to be a given value.
virtual | ~IProcess ()=0
Destructor.

Static Public Member Functions

static
ACTIV_SYSTEM_EXPORTED_API
std::string 		StateToString (const State state)
Convert process state to string.

Classes

class | Stats
Process stats. More...

Detailed Description

Process interface class.

Definition at line 41 of file IProcess.h.

Member Function Documentation

virtual ProcessId Activ::IProcess::GetId ( ) const [pure virtual]

Get the system unique process id for this process.

Returns:
The system unique process id.

virtual std::string Activ::IProcess::GetName ( ) const [pure virtual]

Get the name of this process.

Returns:
The name of this process.

virtual OsProcessId Activ::IProcess::GetOsId ( ) const [pure virtual]

Get the os process id for this process.

Returns:
The os process id.

virtual State Activ::IProcess::GetState ( ) const [pure virtual]

Get the process state.

Returns:
The current state of the process.

virtual void Activ::IProcess::GetStats ( Stats & stats ) const [pure virtual]

Get process stats.

Parameters:
stats reference to a Stats object.

virtual ISystem* Activ::IProcess::GetSystem ( ) const [pure virtual]

Get the system that created the process.

Returns:
An ISystem interface.

virtual const Uuid& Activ::IProcess::GetUuid ( ) const [pure virtual]

Get UUID of this process.

Returns:
Uuid reference.

virtual void Activ::IProcess::SetState ( const State state ) [pure virtual]

Set the state of the process.

Parameters:
state new state.

static ACTIV_SYSTEM_EXPORTED_API std::string Activ::IProcess::StateToString ( const State state ) [static]

Convert process state to string.

Parameters:
state state to convert.
Returns:
string form of system state.

virtual StatusCode Activ::IProcess::WaitForState | ( | const State | state,
 |  | Timeout & | timeout = Timeout::GetInfinite() |
 | ) |  |  | [pure virtual]

Wait for the state of the process to be a given value.

Parameters:
state | to wait for.
timeout | how long to wait.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_TIMEOUT

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivSystem/IProcess.h
Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::IProcess::Stats

Activ::IProcess::Stats Class Reference

Process stats. More...

#include <ActivMiddleware/ActivSystem/IProcess.h>

List of all members.

Public Member Functions

ACTIV_SYSTEM_EXPORTED_API
StatusCode 		Deserialize (MessageValidator &messageValidator)
Deserialize.
ACTIV_SYSTEM_EXPORTED_API
StatusCode 		Serialize (MessageBuilder &messageBuilder) const
Serialize.

Public Attributes

ProcessId | m_id
system wide id of the process
std::string | m_name
name of the process in the system
OsProcessId | m_osId
os wide id if the process
State m_state
state of the process
std::string | m_version
process version string

Detailed Description

Process stats.

Definition at line 58 of file IProcess.h.

Member Function Documentation

ACTIV_SYSTEM_EXPORTED_API StatusCode Activ::IProcess::Stats::Deserialize ( MessageValidator & messageValidator )

Deserialize.

Parameters:
messageValidator
Return values:
STATUS_CODE_SUCCESS
...

ACTIV_SYSTEM_EXPORTED_API StatusCode Activ::IProcess::Stats::Serialize ( MessageBuilder & messageBuilder ) const

Serialize.

Parameters:
messageBuilder
Return values:
STATUS_CODE_SUCCESS
...

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivSystem/IProcess.h
Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::IpSocket

Activ::IpSocket Class Reference

Base ip socket class. More...

#include <ActivMiddleware/ActivIp/Windows/IpSocket.h>

Inheritance diagram for Activ::IpSocket:

Activ::TcpSocket Activ::UdpSocket

List of all members.

Public Types

enum | CompletionResult { COMPLETION_RESULT_CLOSE_SOCKET, COMPLETION_RESULT_OK }
Return values from OnCompletion(). More...
enum | GetBuffersResult { GET_BUFFERS_RESULT_CLOSE_SOCKET, GET_BUFFERS_RESULT_NO_MORE_BUFFERS }
Return values from OnGet(Rx/Tx)Buffers(). More...

Public Member Functions

void | AppendRxBuffer (void *pData, const size_t dataLength)
Append an rx buffer.
void | AppendTxBuffer (const void *pData, const size_t dataLength)
Append a tx buffer.
ACTIV_IP_API void | GetLocalAddress (IpAddress &ipAddress) const
Get the local address of the socket.
ACTIV_IP_API void | GetRemoteAddress (IpAddress &ipAddress) const
Get the remote address of the socket.
ACTIV_IP_API SOCKET | GetSocketHandle () const
Get the socket handle.
ACTIV_IP_API void | GetSocketOption (const int optionName, char *pOptionValue, socklen_t *pOptionLength, const int level=SOL_SOCKET)
Get a socket option.
ACTIV_IP_API | IpSocket (IpManager &ipManager, const Settings &settings)
Default constructor.
void | LockedRead ()
Read some data.
void | LockedWrite ()
Write some data.
void | PreLockedRead ()
Read some data without obtaining the socket mutex.
void | PreLockedWrite ()
Write some data without obtaining the socket mutex.
ACTIV_IP_API void | SetRxBufferSize (const int size)
Set the internal rx buffer size.
ACTIV_IP_API void | SetSocketOption (const int optionName, const char *pOptionValue, const socklen_t optionLength, const int level=SOL_SOCKET)
Set a socket option.
ACTIV_IP_API void | SetTxBufferSize (const int size)
Set the internal tx buffer size.
virtual ACTIV_IP_API | ~IpSocket ()
Destructor.

Protected Member Functions

ACTIV_IP_API bool | CleanupIo ()
Invoke the OnCleanupIo() callback if no rx or tx is outstanding.
ACTIV_IP_API void | CloseSocket ()
Abortive close on a socket if it hasn't already been closed.
virtual void | HandleIoFailure (const bool gracefully)=0
Handle an io failure.
virtual ACTIV_IP_API void | OnCleanupIo ()
Callback to cleanup rx / tx state.
virtual ACTIV_IP_API
GetBuffersResult 		OnGetRxBuffers ()
Callback to get rx buffers.
virtual ACTIV_IP_API
GetBuffersResult 		OnGetTxBuffers ()
Callback to get tx buffers.
virtual ACTIV_IP_API bool | OnInitializeIo ()
Callback to initialize rx / tx state.
virtual ACTIV_IP_API
CompletionResult 		OnRxBuffers (const size_t dataLength)
Callback on rx completion.
virtual ACTIV_IP_API void | OnSetSocketOptions ()
Overridable socket options.
virtual ACTIV_IP_API
CompletionResult 		OnTxBuffers (const size_t dataLength)
Callback on tx completion.
ACTIV_IP_API bool | PostRead ()
Post a read on a socket.
ACTIV_IP_API bool | PostWrite ()
Post a write on a socket.
ACTIV_IP_API bool | ShutdownSocket ()
Shutdown a socket.

Protected Attributes

bool | m_closeOnTxCompletion
close gracefully when there is no more data to transmit
bool | m_closePosted
user has requested a close
IpAddress m_fromAddress
source address for current read (connectionless)
SocketWrapper m_handle
the underlying socket
IpManager & m_ipManager
this object is managed by an IpManager
IpAddress m_localAddress
local address information
IMutex *const | m_pMutex
mutex
IpAddress m_remoteAddress
remote address information (if socket is connected)
WsaBufHelper m_rxBuffers
WSABUF array for receive.
uint64_t | m_rxBytes
total rx bytes
DWORD | m_rxFlags
flags for WSARecv()
RxOverlapped m_rxOverlapped
receive overlapped info
IpAddress m_toAddress
sestination address for current write (connectionless)
WsaBufHelper m_txBuffers
WSABUF array for transmission.
uint64_t | m_txBytes
total tx bytes
DWORD | m_txFlags
flags for WSASend()
TxOverlapped m_txOverlapped
transmission overlapped info

Friends

class | IpManager
manager needs access to the objects it is managing

Classes

class | RxOverlapped
Overlapped class for reads. More...
class | Settings
Settings. More...
class | Stats
Stats. More...
class | TxOverlapped
Overlapped class for writes. More...

Detailed Description

Base ip socket class.

Definition at line 25 of file IpSocket.h.

Member Enumeration Documentation

enum Activ::IpSocket::CompletionResult

Return values from OnCompletion().

Enumerator:
COMPLETION_RESULT_CLOSE_SOCKET | major error, close socket (eg out of protocol data)
COMPLETION_RESULT_OK | completion data was OK

Definition at line 40 of file IpSocket.h.

enum Activ::IpSocket::GetBuffersResult

Return values from OnGet(Rx/Tx)Buffers().

Enumerator:
GET_BUFFERS_RESULT_CLOSE_SOCKET | major error, close socket
GET_BUFFERS_RESULT_NO_MORE_BUFFERS | no buffers available, but keep socket alive

Definition at line 31 of file IpSocket.h.

Constructor & Destructor Documentation

ACTIV_IP_API Activ::IpSocket::IpSocket | ( | IpManager & | ipManager,
 |  | const Settings & | settings
 | ) |  |

Default constructor.

Parameters:
ipManager | the IpManager that owns the socket.
settings | the Settings.
Exceptions:
Exception.

Member Function Documentation

void Activ::IpSocket::AppendRxBuffer | ( | void * | pData,
 |  | const size_t | dataLength |
 | ) |  |  | [inline]

Append an rx buffer.

Parameters:
pData | pointer to the buffer to read into.
dataLength | the length the buffer.
Exceptions:
Exception if the buffer wasn't appended to the rx array.

Definition at line 41 of file IpSocket.h.

References Activ::WsaBufHelper::Append(), and m_rxBuffers.

void Activ::IpSocket::AppendTxBuffer | ( | const void * | pData,
 |  | const size_t | dataLength |
 | ) |  |  | [inline]

Append a tx buffer.

Parameters:
pData | pointer to the buffer to transmit.
dataLength | the length the buffer.
Exceptions:
Exception if the buffer wasn't appended to the tx array.

Definition at line 48 of file IpSocket.h.

References Activ::WsaBufHelper::Append(), and m_txBuffers.

ACTIV_IP_API bool Activ::IpSocket::CleanupIo ( ) [protected]

Invoke the OnCleanupIo() callback if no rx or tx is outstanding.

Returns:
true if all io is complete and rx and tx handlers are fully cleaned up.

ACTIV_IP_API void Activ::IpSocket::GetLocalAddress ( IpAddress & ipAddress ) const

Get the local address of the socket.

Parameters:
ipAddress a reference to an IpAddress object to receive the local socket address.

ACTIV_IP_API void Activ::IpSocket::GetRemoteAddress ( IpAddress & ipAddress ) const

Get the remote address of the socket.

Parameters:
ipAddress a reference to an IpAddress object to receive the remote socket address.

ACTIV_IP_API SOCKET Activ::IpSocket::GetSocketHandle ( ) const

Get the socket handle.

Returns:
The socket handle.

ACTIV_IP_API void Activ::IpSocket::GetSocketOption | ( | const int | optionName,
 |  | char * | pOptionValue,
 |  | socklen_t * | pOptionLength,
 |  | const int | level = SOL_SOCKET
 | ) |  |

Get a socket option.

Parameters:
optionName | Socket option for which the value is to be retrieved.
pOptionValue | Pointer to the buffer in which the value for the requested option is to be returned.
pOptionLength | Pointer to the size of the pOptionValue buffer.
level | Level at which the option is defined.
Exceptions:
Exception if the socket option is not retrieved successfully.

virtual void Activ::IpSocket::HandleIoFailure ( const bool gracefully ) [protected, pure virtual]

Handle an io failure.

Parameters:
gracefully whether to do a graceful shutdown on the socket, or an abortive close.

Referenced by PreLockedRead(), and PreLockedWrite().

void Activ::IpSocket::LockedRead ( ) [inline]

Read some data.

Generally a read will always be outstanding on a socket, unless an rx handler returns 0 buffers from OnGetRxBuffers(), in which case LockedRead() here needs to be called at some point to start reading from the socket again.

Note this function will obtain the socket mutex for the duration of the call.

Definition at line 433 of file IpSocket.h.

References m_pMutex, and PreLockedRead().

void Activ::IpSocket::LockedWrite ( ) [inline]

Write some data.

If no write event is set for the socket, this will set one. At some point the event thread will callback OnGetTxBuffers().

Note this function will obtain the socket mutex for the duration of the call.

Definition at line 455 of file IpSocket.h.

References m_pMutex, and PreLockedWrite().

virtual ACTIV_IP_API void Activ::IpSocket::OnCleanupIo ( ) [protected, virtual]

Callback to cleanup rx / tx state.

For example, this will be called when a tcp connection is closed.

virtual ACTIV_IP_API bool Activ::IpSocket::OnInitializeIo ( ) [protected, virtual]

Callback to initialize rx / tx state.

Return values:
true | if successful.
false | if unsuccessful and the socket will be closed.

virtual ACTIV_IP_API CompletionResult Activ::IpSocket::OnRxBuffers ( const size_t dataLength ) [protected, virtual]

Callback on rx completion.

When overriding this function, you MUST call the base class OnRxBuffers() first, and return the result if it isn't COMPLETION_RESULT_SUCCESS.

Parameters:
dataLength the number of bytes transferred.

Reimplemented in Activ::TcpSocket, and Activ::UdpSocket.

virtual ACTIV_IP_API void Activ::IpSocket::OnSetSocketOptions ( ) [protected, virtual]

Overridable socket options.

Use SetSocketOption() in an overridden OnSetSocketOptions().

Exceptions:
Exception if the socket option is not set correctly.

virtual ACTIV_IP_API CompletionResult Activ::IpSocket::OnTxBuffers ( const size_t dataLength ) [protected, virtual]

Callback on tx completion.

When overriding this function, you MUST call the base class OnTxBuffers() first, and return the result if it isn't COMPLETION_RESULT_SUCCESS.

Parameters:
dataLength the number of bytes transferred.

Reimplemented in Activ::TcpSocket, and Activ::UdpSocket.

ACTIV_IP_API bool Activ::IpSocket::PostRead ( ) [protected]

Post a read on a socket.

Returns:
false if a read was not posted on the socket, in which case the socket should be closed.

Referenced by PreLockedRead().

ACTIV_IP_API bool Activ::IpSocket::PostWrite ( ) [protected]

Post a write on a socket.

Returns:
false if a write was not posted on the socket, in which case the socket should be closed.

Referenced by PreLockedWrite().

void Activ::IpSocket::PreLockedRead ( ) [inline]

Read some data without obtaining the socket mutex.

As LockedRead(), but do not obtain the socket mutex first (assumes the mutex is already locked).

Definition at line 442 of file IpSocket.h.

References HandleIoFailure(), Activ::IoCompletionManager::Overlapped::IsPending(), m_rxOverlapped, and PostRead().

Referenced by LockedRead().

void Activ::IpSocket::PreLockedWrite ( ) [inline]

Write some data without obtaining the socket mutex.

As LockedWrite(), but do not obtain the socket mutex first (assumes the mutex is already locked).

Definition at line 464 of file IpSocket.h.

References HandleIoFailure(), Activ::IoCompletionManager::Overlapped::IsPending(), m_txOverlapped, and PostWrite().

Referenced by LockedWrite().

ACTIV_IP_API void Activ::IpSocket::SetRxBufferSize ( const int size )

Set the internal rx buffer size.

This would most likely be used in an overriden OnSetSocketOptions(). Note once setting the buffer size, this call then retrieves the buffer size and checks that it was actually set to the value asked for. If not, an exception is thrown.

Parameters:
size the rx buffer size.
Exceptions:
Exception.

ACTIV_IP_API void Activ::IpSocket::SetSocketOption | ( | const int | optionName,
 |  | const char * | pOptionValue,
 |  | const socklen_t | optionLength,
 |  | const int | level = SOL_SOCKET
 | ) |  |

Set a socket option.

Parameters:
optionName | Socket option for which the value is to be set.
pOptionValue | Pointer to the buffer in which the value for the requested option is supplied.
optionLength | Size of the pOptionValue buffer.
level | Level at which the option is defined.
Exceptions:
Exception if the socket option is not set successfully.

ACTIV_IP_API void Activ::IpSocket::SetTxBufferSize ( const int size )

Set the internal tx buffer size.

This would most likely be used in an overriden OnSetSocketOptions(). Note once setting the buffer size, this call then retrieves the buffer size and checks that it was actually set to the value asked for. If not, an exception is thrown.

Parameters:
size the tx buffer size.
Exceptions:
Exception.

ACTIV_IP_API bool Activ::IpSocket::ShutdownSocket ( ) [protected]

Shutdown a socket.

Returns:
true if the shutdown was successful.

The documentation for this class was generated from the following files:
  • include/ActivMiddleware/ActivIp/Windows/IpSocket.h
  • include/ActivMiddleware/ActivIp/IpSocket.h
Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::IpSocket::RxOverlapped

Activ::IpSocket::RxOverlapped Class Reference

Overlapped class for reads. More...

#include <ActivMiddleware/ActivIp/Windows/IpSocket.h>

Inheritance diagram for Activ::IpSocket::RxOverlapped:

Activ::IoCompletionManager::Overlapped

List of all members.

Public Member Functions

RxOverlapped (IpSocket &ipSocket)
Constructor.

Detailed Description

Overlapped class for reads.

Definition at line 363 of file IpSocket.h.

Constructor & Destructor Documentation

Activ::IpSocket::RxOverlapped::RxOverlapped ( IpSocket & ipSocket )

Constructor.

Parameters:
ipSocket IpSocket containing this object.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivIp/Windows/IpSocket.h
Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::IpSocket::Settings

Activ::IpSocket::Settings Class Reference

Settings. More...

#include <ActivMiddleware/ActivIp/Windows/IpSocket.h>

Inheritance diagram for Activ::IpSocket::Settings:

Activ::TcpSocket::Settings Activ::UdpSocket::Settings

List of all members.

Public Member Functions

ACTIV_IP_API | Settings (const bool shouldCork=false)
Constructor.

Public Attributes

bool | m_shouldCork
set TCP_CORK, if available, whilst in tx loop

Detailed Description

Settings.

Definition at line 49 of file IpSocket.h.

Constructor & Destructor Documentation

ACTIV_IP_API Activ::IpSocket::Settings::Settings ( const bool shouldCork = false )

Constructor.

Parameters:
shouldCork set TCP_CORK, if available, whilst in tx loop.

Reimplemented in Activ::TcpSocket::Settings, and Activ::UdpSocket::Settings.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivIp/Windows/IpSocket.h
Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::IpSocket::Stats

Activ::IpSocket::Stats Class Reference

Stats. More...

#include <ActivMiddleware/ActivIp/Windows/IpSocket.h>

Inheritance diagram for Activ::IpSocket::Stats:

Activ::TcpSocket::Stats Activ::UdpSocket::Stats

List of all members.

Public Member Functions

ACTIV_IP_API | Stats (const IpSocket &socket)
Constructor.

Static Public Member Functions

template<typename SOCKET_TYPE>
static SOCKET_TYPE::Stats | Get (const SOCKET_TYPE &socket)
Helper function to get stats for a socket.

Public Attributes

bool | m_closeOnTxCompletion
close gracefully when there is no more data to transmit
bool | m_closePosted
user has requested a close
IpAddress m_localAddress
local address information
size_t | m_mutexContentionCount
approx. number of contentions on the mutex
IpAddress m_remoteAddress
remote address information
uint64_t | m_rxBytes
total bytes received
bool | m_rxPosted
read outstanding
uint64_t | m_txBytes
total bytes transmitted
bool | m_txPosted
write outstanding

Detailed Description

Stats.

Definition at line 65 of file IpSocket.h.

Constructor & Destructor Documentation

ACTIV_IP_API Activ::IpSocket::Stats::Stats ( const IpSocket & socket )

Constructor.

Note if constructing a Stats object directly, the socket's mutex must be locked (this isn't done by the Stats constructor). Alternatively, use the helper function IpSocket::Stats::Get() which will lock the mutex for you before gathering the stats.

Parameters:
socket to get stats from.

Member Function Documentation

template<typename SOCKET_TYPE>
SOCKET_TYPE::Stats Activ::IpSocket::Stats::Get ( const SOCKET_TYPE & socket ) [inline, static]

Helper function to get stats for a socket.

This is templatized by a derived socket type and locks the socket before gathering the stats.

Parameters:
socket socket to get stats for.
Returns:
Stats for socket.

Definition at line 25 of file IpSocket.h.

References Activ::IpSocket::m_pMutex.

The documentation for this class was generated from the following files:
  • include/ActivMiddleware/ActivIp/Windows/IpSocket.h
  • include/ActivMiddleware/ActivIp/IpSocket.h
Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::IpSocket::TxOverlapped

Activ::IpSocket::TxOverlapped Class Reference

Overlapped class for writes. More...

#include <ActivMiddleware/ActivIp/Windows/IpSocket.h>

Inheritance diagram for Activ::IpSocket::TxOverlapped:

Activ::IoCompletionManager::Overlapped

List of all members.

Public Member Functions

TxOverlapped (IpSocket &ipSocket)
Constructor.

Detailed Description

Overlapped class for writes.

Definition at line 344 of file IpSocket.h.

Constructor & Destructor Documentation

Activ::IpSocket::TxOverlapped::TxOverlapped ( IpSocket & ipSocket )

Constructor.

Parameters:
ipSocket IpSocket containing this object.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivIp/Windows/IpSocket.h
Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ISemaphore

Activ::ISemaphore Class Reference

Abstract base semaphore class. More...

#include <ActivMiddleware/ActivBase/ISemaphore.h>

List of all members.

Public Member Functions

virtual StatusCode | Acquire (const TimeoutPeriod timeout=ACTIV_WAIT_INFINITE)=0
Acquire the semaphore.
virtual StatusCode | Release (const size_t count=1)=0
Release the semaphore.
virtual | ~ISemaphore ()=0
Virtual destructor.

Detailed Description

Abstract base semaphore class.

Definition at line 20 of file ISemaphore.h.

Member Function Documentation

virtual StatusCode Activ::ISemaphore::Acquire ( const TimeoutPeriod timeout = ACTIV_WAIT_INFINITE ) [pure virtual]

Acquire the semaphore.

Parameters:
timeout how long to wait for the semaphore to be signalled, in ms.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_TIMEOUT
STATUS_CODE_FAILURE

virtual StatusCode Activ::ISemaphore::Release ( const size_t count = 1 ) [pure virtual]

Release the semaphore.

Parameters:
count number of times to release the semaphore.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_FAILURE

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivBase/ISemaphore.h
Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ISerializableMessage

Activ::ISerializableMessage Class Reference

Serializable message interface. More...

#include <ActivMiddleware/ActivBase/ISerializableMessage.h>

Inheritance diagram for Activ::ISerializableMessage:

Activ::OpenServiceRequest Activ::OpenServiceResponse

List of all members.

Public Member Functions

virtual StatusCode | Deserialize (MessageValidator &messageValidator)=0
Deserialize the message.
virtual StatusCode | Serialize (MessageBuilder &messageBuilder) const =0
Serialize the message.
virtual | ~ISerializableMessage ()=0
Destructor.

Detailed Description

Serializable message interface.

Definition at line 25 of file ISerializableMessage.h.

Member Function Documentation

virtual StatusCode Activ::ISerializableMessage::Deserialize ( MessageValidator & messageValidator ) [pure virtual]

Deserialize the message.

Parameters:
messageValidator message validator from which the data will be extracted.

Implemented in Activ::OpenServiceRequest, and Activ::OpenServiceResponse.

virtual StatusCode Activ::ISerializableMessage::Serialize ( MessageBuilder & messageBuilder ) const [pure virtual]

Serialize the message.

Parameters:
messageBuilder message builder into which data will be placed.

Implemented in Activ::OpenServiceRequest, and Activ::OpenServiceResponse.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivBase/ISerializableMessage.h
Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ISyncEndPoint

Activ::ISyncEndPoint Class Reference

Endpoint interface class with sync call support. More...

#include <ActivMiddleware/ActivSystem/IEndPoint.h>

Inheritance diagram for Activ::ISyncEndPoint:

Activ::IEndPoint

List of all members.

Public Member Functions

virtual ProcessId | GetCreatorProcessId () const =0
Get the process id of the creator of the endpoint.
virtual EndPointId | GetId () const =0
Get the id of the endpoint.
virtual std::string | GetName () const =0
Get the name of the endpoint.
virtual void | GetStats (Stats &stats) const =0
Get endpoint stats.
virtual StatusCode | SendMessage (HeapMessage &heapMessage, SyncRequestId &syncRequestId)=0
Send a message to the endpoint and initialize a SyncRequestId that can be used to wait for the response.
virtual StatusCode | SendMessage (HeapMessage &heapMessage, const TimeoutPeriod timeout=ACTIV_WAIT_INFINITE)=0
Send a message to the endpoint and wait for a response.

Classes

class | Stats
Stats for a shared endpoint. More...

Detailed Description

Endpoint interface class with sync call support.

Definition at line 298 of file IEndPoint.h.

Member Function Documentation

virtual ProcessId Activ::ISyncEndPoint::GetCreatorProcessId ( ) const [pure virtual]

Get the process id of the creator of the endpoint.

Returns:
The process id of the creator of the endpoint.

virtual EndPointId Activ::ISyncEndPoint::GetId ( ) const [pure virtual]

Get the id of the endpoint.

Returns:
The unique system wide id of the endpoint.

virtual std::string Activ::ISyncEndPoint::GetName ( ) const [pure virtual]

Get the name of the endpoint.

Returns:
A string containing the unique system wide name of the endpoint.

virtual void Activ::ISyncEndPoint::GetStats ( Stats & stats ) const [pure virtual]

Get endpoint stats.

Parameters:
stats reference to a Stats object.

Implements Activ::IEndPoint.

virtual StatusCode Activ::ISyncEndPoint::SendMessage | ( | HeapMessage & | heapMessage,
 |  | SyncRequestId & | syncRequestId |
 | ) |  |  | [pure virtual]

Send a message to the endpoint and initialize a SyncRequestId that can be used to wait for the response.

Parameters:
heapMessage | the message to send.
syncRequestId | reference to a syncRequestId object.
Return values:
STATUS_CODE_SUCCESS | syncRequestId can be used to wait or poll for the response message.
STATUS_CODE_DISABLED | the endpoint is not accepting messages, heapMessage returned to it's heap.

virtual StatusCode Activ::ISyncEndPoint::SendMessage | ( | HeapMessage & | heapMessage,
 |  | const TimeoutPeriod | timeout = ACTIV_WAIT_INFINITE |
 | ) |  |  | [pure virtual]

Send a message to the endpoint and wait for a response.

Parameters:
heapMessage | the message to send.
timeout | how long to wait for the response, in ms.
Return values:
STATUS_CODE_SUCCESS | heapMessage now contains the response message.
STATUS_CODE_TIMEOUT | no message received in the timeout period.
STATUS_CODE_DISABLED | the endpoint is not accepting messages, heapMessage returned to it's heap.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivSystem/IEndPoint.h
Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ISyncEndPoint::Stats

Activ::ISyncEndPoint::Stats Class Reference

Stats for a shared endpoint. More...

#include <ActivMiddleware/ActivSystem/IEndPoint.h>

Inheritance diagram for Activ::ISyncEndPoint::Stats:

Activ::IEndPoint::Stats

List of all members.

Public Member Functions

ACTIV_SYSTEM_EXPORTED_API
StatusCode 		Deserialize (MessageValidator &messageValidator)
Deserialize.
ACTIV_SYSTEM_EXPORTED_API
StatusCode 		Serialize (MessageBuilder &messageBuilder) const
Serialize.

Public Attributes

EndPointId | m_id
std::string | m_name

Detailed Description

Stats for a shared endpoint.

Definition at line 304 of file IEndPoint.h.

Member Function Documentation

ACTIV_SYSTEM_EXPORTED_API StatusCode Activ::ISyncEndPoint::Stats::Deserialize ( MessageValidator & messageValidator )

Deserialize.

Parameters:
messageValidator
Return values:
STATUS_CODE_SUCCESS
...

Reimplemented from Activ::IEndPoint::Stats.

ACTIV_SYSTEM_EXPORTED_API StatusCode Activ::ISyncEndPoint::Stats::Serialize ( MessageBuilder & messageBuilder ) const

Serialize.

Parameters:
messageBuilder
Return values:
STATUS_CODE_SUCCESS
...

Reimplemented from Activ::IEndPoint::Stats.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivSystem/IEndPoint.h
Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ISystem

Activ::ISystem Class Reference

Abstract system interface class. More...

#include <ActivMiddleware/ActivSystem/ISystem.h>

Inheritance diagram for Activ::ISystem:

Activ::SystemProxy Activ::Application Activ::AgentApplication Activ::ThinApplication

List of all members.

Public Member Functions

virtual ISyncEndPoint * | CreateEndPoint (const std::string &name, const bool hasMutex, const IEndPoint::NotificationType notificationType)=0
Create a system endpoint.
virtual IHeap * | CreateHeap (const std::string &name, const IHeap::BucketInfoVector &bucketInfoVector)=0
Create a named memory heap.
virtual IEndPoint * | CreatePrivateEndPoint (const bool hasMutex, const IEndPoint::NotificationType notificationType)=0
Create a private, local memory endpoint.
virtual void | EnumerateObjects (IHeapEnumerator &enumerator)=0
Enumerate all opened heaps.
virtual void | EnumerateObjects (IEndPointEnumerator &enumerator)=0
Enumerate all opened endpoints.
virtual void | EnumerateObjects (IProcessEnumerator &enumerator)=0
Enumerate all opened processes.
virtual IProcess * | GetProcess () const =0
Get this process.
virtual IHeap * | GetSystemHeap () const =0
Get the system heap.
virtual SystemInfo | GetSystemInfo () const =0
Get system info.
virtual std::string | GetSystemName () const =0
Get the name of the system.
virtual ISyncEndPoint * | OpenEndPoint (EndPointId endPointId, Timeout &timeout=Timeout::GetInfinite())=0
Open a system endpoint by id.
virtual ISyncEndPoint * | OpenEndPoint (const std::string &name, Timeout &timeout=Timeout::GetInfinite())=0
Open a system endpoint by name.
virtual IHeap * | OpenHeap (const HeapId heapId, Timeout &timeout=Timeout::GetInfinite())=0
Open an existing named memory heap.
virtual IHeap * | OpenHeap (const std::string &name, Timeout &timeout=Timeout::GetInfinite())=0
Open an existing named memory heap.
virtual IProcess * | OpenProcess (const ProcessId processId, Timeout &timeout=Timeout::GetInfinite())=0
Open an existing process within the shared memory system.
virtual IProcess * | OpenProcess (const std::string &name, Timeout &timeout=Timeout::GetInfinite())=0
Open an existing process within the shared memory system.
virtual | ~ISystem ()=0
Destructor.

Classes

class | IEndPointEnumerator
Endpoint enumerator callback interface. More...
class | IHeapEnumerator
Heap enumerator callback interface. More...
class | IProcessEnumerator
Process enumerator callback interface. More...
class | Settings
Settings. More...
class | SystemInfo
System information. More...

Detailed Description

Abstract system interface class.

Provides functionality to create new or open existing endpoints and heaps.

Definition at line 30 of file ISystem.h.

Member Function Documentation

virtual ISyncEndPoint* Activ::ISystem::CreateEndPoint | ( | const std::string & | name,
 |  | const bool | hasMutex,
 |  | const IEndPoint::NotificationType | notificationType |
 | ) |  |  | [pure virtual]

Create a system endpoint.

The endpoint will exist in shared memory if the system was created with MEMORY_MODEL_SHARED and will be available to other processes in the system. Otherwise it will be created in local memory and can only be opened by this process (using OpenEndPoint()).

Parameters:
name | the name of the endpoint which will exist within the parent system namespace. If name == "", the endpoint is given a name based on a unique id.
hasMutex | true if the endpoint is to be protected by a mutex, else false.
notificationType | primitive to use for data available notification on the endpoint.
Returns:
Pointer to an object providing an ISyncEndPoint interface.
Exceptions:
Exception

Implemented in Activ::SystemProxy.

virtual IHeap* Activ::ISystem::CreateHeap | ( | const std::string & | name,
 |  | const IHeap::BucketInfoVector & | bucketInfoVector |
 | ) |  |  | [pure virtual]

Create a named memory heap.

The heap will exist in shared memory if the system was created with MEMORY_MODEL_SHARED and will be available to other processes in the system. Otherwise it will be created in local memory and can only be opened by this process (using OpenHeap()).

Parameters:
name | the name of the heap which will exist within the parent system namespace.
bucketInfoVector | a vector of BucketInfo classes describing the layout of the heap.
Returns:
Pointer to an object providing an IHeap interface.
Exceptions:
Exception

Implemented in Activ::SystemProxy.

virtual IEndPoint* Activ::ISystem::CreatePrivateEndPoint | ( | const bool | hasMutex,
 |  | const IEndPoint::NotificationType | notificationType |
 | ) |  |  | [pure virtual]

Create a private, local memory endpoint.

Parameters:
hasMutex | true if the endpoint is to be protected by a mutex, else false.
notificationType | primitive to use for data available notification on the endpoint.
Returns:
Pointer to an object providing an IEndPoint interface.
Exceptions:
Exception

Implemented in Activ::SystemProxy.

virtual void Activ::ISystem::EnumerateObjects ( IHeapEnumerator & enumerator ) [pure virtual]

Enumerate all opened heaps.

Parameters:
enumerator reference to an object providing an IHeapEnumerator interface to be called back on a process instance.

Implemented in Activ::SystemProxy.

virtual void Activ::ISystem::EnumerateObjects ( IEndPointEnumerator & enumerator ) [pure virtual]

Enumerate all opened endpoints.

Parameters:
enumerator reference to an object providing an IEndPointEnumerator interface to be called back on an endpoint instance.

Implemented in Activ::SystemProxy.

virtual void Activ::ISystem::EnumerateObjects ( IProcessEnumerator & enumerator ) [pure virtual]

Enumerate all opened processes.

Parameters:
enumerator reference to an object providing an IProcessEnumerator interface to be called back on a process instance.

Implemented in Activ::SystemProxy.

virtual IProcess* Activ::ISystem::GetProcess ( ) const [pure virtual]

Get this process.

Returns:
An IProcess interface to this process.

Implemented in Activ::SystemProxy.

virtual IHeap* Activ::ISystem::GetSystemHeap ( ) const [pure virtual]

Get the system heap.

Returns:
An object providing an IHeap interface.

Implemented in Activ::SystemProxy.

virtual SystemInfo Activ::ISystem::GetSystemInfo ( ) const [pure virtual]

Get system info.

Returns:
SystemInfo.
Exceptions:
Exception.

Implemented in Activ::SystemProxy.

virtual std::string Activ::ISystem::GetSystemName ( ) const [pure virtual]

Get the name of the system.

Returns:
A string object containing the name of the system.

Implemented in Activ::SystemProxy.

virtual ISyncEndPoint* Activ::ISystem::OpenEndPoint | ( | EndPointId | endPointId,
 |  | Timeout & | timeout = Timeout::GetInfinite() |
 | ) |  |  | [pure virtual]

Open a system endpoint by id.

Parameters:
endPointId | the system unique id of the endpoint to open.
timeout | a Timeout object specifying how long to wait for the endpoint to exist.
Returns:
Pointer to an object providing an ISyncEndPoint interface.
Exceptions:
Exception

Implemented in Activ::SystemProxy.

virtual ISyncEndPoint* Activ::ISystem::OpenEndPoint | ( | const std::string & | name,
 |  | Timeout & | timeout = Timeout::GetInfinite() |
 | ) |  |  | [pure virtual]

Open a system endpoint by name.

Parameters:
name | the name of the endpoint which exists within the parent system namespace.
timeout | a Timeout object specifying how long to wait for the endpoint to exist.
Returns:
Pointer to an object providing an ISyncEndPoint interface.
Exceptions:
Exception

Implemented in Activ::SystemProxy.

virtual IHeap* Activ::ISystem::OpenHeap | ( | const HeapId | heapId,
 |  | Timeout & | timeout = Timeout::GetInfinite() |
 | ) |  |  | [pure virtual]

Open an existing named memory heap.

Parameters:
heapId | the system unique id of the heap to open.
timeout | a Timeout object specifying how long to wait for the heap to exist.
Returns:
Pointer to an object providing an IHeap interface.
Exceptions:
Exception

Implemented in Activ::SystemProxy.

virtual IHeap* Activ::ISystem::OpenHeap | ( | const std::string & | name,
 |  | Timeout & | timeout = Timeout::GetInfinite() |
 | ) |  |  | [pure virtual]

Open an existing named memory heap.

Parameters:
name | the name of the heap which exists within the parent system namespace.
timeout | a Timeout object specifying how long to wait for the heap to exist.
Returns:
Pointer to an object providing an IHeap interface.
Exceptions:
Exception

Implemented in Activ::SystemProxy.

virtual IProcess* Activ::ISystem::OpenProcess | ( | const ProcessId | processId,
 |  | Timeout & | timeout = Timeout::GetInfinite() |
 | ) |  |  | [pure virtual]

Open an existing process within the shared memory system.

Parameters:
processId | the id of the process within the system.
timeout | a Timeout object specifying how long to wait for the process to exist, in ms.
Returns:
An object providing an IProcess interface.
Exceptions:
Exception.

Implemented in Activ::SystemProxy.

virtual IProcess* Activ::ISystem::OpenProcess | ( | const std::string & | name,
 |  | Timeout & | timeout = Timeout::GetInfinite() |
 | ) |  |  | [pure virtual]

Open an existing process within the shared memory system.

Parameters:
name | the name of the process.
timeout | a Timeout object specifying how long to wait for the process to exist, in ms.
Returns:
An object providing an IProcess interface.
Exceptions:
Exception.

Implemented in Activ::SystemProxy.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivSystem/ISystem.h
Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ISystem::IEndPointEnumerator

Activ::ISystem::IEndPointEnumerator Class Reference

Endpoint enumerator callback interface. More...

#include <ActivMiddleware/ActivSystem/ISystem.h>

List of all members.

Public Member Functions

virtual bool | OnObject (ISyncEndPoint *const pEndPoint)=0
Callback on an endpoint instance.
virtual | ~IEndPointEnumerator ()=0
Destructor.

Detailed Description

Endpoint enumerator callback interface.

Definition at line 175 of file ISystem.h.

Member Function Documentation

virtual bool Activ::ISystem::IEndPointEnumerator::OnObject ( ISyncEndPoint *const pEndPoint ) [pure virtual]

Callback on an endpoint instance.

Parameters:
pEndPoint pointer to an object providing an ISyncEndPoint interface.
Return values:
true | to continue enumerating.
false | to stop enumerating.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivSystem/ISystem.h
Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ISystem::IHeapEnumerator

Activ::ISystem::IHeapEnumerator Class Reference

Heap enumerator callback interface. More...

#include <ActivMiddleware/ActivSystem/ISystem.h>

List of all members.

Public Member Functions

virtual bool | OnObject (IHeap *const pHeap)=0
Callback on a heap instance.
virtual | ~IHeapEnumerator ()=0
Destructor.

Detailed Description

Heap enumerator callback interface.

Definition at line 197 of file ISystem.h.

Member Function Documentation

virtual bool Activ::ISystem::IHeapEnumerator::OnObject ( IHeap *const pHeap ) [pure virtual]

Callback on a heap instance.

Parameters:
pHeap pointer to an object providing an IHeap interface.
Return values:
true | to continue enumerating.
false | to stop enumerating.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivSystem/ISystem.h
Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ISystem::IProcessEnumerator

Activ::ISystem::IProcessEnumerator Class Reference

Process enumerator callback interface. More...

#include <ActivMiddleware/ActivSystem/ISystem.h>

List of all members.

Public Member Functions

virtual bool | OnObject (IProcess *const pProcess)=0
Callback on a process instance.
virtual | ~IProcessEnumerator ()=0
Destructor.

Detailed Description

Process enumerator callback interface.

Definition at line 153 of file ISystem.h.

Member Function Documentation

virtual bool Activ::ISystem::IProcessEnumerator::OnObject ( IProcess *const pProcess ) [pure virtual]

Callback on a process instance.

Parameters:
pProcess pointer to an object providing an IProcess interface.
Return values:
true | to continue enumerating.
false | to stop enumerating.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivSystem/ISystem.h
Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ISystem::Settings

Activ::ISystem::Settings Class Reference

Settings. More...

#include <ActivMiddleware/ActivSystem/ISystem.h>

Inheritance diagram for Activ::ISystem::Settings:

Activ::Application::Settings Activ::AgentApplication::Settings Activ::ThinApplication::Settings

List of all members.

Public Types

enum | MemoryModel { MEMORY_MODEL_SHARED, MEMORY_MODEL_PRIVATE }
enum | SystemLogMode { SYSTEM_LOG_MODE_OFF, SYSTEM_LOG_MODE_TO_CONSOLE, SYSTEM_LOG_MODE_TO_AGENT }

Public Member Functions

ACTIV_SYSTEM_EXPORTED_API
StatusCode 		Read (const IniFileParser::ConstSectionIterator &sectionIterator)
Read settings from an ini file section.
ACTIV_SYSTEM_EXPORTED_API | Settings ()
Default constructor.

Public Attributes

MemoryModel m_memoryModel
Shared or private memory system (default shared).
uint32_t | m_minimumTimerResolution
Windows only: see timeBeginPeriod() (default is 0, don't call timeBeginPeriod).
Process::ProcessorList m_processorAffinityList
default: do not adjust
std::string | m_processVersion
Process version string.
bool | m_setConsoleTitle
Set console title (default false).
uint32_t | m_smallBlockHeapThreshold
Windows only: see _set_sbh_threshold() (default is 1016).
SystemLogMode m_systemLogMode
System log mode for this process (default to agent).
std::string | m_systemName
Name of the system to create / open (default "System").

Static Protected Attributes

static
ACTIV_SYSTEM_EXPORTED_API
const std::string 		sectionName
All settings are in this section.

Detailed Description

Settings.

Definition at line 37 of file ISystem.h.

Member Enumeration Documentation

enum Activ::ISystem::Settings::MemoryModel

Enumerator:
MEMORY_MODEL_SHARED | System exists in shared memory.
MEMORY_MODEL_PRIVATE | System exists in private memory.

Definition at line 40 of file ISystem.h.

enum Activ::ISystem::Settings::SystemLogMode

Enumerator:
SYSTEM_LOG_MODE_OFF | System log off for this process.
SYSTEM_LOG_MODE_TO_CONSOLE | System log goes to local console for this process.
SYSTEM_LOG_MODE_TO_AGENT | System log messages published to agent for this process.

Definition at line 46 of file ISystem.h.

Member Function Documentation

ACTIV_SYSTEM_EXPORTED_API StatusCode Activ::ISystem::Settings::Read ( const IniFileParser::ConstSectionIterator & sectionIterator )

Read settings from an ini file section.

Parameters:
sectionIterator iterator to an ini file section.
Return values:
STATUS_CODE_SUCCESS
...

Reimplemented in Activ::Application::Settings.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivSystem/ISystem.h
Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ISystem::SystemInfo

Activ::ISystem::SystemInfo Class Reference

System information. More...

#include <ActivMiddleware/ActivSystem/ISystem.h>

Inheritance diagram for Activ::ISystem::SystemInfo:

Activ::SystemInfo

List of all members.

Public Member Functions

ACTIV_SYSTEM_EXPORTED_API
StatusCode 		Deserialize (MessageValidator &messageValidator)
Deserialize system info.
ACTIV_SYSTEM_EXPORTED_API
StatusCode 		Serialize (MessageBuilder &messageBuilder, const SystemInfo &systemInfo) const
Serialize this SystemInfo to the version of the SystemInfo parameter.
ACTIV_SYSTEM_EXPORTED_API
StatusCode 		Serialize (MessageBuilder &messageBuilder) const
Serialize this SystemInfo to the latest version.
ACTIV_SYSTEM_EXPORTED_API | SystemInfo ()
Default constructor.

Public Attributes

Settings::MemoryModel m_memoryModel
Shared or private memory system (default shared).
std::string | m_systemName
System name.
std::string | m_systemVersion
System version.
size_t | m_upTimeSeconds
System uptime in seconds.
DateTime m_utcStartupDateTime
System startup time, utc.

Detailed Description

System information.

Definition at line 87 of file ISystem.h.

Member Function Documentation

ACTIV_SYSTEM_EXPORTED_API StatusCode Activ::ISystem::SystemInfo::Deserialize ( MessageValidator & messageValidator )

Deserialize system info.

Parameters:
messageValidator to deserialize from.
Returns:
STATUS_CODE_SUCCESS or error code.

Reimplemented from Activ::SystemInfo.

ACTIV_SYSTEM_EXPORTED_API StatusCode Activ::ISystem::SystemInfo::Serialize | ( | MessageBuilder & | messageBuilder,
 |  | const SystemInfo & | systemInfo |
 | ) |  |  | const

Serialize this SystemInfo to the version of the SystemInfo parameter.

Parameters:
messageBuilder | to serialize into.
systemInfo | containing the version to serialize to.
Returns:
STATUS_CODE_SUCCESS or error code.

ACTIV_SYSTEM_EXPORTED_API StatusCode Activ::ISystem::SystemInfo::Serialize ( MessageBuilder & messageBuilder ) const

Serialize this SystemInfo to the latest version.

Parameters:
messageBuilder to serialize into.
Returns:
STATUS_CODE_SUCCESS or error code.

Reimplemented from Activ::SystemInfo.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivSystem/ISystem.h
Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::LengthToIntegralType

Activ::LengthToIntegralType< N, S > Class Template Reference

Template to determine ACTIV integral type from length of integral in bytes. More...

#include <ActivMiddleware/BasicTypes.h>

Detailed Description

template<size_t N, bool S>
class Activ::LengthToIntegralType< N, S >

Template to determine ACTIV integral type from length of integral in bytes.

N is the integral type length. S is a whether the type should be signed.

Provides a Type typedef for supported ACTIV types.

Definition at line 263 of file BasicTypes.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/BasicTypes.h
Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Less

Activ::Less< T, RHS > Class Template Reference

Less than comparison object where the right hand side is constant. More...

#include <ActivMiddleware/BasicTypes.h>

List of all members.

Public Member Functions

BOOST_STATIC_ASSERT (boost::is_integral< T >::value)
bool operator() (const T lhs) const

Detailed Description

template<typename T, T RHS>
class Activ::Less< T, RHS >

Less than comparison object where the right hand side is constant.

This is a long winded work around the GCC warning "comparison is always false due to limited range of data type".

Definition at line 869 of file BasicTypes.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/BasicTypes.h
Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::LessThanPairComparisonObject

Activ::LessThanPairComparisonObject< Pair > Class Template Reference

Less than pair comparison function object. More...

#include <ActivMiddleware/Misc/FunctionObjects.h>

List of all members.

Public Member Functions

bool | operator() (const typename Pair::first_type &lhs, const Pair &rhs) const
Function operator.
bool | operator() (const Pair &lhs, const typename Pair::first_type &rhs) const
Function operator.
bool | operator() (const Pair &lhs, const Pair &rhs) const
Function operator.

Detailed Description

template<typename Pair>
class Activ::LessThanPairComparisonObject< Pair >

Less than pair comparison function object.

Definition at line 106 of file FunctionObjects.h.

Member Function Documentation

template<typename Pair>
bool Activ::LessThanPairComparisonObject< Pair >::operator() | ( | const typename Pair::first_type & | lhs,
 |  | const Pair & | rhs |
 | ) |  |  | const [inline]

Function operator.

Parameters:
lhs | a reference to the lhs object.
rhs | a reference to the rhs object.
Returns:
whether the lhs object is less than rhs object.

Definition at line 143 of file FunctionObjects.h.

template<typename Pair>
bool Activ::LessThanPairComparisonObject< Pair >::operator() | ( | const Pair & | lhs,
 |  | const typename Pair::first_type & | rhs |
 | ) |  |  | const [inline]

Function operator.

Parameters:
lhs | a reference to the lhs object.
rhs | a reference to the rhs object.
Returns:
whether the lhs object is less than rhs object.

Definition at line 130 of file FunctionObjects.h.

template<typename Pair>
bool Activ::LessThanPairComparisonObject< Pair >::operator() | ( | const Pair & | lhs,
 |  | const Pair & | rhs |
 | ) |  |  | const [inline]

Function operator.

Parameters:
lhs | a reference to the lhs object.
rhs | a reference to the rhs object.
Returns:
whether the lhs object is less than rhs object.

Definition at line 117 of file FunctionObjects.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/Misc/FunctionObjects.h
Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::LicenseServiceApi

Activ::LicenseServiceApi Class Reference

Api to agent's license service. More...

#include <ActivMiddleware/ActivFramework/LicenseServiceApi.h>

List of all members.

Static Public Member Functions

static ACTIV_FRAMEWORK_API
StatusCode 		GetIniFileParser (const Component &component, IniFileParser &iniFileParser)
Get the ini file parser containing the license.
static ACTIV_FRAMEWORK_API
StatusCode 		GetSectionName (const Component &component, std::string &sectionName)
Get name of the ini file section containing the license.

Detailed Description

Api to agent's license service.

Definition at line 24 of file LicenseServiceApi.h.

Member Function Documentation

static ACTIV_FRAMEWORK_API StatusCode Activ::LicenseServiceApi::GetIniFileParser | ( | const Component & | component,
 |  | IniFileParser & | iniFileParser |
 | ) |  |  | [static]

Get the ini file parser containing the license.

Parameters:
component | component that wishes to get the ini file parser.
iniFileParser | reference to object to receive the ini file parser.
Return values:
STATUS_CODE_SUCCESS
...

static ACTIV_FRAMEWORK_API StatusCode Activ::LicenseServiceApi::GetSectionName | ( | const Component & | component,
 |  | std::string & | sectionName |
 | ) |  |  | [static]

Get name of the ini file section containing the license.

Parameters:
component | component that wishes to get the section name.
sectionName | reference to object to receive the section name.
Return values:
STATUS_CODE_SUCCESS
...

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivFramework/LicenseServiceApi.h
Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::LocalTime

Activ::LocalTime Class Reference

Local time class. More...

#include <ActivMiddleware/ActivFramework/TimeHelper.h>

Inheritance diagram for Activ::LocalTime:

Activ::BaseTime

List of all members.

Public Member Functions

DateTime | Get () const
Get.
ACTIV_FRAMEWORK_API | LocalTime (const BaseTime &baseTime)
Copy constructor.
ACTIV_FRAMEWORK_API | LocalTime (const Date &date, const Time &time)
Constructor.
ACTIV_FRAMEWORK_API | LocalTime (const DateTime &dateTime)
Constructor.
ACTIV_FRAMEWORK_API | LocalTime (const uint16_t year, const uint8_t month=1, const uint8_t day=1, const uint8_t hour=0, const uint8_t minute=0, const uint8_t second=0, uint16_t millisecond=0)
Constructor.
ACTIV_FRAMEWORK_API | LocalTime ()
Default constructor.

Static Public Member Functions

static ACTIV_FRAMEWORK_API
LocalTime 		GetCurrent ()
Get current local time.
static ACTIV_FRAMEWORK_API
LocalTime 		GetMidnight ()
Create a LocalTime object representing the next midnight.

Detailed Description

Local time class.

Definition at line 401 of file TimeHelper.h.

Constructor & Destructor Documentation

ACTIV_FRAMEWORK_API Activ::LocalTime::LocalTime | ( | const uint16_t | year,
 |  | const uint8_t | month = 1,
 |  | const uint8_t | day = 1,
 |  | const uint8_t | hour = 0,
 |  | const uint8_t | minute = 0,
 |  | const uint8_t | second = 0,
 |  | uint16_t | millisecond = 0 |
 | ) |  |  | [explicit]

Constructor.

Construct from specific local time.

Parameters:
year | the year.
month | the month.
day | the day.
hour | the hour.
minute | the minute.
second | the second.
millisecond | the millisecond.

ACTIV_FRAMEWORK_API Activ::LocalTime::LocalTime ( const DateTime & dateTime )

Constructor.

Construct from specific local time.

Parameters:
dateTime the date/time.

ACTIV_FRAMEWORK_API Activ::LocalTime::LocalTime | ( | const Date & | date,
 |  | const Time & | time
 | ) |  |

Constructor.

Construct from specific local time.

Parameters:
date | the date.
time | the time.

ACTIV_FRAMEWORK_API Activ::LocalTime::LocalTime ( const BaseTime & baseTime )

Copy constructor.

Parameters:
baseTime time to copy from (can be LocalTime or UtcTime).

Member Function Documentation

DateTime Activ::LocalTime::Get ( ) const [inline]

Get.

Returns:
the date/time.

Definition at line 546 of file TimeHelper.h.

References Activ::BaseTime::GetDay(), Activ::BaseTime::GetHour(), Activ::BaseTime::GetMillisecond(), Activ::BaseTime::GetMinute(), Activ::BaseTime::GetMonth(), Activ::BaseTime::GetSecond(), and Activ::BaseTime::GetYear().

Referenced by Activ::Timeband::IsIn().

static ACTIV_FRAMEWORK_API LocalTime Activ::LocalTime::GetCurrent ( ) [static]

Get current local time.

Returns:
LocalTime initialized with the current time.

Reimplemented from Activ::BaseTime.

static ACTIV_FRAMEWORK_API LocalTime Activ::LocalTime::GetMidnight ( ) [static]

Create a LocalTime object representing the next midnight.

Returns:
LocalTime initialized with the next midnight time.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivFramework/TimeHelper.h
Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::LoggerDefinitions

Activ::LoggerDefinitions Class Reference

Logger definitions class. More...

#include <ActivMiddleware/ActivFramework/LoggerDefinitions.h>

List of all members.

Public Types

enum | FileType { ACTIV_DECLARE_ELEMENT_1_WITH_COMMA }
Log file type enumeration. More...

Static Public Member Functions

static ACTIV_FRAMEWORK_API
std::string 		TypeToString (const FileType logFileType)
Get the type as a string.

Static Public Attributes

static const uint64_t | MAX_FILE_SIZE_UNDEFINED = static_cast<uint64_t>(~0)
static const size_t | NUMBER_OF_BACKUPS_UNDEFINED = static_cast<size_t>(~0)
static const PortId | servicePortId = 0
fixed port number of logger service

Detailed Description

Logger definitions class.

Definition at line 29 of file LoggerDefinitions.h.

Member Enumeration Documentation

enum Activ::LoggerDefinitions::FileType

Log file type enumeration.

Enumerator:
ACTIV_DECLARE_ELEMENT_1_WITH_COMMA list of log file types

number of log file types

Definition at line 40 of file LoggerDefinitions.h.

Member Function Documentation

static ACTIV_FRAMEWORK_API std::string Activ::LoggerDefinitions::TypeToString ( const FileType logFileType ) [static]

Get the type as a string.

Parameters:
logFileType the log file type.
Returns:
the type as a string.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivFramework/LoggerDefinitions.h
Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::LoggerServiceApi

Activ::LoggerServiceApi Class Reference

Api to the agent's logger service. More...

#include <ActivMiddleware/ActivFramework/LoggerServiceApi.h>

List of all members.

Static Public Member Functions

static ACTIV_FRAMEWORK_API
StatusCode 		CloseLogFile (const Component &component, Address &logAddress)
Close a log file.
static ACTIV_FRAMEWORK_API
StatusCode 		LogMessage (const Component &component, const Address &logAddress, HeapMessage &heapMessage)
Log a message to a log file.
static ACTIV_FRAMEWORK_API
StatusCode 		LogMessage (const Component &component, const Address &logAddress, const void *pMessage, const size_t messageLength)
Log a message to a log file.
static ACTIV_FRAMEWORK_API
StatusCode 		LogMessage (const Component &component, const Address &logAddress, const boost::format &message)
Log a message to a log file.
static ACTIV_FRAMEWORK_API
StatusCode 		LogMessage (const Component &component, const Address &logAddress, const std::string &message)
Log a message to a log file.
static ACTIV_FRAMEWORK_API
StatusCode 		OpenLogFile (const Component &component, const std::string &fileName, const LoggerDefinitions::FileType fileType, const uint64_t maxFileSize, const size_t nBackups, const bool isUniqueFileName, Address::Proxy logAddress)
Open a curbed log file.
static ACTIV_FRAMEWORK_API
StatusCode 		OpenLogFile (const Component &component, const std::string &fileName, const LoggerDefinitions::FileType fileType, const uint64_t maxFileSize, const size_t nBackups, Address::Proxy logAddress)
Open a rolling log file.
static ACTIV_FRAMEWORK_API
StatusCode 		OpenLogFile (const Component &component, const std::string &fileName, const LoggerDefinitions::FileType fileType, const bool isUniqueFileName, Address::Proxy logAddress)
Open a log file.
static ACTIV_FRAMEWORK_API
StatusCode 		SetLogHeader (const Component &component, const Address &logAddress, const std::string &header)
Set header for a log file.

Detailed Description

Api to the agent's logger service.

Definition at line 25 of file LoggerServiceApi.h.

Member Function Documentation

static ACTIV_FRAMEWORK_API StatusCode Activ::LoggerServiceApi::CloseLogFile | ( | const Component & | component,
 |  | Address & | logAddress |
 | ) |  |  | [static]

Close a log file.

Parameters:
component | that wishes to close the log file.
logAddress | the address of a log file. This is cleared down on success.
Return values:
STATUS_CODE_SUCCESS
...

static ACTIV_FRAMEWORK_API StatusCode Activ::LoggerServiceApi::LogMessage | ( | const Component & | component,
 |  | const Address & | logAddress,
 |  | HeapMessage & | heapMessage |
 | ) |  |  | [static]

Log a message to a log file.

Parameters:
component | that wishes to log.
logAddress | the address of a log file.
heapMessage | a HeapMessage containing the message to log.
Return values:
STATUS_CODE_SUCCESS
...

static ACTIV_FRAMEWORK_API StatusCode Activ::LoggerServiceApi::LogMessage | ( | const Component & | component,
 |  | const Address & | logAddress,
 |  | const void * | pMessage,
 |  | const size_t | messageLength |
 | ) |  |  | [static]

Log a message to a log file.

Parameters:
component | that wishes to log.
logAddress | the address of a log file.
pMessage | the message to log.
messageLength | the length of the message.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_HEAP_EMPTY
...

static ACTIV_FRAMEWORK_API StatusCode Activ::LoggerServiceApi::LogMessage | ( | const Component & | component,
 |  | const Address & | logAddress,
 |  | const boost::format & | message |
 | ) |  |  | [static]

Log a message to a log file.

Parameters:
component | that wishes to log.
logAddress | the address of a log file.
message | boost::format containing the message to log.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_HEAP_EMPTY
...

static ACTIV_FRAMEWORK_API StatusCode Activ::LoggerServiceApi::LogMessage | ( | const Component & | component,
 |  | const Address & | logAddress,
 |  | const std::string & | message |
 | ) |  |  | [static]

Log a message to a log file.

Parameters:
component | that wishes to log.
logAddress | the address of a log file.
message | the message to log.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_HEAP_EMPTY
...

static ACTIV_FRAMEWORK_API StatusCode Activ::LoggerServiceApi::OpenLogFile | ( | const Component & | component,
 |  | const std::string & | fileName,
 |  | const LoggerDefinitions::FileType | fileType,
 |  | const uint64_t | maxFileSize,
 |  | const size_t | nBackups,
 |  | const bool | isUniqueFileName,
 |  | Address::Proxy | logAddress |
 | ) |  |  | [static]

Open a curbed log file.

Parameters:
component | that wishes to open the log file.
fileName | the name of the log file.
fileType | the type of the log file.
maxFileSize | the maximum size of the file.
nBackups | the number of backup files.
isUniqueFileName | whether the filename should be unique.
logAddress | reference to an Address object to receive the address of the new log file.
Return values:
STATUS_CODE_SUCCESS
...

static ACTIV_FRAMEWORK_API StatusCode Activ::LoggerServiceApi::OpenLogFile | ( | const Component & | component,
 |  | const std::string & | fileName,
 |  | const LoggerDefinitions::FileType | fileType,
 |  | const uint64_t | maxFileSize,
 |  | const size_t | nBackups,
 |  | Address::Proxy | logAddress |
 | ) |  |  | [static]

Open a rolling log file.

Parameters:
component | that wishes to open the log file.
fileName | the name of the log file.
fileType | the type of the log file.
maxFileSize | the maximum size of the file.
nBackups | the number of backup files.
logAddress | reference to an Address object to receive the address of the new log file.
Return values:
STATUS_CODE_SUCCESS
...

static ACTIV_FRAMEWORK_API StatusCode Activ::LoggerServiceApi::OpenLogFile | ( | const Component & | component,
 |  | const std::string & | fileName,
 |  | const LoggerDefinitions::FileType | fileType,
 |  | const bool | isUniqueFileName,
 |  | Address::Proxy | logAddress |
 | ) |  |  | [static]

Open a log file.

Parameters:
component | that wishes to open the log file.
fileName | the name of the log file.
fileType | the type of the log file.
isUniqueFileName | whether the filename should be unique.
logAddress | reference to an Address object to receive the address of the new log file.
Return values:
STATUS_CODE_SUCCESS
...

static ACTIV_FRAMEWORK_API StatusCode Activ::LoggerServiceApi::SetLogHeader | ( | const Component & | component,
 |  | const Address & | logAddress,
 |  | const std::string & | header |
 | ) |  |  | [static]

Set header for a log file.

The header will be appended to the log file now if the log is empty and whenever a new log is created (e.g. overnight, weekly, etc.). Note a newline will automatically be appended.

Parameters:
component | that wishes to close the log file.
logAddress | the address of a log file.
header
Return values:
STATUS_CODE_SUCCESS
...

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivFramework/LoggerServiceApi.h
Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ManagedEndPoint

Activ::ManagedEndPoint Class Reference

Managed endpoint class. More...

#include <ActivMiddleware/ActivSystem/ManagedEndPoint.h>

Inheritance diagram for Activ::ManagedEndPoint:

Activ::Application Activ::AgentApplication Activ::ThinApplication

List of all members.

Public Types

typedef std::set< PortId > | PortIdSet
type of the set of port ids

Public Member Functions

ACTIV_SYSTEM_EXPORTED_API
StatusCode 		FindPort (const std::string &portName, Address &portAddress) const
Find a port on the endpoint by name.
ACTIV_SYSTEM_EXPORTED_API
ISyncEndPoint * 		GetEndPoint () const
Get the underlying endpoint.
ACTIV_SYSTEM_EXPORTED_API size_t | GetMaxThreads () const
Get the maximum number of threads that can process the endpoint at once.
ACTIV_SYSTEM_EXPORTED_API | ManagedEndPoint (ISystem *const pSystem, const std::string &name, const Settings &settings=Settings())
Constructor.
ACTIV_SYSTEM_EXPORTED_API void | PostDiesToThreads () const
Post shutdown messages to all the threads processing the endpoint.
ACTIV_SYSTEM_EXPORTED_API
StatusCode 		Run ()
Run the endpoint from the context of the calling thread.
ACTIV_SYSTEM_EXPORTED_API
StatusCode 		StartThread ()
Launch a thread to process this endpoint.
ACTIV_SYSTEM_EXPORTED_API
StatusCode 		WaitForThreadsToExit (const TimeoutPeriod timeout=ACTIV_WAIT_INFINITE) const
Wait for all threads to finish processing the endpoint and exit.
virtual ACTIV_SYSTEM_EXPORTED_API | ~ManagedEndPoint ()
Destructor.

Protected Member Functions

virtual
ACTIV_SYSTEM_EXPORTED_API bool 		CanThreadExit ()
Ok to exit this thread?
virtual
ACTIV_SYSTEM_EXPORTED_API void 		Process ()
Overridable endpoint processing function.

Friends

class | Port

Classes

class | RunHelper
Helper class to run an endpoint. More...
class | Settings
Settings for the endpoint. More...

Detailed Description

Managed endpoint class.

A managed endpoint contains the underlying endpoint object and manages ports that are attached to the endpoint and threads that are processing messages from the endpoint.

Definition at line 37 of file ManagedEndPoint.h.

Constructor & Destructor Documentation

ACTIV_SYSTEM_EXPORTED_API Activ::ManagedEndPoint::ManagedEndPoint | ( | ISystem *const | pSystem,
 |  | const std::string & | name,
 |  | const Settings & | settings = Settings()
 | ) |  |

Constructor.

This constructor creates an endpoint with the given name. No threads are launched.

Parameters:
pSystem | the system that will create the endpoint.
name | the name of the endpoint.
settings | settings for the endpoint.
Exceptions:
Exception.

virtual ACTIV_SYSTEM_EXPORTED_API Activ::ManagedEndPoint::~ManagedEndPoint ( ) [virtual]

Destructor.

The destructor stops the endpoint from receiving any more messages, and clears any queued messages.

Member Function Documentation

virtual ACTIV_SYSTEM_EXPORTED_API bool Activ::ManagedEndPoint::CanThreadExit ( ) [protected, virtual]

Ok to exit this thread?

Once a thread has received an exit message, CanThreadExit() will subsequently be invoked after processing of any message by that thread to determine if the thread can actually exit. Default behaviour is to return true.

Return values:
true | this thread can exit
false | this thread cannot exit

Reimplemented in Activ::AgentApplication.

ACTIV_SYSTEM_EXPORTED_API StatusCode Activ::ManagedEndPoint::FindPort | ( | const std::string & | portName,
 |  | Address & | portAddress |
 | ) |  |  | const

Find a port on the endpoint by name.

Parameters:
portName | name of the port to find.
portAddress | a reference to an Address to receive port's address.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_FOUND

ACTIV_SYSTEM_EXPORTED_API ISyncEndPoint* Activ::ManagedEndPoint::GetEndPoint ( ) const

Get the underlying endpoint.

Returns:
The ISyncEndPoint interface of the endpoint.

ACTIV_SYSTEM_EXPORTED_API size_t Activ::ManagedEndPoint::GetMaxThreads ( ) const

Get the maximum number of threads that can process the endpoint at once.

Returns:
The maximum number of threads that can process the endpoint at once.

virtual ACTIV_SYSTEM_EXPORTED_API void Activ::ManagedEndPoint::Process ( ) [protected, virtual]

Overridable endpoint processing function.

This function is called from the thread launched by a StartThread() call, it is *not* called after using the Run function object.

ACTIV_SYSTEM_EXPORTED_API StatusCode Activ::ManagedEndPoint::Run ( )

Run the endpoint from the context of the calling thread.

This call will run return until the endpoint has received die messages from PostDiesToThreads().

Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_FULL too many threads already running.

ACTIV_SYSTEM_EXPORTED_API StatusCode Activ::ManagedEndPoint::StartThread ( )

Launch a thread to process this endpoint.

The virtual method Process() is called from the new thread. The default behaviour of Process() is to run the endpoint until dies are received (essentially Run() from the new thread).

Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_FAILURE
STATUS_CODE_HEAP_EMPTY
STATUS_CODE_FULL

ACTIV_SYSTEM_EXPORTED_API StatusCode Activ::ManagedEndPoint::WaitForThreadsToExit ( const TimeoutPeriod timeout = ACTIV_WAIT_INFINITE ) const

Wait for all threads to finish processing the endpoint and exit.

Parameters:
timeout how long to wait, in ms.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_FAILURE
STATUS_CODE_TIMEOUT
STATUS_CODE_IN_USE called from within a thread processing the endpoint

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivSystem/ManagedEndPoint.h
Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ManagedEndPoint::RunHelper

Activ::ManagedEndPoint::RunHelper Class Reference

Helper class to run an endpoint. More...

#include <ActivMiddleware/ActivSystem/ManagedEndPoint.h>

List of all members.

Public Member Functions

ACTIV_SYSTEM_EXPORTED_API
StatusCode 		operator() (const size_t maxMessagesToProcess, const TimeoutPeriod timeout)
Pump the endpoint message loop.
ACTIV_SYSTEM_EXPORTED_API | RunHelper (ManagedEndPoint &managedEndPoint)
Constructor.
ACTIV_SYSTEM_EXPORTED_API | ~RunHelper ()
Destructor.

Detailed Description

Helper class to run an endpoint.

The behavior of the Run() method and the thread started by a call to StartThread() is to not return until the endpoint has received die messages (from PostDiesToThreads()).

However, if you wish to integrate the endpoint message loop with another event loop mechanism it may be necessary to poll the endpoint, or only block for a small timeout period. This can be accomplished with the RunHelper class:

Application application; ManagedEndPoint::Run applicationRun(application);

switch (applicationRun(0, 10)) { case STATUS_CODE_SUCCESS: // message processed break;

case STATUS_CODE_TIMEOUT: // no messages on endpoint in the timeout period break;

case STATUS_CODE_EXIT: // endpoint has received dies break; }

Definition at line 111 of file ManagedEndPoint.h.

Constructor & Destructor Documentation

ACTIV_SYSTEM_EXPORTED_API Activ::ManagedEndPoint::RunHelper::RunHelper ( ManagedEndPoint & managedEndPoint )

Constructor.

Sets up the calling thread to run the endpoint.

Parameters:
managedEndPoint the endpoint to run.
Exceptions:
StatusCodeException if too many threads are processing the endpoint already, out of memory.

ACTIV_SYSTEM_EXPORTED_API Activ::ManagedEndPoint::RunHelper::~RunHelper ( )

Destructor.

Cleans up some thread local state.

Member Function Documentation

ACTIV_SYSTEM_EXPORTED_API StatusCode Activ::ManagedEndPoint::RunHelper::operator() | ( | const size_t | maxMessagesToProcess,
 |  | const TimeoutPeriod | timeout
 | ) |  |

Pump the endpoint message loop.

Parameters:
maxMessagesToProcess | 0 for no limit, else number of messages to process before returning.
timeout | how long to wait for messages on the endpoint, in ms, or ACTIV_WAIT_INFINITE.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_TIMEOUT | no message on the endpoint
STATUS_CODE_EXIT | endpoint received a die message whilst processing messages on the endpoint.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivSystem/ManagedEndPoint.h
Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ManagedEndPoint::Settings

Activ::ManagedEndPoint::Settings Class Reference

Settings for the endpoint. More...

#include <ActivMiddleware/ActivSystem/ManagedEndPoint.h>

List of all members.

Public Member Functions

ACTIV_SYSTEM_EXPORTED_API
StatusCode 		Read (const IniFileParser::ConstSectionIterator &sectionIterator)
Read settings from an ini file section.
ACTIV_SYSTEM_EXPORTED_API | Settings ()
Default constructor.

Public Attributes

PortId | m_initialPortListSize
default: 64
size_t | m_maxThreads
default: 1
PortId | m_minFreePortIdListSize
default: 32
IEndPoint::NotificationType m_notificationType
default: NOTIFICATION_TYPE_DEFAULT
PortIdSet m_reservedPortIdSet
default: empty
uint32_t | m_threadPriority
default: THREAD_PRIORITY_NORMAL
Thread::ProcessorList m_threadProcessorAffinityList
default: do not adjust

Detailed Description

Settings for the endpoint.

m_maxThreads the maximum number of threads that can be running the endpoint message loop at any one time. m_notificationType the mechanism to use for notification of messages arriving on the endpoint. m_initialPortListSize initial size of the port list, also used to grow the port list. m_minFreePortIdListSize this number of port ids must be in the free list before a port can be resused. m_reservedPortIdSet a set of PortIds that cannot by dynamically allocated by AttachPort().

Definition at line 51 of file ManagedEndPoint.h.

Member Function Documentation

ACTIV_SYSTEM_EXPORTED_API StatusCode Activ::ManagedEndPoint::Settings::Read ( const IniFileParser::ConstSectionIterator & sectionIterator )

Read settings from an ini file section.

Parameters:
sectionIterator iterator to an ini file section.
Return values:
STATUS_CODE_SUCCESS
...

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivSystem/ManagedEndPoint.h
Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::MessageBuilder

Activ::MessageBuilder Class Reference

Message builder class. More...

#include <ActivMiddleware/ActivBase/MessageBuilder.h>

Inheritance diagram for Activ::MessageBuilder:

Activ::MessageHandler

List of all members.

Public Member Functions

template<typename T>
ACTIV_BASE_INLINE_API StatusCode | Append (const T value, const size_t size, const Endian endian)
Append a built-in type.
template<typename T>
ACTIV_BASE_INLINE_API StatusCode | Append (const T value, const Endian endian)
Append a built-in type.
ACTIV_BASE_INLINE_API StatusCode | Append (const std::string &str)
Append a string.
ACTIV_BASE_INLINE_API StatusCode | Append (const char character, const size_t count)
Append characters.
ACTIV_BASE_INLINE_API StatusCode | Append (const char character)
Append a character.
ACTIV_BASE_INLINE_API StatusCode | Append (const void *const pBuffer, const size_t length)
Append a buffer.
ACTIV_BASE_INLINE_API StatusCode | AppendBoolean (const bool value)
Append a boolean value.
ACTIV_BASE_INLINE_API StatusCode | AppendInEndian (const void *const pValue, const size_t size, const Endian endian)
Append a variable length binary integral value with a given endian ordering.
ACTIV_BASE_INLINE_API StatusCode | Erase (const size_t offset, const size_t length)
Erase a buffer / binary integral value.
ACTIV_BASE_INLINE_API size_t | GetBufferSize () const
Get the message buffer size.
ACTIV_BASE_INLINE_API size_t | GetLength () const
Get the length of the message.
ACTIV_BASE_INLINE_API const void * | GetMessage () const
Get the address of the message.
ACTIV_BASE_INLINE_API StatusCode | Initialize (void *const pBuffer, const size_t bufferSize, const bool shouldAdjustBufferSize=true, const MessageVersion messageVersion=MESSAGE_VERSION_UNDEFINED)
Initialize.
ACTIV_BASE_INLINE_API StatusCode | Initialize (const size_t initialBufferSize, const bool shouldAdjustBufferSize=true, const MessageVersion messageVersion=MESSAGE_VERSION_UNDEFINED)
Initialize.
template<typename T>
ACTIV_BASE_INLINE_API StatusCode | Insert (const size_t offset, const T value, const size_t size, const Endian endian)
Insert a built-in type.
template<typename T>
ACTIV_BASE_INLINE_API StatusCode | Insert (const size_t offset, const T value, const Endian endian)
Insert a built-in type.
ACTIV_BASE_INLINE_API StatusCode | Insert (const size_t offset, const std::string &str)
Insert a string.
ACTIV_BASE_INLINE_API StatusCode | Insert (const size_t offset, const char character, const size_t count)
Insert characters.
ACTIV_BASE_INLINE_API StatusCode | Insert (const size_t offset, const char character)
Insert a character.
ACTIV_BASE_INLINE_API StatusCode | Insert (const size_t offset, const void *const pBuffer, const size_t length)
Insert a buffer.
ACTIV_BASE_INLINE_API StatusCode | InsertBoolean (const size_t offset, const bool value)
Insert a boolean value.
ACTIV_BASE_INLINE_API StatusCode | InsertInEndian (const size_t offset, const void *const pValue, const size_t size, const Endian endian)
Insert a variable length binary integral value with a given endian ordering.
ACTIV_BASE_INLINE_API | MessageBuilder (const MessageBuilder &rhs)
Copy constructor.
ACTIV_BASE_INLINE_API | MessageBuilder (void *const pBuffer, const size_t bufferSize, const bool shouldAdjustBufferSize=true, const MessageVersion messageVersion=MESSAGE_VERSION_UNDEFINED)
Constructor.
ACTIV_BASE_INLINE_API | MessageBuilder (const size_t initialBufferSize=0, const bool shouldAdjustBufferSize=true, const MessageVersion messageVersion=MESSAGE_VERSION_UNDEFINED)
Default constructor.
ACTIV_BASE_INLINE_API const
MessageBuilder 		operator+ (const MessageBuilder &rhs) const
Addition operator.
ACTIV_BASE_INLINE_API
MessageBuilder & 		operator+= (const MessageBuilder &rhs)
Addition assignment operator.
ACTIV_BASE_INLINE_API
MessageBuilder & 		operator= (const MessageBuilder &rhs)
Assignment operator.
template<typename T>
ACTIV_BASE_INLINE_API StatusCode | Overwrite (const size_t offset, const T value, const size_t size, const Endian endian)
Overwrite a built-in type.
template<typename T>
ACTIV_BASE_INLINE_API StatusCode | Overwrite (const size_t offset, const T value, const Endian endian)
Overwrite a built-in type.
ACTIV_BASE_INLINE_API StatusCode | Overwrite (const size_t offset, const std::string &str)
Overwrite a string.
ACTIV_BASE_INLINE_API StatusCode | Overwrite (const size_t offset, const char character, const size_t count)
Overwrite characters.
ACTIV_BASE_INLINE_API StatusCode | Overwrite (const size_t offset, const char character)
Overwrite a character.
ACTIV_BASE_INLINE_API StatusCode | Overwrite (const size_t offset, const void *const pBuffer, const size_t length)
Overwrite a buffer.
ACTIV_BASE_INLINE_API StatusCode | OverwriteBoolean (const size_t offset, const bool value)
Overwrite a boolean value.
ACTIV_BASE_INLINE_API StatusCode | OverwriteInEndian (const size_t offset, const void *const pValue, const size_t size, const Endian endian)
Overwrite a variable length binary integral value with a given endian ordering.
ACTIV_BASE_INLINE_API void | Reset (const MessageVersion messageVersion=MESSAGE_VERSION_UNDEFINED)
Reset.
ACTIV_BASE_INLINE_API StatusCode | SetBufferSize (const size_t bufferSize)
Set the message buffer size.
ACTIV_BASE_INLINE_API StatusCode | SetLength (const size_t length)
Set the length of the message.
ACTIV_BASE_INLINE_API | ~MessageBuilder ()
Destructor.

Detailed Description

Message builder class.

Definition at line 27 of file MessageBuilder.h.

Constructor & Destructor Documentation

Activ::MessageBuilder::MessageBuilder | ( | const size_t | initialBufferSize = 0,
 |  | const bool | shouldAdjustBufferSize = true,
 |  | const MessageVersion | messageVersion = MESSAGE_VERSION_UNDEFINED |
 | ) |  |  | [inline]

Default constructor.

Parameters:
initialBufferSize | the initial size of the message buffer.
shouldAdjustBufferSize | indicates whether the size of the message buffer should be adjusted (if required).
messageVersion | optional version.
Exceptions:
StatusCodeException

Definition at line 849 of file MessageBuilder.h.

References ACTIV_THROW_RESULT_IF.

Referenced by operator+().

Activ::MessageBuilder::MessageBuilder | ( | void *const | pBuffer,
 |  | const size_t | bufferSize,
 |  | const bool | shouldAdjustBufferSize = true,
 |  | const MessageVersion | messageVersion = MESSAGE_VERSION_UNDEFINED |
 | ) |  |  | [inline]

Constructor.

Parameters:
pBuffer | the address of the message buffer.
bufferSize | the size of the message buffer.
shouldAdjustBufferSize | indicates whether the size of the message buffer should be adjusted (if required).
messageVersion | optional version.

Definition at line 866 of file MessageBuilder.h.

Activ::MessageBuilder::MessageBuilder ( const MessageBuilder & rhs ) [inline]

Copy constructor.

Parameters:
rhs the value to assign to this object.
Exceptions:
StatusCodeException

Definition at line 879 of file MessageBuilder.h.

References ACTIV_THROW_RESULT_IF, m_length, and m_pBuffer.

Member Function Documentation

template<typename T>
StatusCode Activ::MessageBuilder::Append | ( | const T | value,
 |  | const size_t | size,
 |  | const Endian | endian |
 | ) |  |  | [inline]

Append a built-in type.

T is the built-in type.

Parameters:
size | the number of bytes of value to append.
value | the value to place in the message.
endian | the endian to copy the value in.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_BUFFER_OVERFLOW
STATUS_CODE_INVALID_PARAMETER | for instance if size > sizeof(T).
STATUS_CODE_OUT_OF_RANGE | if value will not fit in size bytes.
STATUS_CODE_HEAP_EMPTY

Definition at line 1072 of file MessageBuilder.h.

References ACTIV_RETURN_RESULT_IF, Append(), and AppendInEndian().

template<typename T>
StatusCode Activ::MessageBuilder::Append | ( | const T | value,
 |  | const Endian | endian |
 | ) |  |  | [inline]

Append a built-in type.

T is the built-in type.

Parameters:
value | the value to place in the message.
endian | the endian to copy the value in.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_BUFFER_OVERFLOW
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_HEAP_EMPTY

Definition at line 1064 of file MessageBuilder.h.

References Activ::MessageHandler::ENDIAN_LOCAL.

StatusCode Activ::MessageBuilder::Append ( const std::string & str ) [inline]

Append a string.

Parameters:
str the string to place in the message.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_BUFFER_OVERFLOW
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_HEAP_EMPTY

Definition at line 1049 of file MessageBuilder.h.

References ACTIV_RETURN_RESULT_IF, and Activ::MessageHandler::ENDIAN_LITTLE.

StatusCode Activ::MessageBuilder::Append | ( | const char | character,
 |  | const size_t | count |
 | ) |  |  | [inline]

Append characters.

Parameters:
character | the character to place in the message.
count | the number of character to place in the message.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_BUFFER_OVERFLOW
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_HEAP_EMPTY

Definition at line 1042 of file MessageBuilder.h.

StatusCode Activ::MessageBuilder::Append ( const char character ) [inline]

Append a character.

Parameters:
character the character to place in the message.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_BUFFER_OVERFLOW
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_HEAP_EMPTY

Definition at line 1035 of file MessageBuilder.h.

StatusCode Activ::MessageBuilder::Append | ( | const void *const | pBuffer,
 |  | const size_t | length |
 | ) |  |  | [inline]

Append a buffer.

Parameters:
pBuffer | the address of the buffer to place in the message.
length | the length of the buffer to place in the message.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_BUFFER_OVERFLOW
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_HEAP_EMPTY

Definition at line 1021 of file MessageBuilder.h.

Referenced by Append(), Activ::SerializableBuffer< LENGTH_TYPE, MIN_LENGTH, MAX_LENGTH >::Serialize(), Activ::RequestId::Serialize(), and Activ::Address::Serialize().

StatusCode Activ::MessageBuilder::AppendBoolean ( const bool value ) [inline]

Append a boolean value.

Parameters:
value the boolean value to place in the message.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_BUFFER_OVERFLOW
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_HEAP_EMPTY

Definition at line 1125 of file MessageBuilder.h.

StatusCode Activ::MessageBuilder::AppendInEndian | ( | const void *const | pValue,
 |  | const size_t | size,
 |  | const Endian | endian |
 | ) |  |  | [inline]

Append a variable length binary integral value with a given endian ordering.

Parameters:
pValue | the address of the value to place in the message.
size | the size of the value to place in the message.
endian | the endian to copy the value in.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_BUFFER_OVERFLOW
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_HEAP_EMPTY

Definition at line 1028 of file MessageBuilder.h.

References Activ::MessageHandler::ENDIAN_LOCAL.

Referenced by Append().

StatusCode Activ::MessageBuilder::Erase | ( | const size_t | offset,
 |  | const size_t | length |
 | ) |  |  | [inline]

Erase a buffer / binary integral value.

Parameters:
offset | the offset in the message from which to erase.
length | the length of the buffer to erase from the message.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_BUFFER_OVERFLOW
STATUS_CODE_INVALID_PARAMETER

Definition at line 1132 of file MessageBuilder.h.

size_t Activ::MessageBuilder::GetBufferSize ( ) const [inline]

Get the message buffer size.

Returns:
the size of the message buffer.

Definition at line 1004 of file MessageBuilder.h.

size_t Activ::MessageBuilder::GetLength ( ) const [inline]

Get the length of the message.

Returns:
the length of the message.

Definition at line 985 of file MessageBuilder.h.

Referenced by Activ::HeapMessageBuilder::GetHeapMessage().

const void * Activ::MessageBuilder::GetMessage ( ) const [inline]

Get the address of the message.

Returns:
the address of the message.

Definition at line 978 of file MessageBuilder.h.

Referenced by Activ::HeapMessageBuilder::GetHeapMessage().

StatusCode Activ::MessageBuilder::Initialize | ( | void *const | pBuffer,
 |  | const size_t | bufferSize,
 |  | const bool | shouldAdjustBufferSize = true,
 |  | const MessageVersion | messageVersion = MESSAGE_VERSION_UNDEFINED |
 | ) |  |  | [inline]

Initialize.

Parameters:
pBuffer | the address of the message buffer.
bufferSize | the size of the message buffer.
shouldAdjustBufferSize | indicates whether the size of the message buffer should be adjusted (if required).
messageVersion | optional version.
Return values:
STATUS_CODE_SUCCESS

Definition at line 953 of file MessageBuilder.h.

References ACTIV_RETURN_RESULT_IF, and Reset().

StatusCode Activ::MessageBuilder::Initialize | ( | const size_t | initialBufferSize,
 |  | const bool | shouldAdjustBufferSize = true,
 |  | const MessageVersion | messageVersion = MESSAGE_VERSION_UNDEFINED |
 | ) |  |  | [inline]

Initialize.

Parameters:
initialBufferSize | the initial size of the message buffer.
shouldAdjustBufferSize | indicates whether the size of the message buffer should be adjusted (if required).
messageVersion | optional version.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_HEAP_EMPTY

Definition at line 931 of file MessageBuilder.h.

References ACTIV_RETURN_RESULT_IF, and Reset().

Referenced by Activ::HeapMessageBuilder::HeapMessageBuilder().

template<typename T>
StatusCode Activ::MessageBuilder::Insert | ( | const size_t | offset,
 |  | const T | value,
 |  | const size_t | size,
 |  | const Endian | endian |
 | ) |  |  | [inline]

Insert a built-in type.

T is the built-in type.

Parameters:
offset | the offset at which to insert in the message.
value | the value to place in the message.
size | the number of bytes of value to append.
endian | the endian to copy the value in.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_BUFFER_OVERFLOW
STATUS_CODE_INVALID_PARAMETER | for instance if size > sizeof(T).
STATUS_CODE_OUT_OF_RANGE | if value will not fit in size bytes.
STATUS_CODE_HEAP_EMPTY

Definition at line 1190 of file MessageBuilder.h.

References ACTIV_RETURN_RESULT_IF, Insert(), and InsertInEndian().

template<typename T>
StatusCode Activ::MessageBuilder::Insert | ( | const size_t | offset,
 |  | const T | value,
 |  | const Endian | endian |
 | ) |  |  | [inline]

Insert a built-in type.

T is the built-in type.

Parameters:
offset | the offset at which to insert in the message.
value | the value to place in the message.
endian | the endian to copy the value in.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_BUFFER_OVERFLOW
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_HEAP_EMPTY

Definition at line 1182 of file MessageBuilder.h.

References Activ::MessageHandler::ENDIAN_LOCAL.

StatusCode Activ::MessageBuilder::Insert | ( | const size_t | offset,
 |  | const std::string & | str |
 | ) |  |  | [inline]

Insert a string.

Parameters:
offset | the offset at which to insert in the message.
str | the string to place in the message.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_BUFFER_OVERFLOW
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_HEAP_EMPTY

Definition at line 1167 of file MessageBuilder.h.

References ACTIV_RETURN_RESULT_IF, and Activ::MessageHandler::ENDIAN_LITTLE.

StatusCode Activ::MessageBuilder::Insert | ( | const size_t | offset,
 |  | const char | character,
 |  | const size_t | count |
 | ) |  |  | [inline]

Insert characters.

Parameters:
offset | the offset at which to insert in the message.
character | the character to place in the message.
count | the number of characters to place in the message.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_BUFFER_OVERFLOW
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_HEAP_EMPTY

Definition at line 1160 of file MessageBuilder.h.

StatusCode Activ::MessageBuilder::Insert | ( | const size_t | offset,
 |  | const char | character |
 | ) |  |  | [inline]

Insert a character.

Parameters:
offset | the offset at which to insert in the message.
character | the character to place in the message.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_BUFFER_OVERFLOW
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_HEAP_EMPTY

Definition at line 1153 of file MessageBuilder.h.

StatusCode Activ::MessageBuilder::Insert | ( | const size_t | offset,
 |  | const void *const | pBuffer,
 |  | const size_t | length |
 | ) |  |  | [inline]

Insert a buffer.

Parameters:
offset | the offset at which to insert in the message.
pBuffer | the address of the buffer to place in the message.
length | the length of the buffer to place in the message.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_BUFFER_OVERFLOW
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_HEAP_EMPTY

Definition at line 1139 of file MessageBuilder.h.

Referenced by Insert().

StatusCode Activ::MessageBuilder::InsertBoolean | ( | const size_t | offset,
 |  | const bool | value |
 | ) |  |  | [inline]

Insert a boolean value.

Parameters:
offset | the offset at which to insert in the message.
value | the boolean value to place in the message.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_BUFFER_OVERFLOW
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_HEAP_EMPTY

Definition at line 1243 of file MessageBuilder.h.

StatusCode Activ::MessageBuilder::InsertInEndian | ( | const size_t | offset,
 |  | const void *const | pValue,
 |  | const size_t | size,
 |  | const Endian | endian |
 | ) |  |  | [inline]

Insert a variable length binary integral value with a given endian ordering.

Parameters:
offset | the offset at which to insert in the message.
pValue | the address of the value to place in the message.
size | the size of the value to place in the message.
endian | the endian to copy the value in.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_BUFFER_OVERFLOW
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_HEAP_EMPTY

Definition at line 1146 of file MessageBuilder.h.

References Activ::MessageHandler::ENDIAN_LOCAL.

Referenced by Insert().

const MessageBuilder Activ::MessageBuilder::operator+ ( const MessageBuilder & rhs ) const [inline]

Addition operator.

Parameters:
rhs the value to add to this object.
Returns:
a reference to this object.
Exceptions:
StatusCodeException

Definition at line 901 of file MessageBuilder.h.

References MessageBuilder().

MessageBuilder & Activ::MessageBuilder::operator+= ( const MessageBuilder & rhs ) [inline]

Addition assignment operator.

Parameters:
rhs the value to add to this object.
Returns:
a reference to this object.
Exceptions:
StatusCodeException

Definition at line 908 of file MessageBuilder.h.

References ACTIV_THROW_RESULT_IF, m_length, and m_pBuffer.

MessageBuilder & Activ::MessageBuilder::operator= ( const MessageBuilder & rhs ) [inline]

Assignment operator.

Parameters:
rhs the value to assign to this object.
Returns:
a reference to this object.
Exceptions:
StatusCodeException

Definition at line 917 of file MessageBuilder.h.

References ACTIV_THROW_RESULT_IF, m_length, m_pBuffer, and SetLength().

template<typename T>
StatusCode Activ::MessageBuilder::Overwrite | ( | const size_t | offset,
 |  | const T | value,
 |  | const size_t | size,
 |  | const Endian | endian |
 | ) |  |  | [inline]

Overwrite a built-in type.

T is the built-in type.

Parameters:
offset | the offset at which to overwrite in the message.
value | the value to place in the message.
size | the number of bytes of value to append.
endian | the endian to copy the value in.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_BUFFER_OVERFLOW
STATUS_CODE_INVALID_PARAMETER | for instance if size > sizeof(T).
STATUS_CODE_OUT_OF_RANGE | if value will not fit in size bytes.
STATUS_CODE_HEAP_EMPTY

Definition at line 1301 of file MessageBuilder.h.

References ACTIV_RETURN_RESULT_IF, Overwrite(), and OverwriteInEndian().

template<typename T>
StatusCode Activ::MessageBuilder::Overwrite | ( | const size_t | offset,
 |  | const T | value,
 |  | const Endian | endian |
 | ) |  |  | [inline]

Overwrite a built-in type.

T is the built-in type.

Parameters:
offset | the offset at which to overwrite in the message.
value | the value to place in the message.
endian | the endian to copy the value in.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_BUFFER_OVERFLOW
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_HEAP_EMPTY

Definition at line 1293 of file MessageBuilder.h.

References Activ::MessageHandler::ENDIAN_LOCAL.

StatusCode Activ::MessageBuilder::Overwrite | ( | const size_t | offset,
 |  | const std::string & | str |
 | ) |  |  | [inline]

Overwrite a string.

Parameters:
offset | the offset at which to overwrite in the message.
str | the string to place in the message.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_BUFFER_OVERFLOW
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_HEAP_EMPTY

Definition at line 1278 of file MessageBuilder.h.

References ACTIV_RETURN_RESULT_IF, and Activ::MessageHandler::ENDIAN_LITTLE.

StatusCode Activ::MessageBuilder::Overwrite | ( | const size_t | offset,
 |  | const char | character,
 |  | const size_t | count |
 | ) |  |  | [inline]

Overwrite characters.

Parameters:
offset | the offset at which to insert in the message.
character | the character to place in the message.
count | the number of character to place in the message.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_BUFFER_OVERFLOW
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_HEAP_EMPTY

Definition at line 1271 of file MessageBuilder.h.

StatusCode Activ::MessageBuilder::Overwrite | ( | const size_t | offset,
 |  | const char | character |
 | ) |  |  | [inline]

Overwrite a character.

Parameters:
offset | the offset at which to insert in the message.
character | the character to place in the message.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_BUFFER_OVERFLOW
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_HEAP_EMPTY

Definition at line 1264 of file MessageBuilder.h.

StatusCode Activ::MessageBuilder::Overwrite | ( | const size_t | offset,
 |  | const void *const | pBuffer,
 |  | const size_t | length |
 | ) |  |  | [inline]

Overwrite a buffer.

Parameters:
offset | the offset at which to overwrite in the message.
pBuffer | the address of the buffer to place in the message.
length | the length of the buffer to place in the message.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_BUFFER_OVERFLOW
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_HEAP_EMPTY

Definition at line 1250 of file MessageBuilder.h.

Referenced by Overwrite().

StatusCode Activ::MessageBuilder::OverwriteBoolean | ( | const size_t | offset,
 |  | const bool | value |
 | ) |  |  | [inline]

Overwrite a boolean value.

Parameters:
offset | the offset at which to overwrite in the message.
value | the boolean value to place in the message.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_BUFFER_OVERFLOW
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_HEAP_EMPTY

Definition at line 1354 of file MessageBuilder.h.

StatusCode Activ::MessageBuilder::OverwriteInEndian | ( | const size_t | offset,
 |  | const void *const | pValue,
 |  | const size_t | size,
 |  | const Endian | endian |
 | ) |  |  | [inline]

Overwrite a variable length binary integral value with a given endian ordering.

Parameters:
offset | the offset at which to overwrite in the message.
pValue | the address of the value to place in the message.
size | the size of the value to place in the message.
endian | the endian to copy the value in.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_BUFFER_OVERFLOW
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_HEAP_EMPTY

Definition at line 1257 of file MessageBuilder.h.

References Activ::MessageHandler::ENDIAN_LOCAL.

Referenced by Overwrite().

void Activ::MessageBuilder::Reset ( const MessageVersion messageVersion = MESSAGE_VERSION_UNDEFINED ) [inline, virtual]

Reset.

Parameters:
messageVersion optional version.

Implements Activ::MessageHandler.

Definition at line 970 of file MessageBuilder.h.

References Activ::MessageHandler::Reset().

Referenced by Initialize().

StatusCode Activ::MessageBuilder::SetBufferSize ( const size_t bufferSize ) [inline]

Set the message buffer size.

The function will fail if the provided size is smaller than the current message length.

Parameters:
bufferSize the size of the message buffer.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_HEAP_EMPTY

Definition at line 1011 of file MessageBuilder.h.

StatusCode Activ::MessageBuilder::SetLength ( const size_t length ) [inline]

Set the length of the message.

Parameters:
length the length of the message.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER

Definition at line 992 of file MessageBuilder.h.

Referenced by operator=().

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivBase/MessageBuilder.h
Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::MessageBuilderVariableLengthRangeCheck

Activ::MessageBuilderVariableLengthRangeCheck< S > Class Template Reference

Class template to check a value is in the acceptable range of a variable number of bytes. More...

#include <ActivMiddleware/ActivBase/MessageBuilder.h>

Detailed Description

template<bool S>
class Activ::MessageBuilderVariableLengthRangeCheck< S >

Class template to check a value is in the acceptable range of a variable number of bytes.

Explicit specializations need to be at namespace scope.

Definition at line 785 of file MessageBuilder.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivBase/MessageBuilder.h
Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::MessageBuilderVariableLengthRangeCheck< false >

Activ::MessageBuilderVariableLengthRangeCheck< false > Class Template Reference

Specialization to check an unsigned value is in the acceptable range of a variable number of bytes. More...

#include <ActivMiddleware/ActivBase/MessageBuilder.h>

List of all members.

Public Member Functions

template<typename T>
bool operator() (const T value, const size_t numberOfBytes) const
Function operator.

Detailed Description

template<>
class Activ::MessageBuilderVariableLengthRangeCheck< false >

Specialization to check an unsigned value is in the acceptable range of a variable number of bytes.

Definition at line 824 of file MessageBuilder.h.

Member Function Documentation

template<typename T>
bool Activ::MessageBuilderVariableLengthRangeCheck< false >::operator() | ( | const T | value,
 |  | const size_t | numberOfBytes |
 | ) |  |  | const [inline]

Function operator.

Parameters:
value | the value to check.
numberOfBytes | the number of bytes to check that value fits in.
Returns:
true if value is in range.

Definition at line 836 of file MessageBuilder.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivBase/MessageBuilder.h
Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::MessageBuilderVariableLengthRangeCheck< true >

Activ::MessageBuilderVariableLengthRangeCheck< true > Class Template Reference

Specialization to check a signed value is in the acceptable range of a variable number of bytes. More...

#include <ActivMiddleware/ActivBase/MessageBuilder.h>

List of all members.

Public Member Functions

template<typename T>
bool operator() (const T value, const size_t numberOfBytes) const
Function operator.

Detailed Description

template<>
class Activ::MessageBuilderVariableLengthRangeCheck< true >

Specialization to check a signed value is in the acceptable range of a variable number of bytes.

Definition at line 795 of file MessageBuilder.h.

Member Function Documentation

template<typename T>
bool Activ::MessageBuilderVariableLengthRangeCheck< true >::operator() | ( | const T | value,
 |  | const size_t | numberOfBytes |
 | ) |  |  | const [inline]

Function operator.

Parameters:
value | the value to check.
numberOfBytes | the number of bytes to check that value fits in.
Returns:
true if value is in range.

Definition at line 807 of file MessageBuilder.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivBase/MessageBuilder.h
Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::MessageHandler

Activ::MessageHandler Class Reference

Base class for validator and builder. More...

#include <ActivMiddleware/ActivBase/MessageHandler.h>

Inheritance diagram for Activ::MessageHandler:

Activ::MessageBuilder Activ::MessageValidator

List of all members.

Public Types

enum | Endian { ENDIAN_LITTLE, ENDIAN_BIG, ENDIAN_LOCAL = ENDIAN_BIG, ENDIAN_ALIEN = ENDIAN_LITTLE }
Endian enumeration. More...
typedef uint8_t | MessageVersion
Definition of the version type.
typedef uint16_t | StringLength
Definition of the string length type.

Public Member Functions

ACTIV_BASE_INLINE_API
MessageVersion 		GetMessageVersion () const
Get the version.
ACTIV_BASE_INLINE_API | MessageHandler (const MessageVersion messageVersion=MESSAGE_VERSION_UNDEFINED)
Constructor.
virtual void | Reset (const MessageVersion messageVersion=MESSAGE_VERSION_UNDEFINED)=0
Reset.
ACTIV_BASE_INLINE_API
MessageVersion 		SetMessageVersion (const MessageVersion messageVersion)
Set the version.
virtual | ~MessageHandler ()=0
Destructor.

Static Public Attributes

static const byte_t | MAX_PRINTABLE_ASCII = 0x7e
The maximum printable ascii character.
static const MessageVersion | MESSAGE_VERSION_UNDEFINED = ~0
Undefined version value.
static const byte_t | MIN_PRINTABLE_ASCII = 0x20
The minimum printable ascii character.

Classes

class | ScopedVersion
Helper class to scope changes to message version. More...

Detailed Description

Base class for validator and builder.

Definition at line 20 of file MessageHandler.h.

Member Enumeration Documentation

enum Activ::MessageHandler::Endian

Endian enumeration.

Enumerator:
ENDIAN_LITTLE | Little endian.
ENDIAN_BIG | Big endian.
ENDIAN_LOCAL | Local endian.

Definition at line 33 of file MessageHandler.h.

Constructor & Destructor Documentation

Activ::MessageHandler::MessageHandler ( const MessageVersion messageVersion = MESSAGE_VERSION_UNDEFINED ) [inline]

Constructor.

Parameters:
messageVersion optional version.

Definition at line 125 of file MessageHandler.h.

References Reset().

Member Function Documentation

MessageHandler::MessageVersion Activ::MessageHandler::GetMessageVersion ( ) const [inline]

Get the version.

Returns:
The version.

Definition at line 145 of file MessageHandler.h.

void Activ::MessageHandler::Reset ( const MessageVersion messageVersion = MESSAGE_VERSION_UNDEFINED ) [inline, pure virtual]

Reset.

Parameters:
messageVersion optional version.

Implemented in Activ::MessageBuilder, and Activ::MessageValidator.

Definition at line 138 of file MessageHandler.h.

References SetMessageVersion().

Referenced by MessageHandler(), Activ::MessageValidator::Reset(), and Activ::MessageBuilder::Reset().

MessageHandler::MessageVersion Activ::MessageHandler::SetMessageVersion ( const MessageVersion messageVersion ) [inline]

Set the version.

Parameters:
messageVersion the new version to set.
Returns:
The previous version.

Definition at line 152 of file MessageHandler.h.

Referenced by Reset(), and Activ::MessageHandler::ScopedVersion::~ScopedVersion().

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivBase/MessageHandler.h
Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::MessageHandler::ScopedVersion

Activ::MessageHandler::ScopedVersion Class Reference

Helper class to scope changes to message version. More...

#include <ActivMiddleware/ActivBase/MessageHandler.h>

List of all members.

Public Member Functions

ACTIV_BASE_INLINE_API | ScopedVersion (MessageHandler &messageHandler, const MessageVersion newVersion)
Constructor.
ACTIV_BASE_INLINE_API | ScopedVersion (MessageHandler &messageHandler)
Constructor.
ACTIV_BASE_INLINE_API | ~ScopedVersion ()
Destructor.

Detailed Description

Helper class to scope changes to message version.

Definition at line 49 of file MessageHandler.h.

Constructor & Destructor Documentation

Activ::MessageHandler::ScopedVersion::ScopedVersion ( MessageHandler & messageHandler ) [inline]

Constructor.

Caches the current message version to restore when this object is destructed.

Parameters:
messageHandler MessageHandler to set version of.

Definition at line 164 of file MessageHandler.h.

Activ::MessageHandler::ScopedVersion::ScopedVersion | ( | MessageHandler & | messageHandler,
 |  | const MessageVersion | newVersion |
 | ) |  |  | [inline]

Constructor.

Caches the current message version to restore when this object is destructed and sets the current version to a new value.

Parameters:
messageHandler | MessageHandler to set version of.
newVersion | version to set.

Definition at line 172 of file MessageHandler.h.

Activ::MessageHandler::ScopedVersion::~ScopedVersion ( ) [inline]

Destructor.

The original message version is restored.

Definition at line 180 of file MessageHandler.h.

References Activ::MessageHandler::SetMessageVersion().

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivBase/MessageHandler.h
Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::MessageRateThrottler

Activ::MessageRateThrottler Class Reference

Message rate throttler class. More...

#include <ActivMiddleware/ActivBase/MessageRateThrottler.h>

List of all members.

Public Member Functions

ACTIV_BASE_EXPORTED_API const
size_t 		GetMessageRate () const
Get the message rate.
ACTIV_BASE_EXPORTED_API const
size_t 		GetPeriodLength () const
Get the period length.
ACTIV_BASE_EXPORTED_API StatusCode | Initialize (const size_t messageRate, const size_t periodLength)
Initialize.
ACTIV_BASE_EXPORTED_API StatusCode | Initialize (const size_t messageRate)
Initialize.
ACTIV_BASE_EXPORTED_API | MessageRateThrottler (const size_t messageRate, const size_t periodLength, const bool shouldCreateMutex=false)
Constructor.
ACTIV_BASE_EXPORTED_API | MessageRateThrottler (const size_t messageRate=0, const bool shouldCreateMutex=false)
Default constructor.
ACTIV_BASE_EXPORTED_API void | Reset ()
Reset.
ACTIV_BASE_EXPORTED_API void | Suspend ()
Suspend.
ACTIV_BASE_EXPORTED_API | ~MessageRateThrottler ()
Destructor.

Static Public Attributes

static const size_t | PERIOD_LENGTH_MAXIMUM = 1000
The maximum period length.
static const size_t | PERIOD_LENGTH_MINIMUM = 25
The minimum period length.

Detailed Description

Message rate throttler class.

Definition at line 25 of file MessageRateThrottler.h.

Constructor & Destructor Documentation

ACTIV_BASE_EXPORTED_API Activ::MessageRateThrottler::MessageRateThrottler | ( | const size_t | messageRate = 0,
 |  | const bool | shouldCreateMutex = false
 | ) |  |

Default constructor.

Parameters:
messageRate | the message rate.
shouldCreateMutex | indicates whether a mutex should be created.

ACTIV_BASE_EXPORTED_API Activ::MessageRateThrottler::MessageRateThrottler | ( | const size_t | messageRate,
 |  | const size_t | periodLength,
 |  | const bool | shouldCreateMutex = false
 | ) |  |

Constructor.

Parameters:
messageRate | the message rate.
periodLength | the period length (in milliseconds). Needs to be divisible by 1000 and periods per second has to be less than the message rate.
shouldCreateMutex | indicates whether a mutex should be created.
Exceptions:
StatusCodeException

Member Function Documentation

ACTIV_BASE_EXPORTED_API const size_t Activ::MessageRateThrottler::GetMessageRate ( ) const

Get the message rate.

Returns:
the message rate.

ACTIV_BASE_EXPORTED_API const size_t Activ::MessageRateThrottler::GetPeriodLength ( ) const

Get the period length.

Returns:
the period length.

ACTIV_BASE_EXPORTED_API StatusCode Activ::MessageRateThrottler::Initialize | ( | const size_t | messageRate,
 |  | const size_t | periodLength
 | ) |  |

Initialize.

Parameters:
messageRate | the message rate.
periodLength | the period length (in milliseconds). Needs to be divisible by 1000 and periods per second has to be less than the message rate.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER

ACTIV_BASE_EXPORTED_API StatusCode Activ::MessageRateThrottler::Initialize ( const size_t messageRate )

Initialize.

Parameters:
messageRate the message rate.
Return values:
STATUS_CODE_SUCCESS

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivBase/MessageRateThrottler.h
Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::MessageValidator

Activ::MessageValidator Class Reference

Message validator class. More...

#include <ActivMiddleware/ActivBase/MessageValidator.h>

Inheritance diagram for Activ::MessageValidator:

Activ::MessageHandler

List of all members.

Public Member Functions

ACTIV_BASE_INLINE_API StatusCode | Get (const size_t offset, const void *&pData, const size_t length) const
Get data from the message.
ACTIV_BASE_INLINE_API size_t | GetLength () const
Get the length of the message.
ACTIV_BASE_INLINE_API const void * | GetMessage () const
Get the address of the message.
ACTIV_BASE_INLINE_API size_t | GetOffset () const
Get the current offset within the message.
ACTIV_BASE_INLINE_API void | Initialize (const void *pMessage, const size_t length, const MessageVersion messageVersion=MESSAGE_VERSION_UNDEFINED)
Initialize with a new contiguous message.
ACTIV_BASE_INLINE_API bool | IsEndOfMessage () const
Is the end of message.
ACTIV_BASE_INLINE_API | MessageValidator (const void *pMessage=0, const size_t length=0, const MessageVersion messageVersion=MESSAGE_VERSION_UNDEFINED)
Default constructor.
ACTIV_BASE_INLINE_API void | Reset (const MessageVersion messageVersion=MESSAGE_VERSION_UNDEFINED)
Reset.
ACTIV_BASE_INLINE_API StatusCode | SetOffset (const size_t offset)
Set the current offset within the message.
template<typename T>
StatusCode | ValidateAsciiHexadecimalIntegral (const size_t size, const std::vector< uint64_t > &set, const Endian endian, T *pValue, const void **ppData=0)
Validate an ASCII hexadecimal integral value.
ACTIV_BASE_INLINE_API StatusCode | ValidateAsciiHexadecimalIntegral (const size_t size, const std::vector< uint64_t > &set, const Endian endian, const void **ppData=0)
Validate an ASCII hexadecimal integral value.
template<typename T>
StatusCode | ValidateAsciiHexadecimalIntegral (const size_t size, const uint64_t lower, const uint64_t upper, const Endian endian, T *pValue, const void **ppData=0)
Validate an ASCII hexadecimal integral value.
ACTIV_BASE_INLINE_API StatusCode | ValidateAsciiHexadecimalIntegral (const size_t size, const uint64_t lower, const uint64_t upper, const Endian endian, const void **ppData=0)
Validate an ASCII hexadecimal integral value.
template<typename T>
StatusCode | ValidateAsciiHexadecimalIntegral (const size_t size, const Endian endian, T *pValue, const void **ppData=0)
Validate an ASCII hexadecimal integral value.
ACTIV_BASE_EXPORTED_API StatusCode | ValidateAsciiHexadecimalIntegral (const size_t size, const Endian endian, const void **ppData=0)
Validate an ASCII hexadecimal integral value.
template<typename T>
StatusCode | ValidateAsciiHexadecimalIntegralCopy (const size_t size, const std::vector< uint64_t > &set, const Endian endian, T *pValue, void *pCopy)
Validate an ASCII hexadecimal integral value and copy.
ACTIV_BASE_INLINE_API StatusCode | ValidateAsciiHexadecimalIntegralCopy (const size_t size, const std::vector< uint64_t > &set, const Endian endian, void *pCopy)
Validate an ASCII hexadecimal integral value and copy.
template<typename T>
StatusCode | ValidateAsciiHexadecimalIntegralCopy (const size_t size, const uint64_t lower, const uint64_t upper, const Endian endian, T *pValue, void *pCopy)
Validate an ASCII hexadecimal integral value and copy.
ACTIV_BASE_INLINE_API StatusCode | ValidateAsciiHexadecimalIntegralCopy (const size_t size, const uint64_t lower, const uint64_t upper, const Endian endian, void *pCopy)
Validate an ASCII hexadecimal integral value and copy.
template<typename T>
StatusCode | ValidateAsciiHexadecimalIntegralCopy (const size_t size, const Endian endian, T *pValue, void *pCopy)
Validate an ASCII hexadecimal integral value and copy.
ACTIV_BASE_EXPORTED_API StatusCode | ValidateAsciiHexadecimalIntegralCopy (const size_t size, const Endian endian, void *pCopy)
Validate an ASCII hexadecimal integral value and copy.
template<size_t SIZE, Endian ENDIAN, typename T>
StatusCode | ValidateBinaryIntegral (const T lower, const T upper, T &value)
Validate a signed or unsigned binary integral value.
template<size_t SIZE, Endian ENDIAN, typename T>
StatusCode | ValidateBinaryIntegral (T &value)
Validate a signed or unsigned binary integral value.
template<size_t SIZE, Endian ENDIAN, typename T, T LOWER, T UPPER>
StatusCode | ValidateBinaryIntegralRange (T &value)
Validate a signed or unsigned binary integral value.
ACTIV_BASE_INLINE_API StatusCode | ValidateBoolean (bool *pBoolean)
Validate a binary boolean value.
ACTIV_BASE_EXPORTED_API StatusCode | ValidateBytes (const size_t length, const std::vector< std::string > &set, const void **ppData=0)
Validate bytes.
ACTIV_BASE_EXPORTED_API StatusCode | ValidateBytes (const size_t length, const std::vector< byte_t > &set, const void **ppData=0)
Validate bytes.
ACTIV_BASE_EXPORTED_API StatusCode | ValidateBytes (const size_t length, const byte_t lower, const byte_t upper, const void **ppData=0)
Validate bytes.
ACTIV_BASE_EXPORTED_API StatusCode | ValidateBytes (const size_t length, const byte_t value, const void **ppData=0)
Validate bytes.
ACTIV_BASE_EXPORTED_API StatusCode | ValidateBytes (const size_t length, const void *const pComperand, const void **ppData=0)
Validate bytes.
ACTIV_BASE_EXPORTED_API StatusCode | ValidateBytes (const size_t length, const void **ppData=0)
Validate bytes.
ACTIV_BASE_EXPORTED_API StatusCode | ValidateBytesCopy (const size_t length, const std::vector< std::string > &set, void *pCopy)
Validate bytes and copy.
ACTIV_BASE_EXPORTED_API StatusCode | ValidateBytesCopy (const size_t length, const std::vector< byte_t > &set, void *pCopy)
Validate bytes and copy.
ACTIV_BASE_EXPORTED_API StatusCode | ValidateBytesCopy (const size_t length, const byte_t lower, const byte_t upper, void *pCopy)
Validate bytes and copy.
ACTIV_BASE_EXPORTED_API StatusCode | ValidateBytesCopy (const size_t length, void *pCopy)
Validate bytes and copy.
template<typename T>
StatusCode | ValidateSignedAsciiIntegral (const size_t length, const std::vector< int64_t > &set, T *pValue, const void **ppData=0)
Validate a signed ASCII integral value.
ACTIV_BASE_INLINE_API StatusCode | ValidateSignedAsciiIntegral (const size_t length, const std::vector< int64_t > &set, const void **ppData=0)
Validate a signed ASCII integral value.
template<typename T>
StatusCode | ValidateSignedAsciiIntegral (const size_t length, const int64_t lower, const int64_t upper, T *pValue, const void **ppData=0)
Validate a signed ASCII integral value.
ACTIV_BASE_EXPORTED_API StatusCode | ValidateSignedAsciiIntegral (const size_t length, const int64_t lower, const int64_t upper, const void **ppData=0)
Validate a signed ASCII integral value.
template<typename T>
StatusCode | ValidateSignedAsciiIntegral (const size_t length, T *pValue, const void **ppData=0)
Validate a signed ASCII integral value.
ACTIV_BASE_EXPORTED_API StatusCode | ValidateSignedAsciiIntegral (const size_t length, const void **ppData=0)
Validate a signed ASCII integral value.
template<typename T>
StatusCode | ValidateSignedAsciiIntegralCopy (const size_t length, const std::vector< int64_t > &set, T *pValue, void *pCopy)
Validate a signed ASCII integral value and copy.
ACTIV_BASE_EXPORTED_API StatusCode | ValidateSignedAsciiIntegralCopy (const size_t length, const std::vector< int64_t > &set, void *pCopy)
Validate a signed ASCII integral value and copy.
template<typename T>
StatusCode | ValidateSignedAsciiIntegralCopy (const size_t length, const int64_t lower, const int64_t upper, T *pValue, void *pCopy)
Validate a signed ASCII integral value and copy.
ACTIV_BASE_EXPORTED_API StatusCode | ValidateSignedAsciiIntegralCopy (const size_t length, const int64_t lower, const int64_t upper, void *pCopy)
Validate a signed ASCII integral value and copy.
template<typename T>
StatusCode | ValidateSignedAsciiIntegralCopy (const size_t length, T *pValue, void *pCopy)
Validate a signed ASCII integral value and copy.
ACTIV_BASE_EXPORTED_API StatusCode | ValidateSignedAsciiIntegralCopy (const size_t length, void *pCopy)
Validate a signed ASCII integral value and copy.
ACTIV_BASE_EXPORTED_API StatusCode | ValidateSignedAsciiReal (const size_t length, const std::vector< long double > &set, int64_t *pNumerator, uint64_t *pDivisor, const void **ppData=0)
Validate a signed ASCII real value.
template<typename T>
StatusCode | ValidateSignedAsciiReal (const size_t length, const std::vector< long double > &set, T *pValue, const void **ppData=0)
Validate a signed ASCII real value.
ACTIV_BASE_INLINE_API StatusCode | ValidateSignedAsciiReal (const size_t length, const std::vector< long double > &set, const void **ppData=0)
Validate a signed ASCII real value.
ACTIV_BASE_EXPORTED_API StatusCode | ValidateSignedAsciiReal (const size_t length, const long double lower, const long double upper, int64_t *pNumerator, uint64_t *pDivisor, const void **ppData=0)
Validate a signed ASCII real value.
template<typename T>
StatusCode | ValidateSignedAsciiReal (const size_t length, const long double lower, const long double upper, T *pValue, const void **ppData=0)
Validate a signed ASCII real value.
ACTIV_BASE_INLINE_API StatusCode | ValidateSignedAsciiReal (const size_t length, const long double lower, const long double upper, const void **ppData=0)
Validate a signed ASCII real value.
ACTIV_BASE_EXPORTED_API StatusCode | ValidateSignedAsciiReal (const size_t length, int64_t *pNumerator, uint64_t *pDivisor, const void **ppData=0)
Validate a signed ASCII real value.
template<typename T>
StatusCode | ValidateSignedAsciiReal (const size_t length, T *pValue, const void **ppData=0)
Validate a signed ASCII real value.
ACTIV_BASE_EXPORTED_API StatusCode | ValidateSignedAsciiReal (const size_t length, const void **ppData=0)
Validate a signed ASCII real value.
ACTIV_BASE_EXPORTED_API StatusCode | ValidateSignedAsciiRealCopy (const size_t length, const std::vector< long double > &set, int64_t *pNumerator, uint64_t *pDivisor, void *pCopy)
Validate a signed ASCII real value and copy.
template<typename T>
StatusCode | ValidateSignedAsciiRealCopy (const size_t length, const std::vector< long double > &set, T *pValue, void *pCopy)
Validate a signed ASCII real value and copy.
ACTIV_BASE_INLINE_API StatusCode | ValidateSignedAsciiRealCopy (const size_t length, const std::vector< long double > &set, void *pCopy)
Validate a signed ASCII real value and copy.
ACTIV_BASE_EXPORTED_API StatusCode | ValidateSignedAsciiRealCopy (const size_t length, const long double lower, const long double upper, int64_t *pNumerator, uint64_t *pDivisor, void *pCopy)
Validate a signed ASCII real value and copy.
template<typename T>
StatusCode | ValidateSignedAsciiRealCopy (const size_t length, const long double lower, const long double upper, T *pValue, void *pCopy)
Validate a signed ASCII real value and copy.
ACTIV_BASE_INLINE_API StatusCode | ValidateSignedAsciiRealCopy (const size_t length, const long double lower, const long double upper, void *pCopy)
Validate a signed ASCII real value and copy.
ACTIV_BASE_EXPORTED_API StatusCode | ValidateSignedAsciiRealCopy (const size_t length, int64_t *pNumerator, uint64_t *pDivisor, void *pCopy)
Validate a signed ASCII real value and copy.
template<typename T>
StatusCode | ValidateSignedAsciiRealCopy (const size_t length, T *pValue, void *pCopy)
Validate a signed ASCII real value and copy.
ACTIV_BASE_EXPORTED_API StatusCode | ValidateSignedAsciiRealCopy (const size_t length, void *pCopy)
Validate a signed ASCII real value and copy.
template<typename T>
StatusCode | ValidateSignedBinaryIntegral (const size_t size, const std::vector< int64_t > &set, const Endian endian, T *pValue, const void **ppData=0)
Validate a signed binary integral value.
ACTIV_BASE_INLINE_API StatusCode | ValidateSignedBinaryIntegral (const size_t size, const std::vector< int64_t > &set, const Endian endian, const void **ppData=0)
Validate a signed binary integral value.
template<typename T>
StatusCode | ValidateSignedBinaryIntegral (const size_t size, const int64_t lower, const int64_t upper, const Endian endian, T *pValue, const void **ppData=0)
Validate a signed binary integral value.
ACTIV_BASE_INLINE_API StatusCode | ValidateSignedBinaryIntegral (const size_t size, const int64_t lower, const int64_t upper, const Endian endian, const void **ppData=0)
Validate a signed binary integral value.
template<typename T>
StatusCode | ValidateSignedBinaryIntegral (const size_t size, const Endian endian, T *pValue, const void **ppData=0)
Validate a signed binary integral value.
ACTIV_BASE_EXPORTED_API StatusCode | ValidateSignedBinaryIntegral (const size_t size, const Endian endian, const void **ppData=0)
Validate a signed binary integral value.
template<typename T>
StatusCode | ValidateSignedBinaryIntegralCopy (const size_t size, const std::vector< int64_t > &set, const Endian endian, T *pValue, void *pCopy)
Validate a signed binary integral value and copy.
ACTIV_BASE_INLINE_API StatusCode | ValidateSignedBinaryIntegralCopy (const size_t size, const std::vector< int64_t > &set, const Endian endian, void *pCopy)
Validate a signed binary integral value and copy.
template<typename T>
StatusCode | ValidateSignedBinaryIntegralCopy (const size_t size, const int64_t lower, const int64_t upper, const Endian endian, T *pValue, void *pCopy)
Validate a signed binary integral value and copy.
ACTIV_BASE_INLINE_API StatusCode | ValidateSignedBinaryIntegralCopy (const size_t size, const int64_t lower, const int64_t upper, const Endian endian, void *pCopy)
Validate a signed binary integral value and copy.
template<typename T>
StatusCode | ValidateSignedBinaryIntegralCopy (const size_t size, const Endian endian, T *pValue, void *pCopy)
Validate a signed binary integral value and copy.
ACTIV_BASE_EXPORTED_API StatusCode | ValidateSignedBinaryIntegralCopy (const size_t size, const Endian endian, void *pCopy)
Validate a signed binary integral value and copy.
ACTIV_BASE_EXPORTED_API StatusCode | ValidateString (const std::vector< std::string > &set, std::string *pString, const void **ppData=0, size_t *pDataLength=0)
Validate string.
ACTIV_BASE_INLINE_API StatusCode | ValidateString (const std::vector< std::string > &set, const void **ppData=0, size_t *pDataLength=0)
Validate string.
ACTIV_BASE_EXPORTED_API StatusCode | ValidateString (const std::vector< byte_t > &set, std::string *pString, const void **ppData=0, size_t *pDataLength=0)
Validate string.
ACTIV_BASE_EXPORTED_API StatusCode | ValidateString (const std::vector< byte_t > &set, const void **ppData=0, size_t *pDataLength=0)
Validate string.
ACTIV_BASE_EXPORTED_API StatusCode | ValidateString (const byte_t lower, const byte_t upper, std::string *pString, const void **ppData=0, size_t *pDataLength=0)
Validate string.
ACTIV_BASE_INLINE_API StatusCode | ValidateString (const byte_t lower, const byte_t upper, const void **ppData=0, size_t *pDataLength=0)
Validate string.
ACTIV_BASE_EXPORTED_API StatusCode | ValidateString (std::string *pString, const void **ppData=0, size_t *pDataLength=0)
Validate string.
ACTIV_BASE_INLINE_API StatusCode | ValidateString (const void **ppData=0, size_t *pDataLength=0)
Validate string.
ACTIV_BASE_EXPORTED_API StatusCode | ValidateStringCopy (const std::vector< std::string > &set, std::string *pString, void *pCopy, const size_t copySize, size_t *pCopyLength)
Validate string and copy.
ACTIV_BASE_INLINE_API StatusCode | ValidateStringCopy (const std::vector< std::string > &set, void *pCopy, const size_t copySize, size_t *pCopyLength)
Validate string and copy.
ACTIV_BASE_EXPORTED_API StatusCode | ValidateStringCopy (const std::vector< byte_t > &set, std::string *pString, void *pCopy, const size_t copySize, size_t *pCopyLength)
Validate string and copy.
ACTIV_BASE_INLINE_API StatusCode | ValidateStringCopy (const std::vector< byte_t > &set, void *pCopy, const size_t copySize, size_t *pCopyLength)
Validate string and copy.
ACTIV_BASE_EXPORTED_API StatusCode | ValidateStringCopy (const byte_t lower, const byte_t upper, std::string *pString, void *pCopy, const size_t copySize, size_t *pCopyLength)
Validate string and copy.
ACTIV_BASE_INLINE_API StatusCode | ValidateStringCopy (const byte_t lower, const byte_t upper, void *pCopy, const size_t copySize, size_t *pCopyLength)
Validate string and copy.
ACTIV_BASE_EXPORTED_API StatusCode | ValidateStringCopy (std::string *pString, void *pCopy, const size_t copySize, size_t *pCopyLength)
Validate string and copy.
ACTIV_BASE_INLINE_API StatusCode | ValidateStringCopy (void *pCopy, const size_t copySize, size_t *pCopyLength)
Validate string and copy.
template<typename T>
StatusCode | ValidateUnsignedAsciiIntegral (const size_t length, const std::vector< uint64_t > &set, T *pValue, const void **ppData=0)
Validate an unsigned ASCII integral value.
ACTIV_BASE_INLINE_API StatusCode | ValidateUnsignedAsciiIntegral (const size_t length, const std::vector< uint64_t > &set, const void **ppData=0)
Validate an unsigned ASCII integral value.
template<typename T>
StatusCode | ValidateUnsignedAsciiIntegral (const size_t length, const uint64_t lower, const uint64_t upper, T *pValue, const void **ppData=0)
Validate an unsigned ASCII integral value.
ACTIV_BASE_INLINE_API StatusCode | ValidateUnsignedAsciiIntegral (const size_t length, const uint64_t lower, const uint64_t upper, const void **ppData=0)
Validate an unsigned ASCII integral value.
template<typename T>
StatusCode | ValidateUnsignedAsciiIntegral (const size_t length, T *pValue, const void **ppData=0)
Validate an unsigned ASCII integral value.
ACTIV_BASE_EXPORTED_API StatusCode | ValidateUnsignedAsciiIntegral (const size_t length, const void **ppData=0)
Validate an unsigned ASCII integral value.
template<typename T>
StatusCode | ValidateUnsignedAsciiIntegralCopy (const size_t length, const std::vector< uint64_t > &set, T *pValue, void *pCopy)
Validate an unsigned ASCII integral value and copy.
ACTIV_BASE_EXPORTED_API StatusCode | ValidateUnsignedAsciiIntegralCopy (const size_t length, const std::vector< uint64_t > &set, void *pCopy)
Validate an unsigned ASCII integral value and copy.
template<typename T>
StatusCode | ValidateUnsignedAsciiIntegralCopy (const size_t length, const uint64_t lower, const uint64_t upper, T *pValue, void *pCopy)
Validate an unsigned ASCII integral value and copy.
ACTIV_BASE_EXPORTED_API StatusCode | ValidateUnsignedAsciiIntegralCopy (const size_t length, const uint64_t lower, const uint64_t upper, void *pCopy)
Validate an unsigned ASCII integral value and copy.
template<typename T>
StatusCode | ValidateUnsignedAsciiIntegralCopy (const size_t length, T *pValue, void *pCopy)
Validate an unsigned ASCII integral value and copy.
ACTIV_BASE_EXPORTED_API StatusCode | ValidateUnsignedAsciiIntegralCopy (const size_t length, void *pCopy)
Validate an unsigned ASCII integral value and copy.
ACTIV_BASE_EXPORTED_API StatusCode | ValidateUnsignedAsciiReal (const size_t length, const std::vector< long double > &set, uint64_t *pNumerator, uint64_t *pDivisor, const void **ppData=0)
Validate an unsigned ASCII real value.
template<typename T>
StatusCode | ValidateUnsignedAsciiReal (const size_t length, const std::vector< long double > &set, T *pValue, const void **ppData=0)
Validate an unsigned ASCII real value.
ACTIV_BASE_INLINE_API StatusCode | ValidateUnsignedAsciiReal (const size_t length, const std::vector< long double > &set, const void **ppData=0)
Validate an unsigned ASCII real value.
ACTIV_BASE_EXPORTED_API StatusCode | ValidateUnsignedAsciiReal (const size_t length, const long double lower, const long double upper, uint64_t *pNumerator, uint64_t *pDivisor, const void **ppData=0)
Validate an unsigned ASCII real value.
template<typename T>
StatusCode | ValidateUnsignedAsciiReal (const size_t length, const long double lower, const long double upper, T *pValue, const void **ppData=0)
Validate an unsigned ASCII real value.
ACTIV_BASE_INLINE_API StatusCode | ValidateUnsignedAsciiReal (const size_t length, const long double lower, const long double upper, const void **ppData=0)
Validate an unsigned ASCII real value.
ACTIV_BASE_EXPORTED_API StatusCode | ValidateUnsignedAsciiReal (const size_t length, uint64_t *pNumerator, uint64_t *pDivisor, const void **ppData=0)
Validate an unsigned ASCII real value.
template<typename T>
StatusCode | ValidateUnsignedAsciiReal (const size_t length, T *pValue, const void **ppData=0)
Validate an unsigned ASCII real value.
ACTIV_BASE_EXPORTED_API StatusCode | ValidateUnsignedAsciiReal (const size_t length, const void **ppData=0)
Validate an unsigned ASCII real value.
ACTIV_BASE_EXPORTED_API StatusCode | ValidateUnsignedAsciiRealCopy (const size_t length, const std::vector< long double > &set, uint64_t *pNumerator, uint64_t *pDivisor, void *pCopy)
Validate an unsigned ASCII real value and copy.
template<typename T>
StatusCode | ValidateUnsignedAsciiRealCopy (const size_t length, const std::vector< long double > &set, T *pValue, void *pCopy)
Validate an unsigned ASCII real value and copy.
ACTIV_BASE_INLINE_API StatusCode | ValidateUnsignedAsciiRealCopy (const size_t length, const std::vector< long double > &set, void *pCopy)
Validate an unsigned ASCII real value and copy.
ACTIV_BASE_EXPORTED_API StatusCode | ValidateUnsignedAsciiRealCopy (const size_t length, const long double lower, const long double upper, uint64_t *pNumerator, uint64_t *pDivisor, void *pCopy)
Validate an unsigned ASCII real value and copy.
template<typename T>
StatusCode | ValidateUnsignedAsciiRealCopy (const size_t length, const long double lower, const long double upper, T *pValue, void *pCopy)
Validate an unsigned ASCII real value and copy.
ACTIV_BASE_INLINE_API StatusCode | ValidateUnsignedAsciiRealCopy (const size_t length, const long double lower, const long double upper, void *pCopy)
Validate an unsigned ASCII real value and copy.
ACTIV_BASE_EXPORTED_API StatusCode | ValidateUnsignedAsciiRealCopy (const size_t length, uint64_t *pNumerator, uint64_t *pDivisor, void *pCopy)
Validate an unsigned ASCII real value and copy.
template<typename T>
StatusCode | ValidateUnsignedAsciiRealCopy (const size_t length, T *pValue, void *pCopy)
Validate an unsigned ASCII real value and copy.
ACTIV_BASE_EXPORTED_API StatusCode | ValidateUnsignedAsciiRealCopy (const size_t length, void *pCopy)
Validate an unsigned ASCII real value and copy.
template<typename T>
StatusCode | ValidateUnsignedBinaryIntegral (const size_t size, const std::vector< uint64_t > &set, const Endian endian, T *pValue, const void **ppData=0)
Validate an unsigned binary integral value.
ACTIV_BASE_INLINE_API StatusCode | ValidateUnsignedBinaryIntegral (const size_t size, const std::vector< uint64_t > &set, const Endian endian, const void **ppData=0)
Validate an unsigned binary integral value.
template<typename T>
StatusCode | ValidateUnsignedBinaryIntegral (const size_t size, const uint64_t lower, const uint64_t upper, const Endian endian, T *pValue, const void **ppData=0)
Validate an unsigned binary integral value.
ACTIV_BASE_INLINE_API StatusCode | ValidateUnsignedBinaryIntegral (const size_t size, const uint64_t lower, const uint64_t upper, const Endian endian, const void **ppData=0)
Validate an unsigned binary integral value.
template<typename T>
StatusCode | ValidateUnsignedBinaryIntegral (const size_t size, const Endian endian, T *pValue, const void **ppData=0)
Validate an unsigned binary integral value.
ACTIV_BASE_EXPORTED_API StatusCode | ValidateUnsignedBinaryIntegral (const size_t size, const Endian endian, const void **ppData=0)
Validate an unsigned binary integral value.
template<typename T>
StatusCode | ValidateUnsignedBinaryIntegralCopy (const size_t size, const std::vector< uint64_t > &set, const Endian endian, T *pValue, void *pCopy)
Validate an unsigned binary integral value and copy.
ACTIV_BASE_INLINE_API StatusCode | ValidateUnsignedBinaryIntegralCopy (const size_t size, const std::vector< uint64_t > &set, const Endian endian, void *pCopy)
Validate an unsigned binary integral value and copy.
template<typename T>
StatusCode | ValidateUnsignedBinaryIntegralCopy (const size_t size, const uint64_t lower, const uint64_t upper, const Endian endian, T *pValue, void *pCopy)
Validate an unsigned binary integral value and copy.
ACTIV_BASE_INLINE_API StatusCode | ValidateUnsignedBinaryIntegralCopy (const size_t size, const uint64_t lower, const uint64_t upper, const Endian endian, void *pCopy)
Validate an unsigned binary integral value and copy.
template<typename T>
StatusCode | ValidateUnsignedBinaryIntegralCopy (const size_t size, const Endian endian, T *pValue, void *pCopy)
Validate an unsigned binary integral value and copy.
ACTIV_BASE_EXPORTED_API StatusCode | ValidateUnsignedBinaryIntegralCopy (const size_t size, const Endian endian, void *pCopy)
Validate an unsigned binary integral value and copy.

Static Public Member Functions

template<typename T>
static StatusCode | CopyAsciiHexadecimalIntegralToUnsignedBinaryIntegral (T &to, const void *const pData, size_t size, const Endian endian)
Copy an ASCII hexadecimal integral value to a unsigned binary integral value.
template<typename T>
static StatusCode | CopySignedAsciiIntegralToSignedBinaryIntegral (T &to, const void *const pData, size_t length)
Copy a signed ASCII integral value to a signed binary integral value.
template<typename T>
static StatusCode | CopySignedAsciiRealToBinaryReal (T &to, const void *const pData, size_t length)
Copy a signed ASCII real value to a binary real.
static ACTIV_BASE_EXPORTED_API
StatusCode 		CopySignedAsciiRealToNumeratorAndDivisor (int64_t &numerator, uint64_t &divisor, const void *const pData, const size_t length)
Copy a signed ASCII real value to a numerator and divisor.
template<typename T>
static StatusCode | CopySignedBinaryIntegralToSignedBinaryIntegral (T &to, const void *const pData, size_t size, const Endian endian)
Copy a signed binary integral value to a signed binary integral value.
template<typename T>
static StatusCode | CopyUnsignedAsciiIntegralToUnsignedBinaryIntegral (T &to, const void *const pData, size_t length)
Copy an unsigned ASCII integral value to an unsigned binary integral value.
template<typename T>
static StatusCode | CopyUnsignedAsciiRealToBinaryReal (T &to, const void *const pData, size_t length)
Copy an unsigned ASCII real value to a binary real.
static ACTIV_BASE_EXPORTED_API
StatusCode 		CopyUnsignedAsciiRealToNumeratorAndDivisor (uint64_t &numerator, uint64_t &divisor, const void *const pData, const size_t length)
Copy a unsigned ASCII real value to a numerator and divisor.
template<typename T>
static StatusCode | CopyUnsignedBinaryIntegralToUnsignedBinaryIntegral (T &to, const void *const pData, size_t size, const Endian endian)
Copy an unsigned binary integral value to a unsigned binary integral value.

Classes

class | CopyBinaryIntegralToBinaryIntegralT
Template to copy binary to binary.
class | CopyBinaryIntegralToBinaryIntegralT< false, false, SIZE, ENDIAN, T >
class | CopyBinaryIntegralToBinaryIntegralT< false, true, SIZE, ENDIAN, T >
class | CopyBinaryIntegralToBinaryIntegralT< true, IS_SIGNED, SIZE, ENDIAN_ALIEN, T >
class | CopyBinaryIntegralToBinaryIntegralT< true, IS_SIGNED, SIZE, ENDIAN_LOCAL, T >

Detailed Description

Message validator class.

Definition at line 27 of file MessageValidator.h.

Constructor & Destructor Documentation

Activ::MessageValidator::MessageValidator | ( | const void * | pMessage = 0,
 |  | const size_t | length = 0,
 |  | const MessageVersion | messageVersion = MESSAGE_VERSION_UNDEFINED |
 | ) |  |  | [inline]

Default constructor.

Parameters:
pMessage | the address of the message.
length | the length of the message.
messageVersion | optional version.

Definition at line 2199 of file MessageValidator.h.

References Initialize().

Member Function Documentation

template<typename T>
StatusCode Activ::MessageValidator::CopyAsciiHexadecimalIntegralToUnsignedBinaryIntegral | ( | T & | to,
 |  | const void *const | pData,
 |  | size_t | size,
 |  | const Endian | endian |
 | ) |  |  | [inline, static]

Copy an ASCII hexadecimal integral value to a unsigned binary integral value.

Parameters:
to | the value to be copied to.
pData | a pointer to the data to copy from.
size | the size of the data to copy from.
endian | the endian of the data to copy from.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT
STATUS_CODE_OUT_OF_RANGE

Definition at line 2683 of file MessageValidator.h.

References Activ::MessageHandler::ENDIAN_LITTLE.

template<typename T>
StatusCode Activ::MessageValidator::CopySignedAsciiIntegralToSignedBinaryIntegral | ( | T & | to,
 |  | const void *const | pData,
 |  | size_t | length |
 | ) |  |  | [inline, static]

Copy a signed ASCII integral value to a signed binary integral value.

Parameters:
to | the value to be copied to.
pData | a pointer to the data to copy from.
length | the length of the data to copy from.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT
STATUS_CODE_OUT_OF_RANGE

Definition at line 2743 of file MessageValidator.h.

template<typename T>
StatusCode Activ::MessageValidator::CopySignedAsciiRealToBinaryReal | ( | T & | to,
 |  | const void *const | pData,
 |  | size_t | length |
 | ) |  |  | [inline, static]

Copy a signed ASCII real value to a binary real.

Parameters:
to | the value to be copied to.
pData | a pointer to the data to copy from.
length | the length of the data to copy from.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT
STATUS_CODE_OUT_OF_RANGE

Definition at line 2782 of file MessageValidator.h.

References ACTIV_RETURN_RESULT_IF, and CopySignedAsciiRealToNumeratorAndDivisor().

static ACTIV_BASE_EXPORTED_API StatusCode Activ::MessageValidator::CopySignedAsciiRealToNumeratorAndDivisor | ( | int64_t & | numerator,
 |  | uint64_t & | divisor,
 |  | const void *const | pData,
 |  | const size_t | length |
 | ) |  |  | [static]

Copy a signed ASCII real value to a numerator and divisor.

Parameters:
numerator | the numerator to be copied to.
divisor | the divisor to be copied to.
pData | a pointer to the data to copy from.
length | the length of the data to copy from.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT
STATUS_CODE_OUT_OF_RANGE

Referenced by CopySignedAsciiRealToBinaryReal().

template<typename T>
StatusCode Activ::MessageValidator::CopySignedBinaryIntegralToSignedBinaryIntegral | ( | T & | to,
 |  | const void *const | pData,
 |  | size_t | size,
 |  | const Endian | endian |
 | ) |  |  | [inline, static]

Copy a signed binary integral value to a signed binary integral value.

Parameters:
to | the value to be copied to.
pData | a pointer to the data to copy from.
size | the size of the data to copy from.
endian | the endian of the data to copy from.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT
STATUS_CODE_OUT_OF_RANGE

Definition at line 2842 of file MessageValidator.h.

References Activ::MessageHandler::ENDIAN_LOCAL.

template<typename T>
StatusCode Activ::MessageValidator::CopyUnsignedAsciiIntegralToUnsignedBinaryIntegral | ( | T & | to,
 |  | const void *const | pData,
 |  | size_t | length |
 | ) |  |  | [inline, static]

Copy an unsigned ASCII integral value to an unsigned binary integral value.

Parameters:
to | the value to be copied to.
pData | a pointer to the data to copy from.
length | the length of the data to copy from.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT
STATUS_CODE_OUT_OF_RANGE

Definition at line 2857 of file MessageValidator.h.

template<typename T>
StatusCode Activ::MessageValidator::CopyUnsignedAsciiRealToBinaryReal | ( | T & | to,
 |  | const void *const | pData,
 |  | size_t | length |
 | ) |  |  | [inline, static]

Copy an unsigned ASCII real value to a binary real.

Parameters:
to | the value to be copied to.
pData | a pointer to the data to copy from.
length | the length of the data to copy from.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT
STATUS_CODE_OUT_OF_RANGE

Definition at line 2884 of file MessageValidator.h.

References ACTIV_RETURN_RESULT_IF, and CopyUnsignedAsciiRealToNumeratorAndDivisor().

static ACTIV_BASE_EXPORTED_API StatusCode Activ::MessageValidator::CopyUnsignedAsciiRealToNumeratorAndDivisor | ( | uint64_t & | numerator,
 |  | uint64_t & | divisor,
 |  | const void *const | pData,
 |  | const size_t | length |
 | ) |  |  | [static]

Copy a unsigned ASCII real value to a numerator and divisor.

Parameters:
numerator | the numerator to be copied to.
divisor | the divisor to be copied to.
pData | a pointer to the data to copy from.
length | the length of the data to copy from.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT
STATUS_CODE_OUT_OF_RANGE

Referenced by CopyUnsignedAsciiRealToBinaryReal().

template<typename T>
StatusCode Activ::MessageValidator::CopyUnsignedBinaryIntegralToUnsignedBinaryIntegral | ( | T & | to,
 |  | const void *const | pData,
 |  | size_t | size,
 |  | const Endian | endian |
 | ) |  |  | [inline, static]

Copy an unsigned binary integral value to a unsigned binary integral value.

Parameters:
to | the value to be copied to.
pData | a pointer to the data to copy from.
size | the size of the data to copy from.
endian | the endian of the data to copy from.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT
STATUS_CODE_OUT_OF_RANGE

Definition at line 2897 of file MessageValidator.h.

References Activ::MessageHandler::ENDIAN_LOCAL.

StatusCode Activ::MessageValidator::Get | ( | const size_t | offset,
 |  | const void *& | pData,
 |  | const size_t | length |
 | ) |  |  | const [inline]

Get data from the message.

Parameters:
offset | the offset within the message.
pData | reference to the address of the data.
length | the length to get.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER

Definition at line 2667 of file MessageValidator.h.

Referenced by Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessage::ValidateCompressedCombinedQuote().

size_t Activ::MessageValidator::GetLength ( ) const [inline]

Get the length of the message.

Returns:
the length of the message.

Definition at line 2231 of file MessageValidator.h.

const void * Activ::MessageValidator::GetMessage ( ) const [inline]

Get the address of the message.

Returns:
The address of the message.

Definition at line 2224 of file MessageValidator.h.

Referenced by Activ::ContentPlatform::Feed::CompressedMessageDefinitions::FieldHeaderValidator::Validate().

size_t Activ::MessageValidator::GetOffset ( ) const [inline]

Get the current offset within the message.

Returns:
The offset within the message.

Definition at line 2238 of file MessageValidator.h.

Referenced by Activ::ContentPlatform::Feed::CompressedMessageDefinitions::FieldHeaderValidator::Validate(), and Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessage::ValidateCompressedCombinedQuote().

void Activ::MessageValidator::Initialize | ( | const void * | pMessage,
 |  | const size_t | length,
 |  | const MessageVersion | messageVersion = MESSAGE_VERSION_UNDEFINED |
 | ) |  |  | [inline]

Initialize with a new contiguous message.

Parameters:
pMessage | the address of the message.
length | the length of the message.
messageVersion | optional version.

Definition at line 2206 of file MessageValidator.h.

References Reset().

Referenced by Activ::HeapMessageDeserializer< MESSAGE_TYPE, BUFFER_SIZE >::Initialize(), and MessageValidator().

bool Activ::MessageValidator::IsEndOfMessage ( ) const [inline]

Is the end of message.

Returns:
whether the end of message has been reached.

Definition at line 2257 of file MessageValidator.h.

Referenced by Activ::HeapMessageDeserializer< MESSAGE_TYPE, BUFFER_SIZE >::IsEndOfMessage().

void Activ::MessageValidator::Reset ( const MessageVersion messageVersion = MESSAGE_VERSION_UNDEFINED ) [inline, virtual]

Reset.

Parameters:
messageVersion optional version.

Implements Activ::MessageHandler.

Definition at line 2216 of file MessageValidator.h.

References Activ::MessageHandler::Reset().

Referenced by Initialize(), and Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessage::ValidateCompressedCombinedQuote().

StatusCode Activ::MessageValidator::SetOffset ( const size_t offset ) [inline]

Set the current offset within the message.

Parameters:
offset the offset within the message.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER

Definition at line 2245 of file MessageValidator.h.

template<typename T>
StatusCode Activ::MessageValidator::ValidateAsciiHexadecimalIntegral | ( | const size_t | size,
 |  | const std::vector< uint64_t > & | set,
 |  | const Endian | endian,
 |  | T * | pValue,
 |  | const void ** | ppData = 0 |
 | ) |  |  | [inline]

Validate an ASCII hexadecimal integral value.

Parameters:
size | the size of the value.
set | the set of allowed values.
endian | the endian of the value.
pValue | the location to copy the value to.
ppData | the location to copy the address of the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

Definition at line 3059 of file MessageValidator.h.

StatusCode Activ::MessageValidator::ValidateAsciiHexadecimalIntegral | ( | const size_t | size,
 |  | const std::vector< uint64_t > & | set,
 |  | const Endian | endian,
 |  | const void ** | ppData = 0 |
 | ) |  |  | [inline]

Validate an ASCII hexadecimal integral value.

Parameters:
size | the size of the value.
set | the set of allowed values.
endian | the endian of the value.
ppData | the location to copy the address of the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

Definition at line 2354 of file MessageValidator.h.

References ValidateAsciiHexadecimalIntegral().

template<typename T>
StatusCode Activ::MessageValidator::ValidateAsciiHexadecimalIntegral | ( | const size_t | size,
 |  | const uint64_t | lower,
 |  | const uint64_t | upper,
 |  | const Endian | endian,
 |  | T * | pValue,
 |  | const void ** | ppData = 0 |
 | ) |  |  | [inline]

Validate an ASCII hexadecimal integral value.

Parameters:
size | the size of the value.
lower | the lower bound value.
upper | the upper bound value.
endian | the endian of the value.
pValue | the location to copy the value to.
ppData | the location to copy the address of the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

Definition at line 3051 of file MessageValidator.h.

StatusCode Activ::MessageValidator::ValidateAsciiHexadecimalIntegral | ( | const size_t | size,
 |  | const uint64_t | lower,
 |  | const uint64_t | upper,
 |  | const Endian | endian,
 |  | const void ** | ppData = 0 |
 | ) |  |  | [inline]

Validate an ASCII hexadecimal integral value.

Parameters:
size | the size of the value.
lower | the lower bound value.
upper | the upper bound value.
endian | the endian of the value.
ppData | the location to copy the address of the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

Definition at line 2345 of file MessageValidator.h.

References ValidateAsciiHexadecimalIntegral().

template<typename T>
StatusCode Activ::MessageValidator::ValidateAsciiHexadecimalIntegral | ( | const size_t | size,
 |  | const Endian | endian,
 |  | T * | pValue,
 |  | const void ** | ppData = 0 |
 | ) |  |  | [inline]

Validate an ASCII hexadecimal integral value.

Parameters:
size | the size of the value.
endian | the endian of the value.
pValue | the location to copy the value to.
ppData | the location to copy the address of the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER

Definition at line 3043 of file MessageValidator.h.

ACTIV_BASE_EXPORTED_API StatusCode Activ::MessageValidator::ValidateAsciiHexadecimalIntegral | ( | const size_t | size,
 |  | const Endian | endian,
 |  | const void ** | ppData = 0
 | ) |  |

Validate an ASCII hexadecimal integral value.

Parameters:
size | the size of the value.
endian | the endian of the value.
ppData | the location to copy the address of the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER

Referenced by ValidateAsciiHexadecimalIntegral().

template<typename T>
StatusCode Activ::MessageValidator::ValidateAsciiHexadecimalIntegralCopy | ( | const size_t | size,
 |  | const std::vector< uint64_t > & | set,
 |  | const Endian | endian,
 |  | T * | pValue,
 |  | void * | pCopy |
 | ) |  |  | [inline]

Validate an ASCII hexadecimal integral value and copy.

Parameters:
size | the size of the value.
set | the set of allowed values.
endian | the endian of the value.
pValue | the location to copy the value to.
pCopy | the address to copy the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

Definition at line 3083 of file MessageValidator.h.

StatusCode Activ::MessageValidator::ValidateAsciiHexadecimalIntegralCopy | ( | const size_t | size,
 |  | const std::vector< uint64_t > & | set,
 |  | const Endian | endian,
 |  | void * | pCopy |
 | ) |  |  | [inline]

Validate an ASCII hexadecimal integral value and copy.

Parameters:
size | the size of the value.
set | the set of allowed values.
endian | the endian of the value.
pCopy | the address to copy the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

Definition at line 2372 of file MessageValidator.h.

References ValidateAsciiHexadecimalIntegralCopy().

template<typename T>
StatusCode Activ::MessageValidator::ValidateAsciiHexadecimalIntegralCopy | ( | const size_t | size,
 |  | const uint64_t | lower,
 |  | const uint64_t | upper,
 |  | const Endian | endian,
 |  | T * | pValue,
 |  | void * | pCopy |
 | ) |  |  | [inline]

Validate an ASCII hexadecimal integral value and copy.

Parameters:
size | the size of the value.
lower | the lower bound value.
upper | the upper bound value.
endian | the endian of the value.
pValue | the location to copy the value to.
pCopy | the address to copy the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

Definition at line 3075 of file MessageValidator.h.

StatusCode Activ::MessageValidator::ValidateAsciiHexadecimalIntegralCopy | ( | const size_t | size,
 |  | const uint64_t | lower,
 |  | const uint64_t | upper,
 |  | const Endian | endian,
 |  | void * | pCopy |
 | ) |  |  | [inline]

Validate an ASCII hexadecimal integral value and copy.

Parameters:
size | the size of the value.
lower | the lower bound value.
upper | the upper bound value.
endian | the endian of the value.
pCopy | the address to copy the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

Definition at line 2363 of file MessageValidator.h.

References ValidateAsciiHexadecimalIntegralCopy().

template<typename T>
StatusCode Activ::MessageValidator::ValidateAsciiHexadecimalIntegralCopy | ( | const size_t | size,
 |  | const Endian | endian,
 |  | T * | pValue,
 |  | void * | pCopy |
 | ) |  |  | [inline]

Validate an ASCII hexadecimal integral value and copy.

Parameters:
size | the size of the value.
endian | the endian of the value.
pValue | the location to copy the value to.
pCopy | the address to copy the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER

Definition at line 3067 of file MessageValidator.h.

ACTIV_BASE_EXPORTED_API StatusCode Activ::MessageValidator::ValidateAsciiHexadecimalIntegralCopy | ( | const size_t | size,
 |  | const Endian | endian,
 |  | void * | pCopy
 | ) |  |

Validate an ASCII hexadecimal integral value and copy.

Parameters:
size | the size of the value.
endian | the endian of the value.
pCopy | the address to copy the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER

Referenced by ValidateAsciiHexadecimalIntegralCopy().

template<size_t SIZE, MessageValidator::Endian ENDIAN, typename T>
StatusCode Activ::MessageValidator::ValidateBinaryIntegral | ( | const T | lower,
 |  | const T | upper,
 |  | T & | value |
 | ) |  |  | [inline]

Validate a signed or unsigned binary integral value.

SIZE the number of bytes to validate. ENDIAN the endian of the source. T the type of the variable to receive the value.

Parameters:
lower | the lower bound value.
upper | the upper bound value.
value | reference to a variable to receive the value.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

Definition at line 2318 of file MessageValidator.h.

template<size_t SIZE, MessageValidator::Endian ENDIAN, typename T>
StatusCode Activ::MessageValidator::ValidateBinaryIntegral ( T & value ) [inline]

Validate a signed or unsigned binary integral value.

SIZE the number of bytes to validate. ENDIAN the endian of the source. T the type of the variable to receive the value.

Parameters:
value reference to a variable to receive the value.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER

Definition at line 2265 of file MessageValidator.h.

Referenced by Activ::SerializableBuffer< LENGTH_TYPE, MIN_LENGTH, MAX_LENGTH >::Deserialize(), Activ::RequestId::Deserialize(), Activ::Address::Deserialize(), Activ::ContentPlatform::Feed::Symbol::Deserialize(), Activ::ContentPlatform::Feed::CompressedMessage::ValidateCompressed(), and Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessage::ValidateCompressedCombinedQuote().

template<size_t SIZE, MessageValidator::Endian ENDIAN, typename T, T LOWER, T UPPER>
StatusCode Activ::MessageValidator::ValidateBinaryIntegralRange ( T & value ) [inline]

Validate a signed or unsigned binary integral value.

SIZE the number of bytes to validate. ENDIAN the endian of the source. T the type of the variable to receive the value. LOWER the lower bound value. UPPER the upper bound value.

Parameters:
value reference to a variable to receive the value.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

Definition at line 2290 of file MessageValidator.h.

StatusCode Activ::MessageValidator::ValidateBoolean ( bool * pBoolean ) [inline]

Validate a binary boolean value.

Parameters:
pBoolean the location to copy the boolean value to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

Definition at line 2653 of file MessageValidator.h.

References ACTIV_RETURN_RESULT_IF, Activ::MessageHandler::ENDIAN_LITTLE, and ValidateUnsignedBinaryIntegral().

ACTIV_BASE_EXPORTED_API StatusCode Activ::MessageValidator::ValidateBytes | ( | const size_t | length,
 |  | const std::vector< std::string > & | set,
 |  | const void ** | ppData = 0
 | ) |  |

Validate bytes.

Parameters:
length | the length of the buffer.
set | the set of allowed values.
ppData | the location to copy the address of the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

ACTIV_BASE_EXPORTED_API StatusCode Activ::MessageValidator::ValidateBytes | ( | const size_t | length,
 |  | const std::vector< byte_t > & | set,
 |  | const void ** | ppData = 0
 | ) |  |

Validate bytes.

Parameters:
length | the length of the buffer.
set | the set of allowed values.
ppData | the location to copy the address of the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

ACTIV_BASE_EXPORTED_API StatusCode Activ::MessageValidator::ValidateBytes | ( | const size_t | length,
 |  | const byte_t | lower,
 |  | const byte_t | upper,
 |  | const void ** | ppData = 0
 | ) |  |

Validate bytes.

Parameters:
length | the length of the buffer.
lower | the lower bound value.
upper | the upper bound value.
ppData | the location to copy the address of the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

ACTIV_BASE_EXPORTED_API StatusCode Activ::MessageValidator::ValidateBytes | ( | const size_t | length,
 |  | const byte_t | value,
 |  | const void ** | ppData = 0
 | ) |  |

Validate bytes.

Parameters:
length | the length of the buffer.
value | the value to compare all bytes in the buffer to.
ppData | the location to copy the address of the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

ACTIV_BASE_EXPORTED_API StatusCode Activ::MessageValidator::ValidateBytes | ( | const size_t | length,
 |  | const void *const | pComperand,
 |  | const void ** | ppData = 0
 | ) |  |

Validate bytes.

Parameters:
length | the length of the buffer.
pComperand | data (of length length) to compare to.
ppData | the location to copy the address of the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER

ACTIV_BASE_EXPORTED_API StatusCode Activ::MessageValidator::ValidateBytes | ( | const size_t | length,
 |  | const void ** | ppData = 0
 | ) |  |

Validate bytes.

Parameters:
length | the length of the buffer.
ppData | the location to copy the address of the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER

Referenced by Activ::ContentPlatform::Feed::Symbol::Deserialize(), and Activ::ContentPlatform::Feed::CompressedMessageDefinitions::FieldHeaderValidator::Validate().

ACTIV_BASE_EXPORTED_API StatusCode Activ::MessageValidator::ValidateBytesCopy | ( | const size_t | length,
 |  | const std::vector< std::string > & | set,
 |  | void * | pCopy
 | ) |  |

Validate bytes and copy.

Parameters:
length | the length of the buffer.
set | the set of allowed values.
pCopy | the address to copy the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

ACTIV_BASE_EXPORTED_API StatusCode Activ::MessageValidator::ValidateBytesCopy | ( | const size_t | length,
 |  | const std::vector< byte_t > & | set,
 |  | void * | pCopy
 | ) |  |

Validate bytes and copy.

Parameters:
length | the length of the buffer.
set | the set of allowed values.
pCopy | the address to copy the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

ACTIV_BASE_EXPORTED_API StatusCode Activ::MessageValidator::ValidateBytesCopy | ( | const size_t | length,
 |  | const byte_t | lower,
 |  | const byte_t | upper,
 |  | void * | pCopy
 | ) |  |

Validate bytes and copy.

Parameters:
length | the length of the buffer.
lower | the lower bound value.
upper | the upper bound value.
pCopy | the address to copy the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

ACTIV_BASE_EXPORTED_API StatusCode Activ::MessageValidator::ValidateBytesCopy | ( | const size_t | length,
 |  | void * | pCopy
 | ) |  |

Validate bytes and copy.

Parameters:
length | the length of the buffer.
pCopy | the address to copy the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER

Referenced by Activ::SerializableBuffer< LENGTH_TYPE, MIN_LENGTH, MAX_LENGTH >::Deserialize(), and Activ::RequestId::Deserialize().

template<typename T>
StatusCode Activ::MessageValidator::ValidateSignedAsciiIntegral | ( | const size_t | length,
 |  | const std::vector< int64_t > & | set,
 |  | T * | pValue,
 |  | const void ** | ppData = 0 |
 | ) |  |  | [inline]

Validate a signed ASCII integral value.

Parameters:
length | the length of the value.
set | the set of allowed values.
pValue | the location to copy the value to.
ppData | the location to copy the address of the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

Definition at line 3107 of file MessageValidator.h.

StatusCode Activ::MessageValidator::ValidateSignedAsciiIntegral | ( | const size_t | length,
 |  | const std::vector< int64_t > & | set,
 |  | const void ** | ppData = 0 |
 | ) |  |  | [inline]

Validate a signed ASCII integral value.

Parameters:
length | the length of the value.
set | the set of allowed values.
ppData | the location to copy the address of the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

Definition at line 2390 of file MessageValidator.h.

References ValidateSignedAsciiIntegral().

template<typename T>
StatusCode Activ::MessageValidator::ValidateSignedAsciiIntegral | ( | const size_t | length,
 |  | const int64_t | lower,
 |  | const int64_t | upper,
 |  | T * | pValue,
 |  | const void ** | ppData = 0 |
 | ) |  |  | [inline]

Validate a signed ASCII integral value.

Parameters:
length | the length of the value.
lower | the lower bound value.
upper | the upper bound value.
pValue | the location to copy the value to.
ppData | the location to copy the address of the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

Definition at line 3099 of file MessageValidator.h.

StatusCode Activ::MessageValidator::ValidateSignedAsciiIntegral | ( | const size_t | length,
 |  | const int64_t | lower,
 |  | const int64_t | upper,
 |  | const void ** | ppData = 0 |
 | ) |  |  | [inline]

Validate a signed ASCII integral value.

Parameters:
length | the length of the value.
lower | the lower bound value.
upper | the upper bound value.
ppData | the location to copy the address of the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

Definition at line 2381 of file MessageValidator.h.

References ValidateSignedAsciiIntegral().

template<typename T>
StatusCode Activ::MessageValidator::ValidateSignedAsciiIntegral | ( | const size_t | length,
 |  | T * | pValue,
 |  | const void ** | ppData = 0 |
 | ) |  |  | [inline]

Validate a signed ASCII integral value.

Parameters:
length | the length of the value.
pValue | the location to copy the value to.
ppData | the location to copy the address of the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

Definition at line 3091 of file MessageValidator.h.

ACTIV_BASE_EXPORTED_API StatusCode Activ::MessageValidator::ValidateSignedAsciiIntegral | ( | const size_t | length,
 |  | const void ** | ppData = 0
 | ) |  |

Validate a signed ASCII integral value.

Parameters:
length | the length of the value.
ppData | the location to copy the address of the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT
STATUS_CODE_INVALID_PARAMETER

Referenced by ValidateSignedAsciiIntegral().

template<typename T>
StatusCode Activ::MessageValidator::ValidateSignedAsciiIntegralCopy | ( | const size_t | length,
 |  | const std::vector< int64_t > & | set,
 |  | T * | pValue,
 |  | void * | pCopy |
 | ) |  |  | [inline]

Validate a signed ASCII integral value and copy.

Parameters:
length | the length of the value.
set | the set of allowed values.
pValue | the location to copy the value to.
pCopy | the address to copy the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

Definition at line 3131 of file MessageValidator.h.

StatusCode Activ::MessageValidator::ValidateSignedAsciiIntegralCopy | ( | const size_t | length,
 |  | const std::vector< int64_t > & | set,
 |  | void * | pCopy |
 | ) |  |  | [inline]

Validate a signed ASCII integral value and copy.

Parameters:
length | the length of the value.
set | the set of allowed values.
pCopy | the address to copy the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

Definition at line 2408 of file MessageValidator.h.

References ValidateSignedAsciiIntegralCopy().

template<typename T>
StatusCode Activ::MessageValidator::ValidateSignedAsciiIntegralCopy | ( | const size_t | length,
 |  | const int64_t | lower,
 |  | const int64_t | upper,
 |  | T * | pValue,
 |  | void * | pCopy |
 | ) |  |  | [inline]

Validate a signed ASCII integral value and copy.

Parameters:
length | the length of the value.
lower | the lower bound value.
upper | the upper bound value.
pValue | the location to copy the value to.
pCopy | the address to copy the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

Definition at line 3123 of file MessageValidator.h.

StatusCode Activ::MessageValidator::ValidateSignedAsciiIntegralCopy | ( | const size_t | length,
 |  | const int64_t | lower,
 |  | const int64_t | upper,
 |  | void * | pCopy |
 | ) |  |  | [inline]

Validate a signed ASCII integral value and copy.

Parameters:
length | the length of the value.
lower | the lower bound value.
upper | the upper bound value.
pCopy | the address to copy the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

Definition at line 2399 of file MessageValidator.h.

References ValidateSignedAsciiIntegralCopy().

template<typename T>
StatusCode Activ::MessageValidator::ValidateSignedAsciiIntegralCopy | ( | const size_t | length,
 |  | T * | pValue,
 |  | void * | pCopy |
 | ) |  |  | [inline]

Validate a signed ASCII integral value and copy.

Parameters:
length | the length of the value.
pValue | the location to copy the value to.
pCopy | the address to copy the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

Definition at line 3115 of file MessageValidator.h.

ACTIV_BASE_EXPORTED_API StatusCode Activ::MessageValidator::ValidateSignedAsciiIntegralCopy | ( | const size_t | length,
 |  | void * | pCopy
 | ) |  |

Validate a signed ASCII integral value and copy.

Parameters:
length | the length of the value.
pCopy | the address to copy the data to.
pCopy | the address to copy the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

Referenced by ValidateSignedAsciiIntegralCopy().

ACTIV_BASE_EXPORTED_API StatusCode Activ::MessageValidator::ValidateSignedAsciiReal | ( | const size_t | length,
 |  | const std::vector< long double > & | set,
 |  | int64_t * | pNumerator,
 |  | uint64_t * | pDivisor,
 |  | const void ** | ppData = 0
 | ) |  |

Validate a signed ASCII real value.

Parameters:
length | the length of the value.
set | the set of allowed values.
pNumerator | the location to copy the numerator to.
pDivisor | the location to copy the divisor to.
ppData | the location to copy the address of the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

template<typename T>
StatusCode Activ::MessageValidator::ValidateSignedAsciiReal | ( | const size_t | length,
 |  | const std::vector< long double > & | set,
 |  | T * | pValue,
 |  | const void ** | ppData = 0 |
 | ) |  |  | [inline]

Validate a signed ASCII real value.

Parameters:
length | the length of the value.
set | the set of allowed values.
pValue | the location to copy the value to.
ppData | the location to copy the address of the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

Definition at line 3155 of file MessageValidator.h.

StatusCode Activ::MessageValidator::ValidateSignedAsciiReal | ( | const size_t | length,
 |  | const std::vector< long double > & | set,
 |  | const void ** | ppData = 0 |
 | ) |  |  | [inline]

Validate a signed ASCII real value.

Parameters:
length | the length of the value.
set | the set of allowed values.
ppData | the location to copy the address of the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

Definition at line 2426 of file MessageValidator.h.

ACTIV_BASE_EXPORTED_API StatusCode Activ::MessageValidator::ValidateSignedAsciiReal | ( | const size_t | length,
 |  | const long double | lower,
 |  | const long double | upper,
 |  | int64_t * | pNumerator,
 |  | uint64_t * | pDivisor,
 |  | const void ** | ppData = 0
 | ) |  |

Validate a signed ASCII real value.

Parameters:
length | the length of the value.
lower | the lower bound value.
upper | the upper bound value.
pNumerator | the location to copy the numerator to.
pDivisor | the location to copy the divisor to.
ppData | the location to copy the address of the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

template<typename T>
StatusCode Activ::MessageValidator::ValidateSignedAsciiReal | ( | const size_t | length,
 |  | const long double | lower,
 |  | const long double | upper,
 |  | T * | pValue,
 |  | const void ** | ppData = 0 |
 | ) |  |  | [inline]

Validate a signed ASCII real value.

Parameters:
length | the length of the value.
lower | the lower bound value.
upper | the upper bound value.
pValue | the location to copy the value to.
ppData | the location to copy the address of the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

Definition at line 3147 of file MessageValidator.h.

StatusCode Activ::MessageValidator::ValidateSignedAsciiReal | ( | const size_t | length,
 |  | const long double | lower,
 |  | const long double | upper,
 |  | const void ** | ppData = 0 |
 | ) |  |  | [inline]

Validate a signed ASCII real value.

Parameters:
length | the length of the value.
lower | the lower bound value.
upper | the upper bound value.
ppData | the location to copy the address of the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

Definition at line 2417 of file MessageValidator.h.

ACTIV_BASE_EXPORTED_API StatusCode Activ::MessageValidator::ValidateSignedAsciiReal | ( | const size_t | length,
 |  | int64_t * | pNumerator,
 |  | uint64_t * | pDivisor,
 |  | const void ** | ppData = 0
 | ) |  |

Validate a signed ASCII real value.

Parameters:
length | the length of the value.
pNumerator | the location to copy the numerator to.
pDivisor | the location to copy the divisor to.
ppData | the location to copy the address of the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

template<typename T>
StatusCode Activ::MessageValidator::ValidateSignedAsciiReal | ( | const size_t | length,
 |  | T * | pValue,
 |  | const void ** | ppData = 0 |
 | ) |  |  | [inline]

Validate a signed ASCII real value.

Parameters:
length | the length of the value.
pValue | the location to copy the value to.
ppData | the location to copy the address of the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

Definition at line 3139 of file MessageValidator.h.

ACTIV_BASE_EXPORTED_API StatusCode Activ::MessageValidator::ValidateSignedAsciiReal | ( | const size_t | length,
 |  | const void ** | ppData = 0
 | ) |  |

Validate a signed ASCII real value.

Parameters:
length | the length of the value.
ppData | the location to copy the address of the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

ACTIV_BASE_EXPORTED_API StatusCode Activ::MessageValidator::ValidateSignedAsciiRealCopy | ( | const size_t | length,
 |  | const std::vector< long double > & | set,
 |  | int64_t * | pNumerator,
 |  | uint64_t * | pDivisor,
 |  | void * | pCopy
 | ) |  |

Validate a signed ASCII real value and copy.

Parameters:
length | the length of the value.
set | the set of allowed values.
pNumerator | the location to copy the numerator to.
pDivisor | the location to copy the divisor to.
pCopy | the address to copy the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

template<typename T>
StatusCode Activ::MessageValidator::ValidateSignedAsciiRealCopy | ( | const size_t | length,
 |  | const std::vector< long double > & | set,
 |  | T * | pValue,
 |  | void * | pCopy |
 | ) |  |  | [inline]

Validate a signed ASCII real value and copy.

Parameters:
length | the length of the value.
set | the set of allowed values.
pValue | the location to copy the value to.
pCopy | the address to copy the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

Definition at line 3179 of file MessageValidator.h.

StatusCode Activ::MessageValidator::ValidateSignedAsciiRealCopy | ( | const size_t | length,
 |  | const std::vector< long double > & | set,
 |  | void * | pCopy |
 | ) |  |  | [inline]

Validate a signed ASCII real value and copy.

Parameters:
length | the length of the value.
set | the set of allowed values.
pCopy | the address to copy the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

Definition at line 2444 of file MessageValidator.h.

ACTIV_BASE_EXPORTED_API StatusCode Activ::MessageValidator::ValidateSignedAsciiRealCopy | ( | const size_t | length,
 |  | const long double | lower,
 |  | const long double | upper,
 |  | int64_t * | pNumerator,
 |  | uint64_t * | pDivisor,
 |  | void * | pCopy
 | ) |  |

Validate a signed ASCII real value and copy.

Parameters:
length | the length of the value.
lower | the lower bound value.
upper | the upper bound value.
pNumerator | the location to copy the numerator to.
pDivisor | the location to copy the divisor to.
pCopy | the address to copy the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

template<typename T>
StatusCode Activ::MessageValidator::ValidateSignedAsciiRealCopy | ( | const size_t | length,
 |  | const long double | lower,
 |  | const long double | upper,
 |  | T * | pValue,
 |  | void * | pCopy |
 | ) |  |  | [inline]

Validate a signed ASCII real value and copy.

Parameters:
length | the length of the value.
lower | the lower bound value.
upper | the upper bound value.
pValue | the location to copy the value to.
pCopy | the address to copy the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

Definition at line 3171 of file MessageValidator.h.

StatusCode Activ::MessageValidator::ValidateSignedAsciiRealCopy | ( | const size_t | length,
 |  | const long double | lower,
 |  | const long double | upper,
 |  | void * | pCopy |
 | ) |  |  | [inline]

Validate a signed ASCII real value and copy.

Parameters:
length | the length of the value.
lower | the lower bound value.
upper | the upper bound value.
pCopy | the address to copy the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

Definition at line 2435 of file MessageValidator.h.

ACTIV_BASE_EXPORTED_API StatusCode Activ::MessageValidator::ValidateSignedAsciiRealCopy | ( | const size_t | length,
 |  | int64_t * | pNumerator,
 |  | uint64_t * | pDivisor,
 |  | void * | pCopy
 | ) |  |

Validate a signed ASCII real value and copy.

Parameters:
length | the length of the value.
pNumerator | the location to copy the numerator to.
pDivisor | the location to copy the divisor to.
pCopy | the address to copy the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

template<typename T>
StatusCode Activ::MessageValidator::ValidateSignedAsciiRealCopy | ( | const size_t | length,
 |  | T * | pValue,
 |  | void * | pCopy |
 | ) |  |  | [inline]

Validate a signed ASCII real value and copy.

Parameters:
length | the length of the value.
pValue | the location to copy the value to.
pCopy | the address to copy the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

Definition at line 3163 of file MessageValidator.h.

ACTIV_BASE_EXPORTED_API StatusCode Activ::MessageValidator::ValidateSignedAsciiRealCopy | ( | const size_t | length,
 |  | void * | pCopy
 | ) |  |

Validate a signed ASCII real value and copy.

Parameters:
length | the length of the value.
pCopy | the address to copy the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

template<typename T>
StatusCode Activ::MessageValidator::ValidateSignedBinaryIntegral | ( | const size_t | size,
 |  | const std::vector< int64_t > & | set,
 |  | const Endian | endian,
 |  | T * | pValue,
 |  | const void ** | ppData = 0 |
 | ) |  |  | [inline]

Validate a signed binary integral value.

Parameters:
size | the size of the value.
set | the set of allowed values.
endian | the endian of the value.
pValue | the location to copy the value to.
ppData | the location to copy the address of the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

Definition at line 3203 of file MessageValidator.h.

StatusCode Activ::MessageValidator::ValidateSignedBinaryIntegral | ( | const size_t | size,
 |  | const std::vector< int64_t > & | set,
 |  | const Endian | endian,
 |  | const void ** | ppData = 0 |
 | ) |  |  | [inline]

Validate a signed binary integral value.

Parameters:
size | the size of the value.
set | the set of allowed values.
endian | the endian of the value.
ppData | the location to copy the address of the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

Definition at line 2462 of file MessageValidator.h.

References ValidateSignedBinaryIntegral().

template<typename T>
StatusCode Activ::MessageValidator::ValidateSignedBinaryIntegral | ( | const size_t | size,
 |  | const int64_t | lower,
 |  | const int64_t | upper,
 |  | const Endian | endian,
 |  | T * | pValue,
 |  | const void ** | ppData = 0 |
 | ) |  |  | [inline]

Validate a signed binary integral value.

Parameters:
size | the size of the value.
lower | the lower bound value.
upper | the upper bound value.
endian | the endian of the value.
pValue | the location to copy the value to.
ppData | the location to copy the address of the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

Definition at line 3195 of file MessageValidator.h.

StatusCode Activ::MessageValidator::ValidateSignedBinaryIntegral | ( | const size_t | size,
 |  | const int64_t | lower,
 |  | const int64_t | upper,
 |  | const Endian | endian,
 |  | const void ** | ppData = 0 |
 | ) |  |  | [inline]

Validate a signed binary integral value.

Parameters:
size | the size of the value.
lower | the lower bound value.
upper | the upper bound value.
endian | the endian of the value.
ppData | the location to copy the address of the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

Definition at line 2453 of file MessageValidator.h.

References ValidateSignedBinaryIntegral().

template<typename T>
StatusCode Activ::MessageValidator::ValidateSignedBinaryIntegral | ( | const size_t | size,
 |  | const Endian | endian,
 |  | T * | pValue,
 |  | const void ** | ppData = 0 |
 | ) |  |  | [inline]

Validate a signed binary integral value.

Parameters:
size | the size of the value.
endian | the endian of the value.
pValue | the location to copy the value to.
ppData | the location to copy the address of the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER

Definition at line 3187 of file MessageValidator.h.

ACTIV_BASE_EXPORTED_API StatusCode Activ::MessageValidator::ValidateSignedBinaryIntegral | ( | const size_t | size,
 |  | const Endian | endian,
 |  | const void ** | ppData = 0
 | ) |  |

Validate a signed binary integral value.

Parameters:
size | the size of the value.
endian | the endian of the value.
ppData | the location to copy the address of the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER

Referenced by ValidateSignedBinaryIntegral().

template<typename T>
StatusCode Activ::MessageValidator::ValidateSignedBinaryIntegralCopy | ( | const size_t | size,
 |  | const std::vector< int64_t > & | set,
 |  | const Endian | endian,
 |  | T * | pValue,
 |  | void * | pCopy |
 | ) |  |  | [inline]

Validate a signed binary integral value and copy.

Parameters:
size | the size of the value.
set | the set of allowed values.
endian | the endian of the value.
pValue | the location to copy the value to.
pCopy | the address to copy the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

Definition at line 3227 of file MessageValidator.h.

StatusCode Activ::MessageValidator::ValidateSignedBinaryIntegralCopy | ( | const size_t | size,
 |  | const std::vector< int64_t > & | set,
 |  | const Endian | endian,
 |  | void * | pCopy |
 | ) |  |  | [inline]

Validate a signed binary integral value and copy.

Parameters:
size | the size of the value.
set | the set of allowed values.
endian | the endian of the value.
pCopy | the address to copy the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

Definition at line 2480 of file MessageValidator.h.

References ValidateSignedBinaryIntegralCopy().

template<typename T>
StatusCode Activ::MessageValidator::ValidateSignedBinaryIntegralCopy | ( | const size_t | size,
 |  | const int64_t | lower,
 |  | const int64_t | upper,
 |  | const Endian | endian,
 |  | T * | pValue,
 |  | void * | pCopy |
 | ) |  |  | [inline]

Validate a signed binary integral value and copy.

Parameters:
size | the size of the value.
lower | the lower bound value.
upper | the upper bound value.
endian | the endian of the value.
pValue | the location to copy the value to.
pCopy | the address to copy the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

Definition at line 3219 of file MessageValidator.h.

StatusCode Activ::MessageValidator::ValidateSignedBinaryIntegralCopy | ( | const size_t | size,
 |  | const int64_t | lower,
 |  | const int64_t | upper,
 |  | const Endian | endian,
 |  | void * | pCopy |
 | ) |  |  | [inline]

Validate a signed binary integral value and copy.

Parameters:
size | the size of the value.
lower | the lower bound value.
upper | the upper bound value.
endian | the endian of the value.
pCopy | the address to copy the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

Definition at line 2471 of file MessageValidator.h.

References ValidateSignedBinaryIntegralCopy().

template<typename T>
StatusCode Activ::MessageValidator::ValidateSignedBinaryIntegralCopy | ( | const size_t | size,
 |  | const Endian | endian,
 |  | T * | pValue,
 |  | void * | pCopy |
 | ) |  |  | [inline]

Validate a signed binary integral value and copy.

Parameters:
size | the size of the value.
endian | the endian of the value.
pValue | the location to copy the value to.
pCopy | the address to copy the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER

Definition at line 3211 of file MessageValidator.h.

ACTIV_BASE_EXPORTED_API StatusCode Activ::MessageValidator::ValidateSignedBinaryIntegralCopy | ( | const size_t | size,
 |  | const Endian | endian,
 |  | void * | pCopy
 | ) |  |

Validate a signed binary integral value and copy.

Parameters:
size | the size of the value.
endian | the endian of the value.
pCopy | the address to copy the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER

Referenced by ValidateSignedBinaryIntegralCopy().

ACTIV_BASE_EXPORTED_API StatusCode Activ::MessageValidator::ValidateString | ( | const std::vector< std::string > & | set,
 |  | std::string * | pString,
 |  | const void ** | ppData = 0,
 |  | size_t * | pDataLength = 0
 | ) |  |

Validate string.

Parameters:
set | the set of allowed values.
pString | the location to copy the string to.
ppData | the location to copy the address of the data to.
pDataLength | pointer to the length of the data.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

StatusCode Activ::MessageValidator::ValidateString | ( | const std::vector< std::string > & | set,
 |  | const void ** | ppData = 0,
 |  | size_t * | pDataLength = 0 |
 | ) |  |  | [inline]

Validate string.

Parameters:
set | the set of allowed values.
ppData | the location to copy the address of the data to.
pDataLength | pointer to the length of the data.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

Definition at line 2510 of file MessageValidator.h.

References ValidateString().

ACTIV_BASE_EXPORTED_API StatusCode Activ::MessageValidator::ValidateString | ( | const std::vector< byte_t > & | set,
 |  | std::string * | pString,
 |  | const void ** | ppData = 0,
 |  | size_t * | pDataLength = 0
 | ) |  |

Validate string.

Parameters:
set | the set of allowed values.
pString | the location to copy the string to.
ppData | the location to copy the address of the data to.
pDataLength | pointer to the length of the data.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

StatusCode Activ::MessageValidator::ValidateString | ( | const std::vector< byte_t > & | set,
 |  | const void ** | ppData = 0,
 |  | size_t * | pDataLength = 0 |
 | ) |  |  | [inline]

Validate string.

Parameters:
set | the set of allowed values.
ppData | the location to copy the address of the data to.
pDataLength | pointer to the length of the data.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

Definition at line 2503 of file MessageValidator.h.

References ValidateString().

ACTIV_BASE_EXPORTED_API StatusCode Activ::MessageValidator::ValidateString | ( | const byte_t | lower,
 |  | const byte_t | upper,
 |  | std::string * | pString,
 |  | const void ** | ppData = 0,
 |  | size_t * | pDataLength = 0
 | ) |  |

Validate string.

Parameters:
lower | the lower bound value.
upper | the upper bound value.
pString | the location to copy the string to.
ppData | the location to copy the address of the data to.
pDataLength | pointer to the length of the data.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

StatusCode Activ::MessageValidator::ValidateString | ( | const byte_t | lower,
 |  | const byte_t | upper,
 |  | const void ** | ppData = 0,
 |  | size_t * | pDataLength = 0 |
 | ) |  |  | [inline]

Validate string.

Parameters:
lower | the lower bound value.
upper | the upper bound value.
ppData | the location to copy the address of the data to.
pDataLength | pointer to the length of the data.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

Definition at line 2496 of file MessageValidator.h.

References ValidateString().

ACTIV_BASE_EXPORTED_API StatusCode Activ::MessageValidator::ValidateString | ( | std::string * | pString,
 |  | const void ** | ppData = 0,
 |  | size_t * | pDataLength = 0
 | ) |  |

Validate string.

Parameters:
pString | the location to copy the string to.
ppData | the location to copy the address of the data to.
pDataLength | pointer to the length of the data.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER

StatusCode Activ::MessageValidator::ValidateString | ( | const void ** | ppData = 0,
 |  | size_t * | pDataLength = 0 |
 | ) |  |  | [inline]

Validate string.

Parameters:
ppData | the location to copy the address of the data to.
pDataLength | pointer to the length of the data.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER

Definition at line 2489 of file MessageValidator.h.

Referenced by ValidateString().

ACTIV_BASE_EXPORTED_API StatusCode Activ::MessageValidator::ValidateStringCopy | ( | const std::vector< std::string > & | set,
 |  | std::string * | pString,
 |  | void * | pCopy,
 |  | const size_t | copySize,
 |  | size_t * | pCopyLength
 | ) |  |

Validate string and copy.

Parameters:
set | the set of allowed values.
pString | the location to copy the string to.
pCopy | the address to copy the data to.
copySize | the size of data.
pCopyLength | pointer to the length of the data.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

StatusCode Activ::MessageValidator::ValidateStringCopy | ( | const std::vector< std::string > & | set,
 |  | void * | pCopy,
 |  | const size_t | copySize,
 |  | size_t * | pCopyLength |
 | ) |  |  | [inline]

Validate string and copy.

Parameters:
set | the set of allowed values.
pCopy | the address to copy the data to.
copySize | the size of data.
pCopyLength | pointer to the length of the data.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

Definition at line 2538 of file MessageValidator.h.

References ValidateStringCopy().

ACTIV_BASE_EXPORTED_API StatusCode Activ::MessageValidator::ValidateStringCopy | ( | const std::vector< byte_t > & | set,
 |  | std::string * | pString,
 |  | void * | pCopy,
 |  | const size_t | copySize,
 |  | size_t * | pCopyLength
 | ) |  |

Validate string and copy.

Parameters:
set | the set of allowed values.
pString | the location to copy the string to.
pCopy | the address to copy the data to.
copySize | the size of data.
pCopyLength | pointer to the length of the data.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

StatusCode Activ::MessageValidator::ValidateStringCopy | ( | const std::vector< byte_t > & | set,
 |  | void * | pCopy,
 |  | const size_t | copySize,
 |  | size_t * | pCopyLength |
 | ) |  |  | [inline]

Validate string and copy.

Parameters:
set | the set of allowed values.
pCopy | the address to copy the data to.
copySize | the size of data.
pCopyLength | pointer to the length of the data.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

Definition at line 2531 of file MessageValidator.h.

References ValidateStringCopy().

ACTIV_BASE_EXPORTED_API StatusCode Activ::MessageValidator::ValidateStringCopy | ( | const byte_t | lower,
 |  | const byte_t | upper,
 |  | std::string * | pString,
 |  | void * | pCopy,
 |  | const size_t | copySize,
 |  | size_t * | pCopyLength
 | ) |  |

Validate string and copy.

Parameters:
lower | the lower bound value.
upper | the upper bound value.
pString | the location to copy the string to.
pCopy | the address to copy the data to.
copySize | the size of data.
pCopyLength | pointer to the length of the data.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

StatusCode Activ::MessageValidator::ValidateStringCopy | ( | const byte_t | lower,
 |  | const byte_t | upper,
 |  | void * | pCopy,
 |  | const size_t | copySize,
 |  | size_t * | pCopyLength |
 | ) |  |  | [inline]

Validate string and copy.

Parameters:
lower | the lower bound value.
upper | the upper bound value.
pCopy | the address to copy the data to.
copySize | the size of data.
pCopyLength | pointer to the length of the data.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

Definition at line 2524 of file MessageValidator.h.

References ValidateStringCopy().

ACTIV_BASE_EXPORTED_API StatusCode Activ::MessageValidator::ValidateStringCopy | ( | std::string * | pString,
 |  | void * | pCopy,
 |  | const size_t | copySize,
 |  | size_t * | pCopyLength
 | ) |  |

Validate string and copy.

Parameters:
pString | the location to copy the string to.
pCopy | the address to copy the data to.
copySize | the size of data.
pCopyLength | pointer to the length of the data.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER

StatusCode Activ::MessageValidator::ValidateStringCopy | ( | void * | pCopy,
 |  | const size_t | copySize,
 |  | size_t * | pCopyLength |
 | ) |  |  | [inline]

Validate string and copy.

Parameters:
pCopy | the address to copy the data to.
copySize | the size of data.
pCopyLength | pointer to the length of the data.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER

Definition at line 2517 of file MessageValidator.h.

Referenced by ValidateStringCopy().

template<typename T>
StatusCode Activ::MessageValidator::ValidateUnsignedAsciiIntegral | ( | const size_t | length,
 |  | const std::vector< uint64_t > & | set,
 |  | T * | pValue,
 |  | const void ** | ppData = 0 |
 | ) |  |  | [inline]

Validate an unsigned ASCII integral value.

Parameters:
length | the length of the value.
set | the set of allowed values.
pValue | the location to copy the value to.
ppData | the location to copy the address of the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

Definition at line 3251 of file MessageValidator.h.

StatusCode Activ::MessageValidator::ValidateUnsignedAsciiIntegral | ( | const size_t | length,
 |  | const std::vector< uint64_t > & | set,
 |  | const void ** | ppData = 0 |
 | ) |  |  | [inline]

Validate an unsigned ASCII integral value.

Parameters:
length | the length of the value.
set | the set of allowed values.
ppData | the location to copy the address of the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

Definition at line 2554 of file MessageValidator.h.

References ValidateUnsignedAsciiIntegral().

template<typename T>
StatusCode Activ::MessageValidator::ValidateUnsignedAsciiIntegral | ( | const size_t | length,
 |  | const uint64_t | lower,
 |  | const uint64_t | upper,
 |  | T * | pValue,
 |  | const void ** | ppData = 0 |
 | ) |  |  | [inline]

Validate an unsigned ASCII integral value.

Parameters:
length | the length of the value.
lower | the lower bound value.
upper | the upper bound value.
pValue | the location to copy the value to.
ppData | the location to copy the address of the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

Definition at line 3243 of file MessageValidator.h.

StatusCode Activ::MessageValidator::ValidateUnsignedAsciiIntegral | ( | const size_t | length,
 |  | const uint64_t | lower,
 |  | const uint64_t | upper,
 |  | const void ** | ppData = 0 |
 | ) |  |  | [inline]

Validate an unsigned ASCII integral value.

Parameters:
length | the length of the value.
lower | the lower bound value.
upper | the upper bound value.
ppData | the location to copy the address of the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

Definition at line 2545 of file MessageValidator.h.

References ValidateUnsignedAsciiIntegral().

template<typename T>
StatusCode Activ::MessageValidator::ValidateUnsignedAsciiIntegral | ( | const size_t | length,
 |  | T * | pValue,
 |  | const void ** | ppData = 0 |
 | ) |  |  | [inline]

Validate an unsigned ASCII integral value.

Parameters:
length | the length of the value.
pValue | the location to copy the value to.
ppData | the location to copy the address of the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

Definition at line 3235 of file MessageValidator.h.

ACTIV_BASE_EXPORTED_API StatusCode Activ::MessageValidator::ValidateUnsignedAsciiIntegral | ( | const size_t | length,
 |  | const void ** | ppData = 0
 | ) |  |

Validate an unsigned ASCII integral value.

Parameters:
length | the length of the value.
ppData | the location to copy the address of the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT
STATUS_CODE_INVALID_PARAMETER

Referenced by ValidateUnsignedAsciiIntegral().

template<typename T>
StatusCode Activ::MessageValidator::ValidateUnsignedAsciiIntegralCopy | ( | const size_t | length,
 |  | const std::vector< uint64_t > & | set,
 |  | T * | pValue,
 |  | void * | pCopy |
 | ) |  |  | [inline]

Validate an unsigned ASCII integral value and copy.

Parameters:
length | the length of the value.
set | the set of allowed values.
pValue | the location to copy the value to.
pCopy | the address to copy the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

Definition at line 3275 of file MessageValidator.h.

StatusCode Activ::MessageValidator::ValidateUnsignedAsciiIntegralCopy | ( | const size_t | length,
 |  | const std::vector< uint64_t > & | set,
 |  | void * | pCopy |
 | ) |  |  | [inline]

Validate an unsigned ASCII integral value and copy.

Parameters:
length | the length of the value.
set | the set of allowed values.
pCopy | the address to copy the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

Definition at line 2572 of file MessageValidator.h.

References ValidateUnsignedAsciiIntegralCopy().

template<typename T>
StatusCode Activ::MessageValidator::ValidateUnsignedAsciiIntegralCopy | ( | const size_t | length,
 |  | const uint64_t | lower,
 |  | const uint64_t | upper,
 |  | T * | pValue,
 |  | void * | pCopy |
 | ) |  |  | [inline]

Validate an unsigned ASCII integral value and copy.

Parameters:
length | the length of the value.
lower | the lower bound value.
upper | the upper bound value.
pValue | the location to copy the value to.
pCopy | the address to copy the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

Definition at line 3267 of file MessageValidator.h.

StatusCode Activ::MessageValidator::ValidateUnsignedAsciiIntegralCopy | ( | const size_t | length,
 |  | const uint64_t | lower,
 |  | const uint64_t | upper,
 |  | void * | pCopy |
 | ) |  |  | [inline]

Validate an unsigned ASCII integral value and copy.

Parameters:
length | the length of the value.
lower | the lower bound value.
upper | the upper bound value.
pCopy | the address to copy the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

Definition at line 2563 of file MessageValidator.h.

References ValidateUnsignedAsciiIntegralCopy().

template<typename T>
StatusCode Activ::MessageValidator::ValidateUnsignedAsciiIntegralCopy | ( | const size_t | length,
 |  | T * | pValue,
 |  | void * | pCopy |
 | ) |  |  | [inline]

Validate an unsigned ASCII integral value and copy.

Parameters:
length | the length of the value.
pValue | the location to copy the value to.
pCopy | the address to copy the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

Definition at line 3259 of file MessageValidator.h.

ACTIV_BASE_EXPORTED_API StatusCode Activ::MessageValidator::ValidateUnsignedAsciiIntegralCopy | ( | const size_t | length,
 |  | void * | pCopy
 | ) |  |

Validate an unsigned ASCII integral value and copy.

Parameters:
length | the length of the value.
pCopy | the address to copy the data to.
pCopy | the address to copy the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

Referenced by ValidateUnsignedAsciiIntegralCopy().

ACTIV_BASE_EXPORTED_API StatusCode Activ::MessageValidator::ValidateUnsignedAsciiReal | ( | const size_t | length,
 |  | const std::vector< long double > & | set,
 |  | uint64_t * | pNumerator,
 |  | uint64_t * | pDivisor,
 |  | const void ** | ppData = 0
 | ) |  |

Validate an unsigned ASCII real value.

Parameters:
length | the length of the value.
set | the set of allowed values.
pNumerator | the location to copy the numerator to.
pDivisor | the location to copy the divisor to.
ppData | the location to copy the address of the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

template<typename T>
StatusCode Activ::MessageValidator::ValidateUnsignedAsciiReal | ( | const size_t | length,
 |  | const std::vector< long double > & | set,
 |  | T * | pValue,
 |  | const void ** | ppData = 0 |
 | ) |  |  | [inline]

Validate an unsigned ASCII real value.

Parameters:
length | the length of the value.
set | the set of allowed values.
pValue | the location to copy the value to.
ppData | the location to copy the address of the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

Definition at line 3299 of file MessageValidator.h.

StatusCode Activ::MessageValidator::ValidateUnsignedAsciiReal | ( | const size_t | length,
 |  | const std::vector< long double > & | set,
 |  | const void ** | ppData = 0 |
 | ) |  |  | [inline]

Validate an unsigned ASCII real value.

Parameters:
length | the length of the value.
set | the set of allowed values.
ppData | the location to copy the address of the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

Definition at line 2590 of file MessageValidator.h.

References ValidateUnsignedAsciiReal().

ACTIV_BASE_EXPORTED_API StatusCode Activ::MessageValidator::ValidateUnsignedAsciiReal | ( | const size_t | length,
 |  | const long double | lower,
 |  | const long double | upper,
 |  | uint64_t * | pNumerator,
 |  | uint64_t * | pDivisor,
 |  | const void ** | ppData = 0
 | ) |  |

Validate an unsigned ASCII real value.

Parameters:
length | the length of the value.
lower | the lower bound value.
upper | the upper bound value.
pNumerator | the location to copy the numerator to.
pDivisor | the location to copy the divisor to.
ppData | the location to copy the address of the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

template<typename T>
StatusCode Activ::MessageValidator::ValidateUnsignedAsciiReal | ( | const size_t | length,
 |  | const long double | lower,
 |  | const long double | upper,
 |  | T * | pValue,
 |  | const void ** | ppData = 0 |
 | ) |  |  | [inline]

Validate an unsigned ASCII real value.

Parameters:
length | the length of the value.
lower | the lower bound value.
upper | the upper bound value.
pValue | the location to copy the value to.
ppData | the location to copy the address of the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

Definition at line 3291 of file MessageValidator.h.

StatusCode Activ::MessageValidator::ValidateUnsignedAsciiReal | ( | const size_t | length,
 |  | const long double | lower,
 |  | const long double | upper,
 |  | const void ** | ppData = 0 |
 | ) |  |  | [inline]

Validate an unsigned ASCII real value.

Parameters:
length | the length of the value.
lower | the lower bound value.
upper | the upper bound value.
ppData | the location to copy the address of the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

Definition at line 2581 of file MessageValidator.h.

References ValidateUnsignedAsciiReal().

ACTIV_BASE_EXPORTED_API StatusCode Activ::MessageValidator::ValidateUnsignedAsciiReal | ( | const size_t | length,
 |  | uint64_t * | pNumerator,
 |  | uint64_t * | pDivisor,
 |  | const void ** | ppData = 0
 | ) |  |

Validate an unsigned ASCII real value.

Parameters:
length | the length of the value.
pNumerator | the location to copy the numerator to.
pDivisor | the location to copy the divisor to.
ppData | the location to copy the address of the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

template<typename T>
StatusCode Activ::MessageValidator::ValidateUnsignedAsciiReal | ( | const size_t | length,
 |  | T * | pValue,
 |  | const void ** | ppData = 0 |
 | ) |  |  | [inline]

Validate an unsigned ASCII real value.

Parameters:
length | the length of the value.
pValue | the location to copy the value to.
ppData | the location to copy the address of the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

Definition at line 3283 of file MessageValidator.h.

ACTIV_BASE_EXPORTED_API StatusCode Activ::MessageValidator::ValidateUnsignedAsciiReal | ( | const size_t | length,
 |  | const void ** | ppData = 0
 | ) |  |

Validate an unsigned ASCII real value.

Parameters:
length | the length of the value.
ppData | the location to copy the address of the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

Referenced by ValidateUnsignedAsciiReal().

ACTIV_BASE_EXPORTED_API StatusCode Activ::MessageValidator::ValidateUnsignedAsciiRealCopy | ( | const size_t | length,
 |  | const std::vector< long double > & | set,
 |  | uint64_t * | pNumerator,
 |  | uint64_t * | pDivisor,
 |  | void * | pCopy
 | ) |  |

Validate an unsigned ASCII real value and copy.

Parameters:
length | the length of the value.
set | the set of allowed values.
pNumerator | the location to copy the numerator to.
pDivisor | the location to copy the divisor to.
pCopy | the address to copy the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

template<typename T>
StatusCode Activ::MessageValidator::ValidateUnsignedAsciiRealCopy | ( | const size_t | length,
 |  | const std::vector< long double > & | set,
 |  | T * | pValue,
 |  | void * | pCopy |
 | ) |  |  | [inline]

Validate an unsigned ASCII real value and copy.

Parameters:
length | the length of the value.
set | the set of allowed values.
pValue | the location to copy the value to.
pCopy | the address to copy the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

Definition at line 3323 of file MessageValidator.h.

StatusCode Activ::MessageValidator::ValidateUnsignedAsciiRealCopy | ( | const size_t | length,
 |  | const std::vector< long double > & | set,
 |  | void * | pCopy |
 | ) |  |  | [inline]

Validate an unsigned ASCII real value and copy.

Parameters:
length | the length of the value.
set | the set of allowed values.
pCopy | the address to copy the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

Definition at line 2608 of file MessageValidator.h.

References ValidateUnsignedAsciiRealCopy().

ACTIV_BASE_EXPORTED_API StatusCode Activ::MessageValidator::ValidateUnsignedAsciiRealCopy | ( | const size_t | length,
 |  | const long double | lower,
 |  | const long double | upper,
 |  | uint64_t * | pNumerator,
 |  | uint64_t * | pDivisor,
 |  | void * | pCopy
 | ) |  |

Validate an unsigned ASCII real value and copy.

Parameters:
length | the length of the value.
lower | the lower bound value.
upper | the upper bound value.
pNumerator | the location to copy the numerator to.
pDivisor | the location to copy the divisor to.
pCopy | the address to copy the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

template<typename T>
StatusCode Activ::MessageValidator::ValidateUnsignedAsciiRealCopy | ( | const size_t | length,
 |  | const long double | lower,
 |  | const long double | upper,
 |  | T * | pValue,
 |  | void * | pCopy |
 | ) |  |  | [inline]

Validate an unsigned ASCII real value and copy.

Parameters:
length | the length of the value.
lower | the lower bound value.
upper | the upper bound value.
pValue | the location to copy the value to.
pCopy | the address to copy the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

Definition at line 3315 of file MessageValidator.h.

StatusCode Activ::MessageValidator::ValidateUnsignedAsciiRealCopy | ( | const size_t | length,
 |  | const long double | lower,
 |  | const long double | upper,
 |  | void * | pCopy |
 | ) |  |  | [inline]

Validate an unsigned ASCII real value and copy.

Parameters:
length | the length of the value.
lower | the lower bound value.
upper | the upper bound value.
pCopy | the address to copy the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

Definition at line 2599 of file MessageValidator.h.

References ValidateUnsignedAsciiRealCopy().

ACTIV_BASE_EXPORTED_API StatusCode Activ::MessageValidator::ValidateUnsignedAsciiRealCopy | ( | const size_t | length,
 |  | uint64_t * | pNumerator,
 |  | uint64_t * | pDivisor,
 |  | void * | pCopy
 | ) |  |

Validate an unsigned ASCII real value and copy.

Parameters:
length | the length of the value.
pNumerator | the location to copy the numerator to.
pDivisor | the location to copy the divisor to.
pCopy | the address to copy the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

template<typename T>
StatusCode Activ::MessageValidator::ValidateUnsignedAsciiRealCopy | ( | const size_t | length,
 |  | T * | pValue,
 |  | void * | pCopy |
 | ) |  |  | [inline]

Validate an unsigned ASCII real value and copy.

Parameters:
length | the length of the value.
pValue | the location to copy the value to.
pCopy | the address to copy the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

Definition at line 3307 of file MessageValidator.h.

ACTIV_BASE_EXPORTED_API StatusCode Activ::MessageValidator::ValidateUnsignedAsciiRealCopy | ( | const size_t | length,
 |  | void * | pCopy
 | ) |  |

Validate an unsigned ASCII real value and copy.

Parameters:
length | the length of the value.
pCopy | the address to copy the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

Referenced by ValidateUnsignedAsciiRealCopy().

template<typename T>
StatusCode Activ::MessageValidator::ValidateUnsignedBinaryIntegral | ( | const size_t | size,
 |  | const std::vector< uint64_t > & | set,
 |  | const Endian | endian,
 |  | T * | pValue,
 |  | const void ** | ppData = 0 |
 | ) |  |  | [inline]

Validate an unsigned binary integral value.

Parameters:
size | the size of the value.
set | the set of allowed values.
endian | the endian of the value.
pValue | the location to copy the value to.
ppData | the location to copy the address of the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

Definition at line 3347 of file MessageValidator.h.

StatusCode Activ::MessageValidator::ValidateUnsignedBinaryIntegral | ( | const size_t | size,
 |  | const std::vector< uint64_t > & | set,
 |  | const Endian | endian,
 |  | const void ** | ppData = 0 |
 | ) |  |  | [inline]

Validate an unsigned binary integral value.

Parameters:
size | the size of the value.
set | the set of allowed values.
endian | the endian of the value.
ppData | the location to copy the address of the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

Definition at line 2626 of file MessageValidator.h.

References ValidateUnsignedBinaryIntegral().

template<typename T>
StatusCode Activ::MessageValidator::ValidateUnsignedBinaryIntegral | ( | const size_t | size,
 |  | const uint64_t | lower,
 |  | const uint64_t | upper,
 |  | const Endian | endian,
 |  | T * | pValue,
 |  | const void ** | ppData = 0 |
 | ) |  |  | [inline]

Validate an unsigned binary integral value.

Parameters:
size | the size of the value.
lower | the lower bound value.
upper | the upper bound value.
endian | the endian of the value.
pValue | the location to copy the value to.
ppData | the location to copy the address of the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

Definition at line 3339 of file MessageValidator.h.

StatusCode Activ::MessageValidator::ValidateUnsignedBinaryIntegral | ( | const size_t | size,
 |  | const uint64_t | lower,
 |  | const uint64_t | upper,
 |  | const Endian | endian,
 |  | const void ** | ppData = 0 |
 | ) |  |  | [inline]

Validate an unsigned binary integral value.

Parameters:
size | the size of the value.
lower | the lower bound value.
upper | the upper bound value.
endian | the endian of the value.
ppData | the location to copy the address of the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

Definition at line 2617 of file MessageValidator.h.

References ValidateUnsignedBinaryIntegral().

template<typename T>
StatusCode Activ::MessageValidator::ValidateUnsignedBinaryIntegral | ( | const size_t | size,
 |  | const Endian | endian,
 |  | T * | pValue,
 |  | const void ** | ppData = 0 |
 | ) |  |  | [inline]

Validate an unsigned binary integral value.

Parameters:
size | the size of the value.
endian | the endian of the value.
pValue | the location to copy the value to.
ppData | the location to copy the address of the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER

Definition at line 3331 of file MessageValidator.h.

ACTIV_BASE_EXPORTED_API StatusCode Activ::MessageValidator::ValidateUnsignedBinaryIntegral | ( | const size_t | size,
 |  | const Endian | endian,
 |  | const void ** | ppData = 0
 | ) |  |

Validate an unsigned binary integral value.

Parameters:
size | the size of the value.
endian | the endian of the value.
ppData | the location to copy the address of the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER

Referenced by Activ::SerializableContainerHelper< std::set< OBJECT_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >::Deserialize(), Activ::SerializableContainerHelper< std::list< OBJECT_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >::Deserialize(), Activ::SerializableContainerHelper< std::vector< OBJECT_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >::Deserialize(), ValidateBoolean(), and ValidateUnsignedBinaryIntegral().

template<typename T>
StatusCode Activ::MessageValidator::ValidateUnsignedBinaryIntegralCopy | ( | const size_t | size,
 |  | const std::vector< uint64_t > & | set,
 |  | const Endian | endian,
 |  | T * | pValue,
 |  | void * | pCopy |
 | ) |  |  | [inline]

Validate an unsigned binary integral value and copy.

Parameters:
size | the size of the value.
set | the set of allowed values.
endian | the endian of the value.
pValue | the location to copy the value to.
pCopy | the address to copy the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

Definition at line 3371 of file MessageValidator.h.

StatusCode Activ::MessageValidator::ValidateUnsignedBinaryIntegralCopy | ( | const size_t | size,
 |  | const std::vector< uint64_t > & | set,
 |  | const Endian | endian,
 |  | void * | pCopy |
 | ) |  |  | [inline]

Validate an unsigned binary integral value and copy.

Parameters:
size | the size of the value.
set | the set of allowed values.
endian | the endian of the value.
pCopy | the address to copy the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

Definition at line 2644 of file MessageValidator.h.

References ValidateUnsignedBinaryIntegralCopy().

template<typename T>
StatusCode Activ::MessageValidator::ValidateUnsignedBinaryIntegralCopy | ( | const size_t | size,
 |  | const uint64_t | lower,
 |  | const uint64_t | upper,
 |  | const Endian | endian,
 |  | T * | pValue,
 |  | void * | pCopy |
 | ) |  |  | [inline]

Validate an unsigned binary integral value and copy.

Parameters:
size | the size of the value.
lower | the lower bound value.
upper | the upper bound value.
endian | the endian of the value.
pValue | the location to copy the value to.
pCopy | the address to copy the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

Definition at line 3363 of file MessageValidator.h.

StatusCode Activ::MessageValidator::ValidateUnsignedBinaryIntegralCopy | ( | const size_t | size,
 |  | const uint64_t | lower,
 |  | const uint64_t | upper,
 |  | const Endian | endian,
 |  | void * | pCopy |
 | ) |  |  | [inline]

Validate an unsigned binary integral value and copy.

Parameters:
size | the size of the value.
lower | the lower bound value.
upper | the upper bound value.
endian | the endian of the value.
pCopy | the address to copy the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

Definition at line 2635 of file MessageValidator.h.

References ValidateUnsignedBinaryIntegralCopy().

template<typename T>
StatusCode Activ::MessageValidator::ValidateUnsignedBinaryIntegralCopy | ( | const size_t | size,
 |  | const Endian | endian,
 |  | T * | pValue,
 |  | void * | pCopy |
 | ) |  |  | [inline]

Validate an unsigned binary integral value and copy.

Parameters:
size | the size of the value.
endian | the endian of the value.
pValue | the location to copy the value to.
pCopy | the address to copy the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER

Definition at line 3355 of file MessageValidator.h.

ACTIV_BASE_EXPORTED_API StatusCode Activ::MessageValidator::ValidateUnsignedBinaryIntegralCopy | ( | const size_t | size,
 |  | const Endian | endian,
 |  | void * | pCopy
 | ) |  |

Validate an unsigned binary integral value and copy.

Parameters:
size | the size of the value.
endian | the endian of the value.
pCopy | the address to copy the data to.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER

Referenced by ValidateUnsignedBinaryIntegralCopy().

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivBase/MessageValidator.h
Generated on Wed Oct 8 14:01:58 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::NextBitField

Activ::NextBitField< PREVIOUS_FIELD, LENGTH_VALUE > Class Template Reference

Next bitfield helper class. More...

#include <ActivMiddleware/Misc/BitFields.h>

Inheritance diagram for Activ::NextBitField< PREVIOUS_FIELD, LENGTH_VALUE >:

Activ::BitField< PREVIOUS_FIELD::Bitmap, PREVIOUS_FIELD::OFFSET+PREVIOUS_FIELD::LENGTH, LENGTH_VALUE >

List of all members.

Detailed Description

template<typename PREVIOUS_FIELD, size_t LENGTH_VALUE>
class Activ::NextBitField< PREVIOUS_FIELD, LENGTH_VALUE >

Next bitfield helper class.

Parameters:
PREVIOUS_FIELD | previous field type.
LENGTH_VALUE | length of the bitfield in bits.

Definition at line 150 of file BitFields.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/Misc/BitFields.h
Generated on Wed Oct 8 14:01:58 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::NullObject

Activ::NullObject Class Reference

Do-nothing function object. More...

#include <ActivMiddleware/Misc/FunctionObjects.h>

List of all members.

Public Member Functions

template<typename T>
void operator() (const T *ptr) const

Detailed Description

Do-nothing function object.

Definition at line 21 of file FunctionObjects.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/Misc/FunctionObjects.h
Generated on Wed Oct 8 14:01:58 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ObjectPool

Activ::ObjectPool< T, INITIAL_FREE_LIST_SIZE, MAX_FREE_LIST_SIZE > Class Template Reference

Object pool. More...

#include <ActivMiddleware/Misc/ObjectPool.h>

Inheritance diagram for Activ::ObjectPool< T, INITIAL_FREE_LIST_SIZE, MAX_FREE_LIST_SIZE >:

Activ::Singleton< T >

List of all members.

Public Types

typedef T | ObjectType

Public Member Functions

BOOST_STATIC_ASSERT (INITIAL_FREE_LIST_SIZE<=MAX_FREE_LIST_SIZE)
void | DestroyAll ()
Destroy all objects allocated by the pool (those currently in use and in the free list).
T * | Get ()
Get an object from the pool.
Stats | GetStats () const
Get statistics.
bool | Return (T *const pObject)
Return an in use object to the pool.
void | ReturnAll ()
Return all in use objects to the pool (invalidates all in use pointers).

Static Public Member Functions

static ObjectPool & | GetInstance ()
Get a reference to the singleton instance.

Friends

class | Singleton< ObjectPool< T, INITIAL_FREE_LIST_SIZE, MAX_FREE_LIST_SIZE > >

Classes

class | Stats
Pool statistics. More...

Detailed Description

template<typename T, size_t INITIAL_FREE_LIST_SIZE = 0, size_t MAX_FREE_LIST_SIZE = 0>
class Activ::ObjectPool< T, INITIAL_FREE_LIST_SIZE, MAX_FREE_LIST_SIZE >

Object pool.

This pool is only for single threaded use.

T the type of the object to cache; must be default constructible. INITIAL_FREE_LIST_SIZE the initial size of the free list. MAX_FREE_LIST_SIZE the maximum size of the free list. 0 is no upper bound.

Definition at line 33 of file ObjectPool.h.

Member Function Documentation

template<typename T, size_t INITIAL_FREE_LIST_SIZE, size_t MAX_FREE_LIST_SIZE>
T * Activ::ObjectPool< T, INITIAL_FREE_LIST_SIZE, MAX_FREE_LIST_SIZE >::Get ( ) [inline]

Get an object from the pool.

Returns:
Pointer to an object from the pool, or a newed object, or 0 if the heap is empty.

Definition at line 173 of file ObjectPool.h.

template<typename T, size_t INITIAL_FREE_LIST_SIZE, size_t MAX_FREE_LIST_SIZE>
ObjectPool< T, INITIAL_FREE_LIST_SIZE, MAX_FREE_LIST_SIZE > & Activ::ObjectPool< T, INITIAL_FREE_LIST_SIZE, MAX_FREE_LIST_SIZE >::GetInstance ( ) [inline, static]

Get a reference to the singleton instance.

Returns:
Reference.

Definition at line 274 of file ObjectPool.h.

template<typename T, size_t INITIAL_FREE_LIST_SIZE, size_t MAX_FREE_LIST_SIZE>
ObjectPool< T, INITIAL_FREE_LIST_SIZE, MAX_FREE_LIST_SIZE >::Stats Activ::ObjectPool< T, INITIAL_FREE_LIST_SIZE, MAX_FREE_LIST_SIZE >::GetStats ( ) const [inline]

Get statistics.

Returns:
Stats.

Definition at line 256 of file ObjectPool.h.

References Activ::ObjectPool< T, INITIAL_FREE_LIST_SIZE, MAX_FREE_LIST_SIZE >::Stats::m_currentFreeListSize, Activ::ObjectPool< T, INITIAL_FREE_LIST_SIZE, MAX_FREE_LIST_SIZE >::Stats::m_currentInUseCount, Activ::ObjectPool< T, INITIAL_FREE_LIST_SIZE, MAX_FREE_LIST_SIZE >::Stats::m_initialFreeListSize, Activ::ObjectPool< T, INITIAL_FREE_LIST_SIZE, MAX_FREE_LIST_SIZE >::Stats::m_maximumAllowedFreeListSize, Activ::ObjectPool< T, INITIAL_FREE_LIST_SIZE, MAX_FREE_LIST_SIZE >::Stats::m_maximumFreeListSize, and Activ::ObjectPool< T, INITIAL_FREE_LIST_SIZE, MAX_FREE_LIST_SIZE >::Stats::m_maximumInUseCount.

template<typename T, size_t INITIAL_FREE_LIST_SIZE, size_t MAX_FREE_LIST_SIZE>
bool Activ::ObjectPool< T, INITIAL_FREE_LIST_SIZE, MAX_FREE_LIST_SIZE >::Return ( T *const pObject ) [inline]

Return an in use object to the pool.

The object will be deleted if the free list is already full.

Parameters:
pObject Pointer to object to return.
Returns:
true if object was returned to the pool or deleted, false if object was not created by the pool.

Definition at line 200 of file ObjectPool.h.

template<typename T, size_t INITIAL_FREE_LIST_SIZE, size_t MAX_FREE_LIST_SIZE>
void Activ::ObjectPool< T, INITIAL_FREE_LIST_SIZE, MAX_FREE_LIST_SIZE >::ReturnAll ( ) [inline]

Return all in use objects to the pool (invalidates all in use pointers).

Some objects may be deleted if the free list is already full.

Definition at line 227 of file ObjectPool.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/Misc/ObjectPool.h
Generated on Wed Oct 8 14:01:58 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ObjectPool::Stats

Activ::ObjectPool< T, INITIAL_FREE_LIST_SIZE, MAX_FREE_LIST_SIZE >::Stats Class Reference

Pool statistics. More...

#include <ActivMiddleware/Misc/ObjectPool.h>

List of all members.

Public Attributes

size_t | m_currentFreeListSize
size_t | m_currentInUseCount
size_t | m_initialFreeListSize
size_t | m_maximumAllowedFreeListSize
size_t | m_maximumFreeListSize
size_t | m_maximumInUseCount

Detailed Description

template<typename T, size_t INITIAL_FREE_LIST_SIZE = 0, size_t MAX_FREE_LIST_SIZE = 0>
class Activ::ObjectPool< T, INITIAL_FREE_LIST_SIZE, MAX_FREE_LIST_SIZE >::Stats

Pool statistics.

Definition at line 43 of file ObjectPool.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/Misc/ObjectPool.h
Generated on Wed Oct 8 14:01:58 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::OpenServiceRequest

Activ::OpenServiceRequest Class Reference

Open service request. More...

#include <ActivMiddleware/ActivFramework/Messages.h>

Inheritance diagram for Activ::OpenServiceRequest:

Activ::ISerializableMessage

List of all members.

Public Member Functions

virtual ACTIV_FRAMEWORK_API
StatusCode 		Deserialize (MessageValidator &messageValidator)
Deserialize the message.
ACTIV_FRAMEWORK_API | OpenServiceRequest ()
Default constructor.
virtual ACTIV_FRAMEWORK_API
StatusCode 		Serialize (MessageBuilder &messageBuilder) const
Serialize the message.

Public Attributes

ServiceId | m_serviceId
byte_t | m_version

Static Public Attributes

static const byte_t | m_currentVersion = 1
Current version used by client side.
static const byte_t | m_highestVersion = 2
Highest supported version.

Detailed Description

Open service request.

Definition at line 21 of file Messages.h.

Constructor & Destructor Documentation

ACTIV_FRAMEWORK_API Activ::OpenServiceRequest::OpenServiceRequest ( )

Default constructor.

m_version is set to m_currentVersion, but can be overriden if required.

Member Function Documentation

virtual ACTIV_FRAMEWORK_API StatusCode Activ::OpenServiceRequest::Deserialize ( MessageValidator & messageValidator ) [virtual]

Deserialize the message.

Parameters:
messageValidator message validator from which the data will be extracted.

Implements Activ::ISerializableMessage.

virtual ACTIV_FRAMEWORK_API StatusCode Activ::OpenServiceRequest::Serialize ( MessageBuilder & messageBuilder ) const [virtual]

Serialize the message.

Parameters:
messageBuilder message builder into which data will be placed.

Implements Activ::ISerializableMessage.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivFramework/Messages.h
Generated on Wed Oct 8 14:01:58 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::OpenServiceResponse

Activ::OpenServiceResponse Class Reference

Open service response. The response implicitly matches the version of the request. More...

#include <ActivMiddleware/ActivFramework/Messages.h>

Inheritance diagram for Activ::OpenServiceResponse:

Activ::ISerializableMessage

List of all members.

Public Member Functions

virtual ACTIV_FRAMEWORK_API
StatusCode 		Deserialize (MessageValidator &messageValidator)
Deserialize the message.
ACTIV_FRAMEWORK_API | OpenServiceResponse (const ServiceId &serviceId)
Constructor.
ACTIV_FRAMEWORK_API | OpenServiceResponse ()
Default constructor.
virtual ACTIV_FRAMEWORK_API
StatusCode 		Serialize (MessageBuilder &messageBuilder) const
Serialize the message.

Public Attributes

ServiceId | m_serviceId

Detailed Description

Open service response. The response implicitly matches the version of the request.

Definition at line 47 of file Messages.h.

Constructor & Destructor Documentation

ACTIV_FRAMEWORK_API Activ::OpenServiceResponse::OpenServiceResponse ( const ServiceId & serviceId )

Constructor.

Parameters:
serviceId id for the service.

Member Function Documentation

virtual ACTIV_FRAMEWORK_API StatusCode Activ::OpenServiceResponse::Deserialize ( MessageValidator & messageValidator ) [virtual]

Deserialize the message.

Parameters:
messageValidator message validator from which the data will be extracted.

Implements Activ::ISerializableMessage.

virtual ACTIV_FRAMEWORK_API StatusCode Activ::OpenServiceResponse::Serialize ( MessageBuilder & messageBuilder ) const [virtual]

Serialize the message.

Parameters:
messageBuilder message builder into which data will be placed.

Implements Activ::ISerializableMessage.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivFramework/Messages.h
Generated on Wed Oct 8 14:01:58 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::OsException

Activ::OsException Class Reference

OS exception class. More...

#include <ActivMiddleware/ActivBase/OsException.h>

Inheritance diagram for Activ::OsException:

Activ::Exception

List of all members.

Public Member Functions

ACTIV_BASE_EXPORTED_API OsException (const char *file, const char *function, uint_fast32_t line, const uint_fast32_t errorCode)
Default constructor.
virtual
ACTIV_BASE_EXPORTED_API
std::string 		ToString () const
Convert the exception error code to a string.

Detailed Description

OS exception class.

Definition at line 31 of file OsException.h.

Constructor & Destructor Documentation

ACTIV_BASE_EXPORTED_API Activ::OsException::OsException | ( | const char * | file,
 |  | const char * | function,
 |  | uint_fast32_t | line,
 |  | const uint_fast32_t | errorCode
 | ) |  |

Default constructor.

Parameters:
file | the file which raised the exception.
function | the function which raised the exception.
line | the line number which raised the exception.
errorCode | the exception specific error code.

Member Function Documentation

virtual ACTIV_BASE_EXPORTED_API std::string Activ::OsException::ToString ( ) const [virtual]

Convert the exception error code to a string.

Classes derived from Exception are required to implement ToString() to convert their error codes to a readable string.

Returns:
the error code as a string.

Reimplemented from Activ::Exception.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivBase/OsException.h
Generated on Wed Oct 8 14:01:58 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::PagingFileMappedMemoryFactory

Activ::PagingFileMappedMemoryFactory Class Reference

Paging file mapped memory factory class. More...

#include <ActivMiddleware/ActivBase/PagingFileMappedMemoryFactory.h>

Inheritance diagram for Activ::PagingFileMappedMemoryFactory:

Activ::Singleton< T >

List of all members.

Public Member Functions

ACTIV_BASE_EXPORTED_API
IMappedMemory * 		Create (const size_t size, const IMappedMemory::MappingFlags mappingFlags=IMappedMemory::MAPPING_FLAG_NONE)
Create an anonymous paging file mapped memory segment.
ACTIV_BASE_EXPORTED_API
IMappedMemory * 		Create (const std::string &name, const size_t size, const IMappedMemory::MappingFlags mappingFlags=IMappedMemory::MAPPING_FLAG_NONE)
Create a paging file mapped memory segment that can be shared via name.
ACTIV_BASE_EXPORTED_API
IMappedMemory * 		Open (const std::string &name, const IMappedMemory::MappingFlags mappingFlags=IMappedMemory::MAPPING_FLAG_NONE, Timeout &timeout=Timeout::GetInfinite())
Open an existing paging file mapped memory segment.

Static Public Member Functions

static ACTIV_BASE_EXPORTED_API
PagingFileMappedMemoryFactory & 		GetInstance ()
Get a reference to the singleton instance.

Friends

class Singleton< PagingFileMappedMemoryFactory >

Detailed Description

Paging file mapped memory factory class.

Definition at line 25 of file PagingFileMappedMemoryFactory.h.

Member Function Documentation

ACTIV_BASE_EXPORTED_API IMappedMemory* Activ::PagingFileMappedMemoryFactory::Create | ( | const size_t | size,
 |  | const IMappedMemory::MappingFlags | mappingFlags = IMappedMemory::MAPPING_FLAG_NONE
 | ) |  |

Create an anonymous paging file mapped memory segment.

Parameters:
size | the size of the mapped memory segment.
mappingFlags | creation flags.
Returns:
Pointer to an object providing an IMappedMemory interface.
Exceptions:
Exception

ACTIV_BASE_EXPORTED_API IMappedMemory* Activ::PagingFileMappedMemoryFactory::Create | ( | const std::string & | name,
 |  | const size_t | size,
 |  | const IMappedMemory::MappingFlags | mappingFlags = IMappedMemory::MAPPING_FLAG_NONE
 | ) |  |

Create a paging file mapped memory segment that can be shared via name.

Parameters:
name | the name of the mapped memory segment.
size | the size of the mapped memory segment.
mappingFlags | creation flags.
Returns:
Pointer to an object providing an IMappedMemory interface.
Exceptions:
Exception

Referenced by Activ::SharedObject< T >::Create().

static ACTIV_BASE_EXPORTED_API PagingFileMappedMemoryFactory& Activ::PagingFileMappedMemoryFactory::GetInstance ( ) [static]

Get a reference to the singleton instance.

Returns:
Reference.

Referenced by Activ::SharedObject< T >::Create(), and Activ::SharedObject< T >::Open().

ACTIV_BASE_EXPORTED_API IMappedMemory* Activ::PagingFileMappedMemoryFactory::Open | ( | const std::string & | name,
 |  | const IMappedMemory::MappingFlags | mappingFlags = IMappedMemory::MAPPING_FLAG_NONE,
 |  | Timeout & | timeout = Timeout::GetInfinite()
 | ) |  |

Open an existing paging file mapped memory segment.

Parameters:
name | the name of the mapped memory segment.
mappingFlags | flags that indicate how the memory segment should be mapped.
timeout | object specifying how long to wait for the segment to exist, in ms.
Returns:
pointer to an object providing an IMappedMemory interface.
Exceptions:
OsException
BaseException

Referenced by Activ::SharedObject< T >::Open().

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivBase/PagingFileMappedMemoryFactory.h
Generated on Wed Oct 8 14:01:58 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Port

Activ::Port Class Reference

Port class. More...

#include <ActivMiddleware/ActivSystem/Port.h>

Inheritance diagram for Activ::Port:

Activ::Component Activ::Application Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient Activ::ContentPlatform::ContentServerApi::ContentServerClient Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient Activ::ContentPlatform::ContributionServerApi::ContributionServerClient Activ::Service Activ::UdpComponent Activ::UiComponent

List of all members.

Public Member Functions

ACTIV_SYSTEM_EXPORTED_API void | Disable ()
Disable a port.
ACTIV_SYSTEM_EXPORTED_API void | Enable ()
Enable a port.
ACTIV_SYSTEM_EXPORTED_API
StatusCode 		FindPort (const std::string &endPointName, const std::string &portName, Address &portAddress, const TimeoutPeriod timeout=defaultTimeout)
Find an endpoint & port by name.
ACTIV_SYSTEM_EXPORTED_API
StatusCode 		ForwardMessage (const Address &destinationAddress, HeapMessage &message, const MessageType newType=INVALID_MESSAGE_TYPE) const
Forward a message to another address without changing the source address.
ACTIV_SYSTEM_INLINE_API const
Address & 		GetAddress () const
Get the address of this port.
ACTIV_SYSTEM_INLINE_API IHeap * | GetHeap () const
Get the heap used for messaging.
ACTIV_SYSTEM_EXPORTED_API
ManagedEndPoint & 		GetManagedEndPoint () const
Get the managed endpoint this port is attached to.
ACTIV_SYSTEM_EXPORTED_API
const std::string & 		GetName () const
Get the name of the port.
ACTIV_SYSTEM_EXPORTED_API | Port (ManagedEndPoint &managedEndPoint, const std::string &name, const PortId portId, IHeap *const pHeap)
Constructor.
ACTIV_SYSTEM_EXPORTED_API | Port (ManagedEndPoint &managedEndPoint, const std::string &name, IHeap *const pHeap)
Constructor.
ACTIV_SYSTEM_EXPORTED_API
StatusCode 		PostEmptyResponse (const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, const StatusCode responseStatus, HeapMessage &response) const
Post an empty response to a request. Use this call when the response message is a newly allocated HeapMessage and is not the original request.
ACTIV_SYSTEM_EXPORTED_API
StatusCode 		PostEmptyResponse (const StatusCode responseStatus, HeapMessage &response) const
Post an empty response to a request. The response will be sent to the source address of the request.
ACTIV_SYSTEM_EXPORTED_API
StatusCode 		PostMessage (const Address &destinationAddress, const MessageType messageType, HeapMessage &message) const
Post a message.
ACTIV_SYSTEM_EXPORTED_API
StatusCode 		PostMessage (const Address &destinationAddress, const MessageType messageType, const void *pMessage=0, const size_t messageLength=0) const
Post a message.
ACTIV_SYSTEM_EXPORTED_API
StatusCode 		PostMessage (const Address &destinationAddress, const MessageType messageType, const MessageBuilder &messageBuilder) const
Post a message.
ACTIV_SYSTEM_EXPORTED_API
StatusCode 		PostRequest (const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, HeapMessage &request) const
Post an asynchronous request.
ACTIV_SYSTEM_EXPORTED_API
StatusCode 		PostRequest (const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, const void *pRequest=0, const size_t requestLength=0) const
Post an asynchronous request.
ACTIV_SYSTEM_EXPORTED_API
StatusCode 		PostRequest (const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, const MessageBuilder &messageBuilder) const
Post an asynchronous request.
ACTIV_SYSTEM_EXPORTED_API
StatusCode 		PostResponse (const StatusCode responseStatus, HeapMessage &request) const
Post a response to a request where the original request message has been filled in with the response. All other members of the response message must be as received (request id, type, addresses).
ACTIV_SYSTEM_EXPORTED_API
StatusCode 		PostResponse (const StatusCode responseStatus, HeapMessage &request, HeapMessage &response) const
Post a response to a request where the request HeapMessage still has the original request id and message type of the request. The provided response HeapMessage contains the response body.
ACTIV_SYSTEM_EXPORTED_API
StatusCode 		PostResponse (const StatusCode responseStatus, HeapMessage &request, const void *pResponse, const size_t responseLength) const
Post a response to a request where the request HeapMessage still has the original request id and message type of the request. The contents of the request HeapMessage are overriden with the provided buffer.
ACTIV_SYSTEM_EXPORTED_API
StatusCode 		PostResponse (const StatusCode responseStatus, HeapMessage &request, const MessageBuilder &messageBuilder) const
Post a response to a request where the request HeapMessage still has the original request id and message type of the request. The contents of the request HeapMessage are overriden with the provided MessageBuilder contents.
ACTIV_SYSTEM_EXPORTED_API
StatusCode 		PostResponse (const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, const StatusCode responseStatus, HeapMessage &response) const
Post a response to a request. Use this call when the response message is a newly allocated HeapMessage and is not the original request.
ACTIV_SYSTEM_EXPORTED_API
StatusCode 		PostResponse (const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, const StatusCode responseStatus, const void *pResponse=0, const size_t responseLength=0) const
Post a response to a request.
ACTIV_SYSTEM_EXPORTED_API
StatusCode 		PostResponse (const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, const StatusCode responseStatus, const MessageBuilder &messageBuilder) const
Post a response to a request.
ACTIV_SYSTEM_EXPORTED_API
StatusCode 		SendRequest (const Address &destinationAddress, const MessageType requestType, SyncRequestId &syncRequestId, HeapMessage &request) const
Send a synchronous request but do not wait for the response.
ACTIV_SYSTEM_EXPORTED_API
StatusCode 		SendRequest (const Address &destinationAddress, const MessageType requestType, SyncRequestId &syncRequestId, const void *pRequest, const size_t requestLength) const
Send a synchronous request but do not wait for the response.
ACTIV_SYSTEM_EXPORTED_API
StatusCode 		SendRequest (const Address &destinationAddress, const MessageType requestType, SyncRequestId &syncRequestId, const MessageBuilder &messageBuilder) const
Send a synchronous request but do not wait for the response.
ACTIV_SYSTEM_EXPORTED_API
StatusCode 		SendRequest (const Address &destinationAddress, const MessageType requestType, HeapMessage &request, const TimeoutPeriod timeout=defaultTimeout) const
Send a synchronous request and wait for the response.
ACTIV_SYSTEM_EXPORTED_API
StatusCode 		SendRequest (const Address &destinationAddress, const MessageType requestType, const void *pRequest, const size_t requestLength, HeapMessage &response, const TimeoutPeriod timeout=defaultTimeout) const
Send a synchronous request and wait for the response.
ACTIV_SYSTEM_EXPORTED_API
StatusCode 		SendRequest (const Address &destinationAddress, const MessageType requestType, const MessageBuilder &messageBuilder, HeapMessage &response, const TimeoutPeriod timeout=defaultTimeout) const
Send a synchronous request and wait for the response.
ACTIV_SYSTEM_EXPORTED_API void | SetHeap (IHeap *const pHeap)
Set the heap used for messaging.
virtual ACTIV_SYSTEM_EXPORTED_API | ~Port ()
Destructor.

Static Public Attributes

static
ACTIV_SYSTEM_EXPORTED_API
const std::string 		anonymousName
use this if you don't want to name a port
static const TimeoutPeriod | defaultTimeout = 30000
default timeout for assorted synchronous calls

Protected Member Functions

virtual
ACTIV_SYSTEM_EXPORTED_API
StatusCode 		OnMessage (HeapMessage &message)
Message callback.
virtual
ACTIV_SYSTEM_EXPORTED_API
StatusCode 		OnRequest (HeapMessage &request)
Request callback.
virtual
ACTIV_SYSTEM_EXPORTED_API
StatusCode 		OnResponse (HeapMessage &response)
Response callback.

Friends

class | ManagedEndPoint::Impl
class | ScopedAddress

Classes

class | Enabler
Helper class to enable & disable a Port. More...

Detailed Description

Port class.

Definition at line 30 of file Port.h.

Constructor & Destructor Documentation

ACTIV_SYSTEM_EXPORTED_API Activ::Port::Port | ( | ManagedEndPoint & | managedEndPoint,
 |  | const std::string & | name,
 |  | IHeap *const | pHeap
 | ) |  |

Constructor.

Attaches this object to a managed endpoint at the next available slot.

Parameters:
managedEndPoint | reference to a ManagedEndPoint object to which this port is to be attached.
name | name of the port, local to the endpoint.
pHeap | heap to use for messaging, or 0 for the system heap.
Exceptions:
Exception.

ACTIV_SYSTEM_EXPORTED_API Activ::Port::Port | ( | ManagedEndPoint & | managedEndPoint,
 |  | const std::string & | name,
 |  | const PortId | portId,
 |  | IHeap *const | pHeap
 | ) |  |

Constructor.

Attaches this object to a managed endpoint at the given slot.

Parameters:
managedEndPoint | reference to a ManagedEndPoint object to which this port is to be attached.
name | name of the port, local to the endpoint.
portId | the port id to attach to.
pHeap | heap to use for messaging, or 0 for the system heap.
Exceptions:
Exception.

virtual ACTIV_SYSTEM_EXPORTED_API Activ::Port::~Port ( ) [virtual]

Destructor.

The destructor will assert if Disable() has not been called for this port if Enable() had previously been called. See Disable() for more information.

Member Function Documentation

ACTIV_SYSTEM_EXPORTED_API void Activ::Port::Disable ( )

Disable a port.

Disabling a port stops it from receiving any more messages and detaches it from its ManagedEndPoint. This should be done before any destruction of a derived Port class starts.

If you have a derived Port class that will never be derived from, then it is safe to put Disable() in the destructor for that class.

Referenced by Activ::Port::Enabler::~Enabler().

ACTIV_SYSTEM_EXPORTED_API void Activ::Port::Enable ( )

Enable a port.

Enabling a port means that it can start to receive messages. This should be done only after the class derived from Port has been fully constructed, so that messages won't be received by the Port before construction is complete.

If you have a derived Port class that will never be derived from, then it is safe to put Enable() in the constructor for that class.

Note that since a Port cannot receive messages until Enable() has been called, no calls should be made before an Enable() that may cause messages to arrive that you cannot miss. For instance, tcp connections should not be initiated since a connect notification may be missed.

A Port can only be Enable()d once.

Referenced by Activ::Port::Enabler::Enabler().

ACTIV_SYSTEM_EXPORTED_API StatusCode Activ::Port::FindPort | ( | const std::string & | endPointName,
 |  | const std::string & | portName,
 |  | Address & | portAddress,
 |  | const TimeoutPeriod | timeout = defaultTimeout
 | ) |  |

Find an endpoint & port by name.

Parameters:
endPointName | the name of the endpoint.
portName | the name of the port.
portAddress | referece to an Address object to receive the address of the discovered port.
timeout | how long to wait for the endpoint, in ms.
Return values:
STATUS_CODE_SUCCESS.
STATUS_CODE_NOT_FOUND.
STATUS_CODE_MISMATCH | port found at the registered address that does not have the given name.
STATUS_CODE_TIMEOUT | port not found in timeout period.
STATUS_CODE_HEAP_EMPTY.

ACTIV_SYSTEM_EXPORTED_API StatusCode Activ::Port::ForwardMessage | ( | const Address & | destinationAddress,
 |  | HeapMessage & | message,
 |  | const MessageType | newType = INVALID_MESSAGE_TYPE |
 | ) |  |  | const

Forward a message to another address without changing the source address.

Parameters:
destinationAddress | the target address.
message | the message.
newType | the new message type, or default to keeping the message type unchanged.
Return values:
STATUS_CODE_SUCCESS.
STATUS_CODE_INVALID_ENDPOINT | the destination endpoint does not exist.
STATUS_CODE_DISABLED | the endpoint is not accepting messages.

const Address & Activ::Port::GetAddress ( ) const [inline]

Get the address of this port.

Returns:
The port's address.

Definition at line 748 of file Port.h.

IHeap * Activ::Port::GetHeap ( ) const [inline]

Get the heap used for messaging.

Returns:
An IHeap interface.

Definition at line 755 of file Port.h.

ACTIV_SYSTEM_EXPORTED_API ManagedEndPoint& Activ::Port::GetManagedEndPoint ( ) const

Get the managed endpoint this port is attached to.

Returns:
Reference to the port's managed endpoint.

ACTIV_SYSTEM_EXPORTED_API const std::string& Activ::Port::GetName ( ) const

Get the name of the port.

Returns:
Reference to the port's name.

virtual ACTIV_SYSTEM_EXPORTED_API StatusCode Activ::Port::OnMessage ( HeapMessage & message ) [protected, virtual]

Message callback.

If you override this method, please call the base class method for any unrecognized message types.

Parameters:
message the message.
Return values:
STATUS_CODE_SUCCESS | the message was recognized.
STATUS_CODE_UNRECOGNIZED | the message was not recognized.
STATUS_CODE_THREAD_EXIT | received a thread-die message.
...

Reimplemented in Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient, Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient, Activ::AgentApplication, Activ::Application, Activ::Component, Activ::ThinApplication, and Activ::UdpComponent.

virtual ACTIV_SYSTEM_EXPORTED_API StatusCode Activ::Port::OnRequest ( HeapMessage & request ) [protected, virtual]

Request callback.

If you override this method, please call the base class method for any unrecognized request types. Note the request is automatically replied to with the returned status value if the status is other than STATUS_CODE_SUCCESS or STATUS_CODE_THREAD_EXIT.

If an overriden OnRequest() throws an exception out of OnRequest(), the request is automatically replied to if request still has an attached message.

If the exception is of type StatusCodeException, the status of the response is the exception error code, otherwise STATUS_CODE_UNHANDLED_EXCEPTION.

If this is not required behaviour, for example if the request has been replied to before an exception is thrown, ensure the exception is not allowed out of the scope of the OnRequest() override, or that request no longer has a message attached at the point the exception is thrown.

Parameters:
request the request message.
Return values:
STATUS_CODE_SUCCESS | the message was recognized.
STATUS_CODE_UNRECOGNIZED | the message was not recognized.
STATUS_CODE_THREAD_EXIT | received a thread-die message.
...

Reimplemented in Activ::Component.

virtual ACTIV_SYSTEM_EXPORTED_API StatusCode Activ::Port::OnResponse ( HeapMessage & response ) [protected, virtual]

Response callback.

If you override this method, please call the base class method for any unrecognized request types.

Parameters:
response the response message.
Return values:
STATUS_CODE_SUCCESS | the message was recognized.
STATUS_CODE_UNRECOGNIZED | the message was not recognized.
STATUS_CODE_THREAD_EXIT | received a thread-die message.
...

Reimplemented in Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient, and Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient.

ACTIV_SYSTEM_EXPORTED_API StatusCode Activ::Port::PostEmptyResponse | ( | const Address & | destinationAddress,
 |  | const MessageType | requestType,
 |  | const RequestId & | requestId,
 |  | const StatusCode | responseStatus,
 |  | HeapMessage & | response |
 | ) |  |  | const

Post an empty response to a request. Use this call when the response message is a newly allocated HeapMessage and is not the original request.

If replying to a request and the contents of the response are unimportant, it is preferable to use PostEmptyResponse() as if the request was made remotely, there will be no serializing of message body over the network.

Parameters:
destinationAddress | the target address (the source address of the original request).
requestType | the request type of the original request.
requestId | the message identification (to match up the response).
responseStatus | the response status.
response | the response message. Data will be truncated.
Return values:
STATUS_CODE_SUCCESS.
STATUS_CODE_INVALID_ENDPOINT | the destination endpoint does not exist.
STATUS_CODE_DISABLED | the endpoint is not accepting messages.

ACTIV_SYSTEM_EXPORTED_API StatusCode Activ::Port::PostEmptyResponse | ( | const StatusCode | responseStatus,
 |  | HeapMessage & | response |
 | ) |  |  | const

Post an empty response to a request. The response will be sent to the source address of the request.

If replying to a request and the contents of the response are unimportant, it is preferable to use PostEmptyResponse() as if the request was made remotely, there will be no serializing of message body over the network.

Parameters:
responseStatus | the response status.
response | the original request message. Any data in the message is truncated.
Return values:
STATUS_CODE_SUCCESS.
STATUS_CODE_INVALID_ENDPOINT | the destination endpoint does not exist.
STATUS_CODE_DISABLED | the endpoint is not accepting messages.

ACTIV_SYSTEM_EXPORTED_API StatusCode Activ::Port::PostMessage | ( | const Address & | destinationAddress,
 |  | const MessageType | messageType,
 |  | HeapMessage & | message |
 | ) |  |  | const

Post a message.

Parameters:
destinationAddress | the target address.
messageType | the message type.
message | the message.
Return values:
STATUS_CODE_SUCCESS.
STATUS_CODE_INVALID_ENDPOINT | the destination endpoint does not exist.
STATUS_CODE_DISABLED | the endpoint is not accepting messages.

ACTIV_SYSTEM_EXPORTED_API StatusCode Activ::Port::PostMessage | ( | const Address & | destinationAddress,
 |  | const MessageType | messageType,
 |  | const void * | pMessage = 0,
 |  | const size_t | messageLength = 0 |
 | ) |  |  | const

Post a message.

Parameters:
destinationAddress | the target address.
messageType | the message type.
pMessage | the message buffer.
messageLength | the length of the message buffer.
Return values:
STATUS_CODE_SUCCESS.
STATUS_CODE_HEAP_EMPTY.
STATUS_CODE_INVALID_ENDPOINT | the destination endpoint does not exist.
STATUS_CODE_DISABLED | the endpoint is not accepting messages.

ACTIV_SYSTEM_EXPORTED_API StatusCode Activ::Port::PostMessage | ( | const Address & | destinationAddress,
 |  | const MessageType | messageType,
 |  | const MessageBuilder & | messageBuilder |
 | ) |  |  | const

Post a message.

Parameters:
destinationAddress | the target address.
messageType | the message type.
messageBuilder | reference to a MessageBuilder containing the message body to post.
Return values:
STATUS_CODE_SUCCESS.
STATUS_CODE_HEAP_EMPTY.
STATUS_CODE_INVALID_ENDPOINT | the destination endpoint does not exist.
STATUS_CODE_DISABLED | the endpoint is not accepting messages.

ACTIV_SYSTEM_EXPORTED_API StatusCode Activ::Port::PostRequest | ( | const Address & | destinationAddress,
 |  | const MessageType | requestType,
 |  | const RequestId & | requestId,
 |  | HeapMessage & | request |
 | ) |  |  | const

Post an asynchronous request.

Parameters:
destinationAddress | the target address.
requestType | the request type.
requestId | the message identification (to match up the response).
request | the HeapMessage containing the request body.
Return values:
STATUS_CODE_SUCCESS.
STATUS_CODE_INVALID_ENDPOINT | the destination endpoint does not exist.
STATUS_CODE_DISABLED | the endpoint is not accepting messages.

ACTIV_SYSTEM_EXPORTED_API StatusCode Activ::Port::PostRequest | ( | const Address & | destinationAddress,
 |  | const MessageType | requestType,
 |  | const RequestId & | requestId,
 |  | const void * | pRequest = 0,
 |  | const size_t | requestLength = 0 |
 | ) |  |  | const

Post an asynchronous request.

Parameters:
destinationAddress | the target address.
requestType | the request type.
requestId | the message identification (to match up the response).
pRequest | the request message buffer.
requestLength | the length of the request message buffer.
Return values:
STATUS_CODE_SUCCESS.
STATUS_CODE_HEAP_EMPTY.
STATUS_CODE_INVALID_ENDPOINT | the destination endpoint does not exist.
STATUS_CODE_DISABLED | the endpoint is not accepting messages.

ACTIV_SYSTEM_EXPORTED_API StatusCode Activ::Port::PostRequest | ( | const Address & | destinationAddress,
 |  | const MessageType | requestType,
 |  | const RequestId & | requestId,
 |  | const MessageBuilder & | messageBuilder |
 | ) |  |  | const

Post an asynchronous request.

Parameters:
destinationAddress | the target address.
requestType | the request type.
requestId | the message identification (to match up the response).
messageBuilder | reference to a MessageBuilder containing the message body to post.
Return values:
STATUS_CODE_SUCCESS.
STATUS_CODE_HEAP_EMPTY.
STATUS_CODE_INVALID_ENDPOINT | the destination endpoint does not exist.
STATUS_CODE_DISABLED | the endpoint is not accepting messages.

ACTIV_SYSTEM_EXPORTED_API StatusCode Activ::Port::PostResponse | ( | const StatusCode | responseStatus,
 |  | HeapMessage & | request |
 | ) |  |  | const

Post a response to a request where the original request message has been filled in with the response. All other members of the response message must be as received (request id, type, addresses).

Parameters:
responseStatus | the response status.
request | the original request message filled in with the response data.
Return values:
STATUS_CODE_SUCCESS.
STATUS_CODE_INVALID_ENDPOINT | the destination endpoint does not exist.
STATUS_CODE_DISABLED | the endpoint is not accepting messages.

ACTIV_SYSTEM_EXPORTED_API StatusCode Activ::Port::PostResponse | ( | const StatusCode | responseStatus,
 |  | HeapMessage & | request,
 |  | HeapMessage & | response |
 | ) |  |  | const

Post a response to a request where the request HeapMessage still has the original request id and message type of the request. The provided response HeapMessage contains the response body.

Parameters:
responseStatus | the response status.
request | the original request.
response | a second HeapMessage containing the response body.
Return values:
STATUS_CODE_SUCCESS.
STATUS_CODE_INVALID_ENDPOINT | the destination endpoint does not exist.
STATUS_CODE_DISABLED | the endpoint is not accepting messages.

ACTIV_SYSTEM_EXPORTED_API StatusCode Activ::Port::PostResponse | ( | const StatusCode | responseStatus,
 |  | HeapMessage & | request,
 |  | const void * | pResponse,
 |  | const size_t | responseLength |
 | ) |  |  | const

Post a response to a request where the request HeapMessage still has the original request id and message type of the request. The contents of the request HeapMessage are overriden with the provided buffer.

Parameters:
responseStatus | the response status.
request | the original request.
pResponse | the response message buffer.
responseLength | the length of the response message buffer.
Return values:
STATUS_CODE_SUCCESS.
STATUS_CODE_HEAP_EMPTY.
STATUS_CODE_INVALID_ENDPOINT | the destination endpoint does not exist.
STATUS_CODE_DISABLED | the endpoint is not accepting messages.

ACTIV_SYSTEM_EXPORTED_API StatusCode Activ::Port::PostResponse | ( | const StatusCode | responseStatus,
 |  | HeapMessage & | request,
 |  | const MessageBuilder & | messageBuilder |
 | ) |  |  | const

Post a response to a request where the request HeapMessage still has the original request id and message type of the request. The contents of the request HeapMessage are overriden with the provided MessageBuilder contents.

Parameters:
responseStatus | the response status.
request | the original request.
messageBuilder | reference to a MessageBuilder containing the message body to post.
Return values:
STATUS_CODE_SUCCESS.
STATUS_CODE_HEAP_EMPTY.
STATUS_CODE_INVALID_ENDPOINT | the destination endpoint does not exist.
STATUS_CODE_DISABLED | the endpoint is not accepting messages.

ACTIV_SYSTEM_EXPORTED_API StatusCode Activ::Port::PostResponse | ( | const Address & | destinationAddress,
 |  | const MessageType | requestType,
 |  | const RequestId & | requestId,
 |  | const StatusCode | responseStatus,
 |  | HeapMessage & | response |
 | ) |  |  | const

Post a response to a request. Use this call when the response message is a newly allocated HeapMessage and is not the original request.

Parameters:
destinationAddress | the target address (the source address of the request).
requestType | the request type.
requestId | the message identification (to match up the response).
responseStatus | the response status.
response | the response message.
Return values:
STATUS_CODE_SUCCESS.
STATUS_CODE_INVALID_ENDPOINT | the destination endpoint does not exist.
STATUS_CODE_DISABLED | the endpoint is not accepting messages.

ACTIV_SYSTEM_EXPORTED_API StatusCode Activ::Port::PostResponse | ( | const Address & | destinationAddress,
 |  | const MessageType | requestType,
 |  | const RequestId & | requestId,
 |  | const StatusCode | responseStatus,
 |  | const void * | pResponse = 0,
 |  | const size_t | responseLength = 0 |
 | ) |  |  | const

Post a response to a request.

Parameters:
destinationAddress | the target address (the source address of the request).
requestType | the request type.
requestId | the message identification (to match up the response).
responseStatus | the response status.
pResponse | the response message buffer.
responseLength | the length of the response message buffer.
Return values:
STATUS_CODE_SUCCESS.
STATUS_CODE_HEAP_EMPTY.
STATUS_CODE_INVALID_ENDPOINT | the destination endpoint does not exist.
STATUS_CODE_DISABLED | the endpoint is not accepting messages.

ACTIV_SYSTEM_EXPORTED_API StatusCode Activ::Port::PostResponse | ( | const Address & | destinationAddress,
 |  | const MessageType | requestType,
 |  | const RequestId & | requestId,
 |  | const StatusCode | responseStatus,
 |  | const MessageBuilder & | messageBuilder |
 | ) |  |  | const

Post a response to a request.

Parameters:
destinationAddress | the target address (the source address of the request).
requestType | the request type.
requestId | the message identification (to match up the response).
responseStatus | the response status.
messageBuilder | reference to a MessageBuilder containing the message body to post.
Return values:
STATUS_CODE_SUCCESS.
STATUS_CODE_HEAP_EMPTY.
STATUS_CODE_INVALID_ENDPOINT | the destination endpoint does not exist.
STATUS_CODE_DISABLED | the endpoint is not accepting messages.

ACTIV_SYSTEM_EXPORTED_API StatusCode Activ::Port::SendRequest | ( | const Address & | destinationAddress,
 |  | const MessageType | requestType,
 |  | SyncRequestId & | syncRequestId,
 |  | HeapMessage & | request |
 | ) |  |  | const

Send a synchronous request but do not wait for the response.

If this returns STATUS_CODE_SUCCESS, the response can be obtained by calling syncRequestId.GetResponse(). The actual return status of the request can then be obtained by GetStatusCode() on the message returned from syncRequestId.GetResponse().

Parameters:
destinationAddress | the target address.
requestType | the request type.
syncRequestId | reference to a SyncRequestId object that can be used later to wait (or poll) for the response.
request | the request message. If request is an empty HeapMessage, a request will be sent with no message body.
Return values:
STATUS_CODE_SUCCESS | the request was sent successfully.
STATUS_CODE_HEAP_EMPTY | if request was empty and no message could be allocated for the outgoing request.
STATUS_CODE_INVALID_ENDPOINT | the destination endpoint does not exist.
STATUS_CODE_DISABLED | the endpoint is not accepting messages.

ACTIV_SYSTEM_EXPORTED_API StatusCode Activ::Port::SendRequest | ( | const Address & | destinationAddress,
 |  | const MessageType | requestType,
 |  | SyncRequestId & | syncRequestId,
 |  | const void * | pRequest,
 |  | const size_t | requestLength |
 | ) |  |  | const

Send a synchronous request but do not wait for the response.

If this returns STATUS_CODE_SUCCESS, the response can be obtained by calling syncRequestId.GetResponse(). The actual return status of the request can then be obtained by GetStatusCode() on the message returned from syncRequestId.GetResponse().

Parameters:
destinationAddress | the target address.
requestType | the request type.
syncRequestId | reference to a SyncRequestId object that can be used later to wait (or poll) for the response.
pRequest | the request message buffer.
requestLength | the length of the request message buffer.
Return values:
STATUS_CODE_SUCCESS | the request was sent successfully.
STATUS_CODE_HEAP_EMPTY.
STATUS_CODE_INVALID_ENDPOINT | the destination endpoint does not exist.
STATUS_CODE_DISABLED | the endpoint is not accepting messages.

ACTIV_SYSTEM_EXPORTED_API StatusCode Activ::Port::SendRequest | ( | const Address & | destinationAddress,
 |  | const MessageType | requestType,
 |  | SyncRequestId & | syncRequestId,
 |  | const MessageBuilder & | messageBuilder |
 | ) |  |  | const

Send a synchronous request but do not wait for the response.

If this returns STATUS_CODE_SUCCESS, the response can be obtained by calling syncRequestId.GetResponse(). The actual return status of the request can then be obtained by GetStatusCode() on the message returned from syncRequestId.GetResponse().

Parameters:
destinationAddress | the target address.
requestType | the request type.
syncRequestId | reference to a SyncRequestId object that can be used later to wait (or poll) for the response.
messageBuilder | reference to a MessageBuilder containing the message body to post.
Return values:
STATUS_CODE_SUCCESS | the request was sent successfully.
STATUS_CODE_HEAP_EMPTY.
STATUS_CODE_INVALID_ENDPOINT | the destination endpoint does not exist.
STATUS_CODE_DISABLED | the endpoint is not accepting messages.

ACTIV_SYSTEM_EXPORTED_API StatusCode Activ::Port::SendRequest | ( | const Address & | destinationAddress,
 |  | const MessageType | requestType,
 |  | HeapMessage & | request,
 |  | const TimeoutPeriod | timeout = defaultTimeout |
 | ) |  |  | const

Send a synchronous request and wait for the response.

If this returns STATUS_CODE_SUCCESS, the value of request.GetStatusCode() will contain the actual return status of the request (the return value from SendRequest() just determines whether the actual message transmission was successful).

Parameters:
destinationAddress | the target address.
requestType | the request type.
request | the request message and container for the response. If request is an empty HeapMessage, a request will be sent with no message body.
timeout | in milliseconds.
Return values:
STATUS_CODE_SUCCESS | a response has been received.
STATUS_CODE_HEAP_EMPTY | if request was empty and no message could be allocated for the outgoing request.
STATUS_CODE_INVALID_ENDPOINT | the destination endpoint does not exist.
STATUS_CODE_DISABLED | the endpoint is not accepting messages.
STATUS_CODE_TIMEOUT | no response received in the timeout period.

ACTIV_SYSTEM_EXPORTED_API StatusCode Activ::Port::SendRequest | ( | const Address & | destinationAddress,
 |  | const MessageType | requestType,
 |  | const void * | pRequest,
 |  | const size_t | requestLength,
 |  | HeapMessage & | response,
 |  | const TimeoutPeriod | timeout = defaultTimeout |
 | ) |  |  | const

Send a synchronous request and wait for the response.

If this returns STATUS_CODE_SUCCESS, the value of response.GetStatusCode() will contain the actual return status of the request (the return value from SendRequest() just determines whether the actual message transmission was successful).

Parameters:
destinationAddress | the target address.
requestType | the request type.
pRequest | the request message buffer.
requestLength | the length of the request message buffer.
response | HeapMessage to receive the response.
timeout | in milliseconds.
Return values:
STATUS_CODE_SUCCESS | a response has been received.
STATUS_CODE_HEAP_EMPTY.
STATUS_CODE_INVALID_ENDPOINT | the destination endpoint does not exist.
STATUS_CODE_DISABLED | the endpoint is not accepting messages.
STATUS_CODE_TIMEOUT | no response received in the timeout period.

ACTIV_SYSTEM_EXPORTED_API StatusCode Activ::Port::SendRequest | ( | const Address & | destinationAddress,
 |  | const MessageType | requestType,
 |  | const MessageBuilder & | messageBuilder,
 |  | HeapMessage & | response,
 |  | const TimeoutPeriod | timeout = defaultTimeout |
 | ) |  |  | const

Send a synchronous request and wait for the response.

If this returns STATUS_CODE_SUCCESS, the value of response.GetStatusCode() will contain the actual return status of the request (the return value from SendRequest() just determines whether the actual message transmission was successful).

Parameters:
destinationAddress | the target address.
requestType | the request type.
messageBuilder | reference to a MessageBuilder containing the message body to post.
response | HeapMessage to receive the response.
timeout | in milliseconds.
Return values:
STATUS_CODE_SUCCESS | a response has been received.
STATUS_CODE_HEAP_EMPTY.
STATUS_CODE_INVALID_ENDPOINT | the destination endpoint does not exist.
STATUS_CODE_DISABLED | the endpoint is not accepting messages.
STATUS_CODE_TIMEOUT | no response received in the timeout period.

ACTIV_SYSTEM_EXPORTED_API void Activ::Port::SetHeap ( IHeap *const pHeap )

Set the heap used for messaging.

Parameters:
pHeap new heap to use for messaging.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivSystem/Port.h
Generated on Wed Oct 8 14:01:58 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Port::Enabler

Activ::Port::Enabler Class Reference

Helper class to enable & disable a Port. More...

#include <ActivMiddleware/ActivSystem/Port.h>

List of all members.

Public Member Functions

ACTIV_SYSTEM_INLINE_API | Enabler (Port &port)
Constructor. Will enable the port.
ACTIV_SYSTEM_INLINE_API | ~Enabler ()
Destructor. Will disable the port.

Detailed Description

Helper class to enable & disable a Port.

Definition at line 41 of file Port.h.

Constructor & Destructor Documentation

Activ::Port::Enabler::Enabler ( Port & port ) [inline]

Constructor. Will enable the port.

Parameters:
port reference to the port to enable.

Definition at line 763 of file Port.h.

References Activ::Port::Enable().

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivSystem/Port.h
Generated on Wed Oct 8 14:01:58 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::PostMessageHelper

Activ::PostMessageHelper Class Reference

Helper class to post messages. More...

#include <ActivMiddleware/ActivSystem/PostMessageHelper.h>

List of all members.

Public Member Functions

ACTIV_SYSTEM_EXPORTED_API void | Flush ()
Flush the queued messages to their target endpoints.
ACTIV_SYSTEM_EXPORTED_API void | PostMessage (HeapMessage &heapMessage)
Post a fully initialized message (type, src, dest addresses set as appropriate).
ACTIV_SYSTEM_EXPORTED_API void | PostMessage (const Port &port, const Address &destinationAddress, const MessageType messageType, HeapMessage &message)
Post a message, setting destination address and type.
ACTIV_SYSTEM_EXPORTED_API
StatusCode 		PostMessage (const Port &port, const Address &destinationAddress, const MessageType messageType, const void *pMessage=0, const size_t messageLength=0)
Post a message, setting destination address and type.
ACTIV_SYSTEM_EXPORTED_API
StatusCode 		PostMessage (const Port &port, const Address &destinationAddress, const MessageType messageType, const MessageBuilder &messageBuilder)
Post a message, setting destination address and type.
ACTIV_SYSTEM_EXPORTED_API | PostMessageHelper (ISystem *const pSystem, const size_t maximumNumberOfFailedTryFlushes=8)
Constructor.
ACTIV_SYSTEM_EXPORTED_API void | TryFlush ()
Try to flush the queued messages to their target endpoints.
ACTIV_SYSTEM_EXPORTED_API | ~PostMessageHelper ()
Destructor.

Detailed Description

Helper class to post messages.

This class provides a similar interface to the Port message posting functions. In addition, it will post multiple messages to a target endpoint in one go, saving multiple acquiring of locks, kernel transitions, etc.

The intended use is when the processing of a single message will result in the sending of multiple messages. For example:

MyPort::ProcessMyMessage(heapMessage) { for (...) { HeapMessage heapMessage2; heapMessage2.Clone(heapMessage); m_postMessageHelper.PostMessage(*this, m_targetAddress, MY_TYPE, heapMessage2); } m_postMessageHelper.Flush(); }

The class is not thread-safe and is only intended to be used from a single thread.

Definition at line 41 of file PostMessageHelper.h.

Constructor & Destructor Documentation

ACTIV_SYSTEM_EXPORTED_API Activ::PostMessageHelper::PostMessageHelper | ( | ISystem *const | pSystem,
 |  | const size_t | maximumNumberOfFailedTryFlushes = 8
 | ) |  |

Constructor.

Parameters:
pSystem
maximumNumberOfFailedTryFlushes how many TryFlush() calls should fail before TryFlush() calls Flush() implicitly.
Exceptions:
Exception.

Member Function Documentation

ACTIV_SYSTEM_EXPORTED_API void Activ::PostMessageHelper::PostMessage ( HeapMessage & heapMessage )

Post a fully initialized message (type, src, dest addresses set as appropriate).

Parameters:
heapMessage the message.

ACTIV_SYSTEM_EXPORTED_API void Activ::PostMessageHelper::PostMessage | ( | const Port & | port,
 |  | const Address & | destinationAddress,
 |  | const MessageType | messageType,
 |  | HeapMessage & | message
 | ) |  |

Post a message, setting destination address and type.

Parameters:
port | reference to the Port to post from.
destinationAddress | the target address.
messageType | the message type.
message | the message.

ACTIV_SYSTEM_EXPORTED_API StatusCode Activ::PostMessageHelper::PostMessage | ( | const Port & | port,
 |  | const Address & | destinationAddress,
 |  | const MessageType | messageType,
 |  | const void * | pMessage = 0,
 |  | const size_t | messageLength = 0
 | ) |  |

Post a message, setting destination address and type.

Parameters:
port | reference to the Port to post from.
destinationAddress | the target address.
messageType | the message type.
pMessage | the message buffer.
messageLength | the length of the message buffer.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_HEAP_EMPTY

ACTIV_SYSTEM_EXPORTED_API StatusCode Activ::PostMessageHelper::PostMessage | ( | const Port & | port,
 |  | const Address & | destinationAddress,
 |  | const MessageType | messageType,
 |  | const MessageBuilder & | messageBuilder
 | ) |  |

Post a message, setting destination address and type.

Parameters:
port | reference to the Port to post from.
destinationAddress | the target address.
messageType | the message type.
messageBuilder | reference to a MessageBuilder containing the message body to post.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_HEAP_EMPTY

ACTIV_SYSTEM_EXPORTED_API void Activ::PostMessageHelper::TryFlush ( )

Try to flush the queued messages to their target endpoints.

If unable to acquire the mutex protecting each target endpoint, messages are left queued in this object (the intention being that a later TryFlush() call will likely succeed).

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivSystem/PostMessageHelper.h
Generated on Wed Oct 8 14:01:58 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::PrivateEventFactory

Activ::PrivateEventFactory Class Reference

Private event factory class. More...

#include <ActivMiddleware/ActivBase/PrivateEventFactory.h>

Inheritance diagram for Activ::PrivateEventFactory:

Activ::Singleton< T >

List of all members.

Public Member Functions

ACTIV_BASE_EXPORTED_API IEvent * | Create (const IEvent::Flags flags=IEvent::FLAG_NONE, const bool initialState=false)
Create an event.

Static Public Member Functions

static ACTIV_BASE_EXPORTED_API
PrivateEventFactory & 		GetInstance ()
Get a reference to the singleton instance.

Friends

class | Singleton< PrivateEventFactory >

Detailed Description

Private event factory class.

A private event cannot be shared across process boundaries.

Definition at line 24 of file PrivateEventFactory.h.

Member Function Documentation

ACTIV_BASE_EXPORTED_API IEvent* Activ::PrivateEventFactory::Create | ( | const IEvent::Flags | flags = IEvent::FLAG_NONE,
 |  | const bool | initialState = false
 | ) |  |

Create an event.

Parameters:
flags | creation flags.
initialState | whether the event is initially set upon creation.
Returns:
pointer to an object providing an IEvent interface.

static ACTIV_BASE_EXPORTED_API PrivateEventFactory& Activ::PrivateEventFactory::GetInstance ( ) [static]

Get a reference to the singleton instance.

Returns:
Reference.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivBase/PrivateEventFactory.h
Generated on Wed Oct 8 14:01:58 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::PrivateMutexFactory

Activ::PrivateMutexFactory Class Reference

Private mutex factory class. More...

#include <ActivMiddleware/ActivBase/PrivateMutexFactory.h>

Inheritance diagram for Activ::PrivateMutexFactory:

Activ::Singleton< T >

List of all members.

Public Member Functions

ACTIV_BASE_EXPORTED_API IMutex * | Create (const bool isInitialOwner=false)
Create a mutex.

Static Public Member Functions

static ACTIV_BASE_EXPORTED_API
PrivateMutexFactory & 		GetInstance ()
Get a reference to the singleton instance.

Friends

class | Singleton< PrivateMutexFactory >

Detailed Description

Private mutex factory class.

A private mutex cannot be shared across process boundaries.

Mutexes will, by default, be recursive. This can be overriden by setting the ACTIV_NON_RECURSIVE_MUTEX environment variable (to any value). This is a first step to switching to non-recursive mutexes.

On Posix, the environment variable ACTIV_COUNT_MUTEX_CONTENTION can be used to hackily count mutex contentions. It should only be used for temporary profiling, as it will incur a small performance hit. Windows always counts mutex contentions.

Definition at line 31 of file PrivateMutexFactory.h.

Member Function Documentation

ACTIV_BASE_EXPORTED_API IMutex* Activ::PrivateMutexFactory::Create ( const bool isInitialOwner = false )

Create a mutex.

Parameters:
isInitialOwner whether the mutex is initially locked on creation.
Returns:
pointer to an object providing an IMutex interface.
Exceptions:
Exception.

static ACTIV_BASE_EXPORTED_API PrivateMutexFactory& Activ::PrivateMutexFactory::GetInstance ( ) [static]

Get a reference to the singleton instance.

Returns:
Reference.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivBase/PrivateMutexFactory.h
Generated on Wed Oct 8 14:01:58 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::PrivateSemaphoreFactory

Activ::PrivateSemaphoreFactory Class Reference

Private semaphore factory class. More...

#include <ActivMiddleware/ActivBase/PrivateSemaphoreFactory.h>

Inheritance diagram for Activ::PrivateSemaphoreFactory:

Activ::Singleton< T >

List of all members.

Public Member Functions

ACTIV_BASE_EXPORTED_API
ISemaphore * 		Create ()
Create a private semaphore.

Static Public Member Functions

static ACTIV_BASE_EXPORTED_API
PrivateSemaphoreFactory & 		GetInstance ()
Get a reference to the singleton instance.

Friends

class Singleton< PrivateSemaphoreFactory >

Detailed Description

Private semaphore factory class.

A private semaphore cannot be shared across process boundaries.

Definition at line 24 of file PrivateSemaphoreFactory.h.

Member Function Documentation

ACTIV_BASE_EXPORTED_API ISemaphore* Activ::PrivateSemaphoreFactory::Create ( )

Create a private semaphore.

Returns:
pointer to an object providing an ISemaphore interface.
Exceptions:
Exception

static ACTIV_BASE_EXPORTED_API PrivateSemaphoreFactory& Activ::PrivateSemaphoreFactory::GetInstance ( ) [static]

Get a reference to the singleton instance.

Returns:
Reference.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivBase/PrivateSemaphoreFactory.h
Generated on Wed Oct 8 14:01:58 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Process

Activ::Process Class Reference

Process class. More...

#include <ActivMiddleware/ActivBase/Process.h>

List of all members.

Public Types

typedef DWORD | Id
process id type for Windows
typedef std::vector< uint16_t > | ProcessorList
list of 0-based processor ids

Static Public Member Functions

static ACTIV_BASE_EXPORTED_API bool | DoesExist (const Id id)
Does a process exist?
static ACTIV_BASE_EXPORTED_API
StatusCode 		Exec (const std::string &command)
Replace the current process image with a new process image.
static ACTIV_BASE_EXPORTED_API Id | GetCurrentId ()
Get the current process id.
static ACTIV_BASE_EXPORTED_API
StatusCode 		Kill (const Id id)
Kill a process.
static ACTIV_BASE_EXPORTED_API
StatusCode 		Run (const std::string &command, std::string &output)
Run a command to completion and return any stdout output of the process.
static ACTIV_BASE_EXPORTED_API
StatusCode 		SetProcessorAffinity (const ProcessorList &processorList)
Set the processors this process can be scheduled on.
static ACTIV_BASE_EXPORTED_API
StatusCode 		Start (const std::string &command, Id &id)
Launch a process in the background.
static ACTIV_BASE_EXPORTED_API
StatusCode 		WaitForCompletion (const Id id, const TimeoutPeriod timeoutPeriod=ACTIV_WAIT_INFINITE)
Wait for a process to exit.

Detailed Description

Process class.

Provides OS-abstractions for common process-level operations.

Definition at line 25 of file Process.h.

Member Function Documentation

static ACTIV_BASE_EXPORTED_API bool Activ::Process::DoesExist ( const Id id ) [static]

Does a process exist?

Parameters:
id the process id to check for.
Returns:
true if the process exists.

static ACTIV_BASE_EXPORTED_API StatusCode Activ::Process::Exec ( const std::string & command ) [static]

Replace the current process image with a new process image.

Note on Windows, this call launches a new process and exits the calling process if the new process was started successfully.

Parameters:
command the command (and arguments) to run.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_FAILURE
STATUS_CODE_HEAP_EMPTY
STATUS_CODE_INVALID_FORMAT | command is incorrectly formatted
STATUS_CODE_NOT_FOUND | command not found

static ACTIV_BASE_EXPORTED_API Id Activ::Process::GetCurrentId ( ) [static]

Get the current process id.

Returns:
The current running process id.

static ACTIV_BASE_EXPORTED_API StatusCode Activ::Process::Kill ( const Id id ) [static]

Kill a process.

Parameters:
id the process id to kill.
Returns:
STATUS_CODE_SUCCESS or an error explaining why the process could not be killed.

static ACTIV_BASE_EXPORTED_API StatusCode Activ::Process::Run | ( | const std::string & | command,
 |  | std::string & | output |
 | ) |  |  | [static]

Run a command to completion and return any stdout output of the process.

Parameters:
command | the command (and arguments) to run.
output | any output from command is appended to output (output is not cleared).
Returns:
STATUS_CODE_SUCCESS or an error explaining why the command could not be run.
Return values:
...

static ACTIV_BASE_EXPORTED_API StatusCode Activ::Process::SetProcessorAffinity ( const ProcessorList & processorList ) [static]

Set the processors this process can be scheduled on.

Parameters:
processorList list of 0-indexed processors this process can run on. If the list is empty, the process will be set to have no affinity to particular processors.
Return values:
STATUS_CODE_SUCCESS
...

static ACTIV_BASE_EXPORTED_API StatusCode Activ::Process::Start | ( | const std::string & | command,
 |  | Id & | id |
 | ) |  |  | [static]

Launch a process in the background.

Parameters:
command | the command (and arguments) to run.
id | reference to an Id variable to receive the process id of the new process.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_FAILURE
STATUS_CODE_HEAP_EMPTY
STATUS_CODE_INVALID_FORMAT | command is incorrectly formatted
STATUS_CODE_NOT_FOUND | command not found

static ACTIV_BASE_EXPORTED_API StatusCode Activ::Process::WaitForCompletion | ( | const Id | id,
 |  | const TimeoutPeriod | timeoutPeriod = ACTIV_WAIT_INFINITE |
 | ) |  |  | [static]

Wait for a process to exit.

Parameters:
id | the process id to wait for.
timeoutPeriod | the timeout period to wait, in ms.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_TIMEOUT
STATUS_CODE_FAILURE

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivBase/Process.h
Generated on Wed Oct 8 14:01:58 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::PubSubServiceApi

Activ::PubSubServiceApi Class Reference

Api to the agent's pubsub service. More...

#include <ActivMiddleware/ActivFramework/PubSubServiceApi.h>

List of all members.

Public Types

typedef std::set< Address > | AddressSet
address set type
typedef std::vector< AddressSet > | AddressSetList
address set list. Index is AgentScope
typedef std::map< Subject,
AddressSetList > 		SubscriptionMap
subscription map

Static Public Member Functions

static ACTIV_FRAMEWORK_API
StatusCode 		GetSubscriptions (const Component &component, const Subject &subject, const bool shouldRecurseTree, SubscriptionMap &subscriptionMap, const TimeoutPeriod timeout=Port::defaultTimeout)
Get subscriptions.
static ACTIV_FRAMEWORK_API void | Publish (const Component &component, PostMessageHelper &postMessageHelper, const AgentScope agentScope, const Subject &subject, const MessageType type, HeapMessage &heapMessage)
Publish a message via a PostMessageHelper object.
static ACTIV_FRAMEWORK_API
StatusCode 		Publish (const Component &component, PostMessageHelper &postMessageHelper, const AgentScope agentScope, const Subject &subject, const MessageType type, const void *pData=0, const size_t dataLength=0)
Publish a message via a PostMessageHelper object.
static ACTIV_FRAMEWORK_API
StatusCode 		Publish (const Component &component, PostMessageHelper &postMessageHelper, const AgentScope agentScope, const Subject &subject, const MessageType type, const MessageBuilder &messageBuilder)
Publish a message via a PostMessageHelper object.
static ACTIV_FRAMEWORK_API
StatusCode 		Publish (const Component &component, const AgentScope agentScope, const Subject &subject, const MessageType type, HeapMessage &heapMessage)
Publish a message.
static ACTIV_FRAMEWORK_API
StatusCode 		Publish (const Component &component, const AgentScope agentScope, const Subject &subject, const MessageType type, const void *pData=0, const size_t dataLength=0)
Publish a message.
static ACTIV_FRAMEWORK_API
StatusCode 		Publish (const Component &component, const AgentScope agentScope, const Subject &subject, const MessageType type, const MessageBuilder &messageBuilder)
Publish a message.
static ACTIV_FRAMEWORK_API
StatusCode 		Subscribe (const Component &component, const AgentScope agentScope, const Subject &subject)
Subscribe to a subject.
static ACTIV_FRAMEWORK_API
StatusCode 		Unsubscribe (const Component &component, const AgentScope agentScope, const Subject &subject)
Unsubscribe from a subject.

Detailed Description

Api to the agent's pubsub service.

Definition at line 28 of file PubSubServiceApi.h.

Member Function Documentation

static ACTIV_FRAMEWORK_API StatusCode Activ::PubSubServiceApi::GetSubscriptions | ( | const Component & | component,
 |  | const Subject & | subject,
 |  | const bool | shouldRecurseTree,
 |  | SubscriptionMap & | subscriptionMap,
 |  | const TimeoutPeriod | timeout = Port::defaultTimeout |
 | ) |  |  | [static]

Get subscriptions.

Parameters:
component | the component requesting subscriptions.
subject | the subject to get the subscriptions for.
shouldRecurseTree | whether to get subscriptions for entire subject tree.
subscriptionMap | reference to the subscription map to receive subscriptions.
timeout | timeout in ms.
Return values:
STATUS_CODE_SUCCESS
...

static ACTIV_FRAMEWORK_API void Activ::PubSubServiceApi::Publish | ( | const Component & | component,
 |  | PostMessageHelper & | postMessageHelper,
 |  | const AgentScope | agentScope,
 |  | const Subject & | subject,
 |  | const MessageType | type,
 |  | HeapMessage & | heapMessage |
 | ) |  |  | [static]

Publish a message via a PostMessageHelper object.

Parameters:
component | the component wishing to publish.
postMessageHelper | reference to a PostMessageHelper. The published message will be queued here and not immediately sent to the PubSubService for distribution. postMessageHelper.Flush() will need to be called at some point in order to push any queued messages to the PubSubService.
agentScope | AGENT_SCOPE_LOCAL only publish locally within this agent space, AGENT_SCOPE_REMOTE only publish onto the network, AGENT_SCOPE_GLOBAL publish locally & remotely.
subject | subject of published message.
type | type of published message.
heapMessage | HeapMessage containing message body to publish.

static ACTIV_FRAMEWORK_API StatusCode Activ::PubSubServiceApi::Publish | ( | const Component & | component,
 |  | PostMessageHelper & | postMessageHelper,
 |  | const AgentScope | agentScope,
 |  | const Subject & | subject,
 |  | const MessageType | type,
 |  | const void * | pData = 0,
 |  | const size_t | dataLength = 0 |
 | ) |  |  | [static]

Publish a message via a PostMessageHelper object.

Parameters:
component | the component wishing to publish.
postMessageHelper | reference to a PostMessageHelper. The published message will be queued here and not immediately sent to the PubSubService for distribution. postMessageHelper.Flush() will need to be called at some point in order to push any queued messages to the PubSubService.
agentScope | AGENT_SCOPE_LOCAL only publish locally within this agent space, AGENT_SCOPE_REMOTE only publish onto the network, AGENT_SCOPE_GLOBAL publish locally & remotely.
subject | subject of published message.
type | type of published message.
pData | pointer to message body.
dataLength | length of message body.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_HEAP_EMTPY

static ACTIV_FRAMEWORK_API StatusCode Activ::PubSubServiceApi::Publish | ( | const Component & | component,
 |  | PostMessageHelper & | postMessageHelper,
 |  | const AgentScope | agentScope,
 |  | const Subject & | subject,
 |  | const MessageType | type,
 |  | const MessageBuilder & | messageBuilder |
 | ) |  |  | [static]

Publish a message via a PostMessageHelper object.

Parameters:
component | the component wishing to publish.
postMessageHelper | reference to a PostMessageHelper. The published message will be queued here and not immediately sent to the PubSubService for distribution. postMessageHelper.Flush() will need to be called at some point in order to push any queued messages to the PubSubService.
agentScope | AGENT_SCOPE_LOCAL only publish locally within this agent space, AGENT_SCOPE_REMOTE only publish onto the network, AGENT_SCOPE_GLOBAL publish locally & remotely.
subject | subject of published message.
type | type of published message.
messageBuilder | reference to a MessageBuilder containing the message body to publish.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_HEAP_EMTPY

static ACTIV_FRAMEWORK_API StatusCode Activ::PubSubServiceApi::Publish | ( | const Component & | component,
 |  | const AgentScope | agentScope,
 |  | const Subject & | subject,
 |  | const MessageType | type,
 |  | HeapMessage & | heapMessage |
 | ) |  |  | [static]

Publish a message.

Parameters:
component | the component wishing to publish.
agentScope | AGENT_SCOPE_LOCAL only publish locally within this agent space, AGENT_SCOPE_REMOTE only publish onto the network, AGENT_SCOPE_GLOBAL publish locally & remotely.
subject | subject of published message.
type | type of published message.
heapMessage | HeapMessage containing message body to publish.
Return values:
STATUS_CODE_SUCCESS. heapMessage will no longer have a message attached.
...

static ACTIV_FRAMEWORK_API StatusCode Activ::PubSubServiceApi::Publish | ( | const Component & | component,
 |  | const AgentScope | agentScope,
 |  | const Subject & | subject,
 |  | const MessageType | type,
 |  | const void * | pData = 0,
 |  | const size_t | dataLength = 0 |
 | ) |  |  | [static]

Publish a message.

Parameters:
component | the component wishing to publish.
agentScope | AGENT_SCOPE_LOCAL only publish locally within this agent space, AGENT_SCOPE_REMOTE only publish onto the network, AGENT_SCOPE_GLOBAL publish locally & remotely.
subject | subject of published message.
type | type of published message.
pData | pointer to message body.
dataLength | length of message body.
Return values:
STATUS_CODE_SUCCESS
...

static ACTIV_FRAMEWORK_API StatusCode Activ::PubSubServiceApi::Publish | ( | const Component & | component,
 |  | const AgentScope | agentScope,
 |  | const Subject & | subject,
 |  | const MessageType | type,
 |  | const MessageBuilder & | messageBuilder |
 | ) |  |  | [static]

Publish a message.

Parameters:
component | the component wishing to publish.
agentScope | AGENT_SCOPE_LOCAL only publish locally within this agent space, AGENT_SCOPE_REMOTE only publish onto the network, AGENT_SCOPE_GLOBAL publish locally & remotely.
subject | subject of published message.
type | type of published message.
messageBuilder | reference to a MessageBuilder containing the message body to publish.
Return values:
STATUS_CODE_SUCCESS
...

static ACTIV_FRAMEWORK_API StatusCode Activ::PubSubServiceApi::Subscribe | ( | const Component & | component,
 |  | const AgentScope | agentScope,
 |  | const Subject & | subject |
 | ) |  |  | [static]

Subscribe to a subject.

Note subscriptions from a component are not cumulative at the same scope level. However, subscribing to the same subject at more than one scope requires unsubscribing at each scope.

Parameters:
component | the component wishing to subscribe.
agentScope | AGENT_SCOPE_LOCAL only receive messages published within this agent space, AGENT_SCOPE_GLOBAL receive both local and messages published onto the network, AGENT_SCOPE_REMOTE only receive messages published remotely.
subject | subject to subscribe to.
Return values:
STATUS_CODE_SUCCESS
...

static ACTIV_FRAMEWORK_API StatusCode Activ::PubSubServiceApi::Unsubscribe | ( | const Component & | component,
 |  | const AgentScope | agentScope,
 |  | const Subject & | subject |
 | ) |  |  | [static]

Unsubscribe from a subject.

Parameters:
component | the component wishing to unsubscribe.
agentScope | the scope from which to unsubscribe.
subject | the subject to unsubscribe from.
Return values:
STATUS_CODE_SUCCESS
...

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivFramework/PubSubServiceApi.h
Generated on Wed Oct 8 14:01:58 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Rational

Activ::Rational Class Reference

Rational class. More...

#include <ActivMiddleware/ActivFieldTypes/Rational.h>

Inheritance diagram for Activ::Rational:

Activ::IFieldType

List of all members.

Public Types

enum Denominator {
DENOMINATOR_WHOLE, DENOMINATOR_1DP, DENOMINATOR_2DP, DENOMINATOR_3DP,
DENOMINATOR_4DP, DENOMINATOR_5DP, DENOMINATOR_6DP, DENOMINATOR_7DP,
DENOMINATOR_8DP, DENOMINATOR_9DP, DENOMINATOR_X1E1, DENOMINATOR_X1E2,
DENOMINATOR_X1E3, DENOMINATOR_X1E4, DENOMINATOR_X1E5, DENOMINATOR_X1E6,
DENOMINATOR_X1E7, DENOMINATOR_X1E8, DENOMINATOR_X1E9, DENOMINATOR_HALF,
DENOMINATOR_QUARTER, DENOMINATOR_8TH, DENOMINATOR_16TH, DENOMINATOR_32ND,
DENOMINATOR_64TH, DENOMINATOR_128TH, DENOMINATOR_256TH, DENOMINATOR_512TH,
DENOMINATOR_CABINET, DENOMINATOR_UNDEFINED, NUMBER_OF_DENOMINATORS
}
Denominator enumeration.

Public Member Functions

ACTIV_FIELD_TYPES_API StatusCode | Add (const Rational &rhs, bool isExactCalculation=true)
Add.
virtual void | Clear ()
Clear the object.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		Compare (const void *const pRhsSerializedBody, const size_t rhsSerializedBodyLength, int &result) const
Compare.
ACTIV_FIELD_TYPES_API StatusCode | Compare (const Rational &rhs, int &result) const
Compare.
StatusCode | Compress ()
Compress the numerator and denominator without losing precision.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		Convert (const IFieldType *const pIFieldType)
Convert another IFieldType object to this type.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		Deserialize (MessageValidator &messageValidator, const size_t maxSerializedBodyLength)
Deserialize the object from the supplied message validator.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		DeserializeBody (const void *const pSerializedBody, const size_t serializedBodyLength)
Deserialize the object's body from the supplied data buffer.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		DeserializeLengthAndBody (MessageValidator &messageValidator, const size_t maxSerializedBodyLength=MAX_SERIALIZED_BODY_LENGTH_UNDEFINED)
Deserialize the object's length and body from the supplied message validator.
ACTIV_FIELD_TYPES_API StatusCode | Divide (const Rational &rhs, bool isExactCalculation=true)
Divide.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		FromString (MessageValidator &messageValidator)
Convert the object from a string.
double | Get () const
Get double.
StatusCode | Get (int64_t &numerator, Denominator &denominator) const
Get the numerator and denominator.
Denominator | GetDenominator () const
Get the denominator portion of the value stored.
StatusCode | GetDouble (double &value) const
Get double.
virtual ACTIV_FIELD_TYPES_API
std::string 		GetFromStringFormat () const
Get a usage string for the format supported by FromString().
StatusCode | GetNumerator (int64_t &numerator, const Denominator denominator) const
Get the numerator (in the specificied denominator).
int64_t | GetNumerator () const
Get the numerator portion of the value stored.
ACTIV_FIELD_TYPES_API StatusCode | GetNumeratorAndDivisor (int64_t &numerator, uint64_t &divisor) const
Get the numerator and divisor.
virtual size_t | GetSerializedBodyLength () const
Get the serialized length of the object's body.
virtual size_t | GetSerializedLength () const
Get the serialized length of the object.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		IsDifferent (const void *const pRhsSerializedBody, const size_t rhsSerializedBodyLength, bool &isDifferent) const
Is different.
ACTIV_FIELD_TYPES_API StatusCode | Multiply (const Rational &rhs, bool isExactCalculation=true)
Multiply.
Rational & | operator *= (const Rational &rhs)
Multiplication assignment operator.
bool | operator!= (const Rational &rhs) const
Inequality operator.
Rational & | operator+= (const Rational &rhs)
Addition assignment operator.
Rational & | operator-= (const Rational &rhs)
Subtraction assignment operator.
Rational & | operator/= (const Rational &rhs)
Division assignment operator.
bool | operator< (const Rational &rhs) const
Less than operator.
bool | operator<= (const Rational &rhs) const
Less than or equal to operator.
bool | operator== (const Rational &rhs) const
Equality operator.
bool | operator> (const Rational &rhs) const
Greater than operator.
bool | operator>= (const Rational &rhs) const
Greater than or equal to operator.
Rational (const int64_t numerator, const Denominator denominator=DENOMINATOR_WHOLE, bool shouldCompress=false)
Constructor.
Rational ()
Default constructor.
virtual void | Reset ()
Reset the object.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		Serialize (MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength) const
Serialize the object into the supplied message builder.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		SerializeBody (void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength) const
Serialize the object's body into the supplied data buffer.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		SerializeLengthAndBody (MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength=MAX_SERIALIZED_BODY_LENGTH_UNDEFINED) const
Serialize the object's length and body into the supplied message builder.
StatusCode | Set (const int64_t numerator, const Denominator denominator, bool shouldCompress=false)
Set a new value using numerator and denominator.
StatusCode | SetDenominator (const Denominator denominator)
Set the denominator portion of the value stored.
ACTIV_FIELD_TYPES_API StatusCode | Subtract (const Rational &rhs, bool isExactCalculation=true)
Subtract.
ACTIV_FIELD_TYPES_API std::string | ToString (const Rational::Denominator denominator) const
Convert the object to a string.
virtual ACTIV_FIELD_TYPES_API
std::string 		ToString () const
Convert the object to a string.
virtual | ~Rational ()
Destructor.

Static Public Member Functions

static ACTIV_FIELD_TYPES_API
StatusCode 		Compare (const void *const pLhsSerializedBody, const size_t lhsSerializedBodyLength, const void *const pRhsSerializedBody, const size_t rhsSerializedBodyLength, int &result)
Compare two objects serialized bodies.
static ACTIV_FIELD_TYPES_API
StatusCode 		GetDenominatorByBinaryPower (const size_t binaryPower, Denominator &denominator)
Get the denominator by binary power.
static ACTIV_FIELD_TYPES_API
StatusCode 		GetDenominatorByDecimalPlaces (const size_t nDecimalPlaces, Denominator &denominator)
Get the denominator by decimal places.
static ACTIV_FIELD_TYPES_API
StatusCode 		GetDenominatorByDecimalPower (const size_t decimalPower, Denominator &denominator)
Get the denominator by decimal power.
static ACTIV_FIELD_TYPES_API
StatusCode 		GetDenominatorByDivisor (const uint64_t divisor, Denominator &denominator)
Get the denominator by divisor.
static ACTIV_FIELD_TYPES_API
StatusCode 		GetDenominatorByMultiplier (const uint64_t multiplier, Denominator &denominator)
Get the denominator by multiplier.
static ACTIV_FIELD_TYPES_API
StatusCode 		GetDenominatorByMultiplierPower (const size_t multiplierPower, Denominator &denominator)
Get the denominator by multiplier power.
static StatusCode | GetDenominatorType (const Denominator denominator, const DenominatorType *&pDenominatorType)
Get the denominator type.
static ACTIV_FIELD_TYPES_API
Denominator 		GetLowestCommonDenominator (const Denominator firstDenominator, const Denominator secondDenominator)
Get the lowest common denominator.
static size_t | GetMaxSerializedBodyLength (const size_t size)
Get the maximum serialized length of the object's body.
static size_t | GetMaxSerializedLength (const size_t size)
Get the maximum serialized length of the object.
static bool | IsValidDenominator (Denominator denominator)
Check whether a denominator is valid.
static bool | IsValidNumerator (int64_t numerator)
Check whether a numerator is valid.
static bool | IsValidSerializedBodyLength (const size_t serializedBodyLength)
Is valid serialized body length.
static ACTIV_FIELD_TYPES_API
StatusCode 		ValidateSerializedLengthAndBody (MessageValidator &messageValidator, size_t &serializedBodyOffset, size_t &serializedBodyLength)
Validate the serialized length and body.

Static Public Attributes

static const FieldType | FIELD_TYPE = FIELD_TYPE_RATIONAL
The field type.
static const int64_t | MAX_NUMERATOR = INT64_MAX
The maximum value for the numerator.
static const int64_t | MIN_NUMERATOR = -INT64_MAX
The minimum value for the numerator.

Friends

class | TRational

Classes

class | DenominatorType
Denominator type. More...
class | SerializedHeaderDefinitions
Serialized header definitions.

Detailed Description

Rational class.

Definition at line 78 of file Rational.h.

Constructor & Destructor Documentation

Activ::Rational::Rational | ( | const int64_t | numerator,
 |  | const Denominator | denominator = DENOMINATOR_WHOLE,
 |  | bool | shouldCompress = false |
 | ) |  |  | [inline]

Constructor.

Parameters:
numerator | the numerator portion of the value.
denominator | the denominator portion of the value.
shouldCompress | indicates whether the numerator and denominator should be compressed.
Exceptions:
StatusCodeException

Definition at line 1016 of file Rational.h.

References ACTIV_THROW_RESULT_IF, and Set().

Activ::Rational::~Rational ( ) [inline, virtual]

Destructor.

Exceptions:
StatusCodeException

Definition at line 1024 of file Rational.h.

Member Function Documentation

ACTIV_FIELD_TYPES_API StatusCode Activ::Rational::Add | ( | const Rational & | rhs,
 |  | bool | isExactCalculation = true
 | ) |  |

Add.

Parameters:
rhs | the value to add to this object.
isExactCalculation | whether loss of precision is allowed.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED
STATUS_CODE_OUT_OF_RANGE

Referenced by operator+=().

static ACTIV_FIELD_TYPES_API StatusCode Activ::Rational::Compare | ( | const void *const | pLhsSerializedBody,
 |  | const size_t | lhsSerializedBodyLength,
 |  | const void *const | pRhsSerializedBody,
 |  | const size_t | rhsSerializedBodyLength,
 |  | int & | result |
 | ) |  |  | [static]

Compare two objects serialized bodies.

Parameters:
pLhsSerializedBody | the buffer containing the lhs serialized version of the object's body in.
lhsSerializedBodyLength | the lhs serialized body length.
pRhsSerializedBody | the buffer containing the rhs serialized version of the object's body in.
rhsSerializedBodyLength | the rhs serialized body length.
result | the result of the comparison.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::Rational::Compare | ( | const void *const | pRhsSerializedBody,
 |  | const size_t | rhsSerializedBodyLength,
 |  | int & | result |
 | ) |  |  | const [virtual]

Compare.

Parameters:
pRhsSerializedBody | the buffer containing the rhs serialized version of the object's body in.
rhsSerializedBodyLength | the rhs serialized body length.
result | the result of the comparison.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

ACTIV_FIELD_TYPES_API StatusCode Activ::Rational::Compare | ( | const Rational & | rhs,
 |  | int & | result |
 | ) |  |  | const

Compare.

Parameters:
rhs | the object to compare with.
result | the result of the comparison.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_OUT_OF_RANGE

Referenced by operator<(), operator==(), operator>(), Activ::TRational::SetTick(), Activ::TRational::SetTickAndTrendOnPrevious(), Activ::TRational::SetTrendOnDay(), and Activ::TRational::SetTrendOnPrevious().

StatusCode Activ::Rational::Compress ( ) [inline]

Compress the numerator and denominator without losing precision.

Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED

Definition at line 1226 of file Rational.h.

References Activ::IFieldType::IsInitialized().

Referenced by Activ::TRational::Compress().

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::Rational::Convert ( const IFieldType *const pIFieldType ) [virtual]

Convert another IFieldType object to this type.

Parameters:
pIFieldType the value to assign from.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_MISMATCH
...

Implements Activ::IFieldType.

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::Rational::Deserialize | ( | MessageValidator & | messageValidator,
 |  | const size_t | maxSerializedBodyLength |
 | ) |  |  | [virtual]

Deserialize the object from the supplied message validator.

Parameters:
messageValidator | the message validator from which the object will be extracted.
maxSerializedBodyLength | the maximum serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::Rational::DeserializeBody | ( | const void *const | pSerializedBody,
 |  | const size_t | serializedBodyLength |
 | ) |  |  | [virtual]

Deserialize the object's body from the supplied data buffer.

Parameters:
pSerializedBody | the buffer from which the object's body will be extracted.
serializedBodyLength | the serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::Rational::DeserializeLengthAndBody | ( | MessageValidator & | messageValidator,
 |  | const size_t | maxSerializedBodyLength = MAX_SERIALIZED_BODY_LENGTH_UNDEFINED |
 | ) |  |  | [virtual]

Deserialize the object's length and body from the supplied message validator.

Parameters:
messageValidator | the message validator from which the object will be extracted.
maxSerializedBodyLength | the maximum serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

ACTIV_FIELD_TYPES_API StatusCode Activ::Rational::Divide | ( | const Rational & | rhs,
 |  | bool | isExactCalculation = true
 | ) |  |

Divide.

Parameters:
rhs | the value to divide this object by.
isExactCalculation | whether loss of precision is allowed.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED
STATUS_CODE_OUT_OF_RANGE

Referenced by operator/=().

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::Rational::FromString ( MessageValidator & messageValidator ) [virtual]

Convert the object from a string.

Parameters:
messageValidator the message validator.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

double Activ::Rational::Get ( ) const [inline]

Get double.

Returns:
the value.
Exceptions:
StatusCodeException

Definition at line 1148 of file Rational.h.

References ACTIV_THROW_RESULT_IF, and GetDouble().

StatusCode Activ::Rational::Get | ( | int64_t & | numerator,
 |  | Denominator & | denominator |
 | ) |  |  | const [inline]

Get the numerator and denominator.

Parameters:
numerator | the numerator portion of the value.
denominator | the denominator portion of the value.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED

Definition at line 1135 of file Rational.h.

References Activ::IFieldType::IsInitialized().

Referenced by Activ::TRational::Get(), and Activ::TRational::GetNumeratorAndDenominator().

Rational::Denominator Activ::Rational::GetDenominator ( ) const [inline]

Get the denominator portion of the value stored.

Returns:
the value of the denominator.
Exceptions:
StatusCodeException

Definition at line 1203 of file Rational.h.

References ACTIV_THROW, and Activ::IFieldType::IsInitialized().

Referenced by Activ::TRational::GetDenominator(), Activ::ContentPlatform::ContentGatewayApi::Tick::GetSize(), Activ::ContentPlatform::ContentGatewayApi::OptionBar::GetStrikePrice(), Activ::ContentPlatform::ContentGatewayApi::IntradayBar::GetTotalVolume(), Activ::ContentPlatform::ContentGatewayApi::HistoryBar::GetTotalVolume(), Activ::ContentPlatform::ContentGatewayApi::OptionBar::SetAskPrice(), Activ::ContentPlatform::ContentGatewayApi::OptionBar::SetBidPrice(), and Activ::ContentPlatform::ContentGatewayApi::OptionBar::SetUnderlyingPrice().

static ACTIV_FIELD_TYPES_API StatusCode Activ::Rational::GetDenominatorByBinaryPower | ( | const size_t | binaryPower,
 |  | Denominator & | denominator |
 | ) |  |  | [static]

Get the denominator by binary power.

Parameters:
binaryPower | the binary power (divisor = 2^binaryPower).
denominator | the denominator.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER

static ACTIV_FIELD_TYPES_API StatusCode Activ::Rational::GetDenominatorByDecimalPlaces | ( | const size_t | nDecimalPlaces,
 |  | Denominator & | denominator |
 | ) |  |  | [static]

Get the denominator by decimal places.

Parameters:
nDecimalPlaces | the number of decimal places.
denominator | the denominator.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER

static ACTIV_FIELD_TYPES_API StatusCode Activ::Rational::GetDenominatorByDecimalPower | ( | const size_t | decimalPower,
 |  | Denominator & | denominator |
 | ) |  |  | [static]

Get the denominator by decimal power.

Parameters:
decimalPower | the decimal power (divisor = 10^decimalPower).
denominator | the denominator.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER

static ACTIV_FIELD_TYPES_API StatusCode Activ::Rational::GetDenominatorByDivisor | ( | const uint64_t | divisor,
 |  | Denominator & | denominator |
 | ) |  |  | [static]

Get the denominator by divisor.

Parameters:
divisor | the divisor.
denominator | the denominator.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

static ACTIV_FIELD_TYPES_API StatusCode Activ::Rational::GetDenominatorByMultiplier | ( | const uint64_t | multiplier,
 |  | Denominator & | denominator |
 | ) |  |  | [static]

Get the denominator by multiplier.

Parameters:
multiplier | the multiplier.
denominator | the denominator.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

static ACTIV_FIELD_TYPES_API StatusCode Activ::Rational::GetDenominatorByMultiplierPower | ( | const size_t | multiplierPower,
 |  | Denominator & | denominator |
 | ) |  |  | [static]

Get the denominator by multiplier power.

Parameters:
multiplierPower | the multiplier power (multiplier = 10^multiplierPower).
denominator | the denominator.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER

StatusCode Activ::Rational::GetDenominatorType | ( | const Denominator | denominator,
 |  | const DenominatorType *& | pDenominatorType |
 | ) |  |  | [inline, static]

Get the denominator type.

Parameters:
denominator | the denominator.
pDenominatorType | a pointer to the denominator type.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER

Definition at line 1280 of file Rational.h.

References IsValidDenominator().

Referenced by Activ::ContentPlatform::ContentGatewayApi::OptionBar::GetAskPrice(), Activ::ContentPlatform::ContentGatewayApi::OptionBar::GetBidPrice(), Activ::ContentPlatform::ContentGatewayApi::OptionBar::GetStrikePrice(), and Activ::ContentPlatform::ContentGatewayApi::OptionBar::GetUnderlyingPrice().

StatusCode Activ::Rational::GetDouble ( double & value ) const [inline]

Get double.

Parameters:
value the value.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED
STATUS_CODE_OUT_OF_RANGE

Definition at line 1213 of file Rational.h.

References ACTIV_RETURN_RESULT_IF, and GetNumeratorAndDivisor().

Referenced by Get(), Activ::ContentPlatform::ContentGatewayApi::IntradayBar::GetClosePrice(), Activ::ContentPlatform::ContentGatewayApi::HistoryBar::GetClosePrice(), Activ::ContentPlatform::ContentGatewayApi::IntradayBar::GetHighPrice(), Activ::ContentPlatform::ContentGatewayApi::HistoryBar::GetHighPrice(), Activ::ContentPlatform::ContentGatewayApi::IntradayBar::GetLowPrice(), Activ::ContentPlatform::ContentGatewayApi::HistoryBar::GetLowPrice(), Activ::ContentPlatform::ContentGatewayApi::IntradayBar::GetOpenPrice(), Activ::ContentPlatform::ContentGatewayApi::HistoryBar::GetOpenPrice(), Activ::ContentPlatform::ContentGatewayApi::Tick::GetPrice(), Activ::ContentPlatform::ContentGatewayApi::Tick::GetSize(), Activ::ContentPlatform::ContentGatewayApi::IntradayBar::GetTotalPrice(), Activ::ContentPlatform::ContentGatewayApi::HistoryBar::GetTotalPrice(), Activ::ContentPlatform::ContentGatewayApi::IntradayBar::GetTotalValue(), Activ::ContentPlatform::ContentGatewayApi::HistoryBar::GetTotalValue(), Activ::ContentPlatform::ContentGatewayApi::IntradayBar::GetTotalVolume(), and Activ::ContentPlatform::ContentGatewayApi::HistoryBar::GetTotalVolume().

virtual ACTIV_FIELD_TYPES_API std::string Activ::Rational::GetFromStringFormat ( ) const [virtual]

Get a usage string for the format supported by FromString().

Returns:
String, may be empty.

Implements Activ::IFieldType.

static ACTIV_FIELD_TYPES_API Denominator Activ::Rational::GetLowestCommonDenominator | ( | const Denominator | firstDenominator,
 |  | const Denominator | secondDenominator |
 | ) |  |  | [static]

Get the lowest common denominator.

Parameters:
firstDenominator | the first denominator.
secondDenominator | the second denominator.
Returns:
the lowest common denominator.

size_t Activ::Rational::GetMaxSerializedBodyLength ( const size_t size ) [inline, static]

Get the maximum serialized length of the object's body.

Parameters:
size the size of the numerator.
Returns:
the maximum serialized length of the object's body.

Definition at line 1273 of file Rational.h.

Referenced by Activ::TRational::GetMaxSerializedBodyLength(), GetMaxSerializedLength(), GetSerializedBodyLength(), and IsValidSerializedBodyLength().

size_t Activ::Rational::GetMaxSerializedLength ( const size_t size ) [inline, static]

Get the maximum serialized length of the object.

Parameters:
size the size of the numerator.
Returns:
the maximum serialized length of the object.

Definition at line 1266 of file Rational.h.

References GetMaxSerializedBodyLength().

Referenced by Activ::TRational::GetMaxSerializedLength().

StatusCode Activ::Rational::GetNumerator | ( | int64_t & | numerator,
 |  | const Denominator | denominator |
 | ) |  |  | const [inline]

Get the numerator (in the specificied denominator).

Parameters:
numerator | the numerator.
denominator | the denominator.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED
STATUS_CODE_OUT_OF_RANGE

Definition at line 1169 of file Rational.h.

References ACTIV_RETURN_RESULT_IF, and Activ::IFieldType::IsInitialized().

int64_t Activ::Rational::GetNumerator ( ) const [inline]

Get the numerator portion of the value stored.

Returns:
the value of the numerator.
Exceptions:
StatusCodeException

Definition at line 1159 of file Rational.h.

References ACTIV_THROW, and Activ::IFieldType::IsInitialized().

Referenced by Activ::TRational::GetNumerator(), Activ::ContentPlatform::ContentGatewayApi::Tick::GetSize(), Activ::ContentPlatform::ContentGatewayApi::OptionBar::GetStrikePrice(), Activ::ContentPlatform::ContentGatewayApi::IntradayBar::GetTotalVolume(), Activ::ContentPlatform::ContentGatewayApi::HistoryBar::GetTotalVolume(), Activ::ContentPlatform::ContentGatewayApi::OptionBar::SetAskPrice(), Activ::ContentPlatform::ContentGatewayApi::OptionBar::SetBidPrice(), and Activ::ContentPlatform::ContentGatewayApi::OptionBar::SetUnderlyingPrice().

ACTIV_FIELD_TYPES_API StatusCode Activ::Rational::GetNumeratorAndDivisor | ( | int64_t & | numerator,
 |  | uint64_t & | divisor |
 | ) |  |  | const

Get the numerator and divisor.

Parameters:
numerator | the numerator.
divisor | the divisor.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED
STATUS_CODE_OUT_OF_RANGE

Referenced by GetDouble(), and Activ::TRational::GetNumeratorAndDivisor().

size_t Activ::Rational::GetSerializedBodyLength ( ) const [inline, virtual]

Get the serialized length of the object's body.

Returns:
the serialized length of the object's body.

Implements Activ::IFieldType.

Definition at line 1259 of file Rational.h.

References GetMaxSerializedBodyLength(), and Activ::IFieldType::IsInitialized().

Referenced by Activ::TRational::GetSerializedBodyLength(), and GetSerializedLength().

size_t Activ::Rational::GetSerializedLength ( ) const [inline, virtual]

Get the serialized length of the object.

Returns:
the serialized length of the object.

Implements Activ::IFieldType.

Definition at line 1252 of file Rational.h.

References GetSerializedBodyLength().

Referenced by Activ::TRational::GetSerializedLength().

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::Rational::IsDifferent | ( | const void *const | pRhsSerializedBody,
 |  | const size_t | rhsSerializedBodyLength,
 |  | bool & | isDifferent |
 | ) |  |  | const [virtual]

Is different.

Parameters:
pRhsSerializedBody | the buffer containing the rhs serialized version of the object's body in.
rhsSerializedBodyLength | the rhs serialized body length.
isDifferent | indicates whether the two objects are different.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

bool Activ::Rational::IsValidDenominator ( Denominator denominator ) [inline, static]

Check whether a denominator is valid.

Parameters:
denominator the denominator to check.
Returns:
whether the denominator is valid.

Definition at line 1299 of file Rational.h.

Referenced by GetDenominatorType(), Set(), and SetDenominator().

bool Activ::Rational::IsValidNumerator ( int64_t numerator ) [inline, static]

Check whether a numerator is valid.

Parameters:
numerator the numerator to check.
Returns:
whether the numerator is valid.

Definition at line 1292 of file Rational.h.

References MIN_NUMERATOR.

Referenced by Set().

bool Activ::Rational::IsValidSerializedBodyLength ( const size_t serializedBodyLength ) [inline, static]

Is valid serialized body length.

Parameters:
serializedBodyLength the serialized body length.
Returns:
whether the serialized body length is valid.

Definition at line 1306 of file Rational.h.

References GetMaxSerializedBodyLength().

ACTIV_FIELD_TYPES_API StatusCode Activ::Rational::Multiply | ( | const Rational & | rhs,
 |  | bool | isExactCalculation = true
 | ) |  |

Multiply.

Parameters:
rhs | the value to multiply this object by.
isExactCalculation | whether loss of precision is allowed.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED
STATUS_CODE_OUT_OF_RANGE

Referenced by operator *=().

Rational & Activ::Rational::operator *= ( const Rational & rhs ) [inline]

Multiplication assignment operator.

Parameters:
rhs the value to multiply this object by.
Returns:
a reference to this object.
Exceptions:
StatusCodeException

Definition at line 1099 of file Rational.h.

References ACTIV_THROW_RESULT_IF, and Multiply().

bool Activ::Rational::operator!= ( const Rational & rhs ) const [inline]

Inequality operator.

Parameters:
rhs the object to compare with.
Returns:
the result of the test.
Exceptions:
StatusCodeException

Definition at line 1040 of file Rational.h.

Rational & Activ::Rational::operator+= ( const Rational & rhs ) [inline]

Addition assignment operator.

Parameters:
rhs the value to add to this object.
Returns:
a reference to this object.
Exceptions:
StatusCodeException

Definition at line 1081 of file Rational.h.

References ACTIV_THROW_RESULT_IF, and Add().

Rational & Activ::Rational::operator-= ( const Rational & rhs ) [inline]

Subtraction assignment operator.

Parameters:
rhs the value to subtract from this object.
Returns:
a reference to this object.
Exceptions:
StatusCodeException

Definition at line 1090 of file Rational.h.

References ACTIV_THROW_RESULT_IF, and Subtract().

Rational & Activ::Rational::operator/= ( const Rational & rhs ) [inline]

Division assignment operator.

Parameters:
rhs the value to divide this object by.
Returns:
a reference to this object.
Exceptions:
StatusCodeException

Definition at line 1108 of file Rational.h.

References ACTIV_THROW_RESULT_IF, and Divide().

bool Activ::Rational::operator< ( const Rational & rhs ) const [inline]

Less than operator.

Parameters:
rhs the object to compare with.
Returns:
the result of the test.
Exceptions:
StatusCodeException

Definition at line 1047 of file Rational.h.

References ACTIV_THROW_RESULT_IF, and Compare().

bool Activ::Rational::operator<= ( const Rational & rhs ) const [inline]

Less than or equal to operator.

Parameters:
rhs the object to compare with.
Returns:
the result of the test.
Exceptions:
StatusCodeException

Definition at line 1057 of file Rational.h.

bool Activ::Rational::operator== ( const Rational & rhs ) const [inline]

Equality operator.

Parameters:
rhs the object to compare with.
Returns:
the result of the test.
Exceptions:
StatusCodeException

Definition at line 1030 of file Rational.h.

References ACTIV_THROW_RESULT_IF, and Compare().

bool Activ::Rational::operator> ( const Rational & rhs ) const [inline]

Greater than operator.

Parameters:
rhs the object to compare with.
Returns:
the result of the test.
Exceptions:
StatusCodeException

Definition at line 1064 of file Rational.h.

References ACTIV_THROW_RESULT_IF, and Compare().

bool Activ::Rational::operator>= ( const Rational & rhs ) const [inline]

Greater than or equal to operator.

Parameters:
rhs the object to compare with.
Returns:
the result of the test.
Exceptions:
StatusCodeException

Definition at line 1074 of file Rational.h.

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::Rational::Serialize | ( | MessageBuilder & | messageBuilder,
 |  | const size_t | maxSerializedBodyLength |
 | ) |  |  | const [virtual]

Serialize the object into the supplied message builder.

Parameters:
messageBuilder | the message builder to store a serialized version of the object in.
maxSerializedBodyLength | the maximum serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::Rational::SerializeBody | ( | void * | pSerializedBody,
 |  | const size_t | maxSerializedBodyLength,
 |  | size_t & | serializedBodyLength |
 | ) |  |  | const [virtual]

Serialize the object's body into the supplied data buffer.

Parameters:
pSerializedBody | the buffer to store a serialized version of the object's body in.
maxSerializedBodyLength | the maximum serialized body length.
serializedBodyLength | the serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::Rational::SerializeLengthAndBody | ( | MessageBuilder & | messageBuilder,
 |  | const size_t | maxSerializedBodyLength = MAX_SERIALIZED_BODY_LENGTH_UNDEFINED |
 | ) |  |  | const [virtual]

Serialize the object's length and body into the supplied message builder.

Parameters:
messageBuilder | the message builder to store a serialized version of the object in.
maxSerializedBodyLength | the maximum serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

StatusCode Activ::Rational::Set | ( | const int64_t | numerator,
 |  | const Denominator | denominator,
 |  | bool | shouldCompress = false |
 | ) |  |  | [inline]

Set a new value using numerator and denominator.

Parameters:
numerator | the numerator portion of the value.
denominator | the denominator portion of the value.
shouldCompress | indicates whether the numerator and denominator should be compressed.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER

Definition at line 1117 of file Rational.h.

References IsValidDenominator(), IsValidNumerator(), and Activ::IFieldType::m_isInitialized.

Referenced by Activ::ContentPlatform::ContentGatewayApi::OptionBar::GetAskPrice(), Activ::ContentPlatform::ContentGatewayApi::OptionBar::GetBidPrice(), Activ::ContentPlatform::ContentGatewayApi::OptionBar::GetUnderlyingPrice(), Rational(), Activ::TRational::Set(), Activ::ContentPlatform::ContentGatewayApi::Tick::SetSize(), Activ::ContentPlatform::ContentGatewayApi::IntradayBar::SetTotalVolume(), and Activ::ContentPlatform::ContentGatewayApi::HistoryBar::SetTotalVolume().

StatusCode Activ::Rational::SetDenominator ( const Denominator denominator ) [inline]

Set the denominator portion of the value stored.

This function will attempt to scale the existing numerator in the record.

Parameters:
denominator the denominator portion of the value.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED
STATUS_CODE_OUT_OF_RANGE

Definition at line 1183 of file Rational.h.

References ACTIV_RETURN_RESULT_IF, Activ::IFieldType::IsInitialized(), and IsValidDenominator().

Referenced by Activ::TRational::SetDenominator().

ACTIV_FIELD_TYPES_API StatusCode Activ::Rational::Subtract | ( | const Rational & | rhs,
 |  | bool | isExactCalculation = true
 | ) |  |

Subtract.

Parameters:
rhs | the value to subtract from this object.
isExactCalculation | whether loss of precision is allowed.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED
STATUS_CODE_OUT_OF_RANGE

Referenced by operator-=().

ACTIV_FIELD_TYPES_API std::string Activ::Rational::ToString ( const Rational::Denominator denominator ) const

Convert the object to a string.

Parameters:
denominator indicates the denominator to display the value in.
Returns:
the object as a string.
Exceptions:
StatusCodeException

virtual ACTIV_FIELD_TYPES_API std::string Activ::Rational::ToString ( ) const [virtual]

Convert the object to a string.

Returns:
the object as a string.

Implements Activ::IFieldType.

static ACTIV_FIELD_TYPES_API StatusCode Activ::Rational::ValidateSerializedLengthAndBody | ( | MessageValidator & | messageValidator,
 |  | size_t & | serializedBodyOffset,
 |  | size_t & | serializedBodyLength |
 | ) |  |  | [static]

Validate the serialized length and body.

Parameters:
messageValidator | the message validator.
serializedBodyOffset | the serialized body offset.
serializedBodyLength | the serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivFieldTypes/Rational.h
Generated on Wed Oct 8 14:01:58 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Rational::DenominatorType

Activ::Rational::DenominatorType Class Reference

Denominator type. More...

#include <ActivMiddleware/ActivFieldTypes/Rational.h>

List of all members.

Public Member Functions

DenominatorType (const uint64_t divisor, const uint64_t multiplier, const size_t nDecimalPlaces, const size_t nDivisorDigits, const size_t multiplierPower)
Constructor.
size_t | GetDecimalPlaces () const
Get the number of decimal places.
uint64_t | GetDivisor () const
Get the divisor.
size_t | GetDivisorDigits () const
Get the number of divisor digits.
uint64_t | GetMultiplier () const
Get the multiplier.
size_t | GetMultiplierPower () const
Get the multiplier power.
bool | IsDivisor () const
Check whether the denominator type is a divisor.
bool | IsDivisorBinary () const
Check whether the denominator type is a binary divisor.
bool | IsDivisorDecimal () const
Check whether the denominator type is a decimal divisor.
bool | IsMultiplier () const
Check whether the denominator type is a multiplier.

Detailed Description

Denominator type.

Definition at line 106 of file Rational.h.

Constructor & Destructor Documentation

Activ::Rational::DenominatorType::DenominatorType | ( | const uint64_t | divisor,
 |  | const uint64_t | multiplier,
 |  | const size_t | nDecimalPlaces,
 |  | const size_t | nDivisorDigits,
 |  | const size_t | multiplierPower |
 | ) |  |  | [inline]

Constructor.

Parameters:
divisor | the divisor.
multiplier | the multiplier.
nDecimalPlaces | the number of decimal places.
nDivisorDigits | the number of divisor digits.
multiplierPower | the multiplier power.

Definition at line 1344 of file Rational.h.

Member Function Documentation

size_t Activ::Rational::DenominatorType::GetDecimalPlaces ( ) const [inline]

Get the number of decimal places.

Returns:
the number of decimal places.

Definition at line 1369 of file Rational.h.

uint64_t Activ::Rational::DenominatorType::GetDivisor ( ) const [inline]

Get the divisor.

Returns:
the divisor.

Definition at line 1355 of file Rational.h.

Referenced by Activ::ContentPlatform::ContentGatewayApi::OptionBar::GetAskPrice(), Activ::ContentPlatform::ContentGatewayApi::OptionBar::GetBidPrice(), Activ::ContentPlatform::ContentGatewayApi::OptionBar::GetStrikePrice(), and Activ::ContentPlatform::ContentGatewayApi::OptionBar::GetUnderlyingPrice().

size_t Activ::Rational::DenominatorType::GetDivisorDigits ( ) const [inline]

Get the number of divisor digits.

Returns:
the number of divisor digits.

Definition at line 1376 of file Rational.h.

uint64_t Activ::Rational::DenominatorType::GetMultiplier ( ) const [inline]

Get the multiplier.

Returns:
the multiplier.

Definition at line 1362 of file Rational.h.

Referenced by Activ::ContentPlatform::ContentGatewayApi::OptionBar::GetAskPrice(), Activ::ContentPlatform::ContentGatewayApi::OptionBar::GetBidPrice(), Activ::ContentPlatform::ContentGatewayApi::OptionBar::GetStrikePrice(), and Activ::ContentPlatform::ContentGatewayApi::OptionBar::GetUnderlyingPrice().

size_t Activ::Rational::DenominatorType::GetMultiplierPower ( ) const [inline]

Get the multiplier power.

Returns:
the multiplier power.

Definition at line 1383 of file Rational.h.

bool Activ::Rational::DenominatorType::IsDivisor ( ) const [inline]

Check whether the denominator type is a divisor.

Returns:
whether the denominator type is a divisor.

Definition at line 1390 of file Rational.h.

Referenced by Activ::ContentPlatform::ContentGatewayApi::OptionBar::GetAskPrice(), Activ::ContentPlatform::ContentGatewayApi::OptionBar::GetBidPrice(), Activ::ContentPlatform::ContentGatewayApi::OptionBar::GetStrikePrice(), Activ::ContentPlatform::ContentGatewayApi::OptionBar::GetUnderlyingPrice(), IsDivisorBinary(), and IsDivisorDecimal().

bool Activ::Rational::DenominatorType::IsDivisorBinary ( ) const [inline]

Check whether the denominator type is a binary divisor.

Returns:
whether the denominator type is a binary divisor.

Definition at line 1397 of file Rational.h.

References IsDivisor().

bool Activ::Rational::DenominatorType::IsDivisorDecimal ( ) const [inline]

Check whether the denominator type is a decimal divisor.

Returns:
whether the denominator type is a decimal divisor.

Definition at line 1405 of file Rational.h.

References IsDivisor().

bool Activ::Rational::DenominatorType::IsMultiplier ( ) const [inline]

Check whether the denominator type is a multiplier.

Returns:
whether the denominator type is a multiplier.

Definition at line 1413 of file Rational.h.

Referenced by Activ::ContentPlatform::ContentGatewayApi::OptionBar::GetAskPrice(), Activ::ContentPlatform::ContentGatewayApi::OptionBar::GetBidPrice(), Activ::ContentPlatform::ContentGatewayApi::OptionBar::GetStrikePrice(), and Activ::ContentPlatform::ContentGatewayApi::OptionBar::GetUnderlyingPrice().

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivFieldTypes/Rational.h
Generated on Wed Oct 8 14:01:58 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ReferenceCounter

Activ::ReferenceCounter Class Reference

Intrusive ptr reference counter. More...

#include <ActivMiddleware/Misc/IntrusivePtrHelper.h>

List of all members.

Public Member Functions

uint32_t | Get () const
Get the reference count value.
uint32_t | operator++ ()
Increment the reference count.
uint32_t | operator-- ()
Decrement the reference count.
ReferenceCounter ()
Constructor.

Detailed Description

Intrusive ptr reference counter.

Definition at line 56 of file IntrusivePtrHelper.h.

Member Function Documentation

uint32_t Activ::ReferenceCounter::Get ( ) const [inline]

Get the reference count value.

Returns:
Current reference count.

Definition at line 112 of file IntrusivePtrHelper.h.

uint32_t Activ::ReferenceCounter::operator++ ( ) [inline]

Increment the reference count.

Returns:
Resulting incremented value.

Definition at line 98 of file IntrusivePtrHelper.h.

uint32_t Activ::ReferenceCounter::operator-- ( ) [inline]

Decrement the reference count.

Returns:
Resulting decremented value.

Definition at line 105 of file IntrusivePtrHelper.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/Misc/IntrusivePtrHelper.h
Generated on Wed Oct 8 14:01:58 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::RegistryHelper

Activ::RegistryHelper Class Reference

Registry helper class. More...

#include <ActivMiddleware/ActivBase/Windows/RegistryHelper.h>

List of all members.

Public Types

enum | Type { TYPE_UNSUPPORTED, TYPE_UNSIGNED32, TYPE_STRING, TYPE_BINARY }
Enumeration of basic types supported by RegistryHelper. More...

Public Member Functions

ACTIV_BASE_EXPORTED_API
uint_fast32_t 		EnumerateKeys (const char *keyName)
Enumerate all sub keys of a given key.
ACTIV_BASE_EXPORTED_API
uint_fast32_t 		EnumerateValues (const char *keyName)
Enumerate all values of a given key.
virtual ACTIV_BASE_EXPORTED_API | ~RegistryHelper ()
Destructor.

Static Public Member Functions

static ACTIV_BASE_EXPORTED_API void | DeleteKey (const char *keyName)
Delete a key and all sub keys.
static ACTIV_BASE_EXPORTED_API void | DeleteValue (const char *keyName, const char *valueName)
Delete a value from a key.
static ACTIV_BASE_EXPORTED_API void | GetValue (const char *keyName, const char *valueName, const void *value, uint_fast32_t &maxValueLen)
Get a BINARY value.
static ACTIV_BASE_EXPORTED_API void | GetValue (const char *keyName, const char *valueName, const char *value, uint_fast32_t maxValueLen)
Get a STRING value.
static ACTIV_BASE_EXPORTED_API void | GetValue (const char *keyName, const char *valueName, uint32_t &value)
Get an UNSIGNED32 value.
static ACTIV_BASE_EXPORTED_API void | SetValue (const char *keyName, const char *valueName, const void *value, uint_fast32_t valueLen)
Set a BINARY value.
static ACTIV_BASE_EXPORTED_API void | SetValue (const char *keyName, const char *valueName, const char *value)
Set a STRING value.
static ACTIV_BASE_EXPORTED_API void | SetValue (const char *keyName, const char *valueName, uint32_t value)
Set an UNSIGNED32 value.

Classes

class | RegistryKey
Registry key class.

Detailed Description

Registry helper class.

RegistryHelper wraps up methods for getting, setting and deleting registry values, deleting registry keys and enumerating keys and values.

Definition at line 23 of file RegistryHelper.h.

Member Enumeration Documentation

enum Activ::RegistryHelper::Type

Enumeration of basic types supported by RegistryHelper.

Enumerator:
TYPE_UNSUPPORTED | Unsupported type.
TYPE_UNSIGNED32 | Unsigned 32 bit type.
TYPE_STRING | 0 terminated string type.
TYPE_BINARY | Variable length binary type.

Definition at line 29 of file RegistryHelper.h.

Member Function Documentation

static ACTIV_BASE_EXPORTED_API void Activ::RegistryHelper::DeleteKey ( const char * keyName ) [static]

Delete a key and all sub keys.

Parameters:
keyName the full name of the key to delete.
Exceptions:
OsException

static ACTIV_BASE_EXPORTED_API void Activ::RegistryHelper::DeleteValue | ( | const char * | keyName,
 |  | const char * | valueName |
 | ) |  |  | [static]

Delete a value from a key.

Parameters:
keyName | the full name of the key containing the value to delete.
valueName | the name of the value to delete.
Exceptions:
OsException

ACTIV_BASE_EXPORTED_API uint_fast32_t Activ::RegistryHelper::EnumerateKeys ( const char * keyName )

Enumerate all sub keys of a given key.

The OnKey() callback will be invoked for all sub keys of the given key.

Parameters:
keyName the full name of the root key to enumerate from.
Returns:
the number of keys enumerated.

ACTIV_BASE_EXPORTED_API uint_fast32_t Activ::RegistryHelper::EnumerateValues ( const char * keyName )

Enumerate all values of a given key.

The OnValue() callback will be invoked for all values within the given key.

Parameters:
keyName the full name of the key to enumerate values from.
Returns:
the number of values enumerated.

static ACTIV_BASE_EXPORTED_API void Activ::RegistryHelper::GetValue | ( | const char * | keyName,
 |  | const char * | valueName,
 |  | const void * | value,
 |  | uint_fast32_t & | maxValueLen |
 | ) |  |  | [static]

Get a BINARY value.

Parameters:
keyName | the full name of the key holding the value to retrieve.
valueName | the name of the value within key keyName to retrieve.
value | on success, the retrieved buffer is stored in value.
maxValueLen | the size of the buffer pointer to by value. On success, maxValueLen will contain the length of the retrieved buffer.
Exceptions:
OsException
BaseException

static ACTIV_BASE_EXPORTED_API void Activ::RegistryHelper::GetValue | ( | const char * | keyName,
 |  | const char * | valueName,
 |  | const char * | value,
 |  | uint_fast32_t | maxValueLen |
 | ) |  |  | [static]

Get a STRING value.

Parameters:
keyName | the full name of the key holding the value to retrieve.
valueName | the name of the value within key keyName to retrieve.
value | on success, the retrieved string is stored in value.
maxValueLen | the size of the buffer pointer to by value, including space for terminating \0 character.
Exceptions:
OsException
BaseException

static ACTIV_BASE_EXPORTED_API void Activ::RegistryHelper::GetValue | ( | const char * | keyName,
 |  | const char * | valueName,
 |  | uint32_t & | value |
 | ) |  |  | [static]

Get an UNSIGNED32 value.

Parameters:
keyName | the full name of the key holding the value to retrieve.
valueName | the name of the value within key keyName to retrieve.
value | on success, the retrieved value is stored in value.
Exceptions:
OsException
BaseException

static ACTIV_BASE_EXPORTED_API void Activ::RegistryHelper::SetValue | ( | const char * | keyName,
 |  | const char * | valueName,
 |  | const void * | value,
 |  | uint_fast32_t | valueLen |
 | ) |  |  | [static]

Set a BINARY value.

Parameters:
keyName | the full name of the key in which to set the value.
valueName | the name of the value within key keyName to set.
value | pointer to the buffer to store.
valueLen | the length of the buffer pointer to by value.
Exceptions:
OsException

static ACTIV_BASE_EXPORTED_API void Activ::RegistryHelper::SetValue | ( | const char * | keyName,
 |  | const char * | valueName,
 |  | const char * | value |
 | ) |  |  | [static]

Set a STRING value.

Parameters:
keyName | the full name of the key in which to set the value.
valueName | the name of the value within key keyName to set.
value | the string to set the value to.
Exceptions:
OsException

static ACTIV_BASE_EXPORTED_API void Activ::RegistryHelper::SetValue | ( | const char * | keyName,
 |  | const char * | valueName,
 |  | uint32_t | value |
 | ) |  |  | [static]

Set an UNSIGNED32 value.

Parameters:
keyName | the full name of the key in which to set the value.
valueName | the name of the value within key keyName to set.
value | the UNSIGNED32 value to set.
Exceptions:
OsException

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivBase/Windows/RegistryHelper.h
Generated on Wed Oct 8 14:01:58 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::RequestId

Activ::RequestId Class Reference

Request id class. More...

#include <ActivMiddleware/ActivSystem/RequestId.h>

List of all members.

Public Types

typedef byte_t | Attribute
attribute type
typedef uint32_t | SendId
request id type for synchronous calls

Public Member Functions

ACTIV_SYSTEM_INLINE_API void | Clear ()
Clear the id.
ACTIV_SYSTEM_INLINE_API StatusCode | Deserialize (MessageValidator &messageValidator)
Deserialize the request id.
ACTIV_SYSTEM_INLINE_API const
byte_t * 		Get () const
Get the data.
ACTIV_SYSTEM_INLINE_API Attribute | GetAttributes () const
Get the attribute bits.
ACTIV_SYSTEM_INLINE_API size_t | GetLength () const
Get the length of data.
ACTIV_SYSTEM_INLINE_API const
Address & 		GetResponseAddress () const
Get the response address.
ACTIV_SYSTEM_INLINE_API std::string | MessageModelToString () const
Get a string representation of the message model (req/resp or other).
ACTIV_SYSTEM_INLINE_API bool | operator!= (const RequestId &rhs) const
Inequality operator.
ACTIV_SYSTEM_INLINE_API bool | operator< (const RequestId &rhs) const
Less than operator.
ACTIV_SYSTEM_INLINE_API RequestId & | operator= (const RequestId &rhs)
Assignment operator.
ACTIV_SYSTEM_INLINE_API bool | operator== (const RequestId &rhs) const
Equality operator.
ACTIV_SYSTEM_INLINE_API | RequestId (const RequestId &requestId)
Copy constructor.
ACTIV_SYSTEM_INLINE_API | RequestId (const void *pData, const size_t dataSize, const Address &responseAddress)
Constructor.
ACTIV_SYSTEM_INLINE_API | RequestId (const void *pData, const size_t dataSize)
Constructor.
ACTIV_SYSTEM_INLINE_API | RequestId ()
Default constructor.
ACTIV_SYSTEM_INLINE_API StatusCode | Serialize (MessageBuilder &messageBuilder) const
Serialize the request id.
ACTIV_SYSTEM_INLINE_API void | Set (const void *pData, const size_t dataLength, const Address &responseAddress)
Set the data.
ACTIV_SYSTEM_INLINE_API void | Set (const void *pData, const size_t dataLength)
Set the data.
ACTIV_SYSTEM_INLINE_API void | SetAttributes (Attribute attributes)
Set the attribute bits.
ACTIV_SYSTEM_INLINE_API void | SetLength (const size_t dataLength)
Set the length of data. Truncated if over maxLength.
ACTIV_SYSTEM_INLINE_API void | SetResponseAddress (const Address &responseAddress)
Set the response address.
ACTIV_SYSTEM_INLINE_API std::string | ToString () const
Convert the request id to a printable string.

Static Public Member Functions

static ACTIV_SYSTEM_INLINE_API
std::string 		MessageModelToString (const Attribute attributes)
Get a string representation of the message model (req/resp or other).

Static Public Attributes

static const Attribute | ATTRIBUTE_NONE = 0x00
static const Attribute | ATTRIBUTE_ON = 0x01
static const Attribute | ATTRIBUTE_RESPONSE = 0x02
static const Attribute | ATTRIBUTE_USE_RESPONSE_ADDRESS = 0x04
static
ACTIV_SYSTEM_EXPORTED_API
const RequestId 		emptyRequestId
an empty request id
static const byte_t | MAX_LENGTH = 0x10

Friends

class | SyncRequestId

Detailed Description

Request id class.

Definition at line 30 of file RequestId.h.

Constructor & Destructor Documentation

Activ::RequestId::RequestId | ( | const void * | pData,
 |  | const size_t | dataSize |
 | ) |  |  | [inline]

Constructor.

Parameters:
pData | data to set
dataSize | size of data in pData.

Definition at line 282 of file RequestId.h.

References Set().

Activ::RequestId::RequestId | ( | const void * | pData,
 |  | const size_t | dataSize,
 |  | const Address & | responseAddress |
 | ) |  |  | [inline]

Constructor.

Parameters:
pData | data to set
dataSize | size of data in pData.
responseAddress | address to route response to request.

Definition at line 289 of file RequestId.h.

References Set().

Activ::RequestId::RequestId ( const RequestId & requestId ) [inline]

Copy constructor.

Parameters:
requestId to copy from.

Definition at line 296 of file RequestId.h.

Member Function Documentation

StatusCode Activ::RequestId::Deserialize ( MessageValidator & messageValidator ) [inline]

Deserialize the request id.

Parameters:
messageValidator reference to MessageValidator to deserialize with.
Return values:
STATUS_CODE_SUCCESS
...

Definition at line 371 of file RequestId.h.

References ACTIV_RETURN_RESULT_IF, Activ::Address::Deserialize(), Activ::MessageHandler::ENDIAN_LITTLE, Activ::MessageValidator::ValidateBinaryIntegral(), and Activ::MessageValidator::ValidateBytesCopy().

const byte_t * Activ::RequestId::Get ( ) const [inline]

Get the data.

Returns:
Pointer to request id data.

Definition at line 326 of file RequestId.h.

RequestId::Attribute Activ::RequestId::GetAttributes ( ) const [inline]

Get the attribute bits.

Returns:
The attributes.

Definition at line 421 of file RequestId.h.

size_t Activ::RequestId::GetLength ( ) const [inline]

Get the length of data.

Returns:
Length of request id data.

Definition at line 312 of file RequestId.h.

const Address & Activ::RequestId::GetResponseAddress ( ) const [inline]

Get the response address.

Returns:
Reference to the response address.

Definition at line 435 of file RequestId.h.

std::string Activ::RequestId::MessageModelToString ( const Attribute attributes ) [inline, static]

Get a string representation of the message model (req/resp or other).

Parameters:
attributes attributes from a request id.
Returns:
String representation of the message model.

Definition at line 473 of file RequestId.h.

std::string Activ::RequestId::MessageModelToString ( ) const [inline]

Get a string representation of the message model (req/resp or other).

Returns:
String representation of the message model.

Definition at line 466 of file RequestId.h.

bool Activ::RequestId::operator!= ( const RequestId & rhs ) const [inline]

Inequality operator.

Returns:
true if this is not equal to rhs.

Definition at line 392 of file RequestId.h.

bool Activ::RequestId::operator< ( const RequestId & rhs ) const [inline]

Less than operator.

Parameters:
rhs RequestId to compare with.
Return values:
true | if this is less than rhs.
false | if this is greater than or equal to rhs.

Definition at line 399 of file RequestId.h.

RequestId & Activ::RequestId::operator= ( const RequestId & rhs ) [inline]

Assignment operator.

Parameters:
rhs to assign from.

Definition at line 406 of file RequestId.h.

References m_attributes, m_buffer, m_length, and m_responseAddress.

bool Activ::RequestId::operator== ( const RequestId & rhs ) const [inline]

Equality operator.

Returns:
true if this is equal to rhs.

Definition at line 385 of file RequestId.h.

StatusCode Activ::RequestId::Serialize ( MessageBuilder & messageBuilder ) const [inline]

Serialize the request id.

Parameters:
messageBuilder reference to MessageBuilder to serialize with.
Return values:
STATUS_CODE_SUCCESS
...

Definition at line 359 of file RequestId.h.

References ACTIV_RETURN_RESULT_IF, Activ::MessageBuilder::Append(), Activ::MessageHandler::ENDIAN_LITTLE, and Activ::Address::Serialize().

void Activ::RequestId::Set | ( | const void * | pData,
 |  | const size_t | dataLength,
 |  | const Address & | responseAddress |
 | ) |  |  | [inline]

Set the data.

Parameters:
pData | data to set
dataLength | size of data in pData.
responseAddress | address to route for response to request.

Definition at line 342 of file RequestId.h.

References Activ::Address::Clear(), and Activ::Address::IsValid().

void Activ::RequestId::Set | ( | const void * | pData,
 |  | const size_t | dataLength |
 | ) |  |  | [inline]

Set the data.

Parameters:
pData | data to set
dataLength | size of data in pData.

Definition at line 333 of file RequestId.h.

References Activ::Address::Clear().

Referenced by RequestId().

void Activ::RequestId::SetAttributes ( Attribute attributes ) [inline]

Set the attribute bits.

Parameters:
attributes the attributes.

Definition at line 428 of file RequestId.h.

void Activ::RequestId::SetLength ( const size_t dataLength ) [inline]

Set the length of data. Truncated if over maxLength.

Parameters:
dataLength length to set to.

Definition at line 319 of file RequestId.h.

void Activ::RequestId::SetResponseAddress ( const Address & responseAddress ) [inline]

Set the response address.

Parameters:
responseAddress the address to set.

Definition at line 442 of file RequestId.h.

std::string Activ::RequestId::ToString ( ) const [inline]

Convert the request id to a printable string.

Returns:
String of the form "aa bb cc dd".

Definition at line 449 of file RequestId.h.

References ACTIV_ARRAY_SIZE.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivSystem/RequestId.h
Generated on Wed Oct 8 14:01:58 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::RouterServiceApi

Activ::RouterServiceApi Class Reference

Api to the agent's router service. More...

#include <ActivMiddleware/ActivFramework/RouterServiceApi.h>

Classes

class | Tcp
Tcp related apis. More...
class | Udp
Udp related apis. More...

Detailed Description

Api to the agent's router service.

Definition at line 25 of file RouterServiceApi.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivFramework/RouterServiceApi.h
Generated on Wed Oct 8 14:01:58 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::RouterServiceApi::Tcp

Activ::RouterServiceApi::Tcp Class Reference

Tcp related apis. More...

#include <ActivMiddleware/ActivFramework/RouterServiceApi.h>

List of all members.

Static Public Member Functions

static ACTIV_FRAMEWORK_API
StatusCode 		Break (const Component &component, const Address &connectionAddress)
Break a connection.
static ACTIV_FRAMEWORK_API
StatusCode 		BreakAll (const Component &component, const Address &serverAddress)
Break all accepted connections by a server.
static ACTIV_FRAMEWORK_API
StatusCode 		ClearSocketStatsHighCounts (const Component &component, const Address &circuitAddress)
Clear high counts for a socket.
static ACTIV_FRAMEWORK_API
StatusCode 		Connect (const Component &component, const std::string &url, Address &circuitAddress, IHeap *const pHeap=0, const ISerializableMessage *const pUserData=0)
Create a circuit and initiate an asynchronous connect.
static ACTIV_FRAMEWORK_API
StatusCode 		Connect (const Component &component, const std::string &url, HeapMessage &connectResponse, IHeap *const pHeap, const TimeoutPeriod timeout, const ISerializableMessage *const pUserData=0)
Create a circuit and initiate a synchronous connect.
static ACTIV_FRAMEWORK_API
StatusCode 		DeserializeSocketStats (const HeapMessage &heapMessage, SocketStats &socketStats)
Deserialize a socket stats message.
static ACTIV_FRAMEWORK_API
StatusCode 		Disconnect (const Component &component, const Address &circuitAddress, const TimeoutPeriod timeout=0)
Disconnect a circuit.
static ACTIV_FRAMEWORK_API
StatusCode 		EnableSocketStats (const Component &component, const Address &circuitAddress)
Enable receipt of socket stats for a circuit.
static ACTIV_FRAMEWORK_API
StatusCode 		Listen (const Component &component, const std::string &url, Address &serverAddress, IHeap *const pHeap=0)
Allow an address to be accessable through a server.
static ACTIV_FRAMEWORK_API
StatusCode 		Listen (const Component &component, const std::string &url, Address &serverAddress, std::vector< std::string > &accessUrlList, IHeap *const pHeap=0)
Allow an address to be accessable through a server.
static ACTIV_FRAMEWORK_API
StatusCode 		SetHeap (const Component &component, const Address &address, const IHeap *const pHeap)
Set heap for a connection.
static ACTIV_FRAMEWORK_API
StatusCode 		SetMaxTxQueueSize (const Component &component, const Address &address, const size_t numberOfBytes)
Set maximum transmit queue size for a connection.
static ACTIV_FRAMEWORK_API
StatusCode 		Stop (const Component &component, const Address &serverAddress)
Remove access to an address through a server.

Classes

class SocketStats
Socket stats. More...

Detailed Description

Tcp related apis.

Definition at line 31 of file RouterServiceApi.h.

Member Function Documentation

static ACTIV_FRAMEWORK_API StatusCode Activ::RouterServiceApi::Tcp::Break | ( | const Component & | component,
 |  | const Address & | connectionAddress |
 | ) |  |  | [static]

Break a connection.

Parameters:
component | component to initiate the break from.
connectionAddress | the address of a circuit to break. If the connection is shared, all circuits over that connection will break.
Return values:
STATUS_CODE_SUCCESS the connection has been broken.
STATUS_CODE_FAILURE

static ACTIV_FRAMEWORK_API StatusCode Activ::RouterServiceApi::Tcp::BreakAll | ( | const Component & | component,
 |  | const Address & | serverAddress |
 | ) |  |  | [static]

Break all accepted connections by a server.

Parameters:
component | component to send message from.
serverAddress | address of the server to close the accepted connections of.
Return values:
STATUS_CODE_SUCCESS.
STATUS_CODE_FAILURE.

static ACTIV_FRAMEWORK_API StatusCode Activ::RouterServiceApi::Tcp::ClearSocketStatsHighCounts | ( | const Component & | component,
 |  | const Address & | circuitAddress |
 | ) |  |  | [static]

Clear high counts for a socket.

Parameters:
component | component to send request from.
circuitAddress | the address of the circuit to get the underlying socket stats for.

static ACTIV_FRAMEWORK_API StatusCode Activ::RouterServiceApi::Tcp::Connect | ( | const Component & | component,
 |  | const std::string & | url,
 |  | Address & | circuitAddress,
 |  | IHeap *const | pHeap = 0,
 |  | const ISerializableMessage *const | pUserData = 0 |
 | ) |  |  | [static]

Create a circuit and initiate an asynchronous connect.

Parameters:
component | component to initiate the connection from.
url | of the form protocol://host:port/location?unique.
circuitAddress | reference to an Address object to receive the address of the circuit.
pHeap | the heap to use for received messages. Default is this component's heap.
pUserData | optional userdata.
Return values:
STATUS_CODE_SUCCESS | OnConnect() will be invoked when the circuit is up.
STATUS_CODE_HOST_NOT_FOUND | unknown destination machine.
STATUS_CODE_INVALID_ENDPOINT_PORT | unknown endpoint-port on target system.
STATUS_CODE_FAILURE ...

static ACTIV_FRAMEWORK_API StatusCode Activ::RouterServiceApi::Tcp::Connect | ( | const Component & | component,
 |  | const std::string & | url,
 |  | HeapMessage & | connectResponse,
 |  | IHeap *const | pHeap,
 |  | const TimeoutPeriod | timeout,
 |  | const ISerializableMessage *const | pUserData = 0 |
 | ) |  |  | [static]

Create a circuit and initiate a synchronous connect.

Parameters:
component | component to initiate the connection from.
url | of the form protocol://host:port/location?unique.
connectResponse | reference to a HeapMessage object to receive connect response. Source address of this message for a successful connect will be the circuit address.
pHeap | the heap to use for received messages. Default is this component's heap.
timeout | How long to wait for the circuit to establish, in ms.
pUserData | optional userdata.
Return values:
STATUS_CODE_SUCCESS | circuit is up.
STATUS_CODE_TIMEOUT | circuit did not establish in the timeout period.
STATUS_CODE_HOST_NOT_FOUND | unknown destination machine.
STATUS_CODE_INVALID_ENDPOINT_PORT | unknown endpoint-port on target system.
STATUS_CODE_FAILURE ...

static ACTIV_FRAMEWORK_API StatusCode Activ::RouterServiceApi::Tcp::DeserializeSocketStats | ( | const HeapMessage & | heapMessage,
 |  | SocketStats & | socketStats |
 | ) |  |  | [static]

Deserialize a socket stats message.

Parameters:
heapMessage | received message of type RouterServiceApi::Tcp::SocketStats::MESSAGE_TYPE
socketStats | reference to a SocketStats to receive the stats.
Returns:
STATUS_CODE_SUCCESS or an error status code.

static ACTIV_FRAMEWORK_API StatusCode Activ::RouterServiceApi::Tcp::Disconnect | ( | const Component & | component,
 |  | const Address & | circuitAddress,
 |  | const TimeoutPeriod | timeout = 0 |
 | ) |  |  | [static]

Disconnect a circuit.

Parameters:
component | component to initiate the disconnect from.
circuitAddress | the address of the circuit to initiate a disconnect on.
timeout | if 0, initiate an asynchronous disconnect. Otherwise, how long to wait for the circuit to close, in ms.
Return values:
STATUS_CODE_SUCCESS | for an asynchronous disconnect, OnDisconnect() will be invoked when the circuit is down.
STATUS_CODE_SUCCESS | for a synchronous disconnect, circuit is down. Note data from this circuit may still be queued up on the destination endpoint, it is up to the application to discard this data if required.
STATUS_CODE_TIMEOUT | for a synchronous disconnect - circuit did not close in the timeout period.
STATUS_CODE_FAILURE ...

static ACTIV_FRAMEWORK_API StatusCode Activ::RouterServiceApi::Tcp::EnableSocketStats | ( | const Component & | component,
 |  | const Address & | circuitAddress |
 | ) |  |  | [static]

Enable receipt of socket stats for a circuit.

The component will receive a message of type RouterServiceApi::Tcp::SocketStats::MESSAGE_TYPE on a lazy basis. Use DeserializeSocketStats() to retrieve the socket stats for the connection.

Parameters:
component | component to send request from.
circuitAddress | the address of the circuit to get the underlying socket stats for.
Returns:
STATUS_CODE_SUCCESS or an error status code.

static ACTIV_FRAMEWORK_API StatusCode Activ::RouterServiceApi::Tcp::Listen | ( | const Component & | component,
 |  | const std::string & | url,
 |  | Address & | serverAddress,
 |  | IHeap *const | pHeap = 0 |
 | ) |  |  | [static]

Allow an address to be accessable through a server.

Parameters:
component | component to allow access to.
url | of the form protocol://host:port?unique,accepts=n
serverAddress | reference to an Address object to receive the address of the server.
pHeap | the heap to use for received messages. Default is this component's heap.
Return values:
STATUS_CODE_SUCCESS.
STATUS_CODE_NOT_SHAREABLE | unique not specified for an non-multiplexable protocol.
STATUS_CODE_INVALID_PROTOCOL | server already exists on the given address and port with a different protocol.
STATUS_CODE_SHUTTING_DOWN | can't add new user as server is shutting down.
STATUS_CODE_ALREADY_LISTENING | user already added.
STATUS_CODE_FAILURE.
STATUS_CODE_TIMEOUT.

static ACTIV_FRAMEWORK_API StatusCode Activ::RouterServiceApi::Tcp::Listen | ( | const Component & | component,
 |  | const std::string & | url,
 |  | Address & | serverAddress,
 |  | std::vector< std::string > & | accessUrlList,
 |  | IHeap *const | pHeap = 0 |
 | ) |  |  | [static]

Allow an address to be accessable through a server.

Parameters:
component | component to allow access to.
url | of the form protocol://host:port?unique,accepts=n
serverAddress | reference to an Address object to receive the address of the server.
accessUrlList | to receive the urls that a client can use to access the server.
pHeap | the heap to use for received messages. Default is this component's heap.
Return values:
STATUS_CODE_SUCCESS.
STATUS_CODE_NOT_SHAREABLE | unique not specified for an non-multiplexable protocol.
STATUS_CODE_INVALID_PROTOCOL | server already exists on the given address and port with a different protocol.
STATUS_CODE_SHUTTING_DOWN | can't add new user as server is shutting down.
STATUS_CODE_ALREADY_LISTENING | user already added.
STATUS_CODE_FAILURE.
STATUS_CODE_TIMEOUT.

static ACTIV_FRAMEWORK_API StatusCode Activ::RouterServiceApi::Tcp::SetHeap | ( | const Component & | component,
 |  | const Address & | address,
 |  | const IHeap *const | pHeap |
 | ) |  |  | [static]

Set heap for a connection.

Parameters:
component | component to send the message from.
address | the address of a circuit.
pHeap | heap to use for received data on this connection.
Return values:
STATUS_CODE_SUCCESS
...

static ACTIV_FRAMEWORK_API StatusCode Activ::RouterServiceApi::Tcp::SetMaxTxQueueSize | ( | const Component & | component,
 |  | const Address & | address,
 |  | const size_t | numberOfBytes |
 | ) |  |  | [static]

Set maximum transmit queue size for a connection.

Parameters:
component | component to send the message from.
address | the address of a circuit.
numberOfBytes | max bytes to allow on tx queue before breaking connection (0 is no limit).
Return values:
STATUS_CODE_SUCCESS
...

static ACTIV_FRAMEWORK_API StatusCode Activ::RouterServiceApi::Tcp::Stop | ( | const Component & | component,
 |  | const Address & | serverAddress |
 | ) |  |  | [static]

Remove access to an address through a server.

Parameters:
component | component to stop listening.
serverAddress | address of the server to remove access from.
Return values:
STATUS_CODE_SUCCESS.
STATUS_CODE_FAILURE.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivFramework/RouterServiceApi.h
Generated on Wed Oct 8 14:01:58 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::RouterServiceApi::Tcp::SocketStats

Activ::RouterServiceApi::Tcp::SocketStats Class Reference

Socket stats. More...

#include <ActivMiddleware/ActivFramework/RouterServiceApi.h>

List of all members.

Public Member Functions

ACTIV_FRAMEWORK_API | SocketStats ()
Default constructor.

Public Attributes

size_t | m_inTxQueueBytes
current size of currently transmitting queue in bytes
size_t | m_inTxQueueHighBytes
high size of currently transmitting queue in bytes
size_t | m_inTxQueueHighMessages
high size of currently transmitting queue in number of messages
size_t | m_inTxQueueMessages
current size of currently transmitting queue in number of messages
size_t | m_mutexContentionCount
approx. contentions on the socket's mutex
uint64_t | m_rxBytes
total rx bytes
uint64_t | m_txBytes
total tx bytes
size_t | m_txQueueBytes
current size of to transmit queue in bytes
size_t | m_txQueueHighBytes
high size of to transmit queue in bytes
size_t | m_txQueueHighMessages
high size of to transmit queue in number of messages
size_t | m_txQueueMessages
current size of to transmit queue in number of messages

Static Public Attributes

static const MessageType | MESSAGE_TYPE = ROUTER_MESSAGE_USER_NOTIFY_SOCKET_STATS

Detailed Description

Socket stats.

Definition at line 37 of file RouterServiceApi.h.

Constructor & Destructor Documentation

ACTIV_FRAMEWORK_API Activ::RouterServiceApi::Tcp::SocketStats::SocketStats ( )

Default constructor.

Zeros all members.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivFramework/RouterServiceApi.h
Generated on Wed Oct 8 14:01:58 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::RouterServiceApi::Udp

Activ::RouterServiceApi::Udp Class Reference

Udp related apis. More...

#include <ActivMiddleware/ActivFramework/RouterServiceApi.h>

List of all members.

Static Public Member Functions

static ACTIV_FRAMEWORK_API
StatusCode 		Close (const Component &component, const Address &socketAddress, const bool gracefully=false)
Close a udp socket.
static ACTIV_FRAMEWORK_API
StatusCode 		Connect (const Component &component, const Address &socketAddress, const std::string &remoteAddressString, const uint16_t remotePort)
Connect a udp socket to a remote address (filter all traffic from other addresses).
static ACTIV_FRAMEWORK_API
StatusCode 		Create (const Component &component, const std::string &localAddress, const uint16_t localPort, const uint16_t maxRxSize, Address &socketAddress, IHeap *const pHeap=0)
Create a socket and bind it to a local address.
static ACTIV_FRAMEWORK_API
StatusCode 		Disconnect (const Component &component, const Address &socketAddress)
Disconnect a udp socket from a remote address (allow all traffic).
static ACTIV_FRAMEWORK_API
StatusCode 		GetSocketHandle (const Component &component, const Address &socketAddress, SOCKET &socket)
Get the underying socket handle.
static ACTIV_FRAMEWORK_API
StatusCode 		JoinMulticastGroup (const Component &component, const Address &socketAddress, const std::string &multicastGroupString, const std::string &interfaceAddressString)
Join a multicast group.
static ACTIV_FRAMEWORK_API
StatusCode 		LeaveMulticastGroup (const Component &component, const Address &socketAddress, const std::string &multicastGroupString, const std::string &interfaceAddressString)
Leave a multicast group.
static ACTIV_FRAMEWORK_API
StatusCode 		PostData (const Component &component, const Address &socketAddress, HeapMessage &heapMessage)
Post some data. This call does not block, the transmission is handled by the router service.
static ACTIV_FRAMEWORK_API
StatusCode 		Read (const Component &component, const Address &socketAddress)
Initiate a read on a udp socket.
static ACTIV_FRAMEWORK_API
StatusCode 		Send (const SOCKET socket, const void *pData, size_t dataLength)
Do a blocking send of some data.
static ACTIV_FRAMEWORK_API
StatusCode 		SendTo (const SOCKET socket, const void *pData, size_t dataLength, const IpAddress &toAddress)
Do a blocking send of some data to a specified ip address.
static ACTIV_FRAMEWORK_API
StatusCode 		SetMulticastLoopback (const Component &component, const Address &socketAddress, const bool enable)
Set the receive multicast loopback option of a socket.
static ACTIV_FRAMEWORK_API
StatusCode 		SetMulticastTtl (const Component &component, const Address &socketAddress, const uint32_t ttl)
Set TTL to be used for multicasting.
static ACTIV_FRAMEWORK_API
StatusCode 		SetMulticastTxInterface (const Component &component, const Address &socketAddress, const std::string &interfaceAddressString)
Set multicast interface for transmission.
static ACTIV_FRAMEWORK_API
StatusCode 		SetRxBufferSize (const Component &component, const Address &socketAddress, const uint32_t size)
Set the internal rx buffer size of a socket.
static ACTIV_FRAMEWORK_API
StatusCode 		SetTxBufferSize (const Component &component, const Address &socketAddress, const uint32_t size)
Set the internal tx buffer size of a socket.
static ACTIV_FRAMEWORK_API
StatusCode 		SetUnicastTtl (const Component &component, const Address &socketAddress, const uint32_t ttl)
Set TTL to be used for unicasting.

Detailed Description

Udp related apis.

Definition at line 261 of file RouterServiceApi.h.

Member Function Documentation

static ACTIV_FRAMEWORK_API StatusCode Activ::RouterServiceApi::Udp::Close | ( | const Component & | component,
 |  | const Address & | socketAddress,
 |  | const bool | gracefully = false |
 | ) |  |  | [static]

Close a udp socket.

Parameters:
component | component to send the message from.
socketAddress | address of the socket to shutdown.
gracefully | true to only close the socket once any outstanding tx has completed, false to force the socket closed immediately.
Return values:
STATUS_CODE_SUCCESS | the socket is fully closed.
STATUS_CODE_PENDING | the socket is closing and OnSocketClose() will be called.
...

static ACTIV_FRAMEWORK_API StatusCode Activ::RouterServiceApi::Udp::Connect | ( | const Component & | component,
 |  | const Address & | socketAddress,
 |  | const std::string & | remoteAddressString,
 |  | const uint16_t | remotePort |
 | ) |  |  | [static]

Connect a udp socket to a remote address (filter all traffic from other addresses).

Parameters:
component | component to send the message from.
socketAddress | address of the socket to connect.
remoteAddressString | the remote address to connect to in string form.
remotePort | the remote port to connect to (local endian).
Return values:
...

static ACTIV_FRAMEWORK_API StatusCode Activ::RouterServiceApi::Udp::Create | ( | const Component & | component,
 |  | const std::string & | localAddress,
 |  | const uint16_t | localPort,
 |  | const uint16_t | maxRxSize,
 |  | Address & | socketAddress,
 |  | IHeap *const | pHeap = 0 |
 | ) |  |  | [static]

Create a socket and bind it to a local address.

Parameters:
component | component to send the message from.
localAddress | local address to bind to.
localPort | local port to bind to.
maxRxSize | maximum size of a datagram that can be received.
socketAddress | reference to an Address object to receive the address of the socket.
pHeap | the heap to use for received messages. Default is this component's heap.
Return values:
STATUS_CODE_SUCCESS.
STATUS_CODE_TIMEOUT.
STATUS_CODE_FAILURE ...

static ACTIV_FRAMEWORK_API StatusCode Activ::RouterServiceApi::Udp::Disconnect | ( | const Component & | component,
 |  | const Address & | socketAddress |
 | ) |  |  | [static]

Disconnect a udp socket from a remote address (allow all traffic).

Parameters:
component | component to send the message from.
socketAddress | address of the socket to disconnect.
Return values:
...

static ACTIV_FRAMEWORK_API StatusCode Activ::RouterServiceApi::Udp::GetSocketHandle | ( | const Component & | component,
 |  | const Address & | socketAddress,
 |  | SOCKET & | socket |
 | ) |  |  | [static]

Get the underying socket handle.

Currently only supports udp sockets created by the router.

Parameters:
component | component to send the message from.
socketAddress | the socket to get the handle of.
socket | reference to a SOCKET variable to receive the handle.
Return values:
STATUS_CODE_SUCCESS
...

static ACTIV_FRAMEWORK_API StatusCode Activ::RouterServiceApi::Udp::JoinMulticastGroup | ( | const Component & | component,
 |  | const Address & | socketAddress,
 |  | const std::string & | multicastGroupString,
 |  | const std::string & | interfaceAddressString |
 | ) |  |  | [static]

Join a multicast group.

Parameters:
component | component to send the message from.
socketAddress | address of the socket to join the multicast group on.
multicastGroupString | an ipv4 or ipv6 multicast address string.
interfaceAddressString | an ipv4 or ipv6 interface address string.
Return values:
...

static ACTIV_FRAMEWORK_API StatusCode Activ::RouterServiceApi::Udp::LeaveMulticastGroup | ( | const Component & | component,
 |  | const Address & | socketAddress,
 |  | const std::string & | multicastGroupString,
 |  | const std::string & | interfaceAddressString |
 | ) |  |  | [static]

Leave a multicast group.

Parameters:
component | component to send the message from.
socketAddress | address of the socket to leave the multicast group.
multicastGroupString | an ipv4 or ipv6 multicast address string.
interfaceAddressString | an ipv4 or ipv6 interface address string.
Return values:
...

static ACTIV_FRAMEWORK_API StatusCode Activ::RouterServiceApi::Udp::PostData | ( | const Component & | component,
 |  | const Address & | socketAddress,
 |  | HeapMessage & | heapMessage |
 | ) |  |  | [static]

Post some data. This call does not block, the transmission is handled by the router service.

Parameters:
component | component to send the message from.
socketAddress | the socket to send the data on.
heapMessage | the message to send.
Return values:
...

static ACTIV_FRAMEWORK_API StatusCode Activ::RouterServiceApi::Udp::Read | ( | const Component & | component,
 |  | const Address & | socketAddress |
 | ) |  |  | [static]

Initiate a read on a udp socket.

Parameters:
component | component to send the message from.
socketAddress | address of the socket to connect.
Return values:
...

static ACTIV_FRAMEWORK_API StatusCode Activ::RouterServiceApi::Udp::Send | ( | const SOCKET | socket,
 |  | const void * | pData,
 |  | size_t | dataLength |
 | ) |  |  | [static]

Do a blocking send of some data.

Parameters:
socket | socket handle obtained with GetSocketHandle().
pData | pointer to data to send.
dataLength | length of data to send.
Returns:
STATUS_CODE_SUCCESS or an error status.

static ACTIV_FRAMEWORK_API StatusCode Activ::RouterServiceApi::Udp::SendTo | ( | const SOCKET | socket,
 |  | const void * | pData,
 |  | size_t | dataLength,
 |  | const IpAddress & | toAddress |
 | ) |  |  | [static]

Do a blocking send of some data to a specified ip address.

Parameters:
socket | socket handle obtained with GetSocketHandle().
pData | pointer to data to send.
dataLength | length of data to send.
toAddress | destination ip address.
Returns:
STATUS_CODE_SUCCESS or an error status.

static ACTIV_FRAMEWORK_API StatusCode Activ::RouterServiceApi::Udp::SetMulticastLoopback | ( | const Component & | component,
 |  | const Address & | socketAddress,
 |  | const bool | enable |
 | ) |  |  | [static]

Set the receive multicast loopback option of a socket.

Parameters:
component | component to send the message from.
socketAddress | address of the socket to set transmit buffer size on.
enable | true to enable receipt of multicast loopback data, else false.
Return values:
...

static ACTIV_FRAMEWORK_API StatusCode Activ::RouterServiceApi::Udp::SetMulticastTtl | ( | const Component & | component,
 |  | const Address & | socketAddress,
 |  | const uint32_t | ttl |
 | ) |  |  | [static]

Set TTL to be used for multicasting.

Parameters:
component | component to send the message from.
socketAddress | address of the socket to set the ttl on.
ttl | the TTL.
Return values:
...

static ACTIV_FRAMEWORK_API StatusCode Activ::RouterServiceApi::Udp::SetMulticastTxInterface | ( | const Component & | component,
 |  | const Address & | socketAddress,
 |  | const std::string & | interfaceAddressString |
 | ) |  |  | [static]

Set multicast interface for transmission.

Parameters:
component | component to send the message from.
socketAddress | address of the socket to set multicast interface on.
interfaceAddressString | an ipv4 or ipv6 address string.
Return values:
...

static ACTIV_FRAMEWORK_API StatusCode Activ::RouterServiceApi::Udp::SetRxBufferSize | ( | const Component & | component,
 |  | const Address & | socketAddress,
 |  | const uint32_t | size |
 | ) |  |  | [static]

Set the internal rx buffer size of a socket.

Parameters:
component | component to send the message from.
socketAddress | address of the socket to set receive buffer size.
size | the rx buffer size.
Return values:
...

static ACTIV_FRAMEWORK_API StatusCode Activ::RouterServiceApi::Udp::SetTxBufferSize | ( | const Component & | component,
 |  | const Address & | socketAddress,
 |  | const uint32_t | size |
 | ) |  |  | [static]

Set the internal tx buffer size of a socket.

Parameters:
component | component to send the message from.
socketAddress | address of the socket to set transmit buffer size on.
size | the tx buffer size.
Return values:
...

static ACTIV_FRAMEWORK_API StatusCode Activ::RouterServiceApi::Udp::SetUnicastTtl | ( | const Component & | component,
 |  | const Address & | socketAddress,
 |  | const uint32_t | ttl |
 | ) |  |  | [static]

Set TTL to be used for unicasting.

Parameters:
component | component to send the message from.
socketAddress | address of the socket to set unicast ttl on.
ttl | the TTL.
Return values:
...

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivFramework/RouterServiceApi.h
Generated on Wed Oct 8 14:01:58 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ScatterBufferHelper

Activ::ScatterBufferHelper Class Reference

Scatter buffer helper class. More...

#include <ActivMiddleware/ActivBase/ScatterBufferHelper.h>

List of all members.

Public Member Functions

ACTIV_BASE_EXPORTED_API StatusCode | AdjustGetBufferSize (const size_t getBufferSize) const
Adjust the get buffer size.
ACTIV_BASE_EXPORTED_API StatusCode | Attach (const ScatterBufferHelper &from, const size_t fromOffset, const size_t dataLength)
Attach a new buffer(s), expand the scatter buffer list if required.
ACTIV_BASE_EXPORTED_API StatusCode | Attach (void *pData, const size_t dataLength)
Attach a new buffer, expand the scatter buffer list if required.
ACTIV_BASE_INLINE_API ConstIterator | Begin () const
Get an iterator to the first scatter buffer in the container.
ACTIV_BASE_EXPORTED_API StatusCode | Copy (void *pData, const size_t dataSize, size_t &dataLength) const
Copy data.
ACTIV_BASE_EXPORTED_API StatusCode | Copy (const size_t offset, void *pData, const size_t dataLength) const
Copy data from the scatter buffer.
ACTIV_BASE_INLINE_API ConstIterator | End () const
Get an iterator that points to beyond the last scatter buffer in the container.
ACTIV_BASE_EXPORTED_API StatusCode | Get (const size_t offset, const void *&pData, const size_t dataLength, size_t &dataLengthRead) const
Get data from the scatter buffer.
ACTIV_BASE_EXPORTED_API StatusCode | Get (const void *&pData, size_t &dataLength, void *pGetBuffer=0, const size_t getBufferSize=0) const
Get data.
ACTIV_BASE_EXPORTED_API StatusCode | Get (const size_t offset, const void *&pData, const size_t dataLength, void *pGetBuffer=0) const
Get data from the scatter buffer.
ACTIV_BASE_INLINE_API size_t | GetNumberOfScatterBuffersInUse () const
Get the number of scatter buffers currently in use.
ACTIV_BASE_INLINE_API size_t | GetTotalBytes () const
Get the total number of bytes in the scatter buffer list.
ACTIV_BASE_EXPORTED_API
ScatterBufferHelper & 		operator= (const ScatterBufferHelper &rhs)
Assignment operator.
ACTIV_BASE_INLINE_API void | Reset ()
Reset the number of buffers in use.
ACTIV_BASE_INLINE_API StatusCode | Reset (const size_t nInitialScatterBuffers)
Reset the number of buffers in use.
ACTIV_BASE_EXPORTED_API | ScatterBufferHelper (const ScatterBufferHelper &rhs)
Copy constructor.
ACTIV_BASE_EXPORTED_API | ScatterBufferHelper (const size_t nInitialScatterBuffers=5, const size_t initialGetBufferSize=0)
Constructor.
ACTIV_BASE_EXPORTED_API StatusCode | Set (const size_t offset, const ScatterBufferHelper &from, const size_t fromOffset, const size_t dataLength)
Set data in the scatter buffer.
ACTIV_BASE_EXPORTED_API StatusCode | Set (const size_t offset, const void *pData, const size_t dataLength)
Set data in the scatter buffer.
ACTIV_BASE_INLINE_API | ~ScatterBufferHelper ()
Destructor.

Classes

class | ConstIterator
Scatter buffer const iterator class. More...
class | ScatterBuffer
Scatter buffer class. More...

Detailed Description

Scatter buffer helper class.

Definition at line 21 of file ScatterBufferHelper.h.

Constructor & Destructor Documentation

ACTIV_BASE_EXPORTED_API Activ::ScatterBufferHelper::ScatterBufferHelper | ( | const size_t | nInitialScatterBuffers = 5,
 |  | const size_t | initialGetBufferSize = 0
 | ) |  |

Constructor.

Parameters:
nInitialScatterBuffers | the number of scatter buffers to allocate initially.
initialGetBufferSize | the initial size of the get buffer.
Exceptions:
StatusCodeException

ACTIV_BASE_EXPORTED_API Activ::ScatterBufferHelper::ScatterBufferHelper ( const ScatterBufferHelper & rhs )

Copy constructor.

Parameters:
rhs the value to assign to this object.
Exceptions:
StatusCodeException

Member Function Documentation

ACTIV_BASE_EXPORTED_API StatusCode Activ::ScatterBufferHelper::AdjustGetBufferSize ( const size_t getBufferSize ) const

Adjust the get buffer size.

Parameters:
getBufferSize the size of the get buffer.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_HEAP_EMPTY

ACTIV_BASE_EXPORTED_API StatusCode Activ::ScatterBufferHelper::Attach | ( | const ScatterBufferHelper & | from,
 |  | const size_t | fromOffset,
 |  | const size_t | dataLength
 | ) |  |

Attach a new buffer(s), expand the scatter buffer list if required.

from the scatterBufferHelper to copy the data from. fromOffset the offset to copy the data from. dataLength the length to set.

Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_HEAP_EMPTY

ACTIV_BASE_EXPORTED_API StatusCode Activ::ScatterBufferHelper::Attach | ( | void * | pData,
 |  | const size_t | dataLength
 | ) |  |

Attach a new buffer, expand the scatter buffer list if required.

pData pointer to the data. dataLength the length of the buffer.

Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_HEAP_EMPTY

ScatterBufferHelper::ConstIterator Activ::ScatterBufferHelper::Begin ( ) const [inline]

Get an iterator to the first scatter buffer in the container.

Returns:
an iterator object.

Definition at line 382 of file ScatterBufferHelper.h.

ACTIV_BASE_EXPORTED_API StatusCode Activ::ScatterBufferHelper::Copy | ( | void * | pData,
 |  | const size_t | dataSize,
 |  | size_t & | dataLength |
 | ) |  |  | const

Copy data.

Parameters:
pData | the address to copy data to.
dataSize | the size of data.
dataLength | the length copied.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER

ACTIV_BASE_EXPORTED_API StatusCode Activ::ScatterBufferHelper::Copy | ( | const size_t | offset,
 |  | void * | pData,
 |  | const size_t | dataLength |
 | ) |  |  | const

Copy data from the scatter buffer.

offset the offset to copy from. pData pointer to copy data to. dataLength the length to copy.

Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER

ScatterBufferHelper::ConstIterator Activ::ScatterBufferHelper::End ( ) const [inline]

Get an iterator that points to beyond the last scatter buffer in the container.

Returns:
an iterator object.

Definition at line 389 of file ScatterBufferHelper.h.

ACTIV_BASE_EXPORTED_API StatusCode Activ::ScatterBufferHelper::Get | ( | const size_t | offset,
 |  | const void *& | pData,
 |  | const size_t | dataLength,
 |  | size_t & | dataLengthRead |
 | ) |  |  | const

Get data from the scatter buffer.

offset the offset to get from. pData reference to the address of the data. dataLength the length to get. dataLengthRead the length read.

Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_HEAP_EMPTY

ACTIV_BASE_EXPORTED_API StatusCode Activ::ScatterBufferHelper::Get | ( | const void *& | pData,
 |  | size_t & | dataLength,
 |  | void * | pGetBuffer = 0,
 |  | const size_t | getBufferSize = 0 |
 | ) |  |  | const

Get data.

Parameters:
pData | reference to the address of the data.
dataLength | the length got.
pGetBuffer | buffer to be used if data not contiguous.
getBufferSize | the size of the get buffer.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_HEAP_EMPTY

ACTIV_BASE_EXPORTED_API StatusCode Activ::ScatterBufferHelper::Get | ( | const size_t | offset,
 |  | const void *& | pData,
 |  | const size_t | dataLength,
 |  | void * | pGetBuffer = 0 |
 | ) |  |  | const

Get data from the scatter buffer.

Parameters:
offset | the offset to get from.
pData | reference to the address of the data.
dataLength | the length to get.
pGetBuffer | pointer to an optional buffer (used if data not contiguous).
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_HEAP_EMPTY

size_t Activ::ScatterBufferHelper::GetNumberOfScatterBuffersInUse ( ) const [inline]

Get the number of scatter buffers currently in use.

Returns:
the number of scatter buffers in use.

Definition at line 375 of file ScatterBufferHelper.h.

size_t Activ::ScatterBufferHelper::GetTotalBytes ( ) const [inline]

Get the total number of bytes in the scatter buffer list.

Returns:
The total number of bytes in the scatter buffer list.

Definition at line 368 of file ScatterBufferHelper.h.

ACTIV_BASE_EXPORTED_API ScatterBufferHelper& Activ::ScatterBufferHelper::operator= ( const ScatterBufferHelper & rhs )

Assignment operator.

Parameters:
rhs the value to assign to this object.
Returns:
a reference to this object.
Exceptions:
StatusCodeException

StatusCode Activ::ScatterBufferHelper::Reset ( const size_t nInitialScatterBuffers ) [inline]

Reset the number of buffers in use.

Parameters:
nInitialScatterBuffers the number of scatter buffers to allocate initially.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_HEAP_EMPTY

Definition at line 347 of file ScatterBufferHelper.h.

References ACTIV_RETURN_RESULT_IF.

ACTIV_BASE_EXPORTED_API StatusCode Activ::ScatterBufferHelper::Set | ( | const size_t | offset,
 |  | const ScatterBufferHelper & | from,
 |  | const size_t | fromOffset,
 |  | const size_t | dataLength
 | ) |  |

Set data in the scatter buffer.

offset the offset to set at. from the scatterBufferHelper to copy the data from. fromOffset the offset to copy the data from. dataLength the length to set.

Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER

ACTIV_BASE_EXPORTED_API StatusCode Activ::ScatterBufferHelper::Set | ( | const size_t | offset,
 |  | const void * | pData,
 |  | const size_t | dataLength
 | ) |  |

Set data in the scatter buffer.

offset the offset to set at. pData the address of the data. dataLength the length to set.

Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivBase/ScatterBufferHelper.h
Generated on Wed Oct 8 14:01:58 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ScatterBufferHelper::ConstIterator

Activ::ScatterBufferHelper::ConstIterator Class Reference

Scatter buffer const iterator class. More...

#include <ActivMiddleware/ActivBase/ScatterBufferHelper.h>

List of all members.

Public Member Functions

ACTIV_BASE_INLINE_API | ConstIterator ()
Default constructor.
ACTIV_BASE_INLINE_API const
ScatterBuffer & 		operator * () const
Dereference operator.
ACTIV_BASE_INLINE_API bool | operator!= (const ConstIterator &rhs) const
Inequality operator.
ACTIV_BASE_INLINE_API const
ConstIterator 		operator++ (int)
Postfix increment operator.
ACTIV_BASE_INLINE_API
ConstIterator & 		operator++ ()
Prefix increment operator.
ACTIV_BASE_INLINE_API const
ScatterBuffer * 		operator-> () const
Member access operator.
ACTIV_BASE_INLINE_API bool | operator== (const ConstIterator &rhs) const
Equality operator.

Friends

class | ScatterBufferHelper

Detailed Description

Scatter buffer const iterator class.

Definition at line 37 of file ScatterBufferHelper.h.

Member Function Documentation

const ScatterBufferHelper::ScatterBuffer & Activ::ScatterBufferHelper::ConstIterator::operator * ( ) const [inline]

Dereference operator.

Returns:
Reference to the current message.

Definition at line 405 of file ScatterBufferHelper.h.

bool Activ::ScatterBufferHelper::ConstIterator::operator!= ( const ConstIterator & rhs ) const [inline]

Inequality operator.

Parameters:
rhs the object to test against.
Returns:
whether the two objects are not equal.

Definition at line 446 of file ScatterBufferHelper.h.

const ScatterBufferHelper::ConstIterator Activ::ScatterBufferHelper::ConstIterator::operator++ ( int ) [inline]

Postfix increment operator.

Returns:
Copy of the original object.

Definition at line 428 of file ScatterBufferHelper.h.

ScatterBufferHelper::ConstIterator & Activ::ScatterBufferHelper::ConstIterator::operator++ ( ) [inline]

Prefix increment operator.

Returns:
Reference to the updated object.

Definition at line 419 of file ScatterBufferHelper.h.

const ScatterBufferHelper::ScatterBuffer * Activ::ScatterBufferHelper::ConstIterator::operator-> ( ) const [inline]

Member access operator.

Returns:
Pointer to the current message.

Definition at line 412 of file ScatterBufferHelper.h.

bool Activ::ScatterBufferHelper::ConstIterator::operator== ( const ConstIterator & rhs ) const [inline]

Equality operator.

Parameters:
rhs the object to test against.
Returns:
whether the two objects are equal.

Definition at line 439 of file ScatterBufferHelper.h.

References m_pScatterBuffer, and m_pScatterBufferHelper.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivBase/ScatterBufferHelper.h
Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ScatterBufferHelper::ScatterBuffer

Activ::ScatterBufferHelper::ScatterBuffer Class Reference

Scatter buffer class. More...

#include <ActivMiddleware/ActivBase/ScatterBufferHelper.h>

List of all members.

Public Attributes

size_t | m_dataLength
the length of the data.
void * | m_pData
pointer to the data.

Detailed Description

Scatter buffer class.

Definition at line 27 of file ScatterBufferHelper.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivBase/ScatterBufferHelper.h
Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ScopedAddress

Activ::ScopedAddress Class Reference

Scoped address. More...

#include <ActivMiddleware/ActivSystem/ScopedAddress.h>

List of all members.

Public Member Functions

ACTIV_SYSTEM_EXPORTED_API void | Clear ()
Clear the current address.
ACTIV_SYSTEM_INLINE_API bool | IsValid () const
Is this a valid address?
ACTIV_SYSTEM_INLINE_API | operator const Address & () const
Const Address reference cast operator.
ACTIV_SYSTEM_INLINE_API | operator Proxy ()
Proxy cast operator.
ACTIV_SYSTEM_INLINE_API bool | operator!= (const Address &rhs) const
Inequality test operator.
ACTIV_SYSTEM_INLINE_API
ScopedAddress & 		operator= (ScopedAddress &rhs)
Assignment from ScopedAddress operator.
ACTIV_SYSTEM_INLINE_API
ScopedAddress & 		operator= (const Address &rhs)
Assignment from Address operator.
ACTIV_SYSTEM_INLINE_API bool | operator== (const Address &rhs) const
Equality test operator.
ACTIV_SYSTEM_INLINE_API void | Release ()
Clear the current address, but do not post a message to it.
ACTIV_SYSTEM_INLINE_API | ScopedAddress (ScopedAddress &scopedAddress)
Copy constructor.
ACTIV_SYSTEM_INLINE_API | ScopedAddress (Port &port, const Address &address)
Constructor.
ACTIV_SYSTEM_INLINE_API | ScopedAddress (Port &port)
Constructor.
ACTIV_SYSTEM_INLINE_API std::string | ToString () const
Convert the address to a string.
ACTIV_SYSTEM_INLINE_API | ~ScopedAddress ()
Destructor.

Classes

class | Proxy
ScopedAddress proxy class. More...

Detailed Description

Scoped address.

When a ScopedAddress goes out of scope, or is assigned a new value, a SYSTEM_MESSAGE_CLOSE_ADDRESS message is sent to the current address (if valid).

Definition at line 28 of file ScopedAddress.h.

Constructor & Destructor Documentation

Activ::ScopedAddress::ScopedAddress ( Port & port ) [inline]

Constructor.

Parameters:
port reference to the Port used to post a SYSTEM_MESSAGE_CLOSE_ADDRESS when this object goes out of scope.

Definition at line 197 of file ScopedAddress.h.

Activ::ScopedAddress::ScopedAddress | ( | Port & | port,
 |  | const Address & | address |
 | ) |  |  | [inline]

Constructor.

Parameters:
port | reference to the Port used to post a SYSTEM_MESSAGE_CLOSE_ADDRESS when this object goes out of scope.
address | initial Address value to assign.

Definition at line 204 of file ScopedAddress.h.

Activ::ScopedAddress::ScopedAddress ( ScopedAddress & scopedAddress ) [inline]

Copy constructor.

The Address stored in rhs is cleared.

Parameters:
scopedAddress the Address to assign from.

Definition at line 212 of file ScopedAddress.h.

Activ::ScopedAddress::~ScopedAddress ( ) [inline]

Destructor.

If the underlying address is valid, a SYSTEM_MESSAGE_CLOSE_ADDRESS is posted to it.

Definition at line 220 of file ScopedAddress.h.

References Clear().

Member Function Documentation

ACTIV_SYSTEM_EXPORTED_API void Activ::ScopedAddress::Clear ( )

Clear the current address.

If the current address is valid, a SYSTEM_MESSAGE_CLOSE_ADDRESS is posted to it.

Referenced by operator=(), and ~ScopedAddress().

bool Activ::ScopedAddress::IsValid ( ) const [inline]

Is this a valid address?

A valid address is one where endPointId is not INVALID_ENDPOINT_ID and portId is not INVALID_PORT_ID.

Returns:
Boolean.

Definition at line 241 of file ScopedAddress.h.

References Activ::Address::IsValid().

Activ::ScopedAddress::operator const Address & ( ) const [inline]

Const Address reference cast operator.

For the case where non-const access to the underlying object is required, a Proxy must be used to ensure correct SYSTEM_MESSAGE_CLOSE_ADDRESS behavior.

Returns:
Const reference to the underlying Address operator.

Definition at line 296 of file ScopedAddress.h.

Activ::ScopedAddress::operator ScopedAddress::Proxy ( ) [inline]

Proxy cast operator.

Returns:
A Proxy object wrapping this ScopedAddress object.

Definition at line 289 of file ScopedAddress.h.

bool Activ::ScopedAddress::operator!= ( const Address & rhs ) const [inline]

Inequality test operator.

Parameters:
rhs Address object to compare with.
Returns:
Boolean.

Definition at line 255 of file ScopedAddress.h.

ScopedAddress & Activ::ScopedAddress::operator= ( ScopedAddress & rhs ) [inline]

Assignment from ScopedAddress operator.

If the current address is valid, a SYSTEM_MESSAGE_CLOSE_ADDRESS is posted to it before assigning the new value. The Address stored in rhs is cleared.

Parameters:
rhs the Address to assign from.
Returns:
*this.

Definition at line 275 of file ScopedAddress.h.

References Activ::Address::Clear(), Clear(), and m_address.

ScopedAddress & Activ::ScopedAddress::operator= ( const Address & rhs ) [inline]

Assignment from Address operator.

If the current address is valid, a SYSTEM_MESSAGE_CLOSE_ADDRESS is posted to it before assigning the new value.

Parameters:
rhs the Address to assign from.
Returns:
*this.

Definition at line 262 of file ScopedAddress.h.

References Clear().

bool Activ::ScopedAddress::operator== ( const Address & rhs ) const [inline]

Equality test operator.

Parameters:
rhs Address object to compare with.
Returns:
Boolean.

Definition at line 248 of file ScopedAddress.h.

std::string Activ::ScopedAddress::ToString ( ) const [inline]

Convert the address to a string.

Returns:
String representation of the address, in the form "endPointId:portId".

Definition at line 234 of file ScopedAddress.h.

References Activ::Address::ToString().

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivSystem/ScopedAddress.h
Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ScopedAddress::Proxy

Activ::ScopedAddress::Proxy Class Reference

ScopedAddress proxy class. More...

#include <ActivMiddleware/ActivSystem/ScopedAddress.h>

Inheritance diagram for Activ::ScopedAddress::Proxy:

Activ::Address::Proxy

List of all members.

Public Member Functions

ACTIV_SYSTEM_INLINE_API | Proxy (ScopedAddress &scopedAddress)
Constructor.
ACTIV_SYSTEM_INLINE_API | ~Proxy ()
Destructor.

Detailed Description

ScopedAddress proxy class.

Definition at line 34 of file ScopedAddress.h.

Constructor & Destructor Documentation

Activ::ScopedAddress::Proxy::Proxy ( ScopedAddress & scopedAddress ) [inline]

Constructor.

Parameters:
scopedAddress reference to the ScopedAddress this object is to be a proxy for.

Definition at line 304 of file ScopedAddress.h.

Activ::ScopedAddress::Proxy::~Proxy ( ) [inline]

Destructor.

If the address was changed during the lifetime of this proxy, the ScopedAddress is reassigned the new value.

Definition at line 313 of file ScopedAddress.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivSystem/ScopedAddress.h
Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ScopedFd

Activ::ScopedFd Class Reference

Scoped file-descriptor helper. More...

#include <ActivMiddleware/Misc/ScopedHelper.h>

Inheritance diagram for Activ::ScopedFd:

Activ::ScopedHelper< int, boost::function< int(int)> >

List of all members.

Public Member Functions

ScopedFd (int fd)

Detailed Description

Scoped file-descriptor helper.

Will call close() on destruction if the fd is not -1.

Definition at line 141 of file ScopedHelper.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/Misc/ScopedHelper.h
Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ScopedFile

Activ::ScopedFile Class Reference

Scoped FILE helper. More...

#include <ActivMiddleware/Misc/ScopedHelper.h>

Inheritance diagram for Activ::ScopedFile:

Activ::ScopedHelper< FILE *, boost::function< int(FILE *)> >

List of all members.

Public Member Functions

ScopedFile (FILE *pFile)

Detailed Description

Scoped FILE helper.

Will call fclose() on destruction if the FILE* is not NULL.

Definition at line 123 of file ScopedHelper.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/Misc/ScopedHelper.h
Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ScopedHandle

Activ::ScopedHandle Class Reference

Scoped HANDLE helper. More...

#include <ActivMiddleware/Misc/ScopedHelper.h>

Inheritance diagram for Activ::ScopedHandle:

Activ::ScopedHelper< HANDLE, boost::function< BOOL(HANDLE)> >

List of all members.

Public Member Functions

ScopedHandle (HANDLE handle)

Classes

class IsValidHandle
Function object to check for a valid handle. More...

Detailed Description

Scoped HANDLE helper.

Will call CloseHandle() on destruction if the HANDLE is not NULL or INVALID_HANDLE_VALUE.

Definition at line 177 of file ScopedHelper.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/Misc/ScopedHelper.h
Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ScopedHandle::IsValidHandle

Activ::ScopedHandle::IsValidHandle Class Reference

Function object to check for a valid handle. More...

#include <ActivMiddleware/Misc/ScopedHelper.h>

List of all members.

Public Member Functions

bool operator() (const HANDLE handle)

Detailed Description

Function object to check for a valid handle.

Definition at line 183 of file ScopedHelper.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/Misc/ScopedHelper.h
Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ScopedHelper

Activ::ScopedHelper< T, D > Class Template Reference

Class which will call a function in its destructor based on a condition. More...

#include <ActivMiddleware/Misc/ScopedHelper.h>

List of all members.

Public Types

typedef boost::function< bool(T)> | Condition
condition function type

Public Member Functions

operator T ()
Accessor for underlying type T.
ScopedHelper (T object, D destructor, Condition condition=True())
Constructor.
~ScopedHelper ()
Destructor.

Classes

class | True
Simple unary function that returns true. More...

Detailed Description

template<typename T, typename D>
class Activ::ScopedHelper< T, D >

Class which will call a function in its destructor based on a condition.

T the type to wrap. D the function to call in the destructor. Should expect one parameter of type T.

Definition at line 33 of file ScopedHelper.h.

Constructor & Destructor Documentation

template<typename T, typename D>
Activ::ScopedHelper< T, D >::ScopedHelper | ( | T | object,
 |  | D | destructor,
 |  | Condition | condition = True() |
 | ) |  |  | [inline]

Constructor.

Parameters:
object | the object to wrap.
destructor | a function to call when this object is destructed, if condition is true.
condition | a function to call when this object is destructed, to determine whether to call destructor. The function expects will receive object as it's only parameter and should return bool. Defaults to a function object that always returns true.

Definition at line 59 of file ScopedHelper.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/Misc/ScopedHelper.h
Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ScopedHelper::True

Activ::ScopedHelper< T, D >::True Class Reference

Simple unary function that returns true. More...

#include <ActivMiddleware/Misc/ScopedHelper.h>

List of all members.

Public Member Functions

bool operator() (T) const

Detailed Description

template<typename T, typename D>
class Activ::ScopedHelper< T, D >::True

Simple unary function that returns true.

Definition at line 39 of file ScopedHelper.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/Misc/ScopedHelper.h
Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ScopedMemory

Activ::ScopedMemory< T > Class Template Reference

Scoped memory helper. More...

#include <ActivMiddleware/Misc/ScopedHelper.h>

Inheritance diagram for Activ::ScopedMemory< T >:

Activ::ScopedHelper< T, boost::function< void(void *)> >

List of all members.

Public Member Functions

ScopedMemory (void *pMem)
Constructor.

Detailed Description

template<typename T>
class Activ::ScopedMemory< T >

Scoped memory helper.

Templatized by the pointer type, e.g. char *.

Will call free() on destruction if the pointer is not NULL.

Definition at line 100 of file ScopedHelper.h.

Constructor & Destructor Documentation

template<typename T>
Activ::ScopedMemory< T >::ScopedMemory ( void * pMem ) [inline]

Constructor.

pMem memory allocated via malloc().

Definition at line 108 of file ScopedHelper.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/Misc/ScopedHelper.h
Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ScopedMutexLocker

Activ::ScopedMutexLocker Class Reference

Scoped mutex locking helper class. More...

#include <ActivMiddleware/ActivBase/MutexHelper.h>

List of all members.

Public Member Functions

ACTIV_BASE_INLINE_API | ScopedMutexLocker (const IMutex *const pMutex)
Constructor which obtains the mutex lock.
ACTIV_BASE_INLINE_API | ~ScopedMutexLocker ()
Destructor releases the mutex lock, if a non-null mutex pointer was provided to the constructor.

Detailed Description

Scoped mutex locking helper class.

The ScopedMutexLocker class wraps up locking / unlocking a mutex.

Definition at line 24 of file MutexHelper.h.

Constructor & Destructor Documentation

Activ::ScopedMutexLocker::ScopedMutexLocker ( const IMutex *const pMutex ) [inline]

Constructor which obtains the mutex lock.

Parameters:
pMutex pointer to the mutex to be locked. It can be null, in which case this is a no-op (as is the dtor).

Definition at line 49 of file MutexHelper.h.

References Activ::IMutex::Acquire().

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivBase/MutexHelper.h
Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ScopedMutexTryLocker

Activ::ScopedMutexTryLocker Class Reference

Try acquire mutex helper class. More...

#include <ActivMiddleware/ActivBase/MutexHelper.h>

List of all members.

Public Member Functions

ACTIV_BASE_INLINE_API void | Acquire ()
Acquire the mutex.
ACTIV_BASE_INLINE_API | operator bool () const
Is the mutex locked?
ACTIV_BASE_INLINE_API bool | operator! () const
Is the mutex NOT locked?
ACTIV_BASE_INLINE_API | ScopedMutexTryLocker (const IMutex *const pMutex)
Constructor. The constructor attempts to lock the mutex.
ACTIV_BASE_INLINE_API | ~ScopedMutexTryLocker ()
Destructor releases the mutex lock, if the lock was acquired.

Detailed Description

Try acquire mutex helper class.

The ScopedMutexTryLocker class wraps up try-locking / unlocking a mutex.

Definition at line 72 of file MutexHelper.h.

Constructor & Destructor Documentation

Activ::ScopedMutexTryLocker::ScopedMutexTryLocker ( const IMutex *const pMutex ) [inline]

Constructor. The constructor attempts to lock the mutex.

Parameters:
pMutex pointer to the mutex to be locked. It can be null. If a null mutex is provided, it is treated as if it is "locked". I.e. operator bool() will return true.

Definition at line 122 of file MutexHelper.h.

Member Function Documentation

void Activ::ScopedMutexTryLocker::Acquire ( ) [inline]

Acquire the mutex.

If the constructor acquired the mutex, this is a no-op. Otherwise, it will block until the mutex is unlocked by another thread.

Definition at line 138 of file MutexHelper.h.

References Activ::IMutex::Acquire().

Activ::ScopedMutexTryLocker::operator bool ( ) const [inline]

Is the mutex locked?

Returns:
boolean.

Definition at line 149 of file MutexHelper.h.

bool Activ::ScopedMutexTryLocker::operator! ( ) const [inline]

Is the mutex NOT locked?

Returns:
boolean.

Definition at line 156 of file MutexHelper.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivBase/MutexHelper.h
Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ScopedPooledObject

Activ::ScopedPooledObject< T > Class Template Reference

Helper class to get an object from an ObjectPool and return it when the helper goes out of scope. More...

#include <ActivMiddleware/Misc/ObjectPool.h>

List of all members.

Public Types

typedef T::ObjectType | ObjectType

Public Member Functions

const ObjectType & | operator() () const
Object accessor.
ObjectType & | operator() ()
Object accessor.
ScopedPooledObject ()
Constructor.
~ScopedPooledObject ()
Destructor.

Detailed Description

template<typename T>
class Activ::ScopedPooledObject< T >

Helper class to get an object from an ObjectPool and return it when the helper goes out of scope.

T is the ObjectPool type.

Definition at line 132 of file ObjectPool.h.

Constructor & Destructor Documentation

template<typename T>
Activ::ScopedPooledObject< T >::ScopedPooledObject ( ) [inline]

Constructor.

Exceptions:
Exception if can't allocate an object from the pool.

Definition at line 313 of file ObjectPool.h.

References ACTIV_THROW.

template<typename T>
Activ::ScopedPooledObject< T >::~ScopedPooledObject ( ) [inline]

Destructor.

Returns the object to the pool.

Definition at line 323 of file ObjectPool.h.

Member Function Documentation

template<typename T>
const T::ObjectType & Activ::ScopedPooledObject< T >::operator() ( ) const [inline]

Object accessor.

Returns:
Const reference to the object.

Definition at line 339 of file ObjectPool.h.

template<typename T>
T::ObjectType & Activ::ScopedPooledObject< T >::operator() ( ) [inline]

Object accessor.

Returns:
Reference to the object.

Definition at line 331 of file ObjectPool.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/Misc/ObjectPool.h
Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ScopedSocket

Activ::ScopedSocket Class Reference

Scoped socket helper. More...

#include <ActivMiddleware/Misc/ScopedHelper.h>

Inheritance diagram for Activ::ScopedSocket:

Activ::ScopedHelper< SOCKET, boost::function< int(SOCKET)> >

List of all members.

Public Member Functions

ScopedSocket (SOCKET socket)

Detailed Description

Scoped socket helper.

Will call closesocket() on destruction if the socket is not INVALID_SOCKET.

Definition at line 158 of file ScopedHelper.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/Misc/ScopedHelper.h
Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ScopedSubscription

Activ::ScopedSubscription Class Reference

Scoped subscription helper. More...

#include <ActivMiddleware/ActivFramework/PubSubServiceApi.h>

List of all members.

Public Member Functions

ACTIV_FRAMEWORK_API | ScopedSubscription (const Component &component, const AgentScope agentScope, const Subject &subject)
Constructor.
ACTIV_FRAMEWORK_API StatusCode | Unsubscribe ()
Unsubscribes.
ACTIV_FRAMEWORK_API | ~ScopedSubscription ()
Destructor.

Detailed Description

Scoped subscription helper.

Definition at line 190 of file PubSubServiceApi.h.

Constructor & Destructor Documentation

ACTIV_FRAMEWORK_API Activ::ScopedSubscription::ScopedSubscription | ( | const Component & | component,
 |  | const AgentScope | agentScope,
 |  | const Subject & | subject
 | ) |  |

Constructor.

Subscribes the component to the given subject at the given scope.

Parameters:
component
agentScope
subject
Exceptions:
Exception if unable to subscribe.

ACTIV_FRAMEWORK_API Activ::ScopedSubscription::~ScopedSubscription ( )

Destructor.

Unsubscribes if the subscription is still in place.

Member Function Documentation

ACTIV_FRAMEWORK_API StatusCode Activ::ScopedSubscription::Unsubscribe ( )

Unsubscribes.

Returns:
STATUS_CODE_SUCCESS or reason for failed unsubscription.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivFramework/PubSubServiceApi.h
Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::SelectFirst

Activ::SelectFirst< P > Class Template Reference

Unary function object to return the first element of a pair. More...

#include <ActivMiddleware/Misc/StlHelper.h>

List of all members.

Public Types

typedef std::unary_function< P,
typename P::first_type > 		Base

Public Member Functions

const Base::result_type & operator() (const typename Base::argument_type &p) const
Function operator.

Detailed Description

template<typename P>
class Activ::SelectFirst< P >

Unary function object to return the first element of a pair.

Parameters:
P pair type (or any type with a first member and a first_type typedef).

Definition at line 292 of file StlHelper.h.

Member Function Documentation

template<typename P>
const Base::result_type& Activ::SelectFirst< P >::operator() ( const typename Base::argument_type & p ) const [inline]

Function operator.

Parameters:
p reference to an object of type P.
Returns:
Const reference to p.first

Definition at line 304 of file StlHelper.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/Misc/StlHelper.h
Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::SelectFirstFromSecond

Activ::SelectFirstFromSecond< P > Class Template Reference

Unary function object to return the first element of a pair, given the second element. More...

#include <ActivMiddleware/Misc/StlHelper.h>

List of all members.

Public Types

typedef std::unary_function
< typename Pair::second_type,
typename Pair::first_type > 		Base
typedef P | Pair

Public Member Functions

const Base::result_type & | operator() (const typename Base::argument_type &second) const
Function operator.

Detailed Description

template<typename P>
class Activ::SelectFirstFromSecond< P >

Unary function object to return the first element of a pair, given the second element.

Parameters:
P pair type (or any type with a second member and a second_type typedef).

Definition at line 344 of file StlHelper.h.

Member Function Documentation

template<typename P>
const Base::result_type& Activ::SelectFirstFromSecond< P >::operator() ( const typename Base::argument_type & second ) const [inline]

Function operator.

Parameters:
second reference to an object of type P::second_type.
Returns:
Const reference to the first member of the pair second is itself a member of.

Definition at line 357 of file StlHelper.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/Misc/StlHelper.h
Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::SelectSecond

Activ::SelectSecond< P > Class Template Reference

Unary function object to return the second element of a pair. More...

#include <ActivMiddleware/Misc/StlHelper.h>

List of all members.

Public Types

typedef std::unary_function< P,
typename P::second_type > 		Base

Public Member Functions

const Base::result_type & operator() (const typename Base::argument_type &p) const
Function operator.

Detailed Description

template<typename P>
class Activ::SelectSecond< P >

Unary function object to return the second element of a pair.

Parameters:
P pair type (or any type with a second member and a second_type typedef).

Definition at line 318 of file StlHelper.h.

Member Function Documentation

template<typename P>
const Base::result_type& Activ::SelectSecond< P >::operator() ( const typename Base::argument_type & p ) const [inline]

Function operator.

Parameters:
p reference to an object of type P.
Returns:
Const reference to p.second

Definition at line 330 of file StlHelper.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/Misc/StlHelper.h
Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::SerializableBuffer

Activ::SerializableBuffer< LENGTH_TYPE, MIN_LENGTH, MAX_LENGTH > Class Template Reference

Serializable buffer template. More...

#include <ActivMiddleware/Misc/SerializableBuffer.h>

List of all members.

Public Types

typedef LENGTH_TYPE | Length

Public Member Functions

StatusCode | Deserialize (MessageValidator &messageValidator)
Deserialize.
const void * | GetData () const
Get pointer to data.
size_t | GetDataLength () const
Get length of data.
SerializableBuffer & | operator= (const SerializableBuffer &rhs)
Assignment operator.
SerializableBuffer (const SerializableBuffer &serializableBuffer)
Copy constructor.
SerializableBuffer ()
Default constructor.
StatusCode | Serialize (MessageBuilder &messageBuilder) const
Serialize.
StatusCode | Set (const void *pData, const size_t dataLength, const bool shouldCopy)
Set data pointer and length.
~SerializableBuffer ()
Destructor.

Static Public Member Functions

static StatusCode | Serialize (MessageBuilder &messageBuilder, const void *const pData, const size_t dataLength)
Serialize.

Detailed Description

template<typename LENGTH_TYPE, LENGTH_TYPE MIN_LENGTH = 0, LENGTH_TYPE MAX_LENGTH = boost::integer_traits<LENGTH_TYPE>::const_max>
class Activ::SerializableBuffer< LENGTH_TYPE, MIN_LENGTH, MAX_LENGTH >

Serializable buffer template.

Parameters:
LENGTH_TYPE | type of length to serialize.
MIN_LENGTH | min length of serializable buffer.
MAX_LENGTH | max length of serializable buffer.

Definition at line 27 of file SerializableBuffer.h.

Constructor & Destructor Documentation

template<typename LENGTH_TYPE, LENGTH_TYPE MIN_LENGTH, LENGTH_TYPE MAX_LENGTH>
Activ::SerializableBuffer< LENGTH_TYPE, MIN_LENGTH, MAX_LENGTH >::SerializableBuffer ( const SerializableBuffer< LENGTH_TYPE, MIN_LENGTH, MAX_LENGTH > & serializableBuffer ) [inline]

Copy constructor.

Parameters:
serializableBuffer to copy from.
Exceptions:
StatusCodeException.

Definition at line 148 of file SerializableBuffer.h.

Member Function Documentation

template<typename LENGTH_TYPE, LENGTH_TYPE MIN_LENGTH, LENGTH_TYPE MAX_LENGTH>
StatusCode Activ::SerializableBuffer< LENGTH_TYPE, MIN_LENGTH, MAX_LENGTH >::Deserialize ( MessageValidator & messageValidator ) [inline]

Deserialize.

Parameters:
messageValidator
Return values:
STATUS_CODE_SUCCESS.
...

Definition at line 257 of file SerializableBuffer.h.

References ACTIV_RETURN_RESULT_IF, Activ::MessageHandler::ENDIAN_LITTLE, Activ::MessageValidator::ValidateBinaryIntegral(), and Activ::MessageValidator::ValidateBytesCopy().

template<typename LENGTH_TYPE, LENGTH_TYPE MIN_LENGTH, LENGTH_TYPE MAX_LENGTH>
const void * Activ::SerializableBuffer< LENGTH_TYPE, MIN_LENGTH, MAX_LENGTH >::GetData ( ) const [inline]

Get pointer to data.

Returns:
Pointer to data.

Definition at line 213 of file SerializableBuffer.h.

Referenced by Activ::SerializableBuffer< LENGTH_TYPE, MIN_LENGTH, MAX_LENGTH >::operator=().

template<typename LENGTH_TYPE, LENGTH_TYPE MIN_LENGTH, LENGTH_TYPE MAX_LENGTH>
size_t Activ::SerializableBuffer< LENGTH_TYPE, MIN_LENGTH, MAX_LENGTH >::GetDataLength ( ) const [inline]

Get length of data.

Returns:
Length of data.

Definition at line 221 of file SerializableBuffer.h.

Referenced by Activ::ContentPlatform::ContentGatewayApi::FieldData::IsEmpty(), and Activ::SerializableBuffer< LENGTH_TYPE, MIN_LENGTH, MAX_LENGTH >::operator=().

template<typename LENGTH_TYPE, LENGTH_TYPE MIN_LENGTH, LENGTH_TYPE MAX_LENGTH>
SerializableBuffer< LENGTH_TYPE, MIN_LENGTH, MAX_LENGTH > & Activ::SerializableBuffer< LENGTH_TYPE, MIN_LENGTH, MAX_LENGTH >::operator= ( const SerializableBuffer< LENGTH_TYPE, MIN_LENGTH, MAX_LENGTH > & rhs ) [inline]

Assignment operator.

Returns:
*this.

Definition at line 169 of file SerializableBuffer.h.

References ACTIV_THROW_RESULT_IF, Activ::SerializableBuffer< LENGTH_TYPE, MIN_LENGTH, MAX_LENGTH >::GetData(), Activ::SerializableBuffer< LENGTH_TYPE, MIN_LENGTH, MAX_LENGTH >::GetDataLength(), Activ::SerializableBuffer< LENGTH_TYPE, MIN_LENGTH, MAX_LENGTH >::m_pBuffer, Activ::SerializableBuffer< LENGTH_TYPE, MIN_LENGTH, MAX_LENGTH >::m_pData, and Activ::SerializableBuffer< LENGTH_TYPE, MIN_LENGTH, MAX_LENGTH >::Set().

template<typename LENGTH_TYPE, LENGTH_TYPE MIN_LENGTH, LENGTH_TYPE MAX_LENGTH>
StatusCode Activ::SerializableBuffer< LENGTH_TYPE, MIN_LENGTH, MAX_LENGTH >::Serialize ( MessageBuilder & messageBuilder ) const [inline]

Serialize.

Parameters:
messageBuilder
Return values:
STATUS_CODE_SUCCESS.
...

Definition at line 249 of file SerializableBuffer.h.

References Activ::SerializableBuffer< LENGTH_TYPE, MIN_LENGTH, MAX_LENGTH >::Serialize().

template<typename LENGTH_TYPE, LENGTH_TYPE MIN_LENGTH, LENGTH_TYPE MAX_LENGTH>
StatusCode Activ::SerializableBuffer< LENGTH_TYPE, MIN_LENGTH, MAX_LENGTH >::Serialize | ( | MessageBuilder & | messageBuilder,
 |  | const void *const | pData,
 |  | const size_t | dataLength |
 | ) |  |  | [inline, static]

Serialize.

Parameters:
messageBuilder
pData | data to serialize.
dataLength | length of data to serialize.
Return values:
STATUS_CODE_SUCCESS.
...

Definition at line 229 of file SerializableBuffer.h.

References ACTIV_RETURN_RESULT_IF, Activ::MessageBuilder::Append(), and Activ::MessageHandler::ENDIAN_LITTLE.

Referenced by Activ::SerializableBuffer< LENGTH_TYPE, MIN_LENGTH, MAX_LENGTH >::Serialize().

template<typename LENGTH_TYPE, LENGTH_TYPE MIN_LENGTH, LENGTH_TYPE MAX_LENGTH>
StatusCode Activ::SerializableBuffer< LENGTH_TYPE, MIN_LENGTH, MAX_LENGTH >::Set | ( | const void * | pData,
 |  | const size_t | dataLength,
 |  | const bool | shouldCopy |
 | ) |  |  | [inline]

Set data pointer and length.

Parameters:
pData | pointer to data.
dataLength | length of data pointed to by pData.
shouldCopy | if true then data is copied into the object, otherwise just sets the pointer value and length.
Return values:
STATUS_CODE_SUCCESS.
...

Definition at line 184 of file SerializableBuffer.h.

References ACTIV_RETURN_RESULT_IF.

Referenced by Activ::SerializableBuffer< LENGTH_TYPE, MIN_LENGTH, MAX_LENGTH >::operator=().

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/Misc/SerializableBuffer.h
Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::SerializableContainerHelper

Activ::SerializableContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER > Class Template Reference

Helper class to serialize STL containers. More...

#include <ActivMiddleware/Misc/SerializableContainerHelper.h>

Inheritance diagram for Activ::SerializableContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >:

Activ::SerializableObjectContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH > Activ::SerializableObjectContainerHelper< hash_map< KEY_TYPE, MAPPED_TYPE, HASH_FN >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH > Activ::SerializableObjectContainerHelper< std::map< KEY_TYPE, MAPPED_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH > Activ::SerializableRawPointerContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH > Activ::SerializableRawPointerContainerHelper< hash_map< KEY_TYPE, MAPPED_TYPE, HASH_FN >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH > Activ::SerializableRawPointerContainerHelper< std::map< KEY_TYPE, MAPPED_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH > Activ::SerializableSmartPointerContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH > Activ::SerializableSmartPointerContainerHelper< hash_map< KEY_TYPE, MAPPED_TYPE, HASH_FN >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH > Activ::SerializableSmartPointerContainerHelper< std::map< KEY_TYPE, MAPPED_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH >

List of all members.

Public Types

typedef CONTAINER_TYPE | Container

Static Public Member Functions

static StatusCode | Deserialize (MessageValidator &messageValidator, Container &container, const bool shouldClearContainer)
Deserialize a container.
static StatusCode | Serialize (MessageBuilder &messageBuilder, const Container &container)
Serialize a container.

Detailed Description

template<typename CONTAINER_TYPE, typename COUNT_TYPE, COUNT_TYPE MIN_LENGTH, COUNT_TYPE MAX_LENGTH, typename OBJECT_HELPER>
class Activ::SerializableContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >

Helper class to serialize STL containers.

The OBJECT_HELPER template class must provide the following methods: static StatusCode Serialize(MessageBuilder &messageBuilder, const typename CONTAINER_TYPE::value_type &object) static StatusCode Deserialize(MessageValidator &messageValidator, typename CONTAINER_TYPE::value_type &object)

Derived classes are provided for containers of object, raw & smart pointers where the underlying object to be stored is either a bultin type or provides Serialize() and Deserialize() methods.

Parameters:
CONTAINER_TYPE | type of container.
COUNT_TYPE | type to use for container length in serialized form.
MIN_LENGTH | min allowed container length.
MAX_LENGTH | max allowed container length.
OBJECT_HELPER | class to (de)serialize objects stored in the container.

Definition at line 34 of file SerializableContainerHelper.h.

Member Function Documentation

template<typename CONTAINER_TYPE, typename COUNT_TYPE, COUNT_TYPE MIN_LENGTH, COUNT_TYPE MAX_LENGTH, typename OBJECT_HELPER>
static StatusCode Activ::SerializableContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >::Deserialize | ( | MessageValidator & | messageValidator,
 |  | Container & | container,
 |  | const bool | shouldClearContainer |
 | ) |  |  | [inline, static]

Deserialize a container.

Parameters:
messageValidator
container | container to deserialize.
shouldClearContainer | whether to empty the container first, or just add new entries.
Return values:
STATUS_CODE_SUCCESS
...

Definition at line 66 of file SerializableContainerHelper.h.

template<typename CONTAINER_TYPE, typename COUNT_TYPE, COUNT_TYPE MIN_LENGTH, COUNT_TYPE MAX_LENGTH, typename OBJECT_HELPER>
static StatusCode Activ::SerializableContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >::Serialize | ( | MessageBuilder & | messageBuilder,
 |  | const Container & | container |
 | ) |  |  | [inline, static]

Serialize a container.

Parameters:
messageBuilder
container container to serialize.
Return values:
STATUS_CODE_SUCCESS
...

Definition at line 48 of file SerializableContainerHelper.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/Misc/SerializableContainerHelper.h
Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::SerializableContainerHelper< hash_map< KEY_TYPE, MAPPED_TYPE, HASH_FN >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >

Activ::SerializableContainerHelper< hash_map< KEY_TYPE, MAPPED_TYPE, HASH_FN >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER > Class Template Reference

Specialization for hash_map containers. More...

#include <ActivMiddleware/Misc/Detail/SerializableContainerHelperSpecializations.h>

List of all members.

Public Types

typedef COUNT_TYPE | Count
typedef hash_map< KEY_TYPE,
MAPPED_TYPE, HASH_FN > 		Map
typedef OBJECT_HELPER | ObjectHelper

Static Public Member Functions

static StatusCode | Deserialize (MessageValidator &messageValidator, Map &map, const bool shouldClearContainer)
Deserialize a map.
static StatusCode | Serialize (MessageBuilder &messageBuilder, const Map &map)
Serialize a map.

Detailed Description

template<typename KEY_TYPE, typename MAPPED_TYPE, typename HASH_FN, typename COUNT_TYPE, COUNT_TYPE MIN_LENGTH, COUNT_TYPE MAX_LENGTH, typename OBJECT_HELPER>
class Activ::SerializableContainerHelper< hash_map< KEY_TYPE, MAPPED_TYPE, HASH_FN >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >

Specialization for hash_map containers.

Definition at line 301 of file SerializableContainerHelperSpecializations.h.

Member Function Documentation

template<typename KEY_TYPE, typename MAPPED_TYPE, typename HASH_FN, typename COUNT_TYPE, COUNT_TYPE MIN_LENGTH, COUNT_TYPE MAX_LENGTH, typename OBJECT_HELPER>
static StatusCode Activ::SerializableContainerHelper< hash_map< KEY_TYPE, MAPPED_TYPE, HASH_FN >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >::Deserialize | ( | MessageValidator & | messageValidator,
 |  | Map & | map,
 |  | const bool | shouldClearContainer |
 | ) |  |  | [inline, static]

Deserialize a map.

Parameters:
messageValidator
map | container to deserialize into.
shouldClearContainer | whether to empty the container first, or just add new entries.
Return values:
STATUS_CODE_SUCCESS
...

Definition at line 332 of file SerializableContainerHelperSpecializations.h.

template<typename KEY_TYPE, typename MAPPED_TYPE, typename HASH_FN, typename COUNT_TYPE, COUNT_TYPE MIN_LENGTH, COUNT_TYPE MAX_LENGTH, typename OBJECT_HELPER>
static StatusCode Activ::SerializableContainerHelper< hash_map< KEY_TYPE, MAPPED_TYPE, HASH_FN >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >::Serialize | ( | MessageBuilder & | messageBuilder,
 |  | const Map & | map |
 | ) |  |  | [inline, static]

Serialize a map.

Parameters:
messageBuilder
map container to serialize.
Return values:
STATUS_CODE_SUCCESS
...

Definition at line 317 of file SerializableContainerHelperSpecializations.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/Misc/Detail/SerializableContainerHelperSpecializations.h
Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::SerializableContainerHelper< std::list< OBJECT_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >

Activ::SerializableContainerHelper< std::list< OBJECT_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER > Class Template Reference

Specialization for list containers. More...

#include <ActivMiddleware/Misc/Detail/SerializableContainerHelperSpecializations.h>

List of all members.

Public Types

typedef COUNT_TYPE | Count
typedef std::list< OBJECT_TYPE > | List
typedef OBJECT_HELPER | ObjectHelper

Static Public Member Functions

static StatusCode | Deserialize (MessageValidator &messageValidator, List &list, const bool shouldClearContainer)
Deserialize a list.
static StatusCode | Serialize (MessageBuilder &messageBuilder, const List &list)
Serialize a list.

Detailed Description

template<typename OBJECT_TYPE, typename COUNT_TYPE, COUNT_TYPE MIN_LENGTH, COUNT_TYPE MAX_LENGTH, typename OBJECT_HELPER>
class Activ::SerializableContainerHelper< std::list< OBJECT_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >

Specialization for list containers.

Definition at line 91 of file SerializableContainerHelperSpecializations.h.

Member Function Documentation

template<typename OBJECT_TYPE, typename COUNT_TYPE, COUNT_TYPE MIN_LENGTH, COUNT_TYPE MAX_LENGTH, typename OBJECT_HELPER>
static StatusCode Activ::SerializableContainerHelper< std::list< OBJECT_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >::Deserialize | ( | MessageValidator & | messageValidator,
 |  | List & | list,
 |  | const bool | shouldClearContainer |
 | ) |  |  | [inline, static]

Deserialize a list.

Parameters:
messageValidator
list | container to deserialize into.
shouldClearContainer | whether to empty the container first, or just add new entries.
Return values:
STATUS_CODE_SUCCESS
...

Definition at line 122 of file SerializableContainerHelperSpecializations.h.

References ACTIV_RETURN_RESULT_IF, Activ::MessageHandler::ENDIAN_LITTLE, and Activ::MessageValidator::ValidateUnsignedBinaryIntegral().

template<typename OBJECT_TYPE, typename COUNT_TYPE, COUNT_TYPE MIN_LENGTH, COUNT_TYPE MAX_LENGTH, typename OBJECT_HELPER>
static StatusCode Activ::SerializableContainerHelper< std::list< OBJECT_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >::Serialize | ( | MessageBuilder & | messageBuilder,
 |  | const List & | list |
 | ) |  |  | [inline, static]

Serialize a list.

Parameters:
messageBuilder
list container to serialize.
Return values:
STATUS_CODE_SUCCESS
...

Definition at line 107 of file SerializableContainerHelperSpecializations.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/Misc/Detail/SerializableContainerHelperSpecializations.h
Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::SerializableContainerHelper< std::map< KEY_TYPE, MAPPED_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >

Activ::SerializableContainerHelper< std::map< KEY_TYPE, MAPPED_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER > Class Template Reference

Specialization for map containers. More...

#include <ActivMiddleware/Misc/Detail/SerializableContainerHelperSpecializations.h>

List of all members.

Public Types

typedef COUNT_TYPE | Count
typedef std::map< KEY_TYPE,
MAPPED_TYPE > 		Map
typedef OBJECT_HELPER | ObjectHelper

Static Public Member Functions

static StatusCode | Deserialize (MessageValidator &messageValidator, Map &map, const bool shouldClearContainer)
Deserialize a map.
static StatusCode | Serialize (MessageBuilder &messageBuilder, const Map &map)
Serialize a map.

Detailed Description

template<typename KEY_TYPE, typename MAPPED_TYPE, typename COUNT_TYPE, COUNT_TYPE MIN_LENGTH, COUNT_TYPE MAX_LENGTH, typename OBJECT_HELPER>
class Activ::SerializableContainerHelper< std::map< KEY_TYPE, MAPPED_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >

Specialization for map containers.

Definition at line 220 of file SerializableContainerHelperSpecializations.h.

Member Function Documentation

template<typename KEY_TYPE, typename MAPPED_TYPE, typename COUNT_TYPE, COUNT_TYPE MIN_LENGTH, COUNT_TYPE MAX_LENGTH, typename OBJECT_HELPER>
static StatusCode Activ::SerializableContainerHelper< std::map< KEY_TYPE, MAPPED_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >::Deserialize | ( | MessageValidator & | messageValidator,
 |  | Map & | map,
 |  | const bool | shouldClearContainer |
 | ) |  |  | [inline, static]

Deserialize a map.

Parameters:
messageValidator
map | container to deserialize into.
shouldClearContainer | whether to empty the container first, or just add new entries.
Return values:
STATUS_CODE_SUCCESS
...

Definition at line 251 of file SerializableContainerHelperSpecializations.h.

template<typename KEY_TYPE, typename MAPPED_TYPE, typename COUNT_TYPE, COUNT_TYPE MIN_LENGTH, COUNT_TYPE MAX_LENGTH, typename OBJECT_HELPER>
static StatusCode Activ::SerializableContainerHelper< std::map< KEY_TYPE, MAPPED_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >::Serialize | ( | MessageBuilder & | messageBuilder,
 |  | const Map & | map |
 | ) |  |  | [inline, static]

Serialize a map.

Parameters:
messageBuilder
map container to serialize.
Return values:
STATUS_CODE_SUCCESS
...

Definition at line 236 of file SerializableContainerHelperSpecializations.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/Misc/Detail/SerializableContainerHelperSpecializations.h
Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::SerializableContainerHelper< std::set< OBJECT_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >

Activ::SerializableContainerHelper< std::set< OBJECT_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER > Class Template Reference

Specialization for set containers. More...

#include <ActivMiddleware/Misc/Detail/SerializableContainerHelperSpecializations.h>

List of all members.

Public Types

typedef COUNT_TYPE | Count
typedef OBJECT_HELPER | ObjectHelper
typedef std::set< OBJECT_TYPE > | Set

Static Public Member Functions

static StatusCode | Deserialize (MessageValidator &messageValidator, Set &set, const bool shouldClearContainer)
Deserialize a set.
static StatusCode | Serialize (MessageBuilder &messageBuilder, const Set &set)
Serialize a set.

Detailed Description

template<typename OBJECT_TYPE, typename COUNT_TYPE, COUNT_TYPE MIN_LENGTH, COUNT_TYPE MAX_LENGTH, typename OBJECT_HELPER>
class Activ::SerializableContainerHelper< std::set< OBJECT_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >

Specialization for set containers.

Definition at line 160 of file SerializableContainerHelperSpecializations.h.

Member Function Documentation

template<typename OBJECT_TYPE, typename COUNT_TYPE, COUNT_TYPE MIN_LENGTH, COUNT_TYPE MAX_LENGTH, typename OBJECT_HELPER>
static StatusCode Activ::SerializableContainerHelper< std::set< OBJECT_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >::Deserialize | ( | MessageValidator & | messageValidator,
 |  | Set & | set,
 |  | const bool | shouldClearContainer |
 | ) |  |  | [inline, static]

Deserialize a set.

Parameters:
messageValidator
set | container to deserialize into.
shouldClearContainer | whether to empty the container first, or just add new entries.
Return values:
STATUS_CODE_SUCCESS
...

Definition at line 191 of file SerializableContainerHelperSpecializations.h.

References ACTIV_RETURN_RESULT_IF, Activ::MessageHandler::ENDIAN_LITTLE, and Activ::MessageValidator::ValidateUnsignedBinaryIntegral().

template<typename OBJECT_TYPE, typename COUNT_TYPE, COUNT_TYPE MIN_LENGTH, COUNT_TYPE MAX_LENGTH, typename OBJECT_HELPER>
static StatusCode Activ::SerializableContainerHelper< std::set< OBJECT_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >::Serialize | ( | MessageBuilder & | messageBuilder,
 |  | const Set & | set |
 | ) |  |  | [inline, static]

Serialize a set.

Parameters:
messageBuilder
set container to serialize.
Return values:
STATUS_CODE_SUCCESS
...

Definition at line 176 of file SerializableContainerHelperSpecializations.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/Misc/Detail/SerializableContainerHelperSpecializations.h
Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::SerializableContainerHelper< std::vector< OBJECT_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >

Activ::SerializableContainerHelper< std::vector< OBJECT_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER > Class Template Reference

SerializableContainerHelper specialization for std::vector containers. More...

#include <ActivMiddleware/Misc/Detail/SerializableContainerHelperSpecializations.h>

List of all members.

Public Types

typedef COUNT_TYPE | Count
typedef OBJECT_HELPER | ObjectHelper
typedef std::vector< OBJECT_TYPE > | Vector

Static Public Member Functions

static StatusCode | Deserialize (MessageValidator &messageValidator, Vector &vector, const bool shouldClearContainer)
Deserialize a vector.
static StatusCode | Serialize (MessageBuilder &messageBuilder, const Vector &vector)
Serialize a vector.

Detailed Description

template<typename OBJECT_TYPE, typename COUNT_TYPE, COUNT_TYPE MIN_LENGTH, COUNT_TYPE MAX_LENGTH, typename OBJECT_HELPER>
class Activ::SerializableContainerHelper< std::vector< OBJECT_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >

SerializableContainerHelper specialization for std::vector containers.

Definition at line 21 of file SerializableContainerHelperSpecializations.h.

Member Function Documentation

template<typename OBJECT_TYPE, typename COUNT_TYPE, COUNT_TYPE MIN_LENGTH, COUNT_TYPE MAX_LENGTH, typename OBJECT_HELPER>
static StatusCode Activ::SerializableContainerHelper< std::vector< OBJECT_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >::Deserialize | ( | MessageValidator & | messageValidator,
 |  | Vector & | vector,
 |  | const bool | shouldClearContainer |
 | ) |  |  | [inline, static]

Deserialize a vector.

Parameters:
messageValidator
vector | container to deserialize into.
shouldClearContainer | whether to empty the container first, or just add new entries.
Return values:
STATUS_CODE_SUCCESS
...

Definition at line 52 of file SerializableContainerHelperSpecializations.h.

References ACTIV_RETURN_RESULT_IF, Activ::MessageHandler::ENDIAN_LITTLE, and Activ::MessageValidator::ValidateUnsignedBinaryIntegral().

template<typename OBJECT_TYPE, typename COUNT_TYPE, COUNT_TYPE MIN_LENGTH, COUNT_TYPE MAX_LENGTH, typename OBJECT_HELPER>
static StatusCode Activ::SerializableContainerHelper< std::vector< OBJECT_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >::Serialize | ( | MessageBuilder & | messageBuilder,
 |  | const Vector & | vector |
 | ) |  |  | [inline, static]

Serialize a vector.

Parameters:
messageBuilder
vector container to serialize.
Return values:
STATUS_CODE_SUCCESS
...

Definition at line 37 of file SerializableContainerHelperSpecializations.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/Misc/Detail/SerializableContainerHelperSpecializations.h
Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::SerializableObjectContainerHelper

Activ::SerializableObjectContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH > Class Template Reference

Helper class to serialize containers of objects. More...

#include <ActivMiddleware/Misc/SerializableContainerHelper.h>

Inheritance diagram for Activ::SerializableObjectContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH >:

Activ::SerializableContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >

List of all members.

Detailed Description

template<typename CONTAINER_TYPE, typename COUNT_TYPE, COUNT_TYPE MIN_LENGTH = 0, COUNT_TYPE MAX_LENGTH = boost::integer_traits<COUNT_TYPE>::const_max>
class Activ::SerializableObjectContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH >

Helper class to serialize containers of objects.

The type of object being (de)serialized must provide the following methods: StatusCode Serialize(MessageBuilder &messageBuilder) const StatusCode Deserialize(MessageValidator &messageValidator)

unless the type is a builtin signed, unsigned or boolean type for which specializations are provided.

The class may then be used as follows, where MyClass is a class providing Serialize() and Deserialize() methods as described above.

typedef std::vector<MyClass> MyClassList; typedef SerializableObjectContainerHelper<MyClassList, uint8_t, 0, 10> MyClassListSerializer;

MyClassList myClassList;

if (STATUS_CODE_SUCCESS == MyClassListSerializer::Serialize(messageBuilder, myClassList)) ... if (STATUS_CODE_SUCCESS == MyClassListSerializer::Deserialize(messageValidator, myClassList)) ...

In this case, MyClassListSerializer will use one byte to serialize the length of the container, and the container can contain a maximum of 10 items otherwise (de)serialization will fail with STATUS_CODE_INVALID_LENGTH.

Parameters:
CONTAINER_TYPE | type of container.
COUNT_TYPE | type to use for container length in serialized form. Must be unsigned basic type.
MIN_LENGTH | min allowed container length, default is 0.
MAX_LENGTH | max allowed container length, default is max value of COUNT_TYPE.

Definition at line 107 of file SerializableContainerHelper.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/Misc/SerializableContainerHelper.h
Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::SerializableObjectContainerHelper< hash_map< KEY_TYPE, MAPPED_TYPE, HASH_FN >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH >

Activ::SerializableObjectContainerHelper< hash_map< KEY_TYPE, MAPPED_TYPE, HASH_FN >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH > Class Template Reference

Partial specialization of SerializableObjectContainerHelper to serialize hash_maps of objects. More...

#include <ActivMiddleware/Misc/Detail/SerializableContainerHelperSpecializations.h>

Inheritance diagram for Activ::SerializableObjectContainerHelper< hash_map< KEY_TYPE, MAPPED_TYPE, HASH_FN >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH >:

Activ::SerializableContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >

List of all members.

Detailed Description

template<typename KEY_TYPE, typename MAPPED_TYPE, typename HASH_FN, typename COUNT_TYPE, COUNT_TYPE MIN_LENGTH, COUNT_TYPE MAX_LENGTH>
class Activ::SerializableObjectContainerHelper< hash_map< KEY_TYPE, MAPPED_TYPE, HASH_FN >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH >

Partial specialization of SerializableObjectContainerHelper to serialize hash_maps of objects.

Definition at line 346 of file SerializableContainerHelperSpecializations.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/Misc/Detail/SerializableContainerHelperSpecializations.h
Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::SerializableObjectContainerHelper< std::map< KEY_TYPE, MAPPED_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH >

Activ::SerializableObjectContainerHelper< std::map< KEY_TYPE, MAPPED_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH > Class Template Reference

Partial specialization of SerializableObjectContainerHelper to serialize maps of objects. More...

#include <ActivMiddleware/Misc/Detail/SerializableContainerHelperSpecializations.h>

Inheritance diagram for Activ::SerializableObjectContainerHelper< std::map< KEY_TYPE, MAPPED_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH >:

Activ::SerializableContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >

List of all members.

Detailed Description

template<typename KEY_TYPE, typename MAPPED_TYPE, typename COUNT_TYPE, COUNT_TYPE MIN_LENGTH, COUNT_TYPE MAX_LENGTH>
class Activ::SerializableObjectContainerHelper< std::map< KEY_TYPE, MAPPED_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH >

Partial specialization of SerializableObjectContainerHelper to serialize maps of objects.

Definition at line 265 of file SerializableContainerHelperSpecializations.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/Misc/Detail/SerializableContainerHelperSpecializations.h
Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::SerializableObjectHelper

Activ::SerializableObjectHelper< OBJECT_TYPE > Class Template Reference

Helper class to (de)serialize objects. More...

#include <ActivMiddleware/Misc/Detail/SerializableContainerHelperDetail.h>

List of all members.

Static Public Member Functions

static StatusCode | Deserialize (MessageValidator &messageValidator, OBJECT_TYPE &object)
Deserialize an object.
static StatusCode | Serialize (MessageBuilder &messageBuilder, const OBJECT_TYPE &object)
Serialize an object.

Detailed Description

template<typename OBJECT_TYPE>
class Activ::SerializableObjectHelper< OBJECT_TYPE >

Helper class to (de)serialize objects.

Provides static member functions which wrap up the global SerializeObject() and DeserializeObject(). This class can then be used as a parameter to SerializableContainerHelper.

Definition at line 151 of file SerializableContainerHelperDetail.h.

Member Function Documentation

template<typename OBJECT_TYPE>
static StatusCode Activ::SerializableObjectHelper< OBJECT_TYPE >::Deserialize | ( | MessageValidator & | messageValidator,
 |  | OBJECT_TYPE & | object |
 | ) |  |  | [inline, static]

Deserialize an object.

Parameters:
messageValidator
object object to deserialize into.
Return values:
STATUS_CODE_SUCCESS
...

Definition at line 177 of file SerializableContainerHelperDetail.h.

template<typename OBJECT_TYPE>
static StatusCode Activ::SerializableObjectHelper< OBJECT_TYPE >::Serialize | ( | MessageBuilder & | messageBuilder,
 |  | const OBJECT_TYPE & | object |
 | ) |  |  | [inline, static]

Serialize an object.

Parameters:
messageBuilder
object object to serialize.
Return values:
STATUS_CODE_SUCCESS
...

Definition at line 163 of file SerializableContainerHelperDetail.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/Misc/Detail/SerializableContainerHelperDetail.h
Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::SerializableRawPointerContainerHelper

Activ::SerializableRawPointerContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH > Class Template Reference

Helper class to serialize containers of raw pointers to objects. More...

#include <ActivMiddleware/Misc/SerializableContainerHelper.h>

Inheritance diagram for Activ::SerializableRawPointerContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH >:

Activ::SerializableContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >

List of all members.

Detailed Description

template<typename CONTAINER_TYPE, typename COUNT_TYPE, COUNT_TYPE MIN_LENGTH = 0, COUNT_TYPE MAX_LENGTH = boost::integer_traits<COUNT_TYPE>::const_max>
class Activ::SerializableRawPointerContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH >

Helper class to serialize containers of raw pointers to objects.

The pointee type that is being (de)serialized must provide the following methods: StatusCode Serialize(MessageBuilder &messageBuilder) const StatusCode Deserialize(MessageValidator &messageValidator)

unless the type is a builtin signed, unsigned or boolean type for which specializations are provided.

The class may then be used as follows, where MyClass is a class providing Serialize() and Deserialize() methods as described above.

typedef std::set<MyClass *> MyClassList; typedef SerializableRawPointerContainerHelper<MyClassList, uint16_t> MyClassListSerializer;

MyClassList myClassList;

if (STATUS_CODE_SUCCESS == MyClassListSerializer::Serialize(messageBuilder, myClassList)) ... if (STATUS_CODE_SUCCESS == MyClassListSerializer::Deserialize(messageValidator, myClassList)) ...

In this case, MyClassListSerializer will use two bytes to serialize the length of the container, and the container can INT16_MAX number of elements.

Parameters:
CONTAINER_TYPE | type of container.
COUNT_TYPE | type to use for container length in serialized form. Must be unsigned basic type.
MIN_LENGTH | min allowed container length, default is 0.
MAX_LENGTH | max allowed container length, default is max value of COUNT_TYPE.

Definition at line 143 of file SerializableContainerHelper.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/Misc/SerializableContainerHelper.h
Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::SerializableRawPointerContainerHelper< hash_map< KEY_TYPE, MAPPED_TYPE, HASH_FN >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH >

Activ::SerializableRawPointerContainerHelper< hash_map< KEY_TYPE, MAPPED_TYPE, HASH_FN >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH > Class Template Reference

Partial specialization of SerializableRawPointerContainerHelper to serialize hash_maps of raw pointers to objects. More...

#include <ActivMiddleware/Misc/Detail/SerializableContainerHelperSpecializations.h>

Inheritance diagram for Activ::SerializableRawPointerContainerHelper< hash_map< KEY_TYPE, MAPPED_TYPE, HASH_FN >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH >:

Activ::SerializableContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >

List of all members.

Detailed Description

template<typename KEY_TYPE, typename MAPPED_TYPE, typename COUNT_TYPE, typename HASH_FN, COUNT_TYPE MIN_LENGTH, COUNT_TYPE MAX_LENGTH>
class Activ::SerializableRawPointerContainerHelper< hash_map< KEY_TYPE, MAPPED_TYPE, HASH_FN >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH >

Partial specialization of SerializableRawPointerContainerHelper to serialize hash_maps of raw pointers to objects.

Note that currently the key type must not be a pointer, the mapped type should be a raw pointer.

Definition at line 359 of file SerializableContainerHelperSpecializations.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/Misc/Detail/SerializableContainerHelperSpecializations.h
Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::SerializableRawPointerContainerHelper< std::map< KEY_TYPE, MAPPED_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH >

Activ::SerializableRawPointerContainerHelper< std::map< KEY_TYPE, MAPPED_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH > Class Template Reference

Partial specialization of SerializableRawPointerContainerHelper to serialize maps of raw pointers to objects. More...

#include <ActivMiddleware/Misc/Detail/SerializableContainerHelperSpecializations.h>

Inheritance diagram for Activ::SerializableRawPointerContainerHelper< std::map< KEY_TYPE, MAPPED_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH >:

Activ::SerializableContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >

List of all members.

Detailed Description

template<typename KEY_TYPE, typename MAPPED_TYPE, typename COUNT_TYPE, COUNT_TYPE MIN_LENGTH, COUNT_TYPE MAX_LENGTH>
class Activ::SerializableRawPointerContainerHelper< std::map< KEY_TYPE, MAPPED_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH >

Partial specialization of SerializableRawPointerContainerHelper to serialize maps of raw pointers to objects.

Note that currently the key type must not be a pointer, the mapped type should be a raw pointer.

Definition at line 278 of file SerializableContainerHelperSpecializations.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/Misc/Detail/SerializableContainerHelperSpecializations.h
Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::SerializableRawPointerHelper

Activ::SerializableRawPointerHelper< POINTER_TYPE > Class Template Reference

Helper class to (de)serialize raw pointers to objects. More...

#include <ActivMiddleware/Misc/Detail/SerializableContainerHelperDetail.h>

List of all members.

Public Types

typedef boost::remove_pointer
< POINTER_TYPE >::type 		ObjectType

Static Public Member Functions

static StatusCode | Deserialize (MessageValidator &messageValidator, POINTER_TYPE &pObject)
Deserialize an object.
static StatusCode | Serialize (MessageBuilder &messageBuilder, const POINTER_TYPE &pObject)
Serialize an object.

Detailed Description

template<typename POINTER_TYPE>
class Activ::SerializableRawPointerHelper< POINTER_TYPE >

Helper class to (de)serialize raw pointers to objects.

Provides static member functions which wrap up the global SerializeObject() and DeserializeObject(). This class can then be used as a parameter to SerializableContainerHelper.

Definition at line 248 of file SerializableContainerHelperDetail.h.

Member Function Documentation

template<typename POINTER_TYPE>
static StatusCode Activ::SerializableRawPointerHelper< POINTER_TYPE >::Deserialize | ( | MessageValidator & | messageValidator,
 |  | POINTER_TYPE & | pObject |
 | ) |  |  | [inline, static]

Deserialize an object.

Parameters:
messageValidator
pObject object to deserialize into.
Return values:
STATUS_CODE_SUCCESS
...

Definition at line 276 of file SerializableContainerHelperDetail.h.

template<typename POINTER_TYPE>
static StatusCode Activ::SerializableRawPointerHelper< POINTER_TYPE >::Serialize | ( | MessageBuilder & | messageBuilder,
 |  | const POINTER_TYPE & | pObject |
 | ) |  |  | [inline, static]

Serialize an object.

Parameters:
messageBuilder
pObject object to serialize.
Return values:
STATUS_CODE_SUCCESS
...

Definition at line 262 of file SerializableContainerHelperDetail.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/Misc/Detail/SerializableContainerHelperDetail.h
Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::SerializableSmartPointerContainerHelper

Activ::SerializableSmartPointerContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH > Class Template Reference

Helper class to serialize containers of smart pointers to objects. More...

#include <ActivMiddleware/Misc/SerializableContainerHelper.h>

Inheritance diagram for Activ::SerializableSmartPointerContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH >:

Activ::SerializableContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >

List of all members.

Detailed Description

template<typename CONTAINER_TYPE, typename COUNT_TYPE, COUNT_TYPE MIN_LENGTH = 0, COUNT_TYPE MAX_LENGTH = boost::integer_traits<COUNT_TYPE>::const_max>
class Activ::SerializableSmartPointerContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH >

Helper class to serialize containers of smart pointers to objects.

The pointee type that is being (de)serialized must provide the following methods: StatusCode Serialize(MessageBuilder &messageBuilder) const StatusCode Deserialize(MessageValidator &messageValidator)

unless the type is a builtin signed, unsigned or boolean type for which specializations are provided.

The class may then be used as follows, where MyClass is a class providing Serialize() and Deserialize() methods as described above.

typedef std::list<boost::shared_ptr<MyClass> > MyClassList; typedef SerializableRawPointerContainerHelper<MyClassList, uint16_t> MyClassListSerializer;

MyClassList myClassList;

if (STATUS_CODE_SUCCESS == MyClassListSerializer::Serialize(messageBuilder, myClassList)) ... if (STATUS_CODE_SUCCESS == MyClassListSerializer::Deserialize(messageValidator, myClassList)) ...

In this case, MyClassListSerializer will use two bytes to serialize the length of the container, and the container can have INT16_MAX number of elements.

Parameters:
CONTAINER_TYPE | type of container.
COUNT_TYPE | type to use for container length in serialized form. Must be unsigned basic type.
MIN_LENGTH | min allowed container length, default is 0.
MAX_LENGTH | max allowed container length, default is max value of COUNT_TYPE.

Definition at line 179 of file SerializableContainerHelper.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/Misc/SerializableContainerHelper.h
Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::SerializableSmartPointerContainerHelper< hash_map< KEY_TYPE, MAPPED_TYPE, HASH_FN >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH >

Activ::SerializableSmartPointerContainerHelper< hash_map< KEY_TYPE, MAPPED_TYPE, HASH_FN >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH > Class Template Reference

Partial specialization of helper class to serialize hash_maps of smart pointers to objects. More...

#include <ActivMiddleware/Misc/Detail/SerializableContainerHelperSpecializations.h>

Inheritance diagram for Activ::SerializableSmartPointerContainerHelper< hash_map< KEY_TYPE, MAPPED_TYPE, HASH_FN >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH >:

Activ::SerializableContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >

List of all members.

Detailed Description

template<typename KEY_TYPE, typename MAPPED_TYPE, typename COUNT_TYPE, typename HASH_FN, COUNT_TYPE MIN_LENGTH, COUNT_TYPE MAX_LENGTH>
class Activ::SerializableSmartPointerContainerHelper< hash_map< KEY_TYPE, MAPPED_TYPE, HASH_FN >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH >

Partial specialization of helper class to serialize hash_maps of smart pointers to objects.

Note that currently the key type must not be a pointer, the mapped type should be a smart pointer.

Definition at line 372 of file SerializableContainerHelperSpecializations.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/Misc/Detail/SerializableContainerHelperSpecializations.h
Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::SerializableSmartPointerContainerHelper< std::map< KEY_TYPE, MAPPED_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH >

Activ::SerializableSmartPointerContainerHelper< std::map< KEY_TYPE, MAPPED_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH > Class Template Reference

Partial specialization of helper class to serialize maps of smart pointers to objects. More...

#include <ActivMiddleware/Misc/Detail/SerializableContainerHelperSpecializations.h>

Inheritance diagram for Activ::SerializableSmartPointerContainerHelper< std::map< KEY_TYPE, MAPPED_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH >:

Activ::SerializableContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >

List of all members.

Detailed Description

template<typename KEY_TYPE, typename MAPPED_TYPE, typename COUNT_TYPE, COUNT_TYPE MIN_LENGTH, COUNT_TYPE MAX_LENGTH>
class Activ::SerializableSmartPointerContainerHelper< std::map< KEY_TYPE, MAPPED_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH >

Partial specialization of helper class to serialize maps of smart pointers to objects.

Note that currently the key type must not be a pointer, the mapped type should be a smart pointer.

Definition at line 291 of file SerializableContainerHelperSpecializations.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/Misc/Detail/SerializableContainerHelperSpecializations.h
Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::SerializableSmartPointerHelper

Activ::SerializableSmartPointerHelper< POINTER_TYPE > Class Template Reference

Helper class to (de)serialize smart pointers to objects. More...

#include <ActivMiddleware/Misc/Detail/SerializableContainerHelperDetail.h>

List of all members.

Public Types

typedef POINTER_TYPE::element_type | ObjectType
Underlying object type.

Static Public Member Functions

static StatusCode | Deserialize (MessageValidator &messageValidator, POINTER_TYPE &pObject)
Deserialize an object.
static StatusCode | Serialize (MessageBuilder &messageBuilder, const POINTER_TYPE &pObject)
Serialize an object.

Detailed Description

template<typename POINTER_TYPE>
class Activ::SerializableSmartPointerHelper< POINTER_TYPE >

Helper class to (de)serialize smart pointers to objects.

Smart pointer type must provide an element_type typedef for the underlying object type.

Provides static member functions which wrap up the global SerializeObject() and DeserializeObject(). This class can then be used as a parameter to SerializableContainerHelper.

Definition at line 195 of file SerializableContainerHelperDetail.h.

Member Function Documentation

template<typename POINTER_TYPE>
static StatusCode Activ::SerializableSmartPointerHelper< POINTER_TYPE >::Deserialize | ( | MessageValidator & | messageValidator,
 |  | POINTER_TYPE & | pObject |
 | ) |  |  | [inline, static]

Deserialize an object.

Parameters:
messageValidator
pObject object to deserialize into.
Return values:
STATUS_CODE_SUCCESS
...

Definition at line 223 of file SerializableContainerHelperDetail.h.

template<typename POINTER_TYPE>
static StatusCode Activ::SerializableSmartPointerHelper< POINTER_TYPE >::Serialize | ( | MessageBuilder & | messageBuilder,
 |  | const POINTER_TYPE & | pObject |
 | ) |  |  | [inline, static]

Serialize an object.

Parameters:
messageBuilder
pObject object to serialize.
Return values:
STATUS_CODE_SUCCESS
...

Definition at line 209 of file SerializableContainerHelperDetail.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/Misc/Detail/SerializableContainerHelperDetail.h
Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Service

Activ::Service Class Reference

Service class. More...

#include <ActivMiddleware/ActivFramework/Service.h>

Inheritance diagram for Activ::Service:

Activ::Component Activ::Port Activ::ChildService< T >

List of all members.

Public Member Functions

ACTIV_FRAMEWORK_API void | Close ()
Close all access points and accepted connections.
virtual ACTIV_FRAMEWORK_API
StatusCode 		Deregister ()
Deregister the service from any directory services.
ACTIV_FRAMEWORK_API const
ServiceInstance & 		GetServiceInstance () const
Get the service instance info.
virtual ACTIV_FRAMEWORK_API
StatusCode 		Register ()
Register the service with any configured directory services.
ACTIV_FRAMEWORK_API | Service (Application &application, ManagedEndPoint &managedEndPoint, const std::string &name, const ServiceInstance &serviceInstance, IHeap *const pHeap=0, const std::string &componentId=defaultComponentId)
Constructor.
ACTIV_FRAMEWORK_API | ~Service ()
Destructor.

Static Public Attributes

static ACTIV_FRAMEWORK_API
const ServiceAccessPointList 		emptyServiceAccessPointList
An empty access point list for a service.

Protected Member Functions

ACTIV_FRAMEWORK_API StatusCode | BuildOpenServiceResponse (HeapMessage &acceptMessage, OpenServiceResponse &openServiceResponse, const byte_t openServiceVersion) const
Build a response to an open service request.
virtual ACTIV_FRAMEWORK_API
StatusCode 		OnAccept (HeapMessage &acceptMessage)
A client is attempting to connect.
virtual ACTIV_FRAMEWORK_API
StatusCode 		ProcessOpenServiceRequest (HeapMessage &acceptMessage)
Process an open service request.
ACTIV_FRAMEWORK_API StatusCode | ValidateOpenServiceRequest (const HeapMessage &acceptMessage, OpenServiceRequest &openServiceRequest) const
Validate a received open service message.

Classes

class | AccessList
List of servers.

Detailed Description

Service class.

Definition at line 25 of file Service.h.

Constructor & Destructor Documentation

ACTIV_FRAMEWORK_API Activ::Service::Service | ( | Application & | application,
 |  | ManagedEndPoint & | managedEndPoint,
 |  | const std::string & | name,
 |  | const ServiceInstance & | serviceInstance,
 |  | IHeap *const | pHeap = 0,
 |  | const std::string & | componentId = defaultComponentId
 | ) |  |

Constructor.

Attaches this service to a managed endpoint at the next available slot. The service will get allocated a uuid.

Parameters:
application | Application object to attach to.
managedEndPoint | reference to a ManagedEndPoint object to which this port is to be attached.
name | name of the service.
serviceInstance | service id and access points for this service.
pHeap | heap to use for messaging, or 0 for the system heap.
componentId | the component id.
Exceptions:
Exception.

Member Function Documentation

ACTIV_FRAMEWORK_API StatusCode Activ::Service::BuildOpenServiceResponse | ( | HeapMessage & | acceptMessage,
 |  | OpenServiceResponse & | openServiceResponse,
 |  | const byte_t | openServiceVersion |
 | ) |  |  | const [protected]

Build a response to an open service request.

Parameters:
acceptMessage | as passed to OnAccept() and validated by ValidateOpenServiceRequest().
openServiceResponse | message to serialize as the response.
openServiceVersion | version of the open service message.
Return values:
STATUS_CODE_SUCCESS.
...

virtual ACTIV_FRAMEWORK_API StatusCode Activ::Service::Deregister ( ) [virtual]

Deregister the service from any directory services.

Return values:
STATUS_CODE_SUCCESS.
...

ACTIV_FRAMEWORK_API const ServiceInstance& Activ::Service::GetServiceInstance ( ) const

Get the service instance info.

Returns:
Reference to the service instance info.

virtual ACTIV_FRAMEWORK_API StatusCode Activ::Service::OnAccept ( HeapMessage & acceptMessage ) [protected, virtual]

A client is attempting to connect.

The default behaviour is to call ProcessOpenServiceRequest(). See Component::OnAccept() for more information.

Parameters:
acceptMessage
Returns:
Unused by the framework.

Reimplemented from Activ::Component.

virtual ACTIV_FRAMEWORK_API StatusCode Activ::Service::ProcessOpenServiceRequest ( HeapMessage & acceptMessage ) [protected, virtual]

Process an open service request.

This method is protected to allow processing of extended open service requests. By default it validates again the default open service request and builds a default open service response.

Parameters:
acceptMessage as passed to OnAccept().
Return values:
STATUS_CODE_SUCCESS
...

virtual ACTIV_FRAMEWORK_API StatusCode Activ::Service::Register ( ) [virtual]

Register the service with any configured directory services.

Return values:
STATUS_CODE_SUCCESS.
...

ACTIV_FRAMEWORK_API StatusCode Activ::Service::ValidateOpenServiceRequest | ( | const HeapMessage & | acceptMessage,
 |  | OpenServiceRequest & | openServiceRequest |
 | ) |  |  | const [protected]

Validate a received open service message.

An open service message is contained in the body of the message passed to OnAccept().

Parameters:
acceptMessage | as passed to OnAccept().
openServiceRequest | message to deserialize into.
Return values:
STATUS_CODE_SUCCESS.
...

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivFramework/Service.h
Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ServiceAccessPoint

Activ::ServiceAccessPoint Class Reference

Service access point class. More...

#include <ActivMiddleware/ActivFramework/ServiceTypes.h>

List of all members.

Public Member Functions

ACTIV_FRAMEWORK_API void | Clear ()
Clear members in access point.
ACTIV_FRAMEWORK_API StatusCode | Read (const IniFileParser::ConstKeyIterator &keyIterator)
Read service access point from an ini file key.
ACTIV_FRAMEWORK_API | ServiceAccessPoint (const std::string &url, const AgentScope agentScope)
Constructor.
ACTIV_FRAMEWORK_API | ServiceAccessPoint ()
Default constructor.
ACTIV_FRAMEWORK_API std::string | ToString () const
Convert to a string for display purposes.

Public Attributes

AgentScope | m_agentScope
std::string | m_url

Detailed Description

Service access point class.

Definition at line 30 of file ServiceTypes.h.

Constructor & Destructor Documentation

ACTIV_FRAMEWORK_API Activ::ServiceAccessPoint::ServiceAccessPoint | ( | const std::string & | url,
 |  | const AgentScope | agentScope
 | ) |  |

Constructor.

Parameters:
url url string.
agentScope

Member Function Documentation

ACTIV_FRAMEWORK_API StatusCode Activ::ServiceAccessPoint::Read ( const IniFileParser::ConstKeyIterator & keyIterator )

Read service access point from an ini file key.

Key is of the form url = scope:url or url = url

E.g. url = local:ams://:9005 url = global:ams://:9006 url = ams://:9007

Parameters:
keyIterator iterator to ini file key.
Return values:
STATUS_CODE_SUCCESS
...

ACTIV_FRAMEWORK_API std::string Activ::ServiceAccessPoint::ToString ( ) const

Convert to a string for display purposes.

Returns:
String.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivFramework/ServiceTypes.h
Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ServiceApi

Activ::ServiceApi Class Reference

Api to the access services. More...

#include <ActivMiddleware/ActivFramework/ServiceApi.h>

List of all members.

Static Public Member Functions

static ACTIV_FRAMEWORK_API
StatusCode 		CloseService (Component &component, ServiceHandle &serviceHandle)
Close a service.
static ACTIV_FRAMEWORK_API
StatusCode 		FindServices (const Component &component, const ServiceId &serviceId, const AgentScope agentScope, const std::string &attributeQuery, ServiceInstanceList &serviceInstanceList, const TimeoutPeriod timeout=Port::defaultTimeout)
Find all instances of a service by service id and return all access points.
static ACTIV_FRAMEWORK_API
StatusCode 		OpenService (Component &component, ServiceHandle &serviceHandle, const TimeoutPeriod timeout=Port::defaultTimeout, OpenServiceRequest *const pOpenServiceRequest=0, OpenServiceResponse *const pOpenServiceResponse=0)
Open a service.
static ACTIV_FRAMEWORK_API
StatusCode 		ValidateOpenServiceResponse (const HeapMessage &connectMessage, OpenServiceResponse &openServiceResponse)
Validate an open service response.

Detailed Description

Api to the access services.

Definition at line 25 of file ServiceApi.h.

Member Function Documentation

static ACTIV_FRAMEWORK_API StatusCode Activ::ServiceApi::CloseService | ( | Component & | component,
 |  | ServiceHandle & | serviceHandle |
 | ) |  |  | [static]

Close a service.

The close is handled asynchronously, as there may be data queued up on the endpoint from the service. At some point an OnDisconnect() callback will be invoked with circuitAddress == serviceHandle.m_serviceAddress.

Parameters:
component | reference to Component that opened the service.
serviceHandle | reference to a ServiceHandle object as filled in by a successful OpenService().
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_CONNECTED
...

static ACTIV_FRAMEWORK_API StatusCode Activ::ServiceApi::FindServices | ( | const Component & | component,
 |  | const ServiceId & | serviceId,
 |  | const AgentScope | agentScope,
 |  | const std::string & | attributeQuery,
 |  | ServiceInstanceList & | serviceInstanceList,
 |  | const TimeoutPeriod | timeout = Port::defaultTimeout |
 | ) |  |  | [static]

Find all instances of a service by service id and return all access points.

Parameters:
component | the component doing the find.
serviceId | id of the service to find.
agentScope | scope of the services to find (within this agent space or globally).
attributeQuery | an LDAP style attribute query. Pass empty string to not filter by attributes.
serviceInstanceList | to receive the results of the find.
timeout | how long to wait for the response, in ms.
Return values:
STATUS_CODE_SUCCESS.
STATUS_CODE_NOT_FOUND.
...

static ACTIV_FRAMEWORK_API StatusCode Activ::ServiceApi::OpenService | ( | Component & | component,
 |  | ServiceHandle & | serviceHandle,
 |  | const TimeoutPeriod | timeout = Port::defaultTimeout,
 |  | OpenServiceRequest *const | pOpenServiceRequest = 0,
 |  | OpenServiceResponse *const | pOpenServiceResponse = 0 |
 | ) |  |  | [static]

Open a service.

The m_serviceId member must contain the id of the service you wish to open and the m_url member must contain the access point of the service you wish to use.

On a successful return, the m_serviceAddress member will contain the proxied address for communction with the service.

If doing an asynchronous open (with timeout == 0), when the connection is established (OnConnect() invoked with circuitAddress == m_serviceAddress of serviceHandle), ValidateOpenServiceResponse() should be called. This verifies the service connected to is of the right type.

Parameters:
component | reference to Component wishing to open service.
serviceHandle | reference to a ServiceHandle object.
timeout | how long to wait for the connection to be established, in ms.
pOpenServiceRequest | optional user data to send in the open service message.
pOpenServiceResponse | optional data to receive from a sync response.
Return values:
STATUS_CODE_SUCCESS
...

static ACTIV_FRAMEWORK_API StatusCode Activ::ServiceApi::ValidateOpenServiceResponse | ( | const HeapMessage & | connectMessage,
 |  | OpenServiceResponse & | openServiceResponse |
 | ) |  |  | [static]

Validate an open service response.

Parameters:
connectMessage | as passed to Component::OnConnect().
openServiceResponse | to deserialize into.
Return values:
STATUS_CODE_SUCCESS.
...

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivFramework/ServiceApi.h
Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ServiceHandle

Activ::ServiceHandle Class Reference

Parameters to OpenService() apis. More...

#include <ActivMiddleware/ActivFramework/ServiceTypes.h>

List of all members.

Public Member Functions

ACTIV_FRAMEWORK_API void | Clear ()
Clear down.
ACTIV_FRAMEWORK_API | ServiceHandle (const ServiceId &serviceId, const std::string &url)
Constructor.
ACTIV_FRAMEWORK_API | ServiceHandle ()
Default constructor.

Public Attributes

Address m_serviceAddress
Local proxied address of the service.
ServiceId m_serviceId
Id of the service.
std::string | m_url
Url to the service.

Detailed Description

Parameters to OpenService() apis.

Definition at line 214 of file ServiceTypes.h.

Constructor & Destructor Documentation

ACTIV_FRAMEWORK_API Activ::ServiceHandle::ServiceHandle | ( | const ServiceId & | serviceId,
 |  | const std::string & | url
 | ) |  |

Constructor.

Parameters:
serviceId id for the service.
url

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivFramework/ServiceTypes.h
Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ServiceId

Activ::ServiceId Class Reference

Service id class. More...

#include <ActivMiddleware/ActivFramework/ServiceTypes.h>

List of all members.

Public Member Functions

ACTIV_FRAMEWORK_API void | Clear ()
Clear down.
ACTIV_FRAMEWORK_API bool | operator!= (const ServiceId &rhs) const
Inequality operator.
ACTIV_FRAMEWORK_API bool | operator< (const ServiceId &rhs) const
Less than operator.
ACTIV_FRAMEWORK_API bool | operator== (const ServiceId &rhs) const
Equality operator.
ACTIV_FRAMEWORK_API | ServiceId (const std::string &id)
Constructor.
ACTIV_FRAMEWORK_API | ServiceId (const char *const id)
Constructor.
ACTIV_FRAMEWORK_API | ServiceId ()
Default constructor.
ACTIV_FRAMEWORK_API void | Set (const std::string &id)
Set the service id.
ACTIV_FRAMEWORK_API std::string | ToString () const
Get service id in string form.

Detailed Description

Service id class.

ServiceId uniquely identifies a particular type of service.

Definition at line 108 of file ServiceTypes.h.

Constructor & Destructor Documentation

ACTIV_FRAMEWORK_API Activ::ServiceId::ServiceId ( const char *const id )

Constructor.

Parameters:
id service id in c-string form.

ACTIV_FRAMEWORK_API Activ::ServiceId::ServiceId ( const std::string & id )

Constructor.

Parameters:
id service id in string form.

Member Function Documentation

ACTIV_FRAMEWORK_API void Activ::ServiceId::Set ( const std::string & id )

Set the service id.

Parameters:
id service id in string form.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivFramework/ServiceTypes.h
Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ServiceInstance

Activ::ServiceInstance Class Reference

Class representing an instance of a service and its locations. More...

#include <ActivMiddleware/ActivFramework/ServiceTypes.h>

List of all members.

Public Member Functions

ACTIV_FRAMEWORK_API void | Clear ()
Clear down.
ACTIV_FRAMEWORK_API | ServiceInstance (const ServiceId &serviceId, const ServiceAccessPointList &serviceAccessPointList, const std::string &attributes)
Constructor.
ACTIV_FRAMEWORK_API | ServiceInstance ()
Default constructor.

Public Attributes

std::string | m_attributes
Attributes for this service.
ServiceAccessPointList | m_serviceAccessPointList
All access points for this service.
ServiceId m_serviceId
Type of the service.

Detailed Description

Class representing an instance of a service and its locations.

Definition at line 174 of file ServiceTypes.h.

Constructor & Destructor Documentation

ACTIV_FRAMEWORK_API Activ::ServiceInstance::ServiceInstance | ( | const ServiceId & | serviceId,
 |  | const ServiceAccessPointList & | serviceAccessPointList,
 |  | const std::string & | attributes
 | ) |  |

Constructor.

Parameters:
serviceId
serviceAccessPointList
attributes

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivFramework/ServiceTypes.h
Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ServiceSubject

Activ::ServiceSubject Class Reference

Service subject type. By subscribing to this subject, a component can receive notifications of service registration / deregistration. More...

#include <ActivMiddleware/ActivFramework/ServiceTypes.h>

Inheritance diagram for Activ::ServiceSubject:

Activ::Subject

List of all members.

Public Member Functions

ACTIV_FRAMEWORK_API ServiceSubject ()
Constructor.

Detailed Description

Service subject type. By subscribing to this subject, a component can receive notifications of service registration / deregistration.

Definition at line 247 of file ServiceTypes.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivFramework/ServiceTypes.h
Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::SharedCompletionPortEventFactory

Activ::SharedCompletionPortEventFactory Class Reference

Shared completion-port based event factory class. More...

#include <ActivMiddleware/ActivBase/Windows/SharedCompletionPortEventFactory.h>

Inheritance diagram for Activ::SharedCompletionPortEventFactory:

Activ::Singleton< T >

List of all members.

Public Member Functions

ACTIV_BASE_EXPORTED_API IEvent * | Create (const std::string &name, const IEvent::Flags flags=IEvent::FLAG_NONE, const bool initialState=false, const HANDLE completionPortHandle=NULL)
Create an event.
ACTIV_BASE_EXPORTED_API IEvent * | Open (const std::string &name, Timeout &timeout=Timeout::GetInfinite())
Open an existing event.

Friends

class | Singleton< SharedCompletionPortEventFactory >

Detailed Description

Shared completion-port based event factory class.

Definition at line 23 of file SharedCompletionPortEventFactory.h.

Member Function Documentation

ACTIV_BASE_EXPORTED_API IEvent* Activ::SharedCompletionPortEventFactory::Create | ( | const std::string & | name,
 |  | const IEvent::Flags | flags = IEvent::FLAG_NONE,
 |  | const bool | initialState = false,
 |  | const HANDLE | completionPortHandle = NULL
 | ) |  |

Create an event.

Parameters:
name | the event name.
flags | creation flags.
initialState | whether the event is initially set upon creation.
completionPortHandle | completion port to use, or NULL to create.
Returns:
pointer to an object providing an IEvent interface.
Exceptions:
Exception

ACTIV_BASE_EXPORTED_API IEvent* Activ::SharedCompletionPortEventFactory::Open | ( | const std::string & | name,
 |  | Timeout & | timeout = Timeout::GetInfinite()
 | ) |  |

Open an existing event.

Parameters:
name | the event name.
timeout | how long to wait for the object to exist, in ms.
Returns:
pointer to an object providing an IEvent interface.
Exceptions:
Exception

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivBase/Windows/SharedCompletionPortEventFactory.h
Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::SharedEventFactory

Activ::SharedEventFactory Class Reference

Shared event factory class. More...

#include <ActivMiddleware/ActivBase/SharedEventFactory.h>

Inheritance diagram for Activ::SharedEventFactory:

Activ::Singleton< T >

List of all members.

Public Member Functions

ACTIV_BASE_EXPORTED_API IEvent * | Create (const std::string &name, const IEvent::Flags flags=IEvent::FLAG_NONE, const bool initialState=false)
Create an event.
ACTIV_BASE_EXPORTED_API IEvent * | Open (const std::string &name, Timeout &timeout=Timeout::GetInfinite())
Open an existing event.

Static Public Member Functions

static ACTIV_BASE_EXPORTED_API
SharedEventFactory & 		GetInstance ()
Get a reference to the singleton instance.

Friends

class | Singleton< SharedEventFactory >

Detailed Description

Shared event factory class.

Definition at line 25 of file SharedEventFactory.h.

Member Function Documentation

ACTIV_BASE_EXPORTED_API IEvent* Activ::SharedEventFactory::Create | ( | const std::string & | name,
 |  | const IEvent::Flags | flags = IEvent::FLAG_NONE,
 |  | const bool | initialState = false
 | ) |  |

Create an event.

Parameters:
name | the event name.
flags | creation flags.
initialState | whether the event is initially set upon creation.
Returns:
pointer to an object providing an IEvent interface.
Exceptions:
Exception

static ACTIV_BASE_EXPORTED_API SharedEventFactory& Activ::SharedEventFactory::GetInstance ( ) [static]

Get a reference to the singleton instance.

Returns:
Reference.

ACTIV_BASE_EXPORTED_API IEvent* Activ::SharedEventFactory::Open | ( | const std::string & | name,
 |  | Timeout & | timeout = Timeout::GetInfinite()
 | ) |  |

Open an existing event.

Parameters:
name | the event name.
timeout | how long to wait for the object to exist, in ms.
Returns:
pointer to an object providing an IEvent interface.
Exceptions:
Exception

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivBase/SharedEventFactory.h
Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::SharedMutexFactory

Activ::SharedMutexFactory Class Reference

Shared mutex factory class. More...

#include <ActivMiddleware/ActivBase/SharedMutexFactory.h>

Inheritance diagram for Activ::SharedMutexFactory:

Activ::Singleton< T >

List of all members.

Public Member Functions

ACTIV_BASE_EXPORTED_API IMutex * | Create (const std::string &name, const bool isInitialOwner=false)
Create a mutex.
ACTIV_BASE_EXPORTED_API IMutex * | Open (const std::string &name, Timeout &timeout=Timeout::GetInfinite())
Open an existing mutex.

Static Public Member Functions

static ACTIV_BASE_EXPORTED_API
SharedMutexFactory & 		GetInstance ()
Get a reference to the singleton instance.

Friends

class | Singleton< SharedMutexFactory >

Detailed Description

Shared mutex factory class.

Mutexes will, by default, be recursive. This can be overriden by setting the ACTIV_NON_RECURSIVE_MUTEX environment variable (to any value). This is a first step to switching to non-recursive mutexes.

On Posix, the environment variable ACTIV_COUNT_MUTEX_CONTENTION can be used to hackily count mutex contentions. It should only be used for temporary profiling, as it will incur a small performance hit. Windows always counts mutex contentions.

Definition at line 32 of file SharedMutexFactory.h.

Member Function Documentation

ACTIV_BASE_EXPORTED_API IMutex* Activ::SharedMutexFactory::Create | ( | const std::string & | name,
 |  | const bool | isInitialOwner = false
 | ) |  |

Create a mutex.

Parameters:
name | the mutex name.
isInitialOwner | whether the mutex is initially locked on creation.
Returns:
pointer to an object providing an IMutex interface.
Exceptions:
Exception.

static ACTIV_BASE_EXPORTED_API SharedMutexFactory& Activ::SharedMutexFactory::GetInstance ( ) [static]

Get a reference to the singleton instance.

Returns:
Reference.

ACTIV_BASE_EXPORTED_API IMutex* Activ::SharedMutexFactory::Open | ( | const std::string & | name,
 |  | Timeout & | timeout = Timeout::GetInfinite()
 | ) |  |

Open an existing mutex.

Parameters:
name | the mutex name.
timeout | how long to wait for the object to exist, in ms.
Returns:
pointer to an object providing an IMutex interface.
Exceptions:
Exception.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivBase/SharedMutexFactory.h
Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::SharedObject

Activ::SharedObject< T > Class Template Reference

Templatized shared object class. More...

#include <ActivMiddleware/ActivBase/SharedObject.h>

List of all members.

Public Member Functions

void | Create (const std::string &name, const IMappedMemory::MappingFlags mappingFlags=IMappedMemory::MAPPING_FLAG_UNIQUE, const size_t size=sizeof(T))
Create shared memory object.
T * | GetPointer () const
Get pointer to shared object.
size_t | GetSize () const
Get actual size of shared object (underlying mapped memory region).
bool | IsOpen () const
Is the shared object open?
void | Open (const std::string &name, const IMappedMemory::MappingFlags mappingFlags=IMappedMemory::MAPPING_FLAG_NONE, Timeout &timeout=Timeout::GetInfinite())
Open existing shared memory object.
SharedObject ()
Default constructor.
~SharedObject ()
Default destructor.

Detailed Description

template<class T>
class Activ::SharedObject< T >

Templatized shared object class.

Definition at line 23 of file SharedObject.h.

Member Function Documentation

template<class T>
void Activ::SharedObject< T >::Create | ( | const std::string & | name,
 |  | const IMappedMemory::MappingFlags | mappingFlags = IMappedMemory::MAPPING_FLAG_UNIQUE,
 |  | const size_t | size = sizeof(T) |
 | ) |  |  | [inline]

Create shared memory object.

Parameters:
name | the name of the object.
mappingFlags | flags indicating how the memory segment should be mapped.
size | the size of the object, by default the size of the class T.
Exceptions:
OsException
BaseException

Definition at line 116 of file SharedObject.h.

References Activ::PagingFileMappedMemoryFactory::Create(), Activ::PagingFileMappedMemoryFactory::GetInstance(), and Activ::IMappedMemory::GetPointer().

template<class T>
T * Activ::SharedObject< T >::GetPointer ( ) const [inline]

Get pointer to shared object.

Returns:
Pointer to shared object.

Definition at line 134 of file SharedObject.h.

template<class T>
size_t Activ::SharedObject< T >::GetSize ( ) const [inline]

Get actual size of shared object (underlying mapped memory region).

Returns:
Size.

Definition at line 142 of file SharedObject.h.

References Activ::IMappedMemory::GetSize().

template<class T>
void Activ::SharedObject< T >::Open | ( | const std::string & | name,
 |  | const IMappedMemory::MappingFlags | mappingFlags = IMappedMemory::MAPPING_FLAG_NONE,
 |  | Timeout & | timeout = Timeout::GetInfinite() |
 | ) |  |  | [inline]

Open existing shared memory object.

Parameters:
name | the name of the object.
mappingFlags | flags indicating how the memory segment should be mapped.
timeout | object specifying how long to wait for the object to exist, in ms.
Exceptions:
OsException.
BaseException

Definition at line 125 of file SharedObject.h.

References Activ::PagingFileMappedMemoryFactory::GetInstance(), Activ::IMappedMemory::GetPointer(), and Activ::PagingFileMappedMemoryFactory::Open().

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivBase/SharedObject.h
Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::SharedSemaphoreFactory

Activ::SharedSemaphoreFactory Class Reference

Shared semaphore factory class. More...

#include <ActivMiddleware/ActivBase/SharedSemaphoreFactory.h>

Inheritance diagram for Activ::SharedSemaphoreFactory:

Activ::Singleton< T >

List of all members.

Public Member Functions

ACTIV_BASE_EXPORTED_API
ISemaphore * 		Create (const std::string &name)
Create a named shared semaphore.
ACTIV_BASE_EXPORTED_API
ISemaphore * 		Open (const std::string &name, Timeout &timeout=Timeout::GetInfinite())
Open an existing named shared semaphore.

Static Public Member Functions

static ACTIV_BASE_EXPORTED_API
SharedSemaphoreFactory & 		GetInstance ()
Get a reference to the singleton instance.

Friends

class Singleton< SharedSemaphoreFactory >

Detailed Description

Shared semaphore factory class.

Definition at line 25 of file SharedSemaphoreFactory.h.

Member Function Documentation

ACTIV_BASE_EXPORTED_API ISemaphore* Activ::SharedSemaphoreFactory::Create ( const std::string & name )

Create a named shared semaphore.

Parameters:
name semaphore name.
Returns:
pointer to an object providing an ISemaphore interface.
Exceptions:
Exception

static ACTIV_BASE_EXPORTED_API SharedSemaphoreFactory& Activ::SharedSemaphoreFactory::GetInstance ( ) [static]

Get a reference to the singleton instance.

Returns:
Reference.

ACTIV_BASE_EXPORTED_API ISemaphore* Activ::SharedSemaphoreFactory::Open | ( | const std::string & | name,
 |  | Timeout & | timeout = Timeout::GetInfinite()
 | ) |  |

Open an existing named shared semaphore.

Parameters:
name | semaphore name.
timeout | how long to wait for the object to exist, in ms.
Returns:
pointer to an object providing an ISemaphore interface.
Exceptions:
Exception

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivBase/SharedSemaphoreFactory.h
Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Shell

Activ::Shell Class Reference

Command-line abstraction. More...

#include <ActivMiddleware/ActivBase/Shell.h>

List of all members.

Public Member Functions

ACTIV_BASE_EXPORTED_API StatusCode | Initialize ()
Initialize the shell.
ACTIV_BASE_EXPORTED_API void | Run ()
Poll for i/o for the shell.
ACTIV_BASE_EXPORTED_API | Shell ()
Default constructor.
virtual ACTIV_BASE_EXPORTED_API | ~Shell ()
Destructor.

Protected Member Functions

virtual StatusCode | OnInputString (std::string &inputString)=0
Called during Run() to check for input to send to the shell.
virtual StatusCode | OnOutputString (const std::string &outputString)=0
Called when the shell has outputted some text.

Detailed Description

Command-line abstraction.

Definition at line 22 of file Shell.h.

Constructor & Destructor Documentation

virtual ACTIV_BASE_EXPORTED_API Activ::Shell::~Shell ( ) [virtual]

Destructor.

If the shell is still running, it will be terminated.

Member Function Documentation

ACTIV_BASE_EXPORTED_API StatusCode Activ::Shell::Initialize ( )

Initialize the shell.

Returns:
STATUS_CODE_SUCCESS or some error code.

virtual StatusCode Activ::Shell::OnInputString ( std::string & inputString ) [protected, pure virtual]

Called during Run() to check for input to send to the shell.

An override of this call should ideally block for a while whilst (for example) waiting for user input, to stop Run() from busy-looping.

Parameters:
inputString to receive the input text.
Return values:
STATUS_CODE_SUCCESS | inputString will be sent to the shell
STATUS_CODE_EXIT | terminate the shell process (causes Run() to return)

virtual StatusCode Activ::Shell::OnOutputString ( const std::string & outputString ) [protected, pure virtual]

Called when the shell has outputted some text.

Parameters:
outputString the text output by the shell.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_EXIT terminate the shell process (causes Run() to return)

ACTIV_BASE_EXPORTED_API void Activ::Shell::Run ( )

Poll for i/o for the shell.

Loops endlessly, checking for the shell process to have exited.

Calls OnOutputString() when the shell has written some output.

Calls OnInputString() to check for text to send to the shell.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivBase/Shell.h
Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ShutdownSubject

Activ::ShutdownSubject Class Reference

Shutdown subject. More...

#include <ActivMiddleware/ActivFramework/Subjects.h>

Inheritance diagram for Activ::ShutdownSubject:

Activ::Subject

List of all members.

Public Member Functions

ShutdownSubject ()
Constructor.

Detailed Description

Shutdown subject.

Definition at line 42 of file Subjects.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivFramework/Subjects.h
Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Singleton

Activ::Singleton< T > Class Template Reference

Singleton template. More...

#include <ActivMiddleware/Misc/Singleton.h>

Inheritance diagram for Activ::Singleton< T >:

Activ::Database::ManagedTableFactory Activ::Database::RemoteTableFactory Activ::Database::UnmanagedTableFactory Activ::FieldTypeFactory Activ::FileMappedMemoryFactory Activ::ObjectPool< T, INITIAL_FREE_LIST_SIZE, MAX_FREE_LIST_SIZE > Activ::PagingFileMappedMemoryFactory Activ::PrivateEventFactory Activ::PrivateMutexFactory Activ::PrivateSemaphoreFactory Activ::SharedCompletionPortEventFactory Activ::SharedEventFactory Activ::SharedMutexFactory Activ::SharedSemaphoreFactory Activ::SystemFactory

List of all members.

Protected Member Functions

Singleton ()
Constructor.

Classes

class Initializer

Detailed Description

template<typename T>
class Activ::Singleton< T >

Singleton template.

To make a class a singleton, use as follows:

class MyFactory : public Singleton<MyFactory> { public: ... methods and members ...

MY_LIB_API static MyFactory &GetInstance();

private: // make the destructor private so instances of this object can't be created, other than by Singleton ~MyFactory();

// allow the base access to the destructor friend class Singleton<MyFactory>; };

In the .cpp file, define the GetInstance() function as follows:

MyFactory &MyFactory::GetInstance() { static MyFactory myFactory; return myFactory; }

The singleton can then be used as follows:

MyFactory::GetInstance().SomeFunction(...);

The Singleton class will ensure that the singleton instance is constructed before main(). This is a partial fix for a multithreaded race on construction of the instance; the assumption is that only one thread will be running before main() is invoked.

T must be default-constructible.

Definition at line 56 of file Singleton.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/Misc/Singleton.h
Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::SInt

Activ::SInt Class Reference

Signed integer class. More...

#include <ActivMiddleware/ActivFieldTypes/SInt.h>

Inheritance diagram for Activ::SInt:

Activ::IFieldType

List of all members.

Public Member Functions

ACTIV_FIELD_TYPES_API StatusCode | Add (const SInt &rhs)
Add.
virtual void | Clear ()
Clear the object.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		Compare (const void *const pRhsSerializedBody, const size_t rhsSerializedBodyLength, int &result) const
Compare.
ACTIV_FIELD_TYPES_API StatusCode | Compare (const SInt &rhs, int &result) const
Compare.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		Convert (const IFieldType *const pIFieldType)
Convert another IFieldType object to this type.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		Deserialize (MessageValidator &messageValidator, const size_t maxSerializedBodyLength)
Deserialize the object from the supplied message validator.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		DeserializeBody (const void *const pSerializedBody, const size_t serializedBodyLength)
Deserialize the object's body from the supplied data buffer.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		DeserializeLengthAndBody (MessageValidator &messageValidator, const size_t maxSerializedBodyLength=MAX_SERIALIZED_BODY_LENGTH_UNDEFINED)
Deserialize the object's length and body from the supplied message validator.
ACTIV_FIELD_TYPES_API StatusCode | Divide (const SInt &rhs)
Divide.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		FromString (MessageValidator &messageValidator)
Convert the object from a string.
int64_t | Get () const
Get the value.
StatusCode | Get (int64_t &value) const
Get the value.
virtual ACTIV_FIELD_TYPES_API
std::string 		GetFromStringFormat () const
Get a usage string for the format supported by FromString().
virtual size_t | GetSerializedBodyLength () const
Get the serialized length of the object's body.
virtual size_t | GetSerializedLength () const
Get the serialized length of the object.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		IsDifferent (const void *const pRhsSerializedBody, const size_t rhsSerializedBodyLength, bool &isDifferent) const
Is different.
ACTIV_FIELD_TYPES_API StatusCode | Multiply (const SInt &rhs)
Multiply.
SInt & | operator *= (const SInt &rhs)
Multiplication assignment operator.
ACTIV_FIELD_TYPES_API | operator const Rational () const
Rational conversion operator.
bool | operator!= (const SInt &rhs) const
Inequality operator.
SInt & | operator+= (const SInt &rhs)
Addition assignment operator.
SInt & | operator-= (const SInt &rhs)
Subtraction assignment operator.
SInt & | operator/= (const SInt &rhs)
Division assignment operator.
bool | operator< (const SInt &rhs) const
Less than operator.
bool | operator<= (const SInt &rhs) const
Less than or equal to operator.
bool | operator== (const SInt &rhs) const
Equality operator.
bool | operator> (const SInt &rhs) const
Greater than operator.
bool | operator>= (const SInt &rhs) const
Greater than or equal to operator.
virtual void | Reset ()
Reset the object.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		Serialize (MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength) const
Serialize the object into the supplied message builder.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		SerializeBody (void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength) const
Serialize the object's body into the supplied data buffer.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		SerializeLengthAndBody (MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength=MAX_SERIALIZED_BODY_LENGTH_UNDEFINED) const
Serialize the object's length and body into the supplied message builder.
StatusCode | Set (const int64_t value)
Set a new value.
SInt (const int64_t value)
Constructor.
SInt ()
Default constructor.
ACTIV_FIELD_TYPES_API StatusCode | Subtract (const SInt &rhs)
Subtract.
virtual ACTIV_FIELD_TYPES_API
std::string 		ToString () const
Convert the object to a string.
virtual | ~SInt ()
Destructor.

Static Public Member Functions

static ACTIV_FIELD_TYPES_API
StatusCode 		Compare (const void *const pLhsSerializedBody, const size_t lhsSerializedBodyLength, const void *const pRhsSerializedBody, const size_t rhsSerializedBodyLength, int &result)
Compare two objects serialized bodies.
static size_t | GetMaxSerializedBodyLength (const size_t size)
Get the maximum serialized length of the object's body.
static size_t | GetMaxSerializedLength (const size_t size)
Get the maximum serialized length of the object.
static bool | IsValidSerializedBodyLength (const size_t serializedBodyLength)
Is valid serialized body length.
static ACTIV_FIELD_TYPES_API
StatusCode 		ValidateSerializedLengthAndBody (MessageValidator &messageValidator, size_t &serializedBodyOffset, size_t &serializedBodyLength)
Validate the serialized length and body.

Static Public Attributes

static const FieldType | FIELD_TYPE = FIELD_TYPE_SINT
The field type.

Detailed Description

Signed integer class.

Definition at line 31 of file SInt.h.

Constructor & Destructor Documentation

Activ::SInt::SInt ( const int64_t value ) [inline]

Constructor.

Parameters:
value the value.

Definition at line 376 of file SInt.h.

References Set().

Member Function Documentation

ACTIV_FIELD_TYPES_API StatusCode Activ::SInt::Add ( const SInt & rhs )

Add.

Parameters:
rhs the value to add to this object.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED
STATUS_CODE_OUT_OF_RANGE

Referenced by operator+=().

static ACTIV_FIELD_TYPES_API StatusCode Activ::SInt::Compare | ( | const void *const | pLhsSerializedBody,
 |  | const size_t | lhsSerializedBodyLength,
 |  | const void *const | pRhsSerializedBody,
 |  | const size_t | rhsSerializedBodyLength,
 |  | int & | result |
 | ) |  |  | [static]

Compare two objects serialized bodies.

Parameters:
pLhsSerializedBody | the buffer containing the lhs serialized version of the object's body in.
lhsSerializedBodyLength | the lhs serialized body length.
pRhsSerializedBody | the buffer containing the rhs serialized version of the object's body in.
rhsSerializedBodyLength | the rhs serialized body length.
result | the result of the comparison.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::SInt::Compare | ( | const void *const | pRhsSerializedBody,
 |  | const size_t | rhsSerializedBodyLength,
 |  | int & | result |
 | ) |  |  | const [virtual]

Compare.

Parameters:
pRhsSerializedBody | the buffer containing the rhs serialized version of the object's body in.
rhsSerializedBodyLength | the rhs serialized body length.
result | the result of the comparison.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

ACTIV_FIELD_TYPES_API StatusCode Activ::SInt::Compare | ( | const SInt & | rhs,
 |  | int & | result |
 | ) |  |  | const

Compare.

Parameters:
rhs | the object to compare with.
result | the result of the comparison.
Return values:
STATUS_CODE_SUCCESS

Referenced by operator<(), operator==(), and operator>().

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::SInt::Convert ( const IFieldType *const pIFieldType ) [virtual]

Convert another IFieldType object to this type.

Parameters:
pIFieldType the value to assign from.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_MISMATCH
...

Implements Activ::IFieldType.

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::SInt::Deserialize | ( | MessageValidator & | messageValidator,
 |  | const size_t | maxSerializedBodyLength |
 | ) |  |  | [virtual]

Deserialize the object from the supplied message validator.

Parameters:
messageValidator | the message validator from which the object will be extracted.
maxSerializedBodyLength | the maximum serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::SInt::DeserializeBody | ( | const void *const | pSerializedBody,
 |  | const size_t | serializedBodyLength |
 | ) |  |  | [virtual]

Deserialize the object's body from the supplied data buffer.

Parameters:
pSerializedBody | the buffer from which the object's body will be extracted.
serializedBodyLength | the serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::SInt::DeserializeLengthAndBody | ( | MessageValidator & | messageValidator,
 |  | const size_t | maxSerializedBodyLength = MAX_SERIALIZED_BODY_LENGTH_UNDEFINED |
 | ) |  |  | [virtual]

Deserialize the object's length and body from the supplied message validator.

Parameters:
messageValidator | the message validator from which the object will be extracted.
maxSerializedBodyLength | the maximum serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

ACTIV_FIELD_TYPES_API StatusCode Activ::SInt::Divide ( const SInt & rhs )

Divide.

Parameters:
rhs the value to divide this object by.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED
STATUS_CODE_OUT_OF_RANGE

Referenced by operator/=().

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::SInt::FromString ( MessageValidator & messageValidator ) [virtual]

Convert the object from a string.

Parameters:
messageValidator the message validator.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

int64_t Activ::SInt::Get ( ) const [inline]

Get the value.

Returns:
the value.
Exceptions:
StatusCodeException

Definition at line 499 of file SInt.h.

References ACTIV_THROW, and Activ::IFieldType::IsInitialized().

StatusCode Activ::SInt::Get ( int64_t & value ) const [inline]

Get the value.

Parameters:
value the value.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED

Definition at line 487 of file SInt.h.

References Activ::IFieldType::IsInitialized().

virtual ACTIV_FIELD_TYPES_API std::string Activ::SInt::GetFromStringFormat ( ) const [virtual]

Get a usage string for the format supported by FromString().

Returns:
String, may be empty.

Implements Activ::IFieldType.

size_t Activ::SInt::GetMaxSerializedBodyLength ( const size_t size ) [inline, static]

Get the maximum serialized length of the object's body.

Parameters:
size the size of the data.
Returns:
the maximum serialized length of the object's body.

Definition at line 544 of file SInt.h.

Referenced by GetMaxSerializedLength(), GetSerializedBodyLength(), and IsValidSerializedBodyLength().

size_t Activ::SInt::GetMaxSerializedLength ( const size_t size ) [inline, static]

Get the maximum serialized length of the object.

Parameters:
size the size of the data.
Returns:
the maximum serialized length of the object.

Definition at line 537 of file SInt.h.

References GetMaxSerializedBodyLength().

Referenced by GetSerializedLength().

size_t Activ::SInt::GetSerializedBodyLength ( ) const [inline, virtual]

Get the serialized length of the object's body.

Returns:
the serialized length of the object's body.

Implements Activ::IFieldType.

Definition at line 530 of file SInt.h.

References GetMaxSerializedBodyLength(), and Activ::IFieldType::IsInitialized().

size_t Activ::SInt::GetSerializedLength ( ) const [inline, virtual]

Get the serialized length of the object.

Returns:
the serialized length of the object.

Implements Activ::IFieldType.

Definition at line 523 of file SInt.h.

References GetMaxSerializedLength(), and Activ::IFieldType::IsInitialized().

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::SInt::IsDifferent | ( | const void *const | pRhsSerializedBody,
 |  | const size_t | rhsSerializedBodyLength,
 |  | bool & | isDifferent |
 | ) |  |  | const [virtual]

Is different.

Parameters:
pRhsSerializedBody | the buffer containing the rhs serialized version of the object's body in.
rhsSerializedBodyLength | the rhs serialized body length.
isDifferent | indicates whether the two objects are different.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

bool Activ::SInt::IsValidSerializedBodyLength ( const size_t serializedBodyLength ) [inline, static]

Is valid serialized body length.

Parameters:
serializedBodyLength the serialized body length.
Returns:
whether the serialized body length is valid.

Definition at line 551 of file SInt.h.

References GetMaxSerializedBodyLength().

ACTIV_FIELD_TYPES_API StatusCode Activ::SInt::Multiply ( const SInt & rhs )

Multiply.

Parameters:
rhs the value to multiply this object by.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED
STATUS_CODE_OUT_OF_RANGE

Referenced by operator *=().

SInt & Activ::SInt::operator *= ( const SInt & rhs ) [inline]

Multiplication assignment operator.

Parameters:
rhs the value to multiply this object by.
Returns:
a reference to this object.
Exceptions:
StatusCodeException

Definition at line 459 of file SInt.h.

References ACTIV_THROW_RESULT_IF, and Multiply().

bool Activ::SInt::operator!= ( const SInt & rhs ) const [inline]

Inequality operator.

Parameters:
rhs the object to compare with.
Returns:
the result of the test.
Exceptions:
StatusCodeException

Definition at line 400 of file SInt.h.

SInt & Activ::SInt::operator+= ( const SInt & rhs ) [inline]

Addition assignment operator.

Parameters:
rhs the value to add to this object.
Returns:
a reference to this object.
Exceptions:
StatusCodeException

Definition at line 441 of file SInt.h.

References ACTIV_THROW_RESULT_IF, and Add().

SInt & Activ::SInt::operator-= ( const SInt & rhs ) [inline]

Subtraction assignment operator.

Parameters:
rhs the value to subtract from this object.
Returns:
a reference to this object.
Exceptions:
StatusCodeException

Definition at line 450 of file SInt.h.

References ACTIV_THROW_RESULT_IF, and Subtract().

SInt & Activ::SInt::operator/= ( const SInt & rhs ) [inline]

Division assignment operator.

Parameters:
rhs the value to divide this object by.
Returns:
a reference to this object.
Exceptions:
StatusCodeException

Definition at line 468 of file SInt.h.

References ACTIV_THROW_RESULT_IF, and Divide().

bool Activ::SInt::operator< ( const SInt & rhs ) const [inline]

Less than operator.

Parameters:
rhs the object to compare with.
Returns:
the result of the test.
Exceptions:
StatusCodeException

Definition at line 407 of file SInt.h.

References ACTIV_THROW_RESULT_IF, and Compare().

bool Activ::SInt::operator<= ( const SInt & rhs ) const [inline]

Less than or equal to operator.

Parameters:
rhs the object to compare with.
Returns:
the result of the test.
Exceptions:
StatusCodeException

Definition at line 417 of file SInt.h.

bool Activ::SInt::operator== ( const SInt & rhs ) const [inline]

Equality operator.

Parameters:
rhs the object to compare with.
Returns:
the result of the test.
Exceptions:
StatusCodeException

Definition at line 390 of file SInt.h.

References ACTIV_THROW_RESULT_IF, and Compare().

bool Activ::SInt::operator> ( const SInt & rhs ) const [inline]

Greater than operator.

Parameters:
rhs the object to compare with.
Returns:
the result of the test.
Exceptions:
StatusCodeException

Definition at line 424 of file SInt.h.

References ACTIV_THROW_RESULT_IF, and Compare().

bool Activ::SInt::operator>= ( const SInt & rhs ) const [inline]

Greater than or equal to operator.

Parameters:
rhs the object to compare with.
Returns:
the result of the test.
Exceptions:
StatusCodeException

Definition at line 434 of file SInt.h.

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::SInt::Serialize | ( | MessageBuilder & | messageBuilder,
 |  | const size_t | maxSerializedBodyLength |
 | ) |  |  | const [virtual]

Serialize the object into the supplied message builder.

Parameters:
messageBuilder | the message builder to store a serialized version of the object in.
maxSerializedBodyLength | the maximum serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::SInt::SerializeBody | ( | void * | pSerializedBody,
 |  | const size_t | maxSerializedBodyLength,
 |  | size_t & | serializedBodyLength |
 | ) |  |  | const [virtual]

Serialize the object's body into the supplied data buffer.

Parameters:
pSerializedBody | the buffer to store a serialized version of the object's body in.
maxSerializedBodyLength | the maximum serialized body length.
serializedBodyLength | the serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::SInt::SerializeLengthAndBody | ( | MessageBuilder & | messageBuilder,
 |  | const size_t | maxSerializedBodyLength = MAX_SERIALIZED_BODY_LENGTH_UNDEFINED |
 | ) |  |  | const [virtual]

Serialize the object's length and body into the supplied message builder.

Parameters:
messageBuilder | the message builder to store a serialized version of the object in.
maxSerializedBodyLength | the maximum serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

StatusCode Activ::SInt::Set ( const int64_t value ) [inline]

Set a new value.

Parameters:
value the value.
Return values:
STATUS_CODE_SUCCESS

Definition at line 477 of file SInt.h.

References Activ::IFieldType::m_isInitialized.

Referenced by SInt().

ACTIV_FIELD_TYPES_API StatusCode Activ::SInt::Subtract ( const SInt & rhs )

Subtract.

Parameters:
rhs the value to subtract from this object.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED
STATUS_CODE_OUT_OF_RANGE

Referenced by operator-=().

virtual ACTIV_FIELD_TYPES_API std::string Activ::SInt::ToString ( ) const [virtual]

Convert the object to a string.

Returns:
the object as a string.

Implements Activ::IFieldType.

static ACTIV_FIELD_TYPES_API StatusCode Activ::SInt::ValidateSerializedLengthAndBody | ( | MessageValidator & | messageValidator,
 |  | size_t & | serializedBodyOffset,
 |  | size_t & | serializedBodyLength |
 | ) |  |  | [static]

Validate the serialized length and body.

Parameters:
messageValidator | the message validator.
serializedBodyOffset | the serialized body offset.
serializedBodyLength | the serialized body length.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
...

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivFieldTypes/SInt.h
Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::SmtpHelper

Activ::SmtpHelper Class Reference

Smtp helper class. More...

#include <ActivMiddleware/Misc/SmtpHelper.h>

List of all members.

Public Member Functions

StatusCode | Connect (const std::string &server, const std::string &hostname=GetHostname())
Connect to the server.
StatusCode | Disconnect ()
Disconnect from the server.
bool | IsConnected () const
Is connected to the server.
StatusCode | PostMessage (const std::string &fromAddress, const std::string &toAddressList, const std::string &ccAddressList, const std::string &bccAddressList, const std::string &subject, const std::string &text)
Post a message.
SmtpHelper (const std::string &server, const std::string &hostname=GetHostname())
Constructor.
SmtpHelper ()
Default constructor.
~SmtpHelper ()
Destructor.

Static Public Member Functions

static std::string | GetHostname ()
Get the hostname.
static void | PostEmail (const Email &email, const std::string &server, const std::string &hostname=GetHostname())
Post an email asynchronously.

Classes

class | Email
Email class. More...
class | PostEmailThread
Send email thread.

Detailed Description

Smtp helper class.

Definition at line 28 of file SmtpHelper.h.

Constructor & Destructor Documentation

Activ::SmtpHelper::SmtpHelper ( ) [inline]

Default constructor.

Exceptions:
StatusCodeException

Definition at line 229 of file SmtpHelper.h.

Activ::SmtpHelper::SmtpHelper | ( | const std::string & | server,
 |  | const std::string & | hostname = GetHostname() |
 | ) |  |  | [inline]

Constructor.

Parameters:
server | the server.
hostname | the hostname.
Exceptions:
StatusCodeException

Definition at line 236 of file SmtpHelper.h.

References ACTIV_THROW_RESULT_IF, and Connect().

Member Function Documentation

StatusCode Activ::SmtpHelper::Connect | ( | const std::string & | server,
 |  | const std::string & | hostname = GetHostname() |
 | ) |  |  | [inline]

Connect to the server.

Parameters:
server | the server.
hostname | the hostname.
Return values:
STATUS_CODE_SUCCESS
...

Definition at line 252 of file SmtpHelper.h.

References ACTIV_RETURN_RESULT_IF, ACTIV_THROW_RESULT_IF, IsConnected(), and Activ::Exception::m_errorCode.

Referenced by SmtpHelper().

StatusCode Activ::SmtpHelper::Disconnect ( ) [inline]

Disconnect from the server.

Return values:
STATUS_CODE_SUCCESS
...

Definition at line 286 of file SmtpHelper.h.

References ACTIV_RETURN_RESULT_IF, ACTIV_THROW_RESULT_IF, IsConnected(), and Activ::Exception::m_errorCode.

Referenced by ~SmtpHelper().

std::string Activ::SmtpHelper::GetHostname ( ) [inline, static]

Get the hostname.

Returns:
the hostname.

Definition at line 409 of file SmtpHelper.h.

References Activ::IpManager::GetHostName().

bool Activ::SmtpHelper::IsConnected ( ) const [inline]

Is connected to the server.

Returns:
whether the object is connected to the server.

Definition at line 402 of file SmtpHelper.h.

Referenced by Connect(), Disconnect(), PostMessage(), and ~SmtpHelper().

void Activ::SmtpHelper::PostEmail | ( | const Email & | email,
 |  | const std::string & | server,
 |  | const std::string & | hostname = GetHostname() |
 | ) |  |  | [inline, static]

Post an email asynchronously.

Starts a new thread to send an email. An exception is thrown only on failure of starting a new thread, not if the attempt to send the email fails.

Parameters:
email | the email to send.
server | the mail server to use.
hostname | the hostname.
Exceptions:
Exception

Definition at line 518 of file SmtpHelper.h.

References ACTIV_THROW.

StatusCode Activ::SmtpHelper::PostMessage | ( | const std::string & | fromAddress,
 |  | const std::string & | toAddressList,
 |  | const std::string & | ccAddressList,
 |  | const std::string & | bccAddressList,
 |  | const std::string & | subject,
 |  | const std::string & | text |
 | ) |  |  | [inline]

Post a message.

Parameters:
fromAddress | the address the message is from.
toAddressList | the 'to' address list.
ccAddressList | the 'cc' address list.
bccAddressList | the 'bcc'address list.
subject | the message subject.
text | the message text.
Return values:
STATUS_CODE_SUCCESS
...

Definition at line 318 of file SmtpHelper.h.

References ACTIV_THROW_RESULT_IF, IsConnected(), and Activ::Exception::m_errorCode.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/Misc/SmtpHelper.h
Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::SmtpHelper::Email

Activ::SmtpHelper::Email Class Reference

Email class. More...

#include <ActivMiddleware/Misc/SmtpHelper.h>

List of all members.

Public Member Functions

Email (const std::string &fromAddress, const std::string &toAddressList, const std::string &ccAddressList, const std::string &bccAddressList, const std::string &subject, const std::string &text)
Constructor.

Public Attributes

const std::string | m_bccAddressList
the 'bcc' address list.
const std::string | m_ccAddressList
the 'cc' address list.
const std::string | m_fromAddress
the address the message is from.
const std::string | m_subject
the message subject.
const std::string | m_text
the message text.
const std::string | m_toAddressList
the 'to' address list.

Detailed Description

Email class.

Definition at line 34 of file SmtpHelper.h.

Constructor & Destructor Documentation

Activ::SmtpHelper::Email::Email | ( | const std::string & | fromAddress,
 |  | const std::string & | toAddressList,
 |  | const std::string & | ccAddressList,
 |  | const std::string & | bccAddressList,
 |  | const std::string & | subject,
 |  | const std::string & | text |
 | ) |  |  | [inline]

Constructor.

Parameters:
fromAddress | the address the message is from.
toAddressList | the 'to' address list.
ccAddressList | the 'cc' address list.
bccAddressList | the 'bcc'address list.
subject | the message subject.
text | the message text.

Definition at line 534 of file SmtpHelper.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/Misc/SmtpHelper.h
Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::SocketWrapper

Activ::SocketWrapper Class Reference

Socket wrapper class. More...

#include <ActivMiddleware/ActivIp/SocketWrapper.h>

List of all members.

Public Member Functions

bool | IsValid () const
Test if socket attached is valid.
operator HANDLE () const
Cast operator to HANDLE.
operator SOCKET () const
Cast operator to SOCKET.
SocketWrapper & | operator= (SocketWrapper &rhs)
Assignment operator. Any current attached socket is closed.
SocketWrapper & | operator= (const SOCKET socket)
Assignment operator. Any current attached socket is closed.
SocketWrapper (SocketWrapper &rhs)
Copy constructor.
SocketWrapper (const SOCKET socket)
Constructor.
SocketWrapper ()
Default constructor.
~SocketWrapper ()
Destructor.

Detailed Description

Socket wrapper class.

Allows cleaning up of a socket if an exception is thrown.

Definition at line 22 of file SocketWrapper.h.

Constructor & Destructor Documentation

Activ::SocketWrapper::SocketWrapper ( const SOCKET socket ) [inline]

Constructor.

Parameters:
socket SOCKET handle to wrap.

Definition at line 112 of file SocketWrapper.h.

Activ::SocketWrapper::SocketWrapper ( SocketWrapper & rhs ) [inline]

Copy constructor.

If rhs has an attached socket, ownership is transferred to this.

Parameters:
rhs SocketWrapper to copy from.

Definition at line 119 of file SocketWrapper.h.

Activ::SocketWrapper::~SocketWrapper ( ) [inline]

Destructor.

The destructor will close the underlying socket if it is still attached to this.

Definition at line 127 of file SocketWrapper.h.

Member Function Documentation

bool Activ::SocketWrapper::IsValid ( ) const [inline]

Test if socket attached is valid.

Returns:
true if attached to a valid socket handle.

Definition at line 174 of file SocketWrapper.h.

Activ::SocketWrapper::operator HANDLE ( ) const [inline]

Cast operator to HANDLE.

Returns:
Underlying socket.

Definition at line 165 of file SocketWrapper.h.

Activ::SocketWrapper::operator SOCKET ( ) const [inline]

Cast operator to SOCKET.

Returns:
Underlying socket.

Definition at line 156 of file SocketWrapper.h.

SocketWrapper & Activ::SocketWrapper::operator= ( SocketWrapper & rhs ) [inline]

Assignment operator. Any current attached socket is closed.

If rhs has an attached socket, ownership is transferred to this.

Parameters:
rhs SocketWrapper to copy from.

Definition at line 134 of file SocketWrapper.h.

References m_socket.

SocketWrapper & Activ::SocketWrapper::operator= ( const SOCKET socket ) [inline]

Assignment operator. Any current attached socket is closed.

Parameters:
socket SOCKET handle to wrap.

Definition at line 147 of file SocketWrapper.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivIp/SocketWrapper.h
Generated on Wed Oct 8 14:02:00 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::StaticAlignValueToProcessorWordBoundary

Activ::StaticAlignValueToProcessorWordBoundary< T, input > Class Template Reference

Compile-time template to align a value to a processor word size boundary. More...

#include <ActivMiddleware/Misc/MemoryHelper.h>

List of all members.

Static Public Attributes

static const T value = static_cast<T>((integralValue + (processorWordSizeBytes - 1)) & ~(processorWordSizeBytes - 1))

Detailed Description

template<typename T, T input>
class Activ::StaticAlignValueToProcessorWordBoundary< T, input >

Compile-time template to align a value to a processor word size boundary.

Definition at line 74 of file MemoryHelper.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/Misc/MemoryHelper.h
Generated on Wed Oct 8 14:02:00 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::StatusCodeException

Activ::StatusCodeException Class Reference

StatusCode exception class. More...

#include <ActivMiddleware/ActivBase/StatusCodeException.h>

Inheritance diagram for Activ::StatusCodeException:

Activ::Exception

List of all members.

Public Member Functions

ACTIV_BASE_EXPORTED_API StatusCodeException (const char *file, const char *function, const uint_fast32_t line, const uint_fast32_t errorCode)
Default constructor.
virtual
ACTIV_BASE_EXPORTED_API
std::string 		ToString () const
Convert the exception error code to a string.

Detailed Description

StatusCode exception class.

Definition at line 58 of file StatusCodeException.h.

Constructor & Destructor Documentation

ACTIV_BASE_EXPORTED_API Activ::StatusCodeException::StatusCodeException | ( | const char * | file,
 |  | const char * | function,
 |  | const uint_fast32_t | line,
 |  | const uint_fast32_t | errorCode
 | ) |  |

Default constructor.

Parameters:
file | the file which raised the exception.
function | the function which raised the exception.
line | the line number which raised the exception.
errorCode | the exception specific error code, in this case a StatusCode value.

Member Function Documentation

virtual ACTIV_BASE_EXPORTED_API std::string Activ::StatusCodeException::ToString ( ) const [virtual]

Convert the exception error code to a string.

Classes derived from Exception are required to implement ToString() to convert their error codes to a readable string.

Returns:
the error code as a string.

Reimplemented from Activ::Exception.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivBase/StatusCodeException.h
Generated on Wed Oct 8 14:02:00 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::StatusCodeHelper

Activ::StatusCodeHelper Class Reference

StatusCodeHelper class. More...

#include <ActivMiddleware/Misc/IFtpHelper.h>

List of all members.

Public Member Functions

operator StatusCode () const
StatusCodeHelper (const StatusCodeHelper &statusCodeHelper)
Copy constuctor.
StatusCodeHelper (StatusCode statusCode=STATUS_CODE_SUCCESS, const std::string &statusText="")
Constuctor.
const std::string & | ToString () const
Get the string version.

Friends

bool | operator!= (const StatusCode &statusCode, const StatusCodeHelper &statusCodeHelper)
equality operator.
bool | operator== (const StatusCode &statusCode, const StatusCodeHelper &statusCodeHelper)
equality operator.

Detailed Description

StatusCodeHelper class.

Definition at line 111 of file IFtpHelper.h.

Constructor & Destructor Documentation

Activ::StatusCodeHelper::StatusCodeHelper | ( | StatusCode | statusCode = STATUS_CODE_SUCCESS,
 |  | const std::string & | statusText = "" |
 | ) |  |  | [inline]

Constuctor.

Parameters:
statusCode | the status code.
statusText | any addtional comments.

Definition at line 316 of file IFtpHelper.h.

Activ::StatusCodeHelper::StatusCodeHelper ( const StatusCodeHelper & statusCodeHelper ) [inline]

Copy constuctor.

Parameters:
statusCodeHelper the other object to copy from.

Definition at line 324 of file IFtpHelper.h.

References m_statusCode, and m_statusText.

Friends And Related Function Documentation

bool operator!= | ( | const StatusCode & | statusCode,
 |  | const StatusCodeHelper & | statusCodeHelper |
 | ) |  |  | [friend]

equality operator.

Parameters:
statusCode | the status code.
statusCodeHelper | the status code helper.

Definition at line 347 of file IFtpHelper.h.

bool operator== | ( | const StatusCode & | statusCode,
 |  | const StatusCodeHelper & | statusCodeHelper |
 | ) |  |  | [friend]

equality operator.

Parameters:
statusCode | the status code.
statusCodeHelper | the status code helper.

Definition at line 340 of file IFtpHelper.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/Misc/IFtpHelper.h
Generated on Wed Oct 8 14:02:00 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::StringHashCompare

Activ::StringHashCompare< TRAITS > Class Template Reference

Hash compare class for STL hash containers where the key is a string. More...

#include <ActivMiddleware/Misc/StlHelper.h>

List of all members.

Public Member Functions

bool | operator() (const std::string &k1, const std::string &k2) const
Unhide operator() in base.
size_t | operator() (const std::string &key) const
Hashing function operator.

Detailed Description

template<typename TRAITS = std::less<std::string>>
class Activ::StringHashCompare< TRAITS >

Hash compare class for STL hash containers where the key is a string.

Parameters:
TRAITS less than comparison class.

Definition at line 247 of file StlHelper.h.

Member Function Documentation

template<typename TRAITS>
size_t Activ::StringHashCompare< TRAITS >::operator() ( const std::string & key ) const [inline]

Hashing function operator.

Parameters:
key key to hash.
Returns:
hash value.

Definition at line 269 of file StlHelper.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/Misc/StlHelper.h
Generated on Wed Oct 8 14:02:00 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Subject

Activ::Subject Class Reference

Subject class. More...

#include <ActivMiddleware/ActivSystem/Subject.h>

Inheritance diagram for Activ::Subject:

Activ::EndPointSubject Activ::ServiceSubject Activ::ShutdownSubject

List of all members.

Public Types

typedef byte_t | SubjectLength
type of the length

Public Member Functions

ACTIV_SYSTEM_INLINE_API void | Clear ()
Clear the subject down.
ACTIV_SYSTEM_EXPORTED_API
StatusCode 		Deserialize (MessageValidator &messageValidator)
Deserialize a subject.
ACTIV_SYSTEM_INLINE_API const
void * 		Get () const
Get pointer to raw subject data.
ACTIV_SYSTEM_INLINE_API size_t | GetLength () const
Get the length of the subject.
ACTIV_SYSTEM_INLINE_API size_t | GetSerializedLength () const
Get the length of the subject when serialized.
ACTIV_SYSTEM_EXPORTED_API bool | operator!= (const Subject &subject) const
Inequality operator.
ACTIV_SYSTEM_EXPORTED_API bool | operator< (const Subject &subject) const
Less than operator.
ACTIV_SYSTEM_EXPORTED_API bool | operator<= (const Subject &subject) const
Less than or equal operator.
ACTIV_SYSTEM_EXPORTED_API bool | operator== (const Subject &subject) const
Equality operator.
ACTIV_SYSTEM_EXPORTED_API bool | operator> (const Subject &subject) const
Greater than operator.
ACTIV_SYSTEM_EXPORTED_API bool | operator>= (const Subject &subject) const
Greater than or equal operator.
ACTIV_SYSTEM_EXPORTED_API
StatusCode 		Serialize (MessageBuilder &messageBuilder) const
Serialize a subject.
ACTIV_SYSTEM_INLINE_API void | Set (const Subject &subject)
Set subject from another Subject object.
ACTIV_SYSTEM_EXPORTED_API void | Set (const std::string &subject)
Set subject from a string.
ACTIV_SYSTEM_EXPORTED_API void | Set (const void *pSubjectData, const size_t subjectDataLength)
Set subject.
ACTIV_SYSTEM_EXPORTED_API void | Set (const char *pSubject)
Set subject.
ACTIV_SYSTEM_EXPORTED_API | Subject (const std::string &subject)
Constructor for stl string subject.
ACTIV_SYSTEM_EXPORTED_API | Subject (const char *pSubject)
Constructor for c-string subject.
ACTIV_SYSTEM_EXPORTED_API | Subject (const void *pSubjectData, const size_t subjectDataLength)
Constructor for binary subject.
ACTIV_SYSTEM_EXPORTED_API | Subject ()
Default constructor.
ACTIV_SYSTEM_EXPORTED_API
std::string 		ToString () const
Convert the subject to a string.

Static Public Attributes

static const SubjectLength | MAX_LENGTH = 48
maximum subject length

Detailed Description

Subject class.

Definition at line 27 of file Subject.h.

Constructor & Destructor Documentation

ACTIV_SYSTEM_EXPORTED_API Activ::Subject::Subject | ( | const void * | pSubjectData,
 |  | const size_t | subjectDataLength
 | ) |  |

Constructor for binary subject.

Parameters:
pSubjectData | subject data.
subjectDataLength | subject data length.
Exceptions:
StatusCodeException

ACTIV_SYSTEM_EXPORTED_API Activ::Subject::Subject ( const char * pSubject )

Constructor for c-string subject.

Parameters:
pSubject textual subject.
Exceptions:
StatusCodeException

ACTIV_SYSTEM_EXPORTED_API Activ::Subject::Subject ( const std::string & subject )

Constructor for stl string subject.

Parameters:
subject subject string.
Exceptions:
StatusCodeException

Member Function Documentation

ACTIV_SYSTEM_EXPORTED_API StatusCode Activ::Subject::Deserialize ( MessageValidator & messageValidator )

Deserialize a subject.

Parameters:
messageValidator
Return values:
STATUS_CODE_SUCCESS
...

const void * Activ::Subject::Get ( ) const [inline]

Get pointer to raw subject data.

Returns:
Pointer to raw subject data.

Definition at line 292 of file Subject.h.

size_t Activ::Subject::GetLength ( ) const [inline]

Get the length of the subject.

Returns:
Length of subject.

Definition at line 270 of file Subject.h.

size_t Activ::Subject::GetSerializedLength ( ) const [inline]

Get the length of the subject when serialized.

Returns:
The serialized length of the subject.

Definition at line 277 of file Subject.h.

ACTIV_SYSTEM_EXPORTED_API bool Activ::Subject::operator!= ( const Subject & subject ) const

Inequality operator.

Parameters:
subject subject to compare.
Returns:
boolean.

ACTIV_SYSTEM_EXPORTED_API bool Activ::Subject::operator< ( const Subject & subject ) const

Less than operator.

Parameters:
subject subject to compare.
Returns:
boolean.

ACTIV_SYSTEM_EXPORTED_API bool Activ::Subject::operator<= ( const Subject & subject ) const

Less than or equal operator.

Parameters:
subject subject to compare.
Returns:
boolean.

ACTIV_SYSTEM_EXPORTED_API bool Activ::Subject::operator== ( const Subject & subject ) const

Equality operator.

Parameters:
subject subject to compare.
Returns:
boolean.

ACTIV_SYSTEM_EXPORTED_API bool Activ::Subject::operator> ( const Subject & subject ) const

Greater than operator.

Parameters:
subject subject to compare.
Returns:
boolean.

ACTIV_SYSTEM_EXPORTED_API bool Activ::Subject::operator>= ( const Subject & subject ) const

Greater than or equal operator.

Parameters:
subject subject to compare.
Returns:
boolean.

ACTIV_SYSTEM_EXPORTED_API StatusCode Activ::Subject::Serialize ( MessageBuilder & messageBuilder ) const

Serialize a subject.

Parameters:
messageBuilder
Return values:
STATUS_CODE_SUCCESS
...

void Activ::Subject::Set ( const Subject & subject ) [inline]

Set subject from another Subject object.

Parameters:
subject Subject to assign from.

Definition at line 284 of file Subject.h.

References m_length, and m_subject.

ACTIV_SYSTEM_EXPORTED_API void Activ::Subject::Set ( const std::string & subject )

Set subject from a string.

Parameters:
subject subject string.
Exceptions:
StatusCodeException

ACTIV_SYSTEM_EXPORTED_API void Activ::Subject::Set | ( | const void * | pSubjectData,
 |  | const size_t | subjectDataLength
 | ) |  |

Set subject.

Parameters:
pSubjectData | subject data.
subjectDataLength | subject data length.
Exceptions:
StatusCodeException

ACTIV_SYSTEM_EXPORTED_API void Activ::Subject::Set ( const char * pSubject )

Set subject.

Parameters:
pSubject textual subject.
Exceptions:
StatusCodeException

ACTIV_SYSTEM_EXPORTED_API std::string Activ::Subject::ToString ( ) const

Convert the subject to a string.

Returns:
A string containing the subject. Note if the subject is not printable, nor will the returned string be!

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivSystem/Subject.h
Generated on Wed Oct 8 14:02:00 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::SyncRequestId

Activ::SyncRequestId Class Reference

Synchronous request id class. More...

#include <ActivMiddleware/ActivSystem/SyncRequestId.h>

List of all members.

Public Member Functions

ACTIV_SYSTEM_INLINE_API const
RequestId & 		GetRequestId () const
Get the underlying RequestId object.
ACTIV_SYSTEM_EXPORTED_API
StatusCode 		GetResponse (HeapMessage &heapMessage, const TimeoutPeriod timeout=ACTIV_WAIT_INFINITE)
Wait for the response to a sync call.
ACTIV_SYSTEM_EXPORTED_API
SyncRequestId & 		operator= (SyncRequestId &rhs)
Assignment operator.
ACTIV_SYSTEM_EXPORTED_API void | Return ()
Explicitly return an attached sync endpoint to the system pool.
ACTIV_SYSTEM_EXPORTED_API | SyncRequestId (SyncRequestId &syncRequestId)
Copy constructor.
ACTIV_SYSTEM_EXPORTED_API | SyncRequestId ()
Default constructor.
ACTIV_SYSTEM_EXPORTED_API | ~SyncRequestId ()
Destructor. An attached endpoint is returned to the system pool.

Friends

class | SystemImpl

Detailed Description

Synchronous request id class.

Definition at line 27 of file SyncRequestId.h.

Constructor & Destructor Documentation

ACTIV_SYSTEM_EXPORTED_API Activ::SyncRequestId::SyncRequestId ( SyncRequestId & syncRequestId )

Copy constructor.

Ownership of an attached endpoint is transferred to the new object.

Parameters:
syncRequestId the SyncRequestId to copy from.

Member Function Documentation

const RequestId & Activ::SyncRequestId::GetRequestId ( ) const [inline]

Get the underlying RequestId object.

Returns:
Reference to the underlying RequestId.

Definition at line 106 of file SyncRequestId.h.

ACTIV_SYSTEM_EXPORTED_API StatusCode Activ::SyncRequestId::GetResponse | ( | HeapMessage & | heapMessage,
 |  | const TimeoutPeriod | timeout = ACTIV_WAIT_INFINITE
 | ) |  |

Wait for the response to a sync call.

Parameters:
heapMessage | reference to a HeapMessage object to receive the response. If the call times out, heapMessage will be left unchanged.
timeout | how long to wait for the response, in ms.
Return values:
STATUS_CODE_SUCCESS | got the response in heapMessage.
STATUS_CODE_TIMEOUT | no response received in timeout period, heapMessage is empty.
STATUS_CODE_INVALID_ENDPOINT.

ACTIV_SYSTEM_EXPORTED_API SyncRequestId& Activ::SyncRequestId::operator= ( SyncRequestId & rhs )

Assignment operator.

Parameters:
rhs SyncRequestId object to copy from.
Returns:
*this.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivSystem/SyncRequestId.h
Generated on Wed Oct 8 14:02:00 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::SystemException

Activ::SystemException Class Reference

ActivSystem exception class. More...

#include <ActivMiddleware/ActivSystem/SystemException.h>

Inheritance diagram for Activ::SystemException:

Activ::Exception

List of all members.

Public Types

enum | { ACTIV_DECLARE_ELEMENT_1_WITH_COMMA }
Enumeration of all SystemException errors.

Public Member Functions

ACTIV_SYSTEM_EXPORTED_API | SystemException (const char *file, const char *function, const uint_fast32_t line, const uint_fast32_t errorCode)
Default constructor.
virtual
ACTIV_SYSTEM_EXPORTED_API
std::string 		ToString () const
Convert the exception error code to a string.

Detailed Description

ActivSystem exception class.

An exception of class SystemException is thrown only by classes inside ActivSystem.

Definition at line 51 of file SystemException.h.

Constructor & Destructor Documentation

ACTIV_SYSTEM_EXPORTED_API Activ::SystemException::SystemException | ( | const char * | file,
 |  | const char * | function,
 |  | const uint_fast32_t | line,
 |  | const uint_fast32_t | errorCode
 | ) |  |

Default constructor.

Parameters:
file | the file which raised the exception
function | the function which raised the exception
line | the line number which raised the exception
errorCode | the exception specific error code

Member Function Documentation

virtual ACTIV_SYSTEM_EXPORTED_API std::string Activ::SystemException::ToString ( ) const [virtual]

Convert the exception error code to a string.

Classes derived from Exception are required to implement ToString() to convert their error codes to a readable string.

Returns:
the error code as a string.

Reimplemented from Activ::Exception.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivSystem/SystemException.h
Generated on Wed Oct 8 14:02:00 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::SystemFactory

Activ::SystemFactory Class Reference

System factory class. More...

#include <ActivMiddleware/ActivSystem/SystemFactory.h>

Inheritance diagram for Activ::SystemFactory:

Activ::Singleton< T >

List of all members.

Public Member Functions

ACTIV_SYSTEM_EXPORTED_API ISystem * | Create (const ISystem::Settings &settings, const IHeap::BucketInfoVector &bucketInfoVector, const std::string &systemVersion)
Create a new shared memory system.
ACTIV_SYSTEM_EXPORTED_API ISystem * | Open (const ISystem::Settings &settings, const std::string &processName, Timeout &timeout=Timeout::GetInfinite())
Open an existing shared memory system.

Static Public Member Functions

static
ACTIV_SYSTEM_EXPORTED_API
SystemFactory & 		GetInstance ()
Get a reference to the singleton instance.

Friends

class | Singleton< SystemFactory >

Detailed Description

System factory class.

Definition at line 22 of file SystemFactory.h.

Member Function Documentation

ACTIV_SYSTEM_EXPORTED_API ISystem* Activ::SystemFactory::Create | ( | const ISystem::Settings & | settings,
 |  | const IHeap::BucketInfoVector & | bucketInfoVector,
 |  | const std::string & | systemVersion
 | ) |  |

Create a new shared memory system.

Parameters:
settings | settings for the system & process.
bucketInfoVector | bucket info for the system heap.
systemVersion | arbitrary version string for the system.
Returns:
Pointer to an object providing an ISystem interface
Exceptions:
Exception

static ACTIV_SYSTEM_EXPORTED_API SystemFactory& Activ::SystemFactory::GetInstance ( ) [static]

Get a reference to the singleton instance.

Returns:
Reference.

ACTIV_SYSTEM_EXPORTED_API ISystem* Activ::SystemFactory::Open | ( | const ISystem::Settings & | settings,
 |  | const std::string & | processName,
 |  | Timeout & | timeout = Timeout::GetInfinite()
 | ) |  |

Open an existing shared memory system.

Parameters:
settings | settings for the system & process.
processName | the name of the process with the system, empty string gives a name based on the process id.
timeout | Timeout object specifying how long to wait for the system to exist.
Returns:
Pointer to an object providing an ISystem interface
Exceptions:
Exception

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivSystem/SystemFactory.h
Generated on Wed Oct 8 14:02:00 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::SystemInfo

Activ::SystemInfo Class Reference

System information. More...

#include <ActivMiddleware/ActivBase/SystemInfo.h>

Inheritance diagram for Activ::SystemInfo:

Activ::ISystem::SystemInfo

List of all members.

Public Types

typedef std::vector< std::string > | ProcessorInfoList

Public Member Functions

ACTIV_BASE_EXPORTED_API StatusCode | Deserialize (MessageValidator &messageValidator)
Deserialize system info.
ACTIV_BASE_EXPORTED_API void | Populate ()
Populate all members.
ACTIV_BASE_EXPORTED_API StatusCode | Serialize (MessageBuilder &messageBuilder, const SystemInfo &systemInfo) const
Serialize this SystemInfo to the version of the SystemInfo parameter.
ACTIV_BASE_EXPORTED_API StatusCode | Serialize (MessageBuilder &messageBuilder) const
Serialize this SystemInfo to the latest version.
ACTIV_BASE_EXPORTED_API | SystemInfo ()
Default constructor.

Public Attributes

std::string | m_boostVersion
Boost version info.
std::string | m_computerName
name of the computer
uint64_t | m_freeMemory
amount of free RAM in the machine
std::string | m_middlewareDate
date/time of compilation of ActivMiddleware
std::string | m_middlewareVersion
ActivMiddleware version string.
uint32_t | m_middlewareVersionValue
numeric ActivMiddleware version
size_t | m_numberOfProcessorCores
number of processor cores across all packages in the machine
size_t | m_numberOfProcessorPackages
number of actual physical processors in the machine
size_t | m_numberOfProcessorThreads
number of logical processors in the machine (e.g. HT enabled)
std::string | m_osName
printable os name string
uint64_t | m_physicalMemory
amount of physical RAM in the machine
PlatformType | m_platformType
ActivMiddleware platform.
ProcessorInfoList | m_processorInfoList
list of processor info
std::string | m_schedulerInfo
printable info about scheduler
uint32_t | m_windowsDpcProcessorAffinityMask
processor affinity for deferred procedure calls

Detailed Description

System information.

Definition at line 28 of file SystemInfo.h.

Constructor & Destructor Documentation

ACTIV_BASE_EXPORTED_API Activ::SystemInfo::SystemInfo ( )

Default constructor.

Sets no members.

Reimplemented in Activ::ISystem::SystemInfo.

Member Function Documentation

ACTIV_BASE_EXPORTED_API StatusCode Activ::SystemInfo::Deserialize ( MessageValidator & messageValidator )

Deserialize system info.

Parameters:
messageValidator to deserialize from.
Returns:
STATUS_CODE_SUCCESS or error code.

Reimplemented in Activ::ISystem::SystemInfo.

ACTIV_BASE_EXPORTED_API void Activ::SystemInfo::Populate ( )

Populate all members.

Exceptions:
Exception.

ACTIV_BASE_EXPORTED_API StatusCode Activ::SystemInfo::Serialize | ( | MessageBuilder & | messageBuilder,
 |  | const SystemInfo & | systemInfo |
 | ) |  |  | const

Serialize this SystemInfo to the version of the SystemInfo parameter.

Parameters:
messageBuilder | to serialize into.
systemInfo | containing the version to serialize to.
Returns:
STATUS_CODE_SUCCESS or error code.

ACTIV_BASE_EXPORTED_API StatusCode Activ::SystemInfo::Serialize ( MessageBuilder & messageBuilder ) const

Serialize this SystemInfo to the latest version.

Parameters:
messageBuilder to serialize into.
Returns:
STATUS_CODE_SUCCESS or error code.

Reimplemented in Activ::ISystem::SystemInfo.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivBase/SystemInfo.h
Generated on Wed Oct 8 14:02:00 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::SystemMessageEndPointIdSet

Activ::SystemMessageEndPointIdSet Class Reference

SYSTEM_MESSAGE_ENDPOINT_SHUTDOWN, SYSTEM_MESSAGE_ENDPOINT_DIE. More...

#include <ActivMiddleware/ActivFramework/Messages.h>

List of all members.

Public Member Functions

ACTIV_FRAMEWORK_API StatusCode | Deserialize (MessageValidator &messageValidator)
Deserialize the message.

Static Public Member Functions

static ACTIV_FRAMEWORK_API
StatusCode 		Serialize (MessageBuilder &messageBuilder, const EndPointIdSet &endPointIdSet)
Serialize the message.

Public Attributes

EndPointIdSet | m_endPointIdSet
set of endpoints that are shutting down

Detailed Description

SYSTEM_MESSAGE_ENDPOINT_SHUTDOWN, SYSTEM_MESSAGE_ENDPOINT_DIE.

Message received by subscribing to EndPointSubject.

Definition at line 76 of file Messages.h.

Member Function Documentation

ACTIV_FRAMEWORK_API StatusCode Activ::SystemMessageEndPointIdSet::Deserialize ( MessageValidator & messageValidator )

Deserialize the message.

Parameters:
messageValidator
Return values:
STATUS_CODE_SUCCESS
...

static ACTIV_FRAMEWORK_API StatusCode Activ::SystemMessageEndPointIdSet::Serialize | ( | MessageBuilder & | messageBuilder,
 |  | const EndPointIdSet & | endPointIdSet |
 | ) |  |  | [static]

Serialize the message.

Parameters:
messageBuilder | builder to use.
endPointIdSet | set of endpoints shutting down.
Return values:
STATUS_CODE_SUCCESS
...

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivFramework/Messages.h
Generated on Wed Oct 8 14:02:00 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::SystemMonitor

Activ::SystemMonitor Class Reference

System monitor class. More...

#include <ActivMiddleware/ActivBase/SystemMonitor.h>

List of all members.

Public Member Functions

ACTIV_BASE_EXPORTED_API StatusCode | AddProcess (const Process::Id processId)
Add an individual process to the watch.
ACTIV_BASE_EXPORTED_API void | CollateStats ()
Collate stats.
ACTIV_BASE_EXPORTED_API const
Stats & 		GetStats ()
Get the stats at the point CollateStats() was last called.
ACTIV_BASE_EXPORTED_API void | RemoveProcess (const Process::Id processId)
Remove an individual process from the watch.
ACTIV_BASE_EXPORTED_API | SystemMonitor (const std::vector< std::string > &diskNameList=std::vector< std::string >())
Constructor.
ACTIV_BASE_EXPORTED_API | ~SystemMonitor ()
Destructor.

Classes

class | Stats
Collected stats. More...

Detailed Description

System monitor class.

Monitors cpu usage, memory, disk usage, context switching and paging.

Note this class is not thread aware - it is not safe to call the methods from different threads without some user-provided locking.

Definition at line 31 of file SystemMonitor.h.

Constructor & Destructor Documentation

ACTIV_BASE_EXPORTED_API Activ::SystemMonitor::SystemMonitor ( const std::vector< std::string > & diskNameList = std::vector< std::string >() )

Constructor.

Parameters:
diskNameList list of disks to watch. If empty, watch the disk containing the current working directory.
Exceptions:
Exception.

Member Function Documentation

ACTIV_BASE_EXPORTED_API StatusCode Activ::SystemMonitor::AddProcess ( const Process::Id processId )

Add an individual process to the watch.

Parameters:
processId os-pid of the process to monitor.
Returns:
STATUS_CODE_SUCCESS or error code.

ACTIV_BASE_EXPORTED_API void Activ::SystemMonitor::CollateStats ( )

Collate stats.

This should be called on a timer with a regular interval. GetStats() can then be called at will, and will return the state at the point CollateStats() was last called.

ACTIV_BASE_EXPORTED_API const Stats& Activ::SystemMonitor::GetStats ( )

Get the stats at the point CollateStats() was last called.

Returns:
Stats reference.

ACTIV_BASE_EXPORTED_API void Activ::SystemMonitor::RemoveProcess ( const Process::Id processId )

Remove an individual process from the watch.

Parameters:
processId os-pid of the process to monitor.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivBase/SystemMonitor.h
Generated on Wed Oct 8 14:02:00 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::SystemMonitor::Stats

Activ::SystemMonitor::Stats Class Reference

Collected stats. More...

#include <ActivMiddleware/ActivBase/SystemMonitor.h>

List of all members.

Public Types

typedef std::vector< uint8_t > | CpuUsageList
typedef std::vector< DiskInfo > | DiskInfoList
typedef std::map< Process::Id,
ProcessInfo > 		ProcessInfoMap

Public Member Functions

ACTIV_BASE_EXPORTED_API | Stats ()
Default constructor.

Public Attributes

uint8_t | m_averageCpuUsage
average usage across all cpus
uint32_t | m_contextSwitchRate
context switches / sec
CpuUsageList | m_cpuUsageList
list of total cpu usage percentages per cpu
DiskInfoList | m_diskInfoList
list of disk usages
uint8_t | m_freeMemoryPercent
% of memory free
uint32_t | m_pagesInOutRate
hard or major page faults / sec
uint8_t | m_peakCpuUsage
peak usage across all cpus
ProcessInfoMap | m_processInfoMap
map of per-process info

Classes

class | DiskInfo
Per-disk info. More...
class | ProcessInfo
Per-process info. More...

Detailed Description

Collected stats.

Definition at line 37 of file SystemMonitor.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivBase/SystemMonitor.h
Generated on Wed Oct 8 14:02:00 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::SystemMonitor::Stats::DiskInfo

Activ::SystemMonitor::Stats::DiskInfo Class Reference

Per-disk info. More...

#include <ActivMiddleware/ActivBase/SystemMonitor.h>

List of all members.

Public Attributes

std::string | m_diskName
name of disk
uint8_t | m_usagePercentage
usage % of disk

Detailed Description

Per-disk info.

Definition at line 43 of file SystemMonitor.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivBase/SystemMonitor.h
Generated on Wed Oct 8 14:02:00 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::SystemMonitor::Stats::ProcessInfo

Activ::SystemMonitor::Stats::ProcessInfo Class Reference

Per-process info. More...

#include <ActivMiddleware/ActivBase/SystemMonitor.h>

List of all members.

Public Attributes

uint8_t | m_averageCpuUsage
average % cpu usage across all threads in this process
uint8_t | m_highestThreadCpuUsage
highest % cpu usage across all threads in this process
uint32_t | m_highestThreadCpuUsageId
id of thread with highest cpu usage in this process
std::string | m_name
process name
uint64_t | m_numberOfPageFaults
uint64_t | m_virtualMemorySize
VM size of this process. NB: not populated on Windows.
uint64_t | m_workingSetSize
working set size of this process

Detailed Description

Per-process info.

Definition at line 53 of file SystemMonitor.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivBase/SystemMonitor.h
Generated on Wed Oct 8 14:02:00 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::SystemProxy

Activ::SystemProxy Class Reference

Proxy class for ISystem interface. More...

#include <ActivMiddleware/ActivFramework/Application.h>

Inheritance diagram for Activ::SystemProxy:

Activ::ISystem Activ::Application Activ::AgentApplication Activ::ThinApplication

List of all members.

Public Member Functions

virtual ACTIV_FRAMEWORK_API
ISyncEndPoint * 		CreateEndPoint (const std::string &name, const bool hasMutex, const IEndPoint::NotificationType notificationType)
Create a system endpoint.
virtual ACTIV_FRAMEWORK_API IHeap * | CreateHeap (const std::string &name, const IHeap::BucketInfoVector &bucketInfoVector)
Create a named memory heap.
virtual ACTIV_FRAMEWORK_API
IEndPoint * 		CreatePrivateEndPoint (const bool hasMutex, const IEndPoint::NotificationType notificationType)
Create a private, local memory endpoint.
virtual ACTIV_FRAMEWORK_API void | EnumerateObjects (IHeapEnumerator &enumerator)
Enumerate all opened heaps.
virtual ACTIV_FRAMEWORK_API void | EnumerateObjects (IEndPointEnumerator &enumerator)
Enumerate all opened endpoints.
virtual ACTIV_FRAMEWORK_API void | EnumerateObjects (IProcessEnumerator &enumerator)
Enumerate all opened processes.
virtual ACTIV_FRAMEWORK_API
IProcess * 		GetProcess () const
Get this process.
virtual ACTIV_FRAMEWORK_API IHeap * | GetSystemHeap () const
Get the system heap.
virtual ACTIV_FRAMEWORK_API
SystemInfo 		GetSystemInfo () const
Get system info.
virtual ACTIV_FRAMEWORK_API
std::string 		GetSystemName () const
Get the name of the system.
virtual ACTIV_FRAMEWORK_API
ISyncEndPoint * 		OpenEndPoint (EndPointId endPointId, Timeout &timeout=Timeout::GetInfinite())
Open a system endpoint by id.
virtual ACTIV_FRAMEWORK_API
ISyncEndPoint * 		OpenEndPoint (const std::string &name, Timeout &timeout=Timeout::GetInfinite())
Open a system endpoint by name.
virtual ACTIV_FRAMEWORK_API IHeap * | OpenHeap (const HeapId heapId, Timeout &timeout=Timeout::GetInfinite())
Open an existing named memory heap.
virtual ACTIV_FRAMEWORK_API IHeap * | OpenHeap (const std::string &name, Timeout &timeout=Timeout::GetInfinite())
Open an existing named memory heap.
virtual ACTIV_FRAMEWORK_API
IProcess * 		OpenProcess (const ProcessId processId, Timeout &timeout=Timeout::GetInfinite())
Open an existing process within the shared memory system.
virtual ACTIV_FRAMEWORK_API
IProcess * 		OpenProcess (const std::string &name, Timeout &timeout=Timeout::GetInfinite())
Open an existing process within the shared memory system.
ACTIV_FRAMEWORK_API | ~SystemProxy ()
Destructor.

Friends

class | Application

Detailed Description

Proxy class for ISystem interface.

Definition at line 30 of file Application.h.

Member Function Documentation

virtual ACTIV_FRAMEWORK_API ISyncEndPoint* Activ::SystemProxy::CreateEndPoint | ( | const std::string & | name,
 |  | const bool | hasMutex,
 |  | const IEndPoint::NotificationType | notificationType |
 | ) |  |  | [virtual]

Create a system endpoint.

The endpoint will exist in shared memory if the system was created with MEMORY_MODEL_SHARED and will be available to other processes in the system. Otherwise it will be created in local memory and can only be opened by this process (using OpenEndPoint()).

Parameters:
name | the name of the endpoint which will exist within the parent system namespace. If name == "", the endpoint is given a name based on a unique id.
hasMutex | true if the endpoint is to be protected by a mutex, else false.
notificationType | primitive to use for data available notification on the endpoint.
Returns:
Pointer to an object providing an ISyncEndPoint interface.
Exceptions:
Exception

Implements Activ::ISystem.

virtual ACTIV_FRAMEWORK_API IHeap* Activ::SystemProxy::CreateHeap | ( | const std::string & | name,
 |  | const IHeap::BucketInfoVector & | bucketInfoVector |
 | ) |  |  | [virtual]

Create a named memory heap.

The heap will exist in shared memory if the system was created with MEMORY_MODEL_SHARED and will be available to other processes in the system. Otherwise it will be created in local memory and can only be opened by this process (using OpenHeap()).

Parameters:
name | the name of the heap which will exist within the parent system namespace.
bucketInfoVector | a vector of BucketInfo classes describing the layout of the heap.
Returns:
Pointer to an object providing an IHeap interface.
Exceptions:
Exception

Implements Activ::ISystem.

virtual ACTIV_FRAMEWORK_API IEndPoint* Activ::SystemProxy::CreatePrivateEndPoint | ( | const bool | hasMutex,
 |  | const IEndPoint::NotificationType | notificationType |
 | ) |  |  | [virtual]

Create a private, local memory endpoint.

Parameters:
hasMutex | true if the endpoint is to be protected by a mutex, else false.
notificationType | primitive to use for data available notification on the endpoint.
Returns:
Pointer to an object providing an IEndPoint interface.
Exceptions:
Exception

Implements Activ::ISystem.

virtual ACTIV_FRAMEWORK_API void Activ::SystemProxy::EnumerateObjects ( IHeapEnumerator & enumerator ) [virtual]

Enumerate all opened heaps.

Parameters:
enumerator reference to an object providing an IHeapEnumerator interface to be called back on a process instance.

Implements Activ::ISystem.

virtual ACTIV_FRAMEWORK_API void Activ::SystemProxy::EnumerateObjects ( IEndPointEnumerator & enumerator ) [virtual]

Enumerate all opened endpoints.

Parameters:
enumerator reference to an object providing an IEndPointEnumerator interface to be called back on an endpoint instance.

Implements Activ::ISystem.

virtual ACTIV_FRAMEWORK_API void Activ::SystemProxy::EnumerateObjects ( IProcessEnumerator & enumerator ) [virtual]

Enumerate all opened processes.

Parameters:
enumerator reference to an object providing an IProcessEnumerator interface to be called back on a process instance.

Implements Activ::ISystem.

virtual ACTIV_FRAMEWORK_API IProcess* Activ::SystemProxy::GetProcess ( ) const [virtual]

Get this process.

Returns:
An IProcess interface to this process.

Implements Activ::ISystem.

virtual ACTIV_FRAMEWORK_API IHeap* Activ::SystemProxy::GetSystemHeap ( ) const [virtual]

Get the system heap.

Returns:
An object providing an IHeap interface.

Implements Activ::ISystem.

virtual ACTIV_FRAMEWORK_API SystemInfo Activ::SystemProxy::GetSystemInfo ( ) const [virtual]

Get system info.

Returns:
SystemInfo.
Exceptions:
Exception.

Implements Activ::ISystem.

virtual ACTIV_FRAMEWORK_API std::string Activ::SystemProxy::GetSystemName ( ) const [virtual]

Get the name of the system.

Returns:
A string object containing the name of the system.

Implements Activ::ISystem.

virtual ACTIV_FRAMEWORK_API ISyncEndPoint* Activ::SystemProxy::OpenEndPoint | ( | EndPointId | endPointId,
 |  | Timeout & | timeout = Timeout::GetInfinite() |
 | ) |  |  | [virtual]

Open a system endpoint by id.

Parameters:
endPointId | the system unique id of the endpoint to open.
timeout | a Timeout object specifying how long to wait for the endpoint to exist.
Returns:
Pointer to an object providing an ISyncEndPoint interface.
Exceptions:
Exception

Implements Activ::ISystem.

virtual ACTIV_FRAMEWORK_API ISyncEndPoint* Activ::SystemProxy::OpenEndPoint | ( | const std::string & | name,
 |  | Timeout & | timeout = Timeout::GetInfinite() |
 | ) |  |  | [virtual]

Open a system endpoint by name.

Parameters:
name | the name of the endpoint which exists within the parent system namespace.
timeout | a Timeout object specifying how long to wait for the endpoint to exist.
Returns:
Pointer to an object providing an ISyncEndPoint interface.
Exceptions:
Exception

Implements Activ::ISystem.

virtual ACTIV_FRAMEWORK_API IHeap* Activ::SystemProxy::OpenHeap | ( | const HeapId | heapId,
 |  | Timeout & | timeout = Timeout::GetInfinite() |
 | ) |  |  | [virtual]

Open an existing named memory heap.

Parameters:
heapId | the system unique id of the heap to open.
timeout | a Timeout object specifying how long to wait for the heap to exist.
Returns:
Pointer to an object providing an IHeap interface.
Exceptions:
Exception

Implements Activ::ISystem.

virtual ACTIV_FRAMEWORK_API IHeap* Activ::SystemProxy::OpenHeap | ( | const std::string & | name,
 |  | Timeout & | timeout = Timeout::GetInfinite() |
 | ) |  |  | [virtual]

Open an existing named memory heap.

Parameters:
name | the name of the heap which exists within the parent system namespace.
timeout | a Timeout object specifying how long to wait for the heap to exist.
Returns:
Pointer to an object providing an IHeap interface.
Exceptions:
Exception

Implements Activ::ISystem.

virtual ACTIV_FRAMEWORK_API IProcess* Activ::SystemProxy::OpenProcess | ( | const ProcessId | processId,
 |  | Timeout & | timeout = Timeout::GetInfinite() |
 | ) |  |  | [virtual]

Open an existing process within the shared memory system.

Parameters:
processId | the id of the process within the system.
timeout | a Timeout object specifying how long to wait for the process to exist, in ms.
Returns:
An object providing an IProcess interface.
Exceptions:
Exception.

Implements Activ::ISystem.

virtual ACTIV_FRAMEWORK_API IProcess* Activ::SystemProxy::OpenProcess | ( | const std::string & | name,
 |  | Timeout & | timeout = Timeout::GetInfinite() |
 | ) |  |  | [virtual]

Open an existing process within the shared memory system.

Parameters:
name | the name of the process.
timeout | a Timeout object specifying how long to wait for the process to exist, in ms.
Returns:
An object providing an IProcess interface.
Exceptions:
Exception.

Implements Activ::ISystem.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivFramework/Application.h
Generated on Wed Oct 8 14:02:00 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::TcpListener

Activ::TcpListener Class Reference

TCP listener class. More...

#include <ActivMiddleware/ActivIp/Windows/TcpListener.h>

List of all members.

Public Types

enum | State { ACTIV_DECLARE_VALUE_WITH_COMMA }
Listening states.

Public Member Functions

ACTIV_IP_API SOCKET | GetHandle () const
Get the underlying socket handle.
ACTIV_IP_API void | GetLocalAddress (IpAddress &ipAddress) const
Get the local address of the listening socket.
ACTIV_IP_API State | GetState () const
Get the listener state.
ACTIV_IP_API void | Start (const IpAddress &localAddress, const int backlog=SOMAXCONN)
Start listening.
ACTIV_IP_API void | Start (const uint16_t localPort, const char *localAddress=0, const int backlog=SOMAXCONN)
Start listening.
ACTIV_IP_API bool | Stop ()
Stop listening.
ACTIV_IP_API | TcpListener (IpManager &ipManager)
Constructor.
ACTIV_IP_API | ~TcpListener ()
Destructor.

Static Public Member Functions

static ACTIV_IP_API std::string | StateToString (const State state)
Return state in string form.

Friends

class | TcpSocket

Detailed Description

TCP listener class.

Definition at line 31 of file TcpListener.h.

Constructor & Destructor Documentation

ACTIV_IP_API Activ::TcpListener::TcpListener ( IpManager & ipManager )

Constructor.

Parameters:
ipManager the IpManager object owning the listening socket.
Exceptions:
Exception.

Member Function Documentation

ACTIV_IP_API SOCKET Activ::TcpListener::GetHandle ( ) const

Get the underlying socket handle.

Returns:
Socket handle.

ACTIV_IP_API void Activ::TcpListener::GetLocalAddress ( IpAddress & ipAddress ) const

Get the local address of the listening socket.

Parameters:
ipAddress a reference to an IpAddress object to receive the local socket address.

ACTIV_IP_API State Activ::TcpListener::GetState ( ) const

Get the listener state.

Returns:
The current state.

ACTIV_IP_API void Activ::TcpListener::Start | ( | const IpAddress & | localAddress,
 |  | const int | backlog = SOMAXCONN
 | ) |  |

Start listening.

Parameters:
localAddress | address to listen on.
backlog | maximum length of the queue of pending connections.
Exceptions:
Exception.

ACTIV_IP_API void Activ::TcpListener::Start | ( | const uint16_t | localPort,
 |  | const char * | localAddress = 0,
 |  | const int | backlog = SOMAXCONN
 | ) |  |

Start listening.

Parameters:
localPort | port to listen on.
localAddress | optional interface to bind to.
backlog | maximum length of the queue of pending connections.
Exceptions:
Exception.

static ACTIV_IP_API std::string Activ::TcpListener::StateToString ( const State state ) [static]

Return state in string form.

Returns:
State in string form.

ACTIV_IP_API bool Activ::TcpListener::Stop ( )

Stop listening.

Returns:
Always returns true.
Exceptions:
Exception.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivIp/Windows/TcpListener.h
Generated on Wed Oct 8 14:02:00 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::TcpSocket

Activ::TcpSocket Class Reference

TCP socket class. More...

#include <ActivMiddleware/ActivIp/Windows/TcpSocket.h>

Inheritance diagram for Activ::TcpSocket:

Activ::IpSocket

List of all members.

Public Types

enum | State { ACTIV_DECLARE_VALUE_WITH_COMMA }
Connection states.

Public Member Functions

ACTIV_IP_API void | Accept (TcpListener &listener)
Post an accept.
ACTIV_IP_API void | Connect (const IpAddress &remoteAddress, const IpAddress &localAddress)
Initiate connection.
ACTIV_IP_API void | Connect (const char *remoteAddress, const uint16_t remotePort, const char *localAddress=0, const uint16_t localPort=0)
Initiate connection.
ACTIV_IP_API bool | Disconnect (const bool gracefully=false)
Close a connection.
ACTIV_IP_API void | LockedBreak ()
Forcably initiate a connection break. If the socket was connected, OnBreak() will be fired.
ACTIV_IP_API void | PostConnect ()
Post a connect to an already set up address.
ACTIV_IP_API void | PreLockedBreak ()
Forcably initiate a connection break. If the socket was connected, OnBreak() will be fired.
ACTIV_IP_API | TcpSocket (IpManager &manager, const Settings &settings=Settings())
Constructor.
ACTIV_IP_API | ~TcpSocket ()
Destructor.

Static Public Member Functions

static ACTIV_IP_API std::string | StateToString (const State state)
Return state as string.

Protected Member Functions

virtual ACTIV_IP_API void | OnAccept ()
Accept has succeeded.
virtual ACTIV_IP_API void | OnAcceptAborted ()
Accept has been aborted. Calling Disconnect() before an accept has completed will cause this event.
virtual ACTIV_IP_API void | OnAcceptFailed (const uint32_t errorCode)
Accept has failed. Stopping the listener will cause this event on an accepting connection.
virtual ACTIV_IP_API void | OnBreak ()
Connection has broken (the user didn't initiate).
virtual ACTIV_IP_API void | OnConnect ()
Connect has succeeded.
virtual ACTIV_IP_API void | OnConnectAborted ()
Connect has been aborted (with a Disconnect()) before it completed either successfully or unsuccessfully.
virtual ACTIV_IP_API void | OnConnectFailed (const uint32_t errorCode)
Connect has failed.
virtual ACTIV_IP_API void | OnDisconnect ()
Connection has closed at the user's request.
virtual ACTIV_IP_API
CompletionResult 		OnRxBuffers (const size_t dataLength)
Callback on rx completion.
virtual ACTIV_IP_API
CompletionResult 		OnTxBuffers (const size_t dataLength)
Callback on tx completion.

Protected Attributes

State m_state
The state of the connection.

Classes

class | AcceptOverlapped
Overlapped class for accepts.
class | BsdThreadInfo
Sync bsd thread info.
class | ConnectOverlapped
Overlapped class for connects.
class | ConnectThreadInfo
Sync bsd thread connect info.
class | Settings
Settings. More...
class | Stats
Stats. More...

Detailed Description

TCP socket class.

Definition at line 36 of file TcpSocket.h.

Constructor & Destructor Documentation

ACTIV_IP_API Activ::TcpSocket::TcpSocket | ( | IpManager & | manager,
 |  | const Settings & | settings = Settings()
 | ) |  |

Constructor.

Parameters:
manager | the IpManager that owns the socket.
settings | settings for this socket.
Exceptions:
Exception.

Member Function Documentation

ACTIV_IP_API void Activ::TcpSocket::Accept ( TcpListener & listener )

Post an accept.

Parameters:
listener the server to accept from.
Exceptions:
Exception.

ACTIV_IP_API void Activ::TcpSocket::Connect | ( | const IpAddress & | remoteAddress,
 |  | const IpAddress & | localAddress
 | ) |  |

Initiate connection.

Parameters:
remoteAddress | the remote address to connect to.
localAddress | the local address to bind to.
Exceptions:
Exception.

ACTIV_IP_API void Activ::TcpSocket::Connect | ( | const char * | remoteAddress,
 |  | const uint16_t | remotePort,
 |  | const char * | localAddress = 0,
 |  | const uint16_t | localPort = 0
 | ) |  |

Initiate connection.

Parameters:
remoteAddress | the remote address to connect to.
remotePort | the remote port to connect to (local endian).
localAddress | the optional local address to bind to.
localPort | the optional local port number to bind to (local endian).
Exceptions:
Exception.

ACTIV_IP_API bool Activ::TcpSocket::Disconnect ( const bool gracefully = false )

Close a connection.

Parameters:
gracefully true to only close the socket once any outstanding tx has completed, false to force the socket closed immediately.
Return values:
true | the socket is fully closed.
false | a close event will be fired when the socket is fully closed (OnDisconnect()).

ACTIV_IP_API void Activ::TcpSocket::LockedBreak ( )

Forcably initiate a connection break. If the socket was connected, OnBreak() will be fired.

Note this function will obtain the socket mutex for the duration of the call.

virtual ACTIV_IP_API void Activ::TcpSocket::OnAcceptFailed ( const uint32_t errorCode ) [protected, virtual]

Accept has failed. Stopping the listener will cause this event on an accepting connection.

Parameters:
errorCode Win32 error code.

virtual ACTIV_IP_API void Activ::TcpSocket::OnConnectFailed ( const uint32_t errorCode ) [protected, virtual]

Connect has failed.

Parameters:
errorCode Win32 error code.

virtual ACTIV_IP_API CompletionResult Activ::TcpSocket::OnRxBuffers ( const size_t dataLength ) [protected, virtual]

Callback on rx completion.

When overriding this function, you MUST call the base class OnRxBuffers() first, and return the result if it isn't COMPLETION_RESULT_SUCCESS.

Parameters:
dataLength the number of bytes transferred.

Reimplemented from Activ::IpSocket.

virtual ACTIV_IP_API CompletionResult Activ::TcpSocket::OnTxBuffers ( const size_t dataLength ) [protected, virtual]

Callback on tx completion.

When overriding this function, you MUST call the base class OnTxBuffers() first, and return the result if it isn't COMPLETION_RESULT_SUCCESS.

Parameters:
dataLength the number of bytes transferred.

Reimplemented from Activ::IpSocket.

ACTIV_IP_API void Activ::TcpSocket::PostConnect ( )

Post a connect to an already set up address.

Exceptions:
Exception.

ACTIV_IP_API void Activ::TcpSocket::PreLockedBreak ( )

Forcably initiate a connection break. If the socket was connected, OnBreak() will be fired.

As LockedBreak(), but do not obtain the socket mutex first (assumes the mutex is already locked).

static ACTIV_IP_API std::string Activ::TcpSocket::StateToString ( const State state ) [static]

Return state as string.

Returns:
Socket state in string form.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivIp/Windows/TcpSocket.h
Generated on Wed Oct 8 14:02:00 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::TcpSocket::Settings

Activ::TcpSocket::Settings Class Reference

Settings. More...

#include <ActivMiddleware/ActivIp/Windows/TcpSocket.h>

Inheritance diagram for Activ::TcpSocket::Settings:

Activ::IpSocket::Settings

List of all members.

Public Member Functions

ACTIV_IP_API Settings (const bool shouldCork=false)
Constructor.

Detailed Description

Settings.

Definition at line 51 of file TcpSocket.h.

Constructor & Destructor Documentation

ACTIV_IP_API Activ::TcpSocket::Settings::Settings ( const bool shouldCork = false )

Constructor.

Parameters:
shouldCork set TCP_CORK, if available, whilst in tx loop.

Reimplemented from Activ::IpSocket::Settings.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivIp/Windows/TcpSocket.h
Generated on Wed Oct 8 14:02:00 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::TcpSocket::Stats

Activ::TcpSocket::Stats Class Reference

Stats. More...

#include <ActivMiddleware/ActivIp/Windows/TcpSocket.h>

Inheritance diagram for Activ::TcpSocket::Stats:

Activ::IpSocket::Stats

List of all members.

Public Member Functions

ACTIV_IP_API | Stats (const TcpSocket &socket)
Constructor.

Public Attributes

bool | m_acceptPosted
accept posted
bool | m_connectPosted
connect posted
State m_state
connection state

Detailed Description

Stats.

Definition at line 65 of file TcpSocket.h.

Constructor & Destructor Documentation

ACTIV_IP_API Activ::TcpSocket::Stats::Stats ( const TcpSocket & socket )

Constructor.

Note if constructing a Stats object directly, you the socket's mutex must be locked (this isn't done by the Stats constructor). Alternatively, use the helper function IpSocket::Stats::Get() which will lock the mutex for you before gathering the stats.

Parameters:
socket to get stats from.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivIp/Windows/TcpSocket.h
Generated on Wed Oct 8 14:02:00 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::TextArray

Activ::TextArray Class Reference

Text array class. More...

#include <ActivMiddleware/ActivFieldTypes/TextArray.h>

Inheritance diagram for Activ::TextArray:

Activ::IFieldType

List of all members.

Public Member Functions

virtual void | Clear ()
Clear the object.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		Compare (const void *const pRhsSerializedBody, const size_t rhsSerializedBodyLength, int &result) const
Compare.
ACTIV_FIELD_TYPES_API StatusCode | Compare (const TextArray &rhs, int &result) const
Compare.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		Convert (const IFieldType *const pIFieldType)
Convert another IFieldType object to this type.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		Deserialize (MessageValidator &messageValidator, const size_t maxSerializedBodyLength)
Deserialize the object from the supplied message validator.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		DeserializeBody (const void *const pSerializedBody, const size_t serializedBodyLength)
Deserialize the object's body from the supplied data buffer.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		DeserializeLengthAndBody (MessageValidator &messageValidator, const size_t maxSerializedBodyLength=MAX_SERIALIZED_BODY_LENGTH_UNDEFINED)
Deserialize the object's length and body from the supplied message validator.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		FromString (MessageValidator &messageValidator)
Convert the object from a string.
StatusCode | Get (const uint8_t *&pData, size_t &size) const
Get the data and size.
const uint8_t * | GetData () const
Get the data.
virtual ACTIV_FIELD_TYPES_API
std::string 		GetFromStringFormat () const
Get a usage string for the format supported by FromString().
virtual size_t | GetSerializedBodyLength () const
Get the serialized length of the object's body.
virtual size_t | GetSerializedLength () const
Get the serialized length of the object.
size_t | GetSize () const
Get the size.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		IsDifferent (const void *const pRhsSerializedBody, const size_t rhsSerializedBodyLength, bool &isDifferent) const
Is different.
TextArray & | operator= (const TextArray &rhs)
Assignment operator.
virtual void | Reset ()
Reset the object.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		Serialize (MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength) const
Serialize the object into the supplied message builder.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		SerializeBody (void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength) const
Serialize the object's body into the supplied data buffer.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		SerializeLengthAndBody (MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength=MAX_SERIALIZED_BODY_LENGTH_UNDEFINED) const
Serialize the object's length and body into the supplied message builder.
StatusCode | Set (const uint8_t *const pData, const size_t size)
Set the data and size.
TextArray (const TextArray &rhs)
Copy constructor.
TextArray (const uint8_t *const pData, const size_t size)
Constructor.
TextArray ()
Default constructor.
virtual ACTIV_FIELD_TYPES_API
std::string 		ToString () const
Convert the object to a string.
virtual | ~TextArray ()
Destructor.

Static Public Member Functions

static ACTIV_FIELD_TYPES_API
StatusCode 		Compare (const void *const pLhsSerializedBody, const size_t lhsSerializedBodyLength, const void *const pRhsSerializedBody, const size_t rhsSerializedBodyLength, int &result)
Compare two objects serialized bodies.
static ACTIV_FIELD_TYPES_API
StatusCode 		Deserialize (MessageValidator &messageValidator, const size_t maxSerializedBodyLength, const uint8_t *&pData, size_t &size)
Deserialize the object from the supplied message validator.
static ACTIV_FIELD_TYPES_API
StatusCode 		DeserializeBody (const void *const pSerializedBody, const size_t serializedBodyLength, const uint8_t *&pData, size_t &size)
Deserialize the object's body from the supplied data buffer.
static ACTIV_FIELD_TYPES_API
StatusCode 		DeserializeLengthAndBody (MessageValidator &messageValidator, const size_t maxSerializedBodyLength, const uint8_t *&pData, size_t &size)
Deserialize the object's length and body from the supplied message validator.
static size_t | GetMaxSerializedBodyLength (const size_t size)
Get the maximum serialized length of the object's body.
static size_t | GetMaxSerializedLength (const size_t size)
Get the maximum serialized length of the object.
static bool | IsValidSerializedBodyLength (const size_t serializedBodyLength)
Is valid serialized body length.
static ACTIV_FIELD_TYPES_API
StatusCode 		Serialize (MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength, const uint8_t *const pData, const size_t size)
Serialize the object into the supplied message builder.
static ACTIV_FIELD_TYPES_API
StatusCode 		SerializeBody (void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength, const uint8_t *const pData, const size_t size)
Serialize the object's body into the supplied data buffer.
static ACTIV_FIELD_TYPES_API
StatusCode 		SerializeLengthAndBody (MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength, const uint8_t *const pData, const size_t size)
Serialize the object's length and body into the supplied message builder.
static ACTIV_FIELD_TYPES_API
StatusCode 		ValidateSerializedLengthAndBody (MessageValidator &messageValidator, size_t &serializedBodyOffset, size_t &serializedBodyLength)
Validate the serialized length and body.

Static Public Attributes

static const FieldType | FIELD_TYPE = FIELD_TYPE_TEXT_ARRAY
The field type.

Detailed Description

Text array class.

Definition at line 30 of file TextArray.h.

Constructor & Destructor Documentation

Activ::TextArray::TextArray | ( | const uint8_t *const | pData,
 |  | const size_t | size |
 | ) |  |  | [inline]

Constructor.

Parameters:
pData | pointer to the data.
size | the size of the data.
Exceptions:
StatusCodeException

Definition at line 319 of file TextArray.h.

References ACTIV_THROW_RESULT_IF, and Set().

Activ::TextArray::TextArray ( const TextArray & rhs ) [inline]

Copy constructor.

Parameters:
rhs the value to assign to this object.

Definition at line 329 of file TextArray.h.

References ACTIV_THROW_RESULT_IF, Activ::IFieldType::IsInitialized(), Activ::IFieldType::m_isInitialized, m_pData, m_size, and Set().

Member Function Documentation

static ACTIV_FIELD_TYPES_API StatusCode Activ::TextArray::Compare | ( | const void *const | pLhsSerializedBody,
 |  | const size_t | lhsSerializedBodyLength,
 |  | const void *const | pRhsSerializedBody,
 |  | const size_t | rhsSerializedBodyLength,
 |  | int & | result |
 | ) |  |  | [static]

Compare two objects serialized bodies.

Parameters:
pLhsSerializedBody | the buffer containing the lhs serialized version of the object's body in.
lhsSerializedBodyLength | the lhs serialized body length.
pRhsSerializedBody | the buffer containing the rhs serialized version of the object's body in.
rhsSerializedBodyLength | the rhs serialized body length.
result | the result of the comparison.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::TextArray::Compare | ( | const void *const | pRhsSerializedBody,
 |  | const size_t | rhsSerializedBodyLength,
 |  | int & | result |
 | ) |  |  | const [virtual]

Compare.

Parameters:
pRhsSerializedBody | the buffer containing the rhs serialized version of the object's body in.
rhsSerializedBodyLength | the rhs serialized body length.
result | the result of the comparison.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

ACTIV_FIELD_TYPES_API StatusCode Activ::TextArray::Compare | ( | const TextArray & | rhs,
 |  | int & | result |
 | ) |  |  | const

Compare.

Parameters:
rhs | the object to compare with.
result | the result of the comparison.
Return values:
STATUS_CODE_SUCCESS

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::TextArray::Convert ( const IFieldType *const pIFieldType ) [virtual]

Convert another IFieldType object to this type.

Parameters:
pIFieldType the value to assign from.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_MISMATCH
...

Implements Activ::IFieldType.

static ACTIV_FIELD_TYPES_API StatusCode Activ::TextArray::Deserialize | ( | MessageValidator & | messageValidator,
 |  | const size_t | maxSerializedBodyLength,
 |  | const uint8_t *& | pData,
 |  | size_t & | size |
 | ) |  |  | [static]

Deserialize the object from the supplied message validator.

Parameters:
messageValidator | the message validator from which the object will be extracted.
maxSerializedBodyLength | the maximum serialized body length.
pData | pointer to the data.
size | the size of the data.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
...

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::TextArray::Deserialize | ( | MessageValidator & | messageValidator,
 |  | const size_t | maxSerializedBodyLength |
 | ) |  |  | [virtual]

Deserialize the object from the supplied message validator.

Parameters:
messageValidator | the message validator from which the object will be extracted.
maxSerializedBodyLength | the maximum serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

static ACTIV_FIELD_TYPES_API StatusCode Activ::TextArray::DeserializeBody | ( | const void *const | pSerializedBody,
 |  | const size_t | serializedBodyLength,
 |  | const uint8_t *& | pData,
 |  | size_t & | size |
 | ) |  |  | [static]

Deserialize the object's body from the supplied data buffer.

Parameters:
pSerializedBody | the buffer from which the object's body will be extracted.
serializedBodyLength | the serialized body length.
pData | pointer to the data.
size | the size of the data.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::TextArray::DeserializeBody | ( | const void *const | pSerializedBody,
 |  | const size_t | serializedBodyLength |
 | ) |  |  | [virtual]

Deserialize the object's body from the supplied data buffer.

Parameters:
pSerializedBody | the buffer from which the object's body will be extracted.
serializedBodyLength | the serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

static ACTIV_FIELD_TYPES_API StatusCode Activ::TextArray::DeserializeLengthAndBody | ( | MessageValidator & | messageValidator,
 |  | const size_t | maxSerializedBodyLength,
 |  | const uint8_t *& | pData,
 |  | size_t & | size |
 | ) |  |  | [static]

Deserialize the object's length and body from the supplied message validator.

Parameters:
messageValidator | the message validator from which the object will be extracted.
maxSerializedBodyLength | the maximum serialized body length.
pData | pointer to the data.
size | the size of the data.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
...

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::TextArray::DeserializeLengthAndBody | ( | MessageValidator & | messageValidator,
 |  | const size_t | maxSerializedBodyLength = MAX_SERIALIZED_BODY_LENGTH_UNDEFINED |
 | ) |  |  | [virtual]

Deserialize the object's length and body from the supplied message validator.

Parameters:
messageValidator | the message validator from which the object will be extracted.
maxSerializedBodyLength | the maximum serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::TextArray::FromString ( MessageValidator & messageValidator ) [virtual]

Convert the object from a string.

Parameters:
messageValidator the message validator.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

StatusCode Activ::TextArray::Get | ( | const uint8_t *& | pData,
 |  | size_t & | size |
 | ) |  |  | const [inline]

Get the data and size.

Parameters:
pData | pointer to the data.
size | the size of the data.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED

Definition at line 398 of file TextArray.h.

References Activ::IFieldType::IsInitialized().

const uint8_t * Activ::TextArray::GetData ( ) const [inline]

Get the data.

Returns:
the pointer to the data.
Exceptions:
StatusCodeException

Definition at line 411 of file TextArray.h.

References ACTIV_THROW, and Activ::IFieldType::IsInitialized().

virtual ACTIV_FIELD_TYPES_API std::string Activ::TextArray::GetFromStringFormat ( ) const [virtual]

Get a usage string for the format supported by FromString().

Returns:
String, may be empty.

Implements Activ::IFieldType.

size_t Activ::TextArray::GetMaxSerializedBodyLength ( const size_t size ) [inline, static]

Get the maximum serialized length of the object's body.

Parameters:
size the size of the data.
Returns:
the maximum serialized length of the object's body.

Definition at line 473 of file TextArray.h.

Referenced by GetMaxSerializedLength(), and GetSerializedBodyLength().

size_t Activ::TextArray::GetMaxSerializedLength ( const size_t size ) [inline, static]

Get the maximum serialized length of the object.

Parameters:
size the size of the data.
Returns:
the maximum serialized length of the object.

Definition at line 466 of file TextArray.h.

References GetMaxSerializedBodyLength().

Referenced by GetSerializedLength().

size_t Activ::TextArray::GetSerializedBodyLength ( ) const [inline, virtual]

Get the serialized length of the object's body.

Returns:
the serialized length of the object's body.

Implements Activ::IFieldType.

Definition at line 459 of file TextArray.h.

References GetMaxSerializedBodyLength(), and Activ::IFieldType::IsInitialized().

size_t Activ::TextArray::GetSerializedLength ( ) const [inline, virtual]

Get the serialized length of the object.

Returns:
the serialized length of the object.

Implements Activ::IFieldType.

Definition at line 452 of file TextArray.h.

References GetMaxSerializedLength(), and Activ::IFieldType::IsInitialized().

size_t Activ::TextArray::GetSize ( ) const [inline]

Get the size.

Returns:
the size of the data.
Exceptions:
StatusCodeException

Definition at line 421 of file TextArray.h.

References ACTIV_THROW, and Activ::IFieldType::IsInitialized().

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::TextArray::IsDifferent | ( | const void *const | pRhsSerializedBody,
 |  | const size_t | rhsSerializedBodyLength,
 |  | bool & | isDifferent |
 | ) |  |  | const [virtual]

Is different.

Parameters:
pRhsSerializedBody | the buffer containing the rhs serialized version of the object's body in.
rhsSerializedBodyLength | the rhs serialized body length.
isDifferent | indicates whether the two objects are different.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

bool Activ::TextArray::IsValidSerializedBodyLength ( const size_t serializedBodyLength ) [inline, static]

Is valid serialized body length.

Parameters:
serializedBodyLength the serialized body length.
Returns:
whether the serialized body length is valid.

Definition at line 480 of file TextArray.h.

TextArray & Activ::TextArray::operator= ( const TextArray & rhs ) [inline]

Assignment operator.

Parameters:
rhs the value to assign to this object.
Returns:
a reference to this object.

Definition at line 350 of file TextArray.h.

References ACTIV_THROW_RESULT_IF, Activ::IFieldType::IsInitialized(), m_pData, m_size, Reset(), and Set().

static ACTIV_FIELD_TYPES_API StatusCode Activ::TextArray::Serialize | ( | MessageBuilder & | messageBuilder,
 |  | const size_t | maxSerializedBodyLength,
 |  | const uint8_t *const | pData,
 |  | const size_t | size |
 | ) |  |  | [static]

Serialize the object into the supplied message builder.

Parameters:
messageBuilder | the message builder to store a serialized version of the object in.
maxSerializedBodyLength | the maximum serialized body length.
pData | pointer to the data.
size | the size of the data.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
...

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::TextArray::Serialize | ( | MessageBuilder & | messageBuilder,
 |  | const size_t | maxSerializedBodyLength |
 | ) |  |  | const [virtual]

Serialize the object into the supplied message builder.

Parameters:
messageBuilder | the message builder to store a serialized version of the object in.
maxSerializedBodyLength | the maximum serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

static ACTIV_FIELD_TYPES_API StatusCode Activ::TextArray::SerializeBody | ( | void * | pSerializedBody,
 |  | const size_t | maxSerializedBodyLength,
 |  | size_t & | serializedBodyLength,
 |  | const uint8_t *const | pData,
 |  | const size_t | size |
 | ) |  |  | [static]

Serialize the object's body into the supplied data buffer.

Parameters:
pSerializedBody | the buffer to store a serialized version of the object's body in.
maxSerializedBodyLength | the maximum serialized body length.
serializedBodyLength | the serialized body length.
pData | pointer to the data.
size | the size of the data.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
...

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::TextArray::SerializeBody | ( | void * | pSerializedBody,
 |  | const size_t | maxSerializedBodyLength,
 |  | size_t & | serializedBodyLength |
 | ) |  |  | const [virtual]

Serialize the object's body into the supplied data buffer.

Parameters:
pSerializedBody | the buffer to store a serialized version of the object's body in.
maxSerializedBodyLength | the maximum serialized body length.
serializedBodyLength | the serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

static ACTIV_FIELD_TYPES_API StatusCode Activ::TextArray::SerializeLengthAndBody | ( | MessageBuilder & | messageBuilder,
 |  | const size_t | maxSerializedBodyLength,
 |  | const uint8_t *const | pData,
 |  | const size_t | size |
 | ) |  |  | [static]

Serialize the object's length and body into the supplied message builder.

Parameters:
messageBuilder | the message builder to store a serialized version of the object in.
maxSerializedBodyLength | the maximum serialized body length.
pData | pointer to the data.
size | the size of the data.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
...

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::TextArray::SerializeLengthAndBody | ( | MessageBuilder & | messageBuilder,
 |  | const size_t | maxSerializedBodyLength = MAX_SERIALIZED_BODY_LENGTH_UNDEFINED |
 | ) |  |  | const [virtual]

Serialize the object's length and body into the supplied message builder.

Parameters:
messageBuilder | the message builder to store a serialized version of the object in.
maxSerializedBodyLength | the maximum serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

StatusCode Activ::TextArray::Set | ( | const uint8_t *const | pData,
 |  | const size_t | size |
 | ) |  |  | [inline]

Set the data and size.

Parameters:
pData | pointer to the data.
size | the size of the data.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_HEAP_EMPTY
STATUS_CODE_INVALID_PARAMETER

Definition at line 369 of file TextArray.h.

References Activ::IFieldType::m_isInitialized.

Referenced by operator=(), and TextArray().

virtual ACTIV_FIELD_TYPES_API std::string Activ::TextArray::ToString ( ) const [virtual]

Convert the object to a string.

Returns:
the object as a string.

Implements Activ::IFieldType.

static ACTIV_FIELD_TYPES_API StatusCode Activ::TextArray::ValidateSerializedLengthAndBody | ( | MessageValidator & | messageValidator,
 |  | size_t & | serializedBodyOffset,
 |  | size_t & | serializedBodyLength |
 | ) |  |  | [static]

Validate the serialized length and body.

Parameters:
messageValidator | the message validator.
serializedBodyOffset | the serialized body offset.
serializedBodyLength | the serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivFieldTypes/TextArray.h
Generated on Wed Oct 8 14:02:00 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::TextString

Activ::TextString Class Reference

Text string class. More...

#include <ActivMiddleware/ActivFieldTypes/TextString.h>

Inheritance diagram for Activ::TextString:

Activ::IFieldType

List of all members.

Public Member Functions

virtual void | Clear ()
Clear the object.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		Compare (const void *const pRhsSerializedBody, const size_t rhsSerializedBodyLength, int &result) const
Compare.
ACTIV_FIELD_TYPES_API StatusCode | Compare (const TextString &rhs, int &result) const
Compare.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		Convert (const IFieldType *const pIFieldType)
Convert another IFieldType object to this type.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		Deserialize (MessageValidator &messageValidator, const size_t maxSerializedBodyLength)
Deserialize the object from the supplied message validator.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		DeserializeBody (const void *const pSerializedBody, const size_t serializedBodyLength)
Deserialize the object's body from the supplied data buffer.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		DeserializeLengthAndBody (MessageValidator &messageValidator, const size_t maxSerializedBodyLength=MAX_SERIALIZED_BODY_LENGTH_UNDEFINED)
Deserialize the object's length and body from the supplied message validator.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		FromString (MessageValidator &messageValidator)
Convert the object from a string.
StatusCode | Get (const uint8_t *&pData, size_t &size) const
Get the data and size.
const uint8_t * | GetData () const
Get the data.
virtual ACTIV_FIELD_TYPES_API
std::string 		GetFromStringFormat () const
Get a usage string for the format supported by FromString().
virtual size_t | GetSerializedBodyLength () const
Get the serialized length of the object's body.
virtual size_t | GetSerializedLength () const
Get the serialized length of the object.
size_t | GetSize () const
Get the size.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		IsDifferent (const void *const pRhsSerializedBody, const size_t rhsSerializedBodyLength, bool &isDifferent) const
Is different.
TextString & | operator= (const TextString &rhs)
Assignment operator.
virtual void | Reset ()
Reset the object.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		Serialize (MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength) const
Serialize the object into the supplied message builder.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		SerializeBody (void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength) const
Serialize the object's body into the supplied data buffer.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		SerializeLengthAndBody (MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength=MAX_SERIALIZED_BODY_LENGTH_UNDEFINED) const
Serialize the object's length and body into the supplied message builder.
StatusCode | Set (const uint8_t *const pData, const size_t size)
Set the data and size.
TextString (const TextString &rhs)
Copy constructor.
TextString (const uint8_t *const pData, const size_t size)
Constructor.
TextString ()
Default constructor.
virtual ACTIV_FIELD_TYPES_API
std::string 		ToString () const
Convert the object to a string.
virtual | ~TextString ()
Destructor.

Static Public Member Functions

static ACTIV_FIELD_TYPES_API
StatusCode 		Compare (const void *const pLhsSerializedBody, const size_t lhsSerializedBodyLength, const void *const pRhsSerializedBody, const size_t rhsSerializedBodyLength, int &result)
Compare two objects serialized bodies.
static ACTIV_FIELD_TYPES_API
StatusCode 		Deserialize (MessageValidator &messageValidator, const size_t maxSerializedBodyLength, const uint8_t *&pData, size_t &size)
Deserialize the object from the supplied message validator.
static ACTIV_FIELD_TYPES_API
StatusCode 		DeserializeBody (const void *const pSerializedBody, const size_t serializedBodyLength, const uint8_t *&pData, size_t &size)
Deserialize the object's body from the supplied data buffer.
static ACTIV_FIELD_TYPES_API
StatusCode 		DeserializeLengthAndBody (MessageValidator &messageValidator, const size_t maxSerializedBodyLength, const uint8_t *&pData, size_t &size)
Deserialize the object's length and body from the supplied message validator.
static size_t | GetMaxSerializedBodyLength (const size_t size)
Get the maximum serialized length of the object's body.
static size_t | GetMaxSerializedLength (const size_t size)
Get the maximum serialized length of the object.
static bool | IsValidSerializedBodyLength (const size_t serializedBodyLength)
Is valid serialized body length.
static ACTIV_FIELD_TYPES_API
StatusCode 		Serialize (MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength, const uint8_t *const pData, const size_t size)
Serialize the object into the supplied message builder.
static ACTIV_FIELD_TYPES_API
StatusCode 		SerializeBody (void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength, const uint8_t *const pData, const size_t size)
Serialize the object's body into the supplied data buffer.
static ACTIV_FIELD_TYPES_API
StatusCode 		SerializeLengthAndBody (MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength, const uint8_t *const pData, const size_t size)
Serialize the object's length and body into the supplied message builder.
static ACTIV_FIELD_TYPES_API
StatusCode 		ValidateSerializedLengthAndBody (MessageValidator &messageValidator, size_t &serializedBodyOffset, size_t &serializedBodyLength)
Validate the serialized length and body.

Static Public Attributes

static const FieldType | FIELD_TYPE = FIELD_TYPE_TEXT_STRING
The field type.

Detailed Description

Text string class.

Definition at line 30 of file TextString.h.

Constructor & Destructor Documentation

Activ::TextString::TextString | ( | const uint8_t *const | pData,
 |  | const size_t | size |
 | ) |  |  | [inline]

Constructor.

Parameters:
pData | pointer to the data.
size | the size of the data.
Exceptions:
StatusCodeException

Definition at line 317 of file TextString.h.

References ACTIV_THROW_RESULT_IF, and Set().

Activ::TextString::TextString ( const TextString & rhs ) [inline]

Copy constructor.

Parameters:
rhs the value to assign to this object.

Definition at line 327 of file TextString.h.

References ACTIV_THROW_RESULT_IF, Activ::IFieldType::IsInitialized(), Activ::IFieldType::m_isInitialized, m_pData, m_size, and Set().

Member Function Documentation

static ACTIV_FIELD_TYPES_API StatusCode Activ::TextString::Compare | ( | const void *const | pLhsSerializedBody,
 |  | const size_t | lhsSerializedBodyLength,
 |  | const void *const | pRhsSerializedBody,
 |  | const size_t | rhsSerializedBodyLength,
 |  | int & | result |
 | ) |  |  | [static]

Compare two objects serialized bodies.

Parameters:
pLhsSerializedBody | the buffer containing the lhs serialized version of the object's body in.
lhsSerializedBodyLength | the lhs serialized body length.
pRhsSerializedBody | the buffer containing the rhs serialized version of the object's body in.
rhsSerializedBodyLength | the rhs serialized body length.
result | the result of the comparison.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::TextString::Compare | ( | const void *const | pRhsSerializedBody,
 |  | const size_t | rhsSerializedBodyLength,
 |  | int & | result |
 | ) |  |  | const [virtual]

Compare.

Parameters:
pRhsSerializedBody | the buffer containing the rhs serialized version of the object's body in.
rhsSerializedBodyLength | the rhs serialized body length.
result | the result of the comparison.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

ACTIV_FIELD_TYPES_API StatusCode Activ::TextString::Compare | ( | const TextString & | rhs,
 |  | int & | result |
 | ) |  |  | const

Compare.

Parameters:
rhs | the object to compare with.
result | the result of the comparison.
Return values:
STATUS_CODE_SUCCESS

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::TextString::Convert ( const IFieldType *const pIFieldType ) [virtual]

Convert another IFieldType object to this type.

Parameters:
pIFieldType the value to assign from.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_MISMATCH
...

Implements Activ::IFieldType.

static ACTIV_FIELD_TYPES_API StatusCode Activ::TextString::Deserialize | ( | MessageValidator & | messageValidator,
 |  | const size_t | maxSerializedBodyLength,
 |  | const uint8_t *& | pData,
 |  | size_t & | size |
 | ) |  |  | [static]

Deserialize the object from the supplied message validator.

Parameters:
messageValidator | the message validator from which the object will be extracted.
maxSerializedBodyLength | the maximum serialized body length.
pData | pointer to the data.
size | the size of the data.
Return values:
STATUS_CODE_SUCCESS
...

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::TextString::Deserialize | ( | MessageValidator & | messageValidator,
 |  | const size_t | maxSerializedBodyLength |
 | ) |  |  | [virtual]

Deserialize the object from the supplied message validator.

Parameters:
messageValidator | the message validator from which the object will be extracted.
maxSerializedBodyLength | the maximum serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

static ACTIV_FIELD_TYPES_API StatusCode Activ::TextString::DeserializeBody | ( | const void *const | pSerializedBody,
 |  | const size_t | serializedBodyLength,
 |  | const uint8_t *& | pData,
 |  | size_t & | size |
 | ) |  |  | [static]

Deserialize the object's body from the supplied data buffer.

Parameters:
pSerializedBody | the buffer from which the object's body will be extracted.
serializedBodyLength | the serialized body length.
pData | pointer to the data.
size | the size of the data.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::TextString::DeserializeBody | ( | const void *const | pSerializedBody,
 |  | const size_t | serializedBodyLength |
 | ) |  |  | [virtual]

Deserialize the object's body from the supplied data buffer.

Parameters:
pSerializedBody | the buffer from which the object's body will be extracted.
serializedBodyLength | the serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

static ACTIV_FIELD_TYPES_API StatusCode Activ::TextString::DeserializeLengthAndBody | ( | MessageValidator & | messageValidator,
 |  | const size_t | maxSerializedBodyLength,
 |  | const uint8_t *& | pData,
 |  | size_t & | size |
 | ) |  |  | [static]

Deserialize the object's length and body from the supplied message validator.

Parameters:
messageValidator | the message validator from which the object will be extracted.
maxSerializedBodyLength | the maximum serialized body length.
pData | pointer to the data.
size | the size of the data.
Return values:
STATUS_CODE_SUCCESS
...

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::TextString::DeserializeLengthAndBody | ( | MessageValidator & | messageValidator,
 |  | const size_t | maxSerializedBodyLength = MAX_SERIALIZED_BODY_LENGTH_UNDEFINED |
 | ) |  |  | [virtual]

Deserialize the object's length and body from the supplied message validator.

Parameters:
messageValidator | the message validator from which the object will be extracted.
maxSerializedBodyLength | the maximum serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::TextString::FromString ( MessageValidator & messageValidator ) [virtual]

Convert the object from a string.

Parameters:
messageValidator the message validator.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

StatusCode Activ::TextString::Get | ( | const uint8_t *& | pData,
 |  | size_t & | size |
 | ) |  |  | const [inline]

Get the data and size.

Parameters:
pData | pointer to the data.
size | the size of the data.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED

Definition at line 396 of file TextString.h.

References Activ::IFieldType::IsInitialized().

const uint8_t * Activ::TextString::GetData ( ) const [inline]

Get the data.

Returns:
the pointer to the data.
Exceptions:
StatusCodeException

Definition at line 409 of file TextString.h.

References ACTIV_THROW, and Activ::IFieldType::IsInitialized().

virtual ACTIV_FIELD_TYPES_API std::string Activ::TextString::GetFromStringFormat ( ) const [virtual]

Get a usage string for the format supported by FromString().

Returns:
String, may be empty.

Implements Activ::IFieldType.

size_t Activ::TextString::GetMaxSerializedBodyLength ( const size_t size ) [inline, static]

Get the maximum serialized length of the object's body.

Parameters:
size the size of the data.
Returns:
the maximum serialized length of the object's body.

Definition at line 471 of file TextString.h.

Referenced by GetMaxSerializedLength(), and GetSerializedBodyLength().

size_t Activ::TextString::GetMaxSerializedLength ( const size_t size ) [inline, static]

Get the maximum serialized length of the object.

Parameters:
size the size of the data.
Returns:
the maximum serialized length of the object.

Definition at line 464 of file TextString.h.

References GetMaxSerializedBodyLength().

Referenced by GetSerializedLength().

size_t Activ::TextString::GetSerializedBodyLength ( ) const [inline, virtual]

Get the serialized length of the object's body.

Returns:
the serialized length of the object's body.

Implements Activ::IFieldType.

Definition at line 457 of file TextString.h.

References GetMaxSerializedBodyLength(), and Activ::IFieldType::IsInitialized().

size_t Activ::TextString::GetSerializedLength ( ) const [inline, virtual]

Get the serialized length of the object.

Returns:
the serialized length of the object.

Implements Activ::IFieldType.

Definition at line 450 of file TextString.h.

References GetMaxSerializedLength(), and Activ::IFieldType::IsInitialized().

size_t Activ::TextString::GetSize ( ) const [inline]

Get the size.

Returns:
the size of the data.
Exceptions:
StatusCodeException

Definition at line 419 of file TextString.h.

References ACTIV_THROW, and Activ::IFieldType::IsInitialized().

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::TextString::IsDifferent | ( | const void *const | pRhsSerializedBody,
 |  | const size_t | rhsSerializedBodyLength,
 |  | bool & | isDifferent |
 | ) |  |  | const [virtual]

Is different.

Parameters:
pRhsSerializedBody | the buffer containing the rhs serialized version of the object's body in.
rhsSerializedBodyLength | the rhs serialized body length.
isDifferent | indicates whether the two objects are different.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

bool Activ::TextString::IsValidSerializedBodyLength ( const size_t serializedBodyLength ) [inline, static]

Is valid serialized body length.

Parameters:
serializedBodyLength the serialized body length.
Returns:
whether the serialized body length is valid.

Definition at line 478 of file TextString.h.

TextString & Activ::TextString::operator= ( const TextString & rhs ) [inline]

Assignment operator.

Parameters:
rhs the value to assign to this object.
Returns:
a reference to this object.

Definition at line 348 of file TextString.h.

References ACTIV_THROW_RESULT_IF, Activ::IFieldType::IsInitialized(), m_pData, m_size, Reset(), and Set().

static ACTIV_FIELD_TYPES_API StatusCode Activ::TextString::Serialize | ( | MessageBuilder & | messageBuilder,
 |  | const size_t | maxSerializedBodyLength,
 |  | const uint8_t *const | pData,
 |  | const size_t | size |
 | ) |  |  | [static]

Serialize the object into the supplied message builder.

Parameters:
messageBuilder | the message builder to store a serialized version of the object in.
maxSerializedBodyLength | the maximum serialized body length.
pData | pointer to the data.
size | the size of the data.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
...

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::TextString::Serialize | ( | MessageBuilder & | messageBuilder,
 |  | const size_t | maxSerializedBodyLength |
 | ) |  |  | const [virtual]

Serialize the object into the supplied message builder.

Parameters:
messageBuilder | the message builder to store a serialized version of the object in.
maxSerializedBodyLength | the maximum serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

static ACTIV_FIELD_TYPES_API StatusCode Activ::TextString::SerializeBody | ( | void * | pSerializedBody,
 |  | const size_t | maxSerializedBodyLength,
 |  | size_t & | serializedBodyLength,
 |  | const uint8_t *const | pData,
 |  | const size_t | size |
 | ) |  |  | [static]

Serialize the object's body into the supplied data buffer.

Parameters:
pSerializedBody | the buffer to store a serialized version of the object's body in.
maxSerializedBodyLength | the maximum serialized body length.
serializedBodyLength | the serialized body length.
pData | pointer to the data.
size | the size of the data.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
...

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::TextString::SerializeBody | ( | void * | pSerializedBody,
 |  | const size_t | maxSerializedBodyLength,
 |  | size_t & | serializedBodyLength |
 | ) |  |  | const [virtual]

Serialize the object's body into the supplied data buffer.

Parameters:
pSerializedBody | the buffer to store a serialized version of the object's body in.
maxSerializedBodyLength | the maximum serialized body length.
serializedBodyLength | the serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

static ACTIV_FIELD_TYPES_API StatusCode Activ::TextString::SerializeLengthAndBody | ( | MessageBuilder & | messageBuilder,
 |  | const size_t | maxSerializedBodyLength,
 |  | const uint8_t *const | pData,
 |  | const size_t | size |
 | ) |  |  | [static]

Serialize the object's length and body into the supplied message builder.

Parameters:
messageBuilder | the message builder to store a serialized version of the object in.
maxSerializedBodyLength | the maximum serialized body length.
pData | pointer to the data.
size | the size of the data.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
...

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::TextString::SerializeLengthAndBody | ( | MessageBuilder & | messageBuilder,
 |  | const size_t | maxSerializedBodyLength = MAX_SERIALIZED_BODY_LENGTH_UNDEFINED |
 | ) |  |  | const [virtual]

Serialize the object's length and body into the supplied message builder.

Parameters:
messageBuilder | the message builder to store a serialized version of the object in.
maxSerializedBodyLength | the maximum serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

StatusCode Activ::TextString::Set | ( | const uint8_t *const | pData,
 |  | const size_t | size |
 | ) |  |  | [inline]

Set the data and size.

Parameters:
pData | pointer to the data.
size | the size of the data.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_HEAP_EMPTY
STATUS_CODE_INVALID_PARAMETER

Definition at line 367 of file TextString.h.

References Activ::IFieldType::m_isInitialized.

Referenced by operator=(), and TextString().

virtual ACTIV_FIELD_TYPES_API std::string Activ::TextString::ToString ( ) const [virtual]

Convert the object to a string.

Returns:
the object as a string.

Implements Activ::IFieldType.

static ACTIV_FIELD_TYPES_API StatusCode Activ::TextString::ValidateSerializedLengthAndBody | ( | MessageValidator & | messageValidator,
 |  | size_t & | serializedBodyOffset,
 |  | size_t & | serializedBodyLength |
 | ) |  |  | [static]

Validate the serialized length and body.

Parameters:
messageValidator | the message validator.
serializedBodyOffset | the serialized body offset.
serializedBodyLength | the serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivFieldTypes/TextString.h
Generated on Wed Oct 8 14:02:00 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ThinApplication

Activ::ThinApplication Class Reference

Thin application class. More...

#include <ActivMiddleware/ActivFramework/ThinApplication.h>

Inheritance diagram for Activ::ThinApplication:

Activ::Application Activ::SystemProxy Activ::ManagedEndPoint Activ::Component Activ::ISystem Activ::Port

List of all members.

Public Member Functions

ACTIV_FRAMEWORK_API | ThinApplication (const Settings &settings, Timeout &timeout=Timeout::GetInfinite(), const std::string &componentId=defaultComponentId)
Constructor.
virtual ACTIV_FRAMEWORK_API | ~ThinApplication ()
Destructor.

Protected Member Functions

virtual ACTIV_FRAMEWORK_API
StatusCode 		OnMessage (HeapMessage &message)
Message callback.

Classes

class | Settings
Settings. More...

Detailed Description

Thin application class.

The ThinApplication class should be used when linking to an existing shared memory system. It provides access to always on agent services.

Definition at line 24 of file ThinApplication.h.

Constructor & Destructor Documentation

ACTIV_FRAMEWORK_API Activ::ThinApplication::ThinApplication | ( | const Settings & | settings,
 |  | Timeout & | timeout = Timeout::GetInfinite(),
 |  | const std::string & | componentId = defaultComponentId
 | ) |  |

Constructor.

Parameters:
settings | the Settings object to use.
timeout | how long to wait for the system to exist, in ms.
componentId | the component id.
Exceptions:
Exception.

Member Function Documentation

virtual ACTIV_FRAMEWORK_API StatusCode Activ::ThinApplication::OnMessage ( HeapMessage & message ) [protected, virtual]

Message callback.

If you override this method, please call the base class method for any unrecognized message types.

Parameters:
message the message.
Return values:
STATUS_CODE_SUCCESS | the message was recognized.
STATUS_CODE_UNRECOGNIZED | the message was not recognized.
STATUS_CODE_THREAD_EXIT | received a thread-die message.
...

Reimplemented from Activ::Application.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivFramework/ThinApplication.h
Generated on Wed Oct 8 14:02:00 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ThinApplication::Settings

Activ::ThinApplication::Settings Class Reference

Settings. More...

#include <ActivMiddleware/ActivFramework/ThinApplication.h>

Inheritance diagram for Activ::ThinApplication::Settings:

Activ::Application::Settings Activ::ISystem::Settings

List of all members.

Public Member Functions

ACTIV_FRAMEWORK_API StatusCode | Read (const IniFileParser &iniFileParser)
Read settings from an ini file section.
ACTIV_FRAMEWORK_API | Settings ()
Default constructor.

Public Attributes

IHeap::BucketInfoVector m_applicationHeapBucketInfo
size of the application heap. Default: empty (use system heap)
std::string | m_processName

Detailed Description

Settings.

Definition at line 30 of file ThinApplication.h.

Member Function Documentation

ACTIV_FRAMEWORK_API StatusCode Activ::ThinApplication::Settings::Read ( const IniFileParser & iniFileParser )

Read settings from an ini file section.

Parameters:
iniFileParser ini file.
Return values:
STATUS_CODE_SUCCESS
...

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivFramework/ThinApplication.h
Generated on Wed Oct 8 14:02:00 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Thread

Activ::Thread Class Reference

Thread base class. More...

#include <ActivMiddleware/ActivBase/Thread.h>

Inherited by Activ::IoCompletionManager::IoThread, and Activ::SmtpHelper::PostEmailThread.

List of all members.

Public Types

typedef DWORD | Id
thread id type for Windows
typedef std::vector< uint16_t > | ProcessorList
list of 0-based processor ids

Public Member Functions

ACTIV_BASE_EXPORTED_API void | End (StatusCode statusCode=STATUS_CODE_SUCCESS)
End the current thread.
ACTIV_BASE_EXPORTED_API Id | GetId () const
Get the thread id of the thread managed by this object.
ACTIV_BASE_EXPORTED_API StatusCode | GetPriority (uint32_t &priority) const
Get the priority of the thread managed by this object.
ACTIV_BASE_EXPORTED_API StatusCode | SetPriority (uint32_t priority)
Set the priority of the thread managed by this object.
ACTIV_BASE_EXPORTED_API void | Start (void *pData=0, const size_t stackSize=0)
Start the thread.
ACTIV_BASE_EXPORTED_API | Thread ()
Default constructor.
ACTIV_BASE_EXPORTED_API StatusCode | WaitForCompletion (const TimeoutPeriod timeoutPeriod=ACTIV_WAIT_INFINITE) const
Wait for the thread to exit.
virtual ACTIV_BASE_EXPORTED_API | ~Thread ()
Destructor.

Static Public Member Functions

static ACTIV_BASE_EXPORTED_API Id | GetCurrentId ()
Get the current thread id.
static ACTIV_BASE_EXPORTED_API
StatusCode 		GetThreadPriority (uint32_t &priority, const Id id=GetCurrentId())
Get the priority of any thread.
static ACTIV_BASE_EXPORTED_API void | SetName (const std::string &threadName, const Id id=GetCurrentId())
Set the name of a thread.
static ACTIV_BASE_EXPORTED_API
StatusCode 		SetProcessorAffinity (const ProcessorList &processorList, const Id id=GetCurrentId())
Set the processors a thread can be scheduled on.
static ACTIV_BASE_EXPORTED_API
StatusCode 		SetThreadPriority (const uint32_t priority, const Id id=GetCurrentId())
Set the priority of any thread.
static ACTIV_BASE_EXPORTED_API
StatusCode 		StringToPriority (const std::string &str, uint32_t &priority)
Convert string to thread priority. Valid priority strings are 'Idle', 'Lowest', 'BelowNormal', 'Normal', 'AboveNormal', 'Highest' and 'TimeCritical'.
static ACTIV_BASE_EXPORTED_API void | Suspend (const TimeoutPeriod period)
Suspend the execution of the current thread for the specified interval.

Protected Member Functions

virtual StatusCode | Process (void *pData)=0
Actual thread function (override this for your own processing).

Friends

unsigned WINAPI | ActivThreadGlobalThreadProc (void *pData)

Detailed Description

Thread base class.

Definition at line 37 of file Thread.h.

Member Function Documentation

ACTIV_BASE_EXPORTED_API void Activ::Thread::End ( StatusCode statusCode = STATUS_CODE_SUCCESS )

End the current thread.

Parameters:
statusCode the value to return from the thread.

static ACTIV_BASE_EXPORTED_API Id Activ::Thread::GetCurrentId ( ) [static]

Get the current thread id.

Returns:
The id of the calling thread.

ACTIV_BASE_EXPORTED_API Id Activ::Thread::GetId ( ) const

Get the thread id of the thread managed by this object.

Returns:
Thread id.

ACTIV_BASE_EXPORTED_API StatusCode Activ::Thread::GetPriority ( uint32_t & priority ) const

Get the priority of the thread managed by this object.

Parameters:
priority thread priority.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_FAILURE

static ACTIV_BASE_EXPORTED_API StatusCode Activ::Thread::GetThreadPriority | ( | uint32_t & | priority,
 |  | const Id | id = GetCurrentId() |
 | ) |  |  | [static]

Get the priority of any thread.

Parameters:
priority | thread priority.
id | id of the thread to get the priority for, default the calling thread.
Return values:
STATUS_CODE_SUCCESS
...

virtual StatusCode Activ::Thread::Process ( void * pData ) [protected, pure virtual]

Actual thread function (override this for your own processing).

Parameters:
pData thread data pointer as passed to Start().

static ACTIV_BASE_EXPORTED_API void Activ::Thread::SetName | ( | const std::string & | threadName,
 |  | const Id | id = GetCurrentId() |
 | ) |  |  | [static]

Set the name of a thread.

Certain platforms may allow the setting of a 'name' for a thread, viewable in debuggers.

Parameters:
threadName | the name to give the thread.
id | the id of the thread to name (or default is current thread).

ACTIV_BASE_EXPORTED_API StatusCode Activ::Thread::SetPriority ( uint32_t priority )

Set the priority of the thread managed by this object.

Parameters:
priority new thread priority.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_FAILURE

static ACTIV_BASE_EXPORTED_API StatusCode Activ::Thread::SetProcessorAffinity | ( | const ProcessorList & | processorList,
 |  | const Id | id = GetCurrentId() |
 | ) |  |  | [static]

Set the processors a thread can be scheduled on.

Parameters:
processorList | list of 0-indexed processors this thread can run on. If the list is empty, the thread will be set to have no affinity to particular processors.
id | id of the thread to set the affinities for, default the calling thread.
Return values:
STATUS_CODE_SUCCESS
...

static ACTIV_BASE_EXPORTED_API StatusCode Activ::Thread::SetThreadPriority | ( | const uint32_t | priority,
 |  | const Id | id = GetCurrentId() |
 | ) |  |  | [static]

Set the priority of any thread.

Parameters:
priority | new thread priority.
id | id of the thread to set the priority for, default the calling thread.
Return values:
STATUS_CODE_SUCCESS
...

ACTIV_BASE_EXPORTED_API void Activ::Thread::Start | ( | void * | pData = 0,
 |  | const size_t | stackSize = 0
 | ) |  |

Start the thread.

Parameters:
pData | thread parameter.
stackSize | optional stack size.
Exceptions:
Exception.

static ACTIV_BASE_EXPORTED_API StatusCode Activ::Thread::StringToPriority | ( | const std::string & | str,
 |  | uint32_t & | priority |
 | ) |  |  | [static]

Convert string to thread priority. Valid priority strings are 'Idle', 'Lowest', 'BelowNormal', 'Normal', 'AboveNormal', 'Highest' and 'TimeCritical'.

Parameters:
str | string to convert. Note case is ignored.
priority | converted thread priority.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_FAILURE

static ACTIV_BASE_EXPORTED_API void Activ::Thread::Suspend ( const TimeoutPeriod period ) [static]

Suspend the execution of the current thread for the specified interval.

Parameters:
period the period to sleep for, in ms.

ACTIV_BASE_EXPORTED_API StatusCode Activ::Thread::WaitForCompletion ( const TimeoutPeriod timeoutPeriod = ACTIV_WAIT_INFINITE ) const

Wait for the thread to exit.

Parameters:
timeoutPeriod the timeout period to wait, in ms.
Returns:
The return value from the thread Process() function.
Exceptions:
Exception.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivBase/Thread.h
Generated on Wed Oct 8 14:02:00 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ThreadSpecificData

Activ::ThreadSpecificData< TYPE, CLEANUP > Class Template Reference

Thread specific data helper class. More...

#include <ActivMiddleware/ActivBase/ThreadSpecificData.h>

Inheritance diagram for Activ::ThreadSpecificData< TYPE, CLEANUP >:

Activ::ThreadSpecificDataBase< TYPE, DERIVED >

List of all members.

Public Member Functions

void OnThreadExit (TYPE *const pValue)
Method invoked whenever a thread exits for all non-NULL thread-specific datas.

Detailed Description

template<typename TYPE, typename CLEANUP>
class Activ::ThreadSpecificData< TYPE, CLEANUP >

Thread specific data helper class.

Stores pointers of TYPE *. Invokes a function object for per-thread cleanup.

This class can be used as follows (for storing pointers of type MyData *) which deletes the objects on thread exit:

ThreadSpecificData<MyData, DeleteObject> m_myThreadSpecificData;

Or to do nothing on thread exit:

ThreadSpecificData<MyData, NullObject> m_myThreadSpecificData;

Parameters:
TYPE | the type to store in thread-local storage.
CLEANUP | function object type to invoke.

Definition at line 140 of file ThreadSpecificData.h.

Member Function Documentation

template<typename TYPE, typename CLEANUP>
void Activ::ThreadSpecificData< TYPE, CLEANUP >::OnThreadExit ( TYPE *const pValue ) [inline]

Method invoked whenever a thread exits for all non-NULL thread-specific datas.

The default implementation of this method does nothing.

Parameters:
pValue current value for the exiting thread.

Reimplemented from Activ::ThreadSpecificDataBase< TYPE, DERIVED >.

Definition at line 143 of file ThreadSpecificData.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivBase/ThreadSpecificData.h
Generated on Wed Oct 8 14:02:00 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ThreadSpecificDataBase

Activ::ThreadSpecificDataBase< TYPE, DERIVED > Class Template Reference

Thread specific data helper base class. More...

#include <ActivMiddleware/ActivBase/ThreadSpecificData.h>

Inheritance diagram for Activ::ThreadSpecificDataBase< TYPE, DERIVED >:

Activ::ThreadSpecificData< TYPE, CLEANUP >

List of all members.

Public Member Functions

TYPE * | Get () const
Get the current value of thread specific data for this thread.
void | OnThreadExit (TYPE *const pValue)
Method invoked whenever a thread exits for all non-NULL thread-specific datas.
void | Set (TYPE *const pValue)
Set the current value of thread specific data for this thread.
ThreadSpecificDataBase ()
Constructor. Allocate thread specific storage.
~ThreadSpecificDataBase ()
Destructor. Free the specific storage.

Classes

class | PerThreadInfo
Data stored per-thread.

Detailed Description

template<typename TYPE, typename DERIVED>
class Activ::ThreadSpecificDataBase< TYPE, DERIVED >

Thread specific data helper base class.

Stores pointers of TYPE *.

This class makes use of the curiously-recurring template pattern to implement per-thread cleanup of data.

This class can be used as follows (for storing pointers of type MyData *):

class MyThreadSpecificData : public ThreadSpecificDataBase<MyData, MyThreadSpecificData> { public: void OnThreadExit(MyData * const pMyData) { // do whatever per-thread cleanup you require, e.g. delete pMyData; } };

The OnThreadExit() method of the derived class will be called whenever a thread that has a non-NULL value for the stored pointer exits.

Most likely the kind of cleanup to be carried out here will be deleting of newed per-thread data - see the ThreadSpecificData class defined below for such simple cases.

Parameters:
TYPE | the type to store in thread-local storage.
DERIVED | the class deriving from this class.

Definition at line 48 of file ThreadSpecificData.h.

Constructor & Destructor Documentation

template<typename TYPE, typename DERIVED>
Activ::ThreadSpecificDataBase< TYPE, DERIVED >::ThreadSpecificDataBase ( ) [inline]

Constructor. Allocate thread specific storage.

Exceptions:
Exception.

Definition at line 32 of file ThreadSpecificDataDetail.h.

References ACTIV_THROW.

Member Function Documentation

template<typename TYPE, typename DERIVED>
TYPE * Activ::ThreadSpecificDataBase< TYPE, DERIVED >::Get ( ) const [inline]

Get the current value of thread specific data for this thread.

Returns:
Current value (0 if not set yet).

Definition at line 58 of file ThreadSpecificDataDetail.h.

template<typename TYPE, typename DERIVED>
void Activ::ThreadSpecificDataBase< TYPE, DERIVED >::OnThreadExit ( TYPE *const pValue )

Method invoked whenever a thread exits for all non-NULL thread-specific datas.

The default implementation of this method does nothing.

Parameters:
pValue current value for the exiting thread.

Reimplemented in Activ::ThreadSpecificData< TYPE, CLEANUP >.

template<typename TYPE, typename DERIVED>
void Activ::ThreadSpecificDataBase< TYPE, DERIVED >::Set ( TYPE *const pValue ) [inline]

Set the current value of thread specific data for this thread.

Parameters:
pValue to set.

Definition at line 71 of file ThreadSpecificDataDetail.h.

The documentation for this class was generated from the following files:
  • include/ActivMiddleware/ActivBase/ThreadSpecificData.h
  • include/ActivMiddleware/ActivBase/Detail/ThreadSpecificDataDetail.h
Generated on Wed Oct 8 14:02:00 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ThreadSpecificFastPoolAllocator

Activ::ThreadSpecificFastPoolAllocator< T, UserAllocator, NextSize > Class Template Reference

boost::fast_pool_allocator like std allocator, except pool is thread local rather than process wide. More...

#include <ActivMiddleware/ActivBase/ThreadSpecificPoolAllocators.h>

List of all members.

Public Types

typedef const value_type * | const_pointer
typedef const value_type & | const_reference
typedef boost::pool
< UserAllocator >
::difference_type 		difference_type
typedef value_type * | pointer
typedef value_type & | reference
typedef boost::pool
< UserAllocator >::size_type 		size_type
typedef UserAllocator | user_allocator
typedef T | value_type

Public Member Functions

bool | operator!= (const ThreadSpecificFastPoolAllocator &) const
bool | operator== (const ThreadSpecificFastPoolAllocator &) const
template<typename U>
ThreadSpecificFastPoolAllocator (const ThreadSpecificFastPoolAllocator< U, UserAllocator, NextSize > &)

Static Public Member Functions

static const_pointer | address (const_reference s)
static pointer | address (reference r)
static pointer | allocate ()
static pointer | allocate (const size_type n, const void *const)
static pointer | allocate (const size_type n)
static void | construct (const pointer ptr, const value_type &t)
static void | deallocate (const pointer ptr)
static void | deallocate (const pointer ptr, const size_type n)
static void | destroy (const pointer ptr)
static size_type | max_size ()

Static Public Attributes

static const unsigned | next_size = NextSize

Classes

struct | rebind
class | ThreadSingleton

Detailed Description

template<typename T, typename UserAllocator = boost::default_user_allocator_new_delete, unsigned NextSize = 32>
class Activ::ThreadSpecificFastPoolAllocator< T, UserAllocator, NextSize >

boost::fast_pool_allocator like std allocator, except pool is thread local rather than process wide.

See http://boost.org/doc/libs/1_35_0/libs/pool/doc/interfaces/pool_alloc.html for more information.

Memory must be allocated and freed from the same thread! This class is better suited to containers where single nodes are allocated (e.g. set, list, etc.) rather than contiguous blocks of nodes (e.g. vector, possibly hash_map).

Definition at line 188 of file ThreadSpecificPoolAllocators.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivBase/ThreadSpecificPoolAllocators.h
Generated on Wed Oct 8 14:02:00 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ThreadSpecificPoolAllocator

Activ::ThreadSpecificPoolAllocator< T, UserAllocator, NextSize > Class Template Reference

boost::pool_allocator like std allocator, except the pool is thread local rather than process wide. More...

#include <ActivMiddleware/ActivBase/ThreadSpecificPoolAllocators.h>

List of all members.

Public Types

typedef const value_type * | const_pointer
typedef const value_type & | const_reference
typedef boost::pool
< UserAllocator >
::difference_type 		difference_type
typedef value_type * | pointer
typedef value_type & | reference
typedef boost::pool
< UserAllocator >::size_type 		size_type
typedef UserAllocator | user_allocator
typedef T | value_type

Public Member Functions

bool | operator!= (const ThreadSpecificPoolAllocator &) const
bool | operator== (const ThreadSpecificPoolAllocator &) const
template<typename U>
ThreadSpecificPoolAllocator (const ThreadSpecificPoolAllocator< U, UserAllocator, NextSize > &)

Static Public Member Functions

static const_pointer | address (const_reference s)
static pointer | address (reference r)
static pointer | allocate (const size_type n, const void *const)
static pointer | allocate (const size_type n)
static void | construct (const pointer ptr, const value_type &t)
static void | deallocate (const pointer ptr, const size_type n)
static void | destroy (const pointer ptr)
static size_type | max_size ()
static bool | ReleaseMemory ()
ACTIV interface addition: release memory.

Static Public Attributes

static const unsigned | next_size = NextSize

Classes

struct | rebind
class | ThreadSingleton

Detailed Description

template<typename T, typename UserAllocator = boost::default_user_allocator_new_delete, unsigned NextSize = 32>
class Activ::ThreadSpecificPoolAllocator< T, UserAllocator, NextSize >

boost::pool_allocator like std allocator, except the pool is thread local rather than process wide.

See http://boost.org/doc/libs/1_35_0/libs/pool/doc/interfaces/pool_alloc.html for more information.

Memory must be allocated and freed from the same thread! This class is suited to any container type.

Definition at line 30 of file ThreadSpecificPoolAllocators.h.

Member Function Documentation

template<typename T, typename UserAllocator = boost::default_user_allocator_new_delete, unsigned NextSize = 32>
static bool Activ::ThreadSpecificPoolAllocator< T, UserAllocator, NextSize >::ReleaseMemory ( ) [inline, static]

ACTIV interface addition: release memory.

Frees every memory block that doesn't have any allocated chunks.

Returns:
true if at least one memory block was freed.

Definition at line 143 of file ThreadSpecificPoolAllocators.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivBase/ThreadSpecificPoolAllocators.h
Generated on Wed Oct 8 14:02:00 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Time

Activ::Time Class Reference

Time class. More...

#include <ActivMiddleware/ActivFieldTypes/Time.h>

Inheritance diagram for Activ::Time:

Activ::IFieldType

List of all members.

Public Member Functions

StatusCode | Add (const Milliseconds &milliseconds)
Add.
StatusCode | Add (const Seconds &seconds)
Add.
StatusCode | Add (const Minutes &minutes)
Add.
StatusCode | Add (const Hours &hours)
Add.
StatusCode | Add (const Time &rhs)
Add.
virtual void | Clear ()
Clear the object.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		Compare (const void *const pRhsSerializedBody, const size_t rhsSerializedBodyLength, int &result) const
Compare.
ACTIV_FIELD_TYPES_API StatusCode | Compare (const Time &rhs, int &result) const
Compare.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		Convert (const IFieldType *const pIFieldType)
Convert another IFieldType object to this type.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		Deserialize (MessageValidator &messageValidator, const size_t maxSerializedBodyLength)
Deserialize the object from the supplied message validator.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		DeserializeBody (const void *const pSerializedBody, const size_t serializedBodyLength)
Deserialize the object's body from the supplied data buffer.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		DeserializeLengthAndBody (MessageValidator &messageValidator, const size_t maxSerializedBodyLength=MAX_SERIALIZED_BODY_LENGTH_UNDEFINED)
Deserialize the object's length and body from the supplied message validator.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		FromString (MessageValidator &messageValidator)
Convert the object from a string.
StatusCode | Get (std::tm &tm, uint32_t &millisecond) const
Get the time.
StatusCode | Get (std::tm &tm) const
Get the time.
StatusCode | Get (int32_t &julianTime, uint32_t &millisecond) const
Get the time.
StatusCode | Get (int32_t &julianTime) const
Get the time.
StatusCode | Get (uint32_t &hour, uint32_t &minute, uint32_t &second, uint32_t &millisecond) const
Get the time.
StatusCode | Get (uint32_t &hour, uint32_t &minute, uint32_t &second) const
Get the time.
int32_t | Get () const
Get the julian time.
virtual ACTIV_FIELD_TYPES_API
std::string 		GetFromStringFormat () const
Get a usage string for the format supported by FromString().
uint32_t | GetHour () const
Get the hour.
Time | GetLocal () const
Get the local time.
uint32_t | GetMillisecond () const
Get the millisecond.
uint32_t | GetMinute () const
Get the minute.
uint32_t | GetSecond () const
Get the second.
virtual size_t | GetSerializedBodyLength () const
Get the serialized length of the object's body.
virtual size_t | GetSerializedLength () const
Get the serialized length of the object.
uint32_t | GetTotalMilliseconds () const
Get the total milliseconds.
Time | GetUtc () const
Get the UTC time.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		IsDifferent (const void *const pRhsSerializedBody, const size_t rhsSerializedBodyLength, bool &isDifferent) const
Is different.
bool | operator!= (const Time &rhs) const
Inequality operator.
template<typename T>
const Time | operator+ (const T &rhs) const
Addition operator.
template<typename T>
Time & | operator+= (const T &rhs)
Addition assignment operator.
template<typename T>
const Time | operator- (const T &rhs) const
Subtraction operator.
template<typename T>
Time & | operator-= (const T &rhs)
Subtraction assignment operator.
bool | operator< (const Time &rhs) const
Less than operator.
bool | operator<= (const Time &rhs) const
Less than or equal to operator.
bool | operator== (const Time &rhs) const
Equality operator.
bool | operator> (const Time &rhs) const
Greater than operator.
bool | operator>= (const Time &rhs) const
Greater than or equal to operator.
virtual void | Reset ()
Reset the object.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		Serialize (MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength) const
Serialize the object into the supplied message builder.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		SerializeBody (void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength) const
Serialize the object's body into the supplied data buffer.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		SerializeLengthAndBody (MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength=MAX_SERIALIZED_BODY_LENGTH_UNDEFINED) const
Serialize the object's length and body into the supplied message builder.
StatusCode | Set (const std::tm &tm, const uint32_t millisecond=0)
Store a new time.
StatusCode | Set (const int32_t julianTime, const uint32_t millisecond=0)
Store a new time.
StatusCode | Set (const uint32_t hour, const uint32_t minute, const uint32_t second, const uint32_t millisecond=0)
Store a new time.
StatusCode | Subtract (const Milliseconds &milliseconds)
Subtract.
StatusCode | Subtract (const Seconds &seconds)
Subtract.
StatusCode | Subtract (const Minutes &minutes)
Subtract.
StatusCode | Subtract (const Hours &hours)
Subtract.
StatusCode | Subtract (const Time &rhs)
Subtract.
Time (const std::tm &tm, const uint32_t millisecond=0)
Constructor.
Time (const int32_t julianTime, const uint32_t millisecond=0)
Constructor.
Time (const uint32_t hour, const uint32_t minute, const uint32_t second, const uint32_t millisecond=0)
Constructor.
Time ()
Default constructor.
ACTIV_FIELD_TYPES_API std::string | ToString (const bool shouldDisplayMilliseconds) const
Convert the object to a string.
virtual ACTIV_FIELD_TYPES_API
std::string 		ToString () const
Convert the object to a string.
virtual | ~Time ()
Destructor.

Static Public Member Functions

static ACTIV_FIELD_TYPES_API
StatusCode 		Compare (const void *const pLhsSerializedBody, const size_t lhsSerializedBodyLength, const void *const pRhsSerializedBody, const size_t rhsSerializedBodyLength, int &result)
Compare two objects serialized bodies.
static int32_t | ConvertGregorianToJulianTime (const int32_t hour, const int32_t minute, const int32_t second)
Convert gregorian to julian time.
static void | ConvertJulianToGregorianTime (const int32_t julianTime, int32_t &hour, int32_t &minute, int32_t &second)
Convert julian to gregorian time.
static ACTIV_FIELD_TYPES_API Time | CreateLocalTime (const bool shouldSetMilliseconds=false)
Create an object intitialised with the current local time.
static ACTIV_FIELD_TYPES_API Time | CreateUtcTime (const bool shouldSetMilliseconds=false)
Create an object intitialised with the current UTC time.
static size_t | GetMaxSerializedBodyLength (const bool shouldSerializeMilliseconds)
Get the maximum serialized length of the object's body.
static size_t | GetMaxSerializedLength (const bool shouldSerializeMilliseconds)
Get the maximum serialized length of the object.
static size_t | GetSerializedBodyLength (const void *const pSerializedBody)
Get the maximum serialized length of the object's body.
static size_t | GetSerializedLength (const void *const pSerializedBody)
Get the maximum serialized length of the object.
static ACTIV_FIELD_TYPES_API
int32_t 		GetTimeZoneOffset ()
Get the time zone offset (local from UTC).
static bool | IsValidSerializedBodyLength (const size_t serializedBodyLength)
Is valid serialized body length.
static ACTIV_FIELD_TYPES_API
StatusCode 		ValidateSerializedLengthAndBody (MessageValidator &messageValidator, size_t &serializedBodyOffset, size_t &serializedBodyLength)
Validate the serialized length and body.

Static Public Attributes

static const FieldType | FIELD_TYPE = FIELD_TYPE_TIME
The field type.

Friends

class | DateTime

Classes

class | Hours
Hours class. More...
class | Milliseconds
Milliseconds class. More...
class | Minutes
Minutes class. More...
class | Seconds
Seconds class. More...

Detailed Description

Time class.

Definition at line 30 of file Time.h.

Constructor & Destructor Documentation

Activ::Time::Time | ( | const uint32_t | hour,
 |  | const uint32_t | minute,
 |  | const uint32_t | second,
 |  | const uint32_t | millisecond = 0 |
 | ) |  |  | [inline]

Constructor.

Parameters:
hour | the hour.
minute | the minute.
second | the second.
millisecond | the millisecond.
Exceptions:
StatusCodeException

Definition at line 761 of file Time.h.

References ACTIV_THROW_RESULT_IF, and Set().

Activ::Time::Time | ( | const int32_t | julianTime,
 |  | const uint32_t | millisecond = 0 |
 | ) |  |  | [inline, explicit]

Constructor.

Parameters:
julianTime | the julian time.
millisecond | the millisecond.
Exceptions:
StatusCodeException

Definition at line 769 of file Time.h.

References ACTIV_THROW_RESULT_IF, and Set().

Activ::Time::Time | ( | const std::tm & | tm,
 |  | const uint32_t | millisecond = 0 |
 | ) |  |  | [inline]

Constructor.

Uses the tm_hour, tm_min and tm_sec fields of the provided tm structure.

Parameters:
tm | reference to a tm structure specifying the time.
millisecond | the millisecond.
Exceptions:
StatusCodeException

Definition at line 777 of file Time.h.

References ACTIV_THROW_RESULT_IF, and Set().

Member Function Documentation

StatusCode Activ::Time::Add ( const Milliseconds & milliseconds ) [inline]

Add.

Parameters:
milliseconds the number of milliseconds to add to this object.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED

Definition at line 1101 of file Time.h.

References GetTotalMilliseconds(), Activ::IFieldType::IsInitialized(), Activ::Time::Milliseconds::m_value, Activ::Time::Milliseconds::NUMBER_PER_DAY, Activ::Time::Milliseconds::NUMBER_PER_SECOND, and Set().

StatusCode Activ::Time::Add ( const Seconds & seconds ) [inline]

Add.

Parameters:
seconds the number of seconds to add to this object.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED

Definition at line 1094 of file Time.h.

References Add(), Activ::Time::Seconds::m_value, Activ::Time::Seconds::NUMBER_PER_DAY, and Activ::Time::Milliseconds::NUMBER_PER_SECOND.

StatusCode Activ::Time::Add ( const Minutes & minutes ) [inline]

Add.

Parameters:
minutes the number of minutes to add to this object.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED

Definition at line 1087 of file Time.h.

References Add(), Activ::Time::Minutes::m_value, Activ::Time::Minutes::NUMBER_PER_DAY, and Activ::Time::Milliseconds::NUMBER_PER_MINUTE.

StatusCode Activ::Time::Add ( const Hours & hours ) [inline]

Add.

Parameters:
hours the number of hours to add to this object.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED

Definition at line 1080 of file Time.h.

References Add(), Activ::Time::Hours::m_value, Activ::Time::Hours::NUMBER_PER_DAY, and Activ::Time::Milliseconds::NUMBER_PER_HOUR.

StatusCode Activ::Time::Add ( const Time & rhs ) [inline]

Add.

Parameters:
rhs the value to add to this object.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED

Definition at line 1070 of file Time.h.

References GetTotalMilliseconds(), and Activ::IFieldType::IsInitialized().

Referenced by Add(), and operator+=().

static ACTIV_FIELD_TYPES_API StatusCode Activ::Time::Compare | ( | const void *const | pLhsSerializedBody,
 |  | const size_t | lhsSerializedBodyLength,
 |  | const void *const | pRhsSerializedBody,
 |  | const size_t | rhsSerializedBodyLength,
 |  | int & | result |
 | ) |  |  | [static]

Compare two objects serialized bodies.

Parameters:
pLhsSerializedBody | the buffer containing the lhs serialized version of the object's body in.
lhsSerializedBodyLength | the lhs serialized body length.
pRhsSerializedBody | the buffer containing the rhs serialized version of the object's body in.
rhsSerializedBodyLength | the rhs serialized body length.
result | the result of the comparison.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::Time::Compare | ( | const void *const | pRhsSerializedBody,
 |  | const size_t | rhsSerializedBodyLength,
 |  | int & | result |
 | ) |  |  | const [virtual]

Compare.

Parameters:
pRhsSerializedBody | the buffer containing the rhs serialized version of the object's body in.
rhsSerializedBodyLength | the rhs serialized body length.
result | the result of the comparison.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

ACTIV_FIELD_TYPES_API StatusCode Activ::Time::Compare | ( | const Time & | rhs,
 |  | int & | result |
 | ) |  |  | const

Compare.

Parameters:
rhs | the object to compare with.
result | the result of the comparison.
Return values:
STATUS_CODE_SUCCESS

Referenced by operator<(), operator==(), and operator>().

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::Time::Convert ( const IFieldType *const pIFieldType ) [virtual]

Convert another IFieldType object to this type.

Parameters:
pIFieldType the value to assign from.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_MISMATCH
...

Implements Activ::IFieldType.

int32_t Activ::Time::ConvertGregorianToJulianTime | ( | const int32_t | hour,
 |  | const int32_t | minute,
 |  | const int32_t | second |
 | ) |  |  | [inline, static]

Convert gregorian to julian time.

Parameters:
hour | the hour.
minute | the minute.
second | the second.
Returns:
the julian time.

Definition at line 1224 of file Time.h.

References Activ::Time::Minutes::NUMBER_PER_HOUR, and Activ::Time::Seconds::NUMBER_PER_MINUTE.

Referenced by Activ::DateTime::ConvertGregorianToJulianDateTime(), Get(), and GetTotalMilliseconds().

void Activ::Time::ConvertJulianToGregorianTime | ( | const int32_t | julianTime,
 |  | int32_t & | hour,
 |  | int32_t & | minute,
 |  | int32_t & | second |
 | ) |  |  | [inline, static]

Convert julian to gregorian time.

Parameters:
julianTime | the julian time.
hour | the hour.
minute | the minute.
second | the second.

Definition at line 1215 of file Time.h.

References Activ::Time::Seconds::NUMBER_PER_HOUR, and Activ::Time::Seconds::NUMBER_PER_MINUTE.

Referenced by Activ::DateTime::ConvertJulianToGregorianDateTime(), and Set().

static ACTIV_FIELD_TYPES_API Time Activ::Time::CreateLocalTime ( const bool shouldSetMilliseconds = false ) [static]

Create an object intitialised with the current local time.

Parameters:
shouldSetMilliseconds indicates whether milliseconds should be set.
Returns:
the initialized object.

static ACTIV_FIELD_TYPES_API Time Activ::Time::CreateUtcTime ( const bool shouldSetMilliseconds = false ) [static]

Create an object intitialised with the current UTC time.

Parameters:
shouldSetMilliseconds indicates whether milliseconds should be set.
Returns:
the initialized object.

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::Time::Deserialize | ( | MessageValidator & | messageValidator,
 |  | const size_t | maxSerializedBodyLength |
 | ) |  |  | [virtual]

Deserialize the object from the supplied message validator.

Parameters:
messageValidator | the message validator from which the object will be extracted.
maxSerializedBodyLength | the maximum serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::Time::DeserializeBody | ( | const void *const | pSerializedBody,
 |  | const size_t | serializedBodyLength |
 | ) |  |  | [virtual]

Deserialize the object's body from the supplied data buffer.

Parameters:
pSerializedBody | the buffer from which the object's body will be extracted.
serializedBodyLength | the serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::Time::DeserializeLengthAndBody | ( | MessageValidator & | messageValidator,
 |  | const size_t | maxSerializedBodyLength = MAX_SERIALIZED_BODY_LENGTH_UNDEFINED |
 | ) |  |  | [virtual]

Deserialize the object's length and body from the supplied message validator.

Parameters:
messageValidator | the message validator from which the object will be extracted.
maxSerializedBodyLength | the maximum serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::Time::FromString ( MessageValidator & messageValidator ) [virtual]

Convert the object from a string.

Parameters:
messageValidator the message validator.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

StatusCode Activ::Time::Get | ( | std::tm & | tm,
 |  | uint32_t & | millisecond |
 | ) |  |  | const [inline]

Get the time.

Only sets the tm_hour, tm_min and tm_sec fields of the provided tm structure.

Parameters:
tm | reference to a tm structure to receive the time.
millisecond | the millisecond.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED

Definition at line 989 of file Time.h.

References ACTIV_RETURN_RESULT_IF, and Get().

StatusCode Activ::Time::Get ( std::tm & tm ) const [inline]

Get the time.

Only sets the tm_hour, tm_min and tm_sec fields of the provided tm structure.

Parameters:
tm reference to a tm structure to receive the time.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED

Definition at line 975 of file Time.h.

References Activ::IFieldType::IsInitialized().

StatusCode Activ::Time::Get | ( | int32_t & | julianTime,
 |  | uint32_t & | millisecond |
 | ) |  |  | const [inline]

Get the time.

Parameters:
julianTime | the julian time.
millisecond | the millisecond.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED

Definition at line 964 of file Time.h.

References ACTIV_RETURN_RESULT_IF, and Get().

StatusCode Activ::Time::Get ( int32_t & julianTime ) const [inline]

Get the time.

Parameters:
julianTime the julian time.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED

Definition at line 952 of file Time.h.

References ConvertGregorianToJulianTime(), and Activ::IFieldType::IsInitialized().

StatusCode Activ::Time::Get | ( | uint32_t & | hour,
 |  | uint32_t & | minute,
 |  | uint32_t & | second,
 |  | uint32_t & | millisecond |
 | ) |  |  | const [inline]

Get the time.

Parameters:
hour | the hour.
minute | the minute.
second | the second.
millisecond | the millisecond.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED

Definition at line 941 of file Time.h.

References ACTIV_RETURN_RESULT_IF, and Get().

StatusCode Activ::Time::Get | ( | uint32_t & | hour,
 |  | uint32_t & | minute,
 |  | uint32_t & | second |
 | ) |  |  | const [inline]

Get the time.

Parameters:
hour | the hour.
minute | the minute.
second | the second.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED

Definition at line 927 of file Time.h.

References Activ::IFieldType::IsInitialized().

int32_t Activ::Time::Get ( ) const [inline]

Get the julian time.

Returns:
the julian time.
Exceptions:
StatusCodeException

Definition at line 917 of file Time.h.

References ACTIV_THROW, ConvertGregorianToJulianTime(), and Activ::IFieldType::IsInitialized().

Referenced by Activ::ContentPlatform::ContentGatewayApi::Tick::Compare(), Get(), and Activ::DateTime::Get().

virtual ACTIV_FIELD_TYPES_API std::string Activ::Time::GetFromStringFormat ( ) const [virtual]

Get a usage string for the format supported by FromString().

Returns:
String, may be empty.

Implements Activ::IFieldType.

uint32_t Activ::Time::GetHour ( ) const [inline]

Get the hour.

Returns:
the hour.
Exceptions:
StatusCodeException

Definition at line 1000 of file Time.h.

References ACTIV_THROW, and Activ::IFieldType::IsInitialized().

Referenced by Activ::DateTime::GetHour().

Time Activ::Time::GetLocal ( ) const [inline]

Get the local time.

Assumes the time is stored as UTC timezone.

Returns:
the local time.
Exceptions:
StatusCodeException

Definition at line 1060 of file Time.h.

References ACTIV_THROW, GetTimeZoneOffset(), and Activ::IFieldType::IsInitialized().

size_t Activ::Time::GetMaxSerializedBodyLength ( const bool shouldSerializeMilliseconds ) [inline, static]

Get the maximum serialized length of the object's body.

Parameters:
shouldSerializeMilliseconds indicates whether milliseconds should be serialized.
Returns:
the maximum serialized length of the object's body.

Definition at line 1205 of file Time.h.

Referenced by Activ::DateTime::GetMaxSerializedBodyLength(), GetMaxSerializedLength(), and GetSerializedBodyLength().

size_t Activ::Time::GetMaxSerializedLength ( const bool shouldSerializeMilliseconds ) [inline, static]

Get the maximum serialized length of the object.

Parameters:
shouldSerializeMilliseconds indicates whether milliseconds should be serialized.
Returns:
the maximum serialized length of the object.

Definition at line 1198 of file Time.h.

References GetMaxSerializedBodyLength().

Referenced by Activ::DateTime::GetMaxSerializedLength().

uint32_t Activ::Time::GetMillisecond ( ) const [inline]

Get the millisecond.

Returns:
the millisecond.
Exceptions:
StatusCodeException

Definition at line 1030 of file Time.h.

References ACTIV_THROW, and Activ::IFieldType::IsInitialized().

Referenced by Activ::DateTime::GetMillisecond().

uint32_t Activ::Time::GetMinute ( ) const [inline]

Get the minute.

Returns:
the minute.
Exceptions:
StatusCodeException

Definition at line 1010 of file Time.h.

References ACTIV_THROW, and Activ::IFieldType::IsInitialized().

Referenced by Activ::DateTime::GetMinute().

uint32_t Activ::Time::GetSecond ( ) const [inline]

Get the second.

Returns:
the second.
Exceptions:
StatusCodeException

Definition at line 1020 of file Time.h.

References ACTIV_THROW, and Activ::IFieldType::IsInitialized().

Referenced by Activ::DateTime::GetSecond().

size_t Activ::Time::GetSerializedBodyLength ( const void *const pSerializedBody ) [inline, static]

Get the maximum serialized length of the object's body.

Parameters:
pSerializedBody a pointer to the serialized body.
Returns:
the maximum serialized length of the object's body.

Definition at line 1191 of file Time.h.

References GetMaxSerializedBodyLength().

size_t Activ::Time::GetSerializedBodyLength ( ) const [inline, virtual]

Get the serialized length of the object's body.

Returns:
the serialized length of the object's body.

Implements Activ::IFieldType.

Definition at line 1177 of file Time.h.

References GetMaxSerializedBodyLength(), and Activ::IFieldType::IsInitialized().

Referenced by Activ::DateTime::GetSerializedBodyLength(), and GetSerializedLength().

size_t Activ::Time::GetSerializedLength ( const void *const pSerializedBody ) [inline, static]

Get the maximum serialized length of the object.

Parameters:
pSerializedBody a pointer to the serialized body.
Returns:
the maximum serialized length of the object.

Definition at line 1184 of file Time.h.

References GetSerializedBodyLength().

size_t Activ::Time::GetSerializedLength ( ) const [inline, virtual]

Get the serialized length of the object.

Returns:
the serialized length of the object.

Implements Activ::IFieldType.

Definition at line 1170 of file Time.h.

References GetSerializedBodyLength().

Referenced by Activ::DateTime::GetSerializedLength().

static ACTIV_FIELD_TYPES_API int32_t Activ::Time::GetTimeZoneOffset ( ) [static]

Get the time zone offset (local from UTC).

Returns:
the time zone offset.

Referenced by GetLocal(), and GetUtc().

uint32_t Activ::Time::GetTotalMilliseconds ( ) const [inline]

Get the total milliseconds.

Returns:
the total milliseconds.
Exceptions:
StatusCodeException

Definition at line 1040 of file Time.h.

References ACTIV_THROW, ConvertGregorianToJulianTime(), Activ::IFieldType::IsInitialized(), and Activ::Time::Milliseconds::NUMBER_PER_SECOND.

Referenced by Add(), Activ::DateTime::Add(), Subtract(), and Activ::DateTime::Subtract().

Time Activ::Time::GetUtc ( ) const [inline]

Get the UTC time.

Assumes the time is stored as local timezone.

Returns:
the UTC time.
Exceptions:
StatusCodeException

Definition at line 1050 of file Time.h.

References ACTIV_THROW, GetTimeZoneOffset(), and Activ::IFieldType::IsInitialized().

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::Time::IsDifferent | ( | const void *const | pRhsSerializedBody,
 |  | const size_t | rhsSerializedBodyLength,
 |  | bool & | isDifferent |
 | ) |  |  | const [virtual]

Is different.

Parameters:
pRhsSerializedBody | the buffer containing the rhs serialized version of the object's body in.
rhsSerializedBodyLength | the rhs serialized body length.
isDifferent | indicates whether the two objects are different.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

bool Activ::Time::IsValidSerializedBodyLength ( const size_t serializedBodyLength ) [inline, static]

Is valid serialized body length.

Parameters:
serializedBodyLength the serialized body length.
Returns:
whether the serialized body length is valid.

Definition at line 1231 of file Time.h.

Referenced by Activ::DateTime::IsValidSerializedBodyLength().

bool Activ::Time::operator!= ( const Time & rhs ) const [inline]

Inequality operator.

Parameters:
rhs the object to compare with.
Returns:
the result of the test.
Exceptions:
StatusCodeException

Definition at line 801 of file Time.h.

template<typename T>
const Time Activ::Time::operator+ ( const T & rhs ) const [inline]

Addition operator.

Parameters:
rhs the value to add to this object.
Returns:
an object containing the result of the operation.
Exceptions:
StatusCodeException

Definition at line 842 of file Time.h.

References Time().

template<typename T>
Time & Activ::Time::operator+= ( const T & rhs ) [inline]

Addition assignment operator.

Parameters:
rhs the value to add to this object.
Returns:
a reference to this object.
Exceptions:
StatusCodeException

Definition at line 849 of file Time.h.

References ACTIV_THROW_RESULT_IF, and Add().

template<typename T>
const Time Activ::Time::operator- ( const T & rhs ) const [inline]

Subtraction operator.

Parameters:
rhs the value to subtract from this object.
Returns:
an object containing the result of the operation.
Exceptions:
StatusCodeException

Definition at line 858 of file Time.h.

References Time().

template<typename T>
Time & Activ::Time::operator-= ( const T & rhs ) [inline]

Subtraction assignment operator.

Parameters:
rhs the value to subtract from this object.
Returns:
a reference to this object.
Exceptions:
StatusCodeException

Definition at line 865 of file Time.h.

References ACTIV_THROW_RESULT_IF, and Subtract().

bool Activ::Time::operator< ( const Time & rhs ) const [inline]

Less than operator.

Parameters:
rhs the object to compare with.
Returns:
the result of the test.
Exceptions:
StatusCodeException

Definition at line 808 of file Time.h.

References ACTIV_THROW_RESULT_IF, and Compare().

bool Activ::Time::operator<= ( const Time & rhs ) const [inline]

Less than or equal to operator.

Parameters:
rhs the object to compare with.
Returns:
the result of the test.
Exceptions:
StatusCodeException

Definition at line 818 of file Time.h.

bool Activ::Time::operator== ( const Time & rhs ) const [inline]

Equality operator.

Parameters:
rhs the object to compare with.
Returns:
the result of the test.
Exceptions:
StatusCodeException

Definition at line 791 of file Time.h.

References ACTIV_THROW_RESULT_IF, and Compare().

bool Activ::Time::operator> ( const Time & rhs ) const [inline]

Greater than operator.

Parameters:
rhs the object to compare with.
Returns:
the result of the test.
Exceptions:
StatusCodeException

Definition at line 825 of file Time.h.

References ACTIV_THROW_RESULT_IF, and Compare().

bool Activ::Time::operator>= ( const Time & rhs ) const [inline]

Greater than or equal to operator.

Parameters:
rhs the object to compare with.
Returns:
the result of the test.
Exceptions:
StatusCodeException

Definition at line 835 of file Time.h.

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::Time::Serialize | ( | MessageBuilder & | messageBuilder,
 |  | const size_t | maxSerializedBodyLength |
 | ) |  |  | const [virtual]

Serialize the object into the supplied message builder.

Parameters:
messageBuilder | the message builder to store a serialized version of the object in.
maxSerializedBodyLength | the maximum serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::Time::SerializeBody | ( | void * | pSerializedBody,
 |  | const size_t | maxSerializedBodyLength,
 |  | size_t & | serializedBodyLength |
 | ) |  |  | const [virtual]

Serialize the object's body into the supplied data buffer.

Parameters:
pSerializedBody | the buffer to store a serialized version of the object's body in.
maxSerializedBodyLength | the maximum serialized body length.
serializedBodyLength | the serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::Time::SerializeLengthAndBody | ( | MessageBuilder & | messageBuilder,
 |  | const size_t | maxSerializedBodyLength = MAX_SERIALIZED_BODY_LENGTH_UNDEFINED |
 | ) |  |  | const [virtual]

Serialize the object's length and body into the supplied message builder.

Parameters:
messageBuilder | the message builder to store a serialized version of the object in.
maxSerializedBodyLength | the maximum serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

StatusCode Activ::Time::Set | ( | const std::tm & | tm,
 |  | const uint32_t | millisecond = 0 |
 | ) |  |  | [inline]

Store a new time.

Uses the tm_hour, tm_min and tm_sec fields of the provided tm structure.

Parameters:
tm | reference to a tm structure specifying the time.
millisecond | the millisecond.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER

Definition at line 910 of file Time.h.

References Set().

StatusCode Activ::Time::Set | ( | const int32_t | julianTime,
 |  | const uint32_t | millisecond = 0 |
 | ) |  |  | [inline]

Store a new time.

Parameters:
julianTime | the julian time.
millisecond | the millisecond.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER

Definition at line 890 of file Time.h.

References ConvertJulianToGregorianTime(), Activ::IFieldType::m_isInitialized, Activ::Time::Hours::NUMBER_PER_DAY, Activ::Time::Minutes::NUMBER_PER_HOUR, Activ::Time::Seconds::NUMBER_PER_MINUTE, and Activ::Time::Milliseconds::NUMBER_PER_SECOND.

StatusCode Activ::Time::Set | ( | const uint32_t | hour,
 |  | const uint32_t | minute,
 |  | const uint32_t | second,
 |  | const uint32_t | millisecond = 0 |
 | ) |  |  | [inline]

Store a new time.

Parameters:
hour | the hour.
minute | the minute.
second | the second.
millisecond | the millisecond.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER

Definition at line 874 of file Time.h.

References Activ::IFieldType::m_isInitialized, Activ::Time::Hours::NUMBER_PER_DAY, Activ::Time::Minutes::NUMBER_PER_HOUR, Activ::Time::Seconds::NUMBER_PER_MINUTE, and Activ::Time::Milliseconds::NUMBER_PER_SECOND.

Referenced by Add(), Set(), Subtract(), and Time().

StatusCode Activ::Time::Subtract ( const Milliseconds & milliseconds ) [inline]

Subtract.

Parameters:
milliseconds the number of milliseconds to subtract from this object.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED

Definition at line 1144 of file Time.h.

References GetTotalMilliseconds(), Activ::IFieldType::IsInitialized(), Activ::Time::Milliseconds::m_value, Activ::Time::Milliseconds::NUMBER_PER_DAY, Activ::Time::Milliseconds::NUMBER_PER_SECOND, and Set().

StatusCode Activ::Time::Subtract ( const Seconds & seconds ) [inline]

Subtract.

Parameters:
seconds the number of seconds to subtract from this object.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED

Definition at line 1137 of file Time.h.

References Activ::Time::Seconds::m_value, Activ::Time::Seconds::NUMBER_PER_DAY, Activ::Time::Milliseconds::NUMBER_PER_SECOND, and Subtract().

StatusCode Activ::Time::Subtract ( const Minutes & minutes ) [inline]

Subtract.

Parameters:
minutes the number of minutes to subtract from this object.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED

Definition at line 1130 of file Time.h.

References Activ::Time::Minutes::m_value, Activ::Time::Minutes::NUMBER_PER_DAY, Activ::Time::Milliseconds::NUMBER_PER_MINUTE, and Subtract().

StatusCode Activ::Time::Subtract ( const Hours & hours ) [inline]

Subtract.

Parameters:
hours the number of hours to subtract from this object.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED

Definition at line 1123 of file Time.h.

References Activ::Time::Hours::m_value, Activ::Time::Hours::NUMBER_PER_DAY, Activ::Time::Milliseconds::NUMBER_PER_HOUR, and Subtract().

StatusCode Activ::Time::Subtract ( const Time & rhs ) [inline]

Subtract.

Parameters:
rhs the value to subtract from this object.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED

Definition at line 1113 of file Time.h.

References GetTotalMilliseconds(), and Activ::IFieldType::IsInitialized().

Referenced by operator-=(), and Subtract().

ACTIV_FIELD_TYPES_API std::string Activ::Time::ToString ( const bool shouldDisplayMilliseconds ) const

Convert the object to a string.

Parameters:
shouldDisplayMilliseconds indicates whether the milliseconds should be displayed.
Returns:
the object as a string.

virtual ACTIV_FIELD_TYPES_API std::string Activ::Time::ToString ( ) const [virtual]

Convert the object to a string.

Returns:
the object as a string.

Implements Activ::IFieldType.

static ACTIV_FIELD_TYPES_API StatusCode Activ::Time::ValidateSerializedLengthAndBody | ( | MessageValidator & | messageValidator,
 |  | size_t & | serializedBodyOffset,
 |  | size_t & | serializedBodyLength |
 | ) |  |  | [static]

Validate the serialized length and body.

Parameters:
messageValidator | the message validator.
serializedBodyOffset | the serialized body offset.
serializedBodyLength | the serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivFieldTypes/Time.h
Generated on Wed Oct 8 14:02:00 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Time::Hours

Activ::Time::Hours Class Reference

Hours class. More...

#include <ActivMiddleware/ActivFieldTypes/Time.h>

List of all members.

Public Member Functions

Hours (const int32_t value)
Constructor.

Public Attributes

const int32_t | m_value
The value;.

Static Public Attributes

static const uint32_t | NUMBER_PER_DAY = 24
The number per day;.

Detailed Description

Hours class.

Definition at line 46 of file Time.h.

Constructor & Destructor Documentation

Activ::Time::Hours::Hours ( const int32_t value ) [inline, explicit]

Constructor.

Parameters:
value the value.

Definition at line 1239 of file Time.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivFieldTypes/Time.h
Generated on Wed Oct 8 14:02:00 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Time::Milliseconds

Activ::Time::Milliseconds Class Reference

Milliseconds class. More...

#include <ActivMiddleware/ActivFieldTypes/Time.h>

List of all members.

Public Member Functions

Milliseconds (const int32_t value)
Constructor.

Public Attributes

const int32_t | m_value
The value;.

Static Public Attributes

static const uint32_t | NUMBER_PER_DAY = NUMBER_PER_HOUR * Hours::NUMBER_PER_DAY
The number per day;.
static const uint32_t | NUMBER_PER_HOUR = NUMBER_PER_MINUTE * Minutes::NUMBER_PER_HOUR
The number per hour;.
static const uint32_t | NUMBER_PER_MINUTE = NUMBER_PER_SECOND * Seconds::NUMBER_PER_MINUTE
The number per minute;.
static const uint32_t | NUMBER_PER_SECOND = 1000
The number per second;.

Detailed Description

Milliseconds class.

Definition at line 103 of file Time.h.

Constructor & Destructor Documentation

Activ::Time::Milliseconds::Milliseconds ( const int32_t value ) [inline, explicit]

Constructor.

Parameters:
value the value.

Definition at line 1263 of file Time.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivFieldTypes/Time.h
Generated on Wed Oct 8 14:02:00 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Time::Minutes

Activ::Time::Minutes Class Reference

Minutes class. More...

#include <ActivMiddleware/ActivFieldTypes/Time.h>

List of all members.

Public Member Functions

Minutes (const int32_t value)
Constructor.

Public Attributes

const int32_t | m_value
The value;.

Static Public Attributes

static const uint32_t | NUMBER_PER_DAY = NUMBER_PER_HOUR * Hours::NUMBER_PER_DAY
The number per day;.
static const uint32_t | NUMBER_PER_HOUR = 60
The number per hour;.

Detailed Description

Minutes class.

Definition at line 64 of file Time.h.

Constructor & Destructor Documentation

Activ::Time::Minutes::Minutes ( const int32_t value ) [inline, explicit]

Constructor.

Parameters:
value the value.

Definition at line 1247 of file Time.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivFieldTypes/Time.h
Generated on Wed Oct 8 14:02:00 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Time::Seconds

Activ::Time::Seconds Class Reference

Seconds class. More...

#include <ActivMiddleware/ActivFieldTypes/Time.h>

List of all members.

Public Member Functions

Seconds (const int32_t value)
Constructor.

Public Attributes

const int32_t | m_value
The value;.

Static Public Attributes

static const uint32_t | NUMBER_PER_DAY = NUMBER_PER_HOUR * Hours::NUMBER_PER_DAY
The number per day;.
static const uint32_t | NUMBER_PER_HOUR = NUMBER_PER_MINUTE * Minutes::NUMBER_PER_HOUR
The number per hour;.
static const uint32_t | NUMBER_PER_MINUTE = 60
The number per minute;.

Detailed Description

Seconds class.

Definition at line 83 of file Time.h.

Constructor & Destructor Documentation

Activ::Time::Seconds::Seconds ( const int32_t value ) [inline, explicit]

Constructor.

Parameters:
value the value.

Definition at line 1255 of file Time.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivFieldTypes/Time.h
Generated on Wed Oct 8 14:02:00 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Timeband

Activ::Timeband Class Reference

Timeband class. More...

#include <ActivMiddleware/ActivFramework/Timeband.h>

List of all members.

Public Types

typedef std::set< Date > | DateSet
date set type
enum | EnabledDateFlag { ENABLED_DATE_END_TIME, ENABLED_DATE_START_TIME }
Enabled date flag enum.
typedef std::bitset< 7 > | EnabledDaysBitmap
enabled days bitmap type

Public Member Functions

ACTIV_FRAMEWORK_API StatusCode | AddDisabledDate (const Date &disabledDate)
Add disabled date.
const DateSet & | GetDisabledDateSet () const
Get the disabled date set.
ACTIV_FRAMEWORK_API const
std::string 		GetDisabledDateSetString () const
Get the disabled dates string.
EnabledDateFlag | GetEnabledDateFlag () const
Get the enabled date flag.
ACTIV_FRAMEWORK_API const
std::string 		GetEnabledDateFlagString () const
Get the disabled date flag string.
ACTIV_FRAMEWORK_API const
std::string 		GetEnabledDaysString () const
Get the enabled days string.
const Time & | GetEndTime () const
Get the end time.
const Time & | GetStartTime () const
Get the start time.
bool | IsIn (const LocalTime &localTime) const
Is the time within this timeband.
ACTIV_FRAMEWORK_API bool | IsIn (const DateTime &dateTime) const
Is the time within this timeband.
ACTIV_FRAMEWORK_API bool | operator!= (const Timeband &rhs) const
Inequality operator.
ACTIV_FRAMEWORK_API Timeband & | operator= (const Timeband &rhs)
Assignment operator.
ACTIV_FRAMEWORK_API bool | operator== (const Timeband &rhs) const
Equality operator.
StatusCode | Read (const std::string &keyNamePrefix, const IniFileParser::ConstSectionIterator &sectionIterator)
ACTIV_FRAMEWORK_API StatusCode | RemoveDisabledDate (const Date &disabledDate)
Remove disabled date.
void | SetDisabledDateSet (const DateSet &disabledDateSet)
Set the disbaled date set.
void | SetEnabledDateFlag (const EnabledDateFlag enabledDateFlag)
Set the enabled date flag.
StatusCode | SetEnabledDaysString (const std::string &enabledDaysString)
Set the enabled days string.
void | SetEndTime (const Time &endTime)
Set the end time.
void | SetStartTime (const Time &startTime)
Set the start time.
ACTIV_FRAMEWORK_API | Timeband (const Time &startTime, const Time &endTime, const std::string &enabledDaysBitmapString, const EnabledDateFlag enabledDateFlag=ENABLED_DATE_END_TIME, const DateSet &disabledDateSet=DateSet())
Constructor.
ACTIV_FRAMEWORK_API | Timeband (const Settings &settings)
Constructor.
ACTIV_FRAMEWORK_API | Timeband ()
Default constructor.
ACTIV_FRAMEWORK_API const
std::string 		ToLogString () const
Convert the field list object to a log string.
ACTIV_FRAMEWORK_API const
std::string 		ToString () const
Convert the object to a string.

Static Public Member Functions

static ACTIV_FRAMEWORK_API
StatusCode 		ConvertStringToEnabledDaysBitmap (const std::string enabledDaysBitmapString, EnabledDaysBitmap &enabledDaysBitmap)
Convert string to enabled days bitmap.

Classes

class | Settings
Settings class. More...

Detailed Description

Timeband class.

Definition at line 26 of file Timeband.h.

Constructor & Destructor Documentation

ACTIV_FRAMEWORK_API Activ::Timeband::Timeband ( const Settings & settings )

Constructor.

Parameters:
settings object's settings.

ACTIV_FRAMEWORK_API Activ::Timeband::Timeband | ( | const Time & | startTime,
 |  | const Time & | endTime,
 |  | const std::string & | enabledDaysBitmapString,
 |  | const EnabledDateFlag | enabledDateFlag = ENABLED_DATE_END_TIME,
 |  | const DateSet & | disabledDateSet = DateSet()
 | ) |  |

Constructor.

Parameters:
startTime | start time of the timeband.
endTime | end time of the timeband.
enabledDaysBitmapString | enabled days bitmap string, e.g. "-mtwtf-".
enabledDateFlag | the endabled date flag.
disabledDateSet | the disabled date set.

Member Function Documentation

ACTIV_FRAMEWORK_API StatusCode Activ::Timeband::AddDisabledDate ( const Date & disabledDate )

Add disabled date.

Parameters:
disabledDate the disabled date to add.
Return values:
STATUS_CODE_SUCCESS
...

static ACTIV_FRAMEWORK_API StatusCode Activ::Timeband::ConvertStringToEnabledDaysBitmap | ( | const std::string | enabledDaysBitmapString,
 |  | EnabledDaysBitmap & | enabledDaysBitmap |
 | ) |  |  | [static]

Convert string to enabled days bitmap.

Parameters:
enabledDaysBitmapString | the string to convert.
enabledDaysBitmap | the enabled days bitmap to receive the result.

Referenced by SetEnabledDaysString().

const Timeband::DateSet & Activ::Timeband::GetDisabledDateSet ( ) const [inline]

Get the disabled date set.

Returns:
the disabled date set.

Definition at line 342 of file Timeband.h.

References Activ::Timeband::Settings::m_disabledDateSet.

ACTIV_FRAMEWORK_API const std::string Activ::Timeband::GetDisabledDateSetString ( ) const

Get the disabled dates string.

Returns:
the disabled dates string.

Timeband::EnabledDateFlag Activ::Timeband::GetEnabledDateFlag ( ) const [inline]

Get the enabled date flag.

Returns:
the enabled date flag.

Definition at line 349 of file Timeband.h.

References Activ::Timeband::Settings::m_enabledDateFlag.

ACTIV_FRAMEWORK_API const std::string Activ::Timeband::GetEnabledDateFlagString ( ) const

Get the disabled date flag string.

Returns:
the disabled dates flag string.

ACTIV_FRAMEWORK_API const std::string Activ::Timeband::GetEnabledDaysString ( ) const

Get the enabled days string.

Returns:
the enabled days string.

const Time & Activ::Timeband::GetEndTime ( ) const [inline]

Get the end time.

Returns:
const reference to the end time.

Definition at line 335 of file Timeband.h.

References Activ::Timeband::Settings::m_endTime.

const Time & Activ::Timeband::GetStartTime ( ) const [inline]

Get the start time.

Returns:
const reference to the start time.

Definition at line 328 of file Timeband.h.

References Activ::Timeband::Settings::m_startTime.

bool Activ::Timeband::IsIn ( const LocalTime & localTime ) const [inline]

Is the time within this timeband.

Deprecated, use version of IsIn() taking a DateTime.

Parameters:
localTime the local time to test if in this timeband.

Definition at line 314 of file Timeband.h.

References Activ::LocalTime::Get(), and IsIn().

ACTIV_FRAMEWORK_API bool Activ::Timeband::IsIn ( const DateTime & dateTime ) const

Is the time within this timeband.

Parameters:
dateTime date/time to test if in this timeband.

Referenced by IsIn().

ACTIV_FRAMEWORK_API bool Activ::Timeband::operator!= ( const Timeband & rhs ) const

Inequality operator.

Parameters:
rhs the object to compare with.
Returns:
the result of the test.
Exceptions:
StatusCodeException

ACTIV_FRAMEWORK_API Timeband& Activ::Timeband::operator= ( const Timeband & rhs )

Assignment operator.

Parameters:
rhs the object to assign from.
Returns:
the result.
Exceptions:
StatusCodeException

ACTIV_FRAMEWORK_API bool Activ::Timeband::operator== ( const Timeband & rhs ) const

Equality operator.

Parameters:
rhs the object to compare with.
Returns:
the result of the test.
Exceptions:
StatusCodeException

ACTIV_FRAMEWORK_API StatusCode Activ::Timeband::RemoveDisabledDate ( const Date & disabledDate )

Remove disabled date.

Parameters:
disabledDate the disabled date to remove.
Return values:
STATUS_CODE_SUCCESS
...

void Activ::Timeband::SetDisabledDateSet ( const DateSet & disabledDateSet ) [inline]

Set the disbaled date set.

Parameters:
disabledDateSet the new disabled date set.

Definition at line 377 of file Timeband.h.

References Activ::Timeband::Settings::m_disabledDateSet.

void Activ::Timeband::SetEnabledDateFlag ( const EnabledDateFlag enabledDateFlag ) [inline]

Set the enabled date flag.

Parameters:
enabledDateFlag the new enabled date flag.

Definition at line 384 of file Timeband.h.

References Activ::Timeband::Settings::m_enabledDateFlag.

StatusCode Activ::Timeband::SetEnabledDaysString ( const std::string & enabledDaysString ) [inline]

Set the enabled days string.

Parameters:
enabledDaysString the new enabled days string.
Return values:
STATUS_CODE_SUCCESS
...

Definition at line 370 of file Timeband.h.

References ConvertStringToEnabledDaysBitmap(), and Activ::Timeband::Settings::m_enabledDaysBitmap.

void Activ::Timeband::SetEndTime ( const Time & endTime ) [inline]

Set the end time.

Parameters:
endTime the new end time.

Definition at line 363 of file Timeband.h.

References Activ::Timeband::Settings::m_endTime.

void Activ::Timeband::SetStartTime ( const Time & startTime ) [inline]

Set the start time.

Parameters:
startTime the new start time.

Definition at line 356 of file Timeband.h.

References Activ::Timeband::Settings::m_startTime.

ACTIV_FRAMEWORK_API const std::string Activ::Timeband::ToLogString ( ) const

Convert the field list object to a log string.

Returns:
the field list object as a log string.

ACTIV_FRAMEWORK_API const std::string Activ::Timeband::ToString ( ) const

Convert the object to a string.

Returns:
the object as a string.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivFramework/Timeband.h
Generated on Wed Oct 8 14:02:01 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Timeband::Settings

Activ::Timeband::Settings Class Reference

Settings class. More...

#include <ActivMiddleware/ActivFramework/Timeband.h>

List of all members.

Public Member Functions

ACTIV_FRAMEWORK_API StatusCode | Read (const std::string &keyNamePrefix, const IniFileParser::ConstSectionIterator &sectionIterator)
ACTIV_FRAMEWORK_API | Settings (const Time &startTime, const Time &endTime, const std::string &enabledDaysBitmapString, const EnabledDateFlag enabledDateFlag=ENABLED_DATE_END_TIME, const DateSet &disabledDateSet=DateSet())
Constructor.
ACTIV_FRAMEWORK_API | Settings ()
Default constructor.

Public Attributes

DateSet m_disabledDateSet
disabled date set
EnabledDateFlag m_enabledDateFlag
enabled date flag
EnabledDaysBitmap m_enabledDaysBitmap
enabled days bitmap
Time m_endTime
end time of timeband
Time m_startTime
start time of timeband

Detailed Description

Settings class.

Deprecated, use the Timeband class directly.

Definition at line 46 of file Timeband.h.

Constructor & Destructor Documentation

ACTIV_FRAMEWORK_API Activ::Timeband::Settings::Settings | ( | const Time & | startTime,
 |  | const Time & | endTime,
 |  | const std::string & | enabledDaysBitmapString,
 |  | const EnabledDateFlag | enabledDateFlag = ENABLED_DATE_END_TIME,
 |  | const DateSet & | disabledDateSet = DateSet()
 | ) |  |

Constructor.

Parameters:
startTime | start time of the timeband.
endTime | end time of the timeband.
enabledDaysBitmapString | enabled days bitmap string, e.g. "-mtwtf-".
enabledDateFlag | the endabled date flag.
disabledDateSet | the disabled date set.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivFramework/Timeband.h
Generated on Wed Oct 8 14:02:01 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Timeout

Activ::Timeout Class Reference

Timeout handler function object class. More...

#include <ActivMiddleware/ActivBase/Timeout.h>

List of all members.

Public Member Functions

ACTIV_BASE_EXPORTED_API
TimeoutPeriod 		GetPeriodLeft () const
Return the timeout period left.
ACTIV_BASE_EXPORTED_API bool | operator() (TimeoutPeriod sleepPeriod=500)
Suspend current thread if any period is left in the timeout.
ACTIV_BASE_EXPORTED_API | Timeout (TimeoutPeriod maxTimeout)
Default constructor.

Static Public Member Functions

static ACTIV_BASE_INLINE_API
Timeout & 		GetInfinite ()
Get a Timeout object representing an infinite timeout.
static ACTIV_BASE_INLINE_API
Timeout & 		GetZero ()
Get a Timeout object with a zero timeout.

Detailed Description

Timeout handler function object class.

Definition at line 20 of file Timeout.h.

Constructor & Destructor Documentation

ACTIV_BASE_EXPORTED_API Activ::Timeout::Timeout ( TimeoutPeriod maxTimeout )

Default constructor.

Parameters:
maxTimeout the maximum timeout period, in ms.

Member Function Documentation

Timeout & Activ::Timeout::GetInfinite ( ) [inline, static]

Get a Timeout object representing an infinite timeout.

Returns:
Reference to a static Timeout object.

Definition at line 70 of file Timeout.h.

ACTIV_BASE_EXPORTED_API TimeoutPeriod Activ::Timeout::GetPeriodLeft ( ) const

Return the timeout period left.

Returns:
The amount of timeout left, in ms.

Timeout & Activ::Timeout::GetZero ( ) [inline, static]

Get a Timeout object with a zero timeout.

Returns:
Reference to a static Timeout object.

Definition at line 77 of file Timeout.h.

ACTIV_BASE_EXPORTED_API bool Activ::Timeout::operator() ( TimeoutPeriod sleepPeriod = 500 )

Suspend current thread if any period is left in the timeout.

Parameters:
sleepPeriod how long to sleep for, in ms.
Return values:
true | if there is no period left in the timeout
false | the current thread was suspended

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivBase/Timeout.h
Generated on Wed Oct 8 14:02:01 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::TimerServiceApi

Activ::TimerServiceApi Class Reference

Api to the agent's timer service. More...

#include <ActivMiddleware/ActivFramework/TimerServiceApi.h>

List of all members.

Static Public Member Functions

static ACTIV_FRAMEWORK_API
StatusCode 		AdjustSystemTime (const Component &component, const int32_t milliseconds)
Adjust the system time.
static ACTIV_FRAMEWORK_API
StatusCode 		CancelTimer (const Component &component, Address &timerAddress)
Cancel a timer.
static ACTIV_FRAMEWORK_API
StatusCode 		CancelTimers (const Component &component)
Cancel outstanding timers set by a component.
static ACTIV_FRAMEWORK_API
StatusCode 		GetCurrentLocalDate (const Component &component, Date &date)
Get current date (local).
static ACTIV_FRAMEWORK_API
StatusCode 		GetCurrentLocalDateTime (const Component &component, DateTime &dateTime, const bool shouldSetMilliseconds=false)
Get current date & time (local).
static ACTIV_FRAMEWORK_API
StatusCode 		GetCurrentLocalTime (const Component &component, Time &time, const bool shouldSetMilliseconds=false)
Get current time (local).
static ACTIV_FRAMEWORK_API
StatusCode 		GetCurrentUtcDate (const Component &component, Date &date)
Get current date (utc).
static ACTIV_FRAMEWORK_API
StatusCode 		GetCurrentUtcDateTime (const Component &component, DateTime &dateTime, const bool shouldSetMilliseconds=false)
Get current date & time (utc).
static ACTIV_FRAMEWORK_API
StatusCode 		GetCurrentUtcTime (const Component &component, Time &time, const bool shouldSetMilliseconds=false)
Get current time (utc).
static ACTIV_FRAMEWORK_API
StatusCode 		SetTimer (const Component &component, const BaseTime &time, const BaseTime::Duration &duration, Address::Proxy timerAddress)
Set a new timer to occur at a given time and then at regular intervals.
static ACTIV_FRAMEWORK_API
StatusCode 		SetTimer (const Component &component, const BaseTime::Duration &duration, Address::Proxy timerAddress)
Set a new timer to occur in a given period.
static ACTIV_FRAMEWORK_API
StatusCode 		SetTimer (const Component &component, const BaseTime &time, Address::Proxy timerAddress)
Set a new timer to occur at a given time.

Detailed Description

Api to the agent's timer service.

Definition at line 28 of file TimerServiceApi.h.

Member Function Documentation

static ACTIV_FRAMEWORK_API StatusCode Activ::TimerServiceApi::AdjustSystemTime | ( | const Component & | component,
 |  | const int32_t | milliseconds |
 | ) |  |  | [static]

Adjust the system time.

May adjust the system time immediately, or gradually, depending on the underlying platform. The TimerService may need to be running in a process with root privileges, depending on the platform.

Parameters:
component
milliseconds milliseconds to adjust by.
Return values:
STATUS_CODE_SUCCESS
...

static ACTIV_FRAMEWORK_API StatusCode Activ::TimerServiceApi::CancelTimer | ( | const Component & | component,
 |  | Address & | timerAddress |
 | ) |  |  | [static]

Cancel a timer.

Parameters:
component | the component that set the timer.
timerAddress | reference to an Address to holding the address of a timer. This is cleared down on success.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER timerAddress is not valid
...

static ACTIV_FRAMEWORK_API StatusCode Activ::TimerServiceApi::CancelTimers ( const Component & component ) [static]

Cancel outstanding timers set by a component.

Parameters:
component the component wanting to cancel.
Return values:
STATUS_CODE_SUCCESS
...

static ACTIV_FRAMEWORK_API StatusCode Activ::TimerServiceApi::GetCurrentLocalDate | ( | const Component & | component,
 |  | Date & | date |
 | ) |  |  | [static]

Get current date (local).

Parameters:
component
date reference to a Date object to set.
Return values:
STATUS_CODE_SUCCESS
...

static ACTIV_FRAMEWORK_API StatusCode Activ::TimerServiceApi::GetCurrentLocalDateTime | ( | const Component & | component,
 |  | DateTime & | dateTime,
 |  | const bool | shouldSetMilliseconds = false |
 | ) |  |  | [static]

Get current date & time (local).

Parameters:
component
dateTime | reference to a DateTime object to set.
shouldSetMilliseconds | whether to set the milliseconds component of dateTime.
Return values:
STATUS_CODE_SUCCESS
...

static ACTIV_FRAMEWORK_API StatusCode Activ::TimerServiceApi::GetCurrentLocalTime | ( | const Component & | component,
 |  | Time & | time,
 |  | const bool | shouldSetMilliseconds = false |
 | ) |  |  | [static]

Get current time (local).

Parameters:
component
time | reference to a Time object to set.
shouldSetMilliseconds | whether to set the milliseconds component of time.
Return values:
STATUS_CODE_SUCCESS
...

static ACTIV_FRAMEWORK_API StatusCode Activ::TimerServiceApi::GetCurrentUtcDate | ( | const Component & | component,
 |  | Date & | date |
 | ) |  |  | [static]

Get current date (utc).

Parameters:
component
date reference to a Date object to set.
Return values:
STATUS_CODE_SUCCESS
...

static ACTIV_FRAMEWORK_API StatusCode Activ::TimerServiceApi::GetCurrentUtcDateTime | ( | const Component & | component,
 |  | DateTime & | dateTime,
 |  | const bool | shouldSetMilliseconds = false |
 | ) |  |  | [static]

Get current date & time (utc).

Parameters:
component
dateTime | reference to a DateTime object to set.
shouldSetMilliseconds | whether to set the milliseconds component of dateTime.
Return values:
STATUS_CODE_SUCCESS
...

static ACTIV_FRAMEWORK_API StatusCode Activ::TimerServiceApi::GetCurrentUtcTime | ( | const Component & | component,
 |  | Time & | time,
 |  | const bool | shouldSetMilliseconds = false |
 | ) |  |  | [static]

Get current time (utc).

Parameters:
component
time | reference to a Time object to set.
shouldSetMilliseconds | whether to set the milliseconds component of time.
Return values:
STATUS_CODE_SUCCESS
...

static ACTIV_FRAMEWORK_API StatusCode Activ::TimerServiceApi::SetTimer | ( | const Component & | component,
 |  | const BaseTime & | time,
 |  | const BaseTime::Duration & | duration,
 |  | Address::Proxy | timerAddress |
 | ) |  |  | [static]

Set a new timer to occur at a given time and then at regular intervals.

Parameters:
component | the component wanting to set the timer.
time | the date/time of the first timer, local or utc.
duration | the duration (in ms) until the next timer.
timerAddress | reference to an Address object to receive the address of the new timer.
Return values:
STATUS_CODE_SUCCESS
...

static ACTIV_FRAMEWORK_API StatusCode Activ::TimerServiceApi::SetTimer | ( | const Component & | component,
 |  | const BaseTime::Duration & | duration,
 |  | Address::Proxy | timerAddress |
 | ) |  |  | [static]

Set a new timer to occur in a given period.

Since there is no source time for this call, the OnTimer() callback will pass back a UTC time object.

Parameters:
component | the component wanting to set the timer.
duration | the duration (in ms) until the timer.
timerAddress | reference to an Address object to receive the address of the new timer.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_TIMEOUT
...

static ACTIV_FRAMEWORK_API StatusCode Activ::TimerServiceApi::SetTimer | ( | const Component & | component,
 |  | const BaseTime & | time,
 |  | Address::Proxy | timerAddress |
 | ) |  |  | [static]

Set a new timer to occur at a given time.

Parameters:
component | the component wanting to set the timer.
time | the date/time of the timer, local or utc.
timerAddress | reference to an Address object to receive the address of the new timer.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_TIMEOUT
...

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivFramework/TimerServiceApi.h
Generated on Wed Oct 8 14:02:01 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::TRational

Activ::TRational Class Reference

Trended rational class. More...

#include <ActivMiddleware/ActivFieldTypes/TRational.h>

Inheritance diagram for Activ::TRational:

Activ::IFieldType

List of all members.

Public Types

enum | Tick { ACTIV_DECLARE_ELEMENT_1_WITH_COMMA }
Tick enumeration.
enum | Trend { ACTIV_DECLARE_ELEMENT_1_WITH_COMMA }
Trend enumeration.

Public Member Functions

virtual void | Clear ()
Clear the object.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		Compare (const void *const pRhsSerializedBody, const size_t rhsSerializedBodyLength, int &result) const
Compare.
ACTIV_FIELD_TYPES_API StatusCode | Compare (const TRational &rhs, int &result) const
Compare.
StatusCode | Compress ()
Compress the numerator and denominator without losing precision.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		Convert (const IFieldType *const pIFieldType)
Convert another IFieldType object to this type.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		Deserialize (MessageValidator &messageValidator, const size_t maxSerializedBodyLength)
Deserialize the object from the supplied message validator.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		DeserializeBody (const void *const pSerializedBody, const size_t serializedBodyLength)
Deserialize the object's body from the supplied data buffer.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		DeserializeLengthAndBody (MessageValidator &messageValidator, const size_t maxSerializedBodyLength=MAX_SERIALIZED_BODY_LENGTH_UNDEFINED)
Deserialize the object's length and body from the supplied message validator.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		FromString (MessageValidator &messageValidator)
Convert the object from a string.
double | Get () const
Get double.
StatusCode | Get (Rational &value, Tick &tick, Trend &trendOnDay, Trend &trendOnPrevious) const
Get the rational and trending.
StatusCode | Get (int64_t &numerator, Rational::Denominator &denominator, Tick &tick, Trend &trendOnDay, Trend &trendOnPrevious) const
Get the numerator, denominator and trending.
Rational::Denominator | GetDenominator () const
Get the denominator portion of the value stored.
virtual ACTIV_FIELD_TYPES_API
std::string 		GetFromStringFormat () const
Get a usage string for the format supported by FromString().
StatusCode | GetNumerator (int64_t &numerator, const Rational::Denominator denominator) const
Get the numerator (in the specificied denominator).
int64_t | GetNumerator () const
Get the numerator portion of the value stored.
StatusCode | GetNumeratorAndDenominator (int64_t &numerator, Rational::Denominator &denominator) const
Get the numerator and denominator.
StatusCode | GetNumeratorAndDivisor (int64_t &numerator, uint64_t &divisor) const
Get the numerator and divisor.
const Rational & | GetRational () const
Get the rational.
virtual size_t | GetSerializedBodyLength () const
Get the serialized length of the object's body.
virtual size_t | GetSerializedLength () const
Get the serialized length of the object.
Tick | GetTick () const
Get the tick.
Trend | GetTrendOnDay () const
Get the trend on day.
Trend | GetTrendOnPrevious () const
Get the trend on previous.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		IsDifferent (const void *const pRhsSerializedBody, const size_t rhsSerializedBodyLength, bool &isDifferent) const
Is different.
operator const Rational & () const
Rational conversion operator.
virtual void | Reset ()
Reset the object.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		Serialize (MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength) const
Serialize the object into the supplied message builder.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		SerializeBody (void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength) const
Serialize the object's body into the supplied data buffer.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		SerializeLengthAndBody (MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength=MAX_SERIALIZED_BODY_LENGTH_UNDEFINED) const
Serialize the object's length and body into the supplied message builder.
StatusCode | Set (const Rational &value, const TRational *pPreviousTick, const Rational *pPreviousValue, const Rational *pPreviousDayValue)
Set a new value.
StatusCode | Set (const int64_t numerator, const Rational::Denominator denominator, const TRational *pPreviousTick, const Rational *pPreviousValue, const Rational *pPreviousDayValue, bool shouldCompress=false)
Set a new value.
StatusCode | Set (const Rational &value, const TRational *pPreviousValue, const Rational *pPreviousDayValue)
Set a new value.
StatusCode | Set (const int64_t numerator, const Rational::Denominator denominator, const TRational *pPreviousValue, const Rational *pPreviousDayValue, bool shouldCompress=false)
Set a new value.
StatusCode | Set (const Rational &value, const Tick tick=TICK_UNDEFINED, const Trend trendOnDay=TREND_UNDEFINED, const Trend trendOnPrevious=TREND_UNDEFINED)
Set a new value.
StatusCode | Set (const int64_t numerator, const Rational::Denominator denominator, const Tick tick=TICK_UNDEFINED, const Trend trendOnDay=TREND_UNDEFINED, const Trend trendOnPrevious=TREND_UNDEFINED, bool shouldCompress=false)
Set a new value.
StatusCode | SetDenominator (const Rational::Denominator denominator)
Set the denominator portion of the value stored.
StatusCode | SetTick (const TRational &previousValue)
Set the tick.
StatusCode | SetTick (const Tick tick)
Set the tick.
StatusCode | SetTickAndTrendOnPrevious (const TRational &previousValue)
Set the tick and trend on previous.
StatusCode | SetTrendOnDay (const Rational &previousDayValue)
Set the trend on day.
StatusCode | SetTrendOnDay (const Trend trend)
Set the trend on day.
StatusCode | SetTrendOnPrevious (const Rational &previousValue)
Set the trend on previous.
StatusCode | SetTrendOnPrevious (const Trend trend)
Set the trend on previous.
ACTIV_FIELD_TYPES_API std::string | ToString (const Rational::Denominator denominator) const
Convert the object to a string.
virtual ACTIV_FIELD_TYPES_API
std::string 		ToString () const
Convert the object to a string.
TRational (const Rational &value, const TRational *pPreviousTick, const Rational *pPreviousValue, const Rational *pPreviousDayValue)
Constructor.
TRational (const int64_t numerator, const Rational::Denominator denominator, const TRational *pPreviousTick, const Rational *pPreviousValue, const Rational *pPreviousDayValue, bool shouldCompress=false)
Constructor.
TRational (const Rational &value, const TRational *pPreviousValue, const Rational *pPreviousDayValue)
Constructor.
TRational (const int64_t numerator, const Rational::Denominator denominator, const TRational *pPreviousValue, const Rational *pPreviousDayValue, bool shouldCompress=false)
Constructor.
TRational (const Rational &value, const Tick tick=TICK_UNDEFINED, const Trend trendOnDay=TREND_UNDEFINED, const Trend trendOnPrevious=TREND_UNDEFINED)
Constructor.
TRational (const int64_t numerator, const Rational::Denominator denominator=Rational::DENOMINATOR_WHOLE, const Tick tick=TICK_UNDEFINED, const Trend trendOnDay=TREND_UNDEFINED, const Trend trendOnPrevious=TREND_UNDEFINED, bool shouldCompress=false)
Constructor.
TRational ()
Default constructor.
virtual | ~TRational ()
Destructor.

Static Public Member Functions

static ACTIV_FIELD_TYPES_API
StatusCode 		Compare (const void *const pLhsSerializedBody, const size_t lhsSerializedBodyLength, const void *const pRhsSerializedBody, const size_t rhsSerializedBodyLength, int &result)
Compare two objects serialized bodies.
static size_t | GetMaxSerializedBodyLength (const size_t size)
Get the maximum serialized length of the object's body.
static size_t | GetMaxSerializedLength (const size_t size)
Get the maximum serialized length of the object.
static bool | IsValidSerializedBodyLength (const size_t serializedBodyLength)
Is valid serialized body length.
static bool | IsValidTick (const Tick tick)
Check whether a tick is valid.
static bool | IsValidTrend (const Trend trend)
Check whether a trend is valid.
static ACTIV_FIELD_TYPES_API
std::string 		TickToString (const Tick tick)
Convert the tick to a string.
static ACTIV_FIELD_TYPES_API
std::string 		TrendToString (const Trend trend)
Convert the trend to a string.
static ACTIV_FIELD_TYPES_API
StatusCode 		ValidateSerializedLengthAndBody (MessageValidator &messageValidator, size_t &serializedBodyOffset, size_t &serializedBodyLength)
Validate the serialized length and body.

Static Public Attributes

static const FieldType | FIELD_TYPE = FIELD_TYPE_TRATIONAL
The field type.

Classes

class | SerializedTrendDefinitions
Serialized trend definitions. More...

Detailed Description

Trended rational class.

Definition at line 47 of file TRational.h.

Constructor & Destructor Documentation

Activ::TRational::TRational | ( | const int64_t | numerator,
 |  | const Rational::Denominator | denominator = Rational::DENOMINATOR_WHOLE,
 |  | const Tick | tick = TICK_UNDEFINED,
 |  | const Trend | trendOnDay = TREND_UNDEFINED,
 |  | const Trend | trendOnPrevious = TREND_UNDEFINED,
 |  | bool | shouldCompress = false |
 | ) |  |  | [inline]

Constructor.

Parameters:
numerator | the numerator portion of the value.
denominator | the denominator portion of the value.
tick | the tick.
trendOnDay | the trend on the day.
trendOnPrevious | the trend on the previous.
shouldCompress | indicates whether the numerator and denominator should be compressed.
Exceptions:
StatusCodeException

Definition at line 686 of file TRational.h.

References ACTIV_THROW_RESULT_IF, and Set().

Activ::TRational::TRational | ( | const Rational & | value,
 |  | const Tick | tick = TICK_UNDEFINED,
 |  | const Trend | trendOnDay = TREND_UNDEFINED,
 |  | const Trend | trendOnPrevious = TREND_UNDEFINED |
 | ) |  |  | [inline]

Constructor.

Parameters:
value | the value.
tick | the tick.
trendOnDay | the trend on the day.
trendOnPrevious | the trend on the previous.
Exceptions:
StatusCodeException

Definition at line 694 of file TRational.h.

References ACTIV_THROW_RESULT_IF, and Set().

Activ::TRational::TRational | ( | const int64_t | numerator,
 |  | const Rational::Denominator | denominator,
 |  | const TRational * | pPreviousValue,
 |  | const Rational * | pPreviousDayValue,
 |  | bool | shouldCompress = false |
 | ) |  |  | [inline]

Constructor.

Parameters:
numerator | the numerator portion of the value.
denominator | the denominator portion of the value.
pPreviousValue | the previous value.
pPreviousDayValue | the previous day's value.
shouldCompress | indicates whether the numerator and denominator should be compressed.
Exceptions:
StatusCodeException

Definition at line 702 of file TRational.h.

References ACTIV_THROW_RESULT_IF, and Set().

Activ::TRational::TRational | ( | const Rational & | value,
 |  | const TRational * | pPreviousValue,
 |  | const Rational * | pPreviousDayValue |
 | ) |  |  | [inline]

Constructor.

Parameters:
value | the value.
pPreviousValue | the previous value.
pPreviousDayValue | the previous day's value.
Exceptions:
StatusCodeException

Definition at line 710 of file TRational.h.

References ACTIV_THROW_RESULT_IF, and Set().

Activ::TRational::TRational | ( | const int64_t | numerator,
 |  | const Rational::Denominator | denominator,
 |  | const TRational * | pPreviousTick,
 |  | const Rational * | pPreviousValue,
 |  | const Rational * | pPreviousDayValue,
 |  | bool | shouldCompress = false |
 | ) |  |  | [inline]

Constructor.

Parameters:
numerator | the numerator portion of the value.
denominator | the denominator portion of the value.
pPreviousTick | the previous tick.
pPreviousValue | the previous value.
pPreviousDayValue | the previous day's value.
shouldCompress | indicates whether the numerator and denominator should be compressed.
Exceptions:
StatusCodeException

Definition at line 718 of file TRational.h.

References ACTIV_THROW_RESULT_IF, and Set().

Activ::TRational::TRational | ( | const Rational & | value,
 |  | const TRational * | pPreviousTick,
 |  | const Rational * | pPreviousValue,
 |  | const Rational * | pPreviousDayValue |
 | ) |  |  | [inline]

Constructor.

Parameters:
value | the value.
pPreviousTick | the previous tick.
pPreviousValue | the previous value.
pPreviousDayValue | the previous day's value.
Exceptions:
StatusCodeException

Definition at line 726 of file TRational.h.

References ACTIV_THROW_RESULT_IF, and Set().

Member Function Documentation

static ACTIV_FIELD_TYPES_API StatusCode Activ::TRational::Compare | ( | const void *const | pLhsSerializedBody,
 |  | const size_t | lhsSerializedBodyLength,
 |  | const void *const | pRhsSerializedBody,
 |  | const size_t | rhsSerializedBodyLength,
 |  | int & | result |
 | ) |  |  | [static]

Compare two objects serialized bodies.

Parameters:
pLhsSerializedBody | the buffer containing the lhs serialized version of the object's body in.
lhsSerializedBodyLength | the lhs serialized body length.
pRhsSerializedBody | the buffer containing the rhs serialized version of the object's body in.
rhsSerializedBodyLength | the rhs serialized body length.
result | the result of the comparison.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_OUT_OF_RANGE

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::TRational::Compare | ( | const void *const | pRhsSerializedBody,
 |  | const size_t | rhsSerializedBodyLength,
 |  | int & | result |
 | ) |  |  | const [virtual]

Compare.

Parameters:
pRhsSerializedBody | the buffer containing the rhs serialized version of the object's body in.
rhsSerializedBodyLength | the rhs serialized body length.
result | the result of the comparison.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

ACTIV_FIELD_TYPES_API StatusCode Activ::TRational::Compare | ( | const TRational & | rhs,
 |  | int & | result |
 | ) |  |  | const

Compare.

Parameters:
rhs | the object to compare with.
result | the result of the comparison.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_OUT_OF_RANGE

StatusCode Activ::TRational::Compress ( ) [inline]

Compress the numerator and denominator without losing precision.

Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED

Definition at line 927 of file TRational.h.

References Activ::Rational::Compress().

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::TRational::Convert ( const IFieldType *const pIFieldType ) [virtual]

Convert another IFieldType object to this type.

Parameters:
pIFieldType the value to assign from.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_MISMATCH
...

Implements Activ::IFieldType.

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::TRational::Deserialize | ( | MessageValidator & | messageValidator,
 |  | const size_t | maxSerializedBodyLength |
 | ) |  |  | [virtual]

Deserialize the object from the supplied message validator.

Parameters:
messageValidator | the message validator from which the object will be extracted.
maxSerializedBodyLength | the maximum serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::TRational::DeserializeBody | ( | const void *const | pSerializedBody,
 |  | const size_t | serializedBodyLength |
 | ) |  |  | [virtual]

Deserialize the object's body from the supplied data buffer.

Parameters:
pSerializedBody | the buffer from which the object's body will be extracted.
serializedBodyLength | the serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::TRational::DeserializeLengthAndBody | ( | MessageValidator & | messageValidator,
 |  | const size_t | maxSerializedBodyLength = MAX_SERIALIZED_BODY_LENGTH_UNDEFINED |
 | ) |  |  | [virtual]

Deserialize the object's length and body from the supplied message validator.

Parameters:
messageValidator | the message validator from which the object will be extracted.
maxSerializedBodyLength | the maximum serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::TRational::FromString ( MessageValidator & messageValidator ) [virtual]

Convert the object from a string.

Parameters:
messageValidator the message validator.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

double Activ::TRational::Get ( ) const [inline]

Get double.

Returns:
the value.
Exceptions:
StatusCodeException

Definition at line 871 of file TRational.h.

References Activ::Rational::Get().

StatusCode Activ::TRational::Get | ( | Rational & | value,
 |  | Tick & | tick,
 |  | Trend & | trendOnDay,
 |  | Trend & | trendOnPrevious |
 | ) |  |  | const [inline]

Get the rational and trending.

Parameters:
value | the value.
tick | the tick on the previous trend.
trendOnDay | the trend on the day.
trendOnPrevious | the trend on the previous.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED

Definition at line 856 of file TRational.h.

References Activ::IFieldType::IsInitialized().

StatusCode Activ::TRational::Get | ( | int64_t & | numerator,
 |  | Rational::Denominator & | denominator,
 |  | Tick & | tick,
 |  | Trend & | trendOnDay,
 |  | Trend & | trendOnPrevious |
 | ) |  |  | const [inline]

Get the numerator, denominator and trending.

Parameters:
numerator | the numerator portion of the value.
denominator | the denominator portion of the value.
tick | the tick on the previous trend.
trendOnDay | the trend on the day.
trendOnPrevious | the trend on the previous.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED

Definition at line 843 of file TRational.h.

References ACTIV_RETURN_RESULT_IF, and Activ::Rational::Get().

Rational::Denominator Activ::TRational::GetDenominator ( ) const [inline]

Get the denominator portion of the value stored.

Returns:
the value of the denominator.
Exceptions:
StatusCodeException

Definition at line 920 of file TRational.h.

References Activ::Rational::GetDenominator().

virtual ACTIV_FIELD_TYPES_API std::string Activ::TRational::GetFromStringFormat ( ) const [virtual]

Get a usage string for the format supported by FromString().

Returns:
String, may be empty.

Implements Activ::IFieldType.

size_t Activ::TRational::GetMaxSerializedBodyLength ( const size_t size ) [inline, static]

Get the maximum serialized length of the object's body.

Parameters:
size the size of the numerator.
Returns:
the maximum serialized length of the object's body.

Definition at line 1108 of file TRational.h.

References Activ::Rational::GetMaxSerializedBodyLength().

Referenced by IsValidSerializedBodyLength().

size_t Activ::TRational::GetMaxSerializedLength ( const size_t size ) [inline, static]

Get the maximum serialized length of the object.

Parameters:
size the size of the numerator.
Returns:
the maximum serialized length of the object.

Definition at line 1101 of file TRational.h.

References Activ::Rational::GetMaxSerializedLength().

StatusCode Activ::TRational::GetNumerator | ( | int64_t & | numerator,
 |  | const Rational::Denominator | denominator |
 | ) |  |  | const [inline]

Get the numerator (in the specificied denominator).

Parameters:
numerator | the numerator.
denominator | the denominator.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED
STATUS_CODE_OUT_OF_RANGE

Definition at line 899 of file TRational.h.

References Activ::Rational::GetNumerator().

int64_t Activ::TRational::GetNumerator ( ) const [inline]

Get the numerator portion of the value stored.

Returns:
the value of the numerator.
Exceptions:
StatusCodeException

Definition at line 892 of file TRational.h.

References Activ::Rational::GetNumerator().

StatusCode Activ::TRational::GetNumeratorAndDenominator | ( | int64_t & | numerator,
 |  | Rational::Denominator & | denominator |
 | ) |  |  | const [inline]

Get the numerator and denominator.

Parameters:
numerator | the numerator portion of the value.
denominator | the denominator portion of the value.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED

Definition at line 878 of file TRational.h.

References Activ::Rational::Get().

StatusCode Activ::TRational::GetNumeratorAndDivisor | ( | int64_t & | numerator,
 |  | uint64_t & | divisor |
 | ) |  |  | const [inline]

Get the numerator and divisor.

Parameters:
numerator | the numerator.
divisor | the divisor.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED
STATUS_CODE_OUT_OF_RANGE

Definition at line 906 of file TRational.h.

References Activ::Rational::GetNumeratorAndDivisor().

const Rational & Activ::TRational::GetRational ( ) const [inline]

Get the rational.

Returns:
the rational.
Exceptions:
StatusCodeException

Definition at line 885 of file TRational.h.

Referenced by SetTickAndTrendOnPrevious().

size_t Activ::TRational::GetSerializedBodyLength ( ) const [inline, virtual]

Get the serialized length of the object's body.

Returns:
the serialized length of the object's body.

Implements Activ::IFieldType.

Definition at line 1094 of file TRational.h.

References Activ::Rational::GetSerializedBodyLength().

size_t Activ::TRational::GetSerializedLength ( ) const [inline, virtual]

Get the serialized length of the object.

Returns:
the serialized length of the object.

Implements Activ::IFieldType.

Definition at line 1087 of file TRational.h.

References Activ::Rational::GetSerializedLength().

TRational::Tick Activ::TRational::GetTick ( ) const [inline]

Get the tick.

Returns:
the tick.
Exceptions:
StatusCodeException

Definition at line 987 of file TRational.h.

References ACTIV_THROW, and Activ::IFieldType::IsInitialized().

TRational::Trend Activ::TRational::GetTrendOnDay ( ) const [inline]

Get the trend on day.

Returns:
the trend.
Exceptions:
StatusCodeException

Definition at line 1024 of file TRational.h.

References ACTIV_THROW, and Activ::IFieldType::IsInitialized().

TRational::Trend Activ::TRational::GetTrendOnPrevious ( ) const [inline]

Get the trend on previous.

Returns:
the trend.
Exceptions:
StatusCodeException

Definition at line 1061 of file TRational.h.

References ACTIV_THROW, and Activ::IFieldType::IsInitialized().

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::TRational::IsDifferent | ( | const void *const | pRhsSerializedBody,
 |  | const size_t | rhsSerializedBodyLength,
 |  | bool & | isDifferent |
 | ) |  |  | const [virtual]

Is different.

Parameters:
pRhsSerializedBody | the buffer containing the rhs serialized version of the object's body in.
rhsSerializedBodyLength | the rhs serialized body length.
isDifferent | indicates whether the two objects are different.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

bool Activ::TRational::IsValidSerializedBodyLength ( const size_t serializedBodyLength ) [inline, static]

Is valid serialized body length.

Parameters:
serializedBodyLength the serialized body length.
Returns:
whether the serialized body length is valid.

Definition at line 1129 of file TRational.h.

References GetMaxSerializedBodyLength().

bool Activ::TRational::IsValidTick ( const Tick tick ) [inline, static]

Check whether a tick is valid.

Parameters:
tick the tick to check.
Returns:
whether the tick is valid.

Definition at line 1115 of file TRational.h.

Referenced by Set(), and SetTick().

bool Activ::TRational::IsValidTrend ( const Trend trend ) [inline, static]

Check whether a trend is valid.

Parameters:
trend the trend to check.
Returns:
whether the trend is valid.

Definition at line 1122 of file TRational.h.

Referenced by Set(), SetTrendOnDay(), and SetTrendOnPrevious().

Activ::TRational::operator const Rational & ( ) const [inline]

Rational conversion operator.

Exceptions:
StatusCodeException

Definition at line 740 of file TRational.h.

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::TRational::Serialize | ( | MessageBuilder & | messageBuilder,
 |  | const size_t | maxSerializedBodyLength |
 | ) |  |  | const [virtual]

Serialize the object into the supplied message builder.

Parameters:
messageBuilder | the message builder to store a serialized version of the object in.
maxSerializedBodyLength | the maximum serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::TRational::SerializeBody | ( | void * | pSerializedBody,
 |  | const size_t | maxSerializedBodyLength,
 |  | size_t & | serializedBodyLength |
 | ) |  |  | const [virtual]

Serialize the object's body into the supplied data buffer.

Parameters:
pSerializedBody | the buffer to store a serialized version of the object's body in.
maxSerializedBodyLength | the maximum serialized body length.
serializedBodyLength | the serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::TRational::SerializeLengthAndBody | ( | MessageBuilder & | messageBuilder,
 |  | const size_t | maxSerializedBodyLength = MAX_SERIALIZED_BODY_LENGTH_UNDEFINED |
 | ) |  |  | const [virtual]

Serialize the object's length and body into the supplied message builder.

Parameters:
messageBuilder | the message builder to store a serialized version of the object in.
maxSerializedBodyLength | the maximum serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

StatusCode Activ::TRational::Set | ( | const Rational & | value,
 |  | const TRational * | pPreviousTick,
 |  | const Rational * | pPreviousValue,
 |  | const Rational * | pPreviousDayValue |
 | ) |  |  | [inline]

Set a new value.

Parameters:
value | the value.
pPreviousTick | the previous tick.
pPreviousValue | the previous value.
pPreviousDayValue | the previous day's value.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED

Definition at line 822 of file TRational.h.

References ACTIV_RETURN_RESULT_IF, Activ::IFieldType::IsInitialized(), SetTick(), SetTrendOnDay(), and SetTrendOnPrevious().

StatusCode Activ::TRational::Set | ( | const int64_t | numerator,
 |  | const Rational::Denominator | denominator,
 |  | const TRational * | pPreviousTick,
 |  | const Rational * | pPreviousValue,
 |  | const Rational * | pPreviousDayValue,
 |  | bool | shouldCompress = false |
 | ) |  |  | [inline]

Set a new value.

Parameters:
numerator | the numerator portion of the value.
denominator | the denominator portion of the value.
pPreviousTick | the previous tick.
pPreviousValue | the previous value.
pPreviousDayValue | the previous day's value.
shouldCompress | indicates whether the numerator and denominator should be compressed.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED

Definition at line 812 of file TRational.h.

References ACTIV_RETURN_RESULT_IF, Set(), and Activ::Rational::Set().

StatusCode Activ::TRational::Set | ( | const Rational & | value,
 |  | const TRational * | pPreviousValue,
 |  | const Rational * | pPreviousDayValue |
 | ) |  |  | [inline]

Set a new value.

Parameters:
value | the value.
pPreviousValue | the previous value.
pPreviousDayValue | the previous day's value.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED

Definition at line 793 of file TRational.h.

References ACTIV_RETURN_RESULT_IF, Activ::IFieldType::IsInitialized(), SetTickAndTrendOnPrevious(), and SetTrendOnDay().

StatusCode Activ::TRational::Set | ( | const int64_t | numerator,
 |  | const Rational::Denominator | denominator,
 |  | const TRational * | pPreviousValue,
 |  | const Rational * | pPreviousDayValue,
 |  | bool | shouldCompress = false |
 | ) |  |  | [inline]

Set a new value.

Parameters:
numerator | the numerator portion of the value.
denominator | the denominator portion of the value.
pPreviousValue | the previous value.
pPreviousDayValue | the previous day's value.
shouldCompress | indicates whether the numerator and denominator should be compressed.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED

Definition at line 783 of file TRational.h.

References ACTIV_RETURN_RESULT_IF, Set(), and Activ::Rational::Set().

StatusCode Activ::TRational::Set | ( | const Rational & | value,
 |  | const Tick | tick = TICK_UNDEFINED,
 |  | const Trend | trendOnDay = TREND_UNDEFINED,
 |  | const Trend | trendOnPrevious = TREND_UNDEFINED |
 | ) |  |  | [inline]

Set a new value.

Parameters:
value | the value.
tick | the tick.
trendOnDay | the trend on the day.
trendOnPrevious | the trend on the previous.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED

Definition at line 764 of file TRational.h.

References Activ::IFieldType::IsInitialized(), IsValidTick(), IsValidTrend(), and Activ::IFieldType::m_isInitialized.

StatusCode Activ::TRational::Set | ( | const int64_t | numerator,
 |  | const Rational::Denominator | denominator,
 |  | const Tick | tick = TICK_UNDEFINED,
 |  | const Trend | trendOnDay = TREND_UNDEFINED,
 |  | const Trend | trendOnPrevious = TREND_UNDEFINED,
 |  | bool | shouldCompress = false |
 | ) |  |  | [inline]

Set a new value.

Parameters:
numerator | the numerator portion of the value.
denominator | the denominator portion of the value.
tick | the tick.
trendOnDay | the trend on the day.
trendOnPrevious | the trend on the previous.
shouldCompress | indicates whether the numerator and denominator should be compressed.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER

Definition at line 747 of file TRational.h.

References ACTIV_RETURN_RESULT_IF, IsValidTick(), IsValidTrend(), Activ::IFieldType::m_isInitialized, and Activ::Rational::Set().

Referenced by Set(), and TRational().

StatusCode Activ::TRational::SetDenominator ( const Rational::Denominator denominator ) [inline]

Set the denominator portion of the value stored.

This function will attempt to scale the existing numerator in the record.

Parameters:
denominator the denominator portion of the value.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED
STATUS_CODE_OUT_OF_RANGE

Definition at line 913 of file TRational.h.

References Activ::Rational::SetDenominator().

StatusCode Activ::TRational::SetTick ( const TRational & previousValue ) [inline]

Set the tick.

Parameters:
previousValue the previous value.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED

Definition at line 949 of file TRational.h.

References ACTIV_RETURN_RESULT_IF, Activ::Rational::Compare(), m_tick, and m_value.

StatusCode Activ::TRational::SetTick ( const Tick tick ) [inline]

Set the tick.

Parameters:
tick the tick.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED

Definition at line 934 of file TRational.h.

References Activ::IFieldType::IsInitialized(), and IsValidTick().

Referenced by Set().

StatusCode Activ::TRational::SetTickAndTrendOnPrevious ( const TRational & previousValue ) [inline]

Set the tick and trend on previous.

Parameters:
previousValue the previous value.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED

Definition at line 961 of file TRational.h.

References ACTIV_RETURN_RESULT_IF, Activ::Rational::Compare(), GetRational(), and m_tick.

Referenced by Set().

StatusCode Activ::TRational::SetTrendOnDay ( const Rational & previousDayValue ) [inline]

Set the trend on day.

Parameters:
previousDayValue the previous day's value.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED

Definition at line 1012 of file TRational.h.

References ACTIV_RETURN_RESULT_IF, and Activ::Rational::Compare().

StatusCode Activ::TRational::SetTrendOnDay ( const Trend trend ) [inline]

Set the trend on day.

Parameters:
trend the trend.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED

Definition at line 997 of file TRational.h.

References Activ::IFieldType::IsInitialized(), and IsValidTrend().

Referenced by Set().

StatusCode Activ::TRational::SetTrendOnPrevious ( const Rational & previousValue ) [inline]

Set the trend on previous.

Parameters:
previousValue the previous value.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED

Definition at line 1049 of file TRational.h.

References ACTIV_RETURN_RESULT_IF, and Activ::Rational::Compare().

StatusCode Activ::TRational::SetTrendOnPrevious ( const Trend trend ) [inline]

Set the trend on previous.

Parameters:
trend the trend.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
STATUS_CODE_NOT_INITIALIZED

Definition at line 1034 of file TRational.h.

References Activ::IFieldType::IsInitialized(), and IsValidTrend().

Referenced by Set().

static ACTIV_FIELD_TYPES_API std::string Activ::TRational::TickToString ( const Tick tick ) [static]

Convert the tick to a string.

Parameters:
tick the tick to convert.
Returns:
the tick as a string.

ACTIV_FIELD_TYPES_API std::string Activ::TRational::ToString ( const Rational::Denominator denominator ) const

Convert the object to a string.

Parameters:
denominator indicates the denominator to display the value in.
Returns:
the object as a string.
Exceptions:
StatusCodeException

virtual ACTIV_FIELD_TYPES_API std::string Activ::TRational::ToString ( ) const [virtual]

Convert the object to a string.

Returns:
the object as a string.

Implements Activ::IFieldType.

static ACTIV_FIELD_TYPES_API std::string Activ::TRational::TrendToString ( const Trend trend ) [static]

Convert the trend to a string.

Parameters:
trend the trend to convert.
Returns:
the trend as a string.

static ACTIV_FIELD_TYPES_API StatusCode Activ::TRational::ValidateSerializedLengthAndBody | ( | MessageValidator & | messageValidator,
 |  | size_t & | serializedBodyOffset,
 |  | size_t & | serializedBodyLength |
 | ) |  |  | [static]

Validate the serialized length and body.

Parameters:
messageValidator | the message validator.
serializedBodyOffset | the serialized body offset.
serializedBodyLength | the serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivFieldTypes/TRational.h
Generated on Wed Oct 8 14:02:01 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::TRational::SerializedTrendDefinitions

Activ::TRational::SerializedTrendDefinitions Class Reference

Serialized trend definitions. More...

#include <ActivMiddleware/ActivFieldTypes/TRational.h>

List of all members.

Public Types

typedef byte_t | SerializedTrend
The serialized trend typedef.

Static Public Member Functions

static SerializedTrend | GetSerializedTrend (const Tick tick, const Trend trendOnDay, const Trend trendOnPrevious)
Get the serialized trend.
static Tick | GetTick (const SerializedTrend serializedTrend)
Get the tick.
static Trend | GetTrendOnDay (const SerializedTrend serializedTrend)
Get the trend on day.
static Trend | GetTrendOnPrevious (const SerializedTrend serializedTrend)
Get the trend on previous.

Static Public Attributes

static const size_t | RESERVED_LENGTH = 2
The ireserved length.
static const size_t | RESERVED_OFFSET = 0
The ireserved offset.
static const size_t | TICK_LENGTH = 2
The tick length.
static const size_t | TICK_OFFSET = (RESERVED_OFFSET + RESERVED_LENGTH)
The tick offset.
static const size_t | TREND_ON_DAY_LENGTH = 2
The trend on day length.
static const size_t | TREND_ON_DAY_OFFSET = (TICK_OFFSET + TICK_LENGTH)
The trend on day offset.
static const size_t | TREND_ON_PREVIOUS_LENGTH = 2
The trend on previous length.
static const size_t | TREND_ON_PREVIOUS_OFFSET = (TREND_ON_DAY_OFFSET + TREND_ON_DAY_LENGTH)
The trend on previous offset.

Detailed Description

Serialized trend definitions.

Definition at line 81 of file TRational.h.

Member Function Documentation

TRational::SerializedTrendDefinitions::SerializedTrend Activ::TRational::SerializedTrendDefinitions::GetSerializedTrend | ( | const Tick | tick,
 |  | const Trend | trendOnDay,
 |  | const Trend | trendOnPrevious |
 | ) |  |  | [inline, static]

Get the serialized trend.

Parameters:
tick | the tick.
trendOnDay | the trend on the day.
trendOnPrevious | the trend on the previous.
Returns:
the serialized trend.

Definition at line 1137 of file TRational.h.

References TICK_LENGTH, TICK_OFFSET, TREND_ON_DAY_LENGTH, TREND_ON_DAY_OFFSET, TREND_ON_PREVIOUS_LENGTH, and TREND_ON_PREVIOUS_OFFSET.

TRational::Tick Activ::TRational::SerializedTrendDefinitions::GetTick ( const SerializedTrend serializedTrend ) [inline, static]

Get the tick.

Parameters:
serializedTrend the serialized trend.
Returns:
the tick.

Definition at line 1144 of file TRational.h.

References TICK_LENGTH, and TICK_OFFSET.

TRational::Trend Activ::TRational::SerializedTrendDefinitions::GetTrendOnDay ( const SerializedTrend serializedTrend ) [inline, static]

Get the trend on day.

Parameters:
serializedTrend the serialized trend.
Returns:
the trend on day.

Definition at line 1151 of file TRational.h.

References TREND_ON_DAY_LENGTH, and TREND_ON_DAY_OFFSET.

TRational::Trend Activ::TRational::SerializedTrendDefinitions::GetTrendOnPrevious ( const SerializedTrend serializedTrend ) [inline, static]

Get the trend on previous.

Parameters:
serializedTrend the serialized trend.
Returns:
the trend on previous.

Definition at line 1158 of file TRational.h.

References TREND_ON_PREVIOUS_LENGTH, and TREND_ON_PREVIOUS_OFFSET.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivFieldTypes/TRational.h
Generated on Wed Oct 8 14:02:01 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::TypeToIntegralType

Activ::TypeToIntegralType< T > Class Template Reference

Template to determine ACTIV integral type from an arbitrary type, if possible. More...

#include <ActivMiddleware/BasicTypes.h>

List of all members.

Public Types

typedef LengthToIntegralType
< sizeof(T), boost::is_signed
< T >::value >::Type 		Type

Detailed Description

template<typename T>
class Activ::TypeToIntegralType< T >

Template to determine ACTIV integral type from an arbitrary type, if possible.

T is the type to convert to an equally sized and signed ACTIV integral type.

Provides a Type typedef if such a conversion is possible.

Definition at line 351 of file BasicTypes.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/BasicTypes.h
Generated on Wed Oct 8 14:02:01 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::UdpComponent

Activ::UdpComponent Class Reference

Udp ingest component. More...

#include <ActivMiddleware/ActivFramework/UdpComponent.h>

Inheritance diagram for Activ::UdpComponent:

Activ::Component Activ::Port

List of all members.

Public Member Functions

ACTIV_FRAMEWORK_API StatusCode | Close (const Address &socketAddress, const bool gracefully=false) const
Close a socket.
ACTIV_FRAMEWORK_API StatusCode | Connect (const Address &socketAddress, const std::string &remoteAddressString, const uint16_t remotePort) const
Connect a socket to a remote address (filter all traffic from other addresses).
ACTIV_FRAMEWORK_API StatusCode | CreateSocket (const std::string &localAddress, const uint16_t localPort, const uint16_t maxRxSize, Address &socketAddress, IHeap *const pHeap=0) const
Create a socket and bind it to a local address.
ACTIV_FRAMEWORK_API StatusCode | Disconnect (const Address &socketAddress) const
Disconnect a socket from a remote address (allow all traffic).
ACTIV_FRAMEWORK_API StatusCode | GetSocketHandle (const Address &socketAddress, SOCKET &socket) const
Get the underying socket handle.
ACTIV_FRAMEWORK_API StatusCode | JoinMulticastGroup (const Address &socketAddress, const std::string &multicastGroupString, const std::string &interfaceAddressString) const
Join a multicast group.
ACTIV_FRAMEWORK_API StatusCode | LeaveMulticastGroup (const Address &socketAddress, const std::string &multicastGroupString, const std::string &interfaceAddressString) const
Leave a multicast group.
ACTIV_FRAMEWORK_API StatusCode | PostData (const Address &socketAddress, const void *pData, const size_t dataLength) const
Post some data.
ACTIV_FRAMEWORK_API StatusCode | PostData (const Address &socketAddress, HeapMessage &heapMessage) const
Post some data.
ACTIV_FRAMEWORK_API StatusCode | Read (const Address &socketAddress) const
Initiate a read on a socket.
ACTIV_FRAMEWORK_API StatusCode | SetMulticastLoopback (const Address &socketAddress, const bool enable) const
Set the receive multicast loopback option of a socket.
ACTIV_FRAMEWORK_API StatusCode | SetMulticastTtl (const Address &socketAddress, const int ttl) const
Set TTL to be used for multicasting.
ACTIV_FRAMEWORK_API StatusCode | SetMulticastTxInterface (const Address &socketAddress, const std::string &interfaceAddressString) const
Set multicast interface for transmission.
ACTIV_FRAMEWORK_API StatusCode | SetRxBufferSize (const Address &socketAddress, const int size) const
Set the internal rx buffer size of a socket.
ACTIV_FRAMEWORK_API StatusCode | SetTxBufferSize (const Address &socketAddress, const int size) const
Set the internal tx buffer size of a socket.
ACTIV_FRAMEWORK_API StatusCode | SetUnicastTtl (const Address &socketAddress, const int ttl) const
Set TTL to be used for unicasting.
ACTIV_FRAMEWORK_API | UdpComponent (Application &application, ManagedEndPoint &managedEndPoint, const std::string &name=Port::anonymousName, IHeap *const pHeap=0, const std::string &componentId=defaultComponentId)
Constructor.
ACTIV_FRAMEWORK_API | ~UdpComponent ()
Destructor.

Protected Member Functions

virtual ACTIV_FRAMEWORK_API
StatusCode 		OnMessage (HeapMessage &message)
Message callback.
virtual ACTIV_FRAMEWORK_API void | OnSocketClose (const Address &socketAddress)
Socket has closed due to being shutdown.
virtual ACTIV_FRAMEWORK_API void | OnSocketError (const Address &socketAddress)
Socket has closed due to an error.

Detailed Description

Udp ingest component.

Definition at line 21 of file UdpComponent.h.

Constructor & Destructor Documentation

ACTIV_FRAMEWORK_API Activ::UdpComponent::UdpComponent | ( | Application & | application,
 |  | ManagedEndPoint & | managedEndPoint,
 |  | const std::string & | name = Port::anonymousName,
 |  | IHeap *const | pHeap = 0,
 |  | const std::string & | componentId = defaultComponentId
 | ) |  |

Constructor.

Attaches this object to a managed endpoint at the next available slot.

Parameters:
application | Application object to attach to.
managedEndPoint | reference to a ManagedEndPoint object to which this port is to be attached.
name | name of the port, local to the endpoint.
pHeap | heap to use for messaging, or 0 for the system heap.
componentId | the component id.
Exceptions:
Exception.

Member Function Documentation

ACTIV_FRAMEWORK_API StatusCode Activ::UdpComponent::Close | ( | const Address & | socketAddress,
 |  | const bool | gracefully = false |
 | ) |  |  | const

Close a socket.

Parameters:
socketAddress | address of the socket to shutdown.
gracefully | true to only close the socket once any outstanding tx has completed, false to force the socket closed immediately.
Return values:
STATUS_CODE_SUCCESS | the socket is fully closed.
STATUS_CODE_PENDING | the socket is closing and OnSocketClose() will be called.
...

ACTIV_FRAMEWORK_API StatusCode Activ::UdpComponent::Connect | ( | const Address & | socketAddress,
 |  | const std::string & | remoteAddressString,
 |  | const uint16_t | remotePort |
 | ) |  |  | const

Connect a socket to a remote address (filter all traffic from other addresses).

Parameters:
socketAddress | address of the socket to connect.
remoteAddressString | the remote address to connect to in string form.
remotePort | the remote port to connect to (local endian).
Return values:
...

ACTIV_FRAMEWORK_API StatusCode Activ::UdpComponent::CreateSocket | ( | const std::string & | localAddress,
 |  | const uint16_t | localPort,
 |  | const uint16_t | maxRxSize,
 |  | Address & | socketAddress,
 |  | IHeap *const | pHeap = 0 |
 | ) |  |  | const

Create a socket and bind it to a local address.

Parameters:
localAddress | local address to bind to.
localPort | local port to bind to.
maxRxSize | maximum size of a datagram that can be received.
socketAddress | reference to an Address object to receive the address of the socket.
pHeap | the heap to use for received messages. Default is this port's heap.
Return values:
STATUS_CODE_SUCCESS.
STATUS_CODE_TIMEOUT.
STATUS_CODE_FAILURE ...

ACTIV_FRAMEWORK_API StatusCode Activ::UdpComponent::Disconnect ( const Address & socketAddress ) const

Disconnect a socket from a remote address (allow all traffic).

Parameters:
socketAddress address of the socket to disconnect.
Return values:
...

ACTIV_FRAMEWORK_API StatusCode Activ::UdpComponent::GetSocketHandle | ( | const Address & | socketAddress,
 |  | SOCKET & | socket |
 | ) |  |  | const

Get the underying socket handle.

Parameters:
socketAddress | the socket to get the handle of.
socket | reference to a SOCKET variable to receive the handle.
Return values:
STATUS_CODE_SUCCESS
...

ACTIV_FRAMEWORK_API StatusCode Activ::UdpComponent::JoinMulticastGroup | ( | const Address & | socketAddress,
 |  | const std::string & | multicastGroupString,
 |  | const std::string & | interfaceAddressString |
 | ) |  |  | const

Join a multicast group.

Parameters:
socketAddress | address of the socket to join the multicast group on.
multicastGroupString | an ipv4 or ipv6 multicast address string.
interfaceAddressString | an ipv4 or ipv6 interface address string.
Return values:
...

ACTIV_FRAMEWORK_API StatusCode Activ::UdpComponent::LeaveMulticastGroup | ( | const Address & | socketAddress,
 |  | const std::string & | multicastGroupString,
 |  | const std::string & | interfaceAddressString |
 | ) |  |  | const

Leave a multicast group.

Parameters:
socketAddress | address of the socket to leave the multicast group.
multicastGroupString | an ipv4 or ipv6 multicast address string.
interfaceAddressString | an ipv4 or ipv6 interface address string.
Return values:
...

virtual ACTIV_FRAMEWORK_API StatusCode Activ::UdpComponent::OnMessage ( HeapMessage & message ) [protected, virtual]

Message callback.

If you override this method, please call the base class method for any unrecognized message types.

Parameters:
message the message.
Return values:
STATUS_CODE_SUCCESS | the message was recognized.
STATUS_CODE_UNRECOGNIZED | the message was not recognized.
STATUS_CODE_THREAD_EXIT | received a thread-die message.
...

Reimplemented from Activ::Component.

ACTIV_FRAMEWORK_API StatusCode Activ::UdpComponent::PostData | ( | const Address & | socketAddress,
 |  | const void * | pData,
 |  | const size_t | dataLength |
 | ) |  |  | const

Post some data.

Parameters:
socketAddress | the socket to send the data on.
pData | pointer to data to send.
dataLength | length of data.
Return values:
...

ACTIV_FRAMEWORK_API StatusCode Activ::UdpComponent::PostData | ( | const Address & | socketAddress,
 |  | HeapMessage & | heapMessage |
 | ) |  |  | const

Post some data.

Parameters:
socketAddress | the socket to send the data on.
heapMessage | the message to send.
Return values:
...

ACTIV_FRAMEWORK_API StatusCode Activ::UdpComponent::Read ( const Address & socketAddress ) const

Initiate a read on a socket.

Parameters:
socketAddress address of the socket to connect.
Return values:
...

ACTIV_FRAMEWORK_API StatusCode Activ::UdpComponent::SetMulticastLoopback | ( | const Address & | socketAddress,
 |  | const bool | enable |
 | ) |  |  | const

Set the receive multicast loopback option of a socket.

Parameters:
socketAddress | address of the socket to set transmit buffer size on.
enable | true to enable receipt of multicast loopback data, else false.
Return values:
...

ACTIV_FRAMEWORK_API StatusCode Activ::UdpComponent::SetMulticastTtl | ( | const Address & | socketAddress,
 |  | const int | ttl |
 | ) |  |  | const

Set TTL to be used for multicasting.

Parameters:
socketAddress | address of the socket to set the ttl on.
ttl | the TTL.
Return values:
...

ACTIV_FRAMEWORK_API StatusCode Activ::UdpComponent::SetMulticastTxInterface | ( | const Address & | socketAddress,
 |  | const std::string & | interfaceAddressString |
 | ) |  |  | const

Set multicast interface for transmission.

Parameters:
socketAddress | address of the socket to set multicast interface on.
interfaceAddressString | an ipv4 or ipv6 address string.
Return values:
...

ACTIV_FRAMEWORK_API StatusCode Activ::UdpComponent::SetRxBufferSize | ( | const Address & | socketAddress,
 |  | const int | size |
 | ) |  |  | const

Set the internal rx buffer size of a socket.

Parameters:
socketAddress | address of the socket to set receive buffer size.
size | the rx buffer size.
Return values:
...

ACTIV_FRAMEWORK_API StatusCode Activ::UdpComponent::SetTxBufferSize | ( | const Address & | socketAddress,
 |  | const int | size |
 | ) |  |  | const

Set the internal tx buffer size of a socket.

Parameters:
socketAddress | address of the socket to set transmit buffer size on.
size | the tx buffer size.
Return values:
...

ACTIV_FRAMEWORK_API StatusCode Activ::UdpComponent::SetUnicastTtl | ( | const Address & | socketAddress,
 |  | const int | ttl |
 | ) |  |  | const

Set TTL to be used for unicasting.

Parameters:
socketAddress | address of the socket to set unicast ttl on.
ttl | the TTL.
Return values:
...

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivFramework/UdpComponent.h
Generated on Wed Oct 8 14:02:01 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::UdpSocket

Activ::UdpSocket Class Reference

UDP socket class. More...

#include <ActivMiddleware/ActivIp/Windows/UdpSocket.h>

Inheritance diagram for Activ::UdpSocket:

Activ::IpSocket

List of all members.

Public Types

enum | State { ACTIV_DECLARE_VALUE_WITH_COMMA }
States.

Public Member Functions

ACTIV_IP_API void | AbortiveClose ()
Initiate an abortive close on the socket.
ACTIV_IP_API void | Connect (const IpAddress &remoteAddress)
Connect to a remote address (filter all traffic from other addresses).
ACTIV_IP_API void | Connect (const std::string &remoteAddressString, const uint16_t remotePort)
Connect to a remote address (filter all traffic from other addresses).
ACTIV_IP_API void | Disconnect ()
Disconnect from a remote address (allow all traffic).
ACTIV_IP_API void | Initialize (const IpAddress &localAddress)
Create and bind a socket.
ACTIV_IP_API void | Initialize (const std::string &localAddressString, const uint16_t localPort)
Create and bind a socket.
ACTIV_IP_API void | JoinMulticastGroup (const std::string &multicastGroupString, const std::string &interfaceAddressString)
Join a multicast group.
ACTIV_IP_API void | LeaveMulticastGroup (const std::string &multicastGroupString, const std::string &interfaceAddressString)
Leave a multicast group.
ACTIV_IP_API void | SetMulticastLoopback (const bool isEnabled)
Set multicast loopback.
ACTIV_IP_API void | SetMulticastTtl (const int ttl)
Set TTL to be used for multicasting.
ACTIV_IP_API void | SetMulticastTxInterface (const std::string &interfaceAddressString)
Set multicast interface for transmission.
ACTIV_IP_API void | SetUnicastTtl (const int ttl)
Set TTL to be used for unicasting.
ACTIV_IP_API bool | Shutdown (const bool gracefully=false)
Shutdown the socket.
ACTIV_IP_API | UdpSocket (IpManager &manager, const Settings &settings=Settings())
Constructor.
ACTIV_IP_API | ~UdpSocket ()
Destructor.

Static Public Member Functions

static ACTIV_IP_API std::string | StateToString (const State state)
Return state as string.

Protected Member Functions

virtual ACTIV_IP_API void | OnError ()
Socket has closed due to an error.
virtual ACTIV_IP_API
CompletionResult 		OnRxBuffers (const size_t dataLength)
Callback on rx completion.
virtual ACTIV_IP_API void | OnShutdown ()
Socket has closed after a Shutdown() call.
virtual ACTIV_IP_API
CompletionResult 		OnTxBuffers (const size_t dataLength)
Callback on tx completion.

Protected Attributes

State m_state
The state of the socket.

Classes

class | Settings
Settings. More...
class | Stats
Stats. More...

Detailed Description

UDP socket class.

Definition at line 29 of file UdpSocket.h.

Constructor & Destructor Documentation

ACTIV_IP_API Activ::UdpSocket::UdpSocket | ( | IpManager & | manager,
 |  | const Settings & | settings = Settings()
 | ) |  |

Constructor.

Parameters:
manager | the IpManager that owns the socket.
settings | settings for this socket.
Exceptions:
Exception.

ACTIV_IP_API Activ::UdpSocket::~UdpSocket ( )

Destructor.

Note a socket is only closed in the destructor.

Member Function Documentation

ACTIV_IP_API void Activ::UdpSocket::AbortiveClose ( )

Initiate an abortive close on the socket.

This will result in an OnError() if the socket was open and not shutting down "cleanly" as the result of a Shutdown() call.

ACTIV_IP_API void Activ::UdpSocket::Connect ( const IpAddress & remoteAddress )

Connect to a remote address (filter all traffic from other addresses).

Parameters:
remoteAddress the remote address to connect to.
Exceptions:
Exception.

ACTIV_IP_API void Activ::UdpSocket::Connect | ( | const std::string & | remoteAddressString,
 |  | const uint16_t | remotePort
 | ) |  |

Connect to a remote address (filter all traffic from other addresses).

Parameters:
remoteAddressString | the remote address to connect to in string form.
remotePort | the remote port to connect to (local endian).
Exceptions:
Exception.

ACTIV_IP_API void Activ::UdpSocket::Disconnect ( )

Disconnect from a remote address (allow all traffic).

Exceptions:
Exception.

ACTIV_IP_API void Activ::UdpSocket::Initialize ( const IpAddress & localAddress )

Create and bind a socket.

Parameters:
localAddress the local address to bind to.
Exceptions:
Exception.

ACTIV_IP_API void Activ::UdpSocket::Initialize | ( | const std::string & | localAddressString,
 |  | const uint16_t | localPort
 | ) |  |

Create and bind a socket.

Parameters:
localAddressString | the local address to bind to in string form.
localPort | the local port number to bind to (local endian).
Exceptions:
Exception.

ACTIV_IP_API void Activ::UdpSocket::JoinMulticastGroup | ( | const std::string & | multicastGroupString,
 |  | const std::string & | interfaceAddressString
 | ) |  |

Join a multicast group.

Parameters:
multicastGroupString | an ipv4 or ipv6 multicast address string.
interfaceAddressString | an ipv4 or ipv6 interface address string.
Exceptions:
Exception.

ACTIV_IP_API void Activ::UdpSocket::LeaveMulticastGroup | ( | const std::string & | multicastGroupString,
 |  | const std::string & | interfaceAddressString
 | ) |  |

Leave a multicast group.

Parameters:
multicastGroupString | an ipv4 or ipv6 multicast address string.
interfaceAddressString | an ipv4 or ipv6 interface address string.
Exceptions:
Exception.

virtual ACTIV_IP_API CompletionResult Activ::UdpSocket::OnRxBuffers ( const size_t dataLength ) [protected, virtual]

Callback on rx completion.

When overriding this function, you MUST call the base class OnRxBuffers() first, and return the result if it isn't COMPLETION_RESULT_SUCCESS.

Parameters:
dataLength the number of bytes transferred.

Reimplemented from Activ::IpSocket.

virtual ACTIV_IP_API CompletionResult Activ::UdpSocket::OnTxBuffers ( const size_t dataLength ) [protected, virtual]

Callback on tx completion.

When overriding this function, you MUST call the base class OnTxBuffers() first, and return the result if it isn't COMPLETION_RESULT_SUCCESS.

Parameters:
dataLength the number of bytes transferred.

Reimplemented from Activ::IpSocket.

ACTIV_IP_API void Activ::UdpSocket::SetMulticastLoopback ( const bool isEnabled )

Set multicast loopback.

Parameters:
isEnabled true to enable, false to disable.
Exceptions:
Exception.

ACTIV_IP_API void Activ::UdpSocket::SetMulticastTtl ( const int ttl )

Set TTL to be used for multicasting.

Parameters:
ttl the TTL.
Exceptions:
Exception.

ACTIV_IP_API void Activ::UdpSocket::SetMulticastTxInterface ( const std::string & interfaceAddressString )

Set multicast interface for transmission.

Parameters:
interfaceAddressString an ipv4 or ipv6 address string.
Exceptions:
Exception.

ACTIV_IP_API void Activ::UdpSocket::SetUnicastTtl ( const int ttl )

Set TTL to be used for unicasting.

Parameters:
ttl the TTL.
Exceptions:
Exception.

ACTIV_IP_API bool Activ::UdpSocket::Shutdown ( const bool gracefully = false )

Shutdown the socket.

Parameters:
gracefully true to only close the socket once any outstanding tx has completed, false to force the socket closed immediately.
Return values:
true | the socket is fully closed.
false | a close event will be fired when the socket is fully closed (OnShutdown()).

static ACTIV_IP_API std::string Activ::UdpSocket::StateToString ( const State state ) [static]

Return state as string.

Returns:
Socket state in string form.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivIp/Windows/UdpSocket.h
Generated on Wed Oct 8 14:02:01 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::UdpSocket::Settings

Activ::UdpSocket::Settings Class Reference

Settings. More...

#include <ActivMiddleware/ActivIp/Windows/UdpSocket.h>

Inheritance diagram for Activ::UdpSocket::Settings:

Activ::IpSocket::Settings

List of all members.

Public Member Functions

ACTIV_IP_API Settings (const bool shouldCork=false)
Constructor.

Detailed Description

Settings.

Definition at line 44 of file UdpSocket.h.

Constructor & Destructor Documentation

ACTIV_IP_API Activ::UdpSocket::Settings::Settings ( const bool shouldCork = false )

Constructor.

Parameters:
shouldCork set TCP_CORK, if available, whilst in tx loop.

Reimplemented from Activ::IpSocket::Settings.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivIp/Windows/UdpSocket.h
Generated on Wed Oct 8 14:02:01 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::UdpSocket::Stats

Activ::UdpSocket::Stats Class Reference

Stats. More...

#include <ActivMiddleware/ActivIp/Windows/UdpSocket.h>

Inheritance diagram for Activ::UdpSocket::Stats:

Activ::IpSocket::Stats

List of all members.

Public Member Functions

ACTIV_IP_API Stats (const UdpSocket &socket)
Constructor.

Public Attributes

State m_state
Udp socket state.

Detailed Description

Stats.

Definition at line 58 of file UdpSocket.h.

Constructor & Destructor Documentation

ACTIV_IP_API Activ::UdpSocket::Stats::Stats ( const UdpSocket & socket )

Constructor.

Note if constructing a Stats object directly, you the socket's mutex must be locked (this isn't done by the Stats constructor). Alternatively, use the helper function IpSocket::Stats::Get() which will lock the mutex for you before gathering the stats.

Parameters:
socket to get stats from.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivIp/Windows/UdpSocket.h
Generated on Wed Oct 8 14:02:01 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::UiComponent

Activ::UiComponent Class Reference

Ui component class. More...

#include <ActivMiddleware/ActivFramework/UiComponent.h>

Inheritance diagram for Activ::UiComponent:

Activ::Component Activ::Port Activ::UiMainComponent

List of all members.

Public Types

enum | Type { TYPE_DEFAULT, TYPE_MAIN, TYPE_MIDDLEWARE }
Ui component types. More...

Public Member Functions

ACTIV_FRAMEWORK_API const
std::string & 		GetUiServiceName () const
Get the name of the ui service this component is attached to.
virtual void | Run (UiUser &uiUser)=0
Run the component.
ACTIV_FRAMEWORK_API | UiComponent (Application &application, ManagedEndPoint &managedEndPoint, const std::string &componentName, const Type type=TYPE_DEFAULT, const std::string &uiServiceName=Application::GetUiServiceName(), IHeap *const pHeap=0)
Constructor.
ACTIV_FRAMEWORK_API | ~UiComponent ()
Destructor.

Detailed Description

Ui component class.

Note a ui component cannot be attached to the ui service endpoint.

Definition at line 28 of file UiComponent.h.

Member Enumeration Documentation

enum Activ::UiComponent::Type

Ui component types.

Enumerator:
TYPE_DEFAULT | normal user uis
TYPE_MAIN | for main menu component
TYPE_MIDDLEWARE | for core service / middleware provided uis

Definition at line 34 of file UiComponent.h.

Constructor & Destructor Documentation

ACTIV_FRAMEWORK_API Activ::UiComponent::UiComponent | ( | Application & | application,
 |  | ManagedEndPoint & | managedEndPoint,
 |  | const std::string & | componentName,
 |  | const Type | type = TYPE_DEFAULT,
 |  | const std::string & | uiServiceName = Application::GetUiServiceName(),
 |  | IHeap *const | pHeap = 0
 | ) |  |

Constructor.

Parameters:
application | application to attach to.
managedEndPoint | endpoint to attach to - must be singly threaded.
componentName | name of the ui component. This name is used to register the component with the main menu.
type | the type to register as.
uiServiceName | name of the ui service.
pHeap | heap to use for this component, or 0 for the service's heap
Exceptions:
Exception.

Member Function Documentation

ACTIV_FRAMEWORK_API const std::string& Activ::UiComponent::GetUiServiceName ( ) const

Get the name of the ui service this component is attached to.

Returns:
Ui service name.

virtual void Activ::UiComponent::Run ( UiUser & uiUser ) [pure virtual]

Run the component.

An override of this function must construct a menu using uiUser, and call Run() on the menu object.

Parameters:
uiUser the user wishing to communicate with this component.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivFramework/UiComponent.h
Generated on Wed Oct 8 14:02:01 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::UiIo

Activ::UiIo Class Reference

Ui io class. Provides methods to get input from and post input to a user. More...

#include <ActivMiddleware/ActivFramework/UiIo.h>

List of all members.

Public Types

typedef std::vector
< CompletionList::const_iterator > 		CompletionIteratorList
typedef std::map< std::string,
std::string > 		CompletionList

Public Member Functions

ACTIV_FRAMEWORK_API StatusCode | EnableDisable (const std::string &prompt, bool &option, const bool positiveDefault=false, const TimeoutPeriod timeout=ACTIV_WAIT_INFINITE) const
Toggle a boolean.
ACTIV_FRAMEWORK_API StatusCode | GetAddress (const std::string &prompt, Address &address, const bool isInitializedWithDefault=false, const TimeoutPeriod timeout=ACTIV_WAIT_INFINITE) const
Get a system address.
ACTIV_FRAMEWORK_API StatusCode | GetChar (const std::string &prompt, const std::string &validChars, char &ch, const bool isInitializedWithDefault=false, const TimeoutPeriod timeout=ACTIV_WAIT_INFINITE) const
Get a character and validate that it is present in the valid character string.
ACTIV_FRAMEWORK_API StatusCode | GetChar (const std::string &prompt, char &ch, const bool isInitializedWithDefault=false, const TimeoutPeriod timeout=ACTIV_WAIT_INFINITE) const
Get a character.
ACTIV_FRAMEWORK_API StatusCode | GetConfirmation (const std::string &prompt, const bool positiveDefault=false, const TimeoutPeriod timeout=ACTIV_WAIT_INFINITE) const
Get confirmation (Y/y or N/n) from user.
template<typename T>
ACTIV_FRAMEWORK_API StatusCode | GetFieldType (const std::string &prompt, T &value, const bool isInitializedWithDefault=false, const TimeoutPeriod timeout=ACTIV_WAIT_INFINITE) const
Get a field type of a given type.
ACTIV_FRAMEWORK_API StatusCode | GetFileName (const std::string &prompt, std::string &fileName, const bool isInitializedWithDefault=false, const TimeoutPeriod timeout=ACTIV_WAIT_INFINITE) const
Get a filename from the user with tab-completion.
ACTIV_FRAMEWORK_API StatusCode | GetIpAddress (const std::string &prompt, IpAddress &ipAddress, const bool isInitializedWithDefault=false, const TimeoutPeriod timeout=ACTIV_WAIT_INFINITE) const
Get ip address.
ACTIV_FRAMEWORK_API StatusCode | GetRandomConfirmation (const std::string &prompt, const TimeoutPeriod timeout=ACTIV_WAIT_INFINITE) const
Get confirmation. The user needs to enter a random confirmation response.
template<typename T>
ACTIV_FRAMEWORK_API StatusCode | GetSignedIntegral (const std::string &prompt, const int64_t lower, const int64_t upper, T &value, const bool isInitializedWithDefault=false, const TimeoutPeriod timeout=ACTIV_WAIT_INFINITE) const
Get a signed integral of a given type within a range.
template<typename T>
ACTIV_FRAMEWORK_API StatusCode | GetSignedIntegral (const std::string &prompt, T &value, const bool isInitializedWithDefault=false, const TimeoutPeriod timeout=ACTIV_WAIT_INFINITE) const
Get a signed integral of a given type.
ACTIV_FRAMEWORK_API StatusCode | GetString (const std::string &prompt, const byte_t lower, const byte_t upper, std::string &str, const bool isInitializedWithDefault=false, const TimeoutPeriod timeout=ACTIV_WAIT_INFINITE) const
Get a string within bounds.
ACTIV_FRAMEWORK_API StatusCode | GetString (const std::string &prompt, CompletionHelper &completionHelper, std::string &str, const bool isInitializedWithDefault=false, const TimeoutPeriod timeout=ACTIV_WAIT_INFINITE) const
Get a string with tab-completion.
ACTIV_FRAMEWORK_API StatusCode | GetString (const std::string &prompt, std::string &str, const bool isInitializedWithDefault=false, const TimeoutPeriod timeout=ACTIV_WAIT_INFINITE) const
Get a string.
ACTIV_FRAMEWORK_API const Address & | GetUiUserAddress () const
Get address of UiUser.
template<typename T>
ACTIV_FRAMEWORK_API StatusCode | GetUnsignedIntegral (const std::string &prompt, const uint64_t lower, const uint64_t upper, T &value, const bool isInitializedWithDefault=false, const TimeoutPeriod timeout=ACTIV_WAIT_INFINITE) const
Get an unsigned integral of a given type within a range.
template<typename T>
ACTIV_FRAMEWORK_API StatusCode | GetUnsignedIntegral (const std::string &prompt, T &value, const bool isInitializedWithDefault=false, const TimeoutPeriod timeout=ACTIV_WAIT_INFINITE) const
Get an unsigned integral of a given type.
ACTIV_FRAMEWORK_API void | GetWindowSize (ConsoleWindow::Coord &windowSize) const
Get the terminal window size.
ACTIV_FRAMEWORK_API StatusCode | PutString (const char *const format,...) const
Put a variable argument string.
ACTIV_FRAMEWORK_API StatusCode | PutString (const boost::format &formatter) const
Put a string from a boost format object.
ACTIV_FRAMEWORK_API StatusCode | PutString (const std::string &str) const
Put a string.
ACTIV_FRAMEWORK_API StatusCode | PutStringList (const std::vector< std::string > &stringList, const size_t numberOfLeadingSpaces) const
Put a list of strings.
ACTIV_FRAMEWORK_API StatusCode | PutStringV (const char *const format, std::va_list args) const
Put a variable argument string.

Static Public Attributes

static ACTIV_FRAMEWORK_API
const Attribute 		BlackBg
static ACTIV_FRAMEWORK_API
const Attribute 		BlackFg
static ACTIV_FRAMEWORK_API
const Attribute 		Blink
static ACTIV_FRAMEWORK_API
const Attribute 		BlueBg
static ACTIV_FRAMEWORK_API
const Attribute 		BlueFg
static ACTIV_FRAMEWORK_API
const Attribute 		Bold
static ACTIV_FRAMEWORK_API
const Attribute 		Concealed
static ACTIV_FRAMEWORK_API
const Attribute 		CyanBg
static ACTIV_FRAMEWORK_API
const Attribute 		CyanFg
static ACTIV_FRAMEWORK_API
const Attribute 		GreenBg
static ACTIV_FRAMEWORK_API
const Attribute 		GreenFg
static ACTIV_FRAMEWORK_API
const Attribute 		MagentaBg
static ACTIV_FRAMEWORK_API
const Attribute 		MagentaFg
static ACTIV_FRAMEWORK_API
const Attribute 		Normal
static ACTIV_FRAMEWORK_API
const Attribute 		RedBg
static ACTIV_FRAMEWORK_API
const Attribute 		RedFg
static ACTIV_FRAMEWORK_API
const Attribute 		Reverse
static ACTIV_FRAMEWORK_API
const Attribute 		Underscore
static ACTIV_FRAMEWORK_API
const Attribute 		WhiteBg
static ACTIV_FRAMEWORK_API
const Attribute 		WhiteFg
static ACTIV_FRAMEWORK_API
const Attribute 		YellowBg
static ACTIV_FRAMEWORK_API
const Attribute 		YellowFg

Friends

class | UiMainComponent
main component needs access to user
class | UiMenu
allow UiMenu to construct UiIo objects

Classes

class | Attribute
ANSI display attribute wrapper. More...
class | Columnizer
Helper class to calculate the column sizes to display a number of items. More...
class | CompletionHelper
Base class to handle tab-completion in the ui. More...
class | DynamicCompletionHelper
Class to handle tab-completion with a dynamic list of strings that may be different each time tab is hit. More...
class | StaticCompletionHelper
Class to handle tab-completion with a fixed list of strings. More...

Detailed Description

Ui io class. Provides methods to get input from and post input to a user.

Definition at line 33 of file UiIo.h.

Member Function Documentation

ACTIV_FRAMEWORK_API StatusCode Activ::UiIo::EnableDisable | ( | const std::string & | prompt,
 |  | bool & | option,
 |  | const bool | positiveDefault = false,
 |  | const TimeoutPeriod | timeout = ACTIV_WAIT_INFINITE |
 | ) |  |  | const

Toggle a boolean.

Parameters:
prompt | the prompt to display. Pass empty string to display default prompt.
option | reference to a boolean to be toggled.
positiveDefault | should the default be positive ('y') or negative ('n')?
timeout | how long to wait for input, in ms.
Return values:
STATUS_CODE_SUCCESS | user changed the value of option
STATUS_CODE_FAILURE | user did not change the value of option
STATUS_CODE_TIMEOUT

ACTIV_FRAMEWORK_API StatusCode Activ::UiIo::GetAddress | ( | const std::string & | prompt,
 |  | Address & | address,
 |  | const bool | isInitializedWithDefault = false,
 |  | const TimeoutPeriod | timeout = ACTIV_WAIT_INFINITE |
 | ) |  |  | const

Get a system address.

Parameters:
prompt | the prompt to display. Pass empty string to display no prompt.
address | the address to read into, or the already initialized default.
isInitializedWithDefault | whether the address is initialized with a default.
timeout | how long to wait for input, in ms.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_FAILURE
STATUS_CODE_UNCHANGED
STATUS_CODE_TIMEOUT

ACTIV_FRAMEWORK_API StatusCode Activ::UiIo::GetChar | ( | const std::string & | prompt,
 |  | const std::string & | validChars,
 |  | char & | ch,
 |  | const bool | isInitializedWithDefault = false,
 |  | const TimeoutPeriod | timeout = ACTIV_WAIT_INFINITE |
 | ) |  |  | const

Get a character and validate that it is present in the valid character string.

Parameters:
prompt | the prompt to display. Pass empty string to display no prompt.
validChars | a string containing the valid characters.
ch | the character to read into, or the already initialized default.
isInitializedWithDefault | whether the character is initialized with a default.
timeout | how long to wait for input, in ms.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_FAILURE
STATUS_CODE_UNCHANGED
STATUS_CODE_TIMEOUT

ACTIV_FRAMEWORK_API StatusCode Activ::UiIo::GetChar | ( | const std::string & | prompt,
 |  | char & | ch,
 |  | const bool | isInitializedWithDefault = false,
 |  | const TimeoutPeriod | timeout = ACTIV_WAIT_INFINITE |
 | ) |  |  | const

Get a character.

Parameters:
prompt | the prompt to display. Pass empty string to display no prompt.
ch | the character to read into, or the already initialized default.
isInitializedWithDefault | whether the character is initialized with a default.
timeout | how long to wait for input, in ms.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_FAILURE
STATUS_CODE_UNCHANGED
STATUS_CODE_TIMEOUT

ACTIV_FRAMEWORK_API StatusCode Activ::UiIo::GetConfirmation | ( | const std::string & | prompt,
 |  | const bool | positiveDefault = false,
 |  | const TimeoutPeriod | timeout = ACTIV_WAIT_INFINITE |
 | ) |  |  | const

Get confirmation (Y/y or N/n) from user.

Parameters:
prompt | the prompt to display. Pass empty string to display default prompt.
positiveDefault | should the default be positive ('y') or negative ('n')?
timeout | how long to wait for input, in ms.
Return values:
STATUS_CODE_SUCCESS | user entered 'y', 'Y'
STATUS_CODE_FAILURE | user entered 'n', 'N'
STATUS_CODE_TIMEOUT

template<typename T>
ACTIV_FRAMEWORK_API StatusCode Activ::UiIo::GetFieldType | ( | const std::string & | prompt,
 |  | T & | value,
 |  | const bool | isInitializedWithDefault = false,
 |  | const TimeoutPeriod | timeout = ACTIV_WAIT_INFINITE |
 | ) |  |  | const [inline]

Get a field type of a given type.

Parameters:
prompt | the prompt to display. Pass empty string to display no prompt.
value | the value to read into, or the already initialized default.
isInitializedWithDefault | whether the value is initialized with a default.
timeout | how long to wait for input, in ms.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_FAILURE
STATUS_CODE_UNCHANGED
STATUS_CODE_TIMEOUT

ACTIV_FRAMEWORK_API StatusCode Activ::UiIo::GetFileName | ( | const std::string & | prompt,
 |  | std::string & | fileName,
 |  | const bool | isInitializedWithDefault = false,
 |  | const TimeoutPeriod | timeout = ACTIV_WAIT_INFINITE |
 | ) |  |  | const

Get a filename from the user with tab-completion.

Note although tab-completion support is provided, the user can still enter a filename that doesn't exist.

Parameters:
prompt | the prompt to display. Pass empty string to display no prompt.
fileName | the string to put the filename into, or the already initialized default.
isInitializedWithDefault | whether fileName is initialized with a default.
timeout | how long to wait for input, in ms.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_FAILURE
STATUS_CODE_UNCHANGED
STATUS_CODE_TIMEOUT

ACTIV_FRAMEWORK_API StatusCode Activ::UiIo::GetIpAddress | ( | const std::string & | prompt,
 |  | IpAddress & | ipAddress,
 |  | const bool | isInitializedWithDefault = false,
 |  | const TimeoutPeriod | timeout = ACTIV_WAIT_INFINITE |
 | ) |  |  | const

Get ip address.

Parameters:
prompt | the prompt to display. Pass empty string to display no prompt.
ipAddress | the address to read into, or the already initialized default.
isInitializedWithDefault | whether the address is initialized with a default.
timeout | how long to wait for input, in ms.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_FAILURE
STATUS_CODE_UNCHANGED
STATUS_CODE_TIMEOUT

ACTIV_FRAMEWORK_API StatusCode Activ::UiIo::GetRandomConfirmation | ( | const std::string & | prompt,
 |  | const TimeoutPeriod | timeout = ACTIV_WAIT_INFINITE |
 | ) |  |  | const

Get confirmation. The user needs to enter a random confirmation response.

Parameters:
prompt | the prompt to display. Pass empty string to display default prompt.
timeout | how long to wait for input, in ms.
Return values:
STATUS_CODE_SUCCESS user confirmed
STATUS_CODE_FAILURE
STATUS_CODE_TIMEOUT

template<typename T>
ACTIV_FRAMEWORK_API StatusCode Activ::UiIo::GetSignedIntegral | ( | const std::string & | prompt,
 |  | const int64_t | lower,
 |  | const int64_t | upper,
 |  | T & | value,
 |  | const bool | isInitializedWithDefault = false,
 |  | const TimeoutPeriod | timeout = ACTIV_WAIT_INFINITE |
 | ) |  |  | const [inline]

Get a signed integral of a given type within a range.

Parameters:
prompt | the prompt to display. Pass empty string to display no prompt.
lower | the lower bound value.
upper | the upper bound value.
value | the value to read into, or the already initialized default.
isInitializedWithDefault | whether the value is initialized with a default.
timeout | how long to wait for input, in ms.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_FAILURE
STATUS_CODE_UNCHANGED
STATUS_CODE_TIMEOUT

template<typename T>
ACTIV_FRAMEWORK_API StatusCode Activ::UiIo::GetSignedIntegral | ( | const std::string & | prompt,
 |  | T & | value,
 |  | const bool | isInitializedWithDefault = false,
 |  | const TimeoutPeriod | timeout = ACTIV_WAIT_INFINITE |
 | ) |  |  | const [inline]

Get a signed integral of a given type.

Parameters:
prompt | the prompt to display. Pass empty string to display no prompt.
value | the value to read into, or the already initialized default.
isInitializedWithDefault | whether the value is initialized with a default.
timeout | how long to wait for input, in ms.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_FAILURE
STATUS_CODE_UNCHANGED
STATUS_CODE_TIMEOUT

ACTIV_FRAMEWORK_API StatusCode Activ::UiIo::GetString | ( | const std::string & | prompt,
 |  | const byte_t | lower,
 |  | const byte_t | upper,
 |  | std::string & | str,
 |  | const bool | isInitializedWithDefault = false,
 |  | const TimeoutPeriod | timeout = ACTIV_WAIT_INFINITE |
 | ) |  |  | const

Get a string within bounds.

Parameters:
prompt | the prompt to display. Pass empty string to display no prompt.
lower | the lower bound value.
upper | the upper bound value.
str | the string to read into, or the already initialized default.
isInitializedWithDefault | whether the string is initialized with a default.
timeout | how long to wait for input, in ms.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_FAILURE
STATUS_CODE_UNCHANGED
STATUS_CODE_TIMEOUT

ACTIV_FRAMEWORK_API StatusCode Activ::UiIo::GetString | ( | const std::string & | prompt,
 |  | CompletionHelper & | completionHelper,
 |  | std::string & | str,
 |  | const bool | isInitializedWithDefault = false,
 |  | const TimeoutPeriod | timeout = ACTIV_WAIT_INFINITE |
 | ) |  |  | const

Get a string with tab-completion.

Parameters:
prompt | the prompt to display. Pass empty string to display no prompt.
completionHelper | reference to a CompletionHelper object to handle tab-completion.
str | the string to read into, or the already initialized default.
isInitializedWithDefault | whether the string is initialized with a default.
timeout | how long to wait for input, in ms.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_FAILURE
STATUS_CODE_UNCHANGED
STATUS_CODE_TIMEOUT

ACTIV_FRAMEWORK_API StatusCode Activ::UiIo::GetString | ( | const std::string & | prompt,
 |  | std::string & | str,
 |  | const bool | isInitializedWithDefault = false,
 |  | const TimeoutPeriod | timeout = ACTIV_WAIT_INFINITE |
 | ) |  |  | const

Get a string.

Parameters:
prompt | the prompt to display. Pass empty string to display no prompt.
str | the string to read into, or the already initialized default.
isInitializedWithDefault | whether the string is initialized with a default.
timeout | how long to wait for input, in ms.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_FAILURE
STATUS_CODE_UNCHANGED
STATUS_CODE_TIMEOUT

ACTIV_FRAMEWORK_API const Address& Activ::UiIo::GetUiUserAddress ( ) const

Get address of UiUser.

Returns:
UiUser address.

template<typename T>
ACTIV_FRAMEWORK_API StatusCode Activ::UiIo::GetUnsignedIntegral | ( | const std::string & | prompt,
 |  | const uint64_t | lower,
 |  | const uint64_t | upper,
 |  | T & | value,
 |  | const bool | isInitializedWithDefault = false,
 |  | const TimeoutPeriod | timeout = ACTIV_WAIT_INFINITE |
 | ) |  |  | const [inline]

Get an unsigned integral of a given type within a range.

Parameters:
prompt | the prompt to display. Pass empty string to display no prompt.
lower | the lower bound value.
upper | the upper bound value.
value | the value to read into, or the already initialized default.
isInitializedWithDefault | whether the value is initialized with a default.
timeout | how long to wait for input, in ms.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_FAILURE
STATUS_CODE_UNCHANGED
STATUS_CODE_TIMEOUT

template<typename T>
ACTIV_FRAMEWORK_API StatusCode Activ::UiIo::GetUnsignedIntegral | ( | const std::string & | prompt,
 |  | T & | value,
 |  | const bool | isInitializedWithDefault = false,
 |  | const TimeoutPeriod | timeout = ACTIV_WAIT_INFINITE |
 | ) |  |  | const [inline]

Get an unsigned integral of a given type.

Parameters:
prompt | the prompt to display. Pass empty string to display no prompt.
value | the value to read into, or the already initialized default.
isInitializedWithDefault | whether the value is initialized with a default.
timeout | how long to wait for input, in ms.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_FAILURE
STATUS_CODE_UNCHANGED
STATUS_CODE_TIMEOUT

ACTIV_FRAMEWORK_API void Activ::UiIo::GetWindowSize ( ConsoleWindow::Coord & windowSize ) const

Get the terminal window size.

Note if either window size dimension is unknown, it will be set to 0.

Parameters:
windowSize to receive the terminal window size (in characters).

ACTIV_FRAMEWORK_API StatusCode Activ::UiIo::PutString | ( | const char *const | format,
 |  |  | ... |
 | ) |  |  | const

Put a variable argument string.

Parameters:
format printf style format string.
... variable arguments to write.
Return values:
STATUS_CODE_SUCCESS.
...

ACTIV_FRAMEWORK_API StatusCode Activ::UiIo::PutString ( const boost::format & formatter ) const

Put a string from a boost format object.

Parameters:
formatter boost formatter object to create the string from.
Return values:
STATUS_CODE_SUCCESS.
...

ACTIV_FRAMEWORK_API StatusCode Activ::UiIo::PutString ( const std::string & str ) const

Put a string.

Parameters:
str the string to write.
Return values:
STATUS_CODE_SUCCESS.
...

ACTIV_FRAMEWORK_API StatusCode Activ::UiIo::PutStringList | ( | const std::vector< std::string > & | stringList,
 |  | const size_t | numberOfLeadingSpaces |
 | ) |  |  | const

Put a list of strings.

Will display in columns if possible given the size of the display.

Parameters:
stringList | the list of strings to display.
numberOfLeadingSpaces | number blank spaces to put at the front of each line.
Return values:
STATUS_CODE_SUCCESS.
...

ACTIV_FRAMEWORK_API StatusCode Activ::UiIo::PutStringV | ( | const char *const | format,
 |  | std::va_list | args |
 | ) |  |  | const

Put a variable argument string.

Parameters:
format | printf style format string.
args | variable arguments to write.
Return values:
STATUS_CODE_SUCCESS.
...

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivFramework/UiIo.h
Generated on Wed Oct 8 14:02:01 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::UiIo::Attribute

Activ::UiIo::Attribute Class Reference

ANSI display attribute wrapper. More...

#include <ActivMiddleware/ActivFramework/UiIo.h>

List of all members.

Public Member Functions

ACTIV_FRAMEWORK_API | operator std::string () const
Cast to std::string operator.
ACTIV_FRAMEWORK_API Attribute & | operator| (const Attribute &attribute)
Or operator.
ACTIV_FRAMEWORK_API Attribute | operator| (const Attribute &attribute) const
Or operator.
ACTIV_FRAMEWORK_API std::string | ToString () const
Create ANSI control sequence.

Friends

class | UiIo

Detailed Description

ANSI display attribute wrapper.

Definition at line 161 of file UiIo.h.

Member Function Documentation

ACTIV_FRAMEWORK_API Activ::UiIo::Attribute::operator std::string ( ) const

Cast to std::string operator.

Returns:
String containing the ANSI control sequence for the set of attributes represented by this object.

ACTIV_FRAMEWORK_API Attribute& Activ::UiIo::Attribute::operator| ( const Attribute & attribute )

Or operator.

Parameters:
attribute reference to an Attribute to or with this object.
Returns:
*this having been orred with attribute.

ACTIV_FRAMEWORK_API Attribute Activ::UiIo::Attribute::operator| ( const Attribute & attribute ) const

Or operator.

Parameters:
attribute reference to an Attribute to or with this object.
Returns:
Attribute object that is (*this | attribute).

ACTIV_FRAMEWORK_API std::string Activ::UiIo::Attribute::ToString ( ) const

Create ANSI control sequence.

Returns:
String containing the ANSI control sequence for the set of attributes represented by this object.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivFramework/UiIo.h
Generated on Wed Oct 8 14:02:01 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::UiIo::Columnizer

Activ::UiIo::Columnizer Class Reference

Helper class to calculate the column sizes to display a number of items. More...

#include <ActivMiddleware/ActivFramework/UiIo.h>

List of all members.

Public Member Functions

ACTIV_FRAMEWORK_API | Columnizer (const UiIo &uiIo, const size_t numberOfLeadingSpaces, const size_t numberOfItems, const size_t longestItemWidth)
Constructor.

Public Attributes

size_t | m_columnSpacing
number of spaces between columns
size_t | m_numberOfColumns
number of columns required
size_t | m_numberOfLines
number of lines required

Detailed Description

Helper class to calculate the column sizes to display a number of items.

Definition at line 137 of file UiIo.h.

Constructor & Destructor Documentation

ACTIV_FRAMEWORK_API Activ::UiIo::Columnizer::Columnizer | ( | const UiIo & | uiIo,
 |  | const size_t | numberOfLeadingSpaces,
 |  | const size_t | numberOfItems,
 |  | const size_t | longestItemWidth
 | ) |  |

Constructor.

m_columnWidth will be set to 0 if longestItemWidth is longer than the available display size.

Parameters:
uiIo | reference to a UiIo object for the current ui session.
numberOfLeadingSpaces | number blank spaces to put at the front of each line.
numberOfItems | the number of items that are to be displayed in columns.
longestItemWidth | the width of the longest item that will be displayed.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivFramework/UiIo.h
Generated on Wed Oct 8 14:02:01 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::UiIo::CompletionHelper

Activ::UiIo::CompletionHelper Class Reference

Base class to handle tab-completion in the ui. More...

#include <ActivMiddleware/ActivFramework/UiIo.h>

Inheritance diagram for Activ::UiIo::CompletionHelper:

Activ::UiIo::DynamicCompletionHelper Activ::UiIo::StaticCompletionHelper

List of all members.

Public Member Functions

ACTIV_FRAMEWORK_API void | AddCompletion (const std::string &completion)
Add a string to the list of possible completions.
ACTIV_FRAMEWORK_API | CompletionHelper (const bool isCaseSensitive)
Constructor.
virtual ACTIV_FRAMEWORK_API | ~CompletionHelper ()
Destructor.

Friends

class | DynamicCompletionHelper
class | StaticCompletionHelper
class | UiIo

Detailed Description

Base class to handle tab-completion in the ui.

You probably won't need to use this class directly - instead see StaticCompletionHelper and DynamicCompletionHelper. Tab-completion is available via a UiIo::GetString() overload.

Definition at line 48 of file UiIo.h.

Constructor & Destructor Documentation

ACTIV_FRAMEWORK_API Activ::UiIo::CompletionHelper::CompletionHelper ( const bool isCaseSensitive )

Constructor.

Parameters:
isCaseSensitive whether to do case-sensitive tab-completion.

Member Function Documentation

ACTIV_FRAMEWORK_API void Activ::UiIo::CompletionHelper::AddCompletion ( const std::string & completion )

Add a string to the list of possible completions.

Parameters:
completion the string to add.

Referenced by Activ::UiIo::StaticCompletionHelper::StaticCompletionHelper().

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivFramework/UiIo.h
Generated on Wed Oct 8 14:02:01 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::UiIo::DynamicCompletionHelper

Activ::UiIo::DynamicCompletionHelper Class Reference

Class to handle tab-completion with a dynamic list of strings that may be different each time tab is hit. More...

#include <ActivMiddleware/ActivFramework/UiIo.h>

Inheritance diagram for Activ::UiIo::DynamicCompletionHelper:

Activ::UiIo::CompletionHelper

List of all members.

Public Member Functions

ACTIV_FRAMEWORK_API | DynamicCompletionHelper (const bool isCaseSensitive)
Constructor.

Protected Member Functions

virtual void | OnPopulateCompletionList (const std::string &partialInput)=0
Callback to populate list of possible completions from partial user input.

Detailed Description

Class to handle tab-completion with a dynamic list of strings that may be different each time tab is hit.

Definition at line 110 of file UiIo.h.

Constructor & Destructor Documentation

ACTIV_FRAMEWORK_API Activ::UiIo::DynamicCompletionHelper::DynamicCompletionHelper ( const bool isCaseSensitive )

Constructor.

Parameters:
isCaseSensitive whether to do case-sensitive tab-completion.

Member Function Documentation

virtual void Activ::UiIo::DynamicCompletionHelper::OnPopulateCompletionList ( const std::string & partialInput ) [protected, pure virtual]

Callback to populate list of possible completions from partial user input.

Override this to set the possible completions (via AddCompletion()) when the user hits tab.

Parameters:
partialInput the user's partial input at the moment tab was hit.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivFramework/UiIo.h
Generated on Wed Oct 8 14:02:01 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::UiIo::StaticCompletionHelper

Activ::UiIo::StaticCompletionHelper Class Reference

Class to handle tab-completion with a fixed list of strings. More...

#include <ActivMiddleware/ActivFramework/UiIo.h>

Inheritance diagram for Activ::UiIo::StaticCompletionHelper:

Activ::UiIo::CompletionHelper

List of all members.

Public Member Functions

template<typename T>
StaticCompletionHelper (const T &begin, const T &end, const bool isCaseSensitive)
Constructor.

Detailed Description

Class to handle tab-completion with a fixed list of strings.

Definition at line 90 of file UiIo.h.

Constructor & Destructor Documentation

template<typename T>
Activ::UiIo::StaticCompletionHelper::StaticCompletionHelper | ( | const T & | begin,
 |  | const T & | end,
 |  | const bool | isCaseSensitive |
 | ) |  |  | [inline]

Constructor.

Parameters:
begin | iterator to the first string in a range of all possible completions.
end | iterator to beyond the last string in a range of all possible completions.
isCaseSensitive | whether to do case-sensitive tab-completion.

Definition at line 613 of file UiIo.h.

References Activ::UiIo::CompletionHelper::AddCompletion().

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivFramework/UiIo.h
Generated on Wed Oct 8 14:02:01 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::UiMainComponent

Activ::UiMainComponent Class Reference

Main ui component. More...

#include <ActivMiddleware/ActivFramework/UiMainComponent.h>

Inheritance diagram for Activ::UiMainComponent:

Activ::UiComponent Activ::Component Activ::Port

List of all members.

Public Member Functions

ACTIV_FRAMEWORK_API StatusCode | OnOption (const UiIo &uiIo, const std::string &optionString)
User has entered an option.
ACTIV_FRAMEWORK_API void | UiDisplayAvailableUiComponentsByType (const UiIo &uiIo, const Type type) const
Menu option to display list of available ui components.
ACTIV_FRAMEWORK_API | UiMainComponent (Application &application, ManagedEndPoint &managedEndPoint, const std::string &uiComponentName, const std::string &uiServiceName)
Constructor.
ACTIV_FRAMEWORK_API | ~UiMainComponent ()
Destructor.

Classes

class | Menu
Main menu. More...

Detailed Description

Main ui component.

The main ui component acts as the main, or master, menu of a ui service (the first menu clients will see). It also maintains a list of other ui components in the system that can be communicated with.

Definition at line 32 of file UiMainComponent.h.

Constructor & Destructor Documentation

ACTIV_FRAMEWORK_API Activ::UiMainComponent::UiMainComponent | ( | Application & | application,
 |  | ManagedEndPoint & | managedEndPoint,
 |  | const std::string & | uiComponentName,
 |  | const std::string & | uiServiceName
 | ) |  |

Constructor.

Parameters:
application | application to attach to.
managedEndPoint | endpoint to attach to - must be singly threaded.
uiComponentName | name of the ui component. This name is used to register the component with the main menu.
uiServiceName | name of the ui service.
Exceptions:
Exception.

Member Function Documentation

ACTIV_FRAMEWORK_API StatusCode Activ::UiMainComponent::OnOption | ( | const UiIo & | uiIo,
 |  | const std::string & | optionString
 | ) |  |

User has entered an option.

Parameters:
uiIo | to read / write to / from the user.
optionString | the option string.

ACTIV_FRAMEWORK_API void Activ::UiMainComponent::UiDisplayAvailableUiComponentsByType | ( | const UiIo & | uiIo,
 |  | const Type | type |
 | ) |  |  | const

Menu option to display list of available ui components.

Parameters:
uiIo | to read / write to / from the user.
type | type of ui component to display.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivFramework/UiMainComponent.h
Generated on Wed Oct 8 14:02:01 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::UiMainComponent::Menu

Activ::UiMainComponent::Menu Class Reference

Main menu. More...

#include <ActivMiddleware/ActivFramework/UiMainComponent.h>

Inheritance diagram for Activ::UiMainComponent::Menu:

Activ::UiMenu

List of all members.

Public Member Functions

ACTIV_FRAMEWORK_API Menu (UiMainComponent &uiComponent, const std::string &name, UiUser &uiUser)
Constructor.

Detailed Description

Main menu.

Definition at line 72 of file UiMainComponent.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivFramework/UiMainComponent.h
Generated on Wed Oct 8 14:02:01 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::UiMenu

Activ::UiMenu Class Reference

Ui menu class. More...

#include <ActivMiddleware/ActivFramework/UiMenu.h>

Inheritance diagram for Activ::UiMenu:

Activ::UiMainComponent::Menu

List of all members.

Public Types

typedef void(* | GlobalOptionFunction )(const UiIo &uiIo)
Global menu option function pointer type.

Public Member Functions

ACTIV_FRAMEWORK_API void | AddOption (const std::string &name, GlobalOptionFunction pFunction, const OptionAttributes &optionAttributes=OptionAttributes())
Add a global function menu option.
template<typename T>
void | AddOption (const std::string &name, T &object, void(T::*pFunction)(const UiIo &), const OptionAttributes &optionAttributes=OptionAttributes())
Add a member function menu option.
ACTIV_FRAMEWORK_API std::string | GetName () const
Get the name of the menu.
ACTIV_FRAMEWORK_API void | Run ()
Run the menu.
ACTIV_FRAMEWORK_API | UiMenu (const std::string &name, const UiIo &uiIo)
Constructor.
ACTIV_FRAMEWORK_API | UiMenu (const std::string &name, UiUser &uiUser, const bool showQuitOption=true)
Constructor.
virtual ACTIV_FRAMEWORK_API | ~UiMenu ()
Destructor.

Protected Member Functions

virtual ACTIV_FRAMEWORK_API void | DisplayFooter (const UiIo &uiIo) const
Display message after options.
virtual ACTIV_FRAMEWORK_API void | DisplayInputPrompt (const UiIo &uiIo, const std::string &prompt, const std::string &value, const bool initializedWithDefault) const
Display the prompt used when requesting input other than menu option selection.
virtual ACTIV_FRAMEWORK_API void | DisplayOption (const UiIo &uiIo, const size_t optionIndex, const std::string &name, const OptionAttributes &optionAttributes) const
Display an option.
virtual ACTIV_FRAMEWORK_API void | DisplayOptionPrompt (const UiIo &uiIo) const
Display the prompt that is used when selecting a menu option.
virtual ACTIV_FRAMEWORK_API void | DisplayTitle (const UiIo &uiIo) const
Display a menu title.
ACTIV_FRAMEWORK_API StatusCode | ProcessOption (const UiIo &uiIo, const std::string &optionString)
User has entered an option.

Friends

class | UiIo

Classes

class | GlobalOption
Global function option class.
class | Option
Option class.
class | OptionAttributes
Option attributes. More...
class | OptionTemplate
Template for member function options.

Detailed Description

Ui menu class.

Definition at line 26 of file UiMenu.h.

Constructor & Destructor Documentation

ACTIV_FRAMEWORK_API Activ::UiMenu::UiMenu | ( | const std::string & | name,
 |  | UiUser & | uiUser,
 |  | const bool | showQuitOption = true
 | ) |  |

Constructor.

Use this constructor for a top level menu.

Parameters:
name | name of the menu.
uiUser | user using this menu.
showQuitOption | show a quit option to move back to a parent menu.

ACTIV_FRAMEWORK_API Activ::UiMenu::UiMenu | ( | const std::string & | name,
 |  | const UiIo & | uiIo
 | ) |  |

Constructor.

Use this constructor for a sub-menu. Note a sub-menu always has a quit option.

Parameters:
name | name of the sub-menu.
uiIo | as passed to the menu option that is creating the sub-menu.

Member Function Documentation

ACTIV_FRAMEWORK_API void Activ::UiMenu::AddOption | ( | const std::string & | name,
 |  | GlobalOptionFunction | pFunction,
 |  | const OptionAttributes & | optionAttributes = OptionAttributes()
 | ) |  |

Add a global function menu option.

Parameters:
name | name of the menu option.
pFunction | pointer to a global function to run.
optionAttributes | optional option attributes.

template<typename T>
void Activ::UiMenu::AddOption | ( | const std::string & | name,
 |  | T & | object,
 |  | void(T::*)(const UiIo &) | pFunction,
 |  | const OptionAttributes & | optionAttributes = OptionAttributes() |
 | ) |  |  | [inline]

Add a member function menu option.

Parameters:
name | name of the menu option.
object | reference to the object the function is to be run on.
pFunction | member function in class T.
optionAttributes | optional option attributes.

Definition at line 115 of file UiMenu.h.

virtual ACTIV_FRAMEWORK_API void Activ::UiMenu::DisplayFooter ( const UiIo & uiIo ) const [protected, virtual]

Display message after options.

Parameters:
uiIo to read / write to / from the user.

virtual ACTIV_FRAMEWORK_API void Activ::UiMenu::DisplayInputPrompt | ( | const UiIo & | uiIo,
 |  | const std::string & | prompt,
 |  | const std::string & | value,
 |  | const bool | initializedWithDefault |
 | ) |  |  | const [protected, virtual]

Display the prompt used when requesting input other than menu option selection.

Default is "prompt <value>: " if initializedWithDefault, else "prompt: ". Override to change.

Parameters:
uiIo | to read / write to / from the user.
prompt | the prompt to display.
value | the default value, if initializedWithDefault.
initializedWithDefault | whether value contains a default value.

virtual ACTIV_FRAMEWORK_API void Activ::UiMenu::DisplayOption | ( | const UiIo & | uiIo,
 |  | const size_t | optionIndex,
 |  | const std::string & | name,
 |  | const OptionAttributes & | optionAttributes |
 | ) |  |  | const [protected, virtual]

Display an option.

Override this to change the format of menu option displays.

Parameters:
uiIo | to read / write to / from the user.
optionIndex | the index of the option.
name | the name of the option.
optionAttributes | attributes for this option.

virtual ACTIV_FRAMEWORK_API void Activ::UiMenu::DisplayOptionPrompt ( const UiIo & uiIo ) const [protected, virtual]

Display the prompt that is used when selecting a menu option.

Default is "# ". Override to change.

Parameters:
uiIo to read / write to / from the user.

virtual ACTIV_FRAMEWORK_API void Activ::UiMenu::DisplayTitle ( const UiIo & uiIo ) const [protected, virtual]

Display a menu title.

Default is "<name> options:". Override to change.

Parameters:
uiIo to read / write to / from the user.

ACTIV_FRAMEWORK_API std::string Activ::UiMenu::GetName ( ) const

Get the name of the menu.

Returns:
The name of the menu.

ACTIV_FRAMEWORK_API StatusCode Activ::UiMenu::ProcessOption | ( | const UiIo & | uiIo,
 |  | const std::string & | optionString |
 | ) |  |  | [protected]

User has entered an option.

Checks for quit (if the menu was constructed with a quit option), then for an unsigned integer in the range 1 ... number of options in menu, running the option if in range.

Parameters:
uiIo | to read / write to / from the user.
optionString | the entered option string.
Return values:
STATUS_CODE_SUCCESS | option has been run.
STATUS_CODE_EXIT | to leave a menu.
...

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivFramework/UiMenu.h
Generated on Wed Oct 8 14:02:01 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::UiMenu::OptionAttributes

Activ::UiMenu::OptionAttributes Class Reference

Option attributes. More...

#include <ActivMiddleware/ActivFramework/UiMenu.h>

List of all members.

Public Member Functions

ACTIV_FRAMEWORK_API | OptionAttributes (const UiPermissions &uiPermissions, const std::string &sectionName)
Constructor.
ACTIV_FRAMEWORK_API | OptionAttributes (const std::string &sectionName)
Constructor.
ACTIV_FRAMEWORK_API | OptionAttributes (const UiPermissions &uiPermissions)
Constructor.
ACTIV_FRAMEWORK_API | OptionAttributes ()
Default constructor.

Public Attributes

const std::string | m_sectionName
const UiPermissions | m_uiPermissions
the ui permissions required to use this option

Detailed Description

Option attributes.

Definition at line 32 of file UiMenu.h.

Constructor & Destructor Documentation

ACTIV_FRAMEWORK_API Activ::UiMenu::OptionAttributes::OptionAttributes ( )

Default constructor.

UiPermissions::READ, no section name.

ACTIV_FRAMEWORK_API Activ::UiMenu::OptionAttributes::OptionAttributes ( const UiPermissions & uiPermissions )

Constructor.

Parameters:
uiPermissions user permissions for the option.

ACTIV_FRAMEWORK_API Activ::UiMenu::OptionAttributes::OptionAttributes ( const std::string & sectionName )

Constructor.

Parameters:
sectionName start a new section in the menu with this name.

ACTIV_FRAMEWORK_API Activ::UiMenu::OptionAttributes::OptionAttributes | ( | const UiPermissions & | uiPermissions,
 |  | const std::string & | sectionName
 | ) |  |

Constructor.

Parameters:
uiPermissions | user permissions for the option.
sectionName | start a new section in the menu with this name.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivFramework/UiMenu.h
Generated on Wed Oct 8 14:02:01 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::UInt

Activ::UInt Class Reference

Unsigned integer class. More...

#include <ActivMiddleware/ActivFieldTypes/UInt.h>

Inheritance diagram for Activ::UInt:

Activ::IFieldType

List of all members.

Public Member Functions

ACTIV_FIELD_TYPES_API StatusCode | Add (const UInt &rhs)
Add.
virtual void | Clear ()
Clear the object.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		Compare (const void *const pRhsSerializedBody, const size_t rhsSerializedBodyLength, int &result) const
Compare.
ACTIV_FIELD_TYPES_API StatusCode | Compare (const UInt &rhs, int &result) const
Compare.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		Convert (const IFieldType *const pIFieldType)
Convert another IFieldType object to this type.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		Deserialize (MessageValidator &messageValidator, const size_t maxSerializedBodyLength)
Deserialize the object from the supplied message validator.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		DeserializeBody (const void *const pSerializedBody, const size_t serializedBodyLength)
Deserialize the object's body from the supplied data buffer.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		DeserializeLengthAndBody (MessageValidator &messageValidator, const size_t maxSerializedBodyLength=MAX_SERIALIZED_BODY_LENGTH_UNDEFINED)
Deserialize the object's length and body from the supplied message validator.
ACTIV_FIELD_TYPES_API StatusCode | Divide (const UInt &rhs)
Divide.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		FromString (MessageValidator &messageValidator)
Convert the object from a string.
uint64_t | Get () const
Get the value.
StatusCode | Get (uint64_t &value) const
Get the value.
virtual ACTIV_FIELD_TYPES_API
std::string 		GetFromStringFormat () const
Get a usage string for the format supported by FromString().
virtual size_t | GetSerializedBodyLength () const
Get the serialized length of the object's body.
virtual size_t | GetSerializedLength () const
Get the serialized length of the object.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		IsDifferent (const void *const pRhsSerializedBody, const size_t rhsSerializedBodyLength, bool &isDifferent) const
Is different.
ACTIV_FIELD_TYPES_API StatusCode | Multiply (const UInt &rhs)
Multiply.
UInt & | operator *= (const UInt &rhs)
Multiplication assignment operator.
ACTIV_FIELD_TYPES_API | operator const Rational () const
Rational conversion operator.
ACTIV_FIELD_TYPES_API | operator const SInt () const
SInt conversion operator.
bool | operator!= (const UInt &rhs) const
Inequality operator.
UInt & | operator+= (const UInt &rhs)
Addition assignment operator.
UInt & | operator-= (const UInt &rhs)
Subtraction assignment operator.
UInt & | operator/= (const UInt &rhs)
Division assignment operator.
bool | operator< (const UInt &rhs) const
Less than operator.
bool | operator<= (const UInt &rhs) const
Less than or equal to operator.
bool | operator== (const UInt &rhs) const
Equality operator.
bool | operator> (const UInt &rhs) const
Greater than operator.
bool | operator>= (const UInt &rhs) const
Greater than or equal to operator.
virtual void | Reset ()
Reset the object.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		Serialize (MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength) const
Serialize the object into the supplied message builder.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		SerializeBody (void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength) const
Serialize the object's body into the supplied data buffer.
virtual ACTIV_FIELD_TYPES_API
StatusCode 		SerializeLengthAndBody (MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength=MAX_SERIALIZED_BODY_LENGTH_UNDEFINED) const
Serialize the object's length and body into the supplied message builder.
StatusCode | Set (const uint64_t value)
Set a new value.
ACTIV_FIELD_TYPES_API StatusCode | Subtract (const UInt &rhs)
Subtract.
virtual ACTIV_FIELD_TYPES_API
std::string 		ToString () const
Convert the object to a string.
UInt (const uint64_t value)
Constructor.
UInt ()
Default constructor.
virtual | ~UInt ()
Destructor.

Static Public Member Functions

static ACTIV_FIELD_TYPES_API
StatusCode 		Compare (const void *const pLhsSerializedBody, const size_t lhsSerializedBodyLength, const void *const pRhsSerializedBody, const size_t rhsSerializedBodyLength, int &result)
Compare two objects serialized bodies.
static size_t | GetMaxSerializedBodyLength (const size_t size)
Get the maximum serialized length of the object's body.
static size_t | GetMaxSerializedLength (const size_t size)
Get the maximum serialized length of the object.
static bool | IsValidSerializedBodyLength (const size_t serializedBodyLength)
Is valid serialized body length.
static ACTIV_FIELD_TYPES_API
StatusCode 		ValidateSerializedLengthAndBody (MessageValidator &messageValidator, size_t &serializedBodyOffset, size_t &serializedBodyLength)
Validate the serialized length and body.

Static Public Attributes

static const FieldType | FIELD_TYPE = FIELD_TYPE_UINT
The field type.

Detailed Description

Unsigned integer class.

Definition at line 32 of file UInt.h.

Constructor & Destructor Documentation

Activ::UInt::UInt ( const uint64_t value ) [inline]

Constructor.

Parameters:
value the value.

Definition at line 386 of file UInt.h.

References Set().

Member Function Documentation

ACTIV_FIELD_TYPES_API StatusCode Activ::UInt::Add ( const UInt & rhs )

Add.

Parameters:
rhs the value to add to this object.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED
STATUS_CODE_OUT_OF_RANGE

Referenced by operator+=().

static ACTIV_FIELD_TYPES_API StatusCode Activ::UInt::Compare | ( | const void *const | pLhsSerializedBody,
 |  | const size_t | lhsSerializedBodyLength,
 |  | const void *const | pRhsSerializedBody,
 |  | const size_t | rhsSerializedBodyLength,
 |  | int & | result |
 | ) |  |  | [static]

Compare two objects serialized bodies.

Parameters:
pLhsSerializedBody | the buffer containing the lhs serialized version of the object's body in.
lhsSerializedBodyLength | the lhs serialized body length.
pRhsSerializedBody | the buffer containing the rhs serialized version of the object's body in.
rhsSerializedBodyLength | the rhs serialized body length.
result | the result of the comparison.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::UInt::Compare | ( | const void *const | pRhsSerializedBody,
 |  | const size_t | rhsSerializedBodyLength,
 |  | int & | result |
 | ) |  |  | const [virtual]

Compare.

Parameters:
pRhsSerializedBody | the buffer containing the rhs serialized version of the object's body in.
rhsSerializedBodyLength | the rhs serialized body length.
result | the result of the comparison.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

ACTIV_FIELD_TYPES_API StatusCode Activ::UInt::Compare | ( | const UInt & | rhs,
 |  | int & | result |
 | ) |  |  | const

Compare.

Parameters:
rhs | the object to compare with.
result | the result of the comparison.
Return values:
STATUS_CODE_SUCCESS

Referenced by operator<(), operator==(), and operator>().

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::UInt::Convert ( const IFieldType *const pIFieldType ) [virtual]

Convert another IFieldType object to this type.

Parameters:
pIFieldType the value to assign from.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_MISMATCH
...

Implements Activ::IFieldType.

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::UInt::Deserialize | ( | MessageValidator & | messageValidator,
 |  | const size_t | maxSerializedBodyLength |
 | ) |  |  | [virtual]

Deserialize the object from the supplied message validator.

Parameters:
messageValidator | the message validator from which the object will be extracted.
maxSerializedBodyLength | the maximum serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::UInt::DeserializeBody | ( | const void *const | pSerializedBody,
 |  | const size_t | serializedBodyLength |
 | ) |  |  | [virtual]

Deserialize the object's body from the supplied data buffer.

Parameters:
pSerializedBody | the buffer from which the object's body will be extracted.
serializedBodyLength | the serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::UInt::DeserializeLengthAndBody | ( | MessageValidator & | messageValidator,
 |  | const size_t | maxSerializedBodyLength = MAX_SERIALIZED_BODY_LENGTH_UNDEFINED |
 | ) |  |  | [virtual]

Deserialize the object's length and body from the supplied message validator.

Parameters:
messageValidator | the message validator from which the object will be extracted.
maxSerializedBodyLength | the maximum serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

ACTIV_FIELD_TYPES_API StatusCode Activ::UInt::Divide ( const UInt & rhs )

Divide.

Parameters:
rhs the value to divide this object by.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED
STATUS_CODE_OUT_OF_RANGE

Referenced by operator/=().

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::UInt::FromString ( MessageValidator & messageValidator ) [virtual]

Convert the object from a string.

Parameters:
messageValidator the message validator.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

uint64_t Activ::UInt::Get ( ) const [inline]

Get the value.

Returns:
the value.
Exceptions:
StatusCodeException

Definition at line 509 of file UInt.h.

References ACTIV_THROW, and Activ::IFieldType::IsInitialized().

StatusCode Activ::UInt::Get ( uint64_t & value ) const [inline]

Get the value.

Parameters:
value the value.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED

Definition at line 497 of file UInt.h.

References Activ::IFieldType::IsInitialized().

virtual ACTIV_FIELD_TYPES_API std::string Activ::UInt::GetFromStringFormat ( ) const [virtual]

Get a usage string for the format supported by FromString().

Returns:
String, may be empty.

Implements Activ::IFieldType.

size_t Activ::UInt::GetMaxSerializedBodyLength ( const size_t size ) [inline, static]

Get the maximum serialized length of the object's body.

Parameters:
size the size of the data.
Returns:
the maximum serialized length of the object's body.

Definition at line 554 of file UInt.h.

Referenced by GetMaxSerializedLength(), GetSerializedBodyLength(), and IsValidSerializedBodyLength().

size_t Activ::UInt::GetMaxSerializedLength ( const size_t size ) [inline, static]

Get the maximum serialized length of the object.

Parameters:
size the size of the data.
Returns:
the maximum serialized length of the object.

Definition at line 547 of file UInt.h.

References GetMaxSerializedBodyLength().

Referenced by GetSerializedLength().

size_t Activ::UInt::GetSerializedBodyLength ( ) const [inline, virtual]

Get the serialized length of the object's body.

Returns:
the serialized length of the object's body.

Implements Activ::IFieldType.

Definition at line 540 of file UInt.h.

References GetMaxSerializedBodyLength(), and Activ::IFieldType::IsInitialized().

size_t Activ::UInt::GetSerializedLength ( ) const [inline, virtual]

Get the serialized length of the object.

Returns:
the serialized length of the object.

Implements Activ::IFieldType.

Definition at line 533 of file UInt.h.

References GetMaxSerializedLength(), and Activ::IFieldType::IsInitialized().

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::UInt::IsDifferent | ( | const void *const | pRhsSerializedBody,
 |  | const size_t | rhsSerializedBodyLength,
 |  | bool & | isDifferent |
 | ) |  |  | const [virtual]

Is different.

Parameters:
pRhsSerializedBody | the buffer containing the rhs serialized version of the object's body in.
rhsSerializedBodyLength | the rhs serialized body length.
isDifferent | indicates whether the two objects are different.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

bool Activ::UInt::IsValidSerializedBodyLength ( const size_t serializedBodyLength ) [inline, static]

Is valid serialized body length.

Parameters:
serializedBodyLength the serialized body length.
Returns:
whether the serialized body length is valid.

Definition at line 561 of file UInt.h.

References GetMaxSerializedBodyLength().

ACTIV_FIELD_TYPES_API StatusCode Activ::UInt::Multiply ( const UInt & rhs )

Multiply.

Parameters:
rhs the value to multiply this object by.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED
STATUS_CODE_OUT_OF_RANGE

Referenced by operator *=().

UInt & Activ::UInt::operator *= ( const UInt & rhs ) [inline]

Multiplication assignment operator.

Parameters:
rhs the value to multiply this object by.
Returns:
a reference to this object.
Exceptions:
StatusCodeException

Definition at line 469 of file UInt.h.

References ACTIV_THROW_RESULT_IF, and Multiply().

ACTIV_FIELD_TYPES_API Activ::UInt::operator const Rational ( ) const

Rational conversion operator.

Exceptions:
StatusCodeException

ACTIV_FIELD_TYPES_API Activ::UInt::operator const SInt ( ) const

SInt conversion operator.

Exceptions:
StatusCodeException

bool Activ::UInt::operator!= ( const UInt & rhs ) const [inline]

Inequality operator.

Parameters:
rhs the object to compare with.
Returns:
the result of the test.
Exceptions:
StatusCodeException

Definition at line 410 of file UInt.h.

UInt & Activ::UInt::operator+= ( const UInt & rhs ) [inline]

Addition assignment operator.

Parameters:
rhs the value to add to this object.
Returns:
a reference to this object.
Exceptions:
StatusCodeException

Definition at line 451 of file UInt.h.

References ACTIV_THROW_RESULT_IF, and Add().

UInt & Activ::UInt::operator-= ( const UInt & rhs ) [inline]

Subtraction assignment operator.

Parameters:
rhs the value to subtract from this object.
Returns:
a reference to this object.
Exceptions:
StatusCodeException

Definition at line 460 of file UInt.h.

References ACTIV_THROW_RESULT_IF, and Subtract().

UInt & Activ::UInt::operator/= ( const UInt & rhs ) [inline]

Division assignment operator.

Parameters:
rhs the value to divide this object by.
Returns:
a reference to this object.
Exceptions:
StatusCodeException

Definition at line 478 of file UInt.h.

References ACTIV_THROW_RESULT_IF, and Divide().

bool Activ::UInt::operator< ( const UInt & rhs ) const [inline]

Less than operator.

Parameters:
rhs the object to compare with.
Returns:
the result of the test.
Exceptions:
StatusCodeException

Definition at line 417 of file UInt.h.

References ACTIV_THROW_RESULT_IF, and Compare().

bool Activ::UInt::operator<= ( const UInt & rhs ) const [inline]

Less than or equal to operator.

Parameters:
rhs the object to compare with.
Returns:
the result of the test.
Exceptions:
StatusCodeException

Definition at line 427 of file UInt.h.

bool Activ::UInt::operator== ( const UInt & rhs ) const [inline]

Equality operator.

Parameters:
rhs the object to compare with.
Returns:
the result of the test.
Exceptions:
StatusCodeException

Definition at line 400 of file UInt.h.

References ACTIV_THROW_RESULT_IF, and Compare().

bool Activ::UInt::operator> ( const UInt & rhs ) const [inline]

Greater than operator.

Parameters:
rhs the object to compare with.
Returns:
the result of the test.
Exceptions:
StatusCodeException

Definition at line 434 of file UInt.h.

References ACTIV_THROW_RESULT_IF, and Compare().

bool Activ::UInt::operator>= ( const UInt & rhs ) const [inline]

Greater than or equal to operator.

Parameters:
rhs the object to compare with.
Returns:
the result of the test.
Exceptions:
StatusCodeException

Definition at line 444 of file UInt.h.

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::UInt::Serialize | ( | MessageBuilder & | messageBuilder,
 |  | const size_t | maxSerializedBodyLength |
 | ) |  |  | const [virtual]

Serialize the object into the supplied message builder.

Parameters:
messageBuilder | the message builder to store a serialized version of the object in.
maxSerializedBodyLength | the maximum serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::UInt::SerializeBody | ( | void * | pSerializedBody,
 |  | const size_t | maxSerializedBodyLength,
 |  | size_t & | serializedBodyLength |
 | ) |  |  | const [virtual]

Serialize the object's body into the supplied data buffer.

Parameters:
pSerializedBody | the buffer to store a serialized version of the object's body in.
maxSerializedBodyLength | the maximum serialized body length.
serializedBodyLength | the serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

virtual ACTIV_FIELD_TYPES_API StatusCode Activ::UInt::SerializeLengthAndBody | ( | MessageBuilder & | messageBuilder,
 |  | const size_t | maxSerializedBodyLength = MAX_SERIALIZED_BODY_LENGTH_UNDEFINED |
 | ) |  |  | const [virtual]

Serialize the object's length and body into the supplied message builder.

Parameters:
messageBuilder | the message builder to store a serialized version of the object in.
maxSerializedBodyLength | the maximum serialized body length.
Return values:
STATUS_CODE_SUCCESS
...

Implements Activ::IFieldType.

StatusCode Activ::UInt::Set ( const uint64_t value ) [inline]

Set a new value.

Parameters:
value the value.
Return values:
STATUS_CODE_SUCCESS

Definition at line 487 of file UInt.h.

References Activ::IFieldType::m_isInitialized.

Referenced by UInt().

ACTIV_FIELD_TYPES_API StatusCode Activ::UInt::Subtract ( const UInt & rhs )

Subtract.

Parameters:
rhs the value to subtract from this object.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_NOT_INITIALIZED
STATUS_CODE_OUT_OF_RANGE

Referenced by operator-=().

virtual ACTIV_FIELD_TYPES_API std::string Activ::UInt::ToString ( ) const [virtual]

Convert the object to a string.

Returns:
the object as a string.

Implements Activ::IFieldType.

static ACTIV_FIELD_TYPES_API StatusCode Activ::UInt::ValidateSerializedLengthAndBody | ( | MessageValidator & | messageValidator,
 |  | size_t & | serializedBodyOffset,
 |  | size_t & | serializedBodyLength |
 | ) |  |  | [static]

Validate the serialized length and body.

Parameters:
messageValidator | the message validator.
serializedBodyOffset | the serialized body offset.
serializedBodyLength | the serialized body length.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER
...

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivFieldTypes/UInt.h
Generated on Wed Oct 8 14:02:02 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::UiPermissions

Activ::UiPermissions Class Reference

Ui permissions class. More...

#include <ActivMiddleware/ActivFramework/UiPermissions.h>

List of all members.

Public Types

typedef int32_t | Bitmap
permissions bitmap type

Public Member Functions

ACTIV_FRAMEWORK_API StatusCode | Deserialize (MessageValidator &messageValidator)
Deserialize.
ACTIV_FRAMEWORK_API StatusCode | FromString (const std::string &string)
Convert the permissions value from a string.
ACTIV_FRAMEWORK_API bool | HasPermissions (const UiPermissions &uiPermissions) const
Check the permissions meets another permissions value.
ACTIV_FRAMEWORK_API StatusCode | Serialize (MessageBuilder &messageBuilder) const
Serialize.
ACTIV_FRAMEWORK_API std::string | ToString () const
Convert the permissions value to a string.
ACTIV_FRAMEWORK_API | UiPermissions ()
Default constructor.

Static Public Attributes

static ACTIV_FRAMEWORK_API
const UiPermissions 		FULL
static ACTIV_FRAMEWORK_API
const UiPermissions 		MODIFY
static ACTIV_FRAMEWORK_API
const UiPermissions 		READ
static ACTIV_FRAMEWORK_API
const UiPermissions 		SHUTDOWN

Detailed Description

Ui permissions class.

Definition at line 20 of file UiPermissions.h.

Member Function Documentation

ACTIV_FRAMEWORK_API StatusCode Activ::UiPermissions::Deserialize ( MessageValidator & messageValidator )

Deserialize.

Parameters:
messageValidator message validator.
Return values:
STATUS_CODE_SUCCESS
...

ACTIV_FRAMEWORK_API StatusCode Activ::UiPermissions::FromString ( const std::string & string )

Convert the permissions value from a string.

Parameters:
string the string to convert from.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_FAILURE

ACTIV_FRAMEWORK_API bool Activ::UiPermissions::HasPermissions ( const UiPermissions & uiPermissions ) const

Check the permissions meets another permissions value.

Parameters:
uiPermissions to compare with.
Returns:
true if this permissions meets the other permissions value.

ACTIV_FRAMEWORK_API StatusCode Activ::UiPermissions::Serialize ( MessageBuilder & messageBuilder ) const

Serialize.

Parameters:
messageBuilder message builder.
Return values:
STATUS_CODE_SUCCESS
...

ACTIV_FRAMEWORK_API std::string Activ::UiPermissions::ToString ( ) const

Convert the permissions value to a string.

Returns:
The converted string representation.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivFramework/UiPermissions.h
Generated on Wed Oct 8 14:02:02 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Url

Activ::Url Class Reference

Url parser & builder class. More...

#include <ActivMiddleware/ActivBase/Url.h>

List of all members.

Public Types

typedef std::pair< std::string,
std::string > 		Parameter
parameter type (key, value)
typedef std::list< Parameter > | ParameterList
parameter list type

Public Member Functions

ACTIV_BASE_EXPORTED_API std::string | Build () const
Build a url from the component parts.
ACTIV_BASE_EXPORTED_API StatusCode | Parse (const std::string &url)
Parse a url into the class members.

Public Attributes

std::string | m_location
location portion of the url
ParameterList m_parameterList
parameter list portion of the url
std::string | m_path
path portion of the url
std::string | m_protocol
protocol portion of the url

Detailed Description

Url parser & builder class.

A Url is of the form protocol://location/path?parameter?parameter parameter is of the form key=value Other accepted parameter delimiters in addition to ? are , ; & Another accepted key/value delimiter is :

Definition at line 28 of file Url.h.

Member Function Documentation

ACTIV_BASE_EXPORTED_API StatusCode Activ::Url::Parse ( const std::string & url )

Parse a url into the class members.

Parameters:
url the url to parse.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_FORMAT

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivBase/Url.h
Generated on Wed Oct 8 14:02:02 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::UtcTime

Activ::UtcTime Class Reference

Utc time class. More...

#include <ActivMiddleware/ActivFramework/TimeHelper.h>

Inheritance diagram for Activ::UtcTime:

Activ::BaseTime

List of all members.

Public Member Functions

ACTIV_FRAMEWORK_API | UtcTime (const BaseTime &baseTime)
Copy constructor.
ACTIV_FRAMEWORK_API | UtcTime ()
Default constructor.

Static Public Member Functions

static ACTIV_FRAMEWORK_API UtcTime | GetCurrent ()
Get current utc time.

Detailed Description

Utc time class.

Definition at line 372 of file TimeHelper.h.

Constructor & Destructor Documentation

ACTIV_FRAMEWORK_API Activ::UtcTime::UtcTime ( const BaseTime & baseTime )

Copy constructor.

Parameters:
baseTime time to copy from (can be LocalTime or UtcTime).

Member Function Documentation

static ACTIV_FRAMEWORK_API UtcTime Activ::UtcTime::GetCurrent ( ) [static]

Get current utc time.

Returns:
UtcTime initialized with the current time.

Reimplemented from Activ::BaseTime.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivFramework/TimeHelper.h
Generated on Wed Oct 8 14:02:02 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Uuid

Activ::Uuid Class Reference

Uuid class. More...

#include <ActivMiddleware/ActivBase/Uuid.h>

List of all members.

Public Member Functions

ACTIV_BASE_EXPORTED_API StatusCode | Deserialize (MessageValidator &messageValidator)
Deserialize from a MessageValidator into this object.
ACTIV_BASE_EXPORTED_API StatusCode | GetBinary (byte_t *pBuffer, const size_t bufferSize) const
Get a binary representation of the Uuid.
ACTIV_BASE_EXPORTED_API bool | operator!= (const Uuid &rhs) const
Inequality operator.
ACTIV_BASE_EXPORTED_API bool | operator< (const Uuid &rhs) const
Less than operator.
ACTIV_BASE_EXPORTED_API bool | operator<= (const Uuid &rhs) const
Less than or equal to operator.
ACTIV_BASE_EXPORTED_API bool | operator== (const Uuid &rhs) const
Equality operator.
ACTIV_BASE_EXPORTED_API bool | operator> (const Uuid &rhs) const
Greater than operator.
ACTIV_BASE_EXPORTED_API bool | operator>= (const Uuid &rhs) const
Greater than or equal to operator.
ACTIV_BASE_EXPORTED_API StatusCode | Serialize (MessageBuilder &messageBuilder) const
Serialize to a MessageBuilder.
ACTIV_BASE_EXPORTED_API StatusCode | Set (const std::string &uuidString)
Set the value of the uuid from a string representation.
ACTIV_BASE_EXPORTED_API StatusCode | Set (const byte_t *pBuffer, const size_t bufferSize)
Set the value of the uuid from a binary representation.
ACTIV_BASE_EXPORTED_API std::string | ToString () const
Get a string representation of the Uuid.
ACTIV_BASE_EXPORTED_API | Uuid (std::string &uuidString)
Constructor that initializes the uuid from a string representation.
ACTIV_BASE_EXPORTED_API | Uuid (const byte_t *pBuffer, const size_t bufferSize)
Constructor that initializes the uuid from a binary representation.
ACTIV_BASE_EXPORTED_API | Uuid ()
Default constructor that initializes with a new uuid.

Static Public Attributes

static ACTIV_BASE_EXPORTED_API
const Uuid 		emptyUuid
Empty uuid object.
static const size_t | UUID_SIZE = 16

Detailed Description

Uuid class.

Definition at line 27 of file Uuid.h.

Constructor & Destructor Documentation

ACTIV_BASE_EXPORTED_API Activ::Uuid::Uuid ( )

Default constructor that initializes with a new uuid.

Exceptions:
Exception

ACTIV_BASE_EXPORTED_API Activ::Uuid::Uuid | ( | const byte_t * | pBuffer,
 |  | const size_t | bufferSize
 | ) |  |

Constructor that initializes the uuid from a binary representation.

Parameters:
pBuffer | buffer containing the binary representation.
bufferSize | the size of the buffer. Must be UUID_SIZE bytes.
Exceptions:
Exception

ACTIV_BASE_EXPORTED_API Activ::Uuid::Uuid ( std::string & uuidString )

Constructor that initializes the uuid from a string representation.

Parameters:
uuidString string representation of the uuid.
Exceptions:
Exception

Member Function Documentation

ACTIV_BASE_EXPORTED_API StatusCode Activ::Uuid::Deserialize ( MessageValidator & messageValidator )

Deserialize from a MessageValidator into this object.

Parameters:
messageValidator to deserialize from.
Returns:
STATUS_CODE_SUCCESS or an error code.

ACTIV_BASE_EXPORTED_API StatusCode Activ::Uuid::GetBinary | ( | byte_t * | pBuffer,
 |  | const size_t | bufferSize |
 | ) |  |  | const

Get a binary representation of the Uuid.

Parameters:
pBuffer | buffer for the binary representation.
bufferSize | the size of the buffer.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_BUFFER_OVERFLOW

ACTIV_BASE_EXPORTED_API bool Activ::Uuid::operator!= ( const Uuid & rhs ) const

Inequality operator.

Parameters:
rhs the object to compare with.
Returns:
the result of the test.
Exceptions:
BaseException

ACTIV_BASE_EXPORTED_API bool Activ::Uuid::operator< ( const Uuid & rhs ) const

Less than operator.

Parameters:
rhs the object to compare with.
Returns:
the result of the test.
Exceptions:
Exception

ACTIV_BASE_EXPORTED_API bool Activ::Uuid::operator<= ( const Uuid & rhs ) const

Less than or equal to operator.

Parameters:
rhs the object to compare with.
Returns:
the result of the test.
Exceptions:
Exception

ACTIV_BASE_EXPORTED_API bool Activ::Uuid::operator== ( const Uuid & rhs ) const

Equality operator.

Parameters:
rhs the object to compare with.
Returns:
the result of the test.

ACTIV_BASE_EXPORTED_API bool Activ::Uuid::operator> ( const Uuid & rhs ) const

Greater than operator.

Parameters:
rhs the object to compare with.
Returns:
the result of the test.
Exceptions:
Exception

ACTIV_BASE_EXPORTED_API bool Activ::Uuid::operator>= ( const Uuid & rhs ) const

Greater than or equal to operator.

Parameters:
rhs the object to compare with.
Returns:
the result of the test.
Exceptions:
Exception

ACTIV_BASE_EXPORTED_API StatusCode Activ::Uuid::Serialize ( MessageBuilder & messageBuilder ) const

Serialize to a MessageBuilder.

Parameters:
messageBuilder to serialize into.
Returns:
STATUS_CODE_SUCCESS or an error code.

ACTIV_BASE_EXPORTED_API StatusCode Activ::Uuid::Set ( const std::string & uuidString )

Set the value of the uuid from a string representation.

Parameters:
uuidString string representation of the Uuid.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER

ACTIV_BASE_EXPORTED_API StatusCode Activ::Uuid::Set | ( | const byte_t * | pBuffer,
 |  | const size_t | bufferSize
 | ) |  |

Set the value of the uuid from a binary representation.

Parameters:
pBuffer | buffer containing the binary representation.
bufferSize | the size of the buffer.
Return values:
STATUS_CODE_SUCCESS
STATUS_CODE_INVALID_PARAMETER

ACTIV_BASE_EXPORTED_API std::string Activ::Uuid::ToString ( ) const

Get a string representation of the Uuid.

Returns:
string representation of the Uuid.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivBase/Uuid.h
Generated on Wed Oct 8 14:02:02 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::WsaBufHelper

Activ::WsaBufHelper Class Reference

WSABUF helper class. More...

#include <ActivMiddleware/ActivIp/Windows/WsaBufHelper.h>

List of all members.

Public Member Functions

void | Append (void *pData, const size_t dataLength)
Append a new buffer, expand the WSABUF array if required.
WSABUF * | GetFirstBuffer () const
Get a pointer to the first WSABUF.
size_t | GetNumberOfBuffersInUse () const
Get the number of buffers in use.
size_t | GetTotalBytes () const
Get the total number of bytes in the WSABUF arary.
void | Reset ()
Reset the number of buffers in use.
WsaBufHelper (const size_t initialSize=10)
Constructor.
~WsaBufHelper ()
Destructor.

Detailed Description

WSABUF helper class.

Definition at line 23 of file WsaBufHelper.h.

Constructor & Destructor Documentation

Activ::WsaBufHelper::WsaBufHelper ( const size_t initialSize = 10 ) [inline]

Constructor.

Parameters:
initialSize the number of WSABUFs to allocate initially.
Exceptions:
Exception.

Definition at line 93 of file WsaBufHelper.h.

Member Function Documentation

void Activ::WsaBufHelper::Append | ( | void * | pData,
 |  | const size_t | dataLength |
 | ) |  |  | [inline]

Append a new buffer, expand the WSABUF array if required.

pData pointer to the data. dataLength the length of the buffer.

Exceptions:
Exception if the WSABUF couldn't be resized.

Definition at line 122 of file WsaBufHelper.h.

Referenced by Activ::IpSocket::AppendRxBuffer(), and Activ::IpSocket::AppendTxBuffer().

WSABUF * Activ::WsaBufHelper::GetFirstBuffer ( ) const [inline]

Get a pointer to the first WSABUF.

Returns:
Pointer to the first WSABUF.

Definition at line 137 of file WsaBufHelper.h.

size_t Activ::WsaBufHelper::GetNumberOfBuffersInUse ( ) const [inline]

Get the number of buffers in use.

Returns:
The number of buffers in use.

Definition at line 144 of file WsaBufHelper.h.

size_t Activ::WsaBufHelper::GetTotalBytes ( ) const [inline]

Get the total number of bytes in the WSABUF arary.

Returns:
The total number of bytes in the WSABUF array.

Definition at line 151 of file WsaBufHelper.h.

The documentation for this class was generated from the following file:
  • include/ActivMiddleware/ActivIp/Windows/WsaBufHelper.h
Generated on Wed Oct 8 14:02:02 2008 for ACTIV C++ SDK by doxygen 1.5.4


ACTIV C++ SDK Class Hierarchy

This inheritance list is sorted roughly, but not completely, alphabetically:
  • Activ::Address
  • Activ::Address::Proxy
    • Activ::ScopedAddress::Proxy
  • Activ::AtomicInteger
  • Activ::AtomicPointer< T >
  • Activ::BaseTime
    • Activ::LocalTime
    • Activ::UtcTime
  • Activ::BaseTime::Duration
  • Activ::Binary< T, N, B >
  • Activ::BitField< T, OFFSET_VALUE, LENGTH_VALUE >
  • Activ::BitField< PREVIOUS_FIELD::Bitmap, PREVIOUS_FIELD::OFFSET+PREVIOUS_FIELD::LENGTH, LENGTH_VALUE >
    • Activ::NextBitField< PREVIOUS_FIELD, LENGTH_VALUE >
  • Activ::BitField< T, 0, LENGTH_VALUE >
    • Activ::FirstBitField< T, LENGTH_VALUE >
  • Activ::CaseInsensitiveLessThanStringComparisonObject
  • Activ::CommandLineParser
  • Activ::CommandLineParserDetail::CommandLineParserImpl
  • Activ::CommandLineParserDetail::Description< T >
    • Activ::CommandLineParserDetail::DefaultDescription< T >
      • Activ::CommandLineParserDetail::OptionalParameterDescription< T >
      • Activ::CommandLineParserDetail::OptionalSwitchDescription< T >
    • Activ::CommandLineParserDetail::MandatoryParameterDescription< T >
    • Activ::CommandLineParserDetail::MandatorySwitchDescription< T >
  • Activ::CommandLineParserDetail::Description< bool >
    • Activ::CommandLineParserDetail::BooleanSwitchDescription
  • Activ::CommandLineParserDetail::DescriptionAppender
  • Activ::CommandLineParserDetail::ValueStore< T >
  • Activ::ConsoleWindow
  • Activ::ConsoleWindow::Coord
  • Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::ApiInfo
  • Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::ConnectParameters
  • Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::Settings
  • Activ::ContentPlatform::ContentGatewayApi::ContentGatewayInfo
  • Activ::ContentPlatform::ContentGatewayApi::DataPointAddress
  • Activ::ContentPlatform::ContentGatewayApi::FieldData
  • Activ::ContentPlatform::ContentGatewayApi::FieldSet
    • Activ::ContentPlatform::ContentGatewayApi::HistoryBar
    • Activ::ContentPlatform::ContentGatewayApi::IntradayBar
    • Activ::ContentPlatform::ContentGatewayApi::OptionBar
    • Activ::ContentPlatform::ContentGatewayApi::Tick
  • Activ::ContentPlatform::ContentGatewayApi::INewsResponses
    • Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
  • Activ::ContentPlatform::ContentGatewayApi::IRealtimeResponses
    • Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
  • Activ::ContentPlatform::ContentGatewayApi::ISymbolDirectoryResponses
    • Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
  • Activ::ContentPlatform::ContentGatewayApi::ITimeSeriesResponses
    • Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
  • Activ::ContentPlatform::ContentGatewayApi::MetaDataRequestHelper
  • Activ::ContentPlatform::ContentGatewayApi::NewsRequestHelper
  • Activ::ContentPlatform::ContentGatewayApi::NewsRequestParameters
  • Activ::ContentPlatform::ContentGatewayApi::NewsResponseParameters
  • Activ::ContentPlatform::ContentGatewayApi::NewsStory
  • Activ::ContentPlatform::ContentGatewayApi::NewsUpdate
  • Activ::ContentPlatform::ContentGatewayApi::NewsUpdateHelper
  • Activ::ContentPlatform::ContentGatewayApi::Period
  • Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestHelper< MESSAGE_TYPE_VALUE, REQUEST_PARAMETERS >
  • Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters
    • Activ::ContentPlatform::ContentGatewayApi::MatchRequestParameters
      • Activ::ContentPlatform::ContentGatewayApi::SymbolIdListMatchRequestParameters
      • Activ::ContentPlatform::ContentGatewayApi::SymbolIdMatchRequestParameters
    • Activ::ContentPlatform::ContentGatewayApi::PatternMatchListRequestParameters
    • Activ::ContentPlatform::ContentGatewayApi::PatternMatchRequestParameters
    • Activ::ContentPlatform::ContentGatewayApi::SymbolIdCountRequestParameters
    • Activ::ContentPlatform::ContentGatewayApi::SymbolIdListRequestParameters
    • Activ::ContentPlatform::ContentGatewayApi::SymbolIdRequestParameters
    • Activ::ContentPlatform::ContentGatewayApi::TableNumberRequestParameters
  • Activ::ContentPlatform::ContentGatewayApi::RealtimeResponseParameters
  • Activ::ContentPlatform::ContentGatewayApi::RecordUpdate
  • Activ::ContentPlatform::ContentGatewayApi::RecordUpdateHelper
  • Activ::ContentPlatform::ContentGatewayApi::RelationshipInfo
  • Activ::ContentPlatform::ContentGatewayApi::RequestBlock
  • Activ::ContentPlatform::ContentGatewayApi::ResponseBlock
  • Activ::ContentPlatform::ContentGatewayApi::SubscribeParameters
    • Activ::ContentPlatform::ContentGatewayApi::SubscribeFeedParameters
    • Activ::ContentPlatform::ContentGatewayApi::SubscribeTableParameters
  • Activ::ContentPlatform::ContentGatewayApi::SubscriptionInfo
  • Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryRequestHelper
  • Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryRequestParameters
  • Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryResponseParameters
  • Activ::ContentPlatform::ContentGatewayApi::SymbolId
  • Activ::ContentPlatform::ContentGatewayApi::SymbolResponse
  • Activ::ContentPlatform::ContentGatewayApi::TableInfo
  • Activ::ContentPlatform::ContentGatewayApi::TimeSeriesCookie
  • Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestHelper< FIRST_MESSAGE_TYPE_VALUE, NEXT_MESSAGE_TYPE_VALUE, FIELD_SET_TYPE >
  • Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestParameters
  • Activ::ContentPlatform::ContentGatewayApi::TimeSeriesResponseParametersTemplate< FIELD_SET_TYPE >
  • Activ::ContentPlatform::ContentServerApi::ContentServerClient::ApiInfo
  • Activ::ContentPlatform::ContentServerApi::ContentServerClient::MessageStats
  • Activ::ContentPlatform::ContentServerApi::ContentServerClient::Settings
  • Activ::ContentPlatform::ContentServerApi::ContentServerClient::UpdateFilter
  • Activ::ContentPlatform::ContentServerApi::ContentServerClient::UpdateFilterMap
  • Activ::ContentPlatform::ContentServerApi::RecordUpdateHelper< MESSAGE_VALIDATOR >
  • Activ::ContentPlatform::ContentServerApi::RecordUpdateHelper< Feed::BaseUpdateMessageValidator >
    • Activ::ContentPlatform::ContentServerApi::SymbolRecordUpdate
  • Activ::ContentPlatform::ContentServerApi::RecordUpdateHelper< Feed::UpdateMessageValidator >
    • Activ::ContentPlatform::ContentServerApi::RecordUpdate
  • Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::ApiInfo
  • Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::ConnectParameters
  • Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::Settings
  • Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayInfo
  • Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayResponseParameters
    • Activ::ContentPlatform::ContributionGatewayApi::PublishRecordResponseParameters
  • Activ::ContentPlatform::ContributionGatewayApi::PermissionInfo
  • Activ::ContentPlatform::ContributionGatewayApi::PublishField
    • Activ::ContentPlatform::ContributionGatewayApi::PublishSymbolRecordParameters::Field
  • Activ::ContentPlatform::ContributionGatewayApi::PublishRecordBaseParameters
    • Activ::ContentPlatform::ContributionGatewayApi::PublishRecordParameters
    • Activ::ContentPlatform::ContributionGatewayApi::PublishSymbolRecordParameters
  • Activ::ContentPlatform::ContributionGatewayApi::PublishRecordResponseParameters::FieldError
  • Activ::ContentPlatform::ContributionGatewayApi::PublishRequestHelper< MESSAGE_TYPE_VALUE, REQUEST_PARAMETERS, RESPONSE_PARAMETERS >
  • Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::ApiInfo
  • Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::RecordMessageBuilder
  • Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::Settings
  • Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::SymbolRecordMessageBuilder
  • Activ::ContentPlatform::Feed::CombinedQuoteMessageHeaderDefinitions
  • Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessage
    • Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator
  • Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderDefinitions
  • Activ::ContentPlatform::Feed::CompressedMessage
    • Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator
  • Activ::ContentPlatform::Feed::CompressedMessageDefinitions
    • Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageDefinitions
  • Activ::ContentPlatform::Feed::CompressedMessageDefinitions::FieldHeaderBuilder
  • Activ::ContentPlatform::Feed::CompressedMessageDefinitions::FieldHeaderValidator
  • Activ::ContentPlatform::Feed::CompressedMessageDefinitions::FieldSpecification
  • Activ::ContentPlatform::Feed::CompressedMessageHeaderDefinitions
  • Activ::ContentPlatform::Feed::CompressedSymbol
  • Activ::ContentPlatform::Feed::CompressedUsEquityOptionSymbol
  • Activ::ContentPlatform::Feed::CopyOnReset
  • Activ::ContentPlatform::Feed::EntityTypeHelper
  • Activ::ContentPlatform::Feed::EventTypeHelper
  • Activ::ContentPlatform::Feed::Field
  • Activ::ContentPlatform::Feed::Field::Specification
  • Activ::ContentPlatform::Feed::FieldHeaderDefinitions
    • Activ::ContentPlatform::Feed::SymbolRecordFieldHeaderDefinitions
  • Activ::ContentPlatform::Feed::Index::IndexFieldSpecification
  • Activ::ContentPlatform::Feed::Index::Specification
  • Activ::ContentPlatform::Feed::IndexSpecification::Field
  • Activ::ContentPlatform::Feed::MessageHeaderDefinitions
  • Activ::ContentPlatform::Feed::PermissionIdHelper
  • Activ::ContentPlatform::Feed::PermissionInfo
    • Activ::ContentPlatform::ContentGatewayApi::PermissionInfo
  • Activ::ContentPlatform::Feed::PermissionInfo::PermissionIdInfo
  • Activ::ContentPlatform::Feed::PermissionLevelData
  • Activ::ContentPlatform::Feed::RecordFieldListBuilder
  • Activ::ContentPlatform::Feed::RecordFieldListValidator
  • Activ::ContentPlatform::Feed::RecordFieldListValidator::ConstIterator
  • Activ::ContentPlatform::Feed::RecordKeyFieldListBuilder
  • Activ::ContentPlatform::Feed::RecordKeyFieldListValidator
  • Activ::ContentPlatform::Feed::RecordKeyFieldListValidator::ConstIterator
  • Activ::ContentPlatform::Feed::RecordMessageBuilder
  • Activ::ContentPlatform::Feed::RecordMessageHeaderDefinitions
  • Activ::ContentPlatform::Feed::RecordMessageHeaderValidator
  • Activ::ContentPlatform::Feed::RecordMessageValidator
  • Activ::ContentPlatform::Feed::RelationshipIdHelper
  • Activ::ContentPlatform::Feed::Rule
  • Activ::ContentPlatform::Feed::Rule::CloseFields
  • Activ::ContentPlatform::Feed::Rule::CopyToFields
  • Activ::ContentPlatform::Feed::Rule::HighFields
  • Activ::ContentPlatform::Feed::Rule::LowFields
  • Activ::ContentPlatform::Feed::Rule::OpenFields
  • Activ::ContentPlatform::Feed::Rule::PriceFields
  • Activ::ContentPlatform::Feed::Rule::VolumeFields
  • Activ::ContentPlatform::Feed::Symbol
  • Activ::ContentPlatform::Feed::SymbolRecordField
  • Activ::ContentPlatform::Feed::SymbolRecordField::PartialUpdate
  • Activ::ContentPlatform::Feed::SymbolRecordFieldListBuilder
  • Activ::ContentPlatform::Feed::SymbolRecordFieldListValidator
  • Activ::ContentPlatform::Feed::SymbolRecordFieldListValidator::ConstIterator
  • Activ::ContentPlatform::Feed::SymbolRecordMessageBuilder
  • Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions
  • Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator
  • Activ::ContentPlatform::Feed::SymbolRecordMessageValidator
  • Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions
  • Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ContentServerRuleSet
  • Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::TranslatorRuleSet
  • Activ::ContentPlatform::Feed::TableTemplate
    • Activ::ContentPlatform::Feed::TableTemplateAddition
  • Activ::ContentPlatform::Feed::TableTemplate::ConstCopyOnResetIterator
  • Activ::ContentPlatform::Feed::TableTemplate::ConstFieldIterator
  • Activ::ContentPlatform::Feed::TableTemplate::ConstIndexIterator
  • Activ::ContentPlatform::Feed::TableTemplate::ConstRuleIterator
  • Activ::ContentPlatform::Feed::TableTemplate::ConstUndefineOnResetIterator
  • Activ::ContentPlatform::Feed::TableTemplate::FieldSpecification
  • Activ::ContentPlatform::Feed::TableTemplate::Specification
  • Activ::ContentPlatform::Feed::TableTemplateField
  • Activ::ContentPlatform::Feed::TableTemplateFieldListValidator
  • Activ::ContentPlatform::Feed::TableTemplateFieldListValidator::ConstIterator
  • Activ::ContentPlatform::Feed::TableTemplateIndex
  • Activ::ContentPlatform::Feed::TableTemplateIndexListValidator
  • Activ::ContentPlatform::Feed::TableTemplateList
  • Activ::ContentPlatform::Feed::TableTemplateList::ConstIterator
  • Activ::ContentPlatform::Feed::TableTemplateList::Settings
  • Activ::ContentPlatform::Feed::TableTemplateList::TableTemplateSpecification
  • Activ::ContentPlatform::Feed::TableTemplateMessageHeaderDefinitions
  • Activ::ContentPlatform::Feed::TableTemplateMessageValidator
  • Activ::ContentPlatform::Feed::UniversalFieldHelper
  • Activ::ContentPlatform::Feed::UniversalFieldList
  • Activ::ContentPlatform::Feed::UniversalFieldList::ConstIterator
  • Activ::ContentPlatform::FeedApi::FieldListValidator
    • Activ::ContentPlatform::ContentGatewayApi::FieldListValidator
    • Activ::ContentPlatform::ContentServerApi::FieldListValidator
  • Activ::ContentPlatform::FeedApi::FieldListValidator::ConstIterator
  • Activ::ContentPlatform::FeedApi::FieldListValidator::Field
  • Activ::ContentPlatform::FeedApi::SymbolPatternHelper
  • Activ::CtrlHandler
  • Activ::CurlFtpHelper::CurlInitializeHelper
  • Activ::Database::Database
  • Activ::Database::Database::ConstIterator
  • Activ::Database::Database::Iterator
  • Activ::Database::DatabaseSpecification
  • Activ::Database::DatabaseSpecification::DatabaseTableSpecification
  • Activ::Database::FieldList
  • Activ::Database::FieldList::ConstIterator
  • Activ::Database::FieldListObject
    • Activ::Database::Key
    • Activ::Database::Record
  • Activ::Database::FieldSpecification
  • Activ::Database::IIndex
  • Activ::Database::IndexSpecification
  • Activ::Database::IndexSpecification::Field
  • Activ::Database::ITable
  • Activ::Database::TableSpecification
  • Activ::Date::Days
  • Activ::DeferredScopedMutexLocker
  • Activ::DeleteAssociativeObject
  • Activ::DeleteObject
  • Activ::DeleteObjectArray
  • Activ::Des3Helper::Key
  • Activ::Des3Helper::KeyBundle
  • Activ::DesHelper::Key
  • Activ::DirectoryWalker
    • Activ::DirectoryRemover
  • Activ::DirectoryWatchApi
  • Activ::DirectoryWatchApi::Event
  • Activ::DllFunctionWrapper< NAME, TYPE, THROW_ON_ERROR >
  • Activ::DynamicLibraryLoader< T >
  • Activ::EqualToPairComparisonObject< Pair >
  • Activ::Exception
    • Activ::BaseException
    • Activ::ContentPlatform::Feed::TableTemplateException
    • Activ::CrtException
    • Activ::Database::DatabaseException
    • Activ::IniFileParser::ParseException
    • Activ::IpException
    • Activ::OsException
    • Activ::StatusCodeException
    • Activ::SystemException
  • Activ::Fiber
  • Activ::FieldTypeToClass<>
  • Activ::FieldTypeToClass< FIELD_TYPE_BINARY_ARRAY >
  • Activ::FieldTypeToClass< FIELD_TYPE_BINARY_STRING >
  • Activ::FieldTypeToClass< FIELD_TYPE_BLOB >
  • Activ::FieldTypeToClass< FIELD_TYPE_CRC_BLOB >
  • Activ::FieldTypeToClass< FIELD_TYPE_DATE >
  • Activ::FieldTypeToClass< FIELD_TYPE_DATE_TIME >
  • Activ::FieldTypeToClass< FIELD_TYPE_RATIONAL >
  • Activ::FieldTypeToClass< FIELD_TYPE_SINT >
  • Activ::FieldTypeToClass< FIELD_TYPE_TEXT_ARRAY >
  • Activ::FieldTypeToClass< FIELD_TYPE_TEXT_STRING >
  • Activ::FieldTypeToClass< FIELD_TYPE_TIME >
  • Activ::FieldTypeToClass< FIELD_TYPE_TRATIONAL >
  • Activ::FieldTypeToClass< FIELD_TYPE_UINT >
  • Activ::File
  • Activ::FileInfo
  • Activ::FtpHelper
  • Activ::Greater< T, RHS >
  • Activ::HandleManager< T >
  • Activ::HeapMessage
  • Activ::HeapMessage::Iterator
  • Activ::HeapMessage::ReadHelper
  • Activ::HeapMessage::Stats
  • Activ::HeapMessage::WriteHelper
  • Activ::HeapMessageBuilder
  • Activ::HeapMessageDeserializer< MESSAGE_TYPE, BUFFER_SIZE >
  • Activ::HeapPool
  • Activ::IEndPoint
    • Activ::ISyncEndPoint
  • Activ::IEndPoint::Stats
    • Activ::ISyncEndPoint::Stats
  • Activ::IEvent
  • Activ::IFieldType
    • Activ::BinaryArray
    • Activ::BinaryString
    • Activ::Blob
    • Activ::CrcBlob
    • Activ::Date
    • Activ::DateTime
    • Activ::Rational
    • Activ::SInt
    • Activ::TextArray
    • Activ::TextString
    • Activ::Time
    • Activ::TRational
    • Activ::UInt
  • Activ::IFtpHelper
    • Activ::CurlFtpHelper
  • Activ::IHeap
  • Activ::IHeap::BucketInfo
  • Activ::IHeap::Stats
  • Activ::IHeap::Stats::BucketStats
  • Activ::IHeap::Stats::RequestDistributionStats
  • Activ::IMappedMemory
    • Activ::IFileMappedMemory
  • Activ::IMutex
  • Activ::IniFileParser
  • Activ::IniFileParser::ConstKeyIterator
  • Activ::IniFileParser::ConstSectionIterator
  • Activ::IntervalTimer
  • Activ::IntervalTimer::Scoped
  • Activ::IoCompletionManager
    • Activ::IpManager
  • Activ::IoCompletionManager::Overlapped
    • Activ::IpSocket::RxOverlapped
    • Activ::IpSocket::TxOverlapped
  • Activ::IpAddress
  • Activ::IpManager::InterfaceInfo
  • Activ::IpManager::Settings
  • Activ::IProcess
  • Activ::IProcess::Stats
  • Activ::IpSocket
    • Activ::TcpSocket
    • Activ::UdpSocket
  • Activ::IpSocket::Settings
    • Activ::TcpSocket::Settings
    • Activ::UdpSocket::Settings
  • Activ::IpSocket::Stats
    • Activ::TcpSocket::Stats
    • Activ::UdpSocket::Stats
  • Activ::ISemaphore
  • Activ::ISerializableMessage
    • Activ::OpenServiceRequest
    • Activ::OpenServiceResponse
  • Activ::ISystem
    • Activ::SystemProxy
      • Activ::Application
        • Activ::AgentApplication
        • Activ::ThinApplication
  • Activ::ISystem::IEndPointEnumerator
  • Activ::ISystem::IHeapEnumerator
  • Activ::ISystem::IProcessEnumerator
  • Activ::ISystem::Settings
    • Activ::Application::Settings
      • Activ::AgentApplication::Settings
      • Activ::ThinApplication::Settings
  • Activ::LengthToIntegralType< N, S >
  • Activ::Less< T, RHS >
  • Activ::LessThanPairComparisonObject< Pair >
  • Activ::LicenseServiceApi
  • Activ::LoggerDefinitions
  • Activ::LoggerServiceApi
  • Activ::ManagedEndPoint
    • Activ::Application
  • Activ::ManagedEndPoint::RunHelper
  • Activ::ManagedEndPoint::Settings
  • Activ::MessageBuilderVariableLengthRangeCheck< S >
  • Activ::MessageBuilderVariableLengthRangeCheck< false >
  • Activ::MessageBuilderVariableLengthRangeCheck< true >
  • Activ::MessageHandler
    • Activ::MessageBuilder
    • Activ::MessageValidator
  • Activ::MessageHandler::ScopedVersion
  • Activ::MessageRateThrottler
  • Activ::NullObject
  • Activ::ObjectPool< T, INITIAL_FREE_LIST_SIZE, MAX_FREE_LIST_SIZE >::Stats
  • Activ::Port
    • Activ::Component
      • Activ::Application
      • Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
      • Activ::ContentPlatform::ContentServerApi::ContentServerClient
      • Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient
      • Activ::ContentPlatform::ContributionServerApi::ContributionServerClient
      • Activ::Service
        • Activ::ChildService< T >
      • Activ::UdpComponent
      • Activ::UiComponent
        • Activ::UiMainComponent
  • Activ::Port::Enabler
  • Activ::PostMessageHelper
  • Activ::Process
  • Activ::PubSubServiceApi
  • Activ::Rational::DenominatorType
  • Activ::ReferenceCounter
  • Activ::RegistryHelper
  • Activ::RequestId
  • Activ::RouterServiceApi
  • Activ::RouterServiceApi::Tcp
  • Activ::RouterServiceApi::Tcp::SocketStats
  • Activ::RouterServiceApi::Udp
  • Activ::ScatterBufferHelper
  • Activ::ScatterBufferHelper::ConstIterator
  • Activ::ScatterBufferHelper::ScatterBuffer
  • Activ::ScopedAddress
  • Activ::ScopedHandle::IsValidHandle
  • Activ::ScopedHelper< T, D >
  • Activ::ScopedHelper< T, D >::True
  • Activ::ScopedMutexLocker
  • Activ::ScopedMutexTryLocker
  • Activ::ScopedPooledObject< T >
  • Activ::ScopedSubscription
  • Activ::SelectFirst< P >
  • Activ::SelectFirstFromSecond< P >
  • Activ::SelectSecond< P >
  • Activ::SerializableBuffer< LENGTH_TYPE, MIN_LENGTH, MAX_LENGTH >
  • Activ::SerializableContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >
    • Activ::SerializableObjectContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH >
    • Activ::SerializableObjectContainerHelper< hash_map< KEY_TYPE, MAPPED_TYPE, HASH_FN >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH >
    • Activ::SerializableObjectContainerHelper< std::map< KEY_TYPE, MAPPED_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH >
    • Activ::SerializableRawPointerContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH >
    • Activ::SerializableRawPointerContainerHelper< hash_map< KEY_TYPE, MAPPED_TYPE, HASH_FN >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH >
    • Activ::SerializableRawPointerContainerHelper< std::map< KEY_TYPE, MAPPED_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH >
    • Activ::SerializableSmartPointerContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH >
    • Activ::SerializableSmartPointerContainerHelper< hash_map< KEY_TYPE, MAPPED_TYPE, HASH_FN >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH >
    • Activ::SerializableSmartPointerContainerHelper< std::map< KEY_TYPE, MAPPED_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH >
  • Activ::SerializableContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, Activ::SerializableObjectHelper< CONTAINER_TYPE::value_type > >
  • Activ::SerializableContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, Activ::SerializableRawPointerHelper< CONTAINER_TYPE::value_type > >
  • Activ::SerializableContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, Activ::SerializableSmartPointerHelper< CONTAINER_TYPE::value_type > >
  • Activ::SerializableContainerHelper< hash_map< KEY_TYPE, MAPPED_TYPE, HASH_FN >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, Activ::SerializableObjectHelper< MAPPED_TYPE > >
  • Activ::SerializableContainerHelper< hash_map< KEY_TYPE, MAPPED_TYPE, HASH_FN >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, Activ::SerializableRawPointerHelper< MAPPED_TYPE > >
  • Activ::SerializableContainerHelper< hash_map< KEY_TYPE, MAPPED_TYPE, HASH_FN >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, Activ::SerializableSmartPointerHelper< MAPPED_TYPE > >
  • Activ::SerializableContainerHelper< hash_map< KEY_TYPE, MAPPED_TYPE, HASH_FN >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >
  • Activ::SerializableContainerHelper< std::list< OBJECT_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >
  • Activ::SerializableContainerHelper< std::map< KEY_TYPE, MAPPED_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, Activ::SerializableObjectHelper< MAPPED_TYPE > >
  • Activ::SerializableContainerHelper< std::map< KEY_TYPE, MAPPED_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, Activ::SerializableRawPointerHelper< MAPPED_TYPE > >
  • Activ::SerializableContainerHelper< std::map< KEY_TYPE, MAPPED_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, Activ::SerializableSmartPointerHelper< MAPPED_TYPE > >
  • Activ::SerializableContainerHelper< std::map< KEY_TYPE, MAPPED_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >
  • Activ::SerializableContainerHelper< std::set< OBJECT_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >
  • Activ::SerializableContainerHelper< std::vector< OBJECT_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >
  • Activ::SerializableObjectHelper< OBJECT_TYPE >
  • Activ::SerializableRawPointerHelper< POINTER_TYPE >
  • Activ::SerializableSmartPointerHelper< POINTER_TYPE >
  • Activ::ServiceAccessPoint
  • Activ::ServiceApi
  • Activ::ServiceHandle
  • Activ::ServiceId
  • Activ::ServiceInstance
  • Activ::SharedObject< T >
  • Activ::Shell
  • Activ::Singleton< T >
    • Activ::Database::ManagedTableFactory
    • Activ::Database::RemoteTableFactory
    • Activ::Database::UnmanagedTableFactory
    • Activ::FieldTypeFactory
    • Activ::FileMappedMemoryFactory
    • Activ::ObjectPool< T, INITIAL_FREE_LIST_SIZE, MAX_FREE_LIST_SIZE >
    • Activ::PagingFileMappedMemoryFactory
    • Activ::PrivateEventFactory
    • Activ::PrivateMutexFactory
    • Activ::PrivateSemaphoreFactory
    • Activ::SharedCompletionPortEventFactory
    • Activ::SharedEventFactory
    • Activ::SharedMutexFactory
    • Activ::SharedSemaphoreFactory
    • Activ::SystemFactory
  • Activ::SmtpHelper
  • Activ::SmtpHelper::Email
  • Activ::SocketWrapper
  • Activ::StaticAlignValueToProcessorWordBoundary< T, input >
  • Activ::StatusCodeHelper
  • Activ::StringHashCompare< TRAITS >
  • Activ::Subject
    • Activ::EndPointSubject
    • Activ::ServiceSubject
    • Activ::ShutdownSubject
  • Activ::SyncRequestId
  • Activ::SystemInfo
    • Activ::ISystem::SystemInfo
  • Activ::SystemMessageEndPointIdSet
  • Activ::SystemMonitor
  • Activ::SystemMonitor::Stats
  • Activ::SystemMonitor::Stats::DiskInfo
  • Activ::SystemMonitor::Stats::ProcessInfo
  • Activ::TcpListener
  • Activ::Thread
  • Activ::ThreadSpecificDataBase< TYPE, DERIVED >
    • Activ::ThreadSpecificData< TYPE, CLEANUP >
  • Activ::ThreadSpecificFastPoolAllocator< T, UserAllocator, NextSize >
  • Activ::ThreadSpecificPoolAllocator< T, UserAllocator, NextSize >
  • Activ::Time::Hours
  • Activ::Time::Milliseconds
  • Activ::Time::Minutes
  • Activ::Time::Seconds
  • Activ::Timeband
  • Activ::Timeband::Settings
  • Activ::Timeout
  • Activ::TimerServiceApi
  • Activ::TRational::SerializedTrendDefinitions
  • Activ::TypeToIntegralType< T >
  • Activ::UiIo
  • Activ::UiIo::Attribute
  • Activ::UiIo::Columnizer
  • Activ::UiIo::CompletionHelper
    • Activ::UiIo::DynamicCompletionHelper
    • Activ::UiIo::StaticCompletionHelper
  • Activ::UiMenu
    • Activ::UiMainComponent::Menu
  • Activ::UiMenu::OptionAttributes
  • Activ::UiPermissions
  • Activ::Url
  • Activ::Uuid
  • Activ::WsaBufHelper
  • noncopyable
    • Activ::ScopedHelper< FILE *, boost::function< int(FILE *)> >
      • Activ::ScopedFile
    • Activ::ScopedHelper< HANDLE, boost::function< BOOL(HANDLE)> >
      • Activ::ScopedHandle
    • Activ::ScopedHelper< int, boost::function< int(int)> >
      • Activ::ScopedFd
    • Activ::ScopedHelper< SOCKET, boost::function< int(SOCKET)> >
      • Activ::ScopedSocket
    • Activ::ScopedHelper< T, boost::function< void(void *)> >
      • Activ::ScopedMemory< T >
    • Activ::Singleton< Activ::Database::ManagedTableFactory >
    • Activ::Singleton< Activ::Database::RemoteTableFactory >
    • Activ::Singleton< Activ::Database::UnmanagedTableFactory >
    • Activ::Singleton< Activ::FieldTypeFactory >
    • Activ::Singleton< Activ::FileMappedMemoryFactory >
    • Activ::Singleton< Activ::ObjectPool< T, INITIAL_FREE_LIST_SIZE, MAX_FREE_LIST_SIZE > >
    • Activ::Singleton< Activ::PagingFileMappedMemoryFactory >
    • Activ::Singleton< Activ::PrivateEventFactory >
    • Activ::Singleton< Activ::PrivateMutexFactory >
    • Activ::Singleton< Activ::PrivateSemaphoreFactory >
    • Activ::Singleton< Activ::SharedCompletionPortEventFactory >
    • Activ::Singleton< Activ::SharedEventFactory >
    • Activ::Singleton< Activ::SharedMutexFactory >
    • Activ::Singleton< Activ::SharedSemaphoreFactory >
    • Activ::Singleton< Activ::SystemFactory >
    • Activ::Singleton< Activ::ThreadSpecificFastPoolAllocator::ThreadSingleton >
    • Activ::Singleton< Activ::ThreadSpecificPoolAllocator::ThreadSingleton >
    • Activ::ThreadSpecificDataBase< TYPE, ACTIV_TEMPLATE_SELF Activ::ThreadSpecificData< TYPE, CLEANUP > >
Generated on Wed Oct 8 14:01:51 2008 for ACTIV C++ SDK by doxygen 1.5.4


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- a -

  • AbortiveClose() : Activ::UdpSocket
  • Accept() : Activ::TcpSocket
  • ACCESS_FLAG_READ : Activ::File
  • ACCESS_FLAG_WRITE : Activ::File
  • AccessFlags : Activ::File
  • Acquire()
: Activ::ScopedMutexTryLocker
, Activ::DeferredScopedMutexLocker
, Activ::IMutex
, Activ::ISemaphore
  • ACTIV_DECLARE_ELEMENT_1_WITH_COMMA : Activ::LoggerDefinitions
  • ACTIV_DECLARE_VALUE_WITH_COMMA
: Activ::ContentPlatform::ContentGatewayApi::SubscribeParameters
, Activ::ContentPlatform::ContentGatewayApi::MatchRequestParameters
, Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryRequestParameters
, Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::ConnectParameters
  • Add()
: Activ::Database::ITable
, Activ::UInt
, Activ::Database::ITable
, Activ::Date
, Activ::DateTime
, Activ::Rational
, Activ::SInt
, Activ::Time
, Activ::Database::ITable
, Activ::Time
  • AddCompletion() : Activ::UiIo::CompletionHelper
  • AddDescriptions() : Activ::CommandLineParser
  • AddDisabledDate() : Activ::Timeband
  • AddException() : Activ::Exception
  • AddOption() : Activ::UiMenu
  • AddProcess() : Activ::SystemMonitor
  • Address() : Activ::Address
  • AddressSet : Activ::PubSubServiceApi
  • AddressSetList : Activ::PubSubServiceApi
  • AddUpdateFilter() : Activ::ContentPlatform::ContentServerApi::ContentServerClient
  • AddWatch() : Activ::DirectoryWatchApi
  • Adjust() : Activ::ContentPlatform::ContentGatewayApi::HistoryBar
  • AdjustGetBufferSize()
: Activ::ScatterBufferHelper
, Activ::HeapMessage::ReadHelper
  • AdjustSystemTime() : Activ::TimerServiceApi
  • AgentApplication() : Activ::AgentApplication
  • AllocateBuffer() : Activ::Database::FieldListObject
  • anonymousName : Activ::Port
  • Append()
: Activ::ContentPlatform::Feed::CompressedMessageDefinitions::FieldHeaderBuilder
, Activ::MessageBuilder
, Activ::WsaBufHelper
, Activ::HeapMessage
  • AppendBoolean() : Activ::MessageBuilder
  • AppendField()
: Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::SymbolRecordMessageBuilder
, Activ::ContentPlatform::Feed::RecordFieldListBuilder
, Activ::ContentPlatform::Feed::RecordKeyFieldListBuilder
, Activ::ContentPlatform::Feed::RecordMessageBuilder
, Activ::ContentPlatform::Feed::SymbolRecordFieldListBuilder
, Activ::ContentPlatform::Feed::SymbolRecordMessageBuilder
, Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::RecordMessageBuilder
  • AppendFieldWithContentServerRuleSet()
: Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::SymbolRecordMessageBuilder
, Activ::ContentPlatform::Feed::SymbolRecordFieldListBuilder
, Activ::ContentPlatform::Feed::SymbolRecordMessageBuilder
, Activ::ContentPlatform::Feed::SymbolRecordFieldListBuilder
  • AppendFieldWithNoneRuleSet()
: Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::SymbolRecordMessageBuilder
, Activ::ContentPlatform::Feed::SymbolRecordFieldListBuilder
, Activ::ContentPlatform::Feed::SymbolRecordMessageBuilder
  • AppendFieldWithTranslatorRuleSet()
: Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::SymbolRecordMessageBuilder
, Activ::ContentPlatform::Feed::SymbolRecordFieldListBuilder
, Activ::ContentPlatform::Feed::SymbolRecordMessageBuilder
, Activ::ContentPlatform::Feed::SymbolRecordFieldListBuilder
, Activ::ContentPlatform::Feed::SymbolRecordMessageBuilder
  • AppendHeader()
: Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::SymbolRecordMessageBuilder
, Activ::ContentPlatform::Feed::SymbolRecordMessageBuilder
, Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::RecordMessageBuilder
, Activ::ContentPlatform::Feed::RecordMessageBuilder
, Activ::ContentPlatform::Feed::SymbolRecordMessageBuilder
  • AppendIndexNumber()
: Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::RecordMessageBuilder
, Activ::ContentPlatform::Feed::RecordMessageBuilder
  • AppendInEndian() : Activ::MessageBuilder
  • AppendKeyField()
: Activ::ContentPlatform::Feed::RecordMessageBuilder
, Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::RecordMessageBuilder
, Activ::ContentPlatform::Feed::RecordMessageBuilder
  • AppendRxBuffer() : Activ::IpSocket
  • AppendTxBuffer() : Activ::IpSocket
  • AppendUndefinedField()
: Activ::ContentPlatform::Feed::SymbolRecordMessageBuilder
, Activ::ContentPlatform::Feed::RecordKeyFieldListBuilder
, Activ::ContentPlatform::Feed::RecordMessageBuilder
, Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::SymbolRecordMessageBuilder
, Activ::ContentPlatform::Feed::SymbolRecordFieldListBuilder
, Activ::ContentPlatform::Feed::RecordFieldListBuilder
, Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::RecordMessageBuilder
  • AppendUndefinedKeyField()
: Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::RecordMessageBuilder
, Activ::ContentPlatform::Feed::RecordMessageBuilder
  • ApplyTableTemplateAddition()
: Activ::ContentPlatform::Feed::TableTemplate
, Activ::ContentPlatform::Feed::TableTemplateList
  • ApplyUpdate()
: Activ::ContentPlatform::ContentServerApi::FieldListValidator
, Activ::ContentPlatform::FeedApi::FieldListValidator
, Activ::ContentPlatform::ContentServerApi::FieldListValidator
, Activ::ContentPlatform::ContentGatewayApi::FieldListValidator
  • ApplyUpdateToExistingFieldsOnly()
: Activ::ContentPlatform::ContentGatewayApi::FieldListValidator
, Activ::ContentPlatform::FeedApi::FieldListValidator
  • Assign() : Activ::IFieldType
  • AtomicInteger() : Activ::AtomicInteger
  • AtomicPointer() : Activ::AtomicPointer< T >
  • Attach()
: Activ::ScatterBufferHelper
, Activ::HeapMessage
  • AttachHandle() : Activ::IoCompletionManager
  • AttachTable() : Activ::Database::Database
  • Attribute : Activ::RequestId
Generated on Wed Oct 8 14:01:54 2008 for ACTIV C++ SDK by doxygen 1.5.4


  • File List
  • File Members

ACTIV C++ SDK File List

Here is a list of all documented files with brief descriptions:
include/ActivContentPlatform/MessageClasses.h [code] | Message classes for content platform
include/ActivContentPlatform/ActivContentGatewayApi/ActivContentGatewayApi.h [code] | ActivContentGatewayApi main header
include/ActivContentPlatform/ActivContentGatewayApi/ContentGatewayClient.h [code] | Content gateway client
include/ActivContentPlatform/ActivContentGatewayApi/External.h [code] | Import rules for ActivContentGatewayApi exports
include/ActivContentPlatform/ActivContentGatewayApi/FieldListValidator.h [code] | Header file for the field list validator class
include/ActivContentPlatform/ActivContentGatewayApi/INewsResponses.h [code] | Callback interface for news responses
include/ActivContentPlatform/ActivContentGatewayApi/IRealtimeResponses.h [code] | Callback interface for realtime data request responses
include/ActivContentPlatform/ActivContentGatewayApi/ISymbolDirectoryResponses.h [code] | Callback interface for symbol directory request responses
include/ActivContentPlatform/ActivContentGatewayApi/ITimeSeriesResponses.h [code] | Callback interface for time series request responses
include/ActivContentPlatform/ActivContentGatewayApi/MetaDataRequestHelper.h [code] | Helper class for metadata requests
include/ActivContentPlatform/ActivContentGatewayApi/NewsRequestHelper.h [code] | Helper class for news requests
include/ActivContentPlatform/ActivContentGatewayApi/NewsUpdateHelper.h [code] | News update helper class
include/ActivContentPlatform/ActivContentGatewayApi/RealtimeRequestHelper.h [code] | Helper class for realtime requests
include/ActivContentPlatform/ActivContentGatewayApi/RecordUpdateHelper.h [code] | Record update helper class
include/ActivContentPlatform/ActivContentGatewayApi/SymbolDirectoryRequestHelper.h [code] | Helper class for symbol directory requests
include/ActivContentPlatform/ActivContentGatewayApi/TimeSeriesRequestHelper.h [code] | Helper class for time series requests
include/ActivContentPlatform/ActivContentGatewayApiCommon/External.h [code] | Import rules for ActivContentGatewayApiCommon exports
include/ActivContentPlatform/ActivContentGatewayApiCommon/FieldSet.h [code] | Header file for the Field Set base class
include/ActivContentPlatform/ActivContentGatewayApiCommon/HistoryBar.h [code] | History Bar Field Set
include/ActivContentPlatform/ActivContentGatewayApiCommon/IntradayBar.h [code] | Intraday Bar Field Set
include/ActivContentPlatform/ActivContentGatewayApiCommon/MetaDataTypes.h [code] | Types for metadata
include/ActivContentPlatform/ActivContentGatewayApiCommon/NewsTypes.h [code] | Types for news data
include/ActivContentPlatform/ActivContentGatewayApiCommon/OptionBar.h [code] | Option Bar Field Set
include/ActivContentPlatform/ActivContentGatewayApiCommon/RealtimeTypes.h [code] | Types for realtime data
include/ActivContentPlatform/ActivContentGatewayApiCommon/SymbolDirectoryTypes.h [code] | Types for symbol directory data
include/ActivContentPlatform/ActivContentGatewayApiCommon/Tick.h [code] | Tick Field Set
include/ActivContentPlatform/ActivContentGatewayApiCommon/TimeSeriesTypes.h [code] | Types for time series data
include/ActivContentPlatform/ActivContentGatewayApiCommon/Types.h [code] | General content gateway types
include/ActivContentPlatform/ActivContentServerApi/ActivContentServerApi.h [code] | ActivContentServerApi main header
include/ActivContentPlatform/ActivContentServerApi/ContentServerClient.h [code] | Content server client
include/ActivContentPlatform/ActivContentServerApi/External.h [code] | Import rules for ActivContentServerApi exports
include/ActivContentPlatform/ActivContentServerApi/FieldListValidator.h [code] | Header file for the field list validator class
include/ActivContentPlatform/ActivContentServerApi/RecordUpdateHelper.h [code] | Record update helper
include/ActivContentPlatform/ActivContentServerApi/SymbolPatternHelper.h [code] | Header for symbol pattern helper class
include/ActivContentPlatform/ActivContributionGatewayApi/ActivContributionGatewayApi.h [code] | ActivContributionGatewayApi main header
include/ActivContentPlatform/ActivContributionGatewayApi/ContributionGatewayClient.h [code] | Contribution gateway client
include/ActivContentPlatform/ActivContributionGatewayApi/External.h [code] | Import rules for ActivContributionGatewayApi exports
include/ActivContentPlatform/ActivContributionGatewayApi/PublishRequestHelper.h [code] | Helper class for publish requests
include/ActivContentPlatform/ActivContributionGatewayApiCommon/External.h [code] | Import rules for ActivContributionGatewayApiCommon exports
include/ActivContentPlatform/ActivContributionGatewayApiCommon/PublishTypes.h [code] | Types for publishing data
include/ActivContentPlatform/ActivContributionGatewayApiCommon/Types.h [code] | General contribution gateway types
include/ActivContentPlatform/ActivContributionServerApi/ContributionServerClient.h [code] | Contribution server api
include/ActivContentPlatform/ActivContributionServerApi/External.h [code] | Import rules for ActivContributionServerApi exports
include/ActivContentPlatform/ActivFeedApiCommon/External.h [code] | Import rules for ActivFeedApiCommon exports
include/ActivContentPlatform/ActivFeedApiCommon/FieldListValidator.h [code] | Header file for the field list validator class
include/ActivContentPlatform/ActivFeedApiCommon/FieldStatus.h [code] | Header file for the field status definitions
include/ActivContentPlatform/ActivFeedCommon/ActivFeed.h [code] | Main header file for ACTIV Feed
include/ActivContentPlatform/ActivFeedCommon/ActivFeedDefinitions.h [code] | Header file for activ feed definitions
include/ActivContentPlatform/ActivFeedCommon/EntityTypeHelper.h [code] | Header file for the entity type helper
include/ActivContentPlatform/ActivFeedCommon/EntityTypes.h [code] | Header file for entity types
include/ActivContentPlatform/ActivFeedCommon/Enumerations.h [code] | Header file for the enumerations
include/ActivContentPlatform/ActivFeedCommon/EventTypeHelper.h [code] | Header file for the event type helper
include/ActivContentPlatform/ActivFeedCommon/EventTypes.h [code] | Header file for the event types
include/ActivContentPlatform/ActivFeedCommon/Exchanges.h [code] | Header file for the exchanges
include/ActivContentPlatform/ActivFeedCommon/External.h [code] | Import rules for ActivFeedCommon exports
include/ActivContentPlatform/ActivFeedCommon/FieldIds.h [code] | Header file for the field ids
include/ActivContentPlatform/ActivFeedCommon/IndexNumbers.h [code] | Header file for the table template index numbers
include/ActivContentPlatform/ActivFeedCommon/PermissionIdHelper.h [code] | Header file for the permission id helper
include/ActivContentPlatform/ActivFeedCommon/PermissionIds.h [code] | Header file for the permission ids
include/ActivContentPlatform/ActivFeedCommon/PermissionLevels.h [code] | Header file for the permission levels
include/ActivContentPlatform/ActivFeedCommon/RelationshipIdHelper.h [code] | Header file for the relationship id helper
include/ActivContentPlatform/ActivFeedCommon/RelationshipIds.h [code] | Header file for the relationship ids
include/ActivContentPlatform/ActivFeedCommon/TableNumbers.h [code] | Header file for the table numbers
include/ActivContentPlatform/ActivFeedCommon/TableResetTypes.h [code] | Header file for the table reset types
include/ActivContentPlatform/ActivFeedCommon/TableTypes.h [code] | Header file for the table types
include/ActivContentPlatform/ActivFeedCommon/UniversalFieldHelper.h [code] | Header file for the universal field helper
include/ActivContentPlatform/ActivFeedCommon/UpdateIds.h [code] | Header file for the update ids
include/ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/ActivFeedMessageHandler.h [code] | Global functions from ActivFeedMessageHandler
include/ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/CombinedQuoteMessageHeaderDefinitions.h [code] | Header file for the combined quote message header definitions class
include/ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/CompressedCombinedQuoteMessage.h [code] | Header file for the compressed combined quote message class
include/ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/CompressedCombinedQuoteMessageDefinitions.h [code] | Header file for the compressed message definitions class
include/ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/CompressedCombinedQuoteMessageHeaderDefinitions.h [code] | Header file for the compressed combined quote message header definitions class
include/ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/CompressedCombinedQuoteMessageHeaderValidator.h [code] | Header file for the compressed combined quote message header validator class
include/ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/CompressedMessage.h [code] | Header file for the compressed message class
include/ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/CompressedMessageDefinitions.h [code] | Header file for the compressed message definitions class
include/ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/CompressedMessageHeaderDefinitions.h [code] | Header file for the compressed message header definitions class
include/ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/CompressedMessageHeaderValidator.h [code] | Header file for the compressed message header validator class
include/ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/CompressedSymbol.h [code] | Header file for the compressed symbol class
include/ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/CompressedUsEquityOptionSymbol.h [code] | Header file for the compressed us equity option symbol class
include/ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/External.h [code] | Import rules for ActivFeedMessageHandler exports
include/ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/FieldHeaderDefinitions.h [code] | Header file for the field header definitions class
include/ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/MessageHeaderDefinitions.h [code] | Header file for the message header definitions class
include/ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/RecordFieldListBuilder.h [code] | Header file for the record field list builder class
include/ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/RecordFieldListValidator.h [code] | Header file for the record field list validator class
include/ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/RecordKeyFieldListBuilder.h [code] | Header file for the record key field list builder class
include/ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/RecordKeyFieldListValidator.h [code] | Header file for the record key field list validator class
include/ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/RecordMessageBuilder.h [code] | Header file for the record message builder class
include/ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/RecordMessageHeaderDefinitions.h [code] | Header file for the record message header definitions class
include/ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/RecordMessageHeaderValidator.h [code] | Header file for the record message header validator class
include/ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/RecordMessageValidator.h [code] | Header file for the record message validator class
include/ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/Symbol.h [code] | Header file for the symbol class
include/ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/SymbolRecordField.h [code] | Header file for the symbol record field class
include/ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/SymbolRecordFieldHeaderDefinitions.h [code] | Header file for the symbol record field header definitions class
include/ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/SymbolRecordFieldListBuilder.h [code] | Rule file for the symbol record field list builder class
include/ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/SymbolRecordFieldListValidator.h [code] | Header file for the symbol record field list validator class
include/ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/SymbolRecordMessageBuilder.h [code] | Header file for the symbol record message builder class
include/ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/SymbolRecordMessageHeaderDefinitions.h [code] | Header file for the symbol record message header definitions class
include/ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/SymbolRecordMessageHeaderValidator.h [code] | Header file for the symbol record message header validator class
include/ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/SymbolRecordMessageValidator.h [code] | Header file for the symbol record message validator class
include/ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/SymbolRecordRuleDefinitions.h [code] | Header file for the symbol record rules definitions class
include/ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/TableTemplateField.h [code] | Header file for the table template field class
include/ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/TableTemplateFieldListValidator.h [code] | Header file for the table template field list validator class
include/ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/TableTemplateIndex.h [code] | Header file for the table template index class
include/ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/TableTemplateIndexListValidator.h [code] | Header file for the table template index list validator class
include/ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/TableTemplateMessageHeaderDefinitions.h [code] | Header file for the table template message header definitions class
include/ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/TableTemplateMessageValidator.h [code] | Header file for the table template message validator class
include/ActivContentPlatform/ActivFeedCommon/ActivFeedPermissioning/PermissionInfo.h [code] | Header file for exported user permissioning info
include/ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/ActivFeedTableTemplateHandler.h [code] | Global functions from ActivFeedTableTemplateHandler
include/ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/External.h [code] | Import rules for ActivFeedTableTemplateHandler exports
include/ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/Field.h [code] | Header file for the field class
include/ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/Index.h [code] | Header file for an index
include/ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/IndexSpecification.h [code] | Header file for an index specification
include/ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/Reset.h [code] | Header file for the reset class
include/ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/Rule.h [code] | Header file for the rule class
include/ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/TableSpecification.h [code] | Header file for a table specification
include/ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/TableTemplate.h [code] | Header file for the table template class
include/ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/TableTemplateException.h [code] | Header file for the table template exception class
include/ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/TableTemplateList.h [code] | Header file for the table template list class
include/ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/UniversalFieldList.h [code] | Header file for the universal field list class
include/ActivMiddleware/Activ.h [code] | Main header file, sets up environment and various useful macros
include/ActivMiddleware/BasicTypes.h [code] | Basic types (as per C99 <stdint.h> standard) and various helper functions
include/ActivMiddleware/FormatSpecifiers.h [code] | Platform independant c-style printf format specifiers
include/ActivMiddleware/StatusCodes.h [code] | Status codes and helper macros
include/ActivMiddleware/ActivAgentApplication/AgentApplication.h [code] | Header file for agent application class
include/ActivMiddleware/ActivAgentApplication/External.h [code] | Import rules for AgentApplication exports
include/ActivMiddleware/ActivBase/ActivBase.h [code] | Global functions from ActivBase
include/ActivMiddleware/ActivBase/Atomic.h [code] | Header file for atomic classes
include/ActivMiddleware/ActivBase/BaseException.h [code] | Header file for the base exception class
include/ActivMiddleware/ActivBase/CommandLineParser.h [code] | Header file for a command line parser class
include/ActivMiddleware/ActivBase/ConsoleWindow.h [code] | Header file for console window
include/ActivMiddleware/ActivBase/CrtException.h [code] | Header file for c runtime exception class
include/ActivMiddleware/ActivBase/CtrlHandler.h [code] | Header file for the ctrl handler class
include/ActivMiddleware/ActivBase/DirectoryRemover.h [code] | Directory remover class
include/ActivMiddleware/ActivBase/DirectoryWalker.h [code] | Directory walker class
include/ActivMiddleware/ActivBase/Exception.h [code] | Header file for the base exception class
include/ActivMiddleware/ActivBase/External.h [code] | Import/export rules for ActivBase
include/ActivMiddleware/ActivBase/Fiber.h [code] | Header file for the fiber class
include/ActivMiddleware/ActivBase/File.h [code] | Header file for file class
include/ActivMiddleware/ActivBase/FileMappedMemoryFactory.h [code] | Header file for the file mapped memory factory class
include/ActivMiddleware/ActivBase/IEvent.h [code] | Header file for the event interface class
include/ActivMiddleware/ActivBase/IFileMappedMemory.h [code] | Header file for the file mapped memory interface class
include/ActivMiddleware/ActivBase/IMappedMemory.h [code] | Header file for the mapped memory interface class
include/ActivMiddleware/ActivBase/IMutex.h [code] | Header file for the mutex interface class
include/ActivMiddleware/ActivBase/IniFileParser.h [code] | Header file for ini file parser class
include/ActivMiddleware/ActivBase/IntervalTimer.h [code] | Header file for the interval timer class
include/ActivMiddleware/ActivBase/ISemaphore.h [code] | Header file for the semaphore interface class
include/ActivMiddleware/ActivBase/ISerializableMessage.h [code] | Header file for serializable message interface class
include/ActivMiddleware/ActivBase/MessageBuilder.h [code] | Header file for the message builder class
include/ActivMiddleware/ActivBase/MessageHandler.h [code] | Header file for the base message handler class
include/ActivMiddleware/ActivBase/MessageRateThrottler.h [code] | Header file for the message rate throttler class
include/ActivMiddleware/ActivBase/MessageValidator.h [code] | Header file for the message validator class
include/ActivMiddleware/ActivBase/MutexHelper.h [code] | Header file for the mutex helper classes
include/ActivMiddleware/ActivBase/OsException.h [code] | Header file for the os dependant exception class
include/ActivMiddleware/ActivBase/PagingFileMappedMemoryFactory.h [code] | Header file for the paging file mapped memory factory class
include/ActivMiddleware/ActivBase/PrivateEventFactory.h [code] | Header file for the private event factory class
include/ActivMiddleware/ActivBase/PrivateMutexFactory.h [code] | Header file for the private mutex factory class
include/ActivMiddleware/ActivBase/PrivateSemaphoreFactory.h [code] | Header file for the private semaphore factory class
include/ActivMiddleware/ActivBase/Process.h [code] | Header file for the process class
include/ActivMiddleware/ActivBase/ScatterBufferHelper.h [code] | Header file for the scatter buffer helper class
include/ActivMiddleware/ActivBase/SharedEventFactory.h [code] | Header file for the shared event factory class
include/ActivMiddleware/ActivBase/SharedMutexFactory.h [code] | Header file for the shared mutex factory class
include/ActivMiddleware/ActivBase/SharedObject.h [code] | Header file for the template shared object class
include/ActivMiddleware/ActivBase/SharedSemaphoreFactory.h [code] | Header file for the shared semaphore factory class
include/ActivMiddleware/ActivBase/Shell.h [code] | Header file for the shell class
include/ActivMiddleware/ActivBase/StatusCodeException.h [code] | Header file for the StatusCode exception class
include/ActivMiddleware/ActivBase/SystemInfo.h [code] | Header file for the system info class
include/ActivMiddleware/ActivBase/SystemMonitor.h [code] | Header file for the system monitor class
include/ActivMiddleware/ActivBase/Thread.h [code] | Header file for the thread class
include/ActivMiddleware/ActivBase/ThreadSpecificData.h [code] | Header file for thread specific data storage class
include/ActivMiddleware/ActivBase/ThreadSpecificPoolAllocators.h [code] | Thread-specific boost (fast_)pool_allocator like classes
include/ActivMiddleware/ActivBase/Timeout.h [code] | Header file for the timeout class
include/ActivMiddleware/ActivBase/Url.h [code] | Url parser & builder class
include/ActivMiddleware/ActivBase/Uuid.h [code] | Header file for the Uuid class
include/ActivMiddleware/ActivBase/Detail/AtomicDetail.h [code] | Header file for implementation details for atomic operations
include/ActivMiddleware/ActivBase/Detail/CommandLineParserDetail.h [code] | Implementation details for CommandLineParser
include/ActivMiddleware/ActivBase/Detail/ThreadSpecificDataDetail.h [code] | Implementation details thread for specific data storage class
include/ActivMiddleware/ActivBase/Windows/IoCompletionManager.h [code] | Header file for Windows I/O completion manager classes
include/ActivMiddleware/ActivBase/Windows/RegistryHelper.h [code] | Header file for the registry helper class
include/ActivMiddleware/ActivBase/Windows/SharedCompletionPortEventFactory.h [code] | Header file for the shared socket based event factory class
include/ActivMiddleware/ActivDatabase/ActivDatabase.h [code] | Header file for the Activ database
include/ActivMiddleware/ActivDatabase/Database.h [code] | Header file for the Database class
include/ActivMiddleware/ActivDatabase/DatabaseException.h [code] | Header file for the database exception class
include/ActivMiddleware/ActivDatabase/DatabaseSpecification.h [code] | Header file for the database specification class
include/ActivMiddleware/ActivDatabase/Definitions.h [code] | Header file for the database definition information
include/ActivMiddleware/ActivDatabase/External.h [code] | Import rules for ActivDatabase exports
include/ActivMiddleware/ActivDatabase/FieldList.h [code] | Header file for the field list class
include/ActivMiddleware/ActivDatabase/FieldListObject.h [code] | Header file for the field list object class
include/ActivMiddleware/ActivDatabase/FieldSpecification.h [code] | Header file for the field specification class
include/ActivMiddleware/ActivDatabase/IIndex.h [code] | Header file for the index interface class
include/ActivMiddleware/ActivDatabase/IndexSpecification.h [code] | Header file for the index specification
include/ActivMiddleware/ActivDatabase/ITable.h [code] | Header file for the table interface class
include/ActivMiddleware/ActivDatabase/Key.h [code] | Header file for the key class
include/ActivMiddleware/ActivDatabase/ManagedTableFactory.h [code] | Header file for the managed table factory class
include/ActivMiddleware/ActivDatabase/Record.h [code] | Header file for the record class
include/ActivMiddleware/ActivDatabase/RemoteTableFactory.h [code] | Header file for the remote table factory class
include/ActivMiddleware/ActivDatabase/TableSpecification.h [code] | Header file for the table specification class
include/ActivMiddleware/ActivDatabase/UnmanagedTableFactory.h [code] | Header file for the unmanaged table factory class
include/ActivMiddleware/ActivFieldTypes/ActivFieldTypes.h [code] | Global functions from ActivFieldTypes
include/ActivMiddleware/ActivFieldTypes/BinaryArray.h [code] | Header file for the binary array class
include/ActivMiddleware/ActivFieldTypes/BinaryString.h [code] | Header file for the binary string class
include/ActivMiddleware/ActivFieldTypes/Blob.h [code] | Header file for the blob class
include/ActivMiddleware/ActivFieldTypes/CrcBlob.h [code] | Header file for the crc blob class
include/ActivMiddleware/ActivFieldTypes/Date.h [code] | Header file for the date class
include/ActivMiddleware/ActivFieldTypes/DateTime.h [code] | Header file for the date / time class
include/ActivMiddleware/ActivFieldTypes/External.h [code] | Import rules for ActivFieldTypes exports
include/ActivMiddleware/ActivFieldTypes/FieldTypeFactory.h [code] | Header file for the field type factory class
include/ActivMiddleware/ActivFieldTypes/IFieldType.h [code] | Header file for the field type interface class
include/ActivMiddleware/ActivFieldTypes/Rational.h [code] | Header file for the rational class
include/ActivMiddleware/ActivFieldTypes/SInt.h [code] | Header file for the signed integer class
include/ActivMiddleware/ActivFieldTypes/TextArray.h [code] | Header file for the text array class
include/ActivMiddleware/ActivFieldTypes/TextString.h [code] | Header file for the text string class
include/ActivMiddleware/ActivFieldTypes/Time.h [code] | Header file for the time class
include/ActivMiddleware/ActivFieldTypes/TRational.h [code] | Header file for the trended rational class
include/ActivMiddleware/ActivFieldTypes/UInt.h [code] | Header file for the unsigned integer class
include/ActivMiddleware/ActivFramework/ActivFramework.h [code] | Main header file for framework
include/ActivMiddleware/ActivFramework/Application.h [code] | Header file for base application class
include/ActivMiddleware/ActivFramework/ChildService.h [code] | Header file for child service class
include/ActivMiddleware/ActivFramework/Component.h [code] | Header file for component class
include/ActivMiddleware/ActivFramework/DirectoryWatchApi.h [code] | Header file for the directory watch api
include/ActivMiddleware/ActivFramework/External.h [code] | Import rules for ActivFramework exports
include/ActivMiddleware/ActivFramework/LicenseServiceApi.h [code] | Header file for the license service api class
include/ActivMiddleware/ActivFramework/LoggerDefinitions.h [code] | Header file for the common LoggerServiceApi / LoggerService definitions
include/ActivMiddleware/ActivFramework/LoggerServiceApi.h [code] | Header file for the logger service api class
include/ActivMiddleware/ActivFramework/Messages.h [code] | Header file for exported framework message classes
include/ActivMiddleware/ActivFramework/PubSubServiceApi.h [code] | Header file for the pubsub service api
include/ActivMiddleware/ActivFramework/RouterServiceApi.h [code] | Header file for router api
include/ActivMiddleware/ActivFramework/Service.h [code] | Header file for service class
include/ActivMiddleware/ActivFramework/ServiceApi.h [code] | Header file for service access api
include/ActivMiddleware/ActivFramework/ServiceTypes.h [code] | Header file for various service related classes
include/ActivMiddleware/ActivFramework/Subjects.h [code] | Header file for framework subject classes
include/ActivMiddleware/ActivFramework/ThinApplication.h [code] | Header file for thin application class
include/ActivMiddleware/ActivFramework/Timeband.h [code] | Header file for the timeband class.
include/ActivMiddleware/ActivFramework/TimeHelper.h [code] | Header file for time helper classes
include/ActivMiddleware/ActivFramework/TimerServiceApi.h [code] | Header file for the timer service api
include/ActivMiddleware/ActivFramework/UdpComponent.h [code] | Header file for udp component class
include/ActivMiddleware/ActivFramework/UiComponent.h [code] | Header file for the ui component class
include/ActivMiddleware/ActivFramework/UiIo.h [code] | Header file for the ui io class
include/ActivMiddleware/ActivFramework/UiMainComponent.h [code] | Header file for the main ui component class
include/ActivMiddleware/ActivFramework/UiMenu.h [code] | Header file for the ui menu class
include/ActivMiddleware/ActivFramework/UiPermissions.h [code] | Header file for the ui permissions class
include/ActivMiddleware/ActivIp/External.h [code] | Import rules for ActivIp exports
include/ActivMiddleware/ActivIp/IpAddress.h [code] | Header file for ip address class
include/ActivMiddleware/ActivIp/IpException.h [code] | Header file for the Ip exception class
include/ActivMiddleware/ActivIp/IpManager.h [code] | Header file for base ip manager class
include/ActivMiddleware/ActivIp/IpSocket.h [code] | Header file for ip socket class
include/ActivMiddleware/ActivIp/SocketWrapper.h [code] | Header file for socket wrapper class
include/ActivMiddleware/ActivIp/TcpListener.h [code] | Header file for tcp listener class
include/ActivMiddleware/ActivIp/TcpSocket.h [code] | Header file for tcp socket class
include/ActivMiddleware/ActivIp/UdpSocket.h [code] | Header file for udp socket class
include/ActivMiddleware/ActivIp/Windows/IpManager.h [code] | Header file for base ip manager class
include/ActivMiddleware/ActivIp/Windows/IpSocket.h [code] | Header file for ip socket class
include/ActivMiddleware/ActivIp/Windows/TcpListener.h [code] | Header file for tcp listener class
include/ActivMiddleware/ActivIp/Windows/TcpSocket.h [code] | Header file for tcp socket class
include/ActivMiddleware/ActivIp/Windows/UdpSocket.h [code] | Header file for udp socket class
include/ActivMiddleware/ActivIp/Windows/WsaBufHelper.h [code] | Header file for WSABUF helper class
include/ActivMiddleware/ActivSystem/ActivSystem.h [code] | Main ActivSystem header
include/ActivMiddleware/ActivSystem/Address.h [code] | Address header file
include/ActivMiddleware/ActivSystem/BasicTypes.h [code] | Basic types for ActivSystem
include/ActivMiddleware/ActivSystem/External.h [code] | Import rules for ActivSystem exports
include/ActivMiddleware/ActivSystem/HeapMessage.h [code] | Header file for heap message class
include/ActivMiddleware/ActivSystem/HeapMessageBuilder.h [code] | Header file for heap message / message builder class
include/ActivMiddleware/ActivSystem/HeapMessageDeserializer.h [code] | Header file for the heap message deserializer template class
include/ActivMiddleware/ActivSystem/HeapPool.h [code] | Header file for heap pool class
include/ActivMiddleware/ActivSystem/IEndPoint.h [code] | Header file for abstract endpoint class
include/ActivMiddleware/ActivSystem/IHeap.h [code] | Header file for abstract heap class
include/ActivMiddleware/ActivSystem/IProcess.h [code] | Header file for process interface class
include/ActivMiddleware/ActivSystem/ISystem.h [code] | Header file for abstract system class
include/ActivMiddleware/ActivSystem/ManagedEndPoint.h [code] | Header file for managed endpoint class
include/ActivMiddleware/ActivSystem/MessageTypes.h [code] | Message types
include/ActivMiddleware/ActivSystem/Port.h [code] | Header file for port class
include/ActivMiddleware/ActivSystem/PostMessageHelper.h [code] | Header file for PostMessageHelper
include/ActivMiddleware/ActivSystem/RequestId.h [code] | Header file for request id class
include/ActivMiddleware/ActivSystem/ScopedAddress.h [code] | ScopedAddress header file
include/ActivMiddleware/ActivSystem/Subject.h [code] | Subject type header file
include/ActivMiddleware/ActivSystem/SyncRequestId.h [code] | Header file for synchronous request id class
include/ActivMiddleware/ActivSystem/SystemException.h [code] | Header file for ActivSystem exception class
include/ActivMiddleware/ActivSystem/SystemFactory.h [code] | Header file for system factory class
include/ActivMiddleware/Config/Config.h [code] | Processor, compiler and platform selection header file
include/ActivMiddleware/Config/Compilers/GCC.h [code] | GNU C++ configuration file
include/ActivMiddleware/Config/Compilers/Intel.h [code] | Intel C++ Compiler configuration file
include/ActivMiddleware/Config/Compilers/SunPro.h [code] | SunPro C++ configuration file
include/ActivMiddleware/Config/Compilers/VisualC.h [code] | Microsoft Visual C++ configuration file
include/ActivMiddleware/Config/Platforms/Bsd.h [code] | BSD configuration file
include/ActivMiddleware/Config/Platforms/Linux.h [code] | Linux configuration file
include/ActivMiddleware/Config/Platforms/OSX.h [code] | OSX configuration file
include/ActivMiddleware/Config/Platforms/Solaris.h [code] | Solaris configuration file
include/ActivMiddleware/Config/Platforms/Windows.h [code] | Microsoft Windows configuration file
include/ActivMiddleware/Misc/BitFields.h [code] | Header file for bit field helper classes
include/ActivMiddleware/Misc/CrtHelper.h [code] | Workarounds for crt disparities across platforms
include/ActivMiddleware/Misc/CurlFtpHelper.h [code] | Header file for the curl FTP helper class which user cUrl and ftpparser
include/ActivMiddleware/Misc/Des3Helper.h [code] | Helper class for DES3 functions in OpenSsl
include/ActivMiddleware/Misc/DesHelper.h [code] | Helper class for DES functions in OpenSsl
include/ActivMiddleware/Misc/DynamicLibraryLoader.h [code] | Header file for dynamic library loader helper classes
include/ActivMiddleware/Misc/FtpHelper.h [code] | Header file for the FTP helper class which user cUrl and ftpparser
include/ActivMiddleware/Misc/FtpParse.h [code] |
include/ActivMiddleware/Misc/FunctionObjects.h [code] | Header file for function objects
include/ActivMiddleware/Misc/HandleManager.h [code] | Header file for the handle manager class
include/ActivMiddleware/Misc/IFtpHelper.h [code] | Header file for the FTP helper class which user cUrl and ftpparser
include/ActivMiddleware/Misc/IntrusivePtrHelper.h [code] | Helper for using intrusive pointer class in a single threaded environment
include/ActivMiddleware/Misc/MemoryHelper.h [code] | Header file for the memory helper functions
include/ActivMiddleware/Misc/ObjectPool.h [code] | Class to cache a number of objects to avoid constructing/destructing them continually
include/ActivMiddleware/Misc/ScopedHelper.h [code] | Helper classes for creating scoped wrappers around other objects
include/ActivMiddleware/Misc/SerializableBuffer.h [code] | Serializable buffer
include/ActivMiddleware/Misc/SerializableContainerHelper.h [code] | Classes to help serialize STL containers
include/ActivMiddleware/Misc/Singleton.h [code] | Header file for singleton template
include/ActivMiddleware/Misc/SmtpHelper.h [code] | Smtp helper class
include/ActivMiddleware/Misc/StlHelper.h [code] | Work arounds for STL disparities across platforms, plus various helpers
include/ActivMiddleware/Misc/TemplateFunctions.h [code] | Header file for miscellaneous template functions with no other home
include/ActivMiddleware/Misc/WinFtpHelper.h [code] | Header file for the win FTP helper class which uses wininet
include/ActivMiddleware/Misc/Detail/DynamicLibraryLoaderDetail.h [code] | Header file for dynamic library loader helper implementation details
include/ActivMiddleware/Misc/Detail/SerializableContainerHelperDetail.h [code] | Classes to help serialize STL containers
include/ActivMiddleware/Misc/Detail/SerializableContainerHelperSpecializations.h [code] | Classes to help serialize STL containers
Generated on Wed Oct 8 14:02:12 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform

MessageClasses.h File Reference

Message classes for content platform. More...

#include "ActivMiddleware/ActivSystem/MessageTypes.h"

Go to the source code of this file.

Namespaces

namespace | Activ

Defines

#define | ACTIV_CONTENT_PLATFORM_MESSAGE_CLASS_LIST(d)
List of available message classes used by ActivContentPlatform.

Functions

ContentGatewayApi
RefreshRequester Ingest
Workstation Service 		Activ::ACTIV_DECLARE_MESSAGE_CLASS (40, MESSAGE_CLASS_CONTRIBUTION_GATEWAY,"ContributionGateway") ACTIV_DECLARE_MESSAGE_CLASS(41
ContentGatewayApi
RefreshRequester Ingest 		Activ::ACTIV_DECLARE_MESSAGE_CLASS (38, MESSAGE_CLASS_NEWS_SERVER,"News Server") ACTIV_DECLARE_MESSAGE_CLASS(39
ContentGatewayApi RefreshRequester | Activ::ACTIV_DECLARE_MESSAGE_CLASS (36, MESSAGE_CLASS_HISTORY_MANAGER,"History Manager") ACTIV_DECLARE_MESSAGE_CLASS(37
ContentGatewayApi | Activ::ACTIV_DECLARE_MESSAGE_CLASS (34, MESSAGE_CLASS_SYMBOL_DIRECTORY,"SymbolDirectory") ACTIV_DECLARE_MESSAGE_CLASS(35
Activ::ACTIV_DECLARE_MESSAGE_CLASS (32, MESSAGE_CLASS_CONTENT_SERVER,"ContentServer") ACTIV_DECLARE_MESSAGE_CLASS(33
Declare list of constant message class values.

Variables

Activ::MESSAGE_CLASS_CONTENT_GATEWAY_API
ContentGatewayApi RefreshRequester | Activ::MESSAGE_CLASS_INGEST
ContentGatewayApi
RefreshRequester Ingest
Workstation Service 		Activ::MESSAGE_CLASS_LOAD_BALANCER
ContentGatewayApi | Activ::MESSAGE_CLASS_REFRESH_REQUESTER
ContentGatewayApi
RefreshRequester Ingest 		Activ::MESSAGE_CLASS_WORKSTATION_SERVICE

Detailed Description

Message classes for content platform.

Log

Definition in file MessageClasses.h.

Define Documentation

#define ACTIV_CONTENT_PLATFORM_MESSAGE_CLASS_LIST ( d )

Value:

d(32,   MESSAGE_CLASS_CONTENT_SERVER,       "ContentServer")            \
    d(33,   MESSAGE_CLASS_CONTENT_GATEWAY_API,  "ContentGatewayApi")        \
    d(34,   MESSAGE_CLASS_SYMBOL_DIRECTORY,     "SymbolDirectory")          \
    d(35,   MESSAGE_CLASS_REFRESH_REQUESTER,    "RefreshRequester")         \
    d(36,   MESSAGE_CLASS_HISTORY_MANAGER,      "History Manager")          \
    d(37,   MESSAGE_CLASS_INGEST,               "Ingest")                   \
    d(38,   MESSAGE_CLASS_NEWS_SERVER,          "News Server")              \
    d(39,   MESSAGE_CLASS_WORKSTATION_SERVICE,  "Workstation Service")      \
    d(40,   MESSAGE_CLASS_CONTRIBUTION_GATEWAY, "ContributionGateway")      \
    d(41,   MESSAGE_CLASS_LOAD_BALANCER,        "LoadBalancer")             \
    d(42,   MESSAGE_CLASS_CONTENT_GATEWAY,      "ContentGateway")
List of available message classes used by ActivContentPlatform.

Definition at line 21 of file MessageClasses.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivContentGatewayApi

ActivContentGatewayApi.h File Reference

ActivContentGatewayApi main header. More...

#include "ActivContentPlatform/ActivContentGatewayApi/ContentGatewayClient.h"
#include "ActivContentPlatform/ActivContentGatewayApi/RecordUpdateHelper.h"
#include "ActivContentPlatform/ActivContentGatewayApi/NewsUpdateHelper.h"
#include "ActivContentPlatform/ActivContentGatewayApi/FieldListValidator.h"

Go to the source code of this file.

Defines

#define | ACTIV_CONTENT_GATEWAY_API_VERSION_STRING "99.99.99.99"
ActivContentGatewayApi version string.
#define | ACTIV_CONTENT_GATEWAY_API_VERSION_VALUE ACTIV_MAKE_VERSION_VALUE(99, 99, 99, 99)
ActivContentGatewayApi version value.

Detailed Description

ActivContentGatewayApi main header.

Log

Definition in file ActivContentGatewayApi.h.

Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivContentGatewayApi

ContentGatewayClient.h File Reference

Content gateway client. More...

#include "ActivContentPlatform/ActivContentGatewayApi/External.h"
#include "ActivContentPlatform/ActivContentGatewayApi/RealtimeRequestHelper.h"
#include "ActivContentPlatform/ActivContentGatewayApi/TimeSeriesRequestHelper.h"
#include "ActivContentPlatform/ActivContentGatewayApi/SymbolDirectoryRequestHelper.h"
#include "ActivContentPlatform/ActivContentGatewayApi/NewsRequestHelper.h"
#include "ActivContentPlatform/ActivContentGatewayApi/MetaDataRequestHelper.h"
#include "ActivContentPlatform/ActivContentGatewayApi/IRealtimeResponses.h"
#include "ActivContentPlatform/ActivContentGatewayApi/ITimeSeriesResponses.h"
#include "ActivContentPlatform/ActivContentGatewayApi/ISymbolDirectoryResponses.h"
#include "ActivContentPlatform/ActivContentGatewayApi/INewsResponses.h"

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::ContentGatewayApi

Classes

class | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
Content gateway client class. More...
class | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::ApiInfo
Information returned from GetApiInfo(). More...
class | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::ConnectParameters
Parameters for Connect(). More...
class | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::Settings
Settings for ContentGatewayClient class. More...

Defines

#define | ACTIV_CONTENT_GATEWAY_CLIENT_DEFAULT_HEAP_SIZE { { 10, 1000 }, { 100, 50000 }, { 200, 10000 }, { 500, 10000 }, { 10000, 1000 }, { 25000, 500 } }
#define | ACTIV_CONTENT_GATEWAY_CLIENT_STATE_LIST(d)
List of client states.
#define | POLICY_TYPE_LIST(d)
Possible actions to take if connection to gateway is down.

Detailed Description

Content gateway client.

Log

Definition in file ContentGatewayClient.h.

Define Documentation

#define ACTIV_CONTENT_GATEWAY_CLIENT_STATE_LIST ( d )

Value:

d(STATE_INITIALIZED, "initialized")             \
        d(STATE_W4_CONNECT, "w4 connect")               \
        d(STATE_LOGGED_ON, "logged on")                 \
        d(STATE_W4_DISCONNECT, "w4 disconnect")
List of client states.

Definition at line 68 of file ContentGatewayClient.h.

#define POLICY_TYPE_LIST ( d )

Value:

d(POLICY_RETRY)                                         \
            d(POLICY_FIND_NEXT_ALTERNATIVE)         \
            d(POLICY_FIND_RANDOM_ALTERNATIVE)
Possible actions to take if connection to gateway is down.

Definition at line 121 of file ContentGatewayClient.h.

Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivContentGatewayApi

External.h File Reference

Import rules for ActivContentGatewayApi exports. More...

#include "ActivMiddleware/ActivFramework/ActivFramework.h"
#include "ActivContentPlatform/ActivContentGatewayApiCommon/RealtimeTypes.h"
#include "ActivContentPlatform/ActivContentGatewayApiCommon/TimeSeriesTypes.h"
#include "ActivContentPlatform/ActivContentGatewayApiCommon/SymbolDirectoryTypes.h"
#include "ActivContentPlatform/ActivContentGatewayApiCommon/NewsTypes.h"
#include "ActivContentPlatform/ActivContentGatewayApiCommon/Tick.h"
#include "ActivContentPlatform/ActivContentGatewayApiCommon/IntradayBar.h"
#include "ActivContentPlatform/ActivContentGatewayApiCommon/HistoryBar.h"
#include "ActivContentPlatform/ActivFeedCommon/UpdateIds.h"
#include "ActivContentPlatform/ActivFeedCommon/EventTypes.h"

Go to the source code of this file.

Defines

#define ACTIV_CONTENT_GATEWAY_API ACTIV_IMPORT_DLL

Detailed Description

Import rules for ActivContentGatewayApi exports.

Log

Definition in file External.h.

Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivContentGatewayApi

FieldListValidator.h File Reference

Header file for the field list validator class. More...

#include "ActivContentPlatform/ActivContentGatewayApi/External.h"
#include "ActivContentPlatform/ActivFeedApiCommon/FieldListValidator.h"

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::ContentGatewayApi

Classes

class | Activ::ContentPlatform::ContentGatewayApi::FieldListValidator
Field list validator class. More...

Detailed Description

Header file for the field list validator class.

Log

Definition in file FieldListValidator.h.

Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivContentGatewayApi

INewsResponses.h File Reference

Callback interface for news responses. More...

#include "ActivContentPlatform/ActivContentGatewayApi/External.h"

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::ContentGatewayApi

Classes

class | Activ::ContentPlatform::ContentGatewayApi::INewsResponses
Interface for news response callbacks. More...

Detailed Description

Callback interface for news responses.

Log

Definition in file INewsResponses.h.

Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivContentGatewayApi

IRealtimeResponses.h File Reference

Callback interface for realtime data request responses. More...

#include "ActivContentPlatform/ActivContentGatewayApi/External.h"

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::ContentGatewayApi

Classes

class | Activ::ContentPlatform::ContentGatewayApi::IRealtimeResponses
Interface for realtime data response callbacks. More...

Detailed Description

Callback interface for realtime data request responses.

Log

Definition in file IRealtimeResponses.h.

Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivContentGatewayApi

ISymbolDirectoryResponses.h File Reference

Callback interface for symbol directory request responses. More...

#include "ActivContentPlatform/ActivContentGatewayApi/External.h"

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::ContentGatewayApi

Classes

class | Activ::ContentPlatform::ContentGatewayApi::ISymbolDirectoryResponses
Interface for symbol directory response callbacks. More...

Detailed Description

Callback interface for symbol directory request responses.

Log

Definition in file ISymbolDirectoryResponses.h.

Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivContentGatewayApi

ITimeSeriesResponses.h File Reference

Callback interface for time series request responses. More...

#include "ActivContentPlatform/ActivContentGatewayApi/External.h"

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::ContentGatewayApi

Classes

class | Activ::ContentPlatform::ContentGatewayApi::ITimeSeriesResponses
Interface for time series request callbacks. More...

Detailed Description

Callback interface for time series request responses.

Log

Definition in file ITimeSeriesResponses.h.

Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivContentGatewayApi

MetaDataRequestHelper.h File Reference

Helper class for metadata requests. More...

#include "ActivContentPlatform/ActivContentGatewayApi/External.h"
#include "ActivContentPlatform/ActivContentGatewayApiCommon/MetaDataTypes.h"
#include "ActivMiddleware/ActivDatabase/TableSpecification.h"

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::ContentGatewayApi

Classes

class | Activ::ContentPlatform::ContentGatewayApi::MetaDataRequestHelper
Metadata request helper class. More...

Detailed Description

Helper class for metadata requests.

Log

Definition in file MetaDataRequestHelper.h.

Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivContentGatewayApi

NewsRequestHelper.h File Reference

Helper class for news requests. More...

#include "ActivContentPlatform/ActivContentGatewayApi/External.h"

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::ContentGatewayApi

Classes

class | Activ::ContentPlatform::ContentGatewayApi::NewsRequestHelper
News request helper class. More...

Detailed Description

Helper class for news requests.

Log

Definition in file NewsRequestHelper.h.

Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivContentGatewayApi

NewsUpdateHelper.h File Reference

News update helper class. More...

#include "ActivContentPlatform/ActivContentGatewayApi/External.h"

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::ContentGatewayApi

Classes

class | Activ::ContentPlatform::ContentGatewayApi::NewsUpdateHelper
News update helper class. More...

Detailed Description

News update helper class.

Log

Definition in file NewsUpdateHelper.h.

Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivContentGatewayApi

RealtimeRequestHelper.h File Reference

Helper class for realtime requests. More...

#include "ActivContentPlatform/ActivContentGatewayApi/External.h"

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::ContentGatewayApi

Classes

class | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestHelper< MESSAGE_TYPE_VALUE, REQUEST_PARAMETERS >
Realtime request helper class. More...

Detailed Description

Helper class for realtime requests.

Log

Definition in file RealtimeRequestHelper.h.

Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivContentGatewayApi

RecordUpdateHelper.h File Reference

Record update helper class. More...

#include "ActivContentPlatform/ActivContentGatewayApi/External.h"

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::ContentGatewayApi

Classes

class | Activ::ContentPlatform::ContentGatewayApi::RecordUpdateHelper
Record update helper class. More...

Detailed Description

Record update helper class.

Log

Definition in file RecordUpdateHelper.h.

Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivContentGatewayApi

SymbolDirectoryRequestHelper.h File Reference

Helper class for symbol directory requests. More...

#include "ActivContentPlatform/ActivContentGatewayApi/External.h"

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::ContentGatewayApi

Classes

class | Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryRequestHelper
Symbol directory helper class. More...

Detailed Description

Helper class for symbol directory requests.

Log

Definition in file SymbolDirectoryRequestHelper.h.

Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivContentGatewayApi

TimeSeriesRequestHelper.h File Reference

Helper class for time series requests. More...

#include "ActivContentPlatform/ActivContentGatewayApi/External.h"

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::ContentGatewayApi

Classes

class | Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestHelper< FIRST_MESSAGE_TYPE_VALUE, NEXT_MESSAGE_TYPE_VALUE, FIELD_SET_TYPE >
Time series helper class. More...

Detailed Description

Helper class for time series requests.

Log

Definition in file TimeSeriesRequestHelper.h.

Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivContentGatewayApiCommon

External.h File Reference

Import rules for ActivContentGatewayApiCommon exports. More...

#include "ActivMiddleware/ActivFramework/ActivFramework.h"

Go to the source code of this file.

Defines

#define ACTIV_CONTENT_GATEWAY_API_COMMON_API ACTIV_IMPORT_DLL

Detailed Description

Import rules for ActivContentGatewayApiCommon exports.

Log

Definition in file External.h.

Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivContentGatewayApiCommon

FieldSet.h File Reference

Header file for the Field Set base class. More...

#include "ActivContentPlatform/ActivContentGatewayApiCommon/External.h"
#include "ActivContentPlatform/ActivFeedCommon/FieldIds.h"
#include "ActivMiddleware/ActivFieldTypes/IFieldType.h"
#include "ActivMiddleware/ActivFieldTypes/Rational.h"
#include "ActivMiddleware/Misc/SerializableContainerHelper.h"

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::ContentGatewayApi

Classes

class | Activ::ContentPlatform::ContentGatewayApi::FieldSet
Field Set base class. More...
class | Activ::ContentPlatform::ContentGatewayApi::FieldSetList< OBJECT_TYPE, COUNT_TYPE >

Defines

#define | ACTIV_FIELD_SET_FILTER_STATUS_LIST(d)
The list of field set types and their string representation.
#define | ACTIV_FIELD_SET_TYPE_LIST(d)
The list of field set types and their string representation.
#define | BASE_TYPE_LIST(d)
#define | FIELDSETLIST_FIND_MODE_LIST(d)
Update return codes.
#define | HISTORY_SYMBOLSIZE 20
#define | UPDATE_FIELDSET_STATUS_LIST(d)
Update return codes.

Enumerations

enum | FieldSetType { ACTIV_DECLARE_ELEMENT_1_WITH_COMMA }

Detailed Description

Header file for the Field Set base class.

Log

Definition in file FieldSet.h.

Define Documentation

#define ACTIV_FIELD_SET_FILTER_STATUS_LIST ( d )

Value:

d(FILTER_STATUS_OK,                 "Ok"            )   \
    d(FILTER_STATUS_IGNORE,             "Ignore"        )   \
    d(FILTER_STATUS_DONE,               "Done"          )
The list of field set types and their string representation.

Definition at line 59 of file FieldSet.h.

#define ACTIV_FIELD_SET_TYPE_LIST ( d )

Value:

d(FIELD_SET_TYPE_NULL,              "Null"                  )   \
    d(FIELD_SET_TYPE_TICK,              "Tick"                  )   \
    d(FIELD_SET_TYPE_INTRADAY_BAR,      "IntradayBar"           )   \
    d(FIELD_SET_TYPE_HISTORY_BAR,       "HistoryBar"            )   \
    d(FIELD_SET_TYPE_CLOSING_BAR,       "ClosingBar"            )   \
    d(FIELD_SET_TYPE_OPTION_BAR,        "OptionBar"             )
The list of field set types and their string representation.

Definition at line 38 of file FieldSet.h.

#define BASE_TYPE_LIST ( d )

Value:

d(BASE_TYPE_LOW,                    "Low"           )   \
    d(BASE_TYPE_OPEN,                   "Open"          )   \
    d(BASE_TYPE_HIGH,                   "High"          )   \
    d(BASE_TYPE_CLOSE,                  "Close"         )

Definition at line 68 of file FieldSet.h.

#define FIELDSETLIST_FIND_MODE_LIST ( d )

Value:

d(FIND_MODE_LATER,              "The first one later in time"               )   \
    d(FIND_MODE_EQUAL_OR_LATER,     "The first one match or later in time"      )   \
    d(FIND_MODE_EQUAL,              "exact match in time"                       )   \
    d(FIND_MODE_EQUAL_OR_EARLIER,   "The first one match or earlierer in time"  )   \
    d(FIND_MODE_EARLIER,            "The first earlier in time"                 )
Update return codes.

Definition at line 87 of file FieldSet.h.

#define UPDATE_FIELDSET_STATUS_LIST ( d )

Value:

d(UPDATE_STATUS_OK,                 "Ok"            )   \
    d(UPDATE_STATUS_FLUSH,              "Flush"         )   \
    d(UPDATE_STATUS_IGNORE,             "Ignore"        )
Update return codes.

Definition at line 78 of file FieldSet.h.

Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivContentGatewayApiCommon

HistoryBar.h File Reference

History Bar Field Set. More...

#include "External.h"
#include "ActivContentPlatform/ActivContentGatewayApiCommon/FieldSet.h"
#include "ActivContentPlatform/ActivContentGatewayApiCommon/TimeSeriesTypes.h"
#include "ActivMiddleware/ActivDatabase/FieldSpecification.h"
#include "ActivMiddleware/ActivFieldTypes/Date.h"
#include "ActivMiddleware/ActivFieldTypes/Time.h"
#include "ActivMiddleware/ActivFieldTypes/Rational.h"
#include "ActivMiddleware/Misc/SerializableContainerHelper.h"

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::ContentGatewayApi
namespace | Activ::Database

Classes

class | Activ::ContentPlatform::ContentGatewayApi::HistoryBar
History Bar Field Set class. More...

Defines

#define | ACTIV_DECLARE_BYTES(value, id) static const byte_t id = value;
#define | ACTIV_HISTORY_ADJUSTMENT_TYPE_LIST(d)
Enumeration of all adjustment types.
#define | ACTIV_HISTORY_BAR_FLAG_LIST(d)

Typedefs

typedef FieldSetList
< HistoryBar, uint16_t > 		Activ::ContentPlatform::ContentGatewayApi::HistoryBarList

Detailed Description

History Bar Field Set.

Log

Definition in file HistoryBar.h.

Define Documentation

#define ACTIV_HISTORY_ADJUSTMENT_TYPE_LIST ( d )

Value:

d(ADJUSTEMENT_TYPE_RATIO_PRICE_VOLUME,  "Same as split.  x ratio for volume.  / ratio for price"    )   \
    d(ADJUSTEMENT_TYPE_RATIO_PRICE_ONLY,    "adjustment for price only"                                 )   \
    d(ADJUSTEMENT_TYPE_RATIO_VOLUME_ONLY,   "adjustment for volume only"                                )   \
    d(ADJUSTEMENT_TYPE_VALUE_PRICE_ONLY,    "Add adjustment amount to price"                            )   \
    d(ADJUSTEMENT_TYPE_VALUE_VOLUME_ONLY,   "Add adjustment amount to volume"                           )   \
    d(ADJUSTEMENT_TYPE_COPY,                "Copy data from source symbol"                              )   \
    d(ADJUSTEMENT_TYPE_DELETE,              "Delete data"                                               )
Enumeration of all adjustment types.

Definition at line 27 of file HistoryBar.h.

#define ACTIV_HISTORY_BAR_FLAG_LIST ( d )

Value:

d(0x04, HISTORY_BAR_TOTAL_PRICE)    \
        d(0x08, HISTORY_BAR_TOTAL_VALUE)    \
        d(0x10, HISTORY_BAR_TOTAL_VOLUME)   \
        d(0x20, HISTORY_BAR_OPEN_INTEREST)  \
        d(0x40, HISTORY_BAR_TICK_COUNT)

Definition at line 623 of file HistoryBar.h.

Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivContentGatewayApiCommon

IntradayBar.h File Reference

Intraday Bar Field Set. More...

#include "External.h"
#include "ActivContentPlatform/ActivContentGatewayApiCommon/FieldSet.h"
#include "ActivMiddleware/ActivFieldTypes/Date.h"
#include "ActivMiddleware/ActivFieldTypes/Time.h"
#include "ActivMiddleware/ActivFieldTypes/Rational.h"
#include "ActivMiddleware/Misc/SerializableContainerHelper.h"

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::ContentGatewayApi

Classes

class | Activ::ContentPlatform::ContentGatewayApi::IntradayBar
Intraday Bar Field Set class. More...

Defines

#define | ACTIV_DECLARE_BYTES(value, id) static const byte_t id = value;
#define | ACTIV_INTRADAY_BAR_FLAG_LIST(d)

Typedefs

typedef FieldSetList
< IntradayBar, uint16_t > 		Activ::ContentPlatform::ContentGatewayApi::IntradayBarList

Detailed Description

Intraday Bar Field Set.

Log

Definition in file IntradayBar.h.

Define Documentation

#define ACTIV_INTRADAY_BAR_FLAG_LIST ( d )

Value:

d(0x01, NONE_REGULAR_HOUR_TRADE_BIT)        \
        d(0x02, VWAP_ONLY_BIT)

Definition at line 46 of file IntradayBar.h.

Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivContentGatewayApiCommon

MetaDataTypes.h File Reference

Types for metadata. More...

#include "ActivContentPlatform/ActivContentGatewayApiCommon/External.h"
#include "ActivContentPlatform/ActivFeedCommon/TableTypes.h"
#include "ActivContentPlatform/ActivFeedCommon/FieldIds.h"
#include "ActivContentPlatform/ActivFeedCommon/UniversalFieldHelper.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedPermissioning/PermissionInfo.h"
#include "ActivMiddleware/ActivFieldTypes/UInt.h"
#include <vector>
#include <map>

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::ContentGatewayApi

Classes

class | Activ::ContentPlatform::ContentGatewayApi::PermissionInfo
Information about client's permissioning. More...
class | Activ::ContentPlatform::ContentGatewayApi::RelationshipInfo
Info about available relationship ids. More...
class | Activ::ContentPlatform::ContentGatewayApi::TableInfo
Info about available tables. More...

Typedefs

typedef std::vector
< RelationshipInfo > 		Activ::ContentPlatform::ContentGatewayApi::RelationshipInfoList
List of RelationshipInfos.
typedef std::vector< TableInfo > | Activ::ContentPlatform::ContentGatewayApi::TableInfoList
List of TableInfos.
typedef std::map
< Feed::FieldId,
Feed::UniversalFieldHelper > 		Activ::ContentPlatform::ContentGatewayApi::UniversalFieldHelperMap
Map from field id to information about that field id.

Detailed Description

Types for metadata.

Log

Definition in file MetaDataTypes.h.

Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivContentGatewayApiCommon

NewsTypes.h File Reference

Types for news data. More...

#include "ActivContentPlatform/ActivContentGatewayApiCommon/External.h"
#include "ActivContentPlatform/ActivContentGatewayApiCommon/Types.h"
#include "ActivContentPlatform/ActivFeedCommon/UpdateIds.h"
#include "ActivMiddleware/ActivFieldTypes/Date.h"

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::ContentGatewayApi

Classes

class | Activ::ContentPlatform::ContentGatewayApi::NewsRequestParameters
News request parameters. More...
class | Activ::ContentPlatform::ContentGatewayApi::NewsResponseParameters
News response parameters. More...
class | Activ::ContentPlatform::ContentGatewayApi::NewsStory
News story class. More...
class | Activ::ContentPlatform::ContentGatewayApi::NewsUpdate
News update class. More...

Defines

#define | ACTIV_DECLARE_FLAGS(value, id) static const Flags id = value;
#define | ACTIV_NEWS_REQUEST_FLAG_LIST(d)
#define | ACTIV_NEWS_UPDATE_FLAG_LIST(d)

Typedefs

typedef std::vector< NewsStory > | Activ::ContentPlatform::ContentGatewayApi::NewsStoryList
List of NewsStory.
typedef uint8_t | Activ::ContentPlatform::ContentGatewayApi::RecordsPerResponseCount
Type for counting records per response.

Detailed Description

Types for news data.

Log

Definition in file NewsTypes.h.

Define Documentation

#define ACTIV_NEWS_REQUEST_FLAG_LIST ( d )

Value:

d(0x00, FLAG_NONE)                                                          \
        d(0x01, FLAG_SUBSCRIBE)                     \
        d(0x02, FLAG_INCLUDE_EXPIRED)

Definition at line 52 of file NewsTypes.h.

#define ACTIV_NEWS_UPDATE_FLAG_LIST ( d )

Value:

d(0x00, FLAG_NONE)                                                              \
        d(0x01, FLAG_DELETE)

Definition at line 123 of file NewsTypes.h.

Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivContentGatewayApiCommon

OptionBar.h File Reference

Option Bar Field Set. More...

#include "ActivContentPlatform/ActivContentGatewayApiCommon/External.h"
#include "ActivContentPlatform/ActivContentGatewayApiCommon/FieldSet.h"
#include "ActivMiddleware/ActivFieldTypes/Date.h"
#include "ActivMiddleware/ActivFieldTypes/Time.h"
#include "ActivMiddleware/ActivFieldTypes/Rational.h"
#include "ActivMiddleware/Misc/SerializableVector.h"

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::ContentGatewayApi

Classes

class | Activ::ContentPlatform::ContentGatewayApi::OptionBar
Option Bar Field Set class. More...

Defines

#define | ACTIV_DECLARE_BYTES(value, id) static const byte_t id = value;
#define | ACTIV_OPTION_BAR_FLAG_LIST(d)

Typedefs

typedef SerializableVector
< OptionBar, uint16_t > 		Activ::ContentPlatform::ContentGatewayApi::OptionBarList

Detailed Description

Option Bar Field Set.

Log

Definition in file OptionBar.h.

Define Documentation

#define ACTIV_OPTION_BAR_FLAG_LIST ( d )

Value:

d(0x10, OPTION_BAR_TOTAL_VOLUME)        \
        d(0x20, OPTION_BAR_OPEN_INTEREST)

Definition at line 414 of file OptionBar.h.

Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivContentGatewayApiCommon

RealtimeTypes.h File Reference

Types for realtime data. More...

#include "ActivContentPlatform/ActivContentGatewayApiCommon/External.h"
#include "ActivContentPlatform/ActivContentGatewayApiCommon/Types.h"
#include "ActivContentPlatform/ActivFeedCommon/FieldIds.h"
#include "ActivContentPlatform/ActivFeedCommon/RelationshipIds.h"
#include "ActivContentPlatform/ActivFeedCommon/UpdateIds.h"
#include "ActivContentPlatform/ActivFeedCommon/EventTypes.h"
#include "ActivContentPlatform/ActivFeedCommon/PermissionLevels.h"
#include "boost/integer_traits.hpp"

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::ContentGatewayApi

Classes

class | Activ::ContentPlatform::ContentGatewayApi::MatchRequestParameters
Request parameters for match request. More...
class | Activ::ContentPlatform::ContentGatewayApi::PatternMatchListRequestParameters
Request parameters for pattern match on symbol based requests. More...
class | Activ::ContentPlatform::ContentGatewayApi::PatternMatchRequestParameters
Request parameters for pattern match on symbol based requests. More...
class | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters
Request parameters that apply to all requests. More...
class | Activ::ContentPlatform::ContentGatewayApi::RealtimeResponseParameters
Response parameters from a realtime request. More...
class | Activ::ContentPlatform::ContentGatewayApi::RecordUpdate
Record update. More...
class | Activ::ContentPlatform::ContentGatewayApi::RequestBlock
Request block. More...
class | Activ::ContentPlatform::ContentGatewayApi::ResponseBlock
Response block. More...
class | Activ::ContentPlatform::ContentGatewayApi::SubscribeFeedParameters
Parameters for SubscribeToFeed() method. More...
class | Activ::ContentPlatform::ContentGatewayApi::SubscribeParameters
Parameters for specifying subscription options. More...
class | Activ::ContentPlatform::ContentGatewayApi::SubscribeTableParameters
Parameters for SubscribeToTable() method. More...
class | Activ::ContentPlatform::ContentGatewayApi::SymbolIdCountRequestParameters
Request parameters for SymbolId based requests with count (for get next, previous). More...
class | Activ::ContentPlatform::ContentGatewayApi::SymbolIdListMatchRequestParameters
Request parameters for multiple match request with multiple symbols. More...
class | Activ::ContentPlatform::ContentGatewayApi::SymbolIdListRequestParameters
Request parameters for SymbolIdList based requests. More...
class | Activ::ContentPlatform::ContentGatewayApi::SymbolIdMatchRequestParameters
Request parameters for match request with single symbol. More...
class | Activ::ContentPlatform::ContentGatewayApi::SymbolIdRequestParameters
Request parameters for SymbolId based requests. More...
class | Activ::ContentPlatform::ContentGatewayApi::TableNumberRequestParameters
Request parameters for table number based requests. More...

Defines

#define | ACTIV_DECLARE_FLAGS(value, id) static const Flags id = value;
#define | ACTIV_DECLARE_REQUEST_FLAGS(value, id) static const RequestFlags id = value;
#define | ACTIV_DECLARE_RESPONSE_BLOCK_STATUS(value, id, name) static const Status id = value;
Macro to declare constant response statuses.
#define | ACTIV_PATTERN_MATCH_REQUEST_PARAMETERS_REQUEST_FLAG_LIST(d)
#define | ACTIV_REALTIME_REQUEST_PARAMETERS_FLAG_LIST(d)
#define | ACTIV_RECORD_UPDATE_FLAG_LIST(d)
#define | ACTIV_REQUEST_BLOCK_FLAG_LIST(d)
#define | ACTIV_REQUEST_FLAG_LIST(d)
#define | ACTIV_RESPONSE_BLOCK_FLAG_LIST(d)
List of response block flag values.
#define | ACTIV_RESPONSE_BLOCK_STATUS_LIST(d)
List of response block status values.
#define | ACTIV_SUBSCRIBE_PARAMETERS_SUBSCRIBE_TYPE_LIST(d)
#define | MATCH_REQUEST_MATCH_TYPE_LIST(d)
Match types.

Typedefs

typedef uint8_t | Activ::ContentPlatform::ContentGatewayApi::RequestBlockCount
Type for counting request blocks.
typedef std::vector< RequestBlock > | Activ::ContentPlatform::ContentGatewayApi::RequestBlockList
List of RequestBlock in contiguous form.
typedef uint8_t | Activ::ContentPlatform::ContentGatewayApi::ResponseBlockCount
Type for counting response blocks.
typedef std::vector
< ResponseBlock > 		Activ::ContentPlatform::ContentGatewayApi::ResponseBlockList
List of response blocks.

Detailed Description

Types for realtime data.

Log

Definition in file RealtimeTypes.h.

Define Documentation

#define ACTIV_PATTERN_MATCH_REQUEST_PARAMETERS_REQUEST_FLAG_LIST ( d )

Value:

d(0x0000,   REQUEST_FLAG_NONE)                                                                              \
        d(0x0001,   REQUEST_FLAG_WATCH)                                     \
        d(0x0002,   REQUEST_FLAG_REVERSE_ORDER)

Definition at line 297 of file RealtimeTypes.h.

#define ACTIV_REALTIME_REQUEST_PARAMETERS_FLAG_LIST ( d )

Value:

d(0x0000,   FLAG_NONE)                                                                                                          \
        d(0x0001,   FLAG_IGNORE_ALIAS)

Definition at line 199 of file RealtimeTypes.h.

#define ACTIV_RECORD_UPDATE_FLAG_LIST ( d )

Value:

d(0x00, FLAG_NONE)                                                                                              \
        d(0x01, FLAG_DELETE)                                                                            \
        d(0x02, FLAG_STALE)                                         \
        d(0x04, FLAG_REFRESH)                                                                                       \
        d(0x08, FLAG_REQUEST_KEY)                                                                       \
        d(0x10, FLAG_RELATIONSHIP_ID)

Definition at line 564 of file RealtimeTypes.h.

#define ACTIV_REQUEST_BLOCK_FLAG_LIST ( d )

Value:

d(0x0000,   FLAG_NONE)                                                                      \
        d(0x0001,   FLAG_ALL_FIELDS)

Definition at line 157 of file RealtimeTypes.h.

#define ACTIV_REQUEST_FLAG_LIST ( d )

Value:

d(0x0000,   REQUEST_FLAG_NONE)                                                                              \
        d(0x0001,   REQUEST_FLAG_WATCH)                                     \
        d(0x0002,   REQUEST_FLAG_REVERSE_ORDER)

Definition at line 327 of file RealtimeTypes.h.

#define ACTIV_RESPONSE_BLOCK_FLAG_LIST ( d )

Value:

d(0x00, FLAG_NONE)                                          \
        d(0x01, FLAG_STALE)
List of response block flag values.

Maximum allowed value is 0x08.

Definition at line 423 of file RealtimeTypes.h.

#define ACTIV_RESPONSE_BLOCK_STATUS_LIST ( d )

Value:

d(0,    STATUS_SUCCESS, "success")                                              \
        d(2,    STATUS_SOURCE_NOT_FOUND, "source not found")                            \
        d(3,    STATUS_SOURCE_NOT_PERMISSIONED, "source not permissioned")              \
        d(4,    STATUS_RELATIONSHIP_NOT_FOUND, "relationship not found")                \
        d(5,    STATUS_RELATIONSHIP_NOT_PERMISSIONED, "relationship not permissioned")  \
        d(6,    STATUS_NAVIGATION_NOT_FOUND, "navigation not found")                    \
        d(7,    STATUS_NAVIGATION_NOT_PERMISSIONED, "navigation not permissioned")      \
        d(8,    STATUS_TARGET_NOT_FOUND, "target not found")                            \
        d(9,    STATUS_TARGET_NOT_PERMISSIONED, "target not permissioned")              \
        d(10,   STATUS_INTERNAL_ERROR, "internal error")                                \
        d(11,   STATUS_INVALID_SOURCE_TABLE, "invalid source table")                    \
        d(12,   STATUS_PERMISSION_LEVEL_NOT_AVAILABLE, "permission level not available")
List of response block status values.

Definition at line 404 of file RealtimeTypes.h.

#define ACTIV_SUBSCRIBE_PARAMETERS_SUBSCRIBE_TYPE_LIST ( d )

Value:

d(TYPE_NONE)                                                                                                    \
        d(TYPE_ADD_OR_DELETE)                                                                       \
        d(TYPE_EVENT_TYPE_FILTER_INCLUDE_LIST)                          \
        d(TYPE_EVENT_TYPE_FILTER_EXCLUDE_LIST)                      \
        d(TYPE_FULL)

Definition at line 52 of file RealtimeTypes.h.

#define MATCH_REQUEST_MATCH_TYPE_LIST ( d )

Value:

d(MATCH_TYPE_COMPOSITE)                                             \
        d(MATCH_TYPE_PRIMARY)
Match types.

Definition at line 352 of file RealtimeTypes.h.

Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivContentGatewayApiCommon

SymbolDirectoryTypes.h File Reference

Types for symbol directory data. More...

#include "ActivContentPlatform/ActivContentGatewayApiCommon/External.h"
#include "ActivContentPlatform/ActivContentGatewayApiCommon/Types.h"
#include "ActivContentPlatform/ActivFeedCommon/EntityTypes.h"

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::ContentGatewayApi

Classes

class | Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryRequestParameters
Get Symbols Request parameters. More...
class | Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryResponseParameters
Symbol directory response parameters. More...
class | Activ::ContentPlatform::ContentGatewayApi::SymbolResponse
Symbol directory response parameters. More...

Defines

#define | ACTIV_DECLARE_FLAGS(value, id) static const Flags id = value;
#define | ACTIV_SYMBOL_RESPONSE_FLAG_LIST(d)
#define | SYMBOL_DIRECTORY_FILTER_TYPE_LIST(d)
#define | SYMBOL_DIRECTORY_MATCH_TYPE_LIST(d)

Detailed Description

Types for symbol directory data.

Log

Definition in file SymbolDirectoryTypes.h.

Define Documentation

#define ACTIV_SYMBOL_RESPONSE_FLAG_LIST ( d )

Value:

d(0x0000,   FLAG_NONE)                                                                                      \
        d(0x0001,   FLAG_SAME_AS_LAST)

Definition at line 111 of file SymbolDirectoryTypes.h.

#define SYMBOL_DIRECTORY_FILTER_TYPE_LIST ( d )

Value:

d(FILTER_TYPE_FULL)                                                                                         \
        d(FILTER_TYPE_ENTITY_TYPE_INCLUDE_LIST)                                 \
        d(FILTER_TYPE_ENTITY_TYPE_EXCLUDE_LIST)

Definition at line 62 of file SymbolDirectoryTypes.h.

#define SYMBOL_DIRECTORY_MATCH_TYPE_LIST ( d )

Value:

d(MATCH_TYPE_ANY)                                                       \
        d(MATCH_TYPE_EXACT)

Definition at line 73 of file SymbolDirectoryTypes.h.

Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivContentGatewayApiCommon

Tick.h File Reference

Tick Field Set. More...

#include "ActivContentPlatform/ActivContentGatewayApiCommon/External.h"
#include "ActivContentPlatform/ActivContentGatewayApiCommon/FieldSet.h"
#include "ActivMiddleware/ActivFieldTypes/BinaryString.h"
#include "ActivMiddleware/ActivFieldTypes/Date.h"
#include "ActivMiddleware/ActivFieldTypes/Time.h"
#include "ActivMiddleware/ActivFieldTypes/Rational.h"
#include "ActivMiddleware/ActivFieldTypes/TRational.h"
#include "ActivMiddleware/ActivFieldTypes/UInt.h"
#include "ActivContentPlatform/ActivFeedCommon/UpdateIds.h"

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::ContentGatewayApi
namespace | Activ::ContentPlatform::TimeSeries

Classes

class | Activ::ContentPlatform::ContentGatewayApi::Tick
Tick Field Set class. More...

Defines

#define | ACTIV_DECLARE_BYTES(value, id) static const byte_t id = value;
#define | ACTIV_TICK_MASK_LIST(d)
#define | TICK_TYPE_LIST(d)
Tick types.

Typedefs

typedef FieldSetList< Tick,
uint16_t > 		Activ::ContentPlatform::ContentGatewayApi::TickList

Enumerations

enum | TickType { ACTIV_DECLARE_ELEMENT_1_WITH_COMMA }

Detailed Description

Tick Field Set.

Log

Definition in file Tick.h.

Define Documentation

#define ACTIV_TICK_MASK_LIST ( d )

Value:

d(0x0F, TICK_TYPE_MASK)                 \
        d(0x70, TICK_CONDITION_LENGTH_MASK)                             \
        d(0x80, TICK_OPTIONAL_DATA_BIT)         \
        d(0x80, TICK_OUT_SEQUENCE_MASK)                                         \
        d(0x40, TICK_KNOWN_EXCHANGE_BIT)        \
        d(0x20, TICK_SIZE_BYTE2)            \
        d(0x1F, TICK_DAY_MASK)                 \
        d(0x01, OPTIONAL_DATA_HAS_BUYER_ID)                 \
        d(0x02, OPTIONAL_DATA_HAS_SELLER_ID)                \
        d(0x04, OPTIONAL_DATA_HAS_TRADE_EXEPTION_FLAG)      \
        d(0x80, OPTIONAL_DATA_HAS_OTHER_LENGTH)         \
        d(0x02, QUOTE_SAME_EXCHANGE_BIT)    \
        d(0x04, QUOTE_SAME_CONDITION)           \
        d(0x08, QUOTE_NO_CONDITION)                                             \
        d(0x10, TICK_SIZE_BYTE1)

Definition at line 665 of file Tick.h.

#define TICK_TYPE_LIST ( d )

Value:

d(  TICK_TYPE_NONE,             "None"                  )   \
    d(  TICK_TYPE_TRADE,            "Trade"                 )   \
    d(  TICK_TYPE_CORRECTED_TRADE,  "Corrected Trade"       )   \
    d(  TICK_TYPE_DELETED_TRADE,    "Deleted Trade"         )   \
    d(  TICK_TYPE_FORM_T_TRADE,     "Form T Trade"          )   \
    d(  TICK_TYPE_FILTERED_TRADE,   "Filtered Trade"        )   \
    d(  TICK_TYPE_BID,              "Bid"                   )   \
    d(  TICK_TYPE_ASK,              "Ask"                   )   \
    d(  TICK_TYPE_QUOTE,            "not used"              )   \
    d(  TICK_TYPE_RESERVED2,        "not used"              )   \
    d(  TICK_TYPE_TRADE_INFO,       "Detailed trade info"   )
Tick types.

Definition at line 43 of file Tick.h.

Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivContentGatewayApiCommon

TimeSeriesTypes.h File Reference

Types for time series data. More...

#include "ActivContentPlatform/ActivContentGatewayApiCommon/External.h"
#include "ActivContentPlatform/ActivContentGatewayApiCommon/Types.h"
#include "ActivMiddleware/ActivFieldTypes/DateTime.h"

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::ContentGatewayApi

Classes

class | Activ::ContentPlatform::ContentGatewayApi::DataPointAddress
Address of an individual data point. More...
class | Activ::ContentPlatform::ContentGatewayApi::Period
Period of a series. More...
class | Activ::ContentPlatform::ContentGatewayApi::TimeSeriesCookie
Cookie passed between history manager and client for multi part requests. More...
class | Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestParameters
Request parameters. More...
class | Activ::ContentPlatform::ContentGatewayApi::TimeSeriesResponseParametersTemplate< FIELD_SET_TYPE >
Time series response parameters. More...

Defines

#define | ACTIV_DECLARE_CONSTANT_FIELD_FILTER_TYPE(val, id, name) const FieldFilterType id = val;
#define | ACTIV_DECLARE_CONSTANT_PERIOD_TYPE(val, id, name) const PeriodType id = val;
#define | ACTIV_DECLARE_CONSTANT_RECORD_FILTER_TYPE(val, id, name) const RecordFilterType id = val;
#define | ACTIV_DECLARE_CONSTANT_SERIES_TYPE(val, id, name) const SeriesType id = val;
#define | ACTIV_DECLARE_FLAGS(value, id) static const Flags id = value;
#define | ACTIV_TIME_SERIES_HISTORY_FIELD_FILTER_TYPE_LIST(d)
List of field filter types for history requests.
#define | ACTIV_TIME_SERIES_HISTORY_SERIES_TYPE_LIST(d)
List of series types for history requests.
#define | ACTIV_TIME_SERIES_INTRADAY_FIELD_FILTER_TYPE_LIST(d)
List of field filter types for intraday requests.
#define | ACTIV_TIME_SERIES_INTRADAY_RECORD_FILTER_TYPE_LIST(d)
List of record filter types for Intraday requests.
#define | ACTIV_TIME_SERIES_INTRADAY_SERIES_TYPE_LIST(d)
List of series types for intraday requests. For INTRADAY_SERIES_TYPE_SPECIFIED_MINUTE, use m_specifiedInterval to specify minutes.
#define | ACTIV_TIME_SERIES_PERIOD_TYPE_LIST(d)
List of period types.
#define | ACTIV_TIME_SERIES_REQUEST_FLAG_LIST(d)
#define | ACTIV_TIME_SERIES_TICK_RECORD_FILTER_TYPE_LIST(d)
List of record filter types for tick requests.
#define | ACTIV_TIME_SERIES_TICK_SERIES_TYPE_LIST(d) d(0, TICK_SERIES_TYPE, "Ticks")
List of series types for tick requests.

Typedefs

typedef uint8_t | Activ::ContentPlatform::ContentGatewayApi::FieldFilterType
Field filter type type.
typedef std::vector< Period > | Activ::ContentPlatform::ContentGatewayApi::PeriodList
List of Period.
typedef uint8_t | Activ::ContentPlatform::ContentGatewayApi::PeriodType
Period type type.
typedef uint8_t | Activ::ContentPlatform::ContentGatewayApi::RecordFilterType
Record filter type type.
typedef uint8_t | Activ::ContentPlatform::ContentGatewayApi::SeriesType
Series type type.

Functions

ACTIV_CONTENT_GATEWAY_API_COMMON_API
std::string 		Activ::ContentPlatform::ContentGatewayApi::FieldFilterTypeToString (const FieldFilterType fieldFilterType)
Return field filter type as string.
ACTIV_CONTENT_GATEWAY_API_COMMON_API
std::string 		Activ::ContentPlatform::ContentGatewayApi::PeriodTypeToString (const PeriodType periodType)
Return period type as string.
ACTIV_CONTENT_GATEWAY_API_COMMON_API
std::string 		Activ::ContentPlatform::ContentGatewayApi::RecordFilterTypeToString (const RecordFilterType recordFilterType)
Return record filter type as string.
ACTIV_CONTENT_GATEWAY_API_COMMON_API
std::string 		Activ::ContentPlatform::ContentGatewayApi::SeriesTypeToString (const SeriesType seriesType)
Return series type as string.

Variables

const FieldFilterType | Activ::ContentPlatform::ContentGatewayApi::HISTORY_FIELD_FILTER_TYPE_FULL_BAR = 20
const FieldFilterType | Activ::ContentPlatform::ContentGatewayApi::HISTORY_FIELD_FILTER_TYPE_MINI_BAR = 21
const SeriesType | Activ::ContentPlatform::ContentGatewayApi::HISTORY_SERIES_TYPE_DAILY = 40
const SeriesType | Activ::ContentPlatform::ContentGatewayApi::HISTORY_SERIES_TYPE_MONTHLY = 42
const SeriesType | Activ::ContentPlatform::ContentGatewayApi::HISTORY_SERIES_TYPE_WEEKLY = 41
const FieldFilterType | Activ::ContentPlatform::ContentGatewayApi::INTRADAY_FIELD_FILTER_TYPE_FULL_BAR = 0
const FieldFilterType | Activ::ContentPlatform::ContentGatewayApi::INTRADAY_FIELD_FILTER_TYPE_MINI_BAR = 1
const RecordFilterType | Activ::ContentPlatform::ContentGatewayApi::INTRADAY_RECORD_FILTER_TYPE_ALL = 1
const RecordFilterType | Activ::ContentPlatform::ContentGatewayApi::INTRADAY_RECORD_FILTER_TYPE_ALL_PLUS_VWAP = 2
const RecordFilterType | Activ::ContentPlatform::ContentGatewayApi::INTRADAY_RECORD_FILTER_TYPE_REGULAR_TRADES = 0
const SeriesType | Activ::ContentPlatform::ContentGatewayApi::INTRADAY_SERIES_TYPE_1_MINUTE = 20
const SeriesType | Activ::ContentPlatform::ContentGatewayApi::INTRADAY_SERIES_TYPE_5_MINUTE = 21
const SeriesType | Activ::ContentPlatform::ContentGatewayApi::INTRADAY_SERIES_TYPE_SPECIFIED_MINUTE = 22
const PeriodType | Activ::ContentPlatform::ContentGatewayApi::PERIOD_TYPE_DATA_POINT_ADDRESS = 6
const PeriodType | Activ::ContentPlatform::ContentGatewayApi::PERIOD_TYPE_DATA_POINT_COUNT = 5
const PeriodType | Activ::ContentPlatform::ContentGatewayApi::PERIOD_TYPE_INFINITY = 1
const PeriodType | Activ::ContentPlatform::ContentGatewayApi::PERIOD_TYPE_LOCAL_DATE_TIME = 2
const PeriodType | Activ::ContentPlatform::ContentGatewayApi::PERIOD_TYPE_NOW = 0
const PeriodType | Activ::ContentPlatform::ContentGatewayApi::PERIOD_TYPE_TRADING_DAY_COUNT = 4
const PeriodType | Activ::ContentPlatform::ContentGatewayApi::PERIOD_TYPE_UTC_DATE_TIME = 3
const RecordFilterType | Activ::ContentPlatform::ContentGatewayApi::TICK_RECORD_FILTER_TYPE_ALL = 0
const RecordFilterType | Activ::ContentPlatform::ContentGatewayApi::TICK_RECORD_FILTER_TYPE_ALL_ASKS = 5
const RecordFilterType | Activ::ContentPlatform::ContentGatewayApi::TICK_RECORD_FILTER_TYPE_ALL_BIDS = 4
const RecordFilterType | Activ::ContentPlatform::ContentGatewayApi::TICK_RECORD_FILTER_TYPE_ALL_QUOTES = 3
const RecordFilterType | Activ::ContentPlatform::ContentGatewayApi::TICK_RECORD_FILTER_TYPE_ALL_TRADES = 1
const RecordFilterType | Activ::ContentPlatform::ContentGatewayApi::TICK_RECORD_FILTER_TYPE_REGULAR_TRADES = 2
const SeriesType | Activ::ContentPlatform::ContentGatewayApi::TICK_SERIES_TYPE = 0

Detailed Description

Types for time series data.

Log

Definition in file TimeSeriesTypes.h.

Define Documentation

#define ACTIV_TIME_SERIES_HISTORY_FIELD_FILTER_TYPE_LIST ( d )

Value:

d(20,   HISTORY_FIELD_FILTER_TYPE_FULL_BAR, "Full Bar")             \
    d(21,   HISTORY_FIELD_FILTER_TYPE_MINI_BAR, "Mini Bar")
List of field filter types for history requests.

Definition at line 147 of file TimeSeriesTypes.h.

#define ACTIV_TIME_SERIES_HISTORY_SERIES_TYPE_LIST ( d )

Value:

d(40,   HISTORY_SERIES_TYPE_DAILY,      "Daily bars")               \
    d(41,   HISTORY_SERIES_TYPE_WEEKLY,     "Weekly bars")              \
    d(42,   HISTORY_SERIES_TYPE_MONTHLY,    "Monthly bars")
List of series types for history requests.

Definition at line 67 of file TimeSeriesTypes.h.

#define ACTIV_TIME_SERIES_INTRADAY_FIELD_FILTER_TYPE_LIST ( d )

Value:

d(0,    INTRADAY_FIELD_FILTER_TYPE_FULL_BAR,    "Full Bar")         \
    d(1,    INTRADAY_FIELD_FILTER_TYPE_MINI_BAR,    "Mini Bar")
List of field filter types for intraday requests.

Definition at line 136 of file TimeSeriesTypes.h.

#define ACTIV_TIME_SERIES_INTRADAY_RECORD_FILTER_TYPE_LIST ( d )

Value:

d(0,    INTRADAY_RECORD_FILTER_TYPE_REGULAR_TRADES, "Regular Trades Only")  \
    d(1,    INTRADAY_RECORD_FILTER_TYPE_ALL,            "All Trades")           \
    d(2,    INTRADAY_RECORD_FILTER_TYPE_ALL_PLUS_VWAP,  "All + VWAP Only Bars")
List of record filter types for Intraday requests.

Definition at line 109 of file TimeSeriesTypes.h.

#define ACTIV_TIME_SERIES_INTRADAY_SERIES_TYPE_LIST ( d )

Value:

d(20,   INTRADAY_SERIES_TYPE_1_MINUTE,  "1 Minute bars")            \
    d(21,   INTRADAY_SERIES_TYPE_5_MINUTE,  "5 Minute bars")            \
    d(22,   INTRADAY_SERIES_TYPE_SPECIFIED_MINUTE,  "Minute bars as specified")
List of series types for intraday requests. For INTRADAY_SERIES_TYPE_SPECIFIED_MINUTE, use m_specifiedInterval to specify minutes.

Definition at line 55 of file TimeSeriesTypes.h.

#define ACTIV_TIME_SERIES_PERIOD_TYPE_LIST ( d )

Value:

d(0,    PERIOD_TYPE_NOW,                "Present Time")             \
    d(1,    PERIOD_TYPE_INFINITY,           "Infinity")                 \
    d(2,    PERIOD_TYPE_LOCAL_DATE_TIME,    "Local Date Time")          \
    d(3,    PERIOD_TYPE_UTC_DATE_TIME,      "UTC Date Time")            \
    d(4,    PERIOD_TYPE_TRADING_DAY_COUNT,  "Trading Day Count")        \
    d(5,    PERIOD_TYPE_DATA_POINT_COUNT,   "Data Point Count")         \
    d(6,    PERIOD_TYPE_DATA_POINT_ADDRESS, "Data Point Address")
List of period types.

Definition at line 158 of file TimeSeriesTypes.h.

#define ACTIV_TIME_SERIES_REQUEST_FLAG_LIST ( d )

Value:

d(0x0000,   FLAG_NONE)                                                              \
        d(0x0001,   FLAG_REVERSE)                                       \
        d(0x0002,   FLAG_IGNORE_ALIAS)

Definition at line 367 of file TimeSeriesTypes.h.

#define ACTIV_TIME_SERIES_TICK_RECORD_FILTER_TYPE_LIST ( d )

Value:

d(0,    TICK_RECORD_FILTER_TYPE_ALL,            "All")              \
    d(1,    TICK_RECORD_FILTER_TYPE_ALL_TRADES,     "All Trades")       \
    d(2,    TICK_RECORD_FILTER_TYPE_REGULAR_TRADES, "Regular Trades")   \
    d(3,    TICK_RECORD_FILTER_TYPE_ALL_QUOTES,     "All Quotes")       \
    d(4,    TICK_RECORD_FILTER_TYPE_ALL_BIDS,       "All Bids")         \
    d(5,    TICK_RECORD_FILTER_TYPE_ALL_ASKS,       "Asks")
List of record filter types for tick requests.

Definition at line 94 of file TimeSeriesTypes.h.

Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivContentGatewayApiCommon

Types.h File Reference

General content gateway types. More...

#include "ActivContentPlatform/ActivContentGatewayApiCommon/External.h"
#include "ActivContentPlatform/MessageClasses.h"
#include "ActivContentPlatform/ActivFeedCommon/TableNumbers.h"
#include "ActivContentPlatform/ActivFeedCommon/PermissionLevels.h"
#include "ActivMiddleware/ActivFieldTypes/UInt.h"
#include "ActivMiddleware/Misc/SerializableBuffer.h"

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::ContentGatewayApi

Classes

class | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayInfo
Information about the ContentGateway. More...
class | Activ::ContentPlatform::ContentGatewayApi::FieldData
Opaque field data block. More...
class | Activ::ContentPlatform::ContentGatewayApi::SubscriptionInfo
Info returned about subscriptions. More...
class | Activ::ContentPlatform::ContentGatewayApi::SymbolId
Symbol id. More...

Defines

#define | ACTIV_CONTENT_GATEWAY_INFO_FLAG_LIST(d)
#define | ACTIV_DECLARE_CONSTANT_USER_TYPE(val, id, name) const UserType id = val;
#define | ACTIV_DECLARE_FLAGS(value, id) static const Flags id = value;
#define | ACTIV_USER_TYPE_LIST(d)
List of user type values.

Typedefs

typedef uint32_t | Activ::ContentPlatform::ContentGatewayApi::LogonFlags
Logon flags type.
typedef uint32_t | Activ::ContentPlatform::ContentGatewayApi::SubscriptionCookie
Cookie used to unsubscribe.
typedef std::vector
< SubscriptionCookie > 		Activ::ContentPlatform::ContentGatewayApi::SubscriptionCookieList
List of subscription cookies.
typedef std::vector< SymbolId > | Activ::ContentPlatform::ContentGatewayApi::SymbolIdList
List of SymbolId.
typedef uint8_t | Activ::ContentPlatform::ContentGatewayApi::UserType
User type type.

Functions

Activ::ContentPlatform::ContentGatewayApi::ACTIV_DECLARE_MESSAGE_TYPE (20, MESSAGE_CLASS_CONTENT_GATEWAY_API, GATEWAY_MESSAGE_USER_SUBSCRIPTION_UPDATE_REMOVE)
Activ::ContentPlatform::ContentGatewayApi::ACTIV_DECLARE_MESSAGE_TYPE (19, MESSAGE_CLASS_CONTENT_GATEWAY_API, GATEWAY_MESSAGE_USER_SUBSCRIPTION_UPDATE_ADD)
Activ::ContentPlatform::ContentGatewayApi::ACTIV_DECLARE_MESSAGE_TYPE (18, MESSAGE_CLASS_CONTENT_GATEWAY_API, GATEWAY_MESSAGE_USER_SUBSCRIPTION_RESPONSE)
Activ::ContentPlatform::ContentGatewayApi::ACTIV_DECLARE_MESSAGE_TYPE (17, MESSAGE_CLASS_CONTENT_GATEWAY_API, GATEWAY_MESSAGE_USER_SUBSCRIPTION_REQUEST)
Activ::ContentPlatform::ContentGatewayApi::ACTIV_DECLARE_MESSAGE_TYPE (16, MESSAGE_CLASS_CONTENT_GATEWAY_API, GATEWAY_MESSAGE_DISOVERY_RESPONSE)
Activ::ContentPlatform::ContentGatewayApi::ACTIV_DECLARE_MESSAGE_TYPE (15, MESSAGE_CLASS_CONTENT_GATEWAY_API, GATEWAY_MESSAGE_DISOVERY_REQUEST)
Activ::ContentPlatform::ContentGatewayApi::ACTIV_DECLARE_MESSAGE_TYPE (14, MESSAGE_CLASS_CONTENT_GATEWAY_API, GATEWAY_MESSAGE_NEWS_UPDATE)
Activ::ContentPlatform::ContentGatewayApi::ACTIV_DECLARE_MESSAGE_TYPE (13, MESSAGE_CLASS_CONTENT_GATEWAY_API, GATEWAY_MESSAGE_CONTENT_GATEWAY_INFO_UPDATE)
Activ::ContentPlatform::ContentGatewayApi::ACTIV_DECLARE_MESSAGE_TYPE (12, MESSAGE_CLASS_CONTENT_GATEWAY_API, GATEWAY_MESSAGE_INTERNAL_LOGOFF)
Activ::ContentPlatform::ContentGatewayApi::ACTIV_DECLARE_MESSAGE_TYPE (11, MESSAGE_CLASS_CONTENT_GATEWAY_API, GATEWAY_MESSAGE_STATS)
Activ::ContentPlatform::ContentGatewayApi::ACTIV_DECLARE_MESSAGE_TYPE (10, MESSAGE_CLASS_CONTENT_GATEWAY_API, GATEWAY_MESSAGE_FAILOVER)
Activ::ContentPlatform::ContentGatewayApi::ACTIV_DECLARE_MESSAGE_TYPE (9, MESSAGE_CLASS_CONTENT_GATEWAY_API, GATEWAY_MESSAGE_SUB_LOGOFF)
Activ::ContentPlatform::ContentGatewayApi::ACTIV_DECLARE_MESSAGE_TYPE (8, MESSAGE_CLASS_CONTENT_GATEWAY_API, GATEWAY_MESSAGE_SUB_LOGON)
Activ::ContentPlatform::ContentGatewayApi::ACTIV_DECLARE_MESSAGE_TYPE (7, MESSAGE_CLASS_CONTENT_GATEWAY_API, GATEWAY_MESSAGE_USER_ID_COUNT)
Activ::ContentPlatform::ContentGatewayApi::ACTIV_DECLARE_MESSAGE_TYPE (6, MESSAGE_CLASS_CONTENT_GATEWAY_API, GATEWAY_MESSAGE_GET_USER_ID_COUNT)
Activ::ContentPlatform::ContentGatewayApi::ACTIV_DECLARE_MESSAGE_TYPE (5, MESSAGE_CLASS_CONTENT_GATEWAY_API, GATEWAY_MESSAGE_UNSUBSCRIBE_COOKIE_SYMBOL_LIST)
Activ::ContentPlatform::ContentGatewayApi::ACTIV_DECLARE_MESSAGE_TYPE (4, MESSAGE_CLASS_CONTENT_GATEWAY_API, GATEWAY_MESSAGE_UNSUBSCRIBE_COOKIE_LIST)
Activ::ContentPlatform::ContentGatewayApi::ACTIV_DECLARE_MESSAGE_TYPE (3, MESSAGE_CLASS_CONTENT_GATEWAY_API, GATEWAY_MESSAGE_UNSUBSCRIBE_ALL)
Activ::ContentPlatform::ContentGatewayApi::ACTIV_DECLARE_MESSAGE_TYPE (2, MESSAGE_CLASS_CONTENT_GATEWAY_API, GATEWAY_MESSAGE_GREETING)
Activ::ContentPlatform::ContentGatewayApi::ACTIV_DECLARE_MESSAGE_TYPE (1, MESSAGE_CLASS_CONTENT_GATEWAY_API, GATEWAY_MESSAGE_REPORT)
Activ::ContentPlatform::ContentGatewayApi::ACTIV_DECLARE_MESSAGE_TYPE (0, MESSAGE_CLASS_CONTENT_GATEWAY_API, GATEWAY_MESSAGE_RECORD_UPDATE)
ContentGatewayApi message types.
Activ::ContentPlatform::ContentGatewayApi::ACTIV_DECLARE_MESSAGE_TYPE (31, MESSAGE_CLASS_CONTENT_GATEWAY_API, GATEWAY_REQUEST_GET_RELATIONSHIP_INFO_LIST)
Activ::ContentPlatform::ContentGatewayApi::ACTIV_DECLARE_MESSAGE_TYPE (30, MESSAGE_CLASS_CONTENT_GATEWAY_API, GATEWAY_REQUEST_GET_UNIVERSAL_FIELD_HELPER_MAP)
Activ::ContentPlatform::ContentGatewayApi::ACTIV_DECLARE_MESSAGE_TYPE (29, MESSAGE_CLASS_CONTENT_GATEWAY_API, GATEWAY_REQUEST_GET_TABLE_SPECIFICATION)
Activ::ContentPlatform::ContentGatewayApi::ACTIV_DECLARE_MESSAGE_TYPE (28, MESSAGE_CLASS_CONTENT_GATEWAY_API, GATEWAY_REQUEST_GET_TABLE_INFO_LIST)
Activ::ContentPlatform::ContentGatewayApi::ACTIV_DECLARE_MESSAGE_TYPE (27, MESSAGE_CLASS_CONTENT_GATEWAY_API, GATEWAY_REQUEST_GET_NEWS_STORIES)
Activ::ContentPlatform::ContentGatewayApi::ACTIV_DECLARE_MESSAGE_TYPE (26, MESSAGE_CLASS_CONTENT_GATEWAY_API, GATEWAY_REQUEST_GET_PERMISSION_INFO)
Activ::ContentPlatform::ContentGatewayApi::ACTIV_DECLARE_MESSAGE_TYPE (25, MESSAGE_CLASS_CONTENT_GATEWAY_API, GATEWAY_REQUEST_GET_SERVER_INFO)
Activ::ContentPlatform::ContentGatewayApi::ACTIV_DECLARE_MESSAGE_TYPE (24, MESSAGE_CLASS_CONTENT_GATEWAY_API, GATEWAY_REQUEST_GET_MULTIPLE_MATCH)
Activ::ContentPlatform::ContentGatewayApi::ACTIV_DECLARE_MESSAGE_TYPE (23, MESSAGE_CLASS_CONTENT_GATEWAY_API, GATEWAY_REQUEST_GET_SYMBOLS)
Activ::ContentPlatform::ContentGatewayApi::ACTIV_DECLARE_MESSAGE_TYPE (22, MESSAGE_CLASS_CONTENT_GATEWAY_API, GATEWAY_REQUEST_SUBSCRIBE_TABLE)
Activ::ContentPlatform::ContentGatewayApi::ACTIV_DECLARE_MESSAGE_TYPE (21, MESSAGE_CLASS_CONTENT_GATEWAY_API, GATEWAY_REQUEST_GET_MATCH)
Activ::ContentPlatform::ContentGatewayApi::ACTIV_DECLARE_MESSAGE_TYPE (20, MESSAGE_CLASS_CONTENT_GATEWAY_API, GATEWAY_REQUEST_GET_SUBSCRIPTION_INFO)
Activ::ContentPlatform::ContentGatewayApi::ACTIV_DECLARE_MESSAGE_TYPE (19, MESSAGE_CLASS_CONTENT_GATEWAY_API, GATEWAY_REQUEST_GET_MULTIPLE_PATTERN_MATCH_LIST)
Activ::ContentPlatform::ContentGatewayApi::ACTIV_DECLARE_MESSAGE_TYPE (18, MESSAGE_CLASS_CONTENT_GATEWAY_API, GATEWAY_REQUEST_UNSUBSCRIBE_ALL)
Activ::ContentPlatform::ContentGatewayApi::ACTIV_DECLARE_MESSAGE_TYPE (17, MESSAGE_CLASS_CONTENT_GATEWAY_API, GATEWAY_REQUEST_GET_NEXT_TICKS)
Activ::ContentPlatform::ContentGatewayApi::ACTIV_DECLARE_MESSAGE_TYPE (16, MESSAGE_CLASS_CONTENT_GATEWAY_API, GATEWAY_REQUEST_GET_FIRST_TICKS)
Activ::ContentPlatform::ContentGatewayApi::ACTIV_DECLARE_MESSAGE_TYPE (15, MESSAGE_CLASS_CONTENT_GATEWAY_API, GATEWAY_REQUEST_GET_NEXT_INTRADAY)
Activ::ContentPlatform::ContentGatewayApi::ACTIV_DECLARE_MESSAGE_TYPE (14, MESSAGE_CLASS_CONTENT_GATEWAY_API, GATEWAY_REQUEST_GET_FIRST_INTRADAY)
Activ::ContentPlatform::ContentGatewayApi::ACTIV_DECLARE_MESSAGE_TYPE (13, MESSAGE_CLASS_CONTENT_GATEWAY_API, GATEWAY_REQUEST_GET_NEXT_HISTORY)
Activ::ContentPlatform::ContentGatewayApi::ACTIV_DECLARE_MESSAGE_TYPE (12, MESSAGE_CLASS_CONTENT_GATEWAY_API, GATEWAY_REQUEST_GET_FIRST_HISTORY)
Activ::ContentPlatform::ContentGatewayApi::ACTIV_DECLARE_MESSAGE_TYPE (11, MESSAGE_CLASS_CONTENT_GATEWAY_API, GATEWAY_REQUEST_UNSUBSCRIBE_COOKIE)
Activ::ContentPlatform::ContentGatewayApi::ACTIV_DECLARE_MESSAGE_TYPE (10, MESSAGE_CLASS_CONTENT_GATEWAY_API, GATEWAY_REQUEST_UNSUBSCRIBE_FEED)
Activ::ContentPlatform::ContentGatewayApi::ACTIV_DECLARE_MESSAGE_TYPE (9, MESSAGE_CLASS_CONTENT_GATEWAY_API, GATEWAY_REQUEST_SUBSCRIBE_FEED)
Activ::ContentPlatform::ContentGatewayApi::ACTIV_DECLARE_MESSAGE_TYPE (8, MESSAGE_CLASS_CONTENT_GATEWAY_API, GATEWAY_REQUEST_GET_MULTIPLE_PATTERN_MATCH)
Activ::ContentPlatform::ContentGatewayApi::ACTIV_DECLARE_MESSAGE_TYPE (7, MESSAGE_CLASS_CONTENT_GATEWAY_API, GATEWAY_REQUEST_GET_MULTIPLE_EQUAL)
Activ::ContentPlatform::ContentGatewayApi::ACTIV_DECLARE_MESSAGE_TYPE (6, MESSAGE_CLASS_CONTENT_GATEWAY_API, GATEWAY_REQUEST_GET_EQUAL)
Activ::ContentPlatform::ContentGatewayApi::ACTIV_DECLARE_MESSAGE_TYPE (5, MESSAGE_CLASS_CONTENT_GATEWAY_API, GATEWAY_REQUEST_GET_PREVIOUS)
Activ::ContentPlatform::ContentGatewayApi::ACTIV_DECLARE_MESSAGE_TYPE (4, MESSAGE_CLASS_CONTENT_GATEWAY_API, GATEWAY_REQUEST_GET_NEXT)
Activ::ContentPlatform::ContentGatewayApi::ACTIV_DECLARE_MESSAGE_TYPE (3, MESSAGE_CLASS_CONTENT_GATEWAY_API, GATEWAY_REQUEST_GET_LAST)
Activ::ContentPlatform::ContentGatewayApi::ACTIV_DECLARE_MESSAGE_TYPE (2, MESSAGE_CLASS_CONTENT_GATEWAY_API, GATEWAY_REQUEST_GET_FIRST)
Activ::ContentPlatform::ContentGatewayApi::ACTIV_DECLARE_MESSAGE_TYPE (1, MESSAGE_CLASS_CONTENT_GATEWAY_API, GATEWAY_REQUEST_UNSUBSCRIBE_COOKIE_SYMBOL)
ContentGatewayApi request types.
ACTIV_CONTENT_GATEWAY_API_COMMON_API
std::string 		Activ::ContentPlatform::ContentGatewayApi::UserTypeToString (const UserType userType)
Return user type as string.

Variables

const LogonFlags | Activ::ContentPlatform::ContentGatewayApi::LOGON_FLAG_DISCONNECT_EXISTING = 0x00000001
If this user is already logged on, disconnect that session such that this one is allowed to logon.
const LogonFlags | Activ::ContentPlatform::ContentGatewayApi::LOGON_FLAG_NONE = 0x00000000
Default value.
const SubscriptionCookie | Activ::ContentPlatform::ContentGatewayApi::SUBSCRIPTION_COOKIE_UNDEFINED = ~0
const UserType | Activ::ContentPlatform::ContentGatewayApi::USER_TYPE_C_SHARP_API = 5
const UserType | Activ::ContentPlatform::ContentGatewayApi::USER_TYPE_CPP_API = 0
const UserType | Activ::ContentPlatform::ContentGatewayApi::USER_TYPE_ISV = 2
const UserType | Activ::ContentPlatform::ContentGatewayApi::USER_TYPE_JAVA_API = 4
const UserType | Activ::ContentPlatform::ContentGatewayApi::USER_TYPE_WORKSTATION = 1
const UserType | Activ::ContentPlatform::ContentGatewayApi::USER_TYPE_WORKSTATION_SERVICE = 3

Detailed Description

General content gateway types.

Log

Definition in file Types.h.

Define Documentation

#define ACTIV_CONTENT_GATEWAY_INFO_FLAG_LIST ( d )

Value:

d(0x00, FLAG_NONE)                                                                                  \
        d(0x01, FLAG_HISTORY_SERVICE_CHANGED)                               \
        d(0x02, FLAG_SYMBOL_DIRECTORY_SERVICE_CHANGED)              \
        d(0x04, FLAG_NEWS_SERVER_SERVICE_CHANGED)

Definition at line 291 of file Types.h.

#define ACTIV_USER_TYPE_LIST ( d )

Value:

d(0,    USER_TYPE_CPP_API,              "C++ API")              \
    d(1,    USER_TYPE_WORKSTATION,          "Workstation")          \
    d(2,    USER_TYPE_ISV,                  "ISV")                  \
    d(3,    USER_TYPE_WORKSTATION_SERVICE,  "Workstation Service")  \
    d(4,    USER_TYPE_JAVA_API,             "Java API")             \
    d(5,    USER_TYPE_C_SHARP_API,          "C# API")
List of user type values.

Definition at line 250 of file Types.h.

Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivContentServerApi

ActivContentServerApi.h File Reference

ActivContentServerApi main header. More...

#include "ActivContentPlatform/ActivContentServerApi/ContentServerClient.h"
#include "ActivContentPlatform/ActivContentServerApi/FieldListValidator.h"

Go to the source code of this file.

Defines

#define | ACTIV_CONTENT_SERVER_API_VERSION_STRING "99.99.99.99"
ActivContentServerApi version string.
#define | ACTIV_CONTENT_SERVER_API_VERSION_VALUE ACTIV_MAKE_VERSION_VALUE(99, 99, 99, 99)
ActivContentServerApi version value.

Detailed Description

ActivContentServerApi main header.

Log

Definition in file ActivContentServerApi.h.

Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivContentServerApi

ContentServerClient.h File Reference

Content server client. More...

#include "ActivContentPlatform/ActivContentServerApi/External.h"
#include "ActivContentPlatform/ActivContentServerApi/RecordUpdateHelper.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedDefinitions.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedPermissioning/PermissionInfo.h"

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::ContentServerApi

Classes

class | Activ::ContentPlatform::ContentServerApi::ContentServerClient
Content server client class. More...
class | Activ::ContentPlatform::ContentServerApi::ContentServerClient::ApiInfo
Information returned from GetApiInfo(). More...
class | Activ::ContentPlatform::ContentServerApi::ContentServerClient::MessageStats
message stats class. More...
class | Activ::ContentPlatform::ContentServerApi::ContentServerClient::Settings
Settings for ContentServerClient class. More...
class | Activ::ContentPlatform::ContentServerApi::ContentServerClient::UpdateFilter
Update Filter. More...
class | Activ::ContentPlatform::ContentServerApi::ContentServerClient::UpdateFilterMap
Update filter map class. More...

Defines

#define | DEFAULT_CS_MANAGER_RESET_TIME 4, 30, 0

Typedefs

typedef uint32_t | Activ::ContentPlatform::ContentServerApi::SubscriptionCookie

Variables

const SubscriptionCookie | Activ::ContentPlatform::ContentServerApi::SUBSCRIPTION_COOKIE_UNDEFINED = static_cast<SubscriptionCookie>(~0)

Detailed Description

Content server client.

Log

Definition in file ContentServerClient.h.

Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivContentServerApi

External.h File Reference

Import rules for ActivContentServerApi exports. More...

#include "ActivMiddleware/ActivFramework/ActivFramework.h"

Go to the source code of this file.

Defines

#define ACTIV_CONTENT_SERVER_API ACTIV_IMPORT_DLL

Detailed Description

Import rules for ActivContentServerApi exports.

Log

Definition in file External.h.

Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivContentServerApi

FieldListValidator.h File Reference

Header file for the field list validator class. More...

#include "ActivContentPlatform/ActivContentServerApi/External.h"
#include "ActivContentPlatform/ActivFeedApiCommon/FieldListValidator.h"

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::ContentServerApi
namespace | Activ::ContentPlatform::Feed

Classes

class | Activ::ContentPlatform::ContentServerApi::FieldListValidator
Field list validator class. More...

Detailed Description

Header file for the field list validator class.

Log

Definition in file FieldListValidator.h.

Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivContentServerApi

RecordUpdateHelper.h File Reference

Record update helper. More...

#include "ActivContentPlatform/ActivContentServerApi/External.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedDefinitions.h"

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::ContentServerApi
namespace | Activ::ContentPlatform::Feed

Classes

class | Activ::ContentPlatform::ContentServerApi::RecordUpdate
Record update class. More...
class | Activ::ContentPlatform::ContentServerApi::RecordUpdateHelper< MESSAGE_VALIDATOR >
Record update helper class. More...
class | Activ::ContentPlatform::ContentServerApi::SymbolRecordUpdate
Symbol record update class. More...

Detailed Description

Record update helper.

Log

Definition in file RecordUpdateHelper.h.

Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivContentServerApi

SymbolPatternHelper.h File Reference

Header for symbol pattern helper class. More...

#include "ActivContentPlatform/ActivContentServerApi/External.h"
#include "boost/shared_ptr.hpp"

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::FeedApi

Classes

class | Activ::ContentPlatform::FeedApi::SymbolPatternHelper
Symbol pattern helper. More...

Detailed Description

Header for symbol pattern helper class.

Log

Definition in file SymbolPatternHelper.h.

Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivContributionGatewayApi

ActivContributionGatewayApi.h File Reference

ActivContributionGatewayApi main header. More...

#include "ActivContentPlatform/ActivContributionGatewayApi/ContributionGatewayClient.h"
#include "ActivContentPlatform/ActivContributionGatewayApi/PublishRequestHelper.h"

Go to the source code of this file.

Defines

#define | ACTIV_CONTRIBUTION_GATEWAY_API_STRING "99.99.99.99"
ActivContributionGatewayApi version string.
#define | ACTIV_CONTRIBUTION_GATEWAY_API_VERSION_VALUE ACTIV_MAKE_VERSION_VALUE(99, 99, 99, 99)
ActivContributionGatewayApi version value.

Detailed Description

ActivContributionGatewayApi main header.

Log

Definition in file ActivContributionGatewayApi.h.

Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivContributionGatewayApi

ContributionGatewayClient.h File Reference

Contribution gateway client. More...

#include "ActivContentPlatform/ActivContributionGatewayApi/External.h"
#include "ActivContentPlatform/ActivContributionGatewayApi/PublishRequestHelper.h"

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::ContributionGatewayApi

Classes

class | Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient
Contribution gateway client class. More...
class | Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::ApiInfo
Information returned from GetApiInfo(). More...
class | Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::ConnectParameters
Parameters for Connect(). More...
class | Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::Settings
Settings for ContributionGatewayClient class. More...

Defines

#define | ACTIV_CONTRIBUTION_GATEWAY_CLIENT_DEFAULT_HEAP_SIZE { { 100, 100000 }, { 500, 20000 }, { 1000, 10000 }, { 25000, 500 } }
#define | ACTIV_CONTRIBUTION_GATEWAY_CLIENT_STATE_LIST(d)
List of client states.
#define | POLICY_TYPE_LIST(d)
Possible actions to take if connection to gateway is down.

Detailed Description

Contribution gateway client.

Log

Definition in file ContributionGatewayClient.h.

Define Documentation

#define ACTIV_CONTRIBUTION_GATEWAY_CLIENT_STATE_LIST ( d )

Value:

d(STATE_INITIALIZED, "initialized")                 \
        d(STATE_W4_CONNECT, "w4 connect")                   \
        d(STATE_LOGGED_ON, "logged on")                     \
        d(STATE_W4_DISCONNECT, "w4 disconnect")
List of client states.

Definition at line 37 of file ContributionGatewayClient.h.

#define POLICY_TYPE_LIST ( d )

Value:

d(POLICY_RETRY)                                         \
            d(POLICY_FIND_NEXT_ALTERNATIVE)         \
            d(POLICY_FIND_RANDOM_ALTERNATIVE)
Possible actions to take if connection to gateway is down.

Definition at line 89 of file ContributionGatewayClient.h.

Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivContributionGatewayApi

External.h File Reference

Import rules for ActivContributionGatewayApi exports. More...

#include "ActivMiddleware/ActivFramework/ActivFramework.h"
#include "ActivContentPlatform/ActivContributionGatewayApiCommon/PublishTypes.h"

Go to the source code of this file.

Defines

#define ACTIV_CONTRIBUTION_GATEWAY_API ACTIV_IMPORT_DLL

Detailed Description

Import rules for ActivContributionGatewayApi exports.

Log

Definition in file External.h.

Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivContributionGatewayApi

PublishRequestHelper.h File Reference

Helper class for publish requests. More...

#include "ActivContentPlatform/ActivContributionGatewayApi/External.h"

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::ContributionGatewayApi

Classes

class | Activ::ContentPlatform::ContributionGatewayApi::PublishRequestHelper< MESSAGE_TYPE_VALUE, REQUEST_PARAMETERS, RESPONSE_PARAMETERS >
Publish request helper class. More...

Detailed Description

Helper class for publish requests.

Log

Definition in file PublishRequestHelper.h.

Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivContributionGatewayApiCommon

External.h File Reference

Import rules for ActivContributionGatewayApiCommon exports. More...

#include "ActivMiddleware/ActivFramework/ActivFramework.h"

Go to the source code of this file.

Defines

#define ACTIV_CONTRIBUTION_GATEWAY_API_COMMON_API ACTIV_IMPORT_DLL

Detailed Description

Import rules for ActivContributionGatewayApiCommon exports.

Log

Definition in file External.h.

Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivContributionGatewayApiCommon

PublishTypes.h File Reference

Types for publishing data. More...

#include "ActivContentPlatform/ActivContributionGatewayApiCommon/External.h"
#include "ActivContentPlatform/ActivContributionGatewayApiCommon/Types.h"
#include "ActivContentPlatform/ActivFeedCommon/TableNumbers.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/SymbolRecordRuleDefinitions.h"
#include "ActivContentPlatform/ActivFeedCommon/UpdateIds.h"
#include "ActivMiddleware/ActivFieldTypes/IFieldType.h"
#include "boost/shared_ptr.hpp"

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::ContributionGatewayApi

Classes

class | Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayResponseParameters
Base response parameters. More...
class | Activ::ContentPlatform::ContributionGatewayApi::PublishField
Publish field class. More...
class | Activ::ContentPlatform::ContributionGatewayApi::PublishRecordBaseParameters
Base parameters for publishing a record. More...
class | Activ::ContentPlatform::ContributionGatewayApi::PublishRecordParameters
Parameters for publishing a record. More...
class | Activ::ContentPlatform::ContributionGatewayApi::PublishRecordResponseParameters
Response parameters from a publish request. More...
class | Activ::ContentPlatform::ContributionGatewayApi::PublishRecordResponseParameters::FieldError
Field error class. More...
class | Activ::ContentPlatform::ContributionGatewayApi::PublishSymbolRecordParameters
Parameters for publishing a symbol record. More...
class | Activ::ContentPlatform::ContributionGatewayApi::PublishSymbolRecordParameters::Field
Field class. More...

Defines

#define | ACTIV_CONTRIBUTION_GATEWAY_RESPONSE_STATUS_LIST(d)
List of response status values.
#define | ACTIV_DECLARE_CONTRIBUTION_GATEWAY_RESPONSE_STATUS(value, id, name) static const Status id = value;
Macro to declare constant response statuses.
#define | ACTIV_DECLARE_FIELD_STATUS(value, id, name) static const FieldStatus id = value;
Macro to declare constant field statuses.
#define | ACTIV_DECLARE_FLAGS(value, id) static const Flags id = value;
#define | ACTIV_FIELD_STATUS_LIST(d)
List of response block status values.
#define | ACTIV_PUBLISH_RECORD_PARAMETERS_FLAG_LIST(d)

Typedefs

typedef std::string | Activ::ContentPlatform::ContributionGatewayApi::Symbol
underlying symbol type

Detailed Description

Types for publishing data.

Log

Definition in file PublishTypes.h.

Define Documentation

#define ACTIV_CONTRIBUTION_GATEWAY_RESPONSE_STATUS_LIST ( d )

Value:

d(0,    STATUS_SUCCESS, "success")                                              \
        d(1,    STATUS_SUCCESS_WITH_ERRORS, "success with errors")                      \
        d(2,    STATUS_FAILURE, "failure")                                              \
        d(3,    STATUS_FAILURE_WITH_ERRORS, "failure with errors")                      \
        d(4,    STATUS_INVALID_TABLE, "invalid table")                                  \
        d(5,    STATUS_NOT_PERMISSIONED, "not permissioned")
List of response status values.

Definition at line 277 of file PublishTypes.h.

#define ACTIV_FIELD_STATUS_LIST ( d )

Value:

d(0,    FIELD_STATUS_INVALID_TYPE, "invalid type")                      \
            d(1,    FIELD_STATUS_INVALID_LENGTH, "invalid length")                  \
            d(2,    FIELD_STATUS_NOT_FOUND, "not found")                            \
            d(3,    FIELD_STATUS_FAILURE, "failure")                                \
            d(4,    FIELD_STATUS_NOT_PERMISSIONED, "not permissioned")
List of response block status values.

Definition at line 329 of file PublishTypes.h.

#define ACTIV_PUBLISH_RECORD_PARAMETERS_FLAG_LIST ( d )

Value:

d(0x00, FLAG_NONE)                                                                  \
        d(0x01, FLAG_BEST_EFFORT)                   \
        d(0x02, FLAG_DELETE)

Definition at line 102 of file PublishTypes.h.

Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivContributionGatewayApiCommon

Types.h File Reference

General contribution gateway types. More...

#include "ActivContentPlatform/ActivContributionGatewayApiCommon/External.h"
#include "ActivContentPlatform/MessageClasses.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedDefinitions.h"

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::ContributionGatewayApi

Classes

class | Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayInfo
Information about the ContributionGateway. More...
class | Activ::ContentPlatform::ContributionGatewayApi::PermissionInfo
Information about users permissioning. More...

Defines

#define | ACTIV_CONTRIBUTION_GATEWAY_USER_TYPE_LIST(d)
List of user type values.
#define | ACTIV_DECLARE_CONSTANT_USER_TYPE(val, id, name) const UserType id = val;
#define | ACTIV_DECLARE_FLAGS(value, id) static const Flags id = value;
#define | ACTIV_PERMISSION_INFO_FLAG_LIST(d)

Typedefs

typedef uint8_t | Activ::ContentPlatform::ContributionGatewayApi::UserType
User type type.

Functions

Activ::ContentPlatform::ContributionGatewayApi::ACTIV_DECLARE_MESSAGE_TYPE (5, MESSAGE_CLASS_CONTRIBUTION_GATEWAY, CONTRIBUTION_GATEWAY_MESSAGE_USER_ID_COUNT)
Activ::ContentPlatform::ContributionGatewayApi::ACTIV_DECLARE_MESSAGE_TYPE (4, MESSAGE_CLASS_CONTRIBUTION_GATEWAY, CONTRIBUTION_GATEWAY_MESSAGE_GET_USER_ID_COUNT)
Activ::ContentPlatform::ContributionGatewayApi::ACTIV_DECLARE_MESSAGE_TYPE (3, MESSAGE_CLASS_CONTRIBUTION_GATEWAY, CONTRIBUTION_GATEWAY_MESSAGE_GREETING)
Activ::ContentPlatform::ContributionGatewayApi::ACTIV_DECLARE_MESSAGE_TYPE (2, MESSAGE_CLASS_CONTRIBUTION_GATEWAY, CONTRIBUTION_GATEWAY_MESSAGE_STATS)
Activ::ContentPlatform::ContributionGatewayApi::ACTIV_DECLARE_MESSAGE_TYPE (1, MESSAGE_CLASS_CONTRIBUTION_GATEWAY, CONTRIBUTION_GATEWAY_MESSAGE_FAILOVER)
Activ::ContentPlatform::ContributionGatewayApi::ACTIV_DECLARE_MESSAGE_TYPE (0, MESSAGE_CLASS_CONTRIBUTION_GATEWAY, CONTRIBUTION_GATEWAY_MESSAGE_REPORT)
Contribution gateway message types.
Activ::ContentPlatform::ContributionGatewayApi::ACTIV_DECLARE_MESSAGE_TYPE (5, MESSAGE_CLASS_CONTRIBUTION_GATEWAY, CONTRIBUTION_GATEWAY_REQUEST_GET_PERMISSION_INFO)
Activ::ContentPlatform::ContributionGatewayApi::ACTIV_DECLARE_MESSAGE_TYPE (4, MESSAGE_CLASS_CONTRIBUTION_GATEWAY, CONTRIBUTION_GATEWAY_REQUEST_DELETE_RECORD)
Activ::ContentPlatform::ContributionGatewayApi::ACTIV_DECLARE_MESSAGE_TYPE (3, MESSAGE_CLASS_CONTRIBUTION_GATEWAY, CONTRIBUTION_GATEWAY_REQUEST_PUBLISH_RECORD)
Activ::ContentPlatform::ContributionGatewayApi::ACTIV_DECLARE_MESSAGE_TYPE (2, MESSAGE_CLASS_CONTRIBUTION_GATEWAY, CONTRIBUTION_GATEWAY_REQUEST_GET_SERVER_INFO)
Activ::ContentPlatform::ContributionGatewayApi::ACTIV_DECLARE_MESSAGE_TYPE (1, MESSAGE_CLASS_CONTRIBUTION_GATEWAY, CONTRIBUTION_GATEWAY_REQUEST_DELETE_SYMBOL_RECORD)
Activ::ContentPlatform::ContributionGatewayApi::ACTIV_DECLARE_MESSAGE_TYPE (0, MESSAGE_CLASS_CONTRIBUTION_GATEWAY, CONTRIBUTION_GATEWAY_REQUEST_PUBLISH_SYMBOL_RECORD)
Contribution gateway request types.
ACTIV_CONTRIBUTION_GATEWAY_API_COMMON_API
std::string 		Activ::ContentPlatform::ContributionGatewayApi::UserTypeToString (const UserType userType)
Return user type as string.

Variables

const UserType | Activ::ContentPlatform::ContributionGatewayApi::CONTRIBUTION_GATEWAY_USER_TYPE_API = 0
const UserType | Activ::ContentPlatform::ContributionGatewayApi::CONTRIBUTION_GATEWAY_USER_TYPE_DOT_NET_API = 1
const UserType | Activ::ContentPlatform::ContributionGatewayApi::CONTRIBUTION_GATEWAY_USER_TYPE_ISV = 3
const UserType | Activ::ContentPlatform::ContributionGatewayApi::CONTRIBUTION_GATEWAY_USER_TYPE_JAVA_API = 2

Detailed Description

General contribution gateway types.

Log

Definition in file Types.h.

Define Documentation

#define ACTIV_CONTRIBUTION_GATEWAY_USER_TYPE_LIST ( d )

Value:

d(0,    CONTRIBUTION_GATEWAY_USER_TYPE_API,                 "Api")          \
    d(1,    CONTRIBUTION_GATEWAY_USER_TYPE_DOT_NET_API,         ".Net Api")     \
    d(2,    CONTRIBUTION_GATEWAY_USER_TYPE_JAVA_API,            "Java Api")     \
    d(3,    CONTRIBUTION_GATEWAY_USER_TYPE_ISV,                 "Isv")
List of user type values.

Definition at line 52 of file Types.h.

#define ACTIV_PERMISSION_INFO_FLAG_LIST ( d )

Value:

d(0x00, FLAG_NONE)                                                  \
        d(0x01, FLAG_ALL_PERMISSION_IDS)            \
        d(0x02, FLAG_ALL_TABLE_NUMBERS)             \
        d(0x04, FLAG_ALL_EXCHANGE_CODES)

Definition at line 102 of file Types.h.

Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivContributionServerApi

ContributionServerClient.h File Reference

Contribution server api. More...

#include "ActivContentPlatform/ActivContributionServerApi/External.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/SymbolRecordRuleDefinitions.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/TableTemplateList.h"
#include "ActivMiddleware/ActivServices/UdpTransmitter.h"

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::ContributionServerApi

Classes

class | Activ::ContentPlatform::ContributionServerApi::ContributionServerClient
Contribution server client class. More...
class | Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::ApiInfo
Information returned from GetApiInfo(). More...
class | Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::RecordMessageBuilder
Record message builder class. More...
class | Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::Settings
Settings for contribution api class. More...
class | Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::SymbolRecordMessageBuilder
Symbol record message builder class. More...

Defines

#define | ACTIV_CONTRIBUTION_SERVER_API_VERSION_STRING "99.99.99.99"
ActivContributionServerApi version string.
#define | ACTIV_CONTRIBUTION_SERVER_API_VERSION_VALUE ACTIV_MAKE_VERSION_VALUE(99, 99, 99, 99)
ActivContributionServerApi version value.

Detailed Description

Contribution server api.

Log

Definition in file ContributionServerClient.h.

Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivContributionServerApi

External.h File Reference

Import rules for ActivContributionServerApi exports. More...

#include "ActivMiddleware/ActivFramework/ActivFramework.h"
#include "ActivContentPlatform/ActivFeedCommon/UpdateIds.h"
#include "ActivContentPlatform/ActivFeedCommon/EventTypes.h"

Go to the source code of this file.

Defines

#define ACTIV_CONTRIBUTION_SERVER_API ACTIV_IMPORT_DLL

Detailed Description

Import rules for ActivContributionServerApi exports.

Log

Definition in file External.h.

Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedApiCommon

External.h File Reference

Import rules for ActivFeedApiCommon exports. More...

#include "ActivMiddleware/ActivFramework/ActivFramework.h"

Go to the source code of this file.

Defines

#define ACTIV_FEED_API_COMMON_API ACTIV_IMPORT_DLL

Detailed Description

Import rules for ActivFeedApiCommon exports.

Log

Definition in file External.h.

Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedApiCommon

FieldListValidator.h File Reference

Header file for the field list validator class. More...

#include "ActivContentPlatform/ActivFeedApiCommon/External.h"
#include "ActivContentPlatform/ActivFeedApiCommon/FieldStatus.h"
#include "ActivContentPlatform/ActivFeedCommon/FieldIds.h"
#include "boost/dynamic_bitset.hpp"
#include <vector>

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::ContentGateway
namespace | Activ::ContentPlatform::ContentGatewayApi
namespace | Activ::ContentPlatform::ContentServerApi
namespace | Activ::ContentPlatform::FeedApi

Classes

class | Activ::ContentPlatform::FeedApi::FieldListValidator
Field list validator class. More...
class | Activ::ContentPlatform::FeedApi::FieldListValidator::CachedField
class | Activ::ContentPlatform::FeedApi::FieldListValidator::ConstIterator
Const iterator class. More...
class | Activ::ContentPlatform::FeedApi::FieldListValidator::Field
Field class. More...

Functions

ACTIV_FEED_API_COMMON_API
std::string 		Activ::ContentPlatform::FeedApi::FieldListValidatorToString (const FieldListValidator &fieldListValidator)
Return a field list validator as a string.

Detailed Description

Header file for the field list validator class.

Log

Definition in file FieldListValidator.h.

Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedApiCommon

FieldStatus.h File Reference

Header file for the field status definitions. More...

#include "ActivContentPlatform/ActivFeedApiCommon/External.h"

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::FeedApi

Defines

#define | ACTIV_DECLARE_CONSTANT_FIELD_STATUS(val, id, name) const FieldStatus id = val;
#define | ACTIV_FIELD_STATUS_TYPE_LIST(d)
List of field status values.

Typedefs

typedef uint8_t | Activ::ContentPlatform::FeedApi::FieldStatus
Field status type.

Functions

ACTIV_FEED_API_COMMON_API
std::string 		Activ::ContentPlatform::FeedApi::FieldStatusToString (const FieldStatus fieldStatus)
Return field status as string.

Variables

const FieldStatus | Activ::ContentPlatform::FeedApi::FIELD_STATUS_DEFINED = 0
const FieldStatus | Activ::ContentPlatform::FeedApi::FIELD_STATUS_NOT_FOUND = 2
const FieldStatus | Activ::ContentPlatform::FeedApi::FIELD_STATUS_NOT_PERMISSIONED = 3
const FieldStatus | Activ::ContentPlatform::FeedApi::FIELD_STATUS_UNDEFINED = 1

Detailed Description

Header file for the field status definitions.

Log

Definition in file FieldStatus.h.

Define Documentation

#define ACTIV_FIELD_STATUS_TYPE_LIST ( d )

Value:

d(0,    FIELD_STATUS_DEFINED,           "defined")          \
    d(1,    FIELD_STATUS_UNDEFINED,         "undefined")        \
    d(2,    FIELD_STATUS_NOT_FOUND,         "not found")        \
    d(3,    FIELD_STATUS_NOT_PERMISSIONED,  "not permissioned")
List of field status values.

Definition at line 26 of file FieldStatus.h.

Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon

ActivFeed.h File Reference

Main header file for ACTIV Feed. More...

#include "ActivContentPlatform/ActivFeedCommon/ActivFeedDefinitions.h"
#include "ActivContentPlatform/ActivFeedCommon/EventTypes.h"
#include "ActivContentPlatform/ActivFeedCommon/FieldIds.h"
#include "ActivContentPlatform/ActivFeedCommon/IndexNumbers.h"
#include "ActivContentPlatform/ActivFeedCommon/PermissionIds.h"
#include "ActivContentPlatform/ActivFeedCommon/RelationshipIds.h"
#include "ActivContentPlatform/ActivFeedCommon/TableNumbers.h"
#include "ActivContentPlatform/ActivFeedCommon/TableTypes.h"
#include "ActivContentPlatform/ActivFeedCommon/UpdateIds.h"

Go to the source code of this file.

Detailed Description

Main header file for ACTIV Feed.

Log

Definition in file ActivFeed.h.

Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon

ActivFeedDefinitions.h File Reference

Header file for activ feed definitions. More...

#include "ActivMiddleware/Activ.h"
#include <vector>

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::Feed

Typedefs

typedef uint32_t | Activ::ContentPlatform::Feed::Context
The symbol context type definition.
typedef uint16_t | Activ::ContentPlatform::Feed::CugId
The cug id type definition.
typedef std::vector< CugId > | Activ::ContentPlatform::Feed::CugIdList
The cug id list type definition.
typedef uint8_t | Activ::ContentPlatform::Feed::EventType
The event type type definition.
typedef uint16_t | Activ::ContentPlatform::Feed::FieldId
The field id type definition.
typedef std::vector< FieldId > | Activ::ContentPlatform::Feed::FieldIdList
The field id list type defintion.
typedef uint8_t | Activ::ContentPlatform::Feed::IndexNumber
The index number type definition.
typedef uint8_t | Activ::ContentPlatform::Feed::IndexProperties
The index properties definition.
typedef uint8_t | Activ::ContentPlatform::Feed::IndexType
The index type definition.
typedef uint16_t | Activ::ContentPlatform::Feed::PermissionId
The permission id type definition.
typedef std::vector< PermissionId > | Activ::ContentPlatform::Feed::PermissionIdList
The permission id list type definition.
typedef uint8_t | Activ::ContentPlatform::Feed::PermissionLevel
The permission level type definition.
typedef std::vector
< PermissionLevel > 		Activ::ContentPlatform::Feed::PermissionLevelList
The permission levels list type definition.
typedef uint16_t | Activ::ContentPlatform::Feed::RelationshipId
The relationship id type definition.
typedef uint8_t | Activ::ContentPlatform::Feed::RelationshipType
The relationship type definition.
typedef uint16_t | Activ::ContentPlatform::Feed::TableId
The table id type definition.
typedef uint16_t | Activ::ContentPlatform::Feed::TableNo
The table number type definition.
typedef std::vector< TableNo > | Activ::ContentPlatform::Feed::TableNoList
The table number list type definition.
typedef uint8_t | Activ::ContentPlatform::Feed::TableVersion
The table version type definition.
typedef uint16_t | Activ::ContentPlatform::Feed::UpdateId
The update id type definition.

Variables

const Context | Activ::ContentPlatform::Feed::CONTEXT_UNDEFINED = ~0
Context undefined.
const EventType | Activ::ContentPlatform::Feed::EVENT_TYPE_CONTRIBUTION_BASE = 232
Starting value for the event type of any contributed events.
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_CONTRIBUTION_BASE = 5000
Starting value for the table number of any contributed tables.
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_MAX = 8191
Maximum allowed table number.
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_UNDEFINED = ~0
Table number undefined.

Detailed Description

Header file for activ feed definitions.

Log

Definition in file ActivFeedDefinitions.h.

Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon

EntityTypeHelper.h File Reference

Header file for the entity type helper. More...

#include "ActivContentPlatform/ActivFeedCommon/External.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedDefinitions.h"
#include "ActivContentPlatform/ActivFeedCommon/EntityTypes.h"

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::Feed

Classes

class | Activ::ContentPlatform::Feed::EntityTypeHelper
Entity type helper class. More...

Functions

ACTIV_FEED_COMMON_API std::string | Activ::ContentPlatform::Feed::GetEntityTypeCodeIdentifier (const EntityType entityType)
Get the entity type code identifier.
ACTIV_FEED_COMMON_API const
EntityTypeHelper & 		Activ::ContentPlatform::Feed::GetEntityTypeHelper (const EntityType entityType)
Get the entity type helper.
ACTIV_FEED_COMMON_API std::string | Activ::ContentPlatform::Feed::GetEntityTypeName (const EntityType entityType)
Get the entity type name.

Detailed Description

Header file for the entity type helper.

Log

Definition in file EntityTypeHelper.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon

EntityTypes.h File Reference

Header file for entity types. More...

#include "ActivMiddleware/Activ.h"

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::Feed

Typedefs

typedef uint8_t | Activ::ContentPlatform::Feed::EntityType
The entity type type definition.

Variables

const EntityType | Activ::ContentPlatform::Feed::ENTITY_TYPE_ANALYTICS = 26
const EntityType | Activ::ContentPlatform::Feed::ENTITY_TYPE_BBO_DEPTH = 39
const EntityType | Activ::ContentPlatform::Feed::ENTITY_TYPE_BBO_QUOTE = 34
const EntityType | Activ::ContentPlatform::Feed::ENTITY_TYPE_BOND = 12
const EntityType | Activ::ContentPlatform::Feed::ENTITY_TYPE_COMPANY = 19
const EntityType | Activ::ContentPlatform::Feed::ENTITY_TYPE_CONVERTIBLE = 21
const EntityType | Activ::ContentPlatform::Feed::ENTITY_TYPE_CORPORATE_ACTION = 16
const EntityType | Activ::ContentPlatform::Feed::ENTITY_TYPE_CORPORATE_BOND = 6
const EntityType | Activ::ContentPlatform::Feed::ENTITY_TYPE_CURRENCY_OPTION = 4
const EntityType | Activ::ContentPlatform::Feed::ENTITY_TYPE_DEBENTURE = 22
const EntityType | Activ::ContentPlatform::Feed::ENTITY_TYPE_EQUITY = 1
const EntityType | Activ::ContentPlatform::Feed::ENTITY_TYPE_EQUITY_OPTION = 2
const EntityType | Activ::ContentPlatform::Feed::ENTITY_TYPE_EXCHANGE = 36
const EntityType | Activ::ContentPlatform::Feed::ENTITY_TYPE_EXCHANGE_TRADED_FUND = 18
const EntityType | Activ::ContentPlatform::Feed::ENTITY_TYPE_EXCHANGE_TRADED_NOTE = 48
const EntityType | Activ::ContentPlatform::Feed::ENTITY_TYPE_FOREX = 9
const EntityType | Activ::ContentPlatform::Feed::ENTITY_TYPE_FOREX_FORWARD = 37
const EntityType | Activ::ContentPlatform::Feed::ENTITY_TYPE_FUTURE = 7
const EntityType | Activ::ContentPlatform::Feed::ENTITY_TYPE_FUTURE_OPTION = 8
const EntityType | Activ::ContentPlatform::Feed::ENTITY_TYPE_FUTURE_OPTION_ROOT = 30
const EntityType | Activ::ContentPlatform::Feed::ENTITY_TYPE_FUTURE_ROOT = 29
const EntityType | Activ::ContentPlatform::Feed::ENTITY_TYPE_FUTURES_SPREAD = 35
const EntityType | Activ::ContentPlatform::Feed::ENTITY_TYPE_GOVERNMENT_BOND = 14
const EntityType | Activ::ContentPlatform::Feed::ENTITY_TYPE_INDEX = 5
const EntityType | Activ::ContentPlatform::Feed::ENTITY_TYPE_INDEX_OPTION = 3
const EntityType | Activ::ContentPlatform::Feed::ENTITY_TYPE_LOAN_STOCK = 46
const EntityType | Activ::ContentPlatform::Feed::ENTITY_TYPE_MARKET_MAKER_QUOTE = 13
const EntityType | Activ::ContentPlatform::Feed::ENTITY_TYPE_MONEY_MARKET_FUND = 11
const EntityType | Activ::ContentPlatform::Feed::ENTITY_TYPE_MUTUAL_FUND = 10
const EntityType | Activ::ContentPlatform::Feed::ENTITY_TYPE_NEWS = 25
const EntityType | Activ::ContentPlatform::Feed::ENTITY_TYPE_NEWS_HEADLINE = 31
const EntityType | Activ::ContentPlatform::Feed::ENTITY_TYPE_NON_CONVERTIBLE_LOAN = 47
const EntityType | Activ::ContentPlatform::Feed::ENTITY_TYPE_NON_STANDARD_OPTION = 40
const EntityType | Activ::ContentPlatform::Feed::ENTITY_TYPE_NONE = 0
const EntityType | Activ::ContentPlatform::Feed::ENTITY_TYPE_OPTION_ROOT = 28
const EntityType | Activ::ContentPlatform::Feed::ENTITY_TYPE_ORDER = 27
const EntityType | Activ::ContentPlatform::Feed::ENTITY_TYPE_PREFERENCE = 23
const EntityType | Activ::ContentPlatform::Feed::ENTITY_TYPE_RANKINGS = 33
const EntityType | Activ::ContentPlatform::Feed::ENTITY_TYPE_RIGHTS = 45
const EntityType | Activ::ContentPlatform::Feed::ENTITY_TYPE_SECURITY = 20
const EntityType | Activ::ContentPlatform::Feed::ENTITY_TYPE_SPOT = 15
const EntityType | Activ::ContentPlatform::Feed::ENTITY_TYPE_STATISTICS = 32
const EntityType | Activ::ContentPlatform::Feed::ENTITY_TYPE_STRATEGY = 41
const EntityType | Activ::ContentPlatform::Feed::ENTITY_TYPE_STRATEGY_LEG = 42
const EntityType | Activ::ContentPlatform::Feed::ENTITY_TYPE_STRUCTURED_PRODUCT = 38
const EntityType | Activ::ContentPlatform::Feed::ENTITY_TYPE_UNIT_INVESTMENT_TRUST = 17
const EntityType | Activ::ContentPlatform::Feed::ENTITY_TYPE_WARRANT = 24

Detailed Description

Header file for entity types.

Log

Definition in file EntityTypes.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon

Enumerations.h File Reference

Header file for the enumerations. More...

#include "ActivMiddleware/Activ.h"

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::Feed

Typedefs

typedef uint8_t | Activ::ContentPlatform::Feed::CloseStatus
The close status type definition.
typedef uint8_t | Activ::ContentPlatform::Feed::ContractType
typedef uint8_t | Activ::ContentPlatform::Feed::DisplayDenominator
The display denominator type definition.
typedef uint32_t | Activ::ContentPlatform::Feed::DividendFrequencyCode
The dividend frequency code type definition.
typedef uint8_t | Activ::ContentPlatform::Feed::DividendStatus
The dividend status type definition.
typedef char | Activ::ContentPlatform::Feed::ExerciseStyle
The exercise style type definition.
typedef uint8_t | Activ::ContentPlatform::Feed::ExMarker
The ex marker type definition.
typedef uint8_t | Activ::ContentPlatform::Feed::ExpirationType
The exercise type type definition.
typedef uint8_t | Activ::ContentPlatform::Feed::MarketMakerStatus
The market maker status type definition.
typedef uint16_t | Activ::ContentPlatform::Feed::NewsState
The news state type definition.
typedef char | Activ::ContentPlatform::Feed::OptionType
The option type type definition.
typedef uint8_t | Activ::ContentPlatform::Feed::OrderType
The order type type definition.
typedef char | Activ::ContentPlatform::Feed::SettlementType
The settlement type type definition.
typedef uint8_t | Activ::ContentPlatform::Feed::SplitType
The split type type definition.
typedef uint16_t | Activ::ContentPlatform::Feed::State
The state type definition.
typedef uint8_t | Activ::ContentPlatform::Feed::UnitOfMeasure
The unit of measure type definition.

Variables

const CloseStatus | Activ::ContentPlatform::Feed::CLOSE_STATUS_CALCULATED_OFFICIAL = 2
const CloseStatus | Activ::ContentPlatform::Feed::CLOSE_STATUS_CALCULATED_UNOFFICIAL = 1
const CloseStatus | Activ::ContentPlatform::Feed::CLOSE_STATUS_EXCHANGE_OFFICIAL = 4
const CloseStatus | Activ::ContentPlatform::Feed::CLOSE_STATUS_EXCHANGE_UNOFFICIAL = 3
const CloseStatus | Activ::ContentPlatform::Feed::CLOSE_STATUS_NONE = 0
const ContractType | Activ::ContentPlatform::Feed::CONTRACT_TYPE_ADJUSTMENT = 1
const ContractType | Activ::ContentPlatform::Feed::CONTRACT_TYPE_BINARY = 7
const ContractType | Activ::ContentPlatform::Feed::CONTRACT_TYPE_CREDIT_DEFAULT = 5
const ContractType | Activ::ContentPlatform::Feed::CONTRACT_TYPE_DELAYED_START = 8
const ContractType | Activ::ContentPlatform::Feed::CONTRACT_TYPE_FIXED_RETURN = 6
const ContractType | Activ::ContentPlatform::Feed::CONTRACT_TYPE_MERGER = 3
const ContractType | Activ::ContentPlatform::Feed::CONTRACT_TYPE_NORMAL = 0
The contract type type definition.
const ContractType | Activ::ContentPlatform::Feed::CONTRACT_TYPE_PERCENTAGE = 4
const ContractType | Activ::ContentPlatform::Feed::CONTRACT_TYPE_RANGE = 9
const ContractType | Activ::ContentPlatform::Feed::CONTRACT_TYPE_SPINOFF = 2
const DisplayDenominator | Activ::ContentPlatform::Feed::DISPLAY_DENOMINATOR_128TH = 25
const DisplayDenominator | Activ::ContentPlatform::Feed::DISPLAY_DENOMINATOR_16TH = 22
const DisplayDenominator | Activ::ContentPlatform::Feed::DISPLAY_DENOMINATOR_1DP = 1
const DisplayDenominator | Activ::ContentPlatform::Feed::DISPLAY_DENOMINATOR_256TH = 26
const DisplayDenominator | Activ::ContentPlatform::Feed::DISPLAY_DENOMINATOR_2DP = 2
const DisplayDenominator | Activ::ContentPlatform::Feed::DISPLAY_DENOMINATOR_32ND = 23
const DisplayDenominator | Activ::ContentPlatform::Feed::DISPLAY_DENOMINATOR_3DP = 3
const DisplayDenominator | Activ::ContentPlatform::Feed::DISPLAY_DENOMINATOR_4DP = 4
const DisplayDenominator | Activ::ContentPlatform::Feed::DISPLAY_DENOMINATOR_512TH = 27
const DisplayDenominator | Activ::ContentPlatform::Feed::DISPLAY_DENOMINATOR_5DP = 5
const DisplayDenominator | Activ::ContentPlatform::Feed::DISPLAY_DENOMINATOR_64TH = 24
const DisplayDenominator | Activ::ContentPlatform::Feed::DISPLAY_DENOMINATOR_6DP = 6
const DisplayDenominator | Activ::ContentPlatform::Feed::DISPLAY_DENOMINATOR_7DP = 7
const DisplayDenominator | Activ::ContentPlatform::Feed::DISPLAY_DENOMINATOR_8DP = 8
const DisplayDenominator | Activ::ContentPlatform::Feed::DISPLAY_DENOMINATOR_8TH = 21
const DisplayDenominator | Activ::ContentPlatform::Feed::DISPLAY_DENOMINATOR_9DP = 9
const DisplayDenominator | Activ::ContentPlatform::Feed::DISPLAY_DENOMINATOR_CABINET = 28
const DisplayDenominator | Activ::ContentPlatform::Feed::DISPLAY_DENOMINATOR_HALF = 19
const DisplayDenominator | Activ::ContentPlatform::Feed::DISPLAY_DENOMINATOR_HALF_32ND = 33
const DisplayDenominator | Activ::ContentPlatform::Feed::DISPLAY_DENOMINATOR_HALF_64TH = 34
const DisplayDenominator | Activ::ContentPlatform::Feed::DISPLAY_DENOMINATOR_QUARTER = 20
const DisplayDenominator | Activ::ContentPlatform::Feed::DISPLAY_DENOMINATOR_REDUCED_FRACTION = 32
const DisplayDenominator | Activ::ContentPlatform::Feed::DISPLAY_DENOMINATOR_RESERVED_1 = 30
const DisplayDenominator | Activ::ContentPlatform::Feed::DISPLAY_DENOMINATOR_RESERVED_2 = 31
const DisplayDenominator | Activ::ContentPlatform::Feed::DISPLAY_DENOMINATOR_UNDEFINED = 29
const DisplayDenominator | Activ::ContentPlatform::Feed::DISPLAY_DENOMINATOR_WHOLE = 0
const DisplayDenominator | Activ::ContentPlatform::Feed::DISPLAY_DENOMINATOR_X1E1 = 10
const DisplayDenominator | Activ::ContentPlatform::Feed::DISPLAY_DENOMINATOR_X1E2 = 11
const DisplayDenominator | Activ::ContentPlatform::Feed::DISPLAY_DENOMINATOR_X1E3 = 12
const DisplayDenominator | Activ::ContentPlatform::Feed::DISPLAY_DENOMINATOR_X1E4 = 13
const DisplayDenominator | Activ::ContentPlatform::Feed::DISPLAY_DENOMINATOR_X1E5 = 14
const DisplayDenominator | Activ::ContentPlatform::Feed::DISPLAY_DENOMINATOR_X1E6 = 15
const DisplayDenominator | Activ::ContentPlatform::Feed::DISPLAY_DENOMINATOR_X1E7 = 16
const DisplayDenominator | Activ::ContentPlatform::Feed::DISPLAY_DENOMINATOR_X1E8 = 17
const DisplayDenominator | Activ::ContentPlatform::Feed::DISPLAY_DENOMINATOR_X1E9 = 18
const DividendFrequencyCode | Activ::ContentPlatform::Feed::DIVIDEND_FREQUENCY_CODE_ANNUALLY = 0
const DividendFrequencyCode | Activ::ContentPlatform::Feed::DIVIDEND_FREQUENCY_CODE_MONTHLY = 1
const DividendFrequencyCode | Activ::ContentPlatform::Feed::DIVIDEND_FREQUENCY_CODE_OTHER = 4
const DividendFrequencyCode | Activ::ContentPlatform::Feed::DIVIDEND_FREQUENCY_CODE_QUARTERLY = 2
const DividendFrequencyCode | Activ::ContentPlatform::Feed::DIVIDEND_FREQUENCY_CODE_SEMI_ANNUALLY = 3
const DividendStatus | Activ::ContentPlatform::Feed::DIVIDEND_STATUS_OFFICIAL = 1
const DividendStatus | Activ::ContentPlatform::Feed::DIVIDEND_STATUS_UNOFFICIAL = 0
const size_t | Activ::ContentPlatform::Feed::EX_MARKER_EX_DIV_BYTE_OFFSET = 0
const ExMarker | Activ::ContentPlatform::Feed::EX_MARKER_NONE = 0
const ExMarker | Activ::ContentPlatform::Feed::EX_MARKER_TODAY = 1
const char | Activ::ContentPlatform::Feed::EXERCISE_STYLE_AMERICAN = 'A'
const char | Activ::ContentPlatform::Feed::EXERCISE_STYLE_EUROPEAN = 'E'
const ExpirationType | Activ::ContentPlatform::Feed::EXPIRATION_TYPE_CREDIT_DEFAULT = 8
const ExpirationType | Activ::ContentPlatform::Feed::EXPIRATION_TYPE_FIFTH_FRIDAY = 5
const ExpirationType | Activ::ContentPlatform::Feed::EXPIRATION_TYPE_FIRST_FRIDAY = 1
const ExpirationType | Activ::ContentPlatform::Feed::EXPIRATION_TYPE_FOURTH_FRIDAY = 4
const ExpirationType | Activ::ContentPlatform::Feed::EXPIRATION_TYPE_MID_MONTH = 0
const ExpirationType | Activ::ContentPlatform::Feed::EXPIRATION_TYPE_QUARTERLY_END_MONTH = 7
const ExpirationType | Activ::ContentPlatform::Feed::EXPIRATION_TYPE_SECOND_FRIDAY = 2
const ExpirationType | Activ::ContentPlatform::Feed::EXPIRATION_TYPE_THIRD_FRIDAY = 3
const ExpirationType | Activ::ContentPlatform::Feed::EXPIRATION_TYPE_WEDNESDAY_MID_MONTH = 6
const MarketMakerStatus | Activ::ContentPlatform::Feed::MARKET_MAKER_STATUS_NONE = 0
const MarketMakerStatus | Activ::ContentPlatform::Feed::MARKET_MAKER_STATUS_PRIMARY = 1
const NewsState | Activ::ContentPlatform::Feed::NEWS_STATE_BIT_DISABLE_NEWS_ALERT = 2
const NewsState | Activ::ContentPlatform::Feed::NEWS_STATE_BIT_EXPIRED = 3
const NewsState | Activ::ContentPlatform::Feed::NEWS_STATE_BIT_HOT = 0
const NewsState | Activ::ContentPlatform::Feed::NEWS_STATE_BIT_TEMPORARY = 1
const NewsState | Activ::ContentPlatform::Feed::NEWS_STATE_DISABLE_NEWS_ALERT = (1 << ((sizeof(NewsState) * CHAR_BIT) - (NEWS_STATE_BIT_DISABLE_NEWS_ALERT + 1)))
const NewsState | Activ::ContentPlatform::Feed::NEWS_STATE_EXPIRED = (1 << ((sizeof(NewsState) * CHAR_BIT) - (NEWS_STATE_BIT_EXPIRED + 1)))
const NewsState | Activ::ContentPlatform::Feed::NEWS_STATE_HOT = (1 << ((sizeof(NewsState) * CHAR_BIT) - (NEWS_STATE_BIT_HOT + 1)))
const NewsState | Activ::ContentPlatform::Feed::NEWS_STATE_NONE = 0
const NewsState | Activ::ContentPlatform::Feed::NEWS_STATE_TEMPORARY = (1 << ((sizeof(NewsState) * CHAR_BIT) - (NEWS_STATE_BIT_TEMPORARY + 1)))
const OptionType | Activ::ContentPlatform::Feed::OPTION_TYPE_CALL = 'C'
const OptionType | Activ::ContentPlatform::Feed::OPTION_TYPE_PUT = 'P'
const OrderType | Activ::ContentPlatform::Feed::ORDER_TYPE_ALL_OR_NONE = 2
const OrderType | Activ::ContentPlatform::Feed::ORDER_TYPE_LIMIT_ORDER = 0
const OrderType | Activ::ContentPlatform::Feed::ORDER_TYPE_LOTS_OF = 3
const OrderType | Activ::ContentPlatform::Feed::ORDER_TYPE_MARKET_ORDER = 1
const OrderType | Activ::ContentPlatform::Feed::ORDER_TYPE_MINIMUM_FILL = 4
const OrderType | Activ::ContentPlatform::Feed::ORDER_TYPE_SPECIAL = 5
const SettlementType | Activ::ContentPlatform::Feed::SETTLEMENT_TYPE_AM = 'A'
const SettlementType | Activ::ContentPlatform::Feed::SETTLEMENT_TYPE_PM = 'P'
const SplitType | Activ::ContentPlatform::Feed::SPLIT_TYPE_DISTRIBUTION = 2
const SplitType | Activ::ContentPlatform::Feed::SPLIT_TYPE_PRICE_ADJUSTMENT = 4
const SplitType | Activ::ContentPlatform::Feed::SPLIT_TYPE_REDUCTION = 3
const SplitType | Activ::ContentPlatform::Feed::SPLIT_TYPE_REVERSE = 1
const SplitType | Activ::ContentPlatform::Feed::SPLIT_TYPE_SPLIT = 0
const State | Activ::ContentPlatform::Feed::STATE_BIT_CLOSED = 0
const State | Activ::ContentPlatform::Feed::STATE_BIT_HALTED = 1
const State | Activ::ContentPlatform::Feed::STATE_BIT_RESTRICTED = 2
const State | Activ::ContentPlatform::Feed::STATE_CLOSED = (1 << ((sizeof(State) * CHAR_BIT) - (STATE_BIT_CLOSED + 1)))
const State | Activ::ContentPlatform::Feed::STATE_HALTED = (1 << ((sizeof(State) * CHAR_BIT) - (STATE_BIT_HALTED + 1)))
const State | Activ::ContentPlatform::Feed::STATE_NONE = 0
const State | Activ::ContentPlatform::Feed::STATE_RESTRICTED = (1 << ((sizeof(State) * CHAR_BIT) - (STATE_BIT_RESTRICTED + 1)))
const UnitOfMeasure | Activ::ContentPlatform::Feed::UNIT_OF_MEASURE_BAGS = 2
const UnitOfMeasure | Activ::ContentPlatform::Feed::UNIT_OF_MEASURE_BALES = 18
const UnitOfMeasure | Activ::ContentPlatform::Feed::UNIT_OF_MEASURE_BARRELS = 4
const UnitOfMeasure | Activ::ContentPlatform::Feed::UNIT_OF_MEASURE_BOARD_FEET = 16
const UnitOfMeasure | Activ::ContentPlatform::Feed::UNIT_OF_MEASURE_BOTTLE_FLASKS = 20
const UnitOfMeasure | Activ::ContentPlatform::Feed::UNIT_OF_MEASURE_BOX_CASES = 19
const UnitOfMeasure | Activ::ContentPlatform::Feed::UNIT_OF_MEASURE_BTU_MILLIONS = 23
const UnitOfMeasure | Activ::ContentPlatform::Feed::UNIT_OF_MEASURE_BUSHELS = 3
const UnitOfMeasure | Activ::ContentPlatform::Feed::UNIT_OF_MEASURE_CERTIFIED_EMISSION_REDUCTION = 44
const UnitOfMeasure | Activ::ContentPlatform::Feed::UNIT_OF_MEASURE_CO2_ALLOWANCE = 46
const UnitOfMeasure | Activ::ContentPlatform::Feed::UNIT_OF_MEASURE_COINS = 17
const UnitOfMeasure | Activ::ContentPlatform::Feed::UNIT_OF_MEASURE_CURRENCY = 40
const UnitOfMeasure | Activ::ContentPlatform::Feed::UNIT_OF_MEASURE_DOZENS = 29
const UnitOfMeasure | Activ::ContentPlatform::Feed::UNIT_OF_MEASURE_EU_EMISSION_ALLOWANCE = 45
const UnitOfMeasure | Activ::ContentPlatform::Feed::UNIT_OF_MEASURE_FINE_TROY_OUNCES = 14
const UnitOfMeasure | Activ::ContentPlatform::Feed::UNIT_OF_MEASURE_FUTURES_CONTRACTS = 39
const UnitOfMeasure | Activ::ContentPlatform::Feed::UNIT_OF_MEASURE_GALLONS = 5
const UnitOfMeasure | Activ::ContentPlatform::Feed::UNIT_OF_MEASURE_GRAMS = 6
const UnitOfMeasure | Activ::ContentPlatform::Feed::UNIT_OF_MEASURE_HUNDRED_PIECES = 35
const UnitOfMeasure | Activ::ContentPlatform::Feed::UNIT_OF_MEASURE_HUNDRED_WEIGHT = 25
const UnitOfMeasure | Activ::ContentPlatform::Feed::UNIT_OF_MEASURE_HUNDRED_WEIGHT_112LBS = 26
const UnitOfMeasure | Activ::ContentPlatform::Feed::UNIT_OF_MEASURE_HUNDREDS = 30
const UnitOfMeasure | Activ::ContentPlatform::Feed::UNIT_OF_MEASURE_INDICES = 38
const UnitOfMeasure | Activ::ContentPlatform::Feed::UNIT_OF_MEASURE_KILOLITERS = 43
const UnitOfMeasure | Activ::ContentPlatform::Feed::UNIT_OF_MEASURE_KILOS = 7
const UnitOfMeasure | Activ::ContentPlatform::Feed::UNIT_OF_MEASURE_LITERS = 42
const UnitOfMeasure | Activ::ContentPlatform::Feed::UNIT_OF_MEASURE_LONG_TONS = 9
const UnitOfMeasure | Activ::ContentPlatform::Feed::UNIT_OF_MEASURE_MEGA_WATT_HOURS = 24
const UnitOfMeasure | Activ::ContentPlatform::Feed::UNIT_OF_MEASURE_METRIC_TONS = 10
const UnitOfMeasure | Activ::ContentPlatform::Feed::UNIT_OF_MEASURE_MILLIONS = 32
const UnitOfMeasure | Activ::ContentPlatform::Feed::UNIT_OF_MEASURE_NOMINAL = 1
const UnitOfMeasure | Activ::ContentPlatform::Feed::UNIT_OF_MEASURE_NON_FAT_DRY_MILK = 22
const UnitOfMeasure | Activ::ContentPlatform::Feed::UNIT_OF_MEASURE_NONE = 0
const UnitOfMeasure | Activ::ContentPlatform::Feed::UNIT_OF_MEASURE_ONES = 27
const UnitOfMeasure | Activ::ContentPlatform::Feed::UNIT_OF_MEASURE_OUNCES = 11
const UnitOfMeasure | Activ::ContentPlatform::Feed::UNIT_OF_MEASURE_PERCENT = 21
const UnitOfMeasure | Activ::ContentPlatform::Feed::UNIT_OF_MEASURE_PIECES = 33
const UnitOfMeasure | Activ::ContentPlatform::Feed::UNIT_OF_MEASURE_POUNDS = 12
const UnitOfMeasure | Activ::ContentPlatform::Feed::UNIT_OF_MEASURE_SHARES = 41
const UnitOfMeasure | Activ::ContentPlatform::Feed::UNIT_OF_MEASURE_SHORT_TONS = 8
const UnitOfMeasure | Activ::ContentPlatform::Feed::UNIT_OF_MEASURE_SQUARE_FEET = 13
const UnitOfMeasure | Activ::ContentPlatform::Feed::UNIT_OF_MEASURE_TEN_PIECES = 34
const UnitOfMeasure | Activ::ContentPlatform::Feed::UNIT_OF_MEASURE_TEN_THOUSAND_PIECES = 37
const UnitOfMeasure | Activ::ContentPlatform::Feed::UNIT_OF_MEASURE_TENS = 28
const UnitOfMeasure | Activ::ContentPlatform::Feed::UNIT_OF_MEASURE_THOUSAND_PIECES = 36
const UnitOfMeasure | Activ::ContentPlatform::Feed::UNIT_OF_MEASURE_THOUSANDS = 31
const UnitOfMeasure | Activ::ContentPlatform::Feed::UNIT_OF_MEASURE_TROY_OUNCES = 15

Detailed Description

Header file for the enumerations.

Log

Definition in file Enumerations.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon

EventTypeHelper.h File Reference

Header file for the event type helper. More...

#include "ActivContentPlatform/ActivFeedCommon/External.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedDefinitions.h"
#include "ActivContentPlatform/ActivFeedCommon/EventTypes.h"

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::Feed

Classes

class | Activ::ContentPlatform::Feed::EventTypeHelper
Event type helper class. More...

Functions

ACTIV_FEED_COMMON_API std::string | Activ::ContentPlatform::Feed::GetEventTypeCodeIdentifier (const EventType eventType)
Get the event type code identifier.
ACTIV_FEED_COMMON_API const
EventTypeHelper & 		Activ::ContentPlatform::Feed::GetEventTypeHelper (const EventType eventType)
Get the event type helper.
ACTIV_FEED_COMMON_API std::string | Activ::ContentPlatform::Feed::GetEventTypeName (const EventType eventType)
Get the event type name.

Detailed Description

Header file for the event type helper.

Log

Definition in file EventTypeHelper.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon

EventTypes.h File Reference

Header file for the event types. More...

#include "ActivMiddleware/Activ.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedDefinitions.h"

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::Feed

Variables

const EventType | Activ::ContentPlatform::Feed::EVENT_TYPE_ALERT = 38
const EventType | Activ::ContentPlatform::Feed::EVENT_TYPE_BBO_DEPTH = 7
const EventType | Activ::ContentPlatform::Feed::EVENT_TYPE_BBO_QUOTE = 3
const EventType | Activ::ContentPlatform::Feed::EVENT_TYPE_CACHE_FLUSH = 45
const EventType | Activ::ContentPlatform::Feed::EVENT_TYPE_CLOSE = 27
const EventType | Activ::ContentPlatform::Feed::EVENT_TYPE_CLOSING_BBO_QUOTE = 26
const EventType | Activ::ContentPlatform::Feed::EVENT_TYPE_CLOSING_QUOTE = 25
const EventType | Activ::ContentPlatform::Feed::EVENT_TYPE_COMPOSITE_BBO_QUOTE = 29
const EventType | Activ::ContentPlatform::Feed::EVENT_TYPE_DELIST = 13
const EventType | Activ::ContentPlatform::Feed::EVENT_TYPE_DELIST_CANCEL = 14
const EventType | Activ::ContentPlatform::Feed::EVENT_TYPE_DIVIDEND = 15
const EventType | Activ::ContentPlatform::Feed::EVENT_TYPE_DIVIDEND_CANCEL = 16
const EventType | Activ::ContentPlatform::Feed::EVENT_TYPE_DIVIDEND_CORRECTION = 17
const EventType | Activ::ContentPlatform::Feed::EVENT_TYPE_FORCE_PROCESS_REFRESH = 40
const EventType | Activ::ContentPlatform::Feed::EVENT_TYPE_HALT_RESUME = 42
const EventType | Activ::ContentPlatform::Feed::EVENT_TYPE_IMBALANCE_VOLUME = 43
const EventType | Activ::ContentPlatform::Feed::EVENT_TYPE_IMPLIED_BBO_QUOTE = 48
const EventType | Activ::ContentPlatform::Feed::EVENT_TYPE_IPO = 11
const EventType | Activ::ContentPlatform::Feed::EVENT_TYPE_IPO_CANCEL = 12
const EventType | Activ::ContentPlatform::Feed::EVENT_TYPE_LRP_PRICE = 47
const EventType | Activ::ContentPlatform::Feed::EVENT_TYPE_MARKET_DEPTH = EVENT_TYPE_BBO_DEPTH
Deprecated.
const EventType | Activ::ContentPlatform::Feed::EVENT_TYPE_MULTIPLE_DELETE = 46
const EventType | Activ::ContentPlatform::Feed::EVENT_TYPE_NEWS = 30
const EventType | Activ::ContentPlatform::Feed::EVENT_TYPE_NEWS_DELETE = 36
const EventType | Activ::ContentPlatform::Feed::EVENT_TYPE_NONE = 0
const EventType | Activ::ContentPlatform::Feed::EVENT_TYPE_OPEN = 35
const EventType | Activ::ContentPlatform::Feed::EVENT_TYPE_OPTION_REFRESH = 41
const EventType | Activ::ContentPlatform::Feed::EVENT_TYPE_OPTION_SPLIT = 24
const EventType | Activ::ContentPlatform::Feed::EVENT_TYPE_OPTION_SYMBOL_CHANGE = 23
const EventType | Activ::ContentPlatform::Feed::EVENT_TYPE_ORDER = 9
const EventType | Activ::ContentPlatform::Feed::EVENT_TYPE_PRICE_ADJUSTMENT = 33
const EventType | Activ::ContentPlatform::Feed::EVENT_TYPE_PRICE_ADJUSTMENT_CANCEL = 34
const EventType | Activ::ContentPlatform::Feed::EVENT_TYPE_PRICE_INDICATION = 44
const EventType | Activ::ContentPlatform::Feed::EVENT_TYPE_PURGE = 37
const EventType | Activ::ContentPlatform::Feed::EVENT_TYPE_QUOTE = 10
const EventType | Activ::ContentPlatform::Feed::EVENT_TYPE_REFRESH = 8
const EventType | Activ::ContentPlatform::Feed::EVENT_TYPE_REFRESH_CYCLE = 39
const EventType | Activ::ContentPlatform::Feed::EVENT_TYPE_RESET = 28
const EventType | Activ::ContentPlatform::Feed::EVENT_TYPE_SPLIT = 18
const EventType | Activ::ContentPlatform::Feed::EVENT_TYPE_SPLIT_CANCEL = 19
const EventType | Activ::ContentPlatform::Feed::EVENT_TYPE_SPLIT_CORRECTION = 20
const EventType | Activ::ContentPlatform::Feed::EVENT_TYPE_SYMBOL_CHANGE = 21
const EventType | Activ::ContentPlatform::Feed::EVENT_TYPE_SYMBOL_CHANGE_CANCEL = 22
const EventType | Activ::ContentPlatform::Feed::EVENT_TYPE_TICK = 2
const EventType | Activ::ContentPlatform::Feed::EVENT_TYPE_TIME_SERIES_ADJUSTMENT = 49
const EventType | Activ::ContentPlatform::Feed::EVENT_TYPE_TIME_SERIES_CORRECTION = 31
const EventType | Activ::ContentPlatform::Feed::EVENT_TYPE_TIME_SERIES_DELETE = 32
const EventType | Activ::ContentPlatform::Feed::EVENT_TYPE_TRADE = 1
const EventType | Activ::ContentPlatform::Feed::EVENT_TYPE_TRADE_CANCEL = 5
const EventType | Activ::ContentPlatform::Feed::EVENT_TYPE_TRADE_CORRECTION = 4
const EventType | Activ::ContentPlatform::Feed::EVENT_TYPE_TRADE_LATE = EVENT_TYPE_TRADE_NON_REGULAR
Deprecated.
const EventType | Activ::ContentPlatform::Feed::EVENT_TYPE_TRADE_NON_REGULAR = 6

Detailed Description

Header file for the event types.

Log

Definition in file EventTypes.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon

Exchanges.h File Reference

Header file for the exchanges. More...

#include "ActivMiddleware/Activ.h"
#include "ActivMiddleware/Misc/StlHelper.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedDefinitions.h"
#include <vector>
#include <string>
#include <map>

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::Feed

Defines

#define | ACTIV_DECLARE_FEED_SYMBOL_SEPARATOR(id, value) const char id = value;
#define | ACTIV_FEED_EXCHANGE_ALPHA_TRADING "ATS"
#define | ACTIV_FEED_EXCHANGE_AMEX "A"
#define | ACTIV_FEED_EXCHANGE_AMEX_OPTIONS "AO"
#define | ACTIV_FEED_EXCHANGE_ARCA ACTIV_FEED_EXCHANGE_NYSE_ARCA_DIRECT
#define | ACTIV_FEED_EXCHANGE_ASX "AX"
#define | ACTIV_FEED_EXCHANGE_BATS "BT"
#define | ACTIV_FEED_EXCHANGE_BATS_DIRECT "EB"
#define | ACTIV_FEED_EXCHANGE_BMF "BMF"
#define | ACTIV_FEED_EXCHANGE_BOSTON "B"
#define | ACTIV_FEED_EXCHANGE_BOSTON_OPTIONS "BO"
#define | ACTIV_FEED_EXCHANGE_BOVESPA "BS"
#define | ACTIV_FEED_EXCHANGE_CBOE "W"
#define | ACTIV_FEED_EXCHANGE_CBOT "CB"
#define | ACTIV_FEED_EXCHANGE_CBOT_GLOBEX "CBE"
#define | ACTIV_FEED_EXCHANGE_CFE "CF"
#define | ACTIV_FEED_EXCHANGE_CHI_X_CANADA "CHIC"
#define | ACTIV_FEED_EXCHANGE_CHI_X_EUROPE "CHIX"
#define | ACTIV_FEED_EXCHANGE_CHICAGO ACTIV_FEED_EXCHANGE_CHX
#define | ACTIV_FEED_EXCHANGE_CHX "MW"
#define | ACTIV_FEED_EXCHANGE_CHX_DIRECT "CH"
#define | ACTIV_FEED_EXCHANGE_CINCINNATI ACTIV_FEED_EXCHANGE_NSX
#define | ACTIV_FEED_EXCHANGE_CME "CM"
#define | ACTIV_FEED_EXCHANGE_CME_GLOBEX "CMG"
#define | ACTIV_FEED_EXCHANGE_CNQ "CQ"
#define | ACTIV_FEED_EXCHANGE_COMEX "CX"
#define | ACTIV_FEED_EXCHANGE_COMEX_ACCESS "CXA"
#define | ACTIV_FEED_EXCHANGE_DIRECT_EDGE "ED"
#define | ACTIV_FEED_EXCHANGE_DUBAI_MERCANTILE_EXCHANGE "DME"
#define | ACTIV_FEED_EXCHANGE_E_CBOT ACTIV_FEED_EXCHANGE_CBOT_GLOBEX
#define | ACTIV_FEED_EXCHANGE_E_NYMEX "NXF"
#define | ACTIV_FEED_EXCHANGE_E_NYMEX_EUROPE "NXE"
#define | ACTIV_FEED_EXCHANGE_EUREX "EX"
#define | ACTIV_FEED_EXCHANGE_EURONEXT_LIFFE "LI"
#define | ACTIV_FEED_EXCHANGE_EURONEXT_PARIS "P"
#define | ACTIV_FEED_EXCHANGE_FEED_STATUS "FEED"
#define | ACTIV_FEED_EXCHANGE_FUKUOKA "FU"
#define | ACTIV_FEED_EXCHANGE_HKFE "HF"
#define | ACTIV_FEED_EXCHANGE_HKSE "HK"
#define | ACTIV_FEED_EXCHANGE_ICE "ICE"
#define | ACTIV_FEED_EXCHANGE_INET "EI"
#define | ACTIV_FEED_EXCHANGE_INSTINET_CBX "CBX"
#define | ACTIV_FEED_EXCHANGE_INTERNATIONAL_SECURITIES ACTIV_FEED_EXCHANGE_ISE
#define | ACTIV_FEED_EXCHANGE_ISE "Y"
#define | ACTIV_FEED_EXCHANGE_ISE_DIRECT "I"
#define | ACTIV_FEED_EXCHANGE_ITA "ITA"
#define | ACTIV_FEED_EXCHANGE_JASDAQ "JQ"
#define | ACTIV_FEED_EXCHANGE_KCBOT "KC"
#define | ACTIV_FEED_EXCHANGE_KCBOT_ELECTRONIC "KCE"
#define | ACTIV_FEED_EXCHANGE_KOREA "KS"
#define | ACTIV_FEED_EXCHANGE_KOSDAQ "KQ"
#define | ACTIV_FEED_EXCHANGE_LATENCY "LTCY"
#define | ACTIV_FEED_EXCHANGE_LME "LM"
#define | ACTIV_FEED_EXCHANGE_LSE "L"
#define | ACTIV_FEED_EXCHANGE_MGEX "MG"
#define | ACTIV_FEED_EXCHANGE_MGEX_ELECTRONIC "MGE"
#define | ACTIV_FEED_EXCHANGE_MONTREAL "M"
#define | ACTIV_FEED_EXCHANGE_NAGOYA "NG"
#define | ACTIV_FEED_EXCHANGE_NASD_ADF "QD"
#define | ACTIV_FEED_EXCHANGE_NASDAQ "Q"
#define | ACTIV_FEED_EXCHANGE_NASDAQ_ADF ACTIV_FEED_EXCHANGE_NASD_ADF
#define | ACTIV_FEED_EXCHANGE_NASDAQ_BULLETIN_BOARD "QB"
#define | ACTIV_FEED_EXCHANGE_NASDAQ_OTHER_OTC "QO"
#define | ACTIV_FEED_EXCHANGE_NATIONAL ACTIV_FEED_EXCHANGE_NSX
#define | ACTIV_FEED_EXCHANGE_NSX "C"
#define | ACTIV_FEED_EXCHANGE_NYBOT "NB"
#define | ACTIV_FEED_EXCHANGE_NYBOT_ELECTRONIC "NBE"
#define | ACTIV_FEED_EXCHANGE_NYMEX "NX"
#define | ACTIV_FEED_EXCHANGE_NYMEX_ACCESS "NXA"
#define | ACTIV_FEED_EXCHANGE_NYMEX_CLEARPORT "NXC"
#define | ACTIV_FEED_EXCHANGE_NYMEX_EUROPE "NXL"
#define | ACTIV_FEED_EXCHANGE_NYMEX_GLOBEX "NXG"
#define | ACTIV_FEED_EXCHANGE_NYSE "N"
#define | ACTIV_FEED_EXCHANGE_NYSE_ARCA "PA"
#define | ACTIV_FEED_EXCHANGE_NYSE_ARCA_DIRECT "EA"
#define | ACTIV_FEED_EXCHANGE_NYSE_ARCA_OPTIONS "PO"
#define | ACTIV_FEED_EXCHANGE_NYSE_BEST_QUOTES "NQ"
#define | ACTIV_FEED_EXCHANGE_NYSE_OPEN_BOOK "OB"
#define | ACTIV_FEED_EXCHANGE_ONE_CHICAGO "OC"
#define | ACTIV_FEED_EXCHANGE_OSE "OS"
#define | ACTIV_FEED_EXCHANGE_OTCQX "QX"
#define | ACTIV_FEED_EXCHANGE_PACIFIC ACTIV_FEED_EXCHANGE_NYSE_ARCA
#define | ACTIV_FEED_EXCHANGE_PACIFIC_OPTIONS ACTIV_FEED_EXCHANGE_NYSE_ARCA_OPTIONS
#define | ACTIV_FEED_EXCHANGE_PBOT "XB"
#define | ACTIV_FEED_EXCHANGE_PHILADELPHIA ACTIV_FEED_EXCHANGE_PHLX
#define | ACTIV_FEED_EXCHANGE_PHILADELPHIA_OPTIONS ACTIV_FEED_EXCHANGE_PHLX_OPTIONS
#define | ACTIV_FEED_EXCHANGE_PHLX "X"
#define | ACTIV_FEED_EXCHANGE_PHLX_OPTIONS "XO"
#define | ACTIV_FEED_EXCHANGE_PINK_SHEETS "PS"
#define | ACTIV_FEED_EXCHANGE_PURE_TRADING "PT"
#define | ACTIV_FEED_EXCHANGE_SAPPORO "SP"
#define | ACTIV_FEED_EXCHANGE_SGX "SG"
#define | ACTIV_FEED_EXCHANGE_SYDNEY_FUTURES "SF"
#define | ACTIV_FEED_EXCHANGE_TAIFEX "TX"
#define | ACTIV_FEED_EXCHANGE_TENFORE "TF"
#define | ACTIV_FEED_EXCHANGE_TOCOM "TC"
#define | ACTIV_FEED_EXCHANGE_TSE "T"
#define | ACTIV_FEED_EXCHANGE_TSX "TO"
#define | ACTIV_FEED_EXCHANGE_TSX_VENTURE "TV"
#define | ACTIV_FEED_EXCHANGE_US_OPTIONS_COMPOSITE "O"
#define | ACTIV_FEED_EXCHANGE_WCE "WC"
#define | ACTIV_FEED_SYMBOL_SEPARATOR_LIST(d)

Typedefs

typedef std::map
< CompositeExchangeMapKey,
std::string > 		Activ::ContentPlatform::Feed::CompositeExchangeMap
Composite exchange map type definition.
typedef std::pair
< Feed::TableNo, std::string > 		Activ::ContentPlatform::Feed::CompositeExchangeMapKey
Composite exchange map key type definition.

Functions

const char | Activ::ContentPlatform::Feed::ANALYTICS_SEPARATOR (LEVEL2_SEPARATOR)
Deprecated.
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_ALPHA_TRADING ("ATS")
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_AMEX ("A")
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_AMEX_OPTIONS ("AO")
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_ARCA (EXCHANGE_NYSE_ARCA_DIRECT)
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_ASX ("AX")
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_BATS ("BT")
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_BATS_DIRECT ("EB")
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_BMF ("BMF")
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_BOSTON ("B")
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_BOSTON_OPTIONS ("BO")
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_BOVESPA ("BS")
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_CBOE ("W")
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_CBOT ("CB")
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_CBOT_GLOBEX ("CBE")
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_CFE ("CF")
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_CHI_X_CANADA ("CHIC")
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_CHI_X_EUROPE ("CHIX")
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_CHICAGO (EXCHANGE_CHX)
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_CHX ("MW")
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_CHX_DIRECT ("CH")
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_CINCINNATI (EXCHANGE_NSX)
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_CME ("CM")
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_CME_GLOBEX ("CMG")
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_CNQ ("CQ")
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_COMEX ("CX")
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_COMEX_ACCESS ("CXA")
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_DIRECT_EDGE ("ED")
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_DUBAI_MERCANTILE_EXCHANGE ("DME")
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_E_CBOT (EXCHANGE_CBOT_GLOBEX)
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_E_NYMEX ("NXF")
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_E_NYMEX_EUROPE ("NXE")
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_EUREX ("EX")
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_EURONEXT_LIFFE ("LI")
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_EURONEXT_PARIS ("P")
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_FEED_STATUS ("FEED")
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_FUKUOKA ("FU")
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_HKFE ("HF")
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_HKSE ("HK")
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_ICE ("ICE")
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_INET ("EI")
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_INSTINET_CBX ("CBX")
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_INTERNATIONAL_SECURITIES (EXCHANGE_ISE)
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_ISE ("Y")
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_ISE_DIRECT ("I")
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_ITA ("ITA")
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_JASDAQ ("JQ")
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_KCBOT ("KC")
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_KCBOT_ELECTRONIC ("KCE")
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_KOREA ("KS")
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_KOSDAQ ("KQ")
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_LATENCY ("LTCY")
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_LME ("LM")
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_LSE ("L")
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_MGEX ("MG")
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_MGEX_ELECTRONIC ("MGE")
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_MONTREAL ("M")
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_NAGOYA ("NG")
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_NASD_ADF ("QD")
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_NASDAQ ("Q")
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_NASDAQ_ADF (EXCHANGE_NASD_ADF)
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_NASDAQ_BULLETIN_BOARD ("QB")
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_NASDAQ_OTHER_OTC ("QO")
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_NATIONAL (EXCHANGE_NSX)
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_NSX ("C")
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_NYBOT ("NB")
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_NYBOT_ELECTRONIC ("NBE")
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_NYMEX ("NX")
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_NYMEX_ACCESS ("NXA")
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_NYMEX_CLEARPORT ("NXC")
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_NYMEX_EUROPE ("NXL")
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_NYMEX_GLOBEX ("NXG")
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_NYSE ("N")
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_NYSE_ARCA ("PA")
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_NYSE_ARCA_DIRECT ("EA")
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_NYSE_ARCA_OPTIONS ("PO")
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_NYSE_BEST_QUOTES ("NQ")
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_NYSE_OPEN_BOOK ("OB")
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_ONE_CHICAGO ("OC")
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_OSE ("OS")
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_OTCQX ("QX")
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_PACIFIC (EXCHANGE_NYSE_ARCA)
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_PACIFIC_OPTIONS (EXCHANGE_NYSE_ARCA_OPTIONS)
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_PBOT ("XB")
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_PHILADELPHIA (EXCHANGE_PHLX)
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_PHILADELPHIA_OPTIONS (EXCHANGE_PHLX_OPTIONS)
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_PHLX ("X")
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_PHLX_OPTIONS ("XO")
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_PINK_SHEETS ("PS")
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_PURE_TRADING ("PT")
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_SAPPORO ("SP")
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_SGX ("SG")
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_SYDNEY_FUTURES ("SF")
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_TAIFEX ("TX")
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_TENFORE ("TF")
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_TOCOM ("TC")
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_TSE ("T")
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_TSX ("TO")
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_TSX_VENTURE ("TV")
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_US_OPTIONS_COMPOSITE ("O")
const std::string | Activ::ContentPlatform::Feed::EXCHANGE_WCE ("WC")
bool | Activ::ContentPlatform::Feed::GetCompositeSymbol (const CompositeExchangeMap &compositeExchangeMap, const Feed::TableNo tableNumber, const std::string &symbol, std::string &compositeSymbol)
Get the composite symbol.
std::string | Activ::ContentPlatform::Feed::GetDefaultCompositeSymbol (const std::string &symbol)
Get the default composite symbol.
std::string | Activ::ContentPlatform::Feed::GetExchange (const std::string &symbol)
Get exchange.

Variables

const char | Activ::ContentPlatform::Feed::CORPORATE_ACTION_SEPARATOR = '%'
const char | Activ::ContentPlatform::Feed::DEAD_INSTRUMENT_SEPARATOR = '#'
const char | Activ::ContentPlatform::Feed::EXCHANGE_SEPARATOR = '.'
const char | Activ::ContentPlatform::Feed::EXPIRATION_DATE_SEPARATOR = '/'
const char | Activ::ContentPlatform::Feed::FORWARD_CODE_SEPARATOR = '/'
const char | Activ::ContentPlatform::Feed::g_compositeSymbolSeparatorList [] = { EXCHANGE_SEPARATOR, QUOTE_SEPARATOR, ORDER_SEPARATOR, CORPORATE_ACTION_SEPARATOR, DEAD_INSTRUMENT_SEPARATOR, NEWS_SOURCE_SEPARATOR, '\0' }
const char | Activ::ContentPlatform::Feed::g_exchangeSeparatorList [] = { EXCHANGE_SEPARATOR, CORPORATE_ACTION_SEPARATOR, DEAD_INSTRUMENT_SEPARATOR, NEWS_SOURCE_SEPARATOR, '\0' }
const char | Activ::ContentPlatform::Feed::g_level2SeparatorList [] = { QUOTE_SEPARATOR, ORDER_SEPARATOR, LEVEL2_SEPARATOR, '\0' }
const char | Activ::ContentPlatform::Feed::INDEX_IDENTIFIER = '='
const char | Activ::ContentPlatform::Feed::LEVEL2_SEPARATOR = '-'
const char | Activ::ContentPlatform::Feed::MARKET_SEPARATOR = '/'
const char | Activ::ContentPlatform::Feed::NEWS_SOURCE_SEPARATOR = '%'
const char | Activ::ContentPlatform::Feed::ORDER_SEPARATOR = ';'
const char | Activ::ContentPlatform::Feed::QUOTE_SEPARATOR = ':'
const char | Activ::ContentPlatform::Feed::RANKINGS_SEPARATOR = '+'
const char | Activ::ContentPlatform::Feed::SPREAD_FUTURES_SEPARATOR = '-'
const char | Activ::ContentPlatform::Feed::STATISTICS_SEPARATOR = '+'
const char | Activ::ContentPlatform::Feed::STRIKE_PRICE_SEPARATOR = '/'
const char | Activ::ContentPlatform::Feed::SYMBOL_SEPARATOR = ' '

Detailed Description

Header file for the exchanges.

Log

Definition in file Exchanges.h.

Define Documentation

#define ACTIV_FEED_SYMBOL_SEPARATOR_LIST ( d )

Value:

d(INDEX_IDENTIFIER, '=')                \
    d(CORPORATE_ACTION_SEPARATOR, '%')      \
    d(DEAD_INSTRUMENT_SEPARATOR, '#')       \
    d(EXCHANGE_SEPARATOR, '.')              \
    d(EXPIRATION_DATE_SEPARATOR, '/')       \
    d(FORWARD_CODE_SEPARATOR, '/')          \
    d(LEVEL2_SEPARATOR, '-')                \
    d(MARKET_SEPARATOR, '/')                \
    d(NEWS_SOURCE_SEPARATOR, '%')           \
    d(ORDER_SEPARATOR, ';')                 \
    d(QUOTE_SEPARATOR, ':')                 \
    d(RANKINGS_SEPARATOR, '+')              \
    d(SPREAD_FUTURES_SEPARATOR, '-')        \
    d(STATISTICS_SEPARATOR, '+')            \
    d(STRIKE_PRICE_SEPARATOR, '/')          \
    d(SYMBOL_SEPARATOR, ' ')

Definition at line 34 of file Exchanges.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon

External.h File Reference

Import rules for ActivFeedCommon exports. More...

#include "ActivMiddleware/ActivFramework/ActivFramework.h"

Go to the source code of this file.

Defines

#define ACTIV_FEED_COMMON_API ACTIV_IMPORT_DLL

Detailed Description

Import rules for ActivFeedCommon exports.

Log

Definition in file External.h.

Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon

FieldIds.h File Reference

Header file for the field ids. More...

#include "ActivContentPlatform/ActivFeedCommon/External.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedDefinitions.h"

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::Feed

Variables

const FieldId | Activ::ContentPlatform::Feed::FID_30_WEEK_MOVING_AVERAGE = 697
const FieldId | Activ::ContentPlatform::Feed::FID_52_WEEK_HIGH = 148
const FieldId | Activ::ContentPlatform::Feed::FID_52_WEEK_HIGH_DATE = 149
const FieldId | Activ::ContentPlatform::Feed::FID_52_WEEK_LOW = 150
const FieldId | Activ::ContentPlatform::Feed::FID_52_WEEK_LOW_DATE = 151
const FieldId | Activ::ContentPlatform::Feed::FID_5_DAY_MOVING_AVERAGE = 698
const FieldId | Activ::ContentPlatform::Feed::FID_5_YEAR_ANNUAL_REVENUE_GROWTH_RATE = 699
const FieldId | Activ::ContentPlatform::Feed::FID_5_YEAR_AVERAGE_PE = 700
const FieldId | Activ::ContentPlatform::Feed::FID_5_YEAR_HIGH_PRICE = 701
const FieldId | Activ::ContentPlatform::Feed::FID_5_YEAR_LOW_PRICE = 702
const FieldId | Activ::ContentPlatform::Feed::FID_7_DAY_YIELD = 226
const FieldId | Activ::ContentPlatform::Feed::FID_7_DAY_YIELD_DATE = 514
const FieldId | Activ::ContentPlatform::Feed::FID_ACCRUED_INTEREST = 227
const FieldId | Activ::ContentPlatform::Feed::FID_ADDITIONAL_PAID_IN_CAPITAL = 228
const FieldId | Activ::ContentPlatform::Feed::FID_ADJUSTMENT_TYPE = 891
const FieldId | Activ::ContentPlatform::Feed::FID_ANALYTICS_SYMBOL = 521
const FieldId | Activ::ContentPlatform::Feed::FID_ANALYTICS_TABLE_NO = 522
const FieldId | Activ::ContentPlatform::Feed::FID_ANNUAL_ADDITIONAL_PAID_IN_CAPITAL = 543
const FieldId | Activ::ContentPlatform::Feed::FID_ANNUAL_BASIC_NORMALIZED_NET_INCOME_PER_SHARE = 703
const FieldId | Activ::ContentPlatform::Feed::FID_ANNUAL_CAPITAL_STOCK = 542
const FieldId | Activ::ContentPlatform::Feed::FID_ANNUAL_CASH_AND_EQUIVALENTS = 704
const FieldId | Activ::ContentPlatform::Feed::FID_ANNUAL_COMMON_PAR = 705
const FieldId | Activ::ContentPlatform::Feed::FID_ANNUAL_CURRENT_ASSETS = 536
const FieldId | Activ::ContentPlatform::Feed::FID_ANNUAL_CURRENT_LIABILITIES = 539
const FieldId | Activ::ContentPlatform::Feed::FID_ANNUAL_DEPRECIATION_DEPLETION = 531
const FieldId | Activ::ContentPlatform::Feed::FID_ANNUAL_DIVIDENDS_PAID_PER_SHARE = 706
const FieldId | Activ::ContentPlatform::Feed::FID_ANNUAL_GROSS_PROFITS = 529
const FieldId | Activ::ContentPlatform::Feed::FID_ANNUAL_INCOME_BEFORE_TAX = 533
const FieldId | Activ::ContentPlatform::Feed::FID_ANNUAL_INCOME_FROM_CONTINUING_OPERATIONS = 534
const FieldId | Activ::ContentPlatform::Feed::FID_ANNUAL_INTEREST_EXPENSE = 532
const FieldId | Activ::ContentPlatform::Feed::FID_ANNUAL_INTEREST_INCOME = 707
const FieldId | Activ::ContentPlatform::Feed::FID_ANNUAL_LONG_TERM_DEBT = 541
const FieldId | Activ::ContentPlatform::Feed::FID_ANNUAL_NET_CASH_FROM_FINANCING_ACTIVITIES = 708
const FieldId | Activ::ContentPlatform::Feed::FID_ANNUAL_NET_CASH_FROM_INVESTMENTS = 709
const FieldId | Activ::ContentPlatform::Feed::FID_ANNUAL_NET_CASH_FROM_OPERATIONS = 710
const FieldId | Activ::ContentPlatform::Feed::FID_ANNUAL_NET_CASH_NET_CHANGE_AND_CASH_EQUIVELENTS = 711
const FieldId | Activ::ContentPlatform::Feed::FID_ANNUAL_NET_FIXED_ASSETS = 712
const FieldId | Activ::ContentPlatform::Feed::FID_ANNUAL_NET_INCOME = 535
const FieldId | Activ::ContentPlatform::Feed::FID_ANNUAL_NET_PROPERTY_PLANT_AND_EQUIPMENT = 537
const FieldId | Activ::ContentPlatform::Feed::FID_ANNUAL_NORMALIZED_CLOSE_PE_RATIO = 713
const FieldId | Activ::ContentPlatform::Feed::FID_ANNUAL_NORMALIZED_HIGH_PE_RATIO = 714
const FieldId | Activ::ContentPlatform::Feed::FID_ANNUAL_NORMALIZED_LOW_PE_RATIO = 715
const FieldId | Activ::ContentPlatform::Feed::FID_ANNUAL_NUMBER_OF_MONTHS_SINCE_LAST_REPORTING_PERIOD = 716
const FieldId | Activ::ContentPlatform::Feed::FID_ANNUAL_OTHER_INCOME = 717
const FieldId | Activ::ContentPlatform::Feed::FID_ANNUAL_OTHER_NON_CURRENT_ASSETS = 718
const FieldId | Activ::ContentPlatform::Feed::FID_ANNUAL_PREFERRED_STOCK_EQUITY = 719
const FieldId | Activ::ContentPlatform::Feed::FID_ANNUAL_RETAINED_EARNINGS = 544
const FieldId | Activ::ContentPlatform::Feed::FID_ANNUAL_REVENUES_FROM_SALES = 528
const FieldId | Activ::ContentPlatform::Feed::FID_ANNUAL_SELLING_AND_GENERAL_ADMIN_EXPENSE = 530
const FieldId | Activ::ContentPlatform::Feed::FID_ANNUAL_TOTAL_ASSETS = 538
const FieldId | Activ::ContentPlatform::Feed::FID_ANNUAL_TOTAL_LIABILITIES = 540
const FieldId | Activ::ContentPlatform::Feed::FID_ANNUALIZED_7_DAY_YIELD = 229
const FieldId | Activ::ContentPlatform::Feed::FID_ANNUALIZED_7_DAY_YIELD_DATE = 515
const FieldId | Activ::ContentPlatform::Feed::FID_APPLICATION_INFO_LIST = 928
const FieldId | Activ::ContentPlatform::Feed::FID_APPLICATION_LIST = 927
const FieldId | Activ::ContentPlatform::Feed::FID_ASK = 5
const FieldId | Activ::ContentPlatform::Feed::FID_ASK1 = 84
const FieldId | Activ::ContentPlatform::Feed::FID_ASK10 = 645
const FieldId | Activ::ContentPlatform::Feed::FID_ASK10_CONDITION = 847
const FieldId | Activ::ContentPlatform::Feed::FID_ASK10_COUNT = 646
const FieldId | Activ::ContentPlatform::Feed::FID_ASK10_PARTICIPANT = 1002
const FieldId | Activ::ContentPlatform::Feed::FID_ASK10_SIZE = 647
const FieldId | Activ::ContentPlatform::Feed::FID_ASK10_TIME = 848
const FieldId | Activ::ContentPlatform::Feed::FID_ASK1_CONDITION = 812
const FieldId | Activ::ContentPlatform::Feed::FID_ASK1_COUNT = 87
const FieldId | Activ::ContentPlatform::Feed::FID_ASK1_PARTICIPANT = 993
const FieldId | Activ::ContentPlatform::Feed::FID_ASK1_SIZE = 86
const FieldId | Activ::ContentPlatform::Feed::FID_ASK1_TIME = 85
const FieldId | Activ::ContentPlatform::Feed::FID_ASK2 = 92
const FieldId | Activ::ContentPlatform::Feed::FID_ASK2_CONDITION = 815
const FieldId | Activ::ContentPlatform::Feed::FID_ASK2_COUNT = 93
const FieldId | Activ::ContentPlatform::Feed::FID_ASK2_PARTICIPANT = 994
const FieldId | Activ::ContentPlatform::Feed::FID_ASK2_SIZE = 94
const FieldId | Activ::ContentPlatform::Feed::FID_ASK2_TIME = 816
const FieldId | Activ::ContentPlatform::Feed::FID_ASK3 = 95
const FieldId | Activ::ContentPlatform::Feed::FID_ASK3_CONDITION = 819
const FieldId | Activ::ContentPlatform::Feed::FID_ASK3_COUNT = 102
const FieldId | Activ::ContentPlatform::Feed::FID_ASK3_PARTICIPANT = 995
const FieldId | Activ::ContentPlatform::Feed::FID_ASK3_SIZE = 100
const FieldId | Activ::ContentPlatform::Feed::FID_ASK3_TIME = 820
const FieldId | Activ::ContentPlatform::Feed::FID_ASK4 = 101
const FieldId | Activ::ContentPlatform::Feed::FID_ASK4_CONDITION = 823
const FieldId | Activ::ContentPlatform::Feed::FID_ASK4_COUNT = 108
const FieldId | Activ::ContentPlatform::Feed::FID_ASK4_PARTICIPANT = 996
const FieldId | Activ::ContentPlatform::Feed::FID_ASK4_SIZE = 103
const FieldId | Activ::ContentPlatform::Feed::FID_ASK4_TIME = 824
const FieldId | Activ::ContentPlatform::Feed::FID_ASK5 = 110
const FieldId | Activ::ContentPlatform::Feed::FID_ASK5_CONDITION = 827
const FieldId | Activ::ContentPlatform::Feed::FID_ASK5_COUNT = 111
const FieldId | Activ::ContentPlatform::Feed::FID_ASK5_PARTICIPANT = 997
const FieldId | Activ::ContentPlatform::Feed::FID_ASK5_SIZE = 109
const FieldId | Activ::ContentPlatform::Feed::FID_ASK5_TIME = 828
const FieldId | Activ::ContentPlatform::Feed::FID_ASK6 = 621
const FieldId | Activ::ContentPlatform::Feed::FID_ASK6_CONDITION = 831
const FieldId | Activ::ContentPlatform::Feed::FID_ASK6_COUNT = 622
const FieldId | Activ::ContentPlatform::Feed::FID_ASK6_PARTICIPANT = 998
const FieldId | Activ::ContentPlatform::Feed::FID_ASK6_SIZE = 623
const FieldId | Activ::ContentPlatform::Feed::FID_ASK6_TIME = 832
const FieldId | Activ::ContentPlatform::Feed::FID_ASK7 = 627
const FieldId | Activ::ContentPlatform::Feed::FID_ASK7_CONDITION = 835
const FieldId | Activ::ContentPlatform::Feed::FID_ASK7_COUNT = 628
const FieldId | Activ::ContentPlatform::Feed::FID_ASK7_PARTICIPANT = 999
const FieldId | Activ::ContentPlatform::Feed::FID_ASK7_SIZE = 629
const FieldId | Activ::ContentPlatform::Feed::FID_ASK7_TIME = 836
const FieldId | Activ::ContentPlatform::Feed::FID_ASK8 = 633
const FieldId | Activ::ContentPlatform::Feed::FID_ASK8_CONDITION = 839
const FieldId | Activ::ContentPlatform::Feed::FID_ASK8_COUNT = 634
const FieldId | Activ::ContentPlatform::Feed::FID_ASK8_PARTICIPANT = 1000
const FieldId | Activ::ContentPlatform::Feed::FID_ASK8_SIZE = 635
const FieldId | Activ::ContentPlatform::Feed::FID_ASK8_TIME = 840
const FieldId | Activ::ContentPlatform::Feed::FID_ASK9 = 639
const FieldId | Activ::ContentPlatform::Feed::FID_ASK9_CONDITION = 843
const FieldId | Activ::ContentPlatform::Feed::FID_ASK9_COUNT = 640
const FieldId | Activ::ContentPlatform::Feed::FID_ASK9_PARTICIPANT = 1001
const FieldId | Activ::ContentPlatform::Feed::FID_ASK9_SIZE = 641
const FieldId | Activ::ContentPlatform::Feed::FID_ASK9_TIME = 844
const FieldId | Activ::ContentPlatform::Feed::FID_ASK_CONDITION = 7
const FieldId | Activ::ContentPlatform::Feed::FID_ASK_COUNT = 940
const FieldId | Activ::ContentPlatform::Feed::FID_ASK_EXCHANGE = 9
const FieldId | Activ::ContentPlatform::Feed::FID_ASK_MARKET_MAKER_ID = 808
const FieldId | Activ::ContentPlatform::Feed::FID_ASK_SIZE = 6
const FieldId | Activ::ContentPlatform::Feed::FID_ASK_TIME = 8
const FieldId | Activ::ContentPlatform::Feed::FID_ASSETS = 230
const FieldId | Activ::ContentPlatform::Feed::FID_ATM_CALL_IMPLIED_VOLATILITY = 231
const FieldId | Activ::ContentPlatform::Feed::FID_ATM_PUT_IMPLIED_VOLATILITY = 232
const FieldId | Activ::ContentPlatform::Feed::FID_AVERAGE_DAILY_VOLUME_LAST_10_DAYS = 720
const FieldId | Activ::ContentPlatform::Feed::FID_AVERAGE_DAILY_VOLUME_LAST_52_WEEKS = 721
const FieldId | Activ::ContentPlatform::Feed::FID_AVERAGE_MATURITY = 233
const FieldId | Activ::ContentPlatform::Feed::FID_AVERAGE_VOLUME = 234
const FieldId | Activ::ContentPlatform::Feed::FID_AVERAGE_VOLUME_100_DAY = 235
const FieldId | Activ::ContentPlatform::Feed::FID_AVERAGE_VOLUME_10_DAY = 899
const FieldId | Activ::ContentPlatform::Feed::FID_AVERAGE_VOLUME_120_DAY = 904
const FieldId | Activ::ContentPlatform::Feed::FID_AVERAGE_VOLUME_150_DAY = 905
const FieldId | Activ::ContentPlatform::Feed::FID_AVERAGE_VOLUME_15_DAY = 919
const FieldId | Activ::ContentPlatform::Feed::FID_AVERAGE_VOLUME_180_DAY = 906
const FieldId | Activ::ContentPlatform::Feed::FID_AVERAGE_VOLUME_20_DAY = 900
const FieldId | Activ::ContentPlatform::Feed::FID_AVERAGE_VOLUME_22_DAY = 236
const FieldId | Activ::ContentPlatform::Feed::FID_AVERAGE_VOLUME_250_DAY = 237
const FieldId | Activ::ContentPlatform::Feed::FID_AVERAGE_VOLUME_30_DAY = 901
const FieldId | Activ::ContentPlatform::Feed::FID_AVERAGE_VOLUME_360_DAY = 907
const FieldId | Activ::ContentPlatform::Feed::FID_AVERAGE_VOLUME_45_DAY = 920
const FieldId | Activ::ContentPlatform::Feed::FID_AVERAGE_VOLUME_5_DAY = 918
const FieldId | Activ::ContentPlatform::Feed::FID_AVERAGE_VOLUME_60_DAY = 902
const FieldId | Activ::ContentPlatform::Feed::FID_AVERAGE_VOLUME_90_DAY = 903
const FieldId | Activ::ContentPlatform::Feed::FID_BASE_PRICE = 855
const FieldId | Activ::ContentPlatform::Feed::FID_BASIC_EPS_TOTAL = 722
const FieldId | Activ::ContentPlatform::Feed::FID_BASIC_NORMALIZED_NET_INCOME_PER_SHARE = 723
const FieldId | Activ::ContentPlatform::Feed::FID_BBO_DEPTH_SYMBOL = 790
const FieldId | Activ::ContentPlatform::Feed::FID_BBO_DEPTH_TABLE_NO = 791
const FieldId | Activ::ContentPlatform::Feed::FID_BETA = 238
const FieldId | Activ::ContentPlatform::Feed::FID_BID = 0
const FieldId | Activ::ContentPlatform::Feed::FID_BID1 = 80
const FieldId | Activ::ContentPlatform::Feed::FID_BID10 = 642
const FieldId | Activ::ContentPlatform::Feed::FID_BID10_CONDITION = 845
const FieldId | Activ::ContentPlatform::Feed::FID_BID10_COUNT = 643
const FieldId | Activ::ContentPlatform::Feed::FID_BID10_PARTICIPANT = 992
const FieldId | Activ::ContentPlatform::Feed::FID_BID10_SIZE = 644
const FieldId | Activ::ContentPlatform::Feed::FID_BID10_TIME = 846
const FieldId | Activ::ContentPlatform::Feed::FID_BID1_CONDITION = 811
const FieldId | Activ::ContentPlatform::Feed::FID_BID1_COUNT = 83
const FieldId | Activ::ContentPlatform::Feed::FID_BID1_PARTICIPANT = 983
const FieldId | Activ::ContentPlatform::Feed::FID_BID1_SIZE = 82
const FieldId | Activ::ContentPlatform::Feed::FID_BID1_TIME = 81
const FieldId | Activ::ContentPlatform::Feed::FID_BID2 = 88
const FieldId | Activ::ContentPlatform::Feed::FID_BID2_CONDITION = 813
const FieldId | Activ::ContentPlatform::Feed::FID_BID2_COUNT = 89
const FieldId | Activ::ContentPlatform::Feed::FID_BID2_PARTICIPANT = 984
const FieldId | Activ::ContentPlatform::Feed::FID_BID2_SIZE = 90
const FieldId | Activ::ContentPlatform::Feed::FID_BID2_TIME = 814
const FieldId | Activ::ContentPlatform::Feed::FID_BID3 = 91
const FieldId | Activ::ContentPlatform::Feed::FID_BID3_CONDITION = 817
const FieldId | Activ::ContentPlatform::Feed::FID_BID3_COUNT = 98
const FieldId | Activ::ContentPlatform::Feed::FID_BID3_PARTICIPANT = 985
const FieldId | Activ::ContentPlatform::Feed::FID_BID3_SIZE = 96
const FieldId | Activ::ContentPlatform::Feed::FID_BID3_TIME = 818
const FieldId | Activ::ContentPlatform::Feed::FID_BID4 = 97
const FieldId | Activ::ContentPlatform::Feed::FID_BID4_CONDITION = 821
const FieldId | Activ::ContentPlatform::Feed::FID_BID4_COUNT = 104
const FieldId | Activ::ContentPlatform::Feed::FID_BID4_PARTICIPANT = 986
const FieldId | Activ::ContentPlatform::Feed::FID_BID4_SIZE = 99
const FieldId | Activ::ContentPlatform::Feed::FID_BID4_TIME = 822
const FieldId | Activ::ContentPlatform::Feed::FID_BID5 = 106
const FieldId | Activ::ContentPlatform::Feed::FID_BID5_CONDITION = 825
const FieldId | Activ::ContentPlatform::Feed::FID_BID5_COUNT = 107
const FieldId | Activ::ContentPlatform::Feed::FID_BID5_PARTICIPANT = 987
const FieldId | Activ::ContentPlatform::Feed::FID_BID5_SIZE = 105
const FieldId | Activ::ContentPlatform::Feed::FID_BID5_TIME = 826
const FieldId | Activ::ContentPlatform::Feed::FID_BID6 = 618
const FieldId | Activ::ContentPlatform::Feed::FID_BID6_CONDITION = 829
const FieldId | Activ::ContentPlatform::Feed::FID_BID6_COUNT = 619
const FieldId | Activ::ContentPlatform::Feed::FID_BID6_PARTICIPANT = 988
const FieldId | Activ::ContentPlatform::Feed::FID_BID6_SIZE = 620
const FieldId | Activ::ContentPlatform::Feed::FID_BID6_TIME = 830
const FieldId | Activ::ContentPlatform::Feed::FID_BID7 = 624
const FieldId | Activ::ContentPlatform::Feed::FID_BID7_CONDITION = 833
const FieldId | Activ::ContentPlatform::Feed::FID_BID7_COUNT = 625
const FieldId | Activ::ContentPlatform::Feed::FID_BID7_PARTICIPANT = 989
const FieldId | Activ::ContentPlatform::Feed::FID_BID7_SIZE = 626
const FieldId | Activ::ContentPlatform::Feed::FID_BID7_TIME = 834
const FieldId | Activ::ContentPlatform::Feed::FID_BID8 = 630
const FieldId | Activ::ContentPlatform::Feed::FID_BID8_CONDITION = 837
const FieldId | Activ::ContentPlatform::Feed::FID_BID8_COUNT = 631
const FieldId | Activ::ContentPlatform::Feed::FID_BID8_PARTICIPANT = 990
const FieldId | Activ::ContentPlatform::Feed::FID_BID8_SIZE = 632
const FieldId | Activ::ContentPlatform::Feed::FID_BID8_TIME = 838
const FieldId | Activ::ContentPlatform::Feed::FID_BID9 = 636
const FieldId | Activ::ContentPlatform::Feed::FID_BID9_CONDITION = 841
const FieldId | Activ::ContentPlatform::Feed::FID_BID9_COUNT = 637
const FieldId | Activ::ContentPlatform::Feed::FID_BID9_PARTICIPANT = 991
const FieldId | Activ::ContentPlatform::Feed::FID_BID9_SIZE = 638
const FieldId | Activ::ContentPlatform::Feed::FID_BID9_TIME = 842
const FieldId | Activ::ContentPlatform::Feed::FID_BID_CONDITION = 2
const FieldId | Activ::ContentPlatform::Feed::FID_BID_COUNT = 941
const FieldId | Activ::ContentPlatform::Feed::FID_BID_EXCHANGE = 4
const FieldId | Activ::ContentPlatform::Feed::FID_BID_MARKET_MAKER_ID = 807
const FieldId | Activ::ContentPlatform::Feed::FID_BID_SIZE = 1
const FieldId | Activ::ContentPlatform::Feed::FID_BID_TIME = 3
const FieldId | Activ::ContentPlatform::Feed::FID_BUY_SELL = 892
const FieldId | Activ::ContentPlatform::Feed::FID_CALCULATED_CLOSING_PRICE = 876
const FieldId | Activ::ContentPlatform::Feed::FID_CALCULATED_CLOSING_PRICE_TIME = 877
const FieldId | Activ::ContentPlatform::Feed::FID_CALCULATED_OPENING_PRICE = 874
const FieldId | Activ::ContentPlatform::Feed::FID_CALCULATED_OPENING_PRICE_TIME = 875
const FieldId | Activ::ContentPlatform::Feed::FID_CAP_GAINS_DATE = 239
const FieldId | Activ::ContentPlatform::Feed::FID_CAP_GAINS_LONG = 240
const FieldId | Activ::ContentPlatform::Feed::FID_CAP_GAINS_OTHER = 241
const FieldId | Activ::ContentPlatform::Feed::FID_CAP_GAINS_REINVEST_PRICE = 492
const FieldId | Activ::ContentPlatform::Feed::FID_CAP_GAINS_REINVEST_PRICE_DATE = 494
const FieldId | Activ::ContentPlatform::Feed::FID_CAP_GAINS_SHORT = 242
const FieldId | Activ::ContentPlatform::Feed::FID_CAPITAL_DISTRIBUTION = 243
const FieldId | Activ::ContentPlatform::Feed::FID_CAPITAL_STOCK = 244
const FieldId | Activ::ContentPlatform::Feed::FID_CASH_AND_EQUIVALENTS = 724
const FieldId | Activ::ContentPlatform::Feed::FID_CASH_FROM_FINANCING = 245
const FieldId | Activ::ContentPlatform::Feed::FID_CASH_FROM_INVESTMENTS = 246
const FieldId | Activ::ContentPlatform::Feed::FID_CASH_FROM_OPERATIONS = 247
const FieldId | Activ::ContentPlatform::Feed::FID_CASH_IN_LIEU_OF = 248
const FieldId | Activ::ContentPlatform::Feed::FID_CASH_NET_CHANGE = 249
const FieldId | Activ::ContentPlatform::Feed::FID_CASH_PER_CONTRACT = 250
const FieldId | Activ::ContentPlatform::Feed::FID_CATEGORY_CODE_LIST = 614
const FieldId | Activ::ContentPlatform::Feed::FID_CHARACTER_SET = 762
const FieldId | Activ::ContentPlatform::Feed::FID_CLOSE = 61
const FieldId | Activ::ContentPlatform::Feed::FID_CLOSE_CONDITION = 62
const FieldId | Activ::ContentPlatform::Feed::FID_CLOSE_CUMULATIVE_VALUE = 70
const FieldId | Activ::ContentPlatform::Feed::FID_CLOSE_CUMULATIVE_VALUE_STATUS = 71
const FieldId | Activ::ContentPlatform::Feed::FID_CLOSE_CUMULATIVE_VOLUME = 67
const FieldId | Activ::ContentPlatform::Feed::FID_CLOSE_CUMULATIVE_VOLUME_DATE = 69
const FieldId | Activ::ContentPlatform::Feed::FID_CLOSE_CUMULATIVE_VOLUME_STATUS = 68
const FieldId | Activ::ContentPlatform::Feed::FID_CLOSE_DATE = 65
const FieldId | Activ::ContentPlatform::Feed::FID_CLOSE_EXCHANGE = 66
const FieldId | Activ::ContentPlatform::Feed::FID_CLOSE_RANGE_1 = 128
const FieldId | Activ::ContentPlatform::Feed::FID_CLOSE_RANGE_1_CONDITION = 129
const FieldId | Activ::ContentPlatform::Feed::FID_CLOSE_RANGE_2 = 130
const FieldId | Activ::ContentPlatform::Feed::FID_CLOSE_RANGE_2_CONDITION = 131
const FieldId | Activ::ContentPlatform::Feed::FID_CLOSE_RANGE_TIME = 132
const FieldId | Activ::ContentPlatform::Feed::FID_CLOSE_STATUS = 63
const FieldId | Activ::ContentPlatform::Feed::FID_CLOSE_TIME = 64
const FieldId | Activ::ContentPlatform::Feed::FID_CLOSING_ASK = 58
const FieldId | Activ::ContentPlatform::Feed::FID_CLOSING_ASK_EXCHANGE = 59
const FieldId | Activ::ContentPlatform::Feed::FID_CLOSING_BID = 56
const FieldId | Activ::ContentPlatform::Feed::FID_CLOSING_BID_EXCHANGE = 57
const FieldId | Activ::ContentPlatform::Feed::FID_CLOSING_PRICE_MONTH = 251
const FieldId | Activ::ContentPlatform::Feed::FID_CLOSING_PRICE_QUARTER = 252
const FieldId | Activ::ContentPlatform::Feed::FID_CLOSING_PRICE_WEEK = 253
const FieldId | Activ::ContentPlatform::Feed::FID_CLOSING_PRICE_YEAR = 254
const FieldId | Activ::ContentPlatform::Feed::FID_CLOSING_QUOTE_DATE = 60
const FieldId | Activ::ContentPlatform::Feed::FID_CODE_IDENTIFIER = 878
const FieldId | Activ::ContentPlatform::Feed::FID_COMMENTS = 255
const FieldId | Activ::ContentPlatform::Feed::FID_COMMON_PAR = 725
const FieldId | Activ::ContentPlatform::Feed::FID_COMPANY_SYMBOL = 390
const FieldId | Activ::ContentPlatform::Feed::FID_COMPANY_TABLE_NO = 391
const FieldId | Activ::ContentPlatform::Feed::FID_COMPOSITE_CLOSE = 72
const FieldId | Activ::ContentPlatform::Feed::FID_COMPOSITE_CLOSE_DATE = 73
const FieldId | Activ::ContentPlatform::Feed::FID_COMPOSITE_CLOSE_EXCHANGE = 74
const FieldId | Activ::ContentPlatform::Feed::FID_COMPOSITE_EXCHANGE = 520
const FieldId | Activ::ContentPlatform::Feed::FID_COMPOSITE_FLAG = 557
const FieldId | Activ::ContentPlatform::Feed::FID_CONDITIONS = 256
const FieldId | Activ::ContentPlatform::Feed::FID_CONSTITUENT_SYMBOL = 392
const FieldId | Activ::ContentPlatform::Feed::FID_CONSTITUENT_TABLE_NO = 393
const FieldId | Activ::ContentPlatform::Feed::FID_CONTEXT = 394
const FieldId | Activ::ContentPlatform::Feed::FID_CONTRACT_MULTIPLIER = 257
const FieldId | Activ::ContentPlatform::Feed::FID_CONTRACT_SIZE = 597
const FieldId | Activ::ContentPlatform::Feed::FID_CONTRACT_TYPE = 258
const FieldId | Activ::ContentPlatform::Feed::FID_CONTRIBUTION_BASE = 5000
const FieldId | Activ::ContentPlatform::Feed::FID_CONTRIBUTOR = 617
const FieldId | Activ::ContentPlatform::Feed::FID_COUNTRY_CODE = 259
const FieldId | Activ::ContentPlatform::Feed::FID_CREATE_DATE = 395
const FieldId | Activ::ContentPlatform::Feed::FID_CREATE_TIME = 786
const FieldId | Activ::ContentPlatform::Feed::FID_CROSS_TYPE = 868
const FieldId | Activ::ContentPlatform::Feed::FID_CUG_ID = 396
const FieldId | Activ::ContentPlatform::Feed::FID_CUMULATIVE_PRICE = 50
const FieldId | Activ::ContentPlatform::Feed::FID_CUMULATIVE_VALUE = 51
const FieldId | Activ::ContentPlatform::Feed::FID_CUMULATIVE_VOLUME = 52
const FieldId | Activ::ContentPlatform::Feed::FID_CUMULATIVE_VOLUME_AT = 942
const FieldId | Activ::ContentPlatform::Feed::FID_CUMULATIVE_VOLUME_MANUAL = 943
const FieldId | Activ::ContentPlatform::Feed::FID_CURRENCY = 260
const FieldId | Activ::ContentPlatform::Feed::FID_CURRENT = 27
const FieldId | Activ::ContentPlatform::Feed::FID_CURRENT_ASSETS = 261
const FieldId | Activ::ContentPlatform::Feed::FID_CURRENT_CONDITION = 28
const FieldId | Activ::ContentPlatform::Feed::FID_CURRENT_DATE = 30
const FieldId | Activ::ContentPlatform::Feed::FID_CURRENT_HIGH = 31
const FieldId | Activ::ContentPlatform::Feed::FID_CURRENT_HIGH_TIME = 32
const FieldId | Activ::ContentPlatform::Feed::FID_CURRENT_LIABILITIES = 262
const FieldId | Activ::ContentPlatform::Feed::FID_CURRENT_LOW = 33
const FieldId | Activ::ContentPlatform::Feed::FID_CURRENT_LOW_TIME = 34
const FieldId | Activ::ContentPlatform::Feed::FID_CURRENT_MARKET_VALUE = 726
const FieldId | Activ::ContentPlatform::Feed::FID_CURRENT_PE_RATIO = 727
const FieldId | Activ::ContentPlatform::Feed::FID_CURRENT_REFERENCE_PRICE = 869
const FieldId | Activ::ContentPlatform::Feed::FID_CURRENT_TIME = 29
const FieldId | Activ::ContentPlatform::Feed::FID_CURRENT_YIELD = 263
const FieldId | Activ::ContentPlatform::Feed::FID_CURRENT_YIELD_DATE = 490
const FieldId | Activ::ContentPlatform::Feed::FID_CURRENT_YIELD_TIME = 489
const FieldId | Activ::ContentPlatform::Feed::FID_DATE = 264
const FieldId | Activ::ContentPlatform::Feed::FID_DATE_TIME = 549
const FieldId | Activ::ContentPlatform::Feed::FID_DAY_DOWN = 683
const FieldId | Activ::ContentPlatform::Feed::FID_DAY_UNCHANGED = 684
const FieldId | Activ::ContentPlatform::Feed::FID_DAY_UP = 682
const FieldId | Activ::ContentPlatform::Feed::FID_DECLARE_DATE = 265
const FieldId | Activ::ContentPlatform::Feed::FID_DELAY_PERIOD = 397
const FieldId | Activ::ContentPlatform::Feed::FID_DELIVERY_SIZE = 982
const FieldId | Activ::ContentPlatform::Feed::FID_DELTA = 935
const FieldId | Activ::ContentPlatform::Feed::FID_DEPRECIATION_DEPLETION = 266
const FieldId | Activ::ContentPlatform::Feed::FID_DESCRIPTION = 267
const FieldId | Activ::ContentPlatform::Feed::FID_DISPLAY_DENOMINATOR = 268
const FieldId | Activ::ContentPlatform::Feed::FID_DIVIDEND = 269
const FieldId | Activ::ContentPlatform::Feed::FID_DIVIDEND_CURRENCY = 270
const FieldId | Activ::ContentPlatform::Feed::FID_DIVIDEND_FREQUENCY_CODE = 271
const FieldId | Activ::ContentPlatform::Feed::FID_DIVIDEND_REINVEST_PRICE = 491
const FieldId | Activ::ContentPlatform::Feed::FID_DIVIDEND_REINVEST_PRICE_DATE = 493
const FieldId | Activ::ContentPlatform::Feed::FID_DIVIDEND_YIELD_5_YEAR_AVERAGE = 728
const FieldId | Activ::ContentPlatform::Feed::FID_DIVIDENDS_PAID_PER_SHARE = 729
const FieldId | Activ::ContentPlatform::Feed::FID_DOLLAR_CHANGE_IN_12_MONTHS_EPS_VS_1_YEAR_AGO = 730
const FieldId | Activ::ContentPlatform::Feed::FID_DOWN = 272
const FieldId | Activ::ContentPlatform::Feed::FID_DST_OFFSET = 686
const FieldId | Activ::ContentPlatform::Feed::FID_EMPLOYEES = 273
const FieldId | Activ::ContentPlatform::Feed::FID_END_DATE = 890
const FieldId | Activ::ContentPlatform::Feed::FID_ENTITY_TYPE = 398
const FieldId | Activ::ContentPlatform::Feed::FID_ESTIMATED_CASH_AMOUNT_PER_UNIT = 274
const FieldId | Activ::ContentPlatform::Feed::FID_ESTIMATED_LONG_TERM_RETURN = 275
const FieldId | Activ::ContentPlatform::Feed::FID_EVENT_DATE = 276
const FieldId | Activ::ContentPlatform::Feed::FID_EVENT_TYPE = 399
const FieldId | Activ::ContentPlatform::Feed::FID_EX_DATE = 277
const FieldId | Activ::ContentPlatform::Feed::FID_EX_MARKER = 517
const FieldId | Activ::ContentPlatform::Feed::FID_EXCHANGE = 278
const FieldId | Activ::ContentPlatform::Feed::FID_EXCHANGE_CODE_LIST = 773
const FieldId | Activ::ContentPlatform::Feed::FID_EXCHANGE_HOLIDAY_LIST = 672
const FieldId | Activ::ContentPlatform::Feed::FID_EXCHANGE_MARKET_SIZE = 944
const FieldId | Activ::ContentPlatform::Feed::FID_EXCHANGE_SYMBOL = 970
const FieldId | Activ::ContentPlatform::Feed::FID_EXCHANGE_TABLE_NO = 971
const FieldId | Activ::ContentPlatform::Feed::FID_EXCHANGE_TYPE_LIST = 879
const FieldId | Activ::ContentPlatform::Feed::FID_EXECUTION_LIMIT_RANGE = 969
const FieldId | Activ::ContentPlatform::Feed::FID_EXERCISE_STYLE = 279
const FieldId | Activ::ContentPlatform::Feed::FID_EXPIRATION_DATE = 280
const FieldId | Activ::ContentPlatform::Feed::FID_EXPIRATION_DATE_01 = 559
const FieldId | Activ::ContentPlatform::Feed::FID_EXPIRATION_DATE_02 = 560
const FieldId | Activ::ContentPlatform::Feed::FID_EXPIRATION_DATE_03 = 561
const FieldId | Activ::ContentPlatform::Feed::FID_EXPIRATION_DATE_04 = 562
const FieldId | Activ::ContentPlatform::Feed::FID_EXPIRATION_DATE_05 = 563
const FieldId | Activ::ContentPlatform::Feed::FID_EXPIRATION_DATE_06 = 564
const FieldId | Activ::ContentPlatform::Feed::FID_EXPIRATION_DATE_07 = 565
const FieldId | Activ::ContentPlatform::Feed::FID_EXPIRATION_DATE_08 = 566
const FieldId | Activ::ContentPlatform::Feed::FID_EXPIRATION_DATE_09 = 567
const FieldId | Activ::ContentPlatform::Feed::FID_EXPIRATION_DATE_10 = 568
const FieldId | Activ::ContentPlatform::Feed::FID_EXPIRATION_DATE_11 = 569
const FieldId | Activ::ContentPlatform::Feed::FID_EXPIRATION_DATE_12 = 570
const FieldId | Activ::ContentPlatform::Feed::FID_EXPIRATION_TIME = 281
const FieldId | Activ::ContentPlatform::Feed::FID_EXPIRATION_TYPE = 753
const FieldId | Activ::ContentPlatform::Feed::FID_FAR_PRICE = 870
const FieldId | Activ::ContentPlatform::Feed::FID_FEED_LATENCY = 766
const FieldId | Activ::ContentPlatform::Feed::FID_FIELD_DESCRIPTION = 880
const FieldId | Activ::ContentPlatform::Feed::FID_FIELD_ID = 400
const FieldId | Activ::ContentPlatform::Feed::FID_FIELD_LENGTH = 401
const FieldId | Activ::ContentPlatform::Feed::FID_FIELD_ORDER = 402
const FieldId | Activ::ContentPlatform::Feed::FID_FIELD_TYPE = 403
const FieldId | Activ::ContentPlatform::Feed::FID_FINANCIAL_STATUS = 688
const FieldId | Activ::ContentPlatform::Feed::FID_FIRST_TRADE = 40
const FieldId | Activ::ContentPlatform::Feed::FID_FIRST_TRADE_TIME = 41
const FieldId | Activ::ContentPlatform::Feed::FID_FISCAL_YEAR_END = 282
const FieldId | Activ::ContentPlatform::Feed::FID_FOOTNOTES = 283
const FieldId | Activ::ContentPlatform::Feed::FID_FOREIGN_APPLICATION_INFO_LIST = 930
const FieldId | Activ::ContentPlatform::Feed::FID_FOREIGN_APPLICATION_LIST = 929
const FieldId | Activ::ContentPlatform::Feed::FID_FUND_CODE = 784
const FieldId | Activ::ContentPlatform::Feed::FID_FUNDAMENTAL_SYMBOL = 695
const FieldId | Activ::ContentPlatform::Feed::FID_FUNDAMENTAL_TABLE_NO = 696
const FieldId | Activ::ContentPlatform::Feed::FID_FUTURE_OPTION_EXPIRATION_SYMBOL = 611
const FieldId | Activ::ContentPlatform::Feed::FID_FUTURE_OPTION_EXPIRATION_TABLE_NO = 612
const FieldId | Activ::ContentPlatform::Feed::FID_FUTURE_OPTION_PATTERN_SYMBOL = 769
const FieldId | Activ::ContentPlatform::Feed::FID_FUTURE_OPTION_PATTERN_TABLE_NO = 770
const FieldId | Activ::ContentPlatform::Feed::FID_FUTURE_OPTION_ROOT_SYMBOL = 404
const FieldId | Activ::ContentPlatform::Feed::FID_FUTURE_OPTION_ROOT_TABLE_NO = 405
const FieldId | Activ::ContentPlatform::Feed::FID_FUTURE_OPTION_SYMBOL = 609
const FieldId | Activ::ContentPlatform::Feed::FID_FUTURE_OPTION_TABLE_NO = 610
const FieldId | Activ::ContentPlatform::Feed::FID_FUTURE_PATTERN_SYMBOL = 771
const FieldId | Activ::ContentPlatform::Feed::FID_FUTURE_PATTERN_TABLE_NO = 772
const FieldId | Activ::ContentPlatform::Feed::FID_FUTURE_ROOT_SYMBOL = 406
const FieldId | Activ::ContentPlatform::Feed::FID_FUTURE_ROOT_TABLE_NO = 407
const FieldId | Activ::ContentPlatform::Feed::FID_FUTURE_SPREAD_PATTERN_SYMBOL = 849
const FieldId | Activ::ContentPlatform::Feed::FID_FUTURE_SPREAD_PATTERN_TABLE_NO = 850
const FieldId | Activ::ContentPlatform::Feed::FID_FUTURE_SYMBOL = 607
const FieldId | Activ::ContentPlatform::Feed::FID_FUTURE_TABLE_NO = 608
const FieldId | Activ::ContentPlatform::Feed::FID_GAMMA = 936
const FieldId | Activ::ContentPlatform::Feed::FID_GENERAL_BUSINESS_EXPENSES_PLUS_COMMISSIONS = 499
const FieldId | Activ::ContentPlatform::Feed::FID_GROSS_PROFITS = 284
const FieldId | Activ::ContentPlatform::Feed::FID_HAS_DELIVERABLES = 613
const FieldId | Activ::ContentPlatform::Feed::FID_HEADLINE = 524
const FieldId | Activ::ContentPlatform::Feed::FID_HIGH_INDICATION_PRICE = 676
const FieldId | Activ::ContentPlatform::Feed::FID_HIGH_LRP_PRICE = 856
const FieldId | Activ::ContentPlatform::Feed::FID_HIGHEST_SPREAD = 285
const FieldId | Activ::ContentPlatform::Feed::FID_IMBALANCE_BUY_VOLUME = 673
const FieldId | Activ::ContentPlatform::Feed::FID_IMBALANCE_SELL_VOLUME = 674
const FieldId | Activ::ContentPlatform::Feed::FID_IMBALANCE_VOLUME_TIME = 675
const FieldId | Activ::ContentPlatform::Feed::FID_IMPLIED_ASK = 863
const FieldId | Activ::ContentPlatform::Feed::FID_IMPLIED_ASK_CONDITION = 865
const FieldId | Activ::ContentPlatform::Feed::FID_IMPLIED_ASK_SIZE = 864
const FieldId | Activ::ContentPlatform::Feed::FID_IMPLIED_ASK_TIME = 866
const FieldId | Activ::ContentPlatform::Feed::FID_IMPLIED_BID = 859
const FieldId | Activ::ContentPlatform::Feed::FID_IMPLIED_BID_CONDITION = 861
const FieldId | Activ::ContentPlatform::Feed::FID_IMPLIED_BID_SIZE = 860
const FieldId | Activ::ContentPlatform::Feed::FID_IMPLIED_BID_TIME = 862
const FieldId | Activ::ContentPlatform::Feed::FID_IMPLIED_QUOTE_DATE = 867
const FieldId | Activ::ContentPlatform::Feed::FID_INCOME_BEFORE_TAX = 286
const FieldId | Activ::ContentPlatform::Feed::FID_INCOME_DISTRIBUTION = 287
const FieldId | Activ::ContentPlatform::Feed::FID_INCOME_FROM_CONTINUING_OPERATIONS = 527
const FieldId | Activ::ContentPlatform::Feed::FID_INDEX_NUMBER = 408
const FieldId | Activ::ContentPlatform::Feed::FID_INDEX_PROPERTIES = 409
const FieldId | Activ::ContentPlatform::Feed::FID_INDEX_SYMBOL = 410
const FieldId | Activ::ContentPlatform::Feed::FID_INDEX_TABLE_NO = 411
const FieldId | Activ::ContentPlatform::Feed::FID_INDEX_TYPE = 412
const FieldId | Activ::ContentPlatform::Feed::FID_INDICATED_ANNUAL_DIVIDEND = 288
const FieldId | Activ::ContentPlatform::Feed::FID_INDICATED_YIELD = 546
const FieldId | Activ::ContentPlatform::Feed::FID_INDICATION_PRICE_TIME = 678
const FieldId | Activ::ContentPlatform::Feed::FID_INDICATIVE_ASK = 798
const FieldId | Activ::ContentPlatform::Feed::FID_INDICATIVE_ASK_SIZE = 799
const FieldId | Activ::ContentPlatform::Feed::FID_INDICATIVE_ASK_TIME = 800
const FieldId | Activ::ContentPlatform::Feed::FID_INDICATIVE_BID = 795
const FieldId | Activ::ContentPlatform::Feed::FID_INDICATIVE_BID_SIZE = 796
const FieldId | Activ::ContentPlatform::Feed::FID_INDICATIVE_BID_TIME = 797
const FieldId | Activ::ContentPlatform::Feed::FID_INDICATIVE_QUOTE_DATE = 801
const FieldId | Activ::ContentPlatform::Feed::FID_INDUSTRY_CODE = 289
const FieldId | Activ::ContentPlatform::Feed::FID_INSTITUTIONAL_SHAREHOLDERS = 290
const FieldId | Activ::ContentPlatform::Feed::FID_INSTRUMENT_PATTERN_SYMBOL = 972
const FieldId | Activ::ContentPlatform::Feed::FID_INSTRUMENT_PATTERN_TABLE_NO = 973
const FieldId | Activ::ContentPlatform::Feed::FID_INTEREST_EXPENSES = 291
const FieldId | Activ::ContentPlatform::Feed::FID_INTEREST_INCOME = 292
const FieldId | Activ::ContentPlatform::Feed::FID_INTEREST_REVENUE = 500
const FieldId | Activ::ContentPlatform::Feed::FID_INTERIM_ENDING_DATE = 731
const FieldId | Activ::ContentPlatform::Feed::FID_INVESTMENT_SECURITIES = 501
const FieldId | Activ::ContentPlatform::Feed::FID_ISIN = 293
const FieldId | Activ::ContentPlatform::Feed::FID_ISSUE_STATUS = 883
const FieldId | Activ::ContentPlatform::Feed::FID_ISSUER_NAME = 294
const FieldId | Activ::ContentPlatform::Feed::FID_LANGUAGE = 761
const FieldId | Activ::ContentPlatform::Feed::FID_LAST_12_MONTHS_EARNINGS = 295
const FieldId | Activ::ContentPlatform::Feed::FID_LAST_FISCAL_YEAR_EARNINGS = 296
const FieldId | Activ::ContentPlatform::Feed::FID_LAST_QUARTER_DATE = 297
const FieldId | Activ::ContentPlatform::Feed::FID_LAST_QUARTER_DATE_INCLUDED = 298
const FieldId | Activ::ContentPlatform::Feed::FID_LAST_QUARTER_EARNINGS = 299
const FieldId | Activ::ContentPlatform::Feed::FID_LAST_REPORTED_TRADE = 776
const FieldId | Activ::ContentPlatform::Feed::FID_LAST_REPORTED_TRADE_CONDITION = 778
const FieldId | Activ::ContentPlatform::Feed::FID_LAST_REPORTED_TRADE_DATE = 780
const FieldId | Activ::ContentPlatform::Feed::FID_LAST_REPORTED_TRADE_EXCHANGE = 781
const FieldId | Activ::ContentPlatform::Feed::FID_LAST_REPORTED_TRADE_REPORTING_EXCHANGE = 810
const FieldId | Activ::ContentPlatform::Feed::FID_LAST_REPORTED_TRADE_SIZE = 777
const FieldId | Activ::ContentPlatform::Feed::FID_LAST_REPORTED_TRADE_THROUGH_EXEMPT_FLAG = 809
const FieldId | Activ::ContentPlatform::Feed::FID_LAST_REPORTED_TRADE_TIME = 779
const FieldId | Activ::ContentPlatform::Feed::FID_LAST_TRADING_DATE = 300
const FieldId | Activ::ContentPlatform::Feed::FID_LAST_UPDATE_DATE = 413
const FieldId | Activ::ContentPlatform::Feed::FID_LAST_UPDATE_TIME = 414
const FieldId | Activ::ContentPlatform::Feed::FID_LATEST_REPORTED_SHARES_OUTSTANDING = 732
const FieldId | Activ::ContentPlatform::Feed::FID_LIFETIME_HIGH = 156
const FieldId | Activ::ContentPlatform::Feed::FID_LIFETIME_HIGH_DATE = 157
const FieldId | Activ::ContentPlatform::Feed::FID_LIFETIME_LOW = 158
const FieldId | Activ::ContentPlatform::Feed::FID_LIFETIME_LOW_DATE = 159
const FieldId | Activ::ContentPlatform::Feed::FID_LIMIT_HIGH_PRICE = 487
const FieldId | Activ::ContentPlatform::Feed::FID_LIMIT_LOW_PRICE = 488
const FieldId | Activ::ContentPlatform::Feed::FID_LISTING_SYMBOL = 415
const FieldId | Activ::ContentPlatform::Feed::FID_LISTING_SYMBOL_LIST = 416
const FieldId | Activ::ContentPlatform::Feed::FID_LISTING_TABLE_NO = 417
const FieldId | Activ::ContentPlatform::Feed::FID_LOCAL_CALL_ROOT = 599
const FieldId | Activ::ContentPlatform::Feed::FID_LOCAL_CODE = 301
const FieldId | Activ::ContentPlatform::Feed::FID_LOCAL_EXCHANGE = 598
const FieldId | Activ::ContentPlatform::Feed::FID_LOCAL_PRICE = 133
const FieldId | Activ::ContentPlatform::Feed::FID_LOCAL_PUT_ROOT = 600
const FieldId | Activ::ContentPlatform::Feed::FID_LOCAL_ROOT = 601
const FieldId | Activ::ContentPlatform::Feed::FID_LOCAL_SESSION_ID = 884
const FieldId | Activ::ContentPlatform::Feed::FID_LONG_TERM_DEBT = 302
const FieldId | Activ::ContentPlatform::Feed::FID_LONG_TERM_INVESTMENTS = 303
const FieldId | Activ::ContentPlatform::Feed::FID_LOT_SIZE = 793
const FieldId | Activ::ContentPlatform::Feed::FID_LOW_INDICATION_PRICE = 677
const FieldId | Activ::ContentPlatform::Feed::FID_LOW_LRP_PRICE = 857
const FieldId | Activ::ContentPlatform::Feed::FID_LOWEST_SPREAD = 304
const FieldId | Activ::ContentPlatform::Feed::FID_LRP_PRICE_TIME = 858
const FieldId | Activ::ContentPlatform::Feed::FID_MAGAZINE = 749
const FieldId | Activ::ContentPlatform::Feed::FID_MARKET_MAKER_ID = 660
const FieldId | Activ::ContentPlatform::Feed::FID_MARKET_MAKER_STATUS = 10
const FieldId | Activ::ContentPlatform::Feed::FID_MARKET_ORDER_IMBALANCE_BUY_VOLUME = 932
const FieldId | Activ::ContentPlatform::Feed::FID_MARKET_ORDER_IMBALANCE_SELL_VOLUME = 933
const FieldId | Activ::ContentPlatform::Feed::FID_MARKET_PRICE = 136
const FieldId | Activ::ContentPlatform::Feed::FID_MARKET_PRICE_DATE = 137
const FieldId | Activ::ContentPlatform::Feed::FID_MARKET_PRICE_TIME = 138
const FieldId | Activ::ContentPlatform::Feed::FID_MARKET_SECTOR = 945
const FieldId | Activ::ContentPlatform::Feed::FID_MARKET_SEGMENT = 946
const FieldId | Activ::ContentPlatform::Feed::FID_MARKET_TIER = 785
const FieldId | Activ::ContentPlatform::Feed::FID_MARKET_VALUE_AS_A_PERCENT_OF_REVENUES = 733
const FieldId | Activ::ContentPlatform::Feed::FID_MAX = 8191
const FieldId | Activ::ContentPlatform::Feed::FID_MAXIMUM_MESSAGE_RATE = 775
const FieldId | Activ::ContentPlatform::Feed::FID_MESSAGE_TYPE = 418
const FieldId | Activ::ContentPlatform::Feed::FID_MID = 934
const FieldId | Activ::ContentPlatform::Feed::FID_MID_HIGH = 947
const FieldId | Activ::ContentPlatform::Feed::FID_MID_HIGH_TIME = 948
const FieldId | Activ::ContentPlatform::Feed::FID_MID_LOW = 949
const FieldId | Activ::ContentPlatform::Feed::FID_MID_LOW_TIME = 950
const FieldId | Activ::ContentPlatform::Feed::FID_MID_TIME = 951
const FieldId | Activ::ContentPlatform::Feed::FID_MINIMUM_TICK = 602
const FieldId | Activ::ContentPlatform::Feed::FID_MOVING_AVERAGE_100_DAY = 305
const FieldId | Activ::ContentPlatform::Feed::FID_MOVING_AVERAGE_10_DAY = 908
const FieldId | Activ::ContentPlatform::Feed::FID_MOVING_AVERAGE_120_DAY = 913
const FieldId | Activ::ContentPlatform::Feed::FID_MOVING_AVERAGE_14_DAY = 306
const FieldId | Activ::ContentPlatform::Feed::FID_MOVING_AVERAGE_150_DAY = 914
const FieldId | Activ::ContentPlatform::Feed::FID_MOVING_AVERAGE_15_DAY = 922
const FieldId | Activ::ContentPlatform::Feed::FID_MOVING_AVERAGE_180_DAY = 915
const FieldId | Activ::ContentPlatform::Feed::FID_MOVING_AVERAGE_20_DAY = 909
const FieldId | Activ::ContentPlatform::Feed::FID_MOVING_AVERAGE_21_DAY = 307
const FieldId | Activ::ContentPlatform::Feed::FID_MOVING_AVERAGE_250_DAY = 308
const FieldId | Activ::ContentPlatform::Feed::FID_MOVING_AVERAGE_30_DAY = 910
const FieldId | Activ::ContentPlatform::Feed::FID_MOVING_AVERAGE_360_DAY = 916
const FieldId | Activ::ContentPlatform::Feed::FID_MOVING_AVERAGE_45_DAY = 923
const FieldId | Activ::ContentPlatform::Feed::FID_MOVING_AVERAGE_50_DAY = 309
const FieldId | Activ::ContentPlatform::Feed::FID_MOVING_AVERAGE_5_DAY = 921
const FieldId | Activ::ContentPlatform::Feed::FID_MOVING_AVERAGE_60_DAY = 911
const FieldId | Activ::ContentPlatform::Feed::FID_MOVING_AVERAGE_90_DAY = 912
const FieldId | Activ::ContentPlatform::Feed::FID_MOVING_AVERAGE_9_DAY = 310
const FieldId | Activ::ContentPlatform::Feed::FID_NAME = 311
const FieldId | Activ::ContentPlatform::Feed::FID_NAV = 142
const FieldId | Activ::ContentPlatform::Feed::FID_NAV_DATE = 144
const FieldId | Activ::ContentPlatform::Feed::FID_NAV_HIGH = 495
const FieldId | Activ::ContentPlatform::Feed::FID_NAV_HIGH_TIME = 496
const FieldId | Activ::ContentPlatform::Feed::FID_NAV_LOW = 497
const FieldId | Activ::ContentPlatform::Feed::FID_NAV_LOW_TIME = 498
const FieldId | Activ::ContentPlatform::Feed::FID_NAV_TIME = 143
const FieldId | Activ::ContentPlatform::Feed::FID_NAVIGATION_INDEX_NO = 419
const FieldId | Activ::ContentPlatform::Feed::FID_NAVIGATION_SOURCE_KEY_FIELD_ID = 420
const FieldId | Activ::ContentPlatform::Feed::FID_NAVIGATION_SOURCE_TABLE_NO_FIELD_ID = 802
const FieldId | Activ::ContentPlatform::Feed::FID_NAVIGATION_TABLE_NO = 421
const FieldId | Activ::ContentPlatform::Feed::FID_NAVIGATION_TARGET_KEY_FIELD_ID = 436
const FieldId | Activ::ContentPlatform::Feed::FID_NAVIGATION_TARGET_PERMISSION_ID_FIELD_ID = 437
const FieldId | Activ::ContentPlatform::Feed::FID_NAVIGATION_TARGET_TABLE_NO_FIELD_ID = 438
const FieldId | Activ::ContentPlatform::Feed::FID_NEAR_PRICE = 871
const FieldId | Activ::ContentPlatform::Feed::FID_NET_ACCRUED_DIVIDEND = 312
const FieldId | Activ::ContentPlatform::Feed::FID_NET_CASH_FROM_FINANCING_ACTIVITIES = 734
const FieldId | Activ::ContentPlatform::Feed::FID_NET_CASH_FROM_INVESTMENTS = 735
const FieldId | Activ::ContentPlatform::Feed::FID_NET_CASH_FROM_OPERATIONS = 736
const FieldId | Activ::ContentPlatform::Feed::FID_NET_CASH_NET_CHANGE_AND_CASH_EQUIVELENTS = 737
const FieldId | Activ::ContentPlatform::Feed::FID_NET_CHANGE = 54
const FieldId | Activ::ContentPlatform::Feed::FID_NET_FIXED_ASSETS = 738
const FieldId | Activ::ContentPlatform::Feed::FID_NET_INCOME = 313
const FieldId | Activ::ContentPlatform::Feed::FID_NET_INTEREST_INCOME = 502
const FieldId | Activ::ContentPlatform::Feed::FID_NET_PROPERTY = 314
const FieldId | Activ::ContentPlatform::Feed::FID_NET_PROPERTY_PLANT_AND_EQUIPMENT = 503
const FieldId | Activ::ContentPlatform::Feed::FID_NEW_COMPANY_NAME = 804
const FieldId | Activ::ContentPlatform::Feed::FID_NEW_DESCRIPTION = 422
const FieldId | Activ::ContentPlatform::Feed::FID_NEW_ISIN = 423
const FieldId | Activ::ContentPlatform::Feed::FID_NEW_LISTING_PERMISSION_ID = 424
const FieldId | Activ::ContentPlatform::Feed::FID_NEW_LISTING_SYMBOL_LIST = 425
const FieldId | Activ::ContentPlatform::Feed::FID_NEW_PRIMARY_EXCHANGE = 1003
const FieldId | Activ::ContentPlatform::Feed::FID_NEW_SECURITY_SYMBOL = 426
const FieldId | Activ::ContentPlatform::Feed::FID_NEW_SYMBOL_LIST = 518
const FieldId | Activ::ContentPlatform::Feed::FID_NEWS_COUNT = 651
const FieldId | Activ::ContentPlatform::Feed::FID_NEWS_MARKER = 650
const FieldId | Activ::ContentPlatform::Feed::FID_NEWS_STATE = 763
const FieldId | Activ::ContentPlatform::Feed::FID_NEXT_DIVIDEND_1 = 315
const FieldId | Activ::ContentPlatform::Feed::FID_NEXT_DIVIDEND_1_DATE = 316
const FieldId | Activ::ContentPlatform::Feed::FID_NEXT_DIVIDEND_1_DECLARE_DATE = 690
const FieldId | Activ::ContentPlatform::Feed::FID_NEXT_DIVIDEND_1_PAYMENT_DATE = 691
const FieldId | Activ::ContentPlatform::Feed::FID_NEXT_DIVIDEND_1_RECORD_DATE = 692
const FieldId | Activ::ContentPlatform::Feed::FID_NEXT_DIVIDEND_1_STATUS = 317
const FieldId | Activ::ContentPlatform::Feed::FID_NEXT_DIVIDEND_2 = 318
const FieldId | Activ::ContentPlatform::Feed::FID_NEXT_DIVIDEND_2_DATE = 319
const FieldId | Activ::ContentPlatform::Feed::FID_NEXT_DIVIDEND_2_STATUS = 320
const FieldId | Activ::ContentPlatform::Feed::FID_NEXT_DIVIDEND_3 = 321
const FieldId | Activ::ContentPlatform::Feed::FID_NEXT_DIVIDEND_3_DATE = 322
const FieldId | Activ::ContentPlatform::Feed::FID_NEXT_DIVIDEND_3_STATUS = 323
const FieldId | Activ::ContentPlatform::Feed::FID_NEXT_DIVIDEND_4 = 324
const FieldId | Activ::ContentPlatform::Feed::FID_NEXT_DIVIDEND_4_DATE = 325
const FieldId | Activ::ContentPlatform::Feed::FID_NEXT_DIVIDEND_4_STATUS = 326
const FieldId | Activ::ContentPlatform::Feed::FID_NEXT_NEWS_SYMBOL = 764
const FieldId | Activ::ContentPlatform::Feed::FID_NEXT_QUARTER_DATE = 327
const FieldId | Activ::ContentPlatform::Feed::FID_NEXT_SPECIAL_DIVIDEND_1 = 751
const FieldId | Activ::ContentPlatform::Feed::FID_NEXT_SPECIAL_DIVIDEND_1_DATE = 752
const FieldId | Activ::ContentPlatform::Feed::FID_NON_INTEREST_EXPENSES = 504
const FieldId | Activ::ContentPlatform::Feed::FID_NORMAL_MARKET_SIZE = 952
const FieldId | Activ::ContentPlatform::Feed::FID_NORMALIZED_CLOSE_PE_RATIO = 739
const FieldId | Activ::ContentPlatform::Feed::FID_NORMALIZED_HIGH_PE_RATIO = 740
const FieldId | Activ::ContentPlatform::Feed::FID_NORMALIZED_LOW_PE_RATIO = 741
const FieldId | Activ::ContentPlatform::Feed::FID_NUMBER_OF_CONCURRENT_USERS = 553
const FieldId | Activ::ContentPlatform::Feed::FID_NUMBER_OF_MONTHS_SINCE_LAST_REPORTING_PERIOD = 742
const FieldId | Activ::ContentPlatform::Feed::FID_NUMBER_OF_QUARTERS_INCLUDED = 328
const FieldId | Activ::ContentPlatform::Feed::FID_OFFER = 139
const FieldId | Activ::ContentPlatform::Feed::FID_OFFER_DATE = 140
const FieldId | Activ::ContentPlatform::Feed::FID_OFFER_TIME = 141
const FieldId | Activ::ContentPlatform::Feed::FID_OFFICIAL_ASK = 885
const FieldId | Activ::ContentPlatform::Feed::FID_OFFICIAL_ASK_CONDITION = 887
const FieldId | Activ::ContentPlatform::Feed::FID_OFFICIAL_BID = 888
const FieldId | Activ::ContentPlatform::Feed::FID_OFFICIAL_BID_CONDITION = 889
const FieldId | Activ::ContentPlatform::Feed::FID_OFFICIAL_QUOTE_DATE = 886
const FieldId | Activ::ContentPlatform::Feed::FID_OLD_COMPANY_NAME = 803
const FieldId | Activ::ContentPlatform::Feed::FID_OLD_DESCRIPTION = 427
const FieldId | Activ::ContentPlatform::Feed::FID_OLD_ISIN = 428
const FieldId | Activ::ContentPlatform::Feed::FID_OLD_LISTING_PERMISSION_ID = 429
const FieldId | Activ::ContentPlatform::Feed::FID_OLD_LISTING_SYMBOL_LIST = 430
const FieldId | Activ::ContentPlatform::Feed::FID_OLD_PRIMARY_EXCHANGE = 1004
const FieldId | Activ::ContentPlatform::Feed::FID_OLD_SECURITY_SYMBOL = 431
const FieldId | Activ::ContentPlatform::Feed::FID_OLD_SYMBOL_LIST = 519
const FieldId | Activ::ContentPlatform::Feed::FID_OPEN = 35
const FieldId | Activ::ContentPlatform::Feed::FID_OPEN_CONDITION = 37
const FieldId | Activ::ContentPlatform::Feed::FID_OPEN_EXCHANGE = 39
const FieldId | Activ::ContentPlatform::Feed::FID_OPEN_INTEREST = 134
const FieldId | Activ::ContentPlatform::Feed::FID_OPEN_INTEREST_DATE = 135
const FieldId | Activ::ContentPlatform::Feed::FID_OPEN_RANGE_1 = 123
const FieldId | Activ::ContentPlatform::Feed::FID_OPEN_RANGE_1_CONDITION = 124
const FieldId | Activ::ContentPlatform::Feed::FID_OPEN_RANGE_2 = 125
const FieldId | Activ::ContentPlatform::Feed::FID_OPEN_RANGE_2_CONDITION = 126
const FieldId | Activ::ContentPlatform::Feed::FID_OPEN_RANGE_TIME = 127
const FieldId | Activ::ContentPlatform::Feed::FID_OPEN_SIZE = 36
const FieldId | Activ::ContentPlatform::Feed::FID_OPEN_TIME = 38
const FieldId | Activ::ContentPlatform::Feed::FID_OPTION_DELIVERABLE_SYMBOL = 432
const FieldId | Activ::ContentPlatform::Feed::FID_OPTION_DELIVERABLE_TABLE_NO = 433
const FieldId | Activ::ContentPlatform::Feed::FID_OPTION_PATTERN_SYMBOL = 758
const FieldId | Activ::ContentPlatform::Feed::FID_OPTION_PATTERN_TABLE_NO = 759
const FieldId | Activ::ContentPlatform::Feed::FID_OPTION_ROOT_SYMBOL = 434
const FieldId | Activ::ContentPlatform::Feed::FID_OPTION_ROOT_TABLE_NO = 435
const FieldId | Activ::ContentPlatform::Feed::FID_OPTION_TYPE = 329
const FieldId | Activ::ContentPlatform::Feed::FID_ORDER_BUY_SELL = 46
const FieldId | Activ::ContentPlatform::Feed::FID_ORDER_COUNT = 689
const FieldId | Activ::ContentPlatform::Feed::FID_ORDER_DATE = 45
const FieldId | Activ::ContentPlatform::Feed::FID_ORDER_PRICE = 42
const FieldId | Activ::ContentPlatform::Feed::FID_ORDER_SEQUENCE_NUMBER = 47
const FieldId | Activ::ContentPlatform::Feed::FID_ORDER_SIZE = 43
const FieldId | Activ::ContentPlatform::Feed::FID_ORDER_STATE = 48
const FieldId | Activ::ContentPlatform::Feed::FID_ORDER_TIME = 44
const FieldId | Activ::ContentPlatform::Feed::FID_ORDER_TYPE = 49
const FieldId | Activ::ContentPlatform::Feed::FID_OTHER_EXPENSES = 330
const FieldId | Activ::ContentPlatform::Feed::FID_OTHER_INCOME = 331
const FieldId | Activ::ContentPlatform::Feed::FID_OTHER_NON_CURRENT_ASSETS = 743
const FieldId | Activ::ContentPlatform::Feed::FID_OTHER_UPDATES = 854
const FieldId | Activ::ContentPlatform::Feed::FID_PAIRED_SHARES = 872
const FieldId | Activ::ContentPlatform::Feed::FID_PAR_VALUE_OF_COMMON_STOCK = 505
const FieldId | Activ::ContentPlatform::Feed::FID_PAR_VALUE_PER_UNIT = 332
const FieldId | Activ::ContentPlatform::Feed::FID_PARTICIPANT = 547
const FieldId | Activ::ContentPlatform::Feed::FID_PARTICIPANT_LIST = 882
const FieldId | Activ::ContentPlatform::Feed::FID_PASSWORD = 439
const FieldId | Activ::ContentPlatform::Feed::FID_PAYMENT_DATE = 333
const FieldId | Activ::ContentPlatform::Feed::FID_PE_RATIO = 648
const FieldId | Activ::ContentPlatform::Feed::FID_PE_RATIO_1_MONTH_AGO = 745
const FieldId | Activ::ContentPlatform::Feed::FID_PE_RATIO_52_WEEKS_AGO = 746
const FieldId | Activ::ContentPlatform::Feed::FID_PERCENT_CHANGE = 55
const FieldId | Activ::ContentPlatform::Feed::FID_PERIOD = 953
const FieldId | Activ::ContentPlatform::Feed::FID_PERMISSION_BODY = 440
const FieldId | Activ::ContentPlatform::Feed::FID_PERMISSION_ID = 441
const FieldId | Activ::ContentPlatform::Feed::FID_PERMISSION_ID_0 = 442
const FieldId | Activ::ContentPlatform::Feed::FID_PERMISSION_ID_1 = 443
const FieldId | Activ::ContentPlatform::Feed::FID_PERMISSION_ID_LIST = 649
const FieldId | Activ::ContentPlatform::Feed::FID_PERMISSION_LEVEL_ID = 444
const FieldId | Activ::ContentPlatform::Feed::FID_PLANT_AND_EQUIPMENT = 334
const FieldId | Activ::ContentPlatform::Feed::FID_POINT_SIZE = 792
const FieldId | Activ::ContentPlatform::Feed::FID_POST_FLAG = 931
const FieldId | Activ::ContentPlatform::Feed::FID_PRE_POST_MARKET_CUMULATIVE_VALUE = 748
const FieldId | Activ::ContentPlatform::Feed::FID_PRE_POST_MARKET_CUMULATIVE_VOLUME = 53
const FieldId | Activ::ContentPlatform::Feed::FID_PRE_POST_MARKET_TRADE = 974
const FieldId | Activ::ContentPlatform::Feed::FID_PRE_POST_MARKET_TRADE_CONDITION = 976
const FieldId | Activ::ContentPlatform::Feed::FID_PRE_POST_MARKET_TRADE_DATE = 978
const FieldId | Activ::ContentPlatform::Feed::FID_PRE_POST_MARKET_TRADE_EXCHANGE = 979
const FieldId | Activ::ContentPlatform::Feed::FID_PRE_POST_MARKET_TRADE_REPORTING_EXCHANGE = 980
const FieldId | Activ::ContentPlatform::Feed::FID_PRE_POST_MARKET_TRADE_SIZE = 975
const FieldId | Activ::ContentPlatform::Feed::FID_PRE_POST_MARKET_TRADE_THROUGH_EXEMPT_FLAG = 981
const FieldId | Activ::ContentPlatform::Feed::FID_PRE_POST_MARKET_TRADE_TIME = 977
const FieldId | Activ::ContentPlatform::Feed::FID_PREFERRED_STOCK_EQUITY = 744
const FieldId | Activ::ContentPlatform::Feed::FID_PREMIUMS_EARNED = 506
const FieldId | Activ::ContentPlatform::Feed::FID_PREMIUMS_EARNED_LESS_EXPENSES = 507
const FieldId | Activ::ContentPlatform::Feed::FID_PREVIOUS_12_MONTHS_EARNINGS_PER_SHARE = 335
const FieldId | Activ::ContentPlatform::Feed::FID_PREVIOUS_7_QUARTERS_EARNINGS_PER_SHARE = 336
const FieldId | Activ::ContentPlatform::Feed::FID_PREVIOUS_ASK = 653
const FieldId | Activ::ContentPlatform::Feed::FID_PREVIOUS_BID = 652
const FieldId | Activ::ContentPlatform::Feed::FID_PREVIOUS_CALENDAR_CLOSE = 967
const FieldId | Activ::ContentPlatform::Feed::FID_PREVIOUS_CALENDAR_CLOSE_DATE = 968
const FieldId | Activ::ContentPlatform::Feed::FID_PREVIOUS_CLOSE = 113
const FieldId | Activ::ContentPlatform::Feed::FID_PREVIOUS_CLOSE_DATE = 655
const FieldId | Activ::ContentPlatform::Feed::FID_PREVIOUS_CUMULATIVE_PRICE = 516
const FieldId | Activ::ContentPlatform::Feed::FID_PREVIOUS_CUMULATIVE_VALUE = 657
const FieldId | Activ::ContentPlatform::Feed::FID_PREVIOUS_CUMULATIVE_VOLUME = 658
const FieldId | Activ::ContentPlatform::Feed::FID_PREVIOUS_CUMULATIVE_VOLUME_DATE = 659
const FieldId | Activ::ContentPlatform::Feed::FID_PREVIOUS_CURRENT_DATE = 337
const FieldId | Activ::ContentPlatform::Feed::FID_PREVIOUS_CURRENT_HIGH = 117
const FieldId | Activ::ContentPlatform::Feed::FID_PREVIOUS_CURRENT_LOW = 118
const FieldId | Activ::ContentPlatform::Feed::FID_PREVIOUS_DIVIDEND = 338
const FieldId | Activ::ContentPlatform::Feed::FID_PREVIOUS_DIVIDEND_DATE = 339
const FieldId | Activ::ContentPlatform::Feed::FID_PREVIOUS_FISCAL_YEAR_EARNINGS_PER_SHARE = 340
const FieldId | Activ::ContentPlatform::Feed::FID_PREVIOUS_MID = 954
const FieldId | Activ::ContentPlatform::Feed::FID_PREVIOUS_NET_CHANGE = 119
const FieldId | Activ::ContentPlatform::Feed::FID_PREVIOUS_NEWS_SYMBOL = 765
const FieldId | Activ::ContentPlatform::Feed::FID_PREVIOUS_OPEN = 114
const FieldId | Activ::ContentPlatform::Feed::FID_PREVIOUS_OPEN_INTEREST = 121
const FieldId | Activ::ContentPlatform::Feed::FID_PREVIOUS_OPEN_INTEREST_DATE = 122
const FieldId | Activ::ContentPlatform::Feed::FID_PREVIOUS_PERCENT_CHANGE = 120
const FieldId | Activ::ContentPlatform::Feed::FID_PREVIOUS_QUOTE_DATE = 654
const FieldId | Activ::ContentPlatform::Feed::FID_PREVIOUS_SETTLEMENT = 513
const FieldId | Activ::ContentPlatform::Feed::FID_PREVIOUS_SETTLEMENT_DATE = 656
const FieldId | Activ::ContentPlatform::Feed::FID_PREVIOUS_SYMBOL = 445
const FieldId | Activ::ContentPlatform::Feed::FID_PREVIOUS_TRADE_HIGH = 115
const FieldId | Activ::ContentPlatform::Feed::FID_PREVIOUS_TRADE_LOW = 116
const FieldId | Activ::ContentPlatform::Feed::FID_PREVIOUS_TRADING_DATE = 112
const FieldId | Activ::ContentPlatform::Feed::FID_PRICE_ADJUSTMENT = 556
const FieldId | Activ::ContentPlatform::Feed::FID_PRICE_VARIATION_INDICATOR = 873
const FieldId | Activ::ContentPlatform::Feed::FID_PRIMARY_EXCHANGE = 341
const FieldId | Activ::ContentPlatform::Feed::FID_PROVIDER_NAME = 446
const FieldId | Activ::ContentPlatform::Feed::FID_PUBLICATION_THRESHOLD_SIZE = 955
const FieldId | Activ::ContentPlatform::Feed::FID_QUARTERLY_INDICATOR = 747
const FieldId | Activ::ContentPlatform::Feed::FID_QUOTE_DATE = 11
const FieldId | Activ::ContentPlatform::Feed::FID_QUOTE_UPDATES = 853
const FieldId | Activ::ContentPlatform::Feed::FID_RATE_OF_RETURN_12MONTH = 342
const FieldId | Activ::ContentPlatform::Feed::FID_RATE_OF_RETURN_YEAR = 343
const FieldId | Activ::ContentPlatform::Feed::FID_RATIO = 893
const FieldId | Activ::ContentPlatform::Feed::FID_RECORD_DATE = 344
const FieldId | Activ::ContentPlatform::Feed::FID_RECORD_STATUS = 447
const FieldId | Activ::ContentPlatform::Feed::FID_RELATIONSHIP_ID = 448
const FieldId | Activ::ContentPlatform::Feed::FID_RELATIONSHIP_TYPE = 757
const FieldId | Activ::ContentPlatform::Feed::FID_REPORT_DATE = 526
const FieldId | Activ::ContentPlatform::Feed::FID_RESET_DATE = 449
const FieldId | Activ::ContentPlatform::Feed::FID_RESET_TIME = 450
const FieldId | Activ::ContentPlatform::Feed::FID_RETAINED_EARNINGS = 345
const FieldId | Activ::ContentPlatform::Feed::FID_RETURN_ON_CAPITAL = 346
const FieldId | Activ::ContentPlatform::Feed::FID_REVENUES_FROM_SALES = 347
const FieldId | Activ::ContentPlatform::Feed::FID_RHO = 937
const FieldId | Activ::ContentPlatform::Feed::FID_SECTOR_SYMBOL = 451
const FieldId | Activ::ContentPlatform::Feed::FID_SECTOR_TABLE_NO = 452
const FieldId | Activ::ContentPlatform::Feed::FID_SECURITIES = 508
const FieldId | Activ::ContentPlatform::Feed::FID_SECURITY_SYMBOL = 453
const FieldId | Activ::ContentPlatform::Feed::FID_SECURITY_TABLE_NO = 454
const FieldId | Activ::ContentPlatform::Feed::FID_SEDOL_CODE = 956
const FieldId | Activ::ContentPlatform::Feed::FID_SELLING_AND_GENERAL_ADMIN_EXPENSES = 348
const FieldId | Activ::ContentPlatform::Feed::FID_SEQUENCE_NUMBER = 756
const FieldId | Activ::ContentPlatform::Feed::FID_SERVER_ID_LIST = 788
const FieldId | Activ::ContentPlatform::Feed::FID_SESSION_1_CLOSE = 160
const FieldId | Activ::ContentPlatform::Feed::FID_SESSION_1_CLOSE_CUMULATIVE_VALUE = 163
const FieldId | Activ::ContentPlatform::Feed::FID_SESSION_1_CLOSE_CUMULATIVE_VALUE_STATUS = 164
const FieldId | Activ::ContentPlatform::Feed::FID_SESSION_1_CLOSE_CUMULATIVE_VOLUME = 165
const FieldId | Activ::ContentPlatform::Feed::FID_SESSION_1_CLOSE_CUMULATIVE_VOLUME_STATUS = 166
const FieldId | Activ::ContentPlatform::Feed::FID_SESSION_1_CLOSE_STATUS = 161
const FieldId | Activ::ContentPlatform::Feed::FID_SESSION_1_CLOSE_TIME = 162
const FieldId | Activ::ContentPlatform::Feed::FID_SESSION_1_CLOSING_ASK = 167
const FieldId | Activ::ContentPlatform::Feed::FID_SESSION_1_CLOSING_BID = 168
const FieldId | Activ::ContentPlatform::Feed::FID_SESSION_1_CURRENT_HIGH = 169
const FieldId | Activ::ContentPlatform::Feed::FID_SESSION_1_CURRENT_HIGH_TIME = 170
const FieldId | Activ::ContentPlatform::Feed::FID_SESSION_1_CURRENT_LOW = 171
const FieldId | Activ::ContentPlatform::Feed::FID_SESSION_1_CURRENT_LOW_TIME = 172
const FieldId | Activ::ContentPlatform::Feed::FID_SESSION_1_FIRST_TRADE = 173
const FieldId | Activ::ContentPlatform::Feed::FID_SESSION_1_FIRST_TRADE_TIME = 174
const FieldId | Activ::ContentPlatform::Feed::FID_SESSION_1_INDICATOR = 175
const FieldId | Activ::ContentPlatform::Feed::FID_SESSION_1_OPEN = 176
const FieldId | Activ::ContentPlatform::Feed::FID_SESSION_1_OPEN_TIME = 177
const FieldId | Activ::ContentPlatform::Feed::FID_SESSION_1_TRADE_HIGH = 178
const FieldId | Activ::ContentPlatform::Feed::FID_SESSION_1_TRADE_HIGH_TIME = 179
const FieldId | Activ::ContentPlatform::Feed::FID_SESSION_1_TRADE_LOW = 180
const FieldId | Activ::ContentPlatform::Feed::FID_SESSION_1_TRADE_LOW_TIME = 181
const FieldId | Activ::ContentPlatform::Feed::FID_SESSION_2_CLOSE = 182
const FieldId | Activ::ContentPlatform::Feed::FID_SESSION_2_CLOSE_CUMULATIVE_VALUE = 185
const FieldId | Activ::ContentPlatform::Feed::FID_SESSION_2_CLOSE_CUMULATIVE_VALUE_STATUS = 186
const FieldId | Activ::ContentPlatform::Feed::FID_SESSION_2_CLOSE_CUMULATIVE_VOLUME = 187
const FieldId | Activ::ContentPlatform::Feed::FID_SESSION_2_CLOSE_CUMULATIVE_VOLUME_STATUS = 188
const FieldId | Activ::ContentPlatform::Feed::FID_SESSION_2_CLOSE_STATUS = 183
const FieldId | Activ::ContentPlatform::Feed::FID_SESSION_2_CLOSE_TIME = 184
const FieldId | Activ::ContentPlatform::Feed::FID_SESSION_2_CLOSING_ASK = 189
const FieldId | Activ::ContentPlatform::Feed::FID_SESSION_2_CLOSING_BID = 190
const FieldId | Activ::ContentPlatform::Feed::FID_SESSION_2_CURRENT_HIGH = 191
const FieldId | Activ::ContentPlatform::Feed::FID_SESSION_2_CURRENT_HIGH_TIME = 192
const FieldId | Activ::ContentPlatform::Feed::FID_SESSION_2_CURRENT_LOW = 193
const FieldId | Activ::ContentPlatform::Feed::FID_SESSION_2_CURRENT_LOW_TIME = 194
const FieldId | Activ::ContentPlatform::Feed::FID_SESSION_2_FIRST_TRADE = 195
const FieldId | Activ::ContentPlatform::Feed::FID_SESSION_2_FIRST_TRADE_TIME = 196
const FieldId | Activ::ContentPlatform::Feed::FID_SESSION_2_INDICATOR = 197
const FieldId | Activ::ContentPlatform::Feed::FID_SESSION_2_OPEN = 198
const FieldId | Activ::ContentPlatform::Feed::FID_SESSION_2_OPEN_TIME = 199
const FieldId | Activ::ContentPlatform::Feed::FID_SESSION_2_TRADE_HIGH = 200
const FieldId | Activ::ContentPlatform::Feed::FID_SESSION_2_TRADE_HIGH_TIME = 201
const FieldId | Activ::ContentPlatform::Feed::FID_SESSION_2_TRADE_LOW = 202
const FieldId | Activ::ContentPlatform::Feed::FID_SESSION_2_TRADE_LOW_TIME = 203
const FieldId | Activ::ContentPlatform::Feed::FID_SESSION_3_CLOSE = 204
const FieldId | Activ::ContentPlatform::Feed::FID_SESSION_3_CLOSE_CUMULATIVE_VALUE = 207
const FieldId | Activ::ContentPlatform::Feed::FID_SESSION_3_CLOSE_CUMULATIVE_VALUE_STATUS = 208
const FieldId | Activ::ContentPlatform::Feed::FID_SESSION_3_CLOSE_CUMULATIVE_VOLUME = 209
const FieldId | Activ::ContentPlatform::Feed::FID_SESSION_3_CLOSE_CUMULATIVE_VOLUME_STATUS = 210
const FieldId | Activ::ContentPlatform::Feed::FID_SESSION_3_CLOSE_STATUS = 205
const FieldId | Activ::ContentPlatform::Feed::FID_SESSION_3_CLOSE_TIME = 206
const FieldId | Activ::ContentPlatform::Feed::FID_SESSION_3_CLOSING_ASK = 211
const FieldId | Activ::ContentPlatform::Feed::FID_SESSION_3_CLOSING_BID = 212
const FieldId | Activ::ContentPlatform::Feed::FID_SESSION_3_CURRENT_HIGH = 213
const FieldId | Activ::ContentPlatform::Feed::FID_SESSION_3_CURRENT_HIGH_TIME = 214
const FieldId | Activ::ContentPlatform::Feed::FID_SESSION_3_CURRENT_LOW = 215
const FieldId | Activ::ContentPlatform::Feed::FID_SESSION_3_CURRENT_LOW_TIME = 216
const FieldId | Activ::ContentPlatform::Feed::FID_SESSION_3_FIRST_TRADE = 217
const FieldId | Activ::ContentPlatform::Feed::FID_SESSION_3_FIRST_TRADE_TIME = 218
const FieldId | Activ::ContentPlatform::Feed::FID_SESSION_3_INDICATOR = 219
const FieldId | Activ::ContentPlatform::Feed::FID_SESSION_3_OPEN = 220
const FieldId | Activ::ContentPlatform::Feed::FID_SESSION_3_OPEN_TIME = 221
const FieldId | Activ::ContentPlatform::Feed::FID_SESSION_3_TRADE_HIGH = 222
const FieldId | Activ::ContentPlatform::Feed::FID_SESSION_3_TRADE_HIGH_TIME = 223
const FieldId | Activ::ContentPlatform::Feed::FID_SESSION_3_TRADE_LOW = 224
const FieldId | Activ::ContentPlatform::Feed::FID_SESSION_3_TRADE_LOW_TIME = 225
const FieldId | Activ::ContentPlatform::Feed::FID_SESSION_ID = 349
const FieldId | Activ::ContentPlatform::Feed::FID_SETTLEMENT = 75
const FieldId | Activ::ContentPlatform::Feed::FID_SETTLEMENT_ALLOCATION = 685
const FieldId | Activ::ContentPlatform::Feed::FID_SETTLEMENT_DATE = 79
const FieldId | Activ::ContentPlatform::Feed::FID_SETTLEMENT_SIZE = 76
const FieldId | Activ::ContentPlatform::Feed::FID_SETTLEMENT_STATUS = 77
const FieldId | Activ::ContentPlatform::Feed::FID_SETTLEMENT_TIME = 78
const FieldId | Activ::ContentPlatform::Feed::FID_SETTLEMENT_TYPE = 687
const FieldId | Activ::ContentPlatform::Feed::FID_SHAREHOLDERS = 350
const FieldId | Activ::ContentPlatform::Feed::FID_SHARES_AFTER = 351
const FieldId | Activ::ContentPlatform::Feed::FID_SHARES_BEFORE = 352
const FieldId | Activ::ContentPlatform::Feed::FID_SHARES_HELD_BY_INSTITUTIONS = 353
const FieldId | Activ::ContentPlatform::Feed::FID_SHARES_OUTSTANDING = 354
const FieldId | Activ::ContentPlatform::Feed::FID_SHARES_PER_CONTRACT = 355
const FieldId | Activ::ContentPlatform::Feed::FID_SHORT_NAME = 965
const FieldId | Activ::ContentPlatform::Feed::FID_SHOULD_WATCH = 760
const FieldId | Activ::ContentPlatform::Feed::FID_SIC_CODE = 356
const FieldId | Activ::ContentPlatform::Feed::FID_SOURCE_CONTEXT = 455
const FieldId | Activ::ContentPlatform::Feed::FID_SOURCE_PERMISSION_ID = 552
const FieldId | Activ::ContentPlatform::Feed::FID_SPECIAL_DIVIDEND = 357
const FieldId | Activ::ContentPlatform::Feed::FID_SPECIAL_DIVIDEND_DATE = 358
const FieldId | Activ::ContentPlatform::Feed::FID_SPLIT_DATE = 359
const FieldId | Activ::ContentPlatform::Feed::FID_SPLIT_RATIO = 360
const FieldId | Activ::ContentPlatform::Feed::FID_SPLIT_TYPE = 787
const FieldId | Activ::ContentPlatform::Feed::FID_STANDARD_MARKET_SIZE = 957
const FieldId | Activ::ContentPlatform::Feed::FID_START_DATE = 670
const FieldId | Activ::ContentPlatform::Feed::FID_STATE = 361
const FieldId | Activ::ContentPlatform::Feed::FID_STORY_BODY = 525
const FieldId | Activ::ContentPlatform::Feed::FID_STORY_DATE_TIME = 523
const FieldId | Activ::ContentPlatform::Feed::FID_STRATEGY_LEG_PATTERN_SYMBOL = 896
const FieldId | Activ::ContentPlatform::Feed::FID_STRATEGY_LEG_SYMBOL = 898
const FieldId | Activ::ContentPlatform::Feed::FID_STRATEGY_LEG_TABLE_NO = 897
const FieldId | Activ::ContentPlatform::Feed::FID_STRATEGY_SYMBOL = 894
const FieldId | Activ::ContentPlatform::Feed::FID_STRATEGY_TABLE_NO = 895
const FieldId | Activ::ContentPlatform::Feed::FID_STRATEGY_TYPE = 917
const FieldId | Activ::ContentPlatform::Feed::FID_STRIKE_PRICE = 362
const FieldId | Activ::ContentPlatform::Feed::FID_STRIKE_PRICE_01 = 571
const FieldId | Activ::ContentPlatform::Feed::FID_STRIKE_PRICE_02 = 572
const FieldId | Activ::ContentPlatform::Feed::FID_STRIKE_PRICE_03 = 573
const FieldId | Activ::ContentPlatform::Feed::FID_STRIKE_PRICE_04 = 574
const FieldId | Activ::ContentPlatform::Feed::FID_STRIKE_PRICE_05 = 575
const FieldId | Activ::ContentPlatform::Feed::FID_STRIKE_PRICE_06 = 576
const FieldId | Activ::ContentPlatform::Feed::FID_STRIKE_PRICE_07 = 577
const FieldId | Activ::ContentPlatform::Feed::FID_STRIKE_PRICE_08 = 578
const FieldId | Activ::ContentPlatform::Feed::FID_STRIKE_PRICE_09 = 579
const FieldId | Activ::ContentPlatform::Feed::FID_STRIKE_PRICE_10 = 580
const FieldId | Activ::ContentPlatform::Feed::FID_STRIKE_PRICE_11 = 581
const FieldId | Activ::ContentPlatform::Feed::FID_STRIKE_PRICE_12 = 582
const FieldId | Activ::ContentPlatform::Feed::FID_STRIKE_PRICE_13 = 583
const FieldId | Activ::ContentPlatform::Feed::FID_STRIKE_PRICE_14 = 584
const FieldId | Activ::ContentPlatform::Feed::FID_STRIKE_PRICE_15 = 585
const FieldId | Activ::ContentPlatform::Feed::FID_STRIKE_PRICE_16 = 586
const FieldId | Activ::ContentPlatform::Feed::FID_STRIKE_PRICE_17 = 587
const FieldId | Activ::ContentPlatform::Feed::FID_STRIKE_PRICE_18 = 588
const FieldId | Activ::ContentPlatform::Feed::FID_STRIKE_PRICE_19 = 589
const FieldId | Activ::ContentPlatform::Feed::FID_STRIKE_PRICE_20 = 590
const FieldId | Activ::ContentPlatform::Feed::FID_STRIKE_PRICE_21 = 591
const FieldId | Activ::ContentPlatform::Feed::FID_STRIKE_PRICE_22 = 592
const FieldId | Activ::ContentPlatform::Feed::FID_STRIKE_PRICE_23 = 593
const FieldId | Activ::ContentPlatform::Feed::FID_STRIKE_PRICE_24 = 594
const FieldId | Activ::ContentPlatform::Feed::FID_STRIKE_PRICE_25 = 595
const FieldId | Activ::ContentPlatform::Feed::FID_STRIKE_PRICE_26 = 596
const FieldId | Activ::ContentPlatform::Feed::FID_STRIKE_PRICE_DENOMINATOR = 783
const FieldId | Activ::ContentPlatform::Feed::FID_STRIKE_PRICE_MULTIPLIER = 881
const FieldId | Activ::ContentPlatform::Feed::FID_SUBSCRIPTION_QUOTA = 782
const FieldId | Activ::ContentPlatform::Feed::FID_SUPPLIER = 750
const FieldId | Activ::ContentPlatform::Feed::FID_SYMBOL = 456
const FieldId | Activ::ContentPlatform::Feed::FID_SYMBOL01 = 457
const FieldId | Activ::ContentPlatform::Feed::FID_SYMBOL02 = 458
const FieldId | Activ::ContentPlatform::Feed::FID_SYMBOL03 = 459
const FieldId | Activ::ContentPlatform::Feed::FID_SYMBOL04 = 460
const FieldId | Activ::ContentPlatform::Feed::FID_SYMBOL05 = 461
const FieldId | Activ::ContentPlatform::Feed::FID_SYMBOL06 = 462
const FieldId | Activ::ContentPlatform::Feed::FID_SYMBOL07 = 463
const FieldId | Activ::ContentPlatform::Feed::FID_SYMBOL08 = 464
const FieldId | Activ::ContentPlatform::Feed::FID_SYMBOL09 = 465
const FieldId | Activ::ContentPlatform::Feed::FID_SYMBOL10 = 466
const FieldId | Activ::ContentPlatform::Feed::FID_SYMBOL11 = 467
const FieldId | Activ::ContentPlatform::Feed::FID_SYMBOL12 = 468
const FieldId | Activ::ContentPlatform::Feed::FID_SYMBOL13 = 469
const FieldId | Activ::ContentPlatform::Feed::FID_SYMBOL14 = 470
const FieldId | Activ::ContentPlatform::Feed::FID_SYMBOL15 = 471
const FieldId | Activ::ContentPlatform::Feed::FID_SYMBOL16 = 472
const FieldId | Activ::ContentPlatform::Feed::FID_SYMBOL17 = 473
const FieldId | Activ::ContentPlatform::Feed::FID_SYMBOL18 = 474
const FieldId | Activ::ContentPlatform::Feed::FID_SYMBOL19 = 475
const FieldId | Activ::ContentPlatform::Feed::FID_SYMBOL20 = 476
const FieldId | Activ::ContentPlatform::Feed::FID_SYMBOL_LIST = 558
const FieldId | Activ::ContentPlatform::Feed::FID_SYSTEM_LATENCY = 767
const FieldId | Activ::ContentPlatform::Feed::FID_SYSTEM_TIMESTAMP = 768
const FieldId | Activ::ContentPlatform::Feed::FID_TABLE_ID = 477
const FieldId | Activ::ContentPlatform::Feed::FID_TABLE_NO = 478
const FieldId | Activ::ContentPlatform::Feed::FID_TABLE_NUMBER_LIST = 774
const FieldId | Activ::ContentPlatform::Feed::FID_TABLE_TYPE = 479
const FieldId | Activ::ContentPlatform::Feed::FID_TABLE_VERSION = 480
const FieldId | Activ::ContentPlatform::Feed::FID_TARGET_SYMBOL = 554
const FieldId | Activ::ContentPlatform::Feed::FID_TARGET_TABLE_NO = 555
const FieldId | Activ::ContentPlatform::Feed::FID_THETA = 939
const FieldId | Activ::ContentPlatform::Feed::FID_TICK_COUNT = 363
const FieldId | Activ::ContentPlatform::Feed::FID_TICK_DOWN = 680
const FieldId | Activ::ContentPlatform::Feed::FID_TICK_PRICE = 364
const FieldId | Activ::ContentPlatform::Feed::FID_TICK_SIZE = 365
const FieldId | Activ::ContentPlatform::Feed::FID_TICK_TYPE = 366
const FieldId | Activ::ContentPlatform::Feed::FID_TICK_UNCHANGED = 681
const FieldId | Activ::ContentPlatform::Feed::FID_TICK_UP = 679
const FieldId | Activ::ContentPlatform::Feed::FID_TIME = 367
const FieldId | Activ::ContentPlatform::Feed::FID_TIME_SERIES_SYMBOL = 550
const FieldId | Activ::ContentPlatform::Feed::FID_TIME_SERIES_TABLE_NO = 551
const FieldId | Activ::ContentPlatform::Feed::FID_TIME_SERIES_TYPE = 548
const FieldId | Activ::ContentPlatform::Feed::FID_TOTAL_ASSETS = 368
const FieldId | Activ::ContentPlatform::Feed::FID_TOTAL_CASH = 369
const FieldId | Activ::ContentPlatform::Feed::FID_TOTAL_CASH_AMOUNT_PER_UNIT = 370
const FieldId | Activ::ContentPlatform::Feed::FID_TOTAL_INTEREST_INCOME = 509
const FieldId | Activ::ContentPlatform::Feed::FID_TOTAL_INVESTED_ASSETS = 510
const FieldId | Activ::ContentPlatform::Feed::FID_TOTAL_LIABILITIES = 545
const FieldId | Activ::ContentPlatform::Feed::FID_TOTAL_NON_INTEREST_INCOME = 511
const FieldId | Activ::ContentPlatform::Feed::FID_TOTAL_NON_PREMIUM_INCOME = 512
const FieldId | Activ::ContentPlatform::Feed::FID_TOTAL_UPDATES = 851
const FieldId | Activ::ContentPlatform::Feed::FID_TRADE = 12
const FieldId | Activ::ContentPlatform::Feed::FID_TRADE_BUYER_ID = 693
const FieldId | Activ::ContentPlatform::Feed::FID_TRADE_CONDITION = 14
const FieldId | Activ::ContentPlatform::Feed::FID_TRADE_COUNT = 26
const FieldId | Activ::ContentPlatform::Feed::FID_TRADE_DATE = 16
const FieldId | Activ::ContentPlatform::Feed::FID_TRADE_EXCHANGE = 17
const FieldId | Activ::ContentPlatform::Feed::FID_TRADE_HIGH = 18
const FieldId | Activ::ContentPlatform::Feed::FID_TRADE_HIGH_CONDITION = 19
const FieldId | Activ::ContentPlatform::Feed::FID_TRADE_HIGH_EXCHANGE = 21
const FieldId | Activ::ContentPlatform::Feed::FID_TRADE_HIGH_TIME = 20
const FieldId | Activ::ContentPlatform::Feed::FID_TRADE_LOW = 22
const FieldId | Activ::ContentPlatform::Feed::FID_TRADE_LOW_CONDITION = 23
const FieldId | Activ::ContentPlatform::Feed::FID_TRADE_LOW_EXCHANGE = 25
const FieldId | Activ::ContentPlatform::Feed::FID_TRADE_LOW_TIME = 24
const FieldId | Activ::ContentPlatform::Feed::FID_TRADE_REPORTING_EXCHANGE = 806
const FieldId | Activ::ContentPlatform::Feed::FID_TRADE_SELLER_ID = 694
const FieldId | Activ::ContentPlatform::Feed::FID_TRADE_SIZE = 13
const FieldId | Activ::ContentPlatform::Feed::FID_TRADE_THROUGH_EXEMPT_FLAG = 805
const FieldId | Activ::ContentPlatform::Feed::FID_TRADE_TIME = 15
const FieldId | Activ::ContentPlatform::Feed::FID_TRADE_UPDATES = 852
const FieldId | Activ::ContentPlatform::Feed::FID_TRADING_DAY_END_TIME = 604
const FieldId | Activ::ContentPlatform::Feed::FID_TRADING_DAY_START_TIME = 603
const FieldId | Activ::ContentPlatform::Feed::FID_TRADING_DAYS_OF_WEEK = 605
const FieldId | Activ::ContentPlatform::Feed::FID_UNALLOCATED = 371
const FieldId | Activ::ContentPlatform::Feed::FID_UNCHANGED = 372
const FieldId | Activ::ContentPlatform::Feed::FID_UNCROSSING_CONDITION = 958
const FieldId | Activ::ContentPlatform::Feed::FID_UNCROSSING_DATE = 959
const FieldId | Activ::ContentPlatform::Feed::FID_UNCROSSING_PRICE = 960
const FieldId | Activ::ContentPlatform::Feed::FID_UNCROSSING_TIME = 961
const FieldId | Activ::ContentPlatform::Feed::FID_UNCROSSING_VOLUME = 962
const FieldId | Activ::ContentPlatform::Feed::FID_UNDEFINED = ~0
const FieldId | Activ::ContentPlatform::Feed::FID_UNDERLYING_SYMBOL = 481
const FieldId | Activ::ContentPlatform::Feed::FID_UNDERLYING_TABLE_NO = 482
const FieldId | Activ::ContentPlatform::Feed::FID_UNIT_OF_MEASURE = 606
const FieldId | Activ::ContentPlatform::Feed::FID_UNIT_OF_MEASURE_CURRENCY = 615
const FieldId | Activ::ContentPlatform::Feed::FID_UP = 373
const FieldId | Activ::ContentPlatform::Feed::FID_UPDATE_ID = 483
const FieldId | Activ::ContentPlatform::Feed::FID_USER_BODY = 484
const FieldId | Activ::ContentPlatform::Feed::FID_USER_FLAGS = 966
const FieldId | Activ::ContentPlatform::Feed::FID_USER_ID = 485
const FieldId | Activ::ContentPlatform::Feed::FID_USER_SCOPE = 662
const FieldId | Activ::ContentPlatform::Feed::FID_USER_TYPE = 661
const FieldId | Activ::ContentPlatform::Feed::FID_USERNAME = 486
const FieldId | Activ::ContentPlatform::Feed::FID_UTC_OFFSET = 671
const FieldId | Activ::ContentPlatform::Feed::FID_VEGA = 938
const FieldId | Activ::ContentPlatform::Feed::FID_VENDOR_CODE = 374
const FieldId | Activ::ContentPlatform::Feed::FID_VERSION = 789
const FieldId | Activ::ContentPlatform::Feed::FID_VOLATILITY_01_MONTH = 375
const FieldId | Activ::ContentPlatform::Feed::FID_VOLATILITY_02_MONTH = 376
const FieldId | Activ::ContentPlatform::Feed::FID_VOLATILITY_03_MONTH = 377
const FieldId | Activ::ContentPlatform::Feed::FID_VOLATILITY_04_MONTH = 378
const FieldId | Activ::ContentPlatform::Feed::FID_VOLATILITY_05_MONTH = 379
const FieldId | Activ::ContentPlatform::Feed::FID_VOLATILITY_06_MONTH = 380
const FieldId | Activ::ContentPlatform::Feed::FID_VOLATILITY_07_MONTH = 381
const FieldId | Activ::ContentPlatform::Feed::FID_VOLATILITY_08_MONTH = 382
const FieldId | Activ::ContentPlatform::Feed::FID_VOLATILITY_09_MONTH = 383
const FieldId | Activ::ContentPlatform::Feed::FID_VOLATILITY_10_DAY = 663
const FieldId | Activ::ContentPlatform::Feed::FID_VOLATILITY_10_MONTH = 384
const FieldId | Activ::ContentPlatform::Feed::FID_VOLATILITY_11_MONTH = 385
const FieldId | Activ::ContentPlatform::Feed::FID_VOLATILITY_120_DAY = 667
const FieldId | Activ::ContentPlatform::Feed::FID_VOLATILITY_12_MONTH = 386
const FieldId | Activ::ContentPlatform::Feed::FID_VOLATILITY_150_DAY = 668
const FieldId | Activ::ContentPlatform::Feed::FID_VOLATILITY_15_DAY = 925
const FieldId | Activ::ContentPlatform::Feed::FID_VOLATILITY_180_DAY = 669
const FieldId | Activ::ContentPlatform::Feed::FID_VOLATILITY_20_DAY = 387
const FieldId | Activ::ContentPlatform::Feed::FID_VOLATILITY_30_DAY = 664
const FieldId | Activ::ContentPlatform::Feed::FID_VOLATILITY_360_DAY = 794
const FieldId | Activ::ContentPlatform::Feed::FID_VOLATILITY_45_DAY = 926
const FieldId | Activ::ContentPlatform::Feed::FID_VOLATILITY_5_DAY = 924
const FieldId | Activ::ContentPlatform::Feed::FID_VOLATILITY_60_DAY = 665
const FieldId | Activ::ContentPlatform::Feed::FID_VOLATILITY_90_DAY = 666
const FieldId | Activ::ContentPlatform::Feed::FID_VOLUME_WEIGHTED_OPENING_PRICE = 616
const FieldId | Activ::ContentPlatform::Feed::FID_VWAP = 963
const FieldId | Activ::ContentPlatform::Feed::FID_VWAP_AT = 964
const FieldId | Activ::ContentPlatform::Feed::FID_VWAP_CUMULATIVE_VALUE = 754
const FieldId | Activ::ContentPlatform::Feed::FID_VWAP_CUMULATIVE_VOLUME = 755
const FieldId | Activ::ContentPlatform::Feed::FID_WEIGHT = 388
const FieldId | Activ::ContentPlatform::Feed::FID_WRAP = 145
const FieldId | Activ::ContentPlatform::Feed::FID_WRAP_DATE = 147
const FieldId | Activ::ContentPlatform::Feed::FID_WRAP_TIME = 146
const FieldId | Activ::ContentPlatform::Feed::FID_YEAR_END_DATE = 389
const FieldId | Activ::ContentPlatform::Feed::FID_YEAR_HIGH = 152
const FieldId | Activ::ContentPlatform::Feed::FID_YEAR_HIGH_DATE = 153
const FieldId | Activ::ContentPlatform::Feed::FID_YEAR_LOW = 154
const FieldId | Activ::ContentPlatform::Feed::FID_YEAR_LOW_DATE = 155

Detailed Description

Header file for the field ids.

Log

Definition in file FieldIds.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon

IndexNumbers.h File Reference

Header file for the table template index numbers. More...

#include "ActivContentPlatform/ActivFeedCommon/External.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedDefinitions.h"

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::Feed

Defines

#define | ACTIV_DECLARE_INDEX_PROPERTIES_ENUMERATIONS(id, name) id,
The index properties enumeration declaration.
#define | ACTIV_DECLARE_INDEX_TYPE_ENUMERATIONS(id, name) id,
The index type enumeration declaration.
#define | ACTIV_INDEX_PROPERTIES_LIST(d)
The list of index properties and their string representation.
#define | ACTIV_INDEX_TYPE_LIST(d)
The list of index types and their string representation.

Enumerations

enum | { INDEX_TYPE_RED_BLACK_TREE, INDEX_TYPE_HASH, NUMBER_OF_INDEX_TYPES, INDEX_TYPE_UNKNOWN = static_cast<IndexType>(~0) }
Enumeration of all index properties.
enum {
INDEX_PROPERTY_NONE, INDEX_PROPERTY_UNIQUE, INDEX_PROPERTY_DUPLICATE, INDEX_PROPERTY_PRIMARY_UNIQUE,
NUMBER_OF_INDEX_PROPERTIES, INDEX_PROPERTY_UNKNOWN = static_cast<IndexProperties>(~0)
}
Enumeration of all index properties.

Functions

ACTIV_FEED_COMMON_API std::string | Activ::ContentPlatform::Feed::IndexPropertiesToString (const IndexProperties indexProperties)
Convert an index property to a string.
ACTIV_FEED_COMMON_API std::string | Activ::ContentPlatform::Feed::IndexTypeToString (const IndexType indexType)
Convert a index type to a string.
ACTIV_FEED_COMMON_API
IndexProperties 		Activ::ContentPlatform::Feed::StringToIndexProperties (const std::string &name)
Convert a string to an index property.
ACTIV_FEED_COMMON_API IndexType | Activ::ContentPlatform::Feed::StringToIndexType (const std::string &name)
Convert a string to a index type.

Detailed Description

Header file for the table template index numbers.

Log

Definition in file IndexNumbers.h.

Define Documentation

#define ACTIV_INDEX_PROPERTIES_LIST ( d )

Value:

d(INDEX_PROPERTY_NONE,              None)           \
    d(INDEX_PROPERTY_UNIQUE,            Unique)         \
    d(INDEX_PROPERTY_DUPLICATE,         Duplicate)      \
    d(INDEX_PROPERTY_PRIMARY_UNIQUE,    PrimaryUnique)
The list of index properties and their string representation.

TYPE NAME

Definition at line 82 of file IndexNumbers.h.

#define ACTIV_INDEX_TYPE_LIST ( d )

Value:

d(INDEX_TYPE_RED_BLACK_TREE,    Tree)   \
    d(INDEX_TYPE_HASH,              Hash)
The list of index types and their string representation.

TYPE NAME

Definition at line 29 of file IndexNumbers.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon

PermissionIdHelper.h File Reference

Header file for the permission id helper. More...

#include "ActivContentPlatform/ActivFeedCommon/External.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedDefinitions.h"
#include "ActivContentPlatform/ActivFeedCommon/PermissionIds.h"

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::Feed

Classes

class | Activ::ContentPlatform::Feed::PermissionIdHelper
Permission id helper class. More...

Functions

ACTIV_FEED_COMMON_API std::string | Activ::ContentPlatform::Feed::GetPermissionIdCodeIdentifier (const PermissionId permissionId)
Get the permission id code identifier.
ACTIV_FEED_COMMON_API const
PermissionIdHelper & 		Activ::ContentPlatform::Feed::GetPermissionIdHelper (const PermissionId permissionId)
Get the permission id helper.
ACTIV_FEED_COMMON_API std::string | Activ::ContentPlatform::Feed::GetPermissionIdName (const PermissionId permissionId)
Get the permission id name.

Detailed Description

Header file for the permission id helper.

Log

Definition in file PermissionIdHelper.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon

PermissionIds.h File Reference

Header file for the permission ids. More...

#include "ActivMiddleware/Activ.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedDefinitions.h"

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::Feed

Functions

bool | Activ::ContentPlatform::Feed::IsActualPermissionId (const PermissionId permissionId)
Check if a permission id is not one of the special values.

Variables

const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_ALPHA_TRADING = 127
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_AMEX = 7
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_AMEX_DEPTH_OF_BOOK = 71
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_AMEX_INDEX = 8
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_AMX = 55
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_ASX = 48
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_BATS = 87
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_BME = 124
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_BMF_LEVEL1 = 122
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_BMF_LEVEL2 = 123
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_BOVESPA_LEVEL1 = 105
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_BOVESPA_LEVEL2 = 106
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_BOX_LEVEL1 = 74
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_BOX_LEVEL2 = 75
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_BRUT = 40
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_CBOE_INDEX = 68
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_CBOT = 13
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_CBOT_DJ_INDEX = 15
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_CBOT_MINI = 14
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_CFE = 46
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_CHI_X_CANADA = 115
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_CHI_X_EUROPE = 116
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_CHX = 108
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_CME = 32
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_CME_E_MINI_LEVEL1 = 33
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_CME_E_MINI_LEVEL2 = 34
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_CME_GLOBEX_LEVEL1 = 35
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_CME_GLOBEX_LEVEL2 = 36
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_CME_SP_INDEX = 37
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_CNQ = 50
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_COMEX = 18
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_COMPANY = 22
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_COMTEX = 31
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_COMTEX_PUBCO_CANADA = 51
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_COMTEX_PUBLIC_COMPANIES = 52
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_CORPORATE_ACTION = 20
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_COUNT = 128
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_DIRECT_EDGE = 70
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_DJN = 30
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_DUBAI_MERCANTILE_EXCHANGE = 88
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_EUREX = 66
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_EURONEXT_LIFFE_LEVEL1 = 94
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_EURONEXT_LIFFE_LEVEL2 = 96
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_EURONEXT_PARIS_LEVEL1 = 95
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_EURONEXT_PARIS_LEVEL2 = 97
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_FUKUOKA = 83
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_HEMSCOTT = 49
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_HKFE = 98
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_HKSE = 85
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_ICE_FUTURES_CANADA = 77
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_ICE_FUTURES_EUROPE = 69
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_ICE_FUTURES_US = 19
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_ICE_LEVEL2 = 89
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_INET = 41
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_INSTINET_CBX = 112
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_INTERNAL = 38
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_ISE = 109
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_ITA_LEVEL1 = 90
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_ITA_LEVEL2 = 91
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_JASDAQ_LEVEL1 = 92
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_JASDAQ_LEVEL2 = 93
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_KCBOT = 16
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_LIST = PERMISSION_ID_UNKNOWN - 1
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_LME = 78
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_LME_PLASTICS = 121
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_LME_STEEL = 120
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_LSE_EUROPEAN_LEVEL1 = 103
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_LSE_EUROPEAN_LEVEL2 = 104
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_LSE_INTERNATIONAL_LEVEL1 = 101
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_LSE_INTERNATIONAL_LEVEL2 = 102
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_LSE_UK_LEVEL1 = 99
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_LSE_UK_LEVEL2 = 100
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_MCEX = 111
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_MGEX = 65
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_MIDNIGHT_TRADER_EARNINGS = 63
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_MIDNIGHT_TRADER_EXTENDED = 61
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_MONTREAL_LEVEL1 = 43
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_MONTREAL_LEVEL2 = 60
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_NAGOYA = 82
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_NASDAQ_ADF = 4
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_NASDAQ_INDEX = 3
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_NASDAQ_INDEX_CONSTITUENTS = 117
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_NASDAQ_LEVEL1 = 1
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_NASDAQ_LEVEL2 = 2
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_NASDAQ_MFDS = 29
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_NASDAQ_OPEN_VIEW = 62
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_NASDAQ_TOTAL_VIEW = 58
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_NEWSTEX = 54
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_NONE = 0
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_NSX = 76
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_NYMEX = 17
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_NYSE = 5
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_NYSE_ARCA = 39
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_NYSE_ARCA_OPTIONS = 119
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_NYSE_CORPORATE_ACTION = 118
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_NYSE_INDEX = 6
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_NYSE_OPEN_BOOK = 59
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_ONE_CHICAGO = 44
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_OPRA_COMPOSITE = 9
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_OPRA_FCO = 10
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_OPRA_FOREX = 12
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_OPRA_INDEX = 11
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_OPRA_REGIONAL = 42
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_OSE = 86
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_PBOT = 56
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_PINK_SHEETS_LEVEL1 = 81
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_PINK_SHEETS_LEVEL2 = 64
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_PURE_TRADING_LEVEL1 = 79
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_PURE_TRADING_LEVEL2 = 80
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_RYDEX = 126
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_SAPPORO = 84
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_SECURITY = 21
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_SGX = 73
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_SGX_DERIVATIVES = 107
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_SYDNEY_FUTURES = 67
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_TAIFEX_LEVEL1 = 113
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_TAIFEX_LEVEL2 = 114
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_TENFORE = 45
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_TOCOM = 110
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_TSE = 72
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_TSEC = 125
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_TSX_FOREX = 47
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_TSX_INDEX = 25
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_TSX_LEVEL1 = 23
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_TSX_LEVEL2 = 24
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_TSX_NEWS = 57
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_TSX_VENTURE_INDEX = 28
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_TSX_VENTURE_LEVEL1 = 26
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_TSX_VENTURE_LEVEL2 = 27
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_UNKNOWN = static_cast<PermissionId>(~0)
const PermissionId | Activ::ContentPlatform::Feed::PERMISSION_ID_WORKSTATION_FULL = 53

Detailed Description

Header file for the permission ids.

Log

Definition in file PermissionIds.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon

PermissionLevels.h File Reference

Header file for the permission levels. More...

#include "ActivContentPlatform/ActivFeedCommon/External.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedDefinitions.h"

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::Feed

Classes

union | Activ::ContentPlatform::Feed::PermissionLevelData

Functions

ACTIV_FEED_COMMON_API std::string | Activ::ContentPlatform::Feed::PermissionLevelToString (const PermissionLevel permissionLevel)
Convert a permission level to a string.

Variables

const PermissionLevel | Activ::ContentPlatform::Feed::PERMISSION_LEVEL_COUNT = 2
const PermissionLevel | Activ::ContentPlatform::Feed::PERMISSION_LEVEL_DEFAULT = ~0
const PermissionLevel | Activ::ContentPlatform::Feed::PERMISSION_LEVEL_DELAYED = 1
const PermissionLevel | Activ::ContentPlatform::Feed::PERMISSION_LEVEL_REALTIME = 0

Detailed Description

Header file for the permission levels.

Log

Definition in file PermissionLevels.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon

RelationshipIdHelper.h File Reference

Header file for the relationship id helper. More...

#include "ActivContentPlatform/ActivFeedCommon/External.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedDefinitions.h"
#include "ActivContentPlatform/ActivFeedCommon/RelationshipIds.h"

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::Feed

Classes

class | Activ::ContentPlatform::Feed::RelationshipIdHelper
Relationship id helper class. More...

Functions

ACTIV_FEED_COMMON_API std::string | Activ::ContentPlatform::Feed::GetRelationshipIdCodeIdentifier (const RelationshipId relationshipId)
Get the relationship id code identifier.
ACTIV_FEED_COMMON_API const
RelationshipIdHelper & 		Activ::ContentPlatform::Feed::GetRelationshipIdHelper (const RelationshipId relationshipId)
Get the relationship id helper.
ACTIV_FEED_COMMON_API std::string | Activ::ContentPlatform::Feed::GetRelationshipIdName (const RelationshipId relationshipId)
Get the relationship id name.

Detailed Description

Header file for the relationship id helper.

Log

Definition in file RelationshipIdHelper.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon

RelationshipIds.h File Reference

Header file for the relationship ids. More...

#include "ActivMiddleware/Activ.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedDefinitions.h"

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::Feed

Variables

const RelationshipId | Activ::ContentPlatform::Feed::RELATIONSHIP_ID_ANALYTICS = 115
const RelationshipId | Activ::ContentPlatform::Feed::RELATIONSHIP_ID_BBO_DEPTH = 122
const RelationshipId | Activ::ContentPlatform::Feed::RELATIONSHIP_ID_COMPANY = 106
const RelationshipId | Activ::ContentPlatform::Feed::RELATIONSHIP_ID_EXCHANGE = 128
const RelationshipId | Activ::ContentPlatform::Feed::RELATIONSHIP_ID_FOREX = 118
const RelationshipId | Activ::ContentPlatform::Feed::RELATIONSHIP_ID_FUNDAMENTAL = 119
const RelationshipId | Activ::ContentPlatform::Feed::RELATIONSHIP_ID_FUTURE = 117
const RelationshipId | Activ::ContentPlatform::Feed::RELATIONSHIP_ID_FUTURE_OPTION = 120
const RelationshipId | Activ::ContentPlatform::Feed::RELATIONSHIP_ID_FUTURE_OPTION_EXPIRATION_ROOT = 116
const RelationshipId | Activ::ContentPlatform::Feed::RELATIONSHIP_ID_FUTURE_OPTION_ROOT = 110
const RelationshipId | Activ::ContentPlatform::Feed::RELATIONSHIP_ID_FUTURE_ROOT = 109
const RelationshipId | Activ::ContentPlatform::Feed::RELATIONSHIP_ID_INDEX = 102
const RelationshipId | Activ::ContentPlatform::Feed::RELATIONSHIP_ID_INSTRUMENT = 127
const RelationshipId | Activ::ContentPlatform::Feed::RELATIONSHIP_ID_LISTING = 104
const RelationshipId | Activ::ContentPlatform::Feed::RELATIONSHIP_ID_NON_STANDARD_OPTION = 125
const RelationshipId | Activ::ContentPlatform::Feed::RELATIONSHIP_ID_NON_STANDARD_OPTION_ROOT = 126
const RelationshipId | Activ::ContentPlatform::Feed::RELATIONSHIP_ID_NONE = 0
const RelationshipId | Activ::ContentPlatform::Feed::RELATIONSHIP_ID_OPTION = 113
const RelationshipId | Activ::ContentPlatform::Feed::RELATIONSHIP_ID_OPTION_DELIVERABLE = 107
const RelationshipId | Activ::ContentPlatform::Feed::RELATIONSHIP_ID_OPTION_ROOT = 108
const RelationshipId | Activ::ContentPlatform::Feed::RELATIONSHIP_ID_PRIMARY_LISTING = 114
const RelationshipId | Activ::ContentPlatform::Feed::RELATIONSHIP_ID_SECTOR = 101
const RelationshipId | Activ::ContentPlatform::Feed::RELATIONSHIP_ID_SECURITY = 105
const RelationshipId | Activ::ContentPlatform::Feed::RELATIONSHIP_ID_SPREAD = 111
const RelationshipId | Activ::ContentPlatform::Feed::RELATIONSHIP_ID_STRATEGY = 123
const RelationshipId | Activ::ContentPlatform::Feed::RELATIONSHIP_ID_STRATEGY_LEG = 124
const RelationshipId | Activ::ContentPlatform::Feed::RELATIONSHIP_ID_UNDERLYING = 121
const RelationshipType | Activ::ContentPlatform::Feed::RELATIONSHIP_TYPE_GET_EQUAL = 0
const RelationshipType | Activ::ContentPlatform::Feed::RELATIONSHIP_TYPE_GET_MULTIPLE_PATTERN_MATCH_SOURCE = 1
const RelationshipType | Activ::ContentPlatform::Feed::RELATIONSHIP_TYPE_GET_MULTIPLE_PATTERN_MATCH_TARGET = 2

Detailed Description

Header file for the relationship ids.

Log

Definition in file RelationshipIds.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon

TableNumbers.h File Reference

Header file for the table numbers. More...

#include "ActivMiddleware/Activ.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedDefinitions.h"
#include <vector>

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::Feed

Variables

const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_AMERICAS_EQUITY_OPTION = 43
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_AMERICAS_EQUITY_OPTION_BBO10 = 54
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_AMERICAS_FUTURE = 42
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_AMERICAS_FUTURE_BBO10 = 53
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_AMERICAS_FUTURE_OPTION = 44
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_AMERICAS_FUTURE_OPTION_BBO10 = 55
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_AMERICAS_FUTURE_SPREAD = 64
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_AMERICAS_LISTING = 5
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_AMERICAS_LISTING_BBO10 = 52
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_AP_ANALYTICS = 1023
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_AP_ANALYTICS_NAVIGATION = 1112
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_AP_COMPANY = 1016
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_AP_COMPANY_DOMICILE_NAVIGATION = 1101
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_AP_CORPORATE_EVENTS = 1200
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_AP_DELIST = 1201
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_AP_DIVIDEND = 1202
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_AP_FEED_STATISTICS = 1352
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_AP_FEED_STATUS = 1350
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_AP_FUNDAMENTAL_NAVIGATION = 1115
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_AP_FUTURE = 1002
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_AP_FUTURE_ALIAS = 1601
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_AP_FUTURE_BBO10 = 1012
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_AP_FUTURE_FUTURE_OPTION_EXPIRATION_NAVIGATION = 1114
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_AP_FUTURE_FUTURE_OPTION_PATTERN_NAVIGATION = 1117
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_AP_FUTURE_FUTURE_ROOT_NAVIGATION = 1103
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_AP_FUTURE_OPTION = 1003
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_AP_FUTURE_OPTION_BBO10 = 1013
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_AP_FUTURE_OPTION_ROOT = 1019
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_AP_FUTURE_OPTION_ROOT_FUTURE_OPTION_PATTERN_NAVIGATION = 1102
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_AP_FUTURE_ROOT = 1018
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_AP_FUTURE_ROOT_FUTURE_PATTERN_NAVIGATION = 1118
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_AP_FUTURE_ROOT_FUTURE_SPREAD_PATTERN_NAVIGATION = 1122
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_AP_FUTURE_SPREAD = 1020
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_AP_FUTURE_SPREAD_BBO10 = 1021
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_AP_INDEX = 1004
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_AP_INDEX_CONSTITUENT_NAVIGATION = 1104
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_AP_IPO = 1203
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_AP_LISTING = 1000
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_AP_LISTING_BBO10 = 1010
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_AP_LISTING_COMPANY_NAVIGATION = 1111
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_AP_LISTING_SECURITY_NAVIGATION = 1105
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_AP_MARKET_MAKER_QUOTE = 10
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_AP_MISCELLANEOUS_ALIAS = 1600
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_AP_NON_STANDARD_OPTION_ROOT_UNDERLYING_NAVIGATION = 1128
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_AP_OPTION = 1001
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_AP_OPTION_BBO10 = 1011
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_AP_OPTION_DELIVERABLE = 1028
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_AP_OPTION_ROOT = 1017
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_AP_OPTION_ROOT_OPTION_DELIVERABLE_NAVIGATION = 1106
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_AP_OPTION_ROOT_OPTION_PATTERN_NAVIGATION = 1121
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_AP_OPTION_ROOT_UNDERLYING_NAVIGATION = 1107
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_AP_ORDER = 9
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_AP_PRIMARY_LISTING_NAVIGATION = 1113
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_AP_RANKINGS = 1024
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_AP_SECTOR_CONSTITUENT_NAVIGATION = 1108
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_AP_SECURITY = 1015
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_AP_SECURITY_COMPANY_NAVIGATION = 1109
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_AP_SESSION_FUTURE = 1007
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_AP_SESSION_FUTURE_OPTION = 1008
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_AP_SESSION_INDEX = 1009
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_AP_SESSION_LISTING = 1005
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_AP_SESSION_OPTION = 1006
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_AP_SESSION_STRATEGY = 1025
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_AP_SESSION_WARRANT = 1030
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_AP_SPLIT = 1204
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_AP_STATISTICS = 1022
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_AP_STRATEGY_BBO10 = 1027
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_AP_STRATEGY_LEG = 1026
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_AP_STRATEGY_LEG_UNDERLYING_NAVIGATION = 1126
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_AP_STRATEGY_STRATEGY_LEG_PATTERN_NAVIGATION = 1124
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_AP_STRATEGY_UNDERLYING_NAVIGATION = 1125
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_AP_SYMBOL_CHANGE = 1205
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_AP_SYNTHETIC_CONSTITUENT_NAVIGATION = 1110
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_AP_SYSTEM_MESSAGE = 1402
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_AP_UNDERLYING_BBO_DEPTH_NAVIGATION = 1120
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_AP_UNDERLYING_FUTURE_PATTERN_NAVIGATION = 1119
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_AP_UNDERLYING_FUTURE_ROOT_NAVIGATION = 1123
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_AP_UNDERLYING_NON_STANDARD_OPTION_PATTERN_NAVIGATION = 1127
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_AP_UNDERLYING_OPTION_PATTERN_NAVIGATION = 1116
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_AP_WARRANT = 1029
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_AP_WARRANT_BBO10 = 1031
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_COMPOSITE_EXCHANGE = 503
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_CONTRIBUTION_USER = 303
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_CUG = 300
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_ENTITY_TYPE_RELATIONSHIP_FIELD = 706
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_EU_ANALYTICS = 2018
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_EU_ANALYTICS_NAVIGATION = 2112
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_EU_COMPANY = 2010
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_EU_COMPANY_DOMICILE_NAVIGATION = 2101
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_EU_CORPORATE_EVENTS = 2200
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_EU_DELIST = 2201
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_EU_DIVIDEND = 2202
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_EU_FEED_STATISTICS = 2352
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_EU_FEED_STATUS = 2350
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_EU_FUNDAMENTAL_NAVIGATION = 2115
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_EU_FUTURE = 2002
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_EU_FUTURE_ALIAS = 2601
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_EU_FUTURE_BBO10 = 2006
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_EU_FUTURE_FUTURE_OPTION_EXPIRATION_NAVIGATION = 2114
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_EU_FUTURE_FUTURE_OPTION_PATTERN_NAVIGATION = 2117
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_EU_FUTURE_FUTURE_ROOT_NAVIGATION = 2103
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_EU_FUTURE_OPTION = 2003
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_EU_FUTURE_OPTION_BBO10 = 2007
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_EU_FUTURE_OPTION_ROOT = 2016
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_EU_FUTURE_OPTION_ROOT_FUTURE_OPTION_PATTERN_NAVIGATION = 2102
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_EU_FUTURE_ROOT = 2015
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_EU_FUTURE_ROOT_FUTURE_PATTERN_NAVIGATION = 2118
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_EU_FUTURE_ROOT_FUTURE_SPREAD_PATTERN_NAVIGATION = 2122
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_EU_FUTURE_SPREAD = 2004
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_EU_FUTURE_SPREAD_BBO10 = 2008
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_EU_INDEX = 2011
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_EU_INDEX_CONSTITUENT_NAVIGATION = 2104
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_EU_IPO = 2203
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_EU_LISTING = 2000
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_EU_LISTING_BBO10 = 2012
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_EU_LISTING_COMPANY_NAVIGATION = 2111
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_EU_LISTING_SECURITY_NAVIGATION = 2105
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_EU_MARKET_MAKER_QUOTE = 4
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_EU_MISCELLANEOUS_ALIAS = 2600
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_EU_NON_STANDARD_OPTION_ROOT_UNDERLYING_NAVIGATION = 2128
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_EU_OPTION = 2001
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_EU_OPTION_BBO10 = 2020
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_EU_OPTION_DELIVERABLE = 2021
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_EU_OPTION_ROOT = 2014
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_EU_OPTION_ROOT_OPTION_DELIVERABLE_NAVIGATION = 2106
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_EU_OPTION_ROOT_OPTION_PATTERN_NAVIGATION = 2121
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_EU_OPTION_ROOT_UNDERLYING_NAVIGATION = 2107
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_EU_ORDER = 8
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_EU_PRIMARY_LISTING_NAVIGATION = 2113
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_EU_RANKINGS = 2019
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_EU_SECTOR_CONSTITUENT_NAVIGATION = 2108
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_EU_SECURITY = 2009
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_EU_SECURITY_COMPANY_NAVIGATION = 2109
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_EU_SESSION_FUTURE = 2005
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_EU_SPLIT = 2204
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_EU_STATISTICS = 2017
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_EU_STRATEGY = 2022
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_EU_STRATEGY_BBO10 = 2024
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_EU_STRATEGY_LEG = 2023
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_EU_STRATEGY_LEG_UNDERLYING_NAVIGATION = 2126
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_EU_STRATEGY_STRATEGY_LEG_PATTERN_NAVIGATION = 2124
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_EU_STRATEGY_UNDERLYING_NAVIGATION = 2125
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_EU_SYMBOL_CHANGE = 2205
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_EU_SYNTHETIC_CONSTITUENT_NAVIGATION = 2110
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_EU_SYSTEM_MESSAGE = 2402
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_EU_UNDERLYING_BBO_DEPTH_NAVIGATION = 2120
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_EU_UNDERLYING_FUTURE_PATTERN_NAVIGATION = 2119
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_EU_UNDERLYING_FUTURE_ROOT_NAVIGATION = 2123
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_EU_UNDERLYING_NON_STANDARD_OPTION_PATTERN_NAVIGATION = 2127
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_EU_UNDERLYING_OPTION_PATTERN_NAVIGATION = 2116
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_EU_WARRANT = 2025
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_EU_WARRANT_BBO10 = 2026
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_EXCHANGE = 37
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_EXCHANGE_ENTITY_TYPE_TABLE = 708
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_HKSE_ORDER = 1014
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_LA_ANALYTICS = 4015
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_LA_ANALYTICS_NAVIGATION = 4112
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_LA_COMPANY = 4010
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_LA_COMPANY_DOMICILE_NAVIGATION = 4101
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_LA_CORPORATE_EVENTS = 4200
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_LA_DELIST = 4201
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_LA_DIVIDEND = 4202
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_LA_FEED_STATISTICS = 4352
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_LA_FEED_STATUS = 4350
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_LA_FUNDAMENTAL_NAVIGATION = 4115
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_LA_FUTURE = 4002
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_LA_FUTURE_BBO10 = 4007
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_LA_FUTURE_FUTURE_OPTION_EXPIRATION_NAVIGATION = 4114
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_LA_FUTURE_FUTURE_OPTION_PATTERN_NAVIGATION = 4117
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_LA_FUTURE_FUTURE_ROOT_NAVIGATION = 4103
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_LA_FUTURE_OPTION = 4003
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_LA_FUTURE_OPTION_BBO10 = 4008
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_LA_FUTURE_OPTION_ROOT = 4013
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_LA_FUTURE_OPTION_ROOT_FUTURE_OPTION_PATTERN_NAVIGATION = 4102
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_LA_FUTURE_ROOT = 4012
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_LA_FUTURE_ROOT_FUTURE_PATTERN_NAVIGATION = 4118
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_LA_FUTURE_ROOT_FUTURE_SPREAD_PATTERN_NAVIGATION = 4122
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_LA_INDEX = 4004
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_LA_INDEX_CONSTITUENT_NAVIGATION = 4104
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_LA_IPO = 4203
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_LA_LISTING = 4000
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_LA_LISTING_BBO10 = 4005
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_LA_LISTING_COMPANY_NAVIGATION = 4111
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_LA_LISTING_SECURITY_NAVIGATION = 4105
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_LA_MISCELLANEOUS_ALIAS = 4600
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_LA_NON_STANDARD_OPTION_ROOT_UNDERLYING_NAVIGATION = 4128
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_LA_OPTION = 4001
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_LA_OPTION_BBO10 = 4006
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_LA_OPTION_DELIVERABLE = 4017
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_LA_OPTION_ROOT = 4011
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_LA_OPTION_ROOT_OPTION_DELIVERABLE_NAVIGATION = 4106
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_LA_OPTION_ROOT_OPTION_PATTERN_NAVIGATION = 4121
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_LA_OPTION_ROOT_UNDERLYING_NAVIGATION = 4107
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_LA_ORDER = 7
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_LA_PRIMARY_LISTING_NAVIGATION = 4113
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_LA_RANKINGS = 4016
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_LA_SECTOR_CONSTITUENT_NAVIGATION = 4108
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_LA_SECURITY = 4009
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_LA_SECURITY_COMPANY_NAVIGATION = 4109
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_LA_SPLIT = 4204
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_LA_STATISTICS = 4014
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_LA_STRATEGY_LEG_UNDERLYING_NAVIGATION = 4126
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_LA_STRATEGY_STRATEGY_LEG_PATTERN_NAVIGATION = 4124
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_LA_STRATEGY_UNDERLYING_NAVIGATION = 4125
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_LA_SYMBOL_CHANGE = 4205
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_LA_SYNTHETIC_CONSTITUENT_NAVIGATION = 4110
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_LA_SYSTEM_MESSAGE = 4402
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_LA_UNDERLYING_BBO_DEPTH_NAVIGATION = 4120
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_LA_UNDERLYING_FUTURE_PATTERN_NAVIGATION = 4119
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_LA_UNDERLYING_FUTURE_ROOT_NAVIGATION = 4123
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_LA_UNDERLYING_NON_STANDARD_OPTION_PATTERN_NAVIGATION = 4127
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_LA_UNDERLYING_OPTION_PATTERN_NAVIGATION = 4116
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_LATENCY = 351
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_LSE_LISTING = 2013
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_NA_ANALYTICS = 40
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_NA_ANALYTICS_NAVIGATION = 112
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_NA_BANK_COMPANY = 32
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_NA_COMPANY = 31
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_NA_COMPANY_DOMICILE_NAVIGATION = 101
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_NA_CORPORATE_EVENTS = 200
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_NA_DELIST = 201
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_NA_DIVIDEND = 202
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_NA_EXCHANGE_INSTRUMENT_PATTERN_NAVIGATION = 129
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_NA_FEED_STATISTICS = 352
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_NA_FEED_STATUS = 350
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_NA_FOREX = 24
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_NA_FUND = 23
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_NA_FUNDAMENTAL_NAVIGATION = 115
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_NA_FUTURE_ALIAS = 601
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_NA_FUTURE_FUTURE_OPTION_EXPIRATION_NAVIGATION = 114
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_NA_FUTURE_FUTURE_OPTION_PATTERN_NAVIGATION = 117
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_NA_FUTURE_FUTURE_ROOT_NAVIGATION = 103
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_NA_FUTURE_OPTION_ROOT = 28
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_NA_FUTURE_OPTION_ROOT_FUTURE_OPTION_PATTERN_NAVIGATION = 102
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_NA_FUTURE_ROOT = 27
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_NA_FUTURE_ROOT_FUTURE_PATTERN_NAVIGATION = 118
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_NA_FUTURE_ROOT_FUTURE_SPREAD_PATTERN_NAVIGATION = 122
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_NA_INDEX = 2
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_NA_INDEX_CONSTITUENT_NAVIGATION = 104
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_NA_INDUSTRIAL_COMPANY = 33
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_NA_INSURANCE_COMPANY = 34
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_NA_IPO = 203
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_NA_LISTING_COMPANY_NAVIGATION = 111
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_NA_LISTING_SECURITY_NAVIGATION = 105
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_NA_MISCELLANEOUS_ALIAS = 600
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_NA_MONEY_MARKET = 22
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_NA_MUTUAL_FUND = 21
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_NA_NON_STANDARD_OPTION_ROOT_UNDERLYING_NAVIGATION = 128
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_NA_OPTION_DELIVERABLE = 26
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_NA_OPTION_ROOT = 25
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_NA_OPTION_ROOT_OPTION_DELIVERABLE_NAVIGATION = 106
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_NA_OPTION_ROOT_OPTION_PATTERN_NAVIGATION = 121
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_NA_OPTION_ROOT_UNDERLYING_NAVIGATION = 107
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_NA_OPTION_SYMBOL_EVENT = 206
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_NA_ORDER = 6
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_NA_PRIMARY_LISTING_NAVIGATION = 113
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_NA_RANKINGS = 41
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_NA_SECTOR = 36
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_NA_SECTOR_CONSTITUENT_NAVIGATION = 108
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_NA_SECURITY = 30
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_NA_SECURITY_COMPANY_NAVIGATION = 109
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_NA_SPLIT = 204
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_NA_STATISTICS = 39
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_NA_STRATEGY_LEG_UNDERLYING_NAVIGATION = 126
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_NA_STRATEGY_STRATEGY_LEG_PATTERN_NAVIGATION = 124
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_NA_STRATEGY_UNDERLYING_NAVIGATION = 125
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_NA_SYMBOL_CHANGE = 205
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_NA_SYNTHETIC = 29
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_NA_SYNTHETIC_CONSTITUENT_NAVIGATION = 110
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_NA_SYSTEM_MESSAGE = 402
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_NA_THRIFT_COMPANY = 35
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_NA_UNDERLYING_BBO_DEPTH_NAVIGATION = 120
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_NA_UNDERLYING_FUTURE_PATTERN_NAVIGATION = 119
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_NA_UNDERLYING_FUTURE_ROOT_NAVIGATION = 123
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_NA_UNDERLYING_NON_STANDARD_OPTION_PATTERN_NAVIGATION = 127
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_NA_UNDERLYING_OPTION_PATTERN_NAVIGATION = 116
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_NEWS = 400
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_NEWS_HEADLINE = 401
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_PERMISSION = 301
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_PERMISSION_METADATA = 705
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_RELATIONSHIP = 100
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_TABLE_ENTITY_TYPE = 707
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_TABLE_TEMPLATE_FIELD_LIST_METADATA = 702
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_TABLE_TEMPLATE_INDEX_FIELD_LIST_METADATA = 704
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_TABLE_TEMPLATE_INDEX_LIST_METADATA = 703
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_TABLE_TEMPLATE_LIST_METADATA = 700
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_TIME_SERIES_ADJUSTMENT = 504
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_TIME_SERIES_HISTORY = 502
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_TIME_SERIES_INTRADAY = 501
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_TIME_SERIES_TRADE = 500
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_UNIVERSAL_FIELD_LIST_METADATA = 701
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_US_EQUITY_OPTION = 1
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_US_EQUITY_OPTION_BBO10 = 20
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_US_FUTURE = 16
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_US_FUTURE_BBO10 = 50
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_US_FUTURE_OPTION = 17
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_US_FUTURE_OPTION_BBO10 = 51
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_US_FUTURE_SPREAD = 46
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_US_FUTURE_SPREAD_BBO10 = 56
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_US_LISTING = 0
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_US_LISTING_BBO10 = 19
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_US_MARKET_MAKER_QUOTE = 3
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_US_STRATEGY = 45
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_US_STRATEGY_BBO10 = 81
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_US_STRATEGY_LEG = 80
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_USER = 302
const TableNo | Activ::ContentPlatform::Feed::TABLE_NO_WORKSTATION_USER = 709

Detailed Description

Header file for the table numbers.

Log

Definition in file TableNumbers.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon

TableResetTypes.h File Reference

Header file for the table reset types. More...

#include "ActivContentPlatform/ActivFeedCommon/External.h"
#include <string>

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::Feed

Defines

#define | ACTIV_DECLARE_TABLE_RESET_TYPE_ENUMERATIONS(id, name) id,
The table reset type enumeration declaration.
#define | ACTIV_TABLE_RESET_TYPE_LIST(d)
The list of table reset types and their string representation.

Typedefs

typedef uint8_t | Activ::ContentPlatform::Feed::TableResetType
The table reset type type definition.

Enumerations

enum {
RESET_TYPE_NONE, RESET_TYPE_INTERNAL, RESET_TYPE_EXTERNAL, NUMBER_OF_TABLE_RESET_TYPES,
TABLE_RESET_TYPE_UNKNOWN = static_cast<TableResetType>(~0)
}
Enumeration of all table reset types.

Functions

ACTIV_FEED_COMMON_API
TableResetType 		Activ::ContentPlatform::Feed::StringToTableResetType (const std::string &name)
Convert a string to a table reset type.
ACTIV_FEED_COMMON_API std::string | Activ::ContentPlatform::Feed::TableResetTypeToString (const TableResetType tableResetType)
Convert a table reset type to a string.

Detailed Description

Header file for the table reset types.

Log

Definition in file TableResetTypes.h.

Define Documentation

#define ACTIV_TABLE_RESET_TYPE_LIST ( d )

Value:

d(RESET_TYPE_NONE,          None)               \
    d(RESET_TYPE_INTERNAL,      Internal)           \
    d(RESET_TYPE_EXTERNAL,      External)
The list of table reset types and their string representation.

TYPE NAME

Definition at line 32 of file TableResetTypes.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon

TableTypes.h File Reference

Header file for the table types. More...

#include "ActivContentPlatform/ActivFeedCommon/External.h"
#include <string>

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::Feed

Defines

#define | ACTIV_DECLARE_TABLE_TYPE_ENUMERATIONS(id, name, abbreviatedName) id,
The table type enumeration declaration.
#define | ACTIV_TABLE_TYPE_LIST(d)
The list of table types and their string representation.

Typedefs

typedef uint8_t | Activ::ContentPlatform::Feed::TableType
The table type type definition.

Enumerations

enum {
TABLE_TYPE_REALTIME, TABLE_TYPE_NAVIGATION, TABLE_TYPE_PERMISSION, TABLE_TYPE_CORPORATE_ACTION,
TABLE_TYPE_NEWS, TABLE_TYPE_INTERNAL, TABLE_TYPE_REALTIME_LEVEL_2, TABLE_TYPE_ALIAS,
TABLE_TYPE_METADATA, TABLE_TYPE_USER, TABLE_TYPE_ORDER, TABLE_TYPE_BBO_DEPTH,
NUMBER_OF_TABLE_TYPES, TABLE_TYPE_UNKNOWN = static_cast<TableType>(~0)
}
Enumeration of all table types.

Functions

ACTIV_FEED_COMMON_API TableType | Activ::ContentPlatform::Feed::StringToTableType (const std::string &name)
Convert a string to a table type.
ACTIV_FEED_COMMON_API std::string | Activ::ContentPlatform::Feed::TableTypeToAbbreviatedString (const TableType tableType)
Convert a table type to an abbreviated string.
ACTIV_FEED_COMMON_API std::string | Activ::ContentPlatform::Feed::TableTypeToString (const TableType tableType)
Convert a table type to a string.

Detailed Description

Header file for the table types.

Log

Definition in file TableTypes.h.

Define Documentation

#define ACTIV_TABLE_TYPE_LIST ( d )

Value:

d(TABLE_TYPE_REALTIME,          Realtime,           RT)     \
    d(TABLE_TYPE_NAVIGATION,        Navigation,         Nav)    \
    d(TABLE_TYPE_PERMISSION,        Permission,         Perm)   \
    d(TABLE_TYPE_CORPORATE_ACTION,  CorporateAction,    CA)     \
    d(TABLE_TYPE_NEWS,              News,               News)   \
    d(TABLE_TYPE_INTERNAL,          Internal,           Intl)   \
    d(TABLE_TYPE_REALTIME_LEVEL_2,  RealtimeLevel2,     RTL2)   \
    d(TABLE_TYPE_ALIAS,             Alias,              Als)    \
    d(TABLE_TYPE_METADATA,          Metadata,           Mtda)   \
    d(TABLE_TYPE_USER,              User,               User)   \
    d(TABLE_TYPE_ORDER,             Order,              Ordr)   \
    d(TABLE_TYPE_BBO_DEPTH,         BboDepth,           BboD)
The list of table types and their string representation.

TYPE NAME ABRV NAME

Definition at line 32 of file TableTypes.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon

UniversalFieldHelper.h File Reference

Header file for the universal field helper. More...

#include "ActivContentPlatform/ActivFeedCommon/External.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedDefinitions.h"
#include "ActivContentPlatform/ActivFeedCommon/FieldIds.h"

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::Feed

Classes

class | Activ::ContentPlatform::Feed::UniversalFieldHelper
Universal field helper class. More...

Functions

ACTIV_FEED_COMMON_API std::string | Activ::ContentPlatform::Feed::GetUniversalFieldCodeIdentifier (const FieldId fieldId)
Get the universal field code identifier.
ACTIV_FEED_COMMON_API std::string | Activ::ContentPlatform::Feed::GetUniversalFieldDescription (const FieldId fieldId)
Get the universal field description.
ACTIV_FEED_COMMON_API const
UniversalFieldHelper & 		Activ::ContentPlatform::Feed::GetUniversalFieldHelper (const FieldId fieldId)
Get the universal field helper.
ACTIV_FEED_COMMON_API size_t | Activ::ContentPlatform::Feed::GetUniversalFieldMaxLength (const FieldId fieldId)
Get the universal field maximum length.
ACTIV_FEED_COMMON_API std::string | Activ::ContentPlatform::Feed::GetUniversalFieldName (const FieldId fieldId)
Get the universal field name.
ACTIV_FEED_COMMON_API FieldType | Activ::ContentPlatform::Feed::GetUniversalFieldType (const FieldId fieldId)
Get the universal field type.

Detailed Description

Header file for the universal field helper.

Log

Definition in file UniversalFieldHelper.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon

UpdateIds.h File Reference

Header file for the update ids. More...

#include "ActivMiddleware/Activ.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedDefinitions.h"

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::Feed

Functions

UpdateId | Activ::ContentPlatform::Feed::GetIncrementedUpdateId (const UpdateId updateId)
Get an incremented version of the update id.
UpdateId | Activ::ContentPlatform::Feed::GetNewRecordUpdateId ()
Get the new record update id.
UpdateId | Activ::ContentPlatform::Feed::GetResetUpdateId (const UpdateId updateId)
Get a reset update id.
UpdateId | Activ::ContentPlatform::Feed::GetUnknownUpdateId ()
Get the unknown update id.
UpdateId | Activ::ContentPlatform::Feed::GetUpdateIdCount (const UpdateId updateId)
Get the count of the update id.
bool | Activ::ContentPlatform::Feed::IsUpdateIdNewRecord (const UpdateId updateId)
Is the value the new record update id?
bool | Activ::ContentPlatform::Feed::IsUpdateIdResetBitSet (const UpdateId updateId)
Is the reset bit set in the update id?
bool | Activ::ContentPlatform::Feed::IsUpdateIdUnknown (const UpdateId updateId)
Is the value the unknown update id?

Variables

const UpdateId | Activ::ContentPlatform::Feed::UPDATE_ID_BIT_RESET = 0
The reset bit of an update id.
const UpdateId | Activ::ContentPlatform::Feed::UPDATE_ID_BITMASK_COUNT = static_cast<UpdateId>(~UPDATE_ID_BITMASK_RESET)
The update id count bitmask.
const UpdateId | Activ::ContentPlatform::Feed::UPDATE_ID_BITMASK_RESET = (1 << ((sizeof(UpdateId) * CHAR_BIT) - (UPDATE_ID_BIT_RESET + 1)))
The update id reset bitmask.
const UpdateId | Activ::ContentPlatform::Feed::UPDATE_ID_COUNT_MAXIMUM = UPDATE_ID_COUNT_UNKNOWN
The maximum allowed update id count.
const UpdateId | Activ::ContentPlatform::Feed::UPDATE_ID_COUNT_NEW_RECORD = 0
The new record update id count .
const UpdateId | Activ::ContentPlatform::Feed::UPDATE_ID_COUNT_UNKNOWN = static_cast<UpdateId>(~0) ^ UPDATE_ID_BITMASK_RESET
The unknown update id count.

Detailed Description

Header file for the update ids.

Log

Definition in file UpdateIds.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedMessageHandler

ActivFeedMessageHandler.h File Reference

Global functions from ActivFeedMessageHandler. More...

#include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/External.h"
#include <string>

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::Feed

Defines

#define | ACTIV_FEED_MESSAGE_TYPE_LIST(d)
The list of message types and their string representation.

Enumerations

enum | MessageType { ACTIV_DECLARE_ELEMENT_1_WITH_COMMA }
Enumeration of all message types.

Functions

ACTIV_FEED_MESSAGE_HANDLER_API
std::string 		Activ::ContentPlatform::Feed::MessageTypeToString (const MessageType messageType)
Convert a message type to a string.

Detailed Description

Global functions from ActivFeedMessageHandler.

Log

Definition in file ActivFeedMessageHandler.h.

Define Documentation

#define ACTIV_FEED_MESSAGE_TYPE_LIST ( d )

Value:

d(MESSAGE_TYPE_TABLE_TEMPLATE,                          "TableTemplate"                         )   \
    d(MESSAGE_TYPE_SYMBOL_RECORD,                           "SymbolRecord"                          )   \
    d(MESSAGE_TYPE_COMPRESSED_QUOTE,                        "CompressedQuote"                       )   \
    d(MESSAGE_TYPE_RECORD,                                  "Record"                                )   \
    d(MESSAGE_TYPE_COMPRESSED_BBO_QUOTE,                    "CompressedBboQuote"                    )   \
    d(MESSAGE_TYPE_UNIVERSAL_FIELD_LIST,                    "UniversalFieldList"                    )   \
    d(MESSAGE_TYPE_TIMESTAMP,                               "Timestamp"                             )   \
    d(MESSAGE_TYPE_FILE,                                    "File"                                  )   \
    d(MESSAGE_TYPE_FILE_EXECUTE,                            "FileExecute"                           )   \
    d(MESSAGE_TYPE_SYMBOL_UPDATE,                           "SymbolUpdate"                          )   \
    d(MESSAGE_TYPE_UPDATE,                                  "Update"                                )   \
    d(MESSAGE_TYPE_COMPRESSED_CLOSE,                        "Compressed Close"                      )   \
    d(MESSAGE_TYPE_COMPRESSED_CLOSING_QUOTE,                "CompressedClosingQuote"                )   \
    d(MESSAGE_TYPE_COMPRESSED_CLOSING_BBO_QUOTE,            "CompressedClosingBboQuote"             )   \
    d(MESSAGE_TYPE_COMPRESSED_COMPOSITE_BBO_QUOTE,          "CompressedCompositeBboQuote"           )   \
    d(MESSAGE_TYPE_COMBINED_QUOTE,                          "CombinedQuote"                         )   \
    d(MESSAGE_TYPE_COMPRESSED_COMBINED_QUOTE,               "CompressedCombinedQuote"               )   \
    d(MESSAGE_TYPE_COMPRESSED_COMPOSITE_CLOSING_BBO_QUOTE,  "CompressedCompositeClosingBboQuote"    )
The list of message types and their string representation.

Definition at line 19 of file ActivFeedMessageHandler.h.

Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedMessageHandler

CombinedQuoteMessageHeaderDefinitions.h File Reference

Header file for the combined quote message header definitions class. More...

#include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/External.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/ActivFeedMessageHandler.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/MessageHeaderDefinitions.h"

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::Feed

Classes

class | Activ::ContentPlatform::Feed::CombinedQuoteMessageHeaderDefinitions
Combined quote message header definitions class. More...

Detailed Description

Header file for the combined quote message header definitions class.

Log

Definition in file CombinedQuoteMessageHeaderDefinitions.h.

Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedMessageHandler

CompressedCombinedQuoteMessage.h File Reference

Header file for the compressed combined quote message class. More...

#include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/Symbol.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/CompressedSymbol.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/CompressedCombinedQuoteMessageDefinitions.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/CompressedCombinedQuoteMessageHeaderDefinitions.h"

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::Feed

Classes

class | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessage
Compressed Combined quote message class. More...

Detailed Description

Header file for the compressed combined quote message class.

Log

Definition in file CompressedCombinedQuoteMessage.h.

Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedMessageHandler

CompressedCombinedQuoteMessageDefinitions.h File Reference

Header file for the compressed message definitions class. More...

#include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/CompressedMessageDefinitions.h"

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::Feed

Classes

class | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageDefinitions
Compressed combined quote message definitions class. More...

Detailed Description

Header file for the compressed message definitions class.

Log

Definition in file CompressedCombinedQuoteMessageDefinitions.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedMessageHandler

CompressedCombinedQuoteMessageHeaderDefinitions.h File Reference

Header file for the compressed combined quote message header definitions class. More...

#include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/External.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/ActivFeedMessageHandler.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/MessageHeaderDefinitions.h"

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::Feed

Classes

class | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderDefinitions
Comrpessed combined quote message header definitions class. More...

Detailed Description

Header file for the compressed combined quote message header definitions class.

Log

Definition in file CompressedCombinedQuoteMessageHeaderDefinitions.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedMessageHandler

CompressedCombinedQuoteMessageHeaderValidator.h File Reference

Header file for the compressed combined quote message header validator class. More...

#include "ActivContentPlatform/ActivFeedCommon/ActivFeed.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/External.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/CompressedCombinedQuoteMessage.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/TableTemplateList.h"

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::Feed

Classes

class | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator
compressed combined quote message header validator class. More...

Detailed Description

Header file for the compressed combined quote message header validator class.

Log

Definition in file CompressedCombinedQuoteMessageHeaderValidator.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedMessageHandler

CompressedMessage.h File Reference

Header file for the compressed message class. More...

#include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/Symbol.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/CompressedSymbol.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/CompressedMessageDefinitions.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/CompressedMessageHeaderDefinitions.h"

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::Feed

Classes

class | Activ::ContentPlatform::Feed::CompressedMessage
Compressed message class. More...

Detailed Description

Header file for the compressed message class.

Log

Definition in file CompressedMessage.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedMessageHandler

CompressedMessageDefinitions.h File Reference

Header file for the compressed message definitions class. More...

#include "ActivMiddleware/ActivBase/MessageValidator.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeed.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/TableTemplate.h"

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::Feed

Classes

class | Activ::ContentPlatform::Feed::CompressedMessageDefinitions
Compressed message definitions class. More...
class | Activ::ContentPlatform::Feed::CompressedMessageDefinitions::FieldHeaderBuilder
Field header builder class. More...
class | Activ::ContentPlatform::Feed::CompressedMessageDefinitions::FieldHeaderValidator
Field header validator class. More...
class | Activ::ContentPlatform::Feed::CompressedMessageDefinitions::FieldSpecification
Field specification class. More...

Defines

#define | ACTIV_FEED_DECLARE_COMPRESSED_MESSAGE_FIELD_SPECIFICATION(id, isSizeField, twinFieldId) CompressedMessageDefinitions::FieldSpecification(Activ::ContentPlatform::Feed::id, isSizeField, Activ::ContentPlatform::Feed::twinFieldId),
The compressed message builder field declaration.

Detailed Description

Header file for the compressed message definitions class.

Log

Definition in file CompressedMessageDefinitions.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedMessageHandler

CompressedMessageHeaderDefinitions.h File Reference

Header file for the compressed message header definitions class. More...

#include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/External.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/ActivFeedMessageHandler.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/MessageHeaderDefinitions.h"

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::Feed

Classes

class | Activ::ContentPlatform::Feed::CompressedMessageHeaderDefinitions
Compressed message header definitions class. More...

Detailed Description

Header file for the compressed message header definitions class.

Log

Definition in file CompressedMessageHeaderDefinitions.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedMessageHandler

CompressedMessageHeaderValidator.h File Reference

Header file for the compressed message header validator class. More...

#include "ActivMiddleware/ActivFieldTypes/TextString.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeed.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/External.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/CompressedMessage.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/TableTemplateList.h"

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::Feed

Classes

class | Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator
compressed message header validator class. More...

Detailed Description

Header file for the compressed message header validator class.

Log

Definition in file CompressedMessageHeaderValidator.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedMessageHandler

CompressedSymbol.h File Reference

Header file for the compressed symbol class. More...

#include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/CompressedUsEquityOptionSymbol.h"
#include <string>

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::Feed

Classes

class | Activ::ContentPlatform::Feed::CompressedSymbol
Compressed symbol class. More...

Detailed Description

Header file for the compressed symbol class.

Log

Definition in file CompressedSymbol.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedMessageHandler

CompressedUsEquityOptionSymbol.h File Reference

Header file for the compressed us equity option symbol class. More...

#include <string>

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::Feed

Classes

class | Activ::ContentPlatform::Feed::CompressedUsEquityOptionSymbol
Compressed us equity option symbol class. More...
class | Activ::ContentPlatform::Feed::CompressedUsEquityOptionSymbol::CStringLessFunctor
C string less than comparision function object.

Detailed Description

Header file for the compressed us equity option symbol class.

Log

Definition in file CompressedUsEquityOptionSymbol.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedMessageHandler

External.h File Reference

Import rules for ActivFeedMessageHandler exports. More...

#include "ActivMiddleware/Activ.h"

Go to the source code of this file.

Defines

#define ACTIV_FEED_MESSAGE_HANDLER_API ACTIV_IMPORT_DLL

Detailed Description

Import rules for ActivFeedMessageHandler exports.

Log

Definition in file External.h.

Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedMessageHandler

FieldHeaderDefinitions.h File Reference

Header file for the field header definitions class. More...

#include "ActivContentPlatform/ActivFeedCommon/FieldIds.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/External.h"

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::Feed

Classes

class | Activ::ContentPlatform::Feed::FieldHeaderDefinitions
Field header definitions class. More...

Detailed Description

Header file for the field header definitions class.

Log

Definition in file FieldHeaderDefinitions.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedMessageHandler

MessageHeaderDefinitions.h File Reference

Header file for the message header definitions class. More...

#include "ActivContentPlatform/ActivFeedCommon/FieldIds.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/External.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/ActivFeedMessageHandler.h"

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::Feed

Classes

class | Activ::ContentPlatform::Feed::MessageHeaderDefinitions
Message header definitions class. More...

Detailed Description

Header file for the message header definitions class.

Log

Definition in file MessageHeaderDefinitions.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedMessageHandler

RecordFieldListBuilder.h File Reference

Header file for the record field list builder class. More...

#include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/External.h"

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::Feed

Classes

class | Activ::ContentPlatform::Feed::RecordFieldListBuilder
Record field list builder class. More...

Detailed Description

Header file for the record field list builder class.

Log

Definition in file RecordFieldListBuilder.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedMessageHandler

RecordFieldListValidator.h File Reference

Header file for the record field list validator class. More...

#include "ActivContentPlatform/ActivFeedCommon/FieldIds.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/External.h"
#include "boost/dynamic_bitset.hpp"
#include <vector>

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::Feed

Classes

class | Activ::ContentPlatform::Feed::RecordFieldListValidator
Record field list validator class. More...
class | Activ::ContentPlatform::Feed::RecordFieldListValidator::ConstIterator
Const iterator class. More...

Detailed Description

Header file for the record field list validator class.

Log

Definition in file RecordFieldListValidator.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedMessageHandler

RecordKeyFieldListBuilder.h File Reference

Header file for the record key field list builder class. More...

#include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/External.h"

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::Feed

Classes

class | Activ::ContentPlatform::Feed::RecordKeyFieldListBuilder
Record key Field list builder class. More...

Detailed Description

Header file for the record key field list builder class.

Log

Definition in file RecordKeyFieldListBuilder.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedMessageHandler

RecordKeyFieldListValidator.h File Reference

Header file for the record key field list validator class. More...

#include "ActivContentPlatform/ActivFeedCommon/FieldIds.h"
#include "ActivMiddleware/ActivFieldTypes/IFieldType.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/External.h"
#include <vector>

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::Feed

Classes

class | Activ::ContentPlatform::Feed::RecordKeyFieldListValidator
Record key field list validator class. More...
class | Activ::ContentPlatform::Feed::RecordKeyFieldListValidator::ConstIterator
Const iterator class. More...

Detailed Description

Header file for the record key field list validator class.

Log

Definition in file RecordKeyFieldListValidator.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedMessageHandler

RecordMessageBuilder.h File Reference

Header file for the record message builder class. More...

#include "ActivContentPlatform/ActivFeedCommon/ActivFeed.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/External.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/RecordKeyFieldListBuilder.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/RecordFieldListBuilder.h"

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::Feed

Classes

class | Activ::ContentPlatform::Feed::RecordMessageBuilder
Record message builder class. More...

Detailed Description

Header file for the record message builder class.

Log

Definition in file RecordMessageBuilder.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedMessageHandler

RecordMessageHeaderDefinitions.h File Reference

Header file for the record message header definitions class. More...

#include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/External.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/ActivFeedMessageHandler.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/MessageHeaderDefinitions.h"

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::Feed

Classes

class | Activ::ContentPlatform::Feed::RecordMessageHeaderDefinitions
Record message header definitions class. More...

Detailed Description

Header file for the record message header definitions class.

Log

Definition in file RecordMessageHeaderDefinitions.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedMessageHandler

RecordMessageHeaderValidator.h File Reference

Header file for the record message header validator class. More...

#include "ActivContentPlatform/ActivFeedCommon/ActivFeed.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/External.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/RecordKeyFieldListValidator.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/TableTemplateList.h"

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::Feed

Classes

class | Activ::ContentPlatform::Feed::RecordMessageHeaderValidator
Record message header validator class. More...

Detailed Description

Header file for the record message header validator class.

Log

Definition in file RecordMessageHeaderValidator.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedMessageHandler

RecordMessageValidator.h File Reference

Header file for the record message validator class. More...

#include "ActivContentPlatform/ActivFeedCommon/ActivFeed.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/External.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/RecordMessageHeaderValidator.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/RecordKeyFieldListValidator.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/RecordFieldListValidator.h"
#include <vector>

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::Feed

Classes

class | Activ::ContentPlatform::Feed::RecordMessageValidator
Record message validator class. More...

Detailed Description

Header file for the record message validator class.

Log

Definition in file RecordMessageValidator.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedMessageHandler

Symbol.h File Reference

Header file for the symbol class. More...

#include "ActivMiddleware/Misc/MemoryHelper.h"
#include <string>

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::Feed

Classes

class | Activ::ContentPlatform::Feed::Symbol
Symbol class. More...

Detailed Description

Header file for the symbol class.

Log

Definition in file Symbol.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedMessageHandler

SymbolRecordField.h File Reference

Header file for the symbol record field class. More...

#include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/External.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/SymbolRecordRuleDefinitions.h"
#include <vector>
#include <iomanip>

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::Feed

Classes

class | Activ::ContentPlatform::Feed::SymbolRecordField
Symbol record field class. More...
class | Activ::ContentPlatform::Feed::SymbolRecordField::PartialUpdate
Partial update class. More...

Detailed Description

Header file for the symbol record field class.

Log

Definition in file SymbolRecordField.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedMessageHandler

SymbolRecordFieldHeaderDefinitions.h File Reference

Header file for the symbol record field header definitions class. More...

#include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/FieldHeaderDefinitions.h"

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::Feed

Classes

class | Activ::ContentPlatform::Feed::SymbolRecordFieldHeaderDefinitions
Symbol record field header definitions class. More...

Detailed Description

Header file for the symbol record field header definitions class.

Log

Definition in file SymbolRecordFieldHeaderDefinitions.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedMessageHandler

SymbolRecordFieldListBuilder.h File Reference

Rule file for the symbol record field list builder class. More...

#include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/External.h"

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::Feed

Classes

class | Activ::ContentPlatform::Feed::SymbolRecordFieldListBuilder
Symbol record field list builder class. More...

Detailed Description

Rule file for the symbol record field list builder class.

Log

Definition in file SymbolRecordFieldListBuilder.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedMessageHandler

SymbolRecordFieldListValidator.h File Reference

Header file for the symbol record field list validator class. More...

#include "ActivContentPlatform/ActivFeedCommon/FieldIds.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/External.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/SymbolRecordField.h"
#include "boost/dynamic_bitset.hpp"
#include <vector>

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::Feed

Classes

class | Activ::ContentPlatform::Feed::SymbolRecordFieldListValidator
Symbol record symbol record field list validator class. More...
class | Activ::ContentPlatform::Feed::SymbolRecordFieldListValidator::ConstIterator
Const iterator class. More...

Detailed Description

Header file for the symbol record field list validator class.

Log

Definition in file SymbolRecordFieldListValidator.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedMessageHandler

SymbolRecordMessageBuilder.h File Reference

Header file for the symbol record message builder class. More...

#include "ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/TableTemplateList.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeed.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/External.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/SymbolRecordFieldListBuilder.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/SymbolRecordRuleDefinitions.h"

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::Feed

Classes

class | Activ::ContentPlatform::Feed::SymbolRecordMessageBuilder
Symbol record message builder class. More...

Detailed Description

Header file for the symbol record message builder class.

Log

Definition in file SymbolRecordMessageBuilder.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedMessageHandler

SymbolRecordMessageHeaderDefinitions.h File Reference

Header file for the symbol record message header definitions class. More...

#include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/External.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/ActivFeedMessageHandler.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/MessageHeaderDefinitions.h"

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::Feed

Classes

class | Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions
Symbol record message header definitions class. More...

Detailed Description

Header file for the symbol record message header definitions class.

Log

Definition in file SymbolRecordMessageHeaderDefinitions.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedMessageHandler

SymbolRecordMessageHeaderValidator.h File Reference

Header file for the symbol record message header validator class. More...

#include "ActivMiddleware/ActivFieldTypes/TextString.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeed.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/External.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/TableTemplateList.h"

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::Feed

Classes

class | Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator
Symbol record message header validator class. More...

Detailed Description

Header file for the symbol record message header validator class.

Log

Definition in file SymbolRecordMessageHeaderValidator.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedMessageHandler

SymbolRecordMessageValidator.h File Reference

Header file for the symbol record message validator class. More...

#include "ActivMiddleware/ActivFieldTypes/TextString.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeed.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/External.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/SymbolRecordMessageHeaderValidator.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/SymbolRecordFieldListValidator.h"

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::Feed

Classes

class | Activ::ContentPlatform::Feed::SymbolRecordMessageValidator
Symbol record message validator class. More...

Detailed Description

Header file for the symbol record message validator class.

Log

Definition in file SymbolRecordMessageValidator.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedMessageHandler

SymbolRecordRuleDefinitions.h File Reference

Header file for the symbol record rules definitions class. More...

#include "ActivContentPlatform/ActivFeedCommon/FieldIds.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/External.h"

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::Feed

Classes

class | Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions
Symbol record rules definitions class. More...
class | Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ContentServerRuleSet
content server rule set. More...
class | Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::TranslatorRuleSet
Translator rule set. More...

Detailed Description

Header file for the symbol record rules definitions class.

Log

Definition in file SymbolRecordRuleDefinitions.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedMessageHandler

TableTemplateField.h File Reference

Header file for the table template field class. More...

#include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/External.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/UniversalFieldList.h"

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::Feed

Classes

class | Activ::ContentPlatform::Feed::TableTemplateField
Table template field class. More...

Detailed Description

Header file for the table template field class.

Log

Definition in file TableTemplateField.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedMessageHandler

TableTemplateFieldListValidator.h File Reference

Header file for the table template field list validator class. More...

#include "ActivContentPlatform/ActivFeedCommon/FieldIds.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/External.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/TableTemplateField.h"
#include <map>

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::Feed

Classes

class | Activ::ContentPlatform::Feed::TableTemplateFieldListValidator
Table template field list validator class. More...
class | Activ::ContentPlatform::Feed::TableTemplateFieldListValidator::ConstIterator
Const iterator class. More...

Detailed Description

Header file for the table template field list validator class.

Log

Definition in file TableTemplateFieldListValidator.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedMessageHandler

TableTemplateIndex.h File Reference

Header file for the table template index class. More...

#include "ActivMiddleware/ActivFieldTypes/TextString.h"
#include "ActivContentPlatform/ActivFeedCommon/FieldIds.h"
#include "ActivContentPlatform/ActivFeedCommon/IndexNumbers.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/External.h"
#include <map>

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::Feed

Classes

class | Activ::ContentPlatform::Feed::TableTemplateIndex
Table template field list validator class. More...

Detailed Description

Header file for the table template index class.

Log

Definition in file TableTemplateIndex.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedMessageHandler

TableTemplateIndexListValidator.h File Reference

Header file for the table template index list validator class. More...

#include "ActivContentPlatform/ActivFeedCommon/FieldIds.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/External.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/TableTemplateIndex.h"
#include <map>

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::Feed

Classes

class | Activ::ContentPlatform::Feed::TableTemplateIndexListValidator
Table template index list validator class. More...

Detailed Description

Header file for the table template index list validator class.

Log

Definition in file TableTemplateIndexListValidator.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedMessageHandler

TableTemplateMessageHeaderDefinitions.h File Reference

Header file for the table template message header definitions class. More...

#include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/External.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/ActivFeedMessageHandler.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/MessageHeaderDefinitions.h"

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::Feed

Classes

class | Activ::ContentPlatform::Feed::TableTemplateMessageHeaderDefinitions
Table template message header definitions class. More...

Detailed Description

Header file for the table template message header definitions class.

Log

Definition in file TableTemplateMessageHeaderDefinitions.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedMessageHandler

TableTemplateMessageValidator.h File Reference

Header file for the table template message validator class. More...

#include "ActivMiddleware/ActivFieldTypes/TextString.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeed.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/External.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/TableTemplateFieldListValidator.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/TableTemplateIndexListValidator.h"

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::Feed

Classes

class | Activ::ContentPlatform::Feed::TableTemplateMessageValidator
Table template message validator class. More...

Detailed Description

Header file for the table template message validator class.

Log

Definition in file TableTemplateMessageValidator.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedPermissioning

PermissionInfo.h File Reference

Header file for exported user permissioning info. More...

#include "ActivContentPlatform/ActivFeedCommon/ActivFeedDefinitions.h"
#include "ActivContentPlatform/ActivFeedCommon/PermissionLevels.h"

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::Feed

Classes

class | Activ::ContentPlatform::Feed::PermissionInfo
Information about a user's permissioning. More...
class | Activ::ContentPlatform::Feed::PermissionInfo::PermissionIdInfo
Information about a particular permission id for the client. More...

Detailed Description

Header file for exported user permissioning info.

Log

Definition in file PermissionInfo.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedTableTemplateHandler

ActivFeedTableTemplateHandler.h File Reference

Global functions from ActivFeedTableTemplateHandler. More...

#include "ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/External.h"

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::Feed

Detailed Description

Global functions from ActivFeedTableTemplateHandler.

Log

Definition in file ActivFeedTableTemplateHandler.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedTableTemplateHandler

External.h File Reference

Import rules for ActivFeedTableTemplateHandler exports. More...

#include "ActivMiddleware/Activ.h"

Go to the source code of this file.

Defines

#define ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API ACTIV_IMPORT_DLL

Detailed Description

Import rules for ActivFeedTableTemplateHandler exports.

Log

Definition in file External.h.

Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedTableTemplateHandler

Field.h File Reference

Header file for the field class. More...

#include "ActivMiddleware/ActivFieldTypes/ActivFieldTypes.h"
#include "ActivContentPlatform/ActivFeedCommon/FieldIds.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/External.h"
#include <string>
#include <vector>
#include <map>

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::Feed

Classes

class | Activ::ContentPlatform::Feed::Field
Field class. More...
class | Activ::ContentPlatform::Feed::Field::Specification
Specification class. More...

Typedefs

typedef std::vector< Field > | Activ::ContentPlatform::Feed::FieldList
list of fields.
typedef std::map
< Feed::FieldId, Feed::Field > 		Activ::ContentPlatform::Feed::FieldMap
map of FieldId, Field pairs.

Functions

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
std::ostream & 		operator<< (std::ostream &os, const Activ::ContentPlatform::Feed::Field &rhs)
Global operator<< to dump a field to an ostream.

Detailed Description

Header file for the field class.

Log

Definition in file Field.h.

Function Documentation

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API std::ostream& operator<< | ( | std::ostream & | os,
 |  | const Activ::ContentPlatform::Feed::Field & | rhs
 | ) |  |

Global operator<< to dump a field to an ostream.

Parameters:
os | the ostream to write the field to.
rhs | the field to write.
Returns:
the ostream os.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedTableTemplateHandler

Index.h File Reference

Header file for an index. More...

#include "ActivMiddleware/ActivDatabase/Record.h"
#include "ActivContentPlatform/ActivFeedCommon/IndexNumbers.h"
#include "ActivContentPlatform/ActivFeedCommon/UniversalFieldHelper.h"
#include "ActivContentPlatform/ActivFeedCommon/FieldIds.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/External.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/Field.h"
#include "xercesc/dom/DOMNode.hpp"
#include <vector>
#include <string>

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::Feed

Classes

class | Activ::ContentPlatform::Feed::Index
class | Activ::ContentPlatform::Feed::Index::IndexFieldSpecification
Index field specification class. More...
class | Activ::ContentPlatform::Feed::Index::Specification
Specification class. More...

Typedefs

typedef std::vector< Index > | Activ::ContentPlatform::Feed::IndexList
The index list type definition.

Functions

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
std::ostream & 		operator<< (std::ostream &os, const Activ::ContentPlatform::Feed::Index &rhs)
Global operator<< to dump an index to an ostream.

Detailed Description

Header file for an index.

Log

Definition in file Index.h.

Function Documentation

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API std::ostream& operator<< | ( | std::ostream & | os,
 |  | const Activ::ContentPlatform::Feed::Index & | rhs
 | ) |  |

Global operator<< to dump an index to an ostream.

Parameters:
os | the ostream to write the index to.
rhs | the index to write.
Returns:
the ostream os.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedTableTemplateHandler

IndexSpecification.h File Reference

Header file for an index specification. More...

#include "ActivMiddleware/ActivDatabase/IndexSpecification.h"
#include "ActivContentPlatform/ActivFeedCommon/FieldIds.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/External.h"
#include <vector>
#include <string>

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::Feed

Classes

class | Activ::ContentPlatform::Feed::IndexSpecification
class | Activ::ContentPlatform::Feed::IndexSpecification::Field
Index field class. More...

Defines

#define | ACTIV_FEED_INDEX_SPECIFICATION_PROPERTIES_LIST(d)
The index specification properties.
#define | ACTIV_FEED_INDEX_SPECIFICATION_TYPE_LIST(d)
The index specification type.

Typedefs

typedef std::vector
< IndexSpecification > 		Activ::ContentPlatform::Feed::IndexSpecificationList

Functions

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API
std::ostream & 		operator<< (std::ostream &os, const Activ::ContentPlatform::Feed::IndexSpecification &rhs)
Global operator<< to dump an index specification to an ostream.

Detailed Description

Header file for an index specification.

Log

Definition in file IndexSpecification.h.

Define Documentation

#define ACTIV_FEED_INDEX_SPECIFICATION_PROPERTIES_LIST ( d )

Value:

d(PROPERTY_NONE,            "None")                     \
    d(PROPERTY_UNIQUE,          "Unique")                   \
    d(PROPERTY_DUPLICATE,       "Duplicate")
The index specification properties.

Definition at line 46 of file IndexSpecification.h.

#define ACTIV_FEED_INDEX_SPECIFICATION_TYPE_LIST ( d )

Value:

d(TYPE_NONE,                    "None")             \
    d(TYPE_RED_BLACK_TREE,          "Red Black Tree")   \
    d(TYPE_HASH,                    "Hash")
The index specification type.

Definition at line 38 of file IndexSpecification.h.

Function Documentation

ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API std::ostream& operator<< | ( | std::ostream & | os,
 |  | const Activ::ContentPlatform::Feed::IndexSpecification & | rhs
 | ) |  |

Global operator<< to dump an index specification to an ostream.

Parameters:
os | the ostream to write the index specification to.
rhs | the index specification to write.
Returns:
the ostream os.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedTableTemplateHandler

Reset.h File Reference

Header file for the reset class. More...

#include "ActivContentPlatform/ActivFeedCommon/FieldIds.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/External.h"
#include <vector>

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::Feed

Classes

class | Activ::ContentPlatform::Feed::CopyOnReset
Copy on reset class. More...

Typedefs

typedef std::vector< CopyOnReset > | Activ::ContentPlatform::Feed::CopyOnResetList
The copy on reset list type definition.
typedef std::vector< FieldId > | Activ::ContentPlatform::Feed::UndefineOnResetList
The undefine on reset list type definition.

Detailed Description

Header file for the reset class.

Log

Definition in file Reset.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedTableTemplateHandler

Rule.h File Reference

Header file for the rule class. More...

#include "ActivMiddleware/Misc/StlHelper.h"
#include "ActivContentPlatform/ActivFeedCommon/FieldIds.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/External.h"
#include <string>

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::Feed

Classes

class | Activ::ContentPlatform::Feed::Rule
Rule class. More...
class | Activ::ContentPlatform::Feed::Rule::CloseFields
Close fields class. More...
class | Activ::ContentPlatform::Feed::Rule::CopyToFields
Copy To fields class. More...
class | Activ::ContentPlatform::Feed::Rule::HighFields
High fields class. More...
class | Activ::ContentPlatform::Feed::Rule::LowFields
Low fields class. More...
class | Activ::ContentPlatform::Feed::Rule::OpenFields
Open fields class. More...
class | Activ::ContentPlatform::Feed::Rule::PriceFields
Price fields class. More...
class | Activ::ContentPlatform::Feed::Rule::VolumeFields
Volume fields class. More...

Typedefs

typedef hash_map< FieldId, Rule > | Activ::ContentPlatform::Feed::RuleMap
The rule map type definition.

Detailed Description

Header file for the rule class.

Log

Definition in file Rule.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedTableTemplateHandler

TableSpecification.h File Reference

Header file for a table specification. More...

#include "ActivMiddleware/ActivDatabase/Definitions.h"
#include "ActivContentPlatform/ActivFeedCommon/TableNumbers.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/Field.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/External.h"
#include <string>
#include <vector>

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::Feed

Classes

class | Activ::ContentPlatform::Feed::TableSpecification

Typedefs

typedef std::vector
< TableSpecification > 		Activ::ContentPlatform::Feed::TableSpecificationList

Detailed Description

Header file for a table specification.

Log

Definition in file TableSpecification.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedTableTemplateHandler

TableTemplate.h File Reference

Header file for the table template class. More...

#include "ActivContentPlatform/ActivFeedCommon/TableNumbers.h"
#include "ActivContentPlatform/ActivFeedCommon/TableTypes.h"
#include "ActivContentPlatform/ActivFeedCommon/TableResetTypes.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/External.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/Field.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/Index.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/Reset.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/Rule.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/UniversalFieldList.h"
#include "xercesc/dom/DOMNode.hpp"
#include <vector>

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::Feed

Classes

class | Activ::ContentPlatform::Feed::TableTemplate
Table template class. More...
class | Activ::ContentPlatform::Feed::TableTemplate::ConstCopyOnResetIterator
Const CopyOnReset iterator class. More...
class | Activ::ContentPlatform::Feed::TableTemplate::ConstFieldIterator
Const field iterator class. More...
class | Activ::ContentPlatform::Feed::TableTemplate::ConstIndexIterator
Const index iterator class. More...
class | Activ::ContentPlatform::Feed::TableTemplate::ConstRuleIterator
Const rule iterator class. More...
class | Activ::ContentPlatform::Feed::TableTemplate::ConstUndefineOnResetIterator
Const UndefineOnReset iterator class. More...
class | Activ::ContentPlatform::Feed::TableTemplate::FieldSpecification
Field specification class. More...
class | Activ::ContentPlatform::Feed::TableTemplate::Specification
Specification class. More...
class | Activ::ContentPlatform::Feed::TableTemplateAddition
Table template addition class. More...

Detailed Description

Header file for the table template class.

Log

Definition in file TableTemplate.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedTableTemplateHandler

TableTemplateException.h File Reference

Header file for the table template exception class. More...

#include "ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/External.h"
#include "ActivMiddleware/ActivBase/ActivBase.h"
#include "ActivMiddleware/ActivBase/Exception.h"

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::Feed

Classes

class | Activ::ContentPlatform::Feed::TableTemplateException
Table template exception. More...

Defines

#define | ACTIV_THROW_TABLE_TEMPLATE_EXCEPTION_IF(statusCode, operator, expression, error)
Throw result if result of expression tests true using operator against statusCode.
#define | ACTIV_THROW_TABLE_TEMPLATE_EXCEPTION_IF_AND_IF(statusCode1, statusCode2, operator, expression, error)
Throw result if result of expression tests true using operator against statusCode1 and statusCode2.

Detailed Description

Header file for the table template exception class.

Log

Definition in file TableTemplateException.h.

Define Documentation

#define ACTIV_THROW_TABLE_TEMPLATE_EXCEPTION_IF | ( | statusCode,
 |  | operator,
 |  | expression,
 |  | error | )

Value:

if (true)                                                                                               \
    {                                                                                                       \
        const Activ::StatusCode thisIsTheResultOfTheCall = expression;                                      \
        if (statusCode operator thisIsTheResultOfTheCall)                                                   \
            ACTIV_THROW(Activ::ContentPlatform::Feed::TableTemplateException, error);                                           \
    }                                                                                                       \
    else
Throw result if result of expression tests true using operator against statusCode.

Definition at line 29 of file TableTemplateException.h.

#define ACTIV_THROW_TABLE_TEMPLATE_EXCEPTION_IF_AND_IF | ( | statusCode1,
 |  | statusCode2,
 |  | operator,
 |  | expression,
 |  | error | )

Value:

if (true)                                                                                                       \
    {                                                                                                               \
        const Activ::StatusCode thisIsTheResultOfTheCall = expression;                                              \
        if ((statusCode1 operator thisIsTheResultOfTheCall) && (statusCode2 operator thisIsTheResultOfTheCall))     \
            ACTIV_THROW(Activ::ContentPlatform::Feed::TableTemplateException, error);                                               \
    }                                                                                                               \
    else
Throw result if result of expression tests true using operator against statusCode1 and statusCode2.

Definition at line 41 of file TableTemplateException.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedTableTemplateHandler

TableTemplateList.h File Reference

Header file for the table template list class. More...

#include "ActivContentPlatform/ActivFeedCommon/ActivFeed.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/External.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/TableTemplate.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/UniversalFieldList.h"

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::Feed

Classes

class | Activ::ContentPlatform::Feed::TableTemplateList
Table template list class. More...
class | Activ::ContentPlatform::Feed::TableTemplateList::ConstIterator
Const iterator class. More...
class | Activ::ContentPlatform::Feed::TableTemplateList::Settings
Settings. More...
class | Activ::ContentPlatform::Feed::TableTemplateList::TableTemplateSpecification
Table template specification class. More...

Detailed Description

Header file for the table template list class.

Log

Definition in file TableTemplateList.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedTableTemplateHandler

UniversalFieldList.h File Reference

Header file for the universal field list class. More...

#include "ActivMiddleware/ActivBase/DirectoryWalker.h"
#include "ActivMiddleware/Misc/StlHelper.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/External.h"
#include "ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/Field.h"

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::ContentPlatform
namespace | Activ::ContentPlatform::Feed

Classes

class | Activ::ContentPlatform::Feed::UniversalFieldList
Universal field list class. More...
class | Activ::ContentPlatform::Feed::UniversalFieldList::ConstIterator
Const iterator class. More...

Typedefs

typedef std::list< std::string > | Activ::ContentPlatform::Feed::PathList
The list of paths.
typedef std::list< ServiceHandle > | Activ::ContentPlatform::Feed::ServiceHandleList
The list of service handles.
typedef std::list< ServiceId > | Activ::ContentPlatform::Feed::ServiceIdList
The list of service ids.
typedef Field | Activ::ContentPlatform::Feed::UniversalField
The universal field type definition.
typedef std::vector
< UniversalField::Specification > 		Activ::ContentPlatform::Feed::UniversalFieldSpecificationList
The universal field specification list type definition.

Detailed Description

Header file for the universal field list class.

Log

Definition in file UniversalFieldList.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware

Activ.h File Reference

Main header file, sets up environment and various useful macros. More...

#include "Config/Config.h"
#include "BasicTypes.h"
#include "FormatSpecifiers.h"
#include "StatusCodes.h"
#include "Optimizations.h"
#include "boost/noncopyable.hpp"

Go to the source code of this file.

Defines

#define | ACTIV_ARRAY_SIZE(a) (sizeof((a)) / sizeof((a)[0]))
Calculate the number of elements in an array.
#define | ACTIV_DEBUG_ONLY(a)
Debug macros.
#define | ACTIV_DECLARE_CONSTANT_ELEMENT_1(type, a, b) const type a = ____##a;
Declare a constanst value from a hidden enumeration value declared with ACTIV_DECLARE_HIDDEN_ELEMENT_1.
#define | ACTIV_DECLARE_ELEMENT_1_WITH_COMMA(a, b) a,
Retrieve the first element of a macro pair.
#define | ACTIV_DECLARE_ELEMENT_2_WITH_COMMA(a, b) b,
Retrieve the second element of a macro pair.
#define | ACTIV_DECLARE_HIDDEN_ELEMENT_1(a, b) ____##a,
Retrieve the first element of a macro pair and prepend with 4 underscores.
#define | ACTIV_DECLARE_HIDDEN_ELEMENT_2(a, b) ____##b,
Retrieve the second element of a macro pair and prepend with 4 underscores.
#define | ACTIV_DECLARE_HIDDEN_VALUE_WITH_COMMA(a) ____##a,
Retrieve the macro parameter and prepend with 4 underscores.
#define | ACTIV_DECLARE_STATIC_CONSTANT_ELEMENT_1(type, a, b) static const type a = ____##a;
#define | ACTIV_DECLARE_VALUE_WITH_COMMA(a) a,
Retrieve the macro parameter.
#define | ACTIV_DO_STRINGIZE(a) #a
Converts parameter a to a string after macro replacement on a has been performed.
#define | ACTIV_ENHANCED_DEBUG_ONLY(a)
Enhanced debug macros.
#define | ACTIV_FIELD_OFFSET(type, field) (reinterpret_cast<size_t>(&(reinterpret_cast<type *>(0)->*(&type::field))))
Retrieves the offset of a member from the beginning of its parent structure.
#define | ACTIV_FIELD_SIZE(type, field) (sizeof(reinterpret_cast<type *>(0)->*(&type::field)))
Retrieves the size of a member in its parent structure.
#define | ACTIV_MAKE_VERSION_VALUE(a, b, c, d) (((a) << 24) | ((b) << 16) | ((c) << 8) | (d))
Macro to make an ACTIV-style a.b.c.d version value.
#define | ACTIV_MIDDLEWARE_VERSION_STRING "99.99.99.99"
Current ActivMiddleware version string.
#define | ACTIV_MIDDLEWARE_VERSION_VALUE ACTIV_MAKE_VERSION_VALUE(99, 99, 99, 99)
Current ActivMiddleware version value.
#define | ACTIV_RELEASE_ONLY(a) a
Release macros.
#define | ACTIV_STRINGIZE(a) ACTIV_DO_STRINGIZE(a)
#define | ACTIV_STRINGIZE_WITH_COMMA(a) ACTIV_DO_STRINGIZE(a),

Detailed Description

Main header file, sets up environment and various useful macros.

Log

Definition in file Activ.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware

BasicTypes.h File Reference

Basic types (as per C99 <stdint.h> standard) and various helper functions. More...

#include "boost/cstdint.hpp"
#include "boost/integer_traits.hpp"
#include "boost/static_assert.hpp"
#include "boost/type_traits.hpp"
#include "boost/call_traits.hpp"
#include <cmath>
#include <string>
#include <sstream>
#include <functional>

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::Binary< T, N, B >
Convert a binary representation of a number. More...
class | Activ::Binary< T, 0, B >
class | Activ::Greater< T, RHS >
Greater than comparison object where the right hand side is constant. More...
class | Activ::GreaterImpl< T, RHS, IS_RHS_MAXIMAL >
class | Activ::GreaterImpl< T, RHS, true >
class | Activ::LengthToIntegralType< N, S >
Template to determine ACTIV integral type from length of integral in bytes. More...
class | Activ::LengthToIntegralType< 1, false >
class | Activ::LengthToIntegralType< 1, true >
class | Activ::LengthToIntegralType< 2, false >
class | Activ::LengthToIntegralType< 2, true >
class | Activ::LengthToIntegralType< 4, false >
class | Activ::LengthToIntegralType< 4, true >
class | Activ::LengthToIntegralType< 8, false >
class | Activ::LengthToIntegralType< 8, true >
class | Activ::Less< T, RHS >
Less than comparison object where the right hand side is constant. More...
class | Activ::LessImpl< T, RHS, IS_RHS_MINIMAL >
class | Activ::LessImpl< T, RHS, true >
class | Activ::TypeToIntegralType< T >
Template to determine ACTIV integral type from an arbitrary type, if possible. More...

Defines

#define | BYTE_MAX UINT8_MAX
#define | INT16_MAX 0x7FFF
#define | INT16_MIN (-(INT16_MAX) - 1)
#define | INT32_MAX 0x7FFFFFFF
#define | INT32_MIN (-(INT32_MAX) - 1)
#define | INT64_MAX INT64_C(0x7FFFFFFFFFFFFFFF)
#define | INT64_MIN (-(INT64_MAX) - 1)
#define | INT8_MAX 0x7F
#define | INT8_MIN (-(INT8_MAX) - 1)
#define | INT_FAST16_MAX 0x7FFF
#define | INT_FAST16_MIN (-(INT16_MAX) - 1)
#define | INT_FAST32_MAX 0x7FFFFFFF
#define | INT_FAST32_MIN (-(INT32_MAX) - 1)
#define | INT_FAST64_MAX INT64_C(0x7FFFFFFFFFFFFFFF)
#define | INT_FAST64_MIN (-(INT64_MAX) - 1)
#define | INT_FAST8_MAX 0x7F
#define | INT_FAST8_MIN (-(INT8_MAX) - 1)
#define | INT_LEAST16_MAX 0x7FFF
#define | INT_LEAST16_MIN (-(INT16_MAX) - 1)
#define | INT_LEAST32_MAX 0x7FFFFFFF
#define | INT_LEAST32_MIN (-(INT32_MAX) - 1)
#define | INT_LEAST64_MAX INT64_C(0x7FFFFFFFFFFFFFFF)
#define | INT_LEAST64_MIN (-(INT64_MAX) - 1)
#define | INT_LEAST8_MAX 0x7F
#define | INT_LEAST8_MIN (-(INT8_MAX) - 1)
#define | INTMAX_MAX INT64_C(0x7FFFFFFFFFFFFFFF)
#define | INTMAX_MIN (-(INT64_MAX) - 1)
#define | UINT16_MAX 0xFFFF
#define | UINT32_MAX 0xFFFFFFFF
#define | UINT64_MAX UINT64_C(0xFFFFFFFFFFFFFFFF)
#define | UINT8_MAX 0xFF
#define | UINT_FAST16_MAX 0xFFFF
#define | UINT_FAST32_MAX 0xFFFFFFFF
#define | UINT_FAST64_MAX UINT64_C(0xFFFFFFFFFFFFFFFF)
#define | UINT_FAST8_MAX 0xFF
#define | UINT_LEAST16_MAX 0xFFFF
#define | UINT_LEAST32_MAX 0xFFFFFFFF
#define | UINT_LEAST64_MAX UINT64_C(0xFFFFFFFFFFFFFFFF)
#define | UINT_LEAST8_MAX 0xFF
#define | UINTMAX_MAX UINT64_C(0xFFFFFFFFFFFFFFFF)

Typedefs

typedef uint8_t | Activ::byte_t
typedef uint32_t | Activ::TimeoutPeriod

Functions

template<typename T>
T | Activ::BigEndianToHostOrder (const T value)
Convert a value from big endian byte order to local endian.
int64_t | Activ::ByteSwap (const int64_t value)
Reverse the order of bytes in a signed 64 bit value.
uint64_t | Activ::ByteSwap (const uint64_t value)
Reverse the order of bytes in an unsigned 64 bit value.
int32_t | Activ::ByteSwap (const int32_t value)
Reverse the order of bytes in a signed 32 bit value.
uint32_t | Activ::ByteSwap (const uint32_t value)
Reverse the order of bytes in an unsigned 32 bit value.
int16_t | Activ::ByteSwap (const int16_t value)
Reverse the order of bytes in a signed 16 bit value.
uint16_t | Activ::ByteSwap (const uint16_t value)
Reverse the order of bytes in an unsigned 16 bit value.
int8_t | Activ::ByteSwap (const int8_t value)
Return provided value. Here so endian template functions support all built-in integral types.
uint8_t | Activ::ByteSwap (const uint8_t value)
Return provided value. Here so endian template functions support all built-in integral types.
double | Activ::GetAbsolute (const double value)
template<typename T>
T | Activ::GetAbsolute (const T value)
Return the absolute value of the parameter.
uint32_t | Activ::GetHigh32BitValue (uint64_t value)
Get the high 32 bits of a 64 bit value.
uint32_t | Activ::GetLow32BitValue (uint64_t value)
Get the low 32 bits of a 64 bit value.
template<typename T>
boost::call_traits< T >::param_type | Activ::GetMaximum (typename boost::call_traits< T >::param_type a, typename boost::call_traits< T >::param_type b)
Get maximum of two values.
template<typename T>
boost::call_traits< T >::param_type | Activ::GetMinimum (typename boost::call_traits< T >::param_type a, typename boost::call_traits< T >::param_type b)
Get minimum of two values.
template<typename T>
T | Activ::HostToBigEndianOrder (const T value)
Convert a value to big endian byte order from local endian.
template<typename T>
T | Activ::HostToLittleEndianOrder (const T value)
Convert a value to little endian byte order from local endian.
template<typename T>
T | Activ::HostToNetworkOrder (const T value)
Convert a value to network byte order from local endian.
template<typename T>
T | Activ::LittleEndianToHostOrder (const T value)
Convert a value from little endian byte order to local endian.
template<typename A, typename B>
uint64_t | Activ::MakeUnsigned64BitValue (A high, B low)
Make an unsigned 64 bit value.
template<typename T>
T | Activ::NetworkToHostOrder (const T value)
Convert a value from network byte order to local endian.
bool | Activ::StringToType (const std::string &str, std::string &target)
template<typename T>
bool | Activ::StringToType (const std::string &str, T &t)
Convert a string to a basic type.
template<typename T>
void | Activ::SwapValues (T &lhs, T &rhs)
Swap two values.
std::string | Activ::TypeToString (const std::string &str)
std::string | Activ::TypeToString (const byte_t &c)
std::string | Activ::TypeToString (const char &c)
template<typename T>
std::string | Activ::TypeToString (const T &t)
Convert a type to a string.

Detailed Description

Basic types (as per C99 <stdint.h> standard) and various helper functions.

Log

Definition in file BasicTypes.h.

Generated on Wed Oct 8 14:01:51 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware

FormatSpecifiers.h File Reference

Platform independant c-style printf format specifiers. More...

Go to the source code of this file.

Defines

#define | PRId16 "d"
#define | PRId32 "d"
#define | PRId64 __PRI64_PREFIX "d"
#define | PRId8 "d"
#define | PRIdFAST16 "d"
#define | PRIdFAST32 "d"
#define | PRIdFAST64 __PRI64_PREFIX "d"
#define | PRIdFAST8 "d"
#define | PRIdLEAST16 "d"
#define | PRIdLEAST32 "d"
#define | PRIdLEAST64 __PRI64_PREFIX "d"
#define | PRIdLEAST8 "d"
#define | PRIdSIZE __SIZE_T_PREFIX "d"
#define | PRIi16 "i"
#define | PRIi32 "i"
#define | PRIi64 __PRI64_PREFIX "i"
#define | PRIi8 "i"
#define | PRIiFAST16 "i"
#define | PRIiFAST32 "i"
#define | PRIiFAST64 __PRI64_PREFIX "i"
#define | PRIiFAST8 "i"
#define | PRIiLEAST16 "i"
#define | PRIiLEAST32 "i"
#define | PRIiLEAST64 __PRI64_PREFIX "i"
#define | PRIiLEAST8 "i"
#define | PRIiSIZE __SIZE_T_PREFIX "i"
#define | PRIo16 "o"
#define | PRIo32 "o"
#define | PRIo64 __PRI64_PREFIX "o"
#define | PRIo8 "o"
#define | PRIoFAST16 "o"
#define | PRIoFAST32 "o"
#define | PRIoFAST64 __PRI64_PREFIX "o"
#define | PRIoFAST8 "o"
#define | PRIoLEAST16 "o"
#define | PRIoLEAST32 "o"
#define | PRIoLEAST64 __PRI64_PREFIX "o"
#define | PRIoLEAST8 "o"
#define | PRIoSIZE __SIZE_T_PREFIX "o"
#define | PRIu16 "u"
#define | PRIu32 "u"
#define | PRIu64 __PRI64_PREFIX "u"
#define | PRIu8 "u"
#define | PRIuFAST16 "u"
#define | PRIuFAST32 "u"
#define | PRIuFAST64 __PRI64_PREFIX "u"
#define | PRIuFAST8 "u"
#define | PRIuLEAST16 "u"
#define | PRIuLEAST32 "u"
#define | PRIuLEAST64 __PRI64_PREFIX "u"
#define | PRIuLEAST8 "u"
#define | PRIuSIZE __SIZE_T_PREFIX "u"
#define | PRIX16 "X"
#define | PRIx16 "x"
#define | PRIX32 "X"
#define | PRIx32 "x"
#define | PRIX64 __PRI64_PREFIX "X"
#define | PRIx64 __PRI64_PREFIX "x"
#define | PRIX8 "X"
#define | PRIx8 "x"
#define | PRIXFAST16 "X"
#define | PRIxFAST16 "x"
#define | PRIXFAST32 "X"
#define | PRIxFAST32 "x"
#define | PRIXFAST64 __PRI64_PREFIX "X"
#define | PRIxFAST64 __PRI64_PREFIX "x"
#define | PRIXFAST8 "X"
#define | PRIxFAST8 "x"
#define | PRIXLEAST16 "X"
#define | PRIxLEAST16 "x"
#define | PRIXLEAST32 "X"
#define | PRIxLEAST32 "x"
#define | PRIXLEAST64 __PRI64_PREFIX "X"
#define | PRIxLEAST64 __PRI64_PREFIX "x"
#define | PRIXLEAST8 "X"
#define | PRIxLEAST8 "x"
#define | PRIXSIZE __SIZE_T_PREFIX "X"
#define | PRIxSIZE __SIZE_T_PREFIX "x"
#define | SCNd16 "hd"
#define | SCNd32 "d"
#define | SCNd64 __PRI64_PREFIX "d"
#define | SCNdFAST16 __PRIPTR_PREFIX "d"
#define | SCNdFAST32 __PRIPTR_PREFIX "d"
#define | SCNdFAST64 __PRI64_PREFIX "d"
#define | SCNdLEAST16 "hd"
#define | SCNdLEAST32 "d"
#define | SCNdLEAST64 __PRI64_PREFIX "d"
#define | SCNdSIZE __SIZE_T_PREFIX "d"
#define | SCNi16 "hi"
#define | SCNi32 "i"
#define | SCNi64 __PRI64_PREFIX "i"
#define | SCNiFAST16 __PRIPTR_PREFIX "i"
#define | SCNiFAST32 __PRIPTR_PREFIX "i"
#define | SCNiFAST64 __PRI64_PREFIX "i"
#define | SCNiLEAST16 "hi"
#define | SCNiLEAST32 "i"
#define | SCNiLEAST64 __PRI64_PREFIX "i"
#define | SCNiSIZE __SIZE_T_PREFIX "i"
#define | SCNo16 "ho"
#define | SCNo32 "o"
#define | SCNo64 __PRI64_PREFIX "o"
#define | SCNoFAST16 __PRIPTR_PREFIX "o"
#define | SCNoFAST32 __PRIPTR_PREFIX "o"
#define | SCNoFAST64 __PRI64_PREFIX "o"
#define | SCNoLEAST16 "ho"
#define | SCNoLEAST32 "o"
#define | SCNoLEAST64 __PRI64_PREFIX "o"
#define | SCNoSIZE __SIZE_T_PREFIX "o"
#define | SCNu16 "hu"
#define | SCNu32 "u"
#define | SCNu64 __PRI64_PREFIX "u"
#define | SCNuFAST16 __PRIPTR_PREFIX "u"
#define | SCNuFAST32 __PRIPTR_PREFIX "u"
#define | SCNuFAST64 __PRI64_PREFIX "u"
#define | SCNuLEAST16 "hu"
#define | SCNuLEAST32 "u"
#define | SCNuLEAST64 __PRI64_PREFIX "u"
#define | SCNuSIZE __SIZE_T_PREFIX "u"
#define | SCNx16 "hx"
#define | SCNx32 "x"
#define | SCNx64 __PRI64_PREFIX "x"
#define | SCNxFAST16 __PRIPTR_PREFIX "x"
#define | SCNxFAST32 __PRIPTR_PREFIX "x"
#define | SCNxFAST64 __PRI64_PREFIX "x"
#define | SCNxLEAST16 "hx"
#define | SCNxLEAST32 "x"
#define | SCNxLEAST64 __PRI64_PREFIX "x"
#define | SCNxSIZE __SIZE_T_PREFIX "x"

Detailed Description

Platform independant c-style printf format specifiers.

Log

Definition in file FormatSpecifiers.h.

Generated on Wed Oct 8 14:01:51 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware

StatusCodes.h File Reference

Status codes and helper macros. More...

Go to the source code of this file.

Namespaces

namespace | Activ

Defines

#define | ACTIV_BREAK_IF(statusCode, operator, expression)
Continue if result of expression tests true using operator against statusCode.
#define | ACTIV_BREAK_IF_AND_IF(statusCode1, statusCode2, operator, expression)
Continue if result of expression tests true using operator against statusCode1 and statusCode2.
#define | ACTIV_BREAK_IF_OR_IF(statusCode1, statusCode2, operator, expression)
Continue if result of expression tests true using operator against statusCode1 or statusCode2.
#define | ACTIV_CONTINUE_IF(statusCode, operator, expression)
Continue if result of expression tests true using operator against statusCode.
#define | ACTIV_CONTINUE_IF_AND_IF(statusCode1, statusCode2, operator, expression)
Continue if result of expression tests true using operator against statusCode1 and statusCode2.
#define | ACTIV_CONTINUE_IF_OR_IF(statusCode1, statusCode2, operator, expression)
Continue if result of expression tests true using operator against statusCode1 or statusCode2.
#define | ACTIV_DECLARE_STATUS_CODE(value, id, name) const StatusCode id = value;
Macro to declare constant status code.
#define | ACTIV_RETURN_FALSE_IF(statusCode, operator, expression) ACTIV_RETURN_VALUE_IF(statusCode, operator, expression, false)
Return false if result of expression tests true using operator against statusCode.
#define | ACTIV_RETURN_FALSE_IF_AND_IF(statusCode1, statusCode2, operator, expression) ACTIV_RETURN_VALUE_IF_AND_IF(statusCode1, statusCode2, operator, expression, false)
Return false if result of expression tests true using operator against statusCode1 and statusCode2.
#define | ACTIV_RETURN_FALSE_IF_OR_IF(statusCode1, statusCode2, operator, expression) ACTIV_RETURN_VALUE_IF_OR_IF(statusCode1, statusCode2, operator, expression, false)
Return false if result of expression tests true using operator against statusCode1 or statusCode2.
#define | ACTIV_RETURN_IF(statusCode, operator, expression)
Return if result of expression tests true using operator against statusCode.
#define | ACTIV_RETURN_IF_AND_IF(statusCode1, statusCode2, operator, expression)
Return if result of expression tests true using operator against statusCode1 and statusCode2.
#define | ACTIV_RETURN_IF_OR_IF(statusCode1, statusCode2, operator, expression)
Return if result of expression tests true using operator against statusCode1 or statusCode2.
#define | ACTIV_RETURN_RESULT_IF(statusCode, operator, expression)
Return result if result of expression tests true using operator against statusCode.
#define | ACTIV_RETURN_RESULT_IF_AND_IF(statusCode1, statusCode2, operator, expression)
Return result if result of expression tests true using operator against statusCode1 and statusCode2.
#define | ACTIV_RETURN_RESULT_IF_OR_IF(statusCode1, statusCode2, operator, expression)
Return result if result of expression tests true using operator against statusCode1 or statusCode2.
#define | ACTIV_RETURN_TRUE_IF(statusCode, operator, expression) ACTIV_RETURN_VALUE_IF(statusCode, operator, expression, true)
Return true if result of expression tests true using operator against statusCode.
#define | ACTIV_RETURN_TRUE_IF_AND_IF(statusCode1, statusCode2, operator, expression) ACTIV_RETURN_VALUE_IF_AND_IF(statusCode1, statusCode2, operator, expression, true)
Return true if result of expression tests true using operator against statusCode1 and statusCode2.
#define | ACTIV_RETURN_TRUE_IF_OR_IF(statusCode1, statusCode2, operator, expression) ACTIV_RETURN_VALUE_IF_OR_IF(statusCode1, statusCode2, operator, expression, true)
Return true if result of expression tests true using operator against statusCode1 or statusCode2.
#define | ACTIV_RETURN_VALUE_IF(statusCode, operator, expression, value)
Return a value if result of expression tests true using operator against statusCode.
#define | ACTIV_RETURN_VALUE_IF_AND_IF(statusCode1, statusCode2, operator, expression, value)
Return a value if result of expression tests true using operator against statusCode1 and statusCode2.
#define | ACTIV_RETURN_VALUE_IF_OR_IF(statusCode1, statusCode2, operator, expression, value)
Return a value if result of expression tests true using operator against statusCode1 or statusCode2.
#define | ACTIV_STATUS_CODE_LIST(d)
The list of possible status codes and their string representations.

Typedefs

typedef byte_t | Activ::StatusCode
Status code type.

Variables

const StatusCode | Activ::STATUS_CODE_ACCESS_DENIED = 10
const StatusCode | Activ::STATUS_CODE_ADDRESS_NOT_AVAILABLE = 67
const StatusCode | Activ::STATUS_CODE_ALREADY_CONNECTED = 44
const StatusCode | Activ::STATUS_CODE_ALREADY_DEFINED = 45
const StatusCode | Activ::STATUS_CODE_ALREADY_EXISTS = 47
const StatusCode | Activ::STATUS_CODE_ALREADY_LISTENING = 50
const StatusCode | Activ::STATUS_CODE_ALREADY_OPEN = 17
const StatusCode | Activ::STATUS_CODE_BUFFER_OVERFLOW = 11
const StatusCode | Activ::STATUS_CODE_BUFFER_UNDERRUN = 12
const StatusCode | Activ::STATUS_CODE_BUSY = 62
const StatusCode | Activ::STATUS_CODE_CONNECTION_REFUSED = 52
const StatusCode | Activ::STATUS_CODE_DELETED = 38
const StatusCode | Activ::STATUS_CODE_DISABLED = 18
const StatusCode | Activ::STATUS_CODE_EMPTY = 39
const StatusCode | Activ::STATUS_CODE_END_OF_DATA = 49
const StatusCode | Activ::STATUS_CODE_EXIT = 2
const StatusCode | Activ::STATUS_CODE_EXPIRED = 63
const StatusCode | Activ::STATUS_CODE_FAILURE = 1
const StatusCode | Activ::STATUS_CODE_FULL = 40
const StatusCode | Activ::STATUS_CODE_HEAP_EMPTY = 41
const StatusCode | Activ::STATUS_CODE_HOST_NOT_FOUND = 57
const StatusCode | Activ::STATUS_CODE_HOST_UNREACHABLE = 64
const StatusCode | Activ::STATUS_CODE_IGNORED = 54
const StatusCode | Activ::STATUS_CODE_IN_USE = 48
const StatusCode | Activ::STATUS_CODE_INSUFFICIENT_RESOURCES = 74
const StatusCode | Activ::STATUS_CODE_INTERRUPTED = 53
const StatusCode | Activ::STATUS_CODE_INVALID_ADDRESS = 73
const StatusCode | Activ::STATUS_CODE_INVALID_ENDPOINT = 19
const StatusCode | Activ::STATUS_CODE_INVALID_ENDPOINT_PORT = 56
const StatusCode | Activ::STATUS_CODE_INVALID_FIELD = 29
const StatusCode | Activ::STATUS_CODE_INVALID_FIELD_TYPE = 28
const StatusCode | Activ::STATUS_CODE_INVALID_FORMAT = 25
const StatusCode | Activ::STATUS_CODE_INVALID_HANDLE = 72
const StatusCode | Activ::STATUS_CODE_INVALID_INDEX = 26
const StatusCode | Activ::STATUS_CODE_INVALID_KEY = 27
const StatusCode | Activ::STATUS_CODE_INVALID_LENGTH = 22
const StatusCode | Activ::STATUS_CODE_INVALID_NAME = 24
const StatusCode | Activ::STATUS_CODE_INVALID_PARAMETER = 23
const StatusCode | Activ::STATUS_CODE_INVALID_PASSWORD = 59
const StatusCode | Activ::STATUS_CODE_INVALID_PORT = 20
const StatusCode | Activ::STATUS_CODE_INVALID_PROTOCOL = 32
const StatusCode | Activ::STATUS_CODE_INVALID_RECORD = 30
const StatusCode | Activ::STATUS_CODE_INVALID_SERVICE_ID = 70
const StatusCode | Activ::STATUS_CODE_INVALID_TABLE = 31
const StatusCode | Activ::STATUS_CODE_INVALID_URL = 60
const StatusCode | Activ::STATUS_CODE_INVALID_USER = 58
const StatusCode | Activ::STATUS_CODE_INVALID_VERSION = 21
const StatusCode | Activ::STATUS_CODE_MISMATCH = 35
const StatusCode | Activ::STATUS_CODE_MISSING_ARGS = 15
const StatusCode | Activ::STATUS_CODE_NETWORK_UNREACHABLE = 65
const StatusCode | Activ::STATUS_CODE_NO_PRIMARY_KEY = 34
const StatusCode | Activ::STATUS_CODE_NO_SUCH_DEVICE = 68
const StatusCode | Activ::STATUS_CODE_NOT_A_DIRECTORY = 61
const StatusCode | Activ::STATUS_CODE_NOT_CONNECTED = 43
const StatusCode | Activ::STATUS_CODE_NOT_CREATED = 46
const StatusCode | Activ::STATUS_CODE_NOT_FOUND = 6
const StatusCode | Activ::STATUS_CODE_NOT_INITIALIZED = 14
const StatusCode | Activ::STATUS_CODE_NOT_LICENSED = 66
const StatusCode | Activ::STATUS_CODE_NOT_OPEN = 16
const StatusCode | Activ::STATUS_CODE_NOT_SHAREABLE = 51
const StatusCode | Activ::STATUS_CODE_NOT_SUPPORTED = 13
const StatusCode | Activ::STATUS_CODE_OUT_OF_RANGE = 36
const StatusCode | Activ::STATUS_CODE_PATH_NOT_FOUND = 71
const StatusCode | Activ::STATUS_CODE_PENDING = 9
const StatusCode | Activ::STATUS_CODE_QUOTA_EXCEEDED = 69
const StatusCode | Activ::STATUS_CODE_SHUTTING_DOWN = 3
const StatusCode | Activ::STATUS_CODE_STALE = 37
const StatusCode | Activ::STATUS_CODE_SUCCESS = 0
Status code constants.
const StatusCode | Activ::STATUS_CODE_TIMEOUT = 7
const StatusCode | Activ::STATUS_CODE_TOO_MANY_REQUESTS = 55
const StatusCode | Activ::STATUS_CODE_UNCHANGED = 8
const StatusCode | Activ::STATUS_CODE_UNDEFINED_FIELD = 33
const StatusCode | Activ::STATUS_CODE_UNHANDLED_EXCEPTION = 4
const StatusCode | Activ::STATUS_CODE_UNKNOWN = 255
const StatusCode | Activ::STATUS_CODE_UNRECOGNIZED = 5
const StatusCode | Activ::STATUS_CODE_WRONG_STATE = 42

Detailed Description

Status codes and helper macros.

Log

Definition in file StatusCodes.h.

Define Documentation

#define ACTIV_BREAK_IF | ( | statusCode,
 |  | operator,
 |  | expression | )

Value:

if (true)                                                                                                       \
    {                                                                                                               \
        if (expression operator statusCode)                                                                         \
            break;                                                                                                  \
    }                                                                                                               \
    else
Continue if result of expression tests true using operator against statusCode.

Definition at line 159 of file StatusCodes.h.

#define ACTIV_BREAK_IF_AND_IF | ( | statusCode1,
 |  | statusCode2,
 |  | operator,
 |  | expression | )

Value:

if (true)                                                                                                       \
    {                                                                                                               \
        const Activ::StatusCode thisIsTheResultOfTheCall = expression;                                              \
        if ((thisIsTheResultOfTheCall operator statusCode1) && (thisIsTheResultOfTheCall operator statusCode2))     \
            break;                                                                                                  \
    }                                                                                                               \
    else
Continue if result of expression tests true using operator against statusCode1 and statusCode2.

Definition at line 170 of file StatusCodes.h.

#define ACTIV_BREAK_IF_OR_IF | ( | statusCode1,
 |  | statusCode2,
 |  | operator,
 |  | expression | )

Value:

if (true)                                                                                                       \
    {                                                                                                               \
        const Activ::StatusCode thisIsTheResultOfTheCall = expression;                                              \
        if ((thisIsTheResultOfTheCall operator statusCode1) || (thisIsTheResultOfTheCall operator statusCode2))     \
            break;                                                                                                  \
    }                                                                                                               \
    else
Continue if result of expression tests true using operator against statusCode1 or statusCode2.

Definition at line 182 of file StatusCodes.h.

#define ACTIV_CONTINUE_IF | ( | statusCode,
 |  | operator,
 |  | expression | )

Value:

if (true)                                                                                                       \
    {                                                                                                               \
        if (expression operator statusCode)                                                                         \
            continue;                                                                                               \
    }                                                                                                               \
    else
Continue if result of expression tests true using operator against statusCode.

Definition at line 124 of file StatusCodes.h.

#define ACTIV_CONTINUE_IF_AND_IF | ( | statusCode1,
 |  | statusCode2,
 |  | operator,
 |  | expression | )

Value:

if (true)                                                                                                       \
    {                                                                                                               \
        const Activ::StatusCode thisIsTheResultOfTheCall = expression;                                              \
        if ((thisIsTheResultOfTheCall operator statusCode1) && (thisIsTheResultOfTheCall operator statusCode2))     \
            continue;                                                                                               \
    }                                                                                                               \
    else
Continue if result of expression tests true using operator against statusCode1 and statusCode2.

Definition at line 135 of file StatusCodes.h.

#define ACTIV_CONTINUE_IF_OR_IF | ( | statusCode1,
 |  | statusCode2,
 |  | operator,
 |  | expression | )

Value:

if (true)                                                                                                       \
    {                                                                                                               \
        const Activ::StatusCode thisIsTheResultOfTheCall = expression;                                              \
        if ((thisIsTheResultOfTheCall operator statusCode1) || (thisIsTheResultOfTheCall operator statusCode2))     \
            continue;                                                                                               \
    }                                                                                                               \
    else
Continue if result of expression tests true using operator against statusCode1 or statusCode2.

Definition at line 147 of file StatusCodes.h.

#define ACTIV_RETURN_IF | ( | statusCode,
 |  | operator,
 |  | expression | )

Value:

if (true)                                                                                                       \
    {                                                                                                               \
        if (expression operator statusCode)                                                                         \
            return;                                                                                                 \
    }                                                                                                               \
    else
Return if result of expression tests true using operator against statusCode.

Definition at line 18 of file StatusCodes.h.

#define ACTIV_RETURN_IF_AND_IF | ( | statusCode1,
 |  | statusCode2,
 |  | operator,
 |  | expression | )

Value:

if (true)                                                                                                       \
    {                                                                                                               \
        const Activ::StatusCode thisIsTheResultOfTheCall = expression;                                              \
        if ((thisIsTheResultOfTheCall operator statusCode1) && (thisIsTheResultOfTheCall operator statusCode2))     \
            return;                                                                                                 \
    }                                                                                                               \
    else
Return if result of expression tests true using operator against statusCode1 and statusCode2.

Definition at line 29 of file StatusCodes.h.

#define ACTIV_RETURN_IF_OR_IF | ( | statusCode1,
 |  | statusCode2,
 |  | operator,
 |  | expression | )

Value:

if (true)                                                                                                       \
    {                                                                                                               \
        const Activ::StatusCode thisIsTheResultOfTheCall = expression;                                              \
        if ((thisIsTheResultOfTheCall operator statusCode1) || (thisIsTheResultOfTheCall operator statusCode2))     \
            return;                                                                                                 \
    }                                                                                                               \
    else
Return if result of expression tests true using operator against statusCode1 or statusCode2.

Definition at line 41 of file StatusCodes.h.

#define ACTIV_RETURN_RESULT_IF | ( | statusCode,
 |  | operator,
 |  | expression | )

Value:

if (true)                                                                                                       \
    {                                                                                                               \
        const Activ::StatusCode thisIsTheResultOfTheCall = expression;                                              \
        if (thisIsTheResultOfTheCall operator statusCode)                                                           \
            return thisIsTheResultOfTheCall;                                                                        \
    }                                                                                                               \
    else
Return result if result of expression tests true using operator against statusCode.

Definition at line 53 of file StatusCodes.h.

Referenced by Activ::MessageBuilder::Append(), Activ::CrcBlob::Compress(), Activ::Blob::Compress(), Activ::SmtpHelper::Connect(), Activ::Database::FieldList::CopyField(), Activ::MessageValidator::CopySignedAsciiRealToBinaryReal(), Activ::MessageValidator::CopyUnsignedAsciiRealToBinaryReal(), Activ::CrcBlob::Decompress(), Activ::Blob::Decompress(), Activ::SerializableBuffer< LENGTH_TYPE, MIN_LENGTH, MAX_LENGTH >::Deserialize(), Activ::SerializableContainerHelper< std::set< OBJECT_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >::Deserialize(), Activ::SerializableContainerHelper< std::list< OBJECT_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >::Deserialize(), Activ::SerializableContainerHelper< std::vector< OBJECT_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >::Deserialize(), Activ::RequestId::Deserialize(), Activ::Address::Deserialize(), Activ::ContentPlatform::Feed::Symbol::Deserialize(), Activ::SmtpHelper::Disconnect(), Activ::TRational::Get(), Activ::Time::Get(), Activ::DateTime::Get(), Activ::CrcBlob::Get(), Activ::Blob::Get(), Activ::ContentPlatform::ContentGatewayApi::OptionBar::GetAskPrice(), Activ::ContentPlatform::ContentGatewayApi::OptionBar::GetBidPrice(), Activ::Rational::GetDouble(), Activ::Rational::GetNumerator(), Activ::ContentPlatform::ContentGatewayApi::Tick::GetSize(), Activ::ContentPlatform::ContentGatewayApi::OptionBar::GetStrikePrice(), Activ::ContentPlatform::ContentGatewayApi::IntradayBar::GetTotalVolume(), Activ::ContentPlatform::ContentGatewayApi::HistoryBar::GetTotalVolume(), Activ::ContentPlatform::ContentGatewayApi::OptionBar::GetUnderlyingPrice(), Activ::HeapMessageDeserializer< MESSAGE_TYPE, BUFFER_SIZE >::Initialize(), Activ::Database::Record::Initialize(), Activ::Database::FieldListObject::Initialize(), Activ::MessageBuilder::Initialize(), Activ::MessageBuilder::Insert(), Activ::HeapMessageDeserializer< MESSAGE_TYPE, BUFFER_SIZE >::operator()(), Activ::MessageBuilder::Overwrite(), Activ::DesHelper::Key::Randomize(), Activ::Des3Helper::KeyBundle::Randomize(), Activ::Des3Helper::Key::Randomize(), Activ::ContentPlatform::ContentGatewayApi::FieldSet::ReadInteger(), Activ::ScatterBufferHelper::Reset(), Activ::SerializableBuffer< LENGTH_TYPE, MIN_LENGTH, MAX_LENGTH >::Serialize(), Activ::RequestId::Serialize(), Activ::Address::Serialize(), Activ::SerializableBuffer< LENGTH_TYPE, MIN_LENGTH, MAX_LENGTH >::Set(), Activ::TRational::Set(), Activ::DateTime::Set(), Activ::CrcBlob::Set(), Activ::Blob::Set(), Activ::ContentPlatform::ContentGatewayApi::OptionBar::SetAskPrice(), Activ::ContentPlatform::ContentGatewayApi::OptionBar::SetBidPrice(), Activ::Rational::SetDenominator(), Activ::ContentPlatform::ContentGatewayApi::OptionBar::SetDenominator(), Activ::DesHelper::Key::SetKey(), Activ::Des3Helper::Key::SetKey(), Activ::TRational::SetTick(), Activ::TRational::SetTickAndTrendOnPrevious(), Activ::TRational::SetTrendOnDay(), Activ::TRational::SetTrendOnPrevious(), Activ::ContentPlatform::ContentGatewayApi::OptionBar::SetUnderlyingPrice(), Activ::MessageValidator::ValidateBoolean(), Activ::ContentPlatform::Feed::CompressedMessage::ValidateCompressed(), and Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessage::ValidateCompressedCombinedQuote().

#define ACTIV_RETURN_RESULT_IF_AND_IF | ( | statusCode1,
 |  | statusCode2,
 |  | operator,
 |  | expression | )

Value:

if (true)                                                                                                       \
    {                                                                                                               \
        const Activ::StatusCode thisIsTheResultOfTheCall = expression;                                              \
        if ((thisIsTheResultOfTheCall operator statusCode1) && (thisIsTheResultOfTheCall operator statusCode2))     \
            return thisIsTheResultOfTheCall;                                                                        \
    }                                                                                                               \
    else
Return result if result of expression tests true using operator against statusCode1 and statusCode2.

Definition at line 65 of file StatusCodes.h.

#define ACTIV_RETURN_RESULT_IF_OR_IF | ( | statusCode1,
 |  | statusCode2,
 |  | operator,
 |  | expression | )

Value:

if (true)                                                                                                       \
    {                                                                                                               \
        const Activ::StatusCode thisIsTheResultOfTheCall = expression;                                              \
        if ((thisIsTheResultOfTheCall operator statusCode1) || (thisIsTheResultOfTheCall operator statusCode2))     \
            return thisIsTheResultOfTheCall;                                                                        \
    }                                                                                                               \
    else
Return result if result of expression tests true using operator against statusCode1 or statusCode2.

Definition at line 77 of file StatusCodes.h.

#define ACTIV_RETURN_VALUE_IF | ( | statusCode,
 |  | operator,
 |  | expression,
 |  | value | )

Value:

if (true)                                                                                                       \
    {                                                                                                               \
        if (expression operator statusCode)                                                                         \
            return value;                                                                                           \
    }                                                                                                               \
    else
Return a value if result of expression tests true using operator against statusCode.

Definition at line 89 of file StatusCodes.h.

#define ACTIV_RETURN_VALUE_IF_AND_IF | ( | statusCode1,
 |  | statusCode2,
 |  | operator,
 |  | expression,
 |  | value | )

Value:

if (true)                                                                                                       \
    {                                                                                                               \
        const Activ::StatusCode thisIsTheResultOfTheCall = expression;                                              \
        if ((thisIsTheResultOfTheCall operator statusCode1) && (thisIsTheResultOfTheCall operator statusCode2))     \
            return value;                                                                                           \
    }                                                                                                               \
    else
Return a value if result of expression tests true using operator against statusCode1 and statusCode2.

Definition at line 100 of file StatusCodes.h.

#define ACTIV_RETURN_VALUE_IF_OR_IF | ( | statusCode1,
 |  | statusCode2,
 |  | operator,
 |  | expression,
 |  | value | )

Value:

if (true)                                                                                                       \
    {                                                                                                               \
        const Activ::StatusCode thisIsTheResultOfTheCall = expression;                                              \
        if ((thisIsTheResultOfTheCall operator statusCode1) || (thisIsTheResultOfTheCall operator statusCode2))     \
            return value;                                                                                           \
    }                                                                                                               \
    else
Return a value if result of expression tests true using operator against statusCode1 or statusCode2.

Definition at line 112 of file StatusCodes.h.

#define ACTIV_STATUS_CODE_LIST ( d )

The list of possible status codes and their string representations.

These are network constant values.

Definition at line 226 of file StatusCodes.h.

Generated on Wed Oct 8 14:01:51 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivAgentApplication

AgentApplication.h File Reference

Header file for agent application class. More...

#include "ActivMiddleware/ActivAgentApplication/External.h"
#include "ActivMiddleware/ActivCoreServices/TimerService.h"
#include "ActivMiddleware/ActivCoreServices/LoggerService.h"
#include "ActivMiddleware/ActivCoreServices/PubSubService.h"
#include "ActivMiddleware/ActivCoreServices/MonitorService.h"
#include "ActivMiddleware/ActivCoreServices/DirectoryService.h"
#include "ActivMiddleware/ActivCoreServices/UiService.h"
#include "ActivMiddleware/ActivCoreServices/LicenseService.h"
#include "ActivMiddleware/ActivRouter/RouterService.h"
#include "boost/scoped_ptr.hpp"

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::AgentApplication
Agent application class. More...
class | Activ::AgentApplication::Settings
Agent settings. More...

Defines

#define | ACTIV_DEFAULT_SYSTEM_HEAP_BUCKET_INFO { { 100, 1000 }, { 500, 1000 } }
Default system heap size.

Detailed Description

Header file for agent application class.

Log

Definition in file AgentApplication.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivAgentApplication

External.h File Reference

Import rules for AgentApplication exports. More...

#include "ActivMiddleware/ActivFramework/ActivFramework.h"

Go to the source code of this file.

Defines

#define ACTIV_AGENT_APPLICATION_API ACTIV_IMPORT_DLL

Detailed Description

Import rules for AgentApplication exports.

Log

Definition in file External.h.

Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

ActivBase.h File Reference

Global functions from ActivBase. More...

#include "ActivMiddleware/ActivBase/External.h"
#include "boost/format.hpp"
#include "boost/array.hpp"
#include <sstream>
#include <iostream>
#include <string>
#include <cstdarg>

Go to the source code of this file.

Namespaces

namespace | Activ

Defines

#define | ACTIV_DECLARE_LOG_TYPE(value, id, name) const LogType id = value;
Macro to declare constant log type.
#define | ACTIV_LOG_TYPE_LIST(d)
Log types.

Typedefs

typedef byte_t | Activ::LogType
Log type.

Functions

ACTIV_BASE_EXPORTED_API std::string | Activ::BufferToHexDumpString (const void *const pBuffer, const size_t bufferLength, const size_t bytesPerLine=16, const size_t maxLines=0)
Build a hex dump of a byte buffer.
ACTIV_BASE_EXPORTED_API uint32_t | Activ::GenericHash (const void *pKeyBuffer, const size_t keyLength, const uint32_t initialValue)
Hash a variable length key into a 32-bit value.
ACTIV_BASE_EXPORTED_API void | Activ::HexDump (const void *const pBuffer, const size_t bufferLength, std::ostream &outStream=std::cout)
Build a hex dump of a byte buffer and write to an output stream.
ACTIV_BASE_EXPORTED_API StatusCode | Activ::HexDumpStringToBuffer (const std::string &hexDumpString, MessageBuilder &messageBuilder)
Convert a hex dump (from BufferToHexDumpString()) to binary.
ACTIV_BASE_EXPORTED_API void | Activ::LogMessage (const LogType type, const boost::format &format)
Log a boost::format message. A newline is appended. By default the output is sent to stdout, or stderr for LOG_TYPE_ERROR.
ACTIV_BASE_EXPORTED_API void | Activ::LogMessage (const LogType type, const std::string &message)
Log a string. A newline is appended. By default the output is sent to stdout, or stderr for LOG_TYPE_ERROR.
ACTIV_BASE_EXPORTED_API void | Activ::LogMessage (const LogType type, const char *message)
Log a string. A newline is appended. By default the output is sent to stdout, or stderr for LOG_TYPE_ERROR.
ACTIV_BASE_EXPORTED_API std::string | Activ::LogTypeToString (const LogType logType)
Return log type as a string.
ACTIV_BASE_EXPORTED_API StatusCode | Activ::OsErrorToStatusCode (const uint32_t errorCode, const StatusCode defaultStatusCode=STATUS_CODE_FAILURE)
Convert os-dependent error code to Activ StatusCode.
ACTIV_BASE_EXPORTED_API std::string | Activ::OsErrorToString (const uint32_t errorCode)
Return a string from an os error.
ACTIV_BASE_EXPORTED_API StatusCode | Activ::PlaySound (const void *pData, const size_t dataLength, const bool shouldPlayAsync=true)
Play a sound sample.
ACTIV_BASE_EXPORTED_API bool | Activ::ReplaceEnvironmentVariables (const std::string &source, std::string &target)
Replace any environment variables in a string with the value of the environment variable.
ACTIV_BASE_EXPORTED_API size_t | Activ::Snprintf (char *buff, const size_t buffLen, const char *format,...)
Safe sprintf-like function that will not overrun the supplied buffer, and will always 0 terminate the formatted string.
template<size_t N>
boost::array< char, N > | Activ::SnprintfArray (const char *pFormat,...)
Safe sprintf-like function that returns a boost::array with the formatted string.
ACTIV_BASE_EXPORTED_API const
std::string & 		Activ::StatusCodeToString (const StatusCode statusCode)
Convert a status code to a string.
ACTIV_BASE_EXPORTED_API size_t | Activ::Vsnprintf (char *buff, const size_t buffLen, const char *format, std::va_list args)
Safe vsnprintf-like function that will not overrun the supplied buffer, and will always 0 terminate the formatted string.

Variables

const LogType | Activ::LOG_TYPE_DEBUG = 0
Log type constants.
const LogType | Activ::LOG_TYPE_ERROR = 3
const LogType | Activ::LOG_TYPE_INFO = 1
const LogType | Activ::LOG_TYPE_WARNING = 2

Detailed Description

Global functions from ActivBase.

ActivBase provides low-level os independant primatives.

Log

Definition in file ActivBase.h.

Define Documentation

#define ACTIV_LOG_TYPE_LIST ( d )

Value:

d(0,    LOG_TYPE_DEBUG,     "Debug")        \
    d(1,    LOG_TYPE_INFO,      "Info")         \
    d(2,    LOG_TYPE_WARNING,   "Warning")      \
    d(3,    LOG_TYPE_ERROR,     "Error")
Log types.

These are network constant values.

Definition at line 29 of file ActivBase.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

Atomic.h File Reference

Header file for atomic classes. More...

#include "ActivMiddleware/ActivBase/Detail/AtomicDetail.h"
#include "boost/static_assert.hpp"

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::AtomicInteger
Atomic integer class. More...
class | Activ::AtomicPointer< T >
Atomic pointer class. More...

Detailed Description

Header file for atomic classes.

Log

Definition in file Atomic.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

BaseException.h File Reference

Header file for the base exception class. More...

#include "ActivMiddleware/ActivBase/Exception.h"

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::BaseException
ActivBase exception class. More...

Defines

#define | ACTIV_BASE_EXCEPTION_LIST(d)
The list of possible errors and their strings.

Detailed Description

Header file for the base exception class.

Log

Definition in file BaseException.h.

Define Documentation

#define ACTIV_BASE_EXCEPTION_LIST ( d )

Value:

d(ERROR_INVALID_REGISTRY_VALUE_TYPE, "invalid registry value type")                     \
    d(ERROR_FAILED_TO_ALLOC_SHARED_MUTEX, "failed to allocate shared mutex")                \
    d(ERROR_FAILED_TO_ALLOC_PRIVATE_MUTEX, "failed to allocate private mutex")              \
    d(ERROR_FAILED_TO_INIT_PRIVATE_MUTEX, "failed to initialize private mutex")             \
    d(ERROR_FAILED_TO_ALLOC_SHARED_EVENT, "failed to allocate shared event")                \
    d(ERROR_FAILED_TO_ALLOC_PRIVATE_EVENT, "failed to allocate private event")              \
    d(ERROR_FAILED_TO_ALLOC_SHARED_SEMAPHORE, "failed to allocate shared semaphore")        \
    d(ERROR_FAILED_TO_ALLOC_PRIVATE_SEMAPHORE, "failed to allocate private semaphore")      \
    d(ERROR_FAILED_TO_ALLOC_VERSION, "failed to allocate version")                          \
    d(ERROR_FAILED_TO_ALLOC_SHARED_MEMORY, "failed to allocate shared memory")              \
    d(ERROR_FAILED_TO_ALLOC_METERED_SECTION, "failed to allocate metered section")          \
    d(ERROR_FAILED_TO_ALLOC_UUID, "failed to allocate Uuid")                                \
    d(ERROR_THREAD_ALREADY_STARTED, "thread already started")
The list of possible errors and their strings.

Note this list is converted to an enum using the ACTIV_DECLARE_ELEMENT_1 macro in Activ.h, and the strings are unpicked using ACTIV_DECLARE_ELEMENT_2.

Definition at line 20 of file BaseException.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

CommandLineParser.h File Reference

Header file for a command line parser class. More...

#include "ActivMiddleware/ActivBase/Detail/CommandLineParserDetail.h"

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::CommandLineParser
Command line parser class. More...

Detailed Description

Header file for a command line parser class.

Log

Definition in file CommandLineParser.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

ConsoleWindow.h File Reference

Header file for console window. More...

#include "ActivMiddleware/ActivBase/External.h"
#include <string>

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::ConsoleWindow
Console window class. More...
class | Activ::ConsoleWindow::Coord
Cursor coordinate. More...

Detailed Description

Header file for console window.

Log

Definition in file ConsoleWindow.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

CrtException.h File Reference

Header file for c runtime exception class. More...

#include "ActivMiddleware/ActivBase/Exception.h"

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::CrtException
C runtime exception class. More...

Detailed Description

Header file for c runtime exception class.

Log

Definition in file CrtException.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

CtrlHandler.h File Reference

Header file for the ctrl handler class. More...

#include "ActivMiddleware/ActivBase/External.h"
#include "ActivMiddleware/ActivBase/Atomic.h"

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::CtrlHandler
Ctrl handler class. More...

Detailed Description

Header file for the ctrl handler class.

Log

Definition in file CtrlHandler.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

DirectoryRemover.h File Reference

Directory remover class. More...

#include "ActivMiddleware/ActivBase/DirectoryWalker.h"

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::DirectoryRemover
Directory remover class. More...

Detailed Description

Directory remover class.

DirectoryRemover.h

Log

Definition in file DirectoryRemover.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

DirectoryWalker.h File Reference

Directory walker class. More...

#include "ActivMiddleware/ActivBase/External.h"
#include <string>

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::DirectoryWalker
Directory walker class. More...

Detailed Description

Directory walker class.

DirectoryWalker.h

Log

Definition in file DirectoryWalker.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

Exception.h File Reference

Header file for the base exception class. More...

#include "ActivMiddleware/ActivBase/External.h"
#include <iostream>

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::Exception
Base Activ exception class. More...

Defines

#define | ACTIV_EXCEPTION(t, e) t(__FILE__, __FUNCTION__, __LINE__, e)
Construct an exception.
#define | ACTIV_RETHROW(e)
Rethrow an exception.
#define | ACTIV_THROW(t, e) throw ACTIV_EXCEPTION(t, e)
Raise an exception.
#define | ACTIV_THROW_ERROR_IF(statusCode, operator, expression, exception)
Throw exception if result of expression tests true using operator against statusCode.

Functions

ACTIV_BASE_EXPORTED_API
std::ostream & 		operator<< (std::ostream &os, const Activ::Exception &e)
Global operator<< to dump an exception to an ostream.

Detailed Description

Header file for the base exception class.

Log

Definition in file Exception.h.

Define Documentation

#define ACTIV_RETHROW ( e )

Value:

if (true)                                                               \
                                        {                                                                       \
                                            e.AddException(new (std::nothrow) ACTIV_EXCEPTION(Exception, 0));   \
                                            throw;                                                              \
                                        }                                                                       \
                                        else
Rethrow an exception.

Definition at line 32 of file Exception.h.

#define ACTIV_THROW | ( | t,
 |  | e | ) | throw ACTIV_EXCEPTION(t, e)

Raise an exception.

Throw an exception of type t with error code e. The file, function and line number throwing the exception are automatically generated.

Definition at line 27 of file Exception.h.

Referenced by Activ::DateTime::DateTime(), Activ::DllFunctionWrapper< NAME, TYPE, THROW_ON_ERROR >::FindFunction(), Activ::FtpHelper::FtpHelper(), Activ::UInt::Get(), Activ::Time::Get(), Activ::SInt::Get(), Activ::DateTime::Get(), Activ::Date::Get(), Activ::CrcBlob::GetCrc(), Activ::TextString::GetData(), Activ::TextArray::GetData(), Activ::CrcBlob::GetData(), Activ::Blob::GetData(), Activ::BinaryString::GetData(), Activ::BinaryArray::GetData(), Activ::Date::GetDay(), Activ::Date::GetDayOfWeek(), Activ::Date::GetDayOfYear(), Activ::Rational::GetDenominator(), Activ::Time::GetHour(), Activ::Time::GetLocal(), Activ::DateTime::GetLocal(), Activ::Time::GetMillisecond(), Activ::Time::GetMinute(), Activ::Date::GetMonth(), Activ::Rational::GetNumerator(), Activ::Time::GetSecond(), Activ::TextString::GetSize(), Activ::TextArray::GetSize(), Activ::CrcBlob::GetSize(), Activ::Blob::GetSize(), Activ::BinaryString::GetSize(), Activ::BinaryArray::GetSize(), Activ::CrcBlob::GetSizeWhenDecompressed(), Activ::Blob::GetSizeWhenDecompressed(), Activ::TRational::GetTick(), Activ::Time::GetTotalMilliseconds(), Activ::DateTime::GetTotalMilliseconds(), Activ::TRational::GetTrendOnDay(), Activ::TRational::GetTrendOnPrevious(), Activ::Time::GetUtc(), Activ::DateTime::GetUtc(), Activ::Date::GetWeekOfYear(), Activ::Date::GetYear(), Activ::HeapMessageBuilder::HeapMessageBuilder(), Activ::CommandLineParserDetail::DescriptionAppender::operator()(), Activ::SmtpHelper::PostEmail(), Activ::ScopedPooledObject< T >::ScopedPooledObject(), and Activ::ThreadSpecificDataBase< TYPE, DERIVED >::ThreadSpecificDataBase().

#define ACTIV_THROW_ERROR_IF | ( | statusCode,
 |  | operator,
 |  | expression,
 |  | exception | )

Value:

if (true)                                                                       \
    {                                                                               \
        if (statusCode operator expression)                                         \
            throw exception;                                                        \
    }                                                                               \
    else
Throw exception if result of expression tests true using operator against statusCode.

Definition at line 42 of file Exception.h.

Function Documentation

ACTIV_BASE_EXPORTED_API std::ostream& operator<< | ( | std::ostream & | os,
 |  | const Activ::Exception & | e
 | ) |  |

Global operator<< to dump an exception to an ostream.

operator<< allows writing of the exception to an ostream object. The file, function, line, error code and error string will be written to the ostream.

Parameters:
os | the ostream to write the exception to.
e | the exception to write.
Returns:
the ostream os.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

External.h File Reference

Import/export rules for ActivBase. More...

#include "ActivMiddleware/Activ.h"

Go to the source code of this file.

Defines

#define | ACTIV_BASE_EXPORTED_API ACTIV_USING_DLL_EXPORTED_API
#define | ACTIV_BASE_INLINE_API ACTIV_USING_DLL_INLINE_API
#define | ACTIV_BASE_LOCAL_API ACTIV_USING_DLL_LOCAL_API

Detailed Description

Import/export rules for ActivBase.

Log

Definition in file External.h.

Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

Fiber.h File Reference

Header file for the fiber class. More...

#include "ActivMiddleware/ActivBase/External.h"

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::Fiber
Fiber class. More...

Detailed Description

Header file for the fiber class.

Log

Definition in file Fiber.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

File.h File Reference

Header file for file class. More...

#include "ActivMiddleware/ActivBase/External.h"
#include <string>

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::File
File class. More...

Detailed Description

Header file for file class.

Log

Definition in file File.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

FileMappedMemoryFactory.h File Reference

Header file for the file mapped memory factory class. More...

#include "ActivMiddleware/ActivBase/External.h"
#include "ActivMiddleware/ActivBase/IFileMappedMemory.h"
#include "ActivMiddleware/ActivBase/Timeout.h"
#include "ActivMiddleware/Misc/Singleton.h"
#include <string>

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::FileMappedMemoryFactory
File mapped memory factory class. More...

Detailed Description

Header file for the file mapped memory factory class.

Log

Definition in file FileMappedMemoryFactory.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

IEvent.h File Reference

Header file for the event interface class. More...

#include "ActivMiddleware/ActivBase/External.h"

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::IEvent
Abstract base event class. More...

Detailed Description

Header file for the event interface class.

Log

Definition in file IEvent.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

IFileMappedMemory.h File Reference

Header file for the file mapped memory interface class. More...

#include "ActivMiddleware/ActivBase/External.h"
#include "ActivMiddleware/ActivBase/IMappedMemory.h"

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::IFileMappedMemory
Abstract base file mapped memory class. More...

Detailed Description

Header file for the file mapped memory interface class.

Log

Definition in file IFileMappedMemory.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

IMappedMemory.h File Reference

Header file for the mapped memory interface class. More...

#include "ActivMiddleware/ActivBase/External.h"

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::IMappedMemory
Abstract base mapped memory class. More...

Detailed Description

Header file for the mapped memory interface class.

Log

Definition in file IMappedMemory.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

IMutex.h File Reference

Header file for the mutex interface class. More...

#include "ActivMiddleware/ActivBase/External.h"

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::IMutex
Mutex interface class. More...

Detailed Description

Header file for the mutex interface class.

Log

Definition in file IMutex.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

IniFileParser.h File Reference

Header file for ini file parser class. More...

#include "ActivMiddleware/ActivBase/External.h"
#include "ActivMiddleware/ActivBase/Exception.h"
#include "ActivMiddleware/Misc/SerializableContainerHelper.h"
#include <string>
#include <vector>

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::IniFileParser
Ini file parser. More...
class | Activ::IniFileParser::ConstKeyIterator
Const iterator to section keys. More...
class | Activ::IniFileParser::ConstSectionIterator
Const iterator to ini file sections. More...
class | Activ::IniFileParser::KeySerializer
Key serializer class.
class | Activ::IniFileParser::ParseException
Exception generated by parse errors. More...
class | Activ::IniFileParser::SectionSerializer
Section serializer class.

Detailed Description

Header file for ini file parser class.

Log

Definition in file IniFileParser.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

IntervalTimer.h File Reference

Header file for the interval timer class. More...

#include "ActivMiddleware/ActivBase/External.h"
#include "ActivMiddleware/ActivBase/ActivBase.h"

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::IntervalTimer
Interval timer class. More...
class | Activ::IntervalTimer::Scoped
Helper class to measure time whilst in scope. More...

Detailed Description

Header file for the interval timer class.

Log

Definition in file IntervalTimer.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

ISemaphore.h File Reference

Header file for the semaphore interface class. More...

#include "ActivMiddleware/ActivBase/External.h"

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::ISemaphore
Abstract base semaphore class. More...

Detailed Description

Header file for the semaphore interface class.

Log

Definition in file ISemaphore.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

ISerializableMessage.h File Reference

Header file for serializable message interface class. More...

#include "ActivMiddleware/ActivBase/External.h"

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::ISerializableMessage
Serializable message interface. More...

Detailed Description

Header file for serializable message interface class.

Log

Definition in file ISerializableMessage.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

MessageBuilder.h File Reference

Header file for the message builder class. More...

#include "ActivMiddleware/ActivBase/External.h"
#include "ActivMiddleware/ActivBase/MessageHandler.h"
#include "ActivMiddleware/ActivBase/StatusCodeException.h"
#include "boost/integer_traits.hpp"
#include <string>
#include <cassert>

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::MessageBuilder
Message builder class. More...
class | Activ::MessageBuilderVariableLengthRangeCheck< S >
Class template to check a value is in the acceptable range of a variable number of bytes. More...
class | Activ::MessageBuilderVariableLengthRangeCheck< false >
Specialization to check an unsigned value is in the acceptable range of a variable number of bytes. More...
class | Activ::MessageBuilderVariableLengthRangeCheck< true >
Specialization to check a signed value is in the acceptable range of a variable number of bytes. More...

Detailed Description

Header file for the message builder class.

Log

Definition in file MessageBuilder.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

MessageHandler.h File Reference

Header file for the base message handler class. More...

#include "ActivMiddleware/ActivBase/External.h"

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::MessageHandler
Base class for validator and builder. More...
class | Activ::MessageHandler::ScopedVersion
Helper class to scope changes to message version. More...

Detailed Description

Header file for the base message handler class.

Log

Definition in file MessageHandler.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

MessageRateThrottler.h File Reference

Header file for the message rate throttler class. More...

#include "ActivMiddleware/ActivBase/External.h"
#include "ActivMiddleware/ActivBase/IntervalTimer.h"

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::MessageRateThrottler
Message rate throttler class. More...

Detailed Description

Header file for the message rate throttler class.

MessageRateThrottler.h

Log

Definition in file MessageRateThrottler.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

MessageValidator.h File Reference

Header file for the message validator class. More...

#include "ActivMiddleware/ActivBase/External.h"
#include "ActivMiddleware/ActivBase/MessageHandler.h"
#include "ActivMiddleware/Misc/MemoryHelper.h"
#include <float.h>
#include <vector>
#include <string>
#include <limits>

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::MessageValidator
Message validator class. More...
class | Activ::MessageValidator::CopyBinaryIntegralToBinaryIntegralT< SIZE_MATCH, IS_SIGNED, SIZE, ENDIAN, T >
Template to copy binary to binary.
class | Activ::MessageValidator::CopyBinaryIntegralToBinaryIntegralT< false, false, SIZE, ENDIAN, T >
class | Activ::MessageValidator::CopyBinaryIntegralToBinaryIntegralT< false, true, SIZE, ENDIAN, T >
class | Activ::MessageValidator::CopyBinaryIntegralToBinaryIntegralT< true, IS_SIGNED, SIZE, ENDIAN_ALIEN, T >
class | Activ::MessageValidator::CopyBinaryIntegralToBinaryIntegralT< true, IS_SIGNED, SIZE, ENDIAN_LOCAL, T >

Detailed Description

Header file for the message validator class.

Log

Definition in file MessageValidator.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

MutexHelper.h File Reference

Header file for the mutex helper classes. More...

#include "ActivMiddleware/ActivBase/IMutex.h"
#include <cassert>

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::DeferredScopedMutexLocker
Deferred acquire mutex helper class. More...
class | Activ::ScopedMutexLocker
Scoped mutex locking helper class. More...
class | Activ::ScopedMutexTryLocker
Try acquire mutex helper class. More...

Typedefs

typedef ScopedMutexLocker | Activ::MutexHelper
deprecated old style name

Detailed Description

Header file for the mutex helper classes.

Log

Definition in file MutexHelper.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

OsException.h File Reference

Header file for the os dependant exception class. More...

#include "ActivMiddleware/ActivBase/Exception.h"

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::OsException
OS exception class. More...

Detailed Description

Header file for the os dependant exception class.

Under Windows, OS exception encapsulates Windows error codes (see GetLastError()). Under Unix, the OS exception class is equivalent to CrtException.

Log

Definition in file OsException.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

PagingFileMappedMemoryFactory.h File Reference

Header file for the paging file mapped memory factory class. More...

#include "ActivMiddleware/ActivBase/External.h"
#include "ActivMiddleware/ActivBase/IMappedMemory.h"
#include "ActivMiddleware/ActivBase/Timeout.h"
#include "ActivMiddleware/Misc/Singleton.h"
#include <string>

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::PagingFileMappedMemoryFactory
Paging file mapped memory factory class. More...

Detailed Description

Header file for the paging file mapped memory factory class.

Log

Definition in file PagingFileMappedMemoryFactory.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

PrivateEventFactory.h File Reference

Header file for the private event factory class. More...

#include "ActivMiddleware/ActivBase/External.h"
#include "ActivMiddleware/ActivBase/IEvent.h"
#include "ActivMiddleware/Misc/Singleton.h"

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::PrivateEventFactory
Private event factory class. More...

Detailed Description

Header file for the private event factory class.

Log

Definition in file PrivateEventFactory.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

PrivateMutexFactory.h File Reference

Header file for the private mutex factory class. More...

#include "ActivMiddleware/ActivBase/External.h"
#include "ActivMiddleware/ActivBase/IMutex.h"
#include "ActivMiddleware/Misc/Singleton.h"

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::PrivateMutexFactory
Private mutex factory class. More...

Detailed Description

Header file for the private mutex factory class.

Log

Definition in file PrivateMutexFactory.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

PrivateSemaphoreFactory.h File Reference

Header file for the private semaphore factory class. More...

#include "ActivMiddleware/ActivBase/External.h"
#include "ActivMiddleware/ActivBase/ISemaphore.h"
#include "ActivMiddleware/Misc/Singleton.h"

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::PrivateSemaphoreFactory
Private semaphore factory class. More...

Detailed Description

Header file for the private semaphore factory class.

Log

Definition in file PrivateSemaphoreFactory.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

Process.h File Reference

Header file for the process class. More...

#include "ActivMiddleware/ActivBase/External.h"
#include <string>
#include <vector>

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::Process
Process class. More...

Detailed Description

Header file for the process class.

Log

Definition in file Process.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

ScatterBufferHelper.h File Reference

Header file for the scatter buffer helper class. More...

#include "ActivMiddleware/ActivBase/External.h"
#include "ActivMiddleware/ActivBase/StatusCodeException.h"

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::ScatterBufferHelper
Scatter buffer helper class. More...
class | Activ::ScatterBufferHelper::ConstIterator
Scatter buffer const iterator class. More...
class | Activ::ScatterBufferHelper::ScatterBuffer
Scatter buffer class. More...

Detailed Description

Header file for the scatter buffer helper class.

Log

Definition in file ScatterBufferHelper.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

SharedEventFactory.h File Reference

Header file for the shared event factory class. More...

#include "ActivMiddleware/ActivBase/External.h"
#include "ActivMiddleware/ActivBase/IEvent.h"
#include "ActivMiddleware/ActivBase/Timeout.h"
#include "ActivMiddleware/Misc/Singleton.h"
#include <string>

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::SharedEventFactory
Shared event factory class. More...

Detailed Description

Header file for the shared event factory class.

Log

Definition in file SharedEventFactory.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

SharedMutexFactory.h File Reference

Header file for the shared mutex factory class. More...

#include "ActivMiddleware/ActivBase/External.h"
#include "ActivMiddleware/ActivBase/IMutex.h"
#include "ActivMiddleware/ActivBase/Timeout.h"
#include "ActivMiddleware/Misc/Singleton.h"
#include <string>

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::SharedMutexFactory
Shared mutex factory class. More...

Detailed Description

Header file for the shared mutex factory class.

Log

Definition in file SharedMutexFactory.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

SharedObject.h File Reference

Header file for the template shared object class. More...

#include "ActivMiddleware/ActivBase/PagingFileMappedMemoryFactory.h"
#include <string>

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::SharedObject< T >
Templatized shared object class. More...

Detailed Description

Header file for the template shared object class.

Log

Definition in file SharedObject.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

SharedSemaphoreFactory.h File Reference

Header file for the shared semaphore factory class. More...

#include "ActivMiddleware/ActivBase/External.h"
#include "ActivMiddleware/ActivBase/ISemaphore.h"
#include "ActivMiddleware/ActivBase/Timeout.h"
#include "ActivMiddleware/Misc/Singleton.h"
#include <string>

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::SharedSemaphoreFactory
Shared semaphore factory class. More...

Detailed Description

Header file for the shared semaphore factory class.

Log

Definition in file SharedSemaphoreFactory.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

Shell.h File Reference

Header file for the shell class. More...

#include "ActivMiddleware/ActivBase/External.h"
#include <string>

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::Shell
Command-line abstraction. More...

Detailed Description

Header file for the shell class.

Log

Definition in file Shell.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

StatusCodeException.h File Reference

Header file for the StatusCode exception class. More...

#include "ActivMiddleware/ActivBase/Exception.h"

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::StatusCodeException
StatusCode exception class. More...

Defines

#define | ACTIV_THROW_RESULT_IF(statusCode, operator, expression)
Throw result if result of expression tests true using operator against statusCode.
#define | ACTIV_THROW_RESULT_IF_AND_IF(statusCode1, statusCode2, operator, expression)
Throw result if result of expression tests true using operator against statusCode1 and statusCode2.
#define | ACTIV_THROW_RESULT_IF_OR_IF(statusCode1, statusCode2, operator, expression)
Throw result if result of expression tests true using operator against statusCode1 or statusCode2.

Detailed Description

Header file for the StatusCode exception class.

Log

Definition in file StatusCodeException.h.

Define Documentation

#define ACTIV_THROW_RESULT_IF | ( | statusCode,
 |  | operator,
 |  | expression | )

Value:

if (true)                                                                                                       \
    {                                                                                                               \
        const Activ::StatusCode thisIsTheResultOfTheCall = expression;                                              \
        if (statusCode operator thisIsTheResultOfTheCall)                                                           \
            ACTIV_THROW(Activ::StatusCodeException, thisIsTheResultOfTheCall);                                      \
    }                                                                                                               \
    else
Throw result if result of expression tests true using operator against statusCode.

Definition at line 20 of file StatusCodeException.h.

Referenced by Activ::BinaryArray::BinaryArray(), Activ::BinaryString::BinaryString(), Activ::Blob::Blob(), Activ::SmtpHelper::Connect(), Activ::CurlFtpHelper::Connect(), Activ::CrcBlob::CrcBlob(), Activ::Date::Date(), Activ::CurlFtpHelper::DeleteFile(), Activ::SmtpHelper::Disconnect(), Activ::Rational::Get(), Activ::ContentPlatform::FeedApi::FieldListValidator::Field::GetActivFieldType(), Activ::ContentPlatform::FeedApi::FieldListValidator::GetActivFieldType(), Activ::CurlFtpHelper::GetAndDeleteFile(), Activ::CrcBlob::GetCrcCompressed(), Activ::CrcBlob::GetCrcDecompressed(), Activ::CrcBlob::GetDataCompressed(), Activ::Blob::GetDataCompressed(), Activ::CrcBlob::GetDataDecompressed(), Activ::Blob::GetDataDecompressed(), Activ::ContentPlatform::Feed::TableTemplate::GetField(), Activ::CurlFtpHelper::GetFile(), Activ::CurlFtpHelper::GetFileList(), Activ::CrcBlob::GetSizeCompressed(), Activ::Blob::GetSizeCompressed(), Activ::CrcBlob::GetSizeDecompressed(), Activ::Blob::GetSizeDecompressed(), Activ::DesHelper::Key::Key(), Activ::Des3Helper::Key::Key(), Activ::MessageBuilder::MessageBuilder(), Activ::UInt::operator *=(), Activ::SInt::operator *=(), Activ::Rational::operator *=(), Activ::UInt::operator+=(), Activ::Time::operator+=(), Activ::SInt::operator+=(), Activ::Rational::operator+=(), Activ::DateTime::operator+=(), Activ::Date::operator+=(), Activ::MessageBuilder::operator+=(), Activ::UInt::operator-=(), Activ::Time::operator-=(), Activ::SInt::operator-=(), Activ::Rational::operator-=(), Activ::DateTime::operator-=(), Activ::Date::operator-=(), Activ::UInt::operator/=(), Activ::SInt::operator/=(), Activ::Rational::operator/=(), Activ::UInt::operator<(), Activ::Time::operator<(), Activ::SInt::operator<(), Activ::Rational::operator<(), Activ::DateTime::operator<(), Activ::Date::operator<(), Activ::SerializableBuffer< LENGTH_TYPE, MIN_LENGTH, MAX_LENGTH >::operator=(), Activ::TextString::operator=(), Activ::TextArray::operator=(), Activ::CrcBlob::operator=(), Activ::Blob::operator=(), Activ::BinaryString::operator=(), Activ::BinaryArray::operator=(), Activ::MessageBuilder::operator=(), Activ::UInt::operator==(), Activ::Time::operator==(), Activ::SInt::operator==(), Activ::Rational::operator==(), Activ::DateTime::operator==(), Activ::Date::operator==(), Activ::UInt::operator>(), Activ::Time::operator>(), Activ::SInt::operator>(), Activ::Rational::operator>(), Activ::DateTime::operator>(), Activ::Date::operator>(), Activ::SmtpHelper::PostMessage(), Activ::Rational::Rational(), Activ::SmtpHelper::SmtpHelper(), Activ::TextArray::TextArray(), Activ::TextString::TextString(), Activ::Time::Time(), and Activ::TRational::TRational().

#define ACTIV_THROW_RESULT_IF_AND_IF | ( | statusCode1,
 |  | statusCode2,
 |  | operator,
 |  | expression | )

Value:

if (true)                                                                                                       \
    {                                                                                                               \
        const Activ::StatusCode thisIsTheResultOfTheCall = expression;                                              \
        if ((statusCode1 operator thisIsTheResultOfTheCall) && (statusCode2 operator thisIsTheResultOfTheCall))     \
            ACTIV_THROW(Activ::StatusCodeException, thisIsTheResultOfTheCall);                                      \
    }                                                                                                               \
    else
Throw result if result of expression tests true using operator against statusCode1 and statusCode2.

Definition at line 32 of file StatusCodeException.h.

#define ACTIV_THROW_RESULT_IF_OR_IF | ( | statusCode1,
 |  | statusCode2,
 |  | operator,
 |  | expression | )

Value:

if (true)                                                                                                       \
    {                                                                                                               \
        const Activ::StatusCode thisIsTheResultOfTheCall = expression;                                              \
        if ((statusCode1 operator thisIsTheResultOfTheCall) || (statusCode2 operator thisIsTheResultOfTheCall))     \
            ACTIV_THROW(Activ::StatusCodeException, thisIsTheResultOfTheCall);                                      \
    }                                                                                                               \
    else
Throw result if result of expression tests true using operator against statusCode1 or statusCode2.

Definition at line 44 of file StatusCodeException.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

SystemInfo.h File Reference

Header file for the system info class. More...

#include "ActivMiddleware/ActivBase/External.h"
#include <string>
#include <vector>

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::SystemInfo
System information. More...

Detailed Description

Header file for the system info class.

Log

Definition in file SystemInfo.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

SystemMonitor.h File Reference

Header file for the system monitor class. More...

#include "ActivMiddleware/ActivBase/External.h"
#include "ActivMiddleware/ActivBase/Process.h"
#include "boost/scoped_ptr.hpp"
#include <vector>
#include <map>

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::SystemMonitor
System monitor class. More...
class | Activ::SystemMonitor::Stats
Collected stats. More...
class | Activ::SystemMonitor::Stats::DiskInfo
Per-disk info. More...
class | Activ::SystemMonitor::Stats::ProcessInfo
Per-process info. More...

Detailed Description

Header file for the system monitor class.

Log

Definition in file SystemMonitor.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

Thread.h File Reference

Header file for the thread class. More...

#include "ActivMiddleware/ActivBase/External.h"
#include "boost/shared_ptr.hpp"
#include <string>
#include <vector>

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::Thread
Thread base class. More...

Functions

unsigned WINAPI | Activ::ActivThreadGlobalThreadProc (void *pData)

Detailed Description

Header file for the thread class.

Log

Definition in file Thread.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

ThreadSpecificData.h File Reference

Header file for thread specific data storage class. More...

#include "ActivMiddleware/ActivBase/External.h"
#include "ActivMiddleware/Misc/FunctionObjects.h"
#include "ActivMiddleware/ActivBase/Detail/ThreadSpecificDataDetail.h"

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::ThreadSpecificData< TYPE, CLEANUP >
Thread specific data helper class. More...
class | Activ::ThreadSpecificDataBase< TYPE, DERIVED >
Thread specific data helper base class. More...
class | Activ::ThreadSpecificDataBase< TYPE, DERIVED >::PerThreadInfo
Data stored per-thread.

Detailed Description

Header file for thread specific data storage class.

Log

Definition in file ThreadSpecificData.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

ThreadSpecificPoolAllocators.h File Reference

Thread-specific boost (fast_)pool_allocator like classes. More...

#include "ActivMiddleware/ActivBase/ThreadSpecificData.h"
#include "ActivMiddleware/Misc/Singleton.h"
#include "boost/pool/poolfwd.hpp"
#include "boost/pool/pool.hpp"

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::ThreadSpecificFastPoolAllocator< T, UserAllocator, NextSize >
boost::fast_pool_allocator like std allocator, except pool is thread local rather than process wide. More...
struct | Activ::ThreadSpecificFastPoolAllocator< T, UserAllocator, NextSize >::rebind< U >
class | Activ::ThreadSpecificFastPoolAllocator< T, UserAllocator, NextSize >::ThreadSingleton
class | Activ::ThreadSpecificPoolAllocator< T, UserAllocator, NextSize >
boost::pool_allocator like std allocator, except the pool is thread local rather than process wide. More...
struct | Activ::ThreadSpecificPoolAllocator< T, UserAllocator, NextSize >::rebind< U >
class | Activ::ThreadSpecificPoolAllocator< T, UserAllocator, NextSize >::ThreadSingleton

Detailed Description

Thread-specific boost (fast_)pool_allocator like classes.

Log

Definition in file ThreadSpecificPoolAllocators.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

Timeout.h File Reference

Header file for the timeout class. More...

#include "ActivMiddleware/ActivBase/External.h"

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::Timeout
Timeout handler function object class. More...

Detailed Description

Header file for the timeout class.

Log

Definition in file Timeout.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

Url.h File Reference

Url parser & builder class. More...

#include "ActivMiddleware/ActivBase/External.h"
#include <string>
#include <list>

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::Url
Url parser & builder class. More...

Detailed Description

Url parser & builder class.

Log

Definition in file Url.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

Uuid.h File Reference

Header file for the Uuid class. More...

#include "ActivMiddleware/ActivBase/External.h"
#include <string>

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::Uuid
Uuid class. More...

Detailed Description

Header file for the Uuid class.

Log

Definition in file Uuid.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase » Detail

AtomicDetail.h File Reference

Header file for implementation details for atomic operations. More...

#include "ActivMiddleware/ActivBase/External.h"
#include <cassert>

Go to the source code of this file.

Namespaces

namespace | Activ

Functions

ACTIV_BASE_EXPORTED_API long | Activ::AtomicDecrement (volatile long *pAddend)
Interlocked decrement by 1 a value and return resulting value.
ACTIV_BASE_EXPORTED_API long | Activ::AtomicExchange (volatile long *pTarget, const long value)
Interlocked exchange value.
ACTIV_BASE_EXPORTED_API long | Activ::AtomicIncrement (volatile long *pAddend)
Interlocked increment by 1 a value and return resulting value.

Detailed Description

Header file for implementation details for atomic operations.

Log

Definition in file AtomicDetail.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase » Detail

CommandLineParserDetail.h File Reference

Implementation details for CommandLineParser. More...

#include "ActivMiddleware/ActivBase/External.h"
#include "ActivMiddleware/ActivBase/StatusCodeException.h"
#include "boost/program_options.hpp"
#include <iostream>

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::CommandLineParserDetail

Classes

class | Activ::CommandLineParserDetail::BooleanSwitchDescription
Description of a boolean command line switch. More...
class | Activ::CommandLineParserDetail::CommandLineParserImpl
Implementation details of CommandLineParser. More...
class | Activ::CommandLineParserDetail::DefaultDescription< T >
Description of a command line parameter/switch with default value. More...
class | Activ::CommandLineParserDetail::Description< T >
Description of a command line parameter/switch. More...
class | Activ::CommandLineParserDetail::DescriptionAppender
Helper class to build description. More...
class | Activ::CommandLineParserDetail::MandatoryParameterDescription< T >
Description of a mandatory command line parameter. More...
class | Activ::CommandLineParserDetail::MandatorySwitchDescription< T >
Description of a mandatory command line switch. More...
class | Activ::CommandLineParserDetail::OptionalParameterDescription< T >
Description of an optional command line parameter. More...
class | Activ::CommandLineParserDetail::OptionalSwitchDescription< T >
Description of an optional command line switch. More...
class | Activ::CommandLineParserDetail::ValueStore< T >
Default action to take for a command line value. More...

Detailed Description

Implementation details for CommandLineParser.

Log

Definition in file CommandLineParserDetail.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase » Detail

ThreadSpecificDataDetail.h File Reference

Implementation details thread for specific data storage class. More...

#include "ActivMiddleware/ActivBase/OsException.h"
#include "ActivMiddleware/ActivBase/StatusCodeException.h"

Go to the source code of this file.

Namespaces

namespace | Activ

Typedefs

typedef void(* | Activ::TsdDestructorFn )(void *)

Functions

ACTIV_BASE_EXPORTED_API void | Activ::ThreadSpecificDataCleanupAddKey (const DWORD key, TsdDestructorFn pTsdDestructorFn)
ACTIV_BASE_EXPORTED_API void | Activ::ThreadSpecificDataCleanupRemoveKey (const DWORD key)

Detailed Description

Implementation details thread for specific data storage class.

Log

Definition in file ThreadSpecificDataDetail.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase » Windows

IoCompletionManager.h File Reference

Header file for Windows I/O completion manager classes. More...

#include "ActivMiddleware/ActivBase/External.h"
#include "ActivMiddleware/ActivBase/Thread.h"
#include "boost/shared_ptr.hpp"
#include <vector>

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::IoCompletionManager
I/O completion manager class. More...
class | Activ::IoCompletionManager::IoThread
Io thread.
class | Activ::IoCompletionManager::Overlapped
Overlapped class. More...

Detailed Description

Header file for Windows I/O completion manager classes.

Log

Definition in file IoCompletionManager.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase » Windows

RegistryHelper.h File Reference

Header file for the registry helper class. More...

#include "ActivMiddleware/ActivBase/External.h"

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::RegistryHelper
Registry helper class. More...
class | Activ::RegistryHelper::RegistryKey
Registry key class.

Detailed Description

Header file for the registry helper class.

Log

Definition in file RegistryHelper.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase » Windows

SharedCompletionPortEventFactory.h File Reference

Header file for the shared socket based event factory class. More...

#include "ActivMiddleware/ActivBase/External.h"
#include "ActivMiddleware/ActivBase/IEvent.h"
#include "ActivMiddleware/ActivBase/Timeout.h"
#include "ActivMiddleware/Misc/Singleton.h"

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::SharedCompletionPortEventFactory
Shared completion-port based event factory class. More...

Detailed Description

Header file for the shared socket based event factory class.

Log

Definition in file SharedCompletionPortEventFactory.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivDatabase

ActivDatabase.h File Reference

Header file for the Activ database. More...

#include "ActivMiddleware/ActivDatabase/External.h"
#include "ActivMiddleware/ActivFieldTypes/Blob.h"
#include "ActivMiddleware/ActivFieldTypes/CrcBlob.h"
#include "ActivMiddleware/ActivFieldTypes/Date.h"
#include "ActivMiddleware/ActivFieldTypes/DateTime.h"
#include "ActivMiddleware/ActivFieldTypes/Rational.h"
#include "ActivMiddleware/ActivFieldTypes/Time.h"
#include "ActivMiddleware/ActivFieldTypes/TRational.h"
#include <iostream>

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::Database

Functions

std::string | Activ::Database::BinaryToString (const byte_t *pSourceData, const size_t length)
Convert a binary buffer to a string.
std::string | Activ::Database::BlobToString (const byte_t *pSourceData, const size_t length)
Convert a blob to a string.
std::string | Activ::Database::BooleanToString (const byte_t *pSourceData, const size_t length)
Convert a boolean to a string.
int | Activ::Database::CompareBlob (const byte_t *pLhsData, const size_t lhsLength, const byte_t *pRhsData, const size_t rhsLength)
Comparison of two blob objects.
int | Activ::Database::CompareCrcBlob (const byte_t *pLhsData, const size_t lhsLength, const byte_t *pRhsData, const size_t rhsLength)
Comparison of two crc blob objects.
int | Activ::Database::CompareDate (const byte_t *pLhsData, const size_t lhsLength, const byte_t *pRhsData, const size_t rhsLength)
Comparison of two date objects.
int | Activ::Database::CompareDateTime (const byte_t *pLhsData, const size_t lhsLength, const byte_t *pRhsData, const size_t rhsLength)
Comparison of two date time objects.
int | Activ::Database::CompareRational (const byte_t *pLhsData, const size_t lhsLength, const byte_t *pRhsData, const size_t rhsLength)
Comparison of two rational objects.
int | Activ::Database::CompareSignedIntegral (const byte_t *pLhsData, const size_t lhsLength, const byte_t *pRhsData, const size_t rhsLength)
Comparison of signed integral types.
int | Activ::Database::CompareTime (const byte_t *pLhsData, const size_t lhsLength, const byte_t *pRhsData, const size_t rhsLength)
Comparison of two time objects.
int | Activ::Database::CompareTRational (const byte_t *pLhsData, const size_t lhsLength, const byte_t *pRhsData, const size_t rhsLength)
Comparison of two trational objects.
int | Activ::Database::CompareUnsignedIntegral (const byte_t *pLhsData, const size_t lhsLength, const byte_t *pRhsData, const size_t rhsLength)
Comparison of unsigned integral types.
int | Activ::Database::CompareUnsignedMemory (const byte_t *pLhsData, const size_t lhsLength, const byte_t *pRhsData, const size_t rhsLength)
Unsigned comparison of memory locations.
std::string | Activ::Database::CrcBlobToString (const byte_t *pSourceData, const size_t length)
Convert a crc blob to a string.
std::string | Activ::Database::DateTimeToString (const byte_t *pSourceData, const size_t length)
Convert a DateTime object to a string.
std::string | Activ::Database::DateToString (const byte_t *pSourceData, const size_t length)
Convert a Date object to a string.
int64_t | Activ::Database::GetSignedInt64 (const void *pData, const size_t length)
Get a signed integer 64 number from a length of binary data.
uint64_t | Activ::Database::GetUnsignedInt64 (const void *pData, const size_t length)
Get an unsigned integer 64 number from a length of binary data.
ACTIV_DATABASE_API ITable * | Activ::Database::OpenTable (const std::string &tableFileName, const bool createRecordFile=true, const bool createIndexes=true)
Open a table file.
std::string | Activ::Database::RationalToString (const byte_t *pSourceData, const size_t length)
Convert a Rational object to a string.
std::string | Activ::Database::SignedIntegralToString (const byte_t *pSourceData, const size_t length)
Convert a signed integral value to a string.
std::string | Activ::Database::TextToString (const byte_t *pSourceData, const size_t length)
Convert a text buffer to a string.
std::string | Activ::Database::TimeToString (const byte_t *pSourceData, const size_t length)
Convert a Time object to a string.
std::string | Activ::Database::TRationalToString (const byte_t *pSourceData, const size_t length)
Convert a TRational object to a string.
int | Activ::Database::Umemcmp (const byte_t *pLhsData, const byte_t *pRhsData, size_t length)
Unsigned memory comparison.
std::string | Activ::Database::UnsignedIntegralToString (const byte_t *pSourceData, const size_t length)
Convert an unsigned integral to a string.
void | Activ::Database::ValidateBlobSpecification (const FieldSpecification &fieldSpecification)
Check whether a field specification is valid for field type blob.
void | Activ::Database::ValidateBooleanSpecification (const FieldSpecification &fieldSpecification)
Check whether a field specification is valid for field type boolean.
void | Activ::Database::ValidateCrcBlobSpecification (const FieldSpecification &fieldSpecification)
Check whether a field specification is valid for field type crc blob.
void | Activ::Database::ValidateDateSpecification (const FieldSpecification &fieldSpecification)
Check whether a field specification is valid for field type date.
void | Activ::Database::ValidateDateTimeSpecification (const FieldSpecification &fieldSpecification)
Check whether a field specification is valid for field type date time.
void | Activ::Database::ValidateNoneSpecification (const FieldSpecification &fieldSpecification)
Check whether a field specification is valid for field type none.
void | Activ::Database::ValidateRationalSpecification (const FieldSpecification &fieldSpecification)
Check whether a field specification is valid for field type rational.
void | Activ::Database::ValidateSignedIntegralSpecification (const FieldSpecification &fieldSpecification)
Check whether a field specification is valid for field type signed integral.
void | Activ::Database::ValidateSpecification (const FieldSpecification &fieldSpecification)
Check whether a field specification is valid.
void | Activ::Database::ValidateTimeSpecification (const FieldSpecification &fieldSpecification)
Check whether a field specification is valid for field type time.
void | Activ::Database::ValidateTRationalSpecification (const FieldSpecification &fieldSpecification)
Check whether a field specification is valid for field type trended rational.
void | Activ::Database::ValidateUnsignedIntegralSpecification (const FieldSpecification &fieldSpecification)
Check whether a field specification is valid for field type unsigned integral.

Detailed Description

Header file for the Activ database.

Log

Definition in file ActivDatabase.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivDatabase

Database.h File Reference

Header file for the Database class. More...

#include "ActivMiddleware/ActivBase/IMutex.h"
#include "ActivMiddleware/ActivBase/MutexHelper.h"
#include "ActivMiddleware/ActivDatabase/ITable.h"
#include "ActivMiddleware/ActivDatabase/DatabaseException.h"
#include "ActivMiddleware/ActivDatabase/DatabaseSpecification.h"
#include "ActivMiddleware/Misc/StlHelper.h"
#include <vector>
#include <set>

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::Database

Classes

class | Activ::Database::Database
Database class. More...
class | Activ::Database::Database::ConstIterator
Const iterator class. More...
class | Activ::Database::Database::Iterator
Iterator class. More...

Detailed Description

Header file for the Database class.

Log

Definition in file Database.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivDatabase

DatabaseException.h File Reference

Header file for the database exception class. More...

#include "ActivMiddleware/Activ.h"
#include "ActivMiddleware/ActivBase/Exception.h"
#include "ActivMiddleware/ActivDatabase/External.h"
#include <string>

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::Database

Classes

class | Activ::Database::DatabaseException
Database exception class. More...

Defines

#define | ACTIV_DATABASE_EXCEPTION_LIST(d)
The list of database errors.

Detailed Description

Header file for the database exception class.

Log

Definition in file DatabaseException.h.

Define Documentation

#define ACTIV_DATABASE_EXCEPTION_LIST ( d )

Value:

d(DATABASE_ERROR_FAILED_TO_ALLOC_DATA_STORE, "failed to allocate data store")               \
    d(DATABASE_ERROR_FAILED_TO_ALLOC_DATA_STORE_CACHE, "failed to allocate data store cache")   \
    d(DATABASE_ERROR_FAILED_TO_ALLOC_DATABASE, "failed to allocate database")                   \
    d(DATABASE_ERROR_FAILED_TO_ALLOC_FIELD_LIST, "failed to allocate field list")               \
    d(DATABASE_ERROR_FAILED_TO_ALLOC_INDEX, "failed to allocate index")                         \
    d(DATABASE_ERROR_FAILED_TO_ALLOC_KEY, "failed to allocate key")                             \
    d(DATABASE_ERROR_FAILED_TO_ALLOC_MEMORY_MANAGER, "failed to allocate memory manager")       \
    d(DATABASE_ERROR_FAILED_TO_ALLOC_RECORD, "failed to allocate record")                       \
    d(DATABASE_ERROR_FAILED_TO_ALLOC_TABLE, "failed to allocate table")                         \
    d(DATABASE_ERROR_FAILED_TO_CREATE_FILE, "failed to create file")                            \
    d(DATABASE_ERROR_NOT_CREATED, "not created")                                                \
    d(DATABASE_ERROR_NOT_SUPPORTED, "not supported")                                            \
    d(DATABASE_ERROR_INVALID_PARAMETER, "invalid parameter")                                    \
    d(DATABASE_ERROR_ALREADY_CREATED, "already created")
The list of database errors.

Definition at line 29 of file DatabaseException.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivDatabase

DatabaseSpecification.h File Reference

Header file for the database specification class. More...

#include "ActivMiddleware/Misc/StlHelper.h"
#include "ActivMiddleware/ActivDatabase/External.h"
#include "ActivMiddleware/ActivDatabase/TableSpecification.h"
#include "ActivMiddleware/ActivDatabase/IndexSpecification.h"
#include <string>

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::Database

Classes

class | Activ::Database::DatabaseSpecification
Database specification structure. More...
class | Activ::Database::DatabaseSpecification::DatabaseTableSpecification
Database table specification structure. More...

Typedefs

typedef std::vector
< IndexSpecification > 		Activ::Database::IndexSpecificationList
Index specification list definition. Defined here as well as Definitions.h because of a cyclic dependency.

Functions

ACTIV_DATABASE_API std::ostream & | operator<< (std::ostream &os, const Activ::Database::DatabaseSpecification &rhs)
Global operator<< to dump a database specification to an ostream.

Detailed Description

Header file for the database specification class.

Log

Definition in file DatabaseSpecification.h.

Function Documentation

ACTIV_DATABASE_API std::ostream& operator<< | ( | std::ostream & | os,
 |  | const Activ::Database::DatabaseSpecification & | rhs
 | ) |  |

Global operator<< to dump a database specification to an ostream.

Parameters:
os | the ostream to write the database specification to.
rhs | the field specification to write.
Returns:
the ostream os.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivDatabase

Definitions.h File Reference

Header file for the database definition information. More...

#include "ActivMiddleware/Activ.h"
#include "ActivMiddleware/ActivDatabase/FieldSpecification.h"
#include "ActivMiddleware/ActivDatabase/IndexSpecification.h"
#include "ActivMiddleware/ActivDatabase/TableSpecification.h"
#include "ActivMiddleware/ActivDatabase/DatabaseSpecification.h"

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::Database

Typedefs

typedef int32_t | Activ::Database::DataId
Data identifier definition.
typedef std::vector
< FieldSpecification::Id > 		Activ::Database::FieldIdList
Field identifier list definition.
typedef std::vector
< FieldSpecification > 		Activ::Database::FieldSpecificationList
Field specification list definition.
typedef std::vector
< IndexSpecification::Field > 		Activ::Database::IndexFieldSpecificationList
Index field specification list.
typedef byte_t | Activ::Database::Mode
Mode type definition.
typedef std::vector
< DatabaseSpecification::TableId > 		Activ::Database::TableIdList
Table id list definition.

Variables

const size_t | Activ::Database::FIELD_COMPARE_LENGTH_WHOLE = ~0
Compare the whole length of a field.
const DataId | Activ::Database::UNDEFINED_ID = -1
Undefined id.

Detailed Description

Header file for the database definition information.

Log

Definition in file Definitions.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivDatabase

External.h File Reference

Import rules for ActivDatabase exports. More...

#include "ActivMiddleware/Activ.h"

Go to the source code of this file.

Defines

#define ACTIV_DATABASE_API ACTIV_IMPORT_DLL
Export as a dll.

Detailed Description

Import rules for ActivDatabase exports.

Log

Definition in file External.h.

Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivDatabase

FieldList.h File Reference

Header file for the field list class. More...

#include "ActivMiddleware/ActivFieldTypes/IFieldType.h"
#include "ActivMiddleware/ActivFieldTypes/BinaryArray.h"
#include "ActivMiddleware/ActivFieldTypes/BinaryString.h"
#include "ActivMiddleware/ActivFieldTypes/Blob.h"
#include "ActivMiddleware/ActivFieldTypes/CrcBlob.h"
#include "ActivMiddleware/ActivFieldTypes/Date.h"
#include "ActivMiddleware/ActivFieldTypes/DateTime.h"
#include "ActivMiddleware/ActivFieldTypes/Rational.h"
#include "ActivMiddleware/ActivFieldTypes/SInt.h"
#include "ActivMiddleware/ActivFieldTypes/TextArray.h"
#include "ActivMiddleware/ActivFieldTypes/TextString.h"
#include "ActivMiddleware/ActivFieldTypes/Time.h"
#include "ActivMiddleware/ActivFieldTypes/TRational.h"
#include "ActivMiddleware/ActivFieldTypes/UInt.h"
#include "ActivMiddleware/ActivDatabase/External.h"
#include "ActivMiddleware/ActivDatabase/Definitions.h"
#include "ActivMiddleware/Misc/StlHelper.h"
#include <iostream>
#include <vector>
#include <algorithm>
#include <memory>

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::Database

Classes

class | Activ::Database::FieldList
Declaration of the field list class. More...
class | Activ::Database::FieldList::ConstIterator
Const iterator class. More...

Detailed Description

Header file for the field list class.

Log

Definition in file FieldList.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivDatabase

FieldListObject.h File Reference

Header file for the field list object class. More...

#include "ActivMiddleware/ActivDatabase/External.h"
#include "ActivMiddleware/ActivDatabase/Definitions.h"
#include "ActivMiddleware/ActivDatabase/ITable.h"
#include "ActivMiddleware/ActivDatabase/FieldList.h"
#include <iostream>
#include <string>
#include <memory>

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::Database

Classes

class | Activ::Database::FieldListObject
Field list object class. More...

Functions

ACTIV_DATABASE_API std::ostream & | operator<< (std::ostream &os, const Activ::Database::FieldListObject &rhs)
Global operator<< to dump a record to an ostream.

Detailed Description

Header file for the field list object class.

Log

Definition in file FieldListObject.h.

Function Documentation

ACTIV_DATABASE_API std::ostream& operator<< | ( | std::ostream & | os,
 |  | const Activ::Database::FieldListObject & | rhs |
 | ) |  |  | [inline]

Global operator<< to dump a record to an ostream.

Parameters:
os | the ostream to write the index specification to.
rhs | the field list object to write.
Returns:
the ostream os.

Definition at line 1169 of file FieldListObject.h.

References Activ::Database::FieldListObject::ToString().

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivDatabase

FieldSpecification.h File Reference

Header file for the field specification class. More...

#include "ActivMiddleware/ActivFieldTypes/ActivFieldTypes.h"
#include "ActivMiddleware/ActivDatabase/External.h"
#include "ActivMiddleware/ActivDatabase/ActivDatabase.h"
#include <string>

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::Database

Classes

class | Activ::Database::FieldSpecification
Field specification structure. More...

Defines

#define | ACTIV_DATABASE_FIELD_ENUM(id, name, type, maxLength, offset, properties) id,
Enumerations of field ids.
#define | ACTIV_DATABASE_FIELD_SPECIFICATION(id, name, type, maxLength, offset, properties) Activ::Database::FieldSpecification(id, name, Activ::Database::FieldSpecification::type, maxLength, offset, Activ::Database::FieldSpecification::properties),
Initializer for field specification structures.
#define | ACTIV_DATABASE_FIELD_TYPE_ENUM(type, name, isVariableLength, isString, validate, compare, toString, activFieldType) type,
Enumeration of allowed field types.
#define | ACTIV_DATABASE_FIELD_TYPE_LIST(d)
The list of field type information.
#define | ACTIV_DATABASE_FIELD_TYPE_SPECIFICATION(type, name, isVariableLength, isString, validate, compare, toString, activFieldType) { name, isVariableLength, isString, validate, compare, toString },
Initializer for field type specification structures.

Functions

ACTIV_DATABASE_API std::ostream & | operator<< (std::ostream &os, const Activ::Database::FieldSpecification &rhs)
Global operator<< to dump a field specification to an ostream.

Detailed Description

Header file for the field specification class.

Log

Definition in file FieldSpecification.h.

Define Documentation

#define ACTIV_DATABASE_FIELD_TYPE_LIST ( d )

Value:

d(TYPE_NONE,                "None",                 false,  false,  ValidateNoneSpecification,              CompareUnsignedMemory,      BinaryToString,             FIELD_TYPE_UNKNOWN)         \
    d(TYPE_BINARY_ARRAY,        "BinaryArray",          false,  true,   ValidateSpecification,                  CompareUnsignedMemory,      BinaryToString,             FIELD_TYPE_BINARY_ARRAY)    \
    d(TYPE_BINARY_STRING,       "BinaryString",         true,   true,   ValidateSpecification,                  CompareUnsignedMemory,      BinaryToString,             FIELD_TYPE_BINARY_STRING)   \
    d(TYPE_BITMAP,              "Bitmap",               false,  false,  ValidateSpecification,                  CompareUnsignedMemory,      BinaryToString,             FIELD_TYPE_UNKNOWN)         \
    d(TYPE_BLOB,                "Blob",                 true,   false,  ValidateBlobSpecification,              CompareBlob,                BlobToString,               FIELD_TYPE_BLOB)            \
    d(TYPE_DATE,                "Date",                 false,  false,  ValidateDateSpecification,              CompareDate,                DateToString,               FIELD_TYPE_DATE)            \
    d(TYPE_DATE_TIME,           "DateTime",             false,  false,  ValidateDateTimeSpecification,          CompareDateTime,            DateTimeToString,           FIELD_TYPE_DATE_TIME)       \
    d(TYPE_POINTER,             "Pointer",              false,  false,  ValidateSpecification,                  CompareUnsignedMemory,      BinaryToString,             FIELD_TYPE_UNKNOWN)         \
    d(TYPE_RATIONAL,            "Rational",             true,   false,  ValidateRationalSpecification,          CompareRational,            RationalToString,           FIELD_TYPE_RATIONAL)        \
    d(TYPE_SIGNED_INTEGRAL,     "SInt",                 false,  false,  ValidateSignedIntegralSpecification,    CompareSignedIntegral,      SignedIntegralToString,     FIELD_TYPE_SINT)            \
    d(TYPE_TEXT_ARRAY,          "TextArray",            false,  true,   ValidateSpecification,                  CompareUnsignedMemory,      TextToString,               FIELD_TYPE_TEXT_ARRAY)      \
    d(TYPE_TEXT_STRING,         "TextString",           true,   true,   ValidateSpecification,                  CompareUnsignedMemory,      TextToString,               FIELD_TYPE_TEXT_STRING)     \
    d(TYPE_TIME,                "Time",                 false,  false,  ValidateTimeSpecification,              CompareTime,                TimeToString,               FIELD_TYPE_TIME)            \
    d(TYPE_TRATIONAL,           "TRational",            true,   false,  ValidateTRationalSpecification,         CompareTRational,           TRationalToString,          FIELD_TYPE_TRATIONAL)       \
    d(TYPE_UNSIGNED_INTEGRAL,   "UInt",                 false,  false,  ValidateUnsignedIntegralSpecification,  CompareUnsignedIntegral,    UnsignedIntegralToString,   FIELD_TYPE_UINT)            \
    d(TYPE_BOOLEAN,             "Boolean",              false,  false,  ValidateBooleanSpecification,           CompareUnsignedIntegral,    BooleanToString,            FIELD_TYPE_UNKNOWN)         \
    d(TYPE_CRC_BLOB,            "CrcBlob",              true,   false,  ValidateCrcBlobSpecification,           CompareCrcBlob,             CrcBlobToString,            FIELD_TYPE_CRC_BLOB)
The list of field type information.

Definition at line 35 of file FieldSpecification.h.

Function Documentation

ACTIV_DATABASE_API std::ostream& operator<< | ( | std::ostream & | os,
 |  | const Activ::Database::FieldSpecification & | rhs
 | ) |  |

Global operator<< to dump a field specification to an ostream.

Parameters:
os | the ostream to write the index specification to.
rhs | the field specification to write.
Returns:
the ostream os.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivDatabase

IIndex.h File Reference

Header file for the index interface class. More...

#include "ActivMiddleware/ActivDatabase/External.h"
#include "ActivMiddleware/ActivDatabase/Definitions.h"
#include <vector>
#include <memory>

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::Database

Classes

class | Activ::Database::IIndex
Abstract base index class. More...

Detailed Description

Header file for the index interface class.

Log

Definition in file IIndex.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivDatabase

IndexSpecification.h File Reference

Header file for the index specification. More...

#include "ActivMiddleware/ActivDatabase/External.h"
#include "ActivMiddleware/ActivDatabase/FieldSpecification.h"
#include <string>
#include <vector>
#include <iostream>

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::Database

Classes

class | Activ::Database::IndexSpecification
Index Specification structure. More...
class | Activ::Database::IndexSpecification::Field
Index field specification structure. More...

Defines

#define | ACTIV_DATABASE_INDEX_ENUM(number, name, type, properties, fieldList) number,
Enumeration of index numbers.
#define | ACTIV_DATABASE_INDEX_ENUM_WITH_CACHE(number, name, type, properties, fieldList, fieldIdList) number,
Enumeration of index numbers.
#define | ACTIV_DATABASE_INDEX_FIELD(id, properties) Activ::Database::IndexSpecification::Field(id, Activ::Database::IndexSpecification::Field::properties)
Declaration of an index specification.
#define | ACTIV_DATABASE_INDEX_SPECIFICATION(number, name, type, properties, fieldList) Activ::Database::IndexSpecification(name, Activ::Database::IndexSpecification::type, Activ::Database::IndexSpecification::properties, std::vector<Activ::Database::IndexSpecification::Field>(fieldList, fieldList + ACTIV_ARRAY_SIZE(fieldList))),
Initializer for index specification structures.
#define | ACTIV_DATABASE_INDEX_SPECIFICATION_WITH_CACHE(number, name, type, properties, fieldList, fieldIdList) Activ::Database::IndexSpecification(name, Activ::Database::IndexSpecification::type, Activ::Database::IndexSpecification::properties, std::vector<Activ::Database::IndexSpecification::Field>(fieldList, fieldList + ACTIV_ARRAY_SIZE(fieldList)), std::vector<Activ::Database::FieldSpecification::Id>(fieldIdList, fieldIdList + ACTIV_ARRAY_SIZE(fieldIdList))),
Initializer for index specification structures.

Functions

ACTIV_DATABASE_API std::ostream & | operator<< (std::ostream &os, const Activ::Database::IndexSpecification &rhs)
Global operator<< to dump an index specification to an ostream.

Detailed Description

Header file for the index specification.

Log

Definition in file IndexSpecification.h.

Define Documentation

#define ACTIV_DATABASE_INDEX_FIELD | ( | id,
 |  | properties | ) | Activ::Database::IndexSpecification::Field(id, Activ::Database::IndexSpecification::Field::properties)

Declaration of an index specification.

Initializer for an index specification field.

Definition at line 32 of file IndexSpecification.h.

Function Documentation

ACTIV_DATABASE_API std::ostream& operator<< | ( | std::ostream & | os,
 |  | const Activ::Database::IndexSpecification & | rhs
 | ) |  |

Global operator<< to dump an index specification to an ostream.

Parameters:
os | the ostream to write the index specification to.
rhs | the index specification to write.
Returns:
the ostream os.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivDatabase

ITable.h File Reference

Header file for the table interface class. More...

#include "ActivMiddleware/ActivDatabase/External.h"
#include "ActivMiddleware/ActivDatabase/Definitions.h"
#include "ActivMiddleware/ActivDatabase/DatabaseException.h"
#include <iostream>
#include <vector>
#include <memory>

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::Database

Classes

class | Activ::Database::ITable
Abstract base table class. More...

Typedefs

typedef std::vector< Key > | Activ::Database::KeyList
Key list type definition.
typedef std::vector< Record > | Activ::Database::RecordList
Record list type definition.

Detailed Description

Header file for the table interface class.

Log

Definition in file ITable.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivDatabase

Key.h File Reference

Header file for the key class. More...

#include "ActivMiddleware/ActivDatabase/External.h"
#include "ActivMiddleware/ActivDatabase/Definitions.h"
#include "ActivMiddleware/ActivDatabase/ITable.h"
#include "ActivMiddleware/ActivDatabase/IIndex.h"
#include "ActivMiddleware/ActivDatabase/FieldListObject.h"
#include <string>
#include <memory>

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::Database

Classes

class | Activ::Database::Key
Key class. More...

Detailed Description

Header file for the key class.

Log

Definition in file Key.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivDatabase

ManagedTableFactory.h File Reference

Header file for the managed table factory class. More...

#include "ActivMiddleware/ActivDatabase/External.h"
#include "ActivMiddleware/ActivDatabase/Definitions.h"
#include "ActivMiddleware/Misc/Singleton.h"
#include <string>
#include <vector>

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::Database

Classes

class | Activ::Database::ManagedTableFactory
Managed table factory class. More...

Detailed Description

Header file for the managed table factory class.

Log

Definition in file ManagedTableFactory.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivDatabase

Record.h File Reference

Header file for the record class. More...

#include "ActivMiddleware/ActivDatabase/External.h"
#include "ActivMiddleware/ActivDatabase/Definitions.h"
#include "ActivMiddleware/ActivDatabase/ITable.h"
#include "ActivMiddleware/ActivDatabase/FieldListObject.h"
#include <iostream>
#include <string>
#include <memory>

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::Database

Classes

class | Activ::Database::Record
Database record class. More...

Detailed Description

Header file for the record class.

Log

Definition in file Record.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivDatabase

RemoteTableFactory.h File Reference

Header file for the remote table factory class. More...

#include "ActivMiddleware/ActivDatabase/External.h"
#include "ActivMiddleware/ActivDatabase/Definitions.h"
#include "ActivMiddleware/Misc/Singleton.h"

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::Database

Classes

class | Activ::Database::RemoteTableFactory
Remote table factory class. More...

Detailed Description

Header file for the remote table factory class.

Log

Definition in file RemoteTableFactory.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivDatabase

TableSpecification.h File Reference

Header file for the table specification class. More...

#include "ActivMiddleware/ActivDatabase/External.h"
#include "ActivMiddleware/ActivDatabase/FieldSpecification.h"
#include <string>

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::Database

Classes

class | Activ::Database::TableSpecification
Table specification structure. More...

Functions

ACTIV_DATABASE_API std::ostream & | operator<< (std::ostream &os, const Activ::Database::TableSpecification &rhs)
Global operator<< to dump a table specification to an ostream.

Detailed Description

Header file for the table specification class.

Log

Definition in file TableSpecification.h.

Function Documentation

ACTIV_DATABASE_API std::ostream& operator<< | ( | std::ostream & | os,
 |  | const Activ::Database::TableSpecification & | rhs
 | ) |  |

Global operator<< to dump a table specification to an ostream.

Parameters:
os | the ostream to write the table specification to.
rhs | the table specification to write.
Returns:
the ostream os.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivDatabase

UnmanagedTableFactory.h File Reference

Header file for the unmanaged table factory class. More...

#include "ActivMiddleware/ActivDatabase/External.h"
#include "ActivMiddleware/ActivDatabase/Definitions.h"
#include "ActivMiddleware/Misc/Singleton.h"
#include <string>
#include <vector>

Go to the source code of this file.

Namespaces

namespace | Activ
namespace | Activ::Database

Classes

class | Activ::Database::UnmanagedTableFactory
Unmanaged table factory class. More...

Detailed Description

Header file for the unmanaged table factory class.

Log

Definition in file UnmanagedTableFactory.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivFieldTypes

ActivFieldTypes.h File Reference

Global functions from ActivFieldTypes. More...

#include "ActivMiddleware/ActivFieldTypes/External.h"
#include <string>

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::FieldTypeToClass<>
Template to map from FIELD_TYPE_* values to concrete IFieldType class. More...

Defines

#define | ACTIV_DECLARE_FIELD_TYPE_ENUMERATIONS(id, name, size1, size2) id,
The field type enumeration declaration.
#define | ACTIV_FIELD_TYPE_LIST(d)
The list of field types and their string representation.

Typedefs

typedef uint8_t | Activ::FieldType
The field type type definition.

Enumerations

enum {
FIELD_TYPE_DATE, FIELD_TYPE_TIME, FIELD_TYPE_DATE_TIME, FIELD_TYPE_SINT,
FIELD_TYPE_UINT, FIELD_TYPE_RATIONAL, FIELD_TYPE_TRATIONAL, FIELD_TYPE_TEXT_STRING,
FIELD_TYPE_TEXT_ARRAY, FIELD_TYPE_BINARY_STRING, FIELD_TYPE_BINARY_ARRAY, FIELD_TYPE_BLOB,
FIELD_TYPE_CRC_BLOB, NUMBER_OF_FIELD_TYPES
}
Enumeration of all field types.

Functions

ACTIV_FIELD_TYPES_API size_t | Activ::FieldTypeToRecordLengthSize (const FieldType fieldType)
Convert a field type to the field length size for a record message.
ACTIV_FIELD_TYPES_API std::string | Activ::FieldTypeToString (const FieldType fieldType)
Convert a field type to a string.
ACTIV_FIELD_TYPES_API size_t | Activ::FieldTypeToUpdateLengthSize (const FieldType fieldType)
Convert a field type to the field length size for an update message.
ACTIV_FIELD_TYPES_API FieldType | Activ::StringToFieldType (const std::string &name)
Convert a string to a field type.

Variables

const FieldType | Activ::FIELD_TYPE_UNKNOWN = ~0

Detailed Description

Global functions from ActivFieldTypes.

Log

Definition in file ActivFieldTypes.h.

Define Documentation

#define ACTIV_FIELD_TYPE_LIST ( d )

Value:

d(FIELD_TYPE_DATE,          Date,               0,      0)      \
    d(FIELD_TYPE_TIME,          Time,               0,      0)      \
    d(FIELD_TYPE_DATE_TIME,     DateTime,           0,      0)      \
    d(FIELD_TYPE_SINT,          SInt,               0,      1)      \
    d(FIELD_TYPE_UINT,          UInt,               0,      1)      \
    d(FIELD_TYPE_RATIONAL,      Rational,           0,      0)      \
    d(FIELD_TYPE_TRATIONAL,     TRational,          0,      0)      \
    d(FIELD_TYPE_TEXT_STRING,   TextString,         1,      1)      \
    d(FIELD_TYPE_TEXT_ARRAY,    TextArray,          0,      1)      \
    d(FIELD_TYPE_BINARY_STRING, BinaryString,       1,      1)      \
    d(FIELD_TYPE_BINARY_ARRAY,  BinaryArray,        0,      1)      \
    d(FIELD_TYPE_BLOB,          Blob,               4,      4)      \
    d(FIELD_TYPE_CRC_BLOB,      CrcBlob,            4,      4)
The list of field types and their string representation.

SIZE1 size of inlined field length in a record message. SIZE2 size of inlined field length in an update message.

TYPE NAME SIZE1 SIZE2

Definition at line 24 of file ActivFieldTypes.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivFieldTypes

BinaryArray.h File Reference

Header file for the binary array class. More...

#include "ActivMiddleware/ActivFieldTypes/External.h"
#include "ActivMiddleware/ActivFieldTypes/IFieldType.h"
#include "ActivMiddleware/Misc/MemoryHelper.h"
#include "ActivMiddleware/ActivBase/StatusCodeException.h"

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::BinaryArray
Binary array class. More...
class | Activ::FieldTypeToClass< FIELD_TYPE_BINARY_ARRAY >
Template specialization to map from FIELD_TYPE_BINARY_ARRAY to BinaryArray class. More...

Detailed Description

Header file for the binary array class.

Log

Definition in file BinaryArray.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivFieldTypes

BinaryString.h File Reference

Header file for the binary string class. More...

#include "ActivMiddleware/ActivFieldTypes/External.h"
#include "ActivMiddleware/ActivFieldTypes/IFieldType.h"
#include "ActivMiddleware/Misc/MemoryHelper.h"
#include "ActivMiddleware/ActivBase/StatusCodeException.h"

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::BinaryString
Binary string class. More...
class | Activ::FieldTypeToClass< FIELD_TYPE_BINARY_STRING >
Template specialization to map from FIELD_TYPE_BINARY_STRING to BinaryString class. More...

Detailed Description

Header file for the binary string class.

Log

Definition in file BinaryString.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivFieldTypes

Blob.h File Reference

Header file for the blob class. More...

#include "ActivMiddleware/ActivFieldTypes/External.h"
#include "ActivMiddleware/ActivFieldTypes/IFieldType.h"
#include "ActivMiddleware/Misc/MemoryHelper.h"
#include "ActivMiddleware/ActivBase/ActivBase.h"
#include "ActivMiddleware/ActivBase/StatusCodeException.h"
#include "ActivMiddleware/ActivCompress/ZlibCompressor.h"

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::Blob
Blob class. More...
class | Activ::FieldTypeToClass< FIELD_TYPE_BLOB >
Template specialization to map from FIELD_TYPE_BLOB to Blob class. More...

Detailed Description

Header file for the blob class.

Log

Definition in file Blob.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivFieldTypes

CrcBlob.h File Reference

Header file for the crc blob class. More...

#include "ActivMiddleware/ActivFieldTypes/External.h"
#include "ActivMiddleware/ActivFieldTypes/IFieldType.h"
#include "ActivMiddleware/Misc/MemoryHelper.h"
#include "ActivMiddleware/ActivBase/ActivBase.h"
#include "ActivMiddleware/ActivBase/StatusCodeException.h"
#include "ActivMiddleware/ActivCompress/ZlibCompressor.h"

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::CrcBlob
Crc blob class. More...
class | Activ::FieldTypeToClass< FIELD_TYPE_CRC_BLOB >
Template specialization to map from FIELD_TYPE_CRC_BLOB to CrcBlob class. More...

Detailed Description

Header file for the crc blob class.

Log

Definition in file CrcBlob.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivFieldTypes

Date.h File Reference

Header file for the date class. More...

#include "ActivMiddleware/ActivFieldTypes/External.h"
#include "ActivMiddleware/ActivFieldTypes/IFieldType.h"
#include "ActivMiddleware/ActivBase/StatusCodeException.h"
#include <ctime>

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::Date
Date class. More...
class | Activ::Date::Days
Days class. More...
class | Activ::FieldTypeToClass< FIELD_TYPE_DATE >
Template specialization to map from FIELD_TYPE_DATE to Date class. More...

Defines

#define | ACTIV_DAY_LIST(d)
The day list.
#define | ACTIV_MONTH_LIST(d)
The month list.

Detailed Description

Header file for the date class.

Log

Definition in file Date.h.

Define Documentation

#define ACTIV_DAY_LIST ( d )

Value:

d(SUNDAY,       "Sunday")       \
    d(MONDAY,       "Monday")       \
    d(TUESDAY,      "Tuesday")      \
    d(WEDNESDAY,    "Wednesday")    \
    d(THURSDAY,     "Thursday")     \
    d(FRIDAY,       "Friday")       \
    d(SATURDAY,     "Saturday")
The day list.

Definition at line 25 of file Date.h.

#define ACTIV_MONTH_LIST ( d )

Value:

d(UNDEFINED,    "Undefined")    \
    d(JANUARY,      "January")      \
    d(FEBRUARY,     "February")     \
    d(MARCH,        "March")        \
    d(APRIL,        "April")        \
    d(MAY,          "May")          \
    d(JUNE,         "June")         \
    d(JULY,         "July")         \
    d(AUGUST,       "August")       \
    d(SEPTEMBER,    "September")    \
    d(OCTOBER,      "October")      \
    d(NOVEMBER,     "November")     \
    d(DECEMBER,     "December")
The month list.

Definition at line 37 of file Date.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivFieldTypes

DateTime.h File Reference

Header file for the date / time class. More...

#include "ActivMiddleware/ActivFieldTypes/External.h"
#include "ActivMiddleware/ActivFieldTypes/IFieldType.h"
#include "ActivMiddleware/ActivFieldTypes/Date.h"
#include "ActivMiddleware/ActivFieldTypes/Time.h"
#include "ActivMiddleware/ActivBase/StatusCodeException.h"

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::DateTime
Date / time class. More...
class | Activ::FieldTypeToClass< FIELD_TYPE_DATE_TIME >
Template specialization to map from FIELD_TYPE_DATE_TIME to DateTime class. More...

Detailed Description

Header file for the date / time class.

Log

Definition in file DateTime.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivFieldTypes

External.h File Reference

Import rules for ActivFieldTypes exports. More...

#include "ActivMiddleware/Activ.h"

Go to the source code of this file.

Defines

#define ACTIV_FIELD_TYPES_API ACTIV_IMPORT_DLL

Detailed Description

Import rules for ActivFieldTypes exports.

Log

Definition in file External.h.

Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivFieldTypes

FieldTypeFactory.h File Reference

Header file for the field type factory class. More...

#include "ActivMiddleware/ActivFieldTypes/External.h"
#include "ActivMiddleware/ActivFieldTypes/ActivFieldTypes.h"
#include "ActivMiddleware/Misc/Singleton.h"

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::FieldTypeFactory
Field type factory class. More...

Detailed Description

Header file for the field type factory class.

Log

Definition in file FieldTypeFactory.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivFieldTypes

IFieldType.h File Reference

Header file for the field type interface class. More...

#include "ActivMiddleware/ActivFieldTypes/External.h"
#include "ActivMiddleware/ActivFieldTypes/ActivFieldTypes.h"
#include "ActivMiddleware/ActivBase/MessageValidator.h"
#include <string>

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::IFieldType
Field type interface class. More...

Detailed Description

Header file for the field type interface class.

Log

Definition in file IFieldType.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivFieldTypes

Rational.h File Reference

Header file for the rational class. More...

#include "ActivMiddleware/ActivFieldTypes/External.h"
#include "ActivMiddleware/ActivFieldTypes/IFieldType.h"
#include "ActivMiddleware/Misc/MemoryHelper.h"
#include "ActivMiddleware/ActivBase/ActivBase.h"
#include "ActivMiddleware/ActivBase/StatusCodeException.h"

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::FieldTypeToClass< FIELD_TYPE_RATIONAL >
Template specialization to map from FIELD_TYPE_RATIONAL to Rational class. More...
class | Activ::Rational
Rational class. More...
class | Activ::Rational::DenominatorType
Denominator type. More...
class | Activ::Rational::SerializedHeaderDefinitions
Serialized header definitions.

Defines

#define | ACTIV_DENOMINATOR_ENUMERATION(enumeration, divisor, multiplier, nDecimalPlaces, nDivisorDigits, multiplierPower) enumeration,
The denominator enumeration declaration.
#define | ACTIV_DENOMINATOR_LIST(d)
The denominator list.
#define | ACTIV_DENOMINATOR_SPECIFICATION(enumeration, divisor, multiplier, nDecimalPlaces, nDivisorDigits, multiplierPower) Rational::DenominatorType(divisor, multiplier, nDecimalPlaces, nDivisorDigits, multiplierPower),
The denominator specification declaration.

Functions

const Rational | Activ::operator * (const Rational &lhs, const Rational &rhs)
Multiplication operator for the rational object.
const Rational | Activ::operator+ (const Rational &lhs, const Rational &rhs)
Addition operator for the rational object.
const Rational | Activ::operator- (const Rational &lhs, const Rational &rhs)
Subtraction operator for the rational object.
const Rational | Activ::operator/ (const Rational &lhs, const Rational &rhs)
Division operator for the rational object.

Detailed Description

Header file for the rational class.

Log

Definition in file Rational.h.

Define Documentation

#define ACTIV_DENOMINATOR_LIST ( d )

Value:

d(DENOMINATOR_WHOLE,        1,          1,          0,      0,      0)      \
    d(DENOMINATOR_1DP,          10,         0,          1,      1,      0)      \
    d(DENOMINATOR_2DP,          100,        0,          2,      2,      0)      \
    d(DENOMINATOR_3DP,          1000,       0,          3,      3,      0)      \
    d(DENOMINATOR_4DP,          10000,      0,          4,      4,      0)      \
    d(DENOMINATOR_5DP,          100000,     0,          5,      5,      0)      \
    d(DENOMINATOR_6DP,          1000000,    0,          6,      6,      0)      \
    d(DENOMINATOR_7DP,          10000000,   0,          7,      7,      0)      \
    d(DENOMINATOR_8DP,          100000000,  0,          8,      8,      0)      \
    d(DENOMINATOR_9DP,          1000000000, 0,          9,      9,      0)      \
    d(DENOMINATOR_X1E1,         0,          10,         0,      0,      1)      \
    d(DENOMINATOR_X1E2,         0,          100,        0,      0,      2)      \
    d(DENOMINATOR_X1E3,         0,          1000,       0,      0,      3)      \
    d(DENOMINATOR_X1E4,         0,          10000,      0,      0,      4)      \
    d(DENOMINATOR_X1E5,         0,          100000,     0,      0,      5)      \
    d(DENOMINATOR_X1E6,         0,          1000000,    0,      0,      6)      \
    d(DENOMINATOR_X1E7,         0,          10000000,   0,      0,      7)      \
    d(DENOMINATOR_X1E8,         0,          100000000,  0,      0,      8)      \
    d(DENOMINATOR_X1E9,         0,          1000000000, 0,      0,      9)      \
    d(DENOMINATOR_HALF,         2,          0,          1,      1,      0)      \
    d(DENOMINATOR_QUARTER,      4,          0,          2,      1,      0)      \
    d(DENOMINATOR_8TH,          8,          0,          3,      1,      0)      \
    d(DENOMINATOR_16TH,         16,         0,          4,      2,      0)      \
    d(DENOMINATOR_32ND,         32,         0,          5,      2,      0)      \
    d(DENOMINATOR_64TH,         64,         0,          6,      2,      0)      \
    d(DENOMINATOR_128TH,        128,        0,          7,      3,      0)      \
    d(DENOMINATOR_256TH,        256,        0,          8,      3,      0)      \
    d(DENOMINATOR_512TH,        512,        0,          9,      3,      0)      \
    d(DENOMINATOR_CABINET,      1,          0,          0,      0,      0)      \
    d(DENOMINATOR_UNDEFINED,    0,          0,          0,      0,      0)
The denominator list.

Definition at line 26 of file Rational.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivFieldTypes

SInt.h File Reference

Header file for the signed integer class. More...

#include "ActivMiddleware/ActivFieldTypes/External.h"
#include "ActivMiddleware/ActivFieldTypes/IFieldType.h"
#include "ActivMiddleware/ActivBase/StatusCodeException.h"
#include "ActivMiddleware/Misc/MemoryHelper.h"

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::FieldTypeToClass< FIELD_TYPE_SINT >
Template specialization to map from FIELD_TYPE_SINT to SInt class. More...
class | Activ::SInt
Signed integer class. More...

Functions

const SInt | Activ::operator * (const SInt &lhs, const SInt &rhs)
Multiplication operator for the signed integer object.
const SInt | Activ::operator+ (const SInt &lhs, const SInt &rhs)
Addition operator for the signed integer object.
const SInt | Activ::operator- (const SInt &lhs, const SInt &rhs)
Subtraction operator for the signed integer object.
const SInt | Activ::operator/ (const SInt &lhs, const SInt &rhs)
Division operator for the signed integer object.

Detailed Description

Header file for the signed integer class.

Log

Definition in file SInt.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivFieldTypes

TextArray.h File Reference

Header file for the text array class. More...

#include "ActivMiddleware/ActivFieldTypes/External.h"
#include "ActivMiddleware/ActivFieldTypes/IFieldType.h"
#include "ActivMiddleware/Misc/MemoryHelper.h"
#include "ActivMiddleware/ActivBase/StatusCodeException.h"

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::FieldTypeToClass< FIELD_TYPE_TEXT_ARRAY >
Template specialization to map from FIELD_TYPE_TEXT_ARRAY to TextArray class. More...
class | Activ::TextArray
Text array class. More...

Detailed Description

Header file for the text array class.

Log

Definition in file TextArray.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivFieldTypes

TextString.h File Reference

Header file for the text string class. More...

#include "ActivMiddleware/ActivFieldTypes/External.h"
#include "ActivMiddleware/ActivFieldTypes/IFieldType.h"
#include "ActivMiddleware/Misc/MemoryHelper.h"
#include "ActivMiddleware/ActivBase/StatusCodeException.h"

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::FieldTypeToClass< FIELD_TYPE_TEXT_STRING >
Template specialization to map from FIELD_TYPE_TEXT_STRING to TextString class. More...
class | Activ::TextString
Text string class. More...

Detailed Description

Header file for the text string class.

Log

Definition in file TextString.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivFieldTypes

Time.h File Reference

Header file for the time class. More...

#include "ActivMiddleware/ActivFieldTypes/External.h"
#include "ActivMiddleware/ActivFieldTypes/IFieldType.h"
#include "ActivMiddleware/ActivBase/StatusCodeException.h"
#include <ctime>

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::FieldTypeToClass< FIELD_TYPE_TIME >
Template specialization to map from FIELD_TYPE_TIME to Time class. More...
class | Activ::Time
Time class. More...
class | Activ::Time::Hours
Hours class. More...
class | Activ::Time::Milliseconds
Milliseconds class. More...
class | Activ::Time::Minutes
Minutes class. More...
class | Activ::Time::Seconds
Seconds class. More...

Detailed Description

Header file for the time class.

Log

Definition in file Time.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivFieldTypes

TRational.h File Reference

Header file for the trended rational class. More...

#include "ActivMiddleware/ActivFieldTypes/External.h"
#include "ActivMiddleware/ActivFieldTypes/IFieldType.h"
#include "ActivMiddleware/ActivFieldTypes/Rational.h"
#include "ActivMiddleware/ActivBase/StatusCodeException.h"

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::FieldTypeToClass< FIELD_TYPE_TRATIONAL >
Template specialization to map from FIELD_TYPE_TRATIONAL to TRational class. More...
class | Activ::TRational
Trended rational class. More...
class | Activ::TRational::SerializedTrendDefinitions
Serialized trend definitions. More...

Defines

#define | ACTIV_TICK_LIST(d)
The tick list.
#define | ACTIV_TREND_LIST(d)
The trend list.

Detailed Description

Header file for the trended rational class.

Log

Definition in file TRational.h.

Define Documentation

#define ACTIV_TICK_LIST ( d )

Value:

d(TICK_UNCHANGED,       "=")    \
    d(TICK_UP,              "+")    \
    d(TICK_DOWN,            "-")    \
    d(TICK_UNDEFINED,       " ")
The tick list.

Definition at line 24 of file TRational.h.

#define ACTIV_TREND_LIST ( d )

Value:

d(TREND_UNCHANGED,      "=")    \
    d(TREND_UP,             "+")    \
    d(TREND_DOWN,           "-")    \
    d(TREND_UNDEFINED,      " ")
The trend list.

Definition at line 33 of file TRational.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivFieldTypes

UInt.h File Reference

Header file for the unsigned integer class. More...

#include "ActivMiddleware/ActivFieldTypes/External.h"
#include "ActivMiddleware/ActivFieldTypes/IFieldType.h"
#include "ActivMiddleware/ActivBase/StatusCodeException.h"
#include "ActivMiddleware/Misc/MemoryHelper.h"

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::FieldTypeToClass< FIELD_TYPE_UINT >
Template specialization to map from FIELD_TYPE_UINT to UInt class. More...
class | Activ::UInt
Unsigned integer class. More...

Functions

const UInt | Activ::operator * (const UInt &lhs, const UInt &rhs)
Multiplication operator for the unsigned integer object.
const UInt | Activ::operator+ (const UInt &lhs, const UInt &rhs)
Addition operator for the unsigned integer object.
const UInt | Activ::operator- (const UInt &lhs, const UInt &rhs)
Subtraction operator for the unsigned integer object.
const UInt | Activ::operator/ (const UInt &lhs, const UInt &rhs)
Division operator for the unsigned integer object.

Detailed Description

Header file for the unsigned integer class.

Log

Definition in file UInt.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivFramework

ActivFramework.h File Reference

Main header file for framework. More...

#include "ActivMiddleware/ActivSystem/ActivSystem.h"
#include "ActivMiddleware/ActivFramework/Application.h"
#include "ActivMiddleware/ActivFramework/ThinApplication.h"
#include "ActivMiddleware/ActivFramework/Component.h"
#include "ActivMiddleware/ActivFramework/Service.h"
#include "ActivMiddleware/ActivFramework/ChildService.h"
#include "ActivMiddleware/ActivFramework/UiComponent.h"
#include "ActivMiddleware/ActivFramework/UiMenu.h"
#include "ActivMiddleware/ActivFramework/UiIo.h"

Go to the source code of this file.

Detailed Description

Main header file for framework.

Log

Definition in file ActivFramework.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivFramework

Application.h File Reference

Header file for base application class. More...

#include "ActivMiddleware/ActivFramework/External.h"
#include "ActivMiddleware/ActivFramework/Component.h"
#include "ActivMiddleware/ActivFramework/DirectoryWatchApi.h"
#include "ActivMiddleware/ActivFramework/TimerServiceApi.h"
#include "ActivMiddleware/ActivFramework/LoggerServiceApi.h"
#include "ActivMiddleware/ActivFramework/RouterServiceApi.h"
#include "ActivMiddleware/ActivFramework/PubSubServiceApi.h"
#include "ActivMiddleware/ActivFramework/ServiceApi.h"
#include "ActivMiddleware/ActivBase/CtrlHandler.h"
#include "boost/scoped_ptr.hpp"

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::Application
Base application class. More...
class | Activ::Application::Settings
Settings. More...
class | Activ::SystemProxy
Proxy class for ISystem interface. More...

Detailed Description

Header file for base application class.

Log

Definition in file Application.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivFramework

ChildService.h File Reference

Header file for child service class. More...

#include "ActivMiddleware/ActivFramework/External.h"
#include "ActivMiddleware/ActivFramework/Service.h"

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::ChildService< T >
Child service class. More...

Detailed Description

Header file for child service class.

Log

Definition in file ChildService.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivFramework

Component.h File Reference

Header file for component class. More...

#include "ActivMiddleware/ActivFramework/External.h"
#include "ActivMiddleware/ActivFramework/ServiceTypes.h"
#include "ActivMiddleware/ActivFramework/TimeHelper.h"

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::Component
Component class. More...

Detailed Description

Header file for component class.

Log

Definition in file Component.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivFramework

DirectoryWatchApi.h File Reference

Header file for the directory watch api. More...

#include "ActivMiddleware/ActivFramework/External.h"
#include "ActivMiddleware/ActivFramework/TimeHelper.h"
#include <vector>

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::DirectoryWatchApi
Api to the agent's directory watching service. More...
class | Activ::DirectoryWatchApi::Event
File/directory change event. More...

Detailed Description

Header file for the directory watch api.

Log

Definition in file DirectoryWatchApi.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivFramework

External.h File Reference

Import rules for ActivFramework exports. More...

#include "ActivMiddleware/Activ.h"
#include "ActivMiddleware/ActivSystem/ActivSystem.h"

Go to the source code of this file.

Namespaces

namespace | Activ

Defines

#define | ACTIV_AGENT_SCOPE_LIST(d)
List of agent scopes.
#define | ACTIV_DECLARE_AGENT_SCOPE(a, b) ACTIV_DECLARE_CONSTANT_ELEMENT_1(AgentScope, a, b)
#define | ACTIV_FRAMEWORK_API ACTIV_IMPORT_DLL

Typedefs

typedef byte_t | Activ::AgentScope
Agent scope type.

Enumerations

enum | { ACTIV_DECLARE_HIDDEN_ELEMENT_1 }

Functions

ACTIV_IMPORT_DLL std::string | Activ::AgentScopeToString (const AgentScope agentScope)
Return a scope as a string.

Variables

const AgentScope | Activ::AGENT_SCOPE_GLOBAL = ____AGENT_SCOPE_GLOBAL
const AgentScope | Activ::AGENT_SCOPE_LOCAL = ____AGENT_SCOPE_LOCAL
const AgentScope | Activ::AGENT_SCOPE_REMOTE = ____AGENT_SCOPE_REMOTE

Detailed Description

Import rules for ActivFramework exports.

Log

Definition in file External.h.

Define Documentation

#define ACTIV_AGENT_SCOPE_LIST ( d )

Value:

d(AGENT_SCOPE_LOCAL, "Local")           \
    d(AGENT_SCOPE_GLOBAL, "Global")         \
    d(AGENT_SCOPE_REMOTE, "Remote")
List of agent scopes.

Definition at line 28 of file External.h.

Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivFramework

LicenseServiceApi.h File Reference

Header file for the license service api class. More...

#include "ActivMiddleware/ActivFramework/External.h"

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::LicenseServiceApi
Api to agent's license service. More...

Detailed Description

Header file for the license service api class.

Log

Definition in file LicenseServiceApi.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivFramework

LoggerDefinitions.h File Reference

Header file for the common LoggerServiceApi / LoggerService definitions. More...

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::LoggerDefinitions
Logger definitions class. More...

Defines

#define | FILE_TYPE_LIST(d)
The list of possible log file types and their string representation.

Detailed Description

Header file for the common LoggerServiceApi / LoggerService definitions.

Log

Definition in file LoggerDefinitions.h.

Define Documentation

#define FILE_TYPE_LIST ( d )

Value:

d(  FILE_TYPE_DAILY, "Daily")                   \
    d(  FILE_TYPE_WEEKLY, "Weekly")                 \
    d(  FILE_TYPE_MONTHLY, "Monthly")               \
    d(  FILE_TYPE_ROLLING, "Rolling")
The list of possible log file types and their string representation.

Definition at line 18 of file LoggerDefinitions.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivFramework

LoggerServiceApi.h File Reference

Header file for the logger service api class. More...

#include "ActivMiddleware/ActivFramework/External.h"
#include "ActivMiddleware/ActivFramework/LoggerDefinitions.h"

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::LoggerServiceApi
Api to the agent's logger service. More...

Detailed Description

Header file for the logger service api class.

Log

Definition in file LoggerServiceApi.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivFramework

Messages.h File Reference

Header file for exported framework message classes. More...

#include "ActivMiddleware/ActivFramework/ServiceTypes.h"
#include "ActivMiddleware/ActivBase/ISerializableMessage.h"

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::OpenServiceRequest
Open service request. More...
class | Activ::OpenServiceResponse
Open service response. The response implicitly matches the version of the request. More...
class | Activ::SystemMessageEndPointIdSet
SYSTEM_MESSAGE_ENDPOINT_SHUTDOWN, SYSTEM_MESSAGE_ENDPOINT_DIE. More...

Detailed Description

Header file for exported framework message classes.

Log

Definition in file Messages.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivFramework

PubSubServiceApi.h File Reference

Header file for the pubsub service api. More...

#include "ActivMiddleware/ActivFramework/External.h"
#include <map>
#include <set>

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::PubSubServiceApi
Api to the agent's pubsub service. More...
class | Activ::ScopedSubscription
Scoped subscription helper. More...

Detailed Description

Header file for the pubsub service api.

Log

Definition in file PubSubServiceApi.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivFramework

RouterServiceApi.h File Reference

Header file for router api. More...

#include "ActivMiddleware/ActivFramework/External.h"
#include "ActivMiddleware/ActivBase/ISerializableMessage.h"

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::RouterServiceApi
Api to the agent's router service. More...
class | Activ::RouterServiceApi::Tcp
Tcp related apis. More...
class | Activ::RouterServiceApi::Tcp::SocketStats
Socket stats. More...
class | Activ::RouterServiceApi::Udp
Udp related apis. More...

Detailed Description

Header file for router api.

Log

Definition in file RouterServiceApi.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivFramework

Service.h File Reference

Header file for service class. More...

#include "ActivMiddleware/ActivFramework/External.h"
#include "ActivMiddleware/ActivFramework/Component.h"
#include "ActivMiddleware/ActivFramework/Messages.h"
#include "ActivMiddleware/ActivBase/Uuid.h"
#include <list>

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::Service
Service class. More...
class | Activ::Service::AccessList
List of servers.

Detailed Description

Header file for service class.

Log

Definition in file Service.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivFramework

ServiceApi.h File Reference

Header file for service access api. More...

#include "ActivMiddleware/ActivFramework/External.h"
#include "ActivMiddleware/ActivFramework/Messages.h"

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::ServiceApi
Api to the access services. More...

Detailed Description

Header file for service access api.

Log

Definition in file ServiceApi.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivFramework

ServiceTypes.h File Reference

Header file for various service related classes. More...

#include "ActivMiddleware/ActivFramework/External.h"
#include "ActivMiddleware/ActivBase/Uuid.h"
#include "ActivMiddleware/Misc/SerializableContainerHelper.h"

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::ServiceAccessPoint
Service access point class. More...
class | Activ::ServiceHandle
Parameters to OpenService() apis. More...
class | Activ::ServiceId
Service id class. More...
class | Activ::ServiceInstance
Class representing an instance of a service and its locations. More...
class | Activ::ServiceSubject
Service subject type. By subscribing to this subject, a component can receive notifications of service registration / deregistration. More...

Typedefs

typedef std::vector
< ServiceAccessPoint > 		Activ::ServiceAccessPointList
List of service access points.
typedef std::vector
< ServiceInstance > 		Activ::ServiceInstanceList
List of service instances.

Functions

Activ::ACTIV_DECLARE_MESSAGE_TYPE (1, MESSAGE_CLASS_SERVICE, SERVICE_MESSAGE_DEREGISTER)
Activ::ACTIV_DECLARE_MESSAGE_TYPE (0, MESSAGE_CLASS_SERVICE, SERVICE_MESSAGE_REGISTER)
List of MESSAGE_CLASS_SERVICE message types.
ACTIV_FRAMEWORK_API StatusCode | Activ::ReadServiceAccessPointList (const IniFileParser::ConstSectionIterator &sectionIterator, ServiceAccessPointList &serviceAccessPointList)
Read service access point list from an ini file section.

Detailed Description

Header file for various service related classes.

Log

Definition in file ServiceTypes.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivFramework

Subjects.h File Reference

Header file for framework subject classes. More...

#include "ActivMiddleware/ActivSystem/Subject.h"

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::EndPointSubject
Endpoint subject. More...
class | Activ::ShutdownSubject
Shutdown subject. More...

Detailed Description

Header file for framework subject classes.

Log

Definition in file Subjects.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivFramework

ThinApplication.h File Reference

Header file for thin application class. More...

#include "ActivMiddleware/ActivFramework/External.h"
#include "ActivMiddleware/ActivFramework/Application.h"

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::ThinApplication
Thin application class. More...
class | Activ::ThinApplication::Settings
Settings. More...

Detailed Description

Header file for thin application class.

Log

Definition in file ThinApplication.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivFramework

Timeband.h File Reference

Header file for the timeband class.. More...

#include "ActivMiddleware/ActivFramework/External.h"
#include "ActivMiddleware/ActivBase/IniFileParser.h"
#include "ActivMiddleware/ActivFramework/TimeHelper.h"
#include <bitset>
#include <string>

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::Timeband
Timeband class. More...
class | Activ::Timeband::Settings
Settings class. More...

Detailed Description

Header file for the timeband class..

Log

Definition in file Timeband.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivFramework

TimeHelper.h File Reference

Header file for time helper classes. More...

#include "ActivMiddleware/ActivFramework/External.h"
#include "ActivMiddleware/ActivFieldTypes/DateTime.h"
#include <string>

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::BaseTime
Base time class. More...
class | Activ::BaseTime::Duration
Duration class. More...
class | Activ::LocalTime
Local time class. More...
class | Activ::UtcTime
Utc time class. More...

Functions

const LocalTime | Activ::operator+ (const LocalTime &lhs, const BaseTime::Duration &duration)
Addition operator for the utc time object.
const LocalTime | Activ::operator+ (const LocalTime &lhs, const uint64_t numberOfMilliseconds)
Addition operator for the utc time object.
const UtcTime | Activ::operator+ (const UtcTime &lhs, const BaseTime::Duration &duration)
Addition operator for the utc time object.
const UtcTime | Activ::operator+ (const UtcTime &lhs, const uint64_t numberOfMilliseconds)
Addition operator for the utc time object.

Detailed Description

Header file for time helper classes.

Log

Definition in file TimeHelper.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivFramework

TimerServiceApi.h File Reference

Header file for the timer service api. More...

#include "ActivMiddleware/ActivFramework/External.h"
#include "ActivMiddleware/ActivFramework/TimeHelper.h"

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::TimerServiceApi
Api to the agent's timer service. More...

Detailed Description

Header file for the timer service api.

Log

Definition in file TimerServiceApi.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivFramework

UdpComponent.h File Reference

Header file for udp component class. More...

#include "ActivMiddleware/ActivFramework/External.h"
#include "ActivMiddleware/ActivFramework/Component.h"

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::UdpComponent
Udp ingest component. More...

Detailed Description

Header file for udp component class.

Log

Definition in file UdpComponent.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivFramework

UiComponent.h File Reference

Header file for the ui component class. More...

#include "ActivMiddleware/ActivFramework/External.h"
#include "ActivMiddleware/ActivFramework/Component.h"
#include "ActivMiddleware/ActivFramework/Application.h"

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::UiComponent
Ui component class. More...

Detailed Description

Header file for the ui component class.

Log

Definition in file UiComponent.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivFramework

UiIo.h File Reference

Header file for the ui io class. More...

#include "ActivMiddleware/ActivFramework/External.h"
#include "ActivMiddleware/ActivBase/ConsoleWindow.h"
#include "boost/format.hpp"
#include "boost/bind.hpp"
#include <map>
#include <vector>
#include <iostream>

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::UiIo
Ui io class. Provides methods to get input from and post input to a user. More...
class | Activ::UiIo::Attribute
ANSI display attribute wrapper. More...
class | Activ::UiIo::Columnizer
Helper class to calculate the column sizes to display a number of items. More...
class | Activ::UiIo::CompletionHelper
Base class to handle tab-completion in the ui. More...
class | Activ::UiIo::DynamicCompletionHelper
Class to handle tab-completion with a dynamic list of strings that may be different each time tab is hit. More...
class | Activ::UiIo::StaticCompletionHelper
Class to handle tab-completion with a fixed list of strings. More...

Functions

ACTIV_FRAMEWORK_API std::ostream & | Activ::operator<< (std::ostream &os, const UiIo::Attribute &attribute)
Stream insertion operator for UiIo::Attribute.

Detailed Description

Header file for the ui io class.

Log

Definition in file UiIo.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivFramework

UiMainComponent.h File Reference

Header file for the main ui component class. More...

#include "ActivMiddleware/ActivFramework/External.h"
#include "ActivMiddleware/ActivFramework/UiComponent.h"
#include "ActivMiddleware/ActivFramework/UiMenu.h"
#include "boost/scoped_ptr.hpp"

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::UiMainComponent
Main ui component. More...
class | Activ::UiMainComponent::Menu
Main menu. More...

Detailed Description

Header file for the main ui component class.

Log

Definition in file UiMainComponent.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivFramework

UiMenu.h File Reference

Header file for the ui menu class. More...

#include "ActivMiddleware/ActivFramework/External.h"
#include "ActivMiddleware/ActivFramework/UiPermissions.h"

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::UiMenu
Ui menu class. More...
class | Activ::UiMenu::GlobalOption
Global function option class.
class | Activ::UiMenu::Option
Option class.
class | Activ::UiMenu::OptionAttributes
Option attributes. More...
class | Activ::UiMenu::OptionTemplate< T >
Template for member function options.

Detailed Description

Header file for the ui menu class.

Log

Definition in file UiMenu.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivFramework

UiPermissions.h File Reference

Header file for the ui permissions class. More...

#include "ActivMiddleware/ActivFramework/External.h"

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::UiPermissions
Ui permissions class. More...

Defines

#define | DECLARE_UI_PERMISSIONS(name, bitmap) ACTIV_FRAMEWORK_API static const UiPermissions name;
#define | UI_PERMISSIONS_LIST(d)
Ui permissions list.

Detailed Description

Header file for the ui permissions class.

Log

Definition in file UiPermissions.h.

Define Documentation

#define UI_PERMISSIONS_LIST ( d )

Value:

d(READ,     READ_BIT)                                   \
        d(MODIFY,   (READ_BIT | MODIFY_BIT))                    \
        d(SHUTDOWN, (READ_BIT | SHUTDOWN_BIT))                  \
        d(FULL,     ((0x01 << NUMBER_OF_PERMISSIONS_BITS) - 1))
Ui permissions list.

Definition at line 26 of file UiPermissions.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivIp

External.h File Reference

Import rules for ActivIp exports. More...

#include "ActivMiddleware/Activ.h"

Go to the source code of this file.

Defines

#define ACTIV_IP_API ACTIV_IMPORT_DLL

Detailed Description

Import rules for ActivIp exports.

Log

Definition in file External.h.

Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivIp

IpAddress.h File Reference

Header file for ip address class. More...

#include "ActivMiddleware/ActivIp/External.h"
#include "ActivMiddleware/ActivBase/MessageValidator.h"
#include "ActivMiddleware/ActivBase/MessageBuilder.h"
#include <string>
#include <vector>

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::IpAddress
Protocol independant ip address information. More...

Typedefs

typedef std::vector< IpAddress > | Activ::IpAddressList
Type of list of ip addresses.

Detailed Description

Header file for ip address class.

Log

Definition in file IpAddress.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivIp

IpException.h File Reference

Header file for the Ip exception class. More...

#include "ActivMiddleware/ActivIp/External.h"
#include "ActivMiddleware/ActivBase/Exception.h"

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::IpException
Ip exception class. More...

Defines

#define | ACTIV_IP_EXCEPTION_LIST(d)
The list of possible errors and their strings.

Detailed Description

Header file for the Ip exception class.

Log

Definition in file IpException.h.

Define Documentation

#define ACTIV_IP_EXCEPTION_LIST ( d )

Value:

d(ERROR_UNACCEPTABLE_WINSOCK_VERSION, "unacceptable winsock version")               \
    d(ERROR_INVALID_FUNCTION_POINTER_LENGTH, "invalid function pointer length")         \
    d(ERROR_MULTIPLE_CLOSES_PERFORMED, "multiple closes performed on socket")           \
    d(ERROR_ALREADY_LISTENING, "already listening")                                     \
    d(ERROR_NOT_LISTENING, "not listening")                                             \
    d(ERROR_RX_BUFFER_SIZE_NOT_SET, "rx buffer size not set correctly")                 \
    d(ERROR_TX_BUFFER_SIZE_NOT_SET, "tx buffer size not set correctly")                 \
    d(ERROR_MANAGED_OBJECTS_STILL_EXIST, "managed objects still exist")                 \
    d(ERROR_ADDRESS_FAMILIES_DO_NOT_MATCH, "address families do not match")             \
    d(ERROR_INVALID_ADDRESS_FAMILY, "invalid address family")                           \
    d(ERROR_INTERFACE_INDEX_MISMATCH, "interface index mismatch")                       \
    d(ERROR_FAILED_TO_POST_READ, "failed to post read")
The list of possible errors and their strings.

Note this list is converted to an enum using the ACTIV_DECLARE_ELEMENT_1 macro in Activ.h, and the strings are unpicked using ACTIV_DECLARE_ELEMENT_2.

Definition at line 24 of file IpException.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivIp

IpManager.h File Reference

Header file for base ip manager class. More...

#include "External.h"
#include "Windows/IpManager.h"

Go to the source code of this file.

Namespaces

namespace Activ

Detailed Description

Header file for base ip manager class.

Log

Definition in file IpManager.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivIp

IpSocket.h File Reference

Header file for ip socket class. More...

#include "External.h"
#include "Windows/IpSocket.h"

Go to the source code of this file.

Namespaces

namespace Activ

Detailed Description

Header file for ip socket class.

Log

Definition in file IpSocket.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivIp

SocketWrapper.h File Reference

Header file for socket wrapper class. More...

#include "ActivMiddleware/ActivIp/External.h"

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::SocketWrapper
Socket wrapper class. More...

Detailed Description

Header file for socket wrapper class.

Log

Definition in file SocketWrapper.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivIp

TcpListener.h File Reference

Header file for tcp listener class. More...

#include "External.h"
#include "Windows/TcpListener.h"

Go to the source code of this file.

Detailed Description

Header file for tcp listener class.

Log

Definition in file TcpListener.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivIp

TcpSocket.h File Reference

Header file for tcp socket class. More...

#include "External.h"
#include "Windows/TcpSocket.h"

Go to the source code of this file.

Detailed Description

Header file for tcp socket class.

Log

Definition in file TcpSocket.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivIp

UdpSocket.h File Reference

Header file for udp socket class. More...

#include "External.h"
#include "Windows/UdpSocket.h"

Go to the source code of this file.

Detailed Description

Header file for udp socket class.

Log

Definition in file UdpSocket.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivIp » Windows

IpManager.h File Reference

Header file for base ip manager class. More...

#include "ActivMiddleware/ActivIp/External.h"
#include "ActivMiddleware/ActivIp/IpAddress.h"
#include "ActivMiddleware/ActivIp/SocketWrapper.h"
#include "ActivMiddleware/ActivBase/Windows/IoCompletionManager.h"
#include "ActivMiddleware/ActivBase/IniFileParser.h"
#include <string>
#include <vector>

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::IpManager
Ip manager base class. More...
class | Activ::IpManager::InterfaceInfo
Information on a network interface. More...
class | Activ::IpManager::Settings
Settings. More...

Detailed Description

Header file for base ip manager class.

Log

Definition in file IpManager.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivIp » Windows

IpSocket.h File Reference

Header file for ip socket class. More...

#include "ActivMiddleware/ActivIp/External.h"
#include "ActivMiddleware/ActivIp/IpManager.h"
#include "ActivMiddleware/ActivIp/Windows/WsaBufHelper.h"
#include "ActivMiddleware/ActivIp/SocketWrapper.h"
#include "ActivMiddleware/ActivIp/IpAddress.h"
#include "ActivMiddleware/ActivBase/MutexHelper.h"

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::IpSocket
Base ip socket class. More...
class | Activ::IpSocket::RxOverlapped
Overlapped class for reads. More...
class | Activ::IpSocket::Settings
Settings. More...
class | Activ::IpSocket::Stats
Stats. More...
class | Activ::IpSocket::TxOverlapped
Overlapped class for writes. More...

Detailed Description

Header file for ip socket class.

Log

Definition in file IpSocket.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivIp » Windows

TcpListener.h File Reference

Header file for tcp listener class. More...

#include "ActivMiddleware/ActivIp/External.h"
#include "ActivMiddleware/ActivIp/IpManager.h"
#include "ActivMiddleware/ActivIp/SocketWrapper.h"
#include "ActivMiddleware/ActivIp/IpAddress.h"
#include "ActivMiddleware/ActivBase/MutexHelper.h"

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::TcpListener
TCP listener class. More...

Defines

#define | ACTIV_TCP_LISTENER_STATE_LIST(d)
List of states.

Detailed Description

Header file for tcp listener class.

Log

Definition in file TcpListener.h.

Define Documentation

#define ACTIV_TCP_LISTENER_STATE_LIST ( d )

Value:

d(STATE_NOT_LISTENING)                  \
    d(STATE_LISTENING)
List of states.

Definition at line 21 of file TcpListener.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivIp » Windows

TcpSocket.h File Reference

Header file for tcp socket class. More...

#include "ActivMiddleware/ActivIp/IpSocket.h"
#include <mswsock.h>

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::TcpSocket
TCP socket class. More...
class | Activ::TcpSocket::AcceptOverlapped
Overlapped class for accepts.
class | Activ::TcpSocket::BsdThreadInfo
Sync bsd thread info.
class | Activ::TcpSocket::ConnectOverlapped
Overlapped class for connects.
class | Activ::TcpSocket::ConnectThreadInfo
Sync bsd thread connect info.
class | Activ::TcpSocket::Settings
Settings. More...
class | Activ::TcpSocket::Stats
Stats. More...

Defines

#define | ACTIV_IP_SOCKET_STATE_LIST(d)
List of socket states.

Detailed Description

Header file for tcp socket class.

Log

Definition in file TcpSocket.h.

Define Documentation

#define ACTIV_IP_SOCKET_STATE_LIST ( d )

Value:

d(STATE_INITIALIZED)                \
    d(STATE_W4_CONNECT)                 \
    d(STATE_W4_ACCEPT)                  \
    d(STATE_CONNECTED)                  \
    d(STATE_W4_DISCONNECT)
List of socket states.

Definition at line 19 of file TcpSocket.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivIp » Windows

UdpSocket.h File Reference

Header file for udp socket class. More...

#include "ActivMiddleware/ActivIp/IpSocket.h"

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::UdpSocket
UDP socket class. More...
class | Activ::UdpSocket::Settings
Settings. More...
class | Activ::UdpSocket::Stats
Stats. More...

Defines

#define | ACTIV_UDP_SOCKET_STATE_LIST(d)
States.

Detailed Description

Header file for udp socket class.

Log

Definition in file UdpSocket.h.

Define Documentation

#define ACTIV_UDP_SOCKET_STATE_LIST ( d )

Value:

d(STATE_INITIALIZED)                \
    d(STATE_CREATED)                    \
    d(STATE_CONNECTED)                  \
    d(STATE_CLOSING)
States.

Definition at line 17 of file UdpSocket.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivIp » Windows

WsaBufHelper.h File Reference

Header file for WSABUF helper class. More...

#include "ActivMiddleware/ActivIp/External.h"
#include "ActivMiddleware/ActivBase/CrtException.h"
#include <cassert>

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::WsaBufHelper
WSABUF helper class. More...

Detailed Description

Header file for WSABUF helper class.

Log

Definition in file WsaBufHelper.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivSystem

ActivSystem.h File Reference

Main ActivSystem header. More...

#include "ActivMiddleware/ActivSystem/External.h"
#include "ActivMiddleware/ActivSystem/Address.h"
#include "ActivMiddleware/ActivSystem/HeapMessage.h"
#include "ActivMiddleware/ActivSystem/HeapMessageDeserializer.h"
#include "ActivMiddleware/ActivSystem/IEndPoint.h"
#include "ActivMiddleware/ActivSystem/IHeap.h"
#include "ActivMiddleware/ActivSystem/IProcess.h"
#include "ActivMiddleware/ActivSystem/ISystem.h"
#include "ActivMiddleware/ActivSystem/ManagedEndPoint.h"
#include "ActivMiddleware/ActivSystem/MessageTypes.h"
#include "ActivMiddleware/ActivSystem/Port.h"
#include "ActivMiddleware/ActivSystem/PostMessageHelper.h"
#include "ActivMiddleware/ActivSystem/RequestId.h"
#include "ActivMiddleware/ActivSystem/ScopedAddress.h"
#include "ActivMiddleware/ActivSystem/Subject.h"
#include "ActivMiddleware/ActivSystem/SyncRequestId.h"
#include "ActivMiddleware/ActivSystem/SystemException.h"
#include "ActivMiddleware/ActivSystem/SystemFactory.h"

Go to the source code of this file.

Detailed Description

Main ActivSystem header.

Log

Definition in file ActivSystem.h.

Generated on Wed Oct 8 14:01:50 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivSystem

Address.h File Reference

Address header file. More...

#include "ActivMiddleware/ActivSystem/External.h"
#include "ActivMiddleware/ActivBase/MessageBuilder.h"
#include "ActivMiddleware/ActivBase/MessageValidator.h"
#include "ActivMiddleware/ActivBase/ActivBase.h"

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::Address
Address. More...
class | Activ::Address::Proxy
Address proxy class. Used where an Address or ScopedAddress can be passed to a function. More...

Detailed Description

Address header file.

Log

Definition in file Address.h.

Generated on Wed Oct 8 14:01:51 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivSystem

BasicTypes.h File Reference

Basic types for ActivSystem. More...

#include "ActivMiddleware/Activ.h"
#include <set>

Go to the source code of this file.

Namespaces

namespace | Activ

Typedefs

typedef byte_t | Activ::BucketId
type of bucket ids
typedef uint16_t | Activ::EndPointId
type of endpoint ids
typedef std::set< EndPointId > | Activ::EndPointIdSet
typedef uint16_t | Activ::HeapId
type of heap ids
typedef uintptr_t | Activ::MessageId
MessageId has to be the size of a pointer as in private heaps it is one.
typedef uint16_t | Activ::MessageType
message type
typedef uint16_t | Activ::PortId
type of port ids
typedef uint16_t | Activ::ProcessId
type of process ids

Variables

const BucketId | Activ::INVALID_BUCKET_ID = ~0
invalid bucket id
const EndPointId | Activ::INVALID_ENDPOINT_ID = ~0
invalid endpoint id
const HeapId | Activ::INVALID_HEAP_ID = ~0
invalid heap id
const MessageId | Activ::INVALID_MESSAGE_ID = ~0
invalid message id
const MessageType | Activ::INVALID_MESSAGE_TYPE = ~0
invalid message type
const PortId | Activ::INVALID_PORT_ID = ~0
invalid port id
const ProcessId | Activ::INVALID_PROCESS_ID = ~0
invalid process id

Detailed Description

Basic types for ActivSystem.

Log

Definition in file BasicTypes.h.

Generated on Wed Oct 8 14:01:51 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivSystem

External.h File Reference

Import rules for ActivSystem exports. More...

#include "ActivMiddleware/Activ.h"
#include "ActivMiddleware/ActivSystem/BasicTypes.h"

Go to the source code of this file.

Defines

#define | ACTIV_SYSTEM_EXPORTED_API ACTIV_USING_DLL_EXPORTED_API
#define | ACTIV_SYSTEM_INLINE_API ACTIV_USING_DLL_INLINE_API
#define | ACTIV_SYSTEM_LOCAL_API ACTIV_USING_DLL_LOCAL_API

Detailed Description

Import rules for ActivSystem exports.

Log

Definition in file External.h.

Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivSystem

HeapMessage.h File Reference

Header file for heap message class. More...

#include "ActivMiddleware/ActivSystem/External.h"
#include "ActivMiddleware/ActivSystem/Address.h"
#include "ActivMiddleware/ActivSystem/RequestId.h"
#include "ActivMiddleware/ActivSystem/Subject.h"
#include "ActivMiddleware/ActivIp/IpAddress.h"
#include "ActivMiddleware/ActivBase/StatusCodeException.h"

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::HeapMessage
Heap message class. More...
class | Activ::HeapMessage::Iterator
Heap message iterator class. More...
class | Activ::HeapMessage::Proxy
Proxy class for non-const copy construction.
class | Activ::HeapMessage::ReadHelper
Heap message read helper class. More...
class | Activ::HeapMessage::Stats
Status for a single HeapMessage, ignoring chaining. More...
class | Activ::HeapMessage::WriteHelper
Heap message write helper class. More...

Detailed Description

Header file for heap message class.

Log

Definition in file HeapMessage.h.

Generated on Wed Oct 8 14:01:51 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivSystem

HeapMessageBuilder.h File Reference

Header file for heap message / message builder class. More...

#include "ActivMiddleware/ActivSystem/External.h"
#include "ActivMiddleware/ActivSystem/IHeap.h"
#include "ActivMiddleware/ActivBase/MessageBuilder.h"

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::HeapMessageBuilder
Helper class to build directly into a contiguous HeapMessage. More...

Detailed Description

Header file for heap message / message builder class.

Log

Definition in file HeapMessageBuilder.h.

Generated on Wed Oct 8 14:01:51 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivSystem

HeapMessageDeserializer.h File Reference

Header file for the heap message deserializer template class. More...

#include "ActivMiddleware/ActivSystem/HeapMessage.h"
#include "ActivMiddleware/ActivBase/MessageValidator.h"

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::HeapMessageDeserializer< MESSAGE_TYPE, BUFFER_SIZE >
Template class to wrap up deserializing a HeapMessage. More...

Detailed Description

Header file for the heap message deserializer template class.

Log

Definition in file HeapMessageDeserializer.h.

Generated on Wed Oct 8 14:01:51 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivSystem

HeapPool.h File Reference

Header file for heap pool class. More...

#include "ActivMiddleware/ActivSystem/External.h"
#include "ActivMiddleware/ActivSystem/IHeap.h"
#include <vector>

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::HeapPool
Heap pool. More...

Detailed Description

Header file for heap pool class.

Log

Definition in file HeapPool.h.

Generated on Wed Oct 8 14:01:51 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivSystem

IEndPoint.h File Reference

Header file for abstract endpoint class. More...

#include "ActivMiddleware/ActivSystem/External.h"
#include "ActivMiddleware/ActivSystem/HeapMessage.h"
#include <string>

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::IEndPoint
Abstract endpoint interface class. More...
class | Activ::IEndPoint::Stats
Stats for an endpoint. More...
class | Activ::ISyncEndPoint
Endpoint interface class with sync call support. More...
class | Activ::ISyncEndPoint::Stats
Stats for a shared endpoint. More...

Defines

#define | ACTIV_IENDPOINT_NOTIFICATION_TYPE_LIST(d)
Endpoint data notification types.
#define | ACTIV_IENDPOINT_STATE_LIST(d)
Endpoint states.

Detailed Description

Header file for abstract endpoint class.

Log

Definition in file IEndPoint.h.

Define Documentation

#define ACTIV_IENDPOINT_NOTIFICATION_TYPE_LIST ( d )

Value:

d(NOTIFICATION_TYPE_NONE, "none")                   \
    d(NOTIFICATION_TYPE_SEMAPHORE, "semaphore")         \
    d(NOTIFICATION_TYPE_EVENT, "event")                 \
    d(NOTIFICATION_TYPE_SOCKET, "socket")
Endpoint data notification types.

Definition at line 26 of file IEndPoint.h.

#define ACTIV_IENDPOINT_STATE_LIST ( d )

Value:

d(STATE_ACCEPTING_MESSAGES, "accepting")            \
    d(STATE_IGNORING_MESSAGES, "ignoring")
Endpoint states.

Definition at line 37 of file IEndPoint.h.

Generated on Wed Oct 8 14:01:51 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivSystem

IHeap.h File Reference

Header file for abstract heap class. More...

#include "ActivMiddleware/ActivSystem/External.h"
#include "ActivMiddleware/ActivSystem/HeapMessage.h"
#include "ActivMiddleware/ActivBase/IniFileParser.h"
#include "ActivMiddleware/ActivFieldTypes/DateTime.h"
#include <vector>

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::IHeap
Abstract heap interface class. More...
class | Activ::IHeap::BucketInfo
Heap bucket size information. More...
class | Activ::IHeap::Stats
Heap stats. More...
class | Activ::IHeap::Stats::BucketStats
Individual Bucket stats. More...
class | Activ::IHeap::Stats::RequestDistributionStats
Request distribution stats. More...

Detailed Description

Header file for abstract heap class.

Log

Definition in file IHeap.h.

Generated on Wed Oct 8 14:01:51 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivSystem

IProcess.h File Reference

Header file for process interface class. More...

#include "ActivMiddleware/ActivSystem/External.h"
#include "ActivMiddleware/ActivBase/MessageValidator.h"
#include "ActivMiddleware/ActivBase/MessageBuilder.h"
#include "ActivMiddleware/ActivBase/Process.h"
#include "ActivMiddleware/ActivBase/Timeout.h"
#include <string>

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::IProcess
Process interface class. More...
class | Activ::IProcess::Stats
Process stats. More...

Defines

#define | ACTIV_IPROCESS_STATE_LIST(d)
List of process states.

Detailed Description

Header file for process interface class.

Log

Definition in file IProcess.h.

Define Documentation

#define ACTIV_IPROCESS_STATE_LIST ( d )

Value:

d(STATE_INITIALIZING, "initializing")           \
    d(STATE_RUNNING, "running")                     \
    d(STATE_SHUTTING_DOWN, "shutting down")         \
    d(STATE_EXITED, "exited")                       \
    d(STATE_DEAD, "dead")
List of process states.

Definition at line 23 of file IProcess.h.

Generated on Wed Oct 8 14:01:51 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivSystem

ISystem.h File Reference

Header file for abstract system class. More...

#include "ActivMiddleware/ActivSystem/External.h"
#include "ActivMiddleware/ActivSystem/IProcess.h"
#include "ActivMiddleware/ActivSystem/IEndPoint.h"
#include "ActivMiddleware/ActivSystem/IHeap.h"
#include "ActivMiddleware/ActivBase/IniFileParser.h"
#include "ActivMiddleware/ActivBase/Process.h"
#include "ActivMiddleware/ActivBase/SystemInfo.h"
#include "ActivMiddleware/ActivBase/Timeout.h"
#include "ActivMiddleware/ActivFieldTypes/DateTime.h"

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::ISystem
Abstract system interface class. More...
class | Activ::ISystem::IEndPointEnumerator
Endpoint enumerator callback interface. More...
class | Activ::ISystem::IHeapEnumerator
Heap enumerator callback interface. More...
class | Activ::ISystem::IProcessEnumerator
Process enumerator callback interface. More...
class | Activ::ISystem::Settings
Settings. More...
class | Activ::ISystem::SystemInfo
System information. More...

Detailed Description

Header file for abstract system class.

Log

Definition in file ISystem.h.

Generated on Wed Oct 8 14:01:51 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivSystem

ManagedEndPoint.h File Reference

Header file for managed endpoint class. More...

#include "ActivMiddleware/ActivSystem/External.h"
#include "ActivMiddleware/ActivSystem/IEndPoint.h"
#include "ActivMiddleware/ActivBase/IniFileParser.h"
#include "ActivMiddleware/ActivBase/Thread.h"
#include "boost/scoped_ptr.hpp"
#include <string>

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::ManagedEndPoint
Managed endpoint class. More...
class | Activ::ManagedEndPoint::RunHelper
Helper class to run an endpoint. More...
class | Activ::ManagedEndPoint::Settings
Settings for the endpoint. More...

Detailed Description

Header file for managed endpoint class.

Log

Definition in file ManagedEndPoint.h.

Generated on Wed Oct 8 14:01:51 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivSystem

MessageTypes.h File Reference

Message types. More...

#include "ActivMiddleware/ActivSystem/External.h"
#include <string>

Go to the source code of this file.

Namespaces

namespace | Activ

Defines

#define | ACTIV_DECLARE_MESSAGE_CLASS(value, messageClass, name) const Activ::MessageClass messageClass = value;
Declare a constant message class value.
#define | ACTIV_DECLARE_MESSAGE_TYPE(value, messageClass, name) const Activ::MessageType name = MakeMessageType(messageClass, value)
Declare a constant message type value.
#define | ACTIV_MESSAGE_CLASS_LIST(d)
List of available message classes used by ActivMiddleware.
#define | MakeMessageType(messageClass, subType) ((static_cast<Activ::MessageType>((messageClass)) << 8) | (subType))
Macro to make message type.

Typedefs

typedef byte_t | Activ::MessageClass
Message class type.

Functions

MessageClass | Activ::GetMessageClass (const MessageType messageType)
Get the message class from a message type.
byte_t | Activ::GetSubType (const MessageType messageType)
Get the message subtype from from a message type.
ACTIV_SYSTEM_EXPORTED_API
std::string 		Activ::MessageClassToString (const MessageClass messageClass)
Return message class as a string.
ACTIV_SYSTEM_EXPORTED_API
StatusCode 		Activ::StringToMessageClass (const std::string &str, MessageClass &messageClass)
Convert string to message class. Case sensitive.

Variables

const Activ::MessageType | Activ::LOGGER_MESSAGE_CLOSE_LOG_FILE = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_LOGGER )) << 8) | ( 0 ))
List of MESSAGE_CLASS_LOGGER message types.
const Activ::MessageType | Activ::LOGGER_MESSAGE_LOG_MESSAGE = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_LOGGER )) << 8) | ( 1 ))
const Activ::MessageType | Activ::LOGGER_MESSAGE_SET_LOG_HEADER = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_LOGGER )) << 8) | ( 3 ))
const Activ::MessageType | Activ::LOGGER_MESSAGE_SYSTEM_LOG_MESSAGE = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_LOGGER )) << 8) | ( 2 ))
const Activ::MessageType | Activ::LOGGER_REQUEST_OPEN_LOG_FILE = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_LOGGER )) << 8) | ( 0 ))
List of MESSAGE_CLASS_LOGGER request types.
const Activ::MessageClass | Activ::MESSAGE_CLASS_DATABASE = 8
const Activ::MessageClass | Activ::MESSAGE_CLASS_DIRECTORY = 3
const Activ::MessageClass | Activ::MESSAGE_CLASS_LICENSE = 14
const Activ::MessageClass | Activ::MESSAGE_CLASS_LOGGER = 2
const Activ::MessageClass | Activ::MESSAGE_CLASS_MONITOR = 12
const Activ::MessageClass | Activ::MESSAGE_CLASS_MQ = 6
const Activ::MessageClass | Activ::MESSAGE_CLASS_PUBSUB = 5
const Activ::MessageClass | Activ::MESSAGE_CLASS_ROUTER = 4
const Activ::MessageClass | Activ::MESSAGE_CLASS_SERVICE = 9
const Activ::MessageClass | Activ::MESSAGE_CLASS_SYSTEM = 0
Declare list of constant message class values.
const Activ::MessageClass | Activ::MESSAGE_CLASS_TCP = 11
const Activ::MessageClass | Activ::MESSAGE_CLASS_TIMER = 1
const Activ::MessageClass | Activ::MESSAGE_CLASS_UDP = 10
const Activ::MessageClass | Activ::MESSAGE_CLASS_UI = 7
const Activ::MessageClass | Activ::MESSAGE_CLASS_UPDATE = 13
const Activ::MessageClass | Activ::MESSAGE_CLASS_USER_BASE = 64
const Activ::MessageType | Activ::ROUTER_MESSAGE_DATA = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_ROUTER )) << 8) | ( 15 ))
const Activ::MessageType | Activ::ROUTER_MESSAGE_INTERNAL_DIRECTORY_WATCH_CLOSED = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_ROUTER )) << 8) | ( 34 ))
const Activ::MessageType | Activ::ROUTER_MESSAGE_INTERNAL_DIRECTORY_WATCH_NOTIFICATION = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_ROUTER )) << 8) | ( 16 ))
const Activ::MessageType | Activ::ROUTER_MESSAGE_INTERNAL_SOCKET_ACCEPT = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_ROUTER )) << 8) | ( 3 ))
const Activ::MessageType | Activ::ROUTER_MESSAGE_INTERNAL_SOCKET_ACCEPT_ABORTED = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_ROUTER )) << 8) | ( 5 ))
const Activ::MessageType | Activ::ROUTER_MESSAGE_INTERNAL_SOCKET_ACCEPT_FAILED = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_ROUTER )) << 8) | ( 4 ))
const Activ::MessageType | Activ::ROUTER_MESSAGE_INTERNAL_SOCKET_BREAK = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_ROUTER )) << 8) | ( 6 ))
const Activ::MessageType | Activ::ROUTER_MESSAGE_INTERNAL_SOCKET_CONNECT = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_ROUTER )) << 8) | ( 0 ))
MESSAGE_CLASS_ROUTER message types.
const Activ::MessageType | Activ::ROUTER_MESSAGE_INTERNAL_SOCKET_CONNECT_ABORTED = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_ROUTER )) << 8) | ( 2 ))
const Activ::MessageType | Activ::ROUTER_MESSAGE_INTERNAL_SOCKET_CONNECT_FAILED = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_ROUTER )) << 8) | ( 1 ))
const Activ::MessageType | Activ::ROUTER_MESSAGE_INTERNAL_SOCKET_DISCONNECT = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_ROUTER )) << 8) | ( 7 ))
const Activ::MessageType | Activ::ROUTER_MESSAGE_INTERNAL_SOCKET_LISTENER_CLOSED = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_ROUTER )) << 8) | ( 32 ))
const Activ::MessageType | Activ::ROUTER_MESSAGE_USER_BREAK_ACCEPTED = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_ROUTER )) << 8) | ( 10 ))
const Activ::MessageType | Activ::ROUTER_MESSAGE_USER_BREAK_CONNECTION = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_ROUTER )) << 8) | ( 9 ))
const Activ::MessageType | Activ::ROUTER_MESSAGE_USER_CANCEL_DIRECTORY_WATCH = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_ROUTER )) << 8) | ( 35 ))
const Activ::MessageType | Activ::ROUTER_MESSAGE_USER_CLEAR_SOCKET_STATS_HIGHS = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_ROUTER )) << 8) | ( 33 ))
const Activ::MessageType | Activ::ROUTER_MESSAGE_USER_ENABLE_SOCKET_STATS = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_ROUTER )) << 8) | ( 37 ))
const Activ::MessageType | Activ::ROUTER_MESSAGE_USER_INITIATE_DISCONNECT = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_ROUTER )) << 8) | ( 8 ))
const Activ::MessageType | Activ::ROUTER_MESSAGE_USER_NOTIFY_CIRCUIT_BREAK = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_ROUTER )) << 8) | ( 14 ))
const Activ::MessageType | Activ::ROUTER_MESSAGE_USER_NOTIFY_CIRCUIT_DOWN = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_ROUTER )) << 8) | ( 13 ))
const Activ::MessageType | Activ::ROUTER_MESSAGE_USER_NOTIFY_CIRCUIT_FAILED = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_ROUTER )) << 8) | ( 31 ))
const Activ::MessageType | Activ::ROUTER_MESSAGE_USER_NOTIFY_CIRCUIT_UP = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_ROUTER )) << 8) | ( 12 ))
const Activ::MessageType | Activ::ROUTER_MESSAGE_USER_NOTIFY_DIRECTORY_WATCH_EVENTS = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_ROUTER )) << 8) | ( 36 ))
const Activ::MessageType | Activ::ROUTER_MESSAGE_USER_NOTIFY_SOCKET_STATS = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_ROUTER )) << 8) | ( 38 ))
const Activ::MessageType | Activ::ROUTER_MESSAGE_USER_NOTIFY_UDP_SOCKET_ERROR = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_ROUTER )) << 8) | ( 26 ))
const Activ::MessageType | Activ::ROUTER_MESSAGE_USER_NOTIFY_UDP_SOCKET_SHUTDOWN = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_ROUTER )) << 8) | ( 27 ))
const Activ::MessageType | Activ::ROUTER_MESSAGE_USER_SET_HEAP = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_ROUTER )) << 8) | ( 30 ))
const Activ::MessageType | Activ::ROUTER_MESSAGE_USER_SET_MAX_TX_QUEUE_SIZE = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_ROUTER )) << 8) | ( 17 ))
const Activ::MessageType | Activ::ROUTER_MESSAGE_USER_STOP_LISTEN = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_ROUTER )) << 8) | ( 11 ))
const Activ::MessageType | Activ::ROUTER_MESSAGE_USER_UDP_READ = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_ROUTER )) << 8) | ( 18 ))
const Activ::MessageType | Activ::ROUTER_REQUEST_INTERNAL_FIN = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_ROUTER )) << 8) | ( 8 ))
const Activ::MessageType | Activ::ROUTER_REQUEST_INTERNAL_SYN = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_ROUTER )) << 8) | ( 7 ))
const Activ::MessageType | Activ::ROUTER_REQUEST_USER_ADD_DIRECTORY_WATCH = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_ROUTER )) << 8) | ( 5 ))
const Activ::MessageType | Activ::ROUTER_REQUEST_USER_ALLOCATE_CLIENT = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_ROUTER )) << 8) | ( 1 ))
const Activ::MessageType | Activ::ROUTER_REQUEST_USER_ASYNC_CONNECT = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_ROUTER )) << 8) | ( 0 ))
MESSAGE_CLASS_ROUTER request types.
const Activ::MessageType | Activ::ROUTER_REQUEST_USER_GET_SOCKET_HANDLE = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_ROUTER )) << 8) | ( 12 ))
const Activ::MessageType | Activ::ROUTER_REQUEST_USER_INITIATE_CONNECT = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_ROUTER )) << 8) | ( 2 ))
const Activ::MessageType | Activ::ROUTER_REQUEST_USER_INITIATE_DISCONNECT = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_ROUTER )) << 8) | ( 3 ))
const Activ::MessageType | Activ::ROUTER_REQUEST_USER_NOTIFY_ACCEPT_CONNECTION = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_ROUTER )) << 8) | ( 9 ))
const Activ::MessageType | Activ::ROUTER_REQUEST_USER_START_LISTEN = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_ROUTER )) << 8) | ( 4 ))
const Activ::MessageType | Activ::ROUTER_REQUEST_USER_UDP_CLEAR_MULTICAST_LOOPBACK = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_ROUTER )) << 8) | ( 23 ))
const Activ::MessageType | Activ::ROUTER_REQUEST_USER_UDP_CONNECT = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_ROUTER )) << 8) | ( 13 ))
const Activ::MessageType | Activ::ROUTER_REQUEST_USER_UDP_DISCONNECT = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_ROUTER )) << 8) | ( 14 ))
const Activ::MessageType | Activ::ROUTER_REQUEST_USER_UDP_INIT = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_ROUTER )) << 8) | ( 10 ))
const Activ::MessageType | Activ::ROUTER_REQUEST_USER_UDP_MULTICAST_JOIN = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_ROUTER )) << 8) | ( 15 ))
const Activ::MessageType | Activ::ROUTER_REQUEST_USER_UDP_MULTICAST_LEAVE = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_ROUTER )) << 8) | ( 16 ))
const Activ::MessageType | Activ::ROUTER_REQUEST_USER_UDP_SET_MULTICAST_INTERFACE = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_ROUTER )) << 8) | ( 19 ))
const Activ::MessageType | Activ::ROUTER_REQUEST_USER_UDP_SET_MULTICAST_LOOPBACK = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_ROUTER )) << 8) | ( 22 ))
const Activ::MessageType | Activ::ROUTER_REQUEST_USER_UDP_SET_MULTICAST_TTL = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_ROUTER )) << 8) | ( 17 ))
const Activ::MessageType | Activ::ROUTER_REQUEST_USER_UDP_SET_RX_BUFFER_SIZE = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_ROUTER )) << 8) | ( 20 ))
const Activ::MessageType | Activ::ROUTER_REQUEST_USER_UDP_SET_TX_BUFFER_SIZE = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_ROUTER )) << 8) | ( 21 ))
const Activ::MessageType | Activ::ROUTER_REQUEST_USER_UDP_SET_UNICAST_TTL = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_ROUTER )) << 8) | ( 18 ))
const Activ::MessageType | Activ::ROUTER_REQUEST_USER_UDP_SHUTDOWN = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_ROUTER )) << 8) | ( 11 ))
const Activ::MessageType | Activ::SYSTEM_MESSAGE_CLOSE_ADDRESS = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_SYSTEM )) << 8) | ( 11 ))
const Activ::MessageType | Activ::SYSTEM_MESSAGE_CTRL_EVENT = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_SYSTEM )) << 8) | ( 1 ))
const Activ::MessageType | Activ::SYSTEM_MESSAGE_ENDPOINT_DIE = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_SYSTEM )) << 8) | ( 7 ))
const Activ::MessageType | Activ::SYSTEM_MESSAGE_ENDPOINT_PAUSE = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_SYSTEM )) << 8) | ( 9 ))
const Activ::MessageType | Activ::SYSTEM_MESSAGE_ENDPOINT_RESUME = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_SYSTEM )) << 8) | ( 10 ))
const Activ::MessageType | Activ::SYSTEM_MESSAGE_ENDPOINT_SHUTDOWN = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_SYSTEM )) << 8) | ( 6 ))
const Activ::MessageType | Activ::SYSTEM_MESSAGE_ENDPOINT_STARTUP = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_SYSTEM )) << 8) | ( 5 ))
const Activ::MessageType | Activ::SYSTEM_MESSAGE_HEAP_STARTUP = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_SYSTEM )) << 8) | ( 8 ))
const Activ::MessageType | Activ::SYSTEM_MESSAGE_KILL_PROCESSES = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_SYSTEM )) << 8) | ( 12 ))
const Activ::MessageType | Activ::SYSTEM_MESSAGE_NOP = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_SYSTEM )) << 8) | ( 13 ))
const Activ::MessageType | Activ::SYSTEM_MESSAGE_PROCESS_SHUTDOWN = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_SYSTEM )) << 8) | ( 4 ))
const Activ::MessageType | Activ::SYSTEM_MESSAGE_PROCESS_STARTUP = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_SYSTEM )) << 8) | ( 3 ))
const Activ::MessageType | Activ::SYSTEM_MESSAGE_SYSTEM_SHUTDOWN = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_SYSTEM )) << 8) | ( 2 ))
const Activ::MessageType | Activ::SYSTEM_MESSAGE_THREAD_EXIT = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_SYSTEM )) << 8) | ( 0 ))
List of MESSAGE_CLASS_SYSTEM message types.
const Activ::MessageType | Activ::SYSTEM_REQUEST_FIND_PORT = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_SYSTEM )) << 8) | ( 0 ))
List of MESSAGE_CLASS_SYSTEM request types.
const Activ::MessageType | Activ::SYSTEM_REQUEST_GET_PORT_INFO_LIST = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_SYSTEM )) << 8) | ( 3 ))
const Activ::MessageType | Activ::SYSTEM_REQUEST_PING_PORT = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_SYSTEM )) << 8) | ( 1 ))
const Activ::MessageType | Activ::SYSTEM_REQUEST_TOKEN = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_SYSTEM )) << 8) | ( 2 ))
const Activ::MessageType | Activ::TIMER_MESSAGE_CANCEL_TIMER = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_TIMER )) << 8) | ( 0 ))
List of MESSAGE_CLASS_TIMER message types.
const Activ::MessageType | Activ::TIMER_MESSAGE_ON_TIMER = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_TIMER )) << 8) | ( 1 ))
const Activ::MessageType | Activ::TIMER_REQUEST_ADJUST_SYSTEM_TIME = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_TIMER )) << 8) | ( 2 ))
const Activ::MessageType | Activ::TIMER_REQUEST_GET_CURRENT_TIME_OBJECT = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_TIMER )) << 8) | ( 1 ))
const Activ::MessageType | Activ::TIMER_REQUEST_SET_TIMER = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_TIMER )) << 8) | ( 0 ))
List of MESSAGE_CLASS_TIMER request types.
const Activ::MessageType | Activ::UDP_MESSAGE_DATA = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_UDP )) << 8) | ( 0 ))
Messages used internally by udp users (pub sub, udp transmitter etc).
const Activ::MessageType | Activ::UDP_MESSAGE_FLUSH = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_UDP )) << 8) | ( 4 ))
const Activ::MessageType | Activ::UDP_MESSAGE_NON_CRITICAL_DATA = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_UDP )) << 8) | ( 6 ))
const Activ::MessageType | Activ::UDP_MESSAGE_SHUTDOWN = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_UDP )) << 8) | ( 3 ))
const Activ::MessageType | Activ::UDP_MESSAGE_SINGLE_MESSAGE = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_UDP )) << 8) | ( 5 ))
const Activ::MessageType | Activ::UDP_MESSAGE_SOCKET_CLOSED = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_UDP )) << 8) | ( 2 ))
const Activ::MessageType | Activ::UDP_MESSAGE_SOCKET_OPEN = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_UDP )) << 8) | ( 1 ))
const Activ::MessageType | Activ::UI_MESSAGE_CLEAR_INPUT = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_UI )) << 8) | ( 14 ))
const Activ::MessageType | Activ::UI_MESSAGE_CLOSE_TUNNEL = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_UI )) << 8) | ( 17 ))
const Activ::MessageType | Activ::UI_MESSAGE_DEREGISTER_COMPONENT = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_UI )) << 8) | ( 1 ))
const Activ::MessageType | Activ::UI_MESSAGE_DESTROY = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_UI )) << 8) | ( 3 ))
const Activ::MessageType | Activ::UI_MESSAGE_INITIATE_TUNNEL = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_UI )) << 8) | ( 16 ))
const Activ::MessageType | Activ::UI_MESSAGE_LOG_OUTPUT = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_UI )) << 8) | ( 8 ))
const Activ::MessageType | Activ::UI_MESSAGE_OUTPUT = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_UI )) << 8) | ( 4 ))
const Activ::MessageType | Activ::UI_MESSAGE_PARTIAL_USER_INPUT = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_UI )) << 8) | ( 11 ))
const Activ::MessageType | Activ::UI_MESSAGE_REGISTER_COMPONENT = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_UI )) << 8) | ( 0 ))
List of MESSAGE_CLASS_UI message types.
const Activ::MessageType | Activ::UI_MESSAGE_RESET_MENU = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_UI )) << 8) | ( 7 ))
const Activ::MessageType | Activ::UI_MESSAGE_RETURN_TO_MAIN_COMPONENT = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_UI )) << 8) | ( 6 ))
const Activ::MessageType | Activ::UI_MESSAGE_SET_INPUT = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_UI )) << 8) | ( 12 ))
const Activ::MessageType | Activ::UI_MESSAGE_SHARED_OUTPUT = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_UI )) << 8) | ( 9 ))
const Activ::MessageType | Activ::UI_MESSAGE_SHARED_SESSION_CLOSED = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_UI )) << 8) | ( 10 ))
const Activ::MessageType | Activ::UI_MESSAGE_SWITCH_TO_COMPONENT = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_UI )) << 8) | ( 5 ))
const Activ::MessageType | Activ::UI_MESSAGE_UNBUFFERED_OUTPUT = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_UI )) << 8) | ( 13 ))
const Activ::MessageType | Activ::UI_MESSAGE_USER_INPUT = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_UI )) << 8) | ( 2 ))
const Activ::MessageType | Activ::UI_MESSAGE_USER_UPDATE = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_UI )) << 8) | ( 15 ))
const Activ::MessageType | Activ::UI_REQUEST_NEW_USER = ((static_cast<Activ::MessageType>(( MESSAGE_CLASS_UI )) << 8) | ( 0 ))
List of MESSAGE_CLASS_UI request types.

Detailed Description

Message types.

Log

Definition in file MessageTypes.h.

Define Documentation

#define ACTIV_MESSAGE_CLASS_LIST ( d )

Value:

d(0,    MESSAGE_CLASS_SYSTEM,           "System")                       \
    d(1,    MESSAGE_CLASS_TIMER,            "Timer")                        \
    d(2,    MESSAGE_CLASS_LOGGER,           "Logger")                       \
    d(3,    MESSAGE_CLASS_DIRECTORY,        "Directory")                    \
    d(4,    MESSAGE_CLASS_ROUTER,           "Router")                       \
    d(5,    MESSAGE_CLASS_PUBSUB,           "Pub-Sub")                      \
    d(6,    MESSAGE_CLASS_MQ,               "Message-Queue")                \
    d(7,    MESSAGE_CLASS_UI,               "UI")                           \
    d(8,    MESSAGE_CLASS_DATABASE,         "Database")                     \
    d(9,    MESSAGE_CLASS_SERVICE,          "Service")                      \
    d(10,   MESSAGE_CLASS_UDP,              "Udp")                          \
    d(11,   MESSAGE_CLASS_TCP,              "Tcp")                          \
    d(12,   MESSAGE_CLASS_MONITOR,          "Monitor")                      \
    d(13,   MESSAGE_CLASS_UPDATE,           "Update")                       \
    d(14,   MESSAGE_CLASS_LICENSE,          "License")                      \
    d(64,   MESSAGE_CLASS_USER_BASE,        "User")
List of available message classes used by ActivMiddleware.

Definition at line 27 of file MessageTypes.h.

#define MakeMessageType | ( | messageClass,
 |  | subType | ) | ((static_cast<Activ::MessageType>((messageClass)) << 8) | (subType))

Macro to make message type.

Parameters:
messageClass | the message class of the type.
subType | the message subtype within messageClass.

Definition at line 86 of file MessageTypes.h.

Generated on Wed Oct 8 14:01:51 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivSystem

Port.h File Reference

Header file for port class. More...

#include "ActivMiddleware/ActivSystem/External.h"
#include "ActivMiddleware/ActivSystem/Address.h"
#include "ActivMiddleware/ActivSystem/ManagedEndPoint.h"
#include "ActivMiddleware/ActivBase/Atomic.h"

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::Port
Port class. More...
class | Activ::Port::Enabler
Helper class to enable & disable a Port. More...

Detailed Description

Header file for port class.

Log

Definition in file Port.h.

Generated on Wed Oct 8 14:01:51 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivSystem

PostMessageHelper.h File Reference

Header file for PostMessageHelper. More...

#include "ActivMiddleware/ActivSystem/External.h"
#include "ActivMiddleware/ActivSystem/Port.h"

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::PostMessageHelper
Helper class to post messages. More...

Detailed Description

Header file for PostMessageHelper.

Log

Definition in file PostMessageHelper.h.

Generated on Wed Oct 8 14:01:51 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivSystem

RequestId.h File Reference

Header file for request id class. More...

#include "ActivMiddleware/ActivSystem/External.h"
#include "ActivMiddleware/ActivSystem/Address.h"
#include "ActivMiddleware/ActivBase/ActivBase.h"
#include "ActivMiddleware/Misc/MemoryHelper.h"
#include <cassert>
#include <string>

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::RequestId
Request id class. More...

Detailed Description

Header file for request id class.

Log

Definition in file RequestId.h.

Generated on Wed Oct 8 14:01:51 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivSystem

ScopedAddress.h File Reference

ScopedAddress header file. More...

#include "ActivMiddleware/ActivSystem/External.h"
#include "ActivMiddleware/ActivSystem/Address.h"

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::ScopedAddress
Scoped address. More...
class | Activ::ScopedAddress::Proxy
ScopedAddress proxy class. More...

Detailed Description

ScopedAddress header file.

Log

Definition in file ScopedAddress.h.

Generated on Wed Oct 8 14:01:51 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivSystem

Subject.h File Reference

Subject type header file. More...

#include "ActivMiddleware/ActivSystem/External.h"
#include "ActivMiddleware/ActivSystem/MessageTypes.h"
#include "ActivMiddleware/Misc/MemoryHelper.h"

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::Subject
Subject class. More...

Detailed Description

Subject type header file.

Log

Definition in file Subject.h.

Generated on Wed Oct 8 14:01:51 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivSystem

SyncRequestId.h File Reference

Header file for synchronous request id class. More...

#include "ActivMiddleware/ActivSystem/External.h"
#include "ActivMiddleware/ActivSystem/RequestId.h"

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::SyncRequestId
Synchronous request id class. More...

Detailed Description

Header file for synchronous request id class.

Log

Definition in file SyncRequestId.h.

Generated on Wed Oct 8 14:01:51 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivSystem

SystemException.h File Reference

Header file for ActivSystem exception class. More...

#include "ActivMiddleware/ActivSystem/External.h"
#include "ActivMiddleware/ActivBase/Exception.h"

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::SystemException
ActivSystem exception class. More...

Defines

#define | ACTIV_SYSTEM_EXCEPTION_LIST(d)
The list of possible errors and their strings.

Detailed Description

Header file for ActivSystem exception class.

Log

Definition in file SystemException.h.

Define Documentation

#define ACTIV_SYSTEM_EXCEPTION_LIST ( d )

Value:

d(ERROR_FAILED_TO_ALLOC_MESSAGE_ARRAY, "failed to allocate message array")              \
    d(ERROR_FAILED_TO_ALLOC_SYSTEM, "failed to allocate system")                            \
    d(ERROR_FAILED_TO_ALLOC_PROCESS, "failed to allocate process")                          \
    d(ERROR_FAILED_TO_ALLOC_PROCESS_TABLE, "failed to allocate process table")              \
    d(ERROR_PROCESS_DOES_NOT_EXIST, "process does not exist")                               \
    d(ERROR_FAILED_TO_ALLOC_ENDPOINT, "failed to allocate endpoint")                        \
    d(ERROR_FAILED_TO_ALLOC_ENDPOINT_TABLE, "failed to allocate endpoint table")            \
    d(ERROR_ENDPOINT_DOES_NOT_EXIST, "endpoint does not exist")                             \
    d(ERROR_FAILED_TO_ALLOC_HEAP, "failed to allocate heap")                                \
    d(ERROR_FAILED_TO_ALLOC_HEAP_TABLE, "failed to allocate heap table")                    \
    d(ERROR_HEAP_DOES_NOT_EXIST, "heap does not exist")                                     \
    d(ERROR_INVALID_NUMBER_OF_BUCKETS, "invalid number of buckets")                         \
    d(ERROR_INVALID_BLOCK_SIZE, "invalid block size (probably 0)")                          \
    d(ERROR_INVALID_HEAP_ID, "invalid heap id")                                             \
    d(ERROR_INVALID_ENDPOINT_ID, "invalid endpoint id")                                     \
    d(ERROR_INVALID_PROCESS_ID, "invalid process id")                                       \
    d(ERROR_PORT_IN_USE, "port in use")                                                     \
    d(ERROR_INVALID_PROCESS_STATE, "invalid process state")                                 \
    d(ERROR_UNKNOWN_SYSTEM_LOG_MODE, "unknown system log mode")                             \
    d(ERROR_INVALID_MEMORY_MODEL, "invalid memory model")
The list of possible errors and their strings.

Note this list is converted to an enum using the ACTIV_DECLARE_ELEMENT_1 macro in Activ.h, and the strings are unpicked using ACTIV_DECLARE_ELEMENT_2.

Definition at line 21 of file SystemException.h.

Generated on Wed Oct 8 14:01:51 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivSystem

SystemFactory.h File Reference

Header file for system factory class. More...

#include "ActivMiddleware/ActivSystem/External.h"
#include "ActivMiddleware/ActivSystem/ISystem.h"
#include "ActivMiddleware/Misc/Singleton.h"

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::SystemFactory
System factory class. More...

Detailed Description

Header file for system factory class.

Log

Definition in file SystemFactory.h.

Generated on Wed Oct 8 14:01:51 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » Config

Config.h File Reference

Processor, compiler and platform selection header file. More...

#include "Compilers/SunPro.h"
#include "Platforms/Windows.h"

Go to the source code of this file.

Namespaces

namespace | Activ

Defines

#define | ACTIV_EXPORT_DLL ACTIV_BUILDING_DLL_EXPORTED_API
#define | ACTIV_EXPORT_LIB ACTIV_BUILDING_LIB_EXPORTED_API
#define | ACTIV_IMPORT_DLL ACTIV_USING_DLL_EXPORTED_API
#define | ACTIV_IMPORT_LIB ACTIV_USING_LIB_EXPORTED_API

Enumerations

enum PlatformType {
PLATFORM_TYPE_UNKNOWN, PLATFORM_TYPE_LINUX, PLATFORM_TYPE_WINDOWS, PLATFORM_TYPE_BSD,
PLATFORM_TYPE_OSX, PLATFORM_TYPE_SOLARIS
}
Enumeration of platforms. More...

Detailed Description

Processor, compiler and platform selection header file.

Log

Definition in file Config.h.

Generated on Wed Oct 8 14:01:51 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » Config » Compilers

GCC.h File Reference

GNU C++ configuration file. More...

Go to the source code of this file.

Defines

#define | ACTIV_BUILDING_DLL_EXPORTED_API
#define | ACTIV_BUILDING_DLL_INLINE_API
#define | ACTIV_BUILDING_DLL_LOCAL_API
#define | ACTIV_BUILDING_LIB_EXPORTED_API
#define | ACTIV_BUILDING_LIB_INLINE_API
#define | ACTIV_BUILDING_LIB_LOCAL_API
#define | ACTIV_COMPILER_NAME "GNU C++ version " ACTIV_STRINGIZE(__GNUC__) "." ACTIV_STRINGIZE(__GNUC_MINOR__)
#define | ACTIV_DECLARE_UNINITIALIZED_VARIABLE(type, name, dummyValue) type name = dummyValue
Declare an "uninitialized" variable such that it does not create a compilation warning.
#define | ACTIV_FORCE_INLINE inline __attribute__((__always_inline__))
Ensure a function is always inlined.
#define | ACTIV_NEVER_INLINE __attribute__((__noinline__))
Ensure a function is never inlined.
#define | ACTIV_TEMPLATE_API(a)
Define rules for exporting template member functions.
#define | ACTIV_TEMPLATE_SELF class
Declare a type in a template parameter list.
#define | ACTIV_USING_DLL_EXPORTED_API
#define | ACTIV_USING_DLL_INLINE_API
#define | ACTIV_USING_DLL_LOCAL_API
#define | ACTIV_USING_LIB_EXPORTED_API
#define | ACTIV_USING_LIB_INLINE_API
#define | ACTIV_USING_LIB_LOCAL_API
#define | stricmp strcasecmp
#define | strnicmp strncasecmp

Detailed Description

GNU C++ configuration file.

Log

Definition in file GCC.h.

Define Documentation

#define ACTIV_DECLARE_UNINITIALIZED_VARIABLE | ( | type,
 |  | name,
 |  | dummyValue | ) | type name = dummyValue

Declare an "uninitialized" variable such that it does not create a compilation warning.

Certain compilers (e.g. gcc 3.4) are not "intelligent" enough to figure out that an uninitialized variable will be initialized before use in all code paths. Use this macro to declare and intialize such a variable with a dummy value to bypass such warnings. With compilers that do not suffer from this problem, this macro just declares the variable unitialized.

Definition at line 58 of file GCC.h.

#define ACTIV_TEMPLATE_API ( a )

Define rules for exporting template member functions.

The Intel & Visual C++ compilers have different rules for __declspec exporting template instantiations from dlls. Use ACTIV_TEMPLATE_API as a workaround, e.g.

class Example { template <typename T> ACTIV_TEMPLATE_API(MY_LIB_API) void Fn(T &); };

Parameters:
a __declspec macro, e.g. ACTIV_BASE_EXPORTED_API.

Definition at line 76 of file GCC.h.

#define ACTIV_TEMPLATE_SELF class

Declare a type in a template parameter list.

When using the curiously recurring template pattern, e.g.

template<...> class Derived : public Base<Derived, ...>

under GCC requires

template<...> class Derived : public Base<class Derived, ...>

but Visual C++ won't accept that (it will accept typename). Use this macro as a workaround, e.g.

template<...> class Derived : public Base<ACTIV_TEMPLATE_SELF Derived, ...>

Definition at line 95 of file GCC.h.

Generated on Wed Oct 8 14:01:51 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » Config » Compilers

Intel.h File Reference

Intel C++ Compiler configuration file. More...

Go to the source code of this file.

Defines

#define | ACTIV_BUILDING_DLL_EXPORTED_API __declspec (dllexport)
#define | ACTIV_BUILDING_DLL_INLINE_API
#define | ACTIV_BUILDING_DLL_LOCAL_API
#define | ACTIV_BUILDING_LIB_EXPORTED_API
#define | ACTIV_BUILDING_LIB_INLINE_API
#define | ACTIV_BUILDING_LIB_LOCAL_API
#define | ACTIV_COMPILER_NAME "Intel C++ Compiler version " ACTIV_STRINGIZE(__INTEL_COMPILER)
#define | ACTIV_DECLARE_UNINITIALIZED_VARIABLE(type, name, dummyValue) type name
Declare an "uninitialized" variable such that it does not create a compilation warning.
#define | ACTIV_TEMPLATE_API(a)
Define rules for exporting template member functions.
#define | ACTIV_USING_DLL_EXPORTED_API __declspec (dllimport)
#define | ACTIV_USING_DLL_INLINE_API
#define | ACTIV_USING_DLL_LOCAL_API
#define | ACTIV_USING_LIB_EXPORTED_API
#define | ACTIV_USING_LIB_INLINE_API
#define | ACTIV_USING_LIB_LOCAL_API
#define | snprintf _snprintf
#define | vsnprintf _vsnprintf

Detailed Description

Intel C++ Compiler configuration file.

Log

Definition in file Intel.h.

Define Documentation

#define ACTIV_DECLARE_UNINITIALIZED_VARIABLE | ( | type,
 |  | name,
 |  | dummyValue | ) | type name

Declare an "uninitialized" variable such that it does not create a compilation warning.

Certain compilers (e.g. gcc 3.4) are not "intelligent" enough to figure out that an uninitialized variable will be initialized before use in all code paths. Use this macro to declare and intialize such a variable with a dummy value to bypass such warnings. With compilers that do not suffer from this problem, this macro just declares the variable unitialized.

Definition at line 36 of file Intel.h.

#define ACTIV_TEMPLATE_API ( a )

Define rules for exporting template member functions.

The Intel & Visual C++ compilers have different rules for __declspec exporting template instantiations from dlls. Use ACTIV_TEMPLATE_API as a workaround, e.g.

class Example { template <typename T> ACTIV_TEMPLATE_API(MY_LIB_API) void Fn(T &); };

Parameters:
a __declspec macro, e.g. ACTIV_BASE_EXPORTED_API.

Definition at line 52 of file Intel.h.

Generated on Wed Oct 8 14:01:51 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » Config » Compilers

SunPro.h File Reference

SunPro C++ configuration file. More...

Go to the source code of this file.

Defines

#define | __EXTENSIONS__
#define | __FUNCTION__ __func__
#define | _POSIX_PTHREAD_SEMANTICS
#define | _XPG4_2
#define | ACTIV_BUILDING_DLL_EXPORTED_API
#define | ACTIV_BUILDING_DLL_INLINE_API
#define | ACTIV_BUILDING_DLL_LOCAL_API
#define | ACTIV_BUILDING_LIB_EXPORTED_API
#define | ACTIV_BUILDING_LIB_INLINE_API
#define | ACTIV_BUILDING_LIB_LOCAL_API
#define | ACTIV_COMPILER_NAME "SunPro C++ version " ACTIV_STRINGIZE(__SUNPRO_CC)
#define | ACTIV_DECLARE_UNINITIALIZED_VARIABLE(type, name, dummyValue) type name
Declare an "uninitialized" variable such that it does not create a compilation warning.
#define | ACTIV_FORCE_INLINE inline
Ensure a function is always inlined.
#define | ACTIV_NEVER_INLINE
Ensure a function is never inlined.
#define | ACTIV_TEMPLATE_API(a)
Define rules for exporting template member functions.
#define | ACTIV_TEMPLATE_SELF typename
Declare a type in a template parameter list.
#define | ACTIV_USING_DLL_EXPORTED_API
#define | ACTIV_USING_DLL_INLINE_API
#define | ACTIV_USING_DLL_LOCAL_API
#define | ACTIV_USING_LIB_EXPORTED_API
#define | ACTIV_USING_LIB_INLINE_API
#define | ACTIV_USING_LIB_LOCAL_API
#define | stricmp strcasecmp
#define | strnicmp strncasecmp

Detailed Description

SunPro C++ configuration file.

Log

Definition in file SunPro.h.

Define Documentation

#define ACTIV_DECLARE_UNINITIALIZED_VARIABLE | ( | type,
 |  | name,
 |  | dummyValue | ) | type name

Declare an "uninitialized" variable such that it does not create a compilation warning.

Certain compilers (e.g. gcc 3.4) are not "intelligent" enough to figure out that an uninitialized variable will be initialized before use in all code paths. Use this macro to declare and intialize such a variable with a dummy value to bypass such warnings. With compilers that do not suffer from this problem, this macro just declares the variable unitialized.

Definition at line 40 of file SunPro.h.

#define ACTIV_TEMPLATE_API ( a )

Define rules for exporting template member functions.

The Intel & Visual C++ compilers have different rules for __declspec exporting template instantiations from dlls. Use ACTIV_TEMPLATE_API as a workaround, e.g.

class Example { template <typename T> ACTIV_TEMPLATE_API(MY_LIB_API) void Fn(T &); };

Parameters:
a __declspec macro, e.g. ACTIV_BASE_EXPORTED_API.

Definition at line 56 of file SunPro.h.

#define ACTIV_TEMPLATE_SELF typename

Declare a type in a template parameter list.

When using the curiously recurring template pattern, e.g.

template<...> class Derived : public Base<Derived, ...>

under GCC requires

template<...> class Derived : public Base<class Derived, ...>

but Visual C++ won't accept that (it will accept typename). Use this macro as a workaround, e.g.

template<...> class Derived : public Base<ACTIV_TEMPLATE_SELF Derived, ...>

Definition at line 73 of file SunPro.h.

Generated on Wed Oct 8 14:01:51 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » Config » Compilers

VisualC.h File Reference

Microsoft Visual C++ configuration file. More...

Go to the source code of this file.

Defines

#define | ACTIV_BUILDING_DLL_EXPORTED_API __declspec (dllexport)
#define | ACTIV_BUILDING_DLL_INLINE_API
#define | ACTIV_BUILDING_DLL_LOCAL_API
#define | ACTIV_BUILDING_LIB_EXPORTED_API
#define | ACTIV_BUILDING_LIB_INLINE_API
#define | ACTIV_BUILDING_LIB_LOCAL_API
#define | ACTIV_COMPILER_NAME "Microsoft Visual C++ version " ACTIV_STRINGIZE(_MSC_VER)
#define | ACTIV_DECLARE_UNINITIALIZED_VARIABLE(type, name, dummyValue) type name
Declare an "uninitialized" variable such that it does not create a compilation warning.
#define | ACTIV_FORCE_INLINE __forceinline
Ensure a function is always inlined.
#define | ACTIV_NEVER_INLINE __declspec(noinline)
Ensure a function is never inlined.
#define | ACTIV_TEMPLATE_API(a) a
Define rules for exporting template member functions.
#define | ACTIV_TEMPLATE_SELF typename
Declare a type in a template parameter list.
#define | ACTIV_USING_DLL_EXPORTED_API __declspec (dllimport)
#define | ACTIV_USING_DLL_INLINE_API
#define | ACTIV_USING_DLL_LOCAL_API
#define | ACTIV_USING_LIB_EXPORTED_API
#define | ACTIV_USING_LIB_INLINE_API
#define | ACTIV_USING_LIB_LOCAL_API
#define | snprintf _snprintf
#define | vsnprintf _vsnprintf

Detailed Description

Microsoft Visual C++ configuration file.

Log

Definition in file VisualC.h.

Define Documentation

#define ACTIV_DECLARE_UNINITIALIZED_VARIABLE | ( | type,
 |  | name,
 |  | dummyValue | ) | type name

Declare an "uninitialized" variable such that it does not create a compilation warning.

Certain compilers (e.g. gcc 3.4) are not "intelligent" enough to figure out that an uninitialized variable will be initialized before use in all code paths. Use this macro to declare and intialize such a variable with a dummy value to bypass such warnings. With compilers that do not suffer from this problem, this macro just declares the variable unitialized.

Definition at line 40 of file VisualC.h.

#define ACTIV_TEMPLATE_API ( a ) a

Define rules for exporting template member functions.

The Intel & Visual C++ compilers have different rules for __declspec exporting template instantiations from dlls. Use ACTIV_TEMPLATE_API as a workaround, e.g.

class Example { template <typename T> ACTIV_TEMPLATE_API(MY_LIB_API) void Fn(T &); };

Parameters:
a __declspec macro, e.g. ACTIV_BASE_EXPORTED_API.

Definition at line 56 of file VisualC.h.

#define ACTIV_TEMPLATE_SELF typename

Declare a type in a template parameter list.

When using the curiously recurring template pattern, e.g.

template<...> class Derived : public Base<Derived, ...>

under GCC requires

template<...> class Derived : public Base<class Derived, ...>

but Visual C++ won't accept that (it will accept typename). Use this macro as a workaround, e.g.

template<...> class Derived : public Base<ACTIV_TEMPLATE_SELF Derived, ...>

Definition at line 73 of file VisualC.h.

Generated on Wed Oct 8 14:01:51 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » Config » Platforms

Bsd.h File Reference

BSD configuration file. More...

#include "Posix.h"

Go to the source code of this file.

Defines

#define | ACTIV_HAS_INTTYPES_H
#define | ACTIV_PLATFORM_NAME "BSD"
#define | ACTIV_PLATFORM_TYPE Activ::PLATFORM_TYPE_BSD
#define | ACTIV_POSIX_HAS_CONTEXT_API

Detailed Description

BSD configuration file.

Log

Definition in file Bsd.h.

Generated on Wed Oct 8 14:01:51 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » Config » Platforms

Linux.h File Reference

Linux configuration file. More...

#include "Posix.h"

Go to the source code of this file.

Defines

#define | ACTIV_HAS_INTTYPES_H
#define | ACTIV_PLATFORM_NAME "Linux"
#define | ACTIV_PLATFORM_TYPE Activ::PLATFORM_TYPE_LINUX
#define | ACTIV_POSIX_HAS_CONTEXT_API
#define | ACTIV_POSIX_HAS_PSHARED

Detailed Description

Linux configuration file.

Log

Definition in file Linux.h.

Generated on Wed Oct 8 14:01:51 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » Config » Platforms

OSX.h File Reference

OSX configuration file. More...

#include "Posix.h"

Go to the source code of this file.

Defines

#define | __STDC_LIBRARY_SUPPORTED__
#define | ACTIV_EXPLICIT_INSTANTIATE_SIZE_T
#define | ACTIV_HAS_INTTYPES_H
#define | ACTIV_PLATFORM_NAME "OSX"
#define | ACTIV_PLATFORM_TYPE Activ::PLATFORM_TYPE_OSX

Detailed Description

OSX configuration file.

Log

Definition in file OSX.h.

Generated on Wed Oct 8 14:01:51 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » Config » Platforms

Solaris.h File Reference

Solaris configuration file. More...

#include <sys/socket.h>
#include "Posix.h"
#include <strings.h>

Go to the source code of this file.

Defines

#define | ACTIV_EXPLICIT_INSTANTIATE_SIZE_T
#define | ACTIV_HAS_INTTYPES_H
#define | ACTIV_PLATFORM_NAME "Solaris"
#define | ACTIV_PLATFORM_TYPE Activ::PLATFORM_TYPE_SOLARIS
#define | ACTIV_POSIX_HAS_CONTEXT_API
#define | ACTIV_POSIX_HAS_PSHARED
#define | CMSG_LEN(len) (_CMSG_DATA_ALIGN(sizeof(struct cmsghdr)) + (len))
#define | CMSG_SPACE(len) (_CMSG_HDR_ALIGN(sizeof(struct cmsghdr)) + (len))
#define | NAME_MAX MAXNAMELEN
#define | SUN_LEN(p) (reinterpret_cast<size_t>(&((sockaddr_un *)0)->sun_path) + strlen((p)->sun_path))

Detailed Description

Solaris configuration file.

Log

Definition in file Solaris.h.

Generated on Wed Oct 8 14:01:51 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » Config » Platforms

Windows.h File Reference

Microsoft Windows configuration file. More...

#include <winsock2.h>
#include <ws2tcpip.h>
#include <windows.h>

Go to the source code of this file.

Defines

#define | _WIN32_WINNT 0x501
#define | ACTIV_PLATFORM_NAME "Win32"
#define | ACTIV_PLATFORM_TYPE Activ::PLATFORM_TYPE_WINDOWS
#define | ACTIV_WAIT_INFINITE INFINITE

Detailed Description

Microsoft Windows configuration file.

Log

Definition in file Windows.h.

Generated on Wed Oct 8 14:01:51 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » Misc

BitFields.h File Reference

Header file for bit field helper classes. More...

#include "ActivMiddleware/Activ.h"
#include "boost/static_assert.hpp"

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::BitField< T, OFFSET_VALUE, LENGTH_VALUE >
Bit field helper class. More...
class | Activ::FirstBitField< T, LENGTH_VALUE >
Initial (0 offset) bit field helper class. More...
class | Activ::NextBitField< PREVIOUS_FIELD, LENGTH_VALUE >
Next bitfield helper class. More...

Detailed Description

Header file for bit field helper classes.

Log

Definition in file BitFields.h.

Generated on Wed Oct 8 14:01:51 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » Misc

CrtHelper.h File Reference

Workarounds for crt disparities across platforms. More...

#include "ActivMiddleware/Activ.h"
#include <time.h>

Go to the source code of this file.

Namespaces

namespace | Activ

Functions

tm * | Activ::gmtime_r (const time_t *const pTime, tm *const pTm)
Convert a time value and store as UTC.
tm * | Activ::localtime_r (const time_t *const pTime, tm *const pTm)
Convert a time value and correct for the local time zone.

Detailed Description

Workarounds for crt disparities across platforms.

Log

Definition in file CrtHelper.h.

Generated on Wed Oct 8 14:01:51 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » Misc

CurlFtpHelper.h File Reference

Header file for the curl FTP helper class which user cUrl and ftpparser. More...

#include "ActivMiddleware/ActivBase/StatusCodeException.h"
#include "ActivMiddleware/ActivBase/OsException.h"
#include "ActivMiddleware/ActivBase/File.h"
#include "ActivMiddleware/Misc/FtpParse.h"
#include "ActivMiddleware/Misc/CrtHelper.h"
#include "curl/curl.h"
#include "IFtpHelper.h"
#include <string>
#include <vector>
#include <time.h>

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::CurlFtpHelper
CurlFtpHelper class. More...
class | Activ::CurlFtpHelper::CallbackData
class | Activ::CurlFtpHelper::CurlInitializeHelper
CurlInitializeHelper class. More...
class | Activ::CurlFtpHelper::FileListCallbackData
class | Activ::CurlFtpHelper::GetFileCallbackData

Detailed Description

Header file for the curl FTP helper class which user cUrl and ftpparser.

When using this file you will need to link to the curl library (CurlPackage_x86_win32_vc71_mdid.lib etc.).

Log

Definition in file CurlFtpHelper.h.

Generated on Wed Oct 8 14:01:51 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » Misc

Des3Helper.h File Reference

Helper class for DES3 functions in OpenSsl. More...

#include "ActivMiddleware/ActivBase/StatusCodeException.h"
#include "ActivMiddleware/ActivBase/MessageValidator.h"
#include <openssl/des.h>
#include <sstream>
#include <iomanip>

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::Des3Helper
class | Activ::Des3Helper::Key
Wrapper class for DES keys. More...
class | Activ::Des3Helper::KeyBundle
class containing three DES key schedules More...

Detailed Description

Helper class for DES3 functions in OpenSsl.

Log

Definition in file Des3Helper.h.

Generated on Wed Oct 8 14:01:51 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » Misc

DesHelper.h File Reference

Helper class for DES functions in OpenSsl. More...

#include "ActivMiddleware/ActivBase/StatusCodeException.h"
#include "ActivMiddleware/ActivBase/MessageValidator.h"
#include <openssl/des.h>
#include <sstream>
#include <iomanip>

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::DesHelper
class | Activ::DesHelper::Key
Wrapper class for DES keys. More...

Detailed Description

Helper class for DES functions in OpenSsl.

Revision 1.1 2007/06/18 08:04:45 cnickson Added for LME.

Definition in file DesHelper.h.

Generated on Wed Oct 8 14:01:51 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » Misc

DynamicLibraryLoader.h File Reference

Header file for dynamic library loader helper classes. More...

#include "ActivMiddleware/ActivBase/OsException.h"
#include "boost/mpl/vector.hpp"
#include "boost/mpl/inherit_linearly.hpp"
#include "boost/mpl/inherit.hpp"
#include "boost/mpl/for_each.hpp"
#include "boost/function.hpp"
#include "ActivMiddleware/Misc/Detail/DynamicLibraryLoaderDetail.h"

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::DynamicLibraryLoader< T >
Main dynamic library loader class. More...
class | Activ::DynamicLibraryLoader< T >::DllFunctionLoader
Helper class to find function pointer for each base of a DynamicLibraryLoader.

Defines

#define | ACTIV_DECLARE_DLL_FUNCTION(name, type, throwOnError)
Declare a dynamic library function to find.

Typedefs

typedef HMODULE | Activ::DllHandle
Handle to dymamic library type.

Detailed Description

Header file for dynamic library loader helper classes.

Log

Definition in file DynamicLibraryLoader.h.

Define Documentation

#define ACTIV_DECLARE_DLL_FUNCTION | ( | name,
 |  | type,
 |  | throwOnError | )

Value:

class name##Name { public: name##Name() : m_name(#name) { } const std::string m_name; };    \
    typedef DllFunctionWrapper<name##Name, type, throwOnError> name
Declare a dynamic library function to find.

This macro creates a new class with the same name as provided to this macro. Therefore, this macro should probably be used at a different scope to the one containing the function declaration, to avoid clashes. This new class provides a m_name member (the name of the function), a Type typedef (the type of the function) and a m_pFunction pointer (to hold the pointer to the function's entry point).

Note we're not using ACTIV_STRINGIZE on name: we don't want it expanded if it is a pre-processor macro.

Parameters:
name | the unquoted name of the library function, e.g. getaddrinfo
type | the type of the library function, e.g. int (WINAPI)(const char FAR *, const char FAR *, const struct addrinfo FAR *, struct addrinfo FAR *FAR *)
throwOnError | boolean whether to throw if the function cannot be found. Useful to distinguish between functions which must be found, and those that are optional.

Definition at line 51 of file DynamicLibraryLoader.h.

Generated on Wed Oct 8 14:01:51 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » Misc

FtpHelper.h File Reference

Header file for the FTP helper class which user cUrl and ftpparser. More...

#include "ActivMiddleware/ActivBase/StatusCodeException.h"
#include "ActivMiddleware/ActivBase/OsException.h"
#include "ActivMiddleware/ActivBase/File.h"
#include "ActivMiddleware/Misc/FtpParse.h"
#include "curl/curl.h"
#include <string>
#include <vector>
#include <time.h>
#include "IFtpHelper.h"
#include "CurlFtpHelper.h"
#include "WinFtpHelper.h"

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::FtpHelper
FtpHelper class. More...

Detailed Description

Header file for the FTP helper class which user cUrl and ftpparser.

When using this file you will need to link to the curl library (CurlPackage_x86_win32_vc71_mdid.lib etc.).

Log

Definition in file FtpHelper.h.

Generated on Wed Oct 8 14:01:51 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » Misc

FunctionObjects.h File Reference

Header file for function objects. More...

#include <algorithm>
#include <functional>

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::CaseInsensitiveLessThanStringComparisonObject
Case-insensitive less than string comparison object. More...
class | Activ::DeleteAssociativeObject
Delete associative object. More...
class | Activ::DeleteObject
Delete object. More...
class | Activ::DeleteObjectArray
Delete object array. More...
class | Activ::EqualToPairComparisonObject< Pair >
Equal to pair comparison function object. More...
class | Activ::LessThanPairComparisonObject< Pair >
Less than pair comparison function object. More...
class | Activ::NullObject
Do-nothing function object. More...

Detailed Description

Header file for function objects.

Log

Definition in file FunctionObjects.h.

Generated on Wed Oct 8 14:01:51 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » Misc

HandleManager.h File Reference

Header file for the handle manager class. More...

#include "ActivMiddleware/Activ.h"

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::HandleManager< T >
HandleManager class. More...

Detailed Description

Header file for the handle manager class.

Log

Definition in file HandleManager.h.

Generated on Wed Oct 8 14:01:51 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » Misc

IFtpHelper.h File Reference

Header file for the FTP helper class which user cUrl and ftpparser. More...

#include "ActivMiddleware/ActivBase/StatusCodeException.h"
#include "ActivMiddleware/ActivBase/OsException.h"
#include "ActivMiddleware/ActivBase/File.h"
#include "ActivMiddleware/Misc/FtpParse.h"
#include "curl/curl.h"
#include <string>
#include <vector>
#include <time.h>

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::FileInfo
FileInfo class. More...
class | Activ::IFtpHelper
FtpHelper class. More...
class | Activ::StatusCodeHelper
StatusCodeHelper class. More...

Typedefs

typedef std::vector< FileInfo > | Activ::FileInfoList
List of FileInfo.

Functions

bool | Activ::operator!= (const StatusCode &statusCode, const StatusCodeHelper &statusCodeHelper)
bool | Activ::operator== (const StatusCode &statusCode, const StatusCodeHelper &statusCodeHelper)

Detailed Description

Header file for the FTP helper class which user cUrl and ftpparser.

When using this file you will need to link to the curl library (CurlPackage_x86_win32_vc71_mdid.lib etc.).

Log

Definition in file IFtpHelper.h.

Generated on Wed Oct 8 14:01:51 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » Misc

IntrusivePtrHelper.h File Reference

Helper for using intrusive pointer class in a single threaded environment. More...

#include "ActivMiddleware/Activ.h"
#include "boost/intrusive_ptr.hpp"

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::ReferenceCounter
Intrusive ptr reference counter. More...

Defines

#define | ACTIV_DECLARE_INTRUSIVE_PTR_TYPEDEF(T) typedef boost::intrusive_ptr<T>
Declare typedef for intrusive ptr.
#define | ACTIV_INTRUSIVE_PTR_HELPER_ADD_REFERENCE_COUNTER
Macro to insert reference counter into an object.
#define | ACTIV_INTRUSIVE_PTR_HELPER_REFERENCE_COUNTER_NAME ____m_referenceCounter__activ____
Kind of unique name for reference counter member.

Functions

template<typename T>
void | intrusive_ptr_add_ref (const T *const pObject)
Global function to add ref to object.
template<typename T>
void | intrusive_ptr_release (const T *const pObject)
Global function to release object.

Detailed Description

Helper for using intrusive pointer class in a single threaded environment.

Log

Definition in file IntrusivePtrHelper.h.

Define Documentation

#define ACTIV_DECLARE_INTRUSIVE_PTR_TYPEDEF ( T ) typedef boost::intrusive_ptr<T>

Declare typedef for intrusive ptr.

Parameters:
T is the type to be pointed to.

Definition at line 138 of file IntrusivePtrHelper.h.

#define ACTIV_INTRUSIVE_PTR_HELPER_ADD_REFERENCE_COUNTER

Value:

mutable Activ::ReferenceCounter ACTIV_INTRUSIVE_PTR_HELPER_REFERENCE_COUNTER_NAME;  \
    Activ::uint32_t GetReferenceCount() const                                           \
    {                                                                                   \
        return ACTIV_INTRUSIVE_PTR_HELPER_REFERENCE_COUNTER_NAME.Get();                 \
    }
Macro to insert reference counter into an object.

This macro needs to be used in the public section of a class.

Definition at line 124 of file IntrusivePtrHelper.h.

Function Documentation

template<typename T>
void intrusive_ptr_add_ref ( const T *const pObject ) [inline]

Global function to add ref to object.

Parameters:
pObject to add reference to.

Definition at line 29 of file IntrusivePtrHelper.h.

template<typename T>
void intrusive_ptr_release ( const T *const pObject ) [inline]

Global function to release object.

Parameters:
pObject to release.

Definition at line 42 of file IntrusivePtrHelper.h.

Generated on Wed Oct 8 14:01:51 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » Misc

MemoryHelper.h File Reference

Header file for the memory helper functions. More...

#include "ActivMiddleware/Activ.h"
#include <memory.h>

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::StaticAlignValueToProcessorWordBoundary< T, input >
Compile-time template to align a value to a processor word size boundary. More...

Functions

template<typename T>
T | Activ::AlignValueToByteBoundary (const T value, const size_t numberOfBytes)
Align a value to an arbitrary byte boundary.
template<typename T>
T | Activ::AlignValueToProcessorWordBoundary (const T value)
Align a value to a processor word size boundary.
template<typename T>
void | Activ::CopyValueToUnalignedPointer (void *p, const T &value)
Copy a built-in type value to a (potentially) unaligned pointer.
template<typename T>
T | Activ::GetValueFromUnalignedPointer (const void *p)
Get built-in type value from a (potentially) unaligned pointer.
void | Activ::MemoryCopy (void *pDestination, const void *pSource, size_t sourceSize)
Fast memory copy.
void | Activ::MemoryReverse (void *pBuffer, size_t bufferSize)
Asymmetrical memory swap.
void | Activ::MemoryReverseCopy (void *pDestination, const void *pSource, size_t sourceSize)
Asymmetrical memory copy.

Detailed Description

Header file for the memory helper functions.

Log

Definition in file MemoryHelper.h.

Generated on Wed Oct 8 14:01:51 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » Misc

ObjectPool.h File Reference

Class to cache a number of objects to avoid constructing/destructing them continually. More...

#include "ActivMiddleware/Misc/FunctionObjects.h"
#include "ActivMiddleware/Misc/Singleton.h"
#include "ActivMiddleware/Misc/StlHelper.h"
#include "ActivMiddleware/ActivBase/StatusCodeException.h"
#include <set>
#include <vector>

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::ObjectPool< T, INITIAL_FREE_LIST_SIZE, MAX_FREE_LIST_SIZE >
Object pool. More...
class | Activ::ObjectPool< T, INITIAL_FREE_LIST_SIZE, MAX_FREE_LIST_SIZE >::Stats
Pool statistics. More...
class | Activ::ScopedPooledObject< T >
Helper class to get an object from an ObjectPool and return it when the helper goes out of scope. More...

Detailed Description

Class to cache a number of objects to avoid constructing/destructing them continually.

Log

Definition in file ObjectPool.h.

Generated on Wed Oct 8 14:01:51 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » Misc

ScopedHelper.h File Reference

Helper classes for creating scoped wrappers around other objects. More...

#include "ActivMiddleware/Activ.h"
#include "boost/function.hpp"
#include "boost/bind.hpp"
#include <functional>
#include <io.h>

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::ScopedFd
Scoped file-descriptor helper. More...
class | Activ::ScopedFile
Scoped FILE helper. More...
class | Activ::ScopedHandle
Scoped HANDLE helper. More...
class | Activ::ScopedHandle::IsValidHandle
Function object to check for a valid handle. More...
class | Activ::ScopedHelper< T, D >
Class which will call a function in its destructor based on a condition. More...
class | Activ::ScopedHelper< T, D >::True
Simple unary function that returns true. More...
class | Activ::ScopedMemory< T >
Scoped memory helper. More...
class | Activ::ScopedSocket
Scoped socket helper. More...

Detailed Description

Helper classes for creating scoped wrappers around other objects.

Log

Definition in file ScopedHelper.h.

Generated on Wed Oct 8 14:01:51 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » Misc

SerializableBuffer.h File Reference

Serializable buffer. More...

#include "ActivMiddleware/Misc/MemoryHelper.h"
#include "boost/integer_traits.hpp"

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::SerializableBuffer< LENGTH_TYPE, MIN_LENGTH, MAX_LENGTH >
Serializable buffer template. More...

Detailed Description

Serializable buffer.

Log

Definition in file SerializableBuffer.h.

Generated on Wed Oct 8 14:01:51 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » Misc

SerializableContainerHelper.h File Reference

Classes to help serialize STL containers. More...

#include "ActivMiddleware/Misc/Detail/SerializableContainerHelperDetail.h"
#include "ActivMiddleware/Misc/Detail/SerializableContainerHelperSpecializations.h"

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::SerializableContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >
Helper class to serialize STL containers. More...
class | Activ::SerializableObjectContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH >
Helper class to serialize containers of objects. More...
class | Activ::SerializableRawPointerContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH >
Helper class to serialize containers of raw pointers to objects. More...
class | Activ::SerializableSmartPointerContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH >
Helper class to serialize containers of smart pointers to objects. More...

Detailed Description

Classes to help serialize STL containers.

Log

Definition in file SerializableContainerHelper.h.

Generated on Wed Oct 8 14:01:51 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » Misc

Singleton.h File Reference

Header file for singleton template. More...

#include "ActivMiddleware/Activ.h"

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::Singleton< T >
Singleton template. More...
class | Activ::Singleton< T >::Initializer

Detailed Description

Header file for singleton template.

Log

Definition in file Singleton.h.

Generated on Wed Oct 8 14:01:51 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » Misc

SmtpHelper.h File Reference

Smtp helper class. More...

#include "ActivMiddleware/ActivBase/ActivBase.h"
#include "ActivMiddleware/ActivBase/StatusCodeException.h"
#include "ActivMiddleware/ActivBase/Thread.h"
#include "ActivMiddleware/ActivIp/IpManager.h"
#include "boost/tokenizer.hpp"
#include <string>

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::SmtpHelper
Smtp helper class. More...
class | Activ::SmtpHelper::Email
Email class. More...
class | Activ::SmtpHelper::PostEmailThread
Send email thread.

Detailed Description

Smtp helper class.

Log

Definition in file SmtpHelper.h.

Generated on Wed Oct 8 14:01:51 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » Misc

StlHelper.h File Reference

Work arounds for STL disparities across platforms, plus various helpers. More...

#include "ActivMiddleware/Activ.h"
#include "boost/functional/hash/hash.hpp"
#include <vector>
#include <string>
#include <list>
#include <map>
#include <algorithm>

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::SelectFirst< P >
Unary function object to return the first element of a pair. More...
class | Activ::SelectFirstFromSecond< P >
Unary function object to return the first element of a pair, given the second element. More...
class | Activ::SelectSecond< P >
Unary function object to return the second element of a pair. More...
class | Activ::StringHashCompare< TRAITS >
Hash compare class for STL hash containers where the key is a string. More...

Functions

template<typename T>
void | Activ::EmptyVector (std::vector< T > &v)
Empty a vector but do not deallocate reserved storage.
template<typename MAPPED_TYPE, typename KEY_TYPE>
bool | Activ::MapFind (MAPPED_TYPE &map, const KEY_TYPE &key, typename MAPPED_TYPE::iterator &iter)
Find the iterator to an item in a map, or the point at which it can be inserted.
template<typename MAPPED_TYPE, typename KEY_TYPE>
MAPPED_TYPE::iterator | Activ::MapInsert (MAPPED_TYPE &map, typename MAPPED_TYPE::iterator hint, const KEY_TYPE &key, typename MAPPED_TYPE::value_type &value)
Insert a (key, value) pair into a map.
template<typename MAPPED_TYPE, typename KEY_TYPE>
std::pair< typename
MAPPED_TYPE::iterator, bool > 		Activ::MapInsert (MAPPED_TYPE &map, const KEY_TYPE &key, typename MAPPED_TYPE::value_type &value)
Insert a (key, value) pair into a map.
template<typename T>
bool | Activ::SortAndCheckForDuplicates (T &c)
Sort a container and check for duplicates.
template<typename T>
void | Activ::SortAndRemoveDuplicates (T &c)
Sort a container and remove any duplicates.
template<typename T>
bool | Activ::SortUnique (T &c)
void | Activ::StringToLower (std::string &str)
Make an STL string lowercase.
void | Activ::StringToUpper (std::string &str)
Make an STL string uppercase.

Detailed Description

Work arounds for STL disparities across platforms, plus various helpers.

Log

Definition in file StlHelper.h.

Generated on Wed Oct 8 14:01:51 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » Misc

TemplateFunctions.h File Reference

Header file for miscellaneous template functions with no other home. More...

#include "ActivMiddleware/Activ.h"
#include <string>

Go to the source code of this file.

Namespaces

namespace | Activ

Functions

template<typename T>
std::string | Activ::IndexToString (const T index, const char *const array[], const size_t arraySize)
Template function for returning a string from a table.

Detailed Description

Header file for miscellaneous template functions with no other home.

Log

Definition in file TemplateFunctions.h.

Generated on Wed Oct 8 14:01:51 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » Misc

WinFtpHelper.h File Reference

Header file for the win FTP helper class which uses wininet. More...

#include "ActivMiddleware/ActivBase/StatusCodeException.h"
#include "ActivMiddleware/ActivBase/OsException.h"
#include "ActivMiddleware/ActivBase/File.h"
#include "ActivMiddleware/Misc/FtpParse.h"
#include <wininet.h>
#include "IFtpHelper.h"
#include <string>
#include <vector>
#include <time.h>

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::WinFtpHelper

Detailed Description

Header file for the win FTP helper class which uses wininet.

Definition in file WinFtpHelper.h.

Generated on Wed Oct 8 14:01:51 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » Misc » Detail

DynamicLibraryLoaderDetail.h File Reference

Header file for dynamic library loader helper implementation details. More...

#include "boost/bind.hpp"
#include "boost/tokenizer.hpp"

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::DllFunctionWrapper< NAME, TYPE, THROW_ON_ERROR >
Function wrapper. More...

Detailed Description

Header file for dynamic library loader helper implementation details.

Log

Definition in file DynamicLibraryLoaderDetail.h.

Generated on Wed Oct 8 14:01:51 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » Misc » Detail

SerializableContainerHelperDetail.h File Reference

Classes to help serialize STL containers. More...

#include "ActivMiddleware/ActivBase/MessageBuilder.h"
#include "ActivMiddleware/ActivBase/MessageValidator.h"
#include "boost/integer_traits.hpp"
#include "boost/type_traits/remove_pointer.hpp"
#include "boost/static_assert.hpp"
#include <vector>
#include <list>
#include <set>
#include <map>

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::SerializableObjectHelper< OBJECT_TYPE >
Helper class to (de)serialize objects. More...
class | Activ::SerializableRawPointerHelper< POINTER_TYPE >
Helper class to (de)serialize raw pointers to objects. More...
class | Activ::SerializableSmartPointerHelper< POINTER_TYPE >
Helper class to (de)serialize smart pointers to objects. More...

Defines

#define | ACTIV_DESERIALIZE_OBJECT(type, validator)
Macro to declare DeserializeObject() for a basic type.
#define | ACTIV_SERIALIZE_OBJECT(type)
Macro to declare SerializeObject() for a basic type.

Functions

template<typename CONTAINER_TYPE, typename COUNT_TYPE, COUNT_TYPE MIN_LENGTH, COUNT_TYPE MAX_LENGTH, typename OBJECT_HELPER>
StatusCode | Activ::DeserializeAssociativeContainer (MessageValidator &messageValidator, CONTAINER_TYPE &container, const bool shouldClearContainer)
Deserialize an associative container type.
StatusCode | Activ::DeserializeObject (MessageValidator &messageValidator, std::string &str)
StatusCode | Activ::DeserializeObject (MessageValidator &messageValidator, bool &booleanValue)
StatusCode | Activ::DeserializeObject (MessageValidator &messageValidator, int64_t &value)
StatusCode | Activ::DeserializeObject (MessageValidator &messageValidator, int32_t &value)
StatusCode | Activ::DeserializeObject (MessageValidator &messageValidator, int16_t &value)
StatusCode | Activ::DeserializeObject (MessageValidator &messageValidator, int8_t &value)
StatusCode | Activ::DeserializeObject (MessageValidator &messageValidator, uint64_t &value)
StatusCode | Activ::DeserializeObject (MessageValidator &messageValidator, uint32_t &value)
StatusCode | Activ::DeserializeObject (MessageValidator &messageValidator, uint16_t &value)
StatusCode | Activ::DeserializeObject (MessageValidator &messageValidator, uint8_t &value)
template<typename OBJECT_TYPE>
StatusCode | Activ::DeserializeObject (MessageValidator &messageValidator, OBJECT_TYPE &object)
Deserialize object helper function.
template<typename CONTAINER_TYPE, typename COUNT_TYPE, COUNT_TYPE MIN_LENGTH, COUNT_TYPE MAX_LENGTH, typename OBJECT_HELPER>
StatusCode | Activ::SerializeAssociativeContainer (MessageBuilder &messageBuilder, const CONTAINER_TYPE &container)
Serialize an associative container type.
template<typename CONTAINER_TYPE, typename COUNT_TYPE, COUNT_TYPE MIN_LENGTH, COUNT_TYPE MAX_LENGTH, typename OBJECT_HELPER>
StatusCode | Activ::SerializeContainer (MessageBuilder &messageBuilder, const CONTAINER_TYPE &container)
Serialize a non-associative container type.
StatusCode | Activ::SerializeObject (MessageBuilder &messageBuilder, const std::string &str)
StatusCode | Activ::SerializeObject (MessageBuilder &messageBuilder, const bool &booleanValue)
StatusCode | Activ::SerializeObject (MessageBuilder &messageBuilder, const int64_t &value)
StatusCode | Activ::SerializeObject (MessageBuilder &messageBuilder, const int32_t &value)
StatusCode | Activ::SerializeObject (MessageBuilder &messageBuilder, const int16_t &value)
StatusCode | Activ::SerializeObject (MessageBuilder &messageBuilder, const int8_t &value)
StatusCode | Activ::SerializeObject (MessageBuilder &messageBuilder, const uint64_t &value)
StatusCode | Activ::SerializeObject (MessageBuilder &messageBuilder, const uint32_t &value)
StatusCode | Activ::SerializeObject (MessageBuilder &messageBuilder, const uint16_t &value)
StatusCode | Activ::SerializeObject (MessageBuilder &messageBuilder, const uint8_t &value)
template<typename OBJECT_TYPE>
StatusCode | Activ::SerializeObject (MessageBuilder &messageBuilder, const OBJECT_TYPE &object)
Serialize object helper function.

Detailed Description

Classes to help serialize STL containers.

Log

Definition in file SerializableContainerHelperDetail.h.

Define Documentation

#define ACTIV_DESERIALIZE_OBJECT | ( | type,
 |  | validator | )

Value:

inline StatusCode DeserializeObject(MessageValidator &messageValidator, type &value)            \
    {                                                                                               \
        return messageValidator.validator(sizeof(value), MessageValidator::ENDIAN_LITTLE, &value);  \
    }
Macro to declare DeserializeObject() for a basic type.

Definition at line 81 of file SerializableContainerHelperDetail.h.

#define ACTIV_SERIALIZE_OBJECT ( type )

Value:

inline StatusCode SerializeObject(MessageBuilder &messageBuilder, const type &value)            \
    {                                                                                               \
        return messageBuilder.Append(value, MessageBuilder::ENDIAN_LITTLE);                         \
    }
Macro to declare SerializeObject() for a basic type.

Definition at line 70 of file SerializableContainerHelperDetail.h.

Generated on Wed Oct 8 14:01:51 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » Misc » Detail

SerializableContainerHelperSpecializations.h File Reference

Classes to help serialize STL containers. More...

#include "ActivMiddleware/Misc/StlHelper.h"

Go to the source code of this file.

Namespaces

namespace | Activ

Classes

class | Activ::SerializableContainerHelper< hash_map< KEY_TYPE, MAPPED_TYPE, HASH_FN >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >
Specialization for hash_map containers. More...
class | Activ::SerializableContainerHelper< std::list< OBJECT_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >
Specialization for list containers. More...
class | Activ::SerializableContainerHelper< std::map< KEY_TYPE, MAPPED_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >
Specialization for map containers. More...
class | Activ::SerializableContainerHelper< std::set< OBJECT_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >
Specialization for set containers. More...
class | Activ::SerializableContainerHelper< std::vector< OBJECT_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >
SerializableContainerHelper specialization for std::vector containers. More...
class | Activ::SerializableObjectContainerHelper< hash_map< KEY_TYPE, MAPPED_TYPE, HASH_FN >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH >
Partial specialization of SerializableObjectContainerHelper to serialize hash_maps of objects. More...
class | Activ::SerializableObjectContainerHelper< std::map< KEY_TYPE, MAPPED_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH >
Partial specialization of SerializableObjectContainerHelper to serialize maps of objects. More...
class | Activ::SerializableRawPointerContainerHelper< hash_map< KEY_TYPE, MAPPED_TYPE, HASH_FN >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH >
Partial specialization of SerializableRawPointerContainerHelper to serialize hash_maps of raw pointers to objects. More...
class | Activ::SerializableRawPointerContainerHelper< std::map< KEY_TYPE, MAPPED_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH >
Partial specialization of SerializableRawPointerContainerHelper to serialize maps of raw pointers to objects. More...
class | Activ::SerializableSmartPointerContainerHelper< hash_map< KEY_TYPE, MAPPED_TYPE, HASH_FN >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH >
Partial specialization of helper class to serialize hash_maps of smart pointers to objects. More...
class | Activ::SerializableSmartPointerContainerHelper< std::map< KEY_TYPE, MAPPED_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH >
Partial specialization of helper class to serialize maps of smart pointers to objects. More...

Detailed Description

Classes to help serialize STL containers.

Log

Definition in file SerializableContainerHelperSpecializations.h.

Generated on Wed Oct 8 14:01:51 2008 for ACTIV C++ SDK by doxygen 1.5.4


ACTIV C++ SDK Directories

This directory hierarchy is sorted roughly, but not completely, alphabetically:
  • include
    • ActivContentPlatform
      • ActivContentGatewayApi
      • ActivContentGatewayApiCommon
      • ActivContentServerApi
      • ActivContributionGatewayApi
      • ActivContributionGatewayApiCommon
      • ActivContributionServerApi
      • ActivFeedApiCommon
      • ActivFeedCommon
        • ActivFeedMessageHandler
        • ActivFeedPermissioning
        • ActivFeedTableTemplateHandler
    • ActivMiddleware
      • ActivAgentApplication
      • ActivBase
        • Detail
        • Windows
      • ActivDatabase
      • ActivFieldTypes
      • ActivFramework
      • ActivIp
        • Windows
      • ActivSystem
      • Config
        • Compilers
        • Platforms
      • Misc
        • Detail
Generated on Wed Oct 8 14:02:12 2008 for ACTIV C++ SDK by doxygen 1.5.4


include

include Directory Reference

Directories

directory | ActivContentPlatform
directory | ActivMiddleware
Generated on Wed Oct 8 14:02:12 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform

ActivContentPlatform Directory Reference

Directories

directory | ActivContentGatewayApi
directory | ActivContentGatewayApiCommon
directory | ActivContentServerApi
directory | ActivContributionGatewayApi
directory | ActivContributionGatewayApiCommon
directory | ActivContributionServerApi
directory | ActivFeedApiCommon
directory | ActivFeedCommon

Files

file | MessageClasses.h [code]
Message classes for content platform.
Generated on Wed Oct 8 14:02:12 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivContentGatewayApi

ActivContentGatewayApi Directory Reference

Files

file | ActivContentGatewayApi.h [code]
ActivContentGatewayApi main header.
file | ContentGatewayClient.h [code]
Content gateway client.
file | External.h [code]
Import rules for ActivContentGatewayApi exports.
file | FieldListValidator.h [code]
Header file for the field list validator class.
file | INewsResponses.h [code]
Callback interface for news responses.
file | IRealtimeResponses.h [code]
Callback interface for realtime data request responses.
file | ISymbolDirectoryResponses.h [code]
Callback interface for symbol directory request responses.
file | ITimeSeriesResponses.h [code]
Callback interface for time series request responses.
file | MetaDataRequestHelper.h [code]
Helper class for metadata requests.
file | NewsRequestHelper.h [code]
Helper class for news requests.
file | NewsUpdateHelper.h [code]
News update helper class.
file | RealtimeRequestHelper.h [code]
Helper class for realtime requests.
file | RecordUpdateHelper.h [code]
Record update helper class.
file | SymbolDirectoryRequestHelper.h [code]
Helper class for symbol directory requests.
file | TimeSeriesRequestHelper.h [code]
Helper class for time series requests.
Generated on Wed Oct 8 14:02:12 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivContentGatewayApiCommon

ActivContentGatewayApiCommon Directory Reference

Files

file | External.h [code]
Import rules for ActivContentGatewayApiCommon exports.
file | FieldSet.h [code]
Header file for the Field Set base class.
file | HistoryBar.h [code]
History Bar Field Set.
file | IntradayBar.h [code]
Intraday Bar Field Set.
file | MetaDataTypes.h [code]
Types for metadata.
file | NewsTypes.h [code]
Types for news data.
file | OptionBar.h [code]
Option Bar Field Set.
file | RealtimeTypes.h [code]
Types for realtime data.
file | SymbolDirectoryTypes.h [code]
Types for symbol directory data.
file | Tick.h [code]
Tick Field Set.
file | TimeSeriesTypes.h [code]
Types for time series data.
file | Types.h [code]
General content gateway types.
Generated on Wed Oct 8 14:02:12 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivContentServerApi

ActivContentServerApi Directory Reference

Files

file | ActivContentServerApi.h [code]
ActivContentServerApi main header.
file | ContentServerClient.h [code]
Content server client.
file | External.h [code]
Import rules for ActivContentServerApi exports.
file | FieldListValidator.h [code]
Header file for the field list validator class.
file | RecordUpdateHelper.h [code]
Record update helper.
file | SymbolPatternHelper.h [code]
Header for symbol pattern helper class.
Generated on Wed Oct 8 14:02:12 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivContributionGatewayApi

ActivContributionGatewayApi Directory Reference

Files

file | ActivContributionGatewayApi.h [code]
ActivContributionGatewayApi main header.
file | ContributionGatewayClient.h [code]
Contribution gateway client.
file | External.h [code]
Import rules for ActivContributionGatewayApi exports.
file | PublishRequestHelper.h [code]
Helper class for publish requests.
Generated on Wed Oct 8 14:02:12 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivContributionGatewayApiCommon

ActivContributionGatewayApiCommon Directory Reference

Files

file | External.h [code]
Import rules for ActivContributionGatewayApiCommon exports.
file | PublishTypes.h [code]
Types for publishing data.
file | Types.h [code]
General contribution gateway types.
Generated on Wed Oct 8 14:02:12 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivContributionServerApi

ActivContributionServerApi Directory Reference

Files

file | ContributionServerClient.h [code]
Contribution server api.
file | External.h [code]
Import rules for ActivContributionServerApi exports.
Generated on Wed Oct 8 14:02:12 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedApiCommon

ActivFeedApiCommon Directory Reference

Files

file | External.h [code]
Import rules for ActivFeedApiCommon exports.
file | FieldListValidator.h [code]
Header file for the field list validator class.
file | FieldStatus.h [code]
Header file for the field status definitions.
Generated on Wed Oct 8 14:02:12 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon

ActivFeedCommon Directory Reference

Directories

directory | ActivFeedMessageHandler
directory | ActivFeedPermissioning
directory | ActivFeedTableTemplateHandler

Files

file | ActivFeed.h [code]
Main header file for ACTIV Feed.
file | ActivFeedDefinitions.h [code]
Header file for activ feed definitions.
file | EntityTypeHelper.h [code]
Header file for the entity type helper.
file | EntityTypes.h [code]
Header file for entity types.
file | Enumerations.h [code]
Header file for the enumerations.
file | EventTypeHelper.h [code]
Header file for the event type helper.
file | EventTypes.h [code]
Header file for the event types.
file | Exchanges.h [code]
Header file for the exchanges.
file | External.h [code]
Import rules for ActivFeedCommon exports.
file | FieldIds.h [code]
Header file for the field ids.
file | IndexNumbers.h [code]
Header file for the table template index numbers.
file | PermissionIdHelper.h [code]
Header file for the permission id helper.
file | PermissionIds.h [code]
Header file for the permission ids.
file | PermissionLevels.h [code]
Header file for the permission levels.
file | RelationshipIdHelper.h [code]
Header file for the relationship id helper.
file | RelationshipIds.h [code]
Header file for the relationship ids.
file | TableNumbers.h [code]
Header file for the table numbers.
file | TableResetTypes.h [code]
Header file for the table reset types.
file | TableTypes.h [code]
Header file for the table types.
file | UniversalFieldHelper.h [code]
Header file for the universal field helper.
file | UpdateIds.h [code]
Header file for the update ids.
Generated on Wed Oct 8 14:02:12 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedMessageHandler

ActivFeedMessageHandler Directory Reference

Files

file | ActivFeedMessageHandler.h [code]
Global functions from ActivFeedMessageHandler.
file | CombinedQuoteMessageHeaderDefinitions.h [code]
Header file for the combined quote message header definitions class.
file | CompressedCombinedQuoteMessage.h [code]
Header file for the compressed combined quote message class.
file | CompressedCombinedQuoteMessageDefinitions.h [code]
Header file for the compressed message definitions class.
file | CompressedCombinedQuoteMessageHeaderDefinitions.h [code]
Header file for the compressed combined quote message header definitions class.
file | CompressedCombinedQuoteMessageHeaderValidator.h [code]
Header file for the compressed combined quote message header validator class.
file | CompressedMessage.h [code]
Header file for the compressed message class.
file | CompressedMessageDefinitions.h [code]
Header file for the compressed message definitions class.
file | CompressedMessageHeaderDefinitions.h [code]
Header file for the compressed message header definitions class.
file | CompressedMessageHeaderValidator.h [code]
Header file for the compressed message header validator class.
file | CompressedSymbol.h [code]
Header file for the compressed symbol class.
file | CompressedUsEquityOptionSymbol.h [code]
Header file for the compressed us equity option symbol class.
file | External.h [code]
Import rules for ActivFeedMessageHandler exports.
file | FieldHeaderDefinitions.h [code]
Header file for the field header definitions class.
file | MessageHeaderDefinitions.h [code]
Header file for the message header definitions class.
file | RecordFieldListBuilder.h [code]
Header file for the record field list builder class.
file | RecordFieldListValidator.h [code]
Header file for the record field list validator class.
file | RecordKeyFieldListBuilder.h [code]
Header file for the record key field list builder class.
file | RecordKeyFieldListValidator.h [code]
Header file for the record key field list validator class.
file | RecordMessageBuilder.h [code]
Header file for the record message builder class.
file | RecordMessageHeaderDefinitions.h [code]
Header file for the record message header definitions class.
file | RecordMessageHeaderValidator.h [code]
Header file for the record message header validator class.
file | RecordMessageValidator.h [code]
Header file for the record message validator class.
file | Symbol.h [code]
Header file for the symbol class.
file | SymbolRecordField.h [code]
Header file for the symbol record field class.
file | SymbolRecordFieldHeaderDefinitions.h [code]
Header file for the symbol record field header definitions class.
file | SymbolRecordFieldListBuilder.h [code]
Rule file for the symbol record field list builder class.
file | SymbolRecordFieldListValidator.h [code]
Header file for the symbol record field list validator class.
file | SymbolRecordMessageBuilder.h [code]
Header file for the symbol record message builder class.
file | SymbolRecordMessageHeaderDefinitions.h [code]
Header file for the symbol record message header definitions class.
file | SymbolRecordMessageHeaderValidator.h [code]
Header file for the symbol record message header validator class.
file | SymbolRecordMessageValidator.h [code]
Header file for the symbol record message validator class.
file | SymbolRecordRuleDefinitions.h [code]
Header file for the symbol record rules definitions class.
file | TableTemplateField.h [code]
Header file for the table template field class.
file | TableTemplateFieldListValidator.h [code]
Header file for the table template field list validator class.
file | TableTemplateIndex.h [code]
Header file for the table template index class.
file | TableTemplateIndexListValidator.h [code]
Header file for the table template index list validator class.
file | TableTemplateMessageHeaderDefinitions.h [code]
Header file for the table template message header definitions class.
file | TableTemplateMessageValidator.h [code]
Header file for the table template message validator class.
Generated on Wed Oct 8 14:02:12 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedPermissioning

ActivFeedPermissioning Directory Reference

Files

file PermissionInfo.h [code]
Header file for exported user permissioning info.
Generated on Wed Oct 8 14:02:12 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedTableTemplateHandler

ActivFeedTableTemplateHandler Directory Reference

Files

file | ActivFeedTableTemplateHandler.h [code]
Global functions from ActivFeedTableTemplateHandler.
file | External.h [code]
Import rules for ActivFeedTableTemplateHandler exports.
file | Field.h [code]
Header file for the field class.
file | Index.h [code]
Header file for an index.
file | IndexSpecification.h [code]
Header file for an index specification.
file | Reset.h [code]
Header file for the reset class.
file | Rule.h [code]
Header file for the rule class.
file | TableSpecification.h [code]
Header file for a table specification.
file | TableTemplate.h [code]
Header file for the table template class.
file | TableTemplateException.h [code]
Header file for the table template exception class.
file | TableTemplateList.h [code]
Header file for the table template list class.
file | UniversalFieldList.h [code]
Header file for the universal field list class.
Generated on Wed Oct 8 14:02:12 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware

ActivMiddleware Directory Reference

Directories

directory | ActivAgentApplication
directory | ActivBase
directory | ActivDatabase
directory | ActivFieldTypes
directory | ActivFramework
directory | ActivIp
directory | ActivSystem
directory | Config
directory | Misc

Files

file | Activ.h [code]
Main header file, sets up environment and various useful macros.
file | BasicTypes.h [code]
Basic types (as per C99 <stdint.h> standard) and various helper functions.
file | FormatSpecifiers.h [code]
Platform independant c-style printf format specifiers.
file | StatusCodes.h [code]
Status codes and helper macros.
Generated on Wed Oct 8 14:02:12 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivAgentApplication

ActivAgentApplication Directory Reference

Files

file | AgentApplication.h [code]
Header file for agent application class.
file | External.h [code]
Import rules for AgentApplication exports.
Generated on Wed Oct 8 14:02:12 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

ActivBase Directory Reference

Directories

directory | Detail
directory | Windows

Files

file | ActivBase.h [code]
Global functions from ActivBase.
file | Atomic.h [code]
Header file for atomic classes.
file | BaseException.h [code]
Header file for the base exception class.
file | CommandLineParser.h [code]
Header file for a command line parser class.
file | ConsoleWindow.h [code]
Header file for console window.
file | CrtException.h [code]
Header file for c runtime exception class.
file | CtrlHandler.h [code]
Header file for the ctrl handler class.
file | DirectoryRemover.h [code]
Directory remover class.
file | DirectoryWalker.h [code]
Directory walker class.
file | Exception.h [code]
Header file for the base exception class.
file | External.h [code]
Import/export rules for ActivBase.
file | Fiber.h [code]
Header file for the fiber class.
file | File.h [code]
Header file for file class.
file | FileMappedMemoryFactory.h [code]
Header file for the file mapped memory factory class.
file | IEvent.h [code]
Header file for the event interface class.
file | IFileMappedMemory.h [code]
Header file for the file mapped memory interface class.
file | IMappedMemory.h [code]
Header file for the mapped memory interface class.
file | IMutex.h [code]
Header file for the mutex interface class.
file | IniFileParser.h [code]
Header file for ini file parser class.
file | IntervalTimer.h [code]
Header file for the interval timer class.
file | ISemaphore.h [code]
Header file for the semaphore interface class.
file | ISerializableMessage.h [code]
Header file for serializable message interface class.
file | MessageBuilder.h [code]
Header file for the message builder class.
file | MessageHandler.h [code]
Header file for the base message handler class.
file | MessageRateThrottler.h [code]
Header file for the message rate throttler class.
file | MessageValidator.h [code]
Header file for the message validator class.
file | MutexHelper.h [code]
Header file for the mutex helper classes.
file | OsException.h [code]
Header file for the os dependant exception class.
file | PagingFileMappedMemoryFactory.h [code]
Header file for the paging file mapped memory factory class.
file | PrivateEventFactory.h [code]
Header file for the private event factory class.
file | PrivateMutexFactory.h [code]
Header file for the private mutex factory class.
file | PrivateSemaphoreFactory.h [code]
Header file for the private semaphore factory class.
file | Process.h [code]
Header file for the process class.
file | ScatterBufferHelper.h [code]
Header file for the scatter buffer helper class.
file | SharedEventFactory.h [code]
Header file for the shared event factory class.
file | SharedMutexFactory.h [code]
Header file for the shared mutex factory class.
file | SharedObject.h [code]
Header file for the template shared object class.
file | SharedSemaphoreFactory.h [code]
Header file for the shared semaphore factory class.
file | Shell.h [code]
Header file for the shell class.
file | StatusCodeException.h [code]
Header file for the StatusCode exception class.
file | SystemInfo.h [code]
Header file for the system info class.
file | SystemMonitor.h [code]
Header file for the system monitor class.
file | Thread.h [code]
Header file for the thread class.
file | ThreadSpecificData.h [code]
Header file for thread specific data storage class.
file | ThreadSpecificPoolAllocators.h [code]
Thread-specific boost (fast_)pool_allocator like classes.
file | Timeout.h [code]
Header file for the timeout class.
file | Url.h [code]
Url parser & builder class.
file | Uuid.h [code]
Header file for the Uuid class.
Generated on Wed Oct 8 14:02:12 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase » Detail

Detail Directory Reference

Files

file | AtomicDetail.h [code]
Header file for implementation details for atomic operations.
file | CommandLineParserDetail.h [code]
Implementation details for CommandLineParser.
file | ThreadSpecificDataDetail.h [code]
Implementation details thread for specific data storage class.
Generated on Wed Oct 8 14:02:12 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase » Windows

Windows Directory Reference

Files

file | IoCompletionManager.h [code]
Header file for Windows I/O completion manager classes.
file | RegistryHelper.h [code]
Header file for the registry helper class.
file | SharedCompletionPortEventFactory.h [code]
Header file for the shared socket based event factory class.
Generated on Wed Oct 8 14:02:12 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivDatabase

ActivDatabase Directory Reference

Files

file | ActivDatabase.h [code]
Header file for the Activ database.
file | Database.h [code]
Header file for the Database class.
file | DatabaseException.h [code]
Header file for the database exception class.
file | DatabaseSpecification.h [code]
Header file for the database specification class.
file | Definitions.h [code]
Header file for the database definition information.
file | External.h [code]
Import rules for ActivDatabase exports.
file | FieldList.h [code]
Header file for the field list class.
file | FieldListObject.h [code]
Header file for the field list object class.
file | FieldSpecification.h [code]
Header file for the field specification class.
file | IIndex.h [code]
Header file for the index interface class.
file | IndexSpecification.h [code]
Header file for the index specification.
file | ITable.h [code]
Header file for the table interface class.
file | Key.h [code]
Header file for the key class.
file | ManagedTableFactory.h [code]
Header file for the managed table factory class.
file | Record.h [code]
Header file for the record class.
file | RemoteTableFactory.h [code]
Header file for the remote table factory class.
file | TableSpecification.h [code]
Header file for the table specification class.
file | UnmanagedTableFactory.h [code]
Header file for the unmanaged table factory class.
Generated on Wed Oct 8 14:02:12 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivFieldTypes

ActivFieldTypes Directory Reference

Files

file | ActivFieldTypes.h [code]
Global functions from ActivFieldTypes.
file | BinaryArray.h [code]
Header file for the binary array class.
file | BinaryString.h [code]
Header file for the binary string class.
file | Blob.h [code]
Header file for the blob class.
file | CrcBlob.h [code]
Header file for the crc blob class.
file | Date.h [code]
Header file for the date class.
file | DateTime.h [code]
Header file for the date / time class.
file | External.h [code]
Import rules for ActivFieldTypes exports.
file | FieldTypeFactory.h [code]
Header file for the field type factory class.
file | IFieldType.h [code]
Header file for the field type interface class.
file | Rational.h [code]
Header file for the rational class.
file | SInt.h [code]
Header file for the signed integer class.
file | TextArray.h [code]
Header file for the text array class.
file | TextString.h [code]
Header file for the text string class.
file | Time.h [code]
Header file for the time class.
file | TRational.h [code]
Header file for the trended rational class.
file | UInt.h [code]
Header file for the unsigned integer class.
Generated on Wed Oct 8 14:02:12 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivFramework

ActivFramework Directory Reference

Files

file | ActivFramework.h [code]
Main header file for framework.
file | Application.h [code]
Header file for base application class.
file | ChildService.h [code]
Header file for child service class.
file | Component.h [code]
Header file for component class.
file | DirectoryWatchApi.h [code]
Header file for the directory watch api.
file | External.h [code]
Import rules for ActivFramework exports.
file | LicenseServiceApi.h [code]
Header file for the license service api class.
file | LoggerDefinitions.h [code]
Header file for the common LoggerServiceApi / LoggerService definitions.
file | LoggerServiceApi.h [code]
Header file for the logger service api class.
file | Messages.h [code]
Header file for exported framework message classes.
file | PubSubServiceApi.h [code]
Header file for the pubsub service api.
file | RouterServiceApi.h [code]
Header file for router api.
file | Service.h [code]
Header file for service class.
file | ServiceApi.h [code]
Header file for service access api.
file | ServiceTypes.h [code]
Header file for various service related classes.
file | Subjects.h [code]
Header file for framework subject classes.
file | ThinApplication.h [code]
Header file for thin application class.
file | Timeband.h [code]
Header file for the timeband class..
file | TimeHelper.h [code]
Header file for time helper classes.
file | TimerServiceApi.h [code]
Header file for the timer service api.
file | UdpComponent.h [code]
Header file for udp component class.
file | UiComponent.h [code]
Header file for the ui component class.
file | UiIo.h [code]
Header file for the ui io class.
file | UiMainComponent.h [code]
Header file for the main ui component class.
file | UiMenu.h [code]
Header file for the ui menu class.
file | UiPermissions.h [code]
Header file for the ui permissions class.
Generated on Wed Oct 8 14:02:12 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivIp

ActivIp Directory Reference

Directories

directory | Windows

Files

file | External.h [code]
Import rules for ActivIp exports.
file | IpAddress.h [code]
Header file for ip address class.
file | IpException.h [code]
Header file for the Ip exception class.
file | IpManager.h [code]
Header file for base ip manager class.
file | IpSocket.h [code]
Header file for ip socket class.
file | SocketWrapper.h [code]
Header file for socket wrapper class.
file | TcpListener.h [code]
Header file for tcp listener class.
file | TcpSocket.h [code]
Header file for tcp socket class.
file | UdpSocket.h [code]
Header file for udp socket class.
Generated on Wed Oct 8 14:02:12 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivIp » Windows

Windows Directory Reference

Files

file | IpManager.h [code]
Header file for base ip manager class.
file | IpSocket.h [code]
Header file for ip socket class.
file | TcpListener.h [code]
Header file for tcp listener class.
file | TcpSocket.h [code]
Header file for tcp socket class.
file | UdpSocket.h [code]
Header file for udp socket class.
file | WsaBufHelper.h [code]
Header file for WSABUF helper class.
Generated on Wed Oct 8 14:02:12 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivSystem

ActivSystem Directory Reference

Files

file | ActivSystem.h [code]
Main ActivSystem header.
file | Address.h [code]
Address header file.
file | BasicTypes.h [code]
Basic types for ActivSystem.
file | External.h [code]
Import rules for ActivSystem exports.
file | HeapMessage.h [code]
Header file for heap message class.
file | HeapMessageBuilder.h [code]
Header file for heap message / message builder class.
file | HeapMessageDeserializer.h [code]
Header file for the heap message deserializer template class.
file | HeapPool.h [code]
Header file for heap pool class.
file | IEndPoint.h [code]
Header file for abstract endpoint class.
file | IHeap.h [code]
Header file for abstract heap class.
file | IProcess.h [code]
Header file for process interface class.
file | ISystem.h [code]
Header file for abstract system class.
file | ManagedEndPoint.h [code]
Header file for managed endpoint class.
file | MessageTypes.h [code]
Message types.
file | Port.h [code]
Header file for port class.
file | PostMessageHelper.h [code]
Header file for PostMessageHelper.
file | RequestId.h [code]
Header file for request id class.
file | ScopedAddress.h [code]
ScopedAddress header file.
file | Subject.h [code]
Subject type header file.
file | SyncRequestId.h [code]
Header file for synchronous request id class.
file | SystemException.h [code]
Header file for ActivSystem exception class.
file | SystemFactory.h [code]
Header file for system factory class.
Generated on Wed Oct 8 14:02:12 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » Config

Config Directory Reference

Directories

directory | Compilers
directory | Platforms

Files

file | Config.h [code]
Processor, compiler and platform selection header file.
Generated on Wed Oct 8 14:02:12 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » Config » Compilers

Compilers Directory Reference

Files

file | GCC.h [code]
GNU C++ configuration file.
file | Intel.h [code]
Intel C++ Compiler configuration file.
file | SunPro.h [code]
SunPro C++ configuration file.
file | VisualC.h [code]
Microsoft Visual C++ configuration file.
Generated on Wed Oct 8 14:02:12 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » Config » Platforms

Platforms Directory Reference

Files

file | Bsd.h [code]
BSD configuration file.
file | Linux.h [code]
Linux configuration file.
file | OSX.h [code]
OSX configuration file.
file | Solaris.h [code]
Solaris configuration file.
file | Windows.h [code]
Microsoft Windows configuration file.
Generated on Wed Oct 8 14:02:12 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » Misc

Misc Directory Reference

Directories

directory | Detail

Files

file | BitFields.h [code]
Header file for bit field helper classes.
file | CrtHelper.h [code]
Workarounds for crt disparities across platforms.
file | CurlFtpHelper.h [code]
Header file for the curl FTP helper class which user cUrl and ftpparser.
file | Des3Helper.h [code]
Helper class for DES3 functions in OpenSsl.
file | DesHelper.h [code]
Helper class for DES functions in OpenSsl.
file | DynamicLibraryLoader.h [code]
Header file for dynamic library loader helper classes.
file | FtpHelper.h [code]
Header file for the FTP helper class which user cUrl and ftpparser.
file | FtpParse.h [code]
file | FunctionObjects.h [code]
Header file for function objects.
file | HandleManager.h [code]
Header file for the handle manager class.
file | IFtpHelper.h [code]
Header file for the FTP helper class which user cUrl and ftpparser.
file | IntrusivePtrHelper.h [code]
Helper for using intrusive pointer class in a single threaded environment.
file | MemoryHelper.h [code]
Header file for the memory helper functions.
file | ObjectPool.h [code]
Class to cache a number of objects to avoid constructing/destructing them continually.
file | ScopedHelper.h [code]
Helper classes for creating scoped wrappers around other objects.
file | SerializableBuffer.h [code]
Serializable buffer.
file | SerializableContainerHelper.h [code]
Classes to help serialize STL containers.
file | Singleton.h [code]
Header file for singleton template.
file | SmtpHelper.h [code]
Smtp helper class.
file | StlHelper.h [code]
Work arounds for STL disparities across platforms, plus various helpers.
file | TemplateFunctions.h [code]
Header file for miscellaneous template functions with no other home.
file | WinFtpHelper.h [code]
Header file for the win FTP helper class which uses wininet.
Generated on Wed Oct 8 14:02:12 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » Misc » Detail

Detail Directory Reference

Files

file | DynamicLibraryLoaderDetail.h [code]
Header file for dynamic library loader helper implementation details.
file | SerializableContainerHelperDetail.h [code]
Classes to help serialize STL containers.
file | SerializableContainerHelperSpecializations.h [code]
Classes to help serialize STL containers.
Generated on Wed Oct 8 14:02:12 2008 for ACTIV C++ SDK by doxygen 1.5.4


  • File List
  • File Members
  • All
  • Functions
  • Defines
  • a
  • f
  • i
  • m
  • o
  • p
  • t
  • u

Here is a list of all documented file members with links to the documentation:

- a -

  • ACTIV_AGENT_SCOPE_LIST : External.h
  • ACTIV_ARRAY_SIZE : Activ.h
  • ACTIV_BASE_EXCEPTION_LIST : BaseException.h
  • ACTIV_BREAK_IF : StatusCodes.h
  • ACTIV_BREAK_IF_AND_IF : StatusCodes.h
  • ACTIV_BREAK_IF_OR_IF : StatusCodes.h
  • ACTIV_CONTENT_GATEWAY_API_VERSION_STRING : ActivContentGatewayApi.h
  • ACTIV_CONTENT_GATEWAY_API_VERSION_VALUE : ActivContentGatewayApi.h
  • ACTIV_CONTENT_GATEWAY_CLIENT_STATE_LIST : ContentGatewayClient.h
  • ACTIV_CONTENT_PLATFORM_MESSAGE_CLASS_LIST : MessageClasses.h
  • ACTIV_CONTENT_SERVER_API_VERSION_STRING : ActivContentServerApi.h
  • ACTIV_CONTENT_SERVER_API_VERSION_VALUE : ActivContentServerApi.h
  • ACTIV_CONTINUE_IF : StatusCodes.h
  • ACTIV_CONTINUE_IF_AND_IF : StatusCodes.h
  • ACTIV_CONTINUE_IF_OR_IF : StatusCodes.h
  • ACTIV_CONTRIBUTION_GATEWAY_API_STRING : ActivContributionGatewayApi.h
  • ACTIV_CONTRIBUTION_GATEWAY_API_VERSION_VALUE : ActivContributionGatewayApi.h
  • ACTIV_CONTRIBUTION_GATEWAY_CLIENT_STATE_LIST : ContributionGatewayClient.h
  • ACTIV_CONTRIBUTION_GATEWAY_RESPONSE_STATUS_LIST : PublishTypes.h
  • ACTIV_CONTRIBUTION_GATEWAY_USER_TYPE_LIST : Types.h
  • ACTIV_CONTRIBUTION_SERVER_API_VERSION_STRING : ContributionServerClient.h
  • ACTIV_CONTRIBUTION_SERVER_API_VERSION_VALUE : ContributionServerClient.h
  • ACTIV_DATABASE_API : External.h
  • ACTIV_DATABASE_EXCEPTION_LIST : DatabaseException.h
  • ACTIV_DATABASE_FIELD_ENUM : FieldSpecification.h
  • ACTIV_DATABASE_FIELD_SPECIFICATION : FieldSpecification.h
  • ACTIV_DATABASE_FIELD_TYPE_ENUM : FieldSpecification.h
  • ACTIV_DATABASE_FIELD_TYPE_LIST : FieldSpecification.h
  • ACTIV_DATABASE_FIELD_TYPE_SPECIFICATION : FieldSpecification.h
  • ACTIV_DATABASE_INDEX_ENUM : IndexSpecification.h
  • ACTIV_DATABASE_INDEX_ENUM_WITH_CACHE : IndexSpecification.h
  • ACTIV_DATABASE_INDEX_FIELD : IndexSpecification.h
  • ACTIV_DATABASE_INDEX_SPECIFICATION : IndexSpecification.h
  • ACTIV_DATABASE_INDEX_SPECIFICATION_WITH_CACHE : IndexSpecification.h
  • ACTIV_DAY_LIST : Date.h
  • ACTIV_DEBUG_ONLY : Activ.h
  • ACTIV_DECLARE_CONSTANT_ELEMENT_1 : Activ.h
  • ACTIV_DECLARE_CONTRIBUTION_GATEWAY_RESPONSE_STATUS : PublishTypes.h
  • ACTIV_DECLARE_DLL_FUNCTION : DynamicLibraryLoader.h
  • ACTIV_DECLARE_ELEMENT_1_WITH_COMMA : Activ.h
  • ACTIV_DECLARE_ELEMENT_2_WITH_COMMA : Activ.h
  • ACTIV_DECLARE_FIELD_STATUS : PublishTypes.h
  • ACTIV_DECLARE_FIELD_TYPE_ENUMERATIONS : ActivFieldTypes.h
  • ACTIV_DECLARE_HIDDEN_ELEMENT_1 : Activ.h
  • ACTIV_DECLARE_HIDDEN_ELEMENT_2 : Activ.h
  • ACTIV_DECLARE_HIDDEN_VALUE_WITH_COMMA : Activ.h
  • ACTIV_DECLARE_INDEX_PROPERTIES_ENUMERATIONS : IndexNumbers.h
  • ACTIV_DECLARE_INDEX_TYPE_ENUMERATIONS : IndexNumbers.h
  • ACTIV_DECLARE_INTRUSIVE_PTR_TYPEDEF : IntrusivePtrHelper.h
  • ACTIV_DECLARE_LOG_TYPE : ActivBase.h
  • ACTIV_DECLARE_MESSAGE_CLASS : MessageTypes.h
  • ACTIV_DECLARE_MESSAGE_TYPE : MessageTypes.h
  • ACTIV_DECLARE_RESPONSE_BLOCK_STATUS : RealtimeTypes.h
  • ACTIV_DECLARE_STATUS_CODE : StatusCodes.h
  • ACTIV_DECLARE_TABLE_RESET_TYPE_ENUMERATIONS : TableResetTypes.h
  • ACTIV_DECLARE_TABLE_TYPE_ENUMERATIONS : TableTypes.h
  • ACTIV_DECLARE_UNINITIALIZED_VARIABLE : GCC.h , Intel.h , SunPro.h , VisualC.h
  • ACTIV_DECLARE_VALUE_WITH_COMMA : Activ.h
  • ACTIV_DEFAULT_SYSTEM_HEAP_BUCKET_INFO : AgentApplication.h
  • ACTIV_DENOMINATOR_ENUMERATION : Rational.h
  • ACTIV_DENOMINATOR_LIST : Rational.h
  • ACTIV_DENOMINATOR_SPECIFICATION : Rational.h
  • ACTIV_DESERIALIZE_OBJECT : SerializableContainerHelperDetail.h
  • ACTIV_DO_STRINGIZE : Activ.h
  • ACTIV_ENHANCED_DEBUG_ONLY : Activ.h
  • ACTIV_EXCEPTION : Exception.h
  • ACTIV_FEED_DECLARE_COMPRESSED_MESSAGE_FIELD_SPECIFICATION : CompressedMessageDefinitions.h
  • ACTIV_FEED_INDEX_SPECIFICATION_PROPERTIES_LIST : IndexSpecification.h
  • ACTIV_FEED_INDEX_SPECIFICATION_TYPE_LIST : IndexSpecification.h
  • ACTIV_FEED_MESSAGE_TYPE_LIST : ActivFeedMessageHandler.h
  • ACTIV_FIELD_OFFSET : Activ.h
  • ACTIV_FIELD_SET_FILTER_STATUS_LIST : FieldSet.h
  • ACTIV_FIELD_SET_TYPE_LIST : FieldSet.h
  • ACTIV_FIELD_SIZE : Activ.h
  • ACTIV_FIELD_STATUS_LIST : PublishTypes.h
  • ACTIV_FIELD_STATUS_TYPE_LIST : FieldStatus.h
  • ACTIV_FIELD_TYPE_LIST : ActivFieldTypes.h
  • ACTIV_FORCE_INLINE : GCC.h , SunPro.h , VisualC.h
  • ACTIV_HISTORY_ADJUSTMENT_TYPE_LIST : HistoryBar.h
  • ACTIV_IENDPOINT_NOTIFICATION_TYPE_LIST : IEndPoint.h
  • ACTIV_IENDPOINT_STATE_LIST : IEndPoint.h
  • ACTIV_INDEX_PROPERTIES_LIST : IndexNumbers.h
  • ACTIV_INDEX_TYPE_LIST : IndexNumbers.h
  • ACTIV_INTRUSIVE_PTR_HELPER_ADD_REFERENCE_COUNTER : IntrusivePtrHelper.h
  • ACTIV_INTRUSIVE_PTR_HELPER_REFERENCE_COUNTER_NAME : IntrusivePtrHelper.h
  • ACTIV_IP_EXCEPTION_LIST : IpException.h
  • ACTIV_IP_SOCKET_STATE_LIST : TcpSocket.h
  • ACTIV_IPROCESS_STATE_LIST : IProcess.h
  • ACTIV_LOG_TYPE_LIST : ActivBase.h
  • ACTIV_MAKE_VERSION_VALUE : Activ.h
  • ACTIV_MESSAGE_CLASS_LIST : MessageTypes.h
  • ACTIV_MIDDLEWARE_VERSION_STRING : Activ.h
  • ACTIV_MIDDLEWARE_VERSION_VALUE : Activ.h
  • ACTIV_MONTH_LIST : Date.h
  • ACTIV_NEVER_INLINE : GCC.h , SunPro.h , VisualC.h
  • ACTIV_RELEASE_ONLY : Activ.h
  • ACTIV_RESPONSE_BLOCK_FLAG_LIST : RealtimeTypes.h
  • ACTIV_RESPONSE_BLOCK_STATUS_LIST : RealtimeTypes.h
  • ACTIV_RETHROW : Exception.h
  • ACTIV_RETURN_FALSE_IF : StatusCodes.h
  • ACTIV_RETURN_FALSE_IF_AND_IF : StatusCodes.h
  • ACTIV_RETURN_FALSE_IF_OR_IF : StatusCodes.h
  • ACTIV_RETURN_IF : StatusCodes.h
  • ACTIV_RETURN_IF_AND_IF : StatusCodes.h
  • ACTIV_RETURN_IF_OR_IF : StatusCodes.h
  • ACTIV_RETURN_RESULT_IF : StatusCodes.h
  • ACTIV_RETURN_RESULT_IF_AND_IF : StatusCodes.h
  • ACTIV_RETURN_RESULT_IF_OR_IF : StatusCodes.h
  • ACTIV_RETURN_TRUE_IF : StatusCodes.h
  • ACTIV_RETURN_TRUE_IF_AND_IF : StatusCodes.h
  • ACTIV_RETURN_TRUE_IF_OR_IF : StatusCodes.h
  • ACTIV_RETURN_VALUE_IF : StatusCodes.h
  • ACTIV_RETURN_VALUE_IF_AND_IF : StatusCodes.h
  • ACTIV_RETURN_VALUE_IF_OR_IF : StatusCodes.h
  • ACTIV_SERIALIZE_OBJECT : SerializableContainerHelperDetail.h
  • ACTIV_STATUS_CODE_LIST : StatusCodes.h
  • ACTIV_SYSTEM_EXCEPTION_LIST : SystemException.h
  • ACTIV_TABLE_RESET_TYPE_LIST : TableResetTypes.h
  • ACTIV_TABLE_TYPE_LIST : TableTypes.h
  • ACTIV_TCP_LISTENER_STATE_LIST : TcpListener.h
  • ACTIV_TEMPLATE_API : GCC.h , VisualC.h , SunPro.h , Intel.h
  • ACTIV_TEMPLATE_SELF : VisualC.h , SunPro.h , GCC.h
  • ACTIV_THROW : Exception.h
  • ACTIV_THROW_ERROR_IF : Exception.h
  • ACTIV_THROW_RESULT_IF : StatusCodeException.h
  • ACTIV_THROW_RESULT_IF_AND_IF : StatusCodeException.h
  • ACTIV_THROW_RESULT_IF_OR_IF : StatusCodeException.h
  • ACTIV_THROW_TABLE_TEMPLATE_EXCEPTION_IF : TableTemplateException.h
  • ACTIV_THROW_TABLE_TEMPLATE_EXCEPTION_IF_AND_IF : TableTemplateException.h
  • ACTIV_TICK_LIST : TRational.h
  • ACTIV_TIME_SERIES_HISTORY_FIELD_FILTER_TYPE_LIST : TimeSeriesTypes.h
  • ACTIV_TIME_SERIES_HISTORY_SERIES_TYPE_LIST : TimeSeriesTypes.h
  • ACTIV_TIME_SERIES_INTRADAY_FIELD_FILTER_TYPE_LIST : TimeSeriesTypes.h
  • ACTIV_TIME_SERIES_INTRADAY_RECORD_FILTER_TYPE_LIST : TimeSeriesTypes.h
  • ACTIV_TIME_SERIES_INTRADAY_SERIES_TYPE_LIST : TimeSeriesTypes.h
  • ACTIV_TIME_SERIES_PERIOD_TYPE_LIST : TimeSeriesTypes.h
  • ACTIV_TIME_SERIES_TICK_RECORD_FILTER_TYPE_LIST : TimeSeriesTypes.h
  • ACTIV_TIME_SERIES_TICK_SERIES_TYPE_LIST : TimeSeriesTypes.h
  • ACTIV_TREND_LIST : TRational.h
  • ACTIV_UDP_SOCKET_STATE_LIST : UdpSocket.h
  • ACTIV_USER_TYPE_LIST : Types.h

- f -

  • FIELDSETLIST_FIND_MODE_LIST : FieldSet.h
  • FILE_TYPE_LIST : LoggerDefinitions.h

- i -

  • intrusive_ptr_add_ref() : IntrusivePtrHelper.h
  • intrusive_ptr_release() : IntrusivePtrHelper.h

- m -

  • MakeMessageType : MessageTypes.h
  • MATCH_REQUEST_MATCH_TYPE_LIST : RealtimeTypes.h

- o -

  • operator<<() : Field.h , TableSpecification.h , IndexSpecification.h , FieldSpecification.h , FieldListObject.h , DatabaseSpecification.h , Exception.h , IndexSpecification.h , Index.h

- p -

  • POLICY_TYPE_LIST : ContentGatewayClient.h , ContributionGatewayClient.h

- t -

  • TICK_TYPE_LIST : Tick.h

- u -

  • UI_PERMISSIONS_LIST : UiPermissions.h
  • UPDATE_FIELDSET_STATUS_LIST : FieldSet.h
Generated on Wed Oct 8 14:02:12 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware

Activ.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_H)
00010 #define ACTIV_H
00011
00015 #define ACTIV_MAKE_VERSION_VALUE(a, b, c, d)                (((a) << 24) | ((b) << 16) | ((c) << 8) | (d))
00016
00020 #define ACTIV_MIDDLEWARE_VERSION_VALUE                      ACTIV_MAKE_VERSION_VALUE(99, 99, 99, 99)
00021
00025 #define ACTIV_MIDDLEWARE_VERSION_STRING                     "99.99.99.99"
00026
00027 // ---------------------------------------------------------------------------------------------------------------------------------
00028
00032 #define ACTIV_ARRAY_SIZE(a)                                 (sizeof((a)) / sizeof((a)[0]))
00033
00037 #define ACTIV_DECLARE_ELEMENT_1_WITH_COMMA(a, b)            a,
00038
00042 #define ACTIV_DECLARE_ELEMENT_2_WITH_COMMA(a, b)            b,
00043
00047 #define ACTIV_DECLARE_VALUE_WITH_COMMA(a)                   a,
00048
00052 #define ACTIV_DECLARE_HIDDEN_VALUE_WITH_COMMA(a)            ____##a,
00053
00057 #define ACTIV_DECLARE_HIDDEN_ELEMENT_1(a, b)                ____##a,
00058
00062 #define ACTIV_DECLARE_HIDDEN_ELEMENT_2(a, b)                ____##b,
00063
00067 #define ACTIV_DECLARE_CONSTANT_ELEMENT_1(type, a, b)        const type a = ____##a;
00068 #define ACTIV_DECLARE_STATIC_CONSTANT_ELEMENT_1(type, a, b) static const type a = ____##a;
00069
00073 #define ACTIV_DO_STRINGIZE(a)                               #a
00074 #define ACTIV_STRINGIZE(a)                                  ACTIV_DO_STRINGIZE(a)
00075 #define ACTIV_STRINGIZE_WITH_COMMA(a)                       ACTIV_DO_STRINGIZE(a),
00076
00080 #define ACTIV_FIELD_OFFSET(type, field)                     (reinterpret_cast<size_t>(&(reinterpret_cast<type *>(0)->*(&type::field))))
00081
00085 #define ACTIV_FIELD_SIZE(type, field)                       (sizeof(reinterpret_cast<type *>(0)->*(&type::field)))
00086
00087 // ---------------------------------------------------------------------------------------------------------------------------------
00088
00092 #if (defined _DEBUG)
00093 #define ACTIV_DEBUG_ONLY(a) a
00094 #else
00095 #define ACTIV_DEBUG_ONLY(a)
00096 #endif
00097
00101 #if (defined NDEBUG)
00102 #define ACTIV_RELEASE_ONLY(a)   a
00103 #else
00104 #define ACTIV_RELEASE_ONLY(a)
00105 #endif
00106
00110 #if (defined _DEBUG) && (defined ACTIV_ENABLE_ENHANCED_DEBUG)
00111 #define ACTIV_ENHANCED_DEBUG_ONLY(a)    a
00112 #else
00113 #define ACTIV_ENHANCED_DEBUG_ONLY(a)
00114 #endif
00115
00116 #include "Config/Config.h"
00117 #include "BasicTypes.h"
00118 #include "FormatSpecifiers.h"
00119 #include "StatusCodes.h"
00120 #include "Optimizations.h"
00121
00122 #if (defined _STLPORT_VERSION) && (!defined ACTIV_STLPORT)
00123 #error Non STLport build specified but STLport headers found
00124 #endif
00125
00126 #if (defined ACTIV_STLPORT) && (!defined _STLPORT_VERSION)
00127 #error STLport build specified but non STLport headers found
00128 #endif
00129
00130 #include "boost/noncopyable.hpp"
00131
00132 #endif // (!defined ACTIV_H)
Generated on Wed Oct 8 14:01:46 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

ActivBase.h

Go to the documentation of this file.
00001
00011 #if (!defined ACTIV_BASE_H)
00012 #define ACTIV_BASE_H
00013
00014 #include "ActivMiddleware/ActivBase/External.h"
00015
00016 #include "boost/format.hpp"
00017 #include "boost/array.hpp"
00018
00019 #include <sstream>
00020 #include <iostream>
00021 #include <string>
00022 #include <cstdarg>
00023
00029 #define ACTIV_LOG_TYPE_LIST(d)                  \
00030     d(0,    LOG_TYPE_DEBUG,     "Debug")        \
00031     d(1,    LOG_TYPE_INFO,      "Info")         \
00032     d(2,    LOG_TYPE_WARNING,   "Warning")      \
00033     d(3,    LOG_TYPE_ERROR,     "Error")
00034
00035 namespace Activ
00036 {
00037
00038 class MessageBuilder;
00039
00043 typedef byte_t LogType;
00044
00048 #define ACTIV_DECLARE_LOG_TYPE(value, id, name) const LogType id = value;
00049
00053 ACTIV_LOG_TYPE_LIST(ACTIV_DECLARE_LOG_TYPE)
00054
00055 // ---------------------------------------------------------------------------------------------------------------------------------
00056
00057
00063 ACTIV_BASE_EXPORTED_API void LogMessage(const LogType type, const char *message);
00064
00071 ACTIV_BASE_EXPORTED_API void LogMessage(const LogType type, const std::string &message);
00072
00080 ACTIV_BASE_EXPORTED_API void LogMessage(const LogType type, const boost::format &format);
00081
00089 ACTIV_BASE_EXPORTED_API std::string LogTypeToString(const LogType logType);
00090
00098 ACTIV_BASE_EXPORTED_API const std::string &StatusCodeToString(const StatusCode statusCode);
00099
00105 ACTIV_BASE_EXPORTED_API std::string OsErrorToString(const uint32_t errorCode);
00106
00115 ACTIV_BASE_EXPORTED_API StatusCode OsErrorToStatusCode(const uint32_t errorCode,
00116     const StatusCode defaultStatusCode = STATUS_CODE_FAILURE);
00117
00126 ACTIV_BASE_EXPORTED_API bool ReplaceEnvironmentVariables(const std::string &source, std::string &target);
00127
00139 ACTIV_BASE_EXPORTED_API size_t Snprintf(char *buff, const size_t buffLen, const char *format, ...);
00140
00152 ACTIV_BASE_EXPORTED_API size_t Vsnprintf(char *buff, const size_t buffLen, const char *format, std::va_list args);
00153
00172 template<size_t N>
00173 boost::array<char, N> SnprintfArray(const char *pFormat, ...);
00174
00185 ACTIV_BASE_EXPORTED_API std::string BufferToHexDumpString(const void * const pBuffer, const size_t bufferLength,
00186     const size_t bytesPerLine = 16, const size_t maxLines = 0);
00187
00195 ACTIV_BASE_EXPORTED_API void HexDump(const void * const pBuffer, const size_t bufferLength, std::ostream &outStream = std::cout);
00196
00205 ACTIV_BASE_EXPORTED_API StatusCode HexDumpStringToBuffer(const std::string &hexDumpString, MessageBuilder &messageBuilder);
00206
00231 ACTIV_BASE_EXPORTED_API uint32_t GenericHash(const void *pKeyBuffer, const size_t keyLength, const uint32_t initialValue);
00232
00245 ACTIV_BASE_EXPORTED_API StatusCode PlaySound(const void *pData, const size_t dataLength, const bool shouldPlayAsync = true);
00246
00247 // ---------------------------------------------------------------------------------------------------------------------------------
00248
00249 template<size_t N>
00250 boost::array<char, N> SnprintfArray(const char *pFormat, ...)
00251 {
00252     boost::array<char, N> array;
00253
00254     std::va_list args;
00255
00256     va_start(args, pFormat);
00257     (void) Vsnprintf(array.c_array(), N, pFormat, args);
00258     va_end(args);
00259
00260     return array;
00261 }
00262
00263 } // namespace Activ
00264
00265 // ---------------------------------------------------------------------------------------------------------------------------------
00266
00267 #if (defined ACTIV_PLATFORM_SOLARIS)
00268
00279 ACTIV_BASE_EXPORTED_API int daemon(int nochdir, int noclose);
00280
00281 #endif
00282
00283 #endif // (!defined ACTIV_BASE_H)
Generated on Wed Oct 8 14:01:46 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivContentGatewayApi

FieldListValidator.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_CONTENT_GATEWAY_API_FIELD_LIST_VALIDATOR_H)
00010 #define ACTIV_CONTENT_GATEWAY_API_FIELD_LIST_VALIDATOR_H
00011
00012 #include "ActivContentPlatform/ActivContentGatewayApi/External.h"
00013 #include "ActivContentPlatform/ActivFeedApiCommon/FieldListValidator.h"
00014
00015 namespace Activ
00016 {
00017
00018 namespace ContentPlatform
00019 {
00020
00021 namespace ContentGatewayApi
00022 {
00023
00029 class FieldListValidator : public FeedApi::FieldListValidator
00030 {
00031 public:
00035     ACTIV_CONTENT_GATEWAY_API FieldListValidator();
00036
00042     ACTIV_CONTENT_GATEWAY_API FieldListValidator(const FieldListValidator &rhs);
00043
00051     ACTIV_CONTENT_GATEWAY_API FieldListValidator(const FieldData &fieldData);
00052
00065     ACTIV_CONTENT_GATEWAY_API StatusCode Initialize(const FieldData &fieldData);
00066
00080     ACTIV_CONTENT_GATEWAY_API StatusCode ApplyUpdate(const FieldData &fieldData);
00081
00095     ACTIV_CONTENT_GATEWAY_API StatusCode ApplyUpdateToExistingFieldsOnly(const FieldData &fieldData);
00096
00110     using FeedApi::FieldListValidator::ApplyUpdate;
00111
00125     using FeedApi::FieldListValidator::ApplyUpdateToExistingFieldsOnly;
00126
00127     MessageValidator    m_messageValidator;
00128 };
00129
00130 } // namespace ContentGatewayApi
00131
00132 } // namespace ContentPlatform
00133
00134 } // namespace Activ
00135
00136 #endif // (!defined ACTIV_CONTENT_GATEWAY_API_FIELD_LIST_VALIDATOR_H)
Generated on Wed Oct 8 14:01:44 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivContentGatewayApi

RecordUpdateHelper.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_CONTENT_GATEWAY_API_RECORD_UPDATE_HELPER_H)
00010 #define ACTIV_CONTENT_GATEWAY_API_RECORD_UPDATE_HELPER_H
00011
00012 #include "ActivContentPlatform/ActivContentGatewayApi/External.h"
00013
00014 namespace Activ
00015 {
00016
00017 namespace ContentPlatform
00018 {
00019
00020 namespace ContentGatewayApi
00021 {
00022
00023 class ContentGatewayClient;
00024 class FieldListValidator;
00025
00026 // ---------------------------------------------------------------------------------------------------------------------------------
00027
00031 class RecordUpdateHelper
00032 {
00033 public:
00045     ACTIV_CONTENT_GATEWAY_API static StatusCode Deserialize(const ContentGatewayClient &client, const HeapMessage &update,
00046         RecordUpdate &recordUpdate);
00047
00061     ACTIV_CONTENT_GATEWAY_API static StatusCode Deserialize(const ContentGatewayClient &client, const HeapMessage &update,
00062         RecordUpdate &recordUpdate, FieldListValidator &fieldListValidator);
00063 };
00064
00065 } // namespace ContentGatewayApi
00066
00067 } // namespace ContentPlatform
00068
00069 } // namespace Activ
00070
00071 #endif // (!defined ACTIV_CONTENT_GATEWAY_API_RECORD_UPDATE_HELPER_H)
Generated on Wed Oct 8 14:01:45 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivContentGatewayApi

ActivContentGatewayApi.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_CONTENT_GATEWAY_API_H)
00010 #define ACTIV_CONTENT_GATEWAY_API_H
00011
00015 #define ACTIV_CONTENT_GATEWAY_API_VERSION_VALUE     ACTIV_MAKE_VERSION_VALUE(99, 99, 99, 99)
00016
00020 #define ACTIV_CONTENT_GATEWAY_API_VERSION_STRING    "99.99.99.99"
00021
00022 #include "ActivContentPlatform/ActivContentGatewayApi/ContentGatewayClient.h"
00023 #include "ActivContentPlatform/ActivContentGatewayApi/RecordUpdateHelper.h"
00024 #include "ActivContentPlatform/ActivContentGatewayApi/NewsUpdateHelper.h"
00025 #include "ActivContentPlatform/ActivContentGatewayApi/FieldListValidator.h"
00026
00027 #endif // (!defined ACTIV_CONTENT_GATEWAY_API_H)
Generated on Wed Oct 8 14:01:44 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivContentGatewayApiCommon

Types.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_CONTENT_GATEWAY_API_COMMON_TYPES_H)
00010 #define ACTIV_CONTENT_GATEWAY_API_COMMON_TYPES_H
00011
00012 #include "ActivContentPlatform/ActivContentGatewayApiCommon/External.h"
00013 #include "ActivContentPlatform/MessageClasses.h"
00014 #include "ActivContentPlatform/ActivFeedCommon/TableNumbers.h"
00015 #include "ActivContentPlatform/ActivFeedCommon/PermissionLevels.h"
00016
00017 #include "ActivMiddleware/ActivFieldTypes/UInt.h"
00018 #include "ActivMiddleware/Misc/SerializableBuffer.h"
00019
00020 namespace Activ
00021 {
00022
00023 class MessageValidator;
00024 class MessageBuilder;
00025
00026 namespace ContentPlatform
00027 {
00028
00029 namespace ContentGatewayApi
00030 {
00031
00035 ACTIV_DECLARE_MESSAGE_TYPE(1,   MESSAGE_CLASS_CONTENT_GATEWAY_API,  GATEWAY_REQUEST_UNSUBSCRIBE_COOKIE_SYMBOL);
00036 ACTIV_DECLARE_MESSAGE_TYPE(2,   MESSAGE_CLASS_CONTENT_GATEWAY_API,  GATEWAY_REQUEST_GET_FIRST);
00037 ACTIV_DECLARE_MESSAGE_TYPE(3,   MESSAGE_CLASS_CONTENT_GATEWAY_API,  GATEWAY_REQUEST_GET_LAST);
00038 ACTIV_DECLARE_MESSAGE_TYPE(4,   MESSAGE_CLASS_CONTENT_GATEWAY_API,  GATEWAY_REQUEST_GET_NEXT);
00039 ACTIV_DECLARE_MESSAGE_TYPE(5,   MESSAGE_CLASS_CONTENT_GATEWAY_API,  GATEWAY_REQUEST_GET_PREVIOUS);
00040 ACTIV_DECLARE_MESSAGE_TYPE(6,   MESSAGE_CLASS_CONTENT_GATEWAY_API,  GATEWAY_REQUEST_GET_EQUAL);
00041 ACTIV_DECLARE_MESSAGE_TYPE(7,   MESSAGE_CLASS_CONTENT_GATEWAY_API,  GATEWAY_REQUEST_GET_MULTIPLE_EQUAL);
00042 ACTIV_DECLARE_MESSAGE_TYPE(8,   MESSAGE_CLASS_CONTENT_GATEWAY_API,  GATEWAY_REQUEST_GET_MULTIPLE_PATTERN_MATCH);
00043 ACTIV_DECLARE_MESSAGE_TYPE(9,   MESSAGE_CLASS_CONTENT_GATEWAY_API,  GATEWAY_REQUEST_SUBSCRIBE_FEED);
00044 ACTIV_DECLARE_MESSAGE_TYPE(10,  MESSAGE_CLASS_CONTENT_GATEWAY_API,  GATEWAY_REQUEST_UNSUBSCRIBE_FEED);
00045 ACTIV_DECLARE_MESSAGE_TYPE(11,  MESSAGE_CLASS_CONTENT_GATEWAY_API,  GATEWAY_REQUEST_UNSUBSCRIBE_COOKIE);
00046 ACTIV_DECLARE_MESSAGE_TYPE(12,  MESSAGE_CLASS_CONTENT_GATEWAY_API,  GATEWAY_REQUEST_GET_FIRST_HISTORY);
00047 ACTIV_DECLARE_MESSAGE_TYPE(13,  MESSAGE_CLASS_CONTENT_GATEWAY_API,  GATEWAY_REQUEST_GET_NEXT_HISTORY);
00048 ACTIV_DECLARE_MESSAGE_TYPE(14,  MESSAGE_CLASS_CONTENT_GATEWAY_API,  GATEWAY_REQUEST_GET_FIRST_INTRADAY);
00049 ACTIV_DECLARE_MESSAGE_TYPE(15,  MESSAGE_CLASS_CONTENT_GATEWAY_API,  GATEWAY_REQUEST_GET_NEXT_INTRADAY);
00050 ACTIV_DECLARE_MESSAGE_TYPE(16,  MESSAGE_CLASS_CONTENT_GATEWAY_API,  GATEWAY_REQUEST_GET_FIRST_TICKS);
00051 ACTIV_DECLARE_MESSAGE_TYPE(17,  MESSAGE_CLASS_CONTENT_GATEWAY_API,  GATEWAY_REQUEST_GET_NEXT_TICKS);
00052 ACTIV_DECLARE_MESSAGE_TYPE(18,  MESSAGE_CLASS_CONTENT_GATEWAY_API,  GATEWAY_REQUEST_UNSUBSCRIBE_ALL);
00053 ACTIV_DECLARE_MESSAGE_TYPE(19,  MESSAGE_CLASS_CONTENT_GATEWAY_API,  GATEWAY_REQUEST_GET_MULTIPLE_PATTERN_MATCH_LIST);
00054 ACTIV_DECLARE_MESSAGE_TYPE(20,  MESSAGE_CLASS_CONTENT_GATEWAY_API,  GATEWAY_REQUEST_GET_SUBSCRIPTION_INFO);
00055 ACTIV_DECLARE_MESSAGE_TYPE(21,  MESSAGE_CLASS_CONTENT_GATEWAY_API,  GATEWAY_REQUEST_GET_MATCH);
00056 ACTIV_DECLARE_MESSAGE_TYPE(22,  MESSAGE_CLASS_CONTENT_GATEWAY_API,  GATEWAY_REQUEST_SUBSCRIBE_TABLE);
00057 ACTIV_DECLARE_MESSAGE_TYPE(23,  MESSAGE_CLASS_CONTENT_GATEWAY_API,  GATEWAY_REQUEST_GET_SYMBOLS);
00058 ACTIV_DECLARE_MESSAGE_TYPE(24,  MESSAGE_CLASS_CONTENT_GATEWAY_API,  GATEWAY_REQUEST_GET_MULTIPLE_MATCH);
00059 ACTIV_DECLARE_MESSAGE_TYPE(25,  MESSAGE_CLASS_CONTENT_GATEWAY_API,  GATEWAY_REQUEST_GET_SERVER_INFO);
00060 ACTIV_DECLARE_MESSAGE_TYPE(26,  MESSAGE_CLASS_CONTENT_GATEWAY_API,  GATEWAY_REQUEST_GET_PERMISSION_INFO);
00061 ACTIV_DECLARE_MESSAGE_TYPE(27,  MESSAGE_CLASS_CONTENT_GATEWAY_API,  GATEWAY_REQUEST_GET_NEWS_STORIES);
00062 ACTIV_DECLARE_MESSAGE_TYPE(28,  MESSAGE_CLASS_CONTENT_GATEWAY_API,  GATEWAY_REQUEST_GET_TABLE_INFO_LIST);
00063 ACTIV_DECLARE_MESSAGE_TYPE(29,  MESSAGE_CLASS_CONTENT_GATEWAY_API,  GATEWAY_REQUEST_GET_TABLE_SPECIFICATION);
00064 ACTIV_DECLARE_MESSAGE_TYPE(30,  MESSAGE_CLASS_CONTENT_GATEWAY_API,  GATEWAY_REQUEST_GET_UNIVERSAL_FIELD_HELPER_MAP);
00065 ACTIV_DECLARE_MESSAGE_TYPE(31,  MESSAGE_CLASS_CONTENT_GATEWAY_API,  GATEWAY_REQUEST_GET_RELATIONSHIP_INFO_LIST);
00066
00067 // ---------------------------------------------------------------------------------------------------------------------------------
00068
00072 ACTIV_DECLARE_MESSAGE_TYPE(0,   MESSAGE_CLASS_CONTENT_GATEWAY_API,  GATEWAY_MESSAGE_RECORD_UPDATE);
00073 ACTIV_DECLARE_MESSAGE_TYPE(1,   MESSAGE_CLASS_CONTENT_GATEWAY_API,  GATEWAY_MESSAGE_REPORT);
00074 ACTIV_DECLARE_MESSAGE_TYPE(2,   MESSAGE_CLASS_CONTENT_GATEWAY_API,  GATEWAY_MESSAGE_GREETING);
00075 ACTIV_DECLARE_MESSAGE_TYPE(3,   MESSAGE_CLASS_CONTENT_GATEWAY_API,  GATEWAY_MESSAGE_UNSUBSCRIBE_ALL);
00076 ACTIV_DECLARE_MESSAGE_TYPE(4,   MESSAGE_CLASS_CONTENT_GATEWAY_API,  GATEWAY_MESSAGE_UNSUBSCRIBE_COOKIE_LIST);
00077 ACTIV_DECLARE_MESSAGE_TYPE(5,   MESSAGE_CLASS_CONTENT_GATEWAY_API,  GATEWAY_MESSAGE_UNSUBSCRIBE_COOKIE_SYMBOL_LIST);
00078 ACTIV_DECLARE_MESSAGE_TYPE(6,   MESSAGE_CLASS_CONTENT_GATEWAY_API,  GATEWAY_MESSAGE_GET_USER_ID_COUNT);
00079 ACTIV_DECLARE_MESSAGE_TYPE(7,   MESSAGE_CLASS_CONTENT_GATEWAY_API,  GATEWAY_MESSAGE_USER_ID_COUNT);
00080 ACTIV_DECLARE_MESSAGE_TYPE(8,   MESSAGE_CLASS_CONTENT_GATEWAY_API,  GATEWAY_MESSAGE_SUB_LOGON);
00081 ACTIV_DECLARE_MESSAGE_TYPE(9,   MESSAGE_CLASS_CONTENT_GATEWAY_API,  GATEWAY_MESSAGE_SUB_LOGOFF);
00082 ACTIV_DECLARE_MESSAGE_TYPE(10,  MESSAGE_CLASS_CONTENT_GATEWAY_API,  GATEWAY_MESSAGE_FAILOVER);
00083 ACTIV_DECLARE_MESSAGE_TYPE(11,  MESSAGE_CLASS_CONTENT_GATEWAY_API,  GATEWAY_MESSAGE_STATS);
00084 ACTIV_DECLARE_MESSAGE_TYPE(12,  MESSAGE_CLASS_CONTENT_GATEWAY_API,  GATEWAY_MESSAGE_INTERNAL_LOGOFF);
00085 ACTIV_DECLARE_MESSAGE_TYPE(13,  MESSAGE_CLASS_CONTENT_GATEWAY_API,  GATEWAY_MESSAGE_CONTENT_GATEWAY_INFO_UPDATE);
00086 ACTIV_DECLARE_MESSAGE_TYPE(14,  MESSAGE_CLASS_CONTENT_GATEWAY_API,  GATEWAY_MESSAGE_NEWS_UPDATE);
00087 ACTIV_DECLARE_MESSAGE_TYPE(15,  MESSAGE_CLASS_CONTENT_GATEWAY_API,  GATEWAY_MESSAGE_DISOVERY_REQUEST);
00088 ACTIV_DECLARE_MESSAGE_TYPE(16,  MESSAGE_CLASS_CONTENT_GATEWAY_API,  GATEWAY_MESSAGE_DISOVERY_RESPONSE);
00089 ACTIV_DECLARE_MESSAGE_TYPE(17,  MESSAGE_CLASS_CONTENT_GATEWAY_API,  GATEWAY_MESSAGE_USER_SUBSCRIPTION_REQUEST);
00090 ACTIV_DECLARE_MESSAGE_TYPE(18,  MESSAGE_CLASS_CONTENT_GATEWAY_API,  GATEWAY_MESSAGE_USER_SUBSCRIPTION_RESPONSE);
00091 ACTIV_DECLARE_MESSAGE_TYPE(19,  MESSAGE_CLASS_CONTENT_GATEWAY_API,  GATEWAY_MESSAGE_USER_SUBSCRIPTION_UPDATE_ADD);
00092 ACTIV_DECLARE_MESSAGE_TYPE(20,  MESSAGE_CLASS_CONTENT_GATEWAY_API,  GATEWAY_MESSAGE_USER_SUBSCRIPTION_UPDATE_REMOVE);
00093
00094 // ---------------------------------------------------------------------------------------------------------------------------------
00095 // ---------------------------------------------------------------------------------------------------------------------------------
00096
00100 class SymbolId
00101 {
00102 public:
00103     typedef std::string Symbol;
00104
00108     SymbolId();
00109
00115     SymbolId(const Symbol &symbol);
00116
00123     SymbolId(const Feed::TableNo tableNumber, const Symbol &symbol);
00124
00132     bool operator<(const SymbolId &rhs) const;
00133
00141     bool operator==(const SymbolId &rhs) const;
00142
00150     bool operator!=(const SymbolId &rhs) const;
00151
00152     Feed::TableNo   m_tableNumber;
00153     Symbol          m_symbol;
00154 };
00155
00156 // ---------------------------------------------------------------------------------------------------------------------------------
00157
00158 inline SymbolId::SymbolId() :
00159     m_tableNumber(Feed::TABLE_NO_UNDEFINED)
00160 {
00161 }
00162
00163 // ---------------------------------------------------------------------------------------------------------------------------------
00164
00165 inline SymbolId::SymbolId(const Symbol &symbol) :
00166     m_tableNumber(Feed::TABLE_NO_UNDEFINED),
00167     m_symbol(symbol)
00168 {
00169 }
00170
00171 // ---------------------------------------------------------------------------------------------------------------------------------
00172
00173 inline SymbolId::SymbolId(const Feed::TableNo tableNumber, const Symbol &symbol) :
00174     m_tableNumber(tableNumber),
00175     m_symbol(symbol)
00176 {
00177 }
00178
00179 // ---------------------------------------------------------------------------------------------------------------------------------
00180
00181 inline bool SymbolId::operator==(const SymbolId &rhs) const
00182 {
00183     return m_symbol == rhs.m_symbol;
00184 }
00185
00186 // ---------------------------------------------------------------------------------------------------------------------------------
00187
00188 inline bool SymbolId::operator<(const SymbolId &rhs) const
00189 {
00190     return m_symbol < rhs.m_symbol;
00191 }
00192
00193 // ---------------------------------------------------------------------------------------------------------------------------------
00194
00195 inline bool SymbolId::operator!=(const SymbolId &rhs) const
00196 {
00197     return !(*this == rhs);
00198 }
00199
00200 // ---------------------------------------------------------------------------------------------------------------------------------
00201
00205 typedef std::vector<SymbolId> SymbolIdList;
00206
00207 // ---------------------------------------------------------------------------------------------------------------------------------
00208 // ---------------------------------------------------------------------------------------------------------------------------------
00209
00213 class FieldData
00214 {
00215 public:
00221     bool IsEmpty() const;
00222
00223     typedef SerializableBuffer<uint16_t> Buffer;
00224
00225     MessageHandler::MessageVersion  m_messageVersion;
00226     Buffer                          m_buffer;
00227 };
00228
00229 // ---------------------------------------------------------------------------------------------------------------------------------
00230
00231 inline bool FieldData::IsEmpty() const
00232 {
00233     return (0 == m_buffer.GetDataLength());
00234 }
00235
00236 // ---------------------------------------------------------------------------------------------------------------------------------
00237 // ---------------------------------------------------------------------------------------------------------------------------------
00238
00239 typedef uint32_t LogonFlags;
00240
00241 const LogonFlags LOGON_FLAG_NONE = 0x00000000;
00242 const LogonFlags LOGON_FLAG_DISCONNECT_EXISTING = 0x00000001;
00243
00244 // ---------------------------------------------------------------------------------------------------------------------------------
00245 // ---------------------------------------------------------------------------------------------------------------------------------
00246
00250 #define ACTIV_USER_TYPE_LIST(d)                                     \
00251     d(0,    USER_TYPE_CPP_API,              "C++ API")              \
00252     d(1,    USER_TYPE_WORKSTATION,          "Workstation")          \
00253     d(2,    USER_TYPE_ISV,                  "ISV")                  \
00254     d(3,    USER_TYPE_WORKSTATION_SERVICE,  "Workstation Service")  \
00255     d(4,    USER_TYPE_JAVA_API,             "Java API")             \
00256     d(5,    USER_TYPE_C_SHARP_API,          "C# API")
00257
00258 typedef uint8_t UserType;
00259
00260 #define ACTIV_DECLARE_CONSTANT_USER_TYPE(val, id, name) const UserType id = val;
00261
00262 ACTIV_USER_TYPE_LIST(ACTIV_DECLARE_CONSTANT_USER_TYPE)
00263
00264 #undef ACTIV_DECLARE_CONSTANT_USER_TYPE
00265
00266 // ---------------------------------------------------------------------------------------------------------------------------------
00267 // ---------------------------------------------------------------------------------------------------------------------------------
00268
00276 ACTIV_CONTENT_GATEWAY_API_COMMON_API std::string UserTypeToString(const UserType userType);
00277
00278 // ---------------------------------------------------------------------------------------------------------------------------------
00279 // ---------------------------------------------------------------------------------------------------------------------------------
00280
00281 #define ACTIV_DECLARE_FLAGS(value, id)  static const Flags id = value;
00282
00286 class ContentGatewayInfo
00287 {
00288 public:
00289     typedef std::vector<Feed::PermissionLevel>  PermissionLevelList;
00290
00291     #define ACTIV_CONTENT_GATEWAY_INFO_FLAG_LIST(d)                                                                                 \
00292         d(0x00, FLAG_NONE)                                                                                  \
00293         d(0x01, FLAG_HISTORY_SERVICE_CHANGED)                               \
00294         d(0x02, FLAG_SYMBOL_DIRECTORY_SERVICE_CHANGED)              \
00295         d(0x04, FLAG_NEWS_SERVER_SERVICE_CHANGED)
00297     typedef uint8_t Flags;
00298     ACTIV_CONTENT_GATEWAY_INFO_FLAG_LIST(ACTIV_DECLARE_FLAGS)
00299
00300     Flags               m_flags;
00301     ISystem::SystemInfo m_systemInfo;
00302     std::string         m_version;
00303     bool                m_isHistoryServiceAvailable;
00304     bool                m_isSymbolDirectoryServiceAvailable;
00305     bool                m_isNewsServerServiceAvailable;
00306     PermissionLevelList m_permissionLevelList;
00307 };
00308
00309 #undef ACTIV_DECLARE_FLAGS
00310
00311 // ---------------------------------------------------------------------------------------------------------------------------------
00312 // ---------------------------------------------------------------------------------------------------------------------------------
00313
00317 typedef uint32_t SubscriptionCookie;
00318
00319 const SubscriptionCookie SUBSCRIPTION_COOKIE_UNDEFINED = ~0;
00320
00321 // ---------------------------------------------------------------------------------------------------------------------------------
00322
00326 typedef std::vector<SubscriptionCookie> SubscriptionCookieList;
00327
00328 // ---------------------------------------------------------------------------------------------------------------------------------
00329 // ---------------------------------------------------------------------------------------------------------------------------------
00330
00334 class SubscriptionInfo
00335 {
00336 public:
00337     typedef std::map<SymbolId, uint32_t> SymbolSubscriptionMap;
00338     typedef std::map<Feed::TableNo, uint32_t> TableSubscriptionMap;
00339     typedef std::map<std::string, uint32_t> NewsSubscriptionMap;
00340
00341     SymbolSubscriptionMap   m_symbolSubscriptionMap;
00342     TableSubscriptionMap    m_tableSubscriptionMap;
00343     uint32_t                m_feedSubscriptionCount;
00344     NewsSubscriptionMap     m_newsSubscriptionMap;
00345 };
00346
00347 } // namespace ContentGatewayApi
00348
00349 } // namespace ContentPlatform
00350
00351 } // namespace Activ
00352
00353 #endif // (!defined ACTIV_CONTENT_GATEWAY_API_COMMON_TYPES_H)
Generated on Wed Oct 8 14:01:45 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivContentGatewayApi

External.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_CONTENT_GATEWAY_API_EXTERNAL_H)
00010 #define ACTIV_CONTENT_GATEWAY_API_EXTERNAL_H
00011
00012 #if (!defined ACTIV_CONTENT_GATEWAY_API)
00013 #   if (!defined ACTIV_STATIC)
00014 #       define ACTIV_CONTENT_GATEWAY_API ACTIV_IMPORT_DLL
00015 #   else
00016 #       define ACTIV_CONTENT_GATEWAY_API ACTIV_IMPORT_LIB
00017 #   endif // (!defined ACTIV_STATIC)
00018 #endif // (!defined ACTIV_CONTENT_GATEWAY_API)
00019
00020 #include "ActivMiddleware/ActivFramework/ActivFramework.h"
00021
00022 #include "ActivContentPlatform/ActivContentGatewayApiCommon/RealtimeTypes.h"
00023 #include "ActivContentPlatform/ActivContentGatewayApiCommon/TimeSeriesTypes.h"
00024 #include "ActivContentPlatform/ActivContentGatewayApiCommon/SymbolDirectoryTypes.h"
00025 #include "ActivContentPlatform/ActivContentGatewayApiCommon/NewsTypes.h"
00026 #include "ActivContentPlatform/ActivContentGatewayApiCommon/Tick.h"
00027 #include "ActivContentPlatform/ActivContentGatewayApiCommon/IntradayBar.h"
00028 #include "ActivContentPlatform/ActivContentGatewayApiCommon/HistoryBar.h"
00029 #include "ActivContentPlatform/ActivFeedCommon/UpdateIds.h"
00030 #include "ActivContentPlatform/ActivFeedCommon/EventTypes.h"
00031
00032 #endif // (!defined ACTIV_CONTENT_GATEWAY_API_EXTERNAL_H)
Generated on Wed Oct 8 14:01:44 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivContentGatewayApiCommon

External.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_CONTENT_GATEWAY_API_COMMON_EXTERNAL_H)
00010 #define ACTIV_CONTENT_GATEWAY_API_COMMON_EXTERNAL_H
00011
00012 #if (!defined ACTIV_CONTENT_GATEWAY_API_COMMON_API)
00013 #   if (!defined ACTIV_STATIC)
00014 #       define ACTIV_CONTENT_GATEWAY_API_COMMON_API ACTIV_IMPORT_DLL
00015 #   else
00016 #       define ACTIV_CONTENT_GATEWAY_API_COMMON_API ACTIV_IMPORT_LIB
00017 #   endif // (!defined ACTIV_STATIC)
00018 #endif // (!defined ACTIV_CONTENT_GATEWAY_API_COMMON_API)
00019
00020 #include "ActivMiddleware/ActivFramework/ActivFramework.h"
00021
00022 #endif // (!defined ACTIV_CONTENT_GATEWAY_API_COMMON_EXTERNAL_H)
Generated on Wed Oct 8 14:01:44 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivContentServerApi

External.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_CONTENT_SERVER_API_EXTERNAL_H)
00010 #define ACTIV_CONTENT_SERVER_API_EXTERNAL_H
00011
00012 #if (!defined ACTIV_CONTENT_SERVER_API)
00013 #   if (!defined ACTIV_STATIC)
00014 #       define ACTIV_CONTENT_SERVER_API ACTIV_IMPORT_DLL
00015 #   else
00016 #       define ACTIV_CONTENT_SERVER_API ACTIV_IMPORT_LIB
00017 #   endif // (!defined ACTIV_STATIC)
00018 #endif // (!defined ACTIV_CONTENT_SERVER_API)
00019
00020 #include "ActivMiddleware/ActivFramework/ActivFramework.h"
00021
00022 #endif // (!defined ACTIV_CONTENT_SERVER_API_EXTERNAL_H)
Generated on Wed Oct 8 14:01:44 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivContributionGatewayApi

External.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_CONTRIBUTION_GATEWAY_API_EXTERNAL_H)
00010 #define ACTIV_CONTRIBUTION_GATEWAY_API_EXTERNAL_H
00011
00012 #if (!defined ACTIV_CONTRIBUTION_GATEWAY_API)
00013 #   if (!defined ACTIV_STATIC)
00014 #       define ACTIV_CONTRIBUTION_GATEWAY_API ACTIV_IMPORT_DLL
00015 #   else
00016 #       define ACTIV_CONTRIBUTION_GATEWAY_API ACTIV_IMPORT_LIB
00017 #   endif // (!defined ACTIV_STATIC)
00018 #endif // (!defined ACTIV_CONTRIBUTION_GATEWAY_API)
00019
00020 #include "ActivMiddleware/ActivFramework/ActivFramework.h"
00021
00022 #include "ActivContentPlatform/ActivContributionGatewayApiCommon/PublishTypes.h"
00023
00024 #endif // (!defined ACTIV_CONTRIBUTION_GATEWAY_API_EXTERNAL_H)
Generated on Wed Oct 8 14:01:44 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivContributionGatewayApiCommon

External.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_CONTRIBUTION_GATEWAY_API_COMMON_EXTERNAL_H)
00010 #define ACTIV_CONTRIBUTION_GATEWAY_API_COMMON_EXTERNAL_H
00011
00012 #if (!defined ACTIV_CONTRIBUTION_GATEWAY_API_COMMON_API)
00013 #   if (!defined ACTIV_STATIC)
00014 #       define ACTIV_CONTRIBUTION_GATEWAY_API_COMMON_API ACTIV_IMPORT_DLL
00015 #   else
00016 #       define ACTIV_CONTRIBUTION_GATEWAY_API_COMMON_API ACTIV_IMPORT_LIB
00017 #   endif // (!defined ACTIV_STATIC)
00018 #endif // (!defined ACTIV_CONTRIBUTION_GATEWAY_API_COMMON_API)
00019
00020 #include "ActivMiddleware/ActivFramework/ActivFramework.h"
00021
00022 #endif // (!defined ACTIV_CONTRIBUTION_GATEWAY_API_COMMON_EXTERNAL_H)
Generated on Wed Oct 8 14:01:44 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivContributionServerApi

External.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_CONTRIBUTION_SERVER_API_EXTERNAL_H)
00010 #define ACTIV_CONTRIBUTION_SERVER_API_EXTERNAL_H
00011
00012 #if (!defined ACTIV_CONTRIBUTION_SERVER_API)
00013 #   if (!defined ACTIV_STATIC)
00014 #       define ACTIV_CONTRIBUTION_SERVER_API ACTIV_IMPORT_DLL
00015 #   else
00016 #       define ACTIV_CONTRIBUTION_SERVER_API ACTIV_IMPORT_LIB
00017 #   endif // (!defined ACTIV_STATIC)
00018 #endif // (!defined ACTIV_CONTRIBUTION_SERVER_API)
00019
00020 #include "ActivMiddleware/ActivFramework/ActivFramework.h"
00021
00022 #include "ActivContentPlatform/ActivFeedCommon/UpdateIds.h"
00023 #include "ActivContentPlatform/ActivFeedCommon/EventTypes.h"
00024
00025 #endif // (!defined ACTIV_CONTRIBUTION_SERVER_API_EXTERNAL_H)
Generated on Wed Oct 8 14:01:44 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedApiCommon

External.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FEED_API_COMMON_EXTERNAL_H)
00010 #define ACTIV_FEED_API_COMMON_EXTERNAL_H
00011
00012 #if (!defined ACTIV_FEED_API_COMMON_API)
00013 #   if (!defined ACTIV_STATIC)
00014 #       define ACTIV_FEED_API_COMMON_API ACTIV_IMPORT_DLL
00015 #   else
00016 #       define ACTIV_FEED_API_COMMON_API ACTIV_IMPORT_LIB
00017 #   endif // (!defined ACTIV_STATIC)
00018 #endif // (!defined ACTIV_FEED_API_COMMON_API)
00019
00020 #include "ActivMiddleware/ActivFramework/ActivFramework.h"
00021
00022 #endif // (!defined ACTIV_FEED_API_COMMON_EXTERNAL_H)
Generated on Wed Oct 8 14:01:44 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedMessageHandler

External.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FEED_MESSAGE_HANDLER_API)
00010 #   if (!defined ACTIV_STATIC)
00011 #       define ACTIV_FEED_MESSAGE_HANDLER_API ACTIV_IMPORT_DLL
00012 #   else
00013 #       define ACTIV_FEED_MESSAGE_HANDLER_API ACTIV_IMPORT_LIB
00014 #   endif // (!defined ACTIV_STATIC)
00015 #endif // (!defined ACTIV_FEED_MESSAGE_HANDLER_API)
00016
00017 #include "ActivMiddleware/Activ.h"
Generated on Wed Oct 8 14:01:44 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedTableTemplateHandler

External.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API)
00010 #   if (!defined ACTIV_STATIC)
00011 #       define ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API ACTIV_IMPORT_DLL
00012 #   else
00013 #       define ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API ACTIV_IMPORT_LIB
00014 #   endif // (!defined ACTIV_STATIC)
00015 #endif // (!defined ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API)
00016
00017 #include "ActivMiddleware/Activ.h"
Generated on Wed Oct 8 14:01:44 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedTableTemplateHandler

IndexSpecification.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FEED_TABLE_TEMPLATE_HANDLER_INDEX_SPECIFICATION_H)
00010 #define ACTIV_FEED_TABLE_TEMPLATE_HANDLER_INDEX_SPECIFICATION_H
00011
00012 #include "ActivMiddleware/ActivDatabase/IndexSpecification.h"
00013
00014 #include "ActivContentPlatform/ActivFeedCommon/FieldIds.h"
00015
00016 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/External.h"
00017
00018 #include <vector>
00019 #include <string>
00020
00021 // ---------------------------------------------------------------------------------------------------------------------------------
00022
00023 namespace Activ
00024 {
00025
00026 class MessageValidator;
00027 class MessageBuilder;
00028
00029 namespace ContentPlatform
00030 {
00031
00032 namespace Feed
00033 {
00034
00038 #define ACTIV_FEED_INDEX_SPECIFICATION_TYPE_LIST(d)     \
00039     d(TYPE_NONE,                    "None")             \
00040     d(TYPE_RED_BLACK_TREE,          "Red Black Tree")   \
00041     d(TYPE_HASH,                    "Hash")
00042
00046 #define ACTIV_FEED_INDEX_SPECIFICATION_PROPERTIES_LIST(d)   \
00047     d(PROPERTY_NONE,            "None")                     \
00048     d(PROPERTY_UNIQUE,          "Unique")                   \
00049     d(PROPERTY_DUPLICATE,       "Duplicate")
00050
00051 // ---------------------------------------------------------------------------------------------------------------------------------
00052
00053 class IndexSpecification
00054 {
00055 public:
00059     class ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API Field
00060     {
00061     public:
00065         Field();
00066
00074         explicit Field(const FieldId fieldId, const uint8_t sequence = 0, const uint16_t properties = 0);
00075
00076         FieldId         m_fieldId;
00077         uint8_t         m_sequence;
00078         uint16_t        m_properties;
00079     };
00080
00081     typedef std::vector<Field> FieldList;
00082     typedef uint8_t Number;
00083
00087     enum Type
00088     {
00089         ACTIV_FEED_INDEX_SPECIFICATION_TYPE_LIST(ACTIV_DECLARE_ELEMENT_1_WITH_COMMA)
00090         NUMBER_OF_TYPES
00091     };
00092
00096     enum Properties
00097     {
00098         ACTIV_FEED_INDEX_SPECIFICATION_PROPERTIES_LIST(ACTIV_DECLARE_ELEMENT_1_WITH_COMMA)
00099         NUMBER_OF_PROPERTIES
00100     };
00101
00105     IndexSpecification();
00106
00116     IndexSpecification(const Number number, const std::string &name, const Type type, const Properties properties,
00117                        const FieldList &fieldList);
00118
00128     void Set(const Number number, const std::string &name, const Type type, const Properties properties, const FieldList &fieldList);
00129
00135     Number GetNumber() const;
00136
00142     std::string GetName() const;
00143
00149     Type GetType() const;
00150
00156     Properties GetProperties() const;
00157
00163     void GetFieldList(FieldList &fieldList) const;
00164
00173     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API StatusCode Serialize(MessageBuilder &builder) const;
00174
00183     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API StatusCode Deserialize(MessageValidator &validator);
00184
00193     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API StatusCode Convert(Database::IndexSpecification &specification) const;
00194
00200     void ToStream(std::ostream &os) const;
00201
00202 private:
00203     Number          m_number;
00204     std::string     m_name;
00205     Type            m_type;
00206     Properties      m_properties;
00207     FieldList       m_fieldList;
00208 };
00209
00210 typedef std::vector<IndexSpecification>  IndexSpecificationList;
00211
00212 // ---------------------------------------------------------------------------------------------------------------------------------
00213
00214 inline IndexSpecification::IndexSpecification() :
00215     m_number(0),
00216     m_type(TYPE_NONE),
00217     m_properties(PROPERTY_UNIQUE)
00218 {
00219 }
00220
00221 // ---------------------------------------------------------------------------------------------------------------------------------
00222
00223 inline IndexSpecification::IndexSpecification(const Number number, const std::string &name, const Type type, const Properties properties,
00224                                               const FieldList &fieldList) :
00225     m_number(number),
00226     m_name(name),
00227     m_type(type),
00228     m_properties(properties),
00229     m_fieldList(fieldList)
00230 {
00231 }
00232
00233 // ---------------------------------------------------------------------------------------------------------------------------------
00234
00235 inline void IndexSpecification::Set(const Number number, const std::string &name, const Type type, const Properties properties,
00236                                     const FieldList &fieldList)
00237 {
00238     m_number = number;
00239     m_name = name;
00240     m_type = type;
00241     m_properties = properties;
00242     m_fieldList = fieldList;
00243 }
00244
00245 // ---------------------------------------------------------------------------------------------------------------------------------
00246
00247 inline IndexSpecification::Number IndexSpecification::GetNumber() const
00248 {
00249     return m_number;
00250 }
00251
00252 // ---------------------------------------------------------------------------------------------------------------------------------
00253
00254 inline std::string IndexSpecification::GetName() const
00255 {
00256     return m_name;
00257 }
00258
00259 // ---------------------------------------------------------------------------------------------------------------------------------
00260
00261 inline IndexSpecification::Type IndexSpecification::GetType() const
00262 {
00263     return m_type;
00264 }
00265
00266 // ---------------------------------------------------------------------------------------------------------------------------------
00267
00268 inline IndexSpecification::Properties IndexSpecification::GetProperties() const
00269 {
00270     return m_properties;
00271 }
00272
00273 // ---------------------------------------------------------------------------------------------------------------------------------
00274
00275 inline void IndexSpecification::GetFieldList(FieldList &fieldList) const
00276 {
00277     fieldList = m_fieldList;
00278 }
00279
00280 // ---------------------------------------------------------------------------------------------------------------------------------
00281 // ---------------------------------------------------------------------------------------------------------------------------------
00282
00283 inline IndexSpecification::Field::Field() :
00284     m_fieldId(0),
00285     m_sequence(0),
00286     m_properties(0)
00287 {
00288 }
00289
00290 // ---------------------------------------------------------------------------------------------------------------------------------
00291
00292 inline IndexSpecification::Field::Field(const FieldId fieldId, const uint8_t sequence, const uint16_t properties) :
00293     m_fieldId(fieldId),
00294     m_sequence(sequence),
00295     m_properties(properties)
00296 {
00297 }
00298
00299 // ---------------------------------------------------------------------------------------------------------------------------------
00300
00301 } // namespace Feed
00302
00303 } // namespace ContentPlatform
00304
00305 } // namespace Activ
00306
00307 // ---------------------------------------------------------------------------------------------------------------------------------
00308
00317 ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API std::ostream &operator<<(std::ostream &os, const Activ::ContentPlatform::Feed::IndexSpecification &rhs);
00318
00319 #endif // (!defined ACTIV_FEED_TABLE_TEMPLATE_HANDLER_INDEX_SPECIFICATION_H)
Generated on Wed Oct 8 14:01:46 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedTableTemplateHandler

TableSpecification.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FEED_TABLE_TEMPLATE_HANDLER_TABLE_SPECIFICATION_H)
00010 #define ACTIV_FEED_TABLE_TEMPLATE_HANDLER_TABLE_SPECIFICATION_H
00011
00012 #include "ActivMiddleware/ActivDatabase/Definitions.h"
00013
00014 #include "ActivContentPlatform/ActivFeedCommon/TableNumbers.h"
00015
00016 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/Field.h"
00017
00018 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/External.h"
00019
00020 #include <string>
00021 #include <vector>
00022
00023 namespace Activ
00024 {
00025
00026 class MessageValidator;
00027 class MessageBuilder;
00028
00029 namespace ContentPlatform
00030 {
00031
00032 namespace Feed
00033 {
00034
00035 class TableSpecification
00036 {
00037 public:
00041     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API TableSpecification();
00042
00050     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API TableSpecification(const TableId id, const std::string &name, const FieldMap &fieldMap);
00051
00059     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API void Set(const TableId id, const std::string &name, const FieldMap &fieldMap);
00060
00066     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API TableId GetId() const;
00067
00073     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API void GetName(std::string &name) const;
00074
00084     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API StatusCode GetField(const FieldId fieldId, Field &field) const;
00085
00091     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API void GetFieldMap(FieldMap &fieldMap) const;
00092
00101     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API StatusCode Serialize(MessageBuilder &builder);
00102
00111     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API StatusCode Deserialize(MessageValidator &validator);
00112
00121     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API StatusCode Convert(Database::FieldSpecificationList &fieldList) const;
00122
00131     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API static TableId GetId(const TableNo number, const TableVersion version);
00132
00140     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API static TableNo GetNumber(const TableId id);
00141
00149     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API static TableVersion GetVersion(const TableId id);
00150
00151 private:
00152     TableId         m_id;
00153     std::string     m_name;
00154     FieldMap        m_fieldMap;
00155 };
00156
00157 typedef std::vector<TableSpecification> TableSpecificationList;
00158
00159 // ---------------------------------------------------------------------------------------------------------------------------------
00160
00161 inline TableSpecification::TableSpecification() :
00162     m_id(0)
00163 {
00164 }
00165
00166 // ---------------------------------------------------------------------------------------------------------------------------------
00167
00168 inline TableSpecification::TableSpecification(const TableId id, const std::string &name, const FieldMap &fieldMap) :
00169     m_id(id),
00170     m_name(name),
00171     m_fieldMap(fieldMap)
00172 {
00173 }
00174
00175 // ---------------------------------------------------------------------------------------------------------------------------------
00176
00177 inline TableId TableSpecification::GetId() const
00178 {
00179     return m_id;
00180 }
00181
00182 // ---------------------------------------------------------------------------------------------------------------------------------
00183
00184 inline void TableSpecification::GetName(std::string &name) const
00185 {
00186     name = m_name;
00187 }
00188
00189 // ---------------------------------------------------------------------------------------------------------------------------------
00190
00191 inline void TableSpecification::GetFieldMap(FieldMap &fieldMap) const
00192 {
00193     fieldMap = m_fieldMap;
00194 }
00195
00196 } // namespace Feed
00197
00198 } // namespace ContentPlatform
00199
00200 } // namespace Activ
00201
00202 #endif // (!defined ACTIV_FEED_TABLE_TEMPLATE_HANDLER_TABLE_SPECIFICATION_H)
Generated on Wed Oct 8 14:01:46 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon

External.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FEED_COMMON_EXTERNAL_H)
00010 #define ACTIV_FEED_COMMON_EXTERNAL_H
00011
00012 #if (!defined ACTIV_FEED_COMMON_API)
00013 #   if (!defined ACTIV_STATIC)
00014 #       define ACTIV_FEED_COMMON_API ACTIV_IMPORT_DLL
00015 #   else
00016 #       define ACTIV_FEED_COMMON_API ACTIV_IMPORT_LIB
00017 #   endif // (!defined ACTIV_STATIC)
00018 #endif // (!defined ACTIV_FEED_COMMON_API)
00019
00020 #include "ActivMiddleware/ActivFramework/ActivFramework.h"
00021
00022 #endif // (!defined ACTIV_FEED_COMMON_EXTERNAL_H)
Generated on Wed Oct 8 14:01:44 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivContentServerApi

FieldListValidator.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_CONTENT_SERVER_API_FIELD_LIST_VALIDATOR_H)
00010 #define ACTIV_CONTENT_SERVER_API_FIELD_LIST_VALIDATOR_H
00011
00012 #include "ActivContentPlatform/ActivContentServerApi/External.h"
00013 #include "ActivContentPlatform/ActivFeedApiCommon/FieldListValidator.h"
00014
00015 namespace Activ
00016 {
00017
00018 namespace ContentPlatform
00019 {
00020
00021 namespace Feed
00022 {
00023
00024 class BaseUpdateMessageValidator;
00025 class FieldIdBitmap;
00026
00027 }
00028
00029 namespace ContentServerApi
00030 {
00031
00032 class ContentServerClient;
00033 class RecordUpdate;
00034 class SymbolRecordUpdate;
00035
00036 // ---------------------------------------------------------------------------------------------------------------------------------
00037
00043 class FieldListValidator : public FeedApi::FieldListValidator
00044 {
00045 public:
00051     ACTIV_CONTENT_SERVER_API FieldListValidator(ContentServerClient &contentServerClient);
00052
00058     ACTIV_CONTENT_SERVER_API FieldListValidator(const FieldListValidator &rhs);
00059
00068     ACTIV_CONTENT_SERVER_API FieldListValidator(ContentServerClient &contentServerClient, SymbolRecordUpdate &symbolRecordUpdate);
00069
00078     ACTIV_CONTENT_SERVER_API FieldListValidator(ContentServerClient &contentServerClient, RecordUpdate &recordUpdate);
00079
00092     ACTIV_CONTENT_SERVER_API StatusCode Initialize(SymbolRecordUpdate &symbolRecordUpdate);
00093
00106     ACTIV_CONTENT_SERVER_API StatusCode Initialize(RecordUpdate &recordUpdate);
00107
00121     ACTIV_CONTENT_SERVER_API StatusCode ApplyUpdate(SymbolRecordUpdate &symbolRecordUpdate);
00122
00136     ACTIV_CONTENT_SERVER_API StatusCode ApplyUpdate(RecordUpdate &recordUpdate);
00137
00151     ACTIV_CONTENT_SERVER_API StatusCode ApplyUpdate(Feed::BaseUpdateMessageValidator &baseUpdateMessageValidator);
00152
00166     using FeedApi::FieldListValidator::ApplyUpdate;
00167
00168 private:
00181     ACTIV_CONTENT_SERVER_API StatusCode Initialize(Feed::BaseUpdateMessageValidator &baseUpdateMessageValidator);
00182
00195     StatusCode InitializeFullyPermissioned(Feed::BaseUpdateMessageValidator &baseUpdateMessageValidator);
00196
00210     StatusCode InitializePartiallyPermissioned(Feed::BaseUpdateMessageValidator &baseUpdateMessageValidator,
00211         const Feed::FieldIdBitmap *pFieldIdBitmap);
00212
00226     ACTIV_CONTENT_SERVER_API StatusCode ApplyUpdateFullyPermissioned(Feed::BaseUpdateMessageValidator &baseUpdateMessageValidator);
00227
00242     ACTIV_CONTENT_SERVER_API StatusCode ApplyUpdatePartiallyPermissioned(
00243         Feed::BaseUpdateMessageValidator &baseUpdateMessageValidator, const Feed::FieldIdBitmap *pFieldIdBitmap);
00244
00245     ContentServerClient &m_contentServerClient;
00246 };
00247
00248 } // namespace ContentServerApi
00249
00250 } // namespace ContentPlatform
00251
00252 } // namespace Activ
00253
00254 #endif // (!defined ACTIV_CONTENT_SERVER_API_FIELD_LIST_VALIDATOR_H)
Generated on Wed Oct 8 14:01:44 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivContentServerApi

RecordUpdateHelper.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_CONTENT_SERVER_API_RECORD_UPDATE_HELPER_H)
00010 #define ACTIV_CONTENT_SERVER_API_RECORD_UPDATE_HELPER_H
00011
00012 #include "ActivContentPlatform/ActivContentServerApi/External.h"
00013
00014 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedDefinitions.h"
00015
00016 namespace Activ
00017 {
00018
00019 namespace ContentPlatform
00020 {
00021
00022 namespace Feed
00023 {
00024
00025 class BaseUpdateMessageValidator;
00026 class UpdateMessageValidator;
00027
00028 }
00029
00030 namespace ContentServerApi
00031 {
00032
00033 class FieldListValidator;
00034
00035 // ---------------------------------------------------------------------------------------------------------------------------------
00036
00040 template<typename MESSAGE_VALIDATOR>
00041 class RecordUpdateHelper
00042 {
00043 public:
00049     ACTIV_CONTENT_SERVER_API RecordUpdateHelper(MESSAGE_VALIDATOR &messageValidator);
00050
00056     ACTIV_CONTENT_SERVER_API Feed::TableNo GetTableNumber() const;
00057
00063     ACTIV_CONTENT_SERVER_API Feed::UpdateId GetUpdateId() const;
00064
00070     ACTIV_CONTENT_SERVER_API Feed::PermissionId GetPermissionId() const;
00071
00077     ACTIV_CONTENT_SERVER_API Feed::EventType GetEventType() const;
00078
00084     ACTIV_CONTENT_SERVER_API bool IsDelete() const;
00085
00091     ACTIV_CONTENT_SERVER_API bool IsNewRecord() const;
00092
00098     ACTIV_CONTENT_SERVER_API bool IsStale() const;
00099
00105     ACTIV_CONTENT_SERVER_API bool IsRefresh() const;
00106
00107 protected:
00108     MESSAGE_VALIDATOR &m_messageValidator;
00109
00110     friend class FieldListValidator;
00111 };
00112
00113 // ---------------------------------------------------------------------------------------------------------------------------------
00114 // ---------------------------------------------------------------------------------------------------------------------------------
00115
00119 class SymbolRecordUpdate : public RecordUpdateHelper<Feed::BaseUpdateMessageValidator>
00120 {
00121 public:
00128     SymbolRecordUpdate(Feed::BaseUpdateMessageValidator &baseUpdateMessageValidator, const std::string &symbol);
00129
00135     ACTIV_CONTENT_SERVER_API const std::string &GetSymbol() const;
00136
00137 private:
00138     std::string m_symbol;
00139 };
00140
00141 // ---------------------------------------------------------------------------------------------------------------------------------
00142 // ---------------------------------------------------------------------------------------------------------------------------------
00143
00147 class RecordUpdate : public RecordUpdateHelper<Feed::UpdateMessageValidator>
00148 {
00149 public:
00150     typedef std::pair<Feed::FieldId, IFieldType *> KeyField;
00151     typedef std::vector<KeyField> KeyFieldList;
00152     typedef KeyFieldList::const_iterator ConstKeyFieldIterator;
00153
00159     RecordUpdate(Feed::UpdateMessageValidator &updateMessageValidator);
00160
00166     ACTIV_CONTENT_SERVER_API Feed::IndexNumber GetIndexNumber() const;
00167
00173     ACTIV_CONTENT_SERVER_API size_t GetNumberOfKeyFields() const;
00174
00180     ACTIV_CONTENT_SERVER_API ConstKeyFieldIterator BeginKeyField() const;
00181
00187     ACTIV_CONTENT_SERVER_API ConstKeyFieldIterator EndKeyField() const;
00188 };
00189
00190 } // namespace ContentServerApi
00191
00192 } // namespace ContentPlatform
00193
00194 } // namespace Activ
00195
00196 #endif // (!defined ACTIV_CONTENT_SERVER_API_RECORD_UPDATE_HELPER_H)
Generated on Wed Oct 8 14:01:45 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivContentServerApi

ActivContentServerApi.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_CONTENT_SERVER_API_H)
00010 #define ACTIV_CONTENT_SERVER_API_H
00011
00015 #define ACTIV_CONTENT_SERVER_API_VERSION_VALUE  ACTIV_MAKE_VERSION_VALUE(99, 99, 99, 99)
00016
00020 #define ACTIV_CONTENT_SERVER_API_VERSION_STRING "99.99.99.99"
00021
00022 #include "ActivContentPlatform/ActivContentServerApi/ContentServerClient.h"
00023 #include "ActivContentPlatform/ActivContentServerApi/FieldListValidator.h"
00024
00025 #endif // (!defined ACTIV_CONTENT_SERVER_API_H)
Generated on Wed Oct 8 14:01:45 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivContributionGatewayApi

ActivContributionGatewayApi.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_CONTRIBUTION_GATEWAY_API_H)
00010 #define ACTIV_CONTRIBUTION_GATEWAY_API_H
00011
00015 #define ACTIV_CONTRIBUTION_GATEWAY_API_VERSION_VALUE    ACTIV_MAKE_VERSION_VALUE(99, 99, 99, 99)
00016
00020 #define ACTIV_CONTRIBUTION_GATEWAY_API_STRING           "99.99.99.99"
00021
00022 #include "ActivContentPlatform/ActivContributionGatewayApi/ContributionGatewayClient.h"
00023 #include "ActivContentPlatform/ActivContributionGatewayApi/PublishRequestHelper.h"
00024
00025 #endif // (!defined ACTIV_CONTRIBUTION_GATEWAY_API_H)
Generated on Wed Oct 8 14:01:45 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivContributionGatewayApiCommon

Types.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_CONTRIBUTION_GATEWAY_API_COMMON_TYPES_H)
00010 #define ACTIV_CONTRIBUTION_GATEWAY_API_COMMON_TYPES_H
00011
00012 #include "ActivContentPlatform/ActivContributionGatewayApiCommon/External.h"
00013 #include "ActivContentPlatform/MessageClasses.h"
00014 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedDefinitions.h"
00015
00016 namespace Activ
00017 {
00018
00019 namespace ContentPlatform
00020 {
00021
00022 namespace ContributionGatewayApi
00023 {
00024
00028 ACTIV_DECLARE_MESSAGE_TYPE(0,   MESSAGE_CLASS_CONTRIBUTION_GATEWAY, CONTRIBUTION_GATEWAY_REQUEST_PUBLISH_SYMBOL_RECORD);
00029 ACTIV_DECLARE_MESSAGE_TYPE(1,   MESSAGE_CLASS_CONTRIBUTION_GATEWAY, CONTRIBUTION_GATEWAY_REQUEST_DELETE_SYMBOL_RECORD);
00030 ACTIV_DECLARE_MESSAGE_TYPE(2,   MESSAGE_CLASS_CONTRIBUTION_GATEWAY, CONTRIBUTION_GATEWAY_REQUEST_GET_SERVER_INFO);
00031 ACTIV_DECLARE_MESSAGE_TYPE(3,   MESSAGE_CLASS_CONTRIBUTION_GATEWAY, CONTRIBUTION_GATEWAY_REQUEST_PUBLISH_RECORD);
00032 ACTIV_DECLARE_MESSAGE_TYPE(4,   MESSAGE_CLASS_CONTRIBUTION_GATEWAY, CONTRIBUTION_GATEWAY_REQUEST_DELETE_RECORD);
00033 ACTIV_DECLARE_MESSAGE_TYPE(5,   MESSAGE_CLASS_CONTRIBUTION_GATEWAY, CONTRIBUTION_GATEWAY_REQUEST_GET_PERMISSION_INFO);
00034
00035 // ---------------------------------------------------------------------------------------------------------------------------------
00036
00040 ACTIV_DECLARE_MESSAGE_TYPE(0,   MESSAGE_CLASS_CONTRIBUTION_GATEWAY, CONTRIBUTION_GATEWAY_MESSAGE_REPORT);
00041 ACTIV_DECLARE_MESSAGE_TYPE(1,   MESSAGE_CLASS_CONTRIBUTION_GATEWAY, CONTRIBUTION_GATEWAY_MESSAGE_FAILOVER);
00042 ACTIV_DECLARE_MESSAGE_TYPE(2,   MESSAGE_CLASS_CONTRIBUTION_GATEWAY, CONTRIBUTION_GATEWAY_MESSAGE_STATS);
00043 ACTIV_DECLARE_MESSAGE_TYPE(3,   MESSAGE_CLASS_CONTRIBUTION_GATEWAY, CONTRIBUTION_GATEWAY_MESSAGE_GREETING);
00044 ACTIV_DECLARE_MESSAGE_TYPE(4,   MESSAGE_CLASS_CONTRIBUTION_GATEWAY, CONTRIBUTION_GATEWAY_MESSAGE_GET_USER_ID_COUNT);
00045 ACTIV_DECLARE_MESSAGE_TYPE(5,   MESSAGE_CLASS_CONTRIBUTION_GATEWAY, CONTRIBUTION_GATEWAY_MESSAGE_USER_ID_COUNT);
00046
00047 // ---------------------------------------------------------------------------------------------------------------------------------
00048
00052 #define ACTIV_CONTRIBUTION_GATEWAY_USER_TYPE_LIST(d)                            \
00053     d(0,    CONTRIBUTION_GATEWAY_USER_TYPE_API,                 "Api")          \
00054     d(1,    CONTRIBUTION_GATEWAY_USER_TYPE_DOT_NET_API,         ".Net Api")     \
00055     d(2,    CONTRIBUTION_GATEWAY_USER_TYPE_JAVA_API,            "Java Api")     \
00056     d(3,    CONTRIBUTION_GATEWAY_USER_TYPE_ISV,                 "Isv")
00057
00058 typedef uint8_t UserType;
00059
00060 #define ACTIV_DECLARE_CONSTANT_USER_TYPE(val, id, name) const UserType id = val;
00061
00062 ACTIV_CONTRIBUTION_GATEWAY_USER_TYPE_LIST(ACTIV_DECLARE_CONSTANT_USER_TYPE)
00063
00064 #undef ACTIV_DECLARE_CONSTANT_USER_TYPE
00065
00066 // ---------------------------------------------------------------------------------------------------------------------------------
00067
00075 ACTIV_CONTRIBUTION_GATEWAY_API_COMMON_API std::string UserTypeToString(const UserType userType);
00076
00077 // ---------------------------------------------------------------------------------------------------------------------------------
00078
00082 class ContributionGatewayInfo
00083 {
00084 public:
00085     ISystem::SystemInfo m_systemInfo;
00086 };
00087
00088 // ---------------------------------------------------------------------------------------------------------------------------------
00089 // ---------------------------------------------------------------------------------------------------------------------------------
00090
00091 #define ACTIV_DECLARE_FLAGS(value, id)  static const Flags id = value;
00092
00096 class PermissionInfo
00097 {
00098 public:
00099     typedef std::list<std::string> ExchangeCodeList;
00100     typedef uint8_t Flags;
00101
00102     #define ACTIV_PERMISSION_INFO_FLAG_LIST(d)                              \
00103         d(0x00, FLAG_NONE)                                                  \
00104         d(0x01, FLAG_ALL_PERMISSION_IDS)            \
00105         d(0x02, FLAG_ALL_TABLE_NUMBERS)             \
00106         d(0x04, FLAG_ALL_EXCHANGE_CODES)
00108     ACTIV_PERMISSION_INFO_FLAG_LIST(ACTIV_DECLARE_FLAGS)
00109
00110     Feed::PermissionIdList      m_permissionIdList;
00111     Feed::TableNoList           m_tableNumberList;
00112     ExchangeCodeList            m_exchangeCodeList;
00113     Flags                       m_flags;
00114 };
00115
00116 #undef ACTIV_DECLARE_FLAGS
00117
00118 } // namespace ContributionGatewayApi
00119
00120 } // namespace ContentPlatform
00121
00122 } // namespace Activ
00123
00124 #endif // (!defined ACTIV_CONTRIBUTION_GATEWAY_API_COMMON_TYPES_H)
Generated on Wed Oct 8 14:01:45 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivDatabase

ActivDatabase.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_DATABASE_H)
00010 #define ACTIV_DATABASE_H
00011
00012 #include "ActivMiddleware/ActivDatabase/External.h"
00013
00014 #include "ActivMiddleware/ActivFieldTypes/Blob.h"
00015 #include "ActivMiddleware/ActivFieldTypes/CrcBlob.h"
00016 #include "ActivMiddleware/ActivFieldTypes/Date.h"
00017 #include "ActivMiddleware/ActivFieldTypes/DateTime.h"
00018 #include "ActivMiddleware/ActivFieldTypes/Rational.h"
00019 #include "ActivMiddleware/ActivFieldTypes/Time.h"
00020 #include "ActivMiddleware/ActivFieldTypes/TRational.h"
00021
00022 #include <iostream>
00023
00024 namespace Activ
00025 {
00026
00027 namespace Database
00028 {
00029
00030 class ITable;
00031 class FieldSpecification;
00032
00044 ACTIV_DATABASE_API ITable *OpenTable(const std::string &tableFileName, const bool createRecordFile = true, const bool createIndexes = true);
00045
00051 void ValidateSpecification(const FieldSpecification &fieldSpecification);
00052
00060 void ValidateBooleanSpecification(const FieldSpecification &fieldSpecification);
00061
00069 void ValidateBlobSpecification(const FieldSpecification &fieldSpecification);
00070
00078 void ValidateCrcBlobSpecification(const FieldSpecification &fieldSpecification);
00079
00087 void ValidateDateSpecification(const FieldSpecification &fieldSpecification);
00088
00096 void ValidateDateTimeSpecification(const FieldSpecification &fieldSpecification);
00097
00105 void ValidateNoneSpecification(const FieldSpecification &fieldSpecification);
00106
00114 void ValidateRationalSpecification(const FieldSpecification &fieldSpecification);
00115
00123 void ValidateSignedIntegralSpecification(const FieldSpecification &fieldSpecification);
00124
00132 void ValidateTimeSpecification(const FieldSpecification &fieldSpecification);
00133
00141 void ValidateTRationalSpecification(const FieldSpecification &fieldSpecification);
00142
00150 void ValidateUnsignedIntegralSpecification(const FieldSpecification &fieldSpecification);
00151
00152 // ---------------------------------------------------------------------------------------------------------------------------------
00153
00164 inline int CompareBlob(const byte_t *pLhsData, const size_t lhsLength, const byte_t *pRhsData, const size_t rhsLength)
00165 {
00166     int result;
00167     (void) Blob::Compare(pLhsData, lhsLength, pRhsData, rhsLength, result);
00168     return result;
00169 }
00170
00171 // ---------------------------------------------------------------------------------------------------------------------------------
00172
00183 inline int CompareCrcBlob(const byte_t *pLhsData, const size_t lhsLength, const byte_t *pRhsData, const size_t rhsLength)
00184 {
00185     int result;
00186     (void) CrcBlob::Compare(pLhsData, lhsLength, pRhsData, rhsLength, result);
00187     return result;
00188 }
00189
00190 // ---------------------------------------------------------------------------------------------------------------------------------
00191
00202 inline int CompareDate(const byte_t *pLhsData, const size_t lhsLength, const byte_t *pRhsData, const size_t rhsLength)
00203 {
00204     int result;
00205     (void) Date::Compare(pLhsData, lhsLength, pRhsData, rhsLength, result);
00206     return result;
00207 }
00208
00209 // ---------------------------------------------------------------------------------------------------------------------------------
00210
00221 inline int CompareDateTime(const byte_t *pLhsData, const size_t lhsLength, const byte_t *pRhsData, const size_t rhsLength)
00222 {
00223     int result;
00224     (void) DateTime::Compare(pLhsData, lhsLength, pRhsData, rhsLength, result);
00225     return result;
00226 }
00227
00228 // ---------------------------------------------------------------------------------------------------------------------------------
00229
00240 inline int CompareRational(const byte_t *pLhsData, const size_t lhsLength, const byte_t *pRhsData, const size_t rhsLength)
00241 {
00242     // TODO: Need to work out what the appropriate behaviour is if Compare fails
00243     int result;
00244     (void) Rational::Compare(pLhsData, lhsLength, pRhsData, rhsLength, result);
00245     return result;
00246 }
00247
00248 // ---------------------------------------------------------------------------------------------------------------------------------
00249
00260 inline int CompareTime(const byte_t *pLhsData, const size_t lhsLength, const byte_t *pRhsData, const size_t rhsLength)
00261 {
00262     int result;
00263     (void) Time::Compare(pLhsData, lhsLength, pRhsData, rhsLength, result);
00264     return result;
00265 }
00266
00267 // ---------------------------------------------------------------------------------------------------------------------------------
00268
00279 inline int CompareTRational(const byte_t *pLhsData, const size_t lhsLength, const byte_t *pRhsData, const size_t rhsLength)
00280 {
00281     // TODO: Need to work out what the appropriate behaviour is if Compare fails
00282     int result;
00283     (void) TRational::Compare(pLhsData, lhsLength, pRhsData, rhsLength, result);
00284     return result;
00285 }
00286
00297 int CompareUnsignedMemory(const byte_t *pLhsData, const size_t lhsLength, const byte_t *pRhsData, const size_t rhsLength);
00298
00308 int Umemcmp(const byte_t *pLhsData, const byte_t *pRhsData, size_t length);
00309
00320 int CompareSignedIntegral(const byte_t *pLhsData, const size_t lhsLength, const byte_t *pRhsData, const size_t rhsLength);
00321
00332 int CompareUnsignedIntegral(const byte_t *pLhsData, const size_t lhsLength, const byte_t *pRhsData, const size_t rhsLength);
00333
00342 int64_t GetSignedInt64(const void *pData, const size_t length);
00343
00352 uint64_t GetUnsignedInt64(const void *pData, const size_t length);
00353
00362 std::string BinaryToString(const byte_t *pSourceData, const size_t length);
00363
00372 std::string BooleanToString(const byte_t *pSourceData, const size_t length);
00373
00382 std::string BlobToString(const byte_t *pSourceData, const size_t length);
00383
00392 std::string CrcBlobToString(const byte_t *pSourceData, const size_t length);
00393
00402 std::string DateToString(const byte_t *pSourceData, const size_t length);
00403
00412 std::string DateTimeToString(const byte_t *pSourceData, const size_t length);
00413
00422 std::string RationalToString(const byte_t *pSourceData, const size_t length);
00423
00432 std::string SignedIntegralToString(const byte_t *pSourceData, const size_t length);
00433
00442 std::string TextToString(const byte_t *pSourceData, const size_t length);
00443
00452 std::string TimeToString(const byte_t *pSourceData, const size_t length);
00453
00462 std::string TRationalToString(const byte_t *pSourceData, const size_t length);
00463
00472 std::string UnsignedIntegralToString(const byte_t *pSourceData, const size_t length);
00473
00474 }   // namespace Database
00475
00476 }   // namespace Activ
00477
00478 #endif // (!defined ACTIV_DATABASE_H)
Generated on Wed Oct 8 14:01:47 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon

ActivFeed.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FEED_H)
00010 #define ACTIV_FEED_H
00011
00012 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedDefinitions.h"
00013 #include "ActivContentPlatform/ActivFeedCommon/EventTypes.h"
00014 #include "ActivContentPlatform/ActivFeedCommon/FieldIds.h"
00015 #include "ActivContentPlatform/ActivFeedCommon/IndexNumbers.h"
00016 #include "ActivContentPlatform/ActivFeedCommon/PermissionIds.h"
00017 #include "ActivContentPlatform/ActivFeedCommon/RelationshipIds.h"
00018 #include "ActivContentPlatform/ActivFeedCommon/TableNumbers.h"
00019 #include "ActivContentPlatform/ActivFeedCommon/TableTypes.h"
00020 #include "ActivContentPlatform/ActivFeedCommon/UpdateIds.h"
00021
00022 #endif // (!defined ACTIV_FEED_H)
Generated on Wed Oct 8 14:01:45 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedApiCommon

FieldListValidator.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FEED_API_COMMON_FIELD_LIST_VALIDATOR_H)
00010 #define ACTIV_FEED_API_COMMON_FIELD_LIST_VALIDATOR_H
00011
00012 #include "ActivContentPlatform/ActivFeedApiCommon/External.h"
00013 #include "ActivContentPlatform/ActivFeedApiCommon/FieldStatus.h"
00014 #include "ActivContentPlatform/ActivFeedCommon/FieldIds.h"
00015
00016 #include "boost/dynamic_bitset.hpp"
00017
00018 #include <vector>
00019
00020 namespace Activ
00021 {
00022
00023 namespace ContentPlatform
00024 {
00025
00026 namespace ContentGateway { class FieldListValidator; }
00027 namespace ContentGatewayApi { class FieldListValidator; }
00028 namespace ContentServerApi { class FieldListValidator; }
00029
00030 namespace FeedApi
00031 {
00032
00038 class FieldListValidator
00039 {
00040 public:
00044     class Field
00045     {
00046     public:
00052         ACTIV_FEED_API_COMMON_API Field(const Feed::FieldId fieldId);
00053
00066         template<typename T>
00067         StatusCode GetActivFieldType(const T* &pFieldType) const;
00068
00081         template<typename T>
00082         const T *GetActivFieldType() const;
00083
00084         typedef uint8_t Rules;
00085
00086         static const Rules RULE_NONE = 0x00;
00087         static const Rules RULE_DOES_NOT_UPDATE_LAST_VALUE = 0x01;
00088
00089         const Feed::FieldId     m_fieldId;
00090         FeedApi::FieldStatus    m_fieldStatus;
00091         Rules                   m_rules;
00092         IFieldType *            m_pIFieldType;
00093     };
00094
00098     class ConstIterator
00099     {
00100     public:
00104         ConstIterator();
00105
00111         ConstIterator &operator++();
00112
00118         const ConstIterator operator++(int);
00119
00127         bool operator==(const ConstIterator &rhs) const;
00128
00136         bool operator!=(const ConstIterator &rhs) const;
00137
00143         Feed::FieldId GetFieldId() const;
00144
00150         const Field &GetField() const;
00151
00152     private:
00159         ConstIterator(const FieldListValidator *pFieldListValidator, const Feed::FieldIdList::const_iterator &iterator);
00160
00161         const FieldListValidator *          m_pFieldListValidator;
00162         Feed::FieldIdList::const_iterator   m_iterator;
00163
00164         friend class FieldListValidator;
00165     };
00166
00170     ACTIV_FEED_API_COMMON_API FieldListValidator();
00171
00177     ACTIV_FEED_API_COMMON_API FieldListValidator(const FieldListValidator &rhs);
00178
00182     ACTIV_FEED_API_COMMON_API ~FieldListValidator();
00183
00197     ACTIV_FEED_API_COMMON_API StatusCode ApplyUpdate(const FieldListValidator &fieldListValidator);
00198
00212     ACTIV_FEED_API_COMMON_API StatusCode ApplyUpdateToExistingFieldsOnly(const FieldListValidator &fieldListValidator);
00213
00219     ACTIV_FEED_API_COMMON_API void Reset();
00220
00226     ACTIV_FEED_API_COMMON_API void Clear();
00227
00233     size_t GetNumberOfFields() const;
00234
00245     StatusCode GetField(const Feed::FieldId fieldId, const Field* &pField) const;
00246
00261     template<typename T>
00262     StatusCode GetActivFieldType(const Feed::FieldId fieldId, const T* &pFieldType) const;
00263
00279     template<typename T>
00280     const T *GetActivFieldType(const Feed::FieldId fieldId) const;
00281
00287     bool IsInitialized() const;
00288
00294     bool IsFieldPresent(const Feed::FieldId fieldId) const;
00295
00301     bool IsSubset(const FieldListValidator &rhs) const;
00302
00308     bool IsPartialSubset(const FieldListValidator &rhs) const;
00309
00317     ACTIV_FEED_API_COMMON_API ConstIterator Begin() const;
00318
00326     ACTIV_FEED_API_COMMON_API ConstIterator End() const;
00327
00335     ACTIV_FEED_API_COMMON_API FieldListValidator &operator=(const FieldListValidator &rhs);
00336
00337 private:
00338     class CachedField
00339     {
00340     public:
00346         CachedField(const Feed::FieldId fieldId);
00347
00351         ~CachedField();
00352
00360         bool IsValid(const FieldType fieldType) const;
00361
00369         ACTIV_FEED_API_COMMON_API StatusCode Create(const FieldType fieldType);
00370
00371         Field       m_field;
00372         IFieldType *m_pIFieldType;
00373     };
00374
00375     typedef boost::dynamic_bitset<> FieldIdPresentBitmap;
00376     typedef std::vector<CachedField *> CachedFieldList;
00377
00388     StatusCode GetField(const Feed::FieldId fieldId, Field* &pField) const;
00389
00399     CachedField &GetCachedField(const Feed::FieldId fieldId);
00400
00410     ACTIV_FEED_API_COMMON_API CachedField &InternalGetCachedField(const Feed::FieldId fieldId);
00411
00425     ACTIV_FEED_API_COMMON_API static StatusCode UpdateField(MessageValidator &messageValidator, const bool isFieldRulesPresent,
00426         const bool isFieldDefined, const bool shouldSkipFields, CachedField &cachedField);
00427
00438     StatusCode UpdateField(const CachedField &sourceCachedField, CachedField &targetCachedField);
00439
00450     ACTIV_FEED_API_COMMON_API static StatusCode ValidateField(MessageValidator &messageValidator, const bool isFieldRulesPresent,
00451         const bool isFieldDefined);
00452
00458     void SetFieldIdPresent(const Feed::FieldId fieldId);
00459
00465     void MakeBitmapsSameSize(const FieldListValidator &rhs) const;
00466
00467     bool                            m_isInitialized;
00468     Feed::FieldIdList               m_fieldIdList;
00469     mutable FieldIdPresentBitmap    m_fieldIdPresentBitmap;
00470     CachedFieldList                 m_cachedFieldList;
00471
00472     friend class ContentGateway::FieldListValidator;
00473     friend class ContentGatewayApi::FieldListValidator;
00474     friend class ContentServerApi::FieldListValidator;
00475 };
00476
00477 // ---------------------------------------------------------------------------------------------------------------------------------
00478
00486 ACTIV_FEED_API_COMMON_API std::string FieldListValidatorToString(const FieldListValidator &fieldListValidator);
00487
00488 // ---------------------------------------------------------------------------------------------------------------------------------
00489
00490 inline size_t FieldListValidator::GetNumberOfFields() const
00491 {
00492     return m_fieldIdList.size();
00493 }
00494
00495 // ---------------------------------------------------------------------------------------------------------------------------------
00496
00497 inline StatusCode FieldListValidator::GetField(const Feed::FieldId fieldId, const Field* &pField) const
00498 {
00499     if (!IsInitialized())
00500         return STATUS_CODE_NOT_INITIALIZED;
00501
00502     if (!IsFieldPresent(fieldId))
00503         return STATUS_CODE_NOT_FOUND;
00504
00505     pField = &m_cachedFieldList[fieldId]->m_field;
00506
00507     return STATUS_CODE_SUCCESS;
00508 }
00509
00510 // ---------------------------------------------------------------------------------------------------------------------------------
00511
00512 template<typename T>
00513 inline StatusCode FieldListValidator::GetActivFieldType(const Feed::FieldId fieldId, const T* &pFieldType) const
00514 {
00515     if (!IsInitialized())
00516         return STATUS_CODE_NOT_INITIALIZED;
00517
00518     if (!IsFieldPresent(fieldId))
00519         return STATUS_CODE_NOT_FOUND;
00520
00521     return m_cachedFieldList[fieldId]->m_field.GetActivFieldType(pFieldType);
00522 }
00523
00524 // ---------------------------------------------------------------------------------------------------------------------------------
00525
00526 template<typename T>
00527 const T *FieldListValidator::GetActivFieldType(const Feed::FieldId fieldId) const
00528 {
00529     const T *pFieldType;
00530
00531     ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, GetActivFieldType(fieldId, pFieldType));
00532
00533     return pFieldType;
00534 }
00535
00536 // ---------------------------------------------------------------------------------------------------------------------------------
00537
00538 inline bool FieldListValidator::IsInitialized() const
00539 {
00540     return m_isInitialized;
00541 }
00542
00543 // ---------------------------------------------------------------------------------------------------------------------------------
00544
00545 inline bool FieldListValidator::IsFieldPresent(const Feed::FieldId fieldId) const
00546 {
00547     return ((m_fieldIdPresentBitmap.size() > fieldId) && m_fieldIdPresentBitmap.test(fieldId));
00548 }
00549
00550 // ---------------------------------------------------------------------------------------------------------------------------------
00551
00552 inline bool FieldListValidator::IsSubset(const FieldListValidator &rhs) const
00553 {
00554     // need to make bitsets same size before we can call is_subset_of()
00555     MakeBitmapsSameSize(rhs);
00556
00557     return m_fieldIdPresentBitmap.is_subset_of(rhs.m_fieldIdPresentBitmap);
00558 }
00559
00560 // ---------------------------------------------------------------------------------------------------------------------------------
00561
00562 inline bool FieldListValidator::IsPartialSubset(const FieldListValidator &rhs) const
00563 {
00564     // need to make bitsets same size before we can do bitwise AND
00565     MakeBitmapsSameSize(rhs);
00566
00567     return (m_fieldIdPresentBitmap & rhs.m_fieldIdPresentBitmap).any();
00568 }
00569
00570 // ---------------------------------------------------------------------------------------------------------------------------------
00571
00572 inline FieldListValidator::CachedField &FieldListValidator::GetCachedField(const Feed::FieldId fieldId)
00573 {
00574     if (ACTIV_LIKELY(fieldId < m_cachedFieldList.size()))
00575     {
00576         CachedField * const pCachedField = m_cachedFieldList[fieldId];
00577
00578         if (ACTIV_LIKELY(0 != pCachedField))
00579             return *pCachedField;
00580     }
00581
00582     return InternalGetCachedField(fieldId);
00583 }
00584
00585 // ---------------------------------------------------------------------------------------------------------------------------------
00586
00587 inline void FieldListValidator::SetFieldIdPresent(const Feed::FieldId fieldId)
00588 {
00589     if (fieldId >= m_fieldIdPresentBitmap.size())
00590         m_fieldIdPresentBitmap.resize(fieldId + 1, false);
00591
00592     // NB we allow duplicate fields in an update and use the 'last'. DCS can send same field multiple times for
00593     // certain event types. This function is called by the ApplyUpdate() functions, too, so
00594     // if we ever put back the strict one-instance-of-fid-per-update, we'll need a separate SetFieldIdPresent() function.
00595
00596     // only append field if not already present
00597     if (!m_fieldIdPresentBitmap.test(fieldId))
00598     {
00599         m_fieldIdPresentBitmap.set(fieldId, true);
00600         m_fieldIdList.push_back(fieldId);
00601     }
00602 }
00603
00604 // ---------------------------------------------------------------------------------------------------------------------------------
00605
00606 inline void FieldListValidator::MakeBitmapsSameSize(const FieldListValidator &rhs) const
00607 {
00608     FieldIdPresentBitmap::size_type thisSize = m_fieldIdPresentBitmap.size();
00609     FieldIdPresentBitmap::size_type rhsSize = rhs.m_fieldIdPresentBitmap.size();
00610
00611     if (thisSize < rhsSize)
00612         m_fieldIdPresentBitmap.resize(rhsSize, false);
00613     else if (rhsSize < thisSize)
00614         rhs.m_fieldIdPresentBitmap.resize(thisSize, false);
00615 }
00616
00617 // ---------------------------------------------------------------------------------------------------------------------------------
00618 // ---------------------------------------------------------------------------------------------------------------------------------
00619
00620 template<typename T>
00621 StatusCode FieldListValidator::Field::GetActivFieldType(const T* &pFieldType) const
00622 {
00623     switch (m_fieldStatus)
00624     {
00625         case FeedApi::FIELD_STATUS_DEFINED:
00626             if (T::FIELD_TYPE != m_pIFieldType->GetType())
00627                 return STATUS_CODE_INVALID_FIELD_TYPE;
00628
00629             pFieldType = static_cast<T *>(m_pIFieldType);
00630             return STATUS_CODE_SUCCESS;
00631
00632         case FeedApi::FIELD_STATUS_UNDEFINED:
00633             return STATUS_CODE_UNDEFINED_FIELD;
00634
00635         case FeedApi::FIELD_STATUS_NOT_FOUND:
00636             return STATUS_CODE_NOT_FOUND;
00637
00638         case FeedApi::FIELD_STATUS_NOT_PERMISSIONED:
00639             return STATUS_CODE_ACCESS_DENIED;
00640
00641         default:
00642             return STATUS_CODE_FAILURE;
00643     }
00644 }
00645
00646 // ---------------------------------------------------------------------------------------------------------------------------------
00647
00648 template<typename T>
00649 const T *FieldListValidator::Field::GetActivFieldType() const
00650 {
00651     const T *pFieldType;
00652
00653     ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, GetActivFieldType(pFieldType));
00654
00655     return pFieldType;
00656 }
00657
00658 // ---------------------------------------------------------------------------------------------------------------------------------
00659 // ---------------------------------------------------------------------------------------------------------------------------------
00660
00661 inline FieldListValidator::ConstIterator::ConstIterator() :
00662     m_pFieldListValidator(0)
00663 {
00664 }
00665
00666 // ---------------------------------------------------------------------------------------------------------------------------------
00667
00668 inline FieldListValidator::ConstIterator &FieldListValidator::ConstIterator::operator++()
00669 {
00670     ++m_iterator;
00671
00672     return *this;
00673 }
00674
00675 // ---------------------------------------------------------------------------------------------------------------------------------
00676
00677 inline const FieldListValidator::ConstIterator FieldListValidator::ConstIterator::operator++(int)
00678 {
00679     ConstIterator oldValue = *this;
00680
00681     ++(*this);
00682
00683     return oldValue;
00684 }
00685
00686 // ---------------------------------------------------------------------------------------------------------------------------------
00687
00688 inline bool FieldListValidator::ConstIterator::operator==(const FieldListValidator::ConstIterator &rhs) const
00689 {
00690     return ((m_pFieldListValidator == rhs.m_pFieldListValidator) && (m_iterator == rhs.m_iterator));
00691 }
00692
00693 // ---------------------------------------------------------------------------------------------------------------------------------
00694
00695 inline bool FieldListValidator::ConstIterator::operator!=(const FieldListValidator::ConstIterator &rhs) const
00696 {
00697     return !(*this == rhs);
00698 }
00699
00700 // ---------------------------------------------------------------------------------------------------------------------------------
00701
00702 inline Feed::FieldId FieldListValidator::ConstIterator::GetFieldId() const
00703 {
00704     return *m_iterator;
00705 }
00706
00707 // ---------------------------------------------------------------------------------------------------------------------------------
00708
00709 inline const FieldListValidator::Field &FieldListValidator::ConstIterator::GetField() const
00710 {
00711     return m_pFieldListValidator->m_cachedFieldList[*m_iterator]->m_field;
00712 }
00713
00714 // ---------------------------------------------------------------------------------------------------------------------------------
00715
00716 inline FieldListValidator::ConstIterator::ConstIterator(const FieldListValidator *pFieldListValidator,
00717         const Feed::FieldIdList::const_iterator &iterator) :
00718     m_pFieldListValidator(pFieldListValidator),
00719     m_iterator(iterator)
00720 {
00721 }
00722
00723 // ---------------------------------------------------------------------------------------------------------------------------------
00724 // ---------------------------------------------------------------------------------------------------------------------------------
00725
00726 inline bool FieldListValidator::CachedField::IsValid(const FieldType fieldType) const
00727 {
00728     return (0 != m_pIFieldType) && (fieldType == m_pIFieldType->GetType());
00729 }
00730
00731 } // namespace FeedApi
00732
00733 } // namespace ContentPlatform
00734
00735 } // namespace Activ
00736
00737 #endif // (!defined ACTIV_FEED_API_COMMON_FIELD_LIST_VALIDATOR_H)
Generated on Wed Oct 8 14:01:44 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon

ActivFeedDefinitions.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FEED_DEFINITIONS_H)
00010 #define ACTIV_FEED_DEFINITIONS_H
00011
00012 #include "ActivMiddleware/Activ.h"
00013
00014 #include <vector>
00015
00016 namespace Activ
00017 {
00018
00019 namespace ContentPlatform
00020 {
00021
00022 namespace Feed
00023 {
00024
00025 typedef uint8_t EventType;
00026
00027 typedef uint16_t FieldId;
00028 typedef std::vector<FieldId> FieldIdList;
00029
00030 typedef uint8_t IndexNumber;
00031 typedef uint8_t IndexType;
00032 typedef uint8_t IndexProperties;
00033
00034 typedef uint16_t PermissionId;
00035 typedef std::vector<PermissionId> PermissionIdList;
00036 typedef uint8_t PermissionLevel;
00037 typedef std::vector<PermissionLevel> PermissionLevelList;
00038
00039 typedef uint8_t RelationshipType;
00040 typedef uint16_t RelationshipId;
00041
00042 typedef uint16_t TableId;
00043 typedef uint8_t TableVersion;
00044 typedef uint16_t TableNo;
00045 typedef std::vector<TableNo> TableNoList;
00046
00047 typedef uint16_t UpdateId;
00048
00049 typedef uint32_t Context;
00050
00051 typedef uint16_t CugId;
00052 typedef std::vector<CugId> CugIdList;
00053
00054 const EventType EVENT_TYPE_CONTRIBUTION_BASE = 232;
00055
00056 const TableNo TABLE_NO_UNDEFINED = ~0;
00057 const TableNo TABLE_NO_CONTRIBUTION_BASE = 5000;
00058 const TableNo TABLE_NO_MAX = 8191;
00059
00060 const Context CONTEXT_UNDEFINED = ~0;
00061
00062 } // namespace Feed
00063
00064 } // namespace ContentPlatform
00065
00066 } // namespace Activ
00067
00068 #endif // (!defined ACTIV_FEED_DEFINITIONS_H)
Generated on Wed Oct 8 14:01:45 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedMessageHandler

ActivFeedMessageHandler.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FEED_MESSAGE_HANDLER_H)
00010 #define ACTIV_FEED_MESSAGE_HANDLER_H
00011
00012 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/External.h"
00013
00014 #include <string>
00015
00019 #define ACTIV_FEED_MESSAGE_TYPE_LIST(d)                                                                 \
00020     d(MESSAGE_TYPE_TABLE_TEMPLATE,                          "TableTemplate"                         )   \
00021     d(MESSAGE_TYPE_SYMBOL_RECORD,                           "SymbolRecord"                          )   \
00022     d(MESSAGE_TYPE_COMPRESSED_QUOTE,                        "CompressedQuote"                       )   \
00023     d(MESSAGE_TYPE_RECORD,                                  "Record"                                )   \
00024     d(MESSAGE_TYPE_COMPRESSED_BBO_QUOTE,                    "CompressedBboQuote"                    )   \
00025     d(MESSAGE_TYPE_UNIVERSAL_FIELD_LIST,                    "UniversalFieldList"                    )   \
00026     d(MESSAGE_TYPE_TIMESTAMP,                               "Timestamp"                             )   \
00027     d(MESSAGE_TYPE_FILE,                                    "File"                                  )   \
00028     d(MESSAGE_TYPE_FILE_EXECUTE,                            "FileExecute"                           )   \
00029     d(MESSAGE_TYPE_SYMBOL_UPDATE,                           "SymbolUpdate"                          )   \
00030     d(MESSAGE_TYPE_UPDATE,                                  "Update"                                )   \
00031     d(MESSAGE_TYPE_COMPRESSED_CLOSE,                        "Compressed Close"                      )   \
00032     d(MESSAGE_TYPE_COMPRESSED_CLOSING_QUOTE,                "CompressedClosingQuote"                )   \
00033     d(MESSAGE_TYPE_COMPRESSED_CLOSING_BBO_QUOTE,            "CompressedClosingBboQuote"             )   \
00034     d(MESSAGE_TYPE_COMPRESSED_COMPOSITE_BBO_QUOTE,          "CompressedCompositeBboQuote"           )   \
00035     d(MESSAGE_TYPE_COMBINED_QUOTE,                          "CombinedQuote"                         )   \
00036     d(MESSAGE_TYPE_COMPRESSED_COMBINED_QUOTE,               "CompressedCombinedQuote"               )   \
00037     d(MESSAGE_TYPE_COMPRESSED_COMPOSITE_CLOSING_BBO_QUOTE,  "CompressedCompositeClosingBboQuote"    )
00038
00039 namespace Activ
00040 {
00041
00042 namespace ContentPlatform
00043 {
00044
00045 namespace Feed
00046 {
00047
00051 enum MessageType
00052 {
00053     ACTIV_FEED_MESSAGE_TYPE_LIST(ACTIV_DECLARE_ELEMENT_1_WITH_COMMA)
00054     NUMBER_OF_MESSAGE_TYPES
00055 };
00056
00064 ACTIV_FEED_MESSAGE_HANDLER_API std::string MessageTypeToString(const MessageType messageType);
00065
00066 } // namespace Feed
00067
00068 } // namespace ContentPlatform
00069
00070 } // namespace Activ
00071
00072 #endif // (!defined ACTIV_FEED_MESSAGE_HANDLER_H)
Generated on Wed Oct 8 14:01:45 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedTableTemplateHandler

ActivFeedTableTemplateHandler.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FEED_TABLE_TEMPLATE_HANDLER_H)
00010 #define ACTIV_FEED_TABLE_TEMPLATE_HANDLER_H
00011
00012 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/External.h"
00013
00014 namespace Activ
00015 {
00016
00017 namespace ContentPlatform
00018 {
00019
00020 namespace Feed
00021 {
00022
00023 } // namespace Feed
00024
00025 } // namespace ContentPlatform
00026
00027 } // namespace Activ
00028
00029 #endif // (!defined ACTIV_FEED_TABLE_TEMPLATE_HANDLER_H)
Generated on Wed Oct 8 14:01:46 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivFieldTypes

ActivFieldTypes.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FIELD_TYPES_H)
00010 #define ACTIV_FIELD_TYPES_H
00011
00012 #include "ActivMiddleware/ActivFieldTypes/External.h"
00013
00014 #include <string>
00015
00024 #define ACTIV_FIELD_TYPE_LIST(d)                                    \
00025     d(FIELD_TYPE_DATE,          Date,               0,      0)      \
00026     d(FIELD_TYPE_TIME,          Time,               0,      0)      \
00027     d(FIELD_TYPE_DATE_TIME,     DateTime,           0,      0)      \
00028     d(FIELD_TYPE_SINT,          SInt,               0,      1)      \
00029     d(FIELD_TYPE_UINT,          UInt,               0,      1)      \
00030     d(FIELD_TYPE_RATIONAL,      Rational,           0,      0)      \
00031     d(FIELD_TYPE_TRATIONAL,     TRational,          0,      0)      \
00032     d(FIELD_TYPE_TEXT_STRING,   TextString,         1,      1)      \
00033     d(FIELD_TYPE_TEXT_ARRAY,    TextArray,          0,      1)      \
00034     d(FIELD_TYPE_BINARY_STRING, BinaryString,       1,      1)      \
00035     d(FIELD_TYPE_BINARY_ARRAY,  BinaryArray,        0,      1)      \
00036     d(FIELD_TYPE_BLOB,          Blob,               4,      4)      \
00037     d(FIELD_TYPE_CRC_BLOB,      CrcBlob,            4,      4)
00038
00042 #define ACTIV_DECLARE_FIELD_TYPE_ENUMERATIONS(id, name, size1, size2)   id,
00043
00044 namespace Activ
00045 {
00046
00047 typedef uint8_t FieldType;
00048
00049 const FieldType FIELD_TYPE_UNKNOWN = ~0;
00050
00051 // ---------------------------------------------------------------------------------------------------------------------------------
00052
00056 enum
00057 {
00058     ACTIV_FIELD_TYPE_LIST(ACTIV_DECLARE_FIELD_TYPE_ENUMERATIONS)
00059     NUMBER_OF_FIELD_TYPES
00060 };
00061
00062 #undef ACTIV_DECLARE_FIELD_TYPE_ENUMERATIONS
00063
00064 // ---------------------------------------------------------------------------------------------------------------------------------
00065
00069 template<FieldType>
00070 class FieldTypeToClass
00071 {
00072     // Nothing defined for unknown field type. Specializations are provided for each concrete IFieldType class.
00073 };
00074
00075 // ---------------------------------------------------------------------------------------------------------------------------------
00076
00084 ACTIV_FIELD_TYPES_API std::string FieldTypeToString(const FieldType fieldType);
00085
00093 ACTIV_FIELD_TYPES_API FieldType StringToFieldType(const std::string &name);
00094
00102 ACTIV_FIELD_TYPES_API size_t FieldTypeToRecordLengthSize(const FieldType fieldType);
00103
00111 ACTIV_FIELD_TYPES_API size_t FieldTypeToUpdateLengthSize(const FieldType fieldType);
00112
00113 } // namespace Activ
00114
00115 #endif // (!defined ACTIV_FIELD_TYPES_H)
Generated on Wed Oct 8 14:01:47 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivFramework

ActivFramework.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FRAMEWORK_H)
00010 #define ACTIV_FRAMEWORK_H
00011
00012 #include "ActivMiddleware/ActivSystem/ActivSystem.h"
00013 #include "ActivMiddleware/ActivFramework/Application.h"
00014 #include "ActivMiddleware/ActivFramework/ThinApplication.h"
00015 #include "ActivMiddleware/ActivFramework/Component.h"
00016 #include "ActivMiddleware/ActivFramework/Service.h"
00017 #include "ActivMiddleware/ActivFramework/ChildService.h"
00018 #include "ActivMiddleware/ActivFramework/UiComponent.h"
00019 #include "ActivMiddleware/ActivFramework/UiMenu.h"
00020 #include "ActivMiddleware/ActivFramework/UiIo.h"
00021
00022 #endif // (!defined ACTIV_FRAMEWORK_H)
Generated on Wed Oct 8 14:01:48 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivAgentApplication

External.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_AGENT_APPLICATION_EXTERNAL_H)
00010 #define ACTIV_AGENT_APPLICATION_EXTERNAL_H
00011
00012 #if (!defined ACTIV_AGENT_APPLICATION_API)
00013 #   if (!defined ACTIV_STATIC)
00014 #       define ACTIV_AGENT_APPLICATION_API ACTIV_IMPORT_DLL
00015 #   else
00016 #       define ACTIV_AGENT_APPLICATION_API ACTIV_IMPORT_LIB
00017 #   endif // (!defined ACTIV_STATIC)
00018 #endif // (!defined ACTIV_AGENT_APPLICATION_API)
00019
00020 #include "ActivMiddleware/ActivFramework/ActivFramework.h"
00021
00022 #endif // (!defined ACTIV_AGENT_APPLICATION_EXTERNAL_H)
Generated on Wed Oct 8 14:01:44 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

External.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_BASE_EXTERNAL_H)
00010 #define ACTIV_BASE_EXTERNAL_H
00011
00012 #if (!defined ACTIV_BASE_EXPORTED_API)
00013 #   if (!defined ACTIV_STATIC)
00014 #       define ACTIV_BASE_EXPORTED_API  ACTIV_USING_DLL_EXPORTED_API
00015 #       define ACTIV_BASE_INLINE_API    ACTIV_USING_DLL_INLINE_API
00016 #       define ACTIV_BASE_LOCAL_API     ACTIV_USING_DLL_LOCAL_API
00017 #   else
00018 #       define ACTIV_BASE_EXPORTED_API  ACTIV_USING_LIB_EXPORTED_API
00019 #       define ACTIV_BASE_INLINE_API    ACTIV_USING_LIB_INLINE_API
00020 #       define ACTIV_BASE_LOCAL_API     ACTIV_USING_LIB_LOCAL_API
00021 #   endif // (!defined ACTIV_STATIC)
00022 #endif // (!defined ACTIV_BASE_EXPORTED_API)
00023
00024 #include "ActivMiddleware/Activ.h"
00025
00026 #endif // (!defined ACTIV_BASE_EXTERNAL_H)
Generated on Wed Oct 8 14:01:44 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivDatabase

External.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_DATABASE_API)
00010 #   if (!defined ACTIV_STATIC)
00011 #       define ACTIV_DATABASE_API ACTIV_IMPORT_DLL
00012 #   else
00013 #       define ACTIV_DATABASE_API ACTIV_IMPORT_LIB
00014 #   endif // (!defined ACTIV_STATIC)
00015 #endif // (!defined ACTIV_DATABASE_API)
00016
00017 #include "ActivMiddleware/Activ.h"
Generated on Wed Oct 8 14:01:44 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivDatabase

IndexSpecification.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_DATABASE_INDEX_SPECIFICATION_H)
00010 #define ACTIV_DATABASE_INDEX_SPECIFICATION_H
00011
00012 #include "ActivMiddleware/ActivDatabase/External.h"
00013
00014 #include "ActivMiddleware/ActivDatabase/FieldSpecification.h"
00015
00016 #include <string>
00017 #include <vector>
00018 #include <iostream>
00019
00020 namespace Activ
00021 {
00022
00023 class MessageBuilder;
00024 class MessageValidator;
00025
00026 namespace Database
00027 {
00028
00032 #define ACTIV_DATABASE_INDEX_FIELD(id, properties)                                                              Activ::Database::IndexSpecification::Field(id, Activ::Database::IndexSpecification::Field::properties)
00033 #define ACTIV_DATABASE_INDEX_ENUM(number, name, type, properties, fieldList)                                    number,
00034 #define ACTIV_DATABASE_INDEX_ENUM_WITH_CACHE(number, name, type, properties, fieldList, fieldIdList)            number,
00035 #define ACTIV_DATABASE_INDEX_SPECIFICATION(number, name, type, properties, fieldList)                           Activ::Database::IndexSpecification(name, Activ::Database::IndexSpecification::type, Activ::Database::IndexSpecification::properties, std::vector<Activ::Database::IndexSpecification::Field>(fieldList, fieldList + ACTIV_ARRAY_SIZE(fieldList))),
00036 #define ACTIV_DATABASE_INDEX_SPECIFICATION_WITH_CACHE(number, name, type, properties, fieldList, fieldIdList)   Activ::Database::IndexSpecification(name, Activ::Database::IndexSpecification::type, Activ::Database::IndexSpecification::properties, std::vector<Activ::Database::IndexSpecification::Field>(fieldList, fieldList + ACTIV_ARRAY_SIZE(fieldList)), std::vector<Activ::Database::FieldSpecification::Id>(fieldIdList, fieldIdList + ACTIV_ARRAY_SIZE(fieldIdList))),
00037
00038 // ---------------------------------------------------------------------------------------------------------------------------------
00039
00043 class IndexSpecification
00044 {
00045 public:
00046     typedef uint16_t Number;
00047
00051     enum Type
00052     {
00053         TYPE_NONE,
00054         TYPE_HASH,
00055         TYPE_RED_BLACK_TREE
00056     };
00057
00061     enum
00062     {
00063         PROPERTY_NONE = 0x00000001,
00064         PROPERTY_UNIQUE = 0x00000002,
00065         PROPERTY_DUPLICATE = 0x00000004,
00066         PROPERTY_PRIMARY_UNIQUE = 0x00000008
00067     };
00068     typedef uint32_t Properties;
00069
00073     class ACTIV_DATABASE_API Field
00074     {
00075     public:
00079         enum
00080         {
00081             PROPERTY_NONE = 0x00000000,
00082             PROPERTY_ASCENDING = PROPERTY_NONE,
00083             PROPERTY_DESCENDING = 0x80000000
00084         };
00085         typedef uint32_t Properties;
00086
00090         Field();
00091
00098         explicit Field(const FieldSpecification::Id fieldId, const Properties properties = PROPERTY_NONE);
00099
00107         bool operator==(const Field &rhs) const;
00108
00116         bool operator!=(const Field &rhs) const;
00117
00128         StatusCode Serialize(MessageBuilder &messageBuilder) const;
00129
00140         StatusCode Deserialize(MessageValidator &messageValidator);
00141
00149         static bool IsAscending(const Properties properties);
00150
00158         static bool IsDescending(const Properties properties);
00159
00160         FieldSpecification::Id  m_fieldId;
00161         Properties              m_properties;
00162     };
00163
00167     ACTIV_DATABASE_API IndexSpecification();
00168
00179     ACTIV_DATABASE_API IndexSpecification(const std::string &name, const Type type, const Properties properties, const std::vector<IndexSpecification::Field> &indexFieldSpecificationList);
00180
00192     IndexSpecification(const std::string &name, const Type type, const Properties properties, const std::vector<IndexSpecification::Field> &indexFieldSpecificationList, const std::vector<uint16_t> &cachedFieldIdList);
00193
00201     ACTIV_DATABASE_API bool operator==(const IndexSpecification &rhs) const;
00202
00210     ACTIV_DATABASE_API bool operator!=(const IndexSpecification &rhs) const;
00211
00221     bool operator<(const IndexSpecification &rhs) const;
00222
00228     ACTIV_DATABASE_API void Validate() const;
00229
00240     ACTIV_DATABASE_API StatusCode Serialize(MessageBuilder &messageBuilder) const;
00241
00252     ACTIV_DATABASE_API StatusCode Deserialize(MessageValidator &messageValidator);
00253
00259     ACTIV_DATABASE_API bool IsPrimaryUnique() const;
00260
00266     ACTIV_DATABASE_API bool IsUnique() const;
00267
00273     ACTIV_DATABASE_API bool IsDuplicate() const;
00274
00280     ACTIV_DATABASE_API bool IsHash() const;
00281
00287     ACTIV_DATABASE_API bool IsTree() const;
00288
00296     ACTIV_DATABASE_API bool IsMatch(const IndexSpecification &rhs) const;
00297
00303     ACTIV_DATABASE_API std::string ToString() const;
00304
00305     static const Number     UNDEFINED_INDEX_NUMBER = ~0;
00306
00307     Number                                  m_number;
00308     std::string                             m_name;
00309     Type                                    m_type;
00310     Properties                              m_properties;
00311     std::vector<Field>                      m_indexFieldSpecificationList;
00312     std::vector<FieldSpecification::Id>     m_cachedFieldIdList;
00313
00314 private:
00315     typedef std::vector<Field>  FieldList;
00316
00329     ACTIV_DATABASE_API IndexSpecification(const IndexSpecification::Number number, const std::string &name, const Type type, const Properties properties, const std::vector<IndexSpecification::Field> &indexFieldSpecificationList, const std::vector<FieldSpecification::Id> &cachedFieldIdList);
00330
00331     friend class Index;
00332 };
00333
00334 // ---------------------------------------------------------------------------------------------------------------------------------
00335
00336 }   // namespace Database
00337
00338 }   // namespace Activ
00339
00340 // ---------------------------------------------------------------------------------------------------------------------------------
00341
00350 ACTIV_DATABASE_API std::ostream &operator<<(std::ostream &os, const Activ::Database::IndexSpecification &rhs);
00351
00352 // ---------------------------------------------------------------------------------------------------------------------------------
00353
00354 #endif // (!defined ACTIV_DATABASE_INDEX_SPECIFICATION_H)
Generated on Wed Oct 8 14:01:46 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivDatabase

TableSpecification.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_DATABASE_TABLE_SPECIFICATION_H)
00010 #define ACTIV_DATABASE_TABLE_SPECIFICATION_H
00011
00012 #include "ActivMiddleware/ActivDatabase/External.h"
00013 #include "ActivMiddleware/ActivDatabase/FieldSpecification.h"
00014
00015 #include <string>
00016
00017 namespace Activ
00018 {
00019
00020 class MessageBuilder;
00021 class MessageValidator;
00022
00023 namespace Database
00024 {
00025
00026 class ITable;
00027 typedef std::vector<FieldSpecification> FieldSpecificationList;
00028
00029 // ---------------------------------------------------------------------------------------------------------------------------------
00030
00034 class TableSpecification
00035 {
00036 public:
00037     static const uint8_t VERSION = 1;
00038
00039     static const size_t GROW_RECORDS_DEFAULT = ~0;
00040     static const size_t CACHE_COMPLETE = ~0;
00041
00045     enum
00046     {
00047         PROPERTY_NONE = 0x00000000,
00048         PROPERTY_CREATE_RECORD_FILE = 0x00000001,
00049         PROPERTY_CREATE_MUTEX = 0x00000002,
00050         PROPERTY_CONVERT = 0x00000004
00051     };
00052     typedef uint32_t Properties;
00053
00057     ACTIV_DATABASE_API TableSpecification();
00058
00071     ACTIV_DATABASE_API TableSpecification(const std::string &name, const Properties properties, const FieldSpecificationList &fieldSpecificationList, const size_t initialMaxRecords, const size_t nGrowRecords = GROW_RECORDS_DEFAULT, const size_t cacheSize = CACHE_COMPLETE);
00072
00086     ACTIV_DATABASE_API TableSpecification(const std::string &name, const Properties properties, const FieldSpecificationList &fieldSpecificationList, const size_t initialMaxRecords, const size_t recordLength, const size_t nGrowRecords = GROW_RECORDS_DEFAULT, const size_t cacheSize = CACHE_COMPLETE);
00087
00102     TableSpecification(const std::string &name, const bool isManaged, const Properties properties, const FieldSpecificationList &fieldSpecificationList, const size_t initialMaxRecords, const size_t recordLength, const size_t nGrowRecords, const size_t cacheSize);
00103
00117     ACTIV_DATABASE_API bool operator==(const TableSpecification &rhs) const;
00118
00126     ACTIV_DATABASE_API bool operator!=(const TableSpecification &rhs) const;
00127
00140     ACTIV_DATABASE_API static StatusCode Serialize(MessageBuilder &messageBuilder, ITable *pTable, const uint8_t version = VERSION);
00141
00153     ACTIV_DATABASE_API StatusCode Serialize(MessageBuilder &messageBuilder, const uint8_t version = VERSION) const;
00154
00165     ACTIV_DATABASE_API StatusCode Deserialize(MessageValidator &messageValidator);
00166
00179     ACTIV_DATABASE_API ITable *CreateTable(const std::string &directory = std::string()) const;
00180
00188     ACTIV_DATABASE_API static bool ShouldCreateRecordFile(const Properties properties);
00189
00197     ACTIV_DATABASE_API static bool ShouldCreateMutex(const Properties properties);
00198
00206     ACTIV_DATABASE_API static bool ShouldConvert(const Properties properties);
00207
00213     ACTIV_DATABASE_API std::string ToString() const;
00214
00215     std::string                 m_name;
00216     bool                        m_isManaged;
00217     Properties                  m_properties;
00218     FieldSpecificationList      m_fieldSpecificationList;
00219     size_t                      m_initialMaxRecords;
00220     size_t                      m_recordLength;
00221     size_t                      m_nGrowRecords;
00222     size_t                      m_cacheSize;
00223 };
00224
00225 // ---------------------------------------------------------------------------------------------------------------------------------
00226
00227 }   // namespace Database
00228
00229 }   // namespace Activ
00230
00231 // ---------------------------------------------------------------------------------------------------------------------------------
00232
00241 ACTIV_DATABASE_API std::ostream &operator<<(std::ostream &os, const Activ::Database::TableSpecification &rhs);
00242
00243 // ---------------------------------------------------------------------------------------------------------------------------------
00244
00245 #endif // (!defined ACTIV_DATABASE_TABLE_SPECIFICATION_H)
Generated on Wed Oct 8 14:01:46 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivFieldTypes

External.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FIELD_TYPES_API)
00010 #   if (!defined ACTIV_STATIC)
00011 #       define ACTIV_FIELD_TYPES_API ACTIV_IMPORT_DLL
00012 #   else
00013 #       define ACTIV_FIELD_TYPES_API ACTIV_IMPORT_LIB
00014 #   endif // (!defined ACTIV_STATIC)
00015 #endif // (!defined ACTIV_FIELD_TYPES_API)
00016
00017 #include "ActivMiddleware/Activ.h"
Generated on Wed Oct 8 14:01:44 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivFramework

External.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FRAMEWORK_EXTERNAL_H)
00010 #define ACTIV_FRAMEWORK_EXTERNAL_H
00011
00012 #if (!defined ACTIV_FRAMEWORK_API)
00013 #   if (!defined ACTIV_STATIC)
00014 #       define ACTIV_FRAMEWORK_API ACTIV_IMPORT_DLL
00015 #   else
00016 #       define ACTIV_FRAMEWORK_API ACTIV_IMPORT_LIB
00017 #   endif // (!defined ACTIV_STATIC)
00018 #endif // (!defined ACTIV_FRAMEWORK_API)
00019
00020 #include "ActivMiddleware/Activ.h"
00021 #include "ActivMiddleware/ActivSystem/ActivSystem.h"
00022
00023 namespace Activ
00024 {
00025
00029 #define ACTIV_AGENT_SCOPE_LIST(d)           \
00030     d(AGENT_SCOPE_LOCAL, "Local")           \
00031     d(AGENT_SCOPE_GLOBAL, "Global")         \
00032     d(AGENT_SCOPE_REMOTE, "Remote")
00033
00041 typedef byte_t AgentScope;
00042
00043 // ---------------------------------------------------------------------------------------------------------------------------------
00044
00045 enum
00046 {
00047     ACTIV_AGENT_SCOPE_LIST(ACTIV_DECLARE_HIDDEN_ELEMENT_1)
00048     NUM_AGENT_SCOPES
00049 };
00050
00051 #define ACTIV_DECLARE_AGENT_SCOPE(a, b) ACTIV_DECLARE_CONSTANT_ELEMENT_1(AgentScope, a, b)
00052 ACTIV_AGENT_SCOPE_LIST(ACTIV_DECLARE_AGENT_SCOPE)
00053 #undef ACTIV_DECLARE_AGENT_SCOPE
00054
00058 ACTIV_FRAMEWORK_API std::string AgentScopeToString(const AgentScope agentScope);
00059
00060 } // namespace Activ
00061
00062 #endif // (!defined ACTIV_FRAMEWORK_EXTERNAL_H)
Generated on Wed Oct 8 14:01:44 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivIp

External.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_IP_EXTERNAL_H)
00010 #define ACTIV_IP_EXTERNAL_H
00011
00012 #if (!defined ACTIV_IP_API)
00013 #   if (!defined ACTIV_STATIC)
00014 #       define ACTIV_IP_API ACTIV_IMPORT_DLL
00015 #   else
00016 #       define ACTIV_IP_API ACTIV_IMPORT_LIB
00017 #   endif // (!defined ACTIV_STATIC)
00018 #endif // (!defined ACTIV_IP_API)
00019
00020 #include "ActivMiddleware/Activ.h"
00021
00022 #endif // (!defined ACTIV_IP_EXTERNAL_H)
Generated on Wed Oct 8 14:01:44 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivSystem

External.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_SYSTEM_EXTERNAL_H)
00010 #define ACTIV_SYSTEM_EXTERNAL_H
00011
00012 #if (!defined ACTIV_SYSTEM_EXPORTED_API)
00013 #   if (!defined ACTIV_STATIC)
00014 #       define ACTIV_SYSTEM_EXPORTED_API    ACTIV_USING_DLL_EXPORTED_API
00015 #       define ACTIV_SYSTEM_INLINE_API      ACTIV_USING_DLL_INLINE_API
00016 #       define ACTIV_SYSTEM_LOCAL_API       ACTIV_USING_DLL_LOCAL_API
00017 #   else
00018 #       define ACTIV_SYSTEM_EXPORTED_API    ACTIV_USING_LIB_EXPORTED_API
00019 #       define ACTIV_SYSTEM_INLINE_API      ACTIV_USING_LIB_INLINE_API
00020 #       define ACTIV_SYSTEM_LOCAL_API       ACTIV_USING_LIB_LOCAL_API
00021 #   endif // (!defined ACTIV_STATIC)
00022 #endif // (!defined ACTIV_SYSTEM_EXPORTED_API)
00023
00024 #include "ActivMiddleware/Activ.h"
00025 #include "ActivMiddleware/ActivSystem/BasicTypes.h"
00026
00027 #endif // (!defined ACTIV_SYSTEM_EXTERNAL_H)
Generated on Wed Oct 8 14:01:44 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivSystem

BasicTypes.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_SYSTEM_BASIC_TYPES_H)
00010 #define ACTIV_SYSTEM_BASIC_TYPES_H
00011
00012 #include "ActivMiddleware/Activ.h"
00013
00014 #include <set>
00015
00016 namespace Activ
00017 {
00018
00019 typedef uint16_t MessageType;
00020 typedef uintptr_t MessageId;
00021 typedef byte_t BucketId;
00022 typedef uint16_t HeapId;
00023 typedef uint16_t PortId;
00024 typedef uint16_t EndPointId;
00025 typedef uint16_t ProcessId;
00026 typedef std::set<EndPointId> EndPointIdSet;
00027
00028 const MessageType INVALID_MESSAGE_TYPE = ~0;
00029 const MessageId INVALID_MESSAGE_ID = ~0;
00030 const BucketId INVALID_BUCKET_ID = ~0;
00031 const HeapId INVALID_HEAP_ID = ~0;
00032 const PortId INVALID_PORT_ID = ~0;
00033 const EndPointId INVALID_ENDPOINT_ID = ~0;
00034 const ProcessId INVALID_PROCESS_ID = ~0;
00035
00036 } // namespace Activ
00037
00038 #endif // (!defined ACTIV_SYSTEM_BASIC_TYPES_H)
Generated on Wed Oct 8 14:01:48 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivSystem

ActivSystem.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_SYSTEM_H)
00010 #define ACTIV_SYSTEM_H
00011
00012 #include "ActivMiddleware/ActivSystem/External.h"
00013
00014 #include "ActivMiddleware/ActivSystem/Address.h"
00015 #include "ActivMiddleware/ActivSystem/HeapMessage.h"
00016 #include "ActivMiddleware/ActivSystem/HeapMessageDeserializer.h"
00017 #include "ActivMiddleware/ActivSystem/IEndPoint.h"
00018 #include "ActivMiddleware/ActivSystem/IHeap.h"
00019 #include "ActivMiddleware/ActivSystem/IProcess.h"
00020 #include "ActivMiddleware/ActivSystem/ISystem.h"
00021 #include "ActivMiddleware/ActivSystem/ManagedEndPoint.h"
00022 #include "ActivMiddleware/ActivSystem/MessageTypes.h"
00023 #include "ActivMiddleware/ActivSystem/Port.h"
00024 #include "ActivMiddleware/ActivSystem/PostMessageHelper.h"
00025 #include "ActivMiddleware/ActivSystem/RequestId.h"
00026 #include "ActivMiddleware/ActivSystem/ScopedAddress.h"
00027 #include "ActivMiddleware/ActivSystem/Subject.h"
00028 #include "ActivMiddleware/ActivSystem/SyncRequestId.h"
00029 #include "ActivMiddleware/ActivSystem/SystemException.h"
00030 #include "ActivMiddleware/ActivSystem/SystemFactory.h"
00031
00032 #endif // (!defined ACTIV_SYSTEM_H)
Generated on Wed Oct 8 14:01:48 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivSystem

Address.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_SYSTEM_ADDRESS_H)
00010 #define ACTIV_SYSTEM_ADDRESS_H
00011
00012 #include "ActivMiddleware/ActivSystem/External.h"
00013 #include "ActivMiddleware/ActivBase/MessageBuilder.h"
00014 #include "ActivMiddleware/ActivBase/MessageValidator.h"
00015 #include "ActivMiddleware/ActivBase/ActivBase.h"
00016
00017 namespace Activ
00018 {
00019
00020 class Port;
00021
00022 // ---------------------------------------------------------------------------------------------------------------------------------
00023
00027 class Address
00028 {
00029 public:
00045     class Proxy
00046     {
00047     public:
00053         ACTIV_SYSTEM_INLINE_API
00054         Proxy(Address &address);
00055
00061         ACTIV_SYSTEM_INLINE_API
00062         operator Address &();
00063
00064     private:
00065         Address &m_address;
00066     };
00067
00073     ACTIV_SYSTEM_INLINE_API
00074     Address();
00075
00082     ACTIV_SYSTEM_INLINE_API
00083     Address(const EndPointId endPointId, const PortId portId);
00084
00092     ACTIV_SYSTEM_INLINE_API
00093     StatusCode Serialize(MessageBuilder &messageBuilder) const;
00094
00102     ACTIV_SYSTEM_INLINE_API
00103     StatusCode Deserialize(MessageValidator &messageValidator);
00104
00110     ACTIV_SYSTEM_INLINE_API
00111     static size_t GetSerializedLength();
00112
00118     ACTIV_SYSTEM_INLINE_API
00119     void Clear();
00120
00126     ACTIV_SYSTEM_INLINE_API
00127     std::string ToString() const;
00128
00136     ACTIV_SYSTEM_INLINE_API
00137     bool IsValid() const;
00138
00144     ACTIV_SYSTEM_INLINE_API
00145     EndPointId GetEndPointId() const;
00146
00152     ACTIV_SYSTEM_INLINE_API
00153     void SetEndPointId(const EndPointId endPointId);
00154
00160     ACTIV_SYSTEM_INLINE_API
00161     PortId GetPortId() const;
00162
00168     ACTIV_SYSTEM_INLINE_API
00169     void SetPortId(const PortId portId);
00170
00177     ACTIV_SYSTEM_INLINE_API
00178     void Set(const EndPointId endPointId, const PortId portId);
00179
00187     ACTIV_SYSTEM_INLINE_API
00188     bool operator==(const Address &rhs) const;
00189
00197     ACTIV_SYSTEM_INLINE_API
00198     bool operator!=(const Address &rhs) const;
00199
00207     ACTIV_SYSTEM_INLINE_API
00208     bool operator<(const Address &rhs) const;
00209
00210 private:
00211     EndPointId  m_endPointId;
00212     PortId      m_portId;
00213 };
00214
00215 // ---------------------------------------------------------------------------------------------------------------------------------
00216
00217 inline Address::Address()
00218 {
00219     Clear();
00220 }
00221
00222 // ---------------------------------------------------------------------------------------------------------------------------------
00223
00224 inline Address::Address(const EndPointId endPointId, const PortId portId)
00225 {
00226     SetEndPointId(endPointId);
00227     SetPortId(portId);
00228 }
00229
00230 // ---------------------------------------------------------------------------------------------------------------------------------
00231
00232 inline StatusCode Address::Serialize(MessageBuilder &messageBuilder) const
00233 {
00234     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, messageBuilder.Append(m_endPointId, MessageBuilder::ENDIAN_LITTLE));
00235     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, messageBuilder.Append(m_portId, MessageBuilder::ENDIAN_LITTLE));
00236
00237     return STATUS_CODE_SUCCESS;
00238 }
00239
00240 // ---------------------------------------------------------------------------------------------------------------------------------
00241
00242 inline StatusCode Address::Deserialize(MessageValidator &messageValidator)
00243 {
00244     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, (messageValidator.ValidateBinaryIntegral<sizeof(m_endPointId),
00245         MessageValidator::ENDIAN_LITTLE>(m_endPointId)));
00246     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, (messageValidator.ValidateBinaryIntegral<sizeof(m_portId),
00247         MessageValidator::ENDIAN_LITTLE>(m_portId)));
00248
00249     return STATUS_CODE_SUCCESS;
00250 }
00251
00252 // ---------------------------------------------------------------------------------------------------------------------------------
00253
00254 inline size_t Address::GetSerializedLength()
00255 {
00256     return ACTIV_FIELD_SIZE(Address, m_endPointId) + ACTIV_FIELD_SIZE(Address, m_portId);
00257 }
00258
00259 // ---------------------------------------------------------------------------------------------------------------------------------
00260
00261 inline void Address::Clear()
00262 {
00263     SetPortId(INVALID_PORT_ID);
00264     SetEndPointId(INVALID_ENDPOINT_ID);
00265 }
00266
00267 // ---------------------------------------------------------------------------------------------------------------------------------
00268
00269 inline EndPointId Address::GetEndPointId() const
00270 {
00271     return m_endPointId;
00272 }
00273
00274 // ---------------------------------------------------------------------------------------------------------------------------------
00275
00276 inline void Address::SetEndPointId(EndPointId endPointId)
00277 {
00278     m_endPointId = endPointId;
00279 }
00280
00281 // ---------------------------------------------------------------------------------------------------------------------------------
00282
00283 inline PortId Address::GetPortId() const
00284 {
00285     return m_portId;
00286 }
00287
00288 // ---------------------------------------------------------------------------------------------------------------------------------
00289
00290 inline void Address::SetPortId(PortId portId)
00291 {
00292     m_portId = portId;
00293 }
00294
00295 // ---------------------------------------------------------------------------------------------------------------------------------
00296
00297 inline void Address::Set(const EndPointId endPointId, const PortId portId)
00298 {
00299     m_endPointId = endPointId;
00300     m_portId = portId;
00301 }
00302
00303 // ---------------------------------------------------------------------------------------------------------------------------------
00304
00305 inline std::string Address::ToString() const
00306 {
00307     char buffer[16];
00308
00309     Snprintf(buffer, ACTIV_ARRAY_SIZE(buffer), "%u:%u", GetEndPointId(), GetPortId());
00310     return buffer;
00311 }
00312
00313 // ---------------------------------------------------------------------------------------------------------------------------------
00314
00315 inline bool Address::IsValid() const
00316 {
00317     return (INVALID_ENDPOINT_ID != m_endPointId) && (INVALID_PORT_ID != m_portId);
00318 }
00319
00320 // ---------------------------------------------------------------------------------------------------------------------------------
00321
00322 inline bool Address::operator==(const Address &rhs) const
00323 {
00324     return (m_endPointId == rhs.m_endPointId) && (m_portId == rhs.m_portId);
00325 }
00326
00327 // ---------------------------------------------------------------------------------------------------------------------------------
00328
00329 inline bool Address::operator!=(const Address &rhs) const
00330 {
00331     return !(*this == rhs);
00332 }
00333
00334 // ---------------------------------------------------------------------------------------------------------------------------------
00335
00336 inline bool Address::operator<(const Address &rhs) const
00337 {
00338     if (m_endPointId < rhs.m_endPointId)
00339         return true;
00340
00341     if (m_endPointId > rhs.m_endPointId)
00342         return false;
00343
00344     return m_portId < rhs.m_portId;
00345 }
00346
00347 // ---------------------------------------------------------------------------------------------------------------------------------
00348 // ---------------------------------------------------------------------------------------------------------------------------------
00349
00350 inline Address::Proxy::Proxy(Address &address) :
00351     m_address(address)
00352 {
00353     // NB don't do anything with m_address, it may not be constructed yet (see ScopedAddress::Proxy)
00354 }
00355
00356 // ---------------------------------------------------------------------------------------------------------------------------------
00357
00358 inline Address::Proxy::operator Address &()
00359 {
00360     return m_address;
00361 }
00362
00363 } // namespace Activ
00364
00365 #endif // (!defined ACTIV_SYSTEM_ADDRESS_H)
Generated on Wed Oct 8 14:01:48 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivAgentApplication

AgentApplication.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_AGENT_APPLICATION_AGENT_APPLICATION_H)
00010 #define ACTIV_AGENT_APPLICATION_AGENT_APPLICATION_H
00011
00012 #include "ActivMiddleware/ActivAgentApplication/External.h"
00013 #include "ActivMiddleware/ActivCoreServices/TimerService.h"
00014 #include "ActivMiddleware/ActivCoreServices/LoggerService.h"
00015 #include "ActivMiddleware/ActivCoreServices/PubSubService.h"
00016 #include "ActivMiddleware/ActivCoreServices/MonitorService.h"
00017 #include "ActivMiddleware/ActivCoreServices/DirectoryService.h"
00018 #include "ActivMiddleware/ActivCoreServices/UiService.h"
00019 #include "ActivMiddleware/ActivCoreServices/LicenseService.h"
00020 #include "ActivMiddleware/ActivRouter/RouterService.h"
00021
00022 #include "boost/scoped_ptr.hpp"
00023
00027 #define ACTIV_DEFAULT_SYSTEM_HEAP_BUCKET_INFO       { { 100, 1000 }, { 500, 1000 } }
00028
00029 namespace Activ
00030 {
00031
00038 class AgentApplication : public Application
00039 {
00040 public:
00044     class Settings : public Application::Settings
00045     {
00046     public:
00050         ACTIV_AGENT_APPLICATION_API Settings();
00051
00055         ACTIV_AGENT_APPLICATION_API ~Settings();
00056
00065         ACTIV_AGENT_APPLICATION_API StatusCode Read(const IniFileParser &iniFileParser);
00066
00067         std::string                 m_systemVersion;
00068
00069         IHeap::BucketInfoVector     m_systemHeapBucketInfo;
00070         std::string                 m_serviceLocationIniFile;
00071         std::string                 m_processStartupIniFile;
00072         bool                        m_createSystemLog;
00073         LoggerDefinitions::FileType m_systemLogType;
00074         uint64_t                    m_systemLogMaxSize;
00075         size_t                      m_systemLogNumberOfBackups;
00076         bool                        m_systemLogUniqueName;
00077         bool                        m_enableUiService;
00078         bool                        m_extendedUiShutdown;
00079
00080         // core service settings
00081         TimerService::Settings      m_timerServiceSettings;
00082         LoggerService::Settings     m_loggerServiceSettings;
00083         RouterService::Settings     m_routerServiceSettings;
00084         PubSubService::Settings     m_pubSubServiceSettings;
00085         MonitorService::Settings    m_monitorServiceSettings;
00086         DirectoryService::Settings  m_directoryServiceSettings;
00087         UiService::Settings         m_uiServiceSettings;
00088         LicenseService::Settings    m_licenseServiceSettings;
00089     };
00090
00099     ACTIV_AGENT_APPLICATION_API AgentApplication(const Settings &settings = Settings(), const std::string &componentId = defaultComponentId);
00100
00104     ACTIV_AGENT_APPLICATION_API virtual ~AgentApplication();
00105
00111     ACTIV_AGENT_APPLICATION_API StatusCode RestartSystem();
00112
00118     ACTIV_AGENT_APPLICATION_API bool IsSystemRestartable();
00119
00120     class Private;
00121
00122 protected:
00123     ACTIV_AGENT_APPLICATION_API virtual StatusCode OnMessage(HeapMessage &message);
00124     ACTIV_AGENT_APPLICATION_API virtual void OnCtrlEvent(const CtrlHandler::EventType eventType);
00125     ACTIV_AGENT_APPLICATION_API virtual bool CanThreadExit();
00126
00127 private:
00128     class UiFunctionality;
00129
00130     boost::scoped_ptr<Private>  m_pPrivate;
00131 };
00132
00133 } // namespace Activ
00134
00135 #endif // (!defined ACTIV_AGENT_APPLICATION_AGENT_APPLICATION_H)
Generated on Wed Oct 8 14:01:46 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivFramework

Application.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FRAMEWORK_APPLICATION_H)
00010 #define ACTIV_FRAMEWORK_APPLICATION_H
00011
00012 #include "ActivMiddleware/ActivFramework/External.h"
00013 #include "ActivMiddleware/ActivFramework/Component.h"
00014 #include "ActivMiddleware/ActivFramework/DirectoryWatchApi.h"
00015 #include "ActivMiddleware/ActivFramework/TimerServiceApi.h"
00016 #include "ActivMiddleware/ActivFramework/LoggerServiceApi.h"
00017 #include "ActivMiddleware/ActivFramework/RouterServiceApi.h"
00018 #include "ActivMiddleware/ActivFramework/PubSubServiceApi.h"
00019 #include "ActivMiddleware/ActivFramework/ServiceApi.h"
00020 #include "ActivMiddleware/ActivBase/CtrlHandler.h"
00021
00022 #include "boost/scoped_ptr.hpp"
00023
00024 namespace Activ
00025 {
00026
00030 class SystemProxy : public ISystem
00031 {
00032 public:
00036     ACTIV_FRAMEWORK_API ~SystemProxy();
00037
00038     // ISystem
00039     ACTIV_FRAMEWORK_API virtual IEndPoint *CreatePrivateEndPoint(const bool hasMutex, const IEndPoint::NotificationType notificationType);
00040     ACTIV_FRAMEWORK_API virtual ISyncEndPoint *CreateEndPoint(const std::string &name, const bool hasMutex,
00041         const IEndPoint::NotificationType notificationType);
00042     ACTIV_FRAMEWORK_API virtual ISyncEndPoint *OpenEndPoint(const std::string &name, Timeout &timeout = Timeout::GetInfinite());
00043     ACTIV_FRAMEWORK_API virtual ISyncEndPoint *OpenEndPoint(EndPointId endPointId, Timeout &timeout = Timeout::GetInfinite());
00044     ACTIV_FRAMEWORK_API virtual IHeap *CreateHeap(const std::string &name, const IHeap::BucketInfoVector &bucketInfoVector);
00045     ACTIV_FRAMEWORK_API virtual IHeap *OpenHeap(const std::string &name, Timeout &timeout = Timeout::GetInfinite());
00046     ACTIV_FRAMEWORK_API virtual IHeap *OpenHeap(const HeapId heapId, Timeout &timeout = Timeout::GetInfinite());
00047     ACTIV_FRAMEWORK_API virtual IProcess *OpenProcess(const std::string &name, Timeout &timeout = Timeout::GetInfinite());
00048     ACTIV_FRAMEWORK_API virtual IProcess *OpenProcess(const ProcessId processId, Timeout &timeout = Timeout::GetInfinite());
00049     ACTIV_FRAMEWORK_API virtual std::string GetSystemName() const;
00050     ACTIV_FRAMEWORK_API virtual IHeap *GetSystemHeap() const;
00051     ACTIV_FRAMEWORK_API virtual IProcess *GetProcess() const;
00052     ACTIV_FRAMEWORK_API virtual SystemInfo GetSystemInfo() const;
00053     ACTIV_FRAMEWORK_API virtual void EnumerateObjects(IProcessEnumerator &enumerator);
00054     ACTIV_FRAMEWORK_API virtual void EnumerateObjects(IEndPointEnumerator &enumerator);
00055     ACTIV_FRAMEWORK_API virtual void EnumerateObjects(IHeapEnumerator &enumerator);
00056
00057 private:
00067     SystemProxy(const ISystem::Settings &settings, const IHeap::BucketInfoVector &bucketInfoVector,
00068         const std::string &systemVersion);
00069
00079     SystemProxy(const ISystem::Settings &settings, const std::string &processName, Timeout &timeout = Timeout::GetInfinite());
00080
00081     ISystem * const m_pSystem;
00082
00083     friend class Application;
00084 };
00085
00086 // ---------------------------------------------------------------------------------------------------------------------------------
00087 // ---------------------------------------------------------------------------------------------------------------------------------
00088
00100 class Application : public SystemProxy, public ManagedEndPoint, public Component
00101 {
00102 public:
00106     class Settings : public ISystem::Settings
00107     {
00108     public:
00114         enum ExceptionHandlerType
00115         {
00116             EXCEPTION_HANDLER_TYPE_NONE,
00117             EXCEPTION_HANDLER_TYPE_NORMAL,
00118             EXCEPTION_HANDLER_TYPE_FULL_MEMORY
00119         };
00120
00124         ACTIV_FRAMEWORK_API Settings();
00125
00134         ACTIV_FRAMEWORK_API StatusCode Read(const IniFileParser::ConstSectionIterator &sectionIterator);
00135
00136         bool                        m_enableCtrlHandler;
00137         ExceptionHandlerType        m_exceptionHandlerType;
00138         ManagedEndPoint::Settings   m_managedEndPointSettings;
00139     };
00140
00144     enum ShutdownReason
00145     {
00146         SHUTDOWN_REASON_API,
00147         SHUTDOWN_REASON_UI,
00148         SHUTDOWN_REASON_UI_RESTART,
00149         SHUTDOWN_REASON_LOGOFF,
00150         SHUTDOWN_REASON_PROCESS_KILLED,
00151         SHUTDOWN_REASON_UPDATING,
00152         SHUTDOWN_REASON_NOT_LICENSED
00153     };
00154
00158     ACTIV_FRAMEWORK_API virtual ~Application();
00159
00163     ACTIV_FRAMEWORK_API void Shutdown();
00164
00172     ACTIV_FRAMEWORK_API IHeap *GetMonitorServiceHeap() const;
00173
00181     ACTIV_FRAMEWORK_API static const std::string &GetUiServiceName();
00182
00183     class Private;
00184
00190     const Private &GetPrivate() const;
00191
00192 protected:
00193     ACTIV_FRAMEWORK_API virtual StatusCode OnMessage(HeapMessage &message);
00194
00200     ACTIV_FRAMEWORK_API virtual void OnCtrlEvent(const CtrlHandler::EventType eventType);
00201
00212     ACTIV_FRAMEWORK_API virtual void OnShutdown(const ShutdownReason shutdownReason);
00213
00214 private:
00224     ACTIV_FRAMEWORK_API Application(const Settings &settings, const IHeap::BucketInfoVector &bucketInfoVector,
00225         const std::string &systemVersion);
00226
00237     Application(const Settings &settings, const std::string &processName, const IHeap::BucketInfoVector &bucketInfoVector,
00238         Timeout &timeout = Timeout::GetInfinite());
00239
00240     const Settings  m_settings;
00241     Private *       m_pPrivate;
00242
00243     friend class AgentApplication;
00244     friend class ThinApplication;
00245 };
00246
00247 // ---------------------------------------------------------------------------------------------------------------------------------
00248
00249 inline const Application::Private &Application::GetPrivate() const
00250 {
00251     return *m_pPrivate;
00252 }
00253
00254 } // namespace Activ
00255
00256 #endif // (!defined ACTIV_FRAMEWORK_APPLICATION_H)
Generated on Wed Oct 8 14:01:48 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

Atomic.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_BASE_ATOMIC_H)
00010 #define ACTIV_BASE_ATOMIC_H
00011
00012 #include "ActivMiddleware/ActivBase/Detail/AtomicDetail.h"
00013
00014 #include "boost/static_assert.hpp"
00015
00016 namespace Activ
00017 {
00018
00022 class AtomicInteger
00023 {
00024 public:
00025     typedef long Type;
00026
00030     ACTIV_BASE_INLINE_API AtomicInteger();
00031
00037     ACTIV_BASE_INLINE_API explicit AtomicInteger(const Type value);
00038
00046     ACTIV_BASE_INLINE_API Type Exchange(const Type value);
00047
00053     ACTIV_BASE_INLINE_API Type Get() const;
00054
00060     ACTIV_BASE_INLINE_API Type operator++();
00061
00067     ACTIV_BASE_INLINE_API Type operator++(int);
00068
00074     ACTIV_BASE_INLINE_API Type operator--();
00075
00081     ACTIV_BASE_INLINE_API Type operator--(int);
00082
00086     ACTIV_BASE_INLINE_API operator Type() const;
00087
00088 private:
00089     volatile Type   m_value;
00090 };
00091
00092 // ---------------------------------------------------------------------------------------------------------------------------------
00093
00094 inline AtomicInteger::AtomicInteger()
00095 {
00096     (void) Exchange(0);
00097 }
00098
00099 // ---------------------------------------------------------------------------------------------------------------------------------
00100
00101 inline AtomicInteger::AtomicInteger(const Type value)
00102 {
00103     (void) Exchange(value);
00104 }
00105
00106 // ---------------------------------------------------------------------------------------------------------------------------------
00107
00108 inline AtomicInteger::Type AtomicInteger::Exchange(const Type value)
00109 {
00110     return AtomicExchange(&m_value, value);
00111 }
00112
00113 // ---------------------------------------------------------------------------------------------------------------------------------
00114
00115 inline AtomicInteger::Type AtomicInteger::Get() const
00116 {
00117     return m_value;
00118 }
00119
00120 // ---------------------------------------------------------------------------------------------------------------------------------
00121
00122 inline AtomicInteger::Type AtomicInteger::operator++()
00123 {
00124     return AtomicIncrement(&m_value);
00125 }
00126
00127 // ---------------------------------------------------------------------------------------------------------------------------------
00128
00129 inline AtomicInteger::Type AtomicInteger::operator++(int)
00130 {
00131     return ++(*this) - 1;
00132 }
00133
00134 // ---------------------------------------------------------------------------------------------------------------------------------
00135
00136 inline AtomicInteger::Type AtomicInteger::operator--()
00137 {
00138     return AtomicDecrement(&m_value);
00139 }
00140
00141 // ---------------------------------------------------------------------------------------------------------------------------------
00142
00143 inline AtomicInteger::Type AtomicInteger::operator--(int)
00144 {
00145     return --(*this) + 1;
00146 }
00147
00148 // ---------------------------------------------------------------------------------------------------------------------------------
00149
00150 inline AtomicInteger::operator AtomicInteger::Type() const
00151 {
00152     return Get();
00153 }
00154
00155 // ---------------------------------------------------------------------------------------------------------------------------------
00156 // ---------------------------------------------------------------------------------------------------------------------------------
00157
00163 template<typename T>
00164 class AtomicPointer
00165 {
00166 public:
00167     typedef T *Pointer;
00168
00172     ACTIV_BASE_INLINE_API AtomicPointer();
00173
00179     ACTIV_BASE_INLINE_API explicit AtomicPointer(const Pointer pointer);
00180
00188     ACTIV_BASE_INLINE_API Pointer Exchange(const Pointer value);
00189
00197     ACTIV_BASE_INLINE_API AtomicPointer &operator=(const Pointer value);
00198
00204     ACTIV_BASE_INLINE_API Pointer operator->() const;
00205
00209     ACTIV_BASE_INLINE_API operator Pointer() const;
00210
00211 private:
00212     volatile Pointer    m_value;
00213 };
00214
00215 // ---------------------------------------------------------------------------------------------------------------------------------
00216
00217 template<typename T>
00218 inline AtomicPointer<T>::AtomicPointer()
00219 {
00220     *this = 0;
00221 }
00222
00223 // ---------------------------------------------------------------------------------------------------------------------------------
00224
00225 template<typename T>
00226 inline AtomicPointer<T>::AtomicPointer(const Pointer value)
00227 {
00228     *this = value;
00229 }
00230
00231 // ---------------------------------------------------------------------------------------------------------------------------------
00232
00233 template<typename T>
00234 inline T *AtomicPointer<T>::Exchange(const Pointer value)
00235 {
00236     // this seemingly pointless variable is to avoid gcc type-punning warnings
00237     volatile Pointer *pTarget = &m_value;
00238
00239 #if (defined ACTIV_PROCESSOR_X86) || (defined ACTIV_PROCESSOR_PPC) || (defined ACTIV_PROCESSOR_SPARC) || (defined ACTIV_PROCESSOR_SPARC64) || (((defined ACTIV_PROCESSOR_X86_64) || (defined ACTIV_PROCESSOR_IA64)) && (!defined ACTIV_PLATFORM_WINDOWS))
00240
00241     BOOST_STATIC_ASSERT(sizeof(long) == sizeof(Pointer));
00242
00243     return reinterpret_cast<Pointer>(AtomicExchange(reinterpret_cast<volatile long *>(pTarget), reinterpret_cast<long>(value)));
00244
00245 #elif ((defined ACTIV_PROCESSOR_X86_64) || (defined ACTIV_PROCESSOR_IA64)) && (defined ACTIV_PLATFORM_WINDOWS)
00246
00247     // on Windows long is still 32-bit
00248     BOOST_STATIC_ASSERT(sizeof(int64_t) == sizeof(Pointer));
00249
00250     return reinterpret_cast<Pointer>(AtomicExchange(reinterpret_cast<volatile int64_t *>(pTarget), reinterpret_cast<int64_t>(value)));
00251
00252 #else
00253 #error Configure
00254 #endif
00255 }
00256
00257 // ---------------------------------------------------------------------------------------------------------------------------------
00258
00259 template<typename T>
00260 inline AtomicPointer<T> &AtomicPointer<T>::operator=(const Pointer value)
00261 {
00262     (void) Exchange(value);
00263     return *this;
00264 }
00265
00266 // ---------------------------------------------------------------------------------------------------------------------------------
00267 // ---------------------------------------------------------------------------------------------------------------------------------
00268
00269 template<typename T>
00270 inline AtomicPointer<T>::operator T *() const
00271 {
00272     return m_value;
00273 }
00274
00275 // ---------------------------------------------------------------------------------------------------------------------------------
00276
00277 template<typename T>
00278 inline T *AtomicPointer<T>::operator->() const
00279 {
00280     return m_value;
00281 }
00282
00283 } // namespace Activ
00284
00285 #endif // (!defined ACTIV_BASE_ATOMIC_H)
Generated on Wed Oct 8 14:01:46 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase » Detail

AtomicDetail.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_BASE_DETAIL_ATOMIC_DETAIL_H)
00010 #define ACTIV_BASE_DETAIL_ATOMIC_DETAIL_H
00011
00012 #include "ActivMiddleware/ActivBase/External.h"
00013
00014 #include <cassert>
00015
00016 namespace Activ
00017 {
00018
00019 #if (defined ACTIV_COMPILER_SUNPRO)
00020
00028 ACTIV_BASE_EXPORTED_API long AtomicIncrement(volatile long *pAddend);
00029
00037 ACTIV_BASE_EXPORTED_API long AtomicDecrement(volatile long *pAddend);
00038
00047 ACTIV_BASE_EXPORTED_API long AtomicExchange(volatile long *pTarget, const long value);
00048
00049 #else
00050
00058 ACTIV_BASE_INLINE_API long AtomicIncrement(volatile long *pAddend);
00059
00067 ACTIV_BASE_INLINE_API long AtomicDecrement(volatile long *pAddend);
00068
00077 ACTIV_BASE_INLINE_API long AtomicExchange(volatile long *pTarget, const long value);
00078
00079 // ---------------------------------------------------------------------------------------------------------------------------------
00080 // ---------------------------------------------------------------------------------------------------------------------------------
00081
00082 inline long AtomicIncrement(volatile long *pAddend)
00083 {
00084 #if (defined ACTIV_PLATFORM_WINDOWS)
00085
00086     return ::InterlockedIncrement(pAddend);
00087
00088 #elif (defined ACTIV_COMPILER_GCC)
00089
00090     long res;
00091
00092 #if (defined ACTIV_PROCESSOR_X86) || (defined ACTIV_PROCESSOR_X86_64)
00093
00094     __asm__ volatile
00095     (
00096     "       mov     $1, %0      \n"
00097     "       lock                \n"
00098     "       xadd    %0, (%1)    \n"
00099     "       inc     %0          \n"
00100     : "=&q" (res)
00101     : "q" (pAddend)
00102     : "memory"
00103     );
00104
00105 #elif (defined ACTIV_PROCESSOR_PPC)
00106
00107     __asm__ volatile
00108     (
00109
00110     "1:     lwarx   %0, 0, %1   \n"
00111     "       addic   %0, %0, 1   \n"
00112     "       stwcx.  %0, 0, %1   \n"
00113     "       bne-    1b          \n"
00114     : "=&r" (res)
00115     : "r" (pAddend)
00116     : "memory", "cc"
00117     );
00118
00119 #elif (defined ACTIV_PROCESSOR_SPARC)
00120
00121     long value = 0;
00122
00123     __asm__ volatile
00124     (
00125     "       ld          [%2], %1            \n"                 // value = *pAddend
00126     "1:     add         %1, 1, %0           \n"                 // res = value + 1
00127     "       cas         [%2], %1, %0        \n"                 // if (*pAddend == value) swap(*pAddend, res) else res = *pAddend
00128     "       cmp         %0, %1              \n"                 // if (res != value) { value = *pAddend; goto 1 }
00129     "       bne,a,pn    %%icc, 1b           \n"
00130     "       ld          [%2], %1            \n"
00131     "       add         %1, 1, %0           \n"                 // res = value + 1
00132     : "=&r" (res)
00133     : "r" (value), "r" (pAddend)
00134     : "memory", "cc"
00135     );
00136
00137 #elif (defined ACTIV_PROCESSOR_SPARC64)
00138
00139     long value = 0;
00140
00141     __asm__ volatile
00142     (
00143     "       ldx         [%2], %1            \n"                 // value = *pAddend
00144     "1:     add         %1, 1, %0           \n"                 // res = value + 1
00145     "       casx        [%2], %1, %0        \n"                 // if (*pAddend == value) swap(*pAddend, res) else res = *pAddend
00146     "       cmp         %0, %1              \n"                 // if (res != value) { value = *pAddend; goto 1 }
00147     "       bne,a,pn    %%icc, 1b           \n"
00148     "       ldx         [%2], %1            \n"
00149     "       add         %1, 1, %0           \n"                 // res = value + 1
00150     : "=&r" (res)
00151     : "r" (value), "r" (pAddend)
00152     : "memory", "cc"
00153     );
00154
00155 #elif (defined ACTIV_PROCESSOR_IA64)
00156
00157     __asm__ volatile
00158     (
00159     "       mf                              \n"
00160     "       fetchadd8.acq   %0 = [%1], 1    \n"
00161     : "=&r" (res)
00162     : "r" (pAddend)
00163     : "memory"
00164     );
00165
00166     ++res;
00167
00168 #else
00169 #error Implement for this processor
00170 #endif
00171
00172     return res;
00173
00174 #else
00175 #error Implement for this compiler
00176 #endif
00177 }
00178
00179 // ---------------------------------------------------------------------------------------------------------------------------------
00180
00181 inline long AtomicDecrement(volatile long *pAddend)
00182 {
00183 #if (defined ACTIV_PLATFORM_WINDOWS)
00184
00185     return ::InterlockedDecrement(pAddend);
00186
00187 #elif (defined ACTIV_COMPILER_GCC)
00188
00189     long res;
00190
00191 #if (defined ACTIV_PROCESSOR_X86) || (defined ACTIV_PROCESSOR_X86_64)
00192
00193     __asm__ volatile
00194     (
00195     "       mov     $-1, %0         \n"
00196     "       lock                    \n"
00197     "       xadd    %0, (%1)        \n"
00198     "       dec     %0              \n"
00199     : "=&q" (res)
00200     : "q" (pAddend)
00201     : "memory"
00202     );
00203
00204 #elif (defined ACTIV_PROCESSOR_PPC)
00205
00206     __asm__ volatile
00207     (
00208     "1:     lwarx   %0, 0, %1       \n"
00209     "       addic   %0, %0, -1      \n"
00210     "       stwcx.  %0, 0, %1       \n"
00211     "       bne-    1b              \n"
00212     : "=&r" (res)
00213     : "r" (pAddend)
00214     : "memory", "cc"
00215     );
00216
00217 #elif (defined ACTIV_PROCESSOR_SPARC)
00218
00219     long value = 0;
00220
00221     __asm__ volatile
00222     (
00223     "       ld          [%2], %1            \n"                 // value = *pAddend
00224     "1:     sub         %1, 1, %0           \n"                 // res = value - 1
00225     "       cas         [%2], %1, %0        \n"                 // if (*pAddend == value) swap(*pAddend, res) else res = *pAddend
00226     "       cmp         %0, %1              \n"                 // if (res != value) { value = *pAddend; goto 1 }
00227     "       bne,a,pn    %%icc, 1b           \n"
00228     "       ld          [%2], %1            \n"
00229     "       sub         %1, 1, %0           \n"                 // res = value - 1
00230     : "=&r" (res)
00231     : "r" (value), "r" (pAddend)
00232     : "memory", "cc"
00233     );
00234
00235 #elif (defined ACTIV_PROCESSOR_SPARC64)
00236
00237     long value = 0;
00238
00239     __asm__ volatile
00240     (
00241     "       ldx         [%2], %1            \n"                 // value = *pAddend
00242     "1:     sub         %1, 1, %0           \n"                 // res = value - 1
00243     "       casx        [%2], %1, %0        \n"                 // if (*pAddend == value) swap(*pAddend, res) else res = *pAddend
00244     "       cmp         %0, %1              \n"                 // if (res != value) { value = *pAddend; goto 1 }
00245     "       bne,a,pn    %%icc, 1b           \n"
00246     "       ldx         [%2], %1            \n"
00247     "       sub         %1, 1, %0           \n"                 // res = value - 1
00248     : "=&r" (res)
00249     : "r" (value), "r" (pAddend)
00250     : "memory", "cc"
00251     );
00252
00253 #elif (defined ACTIV_PROCESSOR_IA64)
00254
00255     __asm__ volatile
00256     (
00257     "       mf                              \n"
00258     "       fetchadd8.acq   %0 = [%1], -1   \n"
00259     : "=&r" (res)
00260     : "r" (pAddend)
00261     : "memory"
00262     );
00263
00264     --res;
00265
00266 #else
00267 #error Implement for this processor
00268 #endif
00269
00270     return res;
00271
00272 #else
00273 #error Implement for this compiler
00274 #endif
00275 }
00276
00277 // ---------------------------------------------------------------------------------------------------------------------------------
00278
00279 inline long AtomicExchange(volatile long *pTarget, const long value)
00280 {
00281 #if (defined ACTIV_PLATFORM_WINDOWS)
00282
00283     return ::InterlockedExchange(pTarget, value);
00284
00285 #elif (defined ACTIV_COMPILER_GCC)
00286
00287     long res;
00288
00289 #if (defined ACTIV_PROCESSOR_X86) || (defined ACTIV_PROCESSOR_X86_64)
00290
00291     __asm__ volatile
00292     (
00293     "       mov         (%1), %0    \n"                         // res = *pTarget
00294     "1:     lock                    \n"
00295     "       cmpxchg     %2, (%1)    \n"                         // if (*pTarget == res) *pTarget = value else res = *pTarget
00296     "       jne         1b          \n"
00297     : "=&a" (res)
00298     : "q" (pTarget), "q" (value)
00299     : "memory", "cc"
00300     );
00301
00302 #elif (defined ACTIV_PROCESSOR_PPC)
00303
00304     __asm__ volatile
00305     (
00306     "1:     lwarx   %0, 0, %1       \n"
00307     "       stwcx.  %2, 0, %1       \n"
00308     "       bne-    1b              \n"
00309     : "=&r" (res)
00310     : "r" (pTarget), "r" (value)
00311     : "memory", "cc"
00312     );
00313
00314 #elif (defined ACTIV_PROCESSOR_SPARC)
00315
00316     long tmp;
00317
00318     __asm__ volatile
00319     (
00320     "       ld          [%2], %1            \n"                 // tmp = *pTarget
00321     "1:     mov         %3, %0              \n"                 // res = value
00322     "       cas         [%2], %1, %0        \n"                 // if (*pTarget == tmp) swap(*pTarget, res) else res = *pAddend
00323     "       cmp         %0, %1              \n"                 // if (res != tmp)
00324     "       bne,a,pn    %%icc, 1b           \n"                 //     tmp = *pTarget; goto 1
00325     "       ld          [%2], %1            \n"                 // executed before the branch (delay slot)
00326     : "=&r" (res), "=&r" (tmp)
00327     : "r" (pTarget), "r" (value)
00328     : "memory", "cc"
00329     );
00330
00331 #elif (defined ACTIV_PROCESSOR_SPARC64)
00332
00333     long tmp;
00334
00335     __asm__ volatile
00336     (
00337     "       ldx         [%2], %1            \n"                 // tmp = *pTarget
00338     "1:     mov         %3, %0              \n"                 // res = value
00339     "       casx        [%2], %1, %0        \n"                 // if (*pTarget == tmp) swap(*pTarget, res) else res = *pAddend
00340     "       cmp         %0, %1              \n"                 // if (res != tmp)
00341     "       bne,a,pn    %%icc, 1b           \n"                 //     tmp = *pTarget; goto 1
00342     "       ldx         [%2], %1            \n"                 // executed before the branch (delay slot)
00343     : "=&r" (res), "=&r" (tmp)
00344     : "r" (pTarget), "r" (value)
00345     : "memory", "cc"
00346     );
00347
00348 #elif (defined ACTIV_PROCESSOR_IA64)
00349
00350     __asm__ volatile
00351     (
00352     "       mf                              \n"
00353     "       xchg8       %0 = [%1], %2       \n"
00354     : "=&r" (res)
00355     : "r" (pTarget), "r" (value)
00356     : "memory"
00357     );
00358
00359 #else
00360 #error Implement for this processor
00361 #endif
00362
00363     return res;
00364
00365 #else
00366 #error Implement for this compiler
00367 #endif
00368 }
00369
00370 // ---------------------------------------------------------------------------------------------------------------------------------
00371
00372 #if ((defined ACTIV_PROCESSOR_X86_64) || (defined ACTIV_PROCESSOR_IA64)) && (defined ACTIV_PLATFORM_WINDOWS)
00373 // NB on Windows 64-bit long is still 32-bit, hence require a 64-bit exchange too
00374
00383 ACTIV_BASE_INLINE_API int64_t AtomicExchange(volatile int64_t *pTarget, const int64_t value);
00384
00385 // ---------------------------------------------------------------------------------------------------------------------------------
00386
00387 inline int64_t AtomicExchange(volatile int64_t *pTarget, const int64_t value)
00388 {
00389     return ::InterlockedExchange64(pTarget, value);
00390 }
00391
00392 #endif // ((defined ACTIV_PROCESSOR_X86_64) || (defined ACTIV_PROCESSOR_IA64)) && (defined ACTIV_PLATFORM_WINDOWS)
00393
00394 #endif // (!defined ACTIV_COMPILER_SUNPRO)
00395
00396 } // namespace Activ
00397
00398 #endif // (!defined ACTIV_BASE_DETAIL_ATOMIC_DETAIL_H)
Generated on Wed Oct 8 14:01:47 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

BaseException.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_BASE_BASE_EXCEPTION_H)
00010 #define ACTIV_BASE_BASE_EXCEPTION_H
00011
00012 #include "ActivMiddleware/ActivBase/Exception.h"
00013
00020 #define ACTIV_BASE_EXCEPTION_LIST(d)                                                        \
00021     d(ERROR_INVALID_REGISTRY_VALUE_TYPE, "invalid registry value type")                     \
00022     d(ERROR_FAILED_TO_ALLOC_SHARED_MUTEX, "failed to allocate shared mutex")                \
00023     d(ERROR_FAILED_TO_ALLOC_PRIVATE_MUTEX, "failed to allocate private mutex")              \
00024     d(ERROR_FAILED_TO_INIT_PRIVATE_MUTEX, "failed to initialize private mutex")             \
00025     d(ERROR_FAILED_TO_ALLOC_SHARED_EVENT, "failed to allocate shared event")                \
00026     d(ERROR_FAILED_TO_ALLOC_PRIVATE_EVENT, "failed to allocate private event")              \
00027     d(ERROR_FAILED_TO_ALLOC_SHARED_SEMAPHORE, "failed to allocate shared semaphore")        \
00028     d(ERROR_FAILED_TO_ALLOC_PRIVATE_SEMAPHORE, "failed to allocate private semaphore")      \
00029     d(ERROR_FAILED_TO_ALLOC_VERSION, "failed to allocate version")                          \
00030     d(ERROR_FAILED_TO_ALLOC_SHARED_MEMORY, "failed to allocate shared memory")              \
00031     d(ERROR_FAILED_TO_ALLOC_METERED_SECTION, "failed to allocate metered section")          \
00032     d(ERROR_FAILED_TO_ALLOC_UUID, "failed to allocate Uuid")                                \
00033     d(ERROR_THREAD_ALREADY_STARTED, "thread already started")
00034
00035 namespace Activ
00036 {
00037
00043 class BaseException : public Exception
00044 {
00045 public:
00049     enum
00050     {
00051         ACTIV_BASE_EXCEPTION_LIST(ACTIV_DECLARE_ELEMENT_1_WITH_COMMA)
00052         NUM_ERRORS
00053     };
00054
00063     ACTIV_BASE_EXPORTED_API BaseException(const char *file, const char *function, const uint_fast32_t line,
00064         const uint_fast32_t errorCode);
00065
00066     ACTIV_BASE_EXPORTED_API virtual std::string ToString() const;
00067 };
00068
00069 } // namespace Activ
00070
00071 #endif // (!defined ACTIV_BASE_BASE_EXCEPTION_H)
Generated on Wed Oct 8 14:01:46 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware

BasicTypes.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_BASIC_TYPES_H)
00010 #define ACTIV_BASIC_TYPES_H
00011
00012 #include "boost/cstdint.hpp"
00013 #include "boost/integer_traits.hpp"
00014 #include "boost/static_assert.hpp"
00015 #include "boost/type_traits.hpp"
00016 #include "boost/call_traits.hpp"
00017
00018 #include <cmath>
00019 #include <string>
00020 #include <sstream>
00021 #include <functional>
00022
00023 namespace Activ
00024 {
00025
00026 using boost::int8_t;
00027 using boost::int_least8_t;
00028 using boost::int_fast8_t;
00029 using boost::uint8_t;
00030 using boost::uint_least8_t;
00031 using boost::uint_fast8_t;
00032
00033 using boost::int16_t;
00034 using boost::int_least16_t;
00035 using boost::int_fast16_t;
00036 using boost::uint16_t;
00037 using boost::uint_least16_t;
00038 using boost::uint_fast16_t;
00039
00040 using boost::int32_t;
00041 using boost::int_least32_t;
00042 using boost::int_fast32_t;
00043 using boost::uint32_t;
00044 using boost::uint_least32_t;
00045 using boost::uint_fast32_t;
00046
00047 using boost::int64_t;
00048 using boost::int_least64_t;
00049 using boost::int_fast64_t;
00050 using boost::uint64_t;
00051 using boost::uint_least64_t;
00052 using boost::uint_fast64_t;
00053
00054 using boost::intmax_t;
00055 using boost::uintmax_t;
00056
00057 typedef uint8_t byte_t;
00058 typedef uint32_t TimeoutPeriod;
00059
00060 // ---------------------------------------------------------------------------------------------------------------------------------
00061
00062 #if (!defined INT8_MAX)
00063 #define INT8_MAX            0x7F
00064 #endif
00065
00066 #if (!defined INT8_MIN)
00067 #define INT8_MIN            (-(INT8_MAX) - 1)
00068 #endif
00069
00070 #if (!defined INT_LEAST8_MAX)
00071 #define INT_LEAST8_MAX      0x7F
00072 #endif
00073
00074 #if (!defined INT_LEAST8_MIN)
00075 #define INT_LEAST8_MIN      (-(INT8_MAX) - 1)
00076 #endif
00077
00078 #if (!defined INT_FAST8_MAX)
00079 #define INT_FAST8_MAX       0x7F
00080 #endif
00081
00082 #if (!defined INT_FAST8_MIN)
00083 #define INT_FAST8_MIN       (-(INT8_MAX) - 1)
00084 #endif
00085
00086 #if (!defined UINT8_MAX)
00087 #define UINT8_MAX           0xFF
00088 #endif
00089
00090 #if (!defined UINT_LEAST8_MAX)
00091 #define UINT_LEAST8_MAX     0xFF
00092 #endif
00093
00094 #if (!defined UINT_FAST8_MAX)
00095 #define UINT_FAST8_MAX      0xFF
00096 #endif
00097
00098 #if (!defined INT16_MAX)
00099 #define INT16_MAX           0x7FFF
00100 #endif
00101
00102 #if (!defined INT16_MIN)
00103 #define INT16_MIN           (-(INT16_MAX) - 1)
00104 #endif
00105
00106 #if (!defined INT_LEAST16_MAX)
00107 #define INT_LEAST16_MAX     0x7FFF
00108 #endif
00109
00110 #if (!defined INT_LEAST16_MIN)
00111 #define INT_LEAST16_MIN     (-(INT16_MAX) - 1)
00112 #endif
00113
00114 #if (!defined INT_FAST16_MAX)
00115 #define INT_FAST16_MAX      0x7FFF
00116 #endif
00117
00118 #if (!defined INT_FAST16_MIN)
00119 #define INT_FAST16_MIN      (-(INT16_MAX) - 1)
00120 #endif
00121
00122 #if (!defined UINT16_MAX)
00123 #define UINT16_MAX          0xFFFF
00124 #endif
00125
00126 #if (!defined UINT_LEAST16_MAX)
00127 #define UINT_LEAST16_MAX    0xFFFF
00128 #endif
00129
00130 #if (!defined UINT_FAST16_MAX)
00131 #define UINT_FAST16_MAX     0xFFFF
00132 #endif
00133
00134 #if (!defined INT32_MAX)
00135 #define INT32_MAX           0x7FFFFFFF
00136 #endif
00137
00138 #if (!defined INT32_MIN)
00139 #define INT32_MIN           (-(INT32_MAX) - 1)
00140 #endif
00141
00142 #if (!defined INT_LEAST32_MAX)
00143 #define INT_LEAST32_MAX     0x7FFFFFFF
00144 #endif
00145
00146 #if (!defined INT_LEAST32_MIN)
00147 #define INT_LEAST32_MIN     (-(INT32_MAX) - 1)
00148 #endif
00149
00150 #if (!defined INT_FAST32_MAX)
00151 #define INT_FAST32_MAX      0x7FFFFFFF
00152 #endif
00153
00154 #if (!defined INT_FAST32_MIN)
00155 #define INT_FAST32_MIN      (-(INT32_MAX) - 1)
00156 #endif
00157
00158 #if (!defined UINT32_MAX)
00159 #define UINT32_MAX          0xFFFFFFFF
00160 #endif
00161
00162 #if (!defined UINT_LEAST32_MAX)
00163 #define UINT_LEAST32_MAX    0xFFFFFFFF
00164 #endif
00165
00166 #if (!defined UINT_FAST32_MAX)
00167 #define UINT_FAST32_MAX     0xFFFFFFFF
00168 #endif
00169
00170 #if (!defined INT64_MAX)
00171 #define INT64_MAX           INT64_C(0x7FFFFFFFFFFFFFFF)
00172 #endif
00173
00174 #if (!defined INT64_MIN)
00175 #define INT64_MIN           (-(INT64_MAX) - 1)
00176 #endif
00177
00178 #if (!defined INT_LEAST64_MAX)
00179 #define INT_LEAST64_MAX     INT64_C(0x7FFFFFFFFFFFFFFF)
00180 #endif
00181
00182 #if (!defined INT_LEAST64_MIN)
00183 #define INT_LEAST64_MIN     (-(INT64_MAX) - 1)
00184 #endif
00185
00186 #if (!defined INT_FAST64_MAX)
00187 #define INT_FAST64_MAX      INT64_C(0x7FFFFFFFFFFFFFFF)
00188 #endif
00189
00190 #if (!defined INT_FAST64_MIN)
00191 #define INT_FAST64_MIN      (-(INT64_MAX) - 1)
00192 #endif
00193
00194 #if (!defined UINT64_MAX)
00195 #define UINT64_MAX          UINT64_C(0xFFFFFFFFFFFFFFFF)
00196 #endif
00197
00198 #if (!defined UINT_LEAST64_MAX)
00199 #define UINT_LEAST64_MAX    UINT64_C(0xFFFFFFFFFFFFFFFF)
00200 #endif
00201
00202 #if (!defined UINT_FAST64_MAX)
00203 #define UINT_FAST64_MAX     UINT64_C(0xFFFFFFFFFFFFFFFF)
00204 #endif
00205
00206 #if (!defined INTMAX_MAX)
00207 #define INTMAX_MAX          INT64_C(0x7FFFFFFFFFFFFFFF)
00208 #endif
00209
00210 #if (!defined INTMAX_MIN)
00211 #define INTMAX_MIN          (-(INT64_MAX) - 1)
00212 #endif
00213
00214 #if (!defined UINTMAX_MAX)
00215 #define UINTMAX_MAX         UINT64_C(0xFFFFFFFFFFFFFFFF)
00216 #endif
00217
00218 #define BYTE_MAX            UINT8_MAX
00219
00220 #if (defined BYTE_ORDER)
00221 #    if (BYTE_ORDER == LITTLE_ENDIAN)
00222 #        define ACTIV_LITTLE_ENDIAN 0x0123
00223 #        define ACTIV_BYTE_ORDER ACTIV_LITTLE_ENDIAN
00224 #    elif (BYTE_ORDER == BIG_ENDIAN)
00225 #        define ACTIV_BIG_ENDIAN 0x3210
00226 #        define ACTIV_BYTE_ORDER ACTIV_BIG_ENDIAN
00227 #    else
00228 #        error: unknown BYTE_ORDER!
00229 #    endif
00230 #elif (defined __BYTE_ORDER)
00231 #    if (__BYTE_ORDER == __LITTLE_ENDIAN)
00232 #        define ACTIV_LITTLE_ENDIAN 0x0123
00233 #        define ACTIV_BYTE_ORDER ACTIV_LITTLE_ENDIAN
00234 #    elif (__BYTE_ORDER == __BIG_ENDIAN)
00235 #        define ACTIV_BIG_ENDIAN 0x3210
00236 #        define ACTIV_BYTE_ORDER ACTIV_BIG_ENDIAN
00237 #    else
00238 #        error: unknown __BYTE_ORDER!
00239 #    endif
00240 #else
00241 #    if (defined ACTIV_PROCESSOR_X86) || (defined ACTIV_PROCESSOR_X86_64) || (defined ACTIV_PROCESSOR_IA64)
00242 #        define ACTIV_LITTLE_ENDIAN 0x0123
00243 #        define ACTIV_BYTE_ORDER ACTIV_LITTLE_ENDIAN
00244 #    elif (defined ACTIV_PROCESSOR_SPARC) || (defined ACTIV_PROCESSOR_SPARC64) || (defined ACTIV_PROCESSOR_PPC)
00245 #        define ACTIV_BIG_ENDIAN 0x3210
00246 #        define ACTIV_BYTE_ORDER ACTIV_BIG_ENDIAN
00247 #    else
00248 #        error Configure for this processor
00249 #    endif
00250 #endif
00251
00252 // ---------------------------------------------------------------------------------------------------------------------------------
00253
00262 template<size_t N, bool S>
00263 class LengthToIntegralType
00264 {
00265 public:
00266 };
00267
00268 // ---------------------------------------------------------------------------------------------------------------------------------
00269
00270 template<>
00271 class LengthToIntegralType<1, true>
00272 {
00273 public:
00274     typedef int8_t Type;
00275 };
00276
00277 // ---------------------------------------------------------------------------------------------------------------------------------
00278
00279 template<>
00280 class LengthToIntegralType<1, false>
00281 {
00282 public:
00283     typedef uint8_t Type;
00284 };
00285
00286 // ---------------------------------------------------------------------------------------------------------------------------------
00287
00288 template<>
00289 class LengthToIntegralType<2, true>
00290 {
00291 public:
00292     typedef int16_t Type;
00293 };
00294
00295 // ---------------------------------------------------------------------------------------------------------------------------------
00296
00297 template<>
00298 class LengthToIntegralType<2, false>
00299 {
00300 public:
00301     typedef uint16_t Type;
00302 };
00303
00304 // ---------------------------------------------------------------------------------------------------------------------------------
00305
00306 template<>
00307 class LengthToIntegralType<4, true>
00308 {
00309 public:
00310     typedef int32_t Type;
00311 };
00312
00313 // ---------------------------------------------------------------------------------------------------------------------------------
00314
00315 template<>
00316 class LengthToIntegralType<4, false>
00317 {
00318 public:
00319     typedef uint32_t Type;
00320 };
00321
00322 // ---------------------------------------------------------------------------------------------------------------------------------
00323
00324 template<>
00325 class LengthToIntegralType<8, true>
00326 {
00327 public:
00328     typedef int64_t Type;
00329 };
00330
00331 // ---------------------------------------------------------------------------------------------------------------------------------
00332
00333 template<>
00334 class LengthToIntegralType<8, false>
00335 {
00336 public:
00337     typedef uint64_t Type;
00338 };
00339
00340 // ---------------------------------------------------------------------------------------------------------------------------------
00341 // ---------------------------------------------------------------------------------------------------------------------------------
00342
00350 template<typename T>
00351 class TypeToIntegralType
00352 {
00353 public:
00354     typedef typename LengthToIntegralType<sizeof(T), boost::is_signed<T>::value>::Type Type;
00355 };
00356
00357 // ---------------------------------------------------------------------------------------------------------------------------------
00358 // ---------------------------------------------------------------------------------------------------------------------------------
00359
00367 inline uint8_t ByteSwap(const uint8_t value)
00368 {
00369     return value;
00370 }
00371
00372 // ---------------------------------------------------------------------------------------------------------------------------------
00373
00381 inline int8_t ByteSwap(const int8_t value)
00382 {
00383     return value;
00384 }
00385
00386 // ---------------------------------------------------------------------------------------------------------------------------------
00387
00395 inline uint16_t ByteSwap(const uint16_t value)
00396 {
00397     return (((value & 0xff00) >> 8) |
00398             ((value & 0x00ff) << 8));
00399 }
00400
00401 // ---------------------------------------------------------------------------------------------------------------------------------
00402
00410 inline int16_t ByteSwap(const int16_t value)
00411 {
00412     return ByteSwap(static_cast<uint16_t>(value));
00413 }
00414
00415 // ---------------------------------------------------------------------------------------------------------------------------------
00416
00424 inline uint32_t ByteSwap(const uint32_t value)
00425 {
00426     return (((value & 0xff000000) >> 24) |
00427             ((value & 0x00ff0000) >> 8) |
00428             ((value & 0x0000ff00) << 8) |
00429             ((value & 0x000000ff) << 24));
00430 }
00431
00432 // ---------------------------------------------------------------------------------------------------------------------------------
00433
00441 inline int32_t ByteSwap(const int32_t value)
00442 {
00443     return ByteSwap(static_cast<uint32_t>(value));
00444 }
00445
00446 // ---------------------------------------------------------------------------------------------------------------------------------
00447
00455 inline uint64_t ByteSwap(const uint64_t value)
00456 {
00457     return ((static_cast<uint64_t>(ByteSwap(static_cast<uint32_t>(value) & UINT32_MAX)) << 32) |
00458             (ByteSwap(static_cast<uint32_t>((value >> 32) & UINT32_MAX))));
00459 }
00460
00461 // ---------------------------------------------------------------------------------------------------------------------------------
00462
00470 inline int64_t ByteSwap(const int64_t value)
00471 {
00472     return ByteSwap(static_cast<uint64_t>(value));
00473 }
00474
00475 // ---------------------------------------------------------------------------------------------------------------------------------
00476
00477 #if (defined ACTIV_EXPLICIT_INSTANTIATE_SIZE_T)
00478
00486 inline size_t ByteSwap(const size_t value)
00487 {
00488     return ByteSwap(static_cast<TypeToIntegralType<size_t>::Type>(value));
00489 }
00490
00491 #endif
00492
00493 // ---------------------------------------------------------------------------------------------------------------------------------
00494
00502 template <typename T>
00503 inline T HostToNetworkOrder(const T value)
00504 {
00505 #if (defined ACTIV_BIG_ENDIAN)
00506     return value;
00507 #elif (defined ACTIV_LITTLE_ENDIAN)
00508     return ByteSwap(value);
00509 #else
00510 #error Either ACTIV_BIG_ENDIAN or ACTIV_LITTLE_ENDIAN must be #defined.
00511 #endif
00512 }
00513
00514 // ---------------------------------------------------------------------------------------------------------------------------------
00515
00523 template <typename T>
00524 inline T HostToBigEndianOrder(const T value)
00525 {
00526 #if (defined ACTIV_BIG_ENDIAN)
00527     return value;
00528 #elif (defined ACTIV_LITTLE_ENDIAN)
00529     return ByteSwap(value);
00530 #else
00531 #error Either ACTIV_BIG_ENDIAN or ACTIV_LITTLE_ENDIAN must be #defined.
00532 #endif
00533 }
00534
00535 // ---------------------------------------------------------------------------------------------------------------------------------
00536
00544 template <typename T>
00545 inline T HostToLittleEndianOrder(const T value)
00546 {
00547 #if (defined ACTIV_BIG_ENDIAN)
00548     return ByteSwap(value);
00549 #elif (defined ACTIV_LITTLE_ENDIAN)
00550     return value;
00551 #else
00552 #error Either ACTIV_BIG_ENDIAN or ACTIV_LITTLE_ENDIAN must be #defined.
00553 #endif
00554 }
00555
00556 // ---------------------------------------------------------------------------------------------------------------------------------
00557
00565 template <typename T>
00566 inline T NetworkToHostOrder(const T value)
00567 {
00568     return HostToNetworkOrder(value);
00569 }
00570
00571 // ---------------------------------------------------------------------------------------------------------------------------------
00572
00580 template <typename T>
00581 inline T BigEndianToHostOrder(const T value)
00582 {
00583     return HostToBigEndianOrder(value);
00584 }
00585
00586 // ---------------------------------------------------------------------------------------------------------------------------------
00587
00595 template <typename T>
00596 inline T LittleEndianToHostOrder(const T value)
00597 {
00598     return HostToLittleEndianOrder(value);
00599 }
00600
00601 // ---------------------------------------------------------------------------------------------------------------------------------
00602
00616 template<typename T>
00617 inline typename boost::call_traits<T>::param_type GetMaximum(typename boost::call_traits<T>::param_type a,
00618     typename boost::call_traits<T>::param_type b)
00619 {
00620     if (a > b)
00621         return a;
00622
00623     return b;
00624 }
00625
00626 // ---------------------------------------------------------------------------------------------------------------------------------
00627
00641 template<typename T>
00642 inline typename boost::call_traits<T>::param_type GetMinimum(typename boost::call_traits<T>::param_type a,
00643     typename boost::call_traits<T>::param_type b)
00644 {
00645     if (a < b)
00646         return a;
00647
00648     return b;
00649 }
00650
00651 // ---------------------------------------------------------------------------------------------------------------------------------
00652
00660 template<typename T>
00661 inline T GetAbsolute(const T value)
00662 {
00663     BOOST_STATIC_ASSERT(boost::is_scalar<T>::value);
00664     return (value < 0) ? -value : value;
00665 }
00666
00667 // ---------------------------------------------------------------------------------------------------------------------------------
00668
00669 inline double GetAbsolute(const double value)
00670 {
00671     return std::fabs(value);
00672 }
00673
00674 // ---------------------------------------------------------------------------------------------------------------------------------
00675
00684 template<typename A, typename B>
00685 inline uint64_t MakeUnsigned64BitValue(A high, B low)
00686 {
00687     return (static_cast<uint64_t>(high) << 32) | static_cast<uint64_t>(low);
00688 }
00689
00690 // ---------------------------------------------------------------------------------------------------------------------------------
00691
00697 inline uint32_t GetHigh32BitValue(uint64_t value)
00698 {
00699     return static_cast<uint32_t>(value >> 32);
00700 }
00701
00702 // ---------------------------------------------------------------------------------------------------------------------------------
00703
00709 inline uint32_t GetLow32BitValue(uint64_t value)
00710 {
00711     return static_cast<uint32_t>(value & UINT32_MAX);
00712 }
00713
00714 // ---------------------------------------------------------------------------------------------------------------------------------
00715
00721 template <typename T>
00722 inline std::string TypeToString(const T &t)
00723 {
00724     std::ostringstream os;
00725     os << t;
00726
00727     return os.str();
00728 }
00729
00730 // ---------------------------------------------------------------------------------------------------------------------------------
00731
00732 inline std::string TypeToString(const char &c)
00733 {
00734     // otherwise c gets converted to ascii char
00735     return TypeToString(static_cast<int32_t>(c));
00736 }
00737
00738 // ---------------------------------------------------------------------------------------------------------------------------------
00739
00740 inline std::string TypeToString(const byte_t &c)
00741 {
00742     // otherwise c gets converted to ascii char
00743     return TypeToString(static_cast<uint32_t>(c));
00744 }
00745
00746 // ---------------------------------------------------------------------------------------------------------------------------------
00747
00748 inline std::string TypeToString(const std::string &str)
00749 {
00750     // simple case
00751     return str;
00752 }
00753
00754 // ---------------------------------------------------------------------------------------------------------------------------------
00755
00764 template <typename T>
00765 inline bool StringToType(const std::string &str, T &t)
00766 {
00767     std::istringstream istream(str);
00768
00769     return (istream >> t) ? true : false;
00770 }
00771
00772 // ---------------------------------------------------------------------------------------------------------------------------------
00773
00774 inline bool StringToType(const std::string &str, std::string &target)
00775 {
00776     // simple case
00777     target = str;
00778
00779     return true;
00780 }
00781
00782 // ---------------------------------------------------------------------------------------------------------------------------------
00783
00790 template <typename T>
00791 inline void SwapValues(T &lhs, T &rhs)
00792 {
00793     T temp(lhs);
00794
00795     lhs = rhs;
00796     rhs = temp;
00797 }
00798
00799 // ---------------------------------------------------------------------------------------------------------------------------------
00800
00812 template<typename T, uint64_t N, uint8_t B = 0>
00813 class Binary
00814 {
00815 public:
00816     BOOST_STATIC_ASSERT((N % 10) <= 1);
00817
00818     static const T value = (2 * (Binary<T, (N / 10), B + 1>::value)) + (N % 10);
00819 };
00820
00821 // ---------------------------------------------------------------------------------------------------------------------------------
00822
00823 template<typename T, uint8_t B>
00824 class Binary<T, 0, B>
00825 {
00826 public:
00827     BOOST_STATIC_ASSERT(B <= (CHAR_BIT * sizeof(T)));
00828
00829     static const T value = 0;
00830 };
00831
00832 // ---------------------------------------------------------------------------------------------------------------------------------
00833
00834 template<typename T, T RHS, bool IS_RHS_MINIMAL>
00835 class LessImpl
00836 {
00837 public:
00838     BOOST_STATIC_ASSERT(boost::is_integral<T>::value);
00839
00840     bool operator()(const T lhs) const
00841     {
00842         return (lhs < RHS);
00843     }
00844 };
00845
00846 // ---------------------------------------------------------------------------------------------------------------------------------
00847
00848 template<typename T, T RHS>
00849 class LessImpl<T, RHS, true>
00850 {
00851 public:
00852     BOOST_STATIC_ASSERT(boost::is_integral<T>::value);
00853     BOOST_STATIC_ASSERT(RHS == boost::integer_traits<T>::const_min);
00854
00855     bool operator()(const T lhs) const
00856     {
00857         // lhs can't be less than RHS as RHS is the minimal value for type T.
00858         return false;
00859     }
00860 };
00861
00862 // ---------------------------------------------------------------------------------------------------------------------------------
00863
00869 template<typename T, T RHS>
00870 class Less
00871 {
00872 public:
00873     BOOST_STATIC_ASSERT(boost::is_integral<T>::value);
00874
00875     bool operator()(const T lhs) const
00876     {
00877         return LessImpl<T, RHS, (RHS == boost::integer_traits<T>::const_min)>()(lhs);
00878     }
00879 };
00880
00881
00882 // ---------------------------------------------------------------------------------------------------------------------------------
00883
00884 template<typename T, T RHS, bool IS_RHS_MAXIMAL>
00885 class GreaterImpl
00886 {
00887 public:
00888     BOOST_STATIC_ASSERT(boost::is_integral<T>::value);
00889
00890     bool operator()(const T lhs) const
00891     {
00892         return (lhs > RHS);
00893     }
00894 };
00895
00896 // ---------------------------------------------------------------------------------------------------------------------------------
00897
00898 template<typename T, T RHS>
00899 class GreaterImpl<T, RHS, true>
00900 {
00901 public:
00902     BOOST_STATIC_ASSERT(boost::is_integral<T>::value);
00903     BOOST_STATIC_ASSERT(RHS == boost::integer_traits<T>::const_max);
00904
00905     bool operator()(const T lhs) const
00906     {
00907         // lhs can't be more than RHS as RHS is the maximal value for type T.
00908         return false;
00909     }
00910 };
00911
00912 // ---------------------------------------------------------------------------------------------------------------------------------
00913
00919 template<typename T, T RHS>
00920 class Greater
00921 {
00922 public:
00923     BOOST_STATIC_ASSERT(boost::is_integral<T>::value);
00924
00925     bool operator()(const T lhs) const
00926     {
00927         return GreaterImpl<T, RHS, (RHS == boost::integer_traits<T>::const_max)>()(lhs);
00928     }
00929 };
00930
00931 } // namespace Activ
00932
00933 #endif // (!defined ACTIV_BASIC_TYPES_H)
Generated on Wed Oct 8 14:01:48 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivFieldTypes

BinaryArray.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FIELD_TYPES_BINARY_ARRAY_H)
00010 #define ACTIV_FIELD_TYPES_BINARY_ARRAY_H
00011
00012 #include "ActivMiddleware/ActivFieldTypes/External.h"
00013 #include "ActivMiddleware/ActivFieldTypes/IFieldType.h"
00014
00015 #include "ActivMiddleware/Misc/MemoryHelper.h"
00016
00017 #include "ActivMiddleware/ActivBase/StatusCodeException.h"
00018
00019 namespace Activ
00020 {
00021
00022 class MessageBuilder;
00023 class MessageValidator;
00024
00025 // ---------------------------------------------------------------------------------------------------------------------------------
00026
00030 class BinaryArray : public IFieldType
00031 {
00032 public:
00033     static const FieldType FIELD_TYPE = FIELD_TYPE_BINARY_ARRAY;
00034
00035     using IFieldType::FromString;
00036     using IFieldType::Serialize;
00037     using IFieldType::SerializeBody;
00038     using IFieldType::SerializeLengthAndBody;
00039     using IFieldType::Deserialize;
00040     using IFieldType::DeserializeBody;
00041     using IFieldType::DeserializeLengthAndBody;
00042
00046     BinaryArray();
00047
00056     BinaryArray(const uint8_t * const pData, const size_t size);
00057
00063     BinaryArray(const BinaryArray &rhs);
00064
00068     virtual ~BinaryArray();
00069
00077     BinaryArray& operator=(const BinaryArray &rhs);
00078
00089     StatusCode Set(const uint8_t * const pData, const size_t size);
00090
00100     StatusCode Get(const uint8_t *&pData, size_t &size) const;
00101
00109     const uint8_t *GetData() const;
00110
00118     size_t GetSize() const;
00119
00120     virtual void Reset();
00121     virtual void Clear();
00122
00131     ACTIV_FIELD_TYPES_API StatusCode Compare(const BinaryArray &rhs, int &result) const;
00132
00133     ACTIV_FIELD_TYPES_API virtual StatusCode Compare(const void * const pRhsSerializedBody, const size_t rhsSerializedBodyLength, int &result) const;
00134     ACTIV_FIELD_TYPES_API virtual StatusCode Convert(const IFieldType * const pIFieldType);
00135     ACTIV_FIELD_TYPES_API virtual std::string ToString() const;
00136
00144     ACTIV_FIELD_TYPES_API virtual std::string ToString(const bool isHexFormat) const;
00145
00146     ACTIV_FIELD_TYPES_API virtual StatusCode FromString(MessageValidator &messageValidator);
00147     ACTIV_FIELD_TYPES_API virtual std::string GetFromStringFormat() const;
00148     ACTIV_FIELD_TYPES_API virtual StatusCode Serialize(MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength) const;
00149     ACTIV_FIELD_TYPES_API virtual StatusCode SerializeBody(void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength) const;
00150     ACTIV_FIELD_TYPES_API virtual StatusCode SerializeLengthAndBody(MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength = MAX_SERIALIZED_BODY_LENGTH_UNDEFINED) const;
00151     ACTIV_FIELD_TYPES_API virtual StatusCode Deserialize(MessageValidator &messageValidator, const size_t maxSerializedBodyLength);
00152     ACTIV_FIELD_TYPES_API virtual StatusCode DeserializeBody(const void * const pSerializedBody, const size_t serializedBodyLength);
00153     ACTIV_FIELD_TYPES_API virtual StatusCode DeserializeLengthAndBody(MessageValidator &messageValidator, const size_t maxSerializedBodyLength = MAX_SERIALIZED_BODY_LENGTH_UNDEFINED);
00154     virtual size_t GetSerializedLength() const;
00155     virtual size_t GetSerializedBodyLength() const;
00156     ACTIV_FIELD_TYPES_API virtual StatusCode IsDifferent(const void * const pRhsSerializedBody, const size_t rhsSerializedBodyLength, bool &isDifferent) const;
00157
00165     static size_t GetMaxSerializedLength(const size_t size);
00166
00174     static size_t GetMaxSerializedBodyLength(const size_t size);
00175
00188     ACTIV_FIELD_TYPES_API static StatusCode Compare(const void * const pLhsSerializedBody, const size_t lhsSerializedBodyLength, const void * const pRhsSerializedBody, const size_t rhsSerializedBodyLength, int &result);
00189
00202     ACTIV_FIELD_TYPES_API static StatusCode Serialize(MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength, const uint8_t * const pData, const size_t size);
00203
00217     ACTIV_FIELD_TYPES_API static StatusCode SerializeBody(void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength, const uint8_t * const pData, const size_t size);
00218
00231     ACTIV_FIELD_TYPES_API static StatusCode SerializeLengthAndBody(MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength, const uint8_t * const pData, const size_t size);
00232
00245     ACTIV_FIELD_TYPES_API static StatusCode Deserialize(MessageValidator &messageValidator, const size_t maxSerializedBodyLength, const uint8_t *&pData, size_t &size);
00246
00258     ACTIV_FIELD_TYPES_API static StatusCode DeserializeBody(const void * const pSerializedBody, const size_t serializedBodyLength, const uint8_t *&pData, size_t &size);
00259
00272     ACTIV_FIELD_TYPES_API static StatusCode DeserializeLengthAndBody(MessageValidator &messageValidator, const size_t maxSerializedBodyLength, const uint8_t *&pData, size_t &size);
00273
00284     ACTIV_FIELD_TYPES_API static StatusCode ValidateSerializedLengthAndBody(MessageValidator &messageValidator, size_t &serializedBodyOffset, size_t &serializedBodyLength);
00285
00293     static bool IsValidSerializedBodyLength(const size_t serializedBodyLength);
00294
00295 private:
00296     static const size_t RESERVED_BUFFER_SIZE = 32;
00297
00308     static int Compare(const void * const pLhsBuffer, const size_t lhsBufferLength, const void * const pRhsBuffer, const size_t rhsBufferLength);
00309
00310     uint8_t     m_reservedBuffer[RESERVED_BUFFER_SIZE];
00311     size_t      m_allocatedSize;
00312
00313     uint8_t *   m_pData;
00314     size_t      m_size;
00315 };
00316
00317 // ---------------------------------------------------------------------------------------------------------------------------------
00318
00319 inline BinaryArray::BinaryArray() :
00320     IFieldType(FIELD_TYPE),
00321     m_allocatedSize(0),
00322     m_pData(m_reservedBuffer)
00323 {
00324     m_isInitialized = false;
00325 }
00326
00327 // ---------------------------------------------------------------------------------------------------------------------------------
00328
00329 inline BinaryArray::BinaryArray(const uint8_t * const pData, const size_t size) :
00330     IFieldType(FIELD_TYPE),
00331     m_allocatedSize(0),
00332     m_pData(m_reservedBuffer)
00333 {
00334     ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, Set(pData, size));
00335 }
00336
00337 // ---------------------------------------------------------------------------------------------------------------------------------
00338
00339 inline BinaryArray::BinaryArray(const BinaryArray &rhs) :
00340     IFieldType(FIELD_TYPE),
00341     m_allocatedSize(0),
00342     m_pData(m_reservedBuffer)
00343 {
00344     if (rhs.IsInitialized())
00345         ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, Set(rhs.m_pData, rhs.m_size));
00346     else
00347         m_isInitialized = false;
00348 }
00349
00350 // ---------------------------------------------------------------------------------------------------------------------------------
00351
00352 inline BinaryArray::~BinaryArray()
00353 {
00354     if (0 != m_allocatedSize)
00355         std::free(m_pData);
00356 }
00357
00358 // ---------------------------------------------------------------------------------------------------------------------------------
00359
00360 inline BinaryArray& BinaryArray::operator=(const BinaryArray &rhs)
00361 {
00362     if (this != &rhs)
00363     {
00364         if (rhs.IsInitialized())
00365         {
00366             ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, Set(rhs.m_pData, rhs.m_size));
00367         }
00368         else
00369         {
00370             Reset();
00371         }
00372     }
00373
00374     return *this;
00375 }
00376
00377 // ---------------------------------------------------------------------------------------------------------------------------------
00378
00379 inline StatusCode BinaryArray::Set(const uint8_t * const pData, const size_t size)
00380 {
00381     if (0 == size)
00382         return STATUS_CODE_INVALID_PARAMETER;
00383
00384     if (size > std::max<size_t>(m_allocatedSize, size_t(RESERVED_BUFFER_SIZE)))
00385     {
00386         const size_t allocatedSize = (4 * (((std::max<size_t>(m_allocatedSize + (m_allocatedSize / 2), size) - 1) / 4) + 1));
00387         uint8_t * const pAllocated = static_cast<uint8_t *>(((0 != m_allocatedSize) ? std::realloc(m_pData, allocatedSize) : std::malloc(allocatedSize)));
00388
00389         if (0 == pAllocated)
00390             return STATUS_CODE_HEAP_EMPTY;
00391
00392         m_allocatedSize = allocatedSize;
00393         m_pData = pAllocated;
00394     }
00395
00396     MemoryCopy(m_pData, pData, size);
00397
00398     m_size = size;
00399     m_isInitialized = true;
00400
00401     return STATUS_CODE_SUCCESS;
00402 }
00403
00404 // ---------------------------------------------------------------------------------------------------------------------------------
00405
00406 inline StatusCode BinaryArray::Get(const uint8_t *&pData, size_t &size) const
00407 {
00408     if (!IsInitialized())
00409         return STATUS_CODE_NOT_INITIALIZED;
00410
00411     pData = m_pData;
00412     size = m_size;
00413
00414     return STATUS_CODE_SUCCESS;
00415 }
00416
00417 // ---------------------------------------------------------------------------------------------------------------------------------
00418
00419 inline const uint8_t *BinaryArray::GetData() const
00420 {
00421     if (!IsInitialized())
00422         ACTIV_THROW(StatusCodeException, STATUS_CODE_NOT_INITIALIZED);
00423
00424     return m_pData;
00425 }
00426
00427 // ---------------------------------------------------------------------------------------------------------------------------------
00428
00429 inline size_t BinaryArray::GetSize() const
00430 {
00431     if (!IsInitialized())
00432         ACTIV_THROW(StatusCodeException, STATUS_CODE_NOT_INITIALIZED);
00433
00434     return m_size;
00435 }
00436
00437 // ---------------------------------------------------------------------------------------------------------------------------------
00438
00439 inline void BinaryArray::Reset()
00440 {
00441     m_isInitialized = false;
00442 }
00443
00444 // ---------------------------------------------------------------------------------------------------------------------------------
00445
00446 inline void BinaryArray::Clear()
00447 {
00448     if (0 != m_allocatedSize)
00449     {
00450         std::free(m_pData);
00451         m_allocatedSize = 0;
00452     }
00453
00454     m_pData = m_reservedBuffer;
00455     m_isInitialized = false;
00456 }
00457
00458 // ---------------------------------------------------------------------------------------------------------------------------------
00459
00460 inline size_t BinaryArray::GetSerializedLength() const
00461 {
00462     return (IsInitialized() ? GetMaxSerializedLength(m_size) : 0);
00463 }
00464
00465 // ---------------------------------------------------------------------------------------------------------------------------------
00466
00467 inline size_t BinaryArray::GetSerializedBodyLength() const
00468 {
00469     return (IsInitialized() ? GetMaxSerializedBodyLength(m_size) : 0);
00470 }
00471
00472 // ---------------------------------------------------------------------------------------------------------------------------------
00473
00474 inline size_t BinaryArray::GetMaxSerializedLength(const size_t size)
00475 {
00476     return GetMaxSerializedBodyLength(size);
00477 }
00478
00479 // ---------------------------------------------------------------------------------------------------------------------------------
00480
00481 inline size_t BinaryArray::GetMaxSerializedBodyLength(const size_t size)
00482 {
00483     return size;
00484 }
00485
00486 // ---------------------------------------------------------------------------------------------------------------------------------
00487
00488 inline bool BinaryArray::IsValidSerializedBodyLength(const size_t serializedBodyLength)
00489 {
00490     return (0 != serializedBodyLength);
00491 }
00492
00493 // ---------------------------------------------------------------------------------------------------------------------------------
00494 // ---------------------------------------------------------------------------------------------------------------------------------
00495
00499 template<>
00500 class FieldTypeToClass<FIELD_TYPE_BINARY_ARRAY>
00501 {
00502 public:
00503     typedef BinaryArray Type;
00504 };
00505
00506 } // namespace Activ
00507
00508 #endif // (!defined ACTIV_FIELD_TYPES_BINARY_ARRAY_H)
Generated on Wed Oct 8 14:01:48 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivFieldTypes

BinaryString.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FIELD_TYPES_BINARY_STRING_H)
00010 #define ACTIV_FIELD_TYPES_BINARY_STRING_H
00011
00012 #include "ActivMiddleware/ActivFieldTypes/External.h"
00013 #include "ActivMiddleware/ActivFieldTypes/IFieldType.h"
00014
00015 #include "ActivMiddleware/Misc/MemoryHelper.h"
00016
00017 #include "ActivMiddleware/ActivBase/StatusCodeException.h"
00018
00019 namespace Activ
00020 {
00021
00022 class MessageBuilder;
00023 class MessageValidator;
00024
00025 // ---------------------------------------------------------------------------------------------------------------------------------
00026
00030 class BinaryString : public IFieldType
00031 {
00032 public:
00033     static const FieldType FIELD_TYPE = FIELD_TYPE_BINARY_STRING;
00034
00035     using IFieldType::FromString;
00036     using IFieldType::Serialize;
00037     using IFieldType::SerializeBody;
00038     using IFieldType::SerializeLengthAndBody;
00039     using IFieldType::Deserialize;
00040     using IFieldType::DeserializeBody;
00041     using IFieldType::DeserializeLengthAndBody;
00042
00046     BinaryString();
00047
00056     BinaryString(const uint8_t * const pData, const size_t size);
00057
00063     BinaryString(const BinaryString &rhs);
00064
00068     virtual ~BinaryString();
00069
00077     BinaryString& operator=(const BinaryString &rhs);
00078
00089     StatusCode Set(const uint8_t * const pData, const size_t size);
00090
00100     StatusCode Get(const uint8_t *&pData, size_t &size) const;
00101
00109     const uint8_t *GetData() const;
00110
00118     size_t GetSize() const;
00119
00120     virtual void Reset();
00121     virtual void Clear();
00122
00131     ACTIV_FIELD_TYPES_API StatusCode Compare(const BinaryString &rhs, int &result) const;
00132
00133     ACTIV_FIELD_TYPES_API virtual StatusCode Compare(const void * const pRhsSerializedBody, const size_t rhsSerializedBodyLength, int &result) const;
00134     ACTIV_FIELD_TYPES_API virtual StatusCode Convert(const IFieldType * const pIFieldType);
00135     ACTIV_FIELD_TYPES_API virtual std::string ToString() const;
00136
00144     ACTIV_FIELD_TYPES_API virtual std::string ToString(const bool isHexFormat) const;
00145
00146     ACTIV_FIELD_TYPES_API virtual StatusCode FromString(MessageValidator &messageValidator);
00147     ACTIV_FIELD_TYPES_API virtual std::string GetFromStringFormat() const;
00148     ACTIV_FIELD_TYPES_API virtual StatusCode Serialize(MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength) const;
00149     ACTIV_FIELD_TYPES_API virtual StatusCode SerializeBody(void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength) const;
00150     ACTIV_FIELD_TYPES_API virtual StatusCode SerializeLengthAndBody(MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength = MAX_SERIALIZED_BODY_LENGTH_UNDEFINED) const;
00151     ACTIV_FIELD_TYPES_API virtual StatusCode Deserialize(MessageValidator &messageValidator, const size_t maxSerializedBodyLength);
00152     ACTIV_FIELD_TYPES_API virtual StatusCode DeserializeBody(const void * const pSerializedBody, const size_t serializedBodyLength);
00153     ACTIV_FIELD_TYPES_API virtual StatusCode DeserializeLengthAndBody(MessageValidator &messageValidator, const size_t maxSerializedBodyLength = MAX_SERIALIZED_BODY_LENGTH_UNDEFINED);
00154     virtual size_t GetSerializedLength() const;
00155     virtual size_t GetSerializedBodyLength() const;
00156     ACTIV_FIELD_TYPES_API virtual StatusCode IsDifferent(const void * const pRhsSerializedBody, const size_t rhsSerializedBodyLength, bool &isDifferent) const;
00157
00165     static size_t GetMaxSerializedLength(const size_t size);
00166
00174     static size_t GetMaxSerializedBodyLength(const size_t size);
00175
00188     ACTIV_FIELD_TYPES_API static StatusCode Compare(const void * const pLhsSerializedBody, const size_t lhsSerializedBodyLength, const void * const pRhsSerializedBody, const size_t rhsSerializedBodyLength, int &result);
00189
00202     ACTIV_FIELD_TYPES_API static StatusCode Serialize(MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength, const uint8_t * const pData, const size_t size);
00203
00217     ACTIV_FIELD_TYPES_API static StatusCode SerializeBody(void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength, const uint8_t * const pData, const size_t size);
00218
00231     ACTIV_FIELD_TYPES_API static StatusCode SerializeLengthAndBody(MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength, const uint8_t * const pData, const size_t size);
00232
00244     ACTIV_FIELD_TYPES_API static StatusCode Deserialize(MessageValidator &messageValidator, const size_t maxSerializedBodyLength, const uint8_t *&pData, size_t &size);
00245
00257     ACTIV_FIELD_TYPES_API static StatusCode DeserializeBody(const void * const pSerializedBody, const size_t serializedBodyLength, const uint8_t *&pData, size_t &size);
00258
00270     ACTIV_FIELD_TYPES_API static StatusCode DeserializeLengthAndBody(MessageValidator &messageValidator, const size_t maxSerializedBodyLength, const uint8_t *&pData, size_t &size);
00271
00282     ACTIV_FIELD_TYPES_API static StatusCode ValidateSerializedLengthAndBody(MessageValidator &messageValidator, size_t &serializedBodyOffset, size_t &serializedBodyLength);
00283
00291     static bool IsValidSerializedBodyLength(const size_t serializedBodyLength);
00292
00293 private:
00294     static const size_t RESERVED_BUFFER_SIZE = 32;
00295
00306     static int Compare(const void * const pLhsBuffer, const size_t lhsBufferLength, const void * const pRhsBuffer, const size_t rhsBufferLength);
00307
00308     uint8_t     m_reservedBuffer[RESERVED_BUFFER_SIZE];
00309     size_t      m_allocatedSize;
00310
00311     uint8_t *   m_pData;
00312     size_t      m_size;
00313 };
00314
00315 // ---------------------------------------------------------------------------------------------------------------------------------
00316
00317 inline BinaryString::BinaryString() :
00318     IFieldType(FIELD_TYPE),
00319     m_allocatedSize(0),
00320     m_pData(m_reservedBuffer)
00321 {
00322     m_isInitialized = false;
00323 }
00324
00325 // ---------------------------------------------------------------------------------------------------------------------------------
00326
00327 inline BinaryString::BinaryString(const uint8_t * const pData, const size_t size) :
00328     IFieldType(FIELD_TYPE),
00329     m_allocatedSize(0),
00330     m_pData(m_reservedBuffer)
00331 {
00332     ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, Set(pData, size));
00333 }
00334
00335 // ---------------------------------------------------------------------------------------------------------------------------------
00336
00337 inline BinaryString::BinaryString(const BinaryString &rhs) :
00338     IFieldType(FIELD_TYPE),
00339     m_allocatedSize(0),
00340     m_pData(m_reservedBuffer)
00341 {
00342     if (rhs.IsInitialized())
00343         ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, Set(rhs.m_pData, rhs.m_size));
00344     else
00345         m_isInitialized = false;
00346 }
00347
00348 // ---------------------------------------------------------------------------------------------------------------------------------
00349
00350 inline BinaryString::~BinaryString()
00351 {
00352     if (0 != m_allocatedSize)
00353         std::free(m_pData);
00354 }
00355
00356 // ---------------------------------------------------------------------------------------------------------------------------------
00357
00358 inline BinaryString& BinaryString::operator=(const BinaryString &rhs)
00359 {
00360     if (this != &rhs)
00361     {
00362         if (rhs.IsInitialized())
00363         {
00364             ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, Set(rhs.m_pData, rhs.m_size));
00365         }
00366         else
00367         {
00368             Reset();
00369         }
00370     }
00371
00372     return *this;
00373 }
00374
00375 // ---------------------------------------------------------------------------------------------------------------------------------
00376
00377 inline StatusCode BinaryString::Set(const uint8_t * const pData, const size_t size)
00378 {
00379     if (0 == size)
00380         return STATUS_CODE_INVALID_PARAMETER;
00381
00382     if (size > std::max<size_t>(m_allocatedSize, size_t(RESERVED_BUFFER_SIZE)))
00383     {
00384         const size_t allocatedSize = (4 * (((std::max<size_t>(m_allocatedSize + (m_allocatedSize / 2), size) - 1) / 4) + 1));
00385         uint8_t * const pAllocated = static_cast<uint8_t *>(((0 != m_allocatedSize) ? std::realloc(m_pData, allocatedSize) : std::malloc(allocatedSize)));
00386
00387         if (0 == pAllocated)
00388             return STATUS_CODE_HEAP_EMPTY;
00389
00390         m_allocatedSize = allocatedSize;
00391         m_pData = pAllocated;
00392     }
00393
00394     MemoryCopy(m_pData, pData, size);
00395
00396     m_size = size;
00397     m_isInitialized = true;
00398
00399     return STATUS_CODE_SUCCESS;
00400 }
00401
00402 // ---------------------------------------------------------------------------------------------------------------------------------
00403
00404 inline StatusCode BinaryString::Get(const uint8_t *&pData, size_t &size) const
00405 {
00406     if (!IsInitialized())
00407         return STATUS_CODE_NOT_INITIALIZED;
00408
00409     pData = m_pData;
00410     size = m_size;
00411
00412     return STATUS_CODE_SUCCESS;
00413 }
00414
00415 // ---------------------------------------------------------------------------------------------------------------------------------
00416
00417 inline const uint8_t *BinaryString::GetData() const
00418 {
00419     if (!IsInitialized())
00420         ACTIV_THROW(StatusCodeException, STATUS_CODE_NOT_INITIALIZED);
00421
00422     return m_pData;
00423 }
00424
00425 // ---------------------------------------------------------------------------------------------------------------------------------
00426
00427 inline size_t BinaryString::GetSize() const
00428 {
00429     if (!IsInitialized())
00430         ACTIV_THROW(StatusCodeException, STATUS_CODE_NOT_INITIALIZED);
00431
00432     return m_size;
00433 }
00434
00435 // ---------------------------------------------------------------------------------------------------------------------------------
00436
00437 inline void BinaryString::Reset()
00438 {
00439     m_isInitialized = false;
00440 }
00441
00442 // ---------------------------------------------------------------------------------------------------------------------------------
00443
00444 inline void BinaryString::Clear()
00445 {
00446     if (0 != m_allocatedSize)
00447     {
00448         std::free(m_pData);
00449         m_allocatedSize = 0;
00450     }
00451
00452     m_pData = m_reservedBuffer;
00453     m_isInitialized = false;
00454 }
00455
00456 // ---------------------------------------------------------------------------------------------------------------------------------
00457
00458 inline size_t BinaryString::GetSerializedLength() const
00459 {
00460     return (IsInitialized() ? GetMaxSerializedLength(m_size) : 0);
00461 }
00462
00463 // ---------------------------------------------------------------------------------------------------------------------------------
00464
00465 inline size_t BinaryString::GetSerializedBodyLength() const
00466 {
00467     return (IsInitialized() ? GetMaxSerializedBodyLength(m_size) : 0);
00468 }
00469
00470 // ---------------------------------------------------------------------------------------------------------------------------------
00471
00472 inline size_t BinaryString::GetMaxSerializedLength(const size_t size)
00473 {
00474     return (sizeof(uint8_t) + GetMaxSerializedBodyLength(size));
00475 }
00476
00477 // ---------------------------------------------------------------------------------------------------------------------------------
00478
00479 inline size_t BinaryString::GetMaxSerializedBodyLength(const size_t size)
00480 {
00481     return size;
00482 }
00483
00484 // ---------------------------------------------------------------------------------------------------------------------------------
00485
00486 inline bool BinaryString::IsValidSerializedBodyLength(const size_t serializedBodyLength)
00487 {
00488     return ((serializedBodyLength > 0) && (serializedBodyLength <= UINT8_MAX));
00489 }
00490
00491 // ---------------------------------------------------------------------------------------------------------------------------------
00492 // ---------------------------------------------------------------------------------------------------------------------------------
00493
00497 template<>
00498 class FieldTypeToClass<FIELD_TYPE_BINARY_STRING>
00499 {
00500 public:
00501     typedef BinaryString Type;
00502 };
00503
00504 } // namespace Activ
00505
00506 #endif // (!defined ACTIV_FIELD_TYPES_BINARY_STRING_H)
Generated on Wed Oct 8 14:01:48 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » Misc

BitFields.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_MISC_BIT_FIELDS_H)
00010 #define ACTIV_MISC_BIT_FIELDS_H
00011
00012 #include "ActivMiddleware/Activ.h"
00013
00014 #include "boost/static_assert.hpp"
00015
00016 namespace Activ
00017 {
00018
00035 template<typename T, size_t OFFSET_VALUE, size_t LENGTH_VALUE>
00036 class BitField
00037 {
00038 public:
00039     typedef T Bitmap;
00040
00053     static Bitmap GetUnshifted(const Bitmap bitmap);
00054
00067     static Bitmap GetShifted(const Bitmap bitmap);
00068
00075     static void Set(Bitmap &bitmap, const Bitmap value);
00076
00082     static Bitmap GetMaxValue();
00083
00084     static const size_t OFFSET = OFFSET_VALUE;
00085     static const size_t LENGTH = LENGTH_VALUE;
00086     static const Bitmap MASK = ((Bitmap(1) << LENGTH) - 1) << OFFSET;
00087
00088     BOOST_STATIC_ASSERT((OFFSET + LENGTH) <= (sizeof(Bitmap) * CHAR_BIT));
00089 };
00090
00091 // ---------------------------------------------------------------------------------------------------------------------------------
00092
00093 template<typename T, size_t OFFSET_VALUE, size_t LENGTH_VALUE>
00094 inline T BitField<T, OFFSET_VALUE, LENGTH_VALUE>::GetUnshifted(const Bitmap bitmap)
00095 {
00096     return bitmap & MASK;
00097 }
00098
00099 // ---------------------------------------------------------------------------------------------------------------------------------
00100
00101 template<typename T, size_t OFFSET_VALUE, size_t LENGTH_VALUE>
00102 inline T BitField<T, OFFSET_VALUE, LENGTH_VALUE>::GetShifted(const Bitmap bitmap)
00103 {
00104     return (bitmap & MASK) >> OFFSET;
00105 }
00106
00107 // ---------------------------------------------------------------------------------------------------------------------------------
00108
00109 template<typename T, size_t OFFSET_VALUE, size_t LENGTH_VALUE>
00110 inline void BitField<T, OFFSET_VALUE, LENGTH_VALUE>::Set(Bitmap &bitmap, const Bitmap value)
00111 {
00112     assert(value <= GetMaxValue());
00113
00114     bitmap &= ~MASK;
00115     bitmap |= (value << OFFSET);
00116 }
00117
00118 // ---------------------------------------------------------------------------------------------------------------------------------
00119
00120 template<typename T, size_t OFFSET_VALUE, size_t LENGTH_VALUE>
00121 inline T BitField<T, OFFSET_VALUE, LENGTH_VALUE>::GetMaxValue()
00122 {
00123     return (Bitmap(1) << LENGTH) - 1;
00124 }
00125
00126 // ---------------------------------------------------------------------------------------------------------------------------------
00127 // ---------------------------------------------------------------------------------------------------------------------------------
00128
00135 template<typename T, size_t LENGTH_VALUE>
00136 class FirstBitField : public BitField<T, 0, LENGTH_VALUE>
00137 {
00138 };
00139
00140 // ---------------------------------------------------------------------------------------------------------------------------------
00141 // ---------------------------------------------------------------------------------------------------------------------------------
00142
00149 template<typename PREVIOUS_FIELD, size_t LENGTH_VALUE>
00150 class NextBitField : public BitField<typename PREVIOUS_FIELD::Bitmap, PREVIOUS_FIELD::OFFSET + PREVIOUS_FIELD::LENGTH, LENGTH_VALUE>
00151 {
00152 };
00153
00154 } // namespace Activ
00155
00156 #endif // (!defined ACTIV_MISC_BIT_FIELDS_H)
Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivFieldTypes

Blob.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FIELD_TYPES_BLOB_H)
00010 #define ACTIV_FIELD_TYPES_BLOB_H
00011
00012 #include "ActivMiddleware/ActivFieldTypes/External.h"
00013 #include "ActivMiddleware/ActivFieldTypes/IFieldType.h"
00014
00015 #include "ActivMiddleware/Misc/MemoryHelper.h"
00016
00017 #include "ActivMiddleware/ActivBase/ActivBase.h"
00018 #include "ActivMiddleware/ActivBase/StatusCodeException.h"
00019
00020 #include "ActivMiddleware/ActivCompress/ZlibCompressor.h"
00021
00022 namespace Activ
00023 {
00024
00025 class MessageBuilder;
00026 class MessageValidator;
00027
00028 // ---------------------------------------------------------------------------------------------------------------------------------
00029
00033 class Blob : public IFieldType
00034 {
00035 public:
00036     static const FieldType FIELD_TYPE = FIELD_TYPE_BLOB;
00037
00038     using IFieldType::FromString;
00039     using IFieldType::Serialize;
00040     using IFieldType::SerializeBody;
00041     using IFieldType::SerializeLengthAndBody;
00042     using IFieldType::Deserialize;
00043     using IFieldType::DeserializeBody;
00044     using IFieldType::DeserializeLengthAndBody;
00045
00049     Blob();
00050
00060     Blob(const uint8_t * const pData, const size_t size, const size_t sizeWhenDecompressed);
00061
00072     Blob(const uint8_t * const pData, const size_t size);
00073
00079     Blob(const Blob &rhs);
00080
00084     virtual ~Blob();
00085
00093     Blob& operator=(const Blob &rhs);
00094
00106     StatusCode Set(const uint8_t * const pData, const size_t size, const size_t sizeWhenDecompressed);
00107
00121     StatusCode Set(const uint8_t * const pData, const size_t size);
00122
00133     StatusCode Get(const uint8_t *&pData, size_t &size, size_t &sizeWhenDecompressed) const;
00134
00148     StatusCode Get(const uint8_t *&pData, size_t &size) const;
00149
00157     const uint8_t *GetData() const;
00158
00166     size_t GetSize() const;
00167
00175     size_t GetSizeWhenDecompressed() const;
00176
00184     const uint8_t *GetDataCompressed() const;
00185
00193     size_t GetSizeCompressed() const;
00194
00202     const uint8_t *GetDataDecompressed() const;
00203
00211     size_t GetSizeDecompressed() const;
00212
00213     virtual void Reset();
00214     virtual void Clear();
00215
00224     ACTIV_FIELD_TYPES_API StatusCode Compare(const Blob &rhs, int &result) const;
00225
00226     ACTIV_FIELD_TYPES_API virtual StatusCode Compare(const void * const pRhsSerializedBody, const size_t rhsSerializedBodyLength, int &result) const;
00227     ACTIV_FIELD_TYPES_API virtual StatusCode Convert(const IFieldType * const pIFieldType);
00228     ACTIV_FIELD_TYPES_API virtual std::string ToString() const;
00229
00239     ACTIV_FIELD_TYPES_API virtual std::string ToString(const bool isHexFormat) const;
00240
00241     ACTIV_FIELD_TYPES_API virtual StatusCode FromString(MessageValidator &messageValidator);
00242     ACTIV_FIELD_TYPES_API virtual std::string GetFromStringFormat() const;
00243     ACTIV_FIELD_TYPES_API virtual StatusCode Serialize(MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength) const;
00244     ACTIV_FIELD_TYPES_API virtual StatusCode SerializeBody(void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength) const;
00245     ACTIV_FIELD_TYPES_API virtual StatusCode SerializeLengthAndBody(MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength = MAX_SERIALIZED_BODY_LENGTH_UNDEFINED) const;
00246     ACTIV_FIELD_TYPES_API virtual StatusCode Deserialize(MessageValidator &messageValidator, const size_t maxSerializedBodyLength);
00247     ACTIV_FIELD_TYPES_API virtual StatusCode DeserializeBody(const void * const pSerializedBody, const size_t serializedBodyLength);
00248     ACTIV_FIELD_TYPES_API virtual StatusCode DeserializeLengthAndBody(MessageValidator &messageValidator, const size_t maxSerializedBodyLength = MAX_SERIALIZED_BODY_LENGTH_UNDEFINED);
00249     virtual size_t GetSerializedLength() const;
00250     virtual size_t GetSerializedBodyLength() const;
00251     ACTIV_FIELD_TYPES_API virtual StatusCode IsDifferent(const void * const pRhsSerializedBody, const size_t rhsSerializedBodyLength, bool &isDifferent) const;
00252
00261     StatusCode Compress() const;
00262
00274     StatusCode Compress(bool shouldSerializeCompressed, bool shouldForceSerializeCompressed = false);
00275
00284     StatusCode Decompress() const;
00285
00296     StatusCode Decompress(bool shouldSerializeDecompressed);
00297
00303     bool IsCompressed() const;
00304
00312     static size_t GetMaxSerializedLength(const size_t size);
00313
00321     static size_t GetMaxSerializedBodyLength(const size_t size);
00322
00335     ACTIV_FIELD_TYPES_API static StatusCode Compare(const void * const pLhsSerializedBody, const size_t lhsSerializedBodyLength, const void * const pRhsSerializedBody, const size_t rhsSerializedBodyLength, int &result);
00336
00350     ACTIV_FIELD_TYPES_API static StatusCode Serialize(MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength, const uint8_t * const pData, const size_t size, const size_t sizeWhenDecompressed = 0);
00351
00366     ACTIV_FIELD_TYPES_API static StatusCode SerializeBody(void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength, const uint8_t * const pData, const size_t size, const size_t sizeWhenDecompressed = 0);
00367
00381     ACTIV_FIELD_TYPES_API static StatusCode SerializeLengthAndBody(MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength, const uint8_t * const pData, const size_t size, const size_t sizeWhenDecompressed = 0);
00382
00395     ACTIV_FIELD_TYPES_API static StatusCode Deserialize(MessageValidator &messageValidator, const size_t maxSerializedBodyLength, const uint8_t *&pData, size_t &size, size_t &sizeWhenDecompressed);
00396
00410     ACTIV_FIELD_TYPES_API static StatusCode DeserializeBody(const void * const pSerializedBody, const size_t serializedBodyLength, const uint8_t *&pData, size_t &size, size_t &sizeWhenDecompressed);
00411
00424     ACTIV_FIELD_TYPES_API static StatusCode DeserializeLengthAndBody(MessageValidator &messageValidator, const size_t maxSerializedBodyLength, const uint8_t *&pData, size_t &size, size_t &sizeWhenDecompressed);
00425
00436     ACTIV_FIELD_TYPES_API static StatusCode ValidateSerializedLengthAndBody(MessageValidator &messageValidator, size_t &serializedBodyOffset, size_t &serializedBodyLength);
00437
00445     static bool IsValidSerializedBodyLength(const size_t serializedBodyLength);
00446
00459     static StatusCode Compress(const uint8_t * const pSource, const size_t sourceLength, uint8_t * const pTarget, const size_t targetSize, size_t &targetLength);
00460
00473     static StatusCode Decompress(const uint8_t * const pSource, const size_t sourceLength, uint8_t * const pTarget, const size_t targetSize, size_t &targetLength);
00474
00475 private:
00486     static int Compare(const void * const pLhsBuffer, const size_t lhsBufferLength, const void * const pRhsBuffer, const size_t rhsBufferLength);
00487
00488     mutable uint8_t *   m_pDataCompressed;
00489     mutable size_t      m_allocatedSizeCompressed;
00490     mutable size_t      m_sizeCompressed;
00491
00492     mutable uint8_t *   m_pDataDecompressed;
00493     mutable size_t      m_allocatedSizeDecompressed;
00494     mutable size_t      m_sizeDecompressed;
00495
00496     uint8_t *           m_pData;
00497     size_t              m_size;
00498     size_t              m_sizeWhenDecompressed;
00499 };
00500
00501 // ---------------------------------------------------------------------------------------------------------------------------------
00502
00503 inline Blob::Blob() :
00504     IFieldType(FIELD_TYPE),
00505     m_allocatedSizeCompressed(0),
00506     m_allocatedSizeDecompressed(0)
00507 {
00508     m_isInitialized = false;
00509 }
00510
00511 // ---------------------------------------------------------------------------------------------------------------------------------
00512
00513 inline Blob::Blob(const uint8_t * const pData, const size_t size, const size_t sizeWhenDecompressed) :
00514     IFieldType(FIELD_TYPE),
00515     m_allocatedSizeCompressed(0),
00516     m_allocatedSizeDecompressed(0)
00517 {
00518     ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, Set(pData, size, sizeWhenDecompressed));
00519 }
00520
00521 // ---------------------------------------------------------------------------------------------------------------------------------
00522
00523 inline Blob::Blob(const uint8_t * const pData, const size_t size) :
00524     IFieldType(FIELD_TYPE),
00525     m_allocatedSizeCompressed(0),
00526     m_allocatedSizeDecompressed(0)
00527 {
00528     ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, Set(pData, size));
00529 }
00530
00531 // ---------------------------------------------------------------------------------------------------------------------------------
00532
00533 inline Blob::Blob(const Blob &rhs) :
00534     IFieldType(FIELD_TYPE),
00535     m_allocatedSizeCompressed(0),
00536     m_allocatedSizeDecompressed(0)
00537 {
00538     if (rhs.IsInitialized())
00539         ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, Set(rhs.m_pData, rhs.m_size, rhs.m_sizeWhenDecompressed));
00540     else
00541         m_isInitialized = false;
00542 }
00543
00544 // ---------------------------------------------------------------------------------------------------------------------------------
00545
00546 inline Blob::~Blob()
00547 {
00548     if (0 != m_allocatedSizeCompressed)
00549         std::free(m_pDataCompressed);
00550     if (0 != m_allocatedSizeDecompressed)
00551         std::free(m_pDataDecompressed);
00552 }
00553
00554 // ---------------------------------------------------------------------------------------------------------------------------------
00555
00556 inline Blob& Blob::operator=(const Blob &rhs)
00557 {
00558     if (this != &rhs)
00559     {
00560         if (rhs.IsInitialized())
00561         {
00562             ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, Set(rhs.m_pData, rhs.m_size, rhs.m_sizeWhenDecompressed));
00563         }
00564         else
00565         {
00566             Reset();
00567         }
00568     }
00569
00570     return *this;
00571 }
00572
00573 // ---------------------------------------------------------------------------------------------------------------------------------
00574
00575 inline StatusCode Blob::Set(const uint8_t * const pData, const size_t size, const size_t sizeWhenDecompressed)
00576 {
00577     if (0 == size)
00578         return STATUS_CODE_INVALID_PARAMETER;
00579
00580     if (0 == sizeWhenDecompressed)
00581     {
00582         if (size > m_allocatedSizeDecompressed)
00583         {
00584             const size_t allocatedSize = (4 * (((std::max<size_t>(m_allocatedSizeDecompressed + (m_allocatedSizeDecompressed / 2), size) - 1) / 4) + 1));
00585             uint8_t * const pAllocated = static_cast<uint8_t *>(((0 != m_allocatedSizeDecompressed) ? std::realloc(m_pDataDecompressed, allocatedSize) : std::malloc(allocatedSize)));
00586
00587             if (0 == pAllocated)
00588                 return STATUS_CODE_HEAP_EMPTY;
00589
00590             m_allocatedSizeDecompressed = allocatedSize;
00591             m_pDataDecompressed = pAllocated;
00592         }
00593
00594         MemoryCopy(m_pDataDecompressed, pData, size);
00595         m_sizeDecompressed = size;
00596
00597         m_sizeCompressed = 0;
00598
00599         m_pData = m_pDataDecompressed;
00600         m_size = size;
00601         m_sizeWhenDecompressed = sizeWhenDecompressed;
00602
00603         m_isInitialized = true;
00604     }
00605     else
00606     {
00607         if (size > m_allocatedSizeCompressed)
00608         {
00609             const size_t allocatedSize = (4 * (((std::max<size_t>(m_allocatedSizeCompressed + (m_allocatedSizeCompressed / 2), size) - 1) / 4) + 1));
00610             uint8_t * const pAllocated = static_cast<uint8_t *>(((0 != m_allocatedSizeCompressed) ? std::realloc(m_pDataCompressed, allocatedSize) : std::malloc(allocatedSize)));
00611
00612             if (0 == pAllocated)
00613                 return STATUS_CODE_HEAP_EMPTY;
00614
00615             m_allocatedSizeCompressed = allocatedSize;
00616             m_pDataCompressed = pAllocated;
00617         }
00618
00619         MemoryCopy(m_pDataCompressed, pData, size);
00620         m_sizeCompressed = size;
00621
00622         m_sizeDecompressed = 0;
00623
00624         m_pData = m_pDataCompressed;
00625         m_size = size;
00626         m_sizeWhenDecompressed = sizeWhenDecompressed;
00627
00628         m_isInitialized = true;
00629     }
00630
00631     return STATUS_CODE_SUCCESS;
00632 }
00633
00634 // ---------------------------------------------------------------------------------------------------------------------------------
00635
00636 inline StatusCode Blob::Set(const uint8_t * const pData, const size_t size)
00637 {
00638     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, Set(pData, size, 0));
00639
00640     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, Compress(true));
00641
00642     return STATUS_CODE_SUCCESS;
00643 }
00644
00645 // ---------------------------------------------------------------------------------------------------------------------------------
00646
00647 inline StatusCode Blob::Get(const uint8_t *&pData, size_t &size, size_t &sizeWhenDecompressed) const
00648 {
00649     if (!IsInitialized())
00650         return STATUS_CODE_NOT_INITIALIZED;
00651
00652     pData = m_pData;
00653     size = m_size;
00654     sizeWhenDecompressed = m_sizeWhenDecompressed;
00655
00656     return STATUS_CODE_SUCCESS;
00657 }
00658
00659 // ---------------------------------------------------------------------------------------------------------------------------------
00660
00661 inline StatusCode Blob::Get(const uint8_t *&pData, size_t &size) const
00662 {
00663     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, Decompress());
00664
00665     pData = m_pDataDecompressed;
00666     size = m_sizeDecompressed;
00667
00668     return STATUS_CODE_SUCCESS;
00669 }
00670
00671 // ---------------------------------------------------------------------------------------------------------------------------------
00672
00673 inline const uint8_t *Blob::GetData() const
00674 {
00675     if (!IsInitialized())
00676         ACTIV_THROW(StatusCodeException, STATUS_CODE_NOT_INITIALIZED);
00677
00678     return m_pData;
00679 }
00680
00681 // ---------------------------------------------------------------------------------------------------------------------------------
00682
00683 inline size_t Blob::GetSize() const
00684 {
00685     if (!IsInitialized())
00686         ACTIV_THROW(StatusCodeException, STATUS_CODE_NOT_INITIALIZED);
00687
00688     return m_size;
00689 }
00690
00691 // ---------------------------------------------------------------------------------------------------------------------------------
00692
00693 inline size_t Blob::GetSizeWhenDecompressed() const
00694 {
00695     if (!IsInitialized())
00696         ACTIV_THROW(StatusCodeException, STATUS_CODE_NOT_INITIALIZED);
00697
00698     return m_sizeWhenDecompressed;
00699 }
00700
00701 // ---------------------------------------------------------------------------------------------------------------------------------
00702
00703 inline const uint8_t *Blob::GetDataCompressed() const
00704 {
00705     ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, Compress());
00706
00707     return m_pDataCompressed;
00708 }
00709
00710 // ---------------------------------------------------------------------------------------------------------------------------------
00711
00712 inline size_t Blob::GetSizeCompressed() const
00713 {
00714     ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, Compress());
00715
00716     return m_sizeCompressed;
00717 }
00718
00719 // ---------------------------------------------------------------------------------------------------------------------------------
00720
00721 inline const uint8_t *Blob::GetDataDecompressed() const
00722 {
00723     ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, Decompress());
00724
00725     return m_pDataDecompressed;
00726 }
00727
00728 // ---------------------------------------------------------------------------------------------------------------------------------
00729
00730 inline size_t Blob::GetSizeDecompressed() const
00731 {
00732     ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, Decompress());
00733
00734     return m_sizeDecompressed;
00735 }
00736
00737 // ---------------------------------------------------------------------------------------------------------------------------------
00738
00739 inline void Blob::Reset()
00740 {
00741     m_isInitialized = false;
00742 }
00743
00744 // ---------------------------------------------------------------------------------------------------------------------------------
00745
00746 inline void Blob::Clear()
00747 {
00748     if (0 != m_allocatedSizeCompressed)
00749     {
00750         std::free(m_pDataCompressed);
00751         m_allocatedSizeCompressed = 0;
00752     }
00753
00754     if (0 != m_allocatedSizeDecompressed)
00755     {
00756         std::free(m_pDataDecompressed);
00757         m_allocatedSizeDecompressed = 0;
00758     }
00759
00760     m_isInitialized = false;
00761 }
00762
00763 // ---------------------------------------------------------------------------------------------------------------------------------
00764
00765 inline size_t Blob::GetSerializedLength() const
00766 {
00767     return (IsInitialized() ? GetMaxSerializedLength(m_size) : 0);
00768 }
00769
00770 // ---------------------------------------------------------------------------------------------------------------------------------
00771
00772 inline size_t Blob::GetSerializedBodyLength() const
00773 {
00774     return (IsInitialized() ? GetMaxSerializedBodyLength(m_size) : 0);
00775 }
00776
00777 // ---------------------------------------------------------------------------------------------------------------------------------
00778
00779 inline StatusCode Blob::Compress() const
00780 {
00781     if (!IsInitialized())
00782         return STATUS_CODE_NOT_INITIALIZED;
00783
00784     if (0 == m_sizeCompressed)
00785     {
00786         const size_t sizeCompressed = ACTIV_COMPRESS_GET_DESTINATION_BUFFER_LENGTH(m_sizeDecompressed);
00787
00788         if (sizeCompressed > m_allocatedSizeCompressed)
00789         {
00790             const size_t allocatedSize = (4 * (((std::max<size_t>(m_allocatedSizeCompressed + (m_allocatedSizeCompressed / 2), sizeCompressed) - 1) / 4) + 1));
00791             uint8_t * const pAllocated = static_cast<uint8_t *>(((0 != m_allocatedSizeCompressed) ? std::realloc(m_pDataCompressed, allocatedSize) : std::malloc(allocatedSize)));
00792
00793             if (0 == pAllocated)
00794                 return STATUS_CODE_HEAP_EMPTY;
00795
00796             m_allocatedSizeCompressed = allocatedSize;
00797             m_pDataCompressed = pAllocated;
00798         }
00799
00800         ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, Compress(m_pDataDecompressed, m_sizeDecompressed, m_pDataCompressed, m_allocatedSizeCompressed, m_sizeCompressed));
00801     }
00802
00803     return STATUS_CODE_SUCCESS;
00804 }
00805
00806 // ---------------------------------------------------------------------------------------------------------------------------------
00807
00808 inline StatusCode Blob::Compress(bool shouldSerializeCompressed, bool shouldForceSerializeCompressed)
00809 {
00810     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, Compress());
00811
00812     if ((0 == m_sizeWhenDecompressed) && (((shouldSerializeCompressed) && (m_sizeCompressed < m_sizeDecompressed)) || (shouldForceSerializeCompressed)))
00813     {
00814         m_pData = m_pDataCompressed;
00815         m_size = m_sizeCompressed;
00816         m_sizeWhenDecompressed = m_sizeDecompressed;
00817     }
00818
00819     return STATUS_CODE_SUCCESS;
00820 }
00821
00822 // ---------------------------------------------------------------------------------------------------------------------------------
00823
00824 inline StatusCode Blob::Decompress() const
00825 {
00826     if (!IsInitialized())
00827         return STATUS_CODE_NOT_INITIALIZED;
00828
00829     if (0 == m_sizeDecompressed)
00830     {
00831         if (m_sizeWhenDecompressed > m_allocatedSizeDecompressed)
00832         {
00833             const size_t allocatedSize = (4 * (((std::max<size_t>(m_allocatedSizeDecompressed + (m_allocatedSizeDecompressed / 2), m_sizeWhenDecompressed) - 1) / 4) + 1));
00834             uint8_t * const pAllocated = static_cast<uint8_t *>(((0 != m_allocatedSizeDecompressed) ? std::realloc(m_pDataDecompressed, allocatedSize) : std::malloc(allocatedSize)));
00835
00836             if (0 == pAllocated)
00837                 return STATUS_CODE_HEAP_EMPTY;
00838
00839             m_allocatedSizeDecompressed = allocatedSize;
00840             m_pDataDecompressed = pAllocated;
00841         }
00842
00843         ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, Decompress(m_pDataCompressed, m_sizeCompressed, m_pDataDecompressed, m_allocatedSizeDecompressed, m_sizeDecompressed));
00844     }
00845
00846     return STATUS_CODE_SUCCESS;
00847 }
00848
00849 // ---------------------------------------------------------------------------------------------------------------------------------
00850
00851 inline StatusCode Blob::Decompress(bool shouldSerializeDecompressed)
00852 {
00853     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, Decompress());
00854
00855     if ((shouldSerializeDecompressed) && (0 != m_sizeWhenDecompressed))
00856     {
00857         m_pData = m_pDataDecompressed;
00858         m_size = m_sizeDecompressed;
00859         m_sizeWhenDecompressed = 0;
00860     }
00861
00862     return STATUS_CODE_SUCCESS;
00863 }
00864
00865 // ---------------------------------------------------------------------------------------------------------------------------------
00866
00867 inline bool Blob::IsCompressed() const
00868 {
00869     return (IsInitialized() ? (0 != m_sizeWhenDecompressed) : false);
00870 }
00871
00872 // ---------------------------------------------------------------------------------------------------------------------------------
00873
00874 inline size_t Blob::GetMaxSerializedLength(const size_t size)
00875 {
00876     return (sizeof(uint32_t) + GetMaxSerializedBodyLength(size));
00877 }
00878
00879 // ---------------------------------------------------------------------------------------------------------------------------------
00880
00881 inline size_t Blob::GetMaxSerializedBodyLength(const size_t size)
00882 {
00883     return (sizeof(uint32_t) + size);
00884 }
00885
00886 // ---------------------------------------------------------------------------------------------------------------------------------
00887
00888 inline bool Blob::IsValidSerializedBodyLength(const size_t serializedBodyLength)
00889 {
00890     return ((serializedBodyLength > GetMaxSerializedBodyLength(0)) && (serializedBodyLength <= UINT32_MAX));
00891 }
00892
00893 // ---------------------------------------------------------------------------------------------------------------------------------
00894
00895 inline StatusCode Blob::Compress(const uint8_t * const pSource, const size_t sourceLength, uint8_t * const pTarget, const size_t targetSize, size_t &targetLength)
00896 {
00897     return ZlibCompressor().Compress(pTarget, targetSize, pSource, sourceLength, targetLength);
00898 }
00899
00900 // ---------------------------------------------------------------------------------------------------------------------------------
00901
00902 inline StatusCode Blob::Decompress(const uint8_t * const pSource, const size_t sourceLength, uint8_t * const pTarget, const size_t targetSize, size_t &targetLength)
00903 {
00904     return ZlibCompressor().Decompress(pTarget, targetSize, pSource, sourceLength, targetLength);
00905 }
00906
00907 // ---------------------------------------------------------------------------------------------------------------------------------
00908 // ---------------------------------------------------------------------------------------------------------------------------------
00909
00913 template<>
00914 class FieldTypeToClass<FIELD_TYPE_BLOB>
00915 {
00916 public:
00917     typedef Blob Type;
00918 };
00919
00920 } // namespace Activ
00921
00922 #endif // (!defined ACTIV_FIELD_TYPES_BLOB_H)
Generated on Wed Oct 8 14:01:48 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » Config » Platforms

Bsd.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_CONFIG_PLATFORMS_BSD_H)
00010 #define ACTIV_CONFIG_PLATFORMS_BSD_H
00011
00012 #define ACTIV_PLATFORM_NAME "BSD"
00013 #define ACTIV_PLATFORM_TYPE Activ::PLATFORM_TYPE_BSD
00014
00015 #define ACTIV_POSIX_HAS_CONTEXT_API
00016 #define ACTIV_HAS_INTTYPES_H
00017
00018 #include "Posix.h"
00019
00020 #endif // (!defined ACTIV_CONFIG_PLATFORMS_BSD_H)
Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivFramework

ChildService.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FRAMEWORK_CHILD_SERVICE_H)
00010 #define ACTIV_FRAMEWORK_CHILD_SERVICE_H
00011
00012 #include "ActivMiddleware/ActivFramework/External.h"
00013 #include "ActivMiddleware/ActivFramework/Service.h"
00014
00015 namespace Activ
00016 {
00017
00023 template <typename T>
00024 class ChildService : public Service
00025 {
00026 public:
00039     ChildService(T &parentService, ManagedEndPoint &managedEndPoint, IHeap * const pHeap = 0,
00040         const std::string &portName = Port::anonymousName);
00041
00042     T   &m_parentService;
00043 };
00044
00045 // ---------------------------------------------------------------------------------------------------------------------------------
00046 // ---------------------------------------------------------------------------------------------------------------------------------
00047
00048 template <typename T>
00049 ChildService<T>::ChildService(T &parentService, ManagedEndPoint &managedEndPoint, IHeap * const pHeap, const std::string &portName) :
00050     Service(parentService.GetApplication(), managedEndPoint, portName,
00051         ServiceInstance(parentService.GetServiceInstance().m_serviceId, Service::emptyServiceAccessPointList, ""),
00052         (0 == pHeap) ? parentService.GetHeap() : pHeap),
00053     m_parentService(parentService)
00054 {
00055 }
00056
00057 } // namespace Activ
00058
00059 #endif // (!defined ACTIV_FRAMEWORK_CHILD_SERVICE_H)
Generated on Wed Oct 8 14:01:48 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedMessageHandler

CombinedQuoteMessageHeaderDefinitions.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FEED_MESSAGE_HANDLER_COMBINED_QUOTE_MESSAGE_HEADER_DEFINITIONS_H)
00010 #define ACTIV_FEED_MESSAGE_HANDLER_COMBINED_QUOTE_MESSAGE_HEADER_DEFINITIONS_H
00011
00012 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/External.h"
00013 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/ActivFeedMessageHandler.h"
00014 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/MessageHeaderDefinitions.h"
00015
00016 namespace Activ
00017 {
00018
00019 namespace ContentPlatform
00020 {
00021
00022 namespace Feed
00023 {
00024
00028 class CombinedQuoteMessageHeaderDefinitions
00029 {
00030 public:
00031     typedef uint8_t Flags;
00032
00033     static const MessageType    MESSAGE_TYPE    = MESSAGE_TYPE_COMBINED_QUOTE;
00034
00035     static const size_t     FLAGS_COMPOSITE_BID_OFFSET              = 0;
00036     static const size_t     FLAGS_COMPOSITE_BID_LENGTH              = 1;
00037     static const size_t     FLAGS_COMPOSITE_ASK_OFFSET              = (FLAGS_COMPOSITE_BID_OFFSET + FLAGS_COMPOSITE_BID_LENGTH);
00038     static const size_t     FLAGS_COMPOSITE_ASK_LENGTH              = 1;
00039     static const size_t     FLAGS_COMPOSITE_BID_APPENDAGE_OFFSET    = (FLAGS_COMPOSITE_ASK_OFFSET + FLAGS_COMPOSITE_ASK_LENGTH);
00040     static const size_t     FLAGS_COMPOSITE_BID_APPENDAGE_LENGTH    = 1;
00041     static const size_t     FLAGS_COMPOSITE_ASK_APPENDAGE_OFFSET    = (FLAGS_COMPOSITE_BID_APPENDAGE_OFFSET + FLAGS_COMPOSITE_BID_APPENDAGE_LENGTH);
00042     static const size_t     FLAGS_COMPOSITE_ASK_APPENDAGE_LENGTH    = 1;
00043
00044     static const Flags      FLAGS_COMPOSITE_BID_BIT_MASK            = static_cast<Flags>((1 << FLAGS_COMPOSITE_BID_LENGTH) - 1);
00045     static const size_t     FLAGS_COMPOSITE_BID_BIT_SHIFT           = (sizeof(Flags) * CHAR_BIT) - (FLAGS_COMPOSITE_BID_OFFSET + FLAGS_COMPOSITE_BID_LENGTH);
00046     static const Flags      FLAGS_COMPOSITE_ASK_BIT_MASK            = static_cast<Flags>((1 << FLAGS_COMPOSITE_ASK_LENGTH) - 1);
00047     static const size_t     FLAGS_COMPOSITE_ASK_BIT_SHIFT           = (sizeof(Flags) * CHAR_BIT) - (FLAGS_COMPOSITE_ASK_OFFSET + FLAGS_COMPOSITE_ASK_LENGTH);
00048     static const Flags      FLAGS_COMPOSITE_BID_APPENDAGE_BIT_MASK  = static_cast<Flags>((1 << FLAGS_COMPOSITE_BID_APPENDAGE_LENGTH) - 1);
00049     static const size_t     FLAGS_COMPOSITE_BID_APPENDAGE_BIT_SHIFT = (sizeof(Flags) * CHAR_BIT) - (FLAGS_COMPOSITE_BID_APPENDAGE_OFFSET + FLAGS_COMPOSITE_BID_APPENDAGE_LENGTH);
00050     static const Flags      FLAGS_COMPOSITE_ASK_APPENDAGE_BIT_MASK  = static_cast<Flags>((1 << FLAGS_COMPOSITE_ASK_APPENDAGE_LENGTH) - 1);
00051     static const size_t     FLAGS_COMPOSITE_ASK_APPENDAGE_BIT_SHIFT = (sizeof(Flags) * CHAR_BIT) - (FLAGS_COMPOSITE_ASK_APPENDAGE_OFFSET + FLAGS_COMPOSITE_ASK_APPENDAGE_LENGTH);
00052
00053     static const size_t     MAX_SYMBOL_LENGTH   = 32;
00054
00062     static MessageHeaderDefinitions::MessageHeader GetMessageHeader(const MessageType messageType = MESSAGE_TYPE);
00063
00071     static bool IsValidMessageType(const MessageHeaderDefinitions::MessageHeader messageHeader);
00072
00083     static Flags GetFlags(const bool isCompositeBid, const bool isCompositeAsk, const bool isCompositeBidAppendage, const bool isCompositeAskAppendage);
00084
00094     static void ExtractFlags(const Flags flags, bool &isCompositeBid, bool &isCompositeAsk, bool &isCompositeBidAppendage, bool &isCompositeAskAppendage);
00095
00103     static bool IsCompositeBid(const Flags flags);
00104
00112     static bool IsCompositeAsk(const Flags flags);
00113
00121     static bool IsCompositeBidAppendage(const Flags flags);
00122
00130     static bool IsCompositeAskAppendage(const Flags flags);
00131 };
00132
00133 // ---------------------------------------------------------------------------------------------------------------------------------
00134
00135 inline MessageHeaderDefinitions::MessageHeader CombinedQuoteMessageHeaderDefinitions::GetMessageHeader(const MessageType messageType)
00136 {
00137     return MessageHeaderDefinitions::GetMessageHeader(0, messageType);
00138 }
00139
00140 // ---------------------------------------------------------------------------------------------------------------------------------
00141
00142 inline bool CombinedQuoteMessageHeaderDefinitions::IsValidMessageType(const MessageHeaderDefinitions::MessageHeader messageHeader)
00143 {
00144     return (MessageHeaderDefinitions::IsValidMessageType(messageHeader, MESSAGE_TYPE));
00145 }
00146
00147 // ---------------------------------------------------------------------------------------------------------------------------------
00148
00149 inline CombinedQuoteMessageHeaderDefinitions::Flags CombinedQuoteMessageHeaderDefinitions::GetFlags(const bool isCompositeBid, const bool isCompositeAsk, const bool isCompositeBidAppendage, const bool isCompositeAskAppendage)
00150 {
00151     return ((isCompositeBid ? (FLAGS_COMPOSITE_BID_BIT_MASK << FLAGS_COMPOSITE_BID_BIT_SHIFT) : 0) | (isCompositeAsk ? (FLAGS_COMPOSITE_ASK_BIT_MASK << FLAGS_COMPOSITE_ASK_BIT_SHIFT) : 0) | (isCompositeBidAppendage ? (FLAGS_COMPOSITE_BID_APPENDAGE_BIT_MASK << FLAGS_COMPOSITE_BID_APPENDAGE_BIT_SHIFT) : 0) | (isCompositeAskAppendage ? (FLAGS_COMPOSITE_ASK_APPENDAGE_BIT_MASK << FLAGS_COMPOSITE_ASK_APPENDAGE_BIT_SHIFT) : 0));
00152 }
00153
00154 // ---------------------------------------------------------------------------------------------------------------------------------
00155
00156 inline void CombinedQuoteMessageHeaderDefinitions::ExtractFlags(const Flags flags, bool &isCompositeBid, bool &isCompositeAsk, bool &isCompositeBidAppendage, bool &isCompositeAskAppendage)
00157 {
00158     isCompositeBid = IsCompositeBid(flags);
00159     isCompositeAsk = IsCompositeAsk(flags);
00160     isCompositeBidAppendage = IsCompositeBidAppendage(flags);
00161     isCompositeAskAppendage = IsCompositeAskAppendage(flags);
00162 }
00163
00164 // ---------------------------------------------------------------------------------------------------------------------------------
00165
00166 inline bool CombinedQuoteMessageHeaderDefinitions::IsCompositeBid(const Flags flags)
00167 {
00168     return (((flags >> FLAGS_COMPOSITE_BID_BIT_SHIFT) & FLAGS_COMPOSITE_BID_BIT_MASK) != 0);
00169 }
00170
00171 // ---------------------------------------------------------------------------------------------------------------------------------
00172
00173 inline bool CombinedQuoteMessageHeaderDefinitions::IsCompositeAsk(const Flags flags)
00174 {
00175     return (((flags >> FLAGS_COMPOSITE_ASK_BIT_SHIFT) & FLAGS_COMPOSITE_ASK_BIT_MASK) != 0);
00176 }
00177
00178 // ---------------------------------------------------------------------------------------------------------------------------------
00179
00180 inline bool CombinedQuoteMessageHeaderDefinitions::IsCompositeBidAppendage(const Flags flags)
00181 {
00182     return (((flags >> FLAGS_COMPOSITE_BID_APPENDAGE_BIT_SHIFT) & FLAGS_COMPOSITE_BID_APPENDAGE_BIT_MASK) != 0);
00183 }
00184
00185 // ---------------------------------------------------------------------------------------------------------------------------------
00186
00187 inline bool CombinedQuoteMessageHeaderDefinitions::IsCompositeAskAppendage(const Flags flags)
00188 {
00189     return (((flags >> FLAGS_COMPOSITE_ASK_APPENDAGE_BIT_SHIFT) & FLAGS_COMPOSITE_ASK_APPENDAGE_BIT_MASK) != 0);
00190 }
00191
00192 } // namespace Feed
00193
00194 } // namespace ContentPlatform
00195
00196 } // namespace Activ
00197
00198 #endif // (!defined ACTIV_FEED_MESSAGE_HANDLER_COMBINED_QUOTE_MESSAGE_HEADER_DEFINITIONS_H)
Generated on Wed Oct 8 14:01:45 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

CommandLineParser.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_BASE_COMMAND_LINE_PARSER_H)
00010 #define ACTIV_BASE_COMMAND_LINE_PARSER_H
00011
00012 #include "ActivMiddleware/ActivBase/Detail/CommandLineParserDetail.h"
00013
00014 namespace Activ
00015 {
00016
00024 class CommandLineParser : private boost::noncopyable
00025 {
00026 public:
00030     ACTIV_BASE_EXPORTED_API CommandLineParser();
00031
00035     ACTIV_BASE_EXPORTED_API virtual ~CommandLineParser();
00036
00050     ACTIV_BASE_EXPORTED_API bool Process(const int argc, char *argv[], std::ostream &outStream = std::cout);
00051
00058     ACTIV_BASE_EXPORTED_API virtual void PrintUsage(const std::string &argv0, std::ostream &outStream) const;
00059
00068     ACTIV_BASE_EXPORTED_API bool IsDefaultValue(const std::string &name) const;
00069
00075     ACTIV_BASE_EXPORTED_API CommandLineParserDetail::DescriptionAppender &AddDescriptions();
00076
00084     template<typename T>
00085     static CommandLineParserDetail::MandatoryParameterDescription<T> Parameter(const std::string &name,
00086         const std::string &description, T &value)
00087     {
00088         return CommandLineParserDetail::MandatoryParameterDescription<T>(name, description,
00089             CommandLineParserDetail::ValueStore<T>(value));
00090     }
00091
00099     template<typename T>
00100     static CommandLineParserDetail::MandatoryParameterDescription<T> Parameter(const std::string &name,
00101         const std::string &description, boost::function<void (const T &)> notifier)
00102     {
00103         return CommandLineParserDetail::MandatoryParameterDescription<T>(name, description, notifier);
00104     }
00105
00114     template<typename T>
00115     static CommandLineParserDetail::OptionalParameterDescription<T> Parameter(const std::string &name,
00116         const std::string &description, const T &defaultValue, T &value)
00117     {
00118         return CommandLineParserDetail::OptionalParameterDescription<T>(name, description, defaultValue,
00119             CommandLineParserDetail::ValueStore<T>(value));
00120     }
00121
00130     template<typename T>
00131     static CommandLineParserDetail::OptionalParameterDescription<T> Parameter(const std::string &name,
00132         const std::string &description, const T &defaultValue, boost::function<void (const T &)> notifier)
00133     {
00134         return CommandLineParserDetail::OptionalParameterDescription<T>(name, description, defaultValue, notifier);
00135     }
00136
00144     template<typename T>
00145     static CommandLineParserDetail::MandatorySwitchDescription<T> Switch(const std::string &name,
00146         const std::string &description, T &value)
00147     {
00148         return CommandLineParserDetail::MandatorySwitchDescription<T>(name, description,
00149             CommandLineParserDetail::ValueStore<T>(value));
00150     }
00151
00159     template<typename T>
00160     static CommandLineParserDetail::MandatorySwitchDescription<T> Switch(const std::string &name,
00161         const std::string &description, boost::function<void (const T &)> notifier)
00162     {
00163         return CommandLineParserDetail::MandatorySwitchDescription<T>(name, description, notifier);
00164     }
00165
00174     template<typename T>
00175     static CommandLineParserDetail::OptionalSwitchDescription<T> Switch(const std::string &name,
00176         const std::string &description, const T &defaultValue, T &value)
00177     {
00178         return CommandLineParserDetail::OptionalSwitchDescription<T>(name, description, defaultValue,
00179             CommandLineParserDetail::ValueStore<T>(value));
00180     }
00181
00190     template<typename T>
00191     static CommandLineParserDetail::OptionalSwitchDescription<T> Switch(const std::string &name,
00192         const std::string &description, const T &defaultValue, boost::function<void (const T &)> notifier)
00193     {
00194         return CommandLineParserDetail::OptionalSwitchDescription<T>(name, description, defaultValue, notifier);
00195     }
00196
00204     ACTIV_BASE_EXPORTED_API static CommandLineParserDetail::BooleanSwitchDescription BooleanSwitch(const std::string &name,
00205         const std::string &description, bool &value);
00206
00214     ACTIV_BASE_EXPORTED_API static CommandLineParserDetail::BooleanSwitchDescription BooleanSwitch(const std::string &name,
00215         const std::string &description, boost::function<void (const bool &)> notifier);
00216
00217 private:
00218     CommandLineParserDetail::CommandLineParserImpl  m_commandLineParserImpl;
00219     CommandLineParserDetail::DescriptionAppender    m_descriptionAppender;
00220 };
00221
00222 } // namespace Activ
00223
00224 #endif // (!defined ACTIV_BASE_COMMAND_LINE_PARSER_H)
Generated on Wed Oct 8 14:01:46 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase » Detail

CommandLineParserDetail.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_BASE_DETAIL_COMMAND_LINE_PARSER_DETAIL_H)
00010 #define ACTIV_BASE_DETAIL_COMMAND_LINE_PARSER_DETAIL_H
00011
00012 #include "ActivMiddleware/ActivBase/External.h"
00013 #include "ActivMiddleware/ActivBase/StatusCodeException.h"
00014
00015 #include "boost/program_options.hpp"
00016
00017 #include <iostream>
00018
00019 namespace Activ
00020 {
00021
00022 class CommandLineParser;
00023
00024 namespace CommandLineParserDetail
00025 {
00026
00030 template<typename T>
00031 class ValueStore
00032 {
00033 public:
00039     ValueStore(T &value) :
00040         m_value(value)
00041     {
00042     }
00043
00049     void operator()(const T &value)
00050     {
00051         m_value = value;
00052     }
00053
00054 private:
00055     T &m_value;
00056 };
00057
00058 // ---------------------------------------------------------------------------------------------------------------------------------
00059 // ---------------------------------------------------------------------------------------------------------------------------------
00060
00064 template<typename T>
00065 class Description
00066 {
00067 public:
00075     Description(const std::string &name, const std::string &description, boost::function<void (const T &)> notifier) :
00076         m_name(name),
00077         m_description(description),
00078         m_notifier(notifier)
00079     {
00080     }
00081
00082     const std::string                       m_name;
00083     const std::string                       m_description;
00084     const boost::function<void (const T &)> m_notifier;
00085 };
00086
00087 // ---------------------------------------------------------------------------------------------------------------------------------
00088 // ---------------------------------------------------------------------------------------------------------------------------------
00089
00093 template<typename T>
00094 class DefaultDescription : public Description<T>
00095 {
00096 public:
00105     DefaultDescription(const std::string &name, const std::string &description, const T &defaultValue, boost::function<void (const T &)> notifier) :
00106         Description<T>(name, description, notifier),
00107         m_defaultValue(defaultValue)
00108     {
00109     }
00110
00111     const T m_defaultValue;
00112 };
00113
00114 // ---------------------------------------------------------------------------------------------------------------------------------
00115 // ---------------------------------------------------------------------------------------------------------------------------------
00116
00120 template<typename T>
00121 class MandatoryParameterDescription : public Description<T>
00122 {
00123 public:
00131     MandatoryParameterDescription(const std::string &name, const std::string &description, boost::function<void (const T &)> notifier) :
00132         Description<T>(name, description, notifier)
00133     {
00134     }
00135 };
00136
00137 // ---------------------------------------------------------------------------------------------------------------------------------
00138 // ---------------------------------------------------------------------------------------------------------------------------------
00139
00143 template<typename T>
00144 class OptionalParameterDescription : public DefaultDescription<T>
00145 {
00146 public:
00155     OptionalParameterDescription(const std::string &name, const std::string &description, const T &defaultValue, boost::function<void (const T &)> notifier) :
00156         DefaultDescription<T>(name, description, defaultValue, notifier)
00157     {
00158     }
00159 };
00160
00161 // ---------------------------------------------------------------------------------------------------------------------------------
00162 // ---------------------------------------------------------------------------------------------------------------------------------
00163
00167 template<typename T>
00168 class MandatorySwitchDescription : public Description<T>
00169 {
00170 public:
00178     MandatorySwitchDescription(const std::string &name, const std::string &description, boost::function<void (const T &)> notifier) :
00179         Description<T>(name, description, notifier)
00180     {
00181     }
00182 };
00183
00184 // ---------------------------------------------------------------------------------------------------------------------------------
00185 // ---------------------------------------------------------------------------------------------------------------------------------
00186
00190 template<typename T>
00191 class OptionalSwitchDescription : public DefaultDescription<T>
00192 {
00193 public:
00202     OptionalSwitchDescription(const std::string &name, const std::string &description, const T &defaultValue, boost::function<void (const T &)> notifier) :
00203         DefaultDescription<T>(name, description, defaultValue, notifier)
00204     {
00205     }
00206 };
00207
00208 // ---------------------------------------------------------------------------------------------------------------------------------
00209 // ---------------------------------------------------------------------------------------------------------------------------------
00210
00214 class BooleanSwitchDescription : public Description<bool>
00215 {
00216 public:
00224     BooleanSwitchDescription(const std::string &name, const std::string &description, boost::function<void (const bool &)> notifier) :
00225         Description<bool>(name, description, notifier)
00226     {
00227     }
00228 };
00229
00230 // ---------------------------------------------------------------------------------------------------------------------------------
00231
00232 class DescriptionAppender;
00233
00234 // ---------------------------------------------------------------------------------------------------------------------------------
00235 // ---------------------------------------------------------------------------------------------------------------------------------
00236
00240 class CommandLineParserImpl : private boost::noncopyable
00241 {
00242 public:
00248     CommandLineParserImpl(CommandLineParser &commandLineParser);
00249
00263     bool Process(const int argc, char *argv[], std::ostream &outStream);
00264
00271     void PrintUsage(const std::string &argv0, std::ostream &outStream) const;
00272
00281     bool IsDefaultValue(const std::string &name) const;
00282
00283 private:
00291     static std::string GetProgramName(const std::string &argv0);
00292
00298     static uint32_t GetLineLength();
00299
00300     CommandLineParser &                                     m_commandLineParser;
00301     const uint32_t                                          m_lineLength;
00302
00303     boost::program_options::options_description             m_mandatoryParameterDescriptions;
00304     boost::program_options::options_description             m_optionalParameterDescriptions;
00305     boost::program_options::positional_options_description  m_positionalDescriptions;
00306
00307     boost::program_options::options_description             m_mandatorySwitchDescriptions;
00308     boost::program_options::options_description             m_optionalSwitchDescriptions;
00309
00310     boost::program_options::variables_map                   m_variablesMap;
00311
00312     friend class DescriptionAppender;
00313 };
00314
00315 // ---------------------------------------------------------------------------------------------------------------------------------
00316 // ---------------------------------------------------------------------------------------------------------------------------------
00317
00321 class DescriptionAppender
00322 {
00323 public:
00329     DescriptionAppender(CommandLineParserImpl &commandLineParserImpl);
00330
00338     template<typename T>
00339     DescriptionAppender &operator()(const MandatoryParameterDescription<T> &parameterDescription)
00340     {
00341         if (parameterDescription.m_name.empty())
00342             ACTIV_THROW(StatusCodeException, STATUS_CODE_INVALID_FORMAT);
00343
00344         m_commandLineParserImpl.m_mandatoryParameterDescriptions.add_options()
00345             (
00346                 parameterDescription.m_name.c_str(),
00347                 boost::program_options::value<T>()->notifier(parameterDescription.m_notifier),
00348                 parameterDescription.m_description.c_str()
00349             );
00350
00351         m_commandLineParserImpl.m_positionalDescriptions.add(parameterDescription.m_name.c_str(), 1);
00352
00353         return *this;
00354     }
00355
00363     template<typename T>
00364     DescriptionAppender &operator()(const MandatoryParameterDescription<std::vector<T> > &parameterDescription)
00365     {
00366         if (parameterDescription.m_name.empty())
00367             ACTIV_THROW(StatusCodeException, STATUS_CODE_INVALID_FORMAT);
00368
00369         m_commandLineParserImpl.m_mandatoryParameterDescriptions.add_options()
00370             (
00371                 parameterDescription.m_name.c_str(),
00372                 boost::program_options::value<std::vector<T> >()->composing()->notifier(parameterDescription.m_notifier),
00373                 parameterDescription.m_description.c_str()
00374             );
00375
00376         m_commandLineParserImpl.m_positionalDescriptions.add(parameterDescription.m_name.c_str(), -1);
00377
00378         return *this;
00379     }
00380
00388     template<typename T>
00389     DescriptionAppender &operator()(const OptionalParameterDescription<T> &parameterDescription)
00390     {
00391         if (parameterDescription.m_name.empty())
00392             ACTIV_THROW(StatusCodeException, STATUS_CODE_INVALID_FORMAT);
00393
00394         // disallow short options
00395         if (std::string::npos != parameterDescription.m_name.find_first_of(','))
00396             ACTIV_THROW(StatusCodeException, STATUS_CODE_INVALID_FORMAT);
00397
00398         m_commandLineParserImpl.m_optionalParameterDescriptions.add_options()
00399             (
00400                 parameterDescription.m_name.c_str(),
00401                 boost::program_options::value<T>()->default_value(parameterDescription.m_defaultValue)->notifier(parameterDescription.m_notifier),
00402                 parameterDescription.m_description.c_str()
00403             );
00404
00405         m_commandLineParserImpl.m_positionalDescriptions.add(parameterDescription.m_name.c_str(), 1);
00406
00407         return *this;
00408     }
00409
00417     template<typename T>
00418     DescriptionAppender &operator()(const OptionalParameterDescription<std::vector<T> > &parameterDescription)
00419     {
00420         if (parameterDescription.m_name.empty())
00421             ACTIV_THROW(StatusCodeException, STATUS_CODE_INVALID_FORMAT);
00422
00423         // disallow short options
00424         if (std::string::npos != parameterDescription.m_name.find_first_of(','))
00425             ACTIV_THROW(StatusCodeException, STATUS_CODE_INVALID_FORMAT);
00426
00427         m_commandLineParserImpl.m_optionalParameterDescriptions.add_options()
00428             (
00429                 parameterDescription.m_name.c_str(),
00430                 boost::program_options::value<std::vector<T> >()->default_value(parameterDescription.m_defaultValue, "")->composing()->notifier(parameterDescription.m_notifier),
00431                 parameterDescription.m_description.c_str()
00432             );
00433
00434         m_commandLineParserImpl.m_positionalDescriptions.add(parameterDescription.m_name.c_str(), -1);
00435
00436         return *this;
00437     }
00438
00446     template<typename T>
00447     DescriptionAppender &operator()(const MandatorySwitchDescription<T> &switchDescription)
00448     {
00449         m_commandLineParserImpl.m_mandatorySwitchDescriptions.add_options()
00450             (
00451                 switchDescription.m_name.c_str(),
00452                 boost::program_options::value<T>()->notifier(switchDescription.m_notifier),
00453                 switchDescription.m_description.c_str()
00454             );
00455
00456         return *this;
00457     }
00458
00466     template<typename T>
00467     DescriptionAppender &operator()(const MandatorySwitchDescription<std::vector<T> > &switchDescription)
00468     {
00469         m_commandLineParserImpl.m_mandatorySwitchDescriptions.add_options()
00470             (
00471                 switchDescription.m_name.c_str(),
00472                 boost::program_options::value<std::vector<T> >()->composing()->notifier(switchDescription.m_notifier),
00473                 switchDescription.m_description.c_str()
00474             );
00475
00476         return *this;
00477     }
00478
00486     template<typename T>
00487     DescriptionAppender &operator()(const OptionalSwitchDescription<T> &switchDescription)
00488     {
00489         m_commandLineParserImpl.m_optionalSwitchDescriptions.add_options()
00490             (
00491                 switchDescription.m_name.c_str(),
00492                 boost::program_options::value<T>()->default_value(switchDescription.m_defaultValue)->notifier(switchDescription.m_notifier),
00493                 switchDescription.m_description.c_str()
00494             );
00495
00496         return *this;
00497     }
00498
00506     template<typename T>
00507     DescriptionAppender &operator()(const OptionalSwitchDescription<std::vector<T> > &switchDescription)
00508     {
00509         m_commandLineParserImpl.m_optionalSwitchDescriptions.add_options()
00510             (
00511                 switchDescription.m_name.c_str(),
00512                 boost::program_options::value<std::vector<T> >()->default_value(switchDescription.m_defaultValue, "")->composing()->notifier(switchDescription.m_notifier),
00513                 switchDescription.m_description.c_str()
00514             );
00515
00516         return *this;
00517     }
00518
00526     DescriptionAppender &operator()(const BooleanSwitchDescription &booleanSwitchDescription)
00527     {
00528         m_commandLineParserImpl.m_optionalSwitchDescriptions.add_options()
00529             (
00530                 booleanSwitchDescription.m_name.c_str(),
00531                 boost::program_options::bool_switch()->notifier(booleanSwitchDescription.m_notifier),
00532                 booleanSwitchDescription.m_description.c_str()
00533             );
00534
00535         return *this;
00536     }
00537
00538 private:
00539     CommandLineParserImpl & m_commandLineParserImpl;
00540 };
00541
00542 } // namespace CommandLineParserDetail
00543
00544 } // namespace Activ
00545
00546 #endif // (!defined ACTIV_BASE_DETAIL_COMMAND_LINE_PARSER_DETAIL_H)
Generated on Wed Oct 8 14:01:47 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivFramework

Component.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FRAMEWORK_COMPONENT_H)
00010 #define ACTIV_FRAMEWORK_COMPONENT_H
00011
00012 #include "ActivMiddleware/ActivFramework/External.h"
00013 #include "ActivMiddleware/ActivFramework/ServiceTypes.h"
00014 #include "ActivMiddleware/ActivFramework/TimeHelper.h"
00015
00016 namespace Activ
00017 {
00018
00019 class Application;
00020
00021 // ---------------------------------------------------------------------------------------------------------------------------------
00022
00028 class Component : public Port
00029 {
00030 public:
00044     ACTIV_FRAMEWORK_API Component(Application &application, ManagedEndPoint &managedEndPoint,
00045         const std::string &name = anonymousName, IHeap * const pHeap = 0, const std::string &componentId = defaultComponentId);
00046
00050     ACTIV_FRAMEWORK_API ~Component();
00051
00057     ACTIV_FRAMEWORK_API Application &GetApplication() const;
00058
00059     ACTIV_FRAMEWORK_API static const std::string defaultComponentId;
00060
00061 protected:
00062     ACTIV_FRAMEWORK_API virtual StatusCode OnRequest(HeapMessage &request);
00063     ACTIV_FRAMEWORK_API virtual StatusCode OnMessage(HeapMessage &message);
00064
00076     ACTIV_FRAMEWORK_API virtual StatusCode OnTimer(const Address &timerAddress, const BaseTime &time);
00077
00097     ACTIV_FRAMEWORK_API virtual StatusCode OnConnect(HeapMessage &connectMessage);
00098
00115     ACTIV_FRAMEWORK_API virtual StatusCode OnConnectFailed(HeapMessage &connectFailMessage);
00116
00144     ACTIV_FRAMEWORK_API virtual StatusCode OnAccept(HeapMessage &acceptMessage);
00145
00157     ACTIV_FRAMEWORK_API virtual StatusCode OnBreak(HeapMessage &breakMessage);
00158
00175     ACTIV_FRAMEWORK_API virtual StatusCode OnDisconnect(HeapMessage &disconnectMessage);
00176
00187     ACTIV_FRAMEWORK_API virtual StatusCode OnData(HeapMessage &heapMessage);
00188
00189 private:
00193     void ProcessOnTimerMessage(HeapMessage &message);
00194
00195     Application &m_application;
00196 };
00197
00198 } // namespace Activ
00199
00200 #endif // (!defined ACTIV_FRAMEWORK_COMPONENT_H)
Generated on Wed Oct 8 14:01:48 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedMessageHandler

CompressedCombinedQuoteMessage.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FEED_MESSAGE_HANDLER_COMPRESSED_COMBINED_QUOTE_MESSAGE_H)
00010 #define ACTIV_FEED_MESSAGE_HANDLER_COMPRESSED_COMBINED_QUOTE_MESSAGE_H
00011
00012 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/Symbol.h"
00013 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/CompressedSymbol.h"
00014 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/CompressedCombinedQuoteMessageDefinitions.h"
00015 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/CompressedCombinedQuoteMessageHeaderDefinitions.h"
00016
00017 namespace Activ
00018 {
00019
00020 namespace ContentPlatform
00021 {
00022
00023 namespace Feed
00024 {
00025
00029 class CompressedCombinedQuoteMessage
00030 {
00031 public:
00040     template <Activ::ContentPlatform::Feed::MessageType MT>
00041     StatusCode ValidateCompressedCombinedQuote(MessageValidator &messageValidator);
00042
00043 protected:
00044
00045     CompressedCombinedQuoteMessageDefinitions::CompositeState       m_compositeBidState;
00046     CompressedCombinedQuoteMessageDefinitions::CompositeState       m_compositeAskState;
00047
00048     bool                                                            m_isComposite;
00049     bool                                                            m_isCompositeBid;
00050     bool                                                            m_isCompositeAsk;
00051
00052     TableNo                                                         m_tableNumber;
00053
00054     UpdateId                                                        m_updateId;
00055     UpdateId                                                        m_compositeUpdateId;
00056
00057     PermissionId                                                    m_permissionId;
00058
00059     std::string                                                     m_symbol;
00060 };
00061
00062 // ---------------------------------------------------------------------------------------------------------------------------------
00063
00064 template <Activ::ContentPlatform::Feed::MessageType MT>
00065 StatusCode CompressedCombinedQuoteMessage::ValidateCompressedCombinedQuote(MessageValidator &messageValidator)
00066 {
00067     messageValidator.Reset();
00068
00069     MessageHeaderDefinitions::MessageHeader messageHeader;
00070     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, (messageValidator.ValidateBinaryIntegral<sizeof(messageHeader), MessageValidator::ENDIAN_LITTLE>(messageHeader)));
00071
00072     const bool isUsEquityOption = CompressedCombinedQuoteMessageHeaderDefinitions::IsUsEquityOption(messageHeader);
00073     const bool isCompressedSymbol = CompressedCombinedQuoteMessageHeaderDefinitions::IsCompressedSymbol(messageHeader);
00074
00075     if (!isUsEquityOption)
00076         ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, (messageValidator.ValidateBinaryIntegral<sizeof(m_tableNumber), MessageValidator::ENDIAN_LITTLE>(m_tableNumber)));
00077     else
00078         m_tableNumber = TABLE_NO_US_EQUITY_OPTION;
00079
00080     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, (isCompressedSymbol ? CompressedSymbol::Deserialize(m_tableNumber, messageValidator, m_symbol) : Symbol::Deserialize(messageValidator, CompressedCombinedQuoteMessageHeaderDefinitions::MAX_SYMBOL_LENGTH, m_symbol)));
00081
00082     uint8_t compressedUpdateId;
00083     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, (messageValidator.ValidateBinaryIntegral<sizeof(compressedUpdateId), MessageValidator::ENDIAN_LITTLE>(compressedUpdateId)));
00084
00085     CompressedCombinedQuoteMessageDefinitions::ExtractCompressedUpdateId(compressedUpdateId, m_updateId, m_compositeUpdateId, m_compositeBidState);
00086
00087     const void *pCompressedCompositeAskState;
00088     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, messageValidator.Get(messageValidator.GetOffset(), pCompressedCompositeAskState, sizeof(uint8_t)));
00089
00090     CompressedCombinedQuoteMessageDefinitions::ExtractCompressedCompositeAskState(*reinterpret_cast<const char *>(pCompressedCompositeAskState), m_compositeAskState);
00091
00092     m_isComposite = CompressedCombinedQuoteMessageHeaderDefinitions::IsComposite(messageHeader);
00093
00094     m_permissionId = PERMISSION_ID_UNKNOWN;
00095
00096     return STATUS_CODE_SUCCESS;
00097 }
00098
00099 // ---------------------------------------------------------------------------------------------------------------------------------
00100
00101 } // namespace Feed
00102
00103 } // namespace ContentPlatform
00104
00105 } // namespace Activ
00106
00107 #endif // (!defined ACTIV_FEED_MESSAGE_HANDLER_COMPRESSED_COMBINED_QUOTE_MESSAGE_H)
Generated on Wed Oct 8 14:01:45 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedMessageHandler

CompressedCombinedQuoteMessageDefinitions.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FEED_MESSAGE_HANDLER_COMPRESSED_COMBINED_QUOTE_MESSAGE_DEFINITIONS_H)
00010 #define ACTIV_FEED_MESSAGE_HANDLER_COMPRESSED_COMBINED_QUOTE_MESSAGE_DEFINITIONS_H
00011
00012 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/CompressedMessageDefinitions.h"
00013
00014 namespace Activ
00015 {
00016
00017 namespace ContentPlatform
00018 {
00019
00020 namespace Feed
00021 {
00022
00026 class CompressedCombinedQuoteMessageDefinitions : public CompressedMessageDefinitions
00027 {
00028 public:
00029     static const size_t     COMPRESSED_UPDATE_ID_OFFSET                 = 0;
00030     static const size_t     COMPRESSED_UPDATE_ID_LENGTH                 = 3;
00031     static const size_t     COMPRESSED_COMPOSITE_UPDATE_ID_OFFSET       = (COMPRESSED_UPDATE_ID_OFFSET + COMPRESSED_UPDATE_ID_LENGTH);
00032     static const size_t     COMPRESSED_COMPOSITE_UPDATE_ID_LENGTH       = 3;
00033     static const size_t     COMPRESSED_COMPOSITE_BID_STATE_OFFSET       = (COMPRESSED_COMPOSITE_UPDATE_ID_OFFSET + COMPRESSED_COMPOSITE_UPDATE_ID_LENGTH);
00034     static const size_t     COMPRESSED_COMPOSITE_BID_STATE_LENGTH       = 2;
00035
00036     static const uint8_t    COMPRESSED_UPDATE_ID_BIT_MASK               = (1 << COMPRESSED_UPDATE_ID_LENGTH) - 1;
00037     static const size_t     COMPRESSED_UPDATE_ID_BIT_SHIFT              = (sizeof(uint8_t) * CHAR_BIT - (COMPRESSED_UPDATE_ID_OFFSET + COMPRESSED_UPDATE_ID_LENGTH));
00038     static const uint8_t    COMPRESSED_COMPOSITE_UPDATE_ID_BIT_MASK     = (1 << COMPRESSED_COMPOSITE_UPDATE_ID_LENGTH) - 1;
00039     static const size_t     COMPRESSED_COMPOSITE_UPDATE_ID_BIT_SHIFT    = (sizeof(uint8_t) * CHAR_BIT - (COMPRESSED_COMPOSITE_UPDATE_ID_OFFSET + COMPRESSED_COMPOSITE_UPDATE_ID_LENGTH));
00040     static const uint8_t    COMPRESSED_COMPOSITE_BID_STATE_BIT_MASK     = (1 << COMPRESSED_COMPOSITE_BID_STATE_LENGTH) - 1;
00041     static const size_t     COMPRESSED_COMPOSITE_BID_STATE_BIT_SHIFT    = (sizeof(uint8_t) * CHAR_BIT - (COMPRESSED_COMPOSITE_BID_STATE_OFFSET + COMPRESSED_COMPOSITE_BID_STATE_LENGTH));
00042
00043     static const size_t     COMPRESSED_COMPOSITE_ASK_STATE_OFFSET       = 0;
00044     static const size_t     COMPRESSED_COMPOSITE_ASK_STATE_LENGTH       = 2;
00045
00046     static const uint8_t    COMPRESSED_COMPOSITE_ASK_STATE_BIT_MASK     = (1 << COMPRESSED_COMPOSITE_ASK_STATE_LENGTH) - 1;
00047     static const size_t     COMPRESSED_COMPOSITE_ASK_STATE_BIT_SHIFT    = (sizeof(uint8_t) * CHAR_BIT - (COMPRESSED_COMPOSITE_ASK_STATE_OFFSET + COMPRESSED_COMPOSITE_ASK_STATE_LENGTH));
00048
00049     typedef uint8_t CompositeState;
00050
00054     enum
00055     {
00056         COMPOSITE_STATE_NO_CHANGE,
00057         COMPOSITE_STATE_REGIONAL_IS_BEST,
00058         COMPOSITE_STATE_NO_BEST,
00059         COMPOSITE_STATE_APPENDAGE
00060     };
00061
00070     static uint8_t GetCompressedUpdateId(const UpdateId updateId, const CompositeState compositeBidState);
00071
00081     static uint8_t GetCompressedUpdateId(const UpdateId updateId, const UpdateId compositeUpdateId, const CompositeState compositeBidState);
00082
00090     static void ExtractCompressedUpdateId(const uint8_t compressedUpdateId, UpdateId &updateId, CompositeState &compositeBidState);
00091
00100     static void ExtractCompressedUpdateId(const uint8_t compressedUpdateId, UpdateId &updateId, UpdateId &compositeUpdateId, CompositeState &compositeBidState);
00101
00109     static uint8_t GetCompressedCompositeAskState(const CompositeState compositeAskState);
00110
00117     static void ExtractCompressedCompositeAskState(const uint8_t compressedCompositeAskState, CompositeState &compositeAskState);
00118 };
00119
00120 // ---------------------------------------------------------------------------------------------------------------------------------
00121
00122 inline uint8_t CompressedCombinedQuoteMessageDefinitions::GetCompressedUpdateId(const UpdateId updateId, const CompositeState compositeBidState)
00123 {
00124     return (((updateId & COMPRESSED_UPDATE_ID_BIT_MASK) << COMPRESSED_UPDATE_ID_BIT_SHIFT) | ((compositeBidState & COMPRESSED_COMPOSITE_BID_STATE_BIT_MASK) << COMPRESSED_COMPOSITE_BID_STATE_BIT_SHIFT));
00125 }
00126
00127 // ---------------------------------------------------------------------------------------------------------------------------------
00128
00129 inline uint8_t CompressedCombinedQuoteMessageDefinitions::GetCompressedUpdateId(const UpdateId updateId, const UpdateId compositeUpdateId, const CompositeState compositeBidState)
00130 {
00131     return (((updateId & COMPRESSED_UPDATE_ID_BIT_MASK) << COMPRESSED_UPDATE_ID_BIT_SHIFT) | ((compositeUpdateId & COMPRESSED_COMPOSITE_UPDATE_ID_BIT_MASK) << COMPRESSED_COMPOSITE_UPDATE_ID_BIT_SHIFT) | ((compositeBidState & COMPRESSED_COMPOSITE_BID_STATE_BIT_MASK) << COMPRESSED_COMPOSITE_BID_STATE_BIT_SHIFT));
00132 }
00133
00134 // ---------------------------------------------------------------------------------------------------------------------------------
00135
00136 inline void CompressedCombinedQuoteMessageDefinitions::ExtractCompressedUpdateId(const uint8_t compressedUpdateId, UpdateId &updateId, CompositeState &compositeBidState)
00137 {
00138     updateId = (compressedUpdateId >> COMPRESSED_UPDATE_ID_BIT_SHIFT) & COMPRESSED_UPDATE_ID_BIT_MASK;
00139     compositeBidState = (compressedUpdateId >> COMPRESSED_COMPOSITE_BID_STATE_BIT_SHIFT) & COMPRESSED_COMPOSITE_BID_STATE_BIT_MASK;
00140 }
00141
00142 // ---------------------------------------------------------------------------------------------------------------------------------
00143
00144 inline void CompressedCombinedQuoteMessageDefinitions::ExtractCompressedUpdateId(const uint8_t compressedUpdateId, UpdateId &updateId, UpdateId &compositeUpdateId, CompositeState &compositeBidState)
00145 {
00146     updateId = (compressedUpdateId >> COMPRESSED_UPDATE_ID_BIT_SHIFT) & COMPRESSED_UPDATE_ID_BIT_MASK;
00147     compositeUpdateId = (compressedUpdateId >> COMPRESSED_COMPOSITE_UPDATE_ID_BIT_SHIFT) & COMPRESSED_COMPOSITE_UPDATE_ID_BIT_MASK;
00148     compositeBidState = (compressedUpdateId >> COMPRESSED_COMPOSITE_BID_STATE_BIT_SHIFT) & COMPRESSED_COMPOSITE_BID_STATE_BIT_MASK;
00149 }
00150
00151 // ---------------------------------------------------------------------------------------------------------------------------------
00152
00153 inline uint8_t CompressedCombinedQuoteMessageDefinitions::GetCompressedCompositeAskState(const CompositeState compositeAskState)
00154 {
00155     return (((compositeAskState & COMPRESSED_COMPOSITE_ASK_STATE_BIT_MASK) << COMPRESSED_COMPOSITE_ASK_STATE_BIT_SHIFT));
00156 }
00157
00158 // ---------------------------------------------------------------------------------------------------------------------------------
00159
00160 inline void CompressedCombinedQuoteMessageDefinitions::ExtractCompressedCompositeAskState(const uint8_t compressedCompositeAskState, CompositeState &compositeAskState)
00161 {
00162     compositeAskState = (compressedCompositeAskState >> COMPRESSED_COMPOSITE_ASK_STATE_BIT_SHIFT) & COMPRESSED_COMPOSITE_ASK_STATE_BIT_MASK;
00163 }
00164
00165 } // namespace Feed
00166
00167 } // namespace ContentPlatform
00168
00169 } // namespace Activ
00170
00171 #endif // (!defined ACTIV_FEED_MESSAGE_HANDLER_COMPRESSED_COMBINED_QUOTE_MESSAGE_DEFINITIONS_H)
Generated on Wed Oct 8 14:01:45 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedMessageHandler

CompressedCombinedQuoteMessageHeaderDefinitions.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FEED_MESSAGE_HANDLER_COMPRESSED_COMBINED_QUOTE_MESSAGE_HEADER_DEFINITIONS_H)
00010 #define ACTIV_FEED_MESSAGE_HANDLER_COMPRESSED_COMBINED_QUOTE_MESSAGE_HEADER_DEFINITIONS_H
00011
00012 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/External.h"
00013 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/ActivFeedMessageHandler.h"
00014 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/MessageHeaderDefinitions.h"
00015
00016 namespace Activ
00017 {
00018
00019 namespace ContentPlatform
00020 {
00021
00022 namespace Feed
00023 {
00024
00028 class CompressedCombinedQuoteMessageHeaderDefinitions
00029 {
00030 public:
00031     static const MessageType    MESSAGE_TYPE    = MESSAGE_TYPE_COMPRESSED_COMBINED_QUOTE;
00032
00033     static const size_t     MESSAGE_HEADER_FLAGS_COMPOSITE_OFFSET               = 0;
00034     static const size_t     MESSAGE_HEADER_FLAGS_COMPOSITE_LENGTH               = 1;
00035     static const size_t     MESSAGE_HEADER_FLAGS_US_EQUITY_OPTION_OFFSET        = (MESSAGE_HEADER_FLAGS_COMPOSITE_OFFSET + MESSAGE_HEADER_FLAGS_COMPOSITE_LENGTH);
00036     static const size_t     MESSAGE_HEADER_FLAGS_US_EQUITY_OPTION_LENGTH        = 1;
00037     static const size_t     MESSAGE_HEADER_FLAGS_COMPRESSED_SYMBOL_OFFSET       = (MESSAGE_HEADER_FLAGS_US_EQUITY_OPTION_OFFSET + MESSAGE_HEADER_FLAGS_US_EQUITY_OPTION_LENGTH);
00038     static const size_t     MESSAGE_HEADER_FLAGS_COMPRESSED_SYMBOL_LENGTH       = 1;
00039
00040     static const MessageHeaderDefinitions::MessageHeader    MESSAGE_HEADER_FLAGS_COMPOSITE_BIT_MASK             = static_cast<MessageHeaderDefinitions::MessageHeader>((1 << MESSAGE_HEADER_FLAGS_COMPOSITE_LENGTH) - 1);
00041     static const size_t                                     MESSAGE_HEADER_FLAGS_COMPOSITE_BIT_SHIFT            = MessageHeaderDefinitions::FLAGS_LENGTH - (MESSAGE_HEADER_FLAGS_COMPOSITE_OFFSET + MESSAGE_HEADER_FLAGS_COMPOSITE_LENGTH);
00042     static const MessageHeaderDefinitions::MessageHeader    MESSAGE_HEADER_FLAGS_US_EQUITY_OPTION_BIT_MASK      = static_cast<MessageHeaderDefinitions::MessageHeader>((1 << MESSAGE_HEADER_FLAGS_US_EQUITY_OPTION_LENGTH) - 1);
00043     static const size_t                                     MESSAGE_HEADER_FLAGS_US_EQUITY_OPTION_BIT_SHIFT     = MessageHeaderDefinitions::FLAGS_LENGTH - (MESSAGE_HEADER_FLAGS_US_EQUITY_OPTION_OFFSET + MESSAGE_HEADER_FLAGS_US_EQUITY_OPTION_LENGTH);
00044     static const MessageHeaderDefinitions::MessageHeader    MESSAGE_HEADER_FLAGS_COMPRESSED_SYMBOL_BIT_MASK     = static_cast<MessageHeaderDefinitions::MessageHeader>((1 << MESSAGE_HEADER_FLAGS_COMPRESSED_SYMBOL_LENGTH) - 1);
00045     static const size_t                                     MESSAGE_HEADER_FLAGS_COMPRESSED_SYMBOL_BIT_SHIFT    = MessageHeaderDefinitions::FLAGS_LENGTH - (MESSAGE_HEADER_FLAGS_COMPRESSED_SYMBOL_OFFSET + MESSAGE_HEADER_FLAGS_COMPRESSED_SYMBOL_LENGTH);
00046
00047     static const size_t     MAX_SYMBOL_LENGTH   = 32;
00048
00058     static MessageHeaderDefinitions::MessageHeader GetMessageHeader(const bool isComposite, const bool isUsEquityOption, const bool isCompressedSymbol);
00059
00067     static bool IsValidMessageType(const MessageHeaderDefinitions::MessageHeader messageHeader);
00068
00076     static bool IsComposite(const MessageHeaderDefinitions::MessageHeader messageHeader);
00077
00085     static bool IsUsEquityOption(const MessageHeaderDefinitions::MessageHeader messageHeader);
00086
00094     static bool IsCompressedSymbol(const MessageHeaderDefinitions::MessageHeader messageHeader);
00095 };
00096
00097 // ---------------------------------------------------------------------------------------------------------------------------------
00098
00099 inline MessageHeaderDefinitions::MessageHeader CompressedCombinedQuoteMessageHeaderDefinitions::GetMessageHeader(const bool isComposite, const bool isUsEquityOption, const bool isCompressedSymbol)
00100 {
00101     return MessageHeaderDefinitions::GetMessageHeader((isComposite ? (MESSAGE_HEADER_FLAGS_COMPOSITE_BIT_MASK << MESSAGE_HEADER_FLAGS_COMPOSITE_BIT_SHIFT) : 0) | (isUsEquityOption ? (MESSAGE_HEADER_FLAGS_US_EQUITY_OPTION_BIT_MASK << MESSAGE_HEADER_FLAGS_US_EQUITY_OPTION_BIT_SHIFT) : 0) | (isCompressedSymbol ? (MESSAGE_HEADER_FLAGS_COMPRESSED_SYMBOL_BIT_MASK << MESSAGE_HEADER_FLAGS_COMPRESSED_SYMBOL_BIT_SHIFT) : 0), MESSAGE_TYPE);
00102 }
00103
00104 // ---------------------------------------------------------------------------------------------------------------------------------
00105
00106 inline bool CompressedCombinedQuoteMessageHeaderDefinitions::IsValidMessageType(const MessageHeaderDefinitions::MessageHeader messageHeader)
00107 {
00108     return (MESSAGE_TYPE == MessageHeaderDefinitions::GetMessageType(messageHeader));
00109 }
00110
00111 // ---------------------------------------------------------------------------------------------------------------------------------
00112
00113 inline bool CompressedCombinedQuoteMessageHeaderDefinitions::IsComposite(const MessageHeaderDefinitions::MessageHeader messageHeader)
00114 {
00115     return (((MessageHeaderDefinitions::GetFlags(messageHeader) >> MESSAGE_HEADER_FLAGS_COMPOSITE_BIT_SHIFT) & MESSAGE_HEADER_FLAGS_COMPOSITE_BIT_MASK) != 0);
00116 }
00117
00118 // ---------------------------------------------------------------------------------------------------------------------------------
00119
00120 inline bool CompressedCombinedQuoteMessageHeaderDefinitions::IsUsEquityOption(const MessageHeaderDefinitions::MessageHeader messageHeader)
00121 {
00122     return (((MessageHeaderDefinitions::GetFlags(messageHeader) >> MESSAGE_HEADER_FLAGS_US_EQUITY_OPTION_BIT_SHIFT) & MESSAGE_HEADER_FLAGS_US_EQUITY_OPTION_BIT_MASK) != 0);
00123 }
00124
00125 // ---------------------------------------------------------------------------------------------------------------------------------
00126
00127 inline bool CompressedCombinedQuoteMessageHeaderDefinitions::IsCompressedSymbol(const MessageHeaderDefinitions::MessageHeader messageHeader)
00128 {
00129     return (((MessageHeaderDefinitions::GetFlags(messageHeader) >> MESSAGE_HEADER_FLAGS_COMPRESSED_SYMBOL_BIT_SHIFT) & MESSAGE_HEADER_FLAGS_COMPRESSED_SYMBOL_BIT_MASK) != 0);
00130 }
00131
00132 } // namespace Feed
00133
00134 } // namespace ContentPlatform
00135
00136 } // namespace Activ
00137
00138 #endif // (!defined ACTIV_FEED_MESSAGE_HANDLER_COMPRESSED_COMBINED_QUOTE_MESSAGE_HEADER_DEFINITIONS_H)
Generated on Wed Oct 8 14:01:45 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedMessageHandler

CompressedCombinedQuoteMessageHeaderValidator.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FEED_MESSAGE_HANDLER_COMPRESSED_COMBINED_QUOTE_MESSAGE_HEADER_VALIDATOR_H)
00010 #define ACTIV_FEED_MESSAGE_HANDLER_COMPRESSED_COMBINED_QUOTE_MESSAGE_HEADER_VALIDATOR_H
00011
00012 #include "ActivContentPlatform/ActivFeedCommon/ActivFeed.h"
00013
00014 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/External.h"
00015
00016 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/CompressedCombinedQuoteMessage.h"
00017 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/TableTemplateList.h"
00018
00019 namespace Activ
00020 {
00021
00022 class MessageValidator;
00023
00024 namespace ContentPlatform
00025 {
00026
00027 namespace Feed
00028 {
00029
00033 class CompressedCombinedQuoteMessageHeaderValidator : public CompressedCombinedQuoteMessage
00034 {
00035 public:
00039     ACTIV_FEED_MESSAGE_HANDLER_API CompressedCombinedQuoteMessageHeaderValidator();
00040
00050     ACTIV_FEED_MESSAGE_HANDLER_API CompressedCombinedQuoteMessageHeaderValidator(const TableTemplateList &tableTemplateList, MessageValidator &messageValidator, Activ::ContentPlatform::Feed::MessageType messageType);
00051
00059     ACTIV_FEED_MESSAGE_HANDLER_API CompressedCombinedQuoteMessageHeaderValidator(const TableTemplateList &tableTemplateList);
00060
00064     ACTIV_FEED_MESSAGE_HANDLER_API ~CompressedCombinedQuoteMessageHeaderValidator();
00065
00076     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Initialize(const TableTemplateList &tableTemplateList, MessageValidator &messageValidator, Activ::ContentPlatform::Feed::MessageType messageType);
00077
00085     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Initialize(const TableTemplateList &tableTemplateList);
00086
00096     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Initialize(MessageValidator &messageValidator, Activ::ContentPlatform::Feed::MessageType messageType);
00097
00101     ACTIV_FEED_MESSAGE_HANDLER_API void Reset();
00102
00111     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode GetTableTemplate(const TableTemplate *&pTableTemplate) const;
00112
00121     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode GetTableNumber(TableNo &tableNumber) const;
00122
00132     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode GetUpdateId(UpdateId &updateId) const;
00133
00143     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode GetCompositeUpdateId(UpdateId &compositeUpdateId) const;
00144
00153     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode GetPermissionId(PermissionId &permissionId) const;
00154
00163     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode GetEventType(EventType &eventType) const;
00164
00173     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode GetSymbol(std::string &symbol) const;
00174
00183     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode GetCompositeBidState(CompressedCombinedQuoteMessageDefinitions::CompositeState &compositeBidState) const;
00184
00193     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode GetCompositeAskState(CompressedCombinedQuoteMessageDefinitions::CompositeState &compositeAskState) const;
00194
00200     ACTIV_FEED_MESSAGE_HANDLER_API bool IsInitialized() const;
00201
00207     ACTIV_FEED_MESSAGE_HANDLER_API bool IsComposite() const;
00208
00214     ACTIV_FEED_MESSAGE_HANDLER_API bool IsCompositeBid() const;
00215
00221     ACTIV_FEED_MESSAGE_HANDLER_API bool IsCompositeAsk() const;
00222
00228     ACTIV_FEED_MESSAGE_HANDLER_API std::string CompositeBidStateToString() const;
00229
00235     ACTIV_FEED_MESSAGE_HANDLER_API std::string CompositeAskStateToString() const;
00236
00242     ACTIV_FEED_MESSAGE_HANDLER_API std::string IsCompositeToString() const;
00243
00249     ACTIV_FEED_MESSAGE_HANDLER_API std::string IsCompositeBidToString() const;
00250
00256     ACTIV_FEED_MESSAGE_HANDLER_API std::string IsCompositeAskToString() const;
00257
00263     ACTIV_FEED_MESSAGE_HANDLER_API std::string TableTemplateIdToString() const;
00264
00270     ACTIV_FEED_MESSAGE_HANDLER_API std::string TableTemplateNameToString() const;
00271
00277     ACTIV_FEED_MESSAGE_HANDLER_API std::string UpdateIdToString() const;
00278
00284     ACTIV_FEED_MESSAGE_HANDLER_API std::string CompositeUpdateIdToString() const;
00285
00291     ACTIV_FEED_MESSAGE_HANDLER_API std::string PermissionIdToString() const;
00292
00298     ACTIV_FEED_MESSAGE_HANDLER_API std::string EventTypeToString() const;
00299
00305     ACTIV_FEED_MESSAGE_HANDLER_API std::string SymbolToString() const;
00306
00312     ACTIV_FEED_MESSAGE_HANDLER_API std::string DefaultRuleSetToString() const;
00313
00319     ACTIV_FEED_MESSAGE_HANDLER_API std::string ToString() const;
00320
00321 private:
00331     StatusCode GetTableTemplate(TableTemplate *&pTableTemplate) const;
00332
00333     const TableTemplateList     *m_pTableTemplateList;
00334     const TableTemplate         *m_pTableTemplate;
00335
00336     bool                        m_isInitialized;
00337 };
00338
00339 // ---------------------------------------------------------------------------------------------------------------------------------
00340
00341 inline std::string CompressedCombinedQuoteMessageHeaderValidator::CompositeBidStateToString() const
00342 {
00343     return std::string("Composite Bid State .... ") + TypeToString(m_compositeBidState);
00344 }
00345
00346 // ---------------------------------------------------------------------------------------------------------------------------------
00347
00348 inline std::string CompressedCombinedQuoteMessageHeaderValidator::CompositeAskStateToString() const
00349 {
00350     return std::string("Composite Ask State .... ") + TypeToString(m_compositeAskState);
00351 }
00352
00353 // ---------------------------------------------------------------------------------------------------------------------------------
00354
00355 inline std::string CompressedCombinedQuoteMessageHeaderValidator::IsCompositeToString() const
00356 {
00357     return std::string("Is Composite ........... ") + std::string(m_isComposite ? "true" : "false");
00358 }
00359
00360 // ---------------------------------------------------------------------------------------------------------------------------------
00361
00362 inline std::string CompressedCombinedQuoteMessageHeaderValidator::IsCompositeBidToString() const
00363 {
00364     return std::string("Is Composite Bid ....... ") + std::string(m_isCompositeBid ? "true" : "false");
00365 }
00366
00367 // ---------------------------------------------------------------------------------------------------------------------------------
00368
00369 inline std::string CompressedCombinedQuoteMessageHeaderValidator::IsCompositeAskToString() const
00370 {
00371     return std::string("Is Composite Ask ....... ") + std::string(m_isCompositeAsk ? "true" : "false");
00372 }
00373
00374 // ---------------------------------------------------------------------------------------------------------------------------------
00375
00376 inline std::string CompressedCombinedQuoteMessageHeaderValidator::TableTemplateIdToString() const
00377 {
00378     return std::string("Table Id ............... " + TypeToString(m_pTableTemplate->GetId()));
00379 }
00380
00381 // ---------------------------------------------------------------------------------------------------------------------------------
00382
00383 inline std::string CompressedCombinedQuoteMessageHeaderValidator::TableTemplateNameToString() const
00384 {
00385     return std::string("Table template ......... " + m_pTableTemplate->GetName());
00386 }
00387
00388 // ---------------------------------------------------------------------------------------------------------------------------------
00389
00390 inline std::string CompressedCombinedQuoteMessageHeaderValidator::UpdateIdToString() const
00391 {
00392     return std::string("Update Id .............. ") + TypeToString(m_updateId);
00393 }
00394
00395 // ---------------------------------------------------------------------------------------------------------------------------------
00396
00397 inline std::string CompressedCombinedQuoteMessageHeaderValidator::CompositeUpdateIdToString() const
00398 {
00399     return std::string("Composite Update Id .... ") + TypeToString(m_compositeUpdateId);
00400 }
00401
00402 // ---------------------------------------------------------------------------------------------------------------------------------
00403
00404 inline std::string CompressedCombinedQuoteMessageHeaderValidator::PermissionIdToString() const
00405 {
00406     return std::string("Permission Id .......... ") + TypeToString(m_permissionId);
00407 }
00408
00409 // ---------------------------------------------------------------------------------------------------------------------------------
00410
00411 inline std::string CompressedCombinedQuoteMessageHeaderValidator::SymbolToString() const
00412 {
00413     return std::string("Symbol ................. ") + m_symbol;
00414 }
00415
00416 // ---------------------------------------------------------------------------------------------------------------------------------
00417
00418 inline std::string CompressedCombinedQuoteMessageHeaderValidator::ToString() const
00419 {
00420     if (!m_isInitialized)
00421         return "Compressed combined quote message header not initialised\n";
00422
00423     std::string str;
00424
00425     str = std::string("\nMessage Header\n");
00426
00427     str += CompositeBidStateToString() + std::string("\n");
00428     str += CompositeAskStateToString() + std::string("\n");
00429     str += IsCompositeToString() + std::string("\n");
00430     str += IsCompositeBidToString() + std::string("\n");
00431     str += IsCompositeAskToString() + std::string("\n");
00432     str += TableTemplateIdToString() + std::string("\n");
00433     str += TableTemplateNameToString() + std::string("\n");
00434     str += UpdateIdToString() + std::string("\n");
00435
00436     if (m_isComposite)
00437         str += CompositeUpdateIdToString() + std::string("\n");
00438
00439     str += PermissionIdToString() + std::string("\n");
00440     str += SymbolToString() + std::string("\n");
00441
00442     return str;
00443 }
00444
00445 // ---------------------------------------------------------------------------------------------------------------------------------
00446
00447 } // namespace Feed
00448
00449 } // namespace ContentPlatform
00450
00451 } // namespace Activ
00452
00453 #endif // (!defined ACTIV_FEED_MESSAGE_HANDLER_COMPRESSED_COMBINED_QUOTE_MESSAGE_HEADER_VALIDATOR_H)
Generated on Wed Oct 8 14:01:45 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedMessageHandler

CompressedMessage.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FEED_MESSAGE_HANDLER_COMPRESSED_MESSAGE_H)
00010 #define ACTIV_FEED_MESSAGE_HANDLER_COMPRESSED_MESSAGE_H
00011
00012 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/Symbol.h"
00013 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/CompressedSymbol.h"
00014 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/CompressedMessageDefinitions.h"
00015 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/CompressedMessageHeaderDefinitions.h"
00016
00017 namespace Activ
00018 {
00019
00020 namespace ContentPlatform
00021 {
00022
00023 namespace Feed
00024 {
00025
00029 class CompressedMessage
00030 {
00031 public:
00040     StatusCode ValidateCompressed(MessageValidator &messageValidator);
00041
00042 protected:
00043
00044     bool                        m_isDelete;
00045     bool                        m_isComposite;
00046
00047     TableNo                     m_tableNumber;
00048
00049     UpdateId                    m_updateId;
00050     UpdateId                    m_compositeUpdateId;
00051
00052     PermissionId                m_permissionId;
00053
00054     std::string                 m_symbol;
00055 };
00056
00057 // ---------------------------------------------------------------------------------------------------------------------------------
00058
00059 inline StatusCode CompressedMessage::ValidateCompressed(MessageValidator &messageValidator)
00060 {
00061     MessageHeaderDefinitions::MessageHeader messageHeader;
00062     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, (messageValidator.ValidateBinaryIntegral<sizeof(messageHeader), MessageValidator::ENDIAN_LITTLE>(messageHeader)));
00063
00064     m_isDelete = CompressedMessageHeaderDefinitions::IsDelete(messageHeader);
00065     m_isComposite = CompressedMessageHeaderDefinitions::IsComposite(messageHeader);
00066
00067     CompressedMessageDefinitions::Header header;
00068     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, (messageValidator.ValidateBinaryIntegral<sizeof(header), MessageValidator::ENDIAN_LITTLE>(header)));
00069
00070     if (!CompressedMessageDefinitions::GetShortTableNumber(header, m_tableNumber))
00071         ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, (messageValidator.ValidateBinaryIntegral<sizeof(m_tableNumber), MessageValidator::ENDIAN_LITTLE>(m_tableNumber)));
00072
00073     if (!m_isDelete)
00074     {
00075         ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, (messageValidator.ValidateBinaryIntegral<sizeof(m_updateId), MessageValidator::ENDIAN_LITTLE>(m_updateId)));
00076
00077         if (m_isComposite)
00078             ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, (messageValidator.ValidateBinaryIntegral<sizeof(m_compositeUpdateId), MessageValidator::ENDIAN_LITTLE>(m_compositeUpdateId)));
00079     }
00080
00081     if (CompressedMessageDefinitions::IsPermissionIdDefined(header))
00082         ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, (messageValidator.ValidateBinaryIntegral<sizeof(m_permissionId), MessageValidator::ENDIAN_LITTLE>(m_permissionId)));
00083     else
00084         m_permissionId = PERMISSION_ID_UNKNOWN;
00085
00086     if (CompressedMessageDefinitions::IsCompressedSymbolDefined(header))
00087         ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, CompressedSymbol::Deserialize(m_tableNumber, messageValidator, m_symbol));
00088     else
00089         ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, Symbol::Deserialize(messageValidator, CompressedMessageHeaderDefinitions::MAX_SYMBOL_LENGTH, m_symbol));
00090
00091     return STATUS_CODE_SUCCESS;
00092 }
00093
00094 // ---------------------------------------------------------------------------------------------------------------------------------
00095
00096 } // namespace Feed
00097
00098 } // namespace ContentPlatform
00099
00100 } // namespace Activ
00101
00102 #endif // (!defined ACTIV_FEED_MESSAGE_HANDLER_COMPRESSED_MESSAGE_H)
Generated on Wed Oct 8 14:01:45 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedMessageHandler

CompressedMessageDefinitions.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FEED_MESSAGE_HANDLER_COMPRESSED_MESSAGE_DEFINITIONS_H)
00010 #define ACTIV_FEED_MESSAGE_HANDLER_COMPRESSED_MESSAGE_DEFINITIONS_H
00011
00012 #include "ActivMiddleware/ActivBase/MessageValidator.h"
00013
00014 #include "ActivContentPlatform/ActivFeedCommon/ActivFeed.h"
00015
00016 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/TableTemplate.h"
00017
00018 namespace Activ
00019 {
00020
00021 namespace ContentPlatform
00022 {
00023
00024 namespace Feed
00025 {
00026
00030 #define ACTIV_FEED_DECLARE_COMPRESSED_MESSAGE_FIELD_SPECIFICATION(id, isSizeField, twinFieldId)     CompressedMessageDefinitions::FieldSpecification(Activ::ContentPlatform::Feed::id, isSizeField, Activ::ContentPlatform::Feed::twinFieldId),
00031
00032 // ---------------------------------------------------------------------------------------------------------------------------------
00033
00037 class CompressedMessageDefinitions
00038 {
00039 public:
00040     typedef uint8_t Header;
00041
00042     static const size_t HEADER_FLAGS_SHORT_TABLE_NUMBER_DEFINED_OFFSET      = 0;
00043     static const size_t HEADER_FLAGS_SHORT_TABLE_NUMBER_DEFINED_LENGTH      = 1;
00044     static const size_t HEADER_FLAGS_PERMISSION_ID_DEFINED_OFFSET           = (HEADER_FLAGS_SHORT_TABLE_NUMBER_DEFINED_LENGTH + HEADER_FLAGS_SHORT_TABLE_NUMBER_DEFINED_OFFSET);
00045     static const size_t HEADER_FLAGS_PERMISSION_ID_DEFINED_LENGTH           = 1;
00046     static const size_t HEADER_FLAGS_COMPRESSED_SYMBOL_DEFINED_OFFSET       = (HEADER_FLAGS_PERMISSION_ID_DEFINED_OFFSET + HEADER_FLAGS_PERMISSION_ID_DEFINED_LENGTH);
00047     static const size_t HEADER_FLAGS_COMPRESSED_SYMBOL_DEFINED_LENGTH       = 1;
00048     static const size_t HEADER_FLAGS_RESERVED_OFFSET                        = (HEADER_FLAGS_COMPRESSED_SYMBOL_DEFINED_OFFSET + HEADER_FLAGS_COMPRESSED_SYMBOL_DEFINED_LENGTH);
00049     static const size_t HEADER_FLAGS_RESERVED_LENGTH                        = 1;
00050     static const size_t HEADER_FLAGS_SHORT_TABLE_NUMBER_OFFSET              = (HEADER_FLAGS_RESERVED_OFFSET + HEADER_FLAGS_RESERVED_LENGTH);
00051     static const size_t HEADER_FLAGS_SHORT_TABLE_NUMBER_LENGTH              = 4;
00052
00053     static const Header HEADER_SHORT_TABLE_NUMBER_DEFINED_BIT_MASK          = (1 << HEADER_FLAGS_SHORT_TABLE_NUMBER_DEFINED_LENGTH) - 1;
00054     static const size_t HEADER_SHORT_TABLE_NUMBER_DEFINED_BIT_SHIFT         = (sizeof(Header) * CHAR_BIT - (HEADER_FLAGS_SHORT_TABLE_NUMBER_DEFINED_OFFSET + HEADER_FLAGS_SHORT_TABLE_NUMBER_DEFINED_LENGTH));
00055     static const Header HEADER_PERMISSION_ID_DEFINED_BIT_MASK               = (1 << HEADER_FLAGS_PERMISSION_ID_DEFINED_LENGTH) - 1;
00056     static const size_t HEADER_PERMISSION_ID_DEFINED_BIT_SHIFT              = (sizeof(Header) * CHAR_BIT - (HEADER_FLAGS_PERMISSION_ID_DEFINED_OFFSET + HEADER_FLAGS_PERMISSION_ID_DEFINED_LENGTH));
00057     static const Header HEADER_COMPRESSED_SYMBOL_DEFINED_BIT_MASK           = (1 << HEADER_FLAGS_COMPRESSED_SYMBOL_DEFINED_LENGTH) - 1;
00058     static const size_t HEADER_COMPRESSED_SYMBOL_DEFINED_BIT_SHIFT          = (sizeof(Header) * CHAR_BIT - (HEADER_FLAGS_COMPRESSED_SYMBOL_DEFINED_OFFSET + HEADER_FLAGS_COMPRESSED_SYMBOL_DEFINED_LENGTH));
00059     static const Header HEADER_SHORT_TABLE_NUMBER_BIT_MASK                  = (1 << HEADER_FLAGS_SHORT_TABLE_NUMBER_LENGTH) - 1;
00060     static const size_t HEADER_SHORT_TABLE_NUMBER_BIT_SHIFT                 = (sizeof(Header) * CHAR_BIT - (HEADER_FLAGS_SHORT_TABLE_NUMBER_OFFSET + HEADER_FLAGS_SHORT_TABLE_NUMBER_LENGTH));
00061
00062     static const size_t FIELD_HEADER_LENGTH         = 2;
00063     static const byte_t FIELD_HEADER_BIT_MASK       = (1 << FIELD_HEADER_LENGTH) - 1;
00064     static const size_t FIELD_HEADERS_PER_BYTE      = sizeof(byte_t) * CHAR_BIT / FIELD_HEADER_LENGTH;
00065
00069     enum FieldState
00070     {
00071         FIELD_STATE_SAME_AS_PREVIOUS,
00072         FIELD_STATE_SAME_AS_TWIN,
00073         FIELD_STATE_UNDEFINED,
00074         FIELD_STATE_DIFFERENT
00075     };
00076
00077     typedef uint8_t CompressedNumeratorLength;
00078     static const CompressedNumeratorLength NUMERATOR_LENGTH_8_BITS  = 0;
00079     static const CompressedNumeratorLength NUMERATOR_LENGTH_16_BITS = 1;
00080     static const CompressedNumeratorLength NUMERATOR_LENGTH_32_BITS = 2;
00081     static const CompressedNumeratorLength NUMERATOR_LENGTH_64_BITS = 3;
00082
00086     class FieldSpecification
00087     {
00088     public:
00096         FieldSpecification(const FieldId fieldId, const bool isSizeField, const FieldId twinFieldId = FID_UNDEFINED);
00097
00103         size_t GetNumberOfFieldHeaders() const;
00104
00105         const FieldId   m_fieldId;
00106         const bool      m_isSizeField;
00107         const FieldId   m_twinFieldId;
00108     };
00109
00113     class FieldHeaderBuilder
00114     {
00115     public:
00119         FieldHeaderBuilder();
00120
00127         void Initialize(const size_t nFieldHeaders, const size_t startingBitOffset = 0);
00128
00136         void Append(byte_t *&pMessage);
00137
00146         void Serialize(const FieldState fieldState);
00147
00156         void Serialize(const CompressedNumeratorLength compressedNumeratorLength);
00157
00158     private:
00159         byte_t *            m_pFieldHeaders;
00160         size_t              m_nBytes;
00161         size_t              m_startingBitOffset;
00162
00163         byte_t *            m_pCurrentByte;
00164         size_t              m_currentBitOffset;
00165     };
00166
00170     class FieldHeaderValidator
00171     {
00172     public:
00176         FieldHeaderValidator();
00177
00184         void Initialize(const size_t nFieldHeaders, const size_t startingBitOffset = 0);
00185
00194         StatusCode Validate(MessageValidator &messageValidator);
00195
00204         void Deserialize(FieldState &fieldState);
00205
00214         void Deserialize(CompressedNumeratorLength &compressedNumeratorLength);
00215
00216     private:
00217         const byte_t *          m_pFieldHeaders;
00218         size_t                  m_nBytes;
00219         size_t                  m_startingBitOffset;
00220
00221         const byte_t *          m_pCurrentByte;
00222         size_t                  m_currentBitOffset;
00223     };
00224
00234     static Header GetHeader(const TableNo tableNumber, const bool isPermissionIdDefined, const bool isCompressedSymbolDefined);
00235
00244     static bool GetShortTableNumber(const Header header, TableNo &tableNumber);
00245
00253     static size_t GetNumeratorLength(const CompressedNumeratorLength compressedNumeratorLength);
00254
00262     static CompressedNumeratorLength GetCompressedNumeratorLength(const size_t numeratorLength);
00263
00271     static bool IsShortTableNumberDefined(const Header header);
00272
00280     static bool IsShortTableNumber(const TableNo tableNumber);
00281
00289     static bool IsPermissionIdDefined(const Header header);
00290
00298     static bool IsCompressedSymbolDefined(const Header header);
00299 };
00300
00301 // ---------------------------------------------------------------------------------------------------------------------------------
00302
00303 inline CompressedMessageDefinitions::Header CompressedMessageDefinitions::GetHeader(const TableNo tableNumber, const bool isPermissionIdDefined, const bool isCompressedSymbolDefined)
00304 {
00305     return (((tableNumber <= HEADER_SHORT_TABLE_NUMBER_BIT_MASK) ? ((HEADER_SHORT_TABLE_NUMBER_DEFINED_BIT_MASK << HEADER_SHORT_TABLE_NUMBER_DEFINED_BIT_SHIFT) | (tableNumber << HEADER_SHORT_TABLE_NUMBER_BIT_SHIFT)) : 0) | (isPermissionIdDefined ? (HEADER_PERMISSION_ID_DEFINED_BIT_MASK << HEADER_PERMISSION_ID_DEFINED_BIT_SHIFT) : 0) | (isCompressedSymbolDefined ? (HEADER_COMPRESSED_SYMBOL_DEFINED_BIT_MASK << HEADER_COMPRESSED_SYMBOL_DEFINED_BIT_SHIFT) : 0));
00306 }
00307
00308 // ---------------------------------------------------------------------------------------------------------------------------------
00309
00310 inline bool CompressedMessageDefinitions::GetShortTableNumber(const Header header, TableNo &tableNumber)
00311 {
00312     if (IsShortTableNumberDefined(header))
00313     {
00314         tableNumber = (header >> HEADER_SHORT_TABLE_NUMBER_BIT_SHIFT) & HEADER_SHORT_TABLE_NUMBER_BIT_MASK;
00315         return true;
00316     }
00317     else
00318         return false;
00319 }
00320
00321 // ---------------------------------------------------------------------------------------------------------------------------------
00322
00323 inline size_t CompressedMessageDefinitions::GetNumeratorLength(const CompressedNumeratorLength compressedNumeratorLength)
00324 {
00325     return (1 << compressedNumeratorLength);
00326 }
00327
00328 // ---------------------------------------------------------------------------------------------------------------------------------
00329
00330 inline CompressedMessageDefinitions::CompressedNumeratorLength CompressedMessageDefinitions::GetCompressedNumeratorLength(const size_t numeratorLength)
00331 {
00332     using namespace Activ;
00333
00334     switch (numeratorLength)
00335     {
00336         case sizeof(uint8_t):
00337             return NUMERATOR_LENGTH_8_BITS;
00338
00339         case sizeof(uint16_t):
00340             return NUMERATOR_LENGTH_16_BITS;
00341
00342         case sizeof(uint32_t):
00343             return NUMERATOR_LENGTH_32_BITS;
00344
00345         default:
00346             return NUMERATOR_LENGTH_64_BITS;
00347     }
00348 }
00349
00350 // ---------------------------------------------------------------------------------------------------------------------------------
00351
00352 inline bool CompressedMessageDefinitions::IsShortTableNumberDefined(const Header header)
00353 {
00354     return (0 != (header & (HEADER_SHORT_TABLE_NUMBER_DEFINED_BIT_MASK << HEADER_SHORT_TABLE_NUMBER_DEFINED_BIT_SHIFT)));
00355 }
00356
00357 // ---------------------------------------------------------------------------------------------------------------------------------
00358
00359 inline bool CompressedMessageDefinitions::IsShortTableNumber(const TableNo tableNumber)
00360 {
00361     return (tableNumber <= HEADER_SHORT_TABLE_NUMBER_BIT_MASK);
00362 }
00363
00364 // ---------------------------------------------------------------------------------------------------------------------------------
00365
00366 inline bool CompressedMessageDefinitions::IsPermissionIdDefined(const Header header)
00367 {
00368     return (0 != (header & (HEADER_PERMISSION_ID_DEFINED_BIT_MASK << HEADER_PERMISSION_ID_DEFINED_BIT_SHIFT)));
00369 }
00370
00371 // ---------------------------------------------------------------------------------------------------------------------------------
00372
00373 inline bool CompressedMessageDefinitions::IsCompressedSymbolDefined(const Header header)
00374 {
00375     return (0 != (header & (HEADER_COMPRESSED_SYMBOL_DEFINED_BIT_MASK << HEADER_COMPRESSED_SYMBOL_DEFINED_BIT_SHIFT)));
00376 }
00377
00378 // ---------------------------------------------------------------------------------------------------------------------------------
00379 // ---------------------------------------------------------------------------------------------------------------------------------
00380
00381 inline CompressedMessageDefinitions::FieldSpecification::FieldSpecification(const FieldId fieldId, const bool isSizeField, const FieldId twinFieldId) :
00382     m_fieldId(fieldId),
00383     m_isSizeField(isSizeField),
00384     m_twinFieldId(twinFieldId)
00385 {
00386 }
00387
00388 // ---------------------------------------------------------------------------------------------------------------------------------
00389
00390 inline size_t CompressedMessageDefinitions::FieldSpecification::GetNumberOfFieldHeaders() const
00391 {
00392     return (1 + (m_isSizeField ? 1 : 0));
00393 }
00394
00395 // ---------------------------------------------------------------------------------------------------------------------------------
00396 // ---------------------------------------------------------------------------------------------------------------------------------
00397
00398 inline CompressedMessageDefinitions::FieldHeaderBuilder::FieldHeaderBuilder() :
00399     m_pFieldHeaders(0),
00400     m_nBytes(0),
00401     m_startingBitOffset(0),
00402     m_pCurrentByte(0),
00403     m_currentBitOffset(0)
00404 {
00405 }
00406
00407 // ---------------------------------------------------------------------------------------------------------------------------------
00408
00409 inline void CompressedMessageDefinitions::FieldHeaderBuilder::Initialize(const size_t nFieldHeaders, const size_t startingBitOffset)
00410 {
00411     m_nBytes = (nFieldHeaders + (startingBitOffset / FIELD_HEADER_LENGTH) + (FIELD_HEADERS_PER_BYTE - 1)) / FIELD_HEADERS_PER_BYTE;
00412     m_startingBitOffset = startingBitOffset;
00413 }
00414
00415 // ---------------------------------------------------------------------------------------------------------------------------------
00416
00417 inline void CompressedMessageDefinitions::FieldHeaderBuilder::Append(byte_t *&pMessage)
00418 {
00419     m_pFieldHeaders = m_pCurrentByte = pMessage;
00420     m_currentBitOffset = m_startingBitOffset;
00421
00422     pMessage += m_nBytes;
00423 }
00424
00425 // ---------------------------------------------------------------------------------------------------------------------------------
00426
00427 inline void CompressedMessageDefinitions::FieldHeaderBuilder::Serialize(const FieldState fieldState)
00428 {
00429     using namespace Activ;
00430
00431     *m_pCurrentByte = (0 == m_currentBitOffset) ?   static_cast<byte_t>(fieldState << (CHAR_BIT - (m_currentBitOffset + FIELD_HEADER_LENGTH))) :
00432                                                     *m_pCurrentByte | static_cast<byte_t>(fieldState << (CHAR_BIT - (m_currentBitOffset + FIELD_HEADER_LENGTH)));
00433
00434     m_currentBitOffset += FIELD_HEADER_LENGTH;
00435
00436     if (CHAR_BIT == m_currentBitOffset)
00437     {
00438         ++m_pCurrentByte;
00439         m_currentBitOffset = 0;
00440     }
00441 }
00442
00443 // ---------------------------------------------------------------------------------------------------------------------------------
00444
00445 inline void CompressedMessageDefinitions::FieldHeaderBuilder::Serialize(const CompressedNumeratorLength compressedNumeratorLength)
00446 {
00447     using namespace Activ;
00448
00449     *m_pCurrentByte = (0 == m_currentBitOffset) ?   static_cast<byte_t>(compressedNumeratorLength << (CHAR_BIT - (m_currentBitOffset + FIELD_HEADER_LENGTH))) :
00450                                                     *m_pCurrentByte | static_cast<byte_t>(compressedNumeratorLength << (CHAR_BIT - (m_currentBitOffset + FIELD_HEADER_LENGTH)));
00451
00452     m_currentBitOffset += FIELD_HEADER_LENGTH;
00453
00454     if (CHAR_BIT == m_currentBitOffset)
00455     {
00456         ++m_pCurrentByte;
00457         m_currentBitOffset = 0;
00458     }
00459 }
00460
00461 // ---------------------------------------------------------------------------------------------------------------------------------
00462 // ---------------------------------------------------------------------------------------------------------------------------------
00463
00464 inline CompressedMessageDefinitions::FieldHeaderValidator::FieldHeaderValidator() :
00465     m_pFieldHeaders(0),
00466     m_nBytes(0),
00467     m_startingBitOffset(0),
00468     m_pCurrentByte(0),
00469     m_currentBitOffset(0)
00470 {
00471 }
00472
00473 // ---------------------------------------------------------------------------------------------------------------------------------
00474
00475 inline void CompressedMessageDefinitions::FieldHeaderValidator::Initialize(const size_t nFieldHeaders, const size_t startingBitOffset)
00476 {
00477     m_nBytes = (nFieldHeaders + (startingBitOffset / FIELD_HEADER_LENGTH) + (FIELD_HEADERS_PER_BYTE - 1)) / FIELD_HEADERS_PER_BYTE;
00478     m_startingBitOffset = startingBitOffset;
00479 }
00480
00481 // ---------------------------------------------------------------------------------------------------------------------------------
00482
00483 inline StatusCode CompressedMessageDefinitions::FieldHeaderValidator::Validate(MessageValidator &messageValidator)
00484 {
00485     using namespace Activ;
00486
00487     m_pFieldHeaders = m_pCurrentByte = static_cast<const byte_t *>(messageValidator.GetMessage()) + messageValidator.GetOffset();
00488     m_currentBitOffset = m_startingBitOffset;
00489
00490     return messageValidator.ValidateBytes(m_nBytes);
00491 }
00492
00493 // ---------------------------------------------------------------------------------------------------------------------------------
00494
00495 inline void CompressedMessageDefinitions::FieldHeaderValidator::Deserialize(FieldState &fieldState)
00496 {
00497     fieldState = static_cast<FieldState>((*m_pCurrentByte >> (CHAR_BIT - (m_currentBitOffset + FIELD_HEADER_LENGTH))) & FIELD_HEADER_BIT_MASK);
00498
00499     m_currentBitOffset += FIELD_HEADER_LENGTH;
00500
00501     if (CHAR_BIT == m_currentBitOffset)
00502     {
00503         ++m_pCurrentByte;
00504         m_currentBitOffset = 0;
00505     }
00506 }
00507
00508 // ---------------------------------------------------------------------------------------------------------------------------------
00509
00510 inline void CompressedMessageDefinitions::FieldHeaderValidator::Deserialize(CompressedNumeratorLength &compressedNumeratorLength)
00511 {
00512     compressedNumeratorLength = static_cast<CompressedNumeratorLength>((*m_pCurrentByte >> (CHAR_BIT - (m_currentBitOffset + FIELD_HEADER_LENGTH))) & FIELD_HEADER_BIT_MASK);
00513
00514     m_currentBitOffset += FIELD_HEADER_LENGTH;
00515
00516     if (CHAR_BIT == m_currentBitOffset)
00517     {
00518         ++m_pCurrentByte;
00519         m_currentBitOffset = 0;
00520     }
00521 }
00522
00523 // ---------------------------------------------------------------------------------------------------------------------------------
00524
00525 } // namespace Feed
00526
00527 } // namespace ContentPlatform
00528
00529 } // namespace Activ
00530
00531 #endif // (!defined ACTIV_FEED_MESSAGE_HANDLER_COMPRESSED_MESSAGE_DEFINITIONS_H)
Generated on Wed Oct 8 14:01:45 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedMessageHandler

CompressedMessageHeaderDefinitions.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FEED_MESSAGE_HANDLER_COMPRESSED_MESSAGE_HEADER_DEFINITIONS_H)
00010 #define ACTIV_FEED_MESSAGE_HANDLER_COMPRESSED_MESSAGE_HEADER_DEFINITIONS_H
00011
00012 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/External.h"
00013 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/ActivFeedMessageHandler.h"
00014 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/MessageHeaderDefinitions.h"
00015
00016 namespace Activ
00017 {
00018
00019 namespace ContentPlatform
00020 {
00021
00022 namespace Feed
00023 {
00024
00028 class CompressedMessageHeaderDefinitions
00029 {
00030 public:
00031     static const size_t         MESSAGE_HEADER_FLAGS_DELETE_OFFSET          = 0;
00032     static const size_t         MESSAGE_HEADER_FLAGS_DELETE_LENGTH          = 1;
00033     static const size_t         MESSAGE_HEADER_FLAGS_COMPOSITE_OFFSET       = (MESSAGE_HEADER_FLAGS_DELETE_OFFSET + MESSAGE_HEADER_FLAGS_DELETE_LENGTH);
00034     static const size_t         MESSAGE_HEADER_FLAGS_COMPOSITE_LENGTH       = 1;
00035
00036     static const MessageHeaderDefinitions::MessageHeader    MESSAGE_HEADER_FLAGS_DELETE_BIT_MASK        = static_cast<MessageHeaderDefinitions::MessageHeader>((1 << MESSAGE_HEADER_FLAGS_DELETE_LENGTH) - 1);
00037     static const size_t                                     MESSAGE_HEADER_FLAGS_DELETE_BIT_SHIFT       = MessageHeaderDefinitions::FLAGS_LENGTH - (MESSAGE_HEADER_FLAGS_DELETE_OFFSET + MESSAGE_HEADER_FLAGS_DELETE_LENGTH);
00038     static const MessageHeaderDefinitions::MessageHeader    MESSAGE_HEADER_FLAGS_COMPOSITE_BIT_MASK     = static_cast<MessageHeaderDefinitions::MessageHeader>((1 << MESSAGE_HEADER_FLAGS_COMPOSITE_LENGTH) - 1);
00039     static const size_t                                     MESSAGE_HEADER_FLAGS_COMPOSITE_BIT_SHIFT    = MessageHeaderDefinitions::FLAGS_LENGTH - (MESSAGE_HEADER_FLAGS_COMPOSITE_OFFSET + MESSAGE_HEADER_FLAGS_COMPOSITE_LENGTH);
00040
00041     static const size_t     MAX_SYMBOL_LENGTH   = 32;
00042
00052     static MessageHeaderDefinitions::MessageHeader GetMessageHeader(const bool isDelete, const bool isComposite, const MessageType messageType);
00053
00062     static bool IsValidMessageType(const MessageHeaderDefinitions::MessageHeader messageHeader, const MessageType messageType);
00063
00071     static bool IsDelete(const MessageHeaderDefinitions::MessageHeader messageHeader);
00072
00080     static bool IsComposite(const MessageHeaderDefinitions::MessageHeader messageHeader);
00081 };
00082
00083 // ---------------------------------------------------------------------------------------------------------------------------------
00084
00085 inline MessageHeaderDefinitions::MessageHeader CompressedMessageHeaderDefinitions::GetMessageHeader(const bool isDelete, const bool isComposite, const MessageType messageType)
00086 {
00087     return MessageHeaderDefinitions::GetMessageHeader((isDelete ? (MESSAGE_HEADER_FLAGS_DELETE_BIT_MASK << MESSAGE_HEADER_FLAGS_DELETE_BIT_SHIFT) : 0) | (isComposite ? (MESSAGE_HEADER_FLAGS_COMPOSITE_BIT_MASK << MESSAGE_HEADER_FLAGS_COMPOSITE_BIT_SHIFT) : 0), messageType);
00088 }
00089
00090 // ---------------------------------------------------------------------------------------------------------------------------------
00091
00092 inline bool CompressedMessageHeaderDefinitions::IsValidMessageType(const MessageHeaderDefinitions::MessageHeader messageHeader, const MessageType messageType)
00093 {
00094     return (messageType == MessageHeaderDefinitions::GetMessageType(messageHeader));
00095 }
00096
00097 // ---------------------------------------------------------------------------------------------------------------------------------
00098
00099 inline bool CompressedMessageHeaderDefinitions::IsDelete(const MessageHeaderDefinitions::MessageHeader messageHeader)
00100 {
00101     return (((MessageHeaderDefinitions::GetFlags(messageHeader) >> MESSAGE_HEADER_FLAGS_DELETE_BIT_SHIFT) & MESSAGE_HEADER_FLAGS_DELETE_BIT_MASK) != 0);
00102 }
00103
00104 // ---------------------------------------------------------------------------------------------------------------------------------
00105
00106 inline bool CompressedMessageHeaderDefinitions::IsComposite(const MessageHeaderDefinitions::MessageHeader messageHeader)
00107 {
00108     return (((MessageHeaderDefinitions::GetFlags(messageHeader) >> MESSAGE_HEADER_FLAGS_COMPOSITE_BIT_SHIFT) & MESSAGE_HEADER_FLAGS_COMPOSITE_BIT_MASK) != 0);
00109 }
00110
00111 } // namespace Feed
00112
00113 } // namespace ContentPlatform
00114
00115 } // namespace Activ
00116
00117 #endif // (!defined ACTIV_FEED_MESSAGE_HANDLER_COMPRESSED_MESSAGE_HEADER_DEFINITIONS_H)
Generated on Wed Oct 8 14:01:45 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedMessageHandler

CompressedMessageHeaderValidator.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FEED_MESSAGE_HANDLER_COMPRESSED_MESSAGE_HEADER_VALIDATOR_H)
00010 #define ACTIV_FEED_MESSAGE_HANDLER_COMPRESSED_MESSAGE_HEADER_VALIDATOR_H
00011
00012 #include "ActivMiddleware/ActivFieldTypes/TextString.h"
00013
00014 #include "ActivContentPlatform/ActivFeedCommon/ActivFeed.h"
00015
00016 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/External.h"
00017
00018 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/CompressedMessage.h"
00019 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/TableTemplateList.h"
00020
00021 namespace Activ
00022 {
00023
00024 class MessageValidator;
00025
00026 namespace ContentPlatform
00027 {
00028
00029 namespace Feed
00030 {
00031
00035 class CompressedMessageHeaderValidator : public CompressedMessage
00036 {
00037 public:
00041     ACTIV_FEED_MESSAGE_HANDLER_API CompressedMessageHeaderValidator();
00042
00052     ACTIV_FEED_MESSAGE_HANDLER_API CompressedMessageHeaderValidator(const TableTemplateList &tableTemplateList, MessageValidator &messageValidator, Activ::ContentPlatform::Feed::MessageType messageType);
00053
00061     ACTIV_FEED_MESSAGE_HANDLER_API CompressedMessageHeaderValidator(const TableTemplateList &tableTemplateList);
00062
00066     ACTIV_FEED_MESSAGE_HANDLER_API ~CompressedMessageHeaderValidator();
00067
00078     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Initialize(const TableTemplateList &tableTemplateList, MessageValidator &messageValidator, Activ::ContentPlatform::Feed::MessageType messageType);
00079
00087     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Initialize(const TableTemplateList &tableTemplateList);
00088
00098     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Initialize(MessageValidator &messageValidator, Activ::ContentPlatform::Feed::MessageType messageType);
00099
00103     ACTIV_FEED_MESSAGE_HANDLER_API void Reset();
00104
00113     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode GetTableTemplate(const TableTemplate *&pTableTemplate) const;
00114
00123     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode GetTableNumber(TableNo &tableNumber) const;
00124
00134     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode GetUpdateId(UpdateId &updateId) const;
00135
00145     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode GetCompositeUpdateId(UpdateId &compositeUpdateId) const;
00146
00155     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode GetPermissionId(PermissionId &permissionId) const;
00156
00165     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode GetEventType(EventType &eventType) const;
00166
00175     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode GetSymbol(std::string &symbol) const;
00176
00182     ACTIV_FEED_MESSAGE_HANDLER_API bool IsInitialized() const;
00183
00189     ACTIV_FEED_MESSAGE_HANDLER_API bool IsDelete() const;
00190
00196     ACTIV_FEED_MESSAGE_HANDLER_API bool IsComposite() const;
00197
00203     ACTIV_FEED_MESSAGE_HANDLER_API std::string IsDeleteToString() const;
00204
00210     ACTIV_FEED_MESSAGE_HANDLER_API std::string IsCompositeToString() const;
00211
00217     ACTIV_FEED_MESSAGE_HANDLER_API std::string TableTemplateIdToString() const;
00218
00224     ACTIV_FEED_MESSAGE_HANDLER_API std::string TableTemplateNameToString() const;
00225
00231     ACTIV_FEED_MESSAGE_HANDLER_API std::string UpdateIdToString() const;
00232
00238     ACTIV_FEED_MESSAGE_HANDLER_API std::string CompositeUpdateIdToString() const;
00239
00245     ACTIV_FEED_MESSAGE_HANDLER_API std::string PermissionIdToString() const;
00246
00252     ACTIV_FEED_MESSAGE_HANDLER_API std::string EventTypeToString() const;
00253
00259     ACTIV_FEED_MESSAGE_HANDLER_API std::string SymbolToString() const;
00260
00266     ACTIV_FEED_MESSAGE_HANDLER_API std::string DefaultRuleSetToString() const;
00267
00273     ACTIV_FEED_MESSAGE_HANDLER_API std::string ToString() const;
00274
00275 private:
00285     StatusCode GetTableTemplate(TableTemplate *&pTableTemplate) const;
00286
00287     const TableTemplateList     *m_pTableTemplateList;
00288     const TableTemplate         *m_pTableTemplate;
00289
00290     bool                        m_isInitialized;
00291 };
00292
00293 // ---------------------------------------------------------------------------------------------------------------------------------
00294
00295 inline std::string CompressedMessageHeaderValidator::IsDeleteToString() const
00296 {
00297     return std::string("Is Delete .............. ") + std::string(m_isDelete ? "true" : "false");
00298 }
00299
00300 // ---------------------------------------------------------------------------------------------------------------------------------
00301
00302 inline std::string CompressedMessageHeaderValidator::IsCompositeToString() const
00303 {
00304     return std::string("Is Composite ........... ") + std::string(m_isComposite ? "true" : "false");
00305 }
00306
00307 // ---------------------------------------------------------------------------------------------------------------------------------
00308
00309 inline std::string CompressedMessageHeaderValidator::TableTemplateIdToString() const
00310 {
00311     return std::string("Table Id ............... " + TypeToString(m_pTableTemplate->GetId()));
00312 }
00313
00314 // ---------------------------------------------------------------------------------------------------------------------------------
00315
00316 inline std::string CompressedMessageHeaderValidator::TableTemplateNameToString() const
00317 {
00318     return std::string("Table template ......... " + m_pTableTemplate->GetName());
00319 }
00320
00321 // ---------------------------------------------------------------------------------------------------------------------------------
00322
00323 inline std::string CompressedMessageHeaderValidator::UpdateIdToString() const
00324 {
00325     return std::string("Update Id .............. ") + TypeToString(m_updateId);
00326 }
00327
00328 // ---------------------------------------------------------------------------------------------------------------------------------
00329
00330 inline std::string CompressedMessageHeaderValidator::CompositeUpdateIdToString() const
00331 {
00332     return std::string("Composite Update Id .... ") + TypeToString(m_compositeUpdateId);
00333 }
00334
00335 // ---------------------------------------------------------------------------------------------------------------------------------
00336
00337 inline std::string CompressedMessageHeaderValidator::PermissionIdToString() const
00338 {
00339     return std::string("Permission Id .......... ") + TypeToString(m_permissionId);
00340 }
00341
00342 // ---------------------------------------------------------------------------------------------------------------------------------
00343
00344 inline std::string CompressedMessageHeaderValidator::SymbolToString() const
00345 {
00346     return std::string("Symbol ................. ") + m_symbol;
00347 }
00348
00349 // ---------------------------------------------------------------------------------------------------------------------------------
00350
00351 inline std::string CompressedMessageHeaderValidator::ToString() const
00352 {
00353     if (!m_isInitialized)
00354         return "Compressed message header not initialised\n";
00355
00356     std::string str;
00357
00358     str = std::string("\nMessage Header\n") + IsDeleteToString() + std::string("\n") + IsCompositeToString() + std::string("\n") +
00359         TableTemplateIdToString() + std::string("\n") + TableTemplateNameToString() + std::string("\n");
00360
00361     if (!m_isDelete)
00362     {
00363         str += UpdateIdToString() + std::string("\n");
00364
00365         if (m_isComposite)
00366             str += CompositeUpdateIdToString() + std::string("\n");
00367     }
00368
00369     str += PermissionIdToString() + std::string("\n") + SymbolToString() + std::string("\n");
00370
00371     return str;
00372 }
00373
00374 // ---------------------------------------------------------------------------------------------------------------------------------
00375
00376 } // namespace Feed
00377
00378 } // namespace ContentPlatform
00379
00380 } // namespace Activ
00381
00382 #endif // (!defined ACTIV_FEED_MESSAGE_HANDLER_COMPRESSED_MESSAGE_HEADER_VALIDATOR_H)
Generated on Wed Oct 8 14:01:45 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedMessageHandler

CompressedSymbol.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FEED_MESSAGE_HANDLER_COMPRESSED_SYMBOL_H)
00010 #define ACTIV_FEED_MESSAGE_HANDLER_COMPRESSED_SYMBOL_H
00011
00012 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/CompressedUsEquityOptionSymbol.h"
00013
00014 #include <string>
00015
00016 namespace Activ
00017 {
00018
00019 class MessageValidator;
00020
00021 namespace ContentPlatform
00022 {
00023
00024 namespace Feed
00025 {
00026
00030 class CompressedSymbol
00031 {
00032 public:
00043     static StatusCode Serialize(const Feed::TableNo tableNumber, byte_t *&pMessage, const std::string &symbol);
00044
00055     static StatusCode Deserialize(const TableNo tableNumber, MessageValidator &messageValidator, std::string &symbol);
00056
00057 private:
00058     typedef uint8_t     EncodedCharacter;
00059     typedef uint64_t    EncodedSymbol;
00060
00070     static StatusCode Serialize(byte_t *&pMessage, const std::string &symbol);
00071
00081     static StatusCode Deserialize(MessageValidator &messageValidator, std::string &symbol);
00082
00090     static size_t GetBytesRequired(const size_t symbolLength);
00091
00100     static bool GetEncodedCharacter(const char chr, EncodedCharacter &encodedCharacter);
00101
00109     static char GetCharacter(const EncodedCharacter encodedCharacter);
00110
00111     static const size_t             MAXIMUM_SYMBOL_LENGTH           = 12;
00112
00113     static const EncodedCharacter   ENCODED_CHARACTER_DOT           = 26;
00114     static const EncodedCharacter   ENCODED_CHARACTER_FORWARD_SLASH = 28;
00115     static const EncodedCharacter   ENCODED_CHARACTER_COLON         = 27;
00116     static const EncodedCharacter   ENCODED_CHARACTER_SEMI_COLON    = 29;
00117     static const EncodedCharacter   ENCODED_CHARACTER_BANG          = 30;
00118     static const EncodedCharacter   ENCODED_CHARACTER_DASH          = 31;
00119
00120     static const size_t             SYMBOL_LENGTH_BIT_SHIFT = 4;
00121     static const EncodedSymbol      SYMBOL_LENGTH_BIT_MASK = (1 << SYMBOL_LENGTH_BIT_SHIFT) - 1;
00122     static const size_t             CHARACTER_BIT_SHIFT = 5;
00123     static const EncodedSymbol      CHARACTER_BIT_MASK = (1 << CHARACTER_BIT_SHIFT) - 1;
00124 };
00125
00126 // ---------------------------------------------------------------------------------------------------------------------------------
00127
00128 inline StatusCode CompressedSymbol::Serialize(const TableNo tableNumber, byte_t *&pMessage, const std::string &symbol)
00129 {
00130     return (TABLE_NO_US_EQUITY_OPTION == tableNumber) ? CompressedUsEquityOptionSymbol::Serialize(pMessage, symbol) : CompressedSymbol::Serialize(pMessage, symbol);
00131 }
00132
00133 // ---------------------------------------------------------------------------------------------------------------------------------
00134
00135 inline StatusCode CompressedSymbol::Deserialize(const TableNo tableNumber, MessageValidator &messageValidator, std::string &symbol)
00136 {
00137     return (TABLE_NO_US_EQUITY_OPTION == tableNumber) ? CompressedUsEquityOptionSymbol::Deserialize(messageValidator, symbol) : CompressedSymbol::Deserialize(messageValidator, symbol);
00138 }
00139
00140 // ---------------------------------------------------------------------------------------------------------------------------------
00141
00142 inline size_t CompressedSymbol::GetBytesRequired(const size_t symbolLength)
00143 {
00144     return (((symbolLength * CHARACTER_BIT_SHIFT) + SYMBOL_LENGTH_BIT_SHIFT + CHAR_BIT - 1) / CHAR_BIT);
00145 }
00146
00147 // ---------------------------------------------------------------------------------------------------------------------------------
00148
00149 inline bool CompressedSymbol::GetEncodedCharacter(const char chr, EncodedCharacter &encodedCharacter)
00150 {
00151     switch (chr)
00152     {
00153         case '.':
00154             encodedCharacter = ENCODED_CHARACTER_DOT;
00155             return true;
00156
00157         case '/':
00158             encodedCharacter = ENCODED_CHARACTER_FORWARD_SLASH;
00159             return true;
00160
00161         case ':':
00162             encodedCharacter = ENCODED_CHARACTER_COLON;
00163             return true;
00164
00165         case ';':
00166             encodedCharacter = ENCODED_CHARACTER_SEMI_COLON;
00167             return true;
00168
00169         case '!':
00170             encodedCharacter = ENCODED_CHARACTER_BANG;
00171             return true;
00172
00173         case '-':
00174             encodedCharacter = ENCODED_CHARACTER_DASH;
00175             return true;
00176
00177         default:
00178             if (!isupper(chr))
00179                 return false;
00180             encodedCharacter = chr - 'A';
00181             return true;
00182     }
00183 }
00184
00185 // ---------------------------------------------------------------------------------------------------------------------------------
00186
00187 inline char CompressedSymbol::GetCharacter(const EncodedCharacter encodedCharacter)
00188 {
00189     switch (encodedCharacter)
00190     {
00191         case ENCODED_CHARACTER_DOT:
00192             return '.';
00193
00194         case ENCODED_CHARACTER_FORWARD_SLASH:
00195             return '/';
00196
00197         case ENCODED_CHARACTER_COLON:
00198             return ':';
00199
00200         case ENCODED_CHARACTER_SEMI_COLON:
00201             return ';';
00202
00203         case ENCODED_CHARACTER_BANG:
00204             return '!';
00205
00206         case ENCODED_CHARACTER_DASH:
00207             return '-';
00208
00209         default:
00210             return ('A' + encodedCharacter);
00211     }
00212 }
00213
00214 } // namespace Feed
00215
00216 } // namespace ContentPlatform
00217
00218 } // namespace Activ
00219
00220 #endif // (!defined ACTIV_FEED_MESSAGE_HANDLER_COMPRESSED_SYMBOL_H)
Generated on Wed Oct 8 14:01:45 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedMessageHandler

CompressedUsEquityOptionSymbol.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FEED_MESSAGE_HANDLER_COMPRESSED_US_EQUITY_OPTION_SYMBOL_H)
00010 #define ACTIV_FEED_MESSAGE_HANDLER_COMPRESSED_US_EQUITY_OPTION_SYMBOL_H
00011
00012 #include <string>
00013
00014 namespace Activ
00015 {
00016
00017 class MessageValidator;
00018
00019 namespace ContentPlatform
00020 {
00021
00022 namespace Feed
00023 {
00024
00028 class CompressedUsEquityOptionSymbol
00029 {
00030 public:
00040     static StatusCode Serialize(byte_t *&pMessage, const std::string &symbol);
00041
00051     static StatusCode Deserialize(MessageValidator &messageValidator, std::string &symbol);
00052
00053 private:
00057     class CStringLessFunctor
00058     {
00059     public:
00068         bool operator ()(const char *pLhs, const char *pRhs) const
00069         {
00070             return (::strcmp(pLhs, pRhs) < 0);
00071         }
00072     };
00073
00074     typedef char const *    Exchange;
00075     typedef Exchange        ExchangeList[];
00076     typedef Exchange *      ExchangeIterator;
00077     typedef uint32_t        EncodedSymbol;
00078
00086     static EncodedSymbol GetEncodedCharacter(const char chr);
00087
00095     static char GetCharacter(const EncodedSymbol encodedCharacter);
00096
00097     static const size_t             MINIMUM_ROOT_LENGTH = 5;
00098     static const size_t             MAXIMUM_MNEMONIC_LENGTH = 3;
00099     static const size_t             MAXIMUM_SYMBOL_LENGTH = 10;
00100
00101     static const size_t             CHARACTER_BIT_SHIFT = 5;
00102     static const EncodedSymbol      CHARACTER_BIT_MASK = (1 << CHARACTER_BIT_SHIFT) - 1;
00103     static const size_t             ENCODED_EXCHANGE_BIT_SHIFT = 4;
00104     static const EncodedSymbol      ENCODED_EXCHANGE_BIT_MASK = (1 << ENCODED_EXCHANGE_BIT_SHIFT) - 1;
00105     static const size_t             EXCHANGE_LENGTH_BIT_SHIFT = 2;
00106     static const EncodedSymbol      EXCHANGE_LENGTH_BIT_MASK = (1 << EXCHANGE_LENGTH_BIT_SHIFT) - 1;
00107
00108     static ExchangeList             m_exchangeList;
00109 };
00110
00111 // ---------------------------------------------------------------------------------------------------------------------------------
00112
00113 inline CompressedUsEquityOptionSymbol::EncodedSymbol CompressedUsEquityOptionSymbol::GetEncodedCharacter(const char chr)
00114 {
00115     return (chr + 1 - 'A');
00116 }
00117
00118 // ---------------------------------------------------------------------------------------------------------------------------------
00119
00120 inline char CompressedUsEquityOptionSymbol::GetCharacter(const EncodedSymbol encodedCharacter)
00121 {
00122     return static_cast<char>('A' + encodedCharacter - 1);
00123 }
00124
00125 } // namespace Feed
00126
00127 } // namespace ContentPlatform
00128
00129 } // namespace Activ
00130
00131 #endif // (!defined ACTIV_FEED_MESSAGE_HANDLER_COMPRESSED_US_EQUITY_OPTION_SYMBOL_H)
Generated on Wed Oct 8 14:01:45 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » Config

Config.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_CONFIG_CONFIG_H)
00010 #define ACTIV_CONFIG_CONFIG_H
00011
00012 // select processor
00013 #if (defined __i386__) || (defined __i386) || (defined _M_IX86)
00014 #define ACTIV_PROCESSOR_X86
00015 #define ACTIV_PROCESSOR_NAME        "x86"
00016 #define ACTIV_PROCESSOR_WORD_SIZE   32
00017 #elif (defined __amd64__) || (defined __x86_64__) || (defined _M_AMD64)
00018 #define ACTIV_PROCESSOR_X86_64
00019 #define ACTIV_PROCESSOR_NAME        "x86-64"
00020 #define ACTIV_PROCESSOR_WORD_SIZE   64
00021 #elif (defined __powerpc__) || (defined __ppc__)
00022 #define ACTIV_PROCESSOR_PPC
00023 #define ACTIV_PROCESSOR_NAME        "PowerPC"
00024 #define ACTIV_PROCESSOR_WORD_SIZE   32
00025 #elif (defined __sparcv9) || ((defined __sparc__) && (defined __arch64__))
00026 #define ACTIV_PROCESSOR_SPARC64
00027 #define ACTIV_PROCESSOR_NAME        "Sparc64"
00028 #define ACTIV_PROCESSOR_WORD_SIZE   64
00029 #define ACTIV_REQUIRE_ALIGNED_MEMORY_ACCESS
00030 #elif (defined __sparc) || ((defined __sparc__) && (!defined __arch64__))
00031 #define ACTIV_PROCESSOR_SPARC
00032 #define ACTIV_PROCESSOR_NAME        "Sparc"
00033 #define ACTIV_PROCESSOR_WORD_SIZE   32
00034 #define ACTIV_REQUIRE_ALIGNED_MEMORY_ACCESS
00035 #elif (defined __ia64__) || (defined _M_IA64)
00036 #define ACTIV_PROCESSOR_IA64
00037 #define ACTIV_PROCESSOR_NAME        "Itanium"
00038 #define ACTIV_PROCESSOR_WORD_SIZE   64
00039 #define ACTIV_REQUIRE_ALIGNED_MEMORY_ACCESS
00040 #else
00041 #error Need to configure for this processor
00042 #endif
00043
00044 // select compiler
00045 #if (defined __GNUC__)
00046 #define ACTIV_COMPILER_GCC
00047 #elif (defined __INTEL_COMPILER)
00048 #define ACTIV_COMPILER_INTEL
00049 #elif (defined _MSC_VER)
00050 #define ACTIV_COMPILER_VISUAL_C
00051 #elif (defined __SUNPRO_CC)
00052 #define ACTIV_COMPILER_SUNPRO
00053 #else
00054 #error Need to configure for this compiler
00055 #endif
00056
00057 // select platform
00058
00059 namespace Activ
00060 {
00061
00067 enum PlatformType
00068 {
00069     PLATFORM_TYPE_UNKNOWN,
00070     PLATFORM_TYPE_LINUX,
00071     PLATFORM_TYPE_WINDOWS,
00072     PLATFORM_TYPE_BSD,
00073     PLATFORM_TYPE_OSX,
00074     PLATFORM_TYPE_SOLARIS
00075 };
00076
00077 } // namespace Activ
00078
00079 #if (defined linux) || (defined __linux) || (defined __linux__)
00080 #define ACTIV_PLATFORM_LINUX
00081 #elif (defined _WIN64)
00082 #define ACTIV_PLATFORM_WINDOWS  64
00083 #elif (defined _WIN32)
00084 #define ACTIV_PLATFORM_WINDOWS  32
00085 #elif (defined __FreeBSD__)
00086 #define ACTIV_PLATFORM_BSD
00087 #elif (defined __APPLE__)
00088 #define ACTIV_PLATFORM_OSX
00089 #elif (defined sun) || (defined __sun)
00090 #define ACTIV_PLATFORM_SOLARIS
00091 #else
00092 #error Need to configure for this platform
00093 #endif
00094
00095 // enable c99 options
00096 #if (!defined __STDC_LIMIT_MACROS)
00097 #define __STDC_LIMIT_MACROS
00098 #endif
00099
00100 #if (!defined __STDC_FORMAT_MACROS)
00101 #define __STDC_FORMAT_MACROS
00102 #endif
00103
00104 #if (!defined ACTIV_COMPILER_SUNPRO) && (!defined __STDC_CONSTANT_MACROS)
00105 #define __STDC_CONSTANT_MACROS
00106 #endif
00107
00108 // compiler specific includes
00109 #if (defined ACTIV_COMPILER_GCC)
00110 #include "Compilers/GCC.h"
00111 #elif (defined ACTIV_COMPILER_INTEL)
00112 #include "Compilers/Intel.h"
00113 #elif (defined ACTIV_COMPILER_VISUAL_C)
00114 #include "Compilers/VisualC.h"
00115 #elif (defined ACTIV_COMPILER_SUNPRO)
00116 #include "Compilers/SunPro.h"
00117 #endif
00118
00119 // old compatability macros until all moved over to new scheme
00120 #define ACTIV_EXPORT_DLL    ACTIV_BUILDING_DLL_EXPORTED_API
00121 #define ACTIV_IMPORT_DLL    ACTIV_USING_DLL_EXPORTED_API
00122
00123 #define ACTIV_EXPORT_LIB    ACTIV_BUILDING_LIB_EXPORTED_API
00124 #define ACTIV_IMPORT_LIB    ACTIV_USING_LIB_EXPORTED_API
00125
00126 // platform specific includes
00127 #if (defined ACTIV_PLATFORM_LINUX)
00128 #include "Platforms/Linux.h"
00129 #elif (defined ACTIV_PLATFORM_WINDOWS)
00130 #include "Platforms/Windows.h"
00131 #elif (defined ACTIV_PLATFORM_BSD)
00132 #include "Platforms/Bsd.h"
00133 #elif (defined ACTIV_PLATFORM_OSX)
00134 #include "Platforms/OSX.h"
00135 #elif (defined ACTIV_PLATFORM_SOLARIS)
00136 #include "Platforms/Solaris.h"
00137 #endif
00138
00139 #endif // (!defined ACTIV_CONFIG_CONFIG_H)
Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

ConsoleWindow.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_BASE_CONSOLE_WINDOW_H)
00010 #define ACTIV_BASE_CONSOLE_WINDOW_H
00011
00012 #include "ActivMiddleware/ActivBase/External.h"
00013
00014 #include <string>
00015
00016 #if (defined ACTIV_PLATFORM_POSIX)
00017 extern "C" typedef struct _win_st WINDOW;
00018 #endif
00019
00020 namespace Activ
00021 {
00022
00023 class IMutex;
00024 class MessageBuilder;
00025 class MessageValidator;
00026
00027 // ---------------------------------------------------------------------------------------------------------------------------------
00028
00032 class ConsoleWindow : private boost::noncopyable
00033 {
00034 public:
00038     class Coord
00039     {
00040     public:
00044         ACTIV_BASE_INLINE_API Coord();
00045
00052         ACTIV_BASE_INLINE_API Coord(const int16_t x, const int16_t y);
00053
00061         ACTIV_BASE_INLINE_API bool operator==(const Coord &rhs) const;
00062
00070         ACTIV_BASE_INLINE_API bool operator!=(const Coord &rhs) const;
00071
00079         ACTIV_BASE_EXPORTED_API StatusCode Serialize(MessageBuilder &messageBuilder) const;
00080
00088         ACTIV_BASE_EXPORTED_API StatusCode Deserialize(MessageValidator &messageValidator);
00089
00090         int16_t m_x;
00091         int16_t m_y;
00092     };
00093
00094     typedef uint32_t Flags;
00095
00096     static const Flags FLAG_NONE = 0x00000000;
00097     static const Flags FLAG_NO_AUTOSCROLL = 0x00000001;
00098     static const Flags FLAG_IMMEDIATE_REFRESH = 0x00000002;
00099
00105     ACTIV_BASE_EXPORTED_API ConsoleWindow(const Flags flags = FLAG_NONE);
00106
00110     ACTIV_BASE_EXPORTED_API ~ConsoleWindow();
00111
00123     ACTIV_BASE_EXPORTED_API StatusCode WaitForInput(const TimeoutPeriod timeoutPeriod = 100) const;
00124
00134     ACTIV_BASE_EXPORTED_API StatusCode ReadLine(std::string &input) const;
00135
00144     ACTIV_BASE_EXPORTED_API StatusCode GetDisplaySize(Coord &size) const;
00145
00156     ACTIV_BASE_EXPORTED_API StatusCode SetDisplaySize(const Coord &size);
00157
00166     ACTIV_BASE_EXPORTED_API StatusCode GetBufferSize(Coord &size) const;
00167
00178     ACTIV_BASE_EXPORTED_API StatusCode SetBufferSize(const Coord &size);
00179
00188     ACTIV_BASE_EXPORTED_API StatusCode GetCursorPosition(Coord &coord) const;
00189
00198     ACTIV_BASE_EXPORTED_API StatusCode SetCursorPosition(const Coord &coord);
00199
00208     ACTIV_BASE_EXPORTED_API StatusCode SetCursorVisibility(const bool isVisible);
00209
00220     ACTIV_BASE_EXPORTED_API StatusCode ClearFrom(const Coord &coord);
00221
00234     ACTIV_BASE_EXPORTED_API StatusCode WriteAt(const Coord &coord, const char * const pStr, const size_t length = 0);
00235
00242     ACTIV_BASE_EXPORTED_API void Printf(const char * const pStr, ...) const;
00243
00249     ACTIV_BASE_EXPORTED_API static void SetTitle(const std::string &title);
00250
00251 private:
00255     ACTIV_BASE_LOCAL_API void CommonCtor();
00256
00260     ACTIV_BASE_LOCAL_API void CommonDtor();
00261
00262 #if (defined ACTIV_PLATFORM_WINDOWS)
00263
00264     const HANDLE    m_outputHandle;
00265     const HANDLE    m_inputHandle;
00266     DWORD           m_initialMode;
00267
00268 #elif (defined ACTIV_PLATFORM_POSIX)
00269
00270     WINDOW * const  m_pWindow;
00271     IMutex * const  m_pMutex;
00272     Coord           m_displaySize;
00273
00274 #else
00275 #error Configure for this platform
00276 #endif
00277
00278     bool            m_initialIsCursorVisible;
00279     Coord           m_initialDisplaySize;
00280     Coord           m_initialBufferSize;
00281 };
00282
00283 // ---------------------------------------------------------------------------------------------------------------------------------
00284 // ---------------------------------------------------------------------------------------------------------------------------------
00285
00286 inline ConsoleWindow::Coord::Coord() :
00287     m_x(0),
00288     m_y(0)
00289 {
00290 }
00291
00292 // ---------------------------------------------------------------------------------------------------------------------------------
00293
00294 inline ConsoleWindow::Coord::Coord(const int16_t x, const int16_t y) :
00295     m_x(x),
00296     m_y(y)
00297 {
00298 }
00299
00300 // ---------------------------------------------------------------------------------------------------------------------------------
00301
00302 inline bool ConsoleWindow::Coord::operator==(const Coord &rhs) const
00303 {
00304     return (m_x == rhs.m_x) && (m_y == rhs.m_y);
00305 }
00306
00307 // ---------------------------------------------------------------------------------------------------------------------------------
00308
00309 inline bool ConsoleWindow::Coord::operator!=(const Coord &rhs) const
00310 {
00311     return !operator==(rhs);
00312 }
00313
00314 } // namespace Activ
00315
00316 #endif // (!defined ACTIV_BASE_CONSOLE_WINDOW_H)
Generated on Wed Oct 8 14:01:46 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivContentGatewayApi

ContentGatewayClient.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_CONTENT_GATEWAY_API_CONTENT_GATEWAY_CLIENT_H)
00010 #define ACTIV_CONTENT_GATEWAY_API_CONTENT_GATEWAY_CLIENT_H
00011
00012 #include "ActivContentPlatform/ActivContentGatewayApi/External.h"
00013 #include "ActivContentPlatform/ActivContentGatewayApi/RealtimeRequestHelper.h"
00014 #include "ActivContentPlatform/ActivContentGatewayApi/TimeSeriesRequestHelper.h"
00015 #include "ActivContentPlatform/ActivContentGatewayApi/SymbolDirectoryRequestHelper.h"
00016 #include "ActivContentPlatform/ActivContentGatewayApi/NewsRequestHelper.h"
00017 #include "ActivContentPlatform/ActivContentGatewayApi/MetaDataRequestHelper.h"
00018 #include "ActivContentPlatform/ActivContentGatewayApi/IRealtimeResponses.h"
00019 #include "ActivContentPlatform/ActivContentGatewayApi/ITimeSeriesResponses.h"
00020 #include "ActivContentPlatform/ActivContentGatewayApi/ISymbolDirectoryResponses.h"
00021 #include "ActivContentPlatform/ActivContentGatewayApi/INewsResponses.h"
00022
00023 namespace Activ
00024 {
00025
00026 namespace ContentPlatform
00027 {
00028
00029 namespace ContentGatewayApi
00030 {
00031
00035 class ContentGatewayClient : public Component, protected IRealtimeResponses, protected ITimeSeriesResponses,
00036     protected ISymbolDirectoryResponses, protected INewsResponses
00037 {
00038 public:
00039     // Available realtime requests.
00040     typedef RealtimeRequestHelper<GATEWAY_REQUEST_GET_FIRST, TableNumberRequestParameters> GetFirst;
00041     typedef RealtimeRequestHelper<GATEWAY_REQUEST_GET_LAST, TableNumberRequestParameters> GetLast;
00042     typedef RealtimeRequestHelper<GATEWAY_REQUEST_GET_NEXT, SymbolIdCountRequestParameters> GetNext;
00043     typedef RealtimeRequestHelper<GATEWAY_REQUEST_GET_PREVIOUS, SymbolIdCountRequestParameters> GetPrevious;
00044     typedef RealtimeRequestHelper<GATEWAY_REQUEST_GET_EQUAL, SymbolIdRequestParameters> GetEqual;
00045     typedef RealtimeRequestHelper<GATEWAY_REQUEST_GET_MULTIPLE_EQUAL, SymbolIdListRequestParameters> GetMultipleEqual;
00046     typedef RealtimeRequestHelper<GATEWAY_REQUEST_GET_MULTIPLE_PATTERN_MATCH, PatternMatchRequestParameters> GetMultiplePatternMatch;
00047     typedef RealtimeRequestHelper<GATEWAY_REQUEST_GET_MULTIPLE_PATTERN_MATCH_LIST, PatternMatchListRequestParameters> GetMultiplePatternMatchList;
00048     typedef RealtimeRequestHelper<GATEWAY_REQUEST_GET_MATCH, SymbolIdMatchRequestParameters> GetMatch;
00049     typedef RealtimeRequestHelper<GATEWAY_REQUEST_GET_MULTIPLE_MATCH, SymbolIdListMatchRequestParameters> GetMultipleMatch;
00050
00051     // Available time series requests.
00052     typedef TimeSeriesRequestHelper<GATEWAY_REQUEST_GET_FIRST_HISTORY, GATEWAY_REQUEST_GET_NEXT_HISTORY, HistoryBarList> GetHistory;
00053     typedef TimeSeriesRequestHelper<GATEWAY_REQUEST_GET_FIRST_INTRADAY, GATEWAY_REQUEST_GET_NEXT_INTRADAY, IntradayBarList> GetIntraday;
00054     typedef TimeSeriesRequestHelper<GATEWAY_REQUEST_GET_FIRST_TICKS, GATEWAY_REQUEST_GET_NEXT_TICKS, TickList> GetTicks;
00055
00056     // Available symbol directory requests.
00057     typedef SymbolDirectoryRequestHelper GetSymbols;
00058
00059     // Available news requests.
00060     typedef NewsRequestHelper GetNewsStories;
00061
00062     // Available metadata requests.
00063     typedef MetaDataRequestHelper MetaData;
00064
00068     #define ACTIV_CONTENT_GATEWAY_CLIENT_STATE_LIST(d)  \
00069         d(STATE_INITIALIZED, "initialized")             \
00070         d(STATE_W4_CONNECT, "w4 connect")               \
00071         d(STATE_LOGGED_ON, "logged on")                 \
00072         d(STATE_W4_DISCONNECT, "w4 disconnect")
00073
00077     enum State
00078     {
00079         ACTIV_CONTENT_GATEWAY_CLIENT_STATE_LIST(ACTIV_DECLARE_ELEMENT_1_WITH_COMMA)
00080         NUMBER_OF_STATES
00081     };
00082
00086     class Settings
00087     {
00088     public:
00089         #define ACTIV_CONTENT_GATEWAY_CLIENT_DEFAULT_HEAP_SIZE \
00090             { { 10, 1000 }, { 100, 50000 }, { 200, 10000 }, { 500, 10000 }, { 10000, 1000 }, { 25000, 500 } }
00091
00100         ACTIV_CONTENT_GATEWAY_API Settings();
00101
00105         ACTIV_CONTENT_GATEWAY_API ~Settings();
00106
00107         bool                    m_createMutex;
00108         IHeap::BucketInfoVector m_heapBucketInfoVector;
00109         IHeap *                 m_pHeap;
00110     };
00111
00115     class ConnectParameters
00116     {
00117     public:
00121         #define POLICY_TYPE_LIST(d)                                                                         \
00122             d(POLICY_RETRY)                                         \
00123             d(POLICY_FIND_NEXT_ALTERNATIVE)         \
00124             d(POLICY_FIND_RANDOM_ALTERNATIVE)
00126         enum Policy
00127         {
00128             POLICY_TYPE_LIST(ACTIV_DECLARE_VALUE_WITH_COMMA)
00129             NUMBER_OF_POLICIES
00130         };
00131
00135         ACTIV_CONTENT_GATEWAY_API ConnectParameters();
00136
00137         static const uint16_t DEFAULT_FAILOVER_SECONDS = 15;
00138
00139         ServiceId       m_serviceId;
00140         std::string     m_url;
00141         std::string     m_userId;
00142         std::string     m_password;
00143         UserType        m_userType;
00144         std::string     m_infoString;
00145         LogonFlags      m_logonFlags;
00146
00147         Policy          m_policy;
00148         uint16_t        m_failoverSeconds;
00149         std::string     m_attributeQuery;
00150         AgentScope      m_agentScope;
00151     };
00152
00156     class ApiInfo
00157     {
00158     public:
00159         std::string m_version;
00160         std::string m_buildConfiguration;
00161         std::string m_buildDateTime;
00162     };
00163
00174     ACTIV_CONTENT_GATEWAY_API ContentGatewayClient(Application &application, ManagedEndPoint &managedEndPoint,
00175         const Settings &settings = Settings(), const std::string &componentId = defaultComponentId);
00176
00180     ACTIV_CONTENT_GATEWAY_API virtual ~ContentGatewayClient();
00181
00187     ACTIV_CONTENT_GATEWAY_API State GetState() const;
00188
00196     ACTIV_CONTENT_GATEWAY_API static std::string StateToString(const State state);
00197
00203     ACTIV_CONTENT_GATEWAY_API std::string GetServiceLocation() const;
00204
00210     ACTIV_CONTENT_GATEWAY_API ApiInfo GetApiInfo() const;
00211
00226     ACTIV_CONTENT_GATEWAY_API StatusCode Connect(const ConnectParameters &connectParameters,
00227         const TimeoutPeriod timeoutPeriod = Port::defaultTimeout);
00228
00239     ACTIV_CONTENT_GATEWAY_API StatusCode Disconnect();
00240
00253     ACTIV_CONTENT_GATEWAY_API StatusCode SubscribeToFeed(const SubscribeFeedParameters &subscribeFeedParameters,
00254         SubscriptionCookie &subscriptionCookie) const;
00255
00266     ACTIV_CONTENT_GATEWAY_API StatusCode SubscribeToTable(const SubscribeTableParameters &subscribeTableParameters,
00267         SubscriptionCookie &subscriptionCookie) const;
00268
00276     ACTIV_CONTENT_GATEWAY_API StatusCode Unsubscribe() const;
00277
00289     ACTIV_CONTENT_GATEWAY_API StatusCode Unsubscribe(const SubscriptionCookie subscriptionCookie) const;
00290
00304     ACTIV_CONTENT_GATEWAY_API StatusCode Unsubscribe(const SubscriptionCookie subscriptionCookie,
00305         const SymbolIdList &sourceSymbolIdList) const;
00306
00318     ACTIV_CONTENT_GATEWAY_API StatusCode Unsubscribe(const SubscriptionCookieList &subscriptionCookieList) const;
00319
00330     ACTIV_CONTENT_GATEWAY_API StatusCode GetSubscriptionInfo(const Feed::PermissionLevel permissionLevel,
00331         SubscriptionInfo &subscriptionInfo) const;
00332
00342     ACTIV_CONTENT_GATEWAY_API StatusCode GetContentGatewayInfo(ContentGatewayInfo &contentGatewayInfo) const;
00343
00351     static bool IsValidResponse(const HeapMessage &response);
00352
00360     static bool IsCompleteResponse(const HeapMessage &response);
00361
00362     class Private;
00363
00364 protected:
00365     // IRealtimeResponses overrides
00366     ACTIV_CONTENT_GATEWAY_API virtual void OnRecordUpdate(HeapMessage &update);
00367     ACTIV_CONTENT_GATEWAY_API virtual void OnGetFirstResponse(HeapMessage &response);
00368     ACTIV_CONTENT_GATEWAY_API virtual void OnGetLastResponse(HeapMessage &response);
00369     ACTIV_CONTENT_GATEWAY_API virtual void OnGetNextResponse(HeapMessage &response);
00370     ACTIV_CONTENT_GATEWAY_API virtual void OnGetPreviousResponse(HeapMessage &response);
00371     ACTIV_CONTENT_GATEWAY_API virtual void OnGetEqualResponse(HeapMessage &response);
00372     ACTIV_CONTENT_GATEWAY_API virtual void OnGetMultipleEqualResponse(HeapMessage &response);
00373     ACTIV_CONTENT_GATEWAY_API virtual void OnGetMultiplePatternMatchResponse(HeapMessage &response);
00374     ACTIV_CONTENT_GATEWAY_API virtual void OnGetMultiplePatternMatchListResponse(HeapMessage &response);
00375     ACTIV_CONTENT_GATEWAY_API virtual void OnGetMatchResponse(HeapMessage &response);
00376     ACTIV_CONTENT_GATEWAY_API virtual void OnGetMultipleMatchResponse(HeapMessage &response);
00377
00378     // ITimeSeriesResponses overrides
00379     ACTIV_CONTENT_GATEWAY_API virtual void OnGetFirstHistoryResponse(HeapMessage &response);
00380     ACTIV_CONTENT_GATEWAY_API virtual void OnGetNextHistoryResponse(HeapMessage &response);
00381     ACTIV_CONTENT_GATEWAY_API virtual void OnGetFirstIntradayResponse(HeapMessage &response);
00382     ACTIV_CONTENT_GATEWAY_API virtual void OnGetNextIntradayResponse(HeapMessage &response);
00383     ACTIV_CONTENT_GATEWAY_API virtual void OnGetFirstTicksResponse(HeapMessage &response);
00384     ACTIV_CONTENT_GATEWAY_API virtual void OnGetNextTicksResponse(HeapMessage &response);
00385
00386     // ISymbolDirectoryResponses overrides
00387     ACTIV_CONTENT_GATEWAY_API virtual void OnGetSymbolsResponse(HeapMessage &response);
00388
00389     // INewsResponses overrides
00390     ACTIV_CONTENT_GATEWAY_API virtual void OnNewsUpdate(HeapMessage &update);
00391     ACTIV_CONTENT_GATEWAY_API virtual void OnGetNewsStoriesResponse(HeapMessage &response);
00392
00393     // Component overrides
00394     ACTIV_CONTENT_GATEWAY_API virtual StatusCode OnConnect(HeapMessage &connectMessage);
00395     ACTIV_CONTENT_GATEWAY_API virtual StatusCode OnConnectFailed(HeapMessage &connectFailMessage);
00396     ACTIV_CONTENT_GATEWAY_API virtual StatusCode OnBreak(HeapMessage &breakMessage);
00397     ACTIV_CONTENT_GATEWAY_API virtual StatusCode OnDisconnect(HeapMessage &disconnectMessage);
00398     ACTIV_CONTENT_GATEWAY_API virtual StatusCode OnTimer(const Address &timerAddress, const BaseTime &time);
00399     ACTIV_CONTENT_GATEWAY_API virtual StatusCode OnResponse(HeapMessage &response);
00400     ACTIV_CONTENT_GATEWAY_API virtual StatusCode OnMessage(HeapMessage &message);
00401
00407     ACTIV_CONTENT_GATEWAY_API virtual void OnReportMessage(const std::string &reportMessage);
00408
00414     ACTIV_CONTENT_GATEWAY_API virtual void OnContentGatewayInfoUpdate(const ContentGatewayInfo &contentGatewayInfo);
00415
00416 private:
00417     std::auto_ptr<Private>  m_pPrivate;
00418 };
00419
00420 // ---------------------------------------------------------------------------------------------------------------------------------
00421
00422 inline bool ContentGatewayClient::IsValidResponse(const HeapMessage &response)
00423 {
00424     const StatusCode statusCode = response.GetStatusCode();
00425
00426     return ((STATUS_CODE_SUCCESS == statusCode) || (STATUS_CODE_PENDING == statusCode));
00427 }
00428
00429 // ---------------------------------------------------------------------------------------------------------------------------------
00430
00431 inline bool ContentGatewayClient::IsCompleteResponse(const HeapMessage &response)
00432 {
00433     // Will get more responses after STATUS_CODE_PENDING, but not any other
00434     return (STATUS_CODE_PENDING != response.GetStatusCode());
00435 }
00436
00437 } // namespace ContentGatewayApi
00438
00439 } // namespace ContentPlatform
00440
00441 } // namespace Activ
00442
00443 #endif // (!defined ACTIV_CONTENT_GATEWAY_API_CONTENT_GATEWAY_CLIENT_H)
Generated on Wed Oct 8 14:01:44 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivContentServerApi

ContentServerClient.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_CONTENT_SERVER_API_CONTENT_SERVER_CLIENT_H)
00010 #define ACTIV_CONTENT_SERVER_API_CONTENT_SERVER_CLIENT_H
00011
00012 #include "ActivContentPlatform/ActivContentServerApi/External.h"
00013 #include "ActivContentPlatform/ActivContentServerApi/RecordUpdateHelper.h"
00014
00015 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedDefinitions.h"
00016 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedPermissioning/PermissionInfo.h"
00017
00018 namespace Activ
00019 {
00020
00021 namespace ContentPlatform
00022 {
00023
00024 namespace ContentServerApi
00025 {
00026
00027 class ContentServerOutput;
00028 class FieldListValidator;
00029
00030 typedef uint32_t SubscriptionCookie;
00031 const SubscriptionCookie SUBSCRIPTION_COOKIE_UNDEFINED = static_cast<SubscriptionCookie>(~0);
00032
00033 // ---------------------------------------------------------------------------------------------------------------------------------
00034
00038 class ContentServerClient : public Component
00039 {
00040 public:
00044     class Settings
00045     {
00046     public:
00050         ACTIV_CONTENT_SERVER_API Settings();
00051
00055         ACTIV_CONTENT_SERVER_API ~Settings();
00056
00065         ACTIV_CONTENT_SERVER_API StatusCode Read(const IniFileParser::ConstSectionIterator &sectionIterator);
00066
00067         #define DEFAULT_CS_MANAGER_RESET_TIME   4, 30, 0
00068
00069         Time                    m_resetTime;
00070         std::string             m_tableTemplateServiceId;
00071
00072         class Private;
00073
00074         boost::shared_ptr<Private>  m_pPrivateSettings;
00075     };
00076
00080     class ApiInfo
00081     {
00082     public:
00083         std::string m_version;
00084         std::string m_buildConfiguration;
00085         std::string m_buildDateTime;
00086     };
00087
00091     class MessageStats
00092     {
00093     public:
00097         ACTIV_CONTENT_SERVER_API MessageStats();
00098
00099         std::string     m_name;
00100         uint32_t        m_receivedUpdateCount;
00101         uint32_t        m_unrecognizedUpdateCount;
00102         uint32_t        m_totalProcessedCount;
00103         uint32_t        m_totalIgnoredCount;
00104         uint32_t        m_totalErrorCount;
00105     };
00106
00107     typedef std::list<MessageStats> MessageStatsList;
00108
00112     class UpdateFilter
00113     {
00114     public:
00115         typedef std::vector<Feed::EventType>    EventTypeList;
00116         typedef std::vector<Feed::TableNo>      TableNumberList;
00117         typedef std::vector<std::string>        SymbolPatternList;
00118
00119         EventTypeList                           m_eventTypeList;
00120         TableNumberList                         m_tableNumberList;
00121         SymbolPatternList                       m_symbolPatternList;
00122     };
00123
00127     class UpdateFilterMap
00128     {
00129     public:
00130         std::string                                 m_name;
00131         std::map<SubscriptionCookie, UpdateFilter>  m_updateFilterMap;
00132     };
00133
00134     typedef std::list<UpdateFilterMap> UpdateFilterMapList;
00135
00146     ACTIV_CONTENT_SERVER_API ContentServerClient(Application &application, ManagedEndPoint &managedEndPoint, const Settings &settings,
00147         const std::string &componentLicenseId = defaultComponentId);
00148
00152     ACTIV_CONTENT_SERVER_API virtual ~ContentServerClient();
00153
00168     ACTIV_CONTENT_SERVER_API StatusCode Logon(const std::string &userId, const std::string &password);
00169
00173     ACTIV_CONTENT_SERVER_API void Logoff();
00174
00180     ACTIV_CONTENT_SERVER_API bool IsUserLoggedOn() const;
00181
00192     ACTIV_CONTENT_SERVER_API StatusCode AddUpdateFilter(const UpdateFilter &updateFilter, SubscriptionCookie &subscriptionCookie,
00193         const std::string &providerName = "");
00194
00203     ACTIV_CONTENT_SERVER_API StatusCode RemoveUpdateFilter(const SubscriptionCookie subscriptionCookie);
00204
00210     ACTIV_CONTENT_SERVER_API const ApiInfo GetApiInfo() const;
00211
00217     ACTIV_CONTENT_SERVER_API const MessageStatsList GetMessageStatsList() const;
00218
00224     ACTIV_CONTENT_SERVER_API const MessageStats GetTotalMessageStats() const;
00225
00231     ACTIV_CONTENT_SERVER_API const UpdateFilterMapList GetUpdateFilterMapList() const;
00232
00238     ACTIV_CONTENT_SERVER_API const Feed::PermissionInfo GetPermissionInfo() const;
00239
00252     ACTIV_CONTENT_SERVER_API virtual StatusCode OnSymbolRecordUpdate(const std::string &providerName,
00253         SymbolRecordUpdate &symbolRecordUpdate);
00254
00267     ACTIV_CONTENT_SERVER_API virtual StatusCode OnRecordUpdate(const std::string &providerName, RecordUpdate &recordUpdate);
00268
00276     ACTIV_CONTENT_SERVER_API virtual void OnFlush(const std::string &providerName);
00277
00278     class Private;
00279
00280 protected:
00281     // Component overrides
00282     ACTIV_CONTENT_SERVER_API StatusCode OnTimer(const Address &timerAddress, const BaseTime &time);
00283
00284 private:
00285     std::auto_ptr<Private>  m_pPrivate;
00286
00287     friend class ContentServerOutput;
00288     friend class FieldListValidator;
00289 };
00290
00291 } // namespace ContentServerApi
00292
00293 } // namespace ContentPlatform
00294
00295 } // namespace Activ
00296
00297 #endif // (!defined ACTIV_CONTENT_SERVER_API_CONTENT_SERVER_CLIENT_H)
Generated on Wed Oct 8 14:01:45 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivContributionGatewayApi

ContributionGatewayClient.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_CONTRIBUTION_GATEWAY_API_CONTRIBUTION_GATEWAY_CLIENT_H)
00010 #define ACTIV_CONTRIBUTION_GATEWAY_API_CONTRIBUTION_GATEWAY_CLIENT_H
00011
00012 #include "ActivContentPlatform/ActivContributionGatewayApi/External.h"
00013 #include "ActivContentPlatform/ActivContributionGatewayApi/PublishRequestHelper.h"
00014
00015 namespace Activ
00016 {
00017
00018 namespace ContentPlatform
00019 {
00020
00021 namespace ContributionGatewayApi
00022 {
00023
00027 class ContributionGatewayClient : public Component
00028 {
00029 public:
00030     // Available publish requests.
00031     typedef PublishRequestHelper<CONTRIBUTION_GATEWAY_REQUEST_PUBLISH_SYMBOL_RECORD, PublishSymbolRecordParameters, PublishRecordResponseParameters> PublishSymbolRecord;
00032     typedef PublishRequestHelper<CONTRIBUTION_GATEWAY_REQUEST_PUBLISH_RECORD, PublishRecordParameters, PublishRecordResponseParameters> PublishRecord;
00033
00037     #define ACTIV_CONTRIBUTION_GATEWAY_CLIENT_STATE_LIST(d) \
00038         d(STATE_INITIALIZED, "initialized")                 \
00039         d(STATE_W4_CONNECT, "w4 connect")                   \
00040         d(STATE_LOGGED_ON, "logged on")                     \
00041         d(STATE_W4_DISCONNECT, "w4 disconnect")
00042
00046     enum State
00047     {
00048         ACTIV_CONTRIBUTION_GATEWAY_CLIENT_STATE_LIST(ACTIV_DECLARE_ELEMENT_1_WITH_COMMA)
00049         NUMBER_OF_STATES
00050     };
00051
00055     class Settings
00056     {
00057     public:
00058         #define ACTIV_CONTRIBUTION_GATEWAY_CLIENT_DEFAULT_HEAP_SIZE { { 100, 100000 }, { 500, 20000 }, { 1000, 10000 }, { 25000, 500 } }
00059
00068         ACTIV_CONTRIBUTION_GATEWAY_API Settings();
00069
00073         ACTIV_CONTRIBUTION_GATEWAY_API ~Settings();
00074
00075         bool                    m_createMutex;
00076         IHeap::BucketInfoVector m_heapBucketInfoVector;
00077         IHeap *                 m_pHeap;
00078     };
00079
00083     class ConnectParameters
00084     {
00085     public:
00089         #define POLICY_TYPE_LIST(d)                                                                         \
00090             d(POLICY_RETRY)                                         \
00091             d(POLICY_FIND_NEXT_ALTERNATIVE)         \
00092             d(POLICY_FIND_RANDOM_ALTERNATIVE)
00094         enum Policy
00095         {
00096             POLICY_TYPE_LIST(ACTIV_DECLARE_VALUE_WITH_COMMA)
00097             NUMBER_OF_POLICIES
00098         };
00099
00103         ACTIV_CONTRIBUTION_GATEWAY_API ConnectParameters();
00104
00105         static const uint16_t DEFAULT_FAILOVER_SECONDS = 15;
00106
00107         ServiceId       m_serviceId;
00108         std::string     m_url;
00109         std::string     m_userId;
00110         std::string     m_password;
00111         Policy          m_policy;
00112         uint16_t        m_failoverSeconds;
00113         std::string     m_attributeQuery;
00114         AgentScope      m_agentScope;
00115         UserType        m_userType;
00116         std::string     m_infoString;
00117     };
00118
00122     class ApiInfo
00123     {
00124     public:
00125         std::string m_version;
00126         std::string m_buildConfiguration;
00127         std::string m_buildDateTime;
00128     };
00129
00140     ACTIV_CONTRIBUTION_GATEWAY_API ContributionGatewayClient(Application &application, ManagedEndPoint &managedEndPoint,
00141         const Settings &settings = Settings(), const std::string &componentId = defaultComponentId);
00142
00146     ACTIV_CONTRIBUTION_GATEWAY_API virtual ~ContributionGatewayClient();
00147
00153     ACTIV_CONTRIBUTION_GATEWAY_API State GetState() const;
00154
00162     ACTIV_CONTRIBUTION_GATEWAY_API static std::string StateToString(const State state);
00163
00169     ACTIV_CONTRIBUTION_GATEWAY_API std::string GetServiceLocation() const;
00170
00176     ACTIV_CONTRIBUTION_GATEWAY_API ApiInfo GetApiInfo() const;
00177
00187     ACTIV_CONTRIBUTION_GATEWAY_API StatusCode GetContributionGatewayInfo(ContributionGatewayInfo &contributionGatewayInfo) const;
00188
00198     ACTIV_CONTRIBUTION_GATEWAY_API StatusCode GetPermissionInfo(PermissionInfo &permissionInfo) const;
00199
00212     ACTIV_CONTRIBUTION_GATEWAY_API StatusCode Connect(const ConnectParameters &connectParameters,
00213         const TimeoutPeriod timeoutPeriod = Port::defaultTimeout);
00214
00225     ACTIV_CONTRIBUTION_GATEWAY_API StatusCode Disconnect();
00226
00234     static bool IsValidResponse(const HeapMessage &response);
00235
00236     class Private;
00237
00238 protected:
00239     ACTIV_CONTRIBUTION_GATEWAY_API virtual void OnPublishSymbolRecordResponse(HeapMessage &update);
00240     ACTIV_CONTRIBUTION_GATEWAY_API virtual void OnPublishRecordResponse(HeapMessage &update);
00241
00242     // Component overrides
00243     ACTIV_CONTRIBUTION_GATEWAY_API virtual StatusCode OnConnect(HeapMessage &connectMessage);
00244     ACTIV_CONTRIBUTION_GATEWAY_API virtual StatusCode OnConnectFailed(HeapMessage &connectFailMessage);
00245     ACTIV_CONTRIBUTION_GATEWAY_API virtual StatusCode OnBreak(HeapMessage &breakMessage);
00246     ACTIV_CONTRIBUTION_GATEWAY_API virtual StatusCode OnDisconnect(HeapMessage &disconnectMessage);
00247     ACTIV_CONTRIBUTION_GATEWAY_API virtual StatusCode OnTimer(const Address &timerAddress, const BaseTime &time);
00248     ACTIV_CONTRIBUTION_GATEWAY_API virtual StatusCode OnResponse(HeapMessage &response);
00249     ACTIV_CONTRIBUTION_GATEWAY_API virtual StatusCode OnMessage(HeapMessage &message);
00250
00256     ACTIV_CONTRIBUTION_GATEWAY_API virtual void OnReportMessage(const std::string &reportMessage);
00257
00258 private:
00259     std::auto_ptr<Private>  m_pPrivate;
00260 };
00261
00262 // ---------------------------------------------------------------------------------------------------------------------------------
00263
00264 inline bool ContributionGatewayClient::IsValidResponse(const HeapMessage &response)
00265 {
00266     return (STATUS_CODE_SUCCESS == response.GetStatusCode());
00267 }
00268
00269 } // namespace ContributionGatewayApi
00270
00271 } // namespace ContentPlatform
00272
00273 } // namespace Activ
00274
00275 #endif // (!defined ACTIV_CONTRIBUTION_GATEWAY_API_CONTRIBUTION_GATEWAY_CLIENT_H)
Generated on Wed Oct 8 14:01:45 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivContributionServerApi

ContributionServerClient.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_CONTRIBUTION_SERVER_API_CONTRIBUTION_SERVER_CLIENT_H)
00010 #define ACTIV_CONTRIBUTION_SERVER_API_CONTRIBUTION_SERVER_CLIENT_H
00011
00012 #include "ActivContentPlatform/ActivContributionServerApi/External.h"
00013
00014 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/SymbolRecordRuleDefinitions.h"
00015 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/TableTemplateList.h"
00016
00017 #include "ActivMiddleware/ActivServices/UdpTransmitter.h"
00018
00022 #define ACTIV_CONTRIBUTION_SERVER_API_VERSION_VALUE     ACTIV_MAKE_VERSION_VALUE(99, 99, 99, 99)
00023
00027 #define ACTIV_CONTRIBUTION_SERVER_API_VERSION_STRING    "99.99.99.99"
00028
00029 namespace Activ
00030 {
00031
00032 class MessageRateThrottler;
00033
00034 namespace ContentPlatform
00035 {
00036
00037 namespace ContributionServerApi
00038 {
00039
00043 class ContributionServerClient : public Component
00044 {
00045 public:
00046     class Private;
00047
00051     class Settings
00052     {
00053     public:
00057         ACTIV_CONTRIBUTION_SERVER_API Settings();
00058
00069         ACTIV_CONTRIBUTION_SERVER_API static Settings GetFromIniFile(const std::string &iniFileName,
00070             const std::string &sectionName = ContributionServerClient::GetDefaultName());
00071
00081         ACTIV_CONTRIBUTION_SERVER_API StatusCode Read(const IniFileParser &iniFileParser, const std::string &sectionName);
00082
00083         std::string                         m_iniFileName;
00084         std::string                         m_sectionName;
00085
00086         size_t                              m_messageRate;
00087         UdpTransmitter::Settings            m_udpSettings;
00088         Feed::TableTemplateList::Settings   m_tableTemplateListSettings;
00089     };
00090
00094     class ApiInfo
00095     {
00096     public:
00097         std::string m_version;
00098         std::string m_buildConfiguration;
00099         std::string m_buildDateTime;
00100     };
00101
00105     class RecordMessageBuilder
00106     {
00107     public:
00108         class Private;
00109
00113         ACTIV_CONTRIBUTION_SERVER_API RecordMessageBuilder(ContributionServerClient &contributionServerClient);
00114
00118         ACTIV_CONTRIBUTION_SERVER_API ~RecordMessageBuilder();
00119
00123         ACTIV_CONTRIBUTION_SERVER_API void Reset();
00124
00140         ACTIV_CONTRIBUTION_SERVER_API StatusCode AppendHeader(const bool isDelete, const bool isRefresh,
00141             const Feed::TableId tableId, const Feed::PermissionId permissionId, const Feed::EventType eventType,
00142             const Feed::UpdateId updateId = Feed::UPDATE_ID_COUNT_UNKNOWN);
00143
00154         ACTIV_CONTRIBUTION_SERVER_API StatusCode AppendIndexNumber(const Feed::IndexNumber indexNumber);
00155
00167         ACTIV_CONTRIBUTION_SERVER_API StatusCode AppendKeyField(const Feed::FieldId fieldId, const IFieldType &iFieldType);
00168
00178         ACTIV_CONTRIBUTION_SERVER_API StatusCode AppendUndefinedKeyField(const Feed::FieldId fieldId);
00179
00191         ACTIV_CONTRIBUTION_SERVER_API StatusCode AppendField(const Feed::FieldId fieldId, const IFieldType &iFieldType);
00192
00202         ACTIV_CONTRIBUTION_SERVER_API StatusCode AppendUndefinedField(const Feed::FieldId fieldId);
00203
00209         ACTIV_CONTRIBUTION_SERVER_API bool IsInitialized() const;
00210
00218         ACTIV_CONTRIBUTION_SERVER_API std::string ToString() const;
00219
00227         ACTIV_CONTRIBUTION_SERVER_API StatusCode Write(bool flush = true);
00228
00235         ACTIV_CONTRIBUTION_SERVER_API StatusCode Flush();
00236
00237     private:
00238         std::auto_ptr<Private>  m_pPrivate;
00239     };
00240
00244     class SymbolRecordMessageBuilder
00245     {
00246     public:
00247         class Private;
00248
00252         ACTIV_CONTRIBUTION_SERVER_API SymbolRecordMessageBuilder(ContributionServerClient &contributionServerClient);
00253
00257         ACTIV_CONTRIBUTION_SERVER_API ~SymbolRecordMessageBuilder();
00258
00262         ACTIV_CONTRIBUTION_SERVER_API void Reset();
00263
00281         ACTIV_CONTRIBUTION_SERVER_API StatusCode AppendHeader(const bool isDelete, const Feed::TableId tableId,
00282             const Feed::PermissionId permissionId, const Feed::EventType eventType, const void * const pSymbol,
00283             const size_t symbolLength, uint8_t defaultRuleSet = Feed::SymbolRecordRuleDefinitions::RULE_SET_NONE,
00284             const Feed::UpdateId updateId = Feed::UPDATE_ID_COUNT_UNKNOWN);
00285
00297         ACTIV_CONTRIBUTION_SERVER_API StatusCode AppendField(const Feed::FieldId fieldId, const IFieldType &iFieldType);
00298
00310         ACTIV_CONTRIBUTION_SERVER_API StatusCode AppendFieldWithNoneRuleSet(const Feed::FieldId fieldId, const IFieldType &iFieldType);
00311
00324         ACTIV_CONTRIBUTION_SERVER_API StatusCode AppendFieldWithTranslatorRuleSet(const Feed::FieldId fieldId,
00325             const uint8_t fieldRules, const IFieldType &iFieldType);
00326
00339         ACTIV_CONTRIBUTION_SERVER_API StatusCode AppendFieldWithContentServerRuleSet(const Feed::FieldId fieldId,
00340             const uint8_t fieldRules, const IFieldType &iFieldType);
00341
00351         ACTIV_CONTRIBUTION_SERVER_API StatusCode AppendUndefinedField(const Feed::FieldId fieldId);
00352
00358         ACTIV_CONTRIBUTION_SERVER_API bool IsInitialized() const;
00359
00367         ACTIV_CONTRIBUTION_SERVER_API std::string ToString() const;
00368
00376         ACTIV_CONTRIBUTION_SERVER_API StatusCode Write(bool flush = true);
00377
00384         ACTIV_CONTRIBUTION_SERVER_API StatusCode Flush();
00385
00386     private:
00387         std::auto_ptr<Private>  m_pPrivate;
00388     };
00389
00400     ACTIV_CONTRIBUTION_SERVER_API ContributionServerClient(Application &application, ManagedEndPoint &managedEndPoint,
00401         const Settings &settings = Settings(), const std::string &componentId = defaultComponentId);
00402
00406     ACTIV_CONTRIBUTION_SERVER_API ~ContributionServerClient();
00407
00411     ACTIV_CONTRIBUTION_SERVER_API const Settings &GetSettings() const;
00412
00416     ACTIV_CONTRIBUTION_SERVER_API const Feed::TableTemplateList &GetTableTemplateList() const;
00417
00421     ACTIV_CONTRIBUTION_SERVER_API Feed::TableTemplateList &GetTableTemplateList();
00422
00426     ACTIV_CONTRIBUTION_SERVER_API SymbolRecordMessageBuilder &GetSymbolRecordMessageBuilder();
00427
00431     ACTIV_CONTRIBUTION_SERVER_API RecordMessageBuilder &GetRecordMessageBuilder();
00432
00436     ACTIV_CONTRIBUTION_SERVER_API const Feed::TableNo &GetMinimumTableNumber() const;
00437
00441     ACTIV_CONTRIBUTION_SERVER_API const Feed::TableNo &GetMaximumTableNumber() const;
00442
00446     ACTIV_CONTRIBUTION_SERVER_API static std::string GetDefaultName();
00447
00453     ACTIV_CONTRIBUTION_SERVER_API ApiInfo GetApiInfo() const;
00454
00455 private:
00459     ACTIV_CONTRIBUTION_SERVER_API UdpTransmitter &GetUdpTransmitter();
00460
00464     ACTIV_CONTRIBUTION_SERVER_API MessageRateThrottler &GetMessageRateThrottler();
00465
00466     std::auto_ptr<Private>  m_pPrivate;
00467 };
00468
00469 } // namespace ContributionServerApi
00470
00471 } // namespace ContentPlatform
00472
00473 } // namespace Activ
00474
00475 #endif // (!defined ACTIV_CONTRIBUTION_SERVER_API_CONTRIBUTION_SERVER_CLIENT_H)
Generated on Wed Oct 8 14:01:45 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivFieldTypes

CrcBlob.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FIELD_TYPES_CRC_BLOB_H)
00010 #define ACTIV_FIELD_TYPES_CRC_BLOB_H
00011
00012 #include "ActivMiddleware/ActivFieldTypes/External.h"
00013 #include "ActivMiddleware/ActivFieldTypes/IFieldType.h"
00014
00015 #include "ActivMiddleware/Misc/MemoryHelper.h"
00016
00017 #include "ActivMiddleware/ActivBase/ActivBase.h"
00018 #include "ActivMiddleware/ActivBase/StatusCodeException.h"
00019
00020 #include "ActivMiddleware/ActivCompress/ZlibCompressor.h"
00021
00022 namespace Activ
00023 {
00024
00025 class MessageBuilder;
00026 class MessageValidator;
00027
00028 // ---------------------------------------------------------------------------------------------------------------------------------
00029
00033 class CrcBlob : public IFieldType
00034 {
00035 public:
00036     static const FieldType FIELD_TYPE = FIELD_TYPE_CRC_BLOB;
00037
00038     using IFieldType::FromString;
00039     using IFieldType::Serialize;
00040     using IFieldType::SerializeBody;
00041     using IFieldType::SerializeLengthAndBody;
00042     using IFieldType::Deserialize;
00043     using IFieldType::DeserializeBody;
00044     using IFieldType::DeserializeLengthAndBody;
00045
00049     CrcBlob();
00050
00061     CrcBlob(const uint32_t crc, const uint8_t * const pData, const size_t size, const size_t sizeWhenDecompressed);
00062
00073     CrcBlob(const uint8_t * const pData, const size_t size);
00074
00080     CrcBlob(const CrcBlob &rhs);
00081
00085     virtual ~CrcBlob();
00086
00094     CrcBlob& operator=(const CrcBlob &rhs);
00095
00108     StatusCode Set(const uint32_t crc, const uint8_t * const pData, const size_t size, const size_t sizeWhenDecompressed);
00109
00123     StatusCode Set(const uint8_t * const pData, const size_t size);
00124
00136     StatusCode Get(uint32_t &crc, const uint8_t *&pData, size_t &size, size_t &sizeWhenDecompressed) const;
00137
00151     StatusCode Get(const uint8_t *&pData, size_t &size) const;
00152
00160     uint32_t GetCrc() const;
00161
00169     const uint8_t *GetData() const;
00170
00178     size_t GetSize() const;
00179
00187     size_t GetSizeWhenDecompressed() const;
00188
00196     uint32_t GetCrcCompressed() const;
00197
00205     const uint8_t *GetDataCompressed() const;
00206
00214     size_t GetSizeCompressed() const;
00215
00223     uint32_t GetCrcDecompressed() const;
00224
00232     const uint8_t *GetDataDecompressed() const;
00233
00241     size_t GetSizeDecompressed() const;
00242
00243     virtual void Reset();
00244     virtual void Clear();
00245
00254     ACTIV_FIELD_TYPES_API StatusCode Compare(const CrcBlob &rhs, int &result) const;
00255
00256     ACTIV_FIELD_TYPES_API virtual StatusCode Compare(const void * const pRhsSerializedBody, const size_t rhsSerializedBodyLength, int &result) const;
00257     ACTIV_FIELD_TYPES_API virtual StatusCode Convert(const IFieldType * const pIFieldType);
00258     ACTIV_FIELD_TYPES_API virtual std::string ToString() const;
00259
00269     ACTIV_FIELD_TYPES_API virtual std::string ToString(const bool isHexFormat) const;
00270
00271     ACTIV_FIELD_TYPES_API virtual StatusCode FromString(MessageValidator &messageValidator);
00272     ACTIV_FIELD_TYPES_API virtual std::string GetFromStringFormat() const;
00273     ACTIV_FIELD_TYPES_API virtual StatusCode Serialize(MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength) const;
00274     ACTIV_FIELD_TYPES_API virtual StatusCode SerializeBody(void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength) const;
00275     ACTIV_FIELD_TYPES_API virtual StatusCode SerializeLengthAndBody(MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength = MAX_SERIALIZED_BODY_LENGTH_UNDEFINED) const;
00276     ACTIV_FIELD_TYPES_API virtual StatusCode Deserialize(MessageValidator &messageValidator, const size_t maxSerializedBodyLength);
00277     ACTIV_FIELD_TYPES_API virtual StatusCode DeserializeBody(const void * const pSerializedBody, const size_t serializedBodyLength);
00278     ACTIV_FIELD_TYPES_API virtual StatusCode DeserializeLengthAndBody(MessageValidator &messageValidator, const size_t maxSerializedBodyLength = MAX_SERIALIZED_BODY_LENGTH_UNDEFINED);
00279     virtual size_t GetSerializedLength() const;
00280     virtual size_t GetSerializedBodyLength() const;
00281     ACTIV_FIELD_TYPES_API virtual StatusCode IsDifferent(const void * const pRhsSerializedBody, const size_t rhsSerializedBodyLength, bool &isDifferent) const;
00282
00291     StatusCode Compress() const;
00292
00304     StatusCode Compress(bool shouldSerializeCompressed, bool shouldForceSerializeCompressed = false);
00305
00314     StatusCode Decompress() const;
00315
00326     StatusCode Decompress(bool shouldSerializeDecompressed);
00327
00333     bool IsCompressed() const;
00334
00342     static size_t GetMaxSerializedLength(const size_t size);
00343
00351     static size_t GetMaxSerializedBodyLength(const size_t size);
00352
00365     ACTIV_FIELD_TYPES_API static StatusCode Compare(const void * const pLhsSerializedBody, const size_t lhsSerializedBodyLength, const void * const pRhsSerializedBody, const size_t rhsSerializedBodyLength, int &result);
00366
00381     ACTIV_FIELD_TYPES_API static StatusCode Serialize(MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength, const uint32_t crc, const uint8_t * const pData, const size_t size, const size_t sizeWhenDecompressed = 0);
00382
00398     ACTIV_FIELD_TYPES_API static StatusCode SerializeBody(void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength, const uint32_t crc, const uint8_t * const pData, const size_t size, const size_t sizeWhenDecompressed = 0);
00399
00414     ACTIV_FIELD_TYPES_API static StatusCode SerializeLengthAndBody(MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength, const uint32_t crc, const uint8_t * const pData, const size_t size, const size_t sizeWhenDecompressed = 0);
00415
00429     ACTIV_FIELD_TYPES_API static StatusCode Deserialize(MessageValidator &messageValidator, const size_t maxSerializedBodyLength, uint32_t &crc, const uint8_t *&pData, size_t &size, size_t &sizeWhenDecompressed);
00430
00445     ACTIV_FIELD_TYPES_API static StatusCode DeserializeBody(const void * const pSerializedBody, const size_t serializedBodyLength, uint32_t &crc, const uint8_t *&pData, size_t &size, size_t &sizeWhenDecompressed);
00446
00460     ACTIV_FIELD_TYPES_API static StatusCode DeserializeLengthAndBody(MessageValidator &messageValidator, const size_t maxSerializedBodyLength, uint32_t &crc, const uint8_t *&pData, size_t &size, size_t &sizeWhenDecompressed);
00461
00474     ACTIV_FIELD_TYPES_API static StatusCode ValidateSerializedLengthAndBody(MessageValidator &messageValidator, size_t &serializedBodyOffset, size_t &serializedBodyLength);
00475
00483     static bool IsValidSerializedBodyLength(const size_t serializedBodyLength);
00484
00494     ACTIV_FIELD_TYPES_API static uint32_t CalculateCrc(const uint8_t * const pData, const size_t size, const uint32_t intitialCrc = 0);
00495
00508     static StatusCode Compress(const uint8_t * const pSource, const size_t sourceLength, uint8_t * const pTarget, const size_t targetSize, size_t &targetLength);
00509
00522     static StatusCode Decompress(const uint8_t * const pSource, const size_t sourceLength, uint8_t * const pTarget, const size_t targetSize, size_t &targetLength);
00523
00524 private:
00525     mutable uint32_t        m_crcCompressed;
00526     mutable uint8_t *       m_pDataCompressed;
00527     mutable size_t          m_allocatedSizeCompressed;
00528     mutable size_t          m_sizeCompressed;
00529
00530     mutable uint32_t        m_crcDecompressed;
00531     mutable uint8_t *       m_pDataDecompressed;
00532     mutable size_t          m_allocatedSizeDecompressed;
00533     mutable size_t          m_sizeDecompressed;
00534
00535     uint32_t                m_crc;
00536     uint8_t *               m_pData;
00537     size_t                  m_size;
00538     size_t                  m_sizeWhenDecompressed;
00539
00540     static const uint32_t   m_crcTable[256];
00541 };
00542
00543 // ---------------------------------------------------------------------------------------------------------------------------------
00544
00545 inline CrcBlob::CrcBlob() :
00546     IFieldType(FIELD_TYPE),
00547     m_allocatedSizeCompressed(0),
00548     m_allocatedSizeDecompressed(0)
00549 {
00550     m_isInitialized = false;
00551 }
00552
00553 // ---------------------------------------------------------------------------------------------------------------------------------
00554
00555 inline CrcBlob::CrcBlob(const uint32_t crc, const uint8_t * const pData, const size_t size, const size_t sizeWhenDecompressed) :
00556     IFieldType(FIELD_TYPE),
00557     m_allocatedSizeCompressed(0),
00558     m_allocatedSizeDecompressed(0)
00559 {
00560     ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, Set(crc, pData, size, sizeWhenDecompressed));
00561 }
00562
00563 // ---------------------------------------------------------------------------------------------------------------------------------
00564
00565 inline CrcBlob::CrcBlob(const uint8_t * const pData, const size_t size) :
00566     IFieldType(FIELD_TYPE),
00567     m_allocatedSizeCompressed(0),
00568     m_allocatedSizeDecompressed(0)
00569 {
00570     ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, Set(pData, size));
00571 }
00572
00573 // ---------------------------------------------------------------------------------------------------------------------------------
00574
00575 inline CrcBlob::CrcBlob(const CrcBlob &rhs) :
00576     IFieldType(FIELD_TYPE),
00577     m_allocatedSizeCompressed(0),
00578     m_allocatedSizeDecompressed(0)
00579 {
00580     if (rhs.IsInitialized())
00581         ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, Set(rhs.m_crc, rhs.m_pData, rhs.m_size, rhs.m_sizeWhenDecompressed));
00582     else
00583         m_isInitialized = false;
00584 }
00585
00586 // ---------------------------------------------------------------------------------------------------------------------------------
00587
00588 inline CrcBlob::~CrcBlob()
00589 {
00590     if (0 != m_allocatedSizeCompressed)
00591         std::free(m_pDataCompressed);
00592     if (0 != m_allocatedSizeDecompressed)
00593         std::free(m_pDataDecompressed);
00594 }
00595
00596 // ---------------------------------------------------------------------------------------------------------------------------------
00597
00598 inline CrcBlob& CrcBlob::operator=(const CrcBlob &rhs)
00599 {
00600     if (this != &rhs)
00601     {
00602         if (rhs.IsInitialized())
00603         {
00604             ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, Set(rhs.m_crc, rhs.m_pData, rhs.m_size, rhs.m_sizeWhenDecompressed));
00605         }
00606         else
00607         {
00608             Reset();
00609         }
00610     }
00611
00612     return *this;
00613 }
00614
00615 // ---------------------------------------------------------------------------------------------------------------------------------
00616
00617 inline StatusCode CrcBlob::Set(const uint32_t crc, const uint8_t * const pData, const size_t size, const size_t sizeWhenDecompressed)
00618 {
00619     if (0 == size)
00620         return STATUS_CODE_INVALID_PARAMETER;
00621
00622     if (0 == sizeWhenDecompressed)
00623     {
00624         if (size > m_allocatedSizeDecompressed)
00625         {
00626             const size_t allocatedSize = (4 * (((std::max<size_t>(m_allocatedSizeDecompressed + (m_allocatedSizeDecompressed / 2), size) - 1) / 4) + 1));
00627             uint8_t * const pAllocated = static_cast<uint8_t *>(((0 != m_allocatedSizeDecompressed) ? std::realloc(m_pDataDecompressed, allocatedSize) : std::malloc(allocatedSize)));
00628
00629             if (0 == pAllocated)
00630                 return STATUS_CODE_HEAP_EMPTY;
00631
00632             m_allocatedSizeDecompressed = allocatedSize;
00633             m_pDataDecompressed = pAllocated;
00634         }
00635
00636         m_crcDecompressed = crc;
00637         MemoryCopy(m_pDataDecompressed, pData, size);
00638         m_sizeDecompressed = size;
00639
00640         m_sizeCompressed = 0;
00641
00642         m_crc = crc;
00643         m_pData = m_pDataDecompressed;
00644         m_size = size;
00645         m_sizeWhenDecompressed = sizeWhenDecompressed;
00646
00647         m_isInitialized = true;
00648     }
00649     else
00650     {
00651         if (size > m_allocatedSizeCompressed)
00652         {
00653             const size_t allocatedSize = (4 * (((std::max<size_t>(m_allocatedSizeCompressed + (m_allocatedSizeCompressed / 2), size) - 1) / 4) + 1));
00654             uint8_t * const pAllocated = static_cast<uint8_t *>(((0 != m_allocatedSizeCompressed) ? std::realloc(m_pDataCompressed, allocatedSize) : std::malloc(allocatedSize)));
00655
00656             if (0 == pAllocated)
00657                 return STATUS_CODE_HEAP_EMPTY;
00658
00659             m_allocatedSizeCompressed = allocatedSize;
00660             m_pDataCompressed = pAllocated;
00661         }
00662
00663         m_crcCompressed = crc;
00664         MemoryCopy(m_pDataCompressed, pData, size);
00665         m_sizeCompressed = size;
00666
00667         m_sizeDecompressed = 0;
00668
00669         m_crc = crc;
00670         m_pData = m_pDataCompressed;
00671         m_size = size;
00672         m_sizeWhenDecompressed = sizeWhenDecompressed;
00673
00674         m_isInitialized = true;
00675     }
00676
00677     return STATUS_CODE_SUCCESS;
00678 }
00679
00680 // ---------------------------------------------------------------------------------------------------------------------------------
00681
00682 inline StatusCode CrcBlob::Set(const uint8_t * const pData, const size_t size)
00683 {
00684     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, Set(CalculateCrc(pData, size), pData, size, 0));
00685
00686     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, Compress(true));
00687
00688     return STATUS_CODE_SUCCESS;
00689 }
00690
00691 // ---------------------------------------------------------------------------------------------------------------------------------
00692
00693 inline StatusCode CrcBlob::Get(uint32_t &crc, const uint8_t *&pData, size_t &size, size_t &sizeWhenDecompressed) const
00694 {
00695     if (!IsInitialized())
00696         return STATUS_CODE_NOT_INITIALIZED;
00697
00698     crc = m_crc;
00699     pData = m_pData;
00700     size = m_size;
00701     sizeWhenDecompressed = m_sizeWhenDecompressed;
00702
00703     return STATUS_CODE_SUCCESS;
00704 }
00705
00706 // ---------------------------------------------------------------------------------------------------------------------------------
00707
00708 inline StatusCode CrcBlob::Get(const uint8_t *&pData, size_t &size) const
00709 {
00710     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, Decompress());
00711
00712     pData = m_pDataDecompressed;
00713     size = m_sizeDecompressed;
00714
00715     return STATUS_CODE_SUCCESS;
00716 }
00717
00718 // ---------------------------------------------------------------------------------------------------------------------------------
00719
00720 inline uint32_t CrcBlob::GetCrc() const
00721 {
00722     if (!IsInitialized())
00723         ACTIV_THROW(StatusCodeException, STATUS_CODE_NOT_INITIALIZED);
00724
00725     return m_crc;
00726 }
00727
00728 // ---------------------------------------------------------------------------------------------------------------------------------
00729
00730 inline const uint8_t *CrcBlob::GetData() const
00731 {
00732     if (!IsInitialized())
00733         ACTIV_THROW(StatusCodeException, STATUS_CODE_NOT_INITIALIZED);
00734
00735     return m_pData;
00736 }
00737
00738 // ---------------------------------------------------------------------------------------------------------------------------------
00739
00740 inline size_t CrcBlob::GetSize() const
00741 {
00742     if (!IsInitialized())
00743         ACTIV_THROW(StatusCodeException, STATUS_CODE_NOT_INITIALIZED);
00744
00745     return m_size;
00746 }
00747
00748 // ---------------------------------------------------------------------------------------------------------------------------------
00749
00750 inline size_t CrcBlob::GetSizeWhenDecompressed() const
00751 {
00752     if (!IsInitialized())
00753         ACTIV_THROW(StatusCodeException, STATUS_CODE_NOT_INITIALIZED);
00754
00755     return m_sizeWhenDecompressed;
00756 }
00757
00758 // ---------------------------------------------------------------------------------------------------------------------------------
00759
00760 inline uint32_t CrcBlob::GetCrcCompressed() const
00761 {
00762     ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, Compress());
00763
00764     return m_crcCompressed;
00765 }
00766
00767 // ---------------------------------------------------------------------------------------------------------------------------------
00768
00769 inline const uint8_t *CrcBlob::GetDataCompressed() const
00770 {
00771     ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, Compress());
00772
00773     return m_pDataCompressed;
00774 }
00775
00776 // ---------------------------------------------------------------------------------------------------------------------------------
00777
00778 inline size_t CrcBlob::GetSizeCompressed() const
00779 {
00780     ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, Compress());
00781
00782     return m_sizeCompressed;
00783 }
00784
00785 // ---------------------------------------------------------------------------------------------------------------------------------
00786
00787 inline uint32_t CrcBlob::GetCrcDecompressed() const
00788 {
00789     ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, Decompress());
00790
00791     return m_crcDecompressed;
00792 }
00793
00794 // ---------------------------------------------------------------------------------------------------------------------------------
00795
00796 inline const uint8_t *CrcBlob::GetDataDecompressed() const
00797 {
00798     ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, Decompress());
00799
00800     return m_pDataDecompressed;
00801 }
00802
00803 // ---------------------------------------------------------------------------------------------------------------------------------
00804
00805 inline size_t CrcBlob::GetSizeDecompressed() const
00806 {
00807     ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, Decompress());
00808
00809     return m_sizeDecompressed;
00810 }
00811
00812 // ---------------------------------------------------------------------------------------------------------------------------------
00813
00814 inline void CrcBlob::Reset()
00815 {
00816     m_isInitialized = false;
00817 }
00818
00819 // ---------------------------------------------------------------------------------------------------------------------------------
00820
00821 inline void CrcBlob::Clear()
00822 {
00823     if (0 != m_allocatedSizeCompressed)
00824     {
00825         std::free(m_pDataCompressed);
00826         m_allocatedSizeCompressed = 0;
00827     }
00828
00829     if (0 != m_allocatedSizeDecompressed)
00830     {
00831         std::free(m_pDataDecompressed);
00832         m_allocatedSizeDecompressed = 0;
00833     }
00834
00835     m_isInitialized = false;
00836 }
00837
00838 // ---------------------------------------------------------------------------------------------------------------------------------
00839
00840 inline size_t CrcBlob::GetSerializedLength() const
00841 {
00842     return (IsInitialized() ? GetMaxSerializedLength(m_size) : 0);
00843 }
00844
00845 // ---------------------------------------------------------------------------------------------------------------------------------
00846
00847 inline size_t CrcBlob::GetSerializedBodyLength() const
00848 {
00849     return (IsInitialized() ? GetMaxSerializedBodyLength(m_size) : 0);
00850 }
00851
00852 // ---------------------------------------------------------------------------------------------------------------------------------
00853
00854 inline StatusCode CrcBlob::Compress() const
00855 {
00856     if (!IsInitialized())
00857         return STATUS_CODE_NOT_INITIALIZED;
00858
00859     if (0 == m_sizeCompressed)
00860     {
00861         const size_t sizeCompressed = ACTIV_COMPRESS_GET_DESTINATION_BUFFER_LENGTH(m_sizeDecompressed);
00862
00863         if (sizeCompressed > m_allocatedSizeCompressed)
00864         {
00865             const size_t allocatedSize = (4 * (((std::max<size_t>(m_allocatedSizeCompressed + (m_allocatedSizeCompressed / 2), sizeCompressed) - 1) / 4) + 1));
00866             uint8_t * const pAllocated = static_cast<uint8_t *>(((0 != m_allocatedSizeCompressed) ? std::realloc(m_pDataCompressed, allocatedSize) : std::malloc(allocatedSize)));
00867
00868             if (0 == pAllocated)
00869                 return STATUS_CODE_HEAP_EMPTY;
00870
00871             m_allocatedSizeCompressed = allocatedSize;
00872             m_pDataCompressed = pAllocated;
00873         }
00874
00875         ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, Compress(m_pDataDecompressed, m_sizeDecompressed, m_pDataCompressed, m_allocatedSizeCompressed, m_sizeCompressed));
00876
00877         m_crcCompressed = CalculateCrc(m_pDataCompressed, m_sizeCompressed);
00878     }
00879
00880     return STATUS_CODE_SUCCESS;
00881 }
00882
00883 // ---------------------------------------------------------------------------------------------------------------------------------
00884
00885 inline StatusCode CrcBlob::Compress(bool shouldSerializeCompressed, bool shouldForceSerializeCompressed)
00886 {
00887     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, Compress());
00888
00889     if ((0 == m_sizeWhenDecompressed) && (((shouldSerializeCompressed) && (m_sizeCompressed < m_sizeDecompressed)) || (shouldForceSerializeCompressed)))
00890     {
00891         m_crc = m_crcCompressed;
00892         m_pData = m_pDataCompressed;
00893         m_size = m_sizeCompressed;
00894         m_sizeWhenDecompressed = m_sizeDecompressed;
00895     }
00896
00897     return STATUS_CODE_SUCCESS;
00898 }
00899
00900 // ---------------------------------------------------------------------------------------------------------------------------------
00901
00902 inline StatusCode CrcBlob::Decompress() const
00903 {
00904     if (!IsInitialized())
00905         return STATUS_CODE_NOT_INITIALIZED;
00906
00907     if (0 == m_sizeDecompressed)
00908     {
00909         if (m_sizeWhenDecompressed > m_allocatedSizeDecompressed)
00910         {
00911             const size_t allocatedSize = (4 * (((std::max<size_t>(m_allocatedSizeDecompressed + (m_allocatedSizeDecompressed / 2), m_sizeWhenDecompressed) - 1) / 4) + 1));
00912             uint8_t * const pAllocated = static_cast<uint8_t *>(((0 != m_allocatedSizeDecompressed) ? std::realloc(m_pDataDecompressed, allocatedSize) : std::malloc(allocatedSize)));
00913
00914             if (0 == pAllocated)
00915                 return STATUS_CODE_HEAP_EMPTY;
00916
00917             m_allocatedSizeDecompressed = allocatedSize;
00918             m_pDataDecompressed = pAllocated;
00919         }
00920
00921         ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, Decompress(m_pDataCompressed, m_sizeCompressed, m_pDataDecompressed, m_allocatedSizeDecompressed, m_sizeDecompressed));
00922
00923         m_crcDecompressed = CalculateCrc(m_pDataDecompressed, m_sizeDecompressed);
00924     }
00925
00926     return STATUS_CODE_SUCCESS;
00927 }
00928
00929 // ---------------------------------------------------------------------------------------------------------------------------------
00930
00931 inline StatusCode CrcBlob::Decompress(bool shouldSerializeDecompressed)
00932 {
00933     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, Decompress());
00934
00935     if ((shouldSerializeDecompressed) && (0 != m_sizeWhenDecompressed))
00936     {
00937         m_crc = m_crcDecompressed;
00938         m_pData = m_pDataDecompressed;
00939         m_size = m_sizeDecompressed;
00940         m_sizeWhenDecompressed = 0;
00941     }
00942
00943     return STATUS_CODE_SUCCESS;
00944 }
00945
00946 // ---------------------------------------------------------------------------------------------------------------------------------
00947
00948 inline bool CrcBlob::IsCompressed() const
00949 {
00950     return (IsInitialized() ? (0 != m_sizeWhenDecompressed) : false);
00951 }
00952
00953 // ---------------------------------------------------------------------------------------------------------------------------------
00954
00955 inline size_t CrcBlob::GetMaxSerializedLength(const size_t size)
00956 {
00957     return (sizeof(uint32_t) + GetMaxSerializedBodyLength(size));
00958 }
00959
00960 // ---------------------------------------------------------------------------------------------------------------------------------
00961
00962 inline size_t CrcBlob::GetMaxSerializedBodyLength(const size_t size)
00963 {
00964     return (sizeof(uint32_t) + sizeof(uint32_t) + size);
00965 }
00966
00967 // ---------------------------------------------------------------------------------------------------------------------------------
00968
00969 inline bool CrcBlob::IsValidSerializedBodyLength(const size_t serializedBodyLength)
00970 {
00971     return ((serializedBodyLength > GetMaxSerializedBodyLength(0)) && (serializedBodyLength <= UINT32_MAX));
00972 }
00973
00974 // ---------------------------------------------------------------------------------------------------------------------------------
00975
00976 inline StatusCode CrcBlob::Compress(const uint8_t * const pSource, const size_t sourceLength, uint8_t * const pTarget, const size_t targetSize, size_t &targetLength)
00977 {
00978     return ZlibCompressor().Compress(pTarget, targetSize, pSource, sourceLength, targetLength);
00979 }
00980
00981 // ---------------------------------------------------------------------------------------------------------------------------------
00982
00983 inline StatusCode CrcBlob::Decompress(const uint8_t * const pSource, const size_t sourceLength, uint8_t * const pTarget, const size_t targetSize, size_t &targetLength)
00984 {
00985     return ZlibCompressor().Decompress(pTarget, targetSize, pSource, sourceLength, targetLength);
00986 }
00987
00988 // ---------------------------------------------------------------------------------------------------------------------------------
00989 // ---------------------------------------------------------------------------------------------------------------------------------
00990
00994 template<>
00995 class FieldTypeToClass<FIELD_TYPE_CRC_BLOB>
00996 {
00997 public:
00998     typedef CrcBlob Type;
00999 };
01000
01001 } // namespace Activ
01002
01003 #endif // (!defined ACTIV_FIELD_TYPES_CRC_BLOB_H)
Generated on Wed Oct 8 14:01:48 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

CrtException.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_BASE_CRT_EXCEPTION_H)
00010 #define ACTIV_BASE_CRT_EXCEPTION_H
00011
00012 #include "ActivMiddleware/ActivBase/Exception.h"
00013
00014 namespace Activ
00015 {
00016
00022 class CrtException : public Exception
00023 {
00024 public:
00033     ACTIV_BASE_EXPORTED_API CrtException(const char *file, const char *function, uint_fast32_t line, const uint_fast32_t errorCode);
00034
00035     ACTIV_BASE_EXPORTED_API virtual std::string ToString() const;
00036 };
00037
00038 } // namespace Activ
00039
00040 #endif // (!defined ACTIV_BASE_CRT_EXCEPTION_H)
Generated on Wed Oct 8 14:01:46 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » Misc

CrtHelper.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_MISC_CRT_HELPER_H)
00010 #define ACTIV_MISC_CRT_HELPER_H
00011
00012 #include "ActivMiddleware/Activ.h"
00013
00014 #include <time.h>
00015
00016 namespace Activ
00017 {
00018
00019 #if (defined ACTIV_PLATFORM_WINDOWS)
00020
00021 // ---------------------------------------------------------------------------------------------------------------------------------
00022
00031 inline tm *localtime_r(const time_t * const pTime, tm * const pTm)
00032 {
00033     tm * const pRes = ::localtime(pTime);
00034
00035     if (ACTIV_UNLIKELY(NULL == pRes))
00036         return NULL;
00037
00038     *pTm = *pRes;
00039
00040     return pTm;
00041 }
00042
00043 // ---------------------------------------------------------------------------------------------------------------------------------
00044
00053 inline tm *gmtime_r(const time_t * const pTime, tm * const pTm)
00054 {
00055     tm * const pRes = ::gmtime(pTime);
00056
00057     if (ACTIV_UNLIKELY(NULL == pRes))
00058         return NULL;
00059
00060     *pTm = *pRes;
00061
00062     return pTm;
00063 }
00064
00065 #elif (defined ACTIV_PLATFORM_POSIX)
00066
00067 using ::localtime_r;
00068 using ::gmtime_r;
00069
00070 #else
00071 #error Configure for this platform
00072 #endif
00073
00074 } // namespace Activ
00075
00076 #endif // (!defined ACTIV_MISC_CRT_HELPER_H)
Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

CtrlHandler.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_BASE_CTRL_HANDLER_H)
00010 #define ACTIV_BASE_CTRL_HANDLER_H
00011
00012 #include "ActivMiddleware/ActivBase/External.h"
00013
00014 #if (defined ACTIV_PLATFORM_WINDOWS)
00015 #include "ActivMiddleware/ActivBase/Atomic.h"
00016 #elif (defined ACTIV_PLATFORM_POSIX)
00017 #include "ActivMiddleware/ActivBase/Thread.h"
00018
00019 #include <signal.h>
00020 #else
00021 #error Configure for this platform
00022 #endif
00023
00024 namespace Activ
00025 {
00026
00032 class CtrlHandler : private boost::noncopyable
00033 {
00034 public:
00038     enum EventType
00039     {
00040         CTRL_C,
00041         CTRL_BREAK,
00042         CTRL_EXIT_PROCESS,
00043         CTRL_LOGOFF_USER,
00044         CTRL_SHUTDOWN_MACHINE
00045     };
00046
00052     ACTIV_BASE_EXPORTED_API CtrlHandler();
00053
00057     ACTIV_BASE_EXPORTED_API virtual ~CtrlHandler();
00058
00059 protected:
00070     ACTIV_BASE_EXPORTED_API virtual bool OnEvent(const EventType eventType);
00071
00072 private:
00073 #if (defined ACTIV_PLATFORM_WINDOWS)
00074
00075     static AtomicPointer<CtrlHandler>   m_pCtrlHandler;
00076
00077     ACTIV_BASE_LOCAL_API static BOOL WINAPI HandlerFunction(DWORD ctrlType);
00078
00079 #elif (defined ACTIV_PLATFORM_POSIX)
00080
00084     class Thread : public Activ::Thread
00085     {
00086     public:
00087         ACTIV_BASE_LOCAL_API Thread(CtrlHandler &ctrlHandler);
00088
00089     private:
00090         ACTIV_BASE_LOCAL_API virtual StatusCode Process(void *pData);
00091
00092         CtrlHandler &m_ctrlHandler;
00093     };
00094
00095     Thread          m_thread;
00096     volatile bool   m_isShuttingDown;
00097     sigset_t        m_originalSigSet;
00098     sigset_t        m_blockSigSet;
00099
00100 #else
00101 #error Configure for this platform
00102 #endif
00103 };
00104
00105 } // namespace Activ
00106
00107 #endif // (!defined ACTIV_BASE_CTRL_HANDLER_H)
Generated on Wed Oct 8 14:01:46 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » Misc

CurlFtpHelper.h

Go to the documentation of this file.
00001
00011 #if (!defined ACTIV_MISC_CURL_FTP_HELPER_H)
00012 #define ACTIV_MISC_CURL_FTP_HELPER_H
00013
00014 #include "ActivMiddleware/ActivBase/StatusCodeException.h"
00015 #include "ActivMiddleware/ActivBase/OsException.h"
00016 #include "ActivMiddleware/ActivBase/File.h"
00017 #include "ActivMiddleware/Misc/FtpParse.h"
00018 #include "ActivMiddleware/Misc/CrtHelper.h"
00019
00020 #include "curl/curl.h"
00021
00022 #include "IFtpHelper.h"
00023
00024 #include <string>
00025 #include <vector>
00026 #include <time.h>
00027
00028 namespace Activ
00029 {
00030
00034 class CurlFtpHelper : public IFtpHelper
00035 {
00036 public:
00037
00041     class CurlInitializeHelper
00042     {
00043     public:
00047         CurlInitializeHelper();
00048
00052         ~CurlInitializeHelper();
00053     };
00054
00068     CurlFtpHelper(const std::string &server, const std::string &username = "", const std::string &password = "", uint32_t port = IFtpHelper::DEFAULT_FTP_PORT, bool useEpsv = false, const std::string &curlLogFilename = "", uint32_t timeout = IFtpHelper::DEFAULT_FTP_TIMEOUT, uint32_t lowSpeedLimit = IFtpHelper::DEFAULT_FTP_LOW_SPEED_LIMIT, uint32_t lowSpeedTime = IFtpHelper::DEFAULT_FTP_LOW_SPEED_TIME);
00069
00070     virtual ~CurlFtpHelper();
00071
00072     virtual StatusCodeHelper Connect();
00073     virtual StatusCodeHelper Disconnect();
00074     virtual StatusCodeHelper GetFileList(FileInfoList &fileInfoList, const std::string &remoteDirectory = "");
00075     virtual StatusCodeHelper GetFile(const std::string &remoteFilename, const std::string &localFilename, const std::string &remoteDirectory = "");
00076     virtual StatusCodeHelper DeleteFile(const std::string &remoteFilename, const std::string &remoteDirectory = "");
00077     virtual StatusCodeHelper DeleteFile(const FileInfoList &fileInfoList, const std::string &remoteDirectory = "");
00078     virtual StatusCodeHelper GetAndDeleteFile(const std::string &remoteFilename, const std::string &localFilename, const std::string &remoteDirectory = "");
00079
00080     virtual bool IsConnected() const;
00081
00085     void SetTimeout(uint32_t timeout);
00086     void SetLowSpeedLimit(uint32_t lowSpeedLimit);
00087     void SetLowSpeedTime(uint32_t lowSpeedTime);
00088     void SetUseEpsv(bool useEpsv);
00089     void SetCurlLogFilename(const std::string &logFilename);
00090
00094     uint32_t GetTimeout() const;
00095     uint32_t GetLowSpeedLimit() const;
00096     uint32_t GetLowSpeedTime() const;
00097     bool GetUseEpsv() const;
00098
00102     static void Initialize();
00103
00107     static void CleanUp();
00108
00109 private:
00110
00111     class CallbackData
00112     {
00113     public:
00114         virtual ~CallbackData();
00115         virtual size_t AppendData(void *ptr, size_t size);
00116     };
00117
00118     class FileListCallbackData : public CallbackData
00119     {
00120     public:
00121         virtual size_t AppendData(void *ptr, size_t size);
00122         StatusCodeHelper GetFileList(FileInfoList &fileInfoList, bool includeDirectories);
00123
00124     private:
00125         std::string m_data;
00126     };
00127
00128     class GetFileCallbackData : CallbackData
00129     {
00130     public:
00131         GetFileCallbackData(const std::string &filename);
00132         virtual size_t AppendData(void *ptr, size_t size);
00133
00134     private:
00135         File m_file;
00136     };
00137
00138     static size_t CallbackFunction(void *ptr, size_t size, size_t nmemb, void *stream);
00139
00140     std::string GetUrl() const;
00141
00142     CURL                *m_pCurl;
00143     bool                m_useEpsv;
00144     FILE                *m_pCurlLogFileHandle;
00145     uint32_t            m_timeout;
00146     uint32_t            m_lowSpeedLimit;
00147     uint32_t            m_lowSpeedTime;
00148 };
00149
00150 // ---------------------------------------------------------------------------------------------------------------------------------
00151 // ---------------------------------------------------------------------------------------------------------------------------------
00152
00153 inline CurlFtpHelper::CurlInitializeHelper::CurlInitializeHelper()
00154 {
00155     CurlFtpHelper::Initialize();
00156 }
00157
00158 // ---------------------------------------------------------------------------------------------------------------------------------
00159
00160 inline CurlFtpHelper::CurlInitializeHelper::~CurlInitializeHelper()
00161 {
00162     CurlFtpHelper::CleanUp();
00163 }
00164
00165 // ---------------------------------------------------------------------------------------------------------------------------------
00166 // ---------------------------------------------------------------------------------------------------------------------------------
00167
00168 inline void CurlFtpHelper::Initialize()
00169 {
00170     curl_global_init(CURL_GLOBAL_ALL);
00171 }
00172
00173 // ---------------------------------------------------------------------------------------------------------------------------------
00174
00175 inline void CurlFtpHelper::CleanUp()
00176 {
00177     curl_global_cleanup();
00178 }
00179
00180 // ---------------------------------------------------------------------------------------------------------------------------------
00181
00182 inline CurlFtpHelper::CurlFtpHelper(const std::string &server, const std::string &username, const std::string &password, uint32_t port, bool useEpsv, const std::string &curlLogFilename, uint32_t timeout, uint32_t lowSpeedLimit, uint32_t lowSpeedTime) :
00183     IFtpHelper(server, username, password, port),
00184     m_pCurl(0),
00185     m_useEpsv(useEpsv),
00186     m_pCurlLogFileHandle(0),
00187     m_timeout(timeout),
00188     m_lowSpeedLimit(lowSpeedLimit),
00189     m_lowSpeedTime(lowSpeedTime)
00190 {
00191     char *pEscapedUsername = curl_escape(username.c_str(), static_cast<int>(username.size()));
00192     char *pEscapedPassword = curl_escape(password.c_str(), static_cast<int>(password.size()));
00193
00194     m_username = std::string(pEscapedUsername);
00195     m_password = std::string(pEscapedPassword);
00196
00197     curl_free(pEscapedUsername);
00198     curl_free(pEscapedPassword);
00199
00200     if ("" != curlLogFilename)
00201         m_pCurlLogFileHandle = fopen(curlLogFilename.c_str(), "a+");
00202 }
00203
00204 // ---------------------------------------------------------------------------------------------------------------------------------
00205
00206 inline CurlFtpHelper::~CurlFtpHelper()
00207 {
00208     Disconnect();
00209     if (m_pCurlLogFileHandle)
00210         fclose(m_pCurlLogFileHandle);
00211 }
00212
00213 // ---------------------------------------------------------------------------------------------------------------------------------
00214
00215 inline bool CurlFtpHelper::IsConnected() const
00216 {
00217     return (0 != m_pCurl);
00218 }
00219
00220 // ---------------------------------------------------------------------------------------------------------------------------------
00221
00222 inline std::string CurlFtpHelper::GetUrl() const
00223 {
00224     return "ftp://" + m_username + ":" + m_password + "@" + m_server + ":" + TypeToString(m_port) + "/";
00225 }
00226
00227 // ---------------------------------------------------------------------------------------------------------------------------------
00228
00229 inline StatusCodeHelper CurlFtpHelper::Connect()
00230 {
00231     if (IsConnected())
00232         return STATUS_CODE_ALREADY_CONNECTED;
00233
00234     m_pCurl = curl_easy_init();
00235
00236     if (0 == m_pCurl)
00237         return StatusCodeHelper(STATUS_CODE_FAILURE, "failed to to initialize curl");
00238     try
00239     {
00240         const std::string url = GetUrl();
00241
00242         ACTIV_THROW_RESULT_IF(CURLE_OK, !=, curl_easy_setopt(m_pCurl, CURLOPT_URL, url.c_str()));
00243         ACTIV_THROW_RESULT_IF(CURLE_OK, !=, curl_easy_setopt(m_pCurl, CURLOPT_NOPROGRESS, 1));
00244         ACTIV_THROW_RESULT_IF(CURLE_OK, !=, curl_easy_setopt(m_pCurl, CURLOPT_NOBODY, 1));
00245         ACTIV_THROW_RESULT_IF(CURLE_OK, !=, curl_easy_setopt(m_pCurl, CURLOPT_WRITEFUNCTION, CallbackFunction));
00246         ACTIV_THROW_RESULT_IF(CURLE_OK, !=, curl_easy_setopt(m_pCurl, CURLOPT_TIMEOUT, m_timeout));
00247         ACTIV_THROW_RESULT_IF(CURLE_OK, !=, curl_easy_setopt(m_pCurl, CURLOPT_LOW_SPEED_LIMIT, m_lowSpeedLimit));
00248         ACTIV_THROW_RESULT_IF(CURLE_OK, !=, curl_easy_setopt(m_pCurl, CURLOPT_LOW_SPEED_TIME, m_lowSpeedTime));
00249
00250         if (!m_useEpsv)
00251             ACTIV_THROW_RESULT_IF(CURLE_OK, !=, curl_easy_setopt(m_pCurl, CURLOPT_FTP_USE_EPSV, 0));
00252
00253         if (NULL != m_pCurlLogFileHandle)
00254         {
00255             ACTIV_THROW_RESULT_IF(CURLE_OK, !=, curl_easy_setopt(m_pCurl, CURLOPT_STDERR , m_pCurlLogFileHandle));
00256             ACTIV_THROW_RESULT_IF(CURLE_OK, !=, curl_easy_setopt(m_pCurl, CURLOPT_VERBOSE , 1));
00257         }
00258
00259         ACTIV_THROW_RESULT_IF(CURLE_OK, !=, curl_easy_perform(m_pCurl));
00260     }
00261     catch (Exception &exception)
00262     {
00263         Disconnect();
00264         return StatusCodeHelper(STATUS_CODE_FAILURE, curl_easy_strerror(static_cast<CURLcode>(exception.m_errorCode)));
00265     }
00266
00267     return STATUS_CODE_SUCCESS;
00268 }
00269
00270 // ---------------------------------------------------------------------------------------------------------------------------------
00271
00272 inline StatusCodeHelper CurlFtpHelper::Disconnect()
00273 {
00274     if (!IsConnected())
00275         return STATUS_CODE_NOT_CONNECTED;
00276
00277     if (0 != m_pCurl)
00278         curl_easy_cleanup(m_pCurl);
00279
00280     m_pCurl = 0;
00281
00282     return STATUS_CODE_SUCCESS;
00283 }
00284
00285 // ---------------------------------------------------------------------------------------------------------------------------------
00286
00287 inline StatusCodeHelper CurlFtpHelper::GetFileList(FileInfoList &fileinfoList, const std::string &remoteDirectory)
00288 {
00289     if (!IsConnected())
00290         return STATUS_CODE_NOT_CONNECTED;
00291
00292     FileListCallbackData fileListCallBackData;
00293
00294     try
00295     {
00296         const std::string url = (remoteDirectory.empty() ? GetUrl() : GetUrl() + remoteDirectory + "/");
00297
00298         ACTIV_THROW_RESULT_IF(CURLE_OK, !=, curl_easy_setopt(m_pCurl, CURLOPT_URL, url.c_str()));
00299         ACTIV_THROW_RESULT_IF(CURLE_OK, !=, curl_easy_setopt(m_pCurl, CURLOPT_NOBODY, 0));
00300         ACTIV_THROW_RESULT_IF(CURLE_OK, !=, curl_easy_setopt(m_pCurl, CURLOPT_WRITEDATA, &fileListCallBackData));
00301
00302         ACTIV_THROW_RESULT_IF(CURLE_OK, !=, curl_easy_perform(m_pCurl));
00303     }
00304     catch (Exception &exception)
00305     {
00306         if (CURLE_COULDNT_CONNECT == exception.m_errorCode)
00307             Disconnect();
00308
00309         return StatusCodeHelper(STATUS_CODE_FAILURE, curl_easy_strerror(static_cast<CURLcode>(exception.m_errorCode)));
00310     }
00311
00312     return fileListCallBackData.GetFileList(fileinfoList, false);
00313 }
00314
00315 // ---------------------------------------------------------------------------------------------------------------------------------
00316
00317 inline StatusCodeHelper CurlFtpHelper::GetFile(const std::string &remoteFilename, const std::string &localFilename, const std::string &remoteDirectory)
00318 {
00319     if (!IsConnected())
00320         return STATUS_CODE_NOT_CONNECTED;
00321
00322     GetFileCallbackData getFileCallbackData(localFilename);
00323
00324     try
00325     {
00326         const std::string url = (remoteDirectory.empty() ? GetUrl() + remoteFilename : GetUrl() + remoteDirectory + "/" + remoteFilename);
00327
00328         ACTIV_THROW_RESULT_IF(CURLE_OK, !=, curl_easy_setopt(m_pCurl, CURLOPT_URL, url.c_str()));
00329         ACTIV_THROW_RESULT_IF(CURLE_OK, !=, curl_easy_setopt(m_pCurl, CURLOPT_NOBODY, 0));
00330         ACTIV_THROW_RESULT_IF(CURLE_OK, !=, curl_easy_setopt(m_pCurl, CURLOPT_WRITEDATA, &getFileCallbackData));
00331
00332         ACTIV_THROW_RESULT_IF(CURLE_OK, !=, curl_easy_perform(m_pCurl));
00333     }
00334     catch (Exception &exception)
00335     {
00336         if (CURLE_COULDNT_CONNECT == exception.m_errorCode)
00337             Disconnect();
00338
00339         return StatusCodeHelper(STATUS_CODE_FAILURE, curl_easy_strerror(static_cast<CURLcode>(exception.m_errorCode)));
00340     }
00341
00342     return STATUS_CODE_SUCCESS;
00343 }
00344
00345 // ---------------------------------------------------------------------------------------------------------------------------------
00346
00347 inline StatusCodeHelper CurlFtpHelper::DeleteFile(const std::string &remoteFilename, const std::string &remoteDirectory)
00348 {
00349     if (!IsConnected())
00350         return STATUS_CODE_NOT_CONNECTED;
00351
00352     struct curl_slist *list = 0;
00353
00354     try
00355     {
00356         std::string ftpCommand =  "DELE " + remoteFilename;
00357         list = curl_slist_append(list, ftpCommand.c_str());
00358
00359         const std::string url = (remoteDirectory.empty() ? GetUrl() : GetUrl() + remoteDirectory + "/");
00360         ACTIV_THROW_RESULT_IF(CURLE_OK, !=, curl_easy_setopt(m_pCurl, CURLOPT_URL, url.c_str()));
00361         ACTIV_THROW_RESULT_IF(CURLE_OK, !=, curl_easy_setopt(m_pCurl, CURLOPT_NOBODY, 1));
00362         ACTIV_THROW_RESULT_IF(CURLE_OK, !=, curl_easy_setopt(m_pCurl, CURLOPT_QUOTE, list));
00363
00364         ACTIV_THROW_RESULT_IF(CURLE_OK, !=, curl_easy_perform(m_pCurl));
00365     }
00366     catch (Exception &exception)
00367     {
00368         if (CURLE_COULDNT_CONNECT == exception.m_errorCode)
00369             Disconnect();
00370
00371         curl_easy_setopt(m_pCurl, CURLOPT_QUOTE, 0);
00372         curl_slist_free_all(list);
00373         return StatusCodeHelper(STATUS_CODE_FAILURE, curl_easy_strerror(static_cast<CURLcode>(exception.m_errorCode)));
00374     }
00375
00376     curl_easy_setopt(m_pCurl, CURLOPT_QUOTE, 0);
00377     curl_slist_free_all(list);
00378
00379     return STATUS_CODE_SUCCESS;
00380 }
00381
00382 // ---------------------------------------------------------------------------------------------------------------------------------
00383
00384 inline StatusCodeHelper CurlFtpHelper::DeleteFile(const FileInfoList &fileInfoList, const std::string &remoteDirectory)
00385 {
00386     if (!IsConnected())
00387         return STATUS_CODE_NOT_CONNECTED;
00388
00389     struct curl_slist *list = 0;
00390
00391     try
00392     {
00393         for (FileInfoList::const_iterator it = fileInfoList.begin(), itEnd = fileInfoList.end(); it != itEnd; ++it)
00394         {
00395             std::string ftpCommand = "DELE " + it->m_name;
00396             list = curl_slist_append(list, ftpCommand.c_str());
00397         }
00398
00399         const std::string url = (remoteDirectory.empty() ? GetUrl() : GetUrl() + remoteDirectory + "/");
00400         ACTIV_THROW_RESULT_IF(CURLE_OK, !=, curl_easy_setopt(m_pCurl, CURLOPT_URL, url.c_str()));
00401         ACTIV_THROW_RESULT_IF(CURLE_OK, !=, curl_easy_setopt(m_pCurl, CURLOPT_NOBODY, 1));
00402         ACTIV_THROW_RESULT_IF(CURLE_OK, !=, curl_easy_setopt(m_pCurl, CURLOPT_QUOTE, list));
00403
00404         ACTIV_THROW_RESULT_IF(CURLE_OK, !=, curl_easy_perform(m_pCurl));
00405     }
00406     catch (Exception &exception)
00407     {
00408         if (CURLE_COULDNT_CONNECT == exception.m_errorCode)
00409             Disconnect();
00410
00411         curl_easy_setopt(m_pCurl, CURLOPT_QUOTE, 0);
00412         curl_slist_free_all(list);
00413         return StatusCodeHelper(STATUS_CODE_FAILURE, curl_easy_strerror(static_cast<CURLcode>(exception.m_errorCode)));
00414     }
00415
00416     curl_easy_setopt(m_pCurl, CURLOPT_QUOTE, 0);
00417     curl_slist_free_all(list);
00418
00419     return STATUS_CODE_SUCCESS;
00420 }
00421
00422 // ---------------------------------------------------------------------------------------------------------------------------------
00423
00424 inline StatusCodeHelper CurlFtpHelper::GetAndDeleteFile(const std::string &remoteFilename, const std::string &localFilename, const std::string &remoteDirectory)
00425 {
00426     if (!IsConnected())
00427         return STATUS_CODE_NOT_CONNECTED;
00428
00429     struct curl_slist *list = 0;
00430     GetFileCallbackData getFileCallbackData(localFilename);
00431
00432     try
00433     {
00434         std::string ftpCommand = "DELE " + remoteFilename;
00435         list = curl_slist_append(list, ftpCommand.c_str());
00436
00437         const std::string url = (remoteDirectory.empty() ? GetUrl() + remoteFilename : GetUrl() + remoteDirectory + "/" + remoteFilename);
00438
00439         ACTIV_THROW_RESULT_IF(CURLE_OK, !=, curl_easy_setopt(m_pCurl, CURLOPT_URL, url.c_str()));
00440         ACTIV_THROW_RESULT_IF(CURLE_OK, !=, curl_easy_setopt(m_pCurl, CURLOPT_NOBODY, 0));
00441         ACTIV_THROW_RESULT_IF(CURLE_OK, !=, curl_easy_setopt(m_pCurl, CURLOPT_WRITEDATA, &getFileCallbackData));
00442         ACTIV_THROW_RESULT_IF(CURLE_OK, !=, curl_easy_setopt(m_pCurl, CURLOPT_POSTQUOTE, list));
00443
00444         ACTIV_THROW_RESULT_IF(CURLE_OK, !=, curl_easy_perform(m_pCurl));
00445     }
00446     catch (Exception &exception)
00447     {
00448         if (CURLE_COULDNT_CONNECT == exception.m_errorCode)
00449             Disconnect();
00450
00451         curl_easy_setopt(m_pCurl, CURLOPT_POSTQUOTE, 0);
00452         curl_slist_free_all(list);
00453
00454         return StatusCodeHelper(STATUS_CODE_FAILURE, curl_easy_strerror(static_cast<CURLcode>(exception.m_errorCode)));
00455     }
00456
00457     curl_easy_setopt(m_pCurl, CURLOPT_POSTQUOTE, 0);
00458     curl_slist_free_all(list);
00459
00460     return STATUS_CODE_SUCCESS;
00461 }
00462
00463 // ---------------------------------------------------------------------------------------------------------------------------------
00464
00465 inline size_t CurlFtpHelper::CallbackFunction(void *ptr, size_t size, size_t nmemb, void *stream)
00466 {
00467     size_t realsize = size * nmemb;
00468     CallbackData *pCallBackData = static_cast<CallbackData *>(stream);
00469
00470     return pCallBackData->AppendData(ptr, realsize);
00471 }
00472
00473 // ---------------------------------------------------------------------------------------------------------------------------------
00474 // ---------------------------------------------------------------------------------------------------------------------------------
00475
00476 inline CurlFtpHelper::CallbackData::~CallbackData()
00477 {
00478 }
00479
00480 // ---------------------------------------------------------------------------------------------------------------------------------
00481
00482 inline size_t CurlFtpHelper::CallbackData::AppendData(void *ptr, size_t size)
00483 {
00484     return size;
00485 }
00486
00487 // ---------------------------------------------------------------------------------------------------------------------------------
00488 // ---------------------------------------------------------------------------------------------------------------------------------
00489
00490 inline StatusCodeHelper CurlFtpHelper::FileListCallbackData::GetFileList(FileInfoList &fileInfoList, bool includeDirectories)
00491 {
00492     size_t start = 0, end = 0;
00493     struct ftpparse parseInfo;
00494
00495     std::string &data = m_data;
00496     while((end = data.find_first_of("\r\n", start)) != data.npos)
00497     {
00498         if (ftpparse(&parseInfo, const_cast<char*>(data.c_str()) + start, static_cast<int>(end - start)))
00499         {
00500             FileInfo fileInfo;
00501
00502             if (!(includeDirectories || !parseInfo.flagtrycwd))
00503             {
00504                 start = end + 2;
00505                 continue;
00506             }
00507
00508             fileInfo.m_name = std::string(parseInfo.name, parseInfo.namelen);
00509             fileInfo.m_size = static_cast<int64_t>(parseInfo.size);
00510
00511             if (FTPPARSE_MTIME_UNKNOWN != parseInfo.mtimetype)
00512             {
00513                 struct tm tm;
00514
00515                 localtime_r(&parseInfo.mtime, &tm);
00516
00517                 fileInfo.m_fileTime = DateTime(tm);
00518             }
00519
00520             fileInfoList.push_back(fileInfo);
00521         }
00522
00523         start = end + 2;
00524     }
00525
00526     return STATUS_CODE_SUCCESS;
00527 }
00528
00529 // ---------------------------------------------------------------------------------------------------------------------------------
00530
00531 inline size_t CurlFtpHelper::FileListCallbackData::AppendData(void *ptr, size_t size)
00532 {
00533     m_data.append(static_cast<char *>(ptr), size);
00534
00535     return size;
00536 }
00537
00538 // ---------------------------------------------------------------------------------------------------------------------------------
00539 // ---------------------------------------------------------------------------------------------------------------------------------
00540
00541 inline CurlFtpHelper::GetFileCallbackData::GetFileCallbackData(const std::string &filename)
00542 {
00543     StatusCode statusCode = m_file.Create(filename, File::ACCESS_FLAG_WRITE, File::SHARE_FLAG_READ);
00544
00545     if (STATUS_CODE_SUCCESS != statusCode)
00546     {
00547         LogMessage(LOG_TYPE_ERROR, "Failed to create temp file " + filename);
00548         ACTIV_THROW(OsException, statusCode);
00549     }
00550 }
00551
00552 // ---------------------------------------------------------------------------------------------------------------------------------
00553
00554 inline size_t CurlFtpHelper::GetFileCallbackData::AppendData(void *ptr, size_t size)
00555 {
00556     try
00557     {
00558         int64_t fileSize = 0;
00559
00560         ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, m_file.GetSize(fileSize));
00561         ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, m_file.SetPosition(fileSize));
00562         ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, m_file.Write(ptr, size));
00563     }
00564     catch (StatusCodeException &statusCodeException)
00565     {
00566         LogMessage(LOG_TYPE_ERROR, "Failed to write data to file " + statusCodeException.ToString());
00567         return 0;
00568     }
00569
00570     return size;
00571 }
00572
00573 // ---------------------------------------------------------------------------------------------------------------------------------
00574 // ---------------------------------------------------------------------------------------------------------------------------------
00575
00576 inline void CurlFtpHelper::SetTimeout(uint32_t timeout)
00577 {
00578     m_timeout = timeout;
00579 }
00580
00581 // ---------------------------------------------------------------------------------------------------------------------------------
00582
00583 inline void CurlFtpHelper::SetLowSpeedLimit(uint32_t lowSpeedLimit)
00584 {
00585     m_lowSpeedLimit = lowSpeedLimit;
00586 }
00587
00588 // ---------------------------------------------------------------------------------------------------------------------------------
00589
00590 inline void CurlFtpHelper::SetLowSpeedTime(uint32_t lowSpeedTime)
00591 {
00592     m_lowSpeedTime = lowSpeedTime;
00593 }
00594
00595 // ---------------------------------------------------------------------------------------------------------------------------------
00596
00597 inline void CurlFtpHelper::SetUseEpsv(bool useEpsv)
00598 {
00599     m_useEpsv = useEpsv;
00600 }
00601
00602 // ---------------------------------------------------------------------------------------------------------------------------------
00603
00604 inline void CurlFtpHelper::SetCurlLogFilename(const std::string &logFilename)
00605 {
00606     if ("" != logFilename)
00607     {
00608         if (m_pCurlLogFileHandle)
00609             fclose(m_pCurlLogFileHandle);
00610
00611         m_pCurlLogFileHandle = fopen(logFilename.c_str(), "a+");
00612     }
00613 }
00614
00615 // ---------------------------------------------------------------------------------------------------------------------------------
00616
00617 inline uint32_t CurlFtpHelper::GetTimeout() const
00618 {
00619     return m_timeout;
00620 }
00621
00622 // ---------------------------------------------------------------------------------------------------------------------------------
00623
00624 inline uint32_t CurlFtpHelper::GetLowSpeedLimit() const
00625 {
00626     return m_lowSpeedLimit;
00627 }
00628
00629 // ---------------------------------------------------------------------------------------------------------------------------------
00630
00631 inline uint32_t CurlFtpHelper::GetLowSpeedTime() const
00632 {
00633     return m_lowSpeedTime;
00634 }
00635
00636 // ---------------------------------------------------------------------------------------------------------------------------------
00637
00638 inline bool CurlFtpHelper::GetUseEpsv() const
00639 {
00640     return m_useEpsv;
00641 }
00642
00643 } // namespace Activ
00644
00645 #endif // (!defined ACTIV_MISC_CURL_FTP_HELPER_H)
Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivDatabase

Database.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_DATABASE_DATABASE_H)
00010 #define ACTIV_DATABASE_DATABASE_H
00011
00012 #include "ActivMiddleware/ActivBase/IMutex.h"
00013 #include "ActivMiddleware/ActivBase/MutexHelper.h"
00014
00015 #include "ActivMiddleware/ActivDatabase/ITable.h"
00016 #include "ActivMiddleware/ActivDatabase/DatabaseException.h"
00017 #include "ActivMiddleware/ActivDatabase/DatabaseSpecification.h"
00018
00019 #include "ActivMiddleware/Misc/StlHelper.h"
00020
00021 #include <vector>
00022 #include <set>
00023
00024 namespace Activ
00025 {
00026
00027 namespace Database
00028 {
00029
00033 class Database
00034 {
00035 private:
00036     typedef std::vector<ITable *> TablePtrList;
00037     typedef std::set<DatabaseSpecification::TableId> TableIdSet;
00038
00039 public:
00043     class ConstIterator
00044     {
00045     public:
00051         ACTIV_DATABASE_API ConstIterator &operator++();
00052
00058         ACTIV_DATABASE_API const ConstIterator operator++(int);
00059
00067         ACTIV_DATABASE_API bool operator==(const ConstIterator &rhs) const;
00068
00076         ACTIV_DATABASE_API bool operator!=(const ConstIterator &rhs) const;
00077
00083         ACTIV_DATABASE_API DatabaseSpecification::TableId GetTableId() const;
00084
00090         ACTIV_DATABASE_API const ITable *GetTable() const;
00091
00092     private:
00099         ConstIterator(const TablePtrList &tablePtrList, const TableIdSet::const_iterator &iterator);
00100
00101         const TablePtrList &        m_tablePtrList;
00102         TableIdSet::const_iterator  m_iterator;
00103
00104         friend class Database;
00105     };
00106
00110     class Iterator
00111     {
00112     public:
00118         ACTIV_DATABASE_API Iterator &operator++();
00119
00125         ACTIV_DATABASE_API const Iterator operator++(int);
00126
00134         ACTIV_DATABASE_API bool operator==(const Iterator &rhs) const;
00135
00143         ACTIV_DATABASE_API bool operator!=(const Iterator &rhs) const;
00144
00150         ACTIV_DATABASE_API DatabaseSpecification::TableId GetTableId() const;
00151
00157         ACTIV_DATABASE_API ITable *GetTable();
00158
00159     private:
00166         Iterator(const TablePtrList &tablePtrList, const TableIdSet::iterator &iterator);
00167
00168         const TablePtrList &        m_tablePtrList;
00169         TableIdSet::iterator        m_iterator;
00170
00171         friend class Database;
00172     };
00173
00182     ACTIV_DATABASE_API Database(const std::string &name = std::string(), const DatabaseSpecification::Properties properties = DatabaseSpecification::PROPERTY_NONE);
00183
00187     ACTIV_DATABASE_API ~Database();
00188
00197     ACTIV_DATABASE_API StatusCode AttachTable(const DatabaseSpecification::TableId tableId, ITable *pTable);
00198
00207     ACTIV_DATABASE_API StatusCode DetachTable(const DatabaseSpecification::TableId tableId, ITable *&pTable);
00208
00219     ACTIV_DATABASE_API StatusCode GetTable(const DatabaseSpecification::TableId tableId, ITable *&pTable) const;
00220
00240     ACTIV_DATABASE_API StatusCode GetEqual(const Key &key, Record &record) const;
00241
00262     StatusCode GetEqual(const ITable *pTable, const IndexSpecification::Number indexNo, const Key &key, Record &record) const;
00263
00274     ACTIV_DATABASE_API StatusCode SerializeSpecification(MessageBuilder &messageBuilder) const;
00275
00281     ACTIV_DATABASE_API DatabaseSpecification GetSpecification() const;
00282
00288     ACTIV_DATABASE_API std::string GetName() const;
00289
00295     TableIdList GetTableIdList() const;
00296
00302     ACTIV_DATABASE_API size_t GetNumberOfTables() const;
00303
00309     void SetMode(const Mode mode);
00310
00323     StatusCode SetSearchOrder(const TableIdList &tableIdList);
00324
00330     TableIdList GetSearchOrder() const;
00331
00337     Mode GetMode() const;
00338
00344     ConstIterator Begin() const;
00345
00351     ConstIterator End() const;
00352
00358     Iterator Begin();
00359
00365     Iterator End();
00366
00367 private:
00373     Database(const Database &rhs);
00374
00382     Database &operator=(const Database &rhs);
00383
00393     bool IsTableIdValid(const DatabaseSpecification::TableId tableId) const;
00394
00395     std::string                         m_name;
00396     DatabaseSpecification::Properties   m_properties;
00397     Mode                                m_mode;
00398     IMutex                              *m_pMutex;
00399     TablePtrList                        m_tablePtrList;
00400     TableIdSet                          m_tableIdSet;
00401     TableIdList                         m_tableIdSearchOrderList;
00402
00403     friend class ConstIterator;
00404     friend class Iterator;
00405 };
00406
00407 // ---------------------------------------------------------------------------------------------------------------------------------
00408
00409 inline TableIdList Database::GetTableIdList() const
00410 {
00411     return TableIdList(m_tableIdSet.begin(), m_tableIdSet.end());
00412 }
00413
00414 // ---------------------------------------------------------------------------------------------------------------------------------
00415
00416 inline void Database::SetMode(const Mode mode)
00417 {
00418     m_mode = mode;
00419 }
00420
00421 // ---------------------------------------------------------------------------------------------------------------------------------
00422
00423 inline Mode Database::GetMode() const
00424 {
00425     return m_mode;
00426 }
00427
00428 // ---------------------------------------------------------------------------------------------------------------------------------
00429
00430 inline Database::ConstIterator Database::Begin() const
00431 {
00432     return ConstIterator(m_tablePtrList, m_tableIdSet.begin());
00433 }
00434
00435 // ---------------------------------------------------------------------------------------------------------------------------------
00436
00437 inline Database::ConstIterator Database::End() const
00438 {
00439     return ConstIterator(m_tablePtrList, m_tableIdSet.end());
00440 }
00441
00442 // ---------------------------------------------------------------------------------------------------------------------------------
00443
00444 inline Database::Iterator Database::Begin()
00445 {
00446     return Iterator(m_tablePtrList, m_tableIdSet.begin());
00447 }
00448
00449 // ---------------------------------------------------------------------------------------------------------------------------------
00450
00451 inline Database::Iterator Database::End()
00452 {
00453     return Iterator(m_tablePtrList, m_tableIdSet.end());
00454 }
00455
00456 // ---------------------------------------------------------------------------------------------------------------------------------
00457 // ---------------------------------------------------------------------------------------------------------------------------------
00458
00459 inline Database::ConstIterator &Database::ConstIterator::operator++()
00460 {
00461     ++m_iterator;
00462
00463     return *this;
00464 }
00465
00466 // ---------------------------------------------------------------------------------------------------------------------------------
00467
00468 inline const Database::ConstIterator Database::ConstIterator::operator++(int)
00469 {
00470     ConstIterator oldValue = *this;
00471
00472     ++(*this);
00473
00474     return oldValue;
00475 }
00476
00477 // ---------------------------------------------------------------------------------------------------------------------------------
00478
00479 inline bool Database::ConstIterator::operator==(const Database::ConstIterator &rhs) const
00480 {
00481     return (m_iterator == rhs.m_iterator);
00482 }
00483
00484 // ---------------------------------------------------------------------------------------------------------------------------------
00485
00486 inline bool Database::ConstIterator::operator!=(const Database::ConstIterator &rhs) const
00487 {
00488     return !((*this) == rhs);
00489 }
00490
00491 // ---------------------------------------------------------------------------------------------------------------------------------
00492 // ---------------------------------------------------------------------------------------------------------------------------------
00493
00494 inline DatabaseSpecification::TableId Database::ConstIterator::GetTableId() const
00495 {
00496     return *m_iterator;
00497 }
00498
00499 // ---------------------------------------------------------------------------------------------------------------------------------
00500
00501 inline const ITable *Database::ConstIterator::GetTable() const
00502 {
00503     return m_tablePtrList[*m_iterator];
00504 }
00505
00506 // ---------------------------------------------------------------------------------------------------------------------------------
00507
00508 inline Database::ConstIterator::ConstIterator(const TablePtrList &tablePtrList, const TableIdSet::const_iterator &iterator) :
00509     m_tablePtrList(tablePtrList),
00510     m_iterator(iterator)
00511 {
00512 }
00513
00514 // ---------------------------------------------------------------------------------------------------------------------------------
00515 // ---------------------------------------------------------------------------------------------------------------------------------
00516
00517 inline Database::Iterator &Database::Iterator::operator++()
00518 {
00519     ++m_iterator;
00520
00521     return *this;
00522 }
00523
00524 // ---------------------------------------------------------------------------------------------------------------------------------
00525
00526 inline const Database::Iterator Database::Iterator::operator++(int)
00527 {
00528     Iterator oldValue = *this;
00529
00530     ++(*this);
00531
00532     return oldValue;
00533 }
00534
00535 // ---------------------------------------------------------------------------------------------------------------------------------
00536
00537 inline bool Database::Iterator::operator==(const Database::Iterator &rhs) const
00538 {
00539     return (m_iterator == rhs.m_iterator);
00540 }
00541
00542 // ---------------------------------------------------------------------------------------------------------------------------------
00543
00544 inline bool Database::Iterator::operator!=(const Database::Iterator &rhs) const
00545 {
00546     return !((*this) == rhs);
00547 }
00548
00549 // ---------------------------------------------------------------------------------------------------------------------------------
00550 // ---------------------------------------------------------------------------------------------------------------------------------
00551
00552 inline DatabaseSpecification::TableId Database::Iterator::GetTableId() const
00553 {
00554     return *m_iterator;
00555 }
00556
00557 // ---------------------------------------------------------------------------------------------------------------------------------
00558
00559 inline ITable *Database::Iterator::GetTable()
00560 {
00561     return m_tablePtrList[*m_iterator];
00562 }
00563
00564 // ---------------------------------------------------------------------------------------------------------------------------------
00565
00566 inline Database::Iterator::Iterator(const TablePtrList &tablePtrList, const TableIdSet::iterator &iterator) :
00567     m_tablePtrList(tablePtrList),
00568     m_iterator(iterator)
00569 {
00570 }
00571
00572 // ---------------------------------------------------------------------------------------------------------------------------------
00573
00574 } // namespace Database
00575
00576 } // namespace Activ
00577
00578 #endif // (!defined ACTIV_DATABASE_DATABASE_H)
Generated on Wed Oct 8 14:01:47 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivDatabase

DatabaseException.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_DATABASE_DATABASE_EXCEPTION_H)
00010 #define ACTIV_DATABASE_DATABASE_EXCEPTION_H
00011
00012 #include "ActivMiddleware/Activ.h"
00013
00014 #include "ActivMiddleware/ActivBase/Exception.h"
00015
00016 #include "ActivMiddleware/ActivDatabase/External.h"
00017
00018 #include <string>
00019
00020 namespace Activ
00021 {
00022
00023 namespace Database
00024 {
00025
00029 #define ACTIV_DATABASE_EXCEPTION_LIST(d)                                                        \
00030     d(DATABASE_ERROR_FAILED_TO_ALLOC_DATA_STORE, "failed to allocate data store")               \
00031     d(DATABASE_ERROR_FAILED_TO_ALLOC_DATA_STORE_CACHE, "failed to allocate data store cache")   \
00032     d(DATABASE_ERROR_FAILED_TO_ALLOC_DATABASE, "failed to allocate database")                   \
00033     d(DATABASE_ERROR_FAILED_TO_ALLOC_FIELD_LIST, "failed to allocate field list")               \
00034     d(DATABASE_ERROR_FAILED_TO_ALLOC_INDEX, "failed to allocate index")                         \
00035     d(DATABASE_ERROR_FAILED_TO_ALLOC_KEY, "failed to allocate key")                             \
00036     d(DATABASE_ERROR_FAILED_TO_ALLOC_MEMORY_MANAGER, "failed to allocate memory manager")       \
00037     d(DATABASE_ERROR_FAILED_TO_ALLOC_RECORD, "failed to allocate record")                       \
00038     d(DATABASE_ERROR_FAILED_TO_ALLOC_TABLE, "failed to allocate table")                         \
00039     d(DATABASE_ERROR_FAILED_TO_CREATE_FILE, "failed to create file")                            \
00040     d(DATABASE_ERROR_NOT_CREATED, "not created")                                                \
00041     d(DATABASE_ERROR_NOT_SUPPORTED, "not supported")                                            \
00042     d(DATABASE_ERROR_INVALID_PARAMETER, "invalid parameter")                                    \
00043     d(DATABASE_ERROR_ALREADY_CREATED, "already created")
00044
00045 // ---------------------------------------------------------------------------------------------------------------------------------
00046
00050 class DatabaseException : public Exception
00051 {
00052 public:
00056     enum Errors
00057     {
00058         ACTIV_DATABASE_EXCEPTION_LIST(ACTIV_DECLARE_ELEMENT_1_WITH_COMMA)
00059         NUMBER_OF_ERRORS
00060     };
00061
00070     ACTIV_DATABASE_API DatabaseException(const char file[], const char function[], const uint_fast32_t line, const uint_fast32_t errorCode);
00071
00082     ACTIV_DATABASE_API DatabaseException(const char file[], const char function[], const uint_fast32_t line, const uint_fast32_t errorCode, const char format[], ...);
00083
00089     ACTIV_DATABASE_API virtual std::string ToString() const;
00090
00091 private:
00092     std::string m_errorString;
00093 };
00094
00095 }   // namespace Database
00096
00097 }   // namespace Activ
00098
00099 #endif // (!defined ACTIV_DATABASE_DATABASE_EXCEPTION_H)
Generated on Wed Oct 8 14:01:47 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivDatabase

DatabaseSpecification.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_DATABASE_DATABASE_SPECIFICATION_H)
00010 #define ACTIV_DATABASE_DATABASE_SPECIFICATION_H
00011
00012 #include "ActivMiddleware/Misc/StlHelper.h"
00013
00014 #include "ActivMiddleware/ActivDatabase/External.h"
00015
00016 #include "ActivMiddleware/ActivDatabase/TableSpecification.h"
00017 #include "ActivMiddleware/ActivDatabase/IndexSpecification.h"
00018
00019 #include <string>
00020
00021 namespace Activ
00022 {
00023
00024 class MessageBuilder;
00025 class MessageValidator;
00026
00027 namespace Database
00028 {
00029
00030 typedef std::vector<IndexSpecification> IndexSpecificationList;
00031
00032 // ---------------------------------------------------------------------------------------------------------------------------------
00033
00037 class DatabaseSpecification
00038 {
00039 public:
00040     static const uint8_t VERSION = 1;
00041
00042     typedef uint16_t TableId;
00043     const static TableId UNDEFINED_TABLE_ID = ~0;
00044
00048     class DatabaseTableSpecification
00049     {
00050     public:
00060         ACTIV_DATABASE_API DatabaseTableSpecification(const TableId tableId = UNDEFINED_TABLE_ID, const TableSpecification &tableSpecification = TableSpecification(), const IndexSpecificationList &indexSpecificationList = IndexSpecificationList());
00061
00072         ACTIV_DATABASE_API StatusCode Serialize(MessageBuilder &messageBuilder) const;
00073
00084         ACTIV_DATABASE_API StatusCode Deserialize(MessageValidator &messageValidator);
00085
00091         ACTIV_DATABASE_API std::string ToString() const;
00092
00093         TableId                 m_tableId;
00094         TableSpecification      m_tableSpecification;
00095         IndexSpecificationList  m_indexSpecificationList;
00096     };
00097     typedef std::vector<DatabaseTableSpecification> DatabaseTableSpecificationList;
00098
00102     enum
00103     {
00104         PROPERTY_NONE = 0x00000000,
00105         PROPERTY_CREATE_MUTEX = 0x00000001
00106     };
00107     typedef uint32_t Properties;
00108
00118     ACTIV_DATABASE_API DatabaseSpecification(const std::string &name = std::string(), const Properties properties = PROPERTY_NONE, const DatabaseTableSpecificationList &databaseTableSpecificationList = DatabaseTableSpecificationList());
00119
00130     ACTIV_DATABASE_API StatusCode Serialize(MessageBuilder &messageBuilder) const;
00131
00142     ACTIV_DATABASE_API StatusCode Deserialize(MessageValidator &messageValidator);
00143
00151     ACTIV_DATABASE_API static bool ShouldCreateMutex(const Properties properties);
00152
00158     ACTIV_DATABASE_API std::string ToString() const;
00159
00160     std::string                         m_name;
00161     Properties                          m_properties;
00162     DatabaseTableSpecificationList      m_databaseTableSpecificationList;
00163 };
00164
00165 // ---------------------------------------------------------------------------------------------------------------------------------
00166
00167 }   // namespace Database
00168
00169 }   // namespace Activ
00170
00171 // ---------------------------------------------------------------------------------------------------------------------------------
00172
00181 ACTIV_DATABASE_API std::ostream &operator<<(std::ostream &os, const Activ::Database::DatabaseSpecification &rhs);
00182
00183 // ---------------------------------------------------------------------------------------------------------------------------------
00184
00185 #endif // (!defined ACTIV_DATABASE_DATABASE_SPECIFICATION_H)
Generated on Wed Oct 8 14:01:47 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivFieldTypes

Date.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FIELD_TYPES_DATE_H)
00010 #define ACTIV_FIELD_TYPES_DATE_H
00011
00012 #include "ActivMiddleware/ActivFieldTypes/External.h"
00013 #include "ActivMiddleware/ActivFieldTypes/IFieldType.h"
00014
00015 #include "ActivMiddleware/ActivBase/StatusCodeException.h"
00016
00017 #include <ctime>
00018
00019 namespace Activ
00020 {
00021
00025 #define ACTIV_DAY_LIST(d)           \
00026     d(SUNDAY,       "Sunday")       \
00027     d(MONDAY,       "Monday")       \
00028     d(TUESDAY,      "Tuesday")      \
00029     d(WEDNESDAY,    "Wednesday")    \
00030     d(THURSDAY,     "Thursday")     \
00031     d(FRIDAY,       "Friday")       \
00032     d(SATURDAY,     "Saturday")
00033
00037 #define ACTIV_MONTH_LIST(d)         \
00038     d(UNDEFINED,    "Undefined")    \
00039     d(JANUARY,      "January")      \
00040     d(FEBRUARY,     "February")     \
00041     d(MARCH,        "March")        \
00042     d(APRIL,        "April")        \
00043     d(MAY,          "May")          \
00044     d(JUNE,         "June")         \
00045     d(JULY,         "July")         \
00046     d(AUGUST,       "August")       \
00047     d(SEPTEMBER,    "September")    \
00048     d(OCTOBER,      "October")      \
00049     d(NOVEMBER,     "November")     \
00050     d(DECEMBER,     "December")
00051
00052 class MessageBuilder;
00053 class MessageValidator;
00054
00055 // ---------------------------------------------------------------------------------------------------------------------------------
00056
00060 class Date : public IFieldType
00061 {
00062 public:
00063     static const FieldType FIELD_TYPE = FIELD_TYPE_DATE;
00064
00065     static const uint32_t MONTHS_PER_YEAR   = 12;
00066     static const uint32_t DAYS_PER_WEEK     = 7;
00067     static const uint32_t DAYS_PER_MONTH    = 31;
00068
00069     using IFieldType::FromString;
00070     using IFieldType::Serialize;
00071     using IFieldType::SerializeBody;
00072     using IFieldType::SerializeLengthAndBody;
00073     using IFieldType::Deserialize;
00074     using IFieldType::DeserializeBody;
00075     using IFieldType::DeserializeLengthAndBody;
00076
00080     enum
00081     {
00082         ACTIV_DAY_LIST(ACTIV_DECLARE_ELEMENT_1_WITH_COMMA)
00083         NUM_DAYS
00084     };
00085
00089     enum
00090     {
00091         ACTIV_MONTH_LIST(ACTIV_DECLARE_ELEMENT_1_WITH_COMMA)
00092         NUM_MONTHS
00093     };
00094
00098     class Days
00099     {
00100     public:
00106         explicit Days(const int32_t value);
00107
00108         const int32_t   m_value;
00109     };
00110
00114     Date();
00115
00125     Date(const uint32_t year, const uint32_t month, const uint32_t day);
00126
00134     explicit Date(const int32_t julianDate);
00135
00145     Date(const std::tm &tm);
00146
00150     virtual ~Date();
00151
00161     bool operator==(const Date &rhs) const;
00162
00172     bool operator!=(const Date &rhs) const;
00173
00183     bool operator<(const Date &rhs) const;
00184
00194     bool operator<=(const Date &rhs) const;
00195
00205     bool operator>(const Date &rhs) const;
00206
00216     bool operator>=(const Date &rhs) const;
00217
00227     template <typename T> const Date operator+(const T &rhs) const;
00228
00238     template <typename T> Date &operator+=(const T &rhs);
00239
00249     template <typename T> const Date operator-(const T &rhs) const;
00250
00260     template <typename T> Date &operator-=(const T &rhs);
00261
00272     StatusCode Set(const uint32_t year, const uint32_t month, const uint32_t day);
00273
00282     StatusCode Set(const int32_t julianDate);
00283
00294     StatusCode Set(const std::tm &tm);
00295
00303     int32_t Get() const;
00304
00315     StatusCode Get(uint32_t &year, uint32_t &month, uint32_t &day) const;
00316
00325     StatusCode Get(int32_t &julianDate) const;
00326
00337     StatusCode Get(std::tm &tm) const;
00338
00346     uint32_t GetYear() const;
00347
00355     uint32_t GetMonth() const;
00356
00364     uint32_t GetDay() const;
00365
00373     uint32_t GetDayOfWeek() const;
00374
00382     uint32_t GetDayOfYear() const;
00383
00391     uint32_t GetWeekOfYear() const;
00392
00402     ACTIV_FIELD_TYPES_API StatusCode Add(const Days &days);
00403
00413     ACTIV_FIELD_TYPES_API StatusCode Subtract(const Days &days);
00414
00415     virtual void Reset();
00416     virtual void Clear();
00417
00426     ACTIV_FIELD_TYPES_API StatusCode Compare(const Date &rhs, int &result) const;
00427
00428     ACTIV_FIELD_TYPES_API virtual StatusCode Compare(const void * const pRhsSerializedBody, const size_t rhsSerializedBodyLength, int &result) const;
00429     ACTIV_FIELD_TYPES_API virtual StatusCode Convert(const IFieldType * const pIFieldType);
00430     ACTIV_FIELD_TYPES_API virtual std::string ToString() const;
00431     ACTIV_FIELD_TYPES_API virtual StatusCode FromString(MessageValidator &messageValidator);
00432     ACTIV_FIELD_TYPES_API virtual std::string GetFromStringFormat() const;
00433     ACTIV_FIELD_TYPES_API virtual StatusCode Serialize(MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength) const;
00434     ACTIV_FIELD_TYPES_API virtual StatusCode SerializeBody(void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength) const;
00435     ACTIV_FIELD_TYPES_API virtual StatusCode SerializeLengthAndBody(MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength = MAX_SERIALIZED_BODY_LENGTH_UNDEFINED) const;
00436     ACTIV_FIELD_TYPES_API virtual StatusCode Deserialize(MessageValidator &messageValidator, const size_t maxSerializedBodyLength);
00437     ACTIV_FIELD_TYPES_API virtual StatusCode DeserializeBody(const void * const pSerializedBody, const size_t serializedBodyLength);
00438     ACTIV_FIELD_TYPES_API virtual StatusCode DeserializeLengthAndBody(MessageValidator &messageValidator, const size_t maxSerializedBodyLength = MAX_SERIALIZED_BODY_LENGTH_UNDEFINED);
00439     virtual size_t GetSerializedLength() const;
00440     virtual size_t GetSerializedBodyLength() const;
00441     ACTIV_FIELD_TYPES_API virtual StatusCode IsDifferent(const void * const pRhsSerializedBody, const size_t rhsSerializedBodyLength, bool &isDifferent) const;
00442
00448     static size_t GetMaxSerializedLength();
00449
00455     static size_t GetMaxSerializedBodyLength();
00456
00469     ACTIV_FIELD_TYPES_API static StatusCode Compare(const void * const pLhsSerializedBody, const size_t lhsSerializedBodyLength, const void * const pRhsSerializedBody, const size_t rhsSerializedBodyLength, int &result);
00470
00479     ACTIV_FIELD_TYPES_API static uint32_t GetDaysInMonth(const uint32_t year, const uint32_t month);
00480
00490     ACTIV_FIELD_TYPES_API static uint32_t GetDayOfWeek(const uint32_t year, const uint32_t month, const uint32_t day);
00491
00501     ACTIV_FIELD_TYPES_API static uint32_t GetDayOfYear(const uint32_t year, const uint32_t month, const uint32_t day);
00502
00512     ACTIV_FIELD_TYPES_API static uint32_t GetWeekOfYear(const uint32_t year, const uint32_t month, const uint32_t day);
00513
00521     ACTIV_FIELD_TYPES_API static bool IsLeapYear(const uint32_t year);
00522
00528     ACTIV_FIELD_TYPES_API static Date CreateUtcDate();
00529
00535     ACTIV_FIELD_TYPES_API static Date CreateLocalDate();
00536
00547     ACTIV_FIELD_TYPES_API static void ConvertJulianToGregorianDate(const int32_t julianDate, int32_t &year, int32_t &month, int32_t &day);
00548
00560     ACTIV_FIELD_TYPES_API static int32_t ConvertGregorianToJulianDate(const int32_t year, const int32_t month, const int32_t day);
00561
00569     ACTIV_FIELD_TYPES_API static std::string DayOfWeekToString(const uint32_t dayOfWeek);
00570
00578     ACTIV_FIELD_TYPES_API static std::string MonthToString(const uint32_t month);
00579
00590     ACTIV_FIELD_TYPES_API static StatusCode ValidateSerializedLengthAndBody(MessageValidator &messageValidator, size_t &serializedBodyOffset, size_t &serializedBodyLength);
00591
00599     static bool IsValidSerializedBodyLength(const size_t serializedBodyLength);
00600
00601 private:
00602     static const size_t DAY_OFFSET                  = 0;
00603     static const size_t DAY_LENGTH                  = 5;
00604     static const size_t MONTH_OFFSET                = (DAY_OFFSET + DAY_LENGTH);
00605     static const size_t MONTH_LENGTH                = 4;
00606     static const size_t YEAR_OFFSET                 = (MONTH_OFFSET + MONTH_LENGTH);
00607     static const size_t YEAR_LENGTH                 = 15;
00608     static const size_t MAX_OFFSET                  = (YEAR_OFFSET + YEAR_LENGTH);
00609
00610     static const size_t MAX_DAY                     = ((1 << DAY_LENGTH) - 1);
00611     static const size_t MAX_MONTH                   = ((1 << MONTH_LENGTH) - 1);
00612     static const size_t MAX_YEAR                    = ((1 << YEAR_LENGTH) - 1);
00613
00614     static const size_t MAX_SERIALIZED_BODY_LENGTH  = (((MAX_OFFSET - 1) / CHAR_BIT) + 1);
00615
00616     uint32_t    m_year;
00617     uint8_t     m_month;
00618     uint8_t     m_day;
00619
00620     friend class DateTime;
00621 };
00622
00623 // ---------------------------------------------------------------------------------------------------------------------------------
00624
00625 inline Date::Date() :
00626     IFieldType(FIELD_TYPE)
00627 {
00628     m_isInitialized = false;
00629 }
00630
00631 // ---------------------------------------------------------------------------------------------------------------------------------
00632
00633 inline Date::Date(const uint32_t year, const uint32_t month, const uint32_t day) :
00634     IFieldType(FIELD_TYPE)
00635 {
00636     ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, Set(year, month, day));
00637 }
00638
00639 // ---------------------------------------------------------------------------------------------------------------------------------
00640
00641 inline Date::Date(const int32_t julianDate) :
00642     IFieldType(FIELD_TYPE)
00643 {
00644     ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, Set(julianDate));
00645 }
00646
00647 // ---------------------------------------------------------------------------------------------------------------------------------
00648
00649 inline Date::Date(const std::tm &tm) :
00650     IFieldType(FIELD_TYPE)
00651 {
00652     ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, Set(tm));
00653 }
00654
00655 // ---------------------------------------------------------------------------------------------------------------------------------
00656
00657 inline Date::~Date()
00658 {
00659 }
00660
00661 // ---------------------------------------------------------------------------------------------------------------------------------
00662
00663 inline bool Date::operator==(const Date &rhs) const
00664 {
00665     int result;
00666     ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, Compare(rhs, result));
00667
00668     return (0 == result);
00669 }
00670
00671 // ---------------------------------------------------------------------------------------------------------------------------------
00672
00673 inline bool Date::operator!=(const Date &rhs) const
00674 {
00675     return !((*this) == rhs);
00676 }
00677
00678 // ---------------------------------------------------------------------------------------------------------------------------------
00679
00680 inline bool Date::operator<(const Date &rhs) const
00681 {
00682     int result;
00683     ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, Compare(rhs, result));
00684
00685     return (result < 0);
00686 }
00687
00688 // ---------------------------------------------------------------------------------------------------------------------------------
00689
00690 inline bool Date::operator<=(const Date &rhs) const
00691 {
00692     return !((*this) > rhs);
00693 }
00694
00695 // ---------------------------------------------------------------------------------------------------------------------------------
00696
00697 inline bool Date::operator>(const Date &rhs) const
00698 {
00699     int result;
00700     ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, Compare(rhs, result));
00701
00702     return (result > 0);
00703 }
00704
00705 // ---------------------------------------------------------------------------------------------------------------------------------
00706
00707 inline bool Date::operator>=(const Date &rhs) const
00708 {
00709     return !((*this) < rhs);
00710 }
00711
00712 // ---------------------------------------------------------------------------------------------------------------------------------
00713
00714 template <typename T> inline const Date Date::operator+(const T &rhs) const
00715 {
00716     return Date(*this) += rhs;
00717 }
00718
00719 // ---------------------------------------------------------------------------------------------------------------------------------
00720
00721 template <typename T> inline Date& Date::operator+=(const T &rhs)
00722 {
00723     ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, Add(rhs));
00724
00725     return (*this);
00726 }
00727
00728 // ---------------------------------------------------------------------------------------------------------------------------------
00729
00730 template <typename T> inline const Date Date::operator-(const T &rhs) const
00731 {
00732     return Date(*this) -= rhs;
00733 }
00734
00735 // ---------------------------------------------------------------------------------------------------------------------------------
00736
00737 template <typename T> inline Date& Date::operator-=(const T &rhs)
00738 {
00739     ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, Subtract(rhs));
00740
00741     return (*this);
00742 }
00743
00744 // ---------------------------------------------------------------------------------------------------------------------------------
00745
00746 inline StatusCode Date::Set(const uint32_t year, const uint32_t month, const uint32_t day)
00747 {
00748     if ((year > MAX_YEAR) || (month < 1) || (month > MONTHS_PER_YEAR) || (day > GetDaysInMonth(year, month)))
00749         return STATUS_CODE_INVALID_PARAMETER;
00750
00751     m_year = static_cast<uint32_t>(year);
00752     m_month = static_cast<uint8_t>(month);
00753     m_day = static_cast<uint8_t>(day);
00754     m_isInitialized = true;
00755
00756     return STATUS_CODE_SUCCESS;
00757 }
00758
00759 // ---------------------------------------------------------------------------------------------------------------------------------
00760
00761 inline StatusCode Date::Set(const int32_t julianDate)
00762 {
00763     int32_t year, month, day;
00764
00765     ConvertJulianToGregorianDate(julianDate, year, month, day);
00766
00767     if ((year < 0) || (year > static_cast<int32_t>(MAX_YEAR)) || (month < 1) || (month > static_cast<int32_t>(MONTHS_PER_YEAR)) || (day < 1) || (static_cast<uint32_t>(day) > GetDaysInMonth(static_cast<uint32_t>(year), static_cast<uint32_t>(month))))
00768         return STATUS_CODE_INVALID_PARAMETER;
00769
00770     m_year = static_cast<uint32_t>(year);
00771     m_month = static_cast<uint8_t>(month);
00772     m_day = static_cast<uint8_t>(day);
00773     m_isInitialized = true;
00774
00775     return STATUS_CODE_SUCCESS;
00776 }
00777
00778 // ---------------------------------------------------------------------------------------------------------------------------------
00779
00780 inline StatusCode Date::Set(const std::tm &tm)
00781 {
00782     return Set(static_cast<uint32_t>(tm.tm_year + 1900), static_cast<uint32_t>(tm.tm_mon + 1), static_cast<uint32_t>(tm.tm_mday));
00783 }
00784
00785 // ---------------------------------------------------------------------------------------------------------------------------------
00786
00787 inline int32_t Date::Get() const
00788 {
00789     if (!IsInitialized())
00790         ACTIV_THROW(StatusCodeException, STATUS_CODE_NOT_INITIALIZED);
00791
00792     return ConvertGregorianToJulianDate(m_year, m_month, m_day);
00793 }
00794
00795 // ---------------------------------------------------------------------------------------------------------------------------------
00796
00797 inline StatusCode Date::Get(uint32_t &year, uint32_t &month, uint32_t &day) const
00798 {
00799     if (!IsInitialized())
00800         return STATUS_CODE_NOT_INITIALIZED;
00801
00802     year = m_year;
00803     month = m_month;
00804     day = m_day;
00805
00806     return STATUS_CODE_SUCCESS;
00807 }
00808
00809 // ---------------------------------------------------------------------------------------------------------------------------------
00810
00811 inline StatusCode Date::Get(int32_t &julianDate) const
00812 {
00813     if (!IsInitialized())
00814         return STATUS_CODE_NOT_INITIALIZED;
00815
00816     julianDate = ConvertGregorianToJulianDate(m_year, m_month, m_day);
00817
00818     return STATUS_CODE_SUCCESS;
00819 }
00820
00821 // ---------------------------------------------------------------------------------------------------------------------------------
00822
00823 inline StatusCode Date::Get(std::tm &tm) const
00824 {
00825     if (!IsInitialized())
00826         return STATUS_CODE_NOT_INITIALIZED;
00827
00828     tm.tm_year = static_cast<int>(m_year - 1900);
00829     tm.tm_mon = static_cast<int>(m_month - 1);
00830     tm.tm_mday = static_cast<int>(m_day);
00831
00832     return STATUS_CODE_SUCCESS;
00833 }
00834
00835 // ---------------------------------------------------------------------------------------------------------------------------------
00836
00837 inline uint32_t Date::GetYear() const
00838 {
00839     if (!IsInitialized())
00840         ACTIV_THROW(StatusCodeException, STATUS_CODE_NOT_INITIALIZED);
00841
00842     return static_cast<uint32_t>(m_year);
00843 }
00844
00845 // ---------------------------------------------------------------------------------------------------------------------------------
00846
00847 inline uint32_t Date::GetMonth() const
00848 {
00849     if (!IsInitialized())
00850         ACTIV_THROW(StatusCodeException, STATUS_CODE_NOT_INITIALIZED);
00851
00852     return static_cast<uint32_t>(m_month);
00853 }
00854
00855 // ---------------------------------------------------------------------------------------------------------------------------------
00856
00857 inline uint32_t Date::GetDay() const
00858 {
00859     if (!IsInitialized())
00860         ACTIV_THROW(StatusCodeException, STATUS_CODE_NOT_INITIALIZED);
00861
00862     return static_cast<uint32_t>(m_day);
00863 }
00864
00865 // ---------------------------------------------------------------------------------------------------------------------------------
00866
00867 inline uint32_t Date::GetDayOfWeek() const
00868 {
00869     if (!IsInitialized())
00870         ACTIV_THROW(StatusCodeException, STATUS_CODE_NOT_INITIALIZED);
00871
00872     return GetDayOfWeek(m_year, m_month, m_day);
00873 }
00874
00875 // ---------------------------------------------------------------------------------------------------------------------------------
00876
00877 inline uint32_t Date::GetDayOfYear() const
00878 {
00879     if (!IsInitialized())
00880         ACTIV_THROW(StatusCodeException, STATUS_CODE_NOT_INITIALIZED);
00881
00882     return GetDayOfYear(m_year, m_month, m_day);
00883 }
00884
00885 // ---------------------------------------------------------------------------------------------------------------------------------
00886
00887 inline uint32_t Date::GetWeekOfYear() const
00888 {
00889     if (!IsInitialized())
00890         ACTIV_THROW(StatusCodeException, STATUS_CODE_NOT_INITIALIZED);
00891
00892     return GetWeekOfYear(m_year, m_month, m_day);
00893 }
00894
00895 // ---------------------------------------------------------------------------------------------------------------------------------
00896
00897 inline void Date::Reset()
00898 {
00899     m_isInitialized = false;
00900 }
00901
00902 // ---------------------------------------------------------------------------------------------------------------------------------
00903
00904 inline void Date::Clear()
00905 {
00906     m_isInitialized = false;
00907 }
00908
00909 // ---------------------------------------------------------------------------------------------------------------------------------
00910
00911 inline size_t Date::GetSerializedLength() const
00912 {
00913     return GetSerializedBodyLength();
00914 }
00915
00916 // ---------------------------------------------------------------------------------------------------------------------------------
00917
00918 inline size_t Date::GetSerializedBodyLength() const
00919 {
00920     return (IsInitialized() ? GetMaxSerializedBodyLength() : 0);
00921 }
00922
00923 // ---------------------------------------------------------------------------------------------------------------------------------
00924
00925 inline size_t Date::GetMaxSerializedLength()
00926 {
00927     return GetMaxSerializedBodyLength();
00928 }
00929
00930 // ---------------------------------------------------------------------------------------------------------------------------------
00931
00932 inline size_t Date::GetMaxSerializedBodyLength()
00933 {
00934     return MAX_SERIALIZED_BODY_LENGTH;
00935 }
00936
00937 // ---------------------------------------------------------------------------------------------------------------------------------
00938
00939 inline bool Date::IsValidSerializedBodyLength(const size_t serializedBodyLength)
00940 {
00941     return (GetMaxSerializedBodyLength() == serializedBodyLength);
00942 }
00943
00944 // ---------------------------------------------------------------------------------------------------------------------------------
00945 // ---------------------------------------------------------------------------------------------------------------------------------
00946
00947 inline Date::Days::Days(const int32_t value) :
00948     m_value(value)
00949 {
00950 }
00951
00952 // ---------------------------------------------------------------------------------------------------------------------------------
00953 // ---------------------------------------------------------------------------------------------------------------------------------
00954
00958 template<>
00959 class FieldTypeToClass<FIELD_TYPE_DATE>
00960 {
00961 public:
00962     typedef Date Type;
00963 };
00964
00965 } // namespace Activ
00966
00967 #endif // (!defined ACTIV_FIELD_TYPES_DATE_H)
Generated on Wed Oct 8 14:01:48 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivFieldTypes

DateTime.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FIELD_TYPES_DATE_TIME_H)
00010 #define ACTIV_FIELD_TYPES_DATE_TIME_H
00011
00012 #include "ActivMiddleware/ActivFieldTypes/External.h"
00013 #include "ActivMiddleware/ActivFieldTypes/IFieldType.h"
00014 #include "ActivMiddleware/ActivFieldTypes/Date.h"
00015 #include "ActivMiddleware/ActivFieldTypes/Time.h"
00016
00017 #include "ActivMiddleware/ActivBase/StatusCodeException.h"
00018
00019 namespace Activ
00020 {
00021
00022 class MessageBuilder;
00023 class MessageValidator;
00024
00025 // ---------------------------------------------------------------------------------------------------------------------------------
00026
00030 class DateTime : public IFieldType
00031 {
00032 public:
00033     static const FieldType FIELD_TYPE = FIELD_TYPE_DATE_TIME;
00034
00035     typedef Date::Days Days;
00036     typedef Time::Hours Hours;
00037     typedef Time::Minutes Minutes;
00038     typedef Time::Seconds Seconds;
00039     typedef Time::Milliseconds Milliseconds;
00040
00041     using IFieldType::FromString;
00042     using IFieldType::Serialize;
00043     using IFieldType::SerializeBody;
00044     using IFieldType::SerializeLengthAndBody;
00045     using IFieldType::Deserialize;
00046     using IFieldType::DeserializeBody;
00047     using IFieldType::DeserializeLengthAndBody;
00048
00052     DateTime();
00053
00067     DateTime(const uint32_t year, const uint32_t month, const uint32_t day, const uint32_t hour, const uint32_t minute, const uint32_t second, const uint32_t millisecond = 0);
00068
00077     explicit DateTime(const int64_t julianDateTime, const uint32_t millisecond = 0);
00078
00089     DateTime(const std::tm &tm, const uint32_t millisecond = 0);
00090
00099     DateTime(const Date &date, const Time &time);
00100
00104     virtual ~DateTime();
00105
00109     operator const Date&() const;
00110
00114     operator const Time&() const;
00115
00125     bool operator==(const DateTime &rhs) const;
00126
00136     bool operator!=(const DateTime &rhs) const;
00137
00147     bool operator<(const DateTime &rhs) const;
00148
00158     bool operator<=(const DateTime &rhs) const;
00159
00169     bool operator>(const DateTime &rhs) const;
00170
00180     bool operator>=(const DateTime &rhs) const;
00181
00191     template <typename T> const DateTime operator+(const T &rhs) const;
00192
00202     template <typename T> DateTime &operator+=(const T &rhs);
00203
00213     template <typename T> const DateTime operator-(const T &rhs) const;
00214
00224     template <typename T> DateTime &operator-=(const T &rhs);
00225
00240     StatusCode Set(const uint32_t year, const uint32_t month, const uint32_t day, const uint32_t hour, const uint32_t minute, const uint32_t second, const uint32_t millisecond = 0);
00241
00251     StatusCode Set(const int64_t julianDateTime, const uint32_t millisecond = 0);
00252
00264     StatusCode Set(const std::tm &tm, const uint32_t millisecond = 0);
00265
00274     StatusCode Set(const Date &date, const Time &time);
00275
00283     int64_t Get() const;
00284
00298     StatusCode Get(uint32_t &year, uint32_t &month, uint32_t &day, uint32_t &hour, uint32_t &minute, uint32_t &second) const;
00299
00314     StatusCode Get(uint32_t &year, uint32_t &month, uint32_t &day, uint32_t &hour, uint32_t &minute, uint32_t &second, uint32_t &millisecond) const;
00315
00324     StatusCode Get(int64_t &julianDateTime) const;
00325
00335     StatusCode Get(int64_t &julianDateTime, uint32_t &millisecond) const;
00336
00347     StatusCode Get(std::tm &tm) const;
00348
00360     StatusCode Get(std::tm &tm, uint32_t &millisecond) const;
00361
00369     const Date &GetDate() const;
00370
00378     const Time &GetTime() const;
00379
00387     uint32_t GetYear() const;
00388
00396     uint32_t GetMonth() const;
00397
00405     uint32_t GetDay() const;
00406
00414     uint32_t GetDayOfWeek() const;
00415
00423     uint32_t GetDayOfYear() const;
00424
00432     uint32_t GetWeekOfYear() const;
00433
00441     uint32_t GetHour() const;
00442
00450     uint32_t GetMinute() const;
00451
00459     uint32_t GetSecond() const;
00460
00468     uint32_t GetMillisecond() const;
00469
00477     uint64_t GetTotalMilliseconds() const;
00478
00488     DateTime GetUtc() const;
00489
00499     DateTime GetLocal() const;
00500
00510     StatusCode Add(const Time &rhs);
00511
00521     StatusCode Add(const Days &days);
00522
00532     StatusCode Add(const Hours &hours);
00533
00543     StatusCode Add(const Minutes &minutes);
00544
00554     StatusCode Add(const Seconds &seconds);
00555
00565     ACTIV_FIELD_TYPES_API StatusCode Add(const Milliseconds &milliseconds);
00566
00576     StatusCode Subtract(const Time &rhs);
00577
00587     StatusCode Subtract(const Days &days);
00588
00598     StatusCode Subtract(const Hours &hours);
00599
00609     StatusCode Subtract(const Minutes &minutes);
00610
00620     StatusCode Subtract(const Seconds &seconds);
00621
00631     ACTIV_FIELD_TYPES_API StatusCode Subtract(const Milliseconds &milliseconds);
00632
00633     virtual void Reset();
00634     virtual void Clear();
00635
00644     ACTIV_FIELD_TYPES_API StatusCode Compare(const DateTime &rhs, int &result) const;
00645
00646     ACTIV_FIELD_TYPES_API virtual StatusCode Compare(const void * const pRhsSerializedBody, const size_t rhsSerializedBodyLength, int &result) const;
00647     ACTIV_FIELD_TYPES_API virtual StatusCode Convert(const IFieldType * const pIFieldType);
00648     ACTIV_FIELD_TYPES_API virtual std::string ToString() const;
00649
00657     ACTIV_FIELD_TYPES_API std::string ToString(const bool shouldDisplayMilliseconds) const;
00658
00659     ACTIV_FIELD_TYPES_API virtual StatusCode FromString(MessageValidator &messageValidator);
00660     ACTIV_FIELD_TYPES_API virtual std::string GetFromStringFormat() const;
00661     ACTIV_FIELD_TYPES_API virtual StatusCode Serialize(MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength) const;
00662     ACTIV_FIELD_TYPES_API virtual StatusCode SerializeBody(void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength) const;
00663     ACTIV_FIELD_TYPES_API virtual StatusCode SerializeLengthAndBody(MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength = MAX_SERIALIZED_BODY_LENGTH_UNDEFINED) const;
00664     ACTIV_FIELD_TYPES_API virtual StatusCode Deserialize(MessageValidator &messageValidator, const size_t maxSerializedBodyLength);
00665     ACTIV_FIELD_TYPES_API virtual StatusCode DeserializeBody(const void * const pSerializedBody, const size_t serializedBodyLength);
00666     ACTIV_FIELD_TYPES_API virtual StatusCode DeserializeLengthAndBody(MessageValidator &messageValidator, const size_t maxSerializedBodyLength = MAX_SERIALIZED_BODY_LENGTH_UNDEFINED);
00667     virtual size_t GetSerializedLength() const;
00668     virtual size_t GetSerializedBodyLength() const;
00669     ACTIV_FIELD_TYPES_API virtual StatusCode IsDifferent(const void * const pRhsSerializedBody, const size_t rhsSerializedBodyLength, bool &isDifferent) const;
00670
00678     static size_t GetSerializedLength(const void * const pSerializedBody);
00679
00687     static size_t GetSerializedBodyLength(const void * const pSerializedBody);
00688
00696     static size_t GetMaxSerializedLength(const bool shouldSerializeMilliseconds);
00697
00705     static size_t GetMaxSerializedBodyLength(const bool shouldSerializeMilliseconds);
00706
00719     ACTIV_FIELD_TYPES_API static StatusCode Compare(const void * const pLhsSerializedBody, const size_t lhsSerializedBodyLength, const void * const pRhsSerializedBody, const size_t rhsSerializedBodyLength, int &result);
00720
00728     ACTIV_FIELD_TYPES_API static int32_t GetTimeZoneOffset();
00729
00737     ACTIV_FIELD_TYPES_API static DateTime CreateUtcDateTime(const bool shouldSetMilliseconds = false);
00738
00746     ACTIV_FIELD_TYPES_API static DateTime CreateLocalDateTime(const bool shouldSetMilliseconds = false);
00747
00759     static void ConvertJulianToGregorianDateTime(const int64_t julianDateTime, int32_t &year, int32_t &month, int32_t &day, int32_t &hour, int32_t &minute, int32_t &second);
00760
00773     static int64_t ConvertGregorianToJulianDateTime(const int32_t year, const int32_t month, const int32_t day, const int32_t hour, const int32_t minute, const int32_t second);
00774
00782     static int32_t GetJulianDate(const int64_t julianDateTime);
00783
00791     static int32_t GetJulianTime(const int64_t julianDateTime);
00792
00803     ACTIV_FIELD_TYPES_API static StatusCode ValidateSerializedLengthAndBody(MessageValidator &messageValidator, size_t &serializedBodyOffset, size_t &serializedBodyLength);
00804
00812     static bool IsValidSerializedBodyLength(const size_t serializedBodyLength);
00813
00814 private:
00825     static StatusCode GetDateAndTimeMaxSerializedBodyLength(const size_t maxSerializedBodyLength, size_t &dateMaxSerializedBodyLength, size_t &timeMaxSerializedBodyLength);
00826
00827     Date    m_date;
00828     Time    m_time;
00829 };
00830
00831 // ---------------------------------------------------------------------------------------------------------------------------------
00832
00833 inline DateTime::DateTime() :
00834     IFieldType(FIELD_TYPE)
00835 {
00836     m_isInitialized = false;
00837 }
00838
00839 // ---------------------------------------------------------------------------------------------------------------------------------
00840
00841 inline DateTime::DateTime(const uint32_t year, const uint32_t month, const uint32_t day, const uint32_t hour, const uint32_t minute, const uint32_t second, const uint32_t millisecond) :
00842     IFieldType(FIELD_TYPE),
00843     m_date(year, month, day),
00844     m_time(hour, minute, second, millisecond)
00845 {
00846     m_isInitialized = true;
00847 }
00848
00849 // ---------------------------------------------------------------------------------------------------------------------------------
00850
00851 inline DateTime::DateTime(const int64_t julianDateTime, const uint32_t millisecond) :
00852     IFieldType(FIELD_TYPE),
00853     m_date(GetJulianDate(julianDateTime)),
00854     m_time(GetJulianTime(julianDateTime), millisecond)
00855 {
00856     m_isInitialized = true;
00857 }
00858
00859 // ---------------------------------------------------------------------------------------------------------------------------------
00860
00861 inline DateTime::DateTime(const std::tm &tm, const uint32_t millisecond) :
00862     IFieldType(FIELD_TYPE),
00863     m_date(tm),
00864     m_time(tm, millisecond)
00865 {
00866     m_isInitialized = true;
00867 }
00868
00869 // ---------------------------------------------------------------------------------------------------------------------------------
00870
00871 inline DateTime::DateTime(const Date &date, const Time &time) :
00872     IFieldType(FIELD_TYPE),
00873     m_date(date),
00874     m_time(time)
00875 {
00876     if (m_date.IsInitialized() != m_time.IsInitialized())
00877         ACTIV_THROW(StatusCodeException, STATUS_CODE_INVALID_PARAMETER);
00878
00879     m_isInitialized = m_date.IsInitialized();
00880 }
00881
00882 // ---------------------------------------------------------------------------------------------------------------------------------
00883
00884 inline DateTime::~DateTime()
00885 {
00886 }
00887
00888 // ---------------------------------------------------------------------------------------------------------------------------------
00889
00890 inline DateTime::operator const Date&() const
00891 {
00892     return m_date;
00893 }
00894
00895 // ---------------------------------------------------------------------------------------------------------------------------------
00896
00897 inline DateTime::operator const Time&() const
00898 {
00899     return m_time;
00900 }
00901
00902 // ---------------------------------------------------------------------------------------------------------------------------------
00903
00904 inline bool DateTime::operator==(const DateTime &rhs) const
00905 {
00906     int result;
00907     ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, Compare(rhs, result));
00908
00909     return (0 == result);
00910 }
00911
00912 // ---------------------------------------------------------------------------------------------------------------------------------
00913
00914 inline bool DateTime::operator!=(const DateTime &rhs) const
00915 {
00916     return !((*this) == rhs);
00917 }
00918
00919 // ---------------------------------------------------------------------------------------------------------------------------------
00920
00921 inline bool DateTime::operator<(const DateTime &rhs) const
00922 {
00923     int result;
00924     ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, Compare(rhs, result));
00925
00926     return (result < 0);
00927 }
00928
00929 // ---------------------------------------------------------------------------------------------------------------------------------
00930
00931 inline bool DateTime::operator<=(const DateTime &rhs) const
00932 {
00933     return !((*this) > rhs);
00934 }
00935
00936 // ---------------------------------------------------------------------------------------------------------------------------------
00937
00938 inline bool DateTime::operator>(const DateTime &rhs) const
00939 {
00940     int result;
00941     ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, Compare(rhs, result));
00942
00943     return (result > 0);
00944 }
00945
00946 // ---------------------------------------------------------------------------------------------------------------------------------
00947
00948 inline bool DateTime::operator>=(const DateTime &rhs) const
00949 {
00950     return !((*this) < rhs);
00951 }
00952
00953 // ---------------------------------------------------------------------------------------------------------------------------------
00954
00955 template <typename T> inline const DateTime DateTime::operator+(const T &rhs) const
00956 {
00957     return DateTime(*this) += rhs;
00958 }
00959
00960 // ---------------------------------------------------------------------------------------------------------------------------------
00961
00962 template <typename T> inline DateTime& DateTime::operator+=(const T &rhs)
00963 {
00964     ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, Add(rhs));
00965
00966     return (*this);
00967 }
00968
00969 // ---------------------------------------------------------------------------------------------------------------------------------
00970
00971 template <typename T> inline const DateTime DateTime::operator-(const T &rhs) const
00972 {
00973     return DateTime(*this) -= rhs;
00974 }
00975
00976 // ---------------------------------------------------------------------------------------------------------------------------------
00977
00978 template <typename T> inline DateTime& DateTime::operator-=(const T &rhs)
00979 {
00980     ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, Subtract(rhs));
00981
00982     return (*this);
00983 }
00984
00985 // ---------------------------------------------------------------------------------------------------------------------------------
00986
00987 inline StatusCode DateTime::Set(const uint32_t year, const uint32_t month, const uint32_t day, const uint32_t hour, const uint32_t minute, const uint32_t second, const uint32_t millisecond)
00988 {
00989     Date date;
00990     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, date.Set(year, month, day));
00991
00992     Time time;
00993     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, time.Set(hour, minute, second, millisecond));
00994
00995     return Set(date, time);
00996 }
00997
00998 // ---------------------------------------------------------------------------------------------------------------------------------
00999
01000 inline StatusCode DateTime::Set(const int64_t julianDateTime, const uint32_t millisecond)
01001 {
01002     Date date;
01003     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, date.Set(GetJulianDate(julianDateTime)));
01004
01005     Time time;
01006     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, time.Set(GetJulianTime(julianDateTime), millisecond));
01007
01008     return Set(date, time);
01009 }
01010
01011 // ---------------------------------------------------------------------------------------------------------------------------------
01012
01013 inline StatusCode DateTime::Set(const std::tm &tm, const uint32_t millisecond)
01014 {
01015     Date date;
01016     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, date.Set(tm));
01017
01018     Time time;
01019     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, time.Set(tm, millisecond));
01020
01021     return Set(date, time);
01022 }
01023
01024 // ---------------------------------------------------------------------------------------------------------------------------------
01025
01026 inline StatusCode DateTime::Set(const Date &date, const Time &time)
01027 {
01028     m_date = date;
01029     m_time = time;
01030     m_isInitialized = true;
01031
01032     return STATUS_CODE_SUCCESS;
01033 }
01034
01035 // ---------------------------------------------------------------------------------------------------------------------------------
01036
01037 inline int64_t DateTime::Get() const
01038 {
01039     if (!IsInitialized())
01040         ACTIV_THROW(StatusCodeException, STATUS_CODE_NOT_INITIALIZED);
01041
01042     return ConvertGregorianToJulianDateTime(m_date.m_year, m_date.m_month, m_date.m_day, m_time.m_hour, m_time.m_minute, m_time.m_second);
01043 }
01044
01045 // ---------------------------------------------------------------------------------------------------------------------------------
01046
01047 inline StatusCode DateTime::Get(uint32_t &year, uint32_t &month, uint32_t &day, uint32_t &hour, uint32_t &minute, uint32_t &second) const
01048 {
01049     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, m_date.Get(year, month, day));
01050     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, m_time.Get(hour, minute, second));
01051
01052     return STATUS_CODE_SUCCESS;
01053 }
01054
01055 // ---------------------------------------------------------------------------------------------------------------------------------
01056
01057 inline StatusCode DateTime::Get(uint32_t &year, uint32_t &month, uint32_t &day, uint32_t &hour, uint32_t &minute, uint32_t &second, uint32_t &millisecond) const
01058 {
01059     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, Get(year, month, day, hour, minute, second));
01060
01061     millisecond = m_time.m_millisecond;
01062
01063     return STATUS_CODE_SUCCESS;
01064 }
01065
01066 // ---------------------------------------------------------------------------------------------------------------------------------
01067
01068 inline StatusCode DateTime::Get(int64_t &julianDateTime) const
01069 {
01070     if (!IsInitialized())
01071         return STATUS_CODE_NOT_INITIALIZED;
01072
01073     julianDateTime = ConvertGregorianToJulianDateTime(m_date.m_year, m_date.m_month, m_date.m_day, m_time.m_hour, m_time.m_minute, m_time.m_second);
01074
01075     return STATUS_CODE_SUCCESS;
01076 }
01077
01078 // ---------------------------------------------------------------------------------------------------------------------------------
01079
01080 inline StatusCode DateTime::Get(int64_t &julianDateTime, uint32_t &millisecond) const
01081 {
01082     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, Get(julianDateTime));
01083
01084     millisecond = m_time.m_millisecond;
01085
01086     return STATUS_CODE_SUCCESS;
01087 }
01088
01089 // ---------------------------------------------------------------------------------------------------------------------------------
01090
01091 inline StatusCode DateTime::Get(std::tm &tm) const
01092 {
01093     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, m_date.Get(tm));
01094     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, m_time.Get(tm));
01095
01096     return STATUS_CODE_SUCCESS;
01097 }
01098
01099 // ---------------------------------------------------------------------------------------------------------------------------------
01100
01101 inline StatusCode DateTime::Get(std::tm &tm, uint32_t &millisecond) const
01102 {
01103     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, Get(tm));
01104
01105     millisecond = m_time.m_millisecond;
01106
01107     return STATUS_CODE_SUCCESS;
01108 }
01109
01110 // ---------------------------------------------------------------------------------------------------------------------------------
01111
01112 inline const Date &DateTime::GetDate() const
01113 {
01114     return m_date;
01115 }
01116
01117 // ---------------------------------------------------------------------------------------------------------------------------------
01118
01119 inline const Time &DateTime::GetTime() const
01120 {
01121     return m_time;
01122 }
01123
01124 // ---------------------------------------------------------------------------------------------------------------------------------
01125
01126 inline uint32_t DateTime::GetYear() const
01127 {
01128     return m_date.GetYear();
01129 }
01130
01131 // ---------------------------------------------------------------------------------------------------------------------------------
01132
01133 inline uint32_t DateTime::GetMonth() const
01134 {
01135     return m_date.GetMonth();
01136 }
01137
01138 // ---------------------------------------------------------------------------------------------------------------------------------
01139
01140 inline uint32_t DateTime::GetDay() const
01141 {
01142     return m_date.GetDay();
01143 }
01144
01145 // ---------------------------------------------------------------------------------------------------------------------------------
01146
01147 inline uint32_t DateTime::GetDayOfWeek() const
01148 {
01149     return m_date.GetDayOfWeek();
01150 }
01151
01152 // ---------------------------------------------------------------------------------------------------------------------------------
01153
01154 inline uint32_t DateTime::GetDayOfYear() const
01155 {
01156     return m_date.GetDayOfYear();
01157 }
01158
01159 // ---------------------------------------------------------------------------------------------------------------------------------
01160
01161 inline uint32_t DateTime::GetWeekOfYear() const
01162 {
01163     return m_date.GetWeekOfYear();
01164 }
01165
01166 // ---------------------------------------------------------------------------------------------------------------------------------
01167
01168 inline uint32_t DateTime::GetHour() const
01169 {
01170     return m_time.GetHour();
01171 }
01172
01173 // ---------------------------------------------------------------------------------------------------------------------------------
01174
01175 inline uint32_t DateTime::GetMinute() const
01176 {
01177     return m_time.GetMinute();
01178 }
01179
01180 // ---------------------------------------------------------------------------------------------------------------------------------
01181
01182 inline uint32_t DateTime::GetSecond() const
01183 {
01184     return m_time.GetSecond();
01185 }
01186
01187 // ---------------------------------------------------------------------------------------------------------------------------------
01188
01189 inline uint32_t DateTime::GetMillisecond() const
01190 {
01191     return m_time.GetMillisecond();
01192 }
01193
01194 // ---------------------------------------------------------------------------------------------------------------------------------
01195
01196 inline uint64_t DateTime::GetTotalMilliseconds() const
01197 {
01198     if (!IsInitialized())
01199         ACTIV_THROW(StatusCodeException, STATUS_CODE_NOT_INITIALIZED);
01200
01201     return (static_cast<uint64_t>(ConvertGregorianToJulianDateTime(m_date.m_year, m_date.m_month, m_date.m_day, m_time.m_hour, m_time.m_minute, m_time.m_second)) * Milliseconds::NUMBER_PER_SECOND) + m_time.m_millisecond;
01202 }
01203
01204 // ---------------------------------------------------------------------------------------------------------------------------------
01205
01206 inline DateTime DateTime::GetUtc() const
01207 {
01208     if (!IsInitialized())
01209         ACTIV_THROW(StatusCodeException, STATUS_CODE_NOT_INITIALIZED);
01210
01211     return (*this) + DateTime::Seconds(GetTimeZoneOffset());
01212 }
01213
01214 // ---------------------------------------------------------------------------------------------------------------------------------
01215
01216 inline DateTime DateTime::GetLocal() const
01217 {
01218     if (!IsInitialized())
01219         ACTIV_THROW(StatusCodeException, STATUS_CODE_NOT_INITIALIZED);
01220
01221     return (*this) - DateTime::Seconds(GetTimeZoneOffset());
01222 }
01223
01224 // ---------------------------------------------------------------------------------------------------------------------------------
01225
01226 inline StatusCode DateTime::Add(const Time &rhs)
01227 {
01228     if (!rhs.IsInitialized())
01229         return STATUS_CODE_NOT_INITIALIZED;
01230
01231     return Add(Milliseconds(rhs.GetTotalMilliseconds()));
01232 }
01233
01234 // ---------------------------------------------------------------------------------------------------------------------------------
01235
01236 inline StatusCode DateTime::Add(const Days &days)
01237 {
01238     return m_date.Add(Date::Days(days.m_value));
01239 }
01240
01241 // ---------------------------------------------------------------------------------------------------------------------------------
01242
01243 inline StatusCode DateTime::Add(const Hours &hours)
01244 {
01245     return Add(Milliseconds(hours.m_value * Milliseconds::NUMBER_PER_HOUR));
01246 }
01247
01248 // ---------------------------------------------------------------------------------------------------------------------------------
01249
01250 inline StatusCode DateTime::Add(const Minutes &minutes)
01251 {
01252     return Add(Milliseconds(minutes.m_value * Milliseconds::NUMBER_PER_MINUTE));
01253 }
01254
01255 // ---------------------------------------------------------------------------------------------------------------------------------
01256
01257 inline StatusCode DateTime::Add(const Seconds &seconds)
01258 {
01259     return Add(Milliseconds(seconds.m_value * Milliseconds::NUMBER_PER_SECOND));
01260 }
01261
01262 // ---------------------------------------------------------------------------------------------------------------------------------
01263
01264 inline StatusCode DateTime::Subtract(const Time &rhs)
01265 {
01266     if (!rhs.IsInitialized())
01267         return STATUS_CODE_NOT_INITIALIZED;
01268
01269     return Subtract(Milliseconds(rhs.GetTotalMilliseconds()));
01270 }
01271
01272 // ---------------------------------------------------------------------------------------------------------------------------------
01273
01274 inline StatusCode DateTime::Subtract(const Days &days)
01275 {
01276     return m_date.Subtract(Date::Days(days.m_value));
01277 }
01278
01279 // ---------------------------------------------------------------------------------------------------------------------------------
01280
01281 inline StatusCode DateTime::Subtract(const Hours &hours)
01282 {
01283     return Subtract(Milliseconds(hours.m_value * Milliseconds::NUMBER_PER_HOUR));
01284 }
01285
01286 // ---------------------------------------------------------------------------------------------------------------------------------
01287
01288 inline StatusCode DateTime::Subtract(const Minutes &minutes)
01289 {
01290     return Subtract(Milliseconds(minutes.m_value * Milliseconds::NUMBER_PER_MINUTE));
01291 }
01292
01293 // ---------------------------------------------------------------------------------------------------------------------------------
01294
01295 inline StatusCode DateTime::Subtract(const Seconds &seconds)
01296 {
01297     return Subtract(Milliseconds(seconds.m_value * Milliseconds::NUMBER_PER_SECOND));
01298 }
01299
01300 // ---------------------------------------------------------------------------------------------------------------------------------
01301
01302 inline void DateTime::Reset()
01303 {
01304     m_date.Reset();
01305     m_time.Reset();
01306     m_isInitialized = false;
01307 }
01308
01309 // ---------------------------------------------------------------------------------------------------------------------------------
01310
01311 inline void DateTime::Clear()
01312 {
01313     m_date.Clear();
01314     m_time.Clear();
01315     m_isInitialized = false;
01316 }
01317
01318 // ---------------------------------------------------------------------------------------------------------------------------------
01319
01320 inline size_t DateTime::GetSerializedLength() const
01321 {
01322     return (m_date.GetSerializedLength() + m_time.GetSerializedLength());
01323 }
01324
01325 // ---------------------------------------------------------------------------------------------------------------------------------
01326
01327 inline size_t DateTime::GetSerializedBodyLength() const
01328 {
01329     return (m_date.GetSerializedBodyLength() + m_time.GetSerializedBodyLength());
01330 }
01331
01332 // ---------------------------------------------------------------------------------------------------------------------------------
01333
01334 inline size_t DateTime::GetSerializedLength(const void * const pSerializedBody)
01335 {
01336     return (Date::GetMaxSerializedLength() + Time::GetSerializedLength(static_cast<const byte_t * const>(pSerializedBody) + Date::GetMaxSerializedBodyLength()));
01337 }
01338
01339 // ---------------------------------------------------------------------------------------------------------------------------------
01340
01341 inline size_t DateTime::GetSerializedBodyLength(const void * const pSerializedBody)
01342 {
01343     return (Date::GetMaxSerializedBodyLength() + Time::GetSerializedBodyLength(static_cast<const byte_t * const>(pSerializedBody) + Date::GetMaxSerializedBodyLength()));
01344 }
01345
01346 // ---------------------------------------------------------------------------------------------------------------------------------
01347
01348 inline size_t DateTime::GetMaxSerializedLength(const bool shouldSerializeMilliseconds)
01349 {
01350     return (Date::GetMaxSerializedLength() + Time::GetMaxSerializedLength(shouldSerializeMilliseconds));
01351 }
01352
01353 // ---------------------------------------------------------------------------------------------------------------------------------
01354
01355 inline size_t DateTime::GetMaxSerializedBodyLength(const bool shouldSerializeMilliseconds)
01356 {
01357     return (Date::GetMaxSerializedBodyLength() + Time::GetMaxSerializedBodyLength(shouldSerializeMilliseconds));
01358 }
01359
01360 // ---------------------------------------------------------------------------------------------------------------------------------
01361
01362 inline void DateTime::ConvertJulianToGregorianDateTime(const int64_t julianDateTime, int32_t &year, int32_t &month, int32_t &day, int32_t &hour, int32_t &minute, int32_t &second)
01363 {
01364     Date::ConvertJulianToGregorianDate(GetJulianDate(julianDateTime), year, month, day);
01365     Time::ConvertJulianToGregorianTime(GetJulianTime(julianDateTime), hour, minute, second);
01366 }
01367
01368 // ---------------------------------------------------------------------------------------------------------------------------------
01369
01370 inline int64_t DateTime::ConvertGregorianToJulianDateTime(const int32_t year, const int32_t month, const int32_t day, const int32_t hour, const int32_t minute, const int32_t second)
01371 {
01372     return ((static_cast<int64_t>(Date::ConvertGregorianToJulianDate(year, month, day)) * Time::Seconds::NUMBER_PER_DAY) + static_cast<int64_t>(Time::ConvertGregorianToJulianTime(hour, minute, second)));
01373 }
01374
01375 // ---------------------------------------------------------------------------------------------------------------------------------
01376
01377 inline int32_t DateTime::GetJulianDate(int64_t julianDateTime)
01378 {
01379     return static_cast<int32_t>((julianDateTime / static_cast<int64_t>(Time::Seconds::NUMBER_PER_DAY)) + ((julianDateTime < 0) && ((julianDateTime % static_cast<int64_t>(Time::Seconds::NUMBER_PER_DAY)) != 0) ? -1 : 0));
01380 }
01381
01382 // ---------------------------------------------------------------------------------------------------------------------------------
01383
01384 inline int32_t DateTime::GetJulianTime(int64_t julianDateTime)
01385 {
01386     return static_cast<int32_t>((Time::Seconds::NUMBER_PER_DAY + (julianDateTime % static_cast<int64_t>(Time::Seconds::NUMBER_PER_DAY))) % Time::Seconds::NUMBER_PER_DAY);
01387 }
01388
01389 // ---------------------------------------------------------------------------------------------------------------------------------
01390
01391 inline bool DateTime::IsValidSerializedBodyLength(const size_t serializedBodyLength)
01392 {
01393     size_t dateSerializedBodyLength, timeSerializedBodyLength;
01394     ACTIV_RETURN_FALSE_IF(STATUS_CODE_SUCCESS, !=, GetDateAndTimeMaxSerializedBodyLength(serializedBodyLength, dateSerializedBodyLength, timeSerializedBodyLength));
01395
01396     return ((Date::IsValidSerializedBodyLength(dateSerializedBodyLength)) && (Time::IsValidSerializedBodyLength(timeSerializedBodyLength)));
01397 }
01398
01399 // ---------------------------------------------------------------------------------------------------------------------------------
01400
01401 inline StatusCode DateTime::GetDateAndTimeMaxSerializedBodyLength(const size_t maxSerializedBodyLength, size_t &dateMaxSerializedBodyLength, size_t &timeMaxSerializedBodyLength)
01402 {
01403     if (MAX_SERIALIZED_BODY_LENGTH_UNDEFINED != maxSerializedBodyLength)
01404     {
01405         dateMaxSerializedBodyLength = Date::GetMaxSerializedBodyLength();
01406
01407         if (dateMaxSerializedBodyLength >= maxSerializedBodyLength)
01408             return STATUS_CODE_INVALID_PARAMETER;
01409
01410         timeMaxSerializedBodyLength = maxSerializedBodyLength - dateMaxSerializedBodyLength;
01411     }
01412     else
01413     {
01414         dateMaxSerializedBodyLength = MAX_SERIALIZED_BODY_LENGTH_UNDEFINED;
01415         timeMaxSerializedBodyLength = MAX_SERIALIZED_BODY_LENGTH_UNDEFINED;
01416     }
01417
01418     return STATUS_CODE_SUCCESS;
01419 }
01420
01421 // ---------------------------------------------------------------------------------------------------------------------------------
01422 // ---------------------------------------------------------------------------------------------------------------------------------
01423
01427 template<>
01428 class FieldTypeToClass<FIELD_TYPE_DATE_TIME>
01429 {
01430 public:
01431     typedef DateTime Type;
01432 };
01433
01434 } // namespace Activ
01435
01436 #endif // (!defined ACTIV_FIELD_TYPES_DATE_TIME_H)
Generated on Wed Oct 8 14:01:48 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivDatabase

Definitions.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_DATABASE_DEFINITIONS_H)
00010 #define ACTIV_DATABASE_DEFINITIONS_H
00011
00012 #include "ActivMiddleware/Activ.h"
00013
00014 #include "ActivMiddleware/ActivDatabase/FieldSpecification.h"
00015 #include "ActivMiddleware/ActivDatabase/IndexSpecification.h"
00016 #include "ActivMiddleware/ActivDatabase/TableSpecification.h"
00017 #include "ActivMiddleware/ActivDatabase/DatabaseSpecification.h"
00018
00019 namespace Activ
00020 {
00021
00022 namespace Database
00023 {
00024
00025 // Used as a unique identifier for records and keys in data storage areas.
00026 typedef int32_t DataId;
00027 const DataId UNDEFINED_ID = -1;
00028
00029 // Mode is a user defined value which can be used to indicate different states
00030 // of database or table operation. For example, it can be used to indicate that
00031 // a database is recovering from a failure and the contents shouldn't necessarily
00032 // be trusted.
00033 typedef byte_t Mode;
00034
00035 // Default value used when doing partial matches on keys in tables.
00036 const size_t FIELD_COMPARE_LENGTH_WHOLE = ~0;
00037
00038 typedef std::vector<FieldSpecification> FieldSpecificationList;
00039 typedef std::vector<FieldSpecification::Id> FieldIdList;
00040 typedef std::vector<IndexSpecification> IndexSpecificationList;
00041 typedef std::vector<IndexSpecification::Field> IndexFieldSpecificationList;
00042 typedef std::vector<DatabaseSpecification::TableId> TableIdList;
00043
00044 } // namespace Database
00045
00046 } // namespace Activ
00047
00048 #endif // (!defined ACTIV_DATABASE_DEFINITIONS_H)
Generated on Wed Oct 8 14:01:47 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » Misc

Des3Helper.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_MISC_DES3_HELPER_H)
00010 #define ACTIV_MISC_DES3_HELPER_H
00011
00012 #include "ActivMiddleware/ActivBase/StatusCodeException.h"
00013 #include "ActivMiddleware/ActivBase/MessageValidator.h"
00014
00015 #include <openssl/des.h>
00016
00017 #include <sstream>
00018 #include <iomanip>
00019
00020 namespace Activ
00021 {
00022
00023 class Des3Helper
00024 {
00025 public:
00029     class Key
00030     {
00031     public:
00035         Key();
00036
00040         Key(const DES_cblock &keyBlock);
00041
00045         Key(const std::string &hexString);
00046
00050         bool IsInitialized() const;
00051
00055         const DES_cblock &GetKeyBlock() const;
00056
00060         const DES_key_schedule &GetKeySchedule() const;
00061
00065         StatusCode Randomize();
00066
00070         void SetKey(const Key &key);
00071
00075         StatusCode SetKey(const DES_cblock &keyBlock);
00076
00080         StatusCode SetKey(const std::string &hexString);
00081
00085         std::string ToString() const;
00086
00087     private:
00088         bool                m_isInitialized;
00089
00090         DES_cblock          m_keyBlock;
00091         DES_key_schedule    m_keySchedule;
00092     };
00093
00097     class KeyBundle
00098     {
00099     public:
00103         KeyBundle();
00104
00108         KeyBundle(const Des3Helper::Key &key1, const Des3Helper::Key &key2, const Des3Helper::Key &key3);
00109
00113         StatusCode Randomize();
00114
00118         void SetKeys(const Des3Helper::Key &key1, const Des3Helper::Key &key2, const Des3Helper::Key &key3);
00119
00120         Des3Helper::Key     m_key1;
00121         Des3Helper::Key     m_key2;
00122         Des3Helper::Key     m_key3;
00123     };
00124
00132     static void Encrypt(const DES_cblock &input, DES_cblock &output, const KeyBundle &keyBundle);
00133
00141     static void Decrypt(const DES_cblock &input, DES_cblock &output, const KeyBundle &keyBundle);
00142
00143 private:
00149     Des3Helper();
00150 };
00151
00152 // ---------------------------------------------------------------------------------------------------------------------------------
00153
00154 inline void Des3Helper::Encrypt(const DES_cblock &input, DES_cblock &output, const KeyBundle &keyBundle)
00155 {
00156     DES_ecb3_encrypt(const_cast<const_DES_cblock *>(&input), &output,
00157         const_cast<DES_key_schedule *>(&keyBundle.m_key1.GetKeySchedule()),
00158         const_cast<DES_key_schedule *>(&keyBundle.m_key2.GetKeySchedule()),
00159         const_cast<DES_key_schedule *>(&keyBundle.m_key3.GetKeySchedule()),
00160         DES_ENCRYPT);
00161 }
00162
00163 // ---------------------------------------------------------------------------------------------------------------------------------
00164
00165 inline void Des3Helper::Decrypt(const DES_cblock &input, DES_cblock &output, const KeyBundle &keyBundle)
00166 {
00167     DES_ecb3_encrypt(const_cast<const_DES_cblock *>(&input), &output,
00168         const_cast<DES_key_schedule *>(&keyBundle.m_key1.GetKeySchedule()),
00169         const_cast<DES_key_schedule *>(&keyBundle.m_key2.GetKeySchedule()),
00170         const_cast<DES_key_schedule *>(&keyBundle.m_key3.GetKeySchedule()),
00171         DES_DECRYPT);
00172 }
00173
00174 // ---------------------------------------------------------------------------------------------------------------------------------
00175 // ---------------------------------------------------------------------------------------------------------------------------------
00176
00177 inline Des3Helper::Key::Key() :
00178     m_isInitialized(false)
00179 {
00180 }
00181
00182 // ---------------------------------------------------------------------------------------------------------------------------------
00183
00184 inline Des3Helper::Key::Key(const DES_cblock &keyBlock) :
00185     m_isInitialized(false)
00186 {
00187     ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, SetKey(keyBlock));
00188 }
00189
00190 // ---------------------------------------------------------------------------------------------------------------------------------
00191
00192 inline Des3Helper::Key::Key(const std::string &hexString) :
00193     m_isInitialized(false)
00194 {
00195     SetKey(hexString);
00196 }
00197
00198 // ---------------------------------------------------------------------------------------------------------------------------------
00199
00200 inline bool Des3Helper::Key::IsInitialized() const
00201 {
00202     return m_isInitialized;
00203 }
00204
00205 // ---------------------------------------------------------------------------------------------------------------------------------
00206
00207 inline const DES_cblock &Des3Helper::Key::GetKeyBlock() const
00208 {
00209     return m_keyBlock;
00210 }
00211
00212 // ---------------------------------------------------------------------------------------------------------------------------------
00213
00214 inline const DES_key_schedule &Des3Helper::Key::GetKeySchedule() const
00215 {
00216     return m_keySchedule;
00217 }
00218
00219 // ---------------------------------------------------------------------------------------------------------------------------------
00220
00221 inline StatusCode Des3Helper::Key::Randomize()
00222 {
00223     // DES_random_key returns zero on failure
00224     if (DES_random_key(&m_keyBlock) == 0)
00225         return STATUS_CODE_FAILURE;
00226
00227     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, SetKey(m_keyBlock));
00228
00229     return STATUS_CODE_SUCCESS;
00230 }
00231
00232 // ---------------------------------------------------------------------------------------------------------------------------------
00233
00234 inline void Des3Helper::Key::SetKey(const Des3Helper::Key &key)
00235 {
00236     *this = key;
00237 }
00238
00239 // ---------------------------------------------------------------------------------------------------------------------------------
00240
00241 inline StatusCode Des3Helper::Key::SetKey(const DES_cblock &keyBlock)
00242 {
00243     // DES_set_key_checked returns zero on success
00244     if (DES_set_key_checked(const_cast<const_DES_cblock *>(&keyBlock), &m_keySchedule) != 0)
00245         return STATUS_CODE_INVALID_KEY;
00246
00247     // Copy key block
00248     if (&m_keyBlock != &keyBlock)
00249         ::memcpy(&m_keyBlock, &keyBlock, sizeof(DES_cblock));
00250
00251     m_isInitialized = true;
00252
00253     return STATUS_CODE_SUCCESS;
00254 }
00255
00256 // ---------------------------------------------------------------------------------------------------------------------------------
00257
00258 inline StatusCode Des3Helper::Key::SetKey(const std::string &hexString)
00259 {
00260     // String must be exactly twice the length of a DES_cblock (2 chars per byte)
00261     if (hexString.length() != (2 * sizeof(DES_cblock)))
00262         return STATUS_CODE_INVALID_LENGTH;
00263
00264     DES_cblock newKeyBlock;
00265     MessageValidator hexValidator(hexString.data(), hexString.length());
00266
00267     // Validate the hex 2 chars (1 byte) at a time
00268     for (size_t i = 0; i < sizeof(DES_cblock); ++i)
00269     {
00270         Activ::byte_t byte;
00271         ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, hexValidator.ValidateAsciiHexadecimalIntegral(2 * sizeof(byte), MessageHandler::ENDIAN_LOCAL, &byte));
00272
00273         newKeyBlock[i] = byte;
00274     }
00275
00276     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, SetKey(newKeyBlock));
00277
00278     return STATUS_CODE_SUCCESS;
00279 }
00280
00281 // ---------------------------------------------------------------------------------------------------------------------------------
00282
00283 inline std::string Des3Helper::Key::ToString() const
00284 {
00285     std::ostringstream str;
00286     str.flags(std::ios::hex | std::ios::uppercase);
00287     str.fill('0');
00288
00289     for (size_t i = 0; i < sizeof(m_keyBlock); ++i)
00290         str << std::setw(2) << static_cast<size_t>(m_keyBlock[i]);
00291
00292     return str.str();
00293 }
00294
00295 // ---------------------------------------------------------------------------------------------------------------------------------
00296 // ---------------------------------------------------------------------------------------------------------------------------------
00297
00298 inline Des3Helper::KeyBundle::KeyBundle()
00299 {
00300 }
00301
00302 // ---------------------------------------------------------------------------------------------------------------------------------
00303
00304 inline Des3Helper::KeyBundle::KeyBundle(const Des3Helper::Key &key1, const Des3Helper::Key &key2, const Des3Helper::Key &key3) :
00305     m_key1(key1),
00306     m_key2(key2),
00307     m_key3(key3)
00308 {
00309 }
00310
00311 // ---------------------------------------------------------------------------------------------------------------------------------
00312
00313 inline StatusCode Des3Helper::KeyBundle::Randomize()
00314 {
00315     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, m_key1.Randomize());
00316     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, m_key2.Randomize());
00317     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, m_key3.Randomize());
00318
00319     return STATUS_CODE_SUCCESS;
00320 }
00321
00322 // ---------------------------------------------------------------------------------------------------------------------------------
00323
00324 inline void Des3Helper::KeyBundle::SetKeys(const Des3Helper::Key &key1, const Des3Helper::Key &key2, const Des3Helper::Key &key3)
00325 {
00326     m_key1.SetKey(key1);
00327     m_key2.SetKey(key2);
00328     m_key3.SetKey(key3);
00329 }
00330
00331 } // namespace Activ;
00332
00333 #endif // (!defined ACTIV_MISC_DES3_HELPER_H)
Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » Misc

DesHelper.h

Go to the documentation of this file.
00001
00012 #if (!defined ACTIV_MISC_DES_HELPER_H)
00013 #define ACTIV_MISC_DES_HELPER_H
00014
00015 #include "ActivMiddleware/ActivBase/StatusCodeException.h"
00016 #include "ActivMiddleware/ActivBase/MessageValidator.h"
00017
00018 #include <openssl/des.h>
00019
00020 #include <sstream>
00021 #include <iomanip>
00022
00023 namespace Activ
00024 {
00025
00026 class DesHelper
00027 {
00028 private:
00032     DesHelper();
00033
00034 public:
00038     class Key
00039     {
00040     public:
00044         Key();
00045
00049         Key(const DES_cblock &keyBlock);
00050
00054         Key(const std::string &hexString);
00055
00059         bool IsInitialized() const;
00060
00064         const DES_cblock &GetKeyBlock() const;
00065
00069         const DES_key_schedule &GetKeySchedule() const;
00070
00074         StatusCode Randomize();
00075
00079         void SetKey(const Key &key);
00080
00084         StatusCode SetKey(const DES_cblock &keyBlock);
00085
00089         StatusCode SetKey(const std::string &hexString);
00090
00094         std::string ToString() const;
00095
00096     private:
00097         bool                m_isInitialized;
00098
00099         DES_cblock          m_keyBlock;
00100         DES_key_schedule    m_keySchedule;
00101     };
00102
00110     static void Encrypt(const DES_cblock &input, DES_cblock &output, const DesHelper::Key key);
00111
00119     static void Decrypt(const DES_cblock &input, DES_cblock &output, const DesHelper::Key key);
00120 };
00121
00122 // ---------------------------------------------------------------------------------------------------------------------------------
00123
00124 inline void DesHelper::Encrypt(const DES_cblock &input, DES_cblock &output, const DesHelper::Key key)
00125 {
00126     DES_ecb_encrypt(const_cast<const_DES_cblock *>(&input), &output, const_cast<DES_key_schedule *>(&key.GetKeySchedule()),
00127         DES_ENCRYPT);
00128 }
00129
00130 // ---------------------------------------------------------------------------------------------------------------------------------
00131
00132 inline void DesHelper::Decrypt(const DES_cblock &input, DES_cblock &output, const DesHelper::Key key)
00133 {
00134     DES_ecb_encrypt(const_cast<const_DES_cblock *>(&input), &output, const_cast<DES_key_schedule *>(&key.GetKeySchedule()),
00135         DES_DECRYPT);
00136 }
00137
00138 // ---------------------------------------------------------------------------------------------------------------------------------
00139 // ---------------------------------------------------------------------------------------------------------------------------------
00140
00141 inline DesHelper::Key::Key() :
00142     m_isInitialized(false)
00143 {
00144 }
00145
00146 // ---------------------------------------------------------------------------------------------------------------------------------
00147
00148 inline DesHelper::Key::Key(const DES_cblock &keyBlock) :
00149     m_isInitialized(false)
00150 {
00151     ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, SetKey(keyBlock));
00152 }
00153
00154 // ---------------------------------------------------------------------------------------------------------------------------------
00155
00156 inline DesHelper::Key::Key(const std::string &hexString) :
00157     m_isInitialized(false)
00158 {
00159     SetKey(hexString);
00160 }
00161
00162 // ---------------------------------------------------------------------------------------------------------------------------------
00163
00164 inline bool DesHelper::Key::IsInitialized() const
00165 {
00166     return m_isInitialized;
00167 }
00168
00169 // ---------------------------------------------------------------------------------------------------------------------------------
00170
00171 inline const DES_cblock &DesHelper::Key::GetKeyBlock() const
00172 {
00173     return m_keyBlock;
00174 }
00175
00176 // ---------------------------------------------------------------------------------------------------------------------------------
00177
00178 inline const DES_key_schedule &DesHelper::Key::GetKeySchedule() const
00179 {
00180     return m_keySchedule;
00181 }
00182
00183 // ---------------------------------------------------------------------------------------------------------------------------------
00184
00185 inline StatusCode DesHelper::Key::Randomize()
00186 {
00187     // DES_random_key returns zero on failure
00188     if (DES_random_key(&m_keyBlock) == 0)
00189         return STATUS_CODE_FAILURE;
00190
00191     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, SetKey(m_keyBlock));
00192
00193     return STATUS_CODE_SUCCESS;
00194 }
00195
00196 // ---------------------------------------------------------------------------------------------------------------------------------
00197
00198 inline void DesHelper::Key::SetKey(const DesHelper::Key &key)
00199 {
00200     *this = key;
00201 }
00202
00203 // ---------------------------------------------------------------------------------------------------------------------------------
00204
00205 inline StatusCode DesHelper::Key::SetKey(const DES_cblock &keyBlock)
00206 {
00207     // DES_set_key_unchecked returns zero on success
00208     DES_set_key_unchecked(const_cast<const_DES_cblock *>(&keyBlock), &m_keySchedule);
00209
00210     // Copy key block
00211     if (&m_keyBlock != &keyBlock)
00212         ::memcpy(&m_keyBlock, &keyBlock, sizeof(DES_cblock));
00213
00214     m_isInitialized = true;
00215
00216     return STATUS_CODE_SUCCESS;
00217 }
00218
00219 // ---------------------------------------------------------------------------------------------------------------------------------
00220
00221 inline StatusCode DesHelper::Key::SetKey(const std::string &hexString)
00222 {
00223     // String must be exactly twice the length of a DES_cblock (2 chars per byte)
00224     if (hexString.length() != (2 * sizeof(DES_cblock)))
00225         return STATUS_CODE_INVALID_LENGTH;
00226
00227     DES_cblock newKeyBlock;
00228     MessageValidator hexValidator(hexString.data(), hexString.length());
00229
00230     // Validate the hex 2 chars (1 byte) at a time
00231     for (size_t i = 0; i < sizeof(DES_cblock); ++i)
00232     {
00233         Activ::byte_t byte;
00234         ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, hexValidator.ValidateAsciiHexadecimalIntegral(2 * sizeof(byte), MessageHandler::ENDIAN_LOCAL, &byte));
00235
00236         newKeyBlock[i] = byte;
00237     }
00238
00239     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, SetKey(newKeyBlock));
00240
00241     return STATUS_CODE_SUCCESS;
00242 }
00243
00244 // ---------------------------------------------------------------------------------------------------------------------------------
00245
00246 inline std::string DesHelper::Key::ToString() const
00247 {
00248     std::ostringstream str;
00249     str.flags(std::ios::hex | std::ios::uppercase);
00250     str.fill('0');
00251
00252     for (size_t i = 0; i < sizeof(m_keyBlock); ++i)
00253         str << std::setw(2) << static_cast<size_t>(m_keyBlock[i]);
00254
00255     return str.str();
00256 }
00257
00258 } // namespace Activ;
00259
00260 #endif // (!defined ACTIV_MISC_DES_HELPER_H)
Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

DirectoryRemover.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_BASE_DIRECTORY_REMOVER_H)
00010 #define ACTIV_BASE_DIRECTORY_REMOVER_H
00011
00012 #include "ActivMiddleware/ActivBase/DirectoryWalker.h"
00013
00014 namespace Activ
00015 {
00016
00020 class DirectoryRemover : private DirectoryWalker
00021 {
00022 public:
00026     ACTIV_BASE_EXPORTED_API DirectoryRemover();
00027
00031     ACTIV_BASE_EXPORTED_API virtual ~DirectoryRemover();
00032
00043     ACTIV_BASE_EXPORTED_API StatusCode Remove(const std::string &path, const bool shouldRecurseDirectory);
00044
00045 protected:
00046     ACTIV_BASE_EXPORTED_API virtual bool OnDirectory(const std::string &path, const std::string &name);
00047     ACTIV_BASE_EXPORTED_API virtual bool OnFile(const std::string &path, const std::string &name);
00048
00049 private:
00050     bool m_shouldRecurseDirectory;
00051 };
00052
00053 } // namespace Activ
00054
00055 #endif // (!defined ACTIV_BASE_DIRECTORY_REMOVER_H)
Generated on Wed Oct 8 14:01:47 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

DirectoryWalker.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_BASE_DIRECTORY_WALKER_H)
00010 #define ACTIV_BASE_DIRECTORY_WALKER_H
00011
00012 #include "ActivMiddleware/ActivBase/External.h"
00013
00014 #include <string>
00015
00016 namespace Activ
00017 {
00018
00024 class DirectoryWalker
00025 {
00026 public:
00030     ACTIV_BASE_EXPORTED_API DirectoryWalker();
00031
00035     ACTIV_BASE_EXPORTED_API virtual ~DirectoryWalker();
00036
00048     ACTIV_BASE_EXPORTED_API StatusCode Walk(const std::string &path, const std::string &wildcardPattern = std::string());
00049
00050 protected:
00059     ACTIV_BASE_EXPORTED_API virtual bool OnDirectory(const std::string &path, const std::string &name);
00060
00069     ACTIV_BASE_EXPORTED_API virtual bool OnFile(const std::string &path, const std::string &name);
00070 };
00071
00072 } // namespace Activ
00073
00074 #endif // (!defined ACTIV_BASE_DIRECTORY_WALKER_H)
Generated on Wed Oct 8 14:01:47 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivFramework

DirectoryWatchApi.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FRAMEWORK_DIRECTORY_WATCH_API_H)
00010 #define ACTIV_FRAMEWORK_DIRECTORY_WATCH_API_H
00011
00012 #include "ActivMiddleware/ActivFramework/External.h"
00013 #include "ActivMiddleware/ActivFramework/TimeHelper.h"
00014
00015 #include <vector>
00016
00017 namespace Activ
00018 {
00019
00020 class Component;
00021
00022 // ---------------------------------------------------------------------------------------------------------------------------------
00023
00027 class DirectoryWatchApi
00028 {
00029 public:
00033     static const MessageType MESSAGE_TYPE = ROUTER_MESSAGE_USER_NOTIFY_DIRECTORY_WATCH_EVENTS;
00034
00035     typedef uint32_t WatchType;
00036
00037     static const WatchType WATCH_TYPE_RECURSIVE = 0x00000001;
00038     static const WatchType WATCH_TYPE_ADDS_DELETES = 0x00000002;
00039     static const WatchType WATCH_TYPE_ATTRIBUTES = 0x00000004;
00040
00044     enum EventType
00045     {
00046         EVENT_TYPE_ADDED,
00047         EVENT_TYPE_DELETED,
00048         EVENT_TYPE_MODIFIED
00049     };
00050
00054     class Event
00055     {
00056     public:
00057         std::string m_path;
00058         EventType   m_eventType;
00059     };
00060
00061     typedef std::vector<Event> EventList;
00062
00079     ACTIV_FRAMEWORK_API static StatusCode AddWatch(const Component &component, const std::string &directoryPath,
00080         const WatchType watchType, Address::Proxy watchAddress);
00081
00095     ACTIV_FRAMEWORK_API static StatusCode CancelWatch(const Component &component, Address &watchAddress);
00096
00105     ACTIV_FRAMEWORK_API static StatusCode Deserialize(const HeapMessage &heapMessage, EventList &eventList);
00106
00114     ACTIV_FRAMEWORK_API static std::string EventTypeToString(const EventType eventType);
00115 };
00116
00117 } // namespace Activ
00118
00119 #endif // (!defined ACTIV_FRAMEWORK_DIRECTORY_WATCH_API_H)
Generated on Wed Oct 8 14:01:48 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » Misc

DynamicLibraryLoader.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_MISC_DYNAMIC_LIBRARY_LOADER_H)
00010 #define ACTIV_MISC_DYNAMIC_LIBRARY_LOADER_H
00011
00012 #include "ActivMiddleware/ActivBase/OsException.h"
00013
00014 #include "boost/mpl/vector.hpp"
00015 #include "boost/mpl/inherit_linearly.hpp"
00016 #include "boost/mpl/inherit.hpp"
00017 #include "boost/mpl/for_each.hpp"
00018 #include "boost/function.hpp"
00019
00020 namespace Activ
00021 {
00022
00026 #if (defined ACTIV_PLATFORM_WINDOWS)
00027 typedef HMODULE DllHandle;
00028 #elif (defined ACTIV_PLATFORM_POSIX)
00029 typedef void *DllHandle;
00030 #else
00031 #error Write me for this platform
00032 #endif
00033
00034 // ---------------------------------------------------------------------------------------------------------------------------------
00035
00052 #define ACTIV_DECLARE_DLL_FUNCTION(name, type, throwOnError)                                    \
00053     class name##Name { public: name##Name() : m_name(#name) { } const std::string m_name; };    \
00054     typedef DllFunctionWrapper<name##Name, type, throwOnError> name
00055
00056 // ---------------------------------------------------------------------------------------------------------------------------------
00057
00079 template<typename T>
00080 class DynamicLibraryLoader : private boost::mpl::inherit_linearly<T, boost::mpl::inherit<boost::mpl::_1, boost::mpl::_2> >::type
00081 {
00082 public:
00088     DynamicLibraryLoader(const std::string &libraryName);
00089
00095     ~DynamicLibraryLoader();
00096
00105 #if (!defined ACTIV_COMPILER_SUNPRO)
00106
00107     template<typename F>
00108     typename F::Type *Get() const
00109     {
00110         return F::m_pFunction;
00111     }
00112
00113 #else
00114
00115     // sun compiler (as of version 5.8) throws error "notfunc" if using the above Get() in one step, e.g.
00116     // myLoader.Get<SomeFn>()(param, param2);
00117     // this works around that, at the cost of using boost::function
00118     template<typename F>
00119     boost::function<typename F::Type> Get() const
00120     {
00121         return boost::function<typename F::Type>(typename F::m_pFunction);
00122     }
00123
00124 #endif
00125
00131     bool HasAllAvailable() const;
00132
00133 private:
00137     class DllFunctionLoader
00138     {
00139     public:
00148         template<typename F>
00149         void operator()(F *unused, DynamicLibraryLoader &dynamicLibraryLoader) const
00150         {
00151             dynamicLibraryLoader.F::FindFunction(dynamicLibraryLoader.m_dllHandle);
00152
00153             if (NULL == dynamicLibraryLoader.F::m_pFunction)
00154                 dynamicLibraryLoader.m_hasAllAvailable = false;
00155         }
00156     };
00157
00165     static DllHandle OpenLibrary(const std::string &libraryName);
00166
00167     const DllHandle m_dllHandle;
00168     bool            m_hasAllAvailable;
00169 };
00170
00171 } // namespace Activ
00172
00173 #include "ActivMiddleware/Misc/Detail/DynamicLibraryLoaderDetail.h"
00174
00175 #endif // (!defined ACTIV_MISC_DYNAMIC_LIBRARY_LOADER_H)
Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » Misc » Detail

DynamicLibraryLoaderDetail.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_MISC_DETAIL_DYNAMIC_LIBRARY_LOADER_DETAIL_H)
00010 #define ACTIV_MISC_DETAIL_DYNAMIC_LIBRARY_LOADER_DETAIL_H
00011
00012 #if (defined ACTIV_PLATFORM_POSIX)
00013 #include <dlfcn.h>
00014 #endif
00015
00016 #include "boost/bind.hpp"
00017 #include "boost/tokenizer.hpp"
00018
00019 namespace Activ
00020 {
00021
00025 template<typename NAME, typename TYPE, bool THROW_ON_ERROR>
00026 class DllFunctionWrapper : public NAME
00027 {
00028 public:
00029     typedef TYPE Type;
00030
00036     DllFunctionWrapper();
00037
00043     void FindFunction(const DllHandle dllHandle);
00044
00045 protected:
00046     Type    *m_pFunction;
00047 };
00048
00049 // ---------------------------------------------------------------------------------------------------------------------------------
00050
00051 template<typename NAME, typename TYPE, bool THROW_ON_ERROR>
00052 DllFunctionWrapper<NAME, TYPE, THROW_ON_ERROR>::DllFunctionWrapper() :
00053     m_pFunction(NULL)
00054 {
00055 }
00056
00057 // ---------------------------------------------------------------------------------------------------------------------------------
00058
00059 template<typename NAME, typename TYPE, bool THROW_ON_ERROR>
00060 void DllFunctionWrapper<NAME, TYPE, THROW_ON_ERROR>::FindFunction(const DllHandle dllHandle)
00061 {
00062     // note C-style casts: reinterpret_cast complains with some compilers
00063     // this-> syntax as base is a dependent type
00064 #if (defined ACTIV_PLATFORM_WINDOWS)
00065     if (NULL != dllHandle)
00066         m_pFunction = (Type *)::GetProcAddress(dllHandle, this->m_name.c_str());
00067
00068     if (THROW_ON_ERROR)
00069     {
00070         if (NULL == m_pFunction)
00071             ACTIV_THROW(OsException, ::GetLastError());
00072     }
00073 #elif (defined ACTIV_PLATFORM_POSIX)
00074     if (NULL != dllHandle)
00075         m_pFunction = (Type *)::dlsym(dllHandle, this->m_name.c_str());
00076
00077     if (THROW_ON_ERROR)
00078     {
00079         if (NULL == m_pFunction)
00080             ACTIV_THROW(OsException, errno);
00081     }
00082 #else
00083 #error Write me for this platform
00084 #endif
00085 }
00086
00087 // ---------------------------------------------------------------------------------------------------------------------------------
00088 // ---------------------------------------------------------------------------------------------------------------------------------
00089
00090 template<typename T>
00091 DynamicLibraryLoader<T>::DynamicLibraryLoader(const std::string &libraryName) :
00092     m_dllHandle(OpenLibrary(libraryName)),
00093     m_hasAllAvailable(true)
00094 {
00095     // for each base of DynamicLibraryLoader, invoke the function object DllFunctionLoader.
00096     // Note using boost::arg<1> for bind as _1 is ambiguous with mpl.
00097     boost::mpl::for_each<T, boost::add_pointer<boost::mpl::_> >(
00098         boost::bind<void>(DllFunctionLoader(), boost::arg<1>(), boost::ref(*this)));
00099 }
00100
00101 // ---------------------------------------------------------------------------------------------------------------------------------
00102
00103 template<typename T>
00104 DynamicLibraryLoader<T>::~DynamicLibraryLoader()
00105 {
00106 #if (defined ACTIV_PLATFORM_WINDOWS)
00107     if (NULL != m_dllHandle)
00108         (void) ::FreeLibrary(m_dllHandle);
00109 #elif (defined ACTIV_PLATFORM_POSIX)
00110     if (NULL != m_dllHandle)
00111         (void) ::dlclose(m_dllHandle);
00112 #else
00113 #error Write me for this platform
00114 #endif
00115 }
00116
00117 // ---------------------------------------------------------------------------------------------------------------------------------
00118
00119 template<typename T>
00120 inline bool DynamicLibraryLoader<T>::HasAllAvailable() const
00121 {
00122     return m_hasAllAvailable;
00123 }
00124
00125 // ---------------------------------------------------------------------------------------------------------------------------------
00126
00127 template<typename T>
00128 DllHandle DynamicLibraryLoader<T>::OpenLibrary(const std::string &libraryName)
00129 {
00130     typedef boost::char_separator<char> CharSeparator;
00131     typedef boost::tokenizer<CharSeparator> Tokenizer;
00132
00133     CharSeparator charSeparator(";");
00134     Tokenizer tokenizer(libraryName, charSeparator);
00135
00136     for (Tokenizer::iterator iter = tokenizer.begin(), iterEnd = tokenizer.end(); iter != iterEnd; ++iter)
00137     {
00138         DllHandle dllHandle;
00139
00140 #if (defined ACTIV_PLATFORM_WINDOWS)
00141         dllHandle = ::LoadLibrary(iter->c_str());
00142 #elif (defined ACTIV_PLATFORM_POSIX)
00143         dllHandle = ::dlopen(iter->c_str(), RTLD_LAZY);
00144 #else
00145 #error Write me for this platform
00146 #endif
00147
00148         if (NULL != dllHandle)
00149             return dllHandle;
00150     }
00151
00152     return NULL;
00153 }
00154
00155 } // namespace Activ
00156
00157 #endif // (!defined ACTIV_MISC_DETAIL_DYNAMIC_LIBRARY_LOADER_DETAIL_H)
Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon

EntityTypeHelper.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FEED_COMMON_ENTITY_TYPE_HELPER_H)
00010 #define ACTIV_FEED_COMMON_ENTITY_TYPE_HELPER_H
00011
00012 #include "ActivContentPlatform/ActivFeedCommon/External.h"
00013 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedDefinitions.h"
00014 #include "ActivContentPlatform/ActivFeedCommon/EntityTypes.h"
00015
00016 namespace Activ
00017 {
00018
00019 namespace ContentPlatform
00020 {
00021
00022 namespace Feed
00023 {
00024
00028 class EntityTypeHelper
00029 {
00030 public:
00034     EntityTypeHelper();
00035
00043     EntityTypeHelper(const EntityType entityType, const char * const pName, const char * const pCodeIdentifier);
00044
00045     EntityType          m_entityType;
00046     std::string         m_name;
00047     std::string         m_codeIdentifier;
00048 };
00049
00050 // ---------------------------------------------------------------------------------------------------------------------------------
00051
00052 inline EntityTypeHelper::EntityTypeHelper() :
00053     m_entityType(ENTITY_TYPE_NONE)
00054 {
00055 }
00056
00057 // ---------------------------------------------------------------------------------------------------------------------------------
00058
00059 inline EntityTypeHelper::EntityTypeHelper(const EntityType entityType, const char * const pName, const char * const pCodeIdentifier) :
00060     m_entityType(entityType),
00061     m_name(pName),
00062     m_codeIdentifier(pCodeIdentifier)
00063 {
00064 }
00065
00066 // ---------------------------------------------------------------------------------------------------------------------------------
00067 // ---------------------------------------------------------------------------------------------------------------------------------
00068
00076 ACTIV_FEED_COMMON_API const EntityTypeHelper &GetEntityTypeHelper(const EntityType entityType);
00077
00085 ACTIV_FEED_COMMON_API std::string GetEntityTypeName(const EntityType entityType);
00086
00094 ACTIV_FEED_COMMON_API std::string GetEntityTypeCodeIdentifier(const EntityType entityType);
00095
00096 } // namespace Feed
00097
00098 } // namespace ContentPlatform
00099
00100 } // namespace Activ
00101
00102 #endif // (!defined ACTIV_FEED_COMMON_ENTITY_TYPE_HELPER_H)
Generated on Wed Oct 8 14:01:46 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon

EntityTypes.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FEED_COMMON_ENTITY_TYPES_H)
00010 #define ACTIV_FEED_COMMON_ENTITY_TYPES_H
00011
00012 #include "ActivMiddleware/Activ.h"
00013
00014 namespace Activ
00015 {
00016
00017 namespace ContentPlatform
00018 {
00019
00020 namespace Feed
00021 {
00022
00023 typedef uint8_t EntityType;
00024
00025 const EntityType ENTITY_TYPE_NONE = 0;
00026 const EntityType ENTITY_TYPE_EQUITY = 1;
00027 const EntityType ENTITY_TYPE_EQUITY_OPTION = 2;
00028 const EntityType ENTITY_TYPE_INDEX_OPTION = 3;
00029 const EntityType ENTITY_TYPE_CURRENCY_OPTION = 4;
00030 const EntityType ENTITY_TYPE_INDEX = 5;
00031 const EntityType ENTITY_TYPE_CORPORATE_BOND = 6;
00032 const EntityType ENTITY_TYPE_FUTURE = 7;
00033 const EntityType ENTITY_TYPE_FUTURE_OPTION = 8;
00034 const EntityType ENTITY_TYPE_FOREX = 9;
00035 const EntityType ENTITY_TYPE_MUTUAL_FUND = 10;
00036 const EntityType ENTITY_TYPE_MONEY_MARKET_FUND = 11;
00037 const EntityType ENTITY_TYPE_BOND = 12;
00038 const EntityType ENTITY_TYPE_MARKET_MAKER_QUOTE = 13;
00039 const EntityType ENTITY_TYPE_GOVERNMENT_BOND = 14;
00040 const EntityType ENTITY_TYPE_SPOT = 15;
00041 const EntityType ENTITY_TYPE_CORPORATE_ACTION = 16;
00042 const EntityType ENTITY_TYPE_UNIT_INVESTMENT_TRUST = 17;
00043 const EntityType ENTITY_TYPE_EXCHANGE_TRADED_FUND = 18;
00044 const EntityType ENTITY_TYPE_COMPANY = 19;
00045 const EntityType ENTITY_TYPE_SECURITY = 20;
00046 const EntityType ENTITY_TYPE_CONVERTIBLE = 21;
00047 const EntityType ENTITY_TYPE_DEBENTURE = 22;
00048 const EntityType ENTITY_TYPE_PREFERENCE = 23;
00049 const EntityType ENTITY_TYPE_WARRANT = 24;
00050 const EntityType ENTITY_TYPE_NEWS = 25;
00051 const EntityType ENTITY_TYPE_ANALYTICS = 26;
00052 const EntityType ENTITY_TYPE_ORDER = 27;
00053 const EntityType ENTITY_TYPE_OPTION_ROOT = 28;
00054 const EntityType ENTITY_TYPE_FUTURE_ROOT = 29;
00055 const EntityType ENTITY_TYPE_FUTURE_OPTION_ROOT = 30;
00056 const EntityType ENTITY_TYPE_NEWS_HEADLINE = 31;
00057 const EntityType ENTITY_TYPE_STATISTICS = 32;
00058 const EntityType ENTITY_TYPE_RANKINGS = 33;
00059 const EntityType ENTITY_TYPE_BBO_QUOTE = 34;
00060 const EntityType ENTITY_TYPE_FUTURES_SPREAD = 35;
00061 const EntityType ENTITY_TYPE_EXCHANGE = 36;
00062 const EntityType ENTITY_TYPE_FOREX_FORWARD = 37;
00063 const EntityType ENTITY_TYPE_STRUCTURED_PRODUCT = 38;
00064 const EntityType ENTITY_TYPE_BBO_DEPTH = 39;
00065 const EntityType ENTITY_TYPE_NON_STANDARD_OPTION = 40;
00066 const EntityType ENTITY_TYPE_STRATEGY = 41;
00067 const EntityType ENTITY_TYPE_STRATEGY_LEG = 42;
00068 const EntityType ENTITY_TYPE_RIGHTS = 45;
00069 const EntityType ENTITY_TYPE_LOAN_STOCK = 46;
00070 const EntityType ENTITY_TYPE_NON_CONVERTIBLE_LOAN = 47;
00071 const EntityType ENTITY_TYPE_EXCHANGE_TRADED_NOTE = 48;
00072
00073 } // namespace Feed
00074
00075 } // namespace ContentPlatform
00076
00077 } // namespace Activ
00078
00079 #endif // (!defined ACTIV_FEED_COMMON_ENTITY_TYPES_H)
Generated on Wed Oct 8 14:01:46 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon

Enumerations.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FEED_COMMON_ENUMERATIONS_H)
00010 #define ACTIV_FEED_COMMON_ENUMERATIONS_H
00011
00012 #include "ActivMiddleware/Activ.h"
00013
00014 namespace Activ
00015 {
00016
00017 namespace ContentPlatform
00018 {
00019
00020 namespace Feed
00021 {
00022
00023 typedef uint16_t State;
00024
00025 const State STATE_BIT_CLOSED = 0;
00026 const State STATE_BIT_HALTED = 1;
00027 const State STATE_BIT_RESTRICTED = 2;
00028
00029 const State STATE_CLOSED = (1 << ((sizeof(State) * CHAR_BIT) - (STATE_BIT_CLOSED + 1)));
00030 const State STATE_HALTED = (1 << ((sizeof(State) * CHAR_BIT) - (STATE_BIT_HALTED + 1)));
00031 const State STATE_RESTRICTED = (1 << ((sizeof(State) * CHAR_BIT) - (STATE_BIT_RESTRICTED + 1)));
00032
00033 const State STATE_NONE = 0;
00034
00035 typedef uint8_t CloseStatus;
00036
00037 const CloseStatus CLOSE_STATUS_NONE = 0;
00038 const CloseStatus CLOSE_STATUS_CALCULATED_UNOFFICIAL = 1;
00039 const CloseStatus CLOSE_STATUS_CALCULATED_OFFICIAL = 2;
00040 const CloseStatus CLOSE_STATUS_EXCHANGE_UNOFFICIAL = 3;
00041 const CloseStatus CLOSE_STATUS_EXCHANGE_OFFICIAL = 4;
00042
00043 typedef uint8_t ContractType;
00044
00045 const ContractType CONTRACT_TYPE_NORMAL = 0;
00046 const ContractType CONTRACT_TYPE_ADJUSTMENT = 1;
00047 const ContractType CONTRACT_TYPE_SPINOFF = 2;
00048 const ContractType CONTRACT_TYPE_MERGER = 3;
00049 const ContractType CONTRACT_TYPE_PERCENTAGE = 4;
00050 const ContractType CONTRACT_TYPE_CREDIT_DEFAULT = 5;
00051 const ContractType CONTRACT_TYPE_FIXED_RETURN = 6;
00052 const ContractType CONTRACT_TYPE_BINARY = 7;
00053 const ContractType CONTRACT_TYPE_DELAYED_START = 8;
00054 const ContractType CONTRACT_TYPE_RANGE = 9;
00055
00056 typedef uint8_t DisplayDenominator;
00057
00058 const DisplayDenominator DISPLAY_DENOMINATOR_WHOLE = 0;
00059 const DisplayDenominator DISPLAY_DENOMINATOR_1DP = 1;
00060 const DisplayDenominator DISPLAY_DENOMINATOR_2DP = 2;
00061 const DisplayDenominator DISPLAY_DENOMINATOR_3DP = 3;
00062 const DisplayDenominator DISPLAY_DENOMINATOR_4DP = 4;
00063 const DisplayDenominator DISPLAY_DENOMINATOR_5DP = 5;
00064 const DisplayDenominator DISPLAY_DENOMINATOR_6DP = 6;
00065 const DisplayDenominator DISPLAY_DENOMINATOR_7DP = 7;
00066 const DisplayDenominator DISPLAY_DENOMINATOR_8DP = 8;
00067 const DisplayDenominator DISPLAY_DENOMINATOR_9DP = 9;
00068 const DisplayDenominator DISPLAY_DENOMINATOR_X1E1 = 10;
00069 const DisplayDenominator DISPLAY_DENOMINATOR_X1E2 = 11;
00070 const DisplayDenominator DISPLAY_DENOMINATOR_X1E3 = 12;
00071 const DisplayDenominator DISPLAY_DENOMINATOR_X1E4 = 13;
00072 const DisplayDenominator DISPLAY_DENOMINATOR_X1E5 = 14;
00073 const DisplayDenominator DISPLAY_DENOMINATOR_X1E6 = 15;
00074 const DisplayDenominator DISPLAY_DENOMINATOR_X1E7 = 16;
00075 const DisplayDenominator DISPLAY_DENOMINATOR_X1E8 = 17;
00076 const DisplayDenominator DISPLAY_DENOMINATOR_X1E9 = 18;
00077 const DisplayDenominator DISPLAY_DENOMINATOR_HALF = 19;
00078 const DisplayDenominator DISPLAY_DENOMINATOR_QUARTER = 20;
00079 const DisplayDenominator DISPLAY_DENOMINATOR_8TH = 21;
00080 const DisplayDenominator DISPLAY_DENOMINATOR_16TH = 22;
00081 const DisplayDenominator DISPLAY_DENOMINATOR_32ND = 23;
00082 const DisplayDenominator DISPLAY_DENOMINATOR_64TH = 24;
00083 const DisplayDenominator DISPLAY_DENOMINATOR_128TH = 25;
00084 const DisplayDenominator DISPLAY_DENOMINATOR_256TH = 26;
00085 const DisplayDenominator DISPLAY_DENOMINATOR_512TH = 27;
00086 const DisplayDenominator DISPLAY_DENOMINATOR_CABINET = 28;
00087 const DisplayDenominator DISPLAY_DENOMINATOR_UNDEFINED = 29;
00088 const DisplayDenominator DISPLAY_DENOMINATOR_RESERVED_1 = 30;
00089 const DisplayDenominator DISPLAY_DENOMINATOR_RESERVED_2 = 31;
00090 const DisplayDenominator DISPLAY_DENOMINATOR_REDUCED_FRACTION = 32;
00091 const DisplayDenominator DISPLAY_DENOMINATOR_HALF_32ND = 33;
00092 const DisplayDenominator DISPLAY_DENOMINATOR_HALF_64TH = 34;
00093
00094 typedef uint32_t DividendFrequencyCode;
00095
00096 const DividendFrequencyCode DIVIDEND_FREQUENCY_CODE_ANNUALLY = 0;
00097 const DividendFrequencyCode DIVIDEND_FREQUENCY_CODE_MONTHLY = 1;
00098 const DividendFrequencyCode DIVIDEND_FREQUENCY_CODE_QUARTERLY = 2;
00099 const DividendFrequencyCode DIVIDEND_FREQUENCY_CODE_SEMI_ANNUALLY = 3;
00100 const DividendFrequencyCode DIVIDEND_FREQUENCY_CODE_OTHER = 4;
00101
00102 typedef uint8_t DividendStatus;
00103
00104 const DividendStatus DIVIDEND_STATUS_UNOFFICIAL = 0;
00105 const DividendStatus DIVIDEND_STATUS_OFFICIAL = 1;
00106
00107 typedef char ExerciseStyle;
00108
00109 const char EXERCISE_STYLE_AMERICAN = 'A';
00110 const char EXERCISE_STYLE_EUROPEAN = 'E';
00111
00112 typedef uint8_t ExMarker;
00113
00114 const size_t EX_MARKER_EX_DIV_BYTE_OFFSET = 0;
00115
00116 const ExMarker EX_MARKER_NONE = 0;
00117 const ExMarker EX_MARKER_TODAY = 1;
00118
00119 typedef uint8_t ExpirationType;
00120
00121 const ExpirationType EXPIRATION_TYPE_MID_MONTH = 0;
00122 const ExpirationType EXPIRATION_TYPE_FIRST_FRIDAY = 1;
00123 const ExpirationType EXPIRATION_TYPE_SECOND_FRIDAY = 2;
00124 const ExpirationType EXPIRATION_TYPE_THIRD_FRIDAY = 3;
00125 const ExpirationType EXPIRATION_TYPE_FOURTH_FRIDAY = 4;
00126 const ExpirationType EXPIRATION_TYPE_FIFTH_FRIDAY = 5;
00127 const ExpirationType EXPIRATION_TYPE_WEDNESDAY_MID_MONTH = 6;
00128 const ExpirationType EXPIRATION_TYPE_QUARTERLY_END_MONTH = 7;
00129 const ExpirationType EXPIRATION_TYPE_CREDIT_DEFAULT = 8;
00130
00131 typedef uint8_t MarketMakerStatus;
00132
00133 const MarketMakerStatus MARKET_MAKER_STATUS_NONE = 0;
00134 const MarketMakerStatus MARKET_MAKER_STATUS_PRIMARY = 1;
00135
00136 typedef uint16_t NewsState;
00137
00138 const NewsState NEWS_STATE_BIT_HOT = 0;
00139 const NewsState NEWS_STATE_BIT_TEMPORARY = 1;
00140 const NewsState NEWS_STATE_BIT_DISABLE_NEWS_ALERT = 2;
00141 const NewsState NEWS_STATE_BIT_EXPIRED = 3;
00142
00143 const NewsState NEWS_STATE_HOT = (1 << ((sizeof(NewsState) * CHAR_BIT) - (NEWS_STATE_BIT_HOT + 1)));
00144 const NewsState NEWS_STATE_TEMPORARY = (1 << ((sizeof(NewsState) * CHAR_BIT) - (NEWS_STATE_BIT_TEMPORARY + 1)));
00145 const NewsState NEWS_STATE_DISABLE_NEWS_ALERT = (1 << ((sizeof(NewsState) * CHAR_BIT) - (NEWS_STATE_BIT_DISABLE_NEWS_ALERT + 1)));
00146 const NewsState NEWS_STATE_EXPIRED = (1 << ((sizeof(NewsState) * CHAR_BIT) - (NEWS_STATE_BIT_EXPIRED + 1)));
00147
00148 const NewsState NEWS_STATE_NONE = 0;
00149
00150 typedef char OptionType;
00151
00152 const OptionType OPTION_TYPE_CALL = 'C';
00153 const OptionType OPTION_TYPE_PUT = 'P';
00154
00155 typedef uint8_t OrderType;
00156
00157 const OrderType ORDER_TYPE_LIMIT_ORDER = 0;
00158 const OrderType ORDER_TYPE_MARKET_ORDER = 1;
00159 const OrderType ORDER_TYPE_ALL_OR_NONE = 2;
00160 const OrderType ORDER_TYPE_LOTS_OF = 3;
00161 const OrderType ORDER_TYPE_MINIMUM_FILL = 4;
00162 const OrderType ORDER_TYPE_SPECIAL = 5;
00163
00164 typedef char SettlementType;
00165
00166 const SettlementType SETTLEMENT_TYPE_AM = 'A';
00167 const SettlementType SETTLEMENT_TYPE_PM = 'P';
00168
00169 typedef uint8_t SplitType;
00170
00171 const SplitType SPLIT_TYPE_SPLIT = 0;
00172 const SplitType SPLIT_TYPE_REVERSE = 1;
00173 const SplitType SPLIT_TYPE_DISTRIBUTION = 2;
00174 const SplitType SPLIT_TYPE_REDUCTION = 3;
00175 const SplitType SPLIT_TYPE_PRICE_ADJUSTMENT = 4;
00176
00177 typedef uint8_t UnitOfMeasure;
00178
00179 const UnitOfMeasure UNIT_OF_MEASURE_NONE = 0;
00180 const UnitOfMeasure UNIT_OF_MEASURE_NOMINAL = 1;
00181 const UnitOfMeasure UNIT_OF_MEASURE_BAGS = 2;
00182 const UnitOfMeasure UNIT_OF_MEASURE_BUSHELS = 3;
00183 const UnitOfMeasure UNIT_OF_MEASURE_BARRELS = 4;
00184 const UnitOfMeasure UNIT_OF_MEASURE_GALLONS = 5;
00185 const UnitOfMeasure UNIT_OF_MEASURE_GRAMS = 6;
00186 const UnitOfMeasure UNIT_OF_MEASURE_KILOS = 7;
00187 const UnitOfMeasure UNIT_OF_MEASURE_SHORT_TONS = 8;
00188 const UnitOfMeasure UNIT_OF_MEASURE_LONG_TONS = 9;
00189 const UnitOfMeasure UNIT_OF_MEASURE_METRIC_TONS = 10;
00190 const UnitOfMeasure UNIT_OF_MEASURE_OUNCES = 11;
00191 const UnitOfMeasure UNIT_OF_MEASURE_POUNDS = 12;
00192 const UnitOfMeasure UNIT_OF_MEASURE_SQUARE_FEET = 13;
00193 const UnitOfMeasure UNIT_OF_MEASURE_FINE_TROY_OUNCES = 14;
00194 const UnitOfMeasure UNIT_OF_MEASURE_TROY_OUNCES = 15;
00195 const UnitOfMeasure UNIT_OF_MEASURE_BOARD_FEET = 16;
00196 const UnitOfMeasure UNIT_OF_MEASURE_COINS = 17;
00197 const UnitOfMeasure UNIT_OF_MEASURE_BALES = 18;
00198 const UnitOfMeasure UNIT_OF_MEASURE_BOX_CASES = 19;
00199 const UnitOfMeasure UNIT_OF_MEASURE_BOTTLE_FLASKS = 20;
00200 const UnitOfMeasure UNIT_OF_MEASURE_PERCENT = 21;
00201 const UnitOfMeasure UNIT_OF_MEASURE_NON_FAT_DRY_MILK = 22;
00202 const UnitOfMeasure UNIT_OF_MEASURE_BTU_MILLIONS = 23;
00203 const UnitOfMeasure UNIT_OF_MEASURE_MEGA_WATT_HOURS = 24;
00204 const UnitOfMeasure UNIT_OF_MEASURE_HUNDRED_WEIGHT = 25;
00205 const UnitOfMeasure UNIT_OF_MEASURE_HUNDRED_WEIGHT_112LBS = 26;
00206 const UnitOfMeasure UNIT_OF_MEASURE_ONES = 27;
00207 const UnitOfMeasure UNIT_OF_MEASURE_TENS = 28;
00208 const UnitOfMeasure UNIT_OF_MEASURE_DOZENS = 29;
00209 const UnitOfMeasure UNIT_OF_MEASURE_HUNDREDS = 30;
00210 const UnitOfMeasure UNIT_OF_MEASURE_THOUSANDS = 31;
00211 const UnitOfMeasure UNIT_OF_MEASURE_MILLIONS = 32;
00212 const UnitOfMeasure UNIT_OF_MEASURE_PIECES = 33;
00213 const UnitOfMeasure UNIT_OF_MEASURE_TEN_PIECES = 34;
00214 const UnitOfMeasure UNIT_OF_MEASURE_HUNDRED_PIECES = 35;
00215 const UnitOfMeasure UNIT_OF_MEASURE_THOUSAND_PIECES = 36;
00216 const UnitOfMeasure UNIT_OF_MEASURE_TEN_THOUSAND_PIECES = 37;
00217 const UnitOfMeasure UNIT_OF_MEASURE_INDICES = 38;
00218 const UnitOfMeasure UNIT_OF_MEASURE_FUTURES_CONTRACTS = 39;
00219 const UnitOfMeasure UNIT_OF_MEASURE_CURRENCY = 40;
00220 const UnitOfMeasure UNIT_OF_MEASURE_SHARES = 41;
00221 const UnitOfMeasure UNIT_OF_MEASURE_LITERS = 42;
00222 const UnitOfMeasure UNIT_OF_MEASURE_KILOLITERS = 43;
00223 const UnitOfMeasure UNIT_OF_MEASURE_CERTIFIED_EMISSION_REDUCTION = 44;
00224 const UnitOfMeasure UNIT_OF_MEASURE_EU_EMISSION_ALLOWANCE = 45;
00225 const UnitOfMeasure UNIT_OF_MEASURE_CO2_ALLOWANCE = 46;
00226
00227 } // namespace Feed
00228
00229 } // namespace ContentPlatform
00230
00231 } // namespace Activ
00232
00233 #endif // (!defined ACTIV_FEED_COMMON_ENUMERATIONS_H)
Generated on Wed Oct 8 14:01:46 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon

EventTypeHelper.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FEED_COMMON_EVENT_TYPE_HELPER_H)
00010 #define ACTIV_FEED_COMMON_EVENT_TYPE_HELPER_H
00011
00012 #include "ActivContentPlatform/ActivFeedCommon/External.h"
00013 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedDefinitions.h"
00014 #include "ActivContentPlatform/ActivFeedCommon/EventTypes.h"
00015
00016 namespace Activ
00017 {
00018
00019 namespace ContentPlatform
00020 {
00021
00022 namespace Feed
00023 {
00024
00028 class EventTypeHelper
00029 {
00030 public:
00034     EventTypeHelper();
00035
00043     EventTypeHelper(const EventType eventType, const char * const pName, const char * const pCodeIdentifier);
00044
00045     EventType           m_eventType;
00046     std::string         m_name;
00047     std::string         m_codeIdentifier;
00048 };
00049
00050 // ---------------------------------------------------------------------------------------------------------------------------------
00051
00052 inline EventTypeHelper::EventTypeHelper() :
00053     m_eventType(EVENT_TYPE_NONE)
00054 {
00055 }
00056
00057 // ---------------------------------------------------------------------------------------------------------------------------------
00058
00059 inline EventTypeHelper::EventTypeHelper(const EventType eventType, const char * const pName, const char * const pCodeIdentifier) :
00060     m_eventType(eventType),
00061     m_name(pName),
00062     m_codeIdentifier(pCodeIdentifier)
00063 {
00064 }
00065
00066 // ---------------------------------------------------------------------------------------------------------------------------------
00067 // ---------------------------------------------------------------------------------------------------------------------------------
00068
00076 ACTIV_FEED_COMMON_API const EventTypeHelper &GetEventTypeHelper(const EventType eventType);
00077
00085 ACTIV_FEED_COMMON_API std::string GetEventTypeName(const EventType eventType);
00086
00094 ACTIV_FEED_COMMON_API std::string GetEventTypeCodeIdentifier(const EventType eventType);
00095
00096 } // namespace Feed
00097
00098 } // namespace ContentPlatform
00099
00100 } // namespace Activ
00101
00102 #endif // (!defined ACTIV_FEED_COMMON_EVENT_TYPE_HELPER_H)
Generated on Wed Oct 8 14:01:46 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon

EventTypes.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FEED_COMMON_EVENT_TYPES_H)
00010 #define ACTIV_FEED_COMMON_EVENT_TYPES_H
00011
00012 #include "ActivMiddleware/Activ.h"
00013
00014 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedDefinitions.h"
00015
00016 namespace Activ
00017 {
00018
00019 namespace ContentPlatform
00020 {
00021
00022 namespace Feed
00023 {
00024
00025 const EventType EVENT_TYPE_NONE = 0;
00026 const EventType EVENT_TYPE_TRADE = 1;
00027 const EventType EVENT_TYPE_TICK = 2;
00028 const EventType EVENT_TYPE_BBO_QUOTE = 3;
00029 const EventType EVENT_TYPE_TRADE_CORRECTION = 4;
00030 const EventType EVENT_TYPE_TRADE_CANCEL = 5;
00031 const EventType EVENT_TYPE_TRADE_NON_REGULAR = 6;
00032 const EventType EVENT_TYPE_BBO_DEPTH = 7;
00033 const EventType EVENT_TYPE_REFRESH = 8;
00034 const EventType EVENT_TYPE_ORDER = 9;
00035 const EventType EVENT_TYPE_QUOTE = 10;
00036 const EventType EVENT_TYPE_IPO = 11;
00037 const EventType EVENT_TYPE_IPO_CANCEL = 12;
00038 const EventType EVENT_TYPE_DELIST = 13;
00039 const EventType EVENT_TYPE_DELIST_CANCEL = 14;
00040 const EventType EVENT_TYPE_DIVIDEND = 15;
00041 const EventType EVENT_TYPE_DIVIDEND_CANCEL = 16;
00042 const EventType EVENT_TYPE_DIVIDEND_CORRECTION = 17;
00043 const EventType EVENT_TYPE_SPLIT = 18;
00044 const EventType EVENT_TYPE_SPLIT_CANCEL = 19;
00045 const EventType EVENT_TYPE_SPLIT_CORRECTION = 20;
00046 const EventType EVENT_TYPE_SYMBOL_CHANGE = 21;
00047 const EventType EVENT_TYPE_SYMBOL_CHANGE_CANCEL = 22;
00048 const EventType EVENT_TYPE_OPTION_SYMBOL_CHANGE = 23;
00049 const EventType EVENT_TYPE_OPTION_SPLIT = 24;
00050 const EventType EVENT_TYPE_CLOSING_QUOTE = 25;
00051 const EventType EVENT_TYPE_CLOSING_BBO_QUOTE = 26;
00052 const EventType EVENT_TYPE_CLOSE = 27;
00053 const EventType EVENT_TYPE_RESET = 28;
00054 const EventType EVENT_TYPE_COMPOSITE_BBO_QUOTE = 29;
00055 const EventType EVENT_TYPE_NEWS = 30;
00056 const EventType EVENT_TYPE_TIME_SERIES_CORRECTION = 31;
00057 const EventType EVENT_TYPE_TIME_SERIES_DELETE = 32;
00058 const EventType EVENT_TYPE_PRICE_ADJUSTMENT = 33;
00059 const EventType EVENT_TYPE_PRICE_ADJUSTMENT_CANCEL = 34;
00060 const EventType EVENT_TYPE_OPEN = 35;
00061 const EventType EVENT_TYPE_NEWS_DELETE = 36;
00062 const EventType EVENT_TYPE_PURGE = 37;
00063 const EventType EVENT_TYPE_ALERT = 38;
00064 const EventType EVENT_TYPE_REFRESH_CYCLE = 39;
00065 const EventType EVENT_TYPE_FORCE_PROCESS_REFRESH = 40;
00066 const EventType EVENT_TYPE_OPTION_REFRESH = 41;
00067 const EventType EVENT_TYPE_HALT_RESUME = 42;
00068 const EventType EVENT_TYPE_IMBALANCE_VOLUME = 43;
00069 const EventType EVENT_TYPE_PRICE_INDICATION = 44;
00070 const EventType EVENT_TYPE_CACHE_FLUSH = 45;
00071 const EventType EVENT_TYPE_MULTIPLE_DELETE = 46;
00072 const EventType EVENT_TYPE_LRP_PRICE = 47;
00073 const EventType EVENT_TYPE_IMPLIED_BBO_QUOTE = 48;
00074 const EventType EVENT_TYPE_TIME_SERIES_ADJUSTMENT = 49;
00075
00076 const EventType EVENT_TYPE_MARKET_DEPTH = EVENT_TYPE_BBO_DEPTH;
00077 const EventType EVENT_TYPE_TRADE_LATE = EVENT_TYPE_TRADE_NON_REGULAR;
00078
00079 } // namespace Feed
00080
00081 } // namespace ContentPlatform
00082
00083 } // namespace Activ
00084
00085 #endif // (!defined ACTIV_FEED_COMMON_EVENT_TYPES_H)
Generated on Wed Oct 8 14:01:46 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

Exception.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_BASE_EXCEPTION_H)
00010 #define ACTIV_BASE_EXCEPTION_H
00011
00012 #include "ActivMiddleware/ActivBase/External.h"
00013
00014 #include <iostream>
00015
00019 #define ACTIV_EXCEPTION(t, e)           t(__FILE__, __FUNCTION__, __LINE__, e)
00020
00027 #define ACTIV_THROW(t, e)               throw ACTIV_EXCEPTION(t, e)
00028
00032 #define ACTIV_RETHROW(e)                if (true)                                                               \
00033                                         {                                                                       \
00034                                             e.AddException(new (std::nothrow) ACTIV_EXCEPTION(Exception, 0));   \
00035                                             throw;                                                              \
00036                                         }                                                                       \
00037                                         else
00038
00042 #define ACTIV_THROW_ERROR_IF(statusCode, operator, expression, exception)           \
00043     if (true)                                                                       \
00044     {                                                                               \
00045         if (statusCode operator expression)                                         \
00046             throw exception;                                                        \
00047     }                                                                               \
00048     else
00049
00050 // ---------------------------------------------------------------------------------------------------------------------------------
00051
00052 namespace Activ
00053 {
00054
00058 class Exception
00059 {
00060 public:
00069     ACTIV_BASE_EXPORTED_API Exception(const char *file, const char *function, const uint_fast32_t line,
00070         const uint_fast32_t errorCode = 0);
00071
00075     ACTIV_BASE_EXPORTED_API Exception(const Exception &rhs);
00076
00080     ACTIV_BASE_EXPORTED_API virtual ~Exception();
00081
00090     ACTIV_BASE_EXPORTED_API virtual std::string ToString() const;
00091
00100     ACTIV_BASE_EXPORTED_API virtual void ToStream(std::ostream &os) const;
00101
00107     ACTIV_BASE_EXPORTED_API void AddException(Exception *pException) const;
00108
00109     const char * const      m_file;
00110     const char * const      m_function;
00111     const uint_fast32_t     m_line;
00112     const uint_fast32_t     m_errorCode;
00113
00114 private:
00118     ACTIV_BASE_LOCAL_API void DisplayChain(std::ostream &os) const;
00119
00120     mutable const Exception *m_pNextException;
00121 };
00122
00123 } // namespace Activ
00124
00125 // ---------------------------------------------------------------------------------------------------------------------------------
00126 // ---------------------------------------------------------------------------------------------------------------------------------
00127
00139 ACTIV_BASE_EXPORTED_API std::ostream &operator<<(std::ostream &os, const Activ::Exception &e);
00140
00141 #if (!defined ACTIV_COMPILER_SUNPRO)
00142
00143 namespace boost
00144 {
00145
00146 namespace io
00147 {
00148
00149 namespace detail
00150 {
00151
00152 inline std::ostream &operator<<(std::ostream &os, const Activ::Exception &e)
00153 {
00154     // allow passing of Exception into boost::format
00155     return ::operator<<(os, e);
00156 }
00157
00158 } // namespace detail
00159
00160 } // namespace io
00161
00162 } // namespace boost
00163
00164 #endif // (!defined ACTIV_COMPILER_SUNPRO)
00165
00166 #endif // (!defined ACTIV_BASE_EXCEPTION_H)
Generated on Wed Oct 8 14:01:47 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon

Exchanges.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FEED_COMMON_EXCHANGES_H)
00010 #define ACTIV_FEED_COMMON_EXCHANGES_H
00011
00012 #include "ActivMiddleware/Activ.h"
00013
00014 #include "ActivMiddleware/Misc/StlHelper.h"
00015
00016 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedDefinitions.h"
00017
00018 #include <vector>
00019 #include <string>
00020 #include <map>
00021
00022 namespace Activ
00023 {
00024
00025 namespace ContentPlatform
00026 {
00027
00028 namespace Feed
00029 {
00030
00031 typedef std::pair<Feed::TableNo, std::string> CompositeExchangeMapKey;
00032 typedef std::map<CompositeExchangeMapKey, std::string> CompositeExchangeMap;
00033
00034 #define ACTIV_FEED_SYMBOL_SEPARATOR_LIST(d) \
00035     d(INDEX_IDENTIFIER, '=')                \
00036     d(CORPORATE_ACTION_SEPARATOR, '%')      \
00037     d(DEAD_INSTRUMENT_SEPARATOR, '#')       \
00038     d(EXCHANGE_SEPARATOR, '.')              \
00039     d(EXPIRATION_DATE_SEPARATOR, '/')       \
00040     d(FORWARD_CODE_SEPARATOR, '/')          \
00041     d(LEVEL2_SEPARATOR, '-')                \
00042     d(MARKET_SEPARATOR, '/')                \
00043     d(NEWS_SOURCE_SEPARATOR, '%')           \
00044     d(ORDER_SEPARATOR, ';')                 \
00045     d(QUOTE_SEPARATOR, ':')                 \
00046     d(RANKINGS_SEPARATOR, '+')              \
00047     d(SPREAD_FUTURES_SEPARATOR, '-')        \
00048     d(STATISTICS_SEPARATOR, '+')            \
00049     d(STRIKE_PRICE_SEPARATOR, '/')          \
00050     d(SYMBOL_SEPARATOR, ' ')
00051
00052 #define ACTIV_DECLARE_FEED_SYMBOL_SEPARATOR(id, value)  const char id = value;
00053
00054 ACTIV_FEED_SYMBOL_SEPARATOR_LIST(ACTIV_DECLARE_FEED_SYMBOL_SEPARATOR)
00055
00056 #undef ACTIV_DECLARE_FEED_SYMBOL_SEPARATOR
00057
00058 const char ANALYTICS_SEPARATOR(LEVEL2_SEPARATOR);
00059
00060 const char g_compositeSymbolSeparatorList[] = { EXCHANGE_SEPARATOR, QUOTE_SEPARATOR, ORDER_SEPARATOR, CORPORATE_ACTION_SEPARATOR, DEAD_INSTRUMENT_SEPARATOR, NEWS_SOURCE_SEPARATOR, '\0' };
00061 const char g_exchangeSeparatorList[] = { EXCHANGE_SEPARATOR, CORPORATE_ACTION_SEPARATOR, DEAD_INSTRUMENT_SEPARATOR, NEWS_SOURCE_SEPARATOR, '\0'  };
00062 const char g_level2SeparatorList[] = { QUOTE_SEPARATOR, ORDER_SEPARATOR, LEVEL2_SEPARATOR, '\0'  };
00063
00064 #define ACTIV_FEED_EXCHANGE_ALPHA_TRADING "ATS"
00065 #define ACTIV_FEED_EXCHANGE_AMEX "A"
00066 #define ACTIV_FEED_EXCHANGE_AMEX_OPTIONS "AO"
00067 #define ACTIV_FEED_EXCHANGE_ASX "AX"
00068 #define ACTIV_FEED_EXCHANGE_BATS "BT"
00069 #define ACTIV_FEED_EXCHANGE_BATS_DIRECT "EB"
00070 #define ACTIV_FEED_EXCHANGE_BMF "BMF"
00071 #define ACTIV_FEED_EXCHANGE_BOSTON "B"
00072 #define ACTIV_FEED_EXCHANGE_BOSTON_OPTIONS "BO"
00073 #define ACTIV_FEED_EXCHANGE_BOVESPA "BS"
00074 #define ACTIV_FEED_EXCHANGE_CBOE "W"
00075 #define ACTIV_FEED_EXCHANGE_CBOT "CB"
00076 #define ACTIV_FEED_EXCHANGE_CBOT_GLOBEX "CBE"
00077 #define ACTIV_FEED_EXCHANGE_CFE "CF"
00078 #define ACTIV_FEED_EXCHANGE_CHI_X_CANADA "CHIC"
00079 #define ACTIV_FEED_EXCHANGE_CHI_X_EUROPE "CHIX"
00080 #define ACTIV_FEED_EXCHANGE_CHX "MW"
00081 #define ACTIV_FEED_EXCHANGE_CHX_DIRECT "CH"
00082 #define ACTIV_FEED_EXCHANGE_CME "CM"
00083 #define ACTIV_FEED_EXCHANGE_CME_GLOBEX "CMG"
00084 #define ACTIV_FEED_EXCHANGE_CNQ "CQ"
00085 #define ACTIV_FEED_EXCHANGE_COMEX "CX"
00086 #define ACTIV_FEED_EXCHANGE_COMEX_ACCESS "CXA"
00087 #define ACTIV_FEED_EXCHANGE_DIRECT_EDGE "ED"
00088 #define ACTIV_FEED_EXCHANGE_DUBAI_MERCANTILE_EXCHANGE "DME"
00089 #define ACTIV_FEED_EXCHANGE_EUREX "EX"
00090 #define ACTIV_FEED_EXCHANGE_EURONEXT_LIFFE "LI"
00091 #define ACTIV_FEED_EXCHANGE_EURONEXT_PARIS "P"
00092 #define ACTIV_FEED_EXCHANGE_E_NYMEX "NXF"
00093 #define ACTIV_FEED_EXCHANGE_E_NYMEX_EUROPE "NXE"
00094 #define ACTIV_FEED_EXCHANGE_FUKUOKA "FU"
00095 #define ACTIV_FEED_EXCHANGE_HKFE "HF"
00096 #define ACTIV_FEED_EXCHANGE_HKSE "HK"
00097 #define ACTIV_FEED_EXCHANGE_ICE "ICE"
00098 #define ACTIV_FEED_EXCHANGE_INET "EI"
00099 #define ACTIV_FEED_EXCHANGE_INSTINET_CBX "CBX"
00100 #define ACTIV_FEED_EXCHANGE_ISE "Y"
00101 #define ACTIV_FEED_EXCHANGE_ISE_DIRECT "I"
00102 #define ACTIV_FEED_EXCHANGE_ITA "ITA"
00103 #define ACTIV_FEED_EXCHANGE_JASDAQ "JQ"
00104 #define ACTIV_FEED_EXCHANGE_KCBOT "KC"
00105 #define ACTIV_FEED_EXCHANGE_KCBOT_ELECTRONIC "KCE"
00106 #define ACTIV_FEED_EXCHANGE_KOREA "KS"
00107 #define ACTIV_FEED_EXCHANGE_KOSDAQ "KQ"
00108 #define ACTIV_FEED_EXCHANGE_LME "LM"
00109 #define ACTIV_FEED_EXCHANGE_LSE "L"
00110 #define ACTIV_FEED_EXCHANGE_MGEX "MG"
00111 #define ACTIV_FEED_EXCHANGE_MGEX_ELECTRONIC "MGE"
00112 #define ACTIV_FEED_EXCHANGE_MONTREAL "M"
00113 #define ACTIV_FEED_EXCHANGE_NAGOYA "NG"
00114 #define ACTIV_FEED_EXCHANGE_NASDAQ "Q"
00115 #define ACTIV_FEED_EXCHANGE_NASDAQ_BULLETIN_BOARD "QB"
00116 #define ACTIV_FEED_EXCHANGE_NASDAQ_OTHER_OTC "QO"
00117 #define ACTIV_FEED_EXCHANGE_NASD_ADF "QD"
00118 #define ACTIV_FEED_EXCHANGE_NSX "C"
00119 #define ACTIV_FEED_EXCHANGE_NYBOT "NB"
00120 #define ACTIV_FEED_EXCHANGE_NYBOT_ELECTRONIC "NBE"
00121 #define ACTIV_FEED_EXCHANGE_NYMEX "NX"
00122 #define ACTIV_FEED_EXCHANGE_NYMEX_ACCESS "NXA"
00123 #define ACTIV_FEED_EXCHANGE_NYMEX_CLEARPORT "NXC"
00124 #define ACTIV_FEED_EXCHANGE_NYMEX_EUROPE "NXL"
00125 #define ACTIV_FEED_EXCHANGE_NYMEX_GLOBEX "NXG"
00126 #define ACTIV_FEED_EXCHANGE_NYSE "N"
00127 #define ACTIV_FEED_EXCHANGE_NYSE_ARCA "PA"
00128 #define ACTIV_FEED_EXCHANGE_NYSE_ARCA_DIRECT "EA"
00129 #define ACTIV_FEED_EXCHANGE_NYSE_ARCA_OPTIONS "PO"
00130 #define ACTIV_FEED_EXCHANGE_NYSE_BEST_QUOTES "NQ"
00131 #define ACTIV_FEED_EXCHANGE_NYSE_OPEN_BOOK "OB"
00132 #define ACTIV_FEED_EXCHANGE_ONE_CHICAGO "OC"
00133 #define ACTIV_FEED_EXCHANGE_OSE "OS"
00134 #define ACTIV_FEED_EXCHANGE_OTCQX "QX"
00135 #define ACTIV_FEED_EXCHANGE_PBOT "XB"
00136 #define ACTIV_FEED_EXCHANGE_PHLX "X"
00137 #define ACTIV_FEED_EXCHANGE_PHLX_OPTIONS "XO"
00138 #define ACTIV_FEED_EXCHANGE_PINK_SHEETS "PS"
00139 #define ACTIV_FEED_EXCHANGE_PURE_TRADING "PT"
00140 #define ACTIV_FEED_EXCHANGE_SAPPORO "SP"
00141 #define ACTIV_FEED_EXCHANGE_SGX "SG"
00142 #define ACTIV_FEED_EXCHANGE_SYDNEY_FUTURES "SF"
00143 #define ACTIV_FEED_EXCHANGE_TAIFEX "TX"
00144 #define ACTIV_FEED_EXCHANGE_TENFORE "TF"
00145 #define ACTIV_FEED_EXCHANGE_TOCOM "TC"
00146 #define ACTIV_FEED_EXCHANGE_TSE "T"
00147 #define ACTIV_FEED_EXCHANGE_TSX "TO"
00148 #define ACTIV_FEED_EXCHANGE_TSX_VENTURE "TV"
00149 #define ACTIV_FEED_EXCHANGE_US_OPTIONS_COMPOSITE "O"
00150 #define ACTIV_FEED_EXCHANGE_WCE "WC"
00151
00152 #define ACTIV_FEED_EXCHANGE_FEED_STATUS "FEED"
00153 #define ACTIV_FEED_EXCHANGE_LATENCY "LTCY"
00154
00155 const std::string EXCHANGE_ALPHA_TRADING(ACTIV_FEED_EXCHANGE_ALPHA_TRADING);
00156 const std::string EXCHANGE_AMEX(ACTIV_FEED_EXCHANGE_AMEX);
00157 const std::string EXCHANGE_AMEX_OPTIONS(ACTIV_FEED_EXCHANGE_AMEX_OPTIONS);
00158 const std::string EXCHANGE_ASX(ACTIV_FEED_EXCHANGE_ASX);
00159 const std::string EXCHANGE_BATS(ACTIV_FEED_EXCHANGE_BATS);
00160 const std::string EXCHANGE_BATS_DIRECT(ACTIV_FEED_EXCHANGE_BATS_DIRECT);
00161 const std::string EXCHANGE_BMF(ACTIV_FEED_EXCHANGE_BMF);
00162 const std::string EXCHANGE_BOSTON(ACTIV_FEED_EXCHANGE_BOSTON);
00163 const std::string EXCHANGE_BOSTON_OPTIONS(ACTIV_FEED_EXCHANGE_BOSTON_OPTIONS);
00164 const std::string EXCHANGE_BOVESPA(ACTIV_FEED_EXCHANGE_BOVESPA);
00165 const std::string EXCHANGE_CBOE(ACTIV_FEED_EXCHANGE_CBOE);
00166 const std::string EXCHANGE_CBOT(ACTIV_FEED_EXCHANGE_CBOT);
00167 const std::string EXCHANGE_CBOT_GLOBEX(ACTIV_FEED_EXCHANGE_CBOT_GLOBEX);
00168 const std::string EXCHANGE_CFE(ACTIV_FEED_EXCHANGE_CFE);
00169 const std::string EXCHANGE_CHI_X_CANADA(ACTIV_FEED_EXCHANGE_CHI_X_CANADA);
00170 const std::string EXCHANGE_CHI_X_EUROPE(ACTIV_FEED_EXCHANGE_CHI_X_EUROPE);
00171 const std::string EXCHANGE_CHX(ACTIV_FEED_EXCHANGE_CHX);
00172 const std::string EXCHANGE_CHX_DIRECT(ACTIV_FEED_EXCHANGE_CHX_DIRECT);
00173 const std::string EXCHANGE_CME(ACTIV_FEED_EXCHANGE_CME);
00174 const std::string EXCHANGE_CME_GLOBEX(ACTIV_FEED_EXCHANGE_CME_GLOBEX);
00175 const std::string EXCHANGE_CNQ(ACTIV_FEED_EXCHANGE_CNQ);
00176 const std::string EXCHANGE_COMEX(ACTIV_FEED_EXCHANGE_COMEX);
00177 const std::string EXCHANGE_COMEX_ACCESS(ACTIV_FEED_EXCHANGE_COMEX_ACCESS);
00178 const std::string EXCHANGE_DIRECT_EDGE(ACTIV_FEED_EXCHANGE_DIRECT_EDGE);
00179 const std::string EXCHANGE_DUBAI_MERCANTILE_EXCHANGE(ACTIV_FEED_EXCHANGE_DUBAI_MERCANTILE_EXCHANGE);
00180 const std::string EXCHANGE_EUREX(ACTIV_FEED_EXCHANGE_EUREX);
00181 const std::string EXCHANGE_EURONEXT_LIFFE(ACTIV_FEED_EXCHANGE_EURONEXT_LIFFE);
00182 const std::string EXCHANGE_EURONEXT_PARIS(ACTIV_FEED_EXCHANGE_EURONEXT_PARIS);
00183 const std::string EXCHANGE_E_NYMEX(ACTIV_FEED_EXCHANGE_E_NYMEX);
00184 const std::string EXCHANGE_E_NYMEX_EUROPE(ACTIV_FEED_EXCHANGE_E_NYMEX_EUROPE);
00185 const std::string EXCHANGE_FUKUOKA(ACTIV_FEED_EXCHANGE_FUKUOKA);
00186 const std::string EXCHANGE_HKFE(ACTIV_FEED_EXCHANGE_HKFE);
00187 const std::string EXCHANGE_HKSE(ACTIV_FEED_EXCHANGE_HKSE);
00188 const std::string EXCHANGE_ICE(ACTIV_FEED_EXCHANGE_ICE);
00189 const std::string EXCHANGE_INET(ACTIV_FEED_EXCHANGE_INET);
00190 const std::string EXCHANGE_INSTINET_CBX(ACTIV_FEED_EXCHANGE_INSTINET_CBX);
00191 const std::string EXCHANGE_ISE(ACTIV_FEED_EXCHANGE_ISE);
00192 const std::string EXCHANGE_ISE_DIRECT(ACTIV_FEED_EXCHANGE_ISE_DIRECT);
00193 const std::string EXCHANGE_ITA(ACTIV_FEED_EXCHANGE_ITA);
00194 const std::string EXCHANGE_JASDAQ(ACTIV_FEED_EXCHANGE_JASDAQ);
00195 const std::string EXCHANGE_KCBOT(ACTIV_FEED_EXCHANGE_KCBOT);
00196 const std::string EXCHANGE_KCBOT_ELECTRONIC(ACTIV_FEED_EXCHANGE_KCBOT_ELECTRONIC);
00197 const std::string EXCHANGE_KOREA(ACTIV_FEED_EXCHANGE_KOREA);
00198 const std::string EXCHANGE_KOSDAQ(ACTIV_FEED_EXCHANGE_KOSDAQ);
00199 const std::string EXCHANGE_LME(ACTIV_FEED_EXCHANGE_LME);
00200 const std::string EXCHANGE_LSE(ACTIV_FEED_EXCHANGE_LSE);
00201 const std::string EXCHANGE_MGEX(ACTIV_FEED_EXCHANGE_MGEX);
00202 const std::string EXCHANGE_MGEX_ELECTRONIC(ACTIV_FEED_EXCHANGE_MGEX_ELECTRONIC);
00203 const std::string EXCHANGE_MONTREAL(ACTIV_FEED_EXCHANGE_MONTREAL);
00204 const std::string EXCHANGE_NAGOYA(ACTIV_FEED_EXCHANGE_NAGOYA);
00205 const std::string EXCHANGE_NASDAQ(ACTIV_FEED_EXCHANGE_NASDAQ);
00206 const std::string EXCHANGE_NASDAQ_BULLETIN_BOARD(ACTIV_FEED_EXCHANGE_NASDAQ_BULLETIN_BOARD);
00207 const std::string EXCHANGE_NASDAQ_OTHER_OTC(ACTIV_FEED_EXCHANGE_NASDAQ_OTHER_OTC);
00208 const std::string EXCHANGE_NASD_ADF(ACTIV_FEED_EXCHANGE_NASD_ADF);
00209 const std::string EXCHANGE_NSX(ACTIV_FEED_EXCHANGE_NSX);
00210 const std::string EXCHANGE_NYBOT(ACTIV_FEED_EXCHANGE_NYBOT);
00211 const std::string EXCHANGE_NYBOT_ELECTRONIC(ACTIV_FEED_EXCHANGE_NYBOT_ELECTRONIC);
00212 const std::string EXCHANGE_NYMEX(ACTIV_FEED_EXCHANGE_NYMEX);
00213 const std::string EXCHANGE_NYMEX_ACCESS(ACTIV_FEED_EXCHANGE_NYMEX_ACCESS);
00214 const std::string EXCHANGE_NYMEX_CLEARPORT(ACTIV_FEED_EXCHANGE_NYMEX_CLEARPORT);
00215 const std::string EXCHANGE_NYMEX_EUROPE(ACTIV_FEED_EXCHANGE_NYMEX_EUROPE);
00216 const std::string EXCHANGE_NYMEX_GLOBEX(ACTIV_FEED_EXCHANGE_NYMEX_GLOBEX);
00217 const std::string EXCHANGE_NYSE(ACTIV_FEED_EXCHANGE_NYSE);
00218 const std::string EXCHANGE_NYSE_ARCA(ACTIV_FEED_EXCHANGE_NYSE_ARCA);
00219 const std::string EXCHANGE_NYSE_ARCA_DIRECT(ACTIV_FEED_EXCHANGE_NYSE_ARCA_DIRECT);
00220 const std::string EXCHANGE_NYSE_ARCA_OPTIONS(ACTIV_FEED_EXCHANGE_NYSE_ARCA_OPTIONS);
00221 const std::string EXCHANGE_NYSE_BEST_QUOTES(ACTIV_FEED_EXCHANGE_NYSE_BEST_QUOTES);
00222 const std::string EXCHANGE_NYSE_OPEN_BOOK(ACTIV_FEED_EXCHANGE_NYSE_OPEN_BOOK);
00223 const std::string EXCHANGE_ONE_CHICAGO(ACTIV_FEED_EXCHANGE_ONE_CHICAGO);
00224 const std::string EXCHANGE_OSE(ACTIV_FEED_EXCHANGE_OSE);
00225 const std::string EXCHANGE_OTCQX(ACTIV_FEED_EXCHANGE_OTCQX);
00226 const std::string EXCHANGE_PBOT(ACTIV_FEED_EXCHANGE_PBOT);
00227 const std::string EXCHANGE_PHLX(ACTIV_FEED_EXCHANGE_PHLX);
00228 const std::string EXCHANGE_PHLX_OPTIONS(ACTIV_FEED_EXCHANGE_PHLX_OPTIONS);
00229 const std::string EXCHANGE_PINK_SHEETS(ACTIV_FEED_EXCHANGE_PINK_SHEETS);
00230 const std::string EXCHANGE_PURE_TRADING(ACTIV_FEED_EXCHANGE_PURE_TRADING);
00231 const std::string EXCHANGE_SAPPORO(ACTIV_FEED_EXCHANGE_SAPPORO);
00232 const std::string EXCHANGE_SGX(ACTIV_FEED_EXCHANGE_SGX);
00233 const std::string EXCHANGE_SYDNEY_FUTURES(ACTIV_FEED_EXCHANGE_SYDNEY_FUTURES);
00234 const std::string EXCHANGE_TAIFEX(ACTIV_FEED_EXCHANGE_TAIFEX);
00235 const std::string EXCHANGE_TENFORE(ACTIV_FEED_EXCHANGE_TENFORE);
00236 const std::string EXCHANGE_TOCOM(ACTIV_FEED_EXCHANGE_TOCOM);
00237 const std::string EXCHANGE_TSE(ACTIV_FEED_EXCHANGE_TSE);
00238 const std::string EXCHANGE_TSX(ACTIV_FEED_EXCHANGE_TSX);
00239 const std::string EXCHANGE_TSX_VENTURE(ACTIV_FEED_EXCHANGE_TSX_VENTURE);
00240 const std::string EXCHANGE_US_OPTIONS_COMPOSITE(ACTIV_FEED_EXCHANGE_US_OPTIONS_COMPOSITE);
00241 const std::string EXCHANGE_WCE(ACTIV_FEED_EXCHANGE_WCE);
00242
00243 const std::string EXCHANGE_FEED_STATUS(ACTIV_FEED_EXCHANGE_FEED_STATUS);
00244 const std::string EXCHANGE_LATENCY(ACTIV_FEED_EXCHANGE_LATENCY);
00245
00246 // Deprecated ...
00247
00248 #define ACTIV_FEED_EXCHANGE_ARCA ACTIV_FEED_EXCHANGE_NYSE_ARCA_DIRECT
00249 #define ACTIV_FEED_EXCHANGE_CHICAGO ACTIV_FEED_EXCHANGE_CHX
00250 #define ACTIV_FEED_EXCHANGE_CINCINNATI ACTIV_FEED_EXCHANGE_NSX
00251 #define ACTIV_FEED_EXCHANGE_E_CBOT ACTIV_FEED_EXCHANGE_CBOT_GLOBEX
00252 #define ACTIV_FEED_EXCHANGE_INTERNATIONAL_SECURITIES ACTIV_FEED_EXCHANGE_ISE
00253 #define ACTIV_FEED_EXCHANGE_NASDAQ_ADF ACTIV_FEED_EXCHANGE_NASD_ADF
00254 #define ACTIV_FEED_EXCHANGE_NATIONAL ACTIV_FEED_EXCHANGE_NSX
00255 #define ACTIV_FEED_EXCHANGE_PACIFIC ACTIV_FEED_EXCHANGE_NYSE_ARCA
00256 #define ACTIV_FEED_EXCHANGE_PACIFIC_OPTIONS ACTIV_FEED_EXCHANGE_NYSE_ARCA_OPTIONS
00257 #define ACTIV_FEED_EXCHANGE_PHILADELPHIA ACTIV_FEED_EXCHANGE_PHLX
00258 #define ACTIV_FEED_EXCHANGE_PHILADELPHIA_OPTIONS ACTIV_FEED_EXCHANGE_PHLX_OPTIONS
00259
00260 const std::string EXCHANGE_ARCA(EXCHANGE_NYSE_ARCA_DIRECT);
00261 const std::string EXCHANGE_CHICAGO(EXCHANGE_CHX);
00262 const std::string EXCHANGE_CINCINNATI(EXCHANGE_NSX);
00263 const std::string EXCHANGE_E_CBOT(EXCHANGE_CBOT_GLOBEX);
00264 const std::string EXCHANGE_INTERNATIONAL_SECURITIES(EXCHANGE_ISE);
00265 const std::string EXCHANGE_NASDAQ_ADF(EXCHANGE_NASD_ADF);
00266 const std::string EXCHANGE_NATIONAL(EXCHANGE_NSX);
00267 const std::string EXCHANGE_PACIFIC(EXCHANGE_NYSE_ARCA);
00268 const std::string EXCHANGE_PACIFIC_OPTIONS(EXCHANGE_NYSE_ARCA_OPTIONS);
00269 const std::string EXCHANGE_PHILADELPHIA(EXCHANGE_PHLX);
00270 const std::string EXCHANGE_PHILADELPHIA_OPTIONS(EXCHANGE_PHLX_OPTIONS);
00271
00279 inline std::string GetExchange(const std::string &symbol)
00280 {
00281     const std::string::size_type exchangeIndex = symbol.find_last_of(g_exchangeSeparatorList);
00282
00283     if (std::string::npos == exchangeIndex)
00284         return std::string("");
00285
00286     const std::string::size_type level2Index = symbol.find_first_of(g_level2SeparatorList, exchangeIndex + 1);
00287
00288     return (std::string::npos == level2Index) ? symbol.substr(exchangeIndex + 1) : symbol.substr(exchangeIndex + 1, level2Index - (exchangeIndex + 1));
00289 }
00290
00291 // ---------------------------------------------------------------------------------------------------------------------------------
00292
00300 inline std::string GetDefaultCompositeSymbol(const std::string &symbol)
00301 {
00302     const std::string::size_type index = symbol.find_last_of(g_compositeSymbolSeparatorList);
00303
00304     return (std::string::npos == index) ? symbol : symbol.substr(0, index + 1);
00305 }
00306
00307 // ---------------------------------------------------------------------------------------------------------------------------------
00308
00319 inline bool GetCompositeSymbol(const CompositeExchangeMap &compositeExchangeMap, const Feed::TableNo tableNumber, const std::string &symbol, std::string &compositeSymbol)
00320 {
00321     const CompositeExchangeMapKey compositeExchangeMapKey(tableNumber, GetExchange(symbol));
00322     const CompositeExchangeMap::const_iterator iterator = compositeExchangeMap.find(compositeExchangeMapKey);
00323     if (compositeExchangeMap.end() == iterator)
00324         return false;
00325
00326     compositeSymbol = GetDefaultCompositeSymbol(symbol) + iterator->second;
00327     return true;
00328 }
00329
00330 } // namespace Feed
00331
00332 } // namespace ContentPlatform
00333
00334 } // namespace Activ
00335
00336 #endif // (!defined ACTIV_FEED_COMMON_EXCHANGES_H)
Generated on Wed Oct 8 14:01:46 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

Fiber.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_BASE_FIBER_H)
00010 #define ACTIV_BASE_FIBER_H
00011
00012 #include "ActivMiddleware/ActivBase/External.h"
00013
00014 #if (defined ACTIV_POSIX_HAS_CONTEXT_API)
00015 #include <ucontext.h>
00016 #include "boost/scoped_array.hpp"
00017 #elif (!defined ACTIV_PLATFORM_WINDOWS)
00018 #include "ActivMiddleware/ActivBase/Thread.h"
00019 #endif
00020
00021 namespace Activ
00022 {
00023
00024 class IEvent;
00025
00026 // ---------------------------------------------------------------------------------------------------------------------------------
00027
00031 class Fiber : private boost::noncopyable
00032 {
00033 public:
00034     static const size_t defaultStackSize = 102400;
00035
00044     ACTIV_BASE_EXPORTED_API Fiber(void * const pData = 0, const size_t stackSize = defaultStackSize);
00045
00049     ACTIV_BASE_EXPORTED_API virtual ~Fiber();
00050
00054     ACTIV_BASE_EXPORTED_API void Switch();
00055
00061     ACTIV_BASE_EXPORTED_API void Return();
00062
00063 protected:
00069     ACTIV_BASE_EXPORTED_API virtual void Process(void * const pData) = 0;
00070
00071 private:
00072     enum State
00073     {
00074         STATE_NOT_ACTIVE,
00075         STATE_ACTIVE,
00076         STATE_DONE
00077     };
00078
00079     State           m_state;
00080
00081 #if (defined ACTIV_PLATFORM_WINDOWS)
00082
00083     typedef void *FiberId;
00084     ACTIV_BASE_LOCAL_API static void CALLBACK StaticFiberProc(void *pData);
00085
00086 #elif (defined ACTIV_POSIX_HAS_CONTEXT_API)
00087
00088     typedef ucontext_t FiberId;
00089     ACTIV_BASE_LOCAL_API static void StaticFiberProc(const uint32_t highFiberAddress, const uint32_t lowFiberAddress);
00090
00091     const size_t    m_stackSize;
00092     char * const    m_pStack;
00093
00094 #else // fallback to a thread based implementation
00095
00096     class FiberThread : public Thread
00097     {
00098     public:
00099         ACTIV_BASE_LOCAL_API FiberThread(Fiber &fiber);
00100
00101     private:
00102         ACTIV_BASE_LOCAL_API virtual StatusCode Process(void *pData);
00103
00104         Fiber   &m_fiber;
00105     };
00106
00107     typedef IEvent *FiberId;
00108
00109     FiberThread     m_fiberThread;
00110
00111 #endif
00112
00113     void * const    m_pData;
00114     FiberId         m_id;
00115     FiberId         m_returnId;
00116 };
00117
00118 } // namespace Activ
00119
00120 #endif // (!defined ACTIV_BASE_FIBER_H)
Generated on Wed Oct 8 14:01:47 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedTableTemplateHandler

Field.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FEED_TABLE_TEMPLATE_HANDLER_FIELD_H)
00010 #define ACTIV_FEED_TABLE_TEMPLATE_HANDLER_FIELD_H
00011
00012 #include "ActivMiddleware/ActivFieldTypes/ActivFieldTypes.h"
00013
00014 #include "ActivContentPlatform/ActivFeedCommon/FieldIds.h"
00015
00016 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/External.h"
00017
00018 #include <string>
00019 #include <vector>
00020 #include <map>
00021
00022 namespace Activ
00023 {
00024
00025 namespace ContentPlatform
00026 {
00027
00028 namespace Feed
00029 {
00030
00034 class Field
00035 {
00036 public:
00042     class Specification
00043     {
00044     public:
00061         ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API Specification(const FieldId id, const std::string &name, const std::string &codeIdentifier, const std::string &description, const FieldType type, const size_t maxLength, const bool isAmfField = false, const uint8_t amfRowIndex = 0, const uint8_t amfRowOffset = 0, const uint8_t amfFieldIndex = 0);
00062
00063         FieldId         m_id;
00064         std::string     m_name;
00065         std::string     m_codeIdentifier;
00066         std::string     m_description;
00067         FieldType       m_type;
00068         size_t          m_maxLength;
00069         bool            m_isAmfField;
00070         uint8_t         m_amfRowIndex;
00071         uint8_t         m_amfRowOffset;
00072         uint8_t         m_amfFieldIndex;
00073     };
00074
00078     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API Field();
00079
00085     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API Field(const Specification &specification);
00086
00090     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API ~Field();
00091
00099     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API bool operator==(const Field &rhs) const;
00100
00108     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API bool operator!=(const Field &rhs) const;
00109
00113     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API Field &operator=(const Field &rhs);
00114
00120     FieldId GetId() const;
00121
00127     const std::string &GetName() const;
00128
00134     const std::string &GetCodeIdentifier() const;
00135
00141     const std::string &GetDescription() const;
00142
00148     const FieldType GetType() const;
00149
00155     size_t GetMaxLength() const;
00156
00162     bool IsAmfField() const;
00163
00169     uint8_t GetAmfRowIndex() const;
00170
00176     uint8_t GetAmfRowOffset() const;
00177
00183     uint8_t GetAmfFieldIndex() const;
00184
00190     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API static std::string GetUiHeading();
00191
00197     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API std::string ToString() const;
00198
00199 private:
00200     FieldId         m_id;
00201     std::string     m_name;
00202     std::string     m_codeIdentifier;
00203     std::string     m_description;
00204     FieldType       m_type;
00205     size_t          m_maxLength;
00206     bool            m_isAmfField;
00207     uint8_t         m_amfRowIndex;
00208     uint8_t         m_amfRowOffset;
00209     uint8_t         m_amfFieldIndex;
00210 };
00211
00212 // ---------------------------------------------------------------------------------------------------------------------------------
00213
00214 inline FieldId Field::GetId() const
00215 {
00216     return m_id;
00217 }
00218
00219 // ---------------------------------------------------------------------------------------------------------------------------------
00220
00221 inline const std::string &Field::GetName() const
00222 {
00223     return m_name;
00224 }
00225
00226 // ---------------------------------------------------------------------------------------------------------------------------------
00227
00228 inline const std::string &Field::GetCodeIdentifier() const
00229 {
00230     return m_codeIdentifier;
00231 }
00232
00233 // ---------------------------------------------------------------------------------------------------------------------------------
00234
00235 inline const std::string &Field::GetDescription() const
00236 {
00237     return m_description;
00238 }
00239
00240 // ---------------------------------------------------------------------------------------------------------------------------------
00241
00242 inline const FieldType Field::GetType() const
00243 {
00244     return m_type;
00245 }
00246
00247 // ---------------------------------------------------------------------------------------------------------------------------------
00248
00249 inline size_t Field::GetMaxLength() const
00250 {
00251     return m_maxLength;
00252 }
00253
00254 // ---------------------------------------------------------------------------------------------------------------------------------
00255
00256 inline bool Field::IsAmfField() const
00257 {
00258     return m_isAmfField;
00259 }
00260
00261 // ---------------------------------------------------------------------------------------------------------------------------------
00262
00263 inline uint8_t Field::GetAmfRowIndex() const
00264 {
00265     return m_amfRowIndex;
00266 }
00267
00268 // ---------------------------------------------------------------------------------------------------------------------------------
00269
00270 inline uint8_t Field::GetAmfRowOffset() const
00271 {
00272     return m_amfRowOffset;
00273 }
00274
00275 // ---------------------------------------------------------------------------------------------------------------------------------
00276
00277 inline uint8_t Field::GetAmfFieldIndex() const
00278 {
00279     return m_amfFieldIndex;
00280 }
00281
00282 // ---------------------------------------------------------------------------------------------------------------------------------
00283
00284 typedef std::vector<Field>  FieldList;
00285
00286 typedef std::map<Feed::FieldId, Feed::Field>  FieldMap;
00287
00288 } // namespace Feed
00289
00290 } // namespace ContentPlatform
00291
00292 } // namespace Activ
00293
00294 // ---------------------------------------------------------------------------------------------------------------------------------
00295
00304 ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API std::ostream &operator<<(std::ostream &os, const Activ::ContentPlatform::Feed::Field &rhs);
00305
00306 #endif // (!defined ACTIV_FEED_TABLE_TEMPLATE_HANDLER_FIELD_H)
Generated on Wed Oct 8 14:01:46 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedMessageHandler

FieldHeaderDefinitions.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FEED_MESSAGE_HANDLER_FIELD_HEADER_DEFINITIONS_H)
00010 #define ACTIV_FEED_MESSAGE_HANDLER_FIELD_HEADER_DEFINITIONS_H
00011
00012 #include "ActivContentPlatform/ActivFeedCommon/FieldIds.h"
00013
00014 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/External.h"
00015
00016 namespace Activ
00017 {
00018
00019 namespace ContentPlatform
00020 {
00021
00022 namespace Feed
00023 {
00024
00028 class FieldHeaderDefinitions
00029 {
00030 public:
00031     typedef uint16_t FieldHeader;
00032
00033     static const size_t     FIELD_UNDEFINED_OFFSET  = 0;
00034     static const size_t     FIELD_UNDEFINED_LENGTH  = 1;
00035     static const size_t     FIELD_RESERVED_OFFSET   = (FIELD_UNDEFINED_OFFSET + FIELD_UNDEFINED_LENGTH);
00036     static const size_t     FIELD_RESERVED_LENGTH   = 1;
00037     static const size_t     FIELD_ID_OFFSET         = (FIELD_RESERVED_OFFSET + FIELD_RESERVED_LENGTH);
00038     static const size_t     FIELD_ID_LENGTH         = 14;
00039
00048     static FieldHeader GetFieldHeader(const FieldId fieldId, const bool isFieldDefined);
00049
00057     static FieldId GetFieldId(const FieldHeader fieldHeader);
00058
00066     static bool IsFieldDefined(const FieldHeader fieldHeader);
00067 };
00068
00069 // ---------------------------------------------------------------------------------------------------------------------------------
00070
00071 inline FieldHeaderDefinitions::FieldHeader FieldHeaderDefinitions::GetFieldHeader(const FieldId fieldId, const bool isFieldDefined)
00072 {
00073     return static_cast<FieldHeader>((fieldId << ((sizeof(FieldHeader) * CHAR_BIT) - (FIELD_ID_OFFSET + FIELD_ID_LENGTH))) | (!isFieldDefined << ((sizeof(FieldHeader) * CHAR_BIT) - (FIELD_UNDEFINED_OFFSET + FIELD_UNDEFINED_LENGTH))));
00074 }
00075
00076 // ---------------------------------------------------------------------------------------------------------------------------------
00077
00078 inline FieldId FieldHeaderDefinitions::GetFieldId(const FieldHeader fieldHeader)
00079 {
00080     return ((fieldHeader >> ((sizeof(FieldHeader) * CHAR_BIT) - (FIELD_ID_OFFSET + FIELD_ID_LENGTH))) & ((1 << FIELD_ID_LENGTH) - 1));
00081 }
00082
00083 // ---------------------------------------------------------------------------------------------------------------------------------
00084
00085 inline bool FieldHeaderDefinitions::IsFieldDefined(const FieldHeader fieldHeader)
00086 {
00087     return (((fieldHeader >> ((sizeof(FieldHeader) * CHAR_BIT) - (FIELD_UNDEFINED_OFFSET + FIELD_UNDEFINED_LENGTH))) & ((1 << FIELD_UNDEFINED_LENGTH) - 1)) == 0);
00088 }
00089
00090 } // namespace Feed
00091
00092 } // namespace ContentPlatform
00093
00094 } // namespace Activ
00095
00096 #endif // (!defined ACTIV_FEED_MESSAGE_HANDLER_FIELD_HEADER_DEFINITIONS_H)
Generated on Wed Oct 8 14:01:45 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon

FieldIds.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FEED_COMMON_FIELD_IDS_H)
00010 #define ACTIV_FEED_COMMON_FIELD_IDS_H
00011
00012 #include "ActivContentPlatform/ActivFeedCommon/External.h"
00013 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedDefinitions.h"
00014
00015 namespace Activ
00016 {
00017
00018 namespace ContentPlatform
00019 {
00020
00021 namespace Feed
00022 {
00023
00024 const FieldId FID_UNDEFINED = ~0;
00025
00026 const FieldId FID_BID = 0;
00027 const FieldId FID_BID_SIZE = 1;
00028 const FieldId FID_BID_CONDITION = 2;
00029 const FieldId FID_BID_TIME = 3;
00030 const FieldId FID_BID_EXCHANGE = 4;
00031 const FieldId FID_ASK = 5;
00032 const FieldId FID_ASK_SIZE = 6;
00033 const FieldId FID_ASK_CONDITION = 7;
00034 const FieldId FID_ASK_TIME = 8;
00035 const FieldId FID_ASK_EXCHANGE = 9;
00036 const FieldId FID_MARKET_MAKER_STATUS = 10;
00037 const FieldId FID_QUOTE_DATE = 11;
00038 const FieldId FID_TRADE = 12;
00039 const FieldId FID_TRADE_SIZE = 13;
00040 const FieldId FID_TRADE_CONDITION = 14;
00041 const FieldId FID_TRADE_TIME = 15;
00042 const FieldId FID_TRADE_DATE = 16;
00043 const FieldId FID_TRADE_EXCHANGE = 17;
00044 const FieldId FID_TRADE_HIGH = 18;
00045 const FieldId FID_TRADE_HIGH_CONDITION = 19;
00046 const FieldId FID_TRADE_HIGH_TIME = 20;
00047 const FieldId FID_TRADE_HIGH_EXCHANGE = 21;
00048 const FieldId FID_TRADE_LOW = 22;
00049 const FieldId FID_TRADE_LOW_CONDITION = 23;
00050 const FieldId FID_TRADE_LOW_TIME = 24;
00051 const FieldId FID_TRADE_LOW_EXCHANGE = 25;
00052 const FieldId FID_TRADE_COUNT = 26;
00053 const FieldId FID_CURRENT = 27;
00054 const FieldId FID_CURRENT_CONDITION = 28;
00055 const FieldId FID_CURRENT_TIME = 29;
00056 const FieldId FID_CURRENT_DATE = 30;
00057 const FieldId FID_CURRENT_HIGH = 31;
00058 const FieldId FID_CURRENT_HIGH_TIME = 32;
00059 const FieldId FID_CURRENT_LOW = 33;
00060 const FieldId FID_CURRENT_LOW_TIME = 34;
00061 const FieldId FID_OPEN = 35;
00062 const FieldId FID_OPEN_SIZE = 36;
00063 const FieldId FID_OPEN_CONDITION = 37;
00064 const FieldId FID_OPEN_TIME = 38;
00065 const FieldId FID_OPEN_EXCHANGE = 39;
00066 const FieldId FID_FIRST_TRADE = 40;
00067 const FieldId FID_FIRST_TRADE_TIME = 41;
00068 const FieldId FID_ORDER_PRICE = 42;
00069 const FieldId FID_ORDER_SIZE = 43;
00070 const FieldId FID_ORDER_TIME = 44;
00071 const FieldId FID_ORDER_DATE = 45;
00072 const FieldId FID_ORDER_BUY_SELL = 46;
00073 const FieldId FID_ORDER_SEQUENCE_NUMBER = 47;
00074 const FieldId FID_ORDER_STATE = 48;
00075 const FieldId FID_ORDER_TYPE = 49;
00076 const FieldId FID_CUMULATIVE_PRICE = 50;
00077 const FieldId FID_CUMULATIVE_VALUE = 51;
00078 const FieldId FID_CUMULATIVE_VOLUME = 52;
00079 const FieldId FID_PRE_POST_MARKET_CUMULATIVE_VOLUME = 53;
00080 const FieldId FID_NET_CHANGE = 54;
00081 const FieldId FID_PERCENT_CHANGE = 55;
00082 const FieldId FID_CLOSING_BID = 56;
00083 const FieldId FID_CLOSING_BID_EXCHANGE = 57;
00084 const FieldId FID_CLOSING_ASK = 58;
00085 const FieldId FID_CLOSING_ASK_EXCHANGE = 59;
00086 const FieldId FID_CLOSING_QUOTE_DATE = 60;
00087 const FieldId FID_CLOSE = 61;
00088 const FieldId FID_CLOSE_CONDITION = 62;
00089 const FieldId FID_CLOSE_STATUS = 63;
00090 const FieldId FID_CLOSE_TIME = 64;
00091 const FieldId FID_CLOSE_DATE = 65;
00092 const FieldId FID_CLOSE_EXCHANGE = 66;
00093 const FieldId FID_CLOSE_CUMULATIVE_VOLUME = 67;
00094 const FieldId FID_CLOSE_CUMULATIVE_VOLUME_STATUS = 68;
00095 const FieldId FID_CLOSE_CUMULATIVE_VOLUME_DATE = 69;
00096 const FieldId FID_CLOSE_CUMULATIVE_VALUE = 70;
00097 const FieldId FID_CLOSE_CUMULATIVE_VALUE_STATUS = 71;
00098 const FieldId FID_COMPOSITE_CLOSE = 72;
00099 const FieldId FID_COMPOSITE_CLOSE_DATE = 73;
00100 const FieldId FID_COMPOSITE_CLOSE_EXCHANGE = 74;
00101 const FieldId FID_SETTLEMENT = 75;
00102 const FieldId FID_SETTLEMENT_SIZE = 76;
00103 const FieldId FID_SETTLEMENT_STATUS = 77;
00104 const FieldId FID_SETTLEMENT_TIME = 78;
00105 const FieldId FID_SETTLEMENT_DATE = 79;
00106 const FieldId FID_BID1 = 80;
00107 const FieldId FID_BID1_TIME = 81;
00108 const FieldId FID_BID1_SIZE = 82;
00109 const FieldId FID_BID1_COUNT = 83;
00110 const FieldId FID_ASK1 = 84;
00111 const FieldId FID_ASK1_TIME = 85;
00112 const FieldId FID_ASK1_SIZE = 86;
00113 const FieldId FID_ASK1_COUNT = 87;
00114 const FieldId FID_BID2 = 88;
00115 const FieldId FID_BID2_COUNT = 89;
00116 const FieldId FID_BID2_SIZE = 90;
00117 const FieldId FID_BID3 = 91;
00118 const FieldId FID_ASK2 = 92;
00119 const FieldId FID_ASK2_COUNT = 93;
00120 const FieldId FID_ASK2_SIZE = 94;
00121 const FieldId FID_ASK3 = 95;
00122 const FieldId FID_BID3_SIZE = 96;
00123 const FieldId FID_BID4 = 97;
00124 const FieldId FID_BID3_COUNT = 98;
00125 const FieldId FID_BID4_SIZE = 99;
00126 const FieldId FID_ASK3_SIZE = 100;
00127 const FieldId FID_ASK4 = 101;
00128 const FieldId FID_ASK3_COUNT = 102;
00129 const FieldId FID_ASK4_SIZE = 103;
00130 const FieldId FID_BID4_COUNT = 104;
00131 const FieldId FID_BID5_SIZE = 105;
00132 const FieldId FID_BID5 = 106;
00133 const FieldId FID_BID5_COUNT = 107;
00134 const FieldId FID_ASK4_COUNT = 108;
00135 const FieldId FID_ASK5_SIZE = 109;
00136 const FieldId FID_ASK5 = 110;
00137 const FieldId FID_ASK5_COUNT = 111;
00138 const FieldId FID_PREVIOUS_TRADING_DATE = 112;
00139 const FieldId FID_PREVIOUS_CLOSE = 113;
00140 const FieldId FID_PREVIOUS_OPEN = 114;
00141 const FieldId FID_PREVIOUS_TRADE_HIGH = 115;
00142 const FieldId FID_PREVIOUS_TRADE_LOW = 116;
00143 const FieldId FID_PREVIOUS_CURRENT_HIGH = 117;
00144 const FieldId FID_PREVIOUS_CURRENT_LOW = 118;
00145 const FieldId FID_PREVIOUS_NET_CHANGE = 119;
00146 const FieldId FID_PREVIOUS_PERCENT_CHANGE = 120;
00147 const FieldId FID_PREVIOUS_OPEN_INTEREST = 121;
00148 const FieldId FID_PREVIOUS_OPEN_INTEREST_DATE = 122;
00149 const FieldId FID_OPEN_RANGE_1 = 123;
00150 const FieldId FID_OPEN_RANGE_1_CONDITION = 124;
00151 const FieldId FID_OPEN_RANGE_2 = 125;
00152 const FieldId FID_OPEN_RANGE_2_CONDITION = 126;
00153 const FieldId FID_OPEN_RANGE_TIME = 127;
00154 const FieldId FID_CLOSE_RANGE_1 = 128;
00155 const FieldId FID_CLOSE_RANGE_1_CONDITION = 129;
00156 const FieldId FID_CLOSE_RANGE_2 = 130;
00157 const FieldId FID_CLOSE_RANGE_2_CONDITION = 131;
00158 const FieldId FID_CLOSE_RANGE_TIME = 132;
00159 const FieldId FID_LOCAL_PRICE = 133;
00160 const FieldId FID_OPEN_INTEREST = 134;
00161 const FieldId FID_OPEN_INTEREST_DATE = 135;
00162 const FieldId FID_MARKET_PRICE = 136;
00163 const FieldId FID_MARKET_PRICE_DATE = 137;
00164 const FieldId FID_MARKET_PRICE_TIME = 138;
00165 const FieldId FID_OFFER = 139;
00166 const FieldId FID_OFFER_DATE = 140;
00167 const FieldId FID_OFFER_TIME = 141;
00168 const FieldId FID_NAV = 142;
00169 const FieldId FID_NAV_TIME = 143;
00170 const FieldId FID_NAV_DATE = 144;
00171 const FieldId FID_WRAP = 145;
00172 const FieldId FID_WRAP_TIME = 146;
00173 const FieldId FID_WRAP_DATE = 147;
00174 const FieldId FID_52_WEEK_HIGH = 148;
00175 const FieldId FID_52_WEEK_HIGH_DATE = 149;
00176 const FieldId FID_52_WEEK_LOW = 150;
00177 const FieldId FID_52_WEEK_LOW_DATE = 151;
00178 const FieldId FID_YEAR_HIGH = 152;
00179 const FieldId FID_YEAR_HIGH_DATE = 153;
00180 const FieldId FID_YEAR_LOW = 154;
00181 const FieldId FID_YEAR_LOW_DATE = 155;
00182 const FieldId FID_LIFETIME_HIGH = 156;
00183 const FieldId FID_LIFETIME_HIGH_DATE = 157;
00184 const FieldId FID_LIFETIME_LOW = 158;
00185 const FieldId FID_LIFETIME_LOW_DATE = 159;
00186 const FieldId FID_SESSION_1_CLOSE = 160;
00187 const FieldId FID_SESSION_1_CLOSE_STATUS = 161;
00188 const FieldId FID_SESSION_1_CLOSE_TIME = 162;
00189 const FieldId FID_SESSION_1_CLOSE_CUMULATIVE_VALUE = 163;
00190 const FieldId FID_SESSION_1_CLOSE_CUMULATIVE_VALUE_STATUS = 164;
00191 const FieldId FID_SESSION_1_CLOSE_CUMULATIVE_VOLUME = 165;
00192 const FieldId FID_SESSION_1_CLOSE_CUMULATIVE_VOLUME_STATUS = 166;
00193 const FieldId FID_SESSION_1_CLOSING_ASK = 167;
00194 const FieldId FID_SESSION_1_CLOSING_BID = 168;
00195 const FieldId FID_SESSION_1_CURRENT_HIGH = 169;
00196 const FieldId FID_SESSION_1_CURRENT_HIGH_TIME = 170;
00197 const FieldId FID_SESSION_1_CURRENT_LOW = 171;
00198 const FieldId FID_SESSION_1_CURRENT_LOW_TIME = 172;
00199 const FieldId FID_SESSION_1_FIRST_TRADE = 173;
00200 const FieldId FID_SESSION_1_FIRST_TRADE_TIME = 174;
00201 const FieldId FID_SESSION_1_INDICATOR = 175;
00202 const FieldId FID_SESSION_1_OPEN = 176;
00203 const FieldId FID_SESSION_1_OPEN_TIME = 177;
00204 const FieldId FID_SESSION_1_TRADE_HIGH = 178;
00205 const FieldId FID_SESSION_1_TRADE_HIGH_TIME = 179;
00206 const FieldId FID_SESSION_1_TRADE_LOW = 180;
00207 const FieldId FID_SESSION_1_TRADE_LOW_TIME = 181;
00208 const FieldId FID_SESSION_2_CLOSE = 182;
00209 const FieldId FID_SESSION_2_CLOSE_STATUS = 183;
00210 const FieldId FID_SESSION_2_CLOSE_TIME = 184;
00211 const FieldId FID_SESSION_2_CLOSE_CUMULATIVE_VALUE = 185;
00212 const FieldId FID_SESSION_2_CLOSE_CUMULATIVE_VALUE_STATUS = 186;
00213 const FieldId FID_SESSION_2_CLOSE_CUMULATIVE_VOLUME = 187;
00214 const FieldId FID_SESSION_2_CLOSE_CUMULATIVE_VOLUME_STATUS = 188;
00215 const FieldId FID_SESSION_2_CLOSING_ASK = 189;
00216 const FieldId FID_SESSION_2_CLOSING_BID = 190;
00217 const FieldId FID_SESSION_2_CURRENT_HIGH = 191;
00218 const FieldId FID_SESSION_2_CURRENT_HIGH_TIME = 192;
00219 const FieldId FID_SESSION_2_CURRENT_LOW = 193;
00220 const FieldId FID_SESSION_2_CURRENT_LOW_TIME = 194;
00221 const FieldId FID_SESSION_2_FIRST_TRADE = 195;
00222 const FieldId FID_SESSION_2_FIRST_TRADE_TIME = 196;
00223 const FieldId FID_SESSION_2_INDICATOR = 197;
00224 const FieldId FID_SESSION_2_OPEN = 198;
00225 const FieldId FID_SESSION_2_OPEN_TIME = 199;
00226 const FieldId FID_SESSION_2_TRADE_HIGH = 200;
00227 const FieldId FID_SESSION_2_TRADE_HIGH_TIME = 201;
00228 const FieldId FID_SESSION_2_TRADE_LOW = 202;
00229 const FieldId FID_SESSION_2_TRADE_LOW_TIME = 203;
00230 const FieldId FID_SESSION_3_CLOSE = 204;
00231 const FieldId FID_SESSION_3_CLOSE_STATUS = 205;
00232 const FieldId FID_SESSION_3_CLOSE_TIME = 206;
00233 const FieldId FID_SESSION_3_CLOSE_CUMULATIVE_VALUE = 207;
00234 const FieldId FID_SESSION_3_CLOSE_CUMULATIVE_VALUE_STATUS = 208;
00235 const FieldId FID_SESSION_3_CLOSE_CUMULATIVE_VOLUME = 209;
00236 const FieldId FID_SESSION_3_CLOSE_CUMULATIVE_VOLUME_STATUS = 210;
00237 const FieldId FID_SESSION_3_CLOSING_ASK = 211;
00238 const FieldId FID_SESSION_3_CLOSING_BID = 212;
00239 const FieldId FID_SESSION_3_CURRENT_HIGH = 213;
00240 const FieldId FID_SESSION_3_CURRENT_HIGH_TIME = 214;
00241 const FieldId FID_SESSION_3_CURRENT_LOW = 215;
00242 const FieldId FID_SESSION_3_CURRENT_LOW_TIME = 216;
00243 const FieldId FID_SESSION_3_FIRST_TRADE = 217;
00244 const FieldId FID_SESSION_3_FIRST_TRADE_TIME = 218;
00245 const FieldId FID_SESSION_3_INDICATOR = 219;
00246 const FieldId FID_SESSION_3_OPEN = 220;
00247 const FieldId FID_SESSION_3_OPEN_TIME = 221;
00248 const FieldId FID_SESSION_3_TRADE_HIGH = 222;
00249 const FieldId FID_SESSION_3_TRADE_HIGH_TIME = 223;
00250 const FieldId FID_SESSION_3_TRADE_LOW = 224;
00251 const FieldId FID_SESSION_3_TRADE_LOW_TIME = 225;
00252 const FieldId FID_7_DAY_YIELD = 226;
00253 const FieldId FID_ACCRUED_INTEREST = 227;
00254 const FieldId FID_ADDITIONAL_PAID_IN_CAPITAL = 228;
00255 const FieldId FID_ANNUALIZED_7_DAY_YIELD = 229;
00256 const FieldId FID_ASSETS = 230;
00257 const FieldId FID_ATM_CALL_IMPLIED_VOLATILITY = 231;
00258 const FieldId FID_ATM_PUT_IMPLIED_VOLATILITY = 232;
00259 const FieldId FID_AVERAGE_MATURITY = 233;
00260 const FieldId FID_AVERAGE_VOLUME = 234;
00261 const FieldId FID_AVERAGE_VOLUME_100_DAY = 235;
00262 const FieldId FID_AVERAGE_VOLUME_22_DAY = 236;
00263 const FieldId FID_AVERAGE_VOLUME_250_DAY = 237;
00264 const FieldId FID_BETA = 238;
00265 const FieldId FID_CAP_GAINS_DATE = 239;
00266 const FieldId FID_CAP_GAINS_LONG = 240;
00267 const FieldId FID_CAP_GAINS_OTHER = 241;
00268 const FieldId FID_CAP_GAINS_SHORT = 242;
00269 const FieldId FID_CAPITAL_DISTRIBUTION = 243;
00270 const FieldId FID_CAPITAL_STOCK = 244;
00271 const FieldId FID_CASH_FROM_FINANCING = 245;
00272 const FieldId FID_CASH_FROM_INVESTMENTS = 246;
00273 const FieldId FID_CASH_FROM_OPERATIONS = 247;
00274 const FieldId FID_CASH_IN_LIEU_OF = 248;
00275 const FieldId FID_CASH_NET_CHANGE = 249;
00276 const FieldId FID_CASH_PER_CONTRACT = 250;
00277 const FieldId FID_CLOSING_PRICE_MONTH = 251;
00278 const FieldId FID_CLOSING_PRICE_QUARTER = 252;
00279 const FieldId FID_CLOSING_PRICE_WEEK = 253;
00280 const FieldId FID_CLOSING_PRICE_YEAR = 254;
00281 const FieldId FID_COMMENTS = 255;
00282 const FieldId FID_CONDITIONS = 256;
00283 const FieldId FID_CONTRACT_MULTIPLIER = 257;
00284 const FieldId FID_CONTRACT_TYPE = 258;
00285 const FieldId FID_COUNTRY_CODE = 259;
00286 const FieldId FID_CURRENCY = 260;
00287 const FieldId FID_CURRENT_ASSETS = 261;
00288 const FieldId FID_CURRENT_LIABILITIES = 262;
00289 const FieldId FID_CURRENT_YIELD = 263;
00290 const FieldId FID_DATE = 264;
00291 const FieldId FID_DECLARE_DATE = 265;
00292 const FieldId FID_DEPRECIATION_DEPLETION = 266;
00293 const FieldId FID_DESCRIPTION = 267;
00294 const FieldId FID_DISPLAY_DENOMINATOR = 268;
00295 const FieldId FID_DIVIDEND = 269;
00296 const FieldId FID_DIVIDEND_CURRENCY = 270;
00297 const FieldId FID_DIVIDEND_FREQUENCY_CODE = 271;
00298 const FieldId FID_DOWN = 272;
00299 const FieldId FID_EMPLOYEES = 273;
00300 const FieldId FID_ESTIMATED_CASH_AMOUNT_PER_UNIT = 274;
00301 const FieldId FID_ESTIMATED_LONG_TERM_RETURN = 275;
00302 const FieldId FID_EVENT_DATE = 276;
00303 const FieldId FID_EX_DATE = 277;
00304 const FieldId FID_EXCHANGE = 278;
00305 const FieldId FID_EXERCISE_STYLE = 279;
00306 const FieldId FID_EXPIRATION_DATE = 280;
00307 const FieldId FID_EXPIRATION_TIME = 281;
00308 const FieldId FID_FISCAL_YEAR_END = 282;
00309 const FieldId FID_FOOTNOTES = 283;
00310 const FieldId FID_GROSS_PROFITS = 284;
00311 const FieldId FID_HIGHEST_SPREAD = 285;
00312 const FieldId FID_INCOME_BEFORE_TAX = 286;
00313 const FieldId FID_INCOME_DISTRIBUTION = 287;
00314 const FieldId FID_INDICATED_ANNUAL_DIVIDEND = 288;
00315 const FieldId FID_INDUSTRY_CODE = 289;
00316 const FieldId FID_INSTITUTIONAL_SHAREHOLDERS = 290;
00317 const FieldId FID_INTEREST_EXPENSES = 291;
00318 const FieldId FID_INTEREST_INCOME = 292;
00319 const FieldId FID_ISIN = 293;
00320 const FieldId FID_ISSUER_NAME = 294;
00321 const FieldId FID_LAST_12_MONTHS_EARNINGS = 295;
00322 const FieldId FID_LAST_FISCAL_YEAR_EARNINGS = 296;
00323 const FieldId FID_LAST_QUARTER_DATE = 297;
00324 const FieldId FID_LAST_QUARTER_DATE_INCLUDED = 298;
00325 const FieldId FID_LAST_QUARTER_EARNINGS = 299;
00326 const FieldId FID_LAST_TRADING_DATE = 300;
00327 const FieldId FID_LOCAL_CODE = 301;
00328 const FieldId FID_LONG_TERM_DEBT = 302;
00329 const FieldId FID_LONG_TERM_INVESTMENTS = 303;
00330 const FieldId FID_LOWEST_SPREAD = 304;
00331 const FieldId FID_MOVING_AVERAGE_100_DAY = 305;
00332 const FieldId FID_MOVING_AVERAGE_14_DAY = 306;
00333 const FieldId FID_MOVING_AVERAGE_21_DAY = 307;
00334 const FieldId FID_MOVING_AVERAGE_250_DAY = 308;
00335 const FieldId FID_MOVING_AVERAGE_50_DAY = 309;
00336 const FieldId FID_MOVING_AVERAGE_9_DAY = 310;
00337 const FieldId FID_NAME = 311;
00338 const FieldId FID_NET_ACCRUED_DIVIDEND = 312;
00339 const FieldId FID_NET_INCOME = 313;
00340 const FieldId FID_NET_PROPERTY = 314;
00341 const FieldId FID_NEXT_DIVIDEND_1 = 315;
00342 const FieldId FID_NEXT_DIVIDEND_1_DATE = 316;
00343 const FieldId FID_NEXT_DIVIDEND_1_STATUS = 317;
00344 const FieldId FID_NEXT_DIVIDEND_2 = 318;
00345 const FieldId FID_NEXT_DIVIDEND_2_DATE = 319;
00346 const FieldId FID_NEXT_DIVIDEND_2_STATUS = 320;
00347 const FieldId FID_NEXT_DIVIDEND_3 = 321;
00348 const FieldId FID_NEXT_DIVIDEND_3_DATE = 322;
00349 const FieldId FID_NEXT_DIVIDEND_3_STATUS = 323;
00350 const FieldId FID_NEXT_DIVIDEND_4 = 324;
00351 const FieldId FID_NEXT_DIVIDEND_4_DATE = 325;
00352 const FieldId FID_NEXT_DIVIDEND_4_STATUS = 326;
00353 const FieldId FID_NEXT_QUARTER_DATE = 327;
00354 const FieldId FID_NUMBER_OF_QUARTERS_INCLUDED = 328;
00355 const FieldId FID_OPTION_TYPE = 329;
00356 const FieldId FID_OTHER_EXPENSES = 330;
00357 const FieldId FID_OTHER_INCOME = 331;
00358 const FieldId FID_PAR_VALUE_PER_UNIT = 332;
00359 const FieldId FID_PAYMENT_DATE = 333;
00360 const FieldId FID_PLANT_AND_EQUIPMENT = 334;
00361 const FieldId FID_PREVIOUS_12_MONTHS_EARNINGS_PER_SHARE = 335;
00362 const FieldId FID_PREVIOUS_7_QUARTERS_EARNINGS_PER_SHARE = 336;
00363 const FieldId FID_PREVIOUS_CURRENT_DATE = 337;
00364 const FieldId FID_PREVIOUS_DIVIDEND = 338;
00365 const FieldId FID_PREVIOUS_DIVIDEND_DATE = 339;
00366 const FieldId FID_PREVIOUS_FISCAL_YEAR_EARNINGS_PER_SHARE = 340;
00367 const FieldId FID_PRIMARY_EXCHANGE = 341;
00368 const FieldId FID_RATE_OF_RETURN_12MONTH = 342;
00369 const FieldId FID_RATE_OF_RETURN_YEAR = 343;
00370 const FieldId FID_RECORD_DATE = 344;
00371 const FieldId FID_RETAINED_EARNINGS = 345;
00372 const FieldId FID_RETURN_ON_CAPITAL = 346;
00373 const FieldId FID_REVENUES_FROM_SALES = 347;
00374 const FieldId FID_SELLING_AND_GENERAL_ADMIN_EXPENSES = 348;
00375 const FieldId FID_SESSION_ID = 349;
00376 const FieldId FID_SHAREHOLDERS = 350;
00377 const FieldId FID_SHARES_AFTER = 351;
00378 const FieldId FID_SHARES_BEFORE = 352;
00379 const FieldId FID_SHARES_HELD_BY_INSTITUTIONS = 353;
00380 const FieldId FID_SHARES_OUTSTANDING = 354;
00381 const FieldId FID_SHARES_PER_CONTRACT = 355;
00382 const FieldId FID_SIC_CODE = 356;
00383 const FieldId FID_SPECIAL_DIVIDEND = 357;
00384 const FieldId FID_SPECIAL_DIVIDEND_DATE = 358;
00385 const FieldId FID_SPLIT_DATE = 359;
00386 const FieldId FID_SPLIT_RATIO = 360;
00387 const FieldId FID_STATE = 361;
00388 const FieldId FID_STRIKE_PRICE = 362;
00389 const FieldId FID_TICK_COUNT = 363;
00390 const FieldId FID_TICK_PRICE = 364;
00391 const FieldId FID_TICK_SIZE = 365;
00392 const FieldId FID_TICK_TYPE = 366;
00393 const FieldId FID_TIME = 367;
00394 const FieldId FID_TOTAL_ASSETS = 368;
00395 const FieldId FID_TOTAL_CASH = 369;
00396 const FieldId FID_TOTAL_CASH_AMOUNT_PER_UNIT = 370;
00397 const FieldId FID_UNALLOCATED = 371;
00398 const FieldId FID_UNCHANGED = 372;
00399 const FieldId FID_UP = 373;
00400 const FieldId FID_VENDOR_CODE = 374;
00401 const FieldId FID_VOLATILITY_01_MONTH = 375;
00402 const FieldId FID_VOLATILITY_02_MONTH = 376;
00403 const FieldId FID_VOLATILITY_03_MONTH = 377;
00404 const FieldId FID_VOLATILITY_04_MONTH = 378;
00405 const FieldId FID_VOLATILITY_05_MONTH = 379;
00406 const FieldId FID_VOLATILITY_06_MONTH = 380;
00407 const FieldId FID_VOLATILITY_07_MONTH = 381;
00408 const FieldId FID_VOLATILITY_08_MONTH = 382;
00409 const FieldId FID_VOLATILITY_09_MONTH = 383;
00410 const FieldId FID_VOLATILITY_10_MONTH = 384;
00411 const FieldId FID_VOLATILITY_11_MONTH = 385;
00412 const FieldId FID_VOLATILITY_12_MONTH = 386;
00413 const FieldId FID_VOLATILITY_20_DAY = 387;
00414 const FieldId FID_WEIGHT = 388;
00415 const FieldId FID_YEAR_END_DATE = 389;
00416 const FieldId FID_COMPANY_SYMBOL = 390;
00417 const FieldId FID_COMPANY_TABLE_NO = 391;
00418 const FieldId FID_CONSTITUENT_SYMBOL = 392;
00419 const FieldId FID_CONSTITUENT_TABLE_NO = 393;
00420 const FieldId FID_CONTEXT = 394;
00421 const FieldId FID_CREATE_DATE = 395;
00422 const FieldId FID_CUG_ID = 396;
00423 const FieldId FID_DELAY_PERIOD = 397;
00424 const FieldId FID_ENTITY_TYPE = 398;
00425 const FieldId FID_EVENT_TYPE = 399;
00426 const FieldId FID_FIELD_ID = 400;
00427 const FieldId FID_FIELD_LENGTH = 401;
00428 const FieldId FID_FIELD_ORDER = 402;
00429 const FieldId FID_FIELD_TYPE = 403;
00430 const FieldId FID_FUTURE_OPTION_ROOT_SYMBOL = 404;
00431 const FieldId FID_FUTURE_OPTION_ROOT_TABLE_NO = 405;
00432 const FieldId FID_FUTURE_ROOT_SYMBOL = 406;
00433 const FieldId FID_FUTURE_ROOT_TABLE_NO = 407;
00434 const FieldId FID_INDEX_NUMBER = 408;
00435 const FieldId FID_INDEX_PROPERTIES = 409;
00436 const FieldId FID_INDEX_SYMBOL = 410;
00437 const FieldId FID_INDEX_TABLE_NO = 411;
00438 const FieldId FID_INDEX_TYPE = 412;
00439 const FieldId FID_LAST_UPDATE_DATE = 413;
00440 const FieldId FID_LAST_UPDATE_TIME = 414;
00441 const FieldId FID_LISTING_SYMBOL = 415;
00442 const FieldId FID_LISTING_SYMBOL_LIST = 416;
00443 const FieldId FID_LISTING_TABLE_NO = 417;
00444 const FieldId FID_MESSAGE_TYPE = 418;
00445 const FieldId FID_NAVIGATION_INDEX_NO = 419;
00446 const FieldId FID_NAVIGATION_SOURCE_KEY_FIELD_ID = 420;
00447 const FieldId FID_NAVIGATION_TABLE_NO = 421;
00448 const FieldId FID_NEW_DESCRIPTION = 422;
00449 const FieldId FID_NEW_ISIN = 423;
00450 const FieldId FID_NEW_LISTING_PERMISSION_ID = 424;
00451 const FieldId FID_NEW_LISTING_SYMBOL_LIST = 425;
00452 const FieldId FID_NEW_SECURITY_SYMBOL = 426;
00453 const FieldId FID_OLD_DESCRIPTION = 427;
00454 const FieldId FID_OLD_ISIN = 428;
00455 const FieldId FID_OLD_LISTING_PERMISSION_ID = 429;
00456 const FieldId FID_OLD_LISTING_SYMBOL_LIST = 430;
00457 const FieldId FID_OLD_SECURITY_SYMBOL = 431;
00458 const FieldId FID_OPTION_DELIVERABLE_SYMBOL = 432;
00459 const FieldId FID_OPTION_DELIVERABLE_TABLE_NO = 433;
00460 const FieldId FID_OPTION_ROOT_SYMBOL = 434;
00461 const FieldId FID_OPTION_ROOT_TABLE_NO = 435;
00462 const FieldId FID_NAVIGATION_TARGET_KEY_FIELD_ID = 436;
00463 const FieldId FID_NAVIGATION_TARGET_PERMISSION_ID_FIELD_ID = 437;
00464 const FieldId FID_NAVIGATION_TARGET_TABLE_NO_FIELD_ID = 438;
00465 const FieldId FID_PASSWORD = 439;
00466 const FieldId FID_PERMISSION_BODY = 440;
00467 const FieldId FID_PERMISSION_ID = 441;
00468 const FieldId FID_PERMISSION_ID_0 = 442;
00469 const FieldId FID_PERMISSION_ID_1 = 443;
00470 const FieldId FID_PERMISSION_LEVEL_ID = 444;
00471 const FieldId FID_PREVIOUS_SYMBOL = 445;
00472 const FieldId FID_PROVIDER_NAME = 446;
00473 const FieldId FID_RECORD_STATUS = 447;
00474 const FieldId FID_RELATIONSHIP_ID = 448;
00475 const FieldId FID_RESET_DATE = 449;
00476 const FieldId FID_RESET_TIME = 450;
00477 const FieldId FID_SECTOR_SYMBOL = 451;
00478 const FieldId FID_SECTOR_TABLE_NO = 452;
00479 const FieldId FID_SECURITY_SYMBOL = 453;
00480 const FieldId FID_SECURITY_TABLE_NO = 454;
00481 const FieldId FID_SOURCE_CONTEXT = 455;
00482 const FieldId FID_SYMBOL = 456;
00483 const FieldId FID_SYMBOL01 = 457;
00484 const FieldId FID_SYMBOL02 = 458;
00485 const FieldId FID_SYMBOL03 = 459;
00486 const FieldId FID_SYMBOL04 = 460;
00487 const FieldId FID_SYMBOL05 = 461;
00488 const FieldId FID_SYMBOL06 = 462;
00489 const FieldId FID_SYMBOL07 = 463;
00490 const FieldId FID_SYMBOL08 = 464;
00491 const FieldId FID_SYMBOL09 = 465;
00492 const FieldId FID_SYMBOL10 = 466;
00493 const FieldId FID_SYMBOL11 = 467;
00494 const FieldId FID_SYMBOL12 = 468;
00495 const FieldId FID_SYMBOL13 = 469;
00496 const FieldId FID_SYMBOL14 = 470;
00497 const FieldId FID_SYMBOL15 = 471;
00498 const FieldId FID_SYMBOL16 = 472;
00499 const FieldId FID_SYMBOL17 = 473;
00500 const FieldId FID_SYMBOL18 = 474;
00501 const FieldId FID_SYMBOL19 = 475;
00502 const FieldId FID_SYMBOL20 = 476;
00503 const FieldId FID_TABLE_ID = 477;
00504 const FieldId FID_TABLE_NO = 478;
00505 const FieldId FID_TABLE_TYPE = 479;
00506 const FieldId FID_TABLE_VERSION = 480;
00507 const FieldId FID_UNDERLYING_SYMBOL = 481;
00508 const FieldId FID_UNDERLYING_TABLE_NO = 482;
00509 const FieldId FID_UPDATE_ID = 483;
00510 const FieldId FID_USER_BODY = 484;
00511 const FieldId FID_USER_ID = 485;
00512 const FieldId FID_USERNAME = 486;
00513 const FieldId FID_LIMIT_HIGH_PRICE = 487;
00514 const FieldId FID_LIMIT_LOW_PRICE = 488;
00515 const FieldId FID_CURRENT_YIELD_TIME = 489;
00516 const FieldId FID_CURRENT_YIELD_DATE = 490;
00517 const FieldId FID_DIVIDEND_REINVEST_PRICE = 491;
00518 const FieldId FID_CAP_GAINS_REINVEST_PRICE = 492;
00519 const FieldId FID_DIVIDEND_REINVEST_PRICE_DATE = 493;
00520 const FieldId FID_CAP_GAINS_REINVEST_PRICE_DATE = 494;
00521 const FieldId FID_NAV_HIGH = 495;
00522 const FieldId FID_NAV_HIGH_TIME = 496;
00523 const FieldId FID_NAV_LOW = 497;
00524 const FieldId FID_NAV_LOW_TIME = 498;
00525 const FieldId FID_GENERAL_BUSINESS_EXPENSES_PLUS_COMMISSIONS = 499;
00526 const FieldId FID_INTEREST_REVENUE = 500;
00527 const FieldId FID_INVESTMENT_SECURITIES = 501;
00528 const FieldId FID_NET_INTEREST_INCOME = 502;
00529 const FieldId FID_NET_PROPERTY_PLANT_AND_EQUIPMENT = 503;
00530 const FieldId FID_NON_INTEREST_EXPENSES = 504;
00531 const FieldId FID_PAR_VALUE_OF_COMMON_STOCK = 505;
00532 const FieldId FID_PREMIUMS_EARNED = 506;
00533 const FieldId FID_PREMIUMS_EARNED_LESS_EXPENSES = 507;
00534 const FieldId FID_SECURITIES = 508;
00535 const FieldId FID_TOTAL_INTEREST_INCOME = 509;
00536 const FieldId FID_TOTAL_INVESTED_ASSETS = 510;
00537 const FieldId FID_TOTAL_NON_INTEREST_INCOME = 511;
00538 const FieldId FID_TOTAL_NON_PREMIUM_INCOME = 512;
00539 const FieldId FID_PREVIOUS_SETTLEMENT = 513;
00540 const FieldId FID_7_DAY_YIELD_DATE = 514;
00541 const FieldId FID_ANNUALIZED_7_DAY_YIELD_DATE = 515;
00542 const FieldId FID_PREVIOUS_CUMULATIVE_PRICE = 516;
00543 const FieldId FID_EX_MARKER = 517;
00544 const FieldId FID_NEW_SYMBOL_LIST = 518;
00545 const FieldId FID_OLD_SYMBOL_LIST = 519;
00546 const FieldId FID_COMPOSITE_EXCHANGE = 520;
00547 const FieldId FID_ANALYTICS_SYMBOL = 521;
00548 const FieldId FID_ANALYTICS_TABLE_NO = 522;
00549 const FieldId FID_STORY_DATE_TIME = 523;
00550 const FieldId FID_HEADLINE = 524;
00551 const FieldId FID_STORY_BODY = 525;
00552 const FieldId FID_REPORT_DATE = 526;
00553 const FieldId FID_INCOME_FROM_CONTINUING_OPERATIONS = 527;
00554 const FieldId FID_ANNUAL_REVENUES_FROM_SALES = 528;
00555 const FieldId FID_ANNUAL_GROSS_PROFITS = 529;
00556 const FieldId FID_ANNUAL_SELLING_AND_GENERAL_ADMIN_EXPENSE = 530;
00557 const FieldId FID_ANNUAL_DEPRECIATION_DEPLETION = 531;
00558 const FieldId FID_ANNUAL_INTEREST_EXPENSE = 532;
00559 const FieldId FID_ANNUAL_INCOME_BEFORE_TAX = 533;
00560 const FieldId FID_ANNUAL_INCOME_FROM_CONTINUING_OPERATIONS = 534;
00561 const FieldId FID_ANNUAL_NET_INCOME = 535;
00562 const FieldId FID_ANNUAL_CURRENT_ASSETS = 536;
00563 const FieldId FID_ANNUAL_NET_PROPERTY_PLANT_AND_EQUIPMENT = 537;
00564 const FieldId FID_ANNUAL_TOTAL_ASSETS = 538;
00565 const FieldId FID_ANNUAL_CURRENT_LIABILITIES = 539;
00566 const FieldId FID_ANNUAL_TOTAL_LIABILITIES = 540;
00567 const FieldId FID_ANNUAL_LONG_TERM_DEBT = 541;
00568 const FieldId FID_ANNUAL_CAPITAL_STOCK = 542;
00569 const FieldId FID_ANNUAL_ADDITIONAL_PAID_IN_CAPITAL = 543;
00570 const FieldId FID_ANNUAL_RETAINED_EARNINGS = 544;
00571 const FieldId FID_TOTAL_LIABILITIES = 545;
00572 const FieldId FID_INDICATED_YIELD = 546;
00573 const FieldId FID_PARTICIPANT = 547;
00574 const FieldId FID_TIME_SERIES_TYPE = 548;
00575 const FieldId FID_DATE_TIME = 549;
00576 const FieldId FID_TIME_SERIES_SYMBOL = 550;
00577 const FieldId FID_TIME_SERIES_TABLE_NO = 551;
00578 const FieldId FID_SOURCE_PERMISSION_ID = 552;
00579 const FieldId FID_NUMBER_OF_CONCURRENT_USERS = 553;
00580 const FieldId FID_TARGET_SYMBOL = 554;
00581 const FieldId FID_TARGET_TABLE_NO = 555;
00582 const FieldId FID_PRICE_ADJUSTMENT = 556;
00583 const FieldId FID_COMPOSITE_FLAG = 557;
00584 const FieldId FID_SYMBOL_LIST = 558;
00585 const FieldId FID_EXPIRATION_DATE_01 = 559;
00586 const FieldId FID_EXPIRATION_DATE_02 = 560;
00587 const FieldId FID_EXPIRATION_DATE_03 = 561;
00588 const FieldId FID_EXPIRATION_DATE_04 = 562;
00589 const FieldId FID_EXPIRATION_DATE_05 = 563;
00590 const FieldId FID_EXPIRATION_DATE_06 = 564;
00591 const FieldId FID_EXPIRATION_DATE_07 = 565;
00592 const FieldId FID_EXPIRATION_DATE_08 = 566;
00593 const FieldId FID_EXPIRATION_DATE_09 = 567;
00594 const FieldId FID_EXPIRATION_DATE_10 = 568;
00595 const FieldId FID_EXPIRATION_DATE_11 = 569;
00596 const FieldId FID_EXPIRATION_DATE_12 = 570;
00597 const FieldId FID_STRIKE_PRICE_01 = 571;
00598 const FieldId FID_STRIKE_PRICE_02 = 572;
00599 const FieldId FID_STRIKE_PRICE_03 = 573;
00600 const FieldId FID_STRIKE_PRICE_04 = 574;
00601 const FieldId FID_STRIKE_PRICE_05 = 575;
00602 const FieldId FID_STRIKE_PRICE_06 = 576;
00603 const FieldId FID_STRIKE_PRICE_07 = 577;
00604 const FieldId FID_STRIKE_PRICE_08 = 578;
00605 const FieldId FID_STRIKE_PRICE_09 = 579;
00606 const FieldId FID_STRIKE_PRICE_10 = 580;
00607 const FieldId FID_STRIKE_PRICE_11 = 581;
00608 const FieldId FID_STRIKE_PRICE_12 = 582;
00609 const FieldId FID_STRIKE_PRICE_13 = 583;
00610 const FieldId FID_STRIKE_PRICE_14 = 584;
00611 const FieldId FID_STRIKE_PRICE_15 = 585;
00612 const FieldId FID_STRIKE_PRICE_16 = 586;
00613 const FieldId FID_STRIKE_PRICE_17 = 587;
00614 const FieldId FID_STRIKE_PRICE_18 = 588;
00615 const FieldId FID_STRIKE_PRICE_19 = 589;
00616 const FieldId FID_STRIKE_PRICE_20 = 590;
00617 const FieldId FID_STRIKE_PRICE_21 = 591;
00618 const FieldId FID_STRIKE_PRICE_22 = 592;
00619 const FieldId FID_STRIKE_PRICE_23 = 593;
00620 const FieldId FID_STRIKE_PRICE_24 = 594;
00621 const FieldId FID_STRIKE_PRICE_25 = 595;
00622 const FieldId FID_STRIKE_PRICE_26 = 596;
00623 const FieldId FID_CONTRACT_SIZE = 597;
00624 const FieldId FID_LOCAL_EXCHANGE = 598;
00625 const FieldId FID_LOCAL_CALL_ROOT = 599;
00626 const FieldId FID_LOCAL_PUT_ROOT = 600;
00627 const FieldId FID_LOCAL_ROOT = 601;
00628 const FieldId FID_MINIMUM_TICK = 602;
00629 const FieldId FID_TRADING_DAY_START_TIME = 603;
00630 const FieldId FID_TRADING_DAY_END_TIME = 604;
00631 const FieldId FID_TRADING_DAYS_OF_WEEK = 605;
00632 const FieldId FID_UNIT_OF_MEASURE = 606;
00633 const FieldId FID_FUTURE_SYMBOL = 607;
00634 const FieldId FID_FUTURE_TABLE_NO = 608;
00635 const FieldId FID_FUTURE_OPTION_SYMBOL = 609;
00636 const FieldId FID_FUTURE_OPTION_TABLE_NO = 610;
00637 const FieldId FID_FUTURE_OPTION_EXPIRATION_SYMBOL = 611;
00638 const FieldId FID_FUTURE_OPTION_EXPIRATION_TABLE_NO = 612;
00639 const FieldId FID_HAS_DELIVERABLES = 613;
00640 const FieldId FID_CATEGORY_CODE_LIST = 614;
00641 const FieldId FID_UNIT_OF_MEASURE_CURRENCY = 615;
00642 const FieldId FID_VOLUME_WEIGHTED_OPENING_PRICE = 616;
00643 const FieldId FID_CONTRIBUTOR = 617;
00644 const FieldId FID_BID6 = 618;
00645 const FieldId FID_BID6_COUNT = 619;
00646 const FieldId FID_BID6_SIZE = 620;
00647 const FieldId FID_ASK6 = 621;
00648 const FieldId FID_ASK6_COUNT = 622;
00649 const FieldId FID_ASK6_SIZE = 623;
00650 const FieldId FID_BID7 = 624;
00651 const FieldId FID_BID7_COUNT = 625;
00652 const FieldId FID_BID7_SIZE = 626;
00653 const FieldId FID_ASK7 = 627;
00654 const FieldId FID_ASK7_COUNT = 628;
00655 const FieldId FID_ASK7_SIZE = 629;
00656 const FieldId FID_BID8 = 630;
00657 const FieldId FID_BID8_COUNT = 631;
00658 const FieldId FID_BID8_SIZE = 632;
00659 const FieldId FID_ASK8 = 633;
00660 const FieldId FID_ASK8_COUNT = 634;
00661 const FieldId FID_ASK8_SIZE = 635;
00662 const FieldId FID_BID9 = 636;
00663 const FieldId FID_BID9_COUNT = 637;
00664 const FieldId FID_BID9_SIZE = 638;
00665 const FieldId FID_ASK9 = 639;
00666 const FieldId FID_ASK9_COUNT = 640;
00667 const FieldId FID_ASK9_SIZE = 641;
00668 const FieldId FID_BID10 = 642;
00669 const FieldId FID_BID10_COUNT = 643;
00670 const FieldId FID_BID10_SIZE = 644;
00671 const FieldId FID_ASK10 = 645;
00672 const FieldId FID_ASK10_COUNT = 646;
00673 const FieldId FID_ASK10_SIZE = 647;
00674 const FieldId FID_PE_RATIO = 648;
00675 const FieldId FID_PERMISSION_ID_LIST = 649;
00676 const FieldId FID_NEWS_MARKER = 650;
00677 const FieldId FID_NEWS_COUNT = 651;
00678 const FieldId FID_PREVIOUS_BID = 652;
00679 const FieldId FID_PREVIOUS_ASK = 653;
00680 const FieldId FID_PREVIOUS_QUOTE_DATE = 654;
00681 const FieldId FID_PREVIOUS_CLOSE_DATE = 655;
00682 const FieldId FID_PREVIOUS_SETTLEMENT_DATE = 656;
00683 const FieldId FID_PREVIOUS_CUMULATIVE_VALUE = 657;
00684 const FieldId FID_PREVIOUS_CUMULATIVE_VOLUME = 658;
00685 const FieldId FID_PREVIOUS_CUMULATIVE_VOLUME_DATE = 659;
00686 const FieldId FID_MARKET_MAKER_ID = 660;
00687 const FieldId FID_USER_TYPE = 661;
00688 const FieldId FID_USER_SCOPE = 662;
00689 const FieldId FID_VOLATILITY_10_DAY = 663;
00690 const FieldId FID_VOLATILITY_30_DAY = 664;
00691 const FieldId FID_VOLATILITY_60_DAY = 665;
00692 const FieldId FID_VOLATILITY_90_DAY = 666;
00693 const FieldId FID_VOLATILITY_120_DAY = 667;
00694 const FieldId FID_VOLATILITY_150_DAY = 668;
00695 const FieldId FID_VOLATILITY_180_DAY = 669;
00696 const FieldId FID_START_DATE = 670;
00697 const FieldId FID_UTC_OFFSET = 671;
00698 const FieldId FID_EXCHANGE_HOLIDAY_LIST = 672;
00699 const FieldId FID_IMBALANCE_BUY_VOLUME = 673;
00700 const FieldId FID_IMBALANCE_SELL_VOLUME = 674;
00701 const FieldId FID_IMBALANCE_VOLUME_TIME = 675;
00702 const FieldId FID_HIGH_INDICATION_PRICE = 676;
00703 const FieldId FID_LOW_INDICATION_PRICE = 677;
00704 const FieldId FID_INDICATION_PRICE_TIME = 678;
00705 const FieldId FID_TICK_UP = 679;
00706 const FieldId FID_TICK_DOWN = 680;
00707 const FieldId FID_TICK_UNCHANGED = 681;
00708 const FieldId FID_DAY_UP = 682;
00709 const FieldId FID_DAY_DOWN = 683;
00710 const FieldId FID_DAY_UNCHANGED = 684;
00711 const FieldId FID_SETTLEMENT_ALLOCATION = 685;
00712 const FieldId FID_DST_OFFSET = 686;
00713 const FieldId FID_SETTLEMENT_TYPE = 687;
00714 const FieldId FID_FINANCIAL_STATUS = 688;
00715 const FieldId FID_ORDER_COUNT = 689;
00716 const FieldId FID_NEXT_DIVIDEND_1_DECLARE_DATE = 690;
00717 const FieldId FID_NEXT_DIVIDEND_1_PAYMENT_DATE = 691;
00718 const FieldId FID_NEXT_DIVIDEND_1_RECORD_DATE = 692;
00719 const FieldId FID_TRADE_BUYER_ID = 693;
00720 const FieldId FID_TRADE_SELLER_ID = 694;
00721 const FieldId FID_FUNDAMENTAL_SYMBOL = 695;
00722 const FieldId FID_FUNDAMENTAL_TABLE_NO = 696;
00723 const FieldId FID_30_WEEK_MOVING_AVERAGE = 697;
00724 const FieldId FID_5_DAY_MOVING_AVERAGE = 698;
00725 const FieldId FID_5_YEAR_ANNUAL_REVENUE_GROWTH_RATE = 699;
00726 const FieldId FID_5_YEAR_AVERAGE_PE = 700;
00727 const FieldId FID_5_YEAR_HIGH_PRICE = 701;
00728 const FieldId FID_5_YEAR_LOW_PRICE = 702;
00729 const FieldId FID_ANNUAL_BASIC_NORMALIZED_NET_INCOME_PER_SHARE = 703;
00730 const FieldId FID_ANNUAL_CASH_AND_EQUIVALENTS = 704;
00731 const FieldId FID_ANNUAL_COMMON_PAR = 705;
00732 const FieldId FID_ANNUAL_DIVIDENDS_PAID_PER_SHARE = 706;
00733 const FieldId FID_ANNUAL_INTEREST_INCOME = 707;
00734 const FieldId FID_ANNUAL_NET_CASH_FROM_FINANCING_ACTIVITIES = 708;
00735 const FieldId FID_ANNUAL_NET_CASH_FROM_INVESTMENTS = 709;
00736 const FieldId FID_ANNUAL_NET_CASH_FROM_OPERATIONS = 710;
00737 const FieldId FID_ANNUAL_NET_CASH_NET_CHANGE_AND_CASH_EQUIVELENTS = 711;
00738 const FieldId FID_ANNUAL_NET_FIXED_ASSETS = 712;
00739 const FieldId FID_ANNUAL_NORMALIZED_CLOSE_PE_RATIO = 713;
00740 const FieldId FID_ANNUAL_NORMALIZED_HIGH_PE_RATIO = 714;
00741 const FieldId FID_ANNUAL_NORMALIZED_LOW_PE_RATIO = 715;
00742 const FieldId FID_ANNUAL_NUMBER_OF_MONTHS_SINCE_LAST_REPORTING_PERIOD = 716;
00743 const FieldId FID_ANNUAL_OTHER_INCOME = 717;
00744 const FieldId FID_ANNUAL_OTHER_NON_CURRENT_ASSETS = 718;
00745 const FieldId FID_ANNUAL_PREFERRED_STOCK_EQUITY = 719;
00746 const FieldId FID_AVERAGE_DAILY_VOLUME_LAST_10_DAYS = 720;
00747 const FieldId FID_AVERAGE_DAILY_VOLUME_LAST_52_WEEKS = 721;
00748 const FieldId FID_BASIC_EPS_TOTAL = 722;
00749 const FieldId FID_BASIC_NORMALIZED_NET_INCOME_PER_SHARE = 723;
00750 const FieldId FID_CASH_AND_EQUIVALENTS = 724;
00751 const FieldId FID_COMMON_PAR = 725;
00752 const FieldId FID_CURRENT_MARKET_VALUE = 726;
00753 const FieldId FID_CURRENT_PE_RATIO = 727;
00754 const FieldId FID_DIVIDEND_YIELD_5_YEAR_AVERAGE = 728;
00755 const FieldId FID_DIVIDENDS_PAID_PER_SHARE = 729;
00756 const FieldId FID_DOLLAR_CHANGE_IN_12_MONTHS_EPS_VS_1_YEAR_AGO = 730;
00757 const FieldId FID_INTERIM_ENDING_DATE = 731;
00758 const FieldId FID_LATEST_REPORTED_SHARES_OUTSTANDING = 732;
00759 const FieldId FID_MARKET_VALUE_AS_A_PERCENT_OF_REVENUES = 733;
00760 const FieldId FID_NET_CASH_FROM_FINANCING_ACTIVITIES = 734;
00761 const FieldId FID_NET_CASH_FROM_INVESTMENTS = 735;
00762 const FieldId FID_NET_CASH_FROM_OPERATIONS = 736;
00763 const FieldId FID_NET_CASH_NET_CHANGE_AND_CASH_EQUIVELENTS = 737;
00764 const FieldId FID_NET_FIXED_ASSETS = 738;
00765 const FieldId FID_NORMALIZED_CLOSE_PE_RATIO = 739;
00766 const FieldId FID_NORMALIZED_HIGH_PE_RATIO = 740;
00767 const FieldId FID_NORMALIZED_LOW_PE_RATIO = 741;
00768 const FieldId FID_NUMBER_OF_MONTHS_SINCE_LAST_REPORTING_PERIOD = 742;
00769 const FieldId FID_OTHER_NON_CURRENT_ASSETS = 743;
00770 const FieldId FID_PREFERRED_STOCK_EQUITY = 744;
00771 const FieldId FID_PE_RATIO_1_MONTH_AGO = 745;
00772 const FieldId FID_PE_RATIO_52_WEEKS_AGO = 746;
00773 const FieldId FID_QUARTERLY_INDICATOR = 747;
00774 const FieldId FID_PRE_POST_MARKET_CUMULATIVE_VALUE = 748;
00775 const FieldId FID_MAGAZINE = 749;
00776 const FieldId FID_SUPPLIER = 750;
00777 const FieldId FID_NEXT_SPECIAL_DIVIDEND_1 = 751;
00778 const FieldId FID_NEXT_SPECIAL_DIVIDEND_1_DATE = 752;
00779 const FieldId FID_EXPIRATION_TYPE = 753;
00780 const FieldId FID_VWAP_CUMULATIVE_VALUE = 754;
00781 const FieldId FID_VWAP_CUMULATIVE_VOLUME = 755;
00782 const FieldId FID_SEQUENCE_NUMBER = 756;
00783 const FieldId FID_RELATIONSHIP_TYPE = 757;
00784 const FieldId FID_OPTION_PATTERN_SYMBOL = 758;
00785 const FieldId FID_OPTION_PATTERN_TABLE_NO = 759;
00786 const FieldId FID_SHOULD_WATCH = 760;
00787 const FieldId FID_LANGUAGE = 761;
00788 const FieldId FID_CHARACTER_SET = 762;
00789 const FieldId FID_NEWS_STATE = 763;
00790 const FieldId FID_NEXT_NEWS_SYMBOL = 764;
00791 const FieldId FID_PREVIOUS_NEWS_SYMBOL = 765;
00792 const FieldId FID_FEED_LATENCY = 766;
00793 const FieldId FID_SYSTEM_LATENCY = 767;
00794 const FieldId FID_SYSTEM_TIMESTAMP = 768;
00795 const FieldId FID_FUTURE_OPTION_PATTERN_SYMBOL = 769;
00796 const FieldId FID_FUTURE_OPTION_PATTERN_TABLE_NO = 770;
00797 const FieldId FID_FUTURE_PATTERN_SYMBOL = 771;
00798 const FieldId FID_FUTURE_PATTERN_TABLE_NO = 772;
00799 const FieldId FID_EXCHANGE_CODE_LIST = 773;
00800 const FieldId FID_TABLE_NUMBER_LIST = 774;
00801 const FieldId FID_MAXIMUM_MESSAGE_RATE = 775;
00802 const FieldId FID_LAST_REPORTED_TRADE = 776;
00803 const FieldId FID_LAST_REPORTED_TRADE_SIZE = 777;
00804 const FieldId FID_LAST_REPORTED_TRADE_CONDITION = 778;
00805 const FieldId FID_LAST_REPORTED_TRADE_TIME = 779;
00806 const FieldId FID_LAST_REPORTED_TRADE_DATE = 780;
00807 const FieldId FID_LAST_REPORTED_TRADE_EXCHANGE = 781;
00808 const FieldId FID_SUBSCRIPTION_QUOTA = 782;
00809 const FieldId FID_STRIKE_PRICE_DENOMINATOR = 783;
00810 const FieldId FID_FUND_CODE = 784;
00811 const FieldId FID_MARKET_TIER = 785;
00812 const FieldId FID_CREATE_TIME = 786;
00813 const FieldId FID_SPLIT_TYPE = 787;
00814 const FieldId FID_SERVER_ID_LIST = 788;
00815 const FieldId FID_VERSION = 789;
00816 const FieldId FID_BBO_DEPTH_SYMBOL = 790;
00817 const FieldId FID_BBO_DEPTH_TABLE_NO = 791;
00818 const FieldId FID_POINT_SIZE = 792;
00819 const FieldId FID_LOT_SIZE = 793;
00820 const FieldId FID_VOLATILITY_360_DAY = 794;
00821 const FieldId FID_INDICATIVE_BID = 795;
00822 const FieldId FID_INDICATIVE_BID_SIZE = 796;
00823 const FieldId FID_INDICATIVE_BID_TIME = 797;
00824 const FieldId FID_INDICATIVE_ASK = 798;
00825 const FieldId FID_INDICATIVE_ASK_SIZE = 799;
00826 const FieldId FID_INDICATIVE_ASK_TIME = 800;
00827 const FieldId FID_INDICATIVE_QUOTE_DATE = 801;
00828 const FieldId FID_NAVIGATION_SOURCE_TABLE_NO_FIELD_ID = 802;
00829 const FieldId FID_OLD_COMPANY_NAME = 803;
00830 const FieldId FID_NEW_COMPANY_NAME = 804;
00831 const FieldId FID_TRADE_THROUGH_EXEMPT_FLAG = 805;
00832 const FieldId FID_TRADE_REPORTING_EXCHANGE = 806;
00833 const FieldId FID_BID_MARKET_MAKER_ID = 807;
00834 const FieldId FID_ASK_MARKET_MAKER_ID = 808;
00835 const FieldId FID_LAST_REPORTED_TRADE_THROUGH_EXEMPT_FLAG = 809;
00836 const FieldId FID_LAST_REPORTED_TRADE_REPORTING_EXCHANGE = 810;
00837 const FieldId FID_BID1_CONDITION = 811;
00838 const FieldId FID_ASK1_CONDITION = 812;
00839 const FieldId FID_BID2_CONDITION = 813;
00840 const FieldId FID_BID2_TIME = 814;
00841 const FieldId FID_ASK2_CONDITION = 815;
00842 const FieldId FID_ASK2_TIME = 816;
00843 const FieldId FID_BID3_CONDITION = 817;
00844 const FieldId FID_BID3_TIME = 818;
00845 const FieldId FID_ASK3_CONDITION = 819;
00846 const FieldId FID_ASK3_TIME = 820;
00847 const FieldId FID_BID4_CONDITION = 821;
00848 const FieldId FID_BID4_TIME = 822;
00849 const FieldId FID_ASK4_CONDITION = 823;
00850 const FieldId FID_ASK4_TIME = 824;
00851 const FieldId FID_BID5_CONDITION = 825;
00852 const FieldId FID_BID5_TIME = 826;
00853 const FieldId FID_ASK5_CONDITION = 827;
00854 const FieldId FID_ASK5_TIME = 828;
00855 const FieldId FID_BID6_CONDITION = 829;
00856 const FieldId FID_BID6_TIME = 830;
00857 const FieldId FID_ASK6_CONDITION = 831;
00858 const FieldId FID_ASK6_TIME = 832;
00859 const FieldId FID_BID7_CONDITION = 833;
00860 const FieldId FID_BID7_TIME = 834;
00861 const FieldId FID_ASK7_CONDITION = 835;
00862 const FieldId FID_ASK7_TIME = 836;
00863 const FieldId FID_BID8_CONDITION = 837;
00864 const FieldId FID_BID8_TIME = 838;
00865 const FieldId FID_ASK8_CONDITION = 839;
00866 const FieldId FID_ASK8_TIME = 840;
00867 const FieldId FID_BID9_CONDITION = 841;
00868 const FieldId FID_BID9_TIME = 842;
00869 const FieldId FID_ASK9_CONDITION = 843;
00870 const FieldId FID_ASK9_TIME = 844;
00871 const FieldId FID_BID10_CONDITION = 845;
00872 const FieldId FID_BID10_TIME = 846;
00873 const FieldId FID_ASK10_CONDITION = 847;
00874 const FieldId FID_ASK10_TIME = 848;
00875 const FieldId FID_FUTURE_SPREAD_PATTERN_SYMBOL = 849;
00876 const FieldId FID_FUTURE_SPREAD_PATTERN_TABLE_NO = 850;
00877 const FieldId FID_TOTAL_UPDATES = 851;
00878 const FieldId FID_TRADE_UPDATES = 852;
00879 const FieldId FID_QUOTE_UPDATES = 853;
00880 const FieldId FID_OTHER_UPDATES = 854;
00881 const FieldId FID_BASE_PRICE = 855;
00882 const FieldId FID_HIGH_LRP_PRICE = 856;
00883 const FieldId FID_LOW_LRP_PRICE = 857;
00884 const FieldId FID_LRP_PRICE_TIME = 858;
00885 const FieldId FID_IMPLIED_BID = 859;
00886 const FieldId FID_IMPLIED_BID_SIZE = 860;
00887 const FieldId FID_IMPLIED_BID_CONDITION = 861;
00888 const FieldId FID_IMPLIED_BID_TIME = 862;
00889 const FieldId FID_IMPLIED_ASK = 863;
00890 const FieldId FID_IMPLIED_ASK_SIZE = 864;
00891 const FieldId FID_IMPLIED_ASK_CONDITION = 865;
00892 const FieldId FID_IMPLIED_ASK_TIME = 866;
00893 const FieldId FID_IMPLIED_QUOTE_DATE = 867;
00894 const FieldId FID_CROSS_TYPE = 868;
00895 const FieldId FID_CURRENT_REFERENCE_PRICE = 869;
00896 const FieldId FID_FAR_PRICE = 870;
00897 const FieldId FID_NEAR_PRICE = 871;
00898 const FieldId FID_PAIRED_SHARES = 872;
00899 const FieldId FID_PRICE_VARIATION_INDICATOR = 873;
00900 const FieldId FID_CALCULATED_OPENING_PRICE = 874;
00901 const FieldId FID_CALCULATED_OPENING_PRICE_TIME = 875;
00902 const FieldId FID_CALCULATED_CLOSING_PRICE = 876;
00903 const FieldId FID_CALCULATED_CLOSING_PRICE_TIME = 877;
00904 const FieldId FID_CODE_IDENTIFIER = 878;
00905 const FieldId FID_EXCHANGE_TYPE_LIST = 879;
00906 const FieldId FID_FIELD_DESCRIPTION = 880;
00907 const FieldId FID_STRIKE_PRICE_MULTIPLIER = 881;
00908 const FieldId FID_PARTICIPANT_LIST = 882;
00909 const FieldId FID_ISSUE_STATUS = 883;
00910 const FieldId FID_LOCAL_SESSION_ID = 884;
00911 const FieldId FID_OFFICIAL_ASK = 885;
00912 const FieldId FID_OFFICIAL_QUOTE_DATE = 886;
00913 const FieldId FID_OFFICIAL_ASK_CONDITION = 887;
00914 const FieldId FID_OFFICIAL_BID = 888;
00915 const FieldId FID_OFFICIAL_BID_CONDITION = 889;
00916 const FieldId FID_END_DATE = 890;
00917 const FieldId FID_ADJUSTMENT_TYPE = 891;
00918 const FieldId FID_BUY_SELL = 892;
00919 const FieldId FID_RATIO = 893;
00920 const FieldId FID_STRATEGY_SYMBOL = 894;
00921 const FieldId FID_STRATEGY_TABLE_NO = 895;
00922 const FieldId FID_STRATEGY_LEG_PATTERN_SYMBOL = 896;
00923 const FieldId FID_STRATEGY_LEG_TABLE_NO = 897;
00924 const FieldId FID_STRATEGY_LEG_SYMBOL = 898;
00925 const FieldId FID_AVERAGE_VOLUME_10_DAY = 899;
00926 const FieldId FID_AVERAGE_VOLUME_20_DAY = 900;
00927 const FieldId FID_AVERAGE_VOLUME_30_DAY = 901;
00928 const FieldId FID_AVERAGE_VOLUME_60_DAY = 902;
00929 const FieldId FID_AVERAGE_VOLUME_90_DAY = 903;
00930 const FieldId FID_AVERAGE_VOLUME_120_DAY = 904;
00931 const FieldId FID_AVERAGE_VOLUME_150_DAY = 905;
00932 const FieldId FID_AVERAGE_VOLUME_180_DAY = 906;
00933 const FieldId FID_AVERAGE_VOLUME_360_DAY = 907;
00934 const FieldId FID_MOVING_AVERAGE_10_DAY = 908;
00935 const FieldId FID_MOVING_AVERAGE_20_DAY = 909;
00936 const FieldId FID_MOVING_AVERAGE_30_DAY = 910;
00937 const FieldId FID_MOVING_AVERAGE_60_DAY = 911;
00938 const FieldId FID_MOVING_AVERAGE_90_DAY = 912;
00939 const FieldId FID_MOVING_AVERAGE_120_DAY = 913;
00940 const FieldId FID_MOVING_AVERAGE_150_DAY = 914;
00941 const FieldId FID_MOVING_AVERAGE_180_DAY = 915;
00942 const FieldId FID_MOVING_AVERAGE_360_DAY = 916;
00943 const FieldId FID_STRATEGY_TYPE = 917;
00944 const FieldId FID_AVERAGE_VOLUME_5_DAY = 918;
00945 const FieldId FID_AVERAGE_VOLUME_15_DAY = 919;
00946 const FieldId FID_AVERAGE_VOLUME_45_DAY = 920;
00947 const FieldId FID_MOVING_AVERAGE_5_DAY = 921;
00948 const FieldId FID_MOVING_AVERAGE_15_DAY = 922;
00949 const FieldId FID_MOVING_AVERAGE_45_DAY = 923;
00950 const FieldId FID_VOLATILITY_5_DAY = 924;
00951 const FieldId FID_VOLATILITY_15_DAY = 925;
00952 const FieldId FID_VOLATILITY_45_DAY = 926;
00953 const FieldId FID_APPLICATION_LIST = 927;
00954 const FieldId FID_APPLICATION_INFO_LIST = 928;
00955 const FieldId FID_FOREIGN_APPLICATION_LIST = 929;
00956 const FieldId FID_FOREIGN_APPLICATION_INFO_LIST = 930;
00957 const FieldId FID_POST_FLAG = 931;
00958 const FieldId FID_MARKET_ORDER_IMBALANCE_BUY_VOLUME = 932;
00959 const FieldId FID_MARKET_ORDER_IMBALANCE_SELL_VOLUME = 933;
00960 const FieldId FID_MID = 934;
00961 const FieldId FID_DELTA = 935;
00962 const FieldId FID_GAMMA = 936;
00963 const FieldId FID_RHO = 937;
00964 const FieldId FID_VEGA = 938;
00965 const FieldId FID_THETA = 939;
00966 const FieldId FID_ASK_COUNT = 940;
00967 const FieldId FID_BID_COUNT = 941;
00968 const FieldId FID_CUMULATIVE_VOLUME_AT = 942;
00969 const FieldId FID_CUMULATIVE_VOLUME_MANUAL = 943;
00970 const FieldId FID_EXCHANGE_MARKET_SIZE = 944;
00971 const FieldId FID_MARKET_SECTOR = 945;
00972 const FieldId FID_MARKET_SEGMENT = 946;
00973 const FieldId FID_MID_HIGH = 947;
00974 const FieldId FID_MID_HIGH_TIME = 948;
00975 const FieldId FID_MID_LOW = 949;
00976 const FieldId FID_MID_LOW_TIME = 950;
00977 const FieldId FID_MID_TIME = 951;
00978 const FieldId FID_NORMAL_MARKET_SIZE = 952;
00979 const FieldId FID_PERIOD = 953;
00980 const FieldId FID_PREVIOUS_MID = 954;
00981 const FieldId FID_PUBLICATION_THRESHOLD_SIZE = 955;
00982 const FieldId FID_SEDOL_CODE = 956;
00983 const FieldId FID_STANDARD_MARKET_SIZE = 957;
00984 const FieldId FID_UNCROSSING_CONDITION = 958;
00985 const FieldId FID_UNCROSSING_DATE = 959;
00986 const FieldId FID_UNCROSSING_PRICE = 960;
00987 const FieldId FID_UNCROSSING_TIME = 961;
00988 const FieldId FID_UNCROSSING_VOLUME = 962;
00989 const FieldId FID_VWAP = 963;
00990 const FieldId FID_VWAP_AT = 964;
00991 const FieldId FID_SHORT_NAME = 965;
00992 const FieldId FID_USER_FLAGS = 966;
00993 const FieldId FID_PREVIOUS_CALENDAR_CLOSE = 967;
00994 const FieldId FID_PREVIOUS_CALENDAR_CLOSE_DATE = 968;
00995 const FieldId FID_EXECUTION_LIMIT_RANGE = 969;
00996 const FieldId FID_EXCHANGE_SYMBOL = 970;
00997 const FieldId FID_EXCHANGE_TABLE_NO = 971;
00998 const FieldId FID_INSTRUMENT_PATTERN_SYMBOL = 972;
00999 const FieldId FID_INSTRUMENT_PATTERN_TABLE_NO = 973;
01000 const FieldId FID_PRE_POST_MARKET_TRADE = 974;
01001 const FieldId FID_PRE_POST_MARKET_TRADE_SIZE = 975;
01002 const FieldId FID_PRE_POST_MARKET_TRADE_CONDITION = 976;
01003 const FieldId FID_PRE_POST_MARKET_TRADE_TIME = 977;
01004 const FieldId FID_PRE_POST_MARKET_TRADE_DATE = 978;
01005 const FieldId FID_PRE_POST_MARKET_TRADE_EXCHANGE = 979;
01006 const FieldId FID_PRE_POST_MARKET_TRADE_REPORTING_EXCHANGE = 980;
01007 const FieldId FID_PRE_POST_MARKET_TRADE_THROUGH_EXEMPT_FLAG = 981;
01008 const FieldId FID_DELIVERY_SIZE = 982;
01009 const FieldId FID_BID1_PARTICIPANT = 983;
01010 const FieldId FID_BID2_PARTICIPANT = 984;
01011 const FieldId FID_BID3_PARTICIPANT = 985;
01012 const FieldId FID_BID4_PARTICIPANT = 986;
01013 const FieldId FID_BID5_PARTICIPANT = 987;
01014 const FieldId FID_BID6_PARTICIPANT = 988;
01015 const FieldId FID_BID7_PARTICIPANT = 989;
01016 const FieldId FID_BID8_PARTICIPANT = 990;
01017 const FieldId FID_BID9_PARTICIPANT = 991;
01018 const FieldId FID_BID10_PARTICIPANT = 992;
01019 const FieldId FID_ASK1_PARTICIPANT = 993;
01020 const FieldId FID_ASK2_PARTICIPANT = 994;
01021 const FieldId FID_ASK3_PARTICIPANT = 995;
01022 const FieldId FID_ASK4_PARTICIPANT = 996;
01023 const FieldId FID_ASK5_PARTICIPANT = 997;
01024 const FieldId FID_ASK6_PARTICIPANT = 998;
01025 const FieldId FID_ASK7_PARTICIPANT = 999;
01026 const FieldId FID_ASK8_PARTICIPANT = 1000;
01027 const FieldId FID_ASK9_PARTICIPANT = 1001;
01028 const FieldId FID_ASK10_PARTICIPANT = 1002;
01029 const FieldId FID_NEW_PRIMARY_EXCHANGE = 1003;
01030 const FieldId FID_OLD_PRIMARY_EXCHANGE = 1004;
01031
01032 // Fixed field ids.
01033 const FieldId FID_CONTRIBUTION_BASE = 5000;
01034 const FieldId FID_MAX = 8191;
01035
01036 } // namespace Feed
01037
01038 } // namespace ContentPlatform
01039
01040 } // namespace Activ
01041
01042 #endif // (!defined ACTIV_FEED_COMMON_FIELD_IDS_H)
Generated on Wed Oct 8 14:01:46 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivDatabase

FieldList.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_DATABASE_FIELD_LIST_H)
00010 #define ACTIV_DATABASE_FIELD_LIST_H
00011
00012 #include "ActivMiddleware/ActivFieldTypes/IFieldType.h"
00013 #include "ActivMiddleware/ActivFieldTypes/BinaryArray.h"
00014 #include "ActivMiddleware/ActivFieldTypes/BinaryString.h"
00015 #include "ActivMiddleware/ActivFieldTypes/Blob.h"
00016 #include "ActivMiddleware/ActivFieldTypes/CrcBlob.h"
00017 #include "ActivMiddleware/ActivFieldTypes/Date.h"
00018 #include "ActivMiddleware/ActivFieldTypes/DateTime.h"
00019 #include "ActivMiddleware/ActivFieldTypes/Rational.h"
00020 #include "ActivMiddleware/ActivFieldTypes/SInt.h"
00021 #include "ActivMiddleware/ActivFieldTypes/TextArray.h"
00022 #include "ActivMiddleware/ActivFieldTypes/TextString.h"
00023 #include "ActivMiddleware/ActivFieldTypes/Time.h"
00024 #include "ActivMiddleware/ActivFieldTypes/TRational.h"
00025 #include "ActivMiddleware/ActivFieldTypes/UInt.h"
00026
00027 #include "ActivMiddleware/ActivDatabase/External.h"
00028 #include "ActivMiddleware/ActivDatabase/Definitions.h"
00029
00030 #include "ActivMiddleware/Misc/StlHelper.h"
00031
00032 #include <iostream>
00033 #include <vector>
00034 #include <algorithm>
00035 #include <memory>
00036
00037 namespace Activ
00038 {
00039
00040 class MessageBuilder;
00041 class MessageValidator;
00042
00043 namespace Database
00044 {
00045
00046 class Field;
00047
00048 // ---------------------------------------------------------------------------------------------------------------------------------
00049
00053 class FieldList
00054 {
00055 public:
00059     class ConstIterator
00060     {
00061     public:
00065         ConstIterator();
00066
00074         ConstIterator(const ConstIterator &rhs);
00075
00081         ACTIV_DATABASE_API ConstIterator &operator++();
00082
00088         const ConstIterator operator++(int);
00089
00097         bool operator==(const ConstIterator &rhs) const;
00098
00106         bool operator!=(const ConstIterator &rhs) const;
00107
00113         ACTIV_DATABASE_API FieldSpecification::Id GetId() const;
00114
00120         ACTIV_DATABASE_API std::string GetName() const;
00121
00127         ACTIV_DATABASE_API FieldSpecification::Type GetType() const;
00128
00134         ACTIV_DATABASE_API FieldSpecification GetSpecification() const;
00135
00141         bool IsInitialized() const;
00142
00143     private:
00152         ConstIterator(const std::vector<Field> *pFieldContainer, const size_t fieldNo);
00153
00154         const std::vector<Field>        *m_pFieldContainer;
00155         size_t                          m_fieldNo;
00156
00157         friend class FieldList;
00158     };
00159
00165     FieldList();
00166
00170     virtual ~FieldList();
00171
00177     void CreateFieldIdLookupList(const FieldSpecificationList &fieldSpecificationList);
00178
00184     void CreateFieldIdMap(const FieldSpecificationList &fieldSpecificationList);
00185
00196     ACTIV_DATABASE_API StatusCode SerializeSpecification(MessageBuilder &messageBuilder) const;
00197
00209     ACTIV_DATABASE_API static StatusCode DeserializeSpecification(MessageValidator &messageValidator, FieldSpecificationList &fieldSpecificationList);
00210
00222     ACTIV_DATABASE_API virtual StatusCode Serialize(MessageBuilder &messageBuilder, const byte_t *pSourceData) const = 0;
00223
00233     ACTIV_DATABASE_API virtual StatusCode Deserialize(MessageValidator &messageValidator, byte_t *pTargetData) const = 0;
00234
00240     ACTIV_DATABASE_API virtual void ResetData(byte_t *pTargetData) const = 0;
00241
00254     virtual StatusCode SetField(const size_t targetFieldNo, byte_t *pTargetData, const size_t sourceFieldNo, const FieldList &sourceFieldList, const byte_t *pSourceData) const = 0;
00255
00267     virtual StatusCode SetField(const size_t fieldNo, byte_t *pTargetData, const void *pField, const size_t fieldLength) const = 0;
00268
00281     ACTIV_DATABASE_API StatusCode SetField(byte_t *pTargetData, const FieldSpecification::Id fieldId, const void *pField, const size_t fieldLength) const;
00282
00296     ACTIV_DATABASE_API StatusCode SetField(byte_t *pTargetData, const FieldSpecification::Id fieldId, const void *pField, const size_t fieldLength, bool &isDifferent) const;
00297
00312     template <typename T> StatusCode SetField(byte_t *pTargetData, const FieldSpecification::Id fieldId, const T &value) const;
00313
00329     template <typename T> StatusCode SetField(byte_t *pTargetData, const FieldSpecification::Id fieldId, const T &value, bool &isDifferent) const;
00330
00345     ACTIV_DATABASE_API virtual StatusCode SetField(byte_t *pTargetData, const FieldSpecification::Id fieldId, const bool value) const = 0;
00346
00360     ACTIV_DATABASE_API StatusCode GetField(const byte_t *pSourceData, const FieldSpecification::Id fieldId, void *pField, const size_t fieldSize, size_t &fieldLength) const;
00361
00373     StatusCode GetField(const size_t fieldNo, const byte_t *pSourceData, const void *&pField, size_t &fieldLength) const;
00374
00386     ACTIV_DATABASE_API StatusCode GetField(const byte_t *pSourceData, const FieldSpecification::Id fieldId, const void *&pField, size_t &fieldLength) const;
00387
00399     ACTIV_DATABASE_API StatusCode GetField(byte_t *pSourceData, const FieldSpecification::Id fieldId, void *&pField, size_t &fieldLength) const;
00400
00414     template <typename T> StatusCode GetField(const byte_t *pSourceData, const FieldSpecification::Id fieldId, T &value) const;
00415
00428     ACTIV_DATABASE_API StatusCode GetField(const byte_t *pSourceData, const ConstIterator &iterator, const void *&pField, size_t &fieldLength) const;
00429
00444     ACTIV_DATABASE_API StatusCode GetField(const byte_t *pSourceData, const ConstIterator &iterator, FieldSpecification::Id &fieldId, FieldSpecification::Type &type, const void *&pField, size_t &fieldLength) const;
00445
00459     ACTIV_DATABASE_API  StatusCode CopyFields(byte_t *pTargetData, const FieldList &sourceFieldList, const byte_t *pSourceData, const bool copyAllFields = false) const;
00460
00473     ACTIV_DATABASE_API StatusCode CopyField(const FieldSpecification::Id fieldId, byte_t *pTargetData, const FieldList &sourceFieldList, const byte_t *pSourceData) const;
00474
00488     StatusCode CopyField(const FieldSpecification::Id fieldId, byte_t *pTargetData, const FieldList &sourceFieldList, const byte_t *pSourceData, bool &isDifferent) const;
00489
00503     ACTIV_DATABASE_API  StatusCode CopyField(const FieldSpecification::Id targetFieldId, byte_t *pTargetData, const FieldList &sourceFieldList, const FieldSpecification::Id sourceFieldId, const byte_t *pSourceData) const;
00504
00519     StatusCode CopyField(const FieldSpecification::Id targetFieldId, byte_t *pTargetData, const FieldList &sourceFieldList, const FieldSpecification::Id sourceFieldId, const byte_t *pSourceData, bool &isDifferent) const;
00520
00533     ACTIV_DATABASE_API virtual StatusCode CompareField(const FieldSpecification::Id fieldId, const byte_t *pLhsData, const IFieldType &iFieldType, int &result) const = 0;
00534
00549     ACTIV_DATABASE_API virtual StatusCode CompareField(const FieldSpecification::Id fieldId, const byte_t *pLhsData, const std::string &value, int &result) const = 0;
00550
00565     ACTIV_DATABASE_API virtual StatusCode CompareField(const FieldSpecification::Id lhsFieldId, const byte_t *pLhsData, const FieldList &rhsFieldList, const FieldSpecification::Id rhsFieldId, const byte_t *pRhsData, int &result) const;
00566
00580     ACTIV_DATABASE_API StatusCode IsFieldDifferent(const FieldSpecification::Id fieldId, const byte_t *pLhsData, const void *pField, const size_t fieldLength, bool &result) const;
00581
00594     ACTIV_DATABASE_API StatusCode IsFieldDifferent(const FieldSpecification::Id fieldId, const byte_t *pLhsData, const IFieldType &iFieldType, bool &result) const;
00595
00610     ACTIV_DATABASE_API StatusCode IsFieldDifferent(const FieldSpecification::Id fieldId, const byte_t *pLhsData, const std::string &value, bool &result) const;
00611
00624     ACTIV_DATABASE_API StatusCode IsFieldDifferent(const FieldSpecification::Id fieldId, const byte_t *pLhsData, const FieldList &rhsFieldList, const byte_t *pRhsData, bool &result) const;
00625
00639     ACTIV_DATABASE_API StatusCode IsFieldDifferent(const FieldSpecification::Id lhsFieldId, const byte_t *pLhsData, const FieldList &rhsFieldList, const FieldSpecification::Id rhsFieldId, const byte_t *pRhsData, bool &result) const;
00640
00652     ACTIV_DATABASE_API virtual StatusCode DefineField(byte_t *pTargetData, const FieldSpecification::Id fieldId, const size_t fieldLength = ~0) const = 0;
00653
00664     ACTIV_DATABASE_API virtual StatusCode UndefineField(byte_t *pTargetData, const FieldSpecification::Id fieldId) const = 0;
00665
00677     ACTIV_DATABASE_API virtual StatusCode UndefineField(byte_t *pTargetData, const FieldSpecification::Id fieldId, bool &isDifferent) const = 0;
00678
00689     ACTIV_DATABASE_API virtual StatusCode IsFieldDefined(const byte_t *pSourceData, const FieldSpecification::Id fieldId, bool &result) const = 0;
00690
00697     virtual void DefineField(const size_t fieldNo, byte_t *pTargetData) const = 0;
00698
00705     virtual void UndefineField(const size_t fieldNo, byte_t *pTargetData) const = 0;
00706
00715     virtual bool IsFieldDefined(const size_t fieldNo, const byte_t *pSourceData) const = 0;
00716
00725     ACTIV_DATABASE_API int Compare(const byte_t *pLhsData, const byte_t *pRhsData) const;
00726
00736     ACTIV_DATABASE_API int Compare(const byte_t *pLhsData, const byte_t *pRhsData, const size_t lastFieldNo) const;
00737
00748     ACTIV_DATABASE_API int Compare(const byte_t *pLhsData, const byte_t *pRhsData, const size_t lastFieldNo, const size_t lastCompareLength) const;
00749
00759     ACTIV_DATABASE_API int Compare(const size_t fieldNo, const byte_t *pLhsData, const byte_t *pRhsData) const;
00760
00769     ACTIV_DATABASE_API int CompareKey(const byte_t *pLhsData, const byte_t *pRhsData) const;
00770
00780     ACTIV_DATABASE_API int CompareKey(const byte_t *pLhsData, const byte_t *pRhsData, const size_t lastFieldNo) const;
00781
00792     ACTIV_DATABASE_API int CompareKey(const byte_t *pLhsData, const byte_t *pRhsData, const size_t lastFieldNo, const size_t lastCompareLength) const;
00793
00799     size_t GetDataLength() const;
00800
00806     size_t GetNumberOfFields() const;
00807
00813     ACTIV_DATABASE_API FieldSpecificationList GetFieldSpecificationList() const;
00814
00820     ACTIV_DATABASE_API void GetFirstFieldSpecification(FieldSpecification &fieldSpecification) const;
00821
00831     ACTIV_DATABASE_API StatusCode GetNextFieldSpecification(FieldSpecification &fieldSpecification) const;
00832
00838     ACTIV_DATABASE_API FieldIdList GetFieldIdList() const;
00839
00845     ACTIV_DATABASE_API void GetFirstFieldId(FieldSpecification::Id &fieldId) const;
00846
00856     ACTIV_DATABASE_API StatusCode GetNextFieldId(FieldSpecification::Id &fieldId) const;
00857
00866     bool GetFieldNumber(const FieldSpecification::Id fieldId, size_t &fieldNo) const;
00867
00876     ACTIV_DATABASE_API bool GetFieldNumber(const FieldSpecification &fieldSpecification, size_t &fieldNo) const;
00877
00887     ACTIV_DATABASE_API StatusCode GetFieldSpecification(const FieldSpecification::Id fieldId, FieldSpecification &fieldSpecification) const;
00888
00899     ACTIV_DATABASE_API StatusCode GetFieldSpecification(const FieldSpecification::Id fieldId, size_t &fieldNo, const FieldSpecification *&pFieldSpecification) const;
00900
00910     ACTIV_DATABASE_API StatusCode GetType(const FieldSpecification::Id fieldId, FieldSpecification::Type &type) const;
00911
00919     const Field &GetFieldDefinition(const size_t fieldNo) const;
00920
00929     ACTIV_DATABASE_API virtual size_t GetFieldLength(const size_t fieldNo, const byte_t *pSourceData) const = 0;
00930
00938     ACTIV_DATABASE_API std::string ToString(const byte_t *pSourceData) const;
00939
00947     ACTIV_DATABASE_API std::string ToLogString(const byte_t *pSourceData) const;
00948
00954     ConstIterator Begin() const;
00955
00961     ConstIterator End() const;
00962
00968     bool IsFound(const FieldSpecification::Id fieldId) const;
00969
00970 #if defined (_DEBUG)
00971
00976     ACTIV_DATABASE_API void DisplayFieldInformation(std::ostream &os = std::cout) const;
00977 #endif
00978
00979 protected:
00980     typedef hash_map<FieldSpecification::Id, size_t> FieldIdMap;
00981     static const size_t     UNDEFINED_FIELD_NUMBER = ~0;
00982
00983     std::vector<Field>      &m_fieldList;
00984     std::vector<size_t>     m_fieldNoList;
00985     FieldIdMap              m_fieldIdMap;
00986
00987     size_t                  m_nFields;
00988     size_t                  m_dataLength;
00989
00990 private:
00998     FieldList(const FieldList &rhs);
00999
01009     FieldList &operator=(const FieldList &rhs);
01010
01011     template <typename T> ACTIV_TEMPLATE_API(ACTIV_DATABASE_API) StatusCode SetFieldT(byte_t *pTargetData, const FieldSpecification::Id fieldId, const T &value) const;
01012     template <typename T> ACTIV_TEMPLATE_API(ACTIV_DATABASE_API) StatusCode SetFieldT(byte_t *pTargetData, const FieldSpecification::Id fieldId, const T &value, bool &isDifferent) const;
01013     template <typename T> ACTIV_TEMPLATE_API(ACTIV_DATABASE_API) StatusCode GetFieldT(const byte_t *pSourceData, const FieldSpecification::Id fieldId, T &value) const;
01014
01029     StatusCode GetField(const byte_t *pSourceData, const FieldSpecification::Id fieldId, void *&pField, size_t &fieldLength) const;
01030 };
01031
01032 // ---------------------------------------------------------------------------------------------------------------------------------
01033
01034 template <typename T>
01035 inline StatusCode FieldList::SetField(byte_t *pTargetData, const FieldSpecification::Id fieldId, const T &value) const
01036 {
01037     return SetFieldT<T>(pTargetData, fieldId, value);
01038 }
01039
01040 // ---------------------------------------------------------------------------------------------------------------------------------
01041
01042 template <typename T>
01043 inline StatusCode FieldList::SetField(byte_t *pTargetData, const FieldSpecification::Id fieldId, const T &value, bool &isDifferent) const
01044 {
01045     return SetFieldT<T>(pTargetData, fieldId, value, isDifferent);
01046 }
01047
01048 // ---------------------------------------------------------------------------------------------------------------------------------
01049
01050 template <typename T>
01051 inline StatusCode FieldList::GetField(const byte_t *pSourceData, const FieldSpecification::Id fieldId, T &value) const
01052 {
01053     return GetFieldT<T>(pSourceData, fieldId, value);
01054 }
01055
01056 // ---------------------------------------------------------------------------------------------------------------------------------
01057
01058 inline StatusCode FieldList::CopyField(const FieldSpecification::Id fieldId, byte_t *pTargetData, const FieldList &sourceFieldList, const byte_t *pSourceData, bool &isDifferent) const
01059 {
01060     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, IsFieldDifferent(fieldId, pTargetData, sourceFieldList, pSourceData, isDifferent));
01061
01062     return CopyField(fieldId, pTargetData, sourceFieldList, pSourceData);
01063 }
01064
01065 // ---------------------------------------------------------------------------------------------------------------------------------
01066
01067 inline StatusCode FieldList::CopyField(const FieldSpecification::Id targetFieldId, byte_t *pTargetData, const FieldList &sourceFieldList, const FieldSpecification::Id sourceFieldId, const byte_t *pSourceData, bool &isDifferent) const
01068 {
01069     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, IsFieldDifferent(targetFieldId, pTargetData, sourceFieldList, sourceFieldId, pSourceData, isDifferent));
01070
01071     return CopyField(targetFieldId, pTargetData, sourceFieldList, sourceFieldId, pSourceData);
01072 }
01073
01074 // ---------------------------------------------------------------------------------------------------------------------------------
01075
01076 inline bool FieldList::GetFieldNumber(const FieldSpecification::Id fieldId, size_t &fieldNo) const
01077 {
01078     if ((fieldId >= m_fieldNoList.size()) || (UNDEFINED_FIELD_NUMBER == m_fieldNoList[fieldId]))
01079         return false;
01080
01081     fieldNo = m_fieldNoList[fieldId];
01082
01083     return true;
01084 }
01085
01086 // ---------------------------------------------------------------------------------------------------------------------------------
01087
01088 inline size_t FieldList::GetDataLength() const
01089 {
01090     return m_dataLength;
01091 }
01092
01093 // ---------------------------------------------------------------------------------------------------------------------------------
01094
01095 inline size_t FieldList::GetNumberOfFields() const
01096 {
01097     return m_nFields;
01098 }
01099
01100 // ---------------------------------------------------------------------------------------------------------------------------------
01101
01102 inline FieldList::ConstIterator FieldList::Begin() const
01103 {
01104     return ConstIterator(&m_fieldList, 0);
01105 }
01106
01107 // ---------------------------------------------------------------------------------------------------------------------------------
01108
01109 inline FieldList::ConstIterator FieldList::End() const
01110 {
01111     return ConstIterator(0, UNDEFINED_FIELD_NUMBER);
01112 }
01113
01114 // ---------------------------------------------------------------------------------------------------------------------------------
01115
01116 inline bool FieldList::IsFound(const FieldSpecification::Id fieldId) const
01117 {
01118     size_t fieldNo;
01119
01120     return GetFieldNumber(fieldId, fieldNo);
01121 }
01122
01123 // ---------------------------------------------------------------------------------------------------------------------------------
01124 // ---------------------------------------------------------------------------------------------------------------------------------
01125
01126 inline FieldList::ConstIterator::ConstIterator() :
01127     m_pFieldContainer(0),
01128     m_fieldNo(UNDEFINED_FIELD_NUMBER)
01129 {
01130 }
01131
01132 // ---------------------------------------------------------------------------------------------------------------------------------
01133
01134 inline FieldList::ConstIterator::ConstIterator(const FieldList::ConstIterator &rhs) :
01135     m_pFieldContainer(rhs.m_pFieldContainer),
01136     m_fieldNo(rhs.m_fieldNo)
01137 {
01138 }
01139
01140 // ---------------------------------------------------------------------------------------------------------------------------------
01141
01142 inline const FieldList::ConstIterator FieldList::ConstIterator::operator++(int)
01143 {
01144     ConstIterator oldValue = *this;
01145
01146     ++(*this);
01147
01148     return oldValue;
01149 }
01150
01151 // ---------------------------------------------------------------------------------------------------------------------------------
01152
01153 inline bool FieldList::ConstIterator::operator==(const FieldList::ConstIterator &rhs) const
01154 {
01155     return ((m_pFieldContainer == rhs.m_pFieldContainer) && (m_fieldNo == rhs.m_fieldNo));
01156 }
01157
01158 // ---------------------------------------------------------------------------------------------------------------------------------
01159
01160 inline bool FieldList::ConstIterator::operator!=(const FieldList::ConstIterator &rhs) const
01161 {
01162     return !((*this) == rhs);
01163 }
01164
01165 // ---------------------------------------------------------------------------------------------------------------------------------
01166
01167 inline bool FieldList::ConstIterator::IsInitialized() const
01168 {
01169     return (0 != m_pFieldContainer);
01170 }
01171
01172 // ---------------------------------------------------------------------------------------------------------------------------------
01173
01174 inline FieldList::ConstIterator::ConstIterator(const std::vector<Field> *pFieldContainer, size_t fieldNo) :
01175     m_pFieldContainer(pFieldContainer),
01176     m_fieldNo(fieldNo)
01177 {
01178 }
01179
01180 // ---------------------------------------------------------------------------------------------------------------------------------
01181
01182 }   // namespace Database
01183
01184 }   // namespace Activ
01185
01186 #endif // (!defined ACTIV_DATABASE_FIELD_LIST_H)
Generated on Wed Oct 8 14:01:47 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivDatabase

FieldListObject.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_DATABASE_FIELD_LIST_OBJECT_H)
00010 #define ACTIV_DATABASE_FIELD_LIST_OBJECT_H
00011
00012 #include "ActivMiddleware/ActivDatabase/External.h"
00013 #include "ActivMiddleware/ActivDatabase/Definitions.h"
00014 #include "ActivMiddleware/ActivDatabase/ITable.h"
00015 #include "ActivMiddleware/ActivDatabase/FieldList.h"
00016
00017 #include <iostream>
00018 #include <string>
00019 #include <memory>
00020
00021 namespace Activ
00022 {
00023
00024 class MessageBuilder;
00025 class MessageValidator;
00026
00027 namespace Database
00028 {
00029
00033 class FieldListObject
00034 {
00035 public:
00036     typedef FieldList::ConstIterator ConstIterator;
00037
00041     FieldListObject();
00042
00046     virtual ~FieldListObject() = 0;
00047
00051     void Initialize();
00052
00064     StatusCode Initialize(ITable *pTable, const FieldList *pFieldList, const size_t requiredBufferSize);
00065
00074     virtual StatusCode Serialize(MessageBuilder &messageBuilder) const = 0;
00075
00085     virtual StatusCode Deserialize(ITable *pTable, MessageValidator &messageValidator) = 0;
00086
00093     virtual StatusCode Reset() = 0;
00094
00107     StatusCode SetField(const FieldSpecification::Id fieldId, const void *pField, const size_t fieldLength);
00108
00122     StatusCode SetField(const FieldSpecification::Id fieldId, const void *pField, const size_t fieldLength, bool &isDifferent);
00123
00136     template <typename T> StatusCode SetField(const FieldSpecification::Id fieldId, const T &value);
00137
00151     template <typename T> StatusCode SetField(const FieldSpecification::Id fieldId, const T &value, bool &isDifferent);
00152
00167     StatusCode GetField(const FieldSpecification::Id fieldId, void *pField, const size_t fieldSize, size_t &fieldLength) const;
00168
00181     StatusCode GetField(const FieldSpecification::Id fieldId, const void *&pField, size_t &fieldLength) const;
00182
00197     StatusCode GetField(const FieldSpecification::Id fieldId, void *&pField, size_t &fieldLength);
00198
00211     template <typename T> StatusCode GetField(const FieldSpecification::Id fieldId, T &value) const;
00212
00225     StatusCode GetField(const ConstIterator &iterator, const void *&pField, size_t &fieldLength) const;
00226
00241     StatusCode GetField(const ConstIterator &iterator, FieldSpecification::Id &fieldId, FieldSpecification::Type &type, const void *&pField, size_t &fieldLength) const;
00242
00254     virtual StatusCode CopyFields(const FieldListObject &sourceFieldListObject, const bool copyAllFields = false);
00255
00267     StatusCode CopyField(const FieldSpecification::Id fieldId, const FieldListObject &sourceFieldListObject);
00268
00281     StatusCode CopyField(const FieldSpecification::Id fieldId, const FieldListObject &sourceFieldListObject, bool &isDifferent);
00282
00296     StatusCode CopyField(const FieldSpecification::Id targetFieldId, const FieldListObject &sourceFieldListObject, const FieldSpecification::Id sourceFieldId);
00297
00312     StatusCode CopyField(const FieldSpecification::Id targetFieldId, const FieldListObject &sourceFieldListObject, const FieldSpecification::Id sourceFieldId, bool &isDifferent);
00313
00326     StatusCode CompareField(const FieldSpecification::Id fieldId, const IFieldType &iFieldType, int &result) const;
00327
00342     StatusCode CompareField(const FieldSpecification::Id fieldId, const std::string &value, int &result) const;
00343
00356     StatusCode CompareField(const FieldSpecification::Id fieldId, const FieldListObject &rhsFieldListObject, int &result) const;
00357
00371     StatusCode CompareField(const FieldSpecification::Id lhsFieldId, const FieldListObject &rhsFieldListObject, const FieldSpecification::Id rhsFieldId, int &result) const;
00372
00386     StatusCode IsFieldDifferent(const FieldSpecification::Id fieldId, const void *pField, const size_t fieldLength, bool &result) const;
00387
00400     StatusCode IsFieldDifferent(const FieldSpecification::Id fieldId, const IFieldType &iFieldType, bool &result) const;
00401
00416     StatusCode IsFieldDifferent(const FieldSpecification::Id fieldId, const std::string &value, bool &result) const;
00417
00428     StatusCode IsFieldDifferent(const FieldSpecification::Id fieldId, const FieldListObject &rhsFieldListObject, bool &result) const;
00429
00441     StatusCode IsFieldDifferent(const FieldSpecification::Id lhsFieldId, const FieldListObject &rhsFieldListObject, const FieldSpecification::Id rhsFieldId, bool &result) const;
00442
00454     StatusCode DefineField(const FieldSpecification::Id fieldId, const size_t fieldLength = ~0);
00455
00465     StatusCode UndefineField(const FieldSpecification::Id fieldId);
00466
00477     StatusCode UndefineField(const FieldSpecification::Id fieldId, bool &isDifferent);
00478
00489     StatusCode IsFieldDefined(const FieldSpecification::Id fieldId, bool &result) const;
00490
00499     StatusCode GetFieldSpecificationList(FieldSpecificationList &fieldSpecificationList) const;
00500
00511     StatusCode GetFieldSpecification(const FieldSpecification::Id fieldId, FieldSpecification &fieldSpecification) const;
00512
00521     StatusCode GetFieldIdList(FieldIdList &fieldIdList) const;
00522
00531     StatusCode GetFirstFieldId(FieldSpecification::Id &fieldId) const;
00532
00543     StatusCode GetNextFieldId(FieldSpecification::Id &fieldId) const;
00544
00555     ACTIV_DATABASE_API StatusCode GetMatchingFieldsByName(FieldIdList &lhsFieldIdList, const FieldListObject &rhsFieldListObject, FieldIdList &rhsFieldIdList);
00556
00566     ACTIV_DATABASE_API StatusCode GetMatchingFieldsById(FieldIdList &fieldIdList, const FieldListObject &rhsFieldListObject);
00567
00578     StatusCode GetType(const FieldSpecification::Id fieldId, FieldSpecification::Type &type) const;
00579
00588     StatusCode GetTablePointer(ITable *&pTable) const;
00589
00595     byte_t *Get();
00596
00602     const byte_t *Get() const;
00603
00609     void SetId(const DataId id) const;
00610
00616     DataId GetId() const;
00617
00623     std::string ToString() const;
00624
00630     std::string ToLogString() const;
00631
00637     ConstIterator Begin() const;
00638
00644     ConstIterator End() const;
00645
00651     bool IsInitialized() const;
00652
00658     bool IsFound(const FieldSpecification::Id fieldId) const;
00659
00660 protected:
00666     const FieldList &GetFieldList() const;
00667
00676     StatusCode AllocateBuffer(const size_t requiredBufferSize);
00677
00678     static const size_t     DEFAULT_BUFFER_SIZE = 1024;
00679
00680     bool                    m_isInitialized;
00681     ITable                  *m_pTable;
00682     ITable::Identity        m_tableIdentity;
00683     const FieldList         *m_pFieldList;
00684     byte_t                  m_defaultBuffer[DEFAULT_BUFFER_SIZE];
00685     byte_t                  *m_pData;
00686     size_t                  m_bufferSize;
00687     mutable DataId          m_id;
00688
00689     friend class FieldList::ConstIterator;
00690 };
00691
00692 // ---------------------------------------------------------------------------------------------------------------------------------
00693
00694 inline FieldListObject::FieldListObject() :
00695     m_isInitialized(false),
00696     m_pTable(0),
00697     m_tableIdentity(0),
00698     m_pFieldList(0),
00699     m_pData(m_defaultBuffer),
00700     m_bufferSize(sizeof(m_defaultBuffer)),
00701     m_id(UNDEFINED_ID)
00702 {
00703 }
00704
00705 // ---------------------------------------------------------------------------------------------------------------------------------
00706
00707 inline FieldListObject::~FieldListObject()
00708 {
00709     if (m_defaultBuffer != m_pData)
00710         delete [] m_pData;
00711 }
00712
00713 // ---------------------------------------------------------------------------------------------------------------------------------
00714
00715 inline void FieldListObject::Initialize()
00716 {
00717     if (m_defaultBuffer != m_pData)
00718         delete [] m_pData;
00719
00720     m_isInitialized = false;
00721     m_pTable = m_tableIdentity = 0;
00722     m_pFieldList = 0;
00723     m_pData = m_defaultBuffer;
00724     m_bufferSize = sizeof(m_defaultBuffer);
00725     m_id = UNDEFINED_ID;
00726     ::memset(m_pData, 0, m_bufferSize);
00727 }
00728
00729 // ---------------------------------------------------------------------------------------------------------------------------------
00730
00731 inline StatusCode FieldListObject::Initialize(ITable *pTable, const FieldList *pFieldList, const size_t requiredBufferSize)
00732 {
00733     if (m_bufferSize < requiredBufferSize)
00734         ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, AllocateBuffer(requiredBufferSize));
00735
00736     m_isInitialized = true;
00737     m_pTable = pTable;
00738     m_tableIdentity = pTable->GetIdentity();
00739     m_pFieldList = pFieldList;
00740
00741     return STATUS_CODE_SUCCESS;
00742 }
00743
00744 // ---------------------------------------------------------------------------------------------------------------------------------
00745
00746 inline StatusCode FieldListObject::AllocateBuffer(const size_t requiredBufferSize)
00747 {
00748     byte_t *pData = new (std::nothrow) byte_t[requiredBufferSize];
00749     if (0 == pData)
00750         return STATUS_CODE_HEAP_EMPTY;
00751
00752     if (m_defaultBuffer != m_pData)
00753         delete [] m_pData;
00754
00755     m_pData = pData;
00756     m_bufferSize = requiredBufferSize;
00757
00758     return STATUS_CODE_SUCCESS;
00759 }
00760
00761 // ---------------------------------------------------------------------------------------------------------------------------------
00762
00763 inline StatusCode FieldListObject::SetField(const FieldSpecification::Id fieldId, const void *pField, const size_t fieldLength)
00764 {
00765     return (IsInitialized()) ? GetFieldList().SetField(Get(), fieldId, pField, fieldLength) : STATUS_CODE_NOT_INITIALIZED;
00766 }
00767
00768 // ---------------------------------------------------------------------------------------------------------------------------------
00769
00770 inline StatusCode FieldListObject::SetField(const FieldSpecification::Id fieldId, const void *pField, const size_t fieldLength, bool &isDifferent)
00771 {
00772     return (IsInitialized()) ? GetFieldList().SetField(Get(), fieldId, pField, fieldLength, isDifferent) : STATUS_CODE_NOT_INITIALIZED;
00773 }
00774
00775 // ---------------------------------------------------------------------------------------------------------------------------------
00776
00777 template <typename T>
00778 inline StatusCode FieldListObject::SetField(const FieldSpecification::Id fieldId, const T &value)
00779 {
00780     return (IsInitialized()) ? GetFieldList().SetField(Get(), fieldId, value) : STATUS_CODE_NOT_INITIALIZED;
00781 }
00782
00783 // ---------------------------------------------------------------------------------------------------------------------------------
00784
00785 template <typename T>
00786 inline StatusCode FieldListObject::SetField(const FieldSpecification::Id fieldId, const T &value, bool &isDifferent)
00787 {
00788     return (IsInitialized()) ? GetFieldList().SetField(Get(), fieldId, value, isDifferent) : STATUS_CODE_NOT_INITIALIZED;
00789 }
00790
00791 // ---------------------------------------------------------------------------------------------------------------------------------
00792
00793 inline StatusCode FieldListObject::GetField(const FieldSpecification::Id fieldId, void *pField, const size_t fieldSize, size_t &fieldLength) const
00794 {
00795     return (IsInitialized()) ? GetFieldList().GetField(Get(), fieldId, pField, fieldSize, fieldLength) : STATUS_CODE_NOT_INITIALIZED;
00796 }
00797
00798 // ---------------------------------------------------------------------------------------------------------------------------------
00799
00800 inline StatusCode FieldListObject::GetField(const FieldSpecification::Id fieldId, const void *&pField, size_t &fieldLength) const
00801 {
00802     return (IsInitialized()) ? GetFieldList().GetField(Get(), fieldId, pField, fieldLength) : STATUS_CODE_NOT_INITIALIZED;
00803 }
00804
00805 // ---------------------------------------------------------------------------------------------------------------------------------
00806
00807 inline StatusCode FieldListObject::GetField(const FieldSpecification::Id fieldId, void *&pField, size_t &fieldLength)
00808 {
00809     return (IsInitialized()) ? GetFieldList().GetField(Get(), fieldId, pField, fieldLength) : STATUS_CODE_NOT_INITIALIZED;
00810 }
00811
00812 // ---------------------------------------------------------------------------------------------------------------------------------
00813
00814 template <typename T>
00815 inline StatusCode FieldListObject::GetField(const FieldSpecification::Id fieldId, T &value) const
00816 {
00817     return (IsInitialized()) ? GetFieldList().GetField(Get(), fieldId, value) : STATUS_CODE_NOT_INITIALIZED;
00818 }
00819
00820 // ---------------------------------------------------------------------------------------------------------------------------------
00821
00822 inline StatusCode FieldListObject::GetField(const ConstIterator &iterator, const void *&pField, size_t &fieldLength) const
00823 {
00824     return (IsInitialized()) ? GetFieldList().GetField(Get(), iterator, pField, fieldLength) : STATUS_CODE_NOT_INITIALIZED;
00825 }
00826
00827 // ---------------------------------------------------------------------------------------------------------------------------------
00828
00829 inline StatusCode FieldListObject::GetField(const ConstIterator &iterator, FieldSpecification::Id &fieldId, FieldSpecification::Type &type, const void *&pField, size_t &fieldLength) const
00830 {
00831     return (IsInitialized()) ? GetFieldList().GetField(Get(), iterator, fieldId, type, pField, fieldLength) : STATUS_CODE_NOT_INITIALIZED;
00832 }
00833
00834 // ---------------------------------------------------------------------------------------------------------------------------------
00835
00836 inline StatusCode FieldListObject::CopyFields(const FieldListObject &sourceFieldListObject, const bool copyAllFields)
00837 {
00838     if ((!IsInitialized()) || (!sourceFieldListObject.IsInitialized()))
00839         return STATUS_CODE_NOT_INITIALIZED;
00840
00841     return GetFieldList().CopyFields(Get(), sourceFieldListObject.GetFieldList(), sourceFieldListObject.Get(), copyAllFields);
00842 }
00843
00844 // ---------------------------------------------------------------------------------------------------------------------------------
00845
00846 inline StatusCode FieldListObject::CopyField(const FieldSpecification::Id fieldId, const FieldListObject &sourceFieldListObject)
00847 {
00848     if ((!IsInitialized()) || (!sourceFieldListObject.IsInitialized()))
00849         return STATUS_CODE_NOT_INITIALIZED;
00850
00851     return GetFieldList().CopyField(fieldId, Get(), sourceFieldListObject.GetFieldList(), sourceFieldListObject.Get());
00852 }
00853
00854 // ---------------------------------------------------------------------------------------------------------------------------------
00855
00856 inline StatusCode FieldListObject::CopyField(const FieldSpecification::Id fieldId, const FieldListObject &sourceFieldListObject, bool &isDifferent)
00857 {
00858     if ((!IsInitialized()) || (!sourceFieldListObject.IsInitialized()))
00859         return STATUS_CODE_NOT_INITIALIZED;
00860
00861     return GetFieldList().CopyField(fieldId, Get(), sourceFieldListObject.GetFieldList(), sourceFieldListObject.Get(), isDifferent);
00862 }
00863
00864 // ---------------------------------------------------------------------------------------------------------------------------------
00865
00866 inline StatusCode FieldListObject::CopyField(const FieldSpecification::Id targetFieldId, const FieldListObject &sourceFieldListObject, const FieldSpecification::Id sourceFieldId)
00867 {
00868     if ((!IsInitialized()) || (!sourceFieldListObject.IsInitialized()))
00869         return STATUS_CODE_NOT_INITIALIZED;
00870
00871     return GetFieldList().CopyField(targetFieldId, Get(), sourceFieldListObject.GetFieldList(), sourceFieldId, sourceFieldListObject.Get());
00872 }
00873
00874 // ---------------------------------------------------------------------------------------------------------------------------------
00875
00876 inline StatusCode FieldListObject::CopyField(const FieldSpecification::Id targetFieldId, const FieldListObject &sourceFieldListObject, const FieldSpecification::Id sourceFieldId, bool &isDifferent)
00877 {
00878     if ((!IsInitialized()) || (!sourceFieldListObject.IsInitialized()))
00879         return STATUS_CODE_NOT_INITIALIZED;
00880
00881     return GetFieldList().CopyField(targetFieldId, Get(), sourceFieldListObject.GetFieldList(), sourceFieldId, sourceFieldListObject.Get(), isDifferent);
00882 }
00883
00884 // ---------------------------------------------------------------------------------------------------------------------------------
00885
00886 inline StatusCode FieldListObject::CompareField(const FieldSpecification::Id fieldId, const IFieldType &iFieldType, int &result) const
00887 {
00888     if (!IsInitialized())
00889         return STATUS_CODE_NOT_INITIALIZED;
00890
00891     return GetFieldList().CompareField(fieldId, Get(), iFieldType, result);
00892 }
00893
00894 // ---------------------------------------------------------------------------------------------------------------------------------
00895
00896 inline StatusCode FieldListObject::CompareField(const FieldSpecification::Id fieldId, const std::string &value, int &result) const
00897 {
00898     if (!IsInitialized())
00899         return STATUS_CODE_NOT_INITIALIZED;
00900
00901     return GetFieldList().CompareField(fieldId, Get(), value, result);
00902 }
00903
00904 // ---------------------------------------------------------------------------------------------------------------------------------
00905
00906 inline StatusCode FieldListObject::CompareField(const FieldSpecification::Id fieldId, const FieldListObject &rhsFieldListObject, int &result) const
00907 {
00908     if ((!IsInitialized()) || (!rhsFieldListObject.IsInitialized()))
00909         return STATUS_CODE_NOT_INITIALIZED;
00910
00911     return GetFieldList().CompareField(fieldId, Get(), rhsFieldListObject.GetFieldList(), fieldId, rhsFieldListObject.Get(), result);
00912 }
00913
00914 // ---------------------------------------------------------------------------------------------------------------------------------
00915
00916 inline StatusCode FieldListObject::CompareField(const FieldSpecification::Id lhsFieldId, const FieldListObject &rhsFieldListObject, const FieldSpecification::Id rhsFieldId, int &result) const
00917 {
00918     if ((!IsInitialized()) || (!rhsFieldListObject.IsInitialized()))
00919         return STATUS_CODE_NOT_INITIALIZED;
00920
00921     return GetFieldList().CompareField(lhsFieldId, Get(), rhsFieldListObject.GetFieldList(), rhsFieldId, rhsFieldListObject.Get(), result);
00922 }
00923
00924 // ---------------------------------------------------------------------------------------------------------------------------------
00925
00926 inline StatusCode FieldListObject::IsFieldDifferent(const FieldSpecification::Id fieldId, const void *pField, const size_t fieldLength, bool &result) const
00927 {
00928     if (!IsInitialized())
00929         return STATUS_CODE_NOT_INITIALIZED;
00930
00931     return GetFieldList().IsFieldDifferent(fieldId, Get(), pField, fieldLength, result);
00932 }
00933
00934 // ---------------------------------------------------------------------------------------------------------------------------------
00935
00936 inline StatusCode FieldListObject::IsFieldDifferent(const FieldSpecification::Id fieldId, const IFieldType &iFieldType, bool &result) const
00937 {
00938     if (!IsInitialized())
00939         return STATUS_CODE_NOT_INITIALIZED;
00940
00941     return GetFieldList().IsFieldDifferent(fieldId, Get(), iFieldType, result);
00942 }
00943
00944 // ---------------------------------------------------------------------------------------------------------------------------------
00945
00946 inline StatusCode FieldListObject::IsFieldDifferent(const FieldSpecification::Id fieldId, const std::string &value, bool &result) const
00947 {
00948     if (!IsInitialized())
00949         return STATUS_CODE_NOT_INITIALIZED;
00950
00951     return GetFieldList().IsFieldDifferent(fieldId, Get(), value, result);
00952 }
00953
00954 // ---------------------------------------------------------------------------------------------------------------------------------
00955
00956 inline StatusCode FieldListObject::IsFieldDifferent(const FieldSpecification::Id fieldId, const FieldListObject &rhsFieldListObject, bool &result) const
00957 {
00958     if ((!IsInitialized()) || (!rhsFieldListObject.IsInitialized()))
00959         return STATUS_CODE_NOT_INITIALIZED;
00960
00961     return GetFieldList().IsFieldDifferent(fieldId, Get(), rhsFieldListObject.GetFieldList(), rhsFieldListObject.Get(), result);
00962 }
00963
00964 // ---------------------------------------------------------------------------------------------------------------------------------
00965
00966 inline StatusCode FieldListObject::IsFieldDifferent(const FieldSpecification::Id lhsFieldId, const FieldListObject &rhsFieldListObject, const FieldSpecification::Id rhsFieldId, bool &result) const
00967 {
00968     if ((!IsInitialized()) || (!rhsFieldListObject.IsInitialized()))
00969         return STATUS_CODE_NOT_INITIALIZED;
00970
00971     return GetFieldList().IsFieldDifferent(lhsFieldId, Get(), rhsFieldListObject.GetFieldList(), rhsFieldId, rhsFieldListObject.Get(), result);
00972 }
00973
00974 // ---------------------------------------------------------------------------------------------------------------------------------
00975
00976 inline StatusCode FieldListObject::DefineField(const FieldSpecification::Id fieldId, const size_t fieldLength)
00977 {
00978     return (IsInitialized()) ? GetFieldList().DefineField(Get(), fieldId, fieldLength) : STATUS_CODE_NOT_INITIALIZED;
00979 }
00980
00981 // ---------------------------------------------------------------------------------------------------------------------------------
00982
00983 inline StatusCode FieldListObject::UndefineField(const FieldSpecification::Id fieldId)
00984 {
00985     return (IsInitialized()) ? GetFieldList().UndefineField(Get(), fieldId) : STATUS_CODE_NOT_INITIALIZED;
00986 }
00987
00988 // ---------------------------------------------------------------------------------------------------------------------------------
00989
00990 inline StatusCode FieldListObject::UndefineField(const FieldSpecification::Id fieldId, bool &isDifferent)
00991 {
00992     return (IsInitialized()) ? GetFieldList().UndefineField(Get(), fieldId, isDifferent) : STATUS_CODE_NOT_INITIALIZED;
00993 }
00994
00995 // ---------------------------------------------------------------------------------------------------------------------------------
00996
00997 inline StatusCode FieldListObject::IsFieldDefined(const FieldSpecification::Id fieldId, bool &result) const
00998 {
00999     return (IsInitialized()) ? GetFieldList().IsFieldDefined(Get(), fieldId, result) : STATUS_CODE_NOT_INITIALIZED;
01000 }
01001
01002 // ---------------------------------------------------------------------------------------------------------------------------------
01003
01004 inline  StatusCode FieldListObject::GetFieldSpecificationList(FieldSpecificationList &fieldSpecificationList) const
01005 {
01006     if (IsInitialized())
01007     {
01008         fieldSpecificationList = GetFieldList().GetFieldSpecificationList();
01009         return STATUS_CODE_SUCCESS;
01010     }
01011     else
01012         return STATUS_CODE_NOT_INITIALIZED;
01013 }
01014
01015 // ---------------------------------------------------------------------------------------------------------------------------------
01016
01017 inline  StatusCode FieldListObject::GetFieldSpecification(const FieldSpecification::Id fieldId, FieldSpecification &fieldSpecification) const
01018 {
01019     return (IsInitialized()) ? GetFieldList().GetFieldSpecification(fieldId, fieldSpecification) : STATUS_CODE_NOT_INITIALIZED;
01020 }
01021
01022 // ---------------------------------------------------------------------------------------------------------------------------------
01023
01024 inline  StatusCode FieldListObject::GetFieldIdList(FieldIdList &fieldIdList) const
01025 {
01026     if (IsInitialized())
01027     {
01028         fieldIdList = GetFieldList().GetFieldIdList();
01029         return STATUS_CODE_SUCCESS;
01030     }
01031     else
01032         return STATUS_CODE_NOT_INITIALIZED;
01033 }
01034
01035 // ---------------------------------------------------------------------------------------------------------------------------------
01036
01037 inline StatusCode FieldListObject::GetFirstFieldId(FieldSpecification::Id &fieldId) const
01038 {
01039     if (IsInitialized())
01040     {
01041         GetFieldList().GetFirstFieldId(fieldId);
01042         return STATUS_CODE_SUCCESS;
01043     }
01044     else
01045         return STATUS_CODE_NOT_INITIALIZED;
01046 }
01047
01048 // ---------------------------------------------------------------------------------------------------------------------------------
01049
01050 inline StatusCode FieldListObject::GetNextFieldId(FieldSpecification::Id &fieldId) const
01051 {
01052     return (IsInitialized()) ? GetFieldList().GetNextFieldId(fieldId) : STATUS_CODE_NOT_INITIALIZED;
01053 }
01054
01055 // ---------------------------------------------------------------------------------------------------------------------------------
01056
01057 inline StatusCode FieldListObject::GetType(const FieldSpecification::Id fieldId, FieldSpecification::Type &type) const
01058 {
01059     return (IsInitialized()) ? GetFieldList().GetType(fieldId, type) : STATUS_CODE_NOT_INITIALIZED;
01060 }
01061
01062 // ---------------------------------------------------------------------------------------------------------------------------------
01063
01064 inline StatusCode FieldListObject::GetTablePointer(ITable *&pTable) const
01065 {
01066     if (IsInitialized())
01067     {
01068         pTable = m_pTable;
01069         return STATUS_CODE_SUCCESS;
01070     }
01071     else
01072         return STATUS_CODE_NOT_INITIALIZED;
01073 }
01074
01075 // ---------------------------------------------------------------------------------------------------------------------------------
01076
01077 inline byte_t *FieldListObject::Get()
01078 {
01079     return m_pData;
01080 }
01081
01082 // ---------------------------------------------------------------------------------------------------------------------------------
01083
01084 inline const byte_t *FieldListObject::Get() const
01085 {
01086     return m_pData;
01087 }
01088
01089 // ---------------------------------------------------------------------------------------------------------------------------------
01090
01091 inline void FieldListObject::SetId(const DataId id) const
01092 {
01093     m_id = id;
01094 }
01095
01096 // ---------------------------------------------------------------------------------------------------------------------------------
01097
01098 inline DataId FieldListObject::GetId() const
01099 {
01100     return m_id;
01101 }
01102
01103 // ---------------------------------------------------------------------------------------------------------------------------------
01104
01105 inline std::string FieldListObject::ToString() const
01106 {
01107     return (IsInitialized()) ? GetFieldList().ToString(Get()) : std::string("Not initialized\n");
01108 }
01109
01110 // ---------------------------------------------------------------------------------------------------------------------------------
01111
01112 inline std::string FieldListObject::ToLogString() const
01113 {
01114     return (IsInitialized()) ? GetFieldList().ToLogString(Get()) : std::string("Not initialized\n");
01115 }
01116
01117 // ---------------------------------------------------------------------------------------------------------------------------------
01118
01119 inline FieldListObject::ConstIterator FieldListObject::Begin() const
01120 {
01121     return (IsInitialized()) ? GetFieldList().Begin() : ConstIterator();
01122 }
01123
01124 // ---------------------------------------------------------------------------------------------------------------------------------
01125
01126 inline FieldListObject::ConstIterator FieldListObject::End() const
01127 {
01128     return (IsInitialized()) ? GetFieldList().End() : ConstIterator();
01129 }
01130
01131 // ---------------------------------------------------------------------------------------------------------------------------------
01132
01133 inline bool FieldListObject::IsInitialized() const
01134 {
01135     return (m_isInitialized && (m_tableIdentity == m_pTable->GetIdentity()));
01136 }
01137
01138 // ---------------------------------------------------------------------------------------------------------------------------------
01139
01140 inline bool FieldListObject::IsFound(const FieldSpecification::Id fieldId) const
01141 {
01142     return IsInitialized() ? GetFieldList().IsFound(fieldId) : false;
01143 }
01144
01145 // ---------------------------------------------------------------------------------------------------------------------------------
01146
01147 inline const FieldList &FieldListObject::GetFieldList() const
01148 {
01149     return *m_pFieldList;
01150 }
01151
01152 // ---------------------------------------------------------------------------------------------------------------------------------
01153
01154 }   // namespace Database
01155
01156 }   // namespace Activ
01157
01158 // ---------------------------------------------------------------------------------------------------------------------------------
01159 // ---------------------------------------------------------------------------------------------------------------------------------
01160
01169 ACTIV_DATABASE_API inline std::ostream &operator<<(std::ostream &os, const Activ::Database::FieldListObject &rhs)
01170 {
01171     os << rhs.ToString();
01172     return os;
01173 }
01174
01175 // ---------------------------------------------------------------------------------------------------------------------------------
01176
01177 #endif // (!defined ACTIV_DATABASE_FIELD_LIST_OBJECT_H)
Generated on Wed Oct 8 14:01:47 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivContentGatewayApiCommon

FieldSet.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_CONTENT_GATEWAY_API_COMMON_FIELD_SET_H)
00010 #define ACTIV_CONTENT_GATEWAY_API_COMMON_FIELD_SET_H
00011
00012 #include "ActivContentPlatform/ActivContentGatewayApiCommon/External.h"
00013
00014 #include "ActivContentPlatform/ActivFeedCommon/FieldIds.h"
00015
00016 #include "ActivMiddleware/ActivFieldTypes/IFieldType.h"
00017 #include "ActivMiddleware/ActivFieldTypes/Rational.h"
00018
00019 #include "ActivMiddleware/Misc/SerializableContainerHelper.h"
00020
00021 #define HISTORY_SYMBOLSIZE 20
00022
00023 namespace Activ
00024 {
00025
00026 class Date;
00027 class Time;
00028
00029 namespace ContentPlatform
00030 {
00031
00032 namespace ContentGatewayApi
00033 {
00034
00038 #define ACTIV_FIELD_SET_TYPE_LIST(d)                                \
00039     d(FIELD_SET_TYPE_NULL,              "Null"                  )   \
00040     d(FIELD_SET_TYPE_TICK,              "Tick"                  )   \
00041     d(FIELD_SET_TYPE_INTRADAY_BAR,      "IntradayBar"           )   \
00042     d(FIELD_SET_TYPE_HISTORY_BAR,       "HistoryBar"            )   \
00043     d(FIELD_SET_TYPE_CLOSING_BAR,       "ClosingBar"            )   \
00044     d(FIELD_SET_TYPE_OPTION_BAR,        "OptionBar"             )
00045
00046 // ---------------------------------------------------------------------------------------------------------------------------------
00047
00048 enum FieldSetType
00049 {
00050     ACTIV_FIELD_SET_TYPE_LIST(ACTIV_DECLARE_ELEMENT_1_WITH_COMMA)
00051     NUMBER_OF_FIELD_SET_TYPES
00052 };
00053
00054 // ---------------------------------------------------------------------------------------------------------------------------------
00055
00059 #define ACTIV_FIELD_SET_FILTER_STATUS_LIST(d)               \
00060     d(FILTER_STATUS_OK,                 "Ok"            )   \
00061     d(FILTER_STATUS_IGNORE,             "Ignore"        )   \
00062     d(FILTER_STATUS_DONE,               "Done"          )
00063
00064 // ---------------------------------------------------------------------------------------------------------------------------------
00065
00066 //  @brief  Bar price types.
00067
00068 #define BASE_TYPE_LIST(d)                                   \
00069     d(BASE_TYPE_LOW,                    "Low"           )   \
00070     d(BASE_TYPE_OPEN,                   "Open"          )   \
00071     d(BASE_TYPE_HIGH,                   "High"          )   \
00072     d(BASE_TYPE_CLOSE,                  "Close"         )
00073
00074 // ---------------------------------------------------------------------------------------------------------------------------------
00078 #define UPDATE_FIELDSET_STATUS_LIST(d)                      \
00079     d(UPDATE_STATUS_OK,                 "Ok"            )   \
00080     d(UPDATE_STATUS_FLUSH,              "Flush"         )   \
00081     d(UPDATE_STATUS_IGNORE,             "Ignore"        )
00082
00083 // ---------------------------------------------------------------------------------------------------------------------------------
00087 #define FIELDSETLIST_FIND_MODE_LIST(d)                                              \
00088     d(FIND_MODE_LATER,              "The first one later in time"               )   \
00089     d(FIND_MODE_EQUAL_OR_LATER,     "The first one match or later in time"      )   \
00090     d(FIND_MODE_EQUAL,              "exact match in time"                       )   \
00091     d(FIND_MODE_EQUAL_OR_EARLIER,   "The first one match or earlierer in time"  )   \
00092     d(FIND_MODE_EARLIER,            "The first earlier in time"                 )
00093
00094 // ---------------------------------------------------------------------------------------------------------------------------------
00095 // ---------------------------------------------------------------------------------------------------------------------------------
00096
00100 class FieldSet
00101 {
00102 public:
00103     ACTIV_CONTENT_GATEWAY_API_COMMON_API static const std::string   DEFAULT_STRING_FIELD_SEPARATER;
00104
00108     enum UpdateFieldSetStatus
00109     {
00110         UPDATE_FIELDSET_STATUS_LIST(ACTIV_DECLARE_ELEMENT_1_WITH_COMMA)
00111         NUMBER_OF_UPDATE_STATUS
00112     };
00113
00114
00115     enum FilterStatus
00116     {
00117         ACTIV_FIELD_SET_FILTER_STATUS_LIST(ACTIV_DECLARE_ELEMENT_1_WITH_COMMA)
00118         NUMBER_OF_FIELD_SET_FILTERS
00119     };
00120
00121     enum FieldSetListFindMode
00122     {
00123         FIELDSETLIST_FIND_MODE_LIST(ACTIV_DECLARE_ELEMENT_1_WITH_COMMA)
00124         NUMBER_OF_FIELD_SET_LIST_FIND_MODES
00125     };
00126
00130     FieldSet();
00131
00135     ACTIV_CONTENT_GATEWAY_API_COMMON_API virtual ~FieldSet();
00136
00140     virtual void Reset();
00141
00152     ACTIV_CONTENT_GATEWAY_API_COMMON_API virtual StatusCode GetField(const Feed::FieldId fieldId, IFieldType &field) const;
00153
00164     ACTIV_CONTENT_GATEWAY_API_COMMON_API virtual StatusCode SetField(const Feed::FieldId fieldId, const IFieldType &field);
00165
00171     ACTIV_CONTENT_GATEWAY_API_COMMON_API virtual FieldSetType GetType() const;
00172
00178     ACTIV_CONTENT_GATEWAY_API_COMMON_API virtual std::string ToString(const std::string &deliminator = DEFAULT_STRING_FIELD_SEPARATER) const;
00179
00187     ACTIV_CONTENT_GATEWAY_API_COMMON_API virtual StatusCode FromString(const std::string &inputStr, const std::string &deliminator = DEFAULT_STRING_FIELD_SEPARATER);
00188
00197     ACTIV_CONTENT_GATEWAY_API_COMMON_API virtual StatusCode Serialize(MessageBuilder &messageBuilder) const;
00198
00207     ACTIV_CONTENT_GATEWAY_API_COMMON_API virtual StatusCode Deserialize(MessageValidator &messageValidator);
00208
00214     ACTIV_CONTENT_GATEWAY_API_COMMON_API virtual size_t GetSerializedLength() const;
00215
00225     StatusCode ProcessSplit(const int sharesBefore, const int sharesAfter, const Rational::Denominator type);
00226
00232     ACTIV_CONTENT_GATEWAY_API_COMMON_API static size_t GetMaxSerializedLength();
00233
00239     void SetSequence(byte_t sequence);
00240
00246     byte_t GetSequence() const;
00247
00248     ACTIV_CONTENT_GATEWAY_API_COMMON_API static char *RationalToDoubleString(const Rational &rational, char *buffer);
00249
00257     ACTIV_CONTENT_GATEWAY_API_COMMON_API static StatusCode ReadDate(const std::string &input,  const std::string &deliminator, std::string::size_type &startingPos, Date &dateOut);
00258
00266     ACTIV_CONTENT_GATEWAY_API_COMMON_API static StatusCode ReadTime(const std::string &input,  const std::string &deliminator, std::string::size_type &startingPos, Time &timeOut);
00267
00275     ACTIV_CONTENT_GATEWAY_API_COMMON_API static StatusCode ReadDateTime(const std::string &input,  const std::string &deliminator, std::string::size_type &startPos, DateTime &dateTimeOut);
00276
00284     static StatusCode ReadInteger(const std::string &input,  const std::string &deliminator, std::string::size_type &startPos, uint32_t &uintOut);
00285
00293     ACTIV_CONTENT_GATEWAY_API_COMMON_API static StatusCode ReadRationalFromDoubleString(const std::string &input,  const std::string &deliminator, std::string::size_type &startPos, Rational &rationalOut);
00294
00295     static StatusCode FindContentSubstring(const std::string &input,  const std::string &deliminator, std::string::size_type &startPos, std::string &subStringOut);
00296
00297 private:
00298     byte_t m_sequence;
00299 };
00300
00301 // ---------------------------------------------------------------------------------------------------------------------------------
00302 // ---------------------------------------------------------------------------------------------------------------------------------
00303
00304 template <typename OBJECT_TYPE, typename COUNT_TYPE>
00305 class FieldSetList : public std::list<OBJECT_TYPE>
00306 {
00307 public:
00308     typedef typename std::list<OBJECT_TYPE>::iterator Iterator;
00309     typedef typename std::list<OBJECT_TYPE>::const_iterator ConstIterator;
00310     typedef SerializableObjectContainerHelper<std::list<OBJECT_TYPE>, COUNT_TYPE> Serializer;
00311
00325     Iterator Find(const DateTime &dateTime, const bool isReverse, const FieldSet::FieldSetListFindMode findMode, const Iterator &startingPos)
00326     {
00327         //TODO: add updateID match
00328         if(isReverse)
00329             return ReverseFind(dateTime, findMode, startingPos);
00330
00331         //we are dealing with a list that is the latest data first
00332         Iterator iter, iterEnd = std::list<OBJECT_TYPE>::end(), lastIter = std::list<OBJECT_TYPE>::end();
00333
00334         switch(findMode)
00335         {
00336         case FieldSet::FIND_MODE_LATER:
00337             for(iter = startingPos; iter != iterEnd; ++iter)
00338             {
00339                 if( (*iter) <= dateTime)
00340                     break;
00341                 else
00342                     lastIter = iter;
00343             }
00344             break;
00345         case FieldSet::FIND_MODE_EQUAL_OR_LATER:
00346             for(iter = startingPos; iter != iterEnd; ++iter)
00347             {
00348                 if( (*iter) < dateTime)
00349                     break;
00350                 else
00351                     lastIter = iter;
00352             }
00353             break;
00354         case FieldSet::FIND_MODE_EQUAL:
00355             for(iter = startingPos; iter != iterEnd; ++iter)
00356             {
00357                 if( (*iter) == dateTime)
00358                     return iter;
00359             }
00360             break;
00361         case FieldSet::FIND_MODE_EQUAL_OR_EARLIER:
00362             for(iter = startingPos; iter != iterEnd; ++iter)
00363             {
00364                 if( (*iter) <= dateTime)
00365                     return iter;
00366             }
00367             break;
00368         case FieldSet::FIND_MODE_EARLIER:
00369             for(iter = startingPos; iter != iterEnd; ++iter)
00370             {
00371                 if( (*iter) < dateTime)
00372                     return iter;
00373             }
00374             break;
00375         default:
00376             ACTIV_THROW(StatusCodeException, STATUS_CODE_INVALID_PARAMETER);
00377         }
00378         return lastIter;
00379     }
00380
00391     void MergeFieldSets(const bool isReverse, const FieldSetList<OBJECT_TYPE, COUNT_TYPE> &fromList);
00392
00393 protected:
00394     Iterator ReverseFind(const DateTime &dateTime, const FieldSet::FieldSetListFindMode findMode, const Iterator &startingPos)
00395     {
00396         //TODO: add updateID match
00397         //we are dealing with a list that is the earliest data first
00398         Iterator iter, iterEnd = std::list<OBJECT_TYPE>::end(), lastIter = std::list<OBJECT_TYPE>::end();
00399
00400         switch(findMode)
00401         {
00402         case FieldSet::FIND_MODE_LATER:
00403             for(iter = startingPos; iter != iterEnd; ++iter)
00404             {
00405                 if( (*iter) > dateTime)
00406                     return iter;
00407             }
00408             break;
00409         case FieldSet::FIND_MODE_EQUAL_OR_LATER:
00410             for(iter = startingPos; iter != iterEnd; ++iter)
00411             {
00412                 if( (*iter) >= dateTime)
00413                     return iter;
00414             }
00415             break;
00416         case FieldSet::FIND_MODE_EQUAL:
00417             for(iter = startingPos; iter != iterEnd; ++iter)
00418             {
00419                 if( (*iter) == dateTime)
00420                     return iter;
00421             }
00422             break;
00423         case FieldSet::FIND_MODE_EQUAL_OR_EARLIER:
00424             for(iter = startingPos; iter != iterEnd; ++iter)
00425             {
00426                 if( (*iter) > dateTime)
00427                     break;
00428                 else
00429                     lastIter = iter;
00430             }
00431             break;
00432         case FieldSet::FIND_MODE_EARLIER:
00433             for(iter = startingPos; iter != iterEnd; ++iter)
00434             {
00435                 if( (*iter) >= dateTime)
00436                     break;
00437                 else
00438                     lastIter = iter;
00439             }
00440             break;
00441         default:
00442             ACTIV_THROW(StatusCodeException, STATUS_CODE_INVALID_PARAMETER);
00443         }
00444         return lastIter;
00445     }
00446
00447     void ReverseMergeFieldSets(const FieldSetList<OBJECT_TYPE, COUNT_TYPE> &fromList);
00448 };
00449
00450 // ---------------------------------------------------------------------------------------------------------------------------------
00451 // ---------------------------------------------------------------------------------------------------------------------------------
00452
00453 inline FieldSet::FieldSet()
00454 {
00455     Reset();
00456 }
00457
00458 // ---------------------------------------------------------------------------------------------------------------------------------
00459
00460 inline void FieldSet::Reset()
00461 {
00462     m_sequence = 0;
00463 }
00464
00465 // ---------------------------------------------------------------------------------------------------------------------------------
00466
00467 inline void FieldSet::SetSequence(byte_t sequence)
00468 {
00469     m_sequence = sequence;
00470 }
00471
00472 // ---------------------------------------------------------------------------------------------------------------------------------
00473
00474 inline byte_t FieldSet::GetSequence() const
00475 {
00476     return m_sequence;
00477 }
00478
00479 // ---------------------------------------------------------------------------------------------------------------------------------
00480
00481 inline StatusCode FieldSet::FindContentSubstring(const std::string &input,  const std::string &deliminator, std::string::size_type &startPos, std::string &subStringOut)
00482 {
00483     if(startPos == std::string::npos)
00484         return STATUS_CODE_INVALID_PARAMETER;
00485
00486     std::string::size_type endPos = input.find(deliminator, startPos);
00487     subStringOut.assign(input, startPos, endPos - startPos);
00488     if(endPos == std::string::npos)
00489         startPos = endPos;
00490     else
00491         startPos = endPos + deliminator.length();
00492     return STATUS_CODE_SUCCESS;
00493 }
00494
00495 // ---------------------------------------------------------------------------------------------------------------------------------
00496
00497 inline StatusCode FieldSet::ReadInteger(const std::string &input,  const std::string &deliminator, std::string::size_type &startPos, uint32_t &intOut)
00498 {
00499     std::string subString;
00500     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, FieldSet::FindContentSubstring(input, deliminator, startPos, subString));
00501     intOut = static_cast<uint32_t>(std::atoi(subString.c_str()));
00502     return STATUS_CODE_SUCCESS;
00503 }
00504
00505 // ---------------------------------------------------------------------------------------------------------------------------------
00506
00507 inline StatusCode FieldSet::ProcessSplit(const int sharesBefore, const int sharesAfter, const Rational::Denominator type)
00508 {
00509     return STATUS_CODE_NOT_SUPPORTED;
00510 }
00511
00512 // ---------------------------------------------------------------------------------------------------------------------------------
00513
00514 template <typename OBJECT_TYPE, typename COUNT_TYPE>
00515 inline void FieldSetList<OBJECT_TYPE, COUNT_TYPE>::MergeFieldSets(const bool isReverse, const FieldSetList<OBJECT_TYPE, COUNT_TYPE> &fromList)
00516 {
00517     if (isReverse)
00518         return ReverseMergeFieldSets(fromList);
00519     ConstIterator fromIter, fromEnd = fromList.end();
00520     Iterator foundPosition = std::list<OBJECT_TYPE>::begin();
00521
00522     //this list is in normal, or from most recent to earlier
00523     DateTime dateTime;
00524     for (fromIter = fromList.begin(); fromIter != fromEnd; ++fromIter)
00525     {
00526         fromIter->GetDateTime(dateTime);
00527         foundPosition = Find(dateTime, isReverse, FieldSet::FIND_MODE_EQUAL_OR_EARLIER, foundPosition);
00528         if (foundPosition == std::list<OBJECT_TYPE>::end())
00529         {
00530             //we did not find anything that is earlier, add to the front
00531             push_back(*fromIter);
00532         }
00533         else if ((*foundPosition) == dateTime)
00534         {
00535             // we are at the same time, replace use fromList
00536             *foundPosition = *fromIter;
00537         }
00538         else
00539         {
00540             //the item is eariler, just insert
00541             foundPosition = insert(foundPosition, *fromIter);
00542         }
00543     }
00544 }
00545
00546 // ---------------------------------------------------------------------------------------------------------------------------------
00547
00548 template <typename OBJECT_TYPE, typename COUNT_TYPE>
00549 inline void FieldSetList<OBJECT_TYPE, COUNT_TYPE>::ReverseMergeFieldSets(const FieldSetList<OBJECT_TYPE, COUNT_TYPE> &fromList)
00550 {
00551     ConstIterator fromIter, fromEnd = fromList.end();
00552     Iterator foundPosition = std::list<OBJECT_TYPE>::begin();
00553
00554     //this list is in reverse, or from earliest to more recent
00555     DateTime dateTime;
00556     for (fromIter = fromList.begin(); fromIter != fromEnd; ++fromIter)
00557     {
00558         fromIter->GetDateTime(dateTime);
00559         foundPosition = Find(dateTime, true, FieldSet::FIND_MODE_EQUAL_OR_LATER, foundPosition);
00560         if (foundPosition == std::list<OBJECT_TYPE>::end())
00561         {
00562             //we did not find anything that is later, add to the end
00563             push_back(*fromIter);
00564         }
00565         else if ((*foundPosition) == dateTime)
00566         {
00567             // we are at the same time, replace use fromList
00568             *foundPosition = *fromIter;
00569         }
00570         else
00571         {
00572             //the item is eariler, just insert
00573             foundPosition = insert(foundPosition, *fromIter);
00574         }
00575     }
00576 }
00577
00578 } // namespace ContentGatewayApi
00579
00580 } // namespace ContentPlatform
00581
00582 } // namespace Activ
00583
00584 #endif // (!defined ACTIV_CONTENT_GATEWAY_API_COMMON_FIELD_SET_H)
Generated on Wed Oct 8 14:01:45 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivDatabase

FieldSpecification.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_DATABASE_FIELD_SPECIFICATION_H)
00010 #define ACTIV_DATABASE_FIELD_SPECIFICATION_H
00011
00012 #include "ActivMiddleware/ActivFieldTypes/ActivFieldTypes.h"
00013
00014 #include "ActivMiddleware/ActivDatabase/External.h"
00015
00016 #include "ActivMiddleware/ActivDatabase/ActivDatabase.h"
00017
00018 #include <string>
00019
00020 namespace Activ
00021 {
00022
00023 class MessageBuilder;
00024 class MessageValidator;
00025
00026 namespace Database
00027 {
00028
00029 #define ACTIV_DATABASE_FIELD_TYPE_ENUM(type, name, isVariableLength, isString, validate, compare, toString, activFieldType)             type,
00030 #define ACTIV_DATABASE_FIELD_TYPE_SPECIFICATION(type, name, isVariableLength, isString, validate, compare, toString, activFieldType)    { name, isVariableLength, isString, validate, compare, toString },
00031
00032
00035 #define ACTIV_DATABASE_FIELD_TYPE_LIST(d)                                                                                                                                                           \
00036     d(TYPE_NONE,                "None",                 false,  false,  ValidateNoneSpecification,              CompareUnsignedMemory,      BinaryToString,             FIELD_TYPE_UNKNOWN)         \
00037     d(TYPE_BINARY_ARRAY,        "BinaryArray",          false,  true,   ValidateSpecification,                  CompareUnsignedMemory,      BinaryToString,             FIELD_TYPE_BINARY_ARRAY)    \
00038     d(TYPE_BINARY_STRING,       "BinaryString",         true,   true,   ValidateSpecification,                  CompareUnsignedMemory,      BinaryToString,             FIELD_TYPE_BINARY_STRING)   \
00039     d(TYPE_BITMAP,              "Bitmap",               false,  false,  ValidateSpecification,                  CompareUnsignedMemory,      BinaryToString,             FIELD_TYPE_UNKNOWN)         \
00040     d(TYPE_BLOB,                "Blob",                 true,   false,  ValidateBlobSpecification,              CompareBlob,                BlobToString,               FIELD_TYPE_BLOB)            \
00041     d(TYPE_DATE,                "Date",                 false,  false,  ValidateDateSpecification,              CompareDate,                DateToString,               FIELD_TYPE_DATE)            \
00042     d(TYPE_DATE_TIME,           "DateTime",             false,  false,  ValidateDateTimeSpecification,          CompareDateTime,            DateTimeToString,           FIELD_TYPE_DATE_TIME)       \
00043     d(TYPE_POINTER,             "Pointer",              false,  false,  ValidateSpecification,                  CompareUnsignedMemory,      BinaryToString,             FIELD_TYPE_UNKNOWN)         \
00044     d(TYPE_RATIONAL,            "Rational",             true,   false,  ValidateRationalSpecification,          CompareRational,            RationalToString,           FIELD_TYPE_RATIONAL)        \
00045     d(TYPE_SIGNED_INTEGRAL,     "SInt",                 false,  false,  ValidateSignedIntegralSpecification,    CompareSignedIntegral,      SignedIntegralToString,     FIELD_TYPE_SINT)            \
00046     d(TYPE_TEXT_ARRAY,          "TextArray",            false,  true,   ValidateSpecification,                  CompareUnsignedMemory,      TextToString,               FIELD_TYPE_TEXT_ARRAY)      \
00047     d(TYPE_TEXT_STRING,         "TextString",           true,   true,   ValidateSpecification,                  CompareUnsignedMemory,      TextToString,               FIELD_TYPE_TEXT_STRING)     \
00048     d(TYPE_TIME,                "Time",                 false,  false,  ValidateTimeSpecification,              CompareTime,                TimeToString,               FIELD_TYPE_TIME)            \
00049     d(TYPE_TRATIONAL,           "TRational",            true,   false,  ValidateTRationalSpecification,         CompareTRational,           TRationalToString,          FIELD_TYPE_TRATIONAL)       \
00050     d(TYPE_UNSIGNED_INTEGRAL,   "UInt",                 false,  false,  ValidateUnsignedIntegralSpecification,  CompareUnsignedIntegral,    UnsignedIntegralToString,   FIELD_TYPE_UINT)            \
00051     d(TYPE_BOOLEAN,             "Boolean",              false,  false,  ValidateBooleanSpecification,           CompareUnsignedIntegral,    BooleanToString,            FIELD_TYPE_UNKNOWN)         \
00052     d(TYPE_CRC_BLOB,            "CrcBlob",              true,   false,  ValidateCrcBlobSpecification,           CompareCrcBlob,             CrcBlobToString,            FIELD_TYPE_CRC_BLOB)
00053
00054 // ---------------------------------------------------------------------------------------------------------------------------------
00055
00056 #define ACTIV_DATABASE_FIELD_ENUM(id, name, type, maxLength, offset, properties)            id,
00057 #define ACTIV_DATABASE_FIELD_SPECIFICATION(id, name, type, maxLength, offset, properties)   Activ::Database::FieldSpecification(id, name, Activ::Database::FieldSpecification::type, maxLength, offset, Activ::Database::FieldSpecification::properties),
00058
00059 // ---------------------------------------------------------------------------------------------------------------------------------
00060
00064 class FieldSpecification
00065 {
00066 public:
00070     typedef uint16_t Id;
00071
00075     enum Type
00076     {
00077         ACTIV_DATABASE_FIELD_TYPE_LIST(ACTIV_DATABASE_FIELD_TYPE_ENUM)
00078         NUMBER_OF_TYPES
00079     };
00080
00085     enum
00086     {
00087         PROPERTY_NONE = 0x0000000
00088         //PROPERTY_NOT_NULL = 0x00000001,
00089         //PROPERTY_REMOTE_MODIFY_DISABLED = 0x00000002,
00090 //      PROPERTY_RESERVED = 0x80000000,     // This is a place holder for the descending property of index fields and should not be removed.
00091     };
00092     typedef uint32_t Properties;
00093
00097     ACTIV_DATABASE_API FieldSpecification();
00098
00111     ACTIV_DATABASE_API FieldSpecification(const Id id, const std::string &name, const Type type, const size_t maxLength, const size_t offset = 0, const Properties properties = PROPERTY_NONE);
00112
00120     ACTIV_DATABASE_API bool operator==(const FieldSpecification &rhs) const;
00121
00129     ACTIV_DATABASE_API bool operator!=(const FieldSpecification &rhs) const;
00130
00138     ACTIV_DATABASE_API bool operator<(const FieldSpecification &rhs) const;
00139
00145     ACTIV_DATABASE_API void Validate() const;
00146
00157     ACTIV_DATABASE_API StatusCode Serialize(MessageBuilder &messageBuilder) const;
00158
00169     ACTIV_DATABASE_API StatusCode Deserialize(MessageValidator &messageValidator);
00170
00180     ACTIV_DATABASE_API static StatusCode GetDatabaseFieldType(const FieldType activFieldType, FieldSpecification::Type &databaseFieldType);
00181
00191     ACTIV_DATABASE_API static StatusCode GetActivFieldType(const FieldSpecification::Type databaseFieldType, FieldType &activFieldType);
00192
00200     ACTIV_DATABASE_API bool IsMatch(const FieldSpecification &rhs) const;
00201
00207     ACTIV_DATABASE_API std::string ToString() const;
00208
00214     ACTIV_DATABASE_API static std::string ToFormattedHeaderString();
00215
00221     ACTIV_DATABASE_API std::string ToFormattedString() const;
00222
00223     static const Id UNDEFINED_FIELD_ID  = ~0;
00224
00225     Id              m_id;
00226     std::string     m_name;
00227     Type            m_type;
00228     size_t          m_maxLength;
00229     size_t          m_offset;
00230     uint32_t        m_properties;
00231 };
00232
00233 }   // namespace Database
00234
00235 }   // namespace Activ
00236
00237 // ---------------------------------------------------------------------------------------------------------------------------------
00238
00247 ACTIV_DATABASE_API std::ostream &operator<<(std::ostream &os, const Activ::Database::FieldSpecification &rhs);
00248
00249 // ---------------------------------------------------------------------------------------------------------------------------------
00250
00251 #endif // (!defined ACTIV_DATABASE_FIELD_SPECIFICATION_H)
Generated on Wed Oct 8 14:01:47 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedApiCommon

FieldStatus.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FEED_API_COMMON_FIELD_STATUS_H)
00010 #define ACTIV_FEED_API_COMMON_FIELD_STATUS_H
00011
00012 #include "ActivContentPlatform/ActivFeedApiCommon/External.h"
00013
00014 namespace Activ
00015 {
00016
00017 namespace ContentPlatform
00018 {
00019
00020 namespace FeedApi
00021 {
00022
00026 #define ACTIV_FIELD_STATUS_TYPE_LIST(d)                         \
00027     d(0,    FIELD_STATUS_DEFINED,           "defined")          \
00028     d(1,    FIELD_STATUS_UNDEFINED,         "undefined")        \
00029     d(2,    FIELD_STATUS_NOT_FOUND,         "not found")        \
00030     d(3,    FIELD_STATUS_NOT_PERMISSIONED,  "not permissioned")
00031
00032 typedef uint8_t FieldStatus;
00033
00034 #define ACTIV_DECLARE_CONSTANT_FIELD_STATUS(val, id, name)  const FieldStatus id = val;
00035
00036 ACTIV_FIELD_STATUS_TYPE_LIST(ACTIV_DECLARE_CONSTANT_FIELD_STATUS)
00037
00038 #undef ACTIV_DECLARE_CONSTANT_FIELD_STATUS
00039
00047 ACTIV_FEED_API_COMMON_API std::string FieldStatusToString(const FieldStatus fieldStatus);
00048
00049 } // namespace FeedApi
00050
00051 } // namespace ContentPlatform
00052
00053 } // namespace Activ
00054
00055 #endif // (!defined ACTIV_FEED_API_COMMON_FIELD_STATUS_H)
Generated on Wed Oct 8 14:01:45 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivFieldTypes

FieldTypeFactory.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FIELD_TYPES_FIELD_TYPE_FACTORY_H)
00010 #define ACTIV_FIELD_TYPES_FIELD_TYPE_FACTORY_H
00011
00012 #include "ActivMiddleware/ActivFieldTypes/External.h"
00013 #include "ActivMiddleware/ActivFieldTypes/ActivFieldTypes.h"
00014 #include "ActivMiddleware/Misc/Singleton.h"
00015
00016 namespace Activ
00017 {
00018
00019 class MessageValidator;
00020 class IFieldType;
00021
00022 // ---------------------------------------------------------------------------------------------------------------------------------
00023
00027 class FieldTypeFactory : public Singleton<FieldTypeFactory>
00028 {
00029 public:
00037     ACTIV_FIELD_TYPES_API IFieldType *Create(const FieldType fieldType) const;
00038
00046     ACTIV_FIELD_TYPES_API IFieldType *Clone(const IFieldType * const pIFieldType) const;
00047
00056     ACTIV_FIELD_TYPES_API IFieldType *Convert(const FieldType fieldType, const IFieldType * const pIFieldType) const;
00057
00063     ACTIV_FIELD_TYPES_API static FieldTypeFactory &GetInstance();
00064
00065 private:
00069     ACTIV_FIELD_TYPES_API FieldTypeFactory();
00070
00071     friend class Singleton<FieldTypeFactory>;
00072 };
00073
00074 } // namespace Activ
00075
00076 #endif // (!defined ACTIV_FIELD_TYPES_FIELD_TYPE_FACTORY_H)
Generated on Wed Oct 8 14:01:48 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

File.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_BASE_FILE_H)
00010 #define ACTIV_BASE_FILE_H
00011
00012 #include "ActivMiddleware/ActivBase/External.h"
00013
00014 #include <string>
00015
00016 namespace Activ
00017 {
00018
00022 class File : private boost::noncopyable
00023 {
00024 public:
00025     typedef uint32_t AccessFlags;
00026     static const AccessFlags ACCESS_FLAG_READ = 0x00000001;
00027     static const AccessFlags ACCESS_FLAG_WRITE = 0x00000002;
00028
00029     typedef uint32_t ShareFlags;
00030     static const ShareFlags SHARE_FLAG_READ = 0x00000001;
00031     static const ShareFlags SHARE_FLAG_WRITE = 0x00000002;
00032
00036     enum SeekMethod
00037     {
00038         SEEK_METHOD_BEGIN,
00039         SEEK_METHOD_END,
00040         SEEK_METHOD_CURRENT
00041     };
00042
00046     ACTIV_BASE_EXPORTED_API File();
00047
00051     ACTIV_BASE_EXPORTED_API ~File();
00052
00064     ACTIV_BASE_EXPORTED_API StatusCode Create(const std::string &fileName, const AccessFlags accessFlags,
00065         const ShareFlags shareFlags);
00066
00078     ACTIV_BASE_EXPORTED_API StatusCode Open(const std::string &fileName, const AccessFlags accessFlags,
00079         const ShareFlags shareFlags);
00080
00088     ACTIV_BASE_EXPORTED_API StatusCode Close();
00089
00101     ACTIV_BASE_EXPORTED_API StatusCode Read(void *pBuffer, const size_t nBytesToRead, size_t &nBytesRead);
00102
00114     ACTIV_BASE_EXPORTED_API StatusCode Read(void *pBuffer, const size_t nBytesToRead);
00115
00127     ACTIV_BASE_EXPORTED_API StatusCode ReadLine(std::string &line, std::string &endOfLine);
00128
00140     ACTIV_BASE_EXPORTED_API StatusCode Write(const void *pBuffer, const size_t nBytesToWrite, size_t &nBytesWritten);
00141
00153     ACTIV_BASE_EXPORTED_API StatusCode Write(const void *pBuffer, const size_t nBytesToWrite);
00154
00164     ACTIV_BASE_EXPORTED_API StatusCode GetPosition(int64_t &position) const;
00165
00176     ACTIV_BASE_EXPORTED_API StatusCode SetPosition(int64_t position, const SeekMethod seekMethod = SEEK_METHOD_BEGIN);
00177
00188     ACTIV_BASE_EXPORTED_API StatusCode GetSize(int64_t &size) const;
00189
00199     ACTIV_BASE_EXPORTED_API StatusCode SetSize(int64_t size);
00200
00210     ACTIV_BASE_EXPORTED_API StatusCode GetLastWriteDateTime(std::tm &tm) const;
00211
00221     ACTIV_BASE_EXPORTED_API StatusCode GetCreationDateTime(std::tm &tm) const;
00222
00232     ACTIV_BASE_EXPORTED_API StatusCode GetLastAccessDateTime(std::tm &tm) const;
00233
00242     ACTIV_BASE_EXPORTED_API StatusCode GetFileName(std::string &fileName) const;
00243
00249     ACTIV_BASE_INLINE_API HANDLE GetHandle() const;
00250
00256     ACTIV_BASE_EXPORTED_API bool IsOpen() const;
00257
00269     ACTIV_BASE_EXPORTED_API static StatusCode Copy(const std::string &sourceFileName, const std::string &targetFileName,
00270         bool replaceExisting = false);
00271
00280     ACTIV_BASE_EXPORTED_API static StatusCode Remove(const std::string &fileName);
00281
00292     ACTIV_BASE_EXPORTED_API static StatusCode Rename(const std::string &sourceFileName, const std::string &targetFileName,
00293         bool replaceExisting = false);
00294
00306     ACTIV_BASE_EXPORTED_API static StatusCode GetSize(const std::string &fileName, int64_t &size);
00307
00318     ACTIV_BASE_EXPORTED_API static StatusCode GetLastWriteDateTime(const std::string &fileName, std::tm &tm);
00319
00330     ACTIV_BASE_EXPORTED_API static StatusCode GetCreationDateTime(const std::string &fileName, std::tm &tm);
00331
00342     ACTIV_BASE_EXPORTED_API static StatusCode GetLastAccessDateTime(const std::string &fileName, std::tm &tm);
00343
00351     ACTIV_BASE_EXPORTED_API static bool IsFound(const std::string &fileName);
00352
00360     ACTIV_BASE_EXPORTED_API static bool IsDirectory(const std::string &pathName);
00361
00367     ACTIV_BASE_EXPORTED_API static const std::string &GetEndOfLine();
00368
00374     ACTIV_BASE_EXPORTED_API static char GetDirectorySeparator();
00375
00384     ACTIV_BASE_EXPORTED_API static std::string GetTemporaryPath();
00385
00394     ACTIV_BASE_EXPORTED_API static std::string MakePath(const std::string &directory, const std::string &fileName);
00395
00403     ACTIV_BASE_EXPORTED_API static std::string MakeAbsolutePath(const std::string &path);
00404
00442     ACTIV_BASE_EXPORTED_API static void SplitPath(const std::string &path, std::string &directory, std::string &fileName);
00443
00451     ACTIV_BASE_EXPORTED_API static std::string ExpandPath(const std::string &path);
00452
00466     ACTIV_BASE_EXPORTED_API static StatusCode SearchPath(const std::string &fileName, std::string &fullyQualifiedFileName);
00467
00475     ACTIV_BASE_EXPORTED_API static bool IsFileNameOnly(const std::string &pathName);
00476
00477 private:
00478     std::string m_fileName;
00479     HANDLE      m_fileHandle;
00480 };
00481
00482 // ---------------------------------------------------------------------------------------------------------------------------------
00483
00484 inline HANDLE File::GetHandle() const
00485 {
00486     return m_fileHandle;
00487 }
00488
00489 } // namespace Activ
00490
00491 #endif // (!defined ACTIV_BASE_FILE_H)
Generated on Wed Oct 8 14:01:47 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

FileMappedMemoryFactory.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_BASE_FILE_MAPPED_MEMORY_FACTORY_H)
00010 #define ACTIV_BASE_FILE_MAPPED_MEMORY_FACTORY_H
00011
00012 #include "ActivMiddleware/ActivBase/External.h"
00013 #include "ActivMiddleware/ActivBase/IFileMappedMemory.h"
00014 #include "ActivMiddleware/ActivBase/Timeout.h"
00015 #include "ActivMiddleware/Misc/Singleton.h"
00016
00017 #include <string>
00018
00019 namespace Activ
00020 {
00021
00025 class FileMappedMemoryFactory : public Singleton<FileMappedMemoryFactory>
00026 {
00027 public:
00041     ACTIV_BASE_EXPORTED_API IFileMappedMemory *Create(const std::string &fileName, const size_t size, const bool canShare,
00042         const IFileMappedMemory::FileFlags fileFlags = IFileMappedMemory::FILE_FLAG_NONE,
00043         const IMappedMemory::MappingFlags mappingFlags = IMappedMemory::MAPPING_FLAG_NONE);
00044
00057     ACTIV_BASE_EXPORTED_API IFileMappedMemory *Open(const std::string &fileName,
00058         const IFileMappedMemory::FileFlags fileFlags = IFileMappedMemory::FILE_FLAG_NONE,
00059         const IMappedMemory::MappingFlags mappingFlags = IMappedMemory::MAPPING_FLAG_NONE,
00060         Timeout &timeout = Timeout::GetInfinite());
00061
00067     ACTIV_BASE_EXPORTED_API static FileMappedMemoryFactory &GetInstance();
00068
00069 private:
00073     ACTIV_BASE_EXPORTED_API FileMappedMemoryFactory();
00074
00075     friend class Singleton<FileMappedMemoryFactory>;
00076 };
00077
00078 } // namespace Activ
00079
00080 #endif // (!defined ACTIV_BASE_FILE_MAPPED_MEMORY_FACTORY_H)
Generated on Wed Oct 8 14:01:47 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware

FormatSpecifiers.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FORMAT_SPECIFIERS_H)
00010 #define ACTIV_FORMAT_SPECIFIERS_H
00011
00012 #if (defined ACTIV_PLATFORM_BSD) || (defined ACTIV_PLATFORM_OSX) || (defined ACTIV_PLATFORM_LINUX)
00013 #define __SIZE_T_PREFIX "z"
00014 #elif (defined ACTIV_PLATFORM_SOLARIS)
00015 #define __SIZE_T_PREFIX "l" // lowercase 'el'
00016 #elif (defined ACTIV_PLATFORM_WINDOWS)
00017 #if (defined ACTIV_COMPILER_VISUAL_C) || (defined ACTIV_COMPILER_INTEL) || ((defined ACTIV_COMPILER_GCC) && (!defined __CYGWIN__))
00018 // NB when using -mno-cygwin with GCC on Windows, we use MS c runtime, hence I for size_t format specifiers
00019 #define ACTIV_USE_MICROSOFT_RUNTIME
00020 #define __SIZE_T_PREFIX "I" // uppercase 'aye'
00021 #elif (defined ACTIV_COMPILER_GCC)
00022 #define __SIZE_T_PREFIX "z"
00023 #else
00024 #error Configure for this compiler
00025 #endif
00026 #else
00027 #error Configure for this platform
00028 #endif
00029
00030 // size_t printing macros
00031 #define PRIdSIZE        __SIZE_T_PREFIX "d"
00032 #define PRIiSIZE        __SIZE_T_PREFIX "i"
00033 #define PRIoSIZE        __SIZE_T_PREFIX "o"
00034 #define PRIuSIZE        __SIZE_T_PREFIX "u"
00035 #define PRIxSIZE        __SIZE_T_PREFIX "x"
00036 #define PRIXSIZE        __SIZE_T_PREFIX "X"
00037
00038 // size_t scanning macros
00039 #define SCNdSIZE        __SIZE_T_PREFIX "d"
00040 #define SCNiSIZE        __SIZE_T_PREFIX "i"
00041 #define SCNuSIZE        __SIZE_T_PREFIX "u"
00042 #define SCNoSIZE        __SIZE_T_PREFIX "o"
00043 #define SCNxSIZE        __SIZE_T_PREFIX "x"
00044
00045 #if (defined ACTIV_HAS_INTTYPES_H)
00046 #include <inttypes.h>
00047 #else
00048
00049 #if (defined ACTIV_USE_MICROSOFT_RUNTIME)
00050 // NB when using -mno-cygwin with GCC on Windows, we use MS c runtime, hence I64 for 64-bit format specifiers
00051 #define __PRI64_PREFIX  "I64"
00052 #define __PRIPTR_PREFIX
00053 #elif (defined ACTIV_COMPILER_GCC)
00054 #if (ACTIV_PROCESSOR_WORD_SIZE == 64)
00055 #define __PRI64_PREFIX  "l"
00056 #define __PRIPTR_PREFIX "l"
00057 #elif (ACTIV_PROCESSOR_WORD_SIZE == 32)
00058 #define __PRI64_PREFIX  "ll"
00059 #define __PRIPTR_PREFIX
00060 #else
00061 #error Configure for this word size on GCC
00062 #endif // ACTIV_PROCESSOR_WORD_SIZE
00063 #else
00064 #error Configure for this compiler
00065 #endif
00066
00067 // printing macros
00068 #define PRId8           "d"
00069 #define PRId16          "d"
00070 #define PRId32          "d"
00071 #define PRId64          __PRI64_PREFIX "d"
00072
00073 #define PRIdLEAST8      "d"
00074 #define PRIdLEAST16     "d"
00075 #define PRIdLEAST32     "d"
00076 #define PRIdLEAST64     __PRI64_PREFIX "d"
00077
00078 #define PRIdFAST8       "d"
00079 #define PRIdFAST16      "d"
00080 #define PRIdFAST32      "d"
00081 #define PRIdFAST64      __PRI64_PREFIX "d"
00082
00083 #define PRIi8           "i"
00084 #define PRIi16          "i"
00085 #define PRIi32          "i"
00086 #define PRIi64          __PRI64_PREFIX "i"
00087
00088 #define PRIiLEAST8      "i"
00089 #define PRIiLEAST16     "i"
00090 #define PRIiLEAST32     "i"
00091 #define PRIiLEAST64     __PRI64_PREFIX "i"
00092
00093 #define PRIiFAST8       "i"
00094 #define PRIiFAST16      "i"
00095 #define PRIiFAST32      "i"
00096 #define PRIiFAST64      __PRI64_PREFIX "i"
00097
00098 #define PRIo8           "o"
00099 #define PRIo16          "o"
00100 #define PRIo32          "o"
00101 #define PRIo64          __PRI64_PREFIX "o"
00102
00103 #define PRIoLEAST8      "o"
00104 #define PRIoLEAST16     "o"
00105 #define PRIoLEAST32     "o"
00106 #define PRIoLEAST64     __PRI64_PREFIX "o"
00107
00108 #define PRIoFAST8       "o"
00109 #define PRIoFAST16      "o"
00110 #define PRIoFAST32      "o"
00111 #define PRIoFAST64      __PRI64_PREFIX "o"
00112
00113 #define PRIu8           "u"
00114 #define PRIu16          "u"
00115 #define PRIu32          "u"
00116 #define PRIu64          __PRI64_PREFIX "u"
00117
00118 #define PRIuLEAST8      "u"
00119 #define PRIuLEAST16     "u"
00120 #define PRIuLEAST32     "u"
00121 #define PRIuLEAST64     __PRI64_PREFIX "u"
00122
00123 #define PRIuFAST8       "u"
00124 #define PRIuFAST16      "u"
00125 #define PRIuFAST32      "u"
00126 #define PRIuFAST64      __PRI64_PREFIX "u"
00127
00128 #define PRIx8           "x"
00129 #define PRIx16          "x"
00130 #define PRIx32          "x"
00131 #define PRIx64          __PRI64_PREFIX "x"
00132
00133 #define PRIxLEAST8      "x"
00134 #define PRIxLEAST16     "x"
00135 #define PRIxLEAST32     "x"
00136 #define PRIxLEAST64     __PRI64_PREFIX "x"
00137
00138 #define PRIxFAST8       "x"
00139 #define PRIxFAST16      "x"
00140 #define PRIxFAST32      "x"
00141 #define PRIxFAST64      __PRI64_PREFIX "x"
00142
00143 #define PRIX8           "X"
00144 #define PRIX16          "X"
00145 #define PRIX32          "X"
00146 #define PRIX64          __PRI64_PREFIX "X"
00147
00148 #define PRIXLEAST8      "X"
00149 #define PRIXLEAST16     "X"
00150 #define PRIXLEAST32     "X"
00151 #define PRIXLEAST64     __PRI64_PREFIX "X"
00152
00153 #define PRIXFAST8       "X"
00154 #define PRIXFAST16      "X"
00155 #define PRIXFAST32      "X"
00156 #define PRIXFAST64      __PRI64_PREFIX "X"
00157
00158 // scanning macros
00159 // NB Visual C++ seemingly doesn't support scanning 8 bit integer value.
00160 #define SCNd16          "hd"
00161 #define SCNd32          "d"
00162 #define SCNd64          __PRI64_PREFIX "d"
00163
00164 #define SCNdLEAST16     "hd"
00165 #define SCNdLEAST32     "d"
00166 #define SCNdLEAST64     __PRI64_PREFIX "d"
00167
00168 #define SCNdFAST16      __PRIPTR_PREFIX "d"
00169 #define SCNdFAST32      __PRIPTR_PREFIX "d"
00170 #define SCNdFAST64      __PRI64_PREFIX "d"
00171
00172 #define SCNi16          "hi"
00173 #define SCNi32          "i"
00174 #define SCNi64          __PRI64_PREFIX "i"
00175
00176 #define SCNiLEAST16     "hi"
00177 #define SCNiLEAST32     "i"
00178 #define SCNiLEAST64     __PRI64_PREFIX "i"
00179
00180 #define SCNiFAST16      __PRIPTR_PREFIX "i"
00181 #define SCNiFAST32      __PRIPTR_PREFIX "i"
00182 #define SCNiFAST64      __PRI64_PREFIX "i"
00183
00184 #define SCNu16          "hu"
00185 #define SCNu32          "u"
00186 #define SCNu64          __PRI64_PREFIX "u"
00187
00188 #define SCNuLEAST16     "hu"
00189 #define SCNuLEAST32     "u"
00190 #define SCNuLEAST64     __PRI64_PREFIX "u"
00191
00192 #define SCNuFAST16      __PRIPTR_PREFIX "u"
00193 #define SCNuFAST32      __PRIPTR_PREFIX "u"
00194 #define SCNuFAST64      __PRI64_PREFIX "u"
00195
00196 #define SCNo16          "ho"
00197 #define SCNo32          "o"
00198 #define SCNo64          __PRI64_PREFIX "o"
00199
00200 #define SCNoLEAST16     "ho"
00201 #define SCNoLEAST32     "o"
00202 #define SCNoLEAST64     __PRI64_PREFIX "o"
00203
00204 #define SCNoFAST16      __PRIPTR_PREFIX "o"
00205 #define SCNoFAST32      __PRIPTR_PREFIX "o"
00206 #define SCNoFAST64      __PRI64_PREFIX "o"
00207
00208 #define SCNx16          "hx"
00209 #define SCNx32          "x"
00210 #define SCNx64          __PRI64_PREFIX "x"
00211
00212 #define SCNxLEAST16     "hx"
00213 #define SCNxLEAST32     "x"
00214 #define SCNxLEAST64     __PRI64_PREFIX "x"
00215
00216 #define SCNxFAST16      __PRIPTR_PREFIX "x"
00217 #define SCNxFAST32      __PRIPTR_PREFIX "x"
00218 #define SCNxFAST64      __PRI64_PREFIX "x"
00219
00220 #endif // (defined ACTIV_HAS_INTTYPES_H)
00221
00222 #endif // (!defined ACTIV_FORMAT_SPECIFIERS_H)
Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » Misc

FtpHelper.h

Go to the documentation of this file.
00001
00011 #if (!defined ACTIV_MISC_FTP_HELPER_H)
00012 #define ACTIV_MISC_FTP_HELPER_H
00013
00014 #include "ActivMiddleware/ActivBase/StatusCodeException.h"
00015 #include "ActivMiddleware/ActivBase/OsException.h"
00016 #include "ActivMiddleware/ActivBase/File.h"
00017 #include "ActivMiddleware/Misc/FtpParse.h"
00018
00019 #include "curl/curl.h"
00020
00021 #include <string>
00022 #include <vector>
00023 #include <time.h>
00024
00025 #include "IFtpHelper.h"
00026 #include "CurlFtpHelper.h"
00027
00028 #if (defined ACTIV_PLATFORM_WINDOWS)
00029 #include "WinFtpHelper.h"
00030 #endif
00031
00032 namespace Activ
00033 {
00034
00038 class FtpHelper : private boost::noncopyable
00039 {
00040 public:
00041
00045      enum FtpType
00046      {
00047         CURL_FTP,
00048         WIN_FTP
00049      };
00050
00060      FtpHelper(const std::string &server, const std::string &username = "", const std::string &password = "", uint32_t port = IFtpHelper::DEFAULT_FTP_PORT, FtpType ftpType = CURL_FTP);
00061
00065      ~FtpHelper();
00066
00070     StatusCodeHelper Connect();
00071
00075     StatusCodeHelper Disconnect();
00076
00083     StatusCodeHelper GetFileList(FileInfoList &fileList, const std::string &remoteDirectory = "");
00084
00092     StatusCodeHelper GetFile(const std::string &remoteFilename, const std::string &localFilename, const std::string &remoteDirectory = "");
00093
00100     StatusCodeHelper DeleteFile(const std::string &remoteFilename, const std::string &remoteDirectory = "");
00101
00102
00103     StatusCodeHelper DeleteFile(const FileInfoList &fileInfoList, const std::string &remoteDirectory = "");
00104
00112     StatusCodeHelper GetAndDeleteFile(const std::string &remoteFilename, const std::string &localFilename, const std::string &remoteDirectory = "");
00113
00117     bool IsConnected() const;
00118
00119 protected:
00120
00121     IFtpHelper *m_pFtpHelper;
00122
00123 };
00124
00125 // ---------------------------------------------------------------------------------------------------------------------------------
00126
00127 inline FtpHelper::FtpHelper(const std::string &server, const std::string &username, const std::string &password, uint32_t port, FtpType ftpType) :
00128     m_pFtpHelper(0)
00129 {
00130     switch (ftpType)
00131     {
00132
00133 #if (defined ACTIV_PLATFORM_WINDOWS)
00134         case WIN_FTP:
00135             m_pFtpHelper = new WinFtpHelper(server, username, password, port);
00136             break;
00137 #endif
00138
00139         case CURL_FTP:
00140             m_pFtpHelper = new CurlFtpHelper(server, username, password, port);
00141             break;
00142
00143         default:
00144             ACTIV_THROW(StatusCodeException, STATUS_CODE_INVALID_PARAMETER);
00145     }
00146 }
00147
00148 // ---------------------------------------------------------------------------------------------------------------------------------
00149
00150 inline FtpHelper::~FtpHelper()
00151 {
00152     delete m_pFtpHelper;
00153 }
00154
00155 // ---------------------------------------------------------------------------------------------------------------------------------
00156
00157 inline bool FtpHelper::IsConnected() const
00158 {
00159     return m_pFtpHelper->IsConnected();
00160 }
00161
00162 // ---------------------------------------------------------------------------------------------------------------------------------
00163
00164 inline StatusCodeHelper FtpHelper::Connect()
00165 {
00166     return m_pFtpHelper->Connect();
00167 }
00168
00169 // ---------------------------------------------------------------------------------------------------------------------------------
00170
00171 inline StatusCodeHelper FtpHelper::Disconnect()
00172 {
00173     return m_pFtpHelper->Disconnect();
00174 }
00175
00176 // ---------------------------------------------------------------------------------------------------------------------------------
00177
00178 inline StatusCodeHelper FtpHelper::GetFileList(FileInfoList &fileinfoList, const std::string &remoteDirectory)
00179 {
00180     return m_pFtpHelper->GetFileList(fileinfoList, remoteDirectory);
00181 }
00182
00183 // ---------------------------------------------------------------------------------------------------------------------------------
00184
00185 inline StatusCodeHelper FtpHelper::GetFile(const std::string &remoteFilename, const std::string &localFilename, const std::string &remoteDirectory)
00186 {
00187     return m_pFtpHelper->GetFile(remoteFilename, localFilename, remoteDirectory);
00188 }
00189
00190 // ---------------------------------------------------------------------------------------------------------------------------------
00191
00192 inline StatusCodeHelper FtpHelper::DeleteFile(const std::string &remoteFilename, const std::string &remoteDirectory)
00193 {
00194     return m_pFtpHelper->DeleteFile(remoteFilename, remoteDirectory);
00195 }
00196
00197 // ---------------------------------------------------------------------------------------------------------------------------------
00198
00199 inline StatusCodeHelper FtpHelper::DeleteFile(const FileInfoList &fileInfoList, const std::string &remoteDirectory)
00200 {
00201     return m_pFtpHelper->DeleteFile(fileInfoList, remoteDirectory);
00202 }
00203
00204 // ---------------------------------------------------------------------------------------------------------------------------------
00205
00206 inline StatusCodeHelper FtpHelper::GetAndDeleteFile(const std::string &remoteFilename, const std::string &localFilename, const std::string &remoteDirectory)
00207 {
00208     return m_pFtpHelper->GetAndDeleteFile(remoteFilename, localFilename, remoteDirectory);
00209 }
00210
00211 } // namespace Activ
00212
00213 #endif // (!defined ACTIV_MISC_FTP_HELPER_H)
Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » Misc

FtpParse.h

00001 #ifndef FTPPARSE_H
00002 #define FTPPARSE_H
00003
00004 /*
00005 ftpparse(&fp,buf,len) tries to parse one line of LIST output.
00006
00007 The line is an array of len characters stored in buf.
00008 It should not include the terminating CR LF; so buf[len] is typically CR.
00009
00010 If ftpparse() can't find a filename, it returns 0.
00011
00012 If ftpparse() can find a filename, it fills in fp and returns 1.
00013 fp is a struct ftpparse, defined below.
00014 The name is an array of fp.namelen characters stored in fp.name;
00015 fp.name points somewhere within buf.
00016 */
00017
00018 // ---------------------------------------------------------------------------------------------------------------------------------
00019
00020 struct ftpparse {
00021   char *name; /* not necessarily 0-terminated */
00022   int namelen;
00023   int flagtrycwd; /* 0 if cwd is definitely pointless, 1 otherwise */
00024   int flagtryretr; /* 0 if retr is definitely pointless, 1 otherwise */
00025   int sizetype;
00026   long size; /* number of octets */
00027   int mtimetype;
00028   time_t mtime; /* modification time */
00029   int idtype;
00030   char *id; /* not necessarily 0-terminated */
00031   int idlen;
00032 } ;
00033
00034 #define FTPPARSE_SIZE_UNKNOWN 0
00035 #define FTPPARSE_SIZE_BINARY 1 /* size is the number of octets in TYPE I */
00036 #define FTPPARSE_SIZE_ASCII 2 /* size is the number of octets in TYPE A */
00037
00038 #define FTPPARSE_MTIME_UNKNOWN 0
00039 #define FTPPARSE_MTIME_LOCAL 1 /* time is correct */
00040 #define FTPPARSE_MTIME_REMOTEMINUTE 2 /* time zone and secs are unknown */
00041 #define FTPPARSE_MTIME_REMOTEDAY 3 /* time zone and time of day are unknown */
00042 /*
00043 When a time zone is unknown, it is assumed to be GMT. You may want
00044 to use localtime() for LOCAL times, along with an indication that the
00045 time is correct in the local time zone, and gmtime() for REMOTE* times.
00046 */
00047
00048 #define FTPPARSE_ID_UNKNOWN 0
00049 #define FTPPARSE_ID_FULL 1 /* unique identifier for files on this FTP server */
00050
00051 /* ftpparse.c, ftpparse.h: library for parsing FTP LIST responses
00052 20001223
00053 D. J. Bernstein, djb@cr.yp.to
00054 http://cr.yp.to/ftpparse.html
00055
00056 Commercial use is fine, if you let me know what programs you're using this in.
00057
00058 Currently covered formats:
00059 EPLF.
00060 UNIX ls, with or without gid.
00061 Microsoft FTP Service.
00062 Windows NT FTP Server.
00063 VMS.
00064 WFTPD.
00065 NetPresenz (Mac).
00066 NetWare.
00067 MSDOS.
00068
00069 Definitely not covered:
00070 Long VMS filenames, with information split across two lines.
00071 NCSA Telnet FTP server. Has LIST = NLST (and bad NLST for directories).
00072 */
00073
00074 #include <time.h>
00075
00076 static long totai(long year,long month,long mday)
00077 {
00078   long result;
00079   if (month >= 2) month -= 2;
00080   else { month += 10; --year; }
00081   result = (mday - 1) * 10 + 5 + 306 * month;
00082   result /= 10;
00083   if (result == 365) { year -= 3; result = 1460; }
00084   else result += 365 * (year % 4);
00085   year /= 4;
00086   result += 1461 * (year % 25);
00087   year /= 25;
00088   if (result == 36524) { year -= 3; result = 146096; }
00089   else { result += 36524 * (year % 4); }
00090   year /= 4;
00091   result += 146097 * (year - 5);
00092   result += 11017;
00093   return result * 86400;
00094 }
00095
00096 static int flagneedbase = 1;
00097 static time_t base; /* time() value on this OS at the beginning of 1970 TAI */
00098 static long now; /* current time */
00099 static int flagneedcurrentyear = 1;
00100 static long currentyear; /* approximation to current year */
00101
00102 static void initbase(void)
00103 {
00104   struct tm *t;
00105   if (!flagneedbase) return;
00106
00107   base = 0;
00108   t = gmtime(&base);
00109   base = -(totai(t->tm_year + 1900,t->tm_mon,t->tm_mday) + t->tm_hour * 3600 + t->tm_min * 60 + t->tm_sec);
00110   /* assumes the right time_t, counting seconds. */
00111   /* base may be slightly off if time_t counts non-leap seconds. */
00112   flagneedbase = 0;
00113 }
00114
00115 static void initnow(void)
00116 {
00117   long day;
00118   long year;
00119
00120   initbase();
00121   now = (long)(time((time_t *) 0) - base);
00122
00123   if (flagneedcurrentyear) {
00124     day = now / 86400;
00125     if ((now % 86400) < 0) --day;
00126     day -= 11017;
00127     year = 5 + day / 146097;
00128     day = day % 146097;
00129     if (day < 0) { day += 146097; --year; }
00130     year *= 4;
00131     if (day == 146096) { year += 3; day = 36524; }
00132     else { year += day / 36524; day %= 36524; }
00133     year *= 25;
00134     year += day / 1461;
00135     day %= 1461;
00136     year *= 4;
00137     if (day == 1460) { year += 3; day = 365; }
00138     else { year += day / 365; day %= 365; }
00139     day *= 10;
00140     if ((day + 5) / 306 >= 10) ++year;
00141     currentyear = year;
00142     flagneedcurrentyear = 0;
00143   }
00144 }
00145
00146 /* UNIX ls does not show the year for dates in the last six months. */
00147 /* So we have to guess the year. */
00148 /* Apparently NetWare uses ``twelve months'' instead of ``six months''; ugh. */
00149 /* Some versions of ls also fail to show the year for future dates. */
00150 static long guesstai(long month,long mday)
00151 {
00152   long year;
00153   long t;
00154
00155   initnow();
00156
00157   for (year = currentyear - 1;year < currentyear + 100;++year) {
00158     t = totai(year,month,mday);
00159     if (now - t < 350 * 86400)
00160       return t;
00161   }
00162
00163   return 0;
00164 }
00165
00166 static int check(const char *buf,const char *monthname)
00167 {
00168   if ((buf[0] != monthname[0]) && (buf[0] != monthname[0] - 32)) return 0;
00169   if ((buf[1] != monthname[1]) && (buf[1] != monthname[1] - 32)) return 0;
00170   if ((buf[2] != monthname[2]) && (buf[2] != monthname[2] - 32)) return 0;
00171   return 1;
00172 }
00173
00174 static const char *months[12] = {
00175   "jan","feb","mar","apr","may","jun","jul","aug","sep","oct","nov","dec"
00176 } ;
00177
00178 static int getmonth(char *buf,int len)
00179 {
00180   int i;
00181   if (len == 3)
00182     for (i = 0;i < 12;++i)
00183       if (check(buf,months[i])) return i;
00184   return -1;
00185 }
00186
00187 static long getlong(char *buf,int len)
00188 {
00189   long u = 0;
00190   while (len-- > 0)
00191     u = u * 10 + (*buf++ - '0');
00192   return u;
00193 }
00194
00195 inline int ftpparse(struct ftpparse *fp,char *buf,int len)
00196 {
00197   int i;
00198   int j;
00199   int state;
00200   long size = 0;
00201   long year = 0;
00202   long month = 0;
00203   long mday = 0;
00204   long hour = 0;
00205   long minute = 0;
00206
00207   fp->name = 0;
00208   fp->namelen = 0;
00209   fp->flagtrycwd = 0;
00210   fp->flagtryretr = 0;
00211   fp->sizetype = FTPPARSE_SIZE_UNKNOWN;
00212   fp->size = 0;
00213   fp->mtimetype = FTPPARSE_MTIME_UNKNOWN;
00214   fp->mtime = 0;
00215   fp->idtype = FTPPARSE_ID_UNKNOWN;
00216   fp->id = 0;
00217   fp->idlen = 0;
00218
00219   if (len < 2) /* an empty name in EPLF, with no info, could be 2 chars */
00220     return 0;
00221
00222   switch(*buf) {
00223     /* see http://pobox.com/~djb/proto/eplf.txt */
00224     /* "+i8388621.29609,m824255902,/,\tdev" */
00225     /* "+i8388621.44468,m839956783,r,s10376,\tRFCEPLF" */
00226     case '+':
00227       i = 1;
00228       for (j = 1;j < len;++j) {
00229         if (buf[j] == 9) {
00230           fp->name = buf + j + 1;
00231           fp->namelen = len - j - 1;
00232           return 1;
00233         }
00234         if (buf[j] == ',') {
00235           switch(buf[i]) {
00236             case '/':
00237               fp->flagtrycwd = 1;
00238               break;
00239             case 'r':
00240               fp->flagtryretr = 1;
00241               break;
00242             case 's':
00243               fp->sizetype = FTPPARSE_SIZE_BINARY;
00244               fp->size = getlong(buf + i + 1,j - i - 1);
00245               break;
00246             case 'm':
00247               fp->mtimetype = FTPPARSE_MTIME_LOCAL;
00248               initbase();
00249               fp->mtime = base + getlong(buf + i + 1,j - i - 1);
00250               break;
00251             case 'i':
00252               fp->idtype = FTPPARSE_ID_FULL;
00253               fp->id = buf + i + 1;
00254               fp->idlen = j - i - 1;
00255           }
00256           i = j + 1;
00257         }
00258       }
00259       return 0;
00260
00261     /* UNIX-style listing, without inum and without blocks */
00262     /* "-rw-r--r--   1 root     other        531 Jan 29 03:26 README" */
00263     /* "dr-xr-xr-x   2 root     other        512 Apr  8  1994 etc" */
00264     /* "dr-xr-xr-x   2 root     512 Apr  8  1994 etc" */
00265     /* "lrwxrwxrwx   1 root     other          7 Jan 25 00:17 bin -> usr/bin" */
00266     /* Also produced by Microsoft's FTP servers for Windows: */
00267     /* "----------   1 owner    group         1803128 Jul 10 10:18 ls-lR.Z" */
00268     /* "d---------   1 owner    group               0 May  9 19:45 Softlib" */
00269     /* Also WFTPD for MSDOS: */
00270     /* "-rwxrwxrwx   1 noone    nogroup      322 Aug 19  1996 message.ftp" */
00271     /* Also NetWare: */
00272     /* "d [R----F--] supervisor            512       Jan 16 18:53    login" */
00273     /* "- [R----F--] rhesus             214059       Oct 20 15:27    cx.exe" */
00274     /* Also NetPresenz for the Mac: */
00275     /* "-------r--         326  1391972  1392298 Nov 22  1995 MegaPhone.sit" */
00276     /* "drwxrwxr-x               folder        2 May 10  1996 network" */
00277     case 'b':
00278     case 'c':
00279     case 'd':
00280     case 'l':
00281     case 'p':
00282     case 's':
00283     case '-':
00284
00285       if (*buf == 'd') fp->flagtrycwd = 1;
00286       if (*buf == '-') fp->flagtryretr = 1;
00287       if (*buf == 'l') fp->flagtrycwd = fp->flagtryretr = 1;
00288
00289       state = 1;
00290       i = 0;
00291       for (j = 1;j < len;++j)
00292         if ((buf[j] == ' ') && (buf[j - 1] != ' ')) {
00293           switch(state) {
00294             case 1: /* skipping perm */
00295               state = 2;
00296               break;
00297             case 2: /* skipping nlink */
00298               state = 3;
00299               if ((j - i == 6) && (buf[i] == 'f')) /* for NetPresenz */
00300                 state = 4;
00301               break;
00302             case 3: /* skipping uid */
00303               state = 4;
00304               break;
00305             case 4: /* getting tentative size */
00306               size = getlong(buf + i,j - i);
00307               state = 5;
00308               break;
00309             case 5: /* searching for month, otherwise getting tentative size */
00310               month = getmonth(buf + i,j - i);
00311               if (month >= 0)
00312                 state = 6;
00313               else
00314                 size = getlong(buf + i,j - i);
00315               break;
00316             case 6: /* have size and month */
00317               mday = getlong(buf + i,j - i);
00318               state = 7;
00319               break;
00320             case 7: /* have size, month, mday */
00321               if ((j - i == 4) && (buf[i + 1] == ':')) {
00322                 hour = getlong(buf + i,1);
00323                 minute = getlong(buf + i + 2,2);
00324                 fp->mtimetype = FTPPARSE_MTIME_REMOTEMINUTE;
00325                 initbase();
00326                 fp->mtime = base + guesstai(month,mday) + hour * 3600 + minute * 60;
00327               } else if ((j - i == 5) && (buf[i + 2] == ':')) {
00328                 hour = getlong(buf + i,2);
00329                 minute = getlong(buf + i + 3,2);
00330                 fp->mtimetype = FTPPARSE_MTIME_REMOTEMINUTE;
00331                 initbase();
00332                 fp->mtime = base + guesstai(month,mday) + hour * 3600 + minute * 60;
00333               }
00334               else if (j - i >= 4) {
00335                 year = getlong(buf + i,j - i);
00336                 fp->mtimetype = FTPPARSE_MTIME_REMOTEDAY;
00337                 initbase();
00338                 fp->mtime = base + totai(year,month,mday);
00339               }
00340               else
00341                 return 0;
00342               fp->name = buf + j + 1;
00343               fp->namelen = len - j - 1;
00344               state = 8;
00345               break;
00346             case 8: /* twiddling thumbs */
00347               break;
00348           }
00349           i = j + 1;
00350           while ((i < len) && (buf[i] == ' ')) ++i;
00351         }
00352
00353       if (state != 8)
00354         return 0;
00355
00356       fp->size = size;
00357       fp->sizetype = FTPPARSE_SIZE_BINARY;
00358
00359       if (*buf == 'l')
00360         for (i = 0;i + 3 < fp->namelen;++i)
00361           if (fp->name[i] == ' ')
00362             if (fp->name[i + 1] == '-')
00363               if (fp->name[i + 2] == '>')
00364                 if (fp->name[i + 3] == ' ') {
00365                   fp->namelen = i;
00366                   break;
00367                 }
00368
00369       /* eliminate extra NetWare spaces */
00370       if ((buf[1] == ' ') || (buf[1] == '['))
00371         if (fp->namelen > 3)
00372           if (fp->name[0] == ' ')
00373             if (fp->name[1] == ' ')
00374               if (fp->name[2] == ' ') {
00375                 fp->name += 3;
00376                 fp->namelen -= 3;
00377               }
00378
00379       return 1;
00380   }
00381
00382   /* MultiNet (some spaces removed from examples) */
00383   /* "00README.TXT;1      2 30-DEC-1996 17:44 [SYSTEM] (RWED,RWED,RE,RE)" */
00384   /* "CORE.DIR;1          1  8-SEP-1996 16:09 [SYSTEM] (RWE,RWE,RE,RE)" */
00385   /* and non-MutliNet VMS: */
00386   /* "CII-MANUAL.TEX;1  213/216  29-JAN-1996 03:33:12  [ANONYMOU,ANONYMOUS]   (RWED,RWED,,)" */
00387   for (i = 0;i < len;++i)
00388     if (buf[i] == ';')
00389       break;
00390   if (i < len) {
00391     fp->name = buf;
00392     fp->namelen = i;
00393     if (i > 4)
00394       if (buf[i - 4] == '.')
00395         if (buf[i - 3] == 'D')
00396           if (buf[i - 2] == 'I')
00397             if (buf[i - 1] == 'R') {
00398               fp->namelen -= 4;
00399               fp->flagtrycwd = 1;
00400             }
00401     if (!fp->flagtrycwd)
00402       fp->flagtryretr = 1;
00403     while (buf[i] != ' ') if (++i == len) return 0;
00404     while (buf[i] == ' ') if (++i == len) return 0;
00405     while (buf[i] != ' ') if (++i == len) return 0;
00406     while (buf[i] == ' ') if (++i == len) return 0;
00407     j = i;
00408     while (buf[j] != '-') if (++j == len) return 0;
00409     mday = getlong(buf + i,j - i);
00410     while (buf[j] == '-') if (++j == len) return 0;
00411     i = j;
00412     while (buf[j] != '-') if (++j == len) return 0;
00413     month = getmonth(buf + i,j - i);
00414     if (month < 0) return 0;
00415     while (buf[j] == '-') if (++j == len) return 0;
00416     i = j;
00417     while (buf[j] != ' ') if (++j == len) return 0;
00418     year = getlong(buf + i,j - i);
00419     while (buf[j] == ' ') if (++j == len) return 0;
00420     i = j;
00421     while (buf[j] != ':') if (++j == len) return 0;
00422     hour = getlong(buf + i,j - i);
00423     while (buf[j] == ':') if (++j == len) return 0;
00424     i = j;
00425     while ((buf[j] != ':') && (buf[j] != ' ')) if (++j == len) return 0;
00426     minute = getlong(buf + i,j - i);
00427
00428     fp->mtimetype = FTPPARSE_MTIME_REMOTEMINUTE;
00429     initbase();
00430     fp->mtime = base + totai(year,month,mday) + hour * 3600 + minute * 60;
00431
00432     return 1;
00433   }
00434
00435   /* MSDOS format */
00436   /* 04-27-00  09:09PM       <DIR>          licensed */
00437   /* 07-18-00  10:16AM       <DIR>          pub */
00438   /* 04-14-00  03:47PM                  589 readme.htm */
00439   if ((*buf >= '0') && (*buf <= '9')) {
00440     i = 0;
00441     j = 0;
00442     while (buf[j] != '-') if (++j == len) return 0;
00443     month = getlong(buf + i,j - i) - 1;
00444     while (buf[j] == '-') if (++j == len) return 0;
00445     i = j;
00446     while (buf[j] != '-') if (++j == len) return 0;
00447     mday = getlong(buf + i,j - i);
00448     while (buf[j] == '-') if (++j == len) return 0;
00449     i = j;
00450     while (buf[j] != ' ') if (++j == len) return 0;
00451     year = getlong(buf + i,j - i);
00452     if (year < 50) year += 2000;
00453     if (year < 1000) year += 1900;
00454     while (buf[j] == ' ') if (++j == len) return 0;
00455     i = j;
00456     while (buf[j] != ':') if (++j == len) return 0;
00457     hour = getlong(buf + i,j - i);
00458     while (buf[j] == ':') if (++j == len) return 0;
00459     i = j;
00460     while ((buf[j] != 'A') && (buf[j] != 'P')) if (++j == len) return 0;
00461     minute = getlong(buf + i,j - i);
00462     if (hour == 12) hour = 0;
00463     if (buf[j] == 'A') if (++j == len) return 0;
00464     if (buf[j] == 'P') { hour += 12; if (++j == len) return 0; }
00465     if (buf[j] == 'M') if (++j == len) return 0;
00466
00467     while (buf[j] == ' ') if (++j == len) return 0;
00468     if (buf[j] == '<') {
00469       fp->flagtrycwd = 1;
00470       while (buf[j] != ' ') if (++j == len) return 0;
00471     }
00472     else {
00473       i = j;
00474       while (buf[j] != ' ') if (++j == len) return 0;
00475       fp->size = getlong(buf + i,j - i);
00476       fp->sizetype = FTPPARSE_SIZE_BINARY;
00477       fp->flagtryretr = 1;
00478     }
00479     while (buf[j] == ' ') if (++j == len) return 0;
00480
00481     fp->name = buf + j;
00482     fp->namelen = len - j;
00483
00484     fp->mtimetype = FTPPARSE_MTIME_REMOTEMINUTE;
00485     initbase();
00486     fp->mtime = base + totai(year,month,mday) + hour * 3600 + minute * 60;
00487
00488     return 1;
00489   }
00490
00491   /* Some useless lines, safely ignored: */
00492   /* "Total of 11 Files, 10966 Blocks." (VMS) */
00493   /* "total 14786" (UNIX) */
00494   /* "DISK$ANONFTP:[ANONYMOUS]" (VMS) */
00495   /* "Directory DISK$PCSA:[ANONYM]" (VMS) */
00496
00497   return 0;
00498 }
00499
00500 #endif
Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » Misc

FunctionObjects.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_MISC_FUNCTION_OBJECTS_H)
00010 #define ACTIV_MISC_FUNCTION_OBJECTS_H
00011
00012 #include <algorithm>
00013 #include <functional>
00014
00015 namespace Activ
00016 {
00017
00021 class NullObject
00022 {
00023 public:
00024     template<typename T>
00025     void operator()(const T *ptr) const
00026     {
00027     }
00028 };
00029
00030 // ---------------------------------------------------------------------------------------------------------------------------------
00031 // ---------------------------------------------------------------------------------------------------------------------------------
00032
00038 class DeleteObject
00039 {
00040 public:
00046     template<typename T>
00047     void operator()(const T *ptr) const
00048     {
00049         delete ptr;
00050     }
00051 };
00052
00053 // ---------------------------------------------------------------------------------------------------------------------------------
00054 // ---------------------------------------------------------------------------------------------------------------------------------
00055
00061 class DeleteObjectArray
00062 {
00063     public:
00069     template<typename T>
00070     void operator()(const T *ptr) const
00071     {
00072         delete [] ptr;
00073     }
00074 };
00075
00076 // ---------------------------------------------------------------------------------------------------------------------------------
00077 // ---------------------------------------------------------------------------------------------------------------------------------
00078
00084 class DeleteAssociativeObject
00085 {
00086 public:
00092     template<typename Pair>
00093     void operator()(const Pair &pair) const
00094     {
00095         delete pair.second;
00096     }
00097 };
00098
00099 // ---------------------------------------------------------------------------------------------------------------------------------
00100 // ---------------------------------------------------------------------------------------------------------------------------------
00101
00105 template <typename Pair>
00106 class LessThanPairComparisonObject : public std::binary_function<const Pair, const Pair, bool>
00107 {
00108 public:
00117     bool operator()(const Pair &lhs, const Pair &rhs) const
00118     {
00119         return LessThan(lhs.first, rhs.first);
00120     }
00121
00130     bool operator()(const Pair &lhs, const typename Pair::first_type &rhs) const
00131     {
00132         return LessThan(lhs.first, rhs);
00133     }
00134
00143     bool operator()(const typename Pair::first_type &lhs, const Pair &rhs) const
00144     {
00145         return LessThan(lhs, rhs.first);
00146     }
00147
00148 private:
00157     bool LessThan(const typename Pair::first_type &lhs, const typename Pair::first_type &rhs) const
00158     {
00159         return lhs < rhs;
00160     }
00161 };
00162
00163 // ---------------------------------------------------------------------------------------------------------------------------------
00164 // ---------------------------------------------------------------------------------------------------------------------------------
00165
00169 template <typename Pair>
00170 class EqualToPairComparisonObject : public std::binary_function<const Pair, const Pair, bool>
00171 {
00172 public:
00181     bool operator()(const Pair &lhs, const Pair &rhs) const
00182     {
00183         return EqualTo(lhs.first, rhs.first);
00184     }
00185
00194     bool operator()(const Pair &lhs, const typename Pair::first_type &rhs) const
00195     {
00196         return EqualTo(lhs.first, rhs);
00197     }
00198
00207     bool operator()(const typename Pair::first_type &lhs, const Pair &rhs) const
00208     {
00209         return EqualTo(lhs, rhs.first);
00210     }
00211
00212 private:
00221     bool EqualTo(const typename Pair::first_type &lhs, const typename Pair::first_type &rhs) const
00222     {
00223         return (lhs == rhs);
00224     }
00225 };
00226
00227 // ---------------------------------------------------------------------------------------------------------------------------------
00228 // ---------------------------------------------------------------------------------------------------------------------------------
00229
00233 class CaseInsensitiveLessThanStringComparisonObject : public std::binary_function<const std::string, const std::string, bool>
00234 {
00235 public:
00244     bool operator()(const std::string &lhs, const std::string &rhs) const
00245     {
00246         return (::stricmp(lhs.c_str(), rhs.c_str()) < 0);
00247     }
00248 };
00249
00250 } // namespace Activ
00251
00252 #endif // (!defined ACTIV_MISC_FUNCTION_OBJECTS_H)
Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » Config » Compilers

GCC.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_CONFIG_COMPILERS_GCC_H)
00010 #define ACTIV_CONFIG_COMPILERS_GCC_H
00011
00012 #if ((__GNUC__ < 3) || ((__GNUC__ == 3) && (__GNUC_MINOR__ < 4)))
00013 #error GCC version not supported
00014 #endif
00015
00016 #define ACTIV_COMPILER_NAME "GNU C++ version " ACTIV_STRINGIZE(__GNUC__) "." ACTIV_STRINGIZE(__GNUC_MINOR__)
00017
00018 #if (__GNUC__ < 4)
00019 #define ACTIV_BUILDING_DLL_EXPORTED_API
00020 #define ACTIV_BUILDING_DLL_INLINE_API
00021 #define ACTIV_BUILDING_DLL_LOCAL_API
00022 #define ACTIV_USING_DLL_EXPORTED_API
00023 #define ACTIV_USING_DLL_INLINE_API
00024 #define ACTIV_USING_DLL_LOCAL_API
00025
00026 #define ACTIV_BUILDING_LIB_EXPORTED_API
00027 #define ACTIV_BUILDING_LIB_INLINE_API
00028 #define ACTIV_BUILDING_LIB_LOCAL_API
00029 #define ACTIV_USING_LIB_EXPORTED_API
00030 #define ACTIV_USING_LIB_INLINE_API
00031 #define ACTIV_USING_LIB_LOCAL_API
00032 #else
00033 #define ACTIV_BUILDING_DLL_EXPORTED_API     __attribute__ ((visibility("default")))
00034 #define ACTIV_BUILDING_DLL_INLINE_API       __attribute__ ((visibility("hidden")))
00035 #define ACTIV_BUILDING_DLL_LOCAL_API        __attribute__ ((visibility("hidden")))
00036 #define ACTIV_USING_DLL_EXPORTED_API
00037 #define ACTIV_USING_DLL_INLINE_API
00038 #define ACTIV_USING_DLL_LOCAL_API
00039
00040 #define ACTIV_BUILDING_LIB_EXPORTED_API
00041 #define ACTIV_BUILDING_LIB_INLINE_API
00042 #define ACTIV_BUILDING_LIB_LOCAL_API
00043 #define ACTIV_USING_LIB_EXPORTED_API
00044 #define ACTIV_USING_LIB_INLINE_API
00045 #define ACTIV_USING_LIB_LOCAL_API
00046 #endif
00047
00056 #if (__GNUC__ > 4) || ((__GNUC__ == 4) && (__GNUC_MINOR__ >= 1))
00057 #define ACTIV_DECLARE_UNINITIALIZED_VARIABLE(type, name, dummyValue) type name
00058 #else
00059 #define ACTIV_DECLARE_UNINITIALIZED_VARIABLE(type, name, dummyValue) type name = dummyValue
00060 #endif
00061
00076 #if (__GNUC__ < 4)
00077 #define ACTIV_TEMPLATE_API(a)
00078 #else
00079 #define ACTIV_TEMPLATE_API(a)   a
00080 #endif
00081
00097 #define ACTIV_TEMPLATE_SELF class
00098
00102 #if (defined _DEBUG)
00103 #define ACTIV_FORCE_INLINE  inline
00104 #else
00105 #define ACTIV_FORCE_INLINE  inline __attribute__((__always_inline__))
00106 #endif
00107
00111 #define ACTIV_NEVER_INLINE  __attribute__((__noinline__))
00112
00113 #define stricmp     strcasecmp
00114 #define strnicmp    strncasecmp
00115
00116 #endif // (!defined ACTIV_CONFIG_COMPILERS_GCC_H)
Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » Misc

HandleManager.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_MISC_HANDLE_MANAGER_H)
00010 #define ACTIV_MISC_HANDLE_MANAGER_H
00011
00012 #include "ActivMiddleware/Activ.h"
00013
00014 #if (defined ACTIV_PLATFORM_POSIX)
00015 #include <sys/poll.h>
00016 #endif
00017
00018 namespace Activ
00019 {
00020
00037 template<typename T>
00038 class HandleManager : private boost::noncopyable
00039 {
00040 public:
00044     HandleManager();
00045
00052     HandleManager(HANDLE *pHandles, const size_t numberOfHandles);
00053
00060     void Initialize(HANDLE *pHandles, const size_t numberOfHandles);
00061
00073     StatusCode Wait(const TimeoutPeriod timeoutPeriod);
00074
00075 private:
00076     T &         m_derived;
00077     size_t      m_numberOfHandles;
00078
00079 #if (defined ACTIV_PLATFORM_POSIX)
00080
00081     typedef std::vector<pollfd> PollFdList;
00082
00083     PollFdList  m_pollFdList;
00084
00085 #elif (defined ACTIV_PLATFORM_WINDOWS)
00086
00087     typedef std::vector<HANDLE> HandleList;
00088
00089     HandleList  m_handleList;
00090
00091 #else
00092 #error Configure
00093 #endif
00094 };
00095
00096 // ---------------------------------------------------------------------------------------------------------------------------------
00097 // ---------------------------------------------------------------------------------------------------------------------------------
00098
00099 template<typename T>
00100 HandleManager<T>::HandleManager() :
00101     m_derived(static_cast<T &>(*this))
00102 {
00103 }
00104
00105 // ---------------------------------------------------------------------------------------------------------------------------------
00106
00107 template<typename T>
00108 HandleManager<T>::HandleManager(HANDLE *pHandles, const size_t numberOfHandles) :
00109     m_derived(static_cast<T &>(*this))
00110 {
00111     Initialize(pHandles, numberOfHandles);
00112 }
00113
00114 // ---------------------------------------------------------------------------------------------------------------------------------
00115
00116 template<typename T>
00117 void HandleManager<T>::Initialize(HANDLE *pHandles, const size_t numberOfHandles)
00118 {
00119     m_numberOfHandles = numberOfHandles;
00120
00121 #if (defined ACTIV_PLATFORM_POSIX)
00122
00123     m_pollFdList.clear();
00124
00125     for (size_t i = 0; i < m_numberOfHandles; ++i)
00126     {
00127         pollfd pollFd;
00128
00129         pollFd.fd = pHandles[i];
00130         pollFd.events = POLLIN;
00131
00132         m_pollFdList.push_back(pollFd);
00133     }
00134
00135 #elif (defined ACTIV_PLATFORM_WINDOWS)
00136
00137     m_handleList.assign(pHandles, pHandles + numberOfHandles);
00138
00139 #else
00140 #error Configure
00141 #endif
00142 }
00143
00144 // ---------------------------------------------------------------------------------------------------------------------------------
00145
00146 template<typename T>
00147 StatusCode HandleManager<T>::Wait(const TimeoutPeriod timeoutPeriod)
00148 {
00149 #if (defined ACTIV_PLATFORM_POSIX)
00150
00151     const int res = ::poll(&m_pollFdList[0], m_numberOfHandles, timeoutPeriod);
00152
00153     if (0 == res)
00154         return STATUS_CODE_TIMEOUT;
00155
00156     if (res < 0)
00157         return OsErrorToStatusCode(errno);
00158
00159     for (size_t i = 0, numberSignalled = 0; i < m_numberOfHandles; ++i)
00160     {
00161         if (m_pollFdList[i].revents & POLLIN)
00162         {
00163             m_derived.OnEvent(i);
00164
00165             if (++numberSignalled == static_cast<size_t>(res))
00166                 break;
00167         }
00168     }
00169
00170 #elif (defined ACTIV_PLATFORM_WINDOWS)
00171
00172     const DWORD res = ::WaitForMultipleObjects(static_cast<DWORD>(m_numberOfHandles), &m_handleList[0], FALSE, timeoutPeriod);
00173
00174     if ((res >= WAIT_OBJECT_0) && (res < WAIT_OBJECT_0 + m_numberOfHandles))
00175         m_derived.OnEvent(res - WAIT_OBJECT_0);
00176     else if ((res >= WAIT_ABANDONED_0) && (res < WAIT_ABANDONED_0 + m_numberOfHandles))
00177         m_derived.OnEvent(res - WAIT_ABANDONED_0);
00178     else if (WAIT_TIMEOUT == res)
00179         return STATUS_CODE_TIMEOUT;
00180     else // (WAIT_FAILED == res)
00181         return OsErrorToStatusCode(::GetLastError());
00182
00183 #else
00184 #error Configure
00185 #endif
00186
00187     return STATUS_CODE_SUCCESS;
00188 }
00189
00190 } // namespace Activ
00191
00192 #endif // (!defined ACTIV_MISC_HANDLE_MANAGER_H)
Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivSystem

HeapMessage.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_SYSTEM_HEAP_MESSAGE_H)
00010 #define ACTIV_SYSTEM_HEAP_MESSAGE_H
00011
00012 #include "ActivMiddleware/ActivSystem/External.h"
00013 #include "ActivMiddleware/ActivSystem/Address.h"
00014 #include "ActivMiddleware/ActivSystem/RequestId.h"
00015 #include "ActivMiddleware/ActivSystem/Subject.h"
00016 #include "ActivMiddleware/ActivIp/IpAddress.h"
00017 #include "ActivMiddleware/ActivBase/StatusCodeException.h"
00018
00019 namespace Activ
00020 {
00021
00022 class MessageImpl;
00023 class SystemImpl;
00024 class ScatterBufferHelper;
00025 class MessageBuilder;
00026 class IHeap;
00027
00028 // ---------------------------------------------------------------------------------------------------------------------------------
00029
00033 class HeapMessage
00034 {
00035 private:
00039     class Proxy
00040     {
00041     public:
00045         ACTIV_SYSTEM_INLINE_API
00046         Proxy(MessageImpl *pMessage, SystemImpl *pSystem);
00047
00048         MessageImpl * const m_pMessage;
00049         SystemImpl * const  m_pSystem;
00050     };
00051
00052 public:
00056     class Iterator
00057     {
00058     public:
00062         ACTIV_SYSTEM_INLINE_API
00063         Iterator();
00064
00070         ACTIV_SYSTEM_INLINE_API
00071         MessageImpl &operator*();
00072
00078         ACTIV_SYSTEM_INLINE_API
00079         MessageImpl *operator->();
00080
00086         ACTIV_SYSTEM_EXPORTED_API
00087         Iterator &operator++();
00088
00094         ACTIV_SYSTEM_INLINE_API
00095         const Iterator operator++(int);
00096
00104         ACTIV_SYSTEM_INLINE_API
00105         bool operator==(const Iterator &rhs) const;
00106
00114         ACTIV_SYSTEM_INLINE_API
00115         bool operator!=(const Iterator &rhs) const;
00116
00117     private:
00124         ACTIV_SYSTEM_INLINE_API
00125         Iterator(const HeapMessage *pHeapMessage, MessageImpl *pMessage);
00126
00127         const HeapMessage   *m_pHeapMessage;
00128         MessageImpl         *m_pMessage;
00129
00130         friend class HeapMessage;
00131     };
00132
00133     class WriteHelper; // Forward declaration.
00134
00138     class ReadHelper
00139     {
00140     public:
00144         ACTIV_SYSTEM_INLINE_API
00145         ReadHelper();
00146
00152         ACTIV_SYSTEM_INLINE_API
00153         ReadHelper(const HeapMessage &heapMessage);
00154
00162         ACTIV_SYSTEM_INLINE_API
00163         ReadHelper(const ReadHelper &rhs);
00164
00170         ACTIV_SYSTEM_INLINE_API
00171         ReadHelper(const WriteHelper &rhs);
00172
00176         ACTIV_SYSTEM_INLINE_API
00177         ~ReadHelper();
00178
00188         ACTIV_SYSTEM_INLINE_API
00189         ReadHelper &operator=(const ReadHelper &rhs);
00190
00196         ACTIV_SYSTEM_INLINE_API
00197         void Initialize(const HeapMessage &heapMessage);
00198
00202         ACTIV_SYSTEM_INLINE_API
00203         void Initialize();
00204
00214         ACTIV_SYSTEM_EXPORTED_API
00215         StatusCode Copy(void *pData, const size_t dataLength);
00216
00227         ACTIV_SYSTEM_EXPORTED_API
00228         StatusCode Copy(WriteHelper &writeHelper, const size_t dataLength);
00229
00240         ACTIV_SYSTEM_EXPORTED_API
00241         StatusCode Copy(MessageBuilder &messageBuilder, const size_t dataLength);
00242
00254         ACTIV_SYSTEM_EXPORTED_API
00255         StatusCode Get(const void *&pData, const size_t dataLength, void *pGetBuffer = 0);
00256
00267         ACTIV_SYSTEM_EXPORTED_API
00268         StatusCode Get(const void *&pData, const size_t dataLength, size_t &dataLengthRead);
00269
00280         ACTIV_SYSTEM_EXPORTED_API
00281         StatusCode Get(ScatterBufferHelper &scatterBufferHelper, const size_t dataLength);
00282
00288         ACTIV_SYSTEM_INLINE_API
00289         size_t GetLength() const;
00290
00296         ACTIV_SYSTEM_INLINE_API
00297         size_t GetOffset() const;
00298
00307         ACTIV_SYSTEM_EXPORTED_API
00308         StatusCode IncrementOffset(const size_t increment);
00309
00318         ACTIV_SYSTEM_EXPORTED_API
00319         StatusCode SetOffset(const size_t offset);
00320
00329         ACTIV_SYSTEM_EXPORTED_API
00330         StatusCode AdjustGetBufferSize(const size_t getBufferSize) const;
00331
00332     private:
00339         ACTIV_SYSTEM_LOCAL_API
00340         void LeftToRightCopy(WriteHelper &writeHelper, size_t &dataLength);
00341
00348         ACTIV_SYSTEM_LOCAL_API
00349         void RecursiveCopy(WriteHelper &writeHelper, size_t &dataLength);
00350
00351         const HeapMessage * m_pHeapMessage;
00352         Iterator            m_iterator;
00353         size_t              m_absoluteOffset;
00354         size_t              m_relativeOffset;
00355
00356         mutable void *      m_pGetBuffer;
00357         mutable size_t      m_getBufferSize;
00358
00359         friend class WriteHelper;
00360     };
00361
00365     class WriteHelper
00366     {
00367     public:
00371         ACTIV_BASE_INLINE_API
00372         WriteHelper();
00373
00379         ACTIV_BASE_INLINE_API
00380         WriteHelper(HeapMessage &heapMessage);
00381
00387         ACTIV_BASE_INLINE_API
00388         WriteHelper(const ReadHelper &rhs);
00389
00395         ACTIV_BASE_INLINE_API
00396         void Initialize(HeapMessage &heapMessage);
00397
00401         ACTIV_BASE_INLINE_API
00402         void Initialize();
00403
00413         ACTIV_SYSTEM_EXPORTED_API
00414         StatusCode Copy(const void *pData, const size_t dataLength);
00415
00426         ACTIV_SYSTEM_EXPORTED_API
00427         StatusCode Copy(ReadHelper &readHelper, const size_t dataLength);
00428
00439         ACTIV_SYSTEM_EXPORTED_API
00440         StatusCode Get(void *&pData, const size_t dataLength, size_t &dataLengthWritten);
00441
00447         ACTIV_BASE_INLINE_API
00448         size_t GetLength() const;
00449
00455         ACTIV_BASE_INLINE_API
00456         size_t GetOffset() const;
00457
00468         ACTIV_SYSTEM_EXPORTED_API
00469         StatusCode IncrementOffset(const size_t increment, const bool updateLength = false);
00470
00481         ACTIV_SYSTEM_EXPORTED_API
00482         StatusCode SetOffset(const size_t offset, const bool updateLength = false);
00483
00484     private:
00491         ACTIV_BASE_LOCAL_API
00492         void LeftToRightCopy(ReadHelper &readHelper, size_t &dataLength);
00493
00500         ACTIV_BASE_LOCAL_API
00501         void RecursiveCopy(ReadHelper &readHelper, size_t &dataLength);
00502
00503         HeapMessage *   m_pHeapMessage;
00504         Iterator        m_iterator;
00505         size_t          m_absoluteOffset;
00506         size_t          m_relativeOffset;
00507
00508         friend class ReadHelper;
00509     };
00510
00514     class Stats
00515     {
00516     public:
00517         HeapId      m_heapId;
00518         MessageId   m_messageId;
00519         BucketId    m_bucketId;
00520         MessageType m_type;
00521         StatusCode  m_statusCode;
00522         Address     m_sourceAddress;
00523         Address     m_destinationAddress;
00524         Address     m_returnAddress;
00525         IpAddress   m_ipAddress;
00526         RequestId   m_requestId;
00527         Subject     m_subject;
00528         size_t      m_totalSpace;
00529         size_t      m_freeSpace;
00530         std::string m_hexDump;
00531     };
00532
00536     ACTIV_BASE_INLINE_API
00537     HeapMessage();
00538
00544     ACTIV_BASE_INLINE_API
00545     HeapMessage(Proxy proxy);
00546
00552     ACTIV_BASE_INLINE_API
00553     HeapMessage(HeapMessage &rhs);
00554
00558     ACTIV_BASE_INLINE_API
00559     ~HeapMessage();
00560
00568     ACTIV_BASE_INLINE_API
00569     HeapMessage &operator=(Proxy proxy);
00570
00578     ACTIV_BASE_INLINE_API
00579     HeapMessage &operator=(HeapMessage &rhs);
00580
00586     ACTIV_BASE_INLINE_API
00587     bool operator==(const HeapMessage &rhs) const;
00588
00594     ACTIV_BASE_INLINE_API
00595     bool operator!=(const HeapMessage &rhs) const;
00596
00602     ACTIV_BASE_INLINE_API
00603     bool operator!() const;
00604
00610     ACTIV_BASE_INLINE_API
00611     operator bool() const;
00612
00618     ACTIV_SYSTEM_EXPORTED_API
00619     const HeapId GetHeapId() const;
00620
00626     ACTIV_SYSTEM_EXPORTED_API
00627     const MessageType GetType() const;
00628
00634     ACTIV_SYSTEM_EXPORTED_API
00635     void SetType(const MessageType type);
00636
00642     ACTIV_SYSTEM_EXPORTED_API
00643     StatusCode GetStatusCode() const;
00644
00650     ACTIV_SYSTEM_EXPORTED_API
00651     void SetStatusCode(const StatusCode statusCode);
00652
00658     ACTIV_SYSTEM_EXPORTED_API
00659     Address &GetSourceAddress() const;
00660
00666     ACTIV_SYSTEM_EXPORTED_API
00667     void SetSourceAddress(const Address &sourceAddress);
00668
00674     ACTIV_SYSTEM_EXPORTED_API
00675     Address &GetDestinationAddress() const;
00676
00682     ACTIV_SYSTEM_EXPORTED_API
00683     void SetDestinationAddress(const Address &destinationAddress);
00684
00690     ACTIV_SYSTEM_EXPORTED_API
00691     Address &GetReturnAddress() const;
00692
00698     ACTIV_SYSTEM_EXPORTED_API
00699     void SetReturnAddress(const Address &returnAddress);
00700
00706     ACTIV_SYSTEM_EXPORTED_API
00707     IpAddress &GetIpAddress() const;
00708
00714     ACTIV_SYSTEM_EXPORTED_API
00715     void SetIpAddress(const IpAddress &ipAddress);
00716
00722     ACTIV_SYSTEM_EXPORTED_API
00723     RequestId &GetRequestId() const;
00724
00730     ACTIV_SYSTEM_EXPORTED_API
00731     void SetRequestId(const RequestId requestId);
00732
00738     ACTIV_SYSTEM_EXPORTED_API
00739     Subject &GetSubject() const;
00740
00746     ACTIV_SYSTEM_EXPORTED_API
00747     void SetSubject(const Subject &subject);
00748
00752     ACTIV_SYSTEM_INLINE_API
00753     void Return();
00754
00758     ACTIV_SYSTEM_INLINE_API
00759     void Release();
00760
00766     ACTIV_SYSTEM_EXPORTED_API
00767     size_t GetCapacity() const;
00768
00774     ACTIV_SYSTEM_EXPORTED_API
00775     size_t GetLength() const;
00776
00785     ACTIV_SYSTEM_EXPORTED_API
00786     StatusCode IncrementLength(size_t length);
00787
00796     ACTIV_SYSTEM_EXPORTED_API
00797     StatusCode SetLength(size_t length);
00798
00808     ACTIV_SYSTEM_EXPORTED_API
00809     StatusCode Append(const void *pData, const size_t dataLength);
00810
00821     ACTIV_SYSTEM_EXPORTED_API
00822     StatusCode Copy(const size_t offset, void *pData, const size_t dataLength) const;
00823
00834     ACTIV_SYSTEM_EXPORTED_API
00835     StatusCode Copy(void *pData, const size_t dataSize, size_t &dataLength) const;
00836
00848     ACTIV_SYSTEM_EXPORTED_API
00849     StatusCode Copy(const size_t offset, MessageBuilder &messageBuilder, const size_t dataLength) const;
00850
00861     ACTIV_SYSTEM_EXPORTED_API
00862     StatusCode Copy(MessageBuilder &messageBuilder, size_t &dataLength) const;
00863
00873     ACTIV_SYSTEM_EXPORTED_API
00874     StatusCode Erase(const size_t offset, const size_t dataLength);
00875
00893     ACTIV_SYSTEM_EXPORTED_API
00894     StatusCode Get(const size_t offset, const void *&pData, const size_t dataLength, void *pGetBuffer = 0) const;
00895
00912     ACTIV_SYSTEM_EXPORTED_API
00913     StatusCode Get(const void *&pData, size_t &dataLength, void *pGetBuffer = 0, const size_t getBufferSize = 0) const;
00914
00930     ACTIV_SYSTEM_EXPORTED_API
00931     StatusCode Get(const size_t offset, const void *&pData, const size_t dataLength, size_t &dataLengthRead) const;
00932
00944     ACTIV_SYSTEM_EXPORTED_API
00945     StatusCode Get(const size_t offset, ScatterBufferHelper &scatterBufferHelper, const size_t dataLength) const;
00946
00957     ACTIV_SYSTEM_EXPORTED_API
00958     StatusCode Get(ScatterBufferHelper &scatterBufferHelper, size_t &dataLength) const;
00959
00971     ACTIV_SYSTEM_EXPORTED_API
00972     StatusCode Insert(const size_t offset, const void *pData, const size_t dataLength);
00973
00985     ACTIV_SYSTEM_EXPORTED_API
00986     StatusCode Overwrite(const size_t offset, const void *pData, const size_t dataLength);
00987
00997     ACTIV_SYSTEM_EXPORTED_API
00998     StatusCode Extend(const size_t size);
00999
01008     ACTIV_SYSTEM_EXPORTED_API
01009     StatusCode Attach(HeapMessage &heapMessage);
01010
01022     ACTIV_SYSTEM_EXPORTED_API
01023     StatusCode Clone(const HeapMessage &sourceHeapMessage, IHeap * const pHeap = 0);
01024
01032     ACTIV_SYSTEM_EXPORTED_API
01033     std::string ToHexDumpString(const size_t bytesPerLine = 16) const;
01034
01040     ACTIV_SYSTEM_INLINE_API
01041     bool IsMessageAttached() const;
01042
01048     ACTIV_SYSTEM_INLINE_API
01049     Iterator Begin() const;
01050
01056     ACTIV_SYSTEM_INLINE_API
01057     Iterator End() const;
01058
01062     ACTIV_SYSTEM_INLINE_API
01063     operator Proxy();
01064
01065 private:
01072     ACTIV_SYSTEM_INLINE_API
01073     HeapMessage(MessageImpl *pMessage, SystemImpl *pSystem);
01074
01078     ACTIV_SYSTEM_EXPORTED_API
01079     void InternalReturn();
01080
01081     MessageImpl *       m_pMessage;
01082     SystemImpl *        m_pSystem;
01083
01084     mutable ReadHelper  m_readHelper;
01085     WriteHelper         m_writeHelper;
01086
01087     friend class HeapMessageAccessor;
01088     friend class PrivateHeap;
01089     friend class SharedHeap;
01090 };
01091
01092 // ---------------------------------------------------------------------------------------------------------------------------------
01093 // ---------------------------------------------------------------------------------------------------------------------------------
01094
01095 inline HeapMessage::Proxy::Proxy(MessageImpl *pMessage, SystemImpl *pSystem) :
01096     m_pMessage(pMessage),
01097     m_pSystem(pSystem)
01098 {
01099 }
01100
01101 // ---------------------------------------------------------------------------------------------------------------------------------
01102 // ---------------------------------------------------------------------------------------------------------------------------------
01103
01104 inline HeapMessage::HeapMessage() :
01105     m_pMessage(0),
01106     m_pSystem(0),
01107     m_readHelper(*this),
01108     m_writeHelper(*this)
01109 {
01110 }
01111
01112 // ---------------------------------------------------------------------------------------------------------------------------------
01113
01114 inline HeapMessage::HeapMessage(HeapMessage &rhs) :
01115     m_pMessage(rhs.m_pMessage),
01116     m_pSystem(rhs.m_pSystem),
01117     m_readHelper(*this),
01118     m_writeHelper(*this)
01119 {
01120     rhs.Release();
01121 }
01122
01123 // ---------------------------------------------------------------------------------------------------------------------------------
01124
01125 inline HeapMessage::HeapMessage(Proxy proxy) :
01126     m_pMessage(proxy.m_pMessage),
01127     m_pSystem(proxy.m_pSystem),
01128     m_readHelper(*this),
01129     m_writeHelper(*this)
01130 {
01131 }
01132
01133 // ---------------------------------------------------------------------------------------------------------------------------------
01134
01135 inline HeapMessage::~HeapMessage()
01136 {
01137     Return();
01138 }
01139
01140 // ---------------------------------------------------------------------------------------------------------------------------------
01141
01142 inline HeapMessage &HeapMessage::operator=(Proxy proxy)
01143 {
01144     Return();
01145
01146     m_pMessage = proxy.m_pMessage;
01147     m_pSystem = proxy.m_pSystem;
01148
01149     m_readHelper.Initialize(*this);
01150     m_writeHelper.Initialize(*this);
01151
01152     return *this;
01153 }
01154
01155 // ---------------------------------------------------------------------------------------------------------------------------------
01156
01157 inline HeapMessage &HeapMessage::operator=(HeapMessage &rhs)
01158 {
01159     if (&rhs != this)
01160     {
01161         Return();
01162
01163         m_pMessage = rhs.m_pMessage;
01164         m_pSystem = rhs.m_pSystem;
01165
01166         m_readHelper.Initialize(*this);
01167         m_writeHelper.Initialize(*this);
01168
01169         rhs.Release();
01170     }
01171
01172     return *this;
01173 }
01174
01175 // ---------------------------------------------------------------------------------------------------------------------------------
01176
01177 inline bool HeapMessage::operator==(const HeapMessage &rhs) const
01178 {
01179     return ((m_pMessage == rhs.m_pMessage) && (m_pSystem == rhs.m_pSystem));
01180 }
01181
01182 // ---------------------------------------------------------------------------------------------------------------------------------
01183
01184 inline bool HeapMessage::operator!=(const HeapMessage &rhs) const
01185 {
01186     return !((*this) == rhs);
01187 }
01188
01189 // ---------------------------------------------------------------------------------------------------------------------------------
01190
01191 inline bool HeapMessage::operator!() const
01192 {
01193     return !IsMessageAttached();
01194 }
01195
01196 // ---------------------------------------------------------------------------------------------------------------------------------
01197
01198 inline HeapMessage::operator bool() const
01199 {
01200     return IsMessageAttached();
01201 }
01202
01203 // ---------------------------------------------------------------------------------------------------------------------------------
01204
01205 inline void HeapMessage::Return()
01206 {
01207     if (0 != m_pMessage)
01208         InternalReturn();
01209 }
01210
01211 // ---------------------------------------------------------------------------------------------------------------------------------
01212
01213 inline void HeapMessage::Release()
01214 {
01215     m_pMessage = 0;
01216 }
01217
01218 // ---------------------------------------------------------------------------------------------------------------------------------
01219
01220 inline bool HeapMessage::IsMessageAttached() const
01221 {
01222     return (0 != m_pMessage);
01223 }
01224
01225 // ---------------------------------------------------------------------------------------------------------------------------------
01226
01227 inline HeapMessage::Iterator HeapMessage::Begin() const
01228 {
01229     return Iterator(this, m_pMessage);
01230 }
01231
01232 // ---------------------------------------------------------------------------------------------------------------------------------
01233
01234 inline HeapMessage::Iterator HeapMessage::End() const
01235 {
01236     return Iterator(this, 0);
01237 }
01238
01239 // ---------------------------------------------------------------------------------------------------------------------------------
01240
01241 inline HeapMessage::operator HeapMessage::Proxy()
01242 {
01243     MessageImpl *pMessage = m_pMessage;
01244     SystemImpl *pSystem = m_pSystem;
01245     Release();
01246
01247     return Proxy(pMessage, pSystem);
01248 }
01249
01250 // ---------------------------------------------------------------------------------------------------------------------------------
01251
01252 inline HeapMessage::HeapMessage(MessageImpl *pMessage, SystemImpl *pSystem) :
01253         m_pMessage(pMessage),
01254     m_pSystem(pSystem),
01255     m_readHelper(*this),
01256     m_writeHelper(*this)
01257 {
01258 }
01259
01260 // ---------------------------------------------------------------------------------------------------------------------------------
01261 // ---------------------------------------------------------------------------------------------------------------------------------
01262
01263 inline HeapMessage::Iterator::Iterator() :
01264     m_pHeapMessage(0),
01265     m_pMessage(0)
01266 {
01267 }
01268
01269 // ---------------------------------------------------------------------------------------------------------------------------------
01270
01271 inline MessageImpl &HeapMessage::Iterator::operator*()
01272 {
01273     return *m_pMessage;
01274 }
01275
01276 // ---------------------------------------------------------------------------------------------------------------------------------
01277
01278 inline MessageImpl *HeapMessage::Iterator::operator->()
01279 {
01280     return m_pMessage;
01281 }
01282
01283 // ---------------------------------------------------------------------------------------------------------------------------------
01284
01285 inline const HeapMessage::Iterator HeapMessage::Iterator::operator++(int)
01286 {
01287     Iterator oldValue = *this;
01288
01289     ++(*this);
01290
01291     return oldValue;
01292 }
01293
01294 // ---------------------------------------------------------------------------------------------------------------------------------
01295
01296 inline bool HeapMessage::Iterator::operator==(const HeapMessage::Iterator &rhs) const
01297 {
01298     return ((m_pHeapMessage == rhs.m_pHeapMessage) && (m_pMessage == rhs.m_pMessage));
01299 }
01300
01301 // ---------------------------------------------------------------------------------------------------------------------------------
01302
01303 inline bool HeapMessage::Iterator::operator!=(const HeapMessage::Iterator &rhs) const
01304 {
01305     return !((*this) == rhs);
01306 }
01307
01308 // ---------------------------------------------------------------------------------------------------------------------------------
01309
01310 inline HeapMessage::Iterator::Iterator(const HeapMessage *pHeapMessage, MessageImpl *pMessage) :
01311     m_pHeapMessage(pHeapMessage),
01312     m_pMessage(pMessage)
01313 {
01314 }
01315
01316 // ---------------------------------------------------------------------------------------------------------------------------------
01317 // ---------------------------------------------------------------------------------------------------------------------------------
01318
01319 inline HeapMessage::ReadHelper::ReadHelper() :
01320     m_pHeapMessage(0),
01321     m_absoluteOffset(0),
01322     m_relativeOffset(0),
01323     m_pGetBuffer(NULL),
01324     m_getBufferSize(0)
01325 {
01326 }
01327
01328 // ---------------------------------------------------------------------------------------------------------------------------------
01329
01330 inline HeapMessage::ReadHelper::ReadHelper(const HeapMessage &heapMessage) :
01331     m_pHeapMessage(&heapMessage),
01332     m_absoluteOffset(0),
01333     m_relativeOffset(0),
01334     m_pGetBuffer(NULL),
01335     m_getBufferSize(0)
01336 {
01337     m_iterator = m_pHeapMessage->Begin();
01338 }
01339
01340 // ---------------------------------------------------------------------------------------------------------------------------------
01341
01342 inline HeapMessage::ReadHelper::ReadHelper(const ReadHelper &rhs) :
01343     m_pHeapMessage(rhs.m_pHeapMessage),
01344     m_iterator(rhs.m_iterator),
01345     m_absoluteOffset(rhs.m_absoluteOffset),
01346     m_relativeOffset(rhs.m_relativeOffset),
01347     m_pGetBuffer(NULL),
01348     m_getBufferSize(0)
01349 {
01350 }
01351
01352 // ---------------------------------------------------------------------------------------------------------------------------------
01353
01354 inline HeapMessage::ReadHelper::ReadHelper(const WriteHelper &rhs) :
01355     m_pHeapMessage(rhs.m_pHeapMessage),
01356     m_iterator(rhs.m_iterator),
01357     m_absoluteOffset(rhs.m_absoluteOffset),
01358     m_relativeOffset(rhs.m_relativeOffset),
01359     m_pGetBuffer(NULL),
01360     m_getBufferSize(0)
01361 {
01362 }
01363
01364 // ---------------------------------------------------------------------------------------------------------------------------------
01365
01366 inline HeapMessage::ReadHelper::~ReadHelper()
01367 {
01368     if (NULL != m_pGetBuffer)
01369         std::free(m_pGetBuffer);
01370 }
01371
01372 // ---------------------------------------------------------------------------------------------------------------------------------
01373
01374 inline HeapMessage::ReadHelper& HeapMessage::ReadHelper::operator=(const ReadHelper &rhs)
01375 {
01376     if (&rhs != this)
01377     {
01378         m_pHeapMessage = rhs.m_pHeapMessage;
01379         m_iterator = rhs.m_iterator;
01380         m_absoluteOffset = rhs.m_absoluteOffset;
01381         m_relativeOffset = rhs.m_relativeOffset;
01382     }
01383
01384     return *this;
01385 }
01386
01387 // ---------------------------------------------------------------------------------------------------------------------------------
01388
01389 inline void HeapMessage::ReadHelper::Initialize(const HeapMessage &heapMessage)
01390 {
01391     m_pHeapMessage = &heapMessage;
01392     m_iterator = m_pHeapMessage->Begin();
01393     m_absoluteOffset = 0;
01394     m_relativeOffset = 0;
01395 }
01396
01397 // ---------------------------------------------------------------------------------------------------------------------------------
01398
01399 inline void HeapMessage::ReadHelper::Initialize()
01400 {
01401     m_iterator = ((0 != m_pHeapMessage) ? m_pHeapMessage->Begin() : Iterator());
01402     m_absoluteOffset = 0;
01403     m_relativeOffset = 0;
01404 }
01405
01406 // ---------------------------------------------------------------------------------------------------------------------------------
01407
01408 inline size_t HeapMessage::ReadHelper::GetLength() const
01409 {
01410     return m_pHeapMessage->GetLength();
01411 }
01412
01413 // ---------------------------------------------------------------------------------------------------------------------------------
01414
01415 inline size_t HeapMessage::ReadHelper::GetOffset() const
01416 {
01417     return m_absoluteOffset;
01418 }
01419
01420 // ---------------------------------------------------------------------------------------------------------------------------------
01421 // ---------------------------------------------------------------------------------------------------------------------------------
01422
01423 inline HeapMessage::WriteHelper::WriteHelper() :
01424     m_pHeapMessage(0),
01425     m_absoluteOffset(0),
01426     m_relativeOffset(0)
01427 {
01428 }
01429
01430 // ---------------------------------------------------------------------------------------------------------------------------------
01431
01432 inline HeapMessage::WriteHelper::WriteHelper(HeapMessage &heapMessage) :
01433     m_pHeapMessage(&heapMessage),
01434     m_absoluteOffset(0),
01435     m_relativeOffset(0)
01436 {
01437     m_iterator = m_pHeapMessage->Begin();
01438 }
01439
01440 // ---------------------------------------------------------------------------------------------------------------------------------
01441
01442 inline HeapMessage::WriteHelper::WriteHelper(const ReadHelper &rhs) :
01443     m_pHeapMessage(const_cast<HeapMessage *>(rhs.m_pHeapMessage)),
01444     m_iterator(rhs.m_iterator),
01445     m_absoluteOffset(rhs.m_absoluteOffset),
01446     m_relativeOffset(rhs.m_relativeOffset)
01447 {
01448 }
01449
01450 // ---------------------------------------------------------------------------------------------------------------------------------
01451
01452 inline void HeapMessage::WriteHelper::Initialize(HeapMessage &heapMessage)
01453 {
01454     m_pHeapMessage = &heapMessage;
01455     m_iterator = m_pHeapMessage->Begin();
01456     m_absoluteOffset = 0;
01457     m_relativeOffset = 0;
01458 }
01459
01460 // ---------------------------------------------------------------------------------------------------------------------------------
01461
01462 inline void HeapMessage::WriteHelper::Initialize()
01463 {
01464     m_iterator = ((0 != m_pHeapMessage) ? m_pHeapMessage->Begin() : Iterator());
01465     m_absoluteOffset = 0;
01466     m_relativeOffset = 0;
01467 }
01468
01469 // ---------------------------------------------------------------------------------------------------------------------------------
01470
01471 inline size_t HeapMessage::WriteHelper::GetLength() const
01472 {
01473     return m_pHeapMessage->GetLength();
01474 }
01475
01476 // ---------------------------------------------------------------------------------------------------------------------------------
01477
01478 inline size_t HeapMessage::WriteHelper::GetOffset() const
01479 {
01480     return m_absoluteOffset;
01481 }
01482
01483 } // namespace Activ
01484
01485 #endif // (!defined ACTIV_SYSTEM_HEAP_MESSAGE_H)
Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivSystem

HeapMessageBuilder.h

Go to the documentation of this file.
00001
00010 #if (!defined ACTIV_SYSTEM_HEAP_MESSAGE_BUILDER_H)
00011 #define ACTIV_SYSTEM_HEAP_MESSAGE_BUILDER_H
00012
00013 #include "ActivMiddleware/ActivSystem/External.h"
00014 #include "ActivMiddleware/ActivSystem/IHeap.h"
00015 #include "ActivMiddleware/ActivBase/MessageBuilder.h"
00016
00017 namespace Activ
00018 {
00019
00023 class HeapMessageBuilder
00024 {
00025 public:
00034     HeapMessageBuilder(IHeap * const pHeap, const size_t approximateSize,
00035         const MessageBuilder::MessageVersion messageVersion = MessageBuilder::MESSAGE_VERSION_UNDEFINED);
00036
00042     MessageBuilder &GetMessageBuilder();
00043
00050     void GetHeapMessage(HeapMessage &heapMessage);
00051
00052 private:
00056     ACTIV_SYSTEM_EXPORTED_API void Initialize();
00057
00058     IHeap * const   m_pHeap;
00059     HeapMessage     m_heapMessage;
00060     void *          m_pBuffer;
00061     size_t          m_size;
00062     MessageBuilder  m_messageBuilder;
00063 };
00064
00065 // ---------------------------------------------------------------------------------------------------------------------------------
00066
00067 inline HeapMessageBuilder::HeapMessageBuilder(IHeap * const pHeap, const size_t approximateSize,
00068         const MessageBuilder::MessageVersion messageVersion) :
00069     m_pHeap(pHeap),
00070     m_heapMessage(pHeap->GetMessage(approximateSize)),
00071     m_pBuffer(0)
00072 {
00073     if (m_heapMessage)
00074         Initialize();
00075
00076     StatusCode statusCode;
00077
00078     if (0 != m_pBuffer)
00079         statusCode = m_messageBuilder.Initialize(m_pBuffer, m_size, true, messageVersion);
00080     else
00081         statusCode = m_messageBuilder.Initialize(approximateSize, true, messageVersion);
00082
00083     if (STATUS_CODE_SUCCESS != statusCode)
00084         ACTIV_THROW(StatusCodeException, statusCode);
00085 }
00086
00087 // ---------------------------------------------------------------------------------------------------------------------------------
00088
00089 inline MessageBuilder &HeapMessageBuilder::GetMessageBuilder()
00090 {
00091     return m_messageBuilder;
00092 }
00093
00094 // ---------------------------------------------------------------------------------------------------------------------------------
00095
00096 inline void HeapMessageBuilder::GetHeapMessage(HeapMessage &heapMessage)
00097 {
00098     // if we have a HeapMessage, and the message was built into it in one block, set the length of the HeapMessage
00099     // NB if m_pBuffer is non-null, it must point to a HeapMessage. Hence no check on m_heapMessage being valid
00100     if ((m_messageBuilder.GetMessage() == m_pBuffer) && (STATUS_CODE_SUCCESS == m_heapMessage.SetLength(m_messageBuilder.GetLength())))
00101         heapMessage = m_heapMessage;
00102     else
00103         heapMessage = m_pHeap->GetMessage(m_messageBuilder.GetLength(), m_messageBuilder.GetMessage());
00104 }
00105
00106 } // namespace Activ
00107
00108 #endif // (!defined ACTIV_SYSTEM_HEAP_MESSAGE_BUILDER_H)
Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivSystem

HeapMessageDeserializer.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_SYSTEM_HEAP_MESSAGE_DESERIALIZER_H)
00010 #define ACTIV_SYSTEM_HEAP_MESSAGE_DESERIALIZER_H
00011
00012 #include "ActivMiddleware/ActivSystem/HeapMessage.h"
00013 #include "ActivMiddleware/ActivBase/MessageValidator.h"
00014
00015 namespace Activ
00016 {
00017
00024 template<typename MESSAGE_TYPE, size_t BUFFER_SIZE>
00025 class HeapMessageDeserializer : private boost::noncopyable
00026 {
00027 public:
00037     ACTIV_SYSTEM_INLINE_API
00038     StatusCode Initialize(const HeapMessage &heapMessage,
00039         const MessageHandler::MessageVersion messageVersion = MessageHandler::MESSAGE_VERSION_UNDEFINED);
00040
00049     ACTIV_SYSTEM_INLINE_API
00050     StatusCode Deserialize(MESSAGE_TYPE &message);
00051
00066     ACTIV_SYSTEM_INLINE_API
00067     StatusCode operator()(const HeapMessage &heapMessage, MESSAGE_TYPE &message,
00068         const MessageHandler::MessageVersion messageVersion = MessageHandler::MESSAGE_VERSION_UNDEFINED);
00069
00076     ACTIV_SYSTEM_INLINE_API
00077     bool IsEndOfMessage() const;
00078
00079 private:
00080     byte_t              m_buffer[BUFFER_SIZE];
00081     const void *        m_pData;
00082     size_t              m_dataLength;
00083     MessageValidator    m_messageValidator;
00084 };
00085
00086 // ---------------------------------------------------------------------------------------------------------------------------------
00087
00088 template<typename MESSAGE_TYPE, size_t BUFFER_SIZE>
00089 inline StatusCode HeapMessageDeserializer<MESSAGE_TYPE, BUFFER_SIZE>::Initialize(const HeapMessage &heapMessage,
00090     const MessageHandler::MessageVersion messageVersion)
00091 {
00092     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, heapMessage.Get(m_pData, m_dataLength, m_buffer, sizeof(m_buffer)));
00093     m_messageValidator.Initialize(m_pData, m_dataLength, messageVersion);
00094
00095     return STATUS_CODE_SUCCESS;
00096 }
00097
00098 // ---------------------------------------------------------------------------------------------------------------------------------
00099
00100 template<typename MESSAGE_TYPE, size_t BUFFER_SIZE>
00101 inline StatusCode HeapMessageDeserializer<MESSAGE_TYPE, BUFFER_SIZE>::Deserialize(MESSAGE_TYPE &message)
00102 {
00103     return message.Deserialize(m_messageValidator);
00104 }
00105
00106 // ---------------------------------------------------------------------------------------------------------------------------------
00107
00108 template<typename MESSAGE_TYPE, size_t BUFFER_SIZE>
00109 inline StatusCode HeapMessageDeserializer<MESSAGE_TYPE, BUFFER_SIZE>::operator()(const HeapMessage &heapMessage,
00110     MESSAGE_TYPE &message, const MessageHandler::MessageVersion messageVersion)
00111 {
00112     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, Initialize(heapMessage, messageVersion));
00113     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, Deserialize(message));
00114
00115     return IsEndOfMessage() ? STATUS_CODE_SUCCESS : STATUS_CODE_INVALID_LENGTH;
00116 }
00117
00118 // ---------------------------------------------------------------------------------------------------------------------------------
00119
00120 template<typename MESSAGE_TYPE, size_t BUFFER_SIZE>
00121 inline bool HeapMessageDeserializer<MESSAGE_TYPE, BUFFER_SIZE>::IsEndOfMessage() const
00122 {
00123     return m_messageValidator.IsEndOfMessage();
00124 }
00125
00126 } // namespace Activ
00127
00128 #endif // (!defined ACTIV_SYSTEM_HEAP_MESSAGE_DESERIALIZER_H)
Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivSystem

HeapPool.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_SYSTEM_HEAP_POOL_H)
00010 #define ACTIV_SYSTEM_HEAP_POOL_H
00011
00012 #include "ActivMiddleware/ActivSystem/External.h"
00013 #include "ActivMiddleware/ActivSystem/IHeap.h"
00014
00015 #include <vector>
00016
00017 namespace Activ
00018 {
00019
00023 class HeapPool : private boost::noncopyable
00024 {
00025 public:
00034     ACTIV_SYSTEM_EXPORTED_API
00035     HeapPool(ISystem * const pSystem, const IHeap::BucketInfoVector &bucketInfoVector, const size_t initialSize,
00036         const std::string &namePrefix);
00037
00046     ACTIV_SYSTEM_EXPORTED_API
00047     HeapMessage GetMessage(const size_t dataLength, const void * const pData);
00048
00056     ACTIV_SYSTEM_EXPORTED_API
00057     IHeap *Get();
00058
00067     ACTIV_SYSTEM_EXPORTED_API
00068     bool Return(IHeap * const pHeap);
00069
00077     ACTIV_SYSTEM_EXPORTED_API
00078     size_t Extend(const size_t numberOfHeaps);
00079
00080 private:
00086     ACTIV_SYSTEM_LOCAL_API
00087     IHeap *CreateHeap();
00088
00089     typedef std::set<IHeap *> HeapSet;
00090     typedef std::vector<IHeap *> HeapList;
00091
00092     ISystem * const                 m_pSystem;
00093     const IHeap::BucketInfoVector   m_bucketInfoVector;
00094     const std::string               m_namePrefix;
00095
00096     size_t                          m_nextHeapNumber;
00097     HeapSet                         m_heapSet;
00098     HeapList                        m_freeHeapList;
00099 };
00100
00101 } // namespace Activ
00102
00103 #endif // (!defined ACTIV_SYSTEM_HEAP_POOL_H)
Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivContentGatewayApiCommon

HistoryBar.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_CONTENT_GATEWAY_API_COMMON_HISTORY_BAR_H)
00010 #define ACTIV_CONTENT_GATEWAY_API_COMMON_HISTORY_BAR_H
00011
00012 #include "External.h"
00013 #include "ActivContentPlatform/ActivContentGatewayApiCommon/FieldSet.h"
00014 #include "ActivContentPlatform/ActivContentGatewayApiCommon/TimeSeriesTypes.h"
00015
00016 #include "ActivMiddleware/ActivDatabase/FieldSpecification.h"
00017
00018 #include "ActivMiddleware/ActivFieldTypes/Date.h"
00019 #include "ActivMiddleware/ActivFieldTypes/Time.h"
00020 #include "ActivMiddleware/ActivFieldTypes/Rational.h"
00021
00022 #include "ActivMiddleware/Misc/SerializableContainerHelper.h"
00023
00027 #define ACTIV_HISTORY_ADJUSTMENT_TYPE_LIST(d)                                                           \
00028     d(ADJUSTEMENT_TYPE_RATIO_PRICE_VOLUME,  "Same as split.  x ratio for volume.  / ratio for price"    )   \
00029     d(ADJUSTEMENT_TYPE_RATIO_PRICE_ONLY,    "adjustment for price only"                                 )   \
00030     d(ADJUSTEMENT_TYPE_RATIO_VOLUME_ONLY,   "adjustment for volume only"                                )   \
00031     d(ADJUSTEMENT_TYPE_VALUE_PRICE_ONLY,    "Add adjustment amount to price"                            )   \
00032     d(ADJUSTEMENT_TYPE_VALUE_VOLUME_ONLY,   "Add adjustment amount to volume"                           )   \
00033     d(ADJUSTEMENT_TYPE_COPY,                "Copy data from source symbol"                              )   \
00034     d(ADJUSTEMENT_TYPE_DELETE,              "Delete data"                                               )
00035
00036 namespace Activ
00037 {
00038
00039 namespace Database
00040 {
00041     class Record;
00042 }
00043
00044 namespace ContentPlatform
00045 {
00046
00047 namespace ContentGatewayApi
00048 {
00049
00050 #define ACTIV_DECLARE_BYTES(value, id)  static const byte_t id = value;
00051
00052 // ---------------------------------------------------------------------------------------------------------------------------------
00053
00057 class HistoryBar : public FieldSet
00058 {
00059 public:
00060
00061     enum HistoryAdjustmentType
00062     {
00063         ACTIV_HISTORY_ADJUSTMENT_TYPE_LIST(ACTIV_DECLARE_ELEMENT_1_WITH_COMMA)
00064         NUM_ADJUSTMENT_TYPES
00065     };
00066
00070     ACTIV_CONTENT_GATEWAY_API_COMMON_API HistoryBar();
00071
00075     ACTIV_CONTENT_GATEWAY_API_COMMON_API virtual ~HistoryBar();
00076
00080     ACTIV_CONTENT_GATEWAY_API_COMMON_API virtual void Reset();
00081
00092     ACTIV_CONTENT_GATEWAY_API_COMMON_API virtual StatusCode GetField(const Feed::FieldId fieldId, IFieldType &field) const;
00093
00104     ACTIV_CONTENT_GATEWAY_API_COMMON_API virtual StatusCode SetField(const Feed::FieldId fieldId, const IFieldType &field);
00105
00111     ACTIV_CONTENT_GATEWAY_API_COMMON_API virtual FieldSetType GetType() const;
00112
00118     ACTIV_CONTENT_GATEWAY_API_COMMON_API virtual std::string ToString(const std::string &deliminator = DEFAULT_STRING_FIELD_SEPARATER) const;
00119
00127     ACTIV_CONTENT_GATEWAY_API_COMMON_API virtual StatusCode FromString(const std::string &inputStr, const std::string &deliminator = DEFAULT_STRING_FIELD_SEPARATER);
00128
00136     ACTIV_CONTENT_GATEWAY_API_COMMON_API virtual StatusCode FromStringSpecial(const std::string &inputStr);
00137
00146     ACTIV_CONTENT_GATEWAY_API_COMMON_API virtual StatusCode Serialize(MessageBuilder &messageBuilder) const;
00147
00156     ACTIV_CONTENT_GATEWAY_API_COMMON_API virtual StatusCode Deserialize(MessageValidator &messageValidator);
00157
00163     ACTIV_CONTENT_GATEWAY_API_COMMON_API virtual size_t GetSerializedLength() const;
00164
00170     ACTIV_CONTENT_GATEWAY_API_COMMON_API static size_t GetMaxSerializedLength();
00171
00179     ACTIV_CONTENT_GATEWAY_API_COMMON_API bool Compare(const HistoryBar &rhs) const;
00180
00190     StatusCode Compare(const HistoryBar &rhs, int &result) const;
00191
00199     bool operator==(const HistoryBar &rhs) const;
00200
00208     bool operator!=(const HistoryBar &rhs) const;
00209
00217     bool operator<(const HistoryBar &rhs) const;
00218
00226     bool operator<=(const HistoryBar &rhs) const;
00227
00235     bool operator>(const HistoryBar &rhs) const;
00236
00244     bool operator>=(const HistoryBar &rhs) const;
00245
00253     bool operator <(const DateTime &dateTime) const;
00254     bool operator <=(const DateTime &dateTime) const;
00255
00263     bool operator ==(const DateTime &dateTime) const;
00264
00272     bool operator >(const DateTime &dateTime) const;
00273     bool operator >=(const DateTime &dateTime) const;
00274
00283     StatusCode GetDate(Date &date) const;
00284
00293     StatusCode SetDate(const Date &date);
00294
00303     StatusCode GetDateTime(DateTime &dateTime) const;
00304
00313     StatusCode GetOpenPrice(Rational &price) const;
00314
00323     StatusCode GetOpenPrice(double &price) const;
00324
00333     StatusCode SetOpenPrice(const Rational &price);
00334
00343     StatusCode GetHighPrice(Rational &price) const;
00344
00353     StatusCode GetHighPrice(double &price) const;
00354
00363     StatusCode SetHighPrice(const Rational &price);
00364
00373     StatusCode GetLowPrice(Rational &price) const;
00374
00383     StatusCode GetLowPrice(double &price) const;
00384
00393     StatusCode SetLowPrice(const Rational &price);
00394
00403     StatusCode GetClosePrice(Rational &price) const;
00404
00413     StatusCode GetClosePrice(double &price) const;
00414
00423     StatusCode SetClosePrice(const Rational &price);
00424
00433     StatusCode GetTotalVolume(uint64_t &volume) const;
00434
00443     StatusCode SetTotalVolume(const uint64_t volume);
00444
00453     StatusCode GetTotalVolume(Rational &volume) const;
00454
00463     StatusCode SetTotalVolume(const Rational& volume);
00464
00473     StatusCode GetTotalPrice(Rational &totalPrice) const;
00474
00483     StatusCode GetTotalPrice(double &totalPrice) const;
00484
00493     StatusCode SetTotalPrice(Rational &totalPrice);
00494
00503     StatusCode GetTotalValue(Rational &totalValue) const;
00504
00513     StatusCode GetTotalValue(double &totalValue) const;
00514
00523     StatusCode SetTotalValue(Rational &totalValue);
00524
00533     StatusCode GetOpenInterest(uint32_t &openInterest) const;
00534
00543     StatusCode SetOpenInterest(const uint32_t openInterest);
00544
00545     /*
00546      *  @brief  Get the bar's tick count.
00547      *
00548      *  @param  count the tick count of the bar.
00549      *
00550      *  @retval STATUS_CODE_SUCCESS
00551      *  @retval STATUS_CODE_INVALID_LENGTH
00552      */
00553 //  StatusCode GetTickCount(unsigned &count) const;
00554
00555     /*
00556      *  @brief  Set the bar's tick count.
00557      *
00558      *  @param  count the tick count of the bar.
00559      *
00560      *  @retval STATUS_CODE_SUCCESS
00561      *  @retval STATUS_CODE_INVALID_LENGTH
00562      */
00563 //  StatusCode SetTickCount(const unsigned count);
00564
00575     ACTIV_CONTENT_GATEWAY_API_COMMON_API FieldSet::UpdateFieldSetStatus Update(const SeriesType period, const HistoryBar &dailyBar);
00576
00580     void SetToMiniBar();
00581
00591     ACTIV_CONTENT_GATEWAY_API_COMMON_API StatusCode ProcessSplit(const int sharesBefore, const int sharesAfter, const Rational::Denominator type);
00592
00596     bool IsOpenValid();
00597
00602     ACTIV_CONTENT_GATEWAY_API_COMMON_API void ForceDecimalType(const Rational::Denominator type);
00603
00607     ACTIV_CONTENT_GATEWAY_API_COMMON_API void Adjust(const HistoryAdjustmentType adjustmentType, const Rational &amount, const Rational::Denominator denominator);
00608
00609
00610 public:
00611     ACTIV_CONTENT_GATEWAY_API_COMMON_API static StatusCode BuildBarFromRecord(const Database::Record& record, HistoryBar& dailyBar);
00612     ACTIV_CONTENT_GATEWAY_API_COMMON_API virtual StatusCode BuildClosedSessionBarFromRecord(const Database::Record& record);
00613
00614 private:
00615     static void ForceDecimalType(Rational &value, const Rational::Denominator type);
00616
00617     void AdjustPriceByRatio(const Rational &ratio);
00618     void AdjustVolumeByRatio(const Rational &ratio);
00619     void AdjustPriceByAmount(const Rational &ratio);
00620     void AdjustVolumeByAmount(const Rational &ratio);
00621
00622 private:
00623     #define ACTIV_HISTORY_BAR_FLAG_LIST(d)  \
00624         d(0x04, HISTORY_BAR_TOTAL_PRICE)    \
00625         d(0x08, HISTORY_BAR_TOTAL_VALUE)    \
00626         d(0x10, HISTORY_BAR_TOTAL_VOLUME)   \
00627         d(0x20, HISTORY_BAR_OPEN_INTEREST)  \
00628         d(0x40, HISTORY_BAR_TICK_COUNT)
00629
00630     ACTIV_HISTORY_BAR_FLAG_LIST(ACTIV_DECLARE_BYTES)
00631
00632     enum BaseType
00633     {
00634         BASE_TYPE_LIST(ACTIV_DECLARE_ELEMENT_1_WITH_COMMA)
00635         NUM_BASE_TYPES
00636     };
00637
00638 private:
00639     Date                   m_date;
00640     Rational               m_open;
00641     Rational               m_high;
00642     Rational               m_low;
00643     Rational               m_close;
00644     Rational               m_totalPrice;
00645     Rational               m_totalValue;
00646     Rational               m_totalVolume;
00647     uint32_t               m_openInterest;
00648 };
00649
00650 typedef FieldSetList<HistoryBar, uint16_t> HistoryBarList;
00651
00652 // ---------------------------------------------------------------------------------------------------------------------------------
00653
00654 inline StatusCode HistoryBar::Compare(const HistoryBar &rhs, int &result) const
00655 {
00656     return m_date.Compare(rhs.m_date, result);
00657 }
00658
00659 // ---------------------------------------------------------------------------------------------------------------------------------
00660
00661 inline bool HistoryBar::operator==(const HistoryBar &rhs) const
00662 {
00663     return m_date == rhs.m_date;
00664 }
00665
00666 // ---------------------------------------------------------------------------------------------------------------------------------
00667
00668 inline bool HistoryBar::operator!=(const HistoryBar &rhs) const
00669 {
00670     return m_date != rhs.m_date;
00671 }
00672
00673 // ---------------------------------------------------------------------------------------------------------------------------------
00674
00675 inline bool HistoryBar::operator<(const HistoryBar &rhs) const
00676 {
00677     return m_date < rhs.m_date;
00678 }
00679
00680 // ---------------------------------------------------------------------------------------------------------------------------------
00681
00682 inline bool HistoryBar::operator<=(const HistoryBar &rhs) const
00683 {
00684     return m_date <= rhs.m_date;
00685 }
00686
00687 // ---------------------------------------------------------------------------------------------------------------------------------
00688
00689 inline bool HistoryBar::operator>(const HistoryBar &rhs) const
00690 {
00691     return m_date > rhs.m_date;
00692 }
00693
00694 // ---------------------------------------------------------------------------------------------------------------------------------
00695
00696 inline bool HistoryBar::operator>=(const HistoryBar &rhs) const
00697 {
00698     return m_date >= rhs.m_date;
00699 }
00700
00701 // ---------------------------------------------------------------------------------------------------------------------------------
00702
00703 inline bool HistoryBar::operator<(const DateTime &dateTime) const
00704 {
00705     return m_date < dateTime.GetDate();
00706 }
00707
00708 // ---------------------------------------------------------------------------------------------------------------------------------
00709
00710 inline bool HistoryBar::operator<=(const DateTime &dateTime) const
00711 {
00712     return m_date <= dateTime.GetDate();
00713 }
00714
00715 // ---------------------------------------------------------------------------------------------------------------------------------
00716
00717 inline bool HistoryBar::operator ==(const DateTime &dateTime) const
00718 {
00719     return m_date == dateTime.GetDate();
00720 }
00721
00722 // ---------------------------------------------------------------------------------------------------------------------------------
00723
00724 inline bool HistoryBar::operator >(const DateTime &dateTime) const
00725 {
00726     return m_date > dateTime.GetDate();
00727 }
00728
00729 // ---------------------------------------------------------------------------------------------------------------------------------
00730
00731 inline bool HistoryBar::operator >=(const DateTime &dateTime) const
00732 {
00733     return m_date >= dateTime.GetDate();
00734 }
00735
00736 // ---------------------------------------------------------------------------------------------------------------------------------
00737
00738 inline StatusCode HistoryBar::GetDate(Date &date) const
00739 {
00740     date = m_date;
00741     return STATUS_CODE_SUCCESS;
00742 }
00743
00744 // ---------------------------------------------------------------------------------------------------------------------------------
00745
00746 inline StatusCode HistoryBar::GetDateTime(DateTime &dateTime) const
00747 {
00748     dateTime.Set(m_date, Time(23,59,59));
00749     return STATUS_CODE_SUCCESS;
00750 }
00751
00752 // ---------------------------------------------------------------------------------------------------------------------------------
00753
00754 inline StatusCode HistoryBar::SetDate(const Date &date)
00755 {
00756     m_date = date;
00757     return STATUS_CODE_SUCCESS;
00758 }
00759
00760 // ---------------------------------------------------------------------------------------------------------------------------------
00761
00762 inline StatusCode HistoryBar::GetOpenPrice(Rational &price) const
00763 {
00764     price = m_open;
00765     return STATUS_CODE_SUCCESS;
00766 }
00767
00768 // ---------------------------------------------------------------------------------------------------------------------------------
00769
00770 inline StatusCode HistoryBar::GetOpenPrice(double &price) const
00771 {
00772     return m_open.GetDouble(price);
00773 }
00774
00775 // ---------------------------------------------------------------------------------------------------------------------------------
00776
00777 inline StatusCode HistoryBar::SetOpenPrice(const Rational &price)
00778 {
00779     m_open = price;
00780     return STATUS_CODE_SUCCESS;
00781 }
00782
00783 // ---------------------------------------------------------------------------------------------------------------------------------
00784
00785 inline StatusCode HistoryBar::GetHighPrice(Rational &price) const
00786 {
00787     price = m_high;
00788     return STATUS_CODE_SUCCESS;
00789 }
00790
00791 // ---------------------------------------------------------------------------------------------------------------------------------
00792
00793 inline StatusCode HistoryBar::GetHighPrice(double &price) const
00794 {
00795     return m_high.GetDouble(price);
00796 }
00797
00798 // ---------------------------------------------------------------------------------------------------------------------------------
00799
00800 inline StatusCode HistoryBar::SetHighPrice(const Rational &price)
00801 {
00802     m_high = price;
00803     return STATUS_CODE_SUCCESS;
00804 }
00805
00806 // ---------------------------------------------------------------------------------------------------------------------------------
00807
00808 inline StatusCode HistoryBar::GetLowPrice(Rational &price) const
00809 {
00810     price = m_low;
00811     return STATUS_CODE_SUCCESS;
00812 }
00813
00814 // ---------------------------------------------------------------------------------------------------------------------------------
00815
00816 inline StatusCode HistoryBar::GetLowPrice(double &price) const
00817 {
00818     return m_low.GetDouble(price);
00819 }
00820
00821 // ---------------------------------------------------------------------------------------------------------------------------------
00822
00823 inline StatusCode HistoryBar::SetLowPrice(const Rational &price)
00824 {
00825     m_low = price;
00826     return STATUS_CODE_SUCCESS;
00827 }
00828
00829 // ---------------------------------------------------------------------------------------------------------------------------------
00830
00831 inline StatusCode HistoryBar::GetClosePrice(Rational &price) const
00832 {
00833     price = m_close;
00834     return STATUS_CODE_SUCCESS;
00835 }
00836
00837 // ---------------------------------------------------------------------------------------------------------------------------------
00838
00839 inline StatusCode HistoryBar::GetClosePrice(double &price) const
00840 {
00841     return m_close.GetDouble(price);
00842 }
00843
00844 // ---------------------------------------------------------------------------------------------------------------------------------
00845
00846 inline StatusCode HistoryBar::SetClosePrice(const Rational &price)
00847 {
00848     m_close = price;
00849     return STATUS_CODE_SUCCESS;
00850 }
00851
00852 // ---------------------------------------------------------------------------------------------------------------------------------
00853
00854 inline StatusCode HistoryBar::GetTotalVolume(uint64_t &volume) const
00855 {
00856     if(Rational::DENOMINATOR_WHOLE == m_totalVolume.GetDenominator())
00857         volume = m_totalVolume.GetNumerator();
00858     else
00859     {
00860         double dSize;
00861         ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, m_totalVolume.GetDouble(dSize));
00862         volume = static_cast<uint64_t>(dSize);
00863     }
00864     return STATUS_CODE_SUCCESS;
00865 }
00866
00867 // ---------------------------------------------------------------------------------------------------------------------------------
00868
00869 inline StatusCode HistoryBar::SetTotalVolume(const uint64_t volume)
00870 {
00871     return m_totalVolume.Set(volume, Rational::DENOMINATOR_WHOLE);
00872 }
00873
00874 // ---------------------------------------------------------------------------------------------------------------------------------
00875
00876 inline StatusCode HistoryBar::GetTotalVolume(Rational &volume) const
00877 {
00878     volume = m_totalVolume;
00879     return STATUS_CODE_SUCCESS;
00880 }
00881
00882 // ---------------------------------------------------------------------------------------------------------------------------------
00883
00884 inline StatusCode HistoryBar::SetTotalVolume(const Rational &volume)
00885 {
00886     m_totalVolume = volume;
00887     return STATUS_CODE_SUCCESS;
00888 }
00889
00890 // ---------------------------------------------------------------------------------------------------------------------------------
00891
00892 inline StatusCode HistoryBar::GetTotalPrice(Rational &totalPrice) const
00893 {
00894     totalPrice = m_totalPrice;
00895     return STATUS_CODE_SUCCESS;
00896 }
00897
00898 // ---------------------------------------------------------------------------------------------------------------------------------
00899
00900 inline StatusCode HistoryBar::GetTotalPrice(double &totalPrice) const
00901 {
00902     return m_totalPrice.GetDouble(totalPrice);
00903 }
00904
00905 // ---------------------------------------------------------------------------------------------------------------------------------
00906
00907 inline StatusCode HistoryBar::SetTotalPrice(Rational &totalPrice)
00908 {
00909     m_totalPrice = totalPrice;
00910     return STATUS_CODE_SUCCESS;
00911 }
00912
00913 // ---------------------------------------------------------------------------------------------------------------------------------
00914
00915 inline StatusCode HistoryBar::GetTotalValue(Rational &totalValue) const
00916 {
00917     totalValue = m_totalValue;
00918     return STATUS_CODE_SUCCESS;
00919 }
00920
00921 // ---------------------------------------------------------------------------------------------------------------------------------
00922
00923 inline StatusCode HistoryBar::GetTotalValue(double &totalValue) const
00924 {
00925     return m_totalValue.GetDouble(totalValue);
00926 }
00927
00928 // ---------------------------------------------------------------------------------------------------------------------------------
00929
00930 inline StatusCode HistoryBar::SetTotalValue(Rational &totalValue)
00931 {
00932     m_totalValue = totalValue;
00933     return STATUS_CODE_SUCCESS;
00934 }
00935
00936 // ---------------------------------------------------------------------------------------------------------------------------------
00937
00938 inline StatusCode HistoryBar::GetOpenInterest(uint32_t &openInterest) const
00939 {
00940     openInterest = m_openInterest;
00941     return STATUS_CODE_SUCCESS;
00942 }
00943
00944 // ---------------------------------------------------------------------------------------------------------------------------------
00945
00946 inline StatusCode HistoryBar::SetOpenInterest(const uint32_t openInterest)
00947 {
00948     m_openInterest = openInterest;
00949     return STATUS_CODE_SUCCESS;
00950 }
00951
00952 // ---------------------------------------------------------------------------------------------------------------------------------
00953 /*
00954 inline StatusCode HistoryBar::GetTickCount(unsigned &count) const
00955 {
00956     count = m_tickCount;
00957     return STATUS_CODE_SUCCESS;
00958 }
00959
00960 // ---------------------------------------------------------------------------------------------------------------------------------
00961
00962 inline StatusCode HistoryBar::SetTickCount(const unsigned count)
00963 {
00964     m_tickCount = count;
00965     return STATUS_CODE_SUCCESS;
00966 }
00967 */
00968
00969 // ---------------------------------------------------------------------------------------------------------------------------------
00970
00971 inline void HistoryBar::SetToMiniBar()
00972 {
00973     m_totalPrice = 0;
00974     m_totalValue = 0;
00975 //  m_tickCount = 0;
00976 }
00977
00978 // ---------------------------------------------------------------------------------------------------------------------------------
00979
00980 inline bool HistoryBar::IsOpenValid()
00981 {
00982     return m_open >= m_low && m_open <= m_high;
00983 }
00984
00985 #undef ACTIV_DECLARE_BYTES
00986
00987 } // namespace ContentGatewayApi
00988
00989 } // namespace ContentPlatform
00990
00991 } // namespace Activ
00992
00993 #endif // (!defined ACTIV_CONTENT_GATEWAY_API_COMMON_HISTORY_BAR_H)
Generated on Wed Oct 8 14:01:45 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivSystem

IEndPoint.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_SYSTEM_IEND_POINT_H)
00010 #define ACTIV_SYSTEM_IEND_POINT_H
00011
00012 #include "ActivMiddleware/ActivSystem/External.h"
00013 #include "ActivMiddleware/ActivSystem/HeapMessage.h"
00014
00015 #include <string>
00016
00017 namespace Activ
00018 {
00019
00020 class ISystem;
00021 class SyncRequestId;
00022
00026 #define ACTIV_IENDPOINT_NOTIFICATION_TYPE_LIST(d)       \
00027     d(NOTIFICATION_TYPE_NONE, "none")                   \
00028     d(NOTIFICATION_TYPE_SEMAPHORE, "semaphore")         \
00029     d(NOTIFICATION_TYPE_EVENT, "event")                 \
00030     d(NOTIFICATION_TYPE_SOCKET, "socket")
00031
00032 // ---------------------------------------------------------------------------------------------------------------------------------
00033
00037 #define ACTIV_IENDPOINT_STATE_LIST(d)                   \
00038     d(STATE_ACCEPTING_MESSAGES, "accepting")            \
00039     d(STATE_IGNORING_MESSAGES, "ignoring")
00040
00041 // ---------------------------------------------------------------------------------------------------------------------------------
00042
00046 class IEndPoint : private boost::noncopyable
00047 {
00048 public:
00052     enum NotificationType
00053     {
00054         ACTIV_IENDPOINT_NOTIFICATION_TYPE_LIST(ACTIV_DECLARE_ELEMENT_1_WITH_COMMA)
00055         NOTIFICATION_TYPE_DEFAULT = -1,
00056 #if (defined ACTIV_PLATFORM_WINDOWS)
00057         NOTIFICATION_TYPE_MULTIPLEX = NOTIFICATION_TYPE_DEFAULT
00058 #elif (defined ACTIV_PLATFORM_POSIX)
00059         NOTIFICATION_TYPE_MULTIPLEX = NOTIFICATION_TYPE_SOCKET
00060 #else
00061 #error Configure
00062 #endif
00063     };
00064
00068     enum State
00069     {
00070         ACTIV_IENDPOINT_STATE_LIST(ACTIV_DECLARE_ELEMENT_1_WITH_COMMA)
00071         NUM_STATES
00072     };
00073
00077     class Stats
00078     {
00079     public:
00088         ACTIV_SYSTEM_EXPORTED_API
00089         StatusCode Serialize(MessageBuilder &messageBuilder) const;
00090
00099         ACTIV_SYSTEM_EXPORTED_API
00100         StatusCode Deserialize(MessageValidator &messageValidator);
00101
00102         ProcessId           m_creatorProcessId;
00103         NotificationType    m_notificationType;
00104         bool                m_hasMutex;
00105         size_t              m_mutexContentionCount;
00106         State               m_state;
00107
00108         size_t              m_messageCount;
00109         size_t              m_messageCountHigh;
00110         size_t              m_messageCountDailyHigh;
00111         size_t              m_messageCountLastHigh;
00112
00113         size_t              m_byteCount;
00114         size_t              m_byteCountHigh;
00115         size_t              m_byteCountDailyHigh;
00116         size_t              m_byteCountLastHigh;
00117
00118     private:
00119         static const byte_t currentSerializedVersion = 3;
00120     };
00121
00125     virtual ~IEndPoint() = 0;
00126
00136     virtual StatusCode PostMessage(HeapMessage &heapMessage) = 0;
00137
00148     virtual StatusCode PostMessages(IEndPoint * const pEndPoint, size_t minBytesToRemove = 0) = 0;
00149
00161     virtual StatusCode TryPostMessages(IEndPoint * const pEndPoint) = 0;
00162
00175     virtual StatusCode GetMessage(HeapMessage &heapMessage, const TimeoutPeriod timeout = ACTIV_WAIT_INFINITE) = 0;
00176
00189     virtual StatusCode GetMessages(IEndPoint * const pEndPoint, const TimeoutPeriod timeout = ACTIV_WAIT_INFINITE,
00190         size_t minBytesToRemove = 0) = 0;
00191
00195     virtual void Clear() = 0;
00196
00202     virtual void SetState(const State state) = 0;
00203
00209     virtual State GetState() const = 0;
00210
00216     virtual ISystem *GetSystem() const = 0;
00217
00223     virtual void GetStats(Stats &stats) const = 0;
00224
00228     virtual void ClearAllHighCounts() = 0;
00229
00233     virtual void ClearDailyHighCounts() = 0;
00234
00238     virtual void ClearLastHighCounts() = 0;
00239
00248     virtual void SetMaxByteCount(const size_t maxByteCount) = 0;
00249
00258     virtual StatusCode GetNotificationHandle(HANDLE &handle) const = 0;
00259
00267     ACTIV_SYSTEM_EXPORTED_API
00268     static std::string NotificationTypeToString(const NotificationType notificationType);
00269
00279     ACTIV_SYSTEM_EXPORTED_API
00280     static StatusCode StringToNotificationType(const std::string &str, NotificationType &notificationType);
00281
00289     ACTIV_SYSTEM_EXPORTED_API
00290     static std::string StateToString(const State state);
00291 };
00292
00293 // ---------------------------------------------------------------------------------------------------------------------------------
00294 // ---------------------------------------------------------------------------------------------------------------------------------
00295
00299 class ISyncEndPoint : public IEndPoint
00300 {
00301 public:
00305     class Stats : public IEndPoint::Stats
00306     {
00307     public:
00316         ACTIV_SYSTEM_EXPORTED_API
00317         StatusCode Serialize(MessageBuilder &messageBuilder) const;
00318
00327         ACTIV_SYSTEM_EXPORTED_API
00328         StatusCode Deserialize(MessageValidator &messageValidator);
00329
00330         std::string m_name;
00331         EndPointId  m_id;
00332     };
00333
00344     virtual StatusCode SendMessage(HeapMessage &heapMessage, const TimeoutPeriod timeout = ACTIV_WAIT_INFINITE) = 0;
00345
00355     virtual StatusCode SendMessage(HeapMessage &heapMessage, SyncRequestId &syncRequestId) = 0;
00356
00362     virtual std::string GetName() const = 0;
00363
00369     virtual EndPointId GetId() const = 0;
00370
00376     virtual ProcessId GetCreatorProcessId() const = 0;
00377
00383     virtual void GetStats(Stats &stats) const = 0;
00384 };
00385
00386 // ---------------------------------------------------------------------------------------------------------------------------------
00387 // ---------------------------------------------------------------------------------------------------------------------------------
00388
00389 inline IEndPoint::~IEndPoint()
00390 {
00391 }
00392
00393 } // namespace Activ
00394
00395 #endif // (!defined ACTIV_SYSTEM_IEND_POINT_H)
Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

IEvent.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_BASE_IEVENT_H)
00010 #define ACTIV_BASE_IEVENT_H
00011
00012 #include "ActivMiddleware/ActivBase/External.h"
00013
00014 namespace Activ
00015 {
00016
00020 class IEvent : private boost::noncopyable
00021 {
00022 public:
00026     typedef uint32_t Flags;
00027
00028     static const Flags FLAG_NONE = 0x00000000;
00029     static const Flags FLAG_MANUAL = 0x00000001;
00030
00034     virtual ~IEvent() = 0;
00035
00042     virtual StatusCode Set() = 0;
00043
00050     virtual StatusCode Clear() = 0;
00051
00061     virtual StatusCode Wait(const TimeoutPeriod timeout = ACTIV_WAIT_INFINITE) = 0;
00062
00071     virtual StatusCode GetHandle(HANDLE &handle) const = 0;
00072 };
00073
00074 // ---------------------------------------------------------------------------------------------------------------------------------
00075
00076 inline IEvent::~IEvent()
00077 {
00078 }
00079
00080 } // namespace Activ
00081
00082 #endif // (!defined ACTIV_BASE_IEVENT_H)
Generated on Wed Oct 8 14:01:47 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivFieldTypes

IFieldType.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FIELD_TYPES_IFIELD_TYPE_H)
00010 #define ACTIV_FIELD_TYPES_IFIELD_TYPE_H
00011
00012 #include "ActivMiddleware/ActivFieldTypes/External.h"
00013 #include "ActivMiddleware/ActivFieldTypes/ActivFieldTypes.h"
00014
00015 #include "ActivMiddleware/ActivBase/MessageValidator.h"
00016
00017 #include <string>
00018
00019 namespace Activ
00020 {
00021
00022 class MessageBuilder;
00023
00024 // ---------------------------------------------------------------------------------------------------------------------------------
00025
00029 class IFieldType
00030 {
00031 public:
00032     static const size_t MAX_SERIALIZED_BODY_LENGTH_UNDEFINED = static_cast<const size_t>(~0);
00033
00037     virtual ~IFieldType() = 0;
00038
00042     virtual void Reset() = 0;
00043
00047     virtual void Clear() = 0;
00048
00059     virtual StatusCode Compare(const void * const pRhsSerializedBody, const size_t rhsSerializedBodyLength, int &result) const = 0;
00060
00070     ACTIV_FIELD_TYPES_API StatusCode Assign(const IFieldType * const pIFieldType);
00071
00081     virtual StatusCode Convert(const IFieldType * const pIFieldType) = 0;
00082
00088     FieldType GetType() const;
00089
00095     virtual std::string ToString() const = 0;
00096
00105     virtual StatusCode FromString(MessageValidator &messageValidator) = 0;
00106
00115     StatusCode FromString(const std::string &field);
00116
00122     virtual std::string GetFromStringFormat() const = 0;
00123
00134     ACTIV_FIELD_TYPES_API StatusCode Serialize(const FieldType fieldType, MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength) const;
00135
00145     virtual StatusCode Serialize(MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength) const = 0;
00146
00158     ACTIV_FIELD_TYPES_API StatusCode SerializeBody(const FieldType fieldType, void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength) const;
00159
00170     virtual StatusCode SerializeBody(void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength) const = 0;
00171
00182     ACTIV_FIELD_TYPES_API StatusCode SerializeLengthAndBody(const FieldType fieldType, MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength = MAX_SERIALIZED_BODY_LENGTH_UNDEFINED) const;
00183
00193     virtual StatusCode SerializeLengthAndBody(MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength = MAX_SERIALIZED_BODY_LENGTH_UNDEFINED) const = 0;
00194
00205     ACTIV_FIELD_TYPES_API StatusCode Deserialize(const FieldType fieldType, MessageValidator &messageValidator, const size_t maxSerializedBodyLength);
00206
00216     virtual StatusCode Deserialize(MessageValidator &messageValidator, const size_t maxSerializedBodyLength) = 0;
00217
00228     ACTIV_FIELD_TYPES_API StatusCode DeserializeBody(const FieldType fieldType, const void * const pSerializedBody, const size_t serializedBodyLength);
00229
00239     virtual StatusCode DeserializeBody(const void * const pSerializedBody, const size_t serializedBodyLength) = 0;
00240
00251     ACTIV_FIELD_TYPES_API StatusCode DeserializeLengthAndBody(const FieldType fieldType, MessageValidator &messageValidator, const size_t maxSerializedBodyLength = MAX_SERIALIZED_BODY_LENGTH_UNDEFINED);
00252
00262     virtual StatusCode DeserializeLengthAndBody(MessageValidator &messageValidator, const size_t maxSerializedBodyLength = MAX_SERIALIZED_BODY_LENGTH_UNDEFINED) = 0;
00263
00269     virtual size_t GetSerializedLength() const = 0;
00270
00276     virtual size_t GetSerializedBodyLength() const = 0;
00277
00283     bool IsInitialized() const;
00284
00295     virtual StatusCode IsDifferent(const void * const pRhsSerializedBody, const size_t rhsSerializedBodyLength, bool &isDifferent) const = 0;
00296
00311     ACTIV_FIELD_TYPES_API static StatusCode Serialize(const FieldType fieldType, MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength, const uint8_t * const pData, const size_t size);
00312
00328     ACTIV_FIELD_TYPES_API static StatusCode SerializeBody(const FieldType fieldType, void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength, const uint8_t * const pData, const size_t size);
00329
00344     ACTIV_FIELD_TYPES_API static StatusCode SerializeLengthAndBody(const FieldType fieldType, MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength, const uint8_t * const pData, const size_t size);
00345
00358     ACTIV_FIELD_TYPES_API static StatusCode ValidateSerializedLengthAndBody(const FieldType fieldType, MessageValidator &messageValidator, size_t &serializedBodyOffset, size_t &serializedBodyLength);
00359
00368     ACTIV_FIELD_TYPES_API static bool IsValidSerializedBodyLength(const FieldType fieldType, const size_t serializedBodyLength);
00369
00370 protected:
00376     explicit IFieldType(const FieldType fieldType);
00377
00378     bool        m_isInitialized;
00379
00380 private:
00381     FieldType   m_fieldType;
00382 };
00383
00384 // ---------------------------------------------------------------------------------------------------------------------------------
00385
00386 inline IFieldType::~IFieldType()
00387 {
00388 }
00389
00390 // ---------------------------------------------------------------------------------------------------------------------------------
00391
00392 inline FieldType IFieldType::GetType() const
00393 {
00394     return m_fieldType;
00395 }
00396
00397 // ---------------------------------------------------------------------------------------------------------------------------------
00398
00399 inline StatusCode IFieldType::FromString(const std::string &field)
00400 {
00401     MessageValidator messageValidator(field.c_str(), field.length());
00402
00403     return FromString(messageValidator);
00404 }
00405
00406 // ---------------------------------------------------------------------------------------------------------------------------------
00407
00408 inline bool IFieldType::IsInitialized() const
00409 {
00410     return m_isInitialized;
00411 }
00412
00413 // ---------------------------------------------------------------------------------------------------------------------------------
00414
00415 inline IFieldType::IFieldType(const FieldType fieldType) :
00416     m_fieldType(fieldType)
00417 {
00418 }
00419
00420 } // namespace Activ
00421
00422 #endif // (!defined ACTIV_FIELD_TYPES_IFIELD_TYPE_H)
Generated on Wed Oct 8 14:01:48 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

IFileMappedMemory.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_BASE_IFILE_MAPPED_MEMORY_H)
00010 #define ACTIV_BASE_IFILE_MAPPED_MEMORY_H
00011
00012 #include "ActivMiddleware/ActivBase/External.h"
00013 #include "ActivMiddleware/ActivBase/IMappedMemory.h"
00014
00015 namespace Activ
00016 {
00017
00021 class IFileMappedMemory : public IMappedMemory
00022 {
00023 public:
00024     static const size_t USE_CURRENT_FILE_SIZE = 0;
00025
00026     typedef uint32_t FileFlags;
00027
00028     static const FileFlags FILE_FLAG_NONE = 0x00000000;
00029     static const FileFlags FILE_FLAG_CREATE_ALWAYS = 0x00000001;
00030     static const FileFlags FILE_FLAG_OPEN_EXISTING = 0x00000002;
00031     static const FileFlags FILE_FLAG_READ_ONLY = 0x00000004;
00032     static const FileFlags FILE_FLAG_DELETE_AT_CLOSE = 0x00000008;
00033
00037     virtual ~IFileMappedMemory() = 0;
00038
00048     virtual void *Resize(const size_t size) = 0;
00049
00057     virtual void Flush(const size_t nBytesToFlush = 0) const = 0;
00058 };
00059
00060 // ---------------------------------------------------------------------------------------------------------------------------------
00061
00062 inline IFileMappedMemory::~IFileMappedMemory()
00063 {
00064 }
00065
00066 } // namespace Activ
00067
00068 #endif // (!defined ACTIV_BASE_IFILE_MAPPED_MEMORY_H)
Generated on Wed Oct 8 14:01:47 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » Misc

IFtpHelper.h

Go to the documentation of this file.
00001
00011 #if (!defined ACTIV_MISC_IFTP_HELPER_H)
00012 #define ACTIV_MISC_IFTP_HELPER_H
00013
00014 #include "ActivMiddleware/ActivBase/StatusCodeException.h"
00015 #include "ActivMiddleware/ActivBase/OsException.h"
00016 #include "ActivMiddleware/ActivBase/File.h"
00017 #include "ActivMiddleware/Misc/FtpParse.h"
00018
00019 #include "curl/curl.h"
00020
00021 #include <string>
00022 #include <vector>
00023 #include <time.h>
00024
00025 namespace Activ
00026 {
00027
00033 class FileInfo
00034 {
00035 public:
00039     FileInfo();
00040
00049     static bool IsNameGreater(const FileInfo &first, const FileInfo &second);
00050
00059     static bool IsSizeGreater(const FileInfo &first, const FileInfo &second);
00060
00069     static bool IsTimeGreater(const FileInfo &first, const FileInfo &second);
00070
00079     static bool IsTimeLess(const FileInfo &first, const FileInfo &second);
00080
00088     bool operator == (const FileInfo &fileInfo) const;
00089
00097     bool operator != (const FileInfo &fileInfo) const;
00098
00099     std::string         m_name;
00100     std::string         m_directory;
00101     int64_t             m_size;
00102     DateTime            m_fileTime;
00103 };
00104
00105 // ---------------------------------------------------------------------------------------------------------------------------------
00106 // ---------------------------------------------------------------------------------------------------------------------------------
00107
00111 class StatusCodeHelper
00112 {
00113 public:
00120     StatusCodeHelper(StatusCode statusCode = STATUS_CODE_SUCCESS, const std::string &statusText = "");
00121
00127     StatusCodeHelper(const StatusCodeHelper &statusCodeHelper);
00128
00135     friend bool operator == (const StatusCode &statusCode, const StatusCodeHelper &statusCodeHelper);
00136
00143     friend bool operator != (const StatusCode &statusCode, const StatusCodeHelper &statusCodeHelper);
00144
00148     const std::string &ToString() const;
00149
00150     operator StatusCode() const
00151     {
00152         return m_statusCode;
00153     }
00154
00155 private:
00156     std::string     m_statusText;
00157     StatusCode      m_statusCode;
00158 };
00159
00163 typedef std::vector<FileInfo> FileInfoList;
00164
00165 // ---------------------------------------------------------------------------------------------------------------------------------
00166 // ---------------------------------------------------------------------------------------------------------------------------------
00167
00171 class IFtpHelper : private boost::noncopyable
00172 {
00173 public:
00182     IFtpHelper(const std::string &server, const std::string &username = "", const std::string &password = "", uint32_t port = DEFAULT_FTP_PORT);
00183
00187     virtual ~IFtpHelper();
00188
00192     virtual StatusCodeHelper Connect() = 0;
00193
00197     virtual StatusCodeHelper Disconnect() = 0;
00198
00205     virtual StatusCodeHelper GetFileList(FileInfoList &fileList, const std::string &remoteDirectory = "") = 0;
00206
00214     virtual StatusCodeHelper GetFile(const std::string &remoteFilename, const std::string &localFilename, const std::string &remoteDirectory = "") = 0;
00215
00222     virtual StatusCodeHelper DeleteFile(const std::string &remoteFilename, const std::string &remoteDirectory = "") = 0;
00223
00230     virtual StatusCodeHelper DeleteFile(const FileInfoList &fileInfoList, const std::string &remoteDirectory = "") = 0;
00231
00239     virtual StatusCodeHelper GetAndDeleteFile(const std::string &remoteFilename, const std::string &localFilename, const std::string &remoteDirectory = "") = 0;
00240
00244     virtual bool IsConnected() const = 0;
00245
00246     void SetServer(const std::string &server);
00247     void SetUsername(const std::string &username);
00248     void SetPassword(const std::string &password);
00249     void SetPort(const uint32_t &port);
00250
00251     static const uint32_t DEFAULT_FTP_PORT              = 21;
00252     static const uint32_t DEFAULT_FTP_TIMEOUT           = 300;
00253     static const uint32_t DEFAULT_FTP_LOW_SPEED_LIMIT   = 5;
00254     static const uint32_t DEFAULT_FTP_LOW_SPEED_TIME    = 120;
00255
00256 protected:
00257     std::string     m_server;
00258     std::string     m_username;
00259     std::string     m_password;
00260     uint32_t        m_port;
00261 };
00262
00263 // ---------------------------------------------------------------------------------------------------------------------------------
00264 // ---------------------------------------------------------------------------------------------------------------------------------
00265
00266 inline FileInfo::FileInfo() :
00267     m_size(0)
00268 {
00269 }
00270
00271 // ---------------------------------------------------------------------------------------------------------------------------------
00272
00273 inline bool FileInfo::IsNameGreater(const FileInfo &first, const FileInfo &second)
00274 {
00275     return (first.m_name > second.m_name);
00276 }
00277
00278 // ---------------------------------------------------------------------------------------------------------------------------------
00279
00280 inline bool FileInfo::IsSizeGreater(const FileInfo &first, const FileInfo &second)
00281 {
00282     return (first.m_size > second.m_size);
00283 }
00284
00285 // ---------------------------------------------------------------------------------------------------------------------------------
00286
00287 inline bool FileInfo::IsTimeGreater(const FileInfo &first, const FileInfo &second)
00288 {
00289     return (first.m_fileTime > second.m_fileTime);
00290 }
00291
00292 // ---------------------------------------------------------------------------------------------------------------------------------
00293
00294 inline bool FileInfo::IsTimeLess(const FileInfo &first, const FileInfo &second)
00295 {
00296     return (first.m_fileTime < second.m_fileTime);
00297 }
00298
00299 // ---------------------------------------------------------------------------------------------------------------------------------
00300
00301 inline bool FileInfo::operator == (const FileInfo &fileInfo) const
00302 {
00303     return (m_name == fileInfo.m_name);
00304 }
00305
00306 // ---------------------------------------------------------------------------------------------------------------------------------
00307
00308 inline bool FileInfo::operator != (const FileInfo &fileInfo) const
00309 {
00310     return !(*this == fileInfo);
00311 }
00312
00313 // ---------------------------------------------------------------------------------------------------------------------------------
00314 // ---------------------------------------------------------------------------------------------------------------------------------
00315
00316 inline StatusCodeHelper::StatusCodeHelper(StatusCode statusCode, const std::string &statusText) :
00317     m_statusText(statusText),
00318     m_statusCode(statusCode)
00319 {
00320 }
00321
00322 // ---------------------------------------------------------------------------------------------------------------------------------
00323
00324 inline StatusCodeHelper::StatusCodeHelper(const StatusCodeHelper &statusCodeHelper)
00325 {
00326     m_statusText = statusCodeHelper.m_statusText;
00327     m_statusCode = statusCodeHelper.m_statusCode;
00328 }
00329
00330 // ---------------------------------------------------------------------------------------------------------------------------------
00331
00332 inline const std::string &StatusCodeHelper::ToString() const
00333 {
00334     return m_statusText;
00335 }
00336
00337 // ---------------------------------------------------------------------------------------------------------------------------------
00338 // ---------------------------------------------------------------------------------------------------------------------------------
00339
00340 inline bool operator == (const StatusCode &statusCode, const StatusCodeHelper &statusCodeHelper)
00341 {
00342     return (statusCodeHelper.m_statusCode == statusCode);
00343 }
00344
00345 // ---------------------------------------------------------------------------------------------------------------------------------
00346
00347 inline bool operator != (const StatusCode &statusCode, const StatusCodeHelper &statusCodeHelper)
00348 {
00349     return !(statusCodeHelper.m_statusCode == statusCode);
00350 }
00351
00352 // ---------------------------------------------------------------------------------------------------------------------------------
00353 // ---------------------------------------------------------------------------------------------------------------------------------
00354
00355 inline IFtpHelper::IFtpHelper(const std::string &server, const std::string &username, const std::string &password, uint32_t port) :
00356     m_server(server),
00357     m_username(username),
00358     m_password(password),
00359     m_port(port)
00360 {
00361 }
00362
00363 // ---------------------------------------------------------------------------------------------------------------------------------
00364
00365 inline IFtpHelper::~IFtpHelper()
00366 {
00367 }
00368
00369 // ---------------------------------------------------------------------------------------------------------------------------------
00370
00371 inline void IFtpHelper::SetServer(const std::string &server)
00372 {
00373     m_server = server;
00374 }
00375
00376 // ---------------------------------------------------------------------------------------------------------------------------------
00377
00378 inline void IFtpHelper::SetUsername(const std::string &username)
00379 {
00380     m_username = username;
00381 }
00382
00383 // ---------------------------------------------------------------------------------------------------------------------------------
00384
00385 inline void IFtpHelper::SetPassword(const std::string &password)
00386 {
00387     m_password = password;
00388 }
00389
00390 // ---------------------------------------------------------------------------------------------------------------------------------
00391
00392 inline void IFtpHelper::SetPort(const uint32_t &port)
00393 {
00394     m_port = port;
00395 }
00396
00397 } // namespace Activ
00398
00399 #endif // (!defined ACTIV_MISC_IFTP_HELPER_H)
Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivSystem

IHeap.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_SYSTEM_IHEAP_H)
00010 #define ACTIV_SYSTEM_IHEAP_H
00011
00012 #include "ActivMiddleware/ActivSystem/External.h"
00013 #include "ActivMiddleware/ActivSystem/HeapMessage.h"
00014 #include "ActivMiddleware/ActivBase/IniFileParser.h"
00015 #include "ActivMiddleware/ActivFieldTypes/DateTime.h"
00016
00017 #include <vector>
00018
00019 namespace Activ
00020 {
00021
00022 class ISystem;
00023
00024 // ---------------------------------------------------------------------------------------------------------------------------------
00025
00029 class IHeap : private boost::noncopyable
00030 {
00031 public:
00035     class BucketInfo
00036     {
00037     public:
00038         size_t  m_blockSize;
00039         size_t  m_numBlocks;
00040     };
00041
00042     typedef std::vector<BucketInfo> BucketInfoVector;
00043
00047     class Stats
00048     {
00049     public:
00053         class RequestDistributionStats
00054         {
00055         public:
00064             ACTIV_SYSTEM_EXPORTED_API
00065             StatusCode Serialize(MessageBuilder &messageBuilder) const;
00066
00075             ACTIV_SYSTEM_EXPORTED_API
00076             StatusCode Deserialize(MessageValidator &messageValidator);
00077
00078             size_t  m_minSize;
00079             size_t  m_maxSize;
00080             size_t  m_count;
00081         };
00082
00086         class BucketStats
00087         {
00088         public:
00092             ACTIV_SYSTEM_EXPORTED_API
00093             BucketStats();
00094
00103             ACTIV_SYSTEM_EXPORTED_API
00104             StatusCode Serialize(MessageBuilder &messageBuilder) const;
00105
00114             ACTIV_SYSTEM_EXPORTED_API
00115             StatusCode Deserialize(MessageValidator &messageValidator);
00116
00117             BucketInfo  m_bucketInfo;
00118             size_t      m_numFreeBlocks;
00119             size_t      m_lowFreeBlocks;
00120             size_t      m_firstRunFails;
00121             size_t      m_secondRunFails;
00122         };
00123
00124         ACTIV_SYSTEM_EXPORTED_API
00125         Stats();
00126
00135         ACTIV_SYSTEM_EXPORTED_API
00136         StatusCode Serialize(MessageBuilder &messageBuilder) const;
00137
00146         ACTIV_SYSTEM_EXPORTED_API
00147         StatusCode Deserialize(MessageValidator &messageValidator);
00148
00149         typedef std::vector<RequestDistributionStats> DistributionVector;
00150         typedef std::vector<BucketStats> BucketStatsVector;
00151
00152         HeapId              m_id;
00153         ProcessId           m_creatorProcessId;
00154         std::string         m_name;
00155         size_t              m_memoryUsage;
00156         size_t              m_totalNumberOfBlocks;
00157
00158         size_t              m_totalFails;
00159         DateTime            m_firstFailLocalDateTime;
00160         DateTime            m_lastFailLocalDateTime;
00161
00162         size_t              m_totalCurrentFreeBlocks;
00163         size_t              m_totalLowFreeBlocks;
00164         size_t              m_idealBucketFails;
00165         size_t              m_mutexContentionCount;
00166         BucketStatsVector   m_bucketStatsVector;
00167
00168         // IHeap::SetRequestDistributionLogging(true) needs to be called for the following to be populated:
00169         size_t              m_maxRequestSize;
00170         DistributionVector  m_distributionVector;
00171
00172     private:
00173         static const byte_t currentSerializedVersion = 2;
00174         static const byte_t firstFailDefined = 0x01;
00175         static const byte_t lastFailDefined = 0x02;
00176     };
00177
00181     virtual ~IHeap() = 0;
00182
00191     virtual HeapMessage GetMessage(const size_t size) = 0;
00192
00202     virtual HeapMessage GetMessage(const size_t size, const void *pData) = 0;
00203
00214     virtual HeapMessage GetMessage(const size_t size, const void *pData, const TimeoutPeriod timeoutPeriod) = 0;
00215
00221     virtual std::string GetName() const = 0;
00222
00228     virtual HeapId GetId() const = 0;
00229
00235     virtual ISystem *GetSystem() const = 0;
00236
00242     virtual void GetStats(Stats &stats) const = 0;
00243
00247     virtual void ResetStats() = 0;
00248
00254     virtual bool GetRequestDistributionLogging() const = 0;
00255
00261     virtual void SetRequestDistributionLogging(const bool shouldEnable) = 0;
00262
00275     ACTIV_SYSTEM_EXPORTED_API
00276     static StatusCode ReadBucketInfoVector(const IniFileParser::ConstSectionIterator &sectionIterator,
00277         IHeap::BucketInfoVector &bucketInfoVector);
00278
00289     ACTIV_SYSTEM_EXPORTED_API
00290     static HeapMessage GetMessageFromList(const size_t size, ...);
00291 };
00292
00293 // ---------------------------------------------------------------------------------------------------------------------------------
00294
00295 inline IHeap::~IHeap()
00296 {
00297 }
00298
00299 } // namespace Activ
00300
00301 #endif // (!defined ACTIV_SYSTEM_IHEAP_H)
Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivDatabase

IIndex.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_DATABASE_IINDEX_H)
00010 #define ACTIV_DATABASE_IINDEX_H
00011
00012 #include "ActivMiddleware/ActivDatabase/External.h"
00013 #include "ActivMiddleware/ActivDatabase/Definitions.h"
00014
00015 #include <vector>
00016 #include <memory>
00017
00018 namespace Activ
00019 {
00020
00021 class ScatterBufferHelper;
00022 class IFieldType;
00023
00024 namespace Database
00025 {
00026
00027 class Record;
00028 class Key;
00029 class FieldList;
00030
00031 // ---------------------------------------------------------------------------------------------------------------------------------
00032
00036 class IIndex
00037 {
00038 public:
00042     virtual ~IIndex() = 0;
00043
00049     virtual void ResetKey(Key &key) const = 0;
00050
00062     virtual StatusCode BuildKey(Key &key, const byte_t *pRecordData, const DataId recordId) const = 0;
00063
00074     virtual StatusCode BuildKey(Key &targetKey, const Key &sourceKey) const = 0;
00075
00086     virtual StatusCode SetFields(Record &record, const ScatterBufferHelper &scatterBufferHelper) const = 0;
00087
00098     virtual StatusCode SetFields(Key &key, const ScatterBufferHelper &scatterBufferHelper) const = 0;
00099
00108     virtual int Compare(const Key &lhs, const Key &rhs) const = 0;
00109
00115     virtual IndexSpecification::Number GetNumber() const = 0;
00116
00122     virtual std::string GetName() const = 0;
00123
00129     virtual size_t GetKeyLength() const = 0;
00130
00136     virtual const FieldList &GetFieldList() const = 0;
00137
00143     virtual FieldSpecificationList GetFieldSpecificationList() const = 0;
00144
00150     virtual FieldIdList GetFieldIdList() const = 0;
00151
00157     virtual IndexSpecification GetSpecification() const = 0;
00158
00166     virtual size_t GetCurrentRecords() const = 0;
00167
00173     virtual bool IsPrimaryUnique() const = 0;
00174
00180     virtual bool IsUnique() const = 0;
00181
00187     virtual bool IsDuplicate() const = 0;
00188
00194     virtual bool IsTree() const = 0;
00195
00201     virtual void CheckIntegrity() const = 0;
00202 };
00203
00204 // ---------------------------------------------------------------------------------------------------------------------------------
00205
00206 inline IIndex::~IIndex()
00207 {
00208 }
00209
00210 } // namespace Database
00211
00212 } // namespace Activ
00213
00214 #endif // (!defined ACTIV_DATABASE_IINDEX_H)
Generated on Wed Oct 8 14:01:47 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

IMappedMemory.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_BASE_IMAPPED_MEMORY_H)
00010 #define ACTIV_BASE_IMAPPED_MEMORY_H
00011
00012 #include "ActivMiddleware/ActivBase/External.h"
00013
00014 namespace Activ
00015 {
00016
00020 class IMappedMemory : private boost::noncopyable
00021 {
00022 public:
00023     typedef uint32_t MappingFlags;
00024
00025     static const MappingFlags MAPPING_FLAG_NONE = 0x00000000;
00026     static const MappingFlags MAPPING_FLAG_READ_ONLY = 0x00000001;
00027     static const MappingFlags MAPPING_FLAG_UNIQUE = 0x00000002;
00028
00032     virtual ~IMappedMemory() = 0;
00033
00039     virtual void *GetPointer() const = 0;
00040
00046     virtual size_t GetSize() const = 0;
00047 };
00048
00049 // ---------------------------------------------------------------------------------------------------------------------------------
00050
00051 inline IMappedMemory::~IMappedMemory()
00052 {
00053 }
00054
00055 } // namespace Activ
00056
00057 #endif // (!defined ACTIV_BASE_IMAPPED_MEMORY_H)
Generated on Wed Oct 8 14:01:47 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

IMutex.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_BASE_IMUTEX_H)
00010 #define ACTIV_BASE_IMUTEX_H
00011
00012 #include "ActivMiddleware/ActivBase/External.h"
00013
00014 namespace Activ
00015 {
00016
00020 class IMutex : private boost::noncopyable
00021 {
00022 public:
00026     virtual ~IMutex() = 0;
00027
00034     virtual StatusCode Try() const = 0;
00035
00043     virtual StatusCode Acquire() const = 0;
00044
00051     virtual StatusCode Release() const = 0;
00052
00066     virtual size_t GetContentionCount() const = 0;
00067 };
00068
00069 // ---------------------------------------------------------------------------------------------------------------------------------
00070
00071 inline IMutex::~IMutex()
00072 {
00073 }
00074
00075 } // namespace Activ
00076
00077 #endif // (!defined ACTIV_BASE_IMUTEX_H)
Generated on Wed Oct 8 14:01:47 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivContentGatewayApi

INewsResponses.h

Go to the documentation of this file.
00001
00010 #if (!defined ACTIV_CONTENT_GATEWAY_API_INEWS_RESPONSES_H)
00011 #define ACTIV_CONTENT_GATEWAY_API_INEWS_RESPONSES_H
00012
00013 #include "ActivContentPlatform/ActivContentGatewayApi/External.h"
00014
00015 namespace Activ
00016 {
00017
00018 namespace ContentPlatform
00019 {
00020
00021 namespace ContentGatewayApi
00022 {
00023
00027 class INewsResponses
00028 {
00029 public:
00033     virtual ~INewsResponses() = 0;
00034
00043     virtual void OnGetNewsStoriesResponse(HeapMessage &response) = 0;
00044
00045
00053     virtual void OnNewsUpdate(HeapMessage &update) = 0;
00054 };
00055
00056 // ---------------------------------------------------------------------------------------------------------------------------------
00057
00058 inline INewsResponses::~INewsResponses()
00059 {
00060 }
00061
00062 } // namespace ContentGatewayApi
00063
00064 } // namespace ContentPlatform
00065
00066 } // namespace Activ
00067
00068 #endif // (!defined ACTIV_CONTENT_GATEWAY_API_INEWS_RESPONSES_H)
Generated on Wed Oct 8 14:01:44 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivSystem

IProcess.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_SYSTEM_IPROCESS_H)
00010 #define ACTIV_SYSTEM_IPROCESS_H
00011
00012 #include "ActivMiddleware/ActivSystem/External.h"
00013 #include "ActivMiddleware/ActivBase/MessageValidator.h"
00014 #include "ActivMiddleware/ActivBase/MessageBuilder.h"
00015 #include "ActivMiddleware/ActivBase/Process.h"
00016 #include "ActivMiddleware/ActivBase/Timeout.h"
00017
00018 #include <string>
00019
00023 #define ACTIV_IPROCESS_STATE_LIST(d)                \
00024     d(STATE_INITIALIZING, "initializing")           \
00025     d(STATE_RUNNING, "running")                     \
00026     d(STATE_SHUTTING_DOWN, "shutting down")         \
00027     d(STATE_EXITED, "exited")                       \
00028     d(STATE_DEAD, "dead")
00029
00030 namespace Activ
00031 {
00032
00033 class ISystem;
00034 class Uuid;
00035
00036 // ---------------------------------------------------------------------------------------------------------------------------------
00037
00041 class IProcess : private boost::noncopyable
00042 {
00043 public:
00044     typedef Process::Id OsProcessId;
00045
00049     enum State
00050     {
00051         ACTIV_IPROCESS_STATE_LIST(ACTIV_DECLARE_ELEMENT_1_WITH_COMMA)
00052         NUM_STATES
00053     };
00054
00058     class Stats
00059     {
00060     public:
00069         ACTIV_SYSTEM_EXPORTED_API
00070         StatusCode Serialize(MessageBuilder &messageBuilder) const;
00071
00080         ACTIV_SYSTEM_EXPORTED_API
00081         StatusCode Deserialize(MessageValidator &messageValidator);
00082
00083         ProcessId   m_id;
00084         OsProcessId m_osId;
00085         std::string m_name;
00086         std::string m_version;
00087         State       m_state;
00088
00089     private:
00090         static const byte_t currentSerializedVersion = 1;
00091     };
00092
00096     virtual ~IProcess() = 0;
00097
00103     virtual ProcessId GetId() const = 0;
00104
00110     virtual OsProcessId GetOsId() const = 0;
00111
00117     virtual std::string GetName() const = 0;
00118
00124     virtual const Uuid &GetUuid() const = 0;
00125
00131     virtual ISystem *GetSystem() const = 0;
00132
00138     virtual void GetStats(Stats &stats) const = 0;
00139
00145     virtual State GetState() const = 0;
00146
00152     virtual void SetState(const State state) = 0;
00153
00163     virtual StatusCode WaitForState(const State state, Timeout &timeout = Timeout::GetInfinite()) = 0;
00164
00172     ACTIV_SYSTEM_EXPORTED_API
00173     static std::string StateToString(const State state);
00174 };
00175
00176 // ---------------------------------------------------------------------------------------------------------------------------------
00177
00178 inline IProcess::~IProcess()
00179 {
00180 }
00181
00182 } // namespace Activ
00183
00184 #endif // (!defined ACTIV_SYSTEM_IPROCESS_H)
Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivContentGatewayApi

IRealtimeResponses.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_CONTENT_GATEWAY_API_IREALTIME_RESPONSES_H)
00010 #define ACTIV_CONTENT_GATEWAY_API_IREALTIME_RESPONSES_H
00011
00012 #include "ActivContentPlatform/ActivContentGatewayApi/External.h"
00013
00014 namespace Activ
00015 {
00016
00017 namespace ContentPlatform
00018 {
00019
00020 namespace ContentGatewayApi
00021 {
00022
00026 class IRealtimeResponses
00027 {
00028 public:
00032     virtual ~IRealtimeResponses() = 0;
00033
00041     virtual void OnRecordUpdate(HeapMessage &update) = 0;
00042
00052     virtual void OnGetFirstResponse(HeapMessage &response) = 0;
00053
00063     virtual void OnGetLastResponse(HeapMessage &response) = 0;
00064
00074     virtual void OnGetNextResponse(HeapMessage &response) = 0;
00075
00085     virtual void OnGetPreviousResponse(HeapMessage &response) = 0;
00086
00096     virtual void OnGetEqualResponse(HeapMessage &response) = 0;
00097
00107     virtual void OnGetMultipleEqualResponse(HeapMessage &response) = 0;
00108
00118     virtual void OnGetMultiplePatternMatchResponse(HeapMessage &response) = 0;
00119
00129     virtual void OnGetMultiplePatternMatchListResponse(HeapMessage &response) = 0;
00130
00140     virtual void OnGetMatchResponse(HeapMessage &response) = 0;
00141
00151     virtual void OnGetMultipleMatchResponse(HeapMessage &response) = 0;
00152 };
00153
00154 // ---------------------------------------------------------------------------------------------------------------------------------
00155
00156 inline IRealtimeResponses::~IRealtimeResponses()
00157 {
00158 }
00159
00160 } // namespace ContentGatewayApi
00161
00162 } // namespace ContentPlatform
00163
00164 } // namespace Activ
00165
00166 #endif // (!defined ACTIV_CONTENT_GATEWAY_API_IREALTIME_RESPONSES_H)
Generated on Wed Oct 8 14:01:44 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

ISemaphore.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_BASE_ISEMAPHORE_H)
00010 #define ACTIV_BASE_ISEMAPHORE_H
00011
00012 #include "ActivMiddleware/ActivBase/External.h"
00013
00014 namespace Activ
00015 {
00016
00020 class ISemaphore : private boost::noncopyable
00021 {
00022 public:
00026     virtual ~ISemaphore() = 0;
00027
00037     virtual StatusCode Acquire(const TimeoutPeriod timeout = ACTIV_WAIT_INFINITE) = 0;
00038
00047     virtual StatusCode Release(const size_t count = 1) = 0;
00048 };
00049
00050 // ---------------------------------------------------------------------------------------------------------------------------------
00051
00052 inline ISemaphore::~ISemaphore()
00053 {
00054 }
00055
00056 } // namespace Activ
00057
00058 #endif // (!defined ACTIV_BASE_ISEMAPHORE_H)
Generated on Wed Oct 8 14:01:47 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

ISerializableMessage.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_BASE_ISERIALIZABLE_MESSAGE_H)
00010 #define ACTIV_BASE_ISERIALIZABLE_MESSAGE_H
00011
00012 #include "ActivMiddleware/ActivBase/External.h"
00013
00014 namespace Activ
00015 {
00016
00017 class MessageValidator;
00018 class MessageBuilder;
00019
00020 // ---------------------------------------------------------------------------------------------------------------------------------
00021
00025 class ISerializableMessage
00026 {
00027 public:
00031     virtual ~ISerializableMessage() = 0;
00032
00038     virtual StatusCode Serialize(MessageBuilder &messageBuilder) const = 0;
00039
00045     virtual StatusCode Deserialize(MessageValidator &messageValidator) = 0;
00046 };
00047
00048 // ---------------------------------------------------------------------------------------------------------------------------------
00049
00050 inline ISerializableMessage::~ISerializableMessage()
00051 {
00052 }
00053
00054 } // namespace Activ
00055
00056 #endif // (!defined ACTIV_BASE_ISERIALIZABLE_MESSAGE_H)
Generated on Wed Oct 8 14:01:47 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivContentGatewayApi

ISymbolDirectoryResponses.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_CONTENT_GATEWAY_API_ISYMBOL_DIRECTORY_RESPONSES_H)
00010 #define ACTIV_CONTENT_GATEWAY_API_ISYMBOL_DIRECTORY_RESPONSES_H
00011
00012 #include "ActivContentPlatform/ActivContentGatewayApi/External.h"
00013
00014 namespace Activ
00015 {
00016
00017 namespace ContentPlatform
00018 {
00019
00020 namespace ContentGatewayApi
00021 {
00022
00026 class ISymbolDirectoryResponses
00027 {
00028 public:
00032     virtual ~ISymbolDirectoryResponses() = 0;
00033
00042     virtual void OnGetSymbolsResponse(HeapMessage &response) = 0;
00043 };
00044
00045 // ---------------------------------------------------------------------------------------------------------------------------------
00046
00047 inline ISymbolDirectoryResponses::~ISymbolDirectoryResponses()
00048 {
00049 }
00050
00051 } // namespace ContentGatewayApi
00052
00053 } // namespace ContentPlatform
00054
00055 } // namespace Activ
00056
00057 #endif // (!defined ACTIV_CONTENT_GATEWAY_API_ISYMBOL_DIRECTORY_RESPONSES_H)
Generated on Wed Oct 8 14:01:44 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivSystem

ISystem.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_SYSTEM_ISYSTEM_H)
00010 #define ACTIV_SYSTEM_ISYSTEM_H
00011
00012 #include "ActivMiddleware/ActivSystem/External.h"
00013 #include "ActivMiddleware/ActivSystem/IProcess.h"
00014 #include "ActivMiddleware/ActivSystem/IEndPoint.h"
00015 #include "ActivMiddleware/ActivSystem/IHeap.h"
00016 #include "ActivMiddleware/ActivBase/IniFileParser.h"
00017 #include "ActivMiddleware/ActivBase/Process.h"
00018 #include "ActivMiddleware/ActivBase/SystemInfo.h"
00019 #include "ActivMiddleware/ActivBase/Timeout.h"
00020 #include "ActivMiddleware/ActivFieldTypes/DateTime.h"
00021
00022 namespace Activ
00023 {
00024
00030 class ISystem : private boost::noncopyable
00031 {
00032 public:
00033
00037     class Settings
00038     {
00039     public:
00040         enum MemoryModel
00041         {
00042             MEMORY_MODEL_SHARED,
00043             MEMORY_MODEL_PRIVATE
00044         };
00045
00046         enum SystemLogMode
00047         {
00048             SYSTEM_LOG_MODE_OFF,
00049             SYSTEM_LOG_MODE_TO_CONSOLE,
00050             SYSTEM_LOG_MODE_TO_AGENT
00051         };
00052
00056         ACTIV_SYSTEM_EXPORTED_API
00057         Settings();
00058
00067         ACTIV_SYSTEM_EXPORTED_API
00068         StatusCode Read(const IniFileParser::ConstSectionIterator &sectionIterator);
00069
00070         std::string             m_systemName;
00071         MemoryModel             m_memoryModel;
00072         std::string             m_processVersion;
00073         bool                    m_setConsoleTitle;
00074         SystemLogMode           m_systemLogMode;
00075         uint32_t                m_smallBlockHeapThreshold;
00076         uint32_t                m_minimumTimerResolution;
00077         Process::ProcessorList  m_processorAffinityList;
00078
00079     protected:
00080         ACTIV_SYSTEM_EXPORTED_API
00081         static const std::string sectionName;
00082     };
00083
00087     class SystemInfo : public Activ::SystemInfo
00088     {
00089     public:
00093         ACTIV_SYSTEM_EXPORTED_API
00094         SystemInfo();
00095
00103         ACTIV_SYSTEM_EXPORTED_API
00104         StatusCode Serialize(MessageBuilder &messageBuilder) const;
00105
00114         ACTIV_SYSTEM_EXPORTED_API
00115         StatusCode Serialize(MessageBuilder &messageBuilder, const SystemInfo &systemInfo) const;
00116
00124         ACTIV_SYSTEM_EXPORTED_API
00125         StatusCode Deserialize(MessageValidator &messageValidator);
00126
00127         std::string             m_systemName;
00128         std::string             m_systemVersion;
00129         Settings::MemoryModel   m_memoryModel;
00130         DateTime                m_utcStartupDateTime;
00131         size_t                  m_upTimeSeconds;
00132
00133     private:
00142         ACTIV_SYSTEM_LOCAL_API
00143         StatusCode Serialize(MessageBuilder &messageBuilder, const byte_t version) const;
00144
00145         static const byte_t     currentVersion = 1;
00146
00147         byte_t                  m_version;
00148     };
00149
00153     class IProcessEnumerator
00154     {
00155     public:
00159         virtual ~IProcessEnumerator() = 0;
00160
00169         virtual bool OnObject(IProcess * const pProcess) = 0;
00170     };
00171
00175     class IEndPointEnumerator
00176     {
00177     public:
00181         virtual ~IEndPointEnumerator() = 0;
00182
00191         virtual bool OnObject(ISyncEndPoint * const pEndPoint) = 0;
00192     };
00193
00197     class IHeapEnumerator
00198     {
00199     public:
00203         virtual ~IHeapEnumerator() = 0;
00204
00213         virtual bool OnObject(IHeap * const pHeap) = 0;
00214     };
00215
00219     virtual ~ISystem() = 0;
00220
00231     virtual IEndPoint *CreatePrivateEndPoint(const bool hasMutex, const IEndPoint::NotificationType notificationType) = 0;
00232
00249     virtual ISyncEndPoint *CreateEndPoint(const std::string &name, const bool hasMutex,
00250         const IEndPoint::NotificationType notificationType) = 0;
00251
00262     virtual ISyncEndPoint *OpenEndPoint(const std::string &name, Timeout &timeout = Timeout::GetInfinite()) = 0;
00263
00274     virtual ISyncEndPoint *OpenEndPoint(EndPointId endPointId, Timeout &timeout = Timeout::GetInfinite()) = 0;
00275
00290     virtual IHeap *CreateHeap(const std::string &name, const IHeap::BucketInfoVector &bucketInfoVector) = 0;
00291
00302     virtual IHeap *OpenHeap(const std::string &name, Timeout &timeout = Timeout::GetInfinite()) = 0;
00303
00314     virtual IHeap *OpenHeap(const HeapId heapId, Timeout &timeout = Timeout::GetInfinite()) = 0;
00315
00326     virtual IProcess *OpenProcess(const std::string &name, Timeout &timeout = Timeout::GetInfinite()) = 0;
00327
00338     virtual IProcess *OpenProcess(const ProcessId processId, Timeout &timeout = Timeout::GetInfinite()) = 0;
00339
00345     virtual std::string GetSystemName() const = 0;
00346
00352     virtual IHeap *GetSystemHeap() const = 0;
00353
00359     virtual IProcess *GetProcess() const = 0;
00360
00368     virtual SystemInfo GetSystemInfo() const = 0;
00369
00376     virtual void EnumerateObjects(IProcessEnumerator &enumerator) = 0;
00377
00384     virtual void EnumerateObjects(IEndPointEnumerator &enumerator) = 0;
00385
00392     virtual void EnumerateObjects(IHeapEnumerator &enumerator) = 0;
00393 };
00394
00395 // ---------------------------------------------------------------------------------------------------------------------------------
00396
00397 inline ISystem::~ISystem()
00398 {
00399 }
00400
00401 // ---------------------------------------------------------------------------------------------------------------------------------
00402 // ---------------------------------------------------------------------------------------------------------------------------------
00403
00404 inline ISystem::IProcessEnumerator::~IProcessEnumerator()
00405 {
00406 }
00407
00408 // ---------------------------------------------------------------------------------------------------------------------------------
00409 // ---------------------------------------------------------------------------------------------------------------------------------
00410
00411 inline ISystem::IEndPointEnumerator::~IEndPointEnumerator()
00412 {
00413 }
00414
00415 // ---------------------------------------------------------------------------------------------------------------------------------
00416 // ---------------------------------------------------------------------------------------------------------------------------------
00417
00418 inline ISystem::IHeapEnumerator::~IHeapEnumerator()
00419 {
00420 }
00421
00422 } // namespace Activ
00423
00424 #endif // (!defined ACTIV_SYSTEM_ISYSTEM_H)
Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivDatabase

ITable.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_DATABASE_ITABLE_H)
00010 #define ACTIV_DATABASE_ITABLE_H
00011
00012 #include "ActivMiddleware/ActivDatabase/External.h"
00013 #include "ActivMiddleware/ActivDatabase/Definitions.h"
00014 #include "ActivMiddleware/ActivDatabase/DatabaseException.h"
00015
00016 #include <iostream>
00017 #include <vector>
00018 #include <memory>
00019
00020 namespace Activ
00021 {
00022
00023 class ScatterBufferHelper;
00024 class MessageBuilder;
00025 class MessageValidator;
00026 class IFieldType;
00027
00028 namespace Database
00029 {
00030
00031 class IIndex;
00032 class Record;
00033 class Key;
00034 class FieldList;
00035
00036 typedef std::vector<FieldSpecification::Id> FieldIdList;
00037 typedef std::vector<Record> RecordList;
00038 typedef std::vector<Key> KeyList;
00039
00040 // ---------------------------------------------------------------------------------------------------------------------------------
00041
00045 class ITable
00046 {
00047 public:
00048     typedef ITable *Identity;
00049
00053     ITable();
00054
00058     virtual ~ITable() = 0;
00059
00065     virtual void CreateRecordFile() = 0;
00066
00074     virtual StatusCode OpenRecordFile() = 0;
00075
00082     virtual StatusCode CloseRecordFile() = 0;
00083
00090     virtual StatusCode Convert() = 0;
00091
00101     virtual StatusCode Save(const std::string &directory) = 0;
00102
00113     virtual StatusCode CopyFiles(const std::string &sourceDirectory, const std::string &targetDirectory) const = 0;
00114
00123     void CreateIndexes(IndexSpecification indexSpecificationList[], const size_t nIndexSpecifications);
00124
00132     virtual void CreateIndexes(IndexSpecificationList &indexSpecificationList) = 0;
00133
00143     virtual void CreateTemporaryIndex(IndexSpecification &indexSpecification) = 0;
00144
00162     virtual ITable *Clone(const std::string &directory = std::string(), const bool createMutex = false, const bool copyRecords = true, size_t recordsPerRequest = 20) const = 0;
00163
00170     virtual StatusCode Clear() = 0;
00171
00193     virtual StatusCode Copy(const ITable *pSourceTable, const bool clearTargetTable = true, size_t recordsPerRequest = 20) = 0;
00194
00205     virtual StatusCode SerializeSpecification(MessageBuilder &messageBuilder) const = 0;
00206
00221     virtual StatusCode Serialize(MessageBuilder &messageBuilder, const KeyList &keyList) const = 0;
00222
00238     virtual StatusCode Serialize(MessageBuilder &messageBuilder, const RecordList &recordList) const = 0;
00239
00256     virtual StatusCode Serialize(MessageBuilder &messageBuilder, const std::vector<StatusCode> &statusCodeList, const RecordList &recordList) const = 0;
00257
00270     virtual StatusCode Deserialize(MessageValidator &messageValidator, KeyList &keyList) const = 0;
00271
00285     virtual StatusCode Deserialize(MessageValidator &messageValidator, RecordList &recordList) const = 0;
00286
00300     virtual StatusCode Deserialize(MessageValidator &messageValidator, DataId &recordId, size_t &maxResponseRecords) const = 0;
00301
00316     virtual StatusCode Deserialize(MessageValidator &messageValidator, std::vector<StatusCode> &statusCodeList, RecordList &recordList) const = 0;
00317
00326     virtual StatusCode ResetRecord(Record &record) const = 0;
00327
00343     virtual StatusCode Add(Record &record) = 0;
00344
00361     virtual StatusCode Add(Record &record, const FieldIdList &modifiedFieldIdList) = 0;
00362
00379     virtual StatusCode Add(Record &record, Record &originalRecord) = 0;
00380
00395     virtual StatusCode Delete(const Key &key) = 0;
00396
00412     virtual StatusCode Delete(const Key &key, Record &record) = 0;
00413
00428     virtual StatusCode GetEqual(const Key &key, Record &record) const = 0;
00429
00445     virtual StatusCode GetEqual(const KeyList &keyList, std::vector<StatusCode> &statusCodeList, RecordList &recordList) const = 0;
00446
00461     virtual StatusCode GetFirst(Key &key, Record &record) const = 0;
00462
00478     virtual StatusCode GetFirst(Key &key, RecordList &recordList, const size_t maxResponseRecords = 0) const = 0;
00479
00494     virtual StatusCode GetLast(Key &key, Record &record) const = 0;
00495
00511     virtual StatusCode GetLast(Key &key, RecordList &recordList, const size_t maxResponseRecords = 0) const = 0;
00512
00527     virtual StatusCode GetNext(Key &key, Record &record) const = 0;
00528
00544     virtual StatusCode GetNext(Key &key, RecordList &recordList, const size_t maxResponseRecords = 0) const = 0;
00545
00560     virtual StatusCode GetPrevious(Key &key, Record &record) const = 0;
00561
00577     virtual StatusCode GetPrevious(Key &key, RecordList &recordList, const size_t maxResponseRecords = 0) const = 0;
00578
00596     virtual StatusCode GetFirstPartial(Key &key, Record &record, const FieldSpecification::Id lastKeyFieldId, const size_t lastKeyCompareLength = FIELD_COMPARE_LENGTH_WHOLE) const = 0;
00597
00616     virtual StatusCode GetFirstPartial(Key &key, RecordList &recordList, const FieldSpecification::Id lastKeyFieldId, const size_t lastKeyCompareLength = FIELD_COMPARE_LENGTH_WHOLE, const size_t maxResponseRecords = 0) const = 0;
00617
00634     virtual StatusCode GetLastPartial(Key &key, Record &record, const FieldSpecification::Id lastKeyFieldId, const size_t lastKeyCompareLength = FIELD_COMPARE_LENGTH_WHOLE) const = 0;
00635
00654     virtual StatusCode GetLastPartial(Key &key, RecordList &recordList, const FieldSpecification::Id lastKeyFieldId, const size_t lastKeyCompareLength = FIELD_COMPARE_LENGTH_WHOLE, const size_t maxResponseRecords = 0) const = 0;
00655
00673     virtual StatusCode GetNextPartial(Key &key, Record &record, const FieldSpecification::Id lastKeyFieldId, const size_t lastKeyCompareLength = FIELD_COMPARE_LENGTH_WHOLE) const = 0;
00674
00694     virtual StatusCode GetNextPartial(Key &key, RecordList &recordList, const FieldSpecification::Id lastKeyFieldId, const size_t lastKeyCompareLength = FIELD_COMPARE_LENGTH_WHOLE, const size_t maxResponseRecords = 0) const = 0;
00695
00713     virtual StatusCode GetPreviousPartial(Key &key, Record &record, const FieldSpecification::Id lastKeyFieldId, const size_t lastKeyCompareLength = FIELD_COMPARE_LENGTH_WHOLE) const = 0;
00714
00734     virtual StatusCode GetPreviousPartial(Key &key, RecordList &recordList, const FieldSpecification::Id lastKeyFieldId, const size_t lastKeyCompareLength = FIELD_COMPARE_LENGTH_WHOLE, const size_t maxResponseRecords = 0) const = 0;
00735
00749     virtual StatusCode StepFirst(DataId &recordId, Record &record) const = 0;
00750
00765     virtual StatusCode StepFirst(DataId &recordId, RecordList &recordList, const size_t maxResponseRecords = 0) const = 0;
00766
00779     virtual StatusCode StepNext(DataId &recordId, Record &record) const = 0;
00780
00795     virtual StatusCode StepNext(DataId &recordId, RecordList &recordList, const size_t maxResponseRecords = 0) const = 0;
00796
00810     virtual StatusCode SetIndexFields(Record &record, const IndexSpecification::Number indexNo, const ScatterBufferHelper &scatterBufferHelper) const = 0;
00811
00818     virtual void CheckIntegrity() const = 0;
00819
00825     virtual const FieldList &GetFieldList() const = 0;
00826
00832     virtual TableSpecification GetTableSpecification() const = 0;
00833
00839     virtual FieldSpecificationList GetFieldSpecificationList() const = 0;
00840
00849     virtual bool GetFieldSpecificationList(const FieldSpecification &fieldSpecification, FieldSpecificationList &matchingFieldSpecificationList) const = 0;
00850
00860     virtual StatusCode GetFieldSpecification(const FieldSpecification::Id fieldId, FieldSpecification &fieldSpecification) const = 0;
00861
00867     virtual void GetFirstFieldSpecification(FieldSpecification &fieldSpecification) const = 0;
00868
00878     virtual StatusCode GetNextFieldSpecification(FieldSpecification &fieldSpecification) const = 0;
00879
00885     virtual IndexSpecificationList GetIndexSpecificationList() const = 0;
00886
00895     virtual bool GetIndexSpecificationList(const IndexSpecification &indexSpecification, IndexSpecificationList &matchingIndexSpecificationList) const = 0;
00896
00906     virtual StatusCode GetIndexSpecification(const IndexSpecification::Number indexNo, IndexSpecification &indexSpecification) const = 0;
00907
00913     virtual FieldIdList GetFieldIdList() const = 0;
00914
00920     virtual void GetFirstFieldId(FieldSpecification::Id &fieldId) const = 0;
00921
00931     virtual StatusCode GetNextFieldId(FieldSpecification::Id &fieldId) const = 0;
00932
00943     virtual StatusCode GetType(const FieldSpecification::Id fieldId, FieldSpecification::Type &type) const = 0;
00944
00950     virtual std::string GetName() const = 0;
00951
00957     virtual std::string GetDirectory() const = 0;
00958
00964     virtual std::string GetBasicFileName() const = 0;
00965
00973     virtual StatusCode GetMaxRecords(size_t &maxRecords) const = 0;
00974
00982     virtual StatusCode GetCurrentRecords(size_t &nRecords) const = 0;
00983
00989     virtual size_t GetRecordLength() const = 0;
00990
00996     virtual size_t GetNumberOfIndexes() const = 0;
00997
01003     virtual IndexSpecification::Number GetPrimaryIndexNumber() const = 0;
01004
01014     virtual StatusCode GetIndexPointer(const IndexSpecification::Number indexNo, IIndex *&pIndex) const = 0;
01015
01021     void SetIdentity(const Identity identity = 0);
01022
01028     Identity GetIdentity() const;
01029
01035     void SetMode(const Mode mode);
01036
01042     Mode GetMode() const;
01043
01049     virtual bool IsRecordFileOpen() const = 0;
01050
01056     virtual bool IsTemporary() const = 0;
01057
01068     virtual bool IsAdd(const Record &record, const Record &originalRecord) const = 0;
01069
01080     virtual bool IsUpdate(const Record &record, const Record &originalRecord) const = 0;
01081
01087     virtual bool IsFound(const FieldSpecification::Id fieldId) const = 0;
01088
01094     virtual bool IsManaged() const = 0;
01095
01096 #if defined (_DEBUG)
01097
01102     virtual void DisplayFieldInformation(std::ostream &os = std::cout) const = 0;
01103
01110     virtual void DisplayKeyFieldInformation(const IndexSpecification::Number indexNo, std::ostream &os = std::cout) const = 0;
01111 #endif
01112
01113 protected:
01114     Identity        m_identity;
01115     Mode            m_mode;
01116
01117 private:
01125     ITable(const ITable &rhs);
01126
01136     ITable &operator=(const ITable &rhs);
01137 };
01138
01139 // ---------------------------------------------------------------------------------------------------------------------------------
01140
01141 inline ITable::ITable() : m_identity(this)
01142 {
01143 }
01144
01145 // ---------------------------------------------------------------------------------------------------------------------------------
01146
01147 inline ITable::~ITable()
01148 {
01149 }
01150
01151 // ---------------------------------------------------------------------------------------------------------------------------------
01152
01153 inline void ITable::CreateIndexes(IndexSpecification indexSpecificationList[], const size_t nIndexSpecifications)
01154 {
01155     IndexSpecificationList indexSpecificationVector(indexSpecificationList, indexSpecificationList + nIndexSpecifications);
01156
01157     CreateIndexes(indexSpecificationVector);
01158
01159     const IndexSpecificationList::const_iterator iteratorEnd = indexSpecificationVector.end();
01160     IndexSpecificationList::const_iterator iterator = indexSpecificationVector.begin();
01161
01162     for (size_t i = 0; iteratorEnd != iterator; ++i, ++iterator)
01163         indexSpecificationList[i].m_number = iterator->m_number;
01164 }
01165
01166 // ---------------------------------------------------------------------------------------------------------------------------------
01167
01168 inline void ITable::SetIdentity(const Identity identity)
01169 {
01170     m_identity = identity;
01171 }
01172
01173 // ---------------------------------------------------------------------------------------------------------------------------------
01174
01175 inline ITable::Identity ITable::GetIdentity() const
01176 {
01177     return m_identity;
01178 }
01179
01180 // ---------------------------------------------------------------------------------------------------------------------------------
01181
01182 inline void ITable::SetMode(const Mode mode)
01183 {
01184     m_mode = mode;
01185 }
01186
01187 // ---------------------------------------------------------------------------------------------------------------------------------
01188
01189 inline Mode ITable::GetMode() const
01190 {
01191     return m_mode;
01192 }
01193
01194 // ---------------------------------------------------------------------------------------------------------------------------------
01195
01196 } // namespace Database
01197
01198 } // namespace Activ
01199
01200 #endif // (!defined ACTIV_DATABASE_ITABLE_H)
Generated on Wed Oct 8 14:01:47 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivContentGatewayApi

ITimeSeriesResponses.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_CONTENT_GATEWAY_API_ITIME_SERIES_RESPONSES_H)
00010 #define ACTIV_CONTENT_GATEWAY_API_ITIME_SERIES_RESPONSES_H
00011
00012 #include "ActivContentPlatform/ActivContentGatewayApi/External.h"
00013
00014 namespace Activ
00015 {
00016
00017 namespace ContentPlatform
00018 {
00019
00020 namespace ContentGatewayApi
00021 {
00022
00026 class ITimeSeriesResponses
00027 {
00028 public:
00032     virtual ~ITimeSeriesResponses() = 0;
00033
00042     virtual void OnGetFirstHistoryResponse(HeapMessage &response) = 0;
00043
00052     virtual void OnGetNextHistoryResponse(HeapMessage &response) = 0;
00053
00062     virtual void OnGetFirstIntradayResponse(HeapMessage &response) = 0;
00063
00072     virtual void OnGetNextIntradayResponse(HeapMessage &response) = 0;
00073
00082     virtual void OnGetFirstTicksResponse(HeapMessage &response) = 0;
00083
00092     virtual void OnGetNextTicksResponse(HeapMessage &response) = 0;
00093 };
00094
00095 // ---------------------------------------------------------------------------------------------------------------------------------
00096
00097 inline ITimeSeriesResponses::~ITimeSeriesResponses()
00098 {
00099 }
00100
00101 } // namespace ContentGatewayApi
00102
00103 } // namespace ContentPlatform
00104
00105 } // namespace Activ
00106
00107 #endif // (!defined ACTIV_CONTENT_GATEWAY_API_ITIME_SERIES_RESPONSES_H)
Generated on Wed Oct 8 14:01:44 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedTableTemplateHandler

Index.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FEED_TABLE_TEMPLATE_HANDLER_INDEX_H)
00010 #define ACTIV_FEED_TABLE_TEMPLATE_HANDLER_INDEX_H
00011
00012 #include "ActivMiddleware/ActivDatabase/Record.h"
00013
00014 #include "ActivContentPlatform/ActivFeedCommon/IndexNumbers.h"
00015 #include "ActivContentPlatform/ActivFeedCommon/UniversalFieldHelper.h"
00016 #include "ActivContentPlatform/ActivFeedCommon/FieldIds.h"
00017
00018 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/External.h"
00019 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/Field.h"
00020
00021 #include "xercesc/dom/DOMNode.hpp"
00022
00023 #include <vector>
00024 #include <string>
00025
00026 // ---------------------------------------------------------------------------------------------------------------------------------
00027
00028 namespace Activ
00029 {
00030
00031 namespace ContentPlatform
00032 {
00033
00034 namespace Feed
00035 {
00036
00037 class TableTemplate;
00038
00039 // ---------------------------------------------------------------------------------------------------------------------------------
00040
00041 class Index
00042 {
00043 public:
00044     typedef std::vector<Field>::const_iterator ConstIterator;
00045
00051     class IndexFieldSpecification
00052     {
00053     public:
00059         ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API IndexFieldSpecification(const FieldId id);
00060
00061         FieldId m_id;
00062     };
00063
00064     typedef std::vector<IndexFieldSpecification> IndexFieldSpecificationList;
00065
00071     class Specification
00072     {
00073     public:
00083         ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API Specification(const IndexNumber number, const std::string &name, const IndexType type, const IndexProperties properties, const IndexFieldSpecificationList &indexFieldSpecificationList);
00084
00085         IndexNumber                     m_number;
00086         std::string                     m_name;
00087         IndexType                       m_type;
00088         IndexProperties                 m_properties;
00089         IndexFieldSpecificationList     m_indexFieldSpecificationList;
00090     };
00091
00092     typedef std::vector<Specification> IndexSpecificationList;
00093
00101     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API Index();
00102
00113     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API Index(const TableTemplate &tableTemplate, const Specification &specification);
00114
00125     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API Index(const TableTemplate &tableTemplate, const xercesc::DOMNode &domNode);
00126
00141     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API Index(const TableTemplate &tableTemplate, Application &application, const ServiceHandle &serviceHandle, const Database::Record &record, IHeap * const pHeap = 0, const std::string &componentId = Component::defaultComponentId);
00142
00146     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API ~Index();
00147
00159     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API StatusCode Initialize(const TableTemplate &tableTemplate, const Specification &specification);
00160
00172     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API StatusCode Initialize(const TableTemplate &tableTemplate, const xercesc::DOMNode &domNode);
00173
00189     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API StatusCode Initialize(const TableTemplate &tableTemplate, Application &application, const ServiceHandle &serviceHandle, const Database::Record &record, IHeap * const pHeap = 0, const std::string &componentId = Component::defaultComponentId);
00190
00198     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API bool operator==(const Index &rhs) const;
00199
00207     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API bool operator!=(const Index &rhs) const;
00208
00214     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API const TableTemplate *GetTableTemplate() const;
00215
00221     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API IndexNumber GetNumber() const;
00222
00228     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API std::string GetName() const;
00229
00235     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API IndexType GetType() const;
00236
00242     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API IndexProperties GetProperties() const;
00243
00249     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API size_t GetNumberOfFields() const;
00250
00260     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API StatusCode GetIndexField(const FieldId fieldId, const Field *&pField) const;
00261
00267     static std::string GetUiHeading();
00268
00274     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API std::string ToString() const;
00275
00281     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API ConstIterator Begin() const;
00282
00288     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API ConstIterator End() const;
00289
00295     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API bool IsPrimaryUnique() const;
00296
00302     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API bool IsUnique() const;
00303
00309     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API bool IsDuplicate() const;
00310
00316     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API bool IsHash() const;
00317
00323     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API bool IsTree() const;
00324
00325 private:
00326     typedef std::vector<Field> IndexFieldList;
00327
00338     StatusCode GetIndexField(const FieldId fieldId, Field *&pField) const;
00339
00340     const TableTemplate         *m_pTableTemplate;
00341
00342     IndexNumber                 m_number;
00343     std::string                 m_name;
00344     IndexType                   m_type;
00345     IndexProperties             m_properties;
00346     IndexFieldList              m_indexFieldList;
00347
00348     std::string                 m_error;
00349 };
00350
00351 typedef std::vector<Index> IndexList;
00352
00353 // ---------------------------------------------------------------------------------------------------------------------------------
00354
00355 } // namespace Feed
00356
00357 } // namespace ContentPlatform
00358
00359 } // namespace Activ
00360
00361 // ---------------------------------------------------------------------------------------------------------------------------------
00362
00371 ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API std::ostream &operator<<(std::ostream &os, const Activ::ContentPlatform::Feed::Index &rhs);
00372
00373 #endif // (!defined ACTIV_FEED_TABLE_TEMPLATE_HANDLER_INDEX_H)
Generated on Wed Oct 8 14:01:46 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon

IndexNumbers.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FEED_COMMON_INDEX_NUMBERS_H)
00010 #define ACTIV_FEED_COMMON_INDEX_NUMBERS_H
00011
00012 #include "ActivContentPlatform/ActivFeedCommon/External.h"
00013 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedDefinitions.h"
00014
00015 namespace Activ
00016 {
00017
00018 namespace ContentPlatform
00019 {
00020
00021 namespace Feed
00022 {
00023
00029 #define ACTIV_INDEX_TYPE_LIST(d)            \
00030     d(INDEX_TYPE_RED_BLACK_TREE,    Tree)   \
00031     d(INDEX_TYPE_HASH,              Hash)
00032
00036 #define ACTIV_DECLARE_INDEX_TYPE_ENUMERATIONS(id, name) id,
00037
00038 // ---------------------------------------------------------------------------------------------------------------------------------
00039
00043 enum
00044 {
00045     ACTIV_INDEX_TYPE_LIST(ACTIV_DECLARE_INDEX_TYPE_ENUMERATIONS)
00046     NUMBER_OF_INDEX_TYPES,
00047     INDEX_TYPE_UNKNOWN = static_cast<IndexType>(~0)
00048 };
00049
00050 #undef ACTIV_DECLARE_INDEX_TYPE_ENUMERATIONS
00051
00059 ACTIV_FEED_COMMON_API std::string IndexTypeToString(const IndexType indexType);
00060
00068 ACTIV_FEED_COMMON_API IndexType StringToIndexType(const std::string &name);
00069
00070 // ---------------------------------------------------------------------------------------------------------------------------------
00071
00075 #define ACTIV_DECLARE_INDEX_PROPERTIES_ENUMERATIONS(id, name)   id,
00076
00082 #define ACTIV_INDEX_PROPERTIES_LIST(d)                  \
00083     d(INDEX_PROPERTY_NONE,              None)           \
00084     d(INDEX_PROPERTY_UNIQUE,            Unique)         \
00085     d(INDEX_PROPERTY_DUPLICATE,         Duplicate)      \
00086     d(INDEX_PROPERTY_PRIMARY_UNIQUE,    PrimaryUnique)
00087
00088 // ---------------------------------------------------------------------------------------------------------------------------------
00089
00093 enum
00094 {
00095     ACTIV_INDEX_PROPERTIES_LIST(ACTIV_DECLARE_INDEX_PROPERTIES_ENUMERATIONS)
00096     NUMBER_OF_INDEX_PROPERTIES,
00097     INDEX_PROPERTY_UNKNOWN = static_cast<IndexProperties>(~0)
00098 };
00099
00100 #undef ACTIV_DECLARE_INDEX_PROPERTIES_ENUMERATIONS
00101
00109 ACTIV_FEED_COMMON_API std::string IndexPropertiesToString(const IndexProperties indexProperties);
00110
00118 ACTIV_FEED_COMMON_API IndexProperties StringToIndexProperties(const std::string &name);
00119
00120 } // namespace Feed
00121
00122 } // namespace ContentPlatform
00123
00124 } // namespace Activ
00125
00126 #endif // (!defined ACTIV_FEED_COMMON_INDEX_NUMBERS_H)
Generated on Wed Oct 8 14:01:46 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

IniFileParser.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_BASE_INI_FILE_PARSER_H)
00010 #define ACTIV_BASE_INI_FILE_PARSER_H
00011
00012 #include "ActivMiddleware/ActivBase/External.h"
00013 #include "ActivMiddleware/ActivBase/Exception.h"
00014 #include "ActivMiddleware/Misc/SerializableContainerHelper.h"
00015
00016 #include <string>
00017 #include <vector>
00018
00019 namespace Activ
00020 {
00021
00022 class MessageBuilder;
00023 class MessageValidator;
00024
00025 // ---------------------------------------------------------------------------------------------------------------------------------
00026
00032 class IniFileParser
00033 {
00034 private:
00035     typedef std::pair<std::string, std::string> Key;
00036     typedef std::vector<Key> KeyList;
00037     typedef std::pair<std::string, KeyList> Section;
00038     typedef std::vector<Section> SectionList;
00039
00040 public:
00044     class ParseException : public Exception
00045     {
00046     public:
00056         ACTIV_BASE_EXPORTED_API ParseException(const char *file, const char *function, const uint_fast32_t line,
00057             const size_t offset, const std::string &validPart);
00058
00059         ACTIV_BASE_EXPORTED_API virtual std::string ToString() const;
00060
00061         const size_t        m_offset;
00062         const std::string   m_validPart;
00063     };
00064
00065     static const char SECTION_DELIMITER = ':';
00066     static const size_t MATCH_LENGTH_COMPLETE = static_cast<size_t>(~0);
00067
00068     class ConstSectionIterator;
00069
00073     class ConstKeyIterator
00074     {
00075     public:
00081         ACTIV_BASE_EXPORTED_API const std::string GetName() const;
00082
00090         ACTIV_BASE_EXPORTED_API StatusCode GetStringValue(std::string &value) const;
00091
00100         ACTIV_BASE_EXPORTED_API StatusCode GetStringValueList(std::vector<std::string> &valueList,
00101             const std::string &delimiterList = std::string(",")) const;
00102
00112         template<typename T>
00113         ACTIV_TEMPLATE_API(ACTIV_BASE_EXPORTED_API) StatusCode GetSignedValue(T &value) const;
00114
00125         template<typename T>
00126         ACTIV_TEMPLATE_API(ACTIV_BASE_EXPORTED_API) StatusCode GetSignedValueList(std::vector<T> &valueList,
00127             const std::string &delimiterList = std::string(",")) const;
00128
00138         template<typename T>
00139         ACTIV_TEMPLATE_API(ACTIV_BASE_EXPORTED_API) StatusCode GetUnsignedValue(T &value) const;
00140
00151         template<typename T>
00152         ACTIV_TEMPLATE_API(ACTIV_BASE_EXPORTED_API) StatusCode GetUnsignedValueList(std::vector<T> &valueList,
00153             const std::string &delimiterList = std::string(",")) const;
00154
00163         ACTIV_BASE_EXPORTED_API StatusCode GetRealValue(double &value) const;
00164
00175         ACTIV_BASE_EXPORTED_API StatusCode GetRealValueList(std::vector<double> &valueList,
00176             const std::string &delimiterList = std::string(",")) const;
00177
00186         ACTIV_BASE_EXPORTED_API StatusCode GetBooleanValue(bool &value) const;
00187
00193         ACTIV_BASE_EXPORTED_API ConstKeyIterator &operator++();
00194
00202         ACTIV_BASE_EXPORTED_API bool operator==(const ConstKeyIterator &rhs) const;
00203
00211         ACTIV_BASE_EXPORTED_API bool operator!=(const ConstKeyIterator &rhs) const;
00212
00213     private:
00221         ACTIV_BASE_LOCAL_API ConstKeyIterator(const Section &section, const KeyList::const_iterator &iterator,
00222             const size_t matchLength);
00223
00224         const Section &         m_section;
00225         KeyList::const_iterator m_iterator;
00226         const size_t            m_matchLength;
00227
00228         friend class ConstSectionIterator;
00229     };
00230
00234     class ConstSectionIterator
00235     {
00236     public:
00242         ACTIV_BASE_EXPORTED_API const std::string &GetName() const;
00243
00249         ACTIV_BASE_EXPORTED_API std::string GetSubName() const;
00250
00257         ACTIV_BASE_EXPORTED_API ConstKeyIterator BeginKey() const;
00258
00264         ACTIV_BASE_EXPORTED_API ConstKeyIterator EndKey() const;
00265
00274         ACTIV_BASE_EXPORTED_API ConstKeyIterator FindKey(const std::string &keyName,
00275             const size_t matchLength = MATCH_LENGTH_COMPLETE) const;
00276
00283         ACTIV_BASE_EXPORTED_API ConstSectionIterator BeginSubSection() const;
00284
00290         ACTIV_BASE_EXPORTED_API ConstSectionIterator EndSubSection() const;
00291
00300         ACTIV_BASE_EXPORTED_API ConstSectionIterator FindSubSection(const std::string &subSectionName,
00301             const size_t matchLength = MATCH_LENGTH_COMPLETE) const;
00302
00308         ACTIV_BASE_EXPORTED_API ConstSectionIterator EndSection() const;
00309
00319         ACTIV_BASE_EXPORTED_API StatusCode GetStringValue(const std::string &keyName, std::string &value) const;
00320
00331         ACTIV_BASE_EXPORTED_API StatusCode GetStringValueList(const std::string &keyName, std::vector<std::string> &valueList,
00332             const std::string &delimiterList = std::string(",")) const;
00333
00345         template<typename T>
00346         StatusCode GetSignedValue(const std::string &keyName, T &value) const;
00347
00360         template<typename T>
00361         StatusCode GetSignedValueList(const std::string &keyName, std::vector<T> &valueList,
00362             const std::string &delimiterList = std::string(",")) const;
00363
00375         template<typename T>
00376         StatusCode GetUnsignedValue(const std::string &keyName, T &value) const;
00377
00390         template<typename T>
00391         StatusCode GetUnsignedValueList(const std::string &keyName, std::vector<T> &valueList,
00392             const std::string &delimiterList = std::string(",")) const;
00393
00404         ACTIV_BASE_EXPORTED_API StatusCode GetRealValue(const std::string &keyName, double &value) const;
00405
00417         ACTIV_BASE_EXPORTED_API StatusCode GetRealValueList(const std::string &keyName, std::vector<double> &valueList,
00418             const std::string &delimiterList = std::string(",")) const;
00419
00430         ACTIV_BASE_EXPORTED_API StatusCode GetBooleanValue(const std::string &keyName, bool &value) const;
00431
00437         ACTIV_BASE_EXPORTED_API ConstSectionIterator &operator++();
00438
00446         ACTIV_BASE_EXPORTED_API bool operator==(const ConstSectionIterator &rhs) const;
00447
00455         ACTIV_BASE_EXPORTED_API bool operator!=(const ConstSectionIterator &rhs) const;
00456
00457     private:
00465         ACTIV_BASE_LOCAL_API ConstSectionIterator(const IniFileParser &iniFileParser, const SectionList::const_iterator &iterator,
00466             const size_t matchLength);
00467
00468         const IniFileParser &       m_iniFileParser;
00469         SectionList::const_iterator m_iterator;
00470         const size_t                m_matchLength;
00471
00472         friend class IniFileParser;
00473     };
00474
00478     ACTIV_BASE_EXPORTED_API IniFileParser();
00479
00488     ACTIV_BASE_EXPORTED_API IniFileParser(const std::string &iniFileName);
00489
00499     ACTIV_BASE_EXPORTED_API IniFileParser(const byte_t * const pBuffer, const size_t bufferLength);
00500
00504     ACTIV_BASE_EXPORTED_API ~IniFileParser();
00505
00512     ACTIV_BASE_EXPORTED_API ConstSectionIterator BeginSection() const;
00513
00519     ACTIV_BASE_EXPORTED_API ConstSectionIterator EndSection() const;
00520
00529     ACTIV_BASE_EXPORTED_API ConstSectionIterator FindSection(const std::string &sectionName,
00530         const size_t matchLength = MATCH_LENGTH_COMPLETE) const;
00531
00542     ACTIV_BASE_EXPORTED_API StatusCode GetStringValue(const std::string &sectionName, const std::string &keyName,
00543         std::string &value) const;
00544
00557     ACTIV_BASE_EXPORTED_API StatusCode GetStringValueList(const std::string &sectionName, const std::string &keyName,
00558         std::vector<std::string> &valueList, const std::string &delimiterList = std::string(",")) const;
00559
00572     template<typename T>
00573     StatusCode GetSignedValue(const std::string &sectionName, const std::string &keyName, T &value) const;
00574
00588     template<typename T>
00589     StatusCode GetSignedValueList(const std::string &sectionName, const std::string &keyName,
00590         std::vector<T> &valueList, const std::string &delimiterList = std::string(",")) const;
00591
00604     template<typename T>
00605     StatusCode GetUnsignedValue(const std::string &sectionName, const std::string &keyName, T &value) const;
00606
00620     template<typename T>
00621     StatusCode GetUnsignedValueList(const std::string &sectionName, const std::string &keyName,
00622         std::vector<T> &valueList, const std::string &delimiterList = std::string(",")) const;
00623
00635     ACTIV_BASE_EXPORTED_API StatusCode GetRealValue(const std::string &sectionName, const std::string &keyName,
00636         double &value) const;
00637
00651     ACTIV_BASE_EXPORTED_API StatusCode GetRealValueList(const std::string &sectionName, const std::string &keyName,
00652         std::vector<double> &valueList, const std::string &delimiterList = std::string(",")) const;
00653
00665     ACTIV_BASE_EXPORTED_API StatusCode GetBooleanValue(const std::string &sectionName, const std::string &keyName,
00666         bool &value) const;
00667
00675     ACTIV_BASE_EXPORTED_API StatusCode Serialize(MessageBuilder &messageBuilder) const;
00676
00684     ACTIV_BASE_EXPORTED_API StatusCode Deserialize(MessageValidator &messageValidator);
00685
00694     ACTIV_BASE_EXPORTED_API static std::string GetSectionName(const size_t count, ...);
00695
00696     class Grammar;
00697
00698 private:
00702     class SectionSerializer
00703     {
00704     public:
00713         ACTIV_BASE_LOCAL_API static StatusCode Serialize(MessageBuilder &messageBuilder, const Section &section);
00714
00723         ACTIV_BASE_LOCAL_API static StatusCode Deserialize(MessageValidator &messageValidator, Section &section);
00724     };
00725
00729     class KeySerializer
00730     {
00731     public:
00740         ACTIV_BASE_LOCAL_API static StatusCode Serialize(MessageBuilder &messageBuilder, const Key &key);
00741
00750         ACTIV_BASE_LOCAL_API static StatusCode Deserialize(MessageValidator &messageValidator, Key &key);
00751     };
00752
00753     typedef SerializableContainerHelper<SectionList, uint32_t, 0, UINT32_MAX, SectionSerializer>    SectionListSerializer;
00754     typedef SerializableContainerHelper<KeyList, uint32_t, 0, UINT32_MAX, KeySerializer>            KeyListSerializer;
00755
00756     SectionList m_sectionList;
00757 };
00758
00759 // ---------------------------------------------------------------------------------------------------------------------------------
00760
00761 template<typename T>
00762 StatusCode IniFileParser::GetSignedValue(const std::string &sectionName, const std::string &keyName, T &value) const
00763 {
00764     ConstSectionIterator iter = FindSection(sectionName);
00765
00766     if (iter == EndSection())
00767         return STATUS_CODE_NOT_FOUND;
00768
00769     return iter.GetSignedValue(keyName, value);
00770 }
00771
00772 // ---------------------------------------------------------------------------------------------------------------------------------
00773
00774 template<typename T>
00775 StatusCode IniFileParser::GetSignedValueList(const std::string &sectionName, const std::string &keyName, std::vector<T> &valueList, const std::string &delimiterList) const
00776 {
00777     ConstSectionIterator iter = FindSection(sectionName);
00778
00779     if (iter == EndSection())
00780         return STATUS_CODE_NOT_FOUND;
00781
00782     return iter.GetSignedValueList(keyName, valueList, delimiterList);
00783 }
00784
00785 // ---------------------------------------------------------------------------------------------------------------------------------
00786
00787 template<typename T>
00788 StatusCode IniFileParser::GetUnsignedValue(const std::string &sectionName, const std::string &keyName, T &value) const
00789 {
00790     ConstSectionIterator iter = FindSection(sectionName);
00791
00792     if (iter == EndSection())
00793         return STATUS_CODE_NOT_FOUND;
00794
00795     return iter.GetUnsignedValue(keyName, value);
00796 }
00797
00798 // ---------------------------------------------------------------------------------------------------------------------------------
00799
00800 template<typename T>
00801 StatusCode IniFileParser::GetUnsignedValueList(const std::string &sectionName, const std::string &keyName, std::vector<T> &valueList, const std::string &delimiterList) const
00802 {
00803     ConstSectionIterator iter = FindSection(sectionName);
00804
00805     if (iter == EndSection())
00806         return STATUS_CODE_NOT_FOUND;
00807
00808     return iter.GetUnsignedValueList(keyName, valueList, delimiterList);
00809 }
00810
00811 // ---------------------------------------------------------------------------------------------------------------------------------
00812 // ---------------------------------------------------------------------------------------------------------------------------------
00813
00814 template<typename T>
00815 StatusCode IniFileParser::ConstSectionIterator::GetSignedValue(const std::string &keyName, T &value) const
00816 {
00817     ConstKeyIterator iter = FindKey(keyName);
00818
00819     if (iter == EndKey())
00820         return STATUS_CODE_NOT_FOUND;
00821
00822     return iter.GetSignedValue(value);
00823 }
00824
00825 // ---------------------------------------------------------------------------------------------------------------------------------
00826
00827 template<typename T>
00828 StatusCode IniFileParser::ConstSectionIterator::GetSignedValueList(const std::string &keyName, std::vector<T> &valueList, const std::string &delimiterList) const
00829 {
00830     ConstKeyIterator iter = FindKey(keyName);
00831
00832     if (iter == EndKey())
00833         return STATUS_CODE_NOT_FOUND;
00834
00835     return iter.GetSignedValueList(valueList, delimiterList);
00836 }
00837
00838 // ---------------------------------------------------------------------------------------------------------------------------------
00839
00840 template<typename T>
00841 StatusCode IniFileParser::ConstSectionIterator::GetUnsignedValue(const std::string &keyName, T &value) const
00842 {
00843     ConstKeyIterator iter = FindKey(keyName);
00844
00845     if (iter == EndKey())
00846         return STATUS_CODE_NOT_FOUND;
00847
00848     return iter.GetUnsignedValue(value);
00849 }
00850
00851 // ---------------------------------------------------------------------------------------------------------------------------------
00852
00853 template<typename T>
00854 StatusCode IniFileParser::ConstSectionIterator::GetUnsignedValueList(const std::string &keyName, std::vector<T> &valueList, const std::string &delimiterList) const
00855 {
00856     ConstKeyIterator iter = FindKey(keyName);
00857
00858     if (iter == EndKey())
00859         return STATUS_CODE_NOT_FOUND;
00860
00861     return iter.GetUnsignedValueList(valueList, delimiterList);
00862 }
00863
00864 } // namepsace Activ
00865
00866 #endif // (!defined ACTIV_BASE_INI_FILE_PARSER_H)
Generated on Wed Oct 8 14:01:47 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » Config » Compilers

Intel.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_CONFIG_COMPILERS_INTEL_H)
00010 #define ACTIV_CONFIG_COMPILERS_INTEL_H
00011
00012 #define ACTIV_COMPILER_NAME "Intel C++ Compiler version " ACTIV_STRINGIZE(__INTEL_COMPILER)
00013
00014 #define ACTIV_BUILDING_DLL_EXPORTED_API     __declspec (dllexport)
00015 #define ACTIV_BUILDING_DLL_INLINE_API
00016 #define ACTIV_BUILDING_DLL_LOCAL_API
00017 #define ACTIV_USING_DLL_EXPORTED_API        __declspec (dllimport)
00018 #define ACTIV_USING_DLL_INLINE_API
00019 #define ACTIV_USING_DLL_LOCAL_API
00020
00021 #define ACTIV_BUILDING_LIB_EXPORTED_API
00022 #define ACTIV_BUILDING_LIB_INLINE_API
00023 #define ACTIV_BUILDING_LIB_LOCAL_API
00024 #define ACTIV_USING_LIB_EXPORTED_API
00025 #define ACTIV_USING_LIB_INLINE_API
00026 #define ACTIV_USING_LIB_LOCAL_API
00027
00036 #define ACTIV_DECLARE_UNINITIALIZED_VARIABLE(type, name, dummyValue) type name
00037
00052 #define ACTIV_TEMPLATE_API(a)
00053
00054 #define snprintf    _snprintf
00055 #define vsnprintf   _vsnprintf
00056
00057 // "C4355: 'this' : used in base member initializer list"
00058 #pragma warning(disable:4355)
00059
00060 #endif // (!defined ACTIV_CONFIG_COMPILERS_INTEL_H)
Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

IntervalTimer.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_BASE_INTERVAL_TIMER_H)
00010 #define ACTIV_BASE_INTERVAL_TIMER_H
00011
00012 #include "ActivMiddleware/ActivBase/External.h"
00013 #include "ActivMiddleware/ActivBase/ActivBase.h"
00014
00015 namespace Activ
00016 {
00017
00021 class IntervalTimer
00022 {
00023 public:
00027     class Scoped : private boost::noncopyable
00028     {
00029     public:
00038         Scoped(IntervalTimer &intervalTimer, double &time);
00039
00045         ~Scoped();
00046
00047     private:
00048         IntervalTimer & m_intervalTimer;
00049         double &        m_time;
00050         const uint64_t  m_startTimeStamp;
00051     };
00052
00058     ACTIV_BASE_EXPORTED_API IntervalTimer();
00059
00065     ACTIV_BASE_INLINE_API uint64_t GetFrequency() const;
00066
00072     ACTIV_BASE_INLINE_API double ScaleTimeStamp(const uint64_t time) const;
00073
00079     ACTIV_BASE_EXPORTED_API static uint64_t GetTimeStamp();
00080
00086     ACTIV_BASE_EXPORTED_API static uint32_t GetTickCount();
00087
00088 private:
00089     const uint64_t  m_frequency;
00090 };
00091
00092 // ---------------------------------------------------------------------------------------------------------------------------------
00093
00094 inline uint64_t IntervalTimer::GetFrequency() const
00095 {
00096     return m_frequency;
00097 }
00098
00099 // ---------------------------------------------------------------------------------------------------------------------------------
00100
00101 inline double IntervalTimer::ScaleTimeStamp(const uint64_t time) const
00102 {
00103     return static_cast<double>(time) / static_cast<double>(m_frequency);
00104 }
00105
00106 // ---------------------------------------------------------------------------------------------------------------------------------
00107 // ---------------------------------------------------------------------------------------------------------------------------------
00108
00109 inline IntervalTimer::Scoped::Scoped(IntervalTimer &intervalTimer, double &time) :
00110     m_intervalTimer(intervalTimer),
00111     m_time(time),
00112     m_startTimeStamp(GetTimeStamp())
00113 {
00114 }
00115
00116 // ---------------------------------------------------------------------------------------------------------------------------------
00117
00118 inline IntervalTimer::Scoped::~Scoped()
00119 {
00120     m_time = m_intervalTimer.ScaleTimeStamp(GetTimeStamp() - m_startTimeStamp);
00121 }
00122
00123 } // namespace Activ
00124
00125 #endif // (!defined ACTIV_BASE_INTERVAL_TIMER_H)
Generated on Wed Oct 8 14:01:47 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivContentGatewayApiCommon

IntradayBar.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_CONTENT_GATEWAY_API_COMMON_INTRADAY_BAR_H)
00010 #define ACTIV_CONTENT_GATEWAY_API_COMMON_INTRADAY_BAR_H
00011
00012 #include "External.h"
00013 #include "ActivContentPlatform/ActivContentGatewayApiCommon/FieldSet.h"
00014
00015 #include "ActivMiddleware/ActivFieldTypes/Date.h"
00016 #include "ActivMiddleware/ActivFieldTypes/Time.h"
00017 #include "ActivMiddleware/ActivFieldTypes/Rational.h"
00018
00019 #include "ActivMiddleware/Misc/SerializableContainerHelper.h"
00020
00021 namespace Activ
00022 {
00023
00024 namespace ContentPlatform
00025 {
00026
00027 namespace ContentGatewayApi
00028 {
00029
00030 #define ACTIV_DECLARE_BYTES(value, id)  static const byte_t id = value;
00031
00032 // ---------------------------------------------------------------------------------------------------------------------------------
00033
00034 // forward reference
00035
00036 class Tick;
00037
00038 // ---------------------------------------------------------------------------------------------------------------------------------
00039
00043 class IntradayBar : public FieldSet
00044 {
00045 public:
00046     #define ACTIV_INTRADAY_BAR_FLAG_LIST(d)         \
00047         d(0x01, NONE_REGULAR_HOUR_TRADE_BIT)        \
00048         d(0x02, VWAP_ONLY_BIT)
00049
00050     ACTIV_INTRADAY_BAR_FLAG_LIST(ACTIV_DECLARE_BYTES)
00051
00052
00055     ACTIV_CONTENT_GATEWAY_API_COMMON_API IntradayBar();
00056
00060     ACTIV_CONTENT_GATEWAY_API_COMMON_API virtual ~IntradayBar();
00061
00065     ACTIV_CONTENT_GATEWAY_API_COMMON_API virtual void Reset();
00066
00077     ACTIV_CONTENT_GATEWAY_API_COMMON_API virtual StatusCode GetField(const Feed::FieldId fieldId, IFieldType &field) const;
00078
00089     ACTIV_CONTENT_GATEWAY_API_COMMON_API virtual StatusCode SetField(const Feed::FieldId fieldId, const IFieldType &field);
00090
00096     ACTIV_CONTENT_GATEWAY_API_COMMON_API virtual FieldSetType GetType() const;
00097
00103     ACTIV_CONTENT_GATEWAY_API_COMMON_API virtual std::string ToString(const std::string &deliminator = DEFAULT_STRING_FIELD_SEPARATER) const;
00104
00112     ACTIV_CONTENT_GATEWAY_API_COMMON_API virtual StatusCode FromString(const std::string &inputStr, const std::string &deliminator = DEFAULT_STRING_FIELD_SEPARATER);
00113
00122     ACTIV_CONTENT_GATEWAY_API_COMMON_API virtual StatusCode Serialize(MessageBuilder &messageBuilder) const;
00123
00132     ACTIV_CONTENT_GATEWAY_API_COMMON_API virtual StatusCode Deserialize(MessageValidator &messageValidator);
00133
00139     ACTIV_CONTENT_GATEWAY_API_COMMON_API virtual size_t GetSerializedLength() const;
00140
00146     ACTIV_CONTENT_GATEWAY_API_COMMON_API static size_t GetMaxSerializedLength();
00147
00155     ACTIV_CONTENT_GATEWAY_API_COMMON_API bool Compare(const IntradayBar &rhs) const;
00156
00166     StatusCode Compare(const IntradayBar &rhs, int &result) const;
00167
00175     bool operator==(const IntradayBar &rhs) const;
00176
00184     bool operator!=(const IntradayBar &rhs) const;
00185
00193     bool operator<(const IntradayBar &rhs) const;
00194
00202     bool operator<=(const IntradayBar &rhs) const;
00203
00211     bool operator>(const IntradayBar &rhs) const;
00212
00220     bool operator>=(const IntradayBar &rhs) const;
00221
00229     bool operator <(const DateTime &dateTime) const;
00230     bool operator <=(const DateTime &dateTime) const;
00231
00239     bool operator ==(const DateTime &dateTime) const;
00240
00248     bool operator >(const DateTime &dateTime) const;
00249     bool operator >=(const DateTime &dateTime) const;
00250
00259     StatusCode SetDate(const Date &date);
00260
00269     StatusCode SetTime(const Time &time);
00270
00279     StatusCode GetDateTime(DateTime &dateTime) const;
00280
00289     StatusCode SetDateTime(const DateTime &dateTime);
00290
00299     StatusCode GetOpenPrice(Rational &price) const;
00300
00309     StatusCode GetOpenPrice(double &price) const;
00310
00319     StatusCode SetOpenPrice(const Rational &price);
00320
00329     StatusCode GetHighPrice(Rational &price) const;
00330
00339     StatusCode GetHighPrice(double &price) const;
00340
00349     StatusCode SetHighPrice(const Rational &price);
00350
00359     StatusCode GetLowPrice(Rational &price) const;
00360
00369     StatusCode GetLowPrice(double &price) const;
00370
00379     StatusCode SetLowPrice(const Rational &price);
00380
00389     StatusCode GetClosePrice(Rational &price) const;
00390
00399     StatusCode GetClosePrice(double &price) const;
00400
00409     StatusCode SetClosePrice(const Rational &price);
00410
00419     StatusCode GetTotalVolume(uint32_t &volume) const;
00420
00429     StatusCode SetTotalVolume(const uint32_t volume);
00430
00439     StatusCode GetTotalVolume(Rational &volume) const;
00440
00449     StatusCode SetTotalVolume(const Rational& volume);
00450
00459     StatusCode GetTotalPrice(Rational &totalPrice) const;
00460
00469     StatusCode GetTotalPrice(double &totalPrice) const;
00470
00479     StatusCode SetTotalPrice(Rational &totalPrice);
00480
00489     StatusCode GetTotalValue(Rational &totalValue) const;
00490
00499     StatusCode GetTotalValue(double &totalValue) const;
00500
00509     StatusCode SetTotalValue(Rational &totalValue);
00510
00519     StatusCode GetTickCount(uint32_t &count) const;
00520
00529     StatusCode SetTickCount(const uint32_t count);
00530
00538     StatusCode SetFlag(const byte_t flag);
00539
00547     StatusCode GetFlag(byte_t &flag) const;
00548
00553     bool IsRegularHour() const;
00554
00558     bool IsVWAPOnly() const;
00559
00569     ACTIV_CONTENT_GATEWAY_API_COMMON_API StatusCode ProcessSplit(const int sharesBefore, const int sharesAfter, const Rational::Denominator type);
00570
00583     ACTIV_CONTENT_GATEWAY_API_COMMON_API FieldSet::UpdateFieldSetStatus Update(const unsigned period, const Tick &tick, bool updateHighLow, bool updateVwap);
00584
00595     ACTIV_CONTENT_GATEWAY_API_COMMON_API FieldSet::UpdateFieldSetStatus Update(const unsigned period, const IntradayBar &bar);
00596
00605     ACTIV_CONTENT_GATEWAY_API_COMMON_API StatusCode RemoveTrade(const Tick &canceledTrade);
00606
00610     void SetToMiniBar();
00611
00615     bool HasTick() const;
00616
00617 private:
00621     void SetVWAPOnlyBit();
00622
00626     void SetNoneRegularTradeBit();
00627
00631     void RemoveVWAPOnlyBit();
00632
00636     void RemoveNoneRegularTradeBit();
00637
00641     bool BelongToNextBar(const DateTime newDateTime, const unsigned period) const;
00642
00643 private:
00644     DateTime               m_dateTime;
00645     Rational               m_open;
00646     Rational               m_high;
00647     Rational               m_low;
00648     Rational               m_close;
00649     Rational               m_totalPrice;
00650     Rational               m_totalValue;
00651     Rational               m_totalVolume;
00652     uint32_t               m_tickCount;
00653     byte_t                 m_flag;
00654 };
00655
00656 typedef FieldSetList<IntradayBar, uint16_t> IntradayBarList;
00657
00658 // ---------------------------------------------------------------------------------------------------------------------------------
00659
00660 inline StatusCode IntradayBar::Compare(const IntradayBar &rhs, int &result) const
00661 {
00662     return m_dateTime.Compare(rhs.m_dateTime, result);
00663 }
00664
00665 // ---------------------------------------------------------------------------------------------------------------------------------
00666
00667 inline bool IntradayBar::operator==(const IntradayBar &rhs) const
00668 {
00669     return m_dateTime == rhs.m_dateTime;
00670 }
00671
00672 // ---------------------------------------------------------------------------------------------------------------------------------
00673
00674 inline bool IntradayBar::operator!=(const IntradayBar &rhs) const
00675 {
00676     return m_dateTime != rhs.m_dateTime;
00677 }
00678
00679 // ---------------------------------------------------------------------------------------------------------------------------------
00680
00681 inline bool IntradayBar::operator<(const IntradayBar &rhs) const
00682 {
00683     return m_dateTime < rhs.m_dateTime;
00684 }
00685
00686 // ---------------------------------------------------------------------------------------------------------------------------------
00687
00688 inline bool IntradayBar::operator<=(const IntradayBar &rhs) const
00689 {
00690     return m_dateTime <= rhs.m_dateTime;
00691 }
00692
00693 // ---------------------------------------------------------------------------------------------------------------------------------
00694
00695 inline bool IntradayBar::operator>(const IntradayBar &rhs) const
00696 {
00697     return m_dateTime > rhs.m_dateTime;
00698 }
00699
00700 // ---------------------------------------------------------------------------------------------------------------------------------
00701
00702 inline bool IntradayBar::operator>=(const IntradayBar &rhs) const
00703 {
00704     return m_dateTime >= rhs.m_dateTime;
00705 }
00706
00707 // ---------------------------------------------------------------------------------------------------------------------------------
00708
00709 inline bool IntradayBar::operator<(const DateTime &dateTime) const
00710 {
00711     return m_dateTime < dateTime;
00712 }
00713
00714 // ---------------------------------------------------------------------------------------------------------------------------------
00715
00716 inline bool IntradayBar::operator<=(const DateTime &dateTime) const
00717 {
00718     return m_dateTime <= dateTime;
00719 }
00720
00721 // ---------------------------------------------------------------------------------------------------------------------------------
00722
00723 inline  bool IntradayBar::operator ==(const DateTime &dateTime) const
00724 {
00725     return m_dateTime == dateTime;
00726 }
00727
00728 // ---------------------------------------------------------------------------------------------------------------------------------
00729
00730 inline bool IntradayBar::operator >(const DateTime &dateTime) const
00731 {
00732     return m_dateTime > dateTime;
00733 }
00734
00735 // ---------------------------------------------------------------------------------------------------------------------------------
00736
00737 inline bool IntradayBar::operator >=(const DateTime &dateTime) const
00738 {
00739     return m_dateTime >= dateTime;
00740 }
00741
00742 // ---------------------------------------------------------------------------------------------------------------------------------
00743
00744 inline StatusCode IntradayBar::GetDateTime(DateTime &dateTime) const
00745 {
00746     dateTime = m_dateTime;
00747     return STATUS_CODE_SUCCESS;
00748 }
00749
00750 // ---------------------------------------------------------------------------------------------------------------------------------
00751
00752 inline StatusCode IntradayBar::SetDateTime(const DateTime &dateTime)
00753 {
00754     m_dateTime = dateTime;
00755     return STATUS_CODE_SUCCESS;
00756 }
00757
00758 // ---------------------------------------------------------------------------------------------------------------------------------
00759
00760 inline StatusCode IntradayBar::SetDate(const Date &date)
00761 {
00762     m_dateTime.Set(date, m_dateTime.GetTime());
00763     return STATUS_CODE_SUCCESS;
00764 }
00765
00766 // ---------------------------------------------------------------------------------------------------------------------------------
00767
00768 inline StatusCode IntradayBar::SetTime(const Time &time)
00769 {
00770     m_dateTime.Set(m_dateTime.GetDate(), time);
00771     return STATUS_CODE_SUCCESS;
00772 }
00773
00774 // ---------------------------------------------------------------------------------------------------------------------------------
00775
00776 inline StatusCode IntradayBar::GetOpenPrice(Rational &price) const
00777 {
00778     price = m_open;
00779     return STATUS_CODE_SUCCESS;
00780 }
00781
00782 // ---------------------------------------------------------------------------------------------------------------------------------
00783
00784 inline StatusCode IntradayBar::GetOpenPrice(double &price) const
00785 {
00786     return m_open.GetDouble(price);
00787 }
00788
00789 // ---------------------------------------------------------------------------------------------------------------------------------
00790
00791 inline StatusCode IntradayBar::SetOpenPrice(const Rational &price)
00792 {
00793     m_open = price;
00794     return STATUS_CODE_SUCCESS;
00795 }
00796
00797 // ---------------------------------------------------------------------------------------------------------------------------------
00798
00799 inline StatusCode IntradayBar::GetHighPrice(Rational &price) const
00800 {
00801     price = m_high;
00802     return STATUS_CODE_SUCCESS;
00803 }
00804
00805 // ---------------------------------------------------------------------------------------------------------------------------------
00806
00807 inline StatusCode IntradayBar::GetHighPrice(double &price) const
00808 {
00809     return m_high.GetDouble(price);
00810 }
00811
00812 // ---------------------------------------------------------------------------------------------------------------------------------
00813
00814 inline StatusCode IntradayBar::SetHighPrice(const Rational &price)
00815 {
00816     m_high = price;
00817     return STATUS_CODE_SUCCESS;
00818 }
00819
00820 // ---------------------------------------------------------------------------------------------------------------------------------
00821
00822 inline StatusCode IntradayBar::GetLowPrice(Rational &price) const
00823 {
00824     price = m_low;
00825     return STATUS_CODE_SUCCESS;
00826 }
00827
00828 // ---------------------------------------------------------------------------------------------------------------------------------
00829
00830 inline StatusCode IntradayBar::GetLowPrice(double &price) const
00831 {
00832     return m_low.GetDouble(price);
00833 }
00834
00835 // ---------------------------------------------------------------------------------------------------------------------------------
00836
00837 inline StatusCode IntradayBar::SetLowPrice(const Rational &price)
00838 {
00839     m_low = price;
00840     return STATUS_CODE_SUCCESS;
00841 }
00842
00843 // ---------------------------------------------------------------------------------------------------------------------------------
00844
00845 inline StatusCode IntradayBar::GetClosePrice(Rational &price) const
00846 {
00847     price = m_close;
00848     return STATUS_CODE_SUCCESS;
00849 }
00850
00851 // ---------------------------------------------------------------------------------------------------------------------------------
00852
00853 inline StatusCode IntradayBar::GetClosePrice(double &price) const
00854 {
00855     return m_close.GetDouble(price);
00856 }
00857
00858 // ---------------------------------------------------------------------------------------------------------------------------------
00859
00860 inline StatusCode IntradayBar::SetClosePrice(const Rational &price)
00861 {
00862     m_close = price;
00863     return STATUS_CODE_SUCCESS;
00864 }
00865
00866 // ---------------------------------------------------------------------------------------------------------------------------------
00867
00868 inline StatusCode IntradayBar::GetTotalVolume(uint32_t &volume) const
00869 {
00870     if(Rational::DENOMINATOR_WHOLE == m_totalVolume.GetDenominator())
00871         volume = static_cast<uint32_t>(m_totalVolume.GetNumerator());
00872     else
00873     {
00874         double dSize;
00875         ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, m_totalVolume.GetDouble(dSize));
00876         volume = static_cast<uint32_t>(dSize);
00877     }
00878     return STATUS_CODE_SUCCESS;
00879 }
00880
00881 // ---------------------------------------------------------------------------------------------------------------------------------
00882
00883 inline StatusCode IntradayBar::SetTotalVolume(const uint32_t volume)
00884 {
00885     return m_totalVolume.Set(volume, Rational::DENOMINATOR_WHOLE);
00886 }
00887
00888 // ---------------------------------------------------------------------------------------------------------------------------------
00889
00890 inline StatusCode IntradayBar::GetTotalVolume(Rational &volume) const
00891 {
00892     volume = m_totalVolume;
00893     return STATUS_CODE_SUCCESS;
00894 }
00895
00896 // ---------------------------------------------------------------------------------------------------------------------------------
00897
00898 inline StatusCode IntradayBar::SetTotalVolume(const Rational &volume)
00899 {
00900     m_totalVolume = volume;
00901     return STATUS_CODE_SUCCESS;
00902 }
00903
00904 // ---------------------------------------------------------------------------------------------------------------------------------
00905
00906 inline StatusCode IntradayBar::GetTotalPrice(Rational &totalPrice) const
00907 {
00908     totalPrice = m_totalPrice;
00909     return STATUS_CODE_SUCCESS;
00910 }
00911
00912 // ---------------------------------------------------------------------------------------------------------------------------------
00913
00914 inline StatusCode IntradayBar::GetTotalPrice(double &totalPrice) const
00915 {
00916     return m_totalPrice.GetDouble(totalPrice);
00917 }
00918
00919 // ---------------------------------------------------------------------------------------------------------------------------------
00920
00921 inline StatusCode IntradayBar::SetTotalPrice(Rational &totalPrice)
00922 {
00923     m_totalPrice = totalPrice;
00924     return STATUS_CODE_SUCCESS;
00925 }
00926
00927 // ---------------------------------------------------------------------------------------------------------------------------------
00928
00929 inline StatusCode IntradayBar::GetTotalValue(Rational &totalValue) const
00930 {
00931     totalValue = m_totalValue;
00932     return STATUS_CODE_SUCCESS;
00933 }
00934
00935 // ---------------------------------------------------------------------------------------------------------------------------------
00936
00937 inline StatusCode IntradayBar::GetTotalValue(double &totalValue) const
00938 {
00939     return m_totalValue.GetDouble(totalValue);
00940 }
00941
00942 // ---------------------------------------------------------------------------------------------------------------------------------
00943
00944 inline StatusCode IntradayBar::SetTotalValue(Rational &totalValue)
00945 {
00946     m_totalValue = totalValue;
00947     return STATUS_CODE_SUCCESS;
00948 }
00949
00950 // ---------------------------------------------------------------------------------------------------------------------------------
00951
00952 inline StatusCode IntradayBar::GetTickCount(uint32_t &count) const
00953 {
00954     count = m_tickCount;
00955     return STATUS_CODE_SUCCESS;
00956 }
00957
00958 // ---------------------------------------------------------------------------------------------------------------------------------
00959
00960 inline StatusCode IntradayBar::SetTickCount(const uint32_t count)
00961 {
00962     m_tickCount = count;
00963     return STATUS_CODE_SUCCESS;
00964 }
00965
00966 // ---------------------------------------------------------------------------------------------------------------------------------
00967
00968 inline StatusCode IntradayBar::SetFlag(const byte_t flag)
00969 {
00970     m_flag = flag;
00971     return STATUS_CODE_SUCCESS;
00972 }
00973
00974 // ---------------------------------------------------------------------------------------------------------------------------------
00975
00976 inline StatusCode IntradayBar::GetFlag(byte_t &flag) const
00977 {
00978     flag = m_flag;
00979     return STATUS_CODE_SUCCESS;
00980 }
00981
00982 // ---------------------------------------------------------------------------------------------------------------------------------
00983
00984 inline bool IntradayBar::IsRegularHour() const
00985 {
00986     return 0 == (m_flag & NONE_REGULAR_HOUR_TRADE_BIT);
00987 }
00988
00989 // ---------------------------------------------------------------------------------------------------------------------------------
00990
00991 inline bool IntradayBar::IsVWAPOnly() const
00992 {
00993     return 0 != (m_flag & VWAP_ONLY_BIT);
00994 }
00995
00996 // ---------------------------------------------------------------------------------------------------------------------------------
00997
00998 inline void IntradayBar::SetToMiniBar()
00999 {
01000     m_totalPrice = 0;
01001     m_totalValue = 0;
01002 }
01003
01004 // ---------------------------------------------------------------------------------------------------------------------------------
01005
01006 inline bool IntradayBar::HasTick() const
01007 {
01008     return m_dateTime.GetYear() > 0;
01009 }
01010
01011 #undef ACTIV_DECLARE_BYTES
01012
01013 } // namespace ContentGatewayApi
01014
01015 } // namespace ContentPlatform
01016
01017 } // namespace Activ
01018
01019 #endif // (!defined ACTIV_CONTENT_GATEWAY_API_COMMON_INTRADAY_BAR_H)
Generated on Wed Oct 8 14:01:45 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » Misc

IntrusivePtrHelper.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_MISC_INTRUSIVE_PTR_HELPER_H)
00010 #define ACTIV_MISC_INTRUSIVE_PTR_HELPER_H
00011
00012 #include "ActivMiddleware/Activ.h"
00013
00014 #include "boost/intrusive_ptr.hpp"
00015
00019 #define ACTIV_INTRUSIVE_PTR_HELPER_REFERENCE_COUNTER_NAME   ____m_referenceCounter__activ____
00020
00021 // ---------------------------------------------------------------------------------------------------------------------------------
00022
00028 template<typename T>
00029 inline void intrusive_ptr_add_ref(const T * const pObject)
00030 {
00031     ++pObject->ACTIV_INTRUSIVE_PTR_HELPER_REFERENCE_COUNTER_NAME;
00032 }
00033
00034 // ---------------------------------------------------------------------------------------------------------------------------------
00035
00041 template<typename T>
00042 inline void intrusive_ptr_release(const T * const pObject)
00043 {
00044     if (0 == --pObject->ACTIV_INTRUSIVE_PTR_HELPER_REFERENCE_COUNTER_NAME)
00045         delete pObject;
00046 }
00047
00048 // ---------------------------------------------------------------------------------------------------------------------------------
00049
00050 namespace Activ
00051 {
00052
00056 class ReferenceCounter
00057 {
00058 public:
00062     ReferenceCounter();
00063
00069     uint32_t operator++();
00070
00076     uint32_t operator--();
00077
00083     uint32_t Get() const;
00084
00085 private:
00086     uint32_t    m_referenceCount;
00087 };
00088
00089 // ---------------------------------------------------------------------------------------------------------------------------------
00090
00091 inline ReferenceCounter::ReferenceCounter() :
00092     m_referenceCount(0)
00093 {
00094 }
00095
00096 // ---------------------------------------------------------------------------------------------------------------------------------
00097
00098 inline uint32_t ReferenceCounter::operator++()
00099 {
00100     return ++m_referenceCount;
00101 }
00102
00103 // ---------------------------------------------------------------------------------------------------------------------------------
00104
00105 inline uint32_t ReferenceCounter::operator--()
00106 {
00107     return --m_referenceCount;
00108 }
00109
00110 // ---------------------------------------------------------------------------------------------------------------------------------
00111
00112 inline uint32_t ReferenceCounter::Get() const
00113 {
00114     return m_referenceCount;
00115 }
00116
00117 // ---------------------------------------------------------------------------------------------------------------------------------
00118
00124 #define ACTIV_INTRUSIVE_PTR_HELPER_ADD_REFERENCE_COUNTER                                \
00125     mutable Activ::ReferenceCounter ACTIV_INTRUSIVE_PTR_HELPER_REFERENCE_COUNTER_NAME;  \
00126     Activ::uint32_t GetReferenceCount() const                                           \
00127     {                                                                                   \
00128         return ACTIV_INTRUSIVE_PTR_HELPER_REFERENCE_COUNTER_NAME.Get();                 \
00129     }
00130
00131 // ---------------------------------------------------------------------------------------------------------------------------------
00132
00138 #define ACTIV_DECLARE_INTRUSIVE_PTR_TYPEDEF(T)  typedef boost::intrusive_ptr<T>
00139
00140 } // namespace Activ
00141
00142 #endif // (!defined ACTIV_MISC_INTRUSIVE_PTR_HELPER_H)
Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase » Windows

IoCompletionManager.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_BASE_WINDOWS_IO_COMPLETION_MANAGER_H)
00010 #define ACTIV_BASE_WINDOWS_IO_COMPLETION_MANAGER_H
00011
00012 #include "ActivMiddleware/ActivBase/External.h"
00013 #include "ActivMiddleware/ActivBase/Thread.h"
00014
00015 #include "boost/shared_ptr.hpp"
00016
00017 #include <vector>
00018
00019 namespace Activ
00020 {
00021
00022 class IMutex;
00023
00024 // ---------------------------------------------------------------------------------------------------------------------------------
00025
00029 class IoCompletionManager : private boost::noncopyable
00030 {
00031 public:
00037     class Overlapped : public OVERLAPPED
00038     {
00039     public:
00046         Overlapped(IoCompletionManager &ioCompletionManager, IMutex * const pMutex);
00047
00057         bool PostIoCompletion(DWORD numberOfBytes);
00058
00064         bool IsPending() const;
00065
00073         void SetPending(const bool isPending);
00074
00082         bool WasSuccessfulCompletion() const;
00083
00091         DWORD GetNumberOfBytes() const;
00092
00093     protected:
00100         virtual void OnIoCompletion() = 0;
00101
00102     private:
00103         IoCompletionManager &   m_ioCompletionManager;
00104         IMutex * const          m_pMutex;
00105
00106         bool                    m_isPending;
00107         bool                    m_wasSuccessfulCompletion;
00108         DWORD                   m_numberOfBytes;
00109
00110         friend class IoCompletionManager;
00111     };
00112
00120     ACTIV_BASE_EXPORTED_API IoCompletionManager(const size_t numberOfIoThreads = 0);
00121
00125     ACTIV_BASE_EXPORTED_API ~IoCompletionManager();
00126
00134     ACTIV_BASE_EXPORTED_API void AttachHandle(const HANDLE handle) const;
00135
00136 private:
00140     class IoThread : public Thread
00141     {
00142     public:
00148         IoThread(IoCompletionManager &ioCompletionManager);
00149
00150     protected:
00151         virtual StatusCode Process(void *pData);
00152
00153     private:
00154         IoCompletionManager &   m_ioCompletionManager;
00155     };
00156
00160     void IoThreadFunction();
00161
00162     typedef boost::shared_ptr<IoThread> IoThreadPtr;
00163     typedef std::vector<IoThreadPtr> IoThreadList;
00164
00165     DWORD           m_concurrency;
00166     IoThreadList    m_ioThreadList;
00167     HANDLE          m_completionPort;
00168 };
00169
00170 // ---------------------------------------------------------------------------------------------------------------------------------
00171 // ---------------------------------------------------------------------------------------------------------------------------------
00172
00173 inline IoCompletionManager::Overlapped::Overlapped(IoCompletionManager &ioCompletionManager, IMutex * const pMutex) :
00174     m_ioCompletionManager(ioCompletionManager),
00175     m_pMutex(pMutex),
00176     m_isPending(false)
00177 {
00178     OVERLAPPED *pOverlapped = static_cast<OVERLAPPED *>(this);
00179
00180     ::memset(pOverlapped, 0, sizeof(OVERLAPPED));
00181 }
00182
00183 // ---------------------------------------------------------------------------------------------------------------------------------
00184
00185 inline bool IoCompletionManager::Overlapped::PostIoCompletion(DWORD numberOfBytes)
00186 {
00187     return (FALSE != ::PostQueuedCompletionStatus(m_ioCompletionManager.m_completionPort, numberOfBytes, 0, this));
00188 }
00189
00190 // ---------------------------------------------------------------------------------------------------------------------------------
00191
00192 inline bool IoCompletionManager::Overlapped::IsPending() const
00193 {
00194     return m_isPending;
00195 }
00196
00197 // ---------------------------------------------------------------------------------------------------------------------------------
00198
00199 inline void IoCompletionManager::Overlapped::SetPending(const bool isPending)
00200 {
00201     m_isPending = isPending;
00202 }
00203
00204 // ---------------------------------------------------------------------------------------------------------------------------------
00205
00206 inline bool IoCompletionManager::Overlapped::WasSuccessfulCompletion() const
00207 {
00208     return m_wasSuccessfulCompletion;
00209 }
00210
00211 // ---------------------------------------------------------------------------------------------------------------------------------
00212
00213 inline DWORD IoCompletionManager::Overlapped::GetNumberOfBytes() const
00214 {
00215     return m_numberOfBytes;
00216 }
00217
00218 } // namespace Activ
00219
00220 #endif // (!defined ACTIV_BASE_WINDOWS_IO_COMPLETION_MANAGER_H)
Generated on Wed Oct 8 14:01:47 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivIp

IpAddress.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_IP_IP_ADDRESS_H)
00010 #define ACTIV_IP_IP_ADDRESS_H
00011
00012 #include "ActivMiddleware/ActivIp/External.h"
00013 #include "ActivMiddleware/ActivBase/MessageValidator.h"
00014 #include "ActivMiddleware/ActivBase/MessageBuilder.h"
00015
00016 #include <string>
00017 #include <vector>
00018
00019 #if (defined ACTIV_PLATFORM_POSIX)
00020 #include <sys/socket.h>
00021 #endif
00022
00023 namespace Activ
00024 {
00025
00031 class IpAddress
00032 {
00033 public:
00041     IpAddress(const int family = AF_UNSPEC);
00042
00050     IpAddress(const int socketType, const int protocol, const int family = AF_UNSPEC);
00051
00061     int Compare(const IpAddress &rhs) const;
00062
00071     bool operator==(const IpAddress &rhs) const;
00072
00081     bool operator!=(const IpAddress &rhs) const;
00082
00091     bool operator<(const IpAddress &rhs) const;
00092
00100     ACTIV_IP_API std::string ToString(const bool shouldShowPort = true) const;
00101
00109     ACTIV_IP_API uint16_t GetPort() const;
00110
00116     ACTIV_IP_API uint32_t GetInterfaceIndex() const;
00117
00125     ACTIV_IP_API bool IsLoopback() const;
00126
00134     ACTIV_IP_API bool IsUnspecified() const;
00135
00143     ACTIV_IP_API bool IsMulticast() const;
00144
00153     ACTIV_IP_API StatusCode Serialize(MessageBuilder &messageBuilder) const;
00154
00163     ACTIV_IP_API StatusCode Deserialize(MessageValidator &messageValidator);
00164
00165     socklen_t           m_addressLength;
00166     union
00167     {
00168         sockaddr        Address;
00169         sockaddr_in     AddressIn;
00170         sockaddr_in6    AddressIn6;
00171     }                   m_address;
00172     uint32_t            m_type;
00173     uint32_t            m_protocol;
00174 };
00175
00176 // ---------------------------------------------------------------------------------------------------------------------------------
00177
00181 typedef std::vector<IpAddress> IpAddressList;
00182
00183 // ---------------------------------------------------------------------------------------------------------------------------------
00184
00185 inline IpAddress::IpAddress(const int family) :
00186     m_addressLength(0),
00187     m_type(0),
00188     m_protocol(0)
00189 {
00190     std::memset(&m_address, 0, sizeof(m_address));
00191     m_address.Address.sa_family = family;
00192 }
00193
00194 // ---------------------------------------------------------------------------------------------------------------------------------
00195
00196 inline IpAddress::IpAddress(const int socketType, const int protocol, const int family) :
00197     m_addressLength(0),
00198     m_type(socketType),
00199     m_protocol(protocol)
00200 {
00201     std::memset(&m_address, 0, sizeof(m_address));
00202     m_address.Address.sa_family = family;
00203 }
00204
00205 // ---------------------------------------------------------------------------------------------------------------------------------
00206
00207 inline int IpAddress::Compare(const IpAddress &rhs) const
00208 {
00209     if (m_addressLength != rhs.m_addressLength)
00210     {
00211         const socklen_t compareLength = std::min<>(m_addressLength, rhs.m_addressLength);
00212         const int compareValue = std::memcmp(&m_address, &rhs.m_address, compareLength);
00213
00214         if (0 == compareValue)
00215             return (m_addressLength == compareLength) ? -1 : 1;
00216         else
00217             return compareValue;
00218     }
00219     else
00220     {
00221         return std::memcmp(&m_address, &rhs.m_address, m_addressLength);
00222     }
00223 }
00224
00225 // ---------------------------------------------------------------------------------------------------------------------------------
00226
00227 inline bool IpAddress::operator==(const IpAddress &rhs) const
00228 {
00229     return 0 == Compare(rhs);
00230 }
00231
00232 // ---------------------------------------------------------------------------------------------------------------------------------
00233
00234 inline bool IpAddress::operator!=(const IpAddress &rhs) const
00235 {
00236     return 0 != Compare(rhs);
00237 }
00238
00239 // ---------------------------------------------------------------------------------------------------------------------------------
00240
00241 inline bool IpAddress::operator<(const IpAddress &rhs) const
00242 {
00243     return Compare(rhs) < 0;
00244 }
00245
00246 } // namespace Activ
00247
00248 #endif // (!defined ACTIV_IP_IP_ADDRESS_H)
Generated on Wed Oct 8 14:01:48 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivIp

IpException.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_IP_IP_EXCEPTION_H)
00010 #define ACTIV_IP_IP_EXCEPTION_H
00011
00012 #include "ActivMiddleware/ActivIp/External.h"
00013 #include "ActivMiddleware/ActivBase/Exception.h"
00014
00015 namespace Activ
00016 {
00017
00024 #define ACTIV_IP_EXCEPTION_LIST(d)                                                      \
00025     d(ERROR_UNACCEPTABLE_WINSOCK_VERSION, "unacceptable winsock version")               \
00026     d(ERROR_INVALID_FUNCTION_POINTER_LENGTH, "invalid function pointer length")         \
00027     d(ERROR_MULTIPLE_CLOSES_PERFORMED, "multiple closes performed on socket")           \
00028     d(ERROR_ALREADY_LISTENING, "already listening")                                     \
00029     d(ERROR_NOT_LISTENING, "not listening")                                             \
00030     d(ERROR_RX_BUFFER_SIZE_NOT_SET, "rx buffer size not set correctly")                 \
00031     d(ERROR_TX_BUFFER_SIZE_NOT_SET, "tx buffer size not set correctly")                 \
00032     d(ERROR_MANAGED_OBJECTS_STILL_EXIST, "managed objects still exist")                 \
00033     d(ERROR_ADDRESS_FAMILIES_DO_NOT_MATCH, "address families do not match")             \
00034     d(ERROR_INVALID_ADDRESS_FAMILY, "invalid address family")                           \
00035     d(ERROR_INTERFACE_INDEX_MISMATCH, "interface index mismatch")                       \
00036     d(ERROR_FAILED_TO_POST_READ, "failed to post read")
00037
00038 // ---------------------------------------------------------------------------------------------------------------------------------
00039
00043 class IpException : public Exception
00044 {
00045 public:
00049     enum
00050     {
00051         ACTIV_IP_EXCEPTION_LIST(ACTIV_DECLARE_ELEMENT_1_WITH_COMMA)
00052         NUM_ERRORS
00053     };
00054
00063     ACTIV_IP_API IpException(const char *file, const char *function, const uint_fast32_t line, const uint_fast32_t errorCode);
00064
00065     ACTIV_IP_API virtual std::string ToString() const;
00066 };
00067
00068 } // namespace Activ
00069
00070 #endif // (!defined ACTIV_IP_IP_EXCEPTION_H)
Generated on Wed Oct 8 14:01:48 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivIp

IpManager.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_IP_IP_MANAGER_H)
00010 #define ACTIV_IP_IP_MANAGER_H
00011
00012 #include "External.h"
00013
00014 #if (defined ACTIV_PLATFORM_WINDOWS)
00015 #include "Windows/IpManager.h"
00016 #elif (defined ACTIV_PLATFORM_POSIX)
00017 #include "Posix/IpManager.h"
00018 #else
00019 #error No IpManager.h for this platform yet.
00020 #endif
00021
00022 namespace Activ
00023 {
00024
00025 inline const IpManager::Settings &IpManager::GetSettings() const
00026 {
00027     return m_settings;
00028 }
00029
00030 } // namespace Activ
00031
00032 #endif // (!defined ACTIV_IP_IP_MANAGER_H)
Generated on Wed Oct 8 14:01:48 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivIp

IpSocket.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_IP_IP_SOCKET_H)
00010 #define ACTIV_IP_IP_SOCKET_H
00011
00012 #include "External.h"
00013
00014 #if (defined ACTIV_PLATFORM_WINDOWS)
00015 #include "Windows/IpSocket.h"
00016 #elif (defined ACTIV_PLATFORM_POSIX)
00017 #include "Posix/IpSocket.h"
00018 #else
00019 #error No IpSocket.h for this platform yet.
00020 #endif
00021
00022 namespace Activ
00023 {
00024
00025 template<typename SOCKET_TYPE>
00026 typename SOCKET_TYPE::Stats IpSocket::Stats::Get(const SOCKET_TYPE &socket)
00027 {
00028     typedef typename SOCKET_TYPE::Stats StatsType;
00029     const IpSocket &ipSocket = socket;
00030     ScopedMutexLocker scopedMutexLocker(ipSocket.m_pMutex);
00031
00032 #if (defined ACTIV_COMPILER_VISUAL_C)
00033     return StatsType::Stats(socket);
00034 #else
00035     return typename SOCKET_TYPE::Stats(socket);
00036 #endif
00037 }
00038
00039 // ---------------------------------------------------------------------------------------------------------------------------------
00040 // ---------------------------------------------------------------------------------------------------------------------------------
00041
00042 inline void IpSocket::AppendRxBuffer(void *pData, const size_t dataLength)
00043 {
00044     return m_rxBuffers.Append(pData, dataLength);
00045 }
00046
00047 // ---------------------------------------------------------------------------------------------------------------------------------
00048
00049 inline void IpSocket::AppendTxBuffer(const void *pData, const size_t dataLength)
00050 {
00051     return m_txBuffers.Append(const_cast<void *>(pData), dataLength);
00052 }
00053
00054 } // namespace Activ
00055
00056 #endif // (!defined ACTIV_IP_IP_SOCKET_H)
Generated on Wed Oct 8 14:01:48 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivDatabase

Key.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_DATABASE_KEY_H)
00010 #define ACTIV_DATABASE_KEY_H
00011
00012 #include "ActivMiddleware/ActivDatabase/External.h"
00013 #include "ActivMiddleware/ActivDatabase/Definitions.h"
00014 #include "ActivMiddleware/ActivDatabase/ITable.h"
00015 #include "ActivMiddleware/ActivDatabase/IIndex.h"
00016 #include "ActivMiddleware/ActivDatabase/FieldListObject.h"
00017
00018 #include <string>
00019 #include <memory>
00020
00021 namespace Activ
00022 {
00023
00024 class ScatterBufferHelper;
00025 class IFieldType;
00026
00027 namespace Database
00028 {
00029
00030 class Record;
00031
00032 // ---------------------------------------------------------------------------------------------------------------------------------
00033
00037 class Key : public FieldListObject
00038 {
00039 public:
00043     Key();
00044
00053     ACTIV_DATABASE_API Key(ITable *pTable, const IndexSpecification::Number indexNo);
00054
00063     ACTIV_DATABASE_API Key(const IndexSpecification::Number indexNo, const Record &record);
00064
00072     ACTIV_DATABASE_API Key(const Key &rhs);
00073
00077     ~Key();
00078
00088     ACTIV_DATABASE_API Key &operator=(const Key &rhs);
00089
00097     bool operator==(const Key &rhs) const;
00098
00106     bool operator!=(const Key &rhs) const;
00107
00115     bool operator<(const Key &rhs) const;
00116
00124     bool operator<=(const Key &rhs) const;
00125
00133     bool operator>(const Key &rhs) const;
00134
00142     bool operator>=(const Key &rhs) const;
00143
00147     void Initialize();
00148
00159     ACTIV_DATABASE_API StatusCode Initialize(ITable *pTable, const IndexSpecification::Number indexNo);
00160
00170     ACTIV_DATABASE_API StatusCode Initialize(const Key &rhs);
00171
00185     ACTIV_DATABASE_API StatusCode Initialize(const IndexSpecification::Number indexNo, const Record &record);
00186
00197     ACTIV_DATABASE_API virtual StatusCode Serialize(MessageBuilder &messageBuilder) const;
00198
00210     ACTIV_DATABASE_API virtual StatusCode Deserialize(ITable *pTable, MessageValidator &messageValidator);
00211
00218     ACTIV_DATABASE_API virtual StatusCode Reset();
00219
00230     ACTIV_DATABASE_API StatusCode BuildKey(const Record &record);
00231
00243     StatusCode SetIndexFields(const ScatterBufferHelper &scatterBufferHelper);
00244
00260     ACTIV_DATABASE_API virtual StatusCode CopyFields(const Key &sourceKey, const bool copyAllFields = false);
00261
00277     ACTIV_DATABASE_API virtual StatusCode CopyFields(const Record &sourceRecord, const bool copyAllFields = false);
00278
00287     StatusCode GetIndexPointer(IIndex *&pIndex) const;
00288
00297     StatusCode GetIndexSpecification(IndexSpecification &indexSpecification) const;
00298
00307     StatusCode Set(const void *pRhsData);
00308
00314     size_t GetDataLength() const;
00315
00324     StatusCode GetIndexNumber(IndexSpecification::Number &indexNo) const;
00325
00334     StatusCode Validate(const ITable *pTable) const;
00335
00345     StatusCode Validate(const ITable *pTable, const size_t nIndexes) const;
00346
00347 private:
00348     static const uint8_t VERSION = 1;
00349
00350     IIndex                      *m_pIndex;
00351     IndexSpecification::Number  m_indexNo;
00352 };
00353
00354 // ---------------------------------------------------------------------------------------------------------------------------------
00355
00356 inline Key::Key() :
00357     m_pIndex(0),
00358     m_indexNo(0)
00359 {
00360 }
00361
00362 // ---------------------------------------------------------------------------------------------------------------------------------
00363
00364 inline Key::~Key()
00365 {
00366 }
00367
00368 // ---------------------------------------------------------------------------------------------------------------------------------
00369
00370 inline bool Key::operator==(const Key &rhs) const
00371 {
00372     bool lhsIsInitialized = IsInitialized(), rhsIsInitialized = rhs.IsInitialized();
00373
00374     if (lhsIsInitialized != rhsIsInitialized)
00375         return false;
00376
00377     if (!lhsIsInitialized && !rhsIsInitialized)
00378         return true;
00379
00380     if ((m_pTable->GetIdentity() != rhs.m_pTable->GetIdentity()) || (m_pIndex != rhs.m_pIndex))
00381         return false;
00382
00383     return (0 == m_pIndex->Compare(*this, rhs));
00384 }
00385
00386 // ---------------------------------------------------------------------------------------------------------------------------------
00387
00388 inline bool Key::operator!=(const Key &rhs) const
00389 {
00390     return !((*this) == rhs);
00391 }
00392
00393 // ---------------------------------------------------------------------------------------------------------------------------------
00394
00395 inline bool Key::operator<(const Key &rhs) const
00396 {
00397     bool lhsIsInitialized = IsInitialized(), rhsIsInitialized = rhs.IsInitialized();
00398
00399     if (lhsIsInitialized != rhsIsInitialized)
00400         return !lhsIsInitialized;
00401
00402     if (!lhsIsInitialized && !rhsIsInitialized)
00403         return false;
00404
00405     if (m_pTable->GetIdentity() != rhs.m_pTable->GetIdentity())
00406         return (m_pTable->GetName() < rhs.m_pTable->GetName());
00407
00408     if (m_pIndex != rhs.m_pIndex)
00409         return (m_pIndex->GetName() < rhs.m_pIndex->GetName());
00410
00411     return (m_pIndex->Compare(*this, rhs) < 0);
00412 }
00413
00414 // ---------------------------------------------------------------------------------------------------------------------------------
00415
00416 inline bool Key::operator<=(const Key &rhs) const
00417 {
00418     bool lhsIsInitialized = IsInitialized(), rhsIsInitialized = rhs.IsInitialized();
00419
00420     if (lhsIsInitialized != rhsIsInitialized)
00421         return !lhsIsInitialized;
00422
00423     if (!lhsIsInitialized && !rhsIsInitialized)
00424         return true;
00425
00426     if (m_pTable->GetIdentity() != rhs.m_pTable->GetIdentity())
00427         return (m_pTable->GetName() < rhs.m_pTable->GetName());
00428
00429     if (m_pIndex != rhs.m_pIndex)
00430         return (m_pIndex->GetName() < rhs.m_pIndex->GetName());
00431
00432     return (m_pIndex->Compare(*this, rhs) <= 0);
00433 }
00434
00435 // ---------------------------------------------------------------------------------------------------------------------------------
00436
00437 inline bool Key::operator>(const Key &rhs) const
00438 {
00439     return !(*this <= rhs);
00440 }
00441
00442 // ---------------------------------------------------------------------------------------------------------------------------------
00443
00444 inline bool Key::operator>=(const Key &rhs) const
00445 {
00446     bool lhsIsInitialized = IsInitialized(), rhsIsInitialized = rhs.IsInitialized();
00447
00448     if (lhsIsInitialized != rhsIsInitialized)
00449         return lhsIsInitialized;
00450
00451     if (!lhsIsInitialized && !rhsIsInitialized)
00452         return true;
00453
00454     if (m_pTable->GetIdentity() != rhs.m_pTable->GetIdentity())
00455         return (m_pTable->GetName() > rhs.m_pTable->GetName());
00456
00457     if (m_pIndex != rhs.m_pIndex)
00458         return (m_pIndex->GetName() > rhs.m_pIndex->GetName());
00459
00460     return (m_pIndex->Compare(*this, rhs) >= 0);
00461 }
00462
00463 // ---------------------------------------------------------------------------------------------------------------------------------
00464
00465 inline void Key::Initialize()
00466 {
00467     FieldListObject::Initialize();
00468     m_pIndex = 0;
00469     m_indexNo = 0;
00470 }
00471
00472 // ---------------------------------------------------------------------------------------------------------------------------------
00473
00474 inline StatusCode Key::Reset()
00475 {
00476     if (!IsInitialized())
00477         return STATUS_CODE_NOT_INITIALIZED;
00478
00479     m_pIndex->ResetKey(*this);
00480     m_id = UNDEFINED_ID;
00481
00482     return STATUS_CODE_SUCCESS;
00483 }
00484
00485 // ---------------------------------------------------------------------------------------------------------------------------------
00486
00487 inline StatusCode Key::SetIndexFields(const ScatterBufferHelper &scatterBufferHelper)
00488 {
00489     return (IsInitialized()) ? m_pIndex->SetFields(*this, scatterBufferHelper) : STATUS_CODE_NOT_INITIALIZED;
00490 }
00491
00492 // ---------------------------------------------------------------------------------------------------------------------------------
00493
00494 inline StatusCode Key::GetIndexPointer(IIndex *&pIndex) const
00495 {
00496     if (!IsInitialized())
00497         return STATUS_CODE_NOT_INITIALIZED;
00498
00499     pIndex = m_pIndex;
00500     return STATUS_CODE_SUCCESS;
00501 }
00502
00503 // ---------------------------------------------------------------------------------------------------------------------------------
00504
00505 inline StatusCode Key::GetIndexSpecification(IndexSpecification &indexSpecification) const
00506 {
00507     if (!IsInitialized())
00508         return STATUS_CODE_NOT_INITIALIZED;
00509
00510     indexSpecification = m_pIndex->GetSpecification();
00511     return STATUS_CODE_SUCCESS;
00512 }
00513
00514 // ---------------------------------------------------------------------------------------------------------------------------------
00515
00516 inline StatusCode Key::Set(const void *pRhsData)
00517 {
00518     if (!IsInitialized())
00519         return STATUS_CODE_NOT_INITIALIZED;
00520
00521     if (0 == pRhsData)
00522         return STATUS_CODE_INVALID_PARAMETER;
00523
00524     MemoryCopy(m_pData, pRhsData, GetDataLength());
00525     return STATUS_CODE_SUCCESS;
00526 }
00527
00528 // ---------------------------------------------------------------------------------------------------------------------------------
00529
00530 inline size_t Key::GetDataLength() const
00531 {
00532     return (IsInitialized() ? m_pIndex->GetKeyLength() : 0);
00533 }
00534
00535 // ---------------------------------------------------------------------------------------------------------------------------------
00536
00537 inline StatusCode Key::GetIndexNumber(IndexSpecification::Number &indexNo) const
00538 {
00539     if (IsInitialized())
00540     {
00541         indexNo = m_indexNo;
00542         return STATUS_CODE_SUCCESS;
00543     }
00544     else
00545         return STATUS_CODE_NOT_INITIALIZED;
00546 }
00547
00548 // ---------------------------------------------------------------------------------------------------------------------------------
00549
00550 inline StatusCode Key::Validate(const ITable *pTable) const
00551 {
00552     return ((IsInitialized() && (pTable->GetIdentity() == m_tableIdentity) && (m_indexNo < pTable->GetNumberOfIndexes())) ? STATUS_CODE_SUCCESS : STATUS_CODE_INVALID_KEY);
00553 }
00554
00555 // ---------------------------------------------------------------------------------------------------------------------------------
00556
00557 inline StatusCode Key::Validate(const ITable *pTable, const size_t nIndexes) const
00558 {
00559     return ((IsInitialized() && (pTable->GetIdentity() == m_tableIdentity) && (m_indexNo < nIndexes)) ? STATUS_CODE_SUCCESS : STATUS_CODE_INVALID_KEY);
00560 }
00561
00562 // ---------------------------------------------------------------------------------------------------------------------------------
00563
00564 }   // namespace Database
00565
00566 }   // namespace Activ
00567
00568 #endif // (!defined ACTIV_DATABASE_KEY_H)
Generated on Wed Oct 8 14:01:47 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivFramework

LicenseServiceApi.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FRAMEWORK_LICENSE_SERVICE_API_H)
00010 #define ACTIV_FRAMEWORK_LICENSE_SERVICE_API_H
00011
00012 #include "ActivMiddleware/ActivFramework/External.h"
00013
00014 namespace Activ
00015 {
00016
00017 class Component;
00018
00019 // ---------------------------------------------------------------------------------------------------------------------------------
00020
00024 class LicenseServiceApi
00025 {
00026 public:
00036     ACTIV_FRAMEWORK_API static StatusCode GetIniFileParser(const Component &component, IniFileParser &iniFileParser);
00037
00047     ACTIV_FRAMEWORK_API static StatusCode GetSectionName(const Component &component, std::string &sectionName);
00048 };
00049
00050 } // namespace Activ
00051
00052 #endif // (!defined ACTIV_FRAMEWORK_LICENSE_SERVICE_API_H)
Generated on Wed Oct 8 14:01:48 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » Config » Platforms

Linux.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_CONFIG_PLATFORMS_LINUX_H)
00010 #define ACTIV_CONFIG_PLATFORMS_LINUX_H
00011
00012 #define ACTIV_PLATFORM_NAME "Linux"
00013 #define ACTIV_PLATFORM_TYPE Activ::PLATFORM_TYPE_LINUX
00014
00015 #define ACTIV_POSIX_HAS_CONTEXT_API
00016 #define ACTIV_POSIX_HAS_PSHARED
00017
00018 #define ACTIV_HAS_INTTYPES_H
00019
00020 #include "Posix.h"
00021
00022 #endif // (!defined ACTIV_CONFIG_PLATFORMS_LINUX_H)
Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivFramework

LoggerDefinitions.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FRAMEWORK_LOGGER_DEFINITIONS_H)
00010 #define ACTIV_FRAMEWORK_LOGGER_DEFINITIONS_H
00011
00012 namespace Activ
00013 {
00014
00018 #define FILE_TYPE_LIST(d)                           \
00019     d(  FILE_TYPE_DAILY, "Daily")                   \
00020     d(  FILE_TYPE_WEEKLY, "Weekly")                 \
00021     d(  FILE_TYPE_MONTHLY, "Monthly")               \
00022     d(  FILE_TYPE_ROLLING, "Rolling")
00023
00024 // ---------------------------------------------------------------------------------------------------------------------------------
00025
00029 class LoggerDefinitions
00030 {
00031 public:
00032     static const PortId     servicePortId               = 0;
00033
00034     static const uint64_t   MAX_FILE_SIZE_UNDEFINED     = static_cast<uint64_t>(~0);
00035     static const size_t     NUMBER_OF_BACKUPS_UNDEFINED = static_cast<size_t>(~0);
00036
00040     enum FileType
00041     {
00042         FILE_TYPE_LIST(ACTIV_DECLARE_ELEMENT_1_WITH_COMMA)
00043         NUMBER_OF_FILE_TYPES
00044     };
00045
00053     ACTIV_FRAMEWORK_API static std::string TypeToString(const FileType logFileType);
00054 };
00055
00056 } // namespace Activ
00057
00058 #endif // (!defined ACTIV_FRAMEWORK_LOGGER_DEFINITIONS_H)
Generated on Wed Oct 8 14:01:48 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivFramework

LoggerServiceApi.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FRAMEWORK_LOGGER_SERVICE_API_H)
00010 #define ACTIV_FRAMEWORK_LOGGER_SERVICE_API_H
00011
00012 #include "ActivMiddleware/ActivFramework/External.h"
00013 #include "ActivMiddleware/ActivFramework/LoggerDefinitions.h"
00014
00015 namespace Activ
00016 {
00017
00018 class Component;
00019
00020 // ---------------------------------------------------------------------------------------------------------------------------------
00021
00025 class LoggerServiceApi
00026 {
00027 public:
00040     ACTIV_FRAMEWORK_API static StatusCode OpenLogFile(const Component &component, const std::string &fileName,
00041         const LoggerDefinitions::FileType fileType, const bool isUniqueFileName, Address::Proxy logAddress);
00042
00056     ACTIV_FRAMEWORK_API static StatusCode OpenLogFile(const Component &component, const std::string &fileName,
00057         const LoggerDefinitions::FileType fileType, const uint64_t maxFileSize, const size_t nBackups, Address::Proxy logAddress);
00058
00073     ACTIV_FRAMEWORK_API static StatusCode OpenLogFile(const Component &component, const std::string &fileName,
00074         const LoggerDefinitions::FileType fileType, const uint64_t maxFileSize, const size_t nBackups, const bool isUniqueFileName,
00075         Address::Proxy logAddress);
00076
00090     ACTIV_FRAMEWORK_API static StatusCode SetLogHeader(const Component &component, const Address &logAddress,
00091         const std::string &header);
00092
00102     ACTIV_FRAMEWORK_API static StatusCode CloseLogFile(const Component &component, Address &logAddress);
00103
00115     ACTIV_FRAMEWORK_API static StatusCode LogMessage(const Component &component, const Address &logAddress,
00116         const std::string &message);
00117
00129     ACTIV_FRAMEWORK_API static StatusCode LogMessage(const Component &component, const Address &logAddress,
00130         const boost::format &message);
00131
00144     ACTIV_FRAMEWORK_API static StatusCode LogMessage(const Component &component, const Address &logAddress,
00145         const void *pMessage, const size_t messageLength);
00146
00157     ACTIV_FRAMEWORK_API static StatusCode LogMessage(const Component &component, const Address &logAddress,
00158         HeapMessage &heapMessage);
00159 };
00160
00161 } // namespace Activ
00162
00163 #endif // (!defined ACTIV_FRAMEWORK_LOGGER_SERVICE_API_H)
Generated on Wed Oct 8 14:01:48 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivSystem

ManagedEndPoint.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_SYSTEM_MANAGED_END_POINT_H)
00010 #define ACTIV_SYSTEM_MANAGED_END_POINT_H
00011
00012 #include "ActivMiddleware/ActivSystem/External.h"
00013 #include "ActivMiddleware/ActivSystem/IEndPoint.h"
00014 #include "ActivMiddleware/ActivBase/IniFileParser.h"
00015 #include "ActivMiddleware/ActivBase/Thread.h"
00016
00017 #include "boost/scoped_ptr.hpp"
00018
00019 #include <string>
00020
00021 namespace Activ
00022 {
00023
00024 class ISystem;
00025 class ISyncEndPoint;
00026 class Address;
00027 class HeapMessage;
00028
00029 // ---------------------------------------------------------------------------------------------------------------------------------
00030
00037 class ManagedEndPoint : private boost::noncopyable
00038 {
00039 public:
00040     typedef std::set<PortId> PortIdSet;
00041
00051     class Settings
00052     {
00053     public:
00057         ACTIV_SYSTEM_EXPORTED_API
00058         Settings();
00059
00068         ACTIV_SYSTEM_EXPORTED_API
00069         StatusCode Read(const IniFileParser::ConstSectionIterator &sectionIterator);
00070
00071         size_t                      m_maxThreads;
00072         IEndPoint::NotificationType m_notificationType;
00073         PortId                      m_initialPortListSize;
00074         PortId                      m_minFreePortIdListSize;
00075         PortIdSet                   m_reservedPortIdSet;
00076
00077 #if (defined ACTIV_PLATFORM_WINDOWS)
00078         uint32_t                    m_threadPriority;
00079         Thread::ProcessorList       m_threadProcessorAffinityList;
00080 #endif
00081     };
00082
00111     class RunHelper
00112     {
00113     public:
00123         ACTIV_SYSTEM_EXPORTED_API
00124         RunHelper(ManagedEndPoint &managedEndPoint);
00125
00131         ACTIV_SYSTEM_EXPORTED_API
00132         ~RunHelper();
00133
00144         ACTIV_SYSTEM_EXPORTED_API
00145         StatusCode operator()(const size_t maxMessagesToProcess, const TimeoutPeriod timeout);
00146
00147     private:
00148         ManagedEndPoint &m_managedEndPoint;
00149     };
00150
00162     ACTIV_SYSTEM_EXPORTED_API
00163     ManagedEndPoint(ISystem * const pSystem, const std::string &name, const Settings &settings = Settings());
00164
00170     ACTIV_SYSTEM_EXPORTED_API
00171     virtual ~ManagedEndPoint();
00172
00182     ACTIV_SYSTEM_EXPORTED_API
00183     StatusCode Run();
00184
00196     ACTIV_SYSTEM_EXPORTED_API
00197     StatusCode StartThread();
00198
00202     ACTIV_SYSTEM_EXPORTED_API
00203     void PostDiesToThreads() const;
00204
00215     ACTIV_SYSTEM_EXPORTED_API
00216     StatusCode WaitForThreadsToExit(const TimeoutPeriod timeout = ACTIV_WAIT_INFINITE) const;
00217
00223     ACTIV_SYSTEM_EXPORTED_API
00224     ISyncEndPoint *GetEndPoint() const;
00225
00231     ACTIV_SYSTEM_EXPORTED_API
00232     size_t GetMaxThreads() const;
00233
00243     ACTIV_SYSTEM_EXPORTED_API
00244     StatusCode FindPort(const std::string &portName, Address &portAddress) const;
00245
00246     class Impl;
00247
00248 protected:
00255     ACTIV_SYSTEM_EXPORTED_API
00256     virtual void Process();
00257
00268     ACTIV_SYSTEM_EXPORTED_API
00269     virtual bool CanThreadExit();
00270
00271 private:
00280     ACTIV_SYSTEM_LOCAL_API
00281     StatusCode ProcessMessage(HeapMessage &heapMessage);
00282
00283     boost::scoped_ptr<Impl> m_pImpl;
00284
00285     friend class Port;
00286 };
00287
00288 } // namespace Activ
00289
00290 #endif // (!defined ACTIV_SYSTEM_MANAGED_END_POINT_H)
Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivDatabase

ManagedTableFactory.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_DATABASE_MANAGED_TABLE_FACTORY_H)
00010 #define ACTIV_DATABASE_MANAGED_TABLE_FACTORY_H
00011
00012 #include "ActivMiddleware/ActivDatabase/External.h"
00013 #include "ActivMiddleware/ActivDatabase/Definitions.h"
00014 #include "ActivMiddleware/Misc/Singleton.h"
00015
00016 #include <string>
00017 #include <vector>
00018
00019 namespace Activ
00020 {
00021
00022 namespace Database
00023 {
00024
00025 class ITable;
00026
00027 // ---------------------------------------------------------------------------------------------------------------------------------
00028
00032 class ManagedTableFactory : public Singleton<ManagedTableFactory>
00033 {
00034 public:
00051     ACTIV_DATABASE_API ITable *Create(const std::string &name, const TableSpecification::Properties properties, const FieldSpecification fieldSpecificationList[], const size_t nFields, const size_t initialMaxRecords, const size_t nGrowRecords = TableSpecification::GROW_RECORDS_DEFAULT, const size_t cacheSize = TableSpecification::CACHE_COMPLETE);
00052
00068     ACTIV_DATABASE_API ITable *Create(const std::string &name, const TableSpecification::Properties properties, const FieldSpecificationList &fieldSpecificationList, const size_t initialMaxRecords, const size_t nGrowRecords = TableSpecification::GROW_RECORDS_DEFAULT, const size_t cacheSize = TableSpecification::CACHE_COMPLETE);
00069
00087     ACTIV_DATABASE_API ITable *Create(const std::string &name, const std::string &directory, const TableSpecification::Properties properties, const FieldSpecification fieldSpecificationList[], const size_t nFields, const size_t initialMaxRecords, const size_t nGrowRecords = TableSpecification::GROW_RECORDS_DEFAULT, const size_t cacheSize = TableSpecification::CACHE_COMPLETE);
00088
00105     ACTIV_DATABASE_API ITable *Create(const std::string &name, const std::string &directory, const TableSpecification::Properties properties, const FieldSpecificationList &fieldSpecificationList, const size_t initialMaxRecords, const size_t nGrowRecords = TableSpecification::GROW_RECORDS_DEFAULT, const size_t cacheSize = TableSpecification::CACHE_COMPLETE);
00106
00112     ACTIV_DATABASE_API static ManagedTableFactory &GetInstance();
00113
00114 private:
00118     ACTIV_DATABASE_API ManagedTableFactory();
00119
00120     friend class Singleton<ManagedTableFactory>;
00121 };
00122
00123 } // namespace Database
00124
00125 } // namespace Activ
00126
00127 #endif // (!defined ACTIV_DATABASE_MANAGED_TABLE_FACTORY_H)
Generated on Wed Oct 8 14:01:47 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » Misc

MemoryHelper.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_MISC_MEMORY_HELPER_H)
00010 #define ACTIV_MISC_MEMORY_HELPER_H
00011
00012 #include "ActivMiddleware/Activ.h"
00013
00014 #include <memory.h>
00015
00016 namespace Activ
00017 {
00018
00026 template<typename T>
00027 inline T GetValueFromUnalignedPointer(const void *p)
00028 {
00029 #if (defined ACTIV_REQUIRE_ALIGNED_MEMORY_ACCESS)
00030
00031     T tmp;
00032
00033     // NB not using MemoryCopy() to allow special compiler optimizations
00034     ::memcpy(&tmp, p, sizeof(T));
00035
00036     return tmp;
00037
00038 #else
00039
00040     return *reinterpret_cast<const T *>(p);
00041
00042 #endif
00043 }
00044
00045 // ---------------------------------------------------------------------------------------------------------------------------------
00046
00053 template <typename T>
00054 inline void CopyValueToUnalignedPointer(void *p, const T &value)
00055 {
00056 #if (defined ACTIV_REQUIRE_ALIGNED_MEMORY_ACCESS)
00057
00058     // NB not using MemoryCopy() to allow special compiler optimizations
00059     ::memcpy(p, &value, sizeof(T));
00060
00061 #else
00062
00063     *reinterpret_cast<T *>(p) = value;
00064
00065 #endif
00066 }
00067
00068 // ---------------------------------------------------------------------------------------------------------------------------------
00069
00073 template<typename T, T input>
00074 class StaticAlignValueToProcessorWordBoundary
00075 {
00076 private:
00077     // Doesn't make sense to pass a signed type.
00078     BOOST_STATIC_ASSERT(boost::is_signed<T>::value == false);
00079
00080     typedef typename TypeToIntegralType<T>::Type IntegralType;
00081
00082     // T may be a pointer, so use integral arithmetic.
00083     static const IntegralType integralValue = static_cast<IntegralType>(input);
00084     static const IntegralType processorWordSizeBytes = (ACTIV_PROCESSOR_WORD_SIZE / CHAR_BIT);
00085
00086 public:
00087     static const T value = static_cast<T>((integralValue + (processorWordSizeBytes - 1)) & ~(processorWordSizeBytes - 1));
00088 };
00089
00090 // ---------------------------------------------------------------------------------------------------------------------------------
00091
00099 template<typename T>
00100 inline T AlignValueToProcessorWordBoundary(const T value)
00101 {
00102     // Doesn't make sense to pass a signed type.
00103     BOOST_STATIC_ASSERT(boost::is_signed<T>::value == false);
00104
00105     typedef typename TypeToIntegralType<T>::Type IntegralType;
00106
00107     // T may be a pointer, so use integral arithmetic.
00108     const IntegralType integralValue = static_cast<IntegralType>(value);
00109     const IntegralType adjustment = ((ACTIV_PROCESSOR_WORD_SIZE / CHAR_BIT) - 1);
00110
00111     return static_cast<T>((integralValue + adjustment) & ~adjustment);
00112 }
00113
00114 // ---------------------------------------------------------------------------------------------------------------------------------
00115
00124 template<typename T>
00125 inline T AlignValueToByteBoundary(const T value, const size_t numberOfBytes)
00126 {
00127     // Doesn't make sense to pass a signed type.
00128     BOOST_STATIC_ASSERT(boost::is_signed<T>::value == false);
00129
00130     typedef typename TypeToIntegralType<T>::Type IntegralType;
00131
00132     // T may be a pointer, so use integral arithmetic.
00133     const IntegralType integralValue = static_cast<IntegralType>(value);
00134
00135     if (0 == integralValue)
00136         return value;
00137
00138     return static_cast<T>((((integralValue - 1) /
00139         static_cast<IntegralType>(numberOfBytes)) + 1) * static_cast<IntegralType>(numberOfBytes));
00140 }
00141
00142 // ---------------------------------------------------------------------------------------------------------------------------------
00143
00150 inline void MemoryReverse(void *pBuffer, size_t bufferSize)
00151 {
00152     for (byte_t *ptr = static_cast<byte_t *>(pBuffer) + bufferSize - 1; static_cast<byte_t *>(pBuffer) < ptr;
00153         pBuffer = (static_cast<byte_t *>(pBuffer)) + sizeof(byte_t), --ptr)
00154     {
00155         *static_cast<byte_t *>(pBuffer) ^= *ptr;
00156         *ptr ^= *static_cast<byte_t *>(pBuffer);
00157         *static_cast<byte_t *>(pBuffer) ^= *ptr;
00158     }
00159 }
00160
00161 // ---------------------------------------------------------------------------------------------------------------------------------
00162
00170 inline void MemoryReverseCopy(void *pDestination, const void *pSource, size_t sourceSize)
00171 {
00172     for (size_t i = 0; i < sourceSize; ++i)
00173     {
00174         static_cast<byte_t *>(pDestination)[i] = static_cast<const byte_t *>(pSource)[sourceSize - i - 1];
00175     }
00176 }
00177
00178 // ---------------------------------------------------------------------------------------------------------------------------------
00179
00190 inline void MemoryCopy(void *pDestination, const void *pSource, size_t sourceSize)
00191 {
00192 // HACK magic numbers where bytewise copy becomes slower than memcpy
00193
00194 #if (defined ACTIV_PROCESSOR_X86)
00195
00196 #if (defined ACTIV_COMPILER_VISUAL_C)
00197 #define ACTIV_MEMORY_HELPER_MEMORY_COPY_LIMIT   10
00198 #elif (defined ACTIV_COMPILER_GCC) || (defined ACTIV_COMPILER_SUNPRO)
00199 #define ACTIV_MEMORY_HELPER_MEMORY_COPY_LIMIT   20
00200 #else
00201 #error Configure for this compiler on x86
00202 #endif // compilers for x86
00203
00204 #elif (defined ACTIV_PROCESSOR_X86_64)
00205
00206 // memcpy is as fast as bytewise with x86-64
00207
00208 #elif (defined ACTIV_PROCESSOR_SPARC) || (defined ACTIV_PROCESSOR_SPARC64)
00209
00210 // use memcpy for sparcs, too
00211
00212 #elif (defined ACTIV_PROCESSOR_IA64)
00213
00214 #if (defined ACTIV_COMPILER_VISUAL_C)
00215 #define ACTIV_MEMORY_HELPER_MEMORY_COPY_LIMIT   14
00216 #elif (defined ACTIV_COMPILER_GCC)
00217 #define ACTIV_MEMORY_HELPER_MEMORY_COPY_LIMIT   5
00218 #else
00219 #error Configure for this compiler on ia64
00220 #endif
00221
00222 #elif (defined ACTIV_PROCESSOR_PPC)
00223
00224 #if (defined ACTIV_COMPILER_GCC)
00225 #define ACTIV_MEMORY_HELPER_MEMORY_COPY_LIMIT   10
00226 #else
00227 #error Configure for this compiler on ppc
00228 #endif
00229
00230 #else
00231 #error Configure for this processor
00232 #endif // processors
00233
00234 #if (defined ACTIV_MEMORY_HELPER_MEMORY_COPY_LIMIT)
00235
00236     if (sourceSize >= ACTIV_MEMORY_HELPER_MEMORY_COPY_LIMIT)
00237     {
00238         ::memcpy(pDestination, pSource, sourceSize);
00239     }
00240     else
00241     {
00242         for (size_t i = 0; i < sourceSize; ++i)
00243         {
00244             static_cast<byte_t *>(pDestination)[i] = static_cast<const byte_t *>(pSource)[i];
00245         }
00246     }
00247
00248 #else
00249
00250     ::memcpy(pDestination, pSource, sourceSize);
00251
00252 #endif
00253 }
00254
00255 } // namespace Activ
00256
00257 #endif // (!defined ACTIV_MISC_MEMORY_HELPER_H)
Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

MessageBuilder.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_BASE_MESSAGE_BUILDER_H)
00010 #define ACTIV_BASE_MESSAGE_BUILDER_H
00011
00012 #include "ActivMiddleware/ActivBase/External.h"
00013 #include "ActivMiddleware/ActivBase/MessageHandler.h"
00014 #include "ActivMiddleware/ActivBase/StatusCodeException.h"
00015
00016 #include "boost/integer_traits.hpp"
00017
00018 #include <string>
00019 #include <cassert>
00020
00021 namespace Activ
00022 {
00023
00027 class MessageBuilder : public MessageHandler
00028 {
00029 public:
00039     ACTIV_BASE_INLINE_API MessageBuilder(const size_t initialBufferSize = 0, const bool shouldAdjustBufferSize = true,
00040         const MessageVersion messageVersion = MESSAGE_VERSION_UNDEFINED);
00041
00050     ACTIV_BASE_INLINE_API MessageBuilder(void * const pBuffer, const size_t bufferSize, const bool shouldAdjustBufferSize = true,
00051         const MessageVersion messageVersion = MESSAGE_VERSION_UNDEFINED);
00052
00060     ACTIV_BASE_INLINE_API MessageBuilder(const MessageBuilder &rhs);
00061
00065     ACTIV_BASE_INLINE_API ~MessageBuilder();
00066
00076     ACTIV_BASE_INLINE_API const MessageBuilder operator+(const MessageBuilder &rhs) const;
00077
00087     ACTIV_BASE_INLINE_API MessageBuilder &operator+=(const MessageBuilder &rhs);
00088
00098     ACTIV_BASE_INLINE_API MessageBuilder &operator=(const MessageBuilder &rhs);
00099
00110     ACTIV_BASE_INLINE_API StatusCode Initialize(const size_t initialBufferSize, const bool shouldAdjustBufferSize = true,
00111         const MessageVersion messageVersion = MESSAGE_VERSION_UNDEFINED);
00112
00123     ACTIV_BASE_INLINE_API StatusCode Initialize(void * const pBuffer, const size_t bufferSize, const bool shouldAdjustBufferSize = true,
00124         const MessageVersion messageVersion = MESSAGE_VERSION_UNDEFINED);
00125
00131     ACTIV_BASE_INLINE_API void Reset(const MessageVersion messageVersion = MESSAGE_VERSION_UNDEFINED);
00132
00138     ACTIV_BASE_INLINE_API const void *GetMessage() const;
00139
00145     ACTIV_BASE_INLINE_API size_t GetLength() const;
00146
00155     ACTIV_BASE_INLINE_API StatusCode SetLength(const size_t length);
00156
00162     ACTIV_BASE_INLINE_API size_t GetBufferSize() const;
00163
00175     ACTIV_BASE_INLINE_API StatusCode SetBufferSize(const size_t bufferSize);
00176
00188     ACTIV_BASE_INLINE_API StatusCode Append(const void * const pBuffer, const size_t length);
00189
00202     ACTIV_BASE_INLINE_API StatusCode AppendInEndian(const void * const pValue, const size_t size, const Endian endian);
00203
00214     ACTIV_BASE_INLINE_API StatusCode Append(const char character);
00215
00227     ACTIV_BASE_INLINE_API StatusCode Append(const char character, const size_t count);
00228
00239     ACTIV_BASE_INLINE_API StatusCode Append(const std::string &str);
00240
00254     template <typename T>
00255     ACTIV_BASE_INLINE_API StatusCode Append(const T value, const Endian endian);
00256
00272     template <typename T>
00273     ACTIV_BASE_INLINE_API StatusCode Append(const T value, const size_t size, const Endian endian);
00274
00285     ACTIV_BASE_INLINE_API StatusCode AppendBoolean(const bool value);
00286
00297     ACTIV_BASE_INLINE_API StatusCode Erase(const size_t offset, const size_t length);
00298
00311     ACTIV_BASE_INLINE_API StatusCode Insert(const size_t offset, const void * const pBuffer, const size_t length);
00312
00326     ACTIV_BASE_INLINE_API StatusCode InsertInEndian(const size_t offset, const void * const pValue, const size_t size,
00327         const Endian endian);
00328
00340     ACTIV_BASE_INLINE_API StatusCode Insert(const size_t offset, const char character);
00341
00354     ACTIV_BASE_INLINE_API StatusCode Insert(const size_t offset, const char character, const size_t count);
00355
00367     ACTIV_BASE_INLINE_API StatusCode Insert(const size_t offset, const std::string &str);
00368
00383     template<typename T>
00384     ACTIV_BASE_INLINE_API StatusCode Insert(const size_t offset, const T value, const Endian endian);
00385
00402     template<typename T>
00403     ACTIV_BASE_INLINE_API StatusCode Insert(const size_t offset, const T value, const size_t size, const Endian endian);
00404
00416     ACTIV_BASE_INLINE_API StatusCode InsertBoolean(const size_t offset, const bool value);
00417
00430     ACTIV_BASE_INLINE_API StatusCode Overwrite(const size_t offset, const void * const pBuffer, const size_t length);
00431
00445     ACTIV_BASE_INLINE_API StatusCode OverwriteInEndian(const size_t offset, const void * const pValue, const size_t size,
00446         const Endian endian);
00447
00459     ACTIV_BASE_INLINE_API StatusCode Overwrite(const size_t offset, const char character);
00460
00473     ACTIV_BASE_INLINE_API StatusCode Overwrite(const size_t offset, const char character, const size_t count);
00474
00486     ACTIV_BASE_INLINE_API StatusCode Overwrite(const size_t offset, const std::string &str);
00487
00502     template<typename T>
00503     ACTIV_BASE_INLINE_API StatusCode Overwrite(const size_t offset, const T value, const Endian endian);
00504
00521     template<typename T>
00522     ACTIV_BASE_INLINE_API StatusCode Overwrite(const size_t offset, const T value, const size_t size, const Endian endian);
00523
00535     ACTIV_BASE_INLINE_API StatusCode OverwriteBoolean(const size_t offset, const bool value);
00536
00537 private:
00545     ACTIV_BASE_LOCAL_API StatusCode Append(const char str[]);
00546
00555     ACTIV_BASE_LOCAL_API StatusCode Insert(const size_t offset, const char str[]);
00556
00565     ACTIV_BASE_LOCAL_API StatusCode Overwrite(const size_t offset, const char str[]);
00566
00582     template<typename T, size_t N>
00583     StatusCode AppendInRange(const T value, const Endian endian);
00584
00597     template<typename T>
00598     ACTIV_TEMPLATE_API(ACTIV_BASE_EXPORTED_API) StatusCode AppendBuiltIn(const T value);
00599
00612     ACTIV_BASE_EXPORTED_API StatusCode AppendBuffer(const void * const pBuffer, const size_t length,
00613         const bool reverseByteOrder = false);
00614
00625     ACTIV_BASE_EXPORTED_API StatusCode EraseBuffer(const size_t offset, const size_t length);
00626
00643     template<typename T, size_t N>
00644     StatusCode InsertInRange(const size_t offset, const T value, const Endian endian);
00645
00659     template<typename T>
00660     ACTIV_TEMPLATE_API(ACTIV_BASE_EXPORTED_API) StatusCode InsertBuiltIn(const size_t offset, const T value);
00661
00675     ACTIV_BASE_EXPORTED_API StatusCode InsertBuffer(const size_t offset, const void * const pBuffer, const size_t length,
00676         const bool reverseByteOrder = false);
00677
00694     template<typename T, size_t N>
00695     StatusCode OverwriteInRange(const size_t offset, const T value, const Endian endian);
00696
00710     template<typename T>
00711     ACTIV_TEMPLATE_API(ACTIV_BASE_EXPORTED_API) StatusCode OverwriteBuiltIn(const size_t offset, const T value);
00712
00726     ACTIV_BASE_EXPORTED_API StatusCode OverwriteBuffer(const size_t offset, const void * const pBuffer, const size_t length,
00727         const bool reverseByteOrder = false);
00728
00738     StatusCode MaybeAdjustBufferSize(const size_t unadjustedBufferSize);
00739
00748     ACTIV_BASE_EXPORTED_API StatusCode AdjustBufferSize(const size_t bufferSize);
00749
00757     ACTIV_BASE_INLINE_API size_t GetSpaceRequired(const size_t size) const;
00758
00766     ACTIV_BASE_INLINE_API bool IsSpaceAvailable(const size_t size) const;
00767
00768     bool    m_shouldAdjustBufferSize;
00769     void    *m_pStaticBuffer;
00770     size_t  m_staticBufferSize;
00771     void    *m_pBuffer;
00772     size_t  m_bufferSize;
00773     size_t  m_length;
00774 };
00775
00776 // ---------------------------------------------------------------------------------------------------------------------------------
00777 // ---------------------------------------------------------------------------------------------------------------------------------
00778
00784 template<bool S>
00785 class MessageBuilderVariableLengthRangeCheck
00786 {
00787 };
00788
00789 // ---------------------------------------------------------------------------------------------------------------------------------
00790
00794 template<>
00795 class MessageBuilderVariableLengthRangeCheck<true>
00796 {
00797 public:
00806     template<typename T>
00807     bool operator()(const T value, const size_t numberOfBytes) const
00808     {
00809         assert(numberOfBytes <= sizeof(T));
00810
00811         const T max = (T(1) << ((numberOfBytes * CHAR_BIT) - 1)) - 1;
00812         const T min = (-max) - 1;
00813
00814         return ((value >= min) && (value <= max));
00815     }
00816 };
00817
00818 // ---------------------------------------------------------------------------------------------------------------------------------
00819
00823 template<>
00824 class MessageBuilderVariableLengthRangeCheck<false>
00825 {
00826 public:
00835     template<typename T>
00836     bool operator()(const T value, const size_t numberOfBytes) const
00837     {
00838         assert(numberOfBytes <= sizeof(T));
00839
00840         const T max = T(~0) >> ((sizeof(T) - numberOfBytes) * CHAR_BIT);
00841
00842         return (value <= max);
00843     }
00844 };
00845
00846 // ---------------------------------------------------------------------------------------------------------------------------------
00847 // ---------------------------------------------------------------------------------------------------------------------------------
00848
00849 inline MessageBuilder::MessageBuilder(const size_t initialBufferSize, const bool shouldAdjustBufferSize, const MessageVersion messageVersion) :
00850     MessageHandler(messageVersion),
00851     m_shouldAdjustBufferSize(shouldAdjustBufferSize),
00852     m_pStaticBuffer(NULL),
00853     m_staticBufferSize(0),
00854     m_pBuffer(NULL),
00855     m_bufferSize(0),
00856     m_length(0)
00857 {
00858     if (0 != initialBufferSize)
00859     {
00860         ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, AdjustBufferSize(initialBufferSize));
00861     }
00862 }
00863
00864 // ---------------------------------------------------------------------------------------------------------------------------------
00865
00866 inline MessageBuilder::MessageBuilder(void * const pBuffer, const size_t bufferSize, const bool shouldAdjustBufferSize, const MessageVersion messageVersion) :
00867     MessageHandler(messageVersion),
00868     m_shouldAdjustBufferSize(shouldAdjustBufferSize),
00869     m_pStaticBuffer(pBuffer),
00870     m_staticBufferSize(bufferSize),
00871     m_pBuffer(pBuffer),
00872     m_bufferSize(bufferSize),
00873     m_length(0)
00874 {
00875 }
00876
00877 // ---------------------------------------------------------------------------------------------------------------------------------
00878
00879 inline MessageBuilder::MessageBuilder(const MessageBuilder &rhs) :
00880     MessageHandler(rhs.GetMessageVersion()),
00881     m_shouldAdjustBufferSize(rhs.m_shouldAdjustBufferSize),
00882     m_pStaticBuffer(NULL),
00883     m_staticBufferSize(0),
00884     m_pBuffer(NULL),
00885     m_bufferSize(0),
00886     m_length(0)
00887 {
00888     ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, AppendBuffer(rhs.m_pBuffer, rhs.m_length));
00889 }
00890
00891 // ---------------------------------------------------------------------------------------------------------------------------------
00892
00893 inline MessageBuilder::~MessageBuilder()
00894 {
00895     if ((m_pStaticBuffer != m_pBuffer) && (NULL != m_pBuffer))
00896         std::free(m_pBuffer);
00897 }
00898
00899 // ---------------------------------------------------------------------------------------------------------------------------------
00900
00901 inline const MessageBuilder MessageBuilder::operator+(const MessageBuilder &rhs) const
00902 {
00903     return MessageBuilder(*this) += rhs;
00904 }
00905
00906 // ---------------------------------------------------------------------------------------------------------------------------------
00907
00908 inline MessageBuilder &MessageBuilder::operator+=(const MessageBuilder &rhs)
00909 {
00910     ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, AppendBuffer(rhs.m_pBuffer, rhs.m_length));
00911
00912     return *this;
00913 }
00914
00915 // ---------------------------------------------------------------------------------------------------------------------------------
00916
00917 inline MessageBuilder &MessageBuilder::operator=(const MessageBuilder &rhs)
00918 {
00919     if (this != &rhs)
00920     {
00921         ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, SetLength(0));
00922
00923         ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, AppendBuffer(rhs.m_pBuffer, rhs.m_length));
00924     }
00925
00926     return *this;
00927 }
00928
00929 // ---------------------------------------------------------------------------------------------------------------------------------
00930
00931 inline StatusCode MessageBuilder::Initialize(const size_t initialBufferSize, const bool shouldAdjustBufferSize, const MessageVersion messageVersion)
00932 {
00933     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, AdjustBufferSize(0));
00934
00935     m_shouldAdjustBufferSize = shouldAdjustBufferSize;
00936     m_pStaticBuffer = NULL;
00937     m_staticBufferSize = 0;
00938     m_pBuffer = NULL;
00939     m_bufferSize = 0;
00940
00941     if (0 != initialBufferSize)
00942     {
00943         ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, AdjustBufferSize(initialBufferSize));
00944     }
00945
00946     Reset(messageVersion);
00947
00948     return STATUS_CODE_SUCCESS;
00949 }
00950
00951 // ---------------------------------------------------------------------------------------------------------------------------------
00952
00953 inline StatusCode MessageBuilder::Initialize(void * const pBuffer, const size_t bufferSize, const bool shouldAdjustBufferSize, const MessageVersion messageVersion)
00954 {
00955     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, AdjustBufferSize(0));
00956
00957     m_shouldAdjustBufferSize = shouldAdjustBufferSize;
00958     m_pStaticBuffer = pBuffer;
00959     m_staticBufferSize = bufferSize;
00960     m_pBuffer = pBuffer;
00961     m_bufferSize = bufferSize;
00962
00963     Reset(messageVersion);
00964
00965     return STATUS_CODE_SUCCESS;
00966 }
00967
00968 // ---------------------------------------------------------------------------------------------------------------------------------
00969
00970 inline void MessageBuilder::Reset(const MessageVersion messageVersion)
00971 {
00972     MessageHandler::Reset(messageVersion);
00973     m_length = 0;
00974 }
00975
00976 // ---------------------------------------------------------------------------------------------------------------------------------
00977
00978 inline const void *MessageBuilder::GetMessage() const
00979 {
00980     return m_pBuffer;
00981 }
00982
00983 // ---------------------------------------------------------------------------------------------------------------------------------
00984
00985 inline size_t MessageBuilder::GetLength() const
00986 {
00987     return m_length;
00988 }
00989
00990 // ---------------------------------------------------------------------------------------------------------------------------------
00991
00992 inline StatusCode MessageBuilder::SetLength(const size_t length)
00993 {
00994     if (ACTIV_UNLIKELY(length > m_length))
00995         return STATUS_CODE_INVALID_PARAMETER;
00996
00997     m_length = length;
00998
00999     return STATUS_CODE_SUCCESS;
01000 }
01001
01002 // ---------------------------------------------------------------------------------------------------------------------------------
01003
01004 inline size_t MessageBuilder::GetBufferSize() const
01005 {
01006     return m_bufferSize;
01007 }
01008
01009 // ---------------------------------------------------------------------------------------------------------------------------------
01010
01011 inline StatusCode MessageBuilder::SetBufferSize(const size_t bufferSize)
01012 {
01013     if (bufferSize < m_length)
01014         return STATUS_CODE_INVALID_PARAMETER;
01015
01016     return AdjustBufferSize(bufferSize);
01017 }
01018
01019 // ---------------------------------------------------------------------------------------------------------------------------------
01020
01021 inline StatusCode MessageBuilder::Append(const void * const pBuffer, const size_t length)
01022 {
01023     return AppendBuffer(pBuffer, length, false);
01024 }
01025
01026 // ---------------------------------------------------------------------------------------------------------------------------------
01027
01028 inline StatusCode MessageBuilder::AppendInEndian(const void * const pValue, const size_t size, const Endian endian)
01029 {
01030     return AppendBuffer(pValue, size, (ENDIAN_LOCAL != endian));
01031 }
01032
01033 // ---------------------------------------------------------------------------------------------------------------------------------
01034
01035 inline StatusCode MessageBuilder::Append(const char character)
01036 {
01037     return AppendBuiltIn<int8_t>(character);
01038 }
01039
01040 // ---------------------------------------------------------------------------------------------------------------------------------
01041
01042 inline StatusCode MessageBuilder::Append(const char character, const size_t count)
01043 {
01044     return AppendBuffer(std::string(count, character).c_str(), count, false);
01045 }
01046
01047 // ---------------------------------------------------------------------------------------------------------------------------------
01048
01049 inline StatusCode MessageBuilder::Append(const std::string &str)
01050 {
01051     if (ACTIV_UNLIKELY(str.length() > boost::integer_traits<StringLength>::const_max))
01052         return STATUS_CODE_INVALID_PARAMETER;
01053
01054     StringLength length = static_cast<StringLength>(str.length());
01055
01056     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, Append<StringLength>(length, ENDIAN_LITTLE));
01057
01058     return AppendBuffer(str.c_str(), length, false);
01059 }
01060
01061 // ---------------------------------------------------------------------------------------------------------------------------------
01062
01063 template <typename T>
01064 inline StatusCode MessageBuilder::Append(const T value, const Endian endian)
01065 {
01066     return AppendBuiltIn<T>((ENDIAN_LOCAL == endian) ? value : ByteSwap(value));
01067 }
01068
01069 // ---------------------------------------------------------------------------------------------------------------------------------
01070
01071 template <typename T>
01072 StatusCode MessageBuilder::Append(const T value, const size_t size, const Endian endian)
01073 {
01074     // Assert T is an integral type, as we cast it to an ACTIV integral type (or use its address).
01075     BOOST_STATIC_ASSERT(boost::is_integral<T>::value);
01076
01077     if (ACTIV_UNLIKELY(size > sizeof(T)))
01078     {
01079         return STATUS_CODE_INVALID_PARAMETER;
01080     }
01081     else if (ACTIV_UNLIKELY(size == sizeof(T)))
01082     {
01083         // Cast to the equivalently sized ACTIV type, as the implementation of Append() is only exported for those types.
01084         typedef typename TypeToIntegralType<T>::Type Target;
01085
01086         return Append(static_cast<Target>(value), endian);
01087     }
01088
01089     switch (size)
01090     {
01091         case 1:
01092             return AppendInRange<T, 1>(value, endian);
01093
01094         case 2:
01095             return AppendInRange<T, 2>(value, endian);
01096
01097         case 4:
01098             return AppendInRange<T, 4>(value, endian);
01099
01100         case 8:
01101             // GCC throws up silly warnings if we go the range-check route with a 64-bit target, so avoid the check
01102             // and assert the source type isn't bigger than 64-bits...
01103             BOOST_STATIC_ASSERT(sizeof(T) <= 8);
01104             return Append(static_cast<typename LengthToIntegralType<8, boost::integer_traits<T>::is_signed>::Type>(value), endian);
01105
01106         default:
01107             break;
01108     }
01109
01110     if (ACTIV_UNLIKELY(!MessageBuilderVariableLengthRangeCheck<boost::integer_traits<T>::is_signed>()(value, size)))
01111         return STATUS_CODE_OUT_OF_RANGE;
01112
01113 #if (defined ACTIV_LITTLE_ENDIAN)
01114     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, AppendInEndian(&value, size, endian));
01115 #else
01116     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, AppendInEndian(reinterpret_cast<const byte_t *>(&value) + sizeof(T) - size,
01117         size, endian));
01118 #endif
01119
01120     return STATUS_CODE_SUCCESS;
01121 }
01122
01123 // ---------------------------------------------------------------------------------------------------------------------------------
01124
01125 inline StatusCode MessageBuilder::AppendBoolean(const bool value)
01126 {
01127     return AppendBuiltIn<uint8_t>(static_cast<uint8_t>(value ? 1 : 0));
01128 }
01129
01130 // ---------------------------------------------------------------------------------------------------------------------------------
01131
01132 inline StatusCode MessageBuilder::Erase(const size_t offset, const size_t length)
01133 {
01134     return EraseBuffer(offset, length);
01135 }
01136
01137 // ---------------------------------------------------------------------------------------------------------------------------------
01138
01139 inline StatusCode MessageBuilder::Insert(const size_t offset, const void * const pBuffer, const size_t length)
01140 {
01141     return InsertBuffer(offset, pBuffer, length, false);
01142 }
01143
01144 // ---------------------------------------------------------------------------------------------------------------------------------
01145
01146 inline StatusCode MessageBuilder::InsertInEndian(const size_t offset, const void * const pValue, const size_t size, const Endian endian)
01147 {
01148     return InsertBuffer(offset, pValue, size, (ENDIAN_LOCAL != endian));
01149 }
01150
01151 // ---------------------------------------------------------------------------------------------------------------------------------
01152
01153 inline StatusCode MessageBuilder::Insert(const size_t offset, const char character)
01154 {
01155     return InsertBuiltIn<int8_t>(offset, character);
01156 }
01157
01158 // ---------------------------------------------------------------------------------------------------------------------------------
01159
01160 inline StatusCode MessageBuilder::Insert(const size_t offset, const char character, const size_t count)
01161 {
01162     return InsertBuffer(offset, std::string(count, character).c_str(), count, false);
01163 }
01164
01165 // ---------------------------------------------------------------------------------------------------------------------------------
01166
01167 inline StatusCode MessageBuilder::Insert(const size_t offset, const std::string &str)
01168 {
01169     if (ACTIV_UNLIKELY(str.length() > boost::integer_traits<StringLength>::const_max))
01170         return STATUS_CODE_INVALID_PARAMETER;
01171
01172     StringLength length = static_cast<StringLength>(str.length());
01173
01174     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, Insert<StringLength>(offset, length, ENDIAN_LITTLE));
01175
01176     return InsertBuffer(offset + sizeof(length), str.c_str(), length, false);
01177 }
01178
01179 // ---------------------------------------------------------------------------------------------------------------------------------
01180
01181 template<typename T>
01182 inline StatusCode MessageBuilder::Insert(const size_t offset, const T value, const Endian endian)
01183 {
01184     return InsertBuiltIn<T>(offset, (ENDIAN_LOCAL == endian) ? value : ByteSwap(value));
01185 }
01186
01187 // ---------------------------------------------------------------------------------------------------------------------------------
01188
01189 template<typename T>
01190 StatusCode MessageBuilder::Insert(const size_t offset, const T value, const size_t size, const Endian endian)
01191 {
01192     // Assert T is an integral type, as we cast it to an ACTIV integral type (or use its address).
01193     BOOST_STATIC_ASSERT(boost::is_integral<T>::value);
01194
01195     if (ACTIV_UNLIKELY(size > sizeof(T)))
01196     {
01197         return STATUS_CODE_INVALID_PARAMETER;
01198     }
01199     else if (ACTIV_UNLIKELY(size == sizeof(T)))
01200     {
01201         // Cast to the equivalently sized ACTIV type, as the implementation of Insert() is only exported for those types.
01202         typedef typename TypeToIntegralType<T>::Type Target;
01203
01204         return Insert(offset, static_cast<Target>(value), endian);
01205     }
01206
01207     switch (size)
01208     {
01209         case 1:
01210             return InsertInRange<T, 1>(offset, value, endian);
01211
01212         case 2:
01213             return InsertInRange<T, 2>(offset, value, endian);
01214
01215         case 4:
01216             return InsertInRange<T, 4>(offset, value, endian);
01217
01218         case 8:
01219             // GCC throws up silly warnings if we go the range-check route with a 64-bit target, so avoid the check
01220             // and assert the source type isn't bigger than 64-bits...
01221             BOOST_STATIC_ASSERT(sizeof(T) <= 8);
01222             return Insert(offset, static_cast<typename LengthToIntegralType<8, boost::integer_traits<T>::is_signed>::Type>(value), endian);
01223
01224         default:
01225             break;
01226     }
01227
01228     if (ACTIV_UNLIKELY(!MessageBuilderVariableLengthRangeCheck<boost::integer_traits<T>::is_signed>()(value, size)))
01229         return STATUS_CODE_OUT_OF_RANGE;
01230
01231 #if (defined ACTIV_LITTLE_ENDIAN)
01232     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, InsertInEndian(offset, &value, size, endian));
01233 #else
01234     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, InsertInEndian(offset,
01235         reinterpret_cast<const byte_t *>(&value) + sizeof(T) - size, size, endian));
01236 #endif
01237
01238     return STATUS_CODE_SUCCESS;
01239 }
01240
01241 // ---------------------------------------------------------------------------------------------------------------------------------
01242
01243 inline StatusCode MessageBuilder::InsertBoolean(const size_t offset, const bool value)
01244 {
01245     return InsertBuiltIn<uint8_t>(offset, static_cast<uint8_t>(value ? 1 : 0));
01246 }
01247
01248 // ---------------------------------------------------------------------------------------------------------------------------------
01249
01250 inline StatusCode MessageBuilder::Overwrite(const size_t offset, const void * const pBuffer, const size_t length)
01251 {
01252     return OverwriteBuffer(offset, pBuffer, length, false);
01253 }
01254
01255 // ---------------------------------------------------------------------------------------------------------------------------------
01256
01257 inline StatusCode MessageBuilder::OverwriteInEndian(const size_t offset, const void * const pValue, const size_t size, const Endian endian)
01258 {
01259     return OverwriteBuffer(offset, pValue, size, (ENDIAN_LOCAL != endian));
01260 }
01261
01262 // ---------------------------------------------------------------------------------------------------------------------------------
01263
01264 inline StatusCode MessageBuilder::Overwrite(const size_t offset, const char character)
01265 {
01266     return OverwriteBuiltIn<int8_t>(offset, character);
01267 }
01268
01269 // ---------------------------------------------------------------------------------------------------------------------------------
01270
01271 inline StatusCode MessageBuilder::Overwrite(const size_t offset, const char character, const size_t count)
01272 {
01273     return OverwriteBuffer(offset, std::string(count, character).c_str(), count, false);
01274 }
01275
01276 // ---------------------------------------------------------------------------------------------------------------------------------
01277
01278 inline StatusCode MessageBuilder::Overwrite(const size_t offset, const std::string &str)
01279 {
01280     if (ACTIV_UNLIKELY(str.length() > boost::integer_traits<StringLength>::const_max))
01281         return STATUS_CODE_INVALID_PARAMETER;
01282
01283     StringLength length = static_cast<StringLength>(str.length());
01284
01285     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, Overwrite<StringLength>(offset, length, ENDIAN_LITTLE));
01286
01287     return OverwriteBuffer(offset + sizeof(length), str.c_str(), length, false);
01288 }
01289
01290 // ---------------------------------------------------------------------------------------------------------------------------------
01291
01292 template<typename T>
01293 inline StatusCode MessageBuilder::Overwrite(const size_t offset, const T value, const Endian endian)
01294 {
01295     return OverwriteBuiltIn<T>(offset, (ENDIAN_LOCAL == endian) ? value : ByteSwap(value));
01296 }
01297
01298 // ---------------------------------------------------------------------------------------------------------------------------------
01299
01300 template<typename T>
01301 StatusCode MessageBuilder::Overwrite(const size_t offset, const T value, const size_t size, const Endian endian)
01302 {
01303     // Assert T is an integral type, as we cast it to an ACTIV integral type (or use its address).
01304     BOOST_STATIC_ASSERT(boost::is_integral<T>::value);
01305
01306     if (ACTIV_UNLIKELY(size > sizeof(T)))
01307     {
01308         return STATUS_CODE_INVALID_PARAMETER;
01309     }
01310     else if (ACTIV_UNLIKELY(size == sizeof(T)))
01311     {
01312         // Cast to the equivalently sized ACTIV type, as the implementation of Overwrite() is only exported for those types.
01313         typedef typename TypeToIntegralType<T>::Type Target;
01314
01315         return Overwrite(offset, static_cast<Target>(value), endian);
01316     }
01317
01318     switch (size)
01319     {
01320         case 1:
01321             return OverwriteInRange<T, 1>(offset, value, endian);
01322
01323         case 2:
01324             return OverwriteInRange<T, 2>(offset, value, endian);
01325
01326         case 4:
01327             return OverwriteInRange<T, 4>(offset, value, endian);
01328
01329         case 8:
01330             // GCC throws up silly warnings if we go the range-check route with a 64-bit target, so avoid the check
01331             // and assert the source type isn't bigger than 64-bits...
01332             BOOST_STATIC_ASSERT(sizeof(T) <= 8);
01333             return Overwrite(offset, static_cast<typename LengthToIntegralType<8, boost::integer_traits<T>::is_signed>::Type>(value), endian);
01334
01335         default:
01336             break;
01337     }
01338
01339     if (ACTIV_UNLIKELY(!MessageBuilderVariableLengthRangeCheck<boost::integer_traits<T>::is_signed>()(value, size)))
01340         return STATUS_CODE_OUT_OF_RANGE;
01341
01342 #if (defined ACTIV_LITTLE_ENDIAN)
01343     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, OverwriteInEndian(offset, &value, size, endian));
01344 #else
01345     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, OverwriteInEndian(offset,
01346         reinterpret_cast<const byte_t *>(&value) + sizeof(T) - size, size, endian));
01347 #endif
01348
01349     return STATUS_CODE_SUCCESS;
01350 }
01351
01352 // ---------------------------------------------------------------------------------------------------------------------------------
01353
01354 inline StatusCode MessageBuilder::OverwriteBoolean(const size_t offset, const bool value)
01355 {
01356     return OverwriteBuiltIn<uint8_t>(offset, static_cast<uint8_t>(value ? 1 : 0));
01357 }
01358
01359 // ---------------------------------------------------------------------------------------------------------------------------------
01360
01361 template<typename T, size_t N>
01362 inline StatusCode MessageBuilder::AppendInRange(const T value, const Endian endian)
01363 {
01364     typedef typename LengthToIntegralType<N, boost::integer_traits<T>::is_signed>::Type Target;
01365
01366     if (ACTIV_UNLIKELY((value > boost::integer_traits<Target>::const_max) || (value < boost::integer_traits<Target>::const_min)))
01367         return STATUS_CODE_OUT_OF_RANGE;
01368
01369     return Append(static_cast<Target>(value), endian);
01370 }
01371
01372 // ---------------------------------------------------------------------------------------------------------------------------------
01373
01374 template<typename T, size_t N>
01375 inline StatusCode MessageBuilder::InsertInRange(const size_t offset, const T value, const Endian endian)
01376 {
01377     typedef typename LengthToIntegralType<N, boost::integer_traits<T>::is_signed>::Type Target;
01378
01379     if (ACTIV_UNLIKELY((value > boost::integer_traits<Target>::const_max) || (value < boost::integer_traits<Target>::const_min)))
01380         return STATUS_CODE_OUT_OF_RANGE;
01381
01382     return Insert(offset, static_cast<Target>(value), endian);
01383 }
01384
01385 // ---------------------------------------------------------------------------------------------------------------------------------
01386
01387 template<typename T, size_t N>
01388 inline StatusCode MessageBuilder::OverwriteInRange(const size_t offset, const T value, const Endian endian)
01389 {
01390     typedef typename LengthToIntegralType<N, boost::integer_traits<T>::is_signed>::Type Target;
01391
01392     if (ACTIV_UNLIKELY((value > boost::integer_traits<Target>::const_max) || (value < boost::integer_traits<Target>::const_min)))
01393         return STATUS_CODE_OUT_OF_RANGE;
01394
01395     return Overwrite(offset, static_cast<Target>(value), endian);
01396 }
01397
01398 } // namespace Activ
01399
01400 #endif // (!defined ACTIV_BASE_MESSAGE_BUILDER_H)
Generated on Wed Oct 8 14:01:47 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform

MessageClasses.h

Go to the documentation of this file.
00001
00010 #if (!defined ACTIV_MESSAGE_CLASSES_H)
00011 #define ACTIV_MESSAGE_CLASSES_H
00012
00013 #include "ActivMiddleware/ActivSystem/MessageTypes.h"
00014
00015 namespace Activ
00016 {
00017
00021 #define ACTIV_CONTENT_PLATFORM_MESSAGE_CLASS_LIST(d)                        \
00022     d(32,   MESSAGE_CLASS_CONTENT_SERVER,       "ContentServer")            \
00023     d(33,   MESSAGE_CLASS_CONTENT_GATEWAY_API,  "ContentGatewayApi")        \
00024     d(34,   MESSAGE_CLASS_SYMBOL_DIRECTORY,     "SymbolDirectory")          \
00025     d(35,   MESSAGE_CLASS_REFRESH_REQUESTER,    "RefreshRequester")         \
00026     d(36,   MESSAGE_CLASS_HISTORY_MANAGER,      "History Manager")          \
00027     d(37,   MESSAGE_CLASS_INGEST,               "Ingest")                   \
00028     d(38,   MESSAGE_CLASS_NEWS_SERVER,          "News Server")              \
00029     d(39,   MESSAGE_CLASS_WORKSTATION_SERVICE,  "Workstation Service")      \
00030     d(40,   MESSAGE_CLASS_CONTRIBUTION_GATEWAY, "ContributionGateway")      \
00031     d(41,   MESSAGE_CLASS_LOAD_BALANCER,        "LoadBalancer")             \
00032     d(42,   MESSAGE_CLASS_CONTENT_GATEWAY,      "ContentGateway")
00033
00037 ACTIV_CONTENT_PLATFORM_MESSAGE_CLASS_LIST(ACTIV_DECLARE_MESSAGE_CLASS)
00038
00039 } // namespace Activ
00040
00041 #endif // (!defined ACTIV_MESSAGE_CLASSES_H)
Generated on Wed Oct 8 14:01:46 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

MessageHandler.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_BASE_MESSAGE_HANDLER_H)
00010 #define ACTIV_BASE_MESSAGE_HANDLER_H
00011
00012 #include "ActivMiddleware/ActivBase/External.h"
00013
00014 namespace Activ
00015 {
00016
00020 class MessageHandler
00021 {
00022 public:
00023     typedef uint16_t StringLength;
00024     typedef uint8_t MessageVersion;
00025
00026     static const byte_t MIN_PRINTABLE_ASCII = 0x20;
00027     static const byte_t MAX_PRINTABLE_ASCII = 0x7e;
00028     static const MessageVersion MESSAGE_VERSION_UNDEFINED = ~0;
00029
00033     enum Endian
00034     {
00035         ENDIAN_LITTLE,
00036         ENDIAN_BIG,
00037 #if (defined ACTIV_LITTLE_ENDIAN)
00038         ENDIAN_LOCAL = ENDIAN_LITTLE,
00039         ENDIAN_ALIEN = ENDIAN_BIG
00040 #else
00041         ENDIAN_LOCAL = ENDIAN_BIG,
00042         ENDIAN_ALIEN = ENDIAN_LITTLE
00043 #endif
00044     };
00045
00049     class ScopedVersion : private boost::noncopyable
00050     {
00051     public:
00059         ACTIV_BASE_INLINE_API ScopedVersion(MessageHandler &messageHandler);
00060
00070         ACTIV_BASE_INLINE_API ScopedVersion(MessageHandler &messageHandler, const MessageVersion newVersion);
00071
00077         ACTIV_BASE_INLINE_API ~ScopedVersion();
00078
00079     private:
00080         MessageHandler &        m_messageHandler;
00081         const MessageVersion    m_oldVersion;
00082     };
00083
00089     ACTIV_BASE_INLINE_API MessageHandler(const MessageVersion messageVersion = MESSAGE_VERSION_UNDEFINED);
00090
00094     virtual ~MessageHandler() = 0;
00095
00101     virtual void Reset(const MessageVersion messageVersion = MESSAGE_VERSION_UNDEFINED) = 0;
00102
00108     ACTIV_BASE_INLINE_API MessageVersion GetMessageVersion() const;
00109
00117     ACTIV_BASE_INLINE_API MessageVersion SetMessageVersion(const MessageVersion messageVersion);
00118
00119 private:
00120     MessageVersion  m_messageVersion;
00121 };
00122
00123 // ---------------------------------------------------------------------------------------------------------------------------------
00124
00125 inline MessageHandler::MessageHandler(const MessageVersion messageVersion)
00126 {
00127     MessageHandler::Reset(messageVersion);
00128 }
00129
00130 // ---------------------------------------------------------------------------------------------------------------------------------
00131
00132 inline MessageHandler::~MessageHandler()
00133 {
00134 }
00135
00136 // ---------------------------------------------------------------------------------------------------------------------------------
00137
00138 inline void MessageHandler::Reset(const MessageVersion messageVersion)
00139 {
00140     SetMessageVersion(messageVersion);
00141 }
00142
00143 // ---------------------------------------------------------------------------------------------------------------------------------
00144
00145 inline MessageHandler::MessageVersion MessageHandler::GetMessageVersion() const
00146 {
00147     return m_messageVersion;
00148 }
00149
00150 // ---------------------------------------------------------------------------------------------------------------------------------
00151
00152 inline MessageHandler::MessageVersion MessageHandler::SetMessageVersion(const MessageVersion messageVersion)
00153 {
00154     const MessageVersion oldMessageVersion = m_messageVersion;
00155
00156     m_messageVersion = messageVersion;
00157
00158     return oldMessageVersion;
00159 }
00160
00161 // ---------------------------------------------------------------------------------------------------------------------------------
00162 // ---------------------------------------------------------------------------------------------------------------------------------
00163
00164 inline MessageHandler::ScopedVersion::ScopedVersion(MessageHandler &messageHandler) :
00165     m_messageHandler(messageHandler),
00166     m_oldVersion(m_messageHandler.GetMessageVersion())
00167 {
00168 }
00169
00170 // ---------------------------------------------------------------------------------------------------------------------------------
00171
00172 inline MessageHandler::ScopedVersion::ScopedVersion(MessageHandler &messageHandler, const byte_t newVersion) :
00173     m_messageHandler(messageHandler),
00174     m_oldVersion(m_messageHandler.SetMessageVersion(newVersion))
00175 {
00176 }
00177
00178 // ---------------------------------------------------------------------------------------------------------------------------------
00179
00180 inline MessageHandler::ScopedVersion::~ScopedVersion()
00181 {
00182     (void) m_messageHandler.SetMessageVersion(m_oldVersion);
00183 }
00184
00185 } // namespace Activ
00186
00187 #endif // (!defined ACTIV_BASE_MESSAGE_HANDLER_H)
Generated on Wed Oct 8 14:01:47 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedMessageHandler

MessageHeaderDefinitions.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FEED_MESSAGE_HANDLER_MESSAGE_HEADER_DEFINITIONS_H)
00010 #define ACTIV_FEED_MESSAGE_HANDLER_MESSAGE_HEADER_DEFINITIONS_H
00011
00012 #include "ActivContentPlatform/ActivFeedCommon/FieldIds.h"
00013
00014 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/External.h"
00015 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/ActivFeedMessageHandler.h"
00016
00017 namespace Activ
00018 {
00019
00020 namespace ContentPlatform
00021 {
00022
00023 namespace Feed
00024 {
00025
00029 class MessageHeaderDefinitions
00030 {
00031 public:
00032     typedef uint8_t MessageHeader;
00033
00034     static const size_t     FLAGS_OFFSET        = 0;
00035     static const size_t     FLAGS_LENGTH        = 3;
00036     static const size_t     MESSAGE_TYPE_OFFSET = (FLAGS_OFFSET + FLAGS_LENGTH);
00037     static const size_t     MESSAGE_TYPE_LENGTH = 5;
00038
00039     static const MessageHeaderDefinitions::MessageHeader    FLAGS_BIT_MASK          = static_cast<MessageHeaderDefinitions::MessageHeader>((1 << FLAGS_LENGTH) - 1);
00040     static const size_t                                     FLAGS_BIT_SHIFT         = (sizeof(MessageHeader) * CHAR_BIT) - (FLAGS_OFFSET + FLAGS_LENGTH);
00041     static const MessageHeaderDefinitions::MessageHeader    MESSAGE_TYPE_BIT_MASK   = static_cast<MessageHeaderDefinitions::MessageHeader>((1 << MESSAGE_TYPE_LENGTH) - 1);
00042     static const size_t                                     MESSAGE_TYPE_BIT_SHIFT  = (sizeof(MessageHeader) * CHAR_BIT) - (MESSAGE_TYPE_OFFSET + MESSAGE_TYPE_LENGTH);
00043
00052     static MessageHeader GetMessageHeader(const uint32_t flags, const MessageType messageType);
00053
00062     static bool IsValidMessageType(const MessageHeader messageHeader, const MessageType messageType);
00063
00071     static uint32_t GetFlags(const MessageHeader messageHeader);
00072
00080     static MessageType GetMessageType(const MessageHeader messageHeader);
00081 };
00082
00083 // ---------------------------------------------------------------------------------------------------------------------------------
00084
00085 inline MessageHeaderDefinitions::MessageHeader MessageHeaderDefinitions::GetMessageHeader(const uint32_t flags, const MessageType messageType)
00086 {
00087     return static_cast<MessageHeader>((flags << FLAGS_BIT_SHIFT) | (messageType << MESSAGE_TYPE_BIT_SHIFT));
00088 }
00089
00090 // ---------------------------------------------------------------------------------------------------------------------------------
00091
00092 inline bool MessageHeaderDefinitions::IsValidMessageType(const MessageHeaderDefinitions::MessageHeader messageHeader, const MessageType messageType)
00093 {
00094     return (MessageHeaderDefinitions::GetMessageType(messageHeader) == messageType);
00095 }
00096
00097 // ---------------------------------------------------------------------------------------------------------------------------------
00098
00099 inline uint32_t MessageHeaderDefinitions::GetFlags(const MessageHeader messageHeader)
00100 {
00101     return static_cast<uint32_t>((messageHeader >> FLAGS_BIT_SHIFT) & FLAGS_BIT_MASK);
00102 }
00103
00104 // ---------------------------------------------------------------------------------------------------------------------------------
00105
00106 inline MessageType MessageHeaderDefinitions::GetMessageType(const MessageHeader messageHeader)
00107 {
00108     return static_cast<MessageType>((messageHeader >> MESSAGE_TYPE_BIT_SHIFT) & MESSAGE_TYPE_BIT_MASK);
00109 }
00110
00111 } // namespace Feed
00112
00113 } // namespace ContentPlatform
00114
00115 } // namespace Activ
00116
00117 #endif // (!defined ACTIV_FEED_MESSAGE_HANDLER_MESSAGE_HEADER_DEFINITIONS_H)
Generated on Wed Oct 8 14:01:45 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

MessageRateThrottler.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_BASE_MESSAGE_RATE_THROTTLER_H)
00010 #define ACTIV_BASE_MESSAGE_RATE_THROTTLER_H
00011
00012 #include "ActivMiddleware/ActivBase/External.h"
00013 #include "ActivMiddleware/ActivBase/IntervalTimer.h"
00014
00015 namespace Activ
00016 {
00017
00018 class IMutex;
00019
00020 // ---------------------------------------------------------------------------------------------------------------------------------
00021
00025 class MessageRateThrottler
00026 {
00027 public:
00028     static const size_t PERIOD_LENGTH_MINIMUM   = 25;
00029     static const size_t PERIOD_LENGTH_MAXIMUM   = 1000;
00030
00037     ACTIV_BASE_EXPORTED_API MessageRateThrottler(const size_t messageRate = 0, const bool shouldCreateMutex = false);
00038
00049     ACTIV_BASE_EXPORTED_API MessageRateThrottler(const size_t messageRate, const size_t periodLength,
00050         const bool shouldCreateMutex = false);
00051
00055     ACTIV_BASE_EXPORTED_API ~MessageRateThrottler();
00056
00064     ACTIV_BASE_EXPORTED_API StatusCode Initialize(const size_t messageRate);
00065
00076     ACTIV_BASE_EXPORTED_API StatusCode Initialize(const size_t messageRate, const size_t periodLength);
00077
00083     ACTIV_BASE_EXPORTED_API const size_t GetMessageRate() const;
00084
00090     ACTIV_BASE_EXPORTED_API const size_t GetPeriodLength() const;
00091
00095     ACTIV_BASE_EXPORTED_API void Reset();
00096
00100     ACTIV_BASE_EXPORTED_API void Suspend();
00101
00102 private:
00103     static const size_t MILLISECONDS_PER_SECOND     = 1000;
00104
00105     const IntervalTimer m_intervalTimer;
00106     const uint64_t      m_intervalTimerFrequency;
00107     IMutex * const      m_pMutex;
00108
00109     size_t              m_messageRate;
00110     size_t              m_periodLength;
00111     size_t              m_totalPeriods;
00112
00113     size_t              m_nPeriod;
00114     size_t              m_nMessagesInPeriod;
00115     size_t              m_maxMessagesInPeriod;
00116     uint64_t            m_startTimeStamp;
00117     uint64_t            m_lastTimeStamp;
00118 };
00119
00120 } // namespace Activ
00121
00122 #endif // (!defined ACTIV_BASE_MESSAGE_RATE_THROTTLER_H)
Generated on Wed Oct 8 14:01:47 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivSystem

MessageTypes.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_SYSTEM_MESSAGE_TYPES_H)
00010 #define ACTIV_SYSTEM_MESSAGE_TYPES_H
00011
00012 #include "ActivMiddleware/ActivSystem/External.h"
00013
00014 #include <string>
00015
00016 namespace Activ
00017 {
00018
00022 typedef byte_t MessageClass;
00023
00027 #define ACTIV_MESSAGE_CLASS_LIST(d)                                         \
00028     d(0,    MESSAGE_CLASS_SYSTEM,           "System")                       \
00029     d(1,    MESSAGE_CLASS_TIMER,            "Timer")                        \
00030     d(2,    MESSAGE_CLASS_LOGGER,           "Logger")                       \
00031     d(3,    MESSAGE_CLASS_DIRECTORY,        "Directory")                    \
00032     d(4,    MESSAGE_CLASS_ROUTER,           "Router")                       \
00033     d(5,    MESSAGE_CLASS_PUBSUB,           "Pub-Sub")                      \
00034     d(6,    MESSAGE_CLASS_MQ,               "Message-Queue")                \
00035     d(7,    MESSAGE_CLASS_UI,               "UI")                           \
00036     d(8,    MESSAGE_CLASS_DATABASE,         "Database")                     \
00037     d(9,    MESSAGE_CLASS_SERVICE,          "Service")                      \
00038     d(10,   MESSAGE_CLASS_UDP,              "Udp")                          \
00039     d(11,   MESSAGE_CLASS_TCP,              "Tcp")                          \
00040     d(12,   MESSAGE_CLASS_MONITOR,          "Monitor")                      \
00041     d(13,   MESSAGE_CLASS_UPDATE,           "Update")                       \
00042     d(14,   MESSAGE_CLASS_LICENSE,          "License")                      \
00043     d(64,   MESSAGE_CLASS_USER_BASE,        "User")
00044
00048 #define ACTIV_DECLARE_MESSAGE_CLASS(value, messageClass, name)              \
00049     const Activ::MessageClass messageClass = value;
00050
00054 ACTIV_MESSAGE_CLASS_LIST(ACTIV_DECLARE_MESSAGE_CLASS)
00055
00056
00063 ACTIV_SYSTEM_EXPORTED_API
00064 std::string MessageClassToString(const MessageClass messageClass);
00065
00075 ACTIV_SYSTEM_EXPORTED_API
00076 StatusCode StringToMessageClass(const std::string &str, MessageClass &messageClass);
00077
00078 // ---------------------------------------------------------------------------------------------------------------------------------
00079
00086 #define MakeMessageType(messageClass, subType)                              \
00087     ((static_cast<Activ::MessageType>((messageClass)) << 8) | (subType))
00088
00096 inline MessageClass GetMessageClass(const MessageType messageType)
00097 {
00098     return static_cast<MessageClass>(messageType >> 8);
00099 }
00100
00101 // ---------------------------------------------------------------------------------------------------------------------------------
00102
00110 inline byte_t GetSubType(const MessageType messageType)
00111 {
00112     return static_cast<byte_t>(messageType & 0xff);
00113 }
00114
00118 #define ACTIV_DECLARE_MESSAGE_TYPE(value, messageClass, name)               \
00119     const Activ::MessageType name = MakeMessageType(messageClass, value)
00120
00121 // ---------------------------------------------------------------------------------------------------------------------------------
00122
00126 ACTIV_DECLARE_MESSAGE_TYPE(0,   MESSAGE_CLASS_SYSTEM,   SYSTEM_REQUEST_FIND_PORT);
00127 ACTIV_DECLARE_MESSAGE_TYPE(1,   MESSAGE_CLASS_SYSTEM,   SYSTEM_REQUEST_PING_PORT);
00128 ACTIV_DECLARE_MESSAGE_TYPE(2,   MESSAGE_CLASS_SYSTEM,   SYSTEM_REQUEST_TOKEN);
00129 ACTIV_DECLARE_MESSAGE_TYPE(3,   MESSAGE_CLASS_SYSTEM,   SYSTEM_REQUEST_GET_PORT_INFO_LIST);
00130
00131 // ---------------------------------------------------------------------------------------------------------------------------------
00132
00136 ACTIV_DECLARE_MESSAGE_TYPE(0,   MESSAGE_CLASS_SYSTEM,   SYSTEM_MESSAGE_THREAD_EXIT);
00137 ACTIV_DECLARE_MESSAGE_TYPE(1,   MESSAGE_CLASS_SYSTEM,   SYSTEM_MESSAGE_CTRL_EVENT);
00138 ACTIV_DECLARE_MESSAGE_TYPE(2,   MESSAGE_CLASS_SYSTEM,   SYSTEM_MESSAGE_SYSTEM_SHUTDOWN);
00139 ACTIV_DECLARE_MESSAGE_TYPE(3,   MESSAGE_CLASS_SYSTEM,   SYSTEM_MESSAGE_PROCESS_STARTUP);
00140 ACTIV_DECLARE_MESSAGE_TYPE(4,   MESSAGE_CLASS_SYSTEM,   SYSTEM_MESSAGE_PROCESS_SHUTDOWN);
00141 ACTIV_DECLARE_MESSAGE_TYPE(5,   MESSAGE_CLASS_SYSTEM,   SYSTEM_MESSAGE_ENDPOINT_STARTUP);
00142 ACTIV_DECLARE_MESSAGE_TYPE(6,   MESSAGE_CLASS_SYSTEM,   SYSTEM_MESSAGE_ENDPOINT_SHUTDOWN);
00143 ACTIV_DECLARE_MESSAGE_TYPE(7,   MESSAGE_CLASS_SYSTEM,   SYSTEM_MESSAGE_ENDPOINT_DIE);
00144 ACTIV_DECLARE_MESSAGE_TYPE(8,   MESSAGE_CLASS_SYSTEM,   SYSTEM_MESSAGE_HEAP_STARTUP);
00145 ACTIV_DECLARE_MESSAGE_TYPE(9,   MESSAGE_CLASS_SYSTEM,   SYSTEM_MESSAGE_ENDPOINT_PAUSE);
00146 ACTIV_DECLARE_MESSAGE_TYPE(10,  MESSAGE_CLASS_SYSTEM,   SYSTEM_MESSAGE_ENDPOINT_RESUME);
00147 ACTIV_DECLARE_MESSAGE_TYPE(11,  MESSAGE_CLASS_SYSTEM,   SYSTEM_MESSAGE_CLOSE_ADDRESS);
00148 ACTIV_DECLARE_MESSAGE_TYPE(12,  MESSAGE_CLASS_SYSTEM,   SYSTEM_MESSAGE_KILL_PROCESSES);
00149 ACTIV_DECLARE_MESSAGE_TYPE(13,  MESSAGE_CLASS_SYSTEM,   SYSTEM_MESSAGE_NOP);
00150
00151 // ---------------------------------------------------------------------------------------------------------------------------------
00152
00156 ACTIV_DECLARE_MESSAGE_TYPE(0,   MESSAGE_CLASS_TIMER,    TIMER_REQUEST_SET_TIMER);
00157 ACTIV_DECLARE_MESSAGE_TYPE(1,   MESSAGE_CLASS_TIMER,    TIMER_REQUEST_GET_CURRENT_TIME_OBJECT);
00158 ACTIV_DECLARE_MESSAGE_TYPE(2,   MESSAGE_CLASS_TIMER,    TIMER_REQUEST_ADJUST_SYSTEM_TIME);
00159
00160 // ---------------------------------------------------------------------------------------------------------------------------------
00161
00165 ACTIV_DECLARE_MESSAGE_TYPE(0,   MESSAGE_CLASS_TIMER,    TIMER_MESSAGE_CANCEL_TIMER);
00166 ACTIV_DECLARE_MESSAGE_TYPE(1,   MESSAGE_CLASS_TIMER,    TIMER_MESSAGE_ON_TIMER);
00167
00168 // ---------------------------------------------------------------------------------------------------------------------------------
00169
00173 ACTIV_DECLARE_MESSAGE_TYPE(0,   MESSAGE_CLASS_LOGGER,   LOGGER_MESSAGE_CLOSE_LOG_FILE);
00174 ACTIV_DECLARE_MESSAGE_TYPE(1,   MESSAGE_CLASS_LOGGER,   LOGGER_MESSAGE_LOG_MESSAGE);
00175 ACTIV_DECLARE_MESSAGE_TYPE(2,   MESSAGE_CLASS_LOGGER,   LOGGER_MESSAGE_SYSTEM_LOG_MESSAGE);
00176 ACTIV_DECLARE_MESSAGE_TYPE(3,   MESSAGE_CLASS_LOGGER,   LOGGER_MESSAGE_SET_LOG_HEADER);
00177
00178 // ---------------------------------------------------------------------------------------------------------------------------------
00179
00183 ACTIV_DECLARE_MESSAGE_TYPE(0,   MESSAGE_CLASS_LOGGER,   LOGGER_REQUEST_OPEN_LOG_FILE);
00184
00185 // ---------------------------------------------------------------------------------------------------------------------------------
00186
00190 ACTIV_DECLARE_MESSAGE_TYPE(0,   MESSAGE_CLASS_ROUTER,   ROUTER_REQUEST_USER_ASYNC_CONNECT);
00191 ACTIV_DECLARE_MESSAGE_TYPE(1,   MESSAGE_CLASS_ROUTER,   ROUTER_REQUEST_USER_ALLOCATE_CLIENT);
00192 ACTIV_DECLARE_MESSAGE_TYPE(2,   MESSAGE_CLASS_ROUTER,   ROUTER_REQUEST_USER_INITIATE_CONNECT);
00193 ACTIV_DECLARE_MESSAGE_TYPE(3,   MESSAGE_CLASS_ROUTER,   ROUTER_REQUEST_USER_INITIATE_DISCONNECT);
00194 ACTIV_DECLARE_MESSAGE_TYPE(4,   MESSAGE_CLASS_ROUTER,   ROUTER_REQUEST_USER_START_LISTEN);
00195 ACTIV_DECLARE_MESSAGE_TYPE(5,   MESSAGE_CLASS_ROUTER,   ROUTER_REQUEST_USER_ADD_DIRECTORY_WATCH);
00196
00197 ACTIV_DECLARE_MESSAGE_TYPE(7,   MESSAGE_CLASS_ROUTER,   ROUTER_REQUEST_INTERNAL_SYN);
00198 ACTIV_DECLARE_MESSAGE_TYPE(8,   MESSAGE_CLASS_ROUTER,   ROUTER_REQUEST_INTERNAL_FIN);
00199 ACTIV_DECLARE_MESSAGE_TYPE(9,   MESSAGE_CLASS_ROUTER,   ROUTER_REQUEST_USER_NOTIFY_ACCEPT_CONNECTION);
00200 ACTIV_DECLARE_MESSAGE_TYPE(10,  MESSAGE_CLASS_ROUTER,   ROUTER_REQUEST_USER_UDP_INIT);
00201 ACTIV_DECLARE_MESSAGE_TYPE(11,  MESSAGE_CLASS_ROUTER,   ROUTER_REQUEST_USER_UDP_SHUTDOWN);
00202 ACTIV_DECLARE_MESSAGE_TYPE(12,  MESSAGE_CLASS_ROUTER,   ROUTER_REQUEST_USER_GET_SOCKET_HANDLE);
00203 ACTIV_DECLARE_MESSAGE_TYPE(13,  MESSAGE_CLASS_ROUTER,   ROUTER_REQUEST_USER_UDP_CONNECT);
00204 ACTIV_DECLARE_MESSAGE_TYPE(14,  MESSAGE_CLASS_ROUTER,   ROUTER_REQUEST_USER_UDP_DISCONNECT);
00205 ACTIV_DECLARE_MESSAGE_TYPE(15,  MESSAGE_CLASS_ROUTER,   ROUTER_REQUEST_USER_UDP_MULTICAST_JOIN);
00206 ACTIV_DECLARE_MESSAGE_TYPE(16,  MESSAGE_CLASS_ROUTER,   ROUTER_REQUEST_USER_UDP_MULTICAST_LEAVE);
00207 ACTIV_DECLARE_MESSAGE_TYPE(17,  MESSAGE_CLASS_ROUTER,   ROUTER_REQUEST_USER_UDP_SET_MULTICAST_TTL);
00208 ACTIV_DECLARE_MESSAGE_TYPE(18,  MESSAGE_CLASS_ROUTER,   ROUTER_REQUEST_USER_UDP_SET_UNICAST_TTL);
00209 ACTIV_DECLARE_MESSAGE_TYPE(19,  MESSAGE_CLASS_ROUTER,   ROUTER_REQUEST_USER_UDP_SET_MULTICAST_INTERFACE);
00210 ACTIV_DECLARE_MESSAGE_TYPE(20,  MESSAGE_CLASS_ROUTER,   ROUTER_REQUEST_USER_UDP_SET_RX_BUFFER_SIZE);
00211 ACTIV_DECLARE_MESSAGE_TYPE(21,  MESSAGE_CLASS_ROUTER,   ROUTER_REQUEST_USER_UDP_SET_TX_BUFFER_SIZE);
00212 ACTIV_DECLARE_MESSAGE_TYPE(22,  MESSAGE_CLASS_ROUTER,   ROUTER_REQUEST_USER_UDP_SET_MULTICAST_LOOPBACK);
00213 ACTIV_DECLARE_MESSAGE_TYPE(23,  MESSAGE_CLASS_ROUTER,   ROUTER_REQUEST_USER_UDP_CLEAR_MULTICAST_LOOPBACK);
00214
00215 // ---------------------------------------------------------------------------------------------------------------------------------
00216
00220 ACTIV_DECLARE_MESSAGE_TYPE(0,   MESSAGE_CLASS_ROUTER,   ROUTER_MESSAGE_INTERNAL_SOCKET_CONNECT);
00221 ACTIV_DECLARE_MESSAGE_TYPE(1,   MESSAGE_CLASS_ROUTER,   ROUTER_MESSAGE_INTERNAL_SOCKET_CONNECT_FAILED);
00222 ACTIV_DECLARE_MESSAGE_TYPE(2,   MESSAGE_CLASS_ROUTER,   ROUTER_MESSAGE_INTERNAL_SOCKET_CONNECT_ABORTED);
00223 ACTIV_DECLARE_MESSAGE_TYPE(3,   MESSAGE_CLASS_ROUTER,   ROUTER_MESSAGE_INTERNAL_SOCKET_ACCEPT);
00224 ACTIV_DECLARE_MESSAGE_TYPE(4,   MESSAGE_CLASS_ROUTER,   ROUTER_MESSAGE_INTERNAL_SOCKET_ACCEPT_FAILED);
00225 ACTIV_DECLARE_MESSAGE_TYPE(5,   MESSAGE_CLASS_ROUTER,   ROUTER_MESSAGE_INTERNAL_SOCKET_ACCEPT_ABORTED);
00226 ACTIV_DECLARE_MESSAGE_TYPE(6,   MESSAGE_CLASS_ROUTER,   ROUTER_MESSAGE_INTERNAL_SOCKET_BREAK);
00227 ACTIV_DECLARE_MESSAGE_TYPE(7,   MESSAGE_CLASS_ROUTER,   ROUTER_MESSAGE_INTERNAL_SOCKET_DISCONNECT);
00228 ACTIV_DECLARE_MESSAGE_TYPE(8,   MESSAGE_CLASS_ROUTER,   ROUTER_MESSAGE_USER_INITIATE_DISCONNECT);
00229 ACTIV_DECLARE_MESSAGE_TYPE(9,   MESSAGE_CLASS_ROUTER,   ROUTER_MESSAGE_USER_BREAK_CONNECTION);
00230 ACTIV_DECLARE_MESSAGE_TYPE(10,  MESSAGE_CLASS_ROUTER,   ROUTER_MESSAGE_USER_BREAK_ACCEPTED);
00231 ACTIV_DECLARE_MESSAGE_TYPE(11,  MESSAGE_CLASS_ROUTER,   ROUTER_MESSAGE_USER_STOP_LISTEN);
00232 ACTIV_DECLARE_MESSAGE_TYPE(12,  MESSAGE_CLASS_ROUTER,   ROUTER_MESSAGE_USER_NOTIFY_CIRCUIT_UP);
00233 ACTIV_DECLARE_MESSAGE_TYPE(13,  MESSAGE_CLASS_ROUTER,   ROUTER_MESSAGE_USER_NOTIFY_CIRCUIT_DOWN);
00234 ACTIV_DECLARE_MESSAGE_TYPE(14,  MESSAGE_CLASS_ROUTER,   ROUTER_MESSAGE_USER_NOTIFY_CIRCUIT_BREAK);
00235 ACTIV_DECLARE_MESSAGE_TYPE(15,  MESSAGE_CLASS_ROUTER,   ROUTER_MESSAGE_DATA);
00236 ACTIV_DECLARE_MESSAGE_TYPE(16,  MESSAGE_CLASS_ROUTER,   ROUTER_MESSAGE_INTERNAL_DIRECTORY_WATCH_NOTIFICATION);
00237 ACTIV_DECLARE_MESSAGE_TYPE(17,  MESSAGE_CLASS_ROUTER,   ROUTER_MESSAGE_USER_SET_MAX_TX_QUEUE_SIZE);
00238 ACTIV_DECLARE_MESSAGE_TYPE(18,  MESSAGE_CLASS_ROUTER,   ROUTER_MESSAGE_USER_UDP_READ);
00239
00240 ACTIV_DECLARE_MESSAGE_TYPE(26,  MESSAGE_CLASS_ROUTER,   ROUTER_MESSAGE_USER_NOTIFY_UDP_SOCKET_ERROR);
00241 ACTIV_DECLARE_MESSAGE_TYPE(27,  MESSAGE_CLASS_ROUTER,   ROUTER_MESSAGE_USER_NOTIFY_UDP_SOCKET_SHUTDOWN);
00242
00243 ACTIV_DECLARE_MESSAGE_TYPE(30,  MESSAGE_CLASS_ROUTER,   ROUTER_MESSAGE_USER_SET_HEAP);
00244 ACTIV_DECLARE_MESSAGE_TYPE(31,  MESSAGE_CLASS_ROUTER,   ROUTER_MESSAGE_USER_NOTIFY_CIRCUIT_FAILED);
00245 ACTIV_DECLARE_MESSAGE_TYPE(32,  MESSAGE_CLASS_ROUTER,   ROUTER_MESSAGE_INTERNAL_SOCKET_LISTENER_CLOSED);
00246 ACTIV_DECLARE_MESSAGE_TYPE(33,  MESSAGE_CLASS_ROUTER,   ROUTER_MESSAGE_USER_CLEAR_SOCKET_STATS_HIGHS);
00247 ACTIV_DECLARE_MESSAGE_TYPE(34,  MESSAGE_CLASS_ROUTER,   ROUTER_MESSAGE_INTERNAL_DIRECTORY_WATCH_CLOSED);
00248 ACTIV_DECLARE_MESSAGE_TYPE(35,  MESSAGE_CLASS_ROUTER,   ROUTER_MESSAGE_USER_CANCEL_DIRECTORY_WATCH);
00249 ACTIV_DECLARE_MESSAGE_TYPE(36,  MESSAGE_CLASS_ROUTER,   ROUTER_MESSAGE_USER_NOTIFY_DIRECTORY_WATCH_EVENTS);
00250 ACTIV_DECLARE_MESSAGE_TYPE(37,  MESSAGE_CLASS_ROUTER,   ROUTER_MESSAGE_USER_ENABLE_SOCKET_STATS);
00251 ACTIV_DECLARE_MESSAGE_TYPE(38,  MESSAGE_CLASS_ROUTER,   ROUTER_MESSAGE_USER_NOTIFY_SOCKET_STATS);
00252
00253 // ---------------------------------------------------------------------------------------------------------------------------------
00254
00258 ACTIV_DECLARE_MESSAGE_TYPE(0,   MESSAGE_CLASS_UI,       UI_REQUEST_NEW_USER);
00259
00260 // ---------------------------------------------------------------------------------------------------------------------------------
00261
00265 ACTIV_DECLARE_MESSAGE_TYPE(0,   MESSAGE_CLASS_UI,       UI_MESSAGE_REGISTER_COMPONENT);
00266 ACTIV_DECLARE_MESSAGE_TYPE(1,   MESSAGE_CLASS_UI,       UI_MESSAGE_DEREGISTER_COMPONENT);
00267 ACTIV_DECLARE_MESSAGE_TYPE(2,   MESSAGE_CLASS_UI,       UI_MESSAGE_USER_INPUT);
00268 ACTIV_DECLARE_MESSAGE_TYPE(3,   MESSAGE_CLASS_UI,       UI_MESSAGE_DESTROY);
00269 ACTIV_DECLARE_MESSAGE_TYPE(4,   MESSAGE_CLASS_UI,       UI_MESSAGE_OUTPUT);
00270 ACTIV_DECLARE_MESSAGE_TYPE(5,   MESSAGE_CLASS_UI,       UI_MESSAGE_SWITCH_TO_COMPONENT);
00271 ACTIV_DECLARE_MESSAGE_TYPE(6,   MESSAGE_CLASS_UI,       UI_MESSAGE_RETURN_TO_MAIN_COMPONENT);
00272 ACTIV_DECLARE_MESSAGE_TYPE(7,   MESSAGE_CLASS_UI,       UI_MESSAGE_RESET_MENU);
00273 ACTIV_DECLARE_MESSAGE_TYPE(8,   MESSAGE_CLASS_UI,       UI_MESSAGE_LOG_OUTPUT);
00274 ACTIV_DECLARE_MESSAGE_TYPE(9,   MESSAGE_CLASS_UI,       UI_MESSAGE_SHARED_OUTPUT);
00275 ACTIV_DECLARE_MESSAGE_TYPE(10,  MESSAGE_CLASS_UI,       UI_MESSAGE_SHARED_SESSION_CLOSED);
00276 ACTIV_DECLARE_MESSAGE_TYPE(11,  MESSAGE_CLASS_UI,       UI_MESSAGE_PARTIAL_USER_INPUT);
00277 ACTIV_DECLARE_MESSAGE_TYPE(12,  MESSAGE_CLASS_UI,       UI_MESSAGE_SET_INPUT);
00278 ACTIV_DECLARE_MESSAGE_TYPE(13,  MESSAGE_CLASS_UI,       UI_MESSAGE_UNBUFFERED_OUTPUT);
00279 ACTIV_DECLARE_MESSAGE_TYPE(14,  MESSAGE_CLASS_UI,       UI_MESSAGE_CLEAR_INPUT);
00280 ACTIV_DECLARE_MESSAGE_TYPE(15,  MESSAGE_CLASS_UI,       UI_MESSAGE_USER_UPDATE);
00281 ACTIV_DECLARE_MESSAGE_TYPE(16,  MESSAGE_CLASS_UI,       UI_MESSAGE_INITIATE_TUNNEL);
00282 ACTIV_DECLARE_MESSAGE_TYPE(17,  MESSAGE_CLASS_UI,       UI_MESSAGE_CLOSE_TUNNEL);
00283
00284 // ---------------------------------------------------------------------------------------------------------------------------------
00285
00289 ACTIV_DECLARE_MESSAGE_TYPE(0,   MESSAGE_CLASS_UDP,      UDP_MESSAGE_DATA);
00290 ACTIV_DECLARE_MESSAGE_TYPE(1,   MESSAGE_CLASS_UDP,      UDP_MESSAGE_SOCKET_OPEN);
00291 ACTIV_DECLARE_MESSAGE_TYPE(2,   MESSAGE_CLASS_UDP,      UDP_MESSAGE_SOCKET_CLOSED);
00292 ACTIV_DECLARE_MESSAGE_TYPE(3,   MESSAGE_CLASS_UDP,      UDP_MESSAGE_SHUTDOWN);
00293 ACTIV_DECLARE_MESSAGE_TYPE(4,   MESSAGE_CLASS_UDP,      UDP_MESSAGE_FLUSH);
00294 ACTIV_DECLARE_MESSAGE_TYPE(5,   MESSAGE_CLASS_UDP,      UDP_MESSAGE_SINGLE_MESSAGE);
00295 ACTIV_DECLARE_MESSAGE_TYPE(6,   MESSAGE_CLASS_UDP,      UDP_MESSAGE_NON_CRITICAL_DATA);
00296
00297 } // namespace Activ
00298
00299 #endif // (!defined ACTIV_SYSTEM_MESSAGE_TYPES_H)
Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

MessageValidator.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_BASE_MESSAGE_VALIDATOR_H)
00010 #define ACTIV_BASE_MESSAGE_VALIDATOR_H
00011
00012 #include "ActivMiddleware/ActivBase/External.h"
00013 #include "ActivMiddleware/ActivBase/MessageHandler.h"
00014 #include "ActivMiddleware/Misc/MemoryHelper.h"
00015
00016 #include <float.h>
00017 #include <vector>
00018 #include <string>
00019 #include <limits>
00020
00021 namespace Activ
00022 {
00023
00027 class MessageValidator : public MessageHandler
00028 {
00029 public:
00037     ACTIV_BASE_INLINE_API MessageValidator(const void *pMessage = 0, const size_t length = 0, const MessageVersion messageVersion = MESSAGE_VERSION_UNDEFINED);
00038
00046     ACTIV_BASE_INLINE_API void Initialize(const void *pMessage, const size_t length, const MessageVersion messageVersion = MESSAGE_VERSION_UNDEFINED);
00047
00053     ACTIV_BASE_INLINE_API void Reset(const MessageVersion messageVersion = MESSAGE_VERSION_UNDEFINED);
00054
00060     ACTIV_BASE_INLINE_API const void *GetMessage() const;
00061
00067     ACTIV_BASE_INLINE_API size_t GetLength() const;
00068
00074     ACTIV_BASE_INLINE_API size_t GetOffset() const;
00075
00084     ACTIV_BASE_INLINE_API StatusCode SetOffset(const size_t offset);
00085
00091     ACTIV_BASE_INLINE_API bool IsEndOfMessage() const;
00092
00102     ACTIV_BASE_EXPORTED_API StatusCode ValidateBytes(const size_t length, const void **ppData = 0);
00103
00114     ACTIV_BASE_EXPORTED_API StatusCode ValidateBytes(const size_t length, const void * const pComperand, const void **ppData = 0);
00115
00127     ACTIV_BASE_EXPORTED_API StatusCode ValidateBytes(const size_t length, const byte_t value, const void **ppData = 0);
00128
00141     ACTIV_BASE_EXPORTED_API StatusCode ValidateBytes(const size_t length, const byte_t lower, const byte_t upper, const void **ppData = 0);
00142
00154     ACTIV_BASE_EXPORTED_API StatusCode ValidateBytes(const size_t length, const std::vector<byte_t> &set, const void **ppData = 0);
00155
00167     ACTIV_BASE_EXPORTED_API StatusCode ValidateBytes(const size_t length, const std::vector<std::string> &set, const void **ppData = 0);
00168
00178     ACTIV_BASE_EXPORTED_API StatusCode ValidateBytesCopy(const size_t length, void *pCopy);
00179
00192     ACTIV_BASE_EXPORTED_API StatusCode ValidateBytesCopy(const size_t length, const byte_t lower, const byte_t upper, void *pCopy);
00193
00205     ACTIV_BASE_EXPORTED_API StatusCode ValidateBytesCopy(const size_t length, const std::vector<byte_t> &set, void *pCopy);
00206
00218     ACTIV_BASE_EXPORTED_API StatusCode ValidateBytesCopy(const size_t length, const std::vector<std::string> &set, void *pCopy);
00219
00232     template<size_t SIZE, Endian ENDIAN, typename T>
00233     StatusCode ValidateBinaryIntegral(T &value);
00234
00250     template<size_t SIZE, Endian ENDIAN, typename T, T LOWER, T UPPER>
00251     StatusCode ValidateBinaryIntegralRange(T &value);
00252
00268     template<size_t SIZE, Endian ENDIAN, typename T>
00269     StatusCode ValidateBinaryIntegral(const T lower, const T upper, T &value);
00270
00281     ACTIV_BASE_EXPORTED_API StatusCode ValidateAsciiHexadecimalIntegral(const size_t size, const Endian endian, const void **ppData = 0);
00282
00294     template <typename T>
00295     StatusCode ValidateAsciiHexadecimalIntegral(const size_t size, const Endian endian, T *pValue, const void **ppData = 0);
00296
00310     ACTIV_BASE_INLINE_API StatusCode ValidateAsciiHexadecimalIntegral(const size_t size, const uint64_t lower, const uint64_t upper, const Endian endian, const void **ppData = 0);
00311
00326     template <typename T>
00327     StatusCode ValidateAsciiHexadecimalIntegral(const size_t size, const uint64_t lower, const uint64_t upper, const Endian endian, T *pValue, const void **ppData = 0);
00328
00341     ACTIV_BASE_INLINE_API StatusCode ValidateAsciiHexadecimalIntegral(const size_t size, const std::vector<uint64_t> &set, const Endian endian, const void **ppData = 0);
00342
00356     template <typename T>
00357     StatusCode ValidateAsciiHexadecimalIntegral(const size_t size, const std::vector<uint64_t> &set, const Endian endian, T *pValue, const void **ppData = 0);
00358
00369     ACTIV_BASE_EXPORTED_API StatusCode ValidateAsciiHexadecimalIntegralCopy(const size_t size, const Endian endian, void *pCopy);
00370
00382     template <typename T>
00383     StatusCode ValidateAsciiHexadecimalIntegralCopy(const size_t size, const Endian endian, T *pValue, void *pCopy);
00384
00398     ACTIV_BASE_INLINE_API StatusCode ValidateAsciiHexadecimalIntegralCopy(const size_t size, const uint64_t lower, const uint64_t upper, const Endian endian, void *pCopy);
00399
00414     template <typename T>
00415     StatusCode ValidateAsciiHexadecimalIntegralCopy(const size_t size, const uint64_t lower, const uint64_t upper, const Endian endian, T *pValue, void *pCopy);
00416
00429     ACTIV_BASE_INLINE_API StatusCode ValidateAsciiHexadecimalIntegralCopy(const size_t size, const std::vector<uint64_t> &set, const Endian endian, void *pCopy);
00430
00444     template <typename T>
00445     StatusCode ValidateAsciiHexadecimalIntegralCopy(const size_t size, const std::vector<uint64_t> &set, const Endian endian, T *pValue, void *pCopy);
00446
00457     ACTIV_BASE_EXPORTED_API StatusCode ValidateSignedAsciiIntegral(const size_t length, const void **ppData = 0);
00458
00471     template <typename T>
00472     StatusCode ValidateSignedAsciiIntegral(const size_t length, T *pValue, const void **ppData = 0);
00473
00487     ACTIV_BASE_EXPORTED_API StatusCode ValidateSignedAsciiIntegral(const size_t length, const int64_t lower, const int64_t upper, const void **ppData = 0);
00488
00503     template <typename T>
00504     StatusCode ValidateSignedAsciiIntegral(const size_t length, const int64_t lower, const int64_t upper, T *pValue, const void **ppData = 0);
00505
00518     ACTIV_BASE_INLINE_API StatusCode ValidateSignedAsciiIntegral(const size_t length, const std::vector<int64_t> &set, const void **ppData = 0);
00519
00533     template <typename T>
00534     StatusCode ValidateSignedAsciiIntegral(const size_t length, const std::vector<int64_t> &set, T *pValue, const void **ppData = 0);
00535
00548     ACTIV_BASE_EXPORTED_API StatusCode ValidateSignedAsciiIntegralCopy(const size_t length, void *pCopy);
00549
00562     template <typename T>
00563     StatusCode ValidateSignedAsciiIntegralCopy(const size_t length, T *pValue, void *pCopy);
00564
00578     ACTIV_BASE_EXPORTED_API StatusCode ValidateSignedAsciiIntegralCopy(const size_t length, const int64_t lower, const int64_t upper, void *pCopy);
00579
00594     template <typename T>
00595     StatusCode ValidateSignedAsciiIntegralCopy(const size_t length, const int64_t lower, const int64_t upper, T *pValue, void *pCopy);
00596
00609     ACTIV_BASE_EXPORTED_API StatusCode ValidateSignedAsciiIntegralCopy(const size_t length, const std::vector<int64_t> &set, void *pCopy);
00610
00624     template <typename T>
00625     StatusCode ValidateSignedAsciiIntegralCopy(const size_t length, const std::vector<int64_t> &set, T *pValue, void *pCopy);
00626
00638     ACTIV_BASE_EXPORTED_API StatusCode ValidateSignedAsciiReal(const size_t length, const void **ppData = 0);
00639
00652     template <typename T>
00653     StatusCode ValidateSignedAsciiReal(const size_t length, T *pValue, const void **ppData = 0);
00654
00668     ACTIV_BASE_EXPORTED_API StatusCode ValidateSignedAsciiReal(const size_t length, int64_t *pNumerator, uint64_t *pDivisor, const void **ppData = 0);
00669
00683     ACTIV_BASE_INLINE_API StatusCode ValidateSignedAsciiReal(const size_t length, const long double lower, const long double upper, const void **ppData = 0);
00684
00699     template <typename T>
00700     StatusCode ValidateSignedAsciiReal(const size_t length, const long double lower, const long double upper, T *pValue, const void **ppData = 0);
00701
00717     ACTIV_BASE_EXPORTED_API StatusCode ValidateSignedAsciiReal(const size_t length, const long double lower, const long double upper, int64_t *pNumerator, uint64_t *pDivisor, const void **ppData = 0);
00718
00731     ACTIV_BASE_INLINE_API StatusCode ValidateSignedAsciiReal(const size_t length, const std::vector<long double> &set, const void **ppData = 0);
00732
00746     template <typename T>
00747     StatusCode ValidateSignedAsciiReal(const size_t length, const std::vector<long double> &set, T *pValue, const void **ppData = 0);
00748
00763     ACTIV_BASE_EXPORTED_API StatusCode ValidateSignedAsciiReal(const size_t length, const std::vector<long double> &set, int64_t *pNumerator, uint64_t *pDivisor, const void **ppData = 0);
00764
00776     ACTIV_BASE_EXPORTED_API StatusCode ValidateSignedAsciiRealCopy(const size_t length, void *pCopy);
00777
00790     template <typename T>
00791     StatusCode ValidateSignedAsciiRealCopy(const size_t length, T *pValue, void *pCopy);
00792
00806     ACTIV_BASE_EXPORTED_API StatusCode ValidateSignedAsciiRealCopy(const size_t length, int64_t *pNumerator, uint64_t *pDivisor, void *pCopy);
00807
00821     ACTIV_BASE_INLINE_API StatusCode ValidateSignedAsciiRealCopy(const size_t length, const long double lower, const long double upper, void *pCopy);
00822
00837     template <typename T>
00838     StatusCode ValidateSignedAsciiRealCopy(const size_t length, const long double lower, const long double upper, T *pValue, void *pCopy);
00839
00855     ACTIV_BASE_EXPORTED_API StatusCode ValidateSignedAsciiRealCopy(const size_t length, const long double lower, const long double upper, int64_t *pNumerator, uint64_t *pDivisor, void *pCopy);
00856
00869     ACTIV_BASE_INLINE_API StatusCode ValidateSignedAsciiRealCopy(const size_t length, const std::vector<long double> &set, void *pCopy);
00870
00884     template <typename T>
00885     StatusCode ValidateSignedAsciiRealCopy(const size_t length, const std::vector<long double> &set, T *pValue, void *pCopy);
00886
00901     ACTIV_BASE_EXPORTED_API StatusCode ValidateSignedAsciiRealCopy(const size_t length, const std::vector<long double> &set, int64_t *pNumerator, uint64_t *pDivisor, void *pCopy);
00902
00913     ACTIV_BASE_EXPORTED_API StatusCode ValidateSignedBinaryIntegral(const size_t size, const Endian endian, const void **ppData = 0);
00914
00926     template <typename T>
00927     StatusCode ValidateSignedBinaryIntegral(const size_t size, const Endian endian, T *pValue, const void **ppData = 0);
00928
00942     ACTIV_BASE_INLINE_API StatusCode ValidateSignedBinaryIntegral(const size_t size, const int64_t lower, const int64_t upper, const Endian endian, const void **ppData = 0);
00943
00958     template <typename T>
00959     StatusCode ValidateSignedBinaryIntegral(const size_t size, const int64_t lower, const int64_t upper, const Endian endian, T *pValue, const void **ppData = 0);
00960
00973     ACTIV_BASE_INLINE_API StatusCode ValidateSignedBinaryIntegral(const size_t size, const std::vector<int64_t> &set, const Endian endian, const void **ppData = 0);
00974
00988     template <typename T>
00989     StatusCode ValidateSignedBinaryIntegral(const size_t size, const std::vector<int64_t> &set, const Endian endian, T *pValue, const void **ppData = 0);
00990
01001     ACTIV_BASE_EXPORTED_API StatusCode ValidateSignedBinaryIntegralCopy(const size_t size, const Endian endian, void *pCopy);
01002
01014     template <typename T>
01015     StatusCode ValidateSignedBinaryIntegralCopy(const size_t size, const Endian endian, T *pValue, void *pCopy);
01016
01030     ACTIV_BASE_INLINE_API StatusCode ValidateSignedBinaryIntegralCopy(const size_t size, const int64_t lower, const int64_t upper, const Endian endian, void *pCopy);
01031
01046     template <typename T>
01047     StatusCode ValidateSignedBinaryIntegralCopy(const size_t size, const int64_t lower, const int64_t upper, const Endian endian, T *pValue, void *pCopy);
01048
01061     ACTIV_BASE_INLINE_API StatusCode ValidateSignedBinaryIntegralCopy(const size_t size, const std::vector<int64_t> &set, const Endian endian, void *pCopy);
01062
01076     template <typename T>
01077     StatusCode ValidateSignedBinaryIntegralCopy(const size_t size, const std::vector<int64_t> &set, const Endian endian, T *pValue, void *pCopy);
01078
01088     ACTIV_BASE_INLINE_API StatusCode ValidateString(const void **ppData = 0, size_t *pDataLength = 0);
01089
01100     ACTIV_BASE_EXPORTED_API StatusCode ValidateString(std::string *pString, const void **ppData = 0, size_t *pDataLength = 0);
01101
01114     ACTIV_BASE_INLINE_API StatusCode ValidateString(const byte_t lower, const byte_t upper, const void **ppData = 0, size_t *pDataLength = 0);
01115
01129     ACTIV_BASE_EXPORTED_API StatusCode ValidateString(const byte_t lower, const byte_t upper, std::string *pString, const void **ppData = 0, size_t *pDataLength = 0);
01130
01142     ACTIV_BASE_EXPORTED_API StatusCode ValidateString(const std::vector<byte_t> &set, const void **ppData = 0, size_t *pDataLength = 0);
01143
01156     ACTIV_BASE_EXPORTED_API StatusCode ValidateString(const std::vector<byte_t> &set, std::string *pString, const void **ppData = 0, size_t *pDataLength = 0);
01157
01169     ACTIV_BASE_INLINE_API StatusCode ValidateString(const std::vector<std::string> &set, const void **ppData = 0, size_t *pDataLength = 0);
01170
01183     ACTIV_BASE_EXPORTED_API StatusCode ValidateString(const std::vector<std::string> &set, std::string *pString, const void **ppData = 0, size_t *pDataLength = 0);
01184
01195     ACTIV_BASE_INLINE_API StatusCode ValidateStringCopy(void *pCopy, const size_t copySize, size_t *pCopyLength);
01196
01208     ACTIV_BASE_EXPORTED_API StatusCode ValidateStringCopy(std::string *pString, void *pCopy, const size_t copySize, size_t *pCopyLength);
01209
01223     ACTIV_BASE_INLINE_API StatusCode ValidateStringCopy(const byte_t lower, const byte_t upper, void *pCopy, const size_t copySize, size_t *pCopyLength);
01224
01239     ACTIV_BASE_EXPORTED_API StatusCode ValidateStringCopy(const byte_t lower, const byte_t upper, std::string *pString, void *pCopy, const size_t copySize, size_t *pCopyLength);
01240
01253     ACTIV_BASE_INLINE_API StatusCode ValidateStringCopy(const std::vector<byte_t> &set, void *pCopy, const size_t copySize, size_t *pCopyLength);
01254
01268     ACTIV_BASE_EXPORTED_API StatusCode ValidateStringCopy(const std::vector<byte_t> &set, std::string *pString, void *pCopy, const size_t copySize, size_t *pCopyLength);
01269
01282     ACTIV_BASE_INLINE_API StatusCode ValidateStringCopy(const std::vector<std::string> &set, void *pCopy, const size_t copySize, size_t *pCopyLength);
01283
01297     ACTIV_BASE_EXPORTED_API StatusCode ValidateStringCopy(const std::vector<std::string> &set, std::string *pString, void *pCopy, const size_t copySize, size_t *pCopyLength);
01298
01309     ACTIV_BASE_EXPORTED_API StatusCode ValidateUnsignedAsciiIntegral(const size_t length, const void **ppData = 0);
01310
01323     template <typename T>
01324     StatusCode ValidateUnsignedAsciiIntegral(const size_t length, T *pValue, const void **ppData = 0);
01325
01339     ACTIV_BASE_INLINE_API StatusCode ValidateUnsignedAsciiIntegral(const size_t length, const uint64_t lower, const uint64_t upper, const void **ppData = 0);
01340
01355     template <typename T>
01356     StatusCode ValidateUnsignedAsciiIntegral(const size_t length, const uint64_t lower, const uint64_t upper, T *pValue, const void **ppData = 0);
01357
01370     ACTIV_BASE_INLINE_API StatusCode ValidateUnsignedAsciiIntegral(const size_t length, const std::vector<uint64_t> &set, const void **ppData = 0);
01371
01385     template <typename T>
01386     StatusCode ValidateUnsignedAsciiIntegral(const size_t length, const std::vector<uint64_t> &set, T *pValue, const void **ppData = 0);
01387
01400     ACTIV_BASE_EXPORTED_API StatusCode ValidateUnsignedAsciiIntegralCopy(const size_t length, void *pCopy);
01401
01414     template <typename T>
01415     StatusCode ValidateUnsignedAsciiIntegralCopy(const size_t length, T *pValue, void *pCopy);
01416
01430     ACTIV_BASE_EXPORTED_API StatusCode ValidateUnsignedAsciiIntegralCopy(const size_t length, const uint64_t lower, const uint64_t upper, void *pCopy);
01431
01446     template <typename T>
01447     StatusCode ValidateUnsignedAsciiIntegralCopy(const size_t length, const uint64_t lower, const uint64_t upper, T *pValue, void *pCopy);
01448
01461     ACTIV_BASE_EXPORTED_API StatusCode ValidateUnsignedAsciiIntegralCopy(const size_t length, const std::vector<uint64_t> &set, void *pCopy);
01462
01476     template <typename T>
01477     StatusCode ValidateUnsignedAsciiIntegralCopy(const size_t length, const std::vector<uint64_t> &set, T *pValue, void *pCopy);
01478
01490     ACTIV_BASE_EXPORTED_API StatusCode ValidateUnsignedAsciiReal(const size_t length, const void **ppData = 0);
01491
01504     template <typename T>
01505     StatusCode ValidateUnsignedAsciiReal(const size_t length, T *pValue, const void **ppData = 0);
01506
01520     ACTIV_BASE_EXPORTED_API StatusCode ValidateUnsignedAsciiReal(const size_t length, uint64_t *pNumerator, uint64_t *pDivisor, const void **ppData = 0);
01521
01535     ACTIV_BASE_INLINE_API StatusCode ValidateUnsignedAsciiReal(const size_t length, const long double lower, const long double upper, const void **ppData = 0);
01536
01551     template <typename T>
01552     StatusCode ValidateUnsignedAsciiReal(const size_t length, const long double lower, const long double upper, T *pValue, const void **ppData = 0);
01553
01569     ACTIV_BASE_EXPORTED_API StatusCode ValidateUnsignedAsciiReal(const size_t length, const long double lower, const long double upper, uint64_t *pNumerator, uint64_t *pDivisor, const void **ppData = 0);
01570
01583     ACTIV_BASE_INLINE_API StatusCode ValidateUnsignedAsciiReal(const size_t length, const std::vector<long double> &set, const void **ppData = 0);
01584
01598     template <typename T>
01599     StatusCode ValidateUnsignedAsciiReal(const size_t length, const std::vector<long double> &set, T *pValue, const void **ppData = 0);
01600
01615     ACTIV_BASE_EXPORTED_API StatusCode ValidateUnsignedAsciiReal(const size_t length, const std::vector<long double> &set, uint64_t *pNumerator, uint64_t *pDivisor, const void **ppData = 0);
01616
01628     ACTIV_BASE_EXPORTED_API StatusCode ValidateUnsignedAsciiRealCopy(const size_t length, void *pCopy);
01629
01642     template <typename T>
01643     StatusCode ValidateUnsignedAsciiRealCopy(const size_t length, T *pValue, void *pCopy);
01644
01658     ACTIV_BASE_EXPORTED_API StatusCode ValidateUnsignedAsciiRealCopy(const size_t length, uint64_t *pNumerator, uint64_t *pDivisor, void *pCopy);
01659
01673     ACTIV_BASE_INLINE_API StatusCode ValidateUnsignedAsciiRealCopy(const size_t length, const long double lower, const long double upper, void *pCopy);
01674
01689     template <typename T>
01690     StatusCode ValidateUnsignedAsciiRealCopy(const size_t length, const long double lower, const long double upper, T *pValue, void *pCopy);
01691
01707     ACTIV_BASE_EXPORTED_API StatusCode ValidateUnsignedAsciiRealCopy(const size_t length, const long double lower, const long double upper, uint64_t *pNumerator, uint64_t *pDivisor, void *pCopy);
01708
01721     ACTIV_BASE_INLINE_API StatusCode ValidateUnsignedAsciiRealCopy(const size_t length, const std::vector<long double> &set, void *pCopy);
01722
01736     template <typename T>
01737     StatusCode ValidateUnsignedAsciiRealCopy(const size_t length, const std::vector<long double> &set, T *pValue, void *pCopy);
01738
01753     ACTIV_BASE_EXPORTED_API StatusCode ValidateUnsignedAsciiRealCopy(const size_t length, const std::vector<long double> &set, uint64_t *pNumerator, uint64_t *pDivisor, void *pCopy);
01754
01765     ACTIV_BASE_EXPORTED_API StatusCode ValidateUnsignedBinaryIntegral(const size_t size, const Endian endian, const void **ppData = 0);
01766
01778     template <typename T>
01779     StatusCode ValidateUnsignedBinaryIntegral(const size_t size, const Endian endian, T *pValue, const void **ppData = 0);
01780
01794     ACTIV_BASE_INLINE_API StatusCode ValidateUnsignedBinaryIntegral(const size_t size, const uint64_t lower, const uint64_t upper, const Endian endian, const void **ppData = 0);
01795
01810     template <typename T>
01811     StatusCode ValidateUnsignedBinaryIntegral(const size_t size, const uint64_t lower, const uint64_t upper, const Endian endian, T *pValue, const void **ppData = 0);
01812
01825     ACTIV_BASE_INLINE_API StatusCode ValidateUnsignedBinaryIntegral(const size_t size, const std::vector<uint64_t> &set, const Endian endian, const void **ppData = 0);
01826
01840     template <typename T>
01841     StatusCode ValidateUnsignedBinaryIntegral(const size_t size, const std::vector<uint64_t> &set, const Endian endian, T *pValue, const void **ppData = 0);
01842
01853     ACTIV_BASE_EXPORTED_API StatusCode ValidateUnsignedBinaryIntegralCopy(const size_t size, const Endian endian, void *pCopy);
01854
01866     template <typename T>
01867     StatusCode ValidateUnsignedBinaryIntegralCopy(const size_t size, const Endian endian, T *pValue, void *pCopy);
01868
01882     ACTIV_BASE_INLINE_API StatusCode ValidateUnsignedBinaryIntegralCopy(const size_t size, const uint64_t lower, const uint64_t upper, const Endian endian, void *pCopy);
01883
01898     template <typename T>
01899     StatusCode ValidateUnsignedBinaryIntegralCopy(const size_t size, const uint64_t lower, const uint64_t upper, const Endian endian, T *pValue, void *pCopy);
01900
01913     ACTIV_BASE_INLINE_API StatusCode ValidateUnsignedBinaryIntegralCopy(const size_t size, const std::vector<uint64_t> &set, const Endian endian, void *pCopy);
01914
01928     template <typename T>
01929     StatusCode ValidateUnsignedBinaryIntegralCopy(const size_t size, const std::vector<uint64_t> &set, const Endian endian, T *pValue, void *pCopy);
01930
01940     ACTIV_BASE_INLINE_API StatusCode ValidateBoolean(bool *pBoolean);
01941
01952     ACTIV_BASE_INLINE_API StatusCode Get(const size_t offset, const void *&pData, const size_t length) const;
01953
01966     template <typename T> static StatusCode CopyAsciiHexadecimalIntegralToUnsignedBinaryIntegral(T &to, const void * const pData, size_t size, const Endian endian);
01967
01979     template <typename T> static StatusCode CopySignedAsciiIntegralToSignedBinaryIntegral(T &to, const void * const pData, size_t length);
01980
01992     template <typename T> static StatusCode CopySignedAsciiRealToBinaryReal(T &to, const void * const pData, size_t length);
01993
02006     ACTIV_BASE_EXPORTED_API static StatusCode CopySignedAsciiRealToNumeratorAndDivisor(int64_t &numerator, uint64_t &divisor, const void * const pData, const size_t length);
02007
02020     template <typename T> static StatusCode CopySignedBinaryIntegralToSignedBinaryIntegral(T &to, const void * const pData, size_t size, const Endian endian);
02021
02033     template <typename T> static StatusCode CopyUnsignedAsciiIntegralToUnsignedBinaryIntegral(T &to, const void * const pData, size_t length);
02034
02046     template <typename T> static StatusCode CopyUnsignedAsciiRealToBinaryReal(T &to, const void * const pData, size_t length);
02047
02060     ACTIV_BASE_EXPORTED_API static StatusCode CopyUnsignedAsciiRealToNumeratorAndDivisor(uint64_t &numerator, uint64_t &divisor, const void * const pData, const size_t length);
02061
02074     template <typename T> static StatusCode CopyUnsignedBinaryIntegralToUnsignedBinaryIntegral(T &to, const void * const pData, size_t size, const Endian endian);
02075
02076 private:
02085     template<typename T> static T GetValueFromUnalignedPointerInEndian(const void * const pData, const Endian endian);
02086
02098     template <bool SIZE_MATCH, bool IS_SIGNED, size_t SIZE, Endian ENDIAN, typename T>
02099     class CopyBinaryIntegralToBinaryIntegralT
02100     {
02101     public:
02102         StatusCode operator()(const void * const pData, T &value) const;
02103     };
02104
02105     template <size_t SIZE, Endian ENDIAN, typename T>
02106     class CopyBinaryIntegralToBinaryIntegralT<false, true, SIZE, ENDIAN, T>
02107     {
02108     public:
02109         StatusCode operator()(const void * const pData, T &value) const;
02110     };
02111
02112     template <size_t SIZE, Endian ENDIAN, typename T>
02113     class CopyBinaryIntegralToBinaryIntegralT<false, false, SIZE, ENDIAN, T>
02114     {
02115     public:
02116         StatusCode operator()(const void * const pData, T &value) const;
02117     };
02118
02119     template <bool IS_SIGNED, size_t SIZE, typename T>
02120     class CopyBinaryIntegralToBinaryIntegralT<true, IS_SIGNED, SIZE, ENDIAN_LOCAL, T>
02121     {
02122     public:
02123         StatusCode operator()(const void * const pData, T &value) const;
02124     };
02125
02126     template <bool IS_SIGNED, size_t SIZE, typename T>
02127     class CopyBinaryIntegralToBinaryIntegralT<true, IS_SIGNED, SIZE, ENDIAN_ALIEN, T>
02128     {
02129     public:
02130         StatusCode operator()(const void * const pData, T &value) const;
02131     };
02132
02133     template <typename T> static StatusCode CopySignedBinaryIntegralToSignedBinaryIntegralInternal(T &to, const void * const pData, size_t size, const Endian endian);
02134     template <typename T> static StatusCode CopyUnsignedBinaryIntegralToUnsignedBinaryIntegralInternal(T &to, const void * const pData, size_t size, const Endian endian);
02135
02136     template <typename T> ACTIV_TEMPLATE_API(ACTIV_BASE_EXPORTED_API) StatusCode ValidateAsciiHexadecimalIntegralT(const size_t size, const Endian endian, T *pValue, const void **ppData);
02137     template <typename T> ACTIV_TEMPLATE_API(ACTIV_BASE_EXPORTED_API) StatusCode ValidateAsciiHexadecimalIntegralT(const size_t size, const uint64_t lower, const uint64_t upper, const Endian endian, T *pValue, const void **ppData);
02138     template <typename T> ACTIV_TEMPLATE_API(ACTIV_BASE_EXPORTED_API) StatusCode ValidateAsciiHexadecimalIntegralT(const size_t size, const std::vector<uint64_t> &set, const Endian endian, T *pValue, const void **ppData = 0);
02139
02140     template <typename T> ACTIV_TEMPLATE_API(ACTIV_BASE_EXPORTED_API) StatusCode ValidateAsciiHexadecimalIntegralCopyT(const size_t size, const Endian endian, T *pValue, void *pCopy);
02141     template <typename T> ACTIV_TEMPLATE_API(ACTIV_BASE_EXPORTED_API) StatusCode ValidateAsciiHexadecimalIntegralCopyT(const size_t size, const uint64_t lower, const uint64_t upper, const Endian endian, T *pValue, void *pCopy);
02142     template <typename T> ACTIV_TEMPLATE_API(ACTIV_BASE_EXPORTED_API) StatusCode ValidateAsciiHexadecimalIntegralCopyT(const size_t size, const std::vector<uint64_t> &set, const Endian endian, T *pValue, void *pCopy);
02143
02144     template <typename T> ACTIV_TEMPLATE_API(ACTIV_BASE_EXPORTED_API) StatusCode ValidateSignedAsciiIntegralT(const size_t length, T *pValue, const void **ppData);
02145     template <typename T> ACTIV_TEMPLATE_API(ACTIV_BASE_EXPORTED_API) StatusCode ValidateSignedAsciiIntegralT(const size_t length, const int64_t lower, const int64_t upper, T *pValue, const void **ppData);
02146     template <typename T> ACTIV_TEMPLATE_API(ACTIV_BASE_EXPORTED_API) StatusCode ValidateSignedAsciiIntegralT(const size_t length, const std::vector<int64_t> &set, T *pValue, const void **ppData);
02147
02148     template <typename T> ACTIV_TEMPLATE_API(ACTIV_BASE_EXPORTED_API) StatusCode ValidateSignedAsciiIntegralCopyT(const size_t length, T *pValue, void *pCopy);
02149     template <typename T> ACTIV_TEMPLATE_API(ACTIV_BASE_EXPORTED_API) StatusCode ValidateSignedAsciiIntegralCopyT(const size_t length, const int64_t lower, const int64_t upper, T *pValue, void *pCopy);
02150     template <typename T> ACTIV_TEMPLATE_API(ACTIV_BASE_EXPORTED_API) StatusCode ValidateSignedAsciiIntegralCopyT(const size_t length, const std::vector<int64_t> &set, T *pValue, void *pCopy);
02151
02152     template <typename T> ACTIV_TEMPLATE_API(ACTIV_BASE_EXPORTED_API) StatusCode ValidateSignedAsciiRealT(const size_t length, T *pValue, const void **ppData);
02153     template <typename T> ACTIV_TEMPLATE_API(ACTIV_BASE_EXPORTED_API) StatusCode ValidateSignedAsciiRealT(const size_t length, const long double lower, const long double upper, T *pValue, const void **ppData);
02154     template <typename T> ACTIV_TEMPLATE_API(ACTIV_BASE_EXPORTED_API) StatusCode ValidateSignedAsciiRealT(const size_t length, const std::vector<long double> &set, T *pValue, const void **ppData);
02155
02156     template <typename T> ACTIV_TEMPLATE_API(ACTIV_BASE_EXPORTED_API) StatusCode ValidateSignedAsciiRealCopyT(const size_t length, T *pValue, void *pCopy);
02157     template <typename T> ACTIV_TEMPLATE_API(ACTIV_BASE_EXPORTED_API) StatusCode ValidateSignedAsciiRealCopyT(const size_t length, const long double lower, const long double upper, T *pValue, void *pCopy);
02158     template <typename T> ACTIV_TEMPLATE_API(ACTIV_BASE_EXPORTED_API) StatusCode ValidateSignedAsciiRealCopyT(const size_t length, const std::vector<long double> &set, T *pValue, void *pCopy);
02159
02160     template <typename T> ACTIV_TEMPLATE_API(ACTIV_BASE_EXPORTED_API) StatusCode ValidateSignedBinaryIntegralT(const size_t size, const Endian endian, T *pValue, const void **ppData);
02161     template <typename T> ACTIV_TEMPLATE_API(ACTIV_BASE_EXPORTED_API) StatusCode ValidateSignedBinaryIntegralT(const size_t size, const int64_t lower, const int64_t upper, const Endian endian, T *pValue, const void **ppData);
02162     template <typename T> ACTIV_TEMPLATE_API(ACTIV_BASE_EXPORTED_API) StatusCode ValidateSignedBinaryIntegralT(const size_t size, const std::vector<int64_t> &set, const Endian endian, T *pValue, const void **ppData);
02163
02164     template <typename T> ACTIV_TEMPLATE_API(ACTIV_BASE_EXPORTED_API) StatusCode ValidateSignedBinaryIntegralCopyT(const size_t size, const Endian endian, T *pValue, void *pCopy);
02165     template <typename T> ACTIV_TEMPLATE_API(ACTIV_BASE_EXPORTED_API) StatusCode ValidateSignedBinaryIntegralCopyT(const size_t size, const int64_t lower, const int64_t upper, const Endian endian, T *pValue, void *pCopy);
02166     template <typename T> ACTIV_TEMPLATE_API(ACTIV_BASE_EXPORTED_API) StatusCode ValidateSignedBinaryIntegralCopyT(const size_t size, const std::vector<int64_t> &set, const Endian endian, T *pValue, void *pCopy);
02167
02168     template <typename T> ACTIV_TEMPLATE_API(ACTIV_BASE_EXPORTED_API) StatusCode ValidateUnsignedAsciiIntegralT(const size_t length, T *pValue, const void **ppData);
02169     template <typename T> ACTIV_TEMPLATE_API(ACTIV_BASE_EXPORTED_API) StatusCode ValidateUnsignedAsciiIntegralT(const size_t length, const uint64_t lower, const uint64_t upper, T *pValue, const void **ppData);
02170     template <typename T> ACTIV_TEMPLATE_API(ACTIV_BASE_EXPORTED_API) StatusCode ValidateUnsignedAsciiIntegralT(const size_t length, const std::vector<uint64_t> &set, T *pValue, const void **ppData);
02171
02172     template <typename T> ACTIV_TEMPLATE_API(ACTIV_BASE_EXPORTED_API) StatusCode ValidateUnsignedAsciiIntegralCopyT(const size_t length, T *pValue, void *pCopy);
02173     template <typename T> ACTIV_TEMPLATE_API(ACTIV_BASE_EXPORTED_API) StatusCode ValidateUnsignedAsciiIntegralCopyT(const size_t length, const uint64_t lower, const uint64_t upper, T *pValue, void *pCopy);
02174     template <typename T> ACTIV_TEMPLATE_API(ACTIV_BASE_EXPORTED_API) StatusCode ValidateUnsignedAsciiIntegralCopyT(const size_t length, const std::vector<uint64_t> &set, T *pValue, void *pCopy);
02175
02176     template <typename T> ACTIV_TEMPLATE_API(ACTIV_BASE_EXPORTED_API) StatusCode ValidateUnsignedAsciiRealT(const size_t length, T *pValue, const void **ppData);
02177     template <typename T> ACTIV_TEMPLATE_API(ACTIV_BASE_EXPORTED_API) StatusCode ValidateUnsignedAsciiRealT(const size_t length, const long double lower, const long double upper, T *pValue, const void **ppData);
02178     template <typename T> ACTIV_TEMPLATE_API(ACTIV_BASE_EXPORTED_API) StatusCode ValidateUnsignedAsciiRealT(const size_t length, const std::vector<long double> &set, T *pValue, const void **ppData);
02179
02180     template <typename T> ACTIV_TEMPLATE_API(ACTIV_BASE_EXPORTED_API) StatusCode ValidateUnsignedAsciiRealCopyT(const size_t length, T *pValue, void *pCopy);
02181     template <typename T> ACTIV_TEMPLATE_API(ACTIV_BASE_EXPORTED_API) StatusCode ValidateUnsignedAsciiRealCopyT(const size_t length, const long double lower, const long double upper, T *pValue, void *pCopy);
02182     template <typename T> ACTIV_TEMPLATE_API(ACTIV_BASE_EXPORTED_API) StatusCode ValidateUnsignedAsciiRealCopyT(const size_t length, const std::vector<long double> &set, T *pValue, void *pCopy);
02183
02184     template <typename T> ACTIV_TEMPLATE_API(ACTIV_BASE_EXPORTED_API) StatusCode ValidateUnsignedBinaryIntegralT(const size_t size, const Endian endian, T *pValue, const void **ppData);
02185     template <typename T> ACTIV_TEMPLATE_API(ACTIV_BASE_EXPORTED_API) StatusCode ValidateUnsignedBinaryIntegralT(const size_t size, const uint64_t lower, const uint64_t upper, const Endian endian, T *pValue, const void **ppData);
02186     template <typename T> ACTIV_TEMPLATE_API(ACTIV_BASE_EXPORTED_API) StatusCode ValidateUnsignedBinaryIntegralT(const size_t size, const std::vector<uint64_t> &set, const Endian endian, T *pValue, const void **ppData);
02187
02188     template <typename T> ACTIV_TEMPLATE_API(ACTIV_BASE_EXPORTED_API) StatusCode ValidateUnsignedBinaryIntegralCopyT(const size_t size, const Endian endian, T *pValue, void *pCopy);
02189     template <typename T> ACTIV_TEMPLATE_API(ACTIV_BASE_EXPORTED_API) StatusCode ValidateUnsignedBinaryIntegralCopyT(const size_t size, const uint64_t lower, const uint64_t upper, const Endian endian, T *pValue, void *pCopy);
02190     template <typename T> ACTIV_TEMPLATE_API(ACTIV_BASE_EXPORTED_API) StatusCode ValidateUnsignedBinaryIntegralCopyT(const size_t size, const std::vector<uint64_t> &set, const Endian endian, T *pValue, void *pCopy);
02191
02192     const void  *m_pMessage;
02193     size_t      m_length;
02194     size_t      m_offset;
02195 };
02196
02197 // ---------------------------------------------------------------------------------------------------------------------------------
02198
02199 inline MessageValidator::MessageValidator(const void *pMessage, const size_t length, const MessageVersion messageVersion)
02200 {
02201     Initialize(pMessage, length, messageVersion);
02202 }
02203
02204 // ---------------------------------------------------------------------------------------------------------------------------------
02205
02206 inline void MessageValidator::Initialize(const void *pMessage, const size_t length, const MessageVersion messageVersion)
02207 {
02208     m_pMessage = pMessage;
02209     m_length = length;
02210
02211     Reset(messageVersion);
02212 }
02213
02214 // ---------------------------------------------------------------------------------------------------------------------------------
02215
02216 inline void MessageValidator::Reset(const MessageVersion messageVersion)
02217 {
02218     MessageHandler::Reset(messageVersion);
02219     m_offset = 0;
02220 }
02221
02222 // ---------------------------------------------------------------------------------------------------------------------------------
02223
02224 inline const void *MessageValidator::GetMessage() const
02225 {
02226     return m_pMessage;
02227 }
02228
02229 // ---------------------------------------------------------------------------------------------------------------------------------
02230
02231 inline size_t MessageValidator::GetLength() const
02232 {
02233     return m_length;
02234 }
02235
02236 // ---------------------------------------------------------------------------------------------------------------------------------
02237
02238 inline size_t MessageValidator::GetOffset() const
02239 {
02240     return m_offset;
02241 }
02242
02243 // ---------------------------------------------------------------------------------------------------------------------------------
02244
02245 inline StatusCode MessageValidator::SetOffset(const size_t offset)
02246 {
02247     if (offset > m_length)
02248         return STATUS_CODE_INVALID_PARAMETER;
02249
02250     m_offset = offset;
02251
02252     return STATUS_CODE_SUCCESS;
02253 }
02254
02255 // ---------------------------------------------------------------------------------------------------------------------------------
02256
02257 inline bool MessageValidator::IsEndOfMessage() const
02258 {
02259     return (m_length == m_offset);
02260 }
02261
02262 // ---------------------------------------------------------------------------------------------------------------------------------
02263
02264 template<size_t SIZE, MessageValidator::Endian ENDIAN, typename T>
02265 StatusCode MessageValidator::ValidateBinaryIntegral(T &value)
02266 {
02267     BOOST_STATIC_ASSERT((SIZE > 0) && (SIZE <= sizeof(uint64_t)));
02268     BOOST_STATIC_ASSERT(boost::is_integral<T>::value);
02269
02270     if (ACTIV_UNLIKELY((m_offset + SIZE) > m_length))
02271         return STATUS_CODE_INVALID_PARAMETER;
02272
02273     const byte_t * const pData = reinterpret_cast<const byte_t *>(m_pMessage) + m_offset;
02274     T to;
02275
02276     StatusCode statusCode = CopyBinaryIntegralToBinaryIntegralT<(SIZE == sizeof(T)), boost::is_signed<T>::value, SIZE, ENDIAN, T>()(pData, to);
02277
02278     if (ACTIV_UNLIKELY(STATUS_CODE_SUCCESS != statusCode))
02279         return statusCode;
02280
02281     m_offset += SIZE;
02282     value = to;
02283
02284     return STATUS_CODE_SUCCESS;
02285 }
02286
02287 // ---------------------------------------------------------------------------------------------------------------------------------
02288
02289 template<size_t SIZE, MessageValidator::Endian ENDIAN, typename T, T LOWER, T UPPER>
02290 StatusCode MessageValidator::ValidateBinaryIntegralRange(T &value)
02291 {
02292     BOOST_STATIC_ASSERT((SIZE > 0) && (SIZE <= sizeof(uint64_t)));
02293     BOOST_STATIC_ASSERT(boost::is_integral<T>::value);
02294
02295     if (ACTIV_UNLIKELY((m_offset + SIZE) > m_length))
02296         return STATUS_CODE_INVALID_PARAMETER;
02297
02298     const byte_t * const pData = reinterpret_cast<const byte_t *>(m_pMessage) + m_offset;
02299     T to;
02300
02301     StatusCode statusCode = CopyBinaryIntegralToBinaryIntegralT<(SIZE == sizeof(T)), boost::is_signed<T>::value, SIZE, ENDIAN, T>()(pData, to);
02302
02303     if (ACTIV_UNLIKELY(STATUS_CODE_SUCCESS != statusCode))
02304         return statusCode;
02305
02306     if (ACTIV_UNLIKELY((Less<T, LOWER>()(to)) || (Greater<T, UPPER>()(to))))
02307         return STATUS_CODE_OUT_OF_RANGE;
02308
02309     m_offset += SIZE;
02310     value = to;
02311
02312     return STATUS_CODE_SUCCESS;
02313 }
02314
02315 // ---------------------------------------------------------------------------------------------------------------------------------
02316
02317 template<size_t SIZE, MessageValidator::Endian ENDIAN, typename T>
02318 StatusCode MessageValidator::ValidateBinaryIntegral(const T lower, const T upper, T &value)
02319 {
02320     BOOST_STATIC_ASSERT((SIZE > 0) && (SIZE <= sizeof(uint64_t)));
02321     BOOST_STATIC_ASSERT(boost::is_integral<T>::value);
02322
02323     if (ACTIV_UNLIKELY((m_offset + SIZE) > m_length))
02324         return STATUS_CODE_INVALID_PARAMETER;
02325
02326     const byte_t * const pData = reinterpret_cast<const byte_t *>(m_pMessage) + m_offset;
02327     T to;
02328
02329     StatusCode statusCode = CopyBinaryIntegralToBinaryIntegralT<(SIZE == sizeof(T)), boost::is_signed<T>::value, SIZE, ENDIAN, T>()(pData, to);
02330
02331     if (ACTIV_UNLIKELY(STATUS_CODE_SUCCESS != statusCode))
02332         return statusCode;
02333
02334     if (ACTIV_UNLIKELY((to < lower) || (to > upper)))
02335         return STATUS_CODE_OUT_OF_RANGE;
02336
02337     m_offset += SIZE;
02338     value = to;
02339
02340     return STATUS_CODE_SUCCESS;
02341 }
02342
02343 // ---------------------------------------------------------------------------------------------------------------------------------
02344
02345 inline StatusCode MessageValidator::ValidateAsciiHexadecimalIntegral(const size_t size, const uint64_t lower, const uint64_t upper, const Endian endian, const void **ppData)
02346 {
02347     uint64_t value;
02348
02349     return ValidateAsciiHexadecimalIntegral(size, lower, upper, endian, &value, ppData);
02350 }
02351
02352 // ---------------------------------------------------------------------------------------------------------------------------------
02353
02354 inline StatusCode MessageValidator::ValidateAsciiHexadecimalIntegral(const size_t size, const std::vector<uint64_t> &set, const Endian endian, const void **ppData)
02355 {
02356     uint64_t value;
02357
02358     return ValidateAsciiHexadecimalIntegral(size, set, endian, &value, ppData);
02359 }
02360
02361 // ---------------------------------------------------------------------------------------------------------------------------------
02362
02363 inline StatusCode MessageValidator::ValidateAsciiHexadecimalIntegralCopy(const size_t size, const uint64_t lower, const uint64_t upper, const Endian endian, void *pCopy)
02364 {
02365     uint64_t value;
02366
02367     return ValidateAsciiHexadecimalIntegralCopy(size, lower, upper, endian, &value, pCopy);
02368 }
02369
02370 // ---------------------------------------------------------------------------------------------------------------------------------
02371
02372 inline StatusCode MessageValidator::ValidateAsciiHexadecimalIntegralCopy(const size_t size, const std::vector<uint64_t> &set, const Endian endian, void *pCopy)
02373 {
02374     uint64_t value;
02375
02376     return ValidateAsciiHexadecimalIntegralCopy(size, set, endian, &value, pCopy);
02377 }
02378
02379 // ---------------------------------------------------------------------------------------------------------------------------------
02380
02381 inline StatusCode MessageValidator::ValidateSignedAsciiIntegral(const size_t length, const int64_t lower, const int64_t upper, const void **ppData)
02382 {
02383     int64_t value;
02384
02385     return ValidateSignedAsciiIntegral(length, lower, upper, &value, ppData);
02386 }
02387
02388 // ---------------------------------------------------------------------------------------------------------------------------------
02389
02390 inline StatusCode MessageValidator::ValidateSignedAsciiIntegral(const size_t length, const std::vector<int64_t> &set, const void **ppData)
02391 {
02392     int64_t value;
02393
02394     return ValidateSignedAsciiIntegral(length, set, &value, ppData);
02395 }
02396
02397 // ---------------------------------------------------------------------------------------------------------------------------------
02398
02399 inline StatusCode MessageValidator::ValidateSignedAsciiIntegralCopy(const size_t length, const int64_t lower, const int64_t upper, void *pCopy)
02400 {
02401     int64_t value;
02402
02403     return ValidateSignedAsciiIntegralCopy(length, lower, upper, &value, pCopy);
02404 }
02405
02406 // ---------------------------------------------------------------------------------------------------------------------------------
02407
02408 inline StatusCode MessageValidator::ValidateSignedAsciiIntegralCopy(const size_t length, const std::vector<int64_t> &set, void *pCopy)
02409 {
02410     int64_t value;
02411
02412     return ValidateSignedAsciiIntegralCopy(length, set, &value, pCopy);
02413 }
02414
02415 // ---------------------------------------------------------------------------------------------------------------------------------
02416
02417 inline StatusCode MessageValidator::ValidateSignedAsciiReal(const size_t length, const long double lower, const long double upper, const void **ppData)
02418 {
02419     long double value;
02420
02421     return ValidateSignedAsciiRealT(length, lower, upper, &value, ppData);
02422 }
02423
02424 // ---------------------------------------------------------------------------------------------------------------------------------
02425
02426 inline StatusCode MessageValidator::ValidateSignedAsciiReal(const size_t length, const std::vector<long double> &set, const void **ppData)
02427 {
02428     long double value;
02429
02430     return ValidateSignedAsciiRealT(length, set, &value, ppData);
02431 }
02432
02433 // ---------------------------------------------------------------------------------------------------------------------------------
02434
02435 inline StatusCode MessageValidator::ValidateSignedAsciiRealCopy(const size_t length, const long double lower, const long double upper, void *pCopy)
02436 {
02437     long double value;
02438
02439     return ValidateSignedAsciiRealCopyT(length, lower, upper, &value, pCopy);
02440 }
02441
02442 // ---------------------------------------------------------------------------------------------------------------------------------
02443
02444 inline StatusCode MessageValidator::ValidateSignedAsciiRealCopy(const size_t length, const std::vector<long double> &set, void *pCopy)
02445 {
02446     long double value;
02447
02448     return ValidateSignedAsciiRealCopyT(length, set, &value, pCopy);
02449 }
02450
02451 // ---------------------------------------------------------------------------------------------------------------------------------
02452
02453 inline StatusCode MessageValidator::ValidateSignedBinaryIntegral(const size_t size, const int64_t lower, const int64_t upper, const Endian endian, const void **ppData)
02454 {
02455     int64_t value;
02456
02457     return ValidateSignedBinaryIntegral(size, lower, upper, endian, &value, ppData);
02458 }
02459
02460 // ---------------------------------------------------------------------------------------------------------------------------------
02461
02462 inline StatusCode MessageValidator::ValidateSignedBinaryIntegral(const size_t size, const std::vector<int64_t> &set, const Endian endian, const void **ppData)
02463 {
02464     int64_t value;
02465
02466     return ValidateSignedBinaryIntegral(size, set, endian, &value, ppData);
02467 }
02468
02469 // ---------------------------------------------------------------------------------------------------------------------------------
02470
02471 inline StatusCode MessageValidator::ValidateSignedBinaryIntegralCopy(const size_t size, const int64_t lower, const int64_t upper, const Endian endian, void *pCopy)
02472 {
02473     int64_t value;
02474
02475     return ValidateSignedBinaryIntegralCopy(size, lower, upper, endian, &value, pCopy);
02476 }
02477
02478 // ---------------------------------------------------------------------------------------------------------------------------------
02479
02480 inline StatusCode MessageValidator::ValidateSignedBinaryIntegralCopy(const size_t size, const std::vector<int64_t> &set, const Endian endian, void *pCopy)
02481 {
02482     int64_t value;
02483
02484     return ValidateSignedBinaryIntegralCopy(size, set, endian, &value, pCopy);
02485 }
02486
02487 // ---------------------------------------------------------------------------------------------------------------------------------
02488
02489 inline StatusCode MessageValidator::ValidateString(const void **ppData, size_t *pDataLength)
02490 {
02491     return ValidateString(0, ppData, pDataLength);
02492 }
02493
02494 // ---------------------------------------------------------------------------------------------------------------------------------
02495
02496 inline StatusCode MessageValidator::ValidateString(const byte_t lower, const byte_t upper, const void **ppData, size_t *pDataLength)
02497 {
02498     return ValidateString(lower, upper, 0, ppData, pDataLength);
02499 }
02500
02501 // ---------------------------------------------------------------------------------------------------------------------------------
02502
02503 inline StatusCode MessageValidator::ValidateString(const std::vector<byte_t> &set, const void **ppData, size_t *pDataLength)
02504 {
02505     return ValidateString(set, 0, ppData, pDataLength);
02506 }
02507
02508 // ---------------------------------------------------------------------------------------------------------------------------------
02509
02510 inline StatusCode MessageValidator::ValidateString(const std::vector<std::string> &set, const void **ppData, size_t *pDataLength)
02511 {
02512     return ValidateString(set, 0, ppData, pDataLength);
02513 }
02514
02515 // ---------------------------------------------------------------------------------------------------------------------------------
02516
02517 inline StatusCode MessageValidator::ValidateStringCopy(void *pCopy, const size_t copySize, size_t *pCopyLength)
02518 {
02519     return ValidateStringCopy(0, pCopy, copySize, pCopyLength);
02520 }
02521
02522 // ---------------------------------------------------------------------------------------------------------------------------------
02523
02524 inline StatusCode MessageValidator::ValidateStringCopy(const byte_t lower, const byte_t upper, void *pCopy, const size_t copySize, size_t *pCopyLength)
02525 {
02526     return ValidateStringCopy(lower, upper, 0, pCopy, copySize, pCopyLength);
02527 }
02528
02529 // ---------------------------------------------------------------------------------------------------------------------------------
02530
02531 inline StatusCode MessageValidator::ValidateStringCopy(const std::vector<byte_t> &set, void *pCopy, const size_t copySize, size_t *pCopyLength)
02532 {
02533     return ValidateStringCopy(set, 0, pCopy, copySize, pCopyLength);
02534 }
02535
02536 // ---------------------------------------------------------------------------------------------------------------------------------
02537
02538 inline StatusCode MessageValidator::ValidateStringCopy(const std::vector<std::string> &set, void *pCopy, const size_t copySize, size_t *pCopyLength)
02539 {
02540     return ValidateStringCopy(set, 0, pCopy, copySize, pCopyLength);
02541 }
02542
02543 // ---------------------------------------------------------------------------------------------------------------------------------
02544
02545 inline StatusCode MessageValidator::ValidateUnsignedAsciiIntegral(const size_t length, const uint64_t lower, const uint64_t upper, const void **ppData)
02546 {
02547     uint64_t value;
02548
02549     return ValidateUnsignedAsciiIntegral(length, lower, upper, &value, ppData);
02550 }
02551
02552 // ---------------------------------------------------------------------------------------------------------------------------------
02553
02554 inline StatusCode MessageValidator::ValidateUnsignedAsciiIntegral(const size_t length, const std::vector<uint64_t> &set, const void **ppData)
02555 {
02556     uint64_t value;
02557
02558     return ValidateUnsignedAsciiIntegral(length, set, &value, ppData);
02559 }
02560
02561 // ---------------------------------------------------------------------------------------------------------------------------------
02562
02563 inline StatusCode MessageValidator::ValidateUnsignedAsciiIntegralCopy(const size_t length, const uint64_t lower, const uint64_t upper, void *pCopy)
02564 {
02565     uint64_t value;
02566
02567     return ValidateUnsignedAsciiIntegralCopy(length, lower, upper, &value, pCopy);
02568 }
02569
02570 // ---------------------------------------------------------------------------------------------------------------------------------
02571
02572 inline StatusCode MessageValidator::ValidateUnsignedAsciiIntegralCopy(const size_t length, const std::vector<uint64_t> &set, void *pCopy)
02573 {
02574     uint64_t value;
02575
02576     return ValidateUnsignedAsciiIntegralCopy(length, set, &value, pCopy);
02577 }
02578
02579 // ---------------------------------------------------------------------------------------------------------------------------------
02580
02581 inline StatusCode MessageValidator::ValidateUnsignedAsciiReal(const size_t length, const long double lower, const long double upper, const void **ppData)
02582 {
02583     long double value;
02584
02585     return ValidateUnsignedAsciiReal(length, lower, upper, &value, ppData);
02586 }
02587
02588 // ---------------------------------------------------------------------------------------------------------------------------------
02589
02590 inline StatusCode MessageValidator::ValidateUnsignedAsciiReal(const size_t length, const std::vector<long double> &set, const void **ppData)
02591 {
02592     long double value;
02593
02594     return ValidateUnsignedAsciiReal(length, set, &value, ppData);
02595 }
02596
02597 // ---------------------------------------------------------------------------------------------------------------------------------
02598
02599 inline StatusCode MessageValidator::ValidateUnsignedAsciiRealCopy(const size_t length, const long double lower, const long double upper, void *pCopy)
02600 {
02601     long double value;
02602
02603     return ValidateUnsignedAsciiRealCopy(length, lower, upper, &value, pCopy);
02604 }
02605
02606 // ---------------------------------------------------------------------------------------------------------------------------------
02607
02608 inline StatusCode MessageValidator::ValidateUnsignedAsciiRealCopy(const size_t length, const std::vector<long double> &set, void *pCopy)
02609 {
02610     long double value;
02611
02612     return ValidateUnsignedAsciiRealCopy(length, set, &value, pCopy);
02613 }
02614
02615 // ---------------------------------------------------------------------------------------------------------------------------------
02616
02617 inline StatusCode MessageValidator::ValidateUnsignedBinaryIntegral(const size_t size, const uint64_t lower, const uint64_t upper, const Endian endian, const void **ppData)
02618 {
02619     uint64_t value;
02620
02621     return ValidateUnsignedBinaryIntegral(size, lower, upper, endian, &value, ppData);
02622 }
02623
02624 // ---------------------------------------------------------------------------------------------------------------------------------
02625
02626 inline StatusCode MessageValidator::ValidateUnsignedBinaryIntegral(const size_t size, const std::vector<uint64_t> &set, const Endian endian, const void **ppData)
02627 {
02628     uint64_t value;
02629
02630     return ValidateUnsignedBinaryIntegral(size, set, endian, &value, ppData);
02631 }
02632
02633 // ---------------------------------------------------------------------------------------------------------------------------------
02634
02635 inline StatusCode MessageValidator::ValidateUnsignedBinaryIntegralCopy(const size_t size, const uint64_t lower, const uint64_t upper, const Endian endian, void *pCopy)
02636 {
02637     uint64_t value;
02638
02639     return ValidateUnsignedBinaryIntegralCopy(size, lower, upper, endian, &value, pCopy);
02640 }
02641
02642 // ---------------------------------------------------------------------------------------------------------------------------------
02643
02644 inline StatusCode MessageValidator::ValidateUnsignedBinaryIntegralCopy(const size_t size, const std::vector<uint64_t> &set, const Endian endian, void *pCopy)
02645 {
02646     uint64_t value;
02647
02648     return ValidateUnsignedBinaryIntegralCopy(size, set, endian, &value, pCopy);
02649 }
02650
02651 // ---------------------------------------------------------------------------------------------------------------------------------
02652
02653 inline StatusCode MessageValidator::ValidateBoolean(bool *pBoolean)
02654 {
02655     uint8_t value;
02656
02657     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, ValidateUnsignedBinaryIntegral(sizeof(uint8_t), ENDIAN_LITTLE, &value));
02658
02659     if (0 != pBoolean)
02660         *pBoolean = (0 != value);
02661
02662     return STATUS_CODE_SUCCESS;
02663 }
02664
02665 // ---------------------------------------------------------------------------------------------------------------------------------
02666
02667 inline StatusCode MessageValidator::Get(const size_t offset, const void *&pData, const size_t length) const
02668 {
02669     if (0 == length)
02670         return STATUS_CODE_SUCCESS;
02671
02672     if ((offset + length) > m_length)
02673         return STATUS_CODE_INVALID_PARAMETER;
02674
02675     pData = static_cast<const byte_t *>(m_pMessage) + offset;
02676
02677     return STATUS_CODE_SUCCESS;
02678 }
02679
02680 // ---------------------------------------------------------------------------------------------------------------------------------
02681
02682 template <typename T>
02683 StatusCode MessageValidator::CopyAsciiHexadecimalIntegralToUnsignedBinaryIntegral(T &to, const void * const pData, size_t size, const Endian endian)
02684 {
02685     if ((0 != (size % 2)) || (size > (2 * sizeof(uint64_t))))
02686         return STATUS_CODE_INVALID_PARAMETER;
02687
02688     const byte_t * const pDataBuffer = static_cast<const byte_t * const>(pData);
02689     uint64_t value = 0;
02690
02691     for (size_t i = 0; i < size; i += 2)
02692     {
02693         uint8_t nibble1, nibble2;
02694
02695         if ((pDataBuffer[i] >= '0') && (pDataBuffer[i] <= '9'))
02696         {
02697             nibble1 = pDataBuffer[i] - '0';
02698         }
02699         else if ((pDataBuffer[i] >= 'A') && (pDataBuffer[i] <= 'F'))
02700         {
02701             nibble1 = pDataBuffer[i] - 'A' + 10;
02702         }
02703         else if ((pDataBuffer[i] >= 'a') && (pDataBuffer[i] <= 'f'))
02704         {
02705             nibble1 = pDataBuffer[i] - 'a' + 10;
02706         }
02707         else
02708         {
02709             return STATUS_CODE_INVALID_FORMAT;
02710         }
02711
02712         if ((pDataBuffer[i + 1] >= '0') && (pDataBuffer[i + 1] <= '9'))
02713         {
02714             nibble2 = pDataBuffer[i + 1] - '0';
02715         }
02716         else if ((pDataBuffer[i + 1] >= 'A') && (pDataBuffer[i + 1] <= 'F'))
02717         {
02718             nibble2 = pDataBuffer[i + 1] - 'A' + 10;
02719         }
02720         else if ((pDataBuffer[i + 1] >= 'a') && (pDataBuffer[i + 1] <= 'f'))
02721         {
02722             nibble2 = pDataBuffer[i + 1] - 'a' + 10;
02723         }
02724         else
02725         {
02726             return STATUS_CODE_INVALID_FORMAT;
02727         }
02728
02729         value |= ((ENDIAN_LITTLE == endian) ? (static_cast<uint64_t>((nibble1 << (CHAR_BIT / 2)) | nibble2) << ((i / 2) * CHAR_BIT)) : (static_cast<uint64_t>((nibble1 << (CHAR_BIT / 2)) | nibble2) << ((((size - i) / 2) - 1) * CHAR_BIT)));
02730     }
02731
02732     if (value > boost::integer_traits<T>::const_max)
02733         return STATUS_CODE_OUT_OF_RANGE;
02734
02735     to = static_cast<T>(value);
02736
02737     return STATUS_CODE_SUCCESS;
02738 }
02739
02740 // ---------------------------------------------------------------------------------------------------------------------------------
02741
02742 template <typename T>
02743 StatusCode MessageValidator::CopySignedAsciiIntegralToSignedBinaryIntegral(T &to, const void * const pData, size_t length)
02744 {
02745     const byte_t * const pDataBuffer = static_cast<const byte_t * const>(pData);
02746     bool negative = false;
02747
02748     to = 0;
02749
02750     for (size_t i = 0; i < length; ++i)
02751     {
02752         if (('+' == pDataBuffer[i]) || ('-' == pDataBuffer[i]))
02753         {
02754             if (i > 0)
02755                 return STATUS_CODE_INVALID_FORMAT;
02756
02757             if ('-' == pDataBuffer[i])
02758                 negative = true;
02759         }
02760         else if ((pDataBuffer[i] >= '0') && (pDataBuffer[i] <= '9'))
02761         {
02762             if ((i >= static_cast<size_t>(boost::integer_traits<T>::digits10)) && (to > ((boost::integer_traits<T>::const_max - static_cast<T>(pDataBuffer[i] - '0')) / 10)))
02763                 return STATUS_CODE_OUT_OF_RANGE;
02764
02765             to = (10 * to) + static_cast<T>(pDataBuffer[i] - '0');
02766         }
02767         else
02768         {
02769             return STATUS_CODE_INVALID_FORMAT;
02770         }
02771     }
02772
02773     if (negative)
02774         to *= -1;
02775
02776     return STATUS_CODE_SUCCESS;
02777 }
02778
02779 // ---------------------------------------------------------------------------------------------------------------------------------
02780
02781 template <typename T>
02782 StatusCode MessageValidator::CopySignedAsciiRealToBinaryReal(T &to, const void * const pData, size_t length)
02783 {
02784     int64_t numerator;
02785     uint64_t divisor;
02786     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, CopySignedAsciiRealToNumeratorAndDivisor(numerator, divisor, pData, length));
02787
02788     to = static_cast<T>(numerator) / static_cast<T>(divisor);
02789
02790     return STATUS_CODE_SUCCESS;
02791 }
02792
02793 // ---------------------------------------------------------------------------------------------------------------------------------
02794
02795 template<typename T> inline T MessageValidator::GetValueFromUnalignedPointerInEndian(const void * const pData, const Endian endian)
02796 {
02797     return (ENDIAN_LOCAL == endian) ? GetValueFromUnalignedPointer<T>(pData) : ByteSwap(GetValueFromUnalignedPointer<T>(pData));
02798 }
02799
02800 // ---------------------------------------------------------------------------------------------------------------------------------
02801
02802 template <size_t SIZE, MessageValidator::Endian ENDIAN, typename T>
02803 StatusCode MessageValidator::CopyBinaryIntegralToBinaryIntegralT<false, true, SIZE, ENDIAN, T>::operator()(const void * const pData, T &value) const
02804 {
02805     return CopySignedBinaryIntegralToSignedBinaryIntegralInternal<T>(value, pData, SIZE, ENDIAN);
02806 }
02807
02808 // ---------------------------------------------------------------------------------------------------------------------------------
02809
02810 template <size_t SIZE, MessageValidator::Endian ENDIAN, typename T>
02811 StatusCode MessageValidator::CopyBinaryIntegralToBinaryIntegralT<false, false, SIZE, ENDIAN, T>::operator()(const void * const pData, T &value) const
02812 {
02813     return CopyUnsignedBinaryIntegralToUnsignedBinaryIntegralInternal<T>(value, pData, SIZE, ENDIAN);
02814 }
02815
02816 // ---------------------------------------------------------------------------------------------------------------------------------
02817
02818 template <bool IS_SIGNED, size_t SIZE, typename T>
02819 inline StatusCode MessageValidator::CopyBinaryIntegralToBinaryIntegralT<true, IS_SIGNED, SIZE, MessageValidator::ENDIAN_LOCAL, T>::operator()(const void * const pData, T &value) const
02820 {
02821     BOOST_STATIC_ASSERT(SIZE == sizeof(T));
02822
02823     value = GetValueFromUnalignedPointer<T>(pData);
02824
02825     return STATUS_CODE_SUCCESS;
02826 }
02827
02828 // ---------------------------------------------------------------------------------------------------------------------------------
02829
02830 template <bool IS_SIGNED, size_t SIZE, typename T>
02831 inline StatusCode MessageValidator::CopyBinaryIntegralToBinaryIntegralT<true, IS_SIGNED, SIZE, MessageValidator::ENDIAN_ALIEN, T>::operator()(const void * const pData, T &value) const
02832 {
02833     BOOST_STATIC_ASSERT(SIZE == sizeof(T));
02834
02835     value = ByteSwap(GetValueFromUnalignedPointer<T>(pData));
02836
02837     return STATUS_CODE_SUCCESS;
02838 }
02839
02840 // ---------------------------------------------------------------------------------------------------------------------------------
02841
02842 template <typename T> inline StatusCode MessageValidator::CopySignedBinaryIntegralToSignedBinaryIntegral(T &to, const void * const pData, size_t size, const Endian endian)
02843 {
02844     if ((sizeof(T) == size) && (ENDIAN_LOCAL == endian))
02845     {
02846         // Fast path for "normal" case.
02847         to = GetValueFromUnalignedPointer<T>(pData);
02848         return STATUS_CODE_SUCCESS;
02849     }
02850
02851     return CopySignedBinaryIntegralToSignedBinaryIntegralInternal<T>(to, pData, size, endian);
02852 }
02853
02854 // ---------------------------------------------------------------------------------------------------------------------------------
02855
02856 template <typename T>
02857 StatusCode MessageValidator::CopyUnsignedAsciiIntegralToUnsignedBinaryIntegral(T &to, const void * const pData, size_t length)
02858 {
02859     const byte_t * const pDataBuffer = static_cast<const byte_t * const>(pData);
02860
02861     to = 0;
02862
02863     for (size_t i = 0; i < length; ++i)
02864     {
02865         if ((pDataBuffer[i] >= '0') && (pDataBuffer[i] <= '9'))
02866         {
02867             if ((i >= static_cast<size_t>(boost::integer_traits<T>::digits10)) && (to > ((boost::integer_traits<T>::const_max - static_cast<T>(pDataBuffer[i] - '0')) / 10)))
02868                 return STATUS_CODE_OUT_OF_RANGE;
02869
02870             to = (10 * to) + static_cast<T>(pDataBuffer[i] - '0');
02871         }
02872         else
02873         {
02874             return STATUS_CODE_INVALID_FORMAT;
02875         }
02876     }
02877
02878     return STATUS_CODE_SUCCESS;
02879 }
02880
02881 // ---------------------------------------------------------------------------------------------------------------------------------
02882
02883 template <typename T>
02884 StatusCode MessageValidator::CopyUnsignedAsciiRealToBinaryReal(T &to, const void * const pData, size_t length)
02885 {
02886     uint64_t numerator;
02887     uint64_t divisor;
02888     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, CopyUnsignedAsciiRealToNumeratorAndDivisor(numerator, divisor, pData, length));
02889
02890     to = static_cast<T>(numerator) / static_cast<T>(divisor);
02891
02892     return STATUS_CODE_SUCCESS;
02893 }
02894
02895 // ---------------------------------------------------------------------------------------------------------------------------------
02896
02897 template <typename T> inline StatusCode MessageValidator::CopyUnsignedBinaryIntegralToUnsignedBinaryIntegral(T &to, const void * const pData, size_t size, const Endian endian)
02898 {
02899     if ((sizeof(T) == size) && (ENDIAN_LOCAL == endian))
02900     {
02901         // Fast path for "normal" case.
02902         to = GetValueFromUnalignedPointer<T>(pData);
02903         return STATUS_CODE_SUCCESS;
02904     }
02905
02906     return CopyUnsignedBinaryIntegralToUnsignedBinaryIntegralInternal<T>(to, pData, size, endian);
02907 }
02908
02909 // ---------------------------------------------------------------------------------------------------------------------------------
02910
02911 template <typename T>
02912 StatusCode MessageValidator::CopySignedBinaryIntegralToSignedBinaryIntegralInternal(T &to, const void * const pData, size_t size, const Endian endian)
02913 {
02914     BOOST_STATIC_ASSERT(boost::is_signed<T>::value);
02915
02916     if (size <= sizeof(T))
02917     {
02918         // Fast path when we can guarantee the value will fit in the target.
02919         switch (size)
02920         {
02921             case sizeof(int8_t):
02922                 to = static_cast<T>(GetValueFromUnalignedPointerInEndian<int8_t>(pData, endian));
02923                 return STATUS_CODE_SUCCESS;
02924
02925             case sizeof(int16_t):
02926                 to = static_cast<T>(GetValueFromUnalignedPointerInEndian<int16_t>(pData, endian));
02927                 return STATUS_CODE_SUCCESS;
02928
02929             case sizeof(int32_t):
02930                 to = static_cast<T>(GetValueFromUnalignedPointerInEndian<int32_t>(pData, endian));
02931                 return STATUS_CODE_SUCCESS;
02932
02933             case sizeof(int64_t):
02934                 to = static_cast<T>(GetValueFromUnalignedPointerInEndian<int64_t>(pData, endian));
02935                 return STATUS_CODE_SUCCESS;
02936
02937             default:
02938                 break;
02939         }
02940     }
02941     else if (size > sizeof(int64_t))
02942     {
02943         return STATUS_CODE_INVALID_PARAMETER;
02944     }
02945
02946     const byte_t * const pDataBuffer = static_cast<const byte_t * const>(pData);
02947     int64_t value = 0;
02948
02949     if (ENDIAN_LITTLE == endian)
02950     {
02951         for (size_t i = 0; i < size; ++i)
02952         {
02953             value |= static_cast<int64_t>(pDataBuffer[i]) << (i * CHAR_BIT);
02954         }
02955     }
02956     else // (ENDIAN_BIG == endian)
02957     {
02958         for (size_t i = 0; i < size; ++i)
02959         {
02960             value |= static_cast<int64_t>(pDataBuffer[i]) << ((size - i - 1) * CHAR_BIT);
02961         }
02962     }
02963
02964     if ((sizeof(int64_t) != size) && (value & (INT64_C(1) << (((size - 1) * CHAR_BIT) + (CHAR_BIT - 1)))))
02965     {
02966         value |= ((INT64_C(-1) >> ((sizeof(int64_t) - size) * CHAR_BIT)) << (size * CHAR_BIT));
02967     }
02968
02969     if ((value < boost::integer_traits<T>::const_min) || (value > boost::integer_traits<T>::const_max))
02970         return STATUS_CODE_OUT_OF_RANGE;
02971
02972     to = static_cast<T>(value);
02973
02974     return STATUS_CODE_SUCCESS;
02975 }
02976
02977 // ---------------------------------------------------------------------------------------------------------------------------------
02978
02979 template <typename T>
02980 StatusCode MessageValidator::CopyUnsignedBinaryIntegralToUnsignedBinaryIntegralInternal(T &to, const void * const pData, size_t size, const Endian endian)
02981 {
02982     BOOST_STATIC_ASSERT(!boost::is_signed<T>::value);
02983
02984     if (size <= sizeof(T))
02985     {
02986         // Fast path when we can guarantee the value will fit in the target.
02987         switch (size)
02988         {
02989             case sizeof(uint8_t):
02990                 to = static_cast<T>(GetValueFromUnalignedPointerInEndian<uint8_t>(pData, endian));
02991                 return STATUS_CODE_SUCCESS;
02992
02993             case sizeof(uint16_t):
02994                 to = static_cast<T>(GetValueFromUnalignedPointerInEndian<uint16_t>(pData, endian));
02995                 return STATUS_CODE_SUCCESS;
02996
02997             case sizeof(uint32_t):
02998                 to = static_cast<T>(GetValueFromUnalignedPointerInEndian<uint32_t>(pData, endian));
02999                 return STATUS_CODE_SUCCESS;
03000
03001             case sizeof(uint64_t):
03002                 to = static_cast<T>(GetValueFromUnalignedPointerInEndian<uint64_t>(pData, endian));
03003                 return STATUS_CODE_SUCCESS;
03004
03005             default:
03006                 break;
03007         }
03008     }
03009     else if (size > sizeof(uint64_t))
03010     {
03011         return STATUS_CODE_INVALID_PARAMETER;
03012     }
03013
03014     const byte_t * const pDataBuffer = static_cast<const byte_t * const>(pData);
03015     uint64_t value = 0;
03016
03017     if (ENDIAN_LITTLE == endian)
03018     {
03019         for (size_t i = 0; i < size; ++i)
03020         {
03021             value |= static_cast<uint64_t>(pDataBuffer[i]) << (i * CHAR_BIT);
03022         }
03023     }
03024     else // (ENDIAN_BIG == endian)
03025     {
03026         for (size_t i = 0; i < size; ++i)
03027         {
03028             value |= static_cast<uint64_t>(pDataBuffer[i]) << ((size - i - 1) * CHAR_BIT);
03029         }
03030     }
03031
03032     if (value > boost::integer_traits<T>::const_max)
03033         return STATUS_CODE_OUT_OF_RANGE;
03034
03035     to = static_cast<T>(value);
03036
03037     return STATUS_CODE_SUCCESS;
03038 }
03039
03040 // ---------------------------------------------------------------------------------------------------------------------------------
03041
03042 template <typename T>
03043 inline StatusCode MessageValidator::ValidateAsciiHexadecimalIntegral(const size_t size, const Endian endian, T *pValue, const void **ppData)
03044 {
03045     return ValidateAsciiHexadecimalIntegralT<T>(size, endian, pValue, ppData);
03046 }
03047
03048 // ---------------------------------------------------------------------------------------------------------------------------------
03049
03050 template <typename T>
03051 inline StatusCode MessageValidator::ValidateAsciiHexadecimalIntegral(const size_t size, const uint64_t lower, const uint64_t upper, const Endian endian, T *pValue, const void **ppData)
03052 {
03053     return ValidateAsciiHexadecimalIntegralT<T>(size, lower, upper, endian, pValue, ppData);
03054 }
03055
03056 // ---------------------------------------------------------------------------------------------------------------------------------
03057
03058 template <typename T>
03059 inline StatusCode MessageValidator::ValidateAsciiHexadecimalIntegral(const size_t size, const std::vector<uint64_t> &set, const Endian endian, T *pValue, const void **ppData)
03060 {
03061     return ValidateAsciiHexadecimalIntegralT<T>(size, set, endian, pValue, ppData);
03062 }
03063
03064 // ---------------------------------------------------------------------------------------------------------------------------------
03065
03066 template <typename T>
03067 inline StatusCode MessageValidator::ValidateAsciiHexadecimalIntegralCopy(const size_t size, const Endian endian, T *pValue, void *pCopy)
03068 {
03069     return ValidateAsciiHexadecimalIntegralCopyT<T>(size, endian, pValue, pCopy);
03070 }
03071
03072 // ---------------------------------------------------------------------------------------------------------------------------------
03073
03074 template <typename T>
03075 inline StatusCode MessageValidator::ValidateAsciiHexadecimalIntegralCopy(const size_t size, const uint64_t lower, const uint64_t upper, const Endian endian, T *pValue, void *pCopy)
03076 {
03077     return ValidateAsciiHexadecimalIntegralCopyT<T>(size, lower, upper, endian, pValue, pCopy);
03078 }
03079
03080 // ---------------------------------------------------------------------------------------------------------------------------------
03081
03082 template <typename T>
03083 inline StatusCode MessageValidator::ValidateAsciiHexadecimalIntegralCopy(const size_t size, const std::vector<uint64_t> &set, const Endian endian, T *pValue, void *pCopy)
03084 {
03085     return ValidateAsciiHexadecimalIntegralCopyT<T>(size, set, endian, pValue, pCopy);
03086 }
03087
03088 // ---------------------------------------------------------------------------------------------------------------------------------
03089
03090 template <typename T>
03091 inline StatusCode MessageValidator::ValidateSignedAsciiIntegral(const size_t length, T *pValue, const void **ppData)
03092 {
03093     return ValidateSignedAsciiIntegralT<T>(length, pValue, ppData);
03094 }
03095
03096 // ---------------------------------------------------------------------------------------------------------------------------------
03097
03098 template <typename T>
03099 inline StatusCode MessageValidator::ValidateSignedAsciiIntegral(const size_t length, const int64_t lower, const int64_t upper, T *pValue, const void **ppData)
03100 {
03101     return ValidateSignedAsciiIntegralT<T>(length, lower, upper, pValue, ppData);
03102 }
03103
03104 // ---------------------------------------------------------------------------------------------------------------------------------
03105
03106 template <typename T>
03107 inline StatusCode MessageValidator::ValidateSignedAsciiIntegral(const size_t length, const std::vector<int64_t> &set, T *pValue, const void **ppData)
03108 {
03109     return ValidateSignedAsciiIntegralT<T>(length, set, pValue, ppData);
03110 }
03111
03112 // ---------------------------------------------------------------------------------------------------------------------------------
03113
03114 template <typename T>
03115 inline StatusCode MessageValidator::ValidateSignedAsciiIntegralCopy(const size_t length, T *pValue, void *pCopy)
03116 {
03117     return ValidateSignedAsciiIntegralCopyT<T>(length, pValue, pCopy);
03118 }
03119
03120 // ---------------------------------------------------------------------------------------------------------------------------------
03121
03122 template <typename T>
03123 inline StatusCode MessageValidator::ValidateSignedAsciiIntegralCopy(const size_t length, const int64_t lower, const int64_t upper, T *pValue, void *pCopy)
03124 {
03125     return ValidateSignedAsciiIntegralCopyT<T>(length, lower, upper, pValue, pCopy);
03126 }
03127
03128 // ---------------------------------------------------------------------------------------------------------------------------------
03129
03130 template <typename T>
03131 inline StatusCode MessageValidator::ValidateSignedAsciiIntegralCopy(const size_t length, const std::vector<int64_t> &set, T *pValue, void *pCopy)
03132 {
03133     return ValidateSignedAsciiIntegralCopyT<T>(length, set, pValue, pCopy);
03134 }
03135
03136 // ---------------------------------------------------------------------------------------------------------------------------------
03137
03138 template <typename T>
03139 inline StatusCode MessageValidator::ValidateSignedAsciiReal(const size_t length, T *pValue, const void **ppData)
03140 {
03141     return ValidateSignedAsciiRealT<T>(length, pValue, ppData);
03142 }
03143
03144 // ---------------------------------------------------------------------------------------------------------------------------------
03145
03146 template <typename T>
03147 inline StatusCode MessageValidator::ValidateSignedAsciiReal(const size_t length, const long double lower, const long double upper, T *pValue, const void **ppData)
03148 {
03149     return ValidateSignedAsciiRealT<T>(length, lower, upper, pValue, ppData);
03150 }
03151
03152 // ---------------------------------------------------------------------------------------------------------------------------------
03153
03154 template <typename T>
03155 inline StatusCode MessageValidator::ValidateSignedAsciiReal(const size_t length, const std::vector<long double> &set, T *pValue, const void **ppData)
03156 {
03157     return ValidateSignedAsciiRealT<T>(length, set, pValue, ppData);
03158 }
03159
03160 // ---------------------------------------------------------------------------------------------------------------------------------
03161
03162 template <typename T>
03163 inline StatusCode MessageValidator::ValidateSignedAsciiRealCopy(const size_t length, T *pValue, void *pCopy)
03164 {
03165     return ValidateSignedAsciiRealCopyT<T>(length, pValue, pCopy);
03166 }
03167
03168 // ---------------------------------------------------------------------------------------------------------------------------------
03169
03170 template <typename T>
03171 inline StatusCode MessageValidator::ValidateSignedAsciiRealCopy(const size_t length, const long double lower, const long double upper, T *pValue, void *pCopy)
03172 {
03173     return ValidateSignedAsciiRealCopyT<T>(length, lower, upper, pValue, pCopy);
03174 }
03175
03176 // ---------------------------------------------------------------------------------------------------------------------------------
03177
03178 template <typename T>
03179 inline StatusCode MessageValidator::ValidateSignedAsciiRealCopy(const size_t length, const std::vector<long double> &set, T *pValue, void *pCopy)
03180 {
03181     return ValidateSignedAsciiRealCopyT<T>(length, set, pValue, pCopy);
03182 }
03183
03184 // ---------------------------------------------------------------------------------------------------------------------------------
03185
03186 template <typename T>
03187 inline StatusCode MessageValidator::ValidateSignedBinaryIntegral(const size_t size, const Endian endian, T *pValue, const void **ppData)
03188 {
03189     return ValidateSignedBinaryIntegralT<T>(size, endian, pValue, ppData);
03190 }
03191
03192 // ---------------------------------------------------------------------------------------------------------------------------------
03193
03194 template <typename T>
03195 inline StatusCode MessageValidator::ValidateSignedBinaryIntegral(const size_t size, const int64_t lower, const int64_t upper, const Endian endian, T *pValue, const void **ppData)
03196 {
03197     return ValidateSignedBinaryIntegralT<T>(size, lower, upper, endian, pValue, ppData);
03198 }
03199
03200 // ---------------------------------------------------------------------------------------------------------------------------------
03201
03202 template <typename T>
03203 inline StatusCode MessageValidator::ValidateSignedBinaryIntegral(const size_t size, const std::vector<int64_t> &set, const Endian endian, T *pValue, const void **ppData)
03204 {
03205     return ValidateSignedBinaryIntegralT<T>(size, set, endian, pValue, ppData);
03206 }
03207
03208 // ---------------------------------------------------------------------------------------------------------------------------------
03209
03210 template <typename T>
03211 inline StatusCode MessageValidator::ValidateSignedBinaryIntegralCopy(const size_t size, const Endian endian, T *pValue, void *pCopy)
03212 {
03213     return ValidateSignedBinaryIntegralCopyT<T>(size, endian, pValue, pCopy);
03214 }
03215
03216 // ---------------------------------------------------------------------------------------------------------------------------------
03217
03218 template <typename T>
03219 inline StatusCode MessageValidator::ValidateSignedBinaryIntegralCopy(const size_t size, const int64_t lower, const int64_t upper, const Endian endian, T *pValue, void *pCopy)
03220 {
03221     return ValidateSignedBinaryIntegralCopyT<T>(size, lower, upper, endian, pValue, pCopy);
03222 }
03223
03224 // ---------------------------------------------------------------------------------------------------------------------------------
03225
03226 template <typename T>
03227 inline StatusCode MessageValidator::ValidateSignedBinaryIntegralCopy(const size_t size, const std::vector<int64_t> &set, const Endian endian, T *pValue, void *pCopy)
03228 {
03229     return ValidateSignedBinaryIntegralCopyT<T>(size, set, endian, pValue, pCopy);
03230 }
03231
03232 // ---------------------------------------------------------------------------------------------------------------------------------
03233
03234 template <typename T>
03235 inline StatusCode MessageValidator::ValidateUnsignedAsciiIntegral(const size_t length, T *pValue, const void **ppData)
03236 {
03237     return ValidateUnsignedAsciiIntegralT<T>(length, pValue, ppData);
03238 }
03239
03240 // ---------------------------------------------------------------------------------------------------------------------------------
03241
03242 template <typename T>
03243 inline StatusCode MessageValidator::ValidateUnsignedAsciiIntegral(const size_t length, const uint64_t lower, const uint64_t upper, T *pValue, const void **ppData)
03244 {
03245     return ValidateUnsignedAsciiIntegralT<T>(length, lower, upper, pValue, ppData);
03246 }
03247
03248 // ---------------------------------------------------------------------------------------------------------------------------------
03249
03250 template <typename T>
03251 inline StatusCode MessageValidator::ValidateUnsignedAsciiIntegral(const size_t length, const std::vector<uint64_t> &set, T *pValue, const void **ppData)
03252 {
03253     return ValidateUnsignedAsciiIntegralT<T>(length, set, pValue, ppData);
03254 }
03255
03256 // ---------------------------------------------------------------------------------------------------------------------------------
03257
03258 template <typename T>
03259 inline StatusCode MessageValidator::ValidateUnsignedAsciiIntegralCopy(const size_t length, T *pValue, void *pCopy)
03260 {
03261     return ValidateUnsignedAsciiIntegralCopyT<T>(length, pValue, pCopy);
03262 }
03263
03264 // ---------------------------------------------------------------------------------------------------------------------------------
03265
03266 template <typename T>
03267 inline StatusCode MessageValidator::ValidateUnsignedAsciiIntegralCopy(const size_t length, const uint64_t lower, const uint64_t upper, T *pValue, void *pCopy)
03268 {
03269     return ValidateUnsignedAsciiIntegralCopyT<T>(length, lower, upper, pValue, pCopy);
03270 }
03271
03272 // ---------------------------------------------------------------------------------------------------------------------------------
03273
03274 template <typename T>
03275 inline StatusCode MessageValidator::ValidateUnsignedAsciiIntegralCopy(const size_t length, const std::vector<uint64_t> &set, T *pValue, void *pCopy)
03276 {
03277     return ValidateUnsignedAsciiIntegralCopyT<T>(length, set, pValue, pCopy);
03278 }
03279
03280 // ---------------------------------------------------------------------------------------------------------------------------------
03281
03282 template <typename T>
03283 inline StatusCode MessageValidator::ValidateUnsignedAsciiReal(const size_t length, T *pValue, const void **ppData)
03284 {
03285     return ValidateUnsignedAsciiRealT<T>(length, pValue, ppData);
03286 }
03287
03288 // ---------------------------------------------------------------------------------------------------------------------------------
03289
03290 template <typename T>
03291 inline StatusCode MessageValidator::ValidateUnsignedAsciiReal(const size_t length, const long double lower, const long double upper, T *pValue, const void **ppData)
03292 {
03293     return ValidateUnsignedAsciiRealT<T>(length, lower, upper, pValue, ppData);
03294 }
03295
03296 // ---------------------------------------------------------------------------------------------------------------------------------
03297
03298 template <typename T>
03299 inline StatusCode MessageValidator::ValidateUnsignedAsciiReal(const size_t length, const std::vector<long double> &set, T *pValue, const void **ppData)
03300 {
03301     return ValidateUnsignedAsciiRealT<T>(length, set, pValue, ppData);
03302 }
03303
03304 // ---------------------------------------------------------------------------------------------------------------------------------
03305
03306 template <typename T>
03307 inline StatusCode MessageValidator::ValidateUnsignedAsciiRealCopy(const size_t length, T *pValue, void *pCopy)
03308 {
03309     return ValidateUnsignedAsciiRealCopyT<T>(length, pValue, pCopy);
03310 }
03311
03312 // ---------------------------------------------------------------------------------------------------------------------------------
03313
03314 template <typename T>
03315 inline StatusCode MessageValidator::ValidateUnsignedAsciiRealCopy(const size_t length, const long double lower, const long double upper, T *pValue, void *pCopy)
03316 {
03317     return ValidateUnsignedAsciiRealCopyT<T>(length, lower, upper, pValue, pCopy);
03318 }
03319
03320 // ---------------------------------------------------------------------------------------------------------------------------------
03321
03322 template <typename T>
03323 inline StatusCode MessageValidator::ValidateUnsignedAsciiRealCopy(const size_t length, const std::vector<long double> &set, T *pValue, void *pCopy)
03324 {
03325     return ValidateUnsignedAsciiRealCopyT<T>(length, set, pValue, pCopy);
03326 }
03327
03328 // ---------------------------------------------------------------------------------------------------------------------------------
03329
03330 template <typename T>
03331 inline StatusCode MessageValidator::ValidateUnsignedBinaryIntegral(const size_t size, const Endian endian, T *pValue, const void **ppData)
03332 {
03333     return ValidateUnsignedBinaryIntegralT<T>(size, endian, pValue, ppData);
03334 }
03335
03336 // ---------------------------------------------------------------------------------------------------------------------------------
03337
03338 template <typename T>
03339 inline StatusCode MessageValidator::ValidateUnsignedBinaryIntegral(const size_t size, const uint64_t lower, const uint64_t upper, const Endian endian, T *pValue, const void **ppData)
03340 {
03341     return ValidateUnsignedBinaryIntegralT<T>(size, lower, upper, endian, pValue, ppData);
03342 }
03343
03344 // ---------------------------------------------------------------------------------------------------------------------------------
03345
03346 template <typename T>
03347 inline StatusCode MessageValidator::ValidateUnsignedBinaryIntegral(const size_t size, const std::vector<uint64_t> &set, const Endian endian, T *pValue, const void **ppData)
03348 {
03349     return ValidateUnsignedBinaryIntegralT<T>(size, set, endian, pValue, ppData);
03350 }
03351
03352 // ---------------------------------------------------------------------------------------------------------------------------------
03353
03354 template <typename T>
03355 inline StatusCode MessageValidator::ValidateUnsignedBinaryIntegralCopy(const size_t size, const Endian endian, T *pValue, void *pCopy)
03356 {
03357     return ValidateUnsignedBinaryIntegralCopyT<T>(size, endian, pValue, pCopy);
03358 }
03359
03360 // ---------------------------------------------------------------------------------------------------------------------------------
03361
03362 template <typename T>
03363 inline StatusCode MessageValidator::ValidateUnsignedBinaryIntegralCopy(const size_t size, const uint64_t lower, const uint64_t upper, const Endian endian, T *pValue, void *pCopy)
03364 {
03365     return ValidateUnsignedBinaryIntegralCopyT<T>(size, lower, upper, endian, pValue, pCopy);
03366 }
03367
03368 // ---------------------------------------------------------------------------------------------------------------------------------
03369
03370 template <typename T>
03371 inline StatusCode MessageValidator::ValidateUnsignedBinaryIntegralCopy(const size_t size, const std::vector<uint64_t> &set, const Endian endian, T *pValue, void *pCopy)
03372 {
03373     return ValidateUnsignedBinaryIntegralCopyT<T>(size, set, endian, pValue, pCopy);
03374 }
03375
03376 } // namespace Activ
03377
03378 #endif // (!defined ACTIV_BASE_MESSAGE_VALIDATOR_H)
Generated on Wed Oct 8 14:01:47 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivFramework

Messages.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FRAMEWORK_MESSAGES_H)
00010 #define ACTIV_FRAMEWORK_MESSAGES_H
00011
00012 #include "ActivMiddleware/ActivFramework/ServiceTypes.h"
00013 #include "ActivMiddleware/ActivBase/ISerializableMessage.h"
00014
00015 namespace Activ
00016 {
00017
00021 class OpenServiceRequest : public ISerializableMessage
00022 {
00023 public:
00029     ACTIV_FRAMEWORK_API OpenServiceRequest();
00030
00031     ACTIV_FRAMEWORK_API virtual StatusCode Serialize(MessageBuilder &messageBuilder) const;
00032     ACTIV_FRAMEWORK_API virtual StatusCode Deserialize(MessageValidator &messageValidator);
00033
00034     static const byte_t m_highestVersion = 2;
00035     static const byte_t m_currentVersion = 1;
00036
00037     byte_t      m_version;
00038     ServiceId   m_serviceId;
00039 };
00040
00041 // ---------------------------------------------------------------------------------------------------------------------------------
00042 // ---------------------------------------------------------------------------------------------------------------------------------
00043
00047 class OpenServiceResponse : public ISerializableMessage
00048 {
00049 public:
00053     ACTIV_FRAMEWORK_API OpenServiceResponse();
00054
00060     ACTIV_FRAMEWORK_API OpenServiceResponse(const ServiceId &serviceId);
00061
00062     ACTIV_FRAMEWORK_API virtual StatusCode Serialize(MessageBuilder &messageBuilder) const;
00063     ACTIV_FRAMEWORK_API virtual StatusCode Deserialize(MessageValidator &messageValidator);
00064
00065     ServiceId   m_serviceId;
00066 };
00067
00068 // ---------------------------------------------------------------------------------------------------------------------------------
00069 // ---------------------------------------------------------------------------------------------------------------------------------
00070
00076 class SystemMessageEndPointIdSet
00077 {
00078 public:
00088     ACTIV_FRAMEWORK_API static StatusCode Serialize(MessageBuilder &messageBuilder, const EndPointIdSet &endPointIdSet);
00089
00098     ACTIV_FRAMEWORK_API StatusCode Deserialize(MessageValidator &messageValidator);
00099
00100     EndPointIdSet   m_endPointIdSet;
00101
00102 private:
00103     typedef SerializableObjectContainerHelper<EndPointIdSet, EndPointId> Serializer;
00104 };
00105
00106 } // namespace Activ
00107
00108 #endif // (!defined ACTIV_FRAMEWORK_MESSAGES_H)
Generated on Wed Oct 8 14:01:48 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivContentGatewayApi

MetaDataRequestHelper.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_CONTENT_GATEWAY_API_META_DATA_REQUEST_HELPER_H)
00010 #define ACTIV_CONTENT_GATEWAY_API_META_DATA_REQUEST_HELPER_H
00011
00012 #include "ActivContentPlatform/ActivContentGatewayApi/External.h"
00013 #include "ActivContentPlatform/ActivContentGatewayApiCommon/MetaDataTypes.h"
00014
00015 #include "ActivMiddleware/ActivDatabase/TableSpecification.h"
00016
00017 namespace Activ
00018 {
00019
00020 namespace ContentPlatform
00021 {
00022
00023 namespace ContentGatewayApi
00024 {
00025
00026 class ContentGatewayClient;
00027
00028 // ---------------------------------------------------------------------------------------------------------------------------------
00029
00033 class MetaDataRequestHelper
00034 {
00035 public:
00046     ACTIV_CONTENT_GATEWAY_API
00047     static StatusCode GetPermissionInfo(const ContentGatewayClient &contentGatewayClient, PermissionInfo &permissionInfo);
00048
00063     ACTIV_CONTENT_GATEWAY_API
00064     static StatusCode GetTableInfoList(const ContentGatewayClient &contentGatewayClient,
00065         const Feed::PermissionLevel permissionLevel, TableInfoList &tableInfoList);
00066
00082     ACTIV_CONTENT_GATEWAY_API
00083     static StatusCode GetTableSpecification(const ContentGatewayClient &contentGatewayClient,
00084         const Feed::PermissionLevel permissionLevel, const Feed::TableNo tableNumber,
00085         Database::TableSpecification &tableSpecification);
00086
00100     ACTIV_CONTENT_GATEWAY_API
00101     static const StatusCode GetRelationshipInfoList(const ContentGatewayClient &contentGatewayClient, const Feed::Context context,
00102         RelationshipInfoList &relationshipInfoList);
00103
00115     ACTIV_CONTENT_GATEWAY_API
00116     static const UniversalFieldHelperMap &GetUniversalFieldHelperMap(const ContentGatewayClient &contentGatewayClient);
00117
00126     ACTIV_CONTENT_GATEWAY_API
00127     static const Feed::UniversalFieldHelper &GetUniversalFieldHelper(const ContentGatewayClient &contentGatewayClient,
00128         const Feed::FieldId fieldId);
00129
00138     ACTIV_CONTENT_GATEWAY_API
00139     static const Feed::UniversalFieldHelper &GetUniversalFieldHelper(const ContentGatewayClient &contentGatewayClient,
00140         const std::string &codeIdentifier);
00141 };
00142
00143 } // namespace ContentGatewayApi
00144
00145 } // namespace ContentPlatform
00146
00147 } // namespace Activ
00148
00149 #endif // (!defined ACTIV_CONTENT_GATEWAY_API_META_DATA_REQUEST_HELPER_H)
Generated on Wed Oct 8 14:01:44 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivContentGatewayApiCommon

MetaDataTypes.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_CONTENT_GATEWAY_API_COMMON_META_DATA_TYPES_H)
00010 #define ACTIV_CONTENT_GATEWAY_API_COMMON_META_DATA_TYPES_H
00011
00012 #include "ActivContentPlatform/ActivContentGatewayApiCommon/External.h"
00013 #include "ActivContentPlatform/ActivFeedCommon/TableTypes.h"
00014 #include "ActivContentPlatform/ActivFeedCommon/FieldIds.h"
00015 #include "ActivContentPlatform/ActivFeedCommon/UniversalFieldHelper.h"
00016 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedPermissioning/PermissionInfo.h"
00017
00018 #include "ActivMiddleware/ActivFieldTypes/UInt.h"
00019
00020 #include <vector>
00021 #include <map>
00022
00023 namespace Activ
00024 {
00025
00026 namespace ContentPlatform
00027 {
00028
00029 namespace ContentGatewayApi
00030 {
00031
00037 class PermissionInfo : public Feed::PermissionInfo
00038 {
00039 public:
00040     UInt    m_symbolSubscriptionQuota;
00041 };
00042
00043 // ---------------------------------------------------------------------------------------------------------------------------------
00044 // ---------------------------------------------------------------------------------------------------------------------------------
00045
00049 class TableInfo
00050 {
00051 public:
00052     Feed::TableNo   m_tableNumber;
00053     std::string     m_tableName;
00054     std::string     m_tableCodeIdentifier;
00055     Feed::TableType m_tableType;
00056 };
00057
00061 typedef std::vector<TableInfo> TableInfoList;
00062
00063 // ---------------------------------------------------------------------------------------------------------------------------------
00064
00068 typedef std::map<Feed::FieldId, Feed::UniversalFieldHelper> UniversalFieldHelperMap;
00069
00070 // ---------------------------------------------------------------------------------------------------------------------------------
00071 // ---------------------------------------------------------------------------------------------------------------------------------
00072
00076 class RelationshipInfo
00077 {
00078 public:
00079     Feed::RelationshipId    m_relationshipId;
00080     Feed::Context           m_context;
00081     std::string             m_name;
00082     std::string             m_codeIdentifier;
00083 };
00084
00088 typedef std::vector<RelationshipInfo> RelationshipInfoList;
00089
00090 } // namespace ContentGatewayApi
00091
00092 } // namespace ContentPlatform
00093
00094 } // namespace Activ
00095
00096 #endif // (!defined ACTIV_CONTENT_GATEWAY_API_COMMON_META_DATA_TYPES_H)
Generated on Wed Oct 8 14:01:45 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

MutexHelper.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_BASE_MUTEX_HELPER_H)
00010 #define ACTIV_BASE_MUTEX_HELPER_H
00011
00012 #include "ActivMiddleware/ActivBase/IMutex.h"
00013
00014 #include <cassert>
00015
00016 namespace Activ
00017 {
00018
00024 class ScopedMutexLocker : private boost::noncopyable
00025 {
00026 public:
00032     ACTIV_BASE_INLINE_API
00033     ScopedMutexLocker(const IMutex * const pMutex);
00034
00038     ACTIV_BASE_INLINE_API
00039     ~ScopedMutexLocker();
00040
00041 private:
00042     const IMutex * const    m_pMutex;
00043 };
00044
00045 typedef ScopedMutexLocker MutexHelper;
00046
00047 // ---------------------------------------------------------------------------------------------------------------------------------
00048
00049 inline ScopedMutexLocker::ScopedMutexLocker(const IMutex * const pMutex) :
00050     m_pMutex(pMutex)
00051 {
00052     if (0 != m_pMutex)
00053         (void) m_pMutex->Acquire();
00054 }
00055
00056 // ---------------------------------------------------------------------------------------------------------------------------------
00057
00058 inline ScopedMutexLocker::~ScopedMutexLocker()
00059 {
00060     if (0 != m_pMutex)
00061         (void) m_pMutex->Release();
00062 }
00063
00064 // ---------------------------------------------------------------------------------------------------------------------------------
00065 // ---------------------------------------------------------------------------------------------------------------------------------
00066
00072 class ScopedMutexTryLocker : private boost::noncopyable
00073 {
00074 public:
00081     ACTIV_BASE_INLINE_API
00082     ScopedMutexTryLocker(const IMutex * const pMutex);
00083
00087     ACTIV_BASE_INLINE_API
00088     ~ScopedMutexTryLocker();
00089
00096     ACTIV_BASE_INLINE_API
00097     void Acquire();
00098
00104     ACTIV_BASE_INLINE_API
00105     operator bool() const;
00106
00112     ACTIV_BASE_INLINE_API
00113     bool operator!() const;
00114
00115 private:
00116     const IMutex * const    m_pMutex;
00117     bool                    m_isLocked;
00118 };
00119
00120 // ---------------------------------------------------------------------------------------------------------------------------------
00121
00122 inline ScopedMutexTryLocker::ScopedMutexTryLocker(const IMutex * const pMutex) :
00123     m_pMutex(pMutex),
00124     m_isLocked((0 != m_pMutex) ? (STATUS_CODE_SUCCESS == m_pMutex->Try()) : true)
00125 {
00126 }
00127
00128 // ---------------------------------------------------------------------------------------------------------------------------------
00129
00130 inline ScopedMutexTryLocker::~ScopedMutexTryLocker()
00131 {
00132     if ((0 != m_pMutex) && m_isLocked)
00133         (void) m_pMutex->Release();
00134 }
00135
00136 // ---------------------------------------------------------------------------------------------------------------------------------
00137
00138 inline void ScopedMutexTryLocker::Acquire()
00139 {
00140     if ((0 != m_pMutex) && !m_isLocked)
00141     {
00142         (void) m_pMutex->Acquire();
00143         m_isLocked = true;
00144     }
00145 }
00146
00147 // ---------------------------------------------------------------------------------------------------------------------------------
00148
00149 inline ScopedMutexTryLocker::operator bool() const
00150 {
00151     return m_isLocked;
00152 }
00153
00154 // ---------------------------------------------------------------------------------------------------------------------------------
00155
00156 inline bool ScopedMutexTryLocker::operator!() const
00157 {
00158     return !m_isLocked;
00159 }
00160
00161 // ---------------------------------------------------------------------------------------------------------------------------------
00162 // ---------------------------------------------------------------------------------------------------------------------------------
00163
00170 class DeferredScopedMutexLocker : private boost::noncopyable
00171 {
00172 public:
00179     ACTIV_BASE_INLINE_API
00180     DeferredScopedMutexLocker(const IMutex * const pMutex);
00181
00185     ACTIV_BASE_INLINE_API
00186     ~DeferredScopedMutexLocker();
00187
00191     ACTIV_BASE_INLINE_API
00192     void Acquire();
00193
00199     ACTIV_BASE_INLINE_API
00200     bool Try();
00201
00207     ACTIV_BASE_INLINE_API
00208     operator bool() const;
00209
00215     ACTIV_BASE_INLINE_API
00216     bool operator!() const;
00217
00218 private:
00219     const IMutex * const    m_pMutex;
00220     bool                    m_isLocked;
00221 };
00222
00223 // ---------------------------------------------------------------------------------------------------------------------------------
00224
00225 inline DeferredScopedMutexLocker::DeferredScopedMutexLocker(const IMutex * const pMutex) :
00226     m_pMutex(pMutex),
00227     m_isLocked(false)
00228 {
00229 }
00230
00231 // ---------------------------------------------------------------------------------------------------------------------------------
00232
00233 inline DeferredScopedMutexLocker::~DeferredScopedMutexLocker()
00234 {
00235     if ((0 != m_pMutex) && m_isLocked)
00236         (void) m_pMutex->Release();
00237 }
00238
00239 // ---------------------------------------------------------------------------------------------------------------------------------
00240
00241 inline void DeferredScopedMutexLocker::Acquire()
00242 {
00243     if (!m_isLocked)
00244     {
00245         if (0 != m_pMutex)
00246             (void) m_pMutex->Acquire();
00247
00248         m_isLocked = true;
00249     }
00250 }
00251
00252 // ---------------------------------------------------------------------------------------------------------------------------------
00253
00254 inline bool DeferredScopedMutexLocker::Try()
00255 {
00256     if (!m_isLocked)
00257     {
00258         if (0 != m_pMutex)
00259         {
00260             if (STATUS_CODE_SUCCESS == m_pMutex->Try())
00261                 m_isLocked = true;
00262         }
00263         else
00264         {
00265             m_isLocked = true;
00266         }
00267     }
00268
00269     return m_isLocked;
00270 }
00271
00272 // ---------------------------------------------------------------------------------------------------------------------------------
00273
00274 inline DeferredScopedMutexLocker::operator bool() const
00275 {
00276     return m_isLocked;
00277 }
00278
00279 // ---------------------------------------------------------------------------------------------------------------------------------
00280
00281 inline bool DeferredScopedMutexLocker::operator!() const
00282 {
00283     return !m_isLocked;
00284 }
00285
00286 } // namespace Activ
00287
00288 #endif // (!defined ACTIV_BASE_MUTEX_HELPER_H)
Generated on Wed Oct 8 14:01:47 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivContentGatewayApi

NewsRequestHelper.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_CONTENT_GATEWAY_API_NEWS_REQUEST_HELPER_H)
00010 #define ACTIV_CONTENT_GATEWAY_API_NEWS_REQUEST_HELPER_H
00011
00012 #include "ActivContentPlatform/ActivContentGatewayApi/External.h"
00013
00014 namespace Activ
00015 {
00016
00017 namespace ContentPlatform
00018 {
00019
00020 namespace ContentGatewayApi
00021 {
00022
00023 class ContentGatewayClient;
00024
00025 // ---------------------------------------------------------------------------------------------------------------------------------
00026
00030 class NewsRequestHelper
00031 {
00032 public:
00033     typedef NewsRequestParameters RequestParameters;
00034     typedef NewsResponseParameters ResponseParameters;
00035
00049     ACTIV_CONTENT_GATEWAY_API static StatusCode SendRequest(const ContentGatewayClient &client,
00050         const RequestParameters &requestParameters, ResponseParameters &responseParameters,
00051         const TimeoutPeriod timeoutPeriod = Port::defaultTimeout);
00052
00064     ACTIV_CONTENT_GATEWAY_API static StatusCode SendRequest(const ContentGatewayClient &client, SyncRequestId &syncRequestId,
00065         const RequestParameters &requestParameters);
00066
00078     ACTIV_CONTENT_GATEWAY_API static StatusCode PostRequest(const ContentGatewayClient &client, const RequestId &requestId,
00079         const RequestParameters &requestParameters);
00080
00094     ACTIV_CONTENT_GATEWAY_API static StatusCode GetResponse(const ContentGatewayClient &client, SyncRequestId &syncRequestId,
00095         ResponseParameters &responseParameters, const TimeoutPeriod timeoutPeriod);
00096
00109     ACTIV_CONTENT_GATEWAY_API static StatusCode Deserialize(const ContentGatewayClient &client, const HeapMessage &response,
00110         ResponseParameters &responseParameters);
00111 };
00112
00113 } // namespace ContentGatewayApi
00114
00115 } // namespace ContentPlatform
00116
00117 } // namespace Activ
00118
00119 #endif // (!defined ACTIV_CONTENT_GATEWAY_API_NEWS_REQUEST_HELPER_H)
Generated on Wed Oct 8 14:01:45 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivContentGatewayApiCommon

NewsTypes.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_CONTENT_GATEWAY_API_COMMON_NEWS_TYPES_H)
00010 #define ACTIV_CONTENT_GATEWAY_API_COMMON_NEWS_TYPES_H
00011
00012 #include "ActivContentPlatform/ActivContentGatewayApiCommon/External.h"
00013 #include "ActivContentPlatform/ActivContentGatewayApiCommon/Types.h"
00014 #include "ActivContentPlatform/ActivFeedCommon/UpdateIds.h"
00015
00016 #include "ActivMiddleware/ActivFieldTypes/Date.h"
00017
00018 namespace Activ
00019 {
00020
00021 namespace ContentPlatform
00022 {
00023
00024 namespace ContentGatewayApi
00025 {
00026
00030 typedef uint8_t RecordsPerResponseCount;
00031
00032 #define ACTIV_DECLARE_FLAGS(value, id)  static const Flags id = value;
00033
00034 // ---------------------------------------------------------------------------------------------------------------------------------
00035
00039 class NewsRequestParameters
00040 {
00041 public:
00050     ACTIV_CONTENT_GATEWAY_API_COMMON_API NewsRequestParameters();
00051
00052     #define ACTIV_NEWS_REQUEST_FLAG_LIST(d)                                         \
00053         d(0x00, FLAG_NONE)                                                          \
00054         d(0x01, FLAG_SUBSCRIBE)                     \
00055         d(0x02, FLAG_INCLUDE_EXPIRED)
00057     typedef uint8_t Flags;
00058     ACTIV_NEWS_REQUEST_FLAG_LIST(ACTIV_DECLARE_FLAGS)
00059
00060     static const RecordsPerResponseCount DEFAULT_MAX_RECORDS_PER_RESPONSE = 64;
00061
00062     std::string                 m_query;
00063     Date                        m_startDate;
00064     Date                        m_endDate;
00065     std::string                 m_startSymbol;
00066     uint16_t                    m_numberOfRecords;
00067     RecordsPerResponseCount     m_maxRecordsPerResponse;
00068     Feed::FieldIdList           m_fieldIdList;
00069     Flags                       m_flags;
00070     Feed::PermissionLevel       m_permissionLevel;
00071 };
00072
00073 // ---------------------------------------------------------------------------------------------------------------------------------
00074 // ---------------------------------------------------------------------------------------------------------------------------------
00075
00079 class NewsStory
00080 {
00081 public:
00082     std::string             m_symbol;
00083     FieldData               m_fieldData;
00084     Feed::PermissionIdList  m_permissionIdList;
00085 };
00086
00087 // ---------------------------------------------------------------------------------------------------------------------------------
00088
00092 typedef std::vector<NewsStory> NewsStoryList;
00093
00094 // ---------------------------------------------------------------------------------------------------------------------------------
00095 // ---------------------------------------------------------------------------------------------------------------------------------
00096
00100 class NewsResponseParameters
00101 {
00102 public:
00108     ACTIV_CONTENT_GATEWAY_API_COMMON_API NewsResponseParameters();
00109
00110     NewsStoryList       m_storyList;
00111     SubscriptionCookie  m_subscriptionCookie;
00112 };
00113
00114 // ---------------------------------------------------------------------------------------------------------------------------------
00115 // ---------------------------------------------------------------------------------------------------------------------------------
00116
00120 class NewsUpdate
00121 {
00122 public:
00123     #define ACTIV_NEWS_UPDATE_FLAG_LIST(d)                                                                  \
00124         d(0x00, FLAG_NONE)                                                              \
00125         d(0x01, FLAG_DELETE)
00127     typedef uint8_t Flags;
00128     ACTIV_NEWS_UPDATE_FLAG_LIST(ACTIV_DECLARE_FLAGS)
00129
00137     ACTIV_CONTENT_GATEWAY_API_COMMON_API static std::string FlagsToString(const Flags flags);
00138
00144     bool IsNewRecord() const;
00145
00151     bool IsDelete() const;
00152
00153     Flags                   m_flags;
00154     NewsStory               m_newsStory;
00155     Feed::UpdateId          m_updateId;
00156     SubscriptionCookieList  m_subscriptionCookieList;
00157 };
00158
00159 // ---------------------------------------------------------------------------------------------------------------------------------
00160
00161 inline bool NewsUpdate::IsNewRecord() const
00162 {
00163     return Feed::IsUpdateIdNewRecord(m_updateId);
00164 }
00165
00166 // ---------------------------------------------------------------------------------------------------------------------------------
00167
00168 inline bool NewsUpdate::IsDelete() const
00169 {
00170     return m_flags & FLAG_DELETE;
00171 }
00172
00173 #undef ACTIV_DECLARE_FLAGS
00174
00175 } // namespace ContentGatewayApi
00176
00177 } // namespace ContentPlatform
00178
00179 } // namespace Activ
00180
00181 #endif // (!defined ACTIV_CONTENT_GATEWAY_API_COMMON_NEWS_TYPES_H)
Generated on Wed Oct 8 14:01:45 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivContentGatewayApi

NewsUpdateHelper.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_CONTENT_GATEWAY_API_NEWS_UPDATE_HELPER_H)
00010 #define ACTIV_CONTENT_GATEWAY_API_NEWS_UPDATE_HELPER_H
00011
00012 #include "ActivContentPlatform/ActivContentGatewayApi/External.h"
00013
00014 namespace Activ
00015 {
00016
00017 namespace ContentPlatform
00018 {
00019
00020 namespace ContentGatewayApi
00021 {
00022
00023 class ContentGatewayClient;
00024
00025 // ---------------------------------------------------------------------------------------------------------------------------------
00026
00030 class NewsUpdateHelper
00031 {
00032 public:
00044     ACTIV_CONTENT_GATEWAY_API static StatusCode Deserialize(const ContentGatewayClient &client, const HeapMessage &update,
00045         NewsUpdate &newsUpdate);
00046 };
00047
00048 } // namespace ContentGatewayApi
00049
00050 } // namespace ContentPlatform
00051
00052 } // namespace Activ
00053
00054 #endif // (!defined ACTIV_CONTENT_GATEWAY_API_NEWS_UPDATE_HELPER_H)
Generated on Wed Oct 8 14:01:45 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » Config » Platforms

OSX.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_CONFIG_PLATFORMS_OSX_H)
00010 #define ACTIV_CONFIG_PLATFORMS_OSX_H
00011
00012 #define ACTIV_PLATFORM_NAME "OSX"
00013 #define ACTIV_PLATFORM_TYPE Activ::PLATFORM_TYPE_OSX
00014
00015 #define __STDC_LIBRARY_SUPPORTED__
00016
00017 #define ACTIV_HAS_INTTYPES_H
00018 #define ACTIV_EXPLICIT_INSTANTIATE_SIZE_T
00019
00020 #include "Posix.h"
00021
00022 #endif // (!defined ACTIV_CONFIG_PLATFORMS_OSX_H)
Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » Misc

ObjectPool.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_MISC_OBJECT_POOL_H)
00010 #define ACTIV_MISC_OBJECT_POOL_H
00011
00012 #include "ActivMiddleware/Misc/FunctionObjects.h"
00013 #include "ActivMiddleware/Misc/Singleton.h"
00014 #include "ActivMiddleware/Misc/StlHelper.h"
00015 #include "ActivMiddleware/ActivBase/StatusCodeException.h"
00016
00017 #include <set>
00018 #include <vector>
00019
00020 namespace Activ
00021 {
00022
00032 template <typename T, size_t INITIAL_FREE_LIST_SIZE = 0, size_t MAX_FREE_LIST_SIZE = 0>
00033 class ObjectPool : public Singleton<ObjectPool<T, INITIAL_FREE_LIST_SIZE, MAX_FREE_LIST_SIZE> >
00034 {
00035 public:
00036     BOOST_STATIC_ASSERT(INITIAL_FREE_LIST_SIZE <= MAX_FREE_LIST_SIZE);
00037
00038     typedef T ObjectType;
00039
00043     class Stats
00044     {
00045     public:
00046         size_t  m_currentInUseCount;
00047         size_t  m_maximumInUseCount;
00048
00049         size_t  m_initialFreeListSize;
00050         size_t  m_currentFreeListSize;
00051         size_t  m_maximumFreeListSize;
00052         size_t  m_maximumAllowedFreeListSize;
00053     };
00054
00060     T *Get();
00061
00071     bool Return(T * const pObject);
00072
00078     void ReturnAll();
00079
00083     void DestroyAll();
00084
00090     Stats GetStats() const;
00091
00097     static ObjectPool &GetInstance();
00098
00099 private:
00103     ObjectPool();
00104
00108     ~ObjectPool();
00109
00110     typedef std::set<T *> ObjectSet;
00111     typedef std::vector<T *> ObjectList;
00112
00113     ObjectSet   m_inUseSet;
00114     ObjectList  m_freeList;
00115
00116     size_t      m_maximumInUseCount;
00117     size_t      m_initialFreeListSize;
00118     size_t      m_maximumFreeListSize;
00119
00120     friend class Singleton<ObjectPool<T, INITIAL_FREE_LIST_SIZE, MAX_FREE_LIST_SIZE> >;
00121 };
00122
00123 // ---------------------------------------------------------------------------------------------------------------------------------
00124 // ---------------------------------------------------------------------------------------------------------------------------------
00125
00131 template<typename T>
00132 class ScopedPooledObject
00133 {
00134 public:
00135     typedef typename T::ObjectType ObjectType;
00136
00142     ScopedPooledObject();
00143
00149     ~ScopedPooledObject();
00150
00156     ObjectType &operator()();
00157
00163     const ObjectType &operator()() const;
00164
00165 private:
00166     ObjectType * const  m_p;
00167 };
00168
00169 // ---------------------------------------------------------------------------------------------------------------------------------
00170 // ---------------------------------------------------------------------------------------------------------------------------------
00171
00172 template <typename T, size_t INITIAL_FREE_LIST_SIZE, size_t MAX_FREE_LIST_SIZE>
00173 T * ObjectPool<T, INITIAL_FREE_LIST_SIZE, MAX_FREE_LIST_SIZE>::Get()
00174 {
00175     T *pObject;
00176
00177     if (m_freeList.empty())
00178     {
00179         pObject = new (std::nothrow) T;
00180         if (0 == pObject)
00181             return 0;
00182     }
00183     else
00184     {
00185         pObject = m_freeList.back();
00186         m_freeList.pop_back();
00187     }
00188
00189     (void) m_inUseSet.insert(pObject);
00190
00191     if (m_inUseSet.size() > m_maximumInUseCount)
00192         m_maximumInUseCount = m_inUseSet.size();
00193
00194     return pObject;
00195 }
00196
00197 // ---------------------------------------------------------------------------------------------------------------------------------
00198
00199 template <typename T, size_t INITIAL_FREE_LIST_SIZE, size_t MAX_FREE_LIST_SIZE>
00200 bool ObjectPool<T, INITIAL_FREE_LIST_SIZE, MAX_FREE_LIST_SIZE>::Return(T * const pObject)
00201 {
00202     typename ObjectSet::iterator iter = m_inUseSet.find(pObject);
00203
00204     if (m_inUseSet.end() == iter)
00205         return false;
00206
00207     m_inUseSet.erase(iter);
00208
00209     if ((0 == MAX_FREE_LIST_SIZE) || (m_freeList.size() < MAX_FREE_LIST_SIZE))
00210     {
00211         m_freeList.push_back(pObject);
00212
00213         if (m_freeList.size() > m_maximumFreeListSize)
00214             m_maximumFreeListSize = m_freeList.size();
00215     }
00216     else
00217     {
00218         delete pObject;
00219     }
00220
00221     return true;
00222 }
00223
00224 // ---------------------------------------------------------------------------------------------------------------------------------
00225
00226 template <typename T, size_t INITIAL_FREE_LIST_SIZE, size_t MAX_FREE_LIST_SIZE>
00227 void ObjectPool<T, INITIAL_FREE_LIST_SIZE, MAX_FREE_LIST_SIZE>::ReturnAll()
00228 {
00229     // Move from the in use set to the free list
00230     std::copy(m_inUseSet.begin(), m_inUseSet.end(), std::back_inserter(m_freeList));
00231     m_inUseSet.clear();
00232
00233     // And trim if necessary
00234     if ((0 != MAX_FREE_LIST_SIZE) && (m_freeList.size() > MAX_FREE_LIST_SIZE))
00235     {
00236         std::for_each(m_freeList.begin() + MAX_FREE_LIST_SIZE, m_freeList.end(), DeleteObject());
00237         m_freeList.erase(m_freeList.begin() + MAX_FREE_LIST_SIZE, m_freeList.end());
00238     }
00239 }
00240
00241 // ---------------------------------------------------------------------------------------------------------------------------------
00242
00243 template <typename T, size_t INITIAL_FREE_LIST_SIZE, size_t MAX_FREE_LIST_SIZE>
00244 void ObjectPool<T, INITIAL_FREE_LIST_SIZE, MAX_FREE_LIST_SIZE>::DestroyAll()
00245 {
00246     std::for_each(m_inUseSet.begin(), m_inUseSet.end(), DeleteObject());
00247     m_inUseSet.clear();
00248
00249     std::for_each(m_freeList.begin(), m_freeList.end(), DeleteObject());
00250     EmptyVector(m_freeList);
00251 }
00252
00253 // ---------------------------------------------------------------------------------------------------------------------------------
00254
00255 template <typename T, size_t INITIAL_FREE_LIST_SIZE, size_t MAX_FREE_LIST_SIZE>
00256 typename ObjectPool<T, INITIAL_FREE_LIST_SIZE, MAX_FREE_LIST_SIZE>::Stats ObjectPool<T, INITIAL_FREE_LIST_SIZE, MAX_FREE_LIST_SIZE>::GetStats() const
00257 {
00258     Stats stats;
00259
00260     stats.m_currentInUseCount = m_inUseSet.size();
00261     stats.m_maximumInUseCount = m_maximumInUseCount;
00262
00263     stats.m_initialFreeListSize = m_initialFreeListSize;
00264     stats.m_currentFreeListSize = m_freeList.size();
00265     stats.m_maximumFreeListSize = m_maximumFreeListSize;
00266     stats.m_maximumAllowedFreeListSize = MAX_FREE_LIST_SIZE;
00267
00268     return stats;
00269 }
00270
00271 // ---------------------------------------------------------------------------------------------------------------------------------
00272
00273 template <typename T, size_t INITIAL_FREE_LIST_SIZE, size_t MAX_FREE_LIST_SIZE>
00274 ObjectPool<T, INITIAL_FREE_LIST_SIZE, MAX_FREE_LIST_SIZE> &ObjectPool<T, INITIAL_FREE_LIST_SIZE, MAX_FREE_LIST_SIZE>::GetInstance()
00275 {
00276     static ObjectPool objectPool;
00277
00278     return objectPool;
00279 }
00280
00281 // ---------------------------------------------------------------------------------------------------------------------------------
00282
00283 template <typename T, size_t INITIAL_FREE_LIST_SIZE, size_t MAX_FREE_LIST_SIZE>
00284 ObjectPool<T, INITIAL_FREE_LIST_SIZE, MAX_FREE_LIST_SIZE>::ObjectPool() :
00285     m_maximumInUseCount(0)
00286 {
00287     m_freeList.reserve(INITIAL_FREE_LIST_SIZE);
00288
00289     for (size_t i = 0; i < INITIAL_FREE_LIST_SIZE; ++i)
00290     {
00291         T *pObject = new (std::nothrow) T;
00292
00293         if (0 != pObject)
00294             m_freeList.push_back(pObject);
00295     }
00296
00297     m_initialFreeListSize = m_freeList.size();
00298     m_maximumFreeListSize = m_initialFreeListSize;
00299 }
00300
00301 // ---------------------------------------------------------------------------------------------------------------------------------
00302
00303 template <typename T, size_t INITIAL_FREE_LIST_SIZE, size_t MAX_FREE_LIST_SIZE>
00304 ObjectPool<T, INITIAL_FREE_LIST_SIZE, MAX_FREE_LIST_SIZE>::~ObjectPool()
00305 {
00306     DestroyAll();
00307 }
00308
00309 // ---------------------------------------------------------------------------------------------------------------------------------
00310 // ---------------------------------------------------------------------------------------------------------------------------------
00311
00312 template<typename T>
00313 inline ScopedPooledObject<T>::ScopedPooledObject() :
00314     m_p(T::GetInstance().Get())
00315 {
00316     if (0 == m_p)
00317         ACTIV_THROW(StatusCodeException, STATUS_CODE_HEAP_EMPTY);
00318 }
00319
00320 // ---------------------------------------------------------------------------------------------------------------------------------
00321
00322 template<typename T>
00323 inline ScopedPooledObject<T>::~ScopedPooledObject()
00324 {
00325     (void) T::GetInstance().Return(m_p);
00326 }
00327
00328 // ---------------------------------------------------------------------------------------------------------------------------------
00329
00330 template<typename T>
00331 inline typename T::ObjectType &ScopedPooledObject<T>::operator()()
00332 {
00333     return *m_p;
00334 }
00335
00336 // ---------------------------------------------------------------------------------------------------------------------------------
00337
00338 template<typename T>
00339 inline const typename T::ObjectType &ScopedPooledObject<T>::operator()() const
00340 {
00341     return *m_p;
00342 }
00343
00344 } // namespace Activ
00345
00346 #endif // (!defined ACTIV_MISC_OBJECT_POOL_H)
Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivContentGatewayApiCommon

OptionBar.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_CONTENT_GATEWAY_API_COMMON_OPTION_BAR_H)
00010 #define ACTIV_CONTENT_GATEWAY_API_COMMON_OPTION_BAR_H
00011
00012 #include "ActivContentPlatform/ActivContentGatewayApiCommon/External.h"
00013 #include "ActivContentPlatform/ActivContentGatewayApiCommon/FieldSet.h"
00014
00015 #include "ActivMiddleware/ActivFieldTypes/Date.h"
00016 #include "ActivMiddleware/ActivFieldTypes/Time.h"
00017 #include "ActivMiddleware/ActivFieldTypes/Rational.h"
00018
00019 #include "ActivMiddleware/Misc/SerializableVector.h"
00020
00021 namespace Activ
00022 {
00023
00024 namespace ContentPlatform
00025 {
00026
00027 namespace ContentGatewayApi
00028 {
00029
00030 #define ACTIV_DECLARE_BYTES(value, id)  static const byte_t id = value;
00031
00032 // ---------------------------------------------------------------------------------------------------------------------------------
00033
00037 class OptionBar : public FieldSet
00038 {
00039 public:
00043     OptionBar();
00044
00048     virtual ~OptionBar();
00049
00053     virtual void Reset();
00054
00065     virtual StatusCode GetField(const Feed::FieldId fieldId, IFieldType &field) const;
00066
00077     virtual StatusCode SetField(const Feed::FieldId fieldId, const IFieldType &field);
00078
00084     virtual FieldSetType GetType() const;
00085
00091     virtual std::string ToString() const;
00092
00101     virtual StatusCode Serialize(MessageBuilder &messageBuilder) const;
00102
00111     virtual StatusCode Deserialize(MessageValidator &messageValidator);
00112
00118     virtual size_t GetSerializedLength() const;
00119
00125     static size_t GetMaxSerializedLength();
00126
00134     bool Compare(const OptionBar &rhs) const;
00135
00143     bool operator==(const OptionBar &rhs) const;
00144
00152     bool operator!=(const OptionBar &rhs) const;
00153
00161     bool operator<(const OptionBar &rhs) const;
00162
00170     bool operator<=(const OptionBar &rhs) const;
00171
00179     bool operator>(const OptionBar &rhs) const;
00180
00188     bool operator>=(const OptionBar &rhs) const;
00189
00195     void Reduce(const Rational::Denominator minDenominator = Rational::DENOMINATOR_2DP);
00196
00202     Rational::Denominator GetDenominator() const;
00203
00211     StatusCode SetDenominator(const Rational::Denominator denominator);
00212
00221     StatusCode GetDate(Date &date) const;
00222
00231     StatusCode SetDate(const Date &date);
00232
00241     StatusCode GetUnderlyingPrice(Rational &price) const;
00242
00251     StatusCode GetUnderlyingPrice(double &price) const;
00252
00261     StatusCode SetUnderlyingPrice(const Rational &price);
00262
00271     StatusCode GetBidPrice(Rational &price) const;
00272
00281     StatusCode GetBidPrice(double &price) const;
00282
00291     StatusCode SetBidPrice(const Rational &price);
00292
00301     StatusCode GetAskPrice(Rational &price) const;
00302
00311     StatusCode GetAskPrice(double &price) const;
00312
00321     StatusCode SetAskPrice(const Rational &price);
00322
00331     StatusCode GetTotalVolume(unsigned &volume) const;
00332
00341     StatusCode SetTotalVolume(const unsigned volume);
00342
00351     StatusCode GetOpenInterest(unsigned &openInterest) const;
00352
00361     StatusCode SetOpenInterest(const unsigned openInterest);
00362
00371     StatusCode GetExpirationDate(Date &date) const;
00372
00381     StatusCode SetExpirationDate(const Date &date);
00382
00391     StatusCode GetStrikePrice(Rational &price) const;
00392
00401     StatusCode GetStrikePrice(double &price) const;
00402
00411     StatusCode SetStrikePrice(const Rational &price);
00412
00413 private:
00414     #define ACTIV_OPTION_BAR_FLAG_LIST(d)       \
00415         d(0x10, OPTION_BAR_TOTAL_VOLUME)        \
00416         d(0x20, OPTION_BAR_OPEN_INTEREST)
00417
00418     ACTIV_OPTION_BAR_FLAG_LIST(ACTIV_DECLARE_BYTES)
00419
00420
00427     StatusCode ScalePrice(Rational &price);
00428
00434     StatusCode ScalePrices(const Rational::Denominator denominator);
00435
00436     Date                   m_date;
00437     Date                   m_expirationDate;
00438     int64_t                m_bid;
00439     int64_t                m_ask;
00440     int64_t                m_underlyingPrice;
00441     Rational::Denominator  m_denominator;
00442     Rational               m_strikePrice;
00443     uint32_t               m_totalVolume;
00444     uint32_t               m_openInterest;
00445 };
00446
00447 typedef SerializableVector<OptionBar, uint16_t> OptionBarList;
00448
00449 // ---------------------------------------------------------------------------------------------------------------------------------
00450
00451 inline bool OptionBar::operator==(const OptionBar &rhs) const
00452 {
00453     return Compare(rhs);
00454 }
00455
00456 // ---------------------------------------------------------------------------------------------------------------------------------
00457
00458 inline bool OptionBar::operator!=(const OptionBar &rhs) const
00459 {
00460     return !Compare(rhs);
00461 }
00462
00463 // ---------------------------------------------------------------------------------------------------------------------------------
00464
00465 inline bool OptionBar::operator<(const OptionBar &rhs) const
00466 {
00467     if (m_date < rhs.m_date)
00468         return true;
00469
00470     return false;
00471 }
00472
00473 // ---------------------------------------------------------------------------------------------------------------------------------
00474
00475 inline bool OptionBar::operator<=(const OptionBar &rhs) const
00476 {
00477     if (m_date <= rhs.m_date)
00478         return true;
00479
00480     return false;
00481 }
00482
00483 // ---------------------------------------------------------------------------------------------------------------------------------
00484
00485 inline bool OptionBar::operator>(const OptionBar &rhs) const
00486 {
00487     if (m_date > rhs.m_date)
00488         return true;
00489
00490     return false;
00491 }
00492
00493 // ---------------------------------------------------------------------------------------------------------------------------------
00494
00495 inline bool OptionBar::operator>=(const OptionBar &rhs) const
00496 {
00497     if (m_date >= rhs.m_date)
00498         return true;
00499
00500     return false;
00501 }
00502
00503 // ---------------------------------------------------------------------------------------------------------------------------------
00504
00505 inline Rational::Denominator OptionBar::GetDenominator() const
00506 {
00507     return m_denominator;
00508 }
00509
00510 // ---------------------------------------------------------------------------------------------------------------------------------
00511
00512 inline StatusCode OptionBar::SetDenominator(const Rational::Denominator denominator)
00513 {
00514     // need to scale the prices up here
00515     if (m_denominator != denominator)
00516         ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, ScalePrices(denominator));
00517
00518     m_denominator = denominator;
00519     return STATUS_CODE_SUCCESS;
00520 }
00521
00522 // ---------------------------------------------------------------------------------------------------------------------------------
00523
00524 inline StatusCode OptionBar::GetDate(Date &date) const
00525 {
00526     date = m_date;
00527     return STATUS_CODE_SUCCESS;
00528 }
00529
00530 // ---------------------------------------------------------------------------------------------------------------------------------
00531
00532 inline StatusCode OptionBar::SetDate(const Date &date)
00533 {
00534     m_date = date;
00535     return STATUS_CODE_SUCCESS;
00536 }
00537
00538 // ---------------------------------------------------------------------------------------------------------------------------------
00539
00540 inline StatusCode OptionBar::GetUnderlyingPrice(Rational &price) const
00541 {
00542     return price.Set(m_underlyingPrice, m_denominator);
00543 }
00544
00545 // ---------------------------------------------------------------------------------------------------------------------------------
00546
00547 inline StatusCode OptionBar::GetUnderlyingPrice(double &price) const
00548 {
00549     Rational::DenominatorType  *pDenominatorType;
00550
00551     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, Rational::GetDenominatorType(m_denominator, pDenominatorType));
00552
00553     if (pDenominatorType->IsMultiplier())
00554         price = (double)m_underlyingPrice*pDenominatorType->GetMultiplier();
00555     else if (pDenominatorType->IsDivisor())
00556         price = (double)m_underlyingPrice/pDenominatorType->GetDivisor();
00557     else
00558         return STATUS_CODE_UNDEFINED_FIELD;
00559
00560     return STATUS_CODE_SUCCESS;
00561 }
00562
00563 // ---------------------------------------------------------------------------------------------------------------------------------
00564
00565 inline StatusCode OptionBar::SetUnderlyingPrice(const Rational &price)
00566 {
00567     Rational  temp = price;
00568
00569     // scale the price
00570     if (m_denominator != price.GetDenominator())
00571         ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, ScalePrice(temp));
00572
00573     m_underlyingPrice = temp.GetNumerator();
00574     return STATUS_CODE_SUCCESS;
00575 }
00576
00577 // ---------------------------------------------------------------------------------------------------------------------------------
00578
00579 inline StatusCode OptionBar::GetBidPrice(Rational &price) const
00580 {
00581     return price.Set(m_bid, m_denominator);
00582 }
00583
00584 // ---------------------------------------------------------------------------------------------------------------------------------
00585
00586 inline StatusCode OptionBar::GetBidPrice(double &price) const
00587 {
00588     Rational::DenominatorType  *pDenominatorType;
00589
00590     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, Rational::GetDenominatorType(m_denominator, pDenominatorType));
00591
00592     if (pDenominatorType->IsMultiplier())
00593         price = (double)m_bid*pDenominatorType->GetMultiplier();
00594     else if (pDenominatorType->IsDivisor())
00595         price = (double)m_bid/pDenominatorType->GetDivisor();
00596     else
00597         return STATUS_CODE_UNDEFINED_FIELD;
00598
00599     return STATUS_CODE_SUCCESS;
00600 }
00601
00602 // ---------------------------------------------------------------------------------------------------------------------------------
00603
00604 inline StatusCode OptionBar::SetBidPrice(const Rational &price)
00605 {
00606     Rational  temp = price;
00607
00608     // scale the price
00609     if (m_denominator != price.GetDenominator())
00610         ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, ScalePrice(temp));
00611
00612     m_bid = temp.GetNumerator();
00613     return STATUS_CODE_SUCCESS;
00614 }
00615
00616 // ---------------------------------------------------------------------------------------------------------------------------------
00617
00618 inline StatusCode OptionBar::GetAskPrice(Rational &price) const
00619 {
00620     return price.Set(m_ask, m_denominator);
00621 }
00622
00623 // ---------------------------------------------------------------------------------------------------------------------------------
00624
00625 inline StatusCode OptionBar::GetAskPrice(double &price) const
00626 {
00627     Rational::DenominatorType  *pDenominatorType;
00628
00629     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, Rational::GetDenominatorType(m_denominator, pDenominatorType));
00630
00631     if (pDenominatorType->IsMultiplier())
00632         price = (double)m_ask*pDenominatorType->GetMultiplier();
00633     else if (pDenominatorType->IsDivisor())
00634         price = (double)m_ask/pDenominatorType->GetDivisor();
00635     else
00636         return STATUS_CODE_UNDEFINED_FIELD;
00637
00638     return STATUS_CODE_SUCCESS;
00639 }
00640
00641 // ---------------------------------------------------------------------------------------------------------------------------------
00642
00643 inline StatusCode OptionBar::SetAskPrice(const Rational &price)
00644 {
00645     Rational  temp = price;
00646
00647     // scale the price
00648     if (m_denominator != price.GetDenominator())
00649         ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, ScalePrice(temp));
00650
00651     m_ask = temp.GetNumerator();
00652     return STATUS_CODE_SUCCESS;
00653 }
00654
00655 // ---------------------------------------------------------------------------------------------------------------------------------
00656
00657 inline StatusCode OptionBar::GetTotalVolume(unsigned &volume) const
00658 {
00659     volume = m_totalVolume;
00660     return STATUS_CODE_SUCCESS;
00661 }
00662
00663 // ---------------------------------------------------------------------------------------------------------------------------------
00664
00665 inline StatusCode OptionBar::SetTotalVolume(const unsigned volume)
00666 {
00667     m_totalVolume = volume;
00668     return STATUS_CODE_SUCCESS;
00669 }
00670
00671 // ---------------------------------------------------------------------------------------------------------------------------------
00672
00673 inline StatusCode OptionBar::GetOpenInterest(unsigned &openInterest) const
00674 {
00675     openInterest = m_openInterest;
00676     return STATUS_CODE_SUCCESS;
00677 }
00678
00679 // ---------------------------------------------------------------------------------------------------------------------------------
00680
00681 inline StatusCode OptionBar::SetOpenInterest(const unsigned openInterest)
00682 {
00683     m_openInterest = openInterest;
00684     return STATUS_CODE_SUCCESS;
00685 }
00686
00687 // ---------------------------------------------------------------------------------------------------------------------------------
00688
00689 inline StatusCode OptionBar::GetExpirationDate(Date &date) const
00690 {
00691     date = m_date;
00692     return STATUS_CODE_SUCCESS;
00693 }
00694
00695 // ---------------------------------------------------------------------------------------------------------------------------------
00696
00697 inline StatusCode OptionBar::SetExpirationDate(const Date &date)
00698 {
00699     m_date = date;
00700     return STATUS_CODE_SUCCESS;
00701 }
00702
00703 // ---------------------------------------------------------------------------------------------------------------------------------
00704
00705 inline StatusCode OptionBar::GetStrikePrice(Rational &price) const
00706 {
00707     price = m_strikePrice;
00708     return STATUS_CODE_SUCCESS;
00709 }
00710
00711 // ---------------------------------------------------------------------------------------------------------------------------------
00712
00713 inline StatusCode OptionBar::GetStrikePrice(double &price) const
00714 {
00715     Rational::DenominatorType  *pDenominatorType;
00716
00717     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, Rational::GetDenominatorType(m_strikePrice.GetDenominator(), pDenominatorType));
00718
00719     if (pDenominatorType->IsMultiplier())
00720         price = (double)m_strikePrice.GetNumerator()*pDenominatorType->GetMultiplier();
00721     else if (pDenominatorType->IsDivisor())
00722         price = (double)m_strikePrice.GetNumerator()/pDenominatorType->GetDivisor();
00723     else
00724         return STATUS_CODE_UNDEFINED_FIELD;
00725
00726     return STATUS_CODE_SUCCESS;
00727 }
00728
00729 // ---------------------------------------------------------------------------------------------------------------------------------
00730
00731 inline StatusCode OptionBar::SetStrikePrice(const Rational &price)
00732 {
00733     m_strikePrice = price;
00734     return STATUS_CODE_SUCCESS;
00735 }
00736
00737 #undef ACTIV_DECLARE_BYTES
00738
00739 } // namespace ContentGatewayApi
00740
00741 } // namespace ContentPlatform
00742
00743 } // namespace Activ
00744
00745 #endif // (!defined ACTIV_CONTENT_GATEWAY_API_COMMON_OPTION_BAR_H)
Generated on Wed Oct 8 14:01:45 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

OsException.h

Go to the documentation of this file.
00001
00012 #if (!defined ACTIV_BASE_OS_EXCEPTION_H)
00013 #define ACTIV_BASE_OS_EXCEPTION_H
00014
00015 #include "ActivMiddleware/ActivBase/Exception.h"
00016
00017 #if (!defined ACTIV_PLATFORM_WINDOWS)
00018 #include "ActivMiddleware/ActivBase/CrtException.h"
00019 namespace Activ
00020 {
00021 typedef CrtException OsException;
00022 }
00023 #else
00024
00025 namespace Activ
00026 {
00027
00031 class OsException : public Exception
00032 {
00033 public:
00042     ACTIV_BASE_EXPORTED_API OsException(const char *file, const char *function, uint_fast32_t line, const uint_fast32_t errorCode);
00043
00044     ACTIV_BASE_EXPORTED_API virtual std::string ToString() const;
00045 };
00046
00047 } // namespace Activ
00048
00049 #endif // (defined ACTIV_PLATFORM_WINDOWS)
00050
00051 #endif // (!defined ACTIV_BASE_OS_EXCEPTION_H)
Generated on Wed Oct 8 14:01:47 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

PagingFileMappedMemoryFactory.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_BASE_PAGING_FILE_MAPPED_MEMORY_FACTORY_H)
00010 #define ACTIV_BASE_PAGING_FILE_MAPPED_MEMORY_FACTORY_H
00011
00012 #include "ActivMiddleware/ActivBase/External.h"
00013 #include "ActivMiddleware/ActivBase/IMappedMemory.h"
00014 #include "ActivMiddleware/ActivBase/Timeout.h"
00015 #include "ActivMiddleware/Misc/Singleton.h"
00016
00017 #include <string>
00018
00019 namespace Activ
00020 {
00021
00025 class PagingFileMappedMemoryFactory : public Singleton<PagingFileMappedMemoryFactory>
00026 {
00027 public:
00039     ACTIV_BASE_EXPORTED_API IMappedMemory *Create(const std::string &name, const size_t size,
00040         const IMappedMemory::MappingFlags mappingFlags = IMappedMemory::MAPPING_FLAG_NONE);
00041
00052     ACTIV_BASE_EXPORTED_API IMappedMemory *Create(const size_t size,
00053         const IMappedMemory::MappingFlags mappingFlags = IMappedMemory::MAPPING_FLAG_NONE);
00054
00067     ACTIV_BASE_EXPORTED_API IMappedMemory *Open(const std::string &name,
00068         const IMappedMemory::MappingFlags mappingFlags = IMappedMemory::MAPPING_FLAG_NONE,
00069         Timeout &timeout = Timeout::GetInfinite());
00070
00076     ACTIV_BASE_EXPORTED_API static PagingFileMappedMemoryFactory &GetInstance();
00077
00078 private:
00082     ACTIV_BASE_EXPORTED_API PagingFileMappedMemoryFactory();
00083
00084     friend class Singleton<PagingFileMappedMemoryFactory>;
00085 };
00086
00087 } // namespace Activ
00088
00089 #endif // (!defined ACTIV_BASE_PAGING_FILE_MAPPED_MEMORY_FACTORY_H)
Generated on Wed Oct 8 14:01:47 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon

PermissionIdHelper.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FEED_COMMON_PERMISSION_ID_HELPER_H)
00010 #define ACTIV_FEED_COMMON_PERMISSION_ID_HELPER_H
00011
00012 #include "ActivContentPlatform/ActivFeedCommon/External.h"
00013 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedDefinitions.h"
00014 #include "ActivContentPlatform/ActivFeedCommon/PermissionIds.h"
00015
00016 namespace Activ
00017 {
00018
00019 namespace ContentPlatform
00020 {
00021
00022 namespace Feed
00023 {
00024
00028 class PermissionIdHelper
00029 {
00030 public:
00034     PermissionIdHelper();
00035
00043     PermissionIdHelper(const PermissionId permissionId, const char * const pName, const char * const pCodeIdentifier);
00044
00045     PermissionId        m_permissionId;
00046     std::string         m_name;
00047     std::string         m_codeIdentifier;
00048 };
00049
00050 // ---------------------------------------------------------------------------------------------------------------------------------
00051
00052 inline PermissionIdHelper::PermissionIdHelper() :
00053     m_permissionId(PERMISSION_ID_NONE)
00054 {
00055 }
00056
00057 // ---------------------------------------------------------------------------------------------------------------------------------
00058
00059 inline PermissionIdHelper::PermissionIdHelper(const PermissionId permissionId, const char * const pName, const char * const pCodeIdentifier) :
00060     m_permissionId(permissionId),
00061     m_name(pName),
00062     m_codeIdentifier(pCodeIdentifier)
00063 {
00064 }
00065
00066 // ---------------------------------------------------------------------------------------------------------------------------------
00067 // ---------------------------------------------------------------------------------------------------------------------------------
00068
00076 ACTIV_FEED_COMMON_API const PermissionIdHelper &GetPermissionIdHelper(const PermissionId permissionId);
00077
00085 ACTIV_FEED_COMMON_API std::string GetPermissionIdName(const PermissionId permissionId);
00086
00094 ACTIV_FEED_COMMON_API std::string GetPermissionIdCodeIdentifier(const PermissionId permissionId);
00095
00096 } // namespace Feed
00097
00098 } // namespace ContentPlatform
00099
00100 } // namespace Activ
00101
00102 #endif // (!defined ACTIV_FEED_COMMON_PERMISSION_ID_HELPER_H)
Generated on Wed Oct 8 14:01:46 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon

PermissionIds.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FEED_COMMON_PERMISSION_IDS_H)
00010 #define ACTIV_FEED_COMMON_PERMISSION_IDS_H
00011
00012 #include "ActivMiddleware/Activ.h"
00013
00014 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedDefinitions.h"
00015
00016 namespace Activ
00017 {
00018
00019 namespace ContentPlatform
00020 {
00021
00022 namespace Feed
00023 {
00024
00025 const PermissionId PERMISSION_ID_UNKNOWN = static_cast<PermissionId>(~0);
00026 const PermissionId PERMISSION_ID_LIST = PERMISSION_ID_UNKNOWN - 1;
00027
00028 const PermissionId PERMISSION_ID_NONE = 0;
00029 const PermissionId PERMISSION_ID_NASDAQ_LEVEL1 = 1;
00030 const PermissionId PERMISSION_ID_NASDAQ_LEVEL2 = 2;
00031 const PermissionId PERMISSION_ID_NASDAQ_INDEX = 3;
00032 const PermissionId PERMISSION_ID_NASDAQ_ADF = 4;
00033 const PermissionId PERMISSION_ID_NYSE = 5;
00034 const PermissionId PERMISSION_ID_NYSE_INDEX = 6;
00035 const PermissionId PERMISSION_ID_AMEX = 7;
00036 const PermissionId PERMISSION_ID_AMEX_INDEX = 8;
00037 const PermissionId PERMISSION_ID_OPRA_COMPOSITE = 9;
00038 const PermissionId PERMISSION_ID_OPRA_FCO = 10;
00039 const PermissionId PERMISSION_ID_OPRA_INDEX = 11;
00040 const PermissionId PERMISSION_ID_OPRA_FOREX = 12;
00041 const PermissionId PERMISSION_ID_CBOT = 13;
00042 const PermissionId PERMISSION_ID_CBOT_MINI = 14;
00043 const PermissionId PERMISSION_ID_CBOT_DJ_INDEX = 15;
00044 const PermissionId PERMISSION_ID_KCBOT = 16;
00045 const PermissionId PERMISSION_ID_NYMEX = 17;
00046 const PermissionId PERMISSION_ID_COMEX = 18;
00047 const PermissionId PERMISSION_ID_ICE_FUTURES_US = 19;
00048 const PermissionId PERMISSION_ID_CORPORATE_ACTION = 20;
00049 const PermissionId PERMISSION_ID_SECURITY = 21;
00050 const PermissionId PERMISSION_ID_COMPANY = 22;
00051 const PermissionId PERMISSION_ID_TSX_LEVEL1 = 23;
00052 const PermissionId PERMISSION_ID_TSX_LEVEL2 = 24;
00053 const PermissionId PERMISSION_ID_TSX_INDEX = 25;
00054 const PermissionId PERMISSION_ID_TSX_VENTURE_LEVEL1 = 26;
00055 const PermissionId PERMISSION_ID_TSX_VENTURE_LEVEL2 = 27;
00056 const PermissionId PERMISSION_ID_TSX_VENTURE_INDEX = 28;
00057 const PermissionId PERMISSION_ID_NASDAQ_MFDS = 29;
00058 const PermissionId PERMISSION_ID_DJN = 30;
00059 const PermissionId PERMISSION_ID_COMTEX = 31;
00060 const PermissionId PERMISSION_ID_CME = 32;
00061 const PermissionId PERMISSION_ID_CME_E_MINI_LEVEL1 = 33;
00062 const PermissionId PERMISSION_ID_CME_E_MINI_LEVEL2 = 34;
00063 const PermissionId PERMISSION_ID_CME_GLOBEX_LEVEL1 = 35;
00064 const PermissionId PERMISSION_ID_CME_GLOBEX_LEVEL2 = 36;
00065 const PermissionId PERMISSION_ID_CME_SP_INDEX = 37;
00066 const PermissionId PERMISSION_ID_INTERNAL = 38;
00067 const PermissionId PERMISSION_ID_NYSE_ARCA = 39;
00068 const PermissionId PERMISSION_ID_BRUT = 40;
00069 const PermissionId PERMISSION_ID_INET = 41;
00070 const PermissionId PERMISSION_ID_OPRA_REGIONAL = 42;
00071 const PermissionId PERMISSION_ID_MONTREAL_LEVEL1 = 43;
00072 const PermissionId PERMISSION_ID_ONE_CHICAGO = 44;
00073 const PermissionId PERMISSION_ID_TENFORE = 45;
00074 const PermissionId PERMISSION_ID_CFE = 46;
00075 const PermissionId PERMISSION_ID_TSX_FOREX = 47;
00076 const PermissionId PERMISSION_ID_ASX = 48;
00077 const PermissionId PERMISSION_ID_HEMSCOTT = 49;
00078 const PermissionId PERMISSION_ID_CNQ = 50;
00079 const PermissionId PERMISSION_ID_COMTEX_PUBCO_CANADA = 51;
00080 const PermissionId PERMISSION_ID_COMTEX_PUBLIC_COMPANIES = 52;
00081 const PermissionId PERMISSION_ID_WORKSTATION_FULL = 53;
00082 const PermissionId PERMISSION_ID_NEWSTEX = 54;
00083 const PermissionId PERMISSION_ID_AMX = 55;
00084 const PermissionId PERMISSION_ID_PBOT = 56;
00085 const PermissionId PERMISSION_ID_TSX_NEWS = 57;
00086 const PermissionId PERMISSION_ID_NASDAQ_TOTAL_VIEW = 58;
00087 const PermissionId PERMISSION_ID_NYSE_OPEN_BOOK = 59;
00088 const PermissionId PERMISSION_ID_MONTREAL_LEVEL2 = 60;
00089 const PermissionId PERMISSION_ID_MIDNIGHT_TRADER_EXTENDED = 61;
00090 const PermissionId PERMISSION_ID_NASDAQ_OPEN_VIEW = 62;
00091 const PermissionId PERMISSION_ID_MIDNIGHT_TRADER_EARNINGS = 63;
00092 const PermissionId PERMISSION_ID_PINK_SHEETS_LEVEL2 = 64;
00093 const PermissionId PERMISSION_ID_MGEX = 65;
00094 const PermissionId PERMISSION_ID_EUREX = 66;
00095 const PermissionId PERMISSION_ID_SYDNEY_FUTURES = 67;
00096 const PermissionId PERMISSION_ID_CBOE_INDEX = 68;
00097 const PermissionId PERMISSION_ID_ICE_FUTURES_EUROPE = 69;
00098 const PermissionId PERMISSION_ID_DIRECT_EDGE = 70;
00099 const PermissionId PERMISSION_ID_AMEX_DEPTH_OF_BOOK = 71;
00100 const PermissionId PERMISSION_ID_TSE = 72;
00101 const PermissionId PERMISSION_ID_SGX = 73;
00102 const PermissionId PERMISSION_ID_BOX_LEVEL1 = 74;
00103 const PermissionId PERMISSION_ID_BOX_LEVEL2 = 75;
00104 const PermissionId PERMISSION_ID_NSX = 76;
00105 const PermissionId PERMISSION_ID_ICE_FUTURES_CANADA = 77;
00106 const PermissionId PERMISSION_ID_LME = 78;
00107 const PermissionId PERMISSION_ID_PURE_TRADING_LEVEL1 = 79;
00108 const PermissionId PERMISSION_ID_PURE_TRADING_LEVEL2 = 80;
00109 const PermissionId PERMISSION_ID_PINK_SHEETS_LEVEL1 = 81;
00110 const PermissionId PERMISSION_ID_NAGOYA = 82;
00111 const PermissionId PERMISSION_ID_FUKUOKA = 83;
00112 const PermissionId PERMISSION_ID_SAPPORO = 84;
00113 const PermissionId PERMISSION_ID_HKSE = 85;
00114 const PermissionId PERMISSION_ID_OSE = 86;
00115 const PermissionId PERMISSION_ID_BATS = 87;
00116 const PermissionId PERMISSION_ID_DUBAI_MERCANTILE_EXCHANGE = 88;
00117 const PermissionId PERMISSION_ID_ICE_LEVEL2 = 89;
00118 const PermissionId PERMISSION_ID_ITA_LEVEL1 = 90;
00119 const PermissionId PERMISSION_ID_ITA_LEVEL2 = 91;
00120 const PermissionId PERMISSION_ID_JASDAQ_LEVEL1 = 92;
00121 const PermissionId PERMISSION_ID_JASDAQ_LEVEL2 = 93;
00122 const PermissionId PERMISSION_ID_EURONEXT_LIFFE_LEVEL1 = 94;
00123 const PermissionId PERMISSION_ID_EURONEXT_PARIS_LEVEL1 = 95;
00124 const PermissionId PERMISSION_ID_EURONEXT_LIFFE_LEVEL2 = 96;
00125 const PermissionId PERMISSION_ID_EURONEXT_PARIS_LEVEL2 = 97;
00126 const PermissionId PERMISSION_ID_HKFE = 98;
00127 const PermissionId PERMISSION_ID_LSE_UK_LEVEL1 = 99;
00128 const PermissionId PERMISSION_ID_LSE_UK_LEVEL2 = 100;
00129 const PermissionId PERMISSION_ID_LSE_INTERNATIONAL_LEVEL1 = 101;
00130 const PermissionId PERMISSION_ID_LSE_INTERNATIONAL_LEVEL2 = 102;
00131 const PermissionId PERMISSION_ID_LSE_EUROPEAN_LEVEL1 = 103;
00132 const PermissionId PERMISSION_ID_LSE_EUROPEAN_LEVEL2 = 104;
00133 const PermissionId PERMISSION_ID_BOVESPA_LEVEL1 = 105;
00134 const PermissionId PERMISSION_ID_BOVESPA_LEVEL2 = 106;
00135 const PermissionId PERMISSION_ID_SGX_DERIVATIVES = 107;
00136 const PermissionId PERMISSION_ID_CHX = 108;
00137 const PermissionId PERMISSION_ID_ISE = 109;
00138 const PermissionId PERMISSION_ID_TOCOM = 110;
00139 const PermissionId PERMISSION_ID_MCEX = 111;
00140 const PermissionId PERMISSION_ID_INSTINET_CBX = 112;
00141 const PermissionId PERMISSION_ID_TAIFEX_LEVEL1 = 113;
00142 const PermissionId PERMISSION_ID_TAIFEX_LEVEL2 = 114;
00143 const PermissionId PERMISSION_ID_CHI_X_CANADA = 115;
00144 const PermissionId PERMISSION_ID_CHI_X_EUROPE = 116;
00145 const PermissionId PERMISSION_ID_NASDAQ_INDEX_CONSTITUENTS = 117;
00146 const PermissionId PERMISSION_ID_NYSE_CORPORATE_ACTION = 118;
00147 const PermissionId PERMISSION_ID_NYSE_ARCA_OPTIONS = 119;
00148 const PermissionId PERMISSION_ID_LME_STEEL = 120;
00149 const PermissionId PERMISSION_ID_LME_PLASTICS = 121;
00150 const PermissionId PERMISSION_ID_BMF_LEVEL1 = 122;
00151 const PermissionId PERMISSION_ID_BMF_LEVEL2 = 123;
00152 const PermissionId PERMISSION_ID_BME = 124;
00153 const PermissionId PERMISSION_ID_TSEC = 125;
00154 const PermissionId PERMISSION_ID_RYDEX = 126;
00155 const PermissionId PERMISSION_ID_ALPHA_TRADING = 127;
00156
00157 const PermissionId PERMISSION_ID_COUNT = 128;
00158
00159 // ---------------------------------------------------------------------------------------------------------------------------------
00160
00168 inline bool IsActualPermissionId(const PermissionId permissionId)
00169 {
00170     return ((PERMISSION_ID_UNKNOWN != permissionId) && (PERMISSION_ID_LIST != permissionId));
00171 }
00172
00173 } // namespace Feed
00174
00175 } // namespace ContentPlatform
00176
00177 } // namespace Activ
00178
00179 #endif // (!defined ACTIV_FEED_COMMON_PERMISSION_IDS_H)
Generated on Wed Oct 8 14:01:46 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedPermissioning

PermissionInfo.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FEED_PERMISSIONING_PERMISSION_INFO_H)
00010 #define ACTIV_FEED_PERMISSIONING_PERMISSION_INFO_H
00011
00012 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedDefinitions.h"
00013 #include "ActivContentPlatform/ActivFeedCommon/PermissionLevels.h"
00014
00015 namespace Activ
00016 {
00017
00018 namespace ContentPlatform
00019 {
00020
00021 namespace Feed
00022 {
00023
00027 class PermissionInfo
00028 {
00029 public:
00033     class PermissionIdInfo
00034     {
00035     public:
00036         enum Type
00037         {
00038             TYPE_INCLUDE_FIELDS,
00039             TYPE_ALL_FIELDS,
00040             TYPE_EXCLUDE_FIELDS
00041         };
00042
00043         Type                m_type;
00044         std::string         m_name;
00045         Feed::FieldIdList   m_fieldIdList;
00046     };
00047
00051     typedef std::map<Feed::PermissionId, PermissionIdInfo> PermissionIdInfoMap;
00052
00056     PermissionIdInfoMap m_permissionLevelInfo[Feed::PERMISSION_LEVEL_COUNT];
00057 };
00058
00059 } // namespace Feed
00060
00061 } // namespace ContentPlatform
00062
00063 } // namespace Activ
00064
00065 #endif // (!defined ACTIV_FEED_PERMISSIONING_PERMISSION_INFO_H)
Generated on Wed Oct 8 14:01:46 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon

PermissionLevels.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FEED_COMMON_PERMISSION_LEVELS_H)
00010 #define ACTIV_FEED_COMMON_PERMISSION_LEVELS_H
00011
00012 #include "ActivContentPlatform/ActivFeedCommon/External.h"
00013 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedDefinitions.h"
00014
00015 namespace Activ
00016 {
00017
00018 namespace ContentPlatform
00019 {
00020
00021 namespace Feed
00022 {
00023
00024 const PermissionLevel PERMISSION_LEVEL_DEFAULT = ~0;
00025
00026 const PermissionLevel PERMISSION_LEVEL_REALTIME = 0;
00027 const PermissionLevel PERMISSION_LEVEL_DELAYED = 1;
00028 const PermissionLevel PERMISSION_LEVEL_COUNT = 2;
00029
00033 union PermissionLevelData
00034 {
00035     byte_t  m_delayPeriod;
00036 };
00037
00045 ACTIV_FEED_COMMON_API std::string PermissionLevelToString(const PermissionLevel permissionLevel);
00046
00047 } // namespace Feed
00048
00049 } // namespace ContentPlatform
00050
00051 } // namespace Activ
00052
00053 #endif // (!defined ACTIV_FEED_COMMON_PERMISSION_LEVELS_H)
Generated on Wed Oct 8 14:01:46 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivSystem

Port.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_SYSTEM_PORT_H)
00010 #define ACTIV_SYSTEM_PORT_H
00011
00012 #include "ActivMiddleware/ActivSystem/External.h"
00013 #include "ActivMiddleware/ActivSystem/Address.h"
00014 #include "ActivMiddleware/ActivSystem/ManagedEndPoint.h"
00015 #include "ActivMiddleware/ActivBase/Atomic.h"
00016
00017 namespace Activ
00018 {
00019
00020 class IHeap;
00021 class RequestId;
00022 class SyncRequestId;
00023 class ScopedAddress;
00024
00025 // ---------------------------------------------------------------------------------------------------------------------------------
00026
00030 class Port : private boost::noncopyable
00031 {
00032 public:
00033     static const TimeoutPeriod defaultTimeout = 30000;
00034
00035     ACTIV_SYSTEM_EXPORTED_API
00036     static const std::string anonymousName;
00037
00041     class Enabler
00042     {
00043     public:
00049         ACTIV_SYSTEM_INLINE_API
00050         Enabler(Port &port);
00051
00055         ACTIV_SYSTEM_INLINE_API
00056         ~Enabler();
00057
00058     private:
00059         Port    &m_port;
00060     };
00061
00073     ACTIV_SYSTEM_EXPORTED_API
00074     Port(ManagedEndPoint &managedEndPoint, const std::string &name, IHeap * const pHeap);
00075
00088     ACTIV_SYSTEM_EXPORTED_API
00089     Port(ManagedEndPoint &managedEndPoint, const std::string &name, const PortId portId, IHeap * const pHeap);
00090
00097     ACTIV_SYSTEM_EXPORTED_API
00098     virtual ~Port();
00099
00115     ACTIV_SYSTEM_EXPORTED_API
00116     void Enable();
00117
00127     ACTIV_SYSTEM_EXPORTED_API
00128     void Disable();
00129
00135     ACTIV_SYSTEM_EXPORTED_API
00136     ManagedEndPoint &GetManagedEndPoint() const;
00137
00143     ACTIV_SYSTEM_EXPORTED_API
00144     const std::string &GetName() const;
00145
00151     ACTIV_SYSTEM_INLINE_API
00152     const Address &GetAddress() const;
00153
00159     ACTIV_SYSTEM_INLINE_API
00160     IHeap *GetHeap() const;
00161
00167     ACTIV_SYSTEM_EXPORTED_API
00168     void SetHeap(IHeap * const pHeap);
00169
00184     ACTIV_SYSTEM_EXPORTED_API
00185     StatusCode FindPort(const std::string &endPointName, const std::string &portName, Address &portAddress,
00186         const TimeoutPeriod timeout = defaultTimeout);
00187
00201     ACTIV_SYSTEM_EXPORTED_API
00202     StatusCode PostRequest(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId,
00203         const MessageBuilder &messageBuilder) const;
00204
00219     ACTIV_SYSTEM_EXPORTED_API
00220     StatusCode PostRequest(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId,
00221         const void *pRequest = 0, const size_t requestLength = 0) const;
00222
00235     ACTIV_SYSTEM_EXPORTED_API
00236     StatusCode PostRequest(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId,
00237         HeapMessage &request) const;
00238
00258     ACTIV_SYSTEM_EXPORTED_API
00259     StatusCode SendRequest(const Address &destinationAddress, const MessageType requestType, const MessageBuilder &messageBuilder,
00260         HeapMessage &response, const TimeoutPeriod timeout = defaultTimeout) const;
00261
00282     ACTIV_SYSTEM_EXPORTED_API
00283     StatusCode SendRequest(const Address &destinationAddress, const MessageType requestType, const void *pRequest,
00284         const size_t requestLength, HeapMessage &response, const TimeoutPeriod timeout = defaultTimeout) const;
00285
00305     ACTIV_SYSTEM_EXPORTED_API
00306     StatusCode SendRequest(const Address &destinationAddress, const MessageType requestType, HeapMessage &request,
00307         const TimeoutPeriod timeout = defaultTimeout) const;
00308
00326     ACTIV_SYSTEM_EXPORTED_API
00327     StatusCode SendRequest(const Address &destinationAddress, const MessageType requestType, SyncRequestId &syncRequestId,
00328         const MessageBuilder &messageBuilder) const;
00329
00348     ACTIV_SYSTEM_EXPORTED_API
00349     StatusCode SendRequest(const Address &destinationAddress, const MessageType requestType, SyncRequestId &syncRequestId,
00350         const void *pRequest, const size_t requestLength) const;
00351
00370     ACTIV_SYSTEM_EXPORTED_API
00371     StatusCode SendRequest(const Address &destinationAddress, const MessageType requestType, SyncRequestId &syncRequestId,
00372         HeapMessage &request) const;
00373
00388     ACTIV_SYSTEM_EXPORTED_API
00389     StatusCode PostResponse(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId,
00390         const StatusCode responseStatus, const MessageBuilder &messageBuilder) const;
00391
00407     ACTIV_SYSTEM_EXPORTED_API
00408     StatusCode PostResponse(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId,
00409         const StatusCode responseStatus, const void *pResponse = 0, const size_t responseLength = 0) const;
00410
00425     ACTIV_SYSTEM_EXPORTED_API
00426     StatusCode PostResponse(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId,
00427         const StatusCode responseStatus, HeapMessage &response) const;
00428
00443     ACTIV_SYSTEM_EXPORTED_API
00444     StatusCode PostResponse(const StatusCode responseStatus, HeapMessage &request, const MessageBuilder &messageBuilder) const;
00445
00461     ACTIV_SYSTEM_EXPORTED_API
00462     StatusCode PostResponse(const StatusCode responseStatus, HeapMessage &request, const void *pResponse,
00463         const size_t responseLength) const;
00464
00477     ACTIV_SYSTEM_EXPORTED_API
00478     StatusCode PostResponse(const StatusCode responseStatus, HeapMessage &request, HeapMessage &response) const;
00479
00491     ACTIV_SYSTEM_EXPORTED_API
00492     StatusCode PostResponse(const StatusCode responseStatus, HeapMessage &request) const;
00493
00507     ACTIV_SYSTEM_EXPORTED_API
00508     StatusCode PostEmptyResponse(const StatusCode responseStatus, HeapMessage &response) const;
00509
00527     ACTIV_SYSTEM_EXPORTED_API
00528     StatusCode PostEmptyResponse(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId,
00529         const StatusCode responseStatus, HeapMessage &response) const;
00530
00543     ACTIV_SYSTEM_EXPORTED_API
00544     StatusCode PostMessage(const Address &destinationAddress, const MessageType messageType,
00545         const MessageBuilder &messageBuilder) const;
00546
00560     ACTIV_SYSTEM_EXPORTED_API
00561     StatusCode PostMessage(const Address &destinationAddress, const MessageType messageType, const void *pMessage = 0,
00562         const size_t messageLength = 0) const;
00563
00575     ACTIV_SYSTEM_EXPORTED_API
00576     StatusCode PostMessage(const Address &destinationAddress, const MessageType messageType, HeapMessage &message) const;
00577
00589     ACTIV_SYSTEM_EXPORTED_API
00590     StatusCode ForwardMessage(const Address &destinationAddress, HeapMessage &message,
00591         const MessageType newType = INVALID_MESSAGE_TYPE) const;
00592
00593 protected:
00618     ACTIV_SYSTEM_EXPORTED_API
00619     virtual StatusCode OnRequest(HeapMessage &request);
00620
00634     ACTIV_SYSTEM_EXPORTED_API
00635     virtual StatusCode OnResponse(HeapMessage &response);
00636
00650     ACTIV_SYSTEM_EXPORTED_API
00651     virtual StatusCode OnMessage(HeapMessage &message);
00652
00653 private:
00662     ACTIV_SYSTEM_LOCAL_API
00663     StatusCode PostResponse(HeapMessage &response) const;
00664
00674     ACTIV_SYSTEM_LOCAL_API
00675     StatusCode Post(HeapMessage &message) const;
00676
00688     ACTIV_SYSTEM_LOCAL_API
00689     StatusCode Send(HeapMessage &message, const TimeoutPeriod timeout) const;
00690
00701     ACTIV_SYSTEM_LOCAL_API
00702     StatusCode Send(HeapMessage &message, SyncRequestId &syncRequestId) const;
00703
00707     ACTIV_SYSTEM_LOCAL_API
00708     void ProcessSystemRequestFindPort(HeapMessage &request) const;
00709
00713     ACTIV_SYSTEM_LOCAL_API
00714     void ProcessSystemRequestPingPort(HeapMessage &request) const;
00715
00719     ACTIV_SYSTEM_LOCAL_API
00720     void ProcessSystemRequestToken(HeapMessage &request) const;
00721
00725     ACTIV_SYSTEM_LOCAL_API
00726     void ProcessSystemRequestGetPortInfoList(HeapMessage &request) const;
00727
00731     ACTIV_SYSTEM_LOCAL_API
00732     void ProcessSystemMessageEndPointStartup(HeapMessage &message) const;
00733
00734     ISystem * const         m_pSystem;
00735     ManagedEndPoint &       m_managedEndPoint;
00736     const std::string       m_name;
00737     volatile bool           m_hasEnabled;
00738     volatile bool           m_isEnabled;
00739     const Address           m_address;
00740     AtomicPointer<IHeap>    m_pHeap;
00741
00742     friend class ManagedEndPoint::Impl;
00743     friend class ScopedAddress;
00744 };
00745
00746 // ---------------------------------------------------------------------------------------------------------------------------------
00747
00748 inline const Address &Port::GetAddress() const
00749 {
00750     return m_address;
00751 }
00752
00753 // ---------------------------------------------------------------------------------------------------------------------------------
00754
00755 inline IHeap *Port::GetHeap() const
00756 {
00757     return m_pHeap;
00758 }
00759
00760 // ---------------------------------------------------------------------------------------------------------------------------------
00761 // ---------------------------------------------------------------------------------------------------------------------------------
00762
00763 inline Port::Enabler::Enabler(Port &port) :
00764     m_port(port)
00765 {
00766     m_port.Enable();
00767 }
00768
00769 // ---------------------------------------------------------------------------------------------------------------------------------
00770
00771 inline Port::Enabler::~Enabler()
00772 {
00773     m_port.Disable();
00774 }
00775
00776 } // namespace Activ
00777
00778 #endif // (!defined ACTIV_SYSTEM_PORT_H)
Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivSystem

PostMessageHelper.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_SYSTEM_POST_MESSAGE_HELPER_H)
00010 #define ACTIV_SYSTEM_POST_MESSAGE_HELPER_H
00011
00012 #include "ActivMiddleware/ActivSystem/External.h"
00013 #include "ActivMiddleware/ActivSystem/Port.h"
00014
00015 namespace Activ
00016 {
00017
00041 class PostMessageHelper : private boost::noncopyable
00042 {
00043 public:
00052     ACTIV_SYSTEM_EXPORTED_API
00053     PostMessageHelper(ISystem * const pSystem, const size_t maximumNumberOfFailedTryFlushes = 8);
00054
00058     ACTIV_SYSTEM_EXPORTED_API
00059     ~PostMessageHelper();
00060
00072     ACTIV_SYSTEM_EXPORTED_API
00073     StatusCode PostMessage(const Port &port, const Address &destinationAddress, const MessageType messageType,
00074         const MessageBuilder &messageBuilder);
00075
00088     ACTIV_SYSTEM_EXPORTED_API
00089     StatusCode PostMessage(const Port &port, const Address &destinationAddress, const MessageType messageType,
00090         const void *pMessage = 0, const size_t messageLength = 0);
00091
00100     ACTIV_SYSTEM_EXPORTED_API
00101     void PostMessage(const Port &port, const Address &destinationAddress, const MessageType messageType, HeapMessage &message);
00102
00108     ACTIV_SYSTEM_EXPORTED_API
00109     void PostMessage(HeapMessage &heapMessage);
00110
00114     ACTIV_SYSTEM_EXPORTED_API
00115     void Flush();
00116
00123     ACTIV_SYSTEM_EXPORTED_API
00124     void TryFlush();
00125
00126 private:
00134     IEndPoint *ExtendLists(const EndPointId endPointId);
00135
00143     IEndPoint *CreateLocalEndPoint(const EndPointId endPointId);
00144
00150     void AddEndPointIdToInUseList(const EndPointId endPointId);
00151
00152     typedef std::pair<IEndPoint *, size_t> EndPointFlushCountPair;
00153     typedef std::vector<EndPointFlushCountPair> EndPointList;
00154     typedef std::vector<EndPointId> EndPointIdList;
00155
00156     ISystem * const         m_pSystem;
00157     const size_t            m_maximumNumberOfFailedTryFlushes;
00158
00159     EndPointList            m_endPointList;
00160     std::vector<bool>       m_endPointInUseList;
00161     EndPointIdList          m_endPointIdList;
00162     EndPointIdList          m_failedFlushEndPointIdList;
00163 };
00164
00165 } // namespace Activ
00166
00167 #endif // (!defined ACTIV_SYSTEM_POST_MESSAGE_HELPER_H)
Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

PrivateEventFactory.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_BASE_PRIVATE_EVENT_FACTORY_H)
00010 #define ACTIV_BASE_PRIVATE_EVENT_FACTORY_H
00011
00012 #include "ActivMiddleware/ActivBase/External.h"
00013 #include "ActivMiddleware/ActivBase/IEvent.h"
00014 #include "ActivMiddleware/Misc/Singleton.h"
00015
00016 namespace Activ
00017 {
00018
00024 class PrivateEventFactory : public Singleton<PrivateEventFactory>
00025 {
00026 public:
00035     ACTIV_BASE_EXPORTED_API IEvent *Create(const IEvent::Flags flags = IEvent::FLAG_NONE, const bool initialState = false);
00036
00042     ACTIV_BASE_EXPORTED_API static PrivateEventFactory &GetInstance();
00043
00044 private:
00048     ACTIV_BASE_EXPORTED_API PrivateEventFactory();
00049
00050     friend class Singleton<PrivateEventFactory>;
00051 };
00052
00053 } // namespace Activ
00054
00055 #endif // (!defined ACTIV_BASE_PRIVATE_EVENT_FACTORY_H)
Generated on Wed Oct 8 14:01:47 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

PrivateMutexFactory.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_BASE_PRIVATE_MUTEX_FACTORY_H)
00010 #define ACTIV_BASE_PRIVATE_MUTEX_FACTORY_H
00011
00012 #include "ActivMiddleware/ActivBase/External.h"
00013 #include "ActivMiddleware/ActivBase/IMutex.h"
00014 #include "ActivMiddleware/Misc/Singleton.h"
00015
00016 namespace Activ
00017 {
00018
00031 class PrivateMutexFactory : public Singleton<PrivateMutexFactory>
00032 {
00033 public:
00043     ACTIV_BASE_EXPORTED_API IMutex *Create(const bool isInitialOwner = false);
00044
00050     ACTIV_BASE_EXPORTED_API static PrivateMutexFactory &GetInstance();
00051
00052 private:
00056     ACTIV_BASE_EXPORTED_API PrivateMutexFactory();
00057
00061     ACTIV_BASE_EXPORTED_API ~PrivateMutexFactory();
00062
00072     template<typename T, bool COUNT_CONTENTION>
00073     IMutex *InternalCreate(const bool isInitialOwner);
00074
00075     const bool  m_isRecursive;
00076     const bool  m_shouldCountContention;
00077
00078     friend class Singleton<PrivateMutexFactory>;
00079 };
00080
00081 } // namespace Activ
00082
00083 #endif // (!defined ACTIV_BASE_PRIVATE_MUTEX_FACTORY_H)
Generated on Wed Oct 8 14:01:47 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

PrivateSemaphoreFactory.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_BASE_PRIVATE_SEMAPHORE_FACTORY_H)
00010 #define ACTIV_BASE_PRIVATE_SEMAPHORE_FACTORY_H
00011
00012 #include "ActivMiddleware/ActivBase/External.h"
00013 #include "ActivMiddleware/ActivBase/ISemaphore.h"
00014 #include "ActivMiddleware/Misc/Singleton.h"
00015
00016 namespace Activ
00017 {
00018
00024 class PrivateSemaphoreFactory : public Singleton<PrivateSemaphoreFactory>
00025 {
00026 public:
00034     ACTIV_BASE_EXPORTED_API ISemaphore *Create();
00035
00041     ACTIV_BASE_EXPORTED_API static PrivateSemaphoreFactory &GetInstance();
00042
00043 private:
00047     ACTIV_BASE_EXPORTED_API PrivateSemaphoreFactory();
00048
00049     friend class Singleton<PrivateSemaphoreFactory>;
00050 };
00051
00052 } // namespace Activ
00053
00054 #endif // (!defined ACTIV_BASE_PRIVATE_SEMAPHORE_FACTORY_H)
Generated on Wed Oct 8 14:01:47 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

Process.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_BASE_PROCESS_H)
00010 #define ACTIV_BASE_PROCESS_H
00011
00012 #include "ActivMiddleware/ActivBase/External.h"
00013
00014 #include <string>
00015 #include <vector>
00016
00017 namespace Activ
00018 {
00019
00025 class Process
00026 {
00027 public:
00028 #if (defined ACTIV_PLATFORM_WINDOWS)
00029     typedef DWORD Id;
00030 #elif (defined ACTIV_PLATFORM_POSIX)
00031     typedef pid_t Id;
00032 #else
00033 #error Configure for this platform
00034 #endif
00035
00036     typedef std::vector<uint16_t> ProcessorList;
00037
00047     ACTIV_BASE_EXPORTED_API static StatusCode Run(const std::string &command, std::string &output);
00048
00063     ACTIV_BASE_EXPORTED_API static StatusCode Exec(const std::string &command);
00064
00077     ACTIV_BASE_EXPORTED_API static StatusCode Start(const std::string &command, Id &id);
00078
00086     ACTIV_BASE_EXPORTED_API static StatusCode Kill(const Id id);
00087
00098     ACTIV_BASE_EXPORTED_API static StatusCode WaitForCompletion(const Id id,
00099         const TimeoutPeriod timeoutPeriod = ACTIV_WAIT_INFINITE);
00100
00108     ACTIV_BASE_EXPORTED_API static bool DoesExist(const Id id);
00109
00115     ACTIV_BASE_EXPORTED_API static Id GetCurrentId();
00116
00126     ACTIV_BASE_EXPORTED_API static StatusCode SetProcessorAffinity(const ProcessorList &processorList);
00127 };
00128
00129 } // namespace Activ
00130
00131 #endif // (!defined ACTIV_BASE_PROCESS_H)
Generated on Wed Oct 8 14:01:47 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivFramework

PubSubServiceApi.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FRAMEWORK_PUB_SUB_SERVICE_API_H)
00010 #define ACTIV_FRAMEWORK_PUB_SUB_SERVICE_API_H
00011
00012 #include "ActivMiddleware/ActivFramework/External.h"
00013
00014 #include <map>
00015 #include <set>
00016
00017 namespace Activ
00018 {
00019
00020 class Component;
00021 class PostMessageHelper;
00022
00023 // ---------------------------------------------------------------------------------------------------------------------------------
00024
00028 class PubSubServiceApi
00029 {
00030 public:
00031     typedef std::set<Address> AddressSet;
00032     typedef std::vector<AddressSet> AddressSetList;
00033     typedef std::map<Subject, AddressSetList> SubscriptionMap;
00034
00050     ACTIV_FRAMEWORK_API static StatusCode Subscribe(const Component &component, const AgentScope agentScope, const Subject &subject);
00051
00062     ACTIV_FRAMEWORK_API static StatusCode Unsubscribe(const Component &component, const AgentScope agentScope, const Subject &subject);
00063
00077     ACTIV_FRAMEWORK_API static StatusCode Publish(const Component &component, const AgentScope agentScope, const Subject &subject,
00078         const MessageType type, const MessageBuilder &messageBuilder);
00079
00094     ACTIV_FRAMEWORK_API static StatusCode Publish(const Component &component, const AgentScope agentScope, const Subject &subject,
00095         const MessageType type, const void *pData = 0, const size_t dataLength = 0);
00096
00110     ACTIV_FRAMEWORK_API static StatusCode Publish(const Component &component, const AgentScope agentScope, const Subject &subject,
00111         const MessageType type, HeapMessage &heapMessage);
00112
00129     ACTIV_FRAMEWORK_API static StatusCode Publish(const Component &component, PostMessageHelper &postMessageHelper,
00130         const AgentScope agentScope, const Subject &subject, const MessageType type, const MessageBuilder &messageBuilder);
00131
00149     ACTIV_FRAMEWORK_API static StatusCode Publish(const Component &component, PostMessageHelper &postMessageHelper,
00150         const AgentScope agentScope, const Subject &subject, const MessageType type, const void *pData = 0,
00151         const size_t dataLength = 0);
00152
00166     ACTIV_FRAMEWORK_API static void Publish(const Component &component, PostMessageHelper &postMessageHelper,
00167         const AgentScope agentScope, const Subject &subject, const MessageType type, HeapMessage &heapMessage);
00168
00181     ACTIV_FRAMEWORK_API static StatusCode GetSubscriptions(const Component &component, const Subject &subject,
00182         const bool shouldRecurseTree,  SubscriptionMap &subscriptionMap, const TimeoutPeriod timeout = Port::defaultTimeout);
00183 };
00184
00185 // ---------------------------------------------------------------------------------------------------------------------------------
00186
00190 class ScopedSubscription : private boost::noncopyable
00191 {
00192 public:
00204     ACTIV_FRAMEWORK_API ScopedSubscription(const Component &component, const AgentScope agentScope, const Subject &subject);
00205
00211     ACTIV_FRAMEWORK_API ~ScopedSubscription();
00212
00218     ACTIV_FRAMEWORK_API StatusCode Unsubscribe();
00219
00220 private:
00221     const Component &   m_component;
00222     const AgentScope    m_agentScope;
00223     const Subject       m_subject;
00224     bool                m_isSubscribed;
00225 };
00226
00227 } // namespace Activ
00228
00229 #endif // (!defined ACTIV_FRAMEWORK_PUB_SUB_SERVICE_API_H)
Generated on Wed Oct 8 14:01:48 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivContributionGatewayApi

PublishRequestHelper.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_CONTRIBUTION_GATEWAY_API_PUBLISH_REQUEST_HELPER_H)
00010 #define ACTIV_CONTRIBUTION_GATEWAY_API_PUBLISH_REQUEST_HELPER_H
00011
00012 #include "ActivContentPlatform/ActivContributionGatewayApi/External.h"
00013
00014 namespace Activ
00015 {
00016
00017 namespace ContentPlatform
00018 {
00019
00020 namespace ContributionGatewayApi
00021 {
00022
00023 class ContributionGatewayClient;
00024
00025 // ---------------------------------------------------------------------------------------------------------------------------------
00026
00033 template<MessageType MESSAGE_TYPE_VALUE, typename REQUEST_PARAMETERS, typename RESPONSE_PARAMETERS>
00034 class PublishRequestHelper
00035 {
00036 public:
00037     typedef REQUEST_PARAMETERS RequestParameters;
00038     typedef RESPONSE_PARAMETERS ResponseParameters;
00039
00053     ACTIV_CONTRIBUTION_GATEWAY_API static StatusCode SendRequest(const ContributionGatewayClient &client,
00054         const RequestParameters &requestParameters, ResponseParameters &responseParameters,
00055         const TimeoutPeriod timeoutPeriod = Port::defaultTimeout);
00056
00068     ACTIV_CONTRIBUTION_GATEWAY_API static StatusCode SendRequest(const ContributionGatewayClient &client,
00069         SyncRequestId &syncRequestId, const RequestParameters &requestParameters);
00070
00082     ACTIV_CONTRIBUTION_GATEWAY_API static StatusCode PostRequest(const ContributionGatewayClient &client,
00083         const RequestId &requestId, const RequestParameters &requestParameters);
00084
00098     ACTIV_CONTRIBUTION_GATEWAY_API static StatusCode GetResponse(const ContributionGatewayClient &client,
00099         SyncRequestId &syncRequestId, ResponseParameters &responseParameters, const TimeoutPeriod timeoutPeriod = Port::defaultTimeout);
00100
00117     ACTIV_CONTRIBUTION_GATEWAY_API static StatusCode Deserialize(const ContributionGatewayClient &client,
00118         const HeapMessage &response, ResponseParameters &responseParameters);
00119
00120 private:
00121     static const MessageType MESSAGE_TYPE = MESSAGE_TYPE_VALUE;
00122 };
00123
00124 } // namespace ContributionGatewayApi
00125
00126 } // namespace ContentPlatform
00127
00128 } // namespace Activ
00129
00130 #endif // (!defined ACTIV_CONTRIBUTION_GATEWAY_API_PUBLISH_REQUEST_HELPER_H)
Generated on Wed Oct 8 14:01:45 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivContributionGatewayApiCommon

PublishTypes.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_CONTRIBUTION_GATEWAY_API_COMMON_PUBLISH_TYPES_H)
00010 #define ACTIV_CONTRIBUTION_GATEWAY_API_COMMON_PUBLISH_TYPES_H
00011
00012 #include "ActivContentPlatform/ActivContributionGatewayApiCommon/External.h"
00013 #include "ActivContentPlatform/ActivContributionGatewayApiCommon/Types.h"
00014 #include "ActivContentPlatform/ActivFeedCommon/TableNumbers.h"
00015 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/SymbolRecordRuleDefinitions.h"
00016 #include "ActivContentPlatform/ActivFeedCommon/UpdateIds.h"
00017
00018 #include "ActivMiddleware/ActivFieldTypes/IFieldType.h"
00019
00020 #include "boost/shared_ptr.hpp"
00021
00022 namespace Activ
00023 {
00024
00025 namespace ContentPlatform
00026 {
00027
00028 namespace ContributionGatewayApi
00029 {
00030
00031 #define ACTIV_DECLARE_FLAGS(value, id)  static const Flags id = value;
00032
00033 typedef std::string Symbol;
00034
00035 // ---------------------------------------------------------------------------------------------------------------------------------
00036
00040 class PublishField
00041 {
00042 public:
00046     ACTIV_CONTRIBUTION_GATEWAY_API_COMMON_API PublishField();
00047
00054     ACTIV_CONTRIBUTION_GATEWAY_API_COMMON_API PublishField(Feed::FieldId fieldId, IFieldType *pIFieldType);
00055
00061     ACTIV_CONTRIBUTION_GATEWAY_API_COMMON_API StatusCode SetFieldContents(IFieldType *pIFieldType);
00062
00068     ACTIV_CONTRIBUTION_GATEWAY_API_COMMON_API const IFieldType *GetFieldContents() const;
00069
00070     Feed::FieldId   m_fieldId;
00071
00072     class Serializer;
00073
00074 private:
00075     typedef boost::shared_ptr<IFieldType>   IFieldTypePtr;
00076
00077     IFieldTypePtr   m_pIFieldType;
00078 };
00079
00080 // ---------------------------------------------------------------------------------------------------------------------------------
00081 // ---------------------------------------------------------------------------------------------------------------------------------
00082
00086 class PublishRecordBaseParameters
00087 {
00088 public:
00089     typedef uint8_t Flags;
00090
00094     ACTIV_CONTRIBUTION_GATEWAY_API_COMMON_API PublishRecordBaseParameters();
00095
00099     ACTIV_CONTRIBUTION_GATEWAY_API_COMMON_API PublishRecordBaseParameters(Feed::TableNo tableNumber, Feed::EventType eventType,
00100         Feed::PermissionId permissionId, Flags flags, Feed::UpdateId updateId);
00101
00102     #define ACTIV_PUBLISH_RECORD_PARAMETERS_FLAG_LIST(d)                                    \
00103         d(0x00, FLAG_NONE)                                                                  \
00104         d(0x01, FLAG_BEST_EFFORT)                   \
00105         d(0x02, FLAG_DELETE)
00107     ACTIV_PUBLISH_RECORD_PARAMETERS_FLAG_LIST(ACTIV_DECLARE_FLAGS)
00108
00109     Feed::TableNo       m_tableNumber;
00110     Feed::PermissionId  m_permissionId;
00111     Feed::EventType     m_eventType;
00112     Feed::UpdateId      m_updateId;
00113     Flags               m_flags;
00114 };
00115
00116 // ---------------------------------------------------------------------------------------------------------------------------------
00117 // ---------------------------------------------------------------------------------------------------------------------------------
00118
00122 class PublishSymbolRecordParameters : public PublishRecordBaseParameters
00123 {
00124 public:
00128     ACTIV_CONTRIBUTION_GATEWAY_API_COMMON_API PublishSymbolRecordParameters();
00129
00133     ACTIV_CONTRIBUTION_GATEWAY_API_COMMON_API PublishSymbolRecordParameters(Feed::TableNo tableNumber, const Symbol &symbol,
00134         Feed::EventType eventType, Feed::PermissionId permissionId, Flags flags, Feed::UpdateId updateId = Feed::UPDATE_ID_COUNT_UNKNOWN,
00135         uint8_t defaultRuleSet = Feed::SymbolRecordRuleDefinitions::RULE_SET_NONE);
00136
00140     class Field : public PublishField
00141     {
00142     public:
00146         ACTIV_CONTRIBUTION_GATEWAY_API_COMMON_API Field();
00147
00154         ACTIV_CONTRIBUTION_GATEWAY_API_COMMON_API Field(Feed::FieldId fieldId, IFieldType* pIFieldType);
00155
00164         ACTIV_CONTRIBUTION_GATEWAY_API_COMMON_API Field(Feed::FieldId fieldId, uint8_t ruleSet, uint8_t rules, IFieldType *pIFieldType);
00165
00172         ACTIV_CONTRIBUTION_GATEWAY_API_COMMON_API StatusCode SetRuleSet(uint8_t ruleSet, uint8_t rules = 0);
00173
00177         ACTIV_CONTRIBUTION_GATEWAY_API_COMMON_API bool IsRulesPresent() const;
00178
00182         ACTIV_CONTRIBUTION_GATEWAY_API_COMMON_API uint8_t GetRuleSet() const;
00183
00187         ACTIV_CONTRIBUTION_GATEWAY_API_COMMON_API uint8_t GetRules() const;
00188
00189         class Serializer;
00190
00191     private:
00192         uint8_t m_ruleSet;
00193         uint8_t m_rules;
00194         bool    m_rulesPresent;
00195     };
00196
00197     typedef std::vector<Field> FieldList;
00198
00199     Symbol      m_symbol;
00200     uint8_t     m_defaultRuleSet;
00201     FieldList   m_fieldList;
00202
00203     class Serializer;
00204
00205 private:
00206     typedef SerializableObjectContainerHelper<FieldList, uint16_t> FieldListSerializer;
00207 };
00208
00209 // ---------------------------------------------------------------------------------------------------------------------------------
00210 // ---------------------------------------------------------------------------------------------------------------------------------
00211
00212 inline bool PublishSymbolRecordParameters::Field::IsRulesPresent() const
00213 {
00214     return m_rulesPresent;
00215 }
00216
00217 // ---------------------------------------------------------------------------------------------------------------------------------
00218
00219 inline uint8_t PublishSymbolRecordParameters::Field::GetRuleSet() const
00220 {
00221     return m_ruleSet;
00222 }
00223
00224 // ---------------------------------------------------------------------------------------------------------------------------------
00225
00226 inline uint8_t PublishSymbolRecordParameters::Field::GetRules() const
00227 {
00228     return m_rules;
00229 }
00230
00231 // ---------------------------------------------------------------------------------------------------------------------------------
00232 // ---------------------------------------------------------------------------------------------------------------------------------
00233
00237 class PublishRecordParameters : public PublishRecordBaseParameters
00238 {
00239 public:
00243     ACTIV_CONTRIBUTION_GATEWAY_API_COMMON_API PublishRecordParameters();
00244
00248     ACTIV_CONTRIBUTION_GATEWAY_API_COMMON_API PublishRecordParameters(Feed::TableNo tableNumber, Feed::EventType eventType,
00249         Feed::PermissionId permissionId, Flags flags, Feed::UpdateId updateId = Feed::UPDATE_ID_COUNT_UNKNOWN);
00250
00251     typedef std::vector<PublishField> FieldList;
00252
00253     uint8_t     m_indexNumber;
00254     FieldList   m_keyFieldList;
00255     FieldList   m_fieldList;
00256
00257     class Serializer;
00258
00259 private:
00260     typedef SerializableObjectContainerHelper<FieldList, uint16_t> FieldListSerializer;
00261 };
00262
00263 // ---------------------------------------------------------------------------------------------------------------------------------
00264 // ---------------------------------------------------------------------------------------------------------------------------------
00265
00269 class ContributionGatewayResponseParameters
00270 {
00271 public:
00272     typedef uint8_t Status;
00273
00277     #define ACTIV_CONTRIBUTION_GATEWAY_RESPONSE_STATUS_LIST(d)                          \
00278         d(0,    STATUS_SUCCESS, "success")                                              \
00279         d(1,    STATUS_SUCCESS_WITH_ERRORS, "success with errors")                      \
00280         d(2,    STATUS_FAILURE, "failure")                                              \
00281         d(3,    STATUS_FAILURE_WITH_ERRORS, "failure with errors")                      \
00282         d(4,    STATUS_INVALID_TABLE, "invalid table")                                  \
00283         d(5,    STATUS_NOT_PERMISSIONED, "not permissioned")
00284
00292     ACTIV_CONTRIBUTION_GATEWAY_API_COMMON_API static std::string StatusToString(const Status status);
00293
00297     #define ACTIV_DECLARE_CONTRIBUTION_GATEWAY_RESPONSE_STATUS(value, id, name) static const Status id = value;
00298
00302     ACTIV_CONTRIBUTION_GATEWAY_RESPONSE_STATUS_LIST(ACTIV_DECLARE_CONTRIBUTION_GATEWAY_RESPONSE_STATUS)
00303
00304     #undef ACTIV_DECLARE_CONTRIBUTION_GATEWAY_RESPONSE_STATUS
00305
00306     Status  m_status;
00307 };
00308
00309 // ---------------------------------------------------------------------------------------------------------------------------------
00310 // ---------------------------------------------------------------------------------------------------------------------------------
00311
00315 class PublishRecordResponseParameters : public ContributionGatewayResponseParameters
00316 {
00317 public:
00321     class FieldError
00322     {
00323     public:
00324         typedef uint8_t FieldStatus;
00325
00329         #define ACTIV_FIELD_STATUS_LIST(d)                                          \
00330             d(0,    FIELD_STATUS_INVALID_TYPE, "invalid type")                      \
00331             d(1,    FIELD_STATUS_INVALID_LENGTH, "invalid length")                  \
00332             d(2,    FIELD_STATUS_NOT_FOUND, "not found")                            \
00333             d(3,    FIELD_STATUS_FAILURE, "failure")                                \
00334             d(4,    FIELD_STATUS_NOT_PERMISSIONED, "not permissioned")
00335
00343         ACTIV_CONTRIBUTION_GATEWAY_API_COMMON_API static std::string FieldStatusToString(const FieldStatus fieldStatus);
00344
00348         #define ACTIV_DECLARE_FIELD_STATUS(value, id, name) static const FieldStatus id = value;
00349
00353         ACTIV_FIELD_STATUS_LIST(ACTIV_DECLARE_FIELD_STATUS)
00354
00355         #undef ACTIV_DECLARE_FIELD_STATUS
00356
00357         Feed::FieldId   m_fieldId;
00358         FieldStatus     m_fieldStatus;
00359
00360         class Serializer;
00361     };
00362
00363     typedef std::vector<FieldError> FieldErrorList;
00364
00365     FieldErrorList      m_fieldErrorList;
00366
00367     class Serializer;
00368
00369 private:
00370     typedef SerializableObjectContainerHelper<FieldErrorList, uint16_t> FieldErrorListSerializer;
00371 };
00372
00373 #undef ACTIV_DECLARE_FLAGS
00374
00375 } // namespace ContributionGatewayApi
00376
00377 } // namespace ContentPlatform
00378
00379 } // namespace Activ
00380
00381 #endif // (!defined ACTIV_CONTRIBUTION_GATEWAY_API_COMMON_PUBLISH_TYPES_H)
Generated on Wed Oct 8 14:01:45 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivFieldTypes

Rational.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FIELD_TYPES_RATIONAL_H)
00010 #define ACTIV_FIELD_TYPES_RATIONAL_H
00011
00012 #include "ActivMiddleware/ActivFieldTypes/External.h"
00013 #include "ActivMiddleware/ActivFieldTypes/IFieldType.h"
00014
00015 #include "ActivMiddleware/Misc/MemoryHelper.h"
00016
00017 #include "ActivMiddleware/ActivBase/ActivBase.h"
00018 #include "ActivMiddleware/ActivBase/StatusCodeException.h"
00019
00020 namespace Activ
00021 {
00022
00026 #define ACTIV_DENOMINATOR_LIST(d)                                               \
00027     d(DENOMINATOR_WHOLE,        1,          1,          0,      0,      0)      \
00028     d(DENOMINATOR_1DP,          10,         0,          1,      1,      0)      \
00029     d(DENOMINATOR_2DP,          100,        0,          2,      2,      0)      \
00030     d(DENOMINATOR_3DP,          1000,       0,          3,      3,      0)      \
00031     d(DENOMINATOR_4DP,          10000,      0,          4,      4,      0)      \
00032     d(DENOMINATOR_5DP,          100000,     0,          5,      5,      0)      \
00033     d(DENOMINATOR_6DP,          1000000,    0,          6,      6,      0)      \
00034     d(DENOMINATOR_7DP,          10000000,   0,          7,      7,      0)      \
00035     d(DENOMINATOR_8DP,          100000000,  0,          8,      8,      0)      \
00036     d(DENOMINATOR_9DP,          1000000000, 0,          9,      9,      0)      \
00037     d(DENOMINATOR_X1E1,         0,          10,         0,      0,      1)      \
00038     d(DENOMINATOR_X1E2,         0,          100,        0,      0,      2)      \
00039     d(DENOMINATOR_X1E3,         0,          1000,       0,      0,      3)      \
00040     d(DENOMINATOR_X1E4,         0,          10000,      0,      0,      4)      \
00041     d(DENOMINATOR_X1E5,         0,          100000,     0,      0,      5)      \
00042     d(DENOMINATOR_X1E6,         0,          1000000,    0,      0,      6)      \
00043     d(DENOMINATOR_X1E7,         0,          10000000,   0,      0,      7)      \
00044     d(DENOMINATOR_X1E8,         0,          100000000,  0,      0,      8)      \
00045     d(DENOMINATOR_X1E9,         0,          1000000000, 0,      0,      9)      \
00046     d(DENOMINATOR_HALF,         2,          0,          1,      1,      0)      \
00047     d(DENOMINATOR_QUARTER,      4,          0,          2,      1,      0)      \
00048     d(DENOMINATOR_8TH,          8,          0,          3,      1,      0)      \
00049     d(DENOMINATOR_16TH,         16,         0,          4,      2,      0)      \
00050     d(DENOMINATOR_32ND,         32,         0,          5,      2,      0)      \
00051     d(DENOMINATOR_64TH,         64,         0,          6,      2,      0)      \
00052     d(DENOMINATOR_128TH,        128,        0,          7,      3,      0)      \
00053     d(DENOMINATOR_256TH,        256,        0,          8,      3,      0)      \
00054     d(DENOMINATOR_512TH,        512,        0,          9,      3,      0)      \
00055     d(DENOMINATOR_CABINET,      1,          0,          0,      0,      0)      \
00056     d(DENOMINATOR_UNDEFINED,    0,          0,          0,      0,      0)
00057
00061 #define ACTIV_DENOMINATOR_ENUMERATION(enumeration, divisor, multiplier, nDecimalPlaces, nDivisorDigits, multiplierPower)    enumeration,
00062
00066 #define ACTIV_DENOMINATOR_SPECIFICATION(enumeration, divisor, multiplier, nDecimalPlaces, nDivisorDigits, multiplierPower)  Rational::DenominatorType(divisor, multiplier, nDecimalPlaces, nDivisorDigits, multiplierPower),
00067
00068 // ---------------------------------------------------------------------------------------------------------------------------------
00069
00070 class MessageBuilder;
00071 class MessageValidator;
00072
00073 // ---------------------------------------------------------------------------------------------------------------------------------
00074
00078 class Rational : public IFieldType
00079 {
00080 public:
00081     static const FieldType FIELD_TYPE = FIELD_TYPE_RATIONAL;
00082
00083     static const int64_t MIN_NUMERATOR = -INT64_MAX;
00084     static const int64_t MAX_NUMERATOR = INT64_MAX;
00085
00086     using IFieldType::FromString;
00087     using IFieldType::Serialize;
00088     using IFieldType::SerializeBody;
00089     using IFieldType::SerializeLengthAndBody;
00090     using IFieldType::Deserialize;
00091     using IFieldType::DeserializeBody;
00092     using IFieldType::DeserializeLengthAndBody;
00093
00097     enum Denominator
00098     {
00099         ACTIV_DENOMINATOR_LIST(ACTIV_DENOMINATOR_ENUMERATION)
00100         NUMBER_OF_DENOMINATORS
00101     };
00102
00106     class DenominatorType
00107     {
00108     public:
00118         DenominatorType(const uint64_t divisor, const uint64_t multiplier, const size_t nDecimalPlaces, const size_t nDivisorDigits, const size_t multiplierPower);
00119
00125         uint64_t GetDivisor() const;
00126
00132         uint64_t GetMultiplier() const;
00133
00139         size_t GetDecimalPlaces() const;
00140
00146         size_t GetDivisorDigits() const;
00147
00153         size_t GetMultiplierPower() const;
00154
00160         bool IsDivisor() const;
00161
00167         bool IsDivisorBinary() const;
00168
00174         bool IsDivisorDecimal() const;
00175
00181         bool IsMultiplier() const;
00182
00183     private:
00184         const uint64_t  m_divisor;
00185         const uint64_t  m_multiplier;
00186         const size_t    m_nDecimalPlaces;
00187         const size_t    m_nDivisorDigits;
00188         const size_t    m_multiplierPower;
00189     };
00190
00194     Rational();
00195
00205     Rational(const int64_t numerator, const Denominator denominator = DENOMINATOR_WHOLE, bool shouldCompress = false);
00206
00212     virtual ~Rational();
00213
00223     bool operator==(const Rational &rhs) const;
00224
00234     bool operator!=(const Rational &rhs) const;
00235
00245     bool operator<(const Rational &rhs) const;
00246
00256     bool operator<=(const Rational &rhs) const;
00257
00267     bool operator>(const Rational &rhs) const;
00268
00278     bool operator>=(const Rational &rhs) const;
00279
00289     Rational& operator+=(const Rational &rhs);
00290
00300     Rational& operator-=(const Rational &rhs);
00301
00311     Rational& operator*=(const Rational &rhs);
00312
00322     Rational& operator/=(const Rational &rhs);
00323
00334     StatusCode Set(const int64_t numerator, const Denominator denominator, bool shouldCompress = false);
00335
00345     StatusCode Get(int64_t &numerator, Denominator &denominator) const;
00346
00354     double Get() const;
00355
00363     int64_t GetNumerator() const;
00364
00375     StatusCode GetNumerator(int64_t &numerator, const Denominator denominator) const;
00376
00387     ACTIV_FIELD_TYPES_API StatusCode GetNumeratorAndDivisor(int64_t &numerator, uint64_t &divisor) const;
00388
00401     StatusCode SetDenominator(const Denominator denominator);
00402
00410     Denominator GetDenominator() const;
00411
00421     StatusCode GetDouble(double &value) const;
00422
00429     StatusCode Compress();
00430
00441     ACTIV_FIELD_TYPES_API StatusCode Add(const Rational &rhs, bool isExactCalculation = true);
00442
00453     ACTIV_FIELD_TYPES_API StatusCode Subtract(const Rational &rhs, bool isExactCalculation = true);
00454
00465     ACTIV_FIELD_TYPES_API StatusCode Multiply(const Rational &rhs, bool isExactCalculation = true);
00466
00477     ACTIV_FIELD_TYPES_API StatusCode Divide(const Rational &rhs, bool isExactCalculation = true);
00478
00479     virtual void Reset();
00480     virtual void Clear();
00481
00491     ACTIV_FIELD_TYPES_API StatusCode Compare(const Rational &rhs, int &result) const;
00492
00493     ACTIV_FIELD_TYPES_API virtual StatusCode Compare(const void * const pRhsSerializedBody, const size_t rhsSerializedBodyLength, int &result) const;
00494     ACTIV_FIELD_TYPES_API virtual StatusCode Convert(const IFieldType * const pIFieldType);
00495     ACTIV_FIELD_TYPES_API virtual std::string ToString() const;
00496
00506     ACTIV_FIELD_TYPES_API std::string ToString(const Rational::Denominator denominator) const;
00507
00508     ACTIV_FIELD_TYPES_API virtual StatusCode FromString(MessageValidator &messageValidator);
00509     ACTIV_FIELD_TYPES_API virtual std::string GetFromStringFormat() const;
00510     ACTIV_FIELD_TYPES_API virtual StatusCode Serialize(MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength) const;
00511     ACTIV_FIELD_TYPES_API virtual StatusCode SerializeBody(void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength) const;
00512     ACTIV_FIELD_TYPES_API virtual StatusCode SerializeLengthAndBody(MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength = MAX_SERIALIZED_BODY_LENGTH_UNDEFINED) const;
00513     ACTIV_FIELD_TYPES_API virtual StatusCode Deserialize(MessageValidator &messageValidator, const size_t maxSerializedBodyLength);
00514     ACTIV_FIELD_TYPES_API virtual StatusCode DeserializeBody(const void * const pSerializedBody, const size_t serializedBodyLength);
00515     ACTIV_FIELD_TYPES_API virtual StatusCode DeserializeLengthAndBody(MessageValidator &messageValidator, const size_t maxSerializedBodyLength = MAX_SERIALIZED_BODY_LENGTH_UNDEFINED);
00516     virtual size_t GetSerializedLength() const;
00517     virtual size_t GetSerializedBodyLength() const;
00518     ACTIV_FIELD_TYPES_API virtual StatusCode IsDifferent(const void * const pRhsSerializedBody, const size_t rhsSerializedBodyLength, bool &isDifferent) const;
00519
00527     static size_t GetMaxSerializedLength(const size_t size);
00528
00536     static size_t GetMaxSerializedBodyLength(const size_t size);
00537
00551     ACTIV_FIELD_TYPES_API static StatusCode Compare(const void * const pLhsSerializedBody, const size_t lhsSerializedBodyLength, const void * const pRhsSerializedBody, const size_t rhsSerializedBodyLength, int &result);
00552
00562     static StatusCode GetDenominatorType(const Denominator denominator, const DenominatorType *&pDenominatorType);
00563
00573     ACTIV_FIELD_TYPES_API static StatusCode GetDenominatorByBinaryPower(const size_t binaryPower, Denominator &denominator);
00574
00584     ACTIV_FIELD_TYPES_API static StatusCode GetDenominatorByDecimalPlaces(const size_t nDecimalPlaces, Denominator &denominator);
00585
00595     ACTIV_FIELD_TYPES_API static StatusCode GetDenominatorByDecimalPower(const size_t decimalPower, Denominator &denominator);
00596
00607     ACTIV_FIELD_TYPES_API static StatusCode GetDenominatorByDivisor(const uint64_t divisor, Denominator &denominator);
00608
00618     ACTIV_FIELD_TYPES_API static StatusCode GetDenominatorByMultiplierPower(const size_t multiplierPower, Denominator &denominator);
00619
00630     ACTIV_FIELD_TYPES_API static StatusCode GetDenominatorByMultiplier(const uint64_t multiplier, Denominator &denominator);
00631
00640     ACTIV_FIELD_TYPES_API static Denominator GetLowestCommonDenominator(const Denominator firstDenominator, const Denominator secondDenominator);
00641
00649     static bool IsValidNumerator(int64_t numerator);
00650
00658     static bool IsValidDenominator(Denominator denominator);
00659
00670     ACTIV_FIELD_TYPES_API static StatusCode ValidateSerializedLengthAndBody(MessageValidator &messageValidator, size_t &serializedBodyOffset, size_t &serializedBodyLength);
00671
00679     static bool IsValidSerializedBodyLength(const size_t serializedBodyLength);
00680
00681 private:
00685     class SerializedHeaderDefinitions
00686     {
00687     public:
00688         typedef byte_t SerializedHeader;
00689
00690         static const size_t IS_NEGATIVE_OFFSET  = 0;
00691         static const size_t IS_NEGATIVE_LENGTH  = 1;
00692         static const size_t LENGTH_OFFSET       = (IS_NEGATIVE_OFFSET + IS_NEGATIVE_LENGTH);
00693         static const size_t LENGTH_LENGTH       = 2;
00694         static const size_t DENOMINATOR_OFFSET  = (LENGTH_OFFSET + LENGTH_LENGTH);
00695         static const size_t DENOMINATOR_LENGTH  = 5;
00696
00706         static SerializedHeader GetSerializedHeader(const bool isNegative, const size_t length, const Denominator denominator);
00707
00715         static bool IsNegative(const SerializedHeader serializedHeader);
00716
00724         static size_t GetLength(const SerializedHeader serializedHeader);
00725
00733         static Denominator GetDenominator(const SerializedHeader serializedHeader);
00734     };
00735
00743     bool GetSignAndAbsoluteValue(uint64_t &absoluteValue) const;
00744
00750     size_t GetCompressedNumeratorSize() const;
00751
00761     template <typename T> StatusCode SerializeBody(void *pSerializedBody) const;
00762
00775     template <typename T> StatusCode DeserializeBody(const void * const pSerializedBody);
00776
00787     ACTIV_FIELD_TYPES_API static StatusCode ScaleNumerator(int64_t &numerator, const Denominator sourceDenominator, const Denominator targetDenominator);
00788
00800     ACTIV_FIELD_TYPES_API static StatusCode ScaleNumerator(int64_t &numerator, const uint64_t divisor, const bool shouldOnlyReturnDecimalDenominator, Denominator &denominator);
00801
00812     static StatusCode ScaleNumeratorToBestPrecision(int64_t &numerator, const Denominator sourceDenominator, Denominator &targetDenominator);
00813
00825     static StatusCode ScaleNumeratorToBestPrecision(int64_t &numerator, const uint64_t divisor, const bool shouldOnlyReturnDecimalDenominator, Denominator &denominator);
00826
00836     static StatusCode IncrementNumerator(int64_t &numerator, int64_t increment);
00837
00847     static StatusCode IncrementNumerator(uint64_t &numerator, uint64_t increment);
00848
00858     static StatusCode DecrementNumerator(int64_t &numerator, int64_t decrement);
00859
00869     static StatusCode DecrementNumerator(uint64_t &numerator, uint64_t decrement);
00870
00880     static StatusCode MultiplyNumerator(int64_t &numerator, int64_t multiplier);
00881
00891     static StatusCode MultiplyNumerator(uint64_t &numerator, uint64_t multiplier);
00892
00902     static StatusCode DivideNumerator(int64_t &numerator, int64_t divisor);
00903
00913     static StatusCode DivideNumerator(uint64_t &numerator, uint64_t divisor);
00914
00921     ACTIV_FIELD_TYPES_API static void CompressNumeratorAndDenominator(int64_t &numerator, Denominator &denominator);
00922
00929     ACTIV_FIELD_TYPES_API static void CompressNumeratorAndDivisor(int64_t &numerator, uint64_t &divisor);
00930
00938     static uint64_t GetAbsoluteValue(const int64_t value);
00939
00947     static size_t GetCompressedValueSize(const uint64_t value);
00948
00962     static StatusCode GetDenominatorByDivisorOrMultiple(const uint64_t divisor, const bool shouldOnlyReturnDecimalDenominator, Denominator &denominator);
00963
00972     static uint64_t GetHighestCommonFactor(const uint64_t firstValue, const uint64_t secondValue);
00973
00984     static StatusCode GetLowestCommonDivisor(uint64_t &lowestCommonDivisor, const uint64_t firstValue, const uint64_t secondValue);
00985
00996     static StatusCode GetLowerDenominator(Denominator &denominator);
00997
00998     int64_t     m_numerator;
00999     Denominator m_denominator;
01000
01001     ACTIV_FIELD_TYPES_API static const DenominatorType  m_denominatorTypeList[NUMBER_OF_DENOMINATORS];
01002
01003     friend class TRational;
01004 };
01005
01006 // ---------------------------------------------------------------------------------------------------------------------------------
01007
01008 inline Rational::Rational() :
01009     IFieldType(FIELD_TYPE)
01010 {
01011     m_isInitialized = false;
01012 }
01013
01014 // ---------------------------------------------------------------------------------------------------------------------------------
01015
01016 inline Rational::Rational(const int64_t numerator, const Denominator denominator, bool shouldCompress) :
01017     IFieldType(FIELD_TYPE)
01018 {
01019     ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, Set(numerator, denominator, shouldCompress));
01020 }
01021
01022 // ---------------------------------------------------------------------------------------------------------------------------------
01023
01024 inline Rational::~Rational()
01025 {
01026 }
01027
01028 // ---------------------------------------------------------------------------------------------------------------------------------
01029
01030 inline bool Rational::operator==(const Rational &rhs) const
01031 {
01032     int result;
01033     ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, Compare(rhs, result));
01034
01035     return (0 == result);
01036 }
01037
01038 // ---------------------------------------------------------------------------------------------------------------------------------
01039
01040 inline bool Rational::operator!=(const Rational &rhs) const
01041 {
01042     return !((*this) == rhs);
01043 }
01044
01045 // ---------------------------------------------------------------------------------------------------------------------------------
01046
01047 inline bool Rational::operator<(const Rational &rhs) const
01048 {
01049     int result;
01050     ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, Compare(rhs, result));
01051
01052     return (result < 0);
01053 }
01054
01055 // ---------------------------------------------------------------------------------------------------------------------------------
01056
01057 inline bool Rational::operator<=(const Rational &rhs) const
01058 {
01059     return !((*this) > rhs);
01060 }
01061
01062 // ---------------------------------------------------------------------------------------------------------------------------------
01063
01064 inline bool Rational::operator>(const Rational &rhs) const
01065 {
01066     int result;
01067     ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, Compare(rhs, result));
01068
01069     return (result > 0);
01070 }
01071
01072 // ---------------------------------------------------------------------------------------------------------------------------------
01073
01074 inline bool Rational::operator>=(const Rational &rhs) const
01075 {
01076     return !((*this) < rhs);
01077 }
01078
01079 // ---------------------------------------------------------------------------------------------------------------------------------
01080
01081 inline Rational& Rational::operator+=(const Rational &rhs)
01082 {
01083     ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, Add(rhs, false));
01084
01085     return (*this);
01086 }
01087
01088 // ---------------------------------------------------------------------------------------------------------------------------------
01089
01090 inline Rational& Rational::operator-=(const Rational &rhs)
01091 {
01092     ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, Subtract(rhs, false));
01093
01094     return (*this);
01095 }
01096
01097 // ---------------------------------------------------------------------------------------------------------------------------------
01098
01099 inline Rational& Rational::operator*=(const Rational &rhs)
01100 {
01101     ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, Multiply(rhs, false));
01102
01103     return (*this);
01104 }
01105
01106 // ---------------------------------------------------------------------------------------------------------------------------------
01107
01108 inline Rational& Rational::operator/=(const Rational &rhs)
01109 {
01110     ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, Divide(rhs, false));
01111
01112     return (*this);
01113 }
01114
01115 // ---------------------------------------------------------------------------------------------------------------------------------
01116
01117 inline StatusCode Rational::Set(const int64_t numerator, const Denominator denominator, bool shouldCompress)
01118 {
01119     if ((!IsValidNumerator(numerator)) || (!IsValidDenominator(denominator)))
01120         return STATUS_CODE_INVALID_PARAMETER;
01121
01122     m_numerator = (((DENOMINATOR_UNDEFINED == denominator) || (DENOMINATOR_CABINET == denominator)) ? 0 : numerator);
01123     m_denominator = denominator;
01124
01125     if (shouldCompress)
01126         CompressNumeratorAndDenominator(m_numerator, m_denominator);
01127
01128     m_isInitialized = true;
01129
01130     return STATUS_CODE_SUCCESS;
01131 }
01132
01133 // ---------------------------------------------------------------------------------------------------------------------------------
01134
01135 inline StatusCode Rational::Get(int64_t &numerator, Denominator &denominator) const
01136 {
01137     if (!IsInitialized())
01138         return STATUS_CODE_NOT_INITIALIZED;
01139
01140     numerator = m_numerator;
01141     denominator = m_denominator;
01142
01143     return STATUS_CODE_SUCCESS;
01144 }
01145
01146 // ---------------------------------------------------------------------------------------------------------------------------------
01147
01148 inline double Rational::Get() const
01149 {
01150     double value;
01151
01152     ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, GetDouble(value));
01153
01154     return value;
01155 }
01156
01157 // ---------------------------------------------------------------------------------------------------------------------------------
01158
01159 inline int64_t Rational::GetNumerator() const
01160 {
01161     if (!IsInitialized())
01162         ACTIV_THROW(StatusCodeException, STATUS_CODE_NOT_INITIALIZED);
01163
01164     return m_numerator;
01165 }
01166
01167 // ---------------------------------------------------------------------------------------------------------------------------------
01168
01169 inline StatusCode Rational::GetNumerator(int64_t &numerator, const Denominator denominator) const
01170 {
01171     if (!IsInitialized())
01172         return STATUS_CODE_NOT_INITIALIZED;
01173
01174     numerator = m_numerator;
01175
01176     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, ScaleNumerator(numerator, m_denominator, denominator));
01177
01178     return STATUS_CODE_SUCCESS;
01179 }
01180
01181 // ---------------------------------------------------------------------------------------------------------------------------------
01182
01183 inline StatusCode Rational::SetDenominator(const Denominator denominator)
01184 {
01185     if (!IsInitialized())
01186         return STATUS_CODE_NOT_INITIALIZED;
01187
01188     if (!IsValidDenominator(denominator))
01189         return STATUS_CODE_INVALID_PARAMETER;
01190
01191     int64_t numerator = m_numerator;
01192
01193     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, ScaleNumerator(numerator, m_denominator, denominator));
01194
01195     m_numerator = numerator;
01196     m_denominator = denominator;
01197
01198     return STATUS_CODE_SUCCESS;
01199 }
01200
01201 // ---------------------------------------------------------------------------------------------------------------------------------
01202
01203 inline Rational::Denominator Rational::GetDenominator() const
01204 {
01205     if (!IsInitialized())
01206         ACTIV_THROW(StatusCodeException, STATUS_CODE_NOT_INITIALIZED);
01207
01208     return m_denominator;
01209 }
01210
01211 // ---------------------------------------------------------------------------------------------------------------------------------
01212
01213 inline StatusCode Rational::GetDouble(double &value) const
01214 {
01215     int64_t numerator;
01216     uint64_t divisor;
01217     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, GetNumeratorAndDivisor(numerator, divisor));
01218
01219     value = static_cast<double>(numerator) / static_cast<double>(divisor);
01220
01221     return STATUS_CODE_SUCCESS;
01222 }
01223
01224 // ---------------------------------------------------------------------------------------------------------------------------------
01225
01226 inline StatusCode Rational::Compress()
01227 {
01228     if (!IsInitialized())
01229         return STATUS_CODE_NOT_INITIALIZED;
01230
01231     CompressNumeratorAndDenominator(m_numerator, m_denominator);
01232
01233     return STATUS_CODE_SUCCESS;
01234 }
01235
01236 // ---------------------------------------------------------------------------------------------------------------------------------
01237
01238 inline void Rational::Reset()
01239 {
01240     m_isInitialized = false;
01241 }
01242
01243 // ---------------------------------------------------------------------------------------------------------------------------------
01244
01245 inline void Rational::Clear()
01246 {
01247     m_isInitialized = false;
01248 }
01249
01250 // ---------------------------------------------------------------------------------------------------------------------------------
01251
01252 inline size_t Rational::GetSerializedLength() const
01253 {
01254     return GetSerializedBodyLength();
01255 }
01256
01257 // ---------------------------------------------------------------------------------------------------------------------------------
01258
01259 inline size_t Rational::GetSerializedBodyLength() const
01260 {
01261     return (IsInitialized() ? GetMaxSerializedBodyLength(GetCompressedNumeratorSize()) : 0);
01262 }
01263
01264 // ---------------------------------------------------------------------------------------------------------------------------------
01265
01266 inline size_t Rational::GetMaxSerializedLength(const size_t size)
01267 {
01268     return GetMaxSerializedBodyLength(size);
01269 }
01270
01271 // ---------------------------------------------------------------------------------------------------------------------------------
01272
01273 inline size_t Rational::GetMaxSerializedBodyLength(const size_t size)
01274 {
01275     return sizeof(SerializedHeaderDefinitions::SerializedHeader) + size;
01276 }
01277
01278 // ---------------------------------------------------------------------------------------------------------------------------------
01279
01280 inline StatusCode Rational::GetDenominatorType(const Denominator denominator, const DenominatorType *&pDenominatorType)
01281 {
01282     if (!IsValidDenominator(denominator))
01283         return STATUS_CODE_INVALID_PARAMETER;
01284
01285     pDenominatorType = m_denominatorTypeList + denominator;
01286
01287     return STATUS_CODE_SUCCESS;
01288 }
01289
01290 // ---------------------------------------------------------------------------------------------------------------------------------
01291
01292 inline bool Rational::IsValidNumerator(int64_t numerator)
01293 {
01294     return (numerator >= MIN_NUMERATOR); // NOTE: (MAX_NUMERATOR == INT64_MAX) so no need to check.
01295 }
01296
01297 // ---------------------------------------------------------------------------------------------------------------------------------
01298
01299 inline bool Rational::IsValidDenominator(Denominator denominator)
01300 {
01301     return (denominator < NUMBER_OF_DENOMINATORS);
01302 }
01303
01304 // ---------------------------------------------------------------------------------------------------------------------------------
01305
01306 inline bool Rational::IsValidSerializedBodyLength(const size_t serializedBodyLength)
01307 {
01308     return ((GetMaxSerializedBodyLength(sizeof(int64_t)) == serializedBodyLength) || (GetMaxSerializedBodyLength(sizeof(int32_t)) == serializedBodyLength) || (GetMaxSerializedBodyLength(sizeof(int16_t)) == serializedBodyLength) || (GetMaxSerializedBodyLength(sizeof(int8_t)) == serializedBodyLength));
01309 }
01310
01311 // ---------------------------------------------------------------------------------------------------------------------------------
01312
01313 inline size_t Rational::GetCompressedNumeratorSize() const
01314 {
01315     return GetCompressedValueSize(GetAbsoluteValue(m_numerator));
01316 }
01317
01318 // ---------------------------------------------------------------------------------------------------------------------------------
01319
01320 inline uint64_t Rational::GetAbsoluteValue(const int64_t value)
01321 {
01322     return static_cast<uint64_t>((value >= 0) ? value : -value);
01323 }
01324
01325 // ---------------------------------------------------------------------------------------------------------------------------------
01326
01327 inline size_t Rational::GetCompressedValueSize(const uint64_t value)
01328 {
01329     if (value <= UINT8_MAX)
01330         return sizeof(uint8_t);
01331
01332     if (value <= UINT16_MAX)
01333         return sizeof(uint16_t);
01334
01335     if (value <= UINT32_MAX)
01336         return sizeof(uint32_t);
01337
01338     return sizeof(uint64_t);
01339 }
01340
01341 // ---------------------------------------------------------------------------------------------------------------------------------
01342 // ---------------------------------------------------------------------------------------------------------------------------------
01343
01344 inline Rational::DenominatorType::DenominatorType(const uint64_t divisor, const uint64_t multiplier, const size_t nDecimalPlaces, const size_t nDivisorDigits, const size_t multiplierPower) :
01345     m_divisor(divisor),
01346     m_multiplier(multiplier),
01347     m_nDecimalPlaces(nDecimalPlaces),
01348     m_nDivisorDigits(nDivisorDigits),
01349     m_multiplierPower(multiplierPower)
01350 {
01351 }
01352
01353 // ---------------------------------------------------------------------------------------------------------------------------------
01354
01355 inline uint64_t Rational::DenominatorType::GetDivisor() const
01356 {
01357     return m_divisor;
01358 }
01359
01360 // ---------------------------------------------------------------------------------------------------------------------------------
01361
01362 inline uint64_t Rational::DenominatorType::GetMultiplier() const
01363 {
01364     return m_multiplier;
01365 }
01366
01367 // ---------------------------------------------------------------------------------------------------------------------------------
01368
01369 inline size_t Rational::DenominatorType::GetDecimalPlaces() const
01370 {
01371     return m_nDecimalPlaces;
01372 }
01373
01374 // ---------------------------------------------------------------------------------------------------------------------------------
01375
01376 inline size_t Rational::DenominatorType::GetDivisorDigits() const
01377 {
01378     return m_nDivisorDigits;
01379 }
01380
01381 // ---------------------------------------------------------------------------------------------------------------------------------
01382
01383 inline size_t Rational::DenominatorType::GetMultiplierPower() const
01384 {
01385     return m_multiplierPower;
01386 }
01387
01388 // ---------------------------------------------------------------------------------------------------------------------------------
01389
01390 inline bool Rational::DenominatorType::IsDivisor() const
01391 {
01392     return (0 != m_divisor);
01393 }
01394
01395 // ---------------------------------------------------------------------------------------------------------------------------------
01396
01397 inline bool Rational::DenominatorType::IsDivisorBinary() const
01398 {
01399     // HACK: should really check a power of 2.
01400     return ((IsDivisor()) && (0 != (m_divisor % 10)));
01401 }
01402
01403 // ---------------------------------------------------------------------------------------------------------------------------------
01404
01405 inline bool Rational::DenominatorType::IsDivisorDecimal() const
01406 {
01407     // HACK: should really check a power of 10.
01408     return ((IsDivisor()) && (0 == (m_divisor % 10)));
01409 }
01410
01411 // ---------------------------------------------------------------------------------------------------------------------------------
01412
01413 inline bool Rational::DenominatorType::IsMultiplier() const
01414 {
01415     return (0 != m_multiplier);
01416 }
01417
01418 // ---------------------------------------------------------------------------------------------------------------------------------
01419 // ---------------------------------------------------------------------------------------------------------------------------------
01420
01431 inline const Rational operator+(const Rational &lhs, const Rational &rhs)
01432 {
01433     return Rational(lhs) += rhs;
01434 }
01435
01436 // ---------------------------------------------------------------------------------------------------------------------------------
01437
01448 inline const Rational operator-(const Rational &lhs, const Rational &rhs)
01449 {
01450     return Rational(lhs) -= rhs;
01451 }
01452
01453 // ---------------------------------------------------------------------------------------------------------------------------------
01454 // ---------------------------------------------------------------------------------------------------------------------------------
01455
01466 inline const Rational operator*(const Rational &lhs, const Rational &rhs)
01467 {
01468     return Rational(lhs) *= rhs;
01469 }
01470
01471 // ---------------------------------------------------------------------------------------------------------------------------------
01472
01483 inline const Rational operator/(const Rational &lhs, const Rational &rhs)
01484 {
01485     return Rational(lhs) /= rhs;
01486 }
01487
01488 // ---------------------------------------------------------------------------------------------------------------------------------
01489 // ---------------------------------------------------------------------------------------------------------------------------------
01490
01494 template<>
01495 class FieldTypeToClass<FIELD_TYPE_RATIONAL>
01496 {
01497 public:
01498     typedef Rational Type;
01499 };
01500
01501 } // namespace Activ
01502
01503 #endif // (!defined ACTIV_FIELD_TYPES_RATIONAL_H)
Generated on Wed Oct 8 14:01:48 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivContentGatewayApi

RealtimeRequestHelper.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_CONTENT_GATEWAY_API_REALTIME_REQUEST_HELPER_H)
00010 #define ACTIV_CONTENT_GATEWAY_API_REALTIME_REQUEST_HELPER_H
00011
00012 #include "ActivContentPlatform/ActivContentGatewayApi/External.h"
00013
00014 namespace Activ
00015 {
00016
00017 namespace ContentPlatform
00018 {
00019
00020 namespace ContentGatewayApi
00021 {
00022
00023 class ContentGatewayClient;
00024
00025 // ---------------------------------------------------------------------------------------------------------------------------------
00026
00033 template<MessageType MESSAGE_TYPE_VALUE, typename REQUEST_PARAMETERS>
00034 class RealtimeRequestHelper
00035 {
00036 public:
00037     typedef REQUEST_PARAMETERS RequestParameters;
00038     typedef RealtimeResponseParameters ResponseParameters;
00039
00053     ACTIV_CONTENT_GATEWAY_API static StatusCode SendRequest(const ContentGatewayClient &client,
00054         const RequestParameters &requestParameters,
00055         ResponseParameters &responseParameters, const TimeoutPeriod timeoutPeriod = Port::defaultTimeout);
00056
00068     ACTIV_CONTENT_GATEWAY_API static StatusCode SendRequest(const ContentGatewayClient &client, SyncRequestId &syncRequestId,
00069         const RequestParameters &requestParameters);
00070
00082     ACTIV_CONTENT_GATEWAY_API static StatusCode PostRequest(const ContentGatewayClient &client, const RequestId &requestId,
00083         const RequestParameters &requestParameters);
00084
00098     ACTIV_CONTENT_GATEWAY_API static StatusCode GetResponse(const ContentGatewayClient &client, SyncRequestId &syncRequestId,
00099         ResponseParameters &responseParameters, const TimeoutPeriod timeoutPeriod = Port::defaultTimeout);
00100
00117     ACTIV_CONTENT_GATEWAY_API static StatusCode Deserialize(const ContentGatewayClient &client, const HeapMessage &response,
00118         ResponseParameters &responseParameters);
00119
00120     static const MessageType MESSAGE_TYPE = MESSAGE_TYPE_VALUE;
00121 };
00122
00123 } // namespace ContentGatewayApi
00124
00125 } // namespace ContentPlatform
00126
00127 } // namespace Activ
00128
00129 #endif // (!defined ACTIV_CONTENT_GATEWAY_API_REALTIME_REQUEST_HELPER_H)
Generated on Wed Oct 8 14:01:45 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivContentGatewayApiCommon

RealtimeTypes.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_CONTENT_GATEWAY_API_COMMON_REALTIME_TYPES_H)
00010 #define ACTIV_CONTENT_GATEWAY_API_COMMON_REALTIME_TYPES_H
00011
00012 #include "ActivContentPlatform/ActivContentGatewayApiCommon/External.h"
00013 #include "ActivContentPlatform/ActivContentGatewayApiCommon/Types.h"
00014 #include "ActivContentPlatform/ActivFeedCommon/FieldIds.h"
00015 #include "ActivContentPlatform/ActivFeedCommon/RelationshipIds.h"
00016 #include "ActivContentPlatform/ActivFeedCommon/UpdateIds.h"
00017 #include "ActivContentPlatform/ActivFeedCommon/EventTypes.h"
00018 #include "ActivContentPlatform/ActivFeedCommon/PermissionLevels.h"
00019
00020 #include "boost/integer_traits.hpp"
00021
00022 namespace Activ
00023 {
00024
00025 namespace ContentPlatform
00026 {
00027
00028 namespace ContentGatewayApi
00029 {
00030
00031 typedef uint8_t RequestBlockCount;
00032 typedef uint8_t ResponseBlockCount;
00033
00034 #define ACTIV_DECLARE_FLAGS(value, id)  static const Flags id = value;
00035 #define ACTIV_DECLARE_REQUEST_FLAGS(value, id)  static const RequestFlags id = value;
00036
00037 // ---------------------------------------------------------------------------------------------------------------------------------
00038
00042 class SubscribeParameters
00043 {
00044 public:
00050     ACTIV_CONTENT_GATEWAY_API_COMMON_API SubscribeParameters();
00051
00052     #define ACTIV_SUBSCRIBE_PARAMETERS_SUBSCRIBE_TYPE_LIST(d)                                                                                                           \
00053         d(TYPE_NONE)                                                                                                    \
00054         d(TYPE_ADD_OR_DELETE)                                                                       \
00055         d(TYPE_EVENT_TYPE_FILTER_INCLUDE_LIST)                          \
00056         d(TYPE_EVENT_TYPE_FILTER_EXCLUDE_LIST)                      \
00057         d(TYPE_FULL)
00059     enum Type
00060     {
00061         ACTIV_SUBSCRIBE_PARAMETERS_SUBSCRIBE_TYPE_LIST(ACTIV_DECLARE_VALUE_WITH_COMMA)
00062         NUMBER_OF_TYPES
00063     };
00064
00065     typedef std::vector<Feed::EventType> EventTypeList;
00066
00067     Type            m_type;
00068     EventTypeList   m_eventTypeList;
00069 };
00070
00071 // ---------------------------------------------------------------------------------------------------------------------------------
00072 // ---------------------------------------------------------------------------------------------------------------------------------
00073
00077 class SubscribeFeedParameters : public SubscribeParameters
00078 {
00079 public:
00086     ACTIV_CONTENT_GATEWAY_API_COMMON_API SubscribeFeedParameters();
00087
00088     Feed::PermissionLevel   m_permissionLevel;
00089 };
00090
00091 // ---------------------------------------------------------------------------------------------------------------------------------
00092 // ---------------------------------------------------------------------------------------------------------------------------------
00093
00097 class SubscribeTableParameters : public SubscribeParameters
00098 {
00099 public:
00106     ACTIV_CONTENT_GATEWAY_API_COMMON_API SubscribeTableParameters();
00107
00108     Feed::TableNoList       m_tableNumberList;
00109     Feed::PermissionLevel   m_permissionLevel;
00110     RequestId               m_updateRequestId;
00111 };
00112
00113 // ---------------------------------------------------------------------------------------------------------------------------------
00114 // ---------------------------------------------------------------------------------------------------------------------------------
00115
00119 class RequestBlock
00120 {
00121 public:
00128     ACTIV_CONTENT_GATEWAY_API_COMMON_API RequestBlock();
00129
00135     ACTIV_CONTENT_GATEWAY_API_COMMON_API void Clear();
00136
00145     ACTIV_CONTENT_GATEWAY_API_COMMON_API StatusCode Serialize(MessageBuilder &messageBuilder) const;
00146
00155     ACTIV_CONTENT_GATEWAY_API_COMMON_API StatusCode Deserialize(MessageValidator &messageValidator);
00156
00157     #define ACTIV_REQUEST_BLOCK_FLAG_LIST(d)                                                        \
00158         d(0x0000,   FLAG_NONE)                                                                      \
00159         d(0x0001,   FLAG_ALL_FIELDS)
00161     typedef uint16_t Flags;
00162     ACTIV_REQUEST_BLOCK_FLAG_LIST(ACTIV_DECLARE_FLAGS)
00163
00164     Flags                   m_flags;
00165     Feed::RelationshipId    m_relationshipId;
00166     Feed::FieldIdList       m_fieldIdList;
00167 };
00168
00169 // ---------------------------------------------------------------------------------------------------------------------------------
00170
00174 typedef std::vector<RequestBlock> RequestBlockList;
00175
00176 // ---------------------------------------------------------------------------------------------------------------------------------
00177 // ---------------------------------------------------------------------------------------------------------------------------------
00178
00182 class RealtimeRequestParameters
00183 {
00184 public:
00192     ACTIV_CONTENT_GATEWAY_API_COMMON_API RealtimeRequestParameters();
00193
00197     ACTIV_CONTENT_GATEWAY_API_COMMON_API void Clear();
00198
00199     #define ACTIV_REALTIME_REQUEST_PARAMETERS_FLAG_LIST(d)                                                                              \
00200         d(0x0000,   FLAG_NONE)                                                                                                          \
00201         d(0x0001,   FLAG_IGNORE_ALIAS)
00203     typedef uint16_t Flags;
00204     ACTIV_REALTIME_REQUEST_PARAMETERS_FLAG_LIST(ACTIV_DECLARE_FLAGS)
00205
00206     static const ResponseBlockCount DEFAULT_MAX_RESPONSE_BLOCKS = 64;
00207
00208     Flags                   m_flags;
00209     Feed::PermissionLevel   m_permissionLevel;
00210     ResponseBlockCount      m_maxResponseBlocks;
00211     RequestBlockList        m_requestBlockList;
00212     SubscribeParameters     m_subscribeParameters;
00213 };
00214
00215 // ---------------------------------------------------------------------------------------------------------------------------------
00216 // ---------------------------------------------------------------------------------------------------------------------------------
00217
00221 class TableNumberRequestParameters : public RealtimeRequestParameters
00222 {
00223 public:
00230     ACTIV_CONTENT_GATEWAY_API_COMMON_API TableNumberRequestParameters();
00231
00232     Feed::TableNo   m_tableNumber;
00233     uint16_t        m_numberOfRecords;
00234 };
00235
00236 // ---------------------------------------------------------------------------------------------------------------------------------
00237 // ---------------------------------------------------------------------------------------------------------------------------------
00238
00242 class SymbolIdRequestParameters : public RealtimeRequestParameters
00243 {
00244 public:
00245     SymbolId    m_symbolId;
00246 };
00247
00248 // ---------------------------------------------------------------------------------------------------------------------------------
00249 // ---------------------------------------------------------------------------------------------------------------------------------
00250
00254 class SymbolIdCountRequestParameters : public RealtimeRequestParameters
00255 {
00256 public:
00262     ACTIV_CONTENT_GATEWAY_API_COMMON_API SymbolIdCountRequestParameters();
00263
00264     SymbolId    m_symbolId;
00265     uint16_t    m_numberOfRecords;
00266 };
00267
00268 // ---------------------------------------------------------------------------------------------------------------------------------
00269 // ---------------------------------------------------------------------------------------------------------------------------------
00270
00274 class SymbolIdListRequestParameters : public RealtimeRequestParameters
00275 {
00276 public:
00277     SymbolIdList    m_symbolIdList;
00278 };
00279
00280 // ---------------------------------------------------------------------------------------------------------------------------------
00281 // ---------------------------------------------------------------------------------------------------------------------------------
00282
00286 class PatternMatchRequestParameters : public RealtimeRequestParameters
00287 {
00288 public:
00295     ACTIV_CONTENT_GATEWAY_API_COMMON_API PatternMatchRequestParameters();
00296
00297     #define ACTIV_PATTERN_MATCH_REQUEST_PARAMETERS_REQUEST_FLAG_LIST(d)                                             \
00298         d(0x0000,   REQUEST_FLAG_NONE)                                                                              \
00299         d(0x0001,   REQUEST_FLAG_WATCH)                                     \
00300         d(0x0002,   REQUEST_FLAG_REVERSE_ORDER)
00302     typedef uint16_t RequestFlags;
00303     ACTIV_PATTERN_MATCH_REQUEST_PARAMETERS_REQUEST_FLAG_LIST(ACTIV_DECLARE_REQUEST_FLAGS)
00304
00305     Feed::TableNo   m_tableNumber;
00306     std::string     m_symbolPattern;
00307     RequestFlags    m_requestFlags;
00308 };
00309
00310 // ---------------------------------------------------------------------------------------------------------------------------------
00311 // ---------------------------------------------------------------------------------------------------------------------------------
00312
00316 class PatternMatchListRequestParameters : public RealtimeRequestParameters
00317 {
00318 public:
00325     ACTIV_CONTENT_GATEWAY_API_COMMON_API PatternMatchListRequestParameters();
00326
00327     #define ACTIV_REQUEST_FLAG_LIST(d)                                                                              \
00328         d(0x0000,   REQUEST_FLAG_NONE)                                                                              \
00329         d(0x0001,   REQUEST_FLAG_WATCH)                                     \
00330         d(0x0002,   REQUEST_FLAG_REVERSE_ORDER)
00332     typedef uint16_t RequestFlags;
00333     ACTIV_REQUEST_FLAG_LIST(ACTIV_DECLARE_REQUEST_FLAGS)
00334
00335     Feed::TableNo               m_tableNumber;
00336     std::vector<std::string>    m_symbolPatternList;
00337     RequestFlags                m_requestFlags;
00338 };
00339
00340 // ---------------------------------------------------------------------------------------------------------------------------------
00341 // ---------------------------------------------------------------------------------------------------------------------------------
00342
00346 class MatchRequestParameters : public RealtimeRequestParameters
00347 {
00348 public:
00352     #define MATCH_REQUEST_MATCH_TYPE_LIST(d)                                                                                \
00353         d(MATCH_TYPE_COMPOSITE)                                             \
00354         d(MATCH_TYPE_PRIMARY)
00356     enum MatchType
00357     {
00358         MATCH_REQUEST_MATCH_TYPE_LIST(ACTIV_DECLARE_VALUE_WITH_COMMA)
00359         NUMBER_OF_MATCH_TYPES
00360     };
00361
00362     MatchType   m_matchType;
00363 };
00364
00365 // ---------------------------------------------------------------------------------------------------------------------------------
00366 // ---------------------------------------------------------------------------------------------------------------------------------
00367
00371 class SymbolIdMatchRequestParameters : public MatchRequestParameters
00372 {
00373 public:
00374     SymbolId    m_symbolId;
00375 };
00376
00377 // ---------------------------------------------------------------------------------------------------------------------------------
00378 // ---------------------------------------------------------------------------------------------------------------------------------
00379
00383 class SymbolIdListMatchRequestParameters : public MatchRequestParameters
00384 {
00385 public:
00386     SymbolIdList    m_symbolIdList;
00387 };
00388
00389 // ---------------------------------------------------------------------------------------------------------------------------------
00390 // ---------------------------------------------------------------------------------------------------------------------------------
00391
00395 class ResponseBlock
00396 {
00397 public:
00398     typedef uint8_t Status;
00399     typedef uint8_t Flags;
00400
00404     #define ACTIV_RESPONSE_BLOCK_STATUS_LIST(d)                                         \
00405         d(0,    STATUS_SUCCESS, "success")                                              \
00406         d(2,    STATUS_SOURCE_NOT_FOUND, "source not found")                            \
00407         d(3,    STATUS_SOURCE_NOT_PERMISSIONED, "source not permissioned")              \
00408         d(4,    STATUS_RELATIONSHIP_NOT_FOUND, "relationship not found")                \
00409         d(5,    STATUS_RELATIONSHIP_NOT_PERMISSIONED, "relationship not permissioned")  \
00410         d(6,    STATUS_NAVIGATION_NOT_FOUND, "navigation not found")                    \
00411         d(7,    STATUS_NAVIGATION_NOT_PERMISSIONED, "navigation not permissioned")      \
00412         d(8,    STATUS_TARGET_NOT_FOUND, "target not found")                            \
00413         d(9,    STATUS_TARGET_NOT_PERMISSIONED, "target not permissioned")              \
00414         d(10,   STATUS_INTERNAL_ERROR, "internal error")                                \
00415         d(11,   STATUS_INVALID_SOURCE_TABLE, "invalid source table")                    \
00416         d(12,   STATUS_PERMISSION_LEVEL_NOT_AVAILABLE, "permission level not available")
00417
00423     #define ACTIV_RESPONSE_BLOCK_FLAG_LIST(d)                                           \
00424         d(0x00, FLAG_NONE)                                          \
00425         d(0x01, FLAG_STALE)
00434     ACTIV_CONTENT_GATEWAY_API_COMMON_API static std::string StatusToString(const Status status);
00435
00443     ACTIV_CONTENT_GATEWAY_API_COMMON_API static std::string FlagsToString(const Flags flags);
00444
00450     bool IsValidResponse() const;
00451
00459     bool IsResponseKeyDefined() const;
00460
00461     Status                      m_status;
00462     Flags                       m_flags;
00463     SymbolId                    m_resolvedKey;
00464     SymbolId                    m_responseKey;
00465     Feed::RelationshipId        m_relationshipId;
00466     Feed::PermissionId          m_permissionId;
00467     Feed::PermissionLevel       m_permissionLevel;
00468     Feed::PermissionLevelData   m_permissionLevelData;
00469     FieldData                   m_fieldData;
00470
00474     #define ACTIV_DECLARE_RESPONSE_BLOCK_STATUS(value, id, name)    static const Status id = value;
00475
00479     ACTIV_RESPONSE_BLOCK_STATUS_LIST(ACTIV_DECLARE_RESPONSE_BLOCK_STATUS)
00480
00481
00484     ACTIV_RESPONSE_BLOCK_FLAG_LIST(ACTIV_DECLARE_FLAGS)
00485
00486     #undef ACTIV_DECLARE_RESPONSE_BLOCK_STATUS
00487 };
00488
00489 // ---------------------------------------------------------------------------------------------------------------------------------
00490
00491 inline bool ResponseBlock::IsValidResponse() const
00492 {
00493     switch (m_status)
00494     {
00495         case STATUS_SUCCESS:
00496             return true;
00497
00498         default:
00499             return false;
00500     }
00501 }
00502
00503 // ---------------------------------------------------------------------------------------------------------------------------------
00504
00505 inline bool ResponseBlock::IsResponseKeyDefined() const
00506 {
00507     switch (m_status)
00508     {
00509         case STATUS_SUCCESS:
00510         case STATUS_TARGET_NOT_FOUND:
00511         case STATUS_TARGET_NOT_PERMISSIONED:
00512         case STATUS_PERMISSION_LEVEL_NOT_AVAILABLE:
00513             return true;
00514
00515         default:
00516             return false;
00517     }
00518 }
00519
00520 // ---------------------------------------------------------------------------------------------------------------------------------
00521
00525 typedef std::vector<ResponseBlock> ResponseBlockList;
00526
00527 // ---------------------------------------------------------------------------------------------------------------------------------
00528 // ---------------------------------------------------------------------------------------------------------------------------------
00529
00533 class RealtimeResponseParameters
00534 {
00535 public:
00541     ACTIV_CONTENT_GATEWAY_API_COMMON_API RealtimeResponseParameters();
00542
00549     ACTIV_CONTENT_GATEWAY_API_COMMON_API void Clear();
00550
00551     ResponseBlockList   m_responseBlockList;
00552     SubscriptionCookie  m_subscriptionCookie;
00553 };
00554
00555 // ---------------------------------------------------------------------------------------------------------------------------------
00556 // ---------------------------------------------------------------------------------------------------------------------------------
00557
00561 class RecordUpdate
00562 {
00563 public:
00564     #define ACTIV_RECORD_UPDATE_FLAG_LIST(d)                                                                                                \
00565         d(0x00, FLAG_NONE)                                                                                              \
00566         d(0x01, FLAG_DELETE)                                                                            \
00567         d(0x02, FLAG_STALE)                                         \
00568         d(0x04, FLAG_REFRESH)                                                                                       \
00569         d(0x08, FLAG_REQUEST_KEY)                                                                       \
00570         d(0x10, FLAG_RELATIONSHIP_ID)
00572     typedef uint8_t Flags;
00573     ACTIV_RECORD_UPDATE_FLAG_LIST(ACTIV_DECLARE_FLAGS)
00574
00582     ACTIV_CONTENT_GATEWAY_API_COMMON_API static std::string FlagsToString(const Flags flags);
00583
00589     bool IsNewRecord() const;
00590
00596     bool IsDelete() const;
00597
00598     Flags                       m_flags;
00599     SymbolId                    m_symbolId;
00600     SymbolId                    m_requestKey;
00601     Feed::RelationshipId        m_relationshipId;
00602     Feed::UpdateId              m_updateId;
00603     Feed::EventType             m_eventType;
00604     Feed::PermissionId          m_permissionId;
00605     Feed::PermissionLevel       m_permissionLevel;
00606     Feed::PermissionLevelData   m_permissionLevelData;
00607     FieldData                   m_fieldData;
00608 };
00609
00610 // ---------------------------------------------------------------------------------------------------------------------------------
00611
00612 inline bool RecordUpdate::IsNewRecord() const
00613 {
00614     return Feed::IsUpdateIdNewRecord(m_updateId);
00615 }
00616
00617 // ---------------------------------------------------------------------------------------------------------------------------------
00618
00619 inline bool RecordUpdate::IsDelete() const
00620 {
00621     return (m_flags & FLAG_DELETE);
00622 }
00623
00624 #undef ACTIV_DECLARE_FLAGS
00625 #undef ACTIV_DECLARE_REQUEST_FLAGS
00626
00627 } // namespace ContentGatewayApi
00628
00629 } // namespace ContentPlatform
00630
00631 } // namespace Activ
00632
00633 #endif // (!defined ACTIV_CONTENT_GATEWAY_API_COMMON_REALTIME_TYPES_H)
Generated on Wed Oct 8 14:01:45 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivDatabase

Record.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_DATABASE_RECORD_H)
00010 #define ACTIV_DATABASE_RECORD_H
00011
00012 #include "ActivMiddleware/ActivDatabase/External.h"
00013 #include "ActivMiddleware/ActivDatabase/Definitions.h"
00014 #include "ActivMiddleware/ActivDatabase/ITable.h"
00015 #include "ActivMiddleware/ActivDatabase/FieldListObject.h"
00016
00017 #include <iostream>
00018 #include <string>
00019 #include <memory>
00020
00021 namespace Activ
00022 {
00023
00024 class ScatterBufferHelper;
00025 class IFieldType;
00026
00027 namespace Database
00028 {
00029
00030 class Key;
00031
00032 // ---------------------------------------------------------------------------------------------------------------------------------
00033
00037 class Record : public FieldListObject
00038 {
00039 public:
00043     Record();
00044
00052     ACTIV_DATABASE_API Record(ITable *pTable);
00053
00063     Record(ITable *pTable, const void *pSourceData, const DataId id);
00064
00072     ACTIV_DATABASE_API Record(const Record &rhs);
00073
00081     ACTIV_DATABASE_API Record(const Key &key);
00082
00086     virtual ~Record();
00087
00097     ACTIV_DATABASE_API Record &operator=(const Record &rhs);
00098
00104     ACTIV_DATABASE_API bool operator==(const Record &rhs) const;
00105
00111     ACTIV_DATABASE_API bool operator!=(const Record &rhs) const;
00112
00113     using FieldListObject::Initialize;
00114
00124     StatusCode Initialize(ITable *pTable);
00125
00137     StatusCode Initialize(ITable *pTable, const void *pSourceData, const DataId id);
00138
00148     ACTIV_DATABASE_API StatusCode Initialize(const Record &rhs);
00149
00162     ACTIV_DATABASE_API StatusCode Initialize(const Key &key);
00163
00174     ACTIV_DATABASE_API virtual StatusCode Serialize(MessageBuilder &messageBuilder) const;
00175
00187     ACTIV_DATABASE_API virtual StatusCode Deserialize(ITable *pTable, MessageValidator &messageValidator);
00188
00195     ACTIV_DATABASE_API virtual StatusCode Reset();
00196
00209     StatusCode SetIndexFields(const IndexSpecification::Number indexNo, const ScatterBufferHelper &scatterBufferHelper);
00210
00220     ACTIV_DATABASE_API Key GetKey(const IndexSpecification::Number indexNo) const;
00221
00229     ACTIV_DATABASE_API Key GetPrimaryKey() const;
00230
00239     StatusCode Set(const void *pSourceData);
00240
00246     size_t GetDataLength() const;
00247
00258     StatusCode Validate(const ITable *pTable) const;
00259
00260 private:
00261     static const uint8_t VERSION = 1;
00262
00263     static const size_t MAX_UNSERIALIZED_LENGTH = 2048;
00264 };
00265
00266 // ---------------------------------------------------------------------------------------------------------------------------------
00267
00268 inline Record::Record()
00269 {
00270 }
00271
00272 // ---------------------------------------------------------------------------------------------------------------------------------
00273
00274 inline Record::~Record()
00275 {
00276 }
00277
00278 // ---------------------------------------------------------------------------------------------------------------------------------
00279
00280 inline StatusCode Record::Initialize(ITable *pTable)
00281 {
00282     if ((0 == pTable) || (0 == pTable->GetIdentity()))
00283         return STATUS_CODE_INVALID_PARAMETER;
00284
00285     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, FieldListObject::Initialize(pTable, &pTable->GetFieldList(), pTable->GetRecordLength()));
00286
00287     return m_pTable->ResetRecord(*this);
00288 }
00289
00290 // ---------------------------------------------------------------------------------------------------------------------------------
00291
00292 inline StatusCode Record::Reset()
00293 {
00294     if (!IsInitialized())
00295         return STATUS_CODE_NOT_INITIALIZED;
00296
00297     GetFieldList().ResetData(m_pData);
00298     m_id = UNDEFINED_ID;
00299
00300     return STATUS_CODE_SUCCESS;
00301 }
00302
00303 // ---------------------------------------------------------------------------------------------------------------------------------
00304
00305 inline StatusCode Record::SetIndexFields(const IndexSpecification::Number indexNo, const ScatterBufferHelper &scatterBufferHelper)
00306 {
00307     return (IsInitialized()) ? m_pTable->SetIndexFields(*this, indexNo, scatterBufferHelper) : STATUS_CODE_NOT_INITIALIZED;
00308 }
00309
00310 // ---------------------------------------------------------------------------------------------------------------------------------
00311
00312 inline StatusCode Record::Set(const void *pSourceData)
00313 {
00314     if (!IsInitialized())
00315         return STATUS_CODE_NOT_INITIALIZED;
00316
00317     if (0 == pSourceData)
00318         return STATUS_CODE_INVALID_PARAMETER;
00319
00320     ::memcpy(m_pData, pSourceData, GetDataLength());
00321     return STATUS_CODE_SUCCESS;
00322 }
00323
00324 // ---------------------------------------------------------------------------------------------------------------------------------
00325
00326 inline size_t Record::GetDataLength() const
00327 {
00328     return (IsInitialized()) ? m_pTable->GetRecordLength() : 0;
00329 }
00330
00331 // ---------------------------------------------------------------------------------------------------------------------------------
00332
00333 inline StatusCode Record::Validate(const ITable *pTable) const
00334 {
00335     return (pTable->GetIdentity() == m_tableIdentity) ? STATUS_CODE_SUCCESS : STATUS_CODE_INVALID_RECORD;
00336 }
00337
00338 // ---------------------------------------------------------------------------------------------------------------------------------
00339
00340 }   // namespace Database
00341
00342 }   // namespace Activ
00343
00344 #endif // (!defined ACTIV_DATABASE_RECORD_H)
Generated on Wed Oct 8 14:01:47 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedMessageHandler

RecordFieldListBuilder.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FEED_MESSAGE_HANDLER_RECORD_FIELD_LIST_BUILDER_H)
00010 #define ACTIV_FEED_MESSAGE_HANDLER_RECORD_FIELD_LIST_BUILDER_H
00011
00012 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/External.h"
00013
00014 namespace Activ
00015 {
00016
00017 class MessageBuilder;
00018 class IFieldType;
00019
00020 namespace ContentPlatform
00021 {
00022
00023 namespace Feed
00024 {
00025
00026 class TableTemplate;
00027
00028 // ---------------------------------------------------------------------------------------------------------------------------------
00029
00033 class RecordFieldListBuilder
00034 {
00035 public:
00039     ACTIV_FEED_MESSAGE_HANDLER_API RecordFieldListBuilder();
00040
00047     ACTIV_FEED_MESSAGE_HANDLER_API RecordFieldListBuilder(const TableTemplate &tableTemplate, MessageBuilder &messageBuilder);
00048
00052     ACTIV_FEED_MESSAGE_HANDLER_API ~RecordFieldListBuilder();
00053
00060     ACTIV_FEED_MESSAGE_HANDLER_API void Initialize(const TableTemplate &tableTemplate, MessageBuilder &messageBuilder);
00061
00065     ACTIV_FEED_MESSAGE_HANDLER_API void Reset();
00066
00070     ACTIV_FEED_MESSAGE_HANDLER_API void Clear();
00071
00083     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode AppendField(const FieldId fieldId, const IFieldType &iFieldType);
00084
00097     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode AppendField(const FieldId fieldId, const void * const pSerializedBody, const size_t serializedBodyLength);
00098
00108     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode AppendUndefinedField(const FieldId fieldId);
00109
00115     ACTIV_FEED_MESSAGE_HANDLER_API bool IsInitialized() const;
00116
00117 private:
00118     typedef std::vector<IFieldType *>       CachedFieldList;
00119
00125     RecordFieldListBuilder(const RecordFieldListBuilder &rhs);
00126
00134     RecordFieldListBuilder& operator=(const RecordFieldListBuilder &rhs);
00135
00146     StatusCode GetConvertedField(const FieldType fieldType, const IFieldType &iFieldType, const IFieldType *&pConvertedField);
00147
00148     CachedFieldList         m_cachedFieldList;
00149
00150     const TableTemplate     *m_pTableTemplate;
00151     MessageBuilder          *m_pMessageBuilder;
00152 };
00153
00154 } // namespace Feed
00155
00156 } // namespace ContentPlatform
00157
00158 } // namespace Activ
00159
00160 #endif // (!defined ACTIV_FEED_MESSAGE_HANDLER_RECORD_FIELD_LIST_BUILDER_H)
Generated on Wed Oct 8 14:01:45 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedMessageHandler

RecordFieldListValidator.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FEED_MESSAGE_HANDLER_RECORD_FIELD_LIST_VALIDATOR_H)
00010 #define ACTIV_FEED_MESSAGE_HANDLER_RECORD_FIELD_LIST_VALIDATOR_H
00011
00012 #include "ActivContentPlatform/ActivFeedCommon/FieldIds.h"
00013
00014 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/External.h"
00015
00016 #include "boost/dynamic_bitset.hpp"
00017
00018 #include <vector>
00019
00020 namespace Activ
00021 {
00022
00023 class MessageValidator;
00024 class IFieldType;
00025
00026 namespace ContentPlatform
00027 {
00028
00029 namespace Feed
00030 {
00031
00032 class TableTemplate;
00033
00034 // ---------------------------------------------------------------------------------------------------------------------------------
00035
00039 class RecordFieldListValidator
00040 {
00041 public:
00045     class ConstIterator
00046     {
00047     public:
00051         ConstIterator();
00052
00058         ConstIterator &operator++();
00059
00065         const ConstIterator operator++(int);
00066
00074         bool operator==(const ConstIterator &rhs) const;
00075
00083         bool operator!=(const ConstIterator &rhs) const;
00084
00090         FieldId GetFieldId() const;
00091
00097         const IFieldType *GetField() const;
00098
00099     private:
00106         ConstIterator(const RecordFieldListValidator *pRecordFieldListValidator, const FieldIdList::const_iterator &iterator);
00107
00108         const RecordFieldListValidator  *m_pRecordFieldListValidator;
00109         FieldIdList::const_iterator     m_iterator;
00110
00111         friend class RecordFieldListValidator;
00112     };
00113
00117     ACTIV_FEED_MESSAGE_HANDLER_API RecordFieldListValidator();
00118
00128     ACTIV_FEED_MESSAGE_HANDLER_API RecordFieldListValidator(const TableTemplate &tableTemplate, MessageValidator &messageValidator, const bool shouldIgnoreUndefinedMissingFields = false);
00129
00133     ACTIV_FEED_MESSAGE_HANDLER_API ~RecordFieldListValidator();
00134
00147     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Initialize(const TableTemplate &tableTemplate, MessageValidator &messageValidator, const bool shouldIgnoreUndefinedMissingFields = false);
00148
00152     ACTIV_FEED_MESSAGE_HANDLER_API void Reset();
00153
00157     ACTIV_FEED_MESSAGE_HANDLER_API void Clear();
00158
00169     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode GetField(const FieldId fieldId, const IFieldType *&pIFieldType) const;
00170
00176     ACTIV_FEED_MESSAGE_HANDLER_API bool IsInitialized() const;
00177
00185     ACTIV_FEED_MESSAGE_HANDLER_API ConstIterator Begin() const;
00186
00194     ACTIV_FEED_MESSAGE_HANDLER_API ConstIterator End() const;
00195
00201     ACTIV_FEED_MESSAGE_HANDLER_API static std::string FieldListTitleToString();
00202
00208     ACTIV_FEED_MESSAGE_HANDLER_API static std::string NamePrefixToString();
00209
00215     ACTIV_FEED_MESSAGE_HANDLER_API static std::string ContentsPrefixToString();
00216
00222     ACTIV_FEED_MESSAGE_HANDLER_API static std::string UndefinedFieldContentsToString();
00223
00229     ACTIV_FEED_MESSAGE_HANDLER_API std::string FieldIdToString(const FieldId &fieldId) const;
00230
00236     ACTIV_FEED_MESSAGE_HANDLER_API std::string FieldContentsToString(const IFieldType *pIFieldType) const;
00237
00243     ACTIV_FEED_MESSAGE_HANDLER_API std::string ToString() const;
00244
00245 private:
00246     typedef boost::dynamic_bitset<>     FieldIdPresentBitmap;
00247     typedef std::vector<IFieldType *>   CachedFieldList;
00248
00254     RecordFieldListValidator(const RecordFieldListValidator &rhs);
00255
00263     RecordFieldListValidator& operator=(const RecordFieldListValidator &rhs);
00264
00275     StatusCode GetField(const FieldId fieldId, IFieldType *&pIFieldType) const;
00276
00284     const IFieldType *GetCachedField(const FieldId fieldId) const;
00285
00286     bool                    m_isInitialized;
00287     FieldIdList             m_fieldIdList;
00288     FieldIdPresentBitmap    m_fieldIdPresentBitmap;
00289     CachedFieldList         m_cachedFieldList;
00290 };
00291
00292 // ---------------------------------------------------------------------------------------------------------------------------------
00293
00294 inline const IFieldType *RecordFieldListValidator::GetCachedField(const FieldId fieldId) const
00295 {
00296     const IFieldType *pCachedFieldType = m_cachedFieldList[fieldId];
00297     return (((0 != pCachedFieldType) && pCachedFieldType->IsInitialized()) ? pCachedFieldType : 0);
00298 }
00299
00300 // ---------------------------------------------------------------------------------------------------------------------------------
00301 // ---------------------------------------------------------------------------------------------------------------------------------
00302
00303 inline RecordFieldListValidator::ConstIterator::ConstIterator() :
00304     m_pRecordFieldListValidator(0)
00305 {
00306 }
00307
00308 // ---------------------------------------------------------------------------------------------------------------------------------
00309
00310 inline RecordFieldListValidator::ConstIterator &RecordFieldListValidator::ConstIterator::operator++()
00311 {
00312     ++m_iterator;
00313
00314     return *this;
00315 }
00316
00317 // ---------------------------------------------------------------------------------------------------------------------------------
00318
00319 inline const RecordFieldListValidator::ConstIterator RecordFieldListValidator::ConstIterator::operator++(int)
00320 {
00321     ConstIterator oldValue = *this;
00322
00323     ++(*this);
00324
00325     return oldValue;
00326 }
00327
00328 // ---------------------------------------------------------------------------------------------------------------------------------
00329
00330 inline bool RecordFieldListValidator::ConstIterator::operator==(const RecordFieldListValidator::ConstIterator &rhs) const
00331 {
00332     return ((m_pRecordFieldListValidator == rhs.m_pRecordFieldListValidator) && (m_iterator == rhs.m_iterator));
00333 }
00334
00335 // ---------------------------------------------------------------------------------------------------------------------------------
00336
00337 inline bool RecordFieldListValidator::ConstIterator::operator!=(const RecordFieldListValidator::ConstIterator &rhs) const
00338 {
00339     return !((*this) == rhs);
00340 }
00341
00342 // ---------------------------------------------------------------------------------------------------------------------------------
00343
00344 inline FieldId RecordFieldListValidator::ConstIterator::GetFieldId() const
00345 {
00346     return *m_iterator;
00347 }
00348
00349 // ---------------------------------------------------------------------------------------------------------------------------------
00350
00351 inline const IFieldType *RecordFieldListValidator::ConstIterator::GetField() const
00352 {
00353     return m_pRecordFieldListValidator->GetCachedField(*m_iterator);
00354 }
00355
00356 // ---------------------------------------------------------------------------------------------------------------------------------
00357
00358 inline RecordFieldListValidator::ConstIterator::ConstIterator(const RecordFieldListValidator *pRecordFieldListValidator, const FieldIdList::const_iterator &iterator) :
00359     m_pRecordFieldListValidator(pRecordFieldListValidator),
00360     m_iterator(iterator)
00361 {
00362 }
00363
00364 } // namespace Feed
00365
00366 } // namespace ContentPlatform
00367
00368 } // namespace Activ
00369
00370 #endif // (!defined ACTIV_FEED_MESSAGE_HANDLER_RECORD_FIELD_LIST_VALIDATOR_H)
Generated on Wed Oct 8 14:01:45 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedMessageHandler

RecordKeyFieldListBuilder.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FEED_MESSAGE_HANDLER_RECORD_KEY_FIELD_LIST_BUILDER_H)
00010 #define ACTIV_FEED_MESSAGE_HANDLER_RECORD_KEY_FIELD_LIST_BUILDER_H
00011
00012 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/External.h"
00013
00014 namespace Activ
00015 {
00016
00017 class MessageBuilder;
00018 class IFieldType;
00019
00020 namespace ContentPlatform
00021 {
00022
00023 namespace Feed
00024 {
00025
00026 class Index;
00027
00028 // ---------------------------------------------------------------------------------------------------------------------------------
00029
00033 class RecordKeyFieldListBuilder
00034 {
00035 public:
00039     ACTIV_FEED_MESSAGE_HANDLER_API RecordKeyFieldListBuilder();
00040
00047     ACTIV_FEED_MESSAGE_HANDLER_API RecordKeyFieldListBuilder(const Index &index, MessageBuilder &messageBuilder);
00048
00052     ACTIV_FEED_MESSAGE_HANDLER_API ~RecordKeyFieldListBuilder();
00053
00060     ACTIV_FEED_MESSAGE_HANDLER_API void Initialize(const Index &index, MessageBuilder &messageBuilder);
00061
00065     ACTIV_FEED_MESSAGE_HANDLER_API void Reset();
00066
00070     ACTIV_FEED_MESSAGE_HANDLER_API void Clear();
00071
00083     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode AppendField(const FieldId fieldId, const IFieldType &iFieldType);
00084
00097     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode AppendField(const FieldId fieldId, const void * const pSerializedBody, const size_t serializedBodyLength);
00098
00108     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode AppendUndefinedField(const FieldId fieldId);
00109
00115     ACTIV_FEED_MESSAGE_HANDLER_API bool IsInitialized() const;
00116
00122     ACTIV_FEED_MESSAGE_HANDLER_API bool IsComplete() const;
00123
00124 private:
00125     typedef std::vector<IFieldType *>       CachedFieldList;
00126
00132     RecordKeyFieldListBuilder(const RecordKeyFieldListBuilder &rhs);
00133
00141     RecordKeyFieldListBuilder& operator=(const RecordKeyFieldListBuilder &rhs);
00142
00153     StatusCode GetConvertedField(const FieldType fieldType, const IFieldType &iFieldType, const IFieldType *&pConvertedField);
00154
00155     CachedFieldList         m_cachedFieldList;
00156
00157     const Index             *m_pIndex;
00158     Index::ConstIterator    m_keyFieldIterator;
00159     MessageBuilder          *m_pMessageBuilder;
00160 };
00161
00162 } // namespace Feed
00163
00164 } // namespace ContentPlatform
00165
00166 } // namespace Activ
00167
00168 #endif // (!defined ACTIV_FEED_MESSAGE_HANDLER_RECORD_KEY_FIELD_LIST_BUILDER_H)
Generated on Wed Oct 8 14:01:45 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedMessageHandler

RecordKeyFieldListValidator.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FEED_MESSAGE_HANDLER_RECORD_KEY_FIELD_LIST_VALIDATOR_H)
00010 #define ACTIV_FEED_MESSAGE_HANDLER_RECORD_KEY_FIELD_LIST_VALIDATOR_H
00011
00012 #include "ActivContentPlatform/ActivFeedCommon/FieldIds.h"
00013
00014 #include "ActivMiddleware/ActivFieldTypes/IFieldType.h"
00015
00016 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/External.h"
00017
00018 #include <vector>
00019
00020 namespace Activ
00021 {
00022
00023 class MessageValidator;
00024
00025 namespace ContentPlatform
00026 {
00027
00028 namespace Feed
00029 {
00030
00031 class Index;
00032
00033 // ---------------------------------------------------------------------------------------------------------------------------------
00034
00038 class RecordKeyFieldListValidator
00039 {
00040 public:
00044     class ConstIterator
00045     {
00046     public:
00050         ConstIterator();
00051
00057         ConstIterator &operator++();
00058
00064         const ConstIterator operator++(int);
00065
00073         bool operator==(const ConstIterator &rhs) const;
00074
00082         bool operator!=(const ConstIterator &rhs) const;
00083
00089         FieldId GetFieldId() const;
00090
00096         const IFieldType *GetField() const;
00097
00098     private:
00099         typedef std::pair<FieldId, IFieldType *> KeyField;
00100         typedef std::vector<KeyField> KeyFieldList;
00101
00108         ConstIterator(const RecordKeyFieldListValidator *pRecordKeyFieldListValidator, const KeyFieldList::const_iterator &iterator);
00109
00110         const RecordKeyFieldListValidator       *m_pRecordKeyFieldListValidator;
00111         KeyFieldList::const_iterator            m_iterator;
00112
00113         friend class RecordKeyFieldListValidator;
00114     };
00115
00119     ACTIV_FEED_MESSAGE_HANDLER_API RecordKeyFieldListValidator();
00120
00129     ACTIV_FEED_MESSAGE_HANDLER_API RecordKeyFieldListValidator(const Index &index, MessageValidator &messageValidator);
00130
00134     ACTIV_FEED_MESSAGE_HANDLER_API ~RecordKeyFieldListValidator();
00135
00147     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Initialize(const Index &index, MessageValidator &messageValidator);
00148
00152     ACTIV_FEED_MESSAGE_HANDLER_API void Reset();
00153
00157     ACTIV_FEED_MESSAGE_HANDLER_API void Clear();
00158
00169     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode GetField(const FieldId fieldId, const IFieldType *&pIFieldType) const;
00170
00176     ACTIV_FEED_MESSAGE_HANDLER_API bool IsInitialized() const;
00177
00185     ACTIV_FEED_MESSAGE_HANDLER_API ConstIterator Begin() const;
00186
00194     ACTIV_FEED_MESSAGE_HANDLER_API ConstIterator End() const;
00195
00201     ACTIV_FEED_MESSAGE_HANDLER_API static std::string KeyFieldListTitleToString();
00202
00208     ACTIV_FEED_MESSAGE_HANDLER_API static std::string ContentsPrefixToString();
00209
00215     ACTIV_FEED_MESSAGE_HANDLER_API static std::string UndefinedFieldContentsToString();
00216
00222     ACTIV_FEED_MESSAGE_HANDLER_API static std::string NamePrefixToString();
00223
00229     ACTIV_FEED_MESSAGE_HANDLER_API std::string FieldIdToString(const FieldId &fieldId) const;
00230
00236     ACTIV_FEED_MESSAGE_HANDLER_API std::string FieldNameToString(const FieldId &fieldId) const;
00237
00243     ACTIV_FEED_MESSAGE_HANDLER_API std::string FieldContentsToString(const IFieldType *pIFieldType) const;
00244
00250     ACTIV_FEED_MESSAGE_HANDLER_API std::string ToString() const;
00251
00252 private:
00253     typedef std::pair<FieldId, IFieldType *>    KeyField;
00254     typedef std::vector<KeyField>               KeyFieldList;
00255     typedef std::vector<IFieldType *>           CachedKeyFieldList;
00256
00262     RecordKeyFieldListValidator(const RecordKeyFieldListValidator &rhs);
00263
00271     RecordKeyFieldListValidator& operator=(const RecordKeyFieldListValidator &rhs);
00272
00283     StatusCode GetField(const FieldId fieldId, IFieldType *&pIFieldType) const;
00284
00285     bool                m_isInitialized;
00286     KeyFieldList        m_keyFieldList;
00287     CachedKeyFieldList  m_cachedKeyFieldList;
00288 };
00289
00290 // ---------------------------------------------------------------------------------------------------------------------------------
00291 // ---------------------------------------------------------------------------------------------------------------------------------
00292
00293 inline RecordKeyFieldListValidator::ConstIterator::ConstIterator() :
00294     m_pRecordKeyFieldListValidator(0)
00295 {
00296 }
00297
00298 // ---------------------------------------------------------------------------------------------------------------------------------
00299
00300 inline RecordKeyFieldListValidator::ConstIterator &RecordKeyFieldListValidator::ConstIterator::operator++()
00301 {
00302     ++m_iterator;
00303
00304     return *this;
00305 }
00306
00307 // ---------------------------------------------------------------------------------------------------------------------------------
00308
00309 inline const RecordKeyFieldListValidator::ConstIterator RecordKeyFieldListValidator::ConstIterator::operator++(int)
00310 {
00311     ConstIterator oldValue = *this;
00312
00313     ++(*this);
00314
00315     return oldValue;
00316 }
00317
00318 // ---------------------------------------------------------------------------------------------------------------------------------
00319
00320 inline bool RecordKeyFieldListValidator::ConstIterator::operator==(const RecordKeyFieldListValidator::ConstIterator &rhs) const
00321 {
00322     return ((m_pRecordKeyFieldListValidator == rhs.m_pRecordKeyFieldListValidator) && (m_iterator == rhs.m_iterator));
00323 }
00324
00325 // ---------------------------------------------------------------------------------------------------------------------------------
00326
00327 inline bool RecordKeyFieldListValidator::ConstIterator::operator!=(const RecordKeyFieldListValidator::ConstIterator &rhs) const
00328 {
00329     return !((*this) == rhs);
00330 }
00331
00332 // ---------------------------------------------------------------------------------------------------------------------------------
00333
00334 inline FieldId RecordKeyFieldListValidator::ConstIterator::GetFieldId() const
00335 {
00336     return m_iterator->first;
00337 }
00338
00339 // ---------------------------------------------------------------------------------------------------------------------------------
00340
00341 inline const IFieldType *RecordKeyFieldListValidator::ConstIterator::GetField() const
00342 {
00343     return m_iterator->second;
00344 }
00345
00346 // ---------------------------------------------------------------------------------------------------------------------------------
00347
00348 inline RecordKeyFieldListValidator::ConstIterator::ConstIterator(const RecordKeyFieldListValidator *pRecordKeyFieldListValidator, const KeyFieldList::const_iterator &iterator) :
00349     m_pRecordKeyFieldListValidator(pRecordKeyFieldListValidator),
00350     m_iterator(iterator)
00351 {
00352 }
00353
00354 } // namespace Feed
00355
00356 } // namespace ContentPlatform
00357
00358 } // namespace Activ
00359
00360 #endif // (!defined ACTIV_FEED_MESSAGE_HANDLER_RECORD_KEY_FIELD_LIST_VALIDATOR_H)
Generated on Wed Oct 8 14:01:45 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedMessageHandler

RecordMessageBuilder.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FEED_MESSAGE_HANDLER_RECORD_MESSAGE_BUILDER_H)
00010 #define ACTIV_FEED_MESSAGE_HANDLER_RECORD_MESSAGE_BUILDER_H
00011
00012 #include "ActivContentPlatform/ActivFeedCommon/ActivFeed.h"
00013
00014 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/External.h"
00015 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/RecordKeyFieldListBuilder.h"
00016 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/RecordFieldListBuilder.h"
00017
00018 namespace Activ
00019 {
00020
00021 class MessageBuilder;
00022 class IFieldType;
00023
00024 namespace ContentPlatform
00025 {
00026
00027 namespace Feed
00028 {
00029
00030 class TableTemplateList;
00031 class TableTemplate;
00032 class Index;
00033
00034 // ---------------------------------------------------------------------------------------------------------------------------------
00035
00039 class RecordMessageBuilder
00040 {
00041 public:
00045     ACTIV_FEED_MESSAGE_HANDLER_API RecordMessageBuilder();
00046
00053     ACTIV_FEED_MESSAGE_HANDLER_API RecordMessageBuilder(const TableTemplateList &tableTemplateList, MessageBuilder &messageBuilder);
00054
00060     ACTIV_FEED_MESSAGE_HANDLER_API RecordMessageBuilder(const TableTemplateList &tableTemplateList);
00061
00065     ACTIV_FEED_MESSAGE_HANDLER_API ~RecordMessageBuilder();
00066
00073     ACTIV_FEED_MESSAGE_HANDLER_API void Initialize(const TableTemplateList &tableTemplateList, MessageBuilder &messageBuilder);
00074
00080     ACTIV_FEED_MESSAGE_HANDLER_API void Initialize(const TableTemplateList &tableTemplateList);
00081
00087     ACTIV_FEED_MESSAGE_HANDLER_API void Initialize(MessageBuilder &messageBuilder);
00088
00092     ACTIV_FEED_MESSAGE_HANDLER_API void Reset();
00093
00109     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode AppendHeader(const bool isDelete, const bool isRefresh, const TableId tableId, const UpdateId updateId, const PermissionId permissionId, const EventType eventType);
00110
00121     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode AppendIndexNumber(const IndexNumber indexNumber);
00122
00134     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode AppendKeyField(const FieldId fieldId, const IFieldType &iFieldType);
00135
00148     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode AppendKeyField(const FieldId fieldId, const void * const pSerializedBody, const size_t serializedBodyLength);
00149
00159     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode AppendUndefinedKeyField(const FieldId fieldId);
00160
00172     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode AppendField(const FieldId fieldId, const IFieldType &iFieldType);
00173
00186     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode AppendField(const FieldId fieldId, const void * const pSerializedBody, const size_t serializedBodyLength);
00187
00197     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode AppendUndefinedField(const FieldId fieldId);
00198
00204     ACTIV_FEED_MESSAGE_HANDLER_API bool IsInitialized() const;
00205
00206 private:
00212     RecordMessageBuilder(const RecordMessageBuilder &rhs);
00213
00221     RecordMessageBuilder& operator=(const RecordMessageBuilder &rhs);
00222
00223     const TableTemplateList     *m_pTableTemplateList;
00224     MessageBuilder              *m_pMessageBuilder;
00225     const TableTemplate         *m_pTableTemplate;
00226     const Index                 *m_pIndex;
00227
00228     RecordKeyFieldListBuilder   m_recordKeyFieldListBuilder;
00229     RecordFieldListBuilder      m_recordFieldListBuilder;
00230 };
00231
00232 } // namespace Feed
00233
00234 } // namespace ContentPlatform
00235
00236 } // namespace Activ
00237
00238 #endif // (!defined ACTIV_FEED_MESSAGE_HANDLER_RECORD_MESSAGE_BUILDER_H)
Generated on Wed Oct 8 14:01:45 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedMessageHandler

RecordMessageHeaderDefinitions.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FEED_MESSAGE_HANDLER_RECORD_MESSAGE_HEADER_DEFINITIONS_H)
00010 #define ACTIV_FEED_MESSAGE_HANDLER_RECORD_MESSAGE_HEADER_DEFINITIONS_H
00011
00012 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/External.h"
00013 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/ActivFeedMessageHandler.h"
00014 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/MessageHeaderDefinitions.h"
00015
00016 namespace Activ
00017 {
00018
00019 namespace ContentPlatform
00020 {
00021
00022 namespace Feed
00023 {
00024
00028 class RecordMessageHeaderDefinitions
00029 {
00030 public:
00031     typedef uint8_t Flags;
00032
00033     static const MessageType    MESSAGE_TYPE    = MESSAGE_TYPE_RECORD;
00034
00035     static const size_t     MESSAGE_HEADER_FLAGS_DELETE_OFFSET  = 0;
00036     static const size_t     MESSAGE_HEADER_FLAGS_DELETE_LENGTH  = 1;
00037     static const size_t     MESSAGE_HEADER_FLAGS_REFRESH_OFFSET = (MESSAGE_HEADER_FLAGS_DELETE_OFFSET + MESSAGE_HEADER_FLAGS_DELETE_LENGTH);
00038     static const size_t     MESSAGE_HEADER_FLAGS_REFRESH_LENGTH = 1;
00039
00040     static const MessageHeaderDefinitions::MessageHeader    MESSAGE_HEADER_FLAGS_DELETE_BIT_MASK        = static_cast<MessageHeaderDefinitions::MessageHeader>((1 << MESSAGE_HEADER_FLAGS_DELETE_LENGTH) - 1);
00041     static const size_t                                     MESSAGE_HEADER_FLAGS_DELETE_BIT_SHIFT       = MessageHeaderDefinitions::FLAGS_LENGTH - (MESSAGE_HEADER_FLAGS_DELETE_OFFSET + MESSAGE_HEADER_FLAGS_DELETE_LENGTH);
00042     static const MessageHeaderDefinitions::MessageHeader    MESSAGE_HEADER_FLAGS_REFRESH_BIT_MASK       = static_cast<MessageHeaderDefinitions::MessageHeader>((1 << MESSAGE_HEADER_FLAGS_REFRESH_LENGTH) - 1);
00043     static const size_t                                     MESSAGE_HEADER_FLAGS_REFRESH_BIT_SHIFT      = MessageHeaderDefinitions::FLAGS_LENGTH - (MESSAGE_HEADER_FLAGS_REFRESH_OFFSET + MESSAGE_HEADER_FLAGS_REFRESH_LENGTH);
00044
00045     static const size_t     FLAGS_EXPANDED_FORMAT_OFFSET            = 0;
00046     static const size_t     FLAGS_EXPANDED_FORMAT_LENGTH            = 1;
00047     static const size_t     FLAGS_DO_NOT_ADD_OFFSET                 = (FLAGS_EXPANDED_FORMAT_OFFSET + FLAGS_EXPANDED_FORMAT_LENGTH);
00048     static const size_t     FLAGS_DO_NOT_ADD_LENGTH                 = 1;
00049
00050     static const Flags      FLAGS_EXPANDED_FORMAT_BIT_MASK          = static_cast<Flags>((1 << FLAGS_EXPANDED_FORMAT_LENGTH) - 1);
00051     static const size_t     FLAGS_EXPANDED_FORMAT_BIT_SHIFT         = (sizeof(Flags) * CHAR_BIT) - (FLAGS_EXPANDED_FORMAT_OFFSET + FLAGS_EXPANDED_FORMAT_LENGTH);
00052     static const Flags      FLAGS_DO_NOT_ADD_BIT_MASK               = static_cast<Flags>((1 << FLAGS_DO_NOT_ADD_LENGTH) - 1);
00053     static const size_t     FLAGS_DO_NOT_ADD_BIT_SHIFT              = (sizeof(Flags) * CHAR_BIT) - (FLAGS_DO_NOT_ADD_OFFSET + FLAGS_DO_NOT_ADD_LENGTH);
00054
00064     static MessageHeaderDefinitions::MessageHeader GetMessageHeader(const bool isDelete, const bool isRefresh, const MessageType messageType = MESSAGE_TYPE);
00065
00073     static bool IsValidMessageType(const MessageHeaderDefinitions::MessageHeader messageHeader);
00074
00082     static bool IsDelete(const MessageHeaderDefinitions::MessageHeader messageHeader);
00083
00091     static bool IsRefresh(const MessageHeaderDefinitions::MessageHeader messageHeader);
00092
00101     static Flags GetFlags(const bool isExpandedFormat, const bool isDoNotAdd);
00102
00110     static void ExtractFlags(const Flags flags, bool &isExpandedFormat, bool &isDoNotAdd);
00111
00119     static bool IsExpandedFormat(const Flags flags);
00120
00128     static bool IsDoNotAdd(const Flags flags);
00129 };
00130
00131 // ---------------------------------------------------------------------------------------------------------------------------------
00132
00133 inline MessageHeaderDefinitions::MessageHeader RecordMessageHeaderDefinitions::GetMessageHeader(const bool isDelete, const bool isRefresh, const MessageType messageType)
00134 {
00135     return MessageHeaderDefinitions::GetMessageHeader((isDelete ? (MESSAGE_HEADER_FLAGS_DELETE_BIT_MASK << MESSAGE_HEADER_FLAGS_DELETE_BIT_SHIFT) : 0) | (isRefresh ? (MESSAGE_HEADER_FLAGS_REFRESH_BIT_MASK << MESSAGE_HEADER_FLAGS_REFRESH_BIT_SHIFT) : 0), messageType);
00136 }
00137
00138 // ---------------------------------------------------------------------------------------------------------------------------------
00139
00140 inline bool RecordMessageHeaderDefinitions::IsValidMessageType(const MessageHeaderDefinitions::MessageHeader messageHeader)
00141 {
00142     return (MessageHeaderDefinitions::IsValidMessageType(messageHeader, MESSAGE_TYPE));
00143 }
00144
00145 // ---------------------------------------------------------------------------------------------------------------------------------
00146
00147 inline bool RecordMessageHeaderDefinitions::IsDelete(const MessageHeaderDefinitions::MessageHeader messageHeader)
00148 {
00149     return (((MessageHeaderDefinitions::GetFlags(messageHeader) >> MESSAGE_HEADER_FLAGS_DELETE_BIT_SHIFT) & MESSAGE_HEADER_FLAGS_DELETE_BIT_MASK) != 0);
00150 }
00151
00152 // ---------------------------------------------------------------------------------------------------------------------------------
00153
00154 inline bool RecordMessageHeaderDefinitions::IsRefresh(const MessageHeaderDefinitions::MessageHeader messageHeader)
00155 {
00156     return (((MessageHeaderDefinitions::GetFlags(messageHeader) >> MESSAGE_HEADER_FLAGS_REFRESH_BIT_SHIFT) & MESSAGE_HEADER_FLAGS_REFRESH_BIT_MASK) != 0);
00157 }
00158
00159 // ---------------------------------------------------------------------------------------------------------------------------------
00160
00161 inline RecordMessageHeaderDefinitions::Flags RecordMessageHeaderDefinitions::GetFlags(const bool isExpandedFormat, const bool isDoNotAdd)
00162 {
00163     return ((isExpandedFormat ? (FLAGS_EXPANDED_FORMAT_BIT_MASK << FLAGS_EXPANDED_FORMAT_BIT_SHIFT) : 0) | (isDoNotAdd ? (FLAGS_DO_NOT_ADD_BIT_MASK << FLAGS_DO_NOT_ADD_BIT_SHIFT) : 0));
00164 }
00165
00166 // ---------------------------------------------------------------------------------------------------------------------------------
00167
00168 inline void RecordMessageHeaderDefinitions::ExtractFlags(const Flags flags, bool &isExpandedFormat, bool &isDoNotAdd)
00169 {
00170     isExpandedFormat = IsExpandedFormat(flags);
00171     isDoNotAdd = IsDoNotAdd(flags);
00172 }
00173
00174 // ---------------------------------------------------------------------------------------------------------------------------------
00175
00176 inline bool RecordMessageHeaderDefinitions::IsExpandedFormat(const Flags flags)
00177 {
00178     return (((flags >> FLAGS_EXPANDED_FORMAT_BIT_SHIFT) & FLAGS_EXPANDED_FORMAT_BIT_MASK) != 0);
00179 }
00180
00181 // ---------------------------------------------------------------------------------------------------------------------------------
00182
00183 inline bool RecordMessageHeaderDefinitions::IsDoNotAdd(const Flags flags)
00184 {
00185     return (((flags >> FLAGS_DO_NOT_ADD_BIT_SHIFT) & FLAGS_DO_NOT_ADD_BIT_MASK) != 0);
00186 }
00187
00188 } // namespace Feed
00189
00190 } // namespace ContentPlatform
00191
00192 } // namespace Activ
00193
00194 #endif // (!defined ACTIV_FEED_MESSAGE_HANDLER_RECORD_MESSAGE_HEADER_DEFINITIONS_H)
Generated on Wed Oct 8 14:01:45 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedMessageHandler

RecordMessageHeaderValidator.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FEED_MESSAGE_HANDLER_RECORD_MESSAGE_HEADER_VALIDATOR_H)
00010 #define ACTIV_FEED_MESSAGE_HANDLER_RECORD_MESSAGE_HEADER_VALIDATOR_H
00011
00012 #include "ActivContentPlatform/ActivFeedCommon/ActivFeed.h"
00013
00014 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/External.h"
00015 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/RecordKeyFieldListValidator.h"
00016 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/TableTemplateList.h"
00017
00018 namespace Activ
00019 {
00020
00021 class MessageValidator;
00022 class IFieldType;
00023
00024 namespace ContentPlatform
00025 {
00026
00027 namespace Feed
00028 {
00029
00033 class RecordMessageHeaderValidator
00034 {
00035 public:
00036     typedef RecordKeyFieldListValidator::ConstIterator ConstKeyFieldIterator;
00037
00041     ACTIV_FEED_MESSAGE_HANDLER_API RecordMessageHeaderValidator();
00042
00052     ACTIV_FEED_MESSAGE_HANDLER_API RecordMessageHeaderValidator(const TableTemplateList &tableTemplateList, MessageValidator &messageValidator, const bool shouldIgnoreMissingTableTemplate = false);
00053
00062     ACTIV_FEED_MESSAGE_HANDLER_API RecordMessageHeaderValidator(const TableTemplateList &tableTemplateList, const bool shouldIgnoreMissingTableTemplate = false);
00063
00067     ACTIV_FEED_MESSAGE_HANDLER_API ~RecordMessageHeaderValidator();
00068
00080     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Initialize(const TableTemplateList &tableTemplateList, MessageValidator &messageValidator, const bool shouldIgnoreMissingTableTemplate = false);
00081
00092     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Initialize(const TableTemplateList &tableTemplateList, const bool shouldIgnoreMissingTableTemplate = false);
00093
00103     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Initialize(MessageValidator &messageValidator);
00104
00108     ACTIV_FEED_MESSAGE_HANDLER_API void Reset();
00109
00113     ACTIV_FEED_MESSAGE_HANDLER_API void Clear();
00114
00123     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode GetTableTemplate(const TableTemplate *&pTableTemplate) const;
00124
00134     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode GetUpdateId(UpdateId &updateId) const;
00135
00144     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode GetPermissionId(PermissionId &permissionId) const;
00145
00154     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode GetEventType(EventType &eventType) const;
00155
00164     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode GetIndexNumber(IndexNumber &indexNumber) const;
00165
00176     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode GetKeyField(const FieldId fieldId, const IFieldType *&pIFieldType) const;
00177
00183     ACTIV_FEED_MESSAGE_HANDLER_API bool IsInitialized() const;
00184
00190     ACTIV_FEED_MESSAGE_HANDLER_API bool IsDelete() const;
00191
00197     ACTIV_FEED_MESSAGE_HANDLER_API bool IsRefresh() const;
00198
00206     ACTIV_FEED_MESSAGE_HANDLER_API ConstKeyFieldIterator BeginKeyField() const;
00207
00215     ACTIV_FEED_MESSAGE_HANDLER_API ConstKeyFieldIterator EndKeyField() const;
00216
00222     ACTIV_FEED_MESSAGE_HANDLER_API std::string IsDeleteToString() const;
00223
00229     ACTIV_FEED_MESSAGE_HANDLER_API std::string IsRefreshToString() const;
00230
00236     ACTIV_FEED_MESSAGE_HANDLER_API std::string TableTemplateIdToString() const;
00237
00243     ACTIV_FEED_MESSAGE_HANDLER_API std::string TableTemplateNameToString() const;
00244
00250     ACTIV_FEED_MESSAGE_HANDLER_API std::string UpdateIdToString() const;
00251
00257     ACTIV_FEED_MESSAGE_HANDLER_API std::string CompositeUpdateIdToString() const;
00258
00264     ACTIV_FEED_MESSAGE_HANDLER_API std::string PermissionIdToString() const;
00265
00271     ACTIV_FEED_MESSAGE_HANDLER_API std::string EventTypeToString() const;
00272
00278     ACTIV_FEED_MESSAGE_HANDLER_API std::string IndexNumberToString() const;
00279
00285     ACTIV_FEED_MESSAGE_HANDLER_API std::string IndexNameToString(const Index *pIndex) const;
00286
00292     ACTIV_FEED_MESSAGE_HANDLER_API std::string ToString() const;
00293
00294 private:
00300     RecordMessageHeaderValidator(const RecordMessageHeaderValidator &rhs);
00301
00309     RecordMessageHeaderValidator& operator=(const RecordMessageHeaderValidator &rhs);
00310
00320     StatusCode GetTableTemplate(TableTemplate *&pTableTemplate) const;
00321
00332     StatusCode GetKeyField(const FieldId fieldId, IFieldType *&pIFieldType) const;
00333
00334     const TableTemplateList         *m_pTableTemplateList;
00335
00336     bool                            m_isInitialized;
00337     bool                            m_shouldIgnoreMissingTableTemplate;
00338     bool                            m_isDelete;
00339     bool                            m_isRefresh;
00340     const TableTemplate             *m_pTableTemplate;
00341     UpdateId                        m_updateId;
00342     PermissionId                    m_permissionId;
00343     EventType                       m_eventType;
00344     IndexNumber                     m_indexNumber;
00345     RecordKeyFieldListValidator     m_recordKeyFieldListValidator;
00346
00347     friend class RecordMessageValidator;
00348 };
00349
00350 } // namespace Feed
00351
00352 } // namespace ContentPlatform
00353
00354 } // namespace Activ
00355
00356 #endif // (!defined ACTIV_FEED_MESSAGE_HANDLER_RECORD_MESSAGE_HEADER_VALIDATOR_H)
Generated on Wed Oct 8 14:01:45 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedMessageHandler

RecordMessageValidator.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FEED_MESSAGE_HANDLER_RECORD_MESSAGE_VALIDATOR_H)
00010 #define ACTIV_FEED_MESSAGE_HANDLER_RECORD_MESSAGE_VALIDATOR_H
00011
00012 #include "ActivContentPlatform/ActivFeedCommon/ActivFeed.h"
00013
00014 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/External.h"
00015 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/RecordMessageHeaderValidator.h"
00016 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/RecordKeyFieldListValidator.h"
00017 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/RecordFieldListValidator.h"
00018
00019 #include <vector>
00020
00021 namespace Activ
00022 {
00023
00024 class MessageValidator;
00025 class IFieldType;
00026
00027 namespace ContentPlatform
00028 {
00029
00030 namespace Feed
00031 {
00032
00033 class TableTemplate;
00034 class TableTemplateList;
00035
00036 // ---------------------------------------------------------------------------------------------------------------------------------
00037
00041 class RecordMessageValidator
00042 {
00043 public:
00044     typedef RecordKeyFieldListValidator::ConstIterator ConstKeyFieldIterator;
00045     typedef RecordFieldListValidator::ConstIterator ConstFieldIterator;
00046
00050     ACTIV_FEED_MESSAGE_HANDLER_API RecordMessageValidator();
00051
00062     ACTIV_FEED_MESSAGE_HANDLER_API RecordMessageValidator(const TableTemplateList &tableTemplateList, MessageValidator &messageValidator, const bool shouldIgnoreMissingTableTemplate = false, const bool shouldIgnoreUndefinedMissingFields = false);
00063
00072     ACTIV_FEED_MESSAGE_HANDLER_API RecordMessageValidator(const TableTemplateList &tableTemplateList, const bool shouldIgnoreMissingTableTemplate = false);
00073
00077     ACTIV_FEED_MESSAGE_HANDLER_API ~RecordMessageValidator();
00078
00091     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Initialize(const TableTemplateList &tableTemplateList, MessageValidator &messageValidator, const bool shouldIgnoreMissingTableTemplate = false, const bool shouldIgnoreUndefinedMissingFields = false);
00092
00103     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Initialize(const TableTemplateList &tableTemplateList, const bool shouldIgnoreMissingTableTemplate = false);
00104
00115     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Initialize(MessageValidator &messageValidator, const bool shouldIgnoreUndefinedMissingFields = false);
00116
00120     ACTIV_FEED_MESSAGE_HANDLER_API void Reset();
00121
00125     ACTIV_FEED_MESSAGE_HANDLER_API void Clear();
00126
00135     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode GetTableTemplate(const TableTemplate *&pTableTemplate) const;
00136
00146     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode GetUpdateId(UpdateId &updateId) const;
00147
00156     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode GetPermissionId(PermissionId &permissionId) const;
00157
00166     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode GetEventType(EventType &eventType) const;
00167
00176     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode GetIndexNumber(IndexNumber &indexNumber) const;
00177
00188     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode GetKeyField(const FieldId fieldId, const IFieldType *&pIFieldType) const;
00189
00200     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode GetField(const FieldId fieldId, const IFieldType *&pIFieldType) const;
00201
00207     ACTIV_FEED_MESSAGE_HANDLER_API bool IsInitialized() const;
00208
00214     ACTIV_FEED_MESSAGE_HANDLER_API bool IsDelete() const;
00215
00221     ACTIV_FEED_MESSAGE_HANDLER_API bool IsRefresh() const;
00222
00230     ACTIV_FEED_MESSAGE_HANDLER_API ConstKeyFieldIterator BeginKeyField() const;
00231
00239     ACTIV_FEED_MESSAGE_HANDLER_API ConstKeyFieldIterator EndKeyField() const;
00240
00248     ACTIV_FEED_MESSAGE_HANDLER_API ConstFieldIterator BeginField() const;
00249
00257     ACTIV_FEED_MESSAGE_HANDLER_API ConstFieldIterator EndField() const;
00258
00264     ACTIV_FEED_MESSAGE_HANDLER_API std::string ToString() const;
00265
00266 private:
00272     RecordMessageValidator(const RecordMessageValidator &rhs);
00273
00281     RecordMessageValidator& operator=(const RecordMessageValidator &rhs);
00282
00292     StatusCode GetTableTemplate(TableTemplate *&pTableTemplate) const;
00293
00304     StatusCode GetKeyField(const FieldId fieldId, IFieldType *&pIFieldType) const;
00305
00316     StatusCode GetField(const FieldId fieldId, IFieldType *&pIFieldType) const;
00317
00318     RecordMessageHeaderValidator    m_recordMessageHeaderValidator;
00319     RecordFieldListValidator        m_recordFieldListValidator;
00320 };
00321
00322 } // namespace Feed
00323
00324 } // namespace ContentPlatform
00325
00326 } // namespace Activ
00327
00328 #endif // (!defined ACTIV_FEED_MESSAGE_HANDLER_RECORD_MESSAGE_VALIDATOR_H)
Generated on Wed Oct 8 14:01:46 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase » Windows

RegistryHelper.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_BASE_WINDOWS_REGISTRY_HELPER_H)
00010 #define ACTIV_BASE_WINDOWS_REGISTRY_HELPER_H
00011
00012 #include "ActivMiddleware/ActivBase/External.h"
00013
00014 namespace Activ
00015 {
00016
00023 class RegistryHelper
00024 {
00025 public:
00029     enum Type
00030     {
00031         TYPE_UNSUPPORTED,
00032         TYPE_UNSIGNED32,
00033         TYPE_STRING,
00034         TYPE_BINARY
00035     };
00036
00040     ACTIV_BASE_EXPORTED_API virtual ~RegistryHelper();
00041
00052     ACTIV_BASE_EXPORTED_API static void GetValue(const char *keyName, const char *valueName, uint32_t &value);
00053
00065     ACTIV_BASE_EXPORTED_API static void GetValue(const char *keyName, const char *valueName, const char *value,
00066         uint_fast32_t maxValueLen);
00067
00080     ACTIV_BASE_EXPORTED_API static void GetValue(const char *keyName, const char *valueName, const void *value,
00081         uint_fast32_t &maxValueLen);
00082
00092     ACTIV_BASE_EXPORTED_API static void SetValue(const char *keyName, const char *valueName, uint32_t value);
00093
00103     ACTIV_BASE_EXPORTED_API static void SetValue(const char *keyName, const char *valueName, const char *value);
00104
00115     ACTIV_BASE_EXPORTED_API static void SetValue(const char *keyName, const char *valueName, const void *value,
00116         uint_fast32_t valueLen);
00117
00125     ACTIV_BASE_EXPORTED_API static void DeleteKey(const char *keyName);
00126
00135     ACTIV_BASE_EXPORTED_API static void DeleteValue(const char *keyName, const char *valueName);
00136
00146     ACTIV_BASE_EXPORTED_API uint_fast32_t EnumerateKeys(const char *keyName);
00147
00157     ACTIV_BASE_EXPORTED_API uint_fast32_t EnumerateValues(const char *keyName);
00158
00159 private:
00163     class RegistryKey
00164     {
00165     public:
00169         ACTIV_BASE_LOCAL_API RegistryKey();
00170
00174         ACTIV_BASE_LOCAL_API ~RegistryKey();
00175
00179         ACTIV_BASE_LOCAL_API HKEY *operator &();
00180
00184         ACTIV_BASE_LOCAL_API operator HKEY() const;
00185
00186     private:
00187         HKEY m_key;
00188     };
00189
00199     ACTIV_BASE_EXPORTED_API virtual bool OnKey(const char *fullKeyName, const char *keyName, uint_fast32_t index);
00200
00211     ACTIV_BASE_EXPORTED_API virtual bool OnValue(const char *fullKeyName, const char *valueName, uint_fast32_t index, Type type);
00212
00222     ACTIV_BASE_LOCAL_API static void GetValue(const char *keyName, const char *valueName, uint32_t type, const void *value,
00223         uint_fast32_t &maxValueLen);
00224
00234     ACTIV_BASE_LOCAL_API static void SetValue(const char *keyName, const char *valueName, uint32_t type, const void *value,
00235         uint_fast32_t maxValueLen);
00236
00247     ACTIV_BASE_LOCAL_API static Type MapWinType(uint32_t type);
00248 };
00249
00250 } // namespace Activ
00251
00252 #endif // (!defined ACTIV_BASE_WINDOWS_REGISTRY_HELPER_H)
Generated on Wed Oct 8 14:01:47 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon

RelationshipIdHelper.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FEED_COMMON_RELATIONSHIP_ID_HELPER_H)
00010 #define ACTIV_FEED_COMMON_RELATIONSHIP_ID_HELPER_H
00011
00012 #include "ActivContentPlatform/ActivFeedCommon/External.h"
00013 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedDefinitions.h"
00014 #include "ActivContentPlatform/ActivFeedCommon/RelationshipIds.h"
00015
00016 namespace Activ
00017 {
00018
00019 namespace ContentPlatform
00020 {
00021
00022 namespace Feed
00023 {
00024
00028 class RelationshipIdHelper
00029 {
00030 public:
00034     RelationshipIdHelper();
00035
00043     RelationshipIdHelper(const RelationshipId relationshipId, const char * const pName, const char * const pCodeIdentifier);
00044
00045     RelationshipId      m_relationshipId;
00046     std::string         m_name;
00047     std::string         m_codeIdentifier;
00048 };
00049
00050 // ---------------------------------------------------------------------------------------------------------------------------------
00051
00052 inline RelationshipIdHelper::RelationshipIdHelper() :
00053     m_relationshipId(RELATIONSHIP_ID_NONE)
00054 {
00055 }
00056
00057 // ---------------------------------------------------------------------------------------------------------------------------------
00058
00059 inline RelationshipIdHelper::RelationshipIdHelper(const RelationshipId relationshipId, const char * const pName, const char * const pCodeIdentifier) :
00060     m_relationshipId(relationshipId),
00061     m_name(pName),
00062     m_codeIdentifier(pCodeIdentifier)
00063 {
00064 }
00065
00066 // ---------------------------------------------------------------------------------------------------------------------------------
00067 // ---------------------------------------------------------------------------------------------------------------------------------
00068
00076 ACTIV_FEED_COMMON_API const RelationshipIdHelper &GetRelationshipIdHelper(const RelationshipId relationshipId);
00077
00085 ACTIV_FEED_COMMON_API std::string GetRelationshipIdName(const RelationshipId relationshipId);
00086
00094 ACTIV_FEED_COMMON_API std::string GetRelationshipIdCodeIdentifier(const RelationshipId relationshipId);
00095
00096 } // namespace Feed
00097
00098 } // namespace ContentPlatform
00099
00100 } // namespace Activ
00101
00102 #endif // (!defined ACTIV_FEED_COMMON_RELATIONSHIP_ID_HELPER_H)
Generated on Wed Oct 8 14:01:46 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon

RelationshipIds.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FEED_COMMON_RELATIONSHIP_IDS_H)
00010 #define ACTIV_FEED_COMMON_RELATIONSHIP_IDS_H
00011
00012 #include "ActivMiddleware/Activ.h"
00013
00014 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedDefinitions.h"
00015
00016 namespace Activ
00017 {
00018
00019 namespace ContentPlatform
00020 {
00021
00022 namespace Feed
00023 {
00024
00025 const RelationshipType RELATIONSHIP_TYPE_GET_EQUAL = 0;
00026 const RelationshipType RELATIONSHIP_TYPE_GET_MULTIPLE_PATTERN_MATCH_SOURCE = 1;
00027 const RelationshipType RELATIONSHIP_TYPE_GET_MULTIPLE_PATTERN_MATCH_TARGET = 2;
00028
00029 const RelationshipId RELATIONSHIP_ID_NONE = 0;
00030 const RelationshipId RELATIONSHIP_ID_SECTOR = 101;
00031 const RelationshipId RELATIONSHIP_ID_INDEX = 102;
00032 const RelationshipId RELATIONSHIP_ID_LISTING = 104;
00033 const RelationshipId RELATIONSHIP_ID_SECURITY = 105;
00034 const RelationshipId RELATIONSHIP_ID_COMPANY = 106;
00035 const RelationshipId RELATIONSHIP_ID_OPTION_DELIVERABLE = 107;
00036 const RelationshipId RELATIONSHIP_ID_OPTION_ROOT = 108;
00037 const RelationshipId RELATIONSHIP_ID_FUTURE_ROOT = 109;
00038 const RelationshipId RELATIONSHIP_ID_FUTURE_OPTION_ROOT = 110;
00039 const RelationshipId RELATIONSHIP_ID_SPREAD = 111;
00040 const RelationshipId RELATIONSHIP_ID_OPTION = 113;
00041 const RelationshipId RELATIONSHIP_ID_PRIMARY_LISTING = 114;
00042 const RelationshipId RELATIONSHIP_ID_ANALYTICS = 115;
00043 const RelationshipId RELATIONSHIP_ID_FUTURE_OPTION_EXPIRATION_ROOT = 116;
00044 const RelationshipId RELATIONSHIP_ID_FUTURE = 117;
00045 const RelationshipId RELATIONSHIP_ID_FOREX = 118;
00046 const RelationshipId RELATIONSHIP_ID_FUNDAMENTAL = 119;
00047 const RelationshipId RELATIONSHIP_ID_FUTURE_OPTION = 120;
00048 const RelationshipId RELATIONSHIP_ID_UNDERLYING = 121;
00049 const RelationshipId RELATIONSHIP_ID_BBO_DEPTH = 122;
00050 const RelationshipId RELATIONSHIP_ID_STRATEGY = 123;
00051 const RelationshipId RELATIONSHIP_ID_STRATEGY_LEG = 124;
00052 const RelationshipId RELATIONSHIP_ID_NON_STANDARD_OPTION = 125;
00053 const RelationshipId RELATIONSHIP_ID_NON_STANDARD_OPTION_ROOT = 126;
00054 const RelationshipId RELATIONSHIP_ID_INSTRUMENT = 127;
00055 const RelationshipId RELATIONSHIP_ID_EXCHANGE = 128;
00056
00057 } // namespace Feed
00058
00059 } // namespace ContentPlatform
00060
00061 } // namespace Activ
00062
00063 #endif // (!defined ACTIV_FEED_COMMON_RELATIONSHIP_IDS_H)
Generated on Wed Oct 8 14:01:46 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivDatabase

RemoteTableFactory.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_DATABASE_REMOTE_TABLE_FACTORY_H)
00010 #define ACTIV_DATABASE_REMOTE_TABLE_FACTORY_H
00011
00012 #include "ActivMiddleware/ActivDatabase/External.h"
00013 #include "ActivMiddleware/ActivDatabase/Definitions.h"
00014 #include "ActivMiddleware/Misc/Singleton.h"
00015
00016 namespace Activ
00017 {
00018
00019 class MessageValidator;
00020
00021 namespace Database
00022 {
00023
00024 class ITable;
00025
00026 // ---------------------------------------------------------------------------------------------------------------------------------
00027
00031 class RemoteTableFactory : public Singleton<RemoteTableFactory>
00032 {
00033 public:
00043     ACTIV_DATABASE_API ITable *Create(MessageValidator &messageValidator);
00044
00050     ACTIV_DATABASE_API static RemoteTableFactory &GetInstance();
00051
00052 private:
00056     ACTIV_DATABASE_API RemoteTableFactory();
00057
00058     friend class Singleton<RemoteTableFactory>;
00059 };
00060
00061 } // namespace Database
00062
00063 } // namespace Activ
00064
00065 #endif // (!defined ACTIV_DATABASE_REMOTE_TABLE_FACTORY_H)
Generated on Wed Oct 8 14:01:47 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivSystem

RequestId.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_SYSTEM_REQUEST_ID_H)
00010 #define ACTIV_SYSTEM_REQUEST_ID_H
00011
00012 #include "ActivMiddleware/ActivSystem/External.h"
00013 #include "ActivMiddleware/ActivSystem/Address.h"
00014 #include "ActivMiddleware/ActivBase/ActivBase.h"
00015 #include "ActivMiddleware/Misc/MemoryHelper.h"
00016
00017 #include <cassert>
00018 #include <string>
00019
00020 namespace Activ
00021 {
00022
00023 class SyncRequestId;
00024
00025 // ---------------------------------------------------------------------------------------------------------------------------------
00026
00030 class RequestId
00031 {
00032 public:
00033     typedef uint32_t SendId;
00034     typedef byte_t Attribute;
00035
00036     static const Attribute ATTRIBUTE_NONE = 0x00;
00037     static const Attribute ATTRIBUTE_ON = 0x01;
00038     static const Attribute ATTRIBUTE_RESPONSE = 0x02;
00039     static const Attribute ATTRIBUTE_USE_RESPONSE_ADDRESS = 0x04;
00040
00041     static const byte_t MAX_LENGTH = 0x10;
00042
00046     ACTIV_SYSTEM_INLINE_API
00047     RequestId();
00048
00055     ACTIV_SYSTEM_INLINE_API
00056     RequestId(const void *pData, const size_t dataSize);
00057
00065     ACTIV_SYSTEM_INLINE_API
00066     RequestId(const void *pData, const size_t dataSize, const Address &responseAddress);
00067
00073     ACTIV_SYSTEM_INLINE_API
00074     RequestId(const RequestId &requestId);
00075
00079     ACTIV_SYSTEM_INLINE_API
00080     void Clear();
00081
00087     ACTIV_SYSTEM_INLINE_API
00088     size_t GetLength() const;
00089
00095     ACTIV_SYSTEM_INLINE_API
00096     void SetLength(const size_t dataLength);
00097
00103     ACTIV_SYSTEM_INLINE_API
00104     const byte_t *Get() const;
00105
00112     ACTIV_SYSTEM_INLINE_API
00113     void Set(const void *pData, const size_t dataLength);
00114
00122     ACTIV_SYSTEM_INLINE_API
00123     void Set(const void *pData, const size_t dataLength, const Address &responseAddress);
00124
00133     ACTIV_SYSTEM_INLINE_API
00134     StatusCode Serialize(MessageBuilder &messageBuilder) const;
00135
00144     ACTIV_SYSTEM_INLINE_API
00145     StatusCode Deserialize(MessageValidator &messageValidator);
00146
00152     ACTIV_SYSTEM_INLINE_API
00153     bool operator==(const RequestId &rhs) const;
00154
00160     ACTIV_SYSTEM_INLINE_API
00161     bool operator!=(const RequestId &rhs) const;
00162
00171     ACTIV_SYSTEM_INLINE_API
00172     bool operator<(const RequestId &rhs) const;
00173
00179     ACTIV_SYSTEM_INLINE_API
00180     RequestId &operator=(const RequestId &rhs);
00181
00187     ACTIV_SYSTEM_INLINE_API
00188     Attribute GetAttributes() const;
00189
00195     ACTIV_SYSTEM_INLINE_API
00196     void SetAttributes(Attribute attributes);
00197
00203     ACTIV_SYSTEM_INLINE_API
00204     const Address &GetResponseAddress() const;
00205
00211     ACTIV_SYSTEM_INLINE_API
00212     void SetResponseAddress(const Address &responseAddress);
00213
00219     ACTIV_SYSTEM_INLINE_API
00220     std::string ToString() const;
00221
00227     ACTIV_SYSTEM_INLINE_API
00228     std::string MessageModelToString() const;
00229
00237     ACTIV_SYSTEM_INLINE_API
00238     static std::string MessageModelToString(const Attribute attributes);
00239
00240     ACTIV_SYSTEM_EXPORTED_API
00241     static const RequestId emptyRequestId;
00242
00243 private:
00250     ACTIV_SYSTEM_INLINE_API
00251     void CommonSet(const void *pData, const size_t dataSize);
00252
00262     ACTIV_SYSTEM_INLINE_API
00263     int Compare(const RequestId &rhs) const;
00264
00265     Attribute   m_attributes;
00266     Address     m_responseAddress;
00267     byte_t      m_length;
00268     byte_t      m_buffer[MAX_LENGTH];
00269
00270     friend class SyncRequestId;
00271 };
00272
00273 // ---------------------------------------------------------------------------------------------------------------------------------
00274
00275 inline RequestId::RequestId()
00276 {
00277     Clear();
00278 }
00279
00280 // ---------------------------------------------------------------------------------------------------------------------------------
00281
00282 inline RequestId::RequestId(const void *pData, const size_t dataSize)
00283 {
00284     Set(pData, dataSize);
00285 }
00286
00287 // ---------------------------------------------------------------------------------------------------------------------------------
00288
00289 inline RequestId::RequestId(const void *pData, const size_t dataLength, const Address &responseAddress)
00290 {
00291     Set(pData, dataLength, responseAddress);
00292 }
00293
00294 // ---------------------------------------------------------------------------------------------------------------------------------
00295
00296 inline RequestId::RequestId(const RequestId &requestId)
00297 {
00298     *this = requestId;
00299 }
00300
00301 // ---------------------------------------------------------------------------------------------------------------------------------
00302
00303 inline void RequestId::Clear()
00304 {
00305     m_attributes = 0;
00306     m_responseAddress.Clear();
00307     m_length = 0;
00308 }
00309
00310 // ---------------------------------------------------------------------------------------------------------------------------------
00311
00312 inline size_t RequestId::GetLength() const
00313 {
00314     return m_length;
00315 }
00316
00317 // ---------------------------------------------------------------------------------------------------------------------------------
00318
00319 inline void RequestId::SetLength(const size_t dataLength)
00320 {
00321     m_length = static_cast<byte_t>(std::min<size_t>(dataLength, sizeof(m_buffer)));
00322 }
00323
00324 // ---------------------------------------------------------------------------------------------------------------------------------
00325
00326 inline const byte_t *RequestId::Get() const
00327 {
00328     return m_buffer;
00329 }
00330
00331 // ---------------------------------------------------------------------------------------------------------------------------------
00332
00333 inline void RequestId::Set(const void *pData, const size_t dataLength)
00334 {
00335     CommonSet(pData, dataLength);
00336
00337     m_responseAddress.Clear();
00338 }
00339
00340 // ---------------------------------------------------------------------------------------------------------------------------------
00341
00342 inline void RequestId::Set(const void *pData, const size_t dataLength, const Address &responseAddress)
00343 {
00344     CommonSet(pData, dataLength);
00345
00346     if (responseAddress.IsValid())
00347     {
00348         m_attributes |= ATTRIBUTE_USE_RESPONSE_ADDRESS;
00349         m_responseAddress = responseAddress;
00350     }
00351     else
00352     {
00353         m_responseAddress.Clear();
00354     }
00355 }
00356
00357 // ---------------------------------------------------------------------------------------------------------------------------------
00358
00359 inline StatusCode RequestId::Serialize(MessageBuilder &messageBuilder) const
00360 {
00361     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, messageBuilder.Append(m_attributes, MessageBuilder::ENDIAN_LITTLE));
00362     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, m_responseAddress.Serialize(messageBuilder));
00363     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, messageBuilder.Append(m_length, MessageBuilder::ENDIAN_LITTLE));
00364     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, messageBuilder.Append(m_buffer, m_length));
00365
00366     return STATUS_CODE_SUCCESS;
00367 }
00368
00369 // ---------------------------------------------------------------------------------------------------------------------------------
00370
00371 inline StatusCode RequestId::Deserialize(MessageValidator &messageValidator)
00372 {
00373     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=,
00374         (messageValidator.ValidateBinaryIntegral<sizeof(m_attributes), MessageValidator::ENDIAN_LITTLE>(m_attributes)));
00375     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, m_responseAddress.Deserialize(messageValidator));
00376     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=,
00377         (messageValidator.ValidateBinaryIntegral<sizeof(m_length), MessageValidator::ENDIAN_LITTLE>(m_length)));
00378     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, messageValidator.ValidateBytesCopy(m_length, &m_buffer));
00379
00380     return STATUS_CODE_SUCCESS;
00381 }
00382
00383 // ---------------------------------------------------------------------------------------------------------------------------------
00384
00385 inline bool RequestId::operator==(const RequestId &rhs) const
00386 {
00387     return 0 == Compare(rhs);
00388 }
00389
00390 // ---------------------------------------------------------------------------------------------------------------------------------
00391
00392 inline bool RequestId::operator!=(const RequestId &rhs) const
00393 {
00394     return 0 != Compare(rhs);
00395 }
00396
00397 // ---------------------------------------------------------------------------------------------------------------------------------
00398
00399 inline bool RequestId::operator<(const RequestId &rhs) const
00400 {
00401     return Compare(rhs) < 0;
00402 }
00403
00404 // ---------------------------------------------------------------------------------------------------------------------------------
00405
00406 inline RequestId &RequestId::operator=(const RequestId &rhs)
00407 {
00408     if (this == &rhs)
00409         return *this;
00410
00411     m_attributes = rhs.m_attributes;
00412     m_responseAddress = rhs.m_responseAddress;
00413     m_length = rhs.m_length;
00414     MemoryCopy(m_buffer, rhs.m_buffer, m_length);
00415
00416     return *this;
00417 }
00418
00419 // ---------------------------------------------------------------------------------------------------------------------------------
00420
00421 inline RequestId::Attribute RequestId::GetAttributes() const
00422 {
00423     return m_attributes;
00424 }
00425
00426 // ---------------------------------------------------------------------------------------------------------------------------------
00427
00428 inline void RequestId::SetAttributes(Attribute attributes)
00429 {
00430     m_attributes = attributes;
00431 }
00432
00433 // ---------------------------------------------------------------------------------------------------------------------------------
00434
00435 inline const Address &RequestId::GetResponseAddress() const
00436 {
00437     return m_responseAddress;
00438 }
00439
00440 // ---------------------------------------------------------------------------------------------------------------------------------
00441
00442 inline void RequestId::SetResponseAddress(const Address &responseAddress)
00443 {
00444     m_responseAddress = responseAddress;
00445 }
00446
00447 // ---------------------------------------------------------------------------------------------------------------------------------
00448
00449 inline std::string RequestId::ToString() const
00450 {
00451     char buff[4];
00452     std::string output;
00453
00454     for (size_t i = 0; i < m_length; ++i)
00455     {
00456         (void) Snprintf(buff, ACTIV_ARRAY_SIZE(buff), "%s%02x", (i > 0) ? " " : "", m_buffer[i]);
00457
00458         output += buff;
00459     }
00460
00461     return output;
00462 }
00463
00464 // ---------------------------------------------------------------------------------------------------------------------------------
00465
00466 inline std::string RequestId::MessageModelToString() const
00467 {
00468     return MessageModelToString(m_attributes);
00469 }
00470
00471 // ---------------------------------------------------------------------------------------------------------------------------------
00472
00473 inline std::string RequestId::MessageModelToString(const Attribute attributes)
00474 {
00475     if (attributes & ATTRIBUTE_ON)
00476     {
00477         if (attributes & ATTRIBUTE_RESPONSE)
00478             return "response";
00479         else
00480             return "request";
00481     }
00482     else
00483     {
00484         return "message";
00485     }
00486 }
00487
00488 // ---------------------------------------------------------------------------------------------------------------------------------
00489
00490 inline void RequestId::CommonSet(const void *pData, const size_t dataLength)
00491 {
00492     assert(dataLength <= sizeof(m_buffer));
00493
00494     // clear down attributes. request / response is set by Port Send/Post methods
00495     m_attributes = ATTRIBUTE_NONE;
00496
00497     m_length = static_cast<byte_t>(std::min<size_t>(dataLength, sizeof(m_buffer)));
00498     MemoryCopy(m_buffer, pData, m_length);
00499 }
00500
00501 // ---------------------------------------------------------------------------------------------------------------------------------
00502
00503 inline int RequestId::Compare(const RequestId &rhs) const
00504 {
00505     // the attribute bits do not take part in the comparison operation (a returned request id may have
00506     // different bits set). Same applies for response address. Comparison is only on the body of the request id.
00507
00508     if (m_length != rhs.m_length)
00509     {
00510         const size_t compareLength = std::min<>(m_length, rhs.m_length);
00511         const int compareValue = ::memcmp(m_buffer, rhs.m_buffer, compareLength);
00512
00513         if (0 == compareValue)
00514             return (m_length == compareLength) ? -1 : 1;
00515         else
00516             return compareValue;
00517     }
00518     else
00519     {
00520         return ::memcmp(m_buffer, rhs.m_buffer, m_length);
00521     }
00522 }
00523
00524 } // namespace Activ
00525
00526 #endif // (!defined ACTIV_SYSTEM_REQUEST_ID_H)
Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedTableTemplateHandler

Reset.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FEED_TABLE_TEMPLATE_HANDLER_RESET_H)
00010 #define ACTIV_FEED_TABLE_TEMPLATE_HANDLER_RESET_H
00011
00012 #include "ActivContentPlatform/ActivFeedCommon/FieldIds.h"
00013
00014 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/External.h"
00015
00016 #include <vector>
00017
00018 namespace Activ
00019 {
00020
00021 namespace ContentPlatform
00022 {
00023
00024 namespace Feed
00025 {
00026
00030 class CopyOnReset
00031 {
00032 public:
00036     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API CopyOnReset();
00037
00045     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API bool operator==(const CopyOnReset &rhs) const;
00046
00054     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API bool operator!=(const CopyOnReset &rhs) const;
00055
00056     FieldId                         m_source;
00057     FieldId                         m_target;
00058     bool                            m_copyIfUndefined;
00059 };
00060
00061 typedef std::vector<CopyOnReset>    CopyOnResetList;
00062 typedef std::vector<FieldId>        UndefineOnResetList;
00063
00064 // ---------------------------------------------------------------------------------------------------------------------------------
00065
00066 inline CopyOnReset::CopyOnReset() :
00067     m_source(FID_UNDEFINED),
00068     m_target(FID_UNDEFINED),
00069     m_copyIfUndefined(false)
00070 {
00071 }
00072
00073 // ---------------------------------------------------------------------------------------------------------------------------------
00074
00075 inline bool CopyOnReset::operator==(const CopyOnReset &rhs) const
00076 {
00077     if (rhs.m_source != m_source)
00078         return false;
00079
00080     if (rhs.m_target != m_target)
00081         return false;
00082
00083     if (rhs.m_copyIfUndefined != m_copyIfUndefined)
00084         return false;
00085
00086     return true;
00087 }
00088
00089 // ---------------------------------------------------------------------------------------------------------------------------------
00090
00091 inline bool CopyOnReset::operator!=(const CopyOnReset &rhs) const
00092 {
00093     return !((*this) == rhs);
00094 }
00095
00096 // ---------------------------------------------------------------------------------------------------------------------------------
00097
00098 } // namespace Feed
00099
00100 } // namespace ContentPlatform
00101
00102 } // namespace Activ
00103
00104 #endif // (!defined ACTIV_FEED_TABLE_TEMPLATE_HANDLER_RESET_H)
Generated on Wed Oct 8 14:01:46 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivFramework

RouterServiceApi.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FRAMEWORK_ROUTER_SERVICE_API_H)
00010 #define ACTIV_FRAMEWORK_ROUTER_SERVICE_API_H
00011
00012 #include "ActivMiddleware/ActivFramework/External.h"
00013 #include "ActivMiddleware/ActivBase/ISerializableMessage.h"
00014
00015 namespace Activ
00016 {
00017
00018 class Component;
00019
00020 // ---------------------------------------------------------------------------------------------------------------------------------
00021
00025 class RouterServiceApi
00026 {
00027 public:
00031     class Tcp
00032     {
00033     public:
00037         class SocketStats
00038         {
00039         public:
00045             ACTIV_FRAMEWORK_API SocketStats();
00046
00047             static const MessageType MESSAGE_TYPE = ROUTER_MESSAGE_USER_NOTIFY_SOCKET_STATS;
00048
00049             size_t      m_txQueueBytes;
00050             size_t      m_txQueueMessages;
00051             size_t      m_txQueueHighBytes;
00052             size_t      m_txQueueHighMessages;
00053
00054             size_t      m_inTxQueueBytes;
00055             size_t      m_inTxQueueMessages;
00056             size_t      m_inTxQueueHighBytes;
00057             size_t      m_inTxQueueHighMessages;
00058
00059             uint64_t    m_rxBytes;
00060             uint64_t    m_txBytes;
00061
00062             size_t      m_mutexContentionCount;
00063         };
00064
00065         // CLIENT SIDE
00066
00084         ACTIV_FRAMEWORK_API static StatusCode Connect(const Component &component, const std::string &url, HeapMessage &connectResponse,
00085             IHeap * const pHeap, const TimeoutPeriod timeout, const ISerializableMessage * const pUserData = 0);
00086
00101         ACTIV_FRAMEWORK_API static StatusCode Connect(const Component &component, const std::string &url, Address &circuitAddress,
00102             IHeap * const pHeap = 0, const ISerializableMessage * const pUserData = 0);
00103
00104         // SERVER SIDE
00105
00123         ACTIV_FRAMEWORK_API static StatusCode Listen(const Component &component, const std::string &url, Address &serverAddress,
00124             std::vector<std::string> &accessUrlList, IHeap * const pHeap = 0);
00125
00142         ACTIV_FRAMEWORK_API static StatusCode Listen(const Component &component, const std::string &url, Address &serverAddress,
00143             IHeap * const pHeap = 0);
00144
00154         ACTIV_FRAMEWORK_API static StatusCode Stop(const Component &component, const Address &serverAddress);
00155
00165         ACTIV_FRAMEWORK_API static StatusCode BreakAll(const Component &component, const Address &serverAddress);
00166
00167         // CLIENT AND SERVER SIDE
00168
00179         ACTIV_FRAMEWORK_API static StatusCode Break(const Component &component, const Address &connectionAddress);
00180
00196         ACTIV_FRAMEWORK_API static StatusCode Disconnect(const Component &component, const Address &circuitAddress,
00197             const TimeoutPeriod timeout = 0);
00198
00209         ACTIV_FRAMEWORK_API static StatusCode SetHeap(const Component &component, const Address &address,
00210             const IHeap * const pHeap);
00211
00222         ACTIV_FRAMEWORK_API static StatusCode SetMaxTxQueueSize(const Component &component, const Address &address,
00223             const size_t numberOfBytes);
00224
00236         ACTIV_FRAMEWORK_API static StatusCode EnableSocketStats(const Component &component, const Address &circuitAddress);
00237
00246         ACTIV_FRAMEWORK_API static StatusCode DeserializeSocketStats(const HeapMessage &heapMessage, SocketStats &socketStats);
00247
00254         ACTIV_FRAMEWORK_API static StatusCode ClearSocketStatsHighCounts(const Component &component, const Address &circuitAddress);
00255
00256     }; // Tcp
00257
00261     class Udp
00262     {
00263     public:
00278         ACTIV_FRAMEWORK_API static StatusCode Create(const Component &component, const std::string &localAddress,
00279                                                      const uint16_t localPort, const uint16_t maxRxSize,
00280                                                      Address &socketAddress, IHeap * const pHeap = 0);
00281
00290         ACTIV_FRAMEWORK_API static StatusCode Read(const Component &component, const Address &socketAddress);
00291
00302         ACTIV_FRAMEWORK_API static StatusCode Connect(const Component &component, const Address &socketAddress,
00303                                                       const std::string &remoteAddressString,
00304                                                       const uint16_t remotePort);
00305
00314         ACTIV_FRAMEWORK_API static StatusCode Disconnect(const Component &component, const Address &socketAddress);
00315
00328         ACTIV_FRAMEWORK_API static StatusCode Close(const Component &component, const Address &socketAddress,
00329             const bool gracefully = false);
00330
00341         ACTIV_FRAMEWORK_API static StatusCode JoinMulticastGroup(const Component &component, const Address &socketAddress,
00342             const std::string &multicastGroupString, const std::string &interfaceAddressString);
00343
00354         ACTIV_FRAMEWORK_API static StatusCode LeaveMulticastGroup(const Component &component, const Address &socketAddress,
00355             const std::string &multicastGroupString, const std::string &interfaceAddressString);
00356
00366         ACTIV_FRAMEWORK_API static StatusCode SetMulticastTxInterface(const Component &component, const Address &socketAddress,
00367             const std::string &interfaceAddressString);
00368
00378         ACTIV_FRAMEWORK_API static StatusCode SetMulticastTtl(const Component &component, const Address &socketAddress,
00379             const uint32_t ttl);
00380
00390         ACTIV_FRAMEWORK_API static StatusCode SetUnicastTtl(const Component &component, const Address &socketAddress,
00391             const uint32_t ttl);
00392
00402         ACTIV_FRAMEWORK_API static StatusCode SetRxBufferSize(const Component &component, const Address &socketAddress,
00403             const uint32_t size);
00404
00414         ACTIV_FRAMEWORK_API static StatusCode SetTxBufferSize(const Component &component, const Address &socketAddress,
00415             const uint32_t size);
00416
00426         ACTIV_FRAMEWORK_API static StatusCode SetMulticastLoopback(const Component &component, const Address &socketAddress,
00427             const bool enable);
00428
00441         ACTIV_FRAMEWORK_API static StatusCode GetSocketHandle(const Component &component, const Address &socketAddress,
00442             SOCKET &socket);
00443
00454         ACTIV_FRAMEWORK_API static StatusCode SendTo(const SOCKET socket, const void *pData, size_t dataLength,
00455             const IpAddress &toAddress);
00456
00466         ACTIV_FRAMEWORK_API static StatusCode Send(const SOCKET socket, const void *pData, size_t dataLength);
00467
00477         ACTIV_FRAMEWORK_API static StatusCode PostData(const Component &component, const Address &socketAddress,
00478             HeapMessage &heapMessage);
00479
00480     }; // Udp
00481 };
00482
00483 } // namespace Activ
00484
00485 #endif // (!defined ACTIV_FRAMEWORK_ROUTER_SERVICE_API_H)
Generated on Wed Oct 8 14:01:48 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedTableTemplateHandler

Rule.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FEED_TABLE_TEMPLATE_HANDLER_RULE_H)
00010 #define ACTIV_FEED_TABLE_TEMPLATE_HANDLER_RULE_H
00011
00012 #include "ActivMiddleware/Misc/StlHelper.h"
00013
00014 #include "ActivContentPlatform/ActivFeedCommon/FieldIds.h"
00015
00016 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/External.h"
00017
00018 #include <string>
00019
00020 namespace Activ
00021 {
00022
00023 namespace ContentPlatform
00024 {
00025
00026 namespace Feed
00027 {
00028
00029 class TableTemplate;
00030
00031 // ---------------------------------------------------------------------------------------------------------------------------------
00032
00036 class Rule
00037 {
00038 public:
00042     class CopyToFields
00043     {
00044     public:
00048         CopyToFields();
00049
00061         CopyToFields(const TableTemplate &tableTemplate, const FieldId target, const FieldId size, const FieldId condition, const FieldId time, const FieldId date, const FieldId exchange);
00062
00069         CopyToFields(const TableTemplate &tableTemplate, const xercesc::DOMNode &domNode);
00070
00084         StatusCode Initialize(const TableTemplate &tableTemplate, const FieldId target, const FieldId size, const FieldId condition, const FieldId time, const FieldId date, const FieldId exchange);
00085
00095         StatusCode Initialize(const TableTemplate &tableTemplate, const xercesc::DOMNode &domNode);
00096
00100         void Clear();
00101
00109         ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API bool operator==(const CopyToFields &rhs) const;
00110
00118         ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API bool operator!=(const CopyToFields &rhs) const;
00119
00125         std::string ToString() const;
00126
00127         const TableTemplate     *m_pTableTemplate;
00128
00129         FieldId                 m_target;
00130         FieldId                 m_size;
00131         FieldId                 m_condition;
00132         FieldId                 m_time;
00133         FieldId                 m_date;
00134         FieldId                 m_exchange;
00135
00136         std::string             m_error;
00137     };
00138
00142     class HighFields
00143     {
00144     public:
00148         HighFields();
00149
00160         HighFields(const TableTemplate &tableTemplate, const FieldId target, const FieldId condition, const FieldId time, const FieldId date, const FieldId exchange);
00161
00168         HighFields(const TableTemplate &tableTemplate, const xercesc::DOMNode &domNode);
00169
00182         StatusCode Initialize(const TableTemplate &tableTemplate, const FieldId target, const FieldId condition, const FieldId time, const FieldId date, const FieldId exchange);
00183
00193         StatusCode Initialize(const TableTemplate &tableTemplate, const xercesc::DOMNode &domNode);
00194
00198         void Clear();
00199
00207         ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API bool operator==(const HighFields &rhs) const;
00208
00216         ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API bool operator!=(const HighFields &rhs) const;
00217
00223         std::string ToString() const;
00224
00225         const TableTemplate     *m_pTableTemplate;
00226
00227         FieldId                 m_target;
00228         FieldId                 m_condition;
00229         FieldId                 m_time;
00230         FieldId                 m_date;
00231         FieldId                 m_exchange;
00232
00233         std::string             m_error;
00234     };
00235
00239     class LowFields
00240     {
00241     public:
00245         LowFields();
00246
00257         LowFields(const TableTemplate &tableTemplate, const FieldId target, const FieldId condition, const FieldId time, const FieldId date, const FieldId exchange);
00258
00265         LowFields(const TableTemplate &tableTemplate, const xercesc::DOMNode &domNode);
00266
00279         StatusCode Initialize(const TableTemplate &tableTemplate, const FieldId target, const FieldId condition, const FieldId time, const FieldId date, const FieldId exchange);
00280
00290         StatusCode Initialize(const TableTemplate &tableTemplate, const xercesc::DOMNode &domNode);
00291
00295         void Clear();
00296
00304         ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API bool operator==(const LowFields &rhs) const;
00305
00313         ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API bool operator!=(const LowFields &rhs) const;
00314
00320         std::string ToString() const;
00321
00322         const TableTemplate     *m_pTableTemplate;
00323
00324         FieldId                 m_target;
00325         FieldId                 m_condition;
00326         FieldId                 m_time;
00327         FieldId                 m_date;
00328         FieldId                 m_exchange;
00329
00330         std::string             m_error;
00331     };
00332
00336     class OpenFields
00337     {
00338     public:
00342         OpenFields();
00343
00353         OpenFields(const TableTemplate &tableTemplate, const FieldId target, const FieldId condition, const FieldId time, const FieldId exchange);
00354
00361         OpenFields(const TableTemplate &tableTemplate, const xercesc::DOMNode &domNode);
00362
00374         StatusCode Initialize(const TableTemplate &tableTemplate, const FieldId target, const FieldId condition, const FieldId time, const FieldId exchange);
00375
00385         StatusCode Initialize(const TableTemplate &tableTemplate, const xercesc::DOMNode &domNode);
00386
00390         void Clear();
00391
00399         ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API bool operator==(const OpenFields &rhs) const;
00400
00408         ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API bool operator!=(const OpenFields &rhs) const;
00409
00415         std::string ToString() const;
00416
00417         const TableTemplate     *m_pTableTemplate;
00418
00419         FieldId                 m_target;
00420         FieldId                 m_condition;
00421         FieldId                 m_time;
00422         FieldId                 m_exchange;
00423
00424         std::string             m_error;
00425     };
00426
00430     class CloseFields
00431     {
00432     public:
00436         CloseFields();
00437
00448         CloseFields(const TableTemplate &tableTemplate, const FieldId target, const FieldId condition, const FieldId status, const FieldId date, const FieldId exchange);
00449
00456         CloseFields(const TableTemplate &tableTemplate, const xercesc::DOMNode &domNode);
00457
00470         StatusCode Initialize(const TableTemplate &tableTemplate, const FieldId target, const FieldId condition, const FieldId status, const FieldId date, const FieldId exchange);
00471
00481         StatusCode Initialize(const TableTemplate &tableTemplate, const xercesc::DOMNode &domNode);
00482
00486         void Clear();
00487
00495         ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API bool operator==(const CloseFields &rhs) const;
00496
00504         ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API bool operator!=(const CloseFields &rhs) const;
00505
00511         std::string ToString() const;
00512
00513         const TableTemplate     *m_pTableTemplate;
00514
00515         FieldId                 m_target;
00516         FieldId                 m_condition;
00517         FieldId                 m_status;
00518         FieldId                 m_date;
00519         FieldId                 m_exchange;
00520
00521         std::string             m_error;
00522     };
00523
00527     class PriceFields
00528     {
00529     public:
00533         PriceFields();
00534
00545         PriceFields(const TableTemplate &tableTemplate, const FieldId previousDayChange, const FieldId netChange, const FieldId percentChange, const FieldId cumulativePrice, const FieldId count);
00546
00553         PriceFields(const TableTemplate &tableTemplate, const xercesc::DOMNode &domNode);
00554
00567         StatusCode Initialize(const TableTemplate &tableTemplate, const FieldId previousDayChange, const FieldId netChange, const FieldId percentChange, const FieldId cumulativePrice, const FieldId count);
00568
00578         StatusCode Initialize(const TableTemplate &tableTemplate, const xercesc::DOMNode &domNode);
00579
00585         StatusCode InitializeChangeFields(const xercesc::DOMNode &domNode);
00586
00590         void Clear();
00591
00599         ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API bool operator==(const PriceFields &rhs) const;
00600
00608         ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API bool operator!=(const PriceFields &rhs) const;
00609
00615         std::string ToString() const;
00616
00617         const TableTemplate     *m_pTableTemplate;
00618
00619         FieldId                 m_previousDayChange;
00620         FieldId                 m_netChange;
00621         FieldId                 m_percentChange;
00622         FieldId                 m_cumulativePrice;
00623         FieldId                 m_count;
00624
00625         std::string             m_error;
00626     };
00627
00631     class VolumeFields
00632     {
00633     public:
00637         VolumeFields();
00638
00650         VolumeFields(const TableTemplate &tableTemplate, const FieldId add1Volume, const FieldId add1Price, const FieldId add1CumulativeValue, const FieldId add2Volume, const FieldId add2Price, const FieldId add2CumulativeValue);
00651
00658         VolumeFields(const TableTemplate &tableTemplate, const xercesc::DOMNode &domNode);
00659
00673         StatusCode Initialize(const TableTemplate &tableTemplate, const FieldId add1Volume, const FieldId add1Price, const FieldId add1CumulativeValue, const FieldId add2Volume, const FieldId add2Price, const FieldId add2CumulativeValue);
00674
00684         StatusCode Initialize(const TableTemplate &tableTemplate, const xercesc::DOMNode &domNode);
00685
00691         StatusCode InitializeAdd1Fields(const xercesc::DOMNode &domNode);
00692
00698         StatusCode InitializeAdd2Fields(const xercesc::DOMNode &domNode);
00699
00705         StatusCode InitializeAdd1CumulativeValueFields(const xercesc::DOMNode &domNode);
00706
00712         StatusCode InitializeAdd2CumulativeValueFields(const xercesc::DOMNode &domNode);
00713
00717         void Clear();
00718
00726         ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API bool operator==(const VolumeFields &rhs) const;
00727
00735         ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API bool operator!=(const VolumeFields &rhs) const;
00736
00742         std::string ToString() const;
00743
00744         const TableTemplate     *m_pTableTemplate;
00745
00746         FieldId                 m_add1Volume;
00747         FieldId                 m_add1Price;
00748         FieldId                 m_add1CumulativeValue;
00749         FieldId                 m_add2Volume;
00750         FieldId                 m_add2Price;
00751         FieldId                 m_add2CumulativeValue;
00752
00753         std::string             m_error;
00754     };
00755
00760     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API Rule();
00761
00781     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API Rule(const TableTemplate &tableTemplate, const FieldId source, const FieldId size, const FieldId condition, const FieldId time, const FieldId date, const FieldId exchange, const FieldId previousDayTrend, const CopyToFields &copyToFields, const HighFields &highFields, const LowFields &lowFields, const OpenFields &openFields, const CloseFields &closeFields, const PriceFields &priceFields, const VolumeFields &volumeFields);
00782
00789     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API Rule(const TableTemplate &tableTemplate, const xercesc::DOMNode &domNode);
00790
00812     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API StatusCode Initialize(const TableTemplate &tableTemplate, const FieldId source, const FieldId size, const FieldId condition, const FieldId time, const FieldId date, const FieldId exchange, const FieldId previousDayTrend, const CopyToFields &copyToFields, const HighFields &highFields, const LowFields &lowFields, const OpenFields &openFields, const CloseFields &closeFields, const PriceFields &priceFields, const VolumeFields &volumeFields);
00813
00823     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API StatusCode Initialize(const TableTemplate &tableTemplate, const xercesc::DOMNode &domNode);
00824
00830     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API StatusCode InitializeSourceFields(const xercesc::DOMNode &domNode);
00831
00835     void Clear();
00836
00844     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API bool operator==(const Rule &rhs) const;
00845
00853     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API bool operator!=(const Rule &rhs) const;
00854
00860     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API std::string ToString() const;
00861
00869     static bool IsDefined(const FieldId fieldId)
00870     {
00871         return (FID_UNDEFINED != fieldId);
00872     }
00873
00874     const TableTemplate     *m_pTableTemplate;
00875
00876     FieldId                 m_source;
00877     FieldId                 m_size;
00878     FieldId                 m_condition;
00879     FieldId                 m_time;
00880     FieldId                 m_date;
00881     FieldId                 m_exchange;
00882     FieldId                 m_previousDayTrend;
00883
00884     CopyToFields            m_copyToFields;
00885     HighFields              m_highFields;
00886     LowFields               m_lowFields;
00887     OpenFields              m_openFields;
00888     CloseFields             m_closeFields;
00889     PriceFields             m_priceFields;
00890     VolumeFields            m_volumeFields;
00891
00892     std::string             m_error;
00893 };
00894
00895 typedef hash_map<FieldId, Rule>     RuleMap;
00896
00897 // ---------------------------------------------------------------------------------------------------------------------------------
00898
00899 } // namespace Feed
00900
00901 } // namespace ContentPlatform
00902
00903 } // namespace Activ
00904
00905 #endif // (!defined ACTIV_FEED_TABLE_TEMPLATE_HANDLER_RULE_H)
Generated on Wed Oct 8 14:01:46 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivFieldTypes

SInt.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FIELD_TYPES_SINT_H)
00010 #define ACTIV_FIELD_TYPES_SINT_H
00011
00012 #include "ActivMiddleware/ActivFieldTypes/External.h"
00013 #include "ActivMiddleware/ActivFieldTypes/IFieldType.h"
00014
00015 #include "ActivMiddleware/ActivBase/StatusCodeException.h"
00016 #include "ActivMiddleware/Misc/MemoryHelper.h"
00017
00018 namespace Activ
00019 {
00020
00021 class MessageBuilder;
00022 class MessageValidator;
00023
00024 class Rational;
00025
00026 // ---------------------------------------------------------------------------------------------------------------------------------
00027
00031 class SInt : public IFieldType
00032 {
00033 public:
00034     static const FieldType FIELD_TYPE = FIELD_TYPE_SINT;
00035
00036     using IFieldType::FromString;
00037     using IFieldType::Serialize;
00038     using IFieldType::SerializeBody;
00039     using IFieldType::SerializeLengthAndBody;
00040     using IFieldType::Deserialize;
00041     using IFieldType::DeserializeBody;
00042     using IFieldType::DeserializeLengthAndBody;
00043
00047     SInt();
00048
00054     SInt(const int64_t value);
00055
00059     virtual ~SInt();
00060
00070     bool operator==(const SInt &rhs) const;
00071
00081     bool operator!=(const SInt &rhs) const;
00082
00092     bool operator<(const SInt &rhs) const;
00093
00103     bool operator<=(const SInt &rhs) const;
00104
00114     bool operator>(const SInt &rhs) const;
00115
00125     bool operator>=(const SInt &rhs) const;
00126
00136     SInt& operator+=(const SInt &rhs);
00137
00147     SInt& operator-=(const SInt &rhs);
00148
00158     SInt& operator*=(const SInt &rhs);
00159
00169     SInt& operator/=(const SInt &rhs);
00170
00174     ACTIV_FIELD_TYPES_API operator const Rational() const;
00175
00183     StatusCode Set(const int64_t value);
00184
00193     StatusCode Get(int64_t &value) const;
00194
00202     int64_t Get() const;
00203
00213     ACTIV_FIELD_TYPES_API StatusCode Add(const SInt &rhs);
00214
00224     ACTIV_FIELD_TYPES_API StatusCode Subtract(const SInt &rhs);
00225
00235     ACTIV_FIELD_TYPES_API StatusCode Multiply(const SInt &rhs);
00236
00246     ACTIV_FIELD_TYPES_API StatusCode Divide(const SInt &rhs);
00247
00248     virtual void Reset();
00249     virtual void Clear();
00250
00259     ACTIV_FIELD_TYPES_API StatusCode Compare(const SInt &rhs, int &result) const;
00260
00261     ACTIV_FIELD_TYPES_API virtual StatusCode Compare(const void * const pRhsSerializedBody, const size_t rhsSerializedBodyLength, int &result) const;
00262     ACTIV_FIELD_TYPES_API virtual StatusCode Convert(const IFieldType * const pIFieldType);
00263     ACTIV_FIELD_TYPES_API virtual std::string ToString() const;
00264     ACTIV_FIELD_TYPES_API virtual StatusCode FromString(MessageValidator &messageValidator);
00265     ACTIV_FIELD_TYPES_API virtual std::string GetFromStringFormat() const;
00266     ACTIV_FIELD_TYPES_API virtual StatusCode Serialize(MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength) const;
00267     ACTIV_FIELD_TYPES_API virtual StatusCode SerializeBody(void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength) const;
00268     ACTIV_FIELD_TYPES_API virtual StatusCode SerializeLengthAndBody(MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength = MAX_SERIALIZED_BODY_LENGTH_UNDEFINED) const;
00269     ACTIV_FIELD_TYPES_API virtual StatusCode Deserialize(MessageValidator &messageValidator, const size_t maxSerializedBodyLength);
00270     ACTIV_FIELD_TYPES_API virtual StatusCode DeserializeBody(const void * const pSerializedBody, const size_t serializedBodyLength);
00271     ACTIV_FIELD_TYPES_API virtual StatusCode DeserializeLengthAndBody(MessageValidator &messageValidator, const size_t maxSerializedBodyLength = MAX_SERIALIZED_BODY_LENGTH_UNDEFINED);
00272     virtual size_t GetSerializedLength() const;
00273     virtual size_t GetSerializedBodyLength() const;
00274     ACTIV_FIELD_TYPES_API virtual StatusCode IsDifferent(const void * const pRhsSerializedBody, const size_t rhsSerializedBodyLength, bool &isDifferent) const;
00275
00283     static size_t GetMaxSerializedLength(const size_t size);
00284
00292     static size_t GetMaxSerializedBodyLength(const size_t size);
00293
00306     ACTIV_FIELD_TYPES_API static StatusCode Compare(const void * const pLhsSerializedBody, const size_t lhsSerializedBodyLength, const void * const pRhsSerializedBody, const size_t rhsSerializedBodyLength, int &result);
00307
00319     ACTIV_FIELD_TYPES_API static StatusCode ValidateSerializedLengthAndBody(MessageValidator &messageValidator, size_t &serializedBodyOffset, size_t &serializedBodyLength);
00320
00328     static bool IsValidSerializedBodyLength(const size_t serializedBodyLength);
00329
00330 private:
00336     size_t GetCompressedValueSize() const;
00337
00347     template <typename T> StatusCode SerializeBody(void *pSerializedBody) const;
00348
00361     template <typename T> StatusCode DeserializeBody(const void * const pSerializedBody);
00362
00363     int64_t m_value;
00364 };
00365
00366 // ---------------------------------------------------------------------------------------------------------------------------------
00367
00368 inline SInt::SInt() :
00369     IFieldType(FIELD_TYPE)
00370 {
00371     m_isInitialized = false;
00372 }
00373
00374 // ---------------------------------------------------------------------------------------------------------------------------------
00375
00376 inline SInt::SInt(const int64_t value) :
00377     IFieldType(FIELD_TYPE)
00378 {
00379     (void) Set(value);
00380 }
00381
00382 // ---------------------------------------------------------------------------------------------------------------------------------
00383
00384 inline SInt::~SInt()
00385 {
00386 }
00387
00388 // ---------------------------------------------------------------------------------------------------------------------------------
00389
00390 inline bool SInt::operator==(const SInt &rhs) const
00391 {
00392     int result;
00393     ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, Compare(rhs, result));
00394
00395     return (0 == result);
00396 }
00397
00398 // ---------------------------------------------------------------------------------------------------------------------------------
00399
00400 inline bool SInt::operator!=(const SInt &rhs) const
00401 {
00402     return !((*this) == rhs);
00403 }
00404
00405 // ---------------------------------------------------------------------------------------------------------------------------------
00406
00407 inline bool SInt::operator<(const SInt &rhs) const
00408 {
00409     int result;
00410     ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, Compare(rhs, result));
00411
00412     return (result < 0);
00413 }
00414
00415 // ---------------------------------------------------------------------------------------------------------------------------------
00416
00417 inline bool SInt::operator<=(const SInt &rhs) const
00418 {
00419     return !((*this) > rhs);
00420 }
00421
00422 // ---------------------------------------------------------------------------------------------------------------------------------
00423
00424 inline bool SInt::operator>(const SInt &rhs) const
00425 {
00426     int result;
00427     ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, Compare(rhs, result));
00428
00429     return (result > 0);
00430 }
00431
00432 // ---------------------------------------------------------------------------------------------------------------------------------
00433
00434 inline bool SInt::operator>=(const SInt &rhs) const
00435 {
00436     return !((*this) < rhs);
00437 }
00438
00439 // ---------------------------------------------------------------------------------------------------------------------------------
00440
00441 inline SInt& SInt::operator+=(const SInt &rhs)
00442 {
00443     ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, Add(rhs));
00444
00445     return (*this);
00446 }
00447
00448 // ---------------------------------------------------------------------------------------------------------------------------------
00449
00450 inline SInt& SInt::operator-=(const SInt &rhs)
00451 {
00452     ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, Subtract(rhs));
00453
00454     return (*this);
00455 }
00456
00457 // ---------------------------------------------------------------------------------------------------------------------------------
00458
00459 inline SInt& SInt::operator*=(const SInt &rhs)
00460 {
00461     ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, Multiply(rhs));
00462
00463     return (*this);
00464 }
00465
00466 // ---------------------------------------------------------------------------------------------------------------------------------
00467
00468 inline SInt& SInt::operator/=(const SInt &rhs)
00469 {
00470     ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, Divide(rhs));
00471
00472     return (*this);
00473 }
00474
00475 // ---------------------------------------------------------------------------------------------------------------------------------
00476
00477 inline StatusCode SInt::Set(const int64_t value)
00478 {
00479     m_value = value;
00480     m_isInitialized = true;
00481
00482     return STATUS_CODE_SUCCESS;
00483 }
00484
00485 // ---------------------------------------------------------------------------------------------------------------------------------
00486
00487 inline StatusCode SInt::Get(int64_t &value) const
00488 {
00489     if (!IsInitialized())
00490         return STATUS_CODE_NOT_INITIALIZED;
00491
00492     value = m_value;
00493
00494     return STATUS_CODE_SUCCESS;
00495 }
00496
00497 // ---------------------------------------------------------------------------------------------------------------------------------
00498
00499 inline int64_t SInt::Get() const
00500 {
00501     if (!IsInitialized())
00502         ACTIV_THROW(StatusCodeException, STATUS_CODE_NOT_INITIALIZED);
00503
00504     return m_value;
00505 }
00506
00507 // ---------------------------------------------------------------------------------------------------------------------------------
00508
00509 inline void SInt::Reset()
00510 {
00511     m_isInitialized = false;
00512 }
00513
00514 // ---------------------------------------------------------------------------------------------------------------------------------
00515
00516 inline void SInt::Clear()
00517 {
00518     m_isInitialized = false;
00519 }
00520
00521 // ---------------------------------------------------------------------------------------------------------------------------------
00522
00523 inline size_t SInt::GetSerializedLength() const
00524 {
00525     return (IsInitialized() ? GetMaxSerializedLength(GetCompressedValueSize()) : 0);
00526 }
00527
00528 // ---------------------------------------------------------------------------------------------------------------------------------
00529
00530 inline size_t SInt::GetSerializedBodyLength() const
00531 {
00532     return (IsInitialized() ? GetMaxSerializedBodyLength(GetCompressedValueSize()) : 0);
00533 }
00534
00535 // ---------------------------------------------------------------------------------------------------------------------------------
00536
00537 inline size_t SInt::GetMaxSerializedLength(const size_t size)
00538 {
00539     return GetMaxSerializedBodyLength(size);
00540 }
00541
00542 // ---------------------------------------------------------------------------------------------------------------------------------
00543
00544 inline size_t SInt::GetMaxSerializedBodyLength(const size_t size)
00545 {
00546     return size;
00547 }
00548
00549 // ---------------------------------------------------------------------------------------------------------------------------------
00550
00551 inline bool SInt::IsValidSerializedBodyLength(const size_t serializedBodyLength)
00552 {
00553     return ((GetMaxSerializedBodyLength(sizeof(int64_t)) == serializedBodyLength) || (GetMaxSerializedBodyLength(sizeof(int32_t)) == serializedBodyLength) || (GetMaxSerializedBodyLength(sizeof(int16_t)) == serializedBodyLength) || (GetMaxSerializedBodyLength(sizeof(int8_t)) == serializedBodyLength));
00554 }
00555
00556 // ---------------------------------------------------------------------------------------------------------------------------------
00557
00558 inline size_t SInt::GetCompressedValueSize() const
00559 {
00560     if ((m_value >= INT8_MIN) && (m_value <= INT8_MAX))
00561         return sizeof(int8_t);
00562
00563     if ((m_value >= INT16_MIN) && (m_value <= INT16_MAX))
00564         return sizeof(int16_t);
00565
00566     if ((m_value >= INT32_MIN) && (m_value <= INT32_MAX))
00567         return sizeof(int32_t);
00568
00569     return sizeof(int64_t);
00570 }
00571
00572 // ---------------------------------------------------------------------------------------------------------------------------------
00573
00574 template <typename T> inline StatusCode SInt::SerializeBody(void *pSerializedBody) const
00575 {
00576     CopyValueToUnalignedPointer(pSerializedBody, HostToLittleEndianOrder(static_cast<T>(m_value)));
00577
00578     return STATUS_CODE_SUCCESS;
00579 }
00580
00581 // ---------------------------------------------------------------------------------------------------------------------------------
00582
00583 template <typename T> inline StatusCode SInt::DeserializeBody(const void * const pSerializedBody)
00584 {
00585     return Set(static_cast<int64_t>(LittleEndianToHostOrder(GetValueFromUnalignedPointer<T>(pSerializedBody))));
00586 }
00587
00588 // ---------------------------------------------------------------------------------------------------------------------------------
00589 // ---------------------------------------------------------------------------------------------------------------------------------
00590
00601 inline const SInt operator+(const SInt &lhs, const SInt &rhs)
00602 {
00603     return SInt(lhs) += rhs;
00604 }
00605
00606 // ---------------------------------------------------------------------------------------------------------------------------------
00607
00618 inline const SInt operator-(const SInt &lhs, const SInt &rhs)
00619 {
00620     return SInt(lhs) -= rhs;
00621 }
00622
00623 // ---------------------------------------------------------------------------------------------------------------------------------
00624 // ---------------------------------------------------------------------------------------------------------------------------------
00625
00636 inline const SInt operator*(const SInt &lhs, const SInt &rhs)
00637 {
00638     return SInt(lhs) *= rhs;
00639 }
00640
00641 // ---------------------------------------------------------------------------------------------------------------------------------
00642
00653 inline const SInt operator/(const SInt &lhs, const SInt &rhs)
00654 {
00655     return SInt(lhs) /= rhs;
00656 }
00657
00658 // ---------------------------------------------------------------------------------------------------------------------------------
00659 // ---------------------------------------------------------------------------------------------------------------------------------
00660
00664 template<>
00665 class FieldTypeToClass<FIELD_TYPE_SINT>
00666 {
00667 public:
00668     typedef SInt Type;
00669 };
00670
00671 } // namespace Activ
00672
00673 #endif // (!defined ACTIV_FIELD_TYPES_SINT_H)
Generated on Wed Oct 8 14:01:48 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

ScatterBufferHelper.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_BASE_SCATTER_BUFFER_HELPER_H)
00010 #define ACTIV_BASE_SCATTER_BUFFER_HELPER_H
00011
00012 #include "ActivMiddleware/ActivBase/External.h"
00013 #include "ActivMiddleware/ActivBase/StatusCodeException.h"
00014
00015 namespace Activ
00016 {
00017
00021 class ScatterBufferHelper : private boost::noncopyable
00022 {
00023 public:
00027     class ScatterBuffer
00028     {
00029     public:
00030         void *  m_pData;
00031         size_t  m_dataLength;
00032     };
00033
00037     class ConstIterator
00038     {
00039     public:
00043         ACTIV_BASE_INLINE_API ConstIterator();
00044
00050         ACTIV_BASE_INLINE_API const ScatterBuffer &operator*() const;
00051
00057         ACTIV_BASE_INLINE_API const ScatterBuffer *operator->() const ;
00058
00064         ACTIV_BASE_INLINE_API ConstIterator &operator++();
00065
00071         ACTIV_BASE_INLINE_API const ConstIterator operator++(int);
00072
00080         ACTIV_BASE_INLINE_API bool operator==(const ConstIterator &rhs) const;
00081
00089         ACTIV_BASE_INLINE_API bool operator!=(const ConstIterator &rhs) const;
00090
00091     private:
00098         ACTIV_BASE_INLINE_API ConstIterator(const ScatterBufferHelper *pScatterBufferHelper, ScatterBuffer *pScatterBuffer);
00099
00100         const ScatterBufferHelper   *m_pScatterBufferHelper;
00101         ScatterBuffer               *m_pScatterBuffer;
00102
00103         friend class ScatterBufferHelper;
00104     };
00105
00114     ACTIV_BASE_EXPORTED_API ScatterBufferHelper(const size_t nInitialScatterBuffers = 5, const size_t initialGetBufferSize = 0);
00115
00123     ACTIV_BASE_EXPORTED_API ScatterBufferHelper(const ScatterBufferHelper &rhs);
00124
00128     ACTIV_BASE_INLINE_API ~ScatterBufferHelper();
00129
00139     ACTIV_BASE_EXPORTED_API ScatterBufferHelper& operator=(const ScatterBufferHelper &rhs);
00140
00149     ACTIV_BASE_INLINE_API StatusCode Reset(const size_t nInitialScatterBuffers);
00150
00154     ACTIV_BASE_INLINE_API void Reset();
00155
00165     ACTIV_BASE_EXPORTED_API StatusCode Attach(void *pData, const size_t dataLength);
00166
00178     ACTIV_BASE_EXPORTED_API StatusCode Attach(const ScatterBufferHelper &from, const size_t fromOffset, const size_t dataLength);
00179
00190     ACTIV_BASE_EXPORTED_API StatusCode Copy(const size_t offset, void *pData, const size_t dataLength) const;
00191
00202     ACTIV_BASE_EXPORTED_API StatusCode Copy(void *pData, const size_t dataSize, size_t &dataLength) const;
00203
00216     ACTIV_BASE_EXPORTED_API StatusCode Get(const size_t offset, const void *&pData, const size_t dataLength,
00217         void *pGetBuffer = 0) const;
00218
00230     ACTIV_BASE_EXPORTED_API StatusCode Get(const void *&pData, size_t &dataLength, void *pGetBuffer = 0,
00231         const size_t getBufferSize = 0) const;
00232
00245     ACTIV_BASE_EXPORTED_API StatusCode Get(const size_t offset, const void *&pData, const size_t dataLength,
00246         size_t &dataLengthRead) const;
00247
00258     ACTIV_BASE_EXPORTED_API StatusCode Set(const size_t offset, const void *pData, const size_t dataLength);
00259
00271     ACTIV_BASE_EXPORTED_API StatusCode Set(const size_t offset, const ScatterBufferHelper &from, const size_t fromOffset,
00272         const size_t dataLength);
00273
00279     ACTIV_BASE_INLINE_API size_t GetTotalBytes() const;
00280
00289     ACTIV_BASE_EXPORTED_API StatusCode AdjustGetBufferSize(const size_t getBufferSize) const;
00290
00296     ACTIV_BASE_INLINE_API size_t GetNumberOfScatterBuffersInUse() const;
00297
00303     ACTIV_BASE_INLINE_API ConstIterator Begin() const;
00304
00310     ACTIV_BASE_INLINE_API ConstIterator End() const;
00311
00312 private:
00321     ACTIV_BASE_LOCAL_API StatusCode AdjustScatterBufferList(const size_t nScatterBuffers);
00322
00323     size_t          m_nInitialScatterBuffers;
00324
00325     ScatterBuffer   *m_pScatterBufferList;
00326     size_t          m_nScatterBuffers;
00327     size_t          m_nScatterBuffersInUse;
00328     size_t          m_totalBytes;
00329
00330     mutable void    *m_pGetBuffer;
00331     mutable size_t  m_getBufferSize;
00332 };
00333
00334 // ---------------------------------------------------------------------------------------------------------------------------------
00335
00336 inline ScatterBufferHelper::~ScatterBufferHelper()
00337 {
00338     if (NULL != m_pScatterBufferList)
00339         std::free(m_pScatterBufferList);
00340
00341     if (NULL != m_pGetBuffer)
00342         std::free(m_pGetBuffer);
00343 }
00344
00345 // ---------------------------------------------------------------------------------------------------------------------------------
00346
00347 inline StatusCode ScatterBufferHelper::Reset(const size_t nInitialScatterBuffers)
00348 {
00349     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, AdjustScatterBufferList(nInitialScatterBuffers));
00350
00351     m_nInitialScatterBuffers = nInitialScatterBuffers;
00352     m_nScatterBuffersInUse = 0;
00353     m_totalBytes = 0;
00354
00355     return STATUS_CODE_SUCCESS;
00356 }
00357
00358 // ---------------------------------------------------------------------------------------------------------------------------------
00359
00360 inline void ScatterBufferHelper::Reset()
00361 {
00362     m_nScatterBuffersInUse = 0;
00363     m_totalBytes = 0;
00364 }
00365
00366 // ---------------------------------------------------------------------------------------------------------------------------------
00367
00368 inline size_t ScatterBufferHelper::GetTotalBytes() const
00369 {
00370     return m_totalBytes;
00371 }
00372
00373 // ---------------------------------------------------------------------------------------------------------------------------------
00374
00375 inline size_t ScatterBufferHelper::GetNumberOfScatterBuffersInUse() const
00376 {
00377     return m_nScatterBuffersInUse;
00378 }
00379
00380 // ---------------------------------------------------------------------------------------------------------------------------------
00381
00382 inline ScatterBufferHelper::ConstIterator ScatterBufferHelper::Begin() const
00383 {
00384     return ConstIterator(this, m_pScatterBufferList);
00385 }
00386
00387 // ---------------------------------------------------------------------------------------------------------------------------------
00388
00389 inline ScatterBufferHelper::ConstIterator ScatterBufferHelper::End() const
00390 {
00391     return ConstIterator(this, ((0 != m_pScatterBufferList) ? m_pScatterBufferList + m_nScatterBuffersInUse : 0));
00392 }
00393
00394 // ---------------------------------------------------------------------------------------------------------------------------------
00395 // ---------------------------------------------------------------------------------------------------------------------------------
00396
00397 inline ScatterBufferHelper::ConstIterator::ConstIterator() :
00398     m_pScatterBufferHelper(0),
00399     m_pScatterBuffer(0)
00400 {
00401 }
00402
00403 // ---------------------------------------------------------------------------------------------------------------------------------
00404
00405 inline const ScatterBufferHelper::ScatterBuffer &ScatterBufferHelper::ConstIterator::operator*() const
00406 {
00407     return *m_pScatterBuffer;
00408 }
00409
00410 // ---------------------------------------------------------------------------------------------------------------------------------
00411
00412 inline const ScatterBufferHelper::ScatterBuffer *ScatterBufferHelper::ConstIterator::operator->() const
00413 {
00414     return m_pScatterBuffer;
00415 }
00416
00417 // ---------------------------------------------------------------------------------------------------------------------------------
00418
00419 inline ScatterBufferHelper::ConstIterator &ScatterBufferHelper::ConstIterator::operator++()
00420 {
00421     ++m_pScatterBuffer;
00422
00423     return *this;
00424 }
00425
00426 // ---------------------------------------------------------------------------------------------------------------------------------
00427
00428 inline const ScatterBufferHelper::ConstIterator ScatterBufferHelper::ConstIterator::operator++(int)
00429 {
00430     ConstIterator oldValue = *this;
00431
00432     ++(*this);
00433
00434     return oldValue;
00435 }
00436
00437 // ---------------------------------------------------------------------------------------------------------------------------------
00438
00439 inline bool ScatterBufferHelper::ConstIterator::operator==(const ScatterBufferHelper::ConstIterator &rhs) const
00440 {
00441     return ((m_pScatterBufferHelper == rhs.m_pScatterBufferHelper) && (m_pScatterBuffer == rhs.m_pScatterBuffer));
00442 }
00443
00444 // ---------------------------------------------------------------------------------------------------------------------------------
00445
00446 inline bool ScatterBufferHelper::ConstIterator::operator!=(const ScatterBufferHelper::ConstIterator &rhs) const
00447 {
00448     return !((*this) == rhs);
00449 }
00450
00451 // ---------------------------------------------------------------------------------------------------------------------------------
00452
00453 inline ScatterBufferHelper::ConstIterator::ConstIterator(const ScatterBufferHelper *pScatterBufferHelper, ScatterBuffer *pScatterBuffer) :
00454     m_pScatterBufferHelper(pScatterBufferHelper),
00455     m_pScatterBuffer(pScatterBuffer)
00456 {
00457 }
00458
00459 } // namespace Activ
00460
00461 #endif // (!defined ACTIV_BASE_SCATTER_BUFFER_HELPER_H)
Generated on Wed Oct 8 14:01:47 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivSystem

ScopedAddress.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_SYSTEM_SCOPED_ADDRESS_H)
00010 #define ACTIV_SYSTEM_SCOPED_ADDRESS_H
00011
00012 #include "ActivMiddleware/ActivSystem/External.h"
00013 #include "ActivMiddleware/ActivSystem/Address.h"
00014
00015 namespace Activ
00016 {
00017
00018 class Port;
00019
00020 // ---------------------------------------------------------------------------------------------------------------------------------
00021
00028 class ScopedAddress
00029 {
00030 public:
00034     class Proxy : public Address::Proxy
00035     {
00036     public:
00042         ACTIV_SYSTEM_INLINE_API
00043         Proxy(ScopedAddress &scopedAddress);
00044
00051         ACTIV_SYSTEM_INLINE_API
00052         ~Proxy();
00053
00054     private:
00055         Address         m_address;
00056         ScopedAddress & m_scopedAddress;
00057     };
00058
00064     ACTIV_SYSTEM_INLINE_API
00065     ScopedAddress(Port &port);
00066
00073     ACTIV_SYSTEM_INLINE_API
00074     ScopedAddress(Port &port, const Address &address);
00075
00083     ACTIV_SYSTEM_INLINE_API
00084     ScopedAddress(ScopedAddress &scopedAddress);
00085
00091     ACTIV_SYSTEM_INLINE_API
00092     ~ScopedAddress();
00093
00099     ACTIV_SYSTEM_EXPORTED_API
00100     void Clear();
00101
00105     ACTIV_SYSTEM_INLINE_API
00106     void Release();
00107
00113     ACTIV_SYSTEM_INLINE_API
00114     std::string ToString() const;
00115
00123     ACTIV_SYSTEM_INLINE_API
00124     bool IsValid() const;
00125
00133     ACTIV_SYSTEM_INLINE_API
00134     bool operator==(const Address &rhs) const;
00135
00143     ACTIV_SYSTEM_INLINE_API
00144     bool operator!=(const Address &rhs) const;
00145
00155     ACTIV_SYSTEM_INLINE_API
00156     ScopedAddress &operator=(const Address &rhs);
00157
00168     ACTIV_SYSTEM_INLINE_API
00169     ScopedAddress &operator=(ScopedAddress &rhs);
00170
00176     ACTIV_SYSTEM_INLINE_API
00177     operator Proxy();
00178
00187     ACTIV_SYSTEM_INLINE_API
00188     operator const Address &() const;
00189
00190 private:
00191     const Port &m_port;
00192     Address     m_address;
00193 };
00194
00195 // ---------------------------------------------------------------------------------------------------------------------------------
00196
00197 inline ScopedAddress::ScopedAddress(Port &port) :
00198     m_port(port)
00199 {
00200 }
00201
00202 // ---------------------------------------------------------------------------------------------------------------------------------
00203
00204 inline ScopedAddress::ScopedAddress(Port &port, const Address &address) :
00205     m_port(port)
00206 {
00207     *this = address;
00208 }
00209
00210 // ---------------------------------------------------------------------------------------------------------------------------------
00211
00212 inline ScopedAddress::ScopedAddress(ScopedAddress &scopedAddress) :
00213     m_port(scopedAddress.m_port)
00214 {
00215     *this = scopedAddress;
00216 }
00217
00218 // ---------------------------------------------------------------------------------------------------------------------------------
00219
00220 inline ScopedAddress::~ScopedAddress()
00221 {
00222     Clear();
00223 }
00224
00225 // ---------------------------------------------------------------------------------------------------------------------------------
00226
00227 inline void ScopedAddress::Release()
00228 {
00229     m_address.Clear();
00230 }
00231
00232 // ---------------------------------------------------------------------------------------------------------------------------------
00233
00234 inline std::string ScopedAddress::ToString() const
00235 {
00236     return m_address.ToString();
00237 }
00238
00239 // ---------------------------------------------------------------------------------------------------------------------------------
00240
00241 inline bool ScopedAddress::IsValid() const
00242 {
00243     return m_address.IsValid();
00244 }
00245
00246 // ---------------------------------------------------------------------------------------------------------------------------------
00247
00248 inline bool ScopedAddress::operator==(const Address &rhs) const
00249 {
00250     return (m_address == rhs);
00251 }
00252
00253 // ---------------------------------------------------------------------------------------------------------------------------------
00254
00255 inline bool ScopedAddress::operator!=(const Address &rhs) const
00256 {
00257     return (m_address != rhs);
00258 }
00259
00260 // ---------------------------------------------------------------------------------------------------------------------------------
00261
00262 inline ScopedAddress &ScopedAddress::operator=(const Address &rhs)
00263 {
00264     if (rhs != m_address)
00265     {
00266         Clear();
00267         m_address = rhs;
00268     }
00269
00270     return *this;
00271 }
00272
00273 // ---------------------------------------------------------------------------------------------------------------------------------
00274
00275 inline ScopedAddress &ScopedAddress::operator=(ScopedAddress &rhs)
00276 {
00277     if (&rhs != this)
00278     {
00279         Clear();
00280         m_address = rhs.m_address;
00281         rhs.m_address.Clear();
00282     }
00283
00284     return *this;
00285 }
00286
00287 // ---------------------------------------------------------------------------------------------------------------------------------
00288
00289 inline ScopedAddress::operator ScopedAddress::Proxy()
00290 {
00291     return Proxy(*this);
00292 }
00293
00294 // ---------------------------------------------------------------------------------------------------------------------------------
00295
00296 inline ScopedAddress::operator const Address &() const
00297 {
00298     return m_address;
00299 }
00300
00301 // ---------------------------------------------------------------------------------------------------------------------------------
00302 // ---------------------------------------------------------------------------------------------------------------------------------
00303
00304 inline ScopedAddress::Proxy::Proxy(ScopedAddress &scopedAddress) :
00305     Address::Proxy(m_address),
00306     m_address(scopedAddress.m_address),
00307     m_scopedAddress(scopedAddress)
00308 {
00309 }
00310
00311 // ---------------------------------------------------------------------------------------------------------------------------------
00312
00313 inline ScopedAddress::Proxy::~Proxy()
00314 {
00315     if (m_scopedAddress != m_address)
00316         m_scopedAddress = m_address;
00317 }
00318
00319 } // namespace Activ
00320
00321 #endif // (!defined ACTIV_SYSTEM_SCOPED_ADDRESS_H)
Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » Misc

ScopedHelper.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_MISC_SCOPED_HELPER_H)
00010 #define ACTIV_MISC_SCOPED_HELPER_H
00011
00012 #include "ActivMiddleware/Activ.h"
00013
00014 #include "boost/function.hpp"
00015 #include "boost/bind.hpp"
00016
00017 #include <functional>
00018
00019 #if (defined ACTIV_PLATFORM_WINDOWS)
00020 #include <io.h>
00021 #endif
00022
00023 namespace Activ
00024 {
00025
00032 template<typename T, typename D>
00033 class ScopedHelper : private boost::noncopyable
00034 {
00035 public:
00039     class True
00040     {
00041     public:
00042         bool operator()(T) const
00043         {
00044             return true;
00045         }
00046     };
00047
00048     typedef boost::function<bool (T)> Condition;
00049
00059     ScopedHelper(T object, D destructor, Condition condition = True()) :
00060         m_object(object),
00061         m_destructor(destructor),
00062         m_condition(condition)
00063     {
00064     }
00065
00069     ~ScopedHelper()
00070     {
00071         if (m_condition(m_object))
00072             m_destructor(m_object);
00073     }
00074
00078     operator T()
00079     {
00080         return m_object;
00081     }
00082
00083 private:
00084     T           m_object;
00085     D           m_destructor;
00086     Condition   m_condition;
00087 };
00088
00089 // ---------------------------------------------------------------------------------------------------------------------------------
00090 // ---------------------------------------------------------------------------------------------------------------------------------
00091
00099 template<typename T>
00100 class ScopedMemory : public ScopedHelper<T, boost::function<void (void *)> >
00101 {
00102 public:
00108     ScopedMemory(void *pMem) :
00109         ScopedHelper<T, boost::function<void (void *)> >(reinterpret_cast<T>(pMem), std::free,
00110             boost::bind(std::not_equal_to<void *>(), _1, reinterpret_cast<T>(NULL)))
00111     {
00112     }
00113 };
00114
00115 // ---------------------------------------------------------------------------------------------------------------------------------
00116 // ---------------------------------------------------------------------------------------------------------------------------------
00117
00123 class ScopedFile : public ScopedHelper<FILE *, boost::function<int (FILE *)> >
00124 {
00125 public:
00126     ScopedFile(FILE *pFile) :
00127         ScopedHelper<FILE *, boost::function<int (FILE *)> >(pFile, ::fclose,
00128             boost::bind(std::not_equal_to<FILE *>(), _1, reinterpret_cast<FILE *>(NULL)))
00129     {
00130     }
00131 };
00132
00133 // ---------------------------------------------------------------------------------------------------------------------------------
00134 // ---------------------------------------------------------------------------------------------------------------------------------
00135
00141 class ScopedFd : public ScopedHelper<int, boost::function<int (int)> >
00142 {
00143 public:
00144     ScopedFd(int fd) :
00145         ScopedHelper<int, boost::function<int (int)> >(fd, ::close, boost::bind(std::not_equal_to<int>(), _1, -1))
00146     {
00147     }
00148 };
00149
00150 // ---------------------------------------------------------------------------------------------------------------------------------
00151 // ---------------------------------------------------------------------------------------------------------------------------------
00152
00158 class ScopedSocket : public ScopedHelper<SOCKET, boost::function<int (SOCKET)> >
00159 {
00160 public:
00161     ScopedSocket(SOCKET socket) :
00162         ScopedHelper<SOCKET, boost::function<int (SOCKET)> >(socket, closesocket, boost::bind(std::not_equal_to<SOCKET>(), _1, INVALID_SOCKET))
00163     {
00164     }
00165 };
00166
00167 // ---------------------------------------------------------------------------------------------------------------------------------
00168 // ---------------------------------------------------------------------------------------------------------------------------------
00169
00170 #if (defined ACTIV_PLATFORM_WINDOWS)
00171
00177 class ScopedHandle : public ScopedHelper<HANDLE, boost::function<BOOL (HANDLE)> >
00178 {
00179 public:
00183     class IsValidHandle
00184     {
00185     public:
00186         bool operator()(const HANDLE handle)
00187         {
00188             return ((NULL != handle) && (INVALID_HANDLE_VALUE != handle));
00189         }
00190     };
00191
00192     ScopedHandle(HANDLE handle) :
00193         ScopedHelper<HANDLE, boost::function<BOOL (HANDLE)> >(handle, ::CloseHandle, IsValidHandle())
00194     {
00195     }
00196 };
00197
00198 #endif // (defined ACTIV_PLATFORM_WINDOWS)
00199
00200 } // namespace Activ
00201
00202 #endif // (!defined ACTIV_MISC_SCOPED_HELPER_H)
Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » Misc

SerializableBuffer.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_MISC_SERIALIZABLE_BUFFER_H)
00010 #define ACTIV_MISC_SERIALIZABLE_BUFFER_H
00011
00012 #include "ActivMiddleware/Misc/MemoryHelper.h"
00013
00014 #include "boost/integer_traits.hpp"
00015
00016 namespace Activ
00017 {
00018
00026 template <typename LENGTH_TYPE, LENGTH_TYPE MIN_LENGTH = 0, LENGTH_TYPE MAX_LENGTH = boost::integer_traits<LENGTH_TYPE>::const_max>
00027 class SerializableBuffer
00028 {
00029 public:
00030     typedef LENGTH_TYPE Length;
00031
00035     SerializableBuffer();
00036
00044     SerializableBuffer(const SerializableBuffer &serializableBuffer);
00045
00049     ~SerializableBuffer();
00050
00056     SerializableBuffer &operator=(const SerializableBuffer &rhs);
00057
00068     StatusCode Set(const void *pData, const size_t dataLength, const bool shouldCopy);
00069
00075     const void *GetData() const;
00076
00082     size_t GetDataLength() const;
00083
00094     static StatusCode Serialize(MessageBuilder &messageBuilder, const void * const pData, const size_t dataLength);
00095
00104     StatusCode Serialize(MessageBuilder &messageBuilder) const;
00105
00114     StatusCode Deserialize(MessageValidator &messageValidator);
00115
00116 private:
00125     StatusCode AdjustBufferSize(const size_t requiredLength);
00126
00127     const void *m_pData;
00128     size_t      m_dataLength;
00129
00130     void *      m_pBuffer;
00131     size_t      m_bufferLength;
00132 };
00133
00134 // ---------------------------------------------------------------------------------------------------------------------------------
00135
00136 template <typename LENGTH_TYPE, LENGTH_TYPE MIN_LENGTH, LENGTH_TYPE MAX_LENGTH>
00137 inline SerializableBuffer<LENGTH_TYPE, MIN_LENGTH, MAX_LENGTH>::SerializableBuffer() :
00138     m_pData(0),
00139     m_dataLength(0),
00140     m_pBuffer(0),
00141     m_bufferLength(0)
00142 {
00143 }
00144
00145 // ---------------------------------------------------------------------------------------------------------------------------------
00146
00147 template <typename LENGTH_TYPE, LENGTH_TYPE MIN_LENGTH, LENGTH_TYPE MAX_LENGTH>
00148 inline SerializableBuffer<LENGTH_TYPE, MIN_LENGTH, MAX_LENGTH>::SerializableBuffer(const SerializableBuffer &serializableBuffer) :
00149     m_pData(0),
00150     m_dataLength(0),
00151     m_pBuffer(0),
00152     m_bufferLength(0)
00153 {
00154     *this = serializableBuffer;
00155 }
00156
00157 // ---------------------------------------------------------------------------------------------------------------------------------
00158
00159 template <typename LENGTH_TYPE, LENGTH_TYPE MIN_LENGTH, LENGTH_TYPE MAX_LENGTH>
00160 inline SerializableBuffer<LENGTH_TYPE, MIN_LENGTH, MAX_LENGTH>::~SerializableBuffer()
00161 {
00162     if (0 != m_pBuffer)
00163         std::free(m_pBuffer);
00164 }
00165
00166 // ---------------------------------------------------------------------------------------------------------------------------------
00167
00168 template <typename LENGTH_TYPE, LENGTH_TYPE MIN_LENGTH, LENGTH_TYPE MAX_LENGTH>
00169 inline SerializableBuffer<LENGTH_TYPE, MIN_LENGTH, MAX_LENGTH> &SerializableBuffer<LENGTH_TYPE, MIN_LENGTH, MAX_LENGTH>::operator=(
00170     const SerializableBuffer &rhs)
00171 {
00172     if (this != &rhs)
00173     {
00174         // If RHS is using an allocated buffer then copy bytes, otherwise just store pointer
00175         ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, Set(rhs.GetData(), rhs.GetDataLength(), (rhs.m_pData == rhs.m_pBuffer)));
00176     }
00177
00178     return *this;
00179 }
00180
00181 // ---------------------------------------------------------------------------------------------------------------------------------
00182
00183 template <typename LENGTH_TYPE, LENGTH_TYPE MIN_LENGTH, LENGTH_TYPE MAX_LENGTH>
00184 inline StatusCode SerializableBuffer<LENGTH_TYPE, MIN_LENGTH, MAX_LENGTH>::Set(const void *pData, const size_t dataLength,
00185     const bool shouldCopy)
00186 {
00187     m_pData = 0;
00188     m_dataLength = 0;
00189
00190     if ((0 == pData) || (0 == dataLength))
00191         return STATUS_CODE_SUCCESS;
00192
00193     if (shouldCopy)
00194     {
00195         ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, AdjustBufferSize(dataLength));
00196         MemoryCopy(m_pBuffer, pData, dataLength);
00197
00198         m_pData = m_pBuffer;
00199         m_dataLength = dataLength;
00200     }
00201     else
00202     {
00203         m_pData = pData;
00204         m_dataLength = dataLength;
00205     }
00206
00207     return STATUS_CODE_SUCCESS;
00208 }
00209
00210 // ---------------------------------------------------------------------------------------------------------------------------------
00211
00212 template <typename LENGTH_TYPE, LENGTH_TYPE MIN_LENGTH, LENGTH_TYPE MAX_LENGTH>
00213 inline const void *SerializableBuffer<LENGTH_TYPE, MIN_LENGTH, MAX_LENGTH>::GetData() const
00214 {
00215     return m_pData;
00216 }
00217
00218 // ---------------------------------------------------------------------------------------------------------------------------------
00219
00220 template <typename LENGTH_TYPE, LENGTH_TYPE MIN_LENGTH, LENGTH_TYPE MAX_LENGTH>
00221 inline size_t SerializableBuffer<LENGTH_TYPE, MIN_LENGTH, MAX_LENGTH>::GetDataLength() const
00222 {
00223     return m_dataLength;
00224 }
00225
00226 // ---------------------------------------------------------------------------------------------------------------------------------
00227
00228 template <typename LENGTH_TYPE, LENGTH_TYPE MIN_LENGTH, LENGTH_TYPE MAX_LENGTH>
00229 inline StatusCode SerializableBuffer<LENGTH_TYPE, MIN_LENGTH, MAX_LENGTH>::Serialize(MessageBuilder &messageBuilder,
00230     const void * const pData, const size_t dataLength)
00231 {
00232     if ((dataLength < MIN_LENGTH) || (dataLength > MAX_LENGTH))
00233         return STATUS_CODE_INVALID_LENGTH;
00234
00235     LENGTH_TYPE actualLength = static_cast<LENGTH_TYPE>(dataLength);
00236
00237     if (static_cast<size_t>(actualLength) != dataLength)
00238         return STATUS_CODE_INVALID_LENGTH;
00239
00240     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, messageBuilder.Append(actualLength, MessageBuilder::ENDIAN_LITTLE));
00241     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, messageBuilder.Append(pData, dataLength));
00242
00243     return STATUS_CODE_SUCCESS;
00244 }
00245
00246 // ---------------------------------------------------------------------------------------------------------------------------------
00247
00248 template <typename LENGTH_TYPE, LENGTH_TYPE MIN_LENGTH, LENGTH_TYPE MAX_LENGTH>
00249 inline StatusCode SerializableBuffer<LENGTH_TYPE, MIN_LENGTH, MAX_LENGTH>::Serialize(MessageBuilder &messageBuilder) const
00250 {
00251     return Serialize(messageBuilder, m_pData, m_dataLength);
00252 }
00253
00254 // ---------------------------------------------------------------------------------------------------------------------------------
00255
00256 template <typename LENGTH_TYPE, LENGTH_TYPE MIN_LENGTH, LENGTH_TYPE MAX_LENGTH>
00257 inline StatusCode SerializableBuffer<LENGTH_TYPE, MIN_LENGTH, MAX_LENGTH>::Deserialize(MessageValidator &messageValidator)
00258 {
00259     m_pData = 0;
00260     m_dataLength = 0;
00261
00262     LENGTH_TYPE dataLength;
00263
00264     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=,
00265         (messageValidator.ValidateBinaryIntegral<sizeof(LENGTH_TYPE), MessageValidator::ENDIAN_LITTLE>(MIN_LENGTH, MAX_LENGTH,
00266         dataLength)));
00267
00268     if (dataLength > 0)
00269     {
00270         ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, AdjustBufferSize(static_cast<size_t>(dataLength)));
00271         ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=,
00272             messageValidator.ValidateBytesCopy(static_cast<size_t>(dataLength), m_pBuffer));
00273
00274         m_pData = m_pBuffer;
00275         m_dataLength = static_cast<size_t>(dataLength);
00276     }
00277
00278     return STATUS_CODE_SUCCESS;
00279 }
00280
00281 // ---------------------------------------------------------------------------------------------------------------------------------
00282
00283 template <typename LENGTH_TYPE, LENGTH_TYPE MIN_LENGTH, LENGTH_TYPE MAX_LENGTH>
00284 StatusCode SerializableBuffer<LENGTH_TYPE, MIN_LENGTH, MAX_LENGTH>::AdjustBufferSize(const size_t requiredLength)
00285 {
00286     if (requiredLength > m_bufferLength)
00287     {
00288         // adjust buffer (greater of 1.5 * existing size or the requested size)
00289         size_t newBufferLength = std::max<>(requiredLength, m_bufferLength + (m_bufferLength / 2));
00290
00291         // and round to 4 bytes
00292         newBufferLength += 3;
00293         newBufferLength &= ~3;
00294
00295         void * const pNewBuffer = std::realloc(m_pBuffer, newBufferLength);
00296
00297         // NB in this case the original buffer is left intact
00298         if (NULL == pNewBuffer)
00299             return STATUS_CODE_HEAP_EMPTY;
00300
00301         m_pBuffer = pNewBuffer;
00302         m_bufferLength = newBufferLength;
00303     }
00304
00305     return STATUS_CODE_SUCCESS;
00306 }
00307
00308 } // namespace Activ
00309
00310 #endif // (!defined ACTIV_MISC_SERIALIZABLE_BUFFER_H)
Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » Misc

SerializableContainerHelper.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_MISC_SERIALIZABLE_CONTAINER_HELPER_H)
00010 #define ACTIV_MISC_SERIALIZABLE_CONTAINER_HELPER_H
00011
00012 #include "ActivMiddleware/Misc/Detail/SerializableContainerHelperDetail.h"
00013
00014 namespace Activ
00015 {
00016
00033 template <typename CONTAINER_TYPE, typename COUNT_TYPE, COUNT_TYPE MIN_LENGTH, COUNT_TYPE MAX_LENGTH, typename OBJECT_HELPER>
00034 class SerializableContainerHelper
00035 {
00036 public:
00037     typedef CONTAINER_TYPE Container;
00038
00048     static StatusCode Serialize(MessageBuilder &messageBuilder, const Container &container)
00049     {
00050         // currently specializations for std::vector, std::list, std::set and std::map are provided
00051         BOOST_STATIC_ASSERT(sizeof(COUNT_TYPE) == 0);
00052
00053         return STATUS_CODE_NOT_SUPPORTED;
00054     }
00055
00066     static StatusCode Deserialize(MessageValidator &messageValidator, Container &container, const bool shouldClearContainer)
00067     {
00068         // currently specializations for std::vector, std::list, std::set and std::map are provided
00069         BOOST_STATIC_ASSERT(sizeof(COUNT_TYPE) == 0);
00070
00071         return STATUS_CODE_NOT_SUPPORTED;
00072     }
00073 };
00074
00075 // ---------------------------------------------------------------------------------------------------------------------------------
00076 // ---------------------------------------------------------------------------------------------------------------------------------
00077
00106 template <typename CONTAINER_TYPE, typename COUNT_TYPE, COUNT_TYPE MIN_LENGTH = 0, COUNT_TYPE MAX_LENGTH = boost::integer_traits<COUNT_TYPE>::const_max>
00107 class SerializableObjectContainerHelper : public SerializableContainerHelper<CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, SerializableObjectHelper<typename CONTAINER_TYPE::value_type> >
00108 {
00109 };
00110
00111 // ---------------------------------------------------------------------------------------------------------------------------------
00112 // ---------------------------------------------------------------------------------------------------------------------------------
00113
00142 template <typename CONTAINER_TYPE, typename COUNT_TYPE, COUNT_TYPE MIN_LENGTH = 0, COUNT_TYPE MAX_LENGTH = boost::integer_traits<COUNT_TYPE>::const_max>
00143 class SerializableRawPointerContainerHelper : public SerializableContainerHelper<CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, SerializableRawPointerHelper<typename CONTAINER_TYPE::value_type> >
00144 {
00145 };
00146
00147 // ---------------------------------------------------------------------------------------------------------------------------------
00148 // ---------------------------------------------------------------------------------------------------------------------------------
00149
00178 template <typename CONTAINER_TYPE, typename COUNT_TYPE, COUNT_TYPE MIN_LENGTH = 0, COUNT_TYPE MAX_LENGTH = boost::integer_traits<COUNT_TYPE>::const_max>
00179 class SerializableSmartPointerContainerHelper : public SerializableContainerHelper<CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, SerializableSmartPointerHelper<typename CONTAINER_TYPE::value_type> >
00180 {
00181 };
00182
00183 } // namespace Activ
00184
00185 #include "ActivMiddleware/Misc/Detail/SerializableContainerHelperSpecializations.h"
00186
00187 #endif // (!defined ACTIV_MISC_SERIALIZABLE_CONTAINER_HELPER_H)
Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » Misc » Detail

SerializableContainerHelperDetail.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_MISC_DETAIL_SERIALIZABLE_CONTAINER_HELPER_DETAIL_H)
00010 #define ACTIV_MISC_DETAIL_SERIALIZABLE_CONTAINER_HELPER_DETAIL_H
00011
00012 #include "ActivMiddleware/ActivBase/MessageBuilder.h"
00013 #include "ActivMiddleware/ActivBase/MessageValidator.h"
00014
00015 #include "boost/integer_traits.hpp"
00016 #include "boost/type_traits/remove_pointer.hpp"
00017 #include "boost/static_assert.hpp"
00018
00019 #include <vector>
00020 #include <list>
00021 #include <set>
00022 #include <map>
00023
00024 namespace Activ
00025 {
00026
00039 template <typename OBJECT_TYPE>
00040 inline StatusCode SerializeObject(MessageBuilder &messageBuilder, const OBJECT_TYPE &object)
00041 {
00042     return object.Serialize(messageBuilder);
00043 }
00044
00045 // ---------------------------------------------------------------------------------------------------------------------------------
00046
00059 template <typename OBJECT_TYPE>
00060 inline StatusCode DeserializeObject(MessageValidator &messageValidator, OBJECT_TYPE &object)
00061 {
00062     return object.Deserialize(messageValidator);
00063 }
00064
00065 // ---------------------------------------------------------------------------------------------------------------------------------
00066
00070 #define ACTIV_SERIALIZE_OBJECT(type)                                                                \
00071     inline StatusCode SerializeObject(MessageBuilder &messageBuilder, const type &value)            \
00072     {                                                                                               \
00073         return messageBuilder.Append(value, MessageBuilder::ENDIAN_LITTLE);                         \
00074     }
00075
00076 // ---------------------------------------------------------------------------------------------------------------------------------
00077
00081 #define ACTIV_DESERIALIZE_OBJECT(type, validator)                                                   \
00082     inline StatusCode DeserializeObject(MessageValidator &messageValidator, type &value)            \
00083     {                                                                                               \
00084         return messageValidator.validator(sizeof(value), MessageValidator::ENDIAN_LITTLE, &value);  \
00085     }
00086
00087 // ---------------------------------------------------------------------------------------------------------------------------------
00088
00089 // Specializations for basic unsigned types
00090 ACTIV_SERIALIZE_OBJECT(uint8_t)
00091 ACTIV_DESERIALIZE_OBJECT(uint8_t, ValidateUnsignedBinaryIntegral)
00092 ACTIV_SERIALIZE_OBJECT(uint16_t)
00093 ACTIV_DESERIALIZE_OBJECT(uint16_t, ValidateUnsignedBinaryIntegral)
00094 ACTIV_SERIALIZE_OBJECT(uint32_t)
00095 ACTIV_DESERIALIZE_OBJECT(uint32_t, ValidateUnsignedBinaryIntegral)
00096 ACTIV_SERIALIZE_OBJECT(uint64_t)
00097 ACTIV_DESERIALIZE_OBJECT(uint64_t, ValidateUnsignedBinaryIntegral)
00098
00099 // ---------------------------------------------------------------------------------------------------------------------------------
00100
00101 // Specializations for basic signed types
00102 ACTIV_SERIALIZE_OBJECT(int8_t)
00103 ACTIV_DESERIALIZE_OBJECT(int8_t, ValidateSignedBinaryIntegral)
00104 ACTIV_SERIALIZE_OBJECT(int16_t)
00105 ACTIV_DESERIALIZE_OBJECT(int16_t, ValidateSignedBinaryIntegral)
00106 ACTIV_SERIALIZE_OBJECT(int32_t)
00107 ACTIV_DESERIALIZE_OBJECT(int32_t, ValidateSignedBinaryIntegral)
00108 ACTIV_SERIALIZE_OBJECT(int64_t)
00109 ACTIV_DESERIALIZE_OBJECT(int64_t, ValidateSignedBinaryIntegral)
00110
00111 // ---------------------------------------------------------------------------------------------------------------------------------
00112
00113 // Specializations for boolean type
00114 inline StatusCode SerializeObject(MessageBuilder &messageBuilder, const bool &booleanValue)
00115 {
00116     return messageBuilder.AppendBoolean(booleanValue);
00117 }
00118
00119 // ---------------------------------------------------------------------------------------------------------------------------------
00120
00121 inline StatusCode DeserializeObject(MessageValidator &messageValidator, bool &booleanValue)
00122 {
00123     return messageValidator.ValidateBoolean(&booleanValue);
00124 }
00125
00126 // ---------------------------------------------------------------------------------------------------------------------------------
00127
00128 // Specializations for string type
00129 inline StatusCode SerializeObject(MessageBuilder &messageBuilder, const std::string &str)
00130 {
00131     return messageBuilder.Append(str);
00132 }
00133
00134 // ---------------------------------------------------------------------------------------------------------------------------------
00135
00136 inline StatusCode DeserializeObject(MessageValidator &messageValidator, std::string &str)
00137 {
00138     return messageValidator.ValidateString(&str);
00139 }
00140
00141 // ---------------------------------------------------------------------------------------------------------------------------------
00142 // ---------------------------------------------------------------------------------------------------------------------------------
00143
00150 template<typename OBJECT_TYPE>
00151 class SerializableObjectHelper
00152 {
00153 public:
00163     static StatusCode Serialize(MessageBuilder &messageBuilder, const OBJECT_TYPE &object)
00164     {
00165         return SerializeObject(messageBuilder, object);
00166     }
00167
00177     static StatusCode Deserialize(MessageValidator &messageValidator, OBJECT_TYPE &object)
00178     {
00179         return DeserializeObject(messageValidator, object);
00180     }
00181 };
00182
00183 // ---------------------------------------------------------------------------------------------------------------------------------
00184 // ---------------------------------------------------------------------------------------------------------------------------------
00185
00194 template<typename POINTER_TYPE>
00195 class SerializableSmartPointerHelper
00196 {
00197 public:
00198     typedef typename POINTER_TYPE::element_type ObjectType;
00199
00209     static StatusCode Serialize(MessageBuilder &messageBuilder, const POINTER_TYPE &pObject)
00210     {
00211         return SerializeObject(messageBuilder, *pObject);
00212     }
00213
00223     static StatusCode Deserialize(MessageValidator &messageValidator, POINTER_TYPE &pObject)
00224     {
00225         // new object into raw pointer
00226         ObjectType * const pRawObject = new (std::nothrow) ObjectType;
00227
00228         if (0 == pRawObject)
00229             return STATUS_CODE_HEAP_EMPTY;
00230
00231         // some smart pointers don't allow assignment from raw pointer. Assign from temporary
00232         pObject = POINTER_TYPE(pRawObject);
00233
00234         return DeserializeObject(messageValidator, *pObject);
00235     }
00236 };
00237
00238 // ---------------------------------------------------------------------------------------------------------------------------------
00239 // ---------------------------------------------------------------------------------------------------------------------------------
00240
00247 template<typename POINTER_TYPE>
00248 class SerializableRawPointerHelper
00249 {
00250 public:
00251     typedef typename boost::remove_pointer<POINTER_TYPE>::type ObjectType;
00252
00262     static StatusCode Serialize(MessageBuilder &messageBuilder, const POINTER_TYPE &pObject)
00263     {
00264         return SerializeObject(messageBuilder, *pObject);
00265     }
00266
00276     static StatusCode Deserialize(MessageValidator &messageValidator, POINTER_TYPE &pObject)
00277     {
00278         // new object into raw pointer
00279         pObject = new (std::nothrow) ObjectType;
00280
00281         if (0 == pObject)
00282             return STATUS_CODE_HEAP_EMPTY;
00283
00284         return DeserializeObject(messageValidator, *pObject);
00285     }
00286 };
00287
00288 // ---------------------------------------------------------------------------------------------------------------------------------
00289 // ---------------------------------------------------------------------------------------------------------------------------------
00290
00297 template<typename CONTAINER_TYPE, typename COUNT_TYPE, COUNT_TYPE MIN_LENGTH, COUNT_TYPE MAX_LENGTH, typename OBJECT_HELPER>
00298 StatusCode SerializeContainer(MessageBuilder &messageBuilder, const CONTAINER_TYPE &container)
00299 {
00300     typedef COUNT_TYPE Count;
00301     typedef CONTAINER_TYPE Container;
00302     typedef OBJECT_HELPER ObjectHelper;
00303
00304     const size_t size = container.size();
00305
00306     if ((size < MIN_LENGTH) || (size > MAX_LENGTH))
00307         return STATUS_CODE_INVALID_LENGTH;
00308
00309     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, messageBuilder.Append(static_cast<Count>(size), MessageBuilder::ENDIAN_LITTLE));
00310
00311     for (typename Container::const_iterator iter = container.begin(), iterEnd = container.end(); iter != iterEnd; ++iter)
00312     {
00313         ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, ObjectHelper::Serialize(messageBuilder, *iter));
00314     }
00315
00316     return STATUS_CODE_SUCCESS;
00317 }
00318
00319 // ---------------------------------------------------------------------------------------------------------------------------------
00320
00329 template<typename CONTAINER_TYPE, typename COUNT_TYPE, COUNT_TYPE MIN_LENGTH, COUNT_TYPE MAX_LENGTH, typename OBJECT_HELPER>
00330 StatusCode SerializeAssociativeContainer(MessageBuilder &messageBuilder, const CONTAINER_TYPE &container)
00331 {
00332     typedef COUNT_TYPE Count;
00333     typedef CONTAINER_TYPE Container;
00334     typedef OBJECT_HELPER ObjectHelper;
00335
00336     const size_t size = container.size();
00337
00338     if ((size < MIN_LENGTH) || (size > MAX_LENGTH))
00339         return STATUS_CODE_INVALID_LENGTH;
00340
00341     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, messageBuilder.Append(static_cast<Count>(size), MessageBuilder::ENDIAN_LITTLE));
00342
00343     for (typename Container::const_iterator iter = container.begin(), iterEnd = container.end(); iter != iterEnd; ++iter)
00344     {
00345         ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, SerializeObject(messageBuilder, iter->first));
00346         ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, ObjectHelper::Serialize(messageBuilder, iter->second));
00347     }
00348
00349     return STATUS_CODE_SUCCESS;
00350 }
00351
00352 // ---------------------------------------------------------------------------------------------------------------------------------
00353
00363 template<typename CONTAINER_TYPE, typename COUNT_TYPE, COUNT_TYPE MIN_LENGTH, COUNT_TYPE MAX_LENGTH, typename OBJECT_HELPER>
00364 StatusCode DeserializeAssociativeContainer(MessageValidator &messageValidator, CONTAINER_TYPE &container, const bool shouldClearContainer)
00365 {
00366     typedef COUNT_TYPE Count;
00367     typedef CONTAINER_TYPE Container;
00368     typedef OBJECT_HELPER ObjectHelper;
00369
00370     Count count;
00371
00372     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=,
00373         messageValidator.ValidateUnsignedBinaryIntegral(sizeof(count), MIN_LENGTH, MAX_LENGTH, MessageValidator::ENDIAN_LITTLE, &count));
00374
00375     if (shouldClearContainer)
00376         container.clear();
00377
00378     for (Count i = 0; i < count; ++i)
00379     {
00380         typename Container::value_type value;
00381
00382         // cheating slightly to avoid deserializing into separate key and value and resultant additional construction of value_type
00383         // (first of value_type is const. using a pair will incur copy construction if passed to insert)
00384         ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, DeserializeObject(messageValidator, const_cast<typename Container::key_type &>(value.first)));
00385         ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, ObjectHelper::Deserialize(messageValidator, value.second));
00386
00387         std::pair<typename Container::iterator, bool> res = container.insert(value);
00388
00389         // update an existing entry?
00390         if (!res.second)
00391             res.first->second = value.second;
00392     }
00393
00394     return STATUS_CODE_SUCCESS;
00395 }
00396
00397 } // namespace Activ
00398
00399 #endif // (!defined ACTIV_MISC_DETAIL_SERIALIZABLE_CONTAINER_HELPER_DETAIL_H)
Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » Misc » Detail

SerializableContainerHelperSpecializations.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_MISC_DETAIL_SERIALIZABLE_CONTAINER_HELPER_SPECIALIZATIONS_H)
00010 #define ACTIV_MISC_DETAIL_SERIALIZABLE_CONTAINER_HELPER_SPECIALIZATIONS_H
00011
00012 #include "ActivMiddleware/Misc/StlHelper.h"
00013
00014 namespace Activ
00015 {
00016
00020 template <typename OBJECT_TYPE, typename COUNT_TYPE, COUNT_TYPE MIN_LENGTH, COUNT_TYPE MAX_LENGTH, typename OBJECT_HELPER>
00021 class SerializableContainerHelper<std::vector<OBJECT_TYPE>, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER>
00022 {
00023 public:
00024     typedef std::vector<OBJECT_TYPE> Vector;
00025     typedef COUNT_TYPE Count;
00026     typedef OBJECT_HELPER ObjectHelper;
00027
00037     static StatusCode Serialize(MessageBuilder &messageBuilder, const Vector &vector)
00038     {
00039         return SerializeContainer<Vector, Count, MIN_LENGTH, MAX_LENGTH, ObjectHelper>(messageBuilder, vector);
00040     }
00041
00052     static StatusCode Deserialize(MessageValidator &messageValidator, Vector &vector, const bool shouldClearContainer)
00053     {
00054         Count count;
00055
00056         ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, messageValidator.ValidateUnsignedBinaryIntegral(sizeof(count), MIN_LENGTH,
00057             MAX_LENGTH, MessageValidator::ENDIAN_LITTLE, &count));
00058
00059         if (shouldClearContainer)
00060             EmptyVector(vector);
00061
00062         const size_t originalSize = vector.size();
00063         const size_t newSize = originalSize + count;
00064         StatusCode statusCode;
00065
00066         // expand the vector to the new size (default constructor called for new objects)
00067         vector.resize(newSize);
00068
00069         for (size_t i = originalSize; i < newSize; ++i)
00070         {
00071             // deserialize directly into the object in the vector
00072             statusCode = ObjectHelper::Deserialize(messageValidator, vector.at(i));
00073
00074             if (STATUS_CODE_SUCCESS != statusCode)
00075             {
00076                 vector.resize(originalSize);
00077                 return statusCode;
00078             }
00079         }
00080
00081         return STATUS_CODE_SUCCESS;
00082     }
00083 };
00084
00085 // ---------------------------------------------------------------------------------------------------------------------------------
00086
00090 template <typename OBJECT_TYPE, typename COUNT_TYPE, COUNT_TYPE MIN_LENGTH, COUNT_TYPE MAX_LENGTH, typename OBJECT_HELPER>
00091 class SerializableContainerHelper<std::list<OBJECT_TYPE>, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER>
00092 {
00093 public:
00094     typedef std::list<OBJECT_TYPE> List;
00095     typedef COUNT_TYPE Count;
00096     typedef OBJECT_HELPER ObjectHelper;
00097
00107     static StatusCode Serialize(MessageBuilder &messageBuilder, const List &list)
00108     {
00109         return SerializeContainer<List, Count, MIN_LENGTH, MAX_LENGTH, ObjectHelper>(messageBuilder, list);
00110     }
00111
00122     static StatusCode Deserialize(MessageValidator &messageValidator, List &list, const bool shouldClearContainer)
00123     {
00124         Count count;
00125
00126         ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, messageValidator.ValidateUnsignedBinaryIntegral(sizeof(count), MIN_LENGTH,
00127             MAX_LENGTH, MessageValidator::ENDIAN_LITTLE, &count));
00128
00129         // TODO could probably be cleverer here and deserialize into existing members if shouldClearContainer
00130         if (shouldClearContainer)
00131             list.clear();
00132
00133         const size_t originalSize = list.size();
00134         StatusCode statusCode;
00135
00136         for (size_t i = 0; i < count; ++i)
00137         {
00138             list.push_back(OBJECT_TYPE());
00139
00140             // deserialize directly into the object in the list
00141             statusCode = ObjectHelper::Deserialize(messageValidator, list.back());
00142
00143             if (STATUS_CODE_SUCCESS != statusCode)
00144             {
00145                 list.resize(originalSize);
00146                 return statusCode;
00147             }
00148         }
00149
00150         return STATUS_CODE_SUCCESS;
00151     }
00152 };
00153
00154 // ---------------------------------------------------------------------------------------------------------------------------------
00155
00159 template <typename OBJECT_TYPE, typename COUNT_TYPE, COUNT_TYPE MIN_LENGTH, COUNT_TYPE MAX_LENGTH, typename OBJECT_HELPER>
00160 class SerializableContainerHelper<std::set<OBJECT_TYPE>, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER>
00161 {
00162 public:
00163     typedef std::set<OBJECT_TYPE> Set;
00164     typedef COUNT_TYPE Count;
00165     typedef OBJECT_HELPER ObjectHelper;
00166
00176     static StatusCode Serialize(MessageBuilder &messageBuilder, const Set &set)
00177     {
00178         return SerializeContainer<Set, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER>(messageBuilder, set);
00179     }
00180
00191     static StatusCode Deserialize(MessageValidator &messageValidator, Set &set, const bool shouldClearContainer)
00192     {
00193         Count count;
00194
00195         ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, messageValidator.ValidateUnsignedBinaryIntegral(sizeof(count), MIN_LENGTH,
00196             MAX_LENGTH, MessageValidator::ENDIAN_LITTLE, &count));
00197
00198         if (shouldClearContainer)
00199             set.clear();
00200
00201         for (Count i = 0; i < count; ++i)
00202         {
00203             typename Set::value_type object;
00204
00205             ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, ObjectHelper::Deserialize(messageValidator, object));
00206
00207             (void) set.insert(object);
00208         }
00209
00210         return STATUS_CODE_SUCCESS;
00211     }
00212 };
00213
00214 // ---------------------------------------------------------------------------------------------------------------------------------
00215
00219 template <typename KEY_TYPE, typename MAPPED_TYPE, typename COUNT_TYPE, COUNT_TYPE MIN_LENGTH, COUNT_TYPE MAX_LENGTH, typename OBJECT_HELPER>
00220 class SerializableContainerHelper<std::map<KEY_TYPE, MAPPED_TYPE>, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER>
00221 {
00222 public:
00223     typedef std::map<KEY_TYPE, MAPPED_TYPE> Map;
00224     typedef COUNT_TYPE Count;
00225     typedef OBJECT_HELPER ObjectHelper;
00226
00236     static StatusCode Serialize(MessageBuilder &messageBuilder, const Map &map)
00237     {
00238         return SerializeAssociativeContainer<Map, Count, MIN_LENGTH, MAX_LENGTH, ObjectHelper>(messageBuilder, map);
00239     }
00240
00251     static StatusCode Deserialize(MessageValidator &messageValidator, Map &map, const bool shouldClearContainer)
00252     {
00253         return DeserializeAssociativeContainer<Map, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER>(messageValidator, map,
00254             shouldClearContainer);
00255     }
00256 };
00257
00258 // ---------------------------------------------------------------------------------------------------------------------------------
00259 // ---------------------------------------------------------------------------------------------------------------------------------
00260
00264 template <typename KEY_TYPE, typename MAPPED_TYPE, typename COUNT_TYPE, COUNT_TYPE MIN_LENGTH, COUNT_TYPE MAX_LENGTH>
00265 class SerializableObjectContainerHelper<std::map<KEY_TYPE, MAPPED_TYPE>, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH> : public SerializableContainerHelper<std::map<KEY_TYPE, MAPPED_TYPE>, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, SerializableObjectHelper<MAPPED_TYPE> >
00266 {
00267 };
00268
00269 // ---------------------------------------------------------------------------------------------------------------------------------
00270 // ---------------------------------------------------------------------------------------------------------------------------------
00271
00277 template <typename KEY_TYPE, typename MAPPED_TYPE, typename COUNT_TYPE, COUNT_TYPE MIN_LENGTH, COUNT_TYPE MAX_LENGTH>
00278 class SerializableRawPointerContainerHelper<std::map<KEY_TYPE, MAPPED_TYPE>, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH> : public SerializableContainerHelper<std::map<KEY_TYPE, MAPPED_TYPE>, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, SerializableRawPointerHelper<MAPPED_TYPE> >
00279 {
00280 };
00281
00282 // ---------------------------------------------------------------------------------------------------------------------------------
00283 // ---------------------------------------------------------------------------------------------------------------------------------
00284
00290 template <typename KEY_TYPE, typename MAPPED_TYPE, typename COUNT_TYPE, COUNT_TYPE MIN_LENGTH, COUNT_TYPE MAX_LENGTH>
00291 class SerializableSmartPointerContainerHelper<std::map<KEY_TYPE, MAPPED_TYPE>, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH> : public SerializableContainerHelper<std::map<KEY_TYPE, MAPPED_TYPE>, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, SerializableSmartPointerHelper<MAPPED_TYPE> >
00292 {
00293 };
00294
00295 // ---------------------------------------------------------------------------------------------------------------------------------
00296
00300 template <typename KEY_TYPE, typename MAPPED_TYPE, typename HASH_FN, typename COUNT_TYPE, COUNT_TYPE MIN_LENGTH, COUNT_TYPE MAX_LENGTH, typename OBJECT_HELPER>
00301 class SerializableContainerHelper<hash_map<KEY_TYPE, MAPPED_TYPE, HASH_FN>, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER>
00302 {
00303 public:
00304     typedef hash_map<KEY_TYPE, MAPPED_TYPE, HASH_FN> Map;
00305     typedef COUNT_TYPE Count;
00306     typedef OBJECT_HELPER ObjectHelper;
00307
00317     static StatusCode Serialize(MessageBuilder &messageBuilder, const Map &map)
00318     {
00319         return SerializeAssociativeContainer<Map, Count, MIN_LENGTH, MAX_LENGTH, ObjectHelper>(messageBuilder, map);
00320     }
00321
00332     static StatusCode Deserialize(MessageValidator &messageValidator, Map &map, const bool shouldClearContainer)
00333     {
00334         return DeserializeAssociativeContainer<Map, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER>(messageValidator, map,
00335             shouldClearContainer);
00336     }
00337 };
00338
00339 // ---------------------------------------------------------------------------------------------------------------------------------
00340 // ---------------------------------------------------------------------------------------------------------------------------------
00341
00345 template <typename KEY_TYPE, typename MAPPED_TYPE, typename HASH_FN, typename COUNT_TYPE, COUNT_TYPE MIN_LENGTH, COUNT_TYPE MAX_LENGTH>
00346 class SerializableObjectContainerHelper<hash_map<KEY_TYPE, MAPPED_TYPE, HASH_FN>, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH> : public SerializableContainerHelper<hash_map<KEY_TYPE, MAPPED_TYPE, HASH_FN>, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, SerializableObjectHelper<MAPPED_TYPE> >
00347 {
00348 };
00349
00350 // ---------------------------------------------------------------------------------------------------------------------------------
00351 // ---------------------------------------------------------------------------------------------------------------------------------
00352
00358 template <typename KEY_TYPE, typename MAPPED_TYPE, typename COUNT_TYPE, typename HASH_FN, COUNT_TYPE MIN_LENGTH, COUNT_TYPE MAX_LENGTH>
00359 class SerializableRawPointerContainerHelper<hash_map<KEY_TYPE, MAPPED_TYPE, HASH_FN>, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH> : public SerializableContainerHelper<hash_map<KEY_TYPE, MAPPED_TYPE, HASH_FN>, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, SerializableRawPointerHelper<MAPPED_TYPE> >
00360 {
00361 };
00362
00363 // ---------------------------------------------------------------------------------------------------------------------------------
00364 // ---------------------------------------------------------------------------------------------------------------------------------
00365
00371 template <typename KEY_TYPE, typename MAPPED_TYPE, typename COUNT_TYPE, typename HASH_FN, COUNT_TYPE MIN_LENGTH, COUNT_TYPE MAX_LENGTH>
00372 class SerializableSmartPointerContainerHelper<hash_map<KEY_TYPE, MAPPED_TYPE, HASH_FN>, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH> : public SerializableContainerHelper<hash_map<KEY_TYPE, MAPPED_TYPE, HASH_FN>, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, SerializableSmartPointerHelper<MAPPED_TYPE> >
00373 {
00374 };
00375
00376 } // namespace Activ
00377
00378 #endif // (!defined ACTIV_MISC_DETAIL_SERIALIZABLE_CONTAINER_HELPER_SPECIALIZATIONS_H)
Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivFramework

Service.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FRAMEWORK_SERVICE_H)
00010 #define ACTIV_FRAMEWORK_SERVICE_H
00011
00012 #include "ActivMiddleware/ActivFramework/External.h"
00013 #include "ActivMiddleware/ActivFramework/Component.h"
00014 #include "ActivMiddleware/ActivFramework/Messages.h"
00015 #include "ActivMiddleware/ActivBase/Uuid.h"
00016
00017 #include <list>
00018
00019 namespace Activ
00020 {
00021
00025 class Service : public Component
00026 {
00027 public:
00031     ACTIV_FRAMEWORK_API static const ServiceAccessPointList emptyServiceAccessPointList;
00032
00048     ACTIV_FRAMEWORK_API Service(Application &application, ManagedEndPoint &managedEndPoint, const std::string &name,
00049         const ServiceInstance &serviceInstance, IHeap * const pHeap = 0, const std::string &componentId = defaultComponentId);
00050
00054     ACTIV_FRAMEWORK_API ~Service();
00055
00061     ACTIV_FRAMEWORK_API const ServiceInstance &GetServiceInstance() const;
00062
00069     ACTIV_FRAMEWORK_API virtual StatusCode Register();
00070
00077     ACTIV_FRAMEWORK_API virtual StatusCode Deregister();
00078
00082     ACTIV_FRAMEWORK_API void Close();
00083
00084 protected:
00094     ACTIV_FRAMEWORK_API virtual StatusCode OnAccept(HeapMessage &acceptMessage);
00095
00107     ACTIV_FRAMEWORK_API virtual StatusCode ProcessOpenServiceRequest(HeapMessage &acceptMessage);
00108
00120     ACTIV_FRAMEWORK_API StatusCode ValidateOpenServiceRequest(const HeapMessage &acceptMessage,
00121         OpenServiceRequest &openServiceRequest) const;
00122
00133     ACTIV_FRAMEWORK_API StatusCode BuildOpenServiceResponse(HeapMessage &acceptMessage, OpenServiceResponse &openServiceResponse,
00134         const byte_t openServiceVersion) const;
00135
00136 private:
00140     class AccessList
00141     {
00142     public:
00148         AccessList(Service &service);
00149
00153         ~AccessList();
00154
00160         void Add(const Address &serverAddress);
00161
00165         void Clear();
00166
00167     private:
00168         typedef std::list<Address> ServerList;
00169
00170         Service     &m_service;
00171         ServerList  m_serverList;
00172     };
00173
00181     ServiceInstance MakeServiceInstance(const ServiceInstance &serviceInstance);
00182
00183     AccessList              m_accessList;
00184
00185     const ServiceInstance   m_serviceInstance;
00186     const Uuid              m_uuid;
00187 };
00188
00189 } // namespace Activ
00190
00191 #endif // (!defined ACTIV_FRAMEWORK_SERVICE_H)
Generated on Wed Oct 8 14:01:48 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivFramework

ServiceApi.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FRAMEWORK_SERVICE_API_H)
00010 #define ACTIV_FRAMEWORK_SERVICE_API_H
00011
00012 #include "ActivMiddleware/ActivFramework/External.h"
00013 #include "ActivMiddleware/ActivFramework/Messages.h"
00014
00015 namespace Activ
00016 {
00017
00018 class Component;
00019
00020 // ---------------------------------------------------------------------------------------------------------------------------------
00021
00025 class ServiceApi
00026 {
00027 public:
00042     ACTIV_FRAMEWORK_API static StatusCode FindServices(const Component &component, const ServiceId &serviceId, const AgentScope agentScope,
00043                                                        const std::string &attributeQuery, ServiceInstanceList &serviceInstanceList,
00044                                                        const TimeoutPeriod timeout = Port::defaultTimeout);
00045
00068     ACTIV_FRAMEWORK_API static StatusCode OpenService(Component &component, ServiceHandle &serviceHandle,
00069                                                       const TimeoutPeriod timeout = Port::defaultTimeout,
00070                                                       OpenServiceRequest * const pOpenServiceRequest = 0,
00071                                                       OpenServiceResponse * const pOpenServiceResponse = 0);
00072
00086     ACTIV_FRAMEWORK_API static StatusCode CloseService(Component &component, ServiceHandle &serviceHandle);
00087
00097     ACTIV_FRAMEWORK_API static StatusCode ValidateOpenServiceResponse(const HeapMessage &connectMessage, OpenServiceResponse &openServiceResponse);
00098
00099 private:
00110     static StatusCode OpenServiceAsync(Component &component, ServiceHandle &serviceHandle, const OpenServiceRequest * const pOpenServiceRequest);
00111
00123     static StatusCode OpenServiceSync(Component &component, ServiceHandle &serviceHandle, const TimeoutPeriod timeout, const OpenServiceRequest * const pOpenServiceRequest, OpenServiceResponse * const pOpenServiceResponse);
00124
00134     static StatusCode InternalOpenService(Component &component, ServiceHandle &serviceHandle);
00135 };
00136
00137 } // namespace Activ
00138
00139 #endif // (!defined ACTIV_FRAMEWORK_SERVICE_API_H)
Generated on Wed Oct 8 14:01:48 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivFramework

ServiceTypes.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FRAMEWORK_SERVICE_TYPES_H)
00010 #define ACTIV_FRAMEWORK_SERVICE_TYPES_H
00011
00012 #include "ActivMiddleware/ActivFramework/External.h"
00013 #include "ActivMiddleware/ActivBase/Uuid.h"
00014 #include "ActivMiddleware/Misc/SerializableContainerHelper.h"
00015
00016 namespace Activ
00017 {
00018
00022 ACTIV_DECLARE_MESSAGE_TYPE(0,   MESSAGE_CLASS_SERVICE,  SERVICE_MESSAGE_REGISTER);
00023 ACTIV_DECLARE_MESSAGE_TYPE(1,   MESSAGE_CLASS_SERVICE,  SERVICE_MESSAGE_DEREGISTER);
00024
00025 // ---------------------------------------------------------------------------------------------------------------------------------
00026
00030 class ServiceAccessPoint
00031 {
00032 public:
00036     ACTIV_FRAMEWORK_API ServiceAccessPoint();
00037
00044     ACTIV_FRAMEWORK_API ServiceAccessPoint(const std::string &url, const AgentScope agentScope);
00045
00061     ACTIV_FRAMEWORK_API StatusCode Read(const IniFileParser::ConstKeyIterator &keyIterator);
00062
00066     ACTIV_FRAMEWORK_API void Clear();
00067
00073     ACTIV_FRAMEWORK_API std::string ToString() const;
00074
00075     std::string m_url;
00076     AgentScope  m_agentScope;
00077 };
00078
00079 // ---------------------------------------------------------------------------------------------------------------------------------
00080
00084 typedef std::vector<ServiceAccessPoint> ServiceAccessPointList;
00085
00098 ACTIV_FRAMEWORK_API StatusCode ReadServiceAccessPointList(const IniFileParser::ConstSectionIterator &sectionIterator, ServiceAccessPointList &serviceAccessPointList);
00099
00100 // ---------------------------------------------------------------------------------------------------------------------------------
00101 // ---------------------------------------------------------------------------------------------------------------------------------
00102
00108 class ServiceId
00109 {
00110 public:
00111     class Serializer;
00112
00116     ACTIV_FRAMEWORK_API ServiceId();
00117
00123     ACTIV_FRAMEWORK_API ServiceId(const char * const id);
00124
00130     ACTIV_FRAMEWORK_API ServiceId(const std::string &id);
00131
00137     ACTIV_FRAMEWORK_API void Set(const std::string &id);
00138
00142     ACTIV_FRAMEWORK_API std::string ToString() const;
00143
00147     ACTIV_FRAMEWORK_API void Clear();
00148
00152     ACTIV_FRAMEWORK_API bool operator==(const ServiceId &rhs) const;
00153
00157     ACTIV_FRAMEWORK_API bool operator!=(const ServiceId &rhs) const;
00158
00162     ACTIV_FRAMEWORK_API bool operator<(const ServiceId &rhs) const;
00163
00164 private:
00165     std::string m_id;
00166 };
00167
00168 // ---------------------------------------------------------------------------------------------------------------------------------
00169 // ---------------------------------------------------------------------------------------------------------------------------------
00170
00174 class ServiceInstance
00175 {
00176 public:
00180     ACTIV_FRAMEWORK_API ServiceInstance();
00181
00189     ACTIV_FRAMEWORK_API ServiceInstance(const ServiceId &serviceId, const ServiceAccessPointList &serviceAccessPointList, const std::string &attributes);
00190
00194     ACTIV_FRAMEWORK_API void Clear();
00195
00196     ServiceId               m_serviceId;
00197     ServiceAccessPointList  m_serviceAccessPointList;
00198     std::string             m_attributes;
00199 };
00200
00201 // ---------------------------------------------------------------------------------------------------------------------------------
00202
00206 typedef std::vector<ServiceInstance> ServiceInstanceList;
00207
00208 // ---------------------------------------------------------------------------------------------------------------------------------
00209 // ---------------------------------------------------------------------------------------------------------------------------------
00210
00214 class ServiceHandle
00215 {
00216 public:
00220     ACTIV_FRAMEWORK_API ServiceHandle();
00221
00228     ACTIV_FRAMEWORK_API ServiceHandle(const ServiceId &serviceId, const std::string &url);
00229
00233     ACTIV_FRAMEWORK_API void Clear();
00234
00235     ServiceId   m_serviceId;
00236     std::string m_url;
00237     Address     m_serviceAddress;
00238 };
00239
00240 // ---------------------------------------------------------------------------------------------------------------------------------
00241 // ---------------------------------------------------------------------------------------------------------------------------------
00242
00247 class ServiceSubject : public Subject
00248 {
00249 public:
00253     ACTIV_FRAMEWORK_API ServiceSubject();
00254 };
00255
00256 } // namespace Activ
00257
00258 #endif // (!defined ACTIV_FRAMEWORK_SERVICE_TYPES_H)
Generated on Wed Oct 8 14:01:48 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase » Windows

SharedCompletionPortEventFactory.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_BASE_SHARED_COMPLETION_PORT_EVENT_FACTORY_H)
00010 #define ACTIV_BASE_SHARED_COMPLETION_PORT_EVENT_FACTORY_H
00011
00012 #include "ActivMiddleware/ActivBase/External.h"
00013 #include "ActivMiddleware/ActivBase/IEvent.h"
00014 #include "ActivMiddleware/ActivBase/Timeout.h"
00015 #include "ActivMiddleware/Misc/Singleton.h"
00016
00017 namespace Activ
00018 {
00019
00023 class SharedCompletionPortEventFactory : public Singleton<SharedCompletionPortEventFactory>
00024 {
00025 public:
00038     ACTIV_BASE_EXPORTED_API IEvent *Create(const std::string &name, const IEvent::Flags flags = IEvent::FLAG_NONE,
00039         const bool initialState = false, const HANDLE completionPortHandle = NULL);
00040
00051     ACTIV_BASE_EXPORTED_API IEvent *Open(const std::string &name, Timeout &timeout = Timeout::GetInfinite());
00052
00053 private:
00057     ACTIV_BASE_EXPORTED_API SharedCompletionPortEventFactory();
00058
00059     friend class Singleton<SharedCompletionPortEventFactory>;
00060 };
00061
00062 } // namespace Activ
00063
00064 #endif // (!defined ACTIV_BASE_SHARED_COMPLETION_PORT_EVENT_FACTORY_H)
Generated on Wed Oct 8 14:01:47 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

SharedEventFactory.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_BASE_SHARED_EVENT_FACTORY_H)
00010 #define ACTIV_BASE_SHARED_EVENT_FACTORY_H
00011
00012 #include "ActivMiddleware/ActivBase/External.h"
00013 #include "ActivMiddleware/ActivBase/IEvent.h"
00014 #include "ActivMiddleware/ActivBase/Timeout.h"
00015 #include "ActivMiddleware/Misc/Singleton.h"
00016
00017 #include <string>
00018
00019 namespace Activ
00020 {
00021
00025 class SharedEventFactory : public Singleton<SharedEventFactory>
00026 {
00027 public:
00039     ACTIV_BASE_EXPORTED_API IEvent *Create(const std::string &name, const IEvent::Flags flags = IEvent::FLAG_NONE,
00040         const bool initialState = false);
00041
00052     ACTIV_BASE_EXPORTED_API IEvent *Open(const std::string &name, Timeout &timeout = Timeout::GetInfinite());
00053
00059     ACTIV_BASE_EXPORTED_API static SharedEventFactory &GetInstance();
00060
00061 private:
00065     ACTIV_BASE_EXPORTED_API SharedEventFactory();
00066
00067     friend class Singleton<SharedEventFactory>;
00068 };
00069
00070 } // namespace Activ
00071
00072 #endif // (!defined ACTIV_BASE_SHARED_EVENT_FACTORY_H)
Generated on Wed Oct 8 14:01:47 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

SharedMutexFactory.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_BASE_SHARED_MUTEX_FACTORY_H)
00010 #define ACTIV_BASE_SHARED_MUTEX_FACTORY_H
00011
00012 #include "ActivMiddleware/ActivBase/External.h"
00013 #include "ActivMiddleware/ActivBase/IMutex.h"
00014 #include "ActivMiddleware/ActivBase/Timeout.h"
00015 #include "ActivMiddleware/Misc/Singleton.h"
00016
00017 #include <string>
00018
00019 namespace Activ
00020 {
00021
00032 class SharedMutexFactory : public Singleton<SharedMutexFactory>
00033 {
00034 public:
00045     ACTIV_BASE_EXPORTED_API IMutex *Create(const std::string &name, const bool isInitialOwner = false);
00046
00057     ACTIV_BASE_EXPORTED_API IMutex *Open(const std::string &name, Timeout &timeout = Timeout::GetInfinite());
00058
00064     ACTIV_BASE_EXPORTED_API static SharedMutexFactory &GetInstance();
00065
00066 private:
00070     ACTIV_BASE_EXPORTED_API SharedMutexFactory();
00071
00075     ACTIV_BASE_EXPORTED_API ~SharedMutexFactory();
00076
00087     template<typename T, bool COUNT_CONTENTION>
00088     IMutex *InternalCreate(const std::string &name, const bool isInitialOwner);
00089
00100     template<typename T, bool COUNT_CONTENTION>
00101     IMutex *InternalOpen(const std::string &name, Timeout &timeout);
00102
00103     const bool  m_isRecursive;
00104     const bool  m_shouldCountContention;
00105
00106     friend class Singleton<SharedMutexFactory>;
00107 };
00108
00109 } // namespace Activ
00110
00111 #endif // (!defined ACTIV_BASE_SHARED_MUTEX_FACTORY_H)
Generated on Wed Oct 8 14:01:47 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

SharedObject.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_BASE_SHARED_OBJECT_H)
00010 #define ACTIV_BASE_SHARED_OBJECT_H
00011
00012 #include "ActivMiddleware/ActivBase/PagingFileMappedMemoryFactory.h"
00013
00014 #include <string>
00015
00016 namespace Activ
00017 {
00018
00022 template <class T>
00023 class SharedObject : private boost::noncopyable
00024 {
00025 public:
00029     SharedObject();
00030
00034     ~SharedObject();
00035
00039     bool IsOpen() const;
00040
00051     void Create(const std::string &name, const IMappedMemory::MappingFlags mappingFlags = IMappedMemory::MAPPING_FLAG_UNIQUE,
00052         const size_t size = sizeof(T));
00053
00064     void Open(const std::string &name, const IMappedMemory::MappingFlags mappingFlags = IMappedMemory::MAPPING_FLAG_NONE,
00065         Timeout &timeout = Timeout::GetInfinite());
00066
00072     T *GetPointer() const;
00073
00079     size_t GetSize() const;
00080
00081 private:
00082     T               *m_pData;
00083     IMappedMemory   *m_pMem;
00084 };
00085
00086 // ---------------------------------------------------------------------------------------------------------------------------------
00087 // ---------------------------------------------------------------------------------------------------------------------------------
00088
00089 template<class T>
00090 inline SharedObject<T>::SharedObject() :
00091     m_pData(0),
00092     m_pMem(0)
00093 {
00094 }
00095
00096 // ---------------------------------------------------------------------------------------------------------------------------------
00097
00098 template<class T>
00099 inline SharedObject<T>::~SharedObject()
00100 {
00101     if (0 != m_pMem)
00102         delete m_pMem;
00103 }
00104
00105 // ---------------------------------------------------------------------------------------------------------------------------------
00106
00107 template<class T>
00108 inline bool SharedObject<T>::IsOpen() const
00109 {
00110     return m_pData != 0;
00111 }
00112
00113 // ---------------------------------------------------------------------------------------------------------------------------------
00114
00115 template<class T>
00116 void SharedObject<T>::Create(const std::string &name, const IMappedMemory::MappingFlags mappingFlags, const size_t size)
00117 {
00118     m_pMem = PagingFileMappedMemoryFactory::GetInstance().Create(name, size, mappingFlags);
00119     m_pData = reinterpret_cast<T *>(m_pMem->GetPointer());
00120 }
00121
00122 // ---------------------------------------------------------------------------------------------------------------------------------
00123
00124 template<class T>
00125 void SharedObject<T>::Open(const std::string &name, const IMappedMemory::MappingFlags mappingFlags, Timeout &timeout)
00126 {
00127     m_pMem = PagingFileMappedMemoryFactory::GetInstance().Open(name, mappingFlags, timeout);
00128     m_pData = reinterpret_cast<T *>(m_pMem->GetPointer());
00129 }
00130
00131 // ---------------------------------------------------------------------------------------------------------------------------------
00132
00133 template<class T>
00134 inline T *SharedObject<T>::GetPointer() const
00135 {
00136     return m_pData;
00137 }
00138
00139 // ---------------------------------------------------------------------------------------------------------------------------------
00140
00141 template<class T>
00142 size_t SharedObject<T>::GetSize() const
00143 {
00144     return (0 != m_pMem) ? m_pMem->GetSize() : 0;
00145 }
00146
00147 } // namespace Activ
00148
00149 #endif // (!defined ACTIV_BASE_SHARED_OBJECT_H)
Generated on Wed Oct 8 14:01:47 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

SharedSemaphoreFactory.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_BASE_SHARED_SEMAPHORE_FACTORY_H)
00010 #define ACTIV_BASE_SHARED_SEMAPHORE_FACTORY_H
00011
00012 #include "ActivMiddleware/ActivBase/External.h"
00013 #include "ActivMiddleware/ActivBase/ISemaphore.h"
00014 #include "ActivMiddleware/ActivBase/Timeout.h"
00015 #include "ActivMiddleware/Misc/Singleton.h"
00016
00017 #include <string>
00018
00019 namespace Activ
00020 {
00021
00025 class SharedSemaphoreFactory : public Singleton<SharedSemaphoreFactory>
00026 {
00027 public:
00037     ACTIV_BASE_EXPORTED_API ISemaphore *Create(const std::string &name);
00038
00049     ACTIV_BASE_EXPORTED_API ISemaphore *Open(const std::string &name, Timeout &timeout = Timeout::GetInfinite());
00050
00056     ACTIV_BASE_EXPORTED_API static SharedSemaphoreFactory &GetInstance();
00057
00058 private:
00062     ACTIV_BASE_EXPORTED_API SharedSemaphoreFactory();
00063
00064     friend class Singleton<SharedSemaphoreFactory>;
00065 };
00066
00067 } // namespace Activ
00068
00069 #endif // (!defined ACTIV_BASE_SHARED_SEMAPHORE_FACTORY_H)
Generated on Wed Oct 8 14:01:47 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

Shell.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_BASE_SHELL_H)
00010 #define ACTIV_BASE_SHELL_H
00011
00012 #include "ActivMiddleware/ActivBase/External.h"
00013
00014 #include <string>
00015
00016 namespace Activ
00017 {
00018
00022 class Shell : private boost::noncopyable
00023 {
00024 public:
00028     ACTIV_BASE_EXPORTED_API Shell();
00029
00035     ACTIV_BASE_EXPORTED_API virtual ~Shell();
00036
00042     ACTIV_BASE_EXPORTED_API StatusCode Initialize();
00043
00053     ACTIV_BASE_EXPORTED_API void Run();
00054
00055 protected:
00064     virtual StatusCode OnOutputString(const std::string &outputString) = 0;
00065
00077     virtual StatusCode OnInputString(std::string &inputString) = 0;
00078
00079 private:
00080 #if (defined ACTIV_PLATFORM_WINDOWS)
00081
00082     PROCESS_INFORMATION m_processInfo;
00083
00084 #elif (defined ACTIV_PLATFORM_POSIX)
00085
00086     pid_t               m_shellPid;
00087
00088 #endif
00089
00090     HANDLE              m_shellOutputParentHandle;
00091     HANDLE              m_shellOutputChildHandle;
00092
00093     HANDLE              m_shellInputParentHandle;
00094     HANDLE              m_shellInputChildHandle;
00095 };
00096
00097 } // namespace Activ
00098
00099 #endif // (!defined ACTIV_BASE_SHELL_H)
Generated on Wed Oct 8 14:01:47 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » Misc

Singleton.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_MISC_SINGLETON_H)
00010 #define ACTIV_MISC_SINGLETON_H
00011
00012 #include "ActivMiddleware/Activ.h"
00013
00014 namespace Activ
00015 {
00016
00055 template<typename T>
00056 class Singleton : private boost::noncopyable
00057 {
00058 protected:
00062     Singleton();
00063
00064 private:
00065     class Initializer
00066     {
00067     public:
00068         Initializer();
00069         void Dummy();
00070     };
00071
00072     static Initializer  m_initializer;
00073 };
00074
00075 // ---------------------------------------------------------------------------------------------------------------------------------
00076
00077 template<typename T>
00078 typename Singleton<T>::Initializer Singleton<T>::m_initializer;
00079
00080 // ---------------------------------------------------------------------------------------------------------------------------------
00081
00082 template<typename T>
00083 inline Singleton<T>::Singleton()
00084 {
00085     // ensure the static creator object is instantiated by referencing it
00086     m_initializer.Dummy();
00087 }
00088
00089 // ---------------------------------------------------------------------------------------------------------------------------------
00090 // ---------------------------------------------------------------------------------------------------------------------------------
00091
00092 template<typename T>
00093 Singleton<T>::Initializer::Initializer()
00094 {
00095     (void) T::GetInstance();
00096 }
00097
00098 // ---------------------------------------------------------------------------------------------------------------------------------
00099
00100 template<typename T>
00101 void Singleton<T>::Initializer::Dummy()
00102 {
00103     // do nothing
00104 }
00105
00106 } // namespace Activ
00107
00108 #endif // (!defined ACTIV_MISC_SINGLETON_H)
Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » Misc

SmtpHelper.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_MISC_SMTP_HELPER_H)
00010 #define ACTIV_MISC_SMTP_HELPER_H
00011
00012 #include "ActivMiddleware/ActivBase/ActivBase.h"
00013 #include "ActivMiddleware/ActivBase/StatusCodeException.h"
00014 #include "ActivMiddleware/ActivBase/Thread.h"
00015
00016 #include "ActivMiddleware/ActivIp/IpManager.h"
00017
00018 #include "boost/tokenizer.hpp"
00019
00020 #include <string>
00021
00022 namespace Activ
00023 {
00024
00028 class SmtpHelper : private boost::noncopyable
00029 {
00030 public:
00034     class Email
00035     {
00036     public:
00047         Email(const std::string &fromAddress, const std::string &toAddressList, const std::string &ccAddressList,
00048               const std::string &bccAddressList, const std::string &subject, const std::string &text);
00049
00050         const std::string   m_fromAddress;
00051         const std::string   m_toAddressList;
00052         const std::string   m_ccAddressList;
00053         const std::string   m_bccAddressList;
00054         const std::string   m_subject;
00055         const std::string   m_text;
00056     };
00057
00063     SmtpHelper();
00064
00073     SmtpHelper(const std::string &server, const std::string &hostname = GetHostname());
00074
00078     ~SmtpHelper();
00079
00089     StatusCode Connect(const std::string &server, const std::string &hostname = GetHostname());
00090
00097     StatusCode Disconnect();
00098
00112     StatusCode PostMessage(const std::string &fromAddress, const std::string &toAddressList, const std::string &ccAddressList, const std::string &bccAddressList, const std::string &subject, const std::string &text);
00113
00119     bool IsConnected() const;
00120
00126     static std::string GetHostname();
00127
00140     static void PostEmail(const Email &email, const std::string &server, const std::string &hostname = GetHostname());
00141
00142 private:
00148     class PostEmailThread : public Thread
00149     {
00150     public:
00158         PostEmailThread(const Email &email, const std::string &server, const std::string &hostname = GetHostname());
00159
00160     private:
00161         // Thread interface
00162         virtual StatusCode Process(void *pData);
00163
00164         Email       m_email;
00165         std::string m_server;
00166         std::string m_hostname;
00167     };
00168
00169     static const uint16_t PORT_NUMBER = 25; // The port number.
00170     static const uint32_t READ_TIMEOUT = 5; // The read timeout.
00171
00180     StatusCode ConfirmReplyCode(const std::string &replyCode);
00181
00190     StatusCode ConnectSocket(const std::string &server);
00191
00198     StatusCode DisconnectSocket();
00199
00211     StatusCode ReadSocket(void * const pData, const size_t size, size_t &length);
00212
00222     StatusCode WriteSocket(const void * const pData, const size_t length);
00223
00224     SOCKET  m_socket;
00225 };
00226
00227 // ---------------------------------------------------------------------------------------------------------------------------------
00228
00229 inline SmtpHelper::SmtpHelper() :
00230     m_socket(INVALID_SOCKET)
00231 {
00232 }
00233
00234 // ---------------------------------------------------------------------------------------------------------------------------------
00235
00236 inline SmtpHelper::SmtpHelper(const std::string &server, const std::string &hostname) :
00237     m_socket(INVALID_SOCKET)
00238 {
00239     ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, Connect(server, hostname));
00240 }
00241
00242 // ---------------------------------------------------------------------------------------------------------------------------------
00243
00244 inline SmtpHelper::~SmtpHelper()
00245 {
00246     if (IsConnected())
00247         (void) Disconnect();
00248 }
00249
00250 // ---------------------------------------------------------------------------------------------------------------------------------
00251
00252 inline StatusCode SmtpHelper::Connect(const std::string &server, const std::string &hostname)
00253 {
00254     if (IsConnected())
00255         return STATUS_CODE_ALREADY_CONNECTED;
00256
00257     try
00258     {
00259         ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, ConnectSocket(server));
00260
00261         ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, ConfirmReplyCode("220"));
00262
00263         const std::string heloCommand("HELO " + hostname + "\r\n");
00264         ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, WriteSocket(heloCommand.c_str(), heloCommand.length()));
00265
00266         ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, ConfirmReplyCode("250"));
00267     }
00268     catch (StatusCodeException &statusCodeException)
00269     {
00270         (void) DisconnectSocket();
00271
00272         return static_cast<const StatusCode>(statusCodeException.m_errorCode);
00273     }
00274     catch (...)
00275     {
00276         (void) DisconnectSocket();
00277
00278         return STATUS_CODE_FAILURE;
00279     }
00280
00281     return STATUS_CODE_SUCCESS;
00282 }
00283
00284 // ---------------------------------------------------------------------------------------------------------------------------------
00285
00286 inline StatusCode SmtpHelper::Disconnect()
00287 {
00288     if (!IsConnected())
00289         return STATUS_CODE_NOT_CONNECTED;
00290
00291     try
00292     {
00293         const std::string quitCommand("QUIT\r\n");
00294         ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, WriteSocket(quitCommand.c_str(), quitCommand.length()));
00295
00296         ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, ConfirmReplyCode("221"));
00297
00298         ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, DisconnectSocket());
00299     }
00300     catch (StatusCodeException &statusCodeException)
00301     {
00302         (void) DisconnectSocket();
00303
00304         return static_cast<const StatusCode>(statusCodeException.m_errorCode);
00305     }
00306     catch (...)
00307     {
00308         (void) DisconnectSocket();
00309
00310         return STATUS_CODE_FAILURE;
00311     }
00312
00313     return STATUS_CODE_SUCCESS;
00314 }
00315
00316 // ---------------------------------------------------------------------------------------------------------------------------------
00317
00318 inline StatusCode SmtpHelper::PostMessage(const std::string &fromAddress, const std::string &toAddressList, const std::string &ccAddressList, const std::string &bccAddressList, const std::string &subject, const std::string &text)
00319 {
00320     if (!IsConnected())
00321         return STATUS_CODE_NOT_CONNECTED;
00322
00323     try
00324     {
00325         const std::string mailFromCommand("MAIL FROM: " + fromAddress + "\r\n");
00326         ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, WriteSocket(mailFromCommand.c_str(), mailFromCommand.length()));
00327
00328         ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, ConfirmReplyCode("250"));
00329
00330         typedef boost::char_separator<char> CharSeparator;
00331         const CharSeparator semiColonSeparator(";");
00332
00333         boost::tokenizer<CharSeparator> tokenizer(toAddressList, semiColonSeparator);
00334
00335         for (boost::tokenizer< boost::char_separator<char> >::const_iterator iterator = tokenizer.begin(), iteratorEnd = tokenizer.end(); iteratorEnd != iterator; ++iterator)
00336         {
00337             const std::string rcptToCommand("RCPT TO: " + *iterator + "\r\n");
00338             ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, WriteSocket(rcptToCommand.c_str(), rcptToCommand.length()));
00339
00340             ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, ConfirmReplyCode("250"));
00341         }
00342
00343         tokenizer.assign(ccAddressList, semiColonSeparator);
00344
00345         for (boost::tokenizer< boost::char_separator<char> >::const_iterator iterator = tokenizer.begin(), iteratorEnd = tokenizer.end(); iteratorEnd != iterator; ++iterator)
00346         {
00347             const std::string rcptToCommand("RCPT TO: " + *iterator + "\r\n");
00348             ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, WriteSocket(rcptToCommand.c_str(), rcptToCommand.length()));
00349
00350             ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, ConfirmReplyCode("250"));
00351         }
00352
00353         tokenizer.assign(bccAddressList, semiColonSeparator);
00354
00355         for (boost::tokenizer< boost::char_separator<char> >::const_iterator iterator = tokenizer.begin(), iteratorEnd = tokenizer.end(); iteratorEnd != iterator; ++iterator)
00356         {
00357             const std::string rcptToCommand("RCPT TO: " + *iterator + "\r\n");
00358             ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, WriteSocket(rcptToCommand.c_str(), rcptToCommand.length()));
00359
00360             ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, ConfirmReplyCode("250"));
00361         }
00362
00363         const std::string dataCommand("DATA\r\n");
00364         ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, WriteSocket(dataCommand.c_str(), dataCommand.length()));
00365
00366         ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, ConfirmReplyCode("354"));
00367
00368         std::string dataHeader;
00369
00370         dataHeader += std::string("From: " + fromAddress + "\r\n");
00371         dataHeader += std::string("To: " + toAddressList + "\r\n");
00372         dataHeader += std::string("Cc: " + ccAddressList + "\r\n");
00373         dataHeader += std::string("Subject: " + subject + "\r\n");
00374         dataHeader += std::string("\r\n");
00375
00376         ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, WriteSocket(dataHeader.c_str(), dataHeader.length()));
00377         ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, WriteSocket(text.c_str(), text.length()));
00378
00379         const std::string endOfDataCommand("\r\n.\r\n");
00380         ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, WriteSocket(endOfDataCommand.c_str(), endOfDataCommand.length()));
00381
00382         ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, ConfirmReplyCode("250"));
00383     }
00384     catch (StatusCodeException &statusCodeException)
00385     {
00386         (void) DisconnectSocket();
00387
00388         return static_cast<const StatusCode>(statusCodeException.m_errorCode);
00389     }
00390     catch (...)
00391     {
00392         (void) DisconnectSocket();
00393
00394         return STATUS_CODE_FAILURE;
00395     }
00396
00397     return STATUS_CODE_SUCCESS;
00398 }
00399
00400 // ---------------------------------------------------------------------------------------------------------------------------------
00401
00402 inline bool SmtpHelper::IsConnected() const
00403 {
00404     return (INVALID_SOCKET != m_socket);
00405 }
00406
00407 // ---------------------------------------------------------------------------------------------------------------------------------
00408
00409 inline std::string SmtpHelper::GetHostname()
00410 {
00411     return IpManager::GetHostName();
00412 }
00413
00414 // ---------------------------------------------------------------------------------------------------------------------------------
00415
00416 inline StatusCode SmtpHelper::ConfirmReplyCode(const std::string &replyCode)
00417 {
00418     char buffer[1024];
00419     size_t length;
00420     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, ReadSocket(buffer, ACTIV_ARRAY_SIZE(buffer), length));
00421
00422     return (((length >= replyCode.length()) && (0 == ::memcmp(buffer, replyCode.c_str(), replyCode.length()))) ? STATUS_CODE_SUCCESS : STATUS_CODE_FAILURE);
00423 }
00424
00425 // ---------------------------------------------------------------------------------------------------------------------------------
00426
00427 inline StatusCode SmtpHelper::ConnectSocket(const std::string &server)
00428 {
00429     try
00430     {
00431         IpAddress remoteAddress(SOCK_STREAM, IPPROTO_TCP);
00432         IpManager::GetIpAddress(server, PORT_NUMBER, remoteAddress);
00433
00434         m_socket = ::socket(remoteAddress.m_address.Address.sa_family, remoteAddress.m_type, remoteAddress.m_protocol);
00435
00436         if (INVALID_SOCKET == m_socket)
00437             ACTIV_THROW(Activ::StatusCodeException, STATUS_CODE_FAILURE);
00438
00439         if (SOCKET_ERROR == ::connect(m_socket, reinterpret_cast<const sockaddr *>(&remoteAddress.m_address), remoteAddress.m_addressLength))
00440             ACTIV_THROW(Activ::StatusCodeException, STATUS_CODE_FAILURE);
00441     }
00442     catch (StatusCodeException &statusCodeException)
00443     {
00444         (void) DisconnectSocket();
00445
00446         return static_cast<const StatusCode>(statusCodeException.m_errorCode);
00447     }
00448     catch (...)
00449     {
00450         (void) DisconnectSocket();
00451
00452         return STATUS_CODE_FAILURE;
00453     }
00454
00455     return STATUS_CODE_SUCCESS;
00456 }
00457
00458 // ---------------------------------------------------------------------------------------------------------------------------------
00459
00460 inline StatusCode SmtpHelper::DisconnectSocket()
00461 {
00462     if (INVALID_SOCKET != m_socket)
00463         (void) closesocket(m_socket);
00464
00465     m_socket = INVALID_SOCKET;
00466
00467     return STATUS_CODE_SUCCESS;
00468 }
00469
00470 // ---------------------------------------------------------------------------------------------------------------------------------
00471
00472 inline StatusCode SmtpHelper::ReadSocket(void * const pData, const size_t size, size_t &length)
00473 {
00474     fd_set readFds;
00475     FD_ZERO(&readFds);
00476     FD_SET(m_socket, &readFds);
00477
00478     struct timeval timeout;
00479     timeout.tv_sec = READ_TIMEOUT;
00480     timeout.tv_usec = 0;
00481
00482     int result = ::select(1, &readFds, 0, 0, &timeout);
00483
00484     if (SOCKET_ERROR == result)
00485         return STATUS_CODE_FAILURE;
00486     if (0 == result)
00487         return STATUS_CODE_TIMEOUT;
00488
00489     result = ::recv(m_socket, reinterpret_cast<char * const>(pData), static_cast<const int>(size), 0);
00490
00491     if (SOCKET_ERROR == result)
00492         return STATUS_CODE_FAILURE;
00493
00494     length = static_cast<const size_t>(result);
00495
00496     return STATUS_CODE_SUCCESS;
00497 }
00498
00499 // ---------------------------------------------------------------------------------------------------------------------------------
00500
00501 inline StatusCode SmtpHelper::WriteSocket(const void * const pData, const size_t length)
00502 {
00503     const int toWrite = static_cast<const int>(length);
00504
00505     for (int written = 0, result; written < toWrite; written += result)
00506     {
00507         result = ::send(m_socket, reinterpret_cast<const char * const>(pData) + written, toWrite - written, 0);
00508
00509         if (SOCKET_ERROR == result)
00510             return STATUS_CODE_FAILURE;
00511     }
00512
00513     return STATUS_CODE_SUCCESS;
00514 }
00515
00516 // ---------------------------------------------------------------------------------------------------------------------------------
00517
00518 inline void SmtpHelper::PostEmail(const Email &email, const std::string &server, const std::string &hostname)
00519 {
00520     std::auto_ptr<PostEmailThread> pPostEmailThread(new (std::nothrow) PostEmailThread(email, server, hostname));
00521
00522     if (0 == pPostEmailThread.get())
00523         ACTIV_THROW(StatusCodeException, STATUS_CODE_HEAP_EMPTY);
00524
00525     pPostEmailThread->Start(); // this might throw an exception
00526
00527     // if we get to here, thread started ok and will delete itself
00528     pPostEmailThread.release();
00529 }
00530
00531 // ---------------------------------------------------------------------------------------------------------------------------------
00532 // ---------------------------------------------------------------------------------------------------------------------------------
00533
00534 inline SmtpHelper::Email::Email(const std::string &fromAddress, const std::string &toAddressList, const std::string &ccAddressList,
00535                                 const std::string &bccAddressList, const std::string &subject, const std::string &text) :
00536     m_fromAddress(fromAddress),
00537     m_toAddressList(toAddressList),
00538     m_ccAddressList(ccAddressList),
00539     m_bccAddressList(bccAddressList),
00540     m_subject(subject),
00541     m_text(text)
00542 {
00543 }
00544
00545 // ---------------------------------------------------------------------------------------------------------------------------------
00546 // ---------------------------------------------------------------------------------------------------------------------------------
00547
00548 inline SmtpHelper::PostEmailThread::PostEmailThread(const Email &email, const std::string &server, const std::string &hostname) :
00549     m_email(email),
00550     m_server(server),
00551     m_hostname(hostname)
00552 {
00553 }
00554
00555 // ---------------------------------------------------------------------------------------------------------------------------------
00556
00557 inline StatusCode SmtpHelper::PostEmailThread::Process(void *pData)
00558 {
00559     SmtpHelper smtpHelper;
00560
00561     StatusCode statusCode = smtpHelper.Connect(m_server, m_hostname);
00562
00563     if (STATUS_CODE_SUCCESS != statusCode)
00564     {
00565         LogMessage(LOG_TYPE_INFO, "Error sending email, failed to connect to " + m_server);
00566         return statusCode;
00567     }
00568
00569     statusCode = smtpHelper.PostMessage(m_email.m_fromAddress, m_email.m_toAddressList, m_email.m_ccAddressList,
00570         m_email.m_bccAddressList, m_email.m_subject, m_email.m_text);
00571
00572     if (STATUS_CODE_SUCCESS != statusCode)
00573     {
00574         LogMessage(LOG_TYPE_INFO, "Error posting email message");
00575         return statusCode;
00576     }
00577
00578     delete this;
00579
00580     return STATUS_CODE_SUCCESS;
00581 }
00582
00583 } // namespace Activ
00584
00585 #endif // (!defined ACTIV_MISC_SMTP_HELPER_H)
Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivIp

SocketWrapper.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_IP_SOCKET_WRAPPER_H)
00010 #define ACTIV_IP_SOCKET_WRAPPER_H
00011
00012 #include "ActivMiddleware/ActivIp/External.h"
00013
00014 namespace Activ
00015 {
00016
00022 class SocketWrapper
00023 {
00024 public:
00028     SocketWrapper();
00029
00035     SocketWrapper(const SOCKET socket);
00036
00044     SocketWrapper(SocketWrapper &rhs);
00045
00051     ~SocketWrapper();
00052
00058     SocketWrapper &operator=(const SOCKET socket);
00059
00067     SocketWrapper &operator=(SocketWrapper &rhs);
00068
00074     operator SOCKET() const;
00075
00076 #if (defined ACTIV_PLATFORM_WINDOWS)
00077
00083     operator HANDLE() const;
00084
00085 #endif
00086
00092     bool IsValid() const;
00093
00094 private:
00098     void Attach(const SOCKET socket);
00099
00100     SOCKET  m_socket;
00101 };
00102
00103 // ---------------------------------------------------------------------------------------------------------------------------------
00104
00105 inline SocketWrapper::SocketWrapper() :
00106     m_socket(INVALID_SOCKET)
00107 {
00108 }
00109
00110 // ---------------------------------------------------------------------------------------------------------------------------------
00111
00112 inline SocketWrapper::SocketWrapper(const SOCKET socket) :
00113     m_socket(socket)
00114 {
00115 }
00116
00117 // ---------------------------------------------------------------------------------------------------------------------------------
00118
00119 inline SocketWrapper::SocketWrapper(SocketWrapper &rhs) :
00120     m_socket(INVALID_SOCKET)
00121 {
00122     *this = rhs;
00123 }
00124
00125 // ---------------------------------------------------------------------------------------------------------------------------------
00126
00127 inline SocketWrapper::~SocketWrapper()
00128 {
00129     Attach(INVALID_SOCKET);
00130 }
00131
00132 // ---------------------------------------------------------------------------------------------------------------------------------
00133
00134 inline SocketWrapper &SocketWrapper::operator=(SocketWrapper &rhs)
00135 {
00136     if (this == &rhs)
00137         return *this;
00138
00139     *this = rhs.m_socket;
00140     rhs.m_socket = INVALID_SOCKET;
00141
00142     return *this;
00143 }
00144
00145 // ---------------------------------------------------------------------------------------------------------------------------------
00146
00147 inline SocketWrapper &SocketWrapper::operator=(const SOCKET socket)
00148 {
00149     Attach(socket);
00150
00151     return *this;
00152 }
00153
00154 // ---------------------------------------------------------------------------------------------------------------------------------
00155
00156 inline SocketWrapper::operator SOCKET() const
00157 {
00158     return m_socket;
00159 }
00160
00161 // ---------------------------------------------------------------------------------------------------------------------------------
00162
00163 #if (defined ACTIV_PLATFORM_WINDOWS)
00164
00165 inline SocketWrapper::operator HANDLE() const
00166 {
00167     return reinterpret_cast<HANDLE>(m_socket);
00168 }
00169
00170 #endif
00171
00172 // ---------------------------------------------------------------------------------------------------------------------------------
00173
00174 inline bool SocketWrapper::IsValid() const
00175 {
00176     return (INVALID_SOCKET != m_socket);
00177 }
00178
00179 // ---------------------------------------------------------------------------------------------------------------------------------
00180
00181 inline void SocketWrapper::Attach(const SOCKET socket)
00182 {
00183     if (IsValid())
00184         (void) closesocket(m_socket);
00185
00186     m_socket = socket;
00187 }
00188
00189 } // namespace Activ
00190
00191 #endif // (!defined ACTIV_IP_SOCKET_WRAPPER_H)
Generated on Wed Oct 8 14:01:48 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » Config » Platforms

Solaris.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_CONFIG_PLATFORMS_SOLARIS_H)
00010 #define ACTIV_CONFIG_PLATFORMS_SOLARIS_H
00011
00012 // include this now to get definitions of SUN_LEN, CMSG_LEN etc if available (e.g. solaris 10)
00013 // and if not we'll define our own later
00014 #include <sys/socket.h>
00015
00016 #define ACTIV_PLATFORM_NAME "Solaris"
00017 #define ACTIV_PLATFORM_TYPE Activ::PLATFORM_TYPE_SOLARIS
00018
00019 #define ACTIV_POSIX_HAS_CONTEXT_API
00020 #define ACTIV_POSIX_HAS_PSHARED
00021
00022 #define ACTIV_HAS_INTTYPES_H
00023 #define ACTIV_EXPLICIT_INSTANTIATE_SIZE_T
00024
00025 #if (!defined SUN_LEN)
00026 // using ACTIV_FIELD_OFFSET fails with 64-bit gcc builds, so use old c-style field length
00027 #define SUN_LEN(p)      (reinterpret_cast<size_t>(&((sockaddr_un *)0)->sun_path) + strlen((p)->sun_path))
00028 #endif
00029
00030 #if (!defined CMSG_SPACE)
00031 #define CMSG_SPACE(len) (_CMSG_HDR_ALIGN(sizeof(struct cmsghdr)) + (len))
00032 #endif
00033
00034 #if (!defined CMSG_LEN)
00035 #define CMSG_LEN(len)   (_CMSG_DATA_ALIGN(sizeof(struct cmsghdr)) + (len))
00036 #endif
00037
00038 #if (!defined NAME_MAX)
00039 #define NAME_MAX    MAXNAMELEN
00040 #endif
00041
00042 #include "Posix.h"
00043 #include <strings.h>
00044
00045 #endif // (!defined ACTIV_CONFIG_PLATFORMS_SOLARIS_H)
Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

StatusCodeException.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_BASE_STATUS_CODE_EXCEPTION_H)
00010 #define ACTIV_BASE_STATUS_CODE_EXCEPTION_H
00011
00012 #include "ActivMiddleware/ActivBase/Exception.h"
00013
00014 namespace Activ
00015 {
00016
00020 #define ACTIV_THROW_RESULT_IF(statusCode, operator, expression)                                                     \
00021     if (true)                                                                                                       \
00022     {                                                                                                               \
00023         const Activ::StatusCode thisIsTheResultOfTheCall = expression;                                              \
00024         if (statusCode operator thisIsTheResultOfTheCall)                                                           \
00025             ACTIV_THROW(Activ::StatusCodeException, thisIsTheResultOfTheCall);                                      \
00026     }                                                                                                               \
00027     else
00028
00032 #define ACTIV_THROW_RESULT_IF_AND_IF(statusCode1, statusCode2, operator, expression)                                \
00033     if (true)                                                                                                       \
00034     {                                                                                                               \
00035         const Activ::StatusCode thisIsTheResultOfTheCall = expression;                                              \
00036         if ((statusCode1 operator thisIsTheResultOfTheCall) && (statusCode2 operator thisIsTheResultOfTheCall))     \
00037             ACTIV_THROW(Activ::StatusCodeException, thisIsTheResultOfTheCall);                                      \
00038     }                                                                                                               \
00039     else
00040
00044 #define ACTIV_THROW_RESULT_IF_OR_IF(statusCode1, statusCode2, operator, expression)                                 \
00045     if (true)                                                                                                       \
00046     {                                                                                                               \
00047         const Activ::StatusCode thisIsTheResultOfTheCall = expression;                                              \
00048         if ((statusCode1 operator thisIsTheResultOfTheCall) || (statusCode2 operator thisIsTheResultOfTheCall))     \
00049             ACTIV_THROW(Activ::StatusCodeException, thisIsTheResultOfTheCall);                                      \
00050     }                                                                                                               \
00051     else
00052
00053 // ---------------------------------------------------------------------------------------------------------------------------------
00054
00058 class StatusCodeException : public Exception
00059 {
00060 public:
00069     ACTIV_BASE_EXPORTED_API StatusCodeException(const char *file, const char *function, const uint_fast32_t line,
00070         const uint_fast32_t errorCode);
00071
00072     ACTIV_BASE_EXPORTED_API virtual std::string ToString() const;
00073 };
00074
00075 } // namespace Activ
00076
00077 #endif // (!defined ACTIV_BASE_STATUS_CODE_EXCEPTION_H)
Generated on Wed Oct 8 14:01:47 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware

StatusCodes.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_STATUS_CODES_H)
00010 #define ACTIV_STATUS_CODES_H
00011
00012 namespace Activ
00013 {
00014
00018 #define ACTIV_RETURN_IF(statusCode, operator, expression)                                                           \
00019     if (true)                                                                                                       \
00020     {                                                                                                               \
00021         if (expression operator statusCode)                                                                         \
00022             return;                                                                                                 \
00023     }                                                                                                               \
00024     else
00025
00029 #define ACTIV_RETURN_IF_AND_IF(statusCode1, statusCode2, operator, expression)                                      \
00030     if (true)                                                                                                       \
00031     {                                                                                                               \
00032         const Activ::StatusCode thisIsTheResultOfTheCall = expression;                                              \
00033         if ((thisIsTheResultOfTheCall operator statusCode1) && (thisIsTheResultOfTheCall operator statusCode2))     \
00034             return;                                                                                                 \
00035     }                                                                                                               \
00036     else
00037
00041 #define ACTIV_RETURN_IF_OR_IF(statusCode1, statusCode2, operator, expression)                                       \
00042     if (true)                                                                                                       \
00043     {                                                                                                               \
00044         const Activ::StatusCode thisIsTheResultOfTheCall = expression;                                              \
00045         if ((thisIsTheResultOfTheCall operator statusCode1) || (thisIsTheResultOfTheCall operator statusCode2))     \
00046             return;                                                                                                 \
00047     }                                                                                                               \
00048     else
00049
00053 #define ACTIV_RETURN_RESULT_IF(statusCode, operator, expression)                                                    \
00054     if (true)                                                                                                       \
00055     {                                                                                                               \
00056         const Activ::StatusCode thisIsTheResultOfTheCall = expression;                                              \
00057         if (thisIsTheResultOfTheCall operator statusCode)                                                           \
00058             return thisIsTheResultOfTheCall;                                                                        \
00059     }                                                                                                               \
00060     else
00061
00065 #define ACTIV_RETURN_RESULT_IF_AND_IF(statusCode1, statusCode2, operator, expression)                               \
00066     if (true)                                                                                                       \
00067     {                                                                                                               \
00068         const Activ::StatusCode thisIsTheResultOfTheCall = expression;                                              \
00069         if ((thisIsTheResultOfTheCall operator statusCode1) && (thisIsTheResultOfTheCall operator statusCode2))     \
00070             return thisIsTheResultOfTheCall;                                                                        \
00071     }                                                                                                               \
00072     else
00073
00077 #define ACTIV_RETURN_RESULT_IF_OR_IF(statusCode1, statusCode2, operator, expression)                                \
00078     if (true)                                                                                                       \
00079     {                                                                                                               \
00080         const Activ::StatusCode thisIsTheResultOfTheCall = expression;                                              \
00081         if ((thisIsTheResultOfTheCall operator statusCode1) || (thisIsTheResultOfTheCall operator statusCode2))     \
00082             return thisIsTheResultOfTheCall;                                                                        \
00083     }                                                                                                               \
00084     else
00085
00089 #define ACTIV_RETURN_VALUE_IF(statusCode, operator, expression, value)                                              \
00090     if (true)                                                                                                       \
00091     {                                                                                                               \
00092         if (expression operator statusCode)                                                                         \
00093             return value;                                                                                           \
00094     }                                                                                                               \
00095     else
00096
00100 #define ACTIV_RETURN_VALUE_IF_AND_IF(statusCode1, statusCode2, operator, expression, value)                         \
00101     if (true)                                                                                                       \
00102     {                                                                                                               \
00103         const Activ::StatusCode thisIsTheResultOfTheCall = expression;                                              \
00104         if ((thisIsTheResultOfTheCall operator statusCode1) && (thisIsTheResultOfTheCall operator statusCode2))     \
00105             return value;                                                                                           \
00106     }                                                                                                               \
00107     else
00108
00112 #define ACTIV_RETURN_VALUE_IF_OR_IF(statusCode1, statusCode2, operator, expression, value)                          \
00113     if (true)                                                                                                       \
00114     {                                                                                                               \
00115         const Activ::StatusCode thisIsTheResultOfTheCall = expression;                                              \
00116         if ((thisIsTheResultOfTheCall operator statusCode1) || (thisIsTheResultOfTheCall operator statusCode2))     \
00117             return value;                                                                                           \
00118     }                                                                                                               \
00119     else
00120
00124 #define ACTIV_CONTINUE_IF(statusCode, operator, expression)                                                         \
00125     if (true)                                                                                                       \
00126     {                                                                                                               \
00127         if (expression operator statusCode)                                                                         \
00128             continue;                                                                                               \
00129     }                                                                                                               \
00130     else
00131
00135 #define ACTIV_CONTINUE_IF_AND_IF(statusCode1, statusCode2, operator, expression)                                    \
00136     if (true)                                                                                                       \
00137     {                                                                                                               \
00138         const Activ::StatusCode thisIsTheResultOfTheCall = expression;                                              \
00139         if ((thisIsTheResultOfTheCall operator statusCode1) && (thisIsTheResultOfTheCall operator statusCode2))     \
00140             continue;                                                                                               \
00141     }                                                                                                               \
00142     else
00143
00147 #define ACTIV_CONTINUE_IF_OR_IF(statusCode1, statusCode2, operator, expression)                                     \
00148     if (true)                                                                                                       \
00149     {                                                                                                               \
00150         const Activ::StatusCode thisIsTheResultOfTheCall = expression;                                              \
00151         if ((thisIsTheResultOfTheCall operator statusCode1) || (thisIsTheResultOfTheCall operator statusCode2))     \
00152             continue;                                                                                               \
00153     }                                                                                                               \
00154     else
00155
00159 #define ACTIV_BREAK_IF(statusCode, operator, expression)                                                            \
00160     if (true)                                                                                                       \
00161     {                                                                                                               \
00162         if (expression operator statusCode)                                                                         \
00163             break;                                                                                                  \
00164     }                                                                                                               \
00165     else
00166
00170 #define ACTIV_BREAK_IF_AND_IF(statusCode1, statusCode2, operator, expression)                                       \
00171     if (true)                                                                                                       \
00172     {                                                                                                               \
00173         const Activ::StatusCode thisIsTheResultOfTheCall = expression;                                              \
00174         if ((thisIsTheResultOfTheCall operator statusCode1) && (thisIsTheResultOfTheCall operator statusCode2))     \
00175             break;                                                                                                  \
00176     }                                                                                                               \
00177     else
00178
00182 #define ACTIV_BREAK_IF_OR_IF(statusCode1, statusCode2, operator, expression)                                        \
00183     if (true)                                                                                                       \
00184     {                                                                                                               \
00185         const Activ::StatusCode thisIsTheResultOfTheCall = expression;                                              \
00186         if ((thisIsTheResultOfTheCall operator statusCode1) || (thisIsTheResultOfTheCall operator statusCode2))     \
00187             break;                                                                                                  \
00188     }                                                                                                               \
00189     else
00190
00194 #define ACTIV_RETURN_TRUE_IF(statusCode, operator, expression)                          ACTIV_RETURN_VALUE_IF(statusCode, operator, expression, true)
00195
00199 #define ACTIV_RETURN_TRUE_IF_AND_IF(statusCode1, statusCode2, operator, expression)     ACTIV_RETURN_VALUE_IF_AND_IF(statusCode1, statusCode2, operator, expression, true)
00200
00204 #define ACTIV_RETURN_TRUE_IF_OR_IF(statusCode1, statusCode2, operator, expression)      ACTIV_RETURN_VALUE_IF_OR_IF(statusCode1, statusCode2, operator, expression, true)
00205
00209 #define ACTIV_RETURN_FALSE_IF(statusCode, operator, expression)                         ACTIV_RETURN_VALUE_IF(statusCode, operator, expression, false)
00210
00214 #define ACTIV_RETURN_FALSE_IF_AND_IF(statusCode1, statusCode2, operator, expression)    ACTIV_RETURN_VALUE_IF_AND_IF(statusCode1, statusCode2, operator, expression, false)
00215
00219 #define ACTIV_RETURN_FALSE_IF_OR_IF(statusCode1, statusCode2, operator, expression)     ACTIV_RETURN_VALUE_IF_OR_IF(statusCode1, statusCode2, operator, expression, false)
00220
00226 #define ACTIV_STATUS_CODE_LIST(d)                                           \
00227     d(0,    STATUS_CODE_SUCCESS, "success")                                 \
00228     d(1,    STATUS_CODE_FAILURE, "failure")                                 \
00229     d(2,    STATUS_CODE_EXIT, "exit")                                       \
00230     d(3,    STATUS_CODE_SHUTTING_DOWN, "shutting down")                     \
00231     d(4,    STATUS_CODE_UNHANDLED_EXCEPTION, "unhandled exception")         \
00232     d(5,    STATUS_CODE_UNRECOGNIZED, "unrecognized")                       \
00233     d(6,    STATUS_CODE_NOT_FOUND, "not found")                             \
00234     d(7,    STATUS_CODE_TIMEOUT, "timeout")                                 \
00235     d(8,    STATUS_CODE_UNCHANGED, "unchanged")                             \
00236     d(9,    STATUS_CODE_PENDING, "pending")                                 \
00237     d(10,   STATUS_CODE_ACCESS_DENIED, "access denied")                     \
00238     d(11,   STATUS_CODE_BUFFER_OVERFLOW, "buffer overflow")                 \
00239     d(12,   STATUS_CODE_BUFFER_UNDERRUN, "buffer underrun")                 \
00240     d(13,   STATUS_CODE_NOT_SUPPORTED, "not supported")                     \
00241     d(14,   STATUS_CODE_NOT_INITIALIZED, "not initialized")                 \
00242     d(15,   STATUS_CODE_MISSING_ARGS, "missing args")                       \
00243     d(16,   STATUS_CODE_NOT_OPEN, "not open")                               \
00244     d(17,   STATUS_CODE_ALREADY_OPEN, "already open")                       \
00245     d(18,   STATUS_CODE_DISABLED, "disabled")                               \
00246     d(19,   STATUS_CODE_INVALID_ENDPOINT, "invalid endpoint")               \
00247     d(20,   STATUS_CODE_INVALID_PORT, "invalid port")                       \
00248     d(21,   STATUS_CODE_INVALID_VERSION, "invalid version")                 \
00249     d(22,   STATUS_CODE_INVALID_LENGTH, "invalid length")                   \
00250     d(23,   STATUS_CODE_INVALID_PARAMETER, "invalid parameter")             \
00251     d(24,   STATUS_CODE_INVALID_NAME, "invalid name")                       \
00252     d(25,   STATUS_CODE_INVALID_FORMAT, "invalid format")                   \
00253     d(26,   STATUS_CODE_INVALID_INDEX, "invalid index")                     \
00254     d(27,   STATUS_CODE_INVALID_KEY, "invalid key")                         \
00255     d(28,   STATUS_CODE_INVALID_FIELD_TYPE, "invalid field type")           \
00256     d(29,   STATUS_CODE_INVALID_FIELD, "invalid field")                     \
00257     d(30,   STATUS_CODE_INVALID_RECORD, "invalid record")                   \
00258     d(31,   STATUS_CODE_INVALID_TABLE, "invalid table")                     \
00259     d(32,   STATUS_CODE_INVALID_PROTOCOL, "invalid protocol")               \
00260     d(33,   STATUS_CODE_UNDEFINED_FIELD, "undefined field")                 \
00261     d(34,   STATUS_CODE_NO_PRIMARY_KEY, "no primary key")                   \
00262     d(35,   STATUS_CODE_MISMATCH, "mismatch")                               \
00263     d(36,   STATUS_CODE_OUT_OF_RANGE, "out of range")                       \
00264     d(37,   STATUS_CODE_STALE, "stale data")                                \
00265     d(38,   STATUS_CODE_DELETED, "item deleted")                            \
00266     d(39,   STATUS_CODE_EMPTY, "empty")                                     \
00267     d(40,   STATUS_CODE_FULL, "full")                                       \
00268     d(41,   STATUS_CODE_HEAP_EMPTY, "heap empty")                           \
00269     d(42,   STATUS_CODE_WRONG_STATE, "wrong state")                         \
00270     d(43,   STATUS_CODE_NOT_CONNECTED, "not connected")                     \
00271     d(44,   STATUS_CODE_ALREADY_CONNECTED, "already connected")             \
00272     d(45,   STATUS_CODE_ALREADY_DEFINED, "already defined")                 \
00273     d(46,   STATUS_CODE_NOT_CREATED, "not created")                         \
00274     d(47,   STATUS_CODE_ALREADY_EXISTS, "already exists")                   \
00275     d(48,   STATUS_CODE_IN_USE, "in use")                                   \
00276     d(49,   STATUS_CODE_END_OF_DATA, "end of data")                         \
00277     d(50,   STATUS_CODE_ALREADY_LISTENING, "already listening")             \
00278     d(51,   STATUS_CODE_NOT_SHAREABLE, "not shareable")                     \
00279     d(52,   STATUS_CODE_CONNECTION_REFUSED, "connection refused")           \
00280     d(53,   STATUS_CODE_INTERRUPTED, "interrupted")                         \
00281     d(54,   STATUS_CODE_IGNORED, "ignored")                                 \
00282     d(55,   STATUS_CODE_TOO_MANY_REQUESTS, "too many requests outstanding") \
00283     d(56,   STATUS_CODE_INVALID_ENDPOINT_PORT, "invalid endpoint-port")     \
00284     d(57,   STATUS_CODE_HOST_NOT_FOUND, "host not found")                   \
00285     d(58,   STATUS_CODE_INVALID_USER, "invalid user")                       \
00286     d(59,   STATUS_CODE_INVALID_PASSWORD, "invalid password")               \
00287     d(60,   STATUS_CODE_INVALID_URL, "invalid url")                         \
00288     d(61,   STATUS_CODE_NOT_A_DIRECTORY, "not a directory")                 \
00289     d(62,   STATUS_CODE_BUSY, "busy")                                       \
00290     d(63,   STATUS_CODE_EXPIRED, "expired")                                 \
00291     d(64,   STATUS_CODE_HOST_UNREACHABLE, "host unreachable")               \
00292     d(65,   STATUS_CODE_NETWORK_UNREACHABLE, "network unreachable")         \
00293     d(66,   STATUS_CODE_NOT_LICENSED, "not licensed")                       \
00294     d(67,   STATUS_CODE_ADDRESS_NOT_AVAILABLE, "address not available")     \
00295     d(68,   STATUS_CODE_NO_SUCH_DEVICE, "no such device")                   \
00296     d(69,   STATUS_CODE_QUOTA_EXCEEDED, "quota exceeded")                   \
00297     d(70,   STATUS_CODE_INVALID_SERVICE_ID, "invalid service id")           \
00298     d(71,   STATUS_CODE_PATH_NOT_FOUND, "path not found")                   \
00299     d(72,   STATUS_CODE_INVALID_HANDLE, "invalid handle")                   \
00300     d(73,   STATUS_CODE_INVALID_ADDRESS, "invalid address")                 \
00301     d(74,   STATUS_CODE_INSUFFICIENT_RESOURCES, "insufficient resources")   \
00302     d(255,  STATUS_CODE_UNKNOWN, "unknown")
00303
00307 typedef byte_t StatusCode;
00308
00312 #define ACTIV_DECLARE_STATUS_CODE(value, id, name)  const StatusCode id = value;
00313
00317 ACTIV_STATUS_CODE_LIST(ACTIV_DECLARE_STATUS_CODE)
00318
00319 #undef ACTIV_DECLARE_STATUS_CODE
00320
00321 } // namespace Activ
00322
00323 #endif // (!defined ACTIV_STATUS_CODES_H)
Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » Misc

StlHelper.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_MISC_STL_HELPER_H)
00010 #define ACTIV_MISC_STL_HELPER_H
00011
00012 #include "ActivMiddleware/Activ.h"
00013
00014 #include "boost/functional/hash/hash.hpp"
00015
00016 #include <vector>
00017 #include <string>
00018 #include <list>
00019 #include <map>
00020 #include <algorithm>
00021
00022 #if (defined _STLPORT_VERSION)
00023 // STLport STL
00024 #include <hash_map>
00025 #include <hash_set>
00026 #if (defined _STLP_STD_NAME)
00027 #define ACTIV_STL_HELPER_EXT_NAMESPACE  _STLP_STD_NAME
00028 #elif (defined _STLP_STD)
00029 #define ACTIV_STL_HELPER_EXT_NAMESPACE  _STLP_STD
00030 #else
00031 #error Unable to determine STLport namespace
00032 #endif
00033 #define ACTIV_STL_HELPER_DEFINE_HASH_COMPARE
00034
00035 // ---------------------------------------------------------------------------------------------------------------------------------
00036
00037 #elif (defined ACTIV_COMPILER_VISUAL_C) || (defined ACTIV_COMPILER_INTEL)
00038 // Dinkumware STL
00039 #include <hash_map>
00040 #include <hash_set>
00041 #if (_CPPLIB_VER > 310)
00042 #define ACTIV_STL_HELPER_EXT_NAMESPACE  stdext
00043 #else
00044 #define ACTIV_STL_HELPER_EXT_NAMESPACE  std
00045 #endif
00046 #if (_MSC_VER < 1400)
00047 // prior to vc80, clear() on a vector would free storage (i.e. the post condition capacity() == 0 would be true)
00048 #define ACTIV_STL_HELPER_NONSTD_VECTOR_CLEAR
00049 #endif
00050
00051 // ---------------------------------------------------------------------------------------------------------------------------------
00052
00053 #elif (defined ACTIV_COMPILER_GCC)
00054 // GCC STL
00055 #include <ext/hash_map>
00056 #include <ext/hash_set>
00057 #define ACTIV_STL_HELPER_EXT_NAMESPACE  __gnu_cxx
00058 #define ACTIV_STL_HELPER_DEFINE_HASH_COMPARE
00059
00060 // ---------------------------------------------------------------------------------------------------------------------------------
00061
00062 #else
00063 #error Add for this compiler / STL implementation.
00064 #endif
00065
00066 // ---------------------------------------------------------------------------------------------------------------------------------
00067
00068 #if (defined ACTIV_STL_HELPER_DEFINE_HASH_COMPARE)
00069
00070 namespace ACTIV_STL_HELPER_EXT_NAMESPACE
00071 {
00072
00078 template<typename KEY, typename TRAITS>
00079 class hash_compare : public hash<KEY>
00080 {
00081 public:
00090     bool operator()(const KEY &k1, const KEY &k2) const
00091     {
00092         return TRAITS(k1, k2);
00093     }
00094 };
00095
00096 } // namespace ACTIV_STL_HELPER_EXT_NAMESPACE
00097
00098 #endif // (!defined ACTIV_STL_HELPER_DEFINE_HASH_COMPARE)
00099
00100 // ---------------------------------------------------------------------------------------------------------------------------------
00101
00102 namespace Activ
00103 {
00104
00113 template <typename T>
00114 inline void EmptyVector(std::vector<T> &v)
00115 {
00116 #if (defined ACTIV_STL_HELPER_NONSTD_VECTOR_CLEAR)
00117     // slightly quicker than resize(0)
00118     while (!v.empty())
00119         v.pop_back();
00120 #else
00121     v.clear();
00122 #endif
00123 }
00124
00125 // ---------------------------------------------------------------------------------------------------------------------------------
00126 // ---------------------------------------------------------------------------------------------------------------------------------
00127
00128 using ACTIV_STL_HELPER_EXT_NAMESPACE::hash_compare;
00129
00130 #if (defined ACTIV_COMPILER_VISUAL_C) || (defined ACTIV_COMPILER_INTEL)
00131
00137 template
00138 <
00139     typename KEY,
00140     typename VALUE,
00141     typename HASH_FN = hash_compare<KEY, std::less<KEY> >,
00142     typename EQUAL_KEY = std::equal_to<KEY>,
00143     typename ALLOCATOR = std::allocator<std::pair<const KEY, VALUE> >
00144 >
00145 class hash_map : public ACTIV_STL_HELPER_EXT_NAMESPACE::hash_map<KEY, VALUE, HASH_FN, ALLOCATOR>
00146 {
00147 public:
00148     hash_map()
00149     {
00150     }
00151
00152     explicit hash_map(const key_compare &_Traits) :
00153         ACTIV_STL_HELPER_EXT_NAMESPACE::hash_map<KEY, VALUE, HASH_FN, ALLOCATOR>(_Traits)
00154     {
00155     }
00156
00157     hash_map(const key_compare &_Traits, const allocator_type &_Al) :
00158         ACTIV_STL_HELPER_EXT_NAMESPACE::hash_map<KEY, VALUE, HASH_FN, ALLOCATOR>(_Traits, _Al)
00159     {
00160     }
00161
00162     template<class _Iter>
00163     hash_map(_Iter _First, _Iter _Last) :
00164         ACTIV_STL_HELPER_EXT_NAMESPACE::hash_map<KEY, VALUE, HASH_FN, ALLOCATOR>(_First, _Last)
00165     {
00166     }
00167
00168     template<class _Iter>
00169     hash_map(_Iter _First, _Iter _Last, const key_compare &_Traits) :
00170         ACTIV_STL_HELPER_EXT_NAMESPACE::hash_map<KEY, VALUE, HASH_FN, ALLOCATOR>(_First, _Last, _Traits)
00171     {
00172     }
00173
00174     template<class _Iter>
00175     hash_map(_Iter _First, _Iter _Last, const key_compare &_Traits, const allocator_type &_Al) :
00176         ACTIV_STL_HELPER_EXT_NAMESPACE::hash_map<KEY, VALUE, HASH_FN, ALLOCATOR>(_First, _Last, _Traits, _Al)
00177     {
00178     }
00179 };
00180
00181 // ---------------------------------------------------------------------------------------------------------------------------------
00182
00188 template
00189 <
00190     typename KEY,
00191     typename HASH_FN = hash_compare<KEY, std::less<KEY> >,
00192     typename EQUAL_KEY = std::equal_to<KEY>,
00193     typename ALLOCATOR = std::allocator<KEY>
00194 >
00195 class hash_set : public ACTIV_STL_HELPER_EXT_NAMESPACE::hash_set<KEY, HASH_FN, ALLOCATOR>
00196 {
00197 public:
00198     hash_set()
00199     {
00200     }
00201
00202     explicit hash_set(const key_compare &_Traits) :
00203         ACTIV_STL_HELPER_EXT_NAMESPACE::hash_set<KEY, HASH_FN, ALLOCATOR>(_Traits)
00204     {
00205     }
00206
00207     hash_set(const key_compare& _Traits, const allocator_type &_Al) :
00208         ACTIV_STL_HELPER_EXT_NAMESPACE::hash_set<KEY, HASH_FN, ALLOCATOR>(_Traits, _Al)
00209     {
00210     }
00211
00212     template<class _Iter>
00213     hash_set(_Iter _First, _Iter _Last) :
00214         ACTIV_STL_HELPER_EXT_NAMESPACE::hash_set<KEY, HASH_FN, ALLOCATOR>(_First, _Last)
00215     {
00216     }
00217
00218     template<class _Iter>
00219     hash_set(_Iter _First, _Iter _Last, const key_compare &_Traits) :
00220         ACTIV_STL_HELPER_EXT_NAMESPACE::hash_set<KEY, HASH_FN, ALLOCATOR>(_First, _Last, _Traits)
00221     {
00222     }
00223
00224     template<class _Iter>
00225     hash_set(_Iter _First, _Iter _Last, const key_compare &_Traits, const allocator_type &_Al) :
00226         ACTIV_STL_HELPER_EXT_NAMESPACE::hash_set<KEY, HASH_FN, ALLOCATOR>(_First, _Last, _Traits, _Al)
00227     {
00228     }
00229 };
00230
00231 using ACTIV_STL_HELPER_EXT_NAMESPACE::_Hash;
00232 using ACTIV_STL_HELPER_EXT_NAMESPACE::_Hmap_traits;
00233 using ACTIV_STL_HELPER_EXT_NAMESPACE::_Hset_traits;
00234
00235 #else
00236 // just import the provided classes into the Activ namespace
00237 using ACTIV_STL_HELPER_EXT_NAMESPACE::hash_map;
00238 using ACTIV_STL_HELPER_EXT_NAMESPACE::hash_set;
00239 #endif
00240
00241 // ---------------------------------------------------------------------------------------------------------------------------------
00242 // ---------------------------------------------------------------------------------------------------------------------------------
00243
00249 template<typename TRAITS = std::less<std::string> >
00250 class StringHashCompare : public hash_compare<std::string, TRAITS>
00251 {
00252 public:
00260     size_t operator()(const std::string &key) const;
00261
00265     bool operator()(const std::string &k1, const std::string &k2) const;
00266 };
00267
00268 // ---------------------------------------------------------------------------------------------------------------------------------
00269 // ---------------------------------------------------------------------------------------------------------------------------------
00270
00271 template<typename TRAITS>
00272 inline size_t StringHashCompare<TRAITS>::operator()(const std::string &key) const
00273 {
00274     return boost::hash<std::string>()(key);
00275 }
00276
00277 // ---------------------------------------------------------------------------------------------------------------------------------
00278
00279 template<typename TRAITS>
00280 inline bool StringHashCompare<TRAITS>::operator()(const std::string &k1, const std::string &k2) const
00281 {
00282     // can't just use using BASE::operator(), VC++ complains
00283     return hash_compare<std::string, TRAITS>::operator()(k1, k2);
00284 }
00285
00286 // ---------------------------------------------------------------------------------------------------------------------------------
00287 // ---------------------------------------------------------------------------------------------------------------------------------
00288
00294 template <typename P>
00295 class SelectFirst : public std::unary_function<P, typename P::first_type>
00296 {
00297 public:
00298     typedef std::unary_function<P, typename P::first_type> Base;
00299
00307     const typename Base::result_type &operator()(const typename Base::argument_type &p) const
00308     {
00309         return p.first;
00310     }
00311 };
00312
00313 // ---------------------------------------------------------------------------------------------------------------------------------
00314
00320 template <typename P>
00321 class SelectSecond : public std::unary_function<P, typename P::second_type>
00322 {
00323 public:
00324     typedef std::unary_function<P, typename P::second_type> Base;
00325
00333     const typename Base::result_type &operator()(const typename Base::argument_type &p) const
00334     {
00335         return p.second;
00336     }
00337 };
00338
00339 // ---------------------------------------------------------------------------------------------------------------------------------
00340
00346 template<typename P>
00347 class SelectFirstFromSecond : public std::unary_function<typename P::second_type, typename P::first_type>
00348 {
00349 public:
00350     typedef P Pair;
00351     typedef std::unary_function<typename Pair::second_type, typename Pair::first_type> Base;
00352
00360     const typename Base::result_type &operator()(const typename Base::argument_type &second) const
00361     {
00362         const TypeToIntegralType<void *>::Type offset = ACTIV_FIELD_OFFSET(Pair, second) - ACTIV_FIELD_OFFSET(Pair, first);
00363
00364         return *reinterpret_cast<const typename Pair::first_type *>(reinterpret_cast<const byte_t *>(&second) - offset);
00365     }
00366 };
00367
00368 // ---------------------------------------------------------------------------------------------------------------------------------
00369 // ---------------------------------------------------------------------------------------------------------------------------------
00370
00378 template<typename T>
00379 inline bool SortAndCheckForDuplicates(T &c)
00380 {
00381     std::sort(c.begin(), c.end());
00382     return (c.end() == std::unique(c.begin(), c.end()));
00383 }
00384
00385 // ---------------------------------------------------------------------------------------------------------------------------------
00386
00387 template<typename T>
00388 inline bool SortUnique(T &c)
00389 {
00390     // old style name to be removed
00391     return SortAndCheckForDuplicates<T>(c);
00392 }
00393
00394 // ---------------------------------------------------------------------------------------------------------------------------------
00395
00401 template<typename T>
00402 inline void SortAndRemoveDuplicates(T &c)
00403 {
00404     std::sort(c.begin(), c.end());
00405     (void) c.erase(std::unique(c.begin(), c.end()), c.end());
00406 }
00407
00408 // ---------------------------------------------------------------------------------------------------------------------------------
00409 // ---------------------------------------------------------------------------------------------------------------------------------
00410
00416 inline void StringToLower(std::string &str)
00417 {
00418     for (size_t i = 0, size = str.length(); i < size; ++i)
00419         str[i] = ::tolower(str[i]);
00420 }
00421
00422 // ---------------------------------------------------------------------------------------------------------------------------------
00423
00429 inline void StringToUpper(std::string &str)
00430 {
00431     for (size_t i = 0, size = str.length(); i < size; ++i)
00432         str[i] = ::toupper(str[i]);
00433 }
00434
00435 // ---------------------------------------------------------------------------------------------------------------------------------
00436 // ---------------------------------------------------------------------------------------------------------------------------------
00437
00448 template<typename MAPPED_TYPE, typename KEY_TYPE>
00449 inline bool MapFind(MAPPED_TYPE &map, const KEY_TYPE &key, typename MAPPED_TYPE::iterator &iter)
00450 {
00451     // returning bool and taking iterator reference is the fastest implementation (faster than
00452     // returning a std::pair<iter, bool> or taking std::pair<iter, bool> by reference) at least with VC++
00453     iter = map.lower_bound(key);
00454
00455     // if lower_bound() doesn't return end(), it returns an iterator to an item that is
00456     // !map.key_comp()(iter->first, key), so to check for equivalence it is only necessary to
00457     // check for !map.key_comp()(key, iter->first).
00458     return ((iter != map.end()) && !map.key_comp()(key, iter->first));
00459 }
00460
00461 // ---------------------------------------------------------------------------------------------------------------------------------
00462
00488 template<typename MAPPED_TYPE, typename KEY_TYPE>
00489 inline std::pair<typename MAPPED_TYPE::iterator, bool> MapInsert(MAPPED_TYPE &map, const KEY_TYPE &key, typename MAPPED_TYPE::value_type &value)
00490 {
00491     const_cast<typename MAPPED_TYPE::key_type &>(value.first) = key;
00492
00493     return map.insert(value);
00494 }
00495
00496 // ---------------------------------------------------------------------------------------------------------------------------------
00497
00527 template<typename MAPPED_TYPE, typename KEY_TYPE>
00528 inline typename MAPPED_TYPE::iterator MapInsert(MAPPED_TYPE &map, typename MAPPED_TYPE::iterator hint, const KEY_TYPE &key, typename MAPPED_TYPE::value_type &value)
00529 {
00530     const_cast<typename MAPPED_TYPE::key_type &>(value.first) = key;
00531
00532     return map.insert(hint, value);
00533 }
00534
00535 } // namespace Activ
00536
00537 // ---------------------------------------------------------------------------------------------------------------------------------
00538 // ---------------------------------------------------------------------------------------------------------------------------------
00539
00540 #if (defined _STLPORT_VERSION)
00541
00550 template<typename K1, typename T1, typename H1, typename E1, typename A1,
00551     typename K2, typename T2, typename H2, typename E2, typename A2>
00552 bool operator==(const ACTIV_STL_HELPER_EXT_NAMESPACE::hash_map<K1, T1, H1, E1, A1> &lhs,
00553     const ACTIV_STL_HELPER_EXT_NAMESPACE::hash_map<K2, T2, H2, E2, A2> &rhs)
00554 {
00555     if (lhs.size() != rhs.size())
00556         return false;
00557
00558     typedef ACTIV_STL_HELPER_EXT_NAMESPACE::hash_map<K1, T1, H1, E1, A1> Map;
00559
00560     for (typename Map::const_iterator iterLhs = lhs.begin(), iterLhsEnd = lhs.end(), iterRhs = rhs.begin();
00561         iterLhs != iterLhsEnd; ++iterLhs, ++iterRhs)
00562     {
00563         assert(iterRhs != rhs.end());
00564
00565         if (*iterLhs != *iterRhs)
00566             return false;
00567     }
00568
00569     return true;
00570 }
00571
00572 // ---------------------------------------------------------------------------------------------------------------------------------
00573
00582 template<typename K1, typename T1, typename H1, typename E1, typename A1,
00583     typename K2, typename T2, typename H2, typename E2, typename A2>
00584 bool operator!=(const ACTIV_STL_HELPER_EXT_NAMESPACE::hash_map<K1, T1, H1, E1, A1> &lhs,
00585     const ACTIV_STL_HELPER_EXT_NAMESPACE::hash_map<K2, T2, H2, E2, A2> &rhs)
00586 {
00587     return !(lhs == rhs);
00588 }
00589
00590 #endif
00591
00592 #endif // (!defined ACTIV_MISC_STL_HELPER_H)
Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivSystem

Subject.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_SYSTEM_SUBJECT_H)
00010 #define ACTIV_SYSTEM_SUBJECT_H
00011
00012 #include "ActivMiddleware/ActivSystem/External.h"
00013 #include "ActivMiddleware/ActivSystem/MessageTypes.h"
00014 #include "ActivMiddleware/Misc/MemoryHelper.h"
00015
00016 namespace Activ
00017 {
00018
00019 class MessageBuilder;
00020 class MessageValidator;
00021
00022 // ---------------------------------------------------------------------------------------------------------------------------------
00023
00027 class Subject
00028 {
00029 public:
00030     typedef byte_t SubjectLength;
00031     static const SubjectLength MAX_LENGTH = 48;
00032
00036     ACTIV_SYSTEM_EXPORTED_API
00037     Subject();
00038
00047     ACTIV_SYSTEM_EXPORTED_API
00048     Subject(const void *pSubjectData, const size_t subjectDataLength);
00049
00057     ACTIV_SYSTEM_EXPORTED_API
00058     Subject(const char *pSubject);
00059
00067     ACTIV_SYSTEM_EXPORTED_API
00068     Subject(const std::string &subject);
00069
00073     ACTIV_SYSTEM_INLINE_API
00074     void Clear();
00075
00084     ACTIV_SYSTEM_EXPORTED_API
00085     StatusCode Serialize(MessageBuilder &messageBuilder) const;
00086
00095     ACTIV_SYSTEM_EXPORTED_API
00096     StatusCode Deserialize(MessageValidator &messageValidator);
00097
00103     ACTIV_SYSTEM_INLINE_API
00104     size_t GetLength() const;
00105
00111     ACTIV_SYSTEM_INLINE_API
00112     size_t GetSerializedLength() const;
00113
00121     ACTIV_SYSTEM_EXPORTED_API
00122     void Set(const char *pSubject);
00123
00132     ACTIV_SYSTEM_EXPORTED_API
00133     void Set(const void *pSubjectData, const size_t subjectDataLength);
00134
00142     ACTIV_SYSTEM_EXPORTED_API
00143     void Set(const std::string &subject);
00144
00150     ACTIV_SYSTEM_INLINE_API
00151     void Set(const Subject &subject);
00152
00158     ACTIV_SYSTEM_INLINE_API
00159     const void *Get() const;
00160
00166     ACTIV_SYSTEM_EXPORTED_API
00167     std::string ToString() const;
00168
00176     ACTIV_SYSTEM_EXPORTED_API
00177     bool operator==(const Subject &subject) const;
00178
00186     ACTIV_SYSTEM_EXPORTED_API
00187     bool operator!=(const Subject &subject) const;
00188
00196     ACTIV_SYSTEM_EXPORTED_API
00197     bool operator<(const Subject &subject) const;
00198
00206     ACTIV_SYSTEM_EXPORTED_API
00207     bool operator>(const Subject &subject) const;
00208
00216     ACTIV_SYSTEM_EXPORTED_API
00217     bool operator<=(const Subject &subject) const;
00218
00226     ACTIV_SYSTEM_EXPORTED_API
00227     bool operator>=(const Subject &subject) const;
00228
00229 private:
00238     ACTIV_SYSTEM_INLINE_API
00239     void Initialize(const void *pSubjectData, const size_t subjectDataLength);
00240
00250     ACTIV_SYSTEM_INLINE_API
00251     int Compare(const Subject &subject) const;
00252
00253 #pragma pack(1)
00254
00255     byte_t          m_subject[MAX_LENGTH];
00256     SubjectLength   m_length;
00257
00258 #pragma pack()
00259 };
00260
00261 // ---------------------------------------------------------------------------------------------------------------------------------
00262
00263 inline void Subject::Clear()
00264 {
00265     m_length = 0;
00266 }
00267
00268 // ---------------------------------------------------------------------------------------------------------------------------------
00269
00270 inline size_t Subject::GetLength() const
00271 {
00272     return m_length;
00273 }
00274
00275 // ---------------------------------------------------------------------------------------------------------------------------------
00276
00277 inline size_t Subject::GetSerializedLength() const
00278 {
00279     return sizeof(m_length) + m_length;
00280 }
00281
00282 // ---------------------------------------------------------------------------------------------------------------------------------
00283
00284 inline void Subject::Set(const Subject &subject)
00285 {
00286     m_length = subject.m_length;
00287     MemoryCopy(m_subject, subject.m_subject, m_length);
00288 }
00289
00290 // ---------------------------------------------------------------------------------------------------------------------------------
00291
00292 inline const void *Subject::Get() const
00293 {
00294     return m_subject;
00295 }
00296
00297 } // namespace Activ
00298
00299 #endif // (!defined ACTIV_SYSTEM_SUBJECT_H)
Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivFramework

Subjects.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FRAMEWORK_SUBJECTS_H)
00010 #define ACTIV_FRAMEWORK_SUBJECTS_H
00011
00012 #include "ActivMiddleware/ActivSystem/Subject.h"
00013
00014 namespace Activ
00015 {
00016
00020 class EndPointSubject : public Subject
00021 {
00022 public:
00026     EndPointSubject();
00027 };
00028
00029 // ---------------------------------------------------------------------------------------------------------------------------------
00030
00031 inline EndPointSubject::EndPointSubject() :
00032     Subject("/system/endpoint")
00033 {
00034 }
00035
00036 // ---------------------------------------------------------------------------------------------------------------------------------
00037 // ---------------------------------------------------------------------------------------------------------------------------------
00038
00042 class ShutdownSubject : public Subject
00043 {
00044 public:
00048     ShutdownSubject();
00049 };
00050
00051 // ---------------------------------------------------------------------------------------------------------------------------------
00052
00053 inline ShutdownSubject::ShutdownSubject() :
00054     Subject("/system/shutdown")
00055 {
00056 }
00057
00058 } // namespace Activ
00059
00060 #endif // (!defined ACTIV_FRAMEWORK_SUBJECTS_H)
Generated on Wed Oct 8 14:01:48 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » Config » Compilers

SunPro.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_CONFIG_COMPILERS_SUN_PRO_H)
00010 #define ACTIV_CONFIG_COMPILERS_SUN_PRO_H
00011
00012 #if (__SUNPRO_CC < 0x580)
00013 #error SunPro version not supported
00014 #endif
00015
00016 #define ACTIV_COMPILER_NAME "SunPro C++ version " ACTIV_STRINGIZE(__SUNPRO_CC)
00017
00018 #define ACTIV_BUILDING_DLL_EXPORTED_API
00019 #define ACTIV_BUILDING_DLL_INLINE_API
00020 #define ACTIV_BUILDING_DLL_LOCAL_API
00021 #define ACTIV_USING_DLL_EXPORTED_API
00022 #define ACTIV_USING_DLL_INLINE_API
00023 #define ACTIV_USING_DLL_LOCAL_API
00024
00025 #define ACTIV_BUILDING_LIB_EXPORTED_API
00026 #define ACTIV_BUILDING_LIB_INLINE_API
00027 #define ACTIV_BUILDING_LIB_LOCAL_API
00028 #define ACTIV_USING_LIB_EXPORTED_API
00029 #define ACTIV_USING_LIB_INLINE_API
00030 #define ACTIV_USING_LIB_LOCAL_API
00031
00040 #define ACTIV_DECLARE_UNINITIALIZED_VARIABLE(type, name, dummyValue) type name
00041
00056 #define ACTIV_TEMPLATE_API(a)
00057
00073 #define ACTIV_TEMPLATE_SELF typename
00074
00078 #define ACTIV_FORCE_INLINE  inline
00079
00083 #define ACTIV_NEVER_INLINE
00084
00085 #define _XPG4_2
00086 #define __EXTENSIONS__
00087 #define _POSIX_PTHREAD_SEMANTICS
00088
00089 #define __FUNCTION__    __func__
00090
00091 #define stricmp         strcasecmp
00092 #define strnicmp        strncasecmp
00093
00094 #endif // (!defined ACTIV_CONFIG_COMPILERS_SUN_PRO_H)
Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedMessageHandler

Symbol.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FEED_MESSAGE_HANDLER_SYMBOL_H)
00010 #define ACTIV_FEED_MESSAGE_HANDLER_SYMBOL_H
00011
00012 #include "ActivMiddleware/Misc/MemoryHelper.h"
00013
00014 #include <string>
00015
00016 namespace Activ
00017 {
00018
00019 class MessageValidator;
00020
00021 namespace ContentPlatform
00022 {
00023
00024 namespace Feed
00025 {
00026
00030 class Symbol
00031 {
00032 public:
00042     static void Serialize(byte_t *&pMessage, const std::string &symbol);
00043
00054     static StatusCode Deserialize(MessageValidator &messageValidator, const size_t maxSymbolLength, std::string &symbol);
00055 };
00056
00057 // ---------------------------------------------------------------------------------------------------------------------------------
00058
00059 inline void Symbol::Serialize(byte_t *&pMessage, const std::string &symbol)
00060 {
00061     const uint8_t symbolLength = static_cast<uint8_t>(symbol.size());
00062
00063     *pMessage = symbolLength;
00064     ++pMessage;
00065
00066     MemoryCopy(pMessage, symbol.c_str(), symbolLength);
00067     pMessage += symbolLength;
00068 }
00069
00070 // ---------------------------------------------------------------------------------------------------------------------------------
00071
00072 inline StatusCode Symbol::Deserialize(MessageValidator &messageValidator, const size_t maxSymbolLength, std::string &symbol)
00073 {
00074     uint8_t symbolLength;
00075     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, (messageValidator.ValidateBinaryIntegral<sizeof(symbolLength), MessageValidator::ENDIAN_LITTLE, uint8_t>(1, maxSymbolLength, symbolLength)));
00076
00077     const void *pSymbol;
00078     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, messageValidator.ValidateBytes(symbolLength, &pSymbol));
00079
00080     symbol.assign(reinterpret_cast<const char *>(pSymbol), symbolLength);
00081
00082     return STATUS_CODE_SUCCESS;
00083 }
00084
00085 // ---------------------------------------------------------------------------------------------------------------------------------
00086
00087 } // namespace Feed
00088
00089 } // namespace ContentPlatform
00090
00091 } // namespace Activ
00092
00093 #endif // (!defined ACTIV_FEED_MESSAGE_HANDLER_SYMBOL_H)
Generated on Wed Oct 8 14:01:46 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivContentGatewayApi

SymbolDirectoryRequestHelper.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_CONTENT_GATEWAY_API_SYMBOL_DIRECTORY_REQUEST_HELPER_H)
00010 #define ACTIV_CONTENT_GATEWAY_API_SYMBOL_DIRECTORY_REQUEST_HELPER_H
00011
00012 #include "ActivContentPlatform/ActivContentGatewayApi/External.h"
00013
00014 namespace Activ
00015 {
00016
00017 namespace ContentPlatform
00018 {
00019
00020 namespace ContentGatewayApi
00021 {
00022
00023 class ContentGatewayClient;
00024
00025 // ---------------------------------------------------------------------------------------------------------------------------------
00026
00030 class SymbolDirectoryRequestHelper
00031 {
00032 public:
00033     typedef SymbolDirectoryRequestParameters RequestParameters;
00034     typedef SymbolDirectoryResponseParameters ResponseParameters;
00035
00049     ACTIV_CONTENT_GATEWAY_API static StatusCode SendRequest(const ContentGatewayClient &client,
00050         const RequestParameters &requestParameters, ResponseParameters &responseParameters,
00051         const TimeoutPeriod timeoutPeriod = Port::defaultTimeout);
00052
00064     ACTIV_CONTENT_GATEWAY_API static StatusCode SendRequest(const ContentGatewayClient &client, SyncRequestId &syncRequestId,
00065         const RequestParameters &requestParameters);
00066
00078     ACTIV_CONTENT_GATEWAY_API static StatusCode PostRequest(const ContentGatewayClient &client, const RequestId &requestId,
00079         const RequestParameters &requestParameters);
00080
00094     ACTIV_CONTENT_GATEWAY_API static StatusCode GetResponse(const ContentGatewayClient &client, SyncRequestId &syncRequestId,
00095         ResponseParameters &responseParameters, const TimeoutPeriod timeoutPeriod);
00096
00109     ACTIV_CONTENT_GATEWAY_API static StatusCode Deserialize(const ContentGatewayClient &client, const HeapMessage &response,
00110         ResponseParameters &responseParameters);
00111 };
00112
00113 } // namespace ContentGatewayApi
00114
00115 } // namespace ContentPlatform
00116
00117 } // namespace Activ
00118
00119 #endif // (!defined ACTIV_CONTENT_GATEWAY_API_SYMBOL_DIRECTORY_REQUEST_HELPER_H)
Generated on Wed Oct 8 14:01:45 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivContentGatewayApiCommon

SymbolDirectoryTypes.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_CONTENT_GATEWAY_API_COMMON_SYMBOL_DIRECTORY_TYPES_H)
00010 #define ACTIV_CONTENT_GATEWAY_API_COMMON_SYMBOL_DIRECTORY_TYPES_H
00011
00012 #include "ActivContentPlatform/ActivContentGatewayApiCommon/External.h"
00013 #include "ActivContentPlatform/ActivContentGatewayApiCommon/Types.h"
00014 #include "ActivContentPlatform/ActivFeedCommon/EntityTypes.h"
00015
00016 namespace Activ
00017 {
00018
00019 namespace ContentPlatform
00020 {
00021
00022 namespace ContentGatewayApi
00023 {
00024
00025 #define ACTIV_DECLARE_FLAGS(value, id)  static const Flags id = value;
00026
00027 // ---------------------------------------------------------------------------------------------------------------------------------
00028
00032 class SymbolDirectoryRequestParameters
00033 {
00034 public:
00038     ACTIV_CONTENT_GATEWAY_API_COMMON_API SymbolDirectoryRequestParameters();
00039
00048     ACTIV_CONTENT_GATEWAY_API_COMMON_API StatusCode Serialize(MessageBuilder &messageBuilder) const;
00049
00058     ACTIV_CONTENT_GATEWAY_API_COMMON_API StatusCode Deserialize(MessageValidator &messageValidator);
00059
00060     typedef std::vector<Feed::EntityType>   EntityTypeList;
00061
00062     #define SYMBOL_DIRECTORY_FILTER_TYPE_LIST(d)                                                                                    \
00063         d(FILTER_TYPE_FULL)                                                                                         \
00064         d(FILTER_TYPE_ENTITY_TYPE_INCLUDE_LIST)                                 \
00065         d(FILTER_TYPE_ENTITY_TYPE_EXCLUDE_LIST)
00067     enum FilterType
00068     {
00069         SYMBOL_DIRECTORY_FILTER_TYPE_LIST(ACTIV_DECLARE_VALUE_WITH_COMMA)
00070         NUMBER_OF_FILTER_TYPES
00071     };
00072
00073     #define SYMBOL_DIRECTORY_MATCH_TYPE_LIST(d)                                                         \
00074         d(MATCH_TYPE_ANY)                                                       \
00075         d(MATCH_TYPE_EXACT)
00077     enum MatchType
00078     {
00079         SYMBOL_DIRECTORY_MATCH_TYPE_LIST(ACTIV_DECLARE_VALUE_WITH_COMMA)
00080         NUMBER_OF_MATCH_TYPES
00081     };
00082
00083     Feed::FieldId       m_fieldId;
00084     std::string         m_searchString;
00085     FilterType          m_filterType;
00086     MatchType           m_matchType;
00087     EntityTypeList      m_entityTypeList;
00088
00089 private:
00090     typedef SerializableObjectContainerHelper<EntityTypeList, uint16_t, 0> EntityTypeListSerializer;
00091 };
00092
00093 // ---------------------------------------------------------------------------------------------------------------------------------
00094 // ---------------------------------------------------------------------------------------------------------------------------------
00095
00099 class SymbolResponse
00100 {
00101 public:
00109     bool SameAsLastCheck(const SymbolResponse &symbolResponse) const;
00110
00111     #define ACTIV_SYMBOL_RESPONSE_FLAG_LIST(d)                                                                      \
00112         d(0x0000,   FLAG_NONE)                                                                                      \
00113         d(0x0001,   FLAG_SAME_AS_LAST)
00115     typedef uint16_t Flags;
00116     ACTIV_SYMBOL_RESPONSE_FLAG_LIST(ACTIV_DECLARE_FLAGS)
00117
00118     SymbolId            m_symbolId;
00119     Flags               m_flags;
00120     std::string         m_matchData;
00121     Feed::EntityType    m_entityType;
00122 };
00123
00124 // ---------------------------------------------------------------------------------------------------------------------------------
00125
00126 inline bool SymbolResponse::SameAsLastCheck(const SymbolResponse &symbolResponse) const
00127 {
00128     return (((m_flags & FLAG_SAME_AS_LAST) == FLAG_SAME_AS_LAST) || (m_matchData == symbolResponse.m_matchData));
00129 }
00130
00131 // ---------------------------------------------------------------------------------------------------------------------------------
00132 // ---------------------------------------------------------------------------------------------------------------------------------
00133
00137 class SymbolDirectoryResponseParameters
00138 {
00139 public:
00140     typedef std::vector<SymbolResponse> SymbolResponseList;
00141
00145     ACTIV_CONTENT_GATEWAY_API_COMMON_API void Clear();
00146
00155     ACTIV_CONTENT_GATEWAY_API_COMMON_API StatusCode Serialize(MessageBuilder &messageBuilder) const;
00156
00165     ACTIV_CONTENT_GATEWAY_API_COMMON_API StatusCode Deserialize(MessageValidator &messageValidator);
00166
00167     Feed::FieldId           m_fieldId;
00168     SymbolResponseList      m_symbolResponseList;
00169 };
00170
00171 #undef ACTIV_DECLARE_FLAGS
00172
00173 } // namespace ContentGatewayApi
00174
00175 } // namespace ContentPlatform
00176
00177 } // namespace Activ
00178
00179 #endif // (!defined ACTIV_CONTENT_GATEWAY_API_COMMON_SYMBOL_DIRECTORY_TYPES_H)
Generated on Wed Oct 8 14:01:45 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivContentServerApi

SymbolPatternHelper.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_CONTENT_SERVER_API_SYMBOL_PATTERN_HELPER_H)
00010 #define ACTIV_CONTENT_SERVER_API_SYMBOL_PATTERN_HELPER_H
00011
00012 #include "ActivContentPlatform/ActivContentServerApi/External.h"
00013
00014 #include "boost/shared_ptr.hpp"
00015
00016 namespace Activ
00017 {
00018
00019 namespace ContentPlatform
00020 {
00021
00022 namespace FeedApi
00023 {
00024
00025 class SymbolPattern;
00026
00027 // ---------------------------------------------------------------------------------------------------------------------------------
00028
00034 class SymbolPatternHelper
00035 {
00036 public:
00040     ACTIV_CONTENT_SERVER_API SymbolPatternHelper();
00041
00045     ACTIV_CONTENT_SERVER_API virtual ~SymbolPatternHelper();
00046
00055     ACTIV_CONTENT_SERVER_API StatusCode Initialize(const std::string &pattern);
00056
00065     ACTIV_CONTENT_SERVER_API bool IsMatch(const std::string &str, const size_t fromPart) const;
00066
00072     ACTIV_CONTENT_SERVER_API bool IsPattern() const;
00073
00074 private:
00075     boost::shared_ptr <SymbolPattern>   m_pSymbolPattern;
00076 };
00077
00078 } // namespace FeedApi
00079
00080 } // namespace ContentPlatform
00081
00082 } // namespace Activ
00083
00084 #endif // (!defined ACTIV_CONTENT_SERVER_API_SYMBOL_PATTERN_HELPER_H)
Generated on Wed Oct 8 14:01:45 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedMessageHandler

SymbolRecordField.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FEED_MESSAGE_HANDLER_SYMBOL_RECORD_FIELD_H)
00010 #define ACTIV_FEED_MESSAGE_HANDLER_SYMBOL_RECORD_FIELD_H
00011
00012 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/External.h"
00013 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/SymbolRecordRuleDefinitions.h"
00014
00015 #include <vector>
00016 #include <iomanip>
00017
00018 namespace Activ
00019 {
00020
00021 class MessageValidator;
00022 class IFieldType;
00023
00024 namespace ContentPlatform
00025 {
00026
00027 namespace Feed
00028 {
00029
00030 class Field;
00031
00032 // ---------------------------------------------------------------------------------------------------------------------------------
00033
00037 class SymbolRecordField
00038 {
00039 public:
00043     class PartialUpdate
00044     {
00045     public:
00049         PartialUpdate(const uint8_t offset = 0, const uint8_t value = 0);
00050
00051         uint8_t         m_offset;
00052         uint8_t         m_value;
00053     };
00054     typedef std::vector<PartialUpdate> PartialBitUpdateList;
00055     typedef std::vector<PartialUpdate> PartialByteUpdateList;
00056
00060     ACTIV_FEED_MESSAGE_HANDLER_API SymbolRecordField();
00061
00073     ACTIV_FEED_MESSAGE_HANDLER_API SymbolRecordField(const Field &field, const bool isComposite, const uint8_t defaultRuleSet, const bool isFieldRulesPresent, MessageValidator &messageValidator);
00074
00078     ACTIV_FEED_MESSAGE_HANDLER_API ~SymbolRecordField();
00079
00094     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Initialize(const Field &field, const bool isComposite, const uint8_t defaultRuleSet, const bool isFieldRulesPresent, MessageValidator &messageValidator);
00095
00101     void InitializeUndefined(const Field &field);
00102
00106     ACTIV_FEED_MESSAGE_HANDLER_API void Reset();
00107
00116     StatusCode GetRuleSet(uint8_t &ruleSet) const;
00117
00126     StatusCode GetFieldRules(uint8_t &fieldRules) const;
00127
00137     StatusCode GetCompositeFieldRules(uint8_t &compositeFieldRules) const;
00138
00148     StatusCode GetField(const IFieldType *&pIFieldType) const;
00149
00159     StatusCode GetPartialBitUpdateList(const PartialBitUpdateList *&pPartialBitUpdateList) const;
00160
00166     bool IsInitialized() const;
00167
00173     bool IsDefined() const;
00174
00180     bool IsComposite() const;
00181
00187     ACTIV_FEED_MESSAGE_HANDLER_API static std::string FieldIdToString(const FieldId &fieldId);
00188
00194     ACTIV_FEED_MESSAGE_HANDLER_API static std::string FieldNameToString(const Field *pField);
00195
00201     ACTIV_FEED_MESSAGE_HANDLER_API static std::string ContentsPrefixToString();
00202
00208     ACTIV_FEED_MESSAGE_HANDLER_API static std::string UndefinedFieldContentsToString();
00209
00215     ACTIV_FEED_MESSAGE_HANDLER_API std::string RuleSetToString() const;
00216
00222     ACTIV_FEED_MESSAGE_HANDLER_API std::string FieldRulesToString() const;
00223
00229     ACTIV_FEED_MESSAGE_HANDLER_API std::string CompositeFieldRulesToString() const;
00230
00236     ACTIV_FEED_MESSAGE_HANDLER_API std::string FieldContentsToString() const;
00237
00243     ACTIV_FEED_MESSAGE_HANDLER_API std::string PartialUpdateToString(PartialUpdate &partialUpdate) const;
00244
00250     ACTIV_FEED_MESSAGE_HANDLER_API std::string ToString() const;
00251
00252 private:
00258     SymbolRecordField(const SymbolRecordField &rhs);
00259
00267     SymbolRecordField& operator=(const SymbolRecordField &rhs);
00268
00269     bool                            m_isInitialized;
00270     bool                            m_isDefined;
00271     bool                            m_isComposite;
00272     uint8_t                         m_ruleSet;
00273     uint8_t                         m_fieldRules;
00274     uint8_t                         m_compositeFieldRules;
00275     IFieldType                      *m_pIFieldType;
00276     std::vector<PartialUpdate>      m_partialUpdateList;
00277 };
00278
00279 // ---------------------------------------------------------------------------------------------------------------------------------
00280
00281 inline void SymbolRecordField::InitializeUndefined(const Field &field)
00282 {
00283     m_isDefined = false;
00284     m_isInitialized = true;
00285
00286     ACTIV_ENHANCED_DEBUG_ONLY(std::cout << UndefinedFieldContentsToString() << std::endl;);
00287 }
00288
00289 // ---------------------------------------------------------------------------------------------------------------------------------
00290
00291 inline StatusCode SymbolRecordField::GetRuleSet(uint8_t &ruleSet) const
00292 {
00293     if (!IsInitialized())
00294         return STATUS_CODE_NOT_INITIALIZED;
00295
00296     ruleSet = m_ruleSet;
00297
00298     return STATUS_CODE_SUCCESS;
00299 }
00300
00301 // ---------------------------------------------------------------------------------------------------------------------------------
00302
00303 inline StatusCode SymbolRecordField::GetFieldRules(uint8_t &fieldRules) const
00304 {
00305     if (!IsInitialized())
00306         return STATUS_CODE_NOT_INITIALIZED;
00307
00308     fieldRules = m_fieldRules;
00309
00310     return STATUS_CODE_SUCCESS;
00311 }
00312
00313 // ---------------------------------------------------------------------------------------------------------------------------------
00314
00315 inline StatusCode SymbolRecordField::GetCompositeFieldRules(uint8_t &compositeFieldRules) const
00316 {
00317     if (!IsInitialized())
00318         return STATUS_CODE_NOT_INITIALIZED;
00319
00320     if (!IsComposite())
00321         return STATUS_CODE_FAILURE;
00322
00323     compositeFieldRules = m_compositeFieldRules;
00324
00325     return STATUS_CODE_SUCCESS;
00326 }
00327
00328 // ---------------------------------------------------------------------------------------------------------------------------------
00329
00330 inline StatusCode SymbolRecordField::GetField(const IFieldType *&pIFieldType) const
00331 {
00332     if (!IsInitialized())
00333         return STATUS_CODE_NOT_INITIALIZED;
00334
00335     switch (m_ruleSet)
00336     {
00337         case SymbolRecordRuleDefinitions::RULE_SET_NONE:
00338         case SymbolRecordRuleDefinitions::RULE_SET_TRANSLATOR:
00339         case SymbolRecordRuleDefinitions::RULE_SET_CONTENT_SERVER:
00340             pIFieldType = m_pIFieldType;
00341             break;
00342
00343         default:
00344             return STATUS_CODE_FAILURE;
00345     }
00346
00347     return STATUS_CODE_SUCCESS;
00348 }
00349
00350 // ---------------------------------------------------------------------------------------------------------------------------------
00351
00352 inline StatusCode SymbolRecordField::GetPartialBitUpdateList(const PartialBitUpdateList *&pPartialBitUpdateList) const
00353 {
00354     if (!IsInitialized())
00355         return STATUS_CODE_NOT_INITIALIZED;
00356
00357     if (SymbolRecordRuleDefinitions::RULE_SET_PARTIAL_BIT_UPDATE != m_ruleSet)
00358         return STATUS_CODE_FAILURE;
00359
00360     pPartialBitUpdateList = &m_partialUpdateList;
00361
00362     return STATUS_CODE_SUCCESS;
00363 }
00364
00365 // ---------------------------------------------------------------------------------------------------------------------------------
00366
00367 inline bool SymbolRecordField::IsInitialized() const
00368 {
00369     return (m_isInitialized);
00370 }
00371
00372 // ---------------------------------------------------------------------------------------------------------------------------------
00373
00374 inline bool SymbolRecordField::IsDefined() const
00375 {
00376     return (IsInitialized() && m_isDefined);
00377 }
00378
00379 // ---------------------------------------------------------------------------------------------------------------------------------
00380
00381 inline bool SymbolRecordField::IsComposite() const
00382 {
00383     return (IsInitialized() && m_isComposite);
00384 }
00385
00386 } // namespace Feed
00387
00388 } // namespace ContentPlatform
00389
00390 } // namespace Activ
00391
00392 #endif // (!defined ACTIV_FEED_MESSAGE_HANDLER_SYMBOL_RECORD_FIELD_H)
Generated on Wed Oct 8 14:01:46 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedMessageHandler

SymbolRecordFieldHeaderDefinitions.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FEED_MESSAGE_HANDLER_SYMBOL_RECORD_FIELD_HEADER_DEFINITIONS_H)
00010 #define ACTIV_FEED_MESSAGE_HANDLER_SYMBOL_RECORD_FIELD_HEADER_DEFINITIONS_H
00011
00012 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/FieldHeaderDefinitions.h"
00013
00014 namespace Activ
00015 {
00016
00017 namespace ContentPlatform
00018 {
00019
00020 namespace Feed
00021 {
00022
00026 class SymbolRecordFieldHeaderDefinitions : public FieldHeaderDefinitions
00027 {
00028 public:
00029     static const size_t FIELD_RULES_PRESENT_OFFSET  = FIELD_RESERVED_OFFSET;
00030     static const size_t FIELD_RULES_PRESENT_LENGTH  = FIELD_RESERVED_LENGTH;
00031
00041     static FieldHeader GetFieldHeader(const FieldId fieldId, const bool isFieldDefined, const bool isFieldRulesPresent = false);
00042
00050     static bool IsFieldRulesPresent(const FieldHeader fieldHeader);
00051 };
00052
00053 // ---------------------------------------------------------------------------------------------------------------------------------
00054
00055 inline SymbolRecordFieldHeaderDefinitions::FieldHeader SymbolRecordFieldHeaderDefinitions::GetFieldHeader(const FieldId fieldId, const bool isFieldDefined, const bool isFieldRulesPresent)
00056 {
00057     return FieldHeaderDefinitions::GetFieldHeader(fieldId, isFieldDefined) | (isFieldRulesPresent << ((sizeof(FieldHeader) * CHAR_BIT) - (FIELD_RULES_PRESENT_OFFSET + FIELD_RULES_PRESENT_LENGTH)));
00058 }
00059
00060 // ---------------------------------------------------------------------------------------------------------------------------------
00061
00062 inline bool SymbolRecordFieldHeaderDefinitions::IsFieldRulesPresent(const FieldHeader fieldHeader)
00063 {
00064     return (((fieldHeader >> ((sizeof(FieldHeader) * CHAR_BIT) - (FIELD_RULES_PRESENT_OFFSET + FIELD_RULES_PRESENT_LENGTH))) & ((1 << FIELD_RULES_PRESENT_LENGTH) - 1)) != 0);
00065 }
00066
00067 } // namespace Feed
00068
00069 } // namespace ContentPlatform
00070
00071 } // namespace Activ
00072
00073 #endif // (!defined ACTIV_FEED_MESSAGE_HANDLER_SYMBOL_RECORD_FIELD_HEADER_DEFINITIONS_H)
Generated on Wed Oct 8 14:01:46 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedMessageHandler

SymbolRecordFieldListBuilder.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FEED_MESSAGE_HANDLER_SYMBOL_RECORD_FIELD_LIST_BUILDER_H)
00010 #define ACTIV_FEED_MESSAGE_HANDLER_SYMBOL_RECORD_FIELD_LIST_BUILDER_H
00011
00012 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/External.h"
00013
00014 namespace Activ
00015 {
00016
00017 class MessageBuilder;
00018 class IFieldType;
00019
00020 namespace ContentPlatform
00021 {
00022
00023 namespace Feed
00024 {
00025
00026 class TableTemplate;
00027
00028 // ---------------------------------------------------------------------------------------------------------------------------------
00029
00033 class SymbolRecordFieldListBuilder
00034 {
00035 public:
00039     ACTIV_FEED_MESSAGE_HANDLER_API SymbolRecordFieldListBuilder();
00040
00049     ACTIV_FEED_MESSAGE_HANDLER_API SymbolRecordFieldListBuilder(const TableTemplate &tableTemplate, const bool isComposite, const uint8_t defaultRuleSet, MessageBuilder &messageBuilder);
00050
00054     ACTIV_FEED_MESSAGE_HANDLER_API ~SymbolRecordFieldListBuilder();
00055
00064     ACTIV_FEED_MESSAGE_HANDLER_API void Initialize(const TableTemplate &tableTemplate, const bool isComposite, const uint8_t defaultRuleSet, MessageBuilder &messageBuilder);
00065
00069     ACTIV_FEED_MESSAGE_HANDLER_API void Reset();
00070
00074     ACTIV_FEED_MESSAGE_HANDLER_API void Clear();
00075
00087     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode AppendField(const FieldId fieldId, const IFieldType &iFieldType);
00088
00101     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode AppendField(const FieldId fieldId, const void * const pSerializedBody, const size_t serializedBodyLength);
00102
00114     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode AppendFieldWithNoneRuleSet(const FieldId fieldId, const IFieldType &iFieldType);
00115
00128     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode AppendFieldWithNoneRuleSet(const FieldId fieldId, const void * const pSerializedBody, const size_t serializedBodyLength);
00129
00142     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode AppendFieldWithTranslatorRuleSet(const FieldId fieldId, const uint8_t fieldRules, const IFieldType &iFieldType);
00143
00157     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode AppendFieldWithTranslatorRuleSet(const FieldId fieldId, const uint8_t fieldRules, const void * const pSerializedBody, const size_t serializedBodyLength);
00158
00172     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode AppendFieldWithTranslatorRuleSet(const FieldId fieldId, const uint8_t fieldRules, const uint8_t compositeFieldRules, const IFieldType &iFieldType);
00173
00188     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode AppendFieldWithTranslatorRuleSet(const FieldId fieldId, const uint8_t fieldRules, const uint8_t compositeFieldRules, const void * const pSerializedBody, const size_t serializedBodyLength);
00189
00202     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode AppendFieldWithContentServerRuleSet(const FieldId fieldId, const uint8_t fieldRules, const IFieldType &iFieldType);
00203
00217     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode AppendFieldWithContentServerRuleSet(const FieldId fieldId, const uint8_t fieldRules, const void * const pSerializedBody, const size_t serializedBodyLength);
00218
00232     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode AppendFieldWithContentServerRuleSet(const FieldId fieldId, const uint8_t fieldRules, const uint8_t compositeFieldRules, const IFieldType &iFieldType);
00233
00248     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode AppendFieldWithContentServerRuleSet(const FieldId fieldId, const uint8_t fieldRules, const uint8_t compositeFieldRules, const void * const pSerializedBody, const size_t serializedBodyLength);
00249
00259     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode AppendUndefinedField(const FieldId fieldId);
00260
00266     ACTIV_FEED_MESSAGE_HANDLER_API bool IsInitialized() const;
00267
00268 private:
00269     typedef std::vector<IFieldType *>       CachedFieldList;
00270
00276     SymbolRecordFieldListBuilder(const SymbolRecordFieldListBuilder &rhs);
00277
00285     SymbolRecordFieldListBuilder& operator=(const SymbolRecordFieldListBuilder &rhs);
00286
00297     StatusCode GetConvertedField(const FieldType fieldType, const IFieldType &iFieldType, const IFieldType *&pConvertedField);
00298
00311     static StatusCode AppendSerializedBody(const Field * const pField, const void * const pSerializedBody, const size_t serializedBodyLength, MessageBuilder &messageBuilder);
00312
00313     CachedFieldList         m_cachedFieldList;
00314
00315     const TableTemplate     *m_pTableTemplate;
00316     MessageBuilder          *m_pMessageBuilder;
00317     bool                    m_isComposite;
00318     uint8_t                 m_defaultRuleSet;
00319 };
00320
00321 } // namespace Feed
00322
00323 } // namespace ContentPlatform
00324
00325 } // namespace Activ
00326
00327 #endif // (!defined ACTIV_FEED_MESSAGE_HANDLER_SYMBOL_RECORD_FIELD_LIST_BUILDER_H)
Generated on Wed Oct 8 14:01:46 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedMessageHandler

SymbolRecordFieldListValidator.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FEED_MESSAGE_HANDLER_SYMBOL_RECORD_FIELD_LIST_VALIDATOR_H)
00010 #define ACTIV_FEED_MESSAGE_HANDLER_SYMBOL_RECORD_FIELD_LIST_VALIDATOR_H
00011
00012 #include "ActivContentPlatform/ActivFeedCommon/FieldIds.h"
00013
00014 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/External.h"
00015 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/SymbolRecordField.h"
00016
00017 #include "boost/dynamic_bitset.hpp"
00018
00019 #include <vector>
00020
00021 namespace Activ
00022 {
00023
00024 class MessageValidator;
00025
00026 namespace ContentPlatform
00027 {
00028
00029 namespace Feed
00030 {
00031
00032 class TableTemplate;
00033 class SymbolRecordField;
00034 class SymbolRecordMessageHeaderValidator;
00035
00036 // ---------------------------------------------------------------------------------------------------------------------------------
00037
00041 class SymbolRecordFieldListValidator
00042 {
00043 public:
00047     class ConstIterator
00048     {
00049     public:
00053         ConstIterator();
00054
00060         ConstIterator &operator++();
00061
00067         const ConstIterator operator++(int);
00068
00076         bool operator==(const ConstIterator &rhs) const;
00077
00085         bool operator!=(const ConstIterator &rhs) const;
00086
00092         FieldId GetFieldId() const;
00093
00099         const SymbolRecordField *GetSymbolRecordField() const;
00100
00101     private:
00108         ConstIterator(const SymbolRecordFieldListValidator *pSymbolRecordFieldListValidator, const FieldIdList::const_iterator &iterator);
00109
00110         const SymbolRecordFieldListValidator    *m_pSymbolRecordFieldListValidator;
00111         FieldIdList::const_iterator             m_iterator;
00112
00113         friend class SymbolRecordFieldListValidator;
00114     };
00115
00119     ACTIV_FEED_MESSAGE_HANDLER_API SymbolRecordFieldListValidator();
00120
00132     ACTIV_FEED_MESSAGE_HANDLER_API SymbolRecordFieldListValidator(const TableTemplate &tableTemplate, const bool isComposite, const uint8_t defaultRuleSet, MessageValidator &messageValidator, const bool shouldIgnoreUndefinedMissingFields = false);
00133
00143     ACTIV_FEED_MESSAGE_HANDLER_API SymbolRecordFieldListValidator(const SymbolRecordMessageHeaderValidator &symbolRecordMessageHeaderValidator, MessageValidator &messageValidator, const bool shouldIgnoreUndefinedMissingFields = false);
00144
00148     ACTIV_FEED_MESSAGE_HANDLER_API ~SymbolRecordFieldListValidator();
00149
00164     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Initialize(const TableTemplate &tableTemplate, const bool isComposite, const uint8_t defaultRuleSet, MessageValidator &messageValidator, const bool shouldIgnoreUndefinedMissingFields = false);
00165
00179     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Initialize(const SymbolRecordMessageHeaderValidator &symbolRecordMessageHeaderValidator, MessageValidator &messageValidator, const bool shouldIgnoreUndefinedMissingFields = false);
00180
00184     ACTIV_FEED_MESSAGE_HANDLER_API void Reset();
00185
00189     ACTIV_FEED_MESSAGE_HANDLER_API void Clear();
00190
00201     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode GetSymbolRecordField(const FieldId fieldId, const SymbolRecordField *&pSymbolRecordField) const;
00202
00208     ACTIV_FEED_MESSAGE_HANDLER_API bool IsInitialized() const;
00209
00217     ACTIV_FEED_MESSAGE_HANDLER_API ConstIterator Begin() const;
00218
00226     ACTIV_FEED_MESSAGE_HANDLER_API ConstIterator End() const;
00227
00233     ACTIV_FEED_MESSAGE_HANDLER_API std::string ToString() const;
00234
00235 private:
00236     typedef boost::dynamic_bitset<>             FieldIdPresentBitmap;
00237     typedef std::vector<SymbolRecordField *>    CachedSymbolRecordFieldList;
00238
00244     SymbolRecordFieldListValidator(const SymbolRecordFieldListValidator &rhs);
00245
00253     SymbolRecordFieldListValidator& operator=(const SymbolRecordFieldListValidator &rhs);
00254
00265     StatusCode GetSymbolRecordField(const FieldId fieldId, SymbolRecordField *&pSymbolRecordField) const;
00266
00274     const SymbolRecordField *GetCachedField(const FieldId fieldId) const;
00275
00276     const TableTemplate         *m_pTableTemplate;
00277
00278     bool                        m_isInitialized;
00279     FieldIdList                 m_fieldIdList;
00280     FieldIdPresentBitmap        m_fieldIdPresentBitmap;
00281     CachedSymbolRecordFieldList m_cachedSymbolRecordFieldList;
00282 };
00283
00284 // ---------------------------------------------------------------------------------------------------------------------------------
00285
00286 inline const SymbolRecordField *SymbolRecordFieldListValidator::GetCachedField(const FieldId fieldId) const
00287 {
00288     const SymbolRecordField *pSymbolRecordField = m_cachedSymbolRecordFieldList[fieldId];
00289     return (((0 != pSymbolRecordField) && pSymbolRecordField->IsDefined()) ? pSymbolRecordField : 0);
00290 }
00291
00292 // ---------------------------------------------------------------------------------------------------------------------------------
00293 // ---------------------------------------------------------------------------------------------------------------------------------
00294
00295 inline SymbolRecordFieldListValidator::ConstIterator::ConstIterator() :
00296     m_pSymbolRecordFieldListValidator(0)
00297 {
00298 }
00299
00300 // ---------------------------------------------------------------------------------------------------------------------------------
00301
00302 inline SymbolRecordFieldListValidator::ConstIterator &SymbolRecordFieldListValidator::ConstIterator::operator++()
00303 {
00304     ++m_iterator;
00305
00306     return *this;
00307 }
00308
00309 // ---------------------------------------------------------------------------------------------------------------------------------
00310
00311 inline const SymbolRecordFieldListValidator::ConstIterator SymbolRecordFieldListValidator::ConstIterator::operator++(int)
00312 {
00313     ConstIterator oldValue = *this;
00314
00315     ++(*this);
00316
00317     return oldValue;
00318 }
00319
00320 // ---------------------------------------------------------------------------------------------------------------------------------
00321
00322 inline bool SymbolRecordFieldListValidator::ConstIterator::operator==(const SymbolRecordFieldListValidator::ConstIterator &rhs) const
00323 {
00324     return ((m_pSymbolRecordFieldListValidator == rhs.m_pSymbolRecordFieldListValidator) && (m_iterator == rhs.m_iterator));
00325 }
00326
00327 // ---------------------------------------------------------------------------------------------------------------------------------
00328
00329 inline bool SymbolRecordFieldListValidator::ConstIterator::operator!=(const SymbolRecordFieldListValidator::ConstIterator &rhs) const
00330 {
00331     return !((*this) == rhs);
00332 }
00333
00334 // ---------------------------------------------------------------------------------------------------------------------------------
00335
00336 inline FieldId SymbolRecordFieldListValidator::ConstIterator::GetFieldId() const
00337 {
00338     return *m_iterator;
00339 }
00340
00341 // ---------------------------------------------------------------------------------------------------------------------------------
00342
00343 inline const SymbolRecordField *SymbolRecordFieldListValidator::ConstIterator::GetSymbolRecordField() const
00344 {
00345     return m_pSymbolRecordFieldListValidator->GetCachedField(*m_iterator);
00346 }
00347
00348 // ---------------------------------------------------------------------------------------------------------------------------------
00349
00350 inline SymbolRecordFieldListValidator::ConstIterator::ConstIterator(const SymbolRecordFieldListValidator *pSymbolRecordFieldListValidator, const FieldIdList::const_iterator &iterator) :
00351     m_pSymbolRecordFieldListValidator(pSymbolRecordFieldListValidator),
00352     m_iterator(iterator)
00353 {
00354 }
00355
00356 } // namespace Feed
00357
00358 } // namespace ContentPlatform
00359
00360 } // namespace Activ
00361
00362 #endif // (!defined ACTIV_FEED_MESSAGE_HANDLER_SYMBOL_RECORD_FIELD_LIST_VALIDATOR_H)
Generated on Wed Oct 8 14:01:46 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedMessageHandler

SymbolRecordMessageBuilder.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FEED_MESSAGE_HANDLER_SYMBOL_RECORD_MESSAGE_BUILDER_H)
00010 #define ACTIV_FEED_MESSAGE_HANDLER_SYMBOL_RECORD_MESSAGE_BUILDER_H
00011
00012 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/TableTemplateList.h"
00013
00014 #include "ActivContentPlatform/ActivFeedCommon/ActivFeed.h"
00015
00016 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/External.h"
00017 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/SymbolRecordFieldListBuilder.h"
00018 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/SymbolRecordRuleDefinitions.h"
00019
00020 namespace Activ
00021 {
00022
00023 class MessageBuilder;
00024 class IFieldType;
00025
00026 namespace ContentPlatform
00027 {
00028
00029 namespace Feed
00030 {
00031
00032 class TableTemplateList;
00033
00034 // ---------------------------------------------------------------------------------------------------------------------------------
00035
00039 class SymbolRecordMessageBuilder
00040 {
00041 public:
00045     ACTIV_FEED_MESSAGE_HANDLER_API SymbolRecordMessageBuilder();
00046
00053     ACTIV_FEED_MESSAGE_HANDLER_API SymbolRecordMessageBuilder(const TableTemplateList &tableTemplateList, MessageBuilder &messageBuilder);
00054
00060     ACTIV_FEED_MESSAGE_HANDLER_API SymbolRecordMessageBuilder(const TableTemplateList &tableTemplateList);
00061
00065     ACTIV_FEED_MESSAGE_HANDLER_API ~SymbolRecordMessageBuilder();
00066
00073     ACTIV_FEED_MESSAGE_HANDLER_API void Initialize(const TableTemplateList &tableTemplateList, MessageBuilder &messageBuilder);
00074
00080     ACTIV_FEED_MESSAGE_HANDLER_API void Initialize(const TableTemplateList &tableTemplateList);
00081
00087     ACTIV_FEED_MESSAGE_HANDLER_API void Initialize(MessageBuilder &messageBuilder);
00088
00092     ACTIV_FEED_MESSAGE_HANDLER_API void Reset();
00093
00111     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode AppendHeader(const bool isDelete, const TableId tableId, const UpdateId updateId, const PermissionId permissionId, const EventType eventType, const void * const pSymbol, const size_t symbolLength, uint8_t defaultRuleSet = SymbolRecordRuleDefinitions::RULE_SET_NONE);
00112
00131     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode AppendHeader(const bool isDelete, const TableId tableId, const UpdateId updateId, const UpdateId compositeUpdateId, const PermissionId permissionId, const EventType eventType, const void * const pSymbol, const size_t symbolLength, uint8_t defaultRuleSet = SymbolRecordRuleDefinitions::RULE_SET_NONE);
00132
00144     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode AppendField(const FieldId fieldId, const IFieldType &iFieldType);
00145
00158     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode AppendField(const FieldId fieldId, const void * const pSerializedBody, const size_t serializedBodyLength);
00159
00171     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode AppendFieldWithNoneRuleSet(const FieldId fieldId, const IFieldType &iFieldType);
00172
00185     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode AppendFieldWithNoneRuleSet(const FieldId fieldId, const void * const pSerializedBody, const size_t serializedBodyLength);
00186
00199     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode AppendFieldWithTranslatorRuleSet(const FieldId fieldId, const uint8_t fieldRules, const IFieldType &iFieldType);
00200
00214     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode AppendFieldWithTranslatorRuleSet(const FieldId fieldId, const uint8_t fieldRules, const void * const pSerializedBody, const size_t serializedBodyLength);
00215
00229     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode AppendFieldWithTranslatorRuleSet(const FieldId fieldId, const uint8_t fieldRules, const uint8_t compositeFieldRules, const IFieldType &iFieldType);
00230
00245     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode AppendFieldWithTranslatorRuleSet(const FieldId fieldId, const uint8_t fieldRules, const uint8_t compositeFieldRules, const void * const pSerializedBody, const size_t serializedBodyLength);
00246
00259     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode AppendFieldWithContentServerRuleSet(const FieldId fieldId, const uint8_t fieldRules, const IFieldType &iFieldType);
00260
00274     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode AppendFieldWithContentServerRuleSet(const FieldId fieldId, const uint8_t fieldRules, const void * const pSerializedBody, const size_t serializedBodyLength);
00275
00289     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode AppendFieldWithContentServerRuleSet(const FieldId fieldId, const uint8_t fieldRules, const uint8_t compositeFieldRules, const IFieldType &iFieldType);
00290
00305     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode AppendFieldWithContentServerRuleSet(const FieldId fieldId, const uint8_t fieldRules, const uint8_t compositeFieldRules, const void * const pSerializedBody, const size_t serializedBodyLength);
00306
00316     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode AppendUndefinedField(const FieldId fieldId);
00317
00323     ACTIV_FEED_MESSAGE_HANDLER_API bool IsInitialized() const;
00324
00325 private:
00331     SymbolRecordMessageBuilder(const SymbolRecordMessageBuilder &rhs);
00332
00340     SymbolRecordMessageBuilder& operator=(const SymbolRecordMessageBuilder &rhs);
00341
00342     const TableTemplateList         *m_pTableTemplateList;
00343     MessageBuilder                  *m_pMessageBuilder;
00344
00345     SymbolRecordFieldListBuilder    m_symbolRecordFieldListBuilder;
00346 };
00347
00348 } // namespace Feed
00349
00350 } // namespace ContentPlatform
00351
00352 } // namespace Activ
00353
00354 #endif // (!defined ACTIV_FEED_MESSAGE_HANDLER_SYMBOL_RECORD_MESSAGE_BUILDER_H)
Generated on Wed Oct 8 14:01:46 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedMessageHandler

SymbolRecordMessageHeaderDefinitions.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FEED_MESSAGE_HANDLER_SYMBOL_RECORD_MESSAGE_HEADER_DEFINITIONS_H)
00010 #define ACTIV_FEED_MESSAGE_HANDLER_SYMBOL_RECORD_MESSAGE_HEADER_DEFINITIONS_H
00011
00012 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/External.h"
00013 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/ActivFeedMessageHandler.h"
00014 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/MessageHeaderDefinitions.h"
00015
00016 namespace Activ
00017 {
00018
00019 namespace ContentPlatform
00020 {
00021
00022 namespace Feed
00023 {
00024
00028 class SymbolRecordMessageHeaderDefinitions
00029 {
00030 public:
00031     typedef uint8_t Flags;
00032
00033     static const MessageType    MESSAGE_TYPE    = MESSAGE_TYPE_SYMBOL_RECORD;
00034
00035     static const size_t     MESSAGE_HEADER_FLAGS_DELETE_OFFSET      = 0;
00036     static const size_t     MESSAGE_HEADER_FLAGS_DELETE_LENGTH      = 1;
00037     static const size_t     MESSAGE_HEADER_FLAGS_COMPOSITE_OFFSET   = (MESSAGE_HEADER_FLAGS_DELETE_OFFSET + MESSAGE_HEADER_FLAGS_DELETE_LENGTH);
00038     static const size_t     MESSAGE_HEADER_FLAGS_COMPOSITE_LENGTH   = 1;
00039
00040     static const MessageHeaderDefinitions::MessageHeader    MESSAGE_HEADER_FLAGS_DELETE_BIT_MASK        = static_cast<MessageHeaderDefinitions::MessageHeader>((1 << MESSAGE_HEADER_FLAGS_DELETE_LENGTH) - 1);
00041     static const size_t                                     MESSAGE_HEADER_FLAGS_DELETE_BIT_SHIFT       = MessageHeaderDefinitions::FLAGS_LENGTH - (MESSAGE_HEADER_FLAGS_DELETE_OFFSET + MESSAGE_HEADER_FLAGS_DELETE_LENGTH);
00042     static const MessageHeaderDefinitions::MessageHeader    MESSAGE_HEADER_FLAGS_COMPOSITE_BIT_MASK     = static_cast<MessageHeaderDefinitions::MessageHeader>((1 << MESSAGE_HEADER_FLAGS_COMPOSITE_LENGTH) - 1);
00043     static const size_t                                     MESSAGE_HEADER_FLAGS_COMPOSITE_BIT_SHIFT    = MessageHeaderDefinitions::FLAGS_LENGTH - (MESSAGE_HEADER_FLAGS_COMPOSITE_OFFSET + MESSAGE_HEADER_FLAGS_COMPOSITE_LENGTH);
00044
00045     static const size_t     FLAGS_EXPANDED_FORMAT_OFFSET            = 0;
00046     static const size_t     FLAGS_EXPANDED_FORMAT_LENGTH            = 1;
00047     static const size_t     FLAGS_DO_NOT_ADD_OFFSET                 = (FLAGS_EXPANDED_FORMAT_OFFSET + FLAGS_EXPANDED_FORMAT_LENGTH);
00048     static const size_t     FLAGS_DO_NOT_ADD_LENGTH                 = 1;
00049
00050     static const Flags      FLAGS_EXPANDED_FORMAT_BIT_MASK          = static_cast<Flags>((1 << FLAGS_EXPANDED_FORMAT_LENGTH) - 1);
00051     static const size_t     FLAGS_EXPANDED_FORMAT_BIT_SHIFT         = (sizeof(Flags) * CHAR_BIT) - (FLAGS_EXPANDED_FORMAT_OFFSET + FLAGS_EXPANDED_FORMAT_LENGTH);
00052     static const Flags      FLAGS_DO_NOT_ADD_BIT_MASK               = static_cast<Flags>((1 << FLAGS_DO_NOT_ADD_LENGTH) - 1);
00053     static const size_t     FLAGS_DO_NOT_ADD_BIT_SHIFT              = (sizeof(Flags) * CHAR_BIT) - (FLAGS_DO_NOT_ADD_OFFSET + FLAGS_DO_NOT_ADD_LENGTH);
00054
00055     static const size_t     MAX_SYMBOL_LENGTH   = 255;
00056
00066     static MessageHeaderDefinitions::MessageHeader GetMessageHeader(const bool isDelete, const bool isComposite, const MessageType messageType = MESSAGE_TYPE);
00067
00075     static bool IsValidMessageType(const MessageHeaderDefinitions::MessageHeader messageHeader);
00076
00084     static bool IsDelete(const MessageHeaderDefinitions::MessageHeader messageHeader);
00085
00093     static bool IsComposite(const MessageHeaderDefinitions::MessageHeader messageHeader);
00094
00103     static Flags GetFlags(const bool isExpandedFormat, const bool isDoNotAdd);
00104
00112     static void ExtractFlags(const Flags flags, bool &isExpandedFormat, bool &isDoNotAdd);
00113
00121     static bool IsExpandedFormat(const Flags flags);
00122
00130     static bool IsDoNotAdd(const Flags flags);
00131 };
00132
00133 // ---------------------------------------------------------------------------------------------------------------------------------
00134
00135 inline MessageHeaderDefinitions::MessageHeader SymbolRecordMessageHeaderDefinitions::GetMessageHeader(const bool isDelete, const bool isComposite, const MessageType messageType)
00136 {
00137     return MessageHeaderDefinitions::GetMessageHeader((isDelete ? (MESSAGE_HEADER_FLAGS_DELETE_BIT_MASK << MESSAGE_HEADER_FLAGS_DELETE_BIT_SHIFT) : 0) | (isComposite ? (MESSAGE_HEADER_FLAGS_COMPOSITE_BIT_MASK << MESSAGE_HEADER_FLAGS_COMPOSITE_BIT_SHIFT) : 0), messageType);
00138 }
00139
00140 // ---------------------------------------------------------------------------------------------------------------------------------
00141
00142 inline bool SymbolRecordMessageHeaderDefinitions::IsValidMessageType(const MessageHeaderDefinitions::MessageHeader messageHeader)
00143 {
00144     return (MessageHeaderDefinitions::IsValidMessageType(messageHeader, MESSAGE_TYPE));
00145 }
00146
00147 // ---------------------------------------------------------------------------------------------------------------------------------
00148
00149 inline bool SymbolRecordMessageHeaderDefinitions::IsDelete(const MessageHeaderDefinitions::MessageHeader messageHeader)
00150 {
00151     return (((MessageHeaderDefinitions::GetFlags(messageHeader) >> MESSAGE_HEADER_FLAGS_DELETE_BIT_SHIFT) & MESSAGE_HEADER_FLAGS_DELETE_BIT_MASK) != 0);
00152 }
00153
00154 // ---------------------------------------------------------------------------------------------------------------------------------
00155
00156 inline bool SymbolRecordMessageHeaderDefinitions::IsComposite(const MessageHeaderDefinitions::MessageHeader messageHeader)
00157 {
00158     return (((MessageHeaderDefinitions::GetFlags(messageHeader) >> MESSAGE_HEADER_FLAGS_COMPOSITE_BIT_SHIFT) & MESSAGE_HEADER_FLAGS_COMPOSITE_BIT_MASK) != 0);
00159 }
00160
00161 // ---------------------------------------------------------------------------------------------------------------------------------
00162
00163 inline SymbolRecordMessageHeaderDefinitions::Flags SymbolRecordMessageHeaderDefinitions::GetFlags(const bool isExpandedFormat, const bool isDoNotAdd)
00164 {
00165     return ((isExpandedFormat ? (FLAGS_EXPANDED_FORMAT_BIT_MASK << FLAGS_EXPANDED_FORMAT_BIT_SHIFT) : 0) | (isDoNotAdd ? (FLAGS_DO_NOT_ADD_BIT_MASK << FLAGS_DO_NOT_ADD_BIT_SHIFT) : 0));
00166 }
00167
00168 // ---------------------------------------------------------------------------------------------------------------------------------
00169
00170 inline void SymbolRecordMessageHeaderDefinitions::ExtractFlags(const Flags flags, bool &isExpandedFormat, bool &isDoNotAdd)
00171 {
00172     isExpandedFormat = IsExpandedFormat(flags);
00173     isDoNotAdd = IsDoNotAdd(flags);
00174 }
00175
00176 // ---------------------------------------------------------------------------------------------------------------------------------
00177
00178 inline bool SymbolRecordMessageHeaderDefinitions::IsExpandedFormat(const Flags flags)
00179 {
00180     return (((flags >> FLAGS_EXPANDED_FORMAT_BIT_SHIFT) & FLAGS_EXPANDED_FORMAT_BIT_MASK) != 0);
00181 }
00182
00183 // ---------------------------------------------------------------------------------------------------------------------------------
00184
00185 inline bool SymbolRecordMessageHeaderDefinitions::IsDoNotAdd(const Flags flags)
00186 {
00187     return (((flags >> FLAGS_DO_NOT_ADD_BIT_SHIFT) & FLAGS_DO_NOT_ADD_BIT_MASK) != 0);
00188 }
00189
00190 } // namespace Feed
00191
00192 } // namespace ContentPlatform
00193
00194 } // namespace Activ
00195
00196 #endif // (!defined ACTIV_FEED_MESSAGE_HANDLER_SYMBOL_RECORD_MESSAGE_HEADER_DEFINITIONS_H)
Generated on Wed Oct 8 14:01:46 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedMessageHandler

SymbolRecordMessageHeaderValidator.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FEED_MESSAGE_HANDLER_SYMBOL_RECORD_MESSAGE_HEADER_VALIDATOR_H)
00010 #define ACTIV_FEED_MESSAGE_HANDLER_SYMBOL_RECORD_MESSAGE_HEADER_VALIDATOR_H
00011
00012 #include "ActivMiddleware/ActivFieldTypes/TextString.h"
00013
00014 #include "ActivContentPlatform/ActivFeedCommon/ActivFeed.h"
00015
00016 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/External.h"
00017 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/TableTemplateList.h"
00018
00019 namespace Activ
00020 {
00021
00022 class MessageValidator;
00023
00024 namespace ContentPlatform
00025 {
00026
00027 namespace Feed
00028 {
00029
00033 class SymbolRecordMessageHeaderValidator
00034 {
00035 public:
00039     ACTIV_FEED_MESSAGE_HANDLER_API SymbolRecordMessageHeaderValidator();
00040
00050     ACTIV_FEED_MESSAGE_HANDLER_API SymbolRecordMessageHeaderValidator(const TableTemplateList &tableTemplateList, MessageValidator &messageValidator, const bool shouldIgnoreMissingTableTemplate = false);
00051
00060     ACTIV_FEED_MESSAGE_HANDLER_API SymbolRecordMessageHeaderValidator(const TableTemplateList &tableTemplateList, const bool shouldIgnoreMissingTableTemplate = false);
00061
00065     ACTIV_FEED_MESSAGE_HANDLER_API ~SymbolRecordMessageHeaderValidator();
00066
00077     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Initialize(const TableTemplateList &tableTemplateList, MessageValidator &messageValidator, const bool shouldIgnoreMissingTableTemplate = false);
00078
00087     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Initialize(const TableTemplateList &tableTemplateList, const bool shouldIgnoreMissingTableTemplate = false);
00088
00098     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Initialize(MessageValidator &messageValidator);
00099
00103     ACTIV_FEED_MESSAGE_HANDLER_API void Reset();
00104
00108     ACTIV_FEED_MESSAGE_HANDLER_API void Clear();
00109
00118     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode GetTableTemplate(const TableTemplate *&pTableTemplate) const;
00119
00129     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode GetUpdateId(UpdateId &updateId) const;
00130
00140     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode GetCompositeUpdateId(UpdateId &compositeUpdateId) const;
00141
00150     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode GetPermissionId(PermissionId &permissionId) const;
00151
00160     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode GetEventType(EventType &eventType) const;
00161
00170     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode GetSymbol(const TextString *&pSymbol) const;
00171
00180     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode GetDefaultRuleSet(uint8_t &defaultRuleSet) const;
00181
00187     ACTIV_FEED_MESSAGE_HANDLER_API bool IsInitialized() const;
00188
00194     ACTIV_FEED_MESSAGE_HANDLER_API bool IsDelete() const;
00195
00201     ACTIV_FEED_MESSAGE_HANDLER_API bool IsComposite() const;
00202
00208     ACTIV_FEED_MESSAGE_HANDLER_API std::string IsDeleteToString() const;
00209
00215     ACTIV_FEED_MESSAGE_HANDLER_API std::string IsCompositeToString() const;
00216
00222     ACTIV_FEED_MESSAGE_HANDLER_API std::string TableTemplateIdToString() const;
00223
00229     ACTIV_FEED_MESSAGE_HANDLER_API std::string TableTemplateNameToString() const;
00230
00236     ACTIV_FEED_MESSAGE_HANDLER_API std::string UpdateIdToString() const;
00237
00243     ACTIV_FEED_MESSAGE_HANDLER_API std::string CompositeUpdateIdToString() const;
00244
00250     ACTIV_FEED_MESSAGE_HANDLER_API std::string PermissionIdToString() const;
00251
00257     ACTIV_FEED_MESSAGE_HANDLER_API std::string EventTypeToString() const;
00258
00264     ACTIV_FEED_MESSAGE_HANDLER_API std::string SymbolToString() const;
00265
00271     ACTIV_FEED_MESSAGE_HANDLER_API std::string DefaultRuleSetToString() const;
00272
00278     ACTIV_FEED_MESSAGE_HANDLER_API std::string ToString() const;
00279
00280 private:
00286     SymbolRecordMessageHeaderValidator(const SymbolRecordMessageHeaderValidator &rhs);
00287
00295     SymbolRecordMessageHeaderValidator& operator=(const SymbolRecordMessageHeaderValidator &rhs);
00296
00306     StatusCode GetTableTemplate(TableTemplate *&pTableTemplate) const;
00307
00317     StatusCode GetSymbol(TextString *&pSymbol) const;
00318
00319     const TableTemplateList     *m_pTableTemplateList;
00320
00321     bool                        m_isInitialized;
00322     bool                        m_shouldIgnoreMissingTableTemplate;
00323     bool                        m_isDelete;
00324     bool                        m_isComposite;
00325     const TableTemplate         *m_pTableTemplate;
00326     UpdateId                    m_updateId;
00327     UpdateId                    m_compositeUpdateId;
00328     PermissionId                m_permissionId;
00329     EventType                   m_eventType;
00330     TextString                  m_symbol;
00331     uint8_t                     m_defaultRuleSet;
00332
00333     friend class SymbolRecordFieldListValidator;
00334 };
00335
00336 } // namespace Feed
00337
00338 } // namespace ContentPlatform
00339
00340 } // namespace Activ
00341
00342 #endif // (!defined ACTIV_FEED_MESSAGE_HANDLER_SYMBOL_RECORD_MESSAGE_HEADER_VALIDATOR_H)
Generated on Wed Oct 8 14:01:46 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedMessageHandler

SymbolRecordMessageValidator.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FEED_MESSAGE_HANDLER_SYMBOL_RECORD_MESSAGE_VALIDATOR_H)
00010 #define ACTIV_FEED_MESSAGE_HANDLER_SYMBOL_RECORD_MESSAGE_VALIDATOR_H
00011
00012 #include "ActivMiddleware/ActivFieldTypes/TextString.h"
00013
00014 #include "ActivContentPlatform/ActivFeedCommon/ActivFeed.h"
00015
00016 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/External.h"
00017 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/SymbolRecordMessageHeaderValidator.h"
00018 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/SymbolRecordFieldListValidator.h"
00019
00020 namespace Activ
00021 {
00022
00023 class MessageValidator;
00024
00025 namespace ContentPlatform
00026 {
00027
00028 namespace Feed
00029 {
00030
00031 class TableTemplate;
00032 class TableTemplateList;
00033 class SymbolRecordField;
00034
00035 // ---------------------------------------------------------------------------------------------------------------------------------
00036
00040 class SymbolRecordMessageValidator
00041 {
00042 public:
00043     typedef SymbolRecordFieldListValidator::ConstIterator ConstIterator;
00044
00048     ACTIV_FEED_MESSAGE_HANDLER_API SymbolRecordMessageValidator();
00049
00060     ACTIV_FEED_MESSAGE_HANDLER_API SymbolRecordMessageValidator(const TableTemplateList &tableTemplateList, MessageValidator &messageValidator, const bool shouldIgnoreMissingTableTemplate = false, const bool shouldIgnoreUndefinedMissingFields = false);
00061
00070     ACTIV_FEED_MESSAGE_HANDLER_API SymbolRecordMessageValidator(const TableTemplateList &tableTemplateList, const bool shouldIgnoreMissingTableTemplate = false);
00071
00075     ACTIV_FEED_MESSAGE_HANDLER_API ~SymbolRecordMessageValidator();
00076
00089     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Initialize(const TableTemplateList &tableTemplateList, MessageValidator &messageValidator, const bool shouldIgnoreMissingTableTemplate = false, const bool shouldIgnoreUndefinedMissingFields = false);
00090
00099     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Initialize(const TableTemplateList &tableTemplateList, const bool shouldIgnoreMissingTableTemplate = false);
00100
00111     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Initialize(MessageValidator &messageValidator, const bool shouldIgnoreUndefinedMissingFields = false);
00112
00116     ACTIV_FEED_MESSAGE_HANDLER_API void Reset();
00117
00121     ACTIV_FEED_MESSAGE_HANDLER_API void Clear();
00122
00131     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode GetTableTemplate(const TableTemplate *&pTableTemplate) const;
00132
00142     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode GetUpdateId(UpdateId &updateId) const;
00143
00153     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode GetCompositeUpdateId(UpdateId &compositeUpdateId) const;
00154
00163     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode GetPermissionId(PermissionId &permissionId) const;
00164
00173     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode GetEventType(EventType &eventType) const;
00174
00183     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode GetSymbol(const TextString *&pSymbol) const;
00184
00193     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode GetDefaultRuleSet(uint8_t &defaultRuleSet) const;
00194
00205     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode GetSymbolRecordField(const FieldId fieldId, const SymbolRecordField *&pSymbolRecordField) const;
00206
00212     ACTIV_FEED_MESSAGE_HANDLER_API bool IsInitialized() const;
00213
00219     ACTIV_FEED_MESSAGE_HANDLER_API bool IsDelete() const;
00220
00226     ACTIV_FEED_MESSAGE_HANDLER_API bool IsComposite() const;
00227
00235     ACTIV_FEED_MESSAGE_HANDLER_API ConstIterator Begin() const;
00236
00244     ACTIV_FEED_MESSAGE_HANDLER_API ConstIterator End() const;
00245
00251     ACTIV_FEED_MESSAGE_HANDLER_API std::string ToString() const;
00252
00253 private:
00259     SymbolRecordMessageValidator(const SymbolRecordMessageValidator &rhs);
00260
00268     SymbolRecordMessageValidator& operator=(const SymbolRecordMessageValidator &rhs);
00269
00279     StatusCode GetTableTemplate(TableTemplate *&pTableTemplate) const;
00280
00290     StatusCode GetSymbol(TextString *&pSymbol) const;
00291
00304     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode GetSymbolRecordField(const FieldId fieldId, SymbolRecordField *&pSymbolRecordField) const;
00305
00306     SymbolRecordMessageHeaderValidator  m_symbolRecordMessageHeaderValidator;
00307     SymbolRecordFieldListValidator      m_symbolRecordFieldListValidator;
00308 };
00309
00310 } // namespace Feed
00311
00312 } // namespace ContentPlatform
00313
00314 } // namespace Activ
00315
00316 #endif // (!defined ACTIV_FEED_MESSAGE_HANDLER_SYMBOL_RECORD_MESSAGE_VALIDATOR_H)
Generated on Wed Oct 8 14:01:46 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedMessageHandler

SymbolRecordRuleDefinitions.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FEED_MESSAGE_HANDLER_SYMBOL_RECORD_RULE_DEFINITIONS_H)
00010 #define ACTIV_FEED_MESSAGE_HANDLER_SYMBOL_RECORD_RULE_DEFINITIONS_H
00011
00012 #include "ActivContentPlatform/ActivFeedCommon/FieldIds.h"
00013
00014 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/External.h"
00015
00016 namespace Activ
00017 {
00018
00019 namespace ContentPlatform
00020 {
00021
00022 namespace Feed
00023 {
00024
00028 class SymbolRecordRuleDefinitions
00029 {
00030 public:
00034     enum
00035     {
00036         RULE_SET_NONE,
00037         RULE_SET_TRANSLATOR,
00038         RULE_SET_CONTENT_SERVER,
00039         RULE_SET_COPY,
00040         RULE_SET_PARTIAL_BIT_UPDATE,
00041         RULE_SET_PARTIAL_BYTE_UPDATE,
00042         NUMBER_OF_RULE_SETS
00043     };
00044
00048     class TranslatorRuleSet
00049     {
00050     public:
00054         enum
00055         {
00056             FIELD_RULE_BIT_DO_NOT_UPDATE_FIELD,
00057             FIELD_RULE_BIT_DO_NOT_TEST_HIGH_LOW,
00058             FIELD_RULE_BIT_DO_NOT_TEST_OPEN,
00059             FIELD_RULE_BIT_DO_NOT_APPLY_ADD_RULE_1,
00060             FIELD_RULE_BIT_DO_NOT_APPLY_ADD_RULE_2,
00061             FIELD_RULE_BIT_DO_NOT_APPLY_TRENDING,
00062             FIELD_RULE_BIT_DO_NOT_APPLY_CHANGE_RULE
00063         };
00064
00065         static const uint8_t FIELD_RULE_DO_NOT_UPDATE_FIELD         = (1 << ((sizeof(uint8_t) * CHAR_BIT) - (FIELD_RULE_BIT_DO_NOT_UPDATE_FIELD + 1)));
00066         static const uint8_t FIELD_RULE_DO_NOT_TEST_HIGH_LOW        = (1 << ((sizeof(uint8_t) * CHAR_BIT) - (FIELD_RULE_BIT_DO_NOT_TEST_HIGH_LOW + 1)));
00067         static const uint8_t FIELD_RULE_DO_NOT_TEST_OPEN            = (1 << ((sizeof(uint8_t) * CHAR_BIT) - (FIELD_RULE_BIT_DO_NOT_TEST_OPEN + 1)));
00068         static const uint8_t FIELD_RULE_DO_NOT_APPLY_ADD_RULE_1     = (1 << ((sizeof(uint8_t) * CHAR_BIT) - (FIELD_RULE_BIT_DO_NOT_APPLY_ADD_RULE_1 + 1)));
00069         static const uint8_t FIELD_RULE_DO_NOT_APPLY_ADD_RULE_2     = (1 << ((sizeof(uint8_t) * CHAR_BIT) - (FIELD_RULE_BIT_DO_NOT_APPLY_ADD_RULE_2 + 1)));
00070         static const uint8_t FIELD_RULE_DO_NOT_APPLY_TRENDING       = (1 << ((sizeof(uint8_t) * CHAR_BIT) - (FIELD_RULE_BIT_DO_NOT_APPLY_TRENDING + 1)));
00071         static const uint8_t FIELD_RULE_DO_NOT_APPLY_CHANGE_RULE    = (1 << ((sizeof(uint8_t) * CHAR_BIT) - (FIELD_RULE_BIT_DO_NOT_APPLY_CHANGE_RULE + 1)));
00072
00086         static uint8_t GetFieldRules(const bool shouldUpdateField, const bool shouldTestHighLow, const bool shouldTestOpen, const bool shouldApplyAddRule1, const bool shouldApplyAddRule2, const bool shouldApplyTrending, const bool shouldApplyChangeRule);
00087
00095         static bool ShouldUpdateField(const uint8_t fieldRules);
00096
00104         static bool ShouldTestHighLow(const uint8_t fieldRules);
00105
00113         static bool ShouldTestOpen(const uint8_t fieldRules);
00114
00122         static bool ShouldApplyAddRule1(const uint8_t fieldRules);
00123
00131         static bool ShouldApplyAddRule2(const uint8_t fieldRules);
00132
00140         static bool ShouldApplyTrending(const uint8_t fieldRules);
00141
00149         static bool ShouldApplyChangeRule(const uint8_t fieldRules);
00150     };
00151
00155     class ContentServerRuleSet
00156     {
00157     public:
00161         enum
00162         {
00163             FIELD_RULE_BIT_DO_NOT_UPDATE_FIELD,
00164             FIELD_RULE_BIT_IS_HIGH,
00165             FIELD_RULE_BIT_IS_LOW,
00166             FIELD_RULE_BIT_IS_OPEN,
00167             FIELD_RULE_BIT_DO_NOT_APPLY_ADD_RULE_1,
00168             FIELD_RULE_BIT_DO_NOT_APPLY_ADD_RULE_2,
00169             FIELD_RULE_BIT_APPLY_TRENDING,
00170             FIELD_RULE_BIT_DO_NOT_APPLY_CHANGE_RULE
00171         };
00172
00173         static const uint8_t FIELD_RULE_DO_NOT_UPDATE_FIELD         = (1 << ((sizeof(uint8_t) * CHAR_BIT) - (FIELD_RULE_BIT_DO_NOT_UPDATE_FIELD + 1)));
00174         static const uint8_t FIELD_RULE_BITMASK_IS_HIGH             = (1 << ((sizeof(uint8_t) * CHAR_BIT) - (FIELD_RULE_BIT_IS_HIGH + 1)));
00175         static const uint8_t FIELD_RULE_BITMASK_IS_LOW              = (1 << ((sizeof(uint8_t) * CHAR_BIT) - (FIELD_RULE_BIT_IS_LOW + 1)));
00176         static const uint8_t FIELD_RULE_BITMASK_IS_OPEN             = (1 << ((sizeof(uint8_t) * CHAR_BIT) - (FIELD_RULE_BIT_IS_OPEN + 1)));
00177         static const uint8_t FIELD_RULE_DO_NOT_APPLY_ADD_RULE_1     = (1 << ((sizeof(uint8_t) * CHAR_BIT) - (FIELD_RULE_BIT_DO_NOT_APPLY_ADD_RULE_1 + 1)));
00178         static const uint8_t FIELD_RULE_DO_NOT_APPLY_ADD_RULE_2     = (1 << ((sizeof(uint8_t) * CHAR_BIT) - (FIELD_RULE_BIT_DO_NOT_APPLY_ADD_RULE_2 + 1)));
00179         static const uint8_t FIELD_RULE_APPLY_TRENDING              = (1 << ((sizeof(uint8_t) * CHAR_BIT) - (FIELD_RULE_BIT_APPLY_TRENDING + 1)));
00180         static const uint8_t FIELD_RULE_DO_NOT_APPLY_CHANGE_RULE    = (1 << ((sizeof(uint8_t) * CHAR_BIT) - (FIELD_RULE_BIT_DO_NOT_APPLY_CHANGE_RULE + 1)));
00181
00196         static uint8_t GetFieldRules(const bool shouldUpdateField, const bool isHigh, const bool isLow, const bool isOpen, const bool shouldApplyAddRule1, const bool shouldApplyAddRule2, const bool shouldApplyTrending, const bool shouldApplyChangeRule);
00197
00205         static bool ShouldUpdateField(const uint8_t fieldRules);
00206
00214         static bool IsHigh(const uint8_t fieldRules);
00215
00223         static bool IsLow(const uint8_t fieldRules);
00224
00232         static bool IsOpen(const uint8_t fieldRules);
00233
00241         static bool ShouldApplyAddRule1(const uint8_t fieldRules);
00242
00250         static bool ShouldApplyAddRule2(const uint8_t fieldRules);
00251
00259         static bool ShouldApplyTrending(const uint8_t fieldRules);
00260
00268         static bool ShouldApplyChangeRule(const uint8_t fieldRules);
00269     };
00270
00271     static const uint8_t FIELD_RULE_CLEAR_ALL               = 0;
00272     static const uint8_t FIELD_RULE_SET_ALL                 = ~0;
00273
00282     static uint8_t SetFieldRules(const uint8_t fieldRules, const uint8_t initialFieldRules = FIELD_RULE_CLEAR_ALL);
00283
00292     static uint8_t ClearFieldRules(const uint8_t fieldRules, const uint8_t initialFieldRules = FIELD_RULE_SET_ALL);
00293 };
00294
00295 // ---------------------------------------------------------------------------------------------------------------------------------
00296
00297 inline uint8_t SymbolRecordRuleDefinitions::SetFieldRules(const uint8_t fieldRules, const uint8_t initialFieldRules)
00298 {
00299     return initialFieldRules | fieldRules;
00300 }
00301
00302 // ---------------------------------------------------------------------------------------------------------------------------------
00303
00304 inline uint8_t SymbolRecordRuleDefinitions::ClearFieldRules(const uint8_t fieldRules, const uint8_t initialFieldRules)
00305 {
00306     return initialFieldRules & ~fieldRules;
00307 }
00308
00309 // ---------------------------------------------------------------------------------------------------------------------------------
00310 // ---------------------------------------------------------------------------------------------------------------------------------
00311
00312 inline uint8_t SymbolRecordRuleDefinitions::TranslatorRuleSet::GetFieldRules(const bool shouldUpdateField, const bool shouldTestHighLow, const bool shouldTestOpen, const bool shouldApplyAddRule1, const bool shouldApplyAddRule2, const bool shouldApplyTrending, const bool shouldApplyChangeRule)
00313 {
00314     return ((shouldUpdateField ? 0 : FIELD_RULE_DO_NOT_UPDATE_FIELD) | (shouldTestHighLow ? 0 : FIELD_RULE_DO_NOT_TEST_HIGH_LOW) |(shouldTestOpen ? 0 : FIELD_RULE_DO_NOT_TEST_OPEN) | (shouldApplyAddRule1 ? 0 : FIELD_RULE_DO_NOT_APPLY_ADD_RULE_1) | (shouldApplyAddRule2 ? 0 : FIELD_RULE_DO_NOT_APPLY_ADD_RULE_2) | (shouldApplyTrending ? 0 : FIELD_RULE_DO_NOT_APPLY_TRENDING) | (shouldApplyChangeRule ? 0 : FIELD_RULE_DO_NOT_APPLY_CHANGE_RULE));
00315 }
00316
00317 // ---------------------------------------------------------------------------------------------------------------------------------
00318
00319 inline bool SymbolRecordRuleDefinitions::TranslatorRuleSet::ShouldUpdateField(const uint8_t fieldRules)
00320 {
00321     return ((fieldRules & FIELD_RULE_DO_NOT_UPDATE_FIELD) == 0);
00322 }
00323
00324 // ---------------------------------------------------------------------------------------------------------------------------------
00325
00326 inline bool SymbolRecordRuleDefinitions::TranslatorRuleSet::ShouldTestHighLow(const uint8_t fieldRules)
00327 {
00328     return ((fieldRules & FIELD_RULE_DO_NOT_TEST_HIGH_LOW) == 0);
00329 }
00330
00331 // ---------------------------------------------------------------------------------------------------------------------------------
00332
00333 inline bool SymbolRecordRuleDefinitions::TranslatorRuleSet::ShouldTestOpen(const uint8_t fieldRules)
00334 {
00335     return ((fieldRules & FIELD_RULE_DO_NOT_TEST_OPEN) == 0);
00336 }
00337
00338 // ---------------------------------------------------------------------------------------------------------------------------------
00339
00340 inline bool SymbolRecordRuleDefinitions::TranslatorRuleSet::ShouldApplyAddRule1(const uint8_t fieldRules)
00341 {
00342     return ((fieldRules & FIELD_RULE_DO_NOT_APPLY_ADD_RULE_1) == 0);
00343 }
00344
00345 // ---------------------------------------------------------------------------------------------------------------------------------
00346
00347 inline bool SymbolRecordRuleDefinitions::TranslatorRuleSet::ShouldApplyAddRule2(const uint8_t fieldRules)
00348 {
00349     return ((fieldRules & FIELD_RULE_DO_NOT_APPLY_ADD_RULE_2) == 0);
00350 }
00351
00352 // ---------------------------------------------------------------------------------------------------------------------------------
00353
00354 inline bool SymbolRecordRuleDefinitions::TranslatorRuleSet::ShouldApplyTrending(const uint8_t fieldRules)
00355 {
00356     return ((fieldRules & FIELD_RULE_DO_NOT_APPLY_TRENDING) == 0);
00357 }
00358
00359 // ---------------------------------------------------------------------------------------------------------------------------------
00360
00361 inline bool SymbolRecordRuleDefinitions::TranslatorRuleSet::ShouldApplyChangeRule(const uint8_t fieldRules)
00362 {
00363     return ((fieldRules & FIELD_RULE_DO_NOT_APPLY_CHANGE_RULE) == 0);
00364 }
00365
00366 // ---------------------------------------------------------------------------------------------------------------------------------
00367 // ---------------------------------------------------------------------------------------------------------------------------------
00368
00369 inline uint8_t SymbolRecordRuleDefinitions::ContentServerRuleSet::GetFieldRules(const bool shouldUpdateField, const bool isHigh, const bool isLow, const bool isOpen, const bool shouldApplyAddRule1, const bool shouldApplyAddRule2, const bool shouldApplyTrending, const bool shouldApplyChangeRule)
00370 {
00371     return ((shouldUpdateField ? 0 : FIELD_RULE_DO_NOT_UPDATE_FIELD) | (isHigh ? FIELD_RULE_BITMASK_IS_HIGH : 0) | (isLow ? FIELD_RULE_BITMASK_IS_LOW : 0) | (isOpen ? FIELD_RULE_BITMASK_IS_OPEN : 0) | (shouldApplyAddRule1 ? 0 : FIELD_RULE_DO_NOT_APPLY_ADD_RULE_1) | (shouldApplyAddRule2 ? 0 : FIELD_RULE_DO_NOT_APPLY_ADD_RULE_2) | (shouldApplyTrending ? FIELD_RULE_APPLY_TRENDING : 0) | (shouldApplyChangeRule ? 0 : FIELD_RULE_DO_NOT_APPLY_CHANGE_RULE));
00372 }
00373
00374 // ---------------------------------------------------------------------------------------------------------------------------------
00375
00376 inline bool SymbolRecordRuleDefinitions::ContentServerRuleSet::ShouldUpdateField(const uint8_t fieldRules)
00377 {
00378     return ((fieldRules & FIELD_RULE_DO_NOT_UPDATE_FIELD) == 0);
00379 }
00380
00381 // ---------------------------------------------------------------------------------------------------------------------------------
00382
00383 inline bool SymbolRecordRuleDefinitions::ContentServerRuleSet::IsHigh(const uint8_t fieldRules)
00384 {
00385     return ((fieldRules & FIELD_RULE_BITMASK_IS_HIGH) != 0);
00386 }
00387
00388 // ---------------------------------------------------------------------------------------------------------------------------------
00389
00390 inline bool SymbolRecordRuleDefinitions::ContentServerRuleSet::IsLow(const uint8_t fieldRules)
00391 {
00392     return ((fieldRules & FIELD_RULE_BITMASK_IS_LOW) != 0);
00393 }
00394
00395 // ---------------------------------------------------------------------------------------------------------------------------------
00396
00397 inline bool SymbolRecordRuleDefinitions::ContentServerRuleSet::IsOpen(const uint8_t fieldRules)
00398 {
00399     return ((fieldRules & FIELD_RULE_BITMASK_IS_OPEN) != 0);
00400 }
00401
00402 // ---------------------------------------------------------------------------------------------------------------------------------
00403
00404 inline bool SymbolRecordRuleDefinitions::ContentServerRuleSet::ShouldApplyAddRule1(const uint8_t fieldRules)
00405 {
00406     return ((fieldRules & FIELD_RULE_DO_NOT_APPLY_ADD_RULE_1) == 0);
00407 }
00408
00409 // ---------------------------------------------------------------------------------------------------------------------------------
00410
00411 inline bool SymbolRecordRuleDefinitions::ContentServerRuleSet::ShouldApplyAddRule2(const uint8_t fieldRules)
00412 {
00413     return ((fieldRules & FIELD_RULE_DO_NOT_APPLY_ADD_RULE_2) == 0);
00414 }
00415
00416 // ---------------------------------------------------------------------------------------------------------------------------------
00417
00418 inline bool SymbolRecordRuleDefinitions::ContentServerRuleSet::ShouldApplyTrending(const uint8_t fieldRules)
00419 {
00420     return ((fieldRules & FIELD_RULE_APPLY_TRENDING) != 0);
00421 }
00422
00423 // ---------------------------------------------------------------------------------------------------------------------------------
00424
00425 inline bool SymbolRecordRuleDefinitions::ContentServerRuleSet::ShouldApplyChangeRule(const uint8_t fieldRules)
00426 {
00427     return ((fieldRules & FIELD_RULE_DO_NOT_APPLY_CHANGE_RULE) == 0);
00428 }
00429
00430 } // namespace Feed
00431
00432 } // namespace ContentPlatform
00433
00434 } // namespace Activ
00435
00436 #endif // (!defined ACTIV_FEED_MESSAGE_HANDLER_SYMBOL_RECORD_RULE_DEFINITIONS_H)
Generated on Wed Oct 8 14:01:46 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivSystem

SyncRequestId.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_SYSTEM_SYNC_REQUEST_ID_H)
00010 #define ACTIV_SYSTEM_SYNC_REQUEST_ID_H
00011
00012 #include "ActivMiddleware/ActivSystem/External.h"
00013 #include "ActivMiddleware/ActivSystem/RequestId.h"
00014
00015 namespace Activ
00016 {
00017
00018 class HeapMessage;
00019 class SystemImpl;
00020 class ISyncEndPoint;
00021
00022 // ---------------------------------------------------------------------------------------------------------------------------------
00023
00027 class SyncRequestId
00028 {
00029 public:
00033     ACTIV_SYSTEM_EXPORTED_API
00034     SyncRequestId();
00035
00043     ACTIV_SYSTEM_EXPORTED_API
00044     SyncRequestId(SyncRequestId &syncRequestId);
00045
00049     ACTIV_SYSTEM_EXPORTED_API
00050     ~SyncRequestId();
00051
00055     ACTIV_SYSTEM_EXPORTED_API
00056     void Return();
00057
00069     ACTIV_SYSTEM_EXPORTED_API
00070     StatusCode GetResponse(HeapMessage &heapMessage, const TimeoutPeriod timeout = ACTIV_WAIT_INFINITE);
00071
00077     ACTIV_SYSTEM_INLINE_API
00078     const RequestId &GetRequestId() const;
00079
00087     ACTIV_SYSTEM_EXPORTED_API
00088     SyncRequestId &operator=(SyncRequestId &rhs);
00089
00090 private:
00094     ACTIV_SYSTEM_LOCAL_API
00095     void Set(SystemImpl * const pSystem, const RequestId::SendId sendId, ISyncEndPoint * const pEndPoint);
00096
00097     SystemImpl *    m_pSystem;
00098     ISyncEndPoint * m_pEndPoint;
00099     RequestId       m_requestId;
00100
00101     friend class SystemImpl;
00102 };
00103
00104 // ---------------------------------------------------------------------------------------------------------------------------------
00105
00106 inline const RequestId &SyncRequestId::GetRequestId() const
00107 {
00108     return m_requestId;
00109 }
00110
00111 } // namespace Activ
00112
00113 #endif // (!defined ACTIV_SYSTEM_SYNC_REQUEST_ID_H)
Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivSystem

SystemException.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_SYSTEM_SYSTEM_EXCEPTION_H)
00010 #define ACTIV_SYSTEM_SYSTEM_EXCEPTION_H
00011
00012 #include "ActivMiddleware/ActivSystem/External.h"
00013 #include "ActivMiddleware/ActivBase/Exception.h"
00014
00021 #define ACTIV_SYSTEM_EXCEPTION_LIST(d)                                                      \
00022     d(ERROR_FAILED_TO_ALLOC_MESSAGE_ARRAY, "failed to allocate message array")              \
00023     d(ERROR_FAILED_TO_ALLOC_SYSTEM, "failed to allocate system")                            \
00024     d(ERROR_FAILED_TO_ALLOC_PROCESS, "failed to allocate process")                          \
00025     d(ERROR_FAILED_TO_ALLOC_PROCESS_TABLE, "failed to allocate process table")              \
00026     d(ERROR_PROCESS_DOES_NOT_EXIST, "process does not exist")                               \
00027     d(ERROR_FAILED_TO_ALLOC_ENDPOINT, "failed to allocate endpoint")                        \
00028     d(ERROR_FAILED_TO_ALLOC_ENDPOINT_TABLE, "failed to allocate endpoint table")            \
00029     d(ERROR_ENDPOINT_DOES_NOT_EXIST, "endpoint does not exist")                             \
00030     d(ERROR_FAILED_TO_ALLOC_HEAP, "failed to allocate heap")                                \
00031     d(ERROR_FAILED_TO_ALLOC_HEAP_TABLE, "failed to allocate heap table")                    \
00032     d(ERROR_HEAP_DOES_NOT_EXIST, "heap does not exist")                                     \
00033     d(ERROR_INVALID_NUMBER_OF_BUCKETS, "invalid number of buckets")                         \
00034     d(ERROR_INVALID_BLOCK_SIZE, "invalid block size (probably 0)")                          \
00035     d(ERROR_INVALID_HEAP_ID, "invalid heap id")                                             \
00036     d(ERROR_INVALID_ENDPOINT_ID, "invalid endpoint id")                                     \
00037     d(ERROR_INVALID_PROCESS_ID, "invalid process id")                                       \
00038     d(ERROR_PORT_IN_USE, "port in use")                                                     \
00039     d(ERROR_INVALID_PROCESS_STATE, "invalid process state")                                 \
00040     d(ERROR_UNKNOWN_SYSTEM_LOG_MODE, "unknown system log mode")                             \
00041     d(ERROR_INVALID_MEMORY_MODEL, "invalid memory model")
00042
00043 namespace Activ
00044 {
00045
00051 class SystemException : public Exception
00052 {
00053 public:
00057     enum
00058     {
00059         ACTIV_SYSTEM_EXCEPTION_LIST(ACTIV_DECLARE_ELEMENT_1_WITH_COMMA)
00060         NUM_ERRORS
00061     };
00062
00071     ACTIV_SYSTEM_EXPORTED_API
00072     SystemException(const char *file, const char *function, const uint_fast32_t line, const uint_fast32_t errorCode);
00073
00074     ACTIV_SYSTEM_EXPORTED_API
00075     virtual std::string ToString() const;
00076 };
00077
00078 } // namespace Activ
00079
00080 #endif // (!defined ACTIV_SYSTEM_SYSTEM_EXCEPTION_H)
Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivSystem

SystemFactory.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_SYSTEM_SYSTEM_FACTORY_H)
00010 #define ACTIV_SYSTEM_SYSTEM_FACTORY_H
00011
00012 #include "ActivMiddleware/ActivSystem/External.h"
00013 #include "ActivMiddleware/ActivSystem/ISystem.h"
00014 #include "ActivMiddleware/Misc/Singleton.h"
00015
00016 namespace Activ
00017 {
00018
00022 class SystemFactory : public Singleton<SystemFactory>
00023 {
00024 public:
00036     ACTIV_SYSTEM_EXPORTED_API
00037     ISystem *Create(const ISystem::Settings &settings, const IHeap::BucketInfoVector &bucketInfoVector,
00038         const std::string &systemVersion);
00039
00051     ACTIV_SYSTEM_EXPORTED_API
00052     ISystem *Open(const ISystem::Settings &settings, const std::string &processName, Timeout &timeout = Timeout::GetInfinite());
00053
00059     ACTIV_SYSTEM_EXPORTED_API
00060     static SystemFactory &GetInstance();
00061
00062 private:
00066     ACTIV_SYSTEM_EXPORTED_API
00067     ~SystemFactory();
00068
00069     friend class Singleton<SystemFactory>;
00070 };
00071
00072 } // namespace Activ
00073
00074 #endif // (!defined ACTIV_SYSTEM_SYSTEM_FACTORY_H)
Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

SystemInfo.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_BASE_SYSTEM_INFO_H)
00010 #define ACTIV_BASE_SYSTEM_INFO_H
00011
00012 #include "ActivMiddleware/ActivBase/External.h"
00013
00014 #include <string>
00015 #include <vector>
00016
00017 namespace Activ
00018 {
00019
00020 class MessageBuilder;
00021 class MessageValidator;
00022
00023 // ---------------------------------------------------------------------------------------------------------------------------------
00024
00028 class SystemInfo
00029 {
00030 public:
00036     ACTIV_BASE_EXPORTED_API SystemInfo();
00037
00043     ACTIV_BASE_EXPORTED_API void Populate();
00044
00052     ACTIV_BASE_EXPORTED_API StatusCode Serialize(MessageBuilder &messageBuilder) const;
00053
00062     ACTIV_BASE_EXPORTED_API StatusCode Serialize(MessageBuilder &messageBuilder, const SystemInfo &systemInfo) const;
00063
00071     ACTIV_BASE_EXPORTED_API StatusCode Deserialize(MessageValidator &messageValidator);
00072
00073     typedef std::vector<std::string> ProcessorInfoList;
00074
00075     // Machine info
00076     size_t              m_numberOfProcessorThreads;
00077     size_t              m_numberOfProcessorCores;
00078     size_t              m_numberOfProcessorPackages;
00079     ProcessorInfoList   m_processorInfoList;
00080
00081     uint64_t            m_physicalMemory;
00082     uint64_t            m_freeMemory;
00083     std::string         m_osName;
00084     std::string         m_schedulerInfo;
00085     std::string         m_computerName;
00086
00087     // Windows specific (not ifdef as non-Windows platform may receive SystemInfo from a Windows machine),
00088     // if m_platformType == PLATFORM_TYPE_WINDOWS
00089     uint32_t            m_windowsDpcProcessorAffinityMask;
00090
00091     // ActivMiddleware info
00092     PlatformType        m_platformType;
00093     uint32_t            m_middlewareVersionValue;
00094     std::string         m_middlewareVersion;
00095     std::string         m_middlewareDate;
00096     std::string         m_boostVersion;
00097
00098 private:
00107     ACTIV_BASE_LOCAL_API StatusCode Serialize(MessageBuilder &messageBuilder, const byte_t version) const;
00108
00109     static const byte_t currentVersion = 2;
00110
00111     byte_t              m_version;
00112 };
00113
00114 } // namespace Activ
00115
00116 #endif // (!defined ACTIV_BASE_SYSTEM_INFO_H)
Generated on Wed Oct 8 14:01:47 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

SystemMonitor.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_BASE_SYSTEM_MONITOR_H)
00010 #define ACTIV_BASE_SYSTEM_MONITOR_H
00011
00012 #include "ActivMiddleware/ActivBase/External.h"
00013 #include "ActivMiddleware/ActivBase/Process.h"
00014
00015 #include "boost/scoped_ptr.hpp"
00016
00017 #include <vector>
00018 #include <map>
00019
00020 namespace Activ
00021 {
00022
00031 class SystemMonitor : private boost::noncopyable
00032 {
00033 public:
00037     class Stats
00038     {
00039     public:
00043         class DiskInfo
00044         {
00045         public:
00046             std::string m_diskName;
00047             uint8_t     m_usagePercentage;
00048         };
00049
00053         class ProcessInfo
00054         {
00055         public:
00056             std::string m_name;
00057             uint8_t     m_averageCpuUsage;
00058             uint8_t     m_highestThreadCpuUsage;
00059             uint32_t    m_highestThreadCpuUsageId;
00060             uint64_t    m_virtualMemorySize;
00061             uint64_t    m_workingSetSize;
00062             uint64_t    m_numberOfPageFaults;
00063         };
00064
00068         ACTIV_BASE_EXPORTED_API Stats();
00069
00070         typedef std::vector<uint8_t> CpuUsageList;
00071         typedef std::map<Process::Id, ProcessInfo> ProcessInfoMap;
00072         typedef std::vector<DiskInfo> DiskInfoList;
00073
00074         CpuUsageList    m_cpuUsageList;
00075         uint8_t         m_averageCpuUsage;
00076         uint8_t         m_peakCpuUsage;
00077         ProcessInfoMap  m_processInfoMap;
00078         DiskInfoList    m_diskInfoList;
00079
00080         uint32_t        m_contextSwitchRate;
00081         uint32_t        m_pagesInOutRate;
00082
00083         uint8_t         m_freeMemoryPercent;
00084     };
00085
00093     ACTIV_BASE_EXPORTED_API SystemMonitor(const std::vector<std::string> &diskNameList = std::vector<std::string>());
00094
00098     ACTIV_BASE_EXPORTED_API ~SystemMonitor();
00099
00107     ACTIV_BASE_EXPORTED_API StatusCode AddProcess(const Process::Id processId);
00108
00114     ACTIV_BASE_EXPORTED_API void RemoveProcess(const Process::Id processId);
00115
00122     ACTIV_BASE_EXPORTED_API void CollateStats();
00123
00129     ACTIV_BASE_EXPORTED_API const Stats &GetStats();
00130
00131 private:
00132     class Impl;
00133
00134     boost::scoped_ptr<Impl> m_pImpl;
00135 };
00136
00137 } // namespace Activ
00138
00139 #endif // (!defined ACTIV_BASE_SYSTEM_MONITOR_H)
Generated on Wed Oct 8 14:01:47 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivFieldTypes

TRational.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FIELD_TYPES_TRATIONAL_H)
00010 #define ACTIV_FIELD_TYPES_TRATIONAL_H
00011
00012 #include "ActivMiddleware/ActivFieldTypes/External.h"
00013 #include "ActivMiddleware/ActivFieldTypes/IFieldType.h"
00014 #include "ActivMiddleware/ActivFieldTypes/Rational.h"
00015
00016 #include "ActivMiddleware/ActivBase/StatusCodeException.h"
00017
00018 namespace Activ
00019 {
00020
00024 #define ACTIV_TICK_LIST(d)          \
00025     d(TICK_UNCHANGED,       "=")    \
00026     d(TICK_UP,              "+")    \
00027     d(TICK_DOWN,            "-")    \
00028     d(TICK_UNDEFINED,       " ")
00029
00033 #define ACTIV_TREND_LIST(d)         \
00034     d(TREND_UNCHANGED,      "=")    \
00035     d(TREND_UP,             "+")    \
00036     d(TREND_DOWN,           "-")    \
00037     d(TREND_UNDEFINED,      " ")
00038
00039 class MessageBuilder;
00040 class MessageValidator;
00041
00042 // ---------------------------------------------------------------------------------------------------------------------------------
00043
00047 class TRational : public IFieldType
00048 {
00049 public:
00050     static const FieldType FIELD_TYPE = FIELD_TYPE_TRATIONAL;
00051
00052     using IFieldType::FromString;
00053     using IFieldType::Serialize;
00054     using IFieldType::SerializeBody;
00055     using IFieldType::SerializeLengthAndBody;
00056     using IFieldType::Deserialize;
00057     using IFieldType::DeserializeBody;
00058     using IFieldType::DeserializeLengthAndBody;
00059
00063     enum Tick
00064     {
00065         ACTIV_TICK_LIST(ACTIV_DECLARE_ELEMENT_1_WITH_COMMA)
00066         NUMBER_OF_TICKS
00067     };
00068
00072     enum Trend
00073     {
00074         ACTIV_TREND_LIST(ACTIV_DECLARE_ELEMENT_1_WITH_COMMA)
00075         NUMBER_OF_TRENDS
00076     };
00077
00081     class SerializedTrendDefinitions
00082     {
00083     public:
00084         typedef byte_t SerializedTrend;
00085
00086         static const size_t RESERVED_OFFSET             = 0;
00087         static const size_t RESERVED_LENGTH             = 2;
00088         static const size_t TICK_OFFSET                 = (RESERVED_OFFSET + RESERVED_LENGTH);
00089         static const size_t TICK_LENGTH                 = 2;
00090         static const size_t TREND_ON_DAY_OFFSET         = (TICK_OFFSET + TICK_LENGTH);
00091         static const size_t TREND_ON_DAY_LENGTH         = 2;
00092         static const size_t TREND_ON_PREVIOUS_OFFSET    = (TREND_ON_DAY_OFFSET + TREND_ON_DAY_LENGTH);
00093         static const size_t TREND_ON_PREVIOUS_LENGTH    = 2;
00094
00104         static SerializedTrend GetSerializedTrend(const Tick tick, const Trend trendOnDay, const Trend trendOnPrevious);
00105
00113         static Tick GetTick(const SerializedTrend serializedTrend);
00114
00122         static Trend GetTrendOnDay(const SerializedTrend serializedTrend);
00123
00131         static Trend GetTrendOnPrevious(const SerializedTrend serializedTrend);
00132     };
00133
00137     TRational();
00138
00151     TRational(const int64_t numerator, const Rational::Denominator denominator = Rational::DENOMINATOR_WHOLE, const Tick tick = TICK_UNDEFINED, const Trend trendOnDay = TREND_UNDEFINED, const Trend trendOnPrevious = TREND_UNDEFINED, bool shouldCompress = false);
00152
00163     TRational(const Rational &value, const Tick tick = TICK_UNDEFINED, const Trend trendOnDay = TREND_UNDEFINED, const Trend trendOnPrevious = TREND_UNDEFINED);
00164
00176     TRational(const int64_t numerator, const Rational::Denominator denominator, const TRational *pPreviousValue, const Rational *pPreviousDayValue, bool shouldCompress = false);
00177
00187     TRational(const Rational &value, const TRational *pPreviousValue, const Rational *pPreviousDayValue);
00188
00201     TRational(const int64_t numerator, const Rational::Denominator denominator, const TRational *pPreviousTick, const Rational *pPreviousValue, const Rational *pPreviousDayValue, bool shouldCompress = false);
00202
00213     TRational(const Rational &value, const TRational *pPreviousTick, const Rational *pPreviousValue, const Rational *pPreviousDayValue);
00214
00218     virtual ~TRational();
00219
00225     operator const Rational&() const;
00226
00240     StatusCode Set(const int64_t numerator, const Rational::Denominator denominator, const Tick tick = TICK_UNDEFINED, const Trend trendOnDay = TREND_UNDEFINED, const Trend trendOnPrevious = TREND_UNDEFINED, bool shouldCompress = false);
00241
00254     StatusCode Set(const Rational &value, const Tick tick = TICK_UNDEFINED, const Trend trendOnDay = TREND_UNDEFINED, const Trend trendOnPrevious = TREND_UNDEFINED);
00255
00269     StatusCode Set(const int64_t numerator, const Rational::Denominator denominator, const TRational *pPreviousValue, const Rational *pPreviousDayValue, bool shouldCompress = false);
00270
00282     StatusCode Set(const Rational &value, const TRational *pPreviousValue, const Rational *pPreviousDayValue);
00283
00298     StatusCode Set(const int64_t numerator, const Rational::Denominator denominator, const TRational *pPreviousTick, const Rational *pPreviousValue, const Rational *pPreviousDayValue, bool shouldCompress = false);
00299
00312     StatusCode Set(const Rational &value, const TRational *pPreviousTick, const Rational *pPreviousValue, const Rational *pPreviousDayValue);
00313
00326     StatusCode Get(int64_t &numerator, Rational::Denominator &denominator, Tick &tick, Trend &trendOnDay, Trend &trendOnPrevious) const;
00327
00339     StatusCode Get(Rational &value, Tick &tick, Trend &trendOnDay, Trend &trendOnPrevious) const;
00340
00348     double Get() const;
00349
00359     StatusCode GetNumeratorAndDenominator(int64_t &numerator, Rational::Denominator &denominator) const;
00360
00368     const Rational &GetRational() const;
00369
00377     int64_t GetNumerator() const;
00378
00389     StatusCode GetNumerator(int64_t &numerator, const Rational::Denominator denominator) const;
00390
00401     StatusCode GetNumeratorAndDivisor(int64_t &numerator, uint64_t &divisor) const;
00402
00415     StatusCode SetDenominator(const Rational::Denominator denominator);
00416
00424     Rational::Denominator GetDenominator() const;
00425
00432     StatusCode Compress();
00433
00443     StatusCode SetTick(const Tick tick);
00444
00454     StatusCode SetTick(const TRational &previousValue);
00455
00465     StatusCode SetTickAndTrendOnPrevious(const TRational &previousValue);
00466
00474     Tick GetTick() const;
00475
00485     StatusCode SetTrendOnDay(const Trend trend);
00486
00496     StatusCode SetTrendOnDay(const Rational &previousDayValue);
00497
00505     Trend GetTrendOnDay() const;
00506
00516     StatusCode SetTrendOnPrevious(const Trend trend);
00517
00527     StatusCode SetTrendOnPrevious(const Rational &previousValue);
00528
00536     Trend GetTrendOnPrevious() const;
00537
00538     virtual void Reset();
00539     virtual void Clear();
00540
00550     ACTIV_FIELD_TYPES_API StatusCode Compare(const TRational &rhs, int &result) const;
00551
00552     ACTIV_FIELD_TYPES_API virtual StatusCode Compare(const void * const pRhsSerializedBody, const size_t rhsSerializedBodyLength, int &result) const;
00553     ACTIV_FIELD_TYPES_API virtual StatusCode Convert(const IFieldType * const pIFieldType);
00554     ACTIV_FIELD_TYPES_API virtual std::string ToString() const;
00555
00565     ACTIV_FIELD_TYPES_API std::string ToString(const Rational::Denominator denominator) const;
00566
00567     ACTIV_FIELD_TYPES_API virtual StatusCode FromString(MessageValidator &messageValidator);
00568     ACTIV_FIELD_TYPES_API virtual std::string GetFromStringFormat() const;
00569     ACTIV_FIELD_TYPES_API virtual StatusCode Serialize(MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength) const;
00570     ACTIV_FIELD_TYPES_API virtual StatusCode SerializeBody(void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength) const;
00571     ACTIV_FIELD_TYPES_API virtual StatusCode SerializeLengthAndBody(MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength = MAX_SERIALIZED_BODY_LENGTH_UNDEFINED) const;
00572     ACTIV_FIELD_TYPES_API virtual StatusCode Deserialize(MessageValidator &messageValidator, const size_t maxSerializedBodyLength);
00573     ACTIV_FIELD_TYPES_API virtual StatusCode DeserializeBody(const void * const pSerializedBody, const size_t serializedBodyLength);
00574     ACTIV_FIELD_TYPES_API virtual StatusCode DeserializeLengthAndBody(MessageValidator &messageValidator, const size_t maxSerializedBodyLength = MAX_SERIALIZED_BODY_LENGTH_UNDEFINED);
00575     virtual size_t GetSerializedLength() const;
00576     virtual size_t GetSerializedBodyLength() const;
00577     ACTIV_FIELD_TYPES_API virtual StatusCode IsDifferent(const void * const pRhsSerializedBody, const size_t rhsSerializedBodyLength, bool &isDifferent) const;
00578
00586     static size_t GetMaxSerializedLength(const size_t size);
00587
00595     static size_t GetMaxSerializedBodyLength(const size_t size);
00596
00610     ACTIV_FIELD_TYPES_API static StatusCode Compare(const void * const pLhsSerializedBody, const size_t lhsSerializedBodyLength, const void * const pRhsSerializedBody, const size_t rhsSerializedBodyLength, int &result);
00611
00619     static bool IsValidTick(const Tick tick);
00620
00628     static bool IsValidTrend(const Trend trend);
00629
00637     ACTIV_FIELD_TYPES_API static std::string TickToString(const Tick tick);
00638
00646     ACTIV_FIELD_TYPES_API static std::string TrendToString(const Trend trend);
00647
00658     ACTIV_FIELD_TYPES_API static StatusCode ValidateSerializedLengthAndBody(MessageValidator &messageValidator, size_t &serializedBodyOffset, size_t &serializedBodyLength);
00659
00667     static bool IsValidSerializedBodyLength(const size_t serializedBodyLength);
00668
00669 private:
00670     Rational    m_value;
00671     Tick        m_tick;
00672     Trend       m_trendOnDay;
00673     Trend       m_trendOnPrevious;
00674 };
00675
00676 // ---------------------------------------------------------------------------------------------------------------------------------
00677
00678 inline TRational::TRational() :
00679     IFieldType(FIELD_TYPE)
00680 {
00681     m_isInitialized = false;
00682 }
00683
00684 // ---------------------------------------------------------------------------------------------------------------------------------
00685
00686 inline TRational::TRational(const int64_t numerator, const Rational::Denominator denominator, const Tick tick, const Trend trendOnDay, const Trend trendOnPrevious, bool shouldCompress) :
00687     IFieldType(FIELD_TYPE)
00688 {
00689     ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, Set(numerator, denominator, tick, trendOnDay, trendOnPrevious, shouldCompress));
00690 }
00691
00692 // ---------------------------------------------------------------------------------------------------------------------------------
00693
00694 inline TRational::TRational(const Rational &value, const Tick tick, const Trend trendOnDay, const Trend trendOnPrevious) :
00695     IFieldType(FIELD_TYPE)
00696 {
00697     ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, Set(value, tick, trendOnDay, trendOnPrevious));
00698 }
00699
00700 // ---------------------------------------------------------------------------------------------------------------------------------
00701
00702 inline TRational::TRational(const int64_t numerator, const Rational::Denominator denominator, const TRational *pPreviousValue, const Rational *pPreviousDayValue, bool shouldCompress) :
00703     IFieldType(FIELD_TYPE)
00704 {
00705     ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, Set(numerator, denominator, pPreviousValue, pPreviousDayValue, shouldCompress));
00706 }
00707
00708 // ---------------------------------------------------------------------------------------------------------------------------------
00709
00710 inline TRational::TRational(const Rational &value, const TRational *pPreviousValue, const Rational *pPreviousDayValue) :
00711     IFieldType(FIELD_TYPE)
00712 {
00713     ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, Set(value, pPreviousValue, pPreviousDayValue));
00714 }
00715
00716 // ---------------------------------------------------------------------------------------------------------------------------------
00717
00718 inline TRational::TRational(const int64_t numerator, const Rational::Denominator denominator, const TRational *pPreviousTick, const Rational *pPreviousValue, const Rational *pPreviousDayValue, bool shouldCompress) :
00719     IFieldType(FIELD_TYPE)
00720 {
00721     ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, Set(numerator, denominator, pPreviousTick, pPreviousValue, pPreviousDayValue, shouldCompress));
00722 }
00723
00724 // ---------------------------------------------------------------------------------------------------------------------------------
00725
00726 inline TRational::TRational(const Rational &value, const TRational *pPreviousTick, const Rational *pPreviousValue, const Rational *pPreviousDayValue) :
00727     IFieldType(FIELD_TYPE)
00728 {
00729     ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, Set(value, pPreviousTick, pPreviousValue, pPreviousDayValue));
00730 }
00731
00732 // ---------------------------------------------------------------------------------------------------------------------------------
00733
00734 inline TRational::~TRational()
00735 {
00736 }
00737
00738 // ---------------------------------------------------------------------------------------------------------------------------------
00739
00740 inline TRational::operator const Rational&() const
00741 {
00742     return m_value;
00743 }
00744
00745 // ---------------------------------------------------------------------------------------------------------------------------------
00746
00747 inline StatusCode TRational::Set(const int64_t numerator, const Rational::Denominator denominator, const Tick tick, const Trend trendOnDay, const Trend trendOnPrevious, bool shouldCompress)
00748 {
00749     if ((!IsValidTick(tick)) || (!IsValidTrend(trendOnDay)) || (!IsValidTrend(trendOnPrevious)))
00750         return STATUS_CODE_INVALID_PARAMETER;
00751
00752     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, m_value.Set(numerator, denominator, shouldCompress));
00753
00754     m_tick = tick;
00755     m_trendOnDay = trendOnDay;
00756     m_trendOnPrevious = trendOnPrevious;
00757     m_isInitialized = true;
00758
00759     return STATUS_CODE_SUCCESS;
00760 }
00761
00762 // ---------------------------------------------------------------------------------------------------------------------------------
00763
00764 inline StatusCode TRational::Set(const Rational &value, const Tick tick, const Trend trendOnDay, const Trend trendOnPrevious)
00765 {
00766     if (!value.IsInitialized())
00767         return STATUS_CODE_NOT_INITIALIZED;
00768
00769     if ((!IsValidTick(tick)) || (!IsValidTrend(trendOnDay)) || (!IsValidTrend(trendOnPrevious)))
00770         return STATUS_CODE_INVALID_PARAMETER;
00771
00772     m_value = value;
00773     m_tick = tick;
00774     m_trendOnDay = trendOnDay;
00775     m_trendOnPrevious = trendOnPrevious;
00776     m_isInitialized = true;
00777
00778     return STATUS_CODE_SUCCESS;
00779 }
00780
00781 // ---------------------------------------------------------------------------------------------------------------------------------
00782
00783 inline StatusCode TRational::Set(const int64_t numerator, const Rational::Denominator denominator, const TRational *pPreviousValue, const Rational *pPreviousDayValue, bool shouldCompress)
00784 {
00785     Rational value;
00786     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, value.Set(numerator, denominator, shouldCompress));
00787
00788     return Set(value, pPreviousValue, pPreviousDayValue);
00789 }
00790
00791 // ---------------------------------------------------------------------------------------------------------------------------------
00792
00793 inline StatusCode TRational::Set(const Rational &value, const TRational *pPreviousValue, const Rational *pPreviousDayValue)
00794 {
00795     if (!value.IsInitialized())
00796         return STATUS_CODE_NOT_INITIALIZED;
00797
00798     TRational newValue(value);
00799
00800     if ((0 != pPreviousValue) && (pPreviousValue->IsInitialized()))
00801         ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, newValue.SetTickAndTrendOnPrevious(*pPreviousValue));
00802     if ((0 != pPreviousDayValue) && (pPreviousDayValue->IsInitialized()))
00803         ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, newValue.SetTrendOnDay(*pPreviousDayValue));
00804
00805     (*this) = newValue;
00806
00807     return STATUS_CODE_SUCCESS;
00808 }
00809
00810 // ---------------------------------------------------------------------------------------------------------------------------------
00811
00812 inline StatusCode TRational::Set(const int64_t numerator, const Rational::Denominator denominator, const TRational *pPreviousTick, const Rational *pPreviousValue, const Rational *pPreviousDayValue, bool shouldCompress)
00813 {
00814     Rational value;
00815     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, value.Set(numerator, denominator, shouldCompress));
00816
00817     return Set(value, pPreviousTick, pPreviousValue, pPreviousDayValue);
00818 }
00819
00820 // ---------------------------------------------------------------------------------------------------------------------------------
00821
00822 inline StatusCode TRational::Set(const Rational &value, const TRational *pPreviousTick, const Rational *pPreviousValue, const Rational *pPreviousDayValue)
00823 {
00824     if (!value.IsInitialized())
00825         return STATUS_CODE_NOT_INITIALIZED;
00826
00827     TRational newValue(value);
00828
00829     if ((0 != pPreviousTick) && (pPreviousTick->IsInitialized()))
00830         ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, newValue.SetTick(*pPreviousTick));
00831     if ((0 != pPreviousValue) && (pPreviousValue->IsInitialized()))
00832         ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, newValue.SetTrendOnPrevious(*pPreviousValue));
00833     if ((0 != pPreviousDayValue) && (pPreviousDayValue->IsInitialized()))
00834         ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, newValue.SetTrendOnDay(*pPreviousDayValue));
00835
00836     (*this) = newValue;
00837
00838     return STATUS_CODE_SUCCESS;
00839 }
00840
00841 // ---------------------------------------------------------------------------------------------------------------------------------
00842
00843 inline StatusCode TRational::Get(int64_t &numerator, Rational::Denominator &denominator, Tick &tick, Trend &trendOnDay, Trend &trendOnPrevious) const
00844 {
00845     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, m_value.Get(numerator, denominator));
00846
00847     tick = m_tick;
00848     trendOnDay = m_trendOnDay;
00849     trendOnPrevious = m_trendOnPrevious;
00850
00851     return STATUS_CODE_SUCCESS;
00852 }
00853
00854 // ---------------------------------------------------------------------------------------------------------------------------------
00855
00856 inline StatusCode TRational::Get(Rational &value, Tick &tick, Trend &trendOnDay, Trend &trendOnPrevious) const
00857 {
00858     if (!IsInitialized())
00859         return STATUS_CODE_NOT_INITIALIZED;
00860
00861     value = m_value;
00862     tick = m_tick;
00863     trendOnDay = m_trendOnDay;
00864     trendOnPrevious = m_trendOnPrevious;
00865
00866     return STATUS_CODE_SUCCESS;
00867 }
00868
00869 // ---------------------------------------------------------------------------------------------------------------------------------
00870
00871 inline double TRational::Get() const
00872 {
00873     return m_value.Get();
00874 }
00875
00876 // ---------------------------------------------------------------------------------------------------------------------------------
00877
00878 inline StatusCode TRational::GetNumeratorAndDenominator(int64_t &numerator, Rational::Denominator &denominator) const
00879 {
00880     return m_value.Get(numerator, denominator);
00881 }
00882
00883 // ---------------------------------------------------------------------------------------------------------------------------------
00884
00885 inline const Rational &TRational::GetRational() const
00886 {
00887     return m_value;
00888 }
00889
00890 // ---------------------------------------------------------------------------------------------------------------------------------
00891
00892 inline int64_t TRational::GetNumerator() const
00893 {
00894     return m_value.GetNumerator();
00895 }
00896
00897 // ---------------------------------------------------------------------------------------------------------------------------------
00898
00899 inline StatusCode TRational::GetNumerator(int64_t &numerator, const Rational::Denominator denominator) const
00900 {
00901     return m_value.GetNumerator(numerator, denominator);
00902 }
00903
00904 // ---------------------------------------------------------------------------------------------------------------------------------
00905
00906 inline StatusCode TRational::GetNumeratorAndDivisor(int64_t &numerator, uint64_t &divisor) const
00907 {
00908     return m_value.GetNumeratorAndDivisor(numerator, divisor);
00909 }
00910
00911 // ---------------------------------------------------------------------------------------------------------------------------------
00912
00913 inline StatusCode TRational::SetDenominator(const Rational::Denominator denominator)
00914 {
00915     return m_value.SetDenominator(denominator);
00916 }
00917
00918 // ---------------------------------------------------------------------------------------------------------------------------------
00919
00920 inline Rational::Denominator TRational::GetDenominator() const
00921 {
00922     return m_value.GetDenominator();
00923 }
00924
00925 // ---------------------------------------------------------------------------------------------------------------------------------
00926
00927 inline StatusCode TRational::Compress()
00928 {
00929     return m_value.Compress();
00930 }
00931
00932 // ---------------------------------------------------------------------------------------------------------------------------------
00933
00934 inline StatusCode TRational::SetTick(const Tick tick)
00935 {
00936     if (!IsInitialized())
00937         return STATUS_CODE_NOT_INITIALIZED;
00938
00939     if (!IsValidTick(tick))
00940         return STATUS_CODE_INVALID_PARAMETER;
00941
00942     m_tick = tick;
00943
00944     return STATUS_CODE_SUCCESS;
00945 }
00946
00947 // ---------------------------------------------------------------------------------------------------------------------------------
00948
00949 inline StatusCode TRational::SetTick(const TRational &previousValue)
00950 {
00951     int result;
00952     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, m_value.Compare(previousValue.m_value, result));
00953
00954     m_tick = ((result < 0) ? TICK_DOWN : ((result > 0) ? TICK_UP : previousValue.m_tick));
00955
00956     return STATUS_CODE_SUCCESS;
00957 }
00958
00959 // ---------------------------------------------------------------------------------------------------------------------------------
00960
00961 inline StatusCode TRational::SetTickAndTrendOnPrevious(const TRational &previousValue)
00962 {
00963     int result;
00964     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, m_value.Compare(previousValue.GetRational(), result));
00965
00966     if (result < 0)
00967     {
00968         m_tick = TICK_DOWN;
00969         m_trendOnPrevious = TREND_DOWN;
00970     }
00971     else if (result > 0)
00972     {
00973         m_tick = TICK_UP;
00974         m_trendOnPrevious = TREND_UP;
00975     }
00976     else
00977     {
00978         m_tick = previousValue.m_tick;
00979         m_trendOnPrevious = TREND_UNCHANGED;
00980     }
00981
00982     return STATUS_CODE_SUCCESS;
00983 }
00984
00985 // ---------------------------------------------------------------------------------------------------------------------------------
00986
00987 inline TRational::Tick TRational::GetTick() const
00988 {
00989     if (!IsInitialized())
00990         ACTIV_THROW(StatusCodeException, STATUS_CODE_NOT_INITIALIZED);
00991
00992     return m_tick;
00993 }
00994
00995 // ---------------------------------------------------------------------------------------------------------------------------------
00996
00997 inline StatusCode TRational::SetTrendOnDay(const Trend trend)
00998 {
00999     if (!IsInitialized())
01000         return STATUS_CODE_NOT_INITIALIZED;
01001
01002     if (!IsValidTrend(trend))
01003         return STATUS_CODE_INVALID_PARAMETER;
01004
01005     m_trendOnDay = trend;
01006
01007     return STATUS_CODE_SUCCESS;
01008 }
01009
01010 // ---------------------------------------------------------------------------------------------------------------------------------
01011
01012 inline StatusCode TRational::SetTrendOnDay(const Rational &previousDayValue)
01013 {
01014     int result;
01015     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, m_value.Compare(previousDayValue, result));
01016
01017     m_trendOnDay = ((result < 0) ? TREND_DOWN : ((result > 0) ? TREND_UP : TREND_UNCHANGED));
01018
01019     return STATUS_CODE_SUCCESS;
01020 }
01021
01022 // ---------------------------------------------------------------------------------------------------------------------------------
01023
01024 inline TRational::Trend TRational::GetTrendOnDay() const
01025 {
01026     if (!IsInitialized())
01027         ACTIV_THROW(StatusCodeException, STATUS_CODE_NOT_INITIALIZED);
01028
01029     return m_trendOnDay;
01030 }
01031
01032 // ---------------------------------------------------------------------------------------------------------------------------------
01033
01034 inline StatusCode TRational::SetTrendOnPrevious(const Trend trend)
01035 {
01036     if (!IsInitialized())
01037         return STATUS_CODE_NOT_INITIALIZED;
01038
01039     if (!IsValidTrend(trend))
01040         return STATUS_CODE_INVALID_PARAMETER;
01041
01042     m_trendOnPrevious = trend;
01043
01044     return STATUS_CODE_SUCCESS;
01045 }
01046
01047 // ---------------------------------------------------------------------------------------------------------------------------------
01048
01049 inline StatusCode TRational::SetTrendOnPrevious(const Rational &previousValue)
01050 {
01051     int result;
01052     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, m_value.Compare(previousValue, result));
01053
01054     m_trendOnPrevious = ((result < 0) ? TREND_DOWN : ((result > 0) ? TREND_UP : TREND_UNCHANGED));
01055
01056     return STATUS_CODE_SUCCESS;
01057 }
01058
01059 // ---------------------------------------------------------------------------------------------------------------------------------
01060
01061 inline TRational::Trend TRational::GetTrendOnPrevious() const
01062 {
01063     if (!IsInitialized())
01064         ACTIV_THROW(StatusCodeException, STATUS_CODE_NOT_INITIALIZED);
01065
01066     return m_trendOnPrevious;
01067 }
01068
01069 // ---------------------------------------------------------------------------------------------------------------------------------
01070
01071 inline void TRational::Reset()
01072 {
01073     m_value.Reset();
01074     m_isInitialized = false;
01075 }
01076
01077 // ---------------------------------------------------------------------------------------------------------------------------------
01078
01079 inline void TRational::Clear()
01080 {
01081     m_value.Clear();
01082     m_isInitialized = false;
01083 }
01084
01085 // ---------------------------------------------------------------------------------------------------------------------------------
01086
01087 inline size_t TRational::GetSerializedLength() const
01088 {
01089     return m_value.GetSerializedLength() + sizeof(SerializedTrendDefinitions::SerializedTrend);
01090 }
01091
01092 // ---------------------------------------------------------------------------------------------------------------------------------
01093
01094 inline size_t TRational::GetSerializedBodyLength() const
01095 {
01096     return m_value.GetSerializedBodyLength() + sizeof(SerializedTrendDefinitions::SerializedTrend);
01097 }
01098
01099 // ---------------------------------------------------------------------------------------------------------------------------------
01100
01101 inline size_t TRational::GetMaxSerializedLength(const size_t size)
01102 {
01103     return Rational::GetMaxSerializedLength(size) + sizeof(SerializedTrendDefinitions::SerializedTrend);
01104 }
01105
01106 // ---------------------------------------------------------------------------------------------------------------------------------
01107
01108 inline size_t TRational::GetMaxSerializedBodyLength(const size_t size)
01109 {
01110     return Rational::GetMaxSerializedBodyLength(size) + sizeof(SerializedTrendDefinitions::SerializedTrend);
01111 }
01112
01113 // ---------------------------------------------------------------------------------------------------------------------------------
01114
01115 inline bool TRational::IsValidTick(const Tick tick)
01116 {
01117     return ((tick != TICK_UNCHANGED) && (tick < NUMBER_OF_TICKS));
01118 }
01119
01120 // ---------------------------------------------------------------------------------------------------------------------------------
01121
01122 inline bool TRational::IsValidTrend(const Trend trend)
01123 {
01124     return (trend < NUMBER_OF_TRENDS);
01125 }
01126
01127 // ---------------------------------------------------------------------------------------------------------------------------------
01128
01129 inline bool TRational::IsValidSerializedBodyLength(const size_t serializedBodyLength)
01130 {
01131     return ((GetMaxSerializedBodyLength(sizeof(int64_t)) == serializedBodyLength) || (GetMaxSerializedBodyLength(sizeof(int32_t)) == serializedBodyLength) || (GetMaxSerializedBodyLength(sizeof(int16_t)) == serializedBodyLength) || (GetMaxSerializedBodyLength(sizeof(int8_t)) == serializedBodyLength));
01132 }
01133
01134 // ---------------------------------------------------------------------------------------------------------------------------------
01135 // ---------------------------------------------------------------------------------------------------------------------------------
01136
01137 inline TRational::SerializedTrendDefinitions::SerializedTrend TRational::SerializedTrendDefinitions::GetSerializedTrend(const Tick tick, const Trend trendOnDay, const Trend trendOnPrevious)
01138 {
01139     return static_cast<SerializedTrend>((tick << ((sizeof(SerializedTrend) * CHAR_BIT) - (TICK_OFFSET + TICK_LENGTH))) | (trendOnDay << ((sizeof(SerializedTrend) * CHAR_BIT) - (TREND_ON_DAY_OFFSET + TREND_ON_DAY_LENGTH))) | (trendOnPrevious << ((sizeof(SerializedTrend) * CHAR_BIT) - (TREND_ON_PREVIOUS_OFFSET + TREND_ON_PREVIOUS_LENGTH))));
01140 }
01141
01142 // ---------------------------------------------------------------------------------------------------------------------------------
01143
01144 inline TRational::Tick TRational::SerializedTrendDefinitions::GetTick(const SerializedTrend serializedTrend)
01145 {
01146     return static_cast<Tick>((serializedTrend >> ((sizeof(SerializedTrend) * CHAR_BIT) - (TICK_OFFSET + TICK_LENGTH))) & ((1 << TICK_LENGTH) - 1));
01147 }
01148
01149 // ---------------------------------------------------------------------------------------------------------------------------------
01150
01151 inline TRational::Trend TRational::SerializedTrendDefinitions::GetTrendOnDay(const SerializedTrend serializedTrend)
01152 {
01153     return static_cast<Trend>((serializedTrend >> ((sizeof(SerializedTrend) * CHAR_BIT) - (TREND_ON_DAY_OFFSET + TREND_ON_DAY_LENGTH))) & ((1 << TREND_ON_DAY_LENGTH) - 1));
01154 }
01155
01156 // ---------------------------------------------------------------------------------------------------------------------------------
01157
01158 inline TRational::Trend TRational::SerializedTrendDefinitions::GetTrendOnPrevious(const SerializedTrend serializedTrend)
01159 {
01160     return static_cast<Trend>((serializedTrend >> ((sizeof(SerializedTrend) * CHAR_BIT) - (TREND_ON_PREVIOUS_OFFSET + TREND_ON_PREVIOUS_LENGTH))) & ((1 << TREND_ON_PREVIOUS_LENGTH) - 1));
01161 }
01162
01163 // ---------------------------------------------------------------------------------------------------------------------------------
01164 // ---------------------------------------------------------------------------------------------------------------------------------
01165
01169 template<>
01170 class FieldTypeToClass<FIELD_TYPE_TRATIONAL>
01171 {
01172 public:
01173     typedef TRational Type;
01174 };
01175
01176 } // namespace Activ
01177
01178 #endif // (!defined ACTIV_FIELD_TYPES_TRATIONAL_H)
Generated on Wed Oct 8 14:01:48 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon

TableNumbers.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FEED_COMMON_TABLE_NUMBERS_H)
00010 #define ACTIV_FEED_COMMON_TABLE_NUMBERS_H
00011
00012 #include "ActivMiddleware/Activ.h"
00013
00014 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedDefinitions.h"
00015
00016 #include <vector>
00017
00018 namespace Activ
00019 {
00020
00021 namespace ContentPlatform
00022 {
00023
00024 namespace Feed
00025 {
00026
00027 typedef std::vector<TableNo> TableNoList;
00028
00029 const TableNo TABLE_NO_US_LISTING = 0;
00030 const TableNo TABLE_NO_US_EQUITY_OPTION = 1;
00031 const TableNo TABLE_NO_NA_INDEX = 2;
00032 const TableNo TABLE_NO_US_MARKET_MAKER_QUOTE = 3;
00033 const TableNo TABLE_NO_EU_MARKET_MAKER_QUOTE = 4;
00034 const TableNo TABLE_NO_AMERICAS_LISTING = 5;
00035 const TableNo TABLE_NO_NA_ORDER = 6;
00036 const TableNo TABLE_NO_LA_ORDER = 7;
00037 const TableNo TABLE_NO_EU_ORDER = 8;
00038 const TableNo TABLE_NO_AP_ORDER = 9;
00039 const TableNo TABLE_NO_AP_MARKET_MAKER_QUOTE = 10;
00040 const TableNo TABLE_NO_US_FUTURE = 16;
00041 const TableNo TABLE_NO_US_FUTURE_OPTION = 17;
00042 const TableNo TABLE_NO_US_LISTING_BBO10 = 19;
00043 const TableNo TABLE_NO_US_EQUITY_OPTION_BBO10 = 20;
00044 const TableNo TABLE_NO_NA_MUTUAL_FUND = 21;
00045 const TableNo TABLE_NO_NA_MONEY_MARKET = 22;
00046 const TableNo TABLE_NO_NA_FUND = 23;
00047 const TableNo TABLE_NO_NA_FOREX = 24;
00048 const TableNo TABLE_NO_NA_OPTION_ROOT = 25;
00049 const TableNo TABLE_NO_NA_OPTION_DELIVERABLE = 26;
00050 const TableNo TABLE_NO_NA_FUTURE_ROOT = 27;
00051 const TableNo TABLE_NO_NA_FUTURE_OPTION_ROOT = 28;
00052 const TableNo TABLE_NO_NA_SYNTHETIC = 29;
00053 const TableNo TABLE_NO_NA_SECURITY = 30;
00054 const TableNo TABLE_NO_NA_COMPANY = 31;
00055 const TableNo TABLE_NO_NA_BANK_COMPANY = 32;
00056 const TableNo TABLE_NO_NA_INDUSTRIAL_COMPANY = 33;
00057 const TableNo TABLE_NO_NA_INSURANCE_COMPANY = 34;
00058 const TableNo TABLE_NO_NA_THRIFT_COMPANY = 35;
00059 const TableNo TABLE_NO_NA_SECTOR = 36;
00060 const TableNo TABLE_NO_EXCHANGE = 37;
00061 const TableNo TABLE_NO_NA_STATISTICS = 39;
00062 const TableNo TABLE_NO_NA_ANALYTICS = 40;
00063 const TableNo TABLE_NO_NA_RANKINGS = 41;
00064 const TableNo TABLE_NO_AMERICAS_FUTURE = 42;
00065 const TableNo TABLE_NO_AMERICAS_EQUITY_OPTION = 43;
00066 const TableNo TABLE_NO_AMERICAS_FUTURE_OPTION = 44;
00067 const TableNo TABLE_NO_US_STRATEGY = 45;
00068 const TableNo TABLE_NO_US_FUTURE_SPREAD = 46;
00069 const TableNo TABLE_NO_US_FUTURE_BBO10 = 50;
00070 const TableNo TABLE_NO_US_FUTURE_OPTION_BBO10 = 51;
00071 const TableNo TABLE_NO_AMERICAS_LISTING_BBO10 = 52;
00072 const TableNo TABLE_NO_AMERICAS_FUTURE_BBO10 = 53;
00073 const TableNo TABLE_NO_AMERICAS_EQUITY_OPTION_BBO10 = 54;
00074 const TableNo TABLE_NO_AMERICAS_FUTURE_OPTION_BBO10 = 55;
00075 const TableNo TABLE_NO_US_FUTURE_SPREAD_BBO10 = 56;
00076 const TableNo TABLE_NO_AMERICAS_FUTURE_SPREAD = 64;
00077 const TableNo TABLE_NO_US_STRATEGY_LEG = 80;
00078 const TableNo TABLE_NO_US_STRATEGY_BBO10 = 81;
00079 const TableNo TABLE_NO_RELATIONSHIP = 100;
00080 const TableNo TABLE_NO_NA_COMPANY_DOMICILE_NAVIGATION = 101;
00081 const TableNo TABLE_NO_NA_FUTURE_OPTION_ROOT_FUTURE_OPTION_PATTERN_NAVIGATION = 102;
00082 const TableNo TABLE_NO_NA_FUTURE_FUTURE_ROOT_NAVIGATION = 103;
00083 const TableNo TABLE_NO_NA_INDEX_CONSTITUENT_NAVIGATION = 104;
00084 const TableNo TABLE_NO_NA_LISTING_SECURITY_NAVIGATION = 105;
00085 const TableNo TABLE_NO_NA_OPTION_ROOT_OPTION_DELIVERABLE_NAVIGATION = 106;
00086 const TableNo TABLE_NO_NA_OPTION_ROOT_UNDERLYING_NAVIGATION = 107;
00087 const TableNo TABLE_NO_NA_SECTOR_CONSTITUENT_NAVIGATION = 108;
00088 const TableNo TABLE_NO_NA_SECURITY_COMPANY_NAVIGATION = 109;
00089 const TableNo TABLE_NO_NA_SYNTHETIC_CONSTITUENT_NAVIGATION = 110;
00090 const TableNo TABLE_NO_NA_LISTING_COMPANY_NAVIGATION = 111;
00091 const TableNo TABLE_NO_NA_ANALYTICS_NAVIGATION = 112;
00092 const TableNo TABLE_NO_NA_PRIMARY_LISTING_NAVIGATION = 113;
00093 const TableNo TABLE_NO_NA_FUTURE_FUTURE_OPTION_EXPIRATION_NAVIGATION = 114;
00094 const TableNo TABLE_NO_NA_FUNDAMENTAL_NAVIGATION = 115;
00095 const TableNo TABLE_NO_NA_UNDERLYING_OPTION_PATTERN_NAVIGATION = 116;
00096 const TableNo TABLE_NO_NA_FUTURE_FUTURE_OPTION_PATTERN_NAVIGATION = 117;
00097 const TableNo TABLE_NO_NA_FUTURE_ROOT_FUTURE_PATTERN_NAVIGATION = 118;
00098 const TableNo TABLE_NO_NA_UNDERLYING_FUTURE_PATTERN_NAVIGATION = 119;
00099 const TableNo TABLE_NO_NA_UNDERLYING_BBO_DEPTH_NAVIGATION = 120;
00100 const TableNo TABLE_NO_NA_OPTION_ROOT_OPTION_PATTERN_NAVIGATION = 121;
00101 const TableNo TABLE_NO_NA_FUTURE_ROOT_FUTURE_SPREAD_PATTERN_NAVIGATION = 122;
00102 const TableNo TABLE_NO_NA_UNDERLYING_FUTURE_ROOT_NAVIGATION = 123;
00103 const TableNo TABLE_NO_NA_STRATEGY_STRATEGY_LEG_PATTERN_NAVIGATION = 124;
00104 const TableNo TABLE_NO_NA_STRATEGY_UNDERLYING_NAVIGATION = 125;
00105 const TableNo TABLE_NO_NA_STRATEGY_LEG_UNDERLYING_NAVIGATION = 126;
00106 const TableNo TABLE_NO_NA_UNDERLYING_NON_STANDARD_OPTION_PATTERN_NAVIGATION = 127;
00107 const TableNo TABLE_NO_NA_NON_STANDARD_OPTION_ROOT_UNDERLYING_NAVIGATION = 128;
00108 const TableNo TABLE_NO_NA_EXCHANGE_INSTRUMENT_PATTERN_NAVIGATION = 129;
00109 const TableNo TABLE_NO_NA_CORPORATE_EVENTS = 200;
00110 const TableNo TABLE_NO_NA_DELIST = 201;
00111 const TableNo TABLE_NO_NA_DIVIDEND = 202;
00112 const TableNo TABLE_NO_NA_IPO = 203;
00113 const TableNo TABLE_NO_NA_SPLIT = 204;
00114 const TableNo TABLE_NO_NA_SYMBOL_CHANGE = 205;
00115 const TableNo TABLE_NO_NA_OPTION_SYMBOL_EVENT = 206;
00116 const TableNo TABLE_NO_CUG = 300;
00117 const TableNo TABLE_NO_PERMISSION = 301;
00118 const TableNo TABLE_NO_USER = 302;
00119 const TableNo TABLE_NO_CONTRIBUTION_USER = 303;
00120 const TableNo TABLE_NO_NA_FEED_STATUS = 350;
00121 const TableNo TABLE_NO_LATENCY = 351;
00122 const TableNo TABLE_NO_NA_FEED_STATISTICS = 352;
00123 const TableNo TABLE_NO_NEWS = 400;
00124 const TableNo TABLE_NO_NEWS_HEADLINE = 401;
00125 const TableNo TABLE_NO_NA_SYSTEM_MESSAGE = 402;
00126 const TableNo TABLE_NO_TIME_SERIES_TRADE = 500;
00127 const TableNo TABLE_NO_TIME_SERIES_INTRADAY = 501;
00128 const TableNo TABLE_NO_TIME_SERIES_HISTORY = 502;
00129 const TableNo TABLE_NO_COMPOSITE_EXCHANGE = 503;
00130 const TableNo TABLE_NO_TIME_SERIES_ADJUSTMENT = 504;
00131 const TableNo TABLE_NO_NA_MISCELLANEOUS_ALIAS = 600;
00132 const TableNo TABLE_NO_NA_FUTURE_ALIAS = 601;
00133 const TableNo TABLE_NO_TABLE_TEMPLATE_LIST_METADATA = 700;
00134 const TableNo TABLE_NO_UNIVERSAL_FIELD_LIST_METADATA = 701;
00135 const TableNo TABLE_NO_TABLE_TEMPLATE_FIELD_LIST_METADATA = 702;
00136 const TableNo TABLE_NO_TABLE_TEMPLATE_INDEX_LIST_METADATA = 703;
00137 const TableNo TABLE_NO_TABLE_TEMPLATE_INDEX_FIELD_LIST_METADATA = 704;
00138 const TableNo TABLE_NO_PERMISSION_METADATA = 705;
00139 const TableNo TABLE_NO_ENTITY_TYPE_RELATIONSHIP_FIELD = 706;
00140 const TableNo TABLE_NO_TABLE_ENTITY_TYPE = 707;
00141 const TableNo TABLE_NO_EXCHANGE_ENTITY_TYPE_TABLE = 708;
00142 const TableNo TABLE_NO_WORKSTATION_USER = 709;
00143 const TableNo TABLE_NO_AP_LISTING = 1000;
00144 const TableNo TABLE_NO_AP_OPTION = 1001;
00145 const TableNo TABLE_NO_AP_FUTURE = 1002;
00146 const TableNo TABLE_NO_AP_FUTURE_OPTION = 1003;
00147 const TableNo TABLE_NO_AP_INDEX = 1004;
00148 const TableNo TABLE_NO_AP_SESSION_LISTING = 1005;
00149 const TableNo TABLE_NO_AP_SESSION_OPTION = 1006;
00150 const TableNo TABLE_NO_AP_SESSION_FUTURE = 1007;
00151 const TableNo TABLE_NO_AP_SESSION_FUTURE_OPTION = 1008;
00152 const TableNo TABLE_NO_AP_SESSION_INDEX = 1009;
00153 const TableNo TABLE_NO_AP_LISTING_BBO10 = 1010;
00154 const TableNo TABLE_NO_AP_OPTION_BBO10 = 1011;
00155 const TableNo TABLE_NO_AP_FUTURE_BBO10 = 1012;
00156 const TableNo TABLE_NO_AP_FUTURE_OPTION_BBO10 = 1013;
00157 const TableNo TABLE_NO_HKSE_ORDER = 1014;
00158 const TableNo TABLE_NO_AP_SECURITY = 1015;
00159 const TableNo TABLE_NO_AP_COMPANY = 1016;
00160 const TableNo TABLE_NO_AP_OPTION_ROOT = 1017;
00161 const TableNo TABLE_NO_AP_FUTURE_ROOT = 1018;
00162 const TableNo TABLE_NO_AP_FUTURE_OPTION_ROOT = 1019;
00163 const TableNo TABLE_NO_AP_FUTURE_SPREAD = 1020;
00164 const TableNo TABLE_NO_AP_FUTURE_SPREAD_BBO10 = 1021;
00165 const TableNo TABLE_NO_AP_STATISTICS = 1022;
00166 const TableNo TABLE_NO_AP_ANALYTICS = 1023;
00167 const TableNo TABLE_NO_AP_RANKINGS = 1024;
00168 const TableNo TABLE_NO_AP_SESSION_STRATEGY = 1025;
00169 const TableNo TABLE_NO_AP_STRATEGY_LEG = 1026;
00170 const TableNo TABLE_NO_AP_STRATEGY_BBO10 = 1027;
00171 const TableNo TABLE_NO_AP_OPTION_DELIVERABLE = 1028;
00172 const TableNo TABLE_NO_AP_WARRANT = 1029;
00173 const TableNo TABLE_NO_AP_SESSION_WARRANT = 1030;
00174 const TableNo TABLE_NO_AP_WARRANT_BBO10 = 1031;
00175 const TableNo TABLE_NO_AP_COMPANY_DOMICILE_NAVIGATION = 1101;
00176 const TableNo TABLE_NO_AP_FUTURE_OPTION_ROOT_FUTURE_OPTION_PATTERN_NAVIGATION = 1102;
00177 const TableNo TABLE_NO_AP_FUTURE_FUTURE_ROOT_NAVIGATION = 1103;
00178 const TableNo TABLE_NO_AP_INDEX_CONSTITUENT_NAVIGATION = 1104;
00179 const TableNo TABLE_NO_AP_LISTING_SECURITY_NAVIGATION = 1105;
00180 const TableNo TABLE_NO_AP_OPTION_ROOT_OPTION_DELIVERABLE_NAVIGATION = 1106;
00181 const TableNo TABLE_NO_AP_OPTION_ROOT_UNDERLYING_NAVIGATION = 1107;
00182 const TableNo TABLE_NO_AP_SECTOR_CONSTITUENT_NAVIGATION = 1108;
00183 const TableNo TABLE_NO_AP_SECURITY_COMPANY_NAVIGATION = 1109;
00184 const TableNo TABLE_NO_AP_SYNTHETIC_CONSTITUENT_NAVIGATION = 1110;
00185 const TableNo TABLE_NO_AP_LISTING_COMPANY_NAVIGATION = 1111;
00186 const TableNo TABLE_NO_AP_ANALYTICS_NAVIGATION = 1112;
00187 const TableNo TABLE_NO_AP_PRIMARY_LISTING_NAVIGATION = 1113;
00188 const TableNo TABLE_NO_AP_FUTURE_FUTURE_OPTION_EXPIRATION_NAVIGATION = 1114;
00189 const TableNo TABLE_NO_AP_FUNDAMENTAL_NAVIGATION = 1115;
00190 const TableNo TABLE_NO_AP_UNDERLYING_OPTION_PATTERN_NAVIGATION = 1116;
00191 const TableNo TABLE_NO_AP_FUTURE_FUTURE_OPTION_PATTERN_NAVIGATION = 1117;
00192 const TableNo TABLE_NO_AP_FUTURE_ROOT_FUTURE_PATTERN_NAVIGATION = 1118;
00193 const TableNo TABLE_NO_AP_UNDERLYING_FUTURE_PATTERN_NAVIGATION = 1119;
00194 const TableNo TABLE_NO_AP_UNDERLYING_BBO_DEPTH_NAVIGATION = 1120;
00195 const TableNo TABLE_NO_AP_OPTION_ROOT_OPTION_PATTERN_NAVIGATION = 1121;
00196 const TableNo TABLE_NO_AP_FUTURE_ROOT_FUTURE_SPREAD_PATTERN_NAVIGATION = 1122;
00197 const TableNo TABLE_NO_AP_UNDERLYING_FUTURE_ROOT_NAVIGATION = 1123;
00198 const TableNo TABLE_NO_AP_STRATEGY_STRATEGY_LEG_PATTERN_NAVIGATION = 1124;
00199 const TableNo TABLE_NO_AP_STRATEGY_UNDERLYING_NAVIGATION = 1125;
00200 const TableNo TABLE_NO_AP_STRATEGY_LEG_UNDERLYING_NAVIGATION = 1126;
00201 const TableNo TABLE_NO_AP_UNDERLYING_NON_STANDARD_OPTION_PATTERN_NAVIGATION = 1127;
00202 const TableNo TABLE_NO_AP_NON_STANDARD_OPTION_ROOT_UNDERLYING_NAVIGATION = 1128;
00203 const TableNo TABLE_NO_AP_CORPORATE_EVENTS = 1200;
00204 const TableNo TABLE_NO_AP_DELIST = 1201;
00205 const TableNo TABLE_NO_AP_DIVIDEND = 1202;
00206 const TableNo TABLE_NO_AP_IPO = 1203;
00207 const TableNo TABLE_NO_AP_SPLIT = 1204;
00208 const TableNo TABLE_NO_AP_SYMBOL_CHANGE = 1205;
00209 const TableNo TABLE_NO_AP_FEED_STATUS = 1350;
00210 const TableNo TABLE_NO_AP_FEED_STATISTICS = 1352;
00211 const TableNo TABLE_NO_AP_SYSTEM_MESSAGE = 1402;
00212 const TableNo TABLE_NO_AP_MISCELLANEOUS_ALIAS = 1600;
00213 const TableNo TABLE_NO_AP_FUTURE_ALIAS = 1601;
00214 const TableNo TABLE_NO_EU_LISTING = 2000;
00215 const TableNo TABLE_NO_EU_OPTION = 2001;
00216 const TableNo TABLE_NO_EU_FUTURE = 2002;
00217 const TableNo TABLE_NO_EU_FUTURE_OPTION = 2003;
00218 const TableNo TABLE_NO_EU_FUTURE_SPREAD = 2004;
00219 const TableNo TABLE_NO_EU_SESSION_FUTURE = 2005;
00220 const TableNo TABLE_NO_EU_FUTURE_BBO10 = 2006;
00221 const TableNo TABLE_NO_EU_FUTURE_OPTION_BBO10 = 2007;
00222 const TableNo TABLE_NO_EU_FUTURE_SPREAD_BBO10 = 2008;
00223 const TableNo TABLE_NO_EU_SECURITY = 2009;
00224 const TableNo TABLE_NO_EU_COMPANY = 2010;
00225 const TableNo TABLE_NO_EU_INDEX = 2011;
00226 const TableNo TABLE_NO_EU_LISTING_BBO10 = 2012;
00227 const TableNo TABLE_NO_LSE_LISTING = 2013;
00228 const TableNo TABLE_NO_EU_OPTION_ROOT = 2014;
00229 const TableNo TABLE_NO_EU_FUTURE_ROOT = 2015;
00230 const TableNo TABLE_NO_EU_FUTURE_OPTION_ROOT = 2016;
00231 const TableNo TABLE_NO_EU_STATISTICS = 2017;
00232 const TableNo TABLE_NO_EU_ANALYTICS = 2018;
00233 const TableNo TABLE_NO_EU_RANKINGS = 2019;
00234 const TableNo TABLE_NO_EU_OPTION_BBO10 = 2020;
00235 const TableNo TABLE_NO_EU_OPTION_DELIVERABLE = 2021;
00236 const TableNo TABLE_NO_EU_STRATEGY = 2022;
00237 const TableNo TABLE_NO_EU_STRATEGY_LEG = 2023;
00238 const TableNo TABLE_NO_EU_STRATEGY_BBO10 = 2024;
00239 const TableNo TABLE_NO_EU_WARRANT = 2025;
00240 const TableNo TABLE_NO_EU_WARRANT_BBO10 = 2026;
00241 const TableNo TABLE_NO_EU_COMPANY_DOMICILE_NAVIGATION = 2101;
00242 const TableNo TABLE_NO_EU_FUTURE_OPTION_ROOT_FUTURE_OPTION_PATTERN_NAVIGATION = 2102;
00243 const TableNo TABLE_NO_EU_FUTURE_FUTURE_ROOT_NAVIGATION = 2103;
00244 const TableNo TABLE_NO_EU_INDEX_CONSTITUENT_NAVIGATION = 2104;
00245 const TableNo TABLE_NO_EU_LISTING_SECURITY_NAVIGATION = 2105;
00246 const TableNo TABLE_NO_EU_OPTION_ROOT_OPTION_DELIVERABLE_NAVIGATION = 2106;
00247 const TableNo TABLE_NO_EU_OPTION_ROOT_UNDERLYING_NAVIGATION = 2107;
00248 const TableNo TABLE_NO_EU_SECTOR_CONSTITUENT_NAVIGATION = 2108;
00249 const TableNo TABLE_NO_EU_SECURITY_COMPANY_NAVIGATION = 2109;
00250 const TableNo TABLE_NO_EU_SYNTHETIC_CONSTITUENT_NAVIGATION = 2110;
00251 const TableNo TABLE_NO_EU_LISTING_COMPANY_NAVIGATION = 2111;
00252 const TableNo TABLE_NO_EU_ANALYTICS_NAVIGATION = 2112;
00253 const TableNo TABLE_NO_EU_PRIMARY_LISTING_NAVIGATION = 2113;
00254 const TableNo TABLE_NO_EU_FUTURE_FUTURE_OPTION_EXPIRATION_NAVIGATION = 2114;
00255 const TableNo TABLE_NO_EU_FUNDAMENTAL_NAVIGATION = 2115;
00256 const TableNo TABLE_NO_EU_UNDERLYING_OPTION_PATTERN_NAVIGATION = 2116;
00257 const TableNo TABLE_NO_EU_FUTURE_FUTURE_OPTION_PATTERN_NAVIGATION = 2117;
00258 const TableNo TABLE_NO_EU_FUTURE_ROOT_FUTURE_PATTERN_NAVIGATION = 2118;
00259 const TableNo TABLE_NO_EU_UNDERLYING_FUTURE_PATTERN_NAVIGATION = 2119;
00260 const TableNo TABLE_NO_EU_UNDERLYING_BBO_DEPTH_NAVIGATION = 2120;
00261 const TableNo TABLE_NO_EU_OPTION_ROOT_OPTION_PATTERN_NAVIGATION = 2121;
00262 const TableNo TABLE_NO_EU_FUTURE_ROOT_FUTURE_SPREAD_PATTERN_NAVIGATION = 2122;
00263 const TableNo TABLE_NO_EU_UNDERLYING_FUTURE_ROOT_NAVIGATION = 2123;
00264 const TableNo TABLE_NO_EU_STRATEGY_STRATEGY_LEG_PATTERN_NAVIGATION = 2124;
00265 const TableNo TABLE_NO_EU_STRATEGY_UNDERLYING_NAVIGATION = 2125;
00266 const TableNo TABLE_NO_EU_STRATEGY_LEG_UNDERLYING_NAVIGATION = 2126;
00267 const TableNo TABLE_NO_EU_UNDERLYING_NON_STANDARD_OPTION_PATTERN_NAVIGATION = 2127;
00268 const TableNo TABLE_NO_EU_NON_STANDARD_OPTION_ROOT_UNDERLYING_NAVIGATION = 2128;
00269 const TableNo TABLE_NO_EU_CORPORATE_EVENTS = 2200;
00270 const TableNo TABLE_NO_EU_DELIST = 2201;
00271 const TableNo TABLE_NO_EU_DIVIDEND = 2202;
00272 const TableNo TABLE_NO_EU_IPO = 2203;
00273 const TableNo TABLE_NO_EU_SPLIT = 2204;
00274 const TableNo TABLE_NO_EU_SYMBOL_CHANGE = 2205;
00275 const TableNo TABLE_NO_EU_FEED_STATUS = 2350;
00276 const TableNo TABLE_NO_EU_FEED_STATISTICS = 2352;
00277 const TableNo TABLE_NO_EU_SYSTEM_MESSAGE = 2402;
00278 const TableNo TABLE_NO_EU_MISCELLANEOUS_ALIAS = 2600;
00279 const TableNo TABLE_NO_EU_FUTURE_ALIAS = 2601;
00280 const TableNo TABLE_NO_LA_LISTING = 4000;
00281 const TableNo TABLE_NO_LA_OPTION = 4001;
00282 const TableNo TABLE_NO_LA_FUTURE = 4002;
00283 const TableNo TABLE_NO_LA_FUTURE_OPTION = 4003;
00284 const TableNo TABLE_NO_LA_INDEX = 4004;
00285 const TableNo TABLE_NO_LA_LISTING_BBO10 = 4005;
00286 const TableNo TABLE_NO_LA_OPTION_BBO10 = 4006;
00287 const TableNo TABLE_NO_LA_FUTURE_BBO10 = 4007;
00288 const TableNo TABLE_NO_LA_FUTURE_OPTION_BBO10 = 4008;
00289 const TableNo TABLE_NO_LA_SECURITY = 4009;
00290 const TableNo TABLE_NO_LA_COMPANY = 4010;
00291 const TableNo TABLE_NO_LA_OPTION_ROOT = 4011;
00292 const TableNo TABLE_NO_LA_FUTURE_ROOT = 4012;
00293 const TableNo TABLE_NO_LA_FUTURE_OPTION_ROOT = 4013;
00294 const TableNo TABLE_NO_LA_STATISTICS = 4014;
00295 const TableNo TABLE_NO_LA_ANALYTICS = 4015;
00296 const TableNo TABLE_NO_LA_RANKINGS = 4016;
00297 const TableNo TABLE_NO_LA_OPTION_DELIVERABLE = 4017;
00298 const TableNo TABLE_NO_LA_COMPANY_DOMICILE_NAVIGATION = 4101;
00299 const TableNo TABLE_NO_LA_FUTURE_OPTION_ROOT_FUTURE_OPTION_PATTERN_NAVIGATION = 4102;
00300 const TableNo TABLE_NO_LA_FUTURE_FUTURE_ROOT_NAVIGATION = 4103;
00301 const TableNo TABLE_NO_LA_INDEX_CONSTITUENT_NAVIGATION = 4104;
00302 const TableNo TABLE_NO_LA_LISTING_SECURITY_NAVIGATION = 4105;
00303 const TableNo TABLE_NO_LA_OPTION_ROOT_OPTION_DELIVERABLE_NAVIGATION = 4106;
00304 const TableNo TABLE_NO_LA_OPTION_ROOT_UNDERLYING_NAVIGATION = 4107;
00305 const TableNo TABLE_NO_LA_SECTOR_CONSTITUENT_NAVIGATION = 4108;
00306 const TableNo TABLE_NO_LA_SECURITY_COMPANY_NAVIGATION = 4109;
00307 const TableNo TABLE_NO_LA_SYNTHETIC_CONSTITUENT_NAVIGATION = 4110;
00308 const TableNo TABLE_NO_LA_LISTING_COMPANY_NAVIGATION = 4111;
00309 const TableNo TABLE_NO_LA_ANALYTICS_NAVIGATION = 4112;
00310 const TableNo TABLE_NO_LA_PRIMARY_LISTING_NAVIGATION = 4113;
00311 const TableNo TABLE_NO_LA_FUTURE_FUTURE_OPTION_EXPIRATION_NAVIGATION = 4114;
00312 const TableNo TABLE_NO_LA_FUNDAMENTAL_NAVIGATION = 4115;
00313 const TableNo TABLE_NO_LA_UNDERLYING_OPTION_PATTERN_NAVIGATION = 4116;
00314 const TableNo TABLE_NO_LA_FUTURE_FUTURE_OPTION_PATTERN_NAVIGATION = 4117;
00315 const TableNo TABLE_NO_LA_FUTURE_ROOT_FUTURE_PATTERN_NAVIGATION = 4118;
00316 const TableNo TABLE_NO_LA_UNDERLYING_FUTURE_PATTERN_NAVIGATION = 4119;
00317 const TableNo TABLE_NO_LA_UNDERLYING_BBO_DEPTH_NAVIGATION = 4120;
00318 const TableNo TABLE_NO_LA_OPTION_ROOT_OPTION_PATTERN_NAVIGATION = 4121;
00319 const TableNo TABLE_NO_LA_FUTURE_ROOT_FUTURE_SPREAD_PATTERN_NAVIGATION = 4122;
00320 const TableNo TABLE_NO_LA_UNDERLYING_FUTURE_ROOT_NAVIGATION = 4123;
00321 const TableNo TABLE_NO_LA_STRATEGY_STRATEGY_LEG_PATTERN_NAVIGATION = 4124;
00322 const TableNo TABLE_NO_LA_STRATEGY_UNDERLYING_NAVIGATION = 4125;
00323 const TableNo TABLE_NO_LA_STRATEGY_LEG_UNDERLYING_NAVIGATION = 4126;
00324 const TableNo TABLE_NO_LA_UNDERLYING_NON_STANDARD_OPTION_PATTERN_NAVIGATION = 4127;
00325 const TableNo TABLE_NO_LA_NON_STANDARD_OPTION_ROOT_UNDERLYING_NAVIGATION = 4128;
00326 const TableNo TABLE_NO_LA_CORPORATE_EVENTS = 4200;
00327 const TableNo TABLE_NO_LA_DELIST = 4201;
00328 const TableNo TABLE_NO_LA_DIVIDEND = 4202;
00329 const TableNo TABLE_NO_LA_IPO = 4203;
00330 const TableNo TABLE_NO_LA_SPLIT = 4204;
00331 const TableNo TABLE_NO_LA_SYMBOL_CHANGE = 4205;
00332 const TableNo TABLE_NO_LA_FEED_STATUS = 4350;
00333 const TableNo TABLE_NO_LA_FEED_STATISTICS = 4352;
00334 const TableNo TABLE_NO_LA_SYSTEM_MESSAGE = 4402;
00335 const TableNo TABLE_NO_LA_MISCELLANEOUS_ALIAS = 4600;
00336
00337 } // namespace Feed
00338
00339 } // namespace ContentPlatform
00340
00341 } // namespace Activ
00342
00343 #endif // (!defined ACTIV_FEED_COMMON_TABLE_NUMBERS_H)
Generated on Wed Oct 8 14:01:46 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon

TableResetTypes.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FEED_COMMON_TABLE_RESET_TYPES_H)
00010 #define ACTIV_FEED_COMMON_TABLE_RESET_TYPES_H
00011
00012 #include "ActivContentPlatform/ActivFeedCommon/External.h"
00013
00014 #include <string>
00015
00016 namespace Activ
00017 {
00018
00019 namespace ContentPlatform
00020 {
00021
00022 namespace Feed
00023 {
00024
00025 typedef uint8_t TableResetType;
00026
00032 #define ACTIV_TABLE_RESET_TYPE_LIST(d)              \
00033     d(RESET_TYPE_NONE,          None)               \
00034     d(RESET_TYPE_INTERNAL,      Internal)           \
00035     d(RESET_TYPE_EXTERNAL,      External)
00036
00040 #define ACTIV_DECLARE_TABLE_RESET_TYPE_ENUMERATIONS(id, name)   id,
00041
00042 // ---------------------------------------------------------------------------------------------------------------------------------
00043
00047 enum
00048 {
00049     ACTIV_TABLE_RESET_TYPE_LIST(ACTIV_DECLARE_TABLE_RESET_TYPE_ENUMERATIONS)
00050     NUMBER_OF_TABLE_RESET_TYPES,
00051     TABLE_RESET_TYPE_UNKNOWN = static_cast<TableResetType>(~0)
00052 };
00053
00054 #undef ACTIV_DECLARE_TABLE_RESET_TYPE_ENUMERATIONS
00055
00063 ACTIV_FEED_COMMON_API std::string TableResetTypeToString(const TableResetType tableResetType);
00064
00072 ACTIV_FEED_COMMON_API TableResetType StringToTableResetType(const std::string &name);
00073
00074 } // namespace Feed
00075
00076 } // namespace ContentPlatform
00077
00078 } // namespace Activ
00079
00080 #endif // (!defined ACTIV_FEED_COMMON_TABLE_RESET_TYPES_H)
Generated on Wed Oct 8 14:01:46 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedTableTemplateHandler

TableTemplate.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FEED_TABLE_TEMPLATE_HANDLER_TABLE_TEMPLATE_H)
00010 #define ACTIV_FEED_TABLE_TEMPLATE_HANDLER_TABLE_TEMPLATE_H
00011
00012 #include "ActivContentPlatform/ActivFeedCommon/TableNumbers.h"
00013 #include "ActivContentPlatform/ActivFeedCommon/TableTypes.h"
00014 #include "ActivContentPlatform/ActivFeedCommon/TableResetTypes.h"
00015
00016 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/External.h"
00017 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/Field.h"
00018 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/Index.h"
00019 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/Reset.h"
00020 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/Rule.h"
00021 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/UniversalFieldList.h"
00022
00023 #include "xercesc/dom/DOMNode.hpp"
00024
00025 #include <vector>
00026
00027 namespace Activ
00028 {
00029
00030 namespace ContentPlatform
00031 {
00032
00033 namespace Feed
00034 {
00035
00039 class TableTemplate
00040 {
00041 public:
00047     class FieldSpecification
00048     {
00049     public:
00060         ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API FieldSpecification(const FieldId id, const size_t maxLength, const bool isAmfField = false, const uint8_t amfRowIndex = 0, const uint8_t amfRowOffset = 0, const uint8_t amfFieldIndex = 0);
00061
00062         FieldId m_id;
00063         size_t  m_maxLength;
00064         bool    m_isAmfField;
00065         uint8_t m_amfRowIndex;
00066         uint8_t m_amfRowOffset;
00067         uint8_t m_amfFieldIndex;
00068     };
00069
00070     typedef std::vector<FieldSpecification> FieldSpecificationList;
00071
00077     class Specification
00078     {
00079     public:
00094         ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API Specification(const TableId id, const std::string &name, const std::string &codeIdentifier, const TableType type, const bool isLatestVersion, const TableTemplate::FieldSpecificationList &fieldSpecificationList, const Index::IndexSpecificationList &indexSpecificationList, const bool isAmfTable = false, const uint8_t amfTableId = 0, const uint8_t amfRecordSize = 0);
00095
00096         const TableId                           m_id;
00097         const std::string                       m_name;
00098         const std::string                       m_codeIdentifier;
00099         const TableType                         m_type;
00100         const bool                              m_isLatestVersion;
00101         const FieldSpecificationList            m_fieldSpecificationList;
00102         const Index::IndexSpecificationList     m_indexSpecificationList;
00103         const bool                              m_isAmfTable;
00104         const uint8_t                           m_amfTableId;
00105         const uint8_t                           m_amfRecordSize;
00106     };
00107
00111     class ConstFieldIterator
00112     {
00113     public:
00117         ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API ConstFieldIterator();
00118
00124         ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API const Field &operator*() const;
00125
00131         ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API const Field *operator->() const;
00132
00138         ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API ConstFieldIterator &operator++();
00139
00145         ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API const ConstFieldIterator operator++(int);
00146
00154         ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API bool operator==(const ConstFieldIterator &rhs) const;
00155
00163         ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API bool operator!=(const ConstFieldIterator &rhs) const;
00164
00170         ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API FieldId GetFieldId() const;
00171
00177         ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API const Field &GetField() const;
00178
00179     private:
00180         typedef hash_map<FieldId, Field> FieldMap;
00181
00188         ConstFieldIterator(const TableTemplate *pTableTemplate, const FieldMap::const_iterator &iterator);
00189
00190         const TableTemplate         *m_pTableTemplate;
00191         FieldMap::const_iterator    m_iterator;
00192
00193         friend class TableTemplate;
00194     };
00195
00199     class ConstIndexIterator
00200     {
00201     public:
00205         ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API ConstIndexIterator();
00206
00212         ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API const Index &operator*() const;
00213
00219         ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API const Index *operator->() const;
00220
00226         ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API ConstIndexIterator &operator++();
00227
00233         ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API const ConstIndexIterator operator++(int);
00234
00242         ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API bool operator==(const ConstIndexIterator &rhs) const;
00243
00251         ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API bool operator!=(const ConstIndexIterator &rhs) const;
00252
00253     private:
00259         ConstIndexIterator(const IndexList::const_iterator &iterator);
00260
00261         IndexList::const_iterator   m_iterator;
00262
00263         friend class TableTemplate;
00264     };
00265
00269     class ConstRuleIterator
00270     {
00271     public:
00275         ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API ConstRuleIterator();
00276
00282         ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API const Rule &operator*() const;
00283
00289         ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API const Rule *operator->() const;
00290
00296         ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API ConstRuleIterator &operator++();
00297
00303         ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API const ConstRuleIterator operator++(int);
00304
00312         ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API bool operator==(const ConstRuleIterator &rhs) const;
00313
00321         ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API bool operator!=(const ConstRuleIterator &rhs) const;
00322
00328         ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API FieldId GetFieldId() const;
00329
00335         ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API const Rule &GetRule() const;
00336
00337     private:
00343         ConstRuleIterator(const RuleMap::const_iterator &iterator);
00344
00345         RuleMap::const_iterator m_iterator;
00346
00347         friend class TableTemplate;
00348     };
00349
00353     class ConstCopyOnResetIterator
00354     {
00355     public:
00359         ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API ConstCopyOnResetIterator();
00360
00366         ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API const CopyOnReset &operator*() const;
00367
00373         ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API const CopyOnReset *operator->() const;
00374
00380         ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API ConstCopyOnResetIterator &operator++();
00381
00387         ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API const ConstCopyOnResetIterator operator++(int);
00388
00396         ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API bool operator==(const ConstCopyOnResetIterator &rhs) const;
00397
00405         ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API bool operator!=(const ConstCopyOnResetIterator &rhs) const;
00406
00407     private:
00413         ConstCopyOnResetIterator(const CopyOnResetList::const_iterator &iterator);
00414
00415         CopyOnResetList::const_iterator m_iterator;
00416
00417         friend class TableTemplate;
00418     };
00419
00423     class ConstUndefineOnResetIterator
00424     {
00425     public:
00429         ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API ConstUndefineOnResetIterator();
00430
00436         ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API const FieldId &operator*() const;
00437
00443         ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API const FieldId *operator->() const;
00444
00450         ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API ConstUndefineOnResetIterator &operator++();
00451
00457         ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API const ConstUndefineOnResetIterator operator++(int);
00458
00466         ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API bool operator==(const ConstUndefineOnResetIterator &rhs) const;
00467
00475         ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API bool operator!=(const ConstUndefineOnResetIterator &rhs) const;
00476
00477     private:
00483         ConstUndefineOnResetIterator(const UndefineOnResetList::const_iterator &iterator);
00484
00485         UndefineOnResetList::const_iterator m_iterator;
00486
00487         friend class TableTemplate;
00488     };
00489
00493     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API TableTemplate();
00494
00505     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API TableTemplate(const UniversalFieldList &universalFieldList, const Specification &specification);
00506
00517     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API TableTemplate(const UniversalFieldList &universalFieldList, const std::string &xmlFileName);
00518
00532     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API TableTemplate(const UniversalFieldList &universalFieldList, Application &application, const ServiceHandle &serviceHandle, const Database::Record &record, IHeap * const pHeap = 0);
00533
00537     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API ~TableTemplate();
00538
00550     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API StatusCode Initialize(const UniversalFieldList &universalFieldList, const Specification &specification);
00551
00563     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API StatusCode Initialize(const UniversalFieldList &universalFieldList, const std::string &xmlFileName);
00564
00580     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API StatusCode Initialize(const UniversalFieldList &universalFieldList, Application &application, const ServiceHandle &serviceHandle, const Database::Record &record, IHeap * const pHeap = 0, const std::string &componentId = Component::defaultComponentId);
00581
00590     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API StatusCode ApplyTableTemplateAddition(const TableTemplate &tableTemplateAddition);
00591
00595     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API void Clear();
00596
00604     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API bool operator==(const TableTemplate &rhs) const;
00605
00613     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API bool operator!=(const TableTemplate &rhs) const;
00614
00622     static bool IsTableTemplate(const std::string &xmlFileName);
00623
00629     TableId GetId() const;
00630
00636     TableNo GetNumber() const;
00637
00643     TableVersion GetVersion() const;
00644
00650     bool IsContributed() const;
00651
00657     const std::string &GetName() const;
00658
00664     const std::string &GetCodeIdentifier() const;
00665
00671     TableType GetType() const;
00672
00678     bool IsAmfTable() const;
00679
00685     uint8_t GetAmfTableId() const;
00686
00692     uint8_t GetAmfRecordSize() const;
00693
00699     size_t GetInitialMaxRecords() const;
00700
00706     size_t GetNumberOfGrowRecords() const;
00707
00713     bool IsPurged() const;
00714
00720     size_t GetNumberOfPurgeDays() const;
00721
00727     TableResetType GetResetType() const;
00728
00734     bool IsDiskBased() const;
00735
00741     size_t GetCacheSize() const;
00742
00748     bool IsLatestVersion() const;
00749
00755     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API std::string GetError() const;
00756
00762     void SetLatestVersion(const bool isLatestVersion);
00763
00773     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API StatusCode GetField(const FieldId fieldId, const Field *&pField) const;
00774
00784     const Field *GetField(const FieldId fieldId) const;
00785
00795     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API StatusCode GetFirstField(const Field *&pField) const;
00796
00807     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API StatusCode GetNextField(const Field *&pField) const;
00808
00818     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API StatusCode GetRule(const FieldId fieldId, const Rule *&pRule) const;
00819
00830     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API StatusCode GetIndex(const IndexNumber indexNumber, const Index *&pIndex) const;
00831
00841     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API StatusCode GetFirstIndex(const Index *&pIndex) const;
00842
00853     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API StatusCode GetNextIndex(const Index *&pIndex) const;
00854
00860     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API ConstFieldIterator BeginField() const;
00861
00867     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API ConstFieldIterator EndField() const;
00868
00874     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API ConstIndexIterator BeginIndex() const;
00875
00881     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API ConstIndexIterator EndIndex() const;
00882
00888     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API ConstRuleIterator BeginRule() const;
00889
00895     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API ConstRuleIterator EndRule() const;
00896
00902     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API ConstCopyOnResetIterator BeginCopyOnReset() const;
00903
00909     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API ConstCopyOnResetIterator EndCopyOnReset() const;
00910
00916     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API ConstUndefineOnResetIterator BeginUndefineOnReset() const;
00917
00923     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API ConstUndefineOnResetIterator EndUndefineOnReset() const;
00924
00930     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API static std::string GetUiHeading();
00931
00943     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API std::string ToString(bool shouldDisplayFields = false, bool shouldDisplayIndices = false, bool shouldDisplayRules = false, bool shouldDisplayCopyOnReset = false, bool shouldDisplayUndefineOnReset = false) const;
00944
00950     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API std::string FieldsToString() const;
00951
00957     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API std::string IndexesToString() const;
00958
00964     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API std::string RulesToString() const;
00965
00971     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API std::string CopyOnResetToString() const;
00972
00978     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API std::string UndefineOnResetToString() const;
00979
00985     static const size_t GetMaxNumber();
00986
00992     static const size_t GetMaxVersion();
00993
01002     static TableId GetId(const TableNo number, const TableVersion version);
01003
01011     static TableNo GetNumber(const TableId id);
01012
01020     static TableVersion GetVersion(const TableId id);
01021
01029     static bool IsContributed(const TableId id);
01030
01031 private:
01032     typedef hash_map<FieldId, Field> FieldMap;
01033
01034     static const size_t     TABLE_ID_RESERVED_BIT_OFFSET    = 0;
01035     static const size_t     TABLE_ID_RESERVED_BIT_LENGTH    = 1;
01036     static const size_t     TABLE_ID_VERSION_OFFSET         = (TABLE_ID_RESERVED_BIT_OFFSET + TABLE_ID_RESERVED_BIT_LENGTH);
01037     static const size_t     TABLE_ID_VERSION_LENGTH         = 2;
01038     static const size_t     TABLE_ID_NUMBER_OFFSET          = (TABLE_ID_VERSION_OFFSET + TABLE_ID_VERSION_LENGTH);
01039     static const size_t     TABLE_ID_NUMBER_LENGTH          = 13;
01040
01041     static const size_t     TABLE_ID_RESERVED_BIT_MASK      = static_cast<TableId>((1 << TABLE_ID_RESERVED_BIT_LENGTH) - 1);
01042     static const size_t     TABLE_ID_RESERVED_BIT_SHIFT     = (sizeof(TableId) * CHAR_BIT) - (TABLE_ID_RESERVED_BIT_OFFSET + TABLE_ID_RESERVED_BIT_LENGTH);
01043     static const TableId    TABLE_ID_VERSION_BIT_MASK       = static_cast<TableId>((1 << TABLE_ID_VERSION_LENGTH) - 1);
01044     static const size_t     TABLE_ID_VERSION_BIT_SHIFT      = (sizeof(TableId) * CHAR_BIT) - (TABLE_ID_VERSION_OFFSET + TABLE_ID_VERSION_LENGTH);
01045     static const TableId    TABLE_ID_NUMBER_BIT_MASK        = static_cast<TableId>((1 << TABLE_ID_NUMBER_LENGTH) - 1);
01046     static const size_t     TABLE_ID_NUMBER_BIT_SHIFT       = (sizeof(TableId) * CHAR_BIT) - (TABLE_ID_NUMBER_OFFSET + TABLE_ID_NUMBER_LENGTH);
01047
01056     StatusCode InitializeAttributes(const xercesc::DOMNode &domNode);
01057
01066     StatusCode InitializeFieldList(const UniversalFieldList &universalFieldList, const xercesc::DOMNode &domNode);
01067
01076     StatusCode InitializeIndexList(const xercesc::DOMNode &domNode);
01077
01086     StatusCode InitializeRules(const xercesc::DOMNode &domNode);
01087
01096     StatusCode InitializeCopyOnResetList(const xercesc::DOMNode &domNode);
01097
01106     StatusCode InitializeCopyOnResetFields(const xercesc::DOMNode &domNode);
01107
01116     StatusCode InitializeUndefineOnResetFieldList(const xercesc::DOMNode &domNode);
01117
01131     StatusCode InitializeFieldList(const UniversalFieldList &universalFieldList, Application &application, const ServiceHandle &serviceHandle, const Database::Record &record, IHeap * const pHeap = 0, const std::string &componentId = Component::defaultComponentId);
01132
01146     StatusCode InitializeIndexList(const UniversalFieldList &universalFieldList, Application &application, const ServiceHandle &serviceHandle, const Database::Record &record, IHeap * const pHeap = 0, const std::string &componentId = Component::defaultComponentId);
01147
01154     StatusCode CheckMandatoryFields();
01155
01166     StatusCode GetField(const FieldId fieldId, Field *&pField) const;
01167
01177     StatusCode GetFirstField(Field *&pField) const;
01178
01188     StatusCode GetNextField(Field *&pField) const;
01189
01199     StatusCode GetFirstIndex(Index *&pIndex) const;
01200
01210     StatusCode GetNextIndex(Index *&pIndex) const;
01211
01212     TableId                 m_id;
01213     std::string             m_name;
01214     std::string             m_codeIdentifier;
01215     TableType               m_type;
01216     bool                    m_isLatestVersion;
01217     bool                    m_isAmfTable;
01218     uint8_t                 m_amfTableId;
01219     uint8_t                 m_amfRecordSize;
01220     size_t                  m_initialMaxRecords;
01221     size_t                  m_nGrowRecords;
01222     bool                    m_isPurged;
01223     size_t                  m_nPurgeDays;
01224     TableResetType          m_resetType;
01225     bool                    m_isDiskBased;
01226     size_t                  m_cacheSize;
01227     FieldMap                m_fieldMap;
01228     IndexList               m_indexList;
01229     RuleMap                 m_ruleMap;
01230     CopyOnResetList         m_copyOnResetList;
01231     UndefineOnResetList     m_undefineOnResetList;
01232
01233     std::string             m_error;
01234
01235     friend class TableTemplateAddition;
01236 };
01237
01238 // ---------------------------------------------------------------------------------------------------------------------------------
01239 // ---------------------------------------------------------------------------------------------------------------------------------
01240
01244 class TableTemplateAddition : public TableTemplate
01245 {
01246 public:
01250     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API TableTemplateAddition();
01251
01262     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API TableTemplateAddition(const UniversalFieldList &universalFieldList, const std::string &xmlFileName);
01263
01275     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API StatusCode Initialize(const UniversalFieldList &universalFieldList, const std::string &xmlFileName);
01276
01284     static bool IsTableTemplateAddition(const std::string &xmlFileName);
01285
01286 private:
01295     StatusCode InitializeAttributes(const xercesc::DOMNode &domNode);
01296 };
01297
01298 // ---------------------------------------------------------------------------------------------------------------------------------
01299 // ---------------------------------------------------------------------------------------------------------------------------------
01300
01301 inline TableId TableTemplate::GetId() const
01302 {
01303     return m_id;
01304 }
01305
01306 // ---------------------------------------------------------------------------------------------------------------------------------
01307
01308 inline TableNo TableTemplate::GetNumber() const
01309 {
01310     return TableTemplate::GetNumber(GetId());
01311 }
01312
01313 // ---------------------------------------------------------------------------------------------------------------------------------
01314
01315 inline TableVersion TableTemplate::GetVersion() const
01316 {
01317     return TableTemplate::GetVersion(GetId());
01318 }
01319
01320 // ---------------------------------------------------------------------------------------------------------------------------------
01321
01322 inline bool TableTemplate::IsContributed() const
01323 {
01324     return TableTemplate::IsContributed(GetId());
01325 }
01326
01327 // ---------------------------------------------------------------------------------------------------------------------------------
01328
01329 inline const std::string &TableTemplate::GetName() const
01330 {
01331     return m_name;
01332 }
01333
01334 // ---------------------------------------------------------------------------------------------------------------------------------
01335
01336 inline const std::string &TableTemplate::GetCodeIdentifier() const
01337 {
01338     return m_codeIdentifier;
01339 }
01340
01341 // ---------------------------------------------------------------------------------------------------------------------------------
01342
01343 inline TableType TableTemplate::GetType() const
01344 {
01345     return m_type;
01346 }
01347
01348 // ---------------------------------------------------------------------------------------------------------------------------------
01349
01350 inline bool TableTemplate::IsAmfTable() const
01351 {
01352     return m_isAmfTable;
01353 }
01354
01355 // ---------------------------------------------------------------------------------------------------------------------------------
01356
01357 inline uint8_t TableTemplate::GetAmfTableId() const
01358 {
01359     return m_amfTableId;
01360 }
01361
01362 // ---------------------------------------------------------------------------------------------------------------------------------
01363
01364 inline uint8_t TableTemplate::GetAmfRecordSize() const
01365 {
01366     return m_amfRecordSize;
01367 }
01368
01369 // ---------------------------------------------------------------------------------------------------------------------------------
01370
01371 inline size_t TableTemplate::GetInitialMaxRecords() const
01372 {
01373     return m_initialMaxRecords;
01374 }
01375
01376 // ---------------------------------------------------------------------------------------------------------------------------------
01377
01378 inline size_t TableTemplate::GetNumberOfGrowRecords() const
01379 {
01380     return m_nGrowRecords;
01381 }
01382
01383 // ---------------------------------------------------------------------------------------------------------------------------------
01384
01385 inline bool TableTemplate::IsPurged() const
01386 {
01387     return m_isPurged;
01388 }
01389
01390 // ---------------------------------------------------------------------------------------------------------------------------------
01391
01392 inline size_t TableTemplate::GetNumberOfPurgeDays() const
01393 {
01394     return m_nPurgeDays;
01395 }
01396
01397 // ---------------------------------------------------------------------------------------------------------------------------------
01398
01399 inline TableResetType TableTemplate::GetResetType() const
01400 {
01401     return m_resetType;
01402 }
01403
01404 // ---------------------------------------------------------------------------------------------------------------------------------
01405
01406 inline bool TableTemplate::IsDiskBased() const
01407 {
01408     return m_isDiskBased;
01409 }
01410
01411 // ---------------------------------------------------------------------------------------------------------------------------------
01412
01413 inline size_t TableTemplate::GetCacheSize() const
01414 {
01415     return m_cacheSize;
01416 }
01417
01418 // ---------------------------------------------------------------------------------------------------------------------------------
01419
01420 inline bool TableTemplate::IsLatestVersion() const
01421 {
01422     return m_isLatestVersion;
01423 }
01424
01425 // ---------------------------------------------------------------------------------------------------------------------------------
01426
01427 inline std::string TableTemplate::GetError() const
01428 {
01429     return m_error;
01430 }
01431
01432 // ---------------------------------------------------------------------------------------------------------------------------------
01433
01434 inline void TableTemplate::SetLatestVersion(const bool isLatestVersion)
01435 {
01436     m_isLatestVersion = isLatestVersion;
01437 }
01438
01439 // ---------------------------------------------------------------------------------------------------------------------------------
01440
01441 inline const Field *TableTemplate::GetField(const FieldId fieldId) const
01442 {
01443     const Field *pField;
01444     ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, GetField(fieldId, pField));
01445     return pField;
01446 }
01447
01448 // ---------------------------------------------------------------------------------------------------------------------------------
01449
01450 inline StatusCode TableTemplate::GetRule(const FieldId fieldId, const Rule *&pRule) const
01451 {
01452     const RuleMap::const_iterator iterator = m_ruleMap.find(fieldId);
01453
01454     if (m_ruleMap.end() == iterator)
01455         return STATUS_CODE_NOT_FOUND;
01456
01457     pRule = &iterator->second;
01458
01459     return STATUS_CODE_SUCCESS;
01460 }
01461
01462 // ---------------------------------------------------------------------------------------------------------------------------------
01463
01464 inline const size_t TableTemplate::GetMaxNumber()
01465 {
01466     return (TABLE_ID_NUMBER_LENGTH << 1) - 1;
01467 }
01468
01469 // ---------------------------------------------------------------------------------------------------------------------------------
01470
01471 inline const size_t TableTemplate::GetMaxVersion()
01472 {
01473     return (TABLE_ID_VERSION_LENGTH << 1) - 1;
01474 }
01475
01476 // ---------------------------------------------------------------------------------------------------------------------------------
01477
01478 inline TableId TableTemplate::GetId(const TableNo number, const TableVersion version)
01479 {
01480     return static_cast<TableId>((number << TABLE_ID_NUMBER_BIT_SHIFT) | (version << TABLE_ID_VERSION_BIT_SHIFT));
01481 }
01482
01483 // ---------------------------------------------------------------------------------------------------------------------------------
01484
01485 inline TableNo TableTemplate::GetNumber(const TableId id)
01486 {
01487     return static_cast<TableNo>((id >> TABLE_ID_NUMBER_BIT_SHIFT) & TABLE_ID_NUMBER_BIT_MASK);
01488 }
01489
01490 // ---------------------------------------------------------------------------------------------------------------------------------
01491
01492 inline TableVersion TableTemplate::GetVersion(const TableId id)
01493 {
01494     return static_cast<TableVersion>((id >> TABLE_ID_VERSION_BIT_SHIFT) & TABLE_ID_VERSION_BIT_MASK);
01495 }
01496
01497 // ---------------------------------------------------------------------------------------------------------------------------------
01498
01499 inline bool TableTemplate::IsContributed(const TableId id)
01500 {
01501     const TableNo number = GetNumber(id);
01502     return ((number >= TABLE_NO_CONTRIBUTION_BASE) && (number <= TABLE_NO_MAX));
01503 }
01504
01505 } // namespace Feed
01506
01507 } // namespace ContentPlatform
01508
01509 } // namespace Activ
01510
01511 #endif // (!defined ACTIV_FEED_TABLE_TEMPLATE_HANDLER_TABLE_TEMPLATE_H)
Generated on Wed Oct 8 14:01:46 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedTableTemplateHandler

TableTemplateException.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FEED_TABLE_TEMPLATE_HANDLER_TABLE_TEMPLATE_EXCEPTION_H)
00010 #define ACTIV_FEED_TABLE_TEMPLATE_HANDLER_TABLE_TEMPLATE_EXCEPTION_H
00011
00012 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/External.h"
00013
00014 #include "ActivMiddleware/ActivBase/ActivBase.h"
00015 #include "ActivMiddleware/ActivBase/Exception.h"
00016
00017 namespace Activ
00018 {
00019
00020 namespace ContentPlatform
00021 {
00022
00023 namespace Feed
00024 {
00025
00029 #define ACTIV_THROW_TABLE_TEMPLATE_EXCEPTION_IF(statusCode, operator, expression, error)                    \
00030     if (true)                                                                                               \
00031     {                                                                                                       \
00032         const Activ::StatusCode thisIsTheResultOfTheCall = expression;                                      \
00033         if (statusCode operator thisIsTheResultOfTheCall)                                                   \
00034             ACTIV_THROW(Activ::ContentPlatform::Feed::TableTemplateException, error);                                           \
00035     }                                                                                                       \
00036     else
00037
00041 #define ACTIV_THROW_TABLE_TEMPLATE_EXCEPTION_IF_AND_IF(statusCode1, statusCode2, operator, expression, error)       \
00042     if (true)                                                                                                       \
00043     {                                                                                                               \
00044         const Activ::StatusCode thisIsTheResultOfTheCall = expression;                                              \
00045         if ((statusCode1 operator thisIsTheResultOfTheCall) && (statusCode2 operator thisIsTheResultOfTheCall))     \
00046             ACTIV_THROW(Activ::ContentPlatform::Feed::TableTemplateException, error);                                               \
00047     }                                                                                                               \
00048     else
00049
00050 // ---------------------------------------------------------------------------------------------------------------------------------
00051
00055 class TableTemplateException : public Exception
00056 {
00057 public:
00066     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API TableTemplateException(const char *file, const char *function, const uint_fast32_t line, const std::string &error);
00067
00068     // Exception interface
00069     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API virtual std::string ToString() const;
00070
00071 private:
00072     std::string         m_error;        // The error string.
00073 };
00074
00075 } // namespace Feed
00076
00077 } // namespace ContentPlatform
00078
00079 } // namespace Activ
00080
00081 #endif // (!defined ACTIV_FEED_TABLE_TEMPLATE_HANDLER_TABLE_TEMPLATE_EXCEPTION_H)
Generated on Wed Oct 8 14:01:46 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedMessageHandler

TableTemplateField.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FEED_MESSAGE_HANDLER_TABLE_TEMPLATE_FIELD_H)
00010 #define ACTIV_FEED_MESSAGE_HANDLER_TABLE_TEMPLATE_FIELD_H
00011
00012 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/External.h"
00013
00014 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/UniversalFieldList.h"
00015
00016 namespace Activ
00017 {
00018
00019 class MessageValidator;
00020
00021 namespace ContentPlatform
00022 {
00023
00024 namespace Feed
00025 {
00026
00030 class TableTemplateField
00031 {
00032 public:
00036     ACTIV_FEED_MESSAGE_HANDLER_API TableTemplateField();
00037
00046     ACTIV_FEED_MESSAGE_HANDLER_API TableTemplateField(const UniversalField &universalField, MessageValidator &messageValidator);
00047
00051     ACTIV_FEED_MESSAGE_HANDLER_API ~TableTemplateField();
00052
00064     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Initialize(const UniversalField &universalField, MessageValidator &messageValidator);
00065
00069     ACTIV_FEED_MESSAGE_HANDLER_API void Reset();
00070
00079     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode GetMaxLength(uint32_t &maxLength) const;
00080
00086     ACTIV_FEED_MESSAGE_HANDLER_API bool IsInitialized() const;
00087
00088 private:
00092     void Clear();
00093
00094     bool        m_isInitialized;
00095     uint32_t    m_maxLength;
00096 };
00097
00098 } // namespace Feed
00099
00100 } // namespace ContentPlatform
00101
00102 } // namespace Activ
00103
00104 #endif // (!defined ACTIV_FEED_MESSAGE_HANDLER_TABLE_TEMPLATE_FIELD_H)
Generated on Wed Oct 8 14:01:46 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedMessageHandler

TableTemplateFieldListValidator.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FEED_MESSAGE_HANDLER_TABLE_TEMPLATE_FIELD_LIST_VALIDATOR_H)
00010 #define ACTIV_FEED_MESSAGE_HANDLER_TABLE_TEMPLATE_FIELD_LIST_VALIDATOR_H
00011
00012 #include "ActivContentPlatform/ActivFeedCommon/FieldIds.h"
00013
00014 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/External.h"
00015 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/TableTemplateField.h"
00016
00017 #include <map>
00018
00019 namespace Activ
00020 {
00021
00022 class MessageValidator;
00023
00024 namespace ContentPlatform
00025 {
00026
00027 namespace Feed
00028 {
00029
00030 class UniversalFieldList;
00031
00032 // ---------------------------------------------------------------------------------------------------------------------------------
00033
00037 class TableTemplateFieldListValidator
00038 {
00039 public:
00043     class ConstIterator
00044     {
00045     public:
00049         ACTIV_FEED_MESSAGE_HANDLER_API ConstIterator();
00050
00056         ACTIV_FEED_MESSAGE_HANDLER_API ConstIterator &operator++();
00057
00063         ACTIV_FEED_MESSAGE_HANDLER_API const ConstIterator operator++(int);
00064
00072         ACTIV_FEED_MESSAGE_HANDLER_API bool operator==(const ConstIterator &rhs) const;
00073
00081         ACTIV_FEED_MESSAGE_HANDLER_API bool operator!=(const ConstIterator &rhs) const;
00082
00088         ACTIV_FEED_MESSAGE_HANDLER_API FieldId GetFieldId() const;
00089
00095         ACTIV_FEED_MESSAGE_HANDLER_API const TableTemplateField *GetTableTemplateField() const;
00096
00097     private:
00098         typedef std::map<FieldId, TableTemplateField> TableTemplateFieldMap;
00099
00106         ConstIterator(const TableTemplateFieldListValidator *pTableTemplateFieldListValidator, const TableTemplateFieldMap::const_iterator &iterator);
00107
00108         const TableTemplateFieldListValidator   *m_pTableTemplateFieldListValidator;
00109         TableTemplateFieldMap::const_iterator   m_iterator;
00110
00111         friend class TableTemplateFieldListValidator;
00112     };
00113
00117     ACTIV_FEED_MESSAGE_HANDLER_API TableTemplateFieldListValidator();
00118
00127     ACTIV_FEED_MESSAGE_HANDLER_API TableTemplateFieldListValidator(const UniversalFieldList &universalFieldList, MessageValidator &messageValidator);
00128
00132     ACTIV_FEED_MESSAGE_HANDLER_API ~TableTemplateFieldListValidator();
00133
00145     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Initialize(const UniversalFieldList &universalFieldList, MessageValidator &messageValidator);
00146
00150     ACTIV_FEED_MESSAGE_HANDLER_API void Reset();
00151
00162     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode GetTableTemplateField(const FieldId fieldId, const TableTemplateField *&pTableTemplateField) const;
00163
00169     ACTIV_FEED_MESSAGE_HANDLER_API bool IsInitialized() const;
00170
00178     ACTIV_FEED_MESSAGE_HANDLER_API ConstIterator Begin() const;
00179
00187     ACTIV_FEED_MESSAGE_HANDLER_API ConstIterator End() const;
00188
00189 private:
00190     typedef std::map<FieldId, TableTemplateField> TableTemplateFieldMap;
00191
00197     TableTemplateFieldListValidator(const TableTemplateFieldListValidator &rhs);
00198
00206     TableTemplateFieldListValidator& operator=(const TableTemplateFieldListValidator &rhs);
00207
00218     StatusCode GetTableTemplateField(const FieldId fieldId, TableTemplateField *&pTableTemplateField);
00219
00223     void Clear();
00224
00225     bool                    m_isInitialized;
00226     TableTemplateFieldMap   m_tableTemplateFieldMap;
00227 };
00228
00229 } // namespace Feed
00230
00231 } // namespace ContentPlatform
00232
00233 } // namespace Activ
00234
00235 #endif // (!defined ACTIV_FEED_MESSAGE_HANDLER_TABLE_TEMPLATE_FIELD_LIST_VALIDATOR_H)
Generated on Wed Oct 8 14:01:46 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedMessageHandler

TableTemplateIndex.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FEED_MESSAGE_HANDLER_TABLE_TEMPLATE_INDEX_H)
00010 #define ACTIV_FEED_MESSAGE_HANDLER_TABLE_TEMPLATE_INDEX_H
00011
00012 #include "ActivMiddleware/ActivFieldTypes/TextString.h"
00013
00014 #include "ActivContentPlatform/ActivFeedCommon/FieldIds.h"
00015 #include "ActivContentPlatform/ActivFeedCommon/IndexNumbers.h"
00016
00017 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/External.h"
00018
00019 #include <map>
00020
00021 namespace Activ
00022 {
00023
00024 class MessageValidator;
00025
00026 namespace ContentPlatform
00027 {
00028
00029 namespace Feed
00030 {
00031
00032 class UniversalFieldList;
00033 class TableTemplateFieldListValidator;
00034
00035 // ---------------------------------------------------------------------------------------------------------------------------------
00036
00040 class TableTemplateIndex
00041 {
00042 public:
00043     typedef std::vector<FieldId>::const_iterator ConstIterator;
00044
00048     ACTIV_FEED_MESSAGE_HANDLER_API TableTemplateIndex();
00049
00058     ACTIV_FEED_MESSAGE_HANDLER_API TableTemplateIndex(const TableTemplateFieldListValidator &tableTemplateFieldListValidator, MessageValidator &messageValidator);
00059
00063     ACTIV_FEED_MESSAGE_HANDLER_API ~TableTemplateIndex();
00064
00076     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Initialize(const TableTemplateFieldListValidator &tableTemplateFieldListValidator, MessageValidator &messageValidator);
00077
00081     ACTIV_FEED_MESSAGE_HANDLER_API void Reset();
00082
00091     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode GetNumber(IndexNumber &number) const;
00092
00101     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode GetName(const TextString *&pName) const;
00102
00111     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode GetType(IndexType &type) const;
00112
00121     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode GetProperties(IndexProperties &properties) const;
00122
00128     ACTIV_FEED_MESSAGE_HANDLER_API bool IsInitialized() const;
00129
00137     ACTIV_FEED_MESSAGE_HANDLER_API ConstIterator Begin() const;
00138
00146     ACTIV_FEED_MESSAGE_HANDLER_API ConstIterator End() const;
00147
00148 private:
00149     typedef std::vector<FieldId> TableTemplateIndexFieldList;
00150
00161     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode GetName(TextString *&pName);
00162
00166     void Clear();
00167
00168     bool                            m_isInitialized;
00169     IndexNumber                     m_number;
00170     TextString                      m_name;
00171     IndexType                       m_type;
00172     IndexProperties                 m_properties;
00173     TableTemplateIndexFieldList     m_tableTemplateIndexFieldList;
00174 };
00175
00176 } // namespace Feed
00177
00178 } // namespace ContentPlatform
00179
00180 } // namespace Activ
00181
00182 #endif // (!defined ACTIV_FEED_MESSAGE_HANDLER_TABLE_TEMPLATE_INDEX_H)
Generated on Wed Oct 8 14:01:46 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedMessageHandler

TableTemplateIndexListValidator.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FEED_MESSAGE_HANDLER_TABLE_TEMPLATE_INDEX_LIST_VALIDATOR_H)
00010 #define ACTIV_FEED_MESSAGE_HANDLER_TABLE_TEMPLATE_INDEX_LIST_VALIDATOR_H
00011
00012 #include "ActivContentPlatform/ActivFeedCommon/FieldIds.h"
00013
00014 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/External.h"
00015 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/TableTemplateIndex.h"
00016
00017 #include <map>
00018
00019 namespace Activ
00020 {
00021
00022 class MessageValidator;
00023
00024 namespace ContentPlatform
00025 {
00026
00027 namespace Feed
00028 {
00029
00033 class TableTemplateIndexListValidator
00034 {
00035 public:
00036     typedef std::vector<TableTemplateIndex>::const_iterator ConstIterator;
00037
00041     ACTIV_FEED_MESSAGE_HANDLER_API TableTemplateIndexListValidator();
00042
00051     ACTIV_FEED_MESSAGE_HANDLER_API TableTemplateIndexListValidator(const TableTemplateFieldListValidator &tableTemplateFieldListValidator, MessageValidator &messageValidator);
00052
00056     ACTIV_FEED_MESSAGE_HANDLER_API ~TableTemplateIndexListValidator();
00057
00069     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Initialize(const TableTemplateFieldListValidator &tableTemplateFieldListValidator, MessageValidator &messageValidator);
00070
00074     ACTIV_FEED_MESSAGE_HANDLER_API void Reset();
00075
00086     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode GetTableTemplateIndex(const IndexNumber indexNumber, const TableTemplateIndex *&pTableTemplateIndex) const;
00087
00093     ACTIV_FEED_MESSAGE_HANDLER_API bool IsInitialized() const;
00094
00102     ACTIV_FEED_MESSAGE_HANDLER_API ConstIterator Begin() const;
00103
00111     ACTIV_FEED_MESSAGE_HANDLER_API ConstIterator End() const;
00112
00113 private:
00114     typedef std::vector<TableTemplateIndex> TableTemplateIndexList;
00115
00121     TableTemplateIndexListValidator(const TableTemplateIndexListValidator &rhs);
00122
00130     TableTemplateIndexListValidator& operator=(const TableTemplateIndexListValidator &rhs);
00131
00142     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode GetTableTemplateIndex(const IndexNumber indexNumber, TableTemplateIndex *&pTableTemplateIndex);
00143
00147     void Clear();
00148
00149     bool                        m_isInitialized;
00150     TableTemplateIndexList      m_tableTemplateIndexList;
00151 };
00152
00153 } // namespace Feed
00154
00155 } // namespace ContentPlatform
00156
00157 } // namespace Activ
00158
00159 #endif // (!defined ACTIV_FEED_MESSAGE_HANDLER_TABLE_TEMPLATE_INDEX_LIST_VALIDATOR_H)
Generated on Wed Oct 8 14:01:46 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedTableTemplateHandler

TableTemplateList.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FEED_TABLE_TEMPLATE_HANDLER_TABLE_TEMPLATE_LIST_H)
00010 #define ACTIV_FEED_TABLE_TEMPLATE_HANDLER_TABLE_TEMPLATE_LIST_H
00011
00012 #include "ActivContentPlatform/ActivFeedCommon/ActivFeed.h"
00013
00014 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/External.h"
00015 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/TableTemplate.h"
00016 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/UniversalFieldList.h"
00017
00018 namespace Activ
00019 {
00020
00021 namespace ContentPlatform
00022 {
00023
00024 namespace Feed
00025 {
00026
00027 class Index::Specification;
00028
00029 // ---------------------------------------------------------------------------------------------------------------------------------
00030
00034 class TableTemplateList
00035 {
00036 public:
00040     class Settings
00041     {
00042     public:
00046         ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API Settings();
00047
00058         ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API static Settings GetFromIniFile(const std::string &iniFileName, const std::string &sectionName);
00059
00068         ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API StatusCode Read(const IniFileParser::ConstSectionIterator &sectionIterator);
00069
00070         bool                        m_shouldTerminateOnError;
00071         bool                        m_shouldReInitializeOnReset;
00072         PathList                    m_pathList;
00073         ServiceIdList               m_serviceIdList;
00074         ServiceHandleList           m_serviceHandleList;
00075         IHeap::BucketInfoVector     m_tableClientHeapBucketInfo;
00076     };
00077
00083     class TableTemplateSpecification
00084     {
00085     public:
00100         ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API TableTemplateSpecification(const TableNo number, const TableVersion version,
00101             const std::string &name, const std::string &codeIdentifier, const TableType type, const bool isLatestVersion,
00102             const TableTemplate::FieldSpecificationList &fieldSpecificationList,
00103             const Index::IndexSpecificationList &indexSpecificationList);
00104
00105         TableNo                                     m_number;
00106         TableVersion                                m_version;
00107         std::string                                 m_name;
00108         std::string                                 m_codeIdentifier;
00109         TableType                                   m_type;
00110         bool                                        m_isLatestVersion;
00111         TableTemplate::FieldSpecificationList       m_fieldSpecificationList;
00112         Index::IndexSpecificationList               m_indexSpecificationList;
00113     };
00114
00118     class ConstIterator
00119     {
00120     public:
00124         ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API ConstIterator();
00125
00131         ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API const TableTemplate &operator*() const;
00132
00138         ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API const TableTemplate *operator->() const;
00139
00145         ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API ConstIterator &operator++();
00146
00152         ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API const ConstIterator operator++(int);
00153
00161         ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API bool operator==(const ConstIterator &rhs) const;
00162
00170         ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API bool operator!=(const ConstIterator &rhs) const;
00171
00177         ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API TableId GetTableId() const;
00178
00184         ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API const TableTemplate &GetTableTemplate() const;
00185
00186     private:
00187         typedef hash_map<TableId, TableTemplate> TableTemplateMap;
00188
00195         ConstIterator(const TableTemplateList *pTableTemplateList, const TableTemplateMap::const_iterator &iterator);
00196
00197         const TableTemplateList             *m_pTableTemplateList;
00198         TableTemplateMap::const_iterator    m_iterator;
00199
00200         friend class TableTemplateList;
00201     };
00202
00210     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API TableTemplateList();
00211
00222     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API TableTemplateList(Application &application, const Settings &settings);
00223
00233     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API TableTemplateList(const std::string &path);
00234
00244     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API TableTemplateList(const PathList &pathList);
00245
00257     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API TableTemplateList(Application &application, const ServiceIdList &serviceIdList, IHeap * const pHeap = 0);
00258
00270     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API TableTemplateList(Application &application, const ServiceHandleList &serviceHandleList, IHeap * const pHeap = 0);
00271
00275     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API ~TableTemplateList();
00276
00287     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API StatusCode Initialize(bool shouldInitializeUniversalFieldList = true);
00288
00302     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API StatusCode Initialize(Application &application, const Settings &settings, IHeap * const pHeap, const std::string &componentId = Component::defaultComponentId);
00303
00314     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API StatusCode Initialize(const std::string &path);
00315
00326     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API StatusCode Initialize(const PathList &pathList);
00327
00341     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API StatusCode Initialize(Application &application, const ServiceIdList &serviceIdList, IHeap * const pHeap = 0, const std::string &componentId = Component::defaultComponentId);
00342
00356     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API StatusCode Initialize(Application &application, const ServiceHandleList &serviceHandleList, IHeap * const pHeap = 0, const std::string &componentId = Component::defaultComponentId);
00357
00361     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API void Reset();
00362
00366     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API void Clear();
00367
00377     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API StatusCode InsertTableTemplate(const TableTemplate &tableTemplate, bool updateLatestVersion = false);
00378
00387     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API StatusCode RemoveTableTemplate(const TableId tableId);
00388
00397     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API StatusCode ApplyTableTemplateAddition(const TableTemplateAddition &tableTemplateAddition);
00398
00404     size_t GetSize() const;
00405
00415     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API StatusCode GetTableTemplate(const TableId tableId, const TableTemplate *&pTableTemplate) const;
00416
00426     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API StatusCode GetLatestTableTemplate(const TableNo tableNumber, const TableTemplate *&pTableTemplate) const;
00427
00437     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API StatusCode GetLatestTableTemplateId(const TableNo tableNumber, TableId &tableId) const;
00438
00448     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API StatusCode GetFirstTableTemplate(const TableTemplate *&pTableTemplate) const;
00449
00460     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API StatusCode GetNextTableTemplate(const TableTemplate *&pTableTemplate) const;
00461
00471     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API StatusCode GetUniversalField(const FieldId fieldId, const UniversalField *&pUniversalField) const;
00472
00478     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API const UniversalFieldList &GetUniversalFieldList() const;
00479
00485     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API ConstIterator Begin() const;
00486
00492     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API ConstIterator End() const;
00493
00501     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API std::string ToString(bool shouldDisplayInitializeType = false) const;
00502
00509     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API void UiAddAllOptions(UiMenu &uiMenu, const std::string &sectionName = std::string());
00510
00516     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API void UiDisplayTableTemplatesList(const Activ::UiIo &uiIo);
00517
00523     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API void UiDisplayTableTemplateFields(const Activ::UiIo &uiIo);
00524
00530     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API void UiDisplayUniversalFieldList(const Activ::UiIo &uiIo);
00531
00537     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API void UiReInitializeTableTemplateListFromHeaders(const Activ::UiIo &uiIo);
00538
00544     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API void UiReInitializeTableTemplateListFromPathList(const Activ::UiIo &uiIo);
00545
00551     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API void UiReInitializeTableTemplateListFromSettingsObject(const Activ::UiIo &uiIo);
00552
00558     std::string GetError() const;
00559
00560 private:
00561     typedef hash_map<TableId, TableTemplate> TableTemplateMap;
00562     typedef hash_map<TableNo, TableTemplate> LatestTableTemplateMap;
00563
00573     StatusCode GetTableTemplate(const TableId tableId, TableTemplate *&pTableTemplate);
00574
00584     StatusCode GetLatestTableTemplate(const TableNo tableNumber, TableTemplate *&pTableTemplate);
00585
00596     StatusCode GetUniversalField(const FieldId fieldId, UniversalField *&pUniversalField) const;
00597
00605     bool IsOnlyVersion(TableTemplate *&pTableTemplate);
00606
00607     TableTemplateMap                m_tableTemplateMap;
00608     LatestTableTemplateMap          m_latestTableTemplateMap;
00609     UniversalFieldList              m_universalFieldList;
00610
00611     Application *                   m_pApplication;
00612     Settings                        m_settings;
00613
00614     std::string                     m_error;
00615     std::string                     m_initializeType;
00616 };
00617
00618 // ---------------------------------------------------------------------------------------------------------------------------------
00619
00620 inline size_t TableTemplateList::GetSize() const
00621 {
00622     return m_tableTemplateMap.size();
00623 }
00624
00625 // ---------------------------------------------------------------------------------------------------------------------------------
00626
00627 inline std::string TableTemplateList::GetError() const
00628 {
00629     return m_error;
00630 }
00631
00632 } // namespace Feed
00633
00634 } // namespace ContentPlatform
00635
00636 } // namespace Activ
00637
00638 #endif // (!defined ACTIV_FEED_TABLE_TEMPLATE_HANDLER_TABLE_TEMPLATE_LIST_H)
Generated on Wed Oct 8 14:01:46 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedMessageHandler

TableTemplateMessageHeaderDefinitions.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FEED_MESSAGE_HANDLER_TABLE_TEMPLATE_MESSAGE_HEADER_DEFINITIONS_H)
00010 #define ACTIV_FEED_MESSAGE_HANDLER_TABLE_TEMPLATE_MESSAGE_HEADER_DEFINITIONS_H
00011
00012 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/External.h"
00013 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/ActivFeedMessageHandler.h"
00014 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/MessageHeaderDefinitions.h"
00015
00016 namespace Activ
00017 {
00018
00019 namespace ContentPlatform
00020 {
00021
00022 namespace Feed
00023 {
00024
00028 class TableTemplateMessageHeaderDefinitions
00029 {
00030 public:
00031     static const MessageType    MESSAGE_TYPE    = MESSAGE_TYPE_TABLE_TEMPLATE;
00032
00033     static const size_t     MESSAGE_HEADER_FLAGS_RESERVED_OFFSET    = 0;
00034     static const size_t     MESSAGE_HEADER_FLAGS_RESERVED_LENGTH    = 2;
00035
00036     static const size_t     MAX_NAME_LENGTH = 32;
00037     static const size_t     MAX_INDEX_NAME_LENGTH   = 32;
00038
00044     static MessageHeaderDefinitions::MessageHeader GetMessageHeader();
00045
00053     static bool IsValidMessageType(const MessageHeaderDefinitions::MessageHeader messageHeader);
00054 };
00055
00056 // ---------------------------------------------------------------------------------------------------------------------------------
00057
00058 inline MessageHeaderDefinitions::MessageHeader TableTemplateMessageHeaderDefinitions::GetMessageHeader()
00059 {
00060     return MessageHeaderDefinitions::GetMessageHeader(0, MESSAGE_TYPE);
00061 }
00062
00063 // ---------------------------------------------------------------------------------------------------------------------------------
00064
00065 inline bool TableTemplateMessageHeaderDefinitions::IsValidMessageType(const MessageHeaderDefinitions::MessageHeader messageHeader)
00066 {
00067     return (MESSAGE_TYPE == MessageHeaderDefinitions::GetMessageType(messageHeader));
00068 }
00069
00070 } // namespace Feed
00071
00072 } // namespace ContentPlatform
00073
00074 } // namespace Activ
00075
00076 #endif // (!defined ACTIV_FEED_MESSAGE_HANDLER_TABLE_TEMPLATE_MESSAGE_HEADER_DEFINITIONS_H)
Generated on Wed Oct 8 14:01:46 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedMessageHandler

TableTemplateMessageValidator.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FEED_MESSAGE_HANDLER_TABLE_TEMPLATE_MESSAGE_VALIDATOR_H)
00010 #define ACTIV_FEED_MESSAGE_HANDLER_TABLE_TEMPLATE_MESSAGE_VALIDATOR_H
00011
00012 #include "ActivMiddleware/ActivFieldTypes/TextString.h"
00013
00014 #include "ActivContentPlatform/ActivFeedCommon/ActivFeed.h"
00015
00016 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/External.h"
00017
00018 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/TableTemplateFieldListValidator.h"
00019 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedMessageHandler/TableTemplateIndexListValidator.h"
00020
00021 namespace Activ
00022 {
00023
00024 class MessageValidator;
00025
00026 namespace ContentPlatform
00027 {
00028
00029 namespace Feed
00030 {
00031
00032 class UniversalFieldList;
00033 class TableTemplateField;
00034 class TableTemplateIndex;
00035
00036 // ---------------------------------------------------------------------------------------------------------------------------------
00037
00041 class TableTemplateMessageValidator
00042 {
00043 public:
00044     typedef TableTemplateFieldListValidator::ConstIterator ConstFieldIterator;
00045     typedef TableTemplateIndexListValidator::ConstIterator ConstIndexIterator;
00046
00050     ACTIV_FEED_MESSAGE_HANDLER_API TableTemplateMessageValidator();
00051
00060     ACTIV_FEED_MESSAGE_HANDLER_API TableTemplateMessageValidator(const UniversalFieldList &universalFieldList, MessageValidator &messageValidator);
00061
00069     ACTIV_FEED_MESSAGE_HANDLER_API TableTemplateMessageValidator(const UniversalFieldList &universalFieldList);
00070
00074     ACTIV_FEED_MESSAGE_HANDLER_API ~TableTemplateMessageValidator();
00075
00085     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Initialize(const UniversalFieldList &universalFieldList, MessageValidator &messageValidator);
00086
00094     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Initialize(const UniversalFieldList &universalFieldList);
00095
00104     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode Initialize(MessageValidator &messageValidator);
00105
00109     ACTIV_FEED_MESSAGE_HANDLER_API void Reset();
00110
00119     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode GetTableId(TableId &tableId) const;
00120
00129     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode GetName(const TextString *&pName) const;
00130
00141     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode GetTableTemplateField(const FieldId fieldId, const TableTemplateField *&pTableTemplateField) const;
00142
00153     ACTIV_FEED_MESSAGE_HANDLER_API StatusCode GetTableTemplateIndex(const IndexNumber indexNumber, const TableTemplateIndex *&pTableTemplateIndex) const;
00154
00160     ACTIV_FEED_MESSAGE_HANDLER_API bool IsInitialized() const;
00161
00169     ACTIV_FEED_MESSAGE_HANDLER_API ConstFieldIterator BeginField() const;
00170
00178     ACTIV_FEED_MESSAGE_HANDLER_API ConstFieldIterator EndField() const;
00179
00187     ACTIV_FEED_MESSAGE_HANDLER_API ConstIndexIterator BeginIndex() const;
00188
00196     ACTIV_FEED_MESSAGE_HANDLER_API ConstIndexIterator EndIndex() const;
00197
00198 private:
00204     TableTemplateMessageValidator(const TableTemplateMessageValidator &rhs);
00205
00213     TableTemplateMessageValidator& operator=(const TableTemplateMessageValidator &rhs);
00214
00218     void Clear();
00219
00220     const UniversalFieldList            *m_pUniversalFieldList;
00221
00222     bool                                m_isInitialized;
00223     TableId                             m_tableId;
00224     TextString                          m_name;
00225     TableTemplateFieldListValidator     m_tableTemplateFieldListValidator;
00226     TableTemplateIndexListValidator     m_tableTemplateIndexListValidator;
00227 };
00228
00229 } // namespace Feed
00230
00231 } // namespace ContentPlatform
00232
00233 } // namespace Activ
00234
00235 #endif // (!defined ACTIV_FEED_MESSAGE_HANDLER_TABLE_TEMPLATE_MESSAGE_VALIDATOR_H)
Generated on Wed Oct 8 14:01:46 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon

TableTypes.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FEED_COMMON_TABLE_TYPES_H)
00010 #define ACTIV_FEED_COMMON_TABLE_TYPES_H
00011
00012 #include "ActivContentPlatform/ActivFeedCommon/External.h"
00013
00014 #include <string>
00015
00016 namespace Activ
00017 {
00018
00019 namespace ContentPlatform
00020 {
00021
00022 namespace Feed
00023 {
00024
00025 typedef uint8_t TableType;
00026
00032 #define ACTIV_TABLE_TYPE_LIST(d)                                \
00033     d(TABLE_TYPE_REALTIME,          Realtime,           RT)     \
00034     d(TABLE_TYPE_NAVIGATION,        Navigation,         Nav)    \
00035     d(TABLE_TYPE_PERMISSION,        Permission,         Perm)   \
00036     d(TABLE_TYPE_CORPORATE_ACTION,  CorporateAction,    CA)     \
00037     d(TABLE_TYPE_NEWS,              News,               News)   \
00038     d(TABLE_TYPE_INTERNAL,          Internal,           Intl)   \
00039     d(TABLE_TYPE_REALTIME_LEVEL_2,  RealtimeLevel2,     RTL2)   \
00040     d(TABLE_TYPE_ALIAS,             Alias,              Als)    \
00041     d(TABLE_TYPE_METADATA,          Metadata,           Mtda)   \
00042     d(TABLE_TYPE_USER,              User,               User)   \
00043     d(TABLE_TYPE_ORDER,             Order,              Ordr)   \
00044     d(TABLE_TYPE_BBO_DEPTH,         BboDepth,           BboD)
00045
00049 #define ACTIV_DECLARE_TABLE_TYPE_ENUMERATIONS(id, name, abbreviatedName)            id,
00050
00051 // ---------------------------------------------------------------------------------------------------------------------------------
00052
00056 enum
00057 {
00058     ACTIV_TABLE_TYPE_LIST(ACTIV_DECLARE_TABLE_TYPE_ENUMERATIONS)
00059     NUMBER_OF_TABLE_TYPES,
00060     TABLE_TYPE_UNKNOWN = static_cast<TableType>(~0)
00061 };
00062
00063 #undef ACTIV_DECLARE_TABLE_TYPE_ENUMERATIONS
00064
00072 ACTIV_FEED_COMMON_API std::string TableTypeToString(const TableType tableType);
00073
00081 ACTIV_FEED_COMMON_API std::string TableTypeToAbbreviatedString(const TableType tableType);
00082
00090 ACTIV_FEED_COMMON_API TableType StringToTableType(const std::string &name);
00091
00092 } // namespace Feed
00093
00094 } // namespace ContentPlatform
00095
00096 } // namespace Activ
00097
00098 #endif // (!defined ACTIV_FEED_COMMON_TABLE_TYPES_H)
Generated on Wed Oct 8 14:01:46 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivIp

TcpListener.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_IP_TCP_LISTENER_H)
00010 #define ACTIV_IP_TCP_LISTENER_H
00011
00012 #include "External.h"
00013
00014 #if (defined ACTIV_PLATFORM_WINDOWS)
00015 #include "Windows/TcpListener.h"
00016 #elif (defined ACTIV_PLATFORM_POSIX)
00017 #include "Posix/TcpListener.h"
00018 #else
00019 #error No TcpListener.h for this platform yet.
00020 #endif
00021
00022 #endif // (!defined ACTIV_IP_TCP_LISTENER_H)
Generated on Wed Oct 8 14:01:48 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivIp

TcpSocket.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_IP_TCP_SOCKET_H)
00010 #define ACTIV_IP_TCP_SOCKET_H
00011
00012 #include "External.h"
00013
00014 #if (defined ACTIV_PLATFORM_WINDOWS)
00015 #include "Windows/TcpSocket.h"
00016 #elif (defined ACTIV_PLATFORM_POSIX)
00017 #include "Posix/TcpSocket.h"
00018 #else
00019 #error No TcpSocket.h for this platform yet.
00020 #endif
00021
00022 #endif // (!defined ACTIV_IP_TCP_SOCKET_H)
Generated on Wed Oct 8 14:01:48 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » Misc

TemplateFunctions.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_MISC_TEMPLATE_FUNCTIONS_H)
00010 #define ACTIV_MISC_TEMPLATE_FUNCTIONS_H
00011
00012 #include "ActivMiddleware/Activ.h"
00013
00014 #include <string>
00015
00016 namespace Activ
00017 {
00018
00028 template <typename T>
00029 std::string IndexToString(const T index, const char * const array[], const size_t arraySize)
00030 {
00031     const size_t actualIndex = static_cast<size_t>(index);
00032
00033     if (actualIndex < arraySize)
00034         return array[actualIndex];
00035
00036     return std::string("unknown index ") + TypeToString(index);
00037 }
00038
00039 } // namespace Activ
00040
00041 #endif // (!defined ACTIV_MISC_TEMPLATE_FUNCTIONS_H)
Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivFieldTypes

TextArray.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FIELD_TYPES_TEXT_ARRAY_H)
00010 #define ACTIV_FIELD_TYPES_TEXT_ARRAY_H
00011
00012 #include "ActivMiddleware/ActivFieldTypes/External.h"
00013 #include "ActivMiddleware/ActivFieldTypes/IFieldType.h"
00014
00015 #include "ActivMiddleware/Misc/MemoryHelper.h"
00016
00017 #include "ActivMiddleware/ActivBase/StatusCodeException.h"
00018
00019 namespace Activ
00020 {
00021
00022 class MessageBuilder;
00023 class MessageValidator;
00024
00025 // ---------------------------------------------------------------------------------------------------------------------------------
00026
00030 class TextArray : public IFieldType
00031 {
00032 public:
00033     static const FieldType FIELD_TYPE = FIELD_TYPE_TEXT_ARRAY;
00034
00035     using IFieldType::FromString;
00036     using IFieldType::Serialize;
00037     using IFieldType::SerializeBody;
00038     using IFieldType::SerializeLengthAndBody;
00039     using IFieldType::Deserialize;
00040     using IFieldType::DeserializeBody;
00041     using IFieldType::DeserializeLengthAndBody;
00042
00046     TextArray();
00047
00056     TextArray(const uint8_t * const pData, const size_t size);
00057
00063     TextArray(const TextArray &rhs);
00064
00068     virtual ~TextArray();
00069
00077     TextArray& operator=(const TextArray &rhs);
00078
00089     StatusCode Set(const uint8_t * const pData, const size_t size);
00090
00100     StatusCode Get(const uint8_t *&pData, size_t &size) const;
00101
00109     const uint8_t *GetData() const;
00110
00118     size_t GetSize() const;
00119
00120     virtual void Reset();
00121     virtual void Clear();
00122
00131     ACTIV_FIELD_TYPES_API StatusCode Compare(const TextArray &rhs, int &result) const;
00132
00133     ACTIV_FIELD_TYPES_API virtual StatusCode Compare(const void * const pRhsSerializedBody, const size_t rhsSerializedBodyLength, int &result) const;
00134     ACTIV_FIELD_TYPES_API virtual StatusCode Convert(const IFieldType * const pIFieldType);
00135     ACTIV_FIELD_TYPES_API virtual std::string ToString() const;
00136     ACTIV_FIELD_TYPES_API virtual StatusCode FromString(MessageValidator &messageValidator);
00137     ACTIV_FIELD_TYPES_API virtual std::string GetFromStringFormat() const;
00138     ACTIV_FIELD_TYPES_API virtual StatusCode Serialize(MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength) const;
00139     ACTIV_FIELD_TYPES_API virtual StatusCode SerializeBody(void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength) const;
00140     ACTIV_FIELD_TYPES_API virtual StatusCode SerializeLengthAndBody(MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength = MAX_SERIALIZED_BODY_LENGTH_UNDEFINED) const;
00141     ACTIV_FIELD_TYPES_API virtual StatusCode Deserialize(MessageValidator &messageValidator, const size_t maxSerializedBodyLength);
00142     ACTIV_FIELD_TYPES_API virtual StatusCode DeserializeBody(const void * const pSerializedBody, const size_t serializedBodyLength);
00143     ACTIV_FIELD_TYPES_API virtual StatusCode DeserializeLengthAndBody(MessageValidator &messageValidator, const size_t maxSerializedBodyLength = MAX_SERIALIZED_BODY_LENGTH_UNDEFINED);
00144     virtual size_t GetSerializedLength() const;
00145     virtual size_t GetSerializedBodyLength() const;
00146     ACTIV_FIELD_TYPES_API virtual StatusCode IsDifferent(const void * const pRhsSerializedBody, const size_t rhsSerializedBodyLength, bool &isDifferent) const;
00147
00155     static size_t GetMaxSerializedLength(const size_t size);
00156
00164     static size_t GetMaxSerializedBodyLength(const size_t size);
00165
00178     ACTIV_FIELD_TYPES_API static StatusCode Compare(const void * const pLhsSerializedBody, const size_t lhsSerializedBodyLength, const void * const pRhsSerializedBody, const size_t rhsSerializedBodyLength, int &result);
00179
00192     ACTIV_FIELD_TYPES_API static StatusCode Serialize(MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength, const uint8_t * const pData, const size_t size);
00193
00207     ACTIV_FIELD_TYPES_API static StatusCode SerializeBody(void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength, const uint8_t * const pData, const size_t size);
00208
00221     ACTIV_FIELD_TYPES_API static StatusCode SerializeLengthAndBody(MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength, const uint8_t * const pData, const size_t size);
00222
00235     ACTIV_FIELD_TYPES_API static StatusCode Deserialize(MessageValidator &messageValidator, const size_t maxSerializedBodyLength, const uint8_t *&pData, size_t &size);
00236
00248     ACTIV_FIELD_TYPES_API static StatusCode DeserializeBody(const void * const pSerializedBody, const size_t serializedBodyLength, const uint8_t *&pData, size_t &size);
00249
00262     ACTIV_FIELD_TYPES_API static StatusCode DeserializeLengthAndBody(MessageValidator &messageValidator, const size_t maxSerializedBodyLength, const uint8_t *&pData, size_t &size);
00263
00274     ACTIV_FIELD_TYPES_API static StatusCode ValidateSerializedLengthAndBody(MessageValidator &messageValidator, size_t &serializedBodyOffset, size_t &serializedBodyLength);
00275
00283     static bool IsValidSerializedBodyLength(const size_t serializedBodyLength);
00284
00285 private:
00286     static const size_t RESERVED_BUFFER_SIZE = 32;
00287
00298     static int Compare(const void * const pLhsBuffer, const size_t lhsBufferLength, const void * const pRhsBuffer, const size_t rhsBufferLength);
00299
00300     uint8_t     m_reservedBuffer[RESERVED_BUFFER_SIZE];
00301     size_t      m_allocatedSize;
00302
00303     uint8_t *   m_pData;
00304     size_t      m_size;
00305 };
00306
00307 // ---------------------------------------------------------------------------------------------------------------------------------
00308
00309 inline TextArray::TextArray() :
00310     IFieldType(FIELD_TYPE),
00311     m_allocatedSize(0),
00312     m_pData(m_reservedBuffer)
00313 {
00314     m_isInitialized = false;
00315 }
00316
00317 // ---------------------------------------------------------------------------------------------------------------------------------
00318
00319 inline TextArray::TextArray(const uint8_t * const pData, const size_t size) :
00320     IFieldType(FIELD_TYPE),
00321     m_allocatedSize(0),
00322     m_pData(m_reservedBuffer)
00323 {
00324     ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, Set(pData, size));
00325 }
00326
00327 // ---------------------------------------------------------------------------------------------------------------------------------
00328
00329 inline TextArray::TextArray(const TextArray &rhs) :
00330     IFieldType(FIELD_TYPE),
00331     m_allocatedSize(0),
00332     m_pData(m_reservedBuffer)
00333 {
00334     if (rhs.IsInitialized())
00335         ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, Set(rhs.m_pData, rhs.m_size));
00336     else
00337         m_isInitialized = false;
00338 }
00339
00340 // ---------------------------------------------------------------------------------------------------------------------------------
00341
00342 inline TextArray::~TextArray()
00343 {
00344     if (0 != m_allocatedSize)
00345         std::free(m_pData);
00346 }
00347
00348 // ---------------------------------------------------------------------------------------------------------------------------------
00349
00350 inline TextArray& TextArray::operator=(const TextArray &rhs)
00351 {
00352     if (this != &rhs)
00353     {
00354         if (rhs.IsInitialized())
00355         {
00356             ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, Set(rhs.m_pData, rhs.m_size));
00357         }
00358         else
00359         {
00360             Reset();
00361         }
00362     }
00363
00364     return *this;
00365 }
00366
00367 // ---------------------------------------------------------------------------------------------------------------------------------
00368
00369 inline StatusCode TextArray::Set(const uint8_t * const pData, const size_t size)
00370 {
00371     // TODO: range check?
00372
00373     if (0 == size)
00374         return STATUS_CODE_INVALID_PARAMETER;
00375
00376     if (size > std::max<size_t>(m_allocatedSize, size_t(RESERVED_BUFFER_SIZE)))
00377     {
00378         const size_t allocatedSize = (4 * (((std::max<size_t>(m_allocatedSize + (m_allocatedSize / 2), size) - 1) / 4) + 1));
00379         uint8_t * const pAllocated = static_cast<uint8_t *>(((0 != m_allocatedSize) ? std::realloc(m_pData, allocatedSize) : std::malloc(allocatedSize)));
00380
00381         if (0 == pAllocated)
00382             return STATUS_CODE_HEAP_EMPTY;
00383
00384         m_allocatedSize = allocatedSize;
00385         m_pData = pAllocated;
00386     }
00387
00388     MemoryCopy(m_pData, pData, size);
00389
00390     m_size = size;
00391     m_isInitialized = true;
00392
00393     return STATUS_CODE_SUCCESS;
00394 }
00395
00396 // ---------------------------------------------------------------------------------------------------------------------------------
00397
00398 inline StatusCode TextArray::Get(const uint8_t *&pData, size_t &size) const
00399 {
00400     if (!IsInitialized())
00401         return STATUS_CODE_NOT_INITIALIZED;
00402
00403     pData = m_pData;
00404     size = m_size;
00405
00406     return STATUS_CODE_SUCCESS;
00407 }
00408
00409 // ---------------------------------------------------------------------------------------------------------------------------------
00410
00411 inline const uint8_t *TextArray::GetData() const
00412 {
00413     if (!IsInitialized())
00414         ACTIV_THROW(StatusCodeException, STATUS_CODE_NOT_INITIALIZED);
00415
00416     return m_pData;
00417 }
00418
00419 // ---------------------------------------------------------------------------------------------------------------------------------
00420
00421 inline size_t TextArray::GetSize() const
00422 {
00423     if (!IsInitialized())
00424         ACTIV_THROW(StatusCodeException, STATUS_CODE_NOT_INITIALIZED);
00425
00426     return m_size;
00427 }
00428
00429 // ---------------------------------------------------------------------------------------------------------------------------------
00430
00431 inline void TextArray::Reset()
00432 {
00433     m_isInitialized = false;
00434 }
00435
00436 // ---------------------------------------------------------------------------------------------------------------------------------
00437
00438 inline void TextArray::Clear()
00439 {
00440     if (0 != m_allocatedSize)
00441     {
00442         std::free(m_pData);
00443         m_allocatedSize = 0;
00444     }
00445
00446     m_pData = m_reservedBuffer;
00447     m_isInitialized = false;
00448 }
00449
00450 // ---------------------------------------------------------------------------------------------------------------------------------
00451
00452 inline size_t TextArray::GetSerializedLength() const
00453 {
00454     return (IsInitialized() ? GetMaxSerializedLength(m_size) : 0);
00455 }
00456
00457 // ---------------------------------------------------------------------------------------------------------------------------------
00458
00459 inline size_t TextArray::GetSerializedBodyLength() const
00460 {
00461     return (IsInitialized() ? GetMaxSerializedBodyLength(m_size) : 0);
00462 }
00463
00464 // ---------------------------------------------------------------------------------------------------------------------------------
00465
00466 inline size_t TextArray::GetMaxSerializedLength(const size_t size)
00467 {
00468     return GetMaxSerializedBodyLength(size);
00469 }
00470
00471 // ---------------------------------------------------------------------------------------------------------------------------------
00472
00473 inline size_t TextArray::GetMaxSerializedBodyLength(const size_t size)
00474 {
00475     return size;
00476 }
00477
00478 // ---------------------------------------------------------------------------------------------------------------------------------
00479
00480 inline bool TextArray::IsValidSerializedBodyLength(const size_t serializedBodyLength)
00481 {
00482     return (0 != serializedBodyLength);
00483 }
00484
00485 // ---------------------------------------------------------------------------------------------------------------------------------
00486 // ---------------------------------------------------------------------------------------------------------------------------------
00487
00491 template<>
00492 class FieldTypeToClass<FIELD_TYPE_TEXT_ARRAY>
00493 {
00494 public:
00495     typedef TextArray Type;
00496 };
00497
00498 } // namespace Activ
00499
00500 #endif // (!defined ACTIV_FIELD_TYPES_TEXT_ARRAY_H)
Generated on Wed Oct 8 14:01:48 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivFieldTypes

TextString.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FIELD_TYPES_TEXT_STRING_H)
00010 #define ACTIV_FIELD_TYPES_TEXT_STRING_H
00011
00012 #include "ActivMiddleware/ActivFieldTypes/External.h"
00013 #include "ActivMiddleware/ActivFieldTypes/IFieldType.h"
00014
00015 #include "ActivMiddleware/Misc/MemoryHelper.h"
00016
00017 #include "ActivMiddleware/ActivBase/StatusCodeException.h"
00018
00019 namespace Activ
00020 {
00021
00022 class MessageBuilder;
00023 class MessageValidator;
00024
00025 // ---------------------------------------------------------------------------------------------------------------------------------
00026
00030 class TextString : public IFieldType
00031 {
00032 public:
00033     static const FieldType FIELD_TYPE = FIELD_TYPE_TEXT_STRING;
00034
00035     using IFieldType::FromString;
00036     using IFieldType::Serialize;
00037     using IFieldType::SerializeBody;
00038     using IFieldType::SerializeLengthAndBody;
00039     using IFieldType::Deserialize;
00040     using IFieldType::DeserializeBody;
00041     using IFieldType::DeserializeLengthAndBody;
00042
00046     TextString();
00047
00056     TextString(const uint8_t * const pData, const size_t size);
00057
00063     TextString(const TextString &rhs);
00064
00068     virtual ~TextString();
00069
00077     TextString& operator=(const TextString &rhs);
00078
00089     StatusCode Set(const uint8_t * const pData, const size_t size);
00090
00100     StatusCode Get(const uint8_t *&pData, size_t &size) const;
00101
00109     const uint8_t *GetData() const;
00110
00118     size_t GetSize() const;
00119
00120     virtual void Reset();
00121     virtual void Clear();
00122
00131     ACTIV_FIELD_TYPES_API StatusCode Compare(const TextString &rhs, int &result) const;
00132
00133     ACTIV_FIELD_TYPES_API virtual StatusCode Compare(const void * const pRhsSerializedBody, const size_t rhsSerializedBodyLength, int &result) const;
00134     ACTIV_FIELD_TYPES_API virtual StatusCode Convert(const IFieldType * const pIFieldType);
00135     ACTIV_FIELD_TYPES_API virtual std::string ToString() const;
00136     ACTIV_FIELD_TYPES_API virtual StatusCode FromString(MessageValidator &messageValidator);
00137     ACTIV_FIELD_TYPES_API virtual std::string GetFromStringFormat() const;
00138     ACTIV_FIELD_TYPES_API virtual StatusCode Serialize(MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength) const;
00139     ACTIV_FIELD_TYPES_API virtual StatusCode SerializeBody(void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength) const;
00140     ACTIV_FIELD_TYPES_API virtual StatusCode SerializeLengthAndBody(MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength = MAX_SERIALIZED_BODY_LENGTH_UNDEFINED) const;
00141     ACTIV_FIELD_TYPES_API virtual StatusCode Deserialize(MessageValidator &messageValidator, const size_t maxSerializedBodyLength);
00142     ACTIV_FIELD_TYPES_API virtual StatusCode DeserializeBody(const void * const pSerializedBody, const size_t serializedBodyLength);
00143     ACTIV_FIELD_TYPES_API virtual StatusCode DeserializeLengthAndBody(MessageValidator &messageValidator, const size_t maxSerializedBodyLength = MAX_SERIALIZED_BODY_LENGTH_UNDEFINED);
00144     virtual size_t GetSerializedLength() const;
00145     virtual size_t GetSerializedBodyLength() const;
00146     ACTIV_FIELD_TYPES_API virtual StatusCode IsDifferent(const void * const pRhsSerializedBody, const size_t rhsSerializedBodyLength, bool &isDifferent) const;
00147
00155     static size_t GetMaxSerializedLength(const size_t size);
00156
00164     static size_t GetMaxSerializedBodyLength(const size_t size);
00165
00178     ACTIV_FIELD_TYPES_API static StatusCode Compare(const void * const pLhsSerializedBody, const size_t lhsSerializedBodyLength, const void * const pRhsSerializedBody, const size_t rhsSerializedBodyLength, int &result);
00179
00192     ACTIV_FIELD_TYPES_API static StatusCode Serialize(MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength, const uint8_t * const pData, const size_t size);
00193
00207     ACTIV_FIELD_TYPES_API static StatusCode SerializeBody(void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength, const uint8_t * const pData, const size_t size);
00208
00221     ACTIV_FIELD_TYPES_API static StatusCode SerializeLengthAndBody(MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength, const uint8_t * const pData, const size_t size);
00222
00234     ACTIV_FIELD_TYPES_API static StatusCode Deserialize(MessageValidator &messageValidator, const size_t maxSerializedBodyLength, const uint8_t *&pData, size_t &size);
00235
00247     ACTIV_FIELD_TYPES_API static StatusCode DeserializeBody(const void * const pSerializedBody, const size_t serializedBodyLength, const uint8_t *&pData, size_t &size);
00248
00260     ACTIV_FIELD_TYPES_API static StatusCode DeserializeLengthAndBody(MessageValidator &messageValidator, const size_t maxSerializedBodyLength, const uint8_t *&pData, size_t &size);
00261
00272     ACTIV_FIELD_TYPES_API static StatusCode ValidateSerializedLengthAndBody(MessageValidator &messageValidator, size_t &serializedBodyOffset, size_t &serializedBodyLength);
00273
00281     static bool IsValidSerializedBodyLength(const size_t serializedBodyLength);
00282
00283 private:
00284     static const size_t RESERVED_BUFFER_SIZE = 32;
00285
00296     static int Compare(const void * const pLhsBuffer, const size_t lhsBufferLength, const void * const pRhsBuffer, const size_t rhsBufferLength);
00297
00298     uint8_t     m_reservedBuffer[RESERVED_BUFFER_SIZE];
00299     size_t      m_allocatedSize;
00300
00301     uint8_t *   m_pData;
00302     size_t      m_size;
00303 };
00304
00305 // ---------------------------------------------------------------------------------------------------------------------------------
00306
00307 inline TextString::TextString() :
00308     IFieldType(FIELD_TYPE),
00309     m_allocatedSize(0),
00310     m_pData(m_reservedBuffer)
00311 {
00312     m_isInitialized = false;
00313 }
00314
00315 // ---------------------------------------------------------------------------------------------------------------------------------
00316
00317 inline TextString::TextString(const uint8_t * const pData, const size_t size) :
00318     IFieldType(FIELD_TYPE),
00319     m_allocatedSize(0),
00320     m_pData(m_reservedBuffer)
00321 {
00322     ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, Set(pData, size));
00323 }
00324
00325 // ---------------------------------------------------------------------------------------------------------------------------------
00326
00327 inline TextString::TextString(const TextString &rhs) :
00328     IFieldType(FIELD_TYPE),
00329     m_allocatedSize(0),
00330     m_pData(m_reservedBuffer)
00331 {
00332     if (rhs.IsInitialized())
00333         ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, Set(rhs.m_pData, rhs.m_size));
00334     else
00335         m_isInitialized = false;
00336 }
00337
00338 // ---------------------------------------------------------------------------------------------------------------------------------
00339
00340 inline TextString::~TextString()
00341 {
00342     if (0 != m_allocatedSize)
00343         std::free(m_pData);
00344 }
00345
00346 // ---------------------------------------------------------------------------------------------------------------------------------
00347
00348 inline TextString& TextString::operator=(const TextString &rhs)
00349 {
00350     if (this != &rhs)
00351     {
00352         if (rhs.IsInitialized())
00353         {
00354             ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, Set(rhs.m_pData, rhs.m_size));
00355         }
00356         else
00357         {
00358             Reset();
00359         }
00360     }
00361
00362     return *this;
00363 }
00364
00365 // ---------------------------------------------------------------------------------------------------------------------------------
00366
00367 inline StatusCode TextString::Set(const uint8_t * const pData, const size_t size)
00368 {
00369     // TODO: range check?
00370
00371     if (0 == size)
00372         return STATUS_CODE_INVALID_PARAMETER;
00373
00374     if (size > std::max<size_t>(m_allocatedSize, size_t(RESERVED_BUFFER_SIZE)))
00375     {
00376         const size_t allocatedSize = (4 * (((std::max<size_t>(m_allocatedSize + (m_allocatedSize / 2), size) - 1) / 4) + 1));
00377         uint8_t * const pAllocated = static_cast<uint8_t *>(((0 != m_allocatedSize) ? std::realloc(m_pData, allocatedSize) : std::malloc(allocatedSize)));
00378
00379         if (0 == pAllocated)
00380             return STATUS_CODE_HEAP_EMPTY;
00381
00382         m_allocatedSize = allocatedSize;
00383         m_pData = pAllocated;
00384     }
00385
00386     MemoryCopy(m_pData, pData, size);
00387
00388     m_size = size;
00389     m_isInitialized = true;
00390
00391     return STATUS_CODE_SUCCESS;
00392 }
00393
00394 // ---------------------------------------------------------------------------------------------------------------------------------
00395
00396 inline StatusCode TextString::Get(const uint8_t *&pData, size_t &size) const
00397 {
00398     if (!IsInitialized())
00399         return STATUS_CODE_NOT_INITIALIZED;
00400
00401     pData = m_pData;
00402     size = m_size;
00403
00404     return STATUS_CODE_SUCCESS;
00405 }
00406
00407 // ---------------------------------------------------------------------------------------------------------------------------------
00408
00409 inline const uint8_t *TextString::GetData() const
00410 {
00411     if (!IsInitialized())
00412         ACTIV_THROW(StatusCodeException, STATUS_CODE_NOT_INITIALIZED);
00413
00414     return m_pData;
00415 }
00416
00417 // ---------------------------------------------------------------------------------------------------------------------------------
00418
00419 inline size_t TextString::GetSize() const
00420 {
00421     if (!IsInitialized())
00422         ACTIV_THROW(StatusCodeException, STATUS_CODE_NOT_INITIALIZED);
00423
00424     return m_size;
00425 }
00426
00427 // ---------------------------------------------------------------------------------------------------------------------------------
00428
00429 inline void TextString::Reset()
00430 {
00431     m_isInitialized = false;
00432 }
00433
00434 // ---------------------------------------------------------------------------------------------------------------------------------
00435
00436 inline void TextString::Clear()
00437 {
00438     if (0 != m_allocatedSize)
00439     {
00440         std::free(m_pData);
00441         m_allocatedSize = 0;
00442     }
00443
00444     m_pData = m_reservedBuffer;
00445     m_isInitialized = false;
00446 }
00447
00448 // ---------------------------------------------------------------------------------------------------------------------------------
00449
00450 inline size_t TextString::GetSerializedLength() const
00451 {
00452     return (IsInitialized() ? GetMaxSerializedLength(m_size) : 0);
00453 }
00454
00455 // ---------------------------------------------------------------------------------------------------------------------------------
00456
00457 inline size_t TextString::GetSerializedBodyLength() const
00458 {
00459     return (IsInitialized() ? GetMaxSerializedBodyLength(m_size) : 0);
00460 }
00461
00462 // ---------------------------------------------------------------------------------------------------------------------------------
00463
00464 inline size_t TextString::GetMaxSerializedLength(const size_t size)
00465 {
00466     return (sizeof(uint8_t) + GetMaxSerializedBodyLength(size));
00467 }
00468
00469 // ---------------------------------------------------------------------------------------------------------------------------------
00470
00471 inline size_t TextString::GetMaxSerializedBodyLength(const size_t size)
00472 {
00473     return size;
00474 }
00475
00476 // ---------------------------------------------------------------------------------------------------------------------------------
00477
00478 inline bool TextString::IsValidSerializedBodyLength(const size_t serializedBodyLength)
00479 {
00480     return ((serializedBodyLength > 0) && (serializedBodyLength <= UINT8_MAX));
00481 }
00482
00483 // ---------------------------------------------------------------------------------------------------------------------------------
00484 // ---------------------------------------------------------------------------------------------------------------------------------
00485
00489 template<>
00490 class FieldTypeToClass<FIELD_TYPE_TEXT_STRING>
00491 {
00492 public:
00493     typedef TextString Type;
00494 };
00495
00496 } // namespace Activ
00497
00498 #endif // (!defined ACTIV_FIELD_TYPES_TEXT_STRING_H)
Generated on Wed Oct 8 14:01:48 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivFramework

ThinApplication.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FRAMEWORK_THIN_APPLICATION_H)
00010 #define ACTIV_FRAMEWORK_THIN_APPLICATION_H
00011
00012 #include "ActivMiddleware/ActivFramework/External.h"
00013 #include "ActivMiddleware/ActivFramework/Application.h"
00014
00015 namespace Activ
00016 {
00017
00024 class ThinApplication : public Application
00025 {
00026 public:
00030     class Settings : public Application::Settings
00031     {
00032     public:
00036         ACTIV_FRAMEWORK_API Settings();
00037
00046         ACTIV_FRAMEWORK_API StatusCode Read(const IniFileParser &iniFileParser);
00047
00048         std::string                 m_processName;
00049         IHeap::BucketInfoVector     m_applicationHeapBucketInfo;
00050     };
00051
00061     ACTIV_FRAMEWORK_API ThinApplication(const Settings &settings, Timeout &timeout = Timeout::GetInfinite(),
00062                                         const std::string &componentId = defaultComponentId);
00063
00067     ACTIV_FRAMEWORK_API virtual ~ThinApplication();
00068
00069 protected:
00070     ACTIV_FRAMEWORK_API virtual StatusCode OnMessage(HeapMessage &message);
00071
00072 private:
00073     class Private;
00074
00075     boost::scoped_ptr<Private>  m_pPrivate;
00076 };
00077
00078 } // namespace Activ
00079
00080 #endif // (!defined ACTIV_FRAMEWORK_THIN_APPLICATION_H)
Generated on Wed Oct 8 14:01:48 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

Thread.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_BASE_THREAD_H)
00010 #define ACTIV_BASE_THREAD_H
00011
00012 #include "ActivMiddleware/ActivBase/External.h"
00013
00014 #include "boost/shared_ptr.hpp"
00015
00016 #include <string>
00017 #include <vector>
00018
00019 namespace Activ
00020 {
00021
00022 #if (defined ACTIV_PLATFORM_WINDOWS)
00023 // to stop the friend declarations getting confused about linkage
00024 extern "C" unsigned WINAPI ActivThreadGlobalThreadProc(void *pData);
00025 #elif (defined ACTIV_PLATFORM_POSIX)
00026 extern "C" void *ActivThreadGlobalThreadProc(void *pData);
00027 extern "C" void ActivThreadGlobalCleanupProc(void *pData);
00028 class IEvent;
00029 #else
00030 #error Configure for this platform
00031 #endif
00032
00033 // ---------------------------------------------------------------------------------------------------------------------------------
00034
00038 class Thread : private boost::noncopyable
00039 {
00040 public:
00041 #if (defined ACTIV_PLATFORM_WINDOWS)
00042     typedef DWORD Id;
00043 #elif (defined ACTIV_PLATFORM_POSIX)
00044     typedef pthread_t Id;
00045 #else
00046 #error Configure for this platform
00047 #endif
00048
00049     typedef std::vector<uint16_t> ProcessorList;
00050
00054     ACTIV_BASE_EXPORTED_API Thread();
00055
00059     ACTIV_BASE_EXPORTED_API virtual ~Thread();
00060
00069     ACTIV_BASE_EXPORTED_API void Start(void *pData = 0, const size_t stackSize = 0);
00070
00076     ACTIV_BASE_EXPORTED_API void End(StatusCode statusCode = STATUS_CODE_SUCCESS);
00077
00087     ACTIV_BASE_EXPORTED_API StatusCode WaitForCompletion(const TimeoutPeriod timeoutPeriod = ACTIV_WAIT_INFINITE) const;
00088
00094     ACTIV_BASE_EXPORTED_API Id GetId() const;
00095
00101     ACTIV_BASE_EXPORTED_API static Id GetCurrentId();
00102
00111     ACTIV_BASE_EXPORTED_API StatusCode GetPriority(uint32_t &priority) const;
00112
00121     ACTIV_BASE_EXPORTED_API StatusCode SetPriority(uint32_t priority);
00122
00132     ACTIV_BASE_EXPORTED_API static StatusCode GetThreadPriority(uint32_t &priority, const Id id = GetCurrentId());
00133
00143     ACTIV_BASE_EXPORTED_API static StatusCode SetThreadPriority(const uint32_t priority, const Id id = GetCurrentId());
00144
00155     ACTIV_BASE_EXPORTED_API static StatusCode StringToPriority(const std::string &str, uint32_t &priority);
00156
00167     ACTIV_BASE_EXPORTED_API static StatusCode SetProcessorAffinity(const ProcessorList &processorList,
00168         const Id id = GetCurrentId());
00169
00175     ACTIV_BASE_EXPORTED_API static void Suspend(const TimeoutPeriod period);
00176
00185     ACTIV_BASE_EXPORTED_API static void SetName(const std::string &threadName, const Id id = GetCurrentId());
00186
00187 protected:
00193     virtual StatusCode Process(void *pData) = 0;
00194
00195 private:
00196 #if (defined ACTIV_PLATFORM_WINDOWS)
00197     friend unsigned WINAPI ActivThreadGlobalThreadProc(void *pData);
00198 #elif (defined ACTIV_PLATFORM_POSIX)
00199     friend void *ActivThreadGlobalThreadProc(void *pData);
00200     friend void ActivThreadGlobalCleanupProc(void *pData);
00201 #else
00202 #error Configure for this platform
00203 #endif
00204
00205     void *                      m_pData;
00206     Id                          m_id;
00207
00208 #if (defined ACTIV_PLATFORM_WINDOWS)
00209     HANDLE                      m_handle;
00210 #elif (defined ACTIV_PLATFORM_POSIX)
00211     boost::shared_ptr<IEvent>   m_pEvent;
00212 #endif
00213 };
00214
00215 } // namespace Activ
00216
00217 #endif // (!defined ACTIV_BASE_THREAD_H)
Generated on Wed Oct 8 14:01:47 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

ThreadSpecificData.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_BASE_THREAD_SPECIFIC_DATA_H)
00010 #define ACTIV_BASE_THREAD_SPECIFIC_DATA_H
00011
00012 #include "ActivMiddleware/ActivBase/External.h"
00013 #include "ActivMiddleware/Misc/FunctionObjects.h"
00014
00015 namespace Activ
00016 {
00017
00047 template <typename TYPE, typename DERIVED>
00048 class ThreadSpecificDataBase : private boost::noncopyable
00049 {
00050 public:
00056     ThreadSpecificDataBase();
00057
00061     ~ThreadSpecificDataBase();
00062
00068     TYPE *Get() const;
00069
00075     void Set(TYPE * const pValue);
00076
00084     void OnThreadExit(TYPE * const pValue);
00085
00086 private:
00092     class PerThreadInfo
00093     {
00094     public:
00095         PerThreadInfo(ThreadSpecificDataBase<TYPE, DERIVED> &threadSpecificData) :
00096             m_threadSpecificData(threadSpecificData),
00097             m_pValue(0)
00098         {
00099         }
00100
00101         ThreadSpecificDataBase<TYPE, DERIVED> & m_threadSpecificData;
00102         TYPE *                                  m_pValue;
00103     };
00104
00105     static void StaticDestructor(void *pData);
00106
00107 #if (defined ACTIV_PLATFORM_WINDOWS)
00108
00109     const DWORD     m_index;
00110
00111 #elif (defined ACTIV_PLATFORM_POSIX)
00112
00113     pthread_key_t   m_key;
00114
00115 #else
00116 #error Configure for this platform
00117 #endif
00118 };
00119
00120 // ---------------------------------------------------------------------------------------------------------------------------------
00121 // ---------------------------------------------------------------------------------------------------------------------------------
00122
00140 template <typename TYPE, typename CLEANUP>
00141 class ThreadSpecificData : public ThreadSpecificDataBase<TYPE, ACTIV_TEMPLATE_SELF ThreadSpecificData<TYPE, CLEANUP> >
00142 {
00143 public:
00144     void OnThreadExit(TYPE * const pValue)
00145     {
00146         CLEANUP()(pValue);
00147     }
00148 };
00149
00150 } // namespace Activ
00151
00152 #include "ActivMiddleware/ActivBase/Detail/ThreadSpecificDataDetail.h"
00153
00154 #endif // (!defined ACTIV_BASE_THREAD_SPECIFIC_DATA_H)
Generated on Wed Oct 8 14:01:47 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase » Detail

ThreadSpecificDataDetail.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_BASE_DETAIL_THREAD_SPECIFIC_DATA_DETAIL_H)
00010 #define ACTIV_BASE_DETAIL_THREAD_SPECIFIC_DATA_DETAIL_H
00011
00012 #include "ActivMiddleware/ActivBase/OsException.h"
00013 #include "ActivMiddleware/ActivBase/StatusCodeException.h"
00014
00015 #if (defined ACTIV_PLATFORM_POSIX)
00016 #include <pthread.h>
00017 #endif
00018
00019 namespace Activ
00020 {
00021
00022 #if (defined ACTIV_PLATFORM_WINDOWS)
00023
00024 typedef void (*TsdDestructorFn)(void *);
00025
00026 ACTIV_BASE_EXPORTED_API void ThreadSpecificDataCleanupAddKey(const DWORD key, TsdDestructorFn pTsdDestructorFn);
00027 ACTIV_BASE_EXPORTED_API void ThreadSpecificDataCleanupRemoveKey(const DWORD key);
00028
00029 // ---------------------------------------------------------------------------------------------------------------------------------
00030
00031 template <typename TYPE, typename DERIVED>
00032 inline ThreadSpecificDataBase<TYPE, DERIVED>::ThreadSpecificDataBase() :
00033     m_index(::TlsAlloc())
00034 {
00035     if (TLS_OUT_OF_INDEXES == m_index)
00036         ACTIV_THROW(OsException, ::GetLastError());
00037
00038     ThreadSpecificDataCleanupAddKey(m_index, &StaticDestructor);
00039 }
00040
00041 // ---------------------------------------------------------------------------------------------------------------------------------
00042
00043 template <typename TYPE, typename DERIVED>
00044 inline ThreadSpecificDataBase<TYPE, DERIVED>::~ThreadSpecificDataBase()
00045 {
00046     void * const pData = ::TlsGetValue(m_index);
00047
00048     if (0 != pData)
00049         StaticDestructor(pData);
00050
00051     ThreadSpecificDataCleanupRemoveKey(m_index);
00052     (void) ::TlsFree(m_index);
00053 }
00054
00055 // ---------------------------------------------------------------------------------------------------------------------------------
00056
00057 template <typename TYPE, typename DERIVED>
00058 inline TYPE *ThreadSpecificDataBase<TYPE, DERIVED>::Get() const
00059 {
00060     PerThreadInfo * const pPerThreadInfo = reinterpret_cast<PerThreadInfo *>(::TlsGetValue(m_index));
00061
00062     if (ACTIV_UNLIKELY(0 == pPerThreadInfo))
00063         return 0;
00064
00065     return pPerThreadInfo->m_pValue;
00066 }
00067
00068 // ---------------------------------------------------------------------------------------------------------------------------------
00069
00070 template <typename TYPE, typename DERIVED>
00071 inline void ThreadSpecificDataBase<TYPE, DERIVED>::Set(TYPE * const pValue)
00072 {
00073     PerThreadInfo *pPerThreadInfo = reinterpret_cast<PerThreadInfo *>(::TlsGetValue(m_index));
00074
00075     if (0 == pPerThreadInfo)
00076     {
00077         pPerThreadInfo = new PerThreadInfo(*this);
00078         (void) ::TlsSetValue(m_index, reinterpret_cast<void *>(pPerThreadInfo));
00079     }
00080
00081     pPerThreadInfo->m_pValue = pValue;
00082 }
00083
00084 // ---------------------------------------------------------------------------------------------------------------------------------
00085
00086 #elif (defined ACTIV_PLATFORM_POSIX)
00087
00088 template <typename TYPE, typename DERIVED>
00089 inline ThreadSpecificDataBase<TYPE, DERIVED>::ThreadSpecificDataBase()
00090 {
00091     int res = ::pthread_key_create(&m_key, &StaticDestructor);
00092
00093     if (0 != res)
00094         ACTIV_THROW(OsException, res);
00095 }
00096
00097 // ---------------------------------------------------------------------------------------------------------------------------------
00098
00099 template <typename TYPE, typename DERIVED>
00100 inline ThreadSpecificDataBase<TYPE, DERIVED>::~ThreadSpecificDataBase()
00101 {
00102     void * const pData = ::pthread_getspecific(m_key);
00103
00104     if (0 != pData)
00105         StaticDestructor(pData);
00106
00107     (void) ::pthread_key_delete(m_key);
00108 }
00109
00110 // ---------------------------------------------------------------------------------------------------------------------------------
00111
00112 template <typename TYPE, typename DERIVED>
00113 inline TYPE *ThreadSpecificDataBase<TYPE, DERIVED>::Get() const
00114 {
00115     PerThreadInfo * const pPerThreadInfo = reinterpret_cast<PerThreadInfo *>(::pthread_getspecific(m_key));
00116
00117     if (ACTIV_UNLIKELY(0 == pPerThreadInfo))
00118         return 0;
00119
00120     return pPerThreadInfo->m_pValue;
00121 }
00122
00123 // ---------------------------------------------------------------------------------------------------------------------------------
00124
00125 template <typename TYPE, typename DERIVED>
00126 inline void ThreadSpecificDataBase<TYPE, DERIVED>::Set(TYPE * const pValue)
00127 {
00128     PerThreadInfo *pPerThreadInfo = reinterpret_cast<PerThreadInfo *>(::pthread_getspecific(m_key));
00129
00130     if (0 == pPerThreadInfo)
00131     {
00132         pPerThreadInfo = new PerThreadInfo(*this);
00133         (void) ::pthread_setspecific(m_key, reinterpret_cast<void *>(pPerThreadInfo));
00134     }
00135
00136     pPerThreadInfo->m_pValue = pValue;
00137 }
00138
00139 // ---------------------------------------------------------------------------------------------------------------------------------
00140
00141 #else
00142 #error Configure for this platform
00143 #endif
00144
00145 // ---------------------------------------------------------------------------------------------------------------------------------
00146
00147 template <typename TYPE, typename DERIVED>
00148 void ThreadSpecificDataBase<TYPE, DERIVED>::StaticDestructor(void *pData)
00149 {
00150     if (0 != pData)
00151     {
00152         PerThreadInfo * const pPerThreadInfo = reinterpret_cast<PerThreadInfo *>(pData);
00153         DERIVED &derived = static_cast<DERIVED &>(pPerThreadInfo->m_threadSpecificData);
00154
00155         if (0 != pPerThreadInfo->m_pValue)
00156             derived.OnThreadExit(pPerThreadInfo->m_pValue);
00157
00158         delete pPerThreadInfo;
00159     }
00160 }
00161
00162 } // namespace Activ
00163
00164 #endif // (!defined ACTIV_BASE_DETAIL_THREAD_SPECIFIC_DATA_DETAIL_H)
Generated on Wed Oct 8 14:01:47 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

ThreadSpecificPoolAllocators.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_THREAD_SPECIFIC_POOL_ALLOCATORS_H)
00010 #define ACTIV_THREAD_SPECIFIC_POOL_ALLOCATORS_H
00011
00012 #include "ActivMiddleware/ActivBase/ThreadSpecificData.h"
00013 #include "ActivMiddleware/Misc/Singleton.h"
00014
00015 #include "boost/pool/poolfwd.hpp"
00016 #include "boost/pool/pool.hpp"
00017
00018 namespace Activ
00019 {
00020
00029 template <typename T, typename UserAllocator = boost::default_user_allocator_new_delete, unsigned NextSize = 32>
00030 class ThreadSpecificPoolAllocator
00031 {
00032 public:
00033     typedef T value_type;
00034     typedef UserAllocator user_allocator;
00035
00036     static const unsigned next_size = NextSize;
00037
00038     typedef value_type * pointer;
00039     typedef const value_type * const_pointer;
00040     typedef value_type & reference;
00041     typedef const value_type & const_reference;
00042     typedef typename boost::pool<UserAllocator>::size_type size_type;
00043     typedef typename boost::pool<UserAllocator>::difference_type difference_type;
00044
00045     template <typename U>
00046     struct rebind
00047     {
00048         typedef ThreadSpecificPoolAllocator<U, UserAllocator, NextSize> other;
00049     };
00050
00051 public:
00052     ThreadSpecificPoolAllocator()
00053     {
00054     }
00055
00056     // default copy constructor
00057
00058     // default assignment operator
00059
00060     // not explicit, mimicking std::allocator [20.4.1]
00061     template <typename U>
00062     ThreadSpecificPoolAllocator(const ThreadSpecificPoolAllocator<U, UserAllocator, NextSize> &)
00063     {
00064     }
00065
00066     static pointer address(reference r)
00067     {
00068         return &r;
00069     }
00070
00071     static const_pointer address(const_reference s)
00072     {
00073         return &s;
00074     }
00075
00076     static size_type max_size()
00077     {
00078         return boost::integer_traits<size_type>::const_max;
00079     }
00080
00081     static void construct(const pointer ptr, const value_type &t)
00082     {
00083         new (ptr) T(t);
00084     }
00085
00086     static void destroy(const pointer ptr)
00087     {
00088         ptr->~T();
00089         (void) ptr; // avoid unused variable warning
00090     }
00091
00092     bool operator==(const ThreadSpecificPoolAllocator &) const
00093     {
00094         return true;
00095     }
00096
00097     bool operator!=(const ThreadSpecificPoolAllocator &) const
00098     {
00099         return false;
00100     }
00101
00102     static pointer allocate(const size_type n)
00103     {
00104         Pool *pPool = ThreadSingleton::GetInstance().m_threadInfo.Get();
00105
00106         if (ACTIV_UNLIKELY(0 == pPool))
00107             pPool = CreatePool();
00108
00109         const pointer ret = static_cast<pointer>(pPool->ordered_malloc(n));
00110
00111         if (ACTIV_UNLIKELY(0 == ret))
00112             throw std::bad_alloc();
00113
00114         return ret;
00115     }
00116
00117     static pointer allocate(const size_type n, const void * const)
00118     {
00119         return allocate(n);
00120     }
00121
00122     static void deallocate(const pointer ptr, const size_type n)
00123     {
00124         Pool *pPool = ThreadSingleton::GetInstance().m_threadInfo.Get();
00125
00126         // If there's no pool for this thread, then the memory can't have been allocated by this thread, either.
00127         if (ACTIV_UNLIKELY(0 == pPool))
00128         {
00129             assert(false);
00130             return;
00131         }
00132
00133         pPool->free(ptr, n);
00134     }
00135
00143     static bool ReleaseMemory()
00144     {
00145         Pool *pPool = ThreadSingleton::GetInstance().m_threadInfo.Get();
00146
00147         if (ACTIV_UNLIKELY(0 == pPool))
00148             return false;
00149
00150         return pPool->release_memory();
00151     }
00152
00153 private:
00154     typedef boost::pool<UserAllocator> Pool;
00155     typedef Activ::ThreadSpecificData<Pool, Activ::DeleteObject> ThreadInfo;
00156
00157     class ThreadSingleton : public Singleton<ThreadSingleton>
00158     {
00159     public:
00160         ThreadInfo  m_threadInfo;
00161
00162     private:
00163         friend class Singleton<ThreadSingleton>;
00164     };
00165
00166     static ACTIV_NEVER_INLINE Pool *CreatePool()
00167     {
00168         Pool * const pPool = new Pool(sizeof(T), NextSize);
00169
00170         ThreadSingleton::GetInstance().m_threadInfo.Set(pPool);
00171
00172         return pPool;
00173     }
00174 };
00175
00176 // ---------------------------------------------------------------------------------------------------------------------------------
00177
00187 template <typename T, typename UserAllocator = boost::default_user_allocator_new_delete, unsigned NextSize = 32>
00188 class ThreadSpecificFastPoolAllocator
00189 {
00190 public:
00191     typedef T value_type;
00192     typedef UserAllocator user_allocator;
00193
00194     static const unsigned next_size = NextSize;
00195
00196     typedef value_type * pointer;
00197     typedef const value_type * const_pointer;
00198     typedef value_type & reference;
00199     typedef const value_type & const_reference;
00200     typedef typename boost::pool<UserAllocator>::size_type size_type;
00201     typedef typename boost::pool<UserAllocator>::difference_type difference_type;
00202
00203     template <typename U>
00204     struct rebind
00205     {
00206         typedef ThreadSpecificFastPoolAllocator<U, UserAllocator, NextSize> other;
00207     };
00208
00209 public:
00210     ThreadSpecificFastPoolAllocator()
00211     {
00212     }
00213
00214     // default copy constructor
00215
00216     // default assignment operator
00217
00218     // not explicit, mimicking std::allocator [20.4.1]
00219     template <typename U>
00220     ThreadSpecificFastPoolAllocator(const ThreadSpecificFastPoolAllocator<U, UserAllocator, NextSize> &)
00221     {
00222     }
00223
00224     static pointer address(reference r)
00225     {
00226         return &r;
00227     }
00228
00229     static const_pointer address(const_reference s)
00230     {
00231         return &s;
00232     }
00233
00234     static size_type max_size()
00235     {
00236         return boost::integer_traits<size_type>::const_max;
00237     }
00238
00239     static void construct(const pointer ptr, const value_type &t)
00240     {
00241         new (ptr) T(t);
00242     }
00243
00244     static void destroy(const pointer ptr)
00245     {
00246         ptr->~T();
00247         (void) ptr; // avoid unused variable warning
00248     }
00249
00250     bool operator==(const ThreadSpecificFastPoolAllocator &) const
00251     {
00252         return true;
00253     }
00254
00255     bool operator!=(const ThreadSpecificFastPoolAllocator &) const
00256     {
00257         return false;
00258     }
00259
00260     static pointer allocate(const size_type n)
00261     {
00262         Pool *pPool = ThreadSingleton::GetInstance().m_threadInfo.Get();
00263
00264         if (ACTIV_UNLIKELY(0 == pPool))
00265             pPool = CreatePool();
00266
00267         const pointer ret = (1 == n) ?
00268             static_cast<pointer>(pPool->malloc()) :
00269             static_cast<pointer>(pPool->ordered_malloc(n));
00270
00271         if (ACTIV_UNLIKELY(0 == ret))
00272             throw std::bad_alloc();
00273
00274         return ret;
00275     }
00276
00277     static pointer allocate(const size_type n, const void * const)
00278     {
00279         return allocate(n);
00280     }
00281
00282     static pointer allocate()
00283     {
00284         Pool *pPool = ThreadSingleton::GetInstance().m_threadInfo.Get();
00285
00286         if (ACTIV_UNLIKELY(0 == pPool))
00287             pPool = CreatePool();
00288
00289         const pointer ret = static_cast<pointer>(pPool->malloc());
00290
00291         if (ACTIV_UNLIKELY(0 == ret))
00292             throw std::bad_alloc();
00293
00294         return ret;
00295     }
00296
00297     static void deallocate(const pointer ptr, const size_type n)
00298     {
00299         Pool *pPool = ThreadSingleton::GetInstance().m_threadInfo.Get();
00300
00301         // If there's no pool for this thread, then the memory can't have been allocated by this thread, either.
00302         if (ACTIV_UNLIKELY(0 == pPool))
00303         {
00304             assert(false);
00305             return;
00306         }
00307
00308         if (1 == n)
00309             pPool->free(ptr);
00310         else
00311             pPool->free(ptr, n);
00312     }
00313
00314     static void deallocate(const pointer ptr)
00315     {
00316         Pool *pPool = ThreadSingleton::GetInstance().m_threadInfo.Get();
00317
00318         // If there's no pool for this thread, then the memory can't have been allocated by this thread, either.
00319         if (ACTIV_UNLIKELY(0 == pPool))
00320         {
00321             assert(false);
00322             return;
00323         }
00324
00325         return pPool->deallocate(ptr);
00326     }
00327
00328 private:
00329     typedef boost::pool<UserAllocator> Pool;
00330     typedef Activ::ThreadSpecificData<Pool, Activ::DeleteObject> ThreadInfo;
00331
00332     class ThreadSingleton : public Singleton<ThreadSingleton>
00333     {
00334     public:
00335         ThreadInfo  m_threadInfo;
00336
00337     private:
00338         friend class Singleton<ThreadSingleton>;
00339     };
00340
00341     static ACTIV_NEVER_INLINE Pool *CreatePool()
00342     {
00343         Pool * const pPool = new Pool(sizeof(T), NextSize);
00344
00345         ThreadSingleton::GetInstance().m_threadInfo.Set(pPool);
00346
00347         return pPool;
00348     }
00349 };
00350
00351 } // namespace Activ
00352
00353 #endif // (!defined ACTIV_THREAD_SPECIFIC_POOL_ALLOCATORS_H)
Generated on Wed Oct 8 14:01:47 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivContentGatewayApiCommon

Tick.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_CONTENT_GATEWAY_API_COMMON_TICK_H)
00010 #define ACTIV_CONTENT_GATEWAY_API_COMMON_TICK_H
00011
00012 #include "ActivContentPlatform/ActivContentGatewayApiCommon/External.h"
00013 #include "ActivContentPlatform/ActivContentGatewayApiCommon/FieldSet.h"
00014
00015 #include "ActivMiddleware/ActivFieldTypes/BinaryString.h"
00016 #include "ActivMiddleware/ActivFieldTypes/Date.h"
00017 #include "ActivMiddleware/ActivFieldTypes/Time.h"
00018 #include "ActivMiddleware/ActivFieldTypes/Rational.h"
00019 #include "ActivMiddleware/ActivFieldTypes/TRational.h"
00020 #include "ActivMiddleware/ActivFieldTypes/UInt.h"
00021
00022 #include "ActivContentPlatform/ActivFeedCommon/UpdateIds.h"
00023
00024 namespace Activ
00025 {
00026
00027 namespace ContentPlatform
00028 {
00029
00030 namespace TimeSeries
00031 {
00032     class TickBlockHelper;
00033 };
00034
00035 namespace ContentGatewayApi
00036 {
00037
00038 #define ACTIV_DECLARE_BYTES(value, id)  static const byte_t id = value;
00039
00043 #define TICK_TYPE_LIST(d)                                       \
00044     d(  TICK_TYPE_NONE,             "None"                  )   \
00045     d(  TICK_TYPE_TRADE,            "Trade"                 )   \
00046     d(  TICK_TYPE_CORRECTED_TRADE,  "Corrected Trade"       )   \
00047     d(  TICK_TYPE_DELETED_TRADE,    "Deleted Trade"         )   \
00048     d(  TICK_TYPE_FORM_T_TRADE,     "Form T Trade"          )   \
00049     d(  TICK_TYPE_FILTERED_TRADE,   "Filtered Trade"        )   \
00050     d(  TICK_TYPE_BID,              "Bid"                   )   \
00051     d(  TICK_TYPE_ASK,              "Ask"                   )   \
00052     d(  TICK_TYPE_QUOTE,            "not used"              )   \
00053     d(  TICK_TYPE_RESERVED2,        "not used"              )   \
00054     d(  TICK_TYPE_TRADE_INFO,       "Detailed trade info"   )
00055
00056 // ---------------------------------------------------------------------------------------------------------------------------------
00057
00058 enum TickType
00059 {
00060     TICK_TYPE_LIST(ACTIV_DECLARE_ELEMENT_1_WITH_COMMA)
00061     NUM_TICK_TYPES
00062 };
00063
00064 // ---------------------------------------------------------------------------------------------------------------------------------
00065 // ---------------------------------------------------------------------------------------------------------------------------------
00066
00070 class Tick : public FieldSet
00071 {
00072 public:
00073
00074     static const size_t CONDITION_LENGTH = 4; //max trade condition legth
00075     static const size_t TRADER_ID_LENGTH = 4; //max TRADER id legth
00076
00080     ACTIV_CONTENT_GATEWAY_API_COMMON_API Tick();
00081
00085     ACTIV_CONTENT_GATEWAY_API_COMMON_API virtual ~Tick();
00086
00090     ACTIV_CONTENT_GATEWAY_API_COMMON_API virtual void Reset();
00091
00102     ACTIV_CONTENT_GATEWAY_API_COMMON_API virtual StatusCode GetField(const Feed::FieldId fieldId, IFieldType &field) const;
00103
00114     ACTIV_CONTENT_GATEWAY_API_COMMON_API virtual StatusCode SetField(const Feed::FieldId fieldId, const IFieldType &field);
00115
00121     ACTIV_CONTENT_GATEWAY_API_COMMON_API virtual FieldSetType GetType() const;
00122
00128     ACTIV_CONTENT_GATEWAY_API_COMMON_API virtual std::string ToString(const std::string &deliminator = DEFAULT_STRING_FIELD_SEPARATER) const;
00129
00135     ACTIV_CONTENT_GATEWAY_API_COMMON_API virtual std::string ToShortString(const std::string &deliminator = DEFAULT_STRING_FIELD_SEPARATER) const;
00136
00144     ACTIV_CONTENT_GATEWAY_API_COMMON_API virtual StatusCode FromString(const std::string &inputStr, const std::string &deliminator = DEFAULT_STRING_FIELD_SEPARATER);
00145
00154     ACTIV_CONTENT_GATEWAY_API_COMMON_API virtual StatusCode Serialize(MessageBuilder &messageBuilder) const;
00155
00164     ACTIV_CONTENT_GATEWAY_API_COMMON_API virtual StatusCode Deserialize(MessageValidator &messageValidator);
00165
00171     ACTIV_CONTENT_GATEWAY_API_COMMON_API virtual size_t GetSerializedLength() const;
00172
00178     ACTIV_CONTENT_GATEWAY_API_COMMON_API static size_t GetMaxSerializedLength();
00179
00187     virtual bool Compare(const Tick &rhs) const;
00188
00196     virtual bool CompareContentOnly(const Tick &rhs) const;
00197
00206     virtual StatusCode Compare(const DateTime &dateTime, int &result) const;
00207
00217     virtual StatusCode Compare(const Tick &rhs, int &result) const;
00218
00226     bool operator==(const Tick &rhs) const;
00227
00235     bool operator!=(const Tick &rhs) const;
00236
00244     bool operator<(const Tick &rhs) const;
00245
00253     virtual bool operator<=(const Tick &rhs) const;
00254
00262     bool operator>(const Tick &rhs) const;
00263
00271     bool operator>=(const Tick &rhs) const;
00272
00280     bool operator <(const DateTime &dateTime) const;
00281     bool operator <=(const DateTime &dateTime) const;
00282
00290     bool operator ==(const DateTime &dateTime) const;
00291
00299     bool operator >=(const DateTime &dateTime) const;
00300     bool operator >(const DateTime &dateTime) const;
00301
00312     StatusCode GetConditions(byte_t *pConditions, const size_t conditionsLength, size_t &conditionsSize) const;
00313
00323     StatusCode SetConditions(const byte_t *pConditions, const size_t conditionsLength);
00324
00333     StatusCode SetConditions(const IFieldType &field);
00334
00343     StatusCode GetPrice(double &price) const;
00344
00350     StatusCode GetPrice(Rational &price) const;
00351
00360     StatusCode SetPrice(const Rational &price);
00361
00370     StatusCode SetPrice(const IFieldType &field);
00371
00380     StatusCode GetExchange(std::string &exchange) const;
00381
00387     const std::string & GetExchange() const;
00388
00397     StatusCode SetExchange(const std::string &exchange);
00398
00404     TickType GetTickType() const;
00405
00414     StatusCode SetTickType(const TickType type);
00415
00424     StatusCode GetDateTime(DateTime &dateTime) const;
00425
00434     StatusCode SetDateTime(const DateTime &dateTime);
00435
00445     StatusCode SetDateTime(const Date &date, const Time &time);
00446
00455     StatusCode SetDate(const Date &date);
00456
00465     StatusCode SetTime(const Time &time);
00466
00475     StatusCode GetSize(Rational &size) const;
00476
00485     StatusCode SetSize(const Rational &size);
00486
00495     StatusCode SetSize(const IFieldType &field);
00496
00505     StatusCode GetSize(uint32_t &size) const;
00506
00515     StatusCode SetSize(const uint32_t size);
00516
00525     StatusCode GetUpdateId(Feed::UpdateId &updateId) const;
00526
00531     Feed::UpdateId GetUpdateId() const;
00532
00541     StatusCode SetUpdateId(const Feed::UpdateId updateId);
00542
00553     ACTIV_CONTENT_GATEWAY_API_COMMON_API StatusCode GetBuyerId(char *pBuyerId, const size_t idMaxLength, size_t &actualSize) const;
00554
00564     ACTIV_CONTENT_GATEWAY_API_COMMON_API StatusCode SetBuyerId(const char *pBuyerId, const size_t idLength);
00565
00574     ACTIV_CONTENT_GATEWAY_API_COMMON_API StatusCode SetBuyerId(const IFieldType &field);
00575
00586     ACTIV_CONTENT_GATEWAY_API_COMMON_API StatusCode GetSellerId(char *pSellerId, const size_t idMaxLength, size_t &actualSize) const;
00587
00597     ACTIV_CONTENT_GATEWAY_API_COMMON_API StatusCode SetSellerId(const char *pSellerId, const size_t idLength);
00598
00604     ACTIV_CONTENT_GATEWAY_API_COMMON_API char GetTradeThroughExemptFlag() const;
00605
00613     ACTIV_CONTENT_GATEWAY_API_COMMON_API StatusCode SetTradeThroughExemptFlag(const char flag);
00614
00623     ACTIV_CONTENT_GATEWAY_API_COMMON_API StatusCode SetSellerId(const IFieldType &field);
00624
00630     bool IsRegularHourTrade() const;
00631
00637     bool IsTrade() const;
00638
00644     bool IsOutOfSequence() const;
00645
00651     void SetOutOfSequence();
00652
00662     ACTIV_CONTENT_GATEWAY_API_COMMON_API StatusCode ProcessSplit(const int sharesBefore, const int sharesAfter, const Rational::Denominator type);
00663
00664 public:
00665     #define ACTIV_TICK_MASK_LIST(d)                                                                                     \
00666         d(0x0F, TICK_TYPE_MASK)                 \
00667         d(0x70, TICK_CONDITION_LENGTH_MASK)                             \
00668         d(0x80, TICK_OPTIONAL_DATA_BIT)         \
00669         d(0x80, TICK_OUT_SEQUENCE_MASK)                                         \
00670         d(0x40, TICK_KNOWN_EXCHANGE_BIT)        \
00671         d(0x20, TICK_SIZE_BYTE2)            \
00672         d(0x1F, TICK_DAY_MASK)                 \
00673         d(0x01, OPTIONAL_DATA_HAS_BUYER_ID)                 \
00674         d(0x02, OPTIONAL_DATA_HAS_SELLER_ID)                \
00675         d(0x04, OPTIONAL_DATA_HAS_TRADE_EXEPTION_FLAG)      \
00676         d(0x80, OPTIONAL_DATA_HAS_OTHER_LENGTH)         \
00677         d(0x02, QUOTE_SAME_EXCHANGE_BIT)    \
00678         d(0x04, QUOTE_SAME_CONDITION)           \
00679         d(0x08, QUOTE_NO_CONDITION)                                             \
00680         d(0x10, TICK_SIZE_BYTE1)
00681 //note 0x20 (TICK_SIZE_BYTE2) and 0x40(TICK_KNOWN_EXCHANGE_BIT) and 0x80 (OPTIONAL_DATA_HAS_OTHER_LENGTH) are used
00682
00683     ACTIV_TICK_MASK_LIST(ACTIV_DECLARE_BYTES)
00684
00685 protected:
00686     byte_t                 m_conditions[CONDITION_LENGTH];
00687     DateTime               m_dateTime;
00688     Rational               m_price;
00689     Rational               m_size;
00690     std::string            m_exchange;
00691     TickType               m_tickType;
00692     Feed::UpdateId         m_updateId;
00693     bool                   m_outSequence;
00694     char                   m_buyerId[TRADER_ID_LENGTH];
00695     char                   m_sellerId[TRADER_ID_LENGTH];
00696     char                   m_tradeThroughExemptFlag;
00697
00698     friend class TimeSeries::TickBlockHelper;
00699 };
00700
00701 typedef FieldSetList<Tick, uint16_t> TickList;
00702
00703 // ---------------------------------------------------------------------------------------------------------------------------------
00704
00705 inline bool Tick::operator==(const Tick &rhs) const
00706 {
00707     return m_dateTime == rhs.m_dateTime;
00708 }
00709
00710 // ---------------------------------------------------------------------------------------------------------------------------------
00711
00712 inline bool Tick::operator!=(const Tick &rhs) const
00713 {
00714     return m_dateTime != rhs.m_dateTime;
00715 }
00716
00717 // ---------------------------------------------------------------------------------------------------------------------------------
00718
00719 inline bool Tick::operator<(const Tick &rhs) const
00720 {
00721     return m_dateTime < rhs.m_dateTime;
00722 }
00723
00724 // ---------------------------------------------------------------------------------------------------------------------------------
00725
00726 inline bool Tick::operator<=(const Tick &rhs) const
00727 {
00728     return m_dateTime <= rhs.m_dateTime;
00729 }
00730
00731 // ---------------------------------------------------------------------------------------------------------------------------------
00732
00733 inline bool Tick::operator>(const Tick &rhs) const
00734 {
00735     return m_dateTime > rhs.m_dateTime;
00736 }
00737
00738 // ---------------------------------------------------------------------------------------------------------------------------------
00739
00740 inline bool Tick::operator>=(const Tick &rhs) const
00741 {
00742     return (m_dateTime >= rhs.m_dateTime);
00743 }
00744
00745 // ---------------------------------------------------------------------------------------------------------------------------------
00746
00747 inline StatusCode Tick::Compare(const DateTime &dateTime, int &result) const
00748 {
00749     return m_dateTime.Compare(dateTime, result);
00750 }
00751
00752 // ---------------------------------------------------------------------------------------------------------------------------------
00753
00754 inline StatusCode Tick::Compare(const Tick &rhs, int &result) const
00755 {
00756     return m_dateTime.Compare(rhs.m_dateTime, result);
00757 }
00758
00759 // ---------------------------------------------------------------------------------------------------------------------------------
00760
00761 inline bool Tick::Compare(const Tick &rhs) const
00762 {
00763     return m_dateTime.GetTime().Get() == rhs.m_dateTime.GetTime().Get()
00764         && m_dateTime.GetDate() == rhs.m_dateTime.GetDate()
00765         && CompareContentOnly(rhs);
00766 }
00767
00768 // ---------------------------------------------------------------------------------------------------------------------------------
00769
00770 inline bool Tick::CompareContentOnly(const Tick &rhs) const
00771 {
00772     if (m_price != rhs.m_price
00773         || m_size != rhs.m_size
00774         || m_exchange != rhs.m_exchange)
00775         return false;
00776     return true;
00777 }
00778
00779 // ---------------------------------------------------------------------------------------------------------------------------------
00780
00781 inline bool Tick::operator<(const DateTime &dateTime) const
00782 {
00783     return m_dateTime < dateTime;
00784 }
00785
00786 // ---------------------------------------------------------------------------------------------------------------------------------
00787
00788 inline bool Tick::operator<=(const DateTime &dateTime) const
00789 {
00790     return m_dateTime <= dateTime;
00791 }
00792
00793 // ---------------------------------------------------------------------------------------------------------------------------------
00794
00795 inline  bool Tick::operator ==(const DateTime &dateTime) const
00796 {
00797     return m_dateTime == dateTime;
00798 }
00799
00800 // ---------------------------------------------------------------------------------------------------------------------------------
00801
00802 inline bool Tick::operator >(const DateTime &dateTime) const
00803 {
00804     return m_dateTime > dateTime;
00805 }
00806
00807 // ---------------------------------------------------------------------------------------------------------------------------------
00808
00809 inline bool Tick::operator >=(const DateTime &dateTime) const
00810 {
00811     return m_dateTime >= dateTime;
00812 }
00813
00814 // ---------------------------------------------------------------------------------------------------------------------------------
00815
00816 inline StatusCode Tick::GetConditions(byte_t *pConditions, const size_t conditionsLength, size_t &conditionsSize) const
00817 {
00818     if (conditionsLength < CONDITION_LENGTH)
00819         return STATUS_CODE_INVALID_LENGTH;
00820
00821     ::memcpy(pConditions, m_conditions, CONDITION_LENGTH);
00822     conditionsSize = CONDITION_LENGTH;
00823     return STATUS_CODE_SUCCESS;
00824 }
00825
00826 // ---------------------------------------------------------------------------------------------------------------------------------
00827
00828 inline StatusCode Tick::SetConditions(const byte_t *pConditions, const size_t conditionsLength)
00829 {
00830     if (conditionsLength > CONDITION_LENGTH)
00831         return STATUS_CODE_INVALID_LENGTH;
00832
00833     ::memset(m_conditions, 0, CONDITION_LENGTH);
00834     ::memcpy(m_conditions, pConditions, conditionsLength);
00835     return STATUS_CODE_SUCCESS;
00836 }
00837
00838 // ---------------------------------------------------------------------------------------------------------------------------------
00839
00840 inline StatusCode Tick::SetConditions(const IFieldType &field)
00841 {
00842     if (FIELD_TYPE_BINARY_STRING != field.GetType())
00843         return STATUS_CODE_INVALID_FIELD_TYPE;
00844
00845     const byte_t  *pData;
00846     size_t        size;
00847
00848     static_cast<const BinaryString&>(field).Get(pData, size);
00849     return SetConditions(pData, size);
00850 }
00851
00852 // ---------------------------------------------------------------------------------------------------------------------------------
00853
00854 inline StatusCode Tick::GetPrice(Rational &price) const
00855 {
00856     price = m_price;
00857     return STATUS_CODE_SUCCESS;
00858 }
00859
00860 // ---------------------------------------------------------------------------------------------------------------------------------
00861
00862 inline StatusCode Tick::GetPrice(double &price) const
00863 {
00864     return m_price.GetDouble(price);
00865 }
00866
00867 // ---------------------------------------------------------------------------------------------------------------------------------
00868
00869 inline StatusCode Tick::SetPrice(const Rational &price)
00870 {
00871     m_price = price;
00872     return STATUS_CODE_SUCCESS;
00873 }
00874
00875 // ---------------------------------------------------------------------------------------------------------------------------------
00876
00877 inline  StatusCode Tick::SetPrice(const IFieldType &field)
00878 {
00879     if (FIELD_TYPE_TRATIONAL == field.GetType())
00880         return SetPrice(static_cast<const TRational&>(field).GetRational());
00881     else if (FIELD_TYPE_RATIONAL == field.GetType())
00882         return SetPrice(static_cast<const Rational&>(field));
00883     else
00884         return STATUS_CODE_INVALID_FIELD_TYPE;
00885 }
00886
00887 // ---------------------------------------------------------------------------------------------------------------------------------
00888
00889 inline StatusCode Tick::GetExchange(std::string &exchange) const
00890 {
00891     exchange = m_exchange;
00892     return STATUS_CODE_SUCCESS;
00893 }
00894
00895 // ---------------------------------------------------------------------------------------------------------------------------------
00896
00897 inline const std::string & Tick::GetExchange() const
00898 {
00899     return m_exchange;
00900 }
00901
00902 // ---------------------------------------------------------------------------------------------------------------------------------
00903
00904 inline StatusCode Tick::SetExchange(const std::string &exchange)
00905 {
00906     m_exchange = exchange;
00907     return STATUS_CODE_SUCCESS;
00908 }
00909
00910 // ---------------------------------------------------------------------------------------------------------------------------------
00911
00912 inline TickType Tick::GetTickType() const
00913 {
00914     return m_tickType;
00915 }
00916
00917 // ---------------------------------------------------------------------------------------------------------------------------------
00918
00919 inline StatusCode Tick::SetTickType(const TickType type)
00920 {
00921     m_tickType = type;
00922     return STATUS_CODE_SUCCESS;
00923 }
00924
00925 // ---------------------------------------------------------------------------------------------------------------------------------
00926
00927 inline StatusCode Tick::GetDateTime(DateTime &dateTime) const
00928 {
00929     dateTime = m_dateTime;
00930     return STATUS_CODE_SUCCESS;
00931 }
00932
00933 // ---------------------------------------------------------------------------------------------------------------------------------
00934
00935 inline StatusCode Tick::SetDateTime(const DateTime &dateTime)
00936 {
00937     m_dateTime = dateTime;
00938     return STATUS_CODE_SUCCESS;
00939 }
00940
00941 // ---------------------------------------------------------------------------------------------------------------------------------
00942
00943 inline StatusCode Tick::SetDateTime(const Date &date, const Time &time)
00944 {
00945     return m_dateTime.Set(date,time);
00946 }
00947
00948 // ---------------------------------------------------------------------------------------------------------------------------------
00949
00950 inline StatusCode Tick::SetDate(const Date &date)
00951 {
00952     return m_dateTime.Set(date, m_dateTime.GetTime());
00953 }
00954
00955 // ---------------------------------------------------------------------------------------------------------------------------------
00956
00957 inline StatusCode Tick::SetTime(const Time &time)
00958 {
00959     return m_dateTime.Set(m_dateTime.GetDate(), time);
00960 }
00961
00962 // ---------------------------------------------------------------------------------------------------------------------------------
00963
00964 inline StatusCode Tick::GetSize(Rational &size) const
00965 {
00966     size = m_size;
00967     return STATUS_CODE_SUCCESS;
00968 }
00969
00970 // ---------------------------------------------------------------------------------------------------------------------------------
00971
00972 inline StatusCode Tick::SetSize(const Rational &size)
00973 {
00974     m_size = size;
00975     return STATUS_CODE_SUCCESS;
00976 }
00977
00978 // ---------------------------------------------------------------------------------------------------------------------------------
00979
00980 inline StatusCode Tick::SetSize(const IFieldType &field)
00981 {
00982     if (FIELD_TYPE_UINT == field.GetType())
00983         return SetSize((uint32_t) static_cast<const UInt&>(field).Get());
00984     else if (FIELD_TYPE_RATIONAL == field.GetType())
00985         return SetSize(static_cast<const Rational&>(field));
00986     return STATUS_CODE_INVALID_FIELD_TYPE;
00987 }
00988
00989 // ---------------------------------------------------------------------------------------------------------------------------------
00990
00991 inline StatusCode Tick::GetSize(uint32_t &size) const
00992 {
00993     if(Rational::DENOMINATOR_WHOLE == m_size.GetDenominator())
00994         size = static_cast<uint32_t>(m_size.GetNumerator());
00995     else
00996     {
00997         double dSize;
00998         ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, m_size.GetDouble(dSize));
00999         size = static_cast<uint32_t>(dSize);
01000     }
01001     return STATUS_CODE_SUCCESS;
01002 }
01003
01004 // ---------------------------------------------------------------------------------------------------------------------------------
01005
01006 inline StatusCode Tick::SetSize(const uint32_t size)
01007 {
01008     return m_size.Set(size, Rational::DENOMINATOR_WHOLE);
01009 }
01010
01011 // ---------------------------------------------------------------------------------------------------------------------------------
01012
01013 inline StatusCode Tick::GetUpdateId(Feed::UpdateId &updateId) const
01014 {
01015     updateId = m_updateId;
01016     return STATUS_CODE_SUCCESS;
01017 }
01018
01019 // ---------------------------------------------------------------------------------------------------------------------------------
01020
01021 inline Feed::UpdateId Tick::GetUpdateId() const
01022 {
01023     return m_updateId;
01024 }
01025
01026 // ---------------------------------------------------------------------------------------------------------------------------------
01027
01028 inline StatusCode Tick::SetUpdateId(const Feed::UpdateId updateId)
01029 {
01030     m_updateId = updateId;
01031     return STATUS_CODE_SUCCESS;
01032 }
01033
01034 // ---------------------------------------------------------------------------------------------------------------------------------
01035
01036 inline bool Tick::IsRegularHourTrade() const
01037 {
01038     return m_tickType == TICK_TYPE_TRADE;
01039 }
01040
01041 // ---------------------------------------------------------------------------------------------------------------------------------
01042
01043 inline bool Tick::IsTrade() const
01044 {
01045     return m_tickType == TICK_TYPE_TRADE || m_tickType == TICK_TYPE_FORM_T_TRADE;
01046 }
01047
01048 // ---------------------------------------------------------------------------------------------------------------------------------
01049
01050 inline bool Tick::IsOutOfSequence() const
01051 {
01052     return m_outSequence;
01053 }
01054
01055 // ---------------------------------------------------------------------------------------------------------------------------------
01056
01057 inline void Tick::SetOutOfSequence()
01058 {
01059     m_outSequence = true;
01060 }
01061
01062 // ---------------------------------------------------------------------------------------------------------------------------------
01063
01064 inline size_t Tick::GetSerializedLength() const
01065 {
01066     // first the fixed length portion
01067     static size_t maxLength = GetMaxSerializedLength();
01068
01069     size_t length = maxLength;
01070     if(0 == m_buyerId[0])
01071         length -= 5;
01072
01073     if(0 == m_sellerId[0])
01074         length -= 5;
01075
01076     if(0 == m_tradeThroughExemptFlag)
01077         --length;
01078
01079     return length;
01080 }
01081
01082 #undef ACTIV_DECLARE_BYTES
01083
01084 } // namespace ContentGatewayApi
01085
01086 } // namespace ContentPlatform
01087
01088 } // namespace Activ
01089
01090 #endif // (!defined ACTIV_CONTENT_GATEWAY_API_COMMON_TICK_H)
Generated on Wed Oct 8 14:01:45 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivFieldTypes

Time.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FIELD_TYPES_TIME_H)
00010 #define ACTIV_FIELD_TYPES_TIME_H
00011
00012 #include "ActivMiddleware/ActivFieldTypes/External.h"
00013 #include "ActivMiddleware/ActivFieldTypes/IFieldType.h"
00014
00015 #include "ActivMiddleware/ActivBase/StatusCodeException.h"
00016
00017 #include <ctime>
00018
00019 namespace Activ
00020 {
00021
00022 class MessageBuilder;
00023 class MessageValidator;
00024
00025 // ---------------------------------------------------------------------------------------------------------------------------------
00026
00030 class Time : public IFieldType
00031 {
00032 public:
00033     static const FieldType FIELD_TYPE = FIELD_TYPE_TIME;
00034
00035     using IFieldType::FromString;
00036     using IFieldType::Serialize;
00037     using IFieldType::SerializeBody;
00038     using IFieldType::SerializeLengthAndBody;
00039     using IFieldType::Deserialize;
00040     using IFieldType::DeserializeBody;
00041     using IFieldType::DeserializeLengthAndBody;
00042
00046     class Hours
00047     {
00048     public:
00054         explicit Hours(const int32_t value);
00055
00056         static const uint32_t NUMBER_PER_DAY = 24;
00057
00058         const int32_t   m_value;
00059     };
00060
00064     class Minutes
00065     {
00066     public:
00072         explicit Minutes(const int32_t value);
00073
00074         static const uint32_t NUMBER_PER_HOUR = 60;
00075         static const uint32_t NUMBER_PER_DAY = NUMBER_PER_HOUR * Hours::NUMBER_PER_DAY;
00076
00077         const int32_t   m_value;
00078     };
00079
00083     class Seconds
00084     {
00085     public:
00091         explicit Seconds(const int32_t value);
00092
00093         static const uint32_t NUMBER_PER_MINUTE = 60;
00094         static const uint32_t NUMBER_PER_HOUR = NUMBER_PER_MINUTE * Minutes::NUMBER_PER_HOUR;
00095         static const uint32_t NUMBER_PER_DAY = NUMBER_PER_HOUR * Hours::NUMBER_PER_DAY;
00096
00097         const int32_t   m_value;
00098     };
00099
00103     class Milliseconds
00104     {
00105     public:
00111         explicit Milliseconds(const int32_t value);
00112
00113         static const uint32_t NUMBER_PER_SECOND = 1000;
00114         static const uint32_t NUMBER_PER_MINUTE = NUMBER_PER_SECOND * Seconds::NUMBER_PER_MINUTE;
00115         static const uint32_t NUMBER_PER_HOUR = NUMBER_PER_MINUTE * Minutes::NUMBER_PER_HOUR;
00116         static const uint32_t NUMBER_PER_DAY = NUMBER_PER_HOUR * Hours::NUMBER_PER_DAY;
00117
00118         const int32_t   m_value;
00119     };
00120
00124     Time();
00125
00136     Time(const uint32_t hour, const uint32_t minute, const uint32_t second, const uint32_t millisecond = 0);
00137
00146     explicit Time(const int32_t julianTime, const uint32_t millisecond = 0);
00147
00158     Time(const std::tm &tm, const uint32_t millisecond = 0);
00159
00163     virtual ~Time();
00164
00174     bool operator==(const Time &rhs) const;
00175
00185     bool operator!=(const Time &rhs) const;
00186
00196     bool operator<(const Time &rhs) const;
00197
00207     bool operator<=(const Time &rhs) const;
00208
00218     bool operator>(const Time &rhs) const;
00219
00229     bool operator>=(const Time &rhs) const;
00230
00240     template <typename T> const Time operator+(const T &rhs) const;
00241
00251     template <typename T> Time &operator+=(const T &rhs);
00252
00262     template <typename T> const Time operator-(const T &rhs) const;
00263
00273     template <typename T> Time &operator-=(const T &rhs);
00274
00286     StatusCode Set(const uint32_t hour, const uint32_t minute, const uint32_t second, const uint32_t millisecond = 0);
00287
00297     StatusCode Set(const int32_t julianTime, const uint32_t millisecond = 0);
00298
00310     StatusCode Set(const std::tm &tm, const uint32_t millisecond = 0);
00311
00319     int32_t Get() const;
00320
00331     StatusCode Get(uint32_t &hour, uint32_t &minute, uint32_t &second) const;
00332
00344     StatusCode Get(uint32_t &hour, uint32_t &minute, uint32_t &second, uint32_t &millisecond) const;
00345
00354     StatusCode Get(int32_t &julianTime) const;
00355
00365     StatusCode Get(int32_t &julianTime, uint32_t &millisecond) const;
00366
00377     StatusCode Get(std::tm &tm) const;
00378
00390     StatusCode Get(std::tm &tm, uint32_t &millisecond) const;
00391
00399     uint32_t GetHour() const;
00400
00408     uint32_t GetMinute() const;
00409
00417     uint32_t GetSecond() const;
00418
00426     uint32_t GetMillisecond() const;
00427
00435     uint32_t GetTotalMilliseconds() const;
00436
00446     Time GetUtc() const;
00447
00457     Time GetLocal() const;
00458
00468     StatusCode Add(const Time &rhs);
00469
00479     StatusCode Add(const Hours &hours);
00480
00490     StatusCode Add(const Minutes &minutes);
00491
00501     StatusCode Add(const Seconds &seconds);
00502
00512     StatusCode Add(const Milliseconds &milliseconds);
00513
00523     StatusCode Subtract(const Time &rhs);
00524
00534     StatusCode Subtract(const Hours &hours);
00535
00545     StatusCode Subtract(const Minutes &minutes);
00546
00556     StatusCode Subtract(const Seconds &seconds);
00557
00567     StatusCode Subtract(const Milliseconds &milliseconds);
00568
00569     virtual void Reset();
00570     virtual void Clear();
00571
00580     ACTIV_FIELD_TYPES_API StatusCode Compare(const Time &rhs, int &result) const;
00581
00582     ACTIV_FIELD_TYPES_API virtual StatusCode Compare(const void * const pRhsSerializedBody, const size_t rhsSerializedBodyLength, int &result) const;
00583     ACTIV_FIELD_TYPES_API virtual StatusCode Convert(const IFieldType * const pIFieldType);
00584     ACTIV_FIELD_TYPES_API virtual std::string ToString() const;
00585
00593     ACTIV_FIELD_TYPES_API std::string ToString(const bool shouldDisplayMilliseconds) const;
00594
00595     ACTIV_FIELD_TYPES_API virtual StatusCode FromString(MessageValidator &messageValidator);
00596     ACTIV_FIELD_TYPES_API virtual std::string GetFromStringFormat() const;
00597     ACTIV_FIELD_TYPES_API virtual StatusCode Serialize(MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength) const;
00598     ACTIV_FIELD_TYPES_API virtual StatusCode SerializeBody(void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength) const;
00599     ACTIV_FIELD_TYPES_API virtual StatusCode SerializeLengthAndBody(MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength = MAX_SERIALIZED_BODY_LENGTH_UNDEFINED) const;
00600     ACTIV_FIELD_TYPES_API virtual StatusCode Deserialize(MessageValidator &messageValidator, const size_t maxSerializedBodyLength);
00601     ACTIV_FIELD_TYPES_API virtual StatusCode DeserializeBody(const void * const pSerializedBody, const size_t serializedBodyLength);
00602     ACTIV_FIELD_TYPES_API virtual StatusCode DeserializeLengthAndBody(MessageValidator &messageValidator, const size_t maxSerializedBodyLength = MAX_SERIALIZED_BODY_LENGTH_UNDEFINED);
00603     virtual size_t GetSerializedLength() const;
00604     virtual size_t GetSerializedBodyLength() const;
00605     ACTIV_FIELD_TYPES_API virtual StatusCode IsDifferent(const void * const pRhsSerializedBody, const size_t rhsSerializedBodyLength, bool &isDifferent) const;
00606
00614     static size_t GetSerializedLength(const void * const pSerializedBody);
00615
00623     static size_t GetSerializedBodyLength(const void * const pSerializedBody);
00624
00632     static size_t GetMaxSerializedLength(const bool shouldSerializeMilliseconds);
00633
00641     static size_t GetMaxSerializedBodyLength(const bool shouldSerializeMilliseconds);
00642
00655     ACTIV_FIELD_TYPES_API static StatusCode Compare(const void * const pLhsSerializedBody, const size_t lhsSerializedBodyLength, const void * const pRhsSerializedBody, const size_t rhsSerializedBodyLength, int &result);
00656
00662     ACTIV_FIELD_TYPES_API static int32_t GetTimeZoneOffset();
00663
00671     ACTIV_FIELD_TYPES_API static Time CreateUtcTime(const bool shouldSetMilliseconds = false);
00672
00680     ACTIV_FIELD_TYPES_API static Time CreateLocalTime(const bool shouldSetMilliseconds = false);
00681
00690     static void ConvertJulianToGregorianTime(const int32_t julianTime, int32_t &hour, int32_t &minute, int32_t &second);
00691
00701     static int32_t ConvertGregorianToJulianTime(const int32_t hour, const int32_t minute, const int32_t second);
00702
00713     ACTIV_FIELD_TYPES_API static StatusCode ValidateSerializedLengthAndBody(MessageValidator &messageValidator, size_t &serializedBodyOffset, size_t &serializedBodyLength);
00714
00722     static bool IsValidSerializedBodyLength(const size_t serializedBodyLength);
00723
00724 private:
00725     static const size_t HOUR_OFFSET                                     = 0;
00726     static const size_t HOUR_LENGTH                                     = 5;
00727     static const size_t MINUTE_OFFSET                                   = (HOUR_OFFSET + HOUR_LENGTH);
00728     static const size_t MINUTE_LENGTH                                   = 6;
00729     static const size_t SECOND_OFFSET                                   = (MINUTE_OFFSET + MINUTE_LENGTH);
00730     static const size_t SECOND_LENGTH                                   = 6;
00731     static const size_t MILLISECOND_OFFSET                              = (SECOND_OFFSET + SECOND_LENGTH);
00732     static const size_t MILLISECOND_LENGTH                              = 10;
00733     static const size_t MAX_OFFSET                                      = (MILLISECOND_OFFSET + MILLISECOND_LENGTH);
00734
00735     static const size_t MAX_HOUR                                        = ((1 << HOUR_LENGTH) - 1);
00736     static const size_t MAX_MINUTE                                      = ((1 << MINUTE_LENGTH) - 1);
00737     static const size_t MAX_SECOND                                      = ((1 << SECOND_LENGTH) - 1);
00738     static const size_t MAX_MILLISECOND                                 = ((1 << MILLISECOND_LENGTH) - 1);
00739
00740     static const size_t MAX_SERIALIZED_BODY_LENGTH                      = (sizeof(uint8_t) + sizeof(uint8_t) + sizeof(uint8_t));
00741     static const size_t MAX_SERIALIZED_BODY_LENGTH_WITH_MILLISECONDS    = (((MAX_OFFSET - 1) / CHAR_BIT) + 1);
00742
00743     uint8_t     m_hour;
00744     uint8_t     m_minute;
00745     uint8_t     m_second;
00746     uint16_t    m_millisecond;
00747
00748     friend class DateTime;
00749 };
00750
00751 // ---------------------------------------------------------------------------------------------------------------------------------
00752
00753 inline Time::Time() :
00754     IFieldType(FIELD_TYPE)
00755 {
00756     m_isInitialized = false;
00757 }
00758
00759 // ---------------------------------------------------------------------------------------------------------------------------------
00760
00761 inline Time::Time(const uint32_t hour, const uint32_t minute, const uint32_t second, const uint32_t millisecond) :
00762     IFieldType(FIELD_TYPE)
00763 {
00764     ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, Set(hour, minute, second, millisecond));
00765 }
00766
00767 // ---------------------------------------------------------------------------------------------------------------------------------
00768
00769 inline Time::Time(const int32_t julianTime, const uint32_t millisecond) :
00770     IFieldType(FIELD_TYPE)
00771 {
00772     ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, Set(julianTime, millisecond));
00773 }
00774
00775 // ---------------------------------------------------------------------------------------------------------------------------------
00776
00777 inline Time::Time(const std::tm &tm, const uint32_t millisecond) :
00778     IFieldType(FIELD_TYPE)
00779 {
00780     ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, Set(tm, millisecond));
00781 }
00782
00783 // ---------------------------------------------------------------------------------------------------------------------------------
00784
00785 inline Time::~Time()
00786 {
00787 }
00788
00789 // ---------------------------------------------------------------------------------------------------------------------------------
00790
00791 inline bool Time::operator==(const Time &rhs) const
00792 {
00793     int result;
00794     ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, Compare(rhs, result));
00795
00796     return (0 == result);
00797 }
00798
00799 // ---------------------------------------------------------------------------------------------------------------------------------
00800
00801 inline bool Time::operator!=(const Time &rhs) const
00802 {
00803     return !((*this) == rhs);
00804 }
00805
00806 // ---------------------------------------------------------------------------------------------------------------------------------
00807
00808 inline bool Time::operator<(const Time &rhs) const
00809 {
00810     int result;
00811     ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, Compare(rhs, result));
00812
00813     return (result < 0);
00814 }
00815
00816 // ---------------------------------------------------------------------------------------------------------------------------------
00817
00818 inline bool Time::operator<=(const Time &rhs) const
00819 {
00820     return !((*this) > rhs);
00821 }
00822
00823 // ---------------------------------------------------------------------------------------------------------------------------------
00824
00825 inline bool Time::operator>(const Time &rhs) const
00826 {
00827     int result;
00828     ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, Compare(rhs, result));
00829
00830     return (result > 0);
00831 }
00832
00833 // ---------------------------------------------------------------------------------------------------------------------------------
00834
00835 inline bool Time::operator>=(const Time &rhs) const
00836 {
00837     return !((*this) < rhs);
00838 }
00839
00840 // ---------------------------------------------------------------------------------------------------------------------------------
00841
00842 template <typename T> inline const Time Time::operator+(const T &rhs) const
00843 {
00844     return Time(*this) += rhs;
00845 }
00846
00847 // ---------------------------------------------------------------------------------------------------------------------------------
00848
00849 template <typename T> inline Time& Time::operator+=(const T &rhs)
00850 {
00851     ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, Add(rhs));
00852
00853     return (*this);
00854 }
00855
00856 // ---------------------------------------------------------------------------------------------------------------------------------
00857
00858 template <typename T> inline const Time Time::operator-(const T &rhs) const
00859 {
00860     return Time(*this) -= rhs;
00861 }
00862
00863 // ---------------------------------------------------------------------------------------------------------------------------------
00864
00865 template <typename T> inline Time& Time::operator-=(const T &rhs)
00866 {
00867     ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, Subtract(rhs));
00868
00869     return (*this);
00870 }
00871
00872 // ---------------------------------------------------------------------------------------------------------------------------------
00873
00874 inline StatusCode Time::Set(const uint32_t hour, const uint32_t minute, const uint32_t second, const uint32_t millisecond)
00875 {
00876     if ((hour >= Hours::NUMBER_PER_DAY) || (minute >= Minutes::NUMBER_PER_HOUR) || (second >= Seconds::NUMBER_PER_MINUTE) || (millisecond >= Milliseconds::NUMBER_PER_SECOND))
00877         return STATUS_CODE_INVALID_PARAMETER;
00878
00879     m_hour = static_cast<uint8_t>(hour);
00880     m_minute = static_cast<uint8_t>(minute);
00881     m_second = static_cast<uint8_t>(second);
00882     m_millisecond = static_cast<uint16_t>(millisecond);
00883     m_isInitialized = true;
00884
00885     return STATUS_CODE_SUCCESS;
00886 }
00887
00888 // ---------------------------------------------------------------------------------------------------------------------------------
00889
00890 inline StatusCode Time::Set(const int32_t julianTime, const uint32_t millisecond)
00891 {
00892     int32_t hour, minute, second;
00893
00894     ConvertJulianToGregorianTime(julianTime, hour, minute, second);
00895
00896     if ((hour < 0) || (hour >= static_cast<int32_t>(Hours::NUMBER_PER_DAY)) || (minute < 0) || (minute >= static_cast<int32_t>(Minutes::NUMBER_PER_HOUR)) || (second < 0) || (second >= static_cast<int32_t>(Seconds::NUMBER_PER_MINUTE)) || (millisecond >= Milliseconds::NUMBER_PER_SECOND))
00897         return STATUS_CODE_INVALID_PARAMETER;
00898
00899     m_hour = static_cast<uint8_t>(hour);
00900     m_minute = static_cast<uint8_t>(minute);
00901     m_second = static_cast<uint8_t>(second);
00902     m_millisecond = static_cast<uint16_t>(millisecond);
00903     m_isInitialized = true;
00904
00905     return STATUS_CODE_SUCCESS;
00906 }
00907
00908 // ---------------------------------------------------------------------------------------------------------------------------------
00909
00910 inline StatusCode Time::Set(const std::tm &tm, const uint32_t millisecond)
00911 {
00912     return Set(static_cast<uint32_t>(tm.tm_hour), static_cast<uint32_t>(tm.tm_min), static_cast<uint32_t>(tm.tm_sec), millisecond);
00913 }
00914
00915 // ---------------------------------------------------------------------------------------------------------------------------------
00916
00917 inline int32_t Time::Get() const
00918 {
00919     if (!IsInitialized())
00920         ACTIV_THROW(StatusCodeException, STATUS_CODE_NOT_INITIALIZED);
00921
00922     return ConvertGregorianToJulianTime(m_hour, m_minute, m_second);
00923 }
00924
00925 // ---------------------------------------------------------------------------------------------------------------------------------
00926
00927 inline StatusCode Time::Get(uint32_t &hour, uint32_t &minute, uint32_t &second) const
00928 {
00929     if (!IsInitialized())
00930         return STATUS_CODE_NOT_INITIALIZED;
00931
00932     hour = m_hour;
00933     minute = m_minute;
00934     second = m_second;
00935
00936     return STATUS_CODE_SUCCESS;
00937 }
00938
00939 // ---------------------------------------------------------------------------------------------------------------------------------
00940
00941 inline StatusCode Time::Get(uint32_t &hour, uint32_t &minute, uint32_t &second, uint32_t &millisecond) const
00942 {
00943     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, Get(hour, minute, second));
00944
00945     millisecond = m_millisecond;
00946
00947     return STATUS_CODE_SUCCESS;
00948 }
00949
00950 // ---------------------------------------------------------------------------------------------------------------------------------
00951
00952 inline StatusCode Time::Get(int32_t &julianTime) const
00953 {
00954     if (!IsInitialized())
00955         return STATUS_CODE_NOT_INITIALIZED;
00956
00957     julianTime = ConvertGregorianToJulianTime(m_hour, m_minute, m_second);
00958
00959     return STATUS_CODE_SUCCESS;
00960 }
00961
00962 // ---------------------------------------------------------------------------------------------------------------------------------
00963
00964 inline StatusCode Time::Get(int32_t &julianTime, uint32_t &millisecond) const
00965 {
00966     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, Get(julianTime));
00967
00968     millisecond = m_millisecond;
00969
00970     return STATUS_CODE_SUCCESS;
00971 }
00972
00973 // ---------------------------------------------------------------------------------------------------------------------------------
00974
00975 inline StatusCode Time::Get(std::tm &tm) const
00976 {
00977     if (!IsInitialized())
00978         return STATUS_CODE_NOT_INITIALIZED;
00979
00980     tm.tm_hour = static_cast<int>(m_hour);
00981     tm.tm_min = static_cast<int>(m_minute);
00982     tm.tm_sec = static_cast<int>(m_second);
00983
00984     return STATUS_CODE_SUCCESS;
00985 }
00986
00987 // ---------------------------------------------------------------------------------------------------------------------------------
00988
00989 inline StatusCode Time::Get(std::tm &tm, uint32_t &millisecond) const
00990 {
00991     ACTIV_RETURN_RESULT_IF(STATUS_CODE_SUCCESS, !=, Get(tm));
00992
00993     millisecond = m_millisecond;
00994
00995     return STATUS_CODE_SUCCESS;
00996 }
00997
00998 // ---------------------------------------------------------------------------------------------------------------------------------
00999
01000 inline uint32_t Time::GetHour() const
01001 {
01002     if (!IsInitialized())
01003         ACTIV_THROW(StatusCodeException, STATUS_CODE_NOT_INITIALIZED);
01004
01005     return static_cast<uint32_t>(m_hour);
01006 }
01007
01008 // ---------------------------------------------------------------------------------------------------------------------------------
01009
01010 inline uint32_t Time::GetMinute() const
01011 {
01012     if (!IsInitialized())
01013         ACTIV_THROW(StatusCodeException, STATUS_CODE_NOT_INITIALIZED);
01014
01015     return static_cast<uint32_t>(m_minute);
01016 }
01017
01018 // ---------------------------------------------------------------------------------------------------------------------------------
01019
01020 inline uint32_t Time::GetSecond() const
01021 {
01022     if (!IsInitialized())
01023         ACTIV_THROW(StatusCodeException, STATUS_CODE_NOT_INITIALIZED);
01024
01025     return static_cast<uint32_t>(m_second);
01026 }
01027
01028 // ---------------------------------------------------------------------------------------------------------------------------------
01029
01030 inline uint32_t Time::GetMillisecond() const
01031 {
01032     if (!IsInitialized())
01033         ACTIV_THROW(StatusCodeException, STATUS_CODE_NOT_INITIALIZED);
01034
01035     return static_cast<uint32_t>(m_millisecond);
01036 }
01037
01038 // ---------------------------------------------------------------------------------------------------------------------------------
01039
01040 inline uint32_t Time::GetTotalMilliseconds() const
01041 {
01042     if (!IsInitialized())
01043         ACTIV_THROW(StatusCodeException, STATUS_CODE_NOT_INITIALIZED);
01044
01045     return (static_cast<uint32_t>(ConvertGregorianToJulianTime(m_hour, m_minute, m_second)) * Milliseconds::NUMBER_PER_SECOND) + m_millisecond;
01046 }
01047
01048 // ---------------------------------------------------------------------------------------------------------------------------------
01049
01050 inline Time Time::GetUtc() const
01051 {
01052     if (!IsInitialized())
01053         ACTIV_THROW(StatusCodeException, STATUS_CODE_NOT_INITIALIZED);
01054
01055     return (*this) + Time::Seconds(GetTimeZoneOffset());
01056 }
01057
01058 // ---------------------------------------------------------------------------------------------------------------------------------
01059
01060 inline Time Time::GetLocal() const
01061 {
01062     if (!IsInitialized())
01063         ACTIV_THROW(StatusCodeException, STATUS_CODE_NOT_INITIALIZED);
01064
01065     return (*this) - Time::Seconds(GetTimeZoneOffset());
01066 }
01067
01068 // ---------------------------------------------------------------------------------------------------------------------------------
01069
01070 inline StatusCode Time::Add(const Time &rhs)
01071 {
01072     if (!rhs.IsInitialized())
01073         return STATUS_CODE_NOT_INITIALIZED;
01074
01075     return Add(Milliseconds(rhs.GetTotalMilliseconds()));
01076 }
01077
01078 // ---------------------------------------------------------------------------------------------------------------------------------
01079
01080 inline StatusCode Time::Add(const Hours &hours)
01081 {
01082     return Add(Milliseconds((hours.m_value % static_cast<int32_t>(Hours::NUMBER_PER_DAY)) * Milliseconds::NUMBER_PER_HOUR));
01083 }
01084
01085 // ---------------------------------------------------------------------------------------------------------------------------------
01086
01087 inline StatusCode Time::Add(const Minutes &minutes)
01088 {
01089     return Add(Milliseconds((minutes.m_value % static_cast<int32_t>(Minutes::NUMBER_PER_DAY)) * Milliseconds::NUMBER_PER_MINUTE));
01090 }
01091
01092 // ---------------------------------------------------------------------------------------------------------------------------------
01093
01094 inline StatusCode Time::Add(const Seconds &seconds)
01095 {
01096     return Add(Milliseconds((seconds.m_value % static_cast<int32_t>(Seconds::NUMBER_PER_DAY)) * Milliseconds::NUMBER_PER_SECOND));
01097 }
01098
01099 // ---------------------------------------------------------------------------------------------------------------------------------
01100
01101 inline StatusCode Time::Add(const Milliseconds &milliseconds)
01102 {
01103     if (!IsInitialized())
01104         return STATUS_CODE_NOT_INITIALIZED;
01105
01106     const uint32_t totalMilliseconds = static_cast<uint32_t>(GetTotalMilliseconds() + (Milliseconds::NUMBER_PER_DAY + (milliseconds.m_value % static_cast<int32_t>(Milliseconds::NUMBER_PER_DAY)))) % Milliseconds::NUMBER_PER_DAY;
01107
01108     return Set(static_cast<int32_t>(totalMilliseconds / Milliseconds::NUMBER_PER_SECOND), totalMilliseconds % Milliseconds::NUMBER_PER_SECOND);
01109 }
01110
01111 // ---------------------------------------------------------------------------------------------------------------------------------
01112
01113 inline StatusCode Time::Subtract(const Time &rhs)
01114 {
01115     if (!rhs.IsInitialized())
01116         return STATUS_CODE_NOT_INITIALIZED;
01117
01118     return Subtract(Milliseconds(rhs.GetTotalMilliseconds()));
01119 }
01120
01121 // ---------------------------------------------------------------------------------------------------------------------------------
01122
01123 inline StatusCode Time::Subtract(const Hours &hours)
01124 {
01125     return Subtract(Milliseconds((hours.m_value % static_cast<int32_t>(Hours::NUMBER_PER_DAY)) * Milliseconds::NUMBER_PER_HOUR));
01126 }
01127
01128 // ---------------------------------------------------------------------------------------------------------------------------------
01129
01130 inline StatusCode Time::Subtract(const Minutes &minutes)
01131 {
01132     return Subtract(Milliseconds((minutes.m_value % static_cast<int32_t>(Minutes::NUMBER_PER_DAY)) * Milliseconds::NUMBER_PER_MINUTE));
01133 }
01134
01135 // ---------------------------------------------------------------------------------------------------------------------------------
01136
01137 inline StatusCode Time::Subtract(const Seconds &seconds)
01138 {
01139     return Subtract(Milliseconds((seconds.m_value % static_cast<int32_t>(Seconds::NUMBER_PER_DAY)) * Milliseconds::NUMBER_PER_SECOND));
01140 }
01141
01142 // ---------------------------------------------------------------------------------------------------------------------------------
01143
01144 inline StatusCode Time::Subtract(const Milliseconds &milliseconds)
01145 {
01146     if (!IsInitialized())
01147         return STATUS_CODE_NOT_INITIALIZED;
01148
01149     const uint32_t totalMilliseconds = static_cast<uint32_t>(GetTotalMilliseconds() + (Milliseconds::NUMBER_PER_DAY - (milliseconds.m_value % static_cast<int32_t>(Milliseconds::NUMBER_PER_DAY)))) % Milliseconds::NUMBER_PER_DAY;
01150
01151     return Set(static_cast<int32_t>(totalMilliseconds / Milliseconds::NUMBER_PER_SECOND), totalMilliseconds % Milliseconds::NUMBER_PER_SECOND);
01152 }
01153
01154 // ---------------------------------------------------------------------------------------------------------------------------------
01155
01156 inline void Time::Reset()
01157 {
01158     m_isInitialized = false;
01159 }
01160
01161 // ---------------------------------------------------------------------------------------------------------------------------------
01162
01163 inline void Time::Clear()
01164 {
01165     m_isInitialized = false;
01166 }
01167
01168 // ---------------------------------------------------------------------------------------------------------------------------------
01169
01170 inline size_t Time::GetSerializedLength() const
01171 {
01172     return GetSerializedBodyLength();
01173 }
01174
01175 // ---------------------------------------------------------------------------------------------------------------------------------
01176
01177 inline size_t Time::GetSerializedBodyLength() const
01178 {
01179     return (IsInitialized() ? GetMaxSerializedBodyLength(0 != m_millisecond) : 0);
01180 }
01181
01182 // ---------------------------------------------------------------------------------------------------------------------------------
01183
01184 inline size_t Time::GetSerializedLength(const void * const pSerializedBody)
01185 {
01186     return GetSerializedBodyLength(pSerializedBody);
01187 }
01188
01189 // ---------------------------------------------------------------------------------------------------------------------------------
01190
01191 inline size_t Time::GetSerializedBodyLength(const void * const pSerializedBody)
01192 {
01193     return GetMaxSerializedBodyLength(0 != (*(static_cast<const byte_t * const>(pSerializedBody)) & (1 << (CHAR_BIT - 1))));
01194 }
01195
01196 // ---------------------------------------------------------------------------------------------------------------------------------
01197
01198 inline size_t Time::GetMaxSerializedLength(const bool shouldSerializeMilliseconds)
01199 {
01200     return GetMaxSerializedBodyLength(shouldSerializeMilliseconds);
01201 }
01202
01203 // ---------------------------------------------------------------------------------------------------------------------------------
01204
01205 inline size_t Time::GetMaxSerializedBodyLength(const bool shouldSerializeMilliseconds)
01206 {
01207     if (shouldSerializeMilliseconds)
01208         return MAX_SERIALIZED_BODY_LENGTH_WITH_MILLISECONDS;
01209
01210     return MAX_SERIALIZED_BODY_LENGTH;
01211 }
01212
01213 // ---------------------------------------------------------------------------------------------------------------------------------
01214
01215 inline void Time::ConvertJulianToGregorianTime(const int32_t julianTime, int32_t &hour, int32_t &minute, int32_t &second)
01216 {
01217     hour = julianTime / Seconds::NUMBER_PER_HOUR;
01218     minute = (julianTime % Seconds::NUMBER_PER_HOUR) / Seconds::NUMBER_PER_MINUTE;
01219     second = julianTime % Seconds::NUMBER_PER_MINUTE;
01220 }
01221
01222 // ---------------------------------------------------------------------------------------------------------------------------------
01223
01224 inline int32_t Time::ConvertGregorianToJulianTime(const int32_t hour, const int32_t minute, const int32_t second)
01225 {
01226     return ((((hour * Minutes::NUMBER_PER_HOUR) + minute) * Seconds::NUMBER_PER_MINUTE) + second);
01227 }
01228
01229 // ---------------------------------------------------------------------------------------------------------------------------------
01230
01231 inline bool Time::IsValidSerializedBodyLength(const size_t serializedBodyLength)
01232 {
01233     return ((MAX_SERIALIZED_BODY_LENGTH_WITH_MILLISECONDS == serializedBodyLength) || (MAX_SERIALIZED_BODY_LENGTH == serializedBodyLength));
01234 }
01235
01236 // ---------------------------------------------------------------------------------------------------------------------------------
01237 // ---------------------------------------------------------------------------------------------------------------------------------
01238
01239 inline Time::Hours::Hours(const int32_t value) :
01240     m_value(value)
01241 {
01242 }
01243
01244 // ---------------------------------------------------------------------------------------------------------------------------------
01245 // ---------------------------------------------------------------------------------------------------------------------------------
01246
01247 inline Time::Minutes::Minutes(const int32_t value) :
01248     m_value(value)
01249 {
01250 }
01251
01252 // ---------------------------------------------------------------------------------------------------------------------------------
01253 // ---------------------------------------------------------------------------------------------------------------------------------
01254
01255 inline Time::Seconds::Seconds(const int32_t value) :
01256     m_value(value)
01257 {
01258 }
01259
01260 // ---------------------------------------------------------------------------------------------------------------------------------
01261 // ---------------------------------------------------------------------------------------------------------------------------------
01262
01263 inline Time::Milliseconds::Milliseconds(const int32_t value) :
01264     m_value(value)
01265 {
01266 }
01267
01268 // ---------------------------------------------------------------------------------------------------------------------------------
01269 // ---------------------------------------------------------------------------------------------------------------------------------
01270
01274 template<>
01275 class FieldTypeToClass<FIELD_TYPE_TIME>
01276 {
01277 public:
01278     typedef Time Type;
01279 };
01280
01281 } // namespace Activ
01282
01283 #endif // (!defined ACTIV_FIELD_TYPES_TIME_H)
Generated on Wed Oct 8 14:01:48 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivFramework

TimeHelper.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FRAMEWORK_TIME_HELPER_H)
00010 #define ACTIV_FRAMEWORK_TIME_HELPER_H
00011
00012 #include "ActivMiddleware/ActivFramework/External.h"
00013
00014 #include "ActivMiddleware/ActivFieldTypes/DateTime.h"
00015
00016 #include <string>
00017
00018 namespace Activ
00019 {
00020
00026 class BaseTime
00027 {
00028 public:
00029     typedef uint8_t DayOfWeek;
00030
00031     static const DayOfWeek SUNDAY = 0;
00032     static const DayOfWeek MONDAY = 1;
00033     static const DayOfWeek TUESDAY = 2;
00034     static const DayOfWeek WEDSDAY = 3;
00035     static const DayOfWeek THURSDAY = 4;
00036     static const DayOfWeek FRIDAY = 5;
00037     static const DayOfWeek SATURDAY = 6;
00038
00039     static const uint32_t secondsPerMinute = 60;
00040     static const uint32_t secondsPerHour = 60 * secondsPerMinute;
00041     static const uint32_t secondsPerDay = 24 * secondsPerHour;
00042
00043     static const uint32_t millisecondsPerSecond = 1000;
00044     static const uint32_t millisecondsPerMinute = secondsPerMinute * millisecondsPerSecond;
00045     static const uint32_t millisecondsPerHour = secondsPerHour * millisecondsPerSecond;
00046     static const uint32_t millisecondsPerDay = secondsPerDay * millisecondsPerSecond;
00047
00051     class Duration
00052     {
00053     public:
00059         ACTIV_FRAMEWORK_API Duration(const int64_t duration);
00060
00070         ACTIV_FRAMEWORK_API Duration(const int32_t days, const int32_t hours, const int32_t minutes = 0, const int32_t seconds = 0,
00071                                      const int32_t milliseconds = 0);
00072
00076         ACTIV_FRAMEWORK_API int64_t GetTotalMilliseconds() const;
00077
00083         ACTIV_FRAMEWORK_API std::string ToString() const;
00084
00085     private:
00086         const int64_t   m_duration;
00087     };
00088
00092     ACTIV_FRAMEWORK_API virtual ~BaseTime();
00093
00099     uint16_t GetYear() const;
00100
00106     uint8_t GetMonth() const;
00107
00113     uint8_t GetDay() const;
00114
00120     DayOfWeek GetDayOfWeek() const;
00121
00127     uint8_t GetHour() const;
00128
00134     uint8_t GetMinute() const;
00135
00141     uint8_t GetSecond() const;
00142
00148     uint16_t GetMillisecond() const;
00149
00155     uint32_t GetJulianTime() const;
00156
00162     bool IsUtc() const;
00163
00171     ACTIV_FRAMEWORK_API BaseTime &operator=(const BaseTime &rhs);
00172
00180     ACTIV_FRAMEWORK_API bool operator==(const BaseTime &rhs) const;
00181
00189     ACTIV_FRAMEWORK_API bool operator!=(const BaseTime &rhs) const;
00190
00198     ACTIV_FRAMEWORK_API bool operator<(const BaseTime &rhs) const;
00199
00207     ACTIV_FRAMEWORK_API bool operator<=(const BaseTime &rhs) const;
00208
00216     ACTIV_FRAMEWORK_API bool operator>(const BaseTime &rhs) const;
00217
00225     ACTIV_FRAMEWORK_API bool operator>=(const BaseTime &rhs) const;
00226
00234     ACTIV_FRAMEWORK_API BaseTime &operator+=(const int64_t numberOfMilliseconds);
00235
00243     ACTIV_FRAMEWORK_API BaseTime &operator+=(const Duration &duration);
00244
00252     ACTIV_FRAMEWORK_API BaseTime &operator-=(const int64_t numberOfMilliseconds);
00253
00261     ACTIV_FRAMEWORK_API BaseTime &operator-=(const Duration &duration);
00262
00270     ACTIV_FRAMEWORK_API std::string ToString(const bool shouldFormatMilliseconds = false) const;
00271
00277     ACTIV_FRAMEWORK_API std::string DateToString() const;
00278
00286     ACTIV_FRAMEWORK_API std::string TimeToString(const bool shouldFormatMilliseconds = false) const;
00287
00296     ACTIV_FRAMEWORK_API static std::string DayOfWeekToString(const DayOfWeek dayOfWeek, bool isShort = false);
00297
00306     ACTIV_FRAMEWORK_API static std::string MonthToString(const uint8_t month, bool isShort = false);
00307
00316     ACTIV_FRAMEWORK_API StatusCode Serialize(MessageBuilder &messageBuilder) const;
00317
00326     ACTIV_FRAMEWORK_API StatusCode Deserialize(MessageValidator &messageValidator);
00327
00328 private:
00332     BaseTime(const bool isUtc);
00333
00337     void MakeFormattedTime();
00338
00344     void MakeUtcTime(const uint16_t millisecond);
00345
00349     void GetCurrent();
00350
00356     void AdjustTime(const int64_t numberOfMilliseconds);
00357
00358     tm          m_formattedTime;
00359     uint64_t    m_utcTime;
00360     bool        m_isUtc;
00361
00362     friend class UtcTime;
00363     friend class LocalTime;
00364 };
00365
00366 // ---------------------------------------------------------------------------------------------------------------------------------
00367 // ---------------------------------------------------------------------------------------------------------------------------------
00368
00372 class UtcTime : public BaseTime
00373 {
00374 public:
00378     ACTIV_FRAMEWORK_API UtcTime();
00379
00385     ACTIV_FRAMEWORK_API UtcTime(const BaseTime &baseTime);
00386
00392     ACTIV_FRAMEWORK_API static UtcTime GetCurrent();
00393 };
00394
00395 // ---------------------------------------------------------------------------------------------------------------------------------
00396 // ---------------------------------------------------------------------------------------------------------------------------------
00397
00401 class LocalTime : public BaseTime
00402 {
00403 public:
00407     ACTIV_FRAMEWORK_API LocalTime();
00408
00422     explicit ACTIV_FRAMEWORK_API LocalTime(const uint16_t year, const uint8_t month = 1, const uint8_t day = 1, const uint8_t hour = 0, const uint8_t minute = 0, const uint8_t second = 0, uint16_t millisecond = 0);
00423
00431     ACTIV_FRAMEWORK_API LocalTime(const DateTime &dateTime);
00432
00441     ACTIV_FRAMEWORK_API LocalTime(const Date &date, const Time &time);
00442
00448     ACTIV_FRAMEWORK_API LocalTime(const BaseTime &baseTime);
00449
00455     DateTime Get() const;
00456
00462     ACTIV_FRAMEWORK_API static LocalTime GetCurrent();
00463
00469     ACTIV_FRAMEWORK_API static LocalTime GetMidnight();
00470 };
00471
00472 // ---------------------------------------------------------------------------------------------------------------------------------
00473 // ---------------------------------------------------------------------------------------------------------------------------------
00474
00475 inline uint16_t BaseTime::GetYear() const
00476 {
00477     return static_cast<uint16_t>(m_formattedTime.tm_year) + 1900;
00478 }
00479
00480 // ---------------------------------------------------------------------------------------------------------------------------------
00481
00482 inline uint8_t BaseTime::GetMonth() const
00483 {
00484     return static_cast<uint8_t>(m_formattedTime.tm_mon) + 1;
00485 }
00486
00487 // ---------------------------------------------------------------------------------------------------------------------------------
00488
00489 inline uint8_t BaseTime::GetDay() const
00490 {
00491     return static_cast<uint8_t>(m_formattedTime.tm_mday);
00492 }
00493
00494 // ---------------------------------------------------------------------------------------------------------------------------------
00495
00496 inline BaseTime::DayOfWeek BaseTime::GetDayOfWeek() const
00497 {
00498     return static_cast<DayOfWeek>(m_formattedTime.tm_wday);
00499 }
00500
00501 // ---------------------------------------------------------------------------------------------------------------------------------
00502
00503 inline uint8_t BaseTime::GetHour() const
00504 {
00505     return static_cast<uint8_t>(m_formattedTime.tm_hour);
00506 }
00507
00508 // ---------------------------------------------------------------------------------------------------------------------------------
00509
00510 inline uint8_t BaseTime::GetMinute() const
00511 {
00512     return static_cast<uint8_t>(m_formattedTime.tm_min);
00513 }
00514
00515 // ---------------------------------------------------------------------------------------------------------------------------------
00516
00517 inline uint8_t BaseTime::GetSecond() const
00518 {
00519     return static_cast<uint8_t>(m_formattedTime.tm_sec);
00520 }
00521
00522 // ---------------------------------------------------------------------------------------------------------------------------------
00523
00524 inline uint16_t BaseTime::GetMillisecond() const
00525 {
00526     return static_cast<uint16_t>(m_utcTime % UINT64_C(1000));
00527 }
00528
00529 // ---------------------------------------------------------------------------------------------------------------------------------
00530
00531 inline uint32_t BaseTime::GetJulianTime() const
00532 {
00533     return static_cast<uint32_t>(GetSecond()) + (secondsPerMinute * static_cast<uint32_t>(GetMinute())) + (secondsPerHour * static_cast<uint32_t>(GetHour()));
00534 }
00535
00536 // ---------------------------------------------------------------------------------------------------------------------------------
00537
00538 inline bool BaseTime::IsUtc() const
00539 {
00540     return m_isUtc;
00541 }
00542
00543 // ---------------------------------------------------------------------------------------------------------------------------------
00544 // ---------------------------------------------------------------------------------------------------------------------------------
00545
00546 inline DateTime LocalTime::Get() const
00547 {
00548     return DateTime(GetYear(), GetMonth(), GetDay(), GetHour(), GetMinute(), GetSecond(), GetMillisecond());
00549 }
00550
00551 // ---------------------------------------------------------------------------------------------------------------------------------
00552 // ---------------------------------------------------------------------------------------------------------------------------------
00553
00564 inline const UtcTime operator+(const UtcTime &lhs, const uint64_t numberOfMilliseconds)
00565 {
00566     return UtcTime(lhs) += numberOfMilliseconds;
00567 }
00568
00569 // ---------------------------------------------------------------------------------------------------------------------------------
00570
00581 inline const UtcTime operator+(const UtcTime &lhs, const BaseTime::Duration &duration)
00582 {
00583     return UtcTime(lhs) += duration;
00584 }
00585
00586 // ---------------------------------------------------------------------------------------------------------------------------------
00587
00598 inline const LocalTime operator+(const LocalTime &lhs, const uint64_t numberOfMilliseconds)
00599 {
00600     return LocalTime(lhs) += numberOfMilliseconds;
00601 }
00602
00603 // ---------------------------------------------------------------------------------------------------------------------------------
00604
00615 inline const LocalTime operator+(const LocalTime &lhs, const BaseTime::Duration &duration)
00616 {
00617     return LocalTime(lhs) += duration;
00618 }
00619
00620 } // namespace Activ
00621
00622 #endif // (!defined ACTIV_FRAMEWORK_TIME_HELPER_H)
Generated on Wed Oct 8 14:01:48 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivContentGatewayApi

TimeSeriesRequestHelper.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_CONTENT_GATEWAY_API_TIME_SERIES_REQUEST_HELPER_H)
00010 #define ACTIV_CONTENT_GATEWAY_API_TIME_SERIES_REQUEST_HELPER_H
00011
00012 #include "ActivContentPlatform/ActivContentGatewayApi/External.h"
00013
00014 namespace Activ
00015 {
00016
00017 namespace ContentPlatform
00018 {
00019
00020 namespace ContentGatewayApi
00021 {
00022
00023 class ContentGatewayClient;
00024
00025 // ---------------------------------------------------------------------------------------------------------------------------------
00026
00034 template<MessageType FIRST_MESSAGE_TYPE_VALUE, MessageType NEXT_MESSAGE_TYPE_VALUE, typename FIELD_SET_TYPE>
00035 class TimeSeriesRequestHelper
00036 {
00037 public:
00038     typedef TimeSeriesRequestParameters RequestParameters;
00039     typedef TimeSeriesResponseParametersTemplate<FIELD_SET_TYPE> ResponseParameters;
00040
00055     ACTIV_CONTENT_GATEWAY_API static StatusCode SendGetFirstRequest(const ContentGatewayClient &client,
00056         const RequestParameters &requestParameters, TimeSeriesCookie &cookie, ResponseParameters &responseParameters,
00057         const TimeoutPeriod timeoutPeriod = Port::defaultTimeout);
00058
00070     ACTIV_CONTENT_GATEWAY_API static StatusCode PostGetFirstRequest(const ContentGatewayClient &client, const RequestId &requestId,
00071         const RequestParameters &requestParameters);
00072
00086     ACTIV_CONTENT_GATEWAY_API static StatusCode SendGetNextRequest(const ContentGatewayClient &client, TimeSeriesCookie &cookie,
00087         ResponseParameters &responseParameters, const TimeoutPeriod timeoutPeriod = Port::defaultTimeout);
00088
00100     ACTIV_CONTENT_GATEWAY_API static StatusCode PostGetNextRequest(const ContentGatewayClient &client, const RequestId &requestId,
00101         const TimeSeriesCookie &cookie);
00102
00116     ACTIV_CONTENT_GATEWAY_API static StatusCode Deserialize(const ContentGatewayClient &client, const HeapMessage &response,
00117         TimeSeriesCookie &cookie, ResponseParameters &responseParameters);
00118
00119 private:
00120     static const MessageType FIRST_MESSAGE_TYPE = FIRST_MESSAGE_TYPE_VALUE;
00121     static const MessageType NEXT_MESSAGE_TYPE = NEXT_MESSAGE_TYPE_VALUE;
00122 };
00123
00124 } // namespace ContentGatewayApi
00125
00126 } // namespace ContentPlatform
00127
00128 } // namespace Activ
00129
00130 #endif // (!defined ACTIV_CONTENT_GATEWAY_API_TIME_SERIES_REQUEST_HELPER_H)
Generated on Wed Oct 8 14:01:45 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivContentGatewayApiCommon

TimeSeriesTypes.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_CONTENT_GATEWAY_API_COMMON_TIME_SERIES_TYPES_H)
00010 #define ACTIV_CONTENT_GATEWAY_API_COMMON_TIME_SERIES_TYPES_H
00011
00012 #include "ActivContentPlatform/ActivContentGatewayApiCommon/External.h"
00013 #include "ActivContentPlatform/ActivContentGatewayApiCommon/Types.h"
00014
00015 #include "ActivMiddleware/ActivFieldTypes/DateTime.h"
00016
00017 namespace Activ
00018 {
00019
00020 namespace ContentPlatform
00021 {
00022
00023 namespace ContentGatewayApi
00024 {
00025
00026 typedef uint8_t SeriesType;
00027
00028 #define ACTIV_DECLARE_FLAGS(value, id)  static const Flags id = value;
00029 #define ACTIV_DECLARE_CONSTANT_SERIES_TYPE(val, id, name) const SeriesType id = val;
00030
00038 ACTIV_CONTENT_GATEWAY_API_COMMON_API std::string SeriesTypeToString(const SeriesType seriesType);
00039
00040 // ---------------------------------------------------------------------------------------------------------------------------------
00041
00045 #define ACTIV_TIME_SERIES_TICK_SERIES_TYPE_LIST(d)                      \
00046     d(0,    TICK_SERIES_TYPE,               "Ticks")
00047
00048 ACTIV_TIME_SERIES_TICK_SERIES_TYPE_LIST(ACTIV_DECLARE_CONSTANT_SERIES_TYPE)
00049
00050 // ---------------------------------------------------------------------------------------------------------------------------------
00051
00052
00055 #define ACTIV_TIME_SERIES_INTRADAY_SERIES_TYPE_LIST(d)                  \
00056     d(20,   INTRADAY_SERIES_TYPE_1_MINUTE,  "1 Minute bars")            \
00057     d(21,   INTRADAY_SERIES_TYPE_5_MINUTE,  "5 Minute bars")            \
00058     d(22,   INTRADAY_SERIES_TYPE_SPECIFIED_MINUTE,  "Minute bars as specified")
00059
00060 ACTIV_TIME_SERIES_INTRADAY_SERIES_TYPE_LIST(ACTIV_DECLARE_CONSTANT_SERIES_TYPE)
00061
00062 // ---------------------------------------------------------------------------------------------------------------------------------
00063
00064
00067 #define ACTIV_TIME_SERIES_HISTORY_SERIES_TYPE_LIST(d)                   \
00068     d(40,   HISTORY_SERIES_TYPE_DAILY,      "Daily bars")               \
00069     d(41,   HISTORY_SERIES_TYPE_WEEKLY,     "Weekly bars")              \
00070     d(42,   HISTORY_SERIES_TYPE_MONTHLY,    "Monthly bars")
00071
00072 ACTIV_TIME_SERIES_HISTORY_SERIES_TYPE_LIST(ACTIV_DECLARE_CONSTANT_SERIES_TYPE)
00073
00074 // ---------------------------------------------------------------------------------------------------------------------------------
00075
00076 typedef uint8_t RecordFilterType;
00077
00078 #define ACTIV_DECLARE_CONSTANT_RECORD_FILTER_TYPE(val, id, name) const RecordFilterType id = val;
00079
00087 ACTIV_CONTENT_GATEWAY_API_COMMON_API std::string RecordFilterTypeToString(const RecordFilterType recordFilterType);
00088
00089 // ---------------------------------------------------------------------------------------------------------------------------------
00090
00094 #define ACTIV_TIME_SERIES_TICK_RECORD_FILTER_TYPE_LIST(d)               \
00095     d(0,    TICK_RECORD_FILTER_TYPE_ALL,            "All")              \
00096     d(1,    TICK_RECORD_FILTER_TYPE_ALL_TRADES,     "All Trades")       \
00097     d(2,    TICK_RECORD_FILTER_TYPE_REGULAR_TRADES, "Regular Trades")   \
00098     d(3,    TICK_RECORD_FILTER_TYPE_ALL_QUOTES,     "All Quotes")       \
00099     d(4,    TICK_RECORD_FILTER_TYPE_ALL_BIDS,       "All Bids")         \
00100     d(5,    TICK_RECORD_FILTER_TYPE_ALL_ASKS,       "Asks")
00101
00102 ACTIV_TIME_SERIES_TICK_RECORD_FILTER_TYPE_LIST(ACTIV_DECLARE_CONSTANT_RECORD_FILTER_TYPE)
00103
00104 // ---------------------------------------------------------------------------------------------------------------------------------
00105
00106
00109 #define ACTIV_TIME_SERIES_INTRADAY_RECORD_FILTER_TYPE_LIST(d)                   \
00110     d(0,    INTRADAY_RECORD_FILTER_TYPE_REGULAR_TRADES, "Regular Trades Only")  \
00111     d(1,    INTRADAY_RECORD_FILTER_TYPE_ALL,            "All Trades")           \
00112     d(2,    INTRADAY_RECORD_FILTER_TYPE_ALL_PLUS_VWAP,  "All + VWAP Only Bars")
00113
00114 ACTIV_TIME_SERIES_INTRADAY_RECORD_FILTER_TYPE_LIST(ACTIV_DECLARE_CONSTANT_RECORD_FILTER_TYPE)
00115
00116 // ---------------------------------------------------------------------------------------------------------------------------------
00117
00118 typedef uint8_t FieldFilterType;
00119
00120 #define ACTIV_DECLARE_CONSTANT_FIELD_FILTER_TYPE(val, id, name) const FieldFilterType id = val;
00121
00129 ACTIV_CONTENT_GATEWAY_API_COMMON_API std::string FieldFilterTypeToString(const FieldFilterType fieldFilterType);
00130
00131 // ---------------------------------------------------------------------------------------------------------------------------------
00132
00136 #define ACTIV_TIME_SERIES_INTRADAY_FIELD_FILTER_TYPE_LIST(d)            \
00137     d(0,    INTRADAY_FIELD_FILTER_TYPE_FULL_BAR,    "Full Bar")         \
00138     d(1,    INTRADAY_FIELD_FILTER_TYPE_MINI_BAR,    "Mini Bar")
00139
00140 ACTIV_TIME_SERIES_INTRADAY_FIELD_FILTER_TYPE_LIST(ACTIV_DECLARE_CONSTANT_FIELD_FILTER_TYPE)
00141
00142 // ---------------------------------------------------------------------------------------------------------------------------------
00143
00144
00147 #define ACTIV_TIME_SERIES_HISTORY_FIELD_FILTER_TYPE_LIST(d)             \
00148     d(20,   HISTORY_FIELD_FILTER_TYPE_FULL_BAR, "Full Bar")             \
00149     d(21,   HISTORY_FIELD_FILTER_TYPE_MINI_BAR, "Mini Bar")
00150
00151 ACTIV_TIME_SERIES_HISTORY_FIELD_FILTER_TYPE_LIST(ACTIV_DECLARE_CONSTANT_FIELD_FILTER_TYPE)
00152
00153 // ---------------------------------------------------------------------------------------------------------------------------------
00154
00155
00158 #define ACTIV_TIME_SERIES_PERIOD_TYPE_LIST(d)                           \
00159     d(0,    PERIOD_TYPE_NOW,                "Present Time")             \
00160     d(1,    PERIOD_TYPE_INFINITY,           "Infinity")                 \
00161     d(2,    PERIOD_TYPE_LOCAL_DATE_TIME,    "Local Date Time")          \
00162     d(3,    PERIOD_TYPE_UTC_DATE_TIME,      "UTC Date Time")            \
00163     d(4,    PERIOD_TYPE_TRADING_DAY_COUNT,  "Trading Day Count")        \
00164     d(5,    PERIOD_TYPE_DATA_POINT_COUNT,   "Data Point Count")         \
00165     d(6,    PERIOD_TYPE_DATA_POINT_ADDRESS, "Data Point Address")
00166
00167 typedef uint8_t PeriodType;
00168
00169 #define ACTIV_DECLARE_CONSTANT_PERIOD_TYPE(val, id, name)   const PeriodType id = val;
00170
00171 ACTIV_TIME_SERIES_PERIOD_TYPE_LIST(ACTIV_DECLARE_CONSTANT_PERIOD_TYPE)
00172
00173 #undef ACTIV_DECLARE_CONSTANT_PERIOD_TYPE
00174
00182 ACTIV_CONTENT_GATEWAY_API_COMMON_API std::string PeriodTypeToString(const PeriodType periodType);
00183
00184 // ---------------------------------------------------------------------------------------------------------------------------------
00185
00189 class DataPointAddress
00190 {
00191 public:
00200     ACTIV_CONTENT_GATEWAY_API_COMMON_API StatusCode Serialize(MessageBuilder &messageBuilder) const;
00201
00210     ACTIV_CONTENT_GATEWAY_API_COMMON_API StatusCode Deserialize(MessageValidator &messageValidator);
00211
00219     ACTIV_CONTENT_GATEWAY_API_COMMON_API bool operator==(const DataPointAddress &rhs) const;
00220
00221     typedef uint32_t SectorNumber;
00222     typedef uint16_t SequenceNumber;
00223     typedef uint16_t Flags;
00224
00225     DateTime        m_dateTime;
00226     SectorNumber    m_sectorNumber;
00227     SequenceNumber  m_sequenceNumber;
00228     Flags           m_internalFlag;
00229 };
00230
00231 // ---------------------------------------------------------------------------------------------------------------------------------
00232 // ---------------------------------------------------------------------------------------------------------------------------------
00233
00237 class Period
00238 {
00239 public:
00248     ACTIV_CONTENT_GATEWAY_API_COMMON_API StatusCode Serialize(MessageBuilder &messageBuilder) const;
00249
00258     ACTIV_CONTENT_GATEWAY_API_COMMON_API StatusCode Deserialize(MessageValidator &messageValidator);
00259
00265     bool IsAbsolutePeriod() const;
00266
00272     bool IsRelativePeriod() const;
00273
00279     bool IsRelativeCount() const;
00280
00288     ACTIV_CONTENT_GATEWAY_API_COMMON_API bool operator==(const Period &rhs) const;
00289
00290     PeriodType          m_periodType;
00291     DateTime            m_dateTime;
00292     uint16_t            m_count;
00293     DataPointAddress    m_dataPointAddress;
00294 };
00295
00296 // ---------------------------------------------------------------------------------------------------------------------------------
00297
00298 inline bool Period::IsAbsolutePeriod() const
00299 {
00300     return (PERIOD_TYPE_NOW == m_periodType) ||
00301         (PERIOD_TYPE_INFINITY == m_periodType) ||
00302         (PERIOD_TYPE_LOCAL_DATE_TIME == m_periodType) ||
00303         (PERIOD_TYPE_UTC_DATE_TIME == m_periodType) ||
00304         (PERIOD_TYPE_DATA_POINT_ADDRESS == m_periodType);
00305 }
00306
00307 // ---------------------------------------------------------------------------------------------------------------------------------
00308
00309 inline bool Period::IsRelativePeriod() const
00310 {
00311     return (PERIOD_TYPE_TRADING_DAY_COUNT == m_periodType);
00312 }
00313
00314 // ---------------------------------------------------------------------------------------------------------------------------------
00315
00316 inline bool Period::IsRelativeCount() const
00317 {
00318     return (PERIOD_TYPE_DATA_POINT_COUNT == m_periodType);
00319 }
00320
00321 // ---------------------------------------------------------------------------------------------------------------------------------
00322
00326 typedef std::vector<Period> PeriodList;
00327
00328 // ---------------------------------------------------------------------------------------------------------------------------------
00329 // ---------------------------------------------------------------------------------------------------------------------------------
00330
00334 class TimeSeriesRequestParameters
00335 {
00336 public:
00340     ACTIV_CONTENT_GATEWAY_API_COMMON_API TimeSeriesRequestParameters();
00341
00345     ACTIV_CONTENT_GATEWAY_API_COMMON_API void Clear();
00346
00355     ACTIV_CONTENT_GATEWAY_API_COMMON_API StatusCode Serialize(MessageBuilder &messageBuilder) const;
00356
00365     ACTIV_CONTENT_GATEWAY_API_COMMON_API StatusCode Deserialize(MessageValidator &messageValidator);
00366
00367     #define ACTIV_TIME_SERIES_REQUEST_FLAG_LIST(d)                                          \
00368         d(0x0000,   FLAG_NONE)                                                              \
00369         d(0x0001,   FLAG_REVERSE)                                       \
00370         d(0x0002,   FLAG_IGNORE_ALIAS)
00372     typedef uint16_t Flags;
00373     ACTIV_TIME_SERIES_REQUEST_FLAG_LIST(ACTIV_DECLARE_FLAGS)
00374
00375     static const size_t DEFAULT_MAX_FIELD_SETS = 1000;
00376
00377     SymbolId            m_symbolId;
00378     Flags               m_flags;
00379     size_t              m_maxFieldSets;
00380     SeriesType          m_seriesType;
00381     RecordFilterType    m_recordFilterType;
00382     FieldFilterType     m_fieldFilterType;
00383     PeriodList          m_periodList;
00384     uint8_t             m_delayPeriod;
00385     uint8_t             m_specifiedInterval;
00386 };
00387
00388 // ---------------------------------------------------------------------------------------------------------------------------------
00389 // ---------------------------------------------------------------------------------------------------------------------------------
00390
00394 class TimeSeriesCookie
00395 {
00396 public:
00405     ACTIV_CONTENT_GATEWAY_API_COMMON_API StatusCode Serialize(MessageBuilder &messageBuilder) const;
00406
00415     ACTIV_CONTENT_GATEWAY_API_COMMON_API StatusCode Deserialize(MessageValidator &messageValidator);
00416
00422     ACTIV_CONTENT_GATEWAY_API_COMMON_API const SymbolId &GetSymbolId() const;
00423
00429     ACTIV_CONTENT_GATEWAY_API_COMMON_API const DataPointAddress &GetDataPointAddress() const;
00430
00431 public:
00432     TimeSeriesRequestParameters m_requestParameters;
00433     DataPointAddress            m_dataPointAddress;
00434 };
00435
00436 // ---------------------------------------------------------------------------------------------------------------------------------
00437 // ---------------------------------------------------------------------------------------------------------------------------------
00438
00444 template <typename FIELD_SET_TYPE>
00445 class TimeSeriesResponseParametersTemplate
00446 {
00447 public:
00448     typedef FIELD_SET_TYPE FieldSetList;
00449
00453     ACTIV_CONTENT_GATEWAY_API_COMMON_API void Clear();
00454
00463     ACTIV_CONTENT_GATEWAY_API_COMMON_API StatusCode Serialize(MessageBuilder &messageBuilder) const;
00464
00473     ACTIV_CONTENT_GATEWAY_API_COMMON_API StatusCode Deserialize(MessageValidator &messageValidator);
00474
00475     FieldSetList    m_fieldSetList;
00476 };
00477
00478 #undef ACTIV_DECLARE_CONSTANT_SERIES_TYPE
00479 #undef ACTIV_DECLARE_FLAGS
00480
00481 } // namespace ContentGatewayApi
00482
00483 } // namespace ContentPlatform
00484
00485 } // namespace Activ
00486
00487 #endif // (!defined ACTIV_CONTENT_GATEWAY_API_COMMON_TIME_SERIES_TYPES_H)
Generated on Wed Oct 8 14:01:45 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivFramework

Timeband.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FRAMEWORK_TIMEBAND_H)
00010 #define ACTIV_FRAMEWORK_TIMEBAND_H
00011
00012 #include "ActivMiddleware/ActivFramework/External.h"
00013
00014 #include "ActivMiddleware/ActivBase/IniFileParser.h"
00015 #include "ActivMiddleware/ActivFramework/TimeHelper.h"
00016
00017 #include <bitset>
00018 #include <string>
00019
00020 namespace Activ
00021 {
00022
00026 class Timeband
00027 {
00028 public:
00032     enum EnabledDateFlag
00033     {
00034         ENABLED_DATE_END_TIME,
00035         ENABLED_DATE_START_TIME
00036     };
00037
00038     typedef std::set<Date>  DateSet;
00039     typedef std::bitset<7>  EnabledDaysBitmap;
00040
00046     class Settings
00047     {
00048     public:
00052         ACTIV_FRAMEWORK_API Settings();
00053
00063         ACTIV_FRAMEWORK_API Settings(const Time &startTime, const Time &endTime, const std::string &enabledDaysBitmapString,
00064                                      const EnabledDateFlag enabledDateFlag = ENABLED_DATE_END_TIME, const DateSet &disabledDateSet = DateSet());
00065
00066         /*  @brief  Read settings from an ini file section.
00067          *
00068          *  @param  sectionIterator iterator to an ini file section.
00069          *
00070          *  @retval STATUS_CODE_SUCCESS
00071          *  @retval ...
00072          */
00073         ACTIV_FRAMEWORK_API StatusCode Read(const std::string &keyNamePrefix, const IniFileParser::ConstSectionIterator &sectionIterator);
00074
00075         EnabledDaysBitmap   m_enabledDaysBitmap;
00076         DateSet             m_disabledDateSet;
00077         Time                m_startTime;
00078         Time                m_endTime;
00079         EnabledDateFlag     m_enabledDateFlag;
00080     };
00081
00085     ACTIV_FRAMEWORK_API Timeband();
00086
00092     ACTIV_FRAMEWORK_API Timeband(const Settings &settings);
00093
00103     ACTIV_FRAMEWORK_API Timeband(const Time &startTime, const Time &endTime, const std::string &enabledDaysBitmapString,
00104                                  const EnabledDateFlag enabledDateFlag = ENABLED_DATE_END_TIME, const DateSet &disabledDateSet = DateSet());
00105
00111     ACTIV_FRAMEWORK_API bool IsIn(const DateTime &dateTime) const;
00112
00120     bool IsIn(const LocalTime &localTime) const;
00121
00122     /*  @brief  Read settings from an ini file section.
00123      *
00124      *  @param  sectionIterator iterator to an ini file section.
00125      *
00126      *  @retval STATUS_CODE_SUCCESS
00127      *  @retval ...
00128      */
00129     StatusCode Read(const std::string &keyNamePrefix, const IniFileParser::ConstSectionIterator &sectionIterator);
00130
00136     const Time &GetStartTime() const;
00137
00143     const Time &GetEndTime() const;
00144
00150     ACTIV_FRAMEWORK_API const std::string GetEnabledDaysString() const;
00151
00157     const DateSet &GetDisabledDateSet() const;
00158
00164     EnabledDateFlag GetEnabledDateFlag() const;
00165
00171     void SetStartTime(const Time &startTime);
00172
00178     void SetEndTime(const Time &endTime);
00179
00188     StatusCode SetEnabledDaysString(const std::string &enabledDaysString);
00189
00195     void SetDisabledDateSet(const DateSet &disabledDateSet);
00196
00202     void SetEnabledDateFlag(const EnabledDateFlag enabledDateFlag);
00203
00212     ACTIV_FRAMEWORK_API StatusCode AddDisabledDate(const Date &disabledDate);
00213
00222     ACTIV_FRAMEWORK_API StatusCode RemoveDisabledDate(const Date &disabledDate);
00223
00233     ACTIV_FRAMEWORK_API bool operator==(const Timeband &rhs) const;
00234
00244     ACTIV_FRAMEWORK_API bool operator!=(const Timeband &rhs) const;
00245
00255     ACTIV_FRAMEWORK_API Timeband &operator=(const Timeband &rhs);
00256
00262     ACTIV_FRAMEWORK_API const std::string GetDisabledDateSetString() const;
00263
00269     ACTIV_FRAMEWORK_API const std::string GetEnabledDateFlagString() const;
00270
00276     ACTIV_FRAMEWORK_API const std::string ToString() const;
00277
00283     ACTIV_FRAMEWORK_API const std::string ToLogString() const;
00284
00291     ACTIV_FRAMEWORK_API static StatusCode ConvertStringToEnabledDaysBitmap(const std::string enabledDaysBitmapString,
00292                                                                            EnabledDaysBitmap &enabledDaysBitmap);
00293
00294 private:
00300     bool IsEnabledDay(const Date &date) const;
00301
00307     static const std::string &GetDayCharsString();
00308
00309     Settings    m_settings;
00310 };
00311
00312 // ---------------------------------------------------------------------------------------------------------------------------------
00313
00314 inline bool Timeband::IsIn(const LocalTime &localTime) const
00315 {
00316     return IsIn(localTime.Get());
00317 }
00318
00319 // ---------------------------------------------------------------------------------------------------------------------------------
00320
00321 inline StatusCode Timeband::Read(const std::string &keyNamePrefix, const IniFileParser::ConstSectionIterator &sectionIterator)
00322 {
00323     return m_settings.Read(keyNamePrefix, sectionIterator);
00324 }
00325
00326 // ---------------------------------------------------------------------------------------------------------------------------------
00327
00328 inline const Time &Timeband::GetStartTime() const
00329 {
00330     return m_settings.m_startTime;
00331 }
00332
00333 // ---------------------------------------------------------------------------------------------------------------------------------
00334
00335 inline const Time &Timeband::GetEndTime() const
00336 {
00337     return m_settings.m_endTime;
00338 }
00339
00340 // ---------------------------------------------------------------------------------------------------------------------------------
00341
00342 inline const Timeband::DateSet &Timeband::GetDisabledDateSet() const
00343 {
00344     return m_settings.m_disabledDateSet;
00345 }
00346
00347 // ---------------------------------------------------------------------------------------------------------------------------------
00348
00349 inline Timeband::EnabledDateFlag Timeband::GetEnabledDateFlag() const
00350 {
00351     return m_settings.m_enabledDateFlag;
00352 }
00353
00354 // ---------------------------------------------------------------------------------------------------------------------------------
00355
00356 inline void Timeband::SetStartTime(const Time &startTime)
00357 {
00358     m_settings.m_startTime = startTime;
00359 }
00360
00361 // ---------------------------------------------------------------------------------------------------------------------------------
00362
00363 inline void Timeband::SetEndTime(const Time &endTime)
00364 {
00365     m_settings.m_endTime = endTime;
00366 }
00367
00368 // ---------------------------------------------------------------------------------------------------------------------------------
00369
00370 inline StatusCode Timeband::SetEnabledDaysString(const std::string &enabledDaysString)
00371 {
00372     return ConvertStringToEnabledDaysBitmap(enabledDaysString, m_settings.m_enabledDaysBitmap);
00373 }
00374
00375 // ---------------------------------------------------------------------------------------------------------------------------------
00376
00377 inline void Timeband::SetDisabledDateSet(const DateSet &disabledDateSet)
00378 {
00379     m_settings.m_disabledDateSet = disabledDateSet;
00380 }
00381
00382 // ---------------------------------------------------------------------------------------------------------------------------------
00383
00384 inline void Timeband::SetEnabledDateFlag(const EnabledDateFlag enabledDateFlag)
00385 {
00386     m_settings.m_enabledDateFlag = enabledDateFlag;
00387 }
00388
00389 } // namespace Activ
00390
00391 #endif // (!defined ACTIV_FRAMEWORK_TIMEBAND_H)
Generated on Wed Oct 8 14:01:48 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

Timeout.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_BASE_TIMEOUT_H)
00010 #define ACTIV_BASE_TIMEOUT_H
00011
00012 #include "ActivMiddleware/ActivBase/External.h"
00013
00014 namespace Activ
00015 {
00016
00020 class Timeout
00021 {
00022 public:
00028     ACTIV_BASE_EXPORTED_API Timeout(TimeoutPeriod maxTimeout);
00029
00038     ACTIV_BASE_EXPORTED_API bool operator()(TimeoutPeriod sleepPeriod = 500);
00039
00045     ACTIV_BASE_EXPORTED_API TimeoutPeriod GetPeriodLeft() const;
00046
00052     ACTIV_BASE_INLINE_API static Timeout &GetInfinite();
00053
00059     ACTIV_BASE_INLINE_API static Timeout &GetZero();
00060
00061 private:
00062     TimeoutPeriod   m_timeout;
00063
00064     ACTIV_BASE_EXPORTED_API static Timeout  m_infinite;
00065     ACTIV_BASE_EXPORTED_API static Timeout  m_zero;
00066 };
00067
00068 // ---------------------------------------------------------------------------------------------------------------------------------
00069
00070 inline Timeout &Timeout::GetInfinite()
00071 {
00072     return m_infinite;
00073 }
00074
00075 // ---------------------------------------------------------------------------------------------------------------------------------
00076
00077 inline Timeout &Timeout::GetZero()
00078 {
00079     return m_zero;
00080 }
00081
00082 } // namespace Activ
00083
00084 #endif // (!defined ACTIV_BASE_TIMEOUT_H)
Generated on Wed Oct 8 14:01:47 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivFramework

TimerServiceApi.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FRAMEWORK_TIMER_SERVICE_API_H)
00010 #define ACTIV_FRAMEWORK_TIMER_SERVICE_API_H
00011
00012 #include "ActivMiddleware/ActivFramework/External.h"
00013 #include "ActivMiddleware/ActivFramework/TimeHelper.h"
00014
00015 namespace Activ
00016 {
00017
00018 class Component;
00019 class Time;
00020 class Date;
00021 class DateTime;
00022
00023 // ---------------------------------------------------------------------------------------------------------------------------------
00024
00028 class TimerServiceApi
00029 {
00030 public:
00042     ACTIV_FRAMEWORK_API static StatusCode SetTimer(const Component &component, const BaseTime &time, Address::Proxy timerAddress);
00043
00057     ACTIV_FRAMEWORK_API static StatusCode SetTimer(const Component &component, const BaseTime::Duration &duration,
00058         Address::Proxy timerAddress);
00059
00071     ACTIV_FRAMEWORK_API static StatusCode SetTimer(const Component &component, const BaseTime &time,
00072         const BaseTime::Duration &duration, Address::Proxy timerAddress);
00073
00084     ACTIV_FRAMEWORK_API static StatusCode CancelTimer(const Component &component, Address &timerAddress);
00085
00094     ACTIV_FRAMEWORK_API static StatusCode CancelTimers(const Component &component);
00095
00105     ACTIV_FRAMEWORK_API static StatusCode GetCurrentUtcDate(const Component &component, Date &date);
00106
00117     ACTIV_FRAMEWORK_API static StatusCode GetCurrentUtcTime(const Component &component, Time &time,
00118         const bool shouldSetMilliseconds = false);
00119
00130     ACTIV_FRAMEWORK_API static StatusCode GetCurrentUtcDateTime(const Component &component, DateTime &dateTime,
00131         const bool shouldSetMilliseconds = false);
00132
00142     ACTIV_FRAMEWORK_API static StatusCode GetCurrentLocalDate(const Component &component, Date &date);
00143
00154     ACTIV_FRAMEWORK_API static StatusCode GetCurrentLocalTime(const Component &component, Time &time,
00155         const bool shouldSetMilliseconds = false);
00156
00167     ACTIV_FRAMEWORK_API static StatusCode GetCurrentLocalDateTime(const Component &component, DateTime &dateTime,
00168         const bool shouldSetMilliseconds = false);
00169
00182     ACTIV_FRAMEWORK_API static StatusCode AdjustSystemTime(const Component &component, const int32_t milliseconds);
00183 };
00184
00185 } // namespace Activ
00186
00187 #endif // (!defined ACTIV_FRAMEWORK_TIMER_SERVICE_API_H)
Generated on Wed Oct 8 14:01:48 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivFieldTypes

UInt.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FIELD_TYPES_UINT_H)
00010 #define ACTIV_FIELD_TYPES_UINT_H
00011
00012 #include "ActivMiddleware/ActivFieldTypes/External.h"
00013 #include "ActivMiddleware/ActivFieldTypes/IFieldType.h"
00014
00015 #include "ActivMiddleware/ActivBase/StatusCodeException.h"
00016 #include "ActivMiddleware/Misc/MemoryHelper.h"
00017
00018 namespace Activ
00019 {
00020
00021 class MessageBuilder;
00022 class MessageValidator;
00023
00024 class Rational;
00025 class SInt;
00026
00027 // ---------------------------------------------------------------------------------------------------------------------------------
00028
00032 class UInt : public IFieldType
00033 {
00034 public:
00035     static const FieldType FIELD_TYPE = FIELD_TYPE_UINT;
00036
00037     using IFieldType::FromString;
00038     using IFieldType::Serialize;
00039     using IFieldType::SerializeBody;
00040     using IFieldType::SerializeLengthAndBody;
00041     using IFieldType::Deserialize;
00042     using IFieldType::DeserializeBody;
00043     using IFieldType::DeserializeLengthAndBody;
00044
00048     UInt();
00049
00055     UInt(const uint64_t value);
00056
00060     virtual ~UInt();
00061
00071     bool operator==(const UInt &rhs) const;
00072
00082     bool operator!=(const UInt &rhs) const;
00083
00093     bool operator<(const UInt &rhs) const;
00094
00104     bool operator<=(const UInt &rhs) const;
00105
00115     bool operator>(const UInt &rhs) const;
00116
00126     bool operator>=(const UInt &rhs) const;
00127
00137     UInt& operator+=(const UInt &rhs);
00138
00148     UInt& operator-=(const UInt &rhs);
00149
00159     UInt& operator*=(const UInt &rhs);
00160
00170     UInt& operator/=(const UInt &rhs);
00171
00177     ACTIV_FIELD_TYPES_API operator const Rational() const;
00178
00184     ACTIV_FIELD_TYPES_API operator const SInt() const;
00185
00193     StatusCode Set(const uint64_t value);
00194
00203     StatusCode Get(uint64_t &value) const;
00204
00212     uint64_t Get() const;
00213
00223     ACTIV_FIELD_TYPES_API StatusCode Add(const UInt &rhs);
00224
00234     ACTIV_FIELD_TYPES_API StatusCode Subtract(const UInt &rhs);
00235
00245     ACTIV_FIELD_TYPES_API StatusCode Multiply(const UInt &rhs);
00246
00256     ACTIV_FIELD_TYPES_API StatusCode Divide(const UInt &rhs);
00257
00258     virtual void Reset();
00259     virtual void Clear();
00260
00269     ACTIV_FIELD_TYPES_API StatusCode Compare(const UInt &rhs, int &result) const;
00270
00271     ACTIV_FIELD_TYPES_API virtual StatusCode Compare(const void * const pRhsSerializedBody, const size_t rhsSerializedBodyLength, int &result) const;
00272     ACTIV_FIELD_TYPES_API virtual StatusCode Convert(const IFieldType * const pIFieldType);
00273     ACTIV_FIELD_TYPES_API virtual std::string ToString() const;
00274     ACTIV_FIELD_TYPES_API virtual StatusCode FromString(MessageValidator &messageValidator);
00275     ACTIV_FIELD_TYPES_API virtual std::string GetFromStringFormat() const;
00276     ACTIV_FIELD_TYPES_API virtual StatusCode Serialize(MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength) const;
00277     ACTIV_FIELD_TYPES_API virtual StatusCode SerializeBody(void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength) const;
00278     ACTIV_FIELD_TYPES_API virtual StatusCode SerializeLengthAndBody(MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength = MAX_SERIALIZED_BODY_LENGTH_UNDEFINED) const;
00279     ACTIV_FIELD_TYPES_API virtual StatusCode Deserialize(MessageValidator &messageValidator, const size_t maxSerializedBodyLength);
00280     ACTIV_FIELD_TYPES_API virtual StatusCode DeserializeBody(const void * const pSerializedBody, const size_t serializedBodyLength);
00281     ACTIV_FIELD_TYPES_API virtual StatusCode DeserializeLengthAndBody(MessageValidator &messageValidator, const size_t maxSerializedBodyLength = MAX_SERIALIZED_BODY_LENGTH_UNDEFINED);
00282     virtual size_t GetSerializedLength() const;
00283     virtual size_t GetSerializedBodyLength() const;
00284     ACTIV_FIELD_TYPES_API virtual StatusCode IsDifferent(const void * const pRhsSerializedBody, const size_t rhsSerializedBodyLength, bool &isDifferent) const;
00285
00293     static size_t GetMaxSerializedLength(const size_t size);
00294
00302     static size_t GetMaxSerializedBodyLength(const size_t size);
00303
00316     ACTIV_FIELD_TYPES_API static StatusCode Compare(const void * const pLhsSerializedBody, const size_t lhsSerializedBodyLength, const void * const pRhsSerializedBody, const size_t rhsSerializedBodyLength, int &result);
00317
00329     ACTIV_FIELD_TYPES_API static StatusCode ValidateSerializedLengthAndBody(MessageValidator &messageValidator, size_t &serializedBodyOffset, size_t &serializedBodyLength);
00330
00338     static bool IsValidSerializedBodyLength(const size_t serializedBodyLength);
00339
00340 private:
00346     size_t GetCompressedValueSize() const;
00347
00357     template <typename T> StatusCode SerializeBody(void *pSerializedBody) const;
00358
00371     template <typename T> StatusCode DeserializeBody(const void * const pSerializedBody);
00372
00373     uint64_t    m_value;
00374 };
00375
00376 // ---------------------------------------------------------------------------------------------------------------------------------
00377
00378 inline UInt::UInt() :
00379     IFieldType(FIELD_TYPE)
00380 {
00381     m_isInitialized = false;
00382 }
00383
00384 // ---------------------------------------------------------------------------------------------------------------------------------
00385
00386 inline UInt::UInt(const uint64_t value) :
00387     IFieldType(FIELD_TYPE)
00388 {
00389     (void) Set(value);
00390 }
00391
00392 // ---------------------------------------------------------------------------------------------------------------------------------
00393
00394 inline UInt::~UInt()
00395 {
00396 }
00397
00398 // ---------------------------------------------------------------------------------------------------------------------------------
00399
00400 inline bool UInt::operator==(const UInt &rhs) const
00401 {
00402     int result;
00403     ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, Compare(rhs, result));
00404
00405     return (0 == result);
00406 }
00407
00408 // ---------------------------------------------------------------------------------------------------------------------------------
00409
00410 inline bool UInt::operator!=(const UInt &rhs) const
00411 {
00412     return !((*this) == rhs);
00413 }
00414
00415 // ---------------------------------------------------------------------------------------------------------------------------------
00416
00417 inline bool UInt::operator<(const UInt &rhs) const
00418 {
00419     int result;
00420     ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, Compare(rhs, result));
00421
00422     return (result < 0);
00423 }
00424
00425 // ---------------------------------------------------------------------------------------------------------------------------------
00426
00427 inline bool UInt::operator<=(const UInt &rhs) const
00428 {
00429     return !((*this) > rhs);
00430 }
00431
00432 // ---------------------------------------------------------------------------------------------------------------------------------
00433
00434 inline bool UInt::operator>(const UInt &rhs) const
00435 {
00436     int result;
00437     ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, Compare(rhs, result));
00438
00439     return (result > 0);
00440 }
00441
00442 // ---------------------------------------------------------------------------------------------------------------------------------
00443
00444 inline bool UInt::operator>=(const UInt &rhs) const
00445 {
00446     return !((*this) < rhs);
00447 }
00448
00449 // ---------------------------------------------------------------------------------------------------------------------------------
00450
00451 inline UInt& UInt::operator+=(const UInt &rhs)
00452 {
00453     ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, Add(rhs));
00454
00455     return (*this);
00456 }
00457
00458 // ---------------------------------------------------------------------------------------------------------------------------------
00459
00460 inline UInt& UInt::operator-=(const UInt &rhs)
00461 {
00462     ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, Subtract(rhs));
00463
00464     return (*this);
00465 }
00466
00467 // ---------------------------------------------------------------------------------------------------------------------------------
00468
00469 inline UInt& UInt::operator*=(const UInt &rhs)
00470 {
00471     ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, Multiply(rhs));
00472
00473     return (*this);
00474 }
00475
00476 // ---------------------------------------------------------------------------------------------------------------------------------
00477
00478 inline UInt& UInt::operator/=(const UInt &rhs)
00479 {
00480     ACTIV_THROW_RESULT_IF(STATUS_CODE_SUCCESS, !=, Divide(rhs));
00481
00482     return (*this);
00483 }
00484
00485 // ---------------------------------------------------------------------------------------------------------------------------------
00486
00487 inline StatusCode UInt::Set(const uint64_t value)
00488 {
00489     m_value = value;
00490     m_isInitialized = true;
00491
00492     return STATUS_CODE_SUCCESS;
00493 }
00494
00495 // ---------------------------------------------------------------------------------------------------------------------------------
00496
00497 inline StatusCode UInt::Get(uint64_t &value) const
00498 {
00499     if (!IsInitialized())
00500         return STATUS_CODE_NOT_INITIALIZED;
00501
00502     value = m_value;
00503
00504     return STATUS_CODE_SUCCESS;
00505 }
00506
00507 // ---------------------------------------------------------------------------------------------------------------------------------
00508
00509 inline uint64_t UInt::Get() const
00510 {
00511     if (!IsInitialized())
00512         ACTIV_THROW(StatusCodeException, STATUS_CODE_NOT_INITIALIZED);
00513
00514     return m_value;
00515 }
00516
00517 // ---------------------------------------------------------------------------------------------------------------------------------
00518
00519 inline void UInt::Reset()
00520 {
00521     m_isInitialized = false;
00522 }
00523
00524 // ---------------------------------------------------------------------------------------------------------------------------------
00525
00526 inline void UInt::Clear()
00527 {
00528     m_isInitialized = false;
00529 }
00530
00531 // ---------------------------------------------------------------------------------------------------------------------------------
00532
00533 inline size_t UInt::GetSerializedLength() const
00534 {
00535     return (IsInitialized() ? GetMaxSerializedLength(GetCompressedValueSize()) : 0);
00536 }
00537
00538 // ---------------------------------------------------------------------------------------------------------------------------------
00539
00540 inline size_t UInt::GetSerializedBodyLength() const
00541 {
00542     return (IsInitialized() ? GetMaxSerializedBodyLength(GetCompressedValueSize()) : 0);
00543 }
00544
00545 // ---------------------------------------------------------------------------------------------------------------------------------
00546
00547 inline size_t UInt::GetMaxSerializedLength(const size_t size)
00548 {
00549     return GetMaxSerializedBodyLength(size);
00550 }
00551
00552 // ---------------------------------------------------------------------------------------------------------------------------------
00553
00554 inline size_t UInt::GetMaxSerializedBodyLength(const size_t size)
00555 {
00556     return size;
00557 }
00558
00559 // ---------------------------------------------------------------------------------------------------------------------------------
00560
00561 inline bool UInt::IsValidSerializedBodyLength(const size_t serializedBodyLength)
00562 {
00563     return ((GetMaxSerializedBodyLength(sizeof(uint64_t)) == serializedBodyLength) || (GetMaxSerializedBodyLength(sizeof(uint32_t)) == serializedBodyLength) || (GetMaxSerializedBodyLength(sizeof(uint16_t)) == serializedBodyLength) || (GetMaxSerializedBodyLength(sizeof(uint8_t)) == serializedBodyLength));
00564 }
00565
00566 // ---------------------------------------------------------------------------------------------------------------------------------
00567
00568 inline size_t UInt::GetCompressedValueSize() const
00569 {
00570     if (m_value <= UINT8_MAX)
00571         return sizeof(uint8_t);
00572
00573     if (m_value <= UINT16_MAX)
00574         return sizeof(uint16_t);
00575
00576     if (m_value <= UINT32_MAX)
00577         return sizeof(uint32_t);
00578
00579     return sizeof(uint64_t);
00580 }
00581
00582 // ---------------------------------------------------------------------------------------------------------------------------------
00583
00584 template <typename T> inline StatusCode UInt::SerializeBody(void *pSerializedBody) const
00585 {
00586     CopyValueToUnalignedPointer(pSerializedBody, HostToLittleEndianOrder(static_cast<T>(m_value)));
00587
00588     return STATUS_CODE_SUCCESS;
00589 }
00590
00591 // ---------------------------------------------------------------------------------------------------------------------------------
00592
00593 template <typename T> inline StatusCode UInt::DeserializeBody(const void * const pSerializedBody)
00594 {
00595     return Set(static_cast<uint64_t>(LittleEndianToHostOrder(GetValueFromUnalignedPointer<T>(pSerializedBody))));
00596 }
00597
00598 // ---------------------------------------------------------------------------------------------------------------------------------
00599 // ---------------------------------------------------------------------------------------------------------------------------------
00600
00611 inline const UInt operator+(const UInt &lhs, const UInt &rhs)
00612 {
00613     return UInt(lhs) += rhs;
00614 }
00615
00616 // ---------------------------------------------------------------------------------------------------------------------------------
00617
00628 inline const UInt operator-(const UInt &lhs, const UInt &rhs)
00629 {
00630     return UInt(lhs) -= rhs;
00631 }
00632
00633 // ---------------------------------------------------------------------------------------------------------------------------------
00634 // ---------------------------------------------------------------------------------------------------------------------------------
00635
00646 inline const UInt operator*(const UInt &lhs, const UInt &rhs)
00647 {
00648     return UInt(lhs) *= rhs;
00649 }
00650
00651 // ---------------------------------------------------------------------------------------------------------------------------------
00652
00663 inline const UInt operator/(const UInt &lhs, const UInt &rhs)
00664 {
00665     return UInt(lhs) /= rhs;
00666 }
00667
00668 // ---------------------------------------------------------------------------------------------------------------------------------
00669 // ---------------------------------------------------------------------------------------------------------------------------------
00670
00674 template<>
00675 class FieldTypeToClass<FIELD_TYPE_UINT>
00676 {
00677 public:
00678     typedef UInt Type;
00679 };
00680
00681 } // namespace Activ
00682
00683 #endif // (!defined ACTIV_FIELD_TYPES_UINT_H)
Generated on Wed Oct 8 14:01:48 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivFramework

UdpComponent.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FRAMEWORK_UDP_COMPONENT_H)
00010 #define ACTIV_FRAMEWORK_UDP_COMPONENT_H
00011
00012 #include "ActivMiddleware/ActivFramework/External.h"
00013 #include "ActivMiddleware/ActivFramework/Component.h"
00014
00015 namespace Activ
00016 {
00017
00021 class UdpComponent : public Component
00022 {
00023 public:
00037     ACTIV_FRAMEWORK_API UdpComponent(Application &application, ManagedEndPoint &managedEndPoint,
00038                                      const std::string &name = Port::anonymousName, IHeap * const pHeap = 0,
00039                                      const std::string &componentId = defaultComponentId);
00040
00044     ACTIV_FRAMEWORK_API ~UdpComponent();
00045
00059     ACTIV_FRAMEWORK_API StatusCode CreateSocket(const std::string &localAddress,
00060                                                 const uint16_t localPort, const uint16_t maxRxSize,
00061                                                 Address &socketAddress, IHeap * const pHeap = 0) const;
00062
00070     ACTIV_FRAMEWORK_API StatusCode Read(const Address &socketAddress) const;
00071
00081     ACTIV_FRAMEWORK_API StatusCode Connect(const Address &socketAddress,
00082                                            const std::string &remoteAddressString,
00083                                            const uint16_t remotePort) const;
00084
00092     ACTIV_FRAMEWORK_API StatusCode Disconnect(const Address &socketAddress) const;
00093
00105     ACTIV_FRAMEWORK_API StatusCode Close(const Address &socketAddress, const bool gracefully = false) const;
00106
00116     ACTIV_FRAMEWORK_API StatusCode JoinMulticastGroup(const Address &socketAddress,
00117                                                       const std::string &multicastGroupString,
00118                                                       const std::string &interfaceAddressString) const;
00119
00129     ACTIV_FRAMEWORK_API StatusCode LeaveMulticastGroup(const Address &socketAddress,
00130                                                        const std::string &multicastGroupString,
00131                                                        const std::string &interfaceAddressString) const;
00132
00141     ACTIV_FRAMEWORK_API StatusCode SetMulticastTxInterface(const Address &socketAddress,
00142                                                            const std::string &interfaceAddressString) const;
00143
00152     ACTIV_FRAMEWORK_API StatusCode SetMulticastTtl(const Address &socketAddress, const int ttl) const;
00153
00162     ACTIV_FRAMEWORK_API StatusCode SetUnicastTtl(const Address &socketAddress, const int ttl) const;
00163
00172     ACTIV_FRAMEWORK_API StatusCode SetRxBufferSize(const Address &socketAddress, const int size) const;
00173
00182     ACTIV_FRAMEWORK_API StatusCode SetTxBufferSize(const Address &socketAddress, const int size) const;
00183
00192     ACTIV_FRAMEWORK_API StatusCode SetMulticastLoopback(const Address &socketAddress, const bool enable) const;
00193
00203     ACTIV_FRAMEWORK_API StatusCode GetSocketHandle(const Address &socketAddress, SOCKET &socket) const;
00204
00213     ACTIV_FRAMEWORK_API StatusCode PostData(const Address &socketAddress, HeapMessage &heapMessage) const;
00214
00224     ACTIV_FRAMEWORK_API StatusCode PostData(const Address &socketAddress, const void *pData, const size_t dataLength) const;
00225
00226 protected:
00227     ACTIV_FRAMEWORK_API virtual StatusCode OnMessage(HeapMessage &message);
00228
00232     ACTIV_FRAMEWORK_API virtual void OnSocketError(const Address &socketAddress);
00233
00237     ACTIV_FRAMEWORK_API virtual void OnSocketClose(const Address &socketAddress);
00238 };
00239
00240 } // namespace Activ
00241
00242 #endif // (!defined ACTIV_FRAMEWORK_UDP_COMPONENT_H)
Generated on Wed Oct 8 14:01:48 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivIp

UdpSocket.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_IP_UDP_SOCKET_H)
00010 #define ACTIV_IP_UDP_SOCKET_H
00011
00012 #include "External.h"
00013
00014 #if (defined ACTIV_PLATFORM_WINDOWS)
00015 #include "Windows/UdpSocket.h"
00016 #elif (defined ACTIV_PLATFORM_POSIX)
00017 #include "Posix/UdpSocket.h"
00018 #else
00019 #error No UdpSocket.h for this platform yet.
00020 #endif
00021
00022 #endif // (!defined ACTIV_IP_UDP_SOCKET_H)
Generated on Wed Oct 8 14:01:48 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivFramework

UiComponent.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FRAMEWORK_UI_COMPONENT_H)
00010 #define ACTIV_FRAMEWORK_UI_COMPONENT_H
00011
00012 #include "ActivMiddleware/ActivFramework/External.h"
00013 #include "ActivMiddleware/ActivFramework/Component.h"
00014 #include "ActivMiddleware/ActivFramework/Application.h"
00015
00016 namespace Activ
00017 {
00018
00019 class UiUser;
00020
00021 // ---------------------------------------------------------------------------------------------------------------------------------
00022
00028 class UiComponent : public Component
00029 {
00030 public:
00034     enum Type
00035     {
00036         TYPE_DEFAULT,
00037         TYPE_MAIN,
00038         TYPE_MIDDLEWARE
00039     };
00040
00053     ACTIV_FRAMEWORK_API UiComponent(Application &application, ManagedEndPoint &managedEndPoint, const std::string &componentName,
00054                                     const Type type = TYPE_DEFAULT, const std::string &uiServiceName = Application::GetUiServiceName(),
00055                                     IHeap * const pHeap = 0);
00056
00060     ACTIV_FRAMEWORK_API ~UiComponent();
00061
00069     virtual void Run(UiUser &uiUser) = 0;
00070
00076     ACTIV_FRAMEWORK_API const std::string &GetUiServiceName() const;
00077
00078 private:
00085     StatusCode Register() const;
00086
00093     StatusCode Deregister() const;
00094
00095     ACTIV_FRAMEWORK_API virtual StatusCode OnRequest(HeapMessage &request);
00096
00102     void ProcessNewUserRequest(HeapMessage &request);
00103
00104     const Type          m_type;
00105     const std::string   m_uiServiceName;
00106 };
00107
00108 } // namespace Activ
00109
00110 #endif // (!defined ACTIV_FRAMEWORK_UI_COMPONENT_H)
Generated on Wed Oct 8 14:01:48 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivFramework

UiIo.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FRAMEWORK_UI_IO_H)
00010 #define ACTIV_FRAMEWORK_UI_IO_H
00011
00012 #include "ActivMiddleware/ActivFramework/External.h"
00013 #include "ActivMiddleware/ActivBase/ConsoleWindow.h"
00014
00015 #include "boost/format.hpp"
00016 #include "boost/bind.hpp"
00017
00018 #include <map>
00019 #include <vector>
00020 #include <iostream>
00021
00022 namespace Activ
00023 {
00024
00025 class UiUser;
00026 class UiMenu;
00027
00028 // ---------------------------------------------------------------------------------------------------------------------------------
00029
00033 class UiIo : private boost::noncopyable
00034 {
00035 public:
00036     typedef std::map<std::string, std::string> CompletionList;
00037     typedef std::vector<CompletionList::const_iterator> CompletionIteratorList;
00038
00039     class StaticCompletionHelper;
00040     class DynamicCompletionHelper;
00041
00048     class CompletionHelper
00049     {
00050     public:
00056         ACTIV_FRAMEWORK_API CompletionHelper(const bool isCaseSensitive);
00057
00061         ACTIV_FRAMEWORK_API virtual ~CompletionHelper();
00062
00068         ACTIV_FRAMEWORK_API void AddCompletion(const std::string &completion);
00069
00070     private:
00077         virtual void PopulateCompletionList(const std::string &partialInput) = 0;
00078
00079         const bool      m_isCaseSensitive;
00080         CompletionList  m_completionList;
00081
00082         friend class UiIo;
00083         friend class StaticCompletionHelper;
00084         friend class DynamicCompletionHelper;
00085     };
00086
00090     class StaticCompletionHelper : public CompletionHelper
00091     {
00092     public:
00100         template<typename T>
00101         StaticCompletionHelper(const T &begin, const T &end, const bool isCaseSensitive);
00102
00103     private:
00104         ACTIV_FRAMEWORK_API virtual void PopulateCompletionList(const std::string &partialInput);
00105     };
00106
00110     class DynamicCompletionHelper : public CompletionHelper
00111     {
00112     public:
00118         ACTIV_FRAMEWORK_API DynamicCompletionHelper(const bool isCaseSensitive);
00119
00120     protected:
00128         virtual void OnPopulateCompletionList(const std::string &partialInput) = 0;
00129
00130     private:
00131         ACTIV_FRAMEWORK_API virtual void PopulateCompletionList(const std::string &partialInput);
00132     };
00133
00137     class Columnizer
00138     {
00139     public:
00150         ACTIV_FRAMEWORK_API Columnizer(const UiIo &uiIo, const size_t numberOfLeadingSpaces, const size_t numberOfItems,
00151                                        const size_t longestItemWidth);
00152
00153         size_t  m_columnSpacing;
00154         size_t  m_numberOfColumns;
00155         size_t  m_numberOfLines;
00156     };
00157
00161     class Attribute
00162     {
00163     public:
00171         ACTIV_FRAMEWORK_API Attribute operator|(const Attribute &attribute) const;
00172
00180         ACTIV_FRAMEWORK_API Attribute &operator|(const Attribute &attribute);
00181
00187         ACTIV_FRAMEWORK_API operator std::string() const;
00188
00194         ACTIV_FRAMEWORK_API std::string ToString() const;
00195
00196     private:
00202         Attribute(const uint32_t type);
00203
00204         std::string m_sequence;
00205
00206         friend class UiIo;
00207     };
00208
00217     ACTIV_FRAMEWORK_API StatusCode PutString(const std::string &str) const;
00218
00227     ACTIV_FRAMEWORK_API StatusCode PutString(const boost::format &formatter) const;
00228
00238     ACTIV_FRAMEWORK_API StatusCode PutString(const char * const format, ...) const;
00239
00249     ACTIV_FRAMEWORK_API StatusCode PutStringV(const char * const format, std::va_list args) const;
00250
00262     ACTIV_FRAMEWORK_API StatusCode PutStringList(const std::vector<std::string> &stringList,
00263         const size_t numberOfLeadingSpaces) const;
00264
00278     ACTIV_FRAMEWORK_API StatusCode GetString(const std::string &prompt, std::string &str,
00279         const bool isInitializedWithDefault = false, const TimeoutPeriod timeout = ACTIV_WAIT_INFINITE) const;
00280
00295     ACTIV_FRAMEWORK_API StatusCode GetString(const std::string &prompt, CompletionHelper &completionHelper, std::string &str,
00296         const bool isInitializedWithDefault = false, const TimeoutPeriod timeout = ACTIV_WAIT_INFINITE) const;
00297
00313     ACTIV_FRAMEWORK_API StatusCode GetString(const std::string &prompt, const byte_t lower, const byte_t upper, std::string &str,
00314         const bool isInitializedWithDefault = false, const TimeoutPeriod timeout = ACTIV_WAIT_INFINITE) const;
00315
00329     ACTIV_FRAMEWORK_API StatusCode GetChar(const std::string &prompt, char &ch, const bool isInitializedWithDefault = false,
00330         const TimeoutPeriod timeout = ACTIV_WAIT_INFINITE) const;
00331
00346     ACTIV_FRAMEWORK_API StatusCode GetChar(const std::string &prompt, const std::string &validChars, char &ch,
00347         const bool isInitializedWithDefault = false, const TimeoutPeriod timeout = ACTIV_WAIT_INFINITE) const;
00348
00362     template<typename T>
00363     ACTIV_TEMPLATE_API(ACTIV_FRAMEWORK_API) StatusCode GetUnsignedIntegral(const std::string &prompt, T &value,
00364         const bool isInitializedWithDefault = false, const TimeoutPeriod timeout = ACTIV_WAIT_INFINITE) const;
00365
00381     template<typename T>
00382     ACTIV_TEMPLATE_API(ACTIV_FRAMEWORK_API) StatusCode GetUnsignedIntegral(const std::string &prompt, const uint64_t lower,
00383         const uint64_t upper, T &value, const bool isInitializedWithDefault = false,
00384         const TimeoutPeriod timeout = ACTIV_WAIT_INFINITE) const;
00385
00399     template<typename T>
00400     ACTIV_TEMPLATE_API(ACTIV_FRAMEWORK_API) StatusCode GetSignedIntegral(const std::string &prompt, T &value,
00401         const bool isInitializedWithDefault = false, const TimeoutPeriod timeout = ACTIV_WAIT_INFINITE) const;
00402
00418     template<typename T>
00419     ACTIV_TEMPLATE_API(ACTIV_FRAMEWORK_API) StatusCode GetSignedIntegral(const std::string &prompt, const int64_t lower,
00420         const int64_t upper, T &value, const bool isInitializedWithDefault = false,
00421         const TimeoutPeriod timeout = ACTIV_WAIT_INFINITE) const;
00422
00436     template<typename T>
00437     ACTIV_TEMPLATE_API(ACTIV_FRAMEWORK_API) StatusCode GetFieldType(const std::string &prompt, T &value,
00438         const bool isInitializedWithDefault = false, const TimeoutPeriod timeout = ACTIV_WAIT_INFINITE) const;
00439
00453     ACTIV_FRAMEWORK_API StatusCode GetAddress(const std::string &prompt, Address &address,
00454         const bool isInitializedWithDefault = false, const TimeoutPeriod timeout = ACTIV_WAIT_INFINITE) const;
00455
00467     ACTIV_FRAMEWORK_API StatusCode GetConfirmation(const std::string &prompt, const bool positiveDefault = false,
00468         const TimeoutPeriod timeout = ACTIV_WAIT_INFINITE) const;
00469
00480     ACTIV_FRAMEWORK_API StatusCode GetRandomConfirmation(const std::string &prompt,
00481         const TimeoutPeriod timeout = ACTIV_WAIT_INFINITE) const;
00482
00495     ACTIV_FRAMEWORK_API StatusCode EnableDisable(const std::string &prompt, bool &option, const bool positiveDefault = false,
00496         const TimeoutPeriod timeout = ACTIV_WAIT_INFINITE) const;
00497
00511     ACTIV_FRAMEWORK_API StatusCode GetIpAddress(const std::string &prompt, IpAddress &ipAddress,
00512         const bool isInitializedWithDefault = false, const TimeoutPeriod timeout = ACTIV_WAIT_INFINITE) const;
00513
00529     ACTIV_FRAMEWORK_API StatusCode GetFileName(const std::string &prompt, std::string &fileName,
00530         const bool isInitializedWithDefault = false, const TimeoutPeriod timeout = ACTIV_WAIT_INFINITE) const;
00531
00539     ACTIV_FRAMEWORK_API void GetWindowSize(ConsoleWindow::Coord &windowSize) const;
00540
00546     ACTIV_FRAMEWORK_API const Address &GetUiUserAddress() const;
00547
00548     ACTIV_FRAMEWORK_API static const Attribute Normal;
00549     ACTIV_FRAMEWORK_API static const Attribute Bold;
00550     ACTIV_FRAMEWORK_API static const Attribute Underscore;
00551     ACTIV_FRAMEWORK_API static const Attribute Blink;
00552     ACTIV_FRAMEWORK_API static const Attribute Reverse;
00553     ACTIV_FRAMEWORK_API static const Attribute Concealed;
00554
00555     ACTIV_FRAMEWORK_API static const Attribute BlackFg;
00556     ACTIV_FRAMEWORK_API static const Attribute RedFg;
00557     ACTIV_FRAMEWORK_API static const Attribute GreenFg;
00558     ACTIV_FRAMEWORK_API static const Attribute YellowFg;
00559     ACTIV_FRAMEWORK_API static const Attribute BlueFg;
00560     ACTIV_FRAMEWORK_API static const Attribute MagentaFg;
00561     ACTIV_FRAMEWORK_API static const Attribute CyanFg;
00562     ACTIV_FRAMEWORK_API static const Attribute WhiteFg;
00563
00564     ACTIV_FRAMEWORK_API static const Attribute BlackBg;
00565     ACTIV_FRAMEWORK_API static const Attribute RedBg;
00566     ACTIV_FRAMEWORK_API static const Attribute GreenBg;
00567     ACTIV_FRAMEWORK_API static const Attribute YellowBg;
00568     ACTIV_FRAMEWORK_API static const Attribute BlueBg;
00569     ACTIV_FRAMEWORK_API static const Attribute MagentaBg;
00570     ACTIV_FRAMEWORK_API static const Attribute CyanBg;
00571     ACTIV_FRAMEWORK_API static const Attribute WhiteBg;
00572
00573 private:
00580     UiIo(UiMenu &uiMenu, UiUser &uiUser);
00581
00589     void DisplayCompletionChoices(const CompletionIteratorList &completionIteratorList, const size_t maxCompletionLength,
00590         const std::string &partialInput) const;
00591
00599     void DisplayCompletionChoicesColumns(const CompletionIteratorList &completionIteratorList, const size_t maxCompletionLength,
00600         const Columnizer &columnizer) const;
00601
00602     UiMenu  &m_uiMenu;
00603     UiUser  &m_uiUser;
00604
00605     friend class UiMenu;
00606     friend class UiMainComponent;
00607 };
00608
00609 // ---------------------------------------------------------------------------------------------------------------------------------
00610 // ---------------------------------------------------------------------------------------------------------------------------------
00611
00612 template<typename T>
00613 UiIo::StaticCompletionHelper::StaticCompletionHelper(const T &begin, const T &end, const bool isCaseSensitive) :
00614     CompletionHelper(isCaseSensitive)
00615 {
00616     std::for_each(begin, end, boost::bind(&CompletionHelper::AddCompletion, this, _1));
00617 }
00618
00619 // ---------------------------------------------------------------------------------------------------------------------------------
00620 // ---------------------------------------------------------------------------------------------------------------------------------
00621
00633 ACTIV_FRAMEWORK_API std::ostream &operator<<(std::ostream &os, const UiIo::Attribute &attribute);
00634
00635 } // namespace Activ
00636
00637 #endif // (!defined ACTIV_FRAMEWORK_UI_IO_H)
Generated on Wed Oct 8 14:01:48 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivFramework

UiMainComponent.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FRAMEWORK_UI_MAIN_COMPONENT_H)
00010 #define ACTIV_FRAMEWORK_UI_MAIN_COMPONENT_H
00011
00012 #include "ActivMiddleware/ActivFramework/External.h"
00013 #include "ActivMiddleware/ActivFramework/UiComponent.h"
00014 #include "ActivMiddleware/ActivFramework/UiMenu.h"
00015
00016 #include "boost/scoped_ptr.hpp"
00017
00018 namespace Activ
00019 {
00020
00021 class UiIo;
00022 class UiComponentInfo;
00023
00024 // ---------------------------------------------------------------------------------------------------------------------------------
00025
00032 class UiMainComponent : public UiComponent
00033 {
00034 public:
00045     ACTIV_FRAMEWORK_API UiMainComponent(Application &application, ManagedEndPoint &managedEndPoint, const std::string &uiComponentName, const std::string &uiServiceName);
00046
00050     ACTIV_FRAMEWORK_API ~UiMainComponent();
00051
00058     ACTIV_FRAMEWORK_API void UiDisplayAvailableUiComponentsByType(const UiIo &uiIo, const Type type) const;
00059
00066     ACTIV_FRAMEWORK_API StatusCode OnOption(const UiIo &uiIo, const std::string &optionString);
00067
00068 protected:
00072     class Menu : public UiMenu
00073     {
00074     public:
00078         ACTIV_FRAMEWORK_API Menu(UiMainComponent &uiComponent, const std::string &name, UiUser &uiUser);
00079
00080     private:
00081         ACTIV_FRAMEWORK_API virtual void DisplayFooter(const UiIo &uiIo) const;
00082         ACTIV_FRAMEWORK_API virtual StatusCode GetOption(const UiIo &uiIo);
00083
00084         UiMainComponent &m_uiComponent;
00085     };
00086
00087 private:
00088     ACTIV_FRAMEWORK_API virtual StatusCode OnMessage(HeapMessage &request);
00089
00095     void ProcessRegisterComponentMessage(HeapMessage &message);
00096
00102     void ProcessDeregisterComponentMessage(HeapMessage &message);
00103
00107     void ProcessSystemEndPointIdSetMessage(HeapMessage &message, const char * const type);
00108
00109     typedef std::map<std::string, UiComponentInfo> UiComponentMap;
00110
00111     boost::scoped_ptr<UiComponentMap>   m_pUiComponentMap;
00112 };
00113
00114 } // namespace Activ
00115
00116 #endif // (!defined ACTIV_FRAMEWORK_UI_MAIN_COMPONENT_H)
Generated on Wed Oct 8 14:01:48 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivFramework

UiMenu.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FRAMEWORK_UI_MENU_H)
00010 #define ACTIV_FRAMEWORK_UI_MENU_H
00011
00012 #include "ActivMiddleware/ActivFramework/External.h"
00013 #include "ActivMiddleware/ActivFramework/UiPermissions.h"
00014
00015 namespace Activ
00016 {
00017
00018 class UiUser;
00019 class UiIo;
00020
00021 // ---------------------------------------------------------------------------------------------------------------------------------
00022
00026 class UiMenu
00027 {
00028 public:
00032     class OptionAttributes
00033     {
00034     public:
00040         ACTIV_FRAMEWORK_API OptionAttributes();
00041
00047         ACTIV_FRAMEWORK_API OptionAttributes(const UiPermissions &uiPermissions);
00048
00054         ACTIV_FRAMEWORK_API OptionAttributes(const std::string &sectionName);
00055
00062         ACTIV_FRAMEWORK_API OptionAttributes(const UiPermissions &uiPermissions, const std::string &sectionName);
00063
00064         const UiPermissions m_uiPermissions;
00065         const std::string   m_sectionName;
00066     };
00067
00071     typedef void (*GlobalOptionFunction)(const UiIo &uiIo);
00072
00082     ACTIV_FRAMEWORK_API UiMenu(const std::string &name, UiUser &uiUser, const bool showQuitOption = true);
00083
00092     ACTIV_FRAMEWORK_API UiMenu(const std::string &name, const UiIo &uiIo);
00093
00097     ACTIV_FRAMEWORK_API virtual ~UiMenu();
00098
00104     ACTIV_FRAMEWORK_API std::string GetName() const;
00105
00114     template<typename T>
00115     void AddOption(const std::string &name, T &object, void (T::*pFunction)(const UiIo &),
00116         const OptionAttributes &optionAttributes = OptionAttributes())
00117     {
00118         Option *pOption = new (std::nothrow) OptionTemplate<T>(object, pFunction, name, optionAttributes);
00119
00120         if (0 == pOption)
00121             return;
00122
00123         m_optionVector.push_back(pOption);
00124     }
00125
00133     ACTIV_FRAMEWORK_API void AddOption(const std::string &name, GlobalOptionFunction pFunction,
00134         const OptionAttributes &optionAttributes = OptionAttributes());
00135
00139     ACTIV_FRAMEWORK_API void Run();
00140
00141 protected:
00149     ACTIV_FRAMEWORK_API virtual void DisplayTitle(const UiIo &uiIo) const;
00150
00161     ACTIV_FRAMEWORK_API virtual void DisplayOption(const UiIo &uiIo, const size_t optionIndex, const std::string &name,
00162         const OptionAttributes &optionAttributes) const;
00163
00169     ACTIV_FRAMEWORK_API virtual void DisplayFooter(const UiIo &uiIo) const;
00170
00178     ACTIV_FRAMEWORK_API virtual void DisplayOptionPrompt(const UiIo &uiIo) const;
00179
00190     ACTIV_FRAMEWORK_API virtual void DisplayInputPrompt(const UiIo &uiIo, const std::string &prompt, const std::string &value,
00191         const bool initializedWithDefault) const;
00192
00206     ACTIV_FRAMEWORK_API StatusCode ProcessOption(const UiIo &uiIo, const std::string &optionString);
00207
00208 private:
00212     class Option
00213     {
00214     public:
00221         ACTIV_FRAMEWORK_API Option(const std::string &name, const OptionAttributes &optionAttributes);
00222
00226         ACTIV_FRAMEWORK_API virtual ~Option();
00227
00233         virtual void Run(const UiIo &uiIo) const = 0;
00234
00235         std::string         m_name;
00236         OptionAttributes    m_attributes;
00237     };
00238
00242     template <typename T>
00243     class OptionTemplate : public Option
00244     {
00245     public:
00246         typedef void (T::*OptionFunction)(const UiIo &uiIo);
00247
00256         OptionTemplate(T &object, OptionFunction pFunction, const std::string &name, const OptionAttributes &optionAttributes) :
00257             Option(name, optionAttributes),
00258             m_object(object),
00259             m_pFunction(pFunction)
00260         {
00261         }
00262
00263     private:
00264         virtual void Run(const UiIo &uiIo) const
00265         {
00266             (m_object.*m_pFunction)(uiIo);
00267         }
00268
00269         T &             m_object;
00270         OptionFunction  m_pFunction;
00271     };
00272
00276     class GlobalOption : public Option
00277     {
00278     public:
00286         GlobalOption(GlobalOptionFunction pFunction, const std::string &name, const OptionAttributes &optionAttributes);
00287
00288     private:
00289         virtual void Run(const UiIo &uiIo) const;
00290
00291         GlobalOptionFunction    m_pFunction;
00292     };
00293
00299     void Display(const UiIo &uiIo) const;
00300
00306     void DisplayOptions(const UiIo &uiIo) const;
00307
00320     virtual StatusCode GetOption(const UiIo &uiIo);
00321
00328     void RunOption(const UiIo &uiIo, const size_t optionIndex);
00329
00335     bool IsUserPermissionedForOption(const UiPermissions &optionUiPermissions) const;
00336
00337     typedef std::vector<Option *> OptionVector;
00338
00339     static const std::string    m_quitSet[];
00340
00341     const std::string           m_name;
00342     UiUser &                    m_uiUser;
00343     UiMenu * const              m_pParentMenu;
00344     const bool                  m_showQuitOption;
00345     OptionVector                m_optionVector;
00346
00347     friend class UiIo;
00348 };
00349
00350 } // namespace Activ
00351
00352 #endif // (!defined ACTIV_FRAMEWORK_UI_MENU_H)
Generated on Wed Oct 8 14:01:48 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivFramework

UiPermissions.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FRAMEWORK_UI_PERMISSIONS_H)
00010 #define ACTIV_FRAMEWORK_UI_PERMISSIONS_H
00011
00012 #include "ActivMiddleware/ActivFramework/External.h"
00013
00014 namespace Activ
00015 {
00016
00020 class UiPermissions
00021 {
00022 public:
00026     #define UI_PERMISSIONS_LIST(d)                              \
00027         d(READ,     READ_BIT)                                   \
00028         d(MODIFY,   (READ_BIT | MODIFY_BIT))                    \
00029         d(SHUTDOWN, (READ_BIT | SHUTDOWN_BIT))                  \
00030         d(FULL,     ((0x01 << NUMBER_OF_PERMISSIONS_BITS) - 1))
00031
00032     #define DECLARE_UI_PERMISSIONS(name, bitmap) ACTIV_FRAMEWORK_API static const UiPermissions name;
00033
00034     UI_PERMISSIONS_LIST(DECLARE_UI_PERMISSIONS)
00035
00036
00039     ACTIV_FRAMEWORK_API UiPermissions();
00040
00049     ACTIV_FRAMEWORK_API StatusCode FromString(const std::string &string);
00050
00056     ACTIV_FRAMEWORK_API std::string ToString() const;
00057
00066     ACTIV_FRAMEWORK_API StatusCode Serialize(MessageBuilder &messageBuilder) const;
00067
00076     ACTIV_FRAMEWORK_API StatusCode Deserialize(MessageValidator &messageValidator);
00077
00085     ACTIV_FRAMEWORK_API bool HasPermissions(const UiPermissions &uiPermissions) const;
00086
00087     typedef int32_t Bitmap;
00088
00089 private:
00095     UiPermissions(const Bitmap bitmap);
00096
00097     Bitmap m_bitmap;
00098 };
00099
00100 } // namespace Activ
00101
00102 #endif // (!defined ACTIV_FRAMEWORK_UI_PERMISSIONS_H)
Generated on Wed Oct 8 14:01:48 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon

UniversalFieldHelper.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FEED_COMMON_UNIVERSAL_FIELD_HELPER_H)
00010 #define ACTIV_FEED_COMMON_UNIVERSAL_FIELD_HELPER_H
00011
00012 #include "ActivContentPlatform/ActivFeedCommon/External.h"
00013 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedDefinitions.h"
00014 #include "ActivContentPlatform/ActivFeedCommon/FieldIds.h"
00015
00016 namespace Activ
00017 {
00018
00019 namespace ContentPlatform
00020 {
00021
00022 namespace Feed
00023 {
00024
00028 class UniversalFieldHelper
00029 {
00030 public:
00034     UniversalFieldHelper();
00035
00046     UniversalFieldHelper(const FieldId fieldId, const char * const pName, const char * const pCodeIdentifier,
00047         const char * const pDescription, const FieldType type, const size_t maxLength);
00048
00049     FieldId         m_fieldId;
00050     std::string     m_name;
00051     std::string     m_codeIdentifier;
00052     std::string     m_description;
00053     FieldType       m_type;
00054     size_t          m_maxLength;
00055 };
00056
00057 // ---------------------------------------------------------------------------------------------------------------------------------
00058
00059 inline UniversalFieldHelper::UniversalFieldHelper() :
00060     m_fieldId(FID_UNDEFINED),
00061     m_type(FIELD_TYPE_UNKNOWN),
00062     m_maxLength(0)
00063 {
00064 }
00065
00066 // ---------------------------------------------------------------------------------------------------------------------------------
00067
00068 inline UniversalFieldHelper::UniversalFieldHelper(const FieldId fieldId, const char * const pName,
00069         const char * const pCodeIdentifier, const char * const pDescription, const FieldType type, const size_t maxLength) :
00070     m_name(pName),
00071     m_codeIdentifier(pCodeIdentifier),
00072     m_description(pDescription),
00073     m_type(type),
00074     m_maxLength(maxLength)
00075 {
00076 }
00077
00078 // ---------------------------------------------------------------------------------------------------------------------------------
00079 // ---------------------------------------------------------------------------------------------------------------------------------
00080
00088 ACTIV_FEED_COMMON_API const UniversalFieldHelper &GetUniversalFieldHelper(const FieldId fieldId);
00089
00097 ACTIV_FEED_COMMON_API std::string GetUniversalFieldName(const FieldId fieldId);
00098
00106 ACTIV_FEED_COMMON_API std::string GetUniversalFieldCodeIdentifier(const FieldId fieldId);
00107
00115 ACTIV_FEED_COMMON_API std::string GetUniversalFieldDescription(const FieldId fieldId);
00116
00124 ACTIV_FEED_COMMON_API FieldType GetUniversalFieldType(const FieldId fieldId);
00125
00133 ACTIV_FEED_COMMON_API size_t GetUniversalFieldMaxLength(const FieldId fieldId);
00134
00135 } // namespace Feed
00136
00137 } // namespace ContentPlatform
00138
00139 } // namespace Activ
00140
00141 #endif // (!defined ACTIV_FEED_COMMON_UNIVERSAL_FIELD_HELPER_H)
Generated on Wed Oct 8 14:01:46 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon » ActivFeedTableTemplateHandler

UniversalFieldList.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FEED_TABLE_TEMPLATE_HANDLER_UNIVERSAL_FIELD_LIST_H)
00010 #define ACTIV_FEED_TABLE_TEMPLATE_HANDLER_UNIVERSAL_FIELD_LIST_H
00011
00012 #include "ActivMiddleware/ActivBase/DirectoryWalker.h"
00013 #include "ActivMiddleware/Misc/StlHelper.h"
00014
00015 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/External.h"
00016 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedTableTemplateHandler/Field.h"
00017
00018 namespace Activ
00019 {
00020
00021 namespace ContentPlatform
00022 {
00023
00024 namespace Feed
00025 {
00026
00027 typedef Field                                           UniversalField;
00028 typedef std::vector<UniversalField::Specification>      UniversalFieldSpecificationList;
00029 typedef std::list<std::string>                          PathList;
00030 typedef std::list<ServiceId>                            ServiceIdList;
00031 typedef std::list<ServiceHandle>                        ServiceHandleList;
00032
00033 // ---------------------------------------------------------------------------------------------------------------------------------
00034
00038 class UniversalFieldList
00039 {
00040 public:
00041     static const std::string DEFAULT_FILENAME;
00042
00046     class ConstIterator
00047     {
00048     public:
00052         ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API ConstIterator();
00053
00059         ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API const UniversalField &operator*() const;
00060
00066         ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API const UniversalField *operator->() const;
00067
00073         ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API ConstIterator &operator++();
00074
00080         ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API const ConstIterator operator++(int);
00081
00089         ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API bool operator==(const ConstIterator &rhs) const;
00090
00098         ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API bool operator!=(const ConstIterator &rhs) const;
00099
00100     private:
00101         typedef hash_map<FieldId, UniversalField> UniversalFieldMap;
00102
00109         ConstIterator(const UniversalFieldMap::const_iterator &iterator);
00110
00111         UniversalFieldMap::const_iterator   m_iterator;
00112
00113         friend class UniversalFieldList;
00114     };
00115
00123     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API UniversalFieldList();
00124
00134     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API UniversalFieldList(const UniversalFieldSpecificationList &universalFieldSpecificationList);
00135
00145     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API UniversalFieldList(const std::string &path);
00146
00156     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API UniversalFieldList(const PathList &pathList);
00157
00168     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API UniversalFieldList(Application &application, const ServiceHandleList &serviceHandleList);
00169
00173     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API ~UniversalFieldList();
00174
00183     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API StatusCode Initialize();
00184
00195     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API StatusCode Initialize(const UniversalFieldSpecificationList &universalFieldSpecificationList);
00196
00207     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API StatusCode Initialize(const std::string &path);
00208
00219     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API StatusCode Initialize(const PathList &pathList);
00220
00234     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API StatusCode Initialize(Application &application, const ServiceHandleList &serviceHandleList, IHeap * const pHeap = 0, const std::string &componentId = Component::defaultComponentId);
00235
00239     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API void Clear();
00240
00244     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API bool IsEmpty() const;
00245
00253     static bool IsContributedUniversalFieldList(const std::string &xmlFileName);
00254
00263     StatusCode InitializeList(const std::string &xmlFileName);
00264
00274     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API StatusCode GetUniversalField(const FieldId fieldId, const UniversalField *&pUniversalField) const;
00275
00281     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API ConstIterator Begin() const;
00282
00288     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API ConstIterator End() const;
00289
00295     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API std::string ToString() const;
00296
00302     ACTIV_FEED_TABLE_TEMPLATE_HANDLER_API std::string GetError() const;
00303
00304 private:
00305     typedef hash_map<FieldId, UniversalField> UniversalFieldMap;
00306
00317     StatusCode GetUniversalField(const FieldId fieldId, UniversalField *&pUniversalField) const;
00318
00319     UniversalFieldMap   m_universalFieldMap;
00320
00321     std::string         m_error;
00322 };
00323
00324 // ---------------------------------------------------------------------------------------------------------------------------------
00325
00326 inline void UniversalFieldList::Clear()
00327 {
00328     m_universalFieldMap.clear();
00329 }
00330
00331 // ---------------------------------------------------------------------------------------------------------------------------------
00332
00333 inline bool UniversalFieldList::IsEmpty() const
00334 {
00335     return m_universalFieldMap.empty();
00336 }
00337
00338 // ---------------------------------------------------------------------------------------------------------------------------------
00339
00340 inline std::string UniversalFieldList::GetError() const
00341 {
00342     return m_error;
00343 }
00344
00345 } // namespace Feed
00346
00347 } // namespace ContentPlatform
00348
00349 } // namespace Activ
00350
00351 #endif // (!defined ACTIV_FEED_TABLE_TEMPLATE_HANDLER_UNIVERSAL_FIELD_LIST_H)
Generated on Wed Oct 8 14:01:46 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivDatabase

UnmanagedTableFactory.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_DATABASE_UNMANAGED_TABLE_FACTORY_H)
00010 #define ACTIV_DATABASE_UNMANAGED_TABLE_FACTORY_H
00011
00012 #include "ActivMiddleware/ActivDatabase/External.h"
00013 #include "ActivMiddleware/ActivDatabase/Definitions.h"
00014 #include "ActivMiddleware/Misc/Singleton.h"
00015
00016 #include <string>
00017 #include <vector>
00018
00019 namespace Activ
00020 {
00021
00022 namespace Database
00023 {
00024
00025 class ITable;
00026
00027 // ---------------------------------------------------------------------------------------------------------------------------------
00028
00032 class UnmanagedTableFactory : public Singleton<UnmanagedTableFactory>
00033 {
00034 public:
00052     ACTIV_DATABASE_API ITable *Create(const std::string &name, const TableSpecification::Properties properties, const FieldSpecification fieldSpecificationList[], const size_t nFields, const size_t initialMaxRecords, const size_t recordLength, const size_t nGrowRecords = TableSpecification::GROW_RECORDS_DEFAULT, const size_t cacheSize = TableSpecification::CACHE_COMPLETE);
00053
00070     ACTIV_DATABASE_API ITable *Create(const std::string &name, const TableSpecification::Properties properties, const FieldSpecificationList &fieldSpecificationList, const size_t initialMaxRecords, const size_t recordLength, const size_t nGrowRecords = TableSpecification::GROW_RECORDS_DEFAULT, const size_t cacheSize = TableSpecification::CACHE_COMPLETE);
00071
00090     ACTIV_DATABASE_API ITable *Create(const std::string &name, const std::string &directory, const TableSpecification::Properties properties, const FieldSpecification fieldSpecificationList[], const size_t nFields, const size_t initialMaxRecords, const size_t recordLength, const size_t nGrowRecords = TableSpecification::GROW_RECORDS_DEFAULT, const size_t cacheSize = TableSpecification::CACHE_COMPLETE);
00091
00109     ACTIV_DATABASE_API ITable *Create(const std::string &name, const std::string &directory, const TableSpecification::Properties properties, const FieldSpecificationList &fieldSpecificationList, const size_t initialMaxRecords, const size_t recordLength, const size_t nGrowRecords = TableSpecification::GROW_RECORDS_DEFAULT, const size_t cacheSize = TableSpecification::CACHE_COMPLETE);
00110
00116     ACTIV_DATABASE_API static UnmanagedTableFactory &GetInstance();
00117
00118 private:
00122     ACTIV_DATABASE_API UnmanagedTableFactory();
00123
00124     friend class Singleton<UnmanagedTableFactory>;
00125 };
00126
00127 } // namespace Database
00128
00129 } // namespace Activ
00130
00131 #endif // (!defined ACTIV_DATABASE_UNMANAGED_TABLE_FACTORY_H)
Generated on Wed Oct 8 14:01:47 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivContentPlatform » ActivFeedCommon

UpdateIds.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_FEED_COMMON_UPDATE_IDS_H)
00010 #define ACTIV_FEED_COMMON_UPDATE_IDS_H
00011
00012 #include "ActivMiddleware/Activ.h"
00013
00014 #include "ActivContentPlatform/ActivFeedCommon/ActivFeedDefinitions.h"
00015
00016 namespace Activ
00017 {
00018
00019 namespace ContentPlatform
00020 {
00021
00022 namespace Feed
00023 {
00024
00025 const UpdateId UPDATE_ID_BIT_RESET          = 0;
00026
00027 const UpdateId UPDATE_ID_BITMASK_RESET      = (1 << ((sizeof(UpdateId) * CHAR_BIT) - (UPDATE_ID_BIT_RESET + 1)));
00028 const UpdateId UPDATE_ID_BITMASK_COUNT      = static_cast<UpdateId>(~UPDATE_ID_BITMASK_RESET);
00029
00030 const UpdateId UPDATE_ID_COUNT_NEW_RECORD   = 0;
00031 const UpdateId UPDATE_ID_COUNT_UNKNOWN      = static_cast<UpdateId>(~0) ^ UPDATE_ID_BITMASK_RESET;
00032 const UpdateId UPDATE_ID_COUNT_MAXIMUM      = UPDATE_ID_COUNT_UNKNOWN;
00033
00034 // ---------------------------------------------------------------------------------------------------------------------------------
00035
00043 inline UpdateId GetUpdateIdCount(const UpdateId updateId)
00044 {
00045     return (UPDATE_ID_BITMASK_COUNT & updateId);
00046 }
00047
00048 // ---------------------------------------------------------------------------------------------------------------------------------
00049
00057 inline UpdateId GetIncrementedUpdateId(const UpdateId updateId)
00058 {
00059     UpdateId updateCount = GetUpdateIdCount(updateId);
00060
00061     return ((UPDATE_ID_BITMASK_RESET & updateId) | ((UPDATE_ID_COUNT_MAXIMUM == ++updateCount) ? 1 : updateCount));
00062 }
00063
00064 // ---------------------------------------------------------------------------------------------------------------------------------
00065
00073 inline UpdateId GetResetUpdateId(const UpdateId updateId)
00074 {
00075     return (UPDATE_ID_BITMASK_RESET ^ GetIncrementedUpdateId(updateId));
00076 }
00077
00078 // ---------------------------------------------------------------------------------------------------------------------------------
00079
00085 inline UpdateId GetNewRecordUpdateId()
00086 {
00087     return UPDATE_ID_COUNT_NEW_RECORD;
00088 }
00089
00090 // ---------------------------------------------------------------------------------------------------------------------------------
00091
00097 inline UpdateId GetUnknownUpdateId()
00098 {
00099     return UPDATE_ID_COUNT_UNKNOWN;
00100 }
00101
00102 // ---------------------------------------------------------------------------------------------------------------------------------
00103
00111 inline bool IsUpdateIdResetBitSet(const UpdateId updateId)
00112 {
00113     return (0 != (UPDATE_ID_BITMASK_RESET & updateId));
00114 }
00115
00116 // ---------------------------------------------------------------------------------------------------------------------------------
00117
00125 inline bool IsUpdateIdNewRecord(const UpdateId updateId)
00126 {
00127     return (UPDATE_ID_COUNT_NEW_RECORD == GetUpdateIdCount(updateId));
00128 }
00129
00130 // ---------------------------------------------------------------------------------------------------------------------------------
00131
00139 inline bool IsUpdateIdUnknown(const UpdateId updateId)
00140 {
00141     return (UPDATE_ID_COUNT_UNKNOWN == GetUpdateIdCount(updateId));
00142 }
00143
00144 // ---------------------------------------------------------------------------------------------------------------------------------
00145
00146 } // namespace Feed
00147
00148 } // namespace ContentPlatform
00149
00150 } // namespace Activ
00151
00152 #endif // (!defined ACTIV_FEED_COMMON_UPDATE_IDS_H)
Generated on Wed Oct 8 14:01:46 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

Url.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_BASE_URL_H)
00010 #define ACTIV_BASE_URL_H
00011
00012 #include "ActivMiddleware/ActivBase/External.h"
00013
00014 #include <string>
00015 #include <list>
00016
00017 namespace Activ
00018 {
00019
00028 class Url
00029 {
00030 public:
00031     typedef std::pair<std::string, std::string> Parameter;
00032     typedef std::list<Parameter> ParameterList;
00033
00042     ACTIV_BASE_EXPORTED_API StatusCode Parse(const std::string &url);
00043
00047     ACTIV_BASE_EXPORTED_API std::string Build() const;
00048
00049     std::string     m_protocol;
00050     std::string     m_location;
00051     std::string     m_path;
00052     ParameterList   m_parameterList;
00053
00054 private:
00061     ACTIV_BASE_LOCAL_API static void ParseParameter(const std::string &parameterString, ParameterList &parameterList);
00062 };
00063
00064 } // namespace Activ
00065
00066 #endif // (!defined ACTIV_BASE_URL_H)
Generated on Wed Oct 8 14:01:47 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivBase

Uuid.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_BASE_UUID_H)
00010 #define ACTIV_BASE_UUID_H
00011
00012 #include "ActivMiddleware/ActivBase/External.h"
00013
00014 #include <string>
00015
00016 namespace Activ
00017 {
00018
00019 class MessageBuilder;
00020 class MessageValidator;
00021
00022 // ---------------------------------------------------------------------------------------------------------------------------------
00023
00027 class Uuid
00028 {
00029 public:
00030     static const size_t UUID_SIZE = 16;
00031
00037     ACTIV_BASE_EXPORTED_API Uuid();
00038
00047     ACTIV_BASE_EXPORTED_API Uuid(const byte_t *pBuffer, const size_t bufferSize);
00048
00056     ACTIV_BASE_EXPORTED_API Uuid(std::string &uuidString);
00057
00065     ACTIV_BASE_EXPORTED_API bool operator==(const Uuid &rhs) const;
00066
00076     ACTIV_BASE_EXPORTED_API bool operator!=(const Uuid &rhs) const;
00077
00087     ACTIV_BASE_EXPORTED_API bool operator<(const Uuid &rhs) const;
00088
00098     ACTIV_BASE_EXPORTED_API bool operator<=(const Uuid &rhs) const;
00099
00109     ACTIV_BASE_EXPORTED_API bool operator>(const Uuid &rhs) const;
00110
00120     ACTIV_BASE_EXPORTED_API bool operator>=(const Uuid &rhs) const;
00121
00131     ACTIV_BASE_EXPORTED_API StatusCode Set(const byte_t *pBuffer, const size_t bufferSize);
00132
00141     ACTIV_BASE_EXPORTED_API StatusCode Set(const std::string &uuidString);
00142
00152     ACTIV_BASE_EXPORTED_API StatusCode GetBinary(byte_t *pBuffer, const size_t bufferSize) const;
00153
00159     ACTIV_BASE_EXPORTED_API std::string ToString() const;
00160
00168     ACTIV_BASE_EXPORTED_API StatusCode Serialize(MessageBuilder &messageBuilder) const;
00169
00177     ACTIV_BASE_EXPORTED_API StatusCode Deserialize(MessageValidator &messageValidator);
00178
00179     ACTIV_BASE_EXPORTED_API static const Uuid emptyUuid;
00180
00181 private:
00189     int Compare(const Uuid &rhs) const;
00190
00191     byte_t  m_uuid[UUID_SIZE];
00192 };
00193
00194 } // namespace Activ
00195
00196 #endif // (!defined ACTIV_BASE_UUID_H)
Generated on Wed Oct 8 14:01:47 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » Config » Compilers

VisualC.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_CONFIG_COMPILERS_VISUAL_C_H)
00010 #define ACTIV_CONFIG_COMPILERS_VISUAL_C_H
00011
00012 #if (_MSC_VER < 1310)
00013 #error VC++ version not supported
00014 #endif
00015
00016 #define ACTIV_COMPILER_NAME "Microsoft Visual C++ version " ACTIV_STRINGIZE(_MSC_VER)
00017
00018 #define ACTIV_BUILDING_DLL_EXPORTED_API     __declspec (dllexport)
00019 #define ACTIV_BUILDING_DLL_INLINE_API
00020 #define ACTIV_BUILDING_DLL_LOCAL_API
00021 #define ACTIV_USING_DLL_EXPORTED_API        __declspec (dllimport)
00022 #define ACTIV_USING_DLL_INLINE_API
00023 #define ACTIV_USING_DLL_LOCAL_API
00024
00025 #define ACTIV_BUILDING_LIB_EXPORTED_API
00026 #define ACTIV_BUILDING_LIB_INLINE_API
00027 #define ACTIV_BUILDING_LIB_LOCAL_API
00028 #define ACTIV_USING_LIB_EXPORTED_API
00029 #define ACTIV_USING_LIB_INLINE_API
00030 #define ACTIV_USING_LIB_LOCAL_API
00031
00040 #define ACTIV_DECLARE_UNINITIALIZED_VARIABLE(type, name, dummyValue) type name
00041
00056 #define ACTIV_TEMPLATE_API(a)   a
00057
00073 #define ACTIV_TEMPLATE_SELF typename
00074
00078 #define ACTIV_FORCE_INLINE  __forceinline
00079
00083 #define ACTIV_NEVER_INLINE  __declspec(noinline)
00084
00085 #if (_MSC_VER < 1500)
00086 #define snprintf    _snprintf
00087 #define vsnprintf   _vsnprintf
00088 #endif
00089
00090 // turn off annoying "C4355: 'this' : used in base member initializer list" warning
00091 #pragma warning(disable:4355)
00092
00093 // turn off annoying "C4163: not available as an intrinsic function" warning
00094 #pragma warning(disable:4163)
00095
00096 // turn off annoying "C4996: : 'blah' was declared deprecated" warning
00097 #pragma warning(disable:4996)
00098
00099 // turn off annoying "warning C4258: 'iter' : definition from the for loop is ignored..." warning
00100 #pragma warning(disable:4258)
00101
00102 #if (_MSC_VER >= 1400)
00103 #if (!defined _SCL_SECURE_NO_DEPRECATE)
00104 #define _SCL_SECURE_NO_DEPRECATE
00105 #endif
00106
00107 #if (defined _SECURE_SCL)
00108 #undef _SECURE_SCL
00109 #endif
00110 #define _SECURE_SCL 0
00111
00112 #if (!defined _CRT_SECURE_NO_DEPRECATE)
00113 #define _CRT_SECURE_NO_DEPRECATE
00114 #endif
00115 #endif
00116
00117 #endif // (!defined ACTIV_CONFIG_COMPILERS_VISUAL_C_H)
Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » Misc

WinFtpHelper.h

Go to the documentation of this file.
00001
00007 #if (!defined ACTIV_MISC_WIN_FTP_HELPER_H)
00008 #define ACTIV_MISC_WIN_FTP_HELPER_H
00009
00010 #include "ActivMiddleware/ActivBase/StatusCodeException.h"
00011 #include "ActivMiddleware/ActivBase/OsException.h"
00012 #include "ActivMiddleware/ActivBase/File.h"
00013 #include "ActivMiddleware/Misc/FtpParse.h"
00014
00015 #include <wininet.h>
00016
00017 #include "IFtpHelper.h"
00018
00019 #include <string>
00020 #include <vector>
00021 #include <time.h>
00022
00023 namespace Activ
00024 {
00025
00026 class WinFtpHelper : public IFtpHelper
00027 {
00028 public:
00029     WinFtpHelper(const std::string server, const std::string &username = "", const std::string &password = "", uint32_t port = 21);
00030     virtual ~WinFtpHelper();
00031
00032     virtual StatusCodeHelper Connect();
00033     virtual StatusCodeHelper Disconnect();
00034     virtual StatusCodeHelper GetFileList(FileInfoList &fileInfoList, const std::string &remoteDirectory = "");
00035     virtual StatusCodeHelper GetFile(const std::string &remoteFilename, const std::string &localFilename, const std::string &remoteDirectory = "");
00036     virtual StatusCodeHelper DeleteFile(const std::string &remoteFilename, const std::string &remoteDirectory = "");
00037     virtual StatusCodeHelper DeleteFile(const FileInfoList &fileInfoList, const std::string &remoteDirectory = "");
00038     virtual StatusCodeHelper GetAndDeleteFile(const std::string &remoteFilename, const std::string &localFilename, const std::string &remoteDirectory = "");
00039
00040     virtual bool IsConnected() const;
00041
00042 private:
00043
00044     std::string GetExtentedWinFtpErrorMessage();
00045
00046     HINTERNET       m_internetHandle;
00047     HINTERNET       m_ftpSessionHandle;
00048
00049 };
00050
00051 // ---------------------------------------------------------------------------------------------------------------------------------
00052
00053 inline WinFtpHelper::WinFtpHelper(const std::string server, const std::string &username, const std::string &password, uint32_t port) :
00054     IFtpHelper(server, username, password, port),
00055     m_internetHandle(0),
00056     m_ftpSessionHandle(0)
00057 {
00058 }
00059
00060 // ---------------------------------------------------------------------------------------------------------------------------------
00061
00062 inline WinFtpHelper::~WinFtpHelper()
00063 {
00064     Disconnect();
00065 }
00066
00067 // ---------------------------------------------------------------------------------------------------------------------------------
00068
00069 inline bool WinFtpHelper::IsConnected() const
00070 {
00071     return (0 != m_ftpSessionHandle);
00072 }
00073
00074 // ---------------------------------------------------------------------------------------------------------------------------------
00075
00076 inline StatusCodeHelper WinFtpHelper::Connect()
00077 {
00078     if (IsConnected())
00079         return STATUS_CODE_ALREADY_CONNECTED;
00080
00081     m_internetHandle = ::InternetOpen(0, INTERNET_OPEN_TYPE_DIRECT, 0, 0, 0);
00082
00083     if (0 == m_internetHandle)
00084         return StatusCodeHelper(STATUS_CODE_FAILURE, OsErrorToString(::GetLastError()));
00085
00086     m_ftpSessionHandle = ::InternetConnect(m_internetHandle, m_server.c_str(), static_cast<INTERNET_PORT>(m_port), m_username.c_str(), m_password.c_str(), INTERNET_SERVICE_FTP, 0, 0);
00087     if (0 == m_ftpSessionHandle)
00088         StatusCodeHelper(STATUS_CODE_FAILURE, OsErrorToString(::GetLastError()) + ":" + GetExtentedWinFtpErrorMessage());
00089
00090     return STATUS_CODE_SUCCESS;
00091 }
00092
00093 // ---------------------------------------------------------------------------------------------------------------------------------
00094
00095 inline StatusCodeHelper WinFtpHelper::Disconnect()
00096 {
00097     if (!IsConnected())
00098         return STATUS_CODE_NOT_CONNECTED;
00099
00100     if (0 != m_ftpSessionHandle)
00101         (void) ::InternetCloseHandle(m_ftpSessionHandle);
00102
00103     if (0 != m_internetHandle)
00104         (void) ::InternetCloseHandle(m_internetHandle);
00105
00106     m_ftpSessionHandle = m_internetHandle = 0;
00107
00108     return STATUS_CODE_SUCCESS;
00109 }
00110
00111 // ---------------------------------------------------------------------------------------------------------------------------------
00112
00113 inline StatusCodeHelper WinFtpHelper::GetFileList(FileInfoList &fileInfoList, const std::string &remoteDirectory)
00114 {
00115     if (!IsConnected())
00116         return STATUS_CODE_NOT_CONNECTED;
00117
00118     WIN32_FIND_DATA findData;
00119     HINTERNET findHandle = ::FtpFindFirstFile(m_ftpSessionHandle, remoteDirectory.c_str(), &findData, INTERNET_FLAG_RELOAD, 0);
00120
00121     if ((0 == findHandle) && (ERROR_NO_MORE_FILES == ::GetLastError()))
00122         return StatusCodeHelper();
00123
00124     if ((0 == findHandle) && (ERROR_NO_MORE_FILES != ::GetLastError()))
00125         return StatusCodeHelper(STATUS_CODE_FAILURE, OsErrorToString(::GetLastError()));
00126
00127     do
00128     {
00129         if (!(findData.dwFileAttributes & FILE_ATTRIBUTE_DIRECTORY))
00130         {
00131             FileInfo fileInfo;
00132
00133             const std::string localFileName(findData.cFileName);
00134             fileInfo.m_name = std::string(findData.cFileName);
00135
00136             fileInfo.m_size = static_cast<int64_t>((findData.nFileSizeHigh * (static_cast<int64_t>(MAXDWORD)+1)) + findData.nFileSizeLow);
00137
00138             SYSTEMTIME stUtc;
00139
00140             // Convert the last-write time to system time.
00141             FileTimeToSystemTime(&findData.ftLastWriteTime, &stUtc);
00142
00143             fileInfo.m_fileTime = DateTime(stUtc.wYear , stUtc.wMonth, stUtc.wDay, stUtc.wHour, stUtc.wMinute, stUtc.wSecond);
00144
00145             fileInfoList.push_back(fileInfo);
00146         }
00147     }
00148     while (::InternetFindNextFile(findHandle, &findData));
00149
00150     (void) ::InternetCloseHandle(findHandle);
00151
00152     if (ERROR_NO_MORE_FILES != ::GetLastError())
00153     {
00154         Disconnect();
00155         return StatusCodeHelper(STATUS_CODE_FAILURE, OsErrorToString(::GetLastError()) + ":" + GetExtentedWinFtpErrorMessage());
00156     }
00157
00158     return STATUS_CODE_SUCCESS;
00159 }
00160
00161 // ---------------------------------------------------------------------------------------------------------------------------------
00162
00163 inline StatusCodeHelper WinFtpHelper::GetFile(const std::string &remoteFilename, const std::string &localFilename, const std::string &remoteDirectory)
00164 {
00165     const std::string requestPath = remoteDirectory.empty() ?  remoteFilename : remoteDirectory + "/" + remoteFilename;
00166
00167     if (!FtpGetFile(m_ftpSessionHandle, requestPath.c_str() , localFilename.c_str(), FALSE, FILE_ATTRIBUTE_NORMAL, FTP_TRANSFER_TYPE_ASCII | INTERNET_FLAG_RELOAD, 0))
00168         return StatusCodeHelper(STATUS_CODE_FAILURE, OsErrorToString(::GetLastError()) + ":" + GetExtentedWinFtpErrorMessage());
00169
00170     return STATUS_CODE_SUCCESS;
00171 }
00172
00173 // ---------------------------------------------------------------------------------------------------------------------------------
00174
00175 inline StatusCodeHelper WinFtpHelper::DeleteFile(const std::string &remoteFilename, const std::string &remoteDirectory)
00176 {
00177     const std::string requestPath = remoteDirectory.empty() ?  remoteFilename : remoteDirectory + "/" + remoteFilename;
00178
00179     if (!FtpDeleteFile(m_ftpSessionHandle, requestPath.c_str()))
00180         return StatusCodeHelper(STATUS_CODE_FAILURE, OsErrorToString(::GetLastError()) + ":" + GetExtentedWinFtpErrorMessage());
00181
00182     return STATUS_CODE_SUCCESS;
00183 }
00184
00185 // ---------------------------------------------------------------------------------------------------------------------------------
00186
00187 inline StatusCodeHelper WinFtpHelper::GetAndDeleteFile(const std::string &remoteFilename, const std::string &localFilename, const std::string &remoteDirectory)
00188 {
00189     StatusCodeHelper statusCodeHelper = GetFile(remoteFilename, localFilename, remoteDirectory);
00190     if (STATUS_CODE_FAILURE == statusCodeHelper)
00191         return statusCodeHelper;
00192
00193     return DeleteFile(remoteFilename, remoteDirectory);
00194 }
00195
00196 // ---------------------------------------------------------------------------------------------------------------------------------
00197
00198 inline StatusCodeHelper WinFtpHelper::DeleteFile(const FileInfoList &fileInfoList, const std::string &remoteDirectory)
00199 {
00200     for (FileInfoList::const_iterator it = fileInfoList.begin(), itEnd = fileInfoList.end(); it != itEnd; ++it)
00201     {
00202         StatusCodeHelper statusCodeHelper = DeleteFile(it->m_name, remoteDirectory);
00203         if (STATUS_CODE_FAILURE == statusCodeHelper)
00204             return statusCodeHelper;
00205     }
00206
00207     return STATUS_CODE_SUCCESS;
00208 }
00209
00210 // ---------------------------------------------------------------------------------------------------------------------------------
00211
00212 inline std::string WinFtpHelper::GetExtentedWinFtpErrorMessage()
00213 {
00214     DWORD error = 0;
00215     DWORD size = 0;
00216
00217     InternetGetLastResponseInfo(&error, 0, &size);
00218
00219     if (0 == size)
00220         return "";
00221
00222     std::vector<char> buff(size + 1);
00223     if (!InternetGetLastResponseInfo(&error, &buff[0], &size))
00224         return "";
00225
00226     buff[size] = 0;
00227
00228     return std::string(&buff[0]);
00229 }
00230
00231 } // namespace Activ
00232
00233 #endif // (!defined ACTIV_MISC_WIN_FTP_HELPER_H)
Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivIp » Windows

IpManager.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_IP_WINDOWS_IP_MANAGER_H)
00010 #define ACTIV_IP_WINDOWS_IP_MANAGER_H
00011
00012 #include "ActivMiddleware/ActivIp/External.h"
00013 #include "ActivMiddleware/ActivIp/IpAddress.h"
00014 #include "ActivMiddleware/ActivIp/SocketWrapper.h"
00015 #include "ActivMiddleware/ActivBase/Windows/IoCompletionManager.h"
00016 #include "ActivMiddleware/ActivBase/IniFileParser.h"
00017
00018 #include <string>
00019 #include <vector>
00020
00021 namespace Activ
00022 {
00023
00027 class IpManager : public IoCompletionManager
00028 {
00029 public:
00033     class Settings
00034     {
00035     public:
00039         ACTIV_IP_API Settings();
00040
00049         ACTIV_IP_API StatusCode Read(const IniFileParser::ConstSectionIterator &sectionIterator);
00050
00051         size_t  m_numberOfIoThreads;
00052         bool    m_enableWindowsOverlappedOperations;
00053     };
00054
00058     class InterfaceInfo
00059     {
00060     public:
00064         ACTIV_IP_API InterfaceInfo();
00065
00066         std::string     m_name;
00067         std::string     m_description;
00068         std::string     m_macAddress;
00069         size_t          m_bitsPerSecond;
00070         size_t          m_mtu;
00071         IpAddressList   m_ipAddressList;
00072     };
00073
00074     typedef std::vector<InterfaceInfo> InterfaceInfoList;
00075
00083     ACTIV_IP_API IpManager(const Settings &settings);
00084
00088     ACTIV_IP_API ~IpManager();
00089
00095     const Settings &GetSettings() const;
00096
00109     ACTIV_IP_API static void GetIpAddress(const std::string &nodeName, const uint16_t portNumber, IpAddress &ipAddress, const int flags = 0);
00110
00126     ACTIV_IP_API static StatusCode GetLocalIpAddressList(const std::string &localAddress, const uint16_t portNumber, IpAddressList &ipAddressList);
00127
00136     ACTIV_IP_API static StatusCode GetInterfaceInfoList(const int family, InterfaceInfoList &interfaceInfoList);
00137
00150     ACTIV_IP_API static bool GetHostAndPort(const std::string &hostAndPort, std::string &host, uint16_t &portNumber);
00151
00159     ACTIV_IP_API static const std::string &GetHostName();
00160
00166     ACTIV_IP_API static void GetHostsFileEntries(std::vector<std::string> &result);
00167
00179     ACTIV_IP_API static void GetExtensionFunction(const SOCKET socket, void *fnStorage, const DWORD fnStorageSize, void *fnGuid, const DWORD fnGuidSize);
00180
00189     ACTIV_IP_API static void CreateNonInheritableSocket(const IpAddress &ipAddress, SocketWrapper &socketWrapper);
00190
00191 private:
00192     const Settings  m_settings;
00193 };
00194
00195 } // namespace Activ
00196
00197 #endif // (!defined ACTIV_IP_WINDOWS_IP_MANAGER_H)
Generated on Wed Oct 8 14:01:48 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivIp » Windows

IpSocket.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_IP_WINDOWS_IP_SOCKET_H)
00010 #define ACTIV_IP_WINDOWS_IP_SOCKET_H
00011
00012 #include "ActivMiddleware/ActivIp/External.h"
00013 #include "ActivMiddleware/ActivIp/IpManager.h"
00014 #include "ActivMiddleware/ActivIp/Windows/WsaBufHelper.h"
00015 #include "ActivMiddleware/ActivIp/SocketWrapper.h"
00016 #include "ActivMiddleware/ActivIp/IpAddress.h"
00017 #include "ActivMiddleware/ActivBase/MutexHelper.h"
00018
00019 namespace Activ
00020 {
00021
00025 class IpSocket : private boost::noncopyable
00026 {
00027 public:
00031     enum GetBuffersResult
00032     {
00033         GET_BUFFERS_RESULT_CLOSE_SOCKET,
00034         GET_BUFFERS_RESULT_NO_MORE_BUFFERS
00035     };
00036
00040     enum CompletionResult
00041     {
00042         COMPLETION_RESULT_CLOSE_SOCKET,
00043         COMPLETION_RESULT_OK
00044     };
00045
00049     class Settings
00050     {
00051     public:
00057         ACTIV_IP_API Settings(const bool shouldCork = false);
00058
00059         bool    m_shouldCork;
00060     };
00061
00065     class Stats
00066     {
00067     public:
00077         ACTIV_IP_API Stats(const IpSocket &socket);
00078
00088         template <typename SOCKET_TYPE>
00089         static typename SOCKET_TYPE::Stats Get(const SOCKET_TYPE &socket);
00090
00091         IpAddress   m_remoteAddress;
00092         IpAddress   m_localAddress;
00093
00094         bool        m_rxPosted;
00095         bool        m_txPosted;
00096
00097         bool        m_closePosted;
00098         bool        m_closeOnTxCompletion;
00099
00100         uint64_t    m_rxBytes;
00101         uint64_t    m_txBytes;
00102
00103         size_t      m_mutexContentionCount;
00104     };
00105
00114     ACTIV_IP_API IpSocket(IpManager &ipManager, const Settings &settings);
00115
00119     ACTIV_IP_API virtual ~IpSocket();
00120
00130     void LockedRead();
00131
00137     void PreLockedRead();
00138
00146     void LockedWrite();
00147
00153     void PreLockedWrite();
00154
00163     void AppendRxBuffer(void *pData, const size_t dataLength);
00164
00173     void AppendTxBuffer(const void *pData, const size_t dataLength);
00174
00180     ACTIV_IP_API void GetLocalAddress(IpAddress &ipAddress) const;
00181
00187     ACTIV_IP_API void GetRemoteAddress(IpAddress &ipAddress) const;
00188
00200     ACTIV_IP_API void SetRxBufferSize(const int size);
00201
00213     ACTIV_IP_API void SetTxBufferSize(const int size);
00214
00225     ACTIV_IP_API void SetSocketOption(const int optionName, const char *pOptionValue, const socklen_t optionLength, const int level = SOL_SOCKET);
00226
00237     ACTIV_IP_API void GetSocketOption(const int optionName, char *pOptionValue, socklen_t *pOptionLength, const int level = SOL_SOCKET);
00238
00244     ACTIV_IP_API SOCKET GetSocketHandle() const;
00245
00246 protected:
00254     ACTIV_IP_API virtual void OnSetSocketOptions();
00255
00262     ACTIV_IP_API virtual bool OnInitializeIo();
00263
00269     ACTIV_IP_API virtual void OnCleanupIo();
00270
00274     ACTIV_IP_API virtual GetBuffersResult OnGetRxBuffers();
00275
00284     ACTIV_IP_API virtual CompletionResult OnRxBuffers(const size_t dataLength);
00285
00289     ACTIV_IP_API virtual GetBuffersResult OnGetTxBuffers();
00290
00299     ACTIV_IP_API virtual CompletionResult OnTxBuffers(const size_t dataLength);
00300
00306     ACTIV_IP_API bool PostRead();
00307
00313     ACTIV_IP_API bool PostWrite();
00314
00320     ACTIV_IP_API bool CleanupIo();
00321
00325     ACTIV_IP_API void CloseSocket();
00326
00332     ACTIV_IP_API bool ShutdownSocket();
00333
00339     virtual void HandleIoFailure(const bool gracefully) = 0;
00340
00344     class TxOverlapped : public IoCompletionManager::Overlapped
00345     {
00346     public:
00352         TxOverlapped(IpSocket &ipSocket);
00353
00354     private:
00355         virtual void OnIoCompletion();
00356
00357         IpSocket &m_ipSocket;
00358     };
00359
00363     class RxOverlapped : public IoCompletionManager::Overlapped
00364     {
00365     public:
00371         RxOverlapped(IpSocket &ipSocket);
00372
00373     private:
00374         virtual void OnIoCompletion();
00375
00376         IpSocket &m_ipSocket;
00377     };
00378
00379     IpManager &     m_ipManager;
00380
00381     IMutex * const  m_pMutex;
00382     SocketWrapper   m_handle;
00383
00384     RxOverlapped    m_rxOverlapped;
00385     WsaBufHelper    m_rxBuffers;
00386     DWORD           m_rxFlags;
00387     uint64_t        m_rxBytes;
00388
00389     TxOverlapped    m_txOverlapped;
00390     WsaBufHelper    m_txBuffers;
00391     DWORD           m_txFlags;
00392     uint64_t        m_txBytes;
00393
00394     IpAddress       m_remoteAddress;
00395     IpAddress       m_localAddress;
00396
00397     IpAddress       m_toAddress;
00398     IpAddress       m_fromAddress;
00399
00400     bool            m_closePosted;
00401     bool            m_closeOnTxCompletion;
00402
00403 private:
00409     bool InitiateWrite();
00410
00416     bool InitiateRead();
00417
00421     void ProcessTxCompletion();
00422
00426     void ProcessRxCompletion();
00427
00428     friend class IpManager;
00429 };
00430
00431 // ---------------------------------------------------------------------------------------------------------------------------------
00432
00433 inline void IpSocket::LockedRead()
00434 {
00435     ScopedMutexLocker scopedMutexLocker(m_pMutex);
00436
00437     PreLockedRead();
00438 }
00439
00440 // ---------------------------------------------------------------------------------------------------------------------------------
00441
00442 inline void IpSocket::PreLockedRead()
00443 {
00444     // if a read is currently still in progress, we can't do anything here. Once the read completes, PostRead()
00445     // will be called internally
00446     if (!m_rxOverlapped.IsPending())
00447     {
00448         if (!PostRead())
00449             HandleIoFailure(false);
00450     }
00451 }
00452
00453 // ---------------------------------------------------------------------------------------------------------------------------------
00454
00455 inline void IpSocket::LockedWrite()
00456 {
00457     ScopedMutexLocker scopedMutexLocker(m_pMutex);
00458
00459     PreLockedWrite();
00460 }
00461
00462 // ---------------------------------------------------------------------------------------------------------------------------------
00463
00464 inline void IpSocket::PreLockedWrite()
00465 {
00466     // if a write is currently still in progress, we can't do anything here. Once the write completes, PostWrite()
00467     // will be called and the data will be taken off the tx handler's queue and written to the socket in the context
00468     // of an io thread
00469     if (!m_txOverlapped.IsPending())
00470     {
00471         if (!PostWrite())
00472             HandleIoFailure(false);
00473     }
00474 }
00475
00476 } // namespace Activ
00477
00478 #endif // (!defined ACTIV_IP_WINDOWS_IP_SOCKET_H)
Generated on Wed Oct 8 14:01:48 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivIp » Windows

TcpListener.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_IP_WINDOWS_TCP_LISTENER_H)
00010 #define ACTIV_IP_WINDOWS_TCP_LISTENER_H
00011
00012 #include "ActivMiddleware/ActivIp/External.h"
00013 #include "ActivMiddleware/ActivIp/IpManager.h"
00014 #include "ActivMiddleware/ActivIp/SocketWrapper.h"
00015 #include "ActivMiddleware/ActivIp/IpAddress.h"
00016 #include "ActivMiddleware/ActivBase/MutexHelper.h"
00017
00021 #define ACTIV_TCP_LISTENER_STATE_LIST(d)    \
00022     d(STATE_NOT_LISTENING)                  \
00023     d(STATE_LISTENING)
00024
00025 namespace Activ
00026 {
00027
00031 class TcpListener : private boost::noncopyable
00032 {
00033 public:
00037     enum State
00038     {
00039         ACTIV_TCP_LISTENER_STATE_LIST(ACTIV_DECLARE_VALUE_WITH_COMMA)
00040         NUM_STATES
00041     };
00042
00050     ACTIV_IP_API TcpListener(IpManager &ipManager);
00051
00055     ACTIV_IP_API ~TcpListener();
00056
00066     ACTIV_IP_API void Start(const uint16_t localPort, const char *localAddress = 0, const int backlog = SOMAXCONN);
00067
00076     ACTIV_IP_API void Start(const IpAddress &localAddress, const int backlog = SOMAXCONN);
00077
00085     ACTIV_IP_API bool Stop();
00086
00092     ACTIV_IP_API SOCKET GetHandle() const;
00093
00099     ACTIV_IP_API void GetLocalAddress(IpAddress &ipAddress) const;
00100
00106     ACTIV_IP_API State GetState() const;
00107
00113     ACTIV_IP_API static std::string StateToString(const State state);
00114
00115 private:
00116     IpManager &     m_ipManager;
00117     IMutex * const  m_pMutex;
00118     State           m_state;
00119     SocketWrapper   m_socket;
00120     IpAddress       m_localAddress;
00121
00122     friend class TcpSocket;
00123 };
00124
00125 } // namespace Activ
00126
00127 #endif // (!defined ACTIV_IP_WINDOWS_TCP_LISTENER_H)
Generated on Wed Oct 8 14:01:48 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivIp » Windows

TcpSocket.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_IP_WINDOWS_TCP_SOCKET_H)
00010 #define ACTIV_IP_WINDOWS_TCP_SOCKET_H
00011
00012 #include "ActivMiddleware/ActivIp/IpSocket.h"
00013
00014 #include <mswsock.h>
00015
00019 #define ACTIV_IP_SOCKET_STATE_LIST(d)   \
00020     d(STATE_INITIALIZED)                \
00021     d(STATE_W4_CONNECT)                 \
00022     d(STATE_W4_ACCEPT)                  \
00023     d(STATE_CONNECTED)                  \
00024     d(STATE_W4_DISCONNECT)
00025
00026 namespace Activ
00027 {
00028
00029 class TcpListener;
00030
00031 // ---------------------------------------------------------------------------------------------------------------------------------
00032
00036 class TcpSocket : public IpSocket
00037 {
00038 public:
00042     enum State
00043     {
00044         ACTIV_IP_SOCKET_STATE_LIST(ACTIV_DECLARE_VALUE_WITH_COMMA)
00045         NUM_STATES
00046     };
00047
00051     class Settings : public IpSocket::Settings
00052     {
00053     public:
00059         ACTIV_IP_API Settings(const bool shouldCork = false);
00060     };
00061
00065     class Stats : public IpSocket::Stats
00066     {
00067     public:
00077         ACTIV_IP_API Stats(const TcpSocket &socket);
00078
00079         State   m_state;
00080         bool    m_connectPosted;
00081         bool    m_acceptPosted;
00082     };
00083
00092     ACTIV_IP_API TcpSocket(IpManager &manager, const Settings &settings = Settings());
00093
00097     ACTIV_IP_API ~TcpSocket();
00098
00109     ACTIV_IP_API void Connect(const char *remoteAddress, const uint16_t remotePort, const char *localAddress = 0, const uint16_t localPort = 0);
00110
00119     ACTIV_IP_API void Connect(const IpAddress &remoteAddress, const IpAddress &localAddress);
00120
00126     ACTIV_IP_API void PostConnect();
00127
00135     ACTIV_IP_API void Accept(TcpListener &listener);
00136
00146     ACTIV_IP_API bool Disconnect(const bool gracefully = false);
00147
00153     ACTIV_IP_API void LockedBreak();
00154
00160     ACTIV_IP_API void PreLockedBreak();
00161
00167     ACTIV_IP_API static std::string StateToString(const State state);
00168
00169 protected:
00170     // IpSocket overrides
00171     ACTIV_IP_API virtual CompletionResult OnRxBuffers(const size_t dataLength);
00172     ACTIV_IP_API virtual CompletionResult OnTxBuffers(const size_t dataLength);
00173
00177     ACTIV_IP_API virtual void OnDisconnect();
00178
00182     ACTIV_IP_API virtual void OnBreak();
00183
00187     ACTIV_IP_API virtual void OnConnect();
00188
00192     ACTIV_IP_API virtual void OnConnectAborted();
00193
00199     ACTIV_IP_API virtual void OnConnectFailed(const uint32_t errorCode);
00200
00204     ACTIV_IP_API virtual void OnAccept();
00205
00209     ACTIV_IP_API virtual void OnAcceptAborted();
00210
00216     ACTIV_IP_API virtual void OnAcceptFailed(const uint32_t errorCode);
00217
00218     State   m_state;
00219
00220 private:
00228     void PreLockedPostConnect();
00229
00235     void CreateClientSocket();
00236
00242     void CreateAcceptSocket();
00243
00249     void CompleteCreateAcceptSocket();
00250
00254     void Cleanup();
00255
00256     ACTIV_IP_API virtual void HandleIoFailure(const bool gracefully);
00257
00261     void ProcessConnectCompletion();
00262
00266     void ProcessSuccessfulConnectCompletion();
00267
00271     void ProcessAcceptCompletion();
00272
00276     void ProcessSuccessfulAcceptCompletion();
00277
00281     class BsdThreadInfo
00282     {
00283     public:
00290         BsdThreadInfo(TcpSocket &tcpSocket, const SOCKET socket);
00291
00292         TcpSocket & m_tcpSocket;
00293         SOCKET      m_socket;
00294     };
00295
00299     class ConnectThreadInfo : public BsdThreadInfo
00300     {
00301     public:
00309         ConnectThreadInfo(TcpSocket &tcpSocket, const SOCKET socket, const IpAddress &remoteAddress);
00310
00311         IpAddress   m_remoteAddress;
00312     };
00313
00319     void BsdConnect(ConnectThreadInfo * const pConnectThreadInfo);
00320
00324     static unsigned WINAPI BsdConnectThread(void *p);
00325
00331     void BsdAccept(BsdThreadInfo * const pBsdThreadInfo);
00332
00336     static unsigned WINAPI BsdAcceptThread(void *p);
00337
00341     class ConnectOverlapped : public IoCompletionManager::Overlapped
00342     {
00343     public:
00349         ConnectOverlapped(TcpSocket &tcpSocket);
00350
00351     private:
00352         virtual void OnIoCompletion();
00353
00354         TcpSocket &m_tcpSocket;
00355     };
00356
00360     class AcceptOverlapped : public IoCompletionManager::Overlapped
00361     {
00362     public:
00368         AcceptOverlapped(TcpSocket &tcpSocket);
00369
00370     private:
00371         virtual void OnIoCompletion();
00372
00373         TcpSocket &m_tcpSocket;
00374     };
00375
00376     // client side members
00377     ConnectOverlapped           m_connectOverlapped;
00378     LPFN_CONNECTEX              m_pConnectEx;
00379     IpAddress                   m_providedLocalAddress;
00380
00381     // server side members
00382     static const size_t PADDED_ADDRESS_SIZE = sizeof(SOCKADDR_IN6) + 16;
00383     static const size_t ACCEPT_BUFFER_SIZE = 2 * PADDED_ADDRESS_SIZE;
00384
00385     AcceptOverlapped            m_acceptOverlapped;
00386     SOCKET                      m_listeningSocket;
00387     byte_t                      m_acceptBuffer[ACCEPT_BUFFER_SIZE];
00388     LPFN_ACCEPTEX               m_pAcceptEx;
00389     LPFN_GETACCEPTEXSOCKADDRS   m_pGetAcceptExSockAddrs;
00390 };
00391
00392 } // namespace Activ
00393
00394 #endif // (!defined ACTIV_IP_WINDOWS_TCP_SOCKET_H)
Generated on Wed Oct 8 14:01:48 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivIp » Windows

UdpSocket.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_IP_WINDOWS_UDP_SOCKET_H)
00010 #define ACTIV_IP_WINDOWS_UDP_SOCKET_H
00011
00012 #include "ActivMiddleware/ActivIp/IpSocket.h"
00013
00017 #define ACTIV_UDP_SOCKET_STATE_LIST(d)  \
00018     d(STATE_INITIALIZED)                \
00019     d(STATE_CREATED)                    \
00020     d(STATE_CONNECTED)                  \
00021     d(STATE_CLOSING)
00022
00023 namespace Activ
00024 {
00025
00029 class UdpSocket : public IpSocket
00030 {
00031 public:
00035     enum State
00036     {
00037         ACTIV_UDP_SOCKET_STATE_LIST(ACTIV_DECLARE_VALUE_WITH_COMMA)
00038         NUM_STATES
00039     };
00040
00044     class Settings : public IpSocket::Settings
00045     {
00046     public:
00052         ACTIV_IP_API Settings(const bool shouldCork = false);
00053     };
00054
00058     class Stats : public IpSocket::Stats
00059     {
00060     public:
00070         ACTIV_IP_API Stats(const UdpSocket &socket);
00071
00072         State   m_state;
00073     };
00074
00083     ACTIV_IP_API UdpSocket(IpManager &manager, const Settings &settings = Settings());
00084
00090     ACTIV_IP_API ~UdpSocket();
00091
00100     ACTIV_IP_API void Initialize(const std::string &localAddressString, const uint16_t localPort);
00101
00109     ACTIV_IP_API void Initialize(const IpAddress &localAddress);
00110
00119     ACTIV_IP_API void Connect(const std::string &remoteAddressString, const uint16_t remotePort);
00120
00128     ACTIV_IP_API void Connect(const IpAddress &remoteAddress);
00129
00135     ACTIV_IP_API void Disconnect();
00136
00146     ACTIV_IP_API bool Shutdown(const bool gracefully = false);
00147
00154     ACTIV_IP_API void AbortiveClose();
00155
00164     ACTIV_IP_API void JoinMulticastGroup(const std::string &multicastGroupString, const std::string &interfaceAddressString);
00165
00174     ACTIV_IP_API void LeaveMulticastGroup(const std::string &multicastGroupString, const std::string &interfaceAddressString);
00175
00183     ACTIV_IP_API void SetMulticastTxInterface(const std::string &interfaceAddressString);
00184
00192     ACTIV_IP_API void SetMulticastTtl(const int ttl);
00193
00201     ACTIV_IP_API void SetUnicastTtl(const int ttl);
00202
00210     ACTIV_IP_API void SetMulticastLoopback(const bool isEnabled);
00211
00217     ACTIV_IP_API static std::string StateToString(const State state);
00218
00219 protected:
00220     // IpSocket overrides
00221     ACTIV_IP_API virtual CompletionResult OnRxBuffers(const size_t dataLength);
00222     ACTIV_IP_API virtual CompletionResult OnTxBuffers(const size_t dataLength);
00223
00227     ACTIV_IP_API virtual void OnError();
00228
00232     ACTIV_IP_API virtual void OnShutdown();
00233
00234     State       m_state;
00235
00236 private:
00242     void CreateSocket();
00243
00247     void Cleanup();
00248
00249     ACTIV_IP_API virtual void HandleIoFailure(const bool gracefully);
00250
00260     void MulticastGroupAction(const std::string &multicastGroupString, const std::string &interfaceAddressString, const bool join);
00261
00271     void Ipv4MulticastGroupAction(const IpAddress &multicastAddress, const IpAddress &interfaceAddress, const bool join);
00272
00282     void Ipv6MulticastGroupAction(const IpAddress &multicastAddress, const IpAddress &interfaceAddress, const bool join);
00283
00291     void SetIpv4MulticastTxInterface(const IpAddress &interfaceAddress);
00292
00300     void SetIpv6MulticastTxInterface(const IpAddress &interfaceAddress);
00301 };
00302
00303 } // namespace Activ
00304
00305 #endif // (!defined ACTIV_IP_WINDOWS_UDP_SOCKET_H)
Generated on Wed Oct 8 14:01:48 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » Config » Platforms

Windows.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_CONFIG_PLATFORMS_WINDOWS_H)
00010 #define ACTIV_CONFIG_PLATFORMS_WINDOWS_H
00011
00012 #if (ACTIV_PLATFORM_WINDOWS == 64)
00013 #define ACTIV_PLATFORM_NAME     "Win64"
00014 #else
00015 #define ACTIV_PLATFORM_NAME     "Win32"
00016 #endif
00017
00018 #define ACTIV_PLATFORM_TYPE     Activ::PLATFORM_TYPE_WINDOWS
00019
00020 #if (!defined _WIN32_WINNT)
00021 #define _WIN32_WINNT 0x501
00022 #endif
00023
00024 // prevent definition of max and min macros in windef.h. Must be defined before windows.h is included.
00025 #if (!defined NOMINMAX)
00026 #define NOMINMAX
00027 #endif
00028
00029 #include <winsock2.h>
00030 #include <ws2tcpip.h>
00031 #include <windows.h>
00032
00033 #define ACTIV_WAIT_INFINITE INFINITE
00034
00035 #if (ACTIV_PLATFORM_WINDOWS == 32) && (!defined ACTIV_COMPILER_GCC)
00036 #define ACTIV_EXPLICIT_INSTANTIATE_SIZE_T
00037 #endif
00038
00039 #endif // (!defined ACTIV_CONFIG_PLATFORMS_WINDOWS_H)
Generated on Wed Oct 8 14:01:49 2008 for ACTIV C++ SDK by doxygen 1.5.4


include » ActivMiddleware » ActivIp » Windows

WsaBufHelper.h

Go to the documentation of this file.
00001
00009 #if (!defined ACTIV_IP_WINDOWS_WSA_BUF_HELPER_H)
00010 #define ACTIV_IP_WINDOWS_WSA_BUF_HELPER_H
00011
00012 #include "ActivMiddleware/ActivIp/External.h"
00013 #include "ActivMiddleware/ActivBase/CrtException.h"
00014
00015 #include <cassert>
00016
00017 namespace Activ
00018 {
00019
00023 class WsaBufHelper : private boost::noncopyable
00024 {
00025 public:
00033     WsaBufHelper(const size_t initialSize = 10);
00034
00038     ~WsaBufHelper();
00039
00043     void Reset();
00044
00053     void Append(void *pData, const size_t dataLength);
00054
00060     WSABUF *GetFirstBuffer() const;
00061
00067     size_t GetNumberOfBuffersInUse() const;
00068
00074     size_t GetTotalBytes() const;
00075
00076 private:
00082     ACTIV_IP_API void Extend();
00083
00084     WSABUF *        m_pWsaBuf;
00085     const size_t    m_initialSize;
00086     size_t          m_numberOfBuffers;
00087     size_t          m_numberInUse;
00088     size_t          m_totalBytes;
00089 };
00090
00091 // ---------------------------------------------------------------------------------------------------------------------------------
00092
00093 inline WsaBufHelper::WsaBufHelper(const size_t initialSize) :
00094     m_pWsaBuf(NULL),
00095     m_initialSize(initialSize),
00096     m_numberOfBuffers(0),
00097     m_numberInUse(0),
00098     m_totalBytes(0)
00099 {
00100     assert(0 != initialSize);
00101     Extend();
00102 }
00103
00104 // ---------------------------------------------------------------------------------------------------------------------------------
00105
00106 inline WsaBufHelper::~WsaBufHelper()
00107 {
00108     if (NULL != m_pWsaBuf)
00109         ::free(m_pWsaBuf);
00110 }
00111
00112 // ---------------------------------------------------------------------------------------------------------------------------------
00113
00114 inline void WsaBufHelper::Reset()
00115 {
00116     m_numberInUse = 0;
00117     m_totalBytes = 0;
00118 }
00119
00120 // ---------------------------------------------------------------------------------------------------------------------------------
00121
00122 inline void WsaBufHelper::Append(void *pData, const size_t dataLength)
00123 {
00124     // do we need to extend the WSABUF array?
00125     if (m_numberInUse == m_numberOfBuffers)
00126         Extend();
00127
00128     m_pWsaBuf[m_numberInUse].buf = reinterpret_cast<char *>(pData);
00129     m_pWsaBuf[m_numberInUse].len = static_cast<DWORD>(dataLength);
00130
00131     m_totalBytes += dataLength;
00132     ++m_numberInUse;
00133 }
00134
00135 // ---------------------------------------------------------------------------------------------------------------------------------
00136
00137 inline WSABUF *WsaBufHelper::GetFirstBuffer() const
00138 {
00139     return m_pWsaBuf;
00140 }
00141
00142 // ---------------------------------------------------------------------------------------------------------------------------------
00143
00144 inline size_t WsaBufHelper::GetNumberOfBuffersInUse() const
00145 {
00146     return m_numberInUse;
00147 }
00148
00149 // ---------------------------------------------------------------------------------------------------------------------------------
00150
00151 inline size_t WsaBufHelper::GetTotalBytes() const
00152 {
00153     return m_totalBytes;
00154 }
00155
00156 } // namespace Activ
00157
00158 #endif // (!defined ACTIV_IP_WINDOWS_WSA_BUF_HELPER_H)
Generated on Wed Oct 8 14:01:48 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Address Member List

This is the complete list of members for Activ::Address, including all inherited members.

Address() | Activ::Address | [inline]
Address(const EndPointId endPointId, const PortId portId) | Activ::Address | [inline]
Clear() | Activ::Address | [inline]
Deserialize(MessageValidator &messageValidator) | Activ::Address | [inline]
GetEndPointId() const | Activ::Address | [inline]
GetPortId() const | Activ::Address | [inline]
GetSerializedLength() | Activ::Address | [inline, static]
IsValid() const | Activ::Address | [inline]
operator!=(const Address &rhs) const | Activ::Address | [inline]
operator<(const Address &rhs) const | Activ::Address | [inline]
operator==(const Address &rhs) const | Activ::Address | [inline]
Serialize(MessageBuilder &messageBuilder) const | Activ::Address | [inline]
Set(const EndPointId endPointId, const PortId portId) | Activ::Address | [inline]
SetEndPointId(const EndPointId endPointId) | Activ::Address | [inline]
SetPortId(const PortId portId) | Activ::Address | [inline]
ToString() const | Activ::Address | [inline]

Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Address::Proxy Member List

This is the complete list of members for Activ::Address::Proxy, including all inherited members.

operator Address &() | Activ::Address::Proxy | [inline]
Proxy(Address &address) | Activ::Address::Proxy | [inline]

Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::AgentApplication Member List

This is the complete list of members for Activ::AgentApplication, including all inherited members.

AgentApplication(const Settings &settings=Settings(), const std::string &componentId=defaultComponentId) | Activ::AgentApplication |
anonymousName | Activ::Port | [static]
CanThreadExit() | Activ::AgentApplication | [protected, virtual]
Component(Application &application, ManagedEndPoint &managedEndPoint, const std::string &name=anonymousName, IHeap *const pHeap=0, const std::string &componentId=defaultComponentId) | Activ::Component |
CreateEndPoint(const std::string &name, const bool hasMutex, const IEndPoint::NotificationType notificationType) | Activ::SystemProxy | [virtual]
CreateHeap(const std::string &name, const IHeap::BucketInfoVector &bucketInfoVector) | Activ::SystemProxy | [virtual]
CreatePrivateEndPoint(const bool hasMutex, const IEndPoint::NotificationType notificationType) | Activ::SystemProxy | [virtual]
defaultComponentId | Activ::Component | [static]
defaultTimeout | Activ::Port | [static]
Disable() | Activ::Port |
Enable() | Activ::Port |
EnumerateObjects(IProcessEnumerator &enumerator) | Activ::SystemProxy | [virtual]
EnumerateObjects(IEndPointEnumerator &enumerator) | Activ::SystemProxy | [virtual]
EnumerateObjects(IHeapEnumerator &enumerator) | Activ::SystemProxy | [virtual]
Activ::FindPort(const std::string &portName, Address &portAddress) const | Activ::ManagedEndPoint |
Activ::Component::FindPort(const std::string &endPointName, const std::string &portName, Address &portAddress, const TimeoutPeriod timeout=defaultTimeout) | Activ::Port |
ForwardMessage(const Address &destinationAddress, HeapMessage &message, const MessageType newType=INVALID_MESSAGE_TYPE) const | Activ::Port |
GetAddress() const | Activ::Port | [inline]
GetApplication() const | Activ::Component |
GetEndPoint() const | Activ::ManagedEndPoint |
GetHeap() const | Activ::Port | [inline]
GetManagedEndPoint() const | Activ::Port |
GetMaxThreads() const | Activ::ManagedEndPoint |
GetMonitorServiceHeap() const | Activ::Application |
GetName() const | Activ::Port |
GetPrivate() const | Activ::Application | [inline]
GetProcess() const | Activ::SystemProxy | [virtual]
GetSystemHeap() const | Activ::SystemProxy | [virtual]
GetSystemInfo() const | Activ::SystemProxy | [virtual]
GetSystemName() const | Activ::SystemProxy | [virtual]
GetUiServiceName() | Activ::Application | [static]
IsSystemRestartable() | Activ::AgentApplication |
ManagedEndPoint(ISystem *const pSystem, const std::string &name, const Settings &settings=Settings()) | Activ::ManagedEndPoint |
ManagedEndPoint::Impl (defined in Activ::Port) | Activ::Port | [friend]
OnAccept(HeapMessage &acceptMessage) | Activ::Component | [protected, virtual]
OnBreak(HeapMessage &breakMessage) | Activ::Component | [protected, virtual]
OnConnect(HeapMessage &connectMessage) | Activ::Component | [protected, virtual]
OnConnectFailed(HeapMessage &connectFailMessage) | Activ::Component | [protected, virtual]
OnCtrlEvent(const CtrlHandler::EventType eventType) | Activ::AgentApplication | [protected, virtual]
OnData(HeapMessage &heapMessage) | Activ::Component | [protected, virtual]
OnDisconnect(HeapMessage &disconnectMessage) | Activ::Component | [protected, virtual]
OnMessage(HeapMessage &message) | Activ::AgentApplication | [protected, virtual]
OnRequest(HeapMessage &request) | Activ::Component | [protected, virtual]
OnResponse(HeapMessage &response) | Activ::Port | [protected, virtual]
OnShutdown(const ShutdownReason shutdownReason) | Activ::Application | [protected, virtual]
OnTimer(const Address &timerAddress, const BaseTime &time) | Activ::Component | [protected, virtual]
OpenEndPoint(const std::string &name, Timeout &timeout=Timeout::GetInfinite()) | Activ::SystemProxy | [virtual]
OpenEndPoint(EndPointId endPointId, Timeout &timeout=Timeout::GetInfinite()) | Activ::SystemProxy | [virtual]
OpenHeap(const std::string &name, Timeout &timeout=Timeout::GetInfinite()) | Activ::SystemProxy | [virtual]
OpenHeap(const HeapId heapId, Timeout &timeout=Timeout::GetInfinite()) | Activ::SystemProxy | [virtual]
OpenProcess(const std::string &name, Timeout &timeout=Timeout::GetInfinite()) | Activ::SystemProxy | [virtual]
OpenProcess(const ProcessId processId, Timeout &timeout=Timeout::GetInfinite()) | Activ::SystemProxy | [virtual]
Port(ManagedEndPoint &managedEndPoint, const std::string &name, IHeap *const pHeap) | Activ::Port |
Activ::Component::Port(ManagedEndPoint &managedEndPoint, const std::string &name, const PortId portId, IHeap *const pHeap) | Activ::Port |
PortIdSet typedef | Activ::ManagedEndPoint |
PostDiesToThreads() const | Activ::ManagedEndPoint |
PostEmptyResponse(const StatusCode responseStatus, HeapMessage &response) const | Activ::Port |
PostEmptyResponse(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, const StatusCode responseStatus, HeapMessage &response) const | Activ::Port |
PostMessage(const Address &destinationAddress, const MessageType messageType, const MessageBuilder &messageBuilder) const | Activ::Port |
PostMessage(const Address &destinationAddress, const MessageType messageType, const void *pMessage=0, const size_t messageLength=0) const | Activ::Port |
PostMessage(const Address &destinationAddress, const MessageType messageType, HeapMessage &message) const | Activ::Port |
PostRequest(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, const MessageBuilder &messageBuilder) const | Activ::Port |
PostRequest(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, const void *pRequest=0, const size_t requestLength=0) const | Activ::Port |
PostRequest(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, HeapMessage &request) const | Activ::Port |
PostResponse(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, const StatusCode responseStatus, const MessageBuilder &messageBuilder) const | Activ::Port |
PostResponse(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, const StatusCode responseStatus, const void *pResponse=0, const size_t responseLength=0) const | Activ::Port |
PostResponse(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, const StatusCode responseStatus, HeapMessage &response) const | Activ::Port |
PostResponse(const StatusCode responseStatus, HeapMessage &request, const MessageBuilder &messageBuilder) const | Activ::Port |
PostResponse(const StatusCode responseStatus, HeapMessage &request, const void *pResponse, const size_t responseLength) const | Activ::Port |
PostResponse(const StatusCode responseStatus, HeapMessage &request, HeapMessage &response) const | Activ::Port |
PostResponse(const StatusCode responseStatus, HeapMessage &request) const | Activ::Port |
Process() | Activ::ManagedEndPoint | [protected, virtual]
RestartSystem() | Activ::AgentApplication |
Run() | Activ::ManagedEndPoint |
SendRequest(const Address &destinationAddress, const MessageType requestType, const MessageBuilder &messageBuilder, HeapMessage &response, const TimeoutPeriod timeout=defaultTimeout) const | Activ::Port |
SendRequest(const Address &destinationAddress, const MessageType requestType, const void *pRequest, const size_t requestLength, HeapMessage &response, const TimeoutPeriod timeout=defaultTimeout) const | Activ::Port |
SendRequest(const Address &destinationAddress, const MessageType requestType, HeapMessage &request, const TimeoutPeriod timeout=defaultTimeout) const | Activ::Port |
SendRequest(const Address &destinationAddress, const MessageType requestType, SyncRequestId &syncRequestId, const MessageBuilder &messageBuilder) const | Activ::Port |
SendRequest(const Address &destinationAddress, const MessageType requestType, SyncRequestId &syncRequestId, const void *pRequest, const size_t requestLength) const | Activ::Port |
SendRequest(const Address &destinationAddress, const MessageType requestType, SyncRequestId &syncRequestId, HeapMessage &request) const | Activ::Port |
SetHeap(IHeap *const pHeap) | Activ::Port |
Shutdown() | Activ::Application |
SHUTDOWN_REASON_API enum value | Activ::Application |
SHUTDOWN_REASON_LOGOFF enum value | Activ::Application |
SHUTDOWN_REASON_NOT_LICENSED enum value | Activ::Application |
SHUTDOWN_REASON_PROCESS_KILLED enum value | Activ::Application |
SHUTDOWN_REASON_UI enum value | Activ::Application |
SHUTDOWN_REASON_UI_RESTART enum value | Activ::Application |
SHUTDOWN_REASON_UPDATING enum value | Activ::Application |
ShutdownReason enum name | Activ::Application |
StartThread() | Activ::ManagedEndPoint |
WaitForThreadsToExit(const TimeoutPeriod timeout=ACTIV_WAIT_INFINITE) const | Activ::ManagedEndPoint |
~AgentApplication() | Activ::AgentApplication | [virtual]
~Application() | Activ::Application | [virtual]
~Component() | Activ::Component |
~ISystem()=0 | Activ::ISystem | [inline, pure virtual]
~ManagedEndPoint() | Activ::ManagedEndPoint | [virtual]
~Port() | Activ::Port | [virtual]
~SystemProxy() | Activ::SystemProxy |

Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::AgentApplication::Settings Member List

This is the complete list of members for Activ::AgentApplication::Settings, including all inherited members.

EXCEPTION_HANDLER_TYPE_FULL_MEMORY enum value | Activ::Application::Settings |
EXCEPTION_HANDLER_TYPE_NONE enum value | Activ::Application::Settings |
EXCEPTION_HANDLER_TYPE_NORMAL enum value | Activ::Application::Settings |
ExceptionHandlerType enum name | Activ::Application::Settings |
m_createSystemLog | Activ::AgentApplication::Settings |
m_directoryServiceSettings | Activ::AgentApplication::Settings |
m_enableCtrlHandler | Activ::Application::Settings |
m_enableUiService | Activ::AgentApplication::Settings |
m_exceptionHandlerType | Activ::Application::Settings |
m_extendedUiShutdown | Activ::AgentApplication::Settings |
m_licenseServiceSettings | Activ::AgentApplication::Settings |
m_loggerServiceSettings | Activ::AgentApplication::Settings |
m_managedEndPointSettings | Activ::Application::Settings |
m_memoryModel | Activ::ISystem::Settings |
m_minimumTimerResolution | Activ::ISystem::Settings |
m_monitorServiceSettings | Activ::AgentApplication::Settings |
m_processorAffinityList | Activ::ISystem::Settings |
m_processStartupIniFile | Activ::AgentApplication::Settings |
m_processVersion | Activ::ISystem::Settings |
m_pubSubServiceSettings | Activ::AgentApplication::Settings |
m_routerServiceSettings | Activ::AgentApplication::Settings |
m_serviceLocationIniFile | Activ::AgentApplication::Settings |
m_setConsoleTitle | Activ::ISystem::Settings |
m_smallBlockHeapThreshold | Activ::ISystem::Settings |
m_systemHeapBucketInfo | Activ::AgentApplication::Settings |
m_systemLogMaxSize | Activ::AgentApplication::Settings |
m_systemLogMode | Activ::ISystem::Settings |
m_systemLogNumberOfBackups | Activ::AgentApplication::Settings |
m_systemLogType | Activ::AgentApplication::Settings |
m_systemLogUniqueName | Activ::AgentApplication::Settings |
m_systemName | Activ::ISystem::Settings |
m_systemVersion | Activ::AgentApplication::Settings |
m_timerServiceSettings | Activ::AgentApplication::Settings |
m_uiServiceSettings | Activ::AgentApplication::Settings |
MEMORY_MODEL_PRIVATE enum value | Activ::ISystem::Settings |
MEMORY_MODEL_SHARED enum value | Activ::ISystem::Settings |
MemoryModel enum name | Activ::ISystem::Settings |
Read(const IniFileParser &iniFileParser) | Activ::AgentApplication::Settings |
Activ::Application::Settings::Read(const IniFileParser::ConstSectionIterator &sectionIterator) | Activ::Application::Settings |
sectionName | Activ::ISystem::Settings | [protected, static]
Settings() | Activ::AgentApplication::Settings |
SYSTEM_LOG_MODE_OFF enum value | Activ::ISystem::Settings |
SYSTEM_LOG_MODE_TO_AGENT enum value | Activ::ISystem::Settings |
SYSTEM_LOG_MODE_TO_CONSOLE enum value | Activ::ISystem::Settings |
SystemLogMode enum name | Activ::ISystem::Settings |
~Settings() | Activ::AgentApplication::Settings |

Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Application Member List

This is the complete list of members for Activ::Application, including all inherited members.

AgentApplication (defined in Activ::Application) | Activ::Application | [friend]
anonymousName | Activ::Port | [static]
CanThreadExit() | Activ::ManagedEndPoint | [protected, virtual]
Component(Application &application, ManagedEndPoint &managedEndPoint, const std::string &name=anonymousName, IHeap *const pHeap=0, const std::string &componentId=defaultComponentId) | Activ::Component |
CreateEndPoint(const std::string &name, const bool hasMutex, const IEndPoint::NotificationType notificationType) | Activ::SystemProxy | [virtual]
CreateHeap(const std::string &name, const IHeap::BucketInfoVector &bucketInfoVector) | Activ::SystemProxy | [virtual]
CreatePrivateEndPoint(const bool hasMutex, const IEndPoint::NotificationType notificationType) | Activ::SystemProxy | [virtual]
defaultComponentId | Activ::Component | [static]
defaultTimeout | Activ::Port | [static]
Disable() | Activ::Port |
Enable() | Activ::Port |
EnumerateObjects(IProcessEnumerator &enumerator) | Activ::SystemProxy | [virtual]
EnumerateObjects(IEndPointEnumerator &enumerator) | Activ::SystemProxy | [virtual]
EnumerateObjects(IHeapEnumerator &enumerator) | Activ::SystemProxy | [virtual]
Activ::FindPort(const std::string &portName, Address &portAddress) const | Activ::ManagedEndPoint |
Activ::Component::FindPort(const std::string &endPointName, const std::string &portName, Address &portAddress, const TimeoutPeriod timeout=defaultTimeout) | Activ::Port |
ForwardMessage(const Address &destinationAddress, HeapMessage &message, const MessageType newType=INVALID_MESSAGE_TYPE) const | Activ::Port |
GetAddress() const | Activ::Port | [inline]
GetApplication() const | Activ::Component |
GetEndPoint() const | Activ::ManagedEndPoint |
GetHeap() const | Activ::Port | [inline]
GetManagedEndPoint() const | Activ::Port |
GetMaxThreads() const | Activ::ManagedEndPoint |
GetMonitorServiceHeap() const | Activ::Application |
GetName() const | Activ::Port |
GetPrivate() const | Activ::Application | [inline]
GetProcess() const | Activ::SystemProxy | [virtual]
GetSystemHeap() const | Activ::SystemProxy | [virtual]
GetSystemInfo() const | Activ::SystemProxy | [virtual]
GetSystemName() const | Activ::SystemProxy | [virtual]
GetUiServiceName() | Activ::Application | [static]
ManagedEndPoint(ISystem *const pSystem, const std::string &name, const Settings &settings=Settings()) | Activ::ManagedEndPoint |
ManagedEndPoint::Impl (defined in Activ::Port) | Activ::Port | [friend]
OnAccept(HeapMessage &acceptMessage) | Activ::Component | [protected, virtual]
OnBreak(HeapMessage &breakMessage) | Activ::Component | [protected, virtual]
OnConnect(HeapMessage &connectMessage) | Activ::Component | [protected, virtual]
OnConnectFailed(HeapMessage &connectFailMessage) | Activ::Component | [protected, virtual]
OnCtrlEvent(const CtrlHandler::EventType eventType) | Activ::Application | [protected, virtual]
OnData(HeapMessage &heapMessage) | Activ::Component | [protected, virtual]
OnDisconnect(HeapMessage &disconnectMessage) | Activ::Component | [protected, virtual]
OnMessage(HeapMessage &message) | Activ::Application | [protected, virtual]
OnRequest(HeapMessage &request) | Activ::Component | [protected, virtual]
OnResponse(HeapMessage &response) | Activ::Port | [protected, virtual]
OnShutdown(const ShutdownReason shutdownReason) | Activ::Application | [protected, virtual]
OnTimer(const Address &timerAddress, const BaseTime &time) | Activ::Component | [protected, virtual]
OpenEndPoint(const std::string &name, Timeout &timeout=Timeout::GetInfinite()) | Activ::SystemProxy | [virtual]
OpenEndPoint(EndPointId endPointId, Timeout &timeout=Timeout::GetInfinite()) | Activ::SystemProxy | [virtual]
OpenHeap(const std::string &name, Timeout &timeout=Timeout::GetInfinite()) | Activ::SystemProxy | [virtual]
OpenHeap(const HeapId heapId, Timeout &timeout=Timeout::GetInfinite()) | Activ::SystemProxy | [virtual]
OpenProcess(const std::string &name, Timeout &timeout=Timeout::GetInfinite()) | Activ::SystemProxy | [virtual]
OpenProcess(const ProcessId processId, Timeout &timeout=Timeout::GetInfinite()) | Activ::SystemProxy | [virtual]
Port(ManagedEndPoint &managedEndPoint, const std::string &name, IHeap *const pHeap) | Activ::Port |
Activ::Component::Port(ManagedEndPoint &managedEndPoint, const std::string &name, const PortId portId, IHeap *const pHeap) | Activ::Port |
PortIdSet typedef | Activ::ManagedEndPoint |
PostDiesToThreads() const | Activ::ManagedEndPoint |
PostEmptyResponse(const StatusCode responseStatus, HeapMessage &response) const | Activ::Port |
PostEmptyResponse(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, const StatusCode responseStatus, HeapMessage &response) const | Activ::Port |
PostMessage(const Address &destinationAddress, const MessageType messageType, const MessageBuilder &messageBuilder) const | Activ::Port |
PostMessage(const Address &destinationAddress, const MessageType messageType, const void *pMessage=0, const size_t messageLength=0) const | Activ::Port |
PostMessage(const Address &destinationAddress, const MessageType messageType, HeapMessage &message) const | Activ::Port |
PostRequest(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, const MessageBuilder &messageBuilder) const | Activ::Port |
PostRequest(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, const void *pRequest=0, const size_t requestLength=0) const | Activ::Port |
PostRequest(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, HeapMessage &request) const | Activ::Port |
PostResponse(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, const StatusCode responseStatus, const MessageBuilder &messageBuilder) const | Activ::Port |
PostResponse(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, const StatusCode responseStatus, const void *pResponse=0, const size_t responseLength=0) const | Activ::Port |
PostResponse(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, const StatusCode responseStatus, HeapMessage &response) const | Activ::Port |
PostResponse(const StatusCode responseStatus, HeapMessage &request, const MessageBuilder &messageBuilder) const | Activ::Port |
PostResponse(const StatusCode responseStatus, HeapMessage &request, const void *pResponse, const size_t responseLength) const | Activ::Port |
PostResponse(const StatusCode responseStatus, HeapMessage &request, HeapMessage &response) const | Activ::Port |
PostResponse(const StatusCode responseStatus, HeapMessage &request) const | Activ::Port |
Process() | Activ::ManagedEndPoint | [protected, virtual]
Run() | Activ::ManagedEndPoint |
SendRequest(const Address &destinationAddress, const MessageType requestType, const MessageBuilder &messageBuilder, HeapMessage &response, const TimeoutPeriod timeout=defaultTimeout) const | Activ::Port |
SendRequest(const Address &destinationAddress, const MessageType requestType, const void *pRequest, const size_t requestLength, HeapMessage &response, const TimeoutPeriod timeout=defaultTimeout) const | Activ::Port |
SendRequest(const Address &destinationAddress, const MessageType requestType, HeapMessage &request, const TimeoutPeriod timeout=defaultTimeout) const | Activ::Port |
SendRequest(const Address &destinationAddress, const MessageType requestType, SyncRequestId &syncRequestId, const MessageBuilder &messageBuilder) const | Activ::Port |
SendRequest(const Address &destinationAddress, const MessageType requestType, SyncRequestId &syncRequestId, const void *pRequest, const size_t requestLength) const | Activ::Port |
SendRequest(const Address &destinationAddress, const MessageType requestType, SyncRequestId &syncRequestId, HeapMessage &request) const | Activ::Port |
SetHeap(IHeap *const pHeap) | Activ::Port |
Shutdown() | Activ::Application |
SHUTDOWN_REASON_API enum value | Activ::Application |
SHUTDOWN_REASON_LOGOFF enum value | Activ::Application |
SHUTDOWN_REASON_NOT_LICENSED enum value | Activ::Application |
SHUTDOWN_REASON_PROCESS_KILLED enum value | Activ::Application |
SHUTDOWN_REASON_UI enum value | Activ::Application |
SHUTDOWN_REASON_UI_RESTART enum value | Activ::Application |
SHUTDOWN_REASON_UPDATING enum value | Activ::Application |
ShutdownReason enum name | Activ::Application |
StartThread() | Activ::ManagedEndPoint |
ThinApplication (defined in Activ::Application) | Activ::Application | [friend]
WaitForThreadsToExit(const TimeoutPeriod timeout=ACTIV_WAIT_INFINITE) const | Activ::ManagedEndPoint |
~Application() | Activ::Application | [virtual]
~Component() | Activ::Component |
~ISystem()=0 | Activ::ISystem | [inline, pure virtual]
~ManagedEndPoint() | Activ::ManagedEndPoint | [virtual]
~Port() | Activ::Port | [virtual]
~SystemProxy() | Activ::SystemProxy |

Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Application::Settings Member List

This is the complete list of members for Activ::Application::Settings, including all inherited members.

EXCEPTION_HANDLER_TYPE_FULL_MEMORY enum value | Activ::Application::Settings |
EXCEPTION_HANDLER_TYPE_NONE enum value | Activ::Application::Settings |
EXCEPTION_HANDLER_TYPE_NORMAL enum value | Activ::Application::Settings |
ExceptionHandlerType enum name | Activ::Application::Settings |
m_enableCtrlHandler | Activ::Application::Settings |
m_exceptionHandlerType | Activ::Application::Settings |
m_managedEndPointSettings | Activ::Application::Settings |
m_memoryModel | Activ::ISystem::Settings |
m_minimumTimerResolution | Activ::ISystem::Settings |
m_processorAffinityList | Activ::ISystem::Settings |
m_processVersion | Activ::ISystem::Settings |
m_setConsoleTitle | Activ::ISystem::Settings |
m_smallBlockHeapThreshold | Activ::ISystem::Settings |
m_systemLogMode | Activ::ISystem::Settings |
m_systemName | Activ::ISystem::Settings |
MEMORY_MODEL_PRIVATE enum value | Activ::ISystem::Settings |
MEMORY_MODEL_SHARED enum value | Activ::ISystem::Settings |
MemoryModel enum name | Activ::ISystem::Settings |
Read(const IniFileParser::ConstSectionIterator &sectionIterator) | Activ::Application::Settings |
sectionName | Activ::ISystem::Settings | [protected, static]
Settings() | Activ::Application::Settings |
SYSTEM_LOG_MODE_OFF enum value | Activ::ISystem::Settings |
SYSTEM_LOG_MODE_TO_AGENT enum value | Activ::ISystem::Settings |
SYSTEM_LOG_MODE_TO_CONSOLE enum value | Activ::ISystem::Settings |
SystemLogMode enum name | Activ::ISystem::Settings |

Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::AtomicInteger Member List

This is the complete list of members for Activ::AtomicInteger, including all inherited members.

AtomicInteger() | Activ::AtomicInteger | [inline]
AtomicInteger(const Type value) | Activ::AtomicInteger | [inline, explicit]
Exchange(const Type value) | Activ::AtomicInteger | [inline]
Get() const | Activ::AtomicInteger | [inline]
operator Type() const | Activ::AtomicInteger | [inline]
operator++() | Activ::AtomicInteger | [inline]
operator++(int) | Activ::AtomicInteger | [inline]
operator--() | Activ::AtomicInteger | [inline]
operator--(int) | Activ::AtomicInteger | [inline]
Type typedef (defined in Activ::AtomicInteger) | Activ::AtomicInteger |

Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::AtomicPointer< T > Member List

This is the complete list of members for Activ::AtomicPointer< T >, including all inherited members.

AtomicPointer() | Activ::AtomicPointer< T > | [inline]
AtomicPointer(const Pointer pointer) | Activ::AtomicPointer< T > | [inline, explicit]
Exchange(const Pointer value) | Activ::AtomicPointer< T > | [inline]
operator Pointer() const | Activ::AtomicPointer< T > |
operator->() const | Activ::AtomicPointer< T > | [inline]
operator=(const Pointer value) | Activ::AtomicPointer< T > | [inline]
Pointer typedef (defined in Activ::AtomicPointer< T >) | Activ::AtomicPointer< T > |

Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::BaseException Member List

This is the complete list of members for Activ::BaseException, including all inherited members.

ACTIV_DECLARE_ELEMENT_1_WITH_COMMA enum value (defined in Activ::BaseException) | Activ::BaseException |
AddException(Exception *pException) const | Activ::Exception |
BaseException(const char *file, const char *function, const uint_fast32_t line, const uint_fast32_t errorCode) | Activ::BaseException |
Exception(const char *file, const char *function, const uint_fast32_t line, const uint_fast32_t errorCode=0) | Activ::Exception |
Exception(const Exception &rhs) | Activ::Exception |
m_errorCode | Activ::Exception |
m_file | Activ::Exception |
m_function | Activ::Exception |
m_line | Activ::Exception |
ToStream(std::ostream &os) const | Activ::Exception | [virtual]
ToString() const | Activ::BaseException | [virtual]
~Exception() | Activ::Exception | [virtual]

Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::BaseTime Member List

This is the complete list of members for Activ::BaseTime, including all inherited members.

DateToString() const | Activ::BaseTime |
DayOfWeek typedef | Activ::BaseTime |
DayOfWeekToString(const DayOfWeek dayOfWeek, bool isShort=false) | Activ::BaseTime | [static]
Deserialize(MessageValidator &messageValidator) | Activ::BaseTime |
FRIDAY (defined in Activ::BaseTime) | Activ::BaseTime | [static]
GetDay() const | Activ::BaseTime | [inline]
GetDayOfWeek() const | Activ::BaseTime | [inline]
GetHour() const | Activ::BaseTime | [inline]
GetJulianTime() const | Activ::BaseTime | [inline]
GetMillisecond() const | Activ::BaseTime | [inline]
GetMinute() const | Activ::BaseTime | [inline]
GetMonth() const | Activ::BaseTime | [inline]
GetSecond() const | Activ::BaseTime | [inline]
GetYear() const | Activ::BaseTime | [inline]
IsUtc() const | Activ::BaseTime | [inline]
LocalTime (defined in Activ::BaseTime) | Activ::BaseTime | [friend]
millisecondsPerDay (defined in Activ::BaseTime) | Activ::BaseTime | [static]
millisecondsPerHour (defined in Activ::BaseTime) | Activ::BaseTime | [static]
millisecondsPerMinute (defined in Activ::BaseTime) | Activ::BaseTime | [static]
millisecondsPerSecond (defined in Activ::BaseTime) | Activ::BaseTime | [static]
MONDAY (defined in Activ::BaseTime) | Activ::BaseTime | [static]
MonthToString(const uint8_t month, bool isShort=false) | Activ::BaseTime | [static]
operator!=(const BaseTime &rhs) const | Activ::BaseTime |
operator+=(const int64_t numberOfMilliseconds) | Activ::BaseTime |
operator+=(const Duration &duration) | Activ::BaseTime |
operator-=(const int64_t numberOfMilliseconds) | Activ::BaseTime |
operator-=(const Duration &duration) | Activ::BaseTime |
operator<(const BaseTime &rhs) const | Activ::BaseTime |
operator<=(const BaseTime &rhs) const | Activ::BaseTime |
operator=(const BaseTime &rhs) | Activ::BaseTime |
operator==(const BaseTime &rhs) const | Activ::BaseTime |
operator>(const BaseTime &rhs) const | Activ::BaseTime |
operator>=(const BaseTime &rhs) const | Activ::BaseTime |
SATURDAY (defined in Activ::BaseTime) | Activ::BaseTime | [static]
secondsPerDay (defined in Activ::BaseTime) | Activ::BaseTime | [static]
secondsPerHour (defined in Activ::BaseTime) | Activ::BaseTime | [static]
secondsPerMinute (defined in Activ::BaseTime) | Activ::BaseTime | [static]
Serialize(MessageBuilder &messageBuilder) const | Activ::BaseTime |
SUNDAY (defined in Activ::BaseTime) | Activ::BaseTime | [static]
THURSDAY (defined in Activ::BaseTime) | Activ::BaseTime | [static]
TimeToString(const bool shouldFormatMilliseconds=false) const | Activ::BaseTime |
ToString(const bool shouldFormatMilliseconds=false) const | Activ::BaseTime |
TUESDAY (defined in Activ::BaseTime) | Activ::BaseTime | [static]
UtcTime (defined in Activ::BaseTime) | Activ::BaseTime | [friend]
WEDSDAY (defined in Activ::BaseTime) | Activ::BaseTime | [static]
~BaseTime() | Activ::BaseTime | [virtual]

Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::BaseTime::Duration Member List

This is the complete list of members for Activ::BaseTime::Duration, including all inherited members.

Duration(const int64_t duration) | Activ::BaseTime::Duration
Duration(const int32_t days, const int32_t hours, const int32_t minutes=0, const int32_t seconds=0, const int32_t milliseconds=0) | Activ::BaseTime::Duration
GetTotalMilliseconds() const | Activ::BaseTime::Duration
ToString() const | Activ::BaseTime::Duration

Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Binary< T, N, B > Member List

This is the complete list of members for Activ::Binary< T, N, B >, including all inherited members.

BOOST_STATIC_ASSERT((N%10)<=1) (defined in Activ::Binary< T, N, B >) | Activ::Binary< T, N, B > |
value (defined in Activ::Binary< T, N, B >) | Activ::Binary< T, N, B > | [static]

Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::BinaryArray Member List

This is the complete list of members for Activ::BinaryArray, including all inherited members.

Assign(const IFieldType *const pIFieldType) | Activ::IFieldType |
BinaryArray() | Activ::BinaryArray | [inline]
BinaryArray(const uint8_t *const pData, const size_t size) | Activ::BinaryArray | [inline]
BinaryArray(const BinaryArray &rhs) | Activ::BinaryArray | [inline]
Clear() | Activ::BinaryArray | [inline, virtual]
Compare(const BinaryArray &rhs, int &result) const | Activ::BinaryArray |
Compare(const void *const pRhsSerializedBody, const size_t rhsSerializedBodyLength, int &result) const | Activ::BinaryArray | [virtual]
Compare(const void *const pLhsSerializedBody, const size_t lhsSerializedBodyLength, const void *const pRhsSerializedBody, const size_t rhsSerializedBodyLength, int &result) | Activ::BinaryArray | [static]
Convert(const IFieldType *const pIFieldType) | Activ::BinaryArray | [virtual]
Deserialize(MessageValidator &messageValidator, const size_t maxSerializedBodyLength) | Activ::BinaryArray | [virtual]
Deserialize(MessageValidator &messageValidator, const size_t maxSerializedBodyLength, const uint8_t *&pData, size_t &size) | Activ::BinaryArray | [static]
Activ::IFieldType::Deserialize(const FieldType fieldType, MessageValidator &messageValidator, const size_t maxSerializedBodyLength) | Activ::IFieldType |
DeserializeBody(const void *const pSerializedBody, const size_t serializedBodyLength) | Activ::BinaryArray | [virtual]
DeserializeBody(const void *const pSerializedBody, const size_t serializedBodyLength, const uint8_t *&pData, size_t &size) | Activ::BinaryArray | [static]
Activ::IFieldType::DeserializeBody(const FieldType fieldType, const void *const pSerializedBody, const size_t serializedBodyLength) | Activ::IFieldType |
DeserializeLengthAndBody(MessageValidator &messageValidator, const size_t maxSerializedBodyLength=MAX_SERIALIZED_BODY_LENGTH_UNDEFINED) | Activ::BinaryArray | [virtual]
DeserializeLengthAndBody(MessageValidator &messageValidator, const size_t maxSerializedBodyLength, const uint8_t *&pData, size_t &size) | Activ::BinaryArray | [static]
Activ::IFieldType::DeserializeLengthAndBody(const FieldType fieldType, MessageValidator &messageValidator, const size_t maxSerializedBodyLength=MAX_SERIALIZED_BODY_LENGTH_UNDEFINED) | Activ::IFieldType |
FIELD_TYPE | Activ::BinaryArray | [static]
FromString(MessageValidator &messageValidator) | Activ::BinaryArray | [virtual]
Activ::IFieldType::FromString(const std::string &field) | Activ::IFieldType | [inline]
Get(const uint8_t *&pData, size_t &size) const | Activ::BinaryArray | [inline]
GetData() const | Activ::BinaryArray | [inline]
GetFromStringFormat() const | Activ::BinaryArray | [virtual]
GetMaxSerializedBodyLength(const size_t size) | Activ::BinaryArray | [inline, static]
GetMaxSerializedLength(const size_t size) | Activ::BinaryArray | [inline, static]
GetSerializedBodyLength() const | Activ::BinaryArray | [inline, virtual]
GetSerializedLength() const | Activ::BinaryArray | [inline, virtual]
GetSize() const | Activ::BinaryArray | [inline]
GetType() const | Activ::IFieldType | [inline]
IFieldType(const FieldType fieldType) | Activ::IFieldType | [inline, explicit, protected]
IsDifferent(const void *const pRhsSerializedBody, const size_t rhsSerializedBodyLength, bool &isDifferent) const | Activ::BinaryArray | [virtual]
IsInitialized() const | Activ::IFieldType | [inline]
IsValidSerializedBodyLength(const size_t serializedBodyLength) | Activ::BinaryArray | [inline, static]
Activ::IFieldType::IsValidSerializedBodyLength(const FieldType fieldType, const size_t serializedBodyLength) | Activ::IFieldType | [static]
m_isInitialized | Activ::IFieldType | [protected]
MAX_SERIALIZED_BODY_LENGTH_UNDEFINED | Activ::IFieldType | [static]
operator=(const BinaryArray &rhs) | Activ::BinaryArray | [inline]
Reset() | Activ::BinaryArray | [inline, virtual]
Serialize(MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength) const | Activ::BinaryArray | [virtual]
Serialize(MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength, const uint8_t *const pData, const size_t size) | Activ::BinaryArray | [static]
Activ::IFieldType::Serialize(const FieldType fieldType, MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength) const | Activ::IFieldType |
Activ::IFieldType::Serialize(const FieldType fieldType, MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength, const uint8_t *const pData, const size_t size) | Activ::IFieldType | [static]
SerializeBody(void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength) const | Activ::BinaryArray | [virtual]
SerializeBody(void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength, const uint8_t *const pData, const size_t size) | Activ::BinaryArray | [static]
Activ::IFieldType::SerializeBody(const FieldType fieldType, void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength) const | Activ::IFieldType |
Activ::IFieldType::SerializeBody(const FieldType fieldType, void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength, const uint8_t *const pData, const size_t size) | Activ::IFieldType | [static]
SerializeLengthAndBody(MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength=MAX_SERIALIZED_BODY_LENGTH_UNDEFINED) const | Activ::BinaryArray | [virtual]
SerializeLengthAndBody(MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength, const uint8_t *const pData, const size_t size) | Activ::BinaryArray | [static]
Activ::IFieldType::SerializeLengthAndBody(const FieldType fieldType, MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength=MAX_SERIALIZED_BODY_LENGTH_UNDEFINED) const | Activ::IFieldType |
Activ::IFieldType::SerializeLengthAndBody(const FieldType fieldType, MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength, const uint8_t *const pData, const size_t size) | Activ::IFieldType | [static]
Set(const uint8_t *const pData, const size_t size) | Activ::BinaryArray | [inline]
ToString() const | Activ::BinaryArray | [virtual]
ToString(const bool isHexFormat) const | Activ::BinaryArray | [virtual]
ValidateSerializedLengthAndBody(MessageValidator &messageValidator, size_t &serializedBodyOffset, size_t &serializedBodyLength) | Activ::BinaryArray | [static]
Activ::IFieldType::ValidateSerializedLengthAndBody(const FieldType fieldType, MessageValidator &messageValidator, size_t &serializedBodyOffset, size_t &serializedBodyLength) | Activ::IFieldType | [static]
~BinaryArray() | Activ::BinaryArray | [inline, virtual]
~IFieldType()=0 | Activ::IFieldType | [inline, pure virtual]

Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::BinaryString Member List

This is the complete list of members for Activ::BinaryString, including all inherited members.

Assign(const IFieldType *const pIFieldType) | Activ::IFieldType |
BinaryString() | Activ::BinaryString | [inline]
BinaryString(const uint8_t *const pData, const size_t size) | Activ::BinaryString | [inline]
BinaryString(const BinaryString &rhs) | Activ::BinaryString | [inline]
Clear() | Activ::BinaryString | [inline, virtual]
Compare(const BinaryString &rhs, int &result) const | Activ::BinaryString |
Compare(const void *const pRhsSerializedBody, const size_t rhsSerializedBodyLength, int &result) const | Activ::BinaryString | [virtual]
Compare(const void *const pLhsSerializedBody, const size_t lhsSerializedBodyLength, const void *const pRhsSerializedBody, const size_t rhsSerializedBodyLength, int &result) | Activ::BinaryString | [static]
Convert(const IFieldType *const pIFieldType) | Activ::BinaryString | [virtual]
Deserialize(MessageValidator &messageValidator, const size_t maxSerializedBodyLength) | Activ::BinaryString | [virtual]
Deserialize(MessageValidator &messageValidator, const size_t maxSerializedBodyLength, const uint8_t *&pData, size_t &size) | Activ::BinaryString | [static]
Activ::IFieldType::Deserialize(const FieldType fieldType, MessageValidator &messageValidator, const size_t maxSerializedBodyLength) | Activ::IFieldType |
DeserializeBody(const void *const pSerializedBody, const size_t serializedBodyLength) | Activ::BinaryString | [virtual]
DeserializeBody(const void *const pSerializedBody, const size_t serializedBodyLength, const uint8_t *&pData, size_t &size) | Activ::BinaryString | [static]
Activ::IFieldType::DeserializeBody(const FieldType fieldType, const void *const pSerializedBody, const size_t serializedBodyLength) | Activ::IFieldType |
DeserializeLengthAndBody(MessageValidator &messageValidator, const size_t maxSerializedBodyLength=MAX_SERIALIZED_BODY_LENGTH_UNDEFINED) | Activ::BinaryString | [virtual]
DeserializeLengthAndBody(MessageValidator &messageValidator, const size_t maxSerializedBodyLength, const uint8_t *&pData, size_t &size) | Activ::BinaryString | [static]
Activ::IFieldType::DeserializeLengthAndBody(const FieldType fieldType, MessageValidator &messageValidator, const size_t maxSerializedBodyLength=MAX_SERIALIZED_BODY_LENGTH_UNDEFINED) | Activ::IFieldType |
FIELD_TYPE | Activ::BinaryString | [static]
FromString(MessageValidator &messageValidator) | Activ::BinaryString | [virtual]
Activ::IFieldType::FromString(const std::string &field) | Activ::IFieldType | [inline]
Get(const uint8_t *&pData, size_t &size) const | Activ::BinaryString | [inline]
GetData() const | Activ::BinaryString | [inline]
GetFromStringFormat() const | Activ::BinaryString | [virtual]
GetMaxSerializedBodyLength(const size_t size) | Activ::BinaryString | [inline, static]
GetMaxSerializedLength(const size_t size) | Activ::BinaryString | [inline, static]
GetSerializedBodyLength() const | Activ::BinaryString | [inline, virtual]
GetSerializedLength() const | Activ::BinaryString | [inline, virtual]
GetSize() const | Activ::BinaryString | [inline]
GetType() const | Activ::IFieldType | [inline]
IFieldType(const FieldType fieldType) | Activ::IFieldType | [inline, explicit, protected]
IsDifferent(const void *const pRhsSerializedBody, const size_t rhsSerializedBodyLength, bool &isDifferent) const | Activ::BinaryString | [virtual]
IsInitialized() const | Activ::IFieldType | [inline]
IsValidSerializedBodyLength(const size_t serializedBodyLength) | Activ::BinaryString | [inline, static]
Activ::IFieldType::IsValidSerializedBodyLength(const FieldType fieldType, const size_t serializedBodyLength) | Activ::IFieldType | [static]
m_isInitialized | Activ::IFieldType | [protected]
MAX_SERIALIZED_BODY_LENGTH_UNDEFINED | Activ::IFieldType | [static]
operator=(const BinaryString &rhs) | Activ::BinaryString | [inline]
Reset() | Activ::BinaryString | [inline, virtual]
Serialize(MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength) const | Activ::BinaryString | [virtual]
Serialize(MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength, const uint8_t *const pData, const size_t size) | Activ::BinaryString | [static]
Activ::IFieldType::Serialize(const FieldType fieldType, MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength) const | Activ::IFieldType |
Activ::IFieldType::Serialize(const FieldType fieldType, MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength, const uint8_t *const pData, const size_t size) | Activ::IFieldType | [static]
SerializeBody(void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength) const | Activ::BinaryString | [virtual]
SerializeBody(void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength, const uint8_t *const pData, const size_t size) | Activ::BinaryString | [static]
Activ::IFieldType::SerializeBody(const FieldType fieldType, void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength) const | Activ::IFieldType |
Activ::IFieldType::SerializeBody(const FieldType fieldType, void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength, const uint8_t *const pData, const size_t size) | Activ::IFieldType | [static]
SerializeLengthAndBody(MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength=MAX_SERIALIZED_BODY_LENGTH_UNDEFINED) const | Activ::BinaryString | [virtual]
SerializeLengthAndBody(MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength, const uint8_t *const pData, const size_t size) | Activ::BinaryString | [static]
Activ::IFieldType::SerializeLengthAndBody(const FieldType fieldType, MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength=MAX_SERIALIZED_BODY_LENGTH_UNDEFINED) const | Activ::IFieldType |
Activ::IFieldType::SerializeLengthAndBody(const FieldType fieldType, MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength, const uint8_t *const pData, const size_t size) | Activ::IFieldType | [static]
Set(const uint8_t *const pData, const size_t size) | Activ::BinaryString | [inline]
ToString() const | Activ::BinaryString | [virtual]
ToString(const bool isHexFormat) const | Activ::BinaryString | [virtual]
ValidateSerializedLengthAndBody(MessageValidator &messageValidator, size_t &serializedBodyOffset, size_t &serializedBodyLength) | Activ::BinaryString | [static]
Activ::IFieldType::ValidateSerializedLengthAndBody(const FieldType fieldType, MessageValidator &messageValidator, size_t &serializedBodyOffset, size_t &serializedBodyLength) | Activ::IFieldType | [static]
~BinaryString() | Activ::BinaryString | [inline, virtual]
~IFieldType()=0 | Activ::IFieldType | [inline, pure virtual]

Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::BitField< T, OFFSET_VALUE, LENGTH_VALUE > Member List

This is the complete list of members for Activ::BitField< T, OFFSET_VALUE, LENGTH_VALUE >, including all inherited members.

Bitmap typedef (defined in Activ::BitField< T, OFFSET_VALUE, LENGTH_VALUE >) | Activ::BitField< T, OFFSET_VALUE, LENGTH_VALUE > |
BOOST_STATIC_ASSERT((OFFSET+LENGTH)<=(sizeof(Bitmap)*CHAR_BIT)) (defined in Activ::BitField< T, OFFSET_VALUE, LENGTH_VALUE >) | Activ::BitField< T, OFFSET_VALUE, LENGTH_VALUE > |
GetMaxValue() | Activ::BitField< T, OFFSET_VALUE, LENGTH_VALUE > | [inline, static]
GetShifted(const Bitmap bitmap) | Activ::BitField< T, OFFSET_VALUE, LENGTH_VALUE > | [inline, static]
GetUnshifted(const Bitmap bitmap) | Activ::BitField< T, OFFSET_VALUE, LENGTH_VALUE > | [inline, static]
LENGTH (defined in Activ::BitField< T, OFFSET_VALUE, LENGTH_VALUE >) | Activ::BitField< T, OFFSET_VALUE, LENGTH_VALUE > | [static]
MASK (defined in Activ::BitField< T, OFFSET_VALUE, LENGTH_VALUE >) | Activ::BitField< T, OFFSET_VALUE, LENGTH_VALUE > | [static]
OFFSET (defined in Activ::BitField< T, OFFSET_VALUE, LENGTH_VALUE >) | Activ::BitField< T, OFFSET_VALUE, LENGTH_VALUE > | [static]
Set(Bitmap &bitmap, const Bitmap value) | Activ::BitField< T, OFFSET_VALUE, LENGTH_VALUE > | [inline, static]

Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Blob Member List

This is the complete list of members for Activ::Blob, including all inherited members.

Assign(const IFieldType *const pIFieldType) | Activ::IFieldType |
Blob() | Activ::Blob | [inline]
Blob(const uint8_t *const pData, const size_t size, const size_t sizeWhenDecompressed) | Activ::Blob | [inline]
Blob(const uint8_t *const pData, const size_t size) | Activ::Blob | [inline]
Blob(const Blob &rhs) | Activ::Blob | [inline]
Clear() | Activ::Blob | [inline, virtual]
Compare(const Blob &rhs, int &result) const | Activ::Blob |
Compare(const void *const pRhsSerializedBody, const size_t rhsSerializedBodyLength, int &result) const | Activ::Blob | [virtual]
Compare(const void *const pLhsSerializedBody, const size_t lhsSerializedBodyLength, const void *const pRhsSerializedBody, const size_t rhsSerializedBodyLength, int &result) | Activ::Blob | [static]
Compress() const | Activ::Blob | [inline]
Compress(bool shouldSerializeCompressed, bool shouldForceSerializeCompressed=false) | Activ::Blob | [inline]
Compress(const uint8_t *const pSource, const size_t sourceLength, uint8_t *const pTarget, const size_t targetSize, size_t &targetLength) | Activ::Blob | [inline, static]
Convert(const IFieldType *const pIFieldType) | Activ::Blob | [virtual]
Decompress() const | Activ::Blob | [inline]
Decompress(bool shouldSerializeDecompressed) | Activ::Blob | [inline]
Decompress(const uint8_t *const pSource, const size_t sourceLength, uint8_t *const pTarget, const size_t targetSize, size_t &targetLength) | Activ::Blob | [inline, static]
Deserialize(MessageValidator &messageValidator, const size_t maxSerializedBodyLength) | Activ::Blob | [virtual]
Deserialize(MessageValidator &messageValidator, const size_t maxSerializedBodyLength, const uint8_t *&pData, size_t &size, size_t &sizeWhenDecompressed) | Activ::Blob | [static]
Activ::IFieldType::Deserialize(const FieldType fieldType, MessageValidator &messageValidator, const size_t maxSerializedBodyLength) | Activ::IFieldType |
DeserializeBody(const void *const pSerializedBody, const size_t serializedBodyLength) | Activ::Blob | [virtual]
DeserializeBody(const void *const pSerializedBody, const size_t serializedBodyLength, const uint8_t *&pData, size_t &size, size_t &sizeWhenDecompressed) | Activ::Blob | [static]
Activ::IFieldType::DeserializeBody(const FieldType fieldType, const void *const pSerializedBody, const size_t serializedBodyLength) | Activ::IFieldType |
DeserializeLengthAndBody(MessageValidator &messageValidator, const size_t maxSerializedBodyLength=MAX_SERIALIZED_BODY_LENGTH_UNDEFINED) | Activ::Blob | [virtual]
DeserializeLengthAndBody(MessageValidator &messageValidator, const size_t maxSerializedBodyLength, const uint8_t *&pData, size_t &size, size_t &sizeWhenDecompressed) | Activ::Blob | [static]
Activ::IFieldType::DeserializeLengthAndBody(const FieldType fieldType, MessageValidator &messageValidator, const size_t maxSerializedBodyLength=MAX_SERIALIZED_BODY_LENGTH_UNDEFINED) | Activ::IFieldType |
FIELD_TYPE | Activ::Blob | [static]
FromString(MessageValidator &messageValidator) | Activ::Blob | [virtual]
Activ::IFieldType::FromString(const std::string &field) | Activ::IFieldType | [inline]
Get(const uint8_t *&pData, size_t &size, size_t &sizeWhenDecompressed) const | Activ::Blob | [inline]
Get(const uint8_t *&pData, size_t &size) const | Activ::Blob | [inline]
GetData() const | Activ::Blob | [inline]
GetDataCompressed() const | Activ::Blob | [inline]
GetDataDecompressed() const | Activ::Blob | [inline]
GetFromStringFormat() const | Activ::Blob | [virtual]
GetMaxSerializedBodyLength(const size_t size) | Activ::Blob | [inline, static]
GetMaxSerializedLength(const size_t size) | Activ::Blob | [inline, static]
GetSerializedBodyLength() const | Activ::Blob | [inline, virtual]
GetSerializedLength() const | Activ::Blob | [inline, virtual]
GetSize() const | Activ::Blob | [inline]
GetSizeCompressed() const | Activ::Blob | [inline]
GetSizeDecompressed() const | Activ::Blob | [inline]
GetSizeWhenDecompressed() const | Activ::Blob | [inline]
GetType() const | Activ::IFieldType | [inline]
IFieldType(const FieldType fieldType) | Activ::IFieldType | [inline, explicit, protected]
IsCompressed() const | Activ::Blob | [inline]
IsDifferent(const void *const pRhsSerializedBody, const size_t rhsSerializedBodyLength, bool &isDifferent) const | Activ::Blob | [virtual]
IsInitialized() const | Activ::IFieldType | [inline]
IsValidSerializedBodyLength(const size_t serializedBodyLength) | Activ::Blob | [inline, static]
Activ::IFieldType::IsValidSerializedBodyLength(const FieldType fieldType, const size_t serializedBodyLength) | Activ::IFieldType | [static]
m_isInitialized | Activ::IFieldType | [protected]
MAX_SERIALIZED_BODY_LENGTH_UNDEFINED | Activ::IFieldType | [static]
operator=(const Blob &rhs) | Activ::Blob | [inline]
Reset() | Activ::Blob | [inline, virtual]
Serialize(MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength) const | Activ::Blob | [virtual]
Serialize(MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength, const uint8_t *const pData, const size_t size, const size_t sizeWhenDecompressed=0) | Activ::Blob | [static]
Activ::IFieldType::Serialize(const FieldType fieldType, MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength) const | Activ::IFieldType |
Activ::IFieldType::Serialize(const FieldType fieldType, MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength, const uint8_t *const pData, const size_t size) | Activ::IFieldType | [static]
SerializeBody(void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength) const | Activ::Blob | [virtual]
SerializeBody(void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength, const uint8_t *const pData, const size_t size, const size_t sizeWhenDecompressed=0) | Activ::Blob | [static]
Activ::IFieldType::SerializeBody(const FieldType fieldType, void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength) const | Activ::IFieldType |
Activ::IFieldType::SerializeBody(const FieldType fieldType, void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength, const uint8_t *const pData, const size_t size) | Activ::IFieldType | [static]
SerializeLengthAndBody(MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength=MAX_SERIALIZED_BODY_LENGTH_UNDEFINED) const | Activ::Blob | [virtual]
SerializeLengthAndBody(MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength, const uint8_t *const pData, const size_t size, const size_t sizeWhenDecompressed=0) | Activ::Blob | [static]
Activ::IFieldType::SerializeLengthAndBody(const FieldType fieldType, MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength=MAX_SERIALIZED_BODY_LENGTH_UNDEFINED) const | Activ::IFieldType |
Activ::IFieldType::SerializeLengthAndBody(const FieldType fieldType, MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength, const uint8_t *const pData, const size_t size) | Activ::IFieldType | [static]
Set(const uint8_t *const pData, const size_t size, const size_t sizeWhenDecompressed) | Activ::Blob | [inline]
Set(const uint8_t *const pData, const size_t size) | Activ::Blob | [inline]
ToString() const | Activ::Blob | [virtual]
ToString(const bool isHexFormat) const | Activ::Blob | [virtual]
ValidateSerializedLengthAndBody(MessageValidator &messageValidator, size_t &serializedBodyOffset, size_t &serializedBodyLength) | Activ::Blob | [static]
Activ::IFieldType::ValidateSerializedLengthAndBody(const FieldType fieldType, MessageValidator &messageValidator, size_t &serializedBodyOffset, size_t &serializedBodyLength) | Activ::IFieldType | [static]
~Blob() | Activ::Blob | [inline, virtual]
~IFieldType()=0 | Activ::IFieldType | [inline, pure virtual]

Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::CaseInsensitiveLessThanStringComparisonObject Member List

This is the complete list of members for Activ::CaseInsensitiveLessThanStringComparisonObject, including all inherited members.

operator()(const std::string &lhs, const std::string &rhs) const Activ::CaseInsensitiveLessThanStringComparisonObject [inline]

Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ChildService< T > Member List

This is the complete list of members for Activ::ChildService< T >, including all inherited members.

anonymousName | Activ::Port | [static]
BuildOpenServiceResponse(HeapMessage &acceptMessage, OpenServiceResponse &openServiceResponse, const byte_t openServiceVersion) const | Activ::Service | [protected]
ChildService(T &parentService, ManagedEndPoint &managedEndPoint, IHeap *const pHeap=0, const std::string &portName=Port::anonymousName) | Activ::ChildService< T > | [inline]
Close() | Activ::Service |
Component(Application &application, ManagedEndPoint &managedEndPoint, const std::string &name=anonymousName, IHeap *const pHeap=0, const std::string &componentId=defaultComponentId) | Activ::Component |
defaultComponentId | Activ::Component | [static]
defaultTimeout | Activ::Port | [static]
Deregister() | Activ::Service | [virtual]
Disable() | Activ::Port |
emptyServiceAccessPointList | Activ::Service | [static]
Enable() | Activ::Port |
FindPort(const std::string &endPointName, const std::string &portName, Address &portAddress, const TimeoutPeriod timeout=defaultTimeout) | Activ::Port |
ForwardMessage(const Address &destinationAddress, HeapMessage &message, const MessageType newType=INVALID_MESSAGE_TYPE) const | Activ::Port |
GetAddress() const | Activ::Port | [inline]
GetApplication() const | Activ::Component |
GetHeap() const | Activ::Port | [inline]
GetManagedEndPoint() const | Activ::Port |
GetName() const | Activ::Port |
GetServiceInstance() const | Activ::Service |
m_parentService | Activ::ChildService< T > |
ManagedEndPoint::Impl (defined in Activ::Port) | Activ::Port | [friend]
OnAccept(HeapMessage &acceptMessage) | Activ::Service | [protected, virtual]
OnBreak(HeapMessage &breakMessage) | Activ::Component | [protected, virtual]
OnConnect(HeapMessage &connectMessage) | Activ::Component | [protected, virtual]
OnConnectFailed(HeapMessage &connectFailMessage) | Activ::Component | [protected, virtual]
OnData(HeapMessage &heapMessage) | Activ::Component | [protected, virtual]
OnDisconnect(HeapMessage &disconnectMessage) | Activ::Component | [protected, virtual]
OnMessage(HeapMessage &message) | Activ::Component | [protected, virtual]
OnRequest(HeapMessage &request) | Activ::Component | [protected, virtual]
OnResponse(HeapMessage &response) | Activ::Port | [protected, virtual]
OnTimer(const Address &timerAddress, const BaseTime &time) | Activ::Component | [protected, virtual]
Port(ManagedEndPoint &managedEndPoint, const std::string &name, IHeap *const pHeap) | Activ::Port |
Port(ManagedEndPoint &managedEndPoint, const std::string &name, const PortId portId, IHeap *const pHeap) | Activ::Port |
PostEmptyResponse(const StatusCode responseStatus, HeapMessage &response) const | Activ::Port |
PostEmptyResponse(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, const StatusCode responseStatus, HeapMessage &response) const | Activ::Port |
PostMessage(const Address &destinationAddress, const MessageType messageType, const MessageBuilder &messageBuilder) const | Activ::Port |
PostMessage(const Address &destinationAddress, const MessageType messageType, const void *pMessage=0, const size_t messageLength=0) const | Activ::Port |
PostMessage(const Address &destinationAddress, const MessageType messageType, HeapMessage &message) const | Activ::Port |
PostRequest(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, const MessageBuilder &messageBuilder) const | Activ::Port |
PostRequest(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, const void *pRequest=0, const size_t requestLength=0) const | Activ::Port |
PostRequest(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, HeapMessage &request) const | Activ::Port |
PostResponse(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, const StatusCode responseStatus, const MessageBuilder &messageBuilder) const | Activ::Port |
PostResponse(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, const StatusCode responseStatus, const void *pResponse=0, const size_t responseLength=0) const | Activ::Port |
PostResponse(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, const StatusCode responseStatus, HeapMessage &response) const | Activ::Port |
PostResponse(const StatusCode responseStatus, HeapMessage &request, const MessageBuilder &messageBuilder) const | Activ::Port |
PostResponse(const StatusCode responseStatus, HeapMessage &request, const void *pResponse, const size_t responseLength) const | Activ::Port |
PostResponse(const StatusCode responseStatus, HeapMessage &request, HeapMessage &response) const | Activ::Port |
PostResponse(const StatusCode responseStatus, HeapMessage &request) const | Activ::Port |
ProcessOpenServiceRequest(HeapMessage &acceptMessage) | Activ::Service | [protected, virtual]
Register() | Activ::Service | [virtual]
SendRequest(const Address &destinationAddress, const MessageType requestType, const MessageBuilder &messageBuilder, HeapMessage &response, const TimeoutPeriod timeout=defaultTimeout) const | Activ::Port |
SendRequest(const Address &destinationAddress, const MessageType requestType, const void *pRequest, const size_t requestLength, HeapMessage &response, const TimeoutPeriod timeout=defaultTimeout) const | Activ::Port |
SendRequest(const Address &destinationAddress, const MessageType requestType, HeapMessage &request, const TimeoutPeriod timeout=defaultTimeout) const | Activ::Port |
SendRequest(const Address &destinationAddress, const MessageType requestType, SyncRequestId &syncRequestId, const MessageBuilder &messageBuilder) const | Activ::Port |
SendRequest(const Address &destinationAddress, const MessageType requestType, SyncRequestId &syncRequestId, const void *pRequest, const size_t requestLength) const | Activ::Port |
SendRequest(const Address &destinationAddress, const MessageType requestType, SyncRequestId &syncRequestId, HeapMessage &request) const | Activ::Port |
Service(Application &application, ManagedEndPoint &managedEndPoint, const std::string &name, const ServiceInstance &serviceInstance, IHeap *const pHeap=0, const std::string &componentId=defaultComponentId) | Activ::Service |
SetHeap(IHeap *const pHeap) | Activ::Port |
ValidateOpenServiceRequest(const HeapMessage &acceptMessage, OpenServiceRequest &openServiceRequest) const | Activ::Service | [protected]
~Component() | Activ::Component |
~Port() | Activ::Port | [virtual]
~Service() | Activ::Service |

Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::CommandLineParser Member List

This is the complete list of members for Activ::CommandLineParser, including all inherited members.

AddDescriptions() | Activ::CommandLineParser |
BooleanSwitch(const std::string &name, const std::string &description, bool &value) | Activ::CommandLineParser | [static]
BooleanSwitch(const std::string &name, const std::string &description, boost::function< void(const bool &)> notifier) | Activ::CommandLineParser | [static]
CommandLineParser() | Activ::CommandLineParser |
IsDefaultValue(const std::string &name) const | Activ::CommandLineParser |
Parameter(const std::string &name, const std::string &description, T &value) | Activ::CommandLineParser | [inline, static]
Parameter(const std::string &name, const std::string &description, boost::function< void(const T &)> notifier) | Activ::CommandLineParser | [inline, static]
Parameter(const std::string &name, const std::string &description, const T &defaultValue, T &value) | Activ::CommandLineParser | [inline, static]
Parameter(const std::string &name, const std::string &description, const T &defaultValue, boost::function< void(const T &)> notifier) | Activ::CommandLineParser | [inline, static]
PrintUsage(const std::string &argv0, std::ostream &outStream) const | Activ::CommandLineParser | [virtual]
Process(const int argc, char *argv[], std::ostream &outStream=std::cout) | Activ::CommandLineParser |
Switch(const std::string &name, const std::string &description, T &value) | Activ::CommandLineParser | [inline, static]
Switch(const std::string &name, const std::string &description, boost::function< void(const T &)> notifier) | Activ::CommandLineParser | [inline, static]
Switch(const std::string &name, const std::string &description, const T &defaultValue, T &value) | Activ::CommandLineParser | [inline, static]
Switch(const std::string &name, const std::string &description, const T &defaultValue, boost::function< void(const T &)> notifier) | Activ::CommandLineParser | [inline, static]
~CommandLineParser() | Activ::CommandLineParser | [virtual]

Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::CommandLineParserDetail::BooleanSwitchDescription Member List

This is the complete list of members for Activ::CommandLineParserDetail::BooleanSwitchDescription, including all inherited members.

BooleanSwitchDescription(const std::string &name, const std::string &description, boost::function< void(const bool &)> notifier) | Activ::CommandLineParserDetail::BooleanSwitchDescription | [inline]
Description(const std::string &name, const std::string &description, boost::function< void(const bool &)> notifier) | Activ::CommandLineParserDetail::Description< bool > | [inline]
m_description | Activ::CommandLineParserDetail::Description< bool > |
m_name | Activ::CommandLineParserDetail::Description< bool > |
m_notifier | Activ::CommandLineParserDetail::Description< bool > |

Generated on Wed Oct 8 14:02:02 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::CommandLineParserDetail::CommandLineParserImpl Member List

This is the complete list of members for Activ::CommandLineParserDetail::CommandLineParserImpl, including all inherited members.

CommandLineParserImpl(CommandLineParser &commandLineParser) | Activ::CommandLineParserDetail::CommandLineParserImpl |
DescriptionAppender (defined in Activ::CommandLineParserDetail::CommandLineParserImpl) | Activ::CommandLineParserDetail::CommandLineParserImpl | [friend]
IsDefaultValue(const std::string &name) const | Activ::CommandLineParserDetail::CommandLineParserImpl |
PrintUsage(const std::string &argv0, std::ostream &outStream) const | Activ::CommandLineParserDetail::CommandLineParserImpl |
Process(const int argc, char *argv[], std::ostream &outStream) | Activ::CommandLineParserDetail::CommandLineParserImpl |

Generated on Wed Oct 8 14:02:02 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::CommandLineParserDetail::DefaultDescription< T > Member List

This is the complete list of members for Activ::CommandLineParserDetail::DefaultDescription< T >, including all inherited members.

DefaultDescription(const std::string &name, const std::string &description, const T &defaultValue, boost::function< void(const T &)> notifier) | Activ::CommandLineParserDetail::DefaultDescription< T > | [inline]
Description(const std::string &name, const std::string &description, boost::function< void(const T &)> notifier) | Activ::CommandLineParserDetail::Description< T > | [inline]
m_defaultValue | Activ::CommandLineParserDetail::DefaultDescription< T > |
m_description | Activ::CommandLineParserDetail::Description< T > |
m_name | Activ::CommandLineParserDetail::Description< T > |
m_notifier | Activ::CommandLineParserDetail::Description< T > |

Generated on Wed Oct 8 14:02:02 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::CommandLineParserDetail::Description< T > Member List

This is the complete list of members for Activ::CommandLineParserDetail::Description< T >, including all inherited members.

Description(const std::string &name, const std::string &description, boost::function< void(const T &)> notifier) | Activ::CommandLineParserDetail::Description< T > | [inline]
m_description | Activ::CommandLineParserDetail::Description< T > |
m_name | Activ::CommandLineParserDetail::Description< T > |
m_notifier | Activ::CommandLineParserDetail::Description< T > |

Generated on Wed Oct 8 14:02:02 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::CommandLineParserDetail::DescriptionAppender Member List

This is the complete list of members for Activ::CommandLineParserDetail::DescriptionAppender, including all inherited members.

DescriptionAppender(CommandLineParserImpl &commandLineParserImpl) | Activ::CommandLineParserDetail::DescriptionAppender |
operator()(const MandatoryParameterDescription< T > &parameterDescription) | Activ::CommandLineParserDetail::DescriptionAppender | [inline]
operator()(const MandatoryParameterDescription< std::vector< T > > &parameterDescription) | Activ::CommandLineParserDetail::DescriptionAppender | [inline]
operator()(const OptionalParameterDescription< T > &parameterDescription) | Activ::CommandLineParserDetail::DescriptionAppender | [inline]
operator()(const OptionalParameterDescription< std::vector< T > > &parameterDescription) | Activ::CommandLineParserDetail::DescriptionAppender | [inline]
operator()(const MandatorySwitchDescription< T > &switchDescription) | Activ::CommandLineParserDetail::DescriptionAppender | [inline]
operator()(const MandatorySwitchDescription< std::vector< T > > &switchDescription) | Activ::CommandLineParserDetail::DescriptionAppender | [inline]
operator()(const OptionalSwitchDescription< T > &switchDescription) | Activ::CommandLineParserDetail::DescriptionAppender | [inline]
operator()(const OptionalSwitchDescription< std::vector< T > > &switchDescription) | Activ::CommandLineParserDetail::DescriptionAppender | [inline]
operator()(const BooleanSwitchDescription &booleanSwitchDescription) | Activ::CommandLineParserDetail::DescriptionAppender | [inline]

Generated on Wed Oct 8 14:02:02 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::CommandLineParserDetail::MandatoryParameterDescription< T > Member List

This is the complete list of members for Activ::CommandLineParserDetail::MandatoryParameterDescription< T >, including all inherited members.

Description(const std::string &name, const std::string &description, boost::function< void(const T &)> notifier) | Activ::CommandLineParserDetail::Description< T > | [inline]
m_description | Activ::CommandLineParserDetail::Description< T > |
m_name | Activ::CommandLineParserDetail::Description< T > |
m_notifier | Activ::CommandLineParserDetail::Description< T > |
MandatoryParameterDescription(const std::string &name, const std::string &description, boost::function< void(const T &)> notifier) | Activ::CommandLineParserDetail::MandatoryParameterDescription< T > | [inline]

Generated on Wed Oct 8 14:02:02 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::CommandLineParserDetail::MandatorySwitchDescription< T > Member List

This is the complete list of members for Activ::CommandLineParserDetail::MandatorySwitchDescription< T >, including all inherited members.

Description(const std::string &name, const std::string &description, boost::function< void(const T &)> notifier) | Activ::CommandLineParserDetail::Description< T > | [inline]
m_description | Activ::CommandLineParserDetail::Description< T > |
m_name | Activ::CommandLineParserDetail::Description< T > |
m_notifier | Activ::CommandLineParserDetail::Description< T > |
MandatorySwitchDescription(const std::string &name, const std::string &description, boost::function< void(const T &)> notifier) | Activ::CommandLineParserDetail::MandatorySwitchDescription< T > | [inline]

Generated on Wed Oct 8 14:02:02 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::CommandLineParserDetail::OptionalParameterDescription< T > Member List

This is the complete list of members for Activ::CommandLineParserDetail::OptionalParameterDescription< T >, including all inherited members.

DefaultDescription(const std::string &name, const std::string &description, const T &defaultValue, boost::function< void(const T &)> notifier) | Activ::CommandLineParserDetail::DefaultDescription< T > | [inline]
Description(const std::string &name, const std::string &description, boost::function< void(const T &)> notifier) | Activ::CommandLineParserDetail::Description< T > | [inline]
m_defaultValue | Activ::CommandLineParserDetail::DefaultDescription< T > |
m_description | Activ::CommandLineParserDetail::Description< T > |
m_name | Activ::CommandLineParserDetail::Description< T > |
m_notifier | Activ::CommandLineParserDetail::Description< T > |
OptionalParameterDescription(const std::string &name, const std::string &description, const T &defaultValue, boost::function< void(const T &)> notifier) | Activ::CommandLineParserDetail::OptionalParameterDescription< T > | [inline]

Generated on Wed Oct 8 14:02:02 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::CommandLineParserDetail::OptionalSwitchDescription< T > Member List

This is the complete list of members for Activ::CommandLineParserDetail::OptionalSwitchDescription< T >, including all inherited members.

DefaultDescription(const std::string &name, const std::string &description, const T &defaultValue, boost::function< void(const T &)> notifier) | Activ::CommandLineParserDetail::DefaultDescription< T > | [inline]
Description(const std::string &name, const std::string &description, boost::function< void(const T &)> notifier) | Activ::CommandLineParserDetail::Description< T > | [inline]
m_defaultValue | Activ::CommandLineParserDetail::DefaultDescription< T > |
m_description | Activ::CommandLineParserDetail::Description< T > |
m_name | Activ::CommandLineParserDetail::Description< T > |
m_notifier | Activ::CommandLineParserDetail::Description< T > |
OptionalSwitchDescription(const std::string &name, const std::string &description, const T &defaultValue, boost::function< void(const T &)> notifier) | Activ::CommandLineParserDetail::OptionalSwitchDescription< T > | [inline]

Generated on Wed Oct 8 14:02:02 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::CommandLineParserDetail::ValueStore< T > Member List

This is the complete list of members for Activ::CommandLineParserDetail::ValueStore< T >, including all inherited members.

operator()(const T &value) | Activ::CommandLineParserDetail::ValueStore< T > | [inline]
ValueStore(T &value) | Activ::CommandLineParserDetail::ValueStore< T > | [inline]

Generated on Wed Oct 8 14:02:02 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Component Member List

This is the complete list of members for Activ::Component, including all inherited members.

anonymousName | Activ::Port | [static]
Component(Application &application, ManagedEndPoint &managedEndPoint, const std::string &name=anonymousName, IHeap *const pHeap=0, const std::string &componentId=defaultComponentId) | Activ::Component |
defaultComponentId | Activ::Component | [static]
defaultTimeout | Activ::Port | [static]
Disable() | Activ::Port |
Enable() | Activ::Port |
FindPort(const std::string &endPointName, const std::string &portName, Address &portAddress, const TimeoutPeriod timeout=defaultTimeout) | Activ::Port |
ForwardMessage(const Address &destinationAddress, HeapMessage &message, const MessageType newType=INVALID_MESSAGE_TYPE) const | Activ::Port |
GetAddress() const | Activ::Port | [inline]
GetApplication() const | Activ::Component |
GetHeap() const | Activ::Port | [inline]
GetManagedEndPoint() const | Activ::Port |
GetName() const | Activ::Port |
ManagedEndPoint::Impl (defined in Activ::Port) | Activ::Port | [friend]
OnAccept(HeapMessage &acceptMessage) | Activ::Component | [protected, virtual]
OnBreak(HeapMessage &breakMessage) | Activ::Component | [protected, virtual]
OnConnect(HeapMessage &connectMessage) | Activ::Component | [protected, virtual]
OnConnectFailed(HeapMessage &connectFailMessage) | Activ::Component | [protected, virtual]
OnData(HeapMessage &heapMessage) | Activ::Component | [protected, virtual]
OnDisconnect(HeapMessage &disconnectMessage) | Activ::Component | [protected, virtual]
OnMessage(HeapMessage &message) | Activ::Component | [protected, virtual]
OnRequest(HeapMessage &request) | Activ::Component | [protected, virtual]
OnResponse(HeapMessage &response) | Activ::Port | [protected, virtual]
OnTimer(const Address &timerAddress, const BaseTime &time) | Activ::Component | [protected, virtual]
Port(ManagedEndPoint &managedEndPoint, const std::string &name, IHeap *const pHeap) | Activ::Port |
Port(ManagedEndPoint &managedEndPoint, const std::string &name, const PortId portId, IHeap *const pHeap) | Activ::Port |
PostEmptyResponse(const StatusCode responseStatus, HeapMessage &response) const | Activ::Port |
PostEmptyResponse(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, const StatusCode responseStatus, HeapMessage &response) const | Activ::Port |
PostMessage(const Address &destinationAddress, const MessageType messageType, const MessageBuilder &messageBuilder) const | Activ::Port |
PostMessage(const Address &destinationAddress, const MessageType messageType, const void *pMessage=0, const size_t messageLength=0) const | Activ::Port |
PostMessage(const Address &destinationAddress, const MessageType messageType, HeapMessage &message) const | Activ::Port |
PostRequest(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, const MessageBuilder &messageBuilder) const | Activ::Port |
PostRequest(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, const void *pRequest=0, const size_t requestLength=0) const | Activ::Port |
PostRequest(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, HeapMessage &request) const | Activ::Port |
PostResponse(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, const StatusCode responseStatus, const MessageBuilder &messageBuilder) const | Activ::Port |
PostResponse(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, const StatusCode responseStatus, const void *pResponse=0, const size_t responseLength=0) const | Activ::Port |
PostResponse(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, const StatusCode responseStatus, HeapMessage &response) const | Activ::Port |
PostResponse(const StatusCode responseStatus, HeapMessage &request, const MessageBuilder &messageBuilder) const | Activ::Port |
PostResponse(const StatusCode responseStatus, HeapMessage &request, const void *pResponse, const size_t responseLength) const | Activ::Port |
PostResponse(const StatusCode responseStatus, HeapMessage &request, HeapMessage &response) const | Activ::Port |
PostResponse(const StatusCode responseStatus, HeapMessage &request) const | Activ::Port |
SendRequest(const Address &destinationAddress, const MessageType requestType, const MessageBuilder &messageBuilder, HeapMessage &response, const TimeoutPeriod timeout=defaultTimeout) const | Activ::Port |
SendRequest(const Address &destinationAddress, const MessageType requestType, const void *pRequest, const size_t requestLength, HeapMessage &response, const TimeoutPeriod timeout=defaultTimeout) const | Activ::Port |
SendRequest(const Address &destinationAddress, const MessageType requestType, HeapMessage &request, const TimeoutPeriod timeout=defaultTimeout) const | Activ::Port |
SendRequest(const Address &destinationAddress, const MessageType requestType, SyncRequestId &syncRequestId, const MessageBuilder &messageBuilder) const | Activ::Port |
SendRequest(const Address &destinationAddress, const MessageType requestType, SyncRequestId &syncRequestId, const void *pRequest, const size_t requestLength) const | Activ::Port |
SendRequest(const Address &destinationAddress, const MessageType requestType, SyncRequestId &syncRequestId, HeapMessage &request) const | Activ::Port |
SetHeap(IHeap *const pHeap) | Activ::Port |
~Component() | Activ::Component |
~Port() | Activ::Port | [virtual]

Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ConsoleWindow Member List

This is the complete list of members for Activ::ConsoleWindow, including all inherited members.

ClearFrom(const Coord &coord) | Activ::ConsoleWindow |
ConsoleWindow(const Flags flags=FLAG_NONE) | Activ::ConsoleWindow |
FLAG_IMMEDIATE_REFRESH | Activ::ConsoleWindow | [static]
FLAG_NO_AUTOSCROLL | Activ::ConsoleWindow | [static]
FLAG_NONE (defined in Activ::ConsoleWindow) | Activ::ConsoleWindow | [static]
Flags typedef | Activ::ConsoleWindow |
GetBufferSize(Coord &size) const | Activ::ConsoleWindow |
GetCursorPosition(Coord &coord) const | Activ::ConsoleWindow |
GetDisplaySize(Coord &size) const | Activ::ConsoleWindow |
Printf(const char *const pStr,...) const | Activ::ConsoleWindow |
ReadLine(std::string &input) const | Activ::ConsoleWindow |
SetBufferSize(const Coord &size) | Activ::ConsoleWindow |
SetCursorPosition(const Coord &coord) | Activ::ConsoleWindow |
SetCursorVisibility(const bool isVisible) | Activ::ConsoleWindow |
SetDisplaySize(const Coord &size) | Activ::ConsoleWindow |
SetTitle(const std::string &title) | Activ::ConsoleWindow | [static]
WaitForInput(const TimeoutPeriod timeoutPeriod=100) const | Activ::ConsoleWindow |
WriteAt(const Coord &coord, const char *const pStr, const size_t length=0) | Activ::ConsoleWindow |
~ConsoleWindow() | Activ::ConsoleWindow |

Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ConsoleWindow::Coord Member List

This is the complete list of members for Activ::ConsoleWindow::Coord, including all inherited members.

Coord() | Activ::ConsoleWindow::Coord | [inline]
Coord(const int16_t x, const int16_t y) | Activ::ConsoleWindow::Coord | [inline]
Deserialize(MessageValidator &messageValidator) | Activ::ConsoleWindow::Coord |
m_x (defined in Activ::ConsoleWindow::Coord) | Activ::ConsoleWindow::Coord |
m_y (defined in Activ::ConsoleWindow::Coord) | Activ::ConsoleWindow::Coord |
operator!=(const Coord &rhs) const | Activ::ConsoleWindow::Coord | [inline]
operator==(const Coord &rhs) const | Activ::ConsoleWindow::Coord | [inline]
Serialize(MessageBuilder &messageBuilder) const | Activ::ConsoleWindow::Coord |

Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient Member List

This is the complete list of members for Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient, including all inherited members.

ACTIV_DECLARE_ELEMENT_1_WITH_COMMA enum value (defined in Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient) | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient |
anonymousName | Activ::Port | [static]
Component(Application &application, ManagedEndPoint &managedEndPoint, const std::string &name=anonymousName, IHeap *const pHeap=0, const std::string &componentId=defaultComponentId) | Activ::Component |
Connect(const ConnectParameters &connectParameters, const TimeoutPeriod timeoutPeriod=Port::defaultTimeout) | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient |
ContentGatewayClient(Application &application, ManagedEndPoint &managedEndPoint, const Settings &settings=Settings(), const std::string &componentId=defaultComponentId) | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient |
defaultComponentId | Activ::Component | [static]
defaultTimeout | Activ::Port | [static]
Disable() | Activ::Port |
Disconnect() | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient |
Enable() | Activ::Port |
FindPort(const std::string &endPointName, const std::string &portName, Address &portAddress, const TimeoutPeriod timeout=defaultTimeout) | Activ::Port |
ForwardMessage(const Address &destinationAddress, HeapMessage &message, const MessageType newType=INVALID_MESSAGE_TYPE) const | Activ::Port |
GetAddress() const | Activ::Port | [inline]
GetApiInfo() const | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient |
GetApplication() const | Activ::Component |
GetContentGatewayInfo(ContentGatewayInfo &contentGatewayInfo) const | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient |
GetEqual typedef (defined in Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient) | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient |
GetFirst typedef (defined in Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient) | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient |
GetHeap() const | Activ::Port | [inline]
GetHistory typedef (defined in Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient) | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient |
GetIntraday typedef (defined in Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient) | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient |
GetLast typedef (defined in Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient) | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient |
GetManagedEndPoint() const | Activ::Port |
GetMatch typedef (defined in Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient) | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient |
GetMultipleEqual typedef (defined in Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient) | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient |
GetMultipleMatch typedef (defined in Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient) | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient |
GetMultiplePatternMatch typedef (defined in Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient) | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient |
GetMultiplePatternMatchList typedef (defined in Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient) | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient |
GetName() const | Activ::Port |
GetNewsStories typedef (defined in Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient) | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient |
GetNext typedef (defined in Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient) | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient |
GetPrevious typedef (defined in Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient) | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient |
GetServiceLocation() const | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient |
GetState() const | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient |
GetSubscriptionInfo(const Feed::PermissionLevel permissionLevel, SubscriptionInfo &subscriptionInfo) const | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient |
GetSymbols typedef (defined in Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient) | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient |
GetTicks typedef (defined in Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient) | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient |
IsCompleteResponse(const HeapMessage &response) | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient | [inline, static]
IsValidResponse(const HeapMessage &response) | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient | [inline, static]
ManagedEndPoint::Impl (defined in Activ::Port) | Activ::Port | [friend]
MetaData typedef (defined in Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient) | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient |
OnAccept(HeapMessage &acceptMessage) | Activ::Component | [protected, virtual]
OnBreak(HeapMessage &breakMessage) | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient | [protected, virtual]
OnConnect(HeapMessage &connectMessage) | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient | [protected, virtual]
OnConnectFailed(HeapMessage &connectFailMessage) | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient | [protected, virtual]
OnContentGatewayInfoUpdate(const ContentGatewayInfo &contentGatewayInfo) | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient | [protected, virtual]
OnData(HeapMessage &heapMessage) | Activ::Component | [protected, virtual]
OnDisconnect(HeapMessage &disconnectMessage) | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient | [protected, virtual]
OnGetEqualResponse(HeapMessage &response) | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient | [protected, virtual]
OnGetFirstHistoryResponse(HeapMessage &response) | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient | [protected, virtual]
OnGetFirstIntradayResponse(HeapMessage &response) | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient | [protected, virtual]
OnGetFirstResponse(HeapMessage &response) | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient | [protected, virtual]
OnGetFirstTicksResponse(HeapMessage &response) | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient | [protected, virtual]
OnGetLastResponse(HeapMessage &response) | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient | [protected, virtual]
OnGetMatchResponse(HeapMessage &response) | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient | [protected, virtual]
OnGetMultipleEqualResponse(HeapMessage &response) | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient | [protected, virtual]
OnGetMultipleMatchResponse(HeapMessage &response) | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient | [protected, virtual]
OnGetMultiplePatternMatchListResponse(HeapMessage &response) | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient | [protected, virtual]
OnGetMultiplePatternMatchResponse(HeapMessage &response) | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient | [protected, virtual]
OnGetNewsStoriesResponse(HeapMessage &response) | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient | [protected, virtual]
OnGetNextHistoryResponse(HeapMessage &response) | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient | [protected, virtual]
OnGetNextIntradayResponse(HeapMessage &response) | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient | [protected, virtual]
OnGetNextResponse(HeapMessage &response) | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient | [protected, virtual]
OnGetNextTicksResponse(HeapMessage &response) | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient | [protected, virtual]
OnGetPreviousResponse(HeapMessage &response) | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient | [protected, virtual]
OnGetSymbolsResponse(HeapMessage &response) | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient | [protected, virtual]
OnMessage(HeapMessage &message) | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient | [protected, virtual]
OnNewsUpdate(HeapMessage &update) | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient | [protected, virtual]
OnRecordUpdate(HeapMessage &update) | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient | [protected, virtual]
OnReportMessage(const std::string &reportMessage) | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient | [protected, virtual]
OnRequest(HeapMessage &request) | Activ::Component | [protected, virtual]
OnResponse(HeapMessage &response) | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient | [protected, virtual]
OnTimer(const Address &timerAddress, const BaseTime &time) | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient | [protected, virtual]
Port(ManagedEndPoint &managedEndPoint, const std::string &name, IHeap *const pHeap) | Activ::Port |
Port(ManagedEndPoint &managedEndPoint, const std::string &name, const PortId portId, IHeap *const pHeap) | Activ::Port |
PostEmptyResponse(const StatusCode responseStatus, HeapMessage &response) const | Activ::Port |
PostEmptyResponse(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, const StatusCode responseStatus, HeapMessage &response) const | Activ::Port |
PostMessage(const Address &destinationAddress, const MessageType messageType, const MessageBuilder &messageBuilder) const | Activ::Port |
PostMessage(const Address &destinationAddress, const MessageType messageType, const void *pMessage=0, const size_t messageLength=0) const | Activ::Port |
PostMessage(const Address &destinationAddress, const MessageType messageType, HeapMessage &message) const | Activ::Port |
PostRequest(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, const MessageBuilder &messageBuilder) const | Activ::Port |
PostRequest(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, const void *pRequest=0, const size_t requestLength=0) const | Activ::Port |
PostRequest(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, HeapMessage &request) const | Activ::Port |
PostResponse(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, const StatusCode responseStatus, const MessageBuilder &messageBuilder) const | Activ::Port |
PostResponse(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, const StatusCode responseStatus, const void *pResponse=0, const size_t responseLength=0) const | Activ::Port |
PostResponse(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, const StatusCode responseStatus, HeapMessage &response) const | Activ::Port |
PostResponse(const StatusCode responseStatus, HeapMessage &request, const MessageBuilder &messageBuilder) const | Activ::Port |
PostResponse(const StatusCode responseStatus, HeapMessage &request, const void *pResponse, const size_t responseLength) const | Activ::Port |
PostResponse(const StatusCode responseStatus, HeapMessage &request, HeapMessage &response) const | Activ::Port |
PostResponse(const StatusCode responseStatus, HeapMessage &request) const | Activ::Port |
SendRequest(const Address &destinationAddress, const MessageType requestType, const MessageBuilder &messageBuilder, HeapMessage &response, const TimeoutPeriod timeout=defaultTimeout) const | Activ::Port |
SendRequest(const Address &destinationAddress, const MessageType requestType, const void *pRequest, const size_t requestLength, HeapMessage &response, const TimeoutPeriod timeout=defaultTimeout) const | Activ::Port |
SendRequest(const Address &destinationAddress, const MessageType requestType, HeapMessage &request, const TimeoutPeriod timeout=defaultTimeout) const | Activ::Port |
SendRequest(const Address &destinationAddress, const MessageType requestType, SyncRequestId &syncRequestId, const MessageBuilder &messageBuilder) const | Activ::Port |
SendRequest(const Address &destinationAddress, const MessageType requestType, SyncRequestId &syncRequestId, const void *pRequest, const size_t requestLength) const | Activ::Port |
SendRequest(const Address &destinationAddress, const MessageType requestType, SyncRequestId &syncRequestId, HeapMessage &request) const | Activ::Port |
SetHeap(IHeap *const pHeap) | Activ::Port |
State enum name | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient |
StateToString(const State state) | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient | [static]
SubscribeToFeed(const SubscribeFeedParameters &subscribeFeedParameters, SubscriptionCookie &subscriptionCookie) const | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient |
SubscribeToTable(const SubscribeTableParameters &subscribeTableParameters, SubscriptionCookie &subscriptionCookie) const | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient |
Unsubscribe() const | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient |
Unsubscribe(const SubscriptionCookie subscriptionCookie) const | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient |
Unsubscribe(const SubscriptionCookie subscriptionCookie, const SymbolIdList &sourceSymbolIdList) const | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient |
Unsubscribe(const SubscriptionCookieList &subscriptionCookieList) const | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient |
~Component() | Activ::Component |
~ContentGatewayClient() | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient | [virtual]
~INewsResponses()=0 | Activ::ContentPlatform::ContentGatewayApi::INewsResponses | [inline, protected, pure virtual]
~IRealtimeResponses()=0 | Activ::ContentPlatform::ContentGatewayApi::IRealtimeResponses | [inline, protected, pure virtual]
~ISymbolDirectoryResponses()=0 | Activ::ContentPlatform::ContentGatewayApi::ISymbolDirectoryResponses | [inline, protected, pure virtual]
~ITimeSeriesResponses()=0 | Activ::ContentPlatform::ContentGatewayApi::ITimeSeriesResponses | [inline, protected, pure virtual]
~Port() | Activ::Port | [virtual]

Generated on Wed Oct 8 14:02:02 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::ApiInfo Member List

This is the complete list of members for Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::ApiInfo, including all inherited members.

m_buildConfiguration | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::ApiInfo
m_buildDateTime | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::ApiInfo
m_version | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::ApiInfo

Generated on Wed Oct 8 14:02:02 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::ConnectParameters Member List

This is the complete list of members for Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::ConnectParameters, including all inherited members.

ACTIV_DECLARE_VALUE_WITH_COMMA enum value (defined in Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::ConnectParameters) | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::ConnectParameters |
ConnectParameters() | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::ConnectParameters |
DEFAULT_FAILOVER_SECONDS (defined in Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::ConnectParameters) | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::ConnectParameters | [static]
m_agentScope | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::ConnectParameters |
m_attributeQuery | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::ConnectParameters |
m_failoverSeconds | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::ConnectParameters |
m_infoString | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::ConnectParameters |
m_logonFlags | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::ConnectParameters |
m_password | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::ConnectParameters |
m_policy | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::ConnectParameters |
m_serviceId | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::ConnectParameters |
m_url | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::ConnectParameters |
m_userId | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::ConnectParameters |
m_userType | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::ConnectParameters |
Policy enum name | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::ConnectParameters |

Generated on Wed Oct 8 14:02:02 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::Settings Member List

This is the complete list of members for Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::Settings, including all inherited members.

m_createMutex | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::Settings
m_heapBucketInfoVector | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::Settings
m_pHeap | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::Settings
Settings() | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::Settings
~Settings() | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::Settings

Generated on Wed Oct 8 14:02:02 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::ContentGatewayInfo Member List

This is the complete list of members for Activ::ContentPlatform::ContentGatewayApi::ContentGatewayInfo, including all inherited members.

FLAG_HISTORY_SERVICE_CHANGED | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayInfo | [static]
FLAG_NEWS_SERVER_SERVICE_CHANGED | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayInfo | [static]
FLAG_NONE (defined in Activ::ContentPlatform::ContentGatewayApi::ContentGatewayInfo) | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayInfo | [static]
FLAG_SYMBOL_DIRECTORY_SERVICE_CHANGED | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayInfo | [static]
Flags typedef | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayInfo |
m_flags | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayInfo |
m_isHistoryServiceAvailable (defined in Activ::ContentPlatform::ContentGatewayApi::ContentGatewayInfo) | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayInfo |
m_isNewsServerServiceAvailable (defined in Activ::ContentPlatform::ContentGatewayApi::ContentGatewayInfo) | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayInfo |
m_isSymbolDirectoryServiceAvailable (defined in Activ::ContentPlatform::ContentGatewayApi::ContentGatewayInfo) | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayInfo |
m_permissionLevelList | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayInfo |
m_systemInfo | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayInfo |
m_version | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayInfo |
PermissionLevelList typedef (defined in Activ::ContentPlatform::ContentGatewayApi::ContentGatewayInfo) | Activ::ContentPlatform::ContentGatewayApi::ContentGatewayInfo |

Generated on Wed Oct 8 14:02:02 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::DataPointAddress Member List

This is the complete list of members for Activ::ContentPlatform::ContentGatewayApi::DataPointAddress, including all inherited members.

Deserialize(MessageValidator &messageValidator) | Activ::ContentPlatform::ContentGatewayApi::DataPointAddress
Flags typedef | Activ::ContentPlatform::ContentGatewayApi::DataPointAddress
m_dateTime (defined in Activ::ContentPlatform::ContentGatewayApi::DataPointAddress) | Activ::ContentPlatform::ContentGatewayApi::DataPointAddress
m_internalFlag (defined in Activ::ContentPlatform::ContentGatewayApi::DataPointAddress) | Activ::ContentPlatform::ContentGatewayApi::DataPointAddress
m_sectorNumber (defined in Activ::ContentPlatform::ContentGatewayApi::DataPointAddress) | Activ::ContentPlatform::ContentGatewayApi::DataPointAddress
m_sequenceNumber (defined in Activ::ContentPlatform::ContentGatewayApi::DataPointAddress) | Activ::ContentPlatform::ContentGatewayApi::DataPointAddress
operator==(const DataPointAddress &rhs) const | Activ::ContentPlatform::ContentGatewayApi::DataPointAddress
SectorNumber typedef (defined in Activ::ContentPlatform::ContentGatewayApi::DataPointAddress) | Activ::ContentPlatform::ContentGatewayApi::DataPointAddress
SequenceNumber typedef (defined in Activ::ContentPlatform::ContentGatewayApi::DataPointAddress) | Activ::ContentPlatform::ContentGatewayApi::DataPointAddress
Serialize(MessageBuilder &messageBuilder) const | Activ::ContentPlatform::ContentGatewayApi::DataPointAddress

Generated on Wed Oct 8 14:02:02 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::FieldData Member List

This is the complete list of members for Activ::ContentPlatform::ContentGatewayApi::FieldData, including all inherited members.

Buffer typedef | Activ::ContentPlatform::ContentGatewayApi::FieldData |
IsEmpty() const | Activ::ContentPlatform::ContentGatewayApi::FieldData | [inline]
m_buffer | Activ::ContentPlatform::ContentGatewayApi::FieldData |
m_messageVersion | Activ::ContentPlatform::ContentGatewayApi::FieldData |

Generated on Wed Oct 8 14:02:02 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::FieldListValidator Member List

This is the complete list of members for Activ::ContentPlatform::ContentGatewayApi::FieldListValidator, including all inherited members.

ApplyUpdate(const FieldData &fieldData) | Activ::ContentPlatform::ContentGatewayApi::FieldListValidator |
Activ::ContentPlatform::FeedApi::FieldListValidator::ApplyUpdate(const FieldListValidator &fieldListValidator) | Activ::ContentPlatform::FeedApi::FieldListValidator |
ApplyUpdateToExistingFieldsOnly(const FieldData &fieldData) | Activ::ContentPlatform::ContentGatewayApi::FieldListValidator |
Activ::ContentPlatform::FeedApi::FieldListValidator::ApplyUpdateToExistingFieldsOnly(const FieldListValidator &fieldListValidator) | Activ::ContentPlatform::FeedApi::FieldListValidator |
Begin() const | Activ::ContentPlatform::FeedApi::FieldListValidator |
Clear() | Activ::ContentPlatform::FeedApi::FieldListValidator |
ContentGateway::FieldListValidator (defined in Activ::ContentPlatform::FeedApi::FieldListValidator) | Activ::ContentPlatform::FeedApi::FieldListValidator | [friend]
ContentGatewayApi::FieldListValidator (defined in Activ::ContentPlatform::FeedApi::FieldListValidator) | Activ::ContentPlatform::FeedApi::FieldListValidator | [friend]
ContentServerApi::FieldListValidator (defined in Activ::ContentPlatform::FeedApi::FieldListValidator) | Activ::ContentPlatform::FeedApi::FieldListValidator | [friend]
End() const | Activ::ContentPlatform::FeedApi::FieldListValidator |
FieldListValidator() | Activ::ContentPlatform::ContentGatewayApi::FieldListValidator |
FieldListValidator(const FieldListValidator &rhs) | Activ::ContentPlatform::ContentGatewayApi::FieldListValidator |
FieldListValidator(const FieldData &fieldData) | Activ::ContentPlatform::ContentGatewayApi::FieldListValidator |
Activ::ContentPlatform::FeedApi::FieldListValidator::FieldListValidator(const FieldListValidator &rhs) | Activ::ContentPlatform::FeedApi::FieldListValidator |
GetActivFieldType(const Feed::FieldId fieldId, const T *&pFieldType) const | Activ::ContentPlatform::FeedApi::FieldListValidator | [inline]
GetActivFieldType(const Feed::FieldId fieldId) const | Activ::ContentPlatform::FeedApi::FieldListValidator | [inline]
GetField(const Feed::FieldId fieldId, const Field *&pField) const | Activ::ContentPlatform::FeedApi::FieldListValidator | [inline]
GetNumberOfFields() const | Activ::ContentPlatform::FeedApi::FieldListValidator | [inline]
Initialize(const FieldData &fieldData) | Activ::ContentPlatform::ContentGatewayApi::FieldListValidator |
IsFieldPresent(const Feed::FieldId fieldId) const | Activ::ContentPlatform::FeedApi::FieldListValidator | [inline]
IsInitialized() const | Activ::ContentPlatform::FeedApi::FieldListValidator | [inline]
IsPartialSubset(const FieldListValidator &rhs) const | Activ::ContentPlatform::FeedApi::FieldListValidator | [inline]
IsSubset(const FieldListValidator &rhs) const | Activ::ContentPlatform::FeedApi::FieldListValidator | [inline]
m_messageValidator | Activ::ContentPlatform::ContentGatewayApi::FieldListValidator |
operator=(const FieldListValidator &rhs) | Activ::ContentPlatform::FeedApi::FieldListValidator |
Reset() | Activ::ContentPlatform::FeedApi::FieldListValidator |
~FieldListValidator() | Activ::ContentPlatform::FeedApi::FieldListValidator |

Generated on Wed Oct 8 14:02:02 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::FieldSet Member List

This is the complete list of members for Activ::ContentPlatform::ContentGatewayApi::FieldSet, including all inherited members.

ACTIV_DECLARE_ELEMENT_1_WITH_COMMA enum value (defined in Activ::ContentPlatform::ContentGatewayApi::FieldSet) | Activ::ContentPlatform::ContentGatewayApi::FieldSet |
DEFAULT_STRING_FIELD_SEPARATER (defined in Activ::ContentPlatform::ContentGatewayApi::FieldSet) | Activ::ContentPlatform::ContentGatewayApi::FieldSet | [static]
Deserialize(MessageValidator &messageValidator) | Activ::ContentPlatform::ContentGatewayApi::FieldSet | [virtual]
FieldSet() | Activ::ContentPlatform::ContentGatewayApi::FieldSet | [inline]
FieldSetListFindMode enum name (defined in Activ::ContentPlatform::ContentGatewayApi::FieldSet) | Activ::ContentPlatform::ContentGatewayApi::FieldSet |
FilterStatus enum name (defined in Activ::ContentPlatform::ContentGatewayApi::FieldSet) | Activ::ContentPlatform::ContentGatewayApi::FieldSet |
FindContentSubstring(const std::string &input, const std::string &deliminator, std::string::size_type &startPos, std::string &subStringOut) (defined in Activ::ContentPlatform::ContentGatewayApi::FieldSet) | Activ::ContentPlatform::ContentGatewayApi::FieldSet | [inline, static]
FromString(const std::string &inputStr, const std::string &deliminator=DEFAULT_STRING_FIELD_SEPARATER) | Activ::ContentPlatform::ContentGatewayApi::FieldSet | [virtual]
GetField(const Feed::FieldId fieldId, IFieldType &field) const | Activ::ContentPlatform::ContentGatewayApi::FieldSet | [virtual]
GetMaxSerializedLength() | Activ::ContentPlatform::ContentGatewayApi::FieldSet | [static]
GetSequence() const | Activ::ContentPlatform::ContentGatewayApi::FieldSet | [inline]
GetSerializedLength() const | Activ::ContentPlatform::ContentGatewayApi::FieldSet | [virtual]
GetType() const | Activ::ContentPlatform::ContentGatewayApi::FieldSet | [virtual]
ProcessSplit(const int sharesBefore, const int sharesAfter, const Rational::Denominator type) | Activ::ContentPlatform::ContentGatewayApi::FieldSet | [inline]
RationalToDoubleString(const Rational &rational, char *buffer) (defined in Activ::ContentPlatform::ContentGatewayApi::FieldSet) | Activ::ContentPlatform::ContentGatewayApi::FieldSet | [static]
ReadDate(const std::string &input, const std::string &deliminator, std::string::size_type &startingPos, Date &dateOut) | Activ::ContentPlatform::ContentGatewayApi::FieldSet | [static]
ReadDateTime(const std::string &input, const std::string &deliminator, std::string::size_type &startPos, DateTime &dateTimeOut) | Activ::ContentPlatform::ContentGatewayApi::FieldSet | [static]
ReadInteger(const std::string &input, const std::string &deliminator, std::string::size_type &startPos, uint32_t &uintOut) | Activ::ContentPlatform::ContentGatewayApi::FieldSet | [inline, static]
ReadRationalFromDoubleString(const std::string &input, const std::string &deliminator, std::string::size_type &startPos, Rational &rationalOut) | Activ::ContentPlatform::ContentGatewayApi::FieldSet | [static]
ReadTime(const std::string &input, const std::string &deliminator, std::string::size_type &startingPos, Time &timeOut) | Activ::ContentPlatform::ContentGatewayApi::FieldSet | [static]
Reset() | Activ::ContentPlatform::ContentGatewayApi::FieldSet | [inline, virtual]
Serialize(MessageBuilder &messageBuilder) const | Activ::ContentPlatform::ContentGatewayApi::FieldSet | [virtual]
SetField(const Feed::FieldId fieldId, const IFieldType &field) | Activ::ContentPlatform::ContentGatewayApi::FieldSet | [virtual]
SetSequence(byte_t sequence) | Activ::ContentPlatform::ContentGatewayApi::FieldSet | [inline]
ToString(const std::string &deliminator=DEFAULT_STRING_FIELD_SEPARATER) const | Activ::ContentPlatform::ContentGatewayApi::FieldSet | [virtual]
UpdateFieldSetStatus enum name | Activ::ContentPlatform::ContentGatewayApi::FieldSet |
~FieldSet() | Activ::ContentPlatform::ContentGatewayApi::FieldSet | [virtual]

Generated on Wed Oct 8 14:02:02 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::HistoryBar Member List

This is the complete list of members for Activ::ContentPlatform::ContentGatewayApi::HistoryBar, including all inherited members.

ACTIV_DECLARE_ELEMENT_1_WITH_COMMA enum value (defined in Activ::ContentPlatform::ContentGatewayApi::HistoryBar) | Activ::ContentPlatform::ContentGatewayApi::HistoryBar |
Adjust(const HistoryAdjustmentType adjustmentType, const Rational &amount, const Rational::Denominator denominator) | Activ::ContentPlatform::ContentGatewayApi::HistoryBar |
BuildBarFromRecord(const Database::Record &record, HistoryBar &dailyBar) (defined in Activ::ContentPlatform::ContentGatewayApi::HistoryBar) | Activ::ContentPlatform::ContentGatewayApi::HistoryBar | [static]
BuildClosedSessionBarFromRecord(const Database::Record &record) (defined in Activ::ContentPlatform::ContentGatewayApi::HistoryBar) | Activ::ContentPlatform::ContentGatewayApi::HistoryBar | [virtual]
Compare(const HistoryBar &rhs) const | Activ::ContentPlatform::ContentGatewayApi::HistoryBar |
Compare(const HistoryBar &rhs, int &result) const | Activ::ContentPlatform::ContentGatewayApi::HistoryBar | [inline]
DEFAULT_STRING_FIELD_SEPARATER (defined in Activ::ContentPlatform::ContentGatewayApi::FieldSet) | Activ::ContentPlatform::ContentGatewayApi::FieldSet | [static]
Deserialize(MessageValidator &messageValidator) | Activ::ContentPlatform::ContentGatewayApi::HistoryBar | [virtual]
FieldSet() | Activ::ContentPlatform::ContentGatewayApi::FieldSet | [inline]
FieldSetListFindMode enum name (defined in Activ::ContentPlatform::ContentGatewayApi::FieldSet) | Activ::ContentPlatform::ContentGatewayApi::FieldSet |
FilterStatus enum name (defined in Activ::ContentPlatform::ContentGatewayApi::FieldSet) | Activ::ContentPlatform::ContentGatewayApi::FieldSet |
FindContentSubstring(const std::string &input, const std::string &deliminator, std::string::size_type &startPos, std::string &subStringOut) (defined in Activ::ContentPlatform::ContentGatewayApi::FieldSet) | Activ::ContentPlatform::ContentGatewayApi::FieldSet | [inline, static]
ForceDecimalType(const Rational::Denominator type) | Activ::ContentPlatform::ContentGatewayApi::HistoryBar |
FromString(const std::string &inputStr, const std::string &deliminator=DEFAULT_STRING_FIELD_SEPARATER) | Activ::ContentPlatform::ContentGatewayApi::HistoryBar | [virtual]
FromStringSpecial(const std::string &inputStr) | Activ::ContentPlatform::ContentGatewayApi::HistoryBar | [virtual]
GetClosePrice(Rational &price) const | Activ::ContentPlatform::ContentGatewayApi::HistoryBar | [inline]
GetClosePrice(double &price) const | Activ::ContentPlatform::ContentGatewayApi::HistoryBar | [inline]
GetDate(Date &date) const | Activ::ContentPlatform::ContentGatewayApi::HistoryBar | [inline]
GetDateTime(DateTime &dateTime) const | Activ::ContentPlatform::ContentGatewayApi::HistoryBar | [inline]
GetField(const Feed::FieldId fieldId, IFieldType &field) const | Activ::ContentPlatform::ContentGatewayApi::HistoryBar | [virtual]
GetHighPrice(Rational &price) const | Activ::ContentPlatform::ContentGatewayApi::HistoryBar | [inline]
GetHighPrice(double &price) const | Activ::ContentPlatform::ContentGatewayApi::HistoryBar | [inline]
GetLowPrice(Rational &price) const | Activ::ContentPlatform::ContentGatewayApi::HistoryBar | [inline]
GetLowPrice(double &price) const | Activ::ContentPlatform::ContentGatewayApi::HistoryBar | [inline]
GetMaxSerializedLength() | Activ::ContentPlatform::ContentGatewayApi::HistoryBar | [static]
GetOpenInterest(uint32_t &openInterest) const | Activ::ContentPlatform::ContentGatewayApi::HistoryBar | [inline]
GetOpenPrice(Rational &price) const | Activ::ContentPlatform::ContentGatewayApi::HistoryBar | [inline]
GetOpenPrice(double &price) const | Activ::ContentPlatform::ContentGatewayApi::HistoryBar | [inline]
GetSequence() const | Activ::ContentPlatform::ContentGatewayApi::FieldSet | [inline]
GetSerializedLength() const | Activ::ContentPlatform::ContentGatewayApi::HistoryBar | [virtual]
GetTotalPrice(Rational &totalPrice) const | Activ::ContentPlatform::ContentGatewayApi::HistoryBar | [inline]
GetTotalPrice(double &totalPrice) const | Activ::ContentPlatform::ContentGatewayApi::HistoryBar | [inline]
GetTotalValue(Rational &totalValue) const | Activ::ContentPlatform::ContentGatewayApi::HistoryBar | [inline]
GetTotalValue(double &totalValue) const | Activ::ContentPlatform::ContentGatewayApi::HistoryBar | [inline]
GetTotalVolume(uint64_t &volume) const | Activ::ContentPlatform::ContentGatewayApi::HistoryBar | [inline]
GetTotalVolume(Rational &volume) const | Activ::ContentPlatform::ContentGatewayApi::HistoryBar | [inline]
GetType() const | Activ::ContentPlatform::ContentGatewayApi::HistoryBar | [virtual]
HistoryAdjustmentType enum name (defined in Activ::ContentPlatform::ContentGatewayApi::HistoryBar) | Activ::ContentPlatform::ContentGatewayApi::HistoryBar |
HistoryBar() | Activ::ContentPlatform::ContentGatewayApi::HistoryBar |
IsOpenValid() | Activ::ContentPlatform::ContentGatewayApi::HistoryBar | [inline]
operator!=(const HistoryBar &rhs) const | Activ::ContentPlatform::ContentGatewayApi::HistoryBar | [inline]
operator<(const HistoryBar &rhs) const | Activ::ContentPlatform::ContentGatewayApi::HistoryBar | [inline]
operator<(const DateTime &dateTime) const | Activ::ContentPlatform::ContentGatewayApi::HistoryBar | [inline]
operator<=(const HistoryBar &rhs) const | Activ::ContentPlatform::ContentGatewayApi::HistoryBar | [inline]
operator<=(const DateTime &dateTime) const (defined in Activ::ContentPlatform::ContentGatewayApi::HistoryBar) | Activ::ContentPlatform::ContentGatewayApi::HistoryBar | [inline]
operator==(const HistoryBar &rhs) const | Activ::ContentPlatform::ContentGatewayApi::HistoryBar | [inline]
operator==(const DateTime &dateTime) const | Activ::ContentPlatform::ContentGatewayApi::HistoryBar | [inline]
operator>(const HistoryBar &rhs) const | Activ::ContentPlatform::ContentGatewayApi::HistoryBar | [inline]
operator>(const DateTime &dateTime) const | Activ::ContentPlatform::ContentGatewayApi::HistoryBar | [inline]
operator>=(const HistoryBar &rhs) const | Activ::ContentPlatform::ContentGatewayApi::HistoryBar | [inline]
operator>=(const DateTime &dateTime) const (defined in Activ::ContentPlatform::ContentGatewayApi::HistoryBar) | Activ::ContentPlatform::ContentGatewayApi::HistoryBar | [inline]
ProcessSplit(const int sharesBefore, const int sharesAfter, const Rational::Denominator type) | Activ::ContentPlatform::ContentGatewayApi::HistoryBar |
RationalToDoubleString(const Rational &rational, char *buffer) (defined in Activ::ContentPlatform::ContentGatewayApi::FieldSet) | Activ::ContentPlatform::ContentGatewayApi::FieldSet | [static]
ReadDate(const std::string &input, const std::string &deliminator, std::string::size_type &startingPos, Date &dateOut) | Activ::ContentPlatform::ContentGatewayApi::FieldSet | [static]
ReadDateTime(const std::string &input, const std::string &deliminator, std::string::size_type &startPos, DateTime &dateTimeOut) | Activ::ContentPlatform::ContentGatewayApi::FieldSet | [static]
ReadInteger(const std::string &input, const std::string &deliminator, std::string::size_type &startPos, uint32_t &uintOut) | Activ::ContentPlatform::ContentGatewayApi::FieldSet | [inline, static]
ReadRationalFromDoubleString(const std::string &input, const std::string &deliminator, std::string::size_type &startPos, Rational &rationalOut) | Activ::ContentPlatform::ContentGatewayApi::FieldSet | [static]
ReadTime(const std::string &input, const std::string &deliminator, std::string::size_type &startingPos, Time &timeOut) | Activ::ContentPlatform::ContentGatewayApi::FieldSet | [static]
Reset() | Activ::ContentPlatform::ContentGatewayApi::HistoryBar | [virtual]
Serialize(MessageBuilder &messageBuilder) const | Activ::ContentPlatform::ContentGatewayApi::HistoryBar | [virtual]
SetClosePrice(const Rational &price) | Activ::ContentPlatform::ContentGatewayApi::HistoryBar | [inline]
SetDate(const Date &date) | Activ::ContentPlatform::ContentGatewayApi::HistoryBar | [inline]
SetField(const Feed::FieldId fieldId, const IFieldType &field) | Activ::ContentPlatform::ContentGatewayApi::HistoryBar | [virtual]
SetHighPrice(const Rational &price) | Activ::ContentPlatform::ContentGatewayApi::HistoryBar | [inline]
SetLowPrice(const Rational &price) | Activ::ContentPlatform::ContentGatewayApi::HistoryBar | [inline]
SetOpenInterest(const uint32_t openInterest) | Activ::ContentPlatform::ContentGatewayApi::HistoryBar | [inline]
SetOpenPrice(const Rational &price) | Activ::ContentPlatform::ContentGatewayApi::HistoryBar | [inline]
SetSequence(byte_t sequence) | Activ::ContentPlatform::ContentGatewayApi::FieldSet | [inline]
SetToMiniBar() | Activ::ContentPlatform::ContentGatewayApi::HistoryBar | [inline]
SetTotalPrice(Rational &totalPrice) | Activ::ContentPlatform::ContentGatewayApi::HistoryBar | [inline]
SetTotalValue(Rational &totalValue) | Activ::ContentPlatform::ContentGatewayApi::HistoryBar | [inline]
SetTotalVolume(const uint64_t volume) | Activ::ContentPlatform::ContentGatewayApi::HistoryBar | [inline]
SetTotalVolume(const Rational &volume) | Activ::ContentPlatform::ContentGatewayApi::HistoryBar | [inline]
ToString(const std::string &deliminator=DEFAULT_STRING_FIELD_SEPARATER) const | Activ::ContentPlatform::ContentGatewayApi::HistoryBar | [virtual]
Update(const SeriesType period, const HistoryBar &dailyBar) | Activ::ContentPlatform::ContentGatewayApi::HistoryBar |
UpdateFieldSetStatus enum name | Activ::ContentPlatform::ContentGatewayApi::FieldSet |
~FieldSet() | Activ::ContentPlatform::ContentGatewayApi::FieldSet | [virtual]
~HistoryBar() | Activ::ContentPlatform::ContentGatewayApi::HistoryBar | [virtual]

Generated on Wed Oct 8 14:02:02 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::INewsResponses Member List

This is the complete list of members for Activ::ContentPlatform::ContentGatewayApi::INewsResponses, including all inherited members.

OnGetNewsStoriesResponse(HeapMessage &response)=0 | Activ::ContentPlatform::ContentGatewayApi::INewsResponses | [pure virtual]
OnNewsUpdate(HeapMessage &update)=0 | Activ::ContentPlatform::ContentGatewayApi::INewsResponses | [pure virtual]
~INewsResponses()=0 | Activ::ContentPlatform::ContentGatewayApi::INewsResponses | [inline, pure virtual]

Generated on Wed Oct 8 14:02:02 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::IRealtimeResponses Member List

This is the complete list of members for Activ::ContentPlatform::ContentGatewayApi::IRealtimeResponses, including all inherited members.

OnGetEqualResponse(HeapMessage &response)=0 | Activ::ContentPlatform::ContentGatewayApi::IRealtimeResponses | [pure virtual]
OnGetFirstResponse(HeapMessage &response)=0 | Activ::ContentPlatform::ContentGatewayApi::IRealtimeResponses | [pure virtual]
OnGetLastResponse(HeapMessage &response)=0 | Activ::ContentPlatform::ContentGatewayApi::IRealtimeResponses | [pure virtual]
OnGetMatchResponse(HeapMessage &response)=0 | Activ::ContentPlatform::ContentGatewayApi::IRealtimeResponses | [pure virtual]
OnGetMultipleEqualResponse(HeapMessage &response)=0 | Activ::ContentPlatform::ContentGatewayApi::IRealtimeResponses | [pure virtual]
OnGetMultipleMatchResponse(HeapMessage &response)=0 | Activ::ContentPlatform::ContentGatewayApi::IRealtimeResponses | [pure virtual]
OnGetMultiplePatternMatchListResponse(HeapMessage &response)=0 | Activ::ContentPlatform::ContentGatewayApi::IRealtimeResponses | [pure virtual]
OnGetMultiplePatternMatchResponse(HeapMessage &response)=0 | Activ::ContentPlatform::ContentGatewayApi::IRealtimeResponses | [pure virtual]
OnGetNextResponse(HeapMessage &response)=0 | Activ::ContentPlatform::ContentGatewayApi::IRealtimeResponses | [pure virtual]
OnGetPreviousResponse(HeapMessage &response)=0 | Activ::ContentPlatform::ContentGatewayApi::IRealtimeResponses | [pure virtual]
OnRecordUpdate(HeapMessage &update)=0 | Activ::ContentPlatform::ContentGatewayApi::IRealtimeResponses | [pure virtual]
~IRealtimeResponses()=0 | Activ::ContentPlatform::ContentGatewayApi::IRealtimeResponses | [inline, pure virtual]

Generated on Wed Oct 8 14:02:03 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::ISymbolDirectoryResponses Member List

This is the complete list of members for Activ::ContentPlatform::ContentGatewayApi::ISymbolDirectoryResponses, including all inherited members.

OnGetSymbolsResponse(HeapMessage &response)=0 | Activ::ContentPlatform::ContentGatewayApi::ISymbolDirectoryResponses | [pure virtual]
~ISymbolDirectoryResponses()=0 | Activ::ContentPlatform::ContentGatewayApi::ISymbolDirectoryResponses | [inline, pure virtual]

Generated on Wed Oct 8 14:02:03 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::ITimeSeriesResponses Member List

This is the complete list of members for Activ::ContentPlatform::ContentGatewayApi::ITimeSeriesResponses, including all inherited members.

OnGetFirstHistoryResponse(HeapMessage &response)=0 | Activ::ContentPlatform::ContentGatewayApi::ITimeSeriesResponses | [pure virtual]
OnGetFirstIntradayResponse(HeapMessage &response)=0 | Activ::ContentPlatform::ContentGatewayApi::ITimeSeriesResponses | [pure virtual]
OnGetFirstTicksResponse(HeapMessage &response)=0 | Activ::ContentPlatform::ContentGatewayApi::ITimeSeriesResponses | [pure virtual]
OnGetNextHistoryResponse(HeapMessage &response)=0 | Activ::ContentPlatform::ContentGatewayApi::ITimeSeriesResponses | [pure virtual]
OnGetNextIntradayResponse(HeapMessage &response)=0 | Activ::ContentPlatform::ContentGatewayApi::ITimeSeriesResponses | [pure virtual]
OnGetNextTicksResponse(HeapMessage &response)=0 | Activ::ContentPlatform::ContentGatewayApi::ITimeSeriesResponses | [pure virtual]
~ITimeSeriesResponses()=0 | Activ::ContentPlatform::ContentGatewayApi::ITimeSeriesResponses | [inline, pure virtual]

Generated on Wed Oct 8 14:02:03 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::IntradayBar Member List

This is the complete list of members for Activ::ContentPlatform::ContentGatewayApi::IntradayBar, including all inherited members.

ACTIV_DECLARE_ELEMENT_1_WITH_COMMA enum value (defined in Activ::ContentPlatform::ContentGatewayApi::FieldSet) | Activ::ContentPlatform::ContentGatewayApi::FieldSet |
Compare(const IntradayBar &rhs) const | Activ::ContentPlatform::ContentGatewayApi::IntradayBar |
Compare(const IntradayBar &rhs, int &result) const | Activ::ContentPlatform::ContentGatewayApi::IntradayBar | [inline]
DEFAULT_STRING_FIELD_SEPARATER (defined in Activ::ContentPlatform::ContentGatewayApi::FieldSet) | Activ::ContentPlatform::ContentGatewayApi::FieldSet | [static]
Deserialize(MessageValidator &messageValidator) | Activ::ContentPlatform::ContentGatewayApi::IntradayBar | [virtual]
FieldSet() | Activ::ContentPlatform::ContentGatewayApi::FieldSet | [inline]
FieldSetListFindMode enum name (defined in Activ::ContentPlatform::ContentGatewayApi::FieldSet) | Activ::ContentPlatform::ContentGatewayApi::FieldSet |
FilterStatus enum name (defined in Activ::ContentPlatform::ContentGatewayApi::FieldSet) | Activ::ContentPlatform::ContentGatewayApi::FieldSet |
FindContentSubstring(const std::string &input, const std::string &deliminator, std::string::size_type &startPos, std::string &subStringOut) (defined in Activ::ContentPlatform::ContentGatewayApi::FieldSet) | Activ::ContentPlatform::ContentGatewayApi::FieldSet | [inline, static]
FromString(const std::string &inputStr, const std::string &deliminator=DEFAULT_STRING_FIELD_SEPARATER) | Activ::ContentPlatform::ContentGatewayApi::IntradayBar | [virtual]
GetClosePrice(Rational &price) const | Activ::ContentPlatform::ContentGatewayApi::IntradayBar | [inline]
GetClosePrice(double &price) const | Activ::ContentPlatform::ContentGatewayApi::IntradayBar | [inline]
GetDateTime(DateTime &dateTime) const | Activ::ContentPlatform::ContentGatewayApi::IntradayBar | [inline]
GetField(const Feed::FieldId fieldId, IFieldType &field) const | Activ::ContentPlatform::ContentGatewayApi::IntradayBar | [virtual]
GetFlag(byte_t &flag) const | Activ::ContentPlatform::ContentGatewayApi::IntradayBar | [inline]
GetHighPrice(Rational &price) const | Activ::ContentPlatform::ContentGatewayApi::IntradayBar | [inline]
GetHighPrice(double &price) const | Activ::ContentPlatform::ContentGatewayApi::IntradayBar | [inline]
GetLowPrice(Rational &price) const | Activ::ContentPlatform::ContentGatewayApi::IntradayBar | [inline]
GetLowPrice(double &price) const | Activ::ContentPlatform::ContentGatewayApi::IntradayBar | [inline]
GetMaxSerializedLength() | Activ::ContentPlatform::ContentGatewayApi::IntradayBar | [static]
GetOpenPrice(Rational &price) const | Activ::ContentPlatform::ContentGatewayApi::IntradayBar | [inline]
GetOpenPrice(double &price) const | Activ::ContentPlatform::ContentGatewayApi::IntradayBar | [inline]
GetSequence() const | Activ::ContentPlatform::ContentGatewayApi::FieldSet | [inline]
GetSerializedLength() const | Activ::ContentPlatform::ContentGatewayApi::IntradayBar | [virtual]
GetTickCount(uint32_t &count) const | Activ::ContentPlatform::ContentGatewayApi::IntradayBar | [inline]
GetTotalPrice(Rational &totalPrice) const | Activ::ContentPlatform::ContentGatewayApi::IntradayBar | [inline]
GetTotalPrice(double &totalPrice) const | Activ::ContentPlatform::ContentGatewayApi::IntradayBar | [inline]
GetTotalValue(Rational &totalValue) const | Activ::ContentPlatform::ContentGatewayApi::IntradayBar | [inline]
GetTotalValue(double &totalValue) const | Activ::ContentPlatform::ContentGatewayApi::IntradayBar | [inline]
GetTotalVolume(uint32_t &volume) const | Activ::ContentPlatform::ContentGatewayApi::IntradayBar | [inline]
GetTotalVolume(Rational &volume) const | Activ::ContentPlatform::ContentGatewayApi::IntradayBar | [inline]
GetType() const | Activ::ContentPlatform::ContentGatewayApi::IntradayBar | [virtual]
HasTick() const | Activ::ContentPlatform::ContentGatewayApi::IntradayBar | [inline]
IntradayBar() | Activ::ContentPlatform::ContentGatewayApi::IntradayBar |
IsRegularHour() const | Activ::ContentPlatform::ContentGatewayApi::IntradayBar | [inline]
IsVWAPOnly() const | Activ::ContentPlatform::ContentGatewayApi::IntradayBar | [inline]
NONE_REGULAR_HOUR_TRADE_BIT (defined in Activ::ContentPlatform::ContentGatewayApi::IntradayBar) | Activ::ContentPlatform::ContentGatewayApi::IntradayBar | [static]
operator!=(const IntradayBar &rhs) const | Activ::ContentPlatform::ContentGatewayApi::IntradayBar | [inline]
operator<(const IntradayBar &rhs) const | Activ::ContentPlatform::ContentGatewayApi::IntradayBar | [inline]
operator<(const DateTime &dateTime) const | Activ::ContentPlatform::ContentGatewayApi::IntradayBar | [inline]
operator<=(const IntradayBar &rhs) const | Activ::ContentPlatform::ContentGatewayApi::IntradayBar | [inline]
operator<=(const DateTime &dateTime) const (defined in Activ::ContentPlatform::ContentGatewayApi::IntradayBar) | Activ::ContentPlatform::ContentGatewayApi::IntradayBar | [inline]
operator==(const IntradayBar &rhs) const | Activ::ContentPlatform::ContentGatewayApi::IntradayBar | [inline]
operator==(const DateTime &dateTime) const | Activ::ContentPlatform::ContentGatewayApi::IntradayBar | [inline]
operator>(const IntradayBar &rhs) const | Activ::ContentPlatform::ContentGatewayApi::IntradayBar | [inline]
operator>(const DateTime &dateTime) const | Activ::ContentPlatform::ContentGatewayApi::IntradayBar | [inline]
operator>=(const IntradayBar &rhs) const | Activ::ContentPlatform::ContentGatewayApi::IntradayBar | [inline]
operator>=(const DateTime &dateTime) const (defined in Activ::ContentPlatform::ContentGatewayApi::IntradayBar) | Activ::ContentPlatform::ContentGatewayApi::IntradayBar | [inline]
ProcessSplit(const int sharesBefore, const int sharesAfter, const Rational::Denominator type) | Activ::ContentPlatform::ContentGatewayApi::IntradayBar |
RationalToDoubleString(const Rational &rational, char *buffer) (defined in Activ::ContentPlatform::ContentGatewayApi::FieldSet) | Activ::ContentPlatform::ContentGatewayApi::FieldSet | [static]
ReadDate(const std::string &input, const std::string &deliminator, std::string::size_type &startingPos, Date &dateOut) | Activ::ContentPlatform::ContentGatewayApi::FieldSet | [static]
ReadDateTime(const std::string &input, const std::string &deliminator, std::string::size_type &startPos, DateTime &dateTimeOut) | Activ::ContentPlatform::ContentGatewayApi::FieldSet | [static]
ReadInteger(const std::string &input, const std::string &deliminator, std::string::size_type &startPos, uint32_t &uintOut) | Activ::ContentPlatform::ContentGatewayApi::FieldSet | [inline, static]
ReadRationalFromDoubleString(const std::string &input, const std::string &deliminator, std::string::size_type &startPos, Rational &rationalOut) | Activ::ContentPlatform::ContentGatewayApi::FieldSet | [static]
ReadTime(const std::string &input, const std::string &deliminator, std::string::size_type &startingPos, Time &timeOut) | Activ::ContentPlatform::ContentGatewayApi::FieldSet | [static]
RemoveTrade(const Tick &canceledTrade) | Activ::ContentPlatform::ContentGatewayApi::IntradayBar |
Reset() | Activ::ContentPlatform::ContentGatewayApi::IntradayBar | [virtual]
Serialize(MessageBuilder &messageBuilder) const | Activ::ContentPlatform::ContentGatewayApi::IntradayBar | [virtual]
SetClosePrice(const Rational &price) | Activ::ContentPlatform::ContentGatewayApi::IntradayBar | [inline]
SetDate(const Date &date) | Activ::ContentPlatform::ContentGatewayApi::IntradayBar | [inline]
SetDateTime(const DateTime &dateTime) | Activ::ContentPlatform::ContentGatewayApi::IntradayBar | [inline]
SetField(const Feed::FieldId fieldId, const IFieldType &field) | Activ::ContentPlatform::ContentGatewayApi::IntradayBar | [virtual]
SetFlag(const byte_t flag) | Activ::ContentPlatform::ContentGatewayApi::IntradayBar | [inline]
SetHighPrice(const Rational &price) | Activ::ContentPlatform::ContentGatewayApi::IntradayBar | [inline]
SetLowPrice(const Rational &price) | Activ::ContentPlatform::ContentGatewayApi::IntradayBar | [inline]
SetOpenPrice(const Rational &price) | Activ::ContentPlatform::ContentGatewayApi::IntradayBar | [inline]
SetSequence(byte_t sequence) | Activ::ContentPlatform::ContentGatewayApi::FieldSet | [inline]
SetTickCount(const uint32_t count) | Activ::ContentPlatform::ContentGatewayApi::IntradayBar | [inline]
SetTime(const Time &time) | Activ::ContentPlatform::ContentGatewayApi::IntradayBar | [inline]
SetToMiniBar() | Activ::ContentPlatform::ContentGatewayApi::IntradayBar | [inline]
SetTotalPrice(Rational &totalPrice) | Activ::ContentPlatform::ContentGatewayApi::IntradayBar | [inline]
SetTotalValue(Rational &totalValue) | Activ::ContentPlatform::ContentGatewayApi::IntradayBar | [inline]
SetTotalVolume(const uint32_t volume) | Activ::ContentPlatform::ContentGatewayApi::IntradayBar | [inline]
SetTotalVolume(const Rational &volume) | Activ::ContentPlatform::ContentGatewayApi::IntradayBar | [inline]
ToString(const std::string &deliminator=DEFAULT_STRING_FIELD_SEPARATER) const | Activ::ContentPlatform::ContentGatewayApi::IntradayBar | [virtual]
Update(const unsigned period, const Tick &tick, bool updateHighLow, bool updateVwap) | Activ::ContentPlatform::ContentGatewayApi::IntradayBar |
Update(const unsigned period, const IntradayBar &bar) | Activ::ContentPlatform::ContentGatewayApi::IntradayBar |
UpdateFieldSetStatus enum name | Activ::ContentPlatform::ContentGatewayApi::FieldSet |
VWAP_ONLY_BIT (defined in Activ::ContentPlatform::ContentGatewayApi::IntradayBar) | Activ::ContentPlatform::ContentGatewayApi::IntradayBar | [static]
~FieldSet() | Activ::ContentPlatform::ContentGatewayApi::FieldSet | [virtual]
~IntradayBar() | Activ::ContentPlatform::ContentGatewayApi::IntradayBar | [virtual]

Generated on Wed Oct 8 14:02:03 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::MatchRequestParameters Member List

This is the complete list of members for Activ::ContentPlatform::ContentGatewayApi::MatchRequestParameters, including all inherited members.

ACTIV_DECLARE_VALUE_WITH_COMMA enum value | Activ::ContentPlatform::ContentGatewayApi::MatchRequestParameters |
Clear() | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters |
DEFAULT_MAX_RESPONSE_BLOCKS | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters | [static]
FLAG_IGNORE_ALIAS (defined in Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters) | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters | [static]
FLAG_NONE (defined in Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters) | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters | [static]
Flags typedef | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters |
m_flags | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters |
m_matchType | Activ::ContentPlatform::ContentGatewayApi::MatchRequestParameters |
m_maxResponseBlocks | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters |
m_permissionLevel | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters |
m_requestBlockList | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters |
m_subscribeParameters | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters |
MatchType enum name | Activ::ContentPlatform::ContentGatewayApi::MatchRequestParameters |
RealtimeRequestParameters() | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters |

Generated on Wed Oct 8 14:02:03 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::MetaDataRequestHelper Member List

This is the complete list of members for Activ::ContentPlatform::ContentGatewayApi::MetaDataRequestHelper, including all inherited members.

GetPermissionInfo(const ContentGatewayClient &contentGatewayClient, PermissionInfo &permissionInfo) | Activ::ContentPlatform::ContentGatewayApi::MetaDataRequestHelper | [static]
GetRelationshipInfoList(const ContentGatewayClient &contentGatewayClient, const Feed::Context context, RelationshipInfoList &relationshipInfoList) | Activ::ContentPlatform::ContentGatewayApi::MetaDataRequestHelper | [static]
GetTableInfoList(const ContentGatewayClient &contentGatewayClient, const Feed::PermissionLevel permissionLevel, TableInfoList &tableInfoList) | Activ::ContentPlatform::ContentGatewayApi::MetaDataRequestHelper | [static]
GetTableSpecification(const ContentGatewayClient &contentGatewayClient, const Feed::PermissionLevel permissionLevel, const Feed::TableNo tableNumber, Database::TableSpecification &tableSpecification) | Activ::ContentPlatform::ContentGatewayApi::MetaDataRequestHelper | [static]
GetUniversalFieldHelper(const ContentGatewayClient &contentGatewayClient, const Feed::FieldId fieldId) | Activ::ContentPlatform::ContentGatewayApi::MetaDataRequestHelper | [static]
GetUniversalFieldHelper(const ContentGatewayClient &contentGatewayClient, const std::string &codeIdentifier) | Activ::ContentPlatform::ContentGatewayApi::MetaDataRequestHelper | [static]
GetUniversalFieldHelperMap(const ContentGatewayClient &contentGatewayClient) | Activ::ContentPlatform::ContentGatewayApi::MetaDataRequestHelper | [static]

Generated on Wed Oct 8 14:02:03 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::NewsRequestHelper Member List

This is the complete list of members for Activ::ContentPlatform::ContentGatewayApi::NewsRequestHelper, including all inherited members.

Deserialize(const ContentGatewayClient &client, const HeapMessage &response, ResponseParameters &responseParameters) | Activ::ContentPlatform::ContentGatewayApi::NewsRequestHelper | [static]
GetResponse(const ContentGatewayClient &client, SyncRequestId &syncRequestId, ResponseParameters &responseParameters, const TimeoutPeriod timeoutPeriod) | Activ::ContentPlatform::ContentGatewayApi::NewsRequestHelper | [static]
PostRequest(const ContentGatewayClient &client, const RequestId &requestId, const RequestParameters &requestParameters) | Activ::ContentPlatform::ContentGatewayApi::NewsRequestHelper | [static]
RequestParameters typedef (defined in Activ::ContentPlatform::ContentGatewayApi::NewsRequestHelper) | Activ::ContentPlatform::ContentGatewayApi::NewsRequestHelper |
ResponseParameters typedef (defined in Activ::ContentPlatform::ContentGatewayApi::NewsRequestHelper) | Activ::ContentPlatform::ContentGatewayApi::NewsRequestHelper |
SendRequest(const ContentGatewayClient &client, const RequestParameters &requestParameters, ResponseParameters &responseParameters, const TimeoutPeriod timeoutPeriod=Port::defaultTimeout) | Activ::ContentPlatform::ContentGatewayApi::NewsRequestHelper | [static]
SendRequest(const ContentGatewayClient &client, SyncRequestId &syncRequestId, const RequestParameters &requestParameters) | Activ::ContentPlatform::ContentGatewayApi::NewsRequestHelper | [static]

Generated on Wed Oct 8 14:02:03 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::NewsRequestParameters Member List

This is the complete list of members for Activ::ContentPlatform::ContentGatewayApi::NewsRequestParameters, including all inherited members.

DEFAULT_MAX_RECORDS_PER_RESPONSE | Activ::ContentPlatform::ContentGatewayApi::NewsRequestParameters | [static]
FLAG_INCLUDE_EXPIRED | Activ::ContentPlatform::ContentGatewayApi::NewsRequestParameters | [static]
FLAG_NONE (defined in Activ::ContentPlatform::ContentGatewayApi::NewsRequestParameters) | Activ::ContentPlatform::ContentGatewayApi::NewsRequestParameters | [static]
FLAG_SUBSCRIBE (defined in Activ::ContentPlatform::ContentGatewayApi::NewsRequestParameters) | Activ::ContentPlatform::ContentGatewayApi::NewsRequestParameters | [static]
Flags typedef | Activ::ContentPlatform::ContentGatewayApi::NewsRequestParameters |
m_endDate | Activ::ContentPlatform::ContentGatewayApi::NewsRequestParameters |
m_fieldIdList | Activ::ContentPlatform::ContentGatewayApi::NewsRequestParameters |
m_flags | Activ::ContentPlatform::ContentGatewayApi::NewsRequestParameters |
m_maxRecordsPerResponse | Activ::ContentPlatform::ContentGatewayApi::NewsRequestParameters |
m_numberOfRecords | Activ::ContentPlatform::ContentGatewayApi::NewsRequestParameters |
m_permissionLevel | Activ::ContentPlatform::ContentGatewayApi::NewsRequestParameters |
m_query | Activ::ContentPlatform::ContentGatewayApi::NewsRequestParameters |
m_startDate | Activ::ContentPlatform::ContentGatewayApi::NewsRequestParameters |
m_startSymbol | Activ::ContentPlatform::ContentGatewayApi::NewsRequestParameters |
NewsRequestParameters() | Activ::ContentPlatform::ContentGatewayApi::NewsRequestParameters |

Generated on Wed Oct 8 14:02:03 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::NewsResponseParameters Member List

This is the complete list of members for Activ::ContentPlatform::ContentGatewayApi::NewsResponseParameters, including all inherited members.

m_storyList (defined in Activ::ContentPlatform::ContentGatewayApi::NewsResponseParameters) | Activ::ContentPlatform::ContentGatewayApi::NewsResponseParameters
m_subscriptionCookie (defined in Activ::ContentPlatform::ContentGatewayApi::NewsResponseParameters) | Activ::ContentPlatform::ContentGatewayApi::NewsResponseParameters
NewsResponseParameters() | Activ::ContentPlatform::ContentGatewayApi::NewsResponseParameters

Generated on Wed Oct 8 14:02:03 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::NewsStory Member List

This is the complete list of members for Activ::ContentPlatform::ContentGatewayApi::NewsStory, including all inherited members.

m_fieldData | Activ::ContentPlatform::ContentGatewayApi::NewsStory
m_permissionIdList | Activ::ContentPlatform::ContentGatewayApi::NewsStory
m_symbol | Activ::ContentPlatform::ContentGatewayApi::NewsStory

Generated on Wed Oct 8 14:02:03 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::NewsUpdate Member List

This is the complete list of members for Activ::ContentPlatform::ContentGatewayApi::NewsUpdate, including all inherited members.

FLAG_DELETE | Activ::ContentPlatform::ContentGatewayApi::NewsUpdate | [static]
FLAG_NONE (defined in Activ::ContentPlatform::ContentGatewayApi::NewsUpdate) | Activ::ContentPlatform::ContentGatewayApi::NewsUpdate | [static]
Flags typedef | Activ::ContentPlatform::ContentGatewayApi::NewsUpdate |
FlagsToString(const Flags flags) | Activ::ContentPlatform::ContentGatewayApi::NewsUpdate | [static]
IsDelete() const | Activ::ContentPlatform::ContentGatewayApi::NewsUpdate | [inline]
IsNewRecord() const | Activ::ContentPlatform::ContentGatewayApi::NewsUpdate | [inline]
m_flags | Activ::ContentPlatform::ContentGatewayApi::NewsUpdate |
m_newsStory | Activ::ContentPlatform::ContentGatewayApi::NewsUpdate |
m_subscriptionCookieList | Activ::ContentPlatform::ContentGatewayApi::NewsUpdate |
m_updateId | Activ::ContentPlatform::ContentGatewayApi::NewsUpdate |

Generated on Wed Oct 8 14:02:03 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::NewsUpdateHelper Member List

This is the complete list of members for Activ::ContentPlatform::ContentGatewayApi::NewsUpdateHelper, including all inherited members.

Deserialize(const ContentGatewayClient &client, const HeapMessage &update, NewsUpdate &newsUpdate) Activ::ContentPlatform::ContentGatewayApi::NewsUpdateHelper [static]

Generated on Wed Oct 8 14:02:03 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::OptionBar Member List

This is the complete list of members for Activ::ContentPlatform::ContentGatewayApi::OptionBar, including all inherited members.

ACTIV_DECLARE_ELEMENT_1_WITH_COMMA enum value (defined in Activ::ContentPlatform::ContentGatewayApi::FieldSet) | Activ::ContentPlatform::ContentGatewayApi::FieldSet |
Compare(const OptionBar &rhs) const | Activ::ContentPlatform::ContentGatewayApi::OptionBar |
DEFAULT_STRING_FIELD_SEPARATER (defined in Activ::ContentPlatform::ContentGatewayApi::FieldSet) | Activ::ContentPlatform::ContentGatewayApi::FieldSet | [static]
Deserialize(MessageValidator &messageValidator) | Activ::ContentPlatform::ContentGatewayApi::OptionBar | [virtual]
FieldSet() | Activ::ContentPlatform::ContentGatewayApi::FieldSet | [inline]
FieldSetListFindMode enum name (defined in Activ::ContentPlatform::ContentGatewayApi::FieldSet) | Activ::ContentPlatform::ContentGatewayApi::FieldSet |
FilterStatus enum name (defined in Activ::ContentPlatform::ContentGatewayApi::FieldSet) | Activ::ContentPlatform::ContentGatewayApi::FieldSet |
FindContentSubstring(const std::string &input, const std::string &deliminator, std::string::size_type &startPos, std::string &subStringOut) (defined in Activ::ContentPlatform::ContentGatewayApi::FieldSet) | Activ::ContentPlatform::ContentGatewayApi::FieldSet | [inline, static]
FromString(const std::string &inputStr, const std::string &deliminator=DEFAULT_STRING_FIELD_SEPARATER) | Activ::ContentPlatform::ContentGatewayApi::FieldSet | [virtual]
GetAskPrice(Rational &price) const | Activ::ContentPlatform::ContentGatewayApi::OptionBar | [inline]
GetAskPrice(double &price) const | Activ::ContentPlatform::ContentGatewayApi::OptionBar | [inline]
GetBidPrice(Rational &price) const | Activ::ContentPlatform::ContentGatewayApi::OptionBar | [inline]
GetBidPrice(double &price) const | Activ::ContentPlatform::ContentGatewayApi::OptionBar | [inline]
GetDate(Date &date) const | Activ::ContentPlatform::ContentGatewayApi::OptionBar | [inline]
GetDenominator() const | Activ::ContentPlatform::ContentGatewayApi::OptionBar | [inline]
GetExpirationDate(Date &date) const | Activ::ContentPlatform::ContentGatewayApi::OptionBar | [inline]
GetField(const Feed::FieldId fieldId, IFieldType &field) const | Activ::ContentPlatform::ContentGatewayApi::OptionBar | [virtual]
GetMaxSerializedLength() | Activ::ContentPlatform::ContentGatewayApi::OptionBar | [static]
GetOpenInterest(unsigned &openInterest) const | Activ::ContentPlatform::ContentGatewayApi::OptionBar | [inline]
GetSequence() const | Activ::ContentPlatform::ContentGatewayApi::FieldSet | [inline]
GetSerializedLength() const | Activ::ContentPlatform::ContentGatewayApi::OptionBar | [virtual]
GetStrikePrice(Rational &price) const | Activ::ContentPlatform::ContentGatewayApi::OptionBar | [inline]
GetStrikePrice(double &price) const | Activ::ContentPlatform::ContentGatewayApi::OptionBar | [inline]
GetTotalVolume(unsigned &volume) const | Activ::ContentPlatform::ContentGatewayApi::OptionBar | [inline]
GetType() const | Activ::ContentPlatform::ContentGatewayApi::OptionBar | [virtual]
GetUnderlyingPrice(Rational &price) const | Activ::ContentPlatform::ContentGatewayApi::OptionBar | [inline]
GetUnderlyingPrice(double &price) const | Activ::ContentPlatform::ContentGatewayApi::OptionBar | [inline]
operator!=(const OptionBar &rhs) const | Activ::ContentPlatform::ContentGatewayApi::OptionBar | [inline]
operator<(const OptionBar &rhs) const | Activ::ContentPlatform::ContentGatewayApi::OptionBar | [inline]
operator<=(const OptionBar &rhs) const | Activ::ContentPlatform::ContentGatewayApi::OptionBar | [inline]
operator==(const OptionBar &rhs) const | Activ::ContentPlatform::ContentGatewayApi::OptionBar | [inline]
operator>(const OptionBar &rhs) const | Activ::ContentPlatform::ContentGatewayApi::OptionBar | [inline]
operator>=(const OptionBar &rhs) const | Activ::ContentPlatform::ContentGatewayApi::OptionBar | [inline]
OptionBar() | Activ::ContentPlatform::ContentGatewayApi::OptionBar |
ProcessSplit(const int sharesBefore, const int sharesAfter, const Rational::Denominator type) | Activ::ContentPlatform::ContentGatewayApi::FieldSet | [inline]
RationalToDoubleString(const Rational &rational, char *buffer) (defined in Activ::ContentPlatform::ContentGatewayApi::FieldSet) | Activ::ContentPlatform::ContentGatewayApi::FieldSet | [static]
ReadDate(const std::string &input, const std::string &deliminator, std::string::size_type &startingPos, Date &dateOut) | Activ::ContentPlatform::ContentGatewayApi::FieldSet | [static]
ReadDateTime(const std::string &input, const std::string &deliminator, std::string::size_type &startPos, DateTime &dateTimeOut) | Activ::ContentPlatform::ContentGatewayApi::FieldSet | [static]
ReadInteger(const std::string &input, const std::string &deliminator, std::string::size_type &startPos, uint32_t &uintOut) | Activ::ContentPlatform::ContentGatewayApi::FieldSet | [inline, static]
ReadRationalFromDoubleString(const std::string &input, const std::string &deliminator, std::string::size_type &startPos, Rational &rationalOut) | Activ::ContentPlatform::ContentGatewayApi::FieldSet | [static]
ReadTime(const std::string &input, const std::string &deliminator, std::string::size_type &startingPos, Time &timeOut) | Activ::ContentPlatform::ContentGatewayApi::FieldSet | [static]
Reduce(const Rational::Denominator minDenominator=Rational::DENOMINATOR_2DP) | Activ::ContentPlatform::ContentGatewayApi::OptionBar |
Reset() | Activ::ContentPlatform::ContentGatewayApi::OptionBar | [virtual]
Serialize(MessageBuilder &messageBuilder) const | Activ::ContentPlatform::ContentGatewayApi::OptionBar | [virtual]
SetAskPrice(const Rational &price) | Activ::ContentPlatform::ContentGatewayApi::OptionBar | [inline]
SetBidPrice(const Rational &price) | Activ::ContentPlatform::ContentGatewayApi::OptionBar | [inline]
SetDate(const Date &date) | Activ::ContentPlatform::ContentGatewayApi::OptionBar | [inline]
SetDenominator(const Rational::Denominator denominator) | Activ::ContentPlatform::ContentGatewayApi::OptionBar | [inline]
SetExpirationDate(const Date &date) | Activ::ContentPlatform::ContentGatewayApi::OptionBar | [inline]
SetField(const Feed::FieldId fieldId, const IFieldType &field) | Activ::ContentPlatform::ContentGatewayApi::OptionBar | [virtual]
SetOpenInterest(const unsigned openInterest) | Activ::ContentPlatform::ContentGatewayApi::OptionBar | [inline]
SetSequence(byte_t sequence) | Activ::ContentPlatform::ContentGatewayApi::FieldSet | [inline]
SetStrikePrice(const Rational &price) | Activ::ContentPlatform::ContentGatewayApi::OptionBar | [inline]
SetTotalVolume(const unsigned volume) | Activ::ContentPlatform::ContentGatewayApi::OptionBar | [inline]
SetUnderlyingPrice(const Rational &price) | Activ::ContentPlatform::ContentGatewayApi::OptionBar | [inline]
ToString() const | Activ::ContentPlatform::ContentGatewayApi::OptionBar | [virtual]
Activ::ContentPlatform::ContentGatewayApi::FieldSet::ToString(const std::string &deliminator=DEFAULT_STRING_FIELD_SEPARATER) const | Activ::ContentPlatform::ContentGatewayApi::FieldSet | [virtual]
UpdateFieldSetStatus enum name | Activ::ContentPlatform::ContentGatewayApi::FieldSet |
~FieldSet() | Activ::ContentPlatform::ContentGatewayApi::FieldSet | [virtual]
~OptionBar() | Activ::ContentPlatform::ContentGatewayApi::OptionBar | [virtual]

Generated on Wed Oct 8 14:02:03 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::PatternMatchListRequestParameters Member List

This is the complete list of members for Activ::ContentPlatform::ContentGatewayApi::PatternMatchListRequestParameters, including all inherited members.

Clear() | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters |
DEFAULT_MAX_RESPONSE_BLOCKS | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters | [static]
FLAG_IGNORE_ALIAS (defined in Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters) | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters | [static]
FLAG_NONE (defined in Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters) | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters | [static]
Flags typedef | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters |
m_flags | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters |
m_maxResponseBlocks | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters |
m_permissionLevel | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters |
m_requestBlockList | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters |
m_requestFlags (defined in Activ::ContentPlatform::ContentGatewayApi::PatternMatchListRequestParameters) | Activ::ContentPlatform::ContentGatewayApi::PatternMatchListRequestParameters |
m_subscribeParameters | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters |
m_symbolPatternList (defined in Activ::ContentPlatform::ContentGatewayApi::PatternMatchListRequestParameters) | Activ::ContentPlatform::ContentGatewayApi::PatternMatchListRequestParameters |
m_tableNumber | Activ::ContentPlatform::ContentGatewayApi::PatternMatchListRequestParameters |
PatternMatchListRequestParameters() | Activ::ContentPlatform::ContentGatewayApi::PatternMatchListRequestParameters |
RealtimeRequestParameters() | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters |
REQUEST_FLAG_NONE (defined in Activ::ContentPlatform::ContentGatewayApi::PatternMatchListRequestParameters) | Activ::ContentPlatform::ContentGatewayApi::PatternMatchListRequestParameters | [static]
REQUEST_FLAG_REVERSE_ORDER | Activ::ContentPlatform::ContentGatewayApi::PatternMatchListRequestParameters | [static]
REQUEST_FLAG_WATCH (defined in Activ::ContentPlatform::ContentGatewayApi::PatternMatchListRequestParameters) | Activ::ContentPlatform::ContentGatewayApi::PatternMatchListRequestParameters | [static]
RequestFlags typedef | Activ::ContentPlatform::ContentGatewayApi::PatternMatchListRequestParameters |

Generated on Wed Oct 8 14:02:03 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::PatternMatchRequestParameters Member List

This is the complete list of members for Activ::ContentPlatform::ContentGatewayApi::PatternMatchRequestParameters, including all inherited members.

Clear() | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters |
DEFAULT_MAX_RESPONSE_BLOCKS | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters | [static]
FLAG_IGNORE_ALIAS (defined in Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters) | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters | [static]
FLAG_NONE (defined in Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters) | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters | [static]
Flags typedef | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters |
m_flags | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters |
m_maxResponseBlocks | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters |
m_permissionLevel | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters |
m_requestBlockList | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters |
m_requestFlags (defined in Activ::ContentPlatform::ContentGatewayApi::PatternMatchRequestParameters) | Activ::ContentPlatform::ContentGatewayApi::PatternMatchRequestParameters |
m_subscribeParameters | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters |
m_symbolPattern (defined in Activ::ContentPlatform::ContentGatewayApi::PatternMatchRequestParameters) | Activ::ContentPlatform::ContentGatewayApi::PatternMatchRequestParameters |
m_tableNumber | Activ::ContentPlatform::ContentGatewayApi::PatternMatchRequestParameters |
PatternMatchRequestParameters() | Activ::ContentPlatform::ContentGatewayApi::PatternMatchRequestParameters |
RealtimeRequestParameters() | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters |
REQUEST_FLAG_NONE (defined in Activ::ContentPlatform::ContentGatewayApi::PatternMatchRequestParameters) | Activ::ContentPlatform::ContentGatewayApi::PatternMatchRequestParameters | [static]
REQUEST_FLAG_REVERSE_ORDER | Activ::ContentPlatform::ContentGatewayApi::PatternMatchRequestParameters | [static]
REQUEST_FLAG_WATCH (defined in Activ::ContentPlatform::ContentGatewayApi::PatternMatchRequestParameters) | Activ::ContentPlatform::ContentGatewayApi::PatternMatchRequestParameters | [static]
RequestFlags typedef | Activ::ContentPlatform::ContentGatewayApi::PatternMatchRequestParameters |

Generated on Wed Oct 8 14:02:03 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::Period Member List

This is the complete list of members for Activ::ContentPlatform::ContentGatewayApi::Period, including all inherited members.

Deserialize(MessageValidator &messageValidator) | Activ::ContentPlatform::ContentGatewayApi::Period |
IsAbsolutePeriod() const | Activ::ContentPlatform::ContentGatewayApi::Period | [inline]
IsRelativeCount() const | Activ::ContentPlatform::ContentGatewayApi::Period | [inline]
IsRelativePeriod() const | Activ::ContentPlatform::ContentGatewayApi::Period | [inline]
m_count | Activ::ContentPlatform::ContentGatewayApi::Period |
m_dataPointAddress | Activ::ContentPlatform::ContentGatewayApi::Period |
m_dateTime | Activ::ContentPlatform::ContentGatewayApi::Period |
m_periodType | Activ::ContentPlatform::ContentGatewayApi::Period |
operator==(const Period &rhs) const | Activ::ContentPlatform::ContentGatewayApi::Period |
Serialize(MessageBuilder &messageBuilder) const | Activ::ContentPlatform::ContentGatewayApi::Period |

Generated on Wed Oct 8 14:02:03 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::PermissionInfo Member List

This is the complete list of members for Activ::ContentPlatform::ContentGatewayApi::PermissionInfo, including all inherited members.

m_permissionLevelInfo | Activ::ContentPlatform::Feed::PermissionInfo
m_symbolSubscriptionQuota | Activ::ContentPlatform::ContentGatewayApi::PermissionInfo
PermissionIdInfoMap typedef | Activ::ContentPlatform::Feed::PermissionInfo

Generated on Wed Oct 8 14:02:03 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestHelper< MESSAGE_TYPE_VALUE, REQUEST_PARAMETERS > Member List

This is the complete list of members for Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestHelper< MESSAGE_TYPE_VALUE, REQUEST_PARAMETERS >, including all inherited members.

Deserialize(const ContentGatewayClient &client, const HeapMessage &response, ResponseParameters &responseParameters) | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestHelper< MESSAGE_TYPE_VALUE, REQUEST_PARAMETERS > | [static]
GetResponse(const ContentGatewayClient &client, SyncRequestId &syncRequestId, ResponseParameters &responseParameters, const TimeoutPeriod timeoutPeriod=Port::defaultTimeout) | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestHelper< MESSAGE_TYPE_VALUE, REQUEST_PARAMETERS > | [static]
MESSAGE_TYPE | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestHelper< MESSAGE_TYPE_VALUE, REQUEST_PARAMETERS > | [static]
PostRequest(const ContentGatewayClient &client, const RequestId &requestId, const RequestParameters &requestParameters) | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestHelper< MESSAGE_TYPE_VALUE, REQUEST_PARAMETERS > | [static]
RequestParameters typedef | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestHelper< MESSAGE_TYPE_VALUE, REQUEST_PARAMETERS > |
ResponseParameters typedef | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestHelper< MESSAGE_TYPE_VALUE, REQUEST_PARAMETERS > |
SendRequest(const ContentGatewayClient &client, const RequestParameters &requestParameters, ResponseParameters &responseParameters, const TimeoutPeriod timeoutPeriod=Port::defaultTimeout) | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestHelper< MESSAGE_TYPE_VALUE, REQUEST_PARAMETERS > | [static]
SendRequest(const ContentGatewayClient &client, SyncRequestId &syncRequestId, const RequestParameters &requestParameters) | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestHelper< MESSAGE_TYPE_VALUE, REQUEST_PARAMETERS > | [static]

Generated on Wed Oct 8 14:02:03 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters Member List

This is the complete list of members for Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters, including all inherited members.

Clear() | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters |
DEFAULT_MAX_RESPONSE_BLOCKS | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters | [static]
FLAG_IGNORE_ALIAS (defined in Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters) | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters | [static]
FLAG_NONE (defined in Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters) | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters | [static]
Flags typedef | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters |
m_flags | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters |
m_maxResponseBlocks | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters |
m_permissionLevel | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters |
m_requestBlockList | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters |
m_subscribeParameters | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters |
RealtimeRequestParameters() | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters |

Generated on Wed Oct 8 14:02:03 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::RealtimeResponseParameters Member List

This is the complete list of members for Activ::ContentPlatform::ContentGatewayApi::RealtimeResponseParameters, including all inherited members.

Clear() | Activ::ContentPlatform::ContentGatewayApi::RealtimeResponseParameters
m_responseBlockList | Activ::ContentPlatform::ContentGatewayApi::RealtimeResponseParameters
m_subscriptionCookie | Activ::ContentPlatform::ContentGatewayApi::RealtimeResponseParameters
RealtimeResponseParameters() | Activ::ContentPlatform::ContentGatewayApi::RealtimeResponseParameters

Generated on Wed Oct 8 14:02:03 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::RecordUpdate Member List

This is the complete list of members for Activ::ContentPlatform::ContentGatewayApi::RecordUpdate, including all inherited members.

FLAG_DELETE | Activ::ContentPlatform::ContentGatewayApi::RecordUpdate | [static]
FLAG_NONE (defined in Activ::ContentPlatform::ContentGatewayApi::RecordUpdate) | Activ::ContentPlatform::ContentGatewayApi::RecordUpdate | [static]
FLAG_REFRESH | Activ::ContentPlatform::ContentGatewayApi::RecordUpdate | [static]
FLAG_RELATIONSHIP_ID | Activ::ContentPlatform::ContentGatewayApi::RecordUpdate | [static]
FLAG_REQUEST_KEY | Activ::ContentPlatform::ContentGatewayApi::RecordUpdate | [static]
FLAG_STALE | Activ::ContentPlatform::ContentGatewayApi::RecordUpdate | [static]
Flags typedef | Activ::ContentPlatform::ContentGatewayApi::RecordUpdate |
FlagsToString(const Flags flags) | Activ::ContentPlatform::ContentGatewayApi::RecordUpdate | [static]
IsDelete() const | Activ::ContentPlatform::ContentGatewayApi::RecordUpdate | [inline]
IsNewRecord() const | Activ::ContentPlatform::ContentGatewayApi::RecordUpdate | [inline]
m_eventType | Activ::ContentPlatform::ContentGatewayApi::RecordUpdate |
m_fieldData | Activ::ContentPlatform::ContentGatewayApi::RecordUpdate |
m_flags | Activ::ContentPlatform::ContentGatewayApi::RecordUpdate |
m_permissionId | Activ::ContentPlatform::ContentGatewayApi::RecordUpdate |
m_permissionLevel | Activ::ContentPlatform::ContentGatewayApi::RecordUpdate |
m_permissionLevelData | Activ::ContentPlatform::ContentGatewayApi::RecordUpdate |
m_relationshipId | Activ::ContentPlatform::ContentGatewayApi::RecordUpdate |
m_requestKey | Activ::ContentPlatform::ContentGatewayApi::RecordUpdate |
m_symbolId | Activ::ContentPlatform::ContentGatewayApi::RecordUpdate |
m_updateId | Activ::ContentPlatform::ContentGatewayApi::RecordUpdate |

Generated on Wed Oct 8 14:02:03 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::RecordUpdateHelper Member List

This is the complete list of members for Activ::ContentPlatform::ContentGatewayApi::RecordUpdateHelper, including all inherited members.

Deserialize(const ContentGatewayClient &client, const HeapMessage &update, RecordUpdate &recordUpdate) | Activ::ContentPlatform::ContentGatewayApi::RecordUpdateHelper | [static]
Deserialize(const ContentGatewayClient &client, const HeapMessage &update, RecordUpdate &recordUpdate, FieldListValidator &fieldListValidator) | Activ::ContentPlatform::ContentGatewayApi::RecordUpdateHelper | [static]

Generated on Wed Oct 8 14:02:03 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::RelationshipInfo Member List

This is the complete list of members for Activ::ContentPlatform::ContentGatewayApi::RelationshipInfo, including all inherited members.

m_codeIdentifier | Activ::ContentPlatform::ContentGatewayApi::RelationshipInfo
m_context | Activ::ContentPlatform::ContentGatewayApi::RelationshipInfo
m_name | Activ::ContentPlatform::ContentGatewayApi::RelationshipInfo
m_relationshipId | Activ::ContentPlatform::ContentGatewayApi::RelationshipInfo

Generated on Wed Oct 8 14:02:03 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::RequestBlock Member List

This is the complete list of members for Activ::ContentPlatform::ContentGatewayApi::RequestBlock, including all inherited members.

Clear() | Activ::ContentPlatform::ContentGatewayApi::RequestBlock |
Deserialize(MessageValidator &messageValidator) | Activ::ContentPlatform::ContentGatewayApi::RequestBlock |
FLAG_ALL_FIELDS (defined in Activ::ContentPlatform::ContentGatewayApi::RequestBlock) | Activ::ContentPlatform::ContentGatewayApi::RequestBlock | [static]
FLAG_NONE (defined in Activ::ContentPlatform::ContentGatewayApi::RequestBlock) | Activ::ContentPlatform::ContentGatewayApi::RequestBlock | [static]
Flags typedef | Activ::ContentPlatform::ContentGatewayApi::RequestBlock |
m_fieldIdList | Activ::ContentPlatform::ContentGatewayApi::RequestBlock |
m_flags | Activ::ContentPlatform::ContentGatewayApi::RequestBlock |
m_relationshipId | Activ::ContentPlatform::ContentGatewayApi::RequestBlock |
RequestBlock() | Activ::ContentPlatform::ContentGatewayApi::RequestBlock |
Serialize(MessageBuilder &messageBuilder) const | Activ::ContentPlatform::ContentGatewayApi::RequestBlock |

Generated on Wed Oct 8 14:02:03 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::ResponseBlock Member List

This is the complete list of members for Activ::ContentPlatform::ContentGatewayApi::ResponseBlock, including all inherited members.

FLAG_NONE | Activ::ContentPlatform::ContentGatewayApi::ResponseBlock | [static]
FLAG_STALE | Activ::ContentPlatform::ContentGatewayApi::ResponseBlock | [static]
Flags typedef | Activ::ContentPlatform::ContentGatewayApi::ResponseBlock |
FlagsToString(const Flags flags) | Activ::ContentPlatform::ContentGatewayApi::ResponseBlock | [static]
IsResponseKeyDefined() const | Activ::ContentPlatform::ContentGatewayApi::ResponseBlock | [inline]
IsValidResponse() const | Activ::ContentPlatform::ContentGatewayApi::ResponseBlock | [inline]
m_fieldData | Activ::ContentPlatform::ContentGatewayApi::ResponseBlock |
m_flags | Activ::ContentPlatform::ContentGatewayApi::ResponseBlock |
m_permissionId | Activ::ContentPlatform::ContentGatewayApi::ResponseBlock |
m_permissionLevel | Activ::ContentPlatform::ContentGatewayApi::ResponseBlock |
m_permissionLevelData | Activ::ContentPlatform::ContentGatewayApi::ResponseBlock |
m_relationshipId | Activ::ContentPlatform::ContentGatewayApi::ResponseBlock |
m_resolvedKey | Activ::ContentPlatform::ContentGatewayApi::ResponseBlock |
m_responseKey | Activ::ContentPlatform::ContentGatewayApi::ResponseBlock |
m_status | Activ::ContentPlatform::ContentGatewayApi::ResponseBlock |
Status typedef | Activ::ContentPlatform::ContentGatewayApi::ResponseBlock |
STATUS_INTERNAL_ERROR (defined in Activ::ContentPlatform::ContentGatewayApi::ResponseBlock) | Activ::ContentPlatform::ContentGatewayApi::ResponseBlock | [static]
STATUS_INVALID_SOURCE_TABLE (defined in Activ::ContentPlatform::ContentGatewayApi::ResponseBlock) | Activ::ContentPlatform::ContentGatewayApi::ResponseBlock | [static]
STATUS_NAVIGATION_NOT_FOUND (defined in Activ::ContentPlatform::ContentGatewayApi::ResponseBlock) | Activ::ContentPlatform::ContentGatewayApi::ResponseBlock | [static]
STATUS_NAVIGATION_NOT_PERMISSIONED (defined in Activ::ContentPlatform::ContentGatewayApi::ResponseBlock) | Activ::ContentPlatform::ContentGatewayApi::ResponseBlock | [static]
STATUS_PERMISSION_LEVEL_NOT_AVAILABLE (defined in Activ::ContentPlatform::ContentGatewayApi::ResponseBlock) | Activ::ContentPlatform::ContentGatewayApi::ResponseBlock | [static]
STATUS_RELATIONSHIP_NOT_FOUND (defined in Activ::ContentPlatform::ContentGatewayApi::ResponseBlock) | Activ::ContentPlatform::ContentGatewayApi::ResponseBlock | [static]
STATUS_RELATIONSHIP_NOT_PERMISSIONED (defined in Activ::ContentPlatform::ContentGatewayApi::ResponseBlock) | Activ::ContentPlatform::ContentGatewayApi::ResponseBlock | [static]
STATUS_SOURCE_NOT_FOUND (defined in Activ::ContentPlatform::ContentGatewayApi::ResponseBlock) | Activ::ContentPlatform::ContentGatewayApi::ResponseBlock | [static]
STATUS_SOURCE_NOT_PERMISSIONED (defined in Activ::ContentPlatform::ContentGatewayApi::ResponseBlock) | Activ::ContentPlatform::ContentGatewayApi::ResponseBlock | [static]
STATUS_SUCCESS | Activ::ContentPlatform::ContentGatewayApi::ResponseBlock | [static]
STATUS_TARGET_NOT_FOUND (defined in Activ::ContentPlatform::ContentGatewayApi::ResponseBlock) | Activ::ContentPlatform::ContentGatewayApi::ResponseBlock | [static]
STATUS_TARGET_NOT_PERMISSIONED (defined in Activ::ContentPlatform::ContentGatewayApi::ResponseBlock) | Activ::ContentPlatform::ContentGatewayApi::ResponseBlock | [static]
StatusToString(const Status status) | Activ::ContentPlatform::ContentGatewayApi::ResponseBlock | [static]

Generated on Wed Oct 8 14:02:03 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::SubscribeFeedParameters Member List

This is the complete list of members for Activ::ContentPlatform::ContentGatewayApi::SubscribeFeedParameters, including all inherited members.

ACTIV_DECLARE_VALUE_WITH_COMMA enum value | Activ::ContentPlatform::ContentGatewayApi::SubscribeParameters
EventTypeList typedef | Activ::ContentPlatform::ContentGatewayApi::SubscribeParameters
m_eventTypeList | Activ::ContentPlatform::ContentGatewayApi::SubscribeParameters
m_permissionLevel | Activ::ContentPlatform::ContentGatewayApi::SubscribeFeedParameters
m_type | Activ::ContentPlatform::ContentGatewayApi::SubscribeParameters
SubscribeFeedParameters() | Activ::ContentPlatform::ContentGatewayApi::SubscribeFeedParameters
SubscribeParameters() | Activ::ContentPlatform::ContentGatewayApi::SubscribeParameters
Type enum name | Activ::ContentPlatform::ContentGatewayApi::SubscribeParameters

Generated on Wed Oct 8 14:02:03 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::SubscribeParameters Member List

This is the complete list of members for Activ::ContentPlatform::ContentGatewayApi::SubscribeParameters, including all inherited members.

ACTIV_DECLARE_VALUE_WITH_COMMA enum value | Activ::ContentPlatform::ContentGatewayApi::SubscribeParameters
EventTypeList typedef | Activ::ContentPlatform::ContentGatewayApi::SubscribeParameters
m_eventTypeList | Activ::ContentPlatform::ContentGatewayApi::SubscribeParameters
m_type | Activ::ContentPlatform::ContentGatewayApi::SubscribeParameters
SubscribeParameters() | Activ::ContentPlatform::ContentGatewayApi::SubscribeParameters
Type enum name | Activ::ContentPlatform::ContentGatewayApi::SubscribeParameters

Generated on Wed Oct 8 14:02:03 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::SubscribeTableParameters Member List

This is the complete list of members for Activ::ContentPlatform::ContentGatewayApi::SubscribeTableParameters, including all inherited members.

ACTIV_DECLARE_VALUE_WITH_COMMA enum value | Activ::ContentPlatform::ContentGatewayApi::SubscribeParameters
EventTypeList typedef | Activ::ContentPlatform::ContentGatewayApi::SubscribeParameters
m_eventTypeList | Activ::ContentPlatform::ContentGatewayApi::SubscribeParameters
m_permissionLevel | Activ::ContentPlatform::ContentGatewayApi::SubscribeTableParameters
m_tableNumberList | Activ::ContentPlatform::ContentGatewayApi::SubscribeTableParameters
m_type | Activ::ContentPlatform::ContentGatewayApi::SubscribeParameters
m_updateRequestId | Activ::ContentPlatform::ContentGatewayApi::SubscribeTableParameters
SubscribeParameters() | Activ::ContentPlatform::ContentGatewayApi::SubscribeParameters
SubscribeTableParameters() | Activ::ContentPlatform::ContentGatewayApi::SubscribeTableParameters
Type enum name | Activ::ContentPlatform::ContentGatewayApi::SubscribeParameters

Generated on Wed Oct 8 14:02:03 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::SubscriptionInfo Member List

This is the complete list of members for Activ::ContentPlatform::ContentGatewayApi::SubscriptionInfo, including all inherited members.

m_feedSubscriptionCount | Activ::ContentPlatform::ContentGatewayApi::SubscriptionInfo
m_newsSubscriptionMap | Activ::ContentPlatform::ContentGatewayApi::SubscriptionInfo
m_symbolSubscriptionMap | Activ::ContentPlatform::ContentGatewayApi::SubscriptionInfo
m_tableSubscriptionMap | Activ::ContentPlatform::ContentGatewayApi::SubscriptionInfo
NewsSubscriptionMap typedef (defined in Activ::ContentPlatform::ContentGatewayApi::SubscriptionInfo) | Activ::ContentPlatform::ContentGatewayApi::SubscriptionInfo
SymbolSubscriptionMap typedef (defined in Activ::ContentPlatform::ContentGatewayApi::SubscriptionInfo) | Activ::ContentPlatform::ContentGatewayApi::SubscriptionInfo
TableSubscriptionMap typedef (defined in Activ::ContentPlatform::ContentGatewayApi::SubscriptionInfo) | Activ::ContentPlatform::ContentGatewayApi::SubscriptionInfo

Generated on Wed Oct 8 14:02:03 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryRequestHelper Member List

This is the complete list of members for Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryRequestHelper, including all inherited members.

Deserialize(const ContentGatewayClient &client, const HeapMessage &response, ResponseParameters &responseParameters) | Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryRequestHelper | [static]
GetResponse(const ContentGatewayClient &client, SyncRequestId &syncRequestId, ResponseParameters &responseParameters, const TimeoutPeriod timeoutPeriod) | Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryRequestHelper | [static]
PostRequest(const ContentGatewayClient &client, const RequestId &requestId, const RequestParameters &requestParameters) | Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryRequestHelper | [static]
RequestParameters typedef (defined in Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryRequestHelper) | Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryRequestHelper |
ResponseParameters typedef (defined in Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryRequestHelper) | Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryRequestHelper |
SendRequest(const ContentGatewayClient &client, const RequestParameters &requestParameters, ResponseParameters &responseParameters, const TimeoutPeriod timeoutPeriod=Port::defaultTimeout) | Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryRequestHelper | [static]
SendRequest(const ContentGatewayClient &client, SyncRequestId &syncRequestId, const RequestParameters &requestParameters) | Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryRequestHelper | [static]

Generated on Wed Oct 8 14:02:03 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryRequestParameters Member List

This is the complete list of members for Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryRequestParameters, including all inherited members.

ACTIV_DECLARE_VALUE_WITH_COMMA enum value | Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryRequestParameters
Deserialize(MessageValidator &messageValidator) | Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryRequestParameters
EntityTypeList typedef (defined in Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryRequestParameters) | Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryRequestParameters
FilterType enum name | Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryRequestParameters
m_entityTypeList | Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryRequestParameters
m_fieldId | Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryRequestParameters
m_filterType | Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryRequestParameters
m_matchType | Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryRequestParameters
m_searchString | Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryRequestParameters
MatchType enum name | Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryRequestParameters
Serialize(MessageBuilder &messageBuilder) const | Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryRequestParameters
SymbolDirectoryRequestParameters() | Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryRequestParameters

Generated on Wed Oct 8 14:02:03 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryResponseParameters Member List

This is the complete list of members for Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryResponseParameters, including all inherited members.

Clear() | Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryResponseParameters
Deserialize(MessageValidator &messageValidator) | Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryResponseParameters
m_fieldId | Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryResponseParameters
m_symbolResponseList | Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryResponseParameters
Serialize(MessageBuilder &messageBuilder) const | Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryResponseParameters
SymbolResponseList typedef (defined in Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryResponseParameters) | Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryResponseParameters

Generated on Wed Oct 8 14:02:04 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::SymbolId Member List

This is the complete list of members for Activ::ContentPlatform::ContentGatewayApi::SymbolId, including all inherited members.

m_symbol | Activ::ContentPlatform::ContentGatewayApi::SymbolId |
m_tableNumber | Activ::ContentPlatform::ContentGatewayApi::SymbolId |
operator!=(const SymbolId &rhs) const | Activ::ContentPlatform::ContentGatewayApi::SymbolId | [inline]
operator<(const SymbolId &rhs) const | Activ::ContentPlatform::ContentGatewayApi::SymbolId | [inline]
operator==(const SymbolId &rhs) const | Activ::ContentPlatform::ContentGatewayApi::SymbolId | [inline]
Symbol typedef | Activ::ContentPlatform::ContentGatewayApi::SymbolId |
SymbolId() | Activ::ContentPlatform::ContentGatewayApi::SymbolId | [inline]
SymbolId(const Symbol &symbol) | Activ::ContentPlatform::ContentGatewayApi::SymbolId | [inline]
SymbolId(const Feed::TableNo tableNumber, const Symbol &symbol) | Activ::ContentPlatform::ContentGatewayApi::SymbolId | [inline]

Generated on Wed Oct 8 14:02:04 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::SymbolIdCountRequestParameters Member List

This is the complete list of members for Activ::ContentPlatform::ContentGatewayApi::SymbolIdCountRequestParameters, including all inherited members.

Clear() | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters |
DEFAULT_MAX_RESPONSE_BLOCKS | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters | [static]
FLAG_IGNORE_ALIAS (defined in Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters) | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters | [static]
FLAG_NONE (defined in Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters) | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters | [static]
Flags typedef | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters |
m_flags | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters |
m_maxResponseBlocks | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters |
m_numberOfRecords | Activ::ContentPlatform::ContentGatewayApi::SymbolIdCountRequestParameters |
m_permissionLevel | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters |
m_requestBlockList | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters |
m_subscribeParameters | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters |
m_symbolId | Activ::ContentPlatform::ContentGatewayApi::SymbolIdCountRequestParameters |
RealtimeRequestParameters() | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters |
SymbolIdCountRequestParameters() | Activ::ContentPlatform::ContentGatewayApi::SymbolIdCountRequestParameters |

Generated on Wed Oct 8 14:02:04 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::SymbolIdListMatchRequestParameters Member List

This is the complete list of members for Activ::ContentPlatform::ContentGatewayApi::SymbolIdListMatchRequestParameters, including all inherited members.

ACTIV_DECLARE_VALUE_WITH_COMMA enum value | Activ::ContentPlatform::ContentGatewayApi::MatchRequestParameters |
Clear() | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters |
DEFAULT_MAX_RESPONSE_BLOCKS | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters | [static]
FLAG_IGNORE_ALIAS (defined in Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters) | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters | [static]
FLAG_NONE (defined in Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters) | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters | [static]
Flags typedef | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters |
m_flags | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters |
m_matchType | Activ::ContentPlatform::ContentGatewayApi::MatchRequestParameters |
m_maxResponseBlocks | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters |
m_permissionLevel | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters |
m_requestBlockList | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters |
m_subscribeParameters | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters |
m_symbolIdList | Activ::ContentPlatform::ContentGatewayApi::SymbolIdListMatchRequestParameters |
MatchType enum name | Activ::ContentPlatform::ContentGatewayApi::MatchRequestParameters |
RealtimeRequestParameters() | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters |

Generated on Wed Oct 8 14:02:04 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::SymbolIdListRequestParameters Member List

This is the complete list of members for Activ::ContentPlatform::ContentGatewayApi::SymbolIdListRequestParameters, including all inherited members.

Clear() | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters |
DEFAULT_MAX_RESPONSE_BLOCKS | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters | [static]
FLAG_IGNORE_ALIAS (defined in Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters) | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters | [static]
FLAG_NONE (defined in Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters) | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters | [static]
Flags typedef | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters |
m_flags | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters |
m_maxResponseBlocks | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters |
m_permissionLevel | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters |
m_requestBlockList | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters |
m_subscribeParameters | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters |
m_symbolIdList (defined in Activ::ContentPlatform::ContentGatewayApi::SymbolIdListRequestParameters) | Activ::ContentPlatform::ContentGatewayApi::SymbolIdListRequestParameters |
RealtimeRequestParameters() | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters |

Generated on Wed Oct 8 14:02:04 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::SymbolIdMatchRequestParameters Member List

This is the complete list of members for Activ::ContentPlatform::ContentGatewayApi::SymbolIdMatchRequestParameters, including all inherited members.

ACTIV_DECLARE_VALUE_WITH_COMMA enum value | Activ::ContentPlatform::ContentGatewayApi::MatchRequestParameters |
Clear() | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters |
DEFAULT_MAX_RESPONSE_BLOCKS | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters | [static]
FLAG_IGNORE_ALIAS (defined in Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters) | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters | [static]
FLAG_NONE (defined in Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters) | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters | [static]
Flags typedef | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters |
m_flags | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters |
m_matchType | Activ::ContentPlatform::ContentGatewayApi::MatchRequestParameters |
m_maxResponseBlocks | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters |
m_permissionLevel | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters |
m_requestBlockList | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters |
m_subscribeParameters | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters |
m_symbolId | Activ::ContentPlatform::ContentGatewayApi::SymbolIdMatchRequestParameters |
MatchType enum name | Activ::ContentPlatform::ContentGatewayApi::MatchRequestParameters |
RealtimeRequestParameters() | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters |

Generated on Wed Oct 8 14:02:04 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::SymbolIdRequestParameters Member List

This is the complete list of members for Activ::ContentPlatform::ContentGatewayApi::SymbolIdRequestParameters, including all inherited members.

Clear() | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters |
DEFAULT_MAX_RESPONSE_BLOCKS | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters | [static]
FLAG_IGNORE_ALIAS (defined in Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters) | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters | [static]
FLAG_NONE (defined in Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters) | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters | [static]
Flags typedef | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters |
m_flags | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters |
m_maxResponseBlocks | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters |
m_permissionLevel | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters |
m_requestBlockList | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters |
m_subscribeParameters | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters |
m_symbolId (defined in Activ::ContentPlatform::ContentGatewayApi::SymbolIdRequestParameters) | Activ::ContentPlatform::ContentGatewayApi::SymbolIdRequestParameters |
RealtimeRequestParameters() | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters |

Generated on Wed Oct 8 14:02:04 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::SymbolResponse Member List

This is the complete list of members for Activ::ContentPlatform::ContentGatewayApi::SymbolResponse, including all inherited members.

FLAG_NONE (defined in Activ::ContentPlatform::ContentGatewayApi::SymbolResponse) | Activ::ContentPlatform::ContentGatewayApi::SymbolResponse | [static]
FLAG_SAME_AS_LAST (defined in Activ::ContentPlatform::ContentGatewayApi::SymbolResponse) | Activ::ContentPlatform::ContentGatewayApi::SymbolResponse | [static]
Flags typedef | Activ::ContentPlatform::ContentGatewayApi::SymbolResponse |
m_entityType | Activ::ContentPlatform::ContentGatewayApi::SymbolResponse |
m_flags | Activ::ContentPlatform::ContentGatewayApi::SymbolResponse |
m_matchData | Activ::ContentPlatform::ContentGatewayApi::SymbolResponse |
m_symbolId | Activ::ContentPlatform::ContentGatewayApi::SymbolResponse |
SameAsLastCheck(const SymbolResponse &symbolResponse) const | Activ::ContentPlatform::ContentGatewayApi::SymbolResponse | [inline]

Generated on Wed Oct 8 14:02:04 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::TableInfo Member List

This is the complete list of members for Activ::ContentPlatform::ContentGatewayApi::TableInfo, including all inherited members.

m_tableCodeIdentifier | Activ::ContentPlatform::ContentGatewayApi::TableInfo
m_tableName | Activ::ContentPlatform::ContentGatewayApi::TableInfo
m_tableNumber | Activ::ContentPlatform::ContentGatewayApi::TableInfo
m_tableType (defined in Activ::ContentPlatform::ContentGatewayApi::TableInfo) | Activ::ContentPlatform::ContentGatewayApi::TableInfo

Generated on Wed Oct 8 14:02:04 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::TableNumberRequestParameters Member List

This is the complete list of members for Activ::ContentPlatform::ContentGatewayApi::TableNumberRequestParameters, including all inherited members.

Clear() | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters |
DEFAULT_MAX_RESPONSE_BLOCKS | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters | [static]
FLAG_IGNORE_ALIAS (defined in Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters) | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters | [static]
FLAG_NONE (defined in Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters) | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters | [static]
Flags typedef | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters |
m_flags | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters |
m_maxResponseBlocks | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters |
m_numberOfRecords | Activ::ContentPlatform::ContentGatewayApi::TableNumberRequestParameters |
m_permissionLevel | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters |
m_requestBlockList | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters |
m_subscribeParameters | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters |
m_tableNumber | Activ::ContentPlatform::ContentGatewayApi::TableNumberRequestParameters |
RealtimeRequestParameters() | Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters |
TableNumberRequestParameters() | Activ::ContentPlatform::ContentGatewayApi::TableNumberRequestParameters |

Generated on Wed Oct 8 14:02:04 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::Tick Member List

This is the complete list of members for Activ::ContentPlatform::ContentGatewayApi::Tick, including all inherited members.

ACTIV_DECLARE_ELEMENT_1_WITH_COMMA enum value (defined in Activ::ContentPlatform::ContentGatewayApi::FieldSet) | Activ::ContentPlatform::ContentGatewayApi::FieldSet |
Compare(const Tick &rhs) const | Activ::ContentPlatform::ContentGatewayApi::Tick | [inline, virtual]
Compare(const DateTime &dateTime, int &result) const | Activ::ContentPlatform::ContentGatewayApi::Tick | [inline, virtual]
Compare(const Tick &rhs, int &result) const | Activ::ContentPlatform::ContentGatewayApi::Tick | [inline, virtual]
CompareContentOnly(const Tick &rhs) const | Activ::ContentPlatform::ContentGatewayApi::Tick | [inline, virtual]
CONDITION_LENGTH (defined in Activ::ContentPlatform::ContentGatewayApi::Tick) | Activ::ContentPlatform::ContentGatewayApi::Tick | [static]
DEFAULT_STRING_FIELD_SEPARATER (defined in Activ::ContentPlatform::ContentGatewayApi::FieldSet) | Activ::ContentPlatform::ContentGatewayApi::FieldSet | [static]
Deserialize(MessageValidator &messageValidator) | Activ::ContentPlatform::ContentGatewayApi::Tick | [virtual]
FieldSet() | Activ::ContentPlatform::ContentGatewayApi::FieldSet | [inline]
FieldSetListFindMode enum name (defined in Activ::ContentPlatform::ContentGatewayApi::FieldSet) | Activ::ContentPlatform::ContentGatewayApi::FieldSet |
FilterStatus enum name (defined in Activ::ContentPlatform::ContentGatewayApi::FieldSet) | Activ::ContentPlatform::ContentGatewayApi::FieldSet |
FindContentSubstring(const std::string &input, const std::string &deliminator, std::string::size_type &startPos, std::string &subStringOut) (defined in Activ::ContentPlatform::ContentGatewayApi::FieldSet) | Activ::ContentPlatform::ContentGatewayApi::FieldSet | [inline, static]
FromString(const std::string &inputStr, const std::string &deliminator=DEFAULT_STRING_FIELD_SEPARATER) | Activ::ContentPlatform::ContentGatewayApi::Tick | [virtual]
GetBuyerId(char *pBuyerId, const size_t idMaxLength, size_t &actualSize) const | Activ::ContentPlatform::ContentGatewayApi::Tick |
GetConditions(byte_t *pConditions, const size_t conditionsLength, size_t &conditionsSize) const | Activ::ContentPlatform::ContentGatewayApi::Tick | [inline]
GetDateTime(DateTime &dateTime) const | Activ::ContentPlatform::ContentGatewayApi::Tick | [inline]
GetExchange(std::string &exchange) const | Activ::ContentPlatform::ContentGatewayApi::Tick | [inline]
GetExchange() const | Activ::ContentPlatform::ContentGatewayApi::Tick | [inline]
GetField(const Feed::FieldId fieldId, IFieldType &field) const | Activ::ContentPlatform::ContentGatewayApi::Tick | [virtual]
GetMaxSerializedLength() | Activ::ContentPlatform::ContentGatewayApi::Tick | [static]
GetPrice(double &price) const | Activ::ContentPlatform::ContentGatewayApi::Tick | [inline]
GetPrice(Rational &price) const | Activ::ContentPlatform::ContentGatewayApi::Tick | [inline]
GetSellerId(char *pSellerId, const size_t idMaxLength, size_t &actualSize) const | Activ::ContentPlatform::ContentGatewayApi::Tick |
GetSequence() const | Activ::ContentPlatform::ContentGatewayApi::FieldSet | [inline]
GetSerializedLength() const | Activ::ContentPlatform::ContentGatewayApi::Tick | [inline, virtual]
GetSize(Rational &size) const | Activ::ContentPlatform::ContentGatewayApi::Tick | [inline]
GetSize(uint32_t &size) const | Activ::ContentPlatform::ContentGatewayApi::Tick | [inline]
GetTickType() const | Activ::ContentPlatform::ContentGatewayApi::Tick | [inline]
GetTradeThroughExemptFlag() const | Activ::ContentPlatform::ContentGatewayApi::Tick |
GetType() const | Activ::ContentPlatform::ContentGatewayApi::Tick | [virtual]
GetUpdateId(Feed::UpdateId &updateId) const | Activ::ContentPlatform::ContentGatewayApi::Tick | [inline]
GetUpdateId() const | Activ::ContentPlatform::ContentGatewayApi::Tick | [inline]
IsOutOfSequence() const | Activ::ContentPlatform::ContentGatewayApi::Tick | [inline]
IsRegularHourTrade() const | Activ::ContentPlatform::ContentGatewayApi::Tick | [inline]
IsTrade() const | Activ::ContentPlatform::ContentGatewayApi::Tick | [inline]
m_buyerId | Activ::ContentPlatform::ContentGatewayApi::Tick | [protected]
m_conditions | Activ::ContentPlatform::ContentGatewayApi::Tick | [protected]
m_dateTime | Activ::ContentPlatform::ContentGatewayApi::Tick | [protected]
m_exchange | Activ::ContentPlatform::ContentGatewayApi::Tick | [protected]
m_outSequence | Activ::ContentPlatform::ContentGatewayApi::Tick | [protected]
m_price | Activ::ContentPlatform::ContentGatewayApi::Tick | [protected]
m_sellerId | Activ::ContentPlatform::ContentGatewayApi::Tick | [protected]
m_size | Activ::ContentPlatform::ContentGatewayApi::Tick | [protected]
m_tickType | Activ::ContentPlatform::ContentGatewayApi::Tick | [protected]
m_tradeThroughExemptFlag | Activ::ContentPlatform::ContentGatewayApi::Tick | [protected]
m_updateId | Activ::ContentPlatform::ContentGatewayApi::Tick | [protected]
operator!=(const Tick &rhs) const | Activ::ContentPlatform::ContentGatewayApi::Tick | [inline]
operator<(const Tick &rhs) const | Activ::ContentPlatform::ContentGatewayApi::Tick | [inline]
operator<(const DateTime &dateTime) const | Activ::ContentPlatform::ContentGatewayApi::Tick | [inline]
operator<=(const Tick &rhs) const | Activ::ContentPlatform::ContentGatewayApi::Tick | [inline, virtual]
operator<=(const DateTime &dateTime) const (defined in Activ::ContentPlatform::ContentGatewayApi::Tick) | Activ::ContentPlatform::ContentGatewayApi::Tick | [inline]
operator==(const Tick &rhs) const | Activ::ContentPlatform::ContentGatewayApi::Tick | [inline]
operator==(const DateTime &dateTime) const | Activ::ContentPlatform::ContentGatewayApi::Tick | [inline]
operator>(const Tick &rhs) const | Activ::ContentPlatform::ContentGatewayApi::Tick | [inline]
operator>(const DateTime &dateTime) const (defined in Activ::ContentPlatform::ContentGatewayApi::Tick) | Activ::ContentPlatform::ContentGatewayApi::Tick | [inline]
operator>=(const Tick &rhs) const | Activ::ContentPlatform::ContentGatewayApi::Tick | [inline]
operator>=(const DateTime &dateTime) const | Activ::ContentPlatform::ContentGatewayApi::Tick | [inline]
OPTIONAL_DATA_HAS_BUYER_ID | Activ::ContentPlatform::ContentGatewayApi::Tick | [static]
OPTIONAL_DATA_HAS_OTHER_LENGTH | Activ::ContentPlatform::ContentGatewayApi::Tick | [static]
OPTIONAL_DATA_HAS_SELLER_ID | Activ::ContentPlatform::ContentGatewayApi::Tick | [static]
OPTIONAL_DATA_HAS_TRADE_EXEPTION_FLAG | Activ::ContentPlatform::ContentGatewayApi::Tick | [static]
ProcessSplit(const int sharesBefore, const int sharesAfter, const Rational::Denominator type) | Activ::ContentPlatform::ContentGatewayApi::Tick |
QUOTE_NO_CONDITION | Activ::ContentPlatform::ContentGatewayApi::Tick | [static]
QUOTE_SAME_CONDITION | Activ::ContentPlatform::ContentGatewayApi::Tick | [static]
QUOTE_SAME_EXCHANGE_BIT | Activ::ContentPlatform::ContentGatewayApi::Tick | [static]
RationalToDoubleString(const Rational &rational, char *buffer) (defined in Activ::ContentPlatform::ContentGatewayApi::FieldSet) | Activ::ContentPlatform::ContentGatewayApi::FieldSet | [static]
ReadDate(const std::string &input, const std::string &deliminator, std::string::size_type &startingPos, Date &dateOut) | Activ::ContentPlatform::ContentGatewayApi::FieldSet | [static]
ReadDateTime(const std::string &input, const std::string &deliminator, std::string::size_type &startPos, DateTime &dateTimeOut) | Activ::ContentPlatform::ContentGatewayApi::FieldSet | [static]
ReadInteger(const std::string &input, const std::string &deliminator, std::string::size_type &startPos, uint32_t &uintOut) | Activ::ContentPlatform::ContentGatewayApi::FieldSet | [inline, static]
ReadRationalFromDoubleString(const std::string &input, const std::string &deliminator, std::string::size_type &startPos, Rational &rationalOut) | Activ::ContentPlatform::ContentGatewayApi::FieldSet | [static]
ReadTime(const std::string &input, const std::string &deliminator, std::string::size_type &startingPos, Time &timeOut) | Activ::ContentPlatform::ContentGatewayApi::FieldSet | [static]
Reset() | Activ::ContentPlatform::ContentGatewayApi::Tick | [virtual]
Serialize(MessageBuilder &messageBuilder) const | Activ::ContentPlatform::ContentGatewayApi::Tick | [virtual]
SetBuyerId(const char *pBuyerId, const size_t idLength) | Activ::ContentPlatform::ContentGatewayApi::Tick |
SetBuyerId(const IFieldType &field) | Activ::ContentPlatform::ContentGatewayApi::Tick |
SetConditions(const byte_t *pConditions, const size_t conditionsLength) | Activ::ContentPlatform::ContentGatewayApi::Tick | [inline]
SetConditions(const IFieldType &field) | Activ::ContentPlatform::ContentGatewayApi::Tick | [inline]
SetDate(const Date &date) | Activ::ContentPlatform::ContentGatewayApi::Tick | [inline]
SetDateTime(const DateTime &dateTime) | Activ::ContentPlatform::ContentGatewayApi::Tick | [inline]
SetDateTime(const Date &date, const Time &time) | Activ::ContentPlatform::ContentGatewayApi::Tick | [inline]
SetExchange(const std::string &exchange) | Activ::ContentPlatform::ContentGatewayApi::Tick | [inline]
SetField(const Feed::FieldId fieldId, const IFieldType &field) | Activ::ContentPlatform::ContentGatewayApi::Tick | [virtual]
SetOutOfSequence() | Activ::ContentPlatform::ContentGatewayApi::Tick | [inline]
SetPrice(const Rational &price) | Activ::ContentPlatform::ContentGatewayApi::Tick | [inline]
SetPrice(const IFieldType &field) | Activ::ContentPlatform::ContentGatewayApi::Tick | [inline]
SetSellerId(const char *pSellerId, const size_t idLength) | Activ::ContentPlatform::ContentGatewayApi::Tick |
SetSellerId(const IFieldType &field) | Activ::ContentPlatform::ContentGatewayApi::Tick |
SetSequence(byte_t sequence) | Activ::ContentPlatform::ContentGatewayApi::FieldSet | [inline]
SetSize(const Rational &size) | Activ::ContentPlatform::ContentGatewayApi::Tick | [inline]
SetSize(const IFieldType &field) | Activ::ContentPlatform::ContentGatewayApi::Tick | [inline]
SetSize(const uint32_t size) | Activ::ContentPlatform::ContentGatewayApi::Tick | [inline]
SetTickType(const TickType type) | Activ::ContentPlatform::ContentGatewayApi::Tick | [inline]
SetTime(const Time &time) | Activ::ContentPlatform::ContentGatewayApi::Tick | [inline]
SetTradeThroughExemptFlag(const char flag) | Activ::ContentPlatform::ContentGatewayApi::Tick |
SetUpdateId(const Feed::UpdateId updateId) | Activ::ContentPlatform::ContentGatewayApi::Tick | [inline]
Tick() | Activ::ContentPlatform::ContentGatewayApi::Tick |
TICK_CONDITION_LENGTH_MASK | Activ::ContentPlatform::ContentGatewayApi::Tick | [static]
TICK_DAY_MASK | Activ::ContentPlatform::ContentGatewayApi::Tick | [static]
TICK_KNOWN_EXCHANGE_BIT | Activ::ContentPlatform::ContentGatewayApi::Tick | [static]
TICK_OPTIONAL_DATA_BIT | Activ::ContentPlatform::ContentGatewayApi::Tick | [static]
TICK_OUT_SEQUENCE_MASK | Activ::ContentPlatform::ContentGatewayApi::Tick | [static]
TICK_SIZE_BYTE1 | Activ::ContentPlatform::ContentGatewayApi::Tick | [static]
TICK_SIZE_BYTE2 | Activ::ContentPlatform::ContentGatewayApi::Tick | [static]
TICK_TYPE_MASK | Activ::ContentPlatform::ContentGatewayApi::Tick | [static]
TimeSeries::TickBlockHelper (defined in Activ::ContentPlatform::ContentGatewayApi::Tick) | Activ::ContentPlatform::ContentGatewayApi::Tick | [friend]
ToShortString(const std::string &deliminator=DEFAULT_STRING_FIELD_SEPARATER) const | Activ::ContentPlatform::ContentGatewayApi::Tick | [virtual]
ToString(const std::string &deliminator=DEFAULT_STRING_FIELD_SEPARATER) const | Activ::ContentPlatform::ContentGatewayApi::Tick | [virtual]
TRADER_ID_LENGTH (defined in Activ::ContentPlatform::ContentGatewayApi::Tick) | Activ::ContentPlatform::ContentGatewayApi::Tick | [static]
UpdateFieldSetStatus enum name | Activ::ContentPlatform::ContentGatewayApi::FieldSet |
~FieldSet() | Activ::ContentPlatform::ContentGatewayApi::FieldSet | [virtual]
~Tick() | Activ::ContentPlatform::ContentGatewayApi::Tick | [virtual]

Generated on Wed Oct 8 14:02:04 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::TimeSeriesCookie Member List

This is the complete list of members for Activ::ContentPlatform::ContentGatewayApi::TimeSeriesCookie, including all inherited members.

Deserialize(MessageValidator &messageValidator) | Activ::ContentPlatform::ContentGatewayApi::TimeSeriesCookie
GetDataPointAddress() const | Activ::ContentPlatform::ContentGatewayApi::TimeSeriesCookie
GetSymbolId() const | Activ::ContentPlatform::ContentGatewayApi::TimeSeriesCookie
m_dataPointAddress (defined in Activ::ContentPlatform::ContentGatewayApi::TimeSeriesCookie) | Activ::ContentPlatform::ContentGatewayApi::TimeSeriesCookie
m_requestParameters (defined in Activ::ContentPlatform::ContentGatewayApi::TimeSeriesCookie) | Activ::ContentPlatform::ContentGatewayApi::TimeSeriesCookie
Serialize(MessageBuilder &messageBuilder) const | Activ::ContentPlatform::ContentGatewayApi::TimeSeriesCookie

Generated on Wed Oct 8 14:02:04 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestHelper< FIRST_MESSAGE_TYPE_VALUE, NEXT_MESSAGE_TYPE_VALUE, FIELD_SET_TYPE > Member List

This is the complete list of members for Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestHelper< FIRST_MESSAGE_TYPE_VALUE, NEXT_MESSAGE_TYPE_VALUE, FIELD_SET_TYPE >, including all inherited members.

Deserialize(const ContentGatewayClient &client, const HeapMessage &response, TimeSeriesCookie &cookie, ResponseParameters &responseParameters) | Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestHelper< FIRST_MESSAGE_TYPE_VALUE, NEXT_MESSAGE_TYPE_VALUE, FIELD_SET_TYPE > | [static]
PostGetFirstRequest(const ContentGatewayClient &client, const RequestId &requestId, const RequestParameters &requestParameters) | Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestHelper< FIRST_MESSAGE_TYPE_VALUE, NEXT_MESSAGE_TYPE_VALUE, FIELD_SET_TYPE > | [static]
PostGetNextRequest(const ContentGatewayClient &client, const RequestId &requestId, const TimeSeriesCookie &cookie) | Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestHelper< FIRST_MESSAGE_TYPE_VALUE, NEXT_MESSAGE_TYPE_VALUE, FIELD_SET_TYPE > | [static]
RequestParameters typedef (defined in Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestHelper< FIRST_MESSAGE_TYPE_VALUE, NEXT_MESSAGE_TYPE_VALUE, FIELD_SET_TYPE >) | Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestHelper< FIRST_MESSAGE_TYPE_VALUE, NEXT_MESSAGE_TYPE_VALUE, FIELD_SET_TYPE > |
ResponseParameters typedef (defined in Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestHelper< FIRST_MESSAGE_TYPE_VALUE, NEXT_MESSAGE_TYPE_VALUE, FIELD_SET_TYPE >) | Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestHelper< FIRST_MESSAGE_TYPE_VALUE, NEXT_MESSAGE_TYPE_VALUE, FIELD_SET_TYPE > |
SendGetFirstRequest(const ContentGatewayClient &client, const RequestParameters &requestParameters, TimeSeriesCookie &cookie, ResponseParameters &responseParameters, const TimeoutPeriod timeoutPeriod=Port::defaultTimeout) | Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestHelper< FIRST_MESSAGE_TYPE_VALUE, NEXT_MESSAGE_TYPE_VALUE, FIELD_SET_TYPE > | [static]
SendGetNextRequest(const ContentGatewayClient &client, TimeSeriesCookie &cookie, ResponseParameters &responseParameters, const TimeoutPeriod timeoutPeriod=Port::defaultTimeout) | Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestHelper< FIRST_MESSAGE_TYPE_VALUE, NEXT_MESSAGE_TYPE_VALUE, FIELD_SET_TYPE > | [static]

Generated on Wed Oct 8 14:02:04 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestParameters Member List

This is the complete list of members for Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestParameters, including all inherited members.

Clear() | Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestParameters |
DEFAULT_MAX_FIELD_SETS | Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestParameters | [static]
Deserialize(MessageValidator &messageValidator) | Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestParameters |
FLAG_IGNORE_ALIAS | Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestParameters | [static]
FLAG_NONE (defined in Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestParameters) | Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestParameters | [static]
FLAG_REVERSE (defined in Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestParameters) | Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestParameters | [static]
Flags typedef | Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestParameters |
m_delayPeriod | Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestParameters |
m_fieldFilterType | Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestParameters |
m_flags | Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestParameters |
m_maxFieldSets | Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestParameters |
m_periodList | Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestParameters |
m_recordFilterType | Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestParameters |
m_seriesType | Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestParameters |
m_specifiedInterval | Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestParameters |
m_symbolId | Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestParameters |
Serialize(MessageBuilder &messageBuilder) const | Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestParameters |
TimeSeriesRequestParameters() | Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestParameters |

Generated on Wed Oct 8 14:02:04 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentGatewayApi::TimeSeriesResponseParametersTemplate< FIELD_SET_TYPE > Member List

This is the complete list of members for Activ::ContentPlatform::ContentGatewayApi::TimeSeriesResponseParametersTemplate< FIELD_SET_TYPE >, including all inherited members.

Clear() | Activ::ContentPlatform::ContentGatewayApi::TimeSeriesResponseParametersTemplate< FIELD_SET_TYPE >
Deserialize(MessageValidator &messageValidator) | Activ::ContentPlatform::ContentGatewayApi::TimeSeriesResponseParametersTemplate< FIELD_SET_TYPE >
FieldSetList typedef | Activ::ContentPlatform::ContentGatewayApi::TimeSeriesResponseParametersTemplate< FIELD_SET_TYPE >
m_fieldSetList (defined in Activ::ContentPlatform::ContentGatewayApi::TimeSeriesResponseParametersTemplate< FIELD_SET_TYPE >) | Activ::ContentPlatform::ContentGatewayApi::TimeSeriesResponseParametersTemplate< FIELD_SET_TYPE >
Serialize(MessageBuilder &messageBuilder) const | Activ::ContentPlatform::ContentGatewayApi::TimeSeriesResponseParametersTemplate< FIELD_SET_TYPE >

Generated on Wed Oct 8 14:02:04 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentServerApi::ContentServerClient Member List

This is the complete list of members for Activ::ContentPlatform::ContentServerApi::ContentServerClient, including all inherited members.

AddUpdateFilter(const UpdateFilter &updateFilter, SubscriptionCookie &subscriptionCookie, const std::string &providerName="") | Activ::ContentPlatform::ContentServerApi::ContentServerClient |
anonymousName | Activ::Port | [static]
Component(Application &application, ManagedEndPoint &managedEndPoint, const std::string &name=anonymousName, IHeap *const pHeap=0, const std::string &componentId=defaultComponentId) | Activ::Component |
ContentServerClient(Application &application, ManagedEndPoint &managedEndPoint, const Settings &settings, const std::string &componentLicenseId=defaultComponentId) | Activ::ContentPlatform::ContentServerApi::ContentServerClient |
ContentServerOutput (defined in Activ::ContentPlatform::ContentServerApi::ContentServerClient) | Activ::ContentPlatform::ContentServerApi::ContentServerClient | [friend]
defaultComponentId | Activ::Component | [static]
defaultTimeout | Activ::Port | [static]
Disable() | Activ::Port |
Enable() | Activ::Port |
FieldListValidator (defined in Activ::ContentPlatform::ContentServerApi::ContentServerClient) | Activ::ContentPlatform::ContentServerApi::ContentServerClient | [friend]
FindPort(const std::string &endPointName, const std::string &portName, Address &portAddress, const TimeoutPeriod timeout=defaultTimeout) | Activ::Port |
ForwardMessage(const Address &destinationAddress, HeapMessage &message, const MessageType newType=INVALID_MESSAGE_TYPE) const | Activ::Port |
GetAddress() const | Activ::Port | [inline]
GetApiInfo() const | Activ::ContentPlatform::ContentServerApi::ContentServerClient |
GetApplication() const | Activ::Component |
GetHeap() const | Activ::Port | [inline]
GetManagedEndPoint() const | Activ::Port |
GetMessageStatsList() const | Activ::ContentPlatform::ContentServerApi::ContentServerClient |
GetName() const | Activ::Port |
GetPermissionInfo() const | Activ::ContentPlatform::ContentServerApi::ContentServerClient |
GetTotalMessageStats() const | Activ::ContentPlatform::ContentServerApi::ContentServerClient |
GetUpdateFilterMapList() const | Activ::ContentPlatform::ContentServerApi::ContentServerClient |
IsUserLoggedOn() const | Activ::ContentPlatform::ContentServerApi::ContentServerClient |
Logoff() | Activ::ContentPlatform::ContentServerApi::ContentServerClient |
Logon(const std::string &userId, const std::string &password) | Activ::ContentPlatform::ContentServerApi::ContentServerClient |
ManagedEndPoint::Impl (defined in Activ::Port) | Activ::Port | [friend]
MessageStatsList typedef (defined in Activ::ContentPlatform::ContentServerApi::ContentServerClient) | Activ::ContentPlatform::ContentServerApi::ContentServerClient |
OnAccept(HeapMessage &acceptMessage) | Activ::Component | [protected, virtual]
OnBreak(HeapMessage &breakMessage) | Activ::Component | [protected, virtual]
OnConnect(HeapMessage &connectMessage) | Activ::Component | [protected, virtual]
OnConnectFailed(HeapMessage &connectFailMessage) | Activ::Component | [protected, virtual]
OnData(HeapMessage &heapMessage) | Activ::Component | [protected, virtual]
OnDisconnect(HeapMessage &disconnectMessage) | Activ::Component | [protected, virtual]
OnFlush(const std::string &providerName) | Activ::ContentPlatform::ContentServerApi::ContentServerClient | [virtual]
OnMessage(HeapMessage &message) | Activ::Component | [protected, virtual]
OnRecordUpdate(const std::string &providerName, RecordUpdate &recordUpdate) | Activ::ContentPlatform::ContentServerApi::ContentServerClient | [virtual]
OnRequest(HeapMessage &request) | Activ::Component | [protected, virtual]
OnResponse(HeapMessage &response) | Activ::Port | [protected, virtual]
OnSymbolRecordUpdate(const std::string &providerName, SymbolRecordUpdate &symbolRecordUpdate) | Activ::ContentPlatform::ContentServerApi::ContentServerClient | [virtual]
OnTimer(const Address &timerAddress, const BaseTime &time) | Activ::ContentPlatform::ContentServerApi::ContentServerClient | [protected, virtual]
Port(ManagedEndPoint &managedEndPoint, const std::string &name, IHeap *const pHeap) | Activ::Port |
Port(ManagedEndPoint &managedEndPoint, const std::string &name, const PortId portId, IHeap *const pHeap) | Activ::Port |
PostEmptyResponse(const StatusCode responseStatus, HeapMessage &response) const | Activ::Port |
PostEmptyResponse(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, const StatusCode responseStatus, HeapMessage &response) const | Activ::Port |
PostMessage(const Address &destinationAddress, const MessageType messageType, const MessageBuilder &messageBuilder) const | Activ::Port |
PostMessage(const Address &destinationAddress, const MessageType messageType, const void *pMessage=0, const size_t messageLength=0) const | Activ::Port |
PostMessage(const Address &destinationAddress, const MessageType messageType, HeapMessage &message) const | Activ::Port |
PostRequest(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, const MessageBuilder &messageBuilder) const | Activ::Port |
PostRequest(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, const void *pRequest=0, const size_t requestLength=0) const | Activ::Port |
PostRequest(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, HeapMessage &request) const | Activ::Port |
PostResponse(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, const StatusCode responseStatus, const MessageBuilder &messageBuilder) const | Activ::Port |
PostResponse(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, const StatusCode responseStatus, const void *pResponse=0, const size_t responseLength=0) const | Activ::Port |
PostResponse(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, const StatusCode responseStatus, HeapMessage &response) const | Activ::Port |
PostResponse(const StatusCode responseStatus, HeapMessage &request, const MessageBuilder &messageBuilder) const | Activ::Port |
PostResponse(const StatusCode responseStatus, HeapMessage &request, const void *pResponse, const size_t responseLength) const | Activ::Port |
PostResponse(const StatusCode responseStatus, HeapMessage &request, HeapMessage &response) const | Activ::Port |
PostResponse(const StatusCode responseStatus, HeapMessage &request) const | Activ::Port |
RemoveUpdateFilter(const SubscriptionCookie subscriptionCookie) | Activ::ContentPlatform::ContentServerApi::ContentServerClient |
SendRequest(const Address &destinationAddress, const MessageType requestType, const MessageBuilder &messageBuilder, HeapMessage &response, const TimeoutPeriod timeout=defaultTimeout) const | Activ::Port |
SendRequest(const Address &destinationAddress, const MessageType requestType, const void *pRequest, const size_t requestLength, HeapMessage &response, const TimeoutPeriod timeout=defaultTimeout) const | Activ::Port |
SendRequest(const Address &destinationAddress, const MessageType requestType, HeapMessage &request, const TimeoutPeriod timeout=defaultTimeout) const | Activ::Port |
SendRequest(const Address &destinationAddress, const MessageType requestType, SyncRequestId &syncRequestId, const MessageBuilder &messageBuilder) const | Activ::Port |
SendRequest(const Address &destinationAddress, const MessageType requestType, SyncRequestId &syncRequestId, const void *pRequest, const size_t requestLength) const | Activ::Port |
SendRequest(const Address &destinationAddress, const MessageType requestType, SyncRequestId &syncRequestId, HeapMessage &request) const | Activ::Port |
SetHeap(IHeap *const pHeap) | Activ::Port |
UpdateFilterMapList typedef (defined in Activ::ContentPlatform::ContentServerApi::ContentServerClient) | Activ::ContentPlatform::ContentServerApi::ContentServerClient |
~Component() | Activ::Component |
~ContentServerClient() | Activ::ContentPlatform::ContentServerApi::ContentServerClient | [virtual]
~Port() | Activ::Port | [virtual]

Generated on Wed Oct 8 14:02:04 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentServerApi::ContentServerClient::ApiInfo Member List

This is the complete list of members for Activ::ContentPlatform::ContentServerApi::ContentServerClient::ApiInfo, including all inherited members.

m_buildConfiguration | Activ::ContentPlatform::ContentServerApi::ContentServerClient::ApiInfo
m_buildDateTime | Activ::ContentPlatform::ContentServerApi::ContentServerClient::ApiInfo
m_version | Activ::ContentPlatform::ContentServerApi::ContentServerClient::ApiInfo

Generated on Wed Oct 8 14:02:04 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentServerApi::ContentServerClient::MessageStats Member List

This is the complete list of members for Activ::ContentPlatform::ContentServerApi::ContentServerClient::MessageStats, including all inherited members.

m_name | Activ::ContentPlatform::ContentServerApi::ContentServerClient::MessageStats
m_receivedUpdateCount | Activ::ContentPlatform::ContentServerApi::ContentServerClient::MessageStats
m_totalErrorCount | Activ::ContentPlatform::ContentServerApi::ContentServerClient::MessageStats
m_totalIgnoredCount | Activ::ContentPlatform::ContentServerApi::ContentServerClient::MessageStats
m_totalProcessedCount | Activ::ContentPlatform::ContentServerApi::ContentServerClient::MessageStats
m_unrecognizedUpdateCount | Activ::ContentPlatform::ContentServerApi::ContentServerClient::MessageStats
MessageStats() | Activ::ContentPlatform::ContentServerApi::ContentServerClient::MessageStats

Generated on Wed Oct 8 14:02:04 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentServerApi::ContentServerClient::Settings Member List

This is the complete list of members for Activ::ContentPlatform::ContentServerApi::ContentServerClient::Settings, including all inherited members.

m_pPrivateSettings (defined in Activ::ContentPlatform::ContentServerApi::ContentServerClient::Settings) | Activ::ContentPlatform::ContentServerApi::ContentServerClient::Settings
m_resetTime | Activ::ContentPlatform::ContentServerApi::ContentServerClient::Settings
m_tableTemplateServiceId | Activ::ContentPlatform::ContentServerApi::ContentServerClient::Settings
Read(const IniFileParser::ConstSectionIterator &sectionIterator) | Activ::ContentPlatform::ContentServerApi::ContentServerClient::Settings
Settings() | Activ::ContentPlatform::ContentServerApi::ContentServerClient::Settings
~Settings() | Activ::ContentPlatform::ContentServerApi::ContentServerClient::Settings

Generated on Wed Oct 8 14:02:04 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentServerApi::ContentServerClient::UpdateFilter Member List

This is the complete list of members for Activ::ContentPlatform::ContentServerApi::ContentServerClient::UpdateFilter, including all inherited members.

EventTypeList typedef | Activ::ContentPlatform::ContentServerApi::ContentServerClient::UpdateFilter
m_eventTypeList | Activ::ContentPlatform::ContentServerApi::ContentServerClient::UpdateFilter
m_symbolPatternList | Activ::ContentPlatform::ContentServerApi::ContentServerClient::UpdateFilter
m_tableNumberList | Activ::ContentPlatform::ContentServerApi::ContentServerClient::UpdateFilter
SymbolPatternList typedef | Activ::ContentPlatform::ContentServerApi::ContentServerClient::UpdateFilter
TableNumberList typedef | Activ::ContentPlatform::ContentServerApi::ContentServerClient::UpdateFilter

Generated on Wed Oct 8 14:02:04 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentServerApi::ContentServerClient::UpdateFilterMap Member List

This is the complete list of members for Activ::ContentPlatform::ContentServerApi::ContentServerClient::UpdateFilterMap, including all inherited members.

m_name | Activ::ContentPlatform::ContentServerApi::ContentServerClient::UpdateFilterMap
m_updateFilterMap | Activ::ContentPlatform::ContentServerApi::ContentServerClient::UpdateFilterMap

Generated on Wed Oct 8 14:02:04 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentServerApi::FieldListValidator Member List

This is the complete list of members for Activ::ContentPlatform::ContentServerApi::FieldListValidator, including all inherited members.

ApplyUpdate(SymbolRecordUpdate &symbolRecordUpdate) | Activ::ContentPlatform::ContentServerApi::FieldListValidator |
ApplyUpdate(RecordUpdate &recordUpdate) | Activ::ContentPlatform::ContentServerApi::FieldListValidator |
ApplyUpdate(Feed::BaseUpdateMessageValidator &baseUpdateMessageValidator) | Activ::ContentPlatform::ContentServerApi::FieldListValidator |
Activ::ContentPlatform::FeedApi::FieldListValidator::ApplyUpdate(const FieldListValidator &fieldListValidator) | Activ::ContentPlatform::FeedApi::FieldListValidator |
ApplyUpdateToExistingFieldsOnly(const FieldListValidator &fieldListValidator) | Activ::ContentPlatform::FeedApi::FieldListValidator |
Begin() const | Activ::ContentPlatform::FeedApi::FieldListValidator |
Clear() | Activ::ContentPlatform::FeedApi::FieldListValidator |
ContentGateway::FieldListValidator (defined in Activ::ContentPlatform::FeedApi::FieldListValidator) | Activ::ContentPlatform::FeedApi::FieldListValidator | [friend]
ContentGatewayApi::FieldListValidator (defined in Activ::ContentPlatform::FeedApi::FieldListValidator) | Activ::ContentPlatform::FeedApi::FieldListValidator | [friend]
ContentServerApi::FieldListValidator (defined in Activ::ContentPlatform::FeedApi::FieldListValidator) | Activ::ContentPlatform::FeedApi::FieldListValidator | [friend]
End() const | Activ::ContentPlatform::FeedApi::FieldListValidator |
FieldListValidator(ContentServerClient &contentServerClient) | Activ::ContentPlatform::ContentServerApi::FieldListValidator |
FieldListValidator(const FieldListValidator &rhs) | Activ::ContentPlatform::ContentServerApi::FieldListValidator |
FieldListValidator(ContentServerClient &contentServerClient, SymbolRecordUpdate &symbolRecordUpdate) | Activ::ContentPlatform::ContentServerApi::FieldListValidator |
FieldListValidator(ContentServerClient &contentServerClient, RecordUpdate &recordUpdate) | Activ::ContentPlatform::ContentServerApi::FieldListValidator |
Activ::ContentPlatform::FeedApi::FieldListValidator::FieldListValidator() | Activ::ContentPlatform::FeedApi::FieldListValidator |
Activ::ContentPlatform::FeedApi::FieldListValidator::FieldListValidator(const FieldListValidator &rhs) | Activ::ContentPlatform::FeedApi::FieldListValidator |
GetActivFieldType(const Feed::FieldId fieldId, const T *&pFieldType) const | Activ::ContentPlatform::FeedApi::FieldListValidator | [inline]
GetActivFieldType(const Feed::FieldId fieldId) const | Activ::ContentPlatform::FeedApi::FieldListValidator | [inline]
GetField(const Feed::FieldId fieldId, const Field *&pField) const | Activ::ContentPlatform::FeedApi::FieldListValidator | [inline]
GetNumberOfFields() const | Activ::ContentPlatform::FeedApi::FieldListValidator | [inline]
Initialize(SymbolRecordUpdate &symbolRecordUpdate) | Activ::ContentPlatform::ContentServerApi::FieldListValidator |
Initialize(RecordUpdate &recordUpdate) | Activ::ContentPlatform::ContentServerApi::FieldListValidator |
IsFieldPresent(const Feed::FieldId fieldId) const | Activ::ContentPlatform::FeedApi::FieldListValidator | [inline]
IsInitialized() const | Activ::ContentPlatform::FeedApi::FieldListValidator | [inline]
IsPartialSubset(const FieldListValidator &rhs) const | Activ::ContentPlatform::FeedApi::FieldListValidator | [inline]
IsSubset(const FieldListValidator &rhs) const | Activ::ContentPlatform::FeedApi::FieldListValidator | [inline]
operator=(const FieldListValidator &rhs) | Activ::ContentPlatform::FeedApi::FieldListValidator |
Reset() | Activ::ContentPlatform::FeedApi::FieldListValidator |
~FieldListValidator() | Activ::ContentPlatform::FeedApi::FieldListValidator |

Generated on Wed Oct 8 14:02:04 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentServerApi::RecordUpdate Member List

This is the complete list of members for Activ::ContentPlatform::ContentServerApi::RecordUpdate, including all inherited members.

BeginKeyField() const | Activ::ContentPlatform::ContentServerApi::RecordUpdate |
ConstKeyFieldIterator typedef | Activ::ContentPlatform::ContentServerApi::RecordUpdate |
EndKeyField() const | Activ::ContentPlatform::ContentServerApi::RecordUpdate |
FieldListValidator (defined in Activ::ContentPlatform::ContentServerApi::RecordUpdateHelper< Feed::UpdateMessageValidator >) | Activ::ContentPlatform::ContentServerApi::RecordUpdateHelper< Feed::UpdateMessageValidator > | [friend]
GetEventType() const | Activ::ContentPlatform::ContentServerApi::RecordUpdateHelper< Feed::UpdateMessageValidator > |
GetIndexNumber() const | Activ::ContentPlatform::ContentServerApi::RecordUpdate |
GetNumberOfKeyFields() const | Activ::ContentPlatform::ContentServerApi::RecordUpdate |
GetPermissionId() const | Activ::ContentPlatform::ContentServerApi::RecordUpdateHelper< Feed::UpdateMessageValidator > |
GetTableNumber() const | Activ::ContentPlatform::ContentServerApi::RecordUpdateHelper< Feed::UpdateMessageValidator > |
GetUpdateId() const | Activ::ContentPlatform::ContentServerApi::RecordUpdateHelper< Feed::UpdateMessageValidator > |
IsDelete() const | Activ::ContentPlatform::ContentServerApi::RecordUpdateHelper< Feed::UpdateMessageValidator > |
IsNewRecord() const | Activ::ContentPlatform::ContentServerApi::RecordUpdateHelper< Feed::UpdateMessageValidator > |
IsRefresh() const | Activ::ContentPlatform::ContentServerApi::RecordUpdateHelper< Feed::UpdateMessageValidator > |
IsStale() const | Activ::ContentPlatform::ContentServerApi::RecordUpdateHelper< Feed::UpdateMessageValidator > |
KeyField typedef | Activ::ContentPlatform::ContentServerApi::RecordUpdate |
KeyFieldList typedef | Activ::ContentPlatform::ContentServerApi::RecordUpdate |
m_messageValidator (defined in Activ::ContentPlatform::ContentServerApi::RecordUpdateHelper< Feed::UpdateMessageValidator >) | Activ::ContentPlatform::ContentServerApi::RecordUpdateHelper< Feed::UpdateMessageValidator > | [protected]
RecordUpdate(Feed::UpdateMessageValidator &updateMessageValidator) | Activ::ContentPlatform::ContentServerApi::RecordUpdate |
RecordUpdateHelper(Feed::UpdateMessageValidator &messageValidator) | Activ::ContentPlatform::ContentServerApi::RecordUpdateHelper< Feed::UpdateMessageValidator > |

Generated on Wed Oct 8 14:02:04 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentServerApi::RecordUpdateHelper< MESSAGE_VALIDATOR > Member List

This is the complete list of members for Activ::ContentPlatform::ContentServerApi::RecordUpdateHelper< MESSAGE_VALIDATOR >, including all inherited members.

FieldListValidator (defined in Activ::ContentPlatform::ContentServerApi::RecordUpdateHelper< MESSAGE_VALIDATOR >) | Activ::ContentPlatform::ContentServerApi::RecordUpdateHelper< MESSAGE_VALIDATOR > | [friend]
GetEventType() const | Activ::ContentPlatform::ContentServerApi::RecordUpdateHelper< MESSAGE_VALIDATOR > |
GetPermissionId() const | Activ::ContentPlatform::ContentServerApi::RecordUpdateHelper< MESSAGE_VALIDATOR > |
GetTableNumber() const | Activ::ContentPlatform::ContentServerApi::RecordUpdateHelper< MESSAGE_VALIDATOR > |
GetUpdateId() const | Activ::ContentPlatform::ContentServerApi::RecordUpdateHelper< MESSAGE_VALIDATOR > |
IsDelete() const | Activ::ContentPlatform::ContentServerApi::RecordUpdateHelper< MESSAGE_VALIDATOR > |
IsNewRecord() const | Activ::ContentPlatform::ContentServerApi::RecordUpdateHelper< MESSAGE_VALIDATOR > |
IsRefresh() const | Activ::ContentPlatform::ContentServerApi::RecordUpdateHelper< MESSAGE_VALIDATOR > |
IsStale() const | Activ::ContentPlatform::ContentServerApi::RecordUpdateHelper< MESSAGE_VALIDATOR > |
m_messageValidator (defined in Activ::ContentPlatform::ContentServerApi::RecordUpdateHelper< MESSAGE_VALIDATOR >) | Activ::ContentPlatform::ContentServerApi::RecordUpdateHelper< MESSAGE_VALIDATOR > | [protected]
RecordUpdateHelper(MESSAGE_VALIDATOR &messageValidator) | Activ::ContentPlatform::ContentServerApi::RecordUpdateHelper< MESSAGE_VALIDATOR > |

Generated on Wed Oct 8 14:02:04 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContentServerApi::SymbolRecordUpdate Member List

This is the complete list of members for Activ::ContentPlatform::ContentServerApi::SymbolRecordUpdate, including all inherited members.

FieldListValidator (defined in Activ::ContentPlatform::ContentServerApi::RecordUpdateHelper< Feed::BaseUpdateMessageValidator >) | Activ::ContentPlatform::ContentServerApi::RecordUpdateHelper< Feed::BaseUpdateMessageValidator > | [friend]
GetEventType() const | Activ::ContentPlatform::ContentServerApi::RecordUpdateHelper< Feed::BaseUpdateMessageValidator > |
GetPermissionId() const | Activ::ContentPlatform::ContentServerApi::RecordUpdateHelper< Feed::BaseUpdateMessageValidator > |
GetSymbol() const | Activ::ContentPlatform::ContentServerApi::SymbolRecordUpdate |
GetTableNumber() const | Activ::ContentPlatform::ContentServerApi::RecordUpdateHelper< Feed::BaseUpdateMessageValidator > |
GetUpdateId() const | Activ::ContentPlatform::ContentServerApi::RecordUpdateHelper< Feed::BaseUpdateMessageValidator > |
IsDelete() const | Activ::ContentPlatform::ContentServerApi::RecordUpdateHelper< Feed::BaseUpdateMessageValidator > |
IsNewRecord() const | Activ::ContentPlatform::ContentServerApi::RecordUpdateHelper< Feed::BaseUpdateMessageValidator > |
IsRefresh() const | Activ::ContentPlatform::ContentServerApi::RecordUpdateHelper< Feed::BaseUpdateMessageValidator > |
IsStale() const | Activ::ContentPlatform::ContentServerApi::RecordUpdateHelper< Feed::BaseUpdateMessageValidator > |
m_messageValidator (defined in Activ::ContentPlatform::ContentServerApi::RecordUpdateHelper< Feed::BaseUpdateMessageValidator >) | Activ::ContentPlatform::ContentServerApi::RecordUpdateHelper< Feed::BaseUpdateMessageValidator > | [protected]
RecordUpdateHelper(Feed::BaseUpdateMessageValidator &messageValidator) | Activ::ContentPlatform::ContentServerApi::RecordUpdateHelper< Feed::BaseUpdateMessageValidator > |
SymbolRecordUpdate(Feed::BaseUpdateMessageValidator &baseUpdateMessageValidator, const std::string &symbol) | Activ::ContentPlatform::ContentServerApi::SymbolRecordUpdate |

Generated on Wed Oct 8 14:02:04 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient Member List

This is the complete list of members for Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient, including all inherited members.

ACTIV_DECLARE_ELEMENT_1_WITH_COMMA enum value (defined in Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient) | Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient |
anonymousName | Activ::Port | [static]
Component(Application &application, ManagedEndPoint &managedEndPoint, const std::string &name=anonymousName, IHeap *const pHeap=0, const std::string &componentId=defaultComponentId) | Activ::Component |
Connect(const ConnectParameters &connectParameters, const TimeoutPeriod timeoutPeriod=Port::defaultTimeout) | Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient |
ContributionGatewayClient(Application &application, ManagedEndPoint &managedEndPoint, const Settings &settings=Settings(), const std::string &componentId=defaultComponentId) | Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient |
defaultComponentId | Activ::Component | [static]
defaultTimeout | Activ::Port | [static]
Disable() | Activ::Port |
Disconnect() | Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient |
Enable() | Activ::Port |
FindPort(const std::string &endPointName, const std::string &portName, Address &portAddress, const TimeoutPeriod timeout=defaultTimeout) | Activ::Port |
ForwardMessage(const Address &destinationAddress, HeapMessage &message, const MessageType newType=INVALID_MESSAGE_TYPE) const | Activ::Port |
GetAddress() const | Activ::Port | [inline]
GetApiInfo() const | Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient |
GetApplication() const | Activ::Component |
GetContributionGatewayInfo(ContributionGatewayInfo &contributionGatewayInfo) const | Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient |
GetHeap() const | Activ::Port | [inline]
GetManagedEndPoint() const | Activ::Port |
GetName() const | Activ::Port |
GetPermissionInfo(PermissionInfo &permissionInfo) const | Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient |
GetServiceLocation() const | Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient |
GetState() const | Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient |
IsValidResponse(const HeapMessage &response) | Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient | [inline, static]
ManagedEndPoint::Impl (defined in Activ::Port) | Activ::Port | [friend]
OnAccept(HeapMessage &acceptMessage) | Activ::Component | [protected, virtual]
OnBreak(HeapMessage &breakMessage) | Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient | [protected, virtual]
OnConnect(HeapMessage &connectMessage) | Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient | [protected, virtual]
OnConnectFailed(HeapMessage &connectFailMessage) | Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient | [protected, virtual]
OnData(HeapMessage &heapMessage) | Activ::Component | [protected, virtual]
OnDisconnect(HeapMessage &disconnectMessage) | Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient | [protected, virtual]
OnMessage(HeapMessage &message) | Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient | [protected, virtual]
OnPublishRecordResponse(HeapMessage &update) (defined in Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient) | Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient | [protected, virtual]
OnPublishSymbolRecordResponse(HeapMessage &update) (defined in Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient) | Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient | [protected, virtual]
OnReportMessage(const std::string &reportMessage) | Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient | [protected, virtual]
OnRequest(HeapMessage &request) | Activ::Component | [protected, virtual]
OnResponse(HeapMessage &response) | Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient | [protected, virtual]
OnTimer(const Address &timerAddress, const BaseTime &time) | Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient | [protected, virtual]
Port(ManagedEndPoint &managedEndPoint, const std::string &name, IHeap *const pHeap) | Activ::Port |
Port(ManagedEndPoint &managedEndPoint, const std::string &name, const PortId portId, IHeap *const pHeap) | Activ::Port |
PostEmptyResponse(const StatusCode responseStatus, HeapMessage &response) const | Activ::Port |
PostEmptyResponse(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, const StatusCode responseStatus, HeapMessage &response) const | Activ::Port |
PostMessage(const Address &destinationAddress, const MessageType messageType, const MessageBuilder &messageBuilder) const | Activ::Port |
PostMessage(const Address &destinationAddress, const MessageType messageType, const void *pMessage=0, const size_t messageLength=0) const | Activ::Port |
PostMessage(const Address &destinationAddress, const MessageType messageType, HeapMessage &message) const | Activ::Port |
PostRequest(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, const MessageBuilder &messageBuilder) const | Activ::Port |
PostRequest(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, const void *pRequest=0, const size_t requestLength=0) const | Activ::Port |
PostRequest(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, HeapMessage &request) const | Activ::Port |
PostResponse(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, const StatusCode responseStatus, const MessageBuilder &messageBuilder) const | Activ::Port |
PostResponse(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, const StatusCode responseStatus, const void *pResponse=0, const size_t responseLength=0) const | Activ::Port |
PostResponse(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, const StatusCode responseStatus, HeapMessage &response) const | Activ::Port |
PostResponse(const StatusCode responseStatus, HeapMessage &request, const MessageBuilder &messageBuilder) const | Activ::Port |
PostResponse(const StatusCode responseStatus, HeapMessage &request, const void *pResponse, const size_t responseLength) const | Activ::Port |
PostResponse(const StatusCode responseStatus, HeapMessage &request, HeapMessage &response) const | Activ::Port |
PostResponse(const StatusCode responseStatus, HeapMessage &request) const | Activ::Port |
PublishRecord typedef (defined in Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient) | Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient |
PublishSymbolRecord typedef (defined in Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient) | Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient |
SendRequest(const Address &destinationAddress, const MessageType requestType, const MessageBuilder &messageBuilder, HeapMessage &response, const TimeoutPeriod timeout=defaultTimeout) const | Activ::Port |
SendRequest(const Address &destinationAddress, const MessageType requestType, const void *pRequest, const size_t requestLength, HeapMessage &response, const TimeoutPeriod timeout=defaultTimeout) const | Activ::Port |
SendRequest(const Address &destinationAddress, const MessageType requestType, HeapMessage &request, const TimeoutPeriod timeout=defaultTimeout) const | Activ::Port |
SendRequest(const Address &destinationAddress, const MessageType requestType, SyncRequestId &syncRequestId, const MessageBuilder &messageBuilder) const | Activ::Port |
SendRequest(const Address &destinationAddress, const MessageType requestType, SyncRequestId &syncRequestId, const void *pRequest, const size_t requestLength) const | Activ::Port |
SendRequest(const Address &destinationAddress, const MessageType requestType, SyncRequestId &syncRequestId, HeapMessage &request) const | Activ::Port |
SetHeap(IHeap *const pHeap) | Activ::Port |
State enum name | Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient |
StateToString(const State state) | Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient | [static]
~Component() | Activ::Component |
~ContributionGatewayClient() | Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient | [virtual]
~Port() | Activ::Port | [virtual]

Generated on Wed Oct 8 14:02:04 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::ApiInfo Member List

This is the complete list of members for Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::ApiInfo, including all inherited members.

m_buildConfiguration | Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::ApiInfo
m_buildDateTime | Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::ApiInfo
m_version | Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::ApiInfo

Generated on Wed Oct 8 14:02:04 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::ConnectParameters Member List

This is the complete list of members for Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::ConnectParameters, including all inherited members.

ACTIV_DECLARE_VALUE_WITH_COMMA enum value | Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::ConnectParameters |
ConnectParameters() | Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::ConnectParameters |
DEFAULT_FAILOVER_SECONDS (defined in Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::ConnectParameters) | Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::ConnectParameters | [static]
m_agentScope | Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::ConnectParameters |
m_attributeQuery | Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::ConnectParameters |
m_failoverSeconds | Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::ConnectParameters |
m_infoString | Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::ConnectParameters |
m_password | Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::ConnectParameters |
m_policy | Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::ConnectParameters |
m_serviceId | Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::ConnectParameters |
m_url | Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::ConnectParameters |
m_userId | Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::ConnectParameters |
m_userType | Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::ConnectParameters |
Policy enum name | Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::ConnectParameters |

Generated on Wed Oct 8 14:02:04 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::Settings Member List

This is the complete list of members for Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::Settings, including all inherited members.

m_createMutex | Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::Settings
m_heapBucketInfoVector | Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::Settings
m_pHeap | Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::Settings
Settings() | Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::Settings
~Settings() | Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::Settings

Generated on Wed Oct 8 14:02:04 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayInfo Member List

This is the complete list of members for Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayInfo, including all inherited members.

m_systemInfo Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayInfo

Generated on Wed Oct 8 14:02:05 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayResponseParameters Member List

This is the complete list of members for Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayResponseParameters, including all inherited members.

m_status | Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayResponseParameters |
Status typedef | Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayResponseParameters |
STATUS_FAILURE (defined in Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayResponseParameters) | Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayResponseParameters | [static]
STATUS_FAILURE_WITH_ERRORS (defined in Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayResponseParameters) | Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayResponseParameters | [static]
STATUS_INVALID_TABLE (defined in Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayResponseParameters) | Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayResponseParameters | [static]
STATUS_NOT_PERMISSIONED (defined in Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayResponseParameters) | Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayResponseParameters | [static]
STATUS_SUCCESS | Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayResponseParameters | [static]
STATUS_SUCCESS_WITH_ERRORS (defined in Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayResponseParameters) | Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayResponseParameters | [static]
StatusToString(const Status status) | Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayResponseParameters | [static]

Generated on Wed Oct 8 14:02:05 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContributionGatewayApi::PermissionInfo Member List

This is the complete list of members for Activ::ContentPlatform::ContributionGatewayApi::PermissionInfo, including all inherited members.

ExchangeCodeList typedef (defined in Activ::ContentPlatform::ContributionGatewayApi::PermissionInfo) | Activ::ContentPlatform::ContributionGatewayApi::PermissionInfo |
FLAG_ALL_EXCHANGE_CODES | Activ::ContentPlatform::ContributionGatewayApi::PermissionInfo | [static]
FLAG_ALL_PERMISSION_IDS (defined in Activ::ContentPlatform::ContributionGatewayApi::PermissionInfo) | Activ::ContentPlatform::ContributionGatewayApi::PermissionInfo | [static]
FLAG_ALL_TABLE_NUMBERS | Activ::ContentPlatform::ContributionGatewayApi::PermissionInfo | [static]
FLAG_NONE | Activ::ContentPlatform::ContributionGatewayApi::PermissionInfo | [static]
Flags typedef | Activ::ContentPlatform::ContributionGatewayApi::PermissionInfo |
m_exchangeCodeList (defined in Activ::ContentPlatform::ContributionGatewayApi::PermissionInfo) | Activ::ContentPlatform::ContributionGatewayApi::PermissionInfo |
m_flags (defined in Activ::ContentPlatform::ContributionGatewayApi::PermissionInfo) | Activ::ContentPlatform::ContributionGatewayApi::PermissionInfo |
m_permissionIdList | Activ::ContentPlatform::ContributionGatewayApi::PermissionInfo |
m_tableNumberList (defined in Activ::ContentPlatform::ContributionGatewayApi::PermissionInfo) | Activ::ContentPlatform::ContributionGatewayApi::PermissionInfo |

Generated on Wed Oct 8 14:02:05 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContributionGatewayApi::PublishField Member List

This is the complete list of members for Activ::ContentPlatform::ContributionGatewayApi::PublishField, including all inherited members.

GetFieldContents() const | Activ::ContentPlatform::ContributionGatewayApi::PublishField
m_fieldId | Activ::ContentPlatform::ContributionGatewayApi::PublishField
PublishField() | Activ::ContentPlatform::ContributionGatewayApi::PublishField
PublishField(Feed::FieldId fieldId, IFieldType *pIFieldType) | Activ::ContentPlatform::ContributionGatewayApi::PublishField
SetFieldContents(IFieldType *pIFieldType) | Activ::ContentPlatform::ContributionGatewayApi::PublishField

Generated on Wed Oct 8 14:02:05 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContributionGatewayApi::PublishRecordBaseParameters Member List

This is the complete list of members for Activ::ContentPlatform::ContributionGatewayApi::PublishRecordBaseParameters, including all inherited members.

FLAG_BEST_EFFORT (defined in Activ::ContentPlatform::ContributionGatewayApi::PublishRecordBaseParameters) | Activ::ContentPlatform::ContributionGatewayApi::PublishRecordBaseParameters | [static]
FLAG_DELETE | Activ::ContentPlatform::ContributionGatewayApi::PublishRecordBaseParameters | [static]
FLAG_NONE | Activ::ContentPlatform::ContributionGatewayApi::PublishRecordBaseParameters | [static]
Flags typedef | Activ::ContentPlatform::ContributionGatewayApi::PublishRecordBaseParameters |
m_eventType (defined in Activ::ContentPlatform::ContributionGatewayApi::PublishRecordBaseParameters) | Activ::ContentPlatform::ContributionGatewayApi::PublishRecordBaseParameters |
m_flags (defined in Activ::ContentPlatform::ContributionGatewayApi::PublishRecordBaseParameters) | Activ::ContentPlatform::ContributionGatewayApi::PublishRecordBaseParameters |
m_permissionId (defined in Activ::ContentPlatform::ContributionGatewayApi::PublishRecordBaseParameters) | Activ::ContentPlatform::ContributionGatewayApi::PublishRecordBaseParameters |
m_tableNumber | Activ::ContentPlatform::ContributionGatewayApi::PublishRecordBaseParameters |
m_updateId (defined in Activ::ContentPlatform::ContributionGatewayApi::PublishRecordBaseParameters) | Activ::ContentPlatform::ContributionGatewayApi::PublishRecordBaseParameters |
PublishRecordBaseParameters() | Activ::ContentPlatform::ContributionGatewayApi::PublishRecordBaseParameters |
PublishRecordBaseParameters(Feed::TableNo tableNumber, Feed::EventType eventType, Feed::PermissionId permissionId, Flags flags, Feed::UpdateId updateId) | Activ::ContentPlatform::ContributionGatewayApi::PublishRecordBaseParameters |

Generated on Wed Oct 8 14:02:05 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContributionGatewayApi::PublishRecordParameters Member List

This is the complete list of members for Activ::ContentPlatform::ContributionGatewayApi::PublishRecordParameters, including all inherited members.

FieldList typedef (defined in Activ::ContentPlatform::ContributionGatewayApi::PublishRecordParameters) | Activ::ContentPlatform::ContributionGatewayApi::PublishRecordParameters |
FLAG_BEST_EFFORT (defined in Activ::ContentPlatform::ContributionGatewayApi::PublishRecordBaseParameters) | Activ::ContentPlatform::ContributionGatewayApi::PublishRecordBaseParameters | [static]
FLAG_DELETE | Activ::ContentPlatform::ContributionGatewayApi::PublishRecordBaseParameters | [static]
FLAG_NONE | Activ::ContentPlatform::ContributionGatewayApi::PublishRecordBaseParameters | [static]
Flags typedef | Activ::ContentPlatform::ContributionGatewayApi::PublishRecordBaseParameters |
m_eventType (defined in Activ::ContentPlatform::ContributionGatewayApi::PublishRecordBaseParameters) | Activ::ContentPlatform::ContributionGatewayApi::PublishRecordBaseParameters |
m_fieldList | Activ::ContentPlatform::ContributionGatewayApi::PublishRecordParameters |
m_flags (defined in Activ::ContentPlatform::ContributionGatewayApi::PublishRecordBaseParameters) | Activ::ContentPlatform::ContributionGatewayApi::PublishRecordBaseParameters |
m_indexNumber | Activ::ContentPlatform::ContributionGatewayApi::PublishRecordParameters |
m_keyFieldList | Activ::ContentPlatform::ContributionGatewayApi::PublishRecordParameters |
m_permissionId (defined in Activ::ContentPlatform::ContributionGatewayApi::PublishRecordBaseParameters) | Activ::ContentPlatform::ContributionGatewayApi::PublishRecordBaseParameters |
m_tableNumber | Activ::ContentPlatform::ContributionGatewayApi::PublishRecordBaseParameters |
m_updateId (defined in Activ::ContentPlatform::ContributionGatewayApi::PublishRecordBaseParameters) | Activ::ContentPlatform::ContributionGatewayApi::PublishRecordBaseParameters |
PublishRecordBaseParameters() | Activ::ContentPlatform::ContributionGatewayApi::PublishRecordBaseParameters |
PublishRecordBaseParameters(Feed::TableNo tableNumber, Feed::EventType eventType, Feed::PermissionId permissionId, Flags flags, Feed::UpdateId updateId) | Activ::ContentPlatform::ContributionGatewayApi::PublishRecordBaseParameters |
PublishRecordParameters() | Activ::ContentPlatform::ContributionGatewayApi::PublishRecordParameters |
PublishRecordParameters(Feed::TableNo tableNumber, Feed::EventType eventType, Feed::PermissionId permissionId, Flags flags, Feed::UpdateId updateId=Feed::UPDATE_ID_COUNT_UNKNOWN) | Activ::ContentPlatform::ContributionGatewayApi::PublishRecordParameters |

Generated on Wed Oct 8 14:02:05 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContributionGatewayApi::PublishRecordResponseParameters Member List

This is the complete list of members for Activ::ContentPlatform::ContributionGatewayApi::PublishRecordResponseParameters, including all inherited members.

FieldErrorList typedef (defined in Activ::ContentPlatform::ContributionGatewayApi::PublishRecordResponseParameters) | Activ::ContentPlatform::ContributionGatewayApi::PublishRecordResponseParameters |
m_fieldErrorList | Activ::ContentPlatform::ContributionGatewayApi::PublishRecordResponseParameters |
m_status | Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayResponseParameters |
Status typedef | Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayResponseParameters |
STATUS_FAILURE (defined in Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayResponseParameters) | Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayResponseParameters | [static]
STATUS_FAILURE_WITH_ERRORS (defined in Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayResponseParameters) | Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayResponseParameters | [static]
STATUS_INVALID_TABLE (defined in Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayResponseParameters) | Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayResponseParameters | [static]
STATUS_NOT_PERMISSIONED (defined in Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayResponseParameters) | Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayResponseParameters | [static]
STATUS_SUCCESS | Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayResponseParameters | [static]
STATUS_SUCCESS_WITH_ERRORS (defined in Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayResponseParameters) | Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayResponseParameters | [static]
StatusToString(const Status status) | Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayResponseParameters | [static]

Generated on Wed Oct 8 14:02:05 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContributionGatewayApi::PublishRecordResponseParameters::FieldError Member List

This is the complete list of members for Activ::ContentPlatform::ContributionGatewayApi::PublishRecordResponseParameters::FieldError, including all inherited members.

FIELD_STATUS_FAILURE (defined in Activ::ContentPlatform::ContributionGatewayApi::PublishRecordResponseParameters::FieldError) | Activ::ContentPlatform::ContributionGatewayApi::PublishRecordResponseParameters::FieldError | [static]
FIELD_STATUS_INVALID_LENGTH (defined in Activ::ContentPlatform::ContributionGatewayApi::PublishRecordResponseParameters::FieldError) | Activ::ContentPlatform::ContributionGatewayApi::PublishRecordResponseParameters::FieldError | [static]
FIELD_STATUS_INVALID_TYPE | Activ::ContentPlatform::ContributionGatewayApi::PublishRecordResponseParameters::FieldError | [static]
FIELD_STATUS_NOT_FOUND (defined in Activ::ContentPlatform::ContributionGatewayApi::PublishRecordResponseParameters::FieldError) | Activ::ContentPlatform::ContributionGatewayApi::PublishRecordResponseParameters::FieldError | [static]
FIELD_STATUS_NOT_PERMISSIONED (defined in Activ::ContentPlatform::ContributionGatewayApi::PublishRecordResponseParameters::FieldError) | Activ::ContentPlatform::ContributionGatewayApi::PublishRecordResponseParameters::FieldError | [static]
FieldStatus typedef (defined in Activ::ContentPlatform::ContributionGatewayApi::PublishRecordResponseParameters::FieldError) | Activ::ContentPlatform::ContributionGatewayApi::PublishRecordResponseParameters::FieldError |
FieldStatusToString(const FieldStatus fieldStatus) | Activ::ContentPlatform::ContributionGatewayApi::PublishRecordResponseParameters::FieldError | [static]
m_fieldId (defined in Activ::ContentPlatform::ContributionGatewayApi::PublishRecordResponseParameters::FieldError) | Activ::ContentPlatform::ContributionGatewayApi::PublishRecordResponseParameters::FieldError |
m_fieldStatus (defined in Activ::ContentPlatform::ContributionGatewayApi::PublishRecordResponseParameters::FieldError) | Activ::ContentPlatform::ContributionGatewayApi::PublishRecordResponseParameters::FieldError |

Generated on Wed Oct 8 14:02:05 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContributionGatewayApi::PublishRequestHelper< MESSAGE_TYPE_VALUE, REQUEST_PARAMETERS, RESPONSE_PARAMETERS > Member List

This is the complete list of members for Activ::ContentPlatform::ContributionGatewayApi::PublishRequestHelper< MESSAGE_TYPE_VALUE, REQUEST_PARAMETERS, RESPONSE_PARAMETERS >, including all inherited members.

Deserialize(const ContributionGatewayClient &client, const HeapMessage &response, ResponseParameters &responseParameters) | Activ::ContentPlatform::ContributionGatewayApi::PublishRequestHelper< MESSAGE_TYPE_VALUE, REQUEST_PARAMETERS, RESPONSE_PARAMETERS > | [static]
GetResponse(const ContributionGatewayClient &client, SyncRequestId &syncRequestId, ResponseParameters &responseParameters, const TimeoutPeriod timeoutPeriod=Port::defaultTimeout) | Activ::ContentPlatform::ContributionGatewayApi::PublishRequestHelper< MESSAGE_TYPE_VALUE, REQUEST_PARAMETERS, RESPONSE_PARAMETERS > | [static]
PostRequest(const ContributionGatewayClient &client, const RequestId &requestId, const RequestParameters &requestParameters) | Activ::ContentPlatform::ContributionGatewayApi::PublishRequestHelper< MESSAGE_TYPE_VALUE, REQUEST_PARAMETERS, RESPONSE_PARAMETERS > | [static]
RequestParameters typedef | Activ::ContentPlatform::ContributionGatewayApi::PublishRequestHelper< MESSAGE_TYPE_VALUE, REQUEST_PARAMETERS, RESPONSE_PARAMETERS > |
ResponseParameters typedef | Activ::ContentPlatform::ContributionGatewayApi::PublishRequestHelper< MESSAGE_TYPE_VALUE, REQUEST_PARAMETERS, RESPONSE_PARAMETERS > |
SendRequest(const ContributionGatewayClient &client, const RequestParameters &requestParameters, ResponseParameters &responseParameters, const TimeoutPeriod timeoutPeriod=Port::defaultTimeout) | Activ::ContentPlatform::ContributionGatewayApi::PublishRequestHelper< MESSAGE_TYPE_VALUE, REQUEST_PARAMETERS, RESPONSE_PARAMETERS > | [static]
SendRequest(const ContributionGatewayClient &client, SyncRequestId &syncRequestId, const RequestParameters &requestParameters) | Activ::ContentPlatform::ContributionGatewayApi::PublishRequestHelper< MESSAGE_TYPE_VALUE, REQUEST_PARAMETERS, RESPONSE_PARAMETERS > | [static]

Generated on Wed Oct 8 14:02:05 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContributionGatewayApi::PublishSymbolRecordParameters Member List

This is the complete list of members for Activ::ContentPlatform::ContributionGatewayApi::PublishSymbolRecordParameters, including all inherited members.

FieldList typedef (defined in Activ::ContentPlatform::ContributionGatewayApi::PublishSymbolRecordParameters) | Activ::ContentPlatform::ContributionGatewayApi::PublishSymbolRecordParameters |
FLAG_BEST_EFFORT (defined in Activ::ContentPlatform::ContributionGatewayApi::PublishRecordBaseParameters) | Activ::ContentPlatform::ContributionGatewayApi::PublishRecordBaseParameters | [static]
FLAG_DELETE | Activ::ContentPlatform::ContributionGatewayApi::PublishRecordBaseParameters | [static]
FLAG_NONE | Activ::ContentPlatform::ContributionGatewayApi::PublishRecordBaseParameters | [static]
Flags typedef | Activ::ContentPlatform::ContributionGatewayApi::PublishRecordBaseParameters |
m_defaultRuleSet | Activ::ContentPlatform::ContributionGatewayApi::PublishSymbolRecordParameters |
m_eventType (defined in Activ::ContentPlatform::ContributionGatewayApi::PublishRecordBaseParameters) | Activ::ContentPlatform::ContributionGatewayApi::PublishRecordBaseParameters |
m_fieldList | Activ::ContentPlatform::ContributionGatewayApi::PublishSymbolRecordParameters |
m_flags (defined in Activ::ContentPlatform::ContributionGatewayApi::PublishRecordBaseParameters) | Activ::ContentPlatform::ContributionGatewayApi::PublishRecordBaseParameters |
m_permissionId (defined in Activ::ContentPlatform::ContributionGatewayApi::PublishRecordBaseParameters) | Activ::ContentPlatform::ContributionGatewayApi::PublishRecordBaseParameters |
m_symbol | Activ::ContentPlatform::ContributionGatewayApi::PublishSymbolRecordParameters |
m_tableNumber | Activ::ContentPlatform::ContributionGatewayApi::PublishRecordBaseParameters |
m_updateId (defined in Activ::ContentPlatform::ContributionGatewayApi::PublishRecordBaseParameters) | Activ::ContentPlatform::ContributionGatewayApi::PublishRecordBaseParameters |
PublishRecordBaseParameters() | Activ::ContentPlatform::ContributionGatewayApi::PublishRecordBaseParameters |
PublishRecordBaseParameters(Feed::TableNo tableNumber, Feed::EventType eventType, Feed::PermissionId permissionId, Flags flags, Feed::UpdateId updateId) | Activ::ContentPlatform::ContributionGatewayApi::PublishRecordBaseParameters |
PublishSymbolRecordParameters() | Activ::ContentPlatform::ContributionGatewayApi::PublishSymbolRecordParameters |
PublishSymbolRecordParameters(Feed::TableNo tableNumber, const Symbol &symbol, Feed::EventType eventType, Feed::PermissionId permissionId, Flags flags, Feed::UpdateId updateId=Feed::UPDATE_ID_COUNT_UNKNOWN, uint8_t defaultRuleSet=Feed::SymbolRecordRuleDefinitions::RULE_SET_NONE) | Activ::ContentPlatform::ContributionGatewayApi::PublishSymbolRecordParameters |

Generated on Wed Oct 8 14:02:05 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContributionGatewayApi::PublishSymbolRecordParameters::Field Member List

This is the complete list of members for Activ::ContentPlatform::ContributionGatewayApi::PublishSymbolRecordParameters::Field, including all inherited members.

Field() | Activ::ContentPlatform::ContributionGatewayApi::PublishSymbolRecordParameters::Field |
Field(Feed::FieldId fieldId, IFieldType *pIFieldType) | Activ::ContentPlatform::ContributionGatewayApi::PublishSymbolRecordParameters::Field |
Field(Feed::FieldId fieldId, uint8_t ruleSet, uint8_t rules, IFieldType *pIFieldType) | Activ::ContentPlatform::ContributionGatewayApi::PublishSymbolRecordParameters::Field |
GetFieldContents() const | Activ::ContentPlatform::ContributionGatewayApi::PublishField |
GetRules() const | Activ::ContentPlatform::ContributionGatewayApi::PublishSymbolRecordParameters::Field | [inline]
GetRuleSet() const | Activ::ContentPlatform::ContributionGatewayApi::PublishSymbolRecordParameters::Field | [inline]
IsRulesPresent() const | Activ::ContentPlatform::ContributionGatewayApi::PublishSymbolRecordParameters::Field | [inline]
m_fieldId | Activ::ContentPlatform::ContributionGatewayApi::PublishField |
PublishField() | Activ::ContentPlatform::ContributionGatewayApi::PublishField |
PublishField(Feed::FieldId fieldId, IFieldType *pIFieldType) | Activ::ContentPlatform::ContributionGatewayApi::PublishField |
SetFieldContents(IFieldType *pIFieldType) | Activ::ContentPlatform::ContributionGatewayApi::PublishField |
SetRuleSet(uint8_t ruleSet, uint8_t rules=0) | Activ::ContentPlatform::ContributionGatewayApi::PublishSymbolRecordParameters::Field |

Generated on Wed Oct 8 14:02:05 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContributionServerApi::ContributionServerClient Member List

This is the complete list of members for Activ::ContentPlatform::ContributionServerApi::ContributionServerClient, including all inherited members.

anonymousName | Activ::Port | [static]
Component(Application &application, ManagedEndPoint &managedEndPoint, const std::string &name=anonymousName, IHeap *const pHeap=0, const std::string &componentId=defaultComponentId) | Activ::Component |
ContributionServerClient(Application &application, ManagedEndPoint &managedEndPoint, const Settings &settings=Settings(), const std::string &componentId=defaultComponentId) | Activ::ContentPlatform::ContributionServerApi::ContributionServerClient |
defaultComponentId | Activ::Component | [static]
defaultTimeout | Activ::Port | [static]
Disable() | Activ::Port |
Enable() | Activ::Port |
FindPort(const std::string &endPointName, const std::string &portName, Address &portAddress, const TimeoutPeriod timeout=defaultTimeout) | Activ::Port |
ForwardMessage(const Address &destinationAddress, HeapMessage &message, const MessageType newType=INVALID_MESSAGE_TYPE) const | Activ::Port |
GetAddress() const | Activ::Port | [inline]
GetApiInfo() const | Activ::ContentPlatform::ContributionServerApi::ContributionServerClient |
GetApplication() const | Activ::Component |
GetDefaultName() | Activ::ContentPlatform::ContributionServerApi::ContributionServerClient | [static]
GetHeap() const | Activ::Port | [inline]
GetManagedEndPoint() const | Activ::Port |
GetMaximumTableNumber() const | Activ::ContentPlatform::ContributionServerApi::ContributionServerClient |
GetMinimumTableNumber() const | Activ::ContentPlatform::ContributionServerApi::ContributionServerClient |
GetName() const | Activ::Port |
GetRecordMessageBuilder() | Activ::ContentPlatform::ContributionServerApi::ContributionServerClient |
GetSettings() const | Activ::ContentPlatform::ContributionServerApi::ContributionServerClient |
GetSymbolRecordMessageBuilder() | Activ::ContentPlatform::ContributionServerApi::ContributionServerClient |
GetTableTemplateList() const | Activ::ContentPlatform::ContributionServerApi::ContributionServerClient |
GetTableTemplateList() | Activ::ContentPlatform::ContributionServerApi::ContributionServerClient |
ManagedEndPoint::Impl (defined in Activ::Port) | Activ::Port | [friend]
OnAccept(HeapMessage &acceptMessage) | Activ::Component | [protected, virtual]
OnBreak(HeapMessage &breakMessage) | Activ::Component | [protected, virtual]
OnConnect(HeapMessage &connectMessage) | Activ::Component | [protected, virtual]
OnConnectFailed(HeapMessage &connectFailMessage) | Activ::Component | [protected, virtual]
OnData(HeapMessage &heapMessage) | Activ::Component | [protected, virtual]
OnDisconnect(HeapMessage &disconnectMessage) | Activ::Component | [protected, virtual]
OnMessage(HeapMessage &message) | Activ::Component | [protected, virtual]
OnRequest(HeapMessage &request) | Activ::Component | [protected, virtual]
OnResponse(HeapMessage &response) | Activ::Port | [protected, virtual]
OnTimer(const Address &timerAddress, const BaseTime &time) | Activ::Component | [protected, virtual]
Port(ManagedEndPoint &managedEndPoint, const std::string &name, IHeap *const pHeap) | Activ::Port |
Port(ManagedEndPoint &managedEndPoint, const std::string &name, const PortId portId, IHeap *const pHeap) | Activ::Port |
PostEmptyResponse(const StatusCode responseStatus, HeapMessage &response) const | Activ::Port |
PostEmptyResponse(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, const StatusCode responseStatus, HeapMessage &response) const | Activ::Port |
PostMessage(const Address &destinationAddress, const MessageType messageType, const MessageBuilder &messageBuilder) const | Activ::Port |
PostMessage(const Address &destinationAddress, const MessageType messageType, const void *pMessage=0, const size_t messageLength=0) const | Activ::Port |
PostMessage(const Address &destinationAddress, const MessageType messageType, HeapMessage &message) const | Activ::Port |
PostRequest(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, const MessageBuilder &messageBuilder) const | Activ::Port |
PostRequest(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, const void *pRequest=0, const size_t requestLength=0) const | Activ::Port |
PostRequest(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, HeapMessage &request) const | Activ::Port |
PostResponse(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, const StatusCode responseStatus, const MessageBuilder &messageBuilder) const | Activ::Port |
PostResponse(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, const StatusCode responseStatus, const void *pResponse=0, const size_t responseLength=0) const | Activ::Port |
PostResponse(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, const StatusCode responseStatus, HeapMessage &response) const | Activ::Port |
PostResponse(const StatusCode responseStatus, HeapMessage &request, const MessageBuilder &messageBuilder) const | Activ::Port |
PostResponse(const StatusCode responseStatus, HeapMessage &request, const void *pResponse, const size_t responseLength) const | Activ::Port |
PostResponse(const StatusCode responseStatus, HeapMessage &request, HeapMessage &response) const | Activ::Port |
PostResponse(const StatusCode responseStatus, HeapMessage &request) const | Activ::Port |
SendRequest(const Address &destinationAddress, const MessageType requestType, const MessageBuilder &messageBuilder, HeapMessage &response, const TimeoutPeriod timeout=defaultTimeout) const | Activ::Port |
SendRequest(const Address &destinationAddress, const MessageType requestType, const void *pRequest, const size_t requestLength, HeapMessage &response, const TimeoutPeriod timeout=defaultTimeout) const | Activ::Port |
SendRequest(const Address &destinationAddress, const MessageType requestType, HeapMessage &request, const TimeoutPeriod timeout=defaultTimeout) const | Activ::Port |
SendRequest(const Address &destinationAddress, const MessageType requestType, SyncRequestId &syncRequestId, const MessageBuilder &messageBuilder) const | Activ::Port |
SendRequest(const Address &destinationAddress, const MessageType requestType, SyncRequestId &syncRequestId, const void *pRequest, const size_t requestLength) const | Activ::Port |
SendRequest(const Address &destinationAddress, const MessageType requestType, SyncRequestId &syncRequestId, HeapMessage &request) const | Activ::Port |
SetHeap(IHeap *const pHeap) | Activ::Port |
~Component() | Activ::Component |
~ContributionServerClient() | Activ::ContentPlatform::ContributionServerApi::ContributionServerClient |
~Port() | Activ::Port | [virtual]

Generated on Wed Oct 8 14:02:05 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::SymbolRecordMessageBuilder Member List

This is the complete list of members for Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::SymbolRecordMessageBuilder, including all inherited members.

AppendField(const Feed::FieldId fieldId, const IFieldType &iFieldType) | Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::SymbolRecordMessageBuilder
AppendFieldWithContentServerRuleSet(const Feed::FieldId fieldId, const uint8_t fieldRules, const IFieldType &iFieldType) | Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::SymbolRecordMessageBuilder
AppendFieldWithNoneRuleSet(const Feed::FieldId fieldId, const IFieldType &iFieldType) | Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::SymbolRecordMessageBuilder
AppendFieldWithTranslatorRuleSet(const Feed::FieldId fieldId, const uint8_t fieldRules, const IFieldType &iFieldType) | Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::SymbolRecordMessageBuilder
AppendHeader(const bool isDelete, const Feed::TableId tableId, const Feed::PermissionId permissionId, const Feed::EventType eventType, const void *const pSymbol, const size_t symbolLength, uint8_t defaultRuleSet=Feed::SymbolRecordRuleDefinitions::RULE_SET_NONE, const Feed::UpdateId updateId=Feed::UPDATE_ID_COUNT_UNKNOWN) | Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::SymbolRecordMessageBuilder
AppendUndefinedField(const Feed::FieldId fieldId) | Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::SymbolRecordMessageBuilder
Flush() | Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::SymbolRecordMessageBuilder
IsInitialized() const | Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::SymbolRecordMessageBuilder
Reset() | Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::SymbolRecordMessageBuilder
SymbolRecordMessageBuilder(ContributionServerClient &contributionServerClient) | Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::SymbolRecordMessageBuilder
ToString() const | Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::SymbolRecordMessageBuilder
Write(bool flush=true) | Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::SymbolRecordMessageBuilder
~SymbolRecordMessageBuilder() | Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::SymbolRecordMessageBuilder

Generated on Wed Oct 8 14:02:05 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::ApiInfo Member List

This is the complete list of members for Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::ApiInfo, including all inherited members.

m_buildConfiguration | Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::ApiInfo
m_buildDateTime | Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::ApiInfo
m_version | Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::ApiInfo

Generated on Wed Oct 8 14:02:05 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::RecordMessageBuilder Member List

This is the complete list of members for Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::RecordMessageBuilder, including all inherited members.

AppendField(const Feed::FieldId fieldId, const IFieldType &iFieldType) | Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::RecordMessageBuilder
AppendHeader(const bool isDelete, const bool isRefresh, const Feed::TableId tableId, const Feed::PermissionId permissionId, const Feed::EventType eventType, const Feed::UpdateId updateId=Feed::UPDATE_ID_COUNT_UNKNOWN) | Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::RecordMessageBuilder
AppendIndexNumber(const Feed::IndexNumber indexNumber) | Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::RecordMessageBuilder
AppendKeyField(const Feed::FieldId fieldId, const IFieldType &iFieldType) | Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::RecordMessageBuilder
AppendUndefinedField(const Feed::FieldId fieldId) | Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::RecordMessageBuilder
AppendUndefinedKeyField(const Feed::FieldId fieldId) | Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::RecordMessageBuilder
Flush() | Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::RecordMessageBuilder
IsInitialized() const | Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::RecordMessageBuilder
RecordMessageBuilder(ContributionServerClient &contributionServerClient) | Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::RecordMessageBuilder
Reset() | Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::RecordMessageBuilder
ToString() const | Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::RecordMessageBuilder
Write(bool flush=true) | Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::RecordMessageBuilder
~RecordMessageBuilder() | Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::RecordMessageBuilder

Generated on Wed Oct 8 14:02:05 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::Settings Member List

This is the complete list of members for Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::Settings, including all inherited members.

GetFromIniFile(const std::string &iniFileName, const std::string &sectionName=ContributionServerClient::GetDefaultName()) | Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::Settings | [static]
m_iniFileName | Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::Settings |
m_messageRate | Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::Settings |
m_sectionName | Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::Settings |
m_tableTemplateListSettings | Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::Settings |
m_udpSettings | Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::Settings |
Read(const IniFileParser &iniFileParser, const std::string &sectionName) | Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::Settings |
Settings() | Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::Settings |

Generated on Wed Oct 8 14:02:05 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::CombinedQuoteMessageHeaderDefinitions Member List

This is the complete list of members for Activ::ContentPlatform::Feed::CombinedQuoteMessageHeaderDefinitions, including all inherited members.

ExtractFlags(const Flags flags, bool &isCompositeBid, bool &isCompositeAsk, bool &isCompositeBidAppendage, bool &isCompositeAskAppendage) | Activ::ContentPlatform::Feed::CombinedQuoteMessageHeaderDefinitions | [inline, static]
Flags typedef | Activ::ContentPlatform::Feed::CombinedQuoteMessageHeaderDefinitions |
FLAGS_COMPOSITE_ASK_APPENDAGE_BIT_MASK (defined in Activ::ContentPlatform::Feed::CombinedQuoteMessageHeaderDefinitions) | Activ::ContentPlatform::Feed::CombinedQuoteMessageHeaderDefinitions | [static]
FLAGS_COMPOSITE_ASK_APPENDAGE_BIT_SHIFT (defined in Activ::ContentPlatform::Feed::CombinedQuoteMessageHeaderDefinitions) | Activ::ContentPlatform::Feed::CombinedQuoteMessageHeaderDefinitions | [static]
FLAGS_COMPOSITE_ASK_APPENDAGE_LENGTH | Activ::ContentPlatform::Feed::CombinedQuoteMessageHeaderDefinitions | [static]
FLAGS_COMPOSITE_ASK_APPENDAGE_OFFSET | Activ::ContentPlatform::Feed::CombinedQuoteMessageHeaderDefinitions | [static]
FLAGS_COMPOSITE_ASK_BIT_MASK (defined in Activ::ContentPlatform::Feed::CombinedQuoteMessageHeaderDefinitions) | Activ::ContentPlatform::Feed::CombinedQuoteMessageHeaderDefinitions | [static]
FLAGS_COMPOSITE_ASK_BIT_SHIFT (defined in Activ::ContentPlatform::Feed::CombinedQuoteMessageHeaderDefinitions) | Activ::ContentPlatform::Feed::CombinedQuoteMessageHeaderDefinitions | [static]
FLAGS_COMPOSITE_ASK_LENGTH | Activ::ContentPlatform::Feed::CombinedQuoteMessageHeaderDefinitions | [static]
FLAGS_COMPOSITE_ASK_OFFSET | Activ::ContentPlatform::Feed::CombinedQuoteMessageHeaderDefinitions | [static]
FLAGS_COMPOSITE_BID_APPENDAGE_BIT_MASK (defined in Activ::ContentPlatform::Feed::CombinedQuoteMessageHeaderDefinitions) | Activ::ContentPlatform::Feed::CombinedQuoteMessageHeaderDefinitions | [static]
FLAGS_COMPOSITE_BID_APPENDAGE_BIT_SHIFT (defined in Activ::ContentPlatform::Feed::CombinedQuoteMessageHeaderDefinitions) | Activ::ContentPlatform::Feed::CombinedQuoteMessageHeaderDefinitions | [static]
FLAGS_COMPOSITE_BID_APPENDAGE_LENGTH | Activ::ContentPlatform::Feed::CombinedQuoteMessageHeaderDefinitions | [static]
FLAGS_COMPOSITE_BID_APPENDAGE_OFFSET | Activ::ContentPlatform::Feed::CombinedQuoteMessageHeaderDefinitions | [static]
FLAGS_COMPOSITE_BID_BIT_MASK (defined in Activ::ContentPlatform::Feed::CombinedQuoteMessageHeaderDefinitions) | Activ::ContentPlatform::Feed::CombinedQuoteMessageHeaderDefinitions | [static]
FLAGS_COMPOSITE_BID_BIT_SHIFT (defined in Activ::ContentPlatform::Feed::CombinedQuoteMessageHeaderDefinitions) | Activ::ContentPlatform::Feed::CombinedQuoteMessageHeaderDefinitions | [static]
FLAGS_COMPOSITE_BID_LENGTH | Activ::ContentPlatform::Feed::CombinedQuoteMessageHeaderDefinitions | [static]
FLAGS_COMPOSITE_BID_OFFSET | Activ::ContentPlatform::Feed::CombinedQuoteMessageHeaderDefinitions | [static]
GetFlags(const bool isCompositeBid, const bool isCompositeAsk, const bool isCompositeBidAppendage, const bool isCompositeAskAppendage) | Activ::ContentPlatform::Feed::CombinedQuoteMessageHeaderDefinitions | [inline, static]
GetMessageHeader(const MessageType messageType=MESSAGE_TYPE) | Activ::ContentPlatform::Feed::CombinedQuoteMessageHeaderDefinitions | [inline, static]
IsCompositeAsk(const Flags flags) | Activ::ContentPlatform::Feed::CombinedQuoteMessageHeaderDefinitions | [inline, static]
IsCompositeAskAppendage(const Flags flags) | Activ::ContentPlatform::Feed::CombinedQuoteMessageHeaderDefinitions | [inline, static]
IsCompositeBid(const Flags flags) | Activ::ContentPlatform::Feed::CombinedQuoteMessageHeaderDefinitions | [inline, static]
IsCompositeBidAppendage(const Flags flags) | Activ::ContentPlatform::Feed::CombinedQuoteMessageHeaderDefinitions | [inline, static]
IsValidMessageType(const MessageHeaderDefinitions::MessageHeader messageHeader) | Activ::ContentPlatform::Feed::CombinedQuoteMessageHeaderDefinitions | [inline, static]
MAX_SYMBOL_LENGTH | Activ::ContentPlatform::Feed::CombinedQuoteMessageHeaderDefinitions | [static]
MESSAGE_TYPE | Activ::ContentPlatform::Feed::CombinedQuoteMessageHeaderDefinitions | [static]

Generated on Wed Oct 8 14:02:05 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessage Member List

This is the complete list of members for Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessage, including all inherited members.

m_compositeAskState | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessage | [protected]
m_compositeBidState | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessage | [protected]
m_compositeUpdateId | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessage | [protected]
m_isComposite | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessage | [protected]
m_isCompositeAsk | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessage | [protected]
m_isCompositeBid | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessage | [protected]
m_permissionId | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessage | [protected]
m_symbol | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessage | [protected]
m_tableNumber | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessage | [protected]
m_updateId | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessage | [protected]
ValidateCompressedCombinedQuote(MessageValidator &messageValidator) | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessage | [inline]

Generated on Wed Oct 8 14:02:05 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageDefinitions Member List

This is the complete list of members for Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageDefinitions, including all inherited members.

COMPOSITE_STATE_APPENDAGE enum value (defined in Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageDefinitions) | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageDefinitions |
COMPOSITE_STATE_NO_BEST enum value (defined in Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageDefinitions) | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageDefinitions |
COMPOSITE_STATE_NO_CHANGE enum value (defined in Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageDefinitions) | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageDefinitions |
COMPOSITE_STATE_REGIONAL_IS_BEST enum value (defined in Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageDefinitions) | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageDefinitions |
CompositeState typedef | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageDefinitions |
COMPRESSED_COMPOSITE_ASK_STATE_BIT_MASK (defined in Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageDefinitions) | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageDefinitions | [static]
COMPRESSED_COMPOSITE_ASK_STATE_BIT_SHIFT (defined in Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageDefinitions) | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageDefinitions | [static]
COMPRESSED_COMPOSITE_ASK_STATE_LENGTH (defined in Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageDefinitions) | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageDefinitions | [static]
COMPRESSED_COMPOSITE_ASK_STATE_OFFSET (defined in Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageDefinitions) | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageDefinitions | [static]
COMPRESSED_COMPOSITE_BID_STATE_BIT_MASK (defined in Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageDefinitions) | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageDefinitions | [static]
COMPRESSED_COMPOSITE_BID_STATE_BIT_SHIFT (defined in Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageDefinitions) | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageDefinitions | [static]
COMPRESSED_COMPOSITE_BID_STATE_LENGTH (defined in Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageDefinitions) | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageDefinitions | [static]
COMPRESSED_COMPOSITE_BID_STATE_OFFSET (defined in Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageDefinitions) | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageDefinitions | [static]
COMPRESSED_COMPOSITE_UPDATE_ID_BIT_MASK (defined in Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageDefinitions) | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageDefinitions | [static]
COMPRESSED_COMPOSITE_UPDATE_ID_BIT_SHIFT (defined in Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageDefinitions) | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageDefinitions | [static]
COMPRESSED_COMPOSITE_UPDATE_ID_LENGTH (defined in Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageDefinitions) | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageDefinitions | [static]
COMPRESSED_COMPOSITE_UPDATE_ID_OFFSET (defined in Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageDefinitions) | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageDefinitions | [static]
COMPRESSED_UPDATE_ID_BIT_MASK (defined in Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageDefinitions) | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageDefinitions | [static]
COMPRESSED_UPDATE_ID_BIT_SHIFT (defined in Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageDefinitions) | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageDefinitions | [static]
COMPRESSED_UPDATE_ID_LENGTH (defined in Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageDefinitions) | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageDefinitions | [static]
COMPRESSED_UPDATE_ID_OFFSET (defined in Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageDefinitions) | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageDefinitions | [static]
CompressedNumeratorLength typedef | Activ::ContentPlatform::Feed::CompressedMessageDefinitions |
ExtractCompressedCompositeAskState(const uint8_t compressedCompositeAskState, CompositeState &compositeAskState) | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageDefinitions | [inline, static]
ExtractCompressedUpdateId(const uint8_t compressedUpdateId, UpdateId &updateId, CompositeState &compositeBidState) | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageDefinitions | [inline, static]
ExtractCompressedUpdateId(const uint8_t compressedUpdateId, UpdateId &updateId, UpdateId &compositeUpdateId, CompositeState &compositeBidState) | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageDefinitions | [inline, static]
FIELD_HEADER_BIT_MASK (defined in Activ::ContentPlatform::Feed::CompressedMessageDefinitions) | Activ::ContentPlatform::Feed::CompressedMessageDefinitions | [static]
FIELD_HEADER_LENGTH (defined in Activ::ContentPlatform::Feed::CompressedMessageDefinitions) | Activ::ContentPlatform::Feed::CompressedMessageDefinitions | [static]
FIELD_HEADERS_PER_BYTE (defined in Activ::ContentPlatform::Feed::CompressedMessageDefinitions) | Activ::ContentPlatform::Feed::CompressedMessageDefinitions | [static]
FIELD_STATE_DIFFERENT enum value (defined in Activ::ContentPlatform::Feed::CompressedMessageDefinitions) | Activ::ContentPlatform::Feed::CompressedMessageDefinitions |
FIELD_STATE_SAME_AS_PREVIOUS enum value (defined in Activ::ContentPlatform::Feed::CompressedMessageDefinitions) | Activ::ContentPlatform::Feed::CompressedMessageDefinitions |
FIELD_STATE_SAME_AS_TWIN enum value (defined in Activ::ContentPlatform::Feed::CompressedMessageDefinitions) | Activ::ContentPlatform::Feed::CompressedMessageDefinitions |
FIELD_STATE_UNDEFINED enum value (defined in Activ::ContentPlatform::Feed::CompressedMessageDefinitions) | Activ::ContentPlatform::Feed::CompressedMessageDefinitions |
FieldState enum name | Activ::ContentPlatform::Feed::CompressedMessageDefinitions |
GetCompressedCompositeAskState(const CompositeState compositeAskState) | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageDefinitions | [inline, static]
GetCompressedNumeratorLength(const size_t numeratorLength) | Activ::ContentPlatform::Feed::CompressedMessageDefinitions | [inline, static]
GetCompressedUpdateId(const UpdateId updateId, const CompositeState compositeBidState) | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageDefinitions | [inline, static]
GetCompressedUpdateId(const UpdateId updateId, const UpdateId compositeUpdateId, const CompositeState compositeBidState) | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageDefinitions | [inline, static]
GetHeader(const TableNo tableNumber, const bool isPermissionIdDefined, const bool isCompressedSymbolDefined) | Activ::ContentPlatform::Feed::CompressedMessageDefinitions | [inline, static]
GetNumeratorLength(const CompressedNumeratorLength compressedNumeratorLength) | Activ::ContentPlatform::Feed::CompressedMessageDefinitions | [inline, static]
GetShortTableNumber(const Header header, TableNo &tableNumber) | Activ::ContentPlatform::Feed::CompressedMessageDefinitions | [inline, static]
Header typedef | Activ::ContentPlatform::Feed::CompressedMessageDefinitions |
HEADER_COMPRESSED_SYMBOL_DEFINED_BIT_MASK (defined in Activ::ContentPlatform::Feed::CompressedMessageDefinitions) | Activ::ContentPlatform::Feed::CompressedMessageDefinitions | [static]
HEADER_COMPRESSED_SYMBOL_DEFINED_BIT_SHIFT (defined in Activ::ContentPlatform::Feed::CompressedMessageDefinitions) | Activ::ContentPlatform::Feed::CompressedMessageDefinitions | [static]
HEADER_FLAGS_COMPRESSED_SYMBOL_DEFINED_LENGTH (defined in Activ::ContentPlatform::Feed::CompressedMessageDefinitions) | Activ::ContentPlatform::Feed::CompressedMessageDefinitions | [static]
HEADER_FLAGS_COMPRESSED_SYMBOL_DEFINED_OFFSET (defined in Activ::ContentPlatform::Feed::CompressedMessageDefinitions) | Activ::ContentPlatform::Feed::CompressedMessageDefinitions | [static]
HEADER_FLAGS_PERMISSION_ID_DEFINED_LENGTH (defined in Activ::ContentPlatform::Feed::CompressedMessageDefinitions) | Activ::ContentPlatform::Feed::CompressedMessageDefinitions | [static]
HEADER_FLAGS_PERMISSION_ID_DEFINED_OFFSET (defined in Activ::ContentPlatform::Feed::CompressedMessageDefinitions) | Activ::ContentPlatform::Feed::CompressedMessageDefinitions | [static]
HEADER_FLAGS_RESERVED_LENGTH (defined in Activ::ContentPlatform::Feed::CompressedMessageDefinitions) | Activ::ContentPlatform::Feed::CompressedMessageDefinitions | [static]
HEADER_FLAGS_RESERVED_OFFSET (defined in Activ::ContentPlatform::Feed::CompressedMessageDefinitions) | Activ::ContentPlatform::Feed::CompressedMessageDefinitions | [static]
HEADER_FLAGS_SHORT_TABLE_NUMBER_DEFINED_LENGTH (defined in Activ::ContentPlatform::Feed::CompressedMessageDefinitions) | Activ::ContentPlatform::Feed::CompressedMessageDefinitions | [static]
HEADER_FLAGS_SHORT_TABLE_NUMBER_DEFINED_OFFSET (defined in Activ::ContentPlatform::Feed::CompressedMessageDefinitions) | Activ::ContentPlatform::Feed::CompressedMessageDefinitions | [static]
HEADER_FLAGS_SHORT_TABLE_NUMBER_LENGTH (defined in Activ::ContentPlatform::Feed::CompressedMessageDefinitions) | Activ::ContentPlatform::Feed::CompressedMessageDefinitions | [static]
HEADER_FLAGS_SHORT_TABLE_NUMBER_OFFSET (defined in Activ::ContentPlatform::Feed::CompressedMessageDefinitions) | Activ::ContentPlatform::Feed::CompressedMessageDefinitions | [static]
HEADER_PERMISSION_ID_DEFINED_BIT_MASK (defined in Activ::ContentPlatform::Feed::CompressedMessageDefinitions) | Activ::ContentPlatform::Feed::CompressedMessageDefinitions | [static]
HEADER_PERMISSION_ID_DEFINED_BIT_SHIFT (defined in Activ::ContentPlatform::Feed::CompressedMessageDefinitions) | Activ::ContentPlatform::Feed::CompressedMessageDefinitions | [static]
HEADER_SHORT_TABLE_NUMBER_BIT_MASK (defined in Activ::ContentPlatform::Feed::CompressedMessageDefinitions) | Activ::ContentPlatform::Feed::CompressedMessageDefinitions | [static]
HEADER_SHORT_TABLE_NUMBER_BIT_SHIFT (defined in Activ::ContentPlatform::Feed::CompressedMessageDefinitions) | Activ::ContentPlatform::Feed::CompressedMessageDefinitions | [static]
HEADER_SHORT_TABLE_NUMBER_DEFINED_BIT_MASK (defined in Activ::ContentPlatform::Feed::CompressedMessageDefinitions) | Activ::ContentPlatform::Feed::CompressedMessageDefinitions | [static]
HEADER_SHORT_TABLE_NUMBER_DEFINED_BIT_SHIFT (defined in Activ::ContentPlatform::Feed::CompressedMessageDefinitions) | Activ::ContentPlatform::Feed::CompressedMessageDefinitions | [static]
IsCompressedSymbolDefined(const Header header) | Activ::ContentPlatform::Feed::CompressedMessageDefinitions | [inline, static]
IsPermissionIdDefined(const Header header) | Activ::ContentPlatform::Feed::CompressedMessageDefinitions | [inline, static]
IsShortTableNumber(const TableNo tableNumber) | Activ::ContentPlatform::Feed::CompressedMessageDefinitions | [inline, static]
IsShortTableNumberDefined(const Header header) | Activ::ContentPlatform::Feed::CompressedMessageDefinitions | [inline, static]
NUMERATOR_LENGTH_16_BITS | Activ::ContentPlatform::Feed::CompressedMessageDefinitions | [static]
NUMERATOR_LENGTH_32_BITS | Activ::ContentPlatform::Feed::CompressedMessageDefinitions | [static]
NUMERATOR_LENGTH_64_BITS | Activ::ContentPlatform::Feed::CompressedMessageDefinitions | [static]
NUMERATOR_LENGTH_8_BITS | Activ::ContentPlatform::Feed::CompressedMessageDefinitions | [static]

Generated on Wed Oct 8 14:02:05 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderDefinitions Member List

This is the complete list of members for Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderDefinitions, including all inherited members.

GetMessageHeader(const bool isComposite, const bool isUsEquityOption, const bool isCompressedSymbol) | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderDefinitions | [inline, static]
IsComposite(const MessageHeaderDefinitions::MessageHeader messageHeader) | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderDefinitions | [inline, static]
IsCompressedSymbol(const MessageHeaderDefinitions::MessageHeader messageHeader) | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderDefinitions | [inline, static]
IsUsEquityOption(const MessageHeaderDefinitions::MessageHeader messageHeader) | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderDefinitions | [inline, static]
IsValidMessageType(const MessageHeaderDefinitions::MessageHeader messageHeader) | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderDefinitions | [inline, static]
MAX_SYMBOL_LENGTH | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderDefinitions | [static]
MESSAGE_HEADER_FLAGS_COMPOSITE_BIT_MASK (defined in Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderDefinitions) | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderDefinitions | [static]
MESSAGE_HEADER_FLAGS_COMPOSITE_BIT_SHIFT (defined in Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderDefinitions) | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderDefinitions | [static]
MESSAGE_HEADER_FLAGS_COMPOSITE_LENGTH | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderDefinitions | [static]
MESSAGE_HEADER_FLAGS_COMPOSITE_OFFSET | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderDefinitions | [static]
MESSAGE_HEADER_FLAGS_COMPRESSED_SYMBOL_BIT_MASK (defined in Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderDefinitions) | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderDefinitions | [static]
MESSAGE_HEADER_FLAGS_COMPRESSED_SYMBOL_BIT_SHIFT (defined in Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderDefinitions) | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderDefinitions | [static]
MESSAGE_HEADER_FLAGS_COMPRESSED_SYMBOL_LENGTH | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderDefinitions | [static]
MESSAGE_HEADER_FLAGS_COMPRESSED_SYMBOL_OFFSET | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderDefinitions | [static]
MESSAGE_HEADER_FLAGS_US_EQUITY_OPTION_BIT_MASK (defined in Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderDefinitions) | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderDefinitions | [static]
MESSAGE_HEADER_FLAGS_US_EQUITY_OPTION_BIT_SHIFT (defined in Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderDefinitions) | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderDefinitions | [static]
MESSAGE_HEADER_FLAGS_US_EQUITY_OPTION_LENGTH | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderDefinitions | [static]
MESSAGE_HEADER_FLAGS_US_EQUITY_OPTION_OFFSET | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderDefinitions | [static]
MESSAGE_TYPE | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderDefinitions | [static]

Generated on Wed Oct 8 14:02:05 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator Member List

This is the complete list of members for Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator, including all inherited members.

CompositeAskStateToString() const | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator | [inline]
CompositeBidStateToString() const | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator | [inline]
CompositeUpdateIdToString() const | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator | [inline]
CompressedCombinedQuoteMessageHeaderValidator() | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator |
CompressedCombinedQuoteMessageHeaderValidator(const TableTemplateList &tableTemplateList, MessageValidator &messageValidator, Activ::ContentPlatform::Feed::MessageType messageType) | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator |
CompressedCombinedQuoteMessageHeaderValidator(const TableTemplateList &tableTemplateList) | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator |
DefaultRuleSetToString() const | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator |
EventTypeToString() const | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator |
GetCompositeAskState(CompressedCombinedQuoteMessageDefinitions::CompositeState &compositeAskState) const | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator |
GetCompositeBidState(CompressedCombinedQuoteMessageDefinitions::CompositeState &compositeBidState) const | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator |
GetCompositeUpdateId(UpdateId &compositeUpdateId) const | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator |
GetEventType(EventType &eventType) const | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator |
GetPermissionId(PermissionId &permissionId) const | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator |
GetSymbol(std::string &symbol) const | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator |
GetTableNumber(TableNo &tableNumber) const | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator |
GetTableTemplate(const TableTemplate *&pTableTemplate) const | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator |
GetUpdateId(UpdateId &updateId) const | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator |
Initialize(const TableTemplateList &tableTemplateList, MessageValidator &messageValidator, Activ::ContentPlatform::Feed::MessageType messageType) | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator |
Initialize(const TableTemplateList &tableTemplateList) | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator |
Initialize(MessageValidator &messageValidator, Activ::ContentPlatform::Feed::MessageType messageType) | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator |
IsComposite() const | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator |
IsCompositeAsk() const | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator |
IsCompositeAskToString() const | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator | [inline]
IsCompositeBid() const | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator |
IsCompositeBidToString() const | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator | [inline]
IsCompositeToString() const | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator | [inline]
IsInitialized() const | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator |
m_compositeAskState | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessage | [protected]
m_compositeBidState | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessage | [protected]
m_compositeUpdateId | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessage | [protected]
m_isComposite | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessage | [protected]
m_isCompositeAsk | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessage | [protected]
m_isCompositeBid | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessage | [protected]
m_permissionId | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessage | [protected]
m_symbol | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessage | [protected]
m_tableNumber | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessage | [protected]
m_updateId | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessage | [protected]
PermissionIdToString() const | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator | [inline]
Reset() | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator |
SymbolToString() const | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator | [inline]
TableTemplateIdToString() const | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator | [inline]
TableTemplateNameToString() const | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator | [inline]
ToString() const | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator | [inline]
UpdateIdToString() const | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator | [inline]
ValidateCompressedCombinedQuote(MessageValidator &messageValidator) | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessage | [inline]
~CompressedCombinedQuoteMessageHeaderValidator() | Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator |

Generated on Wed Oct 8 14:02:05 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::CompressedMessage Member List

This is the complete list of members for Activ::ContentPlatform::Feed::CompressedMessage, including all inherited members.

m_compositeUpdateId | Activ::ContentPlatform::Feed::CompressedMessage | [protected]
m_isComposite | Activ::ContentPlatform::Feed::CompressedMessage | [protected]
m_isDelete | Activ::ContentPlatform::Feed::CompressedMessage | [protected]
m_permissionId | Activ::ContentPlatform::Feed::CompressedMessage | [protected]
m_symbol | Activ::ContentPlatform::Feed::CompressedMessage | [protected]
m_tableNumber | Activ::ContentPlatform::Feed::CompressedMessage | [protected]
m_updateId | Activ::ContentPlatform::Feed::CompressedMessage | [protected]
ValidateCompressed(MessageValidator &messageValidator) | Activ::ContentPlatform::Feed::CompressedMessage | [inline]

Generated on Wed Oct 8 14:02:05 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::CompressedMessageDefinitions Member List

This is the complete list of members for Activ::ContentPlatform::Feed::CompressedMessageDefinitions, including all inherited members.

CompressedNumeratorLength typedef | Activ::ContentPlatform::Feed::CompressedMessageDefinitions |
FIELD_HEADER_BIT_MASK (defined in Activ::ContentPlatform::Feed::CompressedMessageDefinitions) | Activ::ContentPlatform::Feed::CompressedMessageDefinitions | [static]
FIELD_HEADER_LENGTH (defined in Activ::ContentPlatform::Feed::CompressedMessageDefinitions) | Activ::ContentPlatform::Feed::CompressedMessageDefinitions | [static]
FIELD_HEADERS_PER_BYTE (defined in Activ::ContentPlatform::Feed::CompressedMessageDefinitions) | Activ::ContentPlatform::Feed::CompressedMessageDefinitions | [static]
FIELD_STATE_DIFFERENT enum value (defined in Activ::ContentPlatform::Feed::CompressedMessageDefinitions) | Activ::ContentPlatform::Feed::CompressedMessageDefinitions |
FIELD_STATE_SAME_AS_PREVIOUS enum value (defined in Activ::ContentPlatform::Feed::CompressedMessageDefinitions) | Activ::ContentPlatform::Feed::CompressedMessageDefinitions |
FIELD_STATE_SAME_AS_TWIN enum value (defined in Activ::ContentPlatform::Feed::CompressedMessageDefinitions) | Activ::ContentPlatform::Feed::CompressedMessageDefinitions |
FIELD_STATE_UNDEFINED enum value (defined in Activ::ContentPlatform::Feed::CompressedMessageDefinitions) | Activ::ContentPlatform::Feed::CompressedMessageDefinitions |
FieldState enum name | Activ::ContentPlatform::Feed::CompressedMessageDefinitions |
GetCompressedNumeratorLength(const size_t numeratorLength) | Activ::ContentPlatform::Feed::CompressedMessageDefinitions | [inline, static]
GetHeader(const TableNo tableNumber, const bool isPermissionIdDefined, const bool isCompressedSymbolDefined) | Activ::ContentPlatform::Feed::CompressedMessageDefinitions | [inline, static]
GetNumeratorLength(const CompressedNumeratorLength compressedNumeratorLength) | Activ::ContentPlatform::Feed::CompressedMessageDefinitions | [inline, static]
GetShortTableNumber(const Header header, TableNo &tableNumber) | Activ::ContentPlatform::Feed::CompressedMessageDefinitions | [inline, static]
Header typedef | Activ::ContentPlatform::Feed::CompressedMessageDefinitions |
HEADER_COMPRESSED_SYMBOL_DEFINED_BIT_MASK (defined in Activ::ContentPlatform::Feed::CompressedMessageDefinitions) | Activ::ContentPlatform::Feed::CompressedMessageDefinitions | [static]
HEADER_COMPRESSED_SYMBOL_DEFINED_BIT_SHIFT (defined in Activ::ContentPlatform::Feed::CompressedMessageDefinitions) | Activ::ContentPlatform::Feed::CompressedMessageDefinitions | [static]
HEADER_FLAGS_COMPRESSED_SYMBOL_DEFINED_LENGTH (defined in Activ::ContentPlatform::Feed::CompressedMessageDefinitions) | Activ::ContentPlatform::Feed::CompressedMessageDefinitions | [static]
HEADER_FLAGS_COMPRESSED_SYMBOL_DEFINED_OFFSET (defined in Activ::ContentPlatform::Feed::CompressedMessageDefinitions) | Activ::ContentPlatform::Feed::CompressedMessageDefinitions | [static]
HEADER_FLAGS_PERMISSION_ID_DEFINED_LENGTH (defined in Activ::ContentPlatform::Feed::CompressedMessageDefinitions) | Activ::ContentPlatform::Feed::CompressedMessageDefinitions | [static]
HEADER_FLAGS_PERMISSION_ID_DEFINED_OFFSET (defined in Activ::ContentPlatform::Feed::CompressedMessageDefinitions) | Activ::ContentPlatform::Feed::CompressedMessageDefinitions | [static]
HEADER_FLAGS_RESERVED_LENGTH (defined in Activ::ContentPlatform::Feed::CompressedMessageDefinitions) | Activ::ContentPlatform::Feed::CompressedMessageDefinitions | [static]
HEADER_FLAGS_RESERVED_OFFSET (defined in Activ::ContentPlatform::Feed::CompressedMessageDefinitions) | Activ::ContentPlatform::Feed::CompressedMessageDefinitions | [static]
HEADER_FLAGS_SHORT_TABLE_NUMBER_DEFINED_LENGTH (defined in Activ::ContentPlatform::Feed::CompressedMessageDefinitions) | Activ::ContentPlatform::Feed::CompressedMessageDefinitions | [static]
HEADER_FLAGS_SHORT_TABLE_NUMBER_DEFINED_OFFSET (defined in Activ::ContentPlatform::Feed::CompressedMessageDefinitions) | Activ::ContentPlatform::Feed::CompressedMessageDefinitions | [static]
HEADER_FLAGS_SHORT_TABLE_NUMBER_LENGTH (defined in Activ::ContentPlatform::Feed::CompressedMessageDefinitions) | Activ::ContentPlatform::Feed::CompressedMessageDefinitions | [static]
HEADER_FLAGS_SHORT_TABLE_NUMBER_OFFSET (defined in Activ::ContentPlatform::Feed::CompressedMessageDefinitions) | Activ::ContentPlatform::Feed::CompressedMessageDefinitions | [static]
HEADER_PERMISSION_ID_DEFINED_BIT_MASK (defined in Activ::ContentPlatform::Feed::CompressedMessageDefinitions) | Activ::ContentPlatform::Feed::CompressedMessageDefinitions | [static]
HEADER_PERMISSION_ID_DEFINED_BIT_SHIFT (defined in Activ::ContentPlatform::Feed::CompressedMessageDefinitions) | Activ::ContentPlatform::Feed::CompressedMessageDefinitions | [static]
HEADER_SHORT_TABLE_NUMBER_BIT_MASK (defined in Activ::ContentPlatform::Feed::CompressedMessageDefinitions) | Activ::ContentPlatform::Feed::CompressedMessageDefinitions | [static]
HEADER_SHORT_TABLE_NUMBER_BIT_SHIFT (defined in Activ::ContentPlatform::Feed::CompressedMessageDefinitions) | Activ::ContentPlatform::Feed::CompressedMessageDefinitions | [static]
HEADER_SHORT_TABLE_NUMBER_DEFINED_BIT_MASK (defined in Activ::ContentPlatform::Feed::CompressedMessageDefinitions) | Activ::ContentPlatform::Feed::CompressedMessageDefinitions | [static]
HEADER_SHORT_TABLE_NUMBER_DEFINED_BIT_SHIFT (defined in Activ::ContentPlatform::Feed::CompressedMessageDefinitions) | Activ::ContentPlatform::Feed::CompressedMessageDefinitions | [static]
IsCompressedSymbolDefined(const Header header) | Activ::ContentPlatform::Feed::CompressedMessageDefinitions | [inline, static]
IsPermissionIdDefined(const Header header) | Activ::ContentPlatform::Feed::CompressedMessageDefinitions | [inline, static]
IsShortTableNumber(const TableNo tableNumber) | Activ::ContentPlatform::Feed::CompressedMessageDefinitions | [inline, static]
IsShortTableNumberDefined(const Header header) | Activ::ContentPlatform::Feed::CompressedMessageDefinitions | [inline, static]
NUMERATOR_LENGTH_16_BITS | Activ::ContentPlatform::Feed::CompressedMessageDefinitions | [static]
NUMERATOR_LENGTH_32_BITS | Activ::ContentPlatform::Feed::CompressedMessageDefinitions | [static]
NUMERATOR_LENGTH_64_BITS | Activ::ContentPlatform::Feed::CompressedMessageDefinitions | [static]
NUMERATOR_LENGTH_8_BITS | Activ::ContentPlatform::Feed::CompressedMessageDefinitions | [static]

Generated on Wed Oct 8 14:02:05 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::CompressedMessageDefinitions::FieldHeaderBuilder Member List

This is the complete list of members for Activ::ContentPlatform::Feed::CompressedMessageDefinitions::FieldHeaderBuilder, including all inherited members.

Append(byte_t *&pMessage) | Activ::ContentPlatform::Feed::CompressedMessageDefinitions::FieldHeaderBuilder | [inline]
FieldHeaderBuilder() | Activ::ContentPlatform::Feed::CompressedMessageDefinitions::FieldHeaderBuilder | [inline]
Initialize(const size_t nFieldHeaders, const size_t startingBitOffset=0) | Activ::ContentPlatform::Feed::CompressedMessageDefinitions::FieldHeaderBuilder | [inline]
Serialize(const FieldState fieldState) | Activ::ContentPlatform::Feed::CompressedMessageDefinitions::FieldHeaderBuilder | [inline]
Serialize(const CompressedNumeratorLength compressedNumeratorLength) | Activ::ContentPlatform::Feed::CompressedMessageDefinitions::FieldHeaderBuilder | [inline]

Generated on Wed Oct 8 14:02:05 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::CompressedMessageDefinitions::FieldHeaderValidator Member List

This is the complete list of members for Activ::ContentPlatform::Feed::CompressedMessageDefinitions::FieldHeaderValidator, including all inherited members.

Deserialize(FieldState &fieldState) | Activ::ContentPlatform::Feed::CompressedMessageDefinitions::FieldHeaderValidator | [inline]
Deserialize(CompressedNumeratorLength &compressedNumeratorLength) | Activ::ContentPlatform::Feed::CompressedMessageDefinitions::FieldHeaderValidator | [inline]
FieldHeaderValidator() | Activ::ContentPlatform::Feed::CompressedMessageDefinitions::FieldHeaderValidator | [inline]
Initialize(const size_t nFieldHeaders, const size_t startingBitOffset=0) | Activ::ContentPlatform::Feed::CompressedMessageDefinitions::FieldHeaderValidator | [inline]
Validate(MessageValidator &messageValidator) | Activ::ContentPlatform::Feed::CompressedMessageDefinitions::FieldHeaderValidator | [inline]

Generated on Wed Oct 8 14:02:05 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::CompressedMessageDefinitions::FieldSpecification Member List

This is the complete list of members for Activ::ContentPlatform::Feed::CompressedMessageDefinitions::FieldSpecification, including all inherited members.

FieldSpecification(const FieldId fieldId, const bool isSizeField, const FieldId twinFieldId=FID_UNDEFINED) | Activ::ContentPlatform::Feed::CompressedMessageDefinitions::FieldSpecification | [inline]
GetNumberOfFieldHeaders() const | Activ::ContentPlatform::Feed::CompressedMessageDefinitions::FieldSpecification | [inline]
m_fieldId | Activ::ContentPlatform::Feed::CompressedMessageDefinitions::FieldSpecification |
m_isSizeField | Activ::ContentPlatform::Feed::CompressedMessageDefinitions::FieldSpecification |
m_twinFieldId | Activ::ContentPlatform::Feed::CompressedMessageDefinitions::FieldSpecification |

Generated on Wed Oct 8 14:02:05 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::CompressedMessageHeaderDefinitions Member List

This is the complete list of members for Activ::ContentPlatform::Feed::CompressedMessageHeaderDefinitions, including all inherited members.

GetMessageHeader(const bool isDelete, const bool isComposite, const MessageType messageType) | Activ::ContentPlatform::Feed::CompressedMessageHeaderDefinitions | [inline, static]
IsComposite(const MessageHeaderDefinitions::MessageHeader messageHeader) | Activ::ContentPlatform::Feed::CompressedMessageHeaderDefinitions | [inline, static]
IsDelete(const MessageHeaderDefinitions::MessageHeader messageHeader) | Activ::ContentPlatform::Feed::CompressedMessageHeaderDefinitions | [inline, static]
IsValidMessageType(const MessageHeaderDefinitions::MessageHeader messageHeader, const MessageType messageType) | Activ::ContentPlatform::Feed::CompressedMessageHeaderDefinitions | [inline, static]
MAX_SYMBOL_LENGTH | Activ::ContentPlatform::Feed::CompressedMessageHeaderDefinitions | [static]
MESSAGE_HEADER_FLAGS_COMPOSITE_BIT_MASK (defined in Activ::ContentPlatform::Feed::CompressedMessageHeaderDefinitions) | Activ::ContentPlatform::Feed::CompressedMessageHeaderDefinitions | [static]
MESSAGE_HEADER_FLAGS_COMPOSITE_BIT_SHIFT (defined in Activ::ContentPlatform::Feed::CompressedMessageHeaderDefinitions) | Activ::ContentPlatform::Feed::CompressedMessageHeaderDefinitions | [static]
MESSAGE_HEADER_FLAGS_COMPOSITE_LENGTH | Activ::ContentPlatform::Feed::CompressedMessageHeaderDefinitions | [static]
MESSAGE_HEADER_FLAGS_COMPOSITE_OFFSET | Activ::ContentPlatform::Feed::CompressedMessageHeaderDefinitions | [static]
MESSAGE_HEADER_FLAGS_DELETE_BIT_MASK (defined in Activ::ContentPlatform::Feed::CompressedMessageHeaderDefinitions) | Activ::ContentPlatform::Feed::CompressedMessageHeaderDefinitions | [static]
MESSAGE_HEADER_FLAGS_DELETE_BIT_SHIFT (defined in Activ::ContentPlatform::Feed::CompressedMessageHeaderDefinitions) | Activ::ContentPlatform::Feed::CompressedMessageHeaderDefinitions | [static]
MESSAGE_HEADER_FLAGS_DELETE_LENGTH | Activ::ContentPlatform::Feed::CompressedMessageHeaderDefinitions | [static]
MESSAGE_HEADER_FLAGS_DELETE_OFFSET | Activ::ContentPlatform::Feed::CompressedMessageHeaderDefinitions | [static]

Generated on Wed Oct 8 14:02:06 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator Member List

This is the complete list of members for Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator, including all inherited members.

CompositeUpdateIdToString() const | Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator | [inline]
CompressedMessageHeaderValidator() | Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator |
CompressedMessageHeaderValidator(const TableTemplateList &tableTemplateList, MessageValidator &messageValidator, Activ::ContentPlatform::Feed::MessageType messageType) | Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator |
CompressedMessageHeaderValidator(const TableTemplateList &tableTemplateList) | Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator |
DefaultRuleSetToString() const | Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator |
EventTypeToString() const | Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator |
GetCompositeUpdateId(UpdateId &compositeUpdateId) const | Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator |
GetEventType(EventType &eventType) const | Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator |
GetPermissionId(PermissionId &permissionId) const | Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator |
GetSymbol(std::string &symbol) const | Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator |
GetTableNumber(TableNo &tableNumber) const | Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator |
GetTableTemplate(const TableTemplate *&pTableTemplate) const | Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator |
GetUpdateId(UpdateId &updateId) const | Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator |
Initialize(const TableTemplateList &tableTemplateList, MessageValidator &messageValidator, Activ::ContentPlatform::Feed::MessageType messageType) | Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator |
Initialize(const TableTemplateList &tableTemplateList) | Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator |
Initialize(MessageValidator &messageValidator, Activ::ContentPlatform::Feed::MessageType messageType) | Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator |
IsComposite() const | Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator |
IsCompositeToString() const | Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator | [inline]
IsDelete() const | Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator |
IsDeleteToString() const | Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator | [inline]
IsInitialized() const | Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator |
m_compositeUpdateId | Activ::ContentPlatform::Feed::CompressedMessage | [protected]
m_isComposite | Activ::ContentPlatform::Feed::CompressedMessage | [protected]
m_isDelete | Activ::ContentPlatform::Feed::CompressedMessage | [protected]
m_permissionId | Activ::ContentPlatform::Feed::CompressedMessage | [protected]
m_symbol | Activ::ContentPlatform::Feed::CompressedMessage | [protected]
m_tableNumber | Activ::ContentPlatform::Feed::CompressedMessage | [protected]
m_updateId | Activ::ContentPlatform::Feed::CompressedMessage | [protected]
PermissionIdToString() const | Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator | [inline]
Reset() | Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator |
SymbolToString() const | Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator | [inline]
TableTemplateIdToString() const | Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator | [inline]
TableTemplateNameToString() const | Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator | [inline]
ToString() const | Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator | [inline]
UpdateIdToString() const | Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator | [inline]
ValidateCompressed(MessageValidator &messageValidator) | Activ::ContentPlatform::Feed::CompressedMessage | [inline]
~CompressedMessageHeaderValidator() | Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator |

Generated on Wed Oct 8 14:02:06 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::CompressedSymbol Member List

This is the complete list of members for Activ::ContentPlatform::Feed::CompressedSymbol, including all inherited members.

Deserialize(const TableNo tableNumber, MessageValidator &messageValidator, std::string &symbol) | Activ::ContentPlatform::Feed::CompressedSymbol | [inline, static]
Serialize(const Feed::TableNo tableNumber, byte_t *&pMessage, const std::string &symbol) | Activ::ContentPlatform::Feed::CompressedSymbol | [inline, static]

Generated on Wed Oct 8 14:02:06 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::CompressedUsEquityOptionSymbol Member List

This is the complete list of members for Activ::ContentPlatform::Feed::CompressedUsEquityOptionSymbol, including all inherited members.

Deserialize(MessageValidator &messageValidator, std::string &symbol) | Activ::ContentPlatform::Feed::CompressedUsEquityOptionSymbol | [static]
Serialize(byte_t *&pMessage, const std::string &symbol) | Activ::ContentPlatform::Feed::CompressedUsEquityOptionSymbol | [static]

Generated on Wed Oct 8 14:02:06 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::CopyOnReset Member List

This is the complete list of members for Activ::ContentPlatform::Feed::CopyOnReset, including all inherited members.

CopyOnReset() | Activ::ContentPlatform::Feed::CopyOnReset | [inline]
m_copyIfUndefined | Activ::ContentPlatform::Feed::CopyOnReset |
m_source | Activ::ContentPlatform::Feed::CopyOnReset |
m_target | Activ::ContentPlatform::Feed::CopyOnReset |
operator!=(const CopyOnReset &rhs) const | Activ::ContentPlatform::Feed::CopyOnReset | [inline]
operator==(const CopyOnReset &rhs) const | Activ::ContentPlatform::Feed::CopyOnReset | [inline]

Generated on Wed Oct 8 14:02:06 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::EntityTypeHelper Member List

This is the complete list of members for Activ::ContentPlatform::Feed::EntityTypeHelper, including all inherited members.

EntityTypeHelper() | Activ::ContentPlatform::Feed::EntityTypeHelper | [inline]
EntityTypeHelper(const EntityType entityType, const char *const pName, const char *const pCodeIdentifier) | Activ::ContentPlatform::Feed::EntityTypeHelper | [inline]
m_codeIdentifier | Activ::ContentPlatform::Feed::EntityTypeHelper |
m_entityType | Activ::ContentPlatform::Feed::EntityTypeHelper |
m_name | Activ::ContentPlatform::Feed::EntityTypeHelper |

Generated on Wed Oct 8 14:02:06 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::EventTypeHelper Member List

This is the complete list of members for Activ::ContentPlatform::Feed::EventTypeHelper, including all inherited members.

EventTypeHelper() | Activ::ContentPlatform::Feed::EventTypeHelper | [inline]
EventTypeHelper(const EventType eventType, const char *const pName, const char *const pCodeIdentifier) | Activ::ContentPlatform::Feed::EventTypeHelper | [inline]
m_codeIdentifier | Activ::ContentPlatform::Feed::EventTypeHelper |
m_eventType | Activ::ContentPlatform::Feed::EventTypeHelper |
m_name | Activ::ContentPlatform::Feed::EventTypeHelper |

Generated on Wed Oct 8 14:02:06 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::Field Member List

This is the complete list of members for Activ::ContentPlatform::Feed::Field, including all inherited members.

Field() | Activ::ContentPlatform::Feed::Field |
Field(const Specification &specification) | Activ::ContentPlatform::Feed::Field |
GetAmfFieldIndex() const | Activ::ContentPlatform::Feed::Field | [inline]
GetAmfRowIndex() const | Activ::ContentPlatform::Feed::Field | [inline]
GetAmfRowOffset() const | Activ::ContentPlatform::Feed::Field | [inline]
GetCodeIdentifier() const | Activ::ContentPlatform::Feed::Field | [inline]
GetDescription() const | Activ::ContentPlatform::Feed::Field | [inline]
GetId() const | Activ::ContentPlatform::Feed::Field | [inline]
GetMaxLength() const | Activ::ContentPlatform::Feed::Field | [inline]
GetName() const | Activ::ContentPlatform::Feed::Field | [inline]
GetType() const | Activ::ContentPlatform::Feed::Field | [inline]
GetUiHeading() | Activ::ContentPlatform::Feed::Field | [static]
IsAmfField() const | Activ::ContentPlatform::Feed::Field | [inline]
operator!=(const Field &rhs) const | Activ::ContentPlatform::Feed::Field |
operator=(const Field &rhs) | Activ::ContentPlatform::Feed::Field |
operator==(const Field &rhs) const | Activ::ContentPlatform::Feed::Field |
ToString() const | Activ::ContentPlatform::Feed::Field |
~Field() | Activ::ContentPlatform::Feed::Field |

Generated on Wed Oct 8 14:02:06 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::Field::Specification Member List

This is the complete list of members for Activ::ContentPlatform::Feed::Field::Specification, including all inherited members.

m_amfFieldIndex | Activ::ContentPlatform::Feed::Field::Specification
m_amfRowIndex | Activ::ContentPlatform::Feed::Field::Specification
m_amfRowOffset | Activ::ContentPlatform::Feed::Field::Specification
m_codeIdentifier | Activ::ContentPlatform::Feed::Field::Specification
m_description | Activ::ContentPlatform::Feed::Field::Specification
m_id | Activ::ContentPlatform::Feed::Field::Specification
m_isAmfField | Activ::ContentPlatform::Feed::Field::Specification
m_maxLength | Activ::ContentPlatform::Feed::Field::Specification
m_name | Activ::ContentPlatform::Feed::Field::Specification
m_type | Activ::ContentPlatform::Feed::Field::Specification
Specification(const FieldId id, const std::string &name, const std::string &codeIdentifier, const std::string &description, const FieldType type, const size_t maxLength, const bool isAmfField=false, const uint8_t amfRowIndex=0, const uint8_t amfRowOffset=0, const uint8_t amfFieldIndex=0) | Activ::ContentPlatform::Feed::Field::Specification

Generated on Wed Oct 8 14:02:06 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::FieldHeaderDefinitions Member List

This is the complete list of members for Activ::ContentPlatform::Feed::FieldHeaderDefinitions, including all inherited members.

FIELD_ID_LENGTH | Activ::ContentPlatform::Feed::FieldHeaderDefinitions | [static]
FIELD_ID_OFFSET | Activ::ContentPlatform::Feed::FieldHeaderDefinitions | [static]
FIELD_RESERVED_LENGTH | Activ::ContentPlatform::Feed::FieldHeaderDefinitions | [static]
FIELD_RESERVED_OFFSET | Activ::ContentPlatform::Feed::FieldHeaderDefinitions | [static]
FIELD_UNDEFINED_LENGTH | Activ::ContentPlatform::Feed::FieldHeaderDefinitions | [static]
FIELD_UNDEFINED_OFFSET | Activ::ContentPlatform::Feed::FieldHeaderDefinitions | [static]
FieldHeader typedef | Activ::ContentPlatform::Feed::FieldHeaderDefinitions |
GetFieldHeader(const FieldId fieldId, const bool isFieldDefined) | Activ::ContentPlatform::Feed::FieldHeaderDefinitions | [inline, static]
GetFieldId(const FieldHeader fieldHeader) | Activ::ContentPlatform::Feed::FieldHeaderDefinitions | [inline, static]
IsFieldDefined(const FieldHeader fieldHeader) | Activ::ContentPlatform::Feed::FieldHeaderDefinitions | [inline, static]

Generated on Wed Oct 8 14:02:06 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::Index::IndexFieldSpecification Member List

This is the complete list of members for Activ::ContentPlatform::Feed::Index::IndexFieldSpecification, including all inherited members.

IndexFieldSpecification(const FieldId id) | Activ::ContentPlatform::Feed::Index::IndexFieldSpecification
m_id | Activ::ContentPlatform::Feed::Index::IndexFieldSpecification

Generated on Wed Oct 8 14:02:06 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::Index::Specification Member List

This is the complete list of members for Activ::ContentPlatform::Feed::Index::Specification, including all inherited members.

m_indexFieldSpecificationList | Activ::ContentPlatform::Feed::Index::Specification
m_name | Activ::ContentPlatform::Feed::Index::Specification
m_number | Activ::ContentPlatform::Feed::Index::Specification
m_properties | Activ::ContentPlatform::Feed::Index::Specification
m_type | Activ::ContentPlatform::Feed::Index::Specification
Specification(const IndexNumber number, const std::string &name, const IndexType type, const IndexProperties properties, const IndexFieldSpecificationList &indexFieldSpecificationList) | Activ::ContentPlatform::Feed::Index::Specification

Generated on Wed Oct 8 14:02:06 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::IndexSpecification::Field Member List

This is the complete list of members for Activ::ContentPlatform::Feed::IndexSpecification::Field, including all inherited members.

Field() | Activ::ContentPlatform::Feed::IndexSpecification::Field | [inline]
Field(const FieldId fieldId, const uint8_t sequence=0, const uint16_t properties=0) | Activ::ContentPlatform::Feed::IndexSpecification::Field | [inline, explicit]
m_fieldId | Activ::ContentPlatform::Feed::IndexSpecification::Field |
m_properties | Activ::ContentPlatform::Feed::IndexSpecification::Field |
m_sequence | Activ::ContentPlatform::Feed::IndexSpecification::Field |

Generated on Wed Oct 8 14:02:06 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::MessageHeaderDefinitions Member List

This is the complete list of members for Activ::ContentPlatform::Feed::MessageHeaderDefinitions, including all inherited members.

FLAGS_BIT_MASK (defined in Activ::ContentPlatform::Feed::MessageHeaderDefinitions) | Activ::ContentPlatform::Feed::MessageHeaderDefinitions | [static]
FLAGS_BIT_SHIFT (defined in Activ::ContentPlatform::Feed::MessageHeaderDefinitions) | Activ::ContentPlatform::Feed::MessageHeaderDefinitions | [static]
FLAGS_LENGTH | Activ::ContentPlatform::Feed::MessageHeaderDefinitions | [static]
FLAGS_OFFSET | Activ::ContentPlatform::Feed::MessageHeaderDefinitions | [static]
GetFlags(const MessageHeader messageHeader) | Activ::ContentPlatform::Feed::MessageHeaderDefinitions | [inline, static]
GetMessageHeader(const uint32_t flags, const MessageType messageType) | Activ::ContentPlatform::Feed::MessageHeaderDefinitions | [inline, static]
GetMessageType(const MessageHeader messageHeader) | Activ::ContentPlatform::Feed::MessageHeaderDefinitions | [inline, static]
IsValidMessageType(const MessageHeader messageHeader, const MessageType messageType) | Activ::ContentPlatform::Feed::MessageHeaderDefinitions | [inline, static]
MESSAGE_TYPE_BIT_MASK (defined in Activ::ContentPlatform::Feed::MessageHeaderDefinitions) | Activ::ContentPlatform::Feed::MessageHeaderDefinitions | [static]
MESSAGE_TYPE_BIT_SHIFT (defined in Activ::ContentPlatform::Feed::MessageHeaderDefinitions) | Activ::ContentPlatform::Feed::MessageHeaderDefinitions | [static]
MESSAGE_TYPE_LENGTH | Activ::ContentPlatform::Feed::MessageHeaderDefinitions | [static]
MESSAGE_TYPE_OFFSET | Activ::ContentPlatform::Feed::MessageHeaderDefinitions | [static]
MessageHeader typedef | Activ::ContentPlatform::Feed::MessageHeaderDefinitions |

Generated on Wed Oct 8 14:02:06 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::PermissionIdHelper Member List

This is the complete list of members for Activ::ContentPlatform::Feed::PermissionIdHelper, including all inherited members.

m_codeIdentifier | Activ::ContentPlatform::Feed::PermissionIdHelper |
m_name | Activ::ContentPlatform::Feed::PermissionIdHelper |
m_permissionId | Activ::ContentPlatform::Feed::PermissionIdHelper |
PermissionIdHelper() | Activ::ContentPlatform::Feed::PermissionIdHelper | [inline]
PermissionIdHelper(const PermissionId permissionId, const char *const pName, const char *const pCodeIdentifier) | Activ::ContentPlatform::Feed::PermissionIdHelper | [inline]

Generated on Wed Oct 8 14:02:06 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::PermissionInfo Member List

This is the complete list of members for Activ::ContentPlatform::Feed::PermissionInfo, including all inherited members.

m_permissionLevelInfo | Activ::ContentPlatform::Feed::PermissionInfo
PermissionIdInfoMap typedef | Activ::ContentPlatform::Feed::PermissionInfo

Generated on Wed Oct 8 14:02:06 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::PermissionInfo::PermissionIdInfo Member List

This is the complete list of members for Activ::ContentPlatform::Feed::PermissionInfo::PermissionIdInfo, including all inherited members.

m_fieldIdList | Activ::ContentPlatform::Feed::PermissionInfo::PermissionIdInfo
m_name | Activ::ContentPlatform::Feed::PermissionInfo::PermissionIdInfo
m_type | Activ::ContentPlatform::Feed::PermissionInfo::PermissionIdInfo
Type enum name | Activ::ContentPlatform::Feed::PermissionInfo::PermissionIdInfo
TYPE_ALL_FIELDS enum value | Activ::ContentPlatform::Feed::PermissionInfo::PermissionIdInfo
TYPE_EXCLUDE_FIELDS enum value | Activ::ContentPlatform::Feed::PermissionInfo::PermissionIdInfo
TYPE_INCLUDE_FIELDS enum value | Activ::ContentPlatform::Feed::PermissionInfo::PermissionIdInfo

Generated on Wed Oct 8 14:02:06 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::RecordFieldListBuilder Member List

This is the complete list of members for Activ::ContentPlatform::Feed::RecordFieldListBuilder, including all inherited members.

AppendField(const FieldId fieldId, const IFieldType &iFieldType) | Activ::ContentPlatform::Feed::RecordFieldListBuilder
AppendField(const FieldId fieldId, const void *const pSerializedBody, const size_t serializedBodyLength) | Activ::ContentPlatform::Feed::RecordFieldListBuilder
AppendUndefinedField(const FieldId fieldId) | Activ::ContentPlatform::Feed::RecordFieldListBuilder
Clear() | Activ::ContentPlatform::Feed::RecordFieldListBuilder
Initialize(const TableTemplate &tableTemplate, MessageBuilder &messageBuilder) | Activ::ContentPlatform::Feed::RecordFieldListBuilder
IsInitialized() const | Activ::ContentPlatform::Feed::RecordFieldListBuilder
RecordFieldListBuilder() | Activ::ContentPlatform::Feed::RecordFieldListBuilder
RecordFieldListBuilder(const TableTemplate &tableTemplate, MessageBuilder &messageBuilder) | Activ::ContentPlatform::Feed::RecordFieldListBuilder
Reset() | Activ::ContentPlatform::Feed::RecordFieldListBuilder
~RecordFieldListBuilder() | Activ::ContentPlatform::Feed::RecordFieldListBuilder

Generated on Wed Oct 8 14:02:06 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::RecordFieldListValidator Member List

This is the complete list of members for Activ::ContentPlatform::Feed::RecordFieldListValidator, including all inherited members.

Begin() const | Activ::ContentPlatform::Feed::RecordFieldListValidator |
Clear() | Activ::ContentPlatform::Feed::RecordFieldListValidator |
ContentsPrefixToString() | Activ::ContentPlatform::Feed::RecordFieldListValidator | [static]
End() const | Activ::ContentPlatform::Feed::RecordFieldListValidator |
FieldContentsToString(const IFieldType *pIFieldType) const | Activ::ContentPlatform::Feed::RecordFieldListValidator |
FieldIdToString(const FieldId &fieldId) const | Activ::ContentPlatform::Feed::RecordFieldListValidator |
FieldListTitleToString() | Activ::ContentPlatform::Feed::RecordFieldListValidator | [static]
GetField(const FieldId fieldId, const IFieldType *&pIFieldType) const | Activ::ContentPlatform::Feed::RecordFieldListValidator |
Initialize(const TableTemplate &tableTemplate, MessageValidator &messageValidator, const bool shouldIgnoreUndefinedMissingFields=false) | Activ::ContentPlatform::Feed::RecordFieldListValidator |
IsInitialized() const | Activ::ContentPlatform::Feed::RecordFieldListValidator |
NamePrefixToString() | Activ::ContentPlatform::Feed::RecordFieldListValidator | [static]
RecordFieldListValidator() | Activ::ContentPlatform::Feed::RecordFieldListValidator |
RecordFieldListValidator(const TableTemplate &tableTemplate, MessageValidator &messageValidator, const bool shouldIgnoreUndefinedMissingFields=false) | Activ::ContentPlatform::Feed::RecordFieldListValidator |
Reset() | Activ::ContentPlatform::Feed::RecordFieldListValidator |
ToString() const | Activ::ContentPlatform::Feed::RecordFieldListValidator |
UndefinedFieldContentsToString() | Activ::ContentPlatform::Feed::RecordFieldListValidator | [static]
~RecordFieldListValidator() | Activ::ContentPlatform::Feed::RecordFieldListValidator |

Generated on Wed Oct 8 14:02:06 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::RecordFieldListValidator::ConstIterator Member List

This is the complete list of members for Activ::ContentPlatform::Feed::RecordFieldListValidator::ConstIterator, including all inherited members.

ConstIterator() | Activ::ContentPlatform::Feed::RecordFieldListValidator::ConstIterator | [inline]
GetField() const | Activ::ContentPlatform::Feed::RecordFieldListValidator::ConstIterator | [inline]
GetFieldId() const | Activ::ContentPlatform::Feed::RecordFieldListValidator::ConstIterator | [inline]
operator!=(const ConstIterator &rhs) const | Activ::ContentPlatform::Feed::RecordFieldListValidator::ConstIterator | [inline]
operator++() | Activ::ContentPlatform::Feed::RecordFieldListValidator::ConstIterator | [inline]
operator++(int) | Activ::ContentPlatform::Feed::RecordFieldListValidator::ConstIterator | [inline]
operator==(const ConstIterator &rhs) const | Activ::ContentPlatform::Feed::RecordFieldListValidator::ConstIterator | [inline]
RecordFieldListValidator (defined in Activ::ContentPlatform::Feed::RecordFieldListValidator::ConstIterator) | Activ::ContentPlatform::Feed::RecordFieldListValidator::ConstIterator | [friend]

Generated on Wed Oct 8 14:02:06 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::RecordKeyFieldListBuilder Member List

This is the complete list of members for Activ::ContentPlatform::Feed::RecordKeyFieldListBuilder, including all inherited members.

AppendField(const FieldId fieldId, const IFieldType &iFieldType) | Activ::ContentPlatform::Feed::RecordKeyFieldListBuilder
AppendField(const FieldId fieldId, const void *const pSerializedBody, const size_t serializedBodyLength) | Activ::ContentPlatform::Feed::RecordKeyFieldListBuilder
AppendUndefinedField(const FieldId fieldId) | Activ::ContentPlatform::Feed::RecordKeyFieldListBuilder
Clear() | Activ::ContentPlatform::Feed::RecordKeyFieldListBuilder
Initialize(const Index &index, MessageBuilder &messageBuilder) | Activ::ContentPlatform::Feed::RecordKeyFieldListBuilder
IsComplete() const | Activ::ContentPlatform::Feed::RecordKeyFieldListBuilder
IsInitialized() const | Activ::ContentPlatform::Feed::RecordKeyFieldListBuilder
RecordKeyFieldListBuilder() | Activ::ContentPlatform::Feed::RecordKeyFieldListBuilder
RecordKeyFieldListBuilder(const Index &index, MessageBuilder &messageBuilder) | Activ::ContentPlatform::Feed::RecordKeyFieldListBuilder
Reset() | Activ::ContentPlatform::Feed::RecordKeyFieldListBuilder
~RecordKeyFieldListBuilder() | Activ::ContentPlatform::Feed::RecordKeyFieldListBuilder

Generated on Wed Oct 8 14:02:06 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::RecordKeyFieldListValidator Member List

This is the complete list of members for Activ::ContentPlatform::Feed::RecordKeyFieldListValidator, including all inherited members.

Begin() const | Activ::ContentPlatform::Feed::RecordKeyFieldListValidator |
Clear() | Activ::ContentPlatform::Feed::RecordKeyFieldListValidator |
ContentsPrefixToString() | Activ::ContentPlatform::Feed::RecordKeyFieldListValidator | [static]
End() const | Activ::ContentPlatform::Feed::RecordKeyFieldListValidator |
FieldContentsToString(const IFieldType *pIFieldType) const | Activ::ContentPlatform::Feed::RecordKeyFieldListValidator |
FieldIdToString(const FieldId &fieldId) const | Activ::ContentPlatform::Feed::RecordKeyFieldListValidator |
FieldNameToString(const FieldId &fieldId) const | Activ::ContentPlatform::Feed::RecordKeyFieldListValidator |
GetField(const FieldId fieldId, const IFieldType *&pIFieldType) const | Activ::ContentPlatform::Feed::RecordKeyFieldListValidator |
Initialize(const Index &index, MessageValidator &messageValidator) | Activ::ContentPlatform::Feed::RecordKeyFieldListValidator |
IsInitialized() const | Activ::ContentPlatform::Feed::RecordKeyFieldListValidator |
KeyFieldListTitleToString() | Activ::ContentPlatform::Feed::RecordKeyFieldListValidator | [static]
NamePrefixToString() | Activ::ContentPlatform::Feed::RecordKeyFieldListValidator | [static]
RecordKeyFieldListValidator() | Activ::ContentPlatform::Feed::RecordKeyFieldListValidator |
RecordKeyFieldListValidator(const Index &index, MessageValidator &messageValidator) | Activ::ContentPlatform::Feed::RecordKeyFieldListValidator |
Reset() | Activ::ContentPlatform::Feed::RecordKeyFieldListValidator |
ToString() const | Activ::ContentPlatform::Feed::RecordKeyFieldListValidator |
UndefinedFieldContentsToString() | Activ::ContentPlatform::Feed::RecordKeyFieldListValidator | [static]
~RecordKeyFieldListValidator() | Activ::ContentPlatform::Feed::RecordKeyFieldListValidator |

Generated on Wed Oct 8 14:02:06 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::RecordKeyFieldListValidator::ConstIterator Member List

This is the complete list of members for Activ::ContentPlatform::Feed::RecordKeyFieldListValidator::ConstIterator, including all inherited members.

ConstIterator() | Activ::ContentPlatform::Feed::RecordKeyFieldListValidator::ConstIterator | [inline]
GetField() const | Activ::ContentPlatform::Feed::RecordKeyFieldListValidator::ConstIterator | [inline]
GetFieldId() const | Activ::ContentPlatform::Feed::RecordKeyFieldListValidator::ConstIterator | [inline]
operator!=(const ConstIterator &rhs) const | Activ::ContentPlatform::Feed::RecordKeyFieldListValidator::ConstIterator | [inline]
operator++() | Activ::ContentPlatform::Feed::RecordKeyFieldListValidator::ConstIterator | [inline]
operator++(int) | Activ::ContentPlatform::Feed::RecordKeyFieldListValidator::ConstIterator | [inline]
operator==(const ConstIterator &rhs) const | Activ::ContentPlatform::Feed::RecordKeyFieldListValidator::ConstIterator | [inline]
RecordKeyFieldListValidator (defined in Activ::ContentPlatform::Feed::RecordKeyFieldListValidator::ConstIterator) | Activ::ContentPlatform::Feed::RecordKeyFieldListValidator::ConstIterator | [friend]

Generated on Wed Oct 8 14:02:06 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::RecordMessageBuilder Member List

This is the complete list of members for Activ::ContentPlatform::Feed::RecordMessageBuilder, including all inherited members.

AppendField(const FieldId fieldId, const IFieldType &iFieldType) | Activ::ContentPlatform::Feed::RecordMessageBuilder
AppendField(const FieldId fieldId, const void *const pSerializedBody, const size_t serializedBodyLength) | Activ::ContentPlatform::Feed::RecordMessageBuilder
AppendHeader(const bool isDelete, const bool isRefresh, const TableId tableId, const UpdateId updateId, const PermissionId permissionId, const EventType eventType) | Activ::ContentPlatform::Feed::RecordMessageBuilder
AppendIndexNumber(const IndexNumber indexNumber) | Activ::ContentPlatform::Feed::RecordMessageBuilder
AppendKeyField(const FieldId fieldId, const IFieldType &iFieldType) | Activ::ContentPlatform::Feed::RecordMessageBuilder
AppendKeyField(const FieldId fieldId, const void *const pSerializedBody, const size_t serializedBodyLength) | Activ::ContentPlatform::Feed::RecordMessageBuilder
AppendUndefinedField(const FieldId fieldId) | Activ::ContentPlatform::Feed::RecordMessageBuilder
AppendUndefinedKeyField(const FieldId fieldId) | Activ::ContentPlatform::Feed::RecordMessageBuilder
Initialize(const TableTemplateList &tableTemplateList, MessageBuilder &messageBuilder) | Activ::ContentPlatform::Feed::RecordMessageBuilder
Initialize(const TableTemplateList &tableTemplateList) | Activ::ContentPlatform::Feed::RecordMessageBuilder
Initialize(MessageBuilder &messageBuilder) | Activ::ContentPlatform::Feed::RecordMessageBuilder
IsInitialized() const | Activ::ContentPlatform::Feed::RecordMessageBuilder
RecordMessageBuilder() | Activ::ContentPlatform::Feed::RecordMessageBuilder
RecordMessageBuilder(const TableTemplateList &tableTemplateList, MessageBuilder &messageBuilder) | Activ::ContentPlatform::Feed::RecordMessageBuilder
RecordMessageBuilder(const TableTemplateList &tableTemplateList) | Activ::ContentPlatform::Feed::RecordMessageBuilder
Reset() | Activ::ContentPlatform::Feed::RecordMessageBuilder
~RecordMessageBuilder() | Activ::ContentPlatform::Feed::RecordMessageBuilder

Generated on Wed Oct 8 14:02:07 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::RecordMessageHeaderDefinitions Member List

This is the complete list of members for Activ::ContentPlatform::Feed::RecordMessageHeaderDefinitions, including all inherited members.

ExtractFlags(const Flags flags, bool &isExpandedFormat, bool &isDoNotAdd) | Activ::ContentPlatform::Feed::RecordMessageHeaderDefinitions | [inline, static]
Flags typedef | Activ::ContentPlatform::Feed::RecordMessageHeaderDefinitions |
FLAGS_DO_NOT_ADD_BIT_MASK (defined in Activ::ContentPlatform::Feed::RecordMessageHeaderDefinitions) | Activ::ContentPlatform::Feed::RecordMessageHeaderDefinitions | [static]
FLAGS_DO_NOT_ADD_BIT_SHIFT (defined in Activ::ContentPlatform::Feed::RecordMessageHeaderDefinitions) | Activ::ContentPlatform::Feed::RecordMessageHeaderDefinitions | [static]
FLAGS_DO_NOT_ADD_LENGTH | Activ::ContentPlatform::Feed::RecordMessageHeaderDefinitions | [static]
FLAGS_DO_NOT_ADD_OFFSET | Activ::ContentPlatform::Feed::RecordMessageHeaderDefinitions | [static]
FLAGS_EXPANDED_FORMAT_BIT_MASK (defined in Activ::ContentPlatform::Feed::RecordMessageHeaderDefinitions) | Activ::ContentPlatform::Feed::RecordMessageHeaderDefinitions | [static]
FLAGS_EXPANDED_FORMAT_BIT_SHIFT (defined in Activ::ContentPlatform::Feed::RecordMessageHeaderDefinitions) | Activ::ContentPlatform::Feed::RecordMessageHeaderDefinitions | [static]
FLAGS_EXPANDED_FORMAT_LENGTH | Activ::ContentPlatform::Feed::RecordMessageHeaderDefinitions | [static]
FLAGS_EXPANDED_FORMAT_OFFSET | Activ::ContentPlatform::Feed::RecordMessageHeaderDefinitions | [static]
GetFlags(const bool isExpandedFormat, const bool isDoNotAdd) | Activ::ContentPlatform::Feed::RecordMessageHeaderDefinitions | [inline, static]
GetMessageHeader(const bool isDelete, const bool isRefresh, const MessageType messageType=MESSAGE_TYPE) | Activ::ContentPlatform::Feed::RecordMessageHeaderDefinitions | [inline, static]
IsDelete(const MessageHeaderDefinitions::MessageHeader messageHeader) | Activ::ContentPlatform::Feed::RecordMessageHeaderDefinitions | [inline, static]
IsDoNotAdd(const Flags flags) | Activ::ContentPlatform::Feed::RecordMessageHeaderDefinitions | [inline, static]
IsExpandedFormat(const Flags flags) | Activ::ContentPlatform::Feed::RecordMessageHeaderDefinitions | [inline, static]
IsRefresh(const MessageHeaderDefinitions::MessageHeader messageHeader) | Activ::ContentPlatform::Feed::RecordMessageHeaderDefinitions | [inline, static]
IsValidMessageType(const MessageHeaderDefinitions::MessageHeader messageHeader) | Activ::ContentPlatform::Feed::RecordMessageHeaderDefinitions | [inline, static]
MESSAGE_HEADER_FLAGS_DELETE_BIT_MASK (defined in Activ::ContentPlatform::Feed::RecordMessageHeaderDefinitions) | Activ::ContentPlatform::Feed::RecordMessageHeaderDefinitions | [static]
MESSAGE_HEADER_FLAGS_DELETE_BIT_SHIFT (defined in Activ::ContentPlatform::Feed::RecordMessageHeaderDefinitions) | Activ::ContentPlatform::Feed::RecordMessageHeaderDefinitions | [static]
MESSAGE_HEADER_FLAGS_DELETE_LENGTH | Activ::ContentPlatform::Feed::RecordMessageHeaderDefinitions | [static]
MESSAGE_HEADER_FLAGS_DELETE_OFFSET | Activ::ContentPlatform::Feed::RecordMessageHeaderDefinitions | [static]
MESSAGE_HEADER_FLAGS_REFRESH_BIT_MASK (defined in Activ::ContentPlatform::Feed::RecordMessageHeaderDefinitions) | Activ::ContentPlatform::Feed::RecordMessageHeaderDefinitions | [static]
MESSAGE_HEADER_FLAGS_REFRESH_BIT_SHIFT (defined in Activ::ContentPlatform::Feed::RecordMessageHeaderDefinitions) | Activ::ContentPlatform::Feed::RecordMessageHeaderDefinitions | [static]
MESSAGE_HEADER_FLAGS_REFRESH_LENGTH | Activ::ContentPlatform::Feed::RecordMessageHeaderDefinitions | [static]
MESSAGE_HEADER_FLAGS_REFRESH_OFFSET | Activ::ContentPlatform::Feed::RecordMessageHeaderDefinitions | [static]
MESSAGE_TYPE | Activ::ContentPlatform::Feed::RecordMessageHeaderDefinitions | [static]

Generated on Wed Oct 8 14:02:07 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::RecordMessageHeaderValidator Member List

This is the complete list of members for Activ::ContentPlatform::Feed::RecordMessageHeaderValidator, including all inherited members.

BeginKeyField() const | Activ::ContentPlatform::Feed::RecordMessageHeaderValidator |
Clear() | Activ::ContentPlatform::Feed::RecordMessageHeaderValidator |
CompositeUpdateIdToString() const | Activ::ContentPlatform::Feed::RecordMessageHeaderValidator |
ConstKeyFieldIterator typedef | Activ::ContentPlatform::Feed::RecordMessageHeaderValidator |
EndKeyField() const | Activ::ContentPlatform::Feed::RecordMessageHeaderValidator |
EventTypeToString() const | Activ::ContentPlatform::Feed::RecordMessageHeaderValidator |
GetEventType(EventType &eventType) const | Activ::ContentPlatform::Feed::RecordMessageHeaderValidator |
GetIndexNumber(IndexNumber &indexNumber) const | Activ::ContentPlatform::Feed::RecordMessageHeaderValidator |
GetKeyField(const FieldId fieldId, const IFieldType *&pIFieldType) const | Activ::ContentPlatform::Feed::RecordMessageHeaderValidator |
GetPermissionId(PermissionId &permissionId) const | Activ::ContentPlatform::Feed::RecordMessageHeaderValidator |
GetTableTemplate(const TableTemplate *&pTableTemplate) const | Activ::ContentPlatform::Feed::RecordMessageHeaderValidator |
GetUpdateId(UpdateId &updateId) const | Activ::ContentPlatform::Feed::RecordMessageHeaderValidator |
IndexNameToString(const Index *pIndex) const | Activ::ContentPlatform::Feed::RecordMessageHeaderValidator |
IndexNumberToString() const | Activ::ContentPlatform::Feed::RecordMessageHeaderValidator |
Initialize(const TableTemplateList &tableTemplateList, MessageValidator &messageValidator, const bool shouldIgnoreMissingTableTemplate=false) | Activ::ContentPlatform::Feed::RecordMessageHeaderValidator |
Initialize(const TableTemplateList &tableTemplateList, const bool shouldIgnoreMissingTableTemplate=false) | Activ::ContentPlatform::Feed::RecordMessageHeaderValidator |
Initialize(MessageValidator &messageValidator) | Activ::ContentPlatform::Feed::RecordMessageHeaderValidator |
IsDelete() const | Activ::ContentPlatform::Feed::RecordMessageHeaderValidator |
IsDeleteToString() const | Activ::ContentPlatform::Feed::RecordMessageHeaderValidator |
IsInitialized() const | Activ::ContentPlatform::Feed::RecordMessageHeaderValidator |
IsRefresh() const | Activ::ContentPlatform::Feed::RecordMessageHeaderValidator |
IsRefreshToString() const | Activ::ContentPlatform::Feed::RecordMessageHeaderValidator |
PermissionIdToString() const | Activ::ContentPlatform::Feed::RecordMessageHeaderValidator |
RecordMessageHeaderValidator() | Activ::ContentPlatform::Feed::RecordMessageHeaderValidator |
RecordMessageHeaderValidator(const TableTemplateList &tableTemplateList, MessageValidator &messageValidator, const bool shouldIgnoreMissingTableTemplate=false) | Activ::ContentPlatform::Feed::RecordMessageHeaderValidator |
RecordMessageHeaderValidator(const TableTemplateList &tableTemplateList, const bool shouldIgnoreMissingTableTemplate=false) | Activ::ContentPlatform::Feed::RecordMessageHeaderValidator |
RecordMessageValidator (defined in Activ::ContentPlatform::Feed::RecordMessageHeaderValidator) | Activ::ContentPlatform::Feed::RecordMessageHeaderValidator | [friend]
Reset() | Activ::ContentPlatform::Feed::RecordMessageHeaderValidator |
TableTemplateIdToString() const | Activ::ContentPlatform::Feed::RecordMessageHeaderValidator |
TableTemplateNameToString() const | Activ::ContentPlatform::Feed::RecordMessageHeaderValidator |
ToString() const | Activ::ContentPlatform::Feed::RecordMessageHeaderValidator |
UpdateIdToString() const | Activ::ContentPlatform::Feed::RecordMessageHeaderValidator |
~RecordMessageHeaderValidator() | Activ::ContentPlatform::Feed::RecordMessageHeaderValidator |

Generated on Wed Oct 8 14:02:07 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::RecordMessageValidator Member List

This is the complete list of members for Activ::ContentPlatform::Feed::RecordMessageValidator, including all inherited members.

BeginField() const | Activ::ContentPlatform::Feed::RecordMessageValidator
BeginKeyField() const | Activ::ContentPlatform::Feed::RecordMessageValidator
Clear() | Activ::ContentPlatform::Feed::RecordMessageValidator
ConstFieldIterator typedef | Activ::ContentPlatform::Feed::RecordMessageValidator
ConstKeyFieldIterator typedef | Activ::ContentPlatform::Feed::RecordMessageValidator
EndField() const | Activ::ContentPlatform::Feed::RecordMessageValidator
EndKeyField() const | Activ::ContentPlatform::Feed::RecordMessageValidator
GetEventType(EventType &eventType) const | Activ::ContentPlatform::Feed::RecordMessageValidator
GetField(const FieldId fieldId, const IFieldType *&pIFieldType) const | Activ::ContentPlatform::Feed::RecordMessageValidator
GetIndexNumber(IndexNumber &indexNumber) const | Activ::ContentPlatform::Feed::RecordMessageValidator
GetKeyField(const FieldId fieldId, const IFieldType *&pIFieldType) const | Activ::ContentPlatform::Feed::RecordMessageValidator
GetPermissionId(PermissionId &permissionId) const | Activ::ContentPlatform::Feed::RecordMessageValidator
GetTableTemplate(const TableTemplate *&pTableTemplate) const | Activ::ContentPlatform::Feed::RecordMessageValidator
GetUpdateId(UpdateId &updateId) const | Activ::ContentPlatform::Feed::RecordMessageValidator
Initialize(const TableTemplateList &tableTemplateList, MessageValidator &messageValidator, const bool shouldIgnoreMissingTableTemplate=false, const bool shouldIgnoreUndefinedMissingFields=false) | Activ::ContentPlatform::Feed::RecordMessageValidator
Initialize(const TableTemplateList &tableTemplateList, const bool shouldIgnoreMissingTableTemplate=false) | Activ::ContentPlatform::Feed::RecordMessageValidator
Initialize(MessageValidator &messageValidator, const bool shouldIgnoreUndefinedMissingFields=false) | Activ::ContentPlatform::Feed::RecordMessageValidator
IsDelete() const | Activ::ContentPlatform::Feed::RecordMessageValidator
IsInitialized() const | Activ::ContentPlatform::Feed::RecordMessageValidator
IsRefresh() const | Activ::ContentPlatform::Feed::RecordMessageValidator
RecordMessageValidator() | Activ::ContentPlatform::Feed::RecordMessageValidator
RecordMessageValidator(const TableTemplateList &tableTemplateList, MessageValidator &messageValidator, const bool shouldIgnoreMissingTableTemplate=false, const bool shouldIgnoreUndefinedMissingFields=false) | Activ::ContentPlatform::Feed::RecordMessageValidator
RecordMessageValidator(const TableTemplateList &tableTemplateList, const bool shouldIgnoreMissingTableTemplate=false) | Activ::ContentPlatform::Feed::RecordMessageValidator
Reset() | Activ::ContentPlatform::Feed::RecordMessageValidator
ToString() const | Activ::ContentPlatform::Feed::RecordMessageValidator
~RecordMessageValidator() | Activ::ContentPlatform::Feed::RecordMessageValidator

Generated on Wed Oct 8 14:02:07 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::RelationshipIdHelper Member List

This is the complete list of members for Activ::ContentPlatform::Feed::RelationshipIdHelper, including all inherited members.

m_codeIdentifier | Activ::ContentPlatform::Feed::RelationshipIdHelper |
m_name | Activ::ContentPlatform::Feed::RelationshipIdHelper |
m_relationshipId | Activ::ContentPlatform::Feed::RelationshipIdHelper |
RelationshipIdHelper() | Activ::ContentPlatform::Feed::RelationshipIdHelper | [inline]
RelationshipIdHelper(const RelationshipId relationshipId, const char *const pName, const char *const pCodeIdentifier) | Activ::ContentPlatform::Feed::RelationshipIdHelper | [inline]

Generated on Wed Oct 8 14:02:07 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::Rule Member List

This is the complete list of members for Activ::ContentPlatform::Feed::Rule, including all inherited members.

Clear() | Activ::ContentPlatform::Feed::Rule |
Initialize(const TableTemplate &tableTemplate, const FieldId source, const FieldId size, const FieldId condition, const FieldId time, const FieldId date, const FieldId exchange, const FieldId previousDayTrend, const CopyToFields &copyToFields, const HighFields &highFields, const LowFields &lowFields, const OpenFields &openFields, const CloseFields &closeFields, const PriceFields &priceFields, const VolumeFields &volumeFields) | Activ::ContentPlatform::Feed::Rule |
Initialize(const TableTemplate &tableTemplate, const xercesc::DOMNode &domNode) | Activ::ContentPlatform::Feed::Rule |
InitializeSourceFields(const xercesc::DOMNode &domNode) | Activ::ContentPlatform::Feed::Rule |
IsDefined(const FieldId fieldId) | Activ::ContentPlatform::Feed::Rule | [inline, static]
m_closeFields | Activ::ContentPlatform::Feed::Rule |
m_condition | Activ::ContentPlatform::Feed::Rule |
m_copyToFields | Activ::ContentPlatform::Feed::Rule |
m_date | Activ::ContentPlatform::Feed::Rule |
m_error | Activ::ContentPlatform::Feed::Rule |
m_exchange | Activ::ContentPlatform::Feed::Rule |
m_highFields | Activ::ContentPlatform::Feed::Rule |
m_lowFields | Activ::ContentPlatform::Feed::Rule |
m_openFields | Activ::ContentPlatform::Feed::Rule |
m_previousDayTrend | Activ::ContentPlatform::Feed::Rule |
m_priceFields | Activ::ContentPlatform::Feed::Rule |
m_pTableTemplate | Activ::ContentPlatform::Feed::Rule |
m_size | Activ::ContentPlatform::Feed::Rule |
m_source | Activ::ContentPlatform::Feed::Rule |
m_time | Activ::ContentPlatform::Feed::Rule |
m_volumeFields | Activ::ContentPlatform::Feed::Rule |
operator!=(const Rule &rhs) const | Activ::ContentPlatform::Feed::Rule |
operator==(const Rule &rhs) const | Activ::ContentPlatform::Feed::Rule |
Rule() | Activ::ContentPlatform::Feed::Rule |
Rule(const TableTemplate &tableTemplate, const FieldId source, const FieldId size, const FieldId condition, const FieldId time, const FieldId date, const FieldId exchange, const FieldId previousDayTrend, const CopyToFields &copyToFields, const HighFields &highFields, const LowFields &lowFields, const OpenFields &openFields, const CloseFields &closeFields, const PriceFields &priceFields, const VolumeFields &volumeFields) | Activ::ContentPlatform::Feed::Rule |
Rule(const TableTemplate &tableTemplate, const xercesc::DOMNode &domNode) | Activ::ContentPlatform::Feed::Rule |
ToString() const | Activ::ContentPlatform::Feed::Rule |

Generated on Wed Oct 8 14:02:07 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::Rule::CloseFields Member List

This is the complete list of members for Activ::ContentPlatform::Feed::Rule::CloseFields, including all inherited members.

Clear() | Activ::ContentPlatform::Feed::Rule::CloseFields
CloseFields() | Activ::ContentPlatform::Feed::Rule::CloseFields
CloseFields(const TableTemplate &tableTemplate, const FieldId target, const FieldId condition, const FieldId status, const FieldId date, const FieldId exchange) | Activ::ContentPlatform::Feed::Rule::CloseFields
CloseFields(const TableTemplate &tableTemplate, const xercesc::DOMNode &domNode) | Activ::ContentPlatform::Feed::Rule::CloseFields
Initialize(const TableTemplate &tableTemplate, const FieldId target, const FieldId condition, const FieldId status, const FieldId date, const FieldId exchange) | Activ::ContentPlatform::Feed::Rule::CloseFields
Initialize(const TableTemplate &tableTemplate, const xercesc::DOMNode &domNode) | Activ::ContentPlatform::Feed::Rule::CloseFields
m_condition | Activ::ContentPlatform::Feed::Rule::CloseFields
m_date | Activ::ContentPlatform::Feed::Rule::CloseFields
m_error | Activ::ContentPlatform::Feed::Rule::CloseFields
m_exchange | Activ::ContentPlatform::Feed::Rule::CloseFields
m_pTableTemplate | Activ::ContentPlatform::Feed::Rule::CloseFields
m_status | Activ::ContentPlatform::Feed::Rule::CloseFields
m_target | Activ::ContentPlatform::Feed::Rule::CloseFields
operator!=(const CloseFields &rhs) const | Activ::ContentPlatform::Feed::Rule::CloseFields
operator==(const CloseFields &rhs) const | Activ::ContentPlatform::Feed::Rule::CloseFields
ToString() const | Activ::ContentPlatform::Feed::Rule::CloseFields

Generated on Wed Oct 8 14:02:07 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::Rule::CopyToFields Member List

This is the complete list of members for Activ::ContentPlatform::Feed::Rule::CopyToFields, including all inherited members.

Clear() | Activ::ContentPlatform::Feed::Rule::CopyToFields
CopyToFields() | Activ::ContentPlatform::Feed::Rule::CopyToFields
CopyToFields(const TableTemplate &tableTemplate, const FieldId target, const FieldId size, const FieldId condition, const FieldId time, const FieldId date, const FieldId exchange) | Activ::ContentPlatform::Feed::Rule::CopyToFields
CopyToFields(const TableTemplate &tableTemplate, const xercesc::DOMNode &domNode) | Activ::ContentPlatform::Feed::Rule::CopyToFields
Initialize(const TableTemplate &tableTemplate, const FieldId target, const FieldId size, const FieldId condition, const FieldId time, const FieldId date, const FieldId exchange) | Activ::ContentPlatform::Feed::Rule::CopyToFields
Initialize(const TableTemplate &tableTemplate, const xercesc::DOMNode &domNode) | Activ::ContentPlatform::Feed::Rule::CopyToFields
m_condition | Activ::ContentPlatform::Feed::Rule::CopyToFields
m_date | Activ::ContentPlatform::Feed::Rule::CopyToFields
m_error | Activ::ContentPlatform::Feed::Rule::CopyToFields
m_exchange | Activ::ContentPlatform::Feed::Rule::CopyToFields
m_pTableTemplate | Activ::ContentPlatform::Feed::Rule::CopyToFields
m_size | Activ::ContentPlatform::Feed::Rule::CopyToFields
m_target | Activ::ContentPlatform::Feed::Rule::CopyToFields
m_time | Activ::ContentPlatform::Feed::Rule::CopyToFields
operator!=(const CopyToFields &rhs) const | Activ::ContentPlatform::Feed::Rule::CopyToFields
operator==(const CopyToFields &rhs) const | Activ::ContentPlatform::Feed::Rule::CopyToFields
ToString() const | Activ::ContentPlatform::Feed::Rule::CopyToFields

Generated on Wed Oct 8 14:02:07 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::Rule::HighFields Member List

This is the complete list of members for Activ::ContentPlatform::Feed::Rule::HighFields, including all inherited members.

Clear() | Activ::ContentPlatform::Feed::Rule::HighFields
HighFields() | Activ::ContentPlatform::Feed::Rule::HighFields
HighFields(const TableTemplate &tableTemplate, const FieldId target, const FieldId condition, const FieldId time, const FieldId date, const FieldId exchange) | Activ::ContentPlatform::Feed::Rule::HighFields
HighFields(const TableTemplate &tableTemplate, const xercesc::DOMNode &domNode) | Activ::ContentPlatform::Feed::Rule::HighFields
Initialize(const TableTemplate &tableTemplate, const FieldId target, const FieldId condition, const FieldId time, const FieldId date, const FieldId exchange) | Activ::ContentPlatform::Feed::Rule::HighFields
Initialize(const TableTemplate &tableTemplate, const xercesc::DOMNode &domNode) | Activ::ContentPlatform::Feed::Rule::HighFields
m_condition | Activ::ContentPlatform::Feed::Rule::HighFields
m_date | Activ::ContentPlatform::Feed::Rule::HighFields
m_error | Activ::ContentPlatform::Feed::Rule::HighFields
m_exchange | Activ::ContentPlatform::Feed::Rule::HighFields
m_pTableTemplate | Activ::ContentPlatform::Feed::Rule::HighFields
m_target | Activ::ContentPlatform::Feed::Rule::HighFields
m_time | Activ::ContentPlatform::Feed::Rule::HighFields
operator!=(const HighFields &rhs) const | Activ::ContentPlatform::Feed::Rule::HighFields
operator==(const HighFields &rhs) const | Activ::ContentPlatform::Feed::Rule::HighFields
ToString() const | Activ::ContentPlatform::Feed::Rule::HighFields

Generated on Wed Oct 8 14:02:07 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::Rule::LowFields Member List

This is the complete list of members for Activ::ContentPlatform::Feed::Rule::LowFields, including all inherited members.

Clear() | Activ::ContentPlatform::Feed::Rule::LowFields
Initialize(const TableTemplate &tableTemplate, const FieldId target, const FieldId condition, const FieldId time, const FieldId date, const FieldId exchange) | Activ::ContentPlatform::Feed::Rule::LowFields
Initialize(const TableTemplate &tableTemplate, const xercesc::DOMNode &domNode) | Activ::ContentPlatform::Feed::Rule::LowFields
LowFields() | Activ::ContentPlatform::Feed::Rule::LowFields
LowFields(const TableTemplate &tableTemplate, const FieldId target, const FieldId condition, const FieldId time, const FieldId date, const FieldId exchange) | Activ::ContentPlatform::Feed::Rule::LowFields
LowFields(const TableTemplate &tableTemplate, const xercesc::DOMNode &domNode) | Activ::ContentPlatform::Feed::Rule::LowFields
m_condition | Activ::ContentPlatform::Feed::Rule::LowFields
m_date | Activ::ContentPlatform::Feed::Rule::LowFields
m_error | Activ::ContentPlatform::Feed::Rule::LowFields
m_exchange | Activ::ContentPlatform::Feed::Rule::LowFields
m_pTableTemplate | Activ::ContentPlatform::Feed::Rule::LowFields
m_target | Activ::ContentPlatform::Feed::Rule::LowFields
m_time | Activ::ContentPlatform::Feed::Rule::LowFields
operator!=(const LowFields &rhs) const | Activ::ContentPlatform::Feed::Rule::LowFields
operator==(const LowFields &rhs) const | Activ::ContentPlatform::Feed::Rule::LowFields
ToString() const | Activ::ContentPlatform::Feed::Rule::LowFields

Generated on Wed Oct 8 14:02:07 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::Rule::OpenFields Member List

This is the complete list of members for Activ::ContentPlatform::Feed::Rule::OpenFields, including all inherited members.

Clear() | Activ::ContentPlatform::Feed::Rule::OpenFields
Initialize(const TableTemplate &tableTemplate, const FieldId target, const FieldId condition, const FieldId time, const FieldId exchange) | Activ::ContentPlatform::Feed::Rule::OpenFields
Initialize(const TableTemplate &tableTemplate, const xercesc::DOMNode &domNode) | Activ::ContentPlatform::Feed::Rule::OpenFields
m_condition | Activ::ContentPlatform::Feed::Rule::OpenFields
m_error | Activ::ContentPlatform::Feed::Rule::OpenFields
m_exchange | Activ::ContentPlatform::Feed::Rule::OpenFields
m_pTableTemplate | Activ::ContentPlatform::Feed::Rule::OpenFields
m_target | Activ::ContentPlatform::Feed::Rule::OpenFields
m_time | Activ::ContentPlatform::Feed::Rule::OpenFields
OpenFields() | Activ::ContentPlatform::Feed::Rule::OpenFields
OpenFields(const TableTemplate &tableTemplate, const FieldId target, const FieldId condition, const FieldId time, const FieldId exchange) | Activ::ContentPlatform::Feed::Rule::OpenFields
OpenFields(const TableTemplate &tableTemplate, const xercesc::DOMNode &domNode) | Activ::ContentPlatform::Feed::Rule::OpenFields
operator!=(const OpenFields &rhs) const | Activ::ContentPlatform::Feed::Rule::OpenFields
operator==(const OpenFields &rhs) const | Activ::ContentPlatform::Feed::Rule::OpenFields
ToString() const | Activ::ContentPlatform::Feed::Rule::OpenFields

Generated on Wed Oct 8 14:02:07 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::Rule::PriceFields Member List

This is the complete list of members for Activ::ContentPlatform::Feed::Rule::PriceFields, including all inherited members.

Clear() | Activ::ContentPlatform::Feed::Rule::PriceFields
Initialize(const TableTemplate &tableTemplate, const FieldId previousDayChange, const FieldId netChange, const FieldId percentChange, const FieldId cumulativePrice, const FieldId count) | Activ::ContentPlatform::Feed::Rule::PriceFields
Initialize(const TableTemplate &tableTemplate, const xercesc::DOMNode &domNode) | Activ::ContentPlatform::Feed::Rule::PriceFields
InitializeChangeFields(const xercesc::DOMNode &domNode) | Activ::ContentPlatform::Feed::Rule::PriceFields
m_count | Activ::ContentPlatform::Feed::Rule::PriceFields
m_cumulativePrice | Activ::ContentPlatform::Feed::Rule::PriceFields
m_error | Activ::ContentPlatform::Feed::Rule::PriceFields
m_netChange | Activ::ContentPlatform::Feed::Rule::PriceFields
m_percentChange | Activ::ContentPlatform::Feed::Rule::PriceFields
m_previousDayChange | Activ::ContentPlatform::Feed::Rule::PriceFields
m_pTableTemplate | Activ::ContentPlatform::Feed::Rule::PriceFields
operator!=(const PriceFields &rhs) const | Activ::ContentPlatform::Feed::Rule::PriceFields
operator==(const PriceFields &rhs) const | Activ::ContentPlatform::Feed::Rule::PriceFields
PriceFields() | Activ::ContentPlatform::Feed::Rule::PriceFields
PriceFields(const TableTemplate &tableTemplate, const FieldId previousDayChange, const FieldId netChange, const FieldId percentChange, const FieldId cumulativePrice, const FieldId count) | Activ::ContentPlatform::Feed::Rule::PriceFields
PriceFields(const TableTemplate &tableTemplate, const xercesc::DOMNode &domNode) | Activ::ContentPlatform::Feed::Rule::PriceFields
ToString() const | Activ::ContentPlatform::Feed::Rule::PriceFields

Generated on Wed Oct 8 14:02:07 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::Rule::VolumeFields Member List

This is the complete list of members for Activ::ContentPlatform::Feed::Rule::VolumeFields, including all inherited members.

Clear() | Activ::ContentPlatform::Feed::Rule::VolumeFields
Initialize(const TableTemplate &tableTemplate, const FieldId add1Volume, const FieldId add1Price, const FieldId add1CumulativeValue, const FieldId add2Volume, const FieldId add2Price, const FieldId add2CumulativeValue) | Activ::ContentPlatform::Feed::Rule::VolumeFields
Initialize(const TableTemplate &tableTemplate, const xercesc::DOMNode &domNode) | Activ::ContentPlatform::Feed::Rule::VolumeFields
InitializeAdd1CumulativeValueFields(const xercesc::DOMNode &domNode) | Activ::ContentPlatform::Feed::Rule::VolumeFields
InitializeAdd1Fields(const xercesc::DOMNode &domNode) | Activ::ContentPlatform::Feed::Rule::VolumeFields
InitializeAdd2CumulativeValueFields(const xercesc::DOMNode &domNode) | Activ::ContentPlatform::Feed::Rule::VolumeFields
InitializeAdd2Fields(const xercesc::DOMNode &domNode) | Activ::ContentPlatform::Feed::Rule::VolumeFields
m_add1CumulativeValue | Activ::ContentPlatform::Feed::Rule::VolumeFields
m_add1Price | Activ::ContentPlatform::Feed::Rule::VolumeFields
m_add1Volume | Activ::ContentPlatform::Feed::Rule::VolumeFields
m_add2CumulativeValue | Activ::ContentPlatform::Feed::Rule::VolumeFields
m_add2Price | Activ::ContentPlatform::Feed::Rule::VolumeFields
m_add2Volume | Activ::ContentPlatform::Feed::Rule::VolumeFields
m_error | Activ::ContentPlatform::Feed::Rule::VolumeFields
m_pTableTemplate | Activ::ContentPlatform::Feed::Rule::VolumeFields
operator!=(const VolumeFields &rhs) const | Activ::ContentPlatform::Feed::Rule::VolumeFields
operator==(const VolumeFields &rhs) const | Activ::ContentPlatform::Feed::Rule::VolumeFields
ToString() const | Activ::ContentPlatform::Feed::Rule::VolumeFields
VolumeFields() | Activ::ContentPlatform::Feed::Rule::VolumeFields
VolumeFields(const TableTemplate &tableTemplate, const FieldId add1Volume, const FieldId add1Price, const FieldId add1CumulativeValue, const FieldId add2Volume, const FieldId add2Price, const FieldId add2CumulativeValue) | Activ::ContentPlatform::Feed::Rule::VolumeFields
VolumeFields(const TableTemplate &tableTemplate, const xercesc::DOMNode &domNode) | Activ::ContentPlatform::Feed::Rule::VolumeFields

Generated on Wed Oct 8 14:02:07 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::Symbol Member List

This is the complete list of members for Activ::ContentPlatform::Feed::Symbol, including all inherited members.

Deserialize(MessageValidator &messageValidator, const size_t maxSymbolLength, std::string &symbol) | Activ::ContentPlatform::Feed::Symbol | [inline, static]
Serialize(byte_t *&pMessage, const std::string &symbol) | Activ::ContentPlatform::Feed::Symbol | [inline, static]

Generated on Wed Oct 8 14:02:07 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::SymbolRecordField Member List

This is the complete list of members for Activ::ContentPlatform::Feed::SymbolRecordField, including all inherited members.

CompositeFieldRulesToString() const | Activ::ContentPlatform::Feed::SymbolRecordField |
ContentsPrefixToString() | Activ::ContentPlatform::Feed::SymbolRecordField | [static]
FieldContentsToString() const | Activ::ContentPlatform::Feed::SymbolRecordField |
FieldIdToString(const FieldId &fieldId) | Activ::ContentPlatform::Feed::SymbolRecordField | [static]
FieldNameToString(const Field *pField) | Activ::ContentPlatform::Feed::SymbolRecordField | [static]
FieldRulesToString() const | Activ::ContentPlatform::Feed::SymbolRecordField |
GetCompositeFieldRules(uint8_t &compositeFieldRules) const | Activ::ContentPlatform::Feed::SymbolRecordField | [inline]
GetField(const IFieldType *&pIFieldType) const | Activ::ContentPlatform::Feed::SymbolRecordField | [inline]
GetFieldRules(uint8_t &fieldRules) const | Activ::ContentPlatform::Feed::SymbolRecordField | [inline]
GetPartialBitUpdateList(const PartialBitUpdateList *&pPartialBitUpdateList) const | Activ::ContentPlatform::Feed::SymbolRecordField | [inline]
GetRuleSet(uint8_t &ruleSet) const | Activ::ContentPlatform::Feed::SymbolRecordField | [inline]
Initialize(const Field &field, const bool isComposite, const uint8_t defaultRuleSet, const bool isFieldRulesPresent, MessageValidator &messageValidator) | Activ::ContentPlatform::Feed::SymbolRecordField |
InitializeUndefined(const Field &field) | Activ::ContentPlatform::Feed::SymbolRecordField | [inline]
IsComposite() const | Activ::ContentPlatform::Feed::SymbolRecordField | [inline]
IsDefined() const | Activ::ContentPlatform::Feed::SymbolRecordField | [inline]
IsInitialized() const | Activ::ContentPlatform::Feed::SymbolRecordField | [inline]
PartialBitUpdateList typedef | Activ::ContentPlatform::Feed::SymbolRecordField |
PartialByteUpdateList typedef | Activ::ContentPlatform::Feed::SymbolRecordField |
PartialUpdateToString(PartialUpdate &partialUpdate) const | Activ::ContentPlatform::Feed::SymbolRecordField |
Reset() | Activ::ContentPlatform::Feed::SymbolRecordField |
RuleSetToString() const | Activ::ContentPlatform::Feed::SymbolRecordField |
SymbolRecordField() | Activ::ContentPlatform::Feed::SymbolRecordField |
SymbolRecordField(const Field &field, const bool isComposite, const uint8_t defaultRuleSet, const bool isFieldRulesPresent, MessageValidator &messageValidator) | Activ::ContentPlatform::Feed::SymbolRecordField |
ToString() const | Activ::ContentPlatform::Feed::SymbolRecordField |
UndefinedFieldContentsToString() | Activ::ContentPlatform::Feed::SymbolRecordField | [static]
~SymbolRecordField() | Activ::ContentPlatform::Feed::SymbolRecordField |

Generated on Wed Oct 8 14:02:07 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::SymbolRecordField::PartialUpdate Member List

This is the complete list of members for Activ::ContentPlatform::Feed::SymbolRecordField::PartialUpdate, including all inherited members.

m_offset (defined in Activ::ContentPlatform::Feed::SymbolRecordField::PartialUpdate) | Activ::ContentPlatform::Feed::SymbolRecordField::PartialUpdate
m_value (defined in Activ::ContentPlatform::Feed::SymbolRecordField::PartialUpdate) | Activ::ContentPlatform::Feed::SymbolRecordField::PartialUpdate
PartialUpdate(const uint8_t offset=0, const uint8_t value=0) | Activ::ContentPlatform::Feed::SymbolRecordField::PartialUpdate

Generated on Wed Oct 8 14:02:07 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::SymbolRecordFieldHeaderDefinitions Member List

This is the complete list of members for Activ::ContentPlatform::Feed::SymbolRecordFieldHeaderDefinitions, including all inherited members.

FIELD_ID_LENGTH | Activ::ContentPlatform::Feed::FieldHeaderDefinitions | [static]
FIELD_ID_OFFSET | Activ::ContentPlatform::Feed::FieldHeaderDefinitions | [static]
FIELD_RESERVED_LENGTH | Activ::ContentPlatform::Feed::FieldHeaderDefinitions | [static]
FIELD_RESERVED_OFFSET | Activ::ContentPlatform::Feed::FieldHeaderDefinitions | [static]
FIELD_RULES_PRESENT_LENGTH | Activ::ContentPlatform::Feed::SymbolRecordFieldHeaderDefinitions | [static]
FIELD_RULES_PRESENT_OFFSET | Activ::ContentPlatform::Feed::SymbolRecordFieldHeaderDefinitions | [static]
FIELD_UNDEFINED_LENGTH | Activ::ContentPlatform::Feed::FieldHeaderDefinitions | [static]
FIELD_UNDEFINED_OFFSET | Activ::ContentPlatform::Feed::FieldHeaderDefinitions | [static]
FieldHeader typedef | Activ::ContentPlatform::Feed::FieldHeaderDefinitions |
GetFieldHeader(const FieldId fieldId, const bool isFieldDefined, const bool isFieldRulesPresent=false) | Activ::ContentPlatform::Feed::SymbolRecordFieldHeaderDefinitions | [inline, static]
Activ::ContentPlatform::Feed::FieldHeaderDefinitions::GetFieldHeader(const FieldId fieldId, const bool isFieldDefined) | Activ::ContentPlatform::Feed::FieldHeaderDefinitions | [inline, static]
GetFieldId(const FieldHeader fieldHeader) | Activ::ContentPlatform::Feed::FieldHeaderDefinitions | [inline, static]
IsFieldDefined(const FieldHeader fieldHeader) | Activ::ContentPlatform::Feed::FieldHeaderDefinitions | [inline, static]
IsFieldRulesPresent(const FieldHeader fieldHeader) | Activ::ContentPlatform::Feed::SymbolRecordFieldHeaderDefinitions | [inline, static]

Generated on Wed Oct 8 14:02:07 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::SymbolRecordFieldListBuilder Member List

This is the complete list of members for Activ::ContentPlatform::Feed::SymbolRecordFieldListBuilder, including all inherited members.

AppendField(const FieldId fieldId, const IFieldType &iFieldType) | Activ::ContentPlatform::Feed::SymbolRecordFieldListBuilder
AppendField(const FieldId fieldId, const void *const pSerializedBody, const size_t serializedBodyLength) | Activ::ContentPlatform::Feed::SymbolRecordFieldListBuilder
AppendFieldWithContentServerRuleSet(const FieldId fieldId, const uint8_t fieldRules, const IFieldType &iFieldType) | Activ::ContentPlatform::Feed::SymbolRecordFieldListBuilder
AppendFieldWithContentServerRuleSet(const FieldId fieldId, const uint8_t fieldRules, const void *const pSerializedBody, const size_t serializedBodyLength) | Activ::ContentPlatform::Feed::SymbolRecordFieldListBuilder
AppendFieldWithContentServerRuleSet(const FieldId fieldId, const uint8_t fieldRules, const uint8_t compositeFieldRules, const IFieldType &iFieldType) | Activ::ContentPlatform::Feed::SymbolRecordFieldListBuilder
AppendFieldWithContentServerRuleSet(const FieldId fieldId, const uint8_t fieldRules, const uint8_t compositeFieldRules, const void *const pSerializedBody, const size_t serializedBodyLength) | Activ::ContentPlatform::Feed::SymbolRecordFieldListBuilder
AppendFieldWithNoneRuleSet(const FieldId fieldId, const IFieldType &iFieldType) | Activ::ContentPlatform::Feed::SymbolRecordFieldListBuilder
AppendFieldWithNoneRuleSet(const FieldId fieldId, const void *const pSerializedBody, const size_t serializedBodyLength) | Activ::ContentPlatform::Feed::SymbolRecordFieldListBuilder
AppendFieldWithTranslatorRuleSet(const FieldId fieldId, const uint8_t fieldRules, const IFieldType &iFieldType) | Activ::ContentPlatform::Feed::SymbolRecordFieldListBuilder
AppendFieldWithTranslatorRuleSet(const FieldId fieldId, const uint8_t fieldRules, const void *const pSerializedBody, const size_t serializedBodyLength) | Activ::ContentPlatform::Feed::SymbolRecordFieldListBuilder
AppendFieldWithTranslatorRuleSet(const FieldId fieldId, const uint8_t fieldRules, const uint8_t compositeFieldRules, const IFieldType &iFieldType) | Activ::ContentPlatform::Feed::SymbolRecordFieldListBuilder
AppendFieldWithTranslatorRuleSet(const FieldId fieldId, const uint8_t fieldRules, const uint8_t compositeFieldRules, const void *const pSerializedBody, const size_t serializedBodyLength) | Activ::ContentPlatform::Feed::SymbolRecordFieldListBuilder
AppendUndefinedField(const FieldId fieldId) | Activ::ContentPlatform::Feed::SymbolRecordFieldListBuilder
Clear() | Activ::ContentPlatform::Feed::SymbolRecordFieldListBuilder
Initialize(const TableTemplate &tableTemplate, const bool isComposite, const uint8_t defaultRuleSet, MessageBuilder &messageBuilder) | Activ::ContentPlatform::Feed::SymbolRecordFieldListBuilder
IsInitialized() const | Activ::ContentPlatform::Feed::SymbolRecordFieldListBuilder
Reset() | Activ::ContentPlatform::Feed::SymbolRecordFieldListBuilder
SymbolRecordFieldListBuilder() | Activ::ContentPlatform::Feed::SymbolRecordFieldListBuilder
SymbolRecordFieldListBuilder(const TableTemplate &tableTemplate, const bool isComposite, const uint8_t defaultRuleSet, MessageBuilder &messageBuilder) | Activ::ContentPlatform::Feed::SymbolRecordFieldListBuilder
~SymbolRecordFieldListBuilder() | Activ::ContentPlatform::Feed::SymbolRecordFieldListBuilder

Generated on Wed Oct 8 14:02:07 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::SymbolRecordFieldListValidator Member List

This is the complete list of members for Activ::ContentPlatform::Feed::SymbolRecordFieldListValidator, including all inherited members.

Begin() const | Activ::ContentPlatform::Feed::SymbolRecordFieldListValidator
Clear() | Activ::ContentPlatform::Feed::SymbolRecordFieldListValidator
End() const | Activ::ContentPlatform::Feed::SymbolRecordFieldListValidator
GetSymbolRecordField(const FieldId fieldId, const SymbolRecordField *&pSymbolRecordField) const | Activ::ContentPlatform::Feed::SymbolRecordFieldListValidator
Initialize(const TableTemplate &tableTemplate, const bool isComposite, const uint8_t defaultRuleSet, MessageValidator &messageValidator, const bool shouldIgnoreUndefinedMissingFields=false) | Activ::ContentPlatform::Feed::SymbolRecordFieldListValidator
Initialize(const SymbolRecordMessageHeaderValidator &symbolRecordMessageHeaderValidator, MessageValidator &messageValidator, const bool shouldIgnoreUndefinedMissingFields=false) | Activ::ContentPlatform::Feed::SymbolRecordFieldListValidator
IsInitialized() const | Activ::ContentPlatform::Feed::SymbolRecordFieldListValidator
Reset() | Activ::ContentPlatform::Feed::SymbolRecordFieldListValidator
SymbolRecordFieldListValidator() | Activ::ContentPlatform::Feed::SymbolRecordFieldListValidator
SymbolRecordFieldListValidator(const TableTemplate &tableTemplate, const bool isComposite, const uint8_t defaultRuleSet, MessageValidator &messageValidator, const bool shouldIgnoreUndefinedMissingFields=false) | Activ::ContentPlatform::Feed::SymbolRecordFieldListValidator
SymbolRecordFieldListValidator(const SymbolRecordMessageHeaderValidator &symbolRecordMessageHeaderValidator, MessageValidator &messageValidator, const bool shouldIgnoreUndefinedMissingFields=false) | Activ::ContentPlatform::Feed::SymbolRecordFieldListValidator
ToString() const | Activ::ContentPlatform::Feed::SymbolRecordFieldListValidator
~SymbolRecordFieldListValidator() | Activ::ContentPlatform::Feed::SymbolRecordFieldListValidator

Generated on Wed Oct 8 14:02:07 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::SymbolRecordFieldListValidator::ConstIterator Member List

This is the complete list of members for Activ::ContentPlatform::Feed::SymbolRecordFieldListValidator::ConstIterator, including all inherited members.

ConstIterator() | Activ::ContentPlatform::Feed::SymbolRecordFieldListValidator::ConstIterator | [inline]
GetFieldId() const | Activ::ContentPlatform::Feed::SymbolRecordFieldListValidator::ConstIterator | [inline]
GetSymbolRecordField() const | Activ::ContentPlatform::Feed::SymbolRecordFieldListValidator::ConstIterator | [inline]
operator!=(const ConstIterator &rhs) const | Activ::ContentPlatform::Feed::SymbolRecordFieldListValidator::ConstIterator | [inline]
operator++() | Activ::ContentPlatform::Feed::SymbolRecordFieldListValidator::ConstIterator | [inline]
operator++(int) | Activ::ContentPlatform::Feed::SymbolRecordFieldListValidator::ConstIterator | [inline]
operator==(const ConstIterator &rhs) const | Activ::ContentPlatform::Feed::SymbolRecordFieldListValidator::ConstIterator | [inline]
SymbolRecordFieldListValidator (defined in Activ::ContentPlatform::Feed::SymbolRecordFieldListValidator::ConstIterator) | Activ::ContentPlatform::Feed::SymbolRecordFieldListValidator::ConstIterator | [friend]

Generated on Wed Oct 8 14:02:08 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::SymbolRecordMessageBuilder Member List

This is the complete list of members for Activ::ContentPlatform::Feed::SymbolRecordMessageBuilder, including all inherited members.

AppendField(const FieldId fieldId, const IFieldType &iFieldType) | Activ::ContentPlatform::Feed::SymbolRecordMessageBuilder
AppendField(const FieldId fieldId, const void *const pSerializedBody, const size_t serializedBodyLength) | Activ::ContentPlatform::Feed::SymbolRecordMessageBuilder
AppendFieldWithContentServerRuleSet(const FieldId fieldId, const uint8_t fieldRules, const IFieldType &iFieldType) | Activ::ContentPlatform::Feed::SymbolRecordMessageBuilder
AppendFieldWithContentServerRuleSet(const FieldId fieldId, const uint8_t fieldRules, const void *const pSerializedBody, const size_t serializedBodyLength) | Activ::ContentPlatform::Feed::SymbolRecordMessageBuilder
AppendFieldWithContentServerRuleSet(const FieldId fieldId, const uint8_t fieldRules, const uint8_t compositeFieldRules, const IFieldType &iFieldType) | Activ::ContentPlatform::Feed::SymbolRecordMessageBuilder
AppendFieldWithContentServerRuleSet(const FieldId fieldId, const uint8_t fieldRules, const uint8_t compositeFieldRules, const void *const pSerializedBody, const size_t serializedBodyLength) | Activ::ContentPlatform::Feed::SymbolRecordMessageBuilder
AppendFieldWithNoneRuleSet(const FieldId fieldId, const IFieldType &iFieldType) | Activ::ContentPlatform::Feed::SymbolRecordMessageBuilder
AppendFieldWithNoneRuleSet(const FieldId fieldId, const void *const pSerializedBody, const size_t serializedBodyLength) | Activ::ContentPlatform::Feed::SymbolRecordMessageBuilder
AppendFieldWithTranslatorRuleSet(const FieldId fieldId, const uint8_t fieldRules, const IFieldType &iFieldType) | Activ::ContentPlatform::Feed::SymbolRecordMessageBuilder
AppendFieldWithTranslatorRuleSet(const FieldId fieldId, const uint8_t fieldRules, const void *const pSerializedBody, const size_t serializedBodyLength) | Activ::ContentPlatform::Feed::SymbolRecordMessageBuilder
AppendFieldWithTranslatorRuleSet(const FieldId fieldId, const uint8_t fieldRules, const uint8_t compositeFieldRules, const IFieldType &iFieldType) | Activ::ContentPlatform::Feed::SymbolRecordMessageBuilder
AppendFieldWithTranslatorRuleSet(const FieldId fieldId, const uint8_t fieldRules, const uint8_t compositeFieldRules, const void *const pSerializedBody, const size_t serializedBodyLength) | Activ::ContentPlatform::Feed::SymbolRecordMessageBuilder
AppendHeader(const bool isDelete, const TableId tableId, const UpdateId updateId, const PermissionId permissionId, const EventType eventType, const void *const pSymbol, const size_t symbolLength, uint8_t defaultRuleSet=SymbolRecordRuleDefinitions::RULE_SET_NONE) | Activ::ContentPlatform::Feed::SymbolRecordMessageBuilder
AppendHeader(const bool isDelete, const TableId tableId, const UpdateId updateId, const UpdateId compositeUpdateId, const PermissionId permissionId, const EventType eventType, const void *const pSymbol, const size_t symbolLength, uint8_t defaultRuleSet=SymbolRecordRuleDefinitions::RULE_SET_NONE) | Activ::ContentPlatform::Feed::SymbolRecordMessageBuilder
AppendUndefinedField(const FieldId fieldId) | Activ::ContentPlatform::Feed::SymbolRecordMessageBuilder
Initialize(const TableTemplateList &tableTemplateList, MessageBuilder &messageBuilder) | Activ::ContentPlatform::Feed::SymbolRecordMessageBuilder
Initialize(const TableTemplateList &tableTemplateList) | Activ::ContentPlatform::Feed::SymbolRecordMessageBuilder
Initialize(MessageBuilder &messageBuilder) | Activ::ContentPlatform::Feed::SymbolRecordMessageBuilder
IsInitialized() const | Activ::ContentPlatform::Feed::SymbolRecordMessageBuilder
Reset() | Activ::ContentPlatform::Feed::SymbolRecordMessageBuilder
SymbolRecordMessageBuilder() | Activ::ContentPlatform::Feed::SymbolRecordMessageBuilder
SymbolRecordMessageBuilder(const TableTemplateList &tableTemplateList, MessageBuilder &messageBuilder) | Activ::ContentPlatform::Feed::SymbolRecordMessageBuilder
SymbolRecordMessageBuilder(const TableTemplateList &tableTemplateList) | Activ::ContentPlatform::Feed::SymbolRecordMessageBuilder
~SymbolRecordMessageBuilder() | Activ::ContentPlatform::Feed::SymbolRecordMessageBuilder

Generated on Wed Oct 8 14:02:08 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions Member List

This is the complete list of members for Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions, including all inherited members.

ExtractFlags(const Flags flags, bool &isExpandedFormat, bool &isDoNotAdd) | Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions | [inline, static]
Flags typedef | Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions |
FLAGS_DO_NOT_ADD_BIT_MASK (defined in Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions) | Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions | [static]
FLAGS_DO_NOT_ADD_BIT_SHIFT (defined in Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions) | Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions | [static]
FLAGS_DO_NOT_ADD_LENGTH | Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions | [static]
FLAGS_DO_NOT_ADD_OFFSET | Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions | [static]
FLAGS_EXPANDED_FORMAT_BIT_MASK (defined in Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions) | Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions | [static]
FLAGS_EXPANDED_FORMAT_BIT_SHIFT (defined in Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions) | Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions | [static]
FLAGS_EXPANDED_FORMAT_LENGTH | Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions | [static]
FLAGS_EXPANDED_FORMAT_OFFSET | Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions | [static]
GetFlags(const bool isExpandedFormat, const bool isDoNotAdd) | Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions | [inline, static]
GetMessageHeader(const bool isDelete, const bool isComposite, const MessageType messageType=MESSAGE_TYPE) | Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions | [inline, static]
IsComposite(const MessageHeaderDefinitions::MessageHeader messageHeader) | Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions | [inline, static]
IsDelete(const MessageHeaderDefinitions::MessageHeader messageHeader) | Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions | [inline, static]
IsDoNotAdd(const Flags flags) | Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions | [inline, static]
IsExpandedFormat(const Flags flags) | Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions | [inline, static]
IsValidMessageType(const MessageHeaderDefinitions::MessageHeader messageHeader) | Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions | [inline, static]
MAX_SYMBOL_LENGTH | Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions | [static]
MESSAGE_HEADER_FLAGS_COMPOSITE_BIT_MASK (defined in Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions) | Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions | [static]
MESSAGE_HEADER_FLAGS_COMPOSITE_BIT_SHIFT (defined in Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions) | Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions | [static]
MESSAGE_HEADER_FLAGS_COMPOSITE_LENGTH | Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions | [static]
MESSAGE_HEADER_FLAGS_COMPOSITE_OFFSET | Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions | [static]
MESSAGE_HEADER_FLAGS_DELETE_BIT_MASK (defined in Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions) | Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions | [static]
MESSAGE_HEADER_FLAGS_DELETE_BIT_SHIFT (defined in Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions) | Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions | [static]
MESSAGE_HEADER_FLAGS_DELETE_LENGTH | Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions | [static]
MESSAGE_HEADER_FLAGS_DELETE_OFFSET | Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions | [static]
MESSAGE_TYPE | Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions | [static]

Generated on Wed Oct 8 14:02:08 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator Member List

This is the complete list of members for Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator, including all inherited members.

Clear() | Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator |
CompositeUpdateIdToString() const | Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator |
DefaultRuleSetToString() const | Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator |
EventTypeToString() const | Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator |
GetCompositeUpdateId(UpdateId &compositeUpdateId) const | Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator |
GetDefaultRuleSet(uint8_t &defaultRuleSet) const | Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator |
GetEventType(EventType &eventType) const | Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator |
GetPermissionId(PermissionId &permissionId) const | Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator |
GetSymbol(const TextString *&pSymbol) const | Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator |
GetTableTemplate(const TableTemplate *&pTableTemplate) const | Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator |
GetUpdateId(UpdateId &updateId) const | Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator |
Initialize(const TableTemplateList &tableTemplateList, MessageValidator &messageValidator, const bool shouldIgnoreMissingTableTemplate=false) | Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator |
Initialize(const TableTemplateList &tableTemplateList, const bool shouldIgnoreMissingTableTemplate=false) | Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator |
Initialize(MessageValidator &messageValidator) | Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator |
IsComposite() const | Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator |
IsCompositeToString() const | Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator |
IsDelete() const | Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator |
IsDeleteToString() const | Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator |
IsInitialized() const | Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator |
PermissionIdToString() const | Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator |
Reset() | Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator |
SymbolRecordFieldListValidator (defined in Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator) | Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator | [friend]
SymbolRecordMessageHeaderValidator() | Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator |
SymbolRecordMessageHeaderValidator(const TableTemplateList &tableTemplateList, MessageValidator &messageValidator, const bool shouldIgnoreMissingTableTemplate=false) | Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator |
SymbolRecordMessageHeaderValidator(const TableTemplateList &tableTemplateList, const bool shouldIgnoreMissingTableTemplate=false) | Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator |
SymbolToString() const | Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator |
TableTemplateIdToString() const | Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator |
TableTemplateNameToString() const | Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator |
ToString() const | Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator |
UpdateIdToString() const | Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator |
~SymbolRecordMessageHeaderValidator() | Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator |

Generated on Wed Oct 8 14:02:08 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::SymbolRecordMessageValidator Member List

This is the complete list of members for Activ::ContentPlatform::Feed::SymbolRecordMessageValidator, including all inherited members.

Begin() const | Activ::ContentPlatform::Feed::SymbolRecordMessageValidator
Clear() | Activ::ContentPlatform::Feed::SymbolRecordMessageValidator
ConstIterator typedef | Activ::ContentPlatform::Feed::SymbolRecordMessageValidator
End() const | Activ::ContentPlatform::Feed::SymbolRecordMessageValidator
GetCompositeUpdateId(UpdateId &compositeUpdateId) const | Activ::ContentPlatform::Feed::SymbolRecordMessageValidator
GetDefaultRuleSet(uint8_t &defaultRuleSet) const | Activ::ContentPlatform::Feed::SymbolRecordMessageValidator
GetEventType(EventType &eventType) const | Activ::ContentPlatform::Feed::SymbolRecordMessageValidator
GetPermissionId(PermissionId &permissionId) const | Activ::ContentPlatform::Feed::SymbolRecordMessageValidator
GetSymbol(const TextString *&pSymbol) const | Activ::ContentPlatform::Feed::SymbolRecordMessageValidator
GetSymbolRecordField(const FieldId fieldId, const SymbolRecordField *&pSymbolRecordField) const | Activ::ContentPlatform::Feed::SymbolRecordMessageValidator
GetTableTemplate(const TableTemplate *&pTableTemplate) const | Activ::ContentPlatform::Feed::SymbolRecordMessageValidator
GetUpdateId(UpdateId &updateId) const | Activ::ContentPlatform::Feed::SymbolRecordMessageValidator
Initialize(const TableTemplateList &tableTemplateList, MessageValidator &messageValidator, const bool shouldIgnoreMissingTableTemplate=false, const bool shouldIgnoreUndefinedMissingFields=false) | Activ::ContentPlatform::Feed::SymbolRecordMessageValidator
Initialize(const TableTemplateList &tableTemplateList, const bool shouldIgnoreMissingTableTemplate=false) | Activ::ContentPlatform::Feed::SymbolRecordMessageValidator
Initialize(MessageValidator &messageValidator, const bool shouldIgnoreUndefinedMissingFields=false) | Activ::ContentPlatform::Feed::SymbolRecordMessageValidator
IsComposite() const | Activ::ContentPlatform::Feed::SymbolRecordMessageValidator
IsDelete() const | Activ::ContentPlatform::Feed::SymbolRecordMessageValidator
IsInitialized() const | Activ::ContentPlatform::Feed::SymbolRecordMessageValidator
Reset() | Activ::ContentPlatform::Feed::SymbolRecordMessageValidator
SymbolRecordMessageValidator() | Activ::ContentPlatform::Feed::SymbolRecordMessageValidator
SymbolRecordMessageValidator(const TableTemplateList &tableTemplateList, MessageValidator &messageValidator, const bool shouldIgnoreMissingTableTemplate=false, const bool shouldIgnoreUndefinedMissingFields=false) | Activ::ContentPlatform::Feed::SymbolRecordMessageValidator
SymbolRecordMessageValidator(const TableTemplateList &tableTemplateList, const bool shouldIgnoreMissingTableTemplate=false) | Activ::ContentPlatform::Feed::SymbolRecordMessageValidator
ToString() const | Activ::ContentPlatform::Feed::SymbolRecordMessageValidator
~SymbolRecordMessageValidator() | Activ::ContentPlatform::Feed::SymbolRecordMessageValidator

Generated on Wed Oct 8 14:02:08 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions Member List

This is the complete list of members for Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions, including all inherited members.

ClearFieldRules(const uint8_t fieldRules, const uint8_t initialFieldRules=FIELD_RULE_SET_ALL) | Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions | [inline, static]
FIELD_RULE_CLEAR_ALL | Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions | [static]
FIELD_RULE_SET_ALL | Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions | [static]
NUMBER_OF_RULE_SETS enum value | Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions |
RULE_SET_CONTENT_SERVER enum value | Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions |
RULE_SET_COPY enum value | Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions |
RULE_SET_NONE enum value | Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions |
RULE_SET_PARTIAL_BIT_UPDATE enum value | Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions |
RULE_SET_PARTIAL_BYTE_UPDATE enum value | Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions |
RULE_SET_TRANSLATOR enum value | Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions |
SetFieldRules(const uint8_t fieldRules, const uint8_t initialFieldRules=FIELD_RULE_CLEAR_ALL) | Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions | [inline, static]

Generated on Wed Oct 8 14:02:08 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ContentServerRuleSet Member List

This is the complete list of members for Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ContentServerRuleSet, including all inherited members.

FIELD_RULE_APPLY_TRENDING | Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ContentServerRuleSet | [static]
FIELD_RULE_BIT_APPLY_TRENDING enum value | Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ContentServerRuleSet |
FIELD_RULE_BIT_DO_NOT_APPLY_ADD_RULE_1 enum value | Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ContentServerRuleSet |
FIELD_RULE_BIT_DO_NOT_APPLY_ADD_RULE_2 enum value | Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ContentServerRuleSet |
FIELD_RULE_BIT_DO_NOT_APPLY_CHANGE_RULE enum value | Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ContentServerRuleSet |
FIELD_RULE_BIT_DO_NOT_UPDATE_FIELD enum value | Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ContentServerRuleSet |
FIELD_RULE_BIT_IS_HIGH enum value | Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ContentServerRuleSet |
FIELD_RULE_BIT_IS_LOW enum value | Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ContentServerRuleSet |
FIELD_RULE_BIT_IS_OPEN enum value | Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ContentServerRuleSet |
FIELD_RULE_BITMASK_IS_HIGH | Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ContentServerRuleSet | [static]
FIELD_RULE_BITMASK_IS_LOW | Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ContentServerRuleSet | [static]
FIELD_RULE_BITMASK_IS_OPEN | Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ContentServerRuleSet | [static]
FIELD_RULE_DO_NOT_APPLY_ADD_RULE_1 | Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ContentServerRuleSet | [static]
FIELD_RULE_DO_NOT_APPLY_ADD_RULE_2 | Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ContentServerRuleSet | [static]
FIELD_RULE_DO_NOT_APPLY_CHANGE_RULE | Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ContentServerRuleSet | [static]
FIELD_RULE_DO_NOT_UPDATE_FIELD | Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ContentServerRuleSet | [static]
GetFieldRules(const bool shouldUpdateField, const bool isHigh, const bool isLow, const bool isOpen, const bool shouldApplyAddRule1, const bool shouldApplyAddRule2, const bool shouldApplyTrending, const bool shouldApplyChangeRule) | Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ContentServerRuleSet | [inline, static]
IsHigh(const uint8_t fieldRules) | Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ContentServerRuleSet | [inline, static]
IsLow(const uint8_t fieldRules) | Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ContentServerRuleSet | [inline, static]
IsOpen(const uint8_t fieldRules) | Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ContentServerRuleSet | [inline, static]
ShouldApplyAddRule1(const uint8_t fieldRules) | Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ContentServerRuleSet | [inline, static]
ShouldApplyAddRule2(const uint8_t fieldRules) | Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ContentServerRuleSet | [inline, static]
ShouldApplyChangeRule(const uint8_t fieldRules) | Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ContentServerRuleSet | [inline, static]
ShouldApplyTrending(const uint8_t fieldRules) | Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ContentServerRuleSet | [inline, static]
ShouldUpdateField(const uint8_t fieldRules) | Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ContentServerRuleSet | [inline, static]

Generated on Wed Oct 8 14:02:08 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::TranslatorRuleSet Member List

This is the complete list of members for Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::TranslatorRuleSet, including all inherited members.

FIELD_RULE_BIT_DO_NOT_APPLY_ADD_RULE_1 enum value | Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::TranslatorRuleSet |
FIELD_RULE_BIT_DO_NOT_APPLY_ADD_RULE_2 enum value | Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::TranslatorRuleSet |
FIELD_RULE_BIT_DO_NOT_APPLY_CHANGE_RULE enum value | Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::TranslatorRuleSet |
FIELD_RULE_BIT_DO_NOT_APPLY_TRENDING enum value | Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::TranslatorRuleSet |
FIELD_RULE_BIT_DO_NOT_TEST_HIGH_LOW enum value | Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::TranslatorRuleSet |
FIELD_RULE_BIT_DO_NOT_TEST_OPEN enum value | Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::TranslatorRuleSet |
FIELD_RULE_BIT_DO_NOT_UPDATE_FIELD enum value | Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::TranslatorRuleSet |
FIELD_RULE_DO_NOT_APPLY_ADD_RULE_1 | Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::TranslatorRuleSet | [static]
FIELD_RULE_DO_NOT_APPLY_ADD_RULE_2 | Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::TranslatorRuleSet | [static]
FIELD_RULE_DO_NOT_APPLY_CHANGE_RULE | Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::TranslatorRuleSet | [static]
FIELD_RULE_DO_NOT_APPLY_TRENDING | Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::TranslatorRuleSet | [static]
FIELD_RULE_DO_NOT_TEST_HIGH_LOW | Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::TranslatorRuleSet | [static]
FIELD_RULE_DO_NOT_TEST_OPEN | Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::TranslatorRuleSet | [static]
FIELD_RULE_DO_NOT_UPDATE_FIELD | Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::TranslatorRuleSet | [static]
GetFieldRules(const bool shouldUpdateField, const bool shouldTestHighLow, const bool shouldTestOpen, const bool shouldApplyAddRule1, const bool shouldApplyAddRule2, const bool shouldApplyTrending, const bool shouldApplyChangeRule) | Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::TranslatorRuleSet | [inline, static]
ShouldApplyAddRule1(const uint8_t fieldRules) | Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::TranslatorRuleSet | [inline, static]
ShouldApplyAddRule2(const uint8_t fieldRules) | Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::TranslatorRuleSet | [inline, static]
ShouldApplyChangeRule(const uint8_t fieldRules) | Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::TranslatorRuleSet | [inline, static]
ShouldApplyTrending(const uint8_t fieldRules) | Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::TranslatorRuleSet | [inline, static]
ShouldTestHighLow(const uint8_t fieldRules) | Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::TranslatorRuleSet | [inline, static]
ShouldTestOpen(const uint8_t fieldRules) | Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::TranslatorRuleSet | [inline, static]
ShouldUpdateField(const uint8_t fieldRules) | Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::TranslatorRuleSet | [inline, static]

Generated on Wed Oct 8 14:02:08 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::TableTemplate Member List

This is the complete list of members for Activ::ContentPlatform::Feed::TableTemplate, including all inherited members.

ApplyTableTemplateAddition(const TableTemplate &tableTemplateAddition) | Activ::ContentPlatform::Feed::TableTemplate |
BeginCopyOnReset() const | Activ::ContentPlatform::Feed::TableTemplate |
BeginField() const | Activ::ContentPlatform::Feed::TableTemplate |
BeginIndex() const | Activ::ContentPlatform::Feed::TableTemplate |
BeginRule() const | Activ::ContentPlatform::Feed::TableTemplate |
BeginUndefineOnReset() const | Activ::ContentPlatform::Feed::TableTemplate |
Clear() | Activ::ContentPlatform::Feed::TableTemplate |
CopyOnResetToString() const | Activ::ContentPlatform::Feed::TableTemplate |
EndCopyOnReset() const | Activ::ContentPlatform::Feed::TableTemplate |
EndField() const | Activ::ContentPlatform::Feed::TableTemplate |
EndIndex() const | Activ::ContentPlatform::Feed::TableTemplate |
EndRule() const | Activ::ContentPlatform::Feed::TableTemplate |
EndUndefineOnReset() const | Activ::ContentPlatform::Feed::TableTemplate |
FieldSpecificationList typedef | Activ::ContentPlatform::Feed::TableTemplate |
FieldsToString() const | Activ::ContentPlatform::Feed::TableTemplate |
GetAmfRecordSize() const | Activ::ContentPlatform::Feed::TableTemplate | [inline]
GetAmfTableId() const | Activ::ContentPlatform::Feed::TableTemplate | [inline]
GetCacheSize() const | Activ::ContentPlatform::Feed::TableTemplate | [inline]
GetCodeIdentifier() const | Activ::ContentPlatform::Feed::TableTemplate | [inline]
GetError() const | Activ::ContentPlatform::Feed::TableTemplate | [inline]
GetField(const FieldId fieldId, const Field *&pField) const | Activ::ContentPlatform::Feed::TableTemplate |
GetField(const FieldId fieldId) const | Activ::ContentPlatform::Feed::TableTemplate | [inline]
GetFirstField(const Field *&pField) const | Activ::ContentPlatform::Feed::TableTemplate |
GetFirstIndex(const Index *&pIndex) const | Activ::ContentPlatform::Feed::TableTemplate |
GetId() const | Activ::ContentPlatform::Feed::TableTemplate | [inline]
GetId(const TableNo number, const TableVersion version) | Activ::ContentPlatform::Feed::TableTemplate | [inline, static]
GetIndex(const IndexNumber indexNumber, const Index *&pIndex) const | Activ::ContentPlatform::Feed::TableTemplate |
GetInitialMaxRecords() const | Activ::ContentPlatform::Feed::TableTemplate | [inline]
GetMaxNumber() | Activ::ContentPlatform::Feed::TableTemplate | [inline, static]
GetMaxVersion() | Activ::ContentPlatform::Feed::TableTemplate | [inline, static]
GetName() const | Activ::ContentPlatform::Feed::TableTemplate | [inline]
GetNextField(const Field *&pField) const | Activ::ContentPlatform::Feed::TableTemplate |
GetNextIndex(const Index *&pIndex) const | Activ::ContentPlatform::Feed::TableTemplate |
GetNumber() const | Activ::ContentPlatform::Feed::TableTemplate | [inline]
GetNumber(const TableId id) | Activ::ContentPlatform::Feed::TableTemplate | [inline, static]
GetNumberOfGrowRecords() const | Activ::ContentPlatform::Feed::TableTemplate | [inline]
GetNumberOfPurgeDays() const | Activ::ContentPlatform::Feed::TableTemplate | [inline]
GetResetType() const | Activ::ContentPlatform::Feed::TableTemplate | [inline]
GetRule(const FieldId fieldId, const Rule *&pRule) const | Activ::ContentPlatform::Feed::TableTemplate | [inline]
GetType() const | Activ::ContentPlatform::Feed::TableTemplate | [inline]
GetUiHeading() | Activ::ContentPlatform::Feed::TableTemplate | [static]
GetVersion() const | Activ::ContentPlatform::Feed::TableTemplate | [inline]
GetVersion(const TableId id) | Activ::ContentPlatform::Feed::TableTemplate | [inline, static]
IndexesToString() const | Activ::ContentPlatform::Feed::TableTemplate |
Initialize(const UniversalFieldList &universalFieldList, const Specification &specification) | Activ::ContentPlatform::Feed::TableTemplate |
Initialize(const UniversalFieldList &universalFieldList, const std::string &xmlFileName) | Activ::ContentPlatform::Feed::TableTemplate |
Initialize(const UniversalFieldList &universalFieldList, Application &application, const ServiceHandle &serviceHandle, const Database::Record &record, IHeap *const pHeap=0, const std::string &componentId=Component::defaultComponentId) | Activ::ContentPlatform::Feed::TableTemplate |
IsAmfTable() const | Activ::ContentPlatform::Feed::TableTemplate | [inline]
IsContributed() const | Activ::ContentPlatform::Feed::TableTemplate | [inline]
IsContributed(const TableId id) | Activ::ContentPlatform::Feed::TableTemplate | [inline, static]
IsDiskBased() const | Activ::ContentPlatform::Feed::TableTemplate | [inline]
IsLatestVersion() const | Activ::ContentPlatform::Feed::TableTemplate | [inline]
IsPurged() const | Activ::ContentPlatform::Feed::TableTemplate | [inline]
IsTableTemplate(const std::string &xmlFileName) | Activ::ContentPlatform::Feed::TableTemplate | [static]
operator!=(const TableTemplate &rhs) const | Activ::ContentPlatform::Feed::TableTemplate |
operator==(const TableTemplate &rhs) const | Activ::ContentPlatform::Feed::TableTemplate |
RulesToString() const | Activ::ContentPlatform::Feed::TableTemplate |
SetLatestVersion(const bool isLatestVersion) | Activ::ContentPlatform::Feed::TableTemplate | [inline]
TableTemplate() | Activ::ContentPlatform::Feed::TableTemplate |
TableTemplate(const UniversalFieldList &universalFieldList, const Specification &specification) | Activ::ContentPlatform::Feed::TableTemplate |
TableTemplate(const UniversalFieldList &universalFieldList, const std::string &xmlFileName) | Activ::ContentPlatform::Feed::TableTemplate |
TableTemplate(const UniversalFieldList &universalFieldList, Application &application, const ServiceHandle &serviceHandle, const Database::Record &record, IHeap *const pHeap=0) | Activ::ContentPlatform::Feed::TableTemplate |
TableTemplateAddition (defined in Activ::ContentPlatform::Feed::TableTemplate) | Activ::ContentPlatform::Feed::TableTemplate | [friend]
ToString(bool shouldDisplayFields=false, bool shouldDisplayIndices=false, bool shouldDisplayRules=false, bool shouldDisplayCopyOnReset=false, bool shouldDisplayUndefineOnReset=false) const | Activ::ContentPlatform::Feed::TableTemplate |
UndefineOnResetToString() const | Activ::ContentPlatform::Feed::TableTemplate |
~TableTemplate() | Activ::ContentPlatform::Feed::TableTemplate |

Generated on Wed Oct 8 14:02:09 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::TableTemplate::ConstCopyOnResetIterator Member List

This is the complete list of members for Activ::ContentPlatform::Feed::TableTemplate::ConstCopyOnResetIterator, including all inherited members.

ConstCopyOnResetIterator() | Activ::ContentPlatform::Feed::TableTemplate::ConstCopyOnResetIterator |
operator *() const | Activ::ContentPlatform::Feed::TableTemplate::ConstCopyOnResetIterator |
operator!=(const ConstCopyOnResetIterator &rhs) const | Activ::ContentPlatform::Feed::TableTemplate::ConstCopyOnResetIterator |
operator++() | Activ::ContentPlatform::Feed::TableTemplate::ConstCopyOnResetIterator |
operator++(int) | Activ::ContentPlatform::Feed::TableTemplate::ConstCopyOnResetIterator |
operator->() const | Activ::ContentPlatform::Feed::TableTemplate::ConstCopyOnResetIterator |
operator==(const ConstCopyOnResetIterator &rhs) const | Activ::ContentPlatform::Feed::TableTemplate::ConstCopyOnResetIterator |
TableTemplate (defined in Activ::ContentPlatform::Feed::TableTemplate::ConstCopyOnResetIterator) | Activ::ContentPlatform::Feed::TableTemplate::ConstCopyOnResetIterator | [friend]

Generated on Wed Oct 8 14:02:09 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::TableTemplate::ConstFieldIterator Member List

This is the complete list of members for Activ::ContentPlatform::Feed::TableTemplate::ConstFieldIterator, including all inherited members.

ConstFieldIterator() | Activ::ContentPlatform::Feed::TableTemplate::ConstFieldIterator |
GetField() const | Activ::ContentPlatform::Feed::TableTemplate::ConstFieldIterator |
GetFieldId() const | Activ::ContentPlatform::Feed::TableTemplate::ConstFieldIterator |
operator *() const | Activ::ContentPlatform::Feed::TableTemplate::ConstFieldIterator |
operator!=(const ConstFieldIterator &rhs) const | Activ::ContentPlatform::Feed::TableTemplate::ConstFieldIterator |
operator++() | Activ::ContentPlatform::Feed::TableTemplate::ConstFieldIterator |
operator++(int) | Activ::ContentPlatform::Feed::TableTemplate::ConstFieldIterator |
operator->() const | Activ::ContentPlatform::Feed::TableTemplate::ConstFieldIterator |
operator==(const ConstFieldIterator &rhs) const | Activ::ContentPlatform::Feed::TableTemplate::ConstFieldIterator |
TableTemplate (defined in Activ::ContentPlatform::Feed::TableTemplate::ConstFieldIterator) | Activ::ContentPlatform::Feed::TableTemplate::ConstFieldIterator | [friend]

Generated on Wed Oct 8 14:02:09 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::TableTemplate::ConstIndexIterator Member List

This is the complete list of members for Activ::ContentPlatform::Feed::TableTemplate::ConstIndexIterator, including all inherited members.

ConstIndexIterator() | Activ::ContentPlatform::Feed::TableTemplate::ConstIndexIterator |
operator *() const | Activ::ContentPlatform::Feed::TableTemplate::ConstIndexIterator |
operator!=(const ConstIndexIterator &rhs) const | Activ::ContentPlatform::Feed::TableTemplate::ConstIndexIterator |
operator++() | Activ::ContentPlatform::Feed::TableTemplate::ConstIndexIterator |
operator++(int) | Activ::ContentPlatform::Feed::TableTemplate::ConstIndexIterator |
operator->() const | Activ::ContentPlatform::Feed::TableTemplate::ConstIndexIterator |
operator==(const ConstIndexIterator &rhs) const | Activ::ContentPlatform::Feed::TableTemplate::ConstIndexIterator |
TableTemplate (defined in Activ::ContentPlatform::Feed::TableTemplate::ConstIndexIterator) | Activ::ContentPlatform::Feed::TableTemplate::ConstIndexIterator | [friend]

Generated on Wed Oct 8 14:02:09 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::TableTemplate::ConstRuleIterator Member List

This is the complete list of members for Activ::ContentPlatform::Feed::TableTemplate::ConstRuleIterator, including all inherited members.

ConstRuleIterator() | Activ::ContentPlatform::Feed::TableTemplate::ConstRuleIterator |
GetFieldId() const | Activ::ContentPlatform::Feed::TableTemplate::ConstRuleIterator |
GetRule() const | Activ::ContentPlatform::Feed::TableTemplate::ConstRuleIterator |
operator *() const | Activ::ContentPlatform::Feed::TableTemplate::ConstRuleIterator |
operator!=(const ConstRuleIterator &rhs) const | Activ::ContentPlatform::Feed::TableTemplate::ConstRuleIterator |
operator++() | Activ::ContentPlatform::Feed::TableTemplate::ConstRuleIterator |
operator++(int) | Activ::ContentPlatform::Feed::TableTemplate::ConstRuleIterator |
operator->() const | Activ::ContentPlatform::Feed::TableTemplate::ConstRuleIterator |
operator==(const ConstRuleIterator &rhs) const | Activ::ContentPlatform::Feed::TableTemplate::ConstRuleIterator |
TableTemplate (defined in Activ::ContentPlatform::Feed::TableTemplate::ConstRuleIterator) | Activ::ContentPlatform::Feed::TableTemplate::ConstRuleIterator | [friend]

Generated on Wed Oct 8 14:02:09 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::TableTemplate::ConstUndefineOnResetIterator Member List

This is the complete list of members for Activ::ContentPlatform::Feed::TableTemplate::ConstUndefineOnResetIterator, including all inherited members.

ConstUndefineOnResetIterator() | Activ::ContentPlatform::Feed::TableTemplate::ConstUndefineOnResetIterator |
operator *() const | Activ::ContentPlatform::Feed::TableTemplate::ConstUndefineOnResetIterator |
operator!=(const ConstUndefineOnResetIterator &rhs) const | Activ::ContentPlatform::Feed::TableTemplate::ConstUndefineOnResetIterator |
operator++() | Activ::ContentPlatform::Feed::TableTemplate::ConstUndefineOnResetIterator |
operator++(int) | Activ::ContentPlatform::Feed::TableTemplate::ConstUndefineOnResetIterator |
operator->() const | Activ::ContentPlatform::Feed::TableTemplate::ConstUndefineOnResetIterator |
operator==(const ConstUndefineOnResetIterator &rhs) const | Activ::ContentPlatform::Feed::TableTemplate::ConstUndefineOnResetIterator |
TableTemplate (defined in Activ::ContentPlatform::Feed::TableTemplate::ConstUndefineOnResetIterator) | Activ::ContentPlatform::Feed::TableTemplate::ConstUndefineOnResetIterator | [friend]

Generated on Wed Oct 8 14:02:09 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::TableTemplate::FieldSpecification Member List

This is the complete list of members for Activ::ContentPlatform::Feed::TableTemplate::FieldSpecification, including all inherited members.

FieldSpecification(const FieldId id, const size_t maxLength, const bool isAmfField=false, const uint8_t amfRowIndex=0, const uint8_t amfRowOffset=0, const uint8_t amfFieldIndex=0) | Activ::ContentPlatform::Feed::TableTemplate::FieldSpecification
m_amfFieldIndex | Activ::ContentPlatform::Feed::TableTemplate::FieldSpecification
m_amfRowIndex | Activ::ContentPlatform::Feed::TableTemplate::FieldSpecification
m_amfRowOffset | Activ::ContentPlatform::Feed::TableTemplate::FieldSpecification
m_id | Activ::ContentPlatform::Feed::TableTemplate::FieldSpecification
m_isAmfField | Activ::ContentPlatform::Feed::TableTemplate::FieldSpecification
m_maxLength | Activ::ContentPlatform::Feed::TableTemplate::FieldSpecification

Generated on Wed Oct 8 14:02:09 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::TableTemplate::Specification Member List

This is the complete list of members for Activ::ContentPlatform::Feed::TableTemplate::Specification, including all inherited members.

m_amfRecordSize | Activ::ContentPlatform::Feed::TableTemplate::Specification
m_amfTableId | Activ::ContentPlatform::Feed::TableTemplate::Specification
m_codeIdentifier | Activ::ContentPlatform::Feed::TableTemplate::Specification
m_fieldSpecificationList | Activ::ContentPlatform::Feed::TableTemplate::Specification
m_id | Activ::ContentPlatform::Feed::TableTemplate::Specification
m_indexSpecificationList | Activ::ContentPlatform::Feed::TableTemplate::Specification
m_isAmfTable | Activ::ContentPlatform::Feed::TableTemplate::Specification
m_isLatestVersion | Activ::ContentPlatform::Feed::TableTemplate::Specification
m_name | Activ::ContentPlatform::Feed::TableTemplate::Specification
m_type | Activ::ContentPlatform::Feed::TableTemplate::Specification
Specification(const TableId id, const std::string &name, const std::string &codeIdentifier, const TableType type, const bool isLatestVersion, const TableTemplate::FieldSpecificationList &fieldSpecificationList, const Index::IndexSpecificationList &indexSpecificationList, const bool isAmfTable=false, const uint8_t amfTableId=0, const uint8_t amfRecordSize=0) | Activ::ContentPlatform::Feed::TableTemplate::Specification

Generated on Wed Oct 8 14:02:09 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::TableTemplateAddition Member List

This is the complete list of members for Activ::ContentPlatform::Feed::TableTemplateAddition, including all inherited members.

ApplyTableTemplateAddition(const TableTemplate &tableTemplateAddition) | Activ::ContentPlatform::Feed::TableTemplate |
BeginCopyOnReset() const | Activ::ContentPlatform::Feed::TableTemplate |
BeginField() const | Activ::ContentPlatform::Feed::TableTemplate |
BeginIndex() const | Activ::ContentPlatform::Feed::TableTemplate |
BeginRule() const | Activ::ContentPlatform::Feed::TableTemplate |
BeginUndefineOnReset() const | Activ::ContentPlatform::Feed::TableTemplate |
Clear() | Activ::ContentPlatform::Feed::TableTemplate |
CopyOnResetToString() const | Activ::ContentPlatform::Feed::TableTemplate |
EndCopyOnReset() const | Activ::ContentPlatform::Feed::TableTemplate |
EndField() const | Activ::ContentPlatform::Feed::TableTemplate |
EndIndex() const | Activ::ContentPlatform::Feed::TableTemplate |
EndRule() const | Activ::ContentPlatform::Feed::TableTemplate |
EndUndefineOnReset() const | Activ::ContentPlatform::Feed::TableTemplate |
FieldSpecificationList typedef | Activ::ContentPlatform::Feed::TableTemplate |
FieldsToString() const | Activ::ContentPlatform::Feed::TableTemplate |
GetAmfRecordSize() const | Activ::ContentPlatform::Feed::TableTemplate | [inline]
GetAmfTableId() const | Activ::ContentPlatform::Feed::TableTemplate | [inline]
GetCacheSize() const | Activ::ContentPlatform::Feed::TableTemplate | [inline]
GetCodeIdentifier() const | Activ::ContentPlatform::Feed::TableTemplate | [inline]
GetError() const | Activ::ContentPlatform::Feed::TableTemplate | [inline]
GetField(const FieldId fieldId, const Field *&pField) const | Activ::ContentPlatform::Feed::TableTemplate |
GetField(const FieldId fieldId) const | Activ::ContentPlatform::Feed::TableTemplate | [inline]
GetFirstField(const Field *&pField) const | Activ::ContentPlatform::Feed::TableTemplate |
GetFirstIndex(const Index *&pIndex) const | Activ::ContentPlatform::Feed::TableTemplate |
GetId() const | Activ::ContentPlatform::Feed::TableTemplate | [inline]
GetId(const TableNo number, const TableVersion version) | Activ::ContentPlatform::Feed::TableTemplate | [inline, static]
GetIndex(const IndexNumber indexNumber, const Index *&pIndex) const | Activ::ContentPlatform::Feed::TableTemplate |
GetInitialMaxRecords() const | Activ::ContentPlatform::Feed::TableTemplate | [inline]
GetMaxNumber() | Activ::ContentPlatform::Feed::TableTemplate | [inline, static]
GetMaxVersion() | Activ::ContentPlatform::Feed::TableTemplate | [inline, static]
GetName() const | Activ::ContentPlatform::Feed::TableTemplate | [inline]
GetNextField(const Field *&pField) const | Activ::ContentPlatform::Feed::TableTemplate |
GetNextIndex(const Index *&pIndex) const | Activ::ContentPlatform::Feed::TableTemplate |
GetNumber() const | Activ::ContentPlatform::Feed::TableTemplate | [inline]
GetNumber(const TableId id) | Activ::ContentPlatform::Feed::TableTemplate | [inline, static]
GetNumberOfGrowRecords() const | Activ::ContentPlatform::Feed::TableTemplate | [inline]
GetNumberOfPurgeDays() const | Activ::ContentPlatform::Feed::TableTemplate | [inline]
GetResetType() const | Activ::ContentPlatform::Feed::TableTemplate | [inline]
GetRule(const FieldId fieldId, const Rule *&pRule) const | Activ::ContentPlatform::Feed::TableTemplate | [inline]
GetType() const | Activ::ContentPlatform::Feed::TableTemplate | [inline]
GetUiHeading() | Activ::ContentPlatform::Feed::TableTemplate | [static]
GetVersion() const | Activ::ContentPlatform::Feed::TableTemplate | [inline]
GetVersion(const TableId id) | Activ::ContentPlatform::Feed::TableTemplate | [inline, static]
IndexesToString() const | Activ::ContentPlatform::Feed::TableTemplate |
Initialize(const UniversalFieldList &universalFieldList, const std::string &xmlFileName) | Activ::ContentPlatform::Feed::TableTemplateAddition |
Activ::ContentPlatform::Feed::TableTemplate::Initialize(const UniversalFieldList &universalFieldList, const Specification &specification) | Activ::ContentPlatform::Feed::TableTemplate |
Activ::ContentPlatform::Feed::TableTemplate::Initialize(const UniversalFieldList &universalFieldList, Application &application, const ServiceHandle &serviceHandle, const Database::Record &record, IHeap *const pHeap=0, const std::string &componentId=Component::defaultComponentId) | Activ::ContentPlatform::Feed::TableTemplate |
IsAmfTable() const | Activ::ContentPlatform::Feed::TableTemplate | [inline]
IsContributed() const | Activ::ContentPlatform::Feed::TableTemplate | [inline]
IsContributed(const TableId id) | Activ::ContentPlatform::Feed::TableTemplate | [inline, static]
IsDiskBased() const | Activ::ContentPlatform::Feed::TableTemplate | [inline]
IsLatestVersion() const | Activ::ContentPlatform::Feed::TableTemplate | [inline]
IsPurged() const | Activ::ContentPlatform::Feed::TableTemplate | [inline]
IsTableTemplate(const std::string &xmlFileName) | Activ::ContentPlatform::Feed::TableTemplate | [static]
IsTableTemplateAddition(const std::string &xmlFileName) | Activ::ContentPlatform::Feed::TableTemplateAddition | [static]
operator!=(const TableTemplate &rhs) const | Activ::ContentPlatform::Feed::TableTemplate |
operator==(const TableTemplate &rhs) const | Activ::ContentPlatform::Feed::TableTemplate |
RulesToString() const | Activ::ContentPlatform::Feed::TableTemplate |
SetLatestVersion(const bool isLatestVersion) | Activ::ContentPlatform::Feed::TableTemplate | [inline]
TableTemplate() | Activ::ContentPlatform::Feed::TableTemplate |
TableTemplate(const UniversalFieldList &universalFieldList, const Specification &specification) | Activ::ContentPlatform::Feed::TableTemplate |
TableTemplate(const UniversalFieldList &universalFieldList, const std::string &xmlFileName) | Activ::ContentPlatform::Feed::TableTemplate |
TableTemplate(const UniversalFieldList &universalFieldList, Application &application, const ServiceHandle &serviceHandle, const Database::Record &record, IHeap *const pHeap=0) | Activ::ContentPlatform::Feed::TableTemplate |
TableTemplateAddition() | Activ::ContentPlatform::Feed::TableTemplateAddition |
TableTemplateAddition(const UniversalFieldList &universalFieldList, const std::string &xmlFileName) | Activ::ContentPlatform::Feed::TableTemplateAddition |
ToString(bool shouldDisplayFields=false, bool shouldDisplayIndices=false, bool shouldDisplayRules=false, bool shouldDisplayCopyOnReset=false, bool shouldDisplayUndefineOnReset=false) const | Activ::ContentPlatform::Feed::TableTemplate |
UndefineOnResetToString() const | Activ::ContentPlatform::Feed::TableTemplate |
~TableTemplate() | Activ::ContentPlatform::Feed::TableTemplate |

Generated on Wed Oct 8 14:02:09 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::TableTemplateException Member List

This is the complete list of members for Activ::ContentPlatform::Feed::TableTemplateException, including all inherited members.

AddException(Exception *pException) const | Activ::Exception |
Exception(const char *file, const char *function, const uint_fast32_t line, const uint_fast32_t errorCode=0) | Activ::Exception |
Exception(const Exception &rhs) | Activ::Exception |
m_errorCode | Activ::Exception |
m_file | Activ::Exception |
m_function | Activ::Exception |
m_line | Activ::Exception |
TableTemplateException(const char *file, const char *function, const uint_fast32_t line, const std::string &error) | Activ::ContentPlatform::Feed::TableTemplateException |
ToStream(std::ostream &os) const | Activ::Exception | [virtual]
ToString() const | Activ::ContentPlatform::Feed::TableTemplateException | [virtual]
~Exception() | Activ::Exception | [virtual]

Generated on Wed Oct 8 14:02:09 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::TableTemplateField Member List

This is the complete list of members for Activ::ContentPlatform::Feed::TableTemplateField, including all inherited members.

GetMaxLength(uint32_t &maxLength) const | Activ::ContentPlatform::Feed::TableTemplateField
Initialize(const UniversalField &universalField, MessageValidator &messageValidator) | Activ::ContentPlatform::Feed::TableTemplateField
IsInitialized() const | Activ::ContentPlatform::Feed::TableTemplateField
Reset() | Activ::ContentPlatform::Feed::TableTemplateField
TableTemplateField() | Activ::ContentPlatform::Feed::TableTemplateField
TableTemplateField(const UniversalField &universalField, MessageValidator &messageValidator) | Activ::ContentPlatform::Feed::TableTemplateField
~TableTemplateField() | Activ::ContentPlatform::Feed::TableTemplateField

Generated on Wed Oct 8 14:02:09 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::TableTemplateFieldListValidator Member List

This is the complete list of members for Activ::ContentPlatform::Feed::TableTemplateFieldListValidator, including all inherited members.

Begin() const | Activ::ContentPlatform::Feed::TableTemplateFieldListValidator
End() const | Activ::ContentPlatform::Feed::TableTemplateFieldListValidator
GetTableTemplateField(const FieldId fieldId, const TableTemplateField *&pTableTemplateField) const | Activ::ContentPlatform::Feed::TableTemplateFieldListValidator
Initialize(const UniversalFieldList &universalFieldList, MessageValidator &messageValidator) | Activ::ContentPlatform::Feed::TableTemplateFieldListValidator
IsInitialized() const | Activ::ContentPlatform::Feed::TableTemplateFieldListValidator
Reset() | Activ::ContentPlatform::Feed::TableTemplateFieldListValidator
TableTemplateFieldListValidator() | Activ::ContentPlatform::Feed::TableTemplateFieldListValidator
TableTemplateFieldListValidator(const UniversalFieldList &universalFieldList, MessageValidator &messageValidator) | Activ::ContentPlatform::Feed::TableTemplateFieldListValidator
~TableTemplateFieldListValidator() | Activ::ContentPlatform::Feed::TableTemplateFieldListValidator

Generated on Wed Oct 8 14:02:09 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::TableTemplateFieldListValidator::ConstIterator Member List

This is the complete list of members for Activ::ContentPlatform::Feed::TableTemplateFieldListValidator::ConstIterator, including all inherited members.

ConstIterator() | Activ::ContentPlatform::Feed::TableTemplateFieldListValidator::ConstIterator |
GetFieldId() const | Activ::ContentPlatform::Feed::TableTemplateFieldListValidator::ConstIterator |
GetTableTemplateField() const | Activ::ContentPlatform::Feed::TableTemplateFieldListValidator::ConstIterator |
operator!=(const ConstIterator &rhs) const | Activ::ContentPlatform::Feed::TableTemplateFieldListValidator::ConstIterator |
operator++() | Activ::ContentPlatform::Feed::TableTemplateFieldListValidator::ConstIterator |
operator++(int) | Activ::ContentPlatform::Feed::TableTemplateFieldListValidator::ConstIterator |
operator==(const ConstIterator &rhs) const | Activ::ContentPlatform::Feed::TableTemplateFieldListValidator::ConstIterator |
TableTemplateFieldListValidator (defined in Activ::ContentPlatform::Feed::TableTemplateFieldListValidator::ConstIterator) | Activ::ContentPlatform::Feed::TableTemplateFieldListValidator::ConstIterator | [friend]

Generated on Wed Oct 8 14:02:09 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::TableTemplateIndex Member List

This is the complete list of members for Activ::ContentPlatform::Feed::TableTemplateIndex, including all inherited members.

Begin() const | Activ::ContentPlatform::Feed::TableTemplateIndex
ConstIterator typedef (defined in Activ::ContentPlatform::Feed::TableTemplateIndex) | Activ::ContentPlatform::Feed::TableTemplateIndex
End() const | Activ::ContentPlatform::Feed::TableTemplateIndex
GetName(const TextString *&pName) const | Activ::ContentPlatform::Feed::TableTemplateIndex
GetNumber(IndexNumber &number) const | Activ::ContentPlatform::Feed::TableTemplateIndex
GetProperties(IndexProperties &properties) const | Activ::ContentPlatform::Feed::TableTemplateIndex
GetType(IndexType &type) const | Activ::ContentPlatform::Feed::TableTemplateIndex
Initialize(const TableTemplateFieldListValidator &tableTemplateFieldListValidator, MessageValidator &messageValidator) | Activ::ContentPlatform::Feed::TableTemplateIndex
IsInitialized() const | Activ::ContentPlatform::Feed::TableTemplateIndex
Reset() | Activ::ContentPlatform::Feed::TableTemplateIndex
TableTemplateIndex() | Activ::ContentPlatform::Feed::TableTemplateIndex
TableTemplateIndex(const TableTemplateFieldListValidator &tableTemplateFieldListValidator, MessageValidator &messageValidator) | Activ::ContentPlatform::Feed::TableTemplateIndex
~TableTemplateIndex() | Activ::ContentPlatform::Feed::TableTemplateIndex

Generated on Wed Oct 8 14:02:09 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::TableTemplateIndexListValidator Member List

This is the complete list of members for Activ::ContentPlatform::Feed::TableTemplateIndexListValidator, including all inherited members.

Begin() const | Activ::ContentPlatform::Feed::TableTemplateIndexListValidator
ConstIterator typedef (defined in Activ::ContentPlatform::Feed::TableTemplateIndexListValidator) | Activ::ContentPlatform::Feed::TableTemplateIndexListValidator
End() const | Activ::ContentPlatform::Feed::TableTemplateIndexListValidator
GetTableTemplateIndex(const IndexNumber indexNumber, const TableTemplateIndex *&pTableTemplateIndex) const | Activ::ContentPlatform::Feed::TableTemplateIndexListValidator
Initialize(const TableTemplateFieldListValidator &tableTemplateFieldListValidator, MessageValidator &messageValidator) | Activ::ContentPlatform::Feed::TableTemplateIndexListValidator
IsInitialized() const | Activ::ContentPlatform::Feed::TableTemplateIndexListValidator
Reset() | Activ::ContentPlatform::Feed::TableTemplateIndexListValidator
TableTemplateIndexListValidator() | Activ::ContentPlatform::Feed::TableTemplateIndexListValidator
TableTemplateIndexListValidator(const TableTemplateFieldListValidator &tableTemplateFieldListValidator, MessageValidator &messageValidator) | Activ::ContentPlatform::Feed::TableTemplateIndexListValidator
~TableTemplateIndexListValidator() | Activ::ContentPlatform::Feed::TableTemplateIndexListValidator

Generated on Wed Oct 8 14:02:09 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::TableTemplateList Member List

This is the complete list of members for Activ::ContentPlatform::Feed::TableTemplateList, including all inherited members.

ApplyTableTemplateAddition(const TableTemplateAddition &tableTemplateAddition) | Activ::ContentPlatform::Feed::TableTemplateList |
Begin() const | Activ::ContentPlatform::Feed::TableTemplateList |
Clear() | Activ::ContentPlatform::Feed::TableTemplateList |
End() const | Activ::ContentPlatform::Feed::TableTemplateList |
GetError() const | Activ::ContentPlatform::Feed::TableTemplateList | [inline]
GetFirstTableTemplate(const TableTemplate *&pTableTemplate) const | Activ::ContentPlatform::Feed::TableTemplateList |
GetLatestTableTemplate(const TableNo tableNumber, const TableTemplate *&pTableTemplate) const | Activ::ContentPlatform::Feed::TableTemplateList |
GetLatestTableTemplateId(const TableNo tableNumber, TableId &tableId) const | Activ::ContentPlatform::Feed::TableTemplateList |
GetNextTableTemplate(const TableTemplate *&pTableTemplate) const | Activ::ContentPlatform::Feed::TableTemplateList |
GetSize() const | Activ::ContentPlatform::Feed::TableTemplateList | [inline]
GetTableTemplate(const TableId tableId, const TableTemplate *&pTableTemplate) const | Activ::ContentPlatform::Feed::TableTemplateList |
GetUniversalField(const FieldId fieldId, const UniversalField *&pUniversalField) const | Activ::ContentPlatform::Feed::TableTemplateList |
GetUniversalFieldList() const | Activ::ContentPlatform::Feed::TableTemplateList |
Initialize(bool shouldInitializeUniversalFieldList=true) | Activ::ContentPlatform::Feed::TableTemplateList |
Initialize(Application &application, const Settings &settings, IHeap *const pHeap, const std::string &componentId=Component::defaultComponentId) | Activ::ContentPlatform::Feed::TableTemplateList |
Initialize(const std::string &path) | Activ::ContentPlatform::Feed::TableTemplateList |
Initialize(const PathList &pathList) | Activ::ContentPlatform::Feed::TableTemplateList |
Initialize(Application &application, const ServiceIdList &serviceIdList, IHeap *const pHeap=0, const std::string &componentId=Component::defaultComponentId) | Activ::ContentPlatform::Feed::TableTemplateList |
Initialize(Application &application, const ServiceHandleList &serviceHandleList, IHeap *const pHeap=0, const std::string &componentId=Component::defaultComponentId) | Activ::ContentPlatform::Feed::TableTemplateList |
InsertTableTemplate(const TableTemplate &tableTemplate, bool updateLatestVersion=false) | Activ::ContentPlatform::Feed::TableTemplateList |
RemoveTableTemplate(const TableId tableId) | Activ::ContentPlatform::Feed::TableTemplateList |
Reset() | Activ::ContentPlatform::Feed::TableTemplateList |
TableTemplateList() | Activ::ContentPlatform::Feed::TableTemplateList |
TableTemplateList(Application &application, const Settings &settings) | Activ::ContentPlatform::Feed::TableTemplateList |
TableTemplateList(const std::string &path) | Activ::ContentPlatform::Feed::TableTemplateList |
TableTemplateList(const PathList &pathList) | Activ::ContentPlatform::Feed::TableTemplateList |
TableTemplateList(Application &application, const ServiceIdList &serviceIdList, IHeap *const pHeap=0) | Activ::ContentPlatform::Feed::TableTemplateList |
TableTemplateList(Application &application, const ServiceHandleList &serviceHandleList, IHeap *const pHeap=0) | Activ::ContentPlatform::Feed::TableTemplateList |
ToString(bool shouldDisplayInitializeType=false) const | Activ::ContentPlatform::Feed::TableTemplateList |
UiAddAllOptions(UiMenu &uiMenu, const std::string &sectionName=std::string()) | Activ::ContentPlatform::Feed::TableTemplateList |
UiDisplayTableTemplateFields(const Activ::UiIo &uiIo) | Activ::ContentPlatform::Feed::TableTemplateList |
UiDisplayTableTemplatesList(const Activ::UiIo &uiIo) | Activ::ContentPlatform::Feed::TableTemplateList |
UiDisplayUniversalFieldList(const Activ::UiIo &uiIo) | Activ::ContentPlatform::Feed::TableTemplateList |
UiReInitializeTableTemplateListFromHeaders(const Activ::UiIo &uiIo) | Activ::ContentPlatform::Feed::TableTemplateList |
UiReInitializeTableTemplateListFromPathList(const Activ::UiIo &uiIo) | Activ::ContentPlatform::Feed::TableTemplateList |
UiReInitializeTableTemplateListFromSettingsObject(const Activ::UiIo &uiIo) | Activ::ContentPlatform::Feed::TableTemplateList |
~TableTemplateList() | Activ::ContentPlatform::Feed::TableTemplateList |

Generated on Wed Oct 8 14:02:09 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::TableTemplateList::ConstIterator Member List

This is the complete list of members for Activ::ContentPlatform::Feed::TableTemplateList::ConstIterator, including all inherited members.

ConstIterator() | Activ::ContentPlatform::Feed::TableTemplateList::ConstIterator |
GetTableId() const | Activ::ContentPlatform::Feed::TableTemplateList::ConstIterator |
GetTableTemplate() const | Activ::ContentPlatform::Feed::TableTemplateList::ConstIterator |
operator *() const | Activ::ContentPlatform::Feed::TableTemplateList::ConstIterator |
operator!=(const ConstIterator &rhs) const | Activ::ContentPlatform::Feed::TableTemplateList::ConstIterator |
operator++() | Activ::ContentPlatform::Feed::TableTemplateList::ConstIterator |
operator++(int) | Activ::ContentPlatform::Feed::TableTemplateList::ConstIterator |
operator->() const | Activ::ContentPlatform::Feed::TableTemplateList::ConstIterator |
operator==(const ConstIterator &rhs) const | Activ::ContentPlatform::Feed::TableTemplateList::ConstIterator |
TableTemplateList (defined in Activ::ContentPlatform::Feed::TableTemplateList::ConstIterator) | Activ::ContentPlatform::Feed::TableTemplateList::ConstIterator | [friend]

Generated on Wed Oct 8 14:02:09 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::TableTemplateList::Settings Member List

This is the complete list of members for Activ::ContentPlatform::Feed::TableTemplateList::Settings, including all inherited members.

GetFromIniFile(const std::string &iniFileName, const std::string &sectionName) | Activ::ContentPlatform::Feed::TableTemplateList::Settings | [static]
m_pathList | Activ::ContentPlatform::Feed::TableTemplateList::Settings |
m_serviceHandleList | Activ::ContentPlatform::Feed::TableTemplateList::Settings |
m_serviceIdList | Activ::ContentPlatform::Feed::TableTemplateList::Settings |
m_shouldReInitializeOnReset | Activ::ContentPlatform::Feed::TableTemplateList::Settings |
m_shouldTerminateOnError | Activ::ContentPlatform::Feed::TableTemplateList::Settings |
m_tableClientHeapBucketInfo | Activ::ContentPlatform::Feed::TableTemplateList::Settings |
Read(const IniFileParser::ConstSectionIterator &sectionIterator) | Activ::ContentPlatform::Feed::TableTemplateList::Settings |
Settings() | Activ::ContentPlatform::Feed::TableTemplateList::Settings |

Generated on Wed Oct 8 14:02:09 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::TableTemplateList::TableTemplateSpecification Member List

This is the complete list of members for Activ::ContentPlatform::Feed::TableTemplateList::TableTemplateSpecification, including all inherited members.

m_codeIdentifier | Activ::ContentPlatform::Feed::TableTemplateList::TableTemplateSpecification
m_fieldSpecificationList | Activ::ContentPlatform::Feed::TableTemplateList::TableTemplateSpecification
m_indexSpecificationList | Activ::ContentPlatform::Feed::TableTemplateList::TableTemplateSpecification
m_isLatestVersion | Activ::ContentPlatform::Feed::TableTemplateList::TableTemplateSpecification
m_name | Activ::ContentPlatform::Feed::TableTemplateList::TableTemplateSpecification
m_number | Activ::ContentPlatform::Feed::TableTemplateList::TableTemplateSpecification
m_type | Activ::ContentPlatform::Feed::TableTemplateList::TableTemplateSpecification
m_version | Activ::ContentPlatform::Feed::TableTemplateList::TableTemplateSpecification
TableTemplateSpecification(const TableNo number, const TableVersion version, const std::string &name, const std::string &codeIdentifier, const TableType type, const bool isLatestVersion, const TableTemplate::FieldSpecificationList &fieldSpecificationList, const Index::IndexSpecificationList &indexSpecificationList) | Activ::ContentPlatform::Feed::TableTemplateList::TableTemplateSpecification

Generated on Wed Oct 8 14:02:09 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::TableTemplateMessageHeaderDefinitions Member List

This is the complete list of members for Activ::ContentPlatform::Feed::TableTemplateMessageHeaderDefinitions, including all inherited members.

GetMessageHeader() | Activ::ContentPlatform::Feed::TableTemplateMessageHeaderDefinitions | [inline, static]
IsValidMessageType(const MessageHeaderDefinitions::MessageHeader messageHeader) | Activ::ContentPlatform::Feed::TableTemplateMessageHeaderDefinitions | [inline, static]
MAX_INDEX_NAME_LENGTH | Activ::ContentPlatform::Feed::TableTemplateMessageHeaderDefinitions | [static]
MAX_NAME_LENGTH | Activ::ContentPlatform::Feed::TableTemplateMessageHeaderDefinitions | [static]
MESSAGE_HEADER_FLAGS_RESERVED_LENGTH | Activ::ContentPlatform::Feed::TableTemplateMessageHeaderDefinitions | [static]
MESSAGE_HEADER_FLAGS_RESERVED_OFFSET | Activ::ContentPlatform::Feed::TableTemplateMessageHeaderDefinitions | [static]
MESSAGE_TYPE | Activ::ContentPlatform::Feed::TableTemplateMessageHeaderDefinitions | [static]

Generated on Wed Oct 8 14:02:10 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::TableTemplateMessageValidator Member List

This is the complete list of members for Activ::ContentPlatform::Feed::TableTemplateMessageValidator, including all inherited members.

BeginField() const | Activ::ContentPlatform::Feed::TableTemplateMessageValidator
BeginIndex() const | Activ::ContentPlatform::Feed::TableTemplateMessageValidator
ConstFieldIterator typedef | Activ::ContentPlatform::Feed::TableTemplateMessageValidator
ConstIndexIterator typedef | Activ::ContentPlatform::Feed::TableTemplateMessageValidator
EndField() const | Activ::ContentPlatform::Feed::TableTemplateMessageValidator
EndIndex() const | Activ::ContentPlatform::Feed::TableTemplateMessageValidator
GetName(const TextString *&pName) const | Activ::ContentPlatform::Feed::TableTemplateMessageValidator
GetTableId(TableId &tableId) const | Activ::ContentPlatform::Feed::TableTemplateMessageValidator
GetTableTemplateField(const FieldId fieldId, const TableTemplateField *&pTableTemplateField) const | Activ::ContentPlatform::Feed::TableTemplateMessageValidator
GetTableTemplateIndex(const IndexNumber indexNumber, const TableTemplateIndex *&pTableTemplateIndex) const | Activ::ContentPlatform::Feed::TableTemplateMessageValidator
Initialize(const UniversalFieldList &universalFieldList, MessageValidator &messageValidator) | Activ::ContentPlatform::Feed::TableTemplateMessageValidator
Initialize(const UniversalFieldList &universalFieldList) | Activ::ContentPlatform::Feed::TableTemplateMessageValidator
Initialize(MessageValidator &messageValidator) | Activ::ContentPlatform::Feed::TableTemplateMessageValidator
IsInitialized() const | Activ::ContentPlatform::Feed::TableTemplateMessageValidator
Reset() | Activ::ContentPlatform::Feed::TableTemplateMessageValidator
TableTemplateMessageValidator() | Activ::ContentPlatform::Feed::TableTemplateMessageValidator
TableTemplateMessageValidator(const UniversalFieldList &universalFieldList, MessageValidator &messageValidator) | Activ::ContentPlatform::Feed::TableTemplateMessageValidator
TableTemplateMessageValidator(const UniversalFieldList &universalFieldList) | Activ::ContentPlatform::Feed::TableTemplateMessageValidator
~TableTemplateMessageValidator() | Activ::ContentPlatform::Feed::TableTemplateMessageValidator

Generated on Wed Oct 8 14:02:10 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::UniversalFieldHelper Member List

This is the complete list of members for Activ::ContentPlatform::Feed::UniversalFieldHelper, including all inherited members.

m_codeIdentifier | Activ::ContentPlatform::Feed::UniversalFieldHelper |
m_description | Activ::ContentPlatform::Feed::UniversalFieldHelper |
m_fieldId | Activ::ContentPlatform::Feed::UniversalFieldHelper |
m_maxLength | Activ::ContentPlatform::Feed::UniversalFieldHelper |
m_name | Activ::ContentPlatform::Feed::UniversalFieldHelper |
m_type | Activ::ContentPlatform::Feed::UniversalFieldHelper |
UniversalFieldHelper() | Activ::ContentPlatform::Feed::UniversalFieldHelper | [inline]
UniversalFieldHelper(const FieldId fieldId, const char *const pName, const char *const pCodeIdentifier, const char *const pDescription, const FieldType type, const size_t maxLength) | Activ::ContentPlatform::Feed::UniversalFieldHelper | [inline]

Generated on Wed Oct 8 14:02:10 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::UniversalFieldList Member List

This is the complete list of members for Activ::ContentPlatform::Feed::UniversalFieldList, including all inherited members.

Begin() const | Activ::ContentPlatform::Feed::UniversalFieldList |
Clear() | Activ::ContentPlatform::Feed::UniversalFieldList | [inline]
DEFAULT_FILENAME | Activ::ContentPlatform::Feed::UniversalFieldList | [static]
End() const | Activ::ContentPlatform::Feed::UniversalFieldList |
GetError() const | Activ::ContentPlatform::Feed::UniversalFieldList | [inline]
GetUniversalField(const FieldId fieldId, const UniversalField *&pUniversalField) const | Activ::ContentPlatform::Feed::UniversalFieldList |
Initialize() | Activ::ContentPlatform::Feed::UniversalFieldList |
Initialize(const UniversalFieldSpecificationList &universalFieldSpecificationList) | Activ::ContentPlatform::Feed::UniversalFieldList |
Initialize(const std::string &path) | Activ::ContentPlatform::Feed::UniversalFieldList |
Initialize(const PathList &pathList) | Activ::ContentPlatform::Feed::UniversalFieldList |
Initialize(Application &application, const ServiceHandleList &serviceHandleList, IHeap *const pHeap=0, const std::string &componentId=Component::defaultComponentId) | Activ::ContentPlatform::Feed::UniversalFieldList |
InitializeList(const std::string &xmlFileName) | Activ::ContentPlatform::Feed::UniversalFieldList |
IsContributedUniversalFieldList(const std::string &xmlFileName) | Activ::ContentPlatform::Feed::UniversalFieldList | [static]
IsEmpty() const | Activ::ContentPlatform::Feed::UniversalFieldList | [inline]
ToString() const | Activ::ContentPlatform::Feed::UniversalFieldList |
UniversalFieldList() | Activ::ContentPlatform::Feed::UniversalFieldList |
UniversalFieldList(const UniversalFieldSpecificationList &universalFieldSpecificationList) | Activ::ContentPlatform::Feed::UniversalFieldList |
UniversalFieldList(const std::string &path) | Activ::ContentPlatform::Feed::UniversalFieldList |
UniversalFieldList(const PathList &pathList) | Activ::ContentPlatform::Feed::UniversalFieldList |
UniversalFieldList(Application &application, const ServiceHandleList &serviceHandleList) | Activ::ContentPlatform::Feed::UniversalFieldList |
~UniversalFieldList() | Activ::ContentPlatform::Feed::UniversalFieldList |

Generated on Wed Oct 8 14:02:10 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::UniversalFieldList::ConstIterator Member List

This is the complete list of members for Activ::ContentPlatform::Feed::UniversalFieldList::ConstIterator, including all inherited members.

ConstIterator() | Activ::ContentPlatform::Feed::UniversalFieldList::ConstIterator |
operator *() const | Activ::ContentPlatform::Feed::UniversalFieldList::ConstIterator |
operator!=(const ConstIterator &rhs) const | Activ::ContentPlatform::Feed::UniversalFieldList::ConstIterator |
operator++() | Activ::ContentPlatform::Feed::UniversalFieldList::ConstIterator |
operator++(int) | Activ::ContentPlatform::Feed::UniversalFieldList::ConstIterator |
operator->() const | Activ::ContentPlatform::Feed::UniversalFieldList::ConstIterator |
operator==(const ConstIterator &rhs) const | Activ::ContentPlatform::Feed::UniversalFieldList::ConstIterator |
UniversalFieldList (defined in Activ::ContentPlatform::Feed::UniversalFieldList::ConstIterator) | Activ::ContentPlatform::Feed::UniversalFieldList::ConstIterator | [friend]

Generated on Wed Oct 8 14:02:10 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::FeedApi::FieldListValidator Member List

This is the complete list of members for Activ::ContentPlatform::FeedApi::FieldListValidator, including all inherited members.

ApplyUpdate(const FieldListValidator &fieldListValidator) | Activ::ContentPlatform::FeedApi::FieldListValidator |
ApplyUpdateToExistingFieldsOnly(const FieldListValidator &fieldListValidator) | Activ::ContentPlatform::FeedApi::FieldListValidator |
Begin() const | Activ::ContentPlatform::FeedApi::FieldListValidator |
Clear() | Activ::ContentPlatform::FeedApi::FieldListValidator |
ContentGateway::FieldListValidator (defined in Activ::ContentPlatform::FeedApi::FieldListValidator) | Activ::ContentPlatform::FeedApi::FieldListValidator | [friend]
ContentGatewayApi::FieldListValidator (defined in Activ::ContentPlatform::FeedApi::FieldListValidator) | Activ::ContentPlatform::FeedApi::FieldListValidator | [friend]
ContentServerApi::FieldListValidator (defined in Activ::ContentPlatform::FeedApi::FieldListValidator) | Activ::ContentPlatform::FeedApi::FieldListValidator | [friend]
End() const | Activ::ContentPlatform::FeedApi::FieldListValidator |
FieldListValidator() | Activ::ContentPlatform::FeedApi::FieldListValidator |
FieldListValidator(const FieldListValidator &rhs) | Activ::ContentPlatform::FeedApi::FieldListValidator |
GetActivFieldType(const Feed::FieldId fieldId, const T *&pFieldType) const | Activ::ContentPlatform::FeedApi::FieldListValidator | [inline]
GetActivFieldType(const Feed::FieldId fieldId) const | Activ::ContentPlatform::FeedApi::FieldListValidator | [inline]
GetField(const Feed::FieldId fieldId, const Field *&pField) const | Activ::ContentPlatform::FeedApi::FieldListValidator | [inline]
GetNumberOfFields() const | Activ::ContentPlatform::FeedApi::FieldListValidator | [inline]
IsFieldPresent(const Feed::FieldId fieldId) const | Activ::ContentPlatform::FeedApi::FieldListValidator | [inline]
IsInitialized() const | Activ::ContentPlatform::FeedApi::FieldListValidator | [inline]
IsPartialSubset(const FieldListValidator &rhs) const | Activ::ContentPlatform::FeedApi::FieldListValidator | [inline]
IsSubset(const FieldListValidator &rhs) const | Activ::ContentPlatform::FeedApi::FieldListValidator | [inline]
operator=(const FieldListValidator &rhs) | Activ::ContentPlatform::FeedApi::FieldListValidator |
Reset() | Activ::ContentPlatform::FeedApi::FieldListValidator |
~FieldListValidator() | Activ::ContentPlatform::FeedApi::FieldListValidator |

Generated on Wed Oct 8 14:02:10 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::FeedApi::FieldListValidator::ConstIterator Member List

This is the complete list of members for Activ::ContentPlatform::FeedApi::FieldListValidator::ConstIterator, including all inherited members.

ConstIterator() | Activ::ContentPlatform::FeedApi::FieldListValidator::ConstIterator | [inline]
FieldListValidator (defined in Activ::ContentPlatform::FeedApi::FieldListValidator::ConstIterator) | Activ::ContentPlatform::FeedApi::FieldListValidator::ConstIterator | [friend]
GetField() const | Activ::ContentPlatform::FeedApi::FieldListValidator::ConstIterator | [inline]
GetFieldId() const | Activ::ContentPlatform::FeedApi::FieldListValidator::ConstIterator | [inline]
operator!=(const ConstIterator &rhs) const | Activ::ContentPlatform::FeedApi::FieldListValidator::ConstIterator | [inline]
operator++() | Activ::ContentPlatform::FeedApi::FieldListValidator::ConstIterator | [inline]
operator++(int) | Activ::ContentPlatform::FeedApi::FieldListValidator::ConstIterator | [inline]
operator==(const ConstIterator &rhs) const | Activ::ContentPlatform::FeedApi::FieldListValidator::ConstIterator | [inline]

Generated on Wed Oct 8 14:02:10 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::FeedApi::FieldListValidator::Field Member List

This is the complete list of members for Activ::ContentPlatform::FeedApi::FieldListValidator::Field, including all inherited members.

Field(const Feed::FieldId fieldId) | Activ::ContentPlatform::FeedApi::FieldListValidator::Field |
GetActivFieldType(const T *&pFieldType) const | Activ::ContentPlatform::FeedApi::FieldListValidator::Field | [inline]
GetActivFieldType() const | Activ::ContentPlatform::FeedApi::FieldListValidator::Field | [inline]
m_fieldId | Activ::ContentPlatform::FeedApi::FieldListValidator::Field |
m_fieldStatus | Activ::ContentPlatform::FeedApi::FieldListValidator::Field |
m_pIFieldType | Activ::ContentPlatform::FeedApi::FieldListValidator::Field |
m_rules | Activ::ContentPlatform::FeedApi::FieldListValidator::Field |
RULE_DOES_NOT_UPDATE_LAST_VALUE | Activ::ContentPlatform::FeedApi::FieldListValidator::Field | [static]
RULE_NONE (defined in Activ::ContentPlatform::FeedApi::FieldListValidator::Field) | Activ::ContentPlatform::FeedApi::FieldListValidator::Field | [static]
Rules typedef | Activ::ContentPlatform::FeedApi::FieldListValidator::Field |

Generated on Wed Oct 8 14:02:10 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::FeedApi::SymbolPatternHelper Member List

This is the complete list of members for Activ::ContentPlatform::FeedApi::SymbolPatternHelper, including all inherited members.

Initialize(const std::string &pattern) | Activ::ContentPlatform::FeedApi::SymbolPatternHelper |
IsMatch(const std::string &str, const size_t fromPart) const | Activ::ContentPlatform::FeedApi::SymbolPatternHelper |
IsPattern() const | Activ::ContentPlatform::FeedApi::SymbolPatternHelper |
SymbolPatternHelper() | Activ::ContentPlatform::FeedApi::SymbolPatternHelper |
~SymbolPatternHelper() | Activ::ContentPlatform::FeedApi::SymbolPatternHelper | [virtual]

Generated on Wed Oct 8 14:02:10 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::CrcBlob Member List

This is the complete list of members for Activ::CrcBlob, including all inherited members.

Assign(const IFieldType *const pIFieldType) | Activ::IFieldType |
CalculateCrc(const uint8_t *const pData, const size_t size, const uint32_t intitialCrc=0) | Activ::CrcBlob | [static]
Clear() | Activ::CrcBlob | [inline, virtual]
Compare(const CrcBlob &rhs, int &result) const | Activ::CrcBlob |
Compare(const void *const pRhsSerializedBody, const size_t rhsSerializedBodyLength, int &result) const | Activ::CrcBlob | [virtual]
Compare(const void *const pLhsSerializedBody, const size_t lhsSerializedBodyLength, const void *const pRhsSerializedBody, const size_t rhsSerializedBodyLength, int &result) | Activ::CrcBlob | [static]
Compress() const | Activ::CrcBlob | [inline]
Compress(bool shouldSerializeCompressed, bool shouldForceSerializeCompressed=false) | Activ::CrcBlob | [inline]
Compress(const uint8_t *const pSource, const size_t sourceLength, uint8_t *const pTarget, const size_t targetSize, size_t &targetLength) | Activ::CrcBlob | [inline, static]
Convert(const IFieldType *const pIFieldType) | Activ::CrcBlob | [virtual]
CrcBlob() | Activ::CrcBlob | [inline]
CrcBlob(const uint32_t crc, const uint8_t *const pData, const size_t size, const size_t sizeWhenDecompressed) | Activ::CrcBlob | [inline]
CrcBlob(const uint8_t *const pData, const size_t size) | Activ::CrcBlob | [inline]
CrcBlob(const CrcBlob &rhs) | Activ::CrcBlob | [inline]
Decompress() const | Activ::CrcBlob | [inline]
Decompress(bool shouldSerializeDecompressed) | Activ::CrcBlob | [inline]
Decompress(const uint8_t *const pSource, const size_t sourceLength, uint8_t *const pTarget, const size_t targetSize, size_t &targetLength) | Activ::CrcBlob | [inline, static]
Deserialize(MessageValidator &messageValidator, const size_t maxSerializedBodyLength) | Activ::CrcBlob | [virtual]
Deserialize(MessageValidator &messageValidator, const size_t maxSerializedBodyLength, uint32_t &crc, const uint8_t *&pData, size_t &size, size_t &sizeWhenDecompressed) | Activ::CrcBlob | [static]
Activ::IFieldType::Deserialize(const FieldType fieldType, MessageValidator &messageValidator, const size_t maxSerializedBodyLength) | Activ::IFieldType |
DeserializeBody(const void *const pSerializedBody, const size_t serializedBodyLength) | Activ::CrcBlob | [virtual]
DeserializeBody(const void *const pSerializedBody, const size_t serializedBodyLength, uint32_t &crc, const uint8_t *&pData, size_t &size, size_t &sizeWhenDecompressed) | Activ::CrcBlob | [static]
Activ::IFieldType::DeserializeBody(const FieldType fieldType, const void *const pSerializedBody, const size_t serializedBodyLength) | Activ::IFieldType |
DeserializeLengthAndBody(MessageValidator &messageValidator, const size_t maxSerializedBodyLength=MAX_SERIALIZED_BODY_LENGTH_UNDEFINED) | Activ::CrcBlob | [virtual]
DeserializeLengthAndBody(MessageValidator &messageValidator, const size_t maxSerializedBodyLength, uint32_t &crc, const uint8_t *&pData, size_t &size, size_t &sizeWhenDecompressed) | Activ::CrcBlob | [static]
Activ::IFieldType::DeserializeLengthAndBody(const FieldType fieldType, MessageValidator &messageValidator, const size_t maxSerializedBodyLength=MAX_SERIALIZED_BODY_LENGTH_UNDEFINED) | Activ::IFieldType |
FIELD_TYPE | Activ::CrcBlob | [static]
FromString(MessageValidator &messageValidator) | Activ::CrcBlob | [virtual]
Activ::IFieldType::FromString(const std::string &field) | Activ::IFieldType | [inline]
Get(uint32_t &crc, const uint8_t *&pData, size_t &size, size_t &sizeWhenDecompressed) const | Activ::CrcBlob | [inline]
Get(const uint8_t *&pData, size_t &size) const | Activ::CrcBlob | [inline]
GetCrc() const | Activ::CrcBlob | [inline]
GetCrcCompressed() const | Activ::CrcBlob | [inline]
GetCrcDecompressed() const | Activ::CrcBlob | [inline]
GetData() const | Activ::CrcBlob | [inline]
GetDataCompressed() const | Activ::CrcBlob | [inline]
GetDataDecompressed() const | Activ::CrcBlob | [inline]
GetFromStringFormat() const | Activ::CrcBlob | [virtual]
GetMaxSerializedBodyLength(const size_t size) | Activ::CrcBlob | [inline, static]
GetMaxSerializedLength(const size_t size) | Activ::CrcBlob | [inline, static]
GetSerializedBodyLength() const | Activ::CrcBlob | [inline, virtual]
GetSerializedLength() const | Activ::CrcBlob | [inline, virtual]
GetSize() const | Activ::CrcBlob | [inline]
GetSizeCompressed() const | Activ::CrcBlob | [inline]
GetSizeDecompressed() const | Activ::CrcBlob | [inline]
GetSizeWhenDecompressed() const | Activ::CrcBlob | [inline]
GetType() const | Activ::IFieldType | [inline]
IFieldType(const FieldType fieldType) | Activ::IFieldType | [inline, explicit, protected]
IsCompressed() const | Activ::CrcBlob | [inline]
IsDifferent(const void *const pRhsSerializedBody, const size_t rhsSerializedBodyLength, bool &isDifferent) const | Activ::CrcBlob | [virtual]
IsInitialized() const | Activ::IFieldType | [inline]
IsValidSerializedBodyLength(const size_t serializedBodyLength) | Activ::CrcBlob | [inline, static]
Activ::IFieldType::IsValidSerializedBodyLength(const FieldType fieldType, const size_t serializedBodyLength) | Activ::IFieldType | [static]
m_isInitialized | Activ::IFieldType | [protected]
MAX_SERIALIZED_BODY_LENGTH_UNDEFINED | Activ::IFieldType | [static]
operator=(const CrcBlob &rhs) | Activ::CrcBlob | [inline]
Reset() | Activ::CrcBlob | [inline, virtual]
Serialize(MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength) const | Activ::CrcBlob | [virtual]
Serialize(MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength, const uint32_t crc, const uint8_t *const pData, const size_t size, const size_t sizeWhenDecompressed=0) | Activ::CrcBlob | [static]
Activ::IFieldType::Serialize(const FieldType fieldType, MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength) const | Activ::IFieldType |
Activ::IFieldType::Serialize(const FieldType fieldType, MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength, const uint8_t *const pData, const size_t size) | Activ::IFieldType | [static]
SerializeBody(void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength) const | Activ::CrcBlob | [virtual]
SerializeBody(void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength, const uint32_t crc, const uint8_t *const pData, const size_t size, const size_t sizeWhenDecompressed=0) | Activ::CrcBlob | [static]
Activ::IFieldType::SerializeBody(const FieldType fieldType, void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength) const | Activ::IFieldType |
Activ::IFieldType::SerializeBody(const FieldType fieldType, void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength, const uint8_t *const pData, const size_t size) | Activ::IFieldType | [static]
SerializeLengthAndBody(MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength=MAX_SERIALIZED_BODY_LENGTH_UNDEFINED) const | Activ::CrcBlob | [virtual]
SerializeLengthAndBody(MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength, const uint32_t crc, const uint8_t *const pData, const size_t size, const size_t sizeWhenDecompressed=0) | Activ::CrcBlob | [static]
Activ::IFieldType::SerializeLengthAndBody(const FieldType fieldType, MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength=MAX_SERIALIZED_BODY_LENGTH_UNDEFINED) const | Activ::IFieldType |
Activ::IFieldType::SerializeLengthAndBody(const FieldType fieldType, MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength, const uint8_t *const pData, const size_t size) | Activ::IFieldType | [static]
Set(const uint32_t crc, const uint8_t *const pData, const size_t size, const size_t sizeWhenDecompressed) | Activ::CrcBlob | [inline]
Set(const uint8_t *const pData, const size_t size) | Activ::CrcBlob | [inline]
ToString() const | Activ::CrcBlob | [virtual]
ToString(const bool isHexFormat) const | Activ::CrcBlob | [virtual]
ValidateSerializedLengthAndBody(MessageValidator &messageValidator, size_t &serializedBodyOffset, size_t &serializedBodyLength) | Activ::CrcBlob | [static]
Activ::IFieldType::ValidateSerializedLengthAndBody(const FieldType fieldType, MessageValidator &messageValidator, size_t &serializedBodyOffset, size_t &serializedBodyLength) | Activ::IFieldType | [static]
~CrcBlob() | Activ::CrcBlob | [inline, virtual]
~IFieldType()=0 | Activ::IFieldType | [inline, pure virtual]

Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::CrtException Member List

This is the complete list of members for Activ::CrtException, including all inherited members.

AddException(Exception *pException) const | Activ::Exception |
CrtException(const char *file, const char *function, uint_fast32_t line, const uint_fast32_t errorCode) | Activ::CrtException |
Exception(const char *file, const char *function, const uint_fast32_t line, const uint_fast32_t errorCode=0) | Activ::Exception |
Exception(const Exception &rhs) | Activ::Exception |
m_errorCode | Activ::Exception |
m_file | Activ::Exception |
m_function | Activ::Exception |
m_line | Activ::Exception |
ToStream(std::ostream &os) const | Activ::Exception | [virtual]
ToString() const | Activ::CrtException | [virtual]
~Exception() | Activ::Exception | [virtual]

Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::CtrlHandler Member List

This is the complete list of members for Activ::CtrlHandler, including all inherited members.

CTRL_BREAK enum value (defined in Activ::CtrlHandler) | Activ::CtrlHandler |
CTRL_C enum value (defined in Activ::CtrlHandler) | Activ::CtrlHandler |
CTRL_EXIT_PROCESS enum value (defined in Activ::CtrlHandler) | Activ::CtrlHandler |
CTRL_LOGOFF_USER enum value (defined in Activ::CtrlHandler) | Activ::CtrlHandler |
CTRL_SHUTDOWN_MACHINE enum value (defined in Activ::CtrlHandler) | Activ::CtrlHandler |
CtrlHandler() | Activ::CtrlHandler |
EventType enum name | Activ::CtrlHandler |
OnEvent(const EventType eventType) | Activ::CtrlHandler | [protected, virtual]
~CtrlHandler() | Activ::CtrlHandler | [virtual]

Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::CurlFtpHelper Member List

This is the complete list of members for Activ::CurlFtpHelper, including all inherited members.

CleanUp() | Activ::CurlFtpHelper | [inline, static]
Connect() | Activ::CurlFtpHelper | [inline, virtual]
CurlFtpHelper(const std::string &server, const std::string &username="", const std::string &password="", uint32_t port=IFtpHelper::DEFAULT_FTP_PORT, bool useEpsv=false, const std::string &curlLogFilename="", uint32_t timeout=IFtpHelper::DEFAULT_FTP_TIMEOUT, uint32_t lowSpeedLimit=IFtpHelper::DEFAULT_FTP_LOW_SPEED_LIMIT, uint32_t lowSpeedTime=IFtpHelper::DEFAULT_FTP_LOW_SPEED_TIME) | Activ::CurlFtpHelper | [inline]
DEFAULT_FTP_LOW_SPEED_LIMIT | Activ::IFtpHelper | [static]
DEFAULT_FTP_LOW_SPEED_TIME | Activ::IFtpHelper | [static]
DEFAULT_FTP_PORT | Activ::IFtpHelper | [static]
DEFAULT_FTP_TIMEOUT | Activ::IFtpHelper | [static]
DeleteFile(const std::string &remoteFilename, const std::string &remoteDirectory="") | Activ::CurlFtpHelper | [inline, virtual]
DeleteFile(const FileInfoList &fileInfoList, const std::string &remoteDirectory="") | Activ::CurlFtpHelper | [inline, virtual]
Disconnect() | Activ::CurlFtpHelper | [inline, virtual]
GetAndDeleteFile(const std::string &remoteFilename, const std::string &localFilename, const std::string &remoteDirectory="") | Activ::CurlFtpHelper | [inline, virtual]
GetFile(const std::string &remoteFilename, const std::string &localFilename, const std::string &remoteDirectory="") | Activ::CurlFtpHelper | [inline, virtual]
GetFileList(FileInfoList &fileInfoList, const std::string &remoteDirectory="") | Activ::CurlFtpHelper | [inline, virtual]
GetLowSpeedLimit() const (defined in Activ::CurlFtpHelper) | Activ::CurlFtpHelper | [inline]
GetLowSpeedTime() const (defined in Activ::CurlFtpHelper) | Activ::CurlFtpHelper | [inline]
GetTimeout() const | Activ::CurlFtpHelper | [inline]
GetUseEpsv() const (defined in Activ::CurlFtpHelper) | Activ::CurlFtpHelper | [inline]
IFtpHelper(const std::string &server, const std::string &username="", const std::string &password="", uint32_t port=DEFAULT_FTP_PORT) | Activ::IFtpHelper | [inline]
Initialize() | Activ::CurlFtpHelper | [inline, static]
IsConnected() const | Activ::CurlFtpHelper | [inline, virtual]
m_password | Activ::IFtpHelper | [protected]
m_port | Activ::IFtpHelper | [protected]
m_server | Activ::IFtpHelper | [protected]
m_username | Activ::IFtpHelper | [protected]
SetCurlLogFilename(const std::string &logFilename) (defined in Activ::CurlFtpHelper) | Activ::CurlFtpHelper | [inline]
SetLowSpeedLimit(uint32_t lowSpeedLimit) (defined in Activ::CurlFtpHelper) | Activ::CurlFtpHelper | [inline]
SetLowSpeedTime(uint32_t lowSpeedTime) (defined in Activ::CurlFtpHelper) | Activ::CurlFtpHelper | [inline]
SetPassword(const std::string &password) (defined in Activ::IFtpHelper) | Activ::IFtpHelper | [inline]
SetPort(const uint32_t &port) (defined in Activ::IFtpHelper) | Activ::IFtpHelper | [inline]
SetServer(const std::string &server) (defined in Activ::IFtpHelper) | Activ::IFtpHelper | [inline]
SetTimeout(uint32_t timeout) | Activ::CurlFtpHelper | [inline]
SetUseEpsv(bool useEpsv) (defined in Activ::CurlFtpHelper) | Activ::CurlFtpHelper | [inline]
SetUsername(const std::string &username) (defined in Activ::IFtpHelper) | Activ::IFtpHelper | [inline]
~CurlFtpHelper() (defined in Activ::CurlFtpHelper) | Activ::CurlFtpHelper | [inline, virtual]
~IFtpHelper() | Activ::IFtpHelper | [inline, virtual]

Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::CurlFtpHelper::CurlInitializeHelper Member List

This is the complete list of members for Activ::CurlFtpHelper::CurlInitializeHelper, including all inherited members.

CurlInitializeHelper() | Activ::CurlFtpHelper::CurlInitializeHelper | [inline]
~CurlInitializeHelper() | Activ::CurlFtpHelper::CurlInitializeHelper | [inline]

Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Database::Database Member List

This is the complete list of members for Activ::Database::Database, including all inherited members.

AttachTable(const DatabaseSpecification::TableId tableId, ITable *pTable) | Activ::Database::Database |
Begin() const | Activ::Database::Database | [inline]
Begin() | Activ::Database::Database | [inline]
ConstIterator (defined in Activ::Database::Database) | Activ::Database::Database | [friend]
Database(const std::string &name=std::string(), const DatabaseSpecification::Properties properties=DatabaseSpecification::PROPERTY_NONE) | Activ::Database::Database |
DetachTable(const DatabaseSpecification::TableId tableId, ITable *&pTable) | Activ::Database::Database |
End() const | Activ::Database::Database | [inline]
End() | Activ::Database::Database | [inline]
GetEqual(const Key &key, Record &record) const | Activ::Database::Database |
GetEqual(const ITable *pTable, const IndexSpecification::Number indexNo, const Key &key, Record &record) const | Activ::Database::Database |
GetMode() const | Activ::Database::Database | [inline]
GetName() const | Activ::Database::Database |
GetNumberOfTables() const | Activ::Database::Database |
GetSearchOrder() const | Activ::Database::Database |
GetSpecification() const | Activ::Database::Database |
GetTable(const DatabaseSpecification::TableId tableId, ITable *&pTable) const | Activ::Database::Database |
GetTableIdList() const | Activ::Database::Database | [inline]
Iterator (defined in Activ::Database::Database) | Activ::Database::Database | [friend]
SerializeSpecification(MessageBuilder &messageBuilder) const | Activ::Database::Database |
SetMode(const Mode mode) | Activ::Database::Database | [inline]
SetSearchOrder(const TableIdList &tableIdList) | Activ::Database::Database |
~Database() | Activ::Database::Database |

Generated on Wed Oct 8 14:02:10 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Database::Database::ConstIterator Member List

This is the complete list of members for Activ::Database::Database::ConstIterator, including all inherited members.

Database (defined in Activ::Database::Database::ConstIterator) | Activ::Database::Database::ConstIterator | [friend]
GetTable() const | Activ::Database::Database::ConstIterator | [inline]
GetTableId() const | Activ::Database::Database::ConstIterator | [inline]
operator!=(const ConstIterator &rhs) const | Activ::Database::Database::ConstIterator | [inline]
operator++() | Activ::Database::Database::ConstIterator | [inline]
operator++(int) | Activ::Database::Database::ConstIterator | [inline]
operator==(const ConstIterator &rhs) const | Activ::Database::Database::ConstIterator | [inline]

Generated on Wed Oct 8 14:02:10 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Database::Database::Iterator Member List

This is the complete list of members for Activ::Database::Database::Iterator, including all inherited members.

Database (defined in Activ::Database::Database::Iterator) | Activ::Database::Database::Iterator | [friend]
GetTable() | Activ::Database::Database::Iterator | [inline]
GetTableId() const | Activ::Database::Database::Iterator | [inline]
operator!=(const Iterator &rhs) const | Activ::Database::Database::Iterator | [inline]
operator++() | Activ::Database::Database::Iterator | [inline]
operator++(int) | Activ::Database::Database::Iterator | [inline]
operator==(const Iterator &rhs) const | Activ::Database::Database::Iterator | [inline]

Generated on Wed Oct 8 14:02:10 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Database::DatabaseException Member List

This is the complete list of members for Activ::Database::DatabaseException, including all inherited members.

ACTIV_DECLARE_ELEMENT_1_WITH_COMMA enum value (defined in Activ::Database::DatabaseException) | Activ::Database::DatabaseException |
AddException(Exception *pException) const | Activ::Exception |
DatabaseException(const char file[], const char function[], const uint_fast32_t line, const uint_fast32_t errorCode) | Activ::Database::DatabaseException |
DatabaseException(const char file[], const char function[], const uint_fast32_t line, const uint_fast32_t errorCode, const char format[],...) | Activ::Database::DatabaseException |
Errors enum name | Activ::Database::DatabaseException |
Exception(const char *file, const char *function, const uint_fast32_t line, const uint_fast32_t errorCode=0) | Activ::Exception |
Exception(const Exception &rhs) | Activ::Exception |
m_errorCode | Activ::Exception |
m_file | Activ::Exception |
m_function | Activ::Exception |
m_line | Activ::Exception |
ToStream(std::ostream &os) const | Activ::Exception | [virtual]
ToString() const | Activ::Database::DatabaseException | [virtual]
~Exception() | Activ::Exception | [virtual]

Generated on Wed Oct 8 14:02:10 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Database::DatabaseSpecification Member List

This is the complete list of members for Activ::Database::DatabaseSpecification, including all inherited members.

DatabaseSpecification(const std::string &name=std::string(), const Properties properties=PROPERTY_NONE, const DatabaseTableSpecificationList &databaseTableSpecificationList=DatabaseTableSpecificationList()) | Activ::Database::DatabaseSpecification |
DatabaseTableSpecificationList typedef | Activ::Database::DatabaseSpecification |
Deserialize(MessageValidator &messageValidator) | Activ::Database::DatabaseSpecification |
m_databaseTableSpecificationList | Activ::Database::DatabaseSpecification |
m_name | Activ::Database::DatabaseSpecification |
m_properties | Activ::Database::DatabaseSpecification |
Properties typedef | Activ::Database::DatabaseSpecification |
PROPERTY_CREATE_MUTEX enum value | Activ::Database::DatabaseSpecification |
PROPERTY_NONE enum value (defined in Activ::Database::DatabaseSpecification) | Activ::Database::DatabaseSpecification |
Serialize(MessageBuilder &messageBuilder) const | Activ::Database::DatabaseSpecification |
ShouldCreateMutex(const Properties properties) | Activ::Database::DatabaseSpecification | [static]
TableId typedef | Activ::Database::DatabaseSpecification |
ToString() const | Activ::Database::DatabaseSpecification |
UNDEFINED_TABLE_ID | Activ::Database::DatabaseSpecification | [static]
VERSION | Activ::Database::DatabaseSpecification | [static]

Generated on Wed Oct 8 14:02:10 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Database::DatabaseSpecification::DatabaseTableSpecification Member List

This is the complete list of members for Activ::Database::DatabaseSpecification::DatabaseTableSpecification, including all inherited members.

DatabaseTableSpecification(const TableId tableId=UNDEFINED_TABLE_ID, const TableSpecification &tableSpecification=TableSpecification(), const IndexSpecificationList &indexSpecificationList=IndexSpecificationList()) | Activ::Database::DatabaseSpecification::DatabaseTableSpecification
Deserialize(MessageValidator &messageValidator) | Activ::Database::DatabaseSpecification::DatabaseTableSpecification
m_indexSpecificationList | Activ::Database::DatabaseSpecification::DatabaseTableSpecification
m_tableId | Activ::Database::DatabaseSpecification::DatabaseTableSpecification
m_tableSpecification | Activ::Database::DatabaseSpecification::DatabaseTableSpecification
Serialize(MessageBuilder &messageBuilder) const | Activ::Database::DatabaseSpecification::DatabaseTableSpecification
ToString() const | Activ::Database::DatabaseSpecification::DatabaseTableSpecification

Generated on Wed Oct 8 14:02:10 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Database::FieldList Member List

This is the complete list of members for Activ::Database::FieldList, including all inherited members.

Begin() const | Activ::Database::FieldList | [inline]
Compare(const byte_t *pLhsData, const byte_t *pRhsData) const | Activ::Database::FieldList |
Compare(const byte_t *pLhsData, const byte_t *pRhsData, const size_t lastFieldNo) const | Activ::Database::FieldList |
Compare(const byte_t *pLhsData, const byte_t *pRhsData, const size_t lastFieldNo, const size_t lastCompareLength) const | Activ::Database::FieldList |
Compare(const size_t fieldNo, const byte_t *pLhsData, const byte_t *pRhsData) const | Activ::Database::FieldList |
CompareField(const FieldSpecification::Id fieldId, const byte_t *pLhsData, const IFieldType &iFieldType, int &result) const =0 | Activ::Database::FieldList | [pure virtual]
CompareField(const FieldSpecification::Id fieldId, const byte_t *pLhsData, const std::string &value, int &result) const =0 | Activ::Database::FieldList | [pure virtual]
CompareField(const FieldSpecification::Id lhsFieldId, const byte_t *pLhsData, const FieldList &rhsFieldList, const FieldSpecification::Id rhsFieldId, const byte_t *pRhsData, int &result) const | Activ::Database::FieldList | [virtual]
CompareKey(const byte_t *pLhsData, const byte_t *pRhsData) const | Activ::Database::FieldList |
CompareKey(const byte_t *pLhsData, const byte_t *pRhsData, const size_t lastFieldNo) const | Activ::Database::FieldList |
CompareKey(const byte_t *pLhsData, const byte_t *pRhsData, const size_t lastFieldNo, const size_t lastCompareLength) const | Activ::Database::FieldList |
CopyField(const FieldSpecification::Id fieldId, byte_t *pTargetData, const FieldList &sourceFieldList, const byte_t *pSourceData) const | Activ::Database::FieldList |
CopyField(const FieldSpecification::Id fieldId, byte_t *pTargetData, const FieldList &sourceFieldList, const byte_t *pSourceData, bool &isDifferent) const | Activ::Database::FieldList | [inline]
CopyField(const FieldSpecification::Id targetFieldId, byte_t *pTargetData, const FieldList &sourceFieldList, const FieldSpecification::Id sourceFieldId, const byte_t *pSourceData) const | Activ::Database::FieldList |
CopyField(const FieldSpecification::Id targetFieldId, byte_t *pTargetData, const FieldList &sourceFieldList, const FieldSpecification::Id sourceFieldId, const byte_t *pSourceData, bool &isDifferent) const | Activ::Database::FieldList | [inline]
CopyFields(byte_t *pTargetData, const FieldList &sourceFieldList, const byte_t *pSourceData, const bool copyAllFields=false) const | Activ::Database::FieldList |
CreateFieldIdLookupList(const FieldSpecificationList &fieldSpecificationList) | Activ::Database::FieldList |
CreateFieldIdMap(const FieldSpecificationList &fieldSpecificationList) | Activ::Database::FieldList |
DefineField(byte_t *pTargetData, const FieldSpecification::Id fieldId, const size_t fieldLength=~0) const =0 | Activ::Database::FieldList | [pure virtual]
DefineField(const size_t fieldNo, byte_t *pTargetData) const =0 | Activ::Database::FieldList | [pure virtual]
Deserialize(MessageValidator &messageValidator, byte_t *pTargetData) const =0 | Activ::Database::FieldList | [pure virtual]
DeserializeSpecification(MessageValidator &messageValidator, FieldSpecificationList &fieldSpecificationList) | Activ::Database::FieldList | [static]
End() const | Activ::Database::FieldList | [inline]
FieldIdMap typedef | Activ::Database::FieldList | [protected]
FieldList() | Activ::Database::FieldList |
GetDataLength() const | Activ::Database::FieldList | [inline]
GetField(const byte_t *pSourceData, const FieldSpecification::Id fieldId, void *pField, const size_t fieldSize, size_t &fieldLength) const | Activ::Database::FieldList |
GetField(const size_t fieldNo, const byte_t *pSourceData, const void *&pField, size_t &fieldLength) const | Activ::Database::FieldList |
GetField(const byte_t *pSourceData, const FieldSpecification::Id fieldId, const void *&pField, size_t &fieldLength) const | Activ::Database::FieldList |
GetField(byte_t *pSourceData, const FieldSpecification::Id fieldId, void *&pField, size_t &fieldLength) const | Activ::Database::FieldList |
GetField(const byte_t *pSourceData, const FieldSpecification::Id fieldId, T &value) const | Activ::Database::FieldList | [inline]
GetField(const byte_t *pSourceData, const ConstIterator &iterator, const void *&pField, size_t &fieldLength) const | Activ::Database::FieldList |
GetField(const byte_t *pSourceData, const ConstIterator &iterator, FieldSpecification::Id &fieldId, FieldSpecification::Type &type, const void *&pField, size_t &fieldLength) const | Activ::Database::FieldList |
GetFieldDefinition(const size_t fieldNo) const | Activ::Database::FieldList |
GetFieldIdList() const | Activ::Database::FieldList |
GetFieldLength(const size_t fieldNo, const byte_t *pSourceData) const =0 | Activ::Database::FieldList | [pure virtual]
GetFieldNumber(const FieldSpecification::Id fieldId, size_t &fieldNo) const | Activ::Database::FieldList | [inline]
GetFieldNumber(const FieldSpecification &fieldSpecification, size_t &fieldNo) const | Activ::Database::FieldList |
GetFieldSpecification(const FieldSpecification::Id fieldId, FieldSpecification &fieldSpecification) const | Activ::Database::FieldList |
GetFieldSpecification(const FieldSpecification::Id fieldId, size_t &fieldNo, const FieldSpecification *&pFieldSpecification) const | Activ::Database::FieldList |
GetFieldSpecificationList() const | Activ::Database::FieldList |
GetFirstFieldId(FieldSpecification::Id &fieldId) const | Activ::Database::FieldList |
GetFirstFieldSpecification(FieldSpecification &fieldSpecification) const | Activ::Database::FieldList |
GetNextFieldId(FieldSpecification::Id &fieldId) const | Activ::Database::FieldList |
GetNextFieldSpecification(FieldSpecification &fieldSpecification) const | Activ::Database::FieldList |
GetNumberOfFields() const | Activ::Database::FieldList | [inline]
GetType(const FieldSpecification::Id fieldId, FieldSpecification::Type &type) const | Activ::Database::FieldList |
IsFieldDefined(const byte_t *pSourceData, const FieldSpecification::Id fieldId, bool &result) const =0 | Activ::Database::FieldList | [pure virtual]
IsFieldDefined(const size_t fieldNo, const byte_t *pSourceData) const =0 | Activ::Database::FieldList | [pure virtual]
IsFieldDifferent(const FieldSpecification::Id fieldId, const byte_t *pLhsData, const void *pField, const size_t fieldLength, bool &result) const | Activ::Database::FieldList |
IsFieldDifferent(const FieldSpecification::Id fieldId, const byte_t *pLhsData, const IFieldType &iFieldType, bool &result) const | Activ::Database::FieldList |
IsFieldDifferent(const FieldSpecification::Id fieldId, const byte_t *pLhsData, const std::string &value, bool &result) const | Activ::Database::FieldList |
IsFieldDifferent(const FieldSpecification::Id fieldId, const byte_t *pLhsData, const FieldList &rhsFieldList, const byte_t *pRhsData, bool &result) const | Activ::Database::FieldList |
IsFieldDifferent(const FieldSpecification::Id lhsFieldId, const byte_t *pLhsData, const FieldList &rhsFieldList, const FieldSpecification::Id rhsFieldId, const byte_t *pRhsData, bool &result) const | Activ::Database::FieldList |
IsFound(const FieldSpecification::Id fieldId) const | Activ::Database::FieldList | [inline]
m_dataLength | Activ::Database::FieldList | [protected]
m_fieldIdMap | Activ::Database::FieldList | [protected]
m_fieldList | Activ::Database::FieldList | [protected]
m_fieldNoList | Activ::Database::FieldList | [protected]
m_nFields | Activ::Database::FieldList | [protected]
ResetData(byte_t *pTargetData) const =0 | Activ::Database::FieldList | [pure virtual]
Serialize(MessageBuilder &messageBuilder, const byte_t *pSourceData) const =0 | Activ::Database::FieldList | [pure virtual]
SerializeSpecification(MessageBuilder &messageBuilder) const | Activ::Database::FieldList |
SetField(const size_t targetFieldNo, byte_t *pTargetData, const size_t sourceFieldNo, const FieldList &sourceFieldList, const byte_t *pSourceData) const =0 | Activ::Database::FieldList | [pure virtual]
SetField(const size_t fieldNo, byte_t *pTargetData, const void *pField, const size_t fieldLength) const =0 | Activ::Database::FieldList | [pure virtual]
SetField(byte_t *pTargetData, const FieldSpecification::Id fieldId, const void *pField, const size_t fieldLength) const | Activ::Database::FieldList |
SetField(byte_t *pTargetData, const FieldSpecification::Id fieldId, const void *pField, const size_t fieldLength, bool &isDifferent) const | Activ::Database::FieldList |
SetField(byte_t *pTargetData, const FieldSpecification::Id fieldId, const T &value) const | Activ::Database::FieldList | [inline]
SetField(byte_t *pTargetData, const FieldSpecification::Id fieldId, const T &value, bool &isDifferent) const | Activ::Database::FieldList | [inline]
SetField(byte_t *pTargetData, const FieldSpecification::Id fieldId, const bool value) const =0 | Activ::Database::FieldList | [pure virtual]
ToLogString(const byte_t *pSourceData) const | Activ::Database::FieldList |
ToString(const byte_t *pSourceData) const | Activ::Database::FieldList |
UNDEFINED_FIELD_NUMBER | Activ::Database::FieldList | [protected, static]
UndefineField(byte_t *pTargetData, const FieldSpecification::Id fieldId) const =0 | Activ::Database::FieldList | [pure virtual]
UndefineField(byte_t *pTargetData, const FieldSpecification::Id fieldId, bool &isDifferent) const =0 | Activ::Database::FieldList | [pure virtual]
UndefineField(const size_t fieldNo, byte_t *pTargetData) const =0 | Activ::Database::FieldList | [pure virtual]
~FieldList() | Activ::Database::FieldList | [virtual]

Generated on Wed Oct 8 14:02:10 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Database::FieldList::ConstIterator Member List

This is the complete list of members for Activ::Database::FieldList::ConstIterator, including all inherited members.

ConstIterator() | Activ::Database::FieldList::ConstIterator | [inline]
ConstIterator(const ConstIterator &rhs) | Activ::Database::FieldList::ConstIterator | [inline]
FieldList class | Activ::Database::FieldList::ConstIterator | [friend]
GetId() const | Activ::Database::FieldList::ConstIterator |
GetName() const | Activ::Database::FieldList::ConstIterator |
GetSpecification() const | Activ::Database::FieldList::ConstIterator |
GetType() const | Activ::Database::FieldList::ConstIterator |
IsInitialized() const | Activ::Database::FieldList::ConstIterator | [inline]
operator!=(const ConstIterator &rhs) const | Activ::Database::FieldList::ConstIterator | [inline]
operator++() | Activ::Database::FieldList::ConstIterator |
operator++(int) | Activ::Database::FieldList::ConstIterator | [inline]
operator==(const ConstIterator &rhs) const | Activ::Database::FieldList::ConstIterator | [inline]

Generated on Wed Oct 8 14:02:10 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Database::FieldListObject Member List

This is the complete list of members for Activ::Database::FieldListObject, including all inherited members.

AllocateBuffer(const size_t requiredBufferSize) | Activ::Database::FieldListObject | [inline, protected]
Begin() const | Activ::Database::FieldListObject | [inline]
CompareField(const FieldSpecification::Id fieldId, const IFieldType &iFieldType, int &result) const | Activ::Database::FieldListObject | [inline]
CompareField(const FieldSpecification::Id fieldId, const std::string &value, int &result) const | Activ::Database::FieldListObject | [inline]
CompareField(const FieldSpecification::Id fieldId, const FieldListObject &rhsFieldListObject, int &result) const | Activ::Database::FieldListObject | [inline]
CompareField(const FieldSpecification::Id lhsFieldId, const FieldListObject &rhsFieldListObject, const FieldSpecification::Id rhsFieldId, int &result) const | Activ::Database::FieldListObject | [inline]
ConstIterator typedef | Activ::Database::FieldListObject |
CopyField(const FieldSpecification::Id fieldId, const FieldListObject &sourceFieldListObject) | Activ::Database::FieldListObject | [inline]
CopyField(const FieldSpecification::Id fieldId, const FieldListObject &sourceFieldListObject, bool &isDifferent) | Activ::Database::FieldListObject | [inline]
CopyField(const FieldSpecification::Id targetFieldId, const FieldListObject &sourceFieldListObject, const FieldSpecification::Id sourceFieldId) | Activ::Database::FieldListObject | [inline]
CopyField(const FieldSpecification::Id targetFieldId, const FieldListObject &sourceFieldListObject, const FieldSpecification::Id sourceFieldId, bool &isDifferent) | Activ::Database::FieldListObject | [inline]
CopyFields(const FieldListObject &sourceFieldListObject, const bool copyAllFields=false) | Activ::Database::FieldListObject | [inline, virtual]
DEFAULT_BUFFER_SIZE (defined in Activ::Database::FieldListObject) | Activ::Database::FieldListObject | [protected, static]
DefineField(const FieldSpecification::Id fieldId, const size_t fieldLength=~0) | Activ::Database::FieldListObject | [inline]
Deserialize(ITable *pTable, MessageValidator &messageValidator)=0 | Activ::Database::FieldListObject | [pure virtual]
End() const | Activ::Database::FieldListObject | [inline]
FieldList::ConstIterator (defined in Activ::Database::FieldListObject) | Activ::Database::FieldListObject | [friend]
FieldListObject() | Activ::Database::FieldListObject | [inline]
Get() | Activ::Database::FieldListObject | [inline]
Get() const | Activ::Database::FieldListObject | [inline]
GetField(const FieldSpecification::Id fieldId, void *pField, const size_t fieldSize, size_t &fieldLength) const | Activ::Database::FieldListObject | [inline]
GetField(const FieldSpecification::Id fieldId, const void *&pField, size_t &fieldLength) const | Activ::Database::FieldListObject | [inline]
GetField(const FieldSpecification::Id fieldId, void *&pField, size_t &fieldLength) | Activ::Database::FieldListObject | [inline]
GetField(const FieldSpecification::Id fieldId, T &value) const | Activ::Database::FieldListObject | [inline]
GetField(const ConstIterator &iterator, const void *&pField, size_t &fieldLength) const | Activ::Database::FieldListObject | [inline]
GetField(const ConstIterator &iterator, FieldSpecification::Id &fieldId, FieldSpecification::Type &type, const void *&pField, size_t &fieldLength) const | Activ::Database::FieldListObject | [inline]
GetFieldIdList(FieldIdList &fieldIdList) const | Activ::Database::FieldListObject | [inline]
GetFieldList() const | Activ::Database::FieldListObject | [inline, protected]
GetFieldSpecification(const FieldSpecification::Id fieldId, FieldSpecification &fieldSpecification) const | Activ::Database::FieldListObject | [inline]
GetFieldSpecificationList(FieldSpecificationList &fieldSpecificationList) const | Activ::Database::FieldListObject | [inline]
GetFirstFieldId(FieldSpecification::Id &fieldId) const | Activ::Database::FieldListObject | [inline]
GetId() const | Activ::Database::FieldListObject | [inline]
GetMatchingFieldsById(FieldIdList &fieldIdList, const FieldListObject &rhsFieldListObject) | Activ::Database::FieldListObject |
GetMatchingFieldsByName(FieldIdList &lhsFieldIdList, const FieldListObject &rhsFieldListObject, FieldIdList &rhsFieldIdList) | Activ::Database::FieldListObject |
GetNextFieldId(FieldSpecification::Id &fieldId) const | Activ::Database::FieldListObject | [inline]
GetTablePointer(ITable *&pTable) const | Activ::Database::FieldListObject | [inline]
GetType(const FieldSpecification::Id fieldId, FieldSpecification::Type &type) const | Activ::Database::FieldListObject | [inline]
Initialize() | Activ::Database::FieldListObject | [inline]
Initialize(ITable *pTable, const FieldList *pFieldList, const size_t requiredBufferSize) | Activ::Database::FieldListObject | [inline]
IsFieldDefined(const FieldSpecification::Id fieldId, bool &result) const | Activ::Database::FieldListObject | [inline]
IsFieldDifferent(const FieldSpecification::Id fieldId, const void *pField, const size_t fieldLength, bool &result) const | Activ::Database::FieldListObject | [inline]
IsFieldDifferent(const FieldSpecification::Id fieldId, const IFieldType &iFieldType, bool &result) const | Activ::Database::FieldListObject | [inline]
IsFieldDifferent(const FieldSpecification::Id fieldId, const std::string &value, bool &result) const | Activ::Database::FieldListObject | [inline]
IsFieldDifferent(const FieldSpecification::Id fieldId, const FieldListObject &rhsFieldListObject, bool &result) const | Activ::Database::FieldListObject | [inline]
IsFieldDifferent(const FieldSpecification::Id lhsFieldId, const FieldListObject &rhsFieldListObject, const FieldSpecification::Id rhsFieldId, bool &result) const | Activ::Database::FieldListObject | [inline]
IsFound(const FieldSpecification::Id fieldId) const | Activ::Database::FieldListObject | [inline]
IsInitialized() const | Activ::Database::FieldListObject | [inline]
m_bufferSize | Activ::Database::FieldListObject | [protected]
m_defaultBuffer | Activ::Database::FieldListObject | [protected]
m_id | Activ::Database::FieldListObject | [mutable, protected]
m_isInitialized | Activ::Database::FieldListObject | [protected]
m_pData | Activ::Database::FieldListObject | [protected]
m_pFieldList | Activ::Database::FieldListObject | [protected]
m_pTable | Activ::Database::FieldListObject | [protected]
m_tableIdentity | Activ::Database::FieldListObject | [protected]
Reset()=0 | Activ::Database::FieldListObject | [pure virtual]
Serialize(MessageBuilder &messageBuilder) const =0 | Activ::Database::FieldListObject | [pure virtual]
SetField(const FieldSpecification::Id fieldId, const void *pField, const size_t fieldLength) | Activ::Database::FieldListObject | [inline]
SetField(const FieldSpecification::Id fieldId, const void *pField, const size_t fieldLength, bool &isDifferent) | Activ::Database::FieldListObject | [inline]
SetField(const FieldSpecification::Id fieldId, const T &value) | Activ::Database::FieldListObject | [inline]
SetField(const FieldSpecification::Id fieldId, const T &value, bool &isDifferent) | Activ::Database::FieldListObject | [inline]
SetId(const DataId id) const | Activ::Database::FieldListObject | [inline]
ToLogString() const | Activ::Database::FieldListObject | [inline]
ToString() const | Activ::Database::FieldListObject | [inline]
UndefineField(const FieldSpecification::Id fieldId) | Activ::Database::FieldListObject | [inline]
UndefineField(const FieldSpecification::Id fieldId, bool &isDifferent) | Activ::Database::FieldListObject | [inline]
~FieldListObject()=0 | Activ::Database::FieldListObject | [inline, pure virtual]

Generated on Wed Oct 8 14:02:11 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Database::FieldSpecification Member List

This is the complete list of members for Activ::Database::FieldSpecification, including all inherited members.

Deserialize(MessageValidator &messageValidator) | Activ::Database::FieldSpecification |
FieldSpecification() | Activ::Database::FieldSpecification |
FieldSpecification(const Id id, const std::string &name, const Type type, const size_t maxLength, const size_t offset=0, const Properties properties=PROPERTY_NONE) | Activ::Database::FieldSpecification |
GetActivFieldType(const FieldSpecification::Type databaseFieldType, FieldType &activFieldType) | Activ::Database::FieldSpecification | [static]
GetDatabaseFieldType(const FieldType activFieldType, FieldSpecification::Type &databaseFieldType) | Activ::Database::FieldSpecification | [static]
Id typedef | Activ::Database::FieldSpecification |
IsMatch(const FieldSpecification &rhs) const | Activ::Database::FieldSpecification |
m_id | Activ::Database::FieldSpecification |
m_maxLength | Activ::Database::FieldSpecification |
m_name | Activ::Database::FieldSpecification |
m_offset | Activ::Database::FieldSpecification |
m_properties | Activ::Database::FieldSpecification |
m_type | Activ::Database::FieldSpecification |
NUMBER_OF_TYPES enum value (defined in Activ::Database::FieldSpecification) | Activ::Database::FieldSpecification |
operator!=(const FieldSpecification &rhs) const | Activ::Database::FieldSpecification |
operator<(const FieldSpecification &rhs) const | Activ::Database::FieldSpecification |
operator==(const FieldSpecification &rhs) const | Activ::Database::FieldSpecification |
Properties typedef | Activ::Database::FieldSpecification |
PROPERTY_NONE enum value (defined in Activ::Database::FieldSpecification) | Activ::Database::FieldSpecification |
Serialize(MessageBuilder &messageBuilder) const | Activ::Database::FieldSpecification |
ToFormattedHeaderString() | Activ::Database::FieldSpecification | [static]
ToFormattedString() const | Activ::Database::FieldSpecification |
ToString() const | Activ::Database::FieldSpecification |
Type enum name | Activ::Database::FieldSpecification |
TYPE_BINARY_ARRAY enum value (defined in Activ::Database::FieldSpecification) | Activ::Database::FieldSpecification |
TYPE_BINARY_STRING enum value (defined in Activ::Database::FieldSpecification) | Activ::Database::FieldSpecification |
TYPE_BITMAP enum value (defined in Activ::Database::FieldSpecification) | Activ::Database::FieldSpecification |
TYPE_BLOB enum value (defined in Activ::Database::FieldSpecification) | Activ::Database::FieldSpecification |
TYPE_BOOLEAN enum value (defined in Activ::Database::FieldSpecification) | Activ::Database::FieldSpecification |
TYPE_CRC_BLOB enum value (defined in Activ::Database::FieldSpecification) | Activ::Database::FieldSpecification |
TYPE_DATE enum value (defined in Activ::Database::FieldSpecification) | Activ::Database::FieldSpecification |
TYPE_DATE_TIME enum value (defined in Activ::Database::FieldSpecification) | Activ::Database::FieldSpecification |
TYPE_NONE enum value (defined in Activ::Database::FieldSpecification) | Activ::Database::FieldSpecification |
TYPE_POINTER enum value (defined in Activ::Database::FieldSpecification) | Activ::Database::FieldSpecification |
TYPE_RATIONAL enum value (defined in Activ::Database::FieldSpecification) | Activ::Database::FieldSpecification |
TYPE_SIGNED_INTEGRAL enum value (defined in Activ::Database::FieldSpecification) | Activ::Database::FieldSpecification |
TYPE_TEXT_ARRAY enum value (defined in Activ::Database::FieldSpecification) | Activ::Database::FieldSpecification |
TYPE_TEXT_STRING enum value (defined in Activ::Database::FieldSpecification) | Activ::Database::FieldSpecification |
TYPE_TIME enum value (defined in Activ::Database::FieldSpecification) | Activ::Database::FieldSpecification |
TYPE_TRATIONAL enum value (defined in Activ::Database::FieldSpecification) | Activ::Database::FieldSpecification |
TYPE_UNSIGNED_INTEGRAL enum value (defined in Activ::Database::FieldSpecification) | Activ::Database::FieldSpecification |
UNDEFINED_FIELD_ID | Activ::Database::FieldSpecification | [static]
Validate() const | Activ::Database::FieldSpecification |

Generated on Wed Oct 8 14:02:11 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Database::IIndex Member List

This is the complete list of members for Activ::Database::IIndex, including all inherited members.

BuildKey(Key &key, const byte_t *pRecordData, const DataId recordId) const =0 | Activ::Database::IIndex | [pure virtual]
BuildKey(Key &targetKey, const Key &sourceKey) const =0 | Activ::Database::IIndex | [pure virtual]
CheckIntegrity() const =0 | Activ::Database::IIndex | [pure virtual]
Compare(const Key &lhs, const Key &rhs) const =0 | Activ::Database::IIndex | [pure virtual]
GetCurrentRecords() const =0 | Activ::Database::IIndex | [pure virtual]
GetFieldIdList() const =0 | Activ::Database::IIndex | [pure virtual]
GetFieldList() const =0 | Activ::Database::IIndex | [pure virtual]
GetFieldSpecificationList() const =0 | Activ::Database::IIndex | [pure virtual]
GetKeyLength() const =0 | Activ::Database::IIndex | [pure virtual]
GetName() const =0 | Activ::Database::IIndex | [pure virtual]
GetNumber() const =0 | Activ::Database::IIndex | [pure virtual]
GetSpecification() const =0 | Activ::Database::IIndex | [pure virtual]
IsDuplicate() const =0 | Activ::Database::IIndex | [pure virtual]
IsPrimaryUnique() const =0 | Activ::Database::IIndex | [pure virtual]
IsTree() const =0 | Activ::Database::IIndex | [pure virtual]
IsUnique() const =0 | Activ::Database::IIndex | [pure virtual]
ResetKey(Key &key) const =0 | Activ::Database::IIndex | [pure virtual]
SetFields(Record &record, const ScatterBufferHelper &scatterBufferHelper) const =0 | Activ::Database::IIndex | [pure virtual]
SetFields(Key &key, const ScatterBufferHelper &scatterBufferHelper) const =0 | Activ::Database::IIndex | [pure virtual]
~IIndex()=0 | Activ::Database::IIndex | [inline, pure virtual]

Generated on Wed Oct 8 14:02:11 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Database::ITable Member List

This is the complete list of members for Activ::Database::ITable, including all inherited members.

Add(Record &record)=0 | Activ::Database::ITable | [pure virtual]
Add(Record &record, const FieldIdList &modifiedFieldIdList)=0 | Activ::Database::ITable | [pure virtual]
Add(Record &record, Record &originalRecord)=0 | Activ::Database::ITable | [pure virtual]
CheckIntegrity() const =0 | Activ::Database::ITable | [pure virtual]
Clear()=0 | Activ::Database::ITable | [pure virtual]
Clone(const std::string &directory=std::string(), const bool createMutex=false, const bool copyRecords=true, size_t recordsPerRequest=20) const =0 | Activ::Database::ITable | [pure virtual]
CloseRecordFile()=0 | Activ::Database::ITable | [pure virtual]
Convert()=0 | Activ::Database::ITable | [pure virtual]
Copy(const ITable *pSourceTable, const bool clearTargetTable=true, size_t recordsPerRequest=20)=0 | Activ::Database::ITable | [pure virtual]
CopyFiles(const std::string &sourceDirectory, const std::string &targetDirectory) const =0 | Activ::Database::ITable | [pure virtual]
CreateIndexes(IndexSpecification indexSpecificationList[], const size_t nIndexSpecifications) | Activ::Database::ITable | [inline]
CreateIndexes(IndexSpecificationList &indexSpecificationList)=0 | Activ::Database::ITable | [pure virtual]
CreateRecordFile()=0 | Activ::Database::ITable | [pure virtual]
CreateTemporaryIndex(IndexSpecification &indexSpecification)=0 | Activ::Database::ITable | [pure virtual]
Delete(const Key &key)=0 | Activ::Database::ITable | [pure virtual]
Delete(const Key &key, Record &record)=0 | Activ::Database::ITable | [pure virtual]
Deserialize(MessageValidator &messageValidator, KeyList &keyList) const =0 | Activ::Database::ITable | [pure virtual]
Deserialize(MessageValidator &messageValidator, RecordList &recordList) const =0 | Activ::Database::ITable | [pure virtual]
Deserialize(MessageValidator &messageValidator, DataId &recordId, size_t &maxResponseRecords) const =0 | Activ::Database::ITable | [pure virtual]
Deserialize(MessageValidator &messageValidator, std::vector< StatusCode > &statusCodeList, RecordList &recordList) const =0 | Activ::Database::ITable | [pure virtual]
GetBasicFileName() const =0 | Activ::Database::ITable | [pure virtual]
GetCurrentRecords(size_t &nRecords) const =0 | Activ::Database::ITable | [pure virtual]
GetDirectory() const =0 | Activ::Database::ITable | [pure virtual]
GetEqual(const Key &key, Record &record) const =0 | Activ::Database::ITable | [pure virtual]
GetEqual(const KeyList &keyList, std::vector< StatusCode > &statusCodeList, RecordList &recordList) const =0 | Activ::Database::ITable | [pure virtual]
GetFieldIdList() const =0 | Activ::Database::ITable | [pure virtual]
GetFieldList() const =0 | Activ::Database::ITable | [pure virtual]
GetFieldSpecification(const FieldSpecification::Id fieldId, FieldSpecification &fieldSpecification) const =0 | Activ::Database::ITable | [pure virtual]
GetFieldSpecificationList() const =0 | Activ::Database::ITable | [pure virtual]
GetFieldSpecificationList(const FieldSpecification &fieldSpecification, FieldSpecificationList &matchingFieldSpecificationList) const =0 | Activ::Database::ITable | [pure virtual]
GetFirst(Key &key, Record &record) const =0 | Activ::Database::ITable | [pure virtual]
GetFirst(Key &key, RecordList &recordList, const size_t maxResponseRecords=0) const =0 | Activ::Database::ITable | [pure virtual]
GetFirstFieldId(FieldSpecification::Id &fieldId) const =0 | Activ::Database::ITable | [pure virtual]
GetFirstFieldSpecification(FieldSpecification &fieldSpecification) const =0 | Activ::Database::ITable | [pure virtual]
GetFirstPartial(Key &key, Record &record, const FieldSpecification::Id lastKeyFieldId, const size_t lastKeyCompareLength=FIELD_COMPARE_LENGTH_WHOLE) const =0 | Activ::Database::ITable | [pure virtual]
GetFirstPartial(Key &key, RecordList &recordList, const FieldSpecification::Id lastKeyFieldId, const size_t lastKeyCompareLength=FIELD_COMPARE_LENGTH_WHOLE, const size_t maxResponseRecords=0) const =0 | Activ::Database::ITable | [pure virtual]
GetIdentity() const | Activ::Database::ITable | [inline]
GetIndexPointer(const IndexSpecification::Number indexNo, IIndex *&pIndex) const =0 | Activ::Database::ITable | [pure virtual]
GetIndexSpecification(const IndexSpecification::Number indexNo, IndexSpecification &indexSpecification) const =0 | Activ::Database::ITable | [pure virtual]
GetIndexSpecificationList() const =0 | Activ::Database::ITable | [pure virtual]
GetIndexSpecificationList(const IndexSpecification &indexSpecification, IndexSpecificationList &matchingIndexSpecificationList) const =0 | Activ::Database::ITable | [pure virtual]
GetLast(Key &key, Record &record) const =0 | Activ::Database::ITable | [pure virtual]
GetLast(Key &key, RecordList &recordList, const size_t maxResponseRecords=0) const =0 | Activ::Database::ITable | [pure virtual]
GetLastPartial(Key &key, Record &record, const FieldSpecification::Id lastKeyFieldId, const size_t lastKeyCompareLength=FIELD_COMPARE_LENGTH_WHOLE) const =0 | Activ::Database::ITable | [pure virtual]
GetLastPartial(Key &key, RecordList &recordList, const FieldSpecification::Id lastKeyFieldId, const size_t lastKeyCompareLength=FIELD_COMPARE_LENGTH_WHOLE, const size_t maxResponseRecords=0) const =0 | Activ::Database::ITable | [pure virtual]
GetMaxRecords(size_t &maxRecords) const =0 | Activ::Database::ITable | [pure virtual]
GetMode() const | Activ::Database::ITable | [inline]
GetName() const =0 | Activ::Database::ITable | [pure virtual]
GetNext(Key &key, Record &record) const =0 | Activ::Database::ITable | [pure virtual]
GetNext(Key &key, RecordList &recordList, const size_t maxResponseRecords=0) const =0 | Activ::Database::ITable | [pure virtual]
GetNextFieldId(FieldSpecification::Id &fieldId) const =0 | Activ::Database::ITable | [pure virtual]
GetNextFieldSpecification(FieldSpecification &fieldSpecification) const =0 | Activ::Database::ITable | [pure virtual]
GetNextPartial(Key &key, Record &record, const FieldSpecification::Id lastKeyFieldId, const size_t lastKeyCompareLength=FIELD_COMPARE_LENGTH_WHOLE) const =0 | Activ::Database::ITable | [pure virtual]
GetNextPartial(Key &key, RecordList &recordList, const FieldSpecification::Id lastKeyFieldId, const size_t lastKeyCompareLength=FIELD_COMPARE_LENGTH_WHOLE, const size_t maxResponseRecords=0) const =0 | Activ::Database::ITable | [pure virtual]
GetNumberOfIndexes() const =0 | Activ::Database::ITable | [pure virtual]
GetPrevious(Key &key, Record &record) const =0 | Activ::Database::ITable | [pure virtual]
GetPrevious(Key &key, RecordList &recordList, const size_t maxResponseRecords=0) const =0 | Activ::Database::ITable | [pure virtual]
GetPreviousPartial(Key &key, Record &record, const FieldSpecification::Id lastKeyFieldId, const size_t lastKeyCompareLength=FIELD_COMPARE_LENGTH_WHOLE) const =0 | Activ::Database::ITable | [pure virtual]
GetPreviousPartial(Key &key, RecordList &recordList, const FieldSpecification::Id lastKeyFieldId, const size_t lastKeyCompareLength=FIELD_COMPARE_LENGTH_WHOLE, const size_t maxResponseRecords=0) const =0 | Activ::Database::ITable | [pure virtual]
GetPrimaryIndexNumber() const =0 | Activ::Database::ITable | [pure virtual]
GetRecordLength() const =0 | Activ::Database::ITable | [pure virtual]
GetTableSpecification() const =0 | Activ::Database::ITable | [pure virtual]
GetType(const FieldSpecification::Id fieldId, FieldSpecification::Type &type) const =0 | Activ::Database::ITable | [pure virtual]
Identity typedef | Activ::Database::ITable |
IsAdd(const Record &record, const Record &originalRecord) const =0 | Activ::Database::ITable | [pure virtual]
IsFound(const FieldSpecification::Id fieldId) const =0 | Activ::Database::ITable | [pure virtual]
IsManaged() const =0 | Activ::Database::ITable | [pure virtual]
IsRecordFileOpen() const =0 | Activ::Database::ITable | [pure virtual]
IsTemporary() const =0 | Activ::Database::ITable | [pure virtual]
IsUpdate(const Record &record, const Record &originalRecord) const =0 | Activ::Database::ITable | [pure virtual]
ITable() | Activ::Database::ITable | [inline]
m_identity | Activ::Database::ITable | [protected]
m_mode | Activ::Database::ITable | [protected]
OpenRecordFile()=0 | Activ::Database::ITable | [pure virtual]
ResetRecord(Record &record) const =0 | Activ::Database::ITable | [pure virtual]
Save(const std::string &directory)=0 | Activ::Database::ITable | [pure virtual]
Serialize(MessageBuilder &messageBuilder, const KeyList &keyList) const =0 | Activ::Database::ITable | [pure virtual]
Serialize(MessageBuilder &messageBuilder, const RecordList &recordList) const =0 | Activ::Database::ITable | [pure virtual]
Serialize(MessageBuilder &messageBuilder, const std::vector< StatusCode > &statusCodeList, const RecordList &recordList) const =0 | Activ::Database::ITable | [pure virtual]
SerializeSpecification(MessageBuilder &messageBuilder) const =0 | Activ::Database::ITable | [pure virtual]
SetIdentity(const Identity identity=0) | Activ::Database::ITable | [inline]
SetIndexFields(Record &record, const IndexSpecification::Number indexNo, const ScatterBufferHelper &scatterBufferHelper) const =0 | Activ::Database::ITable | [pure virtual]
SetMode(const Mode mode) | Activ::Database::ITable | [inline]
StepFirst(DataId &recordId, Record &record) const =0 | Activ::Database::ITable | [pure virtual]
StepFirst(DataId &recordId, RecordList &recordList, const size_t maxResponseRecords=0) const =0 | Activ::Database::ITable | [pure virtual]
StepNext(DataId &recordId, Record &record) const =0 | Activ::Database::ITable | [pure virtual]
StepNext(DataId &recordId, RecordList &recordList, const size_t maxResponseRecords=0) const =0 | Activ::Database::ITable | [pure virtual]
~ITable()=0 | Activ::Database::ITable | [inline, pure virtual]

Generated on Wed Oct 8 14:02:11 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Database::IndexSpecification Member List

This is the complete list of members for Activ::Database::IndexSpecification, including all inherited members.

Deserialize(MessageValidator &messageValidator) | Activ::Database::IndexSpecification |
Index (defined in Activ::Database::IndexSpecification) | Activ::Database::IndexSpecification | [friend]
IndexSpecification() | Activ::Database::IndexSpecification |
IndexSpecification(const std::string &name, const Type type, const Properties properties, const std::vector< IndexSpecification::Field > &indexFieldSpecificationList) | Activ::Database::IndexSpecification |
IndexSpecification(const std::string &name, const Type type, const Properties properties, const std::vector< IndexSpecification::Field > &indexFieldSpecificationList, const std::vector< uint16_t > &cachedFieldIdList) | Activ::Database::IndexSpecification |
IsDuplicate() const | Activ::Database::IndexSpecification |
IsHash() const | Activ::Database::IndexSpecification |
IsMatch(const IndexSpecification &rhs) const | Activ::Database::IndexSpecification |
IsPrimaryUnique() const | Activ::Database::IndexSpecification |
IsTree() const | Activ::Database::IndexSpecification |
IsUnique() const | Activ::Database::IndexSpecification |
m_cachedFieldIdList | Activ::Database::IndexSpecification |
m_indexFieldSpecificationList | Activ::Database::IndexSpecification |
m_name | Activ::Database::IndexSpecification |
m_number | Activ::Database::IndexSpecification |
m_properties | Activ::Database::IndexSpecification |
m_type | Activ::Database::IndexSpecification |
Number typedef | Activ::Database::IndexSpecification |
operator!=(const IndexSpecification &rhs) const | Activ::Database::IndexSpecification |
operator<(const IndexSpecification &rhs) const | Activ::Database::IndexSpecification |
operator==(const IndexSpecification &rhs) const | Activ::Database::IndexSpecification |
Properties typedef | Activ::Database::IndexSpecification |
PROPERTY_DUPLICATE enum value (defined in Activ::Database::IndexSpecification) | Activ::Database::IndexSpecification |
PROPERTY_NONE enum value (defined in Activ::Database::IndexSpecification) | Activ::Database::IndexSpecification |
PROPERTY_PRIMARY_UNIQUE enum value (defined in Activ::Database::IndexSpecification) | Activ::Database::IndexSpecification |
PROPERTY_UNIQUE enum value (defined in Activ::Database::IndexSpecification) | Activ::Database::IndexSpecification |
Serialize(MessageBuilder &messageBuilder) const | Activ::Database::IndexSpecification |
ToString() const | Activ::Database::IndexSpecification |
Type enum name | Activ::Database::IndexSpecification |
TYPE_HASH enum value (defined in Activ::Database::IndexSpecification) | Activ::Database::IndexSpecification |
TYPE_NONE enum value (defined in Activ::Database::IndexSpecification) | Activ::Database::IndexSpecification |
TYPE_RED_BLACK_TREE enum value (defined in Activ::Database::IndexSpecification) | Activ::Database::IndexSpecification |
UNDEFINED_INDEX_NUMBER | Activ::Database::IndexSpecification | [static]
Validate() const | Activ::Database::IndexSpecification |

Generated on Wed Oct 8 14:02:11 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Database::IndexSpecification::Field Member List

This is the complete list of members for Activ::Database::IndexSpecification::Field, including all inherited members.

Deserialize(MessageValidator &messageValidator) | Activ::Database::IndexSpecification::Field |
Field() | Activ::Database::IndexSpecification::Field |
Field(const FieldSpecification::Id fieldId, const Properties properties=PROPERTY_NONE) | Activ::Database::IndexSpecification::Field | [explicit]
IsAscending(const Properties properties) | Activ::Database::IndexSpecification::Field | [static]
IsDescending(const Properties properties) | Activ::Database::IndexSpecification::Field | [static]
m_fieldId | Activ::Database::IndexSpecification::Field |
m_properties | Activ::Database::IndexSpecification::Field |
operator!=(const Field &rhs) const | Activ::Database::IndexSpecification::Field |
operator==(const Field &rhs) const | Activ::Database::IndexSpecification::Field |
Properties typedef | Activ::Database::IndexSpecification::Field |
PROPERTY_ASCENDING enum value (defined in Activ::Database::IndexSpecification::Field) | Activ::Database::IndexSpecification::Field |
PROPERTY_DESCENDING enum value (defined in Activ::Database::IndexSpecification::Field) | Activ::Database::IndexSpecification::Field |
PROPERTY_NONE enum value (defined in Activ::Database::IndexSpecification::Field) | Activ::Database::IndexSpecification::Field |
Serialize(MessageBuilder &messageBuilder) const | Activ::Database::IndexSpecification::Field |

Generated on Wed Oct 8 14:02:11 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Database::Key Member List

This is the complete list of members for Activ::Database::Key, including all inherited members.

AllocateBuffer(const size_t requiredBufferSize) | Activ::Database::FieldListObject | [inline, protected]
Begin() const | Activ::Database::FieldListObject | [inline]
BuildKey(const Record &record) | Activ::Database::Key |
CompareField(const FieldSpecification::Id fieldId, const IFieldType &iFieldType, int &result) const | Activ::Database::FieldListObject | [inline]
CompareField(const FieldSpecification::Id fieldId, const std::string &value, int &result) const | Activ::Database::FieldListObject | [inline]
CompareField(const FieldSpecification::Id fieldId, const FieldListObject &rhsFieldListObject, int &result) const | Activ::Database::FieldListObject | [inline]
CompareField(const FieldSpecification::Id lhsFieldId, const FieldListObject &rhsFieldListObject, const FieldSpecification::Id rhsFieldId, int &result) const | Activ::Database::FieldListObject | [inline]
ConstIterator typedef | Activ::Database::FieldListObject |
CopyField(const FieldSpecification::Id fieldId, const FieldListObject &sourceFieldListObject) | Activ::Database::FieldListObject | [inline]
CopyField(const FieldSpecification::Id fieldId, const FieldListObject &sourceFieldListObject, bool &isDifferent) | Activ::Database::FieldListObject | [inline]
CopyField(const FieldSpecification::Id targetFieldId, const FieldListObject &sourceFieldListObject, const FieldSpecification::Id sourceFieldId) | Activ::Database::FieldListObject | [inline]
CopyField(const FieldSpecification::Id targetFieldId, const FieldListObject &sourceFieldListObject, const FieldSpecification::Id sourceFieldId, bool &isDifferent) | Activ::Database::FieldListObject | [inline]
CopyFields(const Key &sourceKey, const bool copyAllFields=false) | Activ::Database::Key | [virtual]
CopyFields(const Record &sourceRecord, const bool copyAllFields=false) | Activ::Database::Key | [virtual]
Activ::Database::FieldListObject::CopyFields(const FieldListObject &sourceFieldListObject, const bool copyAllFields=false) | Activ::Database::FieldListObject | [inline, virtual]
DEFAULT_BUFFER_SIZE (defined in Activ::Database::FieldListObject) | Activ::Database::FieldListObject | [protected, static]
DefineField(const FieldSpecification::Id fieldId, const size_t fieldLength=~0) | Activ::Database::FieldListObject | [inline]
Deserialize(ITable *pTable, MessageValidator &messageValidator) | Activ::Database::Key | [virtual]
End() const | Activ::Database::FieldListObject | [inline]
FieldList::ConstIterator (defined in Activ::Database::FieldListObject) | Activ::Database::FieldListObject | [friend]
FieldListObject() | Activ::Database::FieldListObject | [inline]
Get() | Activ::Database::FieldListObject | [inline]
Get() const | Activ::Database::FieldListObject | [inline]
GetDataLength() const | Activ::Database::Key | [inline]
GetField(const FieldSpecification::Id fieldId, void *pField, const size_t fieldSize, size_t &fieldLength) const | Activ::Database::FieldListObject | [inline]
GetField(const FieldSpecification::Id fieldId, const void *&pField, size_t &fieldLength) const | Activ::Database::FieldListObject | [inline]
GetField(const FieldSpecification::Id fieldId, void *&pField, size_t &fieldLength) | Activ::Database::FieldListObject | [inline]
GetField(const FieldSpecification::Id fieldId, T &value) const | Activ::Database::FieldListObject | [inline]
GetField(const ConstIterator &iterator, const void *&pField, size_t &fieldLength) const | Activ::Database::FieldListObject | [inline]
GetField(const ConstIterator &iterator, FieldSpecification::Id &fieldId, FieldSpecification::Type &type, const void *&pField, size_t &fieldLength) const | Activ::Database::FieldListObject | [inline]
GetFieldIdList(FieldIdList &fieldIdList) const | Activ::Database::FieldListObject | [inline]
GetFieldList() const | Activ::Database::FieldListObject | [inline, protected]
GetFieldSpecification(const FieldSpecification::Id fieldId, FieldSpecification &fieldSpecification) const | Activ::Database::FieldListObject | [inline]
GetFieldSpecificationList(FieldSpecificationList &fieldSpecificationList) const | Activ::Database::FieldListObject | [inline]
GetFirstFieldId(FieldSpecification::Id &fieldId) const | Activ::Database::FieldListObject | [inline]
GetId() const | Activ::Database::FieldListObject | [inline]
GetIndexNumber(IndexSpecification::Number &indexNo) const | Activ::Database::Key | [inline]
GetIndexPointer(IIndex *&pIndex) const | Activ::Database::Key | [inline]
GetIndexSpecification(IndexSpecification &indexSpecification) const | Activ::Database::Key | [inline]
GetMatchingFieldsById(FieldIdList &fieldIdList, const FieldListObject &rhsFieldListObject) | Activ::Database::FieldListObject |
GetMatchingFieldsByName(FieldIdList &lhsFieldIdList, const FieldListObject &rhsFieldListObject, FieldIdList &rhsFieldIdList) | Activ::Database::FieldListObject |
GetNextFieldId(FieldSpecification::Id &fieldId) const | Activ::Database::FieldListObject | [inline]
GetTablePointer(ITable *&pTable) const | Activ::Database::FieldListObject | [inline]
GetType(const FieldSpecification::Id fieldId, FieldSpecification::Type &type) const | Activ::Database::FieldListObject | [inline]
Initialize() | Activ::Database::Key | [inline]
Initialize(ITable *pTable, const IndexSpecification::Number indexNo) | Activ::Database::Key |
Initialize(const Key &rhs) | Activ::Database::Key |
Initialize(const IndexSpecification::Number indexNo, const Record &record) | Activ::Database::Key |
Activ::Database::FieldListObject::Initialize(ITable *pTable, const FieldList *pFieldList, const size_t requiredBufferSize) | Activ::Database::FieldListObject | [inline]
IsFieldDefined(const FieldSpecification::Id fieldId, bool &result) const | Activ::Database::FieldListObject | [inline]
IsFieldDifferent(const FieldSpecification::Id fieldId, const void *pField, const size_t fieldLength, bool &result) const | Activ::Database::FieldListObject | [inline]
IsFieldDifferent(const FieldSpecification::Id fieldId, const IFieldType &iFieldType, bool &result) const | Activ::Database::FieldListObject | [inline]
IsFieldDifferent(const FieldSpecification::Id fieldId, const std::string &value, bool &result) const | Activ::Database::FieldListObject | [inline]
IsFieldDifferent(const FieldSpecification::Id fieldId, const FieldListObject &rhsFieldListObject, bool &result) const | Activ::Database::FieldListObject | [inline]
IsFieldDifferent(const FieldSpecification::Id lhsFieldId, const FieldListObject &rhsFieldListObject, const FieldSpecification::Id rhsFieldId, bool &result) const | Activ::Database::FieldListObject | [inline]
IsFound(const FieldSpecification::Id fieldId) const | Activ::Database::FieldListObject | [inline]
IsInitialized() const | Activ::Database::FieldListObject | [inline]
Key() | Activ::Database::Key | [inline]
Key(ITable *pTable, const IndexSpecification::Number indexNo) | Activ::Database::Key |
Key(const IndexSpecification::Number indexNo, const Record &record) | Activ::Database::Key |
Key(const Key &rhs) | Activ::Database::Key |
m_bufferSize | Activ::Database::FieldListObject | [protected]
m_defaultBuffer | Activ::Database::FieldListObject | [protected]
m_id | Activ::Database::FieldListObject | [mutable, protected]
m_isInitialized | Activ::Database::FieldListObject | [protected]
m_pData | Activ::Database::FieldListObject | [protected]
m_pFieldList | Activ::Database::FieldListObject | [protected]
m_pTable | Activ::Database::FieldListObject | [protected]
m_tableIdentity | Activ::Database::FieldListObject | [protected]
operator!=(const Key &rhs) const | Activ::Database::Key | [inline]
operator<(const Key &rhs) const | Activ::Database::Key | [inline]
operator<=(const Key &rhs) const | Activ::Database::Key | [inline]
operator=(const Key &rhs) | Activ::Database::Key |
operator==(const Key &rhs) const | Activ::Database::Key | [inline]
operator>(const Key &rhs) const | Activ::Database::Key | [inline]
operator>=(const Key &rhs) const | Activ::Database::Key | [inline]
Reset() | Activ::Database::Key | [inline, virtual]
Serialize(MessageBuilder &messageBuilder) const | Activ::Database::Key | [virtual]
Set(const void *pRhsData) | Activ::Database::Key | [inline]
SetField(const FieldSpecification::Id fieldId, const void *pField, const size_t fieldLength) | Activ::Database::FieldListObject | [inline]
SetField(const FieldSpecification::Id fieldId, const void *pField, const size_t fieldLength, bool &isDifferent) | Activ::Database::FieldListObject | [inline]
SetField(const FieldSpecification::Id fieldId, const T &value) | Activ::Database::FieldListObject | [inline]
SetField(const FieldSpecification::Id fieldId, const T &value, bool &isDifferent) | Activ::Database::FieldListObject | [inline]
SetId(const DataId id) const | Activ::Database::FieldListObject | [inline]
SetIndexFields(const ScatterBufferHelper &scatterBufferHelper) | Activ::Database::Key | [inline]
ToLogString() const | Activ::Database::FieldListObject | [inline]
ToString() const | Activ::Database::FieldListObject | [inline]
UndefineField(const FieldSpecification::Id fieldId) | Activ::Database::FieldListObject | [inline]
UndefineField(const FieldSpecification::Id fieldId, bool &isDifferent) | Activ::Database::FieldListObject | [inline]
Validate(const ITable *pTable) const | Activ::Database::Key | [inline]
Validate(const ITable *pTable, const size_t nIndexes) const | Activ::Database::Key | [inline]
~FieldListObject()=0 | Activ::Database::FieldListObject | [inline, pure virtual]
~Key() | Activ::Database::Key | [inline]

Generated on Wed Oct 8 14:02:11 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Database::ManagedTableFactory Member List

This is the complete list of members for Activ::Database::ManagedTableFactory, including all inherited members.

Create(const std::string &name, const TableSpecification::Properties properties, const FieldSpecification fieldSpecificationList[], const size_t nFields, const size_t initialMaxRecords, const size_t nGrowRecords=TableSpecification::GROW_RECORDS_DEFAULT, const size_t cacheSize=TableSpecification::CACHE_COMPLETE) | Activ::Database::ManagedTableFactory |
Create(const std::string &name, const TableSpecification::Properties properties, const FieldSpecificationList &fieldSpecificationList, const size_t initialMaxRecords, const size_t nGrowRecords=TableSpecification::GROW_RECORDS_DEFAULT, const size_t cacheSize=TableSpecification::CACHE_COMPLETE) | Activ::Database::ManagedTableFactory |
Create(const std::string &name, const std::string &directory, const TableSpecification::Properties properties, const FieldSpecification fieldSpecificationList[], const size_t nFields, const size_t initialMaxRecords, const size_t nGrowRecords=TableSpecification::GROW_RECORDS_DEFAULT, const size_t cacheSize=TableSpecification::CACHE_COMPLETE) | Activ::Database::ManagedTableFactory |
Create(const std::string &name, const std::string &directory, const TableSpecification::Properties properties, const FieldSpecificationList &fieldSpecificationList, const size_t initialMaxRecords, const size_t nGrowRecords=TableSpecification::GROW_RECORDS_DEFAULT, const size_t cacheSize=TableSpecification::CACHE_COMPLETE) | Activ::Database::ManagedTableFactory |
GetInstance() | Activ::Database::ManagedTableFactory | [static]
Singleton() | Activ::Singleton< T > | [inline, protected]
Singleton< ManagedTableFactory > (defined in Activ::Database::ManagedTableFactory) | Activ::Database::ManagedTableFactory | [friend]

Generated on Wed Oct 8 14:02:12 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Database::Record Member List

This is the complete list of members for Activ::Database::Record, including all inherited members.

AllocateBuffer(const size_t requiredBufferSize) | Activ::Database::FieldListObject | [inline, protected]
Begin() const | Activ::Database::FieldListObject | [inline]
CompareField(const FieldSpecification::Id fieldId, const IFieldType &iFieldType, int &result) const | Activ::Database::FieldListObject | [inline]
CompareField(const FieldSpecification::Id fieldId, const std::string &value, int &result) const | Activ::Database::FieldListObject | [inline]
CompareField(const FieldSpecification::Id fieldId, const FieldListObject &rhsFieldListObject, int &result) const | Activ::Database::FieldListObject | [inline]
CompareField(const FieldSpecification::Id lhsFieldId, const FieldListObject &rhsFieldListObject, const FieldSpecification::Id rhsFieldId, int &result) const | Activ::Database::FieldListObject | [inline]
ConstIterator typedef | Activ::Database::FieldListObject |
CopyField(const FieldSpecification::Id fieldId, const FieldListObject &sourceFieldListObject) | Activ::Database::FieldListObject | [inline]
CopyField(const FieldSpecification::Id fieldId, const FieldListObject &sourceFieldListObject, bool &isDifferent) | Activ::Database::FieldListObject | [inline]
CopyField(const FieldSpecification::Id targetFieldId, const FieldListObject &sourceFieldListObject, const FieldSpecification::Id sourceFieldId) | Activ::Database::FieldListObject | [inline]
CopyField(const FieldSpecification::Id targetFieldId, const FieldListObject &sourceFieldListObject, const FieldSpecification::Id sourceFieldId, bool &isDifferent) | Activ::Database::FieldListObject | [inline]
CopyFields(const FieldListObject &sourceFieldListObject, const bool copyAllFields=false) | Activ::Database::FieldListObject | [inline, virtual]
DEFAULT_BUFFER_SIZE (defined in Activ::Database::FieldListObject) | Activ::Database::FieldListObject | [protected, static]
DefineField(const FieldSpecification::Id fieldId, const size_t fieldLength=~0) | Activ::Database::FieldListObject | [inline]
Deserialize(ITable *pTable, MessageValidator &messageValidator) | Activ::Database::Record | [virtual]
End() const | Activ::Database::FieldListObject | [inline]
FieldList::ConstIterator (defined in Activ::Database::FieldListObject) | Activ::Database::FieldListObject | [friend]
FieldListObject() | Activ::Database::FieldListObject | [inline]
Get() | Activ::Database::FieldListObject | [inline]
Get() const | Activ::Database::FieldListObject | [inline]
GetDataLength() const | Activ::Database::Record | [inline]
GetField(const FieldSpecification::Id fieldId, void *pField, const size_t fieldSize, size_t &fieldLength) const | Activ::Database::FieldListObject | [inline]
GetField(const FieldSpecification::Id fieldId, const void *&pField, size_t &fieldLength) const | Activ::Database::FieldListObject | [inline]
GetField(const FieldSpecification::Id fieldId, void *&pField, size_t &fieldLength) | Activ::Database::FieldListObject | [inline]
GetField(const FieldSpecification::Id fieldId, T &value) const | Activ::Database::FieldListObject | [inline]
GetField(const ConstIterator &iterator, const void *&pField, size_t &fieldLength) const | Activ::Database::FieldListObject | [inline]
GetField(const ConstIterator &iterator, FieldSpecification::Id &fieldId, FieldSpecification::Type &type, const void *&pField, size_t &fieldLength) const | Activ::Database::FieldListObject | [inline]
GetFieldIdList(FieldIdList &fieldIdList) const | Activ::Database::FieldListObject | [inline]
GetFieldList() const | Activ::Database::FieldListObject | [inline, protected]
GetFieldSpecification(const FieldSpecification::Id fieldId, FieldSpecification &fieldSpecification) const | Activ::Database::FieldListObject | [inline]
GetFieldSpecificationList(FieldSpecificationList &fieldSpecificationList) const | Activ::Database::FieldListObject | [inline]
GetFirstFieldId(FieldSpecification::Id &fieldId) const | Activ::Database::FieldListObject | [inline]
GetId() const | Activ::Database::FieldListObject | [inline]
GetKey(const IndexSpecification::Number indexNo) const | Activ::Database::Record |
GetMatchingFieldsById(FieldIdList &fieldIdList, const FieldListObject &rhsFieldListObject) | Activ::Database::FieldListObject |
GetMatchingFieldsByName(FieldIdList &lhsFieldIdList, const FieldListObject &rhsFieldListObject, FieldIdList &rhsFieldIdList) | Activ::Database::FieldListObject |
GetNextFieldId(FieldSpecification::Id &fieldId) const | Activ::Database::FieldListObject | [inline]
GetPrimaryKey() const | Activ::Database::Record |
GetTablePointer(ITable *&pTable) const | Activ::Database::FieldListObject | [inline]
GetType(const FieldSpecification::Id fieldId, FieldSpecification::Type &type) const | Activ::Database::FieldListObject | [inline]
Initialize(ITable *pTable) | Activ::Database::Record | [inline]
Initialize(ITable *pTable, const void *pSourceData, const DataId id) | Activ::Database::Record |
Initialize(const Record &rhs) | Activ::Database::Record |
Initialize(const Key &key) | Activ::Database::Record |
Activ::Database::FieldListObject::Initialize() | Activ::Database::FieldListObject | [inline]
Activ::Database::FieldListObject::Initialize(ITable *pTable, const FieldList *pFieldList, const size_t requiredBufferSize) | Activ::Database::FieldListObject | [inline]
IsFieldDefined(const FieldSpecification::Id fieldId, bool &result) const | Activ::Database::FieldListObject | [inline]
IsFieldDifferent(const FieldSpecification::Id fieldId, const void *pField, const size_t fieldLength, bool &result) const | Activ::Database::FieldListObject | [inline]
IsFieldDifferent(const FieldSpecification::Id fieldId, const IFieldType &iFieldType, bool &result) const | Activ::Database::FieldListObject | [inline]
IsFieldDifferent(const FieldSpecification::Id fieldId, const std::string &value, bool &result) const | Activ::Database::FieldListObject | [inline]
IsFieldDifferent(const FieldSpecification::Id fieldId, const FieldListObject &rhsFieldListObject, bool &result) const | Activ::Database::FieldListObject | [inline]
IsFieldDifferent(const FieldSpecification::Id lhsFieldId, const FieldListObject &rhsFieldListObject, const FieldSpecification::Id rhsFieldId, bool &result) const | Activ::Database::FieldListObject | [inline]
IsFound(const FieldSpecification::Id fieldId) const | Activ::Database::FieldListObject | [inline]
IsInitialized() const | Activ::Database::FieldListObject | [inline]
m_bufferSize | Activ::Database::FieldListObject | [protected]
m_defaultBuffer | Activ::Database::FieldListObject | [protected]
m_id | Activ::Database::FieldListObject | [mutable, protected]
m_isInitialized | Activ::Database::FieldListObject | [protected]
m_pData | Activ::Database::FieldListObject | [protected]
m_pFieldList | Activ::Database::FieldListObject | [protected]
m_pTable | Activ::Database::FieldListObject | [protected]
m_tableIdentity | Activ::Database::FieldListObject | [protected]
operator!=(const Record &rhs) const | Activ::Database::Record |
operator=(const Record &rhs) | Activ::Database::Record |
operator==(const Record &rhs) const | Activ::Database::Record |
Record() | Activ::Database::Record | [inline]
Record(ITable *pTable) | Activ::Database::Record |
Record(ITable *pTable, const void *pSourceData, const DataId id) | Activ::Database::Record |
Record(const Record &rhs) | Activ::Database::Record |
Record(const Key &key) | Activ::Database::Record |
Reset() | Activ::Database::Record | [inline, virtual]
Serialize(MessageBuilder &messageBuilder) const | Activ::Database::Record | [virtual]
Set(const void *pSourceData) | Activ::Database::Record | [inline]
SetField(const FieldSpecification::Id fieldId, const void *pField, const size_t fieldLength) | Activ::Database::FieldListObject | [inline]
SetField(const FieldSpecification::Id fieldId, const void *pField, const size_t fieldLength, bool &isDifferent) | Activ::Database::FieldListObject | [inline]
SetField(const FieldSpecification::Id fieldId, const T &value) | Activ::Database::FieldListObject | [inline]
SetField(const FieldSpecification::Id fieldId, const T &value, bool &isDifferent) | Activ::Database::FieldListObject | [inline]
SetId(const DataId id) const | Activ::Database::FieldListObject | [inline]
SetIndexFields(const IndexSpecification::Number indexNo, const ScatterBufferHelper &scatterBufferHelper) | Activ::Database::Record | [inline]
ToLogString() const | Activ::Database::FieldListObject | [inline]
ToString() const | Activ::Database::FieldListObject | [inline]
UndefineField(const FieldSpecification::Id fieldId) | Activ::Database::FieldListObject | [inline]
UndefineField(const FieldSpecification::Id fieldId, bool &isDifferent) | Activ::Database::FieldListObject | [inline]
Validate(const ITable *pTable) const | Activ::Database::Record | [inline]
~FieldListObject()=0 | Activ::Database::FieldListObject | [inline, pure virtual]
~Record() | Activ::Database::Record | [inline, virtual]

Generated on Wed Oct 8 14:02:12 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Database::RemoteTableFactory Member List

This is the complete list of members for Activ::Database::RemoteTableFactory, including all inherited members.

Create(MessageValidator &messageValidator) | Activ::Database::RemoteTableFactory |
GetInstance() | Activ::Database::RemoteTableFactory | [static]
Singleton() | Activ::Singleton< T > | [inline, protected]
Singleton< RemoteTableFactory > (defined in Activ::Database::RemoteTableFactory) | Activ::Database::RemoteTableFactory | [friend]

Generated on Wed Oct 8 14:02:12 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Database::TableSpecification Member List

This is the complete list of members for Activ::Database::TableSpecification, including all inherited members.

CACHE_COMPLETE | Activ::Database::TableSpecification | [static]
CreateTable(const std::string &directory=std::string()) const | Activ::Database::TableSpecification |
Deserialize(MessageValidator &messageValidator) | Activ::Database::TableSpecification |
GROW_RECORDS_DEFAULT | Activ::Database::TableSpecification | [static]
m_cacheSize | Activ::Database::TableSpecification |
m_fieldSpecificationList | Activ::Database::TableSpecification |
m_initialMaxRecords | Activ::Database::TableSpecification |
m_isManaged | Activ::Database::TableSpecification |
m_name | Activ::Database::TableSpecification |
m_nGrowRecords | Activ::Database::TableSpecification |
m_properties | Activ::Database::TableSpecification |
m_recordLength | Activ::Database::TableSpecification |
operator!=(const TableSpecification &rhs) const | Activ::Database::TableSpecification |
operator==(const TableSpecification &rhs) const | Activ::Database::TableSpecification |
Properties typedef | Activ::Database::TableSpecification |
PROPERTY_CONVERT enum value | Activ::Database::TableSpecification |
PROPERTY_CREATE_MUTEX enum value | Activ::Database::TableSpecification |
PROPERTY_CREATE_RECORD_FILE enum value | Activ::Database::TableSpecification |
PROPERTY_NONE enum value (defined in Activ::Database::TableSpecification) | Activ::Database::TableSpecification |
Serialize(MessageBuilder &messageBuilder, ITable *pTable, const uint8_t version=VERSION) | Activ::Database::TableSpecification | [static]
Serialize(MessageBuilder &messageBuilder, const uint8_t version=VERSION) const | Activ::Database::TableSpecification |
ShouldConvert(const Properties properties) | Activ::Database::TableSpecification | [static]
ShouldCreateMutex(const Properties properties) | Activ::Database::TableSpecification | [static]
ShouldCreateRecordFile(const Properties properties) | Activ::Database::TableSpecification | [static]
TableSpecification() | Activ::Database::TableSpecification |
TableSpecification(const std::string &name, const Properties properties, const FieldSpecificationList &fieldSpecificationList, const size_t initialMaxRecords, const size_t nGrowRecords=GROW_RECORDS_DEFAULT, const size_t cacheSize=CACHE_COMPLETE) | Activ::Database::TableSpecification |
TableSpecification(const std::string &name, const Properties properties, const FieldSpecificationList &fieldSpecificationList, const size_t initialMaxRecords, const size_t recordLength, const size_t nGrowRecords=GROW_RECORDS_DEFAULT, const size_t cacheSize=CACHE_COMPLETE) | Activ::Database::TableSpecification |
TableSpecification(const std::string &name, const bool isManaged, const Properties properties, const FieldSpecificationList &fieldSpecificationList, const size_t initialMaxRecords, const size_t recordLength, const size_t nGrowRecords, const size_t cacheSize) | Activ::Database::TableSpecification |
ToString() const | Activ::Database::TableSpecification |
VERSION | Activ::Database::TableSpecification | [static]

Generated on Wed Oct 8 14:02:12 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Database::UnmanagedTableFactory Member List

This is the complete list of members for Activ::Database::UnmanagedTableFactory, including all inherited members.

Create(const std::string &name, const TableSpecification::Properties properties, const FieldSpecification fieldSpecificationList[], const size_t nFields, const size_t initialMaxRecords, const size_t recordLength, const size_t nGrowRecords=TableSpecification::GROW_RECORDS_DEFAULT, const size_t cacheSize=TableSpecification::CACHE_COMPLETE) | Activ::Database::UnmanagedTableFactory |
Create(const std::string &name, const TableSpecification::Properties properties, const FieldSpecificationList &fieldSpecificationList, const size_t initialMaxRecords, const size_t recordLength, const size_t nGrowRecords=TableSpecification::GROW_RECORDS_DEFAULT, const size_t cacheSize=TableSpecification::CACHE_COMPLETE) | Activ::Database::UnmanagedTableFactory |
Create(const std::string &name, const std::string &directory, const TableSpecification::Properties properties, const FieldSpecification fieldSpecificationList[], const size_t nFields, const size_t initialMaxRecords, const size_t recordLength, const size_t nGrowRecords=TableSpecification::GROW_RECORDS_DEFAULT, const size_t cacheSize=TableSpecification::CACHE_COMPLETE) | Activ::Database::UnmanagedTableFactory |
Create(const std::string &name, const std::string &directory, const TableSpecification::Properties properties, const FieldSpecificationList &fieldSpecificationList, const size_t initialMaxRecords, const size_t recordLength, const size_t nGrowRecords=TableSpecification::GROW_RECORDS_DEFAULT, const size_t cacheSize=TableSpecification::CACHE_COMPLETE) | Activ::Database::UnmanagedTableFactory |
GetInstance() | Activ::Database::UnmanagedTableFactory | [static]
Singleton() | Activ::Singleton< T > | [inline, protected]
Singleton< UnmanagedTableFactory > (defined in Activ::Database::UnmanagedTableFactory) | Activ::Database::UnmanagedTableFactory | [friend]

Generated on Wed Oct 8 14:02:12 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Date Member List

This is the complete list of members for Activ::Date, including all inherited members.

ACTIV_DECLARE_ELEMENT_1_WITH_COMMA enum value (defined in Activ::Date) | Activ::Date |
Add(const Days &days) | Activ::Date |
Assign(const IFieldType *const pIFieldType) | Activ::IFieldType |
Clear() | Activ::Date | [inline, virtual]
Compare(const Date &rhs, int &result) const | Activ::Date |
Compare(const void *const pRhsSerializedBody, const size_t rhsSerializedBodyLength, int &result) const | Activ::Date | [virtual]
Compare(const void *const pLhsSerializedBody, const size_t lhsSerializedBodyLength, const void *const pRhsSerializedBody, const size_t rhsSerializedBodyLength, int &result) | Activ::Date | [static]
Convert(const IFieldType *const pIFieldType) | Activ::Date | [virtual]
ConvertGregorianToJulianDate(const int32_t year, const int32_t month, const int32_t day) | Activ::Date | [static]
ConvertJulianToGregorianDate(const int32_t julianDate, int32_t &year, int32_t &month, int32_t &day) | Activ::Date | [static]
CreateLocalDate() | Activ::Date | [static]
CreateUtcDate() | Activ::Date | [static]
Date() | Activ::Date | [inline]
Date(const uint32_t year, const uint32_t month, const uint32_t day) | Activ::Date | [inline]
Date(const int32_t julianDate) | Activ::Date | [inline, explicit]
Date(const std::tm &tm) | Activ::Date | [inline]
DateTime (defined in Activ::Date) | Activ::Date | [friend]
DayOfWeekToString(const uint32_t dayOfWeek) | Activ::Date | [static]
DAYS_PER_MONTH | Activ::Date | [static]
DAYS_PER_WEEK | Activ::Date | [static]
Deserialize(MessageValidator &messageValidator, const size_t maxSerializedBodyLength) | Activ::Date | [virtual]
Activ::IFieldType::Deserialize(const FieldType fieldType, MessageValidator &messageValidator, const size_t maxSerializedBodyLength) | Activ::IFieldType |
DeserializeBody(const void *const pSerializedBody, const size_t serializedBodyLength) | Activ::Date | [virtual]
Activ::IFieldType::DeserializeBody(const FieldType fieldType, const void *const pSerializedBody, const size_t serializedBodyLength) | Activ::IFieldType |
DeserializeLengthAndBody(MessageValidator &messageValidator, const size_t maxSerializedBodyLength=MAX_SERIALIZED_BODY_LENGTH_UNDEFINED) | Activ::Date | [virtual]
Activ::IFieldType::DeserializeLengthAndBody(const FieldType fieldType, MessageValidator &messageValidator, const size_t maxSerializedBodyLength=MAX_SERIALIZED_BODY_LENGTH_UNDEFINED) | Activ::IFieldType |
FIELD_TYPE | Activ::Date | [static]
FromString(MessageValidator &messageValidator) | Activ::Date | [virtual]
Activ::IFieldType::FromString(const std::string &field) | Activ::IFieldType | [inline]
Get() const | Activ::Date | [inline]
Get(uint32_t &year, uint32_t &month, uint32_t &day) const | Activ::Date | [inline]
Get(int32_t &julianDate) const | Activ::Date | [inline]
Get(std::tm &tm) const | Activ::Date | [inline]
GetDay() const | Activ::Date | [inline]
GetDayOfWeek() const | Activ::Date | [inline]
GetDayOfWeek(const uint32_t year, const uint32_t month, const uint32_t day) | Activ::Date | [static]
GetDayOfYear() const | Activ::Date | [inline]
GetDayOfYear(const uint32_t year, const uint32_t month, const uint32_t day) | Activ::Date | [static]
GetDaysInMonth(const uint32_t year, const uint32_t month) | Activ::Date | [static]
GetFromStringFormat() const | Activ::Date | [virtual]
GetMaxSerializedBodyLength() | Activ::Date | [inline, static]
GetMaxSerializedLength() | Activ::Date | [inline, static]
GetMonth() const | Activ::Date | [inline]
GetSerializedBodyLength() const | Activ::Date | [inline, virtual]
GetSerializedLength() const | Activ::Date | [inline, virtual]
GetType() const | Activ::IFieldType | [inline]
GetWeekOfYear() const | Activ::Date | [inline]
GetWeekOfYear(const uint32_t year, const uint32_t month, const uint32_t day) | Activ::Date | [static]
GetYear() const | Activ::Date | [inline]
IFieldType(const FieldType fieldType) | Activ::IFieldType | [inline, explicit, protected]
IsDifferent(const void *const pRhsSerializedBody, const size_t rhsSerializedBodyLength, bool &isDifferent) const | Activ::Date | [virtual]
IsInitialized() const | Activ::IFieldType | [inline]
IsLeapYear(const uint32_t year) | Activ::Date | [static]
IsValidSerializedBodyLength(const size_t serializedBodyLength) | Activ::Date | [inline, static]
Activ::IFieldType::IsValidSerializedBodyLength(const FieldType fieldType, const size_t serializedBodyLength) | Activ::IFieldType | [static]
m_isInitialized | Activ::IFieldType | [protected]
MAX_SERIALIZED_BODY_LENGTH_UNDEFINED | Activ::IFieldType | [static]
MONTHS_PER_YEAR | Activ::Date | [static]
MonthToString(const uint32_t month) | Activ::Date | [static]
operator!=(const Date &rhs) const | Activ::Date | [inline]
operator+(const T &rhs) const | Activ::Date | [inline]
operator+=(const T &rhs) | Activ::Date | [inline]
operator-(const T &rhs) const | Activ::Date | [inline]
operator-=(const T &rhs) | Activ::Date | [inline]
operator<(const Date &rhs) const | Activ::Date | [inline]
operator<=(const Date &rhs) const | Activ::Date | [inline]
operator==(const Date &rhs) const | Activ::Date | [inline]
operator>(const Date &rhs) const | Activ::Date | [inline]
operator>=(const Date &rhs) const | Activ::Date | [inline]
Reset() | Activ::Date | [inline, virtual]
Serialize(MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength) const | Activ::Date | [virtual]
Activ::IFieldType::Serialize(const FieldType fieldType, MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength) const | Activ::IFieldType |
Activ::IFieldType::Serialize(const FieldType fieldType, MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength, const uint8_t *const pData, const size_t size) | Activ::IFieldType | [static]
SerializeBody(void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength) const | Activ::Date | [virtual]
Activ::IFieldType::SerializeBody(const FieldType fieldType, void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength) const | Activ::IFieldType |
Activ::IFieldType::SerializeBody(const FieldType fieldType, void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength, const uint8_t *const pData, const size_t size) | Activ::IFieldType | [static]
SerializeLengthAndBody(MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength=MAX_SERIALIZED_BODY_LENGTH_UNDEFINED) const | Activ::Date | [virtual]
Activ::IFieldType::SerializeLengthAndBody(const FieldType fieldType, MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength=MAX_SERIALIZED_BODY_LENGTH_UNDEFINED) const | Activ::IFieldType |
Activ::IFieldType::SerializeLengthAndBody(const FieldType fieldType, MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength, const uint8_t *const pData, const size_t size) | Activ::IFieldType | [static]
Set(const uint32_t year, const uint32_t month, const uint32_t day) | Activ::Date | [inline]
Set(const int32_t julianDate) | Activ::Date | [inline]
Set(const std::tm &tm) | Activ::Date | [inline]
Subtract(const Days &days) | Activ::Date |
ToString() const | Activ::Date | [virtual]
ValidateSerializedLengthAndBody(MessageValidator &messageValidator, size_t &serializedBodyOffset, size_t &serializedBodyLength) | Activ::Date | [static]
Activ::IFieldType::ValidateSerializedLengthAndBody(const FieldType fieldType, MessageValidator &messageValidator, size_t &serializedBodyOffset, size_t &serializedBodyLength) | Activ::IFieldType | [static]
~Date() | Activ::Date | [inline, virtual]
~IFieldType()=0 | Activ::IFieldType | [inline, pure virtual]

Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Date::Days Member List

This is the complete list of members for Activ::Date::Days, including all inherited members.

Days(const int32_t value) | Activ::Date::Days | [inline, explicit]
m_value | Activ::Date::Days |

Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::DateTime Member List

This is the complete list of members for Activ::DateTime, including all inherited members.

Add(const Time &rhs) | Activ::DateTime | [inline]
Add(const Days &days) | Activ::DateTime | [inline]
Add(const Hours &hours) | Activ::DateTime | [inline]
Add(const Minutes &minutes) | Activ::DateTime | [inline]
Add(const Seconds &seconds) | Activ::DateTime | [inline]
Add(const Milliseconds &milliseconds) | Activ::DateTime |
Assign(const IFieldType *const pIFieldType) | Activ::IFieldType |
Clear() | Activ::DateTime | [inline, virtual]
Compare(const DateTime &rhs, int &result) const | Activ::DateTime |
Compare(const void *const pRhsSerializedBody, const size_t rhsSerializedBodyLength, int &result) const | Activ::DateTime | [virtual]
Compare(const void *const pLhsSerializedBody, const size_t lhsSerializedBodyLength, const void *const pRhsSerializedBody, const size_t rhsSerializedBodyLength, int &result) | Activ::DateTime | [static]
Convert(const IFieldType *const pIFieldType) | Activ::DateTime | [virtual]
ConvertGregorianToJulianDateTime(const int32_t year, const int32_t month, const int32_t day, const int32_t hour, const int32_t minute, const int32_t second) | Activ::DateTime | [inline, static]
ConvertJulianToGregorianDateTime(const int64_t julianDateTime, int32_t &year, int32_t &month, int32_t &day, int32_t &hour, int32_t &minute, int32_t &second) | Activ::DateTime | [inline, static]
CreateLocalDateTime(const bool shouldSetMilliseconds=false) | Activ::DateTime | [static]
CreateUtcDateTime(const bool shouldSetMilliseconds=false) | Activ::DateTime | [static]
DateTime() | Activ::DateTime | [inline]
DateTime(const uint32_t year, const uint32_t month, const uint32_t day, const uint32_t hour, const uint32_t minute, const uint32_t second, const uint32_t millisecond=0) | Activ::DateTime | [inline]
DateTime(const int64_t julianDateTime, const uint32_t millisecond=0) | Activ::DateTime | [inline, explicit]
DateTime(const std::tm &tm, const uint32_t millisecond=0) | Activ::DateTime | [inline]
DateTime(const Date &date, const Time &time) | Activ::DateTime | [inline]
Days typedef | Activ::DateTime |
Deserialize(MessageValidator &messageValidator, const size_t maxSerializedBodyLength) | Activ::DateTime | [virtual]
Activ::IFieldType::Deserialize(const FieldType fieldType, MessageValidator &messageValidator, const size_t maxSerializedBodyLength) | Activ::IFieldType |
DeserializeBody(const void *const pSerializedBody, const size_t serializedBodyLength) | Activ::DateTime | [virtual]
Activ::IFieldType::DeserializeBody(const FieldType fieldType, const void *const pSerializedBody, const size_t serializedBodyLength) | Activ::IFieldType |
DeserializeLengthAndBody(MessageValidator &messageValidator, const size_t maxSerializedBodyLength=MAX_SERIALIZED_BODY_LENGTH_UNDEFINED) | Activ::DateTime | [virtual]
Activ::IFieldType::DeserializeLengthAndBody(const FieldType fieldType, MessageValidator &messageValidator, const size_t maxSerializedBodyLength=MAX_SERIALIZED_BODY_LENGTH_UNDEFINED) | Activ::IFieldType |
FIELD_TYPE | Activ::DateTime | [static]
FromString(MessageValidator &messageValidator) | Activ::DateTime | [virtual]
Activ::IFieldType::FromString(const std::string &field) | Activ::IFieldType | [inline]
Get() const | Activ::DateTime | [inline]
Get(uint32_t &year, uint32_t &month, uint32_t &day, uint32_t &hour, uint32_t &minute, uint32_t &second) const | Activ::DateTime | [inline]
Get(uint32_t &year, uint32_t &month, uint32_t &day, uint32_t &hour, uint32_t &minute, uint32_t &second, uint32_t &millisecond) const | Activ::DateTime | [inline]
Get(int64_t &julianDateTime) const | Activ::DateTime | [inline]
Get(int64_t &julianDateTime, uint32_t &millisecond) const | Activ::DateTime | [inline]
Get(std::tm &tm) const | Activ::DateTime | [inline]
Get(std::tm &tm, uint32_t &millisecond) const | Activ::DateTime | [inline]
GetDate() const | Activ::DateTime | [inline]
GetDay() const | Activ::DateTime | [inline]
GetDayOfWeek() const | Activ::DateTime | [inline]
GetDayOfYear() const | Activ::DateTime | [inline]
GetFromStringFormat() const | Activ::DateTime | [virtual]
GetHour() const | Activ::DateTime | [inline]
GetJulianDate(const int64_t julianDateTime) | Activ::DateTime | [inline, static]
GetJulianTime(const int64_t julianDateTime) | Activ::DateTime | [inline, static]
GetLocal() const | Activ::DateTime | [inline]
GetMaxSerializedBodyLength(const bool shouldSerializeMilliseconds) | Activ::DateTime | [inline, static]
GetMaxSerializedLength(const bool shouldSerializeMilliseconds) | Activ::DateTime | [inline, static]
GetMillisecond() const | Activ::DateTime | [inline]
GetMinute() const | Activ::DateTime | [inline]
GetMonth() const | Activ::DateTime | [inline]
GetSecond() const | Activ::DateTime | [inline]
GetSerializedBodyLength() const | Activ::DateTime | [inline, virtual]
GetSerializedBodyLength(const void *const pSerializedBody) | Activ::DateTime | [inline, static]
GetSerializedLength() const | Activ::DateTime | [inline, virtual]
GetSerializedLength(const void *const pSerializedBody) | Activ::DateTime | [inline, static]
GetTime() const | Activ::DateTime | [inline]
GetTimeZoneOffset() | Activ::DateTime | [static]
GetTotalMilliseconds() const | Activ::DateTime | [inline]
GetType() const | Activ::IFieldType | [inline]
GetUtc() const | Activ::DateTime | [inline]
GetWeekOfYear() const | Activ::DateTime | [inline]
GetYear() const | Activ::DateTime | [inline]
Hours typedef | Activ::DateTime |
IFieldType(const FieldType fieldType) | Activ::IFieldType | [inline, explicit, protected]
IsDifferent(const void *const pRhsSerializedBody, const size_t rhsSerializedBodyLength, bool &isDifferent) const | Activ::DateTime | [virtual]
IsInitialized() const | Activ::IFieldType | [inline]
IsValidSerializedBodyLength(const size_t serializedBodyLength) | Activ::DateTime | [inline, static]
Activ::IFieldType::IsValidSerializedBodyLength(const FieldType fieldType, const size_t serializedBodyLength) | Activ::IFieldType | [static]
m_isInitialized | Activ::IFieldType | [protected]
MAX_SERIALIZED_BODY_LENGTH_UNDEFINED | Activ::IFieldType | [static]
Milliseconds typedef | Activ::DateTime |
Minutes typedef | Activ::DateTime |
operator const Date &() const | Activ::DateTime | [inline]
operator const Time &() const | Activ::DateTime | [inline]
operator!=(const DateTime &rhs) const | Activ::DateTime | [inline]
operator+(const T &rhs) const | Activ::DateTime | [inline]
operator+=(const T &rhs) | Activ::DateTime | [inline]
operator-(const T &rhs) const | Activ::DateTime | [inline]
operator-=(const T &rhs) | Activ::DateTime | [inline]
operator<(const DateTime &rhs) const | Activ::DateTime | [inline]
operator<=(const DateTime &rhs) const | Activ::DateTime | [inline]
operator==(const DateTime &rhs) const | Activ::DateTime | [inline]
operator>(const DateTime &rhs) const | Activ::DateTime | [inline]
operator>=(const DateTime &rhs) const | Activ::DateTime | [inline]
Reset() | Activ::DateTime | [inline, virtual]
Seconds typedef | Activ::DateTime |
Serialize(MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength) const | Activ::DateTime | [virtual]
Activ::IFieldType::Serialize(const FieldType fieldType, MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength) const | Activ::IFieldType |
Activ::IFieldType::Serialize(const FieldType fieldType, MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength, const uint8_t *const pData, const size_t size) | Activ::IFieldType | [static]
SerializeBody(void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength) const | Activ::DateTime | [virtual]
Activ::IFieldType::SerializeBody(const FieldType fieldType, void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength) const | Activ::IFieldType |
Activ::IFieldType::SerializeBody(const FieldType fieldType, void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength, const uint8_t *const pData, const size_t size) | Activ::IFieldType | [static]
SerializeLengthAndBody(MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength=MAX_SERIALIZED_BODY_LENGTH_UNDEFINED) const | Activ::DateTime | [virtual]
Activ::IFieldType::SerializeLengthAndBody(const FieldType fieldType, MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength=MAX_SERIALIZED_BODY_LENGTH_UNDEFINED) const | Activ::IFieldType |
Activ::IFieldType::SerializeLengthAndBody(const FieldType fieldType, MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength, const uint8_t *const pData, const size_t size) | Activ::IFieldType | [static]
Set(const uint32_t year, const uint32_t month, const uint32_t day, const uint32_t hour, const uint32_t minute, const uint32_t second, const uint32_t millisecond=0) | Activ::DateTime | [inline]
Set(const int64_t julianDateTime, const uint32_t millisecond=0) | Activ::DateTime | [inline]
Set(const std::tm &tm, const uint32_t millisecond=0) | Activ::DateTime | [inline]
Set(const Date &date, const Time &time) | Activ::DateTime | [inline]
Subtract(const Time &rhs) | Activ::DateTime | [inline]
Subtract(const Days &days) | Activ::DateTime | [inline]
Subtract(const Hours &hours) | Activ::DateTime | [inline]
Subtract(const Minutes &minutes) | Activ::DateTime | [inline]
Subtract(const Seconds &seconds) | Activ::DateTime | [inline]
Subtract(const Milliseconds &milliseconds) | Activ::DateTime |
ToString() const | Activ::DateTime | [virtual]
ToString(const bool shouldDisplayMilliseconds) const | Activ::DateTime |
ValidateSerializedLengthAndBody(MessageValidator &messageValidator, size_t &serializedBodyOffset, size_t &serializedBodyLength) | Activ::DateTime | [static]
Activ::IFieldType::ValidateSerializedLengthAndBody(const FieldType fieldType, MessageValidator &messageValidator, size_t &serializedBodyOffset, size_t &serializedBodyLength) | Activ::IFieldType | [static]
~DateTime() | Activ::DateTime | [inline, virtual]
~IFieldType()=0 | Activ::IFieldType | [inline, pure virtual]

Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::DeferredScopedMutexLocker Member List

This is the complete list of members for Activ::DeferredScopedMutexLocker, including all inherited members.

Acquire() | Activ::DeferredScopedMutexLocker | [inline]
DeferredScopedMutexLocker(const IMutex *const pMutex) | Activ::DeferredScopedMutexLocker | [inline]
operator bool() const | Activ::DeferredScopedMutexLocker | [inline]
operator!() const | Activ::DeferredScopedMutexLocker | [inline]
Try() | Activ::DeferredScopedMutexLocker | [inline]
~DeferredScopedMutexLocker() | Activ::DeferredScopedMutexLocker | [inline]

Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::DeleteAssociativeObject Member List

This is the complete list of members for Activ::DeleteAssociativeObject, including all inherited members.

operator()(const Pair &pair) const Activ::DeleteAssociativeObject [inline]

Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::DeleteObject Member List

This is the complete list of members for Activ::DeleteObject, including all inherited members.

operator()(const T *ptr) const Activ::DeleteObject [inline]

Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::DeleteObjectArray Member List

This is the complete list of members for Activ::DeleteObjectArray, including all inherited members.

operator()(const T *ptr) const Activ::DeleteObjectArray [inline]

Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Des3Helper::Key Member List

This is the complete list of members for Activ::Des3Helper::Key, including all inherited members.

GetKeyBlock() const | Activ::Des3Helper::Key | [inline]
GetKeySchedule() const | Activ::Des3Helper::Key | [inline]
IsInitialized() const | Activ::Des3Helper::Key | [inline]
Key() | Activ::Des3Helper::Key | [inline]
Key(const DES_cblock &keyBlock) | Activ::Des3Helper::Key | [inline]
Key(const std::string &hexString) | Activ::Des3Helper::Key | [inline]
Randomize() | Activ::Des3Helper::Key | [inline]
SetKey(const Key &key) | Activ::Des3Helper::Key | [inline]
SetKey(const DES_cblock &keyBlock) | Activ::Des3Helper::Key | [inline]
SetKey(const std::string &hexString) | Activ::Des3Helper::Key | [inline]
ToString() const | Activ::Des3Helper::Key | [inline]

Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Des3Helper::KeyBundle Member List

This is the complete list of members for Activ::Des3Helper::KeyBundle, including all inherited members.

KeyBundle() | Activ::Des3Helper::KeyBundle | [inline]
KeyBundle(const Des3Helper::Key &key1, const Des3Helper::Key &key2, const Des3Helper::Key &key3) | Activ::Des3Helper::KeyBundle | [inline]
m_key1 | Activ::Des3Helper::KeyBundle |
m_key2 | Activ::Des3Helper::KeyBundle |
m_key3 | Activ::Des3Helper::KeyBundle |
Randomize() | Activ::Des3Helper::KeyBundle | [inline]
SetKeys(const Des3Helper::Key &key1, const Des3Helper::Key &key2, const Des3Helper::Key &key3) | Activ::Des3Helper::KeyBundle | [inline]

Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::DesHelper::Key Member List

This is the complete list of members for Activ::DesHelper::Key, including all inherited members.

GetKeyBlock() const | Activ::DesHelper::Key | [inline]
GetKeySchedule() const | Activ::DesHelper::Key | [inline]
IsInitialized() const | Activ::DesHelper::Key | [inline]
Key() | Activ::DesHelper::Key | [inline]
Key(const DES_cblock &keyBlock) | Activ::DesHelper::Key | [inline]
Key(const std::string &hexString) | Activ::DesHelper::Key | [inline]
Randomize() | Activ::DesHelper::Key | [inline]
SetKey(const Key &key) | Activ::DesHelper::Key | [inline]
SetKey(const DES_cblock &keyBlock) | Activ::DesHelper::Key | [inline]
SetKey(const std::string &hexString) | Activ::DesHelper::Key | [inline]
ToString() const | Activ::DesHelper::Key | [inline]

Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::DirectoryRemover Member List

This is the complete list of members for Activ::DirectoryRemover, including all inherited members.

DirectoryRemover() | Activ::DirectoryRemover |
DirectoryWalker() | Activ::DirectoryWalker | [private]
OnDirectory(const std::string &path, const std::string &name) | Activ::DirectoryRemover | [protected, virtual]
OnFile(const std::string &path, const std::string &name) | Activ::DirectoryRemover | [protected, virtual]
Remove(const std::string &path, const bool shouldRecurseDirectory) | Activ::DirectoryRemover |
Walk(const std::string &path, const std::string &wildcardPattern=std::string()) | Activ::DirectoryWalker | [private]
~DirectoryRemover() | Activ::DirectoryRemover | [virtual]
~DirectoryWalker() | Activ::DirectoryWalker | [private, virtual]

Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::DirectoryWalker Member List

This is the complete list of members for Activ::DirectoryWalker, including all inherited members.

DirectoryWalker() | Activ::DirectoryWalker |
OnDirectory(const std::string &path, const std::string &name) | Activ::DirectoryWalker | [protected, virtual]
OnFile(const std::string &path, const std::string &name) | Activ::DirectoryWalker | [protected, virtual]
Walk(const std::string &path, const std::string &wildcardPattern=std::string()) | Activ::DirectoryWalker |
~DirectoryWalker() | Activ::DirectoryWalker | [virtual]

Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::DirectoryWatchApi Member List

This is the complete list of members for Activ::DirectoryWatchApi, including all inherited members.

AddWatch(const Component &component, const std::string &directoryPath, const WatchType watchType, Address::Proxy watchAddress) | Activ::DirectoryWatchApi | [static]
CancelWatch(const Component &component, Address &watchAddress) | Activ::DirectoryWatchApi | [static]
Deserialize(const HeapMessage &heapMessage, EventList &eventList) | Activ::DirectoryWatchApi | [static]
EVENT_TYPE_ADDED enum value | Activ::DirectoryWatchApi |
EVENT_TYPE_DELETED enum value | Activ::DirectoryWatchApi |
EVENT_TYPE_MODIFIED enum value | Activ::DirectoryWatchApi |
EventList typedef | Activ::DirectoryWatchApi |
EventType enum name | Activ::DirectoryWatchApi |
EventTypeToString(const EventType eventType) | Activ::DirectoryWatchApi | [static]
MESSAGE_TYPE | Activ::DirectoryWatchApi | [static]
WATCH_TYPE_ADDS_DELETES | Activ::DirectoryWatchApi | [static]
WATCH_TYPE_ATTRIBUTES | Activ::DirectoryWatchApi | [static]
WATCH_TYPE_RECURSIVE | Activ::DirectoryWatchApi | [static]
WatchType typedef (defined in Activ::DirectoryWatchApi) | Activ::DirectoryWatchApi |

Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::DirectoryWatchApi::Event Member List

This is the complete list of members for Activ::DirectoryWatchApi::Event, including all inherited members.

m_eventType | Activ::DirectoryWatchApi::Event
m_path | Activ::DirectoryWatchApi::Event

Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::DllFunctionWrapper< NAME, TYPE, THROW_ON_ERROR > Member List

This is the complete list of members for Activ::DllFunctionWrapper< NAME, TYPE, THROW_ON_ERROR >, including all inherited members.

DllFunctionWrapper() | Activ::DllFunctionWrapper< NAME, TYPE, THROW_ON_ERROR > | [inline]
FindFunction(const DllHandle dllHandle) | Activ::DllFunctionWrapper< NAME, TYPE, THROW_ON_ERROR > | [inline]
m_pFunction (defined in Activ::DllFunctionWrapper< NAME, TYPE, THROW_ON_ERROR >) | Activ::DllFunctionWrapper< NAME, TYPE, THROW_ON_ERROR > | [protected]
Type typedef (defined in Activ::DllFunctionWrapper< NAME, TYPE, THROW_ON_ERROR >) | Activ::DllFunctionWrapper< NAME, TYPE, THROW_ON_ERROR > |

Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::DynamicLibraryLoader< T > Member List

This is the complete list of members for Activ::DynamicLibraryLoader< T >, including all inherited members.

DynamicLibraryLoader(const std::string &libraryName) | Activ::DynamicLibraryLoader< T > | [inline]
Get() const | Activ::DynamicLibraryLoader< T > | [inline]
HasAllAvailable() const | Activ::DynamicLibraryLoader< T > | [inline]
~DynamicLibraryLoader() | Activ::DynamicLibraryLoader< T > | [inline]

Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::EndPointSubject Member List

This is the complete list of members for Activ::EndPointSubject, including all inherited members.

Clear() | Activ::Subject | [inline]
Deserialize(MessageValidator &messageValidator) | Activ::Subject |
EndPointSubject() | Activ::EndPointSubject | [inline]
Get() const | Activ::Subject | [inline]
GetLength() const | Activ::Subject | [inline]
GetSerializedLength() const | Activ::Subject | [inline]
MAX_LENGTH | Activ::Subject | [static]
operator!=(const Subject &subject) const | Activ::Subject |
operator<(const Subject &subject) const | Activ::Subject |
operator<=(const Subject &subject) const | Activ::Subject |
operator==(const Subject &subject) const | Activ::Subject |
operator>(const Subject &subject) const | Activ::Subject |
operator>=(const Subject &subject) const | Activ::Subject |
Serialize(MessageBuilder &messageBuilder) const | Activ::Subject |
Set(const char *pSubject) | Activ::Subject |
Set(const void *pSubjectData, const size_t subjectDataLength) | Activ::Subject |
Set(const std::string &subject) | Activ::Subject |
Set(const Subject &subject) | Activ::Subject | [inline]
Subject() | Activ::Subject |
Subject(const void *pSubjectData, const size_t subjectDataLength) | Activ::Subject |
Subject(const char *pSubject) | Activ::Subject |
Subject(const std::string &subject) | Activ::Subject |
SubjectLength typedef | Activ::Subject |
ToString() const | Activ::Subject |

Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::EqualToPairComparisonObject< Pair > Member List

This is the complete list of members for Activ::EqualToPairComparisonObject< Pair >, including all inherited members.

operator()(const Pair &lhs, const Pair &rhs) const | Activ::EqualToPairComparisonObject< Pair > | [inline]
operator()(const Pair &lhs, const typename Pair::first_type &rhs) const | Activ::EqualToPairComparisonObject< Pair > | [inline]
operator()(const typename Pair::first_type &lhs, const Pair &rhs) const | Activ::EqualToPairComparisonObject< Pair > | [inline]

Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Exception Member List

This is the complete list of members for Activ::Exception, including all inherited members.

AddException(Exception *pException) const | Activ::Exception |
Exception(const char *file, const char *function, const uint_fast32_t line, const uint_fast32_t errorCode=0) | Activ::Exception |
Exception(const Exception &rhs) | Activ::Exception |
m_errorCode | Activ::Exception |
m_file | Activ::Exception |
m_function | Activ::Exception |
m_line | Activ::Exception |
ToStream(std::ostream &os) const | Activ::Exception | [virtual]
ToString() const | Activ::Exception | [virtual]
~Exception() | Activ::Exception | [virtual]

Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Fiber Member List

This is the complete list of members for Activ::Fiber, including all inherited members.

defaultStackSize (defined in Activ::Fiber) | Activ::Fiber | [static]
Fiber(void *const pData=0, const size_t stackSize=defaultStackSize) | Activ::Fiber |
Process(void *const pData)=0 | Activ::Fiber | [protected, pure virtual]
Return() | Activ::Fiber |
Switch() | Activ::Fiber |
~Fiber() | Activ::Fiber | [virtual]

Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::FieldTypeFactory Member List

This is the complete list of members for Activ::FieldTypeFactory, including all inherited members.

Clone(const IFieldType *const pIFieldType) const | Activ::FieldTypeFactory |
Convert(const FieldType fieldType, const IFieldType *const pIFieldType) const | Activ::FieldTypeFactory |
Create(const FieldType fieldType) const | Activ::FieldTypeFactory |
GetInstance() | Activ::FieldTypeFactory | [static]
Singleton() | Activ::Singleton< T > | [inline, protected]
Singleton< FieldTypeFactory > (defined in Activ::FieldTypeFactory) | Activ::FieldTypeFactory | [friend]

Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::FieldTypeToClass< FIELD_TYPE_BINARY_ARRAY > Member List

This is the complete list of members for Activ::FieldTypeToClass< FIELD_TYPE_BINARY_ARRAY >, including all inherited members.

Type typedef (defined in Activ::FieldTypeToClass< FIELD_TYPE_BINARY_ARRAY >) Activ::FieldTypeToClass< FIELD_TYPE_BINARY_ARRAY >

Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::FieldTypeToClass< FIELD_TYPE_BINARY_STRING > Member List

This is the complete list of members for Activ::FieldTypeToClass< FIELD_TYPE_BINARY_STRING >, including all inherited members.

Type typedef (defined in Activ::FieldTypeToClass< FIELD_TYPE_BINARY_STRING >) Activ::FieldTypeToClass< FIELD_TYPE_BINARY_STRING >

Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::FieldTypeToClass< FIELD_TYPE_BLOB > Member List

This is the complete list of members for Activ::FieldTypeToClass< FIELD_TYPE_BLOB >, including all inherited members.

Type typedef (defined in Activ::FieldTypeToClass< FIELD_TYPE_BLOB >) Activ::FieldTypeToClass< FIELD_TYPE_BLOB >

Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::FieldTypeToClass< FIELD_TYPE_CRC_BLOB > Member List

This is the complete list of members for Activ::FieldTypeToClass< FIELD_TYPE_CRC_BLOB >, including all inherited members.

Type typedef (defined in Activ::FieldTypeToClass< FIELD_TYPE_CRC_BLOB >) Activ::FieldTypeToClass< FIELD_TYPE_CRC_BLOB >

Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::FieldTypeToClass< FIELD_TYPE_DATE > Member List

This is the complete list of members for Activ::FieldTypeToClass< FIELD_TYPE_DATE >, including all inherited members.

Type typedef (defined in Activ::FieldTypeToClass< FIELD_TYPE_DATE >) Activ::FieldTypeToClass< FIELD_TYPE_DATE >

Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::FieldTypeToClass< FIELD_TYPE_DATE_TIME > Member List

This is the complete list of members for Activ::FieldTypeToClass< FIELD_TYPE_DATE_TIME >, including all inherited members.

Type typedef (defined in Activ::FieldTypeToClass< FIELD_TYPE_DATE_TIME >) Activ::FieldTypeToClass< FIELD_TYPE_DATE_TIME >

Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::FieldTypeToClass< FIELD_TYPE_RATIONAL > Member List

This is the complete list of members for Activ::FieldTypeToClass< FIELD_TYPE_RATIONAL >, including all inherited members.

Type typedef (defined in Activ::FieldTypeToClass< FIELD_TYPE_RATIONAL >) Activ::FieldTypeToClass< FIELD_TYPE_RATIONAL >

Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::FieldTypeToClass< FIELD_TYPE_SINT > Member List

This is the complete list of members for Activ::FieldTypeToClass< FIELD_TYPE_SINT >, including all inherited members.

Type typedef (defined in Activ::FieldTypeToClass< FIELD_TYPE_SINT >) Activ::FieldTypeToClass< FIELD_TYPE_SINT >

Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::FieldTypeToClass< FIELD_TYPE_TEXT_ARRAY > Member List

This is the complete list of members for Activ::FieldTypeToClass< FIELD_TYPE_TEXT_ARRAY >, including all inherited members.

Type typedef (defined in Activ::FieldTypeToClass< FIELD_TYPE_TEXT_ARRAY >) Activ::FieldTypeToClass< FIELD_TYPE_TEXT_ARRAY >

Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::FieldTypeToClass< FIELD_TYPE_TEXT_STRING > Member List

This is the complete list of members for Activ::FieldTypeToClass< FIELD_TYPE_TEXT_STRING >, including all inherited members.

Type typedef (defined in Activ::FieldTypeToClass< FIELD_TYPE_TEXT_STRING >) Activ::FieldTypeToClass< FIELD_TYPE_TEXT_STRING >

Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::FieldTypeToClass< FIELD_TYPE_TIME > Member List

This is the complete list of members for Activ::FieldTypeToClass< FIELD_TYPE_TIME >, including all inherited members.

Type typedef (defined in Activ::FieldTypeToClass< FIELD_TYPE_TIME >) Activ::FieldTypeToClass< FIELD_TYPE_TIME >

Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::FieldTypeToClass< FIELD_TYPE_TRATIONAL > Member List

This is the complete list of members for Activ::FieldTypeToClass< FIELD_TYPE_TRATIONAL >, including all inherited members.

Type typedef (defined in Activ::FieldTypeToClass< FIELD_TYPE_TRATIONAL >) Activ::FieldTypeToClass< FIELD_TYPE_TRATIONAL >

Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::FieldTypeToClass< FIELD_TYPE_UINT > Member List

This is the complete list of members for Activ::FieldTypeToClass< FIELD_TYPE_UINT >, including all inherited members.

Type typedef (defined in Activ::FieldTypeToClass< FIELD_TYPE_UINT >) Activ::FieldTypeToClass< FIELD_TYPE_UINT >

Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::File Member List

This is the complete list of members for Activ::File, including all inherited members.

ACCESS_FLAG_READ | Activ::File | [static]
ACCESS_FLAG_WRITE | Activ::File | [static]
AccessFlags typedef | Activ::File |
Close() | Activ::File |
Copy(const std::string &sourceFileName, const std::string &targetFileName, bool replaceExisting=false) | Activ::File | [static]
Create(const std::string &fileName, const AccessFlags accessFlags, const ShareFlags shareFlags) | Activ::File |
ExpandPath(const std::string &path) | Activ::File | [static]
File() | Activ::File |
GetCreationDateTime(std::tm &tm) const | Activ::File |
GetCreationDateTime(const std::string &fileName, std::tm &tm) | Activ::File | [static]
GetDirectorySeparator() | Activ::File | [static]
GetEndOfLine() | Activ::File | [static]
GetFileName(std::string &fileName) const | Activ::File |
GetHandle() const | Activ::File | [inline]
GetLastAccessDateTime(std::tm &tm) const | Activ::File |
GetLastAccessDateTime(const std::string &fileName, std::tm &tm) | Activ::File | [static]
GetLastWriteDateTime(std::tm &tm) const | Activ::File |
GetLastWriteDateTime(const std::string &fileName, std::tm &tm) | Activ::File | [static]
GetPosition(int64_t &position) const | Activ::File |
GetSize(int64_t &size) const | Activ::File |
GetSize(const std::string &fileName, int64_t &size) | Activ::File | [static]
GetTemporaryPath() | Activ::File | [static]
IsDirectory(const std::string &pathName) | Activ::File | [static]
IsFileNameOnly(const std::string &pathName) | Activ::File | [static]
IsFound(const std::string &fileName) | Activ::File | [static]
IsOpen() const | Activ::File |
MakeAbsolutePath(const std::string &path) | Activ::File | [static]
MakePath(const std::string &directory, const std::string &fileName) | Activ::File | [static]
Open(const std::string &fileName, const AccessFlags accessFlags, const ShareFlags shareFlags) | Activ::File |
Read(void *pBuffer, const size_t nBytesToRead, size_t &nBytesRead) | Activ::File |
Read(void *pBuffer, const size_t nBytesToRead) | Activ::File |
ReadLine(std::string &line, std::string &endOfLine) | Activ::File |
Remove(const std::string &fileName) | Activ::File | [static]
Rename(const std::string &sourceFileName, const std::string &targetFileName, bool replaceExisting=false) | Activ::File | [static]
SearchPath(const std::string &fileName, std::string &fullyQualifiedFileName) | Activ::File | [static]
SEEK_METHOD_BEGIN enum value (defined in Activ::File) | Activ::File |
SEEK_METHOD_CURRENT enum value (defined in Activ::File) | Activ::File |
SEEK_METHOD_END enum value (defined in Activ::File) | Activ::File |
SeekMethod enum name | Activ::File |
SetPosition(int64_t position, const SeekMethod seekMethod=SEEK_METHOD_BEGIN) | Activ::File |
SetSize(int64_t size) | Activ::File |
SHARE_FLAG_READ | Activ::File | [static]
SHARE_FLAG_WRITE | Activ::File | [static]
ShareFlags typedef | Activ::File |
SplitPath(const std::string &path, std::string &directory, std::string &fileName) | Activ::File | [static]
Write(const void *pBuffer, const size_t nBytesToWrite, size_t &nBytesWritten) | Activ::File |
Write(const void *pBuffer, const size_t nBytesToWrite) | Activ::File |
~File() | Activ::File |

Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::FileInfo Member List

This is the complete list of members for Activ::FileInfo, including all inherited members.

FileInfo() | Activ::FileInfo | [inline]
IsNameGreater(const FileInfo &first, const FileInfo &second) | Activ::FileInfo | [inline, static]
IsSizeGreater(const FileInfo &first, const FileInfo &second) | Activ::FileInfo | [inline, static]
IsTimeGreater(const FileInfo &first, const FileInfo &second) | Activ::FileInfo | [inline, static]
IsTimeLess(const FileInfo &first, const FileInfo &second) | Activ::FileInfo | [inline, static]
m_directory | Activ::FileInfo |
m_fileTime | Activ::FileInfo |
m_name | Activ::FileInfo |
m_size | Activ::FileInfo |
operator!=(const FileInfo &fileInfo) const | Activ::FileInfo | [inline]
operator==(const FileInfo &fileInfo) const | Activ::FileInfo | [inline]

Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::FileMappedMemoryFactory Member List

This is the complete list of members for Activ::FileMappedMemoryFactory, including all inherited members.

Create(const std::string &fileName, const size_t size, const bool canShare, const IFileMappedMemory::FileFlags fileFlags=IFileMappedMemory::FILE_FLAG_NONE, const IMappedMemory::MappingFlags mappingFlags=IMappedMemory::MAPPING_FLAG_NONE) | Activ::FileMappedMemoryFactory |
GetInstance() | Activ::FileMappedMemoryFactory | [static]
Open(const std::string &fileName, const IFileMappedMemory::FileFlags fileFlags=IFileMappedMemory::FILE_FLAG_NONE, const IMappedMemory::MappingFlags mappingFlags=IMappedMemory::MAPPING_FLAG_NONE, Timeout &timeout=Timeout::GetInfinite()) | Activ::FileMappedMemoryFactory |
Singleton() | Activ::Singleton< T > | [inline, protected]
Singleton< FileMappedMemoryFactory > (defined in Activ::FileMappedMemoryFactory) | Activ::FileMappedMemoryFactory | [friend]

Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::FirstBitField< T, LENGTH_VALUE > Member List

This is the complete list of members for Activ::FirstBitField< T, LENGTH_VALUE >, including all inherited members.

Bitmap typedef (defined in Activ::BitField< T, 0, LENGTH_VALUE >) | Activ::BitField< T, 0, LENGTH_VALUE > |
BOOST_STATIC_ASSERT((OFFSET+LENGTH)<=(sizeof(Bitmap)*CHAR_BIT)) (defined in Activ::BitField< T, 0, LENGTH_VALUE >) | Activ::BitField< T, 0, LENGTH_VALUE > |
GetMaxValue() | Activ::BitField< T, 0, LENGTH_VALUE > | [static]
GetShifted(const Bitmap bitmap) | Activ::BitField< T, 0, LENGTH_VALUE > | [static]
GetUnshifted(const Bitmap bitmap) | Activ::BitField< T, 0, LENGTH_VALUE > | [static]
LENGTH (defined in Activ::BitField< T, 0, LENGTH_VALUE >) | Activ::BitField< T, 0, LENGTH_VALUE > | [static]
MASK (defined in Activ::BitField< T, 0, LENGTH_VALUE >) | Activ::BitField< T, 0, LENGTH_VALUE > | [static]
OFFSET (defined in Activ::BitField< T, 0, LENGTH_VALUE >) | Activ::BitField< T, 0, LENGTH_VALUE > | [static]
Set(Bitmap &bitmap, const Bitmap value) | Activ::BitField< T, 0, LENGTH_VALUE > | [static]

Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::FtpHelper Member List

This is the complete list of members for Activ::FtpHelper, including all inherited members.

Connect() | Activ::FtpHelper | [inline]
CURL_FTP enum value (defined in Activ::FtpHelper) | Activ::FtpHelper |
DeleteFile(const std::string &remoteFilename, const std::string &remoteDirectory="") | Activ::FtpHelper | [inline]
DeleteFile(const FileInfoList &fileInfoList, const std::string &remoteDirectory="") (defined in Activ::FtpHelper) | Activ::FtpHelper | [inline]
Disconnect() | Activ::FtpHelper | [inline]
FtpHelper(const std::string &server, const std::string &username="", const std::string &password="", uint32_t port=IFtpHelper::DEFAULT_FTP_PORT, FtpType ftpType=CURL_FTP) | Activ::FtpHelper | [inline]
FtpType enum name | Activ::FtpHelper |
GetAndDeleteFile(const std::string &remoteFilename, const std::string &localFilename, const std::string &remoteDirectory="") | Activ::FtpHelper | [inline]
GetFile(const std::string &remoteFilename, const std::string &localFilename, const std::string &remoteDirectory="") | Activ::FtpHelper | [inline]
GetFileList(FileInfoList &fileList, const std::string &remoteDirectory="") | Activ::FtpHelper | [inline]
IsConnected() const | Activ::FtpHelper | [inline]
m_pFtpHelper | Activ::FtpHelper | [protected]
WIN_FTP enum value (defined in Activ::FtpHelper) | Activ::FtpHelper |
~FtpHelper() | Activ::FtpHelper | [inline]

Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Greater< T, RHS > Member List

This is the complete list of members for Activ::Greater< T, RHS >, including all inherited members.

BOOST_STATIC_ASSERT(boost::is_integral< T >::value) (defined in Activ::Greater< T, RHS >) | Activ::Greater< T, RHS > |
operator()(const T lhs) const (defined in Activ::Greater< T, RHS >) | Activ::Greater< T, RHS > | [inline]

Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::HandleManager< T > Member List

This is the complete list of members for Activ::HandleManager< T >, including all inherited members.

HandleManager() | Activ::HandleManager< T > | [inline]
HandleManager(HANDLE *pHandles, const size_t numberOfHandles) | Activ::HandleManager< T > | [inline]
Initialize(HANDLE *pHandles, const size_t numberOfHandles) | Activ::HandleManager< T > | [inline]
Wait(const TimeoutPeriod timeoutPeriod) | Activ::HandleManager< T > | [inline]

Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::HeapMessage Member List

This is the complete list of members for Activ::HeapMessage, including all inherited members.

Append(const void *pData, const size_t dataLength) | Activ::HeapMessage |
Attach(HeapMessage &heapMessage) | Activ::HeapMessage |
Begin() const | Activ::HeapMessage | [inline]
Clone(const HeapMessage &sourceHeapMessage, IHeap *const pHeap=0) | Activ::HeapMessage |
Copy(const size_t offset, void *pData, const size_t dataLength) const | Activ::HeapMessage |
Copy(void *pData, const size_t dataSize, size_t &dataLength) const | Activ::HeapMessage |
Copy(const size_t offset, MessageBuilder &messageBuilder, const size_t dataLength) const | Activ::HeapMessage |
Copy(MessageBuilder &messageBuilder, size_t &dataLength) const | Activ::HeapMessage |
End() const | Activ::HeapMessage | [inline]
Erase(const size_t offset, const size_t dataLength) | Activ::HeapMessage |
Extend(const size_t size) | Activ::HeapMessage |
Get(const size_t offset, const void *&pData, const size_t dataLength, void *pGetBuffer=0) const | Activ::HeapMessage |
Get(const void *&pData, size_t &dataLength, void *pGetBuffer=0, const size_t getBufferSize=0) const | Activ::HeapMessage |
Get(const size_t offset, const void *&pData, const size_t dataLength, size_t &dataLengthRead) const | Activ::HeapMessage |
Get(const size_t offset, ScatterBufferHelper &scatterBufferHelper, const size_t dataLength) const | Activ::HeapMessage |
Get(ScatterBufferHelper &scatterBufferHelper, size_t &dataLength) const | Activ::HeapMessage |
GetCapacity() const | Activ::HeapMessage |
GetDestinationAddress() const | Activ::HeapMessage |
GetHeapId() const | Activ::HeapMessage |
GetIpAddress() const | Activ::HeapMessage |
GetLength() const | Activ::HeapMessage |
GetRequestId() const | Activ::HeapMessage |
GetReturnAddress() const | Activ::HeapMessage |
GetSourceAddress() const | Activ::HeapMessage |
GetStatusCode() const | Activ::HeapMessage |
GetSubject() const | Activ::HeapMessage |
GetType() const | Activ::HeapMessage |
HeapMessage() | Activ::HeapMessage | [inline]
HeapMessage(Proxy proxy) | Activ::HeapMessage | [inline]
HeapMessage(HeapMessage &rhs) | Activ::HeapMessage | [inline]
HeapMessageAccessor (defined in Activ::HeapMessage) | Activ::HeapMessage | [friend]
IncrementLength(size_t length) | Activ::HeapMessage |
Insert(const size_t offset, const void *pData, const size_t dataLength) | Activ::HeapMessage |
IsMessageAttached() const | Activ::HeapMessage | [inline]
operator bool() const | Activ::HeapMessage | [inline]
operator Proxy() | Activ::HeapMessage | [inline]
operator!() const | Activ::HeapMessage | [inline]
operator!=(const HeapMessage &rhs) const | Activ::HeapMessage | [inline]
operator=(Proxy proxy) | Activ::HeapMessage | [inline]
operator=(HeapMessage &rhs) | Activ::HeapMessage | [inline]
operator==(const HeapMessage &rhs) const | Activ::HeapMessage | [inline]
Overwrite(const size_t offset, const void *pData, const size_t dataLength) | Activ::HeapMessage |
PrivateHeap (defined in Activ::HeapMessage) | Activ::HeapMessage | [friend]
Release() | Activ::HeapMessage | [inline]
Return() | Activ::HeapMessage | [inline]
SetDestinationAddress(const Address &destinationAddress) | Activ::HeapMessage |
SetIpAddress(const IpAddress &ipAddress) | Activ::HeapMessage |
SetLength(size_t length) | Activ::HeapMessage |
SetRequestId(const RequestId requestId) | Activ::HeapMessage |
SetReturnAddress(const Address &returnAddress) | Activ::HeapMessage |
SetSourceAddress(const Address &sourceAddress) | Activ::HeapMessage |
SetStatusCode(const StatusCode statusCode) | Activ::HeapMessage |
SetSubject(const Subject &subject) | Activ::HeapMessage |
SetType(const MessageType type) | Activ::HeapMessage |
SharedHeap (defined in Activ::HeapMessage) | Activ::HeapMessage | [friend]
ToHexDumpString(const size_t bytesPerLine=16) const | Activ::HeapMessage |
~HeapMessage() | Activ::HeapMessage | [inline]

Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::HeapMessage::Iterator Member List

This is the complete list of members for Activ::HeapMessage::Iterator, including all inherited members.

HeapMessage (defined in Activ::HeapMessage::Iterator) | Activ::HeapMessage::Iterator | [friend]
Iterator() | Activ::HeapMessage::Iterator | [inline]
operator *() | Activ::HeapMessage::Iterator | [inline]
operator!=(const Iterator &rhs) const | Activ::HeapMessage::Iterator | [inline]
operator++() | Activ::HeapMessage::Iterator |
operator++(int) | Activ::HeapMessage::Iterator | [inline]
operator->() | Activ::HeapMessage::Iterator | [inline]
operator==(const Iterator &rhs) const | Activ::HeapMessage::Iterator | [inline]

Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::HeapMessage::ReadHelper Member List

This is the complete list of members for Activ::HeapMessage::ReadHelper, including all inherited members.

AdjustGetBufferSize(const size_t getBufferSize) const | Activ::HeapMessage::ReadHelper |
Copy(void *pData, const size_t dataLength) | Activ::HeapMessage::ReadHelper |
Copy(WriteHelper &writeHelper, const size_t dataLength) | Activ::HeapMessage::ReadHelper |
Copy(MessageBuilder &messageBuilder, const size_t dataLength) | Activ::HeapMessage::ReadHelper |
Get(const void *&pData, const size_t dataLength, void *pGetBuffer=0) | Activ::HeapMessage::ReadHelper |
Get(const void *&pData, const size_t dataLength, size_t &dataLengthRead) | Activ::HeapMessage::ReadHelper |
Get(ScatterBufferHelper &scatterBufferHelper, const size_t dataLength) | Activ::HeapMessage::ReadHelper |
GetLength() const | Activ::HeapMessage::ReadHelper | [inline]
GetOffset() const | Activ::HeapMessage::ReadHelper | [inline]
IncrementOffset(const size_t increment) | Activ::HeapMessage::ReadHelper |
Initialize(const HeapMessage &heapMessage) | Activ::HeapMessage::ReadHelper | [inline]
Initialize() | Activ::HeapMessage::ReadHelper | [inline]
operator=(const ReadHelper &rhs) | Activ::HeapMessage::ReadHelper | [inline]
ReadHelper() | Activ::HeapMessage::ReadHelper | [inline]
ReadHelper(const HeapMessage &heapMessage) | Activ::HeapMessage::ReadHelper | [inline]
ReadHelper(const ReadHelper &rhs) | Activ::HeapMessage::ReadHelper | [inline]
ReadHelper(const WriteHelper &rhs) | Activ::HeapMessage::ReadHelper | [inline]
SetOffset(const size_t offset) | Activ::HeapMessage::ReadHelper |
WriteHelper (defined in Activ::HeapMessage::ReadHelper) | Activ::HeapMessage::ReadHelper | [friend]
~ReadHelper() | Activ::HeapMessage::ReadHelper | [inline]

Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::HeapMessage::Stats Member List

This is the complete list of members for Activ::HeapMessage::Stats, including all inherited members.

m_bucketId (defined in Activ::HeapMessage::Stats) | Activ::HeapMessage::Stats
m_destinationAddress (defined in Activ::HeapMessage::Stats) | Activ::HeapMessage::Stats
m_freeSpace (defined in Activ::HeapMessage::Stats) | Activ::HeapMessage::Stats
m_heapId (defined in Activ::HeapMessage::Stats) | Activ::HeapMessage::Stats
m_hexDump | Activ::HeapMessage::Stats
m_ipAddress (defined in Activ::HeapMessage::Stats) | Activ::HeapMessage::Stats
m_messageId (defined in Activ::HeapMessage::Stats) | Activ::HeapMessage::Stats
m_requestId (defined in Activ::HeapMessage::Stats) | Activ::HeapMessage::Stats
m_returnAddress (defined in Activ::HeapMessage::Stats) | Activ::HeapMessage::Stats
m_sourceAddress (defined in Activ::HeapMessage::Stats) | Activ::HeapMessage::Stats
m_statusCode (defined in Activ::HeapMessage::Stats) | Activ::HeapMessage::Stats
m_subject (defined in Activ::HeapMessage::Stats) | Activ::HeapMessage::Stats
m_totalSpace (defined in Activ::HeapMessage::Stats) | Activ::HeapMessage::Stats
m_type (defined in Activ::HeapMessage::Stats) | Activ::HeapMessage::Stats

Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::HeapMessage::WriteHelper Member List

This is the complete list of members for Activ::HeapMessage::WriteHelper, including all inherited members.

Copy(const void *pData, const size_t dataLength) | Activ::HeapMessage::WriteHelper |
Copy(ReadHelper &readHelper, const size_t dataLength) | Activ::HeapMessage::WriteHelper |
Get(void *&pData, const size_t dataLength, size_t &dataLengthWritten) | Activ::HeapMessage::WriteHelper |
GetLength() const | Activ::HeapMessage::WriteHelper | [inline]
GetOffset() const | Activ::HeapMessage::WriteHelper | [inline]
IncrementOffset(const size_t increment, const bool updateLength=false) | Activ::HeapMessage::WriteHelper |
Initialize(HeapMessage &heapMessage) | Activ::HeapMessage::WriteHelper | [inline]
Initialize() | Activ::HeapMessage::WriteHelper | [inline]
ReadHelper (defined in Activ::HeapMessage::WriteHelper) | Activ::HeapMessage::WriteHelper | [friend]
SetOffset(const size_t offset, const bool updateLength=false) | Activ::HeapMessage::WriteHelper |
WriteHelper() | Activ::HeapMessage::WriteHelper | [inline]
WriteHelper(HeapMessage &heapMessage) | Activ::HeapMessage::WriteHelper | [inline]
WriteHelper(const ReadHelper &rhs) | Activ::HeapMessage::WriteHelper | [inline]

Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::HeapMessageBuilder Member List

This is the complete list of members for Activ::HeapMessageBuilder, including all inherited members.

GetHeapMessage(HeapMessage &heapMessage) | Activ::HeapMessageBuilder | [inline]
GetMessageBuilder() | Activ::HeapMessageBuilder | [inline]
HeapMessageBuilder(IHeap *const pHeap, const size_t approximateSize, const MessageBuilder::MessageVersion messageVersion=MessageBuilder::MESSAGE_VERSION_UNDEFINED) | Activ::HeapMessageBuilder | [inline]

Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::HeapMessageDeserializer< MESSAGE_TYPE, BUFFER_SIZE > Member List

This is the complete list of members for Activ::HeapMessageDeserializer< MESSAGE_TYPE, BUFFER_SIZE >, including all inherited members.

Deserialize(MESSAGE_TYPE &message) | Activ::HeapMessageDeserializer< MESSAGE_TYPE, BUFFER_SIZE > | [inline]
Initialize(const HeapMessage &heapMessage, const MessageHandler::MessageVersion messageVersion=MessageHandler::MESSAGE_VERSION_UNDEFINED) | Activ::HeapMessageDeserializer< MESSAGE_TYPE, BUFFER_SIZE > | [inline]
IsEndOfMessage() const | Activ::HeapMessageDeserializer< MESSAGE_TYPE, BUFFER_SIZE > | [inline]
operator()(const HeapMessage &heapMessage, MESSAGE_TYPE &message, const MessageHandler::MessageVersion messageVersion=MessageHandler::MESSAGE_VERSION_UNDEFINED) | Activ::HeapMessageDeserializer< MESSAGE_TYPE, BUFFER_SIZE > | [inline]

Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::HeapPool Member List

This is the complete list of members for Activ::HeapPool, including all inherited members.

Extend(const size_t numberOfHeaps) | Activ::HeapPool
Get() | Activ::HeapPool
GetMessage(const size_t dataLength, const void *const pData) | Activ::HeapPool
HeapPool(ISystem *const pSystem, const IHeap::BucketInfoVector &bucketInfoVector, const size_t initialSize, const std::string &namePrefix) | Activ::HeapPool
Return(IHeap *const pHeap) | Activ::HeapPool

Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::IEndPoint Member List

This is the complete list of members for Activ::IEndPoint, including all inherited members.

ACTIV_DECLARE_ELEMENT_1_WITH_COMMA enum value (defined in Activ::IEndPoint) | Activ::IEndPoint |
Clear()=0 | Activ::IEndPoint | [pure virtual]
ClearAllHighCounts()=0 | Activ::IEndPoint | [pure virtual]
ClearDailyHighCounts()=0 | Activ::IEndPoint | [pure virtual]
ClearLastHighCounts()=0 | Activ::IEndPoint | [pure virtual]
GetMessage(HeapMessage &heapMessage, const TimeoutPeriod timeout=ACTIV_WAIT_INFINITE)=0 | Activ::IEndPoint | [pure virtual]
GetMessages(IEndPoint *const pEndPoint, const TimeoutPeriod timeout=ACTIV_WAIT_INFINITE, size_t minBytesToRemove=0)=0 | Activ::IEndPoint | [pure virtual]
GetNotificationHandle(HANDLE &handle) const =0 | Activ::IEndPoint | [pure virtual]
GetState() const =0 | Activ::IEndPoint | [pure virtual]
GetStats(Stats &stats) const =0 | Activ::IEndPoint | [pure virtual]
GetSystem() const =0 | Activ::IEndPoint | [pure virtual]
NOTIFICATION_TYPE_MULTIPLEX enum value (defined in Activ::IEndPoint) | Activ::IEndPoint |
NotificationType enum name | Activ::IEndPoint |
NotificationTypeToString(const NotificationType notificationType) | Activ::IEndPoint | [static]
PostMessage(HeapMessage &heapMessage)=0 | Activ::IEndPoint | [pure virtual]
PostMessages(IEndPoint *const pEndPoint, size_t minBytesToRemove=0)=0 | Activ::IEndPoint | [pure virtual]
SetMaxByteCount(const size_t maxByteCount)=0 | Activ::IEndPoint | [pure virtual]
SetState(const State state)=0 | Activ::IEndPoint | [pure virtual]
State enum name | Activ::IEndPoint |
StateToString(const State state) | Activ::IEndPoint | [static]
StringToNotificationType(const std::string &str, NotificationType &notificationType) | Activ::IEndPoint | [static]
TryPostMessages(IEndPoint *const pEndPoint)=0 | Activ::IEndPoint | [pure virtual]
~IEndPoint()=0 | Activ::IEndPoint | [inline, pure virtual]

Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::IEndPoint::Stats Member List

This is the complete list of members for Activ::IEndPoint::Stats, including all inherited members.

Deserialize(MessageValidator &messageValidator) | Activ::IEndPoint::Stats
m_byteCount | Activ::IEndPoint::Stats
m_byteCountDailyHigh | Activ::IEndPoint::Stats
m_byteCountHigh | Activ::IEndPoint::Stats
m_byteCountLastHigh | Activ::IEndPoint::Stats
m_creatorProcessId | Activ::IEndPoint::Stats
m_hasMutex | Activ::IEndPoint::Stats
m_messageCount | Activ::IEndPoint::Stats
m_messageCountDailyHigh | Activ::IEndPoint::Stats
m_messageCountHigh | Activ::IEndPoint::Stats
m_messageCountLastHigh | Activ::IEndPoint::Stats
m_mutexContentionCount | Activ::IEndPoint::Stats
m_notificationType | Activ::IEndPoint::Stats
m_state (defined in Activ::IEndPoint::Stats) | Activ::IEndPoint::Stats
Serialize(MessageBuilder &messageBuilder) const | Activ::IEndPoint::Stats

Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::IEvent Member List

This is the complete list of members for Activ::IEvent, including all inherited members.

Clear()=0 | Activ::IEvent | [pure virtual]
FLAG_MANUAL | Activ::IEvent | [static]
FLAG_NONE (defined in Activ::IEvent) | Activ::IEvent | [static]
Flags typedef | Activ::IEvent |
GetHandle(HANDLE &handle) const =0 | Activ::IEvent | [pure virtual]
Set()=0 | Activ::IEvent | [pure virtual]
Wait(const TimeoutPeriod timeout=ACTIV_WAIT_INFINITE)=0 | Activ::IEvent | [pure virtual]
~IEvent()=0 | Activ::IEvent | [inline, pure virtual]

Generated on Wed Oct 8 14:01:56 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::IFieldType Member List

This is the complete list of members for Activ::IFieldType, including all inherited members.

Assign(const IFieldType *const pIFieldType) | Activ::IFieldType |
Clear()=0 | Activ::IFieldType | [pure virtual]
Compare(const void *const pRhsSerializedBody, const size_t rhsSerializedBodyLength, int &result) const =0 | Activ::IFieldType | [pure virtual]
Convert(const IFieldType *const pIFieldType)=0 | Activ::IFieldType | [pure virtual]
Deserialize(const FieldType fieldType, MessageValidator &messageValidator, const size_t maxSerializedBodyLength) | Activ::IFieldType |
Deserialize(MessageValidator &messageValidator, const size_t maxSerializedBodyLength)=0 | Activ::IFieldType | [pure virtual]
DeserializeBody(const FieldType fieldType, const void *const pSerializedBody, const size_t serializedBodyLength) | Activ::IFieldType |
DeserializeBody(const void *const pSerializedBody, const size_t serializedBodyLength)=0 | Activ::IFieldType | [pure virtual]
DeserializeLengthAndBody(const FieldType fieldType, MessageValidator &messageValidator, const size_t maxSerializedBodyLength=MAX_SERIALIZED_BODY_LENGTH_UNDEFINED) | Activ::IFieldType |
DeserializeLengthAndBody(MessageValidator &messageValidator, const size_t maxSerializedBodyLength=MAX_SERIALIZED_BODY_LENGTH_UNDEFINED)=0 | Activ::IFieldType | [pure virtual]
FromString(MessageValidator &messageValidator)=0 | Activ::IFieldType | [pure virtual]
FromString(const std::string &field) | Activ::IFieldType | [inline]
GetFromStringFormat() const =0 | Activ::IFieldType | [pure virtual]
GetSerializedBodyLength() const =0 | Activ::IFieldType | [pure virtual]
GetSerializedLength() const =0 | Activ::IFieldType | [pure virtual]
GetType() const | Activ::IFieldType | [inline]
IFieldType(const FieldType fieldType) | Activ::IFieldType | [inline, explicit, protected]
IsDifferent(const void *const pRhsSerializedBody, const size_t rhsSerializedBodyLength, bool &isDifferent) const =0 | Activ::IFieldType | [pure virtual]
IsInitialized() const | Activ::IFieldType | [inline]
IsValidSerializedBodyLength(const FieldType fieldType, const size_t serializedBodyLength) | Activ::IFieldType | [static]
m_isInitialized | Activ::IFieldType | [protected]
MAX_SERIALIZED_BODY_LENGTH_UNDEFINED | Activ::IFieldType | [static]
Reset()=0 | Activ::IFieldType | [pure virtual]
Serialize(const FieldType fieldType, MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength) const | Activ::IFieldType |
Serialize(MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength) const =0 | Activ::IFieldType | [pure virtual]
Serialize(const FieldType fieldType, MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength, const uint8_t *const pData, const size_t size) | Activ::IFieldType | [static]
SerializeBody(const FieldType fieldType, void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength) const | Activ::IFieldType |
SerializeBody(void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength) const =0 | Activ::IFieldType | [pure virtual]
SerializeBody(const FieldType fieldType, void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength, const uint8_t *const pData, const size_t size) | Activ::IFieldType | [static]
SerializeLengthAndBody(const FieldType fieldType, MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength=MAX_SERIALIZED_BODY_LENGTH_UNDEFINED) const | Activ::IFieldType |
SerializeLengthAndBody(MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength=MAX_SERIALIZED_BODY_LENGTH_UNDEFINED) const =0 | Activ::IFieldType | [pure virtual]
SerializeLengthAndBody(const FieldType fieldType, MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength, const uint8_t *const pData, const size_t size) | Activ::IFieldType | [static]
ToString() const =0 | Activ::IFieldType | [pure virtual]
ValidateSerializedLengthAndBody(const FieldType fieldType, MessageValidator &messageValidator, size_t &serializedBodyOffset, size_t &serializedBodyLength) | Activ::IFieldType | [static]
~IFieldType()=0 | Activ::IFieldType | [inline, pure virtual]

Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::IFileMappedMemory Member List

This is the complete list of members for Activ::IFileMappedMemory, including all inherited members.

FILE_FLAG_CREATE_ALWAYS | Activ::IFileMappedMemory | [static]
FILE_FLAG_DELETE_AT_CLOSE | Activ::IFileMappedMemory | [static]
FILE_FLAG_NONE (defined in Activ::IFileMappedMemory) | Activ::IFileMappedMemory | [static]
FILE_FLAG_OPEN_EXISTING | Activ::IFileMappedMemory | [static]
FILE_FLAG_READ_ONLY | Activ::IFileMappedMemory | [static]
FileFlags typedef (defined in Activ::IFileMappedMemory) | Activ::IFileMappedMemory |
Flush(const size_t nBytesToFlush=0) const =0 | Activ::IFileMappedMemory | [pure virtual]
GetPointer() const =0 | Activ::IMappedMemory | [pure virtual]
GetSize() const =0 | Activ::IMappedMemory | [pure virtual]
MAPPING_FLAG_NONE (defined in Activ::IMappedMemory) | Activ::IMappedMemory | [static]
MAPPING_FLAG_READ_ONLY | Activ::IMappedMemory | [static]
MAPPING_FLAG_UNIQUE | Activ::IMappedMemory | [static]
MappingFlags typedef (defined in Activ::IMappedMemory) | Activ::IMappedMemory |
Resize(const size_t size)=0 | Activ::IFileMappedMemory | [pure virtual]
USE_CURRENT_FILE_SIZE | Activ::IFileMappedMemory | [static]
~IFileMappedMemory()=0 | Activ::IFileMappedMemory | [inline, pure virtual]
~IMappedMemory()=0 | Activ::IMappedMemory | [inline, pure virtual]

Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::IFtpHelper Member List

This is the complete list of members for Activ::IFtpHelper, including all inherited members.

Connect()=0 | Activ::IFtpHelper | [pure virtual]
DEFAULT_FTP_LOW_SPEED_LIMIT | Activ::IFtpHelper | [static]
DEFAULT_FTP_LOW_SPEED_TIME | Activ::IFtpHelper | [static]
DEFAULT_FTP_PORT | Activ::IFtpHelper | [static]
DEFAULT_FTP_TIMEOUT | Activ::IFtpHelper | [static]
DeleteFile(const std::string &remoteFilename, const std::string &remoteDirectory="")=0 | Activ::IFtpHelper | [pure virtual]
DeleteFile(const FileInfoList &fileInfoList, const std::string &remoteDirectory="")=0 | Activ::IFtpHelper | [pure virtual]
Disconnect()=0 | Activ::IFtpHelper | [pure virtual]
GetAndDeleteFile(const std::string &remoteFilename, const std::string &localFilename, const std::string &remoteDirectory="")=0 | Activ::IFtpHelper | [pure virtual]
GetFile(const std::string &remoteFilename, const std::string &localFilename, const std::string &remoteDirectory="")=0 | Activ::IFtpHelper | [pure virtual]
GetFileList(FileInfoList &fileList, const std::string &remoteDirectory="")=0 | Activ::IFtpHelper | [pure virtual]
IFtpHelper(const std::string &server, const std::string &username="", const std::string &password="", uint32_t port=DEFAULT_FTP_PORT) | Activ::IFtpHelper | [inline]
IsConnected() const =0 | Activ::IFtpHelper | [pure virtual]
m_password | Activ::IFtpHelper | [protected]
m_port | Activ::IFtpHelper | [protected]
m_server | Activ::IFtpHelper | [protected]
m_username | Activ::IFtpHelper | [protected]
SetPassword(const std::string &password) (defined in Activ::IFtpHelper) | Activ::IFtpHelper | [inline]
SetPort(const uint32_t &port) (defined in Activ::IFtpHelper) | Activ::IFtpHelper | [inline]
SetServer(const std::string &server) (defined in Activ::IFtpHelper) | Activ::IFtpHelper | [inline]
SetUsername(const std::string &username) (defined in Activ::IFtpHelper) | Activ::IFtpHelper | [inline]
~IFtpHelper() | Activ::IFtpHelper | [inline, virtual]

Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::IHeap Member List

This is the complete list of members for Activ::IHeap, including all inherited members.

BucketInfoVector typedef | Activ::IHeap |
GetId() const =0 | Activ::IHeap | [pure virtual]
GetMessage(const size_t size)=0 | Activ::IHeap | [pure virtual]
GetMessage(const size_t size, const void *pData)=0 | Activ::IHeap | [pure virtual]
GetMessage(const size_t size, const void *pData, const TimeoutPeriod timeoutPeriod)=0 | Activ::IHeap | [pure virtual]
GetMessageFromList(const size_t size,...) | Activ::IHeap | [static]
GetName() const =0 | Activ::IHeap | [pure virtual]
GetRequestDistributionLogging() const =0 | Activ::IHeap | [pure virtual]
GetStats(Stats &stats) const =0 | Activ::IHeap | [pure virtual]
GetSystem() const =0 | Activ::IHeap | [pure virtual]
ReadBucketInfoVector(const IniFileParser::ConstSectionIterator &sectionIterator, IHeap::BucketInfoVector &bucketInfoVector) | Activ::IHeap | [static]
ResetStats()=0 | Activ::IHeap | [pure virtual]
SetRequestDistributionLogging(const bool shouldEnable)=0 | Activ::IHeap | [pure virtual]
~IHeap()=0 | Activ::IHeap | [inline, pure virtual]

Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::IHeap::BucketInfo Member List

This is the complete list of members for Activ::IHeap::BucketInfo, including all inherited members.

m_blockSize | Activ::IHeap::BucketInfo
m_numBlocks | Activ::IHeap::BucketInfo

Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::IHeap::Stats Member List

This is the complete list of members for Activ::IHeap::Stats, including all inherited members.

BucketStatsVector typedef (defined in Activ::IHeap::Stats) | Activ::IHeap::Stats
Deserialize(MessageValidator &messageValidator) | Activ::IHeap::Stats
DistributionVector typedef (defined in Activ::IHeap::Stats) | Activ::IHeap::Stats
m_bucketStatsVector | Activ::IHeap::Stats
m_creatorProcessId (defined in Activ::IHeap::Stats) | Activ::IHeap::Stats
m_distributionVector | Activ::IHeap::Stats
m_firstFailLocalDateTime | Activ::IHeap::Stats
m_id (defined in Activ::IHeap::Stats) | Activ::IHeap::Stats
m_idealBucketFails | Activ::IHeap::Stats
m_lastFailLocalDateTime | Activ::IHeap::Stats
m_maxRequestSize | Activ::IHeap::Stats
m_memoryUsage | Activ::IHeap::Stats
m_mutexContentionCount | Activ::IHeap::Stats
m_name (defined in Activ::IHeap::Stats) | Activ::IHeap::Stats
m_totalCurrentFreeBlocks | Activ::IHeap::Stats
m_totalFails | Activ::IHeap::Stats
m_totalLowFreeBlocks | Activ::IHeap::Stats
m_totalNumberOfBlocks (defined in Activ::IHeap::Stats) | Activ::IHeap::Stats
Serialize(MessageBuilder &messageBuilder) const | Activ::IHeap::Stats
Stats() (defined in Activ::IHeap::Stats) | Activ::IHeap::Stats

Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::IHeap::Stats::BucketStats Member List

This is the complete list of members for Activ::IHeap::Stats::BucketStats, including all inherited members.

BucketStats() | Activ::IHeap::Stats::BucketStats
Deserialize(MessageValidator &messageValidator) | Activ::IHeap::Stats::BucketStats
m_bucketInfo (defined in Activ::IHeap::Stats::BucketStats) | Activ::IHeap::Stats::BucketStats
m_firstRunFails | Activ::IHeap::Stats::BucketStats
m_lowFreeBlocks | Activ::IHeap::Stats::BucketStats
m_numFreeBlocks | Activ::IHeap::Stats::BucketStats
m_secondRunFails | Activ::IHeap::Stats::BucketStats
Serialize(MessageBuilder &messageBuilder) const | Activ::IHeap::Stats::BucketStats

Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::IHeap::Stats::RequestDistributionStats Member List

This is the complete list of members for Activ::IHeap::Stats::RequestDistributionStats, including all inherited members.

Deserialize(MessageValidator &messageValidator) | Activ::IHeap::Stats::RequestDistributionStats
m_count | Activ::IHeap::Stats::RequestDistributionStats
m_maxSize | Activ::IHeap::Stats::RequestDistributionStats
m_minSize | Activ::IHeap::Stats::RequestDistributionStats
Serialize(MessageBuilder &messageBuilder) const | Activ::IHeap::Stats::RequestDistributionStats

Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::IMappedMemory Member List

This is the complete list of members for Activ::IMappedMemory, including all inherited members.

GetPointer() const =0 | Activ::IMappedMemory | [pure virtual]
GetSize() const =0 | Activ::IMappedMemory | [pure virtual]
MAPPING_FLAG_NONE (defined in Activ::IMappedMemory) | Activ::IMappedMemory | [static]
MAPPING_FLAG_READ_ONLY | Activ::IMappedMemory | [static]
MAPPING_FLAG_UNIQUE | Activ::IMappedMemory | [static]
MappingFlags typedef (defined in Activ::IMappedMemory) | Activ::IMappedMemory |
~IMappedMemory()=0 | Activ::IMappedMemory | [inline, pure virtual]

Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::IMutex Member List

This is the complete list of members for Activ::IMutex, including all inherited members.

Acquire() const =0 | Activ::IMutex | [pure virtual]
GetContentionCount() const =0 | Activ::IMutex | [pure virtual]
Release() const =0 | Activ::IMutex | [pure virtual]
Try() const =0 | Activ::IMutex | [pure virtual]
~IMutex()=0 | Activ::IMutex | [inline, pure virtual]

Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::IProcess Member List

This is the complete list of members for Activ::IProcess, including all inherited members.

ACTIV_DECLARE_ELEMENT_1_WITH_COMMA enum value (defined in Activ::IProcess) | Activ::IProcess |
GetId() const =0 | Activ::IProcess | [pure virtual]
GetName() const =0 | Activ::IProcess | [pure virtual]
GetOsId() const =0 | Activ::IProcess | [pure virtual]
GetState() const =0 | Activ::IProcess | [pure virtual]
GetStats(Stats &stats) const =0 | Activ::IProcess | [pure virtual]
GetSystem() const =0 | Activ::IProcess | [pure virtual]
GetUuid() const =0 | Activ::IProcess | [pure virtual]
OsProcessId typedef (defined in Activ::IProcess) | Activ::IProcess |
SetState(const State state)=0 | Activ::IProcess | [pure virtual]
State enum name | Activ::IProcess |
StateToString(const State state) | Activ::IProcess | [static]
WaitForState(const State state, Timeout &timeout=Timeout::GetInfinite())=0 | Activ::IProcess | [pure virtual]
~IProcess()=0 | Activ::IProcess | [inline, pure virtual]

Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::IProcess::Stats Member List

This is the complete list of members for Activ::IProcess::Stats, including all inherited members.

Deserialize(MessageValidator &messageValidator) | Activ::IProcess::Stats
m_id | Activ::IProcess::Stats
m_name | Activ::IProcess::Stats
m_osId | Activ::IProcess::Stats
m_state | Activ::IProcess::Stats
m_version | Activ::IProcess::Stats
Serialize(MessageBuilder &messageBuilder) const | Activ::IProcess::Stats

Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ISemaphore Member List

This is the complete list of members for Activ::ISemaphore, including all inherited members.

Acquire(const TimeoutPeriod timeout=ACTIV_WAIT_INFINITE)=0 | Activ::ISemaphore | [pure virtual]
Release(const size_t count=1)=0 | Activ::ISemaphore | [pure virtual]
~ISemaphore()=0 | Activ::ISemaphore | [inline, pure virtual]

Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ISerializableMessage Member List

This is the complete list of members for Activ::ISerializableMessage, including all inherited members.

Deserialize(MessageValidator &messageValidator)=0 | Activ::ISerializableMessage | [pure virtual]
Serialize(MessageBuilder &messageBuilder) const =0 | Activ::ISerializableMessage | [pure virtual]
~ISerializableMessage()=0 | Activ::ISerializableMessage | [inline, pure virtual]

Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ISyncEndPoint Member List

This is the complete list of members for Activ::ISyncEndPoint, including all inherited members.

ACTIV_DECLARE_ELEMENT_1_WITH_COMMA enum value (defined in Activ::IEndPoint) | Activ::IEndPoint |
Clear()=0 | Activ::IEndPoint | [pure virtual]
ClearAllHighCounts()=0 | Activ::IEndPoint | [pure virtual]
ClearDailyHighCounts()=0 | Activ::IEndPoint | [pure virtual]
ClearLastHighCounts()=0 | Activ::IEndPoint | [pure virtual]
GetCreatorProcessId() const =0 | Activ::ISyncEndPoint | [pure virtual]
GetId() const =0 | Activ::ISyncEndPoint | [pure virtual]
GetMessage(HeapMessage &heapMessage, const TimeoutPeriod timeout=ACTIV_WAIT_INFINITE)=0 | Activ::IEndPoint | [pure virtual]
GetMessages(IEndPoint *const pEndPoint, const TimeoutPeriod timeout=ACTIV_WAIT_INFINITE, size_t minBytesToRemove=0)=0 | Activ::IEndPoint | [pure virtual]
GetName() const =0 | Activ::ISyncEndPoint | [pure virtual]
GetNotificationHandle(HANDLE &handle) const =0 | Activ::IEndPoint | [pure virtual]
GetState() const =0 | Activ::IEndPoint | [pure virtual]
GetStats(Stats &stats) const =0 | Activ::ISyncEndPoint | [pure virtual]
GetSystem() const =0 | Activ::IEndPoint | [pure virtual]
NOTIFICATION_TYPE_MULTIPLEX enum value (defined in Activ::IEndPoint) | Activ::IEndPoint |
NotificationType enum name | Activ::IEndPoint |
NotificationTypeToString(const NotificationType notificationType) | Activ::IEndPoint | [static]
PostMessage(HeapMessage &heapMessage)=0 | Activ::IEndPoint | [pure virtual]
PostMessages(IEndPoint *const pEndPoint, size_t minBytesToRemove=0)=0 | Activ::IEndPoint | [pure virtual]
SendMessage(HeapMessage &heapMessage, const TimeoutPeriod timeout=ACTIV_WAIT_INFINITE)=0 | Activ::ISyncEndPoint | [pure virtual]
SendMessage(HeapMessage &heapMessage, SyncRequestId &syncRequestId)=0 | Activ::ISyncEndPoint | [pure virtual]
SetMaxByteCount(const size_t maxByteCount)=0 | Activ::IEndPoint | [pure virtual]
SetState(const State state)=0 | Activ::IEndPoint | [pure virtual]
State enum name | Activ::IEndPoint |
StateToString(const State state) | Activ::IEndPoint | [static]
StringToNotificationType(const std::string &str, NotificationType &notificationType) | Activ::IEndPoint | [static]
TryPostMessages(IEndPoint *const pEndPoint)=0 | Activ::IEndPoint | [pure virtual]
~IEndPoint()=0 | Activ::IEndPoint | [inline, pure virtual]

Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ISyncEndPoint::Stats Member List

This is the complete list of members for Activ::ISyncEndPoint::Stats, including all inherited members.

Deserialize(MessageValidator &messageValidator) | Activ::ISyncEndPoint::Stats
m_byteCount | Activ::IEndPoint::Stats
m_byteCountDailyHigh | Activ::IEndPoint::Stats
m_byteCountHigh | Activ::IEndPoint::Stats
m_byteCountLastHigh | Activ::IEndPoint::Stats
m_creatorProcessId | Activ::IEndPoint::Stats
m_hasMutex | Activ::IEndPoint::Stats
m_id (defined in Activ::ISyncEndPoint::Stats) | Activ::ISyncEndPoint::Stats
m_messageCount | Activ::IEndPoint::Stats
m_messageCountDailyHigh | Activ::IEndPoint::Stats
m_messageCountHigh | Activ::IEndPoint::Stats
m_messageCountLastHigh | Activ::IEndPoint::Stats
m_mutexContentionCount | Activ::IEndPoint::Stats
m_name (defined in Activ::ISyncEndPoint::Stats) | Activ::ISyncEndPoint::Stats
m_notificationType | Activ::IEndPoint::Stats
m_state (defined in Activ::IEndPoint::Stats) | Activ::IEndPoint::Stats
Serialize(MessageBuilder &messageBuilder) const | Activ::ISyncEndPoint::Stats

Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ISystem Member List

This is the complete list of members for Activ::ISystem, including all inherited members.

CreateEndPoint(const std::string &name, const bool hasMutex, const IEndPoint::NotificationType notificationType)=0 | Activ::ISystem | [pure virtual]
CreateHeap(const std::string &name, const IHeap::BucketInfoVector &bucketInfoVector)=0 | Activ::ISystem | [pure virtual]
CreatePrivateEndPoint(const bool hasMutex, const IEndPoint::NotificationType notificationType)=0 | Activ::ISystem | [pure virtual]
EnumerateObjects(IProcessEnumerator &enumerator)=0 | Activ::ISystem | [pure virtual]
EnumerateObjects(IEndPointEnumerator &enumerator)=0 | Activ::ISystem | [pure virtual]
EnumerateObjects(IHeapEnumerator &enumerator)=0 | Activ::ISystem | [pure virtual]
GetProcess() const =0 | Activ::ISystem | [pure virtual]
GetSystemHeap() const =0 | Activ::ISystem | [pure virtual]
GetSystemInfo() const =0 | Activ::ISystem | [pure virtual]
GetSystemName() const =0 | Activ::ISystem | [pure virtual]
OpenEndPoint(const std::string &name, Timeout &timeout=Timeout::GetInfinite())=0 | Activ::ISystem | [pure virtual]
OpenEndPoint(EndPointId endPointId, Timeout &timeout=Timeout::GetInfinite())=0 | Activ::ISystem | [pure virtual]
OpenHeap(const std::string &name, Timeout &timeout=Timeout::GetInfinite())=0 | Activ::ISystem | [pure virtual]
OpenHeap(const HeapId heapId, Timeout &timeout=Timeout::GetInfinite())=0 | Activ::ISystem | [pure virtual]
OpenProcess(const std::string &name, Timeout &timeout=Timeout::GetInfinite())=0 | Activ::ISystem | [pure virtual]
OpenProcess(const ProcessId processId, Timeout &timeout=Timeout::GetInfinite())=0 | Activ::ISystem | [pure virtual]
~ISystem()=0 | Activ::ISystem | [inline, pure virtual]

Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ISystem::IEndPointEnumerator Member List

This is the complete list of members for Activ::ISystem::IEndPointEnumerator, including all inherited members.

OnObject(ISyncEndPoint *const pEndPoint)=0 | Activ::ISystem::IEndPointEnumerator | [pure virtual]
~IEndPointEnumerator()=0 | Activ::ISystem::IEndPointEnumerator | [inline, pure virtual]

Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ISystem::IHeapEnumerator Member List

This is the complete list of members for Activ::ISystem::IHeapEnumerator, including all inherited members.

OnObject(IHeap *const pHeap)=0 | Activ::ISystem::IHeapEnumerator | [pure virtual]
~IHeapEnumerator()=0 | Activ::ISystem::IHeapEnumerator | [inline, pure virtual]

Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ISystem::IProcessEnumerator Member List

This is the complete list of members for Activ::ISystem::IProcessEnumerator, including all inherited members.

OnObject(IProcess *const pProcess)=0 | Activ::ISystem::IProcessEnumerator | [pure virtual]
~IProcessEnumerator()=0 | Activ::ISystem::IProcessEnumerator | [inline, pure virtual]

Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ISystem::Settings Member List

This is the complete list of members for Activ::ISystem::Settings, including all inherited members.

m_memoryModel | Activ::ISystem::Settings |
m_minimumTimerResolution | Activ::ISystem::Settings |
m_processorAffinityList | Activ::ISystem::Settings |
m_processVersion | Activ::ISystem::Settings |
m_setConsoleTitle | Activ::ISystem::Settings |
m_smallBlockHeapThreshold | Activ::ISystem::Settings |
m_systemLogMode | Activ::ISystem::Settings |
m_systemName | Activ::ISystem::Settings |
MEMORY_MODEL_PRIVATE enum value | Activ::ISystem::Settings |
MEMORY_MODEL_SHARED enum value | Activ::ISystem::Settings |
MemoryModel enum name | Activ::ISystem::Settings |
Read(const IniFileParser::ConstSectionIterator &sectionIterator) | Activ::ISystem::Settings |
sectionName | Activ::ISystem::Settings | [protected, static]
Settings() | Activ::ISystem::Settings |
SYSTEM_LOG_MODE_OFF enum value | Activ::ISystem::Settings |
SYSTEM_LOG_MODE_TO_AGENT enum value | Activ::ISystem::Settings |
SYSTEM_LOG_MODE_TO_CONSOLE enum value | Activ::ISystem::Settings |
SystemLogMode enum name | Activ::ISystem::Settings |

Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ISystem::SystemInfo Member List

This is the complete list of members for Activ::ISystem::SystemInfo, including all inherited members.

Deserialize(MessageValidator &messageValidator) | Activ::ISystem::SystemInfo
m_boostVersion | Activ::SystemInfo
m_computerName | Activ::SystemInfo
m_freeMemory | Activ::SystemInfo
m_memoryModel | Activ::ISystem::SystemInfo
m_middlewareDate | Activ::SystemInfo
m_middlewareVersion | Activ::SystemInfo
m_middlewareVersionValue | Activ::SystemInfo
m_numberOfProcessorCores | Activ::SystemInfo
m_numberOfProcessorPackages | Activ::SystemInfo
m_numberOfProcessorThreads | Activ::SystemInfo
m_osName | Activ::SystemInfo
m_physicalMemory | Activ::SystemInfo
m_platformType | Activ::SystemInfo
m_processorInfoList | Activ::SystemInfo
m_schedulerInfo | Activ::SystemInfo
m_systemName | Activ::ISystem::SystemInfo
m_systemVersion | Activ::ISystem::SystemInfo
m_upTimeSeconds | Activ::ISystem::SystemInfo
m_utcStartupDateTime | Activ::ISystem::SystemInfo
m_windowsDpcProcessorAffinityMask | Activ::SystemInfo
Populate() | Activ::SystemInfo
ProcessorInfoList typedef (defined in Activ::SystemInfo) | Activ::SystemInfo
Serialize(MessageBuilder &messageBuilder) const | Activ::ISystem::SystemInfo
Serialize(MessageBuilder &messageBuilder, const SystemInfo &systemInfo) const | Activ::ISystem::SystemInfo
Activ::SystemInfo::Serialize(MessageBuilder &messageBuilder, const SystemInfo &systemInfo) const | Activ::SystemInfo
SystemInfo() | Activ::ISystem::SystemInfo

Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::IniFileParser Member List

This is the complete list of members for Activ::IniFileParser, including all inherited members.

BeginSection() const | Activ::IniFileParser |
Deserialize(MessageValidator &messageValidator) | Activ::IniFileParser |
EndSection() const | Activ::IniFileParser |
FindSection(const std::string &sectionName, const size_t matchLength=MATCH_LENGTH_COMPLETE) const | Activ::IniFileParser |
GetBooleanValue(const std::string &sectionName, const std::string &keyName, bool &value) const | Activ::IniFileParser |
GetRealValue(const std::string &sectionName, const std::string &keyName, double &value) const | Activ::IniFileParser |
GetRealValueList(const std::string &sectionName, const std::string &keyName, std::vector< double > &valueList, const std::string &delimiterList=std::string(",")) const | Activ::IniFileParser |
GetSectionName(const size_t count,...) | Activ::IniFileParser | [static]
GetSignedValue(const std::string &sectionName, const std::string &keyName, T &value) const | Activ::IniFileParser | [inline]
GetSignedValueList(const std::string &sectionName, const std::string &keyName, std::vector< T > &valueList, const std::string &delimiterList=std::string(",")) const | Activ::IniFileParser | [inline]
GetStringValue(const std::string &sectionName, const std::string &keyName, std::string &value) const | Activ::IniFileParser |
GetStringValueList(const std::string &sectionName, const std::string &keyName, std::vector< std::string > &valueList, const std::string &delimiterList=std::string(",")) const | Activ::IniFileParser |
GetUnsignedValue(const std::string &sectionName, const std::string &keyName, T &value) const | Activ::IniFileParser | [inline]
GetUnsignedValueList(const std::string &sectionName, const std::string &keyName, std::vector< T > &valueList, const std::string &delimiterList=std::string(",")) const | Activ::IniFileParser | [inline]
IniFileParser() | Activ::IniFileParser |
IniFileParser(const std::string &iniFileName) | Activ::IniFileParser |
IniFileParser(const byte_t *const pBuffer, const size_t bufferLength) | Activ::IniFileParser |
MATCH_LENGTH_COMPLETE (defined in Activ::IniFileParser) | Activ::IniFileParser | [static]
SECTION_DELIMITER | Activ::IniFileParser | [static]
Serialize(MessageBuilder &messageBuilder) const | Activ::IniFileParser |
~IniFileParser() | Activ::IniFileParser |

Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::IniFileParser::ConstKeyIterator Member List

This is the complete list of members for Activ::IniFileParser::ConstKeyIterator, including all inherited members.

ConstSectionIterator class | Activ::IniFileParser::ConstKeyIterator | [friend]
GetBooleanValue(bool &value) const | Activ::IniFileParser::ConstKeyIterator |
GetName() const | Activ::IniFileParser::ConstKeyIterator |
GetRealValue(double &value) const | Activ::IniFileParser::ConstKeyIterator |
GetRealValueList(std::vector< double > &valueList, const std::string &delimiterList=std::string(",")) const | Activ::IniFileParser::ConstKeyIterator |
GetSignedValue(T &value) const | Activ::IniFileParser::ConstKeyIterator | [inline]
GetSignedValueList(std::vector< T > &valueList, const std::string &delimiterList=std::string(",")) const | Activ::IniFileParser::ConstKeyIterator | [inline]
GetStringValue(std::string &value) const | Activ::IniFileParser::ConstKeyIterator |
GetStringValueList(std::vector< std::string > &valueList, const std::string &delimiterList=std::string(",")) const | Activ::IniFileParser::ConstKeyIterator |
GetUnsignedValue(T &value) const | Activ::IniFileParser::ConstKeyIterator | [inline]
GetUnsignedValueList(std::vector< T > &valueList, const std::string &delimiterList=std::string(",")) const | Activ::IniFileParser::ConstKeyIterator | [inline]
operator!=(const ConstKeyIterator &rhs) const | Activ::IniFileParser::ConstKeyIterator |
operator++() | Activ::IniFileParser::ConstKeyIterator |
operator==(const ConstKeyIterator &rhs) const | Activ::IniFileParser::ConstKeyIterator |

Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::IniFileParser::ConstSectionIterator Member List

This is the complete list of members for Activ::IniFileParser::ConstSectionIterator, including all inherited members.

BeginKey() const | Activ::IniFileParser::ConstSectionIterator |
BeginSubSection() const | Activ::IniFileParser::ConstSectionIterator |
EndKey() const | Activ::IniFileParser::ConstSectionIterator |
EndSection() const | Activ::IniFileParser::ConstSectionIterator |
EndSubSection() const | Activ::IniFileParser::ConstSectionIterator |
FindKey(const std::string &keyName, const size_t matchLength=MATCH_LENGTH_COMPLETE) const | Activ::IniFileParser::ConstSectionIterator |
FindSubSection(const std::string &subSectionName, const size_t matchLength=MATCH_LENGTH_COMPLETE) const | Activ::IniFileParser::ConstSectionIterator |
GetBooleanValue(const std::string &keyName, bool &value) const | Activ::IniFileParser::ConstSectionIterator |
GetName() const | Activ::IniFileParser::ConstSectionIterator |
GetRealValue(const std::string &keyName, double &value) const | Activ::IniFileParser::ConstSectionIterator |
GetRealValueList(const std::string &keyName, std::vector< double > &valueList, const std::string &delimiterList=std::string(",")) const | Activ::IniFileParser::ConstSectionIterator |
GetSignedValue(const std::string &keyName, T &value) const | Activ::IniFileParser::ConstSectionIterator | [inline]
GetSignedValueList(const std::string &keyName, std::vector< T > &valueList, const std::string &delimiterList=std::string(",")) const | Activ::IniFileParser::ConstSectionIterator | [inline]
GetStringValue(const std::string &keyName, std::string &value) const | Activ::IniFileParser::ConstSectionIterator |
GetStringValueList(const std::string &keyName, std::vector< std::string > &valueList, const std::string &delimiterList=std::string(",")) const | Activ::IniFileParser::ConstSectionIterator |
GetSubName() const | Activ::IniFileParser::ConstSectionIterator |
GetUnsignedValue(const std::string &keyName, T &value) const | Activ::IniFileParser::ConstSectionIterator | [inline]
GetUnsignedValueList(const std::string &keyName, std::vector< T > &valueList, const std::string &delimiterList=std::string(",")) const | Activ::IniFileParser::ConstSectionIterator | [inline]
IniFileParser class | Activ::IniFileParser::ConstSectionIterator | [friend]
operator!=(const ConstSectionIterator &rhs) const | Activ::IniFileParser::ConstSectionIterator |
operator++() | Activ::IniFileParser::ConstSectionIterator |
operator==(const ConstSectionIterator &rhs) const | Activ::IniFileParser::ConstSectionIterator |

Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::IniFileParser::ParseException Member List

This is the complete list of members for Activ::IniFileParser::ParseException, including all inherited members.

AddException(Exception *pException) const | Activ::Exception |
Exception(const char *file, const char *function, const uint_fast32_t line, const uint_fast32_t errorCode=0) | Activ::Exception |
Exception(const Exception &rhs) | Activ::Exception |
m_errorCode | Activ::Exception |
m_file | Activ::Exception |
m_function | Activ::Exception |
m_line | Activ::Exception |
m_offset | Activ::IniFileParser::ParseException |
m_validPart | Activ::IniFileParser::ParseException |
ParseException(const char *file, const char *function, const uint_fast32_t line, const size_t offset, const std::string &validPart) | Activ::IniFileParser::ParseException |
ToStream(std::ostream &os) const | Activ::Exception | [virtual]
ToString() const | Activ::IniFileParser::ParseException | [virtual]
~Exception() | Activ::Exception | [virtual]

Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::IntervalTimer Member List

This is the complete list of members for Activ::IntervalTimer, including all inherited members.

GetFrequency() const | Activ::IntervalTimer | [inline]
GetTickCount() | Activ::IntervalTimer | [static]
GetTimeStamp() | Activ::IntervalTimer | [static]
IntervalTimer() | Activ::IntervalTimer |
ScaleTimeStamp(const uint64_t time) const | Activ::IntervalTimer | [inline]

Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::IntervalTimer::Scoped Member List

This is the complete list of members for Activ::IntervalTimer::Scoped, including all inherited members.

Scoped(IntervalTimer &intervalTimer, double &time) | Activ::IntervalTimer::Scoped | [inline]
~Scoped() | Activ::IntervalTimer::Scoped | [inline]

Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::IoCompletionManager Member List

This is the complete list of members for Activ::IoCompletionManager, including all inherited members.

AttachHandle(const HANDLE handle) const | Activ::IoCompletionManager
IoCompletionManager(const size_t numberOfIoThreads=0) | Activ::IoCompletionManager
~IoCompletionManager() | Activ::IoCompletionManager

Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::IoCompletionManager::Overlapped Member List

This is the complete list of members for Activ::IoCompletionManager::Overlapped, including all inherited members.

GetNumberOfBytes() const | Activ::IoCompletionManager::Overlapped | [inline]
IoCompletionManager class | Activ::IoCompletionManager::Overlapped | [friend]
IsPending() const | Activ::IoCompletionManager::Overlapped | [inline]
OnIoCompletion()=0 | Activ::IoCompletionManager::Overlapped | [protected, pure virtual]
Overlapped(IoCompletionManager &ioCompletionManager, IMutex *const pMutex) | Activ::IoCompletionManager::Overlapped | [inline]
PostIoCompletion(DWORD numberOfBytes) | Activ::IoCompletionManager::Overlapped | [inline]
SetPending(const bool isPending) | Activ::IoCompletionManager::Overlapped | [inline]
WasSuccessfulCompletion() const | Activ::IoCompletionManager::Overlapped | [inline]

Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::IpAddress Member List

This is the complete list of members for Activ::IpAddress, including all inherited members.

Address (defined in Activ::IpAddress) | Activ::IpAddress |
AddressIn (defined in Activ::IpAddress) | Activ::IpAddress |
AddressIn6 (defined in Activ::IpAddress) | Activ::IpAddress |
Compare(const IpAddress &rhs) const | Activ::IpAddress | [inline]
Deserialize(MessageValidator &messageValidator) | Activ::IpAddress |
GetInterfaceIndex() const | Activ::IpAddress |
GetPort() const | Activ::IpAddress |
IpAddress(const int family=AF_UNSPEC) | Activ::IpAddress | [inline]
IpAddress(const int socketType, const int protocol, const int family=AF_UNSPEC) | Activ::IpAddress | [inline]
IsLoopback() const | Activ::IpAddress |
IsMulticast() const | Activ::IpAddress |
IsUnspecified() const | Activ::IpAddress |
m_address (defined in Activ::IpAddress) | Activ::IpAddress |
m_addressLength | Activ::IpAddress |
m_protocol | Activ::IpAddress |
m_type | Activ::IpAddress |
operator!=(const IpAddress &rhs) const | Activ::IpAddress | [inline]
operator<(const IpAddress &rhs) const | Activ::IpAddress | [inline]
operator==(const IpAddress &rhs) const | Activ::IpAddress | [inline]
Serialize(MessageBuilder &messageBuilder) const | Activ::IpAddress |
ToString(const bool shouldShowPort=true) const | Activ::IpAddress |

Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::IpException Member List

This is the complete list of members for Activ::IpException, including all inherited members.

ACTIV_DECLARE_ELEMENT_1_WITH_COMMA enum value (defined in Activ::IpException) | Activ::IpException |
AddException(Exception *pException) const | Activ::Exception |
Exception(const char *file, const char *function, const uint_fast32_t line, const uint_fast32_t errorCode=0) | Activ::Exception |
Exception(const Exception &rhs) | Activ::Exception |
IpException(const char *file, const char *function, const uint_fast32_t line, const uint_fast32_t errorCode) | Activ::IpException |
m_errorCode | Activ::Exception |
m_file | Activ::Exception |
m_function | Activ::Exception |
m_line | Activ::Exception |
ToStream(std::ostream &os) const | Activ::Exception | [virtual]
ToString() const | Activ::IpException | [virtual]
~Exception() | Activ::Exception | [virtual]

Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::IpManager Member List

This is the complete list of members for Activ::IpManager, including all inherited members.

AttachHandle(const HANDLE handle) const | Activ::IoCompletionManager |
CreateNonInheritableSocket(const IpAddress &ipAddress, SocketWrapper &socketWrapper) | Activ::IpManager | [static]
GetExtensionFunction(const SOCKET socket, void *fnStorage, const DWORD fnStorageSize, void *fnGuid, const DWORD fnGuidSize) | Activ::IpManager | [static]
GetHostAndPort(const std::string &hostAndPort, std::string &host, uint16_t &portNumber) | Activ::IpManager | [static]
GetHostName() | Activ::IpManager | [static]
GetHostsFileEntries(std::vector< std::string > &result) | Activ::IpManager | [static]
GetInterfaceInfoList(const int family, InterfaceInfoList &interfaceInfoList) | Activ::IpManager | [static]
GetIpAddress(const std::string &nodeName, const uint16_t portNumber, IpAddress &ipAddress, const int flags=0) | Activ::IpManager | [static]
GetLocalIpAddressList(const std::string &localAddress, const uint16_t portNumber, IpAddressList &ipAddressList) | Activ::IpManager | [static]
GetSettings() const | Activ::IpManager | [inline]
InterfaceInfoList typedef | Activ::IpManager |
IoCompletionManager(const size_t numberOfIoThreads=0) | Activ::IoCompletionManager |
IpManager(const Settings &settings) | Activ::IpManager |
~IoCompletionManager() | Activ::IoCompletionManager |
~IpManager() | Activ::IpManager |

Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::IpManager::InterfaceInfo Member List

This is the complete list of members for Activ::IpManager::InterfaceInfo, including all inherited members.

InterfaceInfo() | Activ::IpManager::InterfaceInfo
m_bitsPerSecond | Activ::IpManager::InterfaceInfo
m_description (defined in Activ::IpManager::InterfaceInfo) | Activ::IpManager::InterfaceInfo
m_ipAddressList | Activ::IpManager::InterfaceInfo
m_macAddress (defined in Activ::IpManager::InterfaceInfo) | Activ::IpManager::InterfaceInfo
m_mtu (defined in Activ::IpManager::InterfaceInfo) | Activ::IpManager::InterfaceInfo
m_name (defined in Activ::IpManager::InterfaceInfo) | Activ::IpManager::InterfaceInfo

Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::IpManager::Settings Member List

This is the complete list of members for Activ::IpManager::Settings, including all inherited members.

m_enableWindowsOverlappedOperations | Activ::IpManager::Settings
m_numberOfIoThreads | Activ::IpManager::Settings
Read(const IniFileParser::ConstSectionIterator &sectionIterator) | Activ::IpManager::Settings
Settings() | Activ::IpManager::Settings

Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::IpSocket Member List

This is the complete list of members for Activ::IpSocket, including all inherited members.

AppendRxBuffer(void *pData, const size_t dataLength) | Activ::IpSocket | [inline]
AppendTxBuffer(const void *pData, const size_t dataLength) | Activ::IpSocket | [inline]
CleanupIo() | Activ::IpSocket | [protected]
CloseSocket() | Activ::IpSocket | [protected]
COMPLETION_RESULT_CLOSE_SOCKET enum value | Activ::IpSocket |
COMPLETION_RESULT_OK enum value | Activ::IpSocket |
CompletionResult enum name | Activ::IpSocket |
GET_BUFFERS_RESULT_CLOSE_SOCKET enum value | Activ::IpSocket |
GET_BUFFERS_RESULT_NO_MORE_BUFFERS enum value | Activ::IpSocket |
GetBuffersResult enum name | Activ::IpSocket |
GetLocalAddress(IpAddress &ipAddress) const | Activ::IpSocket |
GetRemoteAddress(IpAddress &ipAddress) const | Activ::IpSocket |
GetSocketHandle() const | Activ::IpSocket |
GetSocketOption(const int optionName, char *pOptionValue, socklen_t *pOptionLength, const int level=SOL_SOCKET) | Activ::IpSocket |
HandleIoFailure(const bool gracefully)=0 | Activ::IpSocket | [protected, pure virtual]
IpManager class | Activ::IpSocket | [friend]
IpSocket(IpManager &ipManager, const Settings &settings) | Activ::IpSocket |
LockedRead() | Activ::IpSocket | [inline]
LockedWrite() | Activ::IpSocket | [inline]
m_closeOnTxCompletion | Activ::IpSocket | [protected]
m_closePosted | Activ::IpSocket | [protected]
m_fromAddress | Activ::IpSocket | [protected]
m_handle | Activ::IpSocket | [protected]
m_ipManager | Activ::IpSocket | [protected]
m_localAddress | Activ::IpSocket | [protected]
m_pMutex | Activ::IpSocket | [protected]
m_remoteAddress | Activ::IpSocket | [protected]
m_rxBuffers | Activ::IpSocket | [protected]
m_rxBytes | Activ::IpSocket | [protected]
m_rxFlags | Activ::IpSocket | [protected]
m_rxOverlapped | Activ::IpSocket | [protected]
m_toAddress | Activ::IpSocket | [protected]
m_txBuffers | Activ::IpSocket | [protected]
m_txBytes | Activ::IpSocket | [protected]
m_txFlags | Activ::IpSocket | [protected]
m_txOverlapped | Activ::IpSocket | [protected]
OnCleanupIo() | Activ::IpSocket | [protected, virtual]
OnGetRxBuffers() | Activ::IpSocket | [protected, virtual]
OnGetTxBuffers() | Activ::IpSocket | [protected, virtual]
OnInitializeIo() | Activ::IpSocket | [protected, virtual]
OnRxBuffers(const size_t dataLength) | Activ::IpSocket | [protected, virtual]
OnSetSocketOptions() | Activ::IpSocket | [protected, virtual]
OnTxBuffers(const size_t dataLength) | Activ::IpSocket | [protected, virtual]
PostRead() | Activ::IpSocket | [protected]
PostWrite() | Activ::IpSocket | [protected]
PreLockedRead() | Activ::IpSocket | [inline]
PreLockedWrite() | Activ::IpSocket | [inline]
SetRxBufferSize(const int size) | Activ::IpSocket |
SetSocketOption(const int optionName, const char *pOptionValue, const socklen_t optionLength, const int level=SOL_SOCKET) | Activ::IpSocket |
SetTxBufferSize(const int size) | Activ::IpSocket |
ShutdownSocket() | Activ::IpSocket | [protected]
~IpSocket() | Activ::IpSocket | [virtual]

Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::IpSocket::RxOverlapped Member List

This is the complete list of members for Activ::IpSocket::RxOverlapped, including all inherited members.

GetNumberOfBytes() const | Activ::IoCompletionManager::Overlapped | [inline]
IsPending() const | Activ::IoCompletionManager::Overlapped | [inline]
Overlapped(IoCompletionManager &ioCompletionManager, IMutex *const pMutex) | Activ::IoCompletionManager::Overlapped | [inline]
PostIoCompletion(DWORD numberOfBytes) | Activ::IoCompletionManager::Overlapped | [inline]
RxOverlapped(IpSocket &ipSocket) | Activ::IpSocket::RxOverlapped |
SetPending(const bool isPending) | Activ::IoCompletionManager::Overlapped | [inline]
WasSuccessfulCompletion() const | Activ::IoCompletionManager::Overlapped | [inline]

Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::IpSocket::Settings Member List

This is the complete list of members for Activ::IpSocket::Settings, including all inherited members.

m_shouldCork | Activ::IpSocket::Settings
Settings(const bool shouldCork=false) | Activ::IpSocket::Settings

Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::IpSocket::Stats Member List

This is the complete list of members for Activ::IpSocket::Stats, including all inherited members.

Get(const SOCKET_TYPE &socket) | Activ::IpSocket::Stats | [inline, static]
m_closeOnTxCompletion | Activ::IpSocket::Stats |
m_closePosted | Activ::IpSocket::Stats |
m_localAddress | Activ::IpSocket::Stats |
m_mutexContentionCount | Activ::IpSocket::Stats |
m_remoteAddress | Activ::IpSocket::Stats |
m_rxBytes | Activ::IpSocket::Stats |
m_rxPosted | Activ::IpSocket::Stats |
m_txBytes | Activ::IpSocket::Stats |
m_txPosted | Activ::IpSocket::Stats |
Stats(const IpSocket &socket) | Activ::IpSocket::Stats |

Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::IpSocket::TxOverlapped Member List

This is the complete list of members for Activ::IpSocket::TxOverlapped, including all inherited members.

GetNumberOfBytes() const | Activ::IoCompletionManager::Overlapped | [inline]
IsPending() const | Activ::IoCompletionManager::Overlapped | [inline]
Overlapped(IoCompletionManager &ioCompletionManager, IMutex *const pMutex) | Activ::IoCompletionManager::Overlapped | [inline]
PostIoCompletion(DWORD numberOfBytes) | Activ::IoCompletionManager::Overlapped | [inline]
SetPending(const bool isPending) | Activ::IoCompletionManager::Overlapped | [inline]
TxOverlapped(IpSocket &ipSocket) | Activ::IpSocket::TxOverlapped |
WasSuccessfulCompletion() const | Activ::IoCompletionManager::Overlapped | [inline]

Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Less< T, RHS > Member List

This is the complete list of members for Activ::Less< T, RHS >, including all inherited members.

BOOST_STATIC_ASSERT(boost::is_integral< T >::value) (defined in Activ::Less< T, RHS >) | Activ::Less< T, RHS > |
operator()(const T lhs) const (defined in Activ::Less< T, RHS >) | Activ::Less< T, RHS > | [inline]

Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::LessThanPairComparisonObject< Pair > Member List

This is the complete list of members for Activ::LessThanPairComparisonObject< Pair >, including all inherited members.

operator()(const Pair &lhs, const Pair &rhs) const | Activ::LessThanPairComparisonObject< Pair > | [inline]
operator()(const Pair &lhs, const typename Pair::first_type &rhs) const | Activ::LessThanPairComparisonObject< Pair > | [inline]
operator()(const typename Pair::first_type &lhs, const Pair &rhs) const | Activ::LessThanPairComparisonObject< Pair > | [inline]

Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::LicenseServiceApi Member List

This is the complete list of members for Activ::LicenseServiceApi, including all inherited members.

GetIniFileParser(const Component &component, IniFileParser &iniFileParser) | Activ::LicenseServiceApi | [static]
GetSectionName(const Component &component, std::string &sectionName) | Activ::LicenseServiceApi | [static]

Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::LocalTime Member List

This is the complete list of members for Activ::LocalTime, including all inherited members.

DateToString() const | Activ::BaseTime |
DayOfWeek typedef | Activ::BaseTime |
DayOfWeekToString(const DayOfWeek dayOfWeek, bool isShort=false) | Activ::BaseTime | [static]
Deserialize(MessageValidator &messageValidator) | Activ::BaseTime |
FRIDAY (defined in Activ::BaseTime) | Activ::BaseTime | [static]
Get() const | Activ::LocalTime | [inline]
GetCurrent() | Activ::LocalTime | [static]
GetDay() const | Activ::BaseTime | [inline]
GetDayOfWeek() const | Activ::BaseTime | [inline]
GetHour() const | Activ::BaseTime | [inline]
GetJulianTime() const | Activ::BaseTime | [inline]
GetMidnight() | Activ::LocalTime | [static]
GetMillisecond() const | Activ::BaseTime | [inline]
GetMinute() const | Activ::BaseTime | [inline]
GetMonth() const | Activ::BaseTime | [inline]
GetSecond() const | Activ::BaseTime | [inline]
GetYear() const | Activ::BaseTime | [inline]
IsUtc() const | Activ::BaseTime | [inline]
LocalTime() | Activ::LocalTime |
LocalTime(const uint16_t year, const uint8_t month=1, const uint8_t day=1, const uint8_t hour=0, const uint8_t minute=0, const uint8_t second=0, uint16_t millisecond=0) | Activ::LocalTime | [explicit]
LocalTime(const DateTime &dateTime) | Activ::LocalTime |
LocalTime(const Date &date, const Time &time) | Activ::LocalTime |
LocalTime(const BaseTime &baseTime) | Activ::LocalTime |
millisecondsPerDay (defined in Activ::BaseTime) | Activ::BaseTime | [static]
millisecondsPerHour (defined in Activ::BaseTime) | Activ::BaseTime | [static]
millisecondsPerMinute (defined in Activ::BaseTime) | Activ::BaseTime | [static]
millisecondsPerSecond (defined in Activ::BaseTime) | Activ::BaseTime | [static]
MONDAY (defined in Activ::BaseTime) | Activ::BaseTime | [static]
MonthToString(const uint8_t month, bool isShort=false) | Activ::BaseTime | [static]
operator!=(const BaseTime &rhs) const | Activ::BaseTime |
operator+=(const int64_t numberOfMilliseconds) | Activ::BaseTime |
operator+=(const Duration &duration) | Activ::BaseTime |
operator-=(const int64_t numberOfMilliseconds) | Activ::BaseTime |
operator-=(const Duration &duration) | Activ::BaseTime |
operator<(const BaseTime &rhs) const | Activ::BaseTime |
operator<=(const BaseTime &rhs) const | Activ::BaseTime |
operator=(const BaseTime &rhs) | Activ::BaseTime |
operator==(const BaseTime &rhs) const | Activ::BaseTime |
operator>(const BaseTime &rhs) const | Activ::BaseTime |
operator>=(const BaseTime &rhs) const | Activ::BaseTime |
SATURDAY (defined in Activ::BaseTime) | Activ::BaseTime | [static]
secondsPerDay (defined in Activ::BaseTime) | Activ::BaseTime | [static]
secondsPerHour (defined in Activ::BaseTime) | Activ::BaseTime | [static]
secondsPerMinute (defined in Activ::BaseTime) | Activ::BaseTime | [static]
Serialize(MessageBuilder &messageBuilder) const | Activ::BaseTime |
SUNDAY (defined in Activ::BaseTime) | Activ::BaseTime | [static]
THURSDAY (defined in Activ::BaseTime) | Activ::BaseTime | [static]
TimeToString(const bool shouldFormatMilliseconds=false) const | Activ::BaseTime |
ToString(const bool shouldFormatMilliseconds=false) const | Activ::BaseTime |
TUESDAY (defined in Activ::BaseTime) | Activ::BaseTime | [static]
WEDSDAY (defined in Activ::BaseTime) | Activ::BaseTime | [static]
~BaseTime() | Activ::BaseTime | [virtual]

Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::LoggerDefinitions Member List

This is the complete list of members for Activ::LoggerDefinitions, including all inherited members.

ACTIV_DECLARE_ELEMENT_1_WITH_COMMA enum value | Activ::LoggerDefinitions |
FileType enum name | Activ::LoggerDefinitions |
MAX_FILE_SIZE_UNDEFINED (defined in Activ::LoggerDefinitions) | Activ::LoggerDefinitions | [static]
NUMBER_OF_BACKUPS_UNDEFINED (defined in Activ::LoggerDefinitions) | Activ::LoggerDefinitions | [static]
servicePortId | Activ::LoggerDefinitions | [static]
TypeToString(const FileType logFileType) | Activ::LoggerDefinitions | [static]

Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::LoggerServiceApi Member List

This is the complete list of members for Activ::LoggerServiceApi, including all inherited members.

CloseLogFile(const Component &component, Address &logAddress) | Activ::LoggerServiceApi | [static]
LogMessage(const Component &component, const Address &logAddress, const std::string &message) | Activ::LoggerServiceApi | [static]
LogMessage(const Component &component, const Address &logAddress, const boost::format &message) | Activ::LoggerServiceApi | [static]
LogMessage(const Component &component, const Address &logAddress, const void *pMessage, const size_t messageLength) | Activ::LoggerServiceApi | [static]
LogMessage(const Component &component, const Address &logAddress, HeapMessage &heapMessage) | Activ::LoggerServiceApi | [static]
OpenLogFile(const Component &component, const std::string &fileName, const LoggerDefinitions::FileType fileType, const bool isUniqueFileName, Address::Proxy logAddress) | Activ::LoggerServiceApi | [static]
OpenLogFile(const Component &component, const std::string &fileName, const LoggerDefinitions::FileType fileType, const uint64_t maxFileSize, const size_t nBackups, Address::Proxy logAddress) | Activ::LoggerServiceApi | [static]
OpenLogFile(const Component &component, const std::string &fileName, const LoggerDefinitions::FileType fileType, const uint64_t maxFileSize, const size_t nBackups, const bool isUniqueFileName, Address::Proxy logAddress) | Activ::LoggerServiceApi | [static]
SetLogHeader(const Component &component, const Address &logAddress, const std::string &header) | Activ::LoggerServiceApi | [static]

Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ManagedEndPoint Member List

This is the complete list of members for Activ::ManagedEndPoint, including all inherited members.

CanThreadExit() | Activ::ManagedEndPoint | [protected, virtual]
FindPort(const std::string &portName, Address &portAddress) const | Activ::ManagedEndPoint |
GetEndPoint() const | Activ::ManagedEndPoint |
GetMaxThreads() const | Activ::ManagedEndPoint |
ManagedEndPoint(ISystem *const pSystem, const std::string &name, const Settings &settings=Settings()) | Activ::ManagedEndPoint |
Port (defined in Activ::ManagedEndPoint) | Activ::ManagedEndPoint | [friend]
PortIdSet typedef | Activ::ManagedEndPoint |
PostDiesToThreads() const | Activ::ManagedEndPoint |
Process() | Activ::ManagedEndPoint | [protected, virtual]
Run() | Activ::ManagedEndPoint |
StartThread() | Activ::ManagedEndPoint |
WaitForThreadsToExit(const TimeoutPeriod timeout=ACTIV_WAIT_INFINITE) const | Activ::ManagedEndPoint |
~ManagedEndPoint() | Activ::ManagedEndPoint | [virtual]

Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ManagedEndPoint::RunHelper Member List

This is the complete list of members for Activ::ManagedEndPoint::RunHelper, including all inherited members.

operator()(const size_t maxMessagesToProcess, const TimeoutPeriod timeout) | Activ::ManagedEndPoint::RunHelper
RunHelper(ManagedEndPoint &managedEndPoint) | Activ::ManagedEndPoint::RunHelper
~RunHelper() | Activ::ManagedEndPoint::RunHelper

Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ManagedEndPoint::Settings Member List

This is the complete list of members for Activ::ManagedEndPoint::Settings, including all inherited members.

m_initialPortListSize | Activ::ManagedEndPoint::Settings
m_maxThreads | Activ::ManagedEndPoint::Settings
m_minFreePortIdListSize | Activ::ManagedEndPoint::Settings
m_notificationType | Activ::ManagedEndPoint::Settings
m_reservedPortIdSet | Activ::ManagedEndPoint::Settings
m_threadPriority | Activ::ManagedEndPoint::Settings
m_threadProcessorAffinityList | Activ::ManagedEndPoint::Settings
Read(const IniFileParser::ConstSectionIterator &sectionIterator) | Activ::ManagedEndPoint::Settings
Settings() | Activ::ManagedEndPoint::Settings

Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::MessageBuilder Member List

This is the complete list of members for Activ::MessageBuilder, including all inherited members.

Append(const void *const pBuffer, const size_t length) | Activ::MessageBuilder | [inline]
Append(const char character) | Activ::MessageBuilder | [inline]
Append(const char character, const size_t count) | Activ::MessageBuilder | [inline]
Append(const std::string &str) | Activ::MessageBuilder | [inline]
Append(const T value, const Endian endian) | Activ::MessageBuilder | [inline]
Append(const T value, const size_t size, const Endian endian) | Activ::MessageBuilder | [inline]
AppendBoolean(const bool value) | Activ::MessageBuilder | [inline]
AppendInEndian(const void *const pValue, const size_t size, const Endian endian) | Activ::MessageBuilder | [inline]
Endian enum name | Activ::MessageHandler |
ENDIAN_ALIEN enum value (defined in Activ::MessageHandler) | Activ::MessageHandler |
ENDIAN_BIG enum value | Activ::MessageHandler |
ENDIAN_LITTLE enum value | Activ::MessageHandler |
ENDIAN_LOCAL enum value | Activ::MessageHandler |
Erase(const size_t offset, const size_t length) | Activ::MessageBuilder | [inline]
GetBufferSize() const | Activ::MessageBuilder | [inline]
GetLength() const | Activ::MessageBuilder | [inline]
GetMessage() const | Activ::MessageBuilder | [inline]
GetMessageVersion() const | Activ::MessageHandler | [inline]
Initialize(const size_t initialBufferSize, const bool shouldAdjustBufferSize=true, const MessageVersion messageVersion=MESSAGE_VERSION_UNDEFINED) | Activ::MessageBuilder | [inline]
Initialize(void *const pBuffer, const size_t bufferSize, const bool shouldAdjustBufferSize=true, const MessageVersion messageVersion=MESSAGE_VERSION_UNDEFINED) | Activ::MessageBuilder | [inline]
Insert(const size_t offset, const void *const pBuffer, const size_t length) | Activ::MessageBuilder | [inline]
Insert(const size_t offset, const char character) | Activ::MessageBuilder | [inline]
Insert(const size_t offset, const char character, const size_t count) | Activ::MessageBuilder | [inline]
Insert(const size_t offset, const std::string &str) | Activ::MessageBuilder | [inline]
Insert(const size_t offset, const T value, const Endian endian) | Activ::MessageBuilder | [inline]
Insert(const size_t offset, const T value, const size_t size, const Endian endian) | Activ::MessageBuilder | [inline]
InsertBoolean(const size_t offset, const bool value) | Activ::MessageBuilder | [inline]
InsertInEndian(const size_t offset, const void *const pValue, const size_t size, const Endian endian) | Activ::MessageBuilder | [inline]
MAX_PRINTABLE_ASCII | Activ::MessageHandler | [static]
MESSAGE_VERSION_UNDEFINED | Activ::MessageHandler | [static]
MessageBuilder(const size_t initialBufferSize=0, const bool shouldAdjustBufferSize=true, const MessageVersion messageVersion=MESSAGE_VERSION_UNDEFINED) | Activ::MessageBuilder | [inline]
MessageBuilder(void *const pBuffer, const size_t bufferSize, const bool shouldAdjustBufferSize=true, const MessageVersion messageVersion=MESSAGE_VERSION_UNDEFINED) | Activ::MessageBuilder | [inline]
MessageBuilder(const MessageBuilder &rhs) | Activ::MessageBuilder | [inline]
MessageHandler(const MessageVersion messageVersion=MESSAGE_VERSION_UNDEFINED) | Activ::MessageHandler | [inline]
MessageVersion typedef | Activ::MessageHandler |
MIN_PRINTABLE_ASCII | Activ::MessageHandler | [static]
operator+(const MessageBuilder &rhs) const | Activ::MessageBuilder | [inline]
operator+=(const MessageBuilder &rhs) | Activ::MessageBuilder | [inline]
operator=(const MessageBuilder &rhs) | Activ::MessageBuilder | [inline]
Overwrite(const size_t offset, const void *const pBuffer, const size_t length) | Activ::MessageBuilder | [inline]
Overwrite(const size_t offset, const char character) | Activ::MessageBuilder | [inline]
Overwrite(const size_t offset, const char character, const size_t count) | Activ::MessageBuilder | [inline]
Overwrite(const size_t offset, const std::string &str) | Activ::MessageBuilder | [inline]
Overwrite(const size_t offset, const T value, const Endian endian) | Activ::MessageBuilder | [inline]
Overwrite(const size_t offset, const T value, const size_t size, const Endian endian) | Activ::MessageBuilder | [inline]
OverwriteBoolean(const size_t offset, const bool value) | Activ::MessageBuilder | [inline]
OverwriteInEndian(const size_t offset, const void *const pValue, const size_t size, const Endian endian) | Activ::MessageBuilder | [inline]
Reset(const MessageVersion messageVersion=MESSAGE_VERSION_UNDEFINED) | Activ::MessageBuilder | [inline, virtual]
SetBufferSize(const size_t bufferSize) | Activ::MessageBuilder | [inline]
SetLength(const size_t length) | Activ::MessageBuilder | [inline]
SetMessageVersion(const MessageVersion messageVersion) | Activ::MessageHandler | [inline]
StringLength typedef | Activ::MessageHandler |
~MessageBuilder() | Activ::MessageBuilder | [inline]
~MessageHandler()=0 | Activ::MessageHandler | [inline, pure virtual]

Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::MessageBuilderVariableLengthRangeCheck< false > Member List

This is the complete list of members for Activ::MessageBuilderVariableLengthRangeCheck< false >, including all inherited members.

operator()(const T value, const size_t numberOfBytes) const Activ::MessageBuilderVariableLengthRangeCheck< false > [inline]

Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::MessageBuilderVariableLengthRangeCheck< true > Member List

This is the complete list of members for Activ::MessageBuilderVariableLengthRangeCheck< true >, including all inherited members.

operator()(const T value, const size_t numberOfBytes) const Activ::MessageBuilderVariableLengthRangeCheck< true > [inline]

Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::MessageHandler Member List

This is the complete list of members for Activ::MessageHandler, including all inherited members.

Endian enum name | Activ::MessageHandler |
ENDIAN_ALIEN enum value (defined in Activ::MessageHandler) | Activ::MessageHandler |
ENDIAN_BIG enum value | Activ::MessageHandler |
ENDIAN_LITTLE enum value | Activ::MessageHandler |
ENDIAN_LOCAL enum value | Activ::MessageHandler |
GetMessageVersion() const | Activ::MessageHandler | [inline]
MAX_PRINTABLE_ASCII | Activ::MessageHandler | [static]
MESSAGE_VERSION_UNDEFINED | Activ::MessageHandler | [static]
MessageHandler(const MessageVersion messageVersion=MESSAGE_VERSION_UNDEFINED) | Activ::MessageHandler | [inline]
MessageVersion typedef | Activ::MessageHandler |
MIN_PRINTABLE_ASCII | Activ::MessageHandler | [static]
Reset(const MessageVersion messageVersion=MESSAGE_VERSION_UNDEFINED)=0 | Activ::MessageHandler | [inline, pure virtual]
SetMessageVersion(const MessageVersion messageVersion) | Activ::MessageHandler | [inline]
StringLength typedef | Activ::MessageHandler |
~MessageHandler()=0 | Activ::MessageHandler | [inline, pure virtual]

Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::MessageHandler::ScopedVersion Member List

This is the complete list of members for Activ::MessageHandler::ScopedVersion, including all inherited members.

ScopedVersion(MessageHandler &messageHandler) | Activ::MessageHandler::ScopedVersion | [inline]
ScopedVersion(MessageHandler &messageHandler, const MessageVersion newVersion) | Activ::MessageHandler::ScopedVersion | [inline]
~ScopedVersion() | Activ::MessageHandler::ScopedVersion | [inline]

Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::MessageRateThrottler Member List

This is the complete list of members for Activ::MessageRateThrottler, including all inherited members.

GetMessageRate() const | Activ::MessageRateThrottler |
GetPeriodLength() const | Activ::MessageRateThrottler |
Initialize(const size_t messageRate) | Activ::MessageRateThrottler |
Initialize(const size_t messageRate, const size_t periodLength) | Activ::MessageRateThrottler |
MessageRateThrottler(const size_t messageRate=0, const bool shouldCreateMutex=false) | Activ::MessageRateThrottler |
MessageRateThrottler(const size_t messageRate, const size_t periodLength, const bool shouldCreateMutex=false) | Activ::MessageRateThrottler |
PERIOD_LENGTH_MAXIMUM | Activ::MessageRateThrottler | [static]
PERIOD_LENGTH_MINIMUM | Activ::MessageRateThrottler | [static]
Reset() | Activ::MessageRateThrottler |
Suspend() | Activ::MessageRateThrottler |
~MessageRateThrottler() | Activ::MessageRateThrottler |

Generated on Wed Oct 8 14:01:57 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::MessageValidator Member List

This is the complete list of members for Activ::MessageValidator, including all inherited members.

CopyAsciiHexadecimalIntegralToUnsignedBinaryIntegral(T &to, const void *const pData, size_t size, const Endian endian) | Activ::MessageValidator | [inline, static]
CopySignedAsciiIntegralToSignedBinaryIntegral(T &to, const void *const pData, size_t length) | Activ::MessageValidator | [inline, static]
CopySignedAsciiRealToBinaryReal(T &to, const void *const pData, size_t length) | Activ::MessageValidator | [inline, static]
CopySignedAsciiRealToNumeratorAndDivisor(int64_t &numerator, uint64_t &divisor, const void *const pData, const size_t length) | Activ::MessageValidator | [static]
CopySignedBinaryIntegralToSignedBinaryIntegral(T &to, const void *const pData, size_t size, const Endian endian) | Activ::MessageValidator | [inline, static]
CopyUnsignedAsciiIntegralToUnsignedBinaryIntegral(T &to, const void *const pData, size_t length) | Activ::MessageValidator | [inline, static]
CopyUnsignedAsciiRealToBinaryReal(T &to, const void *const pData, size_t length) | Activ::MessageValidator | [inline, static]
CopyUnsignedAsciiRealToNumeratorAndDivisor(uint64_t &numerator, uint64_t &divisor, const void *const pData, const size_t length) | Activ::MessageValidator | [static]
CopyUnsignedBinaryIntegralToUnsignedBinaryIntegral(T &to, const void *const pData, size_t size, const Endian endian) | Activ::MessageValidator | [inline, static]
Endian enum name | Activ::MessageHandler |
ENDIAN_ALIEN enum value (defined in Activ::MessageHandler) | Activ::MessageHandler |
ENDIAN_BIG enum value | Activ::MessageHandler |
ENDIAN_LITTLE enum value | Activ::MessageHandler |
ENDIAN_LOCAL enum value | Activ::MessageHandler |
Get(const size_t offset, const void *&pData, const size_t length) const | Activ::MessageValidator | [inline]
GetLength() const | Activ::MessageValidator | [inline]
GetMessage() const | Activ::MessageValidator | [inline]
GetMessageVersion() const | Activ::MessageHandler | [inline]
GetOffset() const | Activ::MessageValidator | [inline]
Initialize(const void *pMessage, const size_t length, const MessageVersion messageVersion=MESSAGE_VERSION_UNDEFINED) | Activ::MessageValidator | [inline]
IsEndOfMessage() const | Activ::MessageValidator | [inline]
MAX_PRINTABLE_ASCII | Activ::MessageHandler | [static]
MESSAGE_VERSION_UNDEFINED | Activ::MessageHandler | [static]
MessageHandler(const MessageVersion messageVersion=MESSAGE_VERSION_UNDEFINED) | Activ::MessageHandler | [inline]
MessageValidator(const void *pMessage=0, const size_t length=0, const MessageVersion messageVersion=MESSAGE_VERSION_UNDEFINED) | Activ::MessageValidator | [inline]
MessageVersion typedef | Activ::MessageHandler |
MIN_PRINTABLE_ASCII | Activ::MessageHandler | [static]
Reset(const MessageVersion messageVersion=MESSAGE_VERSION_UNDEFINED) | Activ::MessageValidator | [inline, virtual]
SetMessageVersion(const MessageVersion messageVersion) | Activ::MessageHandler | [inline]
SetOffset(const size_t offset) | Activ::MessageValidator | [inline]
StringLength typedef | Activ::MessageHandler |
ValidateAsciiHexadecimalIntegral(const size_t size, const Endian endian, const void **ppData=0) | Activ::MessageValidator |
ValidateAsciiHexadecimalIntegral(const size_t size, const Endian endian, T *pValue, const void **ppData=0) | Activ::MessageValidator | [inline]
ValidateAsciiHexadecimalIntegral(const size_t size, const uint64_t lower, const uint64_t upper, const Endian endian, const void **ppData=0) | Activ::MessageValidator | [inline]
ValidateAsciiHexadecimalIntegral(const size_t size, const uint64_t lower, const uint64_t upper, const Endian endian, T *pValue, const void **ppData=0) | Activ::MessageValidator | [inline]
ValidateAsciiHexadecimalIntegral(const size_t size, const std::vector< uint64_t > &set, const Endian endian, const void **ppData=0) | Activ::MessageValidator | [inline]
ValidateAsciiHexadecimalIntegral(const size_t size, const std::vector< uint64_t > &set, const Endian endian, T *pValue, const void **ppData=0) | Activ::MessageValidator | [inline]
ValidateAsciiHexadecimalIntegralCopy(const size_t size, const Endian endian, void *pCopy) | Activ::MessageValidator |
ValidateAsciiHexadecimalIntegralCopy(const size_t size, const Endian endian, T *pValue, void *pCopy) | Activ::MessageValidator | [inline]
ValidateAsciiHexadecimalIntegralCopy(const size_t size, const uint64_t lower, const uint64_t upper, const Endian endian, void *pCopy) | Activ::MessageValidator | [inline]
ValidateAsciiHexadecimalIntegralCopy(const size_t size, const uint64_t lower, const uint64_t upper, const Endian endian, T *pValue, void *pCopy) | Activ::MessageValidator | [inline]
ValidateAsciiHexadecimalIntegralCopy(const size_t size, const std::vector< uint64_t > &set, const Endian endian, void *pCopy) | Activ::MessageValidator | [inline]
ValidateAsciiHexadecimalIntegralCopy(const size_t size, const std::vector< uint64_t > &set, const Endian endian, T *pValue, void *pCopy) | Activ::MessageValidator | [inline]
ValidateBinaryIntegral(T &value) | Activ::MessageValidator | [inline]
ValidateBinaryIntegral(const T lower, const T upper, T &value) | Activ::MessageValidator | [inline]
ValidateBinaryIntegralRange(T &value) | Activ::MessageValidator | [inline]
ValidateBoolean(bool *pBoolean) | Activ::MessageValidator | [inline]
ValidateBytes(const size_t length, const void **ppData=0) | Activ::MessageValidator |
ValidateBytes(const size_t length, const void *const pComperand, const void **ppData=0) | Activ::MessageValidator |
ValidateBytes(const size_t length, const byte_t value, const void **ppData=0) | Activ::MessageValidator |
ValidateBytes(const size_t length, const byte_t lower, const byte_t upper, const void **ppData=0) | Activ::MessageValidator |
ValidateBytes(const size_t length, const std::vector< byte_t > &set, const void **ppData=0) | Activ::MessageValidator |
ValidateBytes(const size_t length, const std::vector< std::string > &set, const void **ppData=0) | Activ::MessageValidator |
ValidateBytesCopy(const size_t length, void *pCopy) | Activ::MessageValidator |
ValidateBytesCopy(const size_t length, const byte_t lower, const byte_t upper, void *pCopy) | Activ::MessageValidator |
ValidateBytesCopy(const size_t length, const std::vector< byte_t > &set, void *pCopy) | Activ::MessageValidator |
ValidateBytesCopy(const size_t length, const std::vector< std::string > &set, void *pCopy) | Activ::MessageValidator |
ValidateSignedAsciiIntegral(const size_t length, const void **ppData=0) | Activ::MessageValidator |
ValidateSignedAsciiIntegral(const size_t length, T *pValue, const void **ppData=0) | Activ::MessageValidator | [inline]
ValidateSignedAsciiIntegral(const size_t length, const int64_t lower, const int64_t upper, const void **ppData=0) | Activ::MessageValidator | [inline]
ValidateSignedAsciiIntegral(const size_t length, const int64_t lower, const int64_t upper, T *pValue, const void **ppData=0) | Activ::MessageValidator | [inline]
ValidateSignedAsciiIntegral(const size_t length, const std::vector< int64_t > &set, const void **ppData=0) | Activ::MessageValidator | [inline]
ValidateSignedAsciiIntegral(const size_t length, const std::vector< int64_t > &set, T *pValue, const void **ppData=0) | Activ::MessageValidator | [inline]
ValidateSignedAsciiIntegralCopy(const size_t length, void *pCopy) | Activ::MessageValidator |
ValidateSignedAsciiIntegralCopy(const size_t length, T *pValue, void *pCopy) | Activ::MessageValidator | [inline]
ValidateSignedAsciiIntegralCopy(const size_t length, const int64_t lower, const int64_t upper, void *pCopy) | Activ::MessageValidator | [inline]
ValidateSignedAsciiIntegralCopy(const size_t length, const int64_t lower, const int64_t upper, T *pValue, void *pCopy) | Activ::MessageValidator | [inline]
ValidateSignedAsciiIntegralCopy(const size_t length, const std::vector< int64_t > &set, void *pCopy) | Activ::MessageValidator | [inline]
ValidateSignedAsciiIntegralCopy(const size_t length, const std::vector< int64_t > &set, T *pValue, void *pCopy) | Activ::MessageValidator | [inline]
ValidateSignedAsciiReal(const size_t length, const void **ppData=0) | Activ::MessageValidator |
ValidateSignedAsciiReal(const size_t length, T *pValue, const void **ppData=0) | Activ::MessageValidator | [inline]
ValidateSignedAsciiReal(const size_t length, int64_t *pNumerator, uint64_t *pDivisor, const void **ppData=0) | Activ::MessageValidator |
ValidateSignedAsciiReal(const size_t length, const long double lower, const long double upper, const void **ppData=0) | Activ::MessageValidator | [inline]
ValidateSignedAsciiReal(const size_t length, const long double lower, const long double upper, T *pValue, const void **ppData=0) | Activ::MessageValidator | [inline]
ValidateSignedAsciiReal(const size_t length, const long double lower, const long double upper, int64_t *pNumerator, uint64_t *pDivisor, const void **ppData=0) | Activ::MessageValidator |
ValidateSignedAsciiReal(const size_t length, const std::vector< long double > &set, const void **ppData=0) | Activ::MessageValidator | [inline]
ValidateSignedAsciiReal(const size_t length, const std::vector< long double > &set, T *pValue, const void **ppData=0) | Activ::MessageValidator | [inline]
ValidateSignedAsciiReal(const size_t length, const std::vector< long double > &set, int64_t *pNumerator, uint64_t *pDivisor, const void **ppData=0) | Activ::MessageValidator |
ValidateSignedAsciiRealCopy(const size_t length, void *pCopy) | Activ::MessageValidator |
ValidateSignedAsciiRealCopy(const size_t length, T *pValue, void *pCopy) | Activ::MessageValidator | [inline]
ValidateSignedAsciiRealCopy(const size_t length, int64_t *pNumerator, uint64_t *pDivisor, void *pCopy) | Activ::MessageValidator |
ValidateSignedAsciiRealCopy(const size_t length, const long double lower, const long double upper, void *pCopy) | Activ::MessageValidator | [inline]
ValidateSignedAsciiRealCopy(const size_t length, const long double lower, const long double upper, T *pValue, void *pCopy) | Activ::MessageValidator | [inline]
ValidateSignedAsciiRealCopy(const size_t length, const long double lower, const long double upper, int64_t *pNumerator, uint64_t *pDivisor, void *pCopy) | Activ::MessageValidator |
ValidateSignedAsciiRealCopy(const size_t length, const std::vector< long double > &set, void *pCopy) | Activ::MessageValidator | [inline]
ValidateSignedAsciiRealCopy(const size_t length, const std::vector< long double > &set, T *pValue, void *pCopy) | Activ::MessageValidator | [inline]
ValidateSignedAsciiRealCopy(const size_t length, const std::vector< long double > &set, int64_t *pNumerator, uint64_t *pDivisor, void *pCopy) | Activ::MessageValidator |
ValidateSignedBinaryIntegral(const size_t size, const Endian endian, const void **ppData=0) | Activ::MessageValidator |
ValidateSignedBinaryIntegral(const size_t size, const Endian endian, T *pValue, const void **ppData=0) | Activ::MessageValidator | [inline]
ValidateSignedBinaryIntegral(const size_t size, const int64_t lower, const int64_t upper, const Endian endian, const void **ppData=0) | Activ::MessageValidator | [inline]
ValidateSignedBinaryIntegral(const size_t size, const int64_t lower, const int64_t upper, const Endian endian, T *pValue, const void **ppData=0) | Activ::MessageValidator | [inline]
ValidateSignedBinaryIntegral(const size_t size, const std::vector< int64_t > &set, const Endian endian, const void **ppData=0) | Activ::MessageValidator | [inline]
ValidateSignedBinaryIntegral(const size_t size, const std::vector< int64_t > &set, const Endian endian, T *pValue, const void **ppData=0) | Activ::MessageValidator | [inline]
ValidateSignedBinaryIntegralCopy(const size_t size, const Endian endian, void *pCopy) | Activ::MessageValidator |
ValidateSignedBinaryIntegralCopy(const size_t size, const Endian endian, T *pValue, void *pCopy) | Activ::MessageValidator | [inline]
ValidateSignedBinaryIntegralCopy(const size_t size, const int64_t lower, const int64_t upper, const Endian endian, void *pCopy) | Activ::MessageValidator | [inline]
ValidateSignedBinaryIntegralCopy(const size_t size, const int64_t lower, const int64_t upper, const Endian endian, T *pValue, void *pCopy) | Activ::MessageValidator | [inline]
ValidateSignedBinaryIntegralCopy(const size_t size, const std::vector< int64_t > &set, const Endian endian, void *pCopy) | Activ::MessageValidator | [inline]
ValidateSignedBinaryIntegralCopy(const size_t size, const std::vector< int64_t > &set, const Endian endian, T *pValue, void *pCopy) | Activ::MessageValidator | [inline]
ValidateString(const void **ppData=0, size_t *pDataLength=0) | Activ::MessageValidator | [inline]
ValidateString(std::string *pString, const void **ppData=0, size_t *pDataLength=0) | Activ::MessageValidator |
ValidateString(const byte_t lower, const byte_t upper, const void **ppData=0, size_t *pDataLength=0) | Activ::MessageValidator | [inline]
ValidateString(const byte_t lower, const byte_t upper, std::string *pString, const void **ppData=0, size_t *pDataLength=0) | Activ::MessageValidator |
ValidateString(const std::vector< byte_t > &set, const void **ppData=0, size_t *pDataLength=0) | Activ::MessageValidator | [inline]
ValidateString(const std::vector< byte_t > &set, std::string *pString, const void **ppData=0, size_t *pDataLength=0) | Activ::MessageValidator |
ValidateString(const std::vector< std::string > &set, const void **ppData=0, size_t *pDataLength=0) | Activ::MessageValidator | [inline]
ValidateString(const std::vector< std::string > &set, std::string *pString, const void **ppData=0, size_t *pDataLength=0) | Activ::MessageValidator |
ValidateStringCopy(void *pCopy, const size_t copySize, size_t *pCopyLength) | Activ::MessageValidator | [inline]
ValidateStringCopy(std::string *pString, void *pCopy, const size_t copySize, size_t *pCopyLength) | Activ::MessageValidator |
ValidateStringCopy(const byte_t lower, const byte_t upper, void *pCopy, const size_t copySize, size_t *pCopyLength) | Activ::MessageValidator | [inline]
ValidateStringCopy(const byte_t lower, const byte_t upper, std::string *pString, void *pCopy, const size_t copySize, size_t *pCopyLength) | Activ::MessageValidator |
ValidateStringCopy(const std::vector< byte_t > &set, void *pCopy, const size_t copySize, size_t *pCopyLength) | Activ::MessageValidator | [inline]
ValidateStringCopy(const std::vector< byte_t > &set, std::string *pString, void *pCopy, const size_t copySize, size_t *pCopyLength) | Activ::MessageValidator |
ValidateStringCopy(const std::vector< std::string > &set, void *pCopy, const size_t copySize, size_t *pCopyLength) | Activ::MessageValidator | [inline]
ValidateStringCopy(const std::vector< std::string > &set, std::string *pString, void *pCopy, const size_t copySize, size_t *pCopyLength) | Activ::MessageValidator |
ValidateUnsignedAsciiIntegral(const size_t length, const void **ppData=0) | Activ::MessageValidator |
ValidateUnsignedAsciiIntegral(const size_t length, T *pValue, const void **ppData=0) | Activ::MessageValidator | [inline]
ValidateUnsignedAsciiIntegral(const size_t length, const uint64_t lower, const uint64_t upper, const void **ppData=0) | Activ::MessageValidator | [inline]
ValidateUnsignedAsciiIntegral(const size_t length, const uint64_t lower, const uint64_t upper, T *pValue, const void **ppData=0) | Activ::MessageValidator | [inline]
ValidateUnsignedAsciiIntegral(const size_t length, const std::vector< uint64_t > &set, const void **ppData=0) | Activ::MessageValidator | [inline]
ValidateUnsignedAsciiIntegral(const size_t length, const std::vector< uint64_t > &set, T *pValue, const void **ppData=0) | Activ::MessageValidator | [inline]
ValidateUnsignedAsciiIntegralCopy(const size_t length, void *pCopy) | Activ::MessageValidator |
ValidateUnsignedAsciiIntegralCopy(const size_t length, T *pValue, void *pCopy) | Activ::MessageValidator | [inline]
ValidateUnsignedAsciiIntegralCopy(const size_t length, const uint64_t lower, const uint64_t upper, void *pCopy) | Activ::MessageValidator | [inline]
ValidateUnsignedAsciiIntegralCopy(const size_t length, const uint64_t lower, const uint64_t upper, T *pValue, void *pCopy) | Activ::MessageValidator | [inline]
ValidateUnsignedAsciiIntegralCopy(const size_t length, const std::vector< uint64_t > &set, void *pCopy) | Activ::MessageValidator | [inline]
ValidateUnsignedAsciiIntegralCopy(const size_t length, const std::vector< uint64_t > &set, T *pValue, void *pCopy) | Activ::MessageValidator | [inline]
ValidateUnsignedAsciiReal(const size_t length, const void **ppData=0) | Activ::MessageValidator |
ValidateUnsignedAsciiReal(const size_t length, T *pValue, const void **ppData=0) | Activ::MessageValidator | [inline]
ValidateUnsignedAsciiReal(const size_t length, uint64_t *pNumerator, uint64_t *pDivisor, const void **ppData=0) | Activ::MessageValidator |
ValidateUnsignedAsciiReal(const size_t length, const long double lower, const long double upper, const void **ppData=0) | Activ::MessageValidator | [inline]
ValidateUnsignedAsciiReal(const size_t length, const long double lower, const long double upper, T *pValue, const void **ppData=0) | Activ::MessageValidator | [inline]
ValidateUnsignedAsciiReal(const size_t length, const long double lower, const long double upper, uint64_t *pNumerator, uint64_t *pDivisor, const void **ppData=0) | Activ::MessageValidator |
ValidateUnsignedAsciiReal(const size_t length, const std::vector< long double > &set, const void **ppData=0) | Activ::MessageValidator | [inline]
ValidateUnsignedAsciiReal(const size_t length, const std::vector< long double > &set, T *pValue, const void **ppData=0) | Activ::MessageValidator | [inline]
ValidateUnsignedAsciiReal(const size_t length, const std::vector< long double > &set, uint64_t *pNumerator, uint64_t *pDivisor, const void **ppData=0) | Activ::MessageValidator |
ValidateUnsignedAsciiRealCopy(const size_t length, void *pCopy) | Activ::MessageValidator |
ValidateUnsignedAsciiRealCopy(const size_t length, T *pValue, void *pCopy) | Activ::MessageValidator | [inline]
ValidateUnsignedAsciiRealCopy(const size_t length, uint64_t *pNumerator, uint64_t *pDivisor, void *pCopy) | Activ::MessageValidator |
ValidateUnsignedAsciiRealCopy(const size_t length, const long double lower, const long double upper, void *pCopy) | Activ::MessageValidator | [inline]
ValidateUnsignedAsciiRealCopy(const size_t length, const long double lower, const long double upper, T *pValue, void *pCopy) | Activ::MessageValidator | [inline]
ValidateUnsignedAsciiRealCopy(const size_t length, const long double lower, const long double upper, uint64_t *pNumerator, uint64_t *pDivisor, void *pCopy) | Activ::MessageValidator |
ValidateUnsignedAsciiRealCopy(const size_t length, const std::vector< long double > &set, void *pCopy) | Activ::MessageValidator | [inline]
ValidateUnsignedAsciiRealCopy(const size_t length, const std::vector< long double > &set, T *pValue, void *pCopy) | Activ::MessageValidator | [inline]
ValidateUnsignedAsciiRealCopy(const size_t length, const std::vector< long double > &set, uint64_t *pNumerator, uint64_t *pDivisor, void *pCopy) | Activ::MessageValidator |
ValidateUnsignedBinaryIntegral(const size_t size, const Endian endian, const void **ppData=0) | Activ::MessageValidator |
ValidateUnsignedBinaryIntegral(const size_t size, const Endian endian, T *pValue, const void **ppData=0) | Activ::MessageValidator | [inline]
ValidateUnsignedBinaryIntegral(const size_t size, const uint64_t lower, const uint64_t upper, const Endian endian, const void **ppData=0) | Activ::MessageValidator | [inline]
ValidateUnsignedBinaryIntegral(const size_t size, const uint64_t lower, const uint64_t upper, const Endian endian, T *pValue, const void **ppData=0) | Activ::MessageValidator | [inline]
ValidateUnsignedBinaryIntegral(const size_t size, const std::vector< uint64_t > &set, const Endian endian, const void **ppData=0) | Activ::MessageValidator | [inline]
ValidateUnsignedBinaryIntegral(const size_t size, const std::vector< uint64_t > &set, const Endian endian, T *pValue, const void **ppData=0) | Activ::MessageValidator | [inline]
ValidateUnsignedBinaryIntegralCopy(const size_t size, const Endian endian, void *pCopy) | Activ::MessageValidator |
ValidateUnsignedBinaryIntegralCopy(const size_t size, const Endian endian, T *pValue, void *pCopy) | Activ::MessageValidator | [inline]
ValidateUnsignedBinaryIntegralCopy(const size_t size, const uint64_t lower, const uint64_t upper, const Endian endian, void *pCopy) | Activ::MessageValidator | [inline]
ValidateUnsignedBinaryIntegralCopy(const size_t size, const uint64_t lower, const uint64_t upper, const Endian endian, T *pValue, void *pCopy) | Activ::MessageValidator | [inline]
ValidateUnsignedBinaryIntegralCopy(const size_t size, const std::vector< uint64_t > &set, const Endian endian, void *pCopy) | Activ::MessageValidator | [inline]
ValidateUnsignedBinaryIntegralCopy(const size_t size, const std::vector< uint64_t > &set, const Endian endian, T *pValue, void *pCopy) | Activ::MessageValidator | [inline]
~MessageHandler()=0 | Activ::MessageHandler | [inline, pure virtual]

Generated on Wed Oct 8 14:01:58 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::NextBitField< PREVIOUS_FIELD, LENGTH_VALUE > Member List

This is the complete list of members for Activ::NextBitField< PREVIOUS_FIELD, LENGTH_VALUE >, including all inherited members.

Bitmap typedef (defined in Activ::BitField< PREVIOUS_FIELD::Bitmap, PREVIOUS_FIELD::OFFSET+PREVIOUS_FIELD::LENGTH, LENGTH_VALUE >) | Activ::BitField< PREVIOUS_FIELD::Bitmap, PREVIOUS_FIELD::OFFSET+PREVIOUS_FIELD::LENGTH, LENGTH_VALUE > |
BOOST_STATIC_ASSERT((OFFSET+LENGTH)<=(sizeof(Bitmap)*CHAR_BIT)) (defined in Activ::BitField< PREVIOUS_FIELD::Bitmap, PREVIOUS_FIELD::OFFSET+PREVIOUS_FIELD::LENGTH, LENGTH_VALUE >) | Activ::BitField< PREVIOUS_FIELD::Bitmap, PREVIOUS_FIELD::OFFSET+PREVIOUS_FIELD::LENGTH, LENGTH_VALUE > |
GetMaxValue() | Activ::BitField< PREVIOUS_FIELD::Bitmap, PREVIOUS_FIELD::OFFSET+PREVIOUS_FIELD::LENGTH, LENGTH_VALUE > | [static]
GetShifted(const Bitmap bitmap) | Activ::BitField< PREVIOUS_FIELD::Bitmap, PREVIOUS_FIELD::OFFSET+PREVIOUS_FIELD::LENGTH, LENGTH_VALUE > | [static]
GetUnshifted(const Bitmap bitmap) | Activ::BitField< PREVIOUS_FIELD::Bitmap, PREVIOUS_FIELD::OFFSET+PREVIOUS_FIELD::LENGTH, LENGTH_VALUE > | [static]
LENGTH (defined in Activ::BitField< PREVIOUS_FIELD::Bitmap, PREVIOUS_FIELD::OFFSET+PREVIOUS_FIELD::LENGTH, LENGTH_VALUE >) | Activ::BitField< PREVIOUS_FIELD::Bitmap, PREVIOUS_FIELD::OFFSET+PREVIOUS_FIELD::LENGTH, LENGTH_VALUE > | [static]
MASK (defined in Activ::BitField< PREVIOUS_FIELD::Bitmap, PREVIOUS_FIELD::OFFSET+PREVIOUS_FIELD::LENGTH, LENGTH_VALUE >) | Activ::BitField< PREVIOUS_FIELD::Bitmap, PREVIOUS_FIELD::OFFSET+PREVIOUS_FIELD::LENGTH, LENGTH_VALUE > | [static]
OFFSET (defined in Activ::BitField< PREVIOUS_FIELD::Bitmap, PREVIOUS_FIELD::OFFSET+PREVIOUS_FIELD::LENGTH, LENGTH_VALUE >) | Activ::BitField< PREVIOUS_FIELD::Bitmap, PREVIOUS_FIELD::OFFSET+PREVIOUS_FIELD::LENGTH, LENGTH_VALUE > | [static]
Set(Bitmap &bitmap, const Bitmap value) | Activ::BitField< PREVIOUS_FIELD::Bitmap, PREVIOUS_FIELD::OFFSET+PREVIOUS_FIELD::LENGTH, LENGTH_VALUE > | [static]

Generated on Wed Oct 8 14:01:58 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::NullObject Member List

This is the complete list of members for Activ::NullObject, including all inherited members.

operator()(const T *ptr) const (defined in Activ::NullObject) Activ::NullObject [inline]

Generated on Wed Oct 8 14:01:58 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ObjectPool< T, INITIAL_FREE_LIST_SIZE, MAX_FREE_LIST_SIZE > Member List

This is the complete list of members for Activ::ObjectPool< T, INITIAL_FREE_LIST_SIZE, MAX_FREE_LIST_SIZE >, including all inherited members.

BOOST_STATIC_ASSERT(INITIAL_FREE_LIST_SIZE<=MAX_FREE_LIST_SIZE) (defined in Activ::ObjectPool< T, INITIAL_FREE_LIST_SIZE, MAX_FREE_LIST_SIZE >) | Activ::ObjectPool< T, INITIAL_FREE_LIST_SIZE, MAX_FREE_LIST_SIZE > |
DestroyAll() | Activ::ObjectPool< T, INITIAL_FREE_LIST_SIZE, MAX_FREE_LIST_SIZE > | [inline]
Get() | Activ::ObjectPool< T, INITIAL_FREE_LIST_SIZE, MAX_FREE_LIST_SIZE > | [inline]
GetInstance() | Activ::ObjectPool< T, INITIAL_FREE_LIST_SIZE, MAX_FREE_LIST_SIZE > | [inline, static]
GetStats() const | Activ::ObjectPool< T, INITIAL_FREE_LIST_SIZE, MAX_FREE_LIST_SIZE > | [inline]
ObjectType typedef (defined in Activ::ObjectPool< T, INITIAL_FREE_LIST_SIZE, MAX_FREE_LIST_SIZE >) | Activ::ObjectPool< T, INITIAL_FREE_LIST_SIZE, MAX_FREE_LIST_SIZE > |
Return(T *const pObject) | Activ::ObjectPool< T, INITIAL_FREE_LIST_SIZE, MAX_FREE_LIST_SIZE > | [inline]
ReturnAll() | Activ::ObjectPool< T, INITIAL_FREE_LIST_SIZE, MAX_FREE_LIST_SIZE > | [inline]
Singleton() | Activ::Singleton< T > | [inline, protected]
Singleton< ObjectPool< T, INITIAL_FREE_LIST_SIZE, MAX_FREE_LIST_SIZE > > (defined in Activ::ObjectPool< T, INITIAL_FREE_LIST_SIZE, MAX_FREE_LIST_SIZE >) | Activ::ObjectPool< T, INITIAL_FREE_LIST_SIZE, MAX_FREE_LIST_SIZE > | [friend]

Generated on Wed Oct 8 14:01:58 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ObjectPool< T, INITIAL_FREE_LIST_SIZE, MAX_FREE_LIST_SIZE >::Stats Member List

This is the complete list of members for Activ::ObjectPool< T, INITIAL_FREE_LIST_SIZE, MAX_FREE_LIST_SIZE >::Stats, including all inherited members.

m_currentFreeListSize (defined in Activ::ObjectPool< T, INITIAL_FREE_LIST_SIZE, MAX_FREE_LIST_SIZE >::Stats) | Activ::ObjectPool< T, INITIAL_FREE_LIST_SIZE, MAX_FREE_LIST_SIZE >::Stats
m_currentInUseCount (defined in Activ::ObjectPool< T, INITIAL_FREE_LIST_SIZE, MAX_FREE_LIST_SIZE >::Stats) | Activ::ObjectPool< T, INITIAL_FREE_LIST_SIZE, MAX_FREE_LIST_SIZE >::Stats
m_initialFreeListSize (defined in Activ::ObjectPool< T, INITIAL_FREE_LIST_SIZE, MAX_FREE_LIST_SIZE >::Stats) | Activ::ObjectPool< T, INITIAL_FREE_LIST_SIZE, MAX_FREE_LIST_SIZE >::Stats
m_maximumAllowedFreeListSize (defined in Activ::ObjectPool< T, INITIAL_FREE_LIST_SIZE, MAX_FREE_LIST_SIZE >::Stats) | Activ::ObjectPool< T, INITIAL_FREE_LIST_SIZE, MAX_FREE_LIST_SIZE >::Stats
m_maximumFreeListSize (defined in Activ::ObjectPool< T, INITIAL_FREE_LIST_SIZE, MAX_FREE_LIST_SIZE >::Stats) | Activ::ObjectPool< T, INITIAL_FREE_LIST_SIZE, MAX_FREE_LIST_SIZE >::Stats
m_maximumInUseCount (defined in Activ::ObjectPool< T, INITIAL_FREE_LIST_SIZE, MAX_FREE_LIST_SIZE >::Stats) | Activ::ObjectPool< T, INITIAL_FREE_LIST_SIZE, MAX_FREE_LIST_SIZE >::Stats

Generated on Wed Oct 8 14:01:58 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::OpenServiceRequest Member List

This is the complete list of members for Activ::OpenServiceRequest, including all inherited members.

Deserialize(MessageValidator &messageValidator) | Activ::OpenServiceRequest | [virtual]
m_currentVersion | Activ::OpenServiceRequest | [static]
m_highestVersion | Activ::OpenServiceRequest | [static]
m_serviceId (defined in Activ::OpenServiceRequest) | Activ::OpenServiceRequest |
m_version (defined in Activ::OpenServiceRequest) | Activ::OpenServiceRequest |
OpenServiceRequest() | Activ::OpenServiceRequest |
Serialize(MessageBuilder &messageBuilder) const | Activ::OpenServiceRequest | [virtual]
~ISerializableMessage()=0 | Activ::ISerializableMessage | [inline, pure virtual]

Generated on Wed Oct 8 14:01:58 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::OpenServiceResponse Member List

This is the complete list of members for Activ::OpenServiceResponse, including all inherited members.

Deserialize(MessageValidator &messageValidator) | Activ::OpenServiceResponse | [virtual]
m_serviceId (defined in Activ::OpenServiceResponse) | Activ::OpenServiceResponse |
OpenServiceResponse() | Activ::OpenServiceResponse |
OpenServiceResponse(const ServiceId &serviceId) | Activ::OpenServiceResponse |
Serialize(MessageBuilder &messageBuilder) const | Activ::OpenServiceResponse | [virtual]
~ISerializableMessage()=0 | Activ::ISerializableMessage | [inline, pure virtual]

Generated on Wed Oct 8 14:01:58 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::OsException Member List

This is the complete list of members for Activ::OsException, including all inherited members.

AddException(Exception *pException) const | Activ::Exception |
Exception(const char *file, const char *function, const uint_fast32_t line, const uint_fast32_t errorCode=0) | Activ::Exception |
Exception(const Exception &rhs) | Activ::Exception |
m_errorCode | Activ::Exception |
m_file | Activ::Exception |
m_function | Activ::Exception |
m_line | Activ::Exception |
OsException(const char *file, const char *function, uint_fast32_t line, const uint_fast32_t errorCode) | Activ::OsException |
ToStream(std::ostream &os) const | Activ::Exception | [virtual]
ToString() const | Activ::OsException | [virtual]
~Exception() | Activ::Exception | [virtual]

Generated on Wed Oct 8 14:01:58 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::PagingFileMappedMemoryFactory Member List

This is the complete list of members for Activ::PagingFileMappedMemoryFactory, including all inherited members.

Create(const std::string &name, const size_t size, const IMappedMemory::MappingFlags mappingFlags=IMappedMemory::MAPPING_FLAG_NONE) | Activ::PagingFileMappedMemoryFactory |
Create(const size_t size, const IMappedMemory::MappingFlags mappingFlags=IMappedMemory::MAPPING_FLAG_NONE) | Activ::PagingFileMappedMemoryFactory |
GetInstance() | Activ::PagingFileMappedMemoryFactory | [static]
Open(const std::string &name, const IMappedMemory::MappingFlags mappingFlags=IMappedMemory::MAPPING_FLAG_NONE, Timeout &timeout=Timeout::GetInfinite()) | Activ::PagingFileMappedMemoryFactory |
Singleton() | Activ::Singleton< T > | [inline, protected]
Singleton< PagingFileMappedMemoryFactory > (defined in Activ::PagingFileMappedMemoryFactory) | Activ::PagingFileMappedMemoryFactory | [friend]

Generated on Wed Oct 8 14:01:58 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Port Member List

This is the complete list of members for Activ::Port, including all inherited members.

anonymousName | Activ::Port | [static]
defaultTimeout | Activ::Port | [static]
Disable() | Activ::Port |
Enable() | Activ::Port |
FindPort(const std::string &endPointName, const std::string &portName, Address &portAddress, const TimeoutPeriod timeout=defaultTimeout) | Activ::Port |
ForwardMessage(const Address &destinationAddress, HeapMessage &message, const MessageType newType=INVALID_MESSAGE_TYPE) const | Activ::Port |
GetAddress() const | Activ::Port | [inline]
GetHeap() const | Activ::Port | [inline]
GetManagedEndPoint() const | Activ::Port |
GetName() const | Activ::Port |
ManagedEndPoint::Impl (defined in Activ::Port) | Activ::Port | [friend]
OnMessage(HeapMessage &message) | Activ::Port | [protected, virtual]
OnRequest(HeapMessage &request) | Activ::Port | [protected, virtual]
OnResponse(HeapMessage &response) | Activ::Port | [protected, virtual]
Port(ManagedEndPoint &managedEndPoint, const std::string &name, IHeap *const pHeap) | Activ::Port |
Port(ManagedEndPoint &managedEndPoint, const std::string &name, const PortId portId, IHeap *const pHeap) | Activ::Port |
PostEmptyResponse(const StatusCode responseStatus, HeapMessage &response) const | Activ::Port |
PostEmptyResponse(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, const StatusCode responseStatus, HeapMessage &response) const | Activ::Port |
PostMessage(const Address &destinationAddress, const MessageType messageType, const MessageBuilder &messageBuilder) const | Activ::Port |
PostMessage(const Address &destinationAddress, const MessageType messageType, const void *pMessage=0, const size_t messageLength=0) const | Activ::Port |
PostMessage(const Address &destinationAddress, const MessageType messageType, HeapMessage &message) const | Activ::Port |
PostRequest(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, const MessageBuilder &messageBuilder) const | Activ::Port |
PostRequest(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, const void *pRequest=0, const size_t requestLength=0) const | Activ::Port |
PostRequest(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, HeapMessage &request) const | Activ::Port |
PostResponse(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, const StatusCode responseStatus, const MessageBuilder &messageBuilder) const | Activ::Port |
PostResponse(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, const StatusCode responseStatus, const void *pResponse=0, const size_t responseLength=0) const | Activ::Port |
PostResponse(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, const StatusCode responseStatus, HeapMessage &response) const | Activ::Port |
PostResponse(const StatusCode responseStatus, HeapMessage &request, const MessageBuilder &messageBuilder) const | Activ::Port |
PostResponse(const StatusCode responseStatus, HeapMessage &request, const void *pResponse, const size_t responseLength) const | Activ::Port |
PostResponse(const StatusCode responseStatus, HeapMessage &request, HeapMessage &response) const | Activ::Port |
PostResponse(const StatusCode responseStatus, HeapMessage &request) const | Activ::Port |
ScopedAddress (defined in Activ::Port) | Activ::Port | [friend]
SendRequest(const Address &destinationAddress, const MessageType requestType, const MessageBuilder &messageBuilder, HeapMessage &response, const TimeoutPeriod timeout=defaultTimeout) const | Activ::Port |
SendRequest(const Address &destinationAddress, const MessageType requestType, const void *pRequest, const size_t requestLength, HeapMessage &response, const TimeoutPeriod timeout=defaultTimeout) const | Activ::Port |
SendRequest(const Address &destinationAddress, const MessageType requestType, HeapMessage &request, const TimeoutPeriod timeout=defaultTimeout) const | Activ::Port |
SendRequest(const Address &destinationAddress, const MessageType requestType, SyncRequestId &syncRequestId, const MessageBuilder &messageBuilder) const | Activ::Port |
SendRequest(const Address &destinationAddress, const MessageType requestType, SyncRequestId &syncRequestId, const void *pRequest, const size_t requestLength) const | Activ::Port |
SendRequest(const Address &destinationAddress, const MessageType requestType, SyncRequestId &syncRequestId, HeapMessage &request) const | Activ::Port |
SetHeap(IHeap *const pHeap) | Activ::Port |
~Port() | Activ::Port | [virtual]

Generated on Wed Oct 8 14:01:58 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Port::Enabler Member List

This is the complete list of members for Activ::Port::Enabler, including all inherited members.

Enabler(Port &port) | Activ::Port::Enabler | [inline]
~Enabler() | Activ::Port::Enabler | [inline]

Generated on Wed Oct 8 14:01:58 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::PostMessageHelper Member List

This is the complete list of members for Activ::PostMessageHelper, including all inherited members.

Flush() | Activ::PostMessageHelper
PostMessage(const Port &port, const Address &destinationAddress, const MessageType messageType, const MessageBuilder &messageBuilder) | Activ::PostMessageHelper
PostMessage(const Port &port, const Address &destinationAddress, const MessageType messageType, const void *pMessage=0, const size_t messageLength=0) | Activ::PostMessageHelper
PostMessage(const Port &port, const Address &destinationAddress, const MessageType messageType, HeapMessage &message) | Activ::PostMessageHelper
PostMessage(HeapMessage &heapMessage) | Activ::PostMessageHelper
PostMessageHelper(ISystem *const pSystem, const size_t maximumNumberOfFailedTryFlushes=8) | Activ::PostMessageHelper
TryFlush() | Activ::PostMessageHelper
~PostMessageHelper() | Activ::PostMessageHelper

Generated on Wed Oct 8 14:01:58 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::PrivateEventFactory Member List

This is the complete list of members for Activ::PrivateEventFactory, including all inherited members.

Create(const IEvent::Flags flags=IEvent::FLAG_NONE, const bool initialState=false) | Activ::PrivateEventFactory |
GetInstance() | Activ::PrivateEventFactory | [static]
Singleton() | Activ::Singleton< T > | [inline, protected]
Singleton< PrivateEventFactory > (defined in Activ::PrivateEventFactory) | Activ::PrivateEventFactory | [friend]

Generated on Wed Oct 8 14:01:58 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::PrivateMutexFactory Member List

This is the complete list of members for Activ::PrivateMutexFactory, including all inherited members.

Create(const bool isInitialOwner=false) | Activ::PrivateMutexFactory |
GetInstance() | Activ::PrivateMutexFactory | [static]
Singleton() | Activ::Singleton< T > | [inline, protected]
Singleton< PrivateMutexFactory > (defined in Activ::PrivateMutexFactory) | Activ::PrivateMutexFactory | [friend]

Generated on Wed Oct 8 14:01:58 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::PrivateSemaphoreFactory Member List

This is the complete list of members for Activ::PrivateSemaphoreFactory, including all inherited members.

Create() | Activ::PrivateSemaphoreFactory |
GetInstance() | Activ::PrivateSemaphoreFactory | [static]
Singleton() | Activ::Singleton< T > | [inline, protected]
Singleton< PrivateSemaphoreFactory > (defined in Activ::PrivateSemaphoreFactory) | Activ::PrivateSemaphoreFactory | [friend]

Generated on Wed Oct 8 14:01:58 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Process Member List

This is the complete list of members for Activ::Process, including all inherited members.

DoesExist(const Id id) | Activ::Process | [static]
Exec(const std::string &command) | Activ::Process | [static]
GetCurrentId() | Activ::Process | [static]
Id typedef | Activ::Process |
Kill(const Id id) | Activ::Process | [static]
ProcessorList typedef | Activ::Process |
Run(const std::string &command, std::string &output) | Activ::Process | [static]
SetProcessorAffinity(const ProcessorList &processorList) | Activ::Process | [static]
Start(const std::string &command, Id &id) | Activ::Process | [static]
WaitForCompletion(const Id id, const TimeoutPeriod timeoutPeriod=ACTIV_WAIT_INFINITE) | Activ::Process | [static]

Generated on Wed Oct 8 14:01:58 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::PubSubServiceApi Member List

This is the complete list of members for Activ::PubSubServiceApi, including all inherited members.

AddressSet typedef | Activ::PubSubServiceApi |
AddressSetList typedef | Activ::PubSubServiceApi |
GetSubscriptions(const Component &component, const Subject &subject, const bool shouldRecurseTree, SubscriptionMap &subscriptionMap, const TimeoutPeriod timeout=Port::defaultTimeout) | Activ::PubSubServiceApi | [static]
Publish(const Component &component, const AgentScope agentScope, const Subject &subject, const MessageType type, const MessageBuilder &messageBuilder) | Activ::PubSubServiceApi | [static]
Publish(const Component &component, const AgentScope agentScope, const Subject &subject, const MessageType type, const void *pData=0, const size_t dataLength=0) | Activ::PubSubServiceApi | [static]
Publish(const Component &component, const AgentScope agentScope, const Subject &subject, const MessageType type, HeapMessage &heapMessage) | Activ::PubSubServiceApi | [static]
Publish(const Component &component, PostMessageHelper &postMessageHelper, const AgentScope agentScope, const Subject &subject, const MessageType type, const MessageBuilder &messageBuilder) | Activ::PubSubServiceApi | [static]
Publish(const Component &component, PostMessageHelper &postMessageHelper, const AgentScope agentScope, const Subject &subject, const MessageType type, const void *pData=0, const size_t dataLength=0) | Activ::PubSubServiceApi | [static]
Publish(const Component &component, PostMessageHelper &postMessageHelper, const AgentScope agentScope, const Subject &subject, const MessageType type, HeapMessage &heapMessage) | Activ::PubSubServiceApi | [static]
Subscribe(const Component &component, const AgentScope agentScope, const Subject &subject) | Activ::PubSubServiceApi | [static]
SubscriptionMap typedef | Activ::PubSubServiceApi |
Unsubscribe(const Component &component, const AgentScope agentScope, const Subject &subject) | Activ::PubSubServiceApi | [static]

Generated on Wed Oct 8 14:01:58 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Rational Member List

This is the complete list of members for Activ::Rational, including all inherited members.

Add(const Rational &rhs, bool isExactCalculation=true) | Activ::Rational |
Assign(const IFieldType *const pIFieldType) | Activ::IFieldType |
Clear() | Activ::Rational | [inline, virtual]
Compare(const Rational &rhs, int &result) const | Activ::Rational |
Compare(const void *const pRhsSerializedBody, const size_t rhsSerializedBodyLength, int &result) const | Activ::Rational | [virtual]
Compare(const void *const pLhsSerializedBody, const size_t lhsSerializedBodyLength, const void *const pRhsSerializedBody, const size_t rhsSerializedBodyLength, int &result) | Activ::Rational | [static]
Compress() | Activ::Rational | [inline]
Convert(const IFieldType *const pIFieldType) | Activ::Rational | [virtual]
Denominator enum name | Activ::Rational |
DENOMINATOR_128TH enum value (defined in Activ::Rational) | Activ::Rational |
DENOMINATOR_16TH enum value (defined in Activ::Rational) | Activ::Rational |
DENOMINATOR_1DP enum value (defined in Activ::Rational) | Activ::Rational |
DENOMINATOR_256TH enum value (defined in Activ::Rational) | Activ::Rational |
DENOMINATOR_2DP enum value (defined in Activ::Rational) | Activ::Rational |
DENOMINATOR_32ND enum value (defined in Activ::Rational) | Activ::Rational |
DENOMINATOR_3DP enum value (defined in Activ::Rational) | Activ::Rational |
DENOMINATOR_4DP enum value (defined in Activ::Rational) | Activ::Rational |
DENOMINATOR_512TH enum value (defined in Activ::Rational) | Activ::Rational |
DENOMINATOR_5DP enum value (defined in Activ::Rational) | Activ::Rational |
DENOMINATOR_64TH enum value (defined in Activ::Rational) | Activ::Rational |
DENOMINATOR_6DP enum value (defined in Activ::Rational) | Activ::Rational |
DENOMINATOR_7DP enum value (defined in Activ::Rational) | Activ::Rational |
DENOMINATOR_8DP enum value (defined in Activ::Rational) | Activ::Rational |
DENOMINATOR_8TH enum value (defined in Activ::Rational) | Activ::Rational |
DENOMINATOR_9DP enum value (defined in Activ::Rational) | Activ::Rational |
DENOMINATOR_CABINET enum value (defined in Activ::Rational) | Activ::Rational |
DENOMINATOR_HALF enum value (defined in Activ::Rational) | Activ::Rational |
DENOMINATOR_QUARTER enum value (defined in Activ::Rational) | Activ::Rational |
DENOMINATOR_UNDEFINED enum value (defined in Activ::Rational) | Activ::Rational |
DENOMINATOR_WHOLE enum value (defined in Activ::Rational) | Activ::Rational |
DENOMINATOR_X1E1 enum value (defined in Activ::Rational) | Activ::Rational |
DENOMINATOR_X1E2 enum value (defined in Activ::Rational) | Activ::Rational |
DENOMINATOR_X1E3 enum value (defined in Activ::Rational) | Activ::Rational |
DENOMINATOR_X1E4 enum value (defined in Activ::Rational) | Activ::Rational |
DENOMINATOR_X1E5 enum value (defined in Activ::Rational) | Activ::Rational |
DENOMINATOR_X1E6 enum value (defined in Activ::Rational) | Activ::Rational |
DENOMINATOR_X1E7 enum value (defined in Activ::Rational) | Activ::Rational |
DENOMINATOR_X1E8 enum value (defined in Activ::Rational) | Activ::Rational |
DENOMINATOR_X1E9 enum value (defined in Activ::Rational) | Activ::Rational |
Deserialize(MessageValidator &messageValidator, const size_t maxSerializedBodyLength) | Activ::Rational | [virtual]
Activ::IFieldType::Deserialize(const FieldType fieldType, MessageValidator &messageValidator, const size_t maxSerializedBodyLength) | Activ::IFieldType |
DeserializeBody(const void *const pSerializedBody, const size_t serializedBodyLength) | Activ::Rational | [virtual]
Activ::IFieldType::DeserializeBody(const FieldType fieldType, const void *const pSerializedBody, const size_t serializedBodyLength) | Activ::IFieldType |
DeserializeLengthAndBody(MessageValidator &messageValidator, const size_t maxSerializedBodyLength=MAX_SERIALIZED_BODY_LENGTH_UNDEFINED) | Activ::Rational | [virtual]
Activ::IFieldType::DeserializeLengthAndBody(const FieldType fieldType, MessageValidator &messageValidator, const size_t maxSerializedBodyLength=MAX_SERIALIZED_BODY_LENGTH_UNDEFINED) | Activ::IFieldType |
Divide(const Rational &rhs, bool isExactCalculation=true) | Activ::Rational |
FIELD_TYPE | Activ::Rational | [static]
FromString(MessageValidator &messageValidator) | Activ::Rational | [virtual]
Activ::IFieldType::FromString(const std::string &field) | Activ::IFieldType | [inline]
Get(int64_t &numerator, Denominator &denominator) const | Activ::Rational | [inline]
Get() const | Activ::Rational | [inline]
GetDenominator() const | Activ::Rational | [inline]
GetDenominatorByBinaryPower(const size_t binaryPower, Denominator &denominator) | Activ::Rational | [static]
GetDenominatorByDecimalPlaces(const size_t nDecimalPlaces, Denominator &denominator) | Activ::Rational | [static]
GetDenominatorByDecimalPower(const size_t decimalPower, Denominator &denominator) | Activ::Rational | [static]
GetDenominatorByDivisor(const uint64_t divisor, Denominator &denominator) | Activ::Rational | [static]
GetDenominatorByMultiplier(const uint64_t multiplier, Denominator &denominator) | Activ::Rational | [static]
GetDenominatorByMultiplierPower(const size_t multiplierPower, Denominator &denominator) | Activ::Rational | [static]
GetDenominatorType(const Denominator denominator, const DenominatorType *&pDenominatorType) | Activ::Rational | [inline, static]
GetDouble(double &value) const | Activ::Rational | [inline]
GetFromStringFormat() const | Activ::Rational | [virtual]
GetLowestCommonDenominator(const Denominator firstDenominator, const Denominator secondDenominator) | Activ::Rational | [static]
GetMaxSerializedBodyLength(const size_t size) | Activ::Rational | [inline, static]
GetMaxSerializedLength(const size_t size) | Activ::Rational | [inline, static]
GetNumerator() const | Activ::Rational | [inline]
GetNumerator(int64_t &numerator, const Denominator denominator) const | Activ::Rational | [inline]
GetNumeratorAndDivisor(int64_t &numerator, uint64_t &divisor) const | Activ::Rational |
GetSerializedBodyLength() const | Activ::Rational | [inline, virtual]
GetSerializedLength() const | Activ::Rational | [inline, virtual]
GetType() const | Activ::IFieldType | [inline]
IFieldType(const FieldType fieldType) | Activ::IFieldType | [inline, explicit, protected]
IsDifferent(const void *const pRhsSerializedBody, const size_t rhsSerializedBodyLength, bool &isDifferent) const | Activ::Rational | [virtual]
IsInitialized() const | Activ::IFieldType | [inline]
IsValidDenominator(Denominator denominator) | Activ::Rational | [inline, static]
IsValidNumerator(int64_t numerator) | Activ::Rational | [inline, static]
IsValidSerializedBodyLength(const size_t serializedBodyLength) | Activ::Rational | [inline, static]
Activ::IFieldType::IsValidSerializedBodyLength(const FieldType fieldType, const size_t serializedBodyLength) | Activ::IFieldType | [static]
m_isInitialized | Activ::IFieldType | [protected]
MAX_NUMERATOR | Activ::Rational | [static]
MAX_SERIALIZED_BODY_LENGTH_UNDEFINED | Activ::IFieldType | [static]
MIN_NUMERATOR | Activ::Rational | [static]
Multiply(const Rational &rhs, bool isExactCalculation=true) | Activ::Rational |
NUMBER_OF_DENOMINATORS enum value (defined in Activ::Rational) | Activ::Rational |
operator *=(const Rational &rhs) | Activ::Rational | [inline]
operator!=(const Rational &rhs) const | Activ::Rational | [inline]
operator+=(const Rational &rhs) | Activ::Rational | [inline]
operator-=(const Rational &rhs) | Activ::Rational | [inline]
operator/=(const Rational &rhs) | Activ::Rational | [inline]
operator<(const Rational &rhs) const | Activ::Rational | [inline]
operator<=(const Rational &rhs) const | Activ::Rational | [inline]
operator==(const Rational &rhs) const | Activ::Rational | [inline]
operator>(const Rational &rhs) const | Activ::Rational | [inline]
operator>=(const Rational &rhs) const | Activ::Rational | [inline]
Rational() | Activ::Rational | [inline]
Rational(const int64_t numerator, const Denominator denominator=DENOMINATOR_WHOLE, bool shouldCompress=false) | Activ::Rational | [inline]
Reset() | Activ::Rational | [inline, virtual]
Serialize(MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength) const | Activ::Rational | [virtual]
Activ::IFieldType::Serialize(const FieldType fieldType, MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength) const | Activ::IFieldType |
Activ::IFieldType::Serialize(const FieldType fieldType, MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength, const uint8_t *const pData, const size_t size) | Activ::IFieldType | [static]
SerializeBody(void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength) const | Activ::Rational | [virtual]
Activ::IFieldType::SerializeBody(const FieldType fieldType, void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength) const | Activ::IFieldType |
Activ::IFieldType::SerializeBody(const FieldType fieldType, void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength, const uint8_t *const pData, const size_t size) | Activ::IFieldType | [static]
SerializeLengthAndBody(MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength=MAX_SERIALIZED_BODY_LENGTH_UNDEFINED) const | Activ::Rational | [virtual]
Activ::IFieldType::SerializeLengthAndBody(const FieldType fieldType, MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength=MAX_SERIALIZED_BODY_LENGTH_UNDEFINED) const | Activ::IFieldType |
Activ::IFieldType::SerializeLengthAndBody(const FieldType fieldType, MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength, const uint8_t *const pData, const size_t size) | Activ::IFieldType | [static]
Set(const int64_t numerator, const Denominator denominator, bool shouldCompress=false) | Activ::Rational | [inline]
SetDenominator(const Denominator denominator) | Activ::Rational | [inline]
Subtract(const Rational &rhs, bool isExactCalculation=true) | Activ::Rational |
ToString() const | Activ::Rational | [virtual]
ToString(const Rational::Denominator denominator) const | Activ::Rational |
TRational (defined in Activ::Rational) | Activ::Rational | [friend]
ValidateSerializedLengthAndBody(MessageValidator &messageValidator, size_t &serializedBodyOffset, size_t &serializedBodyLength) | Activ::Rational | [static]
Activ::IFieldType::ValidateSerializedLengthAndBody(const FieldType fieldType, MessageValidator &messageValidator, size_t &serializedBodyOffset, size_t &serializedBodyLength) | Activ::IFieldType | [static]
~IFieldType()=0 | Activ::IFieldType | [inline, pure virtual]
~Rational() | Activ::Rational | [inline, virtual]

Generated on Wed Oct 8 14:01:58 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Rational::DenominatorType Member List

This is the complete list of members for Activ::Rational::DenominatorType, including all inherited members.

DenominatorType(const uint64_t divisor, const uint64_t multiplier, const size_t nDecimalPlaces, const size_t nDivisorDigits, const size_t multiplierPower) | Activ::Rational::DenominatorType | [inline]
GetDecimalPlaces() const | Activ::Rational::DenominatorType | [inline]
GetDivisor() const | Activ::Rational::DenominatorType | [inline]
GetDivisorDigits() const | Activ::Rational::DenominatorType | [inline]
GetMultiplier() const | Activ::Rational::DenominatorType | [inline]
GetMultiplierPower() const | Activ::Rational::DenominatorType | [inline]
IsDivisor() const | Activ::Rational::DenominatorType | [inline]
IsDivisorBinary() const | Activ::Rational::DenominatorType | [inline]
IsDivisorDecimal() const | Activ::Rational::DenominatorType | [inline]
IsMultiplier() const | Activ::Rational::DenominatorType | [inline]

Generated on Wed Oct 8 14:01:58 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ReferenceCounter Member List

This is the complete list of members for Activ::ReferenceCounter, including all inherited members.

Get() const | Activ::ReferenceCounter | [inline]
operator++() | Activ::ReferenceCounter | [inline]
operator--() | Activ::ReferenceCounter | [inline]
ReferenceCounter() | Activ::ReferenceCounter | [inline]

Generated on Wed Oct 8 14:01:58 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::RegistryHelper Member List

This is the complete list of members for Activ::RegistryHelper, including all inherited members.

DeleteKey(const char *keyName) | Activ::RegistryHelper | [static]
DeleteValue(const char *keyName, const char *valueName) | Activ::RegistryHelper | [static]
EnumerateKeys(const char *keyName) | Activ::RegistryHelper |
EnumerateValues(const char *keyName) | Activ::RegistryHelper |
GetValue(const char *keyName, const char *valueName, uint32_t &value) | Activ::RegistryHelper | [static]
GetValue(const char *keyName, const char *valueName, const char *value, uint_fast32_t maxValueLen) | Activ::RegistryHelper | [static]
GetValue(const char *keyName, const char *valueName, const void *value, uint_fast32_t &maxValueLen) | Activ::RegistryHelper | [static]
SetValue(const char *keyName, const char *valueName, uint32_t value) | Activ::RegistryHelper | [static]
SetValue(const char *keyName, const char *valueName, const char *value) | Activ::RegistryHelper | [static]
SetValue(const char *keyName, const char *valueName, const void *value, uint_fast32_t valueLen) | Activ::RegistryHelper | [static]
Type enum name | Activ::RegistryHelper |
TYPE_BINARY enum value | Activ::RegistryHelper |
TYPE_STRING enum value | Activ::RegistryHelper |
TYPE_UNSIGNED32 enum value | Activ::RegistryHelper |
TYPE_UNSUPPORTED enum value | Activ::RegistryHelper |
~RegistryHelper() | Activ::RegistryHelper | [virtual]

Generated on Wed Oct 8 14:01:58 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::RequestId Member List

This is the complete list of members for Activ::RequestId, including all inherited members.

Attribute typedef | Activ::RequestId |
ATTRIBUTE_NONE (defined in Activ::RequestId) | Activ::RequestId | [static]
ATTRIBUTE_ON (defined in Activ::RequestId) | Activ::RequestId | [static]
ATTRIBUTE_RESPONSE (defined in Activ::RequestId) | Activ::RequestId | [static]
ATTRIBUTE_USE_RESPONSE_ADDRESS (defined in Activ::RequestId) | Activ::RequestId | [static]
Clear() | Activ::RequestId | [inline]
Deserialize(MessageValidator &messageValidator) | Activ::RequestId | [inline]
emptyRequestId | Activ::RequestId | [static]
Get() const | Activ::RequestId | [inline]
GetAttributes() const | Activ::RequestId | [inline]
GetLength() const | Activ::RequestId | [inline]
GetResponseAddress() const | Activ::RequestId | [inline]
MAX_LENGTH (defined in Activ::RequestId) | Activ::RequestId | [static]
MessageModelToString() const | Activ::RequestId | [inline]
MessageModelToString(const Attribute attributes) | Activ::RequestId | [inline, static]
operator!=(const RequestId &rhs) const | Activ::RequestId | [inline]
operator<(const RequestId &rhs) const | Activ::RequestId | [inline]
operator=(const RequestId &rhs) | Activ::RequestId | [inline]
operator==(const RequestId &rhs) const | Activ::RequestId | [inline]
RequestId() | Activ::RequestId | [inline]
RequestId(const void *pData, const size_t dataSize) | Activ::RequestId | [inline]
RequestId(const void *pData, const size_t dataSize, const Address &responseAddress) | Activ::RequestId | [inline]
RequestId(const RequestId &requestId) | Activ::RequestId | [inline]
SendId typedef | Activ::RequestId |
Serialize(MessageBuilder &messageBuilder) const | Activ::RequestId | [inline]
Set(const void *pData, const size_t dataLength) | Activ::RequestId | [inline]
Set(const void *pData, const size_t dataLength, const Address &responseAddress) | Activ::RequestId | [inline]
SetAttributes(Attribute attributes) | Activ::RequestId | [inline]
SetLength(const size_t dataLength) | Activ::RequestId | [inline]
SetResponseAddress(const Address &responseAddress) | Activ::RequestId | [inline]
SyncRequestId (defined in Activ::RequestId) | Activ::RequestId | [friend]
ToString() const | Activ::RequestId | [inline]

Generated on Wed Oct 8 14:01:58 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::RouterServiceApi::Tcp Member List

This is the complete list of members for Activ::RouterServiceApi::Tcp, including all inherited members.

Break(const Component &component, const Address &connectionAddress) | Activ::RouterServiceApi::Tcp | [static]
BreakAll(const Component &component, const Address &serverAddress) | Activ::RouterServiceApi::Tcp | [static]
ClearSocketStatsHighCounts(const Component &component, const Address &circuitAddress) | Activ::RouterServiceApi::Tcp | [static]
Connect(const Component &component, const std::string &url, HeapMessage &connectResponse, IHeap *const pHeap, const TimeoutPeriod timeout, const ISerializableMessage *const pUserData=0) | Activ::RouterServiceApi::Tcp | [static]
Connect(const Component &component, const std::string &url, Address &circuitAddress, IHeap *const pHeap=0, const ISerializableMessage *const pUserData=0) | Activ::RouterServiceApi::Tcp | [static]
DeserializeSocketStats(const HeapMessage &heapMessage, SocketStats &socketStats) | Activ::RouterServiceApi::Tcp | [static]
Disconnect(const Component &component, const Address &circuitAddress, const TimeoutPeriod timeout=0) | Activ::RouterServiceApi::Tcp | [static]
EnableSocketStats(const Component &component, const Address &circuitAddress) | Activ::RouterServiceApi::Tcp | [static]
Listen(const Component &component, const std::string &url, Address &serverAddress, std::vector< std::string > &accessUrlList, IHeap *const pHeap=0) | Activ::RouterServiceApi::Tcp | [static]
Listen(const Component &component, const std::string &url, Address &serverAddress, IHeap *const pHeap=0) | Activ::RouterServiceApi::Tcp | [static]
SetHeap(const Component &component, const Address &address, const IHeap *const pHeap) | Activ::RouterServiceApi::Tcp | [static]
SetMaxTxQueueSize(const Component &component, const Address &address, const size_t numberOfBytes) | Activ::RouterServiceApi::Tcp | [static]
Stop(const Component &component, const Address &serverAddress) | Activ::RouterServiceApi::Tcp | [static]

Generated on Wed Oct 8 14:01:58 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::RouterServiceApi::Tcp::SocketStats Member List

This is the complete list of members for Activ::RouterServiceApi::Tcp::SocketStats, including all inherited members.

m_inTxQueueBytes | Activ::RouterServiceApi::Tcp::SocketStats |
m_inTxQueueHighBytes | Activ::RouterServiceApi::Tcp::SocketStats |
m_inTxQueueHighMessages | Activ::RouterServiceApi::Tcp::SocketStats |
m_inTxQueueMessages | Activ::RouterServiceApi::Tcp::SocketStats |
m_mutexContentionCount | Activ::RouterServiceApi::Tcp::SocketStats |
m_rxBytes | Activ::RouterServiceApi::Tcp::SocketStats |
m_txBytes | Activ::RouterServiceApi::Tcp::SocketStats |
m_txQueueBytes | Activ::RouterServiceApi::Tcp::SocketStats |
m_txQueueHighBytes | Activ::RouterServiceApi::Tcp::SocketStats |
m_txQueueHighMessages | Activ::RouterServiceApi::Tcp::SocketStats |
m_txQueueMessages | Activ::RouterServiceApi::Tcp::SocketStats |
MESSAGE_TYPE (defined in Activ::RouterServiceApi::Tcp::SocketStats) | Activ::RouterServiceApi::Tcp::SocketStats | [static]
SocketStats() | Activ::RouterServiceApi::Tcp::SocketStats |

Generated on Wed Oct 8 14:01:58 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::RouterServiceApi::Udp Member List

This is the complete list of members for Activ::RouterServiceApi::Udp, including all inherited members.

Close(const Component &component, const Address &socketAddress, const bool gracefully=false) | Activ::RouterServiceApi::Udp | [static]
Connect(const Component &component, const Address &socketAddress, const std::string &remoteAddressString, const uint16_t remotePort) | Activ::RouterServiceApi::Udp | [static]
Create(const Component &component, const std::string &localAddress, const uint16_t localPort, const uint16_t maxRxSize, Address &socketAddress, IHeap *const pHeap=0) | Activ::RouterServiceApi::Udp | [static]
Disconnect(const Component &component, const Address &socketAddress) | Activ::RouterServiceApi::Udp | [static]
GetSocketHandle(const Component &component, const Address &socketAddress, SOCKET &socket) | Activ::RouterServiceApi::Udp | [static]
JoinMulticastGroup(const Component &component, const Address &socketAddress, const std::string &multicastGroupString, const std::string &interfaceAddressString) | Activ::RouterServiceApi::Udp | [static]
LeaveMulticastGroup(const Component &component, const Address &socketAddress, const std::string &multicastGroupString, const std::string &interfaceAddressString) | Activ::RouterServiceApi::Udp | [static]
PostData(const Component &component, const Address &socketAddress, HeapMessage &heapMessage) | Activ::RouterServiceApi::Udp | [static]
Read(const Component &component, const Address &socketAddress) | Activ::RouterServiceApi::Udp | [static]
Send(const SOCKET socket, const void *pData, size_t dataLength) | Activ::RouterServiceApi::Udp | [static]
SendTo(const SOCKET socket, const void *pData, size_t dataLength, const IpAddress &toAddress) | Activ::RouterServiceApi::Udp | [static]
SetMulticastLoopback(const Component &component, const Address &socketAddress, const bool enable) | Activ::RouterServiceApi::Udp | [static]
SetMulticastTtl(const Component &component, const Address &socketAddress, const uint32_t ttl) | Activ::RouterServiceApi::Udp | [static]
SetMulticastTxInterface(const Component &component, const Address &socketAddress, const std::string &interfaceAddressString) | Activ::RouterServiceApi::Udp | [static]
SetRxBufferSize(const Component &component, const Address &socketAddress, const uint32_t size) | Activ::RouterServiceApi::Udp | [static]
SetTxBufferSize(const Component &component, const Address &socketAddress, const uint32_t size) | Activ::RouterServiceApi::Udp | [static]
SetUnicastTtl(const Component &component, const Address &socketAddress, const uint32_t ttl) | Activ::RouterServiceApi::Udp | [static]

Generated on Wed Oct 8 14:01:58 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::SInt Member List

This is the complete list of members for Activ::SInt, including all inherited members.

Add(const SInt &rhs) | Activ::SInt |
Assign(const IFieldType *const pIFieldType) | Activ::IFieldType |
Clear() | Activ::SInt | [inline, virtual]
Compare(const SInt &rhs, int &result) const | Activ::SInt |
Compare(const void *const pRhsSerializedBody, const size_t rhsSerializedBodyLength, int &result) const | Activ::SInt | [virtual]
Compare(const void *const pLhsSerializedBody, const size_t lhsSerializedBodyLength, const void *const pRhsSerializedBody, const size_t rhsSerializedBodyLength, int &result) | Activ::SInt | [static]
Convert(const IFieldType *const pIFieldType) | Activ::SInt | [virtual]
Deserialize(MessageValidator &messageValidator, const size_t maxSerializedBodyLength) | Activ::SInt | [virtual]
Activ::IFieldType::Deserialize(const FieldType fieldType, MessageValidator &messageValidator, const size_t maxSerializedBodyLength) | Activ::IFieldType |
DeserializeBody(const void *const pSerializedBody, const size_t serializedBodyLength) | Activ::SInt | [virtual]
Activ::IFieldType::DeserializeBody(const FieldType fieldType, const void *const pSerializedBody, const size_t serializedBodyLength) | Activ::IFieldType |
DeserializeLengthAndBody(MessageValidator &messageValidator, const size_t maxSerializedBodyLength=MAX_SERIALIZED_BODY_LENGTH_UNDEFINED) | Activ::SInt | [virtual]
Activ::IFieldType::DeserializeLengthAndBody(const FieldType fieldType, MessageValidator &messageValidator, const size_t maxSerializedBodyLength=MAX_SERIALIZED_BODY_LENGTH_UNDEFINED) | Activ::IFieldType |
Divide(const SInt &rhs) | Activ::SInt |
FIELD_TYPE | Activ::SInt | [static]
FromString(MessageValidator &messageValidator) | Activ::SInt | [virtual]
Activ::IFieldType::FromString(const std::string &field) | Activ::IFieldType | [inline]
Get(int64_t &value) const | Activ::SInt | [inline]
Get() const | Activ::SInt | [inline]
GetFromStringFormat() const | Activ::SInt | [virtual]
GetMaxSerializedBodyLength(const size_t size) | Activ::SInt | [inline, static]
GetMaxSerializedLength(const size_t size) | Activ::SInt | [inline, static]
GetSerializedBodyLength() const | Activ::SInt | [inline, virtual]
GetSerializedLength() const | Activ::SInt | [inline, virtual]
GetType() const | Activ::IFieldType | [inline]
IFieldType(const FieldType fieldType) | Activ::IFieldType | [inline, explicit, protected]
IsDifferent(const void *const pRhsSerializedBody, const size_t rhsSerializedBodyLength, bool &isDifferent) const | Activ::SInt | [virtual]
IsInitialized() const | Activ::IFieldType | [inline]
IsValidSerializedBodyLength(const size_t serializedBodyLength) | Activ::SInt | [inline, static]
Activ::IFieldType::IsValidSerializedBodyLength(const FieldType fieldType, const size_t serializedBodyLength) | Activ::IFieldType | [static]
m_isInitialized | Activ::IFieldType | [protected]
MAX_SERIALIZED_BODY_LENGTH_UNDEFINED | Activ::IFieldType | [static]
Multiply(const SInt &rhs) | Activ::SInt |
operator *=(const SInt &rhs) | Activ::SInt | [inline]
operator const Rational() const | Activ::SInt |
operator!=(const SInt &rhs) const | Activ::SInt | [inline]
operator+=(const SInt &rhs) | Activ::SInt | [inline]
operator-=(const SInt &rhs) | Activ::SInt | [inline]
operator/=(const SInt &rhs) | Activ::SInt | [inline]
operator<(const SInt &rhs) const | Activ::SInt | [inline]
operator<=(const SInt &rhs) const | Activ::SInt | [inline]
operator==(const SInt &rhs) const | Activ::SInt | [inline]
operator>(const SInt &rhs) const | Activ::SInt | [inline]
operator>=(const SInt &rhs) const | Activ::SInt | [inline]
Reset() | Activ::SInt | [inline, virtual]
Serialize(MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength) const | Activ::SInt | [virtual]
Activ::IFieldType::Serialize(const FieldType fieldType, MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength) const | Activ::IFieldType |
Activ::IFieldType::Serialize(const FieldType fieldType, MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength, const uint8_t *const pData, const size_t size) | Activ::IFieldType | [static]
SerializeBody(void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength) const | Activ::SInt | [virtual]
Activ::IFieldType::SerializeBody(const FieldType fieldType, void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength) const | Activ::IFieldType |
Activ::IFieldType::SerializeBody(const FieldType fieldType, void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength, const uint8_t *const pData, const size_t size) | Activ::IFieldType | [static]
SerializeLengthAndBody(MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength=MAX_SERIALIZED_BODY_LENGTH_UNDEFINED) const | Activ::SInt | [virtual]
Activ::IFieldType::SerializeLengthAndBody(const FieldType fieldType, MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength=MAX_SERIALIZED_BODY_LENGTH_UNDEFINED) const | Activ::IFieldType |
Activ::IFieldType::SerializeLengthAndBody(const FieldType fieldType, MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength, const uint8_t *const pData, const size_t size) | Activ::IFieldType | [static]
Set(const int64_t value) | Activ::SInt | [inline]
SInt() | Activ::SInt | [inline]
SInt(const int64_t value) | Activ::SInt | [inline]
Subtract(const SInt &rhs) | Activ::SInt |
ToString() const | Activ::SInt | [virtual]
ValidateSerializedLengthAndBody(MessageValidator &messageValidator, size_t &serializedBodyOffset, size_t &serializedBodyLength) | Activ::SInt | [static]
Activ::IFieldType::ValidateSerializedLengthAndBody(const FieldType fieldType, MessageValidator &messageValidator, size_t &serializedBodyOffset, size_t &serializedBodyLength) | Activ::IFieldType | [static]
~IFieldType()=0 | Activ::IFieldType | [inline, pure virtual]
~SInt() | Activ::SInt | [inline, virtual]

Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ScatterBufferHelper Member List

This is the complete list of members for Activ::ScatterBufferHelper, including all inherited members.

AdjustGetBufferSize(const size_t getBufferSize) const | Activ::ScatterBufferHelper |
Attach(void *pData, const size_t dataLength) | Activ::ScatterBufferHelper |
Attach(const ScatterBufferHelper &from, const size_t fromOffset, const size_t dataLength) | Activ::ScatterBufferHelper |
Begin() const | Activ::ScatterBufferHelper | [inline]
Copy(const size_t offset, void *pData, const size_t dataLength) const | Activ::ScatterBufferHelper |
Copy(void *pData, const size_t dataSize, size_t &dataLength) const | Activ::ScatterBufferHelper |
End() const | Activ::ScatterBufferHelper | [inline]
Get(const size_t offset, const void *&pData, const size_t dataLength, void *pGetBuffer=0) const | Activ::ScatterBufferHelper |
Get(const void *&pData, size_t &dataLength, void *pGetBuffer=0, const size_t getBufferSize=0) const | Activ::ScatterBufferHelper |
Get(const size_t offset, const void *&pData, const size_t dataLength, size_t &dataLengthRead) const | Activ::ScatterBufferHelper |
GetNumberOfScatterBuffersInUse() const | Activ::ScatterBufferHelper | [inline]
GetTotalBytes() const | Activ::ScatterBufferHelper | [inline]
operator=(const ScatterBufferHelper &rhs) | Activ::ScatterBufferHelper |
Reset(const size_t nInitialScatterBuffers) | Activ::ScatterBufferHelper | [inline]
Reset() | Activ::ScatterBufferHelper | [inline]
ScatterBufferHelper(const size_t nInitialScatterBuffers=5, const size_t initialGetBufferSize=0) | Activ::ScatterBufferHelper |
ScatterBufferHelper(const ScatterBufferHelper &rhs) | Activ::ScatterBufferHelper |
Set(const size_t offset, const void *pData, const size_t dataLength) | Activ::ScatterBufferHelper |
Set(const size_t offset, const ScatterBufferHelper &from, const size_t fromOffset, const size_t dataLength) | Activ::ScatterBufferHelper |
~ScatterBufferHelper() | Activ::ScatterBufferHelper | [inline]

Generated on Wed Oct 8 14:01:58 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ScatterBufferHelper::ConstIterator Member List

This is the complete list of members for Activ::ScatterBufferHelper::ConstIterator, including all inherited members.

ConstIterator() | Activ::ScatterBufferHelper::ConstIterator | [inline]
operator *() const | Activ::ScatterBufferHelper::ConstIterator | [inline]
operator!=(const ConstIterator &rhs) const | Activ::ScatterBufferHelper::ConstIterator | [inline]
operator++() | Activ::ScatterBufferHelper::ConstIterator | [inline]
operator++(int) | Activ::ScatterBufferHelper::ConstIterator | [inline]
operator->() const | Activ::ScatterBufferHelper::ConstIterator | [inline]
operator==(const ConstIterator &rhs) const | Activ::ScatterBufferHelper::ConstIterator | [inline]
ScatterBufferHelper (defined in Activ::ScatterBufferHelper::ConstIterator) | Activ::ScatterBufferHelper::ConstIterator | [friend]

Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ScatterBufferHelper::ScatterBuffer Member List

This is the complete list of members for Activ::ScatterBufferHelper::ScatterBuffer, including all inherited members.

m_dataLength | Activ::ScatterBufferHelper::ScatterBuffer
m_pData | Activ::ScatterBufferHelper::ScatterBuffer

Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ScopedAddress Member List

This is the complete list of members for Activ::ScopedAddress, including all inherited members.

Clear() | Activ::ScopedAddress |
IsValid() const | Activ::ScopedAddress | [inline]
operator const Address &() const | Activ::ScopedAddress | [inline]
operator Proxy() | Activ::ScopedAddress | [inline]
operator!=(const Address &rhs) const | Activ::ScopedAddress | [inline]
operator=(const Address &rhs) | Activ::ScopedAddress | [inline]
operator=(ScopedAddress &rhs) | Activ::ScopedAddress | [inline]
operator==(const Address &rhs) const | Activ::ScopedAddress | [inline]
Release() | Activ::ScopedAddress | [inline]
ScopedAddress(Port &port) | Activ::ScopedAddress | [inline]
ScopedAddress(Port &port, const Address &address) | Activ::ScopedAddress | [inline]
ScopedAddress(ScopedAddress &scopedAddress) | Activ::ScopedAddress | [inline]
ToString() const | Activ::ScopedAddress | [inline]
~ScopedAddress() | Activ::ScopedAddress | [inline]

Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ScopedAddress::Proxy Member List

This is the complete list of members for Activ::ScopedAddress::Proxy, including all inherited members.

operator Address &() | Activ::Address::Proxy | [inline]
Proxy(ScopedAddress &scopedAddress) | Activ::ScopedAddress::Proxy | [inline]
Activ::Address::Proxy::Proxy(Address &address) | Activ::Address::Proxy | [inline]
~Proxy() | Activ::ScopedAddress::Proxy | [inline]

Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ScopedFd Member List

This is the complete list of members for Activ::ScopedFd, including all inherited members.

Condition typedef | Activ::ScopedHelper< int, boost::function< int(int)> > |
operator int() | Activ::ScopedHelper< int, boost::function< int(int)> > | [inline]
ScopedFd(int fd) (defined in Activ::ScopedFd) | Activ::ScopedFd | [inline]
ScopedHelper(intobject, boost::function< int(int)>destructor, Condition condition=True()) | Activ::ScopedHelper< int, boost::function< int(int)> > | [inline]
~ScopedHelper() | Activ::ScopedHelper< int, boost::function< int(int)> > | [inline]

Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ScopedFile Member List

This is the complete list of members for Activ::ScopedFile, including all inherited members.

Condition typedef | Activ::ScopedHelper< FILE *, boost::function< int(FILE *)> > |
operator FILE *() | Activ::ScopedHelper< FILE *, boost::function< int(FILE *)> > | [inline]
ScopedFile(FILE *pFile) (defined in Activ::ScopedFile) | Activ::ScopedFile | [inline]
ScopedHelper(FILE *object, boost::function< int(FILE *)>destructor, Condition condition=True()) | Activ::ScopedHelper< FILE *, boost::function< int(FILE *)> > | [inline]
~ScopedHelper() | Activ::ScopedHelper< FILE *, boost::function< int(FILE *)> > | [inline]

Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ScopedHandle Member List

This is the complete list of members for Activ::ScopedHandle, including all inherited members.

Condition typedef | Activ::ScopedHelper< HANDLE, boost::function< BOOL(HANDLE)> > |
operator HANDLE() | Activ::ScopedHelper< HANDLE, boost::function< BOOL(HANDLE)> > | [inline]
ScopedHandle(HANDLE handle) (defined in Activ::ScopedHandle) | Activ::ScopedHandle | [inline]
ScopedHelper(HANDLEobject, boost::function< BOOL(HANDLE)>destructor, Condition condition=True()) | Activ::ScopedHelper< HANDLE, boost::function< BOOL(HANDLE)> > | [inline]
~ScopedHelper() | Activ::ScopedHelper< HANDLE, boost::function< BOOL(HANDLE)> > | [inline]

Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ScopedHandle::IsValidHandle Member List

This is the complete list of members for Activ::ScopedHandle::IsValidHandle, including all inherited members.

operator()(const HANDLE handle) (defined in Activ::ScopedHandle::IsValidHandle) Activ::ScopedHandle::IsValidHandle [inline]

Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ScopedHelper< T, D > Member List

This is the complete list of members for Activ::ScopedHelper< T, D >, including all inherited members.

Condition typedef | Activ::ScopedHelper< T, D > |
operator T() | Activ::ScopedHelper< T, D > | [inline]
ScopedHelper(T object, D destructor, Condition condition=True()) | Activ::ScopedHelper< T, D > | [inline]
~ScopedHelper() | Activ::ScopedHelper< T, D > | [inline]

Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ScopedHelper< T, D >::True Member List

This is the complete list of members for Activ::ScopedHelper< T, D >::True, including all inherited members.

operator()(T) const (defined in Activ::ScopedHelper< T, D >::True) Activ::ScopedHelper< T, D >::True [inline]

Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ScopedMemory< T > Member List

This is the complete list of members for Activ::ScopedMemory< T >, including all inherited members.

Condition typedef | Activ::ScopedHelper< T, boost::function< void(void *)> > |
operator T() | Activ::ScopedHelper< T, boost::function< void(void *)> > | [inline]
ScopedHelper(Tobject, boost::function< void(void *)>destructor, Condition condition=True()) | Activ::ScopedHelper< T, boost::function< void(void *)> > | [inline]
ScopedMemory(void *pMem) | Activ::ScopedMemory< T > | [inline]
~ScopedHelper() | Activ::ScopedHelper< T, boost::function< void(void *)> > | [inline]

Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ScopedMutexLocker Member List

This is the complete list of members for Activ::ScopedMutexLocker, including all inherited members.

ScopedMutexLocker(const IMutex *const pMutex) | Activ::ScopedMutexLocker | [inline]
~ScopedMutexLocker() | Activ::ScopedMutexLocker | [inline]

Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ScopedMutexTryLocker Member List

This is the complete list of members for Activ::ScopedMutexTryLocker, including all inherited members.

Acquire() | Activ::ScopedMutexTryLocker | [inline]
operator bool() const | Activ::ScopedMutexTryLocker | [inline]
operator!() const | Activ::ScopedMutexTryLocker | [inline]
ScopedMutexTryLocker(const IMutex *const pMutex) | Activ::ScopedMutexTryLocker | [inline]
~ScopedMutexTryLocker() | Activ::ScopedMutexTryLocker | [inline]

Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ScopedPooledObject< T > Member List

This is the complete list of members for Activ::ScopedPooledObject< T >, including all inherited members.

ObjectType typedef (defined in Activ::ScopedPooledObject< T >) | Activ::ScopedPooledObject< T > |
operator()() | Activ::ScopedPooledObject< T > | [inline]
operator()() const | Activ::ScopedPooledObject< T > | [inline]
ScopedPooledObject() | Activ::ScopedPooledObject< T > | [inline]
~ScopedPooledObject() | Activ::ScopedPooledObject< T > | [inline]

Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ScopedSocket Member List

This is the complete list of members for Activ::ScopedSocket, including all inherited members.

Condition typedef | Activ::ScopedHelper< SOCKET, boost::function< int(SOCKET)> > |
operator SOCKET() | Activ::ScopedHelper< SOCKET, boost::function< int(SOCKET)> > | [inline]
ScopedHelper(SOCKETobject, boost::function< int(SOCKET)>destructor, Condition condition=True()) | Activ::ScopedHelper< SOCKET, boost::function< int(SOCKET)> > | [inline]
ScopedSocket(SOCKET socket) (defined in Activ::ScopedSocket) | Activ::ScopedSocket | [inline]
~ScopedHelper() | Activ::ScopedHelper< SOCKET, boost::function< int(SOCKET)> > | [inline]

Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ScopedSubscription Member List

This is the complete list of members for Activ::ScopedSubscription, including all inherited members.

ScopedSubscription(const Component &component, const AgentScope agentScope, const Subject &subject) | Activ::ScopedSubscription
Unsubscribe() | Activ::ScopedSubscription
~ScopedSubscription() | Activ::ScopedSubscription

Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::SelectFirst< P > Member List

This is the complete list of members for Activ::SelectFirst< P >, including all inherited members.

Base typedef (defined in Activ::SelectFirst< P >) | Activ::SelectFirst< P > |
operator()(const typename Base::argument_type &p) const | Activ::SelectFirst< P > | [inline]

Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::SelectFirstFromSecond< P > Member List

This is the complete list of members for Activ::SelectFirstFromSecond< P >, including all inherited members.

Base typedef (defined in Activ::SelectFirstFromSecond< P >) | Activ::SelectFirstFromSecond< P > |
operator()(const typename Base::argument_type &second) const | Activ::SelectFirstFromSecond< P > | [inline]
Pair typedef (defined in Activ::SelectFirstFromSecond< P >) | Activ::SelectFirstFromSecond< P > |

Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::SelectSecond< P > Member List

This is the complete list of members for Activ::SelectSecond< P >, including all inherited members.

Base typedef (defined in Activ::SelectSecond< P >) | Activ::SelectSecond< P > |
operator()(const typename Base::argument_type &p) const | Activ::SelectSecond< P > | [inline]

Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::SerializableBuffer< LENGTH_TYPE, MIN_LENGTH, MAX_LENGTH > Member List

This is the complete list of members for Activ::SerializableBuffer< LENGTH_TYPE, MIN_LENGTH, MAX_LENGTH >, including all inherited members.

Deserialize(MessageValidator &messageValidator) | Activ::SerializableBuffer< LENGTH_TYPE, MIN_LENGTH, MAX_LENGTH > | [inline]
GetData() const | Activ::SerializableBuffer< LENGTH_TYPE, MIN_LENGTH, MAX_LENGTH > | [inline]
GetDataLength() const | Activ::SerializableBuffer< LENGTH_TYPE, MIN_LENGTH, MAX_LENGTH > | [inline]
Length typedef (defined in Activ::SerializableBuffer< LENGTH_TYPE, MIN_LENGTH, MAX_LENGTH >) | Activ::SerializableBuffer< LENGTH_TYPE, MIN_LENGTH, MAX_LENGTH > |
operator=(const SerializableBuffer &rhs) | Activ::SerializableBuffer< LENGTH_TYPE, MIN_LENGTH, MAX_LENGTH > | [inline]
SerializableBuffer() | Activ::SerializableBuffer< LENGTH_TYPE, MIN_LENGTH, MAX_LENGTH > | [inline]
SerializableBuffer(const SerializableBuffer &serializableBuffer) | Activ::SerializableBuffer< LENGTH_TYPE, MIN_LENGTH, MAX_LENGTH > | [inline]
Serialize(MessageBuilder &messageBuilder, const void *const pData, const size_t dataLength) | Activ::SerializableBuffer< LENGTH_TYPE, MIN_LENGTH, MAX_LENGTH > | [inline, static]
Serialize(MessageBuilder &messageBuilder) const | Activ::SerializableBuffer< LENGTH_TYPE, MIN_LENGTH, MAX_LENGTH > | [inline]
Set(const void *pData, const size_t dataLength, const bool shouldCopy) | Activ::SerializableBuffer< LENGTH_TYPE, MIN_LENGTH, MAX_LENGTH > | [inline]
~SerializableBuffer() | Activ::SerializableBuffer< LENGTH_TYPE, MIN_LENGTH, MAX_LENGTH > | [inline]

Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::SerializableContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER > Member List

This is the complete list of members for Activ::SerializableContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >, including all inherited members.

Container typedef (defined in Activ::SerializableContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >) | Activ::SerializableContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER > |
Deserialize(MessageValidator &messageValidator, Container &container, const bool shouldClearContainer) | Activ::SerializableContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER > | [inline, static]
Serialize(MessageBuilder &messageBuilder, const Container &container) | Activ::SerializableContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER > | [inline, static]

Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::SerializableContainerHelper< hash_map< KEY_TYPE, MAPPED_TYPE, HASH_FN >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER > Member List

This is the complete list of members for Activ::SerializableContainerHelper< hash_map< KEY_TYPE, MAPPED_TYPE, HASH_FN >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >, including all inherited members.

Count typedef (defined in Activ::SerializableContainerHelper< hash_map< KEY_TYPE, MAPPED_TYPE, HASH_FN >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >) | Activ::SerializableContainerHelper< hash_map< KEY_TYPE, MAPPED_TYPE, HASH_FN >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER > |
Deserialize(MessageValidator &messageValidator, Map &map, const bool shouldClearContainer) | Activ::SerializableContainerHelper< hash_map< KEY_TYPE, MAPPED_TYPE, HASH_FN >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER > | [inline, static]
Map typedef (defined in Activ::SerializableContainerHelper< hash_map< KEY_TYPE, MAPPED_TYPE, HASH_FN >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >) | Activ::SerializableContainerHelper< hash_map< KEY_TYPE, MAPPED_TYPE, HASH_FN >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER > |
ObjectHelper typedef (defined in Activ::SerializableContainerHelper< hash_map< KEY_TYPE, MAPPED_TYPE, HASH_FN >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >) | Activ::SerializableContainerHelper< hash_map< KEY_TYPE, MAPPED_TYPE, HASH_FN >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER > |
Serialize(MessageBuilder &messageBuilder, const Map &map) | Activ::SerializableContainerHelper< hash_map< KEY_TYPE, MAPPED_TYPE, HASH_FN >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER > | [inline, static]

Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::SerializableContainerHelper< std::list< OBJECT_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER > Member List

This is the complete list of members for Activ::SerializableContainerHelper< std::list< OBJECT_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >, including all inherited members.

Count typedef (defined in Activ::SerializableContainerHelper< std::list< OBJECT_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >) | Activ::SerializableContainerHelper< std::list< OBJECT_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER > |
Deserialize(MessageValidator &messageValidator, List &list, const bool shouldClearContainer) | Activ::SerializableContainerHelper< std::list< OBJECT_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER > | [inline, static]
List typedef (defined in Activ::SerializableContainerHelper< std::list< OBJECT_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >) | Activ::SerializableContainerHelper< std::list< OBJECT_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER > |
ObjectHelper typedef (defined in Activ::SerializableContainerHelper< std::list< OBJECT_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >) | Activ::SerializableContainerHelper< std::list< OBJECT_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER > |
Serialize(MessageBuilder &messageBuilder, const List &list) | Activ::SerializableContainerHelper< std::list< OBJECT_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER > | [inline, static]

Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::SerializableContainerHelper< std::map< KEY_TYPE, MAPPED_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER > Member List

This is the complete list of members for Activ::SerializableContainerHelper< std::map< KEY_TYPE, MAPPED_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >, including all inherited members.

Count typedef (defined in Activ::SerializableContainerHelper< std::map< KEY_TYPE, MAPPED_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >) | Activ::SerializableContainerHelper< std::map< KEY_TYPE, MAPPED_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER > |
Deserialize(MessageValidator &messageValidator, Map &map, const bool shouldClearContainer) | Activ::SerializableContainerHelper< std::map< KEY_TYPE, MAPPED_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER > | [inline, static]
Map typedef (defined in Activ::SerializableContainerHelper< std::map< KEY_TYPE, MAPPED_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >) | Activ::SerializableContainerHelper< std::map< KEY_TYPE, MAPPED_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER > |
ObjectHelper typedef (defined in Activ::SerializableContainerHelper< std::map< KEY_TYPE, MAPPED_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >) | Activ::SerializableContainerHelper< std::map< KEY_TYPE, MAPPED_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER > |
Serialize(MessageBuilder &messageBuilder, const Map &map) | Activ::SerializableContainerHelper< std::map< KEY_TYPE, MAPPED_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER > | [inline, static]

Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::SerializableContainerHelper< std::set< OBJECT_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER > Member List

This is the complete list of members for Activ::SerializableContainerHelper< std::set< OBJECT_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >, including all inherited members.

Count typedef (defined in Activ::SerializableContainerHelper< std::set< OBJECT_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >) | Activ::SerializableContainerHelper< std::set< OBJECT_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER > |
Deserialize(MessageValidator &messageValidator, Set &set, const bool shouldClearContainer) | Activ::SerializableContainerHelper< std::set< OBJECT_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER > | [inline, static]
ObjectHelper typedef (defined in Activ::SerializableContainerHelper< std::set< OBJECT_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >) | Activ::SerializableContainerHelper< std::set< OBJECT_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER > |
Serialize(MessageBuilder &messageBuilder, const Set &set) | Activ::SerializableContainerHelper< std::set< OBJECT_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER > | [inline, static]
Set typedef (defined in Activ::SerializableContainerHelper< std::set< OBJECT_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >) | Activ::SerializableContainerHelper< std::set< OBJECT_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER > |

Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::SerializableContainerHelper< std::vector< OBJECT_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER > Member List

This is the complete list of members for Activ::SerializableContainerHelper< std::vector< OBJECT_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >, including all inherited members.

Count typedef (defined in Activ::SerializableContainerHelper< std::vector< OBJECT_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >) | Activ::SerializableContainerHelper< std::vector< OBJECT_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER > |
Deserialize(MessageValidator &messageValidator, Vector &vector, const bool shouldClearContainer) | Activ::SerializableContainerHelper< std::vector< OBJECT_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER > | [inline, static]
ObjectHelper typedef (defined in Activ::SerializableContainerHelper< std::vector< OBJECT_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >) | Activ::SerializableContainerHelper< std::vector< OBJECT_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER > |
Serialize(MessageBuilder &messageBuilder, const Vector &vector) | Activ::SerializableContainerHelper< std::vector< OBJECT_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER > | [inline, static]
Vector typedef (defined in Activ::SerializableContainerHelper< std::vector< OBJECT_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >) | Activ::SerializableContainerHelper< std::vector< OBJECT_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER > |

Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::SerializableObjectContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH > Member List

This is the complete list of members for Activ::SerializableObjectContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH >, including all inherited members.

Container typedef (defined in Activ::SerializableContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >) | Activ::SerializableContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER > |
Deserialize(MessageValidator &messageValidator, Container &container, const bool shouldClearContainer) | Activ::SerializableContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER > | [inline, static]
Serialize(MessageBuilder &messageBuilder, const Container &container) | Activ::SerializableContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER > | [inline, static]

Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::SerializableObjectContainerHelper< hash_map< KEY_TYPE, MAPPED_TYPE, HASH_FN >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH > Member List

This is the complete list of members for Activ::SerializableObjectContainerHelper< hash_map< KEY_TYPE, MAPPED_TYPE, HASH_FN >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH >, including all inherited members.

Container typedef (defined in Activ::SerializableContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >) | Activ::SerializableContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER > |
Deserialize(MessageValidator &messageValidator, Container &container, const bool shouldClearContainer) | Activ::SerializableContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER > | [inline, static]
Serialize(MessageBuilder &messageBuilder, const Container &container) | Activ::SerializableContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER > | [inline, static]

Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::SerializableObjectContainerHelper< std::map< KEY_TYPE, MAPPED_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH > Member List

This is the complete list of members for Activ::SerializableObjectContainerHelper< std::map< KEY_TYPE, MAPPED_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH >, including all inherited members.

Container typedef (defined in Activ::SerializableContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >) | Activ::SerializableContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER > |
Deserialize(MessageValidator &messageValidator, Container &container, const bool shouldClearContainer) | Activ::SerializableContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER > | [inline, static]
Serialize(MessageBuilder &messageBuilder, const Container &container) | Activ::SerializableContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER > | [inline, static]

Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::SerializableObjectHelper< OBJECT_TYPE > Member List

This is the complete list of members for Activ::SerializableObjectHelper< OBJECT_TYPE >, including all inherited members.

Deserialize(MessageValidator &messageValidator, OBJECT_TYPE &object) | Activ::SerializableObjectHelper< OBJECT_TYPE > | [inline, static]
Serialize(MessageBuilder &messageBuilder, const OBJECT_TYPE &object) | Activ::SerializableObjectHelper< OBJECT_TYPE > | [inline, static]

Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::SerializableRawPointerContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH > Member List

This is the complete list of members for Activ::SerializableRawPointerContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH >, including all inherited members.

Container typedef (defined in Activ::SerializableContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >) | Activ::SerializableContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER > |
Deserialize(MessageValidator &messageValidator, Container &container, const bool shouldClearContainer) | Activ::SerializableContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER > | [inline, static]
Serialize(MessageBuilder &messageBuilder, const Container &container) | Activ::SerializableContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER > | [inline, static]

Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::SerializableRawPointerContainerHelper< hash_map< KEY_TYPE, MAPPED_TYPE, HASH_FN >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH > Member List

This is the complete list of members for Activ::SerializableRawPointerContainerHelper< hash_map< KEY_TYPE, MAPPED_TYPE, HASH_FN >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH >, including all inherited members.

Container typedef (defined in Activ::SerializableContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >) | Activ::SerializableContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER > |
Deserialize(MessageValidator &messageValidator, Container &container, const bool shouldClearContainer) | Activ::SerializableContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER > | [inline, static]
Serialize(MessageBuilder &messageBuilder, const Container &container) | Activ::SerializableContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER > | [inline, static]

Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::SerializableRawPointerContainerHelper< std::map< KEY_TYPE, MAPPED_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH > Member List

This is the complete list of members for Activ::SerializableRawPointerContainerHelper< std::map< KEY_TYPE, MAPPED_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH >, including all inherited members.

Container typedef (defined in Activ::SerializableContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >) | Activ::SerializableContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER > |
Deserialize(MessageValidator &messageValidator, Container &container, const bool shouldClearContainer) | Activ::SerializableContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER > | [inline, static]
Serialize(MessageBuilder &messageBuilder, const Container &container) | Activ::SerializableContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER > | [inline, static]

Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::SerializableRawPointerHelper< POINTER_TYPE > Member List

This is the complete list of members for Activ::SerializableRawPointerHelper< POINTER_TYPE >, including all inherited members.

Deserialize(MessageValidator &messageValidator, POINTER_TYPE &pObject) | Activ::SerializableRawPointerHelper< POINTER_TYPE > | [inline, static]
ObjectType typedef (defined in Activ::SerializableRawPointerHelper< POINTER_TYPE >) | Activ::SerializableRawPointerHelper< POINTER_TYPE > |
Serialize(MessageBuilder &messageBuilder, const POINTER_TYPE &pObject) | Activ::SerializableRawPointerHelper< POINTER_TYPE > | [inline, static]

Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::SerializableSmartPointerContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH > Member List

This is the complete list of members for Activ::SerializableSmartPointerContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH >, including all inherited members.

Container typedef (defined in Activ::SerializableContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >) | Activ::SerializableContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER > |
Deserialize(MessageValidator &messageValidator, Container &container, const bool shouldClearContainer) | Activ::SerializableContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER > | [inline, static]
Serialize(MessageBuilder &messageBuilder, const Container &container) | Activ::SerializableContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER > | [inline, static]

Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::SerializableSmartPointerContainerHelper< hash_map< KEY_TYPE, MAPPED_TYPE, HASH_FN >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH > Member List

This is the complete list of members for Activ::SerializableSmartPointerContainerHelper< hash_map< KEY_TYPE, MAPPED_TYPE, HASH_FN >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH >, including all inherited members.

Container typedef (defined in Activ::SerializableContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >) | Activ::SerializableContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER > |
Deserialize(MessageValidator &messageValidator, Container &container, const bool shouldClearContainer) | Activ::SerializableContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER > | [inline, static]
Serialize(MessageBuilder &messageBuilder, const Container &container) | Activ::SerializableContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER > | [inline, static]

Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::SerializableSmartPointerContainerHelper< std::map< KEY_TYPE, MAPPED_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH > Member List

This is the complete list of members for Activ::SerializableSmartPointerContainerHelper< std::map< KEY_TYPE, MAPPED_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH >, including all inherited members.

Container typedef (defined in Activ::SerializableContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >) | Activ::SerializableContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER > |
Deserialize(MessageValidator &messageValidator, Container &container, const bool shouldClearContainer) | Activ::SerializableContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER > | [inline, static]
Serialize(MessageBuilder &messageBuilder, const Container &container) | Activ::SerializableContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER > | [inline, static]

Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::SerializableSmartPointerHelper< POINTER_TYPE > Member List

This is the complete list of members for Activ::SerializableSmartPointerHelper< POINTER_TYPE >, including all inherited members.

Deserialize(MessageValidator &messageValidator, POINTER_TYPE &pObject) | Activ::SerializableSmartPointerHelper< POINTER_TYPE > | [inline, static]
ObjectType typedef | Activ::SerializableSmartPointerHelper< POINTER_TYPE > |
Serialize(MessageBuilder &messageBuilder, const POINTER_TYPE &pObject) | Activ::SerializableSmartPointerHelper< POINTER_TYPE > | [inline, static]

Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Service Member List

This is the complete list of members for Activ::Service, including all inherited members.

anonymousName | Activ::Port | [static]
BuildOpenServiceResponse(HeapMessage &acceptMessage, OpenServiceResponse &openServiceResponse, const byte_t openServiceVersion) const | Activ::Service | [protected]
Close() | Activ::Service |
Component(Application &application, ManagedEndPoint &managedEndPoint, const std::string &name=anonymousName, IHeap *const pHeap=0, const std::string &componentId=defaultComponentId) | Activ::Component |
defaultComponentId | Activ::Component | [static]
defaultTimeout | Activ::Port | [static]
Deregister() | Activ::Service | [virtual]
Disable() | Activ::Port |
emptyServiceAccessPointList | Activ::Service | [static]
Enable() | Activ::Port |
FindPort(const std::string &endPointName, const std::string &portName, Address &portAddress, const TimeoutPeriod timeout=defaultTimeout) | Activ::Port |
ForwardMessage(const Address &destinationAddress, HeapMessage &message, const MessageType newType=INVALID_MESSAGE_TYPE) const | Activ::Port |
GetAddress() const | Activ::Port | [inline]
GetApplication() const | Activ::Component |
GetHeap() const | Activ::Port | [inline]
GetManagedEndPoint() const | Activ::Port |
GetName() const | Activ::Port |
GetServiceInstance() const | Activ::Service |
ManagedEndPoint::Impl (defined in Activ::Port) | Activ::Port | [friend]
OnAccept(HeapMessage &acceptMessage) | Activ::Service | [protected, virtual]
OnBreak(HeapMessage &breakMessage) | Activ::Component | [protected, virtual]
OnConnect(HeapMessage &connectMessage) | Activ::Component | [protected, virtual]
OnConnectFailed(HeapMessage &connectFailMessage) | Activ::Component | [protected, virtual]
OnData(HeapMessage &heapMessage) | Activ::Component | [protected, virtual]
OnDisconnect(HeapMessage &disconnectMessage) | Activ::Component | [protected, virtual]
OnMessage(HeapMessage &message) | Activ::Component | [protected, virtual]
OnRequest(HeapMessage &request) | Activ::Component | [protected, virtual]
OnResponse(HeapMessage &response) | Activ::Port | [protected, virtual]
OnTimer(const Address &timerAddress, const BaseTime &time) | Activ::Component | [protected, virtual]
Port(ManagedEndPoint &managedEndPoint, const std::string &name, IHeap *const pHeap) | Activ::Port |
Port(ManagedEndPoint &managedEndPoint, const std::string &name, const PortId portId, IHeap *const pHeap) | Activ::Port |
PostEmptyResponse(const StatusCode responseStatus, HeapMessage &response) const | Activ::Port |
PostEmptyResponse(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, const StatusCode responseStatus, HeapMessage &response) const | Activ::Port |
PostMessage(const Address &destinationAddress, const MessageType messageType, const MessageBuilder &messageBuilder) const | Activ::Port |
PostMessage(const Address &destinationAddress, const MessageType messageType, const void *pMessage=0, const size_t messageLength=0) const | Activ::Port |
PostMessage(const Address &destinationAddress, const MessageType messageType, HeapMessage &message) const | Activ::Port |
PostRequest(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, const MessageBuilder &messageBuilder) const | Activ::Port |
PostRequest(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, const void *pRequest=0, const size_t requestLength=0) const | Activ::Port |
PostRequest(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, HeapMessage &request) const | Activ::Port |
PostResponse(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, const StatusCode responseStatus, const MessageBuilder &messageBuilder) const | Activ::Port |
PostResponse(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, const StatusCode responseStatus, const void *pResponse=0, const size_t responseLength=0) const | Activ::Port |
PostResponse(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, const StatusCode responseStatus, HeapMessage &response) const | Activ::Port |
PostResponse(const StatusCode responseStatus, HeapMessage &request, const MessageBuilder &messageBuilder) const | Activ::Port |
PostResponse(const StatusCode responseStatus, HeapMessage &request, const void *pResponse, const size_t responseLength) const | Activ::Port |
PostResponse(const StatusCode responseStatus, HeapMessage &request, HeapMessage &response) const | Activ::Port |
PostResponse(const StatusCode responseStatus, HeapMessage &request) const | Activ::Port |
ProcessOpenServiceRequest(HeapMessage &acceptMessage) | Activ::Service | [protected, virtual]
Register() | Activ::Service | [virtual]
SendRequest(const Address &destinationAddress, const MessageType requestType, const MessageBuilder &messageBuilder, HeapMessage &response, const TimeoutPeriod timeout=defaultTimeout) const | Activ::Port |
SendRequest(const Address &destinationAddress, const MessageType requestType, const void *pRequest, const size_t requestLength, HeapMessage &response, const TimeoutPeriod timeout=defaultTimeout) const | Activ::Port |
SendRequest(const Address &destinationAddress, const MessageType requestType, HeapMessage &request, const TimeoutPeriod timeout=defaultTimeout) const | Activ::Port |
SendRequest(const Address &destinationAddress, const MessageType requestType, SyncRequestId &syncRequestId, const MessageBuilder &messageBuilder) const | Activ::Port |
SendRequest(const Address &destinationAddress, const MessageType requestType, SyncRequestId &syncRequestId, const void *pRequest, const size_t requestLength) const | Activ::Port |
SendRequest(const Address &destinationAddress, const MessageType requestType, SyncRequestId &syncRequestId, HeapMessage &request) const | Activ::Port |
Service(Application &application, ManagedEndPoint &managedEndPoint, const std::string &name, const ServiceInstance &serviceInstance, IHeap *const pHeap=0, const std::string &componentId=defaultComponentId) | Activ::Service |
SetHeap(IHeap *const pHeap) | Activ::Port |
ValidateOpenServiceRequest(const HeapMessage &acceptMessage, OpenServiceRequest &openServiceRequest) const | Activ::Service | [protected]
~Component() | Activ::Component |
~Port() | Activ::Port | [virtual]
~Service() | Activ::Service |

Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ServiceAccessPoint Member List

This is the complete list of members for Activ::ServiceAccessPoint, including all inherited members.

Clear() | Activ::ServiceAccessPoint
m_agentScope (defined in Activ::ServiceAccessPoint) | Activ::ServiceAccessPoint
m_url (defined in Activ::ServiceAccessPoint) | Activ::ServiceAccessPoint
Read(const IniFileParser::ConstKeyIterator &keyIterator) | Activ::ServiceAccessPoint
ServiceAccessPoint() | Activ::ServiceAccessPoint
ServiceAccessPoint(const std::string &url, const AgentScope agentScope) | Activ::ServiceAccessPoint
ToString() const | Activ::ServiceAccessPoint

Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ServiceApi Member List

This is the complete list of members for Activ::ServiceApi, including all inherited members.

CloseService(Component &component, ServiceHandle &serviceHandle) | Activ::ServiceApi | [static]
FindServices(const Component &component, const ServiceId &serviceId, const AgentScope agentScope, const std::string &attributeQuery, ServiceInstanceList &serviceInstanceList, const TimeoutPeriod timeout=Port::defaultTimeout) | Activ::ServiceApi | [static]
OpenService(Component &component, ServiceHandle &serviceHandle, const TimeoutPeriod timeout=Port::defaultTimeout, OpenServiceRequest *const pOpenServiceRequest=0, OpenServiceResponse *const pOpenServiceResponse=0) | Activ::ServiceApi | [static]
ValidateOpenServiceResponse(const HeapMessage &connectMessage, OpenServiceResponse &openServiceResponse) | Activ::ServiceApi | [static]

Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ServiceHandle Member List

This is the complete list of members for Activ::ServiceHandle, including all inherited members.

Clear() | Activ::ServiceHandle
m_serviceAddress | Activ::ServiceHandle
m_serviceId | Activ::ServiceHandle
m_url | Activ::ServiceHandle
ServiceHandle() | Activ::ServiceHandle
ServiceHandle(const ServiceId &serviceId, const std::string &url) | Activ::ServiceHandle

Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ServiceId Member List

This is the complete list of members for Activ::ServiceId, including all inherited members.

Clear() | Activ::ServiceId
operator!=(const ServiceId &rhs) const | Activ::ServiceId
operator<(const ServiceId &rhs) const | Activ::ServiceId
operator==(const ServiceId &rhs) const | Activ::ServiceId
ServiceId() | Activ::ServiceId
ServiceId(const char *const id) | Activ::ServiceId
ServiceId(const std::string &id) | Activ::ServiceId
Set(const std::string &id) | Activ::ServiceId
ToString() const | Activ::ServiceId

Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ServiceInstance Member List

This is the complete list of members for Activ::ServiceInstance, including all inherited members.

Clear() | Activ::ServiceInstance
m_attributes | Activ::ServiceInstance
m_serviceAccessPointList | Activ::ServiceInstance
m_serviceId | Activ::ServiceInstance
ServiceInstance() | Activ::ServiceInstance
ServiceInstance(const ServiceId &serviceId, const ServiceAccessPointList &serviceAccessPointList, const std::string &attributes) | Activ::ServiceInstance

Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ServiceSubject Member List

This is the complete list of members for Activ::ServiceSubject, including all inherited members.

Clear() | Activ::Subject | [inline]
Deserialize(MessageValidator &messageValidator) | Activ::Subject |
Get() const | Activ::Subject | [inline]
GetLength() const | Activ::Subject | [inline]
GetSerializedLength() const | Activ::Subject | [inline]
MAX_LENGTH | Activ::Subject | [static]
operator!=(const Subject &subject) const | Activ::Subject |
operator<(const Subject &subject) const | Activ::Subject |
operator<=(const Subject &subject) const | Activ::Subject |
operator==(const Subject &subject) const | Activ::Subject |
operator>(const Subject &subject) const | Activ::Subject |
operator>=(const Subject &subject) const | Activ::Subject |
Serialize(MessageBuilder &messageBuilder) const | Activ::Subject |
ServiceSubject() | Activ::ServiceSubject |
Set(const char *pSubject) | Activ::Subject |
Set(const void *pSubjectData, const size_t subjectDataLength) | Activ::Subject |
Set(const std::string &subject) | Activ::Subject |
Set(const Subject &subject) | Activ::Subject | [inline]
Subject() | Activ::Subject |
Subject(const void *pSubjectData, const size_t subjectDataLength) | Activ::Subject |
Subject(const char *pSubject) | Activ::Subject |
Subject(const std::string &subject) | Activ::Subject |
SubjectLength typedef | Activ::Subject |
ToString() const | Activ::Subject |

Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::SharedCompletionPortEventFactory Member List

This is the complete list of members for Activ::SharedCompletionPortEventFactory, including all inherited members.

Create(const std::string &name, const IEvent::Flags flags=IEvent::FLAG_NONE, const bool initialState=false, const HANDLE completionPortHandle=NULL) | Activ::SharedCompletionPortEventFactory |
Open(const std::string &name, Timeout &timeout=Timeout::GetInfinite()) | Activ::SharedCompletionPortEventFactory |
Singleton() | Activ::Singleton< T > | [inline, protected]
Singleton< SharedCompletionPortEventFactory > (defined in Activ::SharedCompletionPortEventFactory) | Activ::SharedCompletionPortEventFactory | [friend]

Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::SharedEventFactory Member List

This is the complete list of members for Activ::SharedEventFactory, including all inherited members.

Create(const std::string &name, const IEvent::Flags flags=IEvent::FLAG_NONE, const bool initialState=false) | Activ::SharedEventFactory |
GetInstance() | Activ::SharedEventFactory | [static]
Open(const std::string &name, Timeout &timeout=Timeout::GetInfinite()) | Activ::SharedEventFactory |
Singleton() | Activ::Singleton< T > | [inline, protected]
Singleton< SharedEventFactory > (defined in Activ::SharedEventFactory) | Activ::SharedEventFactory | [friend]

Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::SharedMutexFactory Member List

This is the complete list of members for Activ::SharedMutexFactory, including all inherited members.

Create(const std::string &name, const bool isInitialOwner=false) | Activ::SharedMutexFactory |
GetInstance() | Activ::SharedMutexFactory | [static]
Open(const std::string &name, Timeout &timeout=Timeout::GetInfinite()) | Activ::SharedMutexFactory |
Singleton() | Activ::Singleton< T > | [inline, protected]
Singleton< SharedMutexFactory > (defined in Activ::SharedMutexFactory) | Activ::SharedMutexFactory | [friend]

Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::SharedObject< T > Member List

This is the complete list of members for Activ::SharedObject< T >, including all inherited members.

Create(const std::string &name, const IMappedMemory::MappingFlags mappingFlags=IMappedMemory::MAPPING_FLAG_UNIQUE, const size_t size=sizeof(T)) | Activ::SharedObject< T > | [inline]
GetPointer() const | Activ::SharedObject< T > | [inline]
GetSize() const | Activ::SharedObject< T > | [inline]
IsOpen() const | Activ::SharedObject< T > | [inline]
Open(const std::string &name, const IMappedMemory::MappingFlags mappingFlags=IMappedMemory::MAPPING_FLAG_NONE, Timeout &timeout=Timeout::GetInfinite()) | Activ::SharedObject< T > | [inline]
SharedObject() | Activ::SharedObject< T > | [inline]
~SharedObject() | Activ::SharedObject< T > | [inline]

Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::SharedSemaphoreFactory Member List

This is the complete list of members for Activ::SharedSemaphoreFactory, including all inherited members.

Create(const std::string &name) | Activ::SharedSemaphoreFactory |
GetInstance() | Activ::SharedSemaphoreFactory | [static]
Open(const std::string &name, Timeout &timeout=Timeout::GetInfinite()) | Activ::SharedSemaphoreFactory |
Singleton() | Activ::Singleton< T > | [inline, protected]
Singleton< SharedSemaphoreFactory > (defined in Activ::SharedSemaphoreFactory) | Activ::SharedSemaphoreFactory | [friend]

Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Shell Member List

This is the complete list of members for Activ::Shell, including all inherited members.

Initialize() | Activ::Shell |
OnInputString(std::string &inputString)=0 | Activ::Shell | [protected, pure virtual]
OnOutputString(const std::string &outputString)=0 | Activ::Shell | [protected, pure virtual]
Run() | Activ::Shell |
Shell() | Activ::Shell |
~Shell() | Activ::Shell | [virtual]

Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ShutdownSubject Member List

This is the complete list of members for Activ::ShutdownSubject, including all inherited members.

Clear() | Activ::Subject | [inline]
Deserialize(MessageValidator &messageValidator) | Activ::Subject |
Get() const | Activ::Subject | [inline]
GetLength() const | Activ::Subject | [inline]
GetSerializedLength() const | Activ::Subject | [inline]
MAX_LENGTH | Activ::Subject | [static]
operator!=(const Subject &subject) const | Activ::Subject |
operator<(const Subject &subject) const | Activ::Subject |
operator<=(const Subject &subject) const | Activ::Subject |
operator==(const Subject &subject) const | Activ::Subject |
operator>(const Subject &subject) const | Activ::Subject |
operator>=(const Subject &subject) const | Activ::Subject |
Serialize(MessageBuilder &messageBuilder) const | Activ::Subject |
Set(const char *pSubject) | Activ::Subject |
Set(const void *pSubjectData, const size_t subjectDataLength) | Activ::Subject |
Set(const std::string &subject) | Activ::Subject |
Set(const Subject &subject) | Activ::Subject | [inline]
ShutdownSubject() | Activ::ShutdownSubject | [inline]
Subject() | Activ::Subject |
Subject(const void *pSubjectData, const size_t subjectDataLength) | Activ::Subject |
Subject(const char *pSubject) | Activ::Subject |
Subject(const std::string &subject) | Activ::Subject |
SubjectLength typedef | Activ::Subject |
ToString() const | Activ::Subject |

Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Singleton< T > Member List

This is the complete list of members for Activ::Singleton< T >, including all inherited members.

Singleton() Activ::Singleton< T > [inline, protected]

Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::SmtpHelper Member List

This is the complete list of members for Activ::SmtpHelper, including all inherited members.

Connect(const std::string &server, const std::string &hostname=GetHostname()) | Activ::SmtpHelper | [inline]
Disconnect() | Activ::SmtpHelper | [inline]
GetHostname() | Activ::SmtpHelper | [inline, static]
IsConnected() const | Activ::SmtpHelper | [inline]
PostEmail(const Email &email, const std::string &server, const std::string &hostname=GetHostname()) | Activ::SmtpHelper | [inline, static]
PostMessage(const std::string &fromAddress, const std::string &toAddressList, const std::string &ccAddressList, const std::string &bccAddressList, const std::string &subject, const std::string &text) | Activ::SmtpHelper | [inline]
SmtpHelper() | Activ::SmtpHelper | [inline]
SmtpHelper(const std::string &server, const std::string &hostname=GetHostname()) | Activ::SmtpHelper | [inline]
~SmtpHelper() | Activ::SmtpHelper | [inline]

Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::SmtpHelper::Email Member List

This is the complete list of members for Activ::SmtpHelper::Email, including all inherited members.

Email(const std::string &fromAddress, const std::string &toAddressList, const std::string &ccAddressList, const std::string &bccAddressList, const std::string &subject, const std::string &text) | Activ::SmtpHelper::Email | [inline]
m_bccAddressList | Activ::SmtpHelper::Email |
m_ccAddressList | Activ::SmtpHelper::Email |
m_fromAddress | Activ::SmtpHelper::Email |
m_subject | Activ::SmtpHelper::Email |
m_text | Activ::SmtpHelper::Email |
m_toAddressList | Activ::SmtpHelper::Email |

Generated on Wed Oct 8 14:01:59 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::SocketWrapper Member List

This is the complete list of members for Activ::SocketWrapper, including all inherited members.

IsValid() const | Activ::SocketWrapper | [inline]
operator HANDLE() const | Activ::SocketWrapper | [inline]
operator SOCKET() const | Activ::SocketWrapper | [inline]
operator=(const SOCKET socket) | Activ::SocketWrapper | [inline]
operator=(SocketWrapper &rhs) | Activ::SocketWrapper | [inline]
SocketWrapper() | Activ::SocketWrapper | [inline]
SocketWrapper(const SOCKET socket) | Activ::SocketWrapper | [inline]
SocketWrapper(SocketWrapper &rhs) | Activ::SocketWrapper | [inline]
~SocketWrapper() | Activ::SocketWrapper | [inline]

Generated on Wed Oct 8 14:02:00 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::StaticAlignValueToProcessorWordBoundary< T, input > Member List

This is the complete list of members for Activ::StaticAlignValueToProcessorWordBoundary< T, input >, including all inherited members.

value (defined in Activ::StaticAlignValueToProcessorWordBoundary< T, input >) Activ::StaticAlignValueToProcessorWordBoundary< T, input > [static]

Generated on Wed Oct 8 14:02:00 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::StatusCodeException Member List

This is the complete list of members for Activ::StatusCodeException, including all inherited members.

AddException(Exception *pException) const | Activ::Exception |
Exception(const char *file, const char *function, const uint_fast32_t line, const uint_fast32_t errorCode=0) | Activ::Exception |
Exception(const Exception &rhs) | Activ::Exception |
m_errorCode | Activ::Exception |
m_file | Activ::Exception |
m_function | Activ::Exception |
m_line | Activ::Exception |
StatusCodeException(const char *file, const char *function, const uint_fast32_t line, const uint_fast32_t errorCode) | Activ::StatusCodeException |
ToStream(std::ostream &os) const | Activ::Exception | [virtual]
ToString() const | Activ::StatusCodeException | [virtual]
~Exception() | Activ::Exception | [virtual]

Generated on Wed Oct 8 14:02:00 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::StatusCodeHelper Member List

This is the complete list of members for Activ::StatusCodeHelper, including all inherited members.

operator StatusCode() const (defined in Activ::StatusCodeHelper) | Activ::StatusCodeHelper | [inline]
operator!=(const StatusCode &statusCode, const StatusCodeHelper &statusCodeHelper) | Activ::StatusCodeHelper | [friend]
operator==(const StatusCode &statusCode, const StatusCodeHelper &statusCodeHelper) | Activ::StatusCodeHelper | [friend]
StatusCodeHelper(StatusCode statusCode=STATUS_CODE_SUCCESS, const std::string &statusText="") | Activ::StatusCodeHelper | [inline]
StatusCodeHelper(const StatusCodeHelper &statusCodeHelper) | Activ::StatusCodeHelper | [inline]
ToString() const | Activ::StatusCodeHelper | [inline]

Generated on Wed Oct 8 14:02:00 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::StringHashCompare< TRAITS > Member List

This is the complete list of members for Activ::StringHashCompare< TRAITS >, including all inherited members.

operator()(const std::string &key) const | Activ::StringHashCompare< TRAITS > | [inline]
operator()(const std::string &k1, const std::string &k2) const | Activ::StringHashCompare< TRAITS > | [inline]

Generated on Wed Oct 8 14:02:00 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Subject Member List

This is the complete list of members for Activ::Subject, including all inherited members.

Clear() | Activ::Subject | [inline]
Deserialize(MessageValidator &messageValidator) | Activ::Subject |
Get() const | Activ::Subject | [inline]
GetLength() const | Activ::Subject | [inline]
GetSerializedLength() const | Activ::Subject | [inline]
MAX_LENGTH | Activ::Subject | [static]
operator!=(const Subject &subject) const | Activ::Subject |
operator<(const Subject &subject) const | Activ::Subject |
operator<=(const Subject &subject) const | Activ::Subject |
operator==(const Subject &subject) const | Activ::Subject |
operator>(const Subject &subject) const | Activ::Subject |
operator>=(const Subject &subject) const | Activ::Subject |
Serialize(MessageBuilder &messageBuilder) const | Activ::Subject |
Set(const char *pSubject) | Activ::Subject |
Set(const void *pSubjectData, const size_t subjectDataLength) | Activ::Subject |
Set(const std::string &subject) | Activ::Subject |
Set(const Subject &subject) | Activ::Subject | [inline]
Subject() | Activ::Subject |
Subject(const void *pSubjectData, const size_t subjectDataLength) | Activ::Subject |
Subject(const char *pSubject) | Activ::Subject |
Subject(const std::string &subject) | Activ::Subject |
SubjectLength typedef | Activ::Subject |
ToString() const | Activ::Subject |

Generated on Wed Oct 8 14:02:00 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::SyncRequestId Member List

This is the complete list of members for Activ::SyncRequestId, including all inherited members.

GetRequestId() const | Activ::SyncRequestId | [inline]
GetResponse(HeapMessage &heapMessage, const TimeoutPeriod timeout=ACTIV_WAIT_INFINITE) | Activ::SyncRequestId |
operator=(SyncRequestId &rhs) | Activ::SyncRequestId |
Return() | Activ::SyncRequestId |
SyncRequestId() | Activ::SyncRequestId |
SyncRequestId(SyncRequestId &syncRequestId) | Activ::SyncRequestId |
SystemImpl (defined in Activ::SyncRequestId) | Activ::SyncRequestId | [friend]
~SyncRequestId() | Activ::SyncRequestId |

Generated on Wed Oct 8 14:02:00 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::SystemException Member List

This is the complete list of members for Activ::SystemException, including all inherited members.

ACTIV_DECLARE_ELEMENT_1_WITH_COMMA enum value (defined in Activ::SystemException) | Activ::SystemException |
AddException(Exception *pException) const | Activ::Exception |
Exception(const char *file, const char *function, const uint_fast32_t line, const uint_fast32_t errorCode=0) | Activ::Exception |
Exception(const Exception &rhs) | Activ::Exception |
m_errorCode | Activ::Exception |
m_file | Activ::Exception |
m_function | Activ::Exception |
m_line | Activ::Exception |
SystemException(const char *file, const char *function, const uint_fast32_t line, const uint_fast32_t errorCode) | Activ::SystemException |
ToStream(std::ostream &os) const | Activ::Exception | [virtual]
ToString() const | Activ::SystemException | [virtual]
~Exception() | Activ::Exception | [virtual]

Generated on Wed Oct 8 14:02:00 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::SystemFactory Member List

This is the complete list of members for Activ::SystemFactory, including all inherited members.

Create(const ISystem::Settings &settings, const IHeap::BucketInfoVector &bucketInfoVector, const std::string &systemVersion) | Activ::SystemFactory |
GetInstance() | Activ::SystemFactory | [static]
Open(const ISystem::Settings &settings, const std::string &processName, Timeout &timeout=Timeout::GetInfinite()) | Activ::SystemFactory |
Singleton() | Activ::Singleton< T > | [inline, protected]
Singleton< SystemFactory > (defined in Activ::SystemFactory) | Activ::SystemFactory | [friend]

Generated on Wed Oct 8 14:02:00 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::SystemInfo Member List

This is the complete list of members for Activ::SystemInfo, including all inherited members.

Deserialize(MessageValidator &messageValidator) | Activ::SystemInfo
m_boostVersion | Activ::SystemInfo
m_computerName | Activ::SystemInfo
m_freeMemory | Activ::SystemInfo
m_middlewareDate | Activ::SystemInfo
m_middlewareVersion | Activ::SystemInfo
m_middlewareVersionValue | Activ::SystemInfo
m_numberOfProcessorCores | Activ::SystemInfo
m_numberOfProcessorPackages | Activ::SystemInfo
m_numberOfProcessorThreads | Activ::SystemInfo
m_osName | Activ::SystemInfo
m_physicalMemory | Activ::SystemInfo
m_platformType | Activ::SystemInfo
m_processorInfoList | Activ::SystemInfo
m_schedulerInfo | Activ::SystemInfo
m_windowsDpcProcessorAffinityMask | Activ::SystemInfo
Populate() | Activ::SystemInfo
ProcessorInfoList typedef (defined in Activ::SystemInfo) | Activ::SystemInfo
Serialize(MessageBuilder &messageBuilder) const | Activ::SystemInfo
Serialize(MessageBuilder &messageBuilder, const SystemInfo &systemInfo) const | Activ::SystemInfo
SystemInfo() | Activ::SystemInfo

Generated on Wed Oct 8 14:02:00 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::SystemMessageEndPointIdSet Member List

This is the complete list of members for Activ::SystemMessageEndPointIdSet, including all inherited members.

Deserialize(MessageValidator &messageValidator) | Activ::SystemMessageEndPointIdSet |
m_endPointIdSet | Activ::SystemMessageEndPointIdSet |
Serialize(MessageBuilder &messageBuilder, const EndPointIdSet &endPointIdSet) | Activ::SystemMessageEndPointIdSet | [static]

Generated on Wed Oct 8 14:02:00 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::SystemMonitor Member List

This is the complete list of members for Activ::SystemMonitor, including all inherited members.

AddProcess(const Process::Id processId) | Activ::SystemMonitor
CollateStats() | Activ::SystemMonitor
GetStats() | Activ::SystemMonitor
RemoveProcess(const Process::Id processId) | Activ::SystemMonitor
SystemMonitor(const std::vector< std::string > &diskNameList=std::vector< std::string >()) | Activ::SystemMonitor
~SystemMonitor() | Activ::SystemMonitor

Generated on Wed Oct 8 14:02:00 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::SystemMonitor::Stats Member List

This is the complete list of members for Activ::SystemMonitor::Stats, including all inherited members.

CpuUsageList typedef (defined in Activ::SystemMonitor::Stats) | Activ::SystemMonitor::Stats
DiskInfoList typedef (defined in Activ::SystemMonitor::Stats) | Activ::SystemMonitor::Stats
m_averageCpuUsage | Activ::SystemMonitor::Stats
m_contextSwitchRate | Activ::SystemMonitor::Stats
m_cpuUsageList | Activ::SystemMonitor::Stats
m_diskInfoList | Activ::SystemMonitor::Stats
m_freeMemoryPercent | Activ::SystemMonitor::Stats
m_pagesInOutRate | Activ::SystemMonitor::Stats
m_peakCpuUsage | Activ::SystemMonitor::Stats
m_processInfoMap | Activ::SystemMonitor::Stats
ProcessInfoMap typedef (defined in Activ::SystemMonitor::Stats) | Activ::SystemMonitor::Stats
Stats() | Activ::SystemMonitor::Stats

Generated on Wed Oct 8 14:02:00 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::SystemMonitor::Stats::DiskInfo Member List

This is the complete list of members for Activ::SystemMonitor::Stats::DiskInfo, including all inherited members.

m_diskName | Activ::SystemMonitor::Stats::DiskInfo
m_usagePercentage | Activ::SystemMonitor::Stats::DiskInfo

Generated on Wed Oct 8 14:02:00 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::SystemMonitor::Stats::ProcessInfo Member List

This is the complete list of members for Activ::SystemMonitor::Stats::ProcessInfo, including all inherited members.

m_averageCpuUsage | Activ::SystemMonitor::Stats::ProcessInfo
m_highestThreadCpuUsage | Activ::SystemMonitor::Stats::ProcessInfo
m_highestThreadCpuUsageId | Activ::SystemMonitor::Stats::ProcessInfo
m_name | Activ::SystemMonitor::Stats::ProcessInfo
m_numberOfPageFaults (defined in Activ::SystemMonitor::Stats::ProcessInfo) | Activ::SystemMonitor::Stats::ProcessInfo
m_virtualMemorySize | Activ::SystemMonitor::Stats::ProcessInfo
m_workingSetSize | Activ::SystemMonitor::Stats::ProcessInfo

Generated on Wed Oct 8 14:02:00 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::SystemProxy Member List

This is the complete list of members for Activ::SystemProxy, including all inherited members.

Application (defined in Activ::SystemProxy) | Activ::SystemProxy | [friend]
CreateEndPoint(const std::string &name, const bool hasMutex, const IEndPoint::NotificationType notificationType) | Activ::SystemProxy | [virtual]
CreateHeap(const std::string &name, const IHeap::BucketInfoVector &bucketInfoVector) | Activ::SystemProxy | [virtual]
CreatePrivateEndPoint(const bool hasMutex, const IEndPoint::NotificationType notificationType) | Activ::SystemProxy | [virtual]
EnumerateObjects(IProcessEnumerator &enumerator) | Activ::SystemProxy | [virtual]
EnumerateObjects(IEndPointEnumerator &enumerator) | Activ::SystemProxy | [virtual]
EnumerateObjects(IHeapEnumerator &enumerator) | Activ::SystemProxy | [virtual]
GetProcess() const | Activ::SystemProxy | [virtual]
GetSystemHeap() const | Activ::SystemProxy | [virtual]
GetSystemInfo() const | Activ::SystemProxy | [virtual]
GetSystemName() const | Activ::SystemProxy | [virtual]
OpenEndPoint(const std::string &name, Timeout &timeout=Timeout::GetInfinite()) | Activ::SystemProxy | [virtual]
OpenEndPoint(EndPointId endPointId, Timeout &timeout=Timeout::GetInfinite()) | Activ::SystemProxy | [virtual]
OpenHeap(const std::string &name, Timeout &timeout=Timeout::GetInfinite()) | Activ::SystemProxy | [virtual]
OpenHeap(const HeapId heapId, Timeout &timeout=Timeout::GetInfinite()) | Activ::SystemProxy | [virtual]
OpenProcess(const std::string &name, Timeout &timeout=Timeout::GetInfinite()) | Activ::SystemProxy | [virtual]
OpenProcess(const ProcessId processId, Timeout &timeout=Timeout::GetInfinite()) | Activ::SystemProxy | [virtual]
~ISystem()=0 | Activ::ISystem | [inline, pure virtual]
~SystemProxy() | Activ::SystemProxy |

Generated on Wed Oct 8 14:02:00 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::TRational Member List

This is the complete list of members for Activ::TRational, including all inherited members.

ACTIV_DECLARE_ELEMENT_1_WITH_COMMA enum value (defined in Activ::TRational) | Activ::TRational |
Assign(const IFieldType *const pIFieldType) | Activ::IFieldType |
Clear() | Activ::TRational | [inline, virtual]
Compare(const TRational &rhs, int &result) const | Activ::TRational |
Compare(const void *const pRhsSerializedBody, const size_t rhsSerializedBodyLength, int &result) const | Activ::TRational | [virtual]
Compare(const void *const pLhsSerializedBody, const size_t lhsSerializedBodyLength, const void *const pRhsSerializedBody, const size_t rhsSerializedBodyLength, int &result) | Activ::TRational | [static]
Compress() | Activ::TRational | [inline]
Convert(const IFieldType *const pIFieldType) | Activ::TRational | [virtual]
Deserialize(MessageValidator &messageValidator, const size_t maxSerializedBodyLength) | Activ::TRational | [virtual]
Activ::IFieldType::Deserialize(const FieldType fieldType, MessageValidator &messageValidator, const size_t maxSerializedBodyLength) | Activ::IFieldType |
DeserializeBody(const void *const pSerializedBody, const size_t serializedBodyLength) | Activ::TRational | [virtual]
Activ::IFieldType::DeserializeBody(const FieldType fieldType, const void *const pSerializedBody, const size_t serializedBodyLength) | Activ::IFieldType |
DeserializeLengthAndBody(MessageValidator &messageValidator, const size_t maxSerializedBodyLength=MAX_SERIALIZED_BODY_LENGTH_UNDEFINED) | Activ::TRational | [virtual]
Activ::IFieldType::DeserializeLengthAndBody(const FieldType fieldType, MessageValidator &messageValidator, const size_t maxSerializedBodyLength=MAX_SERIALIZED_BODY_LENGTH_UNDEFINED) | Activ::IFieldType |
FIELD_TYPE | Activ::TRational | [static]
FromString(MessageValidator &messageValidator) | Activ::TRational | [virtual]
Activ::IFieldType::FromString(const std::string &field) | Activ::IFieldType | [inline]
Get(int64_t &numerator, Rational::Denominator &denominator, Tick &tick, Trend &trendOnDay, Trend &trendOnPrevious) const | Activ::TRational | [inline]
Get(Rational &value, Tick &tick, Trend &trendOnDay, Trend &trendOnPrevious) const | Activ::TRational | [inline]
Get() const | Activ::TRational | [inline]
GetDenominator() const | Activ::TRational | [inline]
GetFromStringFormat() const | Activ::TRational | [virtual]
GetMaxSerializedBodyLength(const size_t size) | Activ::TRational | [inline, static]
GetMaxSerializedLength(const size_t size) | Activ::TRational | [inline, static]
GetNumerator() const | Activ::TRational | [inline]
GetNumerator(int64_t &numerator, const Rational::Denominator denominator) const | Activ::TRational | [inline]
GetNumeratorAndDenominator(int64_t &numerator, Rational::Denominator &denominator) const | Activ::TRational | [inline]
GetNumeratorAndDivisor(int64_t &numerator, uint64_t &divisor) const | Activ::TRational | [inline]
GetRational() const | Activ::TRational | [inline]
GetSerializedBodyLength() const | Activ::TRational | [inline, virtual]
GetSerializedLength() const | Activ::TRational | [inline, virtual]
GetTick() const | Activ::TRational | [inline]
GetTrendOnDay() const | Activ::TRational | [inline]
GetTrendOnPrevious() const | Activ::TRational | [inline]
GetType() const | Activ::IFieldType | [inline]
IFieldType(const FieldType fieldType) | Activ::IFieldType | [inline, explicit, protected]
IsDifferent(const void *const pRhsSerializedBody, const size_t rhsSerializedBodyLength, bool &isDifferent) const | Activ::TRational | [virtual]
IsInitialized() const | Activ::IFieldType | [inline]
IsValidSerializedBodyLength(const size_t serializedBodyLength) | Activ::TRational | [inline, static]
Activ::IFieldType::IsValidSerializedBodyLength(const FieldType fieldType, const size_t serializedBodyLength) | Activ::IFieldType | [static]
IsValidTick(const Tick tick) | Activ::TRational | [inline, static]
IsValidTrend(const Trend trend) | Activ::TRational | [inline, static]
m_isInitialized | Activ::IFieldType | [protected]
MAX_SERIALIZED_BODY_LENGTH_UNDEFINED | Activ::IFieldType | [static]
operator const Rational &() const | Activ::TRational | [inline]
Reset() | Activ::TRational | [inline, virtual]
Serialize(MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength) const | Activ::TRational | [virtual]
Activ::IFieldType::Serialize(const FieldType fieldType, MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength) const | Activ::IFieldType |
Activ::IFieldType::Serialize(const FieldType fieldType, MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength, const uint8_t *const pData, const size_t size) | Activ::IFieldType | [static]
SerializeBody(void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength) const | Activ::TRational | [virtual]
Activ::IFieldType::SerializeBody(const FieldType fieldType, void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength) const | Activ::IFieldType |
Activ::IFieldType::SerializeBody(const FieldType fieldType, void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength, const uint8_t *const pData, const size_t size) | Activ::IFieldType | [static]
SerializeLengthAndBody(MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength=MAX_SERIALIZED_BODY_LENGTH_UNDEFINED) const | Activ::TRational | [virtual]
Activ::IFieldType::SerializeLengthAndBody(const FieldType fieldType, MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength=MAX_SERIALIZED_BODY_LENGTH_UNDEFINED) const | Activ::IFieldType |
Activ::IFieldType::SerializeLengthAndBody(const FieldType fieldType, MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength, const uint8_t *const pData, const size_t size) | Activ::IFieldType | [static]
Set(const int64_t numerator, const Rational::Denominator denominator, const Tick tick=TICK_UNDEFINED, const Trend trendOnDay=TREND_UNDEFINED, const Trend trendOnPrevious=TREND_UNDEFINED, bool shouldCompress=false) | Activ::TRational | [inline]
Set(const Rational &value, const Tick tick=TICK_UNDEFINED, const Trend trendOnDay=TREND_UNDEFINED, const Trend trendOnPrevious=TREND_UNDEFINED) | Activ::TRational | [inline]
Set(const int64_t numerator, const Rational::Denominator denominator, const TRational *pPreviousValue, const Rational *pPreviousDayValue, bool shouldCompress=false) | Activ::TRational | [inline]
Set(const Rational &value, const TRational *pPreviousValue, const Rational *pPreviousDayValue) | Activ::TRational | [inline]
Set(const int64_t numerator, const Rational::Denominator denominator, const TRational *pPreviousTick, const Rational *pPreviousValue, const Rational *pPreviousDayValue, bool shouldCompress=false) | Activ::TRational | [inline]
Set(const Rational &value, const TRational *pPreviousTick, const Rational *pPreviousValue, const Rational *pPreviousDayValue) | Activ::TRational | [inline]
SetDenominator(const Rational::Denominator denominator) | Activ::TRational | [inline]
SetTick(const Tick tick) | Activ::TRational | [inline]
SetTick(const TRational &previousValue) | Activ::TRational | [inline]
SetTickAndTrendOnPrevious(const TRational &previousValue) | Activ::TRational | [inline]
SetTrendOnDay(const Trend trend) | Activ::TRational | [inline]
SetTrendOnDay(const Rational &previousDayValue) | Activ::TRational | [inline]
SetTrendOnPrevious(const Trend trend) | Activ::TRational | [inline]
SetTrendOnPrevious(const Rational &previousValue) | Activ::TRational | [inline]
Tick enum name | Activ::TRational |
TickToString(const Tick tick) | Activ::TRational | [static]
ToString() const | Activ::TRational | [virtual]
ToString(const Rational::Denominator denominator) const | Activ::TRational |
TRational() | Activ::TRational | [inline]
TRational(const int64_t numerator, const Rational::Denominator denominator=Rational::DENOMINATOR_WHOLE, const Tick tick=TICK_UNDEFINED, const Trend trendOnDay=TREND_UNDEFINED, const Trend trendOnPrevious=TREND_UNDEFINED, bool shouldCompress=false) | Activ::TRational | [inline]
TRational(const Rational &value, const Tick tick=TICK_UNDEFINED, const Trend trendOnDay=TREND_UNDEFINED, const Trend trendOnPrevious=TREND_UNDEFINED) | Activ::TRational | [inline]
TRational(const int64_t numerator, const Rational::Denominator denominator, const TRational *pPreviousValue, const Rational *pPreviousDayValue, bool shouldCompress=false) | Activ::TRational | [inline]
TRational(const Rational &value, const TRational *pPreviousValue, const Rational *pPreviousDayValue) | Activ::TRational | [inline]
TRational(const int64_t numerator, const Rational::Denominator denominator, const TRational *pPreviousTick, const Rational *pPreviousValue, const Rational *pPreviousDayValue, bool shouldCompress=false) | Activ::TRational | [inline]
TRational(const Rational &value, const TRational *pPreviousTick, const Rational *pPreviousValue, const Rational *pPreviousDayValue) | Activ::TRational | [inline]
Trend enum name | Activ::TRational |
TrendToString(const Trend trend) | Activ::TRational | [static]
ValidateSerializedLengthAndBody(MessageValidator &messageValidator, size_t &serializedBodyOffset, size_t &serializedBodyLength) | Activ::TRational | [static]
Activ::IFieldType::ValidateSerializedLengthAndBody(const FieldType fieldType, MessageValidator &messageValidator, size_t &serializedBodyOffset, size_t &serializedBodyLength) | Activ::IFieldType | [static]
~IFieldType()=0 | Activ::IFieldType | [inline, pure virtual]
~TRational() | Activ::TRational | [inline, virtual]

Generated on Wed Oct 8 14:02:01 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::TRational::SerializedTrendDefinitions Member List

This is the complete list of members for Activ::TRational::SerializedTrendDefinitions, including all inherited members.

GetSerializedTrend(const Tick tick, const Trend trendOnDay, const Trend trendOnPrevious) | Activ::TRational::SerializedTrendDefinitions | [inline, static]
GetTick(const SerializedTrend serializedTrend) | Activ::TRational::SerializedTrendDefinitions | [inline, static]
GetTrendOnDay(const SerializedTrend serializedTrend) | Activ::TRational::SerializedTrendDefinitions | [inline, static]
GetTrendOnPrevious(const SerializedTrend serializedTrend) | Activ::TRational::SerializedTrendDefinitions | [inline, static]
RESERVED_LENGTH | Activ::TRational::SerializedTrendDefinitions | [static]
RESERVED_OFFSET | Activ::TRational::SerializedTrendDefinitions | [static]
SerializedTrend typedef | Activ::TRational::SerializedTrendDefinitions |
TICK_LENGTH | Activ::TRational::SerializedTrendDefinitions | [static]
TICK_OFFSET | Activ::TRational::SerializedTrendDefinitions | [static]
TREND_ON_DAY_LENGTH | Activ::TRational::SerializedTrendDefinitions | [static]
TREND_ON_DAY_OFFSET | Activ::TRational::SerializedTrendDefinitions | [static]
TREND_ON_PREVIOUS_LENGTH | Activ::TRational::SerializedTrendDefinitions | [static]
TREND_ON_PREVIOUS_OFFSET | Activ::TRational::SerializedTrendDefinitions | [static]

Generated on Wed Oct 8 14:02:01 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::TcpListener Member List

This is the complete list of members for Activ::TcpListener, including all inherited members.

ACTIV_DECLARE_VALUE_WITH_COMMA enum value (defined in Activ::TcpListener) | Activ::TcpListener |
GetHandle() const | Activ::TcpListener |
GetLocalAddress(IpAddress &ipAddress) const | Activ::TcpListener |
GetState() const | Activ::TcpListener |
Start(const uint16_t localPort, const char *localAddress=0, const int backlog=SOMAXCONN) | Activ::TcpListener |
Start(const IpAddress &localAddress, const int backlog=SOMAXCONN) | Activ::TcpListener |
State enum name | Activ::TcpListener |
StateToString(const State state) | Activ::TcpListener | [static]
Stop() | Activ::TcpListener |
TcpListener(IpManager &ipManager) | Activ::TcpListener |
TcpSocket (defined in Activ::TcpListener) | Activ::TcpListener | [friend]
~TcpListener() | Activ::TcpListener |

Generated on Wed Oct 8 14:02:00 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::TcpSocket Member List

This is the complete list of members for Activ::TcpSocket, including all inherited members.

Accept(TcpListener &listener) | Activ::TcpSocket |
ACTIV_DECLARE_VALUE_WITH_COMMA enum value (defined in Activ::TcpSocket) | Activ::TcpSocket |
AppendRxBuffer(void *pData, const size_t dataLength) | Activ::IpSocket | [inline]
AppendTxBuffer(const void *pData, const size_t dataLength) | Activ::IpSocket | [inline]
CleanupIo() | Activ::IpSocket | [protected]
CloseSocket() | Activ::IpSocket | [protected]
COMPLETION_RESULT_CLOSE_SOCKET enum value | Activ::IpSocket |
COMPLETION_RESULT_OK enum value | Activ::IpSocket |
CompletionResult enum name | Activ::IpSocket |
Connect(const char *remoteAddress, const uint16_t remotePort, const char *localAddress=0, const uint16_t localPort=0) | Activ::TcpSocket |
Connect(const IpAddress &remoteAddress, const IpAddress &localAddress) | Activ::TcpSocket |
Disconnect(const bool gracefully=false) | Activ::TcpSocket |
GET_BUFFERS_RESULT_CLOSE_SOCKET enum value | Activ::IpSocket |
GET_BUFFERS_RESULT_NO_MORE_BUFFERS enum value | Activ::IpSocket |
GetBuffersResult enum name | Activ::IpSocket |
GetLocalAddress(IpAddress &ipAddress) const | Activ::IpSocket |
GetRemoteAddress(IpAddress &ipAddress) const | Activ::IpSocket |
GetSocketHandle() const | Activ::IpSocket |
GetSocketOption(const int optionName, char *pOptionValue, socklen_t *pOptionLength, const int level=SOL_SOCKET) | Activ::IpSocket |
IpSocket(IpManager &ipManager, const Settings &settings) | Activ::IpSocket |
LockedBreak() | Activ::TcpSocket |
LockedRead() | Activ::IpSocket | [inline]
LockedWrite() | Activ::IpSocket | [inline]
m_closeOnTxCompletion | Activ::IpSocket | [protected]
m_closePosted | Activ::IpSocket | [protected]
m_fromAddress | Activ::IpSocket | [protected]
m_handle | Activ::IpSocket | [protected]
m_ipManager | Activ::IpSocket | [protected]
m_localAddress | Activ::IpSocket | [protected]
m_pMutex | Activ::IpSocket | [protected]
m_remoteAddress | Activ::IpSocket | [protected]
m_rxBuffers | Activ::IpSocket | [protected]
m_rxBytes | Activ::IpSocket | [protected]
m_rxFlags | Activ::IpSocket | [protected]
m_rxOverlapped | Activ::IpSocket | [protected]
m_state | Activ::TcpSocket | [protected]
m_toAddress | Activ::IpSocket | [protected]
m_txBuffers | Activ::IpSocket | [protected]
m_txBytes | Activ::IpSocket | [protected]
m_txFlags | Activ::IpSocket | [protected]
m_txOverlapped | Activ::IpSocket | [protected]
OnAccept() | Activ::TcpSocket | [protected, virtual]
OnAcceptAborted() | Activ::TcpSocket | [protected, virtual]
OnAcceptFailed(const uint32_t errorCode) | Activ::TcpSocket | [protected, virtual]
OnBreak() | Activ::TcpSocket | [protected, virtual]
OnCleanupIo() | Activ::IpSocket | [protected, virtual]
OnConnect() | Activ::TcpSocket | [protected, virtual]
OnConnectAborted() | Activ::TcpSocket | [protected, virtual]
OnConnectFailed(const uint32_t errorCode) | Activ::TcpSocket | [protected, virtual]
OnDisconnect() | Activ::TcpSocket | [protected, virtual]
OnGetRxBuffers() | Activ::IpSocket | [protected, virtual]
OnGetTxBuffers() | Activ::IpSocket | [protected, virtual]
OnInitializeIo() | Activ::IpSocket | [protected, virtual]
OnRxBuffers(const size_t dataLength) | Activ::TcpSocket | [protected, virtual]
OnSetSocketOptions() | Activ::IpSocket | [protected, virtual]
OnTxBuffers(const size_t dataLength) | Activ::TcpSocket | [protected, virtual]
PostConnect() | Activ::TcpSocket |
PostRead() | Activ::IpSocket | [protected]
PostWrite() | Activ::IpSocket | [protected]
PreLockedBreak() | Activ::TcpSocket |
PreLockedRead() | Activ::IpSocket | [inline]
PreLockedWrite() | Activ::IpSocket | [inline]
SetRxBufferSize(const int size) | Activ::IpSocket |
SetSocketOption(const int optionName, const char *pOptionValue, const socklen_t optionLength, const int level=SOL_SOCKET) | Activ::IpSocket |
SetTxBufferSize(const int size) | Activ::IpSocket |
ShutdownSocket() | Activ::IpSocket | [protected]
State enum name | Activ::TcpSocket |
StateToString(const State state) | Activ::TcpSocket | [static]
TcpSocket(IpManager &manager, const Settings &settings=Settings()) | Activ::TcpSocket |
~IpSocket() | Activ::IpSocket | [virtual]
~TcpSocket() | Activ::TcpSocket |

Generated on Wed Oct 8 14:02:00 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::TcpSocket::Settings Member List

This is the complete list of members for Activ::TcpSocket::Settings, including all inherited members.

m_shouldCork | Activ::IpSocket::Settings
Settings(const bool shouldCork=false) | Activ::TcpSocket::Settings

Generated on Wed Oct 8 14:02:00 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::TcpSocket::Stats Member List

This is the complete list of members for Activ::TcpSocket::Stats, including all inherited members.

Get(const SOCKET_TYPE &socket) | Activ::IpSocket::Stats | [inline, static]
m_acceptPosted | Activ::TcpSocket::Stats |
m_closeOnTxCompletion | Activ::IpSocket::Stats |
m_closePosted | Activ::IpSocket::Stats |
m_connectPosted | Activ::TcpSocket::Stats |
m_localAddress | Activ::IpSocket::Stats |
m_mutexContentionCount | Activ::IpSocket::Stats |
m_remoteAddress | Activ::IpSocket::Stats |
m_rxBytes | Activ::IpSocket::Stats |
m_rxPosted | Activ::IpSocket::Stats |
m_state | Activ::TcpSocket::Stats |
m_txBytes | Activ::IpSocket::Stats |
m_txPosted | Activ::IpSocket::Stats |
Stats(const TcpSocket &socket) | Activ::TcpSocket::Stats |
Activ::IpSocket::Stats::Stats(const IpSocket &socket) | Activ::IpSocket::Stats |

Generated on Wed Oct 8 14:02:00 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::TextArray Member List

This is the complete list of members for Activ::TextArray, including all inherited members.

Assign(const IFieldType *const pIFieldType) | Activ::IFieldType |
Clear() | Activ::TextArray | [inline, virtual]
Compare(const TextArray &rhs, int &result) const | Activ::TextArray |
Compare(const void *const pRhsSerializedBody, const size_t rhsSerializedBodyLength, int &result) const | Activ::TextArray | [virtual]
Compare(const void *const pLhsSerializedBody, const size_t lhsSerializedBodyLength, const void *const pRhsSerializedBody, const size_t rhsSerializedBodyLength, int &result) | Activ::TextArray | [static]
Convert(const IFieldType *const pIFieldType) | Activ::TextArray | [virtual]
Deserialize(MessageValidator &messageValidator, const size_t maxSerializedBodyLength) | Activ::TextArray | [virtual]
Deserialize(MessageValidator &messageValidator, const size_t maxSerializedBodyLength, const uint8_t *&pData, size_t &size) | Activ::TextArray | [static]
Activ::IFieldType::Deserialize(const FieldType fieldType, MessageValidator &messageValidator, const size_t maxSerializedBodyLength) | Activ::IFieldType |
DeserializeBody(const void *const pSerializedBody, const size_t serializedBodyLength) | Activ::TextArray | [virtual]
DeserializeBody(const void *const pSerializedBody, const size_t serializedBodyLength, const uint8_t *&pData, size_t &size) | Activ::TextArray | [static]
Activ::IFieldType::DeserializeBody(const FieldType fieldType, const void *const pSerializedBody, const size_t serializedBodyLength) | Activ::IFieldType |
DeserializeLengthAndBody(MessageValidator &messageValidator, const size_t maxSerializedBodyLength=MAX_SERIALIZED_BODY_LENGTH_UNDEFINED) | Activ::TextArray | [virtual]
DeserializeLengthAndBody(MessageValidator &messageValidator, const size_t maxSerializedBodyLength, const uint8_t *&pData, size_t &size) | Activ::TextArray | [static]
Activ::IFieldType::DeserializeLengthAndBody(const FieldType fieldType, MessageValidator &messageValidator, const size_t maxSerializedBodyLength=MAX_SERIALIZED_BODY_LENGTH_UNDEFINED) | Activ::IFieldType |
FIELD_TYPE | Activ::TextArray | [static]
FromString(MessageValidator &messageValidator) | Activ::TextArray | [virtual]
Activ::IFieldType::FromString(const std::string &field) | Activ::IFieldType | [inline]
Get(const uint8_t *&pData, size_t &size) const | Activ::TextArray | [inline]
GetData() const | Activ::TextArray | [inline]
GetFromStringFormat() const | Activ::TextArray | [virtual]
GetMaxSerializedBodyLength(const size_t size) | Activ::TextArray | [inline, static]
GetMaxSerializedLength(const size_t size) | Activ::TextArray | [inline, static]
GetSerializedBodyLength() const | Activ::TextArray | [inline, virtual]
GetSerializedLength() const | Activ::TextArray | [inline, virtual]
GetSize() const | Activ::TextArray | [inline]
GetType() const | Activ::IFieldType | [inline]
IFieldType(const FieldType fieldType) | Activ::IFieldType | [inline, explicit, protected]
IsDifferent(const void *const pRhsSerializedBody, const size_t rhsSerializedBodyLength, bool &isDifferent) const | Activ::TextArray | [virtual]
IsInitialized() const | Activ::IFieldType | [inline]
IsValidSerializedBodyLength(const size_t serializedBodyLength) | Activ::TextArray | [inline, static]
Activ::IFieldType::IsValidSerializedBodyLength(const FieldType fieldType, const size_t serializedBodyLength) | Activ::IFieldType | [static]
m_isInitialized | Activ::IFieldType | [protected]
MAX_SERIALIZED_BODY_LENGTH_UNDEFINED | Activ::IFieldType | [static]
operator=(const TextArray &rhs) | Activ::TextArray | [inline]
Reset() | Activ::TextArray | [inline, virtual]
Serialize(MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength) const | Activ::TextArray | [virtual]
Serialize(MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength, const uint8_t *const pData, const size_t size) | Activ::TextArray | [static]
Activ::IFieldType::Serialize(const FieldType fieldType, MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength) const | Activ::IFieldType |
Activ::IFieldType::Serialize(const FieldType fieldType, MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength, const uint8_t *const pData, const size_t size) | Activ::IFieldType | [static]
SerializeBody(void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength) const | Activ::TextArray | [virtual]
SerializeBody(void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength, const uint8_t *const pData, const size_t size) | Activ::TextArray | [static]
Activ::IFieldType::SerializeBody(const FieldType fieldType, void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength) const | Activ::IFieldType |
Activ::IFieldType::SerializeBody(const FieldType fieldType, void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength, const uint8_t *const pData, const size_t size) | Activ::IFieldType | [static]
SerializeLengthAndBody(MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength=MAX_SERIALIZED_BODY_LENGTH_UNDEFINED) const | Activ::TextArray | [virtual]
SerializeLengthAndBody(MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength, const uint8_t *const pData, const size_t size) | Activ::TextArray | [static]
Activ::IFieldType::SerializeLengthAndBody(const FieldType fieldType, MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength=MAX_SERIALIZED_BODY_LENGTH_UNDEFINED) const | Activ::IFieldType |
Activ::IFieldType::SerializeLengthAndBody(const FieldType fieldType, MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength, const uint8_t *const pData, const size_t size) | Activ::IFieldType | [static]
Set(const uint8_t *const pData, const size_t size) | Activ::TextArray | [inline]
TextArray() | Activ::TextArray | [inline]
TextArray(const uint8_t *const pData, const size_t size) | Activ::TextArray | [inline]
TextArray(const TextArray &rhs) | Activ::TextArray | [inline]
ToString() const | Activ::TextArray | [virtual]
ValidateSerializedLengthAndBody(MessageValidator &messageValidator, size_t &serializedBodyOffset, size_t &serializedBodyLength) | Activ::TextArray | [static]
Activ::IFieldType::ValidateSerializedLengthAndBody(const FieldType fieldType, MessageValidator &messageValidator, size_t &serializedBodyOffset, size_t &serializedBodyLength) | Activ::IFieldType | [static]
~IFieldType()=0 | Activ::IFieldType | [inline, pure virtual]
~TextArray() | Activ::TextArray | [inline, virtual]

Generated on Wed Oct 8 14:02:00 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::TextString Member List

This is the complete list of members for Activ::TextString, including all inherited members.

Assign(const IFieldType *const pIFieldType) | Activ::IFieldType |
Clear() | Activ::TextString | [inline, virtual]
Compare(const TextString &rhs, int &result) const | Activ::TextString |
Compare(const void *const pRhsSerializedBody, const size_t rhsSerializedBodyLength, int &result) const | Activ::TextString | [virtual]
Compare(const void *const pLhsSerializedBody, const size_t lhsSerializedBodyLength, const void *const pRhsSerializedBody, const size_t rhsSerializedBodyLength, int &result) | Activ::TextString | [static]
Convert(const IFieldType *const pIFieldType) | Activ::TextString | [virtual]
Deserialize(MessageValidator &messageValidator, const size_t maxSerializedBodyLength) | Activ::TextString | [virtual]
Deserialize(MessageValidator &messageValidator, const size_t maxSerializedBodyLength, const uint8_t *&pData, size_t &size) | Activ::TextString | [static]
Activ::IFieldType::Deserialize(const FieldType fieldType, MessageValidator &messageValidator, const size_t maxSerializedBodyLength) | Activ::IFieldType |
DeserializeBody(const void *const pSerializedBody, const size_t serializedBodyLength) | Activ::TextString | [virtual]
DeserializeBody(const void *const pSerializedBody, const size_t serializedBodyLength, const uint8_t *&pData, size_t &size) | Activ::TextString | [static]
Activ::IFieldType::DeserializeBody(const FieldType fieldType, const void *const pSerializedBody, const size_t serializedBodyLength) | Activ::IFieldType |
DeserializeLengthAndBody(MessageValidator &messageValidator, const size_t maxSerializedBodyLength=MAX_SERIALIZED_BODY_LENGTH_UNDEFINED) | Activ::TextString | [virtual]
DeserializeLengthAndBody(MessageValidator &messageValidator, const size_t maxSerializedBodyLength, const uint8_t *&pData, size_t &size) | Activ::TextString | [static]
Activ::IFieldType::DeserializeLengthAndBody(const FieldType fieldType, MessageValidator &messageValidator, const size_t maxSerializedBodyLength=MAX_SERIALIZED_BODY_LENGTH_UNDEFINED) | Activ::IFieldType |
FIELD_TYPE | Activ::TextString | [static]
FromString(MessageValidator &messageValidator) | Activ::TextString | [virtual]
Activ::IFieldType::FromString(const std::string &field) | Activ::IFieldType | [inline]
Get(const uint8_t *&pData, size_t &size) const | Activ::TextString | [inline]
GetData() const | Activ::TextString | [inline]
GetFromStringFormat() const | Activ::TextString | [virtual]
GetMaxSerializedBodyLength(const size_t size) | Activ::TextString | [inline, static]
GetMaxSerializedLength(const size_t size) | Activ::TextString | [inline, static]
GetSerializedBodyLength() const | Activ::TextString | [inline, virtual]
GetSerializedLength() const | Activ::TextString | [inline, virtual]
GetSize() const | Activ::TextString | [inline]
GetType() const | Activ::IFieldType | [inline]
IFieldType(const FieldType fieldType) | Activ::IFieldType | [inline, explicit, protected]
IsDifferent(const void *const pRhsSerializedBody, const size_t rhsSerializedBodyLength, bool &isDifferent) const | Activ::TextString | [virtual]
IsInitialized() const | Activ::IFieldType | [inline]
IsValidSerializedBodyLength(const size_t serializedBodyLength) | Activ::TextString | [inline, static]
Activ::IFieldType::IsValidSerializedBodyLength(const FieldType fieldType, const size_t serializedBodyLength) | Activ::IFieldType | [static]
m_isInitialized | Activ::IFieldType | [protected]
MAX_SERIALIZED_BODY_LENGTH_UNDEFINED | Activ::IFieldType | [static]
operator=(const TextString &rhs) | Activ::TextString | [inline]
Reset() | Activ::TextString | [inline, virtual]
Serialize(MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength) const | Activ::TextString | [virtual]
Serialize(MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength, const uint8_t *const pData, const size_t size) | Activ::TextString | [static]
Activ::IFieldType::Serialize(const FieldType fieldType, MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength) const | Activ::IFieldType |
Activ::IFieldType::Serialize(const FieldType fieldType, MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength, const uint8_t *const pData, const size_t size) | Activ::IFieldType | [static]
SerializeBody(void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength) const | Activ::TextString | [virtual]
SerializeBody(void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength, const uint8_t *const pData, const size_t size) | Activ::TextString | [static]
Activ::IFieldType::SerializeBody(const FieldType fieldType, void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength) const | Activ::IFieldType |
Activ::IFieldType::SerializeBody(const FieldType fieldType, void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength, const uint8_t *const pData, const size_t size) | Activ::IFieldType | [static]
SerializeLengthAndBody(MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength=MAX_SERIALIZED_BODY_LENGTH_UNDEFINED) const | Activ::TextString | [virtual]
SerializeLengthAndBody(MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength, const uint8_t *const pData, const size_t size) | Activ::TextString | [static]
Activ::IFieldType::SerializeLengthAndBody(const FieldType fieldType, MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength=MAX_SERIALIZED_BODY_LENGTH_UNDEFINED) const | Activ::IFieldType |
Activ::IFieldType::SerializeLengthAndBody(const FieldType fieldType, MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength, const uint8_t *const pData, const size_t size) | Activ::IFieldType | [static]
Set(const uint8_t *const pData, const size_t size) | Activ::TextString | [inline]
TextString() | Activ::TextString | [inline]
TextString(const uint8_t *const pData, const size_t size) | Activ::TextString | [inline]
TextString(const TextString &rhs) | Activ::TextString | [inline]
ToString() const | Activ::TextString | [virtual]
ValidateSerializedLengthAndBody(MessageValidator &messageValidator, size_t &serializedBodyOffset, size_t &serializedBodyLength) | Activ::TextString | [static]
Activ::IFieldType::ValidateSerializedLengthAndBody(const FieldType fieldType, MessageValidator &messageValidator, size_t &serializedBodyOffset, size_t &serializedBodyLength) | Activ::IFieldType | [static]
~IFieldType()=0 | Activ::IFieldType | [inline, pure virtual]
~TextString() | Activ::TextString | [inline, virtual]

Generated on Wed Oct 8 14:02:00 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ThinApplication Member List

This is the complete list of members for Activ::ThinApplication, including all inherited members.

anonymousName | Activ::Port | [static]
CanThreadExit() | Activ::ManagedEndPoint | [protected, virtual]
Component(Application &application, ManagedEndPoint &managedEndPoint, const std::string &name=anonymousName, IHeap *const pHeap=0, const std::string &componentId=defaultComponentId) | Activ::Component |
CreateEndPoint(const std::string &name, const bool hasMutex, const IEndPoint::NotificationType notificationType) | Activ::SystemProxy | [virtual]
CreateHeap(const std::string &name, const IHeap::BucketInfoVector &bucketInfoVector) | Activ::SystemProxy | [virtual]
CreatePrivateEndPoint(const bool hasMutex, const IEndPoint::NotificationType notificationType) | Activ::SystemProxy | [virtual]
defaultComponentId | Activ::Component | [static]
defaultTimeout | Activ::Port | [static]
Disable() | Activ::Port |
Enable() | Activ::Port |
EnumerateObjects(IProcessEnumerator &enumerator) | Activ::SystemProxy | [virtual]
EnumerateObjects(IEndPointEnumerator &enumerator) | Activ::SystemProxy | [virtual]
EnumerateObjects(IHeapEnumerator &enumerator) | Activ::SystemProxy | [virtual]
Activ::FindPort(const std::string &portName, Address &portAddress) const | Activ::ManagedEndPoint |
Activ::Component::FindPort(const std::string &endPointName, const std::string &portName, Address &portAddress, const TimeoutPeriod timeout=defaultTimeout) | Activ::Port |
ForwardMessage(const Address &destinationAddress, HeapMessage &message, const MessageType newType=INVALID_MESSAGE_TYPE) const | Activ::Port |
GetAddress() const | Activ::Port | [inline]
GetApplication() const | Activ::Component |
GetEndPoint() const | Activ::ManagedEndPoint |
GetHeap() const | Activ::Port | [inline]
GetManagedEndPoint() const | Activ::Port |
GetMaxThreads() const | Activ::ManagedEndPoint |
GetMonitorServiceHeap() const | Activ::Application |
GetName() const | Activ::Port |
GetPrivate() const | Activ::Application | [inline]
GetProcess() const | Activ::SystemProxy | [virtual]
GetSystemHeap() const | Activ::SystemProxy | [virtual]
GetSystemInfo() const | Activ::SystemProxy | [virtual]
GetSystemName() const | Activ::SystemProxy | [virtual]
GetUiServiceName() | Activ::Application | [static]
ManagedEndPoint(ISystem *const pSystem, const std::string &name, const Settings &settings=Settings()) | Activ::ManagedEndPoint |
ManagedEndPoint::Impl (defined in Activ::Port) | Activ::Port | [friend]
OnAccept(HeapMessage &acceptMessage) | Activ::Component | [protected, virtual]
OnBreak(HeapMessage &breakMessage) | Activ::Component | [protected, virtual]
OnConnect(HeapMessage &connectMessage) | Activ::Component | [protected, virtual]
OnConnectFailed(HeapMessage &connectFailMessage) | Activ::Component | [protected, virtual]
OnCtrlEvent(const CtrlHandler::EventType eventType) | Activ::Application | [protected, virtual]
OnData(HeapMessage &heapMessage) | Activ::Component | [protected, virtual]
OnDisconnect(HeapMessage &disconnectMessage) | Activ::Component | [protected, virtual]
OnMessage(HeapMessage &message) | Activ::ThinApplication | [protected, virtual]
OnRequest(HeapMessage &request) | Activ::Component | [protected, virtual]
OnResponse(HeapMessage &response) | Activ::Port | [protected, virtual]
OnShutdown(const ShutdownReason shutdownReason) | Activ::Application | [protected, virtual]
OnTimer(const Address &timerAddress, const BaseTime &time) | Activ::Component | [protected, virtual]
OpenEndPoint(const std::string &name, Timeout &timeout=Timeout::GetInfinite()) | Activ::SystemProxy | [virtual]
OpenEndPoint(EndPointId endPointId, Timeout &timeout=Timeout::GetInfinite()) | Activ::SystemProxy | [virtual]
OpenHeap(const std::string &name, Timeout &timeout=Timeout::GetInfinite()) | Activ::SystemProxy | [virtual]
OpenHeap(const HeapId heapId, Timeout &timeout=Timeout::GetInfinite()) | Activ::SystemProxy | [virtual]
OpenProcess(const std::string &name, Timeout &timeout=Timeout::GetInfinite()) | Activ::SystemProxy | [virtual]
OpenProcess(const ProcessId processId, Timeout &timeout=Timeout::GetInfinite()) | Activ::SystemProxy | [virtual]
Port(ManagedEndPoint &managedEndPoint, const std::string &name, IHeap *const pHeap) | Activ::Port |
Activ::Component::Port(ManagedEndPoint &managedEndPoint, const std::string &name, const PortId portId, IHeap *const pHeap) | Activ::Port |
PortIdSet typedef | Activ::ManagedEndPoint |
PostDiesToThreads() const | Activ::ManagedEndPoint |
PostEmptyResponse(const StatusCode responseStatus, HeapMessage &response) const | Activ::Port |
PostEmptyResponse(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, const StatusCode responseStatus, HeapMessage &response) const | Activ::Port |
PostMessage(const Address &destinationAddress, const MessageType messageType, const MessageBuilder &messageBuilder) const | Activ::Port |
PostMessage(const Address &destinationAddress, const MessageType messageType, const void *pMessage=0, const size_t messageLength=0) const | Activ::Port |
PostMessage(const Address &destinationAddress, const MessageType messageType, HeapMessage &message) const | Activ::Port |
PostRequest(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, const MessageBuilder &messageBuilder) const | Activ::Port |
PostRequest(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, const void *pRequest=0, const size_t requestLength=0) const | Activ::Port |
PostRequest(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, HeapMessage &request) const | Activ::Port |
PostResponse(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, const StatusCode responseStatus, const MessageBuilder &messageBuilder) const | Activ::Port |
PostResponse(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, const StatusCode responseStatus, const void *pResponse=0, const size_t responseLength=0) const | Activ::Port |
PostResponse(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, const StatusCode responseStatus, HeapMessage &response) const | Activ::Port |
PostResponse(const StatusCode responseStatus, HeapMessage &request, const MessageBuilder &messageBuilder) const | Activ::Port |
PostResponse(const StatusCode responseStatus, HeapMessage &request, const void *pResponse, const size_t responseLength) const | Activ::Port |
PostResponse(const StatusCode responseStatus, HeapMessage &request, HeapMessage &response) const | Activ::Port |
PostResponse(const StatusCode responseStatus, HeapMessage &request) const | Activ::Port |
Process() | Activ::ManagedEndPoint | [protected, virtual]
Run() | Activ::ManagedEndPoint |
SendRequest(const Address &destinationAddress, const MessageType requestType, const MessageBuilder &messageBuilder, HeapMessage &response, const TimeoutPeriod timeout=defaultTimeout) const | Activ::Port |
SendRequest(const Address &destinationAddress, const MessageType requestType, const void *pRequest, const size_t requestLength, HeapMessage &response, const TimeoutPeriod timeout=defaultTimeout) const | Activ::Port |
SendRequest(const Address &destinationAddress, const MessageType requestType, HeapMessage &request, const TimeoutPeriod timeout=defaultTimeout) const | Activ::Port |
SendRequest(const Address &destinationAddress, const MessageType requestType, SyncRequestId &syncRequestId, const MessageBuilder &messageBuilder) const | Activ::Port |
SendRequest(const Address &destinationAddress, const MessageType requestType, SyncRequestId &syncRequestId, const void *pRequest, const size_t requestLength) const | Activ::Port |
SendRequest(const Address &destinationAddress, const MessageType requestType, SyncRequestId &syncRequestId, HeapMessage &request) const | Activ::Port |
SetHeap(IHeap *const pHeap) | Activ::Port |
Shutdown() | Activ::Application |
SHUTDOWN_REASON_API enum value | Activ::Application |
SHUTDOWN_REASON_LOGOFF enum value | Activ::Application |
SHUTDOWN_REASON_NOT_LICENSED enum value | Activ::Application |
SHUTDOWN_REASON_PROCESS_KILLED enum value | Activ::Application |
SHUTDOWN_REASON_UI enum value | Activ::Application |
SHUTDOWN_REASON_UI_RESTART enum value | Activ::Application |
SHUTDOWN_REASON_UPDATING enum value | Activ::Application |
ShutdownReason enum name | Activ::Application |
StartThread() | Activ::ManagedEndPoint |
ThinApplication(const Settings &settings, Timeout &timeout=Timeout::GetInfinite(), const std::string &componentId=defaultComponentId) | Activ::ThinApplication |
WaitForThreadsToExit(const TimeoutPeriod timeout=ACTIV_WAIT_INFINITE) const | Activ::ManagedEndPoint |
~Application() | Activ::Application | [virtual]
~Component() | Activ::Component |
~ISystem()=0 | Activ::ISystem | [inline, pure virtual]
~ManagedEndPoint() | Activ::ManagedEndPoint | [virtual]
~Port() | Activ::Port | [virtual]
~SystemProxy() | Activ::SystemProxy |
~ThinApplication() | Activ::ThinApplication | [virtual]

Generated on Wed Oct 8 14:02:00 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ThinApplication::Settings Member List

This is the complete list of members for Activ::ThinApplication::Settings, including all inherited members.

EXCEPTION_HANDLER_TYPE_FULL_MEMORY enum value | Activ::Application::Settings |
EXCEPTION_HANDLER_TYPE_NONE enum value | Activ::Application::Settings |
EXCEPTION_HANDLER_TYPE_NORMAL enum value | Activ::Application::Settings |
ExceptionHandlerType enum name | Activ::Application::Settings |
m_applicationHeapBucketInfo | Activ::ThinApplication::Settings |
m_enableCtrlHandler | Activ::Application::Settings |
m_exceptionHandlerType | Activ::Application::Settings |
m_managedEndPointSettings | Activ::Application::Settings |
m_memoryModel | Activ::ISystem::Settings |
m_minimumTimerResolution | Activ::ISystem::Settings |
m_processName (defined in Activ::ThinApplication::Settings) | Activ::ThinApplication::Settings |
m_processorAffinityList | Activ::ISystem::Settings |
m_processVersion | Activ::ISystem::Settings |
m_setConsoleTitle | Activ::ISystem::Settings |
m_smallBlockHeapThreshold | Activ::ISystem::Settings |
m_systemLogMode | Activ::ISystem::Settings |
m_systemName | Activ::ISystem::Settings |
MEMORY_MODEL_PRIVATE enum value | Activ::ISystem::Settings |
MEMORY_MODEL_SHARED enum value | Activ::ISystem::Settings |
MemoryModel enum name | Activ::ISystem::Settings |
Read(const IniFileParser &iniFileParser) | Activ::ThinApplication::Settings |
Activ::Application::Settings::Read(const IniFileParser::ConstSectionIterator &sectionIterator) | Activ::Application::Settings |
sectionName | Activ::ISystem::Settings | [protected, static]
Settings() | Activ::ThinApplication::Settings |
SYSTEM_LOG_MODE_OFF enum value | Activ::ISystem::Settings |
SYSTEM_LOG_MODE_TO_AGENT enum value | Activ::ISystem::Settings |
SYSTEM_LOG_MODE_TO_CONSOLE enum value | Activ::ISystem::Settings |
SystemLogMode enum name | Activ::ISystem::Settings |

Generated on Wed Oct 8 14:02:00 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Thread Member List

This is the complete list of members for Activ::Thread, including all inherited members.

ActivThreadGlobalThreadProc (defined in Activ::Thread) | Activ::Thread | [friend]
End(StatusCode statusCode=STATUS_CODE_SUCCESS) | Activ::Thread |
GetCurrentId() | Activ::Thread | [static]
GetId() const | Activ::Thread |
GetPriority(uint32_t &priority) const | Activ::Thread |
GetThreadPriority(uint32_t &priority, const Id id=GetCurrentId()) | Activ::Thread | [static]
Id typedef | Activ::Thread |
Process(void *pData)=0 | Activ::Thread | [protected, pure virtual]
ProcessorList typedef | Activ::Thread |
SetName(const std::string &threadName, const Id id=GetCurrentId()) | Activ::Thread | [static]
SetPriority(uint32_t priority) | Activ::Thread |
SetProcessorAffinity(const ProcessorList &processorList, const Id id=GetCurrentId()) | Activ::Thread | [static]
SetThreadPriority(const uint32_t priority, const Id id=GetCurrentId()) | Activ::Thread | [static]
Start(void *pData=0, const size_t stackSize=0) | Activ::Thread |
StringToPriority(const std::string &str, uint32_t &priority) | Activ::Thread | [static]
Suspend(const TimeoutPeriod period) | Activ::Thread | [static]
Thread() | Activ::Thread |
WaitForCompletion(const TimeoutPeriod timeoutPeriod=ACTIV_WAIT_INFINITE) const | Activ::Thread |
~Thread() | Activ::Thread | [virtual]

Generated on Wed Oct 8 14:02:00 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ThreadSpecificData< TYPE, CLEANUP > Member List

This is the complete list of members for Activ::ThreadSpecificData< TYPE, CLEANUP >, including all inherited members.

Get() const | Activ::ThreadSpecificDataBase< TYPE, DERIVED > | [inline]
OnThreadExit(TYPE *const pValue) | Activ::ThreadSpecificData< TYPE, CLEANUP > | [inline]
Set(TYPE *const pValue) | Activ::ThreadSpecificDataBase< TYPE, DERIVED > | [inline]
ThreadSpecificDataBase() | Activ::ThreadSpecificDataBase< TYPE, DERIVED > | [inline]
~ThreadSpecificDataBase() | Activ::ThreadSpecificDataBase< TYPE, DERIVED > | [inline]

Generated on Wed Oct 8 14:02:00 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ThreadSpecificDataBase< TYPE, DERIVED > Member List

This is the complete list of members for Activ::ThreadSpecificDataBase< TYPE, DERIVED >, including all inherited members.

Get() const | Activ::ThreadSpecificDataBase< TYPE, DERIVED > | [inline]
OnThreadExit(TYPE *const pValue) | Activ::ThreadSpecificDataBase< TYPE, DERIVED > |
Set(TYPE *const pValue) | Activ::ThreadSpecificDataBase< TYPE, DERIVED > | [inline]
ThreadSpecificDataBase() | Activ::ThreadSpecificDataBase< TYPE, DERIVED > | [inline]
~ThreadSpecificDataBase() | Activ::ThreadSpecificDataBase< TYPE, DERIVED > | [inline]

Generated on Wed Oct 8 14:02:00 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ThreadSpecificFastPoolAllocator< T, UserAllocator, NextSize > Member List

This is the complete list of members for Activ::ThreadSpecificFastPoolAllocator< T, UserAllocator, NextSize >, including all inherited members.

address(reference r) (defined in Activ::ThreadSpecificFastPoolAllocator< T, UserAllocator, NextSize >) | Activ::ThreadSpecificFastPoolAllocator< T, UserAllocator, NextSize > | [inline, static]
address(const_reference s) (defined in Activ::ThreadSpecificFastPoolAllocator< T, UserAllocator, NextSize >) | Activ::ThreadSpecificFastPoolAllocator< T, UserAllocator, NextSize > | [inline, static]
allocate(const size_type n) (defined in Activ::ThreadSpecificFastPoolAllocator< T, UserAllocator, NextSize >) | Activ::ThreadSpecificFastPoolAllocator< T, UserAllocator, NextSize > | [inline, static]
allocate(const size_type n, const void *const) (defined in Activ::ThreadSpecificFastPoolAllocator< T, UserAllocator, NextSize >) | Activ::ThreadSpecificFastPoolAllocator< T, UserAllocator, NextSize > | [inline, static]
allocate() (defined in Activ::ThreadSpecificFastPoolAllocator< T, UserAllocator, NextSize >) | Activ::ThreadSpecificFastPoolAllocator< T, UserAllocator, NextSize > | [inline, static]
const_pointer typedef (defined in Activ::ThreadSpecificFastPoolAllocator< T, UserAllocator, NextSize >) | Activ::ThreadSpecificFastPoolAllocator< T, UserAllocator, NextSize > |
const_reference typedef (defined in Activ::ThreadSpecificFastPoolAllocator< T, UserAllocator, NextSize >) | Activ::ThreadSpecificFastPoolAllocator< T, UserAllocator, NextSize > |
construct(const pointer ptr, const value_type &t) (defined in Activ::ThreadSpecificFastPoolAllocator< T, UserAllocator, NextSize >) | Activ::ThreadSpecificFastPoolAllocator< T, UserAllocator, NextSize > | [inline, static]
deallocate(const pointer ptr, const size_type n) (defined in Activ::ThreadSpecificFastPoolAllocator< T, UserAllocator, NextSize >) | Activ::ThreadSpecificFastPoolAllocator< T, UserAllocator, NextSize > | [inline, static]
deallocate(const pointer ptr) (defined in Activ::ThreadSpecificFastPoolAllocator< T, UserAllocator, NextSize >) | Activ::ThreadSpecificFastPoolAllocator< T, UserAllocator, NextSize > | [inline, static]
destroy(const pointer ptr) (defined in Activ::ThreadSpecificFastPoolAllocator< T, UserAllocator, NextSize >) | Activ::ThreadSpecificFastPoolAllocator< T, UserAllocator, NextSize > | [inline, static]
difference_type typedef (defined in Activ::ThreadSpecificFastPoolAllocator< T, UserAllocator, NextSize >) | Activ::ThreadSpecificFastPoolAllocator< T, UserAllocator, NextSize > |
max_size() (defined in Activ::ThreadSpecificFastPoolAllocator< T, UserAllocator, NextSize >) | Activ::ThreadSpecificFastPoolAllocator< T, UserAllocator, NextSize > | [inline, static]
next_size (defined in Activ::ThreadSpecificFastPoolAllocator< T, UserAllocator, NextSize >) | Activ::ThreadSpecificFastPoolAllocator< T, UserAllocator, NextSize > | [static]
operator!=(const ThreadSpecificFastPoolAllocator &) const (defined in Activ::ThreadSpecificFastPoolAllocator< T, UserAllocator, NextSize >) | Activ::ThreadSpecificFastPoolAllocator< T, UserAllocator, NextSize > | [inline]
operator==(const ThreadSpecificFastPoolAllocator &) const (defined in Activ::ThreadSpecificFastPoolAllocator< T, UserAllocator, NextSize >) | Activ::ThreadSpecificFastPoolAllocator< T, UserAllocator, NextSize > | [inline]
pointer typedef (defined in Activ::ThreadSpecificFastPoolAllocator< T, UserAllocator, NextSize >) | Activ::ThreadSpecificFastPoolAllocator< T, UserAllocator, NextSize > |
reference typedef (defined in Activ::ThreadSpecificFastPoolAllocator< T, UserAllocator, NextSize >) | Activ::ThreadSpecificFastPoolAllocator< T, UserAllocator, NextSize > |
size_type typedef (defined in Activ::ThreadSpecificFastPoolAllocator< T, UserAllocator, NextSize >) | Activ::ThreadSpecificFastPoolAllocator< T, UserAllocator, NextSize > |
ThreadSpecificFastPoolAllocator() (defined in Activ::ThreadSpecificFastPoolAllocator< T, UserAllocator, NextSize >) | Activ::ThreadSpecificFastPoolAllocator< T, UserAllocator, NextSize > | [inline]
ThreadSpecificFastPoolAllocator(const ThreadSpecificFastPoolAllocator< U, UserAllocator, NextSize > &) (defined in Activ::ThreadSpecificFastPoolAllocator< T, UserAllocator, NextSize >) | Activ::ThreadSpecificFastPoolAllocator< T, UserAllocator, NextSize > | [inline]
user_allocator typedef (defined in Activ::ThreadSpecificFastPoolAllocator< T, UserAllocator, NextSize >) | Activ::ThreadSpecificFastPoolAllocator< T, UserAllocator, NextSize > |
value_type typedef (defined in Activ::ThreadSpecificFastPoolAllocator< T, UserAllocator, NextSize >) | Activ::ThreadSpecificFastPoolAllocator< T, UserAllocator, NextSize > |

Generated on Wed Oct 8 14:02:00 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ThreadSpecificPoolAllocator< T, UserAllocator, NextSize > Member List

This is the complete list of members for Activ::ThreadSpecificPoolAllocator< T, UserAllocator, NextSize >, including all inherited members.

address(reference r) (defined in Activ::ThreadSpecificPoolAllocator< T, UserAllocator, NextSize >) | Activ::ThreadSpecificPoolAllocator< T, UserAllocator, NextSize > | [inline, static]
address(const_reference s) (defined in Activ::ThreadSpecificPoolAllocator< T, UserAllocator, NextSize >) | Activ::ThreadSpecificPoolAllocator< T, UserAllocator, NextSize > | [inline, static]
allocate(const size_type n) (defined in Activ::ThreadSpecificPoolAllocator< T, UserAllocator, NextSize >) | Activ::ThreadSpecificPoolAllocator< T, UserAllocator, NextSize > | [inline, static]
allocate(const size_type n, const void *const) (defined in Activ::ThreadSpecificPoolAllocator< T, UserAllocator, NextSize >) | Activ::ThreadSpecificPoolAllocator< T, UserAllocator, NextSize > | [inline, static]
const_pointer typedef (defined in Activ::ThreadSpecificPoolAllocator< T, UserAllocator, NextSize >) | Activ::ThreadSpecificPoolAllocator< T, UserAllocator, NextSize > |
const_reference typedef (defined in Activ::ThreadSpecificPoolAllocator< T, UserAllocator, NextSize >) | Activ::ThreadSpecificPoolAllocator< T, UserAllocator, NextSize > |
construct(const pointer ptr, const value_type &t) (defined in Activ::ThreadSpecificPoolAllocator< T, UserAllocator, NextSize >) | Activ::ThreadSpecificPoolAllocator< T, UserAllocator, NextSize > | [inline, static]
deallocate(const pointer ptr, const size_type n) (defined in Activ::ThreadSpecificPoolAllocator< T, UserAllocator, NextSize >) | Activ::ThreadSpecificPoolAllocator< T, UserAllocator, NextSize > | [inline, static]
destroy(const pointer ptr) (defined in Activ::ThreadSpecificPoolAllocator< T, UserAllocator, NextSize >) | Activ::ThreadSpecificPoolAllocator< T, UserAllocator, NextSize > | [inline, static]
difference_type typedef (defined in Activ::ThreadSpecificPoolAllocator< T, UserAllocator, NextSize >) | Activ::ThreadSpecificPoolAllocator< T, UserAllocator, NextSize > |
max_size() (defined in Activ::ThreadSpecificPoolAllocator< T, UserAllocator, NextSize >) | Activ::ThreadSpecificPoolAllocator< T, UserAllocator, NextSize > | [inline, static]
next_size (defined in Activ::ThreadSpecificPoolAllocator< T, UserAllocator, NextSize >) | Activ::ThreadSpecificPoolAllocator< T, UserAllocator, NextSize > | [static]
operator!=(const ThreadSpecificPoolAllocator &) const (defined in Activ::ThreadSpecificPoolAllocator< T, UserAllocator, NextSize >) | Activ::ThreadSpecificPoolAllocator< T, UserAllocator, NextSize > | [inline]
operator==(const ThreadSpecificPoolAllocator &) const (defined in Activ::ThreadSpecificPoolAllocator< T, UserAllocator, NextSize >) | Activ::ThreadSpecificPoolAllocator< T, UserAllocator, NextSize > | [inline]
pointer typedef (defined in Activ::ThreadSpecificPoolAllocator< T, UserAllocator, NextSize >) | Activ::ThreadSpecificPoolAllocator< T, UserAllocator, NextSize > |
reference typedef (defined in Activ::ThreadSpecificPoolAllocator< T, UserAllocator, NextSize >) | Activ::ThreadSpecificPoolAllocator< T, UserAllocator, NextSize > |
ReleaseMemory() | Activ::ThreadSpecificPoolAllocator< T, UserAllocator, NextSize > | [inline, static]
size_type typedef (defined in Activ::ThreadSpecificPoolAllocator< T, UserAllocator, NextSize >) | Activ::ThreadSpecificPoolAllocator< T, UserAllocator, NextSize > |
ThreadSpecificPoolAllocator() (defined in Activ::ThreadSpecificPoolAllocator< T, UserAllocator, NextSize >) | Activ::ThreadSpecificPoolAllocator< T, UserAllocator, NextSize > | [inline]
ThreadSpecificPoolAllocator(const ThreadSpecificPoolAllocator< U, UserAllocator, NextSize > &) (defined in Activ::ThreadSpecificPoolAllocator< T, UserAllocator, NextSize >) | Activ::ThreadSpecificPoolAllocator< T, UserAllocator, NextSize > | [inline]
user_allocator typedef (defined in Activ::ThreadSpecificPoolAllocator< T, UserAllocator, NextSize >) | Activ::ThreadSpecificPoolAllocator< T, UserAllocator, NextSize > |
value_type typedef (defined in Activ::ThreadSpecificPoolAllocator< T, UserAllocator, NextSize >) | Activ::ThreadSpecificPoolAllocator< T, UserAllocator, NextSize > |

Generated on Wed Oct 8 14:02:00 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Time Member List

This is the complete list of members for Activ::Time, including all inherited members.

Add(const Time &rhs) | Activ::Time | [inline]
Add(const Hours &hours) | Activ::Time | [inline]
Add(const Minutes &minutes) | Activ::Time | [inline]
Add(const Seconds &seconds) | Activ::Time | [inline]
Add(const Milliseconds &milliseconds) | Activ::Time | [inline]
Assign(const IFieldType *const pIFieldType) | Activ::IFieldType |
Clear() | Activ::Time | [inline, virtual]
Compare(const Time &rhs, int &result) const | Activ::Time |
Compare(const void *const pRhsSerializedBody, const size_t rhsSerializedBodyLength, int &result) const | Activ::Time | [virtual]
Compare(const void *const pLhsSerializedBody, const size_t lhsSerializedBodyLength, const void *const pRhsSerializedBody, const size_t rhsSerializedBodyLength, int &result) | Activ::Time | [static]
Convert(const IFieldType *const pIFieldType) | Activ::Time | [virtual]
ConvertGregorianToJulianTime(const int32_t hour, const int32_t minute, const int32_t second) | Activ::Time | [inline, static]
ConvertJulianToGregorianTime(const int32_t julianTime, int32_t &hour, int32_t &minute, int32_t &second) | Activ::Time | [inline, static]
CreateLocalTime(const bool shouldSetMilliseconds=false) | Activ::Time | [static]
CreateUtcTime(const bool shouldSetMilliseconds=false) | Activ::Time | [static]
DateTime (defined in Activ::Time) | Activ::Time | [friend]
Deserialize(MessageValidator &messageValidator, const size_t maxSerializedBodyLength) | Activ::Time | [virtual]
Activ::IFieldType::Deserialize(const FieldType fieldType, MessageValidator &messageValidator, const size_t maxSerializedBodyLength) | Activ::IFieldType |
DeserializeBody(const void *const pSerializedBody, const size_t serializedBodyLength) | Activ::Time | [virtual]
Activ::IFieldType::DeserializeBody(const FieldType fieldType, const void *const pSerializedBody, const size_t serializedBodyLength) | Activ::IFieldType |
DeserializeLengthAndBody(MessageValidator &messageValidator, const size_t maxSerializedBodyLength=MAX_SERIALIZED_BODY_LENGTH_UNDEFINED) | Activ::Time | [virtual]
Activ::IFieldType::DeserializeLengthAndBody(const FieldType fieldType, MessageValidator &messageValidator, const size_t maxSerializedBodyLength=MAX_SERIALIZED_BODY_LENGTH_UNDEFINED) | Activ::IFieldType |
FIELD_TYPE | Activ::Time | [static]
FromString(MessageValidator &messageValidator) | Activ::Time | [virtual]
Activ::IFieldType::FromString(const std::string &field) | Activ::IFieldType | [inline]
Get() const | Activ::Time | [inline]
Get(uint32_t &hour, uint32_t &minute, uint32_t &second) const | Activ::Time | [inline]
Get(uint32_t &hour, uint32_t &minute, uint32_t &second, uint32_t &millisecond) const | Activ::Time | [inline]
Get(int32_t &julianTime) const | Activ::Time | [inline]
Get(int32_t &julianTime, uint32_t &millisecond) const | Activ::Time | [inline]
Get(std::tm &tm) const | Activ::Time | [inline]
Get(std::tm &tm, uint32_t &millisecond) const | Activ::Time | [inline]
GetFromStringFormat() const | Activ::Time | [virtual]
GetHour() const | Activ::Time | [inline]
GetLocal() const | Activ::Time | [inline]
GetMaxSerializedBodyLength(const bool shouldSerializeMilliseconds) | Activ::Time | [inline, static]
GetMaxSerializedLength(const bool shouldSerializeMilliseconds) | Activ::Time | [inline, static]
GetMillisecond() const | Activ::Time | [inline]
GetMinute() const | Activ::Time | [inline]
GetSecond() const | Activ::Time | [inline]
GetSerializedBodyLength() const | Activ::Time | [inline, virtual]
GetSerializedBodyLength(const void *const pSerializedBody) | Activ::Time | [inline, static]
GetSerializedLength() const | Activ::Time | [inline, virtual]
GetSerializedLength(const void *const pSerializedBody) | Activ::Time | [inline, static]
GetTimeZoneOffset() | Activ::Time | [static]
GetTotalMilliseconds() const | Activ::Time | [inline]
GetType() const | Activ::IFieldType | [inline]
GetUtc() const | Activ::Time | [inline]
IFieldType(const FieldType fieldType) | Activ::IFieldType | [inline, explicit, protected]
IsDifferent(const void *const pRhsSerializedBody, const size_t rhsSerializedBodyLength, bool &isDifferent) const | Activ::Time | [virtual]
IsInitialized() const | Activ::IFieldType | [inline]
IsValidSerializedBodyLength(const size_t serializedBodyLength) | Activ::Time | [inline, static]
Activ::IFieldType::IsValidSerializedBodyLength(const FieldType fieldType, const size_t serializedBodyLength) | Activ::IFieldType | [static]
m_isInitialized | Activ::IFieldType | [protected]
MAX_SERIALIZED_BODY_LENGTH_UNDEFINED | Activ::IFieldType | [static]
operator!=(const Time &rhs) const | Activ::Time | [inline]
operator+(const T &rhs) const | Activ::Time | [inline]
operator+=(const T &rhs) | Activ::Time | [inline]
operator-(const T &rhs) const | Activ::Time | [inline]
operator-=(const T &rhs) | Activ::Time | [inline]
operator<(const Time &rhs) const | Activ::Time | [inline]
operator<=(const Time &rhs) const | Activ::Time | [inline]
operator==(const Time &rhs) const | Activ::Time | [inline]
operator>(const Time &rhs) const | Activ::Time | [inline]
operator>=(const Time &rhs) const | Activ::Time | [inline]
Reset() | Activ::Time | [inline, virtual]
Serialize(MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength) const | Activ::Time | [virtual]
Activ::IFieldType::Serialize(const FieldType fieldType, MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength) const | Activ::IFieldType |
Activ::IFieldType::Serialize(const FieldType fieldType, MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength, const uint8_t *const pData, const size_t size) | Activ::IFieldType | [static]
SerializeBody(void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength) const | Activ::Time | [virtual]
Activ::IFieldType::SerializeBody(const FieldType fieldType, void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength) const | Activ::IFieldType |
Activ::IFieldType::SerializeBody(const FieldType fieldType, void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength, const uint8_t *const pData, const size_t size) | Activ::IFieldType | [static]
SerializeLengthAndBody(MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength=MAX_SERIALIZED_BODY_LENGTH_UNDEFINED) const | Activ::Time | [virtual]
Activ::IFieldType::SerializeLengthAndBody(const FieldType fieldType, MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength=MAX_SERIALIZED_BODY_LENGTH_UNDEFINED) const | Activ::IFieldType |
Activ::IFieldType::SerializeLengthAndBody(const FieldType fieldType, MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength, const uint8_t *const pData, const size_t size) | Activ::IFieldType | [static]
Set(const uint32_t hour, const uint32_t minute, const uint32_t second, const uint32_t millisecond=0) | Activ::Time | [inline]
Set(const int32_t julianTime, const uint32_t millisecond=0) | Activ::Time | [inline]
Set(const std::tm &tm, const uint32_t millisecond=0) | Activ::Time | [inline]
Subtract(const Time &rhs) | Activ::Time | [inline]
Subtract(const Hours &hours) | Activ::Time | [inline]
Subtract(const Minutes &minutes) | Activ::Time | [inline]
Subtract(const Seconds &seconds) | Activ::Time | [inline]
Subtract(const Milliseconds &milliseconds) | Activ::Time | [inline]
Time() | Activ::Time | [inline]
Time(const uint32_t hour, const uint32_t minute, const uint32_t second, const uint32_t millisecond=0) | Activ::Time | [inline]
Time(const int32_t julianTime, const uint32_t millisecond=0) | Activ::Time | [inline, explicit]
Time(const std::tm &tm, const uint32_t millisecond=0) | Activ::Time | [inline]
ToString() const | Activ::Time | [virtual]
ToString(const bool shouldDisplayMilliseconds) const | Activ::Time |
ValidateSerializedLengthAndBody(MessageValidator &messageValidator, size_t &serializedBodyOffset, size_t &serializedBodyLength) | Activ::Time | [static]
Activ::IFieldType::ValidateSerializedLengthAndBody(const FieldType fieldType, MessageValidator &messageValidator, size_t &serializedBodyOffset, size_t &serializedBodyLength) | Activ::IFieldType | [static]
~IFieldType()=0 | Activ::IFieldType | [inline, pure virtual]
~Time() | Activ::Time | [inline, virtual]

Generated on Wed Oct 8 14:02:00 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Time::Hours Member List

This is the complete list of members for Activ::Time::Hours, including all inherited members.

Hours(const int32_t value) | Activ::Time::Hours | [inline, explicit]
m_value | Activ::Time::Hours |
NUMBER_PER_DAY | Activ::Time::Hours | [static]

Generated on Wed Oct 8 14:02:00 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Time::Milliseconds Member List

This is the complete list of members for Activ::Time::Milliseconds, including all inherited members.

m_value | Activ::Time::Milliseconds |
Milliseconds(const int32_t value) | Activ::Time::Milliseconds | [inline, explicit]
NUMBER_PER_DAY | Activ::Time::Milliseconds | [static]
NUMBER_PER_HOUR | Activ::Time::Milliseconds | [static]
NUMBER_PER_MINUTE | Activ::Time::Milliseconds | [static]
NUMBER_PER_SECOND | Activ::Time::Milliseconds | [static]

Generated on Wed Oct 8 14:02:00 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Time::Minutes Member List

This is the complete list of members for Activ::Time::Minutes, including all inherited members.

m_value | Activ::Time::Minutes |
Minutes(const int32_t value) | Activ::Time::Minutes | [inline, explicit]
NUMBER_PER_DAY | Activ::Time::Minutes | [static]
NUMBER_PER_HOUR | Activ::Time::Minutes | [static]

Generated on Wed Oct 8 14:02:00 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Time::Seconds Member List

This is the complete list of members for Activ::Time::Seconds, including all inherited members.

m_value | Activ::Time::Seconds |
NUMBER_PER_DAY | Activ::Time::Seconds | [static]
NUMBER_PER_HOUR | Activ::Time::Seconds | [static]
NUMBER_PER_MINUTE | Activ::Time::Seconds | [static]
Seconds(const int32_t value) | Activ::Time::Seconds | [inline, explicit]

Generated on Wed Oct 8 14:02:00 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Timeband Member List

This is the complete list of members for Activ::Timeband, including all inherited members.

AddDisabledDate(const Date &disabledDate) | Activ::Timeband |
ConvertStringToEnabledDaysBitmap(const std::string enabledDaysBitmapString, EnabledDaysBitmap &enabledDaysBitmap) | Activ::Timeband | [static]
DateSet typedef | Activ::Timeband |
ENABLED_DATE_END_TIME enum value (defined in Activ::Timeband) | Activ::Timeband |
ENABLED_DATE_START_TIME enum value (defined in Activ::Timeband) | Activ::Timeband |
EnabledDateFlag enum name | Activ::Timeband |
EnabledDaysBitmap typedef | Activ::Timeband |
GetDisabledDateSet() const | Activ::Timeband | [inline]
GetDisabledDateSetString() const | Activ::Timeband |
GetEnabledDateFlag() const | Activ::Timeband | [inline]
GetEnabledDateFlagString() const | Activ::Timeband |
GetEnabledDaysString() const | Activ::Timeband |
GetEndTime() const | Activ::Timeband | [inline]
GetStartTime() const | Activ::Timeband | [inline]
IsIn(const DateTime &dateTime) const | Activ::Timeband |
IsIn(const LocalTime &localTime) const | Activ::Timeband | [inline]
operator!=(const Timeband &rhs) const | Activ::Timeband |
operator=(const Timeband &rhs) | Activ::Timeband |
operator==(const Timeband &rhs) const | Activ::Timeband |
Read(const std::string &keyNamePrefix, const IniFileParser::ConstSectionIterator &sectionIterator) (defined in Activ::Timeband) | Activ::Timeband | [inline]
RemoveDisabledDate(const Date &disabledDate) | Activ::Timeband |
SetDisabledDateSet(const DateSet &disabledDateSet) | Activ::Timeband | [inline]
SetEnabledDateFlag(const EnabledDateFlag enabledDateFlag) | Activ::Timeband | [inline]
SetEnabledDaysString(const std::string &enabledDaysString) | Activ::Timeband | [inline]
SetEndTime(const Time &endTime) | Activ::Timeband | [inline]
SetStartTime(const Time &startTime) | Activ::Timeband | [inline]
Timeband() | Activ::Timeband |
Timeband(const Settings &settings) | Activ::Timeband |
Timeband(const Time &startTime, const Time &endTime, const std::string &enabledDaysBitmapString, const EnabledDateFlag enabledDateFlag=ENABLED_DATE_END_TIME, const DateSet &disabledDateSet=DateSet()) | Activ::Timeband |
ToLogString() const | Activ::Timeband |
ToString() const | Activ::Timeband |

Generated on Wed Oct 8 14:02:01 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Timeband::Settings Member List

This is the complete list of members for Activ::Timeband::Settings, including all inherited members.

m_disabledDateSet | Activ::Timeband::Settings
m_enabledDateFlag | Activ::Timeband::Settings
m_enabledDaysBitmap | Activ::Timeband::Settings
m_endTime | Activ::Timeband::Settings
m_startTime | Activ::Timeband::Settings
Read(const std::string &keyNamePrefix, const IniFileParser::ConstSectionIterator &sectionIterator) (defined in Activ::Timeband::Settings) | Activ::Timeband::Settings
Settings() | Activ::Timeband::Settings
Settings(const Time &startTime, const Time &endTime, const std::string &enabledDaysBitmapString, const EnabledDateFlag enabledDateFlag=ENABLED_DATE_END_TIME, const DateSet &disabledDateSet=DateSet()) | Activ::Timeband::Settings

Generated on Wed Oct 8 14:02:01 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Timeout Member List

This is the complete list of members for Activ::Timeout, including all inherited members.

GetInfinite() | Activ::Timeout | [inline, static]
GetPeriodLeft() const | Activ::Timeout |
GetZero() | Activ::Timeout | [inline, static]
operator()(TimeoutPeriod sleepPeriod=500) | Activ::Timeout |
Timeout(TimeoutPeriod maxTimeout) | Activ::Timeout |

Generated on Wed Oct 8 14:02:01 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::TimerServiceApi Member List

This is the complete list of members for Activ::TimerServiceApi, including all inherited members.

AdjustSystemTime(const Component &component, const int32_t milliseconds) | Activ::TimerServiceApi | [static]
CancelTimer(const Component &component, Address &timerAddress) | Activ::TimerServiceApi | [static]
CancelTimers(const Component &component) | Activ::TimerServiceApi | [static]
GetCurrentLocalDate(const Component &component, Date &date) | Activ::TimerServiceApi | [static]
GetCurrentLocalDateTime(const Component &component, DateTime &dateTime, const bool shouldSetMilliseconds=false) | Activ::TimerServiceApi | [static]
GetCurrentLocalTime(const Component &component, Time &time, const bool shouldSetMilliseconds=false) | Activ::TimerServiceApi | [static]
GetCurrentUtcDate(const Component &component, Date &date) | Activ::TimerServiceApi | [static]
GetCurrentUtcDateTime(const Component &component, DateTime &dateTime, const bool shouldSetMilliseconds=false) | Activ::TimerServiceApi | [static]
GetCurrentUtcTime(const Component &component, Time &time, const bool shouldSetMilliseconds=false) | Activ::TimerServiceApi | [static]
SetTimer(const Component &component, const BaseTime &time, Address::Proxy timerAddress) | Activ::TimerServiceApi | [static]
SetTimer(const Component &component, const BaseTime::Duration &duration, Address::Proxy timerAddress) | Activ::TimerServiceApi | [static]
SetTimer(const Component &component, const BaseTime &time, const BaseTime::Duration &duration, Address::Proxy timerAddress) | Activ::TimerServiceApi | [static]

Generated on Wed Oct 8 14:02:01 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::TypeToIntegralType< T > Member List

This is the complete list of members for Activ::TypeToIntegralType< T >, including all inherited members.

Type typedef (defined in Activ::TypeToIntegralType< T >) Activ::TypeToIntegralType< T >

Generated on Wed Oct 8 14:02:01 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::UInt Member List

This is the complete list of members for Activ::UInt, including all inherited members.

Add(const UInt &rhs) | Activ::UInt |
Assign(const IFieldType *const pIFieldType) | Activ::IFieldType |
Clear() | Activ::UInt | [inline, virtual]
Compare(const UInt &rhs, int &result) const | Activ::UInt |
Compare(const void *const pRhsSerializedBody, const size_t rhsSerializedBodyLength, int &result) const | Activ::UInt | [virtual]
Compare(const void *const pLhsSerializedBody, const size_t lhsSerializedBodyLength, const void *const pRhsSerializedBody, const size_t rhsSerializedBodyLength, int &result) | Activ::UInt | [static]
Convert(const IFieldType *const pIFieldType) | Activ::UInt | [virtual]
Deserialize(MessageValidator &messageValidator, const size_t maxSerializedBodyLength) | Activ::UInt | [virtual]
Activ::IFieldType::Deserialize(const FieldType fieldType, MessageValidator &messageValidator, const size_t maxSerializedBodyLength) | Activ::IFieldType |
DeserializeBody(const void *const pSerializedBody, const size_t serializedBodyLength) | Activ::UInt | [virtual]
Activ::IFieldType::DeserializeBody(const FieldType fieldType, const void *const pSerializedBody, const size_t serializedBodyLength) | Activ::IFieldType |
DeserializeLengthAndBody(MessageValidator &messageValidator, const size_t maxSerializedBodyLength=MAX_SERIALIZED_BODY_LENGTH_UNDEFINED) | Activ::UInt | [virtual]
Activ::IFieldType::DeserializeLengthAndBody(const FieldType fieldType, MessageValidator &messageValidator, const size_t maxSerializedBodyLength=MAX_SERIALIZED_BODY_LENGTH_UNDEFINED) | Activ::IFieldType |
Divide(const UInt &rhs) | Activ::UInt |
FIELD_TYPE | Activ::UInt | [static]
FromString(MessageValidator &messageValidator) | Activ::UInt | [virtual]
Activ::IFieldType::FromString(const std::string &field) | Activ::IFieldType | [inline]
Get(uint64_t &value) const | Activ::UInt | [inline]
Get() const | Activ::UInt | [inline]
GetFromStringFormat() const | Activ::UInt | [virtual]
GetMaxSerializedBodyLength(const size_t size) | Activ::UInt | [inline, static]
GetMaxSerializedLength(const size_t size) | Activ::UInt | [inline, static]
GetSerializedBodyLength() const | Activ::UInt | [inline, virtual]
GetSerializedLength() const | Activ::UInt | [inline, virtual]
GetType() const | Activ::IFieldType | [inline]
IFieldType(const FieldType fieldType) | Activ::IFieldType | [inline, explicit, protected]
IsDifferent(const void *const pRhsSerializedBody, const size_t rhsSerializedBodyLength, bool &isDifferent) const | Activ::UInt | [virtual]
IsInitialized() const | Activ::IFieldType | [inline]
IsValidSerializedBodyLength(const size_t serializedBodyLength) | Activ::UInt | [inline, static]
Activ::IFieldType::IsValidSerializedBodyLength(const FieldType fieldType, const size_t serializedBodyLength) | Activ::IFieldType | [static]
m_isInitialized | Activ::IFieldType | [protected]
MAX_SERIALIZED_BODY_LENGTH_UNDEFINED | Activ::IFieldType | [static]
Multiply(const UInt &rhs) | Activ::UInt |
operator *=(const UInt &rhs) | Activ::UInt | [inline]
operator const Rational() const | Activ::UInt |
operator const SInt() const | Activ::UInt |
operator!=(const UInt &rhs) const | Activ::UInt | [inline]
operator+=(const UInt &rhs) | Activ::UInt | [inline]
operator-=(const UInt &rhs) | Activ::UInt | [inline]
operator/=(const UInt &rhs) | Activ::UInt | [inline]
operator<(const UInt &rhs) const | Activ::UInt | [inline]
operator<=(const UInt &rhs) const | Activ::UInt | [inline]
operator==(const UInt &rhs) const | Activ::UInt | [inline]
operator>(const UInt &rhs) const | Activ::UInt | [inline]
operator>=(const UInt &rhs) const | Activ::UInt | [inline]
Reset() | Activ::UInt | [inline, virtual]
Serialize(MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength) const | Activ::UInt | [virtual]
Activ::IFieldType::Serialize(const FieldType fieldType, MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength) const | Activ::IFieldType |
Activ::IFieldType::Serialize(const FieldType fieldType, MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength, const uint8_t *const pData, const size_t size) | Activ::IFieldType | [static]
SerializeBody(void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength) const | Activ::UInt | [virtual]
Activ::IFieldType::SerializeBody(const FieldType fieldType, void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength) const | Activ::IFieldType |
Activ::IFieldType::SerializeBody(const FieldType fieldType, void *pSerializedBody, const size_t maxSerializedBodyLength, size_t &serializedBodyLength, const uint8_t *const pData, const size_t size) | Activ::IFieldType | [static]
SerializeLengthAndBody(MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength=MAX_SERIALIZED_BODY_LENGTH_UNDEFINED) const | Activ::UInt | [virtual]
Activ::IFieldType::SerializeLengthAndBody(const FieldType fieldType, MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength=MAX_SERIALIZED_BODY_LENGTH_UNDEFINED) const | Activ::IFieldType |
Activ::IFieldType::SerializeLengthAndBody(const FieldType fieldType, MessageBuilder &messageBuilder, const size_t maxSerializedBodyLength, const uint8_t *const pData, const size_t size) | Activ::IFieldType | [static]
Set(const uint64_t value) | Activ::UInt | [inline]
Subtract(const UInt &rhs) | Activ::UInt |
ToString() const | Activ::UInt | [virtual]
UInt() | Activ::UInt | [inline]
UInt(const uint64_t value) | Activ::UInt | [inline]
ValidateSerializedLengthAndBody(MessageValidator &messageValidator, size_t &serializedBodyOffset, size_t &serializedBodyLength) | Activ::UInt | [static]
Activ::IFieldType::ValidateSerializedLengthAndBody(const FieldType fieldType, MessageValidator &messageValidator, size_t &serializedBodyOffset, size_t &serializedBodyLength) | Activ::IFieldType | [static]
~IFieldType()=0 | Activ::IFieldType | [inline, pure virtual]
~UInt() | Activ::UInt | [inline, virtual]

Generated on Wed Oct 8 14:02:02 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::UdpComponent Member List

This is the complete list of members for Activ::UdpComponent, including all inherited members.

anonymousName | Activ::Port | [static]
Close(const Address &socketAddress, const bool gracefully=false) const | Activ::UdpComponent |
Component(Application &application, ManagedEndPoint &managedEndPoint, const std::string &name=anonymousName, IHeap *const pHeap=0, const std::string &componentId=defaultComponentId) | Activ::Component |
Connect(const Address &socketAddress, const std::string &remoteAddressString, const uint16_t remotePort) const | Activ::UdpComponent |
CreateSocket(const std::string &localAddress, const uint16_t localPort, const uint16_t maxRxSize, Address &socketAddress, IHeap *const pHeap=0) const | Activ::UdpComponent |
defaultComponentId | Activ::Component | [static]
defaultTimeout | Activ::Port | [static]
Disable() | Activ::Port |
Disconnect(const Address &socketAddress) const | Activ::UdpComponent |
Enable() | Activ::Port |
FindPort(const std::string &endPointName, const std::string &portName, Address &portAddress, const TimeoutPeriod timeout=defaultTimeout) | Activ::Port |
ForwardMessage(const Address &destinationAddress, HeapMessage &message, const MessageType newType=INVALID_MESSAGE_TYPE) const | Activ::Port |
GetAddress() const | Activ::Port | [inline]
GetApplication() const | Activ::Component |
GetHeap() const | Activ::Port | [inline]
GetManagedEndPoint() const | Activ::Port |
GetName() const | Activ::Port |
GetSocketHandle(const Address &socketAddress, SOCKET &socket) const | Activ::UdpComponent |
JoinMulticastGroup(const Address &socketAddress, const std::string &multicastGroupString, const std::string &interfaceAddressString) const | Activ::UdpComponent |
LeaveMulticastGroup(const Address &socketAddress, const std::string &multicastGroupString, const std::string &interfaceAddressString) const | Activ::UdpComponent |
ManagedEndPoint::Impl (defined in Activ::Port) | Activ::Port | [friend]
OnAccept(HeapMessage &acceptMessage) | Activ::Component | [protected, virtual]
OnBreak(HeapMessage &breakMessage) | Activ::Component | [protected, virtual]
OnConnect(HeapMessage &connectMessage) | Activ::Component | [protected, virtual]
OnConnectFailed(HeapMessage &connectFailMessage) | Activ::Component | [protected, virtual]
OnData(HeapMessage &heapMessage) | Activ::Component | [protected, virtual]
OnDisconnect(HeapMessage &disconnectMessage) | Activ::Component | [protected, virtual]
OnMessage(HeapMessage &message) | Activ::UdpComponent | [protected, virtual]
OnRequest(HeapMessage &request) | Activ::Component | [protected, virtual]
OnResponse(HeapMessage &response) | Activ::Port | [protected, virtual]
OnSocketClose(const Address &socketAddress) | Activ::UdpComponent | [protected, virtual]
OnSocketError(const Address &socketAddress) | Activ::UdpComponent | [protected, virtual]
OnTimer(const Address &timerAddress, const BaseTime &time) | Activ::Component | [protected, virtual]
Port(ManagedEndPoint &managedEndPoint, const std::string &name, IHeap *const pHeap) | Activ::Port |
Port(ManagedEndPoint &managedEndPoint, const std::string &name, const PortId portId, IHeap *const pHeap) | Activ::Port |
PostData(const Address &socketAddress, HeapMessage &heapMessage) const | Activ::UdpComponent |
PostData(const Address &socketAddress, const void *pData, const size_t dataLength) const | Activ::UdpComponent |
PostEmptyResponse(const StatusCode responseStatus, HeapMessage &response) const | Activ::Port |
PostEmptyResponse(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, const StatusCode responseStatus, HeapMessage &response) const | Activ::Port |
PostMessage(const Address &destinationAddress, const MessageType messageType, const MessageBuilder &messageBuilder) const | Activ::Port |
PostMessage(const Address &destinationAddress, const MessageType messageType, const void *pMessage=0, const size_t messageLength=0) const | Activ::Port |
PostMessage(const Address &destinationAddress, const MessageType messageType, HeapMessage &message) const | Activ::Port |
PostRequest(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, const MessageBuilder &messageBuilder) const | Activ::Port |
PostRequest(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, const void *pRequest=0, const size_t requestLength=0) const | Activ::Port |
PostRequest(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, HeapMessage &request) const | Activ::Port |
PostResponse(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, const StatusCode responseStatus, const MessageBuilder &messageBuilder) const | Activ::Port |
PostResponse(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, const StatusCode responseStatus, const void *pResponse=0, const size_t responseLength=0) const | Activ::Port |
PostResponse(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, const StatusCode responseStatus, HeapMessage &response) const | Activ::Port |
PostResponse(const StatusCode responseStatus, HeapMessage &request, const MessageBuilder &messageBuilder) const | Activ::Port |
PostResponse(const StatusCode responseStatus, HeapMessage &request, const void *pResponse, const size_t responseLength) const | Activ::Port |
PostResponse(const StatusCode responseStatus, HeapMessage &request, HeapMessage &response) const | Activ::Port |
PostResponse(const StatusCode responseStatus, HeapMessage &request) const | Activ::Port |
Read(const Address &socketAddress) const | Activ::UdpComponent |
SendRequest(const Address &destinationAddress, const MessageType requestType, const MessageBuilder &messageBuilder, HeapMessage &response, const TimeoutPeriod timeout=defaultTimeout) const | Activ::Port |
SendRequest(const Address &destinationAddress, const MessageType requestType, const void *pRequest, const size_t requestLength, HeapMessage &response, const TimeoutPeriod timeout=defaultTimeout) const | Activ::Port |
SendRequest(const Address &destinationAddress, const MessageType requestType, HeapMessage &request, const TimeoutPeriod timeout=defaultTimeout) const | Activ::Port |
SendRequest(const Address &destinationAddress, const MessageType requestType, SyncRequestId &syncRequestId, const MessageBuilder &messageBuilder) const | Activ::Port |
SendRequest(const Address &destinationAddress, const MessageType requestType, SyncRequestId &syncRequestId, const void *pRequest, const size_t requestLength) const | Activ::Port |
SendRequest(const Address &destinationAddress, const MessageType requestType, SyncRequestId &syncRequestId, HeapMessage &request) const | Activ::Port |
SetHeap(IHeap *const pHeap) | Activ::Port |
SetMulticastLoopback(const Address &socketAddress, const bool enable) const | Activ::UdpComponent |
SetMulticastTtl(const Address &socketAddress, const int ttl) const | Activ::UdpComponent |
SetMulticastTxInterface(const Address &socketAddress, const std::string &interfaceAddressString) const | Activ::UdpComponent |
SetRxBufferSize(const Address &socketAddress, const int size) const | Activ::UdpComponent |
SetTxBufferSize(const Address &socketAddress, const int size) const | Activ::UdpComponent |
SetUnicastTtl(const Address &socketAddress, const int ttl) const | Activ::UdpComponent |
UdpComponent(Application &application, ManagedEndPoint &managedEndPoint, const std::string &name=Port::anonymousName, IHeap *const pHeap=0, const std::string &componentId=defaultComponentId) | Activ::UdpComponent |
~Component() | Activ::Component |
~Port() | Activ::Port | [virtual]
~UdpComponent() | Activ::UdpComponent |

Generated on Wed Oct 8 14:02:01 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::UdpSocket Member List

This is the complete list of members for Activ::UdpSocket, including all inherited members.

AbortiveClose() | Activ::UdpSocket |
ACTIV_DECLARE_VALUE_WITH_COMMA enum value (defined in Activ::UdpSocket) | Activ::UdpSocket |
AppendRxBuffer(void *pData, const size_t dataLength) | Activ::IpSocket | [inline]
AppendTxBuffer(const void *pData, const size_t dataLength) | Activ::IpSocket | [inline]
CleanupIo() | Activ::IpSocket | [protected]
CloseSocket() | Activ::IpSocket | [protected]
COMPLETION_RESULT_CLOSE_SOCKET enum value | Activ::IpSocket |
COMPLETION_RESULT_OK enum value | Activ::IpSocket |
CompletionResult enum name | Activ::IpSocket |
Connect(const std::string &remoteAddressString, const uint16_t remotePort) | Activ::UdpSocket |
Connect(const IpAddress &remoteAddress) | Activ::UdpSocket |
Disconnect() | Activ::UdpSocket |
GET_BUFFERS_RESULT_CLOSE_SOCKET enum value | Activ::IpSocket |
GET_BUFFERS_RESULT_NO_MORE_BUFFERS enum value | Activ::IpSocket |
GetBuffersResult enum name | Activ::IpSocket |
GetLocalAddress(IpAddress &ipAddress) const | Activ::IpSocket |
GetRemoteAddress(IpAddress &ipAddress) const | Activ::IpSocket |
GetSocketHandle() const | Activ::IpSocket |
GetSocketOption(const int optionName, char *pOptionValue, socklen_t *pOptionLength, const int level=SOL_SOCKET) | Activ::IpSocket |
Initialize(const std::string &localAddressString, const uint16_t localPort) | Activ::UdpSocket |
Initialize(const IpAddress &localAddress) | Activ::UdpSocket |
IpSocket(IpManager &ipManager, const Settings &settings) | Activ::IpSocket |
JoinMulticastGroup(const std::string &multicastGroupString, const std::string &interfaceAddressString) | Activ::UdpSocket |
LeaveMulticastGroup(const std::string &multicastGroupString, const std::string &interfaceAddressString) | Activ::UdpSocket |
LockedRead() | Activ::IpSocket | [inline]
LockedWrite() | Activ::IpSocket | [inline]
m_closeOnTxCompletion | Activ::IpSocket | [protected]
m_closePosted | Activ::IpSocket | [protected]
m_fromAddress | Activ::IpSocket | [protected]
m_handle | Activ::IpSocket | [protected]
m_ipManager | Activ::IpSocket | [protected]
m_localAddress | Activ::IpSocket | [protected]
m_pMutex | Activ::IpSocket | [protected]
m_remoteAddress | Activ::IpSocket | [protected]
m_rxBuffers | Activ::IpSocket | [protected]
m_rxBytes | Activ::IpSocket | [protected]
m_rxFlags | Activ::IpSocket | [protected]
m_rxOverlapped | Activ::IpSocket | [protected]
m_state | Activ::UdpSocket | [protected]
m_toAddress | Activ::IpSocket | [protected]
m_txBuffers | Activ::IpSocket | [protected]
m_txBytes | Activ::IpSocket | [protected]
m_txFlags | Activ::IpSocket | [protected]
m_txOverlapped | Activ::IpSocket | [protected]
OnCleanupIo() | Activ::IpSocket | [protected, virtual]
OnError() | Activ::UdpSocket | [protected, virtual]
OnGetRxBuffers() | Activ::IpSocket | [protected, virtual]
OnGetTxBuffers() | Activ::IpSocket | [protected, virtual]
OnInitializeIo() | Activ::IpSocket | [protected, virtual]
OnRxBuffers(const size_t dataLength) | Activ::UdpSocket | [protected, virtual]
OnSetSocketOptions() | Activ::IpSocket | [protected, virtual]
OnShutdown() | Activ::UdpSocket | [protected, virtual]
OnTxBuffers(const size_t dataLength) | Activ::UdpSocket | [protected, virtual]
PostRead() | Activ::IpSocket | [protected]
PostWrite() | Activ::IpSocket | [protected]
PreLockedRead() | Activ::IpSocket | [inline]
PreLockedWrite() | Activ::IpSocket | [inline]
SetMulticastLoopback(const bool isEnabled) | Activ::UdpSocket |
SetMulticastTtl(const int ttl) | Activ::UdpSocket |
SetMulticastTxInterface(const std::string &interfaceAddressString) | Activ::UdpSocket |
SetRxBufferSize(const int size) | Activ::IpSocket |
SetSocketOption(const int optionName, const char *pOptionValue, const socklen_t optionLength, const int level=SOL_SOCKET) | Activ::IpSocket |
SetTxBufferSize(const int size) | Activ::IpSocket |
SetUnicastTtl(const int ttl) | Activ::UdpSocket |
Shutdown(const bool gracefully=false) | Activ::UdpSocket |
ShutdownSocket() | Activ::IpSocket | [protected]
State enum name | Activ::UdpSocket |
StateToString(const State state) | Activ::UdpSocket | [static]
UdpSocket(IpManager &manager, const Settings &settings=Settings()) | Activ::UdpSocket |
~IpSocket() | Activ::IpSocket | [virtual]
~UdpSocket() | Activ::UdpSocket |

Generated on Wed Oct 8 14:02:01 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::UdpSocket::Settings Member List

This is the complete list of members for Activ::UdpSocket::Settings, including all inherited members.

m_shouldCork | Activ::IpSocket::Settings
Settings(const bool shouldCork=false) | Activ::UdpSocket::Settings

Generated on Wed Oct 8 14:02:01 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::UdpSocket::Stats Member List

This is the complete list of members for Activ::UdpSocket::Stats, including all inherited members.

Get(const SOCKET_TYPE &socket) | Activ::IpSocket::Stats | [inline, static]
m_closeOnTxCompletion | Activ::IpSocket::Stats |
m_closePosted | Activ::IpSocket::Stats |
m_localAddress | Activ::IpSocket::Stats |
m_mutexContentionCount | Activ::IpSocket::Stats |
m_remoteAddress | Activ::IpSocket::Stats |
m_rxBytes | Activ::IpSocket::Stats |
m_rxPosted | Activ::IpSocket::Stats |
m_state | Activ::UdpSocket::Stats |
m_txBytes | Activ::IpSocket::Stats |
m_txPosted | Activ::IpSocket::Stats |
Stats(const UdpSocket &socket) | Activ::UdpSocket::Stats |
Activ::IpSocket::Stats::Stats(const IpSocket &socket) | Activ::IpSocket::Stats |

Generated on Wed Oct 8 14:02:01 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::UiComponent Member List

This is the complete list of members for Activ::UiComponent, including all inherited members.

anonymousName | Activ::Port | [static]
Component(Application &application, ManagedEndPoint &managedEndPoint, const std::string &name=anonymousName, IHeap *const pHeap=0, const std::string &componentId=defaultComponentId) | Activ::Component |
defaultComponentId | Activ::Component | [static]
defaultTimeout | Activ::Port | [static]
Disable() | Activ::Port |
Enable() | Activ::Port |
FindPort(const std::string &endPointName, const std::string &portName, Address &portAddress, const TimeoutPeriod timeout=defaultTimeout) | Activ::Port |
ForwardMessage(const Address &destinationAddress, HeapMessage &message, const MessageType newType=INVALID_MESSAGE_TYPE) const | Activ::Port |
GetAddress() const | Activ::Port | [inline]
GetApplication() const | Activ::Component |
GetHeap() const | Activ::Port | [inline]
GetManagedEndPoint() const | Activ::Port |
GetName() const | Activ::Port |
GetUiServiceName() const | Activ::UiComponent |
ManagedEndPoint::Impl (defined in Activ::Port) | Activ::Port | [friend]
OnAccept(HeapMessage &acceptMessage) | Activ::Component | [protected, virtual]
OnBreak(HeapMessage &breakMessage) | Activ::Component | [protected, virtual]
OnConnect(HeapMessage &connectMessage) | Activ::Component | [protected, virtual]
OnConnectFailed(HeapMessage &connectFailMessage) | Activ::Component | [protected, virtual]
OnData(HeapMessage &heapMessage) | Activ::Component | [protected, virtual]
OnDisconnect(HeapMessage &disconnectMessage) | Activ::Component | [protected, virtual]
OnMessage(HeapMessage &message) | Activ::Component | [protected, virtual]
OnResponse(HeapMessage &response) | Activ::Port | [protected, virtual]
OnTimer(const Address &timerAddress, const BaseTime &time) | Activ::Component | [protected, virtual]
Port(ManagedEndPoint &managedEndPoint, const std::string &name, IHeap *const pHeap) | Activ::Port |
Port(ManagedEndPoint &managedEndPoint, const std::string &name, const PortId portId, IHeap *const pHeap) | Activ::Port |
PostEmptyResponse(const StatusCode responseStatus, HeapMessage &response) const | Activ::Port |
PostEmptyResponse(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, const StatusCode responseStatus, HeapMessage &response) const | Activ::Port |
PostMessage(const Address &destinationAddress, const MessageType messageType, const MessageBuilder &messageBuilder) const | Activ::Port |
PostMessage(const Address &destinationAddress, const MessageType messageType, const void *pMessage=0, const size_t messageLength=0) const | Activ::Port |
PostMessage(const Address &destinationAddress, const MessageType messageType, HeapMessage &message) const | Activ::Port |
PostRequest(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, const MessageBuilder &messageBuilder) const | Activ::Port |
PostRequest(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, const void *pRequest=0, const size_t requestLength=0) const | Activ::Port |
PostRequest(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, HeapMessage &request) const | Activ::Port |
PostResponse(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, const StatusCode responseStatus, const MessageBuilder &messageBuilder) const | Activ::Port |
PostResponse(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, const StatusCode responseStatus, const void *pResponse=0, const size_t responseLength=0) const | Activ::Port |
PostResponse(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, const StatusCode responseStatus, HeapMessage &response) const | Activ::Port |
PostResponse(const StatusCode responseStatus, HeapMessage &request, const MessageBuilder &messageBuilder) const | Activ::Port |
PostResponse(const StatusCode responseStatus, HeapMessage &request, const void *pResponse, const size_t responseLength) const | Activ::Port |
PostResponse(const StatusCode responseStatus, HeapMessage &request, HeapMessage &response) const | Activ::Port |
PostResponse(const StatusCode responseStatus, HeapMessage &request) const | Activ::Port |
Run(UiUser &uiUser)=0 | Activ::UiComponent | [pure virtual]
SendRequest(const Address &destinationAddress, const MessageType requestType, const MessageBuilder &messageBuilder, HeapMessage &response, const TimeoutPeriod timeout=defaultTimeout) const | Activ::Port |
SendRequest(const Address &destinationAddress, const MessageType requestType, const void *pRequest, const size_t requestLength, HeapMessage &response, const TimeoutPeriod timeout=defaultTimeout) const | Activ::Port |
SendRequest(const Address &destinationAddress, const MessageType requestType, HeapMessage &request, const TimeoutPeriod timeout=defaultTimeout) const | Activ::Port |
SendRequest(const Address &destinationAddress, const MessageType requestType, SyncRequestId &syncRequestId, const MessageBuilder &messageBuilder) const | Activ::Port |
SendRequest(const Address &destinationAddress, const MessageType requestType, SyncRequestId &syncRequestId, const void *pRequest, const size_t requestLength) const | Activ::Port |
SendRequest(const Address &destinationAddress, const MessageType requestType, SyncRequestId &syncRequestId, HeapMessage &request) const | Activ::Port |
SetHeap(IHeap *const pHeap) | Activ::Port |
Type enum name | Activ::UiComponent |
TYPE_DEFAULT enum value | Activ::UiComponent |
TYPE_MAIN enum value | Activ::UiComponent |
TYPE_MIDDLEWARE enum value | Activ::UiComponent |
UiComponent(Application &application, ManagedEndPoint &managedEndPoint, const std::string &componentName, const Type type=TYPE_DEFAULT, const std::string &uiServiceName=Application::GetUiServiceName(), IHeap *const pHeap=0) | Activ::UiComponent |
~Component() | Activ::Component |
~Port() | Activ::Port | [virtual]
~UiComponent() | Activ::UiComponent |

Generated on Wed Oct 8 14:02:01 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::UiIo Member List

This is the complete list of members for Activ::UiIo, including all inherited members.

BlackBg (defined in Activ::UiIo) | Activ::UiIo | [static]
BlackFg (defined in Activ::UiIo) | Activ::UiIo | [static]
Blink (defined in Activ::UiIo) | Activ::UiIo | [static]
BlueBg (defined in Activ::UiIo) | Activ::UiIo | [static]
BlueFg (defined in Activ::UiIo) | Activ::UiIo | [static]
Bold (defined in Activ::UiIo) | Activ::UiIo | [static]
CompletionIteratorList typedef (defined in Activ::UiIo) | Activ::UiIo |
CompletionList typedef (defined in Activ::UiIo) | Activ::UiIo |
Concealed (defined in Activ::UiIo) | Activ::UiIo | [static]
CyanBg (defined in Activ::UiIo) | Activ::UiIo | [static]
CyanFg (defined in Activ::UiIo) | Activ::UiIo | [static]
EnableDisable(const std::string &prompt, bool &option, const bool positiveDefault=false, const TimeoutPeriod timeout=ACTIV_WAIT_INFINITE) const | Activ::UiIo |
GetAddress(const std::string &prompt, Address &address, const bool isInitializedWithDefault=false, const TimeoutPeriod timeout=ACTIV_WAIT_INFINITE) const | Activ::UiIo |
GetChar(const std::string &prompt, char &ch, const bool isInitializedWithDefault=false, const TimeoutPeriod timeout=ACTIV_WAIT_INFINITE) const | Activ::UiIo |
GetChar(const std::string &prompt, const std::string &validChars, char &ch, const bool isInitializedWithDefault=false, const TimeoutPeriod timeout=ACTIV_WAIT_INFINITE) const | Activ::UiIo |
GetConfirmation(const std::string &prompt, const bool positiveDefault=false, const TimeoutPeriod timeout=ACTIV_WAIT_INFINITE) const | Activ::UiIo |
GetFieldType(const std::string &prompt, T &value, const bool isInitializedWithDefault=false, const TimeoutPeriod timeout=ACTIV_WAIT_INFINITE) const | Activ::UiIo | [inline]
GetFileName(const std::string &prompt, std::string &fileName, const bool isInitializedWithDefault=false, const TimeoutPeriod timeout=ACTIV_WAIT_INFINITE) const | Activ::UiIo |
GetIpAddress(const std::string &prompt, IpAddress &ipAddress, const bool isInitializedWithDefault=false, const TimeoutPeriod timeout=ACTIV_WAIT_INFINITE) const | Activ::UiIo |
GetRandomConfirmation(const std::string &prompt, const TimeoutPeriod timeout=ACTIV_WAIT_INFINITE) const | Activ::UiIo |
GetSignedIntegral(const std::string &prompt, T &value, const bool isInitializedWithDefault=false, const TimeoutPeriod timeout=ACTIV_WAIT_INFINITE) const | Activ::UiIo | [inline]
GetSignedIntegral(const std::string &prompt, const int64_t lower, const int64_t upper, T &value, const bool isInitializedWithDefault=false, const TimeoutPeriod timeout=ACTIV_WAIT_INFINITE) const | Activ::UiIo | [inline]
GetString(const std::string &prompt, std::string &str, const bool isInitializedWithDefault=false, const TimeoutPeriod timeout=ACTIV_WAIT_INFINITE) const | Activ::UiIo |
GetString(const std::string &prompt, CompletionHelper &completionHelper, std::string &str, const bool isInitializedWithDefault=false, const TimeoutPeriod timeout=ACTIV_WAIT_INFINITE) const | Activ::UiIo |
GetString(const std::string &prompt, const byte_t lower, const byte_t upper, std::string &str, const bool isInitializedWithDefault=false, const TimeoutPeriod timeout=ACTIV_WAIT_INFINITE) const | Activ::UiIo |
GetUiUserAddress() const | Activ::UiIo |
GetUnsignedIntegral(const std::string &prompt, T &value, const bool isInitializedWithDefault=false, const TimeoutPeriod timeout=ACTIV_WAIT_INFINITE) const | Activ::UiIo | [inline]
GetUnsignedIntegral(const std::string &prompt, const uint64_t lower, const uint64_t upper, T &value, const bool isInitializedWithDefault=false, const TimeoutPeriod timeout=ACTIV_WAIT_INFINITE) const | Activ::UiIo | [inline]
GetWindowSize(ConsoleWindow::Coord &windowSize) const | Activ::UiIo |
GreenBg (defined in Activ::UiIo) | Activ::UiIo | [static]
GreenFg (defined in Activ::UiIo) | Activ::UiIo | [static]
MagentaBg (defined in Activ::UiIo) | Activ::UiIo | [static]
MagentaFg (defined in Activ::UiIo) | Activ::UiIo | [static]
Normal (defined in Activ::UiIo) | Activ::UiIo | [static]
PutString(const std::string &str) const | Activ::UiIo |
PutString(const boost::format &formatter) const | Activ::UiIo |
PutString(const char *const format,...) const | Activ::UiIo |
PutStringList(const std::vector< std::string > &stringList, const size_t numberOfLeadingSpaces) const | Activ::UiIo |
PutStringV(const char *const format, std::va_list args) const | Activ::UiIo |
RedBg (defined in Activ::UiIo) | Activ::UiIo | [static]
RedFg (defined in Activ::UiIo) | Activ::UiIo | [static]
Reverse (defined in Activ::UiIo) | Activ::UiIo | [static]
UiMainComponent class | Activ::UiIo | [friend]
UiMenu class | Activ::UiIo | [friend]
Underscore (defined in Activ::UiIo) | Activ::UiIo | [static]
WhiteBg (defined in Activ::UiIo) | Activ::UiIo | [static]
WhiteFg (defined in Activ::UiIo) | Activ::UiIo | [static]
YellowBg (defined in Activ::UiIo) | Activ::UiIo | [static]
YellowFg (defined in Activ::UiIo) | Activ::UiIo | [static]

Generated on Wed Oct 8 14:02:01 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::UiIo::Attribute Member List

This is the complete list of members for Activ::UiIo::Attribute, including all inherited members.

operator std::string() const | Activ::UiIo::Attribute |
operator|(const Attribute &attribute) const | Activ::UiIo::Attribute |
operator|(const Attribute &attribute) | Activ::UiIo::Attribute |
ToString() const | Activ::UiIo::Attribute |
UiIo (defined in Activ::UiIo::Attribute) | Activ::UiIo::Attribute | [friend]

Generated on Wed Oct 8 14:02:01 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::UiIo::Columnizer Member List

This is the complete list of members for Activ::UiIo::Columnizer, including all inherited members.

Columnizer(const UiIo &uiIo, const size_t numberOfLeadingSpaces, const size_t numberOfItems, const size_t longestItemWidth) | Activ::UiIo::Columnizer
m_columnSpacing | Activ::UiIo::Columnizer
m_numberOfColumns | Activ::UiIo::Columnizer
m_numberOfLines | Activ::UiIo::Columnizer

Generated on Wed Oct 8 14:02:01 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::UiIo::CompletionHelper Member List

This is the complete list of members for Activ::UiIo::CompletionHelper, including all inherited members.

AddCompletion(const std::string &completion) | Activ::UiIo::CompletionHelper |
CompletionHelper(const bool isCaseSensitive) | Activ::UiIo::CompletionHelper |
DynamicCompletionHelper (defined in Activ::UiIo::CompletionHelper) | Activ::UiIo::CompletionHelper | [friend]
StaticCompletionHelper (defined in Activ::UiIo::CompletionHelper) | Activ::UiIo::CompletionHelper | [friend]
UiIo (defined in Activ::UiIo::CompletionHelper) | Activ::UiIo::CompletionHelper | [friend]
~CompletionHelper() | Activ::UiIo::CompletionHelper | [virtual]

Generated on Wed Oct 8 14:02:01 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::UiIo::DynamicCompletionHelper Member List

This is the complete list of members for Activ::UiIo::DynamicCompletionHelper, including all inherited members.

AddCompletion(const std::string &completion) | Activ::UiIo::CompletionHelper |
CompletionHelper(const bool isCaseSensitive) | Activ::UiIo::CompletionHelper |
DynamicCompletionHelper(const bool isCaseSensitive) | Activ::UiIo::DynamicCompletionHelper |
OnPopulateCompletionList(const std::string &partialInput)=0 | Activ::UiIo::DynamicCompletionHelper | [protected, pure virtual]
~CompletionHelper() | Activ::UiIo::CompletionHelper | [virtual]

Generated on Wed Oct 8 14:02:01 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::UiIo::StaticCompletionHelper Member List

This is the complete list of members for Activ::UiIo::StaticCompletionHelper, including all inherited members.

AddCompletion(const std::string &completion) | Activ::UiIo::CompletionHelper |
CompletionHelper(const bool isCaseSensitive) | Activ::UiIo::CompletionHelper |
StaticCompletionHelper(const T &begin, const T &end, const bool isCaseSensitive) | Activ::UiIo::StaticCompletionHelper | [inline]
~CompletionHelper() | Activ::UiIo::CompletionHelper | [virtual]

Generated on Wed Oct 8 14:02:01 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::UiMainComponent Member List

This is the complete list of members for Activ::UiMainComponent, including all inherited members.

anonymousName | Activ::Port | [static]
Component(Application &application, ManagedEndPoint &managedEndPoint, const std::string &name=anonymousName, IHeap *const pHeap=0, const std::string &componentId=defaultComponentId) | Activ::Component |
defaultComponentId | Activ::Component | [static]
defaultTimeout | Activ::Port | [static]
Disable() | Activ::Port |
Enable() | Activ::Port |
FindPort(const std::string &endPointName, const std::string &portName, Address &portAddress, const TimeoutPeriod timeout=defaultTimeout) | Activ::Port |
ForwardMessage(const Address &destinationAddress, HeapMessage &message, const MessageType newType=INVALID_MESSAGE_TYPE) const | Activ::Port |
GetAddress() const | Activ::Port | [inline]
GetApplication() const | Activ::Component |
GetHeap() const | Activ::Port | [inline]
GetManagedEndPoint() const | Activ::Port |
GetName() const | Activ::Port |
GetUiServiceName() const | Activ::UiComponent |
ManagedEndPoint::Impl (defined in Activ::Port) | Activ::Port | [friend]
OnAccept(HeapMessage &acceptMessage) | Activ::Component | [protected, virtual]
OnBreak(HeapMessage &breakMessage) | Activ::Component | [protected, virtual]
OnConnect(HeapMessage &connectMessage) | Activ::Component | [protected, virtual]
OnConnectFailed(HeapMessage &connectFailMessage) | Activ::Component | [protected, virtual]
OnData(HeapMessage &heapMessage) | Activ::Component | [protected, virtual]
OnDisconnect(HeapMessage &disconnectMessage) | Activ::Component | [protected, virtual]
OnOption(const UiIo &uiIo, const std::string &optionString) | Activ::UiMainComponent |
OnResponse(HeapMessage &response) | Activ::Port | [protected, virtual]
OnTimer(const Address &timerAddress, const BaseTime &time) | Activ::Component | [protected, virtual]
Port(ManagedEndPoint &managedEndPoint, const std::string &name, IHeap *const pHeap) | Activ::Port |
Port(ManagedEndPoint &managedEndPoint, const std::string &name, const PortId portId, IHeap *const pHeap) | Activ::Port |
PostEmptyResponse(const StatusCode responseStatus, HeapMessage &response) const | Activ::Port |
PostEmptyResponse(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, const StatusCode responseStatus, HeapMessage &response) const | Activ::Port |
PostMessage(const Address &destinationAddress, const MessageType messageType, const MessageBuilder &messageBuilder) const | Activ::Port |
PostMessage(const Address &destinationAddress, const MessageType messageType, const void *pMessage=0, const size_t messageLength=0) const | Activ::Port |
PostMessage(const Address &destinationAddress, const MessageType messageType, HeapMessage &message) const | Activ::Port |
PostRequest(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, const MessageBuilder &messageBuilder) const | Activ::Port |
PostRequest(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, const void *pRequest=0, const size_t requestLength=0) const | Activ::Port |
PostRequest(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, HeapMessage &request) const | Activ::Port |
PostResponse(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, const StatusCode responseStatus, const MessageBuilder &messageBuilder) const | Activ::Port |
PostResponse(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, const StatusCode responseStatus, const void *pResponse=0, const size_t responseLength=0) const | Activ::Port |
PostResponse(const Address &destinationAddress, const MessageType requestType, const RequestId &requestId, const StatusCode responseStatus, HeapMessage &response) const | Activ::Port |
PostResponse(const StatusCode responseStatus, HeapMessage &request, const MessageBuilder &messageBuilder) const | Activ::Port |
PostResponse(const StatusCode responseStatus, HeapMessage &request, const void *pResponse, const size_t responseLength) const | Activ::Port |
PostResponse(const StatusCode responseStatus, HeapMessage &request, HeapMessage &response) const | Activ::Port |
PostResponse(const StatusCode responseStatus, HeapMessage &request) const | Activ::Port |
Run(UiUser &uiUser)=0 | Activ::UiComponent | [pure virtual]
SendRequest(const Address &destinationAddress, const MessageType requestType, const MessageBuilder &messageBuilder, HeapMessage &response, const TimeoutPeriod timeout=defaultTimeout) const | Activ::Port |
SendRequest(const Address &destinationAddress, const MessageType requestType, const void *pRequest, const size_t requestLength, HeapMessage &response, const TimeoutPeriod timeout=defaultTimeout) const | Activ::Port |
SendRequest(const Address &destinationAddress, const MessageType requestType, HeapMessage &request, const TimeoutPeriod timeout=defaultTimeout) const | Activ::Port |
SendRequest(const Address &destinationAddress, const MessageType requestType, SyncRequestId &syncRequestId, const MessageBuilder &messageBuilder) const | Activ::Port |
SendRequest(const Address &destinationAddress, const MessageType requestType, SyncRequestId &syncRequestId, const void *pRequest, const size_t requestLength) const | Activ::Port |
SendRequest(const Address &destinationAddress, const MessageType requestType, SyncRequestId &syncRequestId, HeapMessage &request) const | Activ::Port |
SetHeap(IHeap *const pHeap) | Activ::Port |
Type enum name | Activ::UiComponent |
TYPE_DEFAULT enum value | Activ::UiComponent |
TYPE_MAIN enum value | Activ::UiComponent |
TYPE_MIDDLEWARE enum value | Activ::UiComponent |
UiComponent(Application &application, ManagedEndPoint &managedEndPoint, const std::string &componentName, const Type type=TYPE_DEFAULT, const std::string &uiServiceName=Application::GetUiServiceName(), IHeap *const pHeap=0) | Activ::UiComponent |
UiDisplayAvailableUiComponentsByType(const UiIo &uiIo, const Type type) const | Activ::UiMainComponent |
UiMainComponent(Application &application, ManagedEndPoint &managedEndPoint, const std::string &uiComponentName, const std::string &uiServiceName) | Activ::UiMainComponent |
~Component() | Activ::Component |
~Port() | Activ::Port | [virtual]
~UiComponent() | Activ::UiComponent |
~UiMainComponent() | Activ::UiMainComponent |

Generated on Wed Oct 8 14:02:01 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::UiMainComponent::Menu Member List

This is the complete list of members for Activ::UiMainComponent::Menu, including all inherited members.

AddOption(const std::string &name, T &object, void(T::*pFunction)(const UiIo &), const OptionAttributes &optionAttributes=OptionAttributes()) | Activ::UiMenu | [inline]
AddOption(const std::string &name, GlobalOptionFunction pFunction, const OptionAttributes &optionAttributes=OptionAttributes()) | Activ::UiMenu |
DisplayInputPrompt(const UiIo &uiIo, const std::string &prompt, const std::string &value, const bool initializedWithDefault) const | Activ::UiMenu | [protected, virtual]
DisplayOption(const UiIo &uiIo, const size_t optionIndex, const std::string &name, const OptionAttributes &optionAttributes) const | Activ::UiMenu | [protected, virtual]
DisplayOptionPrompt(const UiIo &uiIo) const | Activ::UiMenu | [protected, virtual]
DisplayTitle(const UiIo &uiIo) const | Activ::UiMenu | [protected, virtual]
GetName() const | Activ::UiMenu |
GlobalOptionFunction typedef | Activ::UiMenu |
Menu(UiMainComponent &uiComponent, const std::string &name, UiUser &uiUser) | Activ::UiMainComponent::Menu |
ProcessOption(const UiIo &uiIo, const std::string &optionString) | Activ::UiMenu | [protected]
Run() | Activ::UiMenu |
UiMenu(const std::string &name, UiUser &uiUser, const bool showQuitOption=true) | Activ::UiMenu |
UiMenu(const std::string &name, const UiIo &uiIo) | Activ::UiMenu |
~UiMenu() | Activ::UiMenu | [virtual]

Generated on Wed Oct 8 14:02:01 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::UiMenu Member List

This is the complete list of members for Activ::UiMenu, including all inherited members.

AddOption(const std::string &name, T &object, void(T::*pFunction)(const UiIo &), const OptionAttributes &optionAttributes=OptionAttributes()) | Activ::UiMenu | [inline]
AddOption(const std::string &name, GlobalOptionFunction pFunction, const OptionAttributes &optionAttributes=OptionAttributes()) | Activ::UiMenu |
DisplayFooter(const UiIo &uiIo) const | Activ::UiMenu | [protected, virtual]
DisplayInputPrompt(const UiIo &uiIo, const std::string &prompt, const std::string &value, const bool initializedWithDefault) const | Activ::UiMenu | [protected, virtual]
DisplayOption(const UiIo &uiIo, const size_t optionIndex, const std::string &name, const OptionAttributes &optionAttributes) const | Activ::UiMenu | [protected, virtual]
DisplayOptionPrompt(const UiIo &uiIo) const | Activ::UiMenu | [protected, virtual]
DisplayTitle(const UiIo &uiIo) const | Activ::UiMenu | [protected, virtual]
GetName() const | Activ::UiMenu |
GlobalOptionFunction typedef | Activ::UiMenu |
ProcessOption(const UiIo &uiIo, const std::string &optionString) | Activ::UiMenu | [protected]
Run() | Activ::UiMenu |
UiIo (defined in Activ::UiMenu) | Activ::UiMenu | [friend]
UiMenu(const std::string &name, UiUser &uiUser, const bool showQuitOption=true) | Activ::UiMenu |
UiMenu(const std::string &name, const UiIo &uiIo) | Activ::UiMenu |
~UiMenu() | Activ::UiMenu | [virtual]

Generated on Wed Oct 8 14:02:01 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::UiMenu::OptionAttributes Member List

This is the complete list of members for Activ::UiMenu::OptionAttributes, including all inherited members.

m_sectionName (defined in Activ::UiMenu::OptionAttributes) | Activ::UiMenu::OptionAttributes
m_uiPermissions | Activ::UiMenu::OptionAttributes
OptionAttributes() | Activ::UiMenu::OptionAttributes
OptionAttributes(const UiPermissions &uiPermissions) | Activ::UiMenu::OptionAttributes
OptionAttributes(const std::string &sectionName) | Activ::UiMenu::OptionAttributes
OptionAttributes(const UiPermissions &uiPermissions, const std::string &sectionName) | Activ::UiMenu::OptionAttributes

Generated on Wed Oct 8 14:02:01 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::UiPermissions Member List

This is the complete list of members for Activ::UiPermissions, including all inherited members.

Bitmap typedef | Activ::UiPermissions |
Deserialize(MessageValidator &messageValidator) | Activ::UiPermissions |
FromString(const std::string &string) | Activ::UiPermissions |
FULL (defined in Activ::UiPermissions) | Activ::UiPermissions | [static]
HasPermissions(const UiPermissions &uiPermissions) const | Activ::UiPermissions |
MODIFY (defined in Activ::UiPermissions) | Activ::UiPermissions | [static]
READ (defined in Activ::UiPermissions) | Activ::UiPermissions | [static]
Serialize(MessageBuilder &messageBuilder) const | Activ::UiPermissions |
SHUTDOWN (defined in Activ::UiPermissions) | Activ::UiPermissions | [static]
ToString() const | Activ::UiPermissions |
UiPermissions() | Activ::UiPermissions |

Generated on Wed Oct 8 14:02:02 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Url Member List

This is the complete list of members for Activ::Url, including all inherited members.

Build() const | Activ::Url
m_location | Activ::Url
m_parameterList | Activ::Url
m_path | Activ::Url
m_protocol | Activ::Url
Parameter typedef | Activ::Url
ParameterList typedef | Activ::Url
Parse(const std::string &url) | Activ::Url

Generated on Wed Oct 8 14:02:02 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::UtcTime Member List

This is the complete list of members for Activ::UtcTime, including all inherited members.

DateToString() const | Activ::BaseTime |
DayOfWeek typedef | Activ::BaseTime |
DayOfWeekToString(const DayOfWeek dayOfWeek, bool isShort=false) | Activ::BaseTime | [static]
Deserialize(MessageValidator &messageValidator) | Activ::BaseTime |
FRIDAY (defined in Activ::BaseTime) | Activ::BaseTime | [static]
GetCurrent() | Activ::UtcTime | [static]
GetDay() const | Activ::BaseTime | [inline]
GetDayOfWeek() const | Activ::BaseTime | [inline]
GetHour() const | Activ::BaseTime | [inline]
GetJulianTime() const | Activ::BaseTime | [inline]
GetMillisecond() const | Activ::BaseTime | [inline]
GetMinute() const | Activ::BaseTime | [inline]
GetMonth() const | Activ::BaseTime | [inline]
GetSecond() const | Activ::BaseTime | [inline]
GetYear() const | Activ::BaseTime | [inline]
IsUtc() const | Activ::BaseTime | [inline]
millisecondsPerDay (defined in Activ::BaseTime) | Activ::BaseTime | [static]
millisecondsPerHour (defined in Activ::BaseTime) | Activ::BaseTime | [static]
millisecondsPerMinute (defined in Activ::BaseTime) | Activ::BaseTime | [static]
millisecondsPerSecond (defined in Activ::BaseTime) | Activ::BaseTime | [static]
MONDAY (defined in Activ::BaseTime) | Activ::BaseTime | [static]
MonthToString(const uint8_t month, bool isShort=false) | Activ::BaseTime | [static]
operator!=(const BaseTime &rhs) const | Activ::BaseTime |
operator+=(const int64_t numberOfMilliseconds) | Activ::BaseTime |
operator+=(const Duration &duration) | Activ::BaseTime |
operator-=(const int64_t numberOfMilliseconds) | Activ::BaseTime |
operator-=(const Duration &duration) | Activ::BaseTime |
operator<(const BaseTime &rhs) const | Activ::BaseTime |
operator<=(const BaseTime &rhs) const | Activ::BaseTime |
operator=(const BaseTime &rhs) | Activ::BaseTime |
operator==(const BaseTime &rhs) const | Activ::BaseTime |
operator>(const BaseTime &rhs) const | Activ::BaseTime |
operator>=(const BaseTime &rhs) const | Activ::BaseTime |
SATURDAY (defined in Activ::BaseTime) | Activ::BaseTime | [static]
secondsPerDay (defined in Activ::BaseTime) | Activ::BaseTime | [static]
secondsPerHour (defined in Activ::BaseTime) | Activ::BaseTime | [static]
secondsPerMinute (defined in Activ::BaseTime) | Activ::BaseTime | [static]
Serialize(MessageBuilder &messageBuilder) const | Activ::BaseTime |
SUNDAY (defined in Activ::BaseTime) | Activ::BaseTime | [static]
THURSDAY (defined in Activ::BaseTime) | Activ::BaseTime | [static]
TimeToString(const bool shouldFormatMilliseconds=false) const | Activ::BaseTime |
ToString(const bool shouldFormatMilliseconds=false) const | Activ::BaseTime |
TUESDAY (defined in Activ::BaseTime) | Activ::BaseTime | [static]
UtcTime() | Activ::UtcTime |
UtcTime(const BaseTime &baseTime) | Activ::UtcTime |
WEDSDAY (defined in Activ::BaseTime) | Activ::BaseTime | [static]
~BaseTime() | Activ::BaseTime | [virtual]

Generated on Wed Oct 8 14:02:02 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::Uuid Member List

This is the complete list of members for Activ::Uuid, including all inherited members.

Deserialize(MessageValidator &messageValidator) | Activ::Uuid |
emptyUuid | Activ::Uuid | [static]
GetBinary(byte_t *pBuffer, const size_t bufferSize) const | Activ::Uuid |
operator!=(const Uuid &rhs) const | Activ::Uuid |
operator<(const Uuid &rhs) const | Activ::Uuid |
operator<=(const Uuid &rhs) const | Activ::Uuid |
operator==(const Uuid &rhs) const | Activ::Uuid |
operator>(const Uuid &rhs) const | Activ::Uuid |
operator>=(const Uuid &rhs) const | Activ::Uuid |
Serialize(MessageBuilder &messageBuilder) const | Activ::Uuid |
Set(const byte_t *pBuffer, const size_t bufferSize) | Activ::Uuid |
Set(const std::string &uuidString) | Activ::Uuid |
ToString() const | Activ::Uuid |
Uuid() | Activ::Uuid |
Uuid(const byte_t *pBuffer, const size_t bufferSize) | Activ::Uuid |
Uuid(std::string &uuidString) | Activ::Uuid |
UUID_SIZE (defined in Activ::Uuid) | Activ::Uuid | [static]

Generated on Wed Oct 8 14:02:02 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::WsaBufHelper Member List

This is the complete list of members for Activ::WsaBufHelper, including all inherited members.

Append(void *pData, const size_t dataLength) | Activ::WsaBufHelper | [inline]
GetFirstBuffer() const | Activ::WsaBufHelper | [inline]
GetNumberOfBuffersInUse() const | Activ::WsaBufHelper | [inline]
GetTotalBytes() const | Activ::WsaBufHelper | [inline]
Reset() | Activ::WsaBufHelper | [inline]
WsaBufHelper(const size_t initialSize=10) | Activ::WsaBufHelper | [inline]
~WsaBufHelper() | Activ::WsaBufHelper | [inline]

Generated on Wed Oct 8 14:02:02 2008 for ACTIV C++ SDK by doxygen 1.5.4


ACTIV C++ SDK Class Index

A | B | C | D | E | F | G | H | I | K | L | M | N | O | P | R | S | T | U | V | W

A
PatternMatchListRequestParameters (Activ::ContentPlatform::ContentGatewayApi)
Address (Activ) | PatternMatchRequestParameters (Activ::ContentPlatform::ContentGatewayApi)
Address::Proxy (Activ) | Period (Activ::ContentPlatform::ContentGatewayApi)
AgentApplication (Activ) | PermissionIdHelper (Activ::ContentPlatform::Feed)
AgentApplication::Settings (Activ) | PermissionInfo (Activ::ContentPlatform::Feed)
Application (Activ) | PermissionInfo (Activ::ContentPlatform::ContributionGatewayApi)
Application::Settings (Activ) | PermissionInfo (Activ::ContentPlatform::ContentGatewayApi)
AtomicInteger (Activ) | PermissionInfo::PermissionIdInfo (Activ::ContentPlatform::Feed)
AtomicPointer (Activ) | PermissionLevelData (Activ::ContentPlatform::Feed)
B
Port (Activ)
BaseException (Activ) | Port::Enabler (Activ)
BaseTime (Activ) | PostMessageHelper (Activ)
BaseTime::Duration (Activ) | PrivateEventFactory (Activ)
Binary (Activ) | PrivateMutexFactory (Activ)
BinaryArray (Activ) | PrivateSemaphoreFactory (Activ)
BinaryString (Activ) | Process (Activ)
BitField (Activ) | PublishField (Activ::ContentPlatform::ContributionGatewayApi)
Blob (Activ) | PublishRecordBaseParameters (Activ::ContentPlatform::ContributionGatewayApi)
BooleanSwitchDescription (Activ::CommandLineParserDetail) | PublishRecordParameters (Activ::ContentPlatform::ContributionGatewayApi)
C
PublishRecordResponseParameters (Activ::ContentPlatform::ContributionGatewayApi)
CaseInsensitiveLessThanStringComparisonObject (Activ) | PublishRecordResponseParameters::FieldError (Activ::ContentPlatform::ContributionGatewayApi)
ChildService (Activ) | PublishRequestHelper (Activ::ContentPlatform::ContributionGatewayApi)
CombinedQuoteMessageHeaderDefinitions (Activ::ContentPlatform::Feed) | PublishSymbolRecordParameters (Activ::ContentPlatform::ContributionGatewayApi)
CommandLineParser (Activ) | PublishSymbolRecordParameters::Field (Activ::ContentPlatform::ContributionGatewayApi)
CommandLineParserImpl (Activ::CommandLineParserDetail) | PubSubServiceApi (Activ)
Component (Activ)
R
CompressedCombinedQuoteMessage (Activ::ContentPlatform::Feed) | Rational (Activ)
CompressedCombinedQuoteMessageDefinitions (Activ::ContentPlatform::Feed) | Rational::DenominatorType (Activ)
CompressedCombinedQuoteMessageHeaderDefinitions (Activ::ContentPlatform::Feed) | RealtimeRequestHelper (Activ::ContentPlatform::ContentGatewayApi)
CompressedCombinedQuoteMessageHeaderValidator (Activ::ContentPlatform::Feed) | RealtimeRequestParameters (Activ::ContentPlatform::ContentGatewayApi)
CompressedMessage (Activ::ContentPlatform::Feed) | RealtimeResponseParameters (Activ::ContentPlatform::ContentGatewayApi)
CompressedMessageDefinitions (Activ::ContentPlatform::Feed) | Record (Activ::Database)
CompressedMessageDefinitions::FieldHeaderBuilder (Activ::ContentPlatform::Feed) | RecordFieldListBuilder (Activ::ContentPlatform::Feed)
CompressedMessageDefinitions::FieldHeaderValidator (Activ::ContentPlatform::Feed) | RecordFieldListValidator (Activ::ContentPlatform::Feed)
CompressedMessageDefinitions::FieldSpecification (Activ::ContentPlatform::Feed) | RecordFieldListValidator::ConstIterator (Activ::ContentPlatform::Feed)
CompressedMessageHeaderDefinitions (Activ::ContentPlatform::Feed) | RecordKeyFieldListBuilder (Activ::ContentPlatform::Feed)
CompressedMessageHeaderValidator (Activ::ContentPlatform::Feed) | RecordKeyFieldListValidator (Activ::ContentPlatform::Feed)
CompressedSymbol (Activ::ContentPlatform::Feed) | RecordKeyFieldListValidator::ConstIterator (Activ::ContentPlatform::Feed)
CompressedUsEquityOptionSymbol (Activ::ContentPlatform::Feed) | RecordMessageBuilder (Activ::ContentPlatform::Feed)
ConsoleWindow (Activ) | RecordMessageHeaderDefinitions (Activ::ContentPlatform::Feed)
ConsoleWindow::Coord (Activ) | RecordMessageHeaderValidator (Activ::ContentPlatform::Feed)
ContentGatewayClient (Activ::ContentPlatform::ContentGatewayApi) | RecordMessageValidator (Activ::ContentPlatform::Feed)
ContentGatewayClient::ApiInfo (Activ::ContentPlatform::ContentGatewayApi) | RecordUpdate (Activ::ContentPlatform::ContentServerApi)
ContentGatewayClient::ConnectParameters (Activ::ContentPlatform::ContentGatewayApi) | RecordUpdate (Activ::ContentPlatform::ContentGatewayApi)
ContentGatewayClient::Settings (Activ::ContentPlatform::ContentGatewayApi) | RecordUpdateHelper (Activ::ContentPlatform::ContentServerApi)
ContentGatewayInfo (Activ::ContentPlatform::ContentGatewayApi) | RecordUpdateHelper (Activ::ContentPlatform::ContentGatewayApi)
ContentServerClient (Activ::ContentPlatform::ContentServerApi) | ReferenceCounter (Activ)
ContentServerClient::ApiInfo (Activ::ContentPlatform::ContentServerApi) | RegistryHelper (Activ)
ContentServerClient::MessageStats (Activ::ContentPlatform::ContentServerApi) | RelationshipIdHelper (Activ::ContentPlatform::Feed)
ContentServerClient::Settings (Activ::ContentPlatform::ContentServerApi) | RelationshipInfo (Activ::ContentPlatform::ContentGatewayApi)
ContentServerClient::UpdateFilter (Activ::ContentPlatform::ContentServerApi) | RemoteTableFactory (Activ::Database)
ContentServerClient::UpdateFilterMap (Activ::ContentPlatform::ContentServerApi) | RequestBlock (Activ::ContentPlatform::ContentGatewayApi)
ContributionGatewayClient (Activ::ContentPlatform::ContributionGatewayApi) | RequestId (Activ)
ContributionGatewayClient::ApiInfo (Activ::ContentPlatform::ContributionGatewayApi) | ResponseBlock (Activ::ContentPlatform::ContentGatewayApi)
ContributionGatewayClient::ConnectParameters (Activ::ContentPlatform::ContributionGatewayApi) | RouterServiceApi (Activ)
ContributionGatewayClient::Settings (Activ::ContentPlatform::ContributionGatewayApi) | RouterServiceApi::Tcp (Activ)
ContributionGatewayInfo (Activ::ContentPlatform::ContributionGatewayApi) | RouterServiceApi::Tcp::SocketStats (Activ)
ContributionGatewayResponseParameters (Activ::ContentPlatform::ContributionGatewayApi) | RouterServiceApi::Udp (Activ)
ContributionServerClient (Activ::ContentPlatform::ContributionServerApi) | Rule (Activ::ContentPlatform::Feed)
ContributionServerClient::ApiInfo (Activ::ContentPlatform::ContributionServerApi) | Rule::CloseFields (Activ::ContentPlatform::Feed)
ContributionServerClient::RecordMessageBuilder (Activ::ContentPlatform::ContributionServerApi) | Rule::CopyToFields (Activ::ContentPlatform::Feed)
ContributionServerClient::Settings (Activ::ContentPlatform::ContributionServerApi) | Rule::HighFields (Activ::ContentPlatform::Feed)
ContributionServerClient::SymbolRecordMessageBuilder (Activ::ContentPlatform::ContributionServerApi) | Rule::LowFields (Activ::ContentPlatform::Feed)
CopyOnReset (Activ::ContentPlatform::Feed) | Rule::OpenFields (Activ::ContentPlatform::Feed)
CrcBlob (Activ) | Rule::PriceFields (Activ::ContentPlatform::Feed)
CrtException (Activ) | Rule::VolumeFields (Activ::ContentPlatform::Feed)
CtrlHandler (Activ)
S
CurlFtpHelper (Activ) | ScatterBufferHelper (Activ)
CurlFtpHelper::CurlInitializeHelper (Activ) | ScatterBufferHelper::ConstIterator (Activ)
D
ScatterBufferHelper::ScatterBuffer (Activ)
Database (Activ::Database) | ScopedAddress (Activ)
Database::ConstIterator (Activ::Database) | ScopedAddress::Proxy (Activ)
Database::Iterator (Activ::Database) | ScopedFd (Activ)
DatabaseException (Activ::Database) | ScopedFile (Activ)
DatabaseSpecification (Activ::Database) | ScopedHandle (Activ)
DatabaseSpecification::DatabaseTableSpecification (Activ::Database) | ScopedHandle::IsValidHandle (Activ)
DataPointAddress (Activ::ContentPlatform::ContentGatewayApi) | ScopedHelper (Activ)
Date (Activ) | ScopedHelper::True (Activ)
Date::Days (Activ) | ScopedMemory (Activ)
DateTime (Activ) | ScopedMutexLocker (Activ)
DefaultDescription (Activ::CommandLineParserDetail) | ScopedMutexTryLocker (Activ)
DeferredScopedMutexLocker (Activ) | ScopedPooledObject (Activ)
DeleteAssociativeObject (Activ) | ScopedSocket (Activ)
DeleteObject (Activ) | ScopedSubscription (Activ)
DeleteObjectArray (Activ) | SelectFirst (Activ)
Des3Helper::Key (Activ) | SelectFirstFromSecond (Activ)
Des3Helper::KeyBundle (Activ) | SelectSecond (Activ)
Description (Activ::CommandLineParserDetail) | SerializableBuffer (Activ)
DescriptionAppender (Activ::CommandLineParserDetail) | SerializableContainerHelper (Activ)
DesHelper::Key (Activ) | SerializableContainerHelper< hash_map< KEY_TYPE, MAPPED_TYPE, HASH_FN >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER > (Activ)
DirectoryRemover (Activ) | SerializableContainerHelper< std::list< OBJECT_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER > (Activ)
DirectoryWalker (Activ) | SerializableContainerHelper< std::map< KEY_TYPE, MAPPED_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER > (Activ)
DirectoryWatchApi (Activ) | SerializableContainerHelper< std::set< OBJECT_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER > (Activ)
DirectoryWatchApi::Event (Activ) | SerializableContainerHelper< std::vector< OBJECT_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER > (Activ)
DllFunctionWrapper (Activ) | SerializableObjectContainerHelper (Activ)
DynamicLibraryLoader (Activ) | SerializableObjectContainerHelper< hash_map< KEY_TYPE, MAPPED_TYPE, HASH_FN >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH > (Activ)
E
SerializableObjectContainerHelper< std::map< KEY_TYPE, MAPPED_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH > (Activ)
EndPointSubject (Activ) | SerializableObjectHelper (Activ)
EntityTypeHelper (Activ::ContentPlatform::Feed) | SerializableRawPointerContainerHelper (Activ)
EqualToPairComparisonObject (Activ) | SerializableRawPointerContainerHelper< hash_map< KEY_TYPE, MAPPED_TYPE, HASH_FN >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH > (Activ)
EventTypeHelper (Activ::ContentPlatform::Feed) | SerializableRawPointerContainerHelper< std::map< KEY_TYPE, MAPPED_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH > (Activ)
Exception (Activ) | SerializableRawPointerHelper (Activ)
F
SerializableSmartPointerContainerHelper (Activ)
Fiber (Activ) | SerializableSmartPointerContainerHelper< hash_map< KEY_TYPE, MAPPED_TYPE, HASH_FN >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH > (Activ)
Field (Activ::ContentPlatform::Feed) | SerializableSmartPointerContainerHelper< std::map< KEY_TYPE, MAPPED_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH > (Activ)
Field::Specification (Activ::ContentPlatform::Feed) | SerializableSmartPointerHelper (Activ)
FieldData (Activ::ContentPlatform::ContentGatewayApi) | Service (Activ)
FieldHeaderDefinitions (Activ::ContentPlatform::Feed) | ServiceAccessPoint (Activ)
FieldList (Activ::Database) | ServiceApi (Activ)
FieldList::ConstIterator (Activ::Database) | ServiceHandle (Activ)
FieldListObject (Activ::Database) | ServiceId (Activ)
FieldListValidator (Activ::ContentPlatform::FeedApi) | ServiceInstance (Activ)
FieldListValidator (Activ::ContentPlatform::ContentServerApi) | ServiceSubject (Activ)
FieldListValidator (Activ::ContentPlatform::ContentGatewayApi) | SharedCompletionPortEventFactory (Activ)
FieldListValidator::ConstIterator (Activ::ContentPlatform::FeedApi) | SharedEventFactory (Activ)
FieldListValidator::Field (Activ::ContentPlatform::FeedApi) | SharedMutexFactory (Activ)
FieldSet (Activ::ContentPlatform::ContentGatewayApi) | SharedObject (Activ)
FieldSpecification (Activ::Database) | SharedSemaphoreFactory (Activ)
FieldTypeFactory (Activ) | Shell (Activ)
FieldTypeToClass (Activ) | ShutdownSubject (Activ)
FieldTypeToClass< FIELD_TYPE_BINARY_ARRAY > (Activ) | Singleton (Activ)
FieldTypeToClass< FIELD_TYPE_BINARY_STRING > (Activ) | SInt (Activ)
FieldTypeToClass< FIELD_TYPE_BLOB > (Activ) | SmtpHelper (Activ)
FieldTypeToClass< FIELD_TYPE_CRC_BLOB > (Activ) | SmtpHelper::Email (Activ)
FieldTypeToClass< FIELD_TYPE_DATE > (Activ) | SocketWrapper (Activ)
FieldTypeToClass< FIELD_TYPE_DATE_TIME > (Activ) | StaticAlignValueToProcessorWordBoundary (Activ)
FieldTypeToClass< FIELD_TYPE_RATIONAL > (Activ) | StatusCodeException (Activ)
FieldTypeToClass< FIELD_TYPE_SINT > (Activ) | StatusCodeHelper (Activ)
FieldTypeToClass< FIELD_TYPE_TEXT_ARRAY > (Activ) | StringHashCompare (Activ)
FieldTypeToClass< FIELD_TYPE_TEXT_STRING > (Activ) | Subject (Activ)
FieldTypeToClass< FIELD_TYPE_TIME > (Activ) | SubscribeFeedParameters (Activ::ContentPlatform::ContentGatewayApi)
FieldTypeToClass< FIELD_TYPE_TRATIONAL > (Activ) | SubscribeParameters (Activ::ContentPlatform::ContentGatewayApi)
FieldTypeToClass< FIELD_TYPE_UINT > (Activ) | SubscribeTableParameters (Activ::ContentPlatform::ContentGatewayApi)
File (Activ) | SubscriptionInfo (Activ::ContentPlatform::ContentGatewayApi)
FileInfo (Activ) | Symbol (Activ::ContentPlatform::Feed)
FileMappedMemoryFactory (Activ) | SymbolDirectoryRequestHelper (Activ::ContentPlatform::ContentGatewayApi)
FirstBitField (Activ) | SymbolDirectoryRequestParameters (Activ::ContentPlatform::ContentGatewayApi)
FtpHelper (Activ) | SymbolDirectoryResponseParameters (Activ::ContentPlatform::ContentGatewayApi)
G
SymbolId (Activ::ContentPlatform::ContentGatewayApi)
Greater (Activ) | SymbolIdCountRequestParameters (Activ::ContentPlatform::ContentGatewayApi)
H
SymbolIdListMatchRequestParameters (Activ::ContentPlatform::ContentGatewayApi)
HandleManager (Activ) | SymbolIdListRequestParameters (Activ::ContentPlatform::ContentGatewayApi)
HeapMessage (Activ) | SymbolIdMatchRequestParameters (Activ::ContentPlatform::ContentGatewayApi)
HeapMessage::Iterator (Activ) | SymbolIdRequestParameters (Activ::ContentPlatform::ContentGatewayApi)
HeapMessage::ReadHelper (Activ) | SymbolPatternHelper (Activ::ContentPlatform::FeedApi)
HeapMessage::Stats (Activ) | SymbolRecordField (Activ::ContentPlatform::Feed)
HeapMessage::WriteHelper (Activ) | SymbolRecordField::PartialUpdate (Activ::ContentPlatform::Feed)
HeapMessageBuilder (Activ) | SymbolRecordFieldHeaderDefinitions (Activ::ContentPlatform::Feed)
HeapMessageDeserializer (Activ) | SymbolRecordFieldListBuilder (Activ::ContentPlatform::Feed)
HeapPool (Activ) | SymbolRecordFieldListValidator (Activ::ContentPlatform::Feed)
HistoryBar (Activ::ContentPlatform::ContentGatewayApi) | SymbolRecordFieldListValidator::ConstIterator (Activ::ContentPlatform::Feed)
I
SymbolRecordMessageBuilder (Activ::ContentPlatform::Feed)
IEndPoint (Activ) | SymbolRecordMessageHeaderDefinitions (Activ::ContentPlatform::Feed)
IEndPoint::Stats (Activ) | SymbolRecordMessageHeaderValidator (Activ::ContentPlatform::Feed)
IEvent (Activ) | SymbolRecordMessageValidator (Activ::ContentPlatform::Feed)
IFieldType (Activ) | SymbolRecordRuleDefinitions (Activ::ContentPlatform::Feed)
IFileMappedMemory (Activ) | SymbolRecordRuleDefinitions::ContentServerRuleSet (Activ::ContentPlatform::Feed)
IFtpHelper (Activ) | SymbolRecordRuleDefinitions::TranslatorRuleSet (Activ::ContentPlatform::Feed)
IHeap (Activ) | SymbolRecordUpdate (Activ::ContentPlatform::ContentServerApi)
IHeap::BucketInfo (Activ) | SymbolResponse (Activ::ContentPlatform::ContentGatewayApi)
IHeap::Stats (Activ) | SyncRequestId (Activ)
IHeap::Stats::BucketStats (Activ) | SystemException (Activ)
IHeap::Stats::RequestDistributionStats (Activ) | SystemFactory (Activ)
IIndex (Activ::Database) | SystemInfo (Activ)
IMappedMemory (Activ) | SystemMessageEndPointIdSet (Activ)
IMutex (Activ) | SystemMonitor (Activ)
Index::IndexFieldSpecification (Activ::ContentPlatform::Feed) | SystemMonitor::Stats (Activ)
Index::Specification (Activ::ContentPlatform::Feed) | SystemMonitor::Stats::DiskInfo (Activ)
IndexSpecification (Activ::Database) | SystemMonitor::Stats::ProcessInfo (Activ)
IndexSpecification::Field (Activ::Database) | SystemProxy (Activ)
IndexSpecification::Field (Activ::ContentPlatform::Feed)
T
INewsResponses (Activ::ContentPlatform::ContentGatewayApi) | TableInfo (Activ::ContentPlatform::ContentGatewayApi)
IniFileParser (Activ) | TableNumberRequestParameters (Activ::ContentPlatform::ContentGatewayApi)
IniFileParser::ConstKeyIterator (Activ) | TableSpecification (Activ::Database)
IniFileParser::ConstSectionIterator (Activ) | TableTemplate (Activ::ContentPlatform::Feed)
IniFileParser::ParseException (Activ) | TableTemplate::ConstCopyOnResetIterator (Activ::ContentPlatform::Feed)
IntervalTimer (Activ) | TableTemplate::ConstFieldIterator (Activ::ContentPlatform::Feed)
IntervalTimer::Scoped (Activ) | TableTemplate::ConstIndexIterator (Activ::ContentPlatform::Feed)
IntradayBar (Activ::ContentPlatform::ContentGatewayApi) | TableTemplate::ConstRuleIterator (Activ::ContentPlatform::Feed)
IoCompletionManager (Activ) | TableTemplate::ConstUndefineOnResetIterator (Activ::ContentPlatform::Feed)
IoCompletionManager::Overlapped (Activ) | TableTemplate::FieldSpecification (Activ::ContentPlatform::Feed)
IpAddress (Activ) | TableTemplate::Specification (Activ::ContentPlatform::Feed)
IpException (Activ) | TableTemplateAddition (Activ::ContentPlatform::Feed)
IpManager (Activ) | TableTemplateException (Activ::ContentPlatform::Feed)
IpManager::InterfaceInfo (Activ) | TableTemplateField (Activ::ContentPlatform::Feed)
IpManager::Settings (Activ) | TableTemplateFieldListValidator (Activ::ContentPlatform::Feed)
IProcess (Activ) | TableTemplateFieldListValidator::ConstIterator (Activ::ContentPlatform::Feed)
IProcess::Stats (Activ) | TableTemplateIndex (Activ::ContentPlatform::Feed)
IpSocket (Activ) | TableTemplateIndexListValidator (Activ::ContentPlatform::Feed)
IpSocket::RxOverlapped (Activ) | TableTemplateList (Activ::ContentPlatform::Feed)
IpSocket::Settings (Activ) | TableTemplateList::ConstIterator (Activ::ContentPlatform::Feed)
IpSocket::Stats (Activ) | TableTemplateList::Settings (Activ::ContentPlatform::Feed)
IpSocket::TxOverlapped (Activ) | TableTemplateList::TableTemplateSpecification (Activ::ContentPlatform::Feed)
IRealtimeResponses (Activ::ContentPlatform::ContentGatewayApi) | TableTemplateMessageHeaderDefinitions (Activ::ContentPlatform::Feed)
ISemaphore (Activ) | TableTemplateMessageValidator (Activ::ContentPlatform::Feed)
ISerializableMessage (Activ) | TcpListener (Activ)
ISymbolDirectoryResponses (Activ::ContentPlatform::ContentGatewayApi) | TcpSocket (Activ)
ISyncEndPoint (Activ) | TcpSocket::Settings (Activ)
ISyncEndPoint::Stats (Activ) | TcpSocket::Stats (Activ)
ISystem (Activ) | TextArray (Activ)
ISystem::IEndPointEnumerator (Activ) | TextString (Activ)
ISystem::IHeapEnumerator (Activ) | ThinApplication (Activ)
ISystem::IProcessEnumerator (Activ) | ThinApplication::Settings (Activ)
ISystem::Settings (Activ) | Thread (Activ)
ISystem::SystemInfo (Activ) | ThreadSpecificData (Activ)
ITable (Activ::Database) | ThreadSpecificDataBase (Activ)
ITimeSeriesResponses (Activ::ContentPlatform::ContentGatewayApi) | ThreadSpecificFastPoolAllocator (Activ)
K
ThreadSpecificPoolAllocator (Activ)
Key (Activ::Database) | Tick (Activ::ContentPlatform::ContentGatewayApi)
L
Time (Activ)
LengthToIntegralType (Activ) | Time::Hours (Activ)
Less (Activ) | Time::Milliseconds (Activ)
LessThanPairComparisonObject (Activ) | Time::Minutes (Activ)
LicenseServiceApi (Activ) | Time::Seconds (Activ)
LocalTime (Activ) | Timeband (Activ)
LoggerDefinitions (Activ) | Timeband::Settings (Activ)
LoggerServiceApi (Activ) | Timeout (Activ)
M
TimerServiceApi (Activ)
ManagedEndPoint (Activ) | TimeSeriesCookie (Activ::ContentPlatform::ContentGatewayApi)
ManagedEndPoint::RunHelper (Activ) | TimeSeriesRequestHelper (Activ::ContentPlatform::ContentGatewayApi)
ManagedEndPoint::Settings (Activ) | TimeSeriesRequestParameters (Activ::ContentPlatform::ContentGatewayApi)
ManagedTableFactory (Activ::Database) | TimeSeriesResponseParametersTemplate (Activ::ContentPlatform::ContentGatewayApi)
MandatoryParameterDescription (Activ::CommandLineParserDetail) | TRational (Activ)
MandatorySwitchDescription (Activ::CommandLineParserDetail) | TRational::SerializedTrendDefinitions (Activ)
MatchRequestParameters (Activ::ContentPlatform::ContentGatewayApi) | TypeToIntegralType (Activ)
MessageBuilder (Activ)
U
MessageBuilderVariableLengthRangeCheck (Activ) | UdpComponent (Activ)
MessageBuilderVariableLengthRangeCheck< false > (Activ) | UdpSocket (Activ)
MessageBuilderVariableLengthRangeCheck< true > (Activ) | UdpSocket::Settings (Activ)
MessageHandler (Activ) | UdpSocket::Stats (Activ)
MessageHandler::ScopedVersion (Activ) | UiComponent (Activ)
MessageHeaderDefinitions (Activ::ContentPlatform::Feed) | UiIo (Activ)
MessageRateThrottler (Activ) | UiIo::Attribute (Activ)
MessageValidator (Activ) | UiIo::Columnizer (Activ)
MetaDataRequestHelper (Activ::ContentPlatform::ContentGatewayApi) | UiIo::CompletionHelper (Activ)
N
UiIo::DynamicCompletionHelper (Activ)
NewsRequestHelper (Activ::ContentPlatform::ContentGatewayApi) | UiIo::StaticCompletionHelper (Activ)
NewsRequestParameters (Activ::ContentPlatform::ContentGatewayApi) | UiMainComponent (Activ)
NewsResponseParameters (Activ::ContentPlatform::ContentGatewayApi) | UiMainComponent::Menu (Activ)
NewsStory (Activ::ContentPlatform::ContentGatewayApi) | UiMenu (Activ)
NewsUpdate (Activ::ContentPlatform::ContentGatewayApi) | UiMenu::OptionAttributes (Activ)
NewsUpdateHelper (Activ::ContentPlatform::ContentGatewayApi) | UInt (Activ)
NextBitField (Activ) | UiPermissions (Activ)
NullObject (Activ) | UniversalFieldHelper (Activ::ContentPlatform::Feed)
O
UniversalFieldList (Activ::ContentPlatform::Feed)
ObjectPool (Activ) | UniversalFieldList::ConstIterator (Activ::ContentPlatform::Feed)
ObjectPool::Stats (Activ) | UnmanagedTableFactory (Activ::Database)
OpenServiceRequest (Activ) | Url (Activ)
OpenServiceResponse (Activ) | UtcTime (Activ)
OptionalParameterDescription (Activ::CommandLineParserDetail) | Uuid (Activ)
OptionalSwitchDescription (Activ::CommandLineParserDetail)
V
OptionBar (Activ::ContentPlatform::ContentGatewayApi) | ValueStore (Activ::CommandLineParserDetail)
OsException (Activ)
W
P
WsaBufHelper (Activ)
PagingFileMappedMemoryFactory (Activ)

A | B | C | D | E | F | G | H | I | K | L | M | N | O | P | R | S | T | U | V | W

Generated on Wed Oct 8 14:01:51 2008 for ACTIV C++ SDK by doxygen 1.5.4


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- j -

  • JoinMulticastGroup()
: Activ::RouterServiceApi::Udp
, Activ::UdpSocket
, Activ::UdpComponent
Generated on Wed Oct 8 14:01:54 2008 for ACTIV C++ SDK by doxygen 1.5.4


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- k -

  • Key()
: Activ::Database::Key
, Activ::DesHelper::Key
, Activ::Des3Helper::Key
, Activ::DesHelper::Key
, Activ::Database::Key
, Activ::Des3Helper::Key
  • KeyBundle() : Activ::Des3Helper::KeyBundle
  • KeyField : Activ::ContentPlatform::ContentServerApi::RecordUpdate
  • KeyFieldList : Activ::ContentPlatform::ContentServerApi::RecordUpdate
  • KeyFieldListTitleToString() : Activ::ContentPlatform::Feed::RecordKeyFieldListValidator
  • Kill() : Activ::Process
Generated on Wed Oct 8 14:01:54 2008 for ACTIV C++ SDK by doxygen 1.5.4


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- l -

  • LeaveMulticastGroup()
: Activ::RouterServiceApi::Udp
, Activ::UdpComponent
, Activ::UdpSocket
  • Listen() : Activ::RouterServiceApi::Tcp
  • LocalTime() : Activ::LocalTime
  • LockedBreak() : Activ::TcpSocket
  • LockedRead() : Activ::IpSocket
  • LockedWrite() : Activ::IpSocket
  • LogMessage() : Activ::LoggerServiceApi
  • Logoff() : Activ::ContentPlatform::ContentServerApi::ContentServerClient
  • Logon() : Activ::ContentPlatform::ContentServerApi::ContentServerClient
  • LowFields() : Activ::ContentPlatform::Feed::Rule::LowFields
Generated on Wed Oct 8 14:01:54 2008 for ACTIV C++ SDK by doxygen 1.5.4


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- m -

  • m_acceptPosted : Activ::TcpSocket::Stats
  • m_add1CumulativeValue : Activ::ContentPlatform::Feed::Rule::VolumeFields
  • m_add1Price : Activ::ContentPlatform::Feed::Rule::VolumeFields
  • m_add1Volume : Activ::ContentPlatform::Feed::Rule::VolumeFields
  • m_add2CumulativeValue : Activ::ContentPlatform::Feed::Rule::VolumeFields
  • m_add2Price : Activ::ContentPlatform::Feed::Rule::VolumeFields
  • m_add2Volume : Activ::ContentPlatform::Feed::Rule::VolumeFields
  • m_addressLength : Activ::IpAddress
  • m_agentScope : Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::ConnectParameters , Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::ConnectParameters
  • m_amfFieldIndex : Activ::ContentPlatform::Feed::Field::Specification , Activ::ContentPlatform::Feed::TableTemplate::FieldSpecification
  • m_amfRecordSize : Activ::ContentPlatform::Feed::TableTemplate::Specification
  • m_amfRowIndex : Activ::ContentPlatform::Feed::Field::Specification , Activ::ContentPlatform::Feed::TableTemplate::FieldSpecification
  • m_amfRowOffset : Activ::ContentPlatform::Feed::Field::Specification , Activ::ContentPlatform::Feed::TableTemplate::FieldSpecification
  • m_amfTableId : Activ::ContentPlatform::Feed::TableTemplate::Specification
  • m_applicationHeapBucketInfo : Activ::ThinApplication::Settings
  • m_attributeQuery : Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::ConnectParameters , Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::ConnectParameters
  • m_attributes : Activ::ServiceInstance
  • m_averageCpuUsage : Activ::SystemMonitor::Stats::ProcessInfo , Activ::SystemMonitor::Stats
  • m_bccAddressList : Activ::SmtpHelper::Email
  • m_bitsPerSecond : Activ::IpManager::InterfaceInfo
  • m_blockSize : Activ::IHeap::BucketInfo
  • m_boostVersion : Activ::SystemInfo
  • m_bucketStatsVector : Activ::IHeap::Stats
  • m_buffer : Activ::ContentPlatform::ContentGatewayApi::FieldData
  • m_bufferSize : Activ::Database::FieldListObject
  • m_buildConfiguration
: Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::ApiInfo
, Activ::ContentPlatform::ContentServerApi::ContentServerClient::ApiInfo
, Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::ApiInfo
, Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::ApiInfo
  • m_buildDateTime
: Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::ApiInfo
, Activ::ContentPlatform::ContentServerApi::ContentServerClient::ApiInfo
, Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::ApiInfo
, Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::ApiInfo
  • m_buyerId : Activ::ContentPlatform::ContentGatewayApi::Tick
  • m_byteCount : Activ::IEndPoint::Stats
  • m_byteCountDailyHigh : Activ::IEndPoint::Stats
  • m_byteCountHigh : Activ::IEndPoint::Stats
  • m_byteCountLastHigh : Activ::IEndPoint::Stats
  • m_cachedFieldIdList : Activ::Database::IndexSpecification
  • m_cacheSize : Activ::Database::TableSpecification
  • m_ccAddressList : Activ::SmtpHelper::Email
  • m_closeFields : Activ::ContentPlatform::Feed::Rule
  • m_closeOnTxCompletion : Activ::IpSocket::Stats , Activ::IpSocket
  • m_closePosted : Activ::IpSocket::Stats , Activ::IpSocket
  • m_codeIdentifier
: Activ::ContentPlatform::ContentGatewayApi::RelationshipInfo
, Activ::ContentPlatform::Feed::Field::Specification
, Activ::ContentPlatform::Feed::TableTemplate::Specification
, Activ::ContentPlatform::Feed::TableTemplateList::TableTemplateSpecification
, Activ::ContentPlatform::Feed::EntityTypeHelper
, Activ::ContentPlatform::Feed::EventTypeHelper
, Activ::ContentPlatform::Feed::PermissionIdHelper
, Activ::ContentPlatform::Feed::RelationshipIdHelper
, Activ::ContentPlatform::Feed::UniversalFieldHelper
  • m_columnSpacing : Activ::UiIo::Columnizer
  • m_compositeAskState : Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessage
  • m_compositeBidState : Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessage
  • m_compositeUpdateId : Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessage , Activ::ContentPlatform::Feed::CompressedMessage
  • m_computerName : Activ::SystemInfo
  • m_condition
: Activ::ContentPlatform::Feed::Rule::CopyToFields
, Activ::ContentPlatform::Feed::Rule::HighFields
, Activ::ContentPlatform::Feed::Rule::LowFields
, Activ::ContentPlatform::Feed::Rule::OpenFields
, Activ::ContentPlatform::Feed::Rule::CloseFields
, Activ::ContentPlatform::Feed::Rule
  • m_conditions : Activ::ContentPlatform::ContentGatewayApi::Tick
  • m_connectPosted : Activ::TcpSocket::Stats
  • m_context : Activ::ContentPlatform::ContentGatewayApi::RelationshipInfo
  • m_contextSwitchRate : Activ::SystemMonitor::Stats
  • m_copyIfUndefined : Activ::ContentPlatform::Feed::CopyOnReset
  • m_copyToFields : Activ::ContentPlatform::Feed::Rule
  • m_count
: Activ::ContentPlatform::ContentGatewayApi::Period
, Activ::ContentPlatform::Feed::Rule::PriceFields
, Activ::IHeap::Stats::RequestDistributionStats
  • m_cpuUsageList : Activ::SystemMonitor::Stats
  • m_createMutex : Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::Settings , Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::Settings
  • m_createSystemLog : Activ::AgentApplication::Settings
  • m_creatorProcessId : Activ::IEndPoint::Stats
  • m_cumulativePrice : Activ::ContentPlatform::Feed::Rule::PriceFields
  • m_currentVersion : Activ::OpenServiceRequest
  • m_databaseTableSpecificationList : Activ::Database::DatabaseSpecification
  • m_dataLength : Activ::ScatterBufferHelper::ScatterBuffer , Activ::Database::FieldList
  • m_dataPointAddress : Activ::ContentPlatform::ContentGatewayApi::Period
  • m_date
: Activ::ContentPlatform::Feed::Rule::CopyToFields
, Activ::ContentPlatform::Feed::Rule::HighFields
, Activ::ContentPlatform::Feed::Rule::LowFields
, Activ::ContentPlatform::Feed::Rule::CloseFields
, Activ::ContentPlatform::Feed::Rule
  • m_dateTime : Activ::ContentPlatform::ContentGatewayApi::Tick , Activ::ContentPlatform::ContentGatewayApi::Period
  • m_defaultBuffer : Activ::Database::FieldListObject
  • m_defaultRuleSet : Activ::ContentPlatform::ContributionGatewayApi::PublishSymbolRecordParameters
  • m_defaultValue : Activ::CommandLineParserDetail::DefaultDescription< T >
  • m_delayPeriod : Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestParameters , Activ::ContentPlatform::Feed::PermissionLevelData
  • m_description
: Activ::ContentPlatform::Feed::Field::Specification
, Activ::ContentPlatform::Feed::UniversalFieldHelper
, Activ::CommandLineParserDetail::Description< T >
  • m_directory : Activ::FileInfo
  • m_directoryServiceSettings : Activ::AgentApplication::Settings
  • m_disabledDateSet : Activ::Timeband::Settings
  • m_diskInfoList : Activ::SystemMonitor::Stats
  • m_diskName : Activ::SystemMonitor::Stats::DiskInfo
  • m_distributionVector : Activ::IHeap::Stats
  • m_enableCtrlHandler : Activ::Application::Settings
  • m_enabledDateFlag : Activ::Timeband::Settings
  • m_enabledDaysBitmap : Activ::Timeband::Settings
  • m_enableUiService : Activ::AgentApplication::Settings
  • m_enableWindowsOverlappedOperations : Activ::IpManager::Settings
  • m_endDate : Activ::ContentPlatform::ContentGatewayApi::NewsRequestParameters
  • m_endPointIdSet : Activ::SystemMessageEndPointIdSet
  • m_endTime : Activ::Timeband::Settings
  • m_entityType : Activ::ContentPlatform::ContentGatewayApi::SymbolResponse , Activ::ContentPlatform::Feed::EntityTypeHelper
  • m_entityTypeList : Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryRequestParameters
  • m_error
: Activ::ContentPlatform::Feed::Rule::LowFields
, Activ::ContentPlatform::Feed::Rule::OpenFields
, Activ::ContentPlatform::Feed::Rule::CloseFields
, Activ::ContentPlatform::Feed::Rule::PriceFields
, Activ::ContentPlatform::Feed::Rule::VolumeFields
, Activ::ContentPlatform::Feed::Rule
, Activ::ContentPlatform::Feed::Rule::CopyToFields
, Activ::ContentPlatform::Feed::Rule::HighFields
  • m_errorCode : Activ::Exception
  • m_eventType
: Activ::ContentPlatform::ContentGatewayApi::RecordUpdate
, Activ::ContentPlatform::Feed::EventTypeHelper
, Activ::DirectoryWatchApi::Event
  • m_eventTypeList : Activ::ContentPlatform::ContentGatewayApi::SubscribeParameters , Activ::ContentPlatform::ContentServerApi::ContentServerClient::UpdateFilter
  • m_exceptionHandlerType : Activ::Application::Settings
  • m_exchange
: Activ::ContentPlatform::ContentGatewayApi::Tick
, Activ::ContentPlatform::Feed::Rule::CopyToFields
, Activ::ContentPlatform::Feed::Rule::HighFields
, Activ::ContentPlatform::Feed::Rule::LowFields
, Activ::ContentPlatform::Feed::Rule::OpenFields
, Activ::ContentPlatform::Feed::Rule::CloseFields
, Activ::ContentPlatform::Feed::Rule
  • m_extendedUiShutdown : Activ::AgentApplication::Settings
  • m_failoverSeconds : Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::ConnectParameters , Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::ConnectParameters
  • m_feedSubscriptionCount : Activ::ContentPlatform::ContentGatewayApi::SubscriptionInfo
  • m_fieldData
: Activ::ContentPlatform::ContentGatewayApi::NewsStory
, Activ::ContentPlatform::ContentGatewayApi::ResponseBlock
, Activ::ContentPlatform::ContentGatewayApi::RecordUpdate
  • m_fieldErrorList : Activ::ContentPlatform::ContributionGatewayApi::PublishRecordResponseParameters
  • m_fieldFilterType : Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestParameters
  • m_fieldId
: Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryRequestParameters
, Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryResponseParameters
, Activ::ContentPlatform::ContributionGatewayApi::PublishField
, Activ::ContentPlatform::FeedApi::FieldListValidator::Field
, Activ::ContentPlatform::Feed::CompressedMessageDefinitions::FieldSpecification
, Activ::ContentPlatform::Feed::IndexSpecification::Field
, Activ::ContentPlatform::Feed::UniversalFieldHelper
, Activ::Database::IndexSpecification::Field
  • m_fieldIdList
: Activ::ContentPlatform::ContentGatewayApi::NewsRequestParameters
, Activ::ContentPlatform::ContentGatewayApi::RequestBlock
, Activ::ContentPlatform::Feed::PermissionInfo::PermissionIdInfo
  • m_fieldIdMap : Activ::Database::FieldList
  • m_fieldList
: Activ::ContentPlatform::ContributionGatewayApi::PublishSymbolRecordParameters
, Activ::ContentPlatform::ContributionGatewayApi::PublishRecordParameters
, Activ::Database::FieldList
  • m_fieldNoList : Activ::Database::FieldList
  • m_fieldSpecificationList
: Activ::ContentPlatform::Feed::TableTemplate::Specification
, Activ::ContentPlatform::Feed::TableTemplateList::TableTemplateSpecification
, Activ::Database::TableSpecification
  • m_fieldStatus : Activ::ContentPlatform::FeedApi::FieldListValidator::Field
  • m_file : Activ::Exception
  • m_fileTime : Activ::FileInfo
  • m_filterType : Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryRequestParameters
  • m_firstFailLocalDateTime : Activ::IHeap::Stats
  • m_firstRunFails : Activ::IHeap::Stats::BucketStats
  • m_flags
: Activ::ContentPlatform::ContentGatewayApi::NewsRequestParameters
, Activ::ContentPlatform::ContentGatewayApi::NewsUpdate
, Activ::ContentPlatform::ContentGatewayApi::RequestBlock
, Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters
, Activ::ContentPlatform::ContentGatewayApi::ResponseBlock
, Activ::ContentPlatform::ContentGatewayApi::RecordUpdate
, Activ::ContentPlatform::ContentGatewayApi::SymbolResponse
, Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestParameters
, Activ::ContentPlatform::ContentGatewayApi::ContentGatewayInfo
  • m_freeMemory : Activ::SystemInfo
  • m_freeMemoryPercent : Activ::SystemMonitor::Stats
  • m_fromAddress : Activ::IpSocket , Activ::SmtpHelper::Email
  • m_function : Activ::Exception
  • m_handle : Activ::IpSocket
  • m_hasMutex : Activ::IEndPoint::Stats
  • m_heapBucketInfoVector : Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::Settings , Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::Settings
  • m_hexDump : Activ::HeapMessage::Stats
  • m_highestThreadCpuUsage : Activ::SystemMonitor::Stats::ProcessInfo
  • m_highestThreadCpuUsageId : Activ::SystemMonitor::Stats::ProcessInfo
  • m_highestVersion : Activ::OpenServiceRequest
  • m_highFields : Activ::ContentPlatform::Feed::Rule
  • m_id
: Activ::ContentPlatform::Feed::Field::Specification
, Activ::ContentPlatform::Feed::Index::IndexFieldSpecification
, Activ::ContentPlatform::Feed::TableTemplate::FieldSpecification
, Activ::ContentPlatform::Feed::TableTemplate::Specification
, Activ::Database::FieldListObject
, Activ::Database::FieldSpecification
, Activ::IProcess::Stats
  • m_idealBucketFails : Activ::IHeap::Stats
  • m_identity : Activ::Database::ITable
  • m_indexFieldSpecificationList : Activ::ContentPlatform::Feed::Index::Specification , Activ::Database::IndexSpecification
  • m_indexNumber : Activ::ContentPlatform::ContributionGatewayApi::PublishRecordParameters
  • m_indexSpecificationList
: Activ::ContentPlatform::Feed::TableTemplate::Specification
, Activ::ContentPlatform::Feed::TableTemplateList::TableTemplateSpecification
, Activ::Database::DatabaseSpecification::DatabaseTableSpecification
  • m_infoString : Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::ConnectParameters , Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::ConnectParameters
  • m_iniFileName : Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::Settings
  • m_initialMaxRecords : Activ::Database::TableSpecification
  • m_initialPortListSize : Activ::ManagedEndPoint::Settings
  • m_inTxQueueBytes : Activ::RouterServiceApi::Tcp::SocketStats
  • m_inTxQueueHighBytes : Activ::RouterServiceApi::Tcp::SocketStats
  • m_inTxQueueHighMessages : Activ::RouterServiceApi::Tcp::SocketStats
  • m_inTxQueueMessages : Activ::RouterServiceApi::Tcp::SocketStats
  • m_ipAddressList : Activ::IpManager::InterfaceInfo
  • m_ipManager : Activ::IpSocket
  • m_isAmfField : Activ::ContentPlatform::Feed::Field::Specification , Activ::ContentPlatform::Feed::TableTemplate::FieldSpecification
  • m_isAmfTable : Activ::ContentPlatform::Feed::TableTemplate::Specification
  • m_isComposite : Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessage , Activ::ContentPlatform::Feed::CompressedMessage
  • m_isCompositeAsk : Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessage
  • m_isCompositeBid : Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessage
  • m_isDelete : Activ::ContentPlatform::Feed::CompressedMessage
  • m_isInitialized : Activ::Database::FieldListObject , Activ::IFieldType
  • m_isLatestVersion : Activ::ContentPlatform::Feed::TableTemplate::Specification , Activ::ContentPlatform::Feed::TableTemplateList::TableTemplateSpecification
  • m_isManaged : Activ::Database::TableSpecification
  • m_isSizeField : Activ::ContentPlatform::Feed::CompressedMessageDefinitions::FieldSpecification
  • m_key1 : Activ::Des3Helper::KeyBundle
  • m_key2 : Activ::Des3Helper::KeyBundle
  • m_key3 : Activ::Des3Helper::KeyBundle
  • m_keyFieldList : Activ::ContentPlatform::ContributionGatewayApi::PublishRecordParameters
  • m_lastFailLocalDateTime : Activ::IHeap::Stats
  • m_licenseServiceSettings : Activ::AgentApplication::Settings
  • m_line : Activ::Exception
  • m_localAddress : Activ::IpSocket::Stats , Activ::IpSocket
  • m_location : Activ::Url
  • m_loggerServiceSettings : Activ::AgentApplication::Settings
  • m_logonFlags : Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::ConnectParameters
  • m_lowFields : Activ::ContentPlatform::Feed::Rule
  • m_lowFreeBlocks : Activ::IHeap::Stats::BucketStats
  • m_managedEndPointSettings : Activ::Application::Settings
  • m_matchData : Activ::ContentPlatform::ContentGatewayApi::SymbolResponse
  • m_matchType : Activ::ContentPlatform::ContentGatewayApi::MatchRequestParameters , Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryRequestParameters
  • m_maxFieldSets : Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestParameters
  • m_maxLength
: Activ::ContentPlatform::Feed::Field::Specification
, Activ::ContentPlatform::Feed::TableTemplate::FieldSpecification
, Activ::ContentPlatform::Feed::UniversalFieldHelper
, Activ::Database::FieldSpecification
  • m_maxRecordsPerResponse : Activ::ContentPlatform::ContentGatewayApi::NewsRequestParameters
  • m_maxRequestSize : Activ::IHeap::Stats
  • m_maxResponseBlocks : Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters
  • m_maxSize : Activ::IHeap::Stats::RequestDistributionStats
  • m_maxThreads : Activ::ManagedEndPoint::Settings
  • m_memoryModel : Activ::ISystem::Settings , Activ::ISystem::SystemInfo
  • m_memoryUsage : Activ::IHeap::Stats
  • m_messageCount : Activ::IEndPoint::Stats
  • m_messageCountDailyHigh : Activ::IEndPoint::Stats
  • m_messageCountHigh : Activ::IEndPoint::Stats
  • m_messageCountLastHigh : Activ::IEndPoint::Stats
  • m_messageRate : Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::Settings
  • m_messageValidator : Activ::ContentPlatform::ContentGatewayApi::FieldListValidator
  • m_messageVersion : Activ::ContentPlatform::ContentGatewayApi::FieldData
  • m_middlewareDate : Activ::SystemInfo
  • m_middlewareVersion : Activ::SystemInfo
  • m_middlewareVersionValue : Activ::SystemInfo
  • m_minFreePortIdListSize : Activ::ManagedEndPoint::Settings
  • m_minimumTimerResolution : Activ::ISystem::Settings
  • m_minSize : Activ::IHeap::Stats::RequestDistributionStats
  • m_mode : Activ::Database::ITable
  • m_monitorServiceSettings : Activ::AgentApplication::Settings
  • m_mutexContentionCount
: Activ::RouterServiceApi::Tcp::SocketStats
, Activ::IpSocket::Stats
, Activ::IEndPoint::Stats
, Activ::IHeap::Stats
  • m_name
: Activ::ContentPlatform::ContentGatewayApi::RelationshipInfo
, Activ::ContentPlatform::ContentServerApi::ContentServerClient::MessageStats
, Activ::ContentPlatform::ContentServerApi::ContentServerClient::UpdateFilterMap
, Activ::ContentPlatform::Feed::PermissionInfo::PermissionIdInfo
, Activ::ContentPlatform::Feed::Field::Specification
, Activ::ContentPlatform::Feed::Index::Specification
, Activ::ContentPlatform::Feed::TableTemplate::Specification
, Activ::ContentPlatform::Feed::TableTemplateList::TableTemplateSpecification
, Activ::ContentPlatform::Feed::EntityTypeHelper
, Activ::ContentPlatform::Feed::EventTypeHelper
, Activ::ContentPlatform::Feed::PermissionIdHelper
, Activ::ContentPlatform::Feed::RelationshipIdHelper
, Activ::ContentPlatform::Feed::UniversalFieldHelper
, Activ::CommandLineParserDetail::Description< T >
, Activ::SystemMonitor::Stats::ProcessInfo
, Activ::Database::DatabaseSpecification
, Activ::Database::FieldSpecification
, Activ::Database::IndexSpecification
, Activ::Database::TableSpecification
, Activ::IProcess::Stats
, Activ::FileInfo
  • m_netChange : Activ::ContentPlatform::Feed::Rule::PriceFields
  • m_newsStory : Activ::ContentPlatform::ContentGatewayApi::NewsUpdate
  • m_newsSubscriptionMap : Activ::ContentPlatform::ContentGatewayApi::SubscriptionInfo
  • m_nFields : Activ::Database::FieldList
  • m_nGrowRecords : Activ::Database::TableSpecification
  • m_notificationType : Activ::IEndPoint::Stats , Activ::ManagedEndPoint::Settings
  • m_notifier : Activ::CommandLineParserDetail::Description< T >
  • m_number
: Activ::ContentPlatform::Feed::Index::Specification
, Activ::ContentPlatform::Feed::TableTemplateList::TableTemplateSpecification
, Activ::Database::IndexSpecification
  • m_numberOfColumns : Activ::UiIo::Columnizer
  • m_numberOfIoThreads : Activ::IpManager::Settings
  • m_numberOfLines : Activ::UiIo::Columnizer
  • m_numberOfProcessorCores : Activ::SystemInfo
  • m_numberOfProcessorPackages : Activ::SystemInfo
  • m_numberOfProcessorThreads : Activ::SystemInfo
  • m_numberOfRecords
: Activ::ContentPlatform::ContentGatewayApi::NewsRequestParameters
, Activ::ContentPlatform::ContentGatewayApi::TableNumberRequestParameters
, Activ::ContentPlatform::ContentGatewayApi::SymbolIdCountRequestParameters
  • m_numBlocks : Activ::IHeap::BucketInfo
  • m_numFreeBlocks : Activ::IHeap::Stats::BucketStats
  • m_offset : Activ::IniFileParser::ParseException , Activ::Database::FieldSpecification
  • m_openFields : Activ::ContentPlatform::Feed::Rule
  • m_osId : Activ::IProcess::Stats
  • m_osName : Activ::SystemInfo
  • m_outSequence : Activ::ContentPlatform::ContentGatewayApi::Tick
  • m_pagesInOutRate : Activ::SystemMonitor::Stats
  • m_parameterList : Activ::Url
  • m_parentService : Activ::ChildService< T >
  • m_password
: Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::ConnectParameters
, Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::ConnectParameters
, Activ::IFtpHelper
  • m_path : Activ::Url , Activ::DirectoryWatchApi::Event
  • m_pathList : Activ::ContentPlatform::Feed::TableTemplateList::Settings
  • m_pData : Activ::ScatterBufferHelper::ScatterBuffer , Activ::Database::FieldListObject
  • m_peakCpuUsage : Activ::SystemMonitor::Stats
  • m_percentChange : Activ::ContentPlatform::Feed::Rule::PriceFields
  • m_periodList : Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestParameters
  • m_periodType : Activ::ContentPlatform::ContentGatewayApi::Period
  • m_permissionId
: Activ::ContentPlatform::Feed::PermissionIdHelper
, Activ::ContentPlatform::ContentGatewayApi::ResponseBlock
, Activ::ContentPlatform::ContentGatewayApi::RecordUpdate
, Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessage
, Activ::ContentPlatform::Feed::CompressedMessage
  • m_permissionIdList : Activ::ContentPlatform::ContentGatewayApi::NewsStory , Activ::ContentPlatform::ContributionGatewayApi::PermissionInfo
  • m_permissionLevel
: Activ::ContentPlatform::ContentGatewayApi::SubscribeFeedParameters
, Activ::ContentPlatform::ContentGatewayApi::NewsRequestParameters
, Activ::ContentPlatform::ContentGatewayApi::SubscribeTableParameters
, Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters
, Activ::ContentPlatform::ContentGatewayApi::ResponseBlock
, Activ::ContentPlatform::ContentGatewayApi::RecordUpdate
  • m_permissionLevelData : Activ::ContentPlatform::ContentGatewayApi::ResponseBlock , Activ::ContentPlatform::ContentGatewayApi::RecordUpdate
  • m_permissionLevelInfo : Activ::ContentPlatform::Feed::PermissionInfo
  • m_permissionLevelList : Activ::ContentPlatform::ContentGatewayApi::ContentGatewayInfo
  • m_pFieldList : Activ::Database::FieldListObject
  • m_pFtpHelper : Activ::FtpHelper
  • m_pHeap : Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::Settings , Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::Settings
  • m_physicalMemory : Activ::SystemInfo
  • m_pIFieldType : Activ::ContentPlatform::FeedApi::FieldListValidator::Field
  • m_platformType : Activ::SystemInfo
  • m_pMutex : Activ::IpSocket
  • m_policy : Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::ConnectParameters , Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::ConnectParameters
  • m_port : Activ::IFtpHelper
  • m_previousDayChange : Activ::ContentPlatform::Feed::Rule::PriceFields
  • m_previousDayTrend : Activ::ContentPlatform::Feed::Rule
  • m_price : Activ::ContentPlatform::ContentGatewayApi::Tick
  • m_priceFields : Activ::ContentPlatform::Feed::Rule
  • m_processInfoMap : Activ::SystemMonitor::Stats
  • m_processorAffinityList : Activ::ISystem::Settings
  • m_processorInfoList : Activ::SystemInfo
  • m_processStartupIniFile : Activ::AgentApplication::Settings
  • m_processVersion : Activ::ISystem::Settings
  • m_properties
: Activ::Database::FieldSpecification
, Activ::ContentPlatform::Feed::Index::Specification
, Activ::ContentPlatform::Feed::IndexSpecification::Field
, Activ::Database::DatabaseSpecification
, Activ::Database::IndexSpecification::Field
, Activ::Database::IndexSpecification
, Activ::Database::TableSpecification
  • m_protocol : Activ::Url , Activ::IpAddress
  • m_pTable : Activ::Database::FieldListObject
  • m_pTableTemplate
: Activ::ContentPlatform::Feed::Rule::PriceFields
, Activ::ContentPlatform::Feed::Rule::HighFields
, Activ::ContentPlatform::Feed::Rule::CopyToFields
, Activ::ContentPlatform::Feed::Rule::LowFields
, Activ::ContentPlatform::Feed::Rule::OpenFields
, Activ::ContentPlatform::Feed::Rule::CloseFields
, Activ::ContentPlatform::Feed::Rule::VolumeFields
, Activ::ContentPlatform::Feed::Rule
  • m_pubSubServiceSettings : Activ::AgentApplication::Settings
  • m_query : Activ::ContentPlatform::ContentGatewayApi::NewsRequestParameters
  • m_receivedUpdateCount : Activ::ContentPlatform::ContentServerApi::ContentServerClient::MessageStats
  • m_recordFilterType : Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestParameters
  • m_recordLength : Activ::Database::TableSpecification
  • m_relationshipId
: Activ::ContentPlatform::Feed::RelationshipIdHelper
, Activ::ContentPlatform::ContentGatewayApi::RelationshipInfo
, Activ::ContentPlatform::ContentGatewayApi::RequestBlock
, Activ::ContentPlatform::ContentGatewayApi::ResponseBlock
, Activ::ContentPlatform::ContentGatewayApi::RecordUpdate
  • m_remoteAddress : Activ::IpSocket::Stats , Activ::IpSocket
  • m_requestBlockList : Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters
  • m_requestKey : Activ::ContentPlatform::ContentGatewayApi::RecordUpdate
  • m_reservedPortIdSet : Activ::ManagedEndPoint::Settings
  • m_resetTime : Activ::ContentPlatform::ContentServerApi::ContentServerClient::Settings
  • m_resolvedKey : Activ::ContentPlatform::ContentGatewayApi::ResponseBlock
  • m_responseBlockList : Activ::ContentPlatform::ContentGatewayApi::RealtimeResponseParameters
  • m_responseKey : Activ::ContentPlatform::ContentGatewayApi::ResponseBlock
  • m_routerServiceSettings : Activ::AgentApplication::Settings
  • m_rules : Activ::ContentPlatform::FeedApi::FieldListValidator::Field
  • m_rxBuffers : Activ::IpSocket
  • m_rxBytes
: Activ::RouterServiceApi::Tcp::SocketStats
, Activ::IpSocket::Stats
, Activ::IpSocket
  • m_rxFlags : Activ::IpSocket
  • m_rxOverlapped : Activ::IpSocket
  • m_rxPosted : Activ::IpSocket::Stats
  • m_schedulerInfo : Activ::SystemInfo
  • m_searchString : Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryRequestParameters
  • m_secondRunFails : Activ::IHeap::Stats::BucketStats
  • m_sectionName : Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::Settings
  • m_sellerId : Activ::ContentPlatform::ContentGatewayApi::Tick
  • m_sequence : Activ::ContentPlatform::Feed::IndexSpecification::Field
  • m_seriesType : Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestParameters
  • m_server : Activ::IFtpHelper
  • m_serviceAccessPointList : Activ::ServiceInstance
  • m_serviceAddress : Activ::ServiceHandle
  • m_serviceHandleList : Activ::ContentPlatform::Feed::TableTemplateList::Settings
  • m_serviceId
: Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::ConnectParameters
, Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::ConnectParameters
, Activ::ServiceHandle
, Activ::ServiceInstance
  • m_serviceIdList : Activ::ContentPlatform::Feed::TableTemplateList::Settings
  • m_serviceLocationIniFile : Activ::AgentApplication::Settings
  • m_setConsoleTitle : Activ::ISystem::Settings
  • m_shouldCork : Activ::IpSocket::Settings
  • m_shouldReInitializeOnReset : Activ::ContentPlatform::Feed::TableTemplateList::Settings
  • m_shouldTerminateOnError : Activ::ContentPlatform::Feed::TableTemplateList::Settings
  • m_size
: Activ::ContentPlatform::Feed::Rule::CopyToFields
, Activ::ContentPlatform::Feed::Rule
, Activ::FileInfo
, Activ::ContentPlatform::ContentGatewayApi::Tick
  • m_smallBlockHeapThreshold : Activ::ISystem::Settings
  • m_source : Activ::ContentPlatform::Feed::Rule , Activ::ContentPlatform::Feed::CopyOnReset
  • m_specifiedInterval : Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestParameters
  • m_startDate : Activ::ContentPlatform::ContentGatewayApi::NewsRequestParameters
  • m_startSymbol : Activ::ContentPlatform::ContentGatewayApi::NewsRequestParameters
  • m_startTime : Activ::Timeband::Settings
  • m_state
: Activ::TcpSocket
, Activ::UdpSocket
, Activ::UdpSocket::Stats
, Activ::TcpSocket::Stats
, Activ::IProcess::Stats
  • m_status
: Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayResponseParameters
, Activ::ContentPlatform::Feed::Rule::CloseFields
, Activ::ContentPlatform::ContentGatewayApi::ResponseBlock
  • m_subject : Activ::SmtpHelper::Email
  • m_subscribeParameters : Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters
  • m_subscriptionCookie : Activ::ContentPlatform::ContentGatewayApi::RealtimeResponseParameters
  • m_subscriptionCookieList : Activ::ContentPlatform::ContentGatewayApi::NewsUpdate
  • m_symbol
: Activ::ContentPlatform::ContentGatewayApi::SymbolId
, Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessage
, Activ::ContentPlatform::ContentGatewayApi::NewsStory
, Activ::ContentPlatform::ContributionGatewayApi::PublishSymbolRecordParameters
, Activ::ContentPlatform::Feed::CompressedMessage
  • m_symbolId
: Activ::ContentPlatform::ContentGatewayApi::SymbolResponse
, Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestParameters
, Activ::ContentPlatform::ContentGatewayApi::SymbolIdCountRequestParameters
, Activ::ContentPlatform::ContentGatewayApi::RecordUpdate
, Activ::ContentPlatform::ContentGatewayApi::SymbolIdMatchRequestParameters
  • m_symbolIdList : Activ::ContentPlatform::ContentGatewayApi::SymbolIdListMatchRequestParameters
  • m_symbolPatternList : Activ::ContentPlatform::ContentServerApi::ContentServerClient::UpdateFilter
  • m_symbolResponseList : Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryResponseParameters
  • m_symbolSubscriptionMap : Activ::ContentPlatform::ContentGatewayApi::SubscriptionInfo
  • m_symbolSubscriptionQuota : Activ::ContentPlatform::ContentGatewayApi::PermissionInfo
  • m_systemHeapBucketInfo : Activ::AgentApplication::Settings
  • m_systemInfo : Activ::ContentPlatform::ContentGatewayApi::ContentGatewayInfo , Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayInfo
  • m_systemLogMaxSize : Activ::AgentApplication::Settings
  • m_systemLogMode : Activ::ISystem::Settings
  • m_systemLogNumberOfBackups : Activ::AgentApplication::Settings
  • m_systemLogType : Activ::AgentApplication::Settings
  • m_systemLogUniqueName : Activ::AgentApplication::Settings
  • m_systemName : Activ::ISystem::SystemInfo , Activ::ISystem::Settings
  • m_systemVersion : Activ::ISystem::SystemInfo , Activ::AgentApplication::Settings
  • m_tableClientHeapBucketInfo : Activ::ContentPlatform::Feed::TableTemplateList::Settings
  • m_tableCodeIdentifier : Activ::ContentPlatform::ContentGatewayApi::TableInfo
  • m_tableId : Activ::Database::DatabaseSpecification::DatabaseTableSpecification
  • m_tableIdentity : Activ::Database::FieldListObject
  • m_tableName : Activ::ContentPlatform::ContentGatewayApi::TableInfo
  • m_tableNumber
: Activ::ContentPlatform::ContentGatewayApi::PatternMatchRequestParameters
, Activ::ContentPlatform::ContentGatewayApi::SymbolId
, Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessage
, Activ::ContentPlatform::ContributionGatewayApi::PublishRecordBaseParameters
, Activ::ContentPlatform::ContentGatewayApi::TableNumberRequestParameters
, Activ::ContentPlatform::Feed::CompressedMessage
, Activ::ContentPlatform::ContentGatewayApi::PatternMatchListRequestParameters
, Activ::ContentPlatform::ContentGatewayApi::TableInfo
  • m_tableNumberList : Activ::ContentPlatform::ContentGatewayApi::SubscribeTableParameters , Activ::ContentPlatform::ContentServerApi::ContentServerClient::UpdateFilter
  • m_tableSpecification : Activ::Database::DatabaseSpecification::DatabaseTableSpecification
  • m_tableSubscriptionMap : Activ::ContentPlatform::ContentGatewayApi::SubscriptionInfo
  • m_tableTemplateListSettings : Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::Settings
  • m_tableTemplateServiceId : Activ::ContentPlatform::ContentServerApi::ContentServerClient::Settings
  • m_target
: Activ::ContentPlatform::Feed::CopyOnReset
, Activ::ContentPlatform::Feed::Rule::OpenFields
, Activ::ContentPlatform::Feed::Rule::CloseFields
, Activ::ContentPlatform::Feed::Rule::CopyToFields
, Activ::ContentPlatform::Feed::Rule::HighFields
, Activ::ContentPlatform::Feed::Rule::LowFields
  • m_text : Activ::SmtpHelper::Email
  • m_threadPriority : Activ::ManagedEndPoint::Settings
  • m_threadProcessorAffinityList : Activ::ManagedEndPoint::Settings
  • m_tickType : Activ::ContentPlatform::ContentGatewayApi::Tick
  • m_time
: Activ::ContentPlatform::Feed::Rule::LowFields
, Activ::ContentPlatform::Feed::Rule::OpenFields
, Activ::ContentPlatform::Feed::Rule
, Activ::ContentPlatform::Feed::Rule::CopyToFields
, Activ::ContentPlatform::Feed::Rule::HighFields
  • m_timerServiceSettings : Activ::AgentApplication::Settings
  • m_toAddress : Activ::IpSocket
  • m_toAddressList : Activ::SmtpHelper::Email
  • m_totalCurrentFreeBlocks : Activ::IHeap::Stats
  • m_totalErrorCount : Activ::ContentPlatform::ContentServerApi::ContentServerClient::MessageStats
  • m_totalFails : Activ::IHeap::Stats
  • m_totalIgnoredCount : Activ::ContentPlatform::ContentServerApi::ContentServerClient::MessageStats
  • m_totalLowFreeBlocks : Activ::IHeap::Stats
  • m_totalProcessedCount : Activ::ContentPlatform::ContentServerApi::ContentServerClient::MessageStats
  • m_tradeThroughExemptFlag : Activ::ContentPlatform::ContentGatewayApi::Tick
  • m_twinFieldId : Activ::ContentPlatform::Feed::CompressedMessageDefinitions::FieldSpecification
  • m_txBuffers : Activ::IpSocket
  • m_txBytes
: Activ::IpSocket::Stats
, Activ::RouterServiceApi::Tcp::SocketStats
, Activ::IpSocket
  • m_txFlags : Activ::IpSocket
  • m_txOverlapped : Activ::IpSocket
  • m_txPosted : Activ::IpSocket::Stats
  • m_txQueueBytes : Activ::RouterServiceApi::Tcp::SocketStats
  • m_txQueueHighBytes : Activ::RouterServiceApi::Tcp::SocketStats
  • m_txQueueHighMessages : Activ::RouterServiceApi::Tcp::SocketStats
  • m_txQueueMessages : Activ::RouterServiceApi::Tcp::SocketStats
  • m_type
: Activ::Database::FieldSpecification
, Activ::ContentPlatform::Feed::UniversalFieldHelper
, Activ::ContentPlatform::ContentGatewayApi::SubscribeParameters
, Activ::ContentPlatform::Feed::TableTemplate::Specification
, Activ::ContentPlatform::Feed::TableTemplateList::TableTemplateSpecification
, Activ::ContentPlatform::Feed::PermissionInfo::PermissionIdInfo
, Activ::IpAddress
, Activ::ContentPlatform::Feed::Index::Specification
, Activ::ContentPlatform::Feed::Field::Specification
, Activ::Database::IndexSpecification
  • m_udpSettings : Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::Settings
  • m_uiPermissions : Activ::UiMenu::OptionAttributes
  • m_uiServiceSettings : Activ::AgentApplication::Settings
  • m_unrecognizedUpdateCount : Activ::ContentPlatform::ContentServerApi::ContentServerClient::MessageStats
  • m_updateFilterMap : Activ::ContentPlatform::ContentServerApi::ContentServerClient::UpdateFilterMap
  • m_updateId
: Activ::ContentPlatform::ContentGatewayApi::Tick
, Activ::ContentPlatform::ContentGatewayApi::NewsUpdate
, Activ::ContentPlatform::Feed::CompressedMessage
, Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessage
, Activ::ContentPlatform::ContentGatewayApi::RecordUpdate
  • m_updateRequestId : Activ::ContentPlatform::ContentGatewayApi::SubscribeTableParameters
  • m_upTimeSeconds : Activ::ISystem::SystemInfo
  • m_url
: Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::ConnectParameters
, Activ::ServiceHandle
, Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::ConnectParameters
  • m_usagePercentage : Activ::SystemMonitor::Stats::DiskInfo
  • m_userId : Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::ConnectParameters , Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::ConnectParameters
  • m_username : Activ::IFtpHelper
  • m_userType : Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::ConnectParameters , Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::ConnectParameters
  • m_utcStartupDateTime : Activ::ISystem::SystemInfo
  • m_validPart : Activ::IniFileParser::ParseException
  • m_value
: Activ::Time::Seconds
, Activ::Date::Days
, Activ::Time::Hours
, Activ::Time::Minutes
, Activ::Time::Milliseconds
  • m_version
: Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::ApiInfo
, Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::ApiInfo
, Activ::ContentPlatform::ContentServerApi::ContentServerClient::ApiInfo
, Activ::IProcess::Stats
, Activ::ContentPlatform::ContentGatewayApi::ContentGatewayInfo
, Activ::ContentPlatform::Feed::TableTemplateList::TableTemplateSpecification
, Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::ApiInfo
  • m_virtualMemorySize : Activ::SystemMonitor::Stats::ProcessInfo
  • m_volumeFields : Activ::ContentPlatform::Feed::Rule
  • m_windowsDpcProcessorAffinityMask : Activ::SystemInfo
  • m_workingSetSize : Activ::SystemMonitor::Stats::ProcessInfo
  • MakeAbsolutePath() : Activ::File
  • MakePath() : Activ::File
  • ManagedEndPoint() : Activ::ManagedEndPoint
  • MandatoryParameterDescription() : Activ::CommandLineParserDetail::MandatoryParameterDescription< T >
  • MandatorySwitchDescription() : Activ::CommandLineParserDetail::MandatorySwitchDescription< T >
  • MAPPING_FLAG_READ_ONLY : Activ::IMappedMemory
  • MAPPING_FLAG_UNIQUE : Activ::IMappedMemory
  • MatchType : Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryRequestParameters , Activ::ContentPlatform::ContentGatewayApi::MatchRequestParameters
  • MAX_INDEX_NAME_LENGTH : Activ::ContentPlatform::Feed::TableTemplateMessageHeaderDefinitions
  • MAX_LENGTH : Activ::Subject
  • MAX_NAME_LENGTH : Activ::ContentPlatform::Feed::TableTemplateMessageHeaderDefinitions
  • MAX_NUMERATOR : Activ::Rational
  • MAX_PRINTABLE_ASCII : Activ::MessageHandler
  • MAX_SERIALIZED_BODY_LENGTH_UNDEFINED : Activ::IFieldType
  • MAX_SYMBOL_LENGTH
: Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions
, Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderDefinitions
, Activ::ContentPlatform::Feed::CompressedMessageHeaderDefinitions
, Activ::ContentPlatform::Feed::CombinedQuoteMessageHeaderDefinitions
  • MEMORY_MODEL_PRIVATE : Activ::ISystem::Settings
  • MEMORY_MODEL_SHARED : Activ::ISystem::Settings
  • MemoryModel : Activ::ISystem::Settings
  • Menu() : Activ::UiMainComponent::Menu
  • MESSAGE_HEADER_FLAGS_COMPOSITE_LENGTH
: Activ::ContentPlatform::Feed::CompressedMessageHeaderDefinitions
, Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions
, Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderDefinitions
  • MESSAGE_HEADER_FLAGS_COMPOSITE_OFFSET
: Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderDefinitions
, Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions
, Activ::ContentPlatform::Feed::CompressedMessageHeaderDefinitions
  • MESSAGE_HEADER_FLAGS_COMPRESSED_SYMBOL_LENGTH : Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderDefinitions
  • MESSAGE_HEADER_FLAGS_COMPRESSED_SYMBOL_OFFSET : Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderDefinitions
  • MESSAGE_HEADER_FLAGS_DELETE_LENGTH
: Activ::ContentPlatform::Feed::RecordMessageHeaderDefinitions
, Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions
, Activ::ContentPlatform::Feed::CompressedMessageHeaderDefinitions
  • MESSAGE_HEADER_FLAGS_DELETE_OFFSET
: Activ::ContentPlatform::Feed::CompressedMessageHeaderDefinitions
, Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions
, Activ::ContentPlatform::Feed::RecordMessageHeaderDefinitions
  • MESSAGE_HEADER_FLAGS_REFRESH_LENGTH : Activ::ContentPlatform::Feed::RecordMessageHeaderDefinitions
  • MESSAGE_HEADER_FLAGS_REFRESH_OFFSET : Activ::ContentPlatform::Feed::RecordMessageHeaderDefinitions
  • MESSAGE_HEADER_FLAGS_RESERVED_LENGTH : Activ::ContentPlatform::Feed::TableTemplateMessageHeaderDefinitions
  • MESSAGE_HEADER_FLAGS_RESERVED_OFFSET : Activ::ContentPlatform::Feed::TableTemplateMessageHeaderDefinitions
  • MESSAGE_HEADER_FLAGS_US_EQUITY_OPTION_LENGTH : Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderDefinitions
  • MESSAGE_HEADER_FLAGS_US_EQUITY_OPTION_OFFSET : Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderDefinitions
  • MESSAGE_TYPE
: Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions
, Activ::ContentPlatform::Feed::TableTemplateMessageHeaderDefinitions
, Activ::ContentPlatform::Feed::RecordMessageHeaderDefinitions
, Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderDefinitions
, Activ::ContentPlatform::Feed::CombinedQuoteMessageHeaderDefinitions
, Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestHelper< MESSAGE_TYPE_VALUE, REQUEST_PARAMETERS >
, Activ::DirectoryWatchApi
  • MESSAGE_TYPE_LENGTH : Activ::ContentPlatform::Feed::MessageHeaderDefinitions
  • MESSAGE_TYPE_OFFSET : Activ::ContentPlatform::Feed::MessageHeaderDefinitions
  • MESSAGE_VERSION_UNDEFINED : Activ::MessageHandler
  • MessageBuilder() : Activ::MessageBuilder
  • MessageHandler() : Activ::MessageHandler
  • MessageHeader : Activ::ContentPlatform::Feed::MessageHeaderDefinitions
  • MessageModelToString() : Activ::RequestId
  • MessageRateThrottler() : Activ::MessageRateThrottler
  • MessageStats() : Activ::ContentPlatform::ContentServerApi::ContentServerClient::MessageStats
  • MessageValidator() : Activ::MessageValidator
  • MessageVersion : Activ::MessageHandler
  • Milliseconds : Activ::DateTime , Activ::Time::Milliseconds
  • MIN_NUMERATOR : Activ::Rational
  • MIN_PRINTABLE_ASCII : Activ::MessageHandler
  • Minutes : Activ::DateTime , Activ::Time::Minutes
  • MONTHS_PER_YEAR : Activ::Date
  • MonthToString()
: Activ::BaseTime
, Activ::Date
  • Multiply()
: Activ::UInt
, Activ::SInt
, Activ::Rational
Generated on Wed Oct 8 14:01:54 2008 for ACTIV C++ SDK by doxygen 1.5.4


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- n -

  • NamePrefixToString()
: Activ::ContentPlatform::Feed::RecordFieldListValidator
, Activ::ContentPlatform::Feed::RecordKeyFieldListValidator
  • NewsRequestParameters() : Activ::ContentPlatform::ContentGatewayApi::NewsRequestParameters
  • NewsResponseParameters() : Activ::ContentPlatform::ContentGatewayApi::NewsResponseParameters
  • NotificationType : Activ::IEndPoint
  • NotificationTypeToString() : Activ::IEndPoint
  • Number : Activ::Database::IndexSpecification
  • NUMBER_OF_RULE_SETS : Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions
  • NUMBER_PER_DAY
: Activ::Time::Hours
, Activ::Time::Minutes
, Activ::Time::Seconds
, Activ::Time::Milliseconds
  • NUMBER_PER_HOUR
: Activ::Time::Milliseconds
, Activ::Time::Minutes
, Activ::Time::Seconds
  • NUMBER_PER_MINUTE : Activ::Time::Seconds , Activ::Time::Milliseconds
  • NUMBER_PER_SECOND : Activ::Time::Milliseconds
  • NUMERATOR_LENGTH_16_BITS : Activ::ContentPlatform::Feed::CompressedMessageDefinitions
  • NUMERATOR_LENGTH_32_BITS : Activ::ContentPlatform::Feed::CompressedMessageDefinitions
  • NUMERATOR_LENGTH_64_BITS : Activ::ContentPlatform::Feed::CompressedMessageDefinitions
  • NUMERATOR_LENGTH_8_BITS : Activ::ContentPlatform::Feed::CompressedMessageDefinitions
Generated on Wed Oct 8 14:01:54 2008 for ACTIV C++ SDK by doxygen 1.5.4


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- o -

  • ObjectType : Activ::SerializableSmartPointerHelper< POINTER_TYPE >
  • OnAccept()
: Activ::Component
, Activ::TcpSocket
, Activ::Service
  • OnAcceptAborted() : Activ::TcpSocket
  • OnAcceptFailed() : Activ::TcpSocket
  • OnBreak()
: Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient
, Activ::Component
, Activ::TcpSocket
, Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
  • OnCleanupIo() : Activ::IpSocket
  • OnConnect()
: Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
, Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient
, Activ::Component
, Activ::TcpSocket
  • OnConnectAborted() : Activ::TcpSocket
  • OnConnectFailed()
: Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
, Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient
, Activ::Component
, Activ::TcpSocket
  • OnContentGatewayInfoUpdate() : Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
  • OnCtrlEvent()
: Activ::AgentApplication
, Activ::Application
  • OnData() : Activ::Component
  • OnDirectory()
: Activ::DirectoryRemover
, Activ::DirectoryWalker
  • OnDisconnect()
: Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
, Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient
, Activ::Component
, Activ::TcpSocket
  • OnError() : Activ::UdpSocket
  • OnEvent() : Activ::CtrlHandler
  • OnFile()
: Activ::DirectoryRemover
, Activ::DirectoryWalker
  • OnFlush() : Activ::ContentPlatform::ContentServerApi::ContentServerClient
  • OnGetEqualResponse()
: Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
, Activ::ContentPlatform::ContentGatewayApi::IRealtimeResponses
  • OnGetFirstHistoryResponse()
: Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
, Activ::ContentPlatform::ContentGatewayApi::ITimeSeriesResponses
  • OnGetFirstIntradayResponse()
: Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
, Activ::ContentPlatform::ContentGatewayApi::ITimeSeriesResponses
  • OnGetFirstResponse()
: Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
, Activ::ContentPlatform::ContentGatewayApi::IRealtimeResponses
  • OnGetFirstTicksResponse()
: Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
, Activ::ContentPlatform::ContentGatewayApi::ITimeSeriesResponses
  • OnGetLastResponse()
: Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
, Activ::ContentPlatform::ContentGatewayApi::IRealtimeResponses
  • OnGetMatchResponse()
: Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
, Activ::ContentPlatform::ContentGatewayApi::IRealtimeResponses
  • OnGetMultipleEqualResponse()
: Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
, Activ::ContentPlatform::ContentGatewayApi::IRealtimeResponses
  • OnGetMultipleMatchResponse()
: Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
, Activ::ContentPlatform::ContentGatewayApi::IRealtimeResponses
  • OnGetMultiplePatternMatchListResponse()
: Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
, Activ::ContentPlatform::ContentGatewayApi::IRealtimeResponses
  • OnGetMultiplePatternMatchResponse()
: Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
, Activ::ContentPlatform::ContentGatewayApi::IRealtimeResponses
  • OnGetNewsStoriesResponse()
: Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
, Activ::ContentPlatform::ContentGatewayApi::INewsResponses
  • OnGetNextHistoryResponse()
: Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
, Activ::ContentPlatform::ContentGatewayApi::ITimeSeriesResponses
  • OnGetNextIntradayResponse()
: Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
, Activ::ContentPlatform::ContentGatewayApi::ITimeSeriesResponses
  • OnGetNextResponse()
: Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
, Activ::ContentPlatform::ContentGatewayApi::IRealtimeResponses
  • OnGetNextTicksResponse()
: Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
, Activ::ContentPlatform::ContentGatewayApi::ITimeSeriesResponses
  • OnGetPreviousResponse()
: Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
, Activ::ContentPlatform::ContentGatewayApi::IRealtimeResponses
  • OnGetRxBuffers() : Activ::IpSocket
  • OnGetSymbolsResponse()
: Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
, Activ::ContentPlatform::ContentGatewayApi::ISymbolDirectoryResponses
  • OnGetTxBuffers() : Activ::IpSocket
  • OnInitializeIo() : Activ::IpSocket
  • OnInputString() : Activ::Shell
  • OnIoCompletion() : Activ::IoCompletionManager::Overlapped
  • OnMessage()
: Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
, Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient
, Activ::AgentApplication
, Activ::Application
, Activ::Component
, Activ::ThinApplication
, Activ::UdpComponent
, Activ::Port
  • OnNewsUpdate()
: Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
, Activ::ContentPlatform::ContentGatewayApi::INewsResponses
  • OnObject()
: Activ::ISystem::IProcessEnumerator
, Activ::ISystem::IEndPointEnumerator
, Activ::ISystem::IHeapEnumerator
  • OnOption() : Activ::UiMainComponent
  • OnOutputString() : Activ::Shell
  • OnPopulateCompletionList() : Activ::UiIo::DynamicCompletionHelper
  • OnRecordUpdate()
: Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
, Activ::ContentPlatform::ContentGatewayApi::IRealtimeResponses
, Activ::ContentPlatform::ContentServerApi::ContentServerClient
  • OnReportMessage()
: Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
, Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient
  • OnRequest()
: Activ::Component
, Activ::Port
  • OnResponse()
: Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
, Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient
, Activ::Port
  • OnRxBuffers()
: Activ::IpSocket
, Activ::TcpSocket
, Activ::UdpSocket
  • OnSetSocketOptions() : Activ::IpSocket
  • OnShutdown()
: Activ::Application
, Activ::UdpSocket
  • OnSocketClose() : Activ::UdpComponent
  • OnSocketError() : Activ::UdpComponent
  • OnSymbolRecordUpdate() : Activ::ContentPlatform::ContentServerApi::ContentServerClient
  • OnThreadExit()
: Activ::ThreadSpecificDataBase< TYPE, DERIVED >
, Activ::ThreadSpecificData< TYPE, CLEANUP >
  • OnTimer()
: Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
, Activ::ContentPlatform::ContentServerApi::ContentServerClient
, Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient
, Activ::Component
  • OnTxBuffers()
: Activ::IpSocket
, Activ::TcpSocket
, Activ::UdpSocket
  • Open()
: Activ::SharedCompletionPortEventFactory
, Activ::SystemFactory
, Activ::File
, Activ::FileMappedMemoryFactory
, Activ::PagingFileMappedMemoryFactory
, Activ::SharedEventFactory
, Activ::SharedMutexFactory
, Activ::SharedObject< T >
, Activ::SharedSemaphoreFactory
  • OpenEndPoint()
: Activ::SystemProxy
, Activ::ISystem
  • OpenFields() : Activ::ContentPlatform::Feed::Rule::OpenFields
  • OpenHeap()
: Activ::SystemProxy
, Activ::ISystem
  • OpenLogFile() : Activ::LoggerServiceApi
  • OpenProcess()
: Activ::SystemProxy
, Activ::ISystem
  • OpenRecordFile() : Activ::Database::ITable
  • OpenService() : Activ::ServiceApi
  • OpenServiceRequest() : Activ::OpenServiceRequest
  • OpenServiceResponse() : Activ::OpenServiceResponse
  • operator *()
: Activ::ContentPlatform::Feed::TableTemplate::ConstFieldIterator
, Activ::ContentPlatform::Feed::TableTemplate::ConstIndexIterator
, Activ::ContentPlatform::Feed::TableTemplate::ConstRuleIterator
, Activ::ContentPlatform::Feed::TableTemplate::ConstCopyOnResetIterator
, Activ::ContentPlatform::Feed::TableTemplate::ConstUndefineOnResetIterator
, Activ::ContentPlatform::Feed::TableTemplateList::ConstIterator
, Activ::ContentPlatform::Feed::UniversalFieldList::ConstIterator
, Activ::ScatterBufferHelper::ConstIterator
, Activ::HeapMessage::Iterator
  • operator *=()
: Activ::Rational
, Activ::SInt
, Activ::UInt
  • operator Address &() : Activ::Address::Proxy
  • operator bool()
: Activ::ScopedMutexTryLocker
, Activ::DeferredScopedMutexLocker
, Activ::HeapMessage
  • operator const Address &() : Activ::ScopedAddress
  • operator const Date &() : Activ::DateTime
  • operator const Rational()
: Activ::SInt
, Activ::UInt
  • operator const Rational &() : Activ::TRational
  • operator const SInt() : Activ::UInt
  • operator const Time &() : Activ::DateTime
  • operator HANDLE() : Activ::SocketWrapper
  • operator Pointer() : Activ::AtomicPointer< T >
  • operator Proxy()
: Activ::HeapMessage
, Activ::ScopedAddress
  • operator SOCKET() : Activ::SocketWrapper
  • operator std::string() : Activ::UiIo::Attribute
  • operator T() : Activ::ScopedHelper< T, D >
  • operator Type() : Activ::AtomicInteger
  • operator!()
: Activ::ScopedMutexTryLocker
, Activ::DeferredScopedMutexLocker
, Activ::HeapMessage
  • operator!=()
: Activ::ContentPlatform::ContentGatewayApi::HistoryBar
, Activ::ContentPlatform::ContentGatewayApi::IntradayBar
, Activ::ContentPlatform::ContentGatewayApi::OptionBar
, Activ::ContentPlatform::ContentGatewayApi::Tick
, Activ::ContentPlatform::ContentGatewayApi::SymbolId
, Activ::ContentPlatform::FeedApi::FieldListValidator::ConstIterator
, Activ::ContentPlatform::Feed::RecordFieldListValidator::ConstIterator
, Activ::ContentPlatform::Feed::RecordKeyFieldListValidator::ConstIterator
, Activ::ContentPlatform::Feed::SymbolRecordFieldListValidator::ConstIterator
, Activ::ContentPlatform::Feed::TableTemplateFieldListValidator::ConstIterator
, Activ::ContentPlatform::Feed::Field
, Activ::ContentPlatform::Feed::CopyOnReset
, Activ::ContentPlatform::Feed::Rule::CopyToFields
, Activ::ContentPlatform::Feed::Rule::HighFields
, Activ::ContentPlatform::Feed::Rule::LowFields
, Activ::ContentPlatform::Feed::Rule::OpenFields
, Activ::ContentPlatform::Feed::Rule::CloseFields
, Activ::ContentPlatform::Feed::Rule::PriceFields
, Activ::ContentPlatform::Feed::Rule::VolumeFields
, Activ::ContentPlatform::Feed::Rule
, Activ::ContentPlatform::Feed::TableTemplate::ConstFieldIterator
, Activ::ContentPlatform::Feed::TableTemplate::ConstIndexIterator
, Activ::ContentPlatform::Feed::TableTemplate::ConstRuleIterator
, Activ::ContentPlatform::Feed::TableTemplate::ConstCopyOnResetIterator
, Activ::ContentPlatform::Feed::TableTemplate::ConstUndefineOnResetIterator
, Activ::ContentPlatform::Feed::TableTemplate
, Activ::ContentPlatform::Feed::TableTemplateList::ConstIterator
, Activ::ContentPlatform::Feed::UniversalFieldList::ConstIterator
, Activ::ConsoleWindow::Coord
, Activ::IniFileParser::ConstKeyIterator
, Activ::IniFileParser::ConstSectionIterator
, Activ::ScatterBufferHelper::ConstIterator
, Activ::Uuid
, Activ::Database::Database::ConstIterator
, Activ::Database::Database::Iterator
, Activ::Database::FieldList::ConstIterator
, Activ::Database::FieldSpecification
, Activ::Database::IndexSpecification::Field
, Activ::Database::IndexSpecification
, Activ::Database::Key
, Activ::Database::Record
, Activ::Database::TableSpecification
, Activ::Date
, Activ::DateTime
, Activ::Rational
, Activ::SInt
, Activ::Time
, Activ::UInt
, Activ::ServiceId
, Activ::Timeband
, Activ::BaseTime
, Activ::IpAddress
, Activ::Address
, Activ::HeapMessage::Iterator
, Activ::HeapMessage
, Activ::RequestId
, Activ::ScopedAddress
, Activ::Subject
, Activ::FileInfo
, Activ::StatusCodeHelper
  • operator()()
: Activ::CommandLineParserDetail::DescriptionAppender
, Activ::MessageBuilderVariableLengthRangeCheck< true >
, Activ::MessageBuilderVariableLengthRangeCheck< false >
, Activ::Timeout
, Activ::HeapMessageDeserializer< MESSAGE_TYPE, BUFFER_SIZE >
, Activ::ManagedEndPoint::RunHelper
, Activ::DeleteObject
, Activ::DeleteObjectArray
, Activ::DeleteAssociativeObject
, Activ::LessThanPairComparisonObject< Pair >
, Activ::EqualToPairComparisonObject< Pair >
, Activ::CaseInsensitiveLessThanStringComparisonObject
, Activ::ScopedPooledObject< T >
, Activ::StringHashCompare< TRAITS >
, Activ::SelectFirst< P >
, Activ::SelectSecond< P >
, Activ::SelectFirstFromSecond< P >
, Activ::CommandLineParserDetail::ValueStore< T >
, Activ::CommandLineParserDetail::DescriptionAppender
  • operator+()
: Activ::MessageBuilder
, Activ::Date
, Activ::DateTime
, Activ::Time
  • operator++()
: Activ::ContentPlatform::FeedApi::FieldListValidator::ConstIterator
, Activ::ContentPlatform::Feed::TableTemplate::ConstIndexIterator
, Activ::ContentPlatform::Feed::RecordKeyFieldListValidator::ConstIterator
, Activ::ContentPlatform::FeedApi::FieldListValidator::ConstIterator
, Activ::ContentPlatform::Feed::RecordFieldListValidator::ConstIterator
, Activ::ContentPlatform::Feed::RecordKeyFieldListValidator::ConstIterator
, Activ::ContentPlatform::Feed::SymbolRecordFieldListValidator::ConstIterator
, Activ::ContentPlatform::Feed::TableTemplateFieldListValidator::ConstIterator
, Activ::ContentPlatform::Feed::TableTemplate::ConstFieldIterator
, Activ::ContentPlatform::Feed::TableTemplate::ConstIndexIterator
, Activ::ContentPlatform::Feed::TableTemplate::ConstRuleIterator
, Activ::ContentPlatform::Feed::TableTemplate::ConstCopyOnResetIterator
, Activ::ContentPlatform::Feed::TableTemplate::ConstUndefineOnResetIterator
, Activ::ContentPlatform::Feed::TableTemplateList::ConstIterator
, Activ::ContentPlatform::Feed::UniversalFieldList::ConstIterator
, Activ::AtomicInteger
, Activ::IniFileParser::ConstKeyIterator
, Activ::IniFileParser::ConstSectionIterator
, Activ::ScatterBufferHelper::ConstIterator
, Activ::Database::Database::ConstIterator
, Activ::Database::Database::Iterator
, Activ::Database::FieldList::ConstIterator
, Activ::HeapMessage::Iterator
, Activ::ReferenceCounter
, Activ::HeapMessage::Iterator
, Activ::Database::Database::Iterator
, Activ::ScatterBufferHelper::ConstIterator
, Activ::ContentPlatform::Feed::TableTemplateList::ConstIterator
, Activ::ContentPlatform::Feed::TableTemplate::ConstCopyOnResetIterator
  • operator+=()
: Activ::MessageBuilder
, Activ::Date
, Activ::DateTime
, Activ::Rational
, Activ::SInt
, Activ::UInt
, Activ::BaseTime
, Activ::Time
  • operator-()
: Activ::DateTime
, Activ::Time
, Activ::Date
  • operator--()
: Activ::AtomicInteger
, Activ::ReferenceCounter
, Activ::AtomicInteger
  • operator-=()
: Activ::Date
, Activ::DateTime
, Activ::Rational
, Activ::SInt
, Activ::Time
, Activ::UInt
, Activ::BaseTime
  • operator->()
: Activ::ContentPlatform::Feed::UniversalFieldList::ConstIterator
, Activ::ContentPlatform::Feed::TableTemplate::ConstFieldIterator
, Activ::ContentPlatform::Feed::TableTemplate::ConstIndexIterator
, Activ::ContentPlatform::Feed::TableTemplate::ConstCopyOnResetIterator
, Activ::ContentPlatform::Feed::TableTemplate::ConstUndefineOnResetIterator
, Activ::ContentPlatform::Feed::TableTemplateList::ConstIterator
, Activ::AtomicPointer< T >
, Activ::ScatterBufferHelper::ConstIterator
, Activ::HeapMessage::Iterator
, Activ::ContentPlatform::Feed::TableTemplate::ConstRuleIterator
  • operator/=()
: Activ::Rational
, Activ::SInt
, Activ::UInt
  • operator<()
: Activ::Date
, Activ::ContentPlatform::ContentGatewayApi::SymbolId
, Activ::Address
, Activ::ContentPlatform::ContentGatewayApi::OptionBar
, Activ::ContentPlatform::ContentGatewayApi::IntradayBar
, Activ::UInt
, Activ::DateTime
, Activ::ContentPlatform::ContentGatewayApi::IntradayBar
, Activ::Database::FieldSpecification
, Activ::ContentPlatform::ContentGatewayApi::HistoryBar
, Activ::ContentPlatform::ContentGatewayApi::Tick
, Activ::Uuid
, Activ::ContentPlatform::ContentGatewayApi::Tick
, Activ::ContentPlatform::ContentGatewayApi::HistoryBar
, Activ::Database::IndexSpecification
, Activ::Database::Key
, Activ::Rational
, Activ::ServiceId
, Activ::IpAddress
, Activ::RequestId
, Activ::SInt
, Activ::Time
, Activ::BaseTime
, Activ::Subject
  • operator<=()
: Activ::Subject
, Activ::SInt
, Activ::Database::Key
, Activ::DateTime
, Activ::ContentPlatform::ContentGatewayApi::IntradayBar
, Activ::Rational
, Activ::ContentPlatform::ContentGatewayApi::OptionBar
, Activ::ContentPlatform::ContentGatewayApi::Tick
, Activ::Uuid
, Activ::Date
, Activ::Time
, Activ::BaseTime
, Activ::ContentPlatform::ContentGatewayApi::HistoryBar
, Activ::UInt
  • operator=()
: Activ::SocketWrapper
, Activ::Blob
, Activ::CrcBlob
, Activ::TextArray
, Activ::Timeband
, Activ::BinaryArray
, Activ::MessageBuilder
, Activ::BaseTime
, Activ::Database::Record
, Activ::HeapMessage::ReadHelper
, Activ::ContentPlatform::FeedApi::FieldListValidator
, Activ::ScatterBufferHelper
, Activ::Database::Key
, Activ::BinaryString
, Activ::TextString
, Activ::SocketWrapper
, Activ::RequestId
, Activ::ScopedAddress
, Activ::SerializableBuffer< LENGTH_TYPE, MIN_LENGTH, MAX_LENGTH >
, Activ::HeapMessage
, Activ::ContentPlatform::Feed::Field
, Activ::SyncRequestId
, Activ::AtomicPointer< T >
  • operator==()
: Activ::Database::Key
, Activ::ContentPlatform::Feed::TableTemplate::ConstIndexIterator
, Activ::Address
, Activ::ContentPlatform::ContentGatewayApi::Tick
, Activ::Date
, Activ::ContentPlatform::ContentGatewayApi::Tick
, Activ::Database::Database::Iterator
, Activ::IniFileParser::ConstSectionIterator
, Activ::ContentPlatform::Feed::Rule::CloseFields
, Activ::UInt
, Activ::ContentPlatform::FeedApi::FieldListValidator::ConstIterator
, Activ::ScatterBufferHelper::ConstIterator
, Activ::ContentPlatform::Feed::Field
, Activ::ContentPlatform::Feed::RecordFieldListValidator::ConstIterator
, Activ::Rational
, Activ::ContentPlatform::Feed::Rule::VolumeFields
, Activ::ServiceId
, Activ::Timeband
, Activ::IpAddress
, Activ::ContentPlatform::Feed::Rule
, Activ::ContentPlatform::Feed::Rule::PriceFields
, Activ::ContentPlatform::Feed::TableTemplate::ConstFieldIterator
, Activ::FileInfo
, Activ::RequestId
, Activ::HeapMessage
, Activ::Database::IndexSpecification
, Activ::ContentPlatform::ContentGatewayApi::Period
, Activ::ContentPlatform::Feed::Rule::LowFields
, Activ::Database::FieldSpecification
, Activ::ContentPlatform::Feed::TableTemplate::ConstUndefineOnResetIterator
, Activ::ContentPlatform::Feed::TableTemplateList::ConstIterator
, Activ::ContentPlatform::Feed::Rule::HighFields
, Activ::ContentPlatform::Feed::CopyOnReset
, Activ::ContentPlatform::Feed::Rule::OpenFields
, Activ::ContentPlatform::Feed::UniversalFieldList::ConstIterator
, Activ::Database::Database::ConstIterator
, Activ::ContentPlatform::ContentGatewayApi::IntradayBar
, Activ::Uuid
, Activ::ConsoleWindow::Coord
, Activ::IniFileParser::ConstKeyIterator
, Activ::Database::FieldList::ConstIterator
, Activ::ContentPlatform::Feed::RecordKeyFieldListValidator::ConstIterator
, Activ::HeapMessage::Iterator
, Activ::ContentPlatform::Feed::TableTemplate::ConstCopyOnResetIterator
, Activ::BaseTime
, Activ::ContentPlatform::Feed::TableTemplateFieldListValidator::ConstIterator
, Activ::Database::IndexSpecification::Field
, Activ::ContentPlatform::ContentGatewayApi::DataPointAddress
, Activ::ContentPlatform::ContentGatewayApi::OptionBar
, Activ::ContentPlatform::Feed::SymbolRecordFieldListValidator::ConstIterator
, Activ::ContentPlatform::Feed::TableTemplate
, Activ::ContentPlatform::ContentGatewayApi::HistoryBar
, Activ::ContentPlatform::ContentGatewayApi::SymbolId
, Activ::Database::TableSpecification
, Activ::Database::Record
, Activ::StatusCodeHelper
, Activ::DateTime
, Activ::Time
, Activ::Subject
, Activ::ContentPlatform::Feed::Rule::CopyToFields
, Activ::ContentPlatform::Feed::TableTemplate::ConstRuleIterator
, Activ::ContentPlatform::ContentGatewayApi::HistoryBar
, Activ::SInt
, Activ::ContentPlatform::ContentGatewayApi::IntradayBar
, Activ::ScopedAddress
  • operator>()
: Activ::Rational
, Activ::ContentPlatform::ContentGatewayApi::IntradayBar
, Activ::ContentPlatform::ContentGatewayApi::Tick
, Activ::ContentPlatform::ContentGatewayApi::OptionBar
, Activ::ContentPlatform::ContentGatewayApi::HistoryBar
, Activ::Uuid
, Activ::Date
, Activ::ContentPlatform::ContentGatewayApi::IntradayBar
, Activ::Time
, Activ::Subject
, Activ::UInt
, Activ::Database::Key
, Activ::SInt
, Activ::BaseTime
, Activ::DateTime
, Activ::ContentPlatform::ContentGatewayApi::HistoryBar
  • operator>=()
: Activ::SInt
, Activ::Database::Key
, Activ::BaseTime
, Activ::Uuid
, Activ::ContentPlatform::ContentGatewayApi::Tick
, Activ::Subject
, Activ::Date
, Activ::ContentPlatform::ContentGatewayApi::HistoryBar
, Activ::Rational
, Activ::ContentPlatform::ContentGatewayApi::IntradayBar
, Activ::UInt
, Activ::ContentPlatform::ContentGatewayApi::Tick
, Activ::ContentPlatform::ContentGatewayApi::OptionBar
, Activ::Time
, Activ::DateTime
  • operator|() : Activ::UiIo::Attribute
  • OPTIONAL_DATA_HAS_BUYER_ID : Activ::ContentPlatform::ContentGatewayApi::Tick
  • OPTIONAL_DATA_HAS_OTHER_LENGTH : Activ::ContentPlatform::ContentGatewayApi::Tick
  • OPTIONAL_DATA_HAS_SELLER_ID : Activ::ContentPlatform::ContentGatewayApi::Tick
  • OPTIONAL_DATA_HAS_TRADE_EXEPTION_FLAG : Activ::ContentPlatform::ContentGatewayApi::Tick
  • OptionalParameterDescription() : Activ::CommandLineParserDetail::OptionalParameterDescription< T >
  • OptionalSwitchDescription() : Activ::CommandLineParserDetail::OptionalSwitchDescription< T >
  • OptionAttributes() : Activ::UiMenu::OptionAttributes
  • OptionBar() : Activ::ContentPlatform::ContentGatewayApi::OptionBar
  • OsException() : Activ::OsException
  • Overlapped() : Activ::IoCompletionManager::Overlapped
  • Overwrite()
: Activ::MessageBuilder
, Activ::HeapMessage
, Activ::MessageBuilder
  • OverwriteBoolean() : Activ::MessageBuilder
  • OverwriteInEndian() : Activ::MessageBuilder
Generated on Wed Oct 8 14:01:54 2008 for ACTIV C++ SDK by doxygen 1.5.4


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- ~ -

  • ~AgentApplication() : Activ::AgentApplication
  • ~Application() : Activ::Application
  • ~BaseTime() : Activ::BaseTime
  • ~BinaryArray() : Activ::BinaryArray
  • ~BinaryString() : Activ::BinaryString
  • ~Blob() : Activ::Blob
  • ~CommandLineParser() : Activ::CommandLineParser
  • ~CompletionHelper() : Activ::UiIo::CompletionHelper
  • ~Component() : Activ::Component
  • ~CompressedCombinedQuoteMessageHeaderValidator() : Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator
  • ~CompressedMessageHeaderValidator() : Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator
  • ~ConsoleWindow() : Activ::ConsoleWindow
  • ~ContentGatewayClient() : Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
  • ~ContentServerClient() : Activ::ContentPlatform::ContentServerApi::ContentServerClient
  • ~ContributionGatewayClient() : Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient
  • ~ContributionServerClient() : Activ::ContentPlatform::ContributionServerApi::ContributionServerClient
  • ~CrcBlob() : Activ::CrcBlob
  • ~CtrlHandler() : Activ::CtrlHandler
  • ~CurlInitializeHelper() : Activ::CurlFtpHelper::CurlInitializeHelper
  • ~Database() : Activ::Database::Database
  • ~Date() : Activ::Date
  • ~DateTime() : Activ::DateTime
  • ~DeferredScopedMutexLocker() : Activ::DeferredScopedMutexLocker
  • ~DirectoryRemover() : Activ::DirectoryRemover
  • ~DirectoryWalker() : Activ::DirectoryWalker
  • ~DynamicLibraryLoader() : Activ::DynamicLibraryLoader< T >
  • ~Enabler() : Activ::Port::Enabler
  • ~Exception() : Activ::Exception
  • ~Fiber() : Activ::Fiber
  • ~Field() : Activ::ContentPlatform::Feed::Field
  • ~FieldList() : Activ::Database::FieldList
  • ~FieldListObject() : Activ::Database::FieldListObject
  • ~FieldListValidator() : Activ::ContentPlatform::FeedApi::FieldListValidator
  • ~FieldSet() : Activ::ContentPlatform::ContentGatewayApi::FieldSet
  • ~File() : Activ::File
  • ~FtpHelper() : Activ::FtpHelper
  • ~HeapMessage() : Activ::HeapMessage
  • ~HistoryBar() : Activ::ContentPlatform::ContentGatewayApi::HistoryBar
  • ~IEndPoint() : Activ::IEndPoint
  • ~IEndPointEnumerator() : Activ::ISystem::IEndPointEnumerator
  • ~IEvent() : Activ::IEvent
  • ~IFieldType() : Activ::IFieldType
  • ~IFileMappedMemory() : Activ::IFileMappedMemory
  • ~IFtpHelper() : Activ::IFtpHelper
  • ~IHeap() : Activ::IHeap
  • ~IHeapEnumerator() : Activ::ISystem::IHeapEnumerator
  • ~IIndex() : Activ::Database::IIndex
  • ~IMappedMemory() : Activ::IMappedMemory
  • ~IMutex() : Activ::IMutex
  • ~INewsResponses() : Activ::ContentPlatform::ContentGatewayApi::INewsResponses
  • ~IniFileParser() : Activ::IniFileParser
  • ~IntradayBar() : Activ::ContentPlatform::ContentGatewayApi::IntradayBar
  • ~IoCompletionManager() : Activ::IoCompletionManager
  • ~IpManager() : Activ::IpManager
  • ~IProcess() : Activ::IProcess
  • ~IProcessEnumerator() : Activ::ISystem::IProcessEnumerator
  • ~IpSocket() : Activ::IpSocket
  • ~IRealtimeResponses() : Activ::ContentPlatform::ContentGatewayApi::IRealtimeResponses
  • ~ISemaphore() : Activ::ISemaphore
  • ~ISerializableMessage() : Activ::ISerializableMessage
  • ~ISymbolDirectoryResponses() : Activ::ContentPlatform::ContentGatewayApi::ISymbolDirectoryResponses
  • ~ISystem() : Activ::ISystem
  • ~ITable() : Activ::Database::ITable
  • ~ITimeSeriesResponses() : Activ::ContentPlatform::ContentGatewayApi::ITimeSeriesResponses
  • ~Key() : Activ::Database::Key
  • ~ManagedEndPoint() : Activ::ManagedEndPoint
  • ~MessageBuilder() : Activ::MessageBuilder
  • ~MessageHandler() : Activ::MessageHandler
  • ~MessageRateThrottler() : Activ::MessageRateThrottler
  • ~OptionBar() : Activ::ContentPlatform::ContentGatewayApi::OptionBar
  • ~Port() : Activ::Port
  • ~PostMessageHelper() : Activ::PostMessageHelper
  • ~Proxy() : Activ::ScopedAddress::Proxy
  • ~Rational() : Activ::Rational
  • ~ReadHelper() : Activ::HeapMessage::ReadHelper
  • ~Record() : Activ::Database::Record
  • ~RecordFieldListBuilder() : Activ::ContentPlatform::Feed::RecordFieldListBuilder
  • ~RecordFieldListValidator() : Activ::ContentPlatform::Feed::RecordFieldListValidator
  • ~RecordKeyFieldListBuilder() : Activ::ContentPlatform::Feed::RecordKeyFieldListBuilder
  • ~RecordKeyFieldListValidator() : Activ::ContentPlatform::Feed::RecordKeyFieldListValidator
  • ~RecordMessageBuilder()
: Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::RecordMessageBuilder
, Activ::ContentPlatform::Feed::RecordMessageBuilder
  • ~RecordMessageHeaderValidator() : Activ::ContentPlatform::Feed::RecordMessageHeaderValidator
  • ~RecordMessageValidator() : Activ::ContentPlatform::Feed::RecordMessageValidator
  • ~RegistryHelper() : Activ::RegistryHelper
  • ~RunHelper() : Activ::ManagedEndPoint::RunHelper
  • ~ScatterBufferHelper() : Activ::ScatterBufferHelper
  • ~Scoped() : Activ::IntervalTimer::Scoped
  • ~ScopedAddress() : Activ::ScopedAddress
  • ~ScopedHelper() : Activ::ScopedHelper< T, D >
  • ~ScopedMutexLocker() : Activ::ScopedMutexLocker
  • ~ScopedMutexTryLocker() : Activ::ScopedMutexTryLocker
  • ~ScopedPooledObject() : Activ::ScopedPooledObject< T >
  • ~ScopedSubscription() : Activ::ScopedSubscription
  • ~ScopedVersion() : Activ::MessageHandler::ScopedVersion
  • ~SerializableBuffer() : Activ::SerializableBuffer< LENGTH_TYPE, MIN_LENGTH, MAX_LENGTH >
  • ~Service() : Activ::Service
  • ~Settings()
: Activ::ContentPlatform::ContentServerApi::ContentServerClient::Settings
, Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::Settings
, Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::Settings
, Activ::AgentApplication::Settings
  • ~SharedObject() : Activ::SharedObject< T >
  • ~Shell() : Activ::Shell
  • ~SInt() : Activ::SInt
  • ~SmtpHelper() : Activ::SmtpHelper
  • ~SocketWrapper() : Activ::SocketWrapper
  • ~SymbolPatternHelper() : Activ::ContentPlatform::FeedApi::SymbolPatternHelper
  • ~SymbolRecordField() : Activ::ContentPlatform::Feed::SymbolRecordField
  • ~SymbolRecordFieldListBuilder() : Activ::ContentPlatform::Feed::SymbolRecordFieldListBuilder
  • ~SymbolRecordFieldListValidator() : Activ::ContentPlatform::Feed::SymbolRecordFieldListValidator
  • ~SymbolRecordMessageBuilder()
: Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::SymbolRecordMessageBuilder
, Activ::ContentPlatform::Feed::SymbolRecordMessageBuilder
  • ~SymbolRecordMessageHeaderValidator() : Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator
  • ~SymbolRecordMessageValidator() : Activ::ContentPlatform::Feed::SymbolRecordMessageValidator
  • ~SyncRequestId() : Activ::SyncRequestId
  • ~SystemMonitor() : Activ::SystemMonitor
  • ~SystemProxy() : Activ::SystemProxy
  • ~TableTemplate() : Activ::ContentPlatform::Feed::TableTemplate
  • ~TableTemplateField() : Activ::ContentPlatform::Feed::TableTemplateField
  • ~TableTemplateFieldListValidator() : Activ::ContentPlatform::Feed::TableTemplateFieldListValidator
  • ~TableTemplateIndex() : Activ::ContentPlatform::Feed::TableTemplateIndex
  • ~TableTemplateIndexListValidator() : Activ::ContentPlatform::Feed::TableTemplateIndexListValidator
  • ~TableTemplateList() : Activ::ContentPlatform::Feed::TableTemplateList
  • ~TableTemplateMessageValidator() : Activ::ContentPlatform::Feed::TableTemplateMessageValidator
  • ~TcpListener() : Activ::TcpListener
  • ~TcpSocket() : Activ::TcpSocket
  • ~TextArray() : Activ::TextArray
  • ~TextString() : Activ::TextString
  • ~ThinApplication() : Activ::ThinApplication
  • ~Thread() : Activ::Thread
  • ~ThreadSpecificDataBase() : Activ::ThreadSpecificDataBase< TYPE, DERIVED >
  • ~Tick() : Activ::ContentPlatform::ContentGatewayApi::Tick
  • ~Time() : Activ::Time
  • ~TRational() : Activ::TRational
  • ~UdpComponent() : Activ::UdpComponent
  • ~UdpSocket() : Activ::UdpSocket
  • ~UiComponent() : Activ::UiComponent
  • ~UiMainComponent() : Activ::UiMainComponent
  • ~UiMenu() : Activ::UiMenu
  • ~UInt() : Activ::UInt
  • ~UniversalFieldList() : Activ::ContentPlatform::Feed::UniversalFieldList
  • ~WsaBufHelper() : Activ::WsaBufHelper
Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- b -

  • BaseException() : Activ::BaseException
  • Begin()
: Activ::ContentPlatform::FeedApi::FieldListValidator
, Activ::ContentPlatform::Feed::RecordKeyFieldListValidator
, Activ::ContentPlatform::Feed::TableTemplateIndex
, Activ::Database::FieldListObject
, Activ::HeapMessage
, Activ::ContentPlatform::Feed::TableTemplateIndexListValidator
, Activ::ContentPlatform::Feed::SymbolRecordFieldListValidator
, Activ::ContentPlatform::Feed::TableTemplateList
, Activ::ContentPlatform::Feed::UniversalFieldList
, Activ::ContentPlatform::Feed::RecordFieldListValidator
, Activ::ContentPlatform::Feed::SymbolRecordMessageValidator
, Activ::ScatterBufferHelper
, Activ::Database::Database
, Activ::ContentPlatform::Feed::TableTemplateFieldListValidator
, Activ::Database::Database
, Activ::Database::FieldList
  • BeginCopyOnReset() : Activ::ContentPlatform::Feed::TableTemplate
  • BeginField()
: Activ::ContentPlatform::Feed::RecordMessageValidator
, Activ::ContentPlatform::Feed::TableTemplateMessageValidator
, Activ::ContentPlatform::Feed::TableTemplate
  • BeginIndex()
: Activ::ContentPlatform::Feed::TableTemplateMessageValidator
, Activ::ContentPlatform::Feed::TableTemplate
  • BeginKey() : Activ::IniFileParser::ConstSectionIterator
  • BeginKeyField()
: Activ::ContentPlatform::ContentServerApi::RecordUpdate
, Activ::ContentPlatform::Feed::RecordMessageHeaderValidator
, Activ::ContentPlatform::Feed::RecordMessageValidator
  • BeginRule() : Activ::ContentPlatform::Feed::TableTemplate
  • BeginSection() : Activ::IniFileParser
  • BeginSubSection() : Activ::IniFileParser::ConstSectionIterator
  • BeginUndefineOnReset() : Activ::ContentPlatform::Feed::TableTemplate
  • BinaryArray() : Activ::BinaryArray
  • BinaryString() : Activ::BinaryString
  • Bitmap : Activ::UiPermissions
  • Blob() : Activ::Blob
  • BooleanSwitch() : Activ::CommandLineParser
  • BooleanSwitchDescription() : Activ::CommandLineParserDetail::BooleanSwitchDescription
  • Break() : Activ::RouterServiceApi::Tcp
  • BreakAll() : Activ::RouterServiceApi::Tcp
  • BucketInfoVector : Activ::IHeap
  • BucketStats() : Activ::IHeap::Stats::BucketStats
  • Buffer : Activ::ContentPlatform::ContentGatewayApi::FieldData
  • Build() : Activ::Url
  • BuildKey()
: Activ::Database::Key
, Activ::Database::IIndex
  • BuildOpenServiceResponse() : Activ::Service
Generated on Wed Oct 8 14:01:54 2008 for ACTIV C++ SDK by doxygen 1.5.4


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- c -

  • CACHE_COMPLETE : Activ::Database::TableSpecification
  • CalculateCrc() : Activ::CrcBlob
  • CancelTimer() : Activ::TimerServiceApi
  • CancelTimers() : Activ::TimerServiceApi
  • CancelWatch() : Activ::DirectoryWatchApi
  • CanThreadExit()
: Activ::AgentApplication
, Activ::ManagedEndPoint
  • CheckIntegrity()
: Activ::Database::IIndex
, Activ::Database::ITable
  • ChildService() : Activ::ChildService< T >
  • CleanUp() : Activ::CurlFtpHelper
  • CleanupIo() : Activ::IpSocket
  • Clear()
: Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryResponseParameters
, Activ::ContentPlatform::Feed::Rule::LowFields
, Activ::ScopedAddress
, Activ::Subject
, Activ::ContentPlatform::Feed::Rule::OpenFields
, Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestParameters
, Activ::ContentPlatform::Feed::Rule::CloseFields
, Activ::ContentPlatform::Feed::Rule::PriceFields
, Activ::ContentPlatform::ContentGatewayApi::TimeSeriesResponseParametersTemplate< FIELD_SET_TYPE >
, Activ::ContentPlatform::Feed::Rule::VolumeFields
, Activ::ContentPlatform::Feed::Rule
, Activ::ContentPlatform::FeedApi::FieldListValidator
, Activ::ContentPlatform::Feed::TableTemplate
, Activ::ContentPlatform::Feed::TableTemplateList
, Activ::ContentPlatform::Feed::RecordFieldListBuilder
, Activ::ContentPlatform::Feed::UniversalFieldList
, Activ::IEvent
, Activ::ContentPlatform::Feed::RecordFieldListValidator
, Activ::Database::ITable
, Activ::BinaryArray
, Activ::ContentPlatform::Feed::RecordKeyFieldListBuilder
, Activ::BinaryString
, Activ::Blob
, Activ::ContentPlatform::Feed::RecordKeyFieldListValidator
, Activ::CrcBlob
, Activ::Date
, Activ::ContentPlatform::Feed::RecordMessageHeaderValidator
, Activ::DateTime
, Activ::IFieldType
, Activ::ContentPlatform::Feed::RecordMessageValidator
, Activ::Rational
, Activ::SInt
, Activ::ContentPlatform::ContentGatewayApi::RequestBlock
, Activ::ContentPlatform::Feed::SymbolRecordFieldListBuilder
, Activ::TextArray
, Activ::TextString
, Activ::ContentPlatform::Feed::SymbolRecordFieldListValidator
, Activ::Time
, Activ::TRational
, Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters
, Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator
, Activ::UInt
, Activ::ServiceAccessPoint
, Activ::ContentPlatform::Feed::SymbolRecordMessageValidator
, Activ::ServiceId
, Activ::ServiceInstance
, Activ::ContentPlatform::ContentGatewayApi::RealtimeResponseParameters
, Activ::ContentPlatform::Feed::Rule::CopyToFields
, Activ::ServiceHandle
, Activ::Address
, Activ::ContentPlatform::Feed::Rule::HighFields
, Activ::IEndPoint
, Activ::RequestId
  • ClearAllHighCounts() : Activ::IEndPoint
  • ClearDailyHighCounts() : Activ::IEndPoint
  • ClearFieldRules() : Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions
  • ClearFrom() : Activ::ConsoleWindow
  • ClearLastHighCounts() : Activ::IEndPoint
  • ClearSocketStatsHighCounts() : Activ::RouterServiceApi::Tcp
  • Clone()
: Activ::Database::ITable
, Activ::FieldTypeFactory
, Activ::HeapMessage
  • Close()
: Activ::File
, Activ::RouterServiceApi::Udp
, Activ::Service
, Activ::UdpComponent
  • CloseFields() : Activ::ContentPlatform::Feed::Rule::CloseFields
  • CloseLogFile() : Activ::LoggerServiceApi
  • CloseRecordFile() : Activ::Database::ITable
  • CloseService() : Activ::ServiceApi
  • CloseSocket() : Activ::IpSocket
  • CollateStats() : Activ::SystemMonitor
  • Columnizer() : Activ::UiIo::Columnizer
  • CommandLineParser() : Activ::CommandLineParser
  • CommandLineParserImpl() : Activ::CommandLineParserDetail::CommandLineParserImpl
  • Compare()
: Activ::TextArray
, Activ::TextString
, Activ::Time
, Activ::TRational
, Activ::UInt
, Activ::IpAddress
, Activ::ContentPlatform::ContentGatewayApi::HistoryBar
, Activ::ContentPlatform::ContentGatewayApi::IntradayBar
, Activ::ContentPlatform::ContentGatewayApi::OptionBar
, Activ::ContentPlatform::ContentGatewayApi::Tick
, Activ::Database::FieldList
, Activ::Database::IIndex
, Activ::BinaryArray
, Activ::BinaryString
, Activ::Blob
, Activ::CrcBlob
, Activ::Date
, Activ::DateTime
, Activ::IFieldType
, Activ::Rational
, Activ::SInt
  • CompareContentOnly() : Activ::ContentPlatform::ContentGatewayApi::Tick
  • CompareField()
: Activ::Database::FieldList
, Activ::Database::FieldListObject
  • CompareKey() : Activ::Database::FieldList
  • COMPLETION_RESULT_CLOSE_SOCKET : Activ::IpSocket
  • COMPLETION_RESULT_OK : Activ::IpSocket
  • CompletionHelper() : Activ::UiIo::CompletionHelper
  • CompletionResult : Activ::IpSocket
  • Component() : Activ::Component
  • CompositeAskStateToString() : Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator
  • CompositeBidStateToString() : Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator
  • CompositeFieldRulesToString() : Activ::ContentPlatform::Feed::SymbolRecordField
  • CompositeState : Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageDefinitions
  • CompositeUpdateIdToString()
: Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator
, Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator
, Activ::ContentPlatform::Feed::RecordMessageHeaderValidator
, Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator
  • Compress()
: Activ::Blob
, Activ::CrcBlob
, Activ::Rational
, Activ::TRational
  • CompressedCombinedQuoteMessageHeaderValidator() : Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator
  • CompressedMessageHeaderValidator() : Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator
  • CompressedNumeratorLength : Activ::ContentPlatform::Feed::CompressedMessageDefinitions
  • Condition : Activ::ScopedHelper< T, D >
  • Connect()
: Activ::RouterServiceApi::Tcp
, Activ::TcpSocket
, Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
, Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient
, Activ::RouterServiceApi::Tcp
, Activ::RouterServiceApi::Udp
, Activ::UdpComponent
, Activ::TcpSocket
, Activ::UdpSocket
, Activ::CurlFtpHelper
, Activ::FtpHelper
, Activ::IFtpHelper
, Activ::SmtpHelper
  • ConnectParameters()
: Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::ConnectParameters
, Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::ConnectParameters
  • ConsoleWindow() : Activ::ConsoleWindow
  • ConstCopyOnResetIterator() : Activ::ContentPlatform::Feed::TableTemplate::ConstCopyOnResetIterator
  • ConstFieldIterator
: Activ::ContentPlatform::Feed::TableTemplateMessageValidator
, Activ::ContentPlatform::Feed::RecordMessageValidator
, Activ::ContentPlatform::Feed::TableTemplate::ConstFieldIterator
  • ConstIndexIterator : Activ::ContentPlatform::Feed::TableTemplateMessageValidator , Activ::ContentPlatform::Feed::TableTemplate::ConstIndexIterator
  • ConstIterator
: Activ::ContentPlatform::Feed::SymbolRecordMessageValidator
, Activ::Database::FieldListObject
, Activ::ContentPlatform::FeedApi::FieldListValidator::ConstIterator
, Activ::ContentPlatform::Feed::RecordFieldListValidator::ConstIterator
, Activ::ContentPlatform::Feed::RecordKeyFieldListValidator::ConstIterator
, Activ::ContentPlatform::Feed::SymbolRecordFieldListValidator::ConstIterator
, Activ::ContentPlatform::Feed::TableTemplateFieldListValidator::ConstIterator
, Activ::ContentPlatform::Feed::TableTemplateList::ConstIterator
, Activ::ScatterBufferHelper::ConstIterator
, Activ::Database::FieldList::ConstIterator
, Activ::ContentPlatform::Feed::UniversalFieldList::ConstIterator
  • ConstKeyFieldIterator
: Activ::ContentPlatform::Feed::RecordMessageHeaderValidator
, Activ::ContentPlatform::Feed::RecordMessageValidator
, Activ::ContentPlatform::ContentServerApi::RecordUpdate
  • ConstRuleIterator() : Activ::ContentPlatform::Feed::TableTemplate::ConstRuleIterator
  • ConstSectionIterator : Activ::IniFileParser::ConstKeyIterator
  • ConstUndefineOnResetIterator() : Activ::ContentPlatform::Feed::TableTemplate::ConstUndefineOnResetIterator
  • ContentGatewayClient() : Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
  • ContentServerClient() : Activ::ContentPlatform::ContentServerApi::ContentServerClient
  • ContentsPrefixToString()
: Activ::ContentPlatform::Feed::RecordFieldListValidator
, Activ::ContentPlatform::Feed::RecordKeyFieldListValidator
, Activ::ContentPlatform::Feed::SymbolRecordField
  • ContributionGatewayClient() : Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient
  • ContributionServerClient() : Activ::ContentPlatform::ContributionServerApi::ContributionServerClient
  • Convert()
: Activ::UInt
, Activ::Date
, Activ::DateTime
, Activ::Time
, Activ::TRational
, Activ::TextArray
, Activ::FieldTypeFactory
, Activ::Blob
, Activ::Database::ITable
, Activ::BinaryString
, Activ::CrcBlob
, Activ::IFieldType
, Activ::Rational
, Activ::SInt
, Activ::TextString
, Activ::BinaryArray
  • ConvertGregorianToJulianDate() : Activ::Date
  • ConvertGregorianToJulianDateTime() : Activ::DateTime
  • ConvertGregorianToJulianTime() : Activ::Time
  • ConvertJulianToGregorianDate() : Activ::Date
  • ConvertJulianToGregorianDateTime() : Activ::DateTime
  • ConvertJulianToGregorianTime() : Activ::Time
  • ConvertStringToEnabledDaysBitmap() : Activ::Timeband
  • Coord() : Activ::ConsoleWindow::Coord
  • Copy()
: Activ::File
, Activ::ScatterBufferHelper
, Activ::Database::ITable
, Activ::HeapMessage::WriteHelper
, Activ::HeapMessage
, Activ::ScatterBufferHelper
, Activ::HeapMessage
, Activ::HeapMessage::WriteHelper
, Activ::HeapMessage::ReadHelper
, Activ::HeapMessage
, Activ::HeapMessage::ReadHelper
  • CopyAsciiHexadecimalIntegralToUnsignedBinaryIntegral() : Activ::MessageValidator
  • CopyField()
: Activ::Database::FieldList
, Activ::Database::FieldListObject
, Activ::Database::FieldList
, Activ::Database::FieldListObject
, Activ::Database::FieldList
  • CopyFields()
: Activ::Database::FieldListObject
, Activ::Database::FieldList
, Activ::Database::Key
  • CopyFiles() : Activ::Database::ITable
  • CopyOnReset() : Activ::ContentPlatform::Feed::CopyOnReset
  • CopyOnResetToString() : Activ::ContentPlatform::Feed::TableTemplate
  • CopySignedAsciiIntegralToSignedBinaryIntegral() : Activ::MessageValidator
  • CopySignedAsciiRealToBinaryReal() : Activ::MessageValidator
  • CopySignedAsciiRealToNumeratorAndDivisor() : Activ::MessageValidator
  • CopySignedBinaryIntegralToSignedBinaryIntegral() : Activ::MessageValidator
  • CopyToFields() : Activ::ContentPlatform::Feed::Rule::CopyToFields
  • CopyUnsignedAsciiIntegralToUnsignedBinaryIntegral() : Activ::MessageValidator
  • CopyUnsignedAsciiRealToBinaryReal() : Activ::MessageValidator
  • CopyUnsignedAsciiRealToNumeratorAndDivisor() : Activ::MessageValidator
  • CopyUnsignedBinaryIntegralToUnsignedBinaryIntegral() : Activ::MessageValidator
  • CrcBlob() : Activ::CrcBlob
  • Create()
: Activ::SharedSemaphoreFactory
, Activ::SharedMutexFactory
, Activ::PrivateEventFactory
, Activ::Database::ManagedTableFactory
, Activ::SharedCompletionPortEventFactory
, Activ::Database::ManagedTableFactory
, Activ::RouterServiceApi::Udp
, Activ::Database::UnmanagedTableFactory
, Activ::Database::RemoteTableFactory
, Activ::SharedEventFactory
, Activ::PrivateSemaphoreFactory
, Activ::PagingFileMappedMemoryFactory
, Activ::FieldTypeFactory
, Activ::PagingFileMappedMemoryFactory
, Activ::PrivateMutexFactory
, Activ::Database::ManagedTableFactory
, Activ::File
, Activ::FileMappedMemoryFactory
, Activ::Database::UnmanagedTableFactory
, Activ::SharedObject< T >
, Activ::SystemFactory
  • CreateEndPoint()
: Activ::ISystem
, Activ::SystemProxy
  • CreateFieldIdLookupList() : Activ::Database::FieldList
  • CreateFieldIdMap() : Activ::Database::FieldList
  • CreateHeap()
: Activ::SystemProxy
, Activ::ISystem
  • CreateIndexes() : Activ::Database::ITable
  • CreateLocalDate() : Activ::Date
  • CreateLocalDateTime() : Activ::DateTime
  • CreateLocalTime() : Activ::Time
  • CreateNonInheritableSocket() : Activ::IpManager
  • CreatePrivateEndPoint()
: Activ::ISystem
, Activ::SystemProxy
  • CreateRecordFile() : Activ::Database::ITable
  • CreateSocket() : Activ::UdpComponent
  • CreateTable() : Activ::Database::TableSpecification
  • CreateTemporaryIndex() : Activ::Database::ITable
  • CreateUtcDate() : Activ::Date
  • CreateUtcDateTime() : Activ::DateTime
  • CreateUtcTime() : Activ::Time
  • CrtException() : Activ::CrtException
  • CtrlHandler() : Activ::CtrlHandler
  • CurlFtpHelper() : Activ::CurlFtpHelper
  • CurlInitializeHelper() : Activ::CurlFtpHelper::CurlInitializeHelper
Generated on Wed Oct 8 14:01:54 2008 for ACTIV C++ SDK by doxygen 1.5.4


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- d -

  • Database() : Activ::Database::Database
  • DatabaseException() : Activ::Database::DatabaseException
  • DatabaseSpecification() : Activ::Database::DatabaseSpecification
  • DatabaseTableSpecification() : Activ::Database::DatabaseSpecification::DatabaseTableSpecification
  • DatabaseTableSpecificationList : Activ::Database::DatabaseSpecification
  • Date() : Activ::Date
  • DateSet : Activ::Timeband
  • DateTime() : Activ::DateTime
  • DateToString() : Activ::BaseTime
  • DayOfWeek : Activ::BaseTime
  • DayOfWeekToString()
: Activ::Date
, Activ::BaseTime
  • Days : Activ::DateTime , Activ::Date::Days
  • DAYS_PER_MONTH : Activ::Date
  • DAYS_PER_WEEK : Activ::Date
  • Decompress()
: Activ::Blob
, Activ::CrcBlob
  • DEFAULT_FILENAME : Activ::ContentPlatform::Feed::UniversalFieldList
  • DEFAULT_FTP_LOW_SPEED_LIMIT : Activ::IFtpHelper
  • DEFAULT_FTP_LOW_SPEED_TIME : Activ::IFtpHelper
  • DEFAULT_FTP_PORT : Activ::IFtpHelper
  • DEFAULT_FTP_TIMEOUT : Activ::IFtpHelper
  • DEFAULT_MAX_FIELD_SETS : Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestParameters
  • DEFAULT_MAX_RECORDS_PER_RESPONSE : Activ::ContentPlatform::ContentGatewayApi::NewsRequestParameters
  • DEFAULT_MAX_RESPONSE_BLOCKS : Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters
  • defaultComponentId : Activ::Component
  • DefaultDescription() : Activ::CommandLineParserDetail::DefaultDescription< T >
  • DefaultRuleSetToString()
: Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator
, Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator
, Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator
  • defaultTimeout : Activ::Port
  • DeferredScopedMutexLocker() : Activ::DeferredScopedMutexLocker
  • DefineField()
: Activ::Database::FieldList
, Activ::Database::FieldListObject
  • Delete() : Activ::Database::ITable
  • DeleteFile()
: Activ::CurlFtpHelper
, Activ::FtpHelper
, Activ::IFtpHelper
  • DeleteKey() : Activ::RegistryHelper
  • DeleteValue() : Activ::RegistryHelper
  • Denominator : Activ::Rational
  • DenominatorType() : Activ::Rational::DenominatorType
  • Deregister() : Activ::Service
  • Description() : Activ::CommandLineParserDetail::Description< T >
  • DescriptionAppender() : Activ::CommandLineParserDetail::DescriptionAppender
  • Deserialize()
: Activ::ContentPlatform::ContentGatewayApi::NewsUpdateHelper
, Activ::UInt
, Activ::DirectoryWatchApi
, Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestHelper< MESSAGE_TYPE_VALUE, REQUEST_PARAMETERS >
, Activ::OpenServiceRequest
, Activ::OpenServiceResponse
, Activ::ContentPlatform::ContentGatewayApi::RecordUpdateHelper
, Activ::SystemMessageEndPointIdSet
, Activ::BaseTime
, Activ::ContentPlatform::ContentGatewayApi::RecordUpdateHelper
, Activ::UiPermissions
, Activ::IpAddress
, Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryRequestHelper
, Activ::Address
, Activ::SerializableBuffer< LENGTH_TYPE, MIN_LENGTH, MAX_LENGTH >
, Activ::SerializableContainerHelper< hash_map< KEY_TYPE, MAPPED_TYPE, HASH_FN >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >
, Activ::HeapMessageDeserializer< MESSAGE_TYPE, BUFFER_SIZE >
, Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestHelper< FIRST_MESSAGE_TYPE_VALUE, NEXT_MESSAGE_TYPE_VALUE, FIELD_SET_TYPE >
, Activ::SerializableContainerHelper< std::list< OBJECT_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >
, Activ::SerializableContainerHelper< std::vector< OBJECT_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >
, Activ::SerializableRawPointerHelper< POINTER_TYPE >
, Activ::IEndPoint::Stats
, Activ::SerializableObjectHelper< OBJECT_TYPE >
, Activ::Subject
, Activ::ISyncEndPoint::Stats
, Activ::ContentPlatform::ContentGatewayApi::FieldSet
, Activ::IHeap::Stats::RequestDistributionStats
, Activ::IHeap::Stats::BucketStats
, Activ::ContentPlatform::ContentGatewayApi::HistoryBar
, Activ::IHeap::Stats
, Activ::IProcess::Stats
, Activ::ContentPlatform::ContentGatewayApi::IntradayBar
, Activ::ISystem::SystemInfo
, Activ::RequestId
, Activ::ContentPlatform::ContentGatewayApi::OptionBar
, Activ::ContentPlatform::ContentGatewayApi::RequestBlock
, Activ::SerializableSmartPointerHelper< POINTER_TYPE >
, Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryRequestParameters
, Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryResponseParameters
, Activ::SerializableContainerHelper< std::set< OBJECT_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >
, Activ::SerializableContainerHelper< std::map< KEY_TYPE, MAPPED_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >
, Activ::ContentPlatform::ContentGatewayApi::Tick
, Activ::TRational
, Activ::Time
, Activ::ContentPlatform::ContentGatewayApi::DataPointAddress
, Activ::SerializableContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >
, Activ::TextArray
, Activ::ContentPlatform::ContentGatewayApi::Period
, Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestParameters
, Activ::ContentPlatform::ContentGatewayApi::TimeSeriesCookie
, Activ::IFieldType
, Activ::ContentPlatform::ContentGatewayApi::TimeSeriesResponseParametersTemplate< FIELD_SET_TYPE >
, Activ::ContentPlatform::ContributionGatewayApi::PublishRequestHelper< MESSAGE_TYPE_VALUE, REQUEST_PARAMETERS, RESPONSE_PARAMETERS >
, Activ::ContentPlatform::Feed::CompressedMessageDefinitions::FieldHeaderValidator
, Activ::ContentPlatform::Feed::CompressedSymbol
, Activ::ContentPlatform::Feed::CompressedUsEquityOptionSymbol
, Activ::ContentPlatform::Feed::Symbol
, Activ::BinaryString
, Activ::ConsoleWindow::Coord
, Activ::IniFileParser
, Activ::ISerializableMessage
, Activ::Database::TableSpecification
, Activ::SystemInfo
, Activ::Uuid
, Activ::Database::DatabaseSpecification::DatabaseTableSpecification
, Activ::Database::ITable
, Activ::Database::DatabaseSpecification
, Activ::Database::FieldList
, Activ::Database::FieldListObject
, Activ::Database::FieldSpecification
, Activ::Database::IndexSpecification::Field
, Activ::Database::IndexSpecification
, Activ::Database::ITable
, Activ::Database::Key
, Activ::Database::Record
, Activ::BinaryArray
, Activ::BinaryString
, Activ::Blob
, Activ::CrcBlob
, Activ::Date
, Activ::DateTime
, Activ::IFieldType
, Activ::Rational
, Activ::SInt
, Activ::TextArray
, Activ::TextString
, Activ::ContentPlatform::ContentGatewayApi::NewsRequestHelper
  • DeserializeBody()
: Activ::Rational
, Activ::IFieldType
, Activ::CrcBlob
, Activ::Date
, Activ::BinaryArray
, Activ::BinaryString
, Activ::BinaryArray
, Activ::TextString
, Activ::TextArray
, Activ::BinaryString
, Activ::Blob
, Activ::CrcBlob
, Activ::IFieldType
, Activ::SInt
, Activ::TextArray
, Activ::TRational
, Activ::UInt
, Activ::Time
, Activ::TextString
, Activ::DateTime
  • DeserializeLengthAndBody()
: Activ::SInt
, Activ::CrcBlob
, Activ::Date
, Activ::UInt
, Activ::TextString
, Activ::TRational
, Activ::Blob
, Activ::BinaryString
, Activ::CrcBlob
, Activ::IFieldType
, Activ::TextString
, Activ::Blob
, Activ::TextArray
, Activ::Time
, Activ::BinaryArray
, Activ::IFieldType
, Activ::Rational
, Activ::DateTime
, Activ::TextArray
  • DeserializeSocketStats() : Activ::RouterServiceApi::Tcp
  • DeserializeSpecification() : Activ::Database::FieldList
  • DestroyAll() : Activ::ObjectPool< T, INITIAL_FREE_LIST_SIZE, MAX_FREE_LIST_SIZE >
  • DetachTable() : Activ::Database::Database
  • DirectoryRemover() : Activ::DirectoryRemover
  • DirectoryWalker() : Activ::DirectoryWalker
  • Disable() : Activ::Port
  • Disconnect()
: Activ::UdpSocket
, Activ::RouterServiceApi::Udp
, Activ::TcpSocket
, Activ::CurlFtpHelper
, Activ::SmtpHelper
, Activ::RouterServiceApi::Tcp
, Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
, Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient
, Activ::IFtpHelper
, Activ::UdpComponent
, Activ::FtpHelper
  • DisplayFooter() : Activ::UiMenu
  • DisplayInputPrompt() : Activ::UiMenu
  • DisplayOption() : Activ::UiMenu
  • DisplayOptionPrompt() : Activ::UiMenu
  • DisplayTitle() : Activ::UiMenu
  • Divide()
: Activ::Rational
, Activ::SInt
, Activ::UInt
  • DllFunctionWrapper() : Activ::DllFunctionWrapper< NAME, TYPE, THROW_ON_ERROR >
  • DoesExist() : Activ::Process
  • Duration() : Activ::BaseTime::Duration
  • DynamicCompletionHelper() : Activ::UiIo::DynamicCompletionHelper
  • DynamicLibraryLoader() : Activ::DynamicLibraryLoader< T >
Generated on Wed Oct 8 14:01:54 2008 for ACTIV C++ SDK by doxygen 1.5.4


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- e -

  • Email() : Activ::SmtpHelper::Email
  • emptyRequestId : Activ::RequestId
  • emptyServiceAccessPointList : Activ::Service
  • emptyUuid : Activ::Uuid
  • Enable() : Activ::Port
  • EnabledDateFlag : Activ::Timeband
  • EnabledDaysBitmap : Activ::Timeband
  • EnableDisable() : Activ::UiIo
  • Enabler() : Activ::Port::Enabler
  • EnableSocketStats() : Activ::RouterServiceApi::Tcp
  • End()
: Activ::ContentPlatform::Feed::TableTemplateFieldListValidator
, Activ::ContentPlatform::Feed::TableTemplateIndex
, Activ::ContentPlatform::Feed::TableTemplateIndexListValidator
, Activ::ContentPlatform::Feed::TableTemplateList
, Activ::ContentPlatform::Feed::UniversalFieldList
, Activ::ScatterBufferHelper
, Activ::ContentPlatform::FeedApi::FieldListValidator
, Activ::Thread
, Activ::Database::Database
, Activ::ContentPlatform::Feed::RecordFieldListValidator
, Activ::Database::Database
, Activ::Database::FieldList
, Activ::ContentPlatform::Feed::RecordKeyFieldListValidator
, Activ::Database::FieldListObject
, Activ::HeapMessage
, Activ::ContentPlatform::Feed::SymbolRecordFieldListValidator
, Activ::ContentPlatform::Feed::SymbolRecordMessageValidator
  • EndCopyOnReset() : Activ::ContentPlatform::Feed::TableTemplate
  • EndField()
: Activ::ContentPlatform::Feed::RecordMessageValidator
, Activ::ContentPlatform::Feed::TableTemplateMessageValidator
, Activ::ContentPlatform::Feed::TableTemplate
  • Endian : Activ::MessageHandler
  • ENDIAN_BIG : Activ::MessageHandler
  • ENDIAN_LITTLE : Activ::MessageHandler
  • ENDIAN_LOCAL : Activ::MessageHandler
  • EndIndex()
: Activ::ContentPlatform::Feed::TableTemplateMessageValidator
, Activ::ContentPlatform::Feed::TableTemplate
  • EndKey() : Activ::IniFileParser::ConstSectionIterator
  • EndKeyField()
: Activ::ContentPlatform::ContentServerApi::RecordUpdate
, Activ::ContentPlatform::Feed::RecordMessageHeaderValidator
, Activ::ContentPlatform::Feed::RecordMessageValidator
  • EndPointSubject() : Activ::EndPointSubject
  • EndRule() : Activ::ContentPlatform::Feed::TableTemplate
  • EndSection()
: Activ::IniFileParser::ConstSectionIterator
, Activ::IniFileParser
  • EndSubSection() : Activ::IniFileParser::ConstSectionIterator
  • EndUndefineOnReset() : Activ::ContentPlatform::Feed::TableTemplate
  • EntityTypeHelper() : Activ::ContentPlatform::Feed::EntityTypeHelper
  • EnumerateKeys() : Activ::RegistryHelper
  • EnumerateObjects()
: Activ::ISystem
, Activ::SystemProxy
, Activ::ISystem
  • EnumerateValues() : Activ::RegistryHelper
  • Erase()
: Activ::HeapMessage
, Activ::MessageBuilder
  • Errors : Activ::Database::DatabaseException
  • EVENT_TYPE_ADDED : Activ::DirectoryWatchApi
  • EVENT_TYPE_DELETED : Activ::DirectoryWatchApi
  • EVENT_TYPE_MODIFIED : Activ::DirectoryWatchApi
  • EventList : Activ::DirectoryWatchApi
  • EventType : Activ::CtrlHandler , Activ::DirectoryWatchApi
  • EventTypeHelper() : Activ::ContentPlatform::Feed::EventTypeHelper
  • EventTypeList : Activ::ContentPlatform::ContentGatewayApi::SubscribeParameters , Activ::ContentPlatform::ContentServerApi::ContentServerClient::UpdateFilter
  • EventTypeToString()
: Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator
, Activ::DirectoryWatchApi
, Activ::ContentPlatform::Feed::RecordMessageHeaderValidator
, Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator
, Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator
  • Exception() : Activ::Exception
  • EXCEPTION_HANDLER_TYPE_FULL_MEMORY : Activ::Application::Settings
  • EXCEPTION_HANDLER_TYPE_NONE : Activ::Application::Settings
  • EXCEPTION_HANDLER_TYPE_NORMAL : Activ::Application::Settings
  • ExceptionHandlerType : Activ::Application::Settings
  • Exchange()
: Activ::AtomicInteger
, Activ::AtomicPointer< T >
  • Exec() : Activ::Process
  • ExpandPath() : Activ::File
  • Extend()
: Activ::HeapMessage
, Activ::HeapPool
  • ExtractCompressedCompositeAskState() : Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageDefinitions
  • ExtractCompressedUpdateId() : Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageDefinitions
  • ExtractFlags()
: Activ::ContentPlatform::Feed::CombinedQuoteMessageHeaderDefinitions
, Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions
, Activ::ContentPlatform::Feed::RecordMessageHeaderDefinitions
Generated on Wed Oct 8 14:01:54 2008 for ACTIV C++ SDK by doxygen 1.5.4


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- f -

  • Fiber() : Activ::Fiber
  • Field()
: Activ::ContentPlatform::ContributionGatewayApi::PublishSymbolRecordParameters::Field
, Activ::ContentPlatform::Feed::IndexSpecification::Field
, Activ::ContentPlatform::FeedApi::FieldListValidator::Field
, Activ::Database::IndexSpecification::Field
, Activ::ContentPlatform::ContributionGatewayApi::PublishSymbolRecordParameters::Field
, Activ::ContentPlatform::Feed::Field
  • FIELD_ID_LENGTH : Activ::ContentPlatform::Feed::FieldHeaderDefinitions
  • FIELD_ID_OFFSET : Activ::ContentPlatform::Feed::FieldHeaderDefinitions
  • FIELD_RESERVED_LENGTH : Activ::ContentPlatform::Feed::FieldHeaderDefinitions
  • FIELD_RESERVED_OFFSET : Activ::ContentPlatform::Feed::FieldHeaderDefinitions
  • FIELD_RULE_APPLY_TRENDING : Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ContentServerRuleSet
  • FIELD_RULE_BIT_APPLY_TRENDING : Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ContentServerRuleSet
  • FIELD_RULE_BIT_DO_NOT_APPLY_ADD_RULE_1 : Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::TranslatorRuleSet , Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ContentServerRuleSet
  • FIELD_RULE_BIT_DO_NOT_APPLY_ADD_RULE_2 : Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::TranslatorRuleSet , Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ContentServerRuleSet
  • FIELD_RULE_BIT_DO_NOT_APPLY_CHANGE_RULE : Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::TranslatorRuleSet , Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ContentServerRuleSet
  • FIELD_RULE_BIT_DO_NOT_APPLY_TRENDING : Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::TranslatorRuleSet
  • FIELD_RULE_BIT_DO_NOT_TEST_HIGH_LOW : Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::TranslatorRuleSet
  • FIELD_RULE_BIT_DO_NOT_TEST_OPEN : Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::TranslatorRuleSet
  • FIELD_RULE_BIT_DO_NOT_UPDATE_FIELD : Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::TranslatorRuleSet , Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ContentServerRuleSet
  • FIELD_RULE_BIT_IS_HIGH : Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ContentServerRuleSet
  • FIELD_RULE_BIT_IS_LOW : Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ContentServerRuleSet
  • FIELD_RULE_BIT_IS_OPEN : Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ContentServerRuleSet
  • FIELD_RULE_BITMASK_IS_HIGH : Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ContentServerRuleSet
  • FIELD_RULE_BITMASK_IS_LOW : Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ContentServerRuleSet
  • FIELD_RULE_BITMASK_IS_OPEN : Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ContentServerRuleSet
  • FIELD_RULE_CLEAR_ALL : Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions
  • FIELD_RULE_DO_NOT_APPLY_ADD_RULE_1 : Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::TranslatorRuleSet , Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ContentServerRuleSet
  • FIELD_RULE_DO_NOT_APPLY_ADD_RULE_2 : Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::TranslatorRuleSet , Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ContentServerRuleSet
  • FIELD_RULE_DO_NOT_APPLY_CHANGE_RULE : Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::TranslatorRuleSet , Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ContentServerRuleSet
  • FIELD_RULE_DO_NOT_APPLY_TRENDING : Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::TranslatorRuleSet
  • FIELD_RULE_DO_NOT_TEST_HIGH_LOW : Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::TranslatorRuleSet
  • FIELD_RULE_DO_NOT_TEST_OPEN : Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::TranslatorRuleSet
  • FIELD_RULE_DO_NOT_UPDATE_FIELD : Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::TranslatorRuleSet , Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ContentServerRuleSet
  • FIELD_RULE_SET_ALL : Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions
  • FIELD_RULES_PRESENT_LENGTH : Activ::ContentPlatform::Feed::SymbolRecordFieldHeaderDefinitions
  • FIELD_RULES_PRESENT_OFFSET : Activ::ContentPlatform::Feed::SymbolRecordFieldHeaderDefinitions
  • FIELD_STATUS_INVALID_TYPE : Activ::ContentPlatform::ContributionGatewayApi::PublishRecordResponseParameters::FieldError
  • FIELD_TYPE
: Activ::BinaryArray
, Activ::BinaryString
, Activ::Blob
, Activ::CrcBlob
, Activ::Date
, Activ::DateTime
, Activ::Rational
, Activ::SInt
, Activ::TextArray
, Activ::TextString
, Activ::Time
, Activ::TRational
, Activ::UInt
  • FIELD_UNDEFINED_LENGTH : Activ::ContentPlatform::Feed::FieldHeaderDefinitions
  • FIELD_UNDEFINED_OFFSET : Activ::ContentPlatform::Feed::FieldHeaderDefinitions
  • FieldContentsToString()
: Activ::ContentPlatform::Feed::RecordFieldListValidator
, Activ::ContentPlatform::Feed::RecordKeyFieldListValidator
, Activ::ContentPlatform::Feed::SymbolRecordField
  • FieldHeader : Activ::ContentPlatform::Feed::FieldHeaderDefinitions
  • FieldHeaderBuilder() : Activ::ContentPlatform::Feed::CompressedMessageDefinitions::FieldHeaderBuilder
  • FieldHeaderValidator() : Activ::ContentPlatform::Feed::CompressedMessageDefinitions::FieldHeaderValidator
  • FieldIdMap : Activ::Database::FieldList
  • FieldIdToString()
: Activ::ContentPlatform::Feed::RecordFieldListValidator
, Activ::ContentPlatform::Feed::RecordKeyFieldListValidator
, Activ::ContentPlatform::Feed::SymbolRecordField
  • FieldList : Activ::Database::FieldList::ConstIterator , Activ::Database::FieldList
  • FieldListObject() : Activ::Database::FieldListObject
  • FieldListTitleToString() : Activ::ContentPlatform::Feed::RecordFieldListValidator
  • FieldListValidator()
: Activ::ContentPlatform::ContentGatewayApi::FieldListValidator
, Activ::ContentPlatform::ContentServerApi::FieldListValidator
, Activ::ContentPlatform::FeedApi::FieldListValidator
  • FieldNameToString()
: Activ::ContentPlatform::Feed::RecordKeyFieldListValidator
, Activ::ContentPlatform::Feed::SymbolRecordField
  • FieldRulesToString() : Activ::ContentPlatform::Feed::SymbolRecordField
  • FieldSet() : Activ::ContentPlatform::ContentGatewayApi::FieldSet
  • FieldSetList : Activ::ContentPlatform::ContentGatewayApi::TimeSeriesResponseParametersTemplate< FIELD_SET_TYPE >
  • FieldSpecification()
: Activ::ContentPlatform::Feed::CompressedMessageDefinitions::FieldSpecification
, Activ::ContentPlatform::Feed::TableTemplate::FieldSpecification
, Activ::Database::FieldSpecification
  • FieldSpecificationList : Activ::ContentPlatform::Feed::TableTemplate
  • FieldState : Activ::ContentPlatform::Feed::CompressedMessageDefinitions
  • FieldStatusToString() : Activ::ContentPlatform::ContributionGatewayApi::PublishRecordResponseParameters::FieldError
  • FieldsToString() : Activ::ContentPlatform::Feed::TableTemplate
  • File() : Activ::File
  • FILE_FLAG_CREATE_ALWAYS : Activ::IFileMappedMemory
  • FILE_FLAG_DELETE_AT_CLOSE : Activ::IFileMappedMemory
  • FILE_FLAG_OPEN_EXISTING : Activ::IFileMappedMemory
  • FILE_FLAG_READ_ONLY : Activ::IFileMappedMemory
  • FileInfo() : Activ::FileInfo
  • FileType : Activ::LoggerDefinitions
  • FilterType : Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryRequestParameters
  • FindFunction() : Activ::DllFunctionWrapper< NAME, TYPE, THROW_ON_ERROR >
  • FindKey() : Activ::IniFileParser::ConstSectionIterator
  • FindPort()
: Activ::ManagedEndPoint
, Activ::Port
  • FindSection() : Activ::IniFileParser
  • FindServices() : Activ::ServiceApi
  • FindSubSection() : Activ::IniFileParser::ConstSectionIterator
  • FLAG_ALL_EXCHANGE_CODES : Activ::ContentPlatform::ContributionGatewayApi::PermissionInfo
  • FLAG_ALL_TABLE_NUMBERS : Activ::ContentPlatform::ContributionGatewayApi::PermissionInfo
  • FLAG_DELETE
: Activ::ContentPlatform::ContentGatewayApi::NewsUpdate
, Activ::ContentPlatform::ContentGatewayApi::RecordUpdate
, Activ::ContentPlatform::ContributionGatewayApi::PublishRecordBaseParameters
  • FLAG_HISTORY_SERVICE_CHANGED : Activ::ContentPlatform::ContentGatewayApi::ContentGatewayInfo
  • FLAG_IGNORE_ALIAS : Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestParameters
  • FLAG_IMMEDIATE_REFRESH : Activ::ConsoleWindow
  • FLAG_INCLUDE_EXPIRED : Activ::ContentPlatform::ContentGatewayApi::NewsRequestParameters
  • FLAG_MANUAL : Activ::IEvent
  • FLAG_NEWS_SERVER_SERVICE_CHANGED : Activ::ContentPlatform::ContentGatewayApi::ContentGatewayInfo
  • FLAG_NO_AUTOSCROLL : Activ::ConsoleWindow
  • FLAG_NONE
: Activ::ContentPlatform::ContentGatewayApi::ResponseBlock
, Activ::ContentPlatform::ContributionGatewayApi::PublishRecordBaseParameters
, Activ::ContentPlatform::ContributionGatewayApi::PermissionInfo
  • FLAG_REFRESH : Activ::ContentPlatform::ContentGatewayApi::RecordUpdate
  • FLAG_RELATIONSHIP_ID : Activ::ContentPlatform::ContentGatewayApi::RecordUpdate
  • FLAG_REQUEST_KEY : Activ::ContentPlatform::ContentGatewayApi::RecordUpdate
  • FLAG_STALE : Activ::ContentPlatform::ContentGatewayApi::RecordUpdate , Activ::ContentPlatform::ContentGatewayApi::ResponseBlock
  • FLAG_SYMBOL_DIRECTORY_SERVICE_CHANGED : Activ::ContentPlatform::ContentGatewayApi::ContentGatewayInfo
  • Flags
: Activ::ContentPlatform::ContentGatewayApi::NewsRequestParameters
, Activ::ContentPlatform::ContentGatewayApi::RequestBlock
, Activ::ContentPlatform::ContentGatewayApi::ResponseBlock
, Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestParameters
, Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters
, Activ::ContentPlatform::ContentGatewayApi::NewsUpdate
, Activ::ContentPlatform::ContentGatewayApi::SymbolResponse
, Activ::ContentPlatform::ContentGatewayApi::DataPointAddress
, Activ::ContentPlatform::ContributionGatewayApi::PublishRecordBaseParameters
, Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions
, Activ::IEvent
, Activ::ContentPlatform::ContentGatewayApi::ContentGatewayInfo
, Activ::ContentPlatform::Feed::RecordMessageHeaderDefinitions
, Activ::ContentPlatform::Feed::CombinedQuoteMessageHeaderDefinitions
, Activ::ContentPlatform::ContentGatewayApi::RecordUpdate
, Activ::ConsoleWindow
, Activ::ContentPlatform::ContributionGatewayApi::PermissionInfo
  • FLAGS_COMPOSITE_ASK_APPENDAGE_LENGTH : Activ::ContentPlatform::Feed::CombinedQuoteMessageHeaderDefinitions
  • FLAGS_COMPOSITE_ASK_APPENDAGE_OFFSET : Activ::ContentPlatform::Feed::CombinedQuoteMessageHeaderDefinitions
  • FLAGS_COMPOSITE_ASK_LENGTH : Activ::ContentPlatform::Feed::CombinedQuoteMessageHeaderDefinitions
  • FLAGS_COMPOSITE_ASK_OFFSET : Activ::ContentPlatform::Feed::CombinedQuoteMessageHeaderDefinitions
  • FLAGS_COMPOSITE_BID_APPENDAGE_LENGTH : Activ::ContentPlatform::Feed::CombinedQuoteMessageHeaderDefinitions
  • FLAGS_COMPOSITE_BID_APPENDAGE_OFFSET : Activ::ContentPlatform::Feed::CombinedQuoteMessageHeaderDefinitions
  • FLAGS_COMPOSITE_BID_LENGTH : Activ::ContentPlatform::Feed::CombinedQuoteMessageHeaderDefinitions
  • FLAGS_COMPOSITE_BID_OFFSET : Activ::ContentPlatform::Feed::CombinedQuoteMessageHeaderDefinitions
  • FLAGS_DO_NOT_ADD_LENGTH : Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions , Activ::ContentPlatform::Feed::RecordMessageHeaderDefinitions
  • FLAGS_DO_NOT_ADD_OFFSET : Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions , Activ::ContentPlatform::Feed::RecordMessageHeaderDefinitions
  • FLAGS_EXPANDED_FORMAT_LENGTH : Activ::ContentPlatform::Feed::RecordMessageHeaderDefinitions , Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions
  • FLAGS_EXPANDED_FORMAT_OFFSET : Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions , Activ::ContentPlatform::Feed::RecordMessageHeaderDefinitions
  • FLAGS_LENGTH : Activ::ContentPlatform::Feed::MessageHeaderDefinitions
  • FLAGS_OFFSET : Activ::ContentPlatform::Feed::MessageHeaderDefinitions
  • FlagsToString()
: Activ::ContentPlatform::ContentGatewayApi::ResponseBlock
, Activ::ContentPlatform::ContentGatewayApi::NewsUpdate
, Activ::ContentPlatform::ContentGatewayApi::RecordUpdate
  • Flush()
: Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::SymbolRecordMessageBuilder
, Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::RecordMessageBuilder
, Activ::PostMessageHelper
, Activ::IFileMappedMemory
  • ForceDecimalType() : Activ::ContentPlatform::ContentGatewayApi::HistoryBar
  • ForwardMessage() : Activ::Port
  • FromString()
: Activ::Date
, Activ::BinaryString
, Activ::DateTime
, Activ::ContentPlatform::ContentGatewayApi::IntradayBar
, Activ::Time
, Activ::TextArray
, Activ::ContentPlatform::ContentGatewayApi::FieldSet
, Activ::Rational
, Activ::ContentPlatform::ContentGatewayApi::HistoryBar
, Activ::IFieldType
, Activ::UiPermissions
, Activ::SInt
, Activ::CrcBlob
, Activ::IFieldType
, Activ::TextString
, Activ::BinaryArray
, Activ::UInt
, Activ::Blob
, Activ::TRational
, Activ::ContentPlatform::ContentGatewayApi::Tick
  • FromStringSpecial() : Activ::ContentPlatform::ContentGatewayApi::HistoryBar
  • FtpHelper() : Activ::FtpHelper
  • FtpType : Activ::FtpHelper
Generated on Wed Oct 8 14:01:54 2008 for ACTIV C++ SDK by doxygen 1.5.4


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- g -

  • Get()
: Activ::AtomicInteger
, Activ::MessageValidator
, Activ::ScatterBufferHelper
, Activ::Database::FieldListObject
, Activ::Date
, Activ::Time
, Activ::Date
, Activ::Time
, Activ::BinaryArray
, Activ::Date
, Activ::Time
, Activ::DateTime
, Activ::Time
, Activ::TRational
, Activ::ScatterBufferHelper
, Activ::BinaryString
, Activ::DateTime
, Activ::TRational
, Activ::DateTime
, Activ::UInt
, Activ::Blob
, Activ::DateTime
, Activ::LocalTime
, Activ::IpSocket::Stats
, Activ::DateTime
, Activ::HeapMessage::ReadHelper
, Activ::ScatterBufferHelper
, Activ::ThreadSpecificDataBase< TYPE, DERIVED >
, Activ::Blob
, Activ::DateTime
, Activ::HeapMessage::ReadHelper
, Activ::HeapMessage::WriteHelper
, Activ::DateTime
, Activ::HeapMessage
, Activ::CrcBlob
, Activ::Rational
, Activ::HeapMessage
, Activ::Rational
, Activ::HeapMessage
, Activ::HeapPool
, Activ::Database::FieldListObject
, Activ::CrcBlob
, Activ::SInt
, Activ::RequestId
, Activ::Subject
, Activ::SInt
, Activ::DynamicLibraryLoader< T >
, Activ::ReferenceCounter
, Activ::Date
, Activ::TextArray
, Activ::ObjectPool< T, INITIAL_FREE_LIST_SIZE, MAX_FREE_LIST_SIZE >
, Activ::TextString
  • GET_BUFFERS_RESULT_CLOSE_SOCKET : Activ::IpSocket
  • GET_BUFFERS_RESULT_NO_MORE_BUFFERS : Activ::IpSocket
  • GetActivFieldType()
: Activ::ContentPlatform::FeedApi::FieldListValidator::Field
, Activ::ContentPlatform::FeedApi::FieldListValidator
, Activ::Database::FieldSpecification
, Activ::ContentPlatform::FeedApi::FieldListValidator::Field
  • GetAddress()
: Activ::UiIo
, Activ::Port
  • GetAmfFieldIndex() : Activ::ContentPlatform::Feed::Field
  • GetAmfRecordSize() : Activ::ContentPlatform::Feed::TableTemplate
  • GetAmfRowIndex() : Activ::ContentPlatform::Feed::Field
  • GetAmfRowOffset() : Activ::ContentPlatform::Feed::Field
  • GetAmfTableId() : Activ::ContentPlatform::Feed::TableTemplate
  • GetAndDeleteFile()
: Activ::CurlFtpHelper
, Activ::FtpHelper
, Activ::IFtpHelper
  • GetApiInfo()
: Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
, Activ::ContentPlatform::ContentServerApi::ContentServerClient
, Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient
, Activ::ContentPlatform::ContributionServerApi::ContributionServerClient
  • GetApplication() : Activ::Component
  • GetAskPrice() : Activ::ContentPlatform::ContentGatewayApi::OptionBar
  • GetAttributes() : Activ::RequestId
  • GetBasicFileName() : Activ::Database::ITable
  • GetBidPrice() : Activ::ContentPlatform::ContentGatewayApi::OptionBar
  • GetBinary() : Activ::Uuid
  • GetBooleanValue()
: Activ::IniFileParser::ConstKeyIterator
, Activ::IniFileParser::ConstSectionIterator
, Activ::IniFileParser
  • GetBufferSize()
: Activ::ConsoleWindow
, Activ::MessageBuilder
  • GetBuffersResult : Activ::IpSocket
  • GetBuyerId() : Activ::ContentPlatform::ContentGatewayApi::Tick
  • GetCacheSize() : Activ::ContentPlatform::Feed::TableTemplate
  • GetCapacity() : Activ::HeapMessage
  • GetChar() : Activ::UiIo
  • GetClosePrice()
: Activ::ContentPlatform::ContentGatewayApi::HistoryBar
, Activ::ContentPlatform::ContentGatewayApi::IntradayBar
  • GetCodeIdentifier()
: Activ::ContentPlatform::Feed::Field
, Activ::ContentPlatform::Feed::TableTemplate
  • GetCompositeAskState() : Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator
  • GetCompositeBidState() : Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator
  • GetCompositeFieldRules() : Activ::ContentPlatform::Feed::SymbolRecordField
  • GetCompositeUpdateId()
: Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator
, Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator
, Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator
, Activ::ContentPlatform::Feed::SymbolRecordMessageValidator
  • GetCompressedCompositeAskState() : Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageDefinitions
  • GetCompressedNumeratorLength() : Activ::ContentPlatform::Feed::CompressedMessageDefinitions
  • GetCompressedUpdateId() : Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageDefinitions
  • GetConditions() : Activ::ContentPlatform::ContentGatewayApi::Tick
  • GetConfirmation() : Activ::UiIo
  • GetContentGatewayInfo() : Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
  • GetContentionCount() : Activ::IMutex
  • GetContributionGatewayInfo() : Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient
  • GetCrc() : Activ::CrcBlob
  • GetCrcCompressed() : Activ::CrcBlob
  • GetCrcDecompressed() : Activ::CrcBlob
  • GetCreationDateTime() : Activ::File
  • GetCreatorProcessId() : Activ::ISyncEndPoint
  • GetCurrent()
: Activ::UtcTime
, Activ::LocalTime
  • GetCurrentId()
: Activ::Process
, Activ::Thread
  • GetCurrentLocalDate() : Activ::TimerServiceApi
  • GetCurrentLocalDateTime() : Activ::TimerServiceApi
  • GetCurrentLocalTime() : Activ::TimerServiceApi
  • GetCurrentRecords()
: Activ::Database::IIndex
, Activ::Database::ITable
  • GetCurrentUtcDate() : Activ::TimerServiceApi
  • GetCurrentUtcDateTime() : Activ::TimerServiceApi
  • GetCurrentUtcTime() : Activ::TimerServiceApi
  • GetCursorPosition() : Activ::ConsoleWindow
  • GetData()
: Activ::BinaryArray
, Activ::BinaryString
, Activ::Blob
, Activ::CrcBlob
, Activ::TextArray
, Activ::TextString
, Activ::SerializableBuffer< LENGTH_TYPE, MIN_LENGTH, MAX_LENGTH >
  • GetDatabaseFieldType() : Activ::Database::FieldSpecification
  • GetDataCompressed()
: Activ::Blob
, Activ::CrcBlob
  • GetDataDecompressed()
: Activ::Blob
, Activ::CrcBlob
  • GetDataLength()
: Activ::Database::FieldList
, Activ::Database::Key
, Activ::Database::Record
, Activ::SerializableBuffer< LENGTH_TYPE, MIN_LENGTH, MAX_LENGTH >
  • GetDataPointAddress() : Activ::ContentPlatform::ContentGatewayApi::TimeSeriesCookie
  • GetDate()
: Activ::ContentPlatform::ContentGatewayApi::HistoryBar
, Activ::ContentPlatform::ContentGatewayApi::OptionBar
, Activ::DateTime
  • GetDateTime()
: Activ::ContentPlatform::ContentGatewayApi::HistoryBar
, Activ::ContentPlatform::ContentGatewayApi::IntradayBar
, Activ::ContentPlatform::ContentGatewayApi::Tick
  • GetDay()
: Activ::Date
, Activ::DateTime
, Activ::BaseTime
  • GetDayOfWeek()
: Activ::Date
, Activ::DateTime
, Activ::BaseTime
  • GetDayOfYear()
: Activ::Date
, Activ::DateTime
  • GetDaysInMonth() : Activ::Date
  • GetDecimalPlaces() : Activ::Rational::DenominatorType
  • GetDefaultName() : Activ::ContentPlatform::ContributionServerApi::ContributionServerClient
  • GetDefaultRuleSet()
: Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator
, Activ::ContentPlatform::Feed::SymbolRecordMessageValidator
  • GetDenominator()
: Activ::ContentPlatform::ContentGatewayApi::OptionBar
, Activ::Rational
, Activ::TRational
  • GetDenominatorByBinaryPower() : Activ::Rational
  • GetDenominatorByDecimalPlaces() : Activ::Rational
  • GetDenominatorByDecimalPower() : Activ::Rational
  • GetDenominatorByDivisor() : Activ::Rational
  • GetDenominatorByMultiplier() : Activ::Rational
  • GetDenominatorByMultiplierPower() : Activ::Rational
  • GetDenominatorType() : Activ::Rational
  • GetDescription() : Activ::ContentPlatform::Feed::Field
  • GetDestinationAddress() : Activ::HeapMessage
  • GetDirectory() : Activ::Database::ITable
  • GetDirectorySeparator() : Activ::File
  • GetDisabledDateSet() : Activ::Timeband
  • GetDisabledDateSetString() : Activ::Timeband
  • GetDisplaySize() : Activ::ConsoleWindow
  • GetDivisor() : Activ::Rational::DenominatorType
  • GetDivisorDigits() : Activ::Rational::DenominatorType
  • GetDouble() : Activ::Rational
  • GetEnabledDateFlag() : Activ::Timeband
  • GetEnabledDateFlagString() : Activ::Timeband
  • GetEnabledDaysString() : Activ::Timeband
  • GetEndOfLine() : Activ::File
  • GetEndPoint() : Activ::ManagedEndPoint
  • GetEndPointId() : Activ::Address
  • GetEndTime() : Activ::Timeband
  • GetEqual()
: Activ::Database::Database
, Activ::Database::ITable
  • GetError()
: Activ::ContentPlatform::Feed::TableTemplate
, Activ::ContentPlatform::Feed::TableTemplateList
, Activ::ContentPlatform::Feed::UniversalFieldList
  • GetEventType()
: Activ::ContentPlatform::ContentServerApi::RecordUpdateHelper< MESSAGE_VALIDATOR >
, Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator
, Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator
, Activ::ContentPlatform::Feed::RecordMessageHeaderValidator
, Activ::ContentPlatform::Feed::RecordMessageValidator
, Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator
, Activ::ContentPlatform::Feed::SymbolRecordMessageValidator
  • GetExchange() : Activ::ContentPlatform::ContentGatewayApi::Tick
  • GetExpirationDate() : Activ::ContentPlatform::ContentGatewayApi::OptionBar
  • GetExtensionFunction() : Activ::IpManager
  • GetField()
: Activ::ContentPlatform::ContentGatewayApi::FieldSet
, Activ::ContentPlatform::ContentGatewayApi::HistoryBar
, Activ::ContentPlatform::ContentGatewayApi::IntradayBar
, Activ::ContentPlatform::ContentGatewayApi::OptionBar
, Activ::ContentPlatform::ContentGatewayApi::Tick
, Activ::ContentPlatform::FeedApi::FieldListValidator::ConstIterator
, Activ::ContentPlatform::FeedApi::FieldListValidator
, Activ::ContentPlatform::Feed::RecordFieldListValidator::ConstIterator
, Activ::ContentPlatform::Feed::RecordFieldListValidator
, Activ::ContentPlatform::Feed::RecordKeyFieldListValidator::ConstIterator
, Activ::ContentPlatform::Feed::RecordKeyFieldListValidator
, Activ::ContentPlatform::Feed::RecordMessageValidator
, Activ::ContentPlatform::Feed::SymbolRecordField
, Activ::ContentPlatform::Feed::TableTemplate::ConstFieldIterator
, Activ::ContentPlatform::Feed::TableTemplate
, Activ::Database::FieldList
, Activ::Database::FieldListObject
  • GetFieldContents() : Activ::ContentPlatform::ContributionGatewayApi::PublishField
  • GetFieldDefinition() : Activ::Database::FieldList
  • GetFieldHeader()
: Activ::ContentPlatform::Feed::FieldHeaderDefinitions
, Activ::ContentPlatform::Feed::SymbolRecordFieldHeaderDefinitions
  • GetFieldId()
: Activ::ContentPlatform::FeedApi::FieldListValidator::ConstIterator
, Activ::ContentPlatform::Feed::FieldHeaderDefinitions
, Activ::ContentPlatform::Feed::RecordFieldListValidator::ConstIterator
, Activ::ContentPlatform::Feed::RecordKeyFieldListValidator::ConstIterator
, Activ::ContentPlatform::Feed::SymbolRecordFieldListValidator::ConstIterator
, Activ::ContentPlatform::Feed::TableTemplateFieldListValidator::ConstIterator
, Activ::ContentPlatform::Feed::TableTemplate::ConstFieldIterator
, Activ::ContentPlatform::Feed::TableTemplate::ConstRuleIterator
  • GetFieldIdList()
: Activ::Database::FieldList
, Activ::Database::FieldListObject
, Activ::Database::IIndex
, Activ::Database::ITable
  • GetFieldLength() : Activ::Database::FieldList
  • GetFieldList()
: Activ::Database::FieldListObject
, Activ::Database::IIndex
, Activ::Database::ITable
  • GetFieldNumber() : Activ::Database::FieldList
  • GetFieldRules()
: Activ::ContentPlatform::Feed::SymbolRecordField
, Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::TranslatorRuleSet
, Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ContentServerRuleSet
  • GetFieldSpecification()
: Activ::Database::FieldList
, Activ::Database::FieldListObject
, Activ::Database::ITable
  • GetFieldSpecificationList()
: Activ::Database::FieldList
, Activ::Database::FieldListObject
, Activ::Database::IIndex
, Activ::Database::ITable
  • GetFieldType() : Activ::UiIo
  • GetFile()
: Activ::CurlFtpHelper
, Activ::FtpHelper
, Activ::IFtpHelper
  • GetFileList()
: Activ::CurlFtpHelper
, Activ::FtpHelper
, Activ::IFtpHelper
  • GetFileName()
: Activ::File
, Activ::UiIo
  • GetFirst() : Activ::Database::ITable
  • GetFirstBuffer() : Activ::WsaBufHelper
  • GetFirstField() : Activ::ContentPlatform::Feed::TableTemplate
  • GetFirstFieldId()
: Activ::Database::FieldList
, Activ::Database::FieldListObject
, Activ::Database::ITable
  • GetFirstFieldSpecification()
: Activ::Database::FieldList
, Activ::Database::ITable
  • GetFirstIndex() : Activ::ContentPlatform::Feed::TableTemplate
  • GetFirstPartial() : Activ::Database::ITable
  • GetFirstTableTemplate() : Activ::ContentPlatform::Feed::TableTemplateList
  • GetFlag() : Activ::ContentPlatform::ContentGatewayApi::IntradayBar
  • GetFlags()
: Activ::ContentPlatform::Feed::CombinedQuoteMessageHeaderDefinitions
, Activ::ContentPlatform::Feed::MessageHeaderDefinitions
, Activ::ContentPlatform::Feed::RecordMessageHeaderDefinitions
, Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions
  • GetFrequency() : Activ::IntervalTimer
  • GetFromIniFile()
: Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::Settings
, Activ::ContentPlatform::Feed::TableTemplateList::Settings
  • GetFromStringFormat()
: Activ::BinaryArray
, Activ::BinaryString
, Activ::Blob
, Activ::CrcBlob
, Activ::Date
, Activ::DateTime
, Activ::IFieldType
, Activ::Rational
, Activ::SInt
, Activ::TextArray
, Activ::TextString
, Activ::Time
, Activ::TRational
, Activ::UInt
  • GetHandle()
: Activ::File
, Activ::IEvent
, Activ::TcpListener
  • GetHeader() : Activ::ContentPlatform::Feed::CompressedMessageDefinitions
  • GetHeap() : Activ::Port
  • GetHeapId() : Activ::HeapMessage
  • GetHeapMessage() : Activ::HeapMessageBuilder
  • GetHighPrice()
: Activ::ContentPlatform::ContentGatewayApi::HistoryBar
, Activ::ContentPlatform::ContentGatewayApi::IntradayBar
  • GetHostAndPort() : Activ::IpManager
  • GetHostName() : Activ::IpManager
  • GetHostname() : Activ::SmtpHelper
  • GetHostsFileEntries() : Activ::IpManager
  • GetHour()
: Activ::DateTime
, Activ::Time
, Activ::BaseTime
  • GetId()
: Activ::ContentPlatform::Feed::Field
, Activ::ContentPlatform::Feed::TableTemplate
, Activ::Thread
, Activ::Database::FieldList::ConstIterator
, Activ::Database::FieldListObject
, Activ::ISyncEndPoint
, Activ::IHeap
, Activ::IProcess
  • GetIdentity() : Activ::Database::ITable
  • GetIndex() : Activ::ContentPlatform::Feed::TableTemplate
  • GetIndexNumber()
: Activ::ContentPlatform::ContentServerApi::RecordUpdate
, Activ::ContentPlatform::Feed::RecordMessageHeaderValidator
, Activ::ContentPlatform::Feed::RecordMessageValidator
, Activ::Database::Key
  • GetIndexPointer()
: Activ::Database::ITable
, Activ::Database::Key
  • GetIndexSpecification()
: Activ::Database::ITable
, Activ::Database::Key
  • GetIndexSpecificationList() : Activ::Database::ITable
  • GetInfinite() : Activ::Timeout
  • GetIniFileParser() : Activ::LicenseServiceApi
  • GetInitialMaxRecords() : Activ::ContentPlatform::Feed::TableTemplate
  • GetInstance()
: Activ::FileMappedMemoryFactory
, Activ::PagingFileMappedMemoryFactory
, Activ::PrivateEventFactory
, Activ::PrivateMutexFactory
, Activ::PrivateSemaphoreFactory
, Activ::SharedEventFactory
, Activ::SharedMutexFactory
, Activ::SharedSemaphoreFactory
, Activ::Database::ManagedTableFactory
, Activ::Database::RemoteTableFactory
, Activ::Database::UnmanagedTableFactory
, Activ::FieldTypeFactory
, Activ::SystemFactory
, Activ::ObjectPool< T, INITIAL_FREE_LIST_SIZE, MAX_FREE_LIST_SIZE >
  • GetInterfaceIndex() : Activ::IpAddress
  • GetInterfaceInfoList() : Activ::IpManager
  • GetIpAddress()
: Activ::UiIo
, Activ::IpManager
, Activ::HeapMessage
  • GetJulianDate() : Activ::DateTime
  • GetJulianTime()
: Activ::DateTime
, Activ::BaseTime
  • GetKey() : Activ::Database::Record
  • GetKeyBlock()
: Activ::Des3Helper::Key
, Activ::DesHelper::Key
  • GetKeyField()
: Activ::ContentPlatform::Feed::RecordMessageHeaderValidator
, Activ::ContentPlatform::Feed::RecordMessageValidator
  • GetKeyLength() : Activ::Database::IIndex
  • GetKeySchedule()
: Activ::Des3Helper::Key
, Activ::DesHelper::Key
  • GetLast() : Activ::Database::ITable
  • GetLastAccessDateTime() : Activ::File
  • GetLastPartial() : Activ::Database::ITable
  • GetLastWriteDateTime() : Activ::File
  • GetLatestTableTemplate() : Activ::ContentPlatform::Feed::TableTemplateList
  • GetLatestTableTemplateId() : Activ::ContentPlatform::Feed::TableTemplateList
  • GetLength()
: Activ::MessageBuilder
, Activ::MessageValidator
, Activ::HeapMessage::ReadHelper
, Activ::HeapMessage::WriteHelper
, Activ::HeapMessage
, Activ::RequestId
, Activ::Subject
  • GetLocal()
: Activ::DateTime
, Activ::Time
  • GetLocalAddress()
: Activ::IpSocket
, Activ::TcpListener
  • GetLocalIpAddressList() : Activ::IpManager
  • GetLowestCommonDenominator() : Activ::Rational
  • GetLowPrice()
: Activ::ContentPlatform::ContentGatewayApi::HistoryBar
, Activ::ContentPlatform::ContentGatewayApi::IntradayBar
  • GetManagedEndPoint() : Activ::Port
  • GetMatchingFieldsById() : Activ::Database::FieldListObject
  • GetMatchingFieldsByName() : Activ::Database::FieldListObject
  • GetMaximumTableNumber() : Activ::ContentPlatform::ContributionServerApi::ContributionServerClient
  • GetMaxLength()
: Activ::ContentPlatform::Feed::TableTemplateField
, Activ::ContentPlatform::Feed::Field
  • GetMaxNumber() : Activ::ContentPlatform::Feed::TableTemplate
  • GetMaxRecords() : Activ::Database::ITable
  • GetMaxSerializedBodyLength()
: Activ::BinaryArray
, Activ::BinaryString
, Activ::Blob
, Activ::CrcBlob
, Activ::Date
, Activ::DateTime
, Activ::Rational
, Activ::SInt
, Activ::TextArray
, Activ::TextString
, Activ::Time
, Activ::TRational
, Activ::UInt
  • GetMaxSerializedLength()
: Activ::Rational
, Activ::ContentPlatform::ContentGatewayApi::OptionBar
, Activ::Blob
, Activ::ContentPlatform::ContentGatewayApi::FieldSet
, Activ::ContentPlatform::ContentGatewayApi::HistoryBar
, Activ::ContentPlatform::ContentGatewayApi::IntradayBar
, Activ::ContentPlatform::ContentGatewayApi::Tick
, Activ::BinaryArray
, Activ::BinaryString
, Activ::CrcBlob
, Activ::Date
, Activ::DateTime
, Activ::SInt
, Activ::TextArray
, Activ::TextString
, Activ::Time
, Activ::TRational
, Activ::UInt
  • GetMaxThreads() : Activ::ManagedEndPoint
  • GetMaxValue() : Activ::BitField< T, OFFSET_VALUE, LENGTH_VALUE >
  • GetMaxVersion() : Activ::ContentPlatform::Feed::TableTemplate
  • GetMessage()
: Activ::IHeap
, Activ::HeapPool
, Activ::MessageBuilder
, Activ::MessageValidator
, Activ::IEndPoint
, Activ::IHeap
  • GetMessageBuilder() : Activ::HeapMessageBuilder
  • GetMessageFromList() : Activ::IHeap
  • GetMessageHeader()
: Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions
, Activ::ContentPlatform::Feed::CombinedQuoteMessageHeaderDefinitions
, Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderDefinitions
, Activ::ContentPlatform::Feed::CompressedMessageHeaderDefinitions
, Activ::ContentPlatform::Feed::MessageHeaderDefinitions
, Activ::ContentPlatform::Feed::RecordMessageHeaderDefinitions
, Activ::ContentPlatform::Feed::TableTemplateMessageHeaderDefinitions
  • GetMessageRate() : Activ::MessageRateThrottler
  • GetMessages() : Activ::IEndPoint
  • GetMessageStatsList() : Activ::ContentPlatform::ContentServerApi::ContentServerClient
  • GetMessageType() : Activ::ContentPlatform::Feed::MessageHeaderDefinitions
  • GetMessageVersion() : Activ::MessageHandler
  • GetMidnight() : Activ::LocalTime
  • GetMillisecond()
: Activ::DateTime
, Activ::Time
, Activ::BaseTime
  • GetMinimumTableNumber() : Activ::ContentPlatform::ContributionServerApi::ContributionServerClient
  • GetMinute()
: Activ::DateTime
, Activ::Time
, Activ::BaseTime
  • GetMode()
: Activ::Database::ITable
, Activ::Database::Database
  • GetMonitorServiceHeap() : Activ::Application
  • GetMonth()
: Activ::BaseTime
, Activ::Date
, Activ::DateTime
  • GetMultiplier() : Activ::Rational::DenominatorType
  • GetMultiplierPower() : Activ::Rational::DenominatorType
  • GetName()
: Activ::ContentPlatform::Feed::Field
, Activ::ContentPlatform::Feed::TableTemplate
, Activ::IniFileParser::ConstKeyIterator
, Activ::IniFileParser::ConstSectionIterator
, Activ::Database::Database
, Activ::Database::FieldList::ConstIterator
, Activ::Database::IIndex
, Activ::UiMenu
, Activ::ISyncEndPoint
, Activ::IHeap
, Activ::Port
, Activ::Database::ITable
, Activ::IProcess
, Activ::ContentPlatform::Feed::TableTemplateMessageValidator
, Activ::ContentPlatform::Feed::TableTemplateIndex
  • GetNext() : Activ::Database::ITable
  • GetNextField() : Activ::ContentPlatform::Feed::TableTemplate
  • GetNextFieldId()
: Activ::Database::FieldList
, Activ::Database::FieldListObject
, Activ::Database::ITable
  • GetNextFieldSpecification()
: Activ::Database::FieldList
, Activ::Database::ITable
  • GetNextIndex() : Activ::ContentPlatform::Feed::TableTemplate
  • GetNextPartial() : Activ::Database::ITable
  • GetNextTableTemplate() : Activ::ContentPlatform::Feed::TableTemplateList
  • GetNotificationHandle() : Activ::IEndPoint
  • GetNumber()
: Activ::ContentPlatform::Feed::TableTemplateIndex
, Activ::ContentPlatform::Feed::TableTemplate
, Activ::Database::IIndex
, Activ::ContentPlatform::Feed::TableTemplate
  • GetNumberOfBuffersInUse() : Activ::WsaBufHelper
  • GetNumberOfBytes() : Activ::IoCompletionManager::Overlapped
  • GetNumberOfFieldHeaders() : Activ::ContentPlatform::Feed::CompressedMessageDefinitions::FieldSpecification
  • GetNumberOfFields()
: Activ::ContentPlatform::FeedApi::FieldListValidator
, Activ::Database::FieldList
  • GetNumberOfGrowRecords() : Activ::ContentPlatform::Feed::TableTemplate
  • GetNumberOfIndexes() : Activ::Database::ITable
  • GetNumberOfKeyFields() : Activ::ContentPlatform::ContentServerApi::RecordUpdate
  • GetNumberOfPurgeDays() : Activ::ContentPlatform::Feed::TableTemplate
  • GetNumberOfScatterBuffersInUse() : Activ::ScatterBufferHelper
  • GetNumberOfTables() : Activ::Database::Database
  • GetNumerator()
: Activ::Rational
, Activ::TRational
  • GetNumeratorAndDenominator() : Activ::TRational
  • GetNumeratorAndDivisor()
: Activ::Rational
, Activ::TRational
  • GetNumeratorLength() : Activ::ContentPlatform::Feed::CompressedMessageDefinitions
  • GetOffset()
: Activ::MessageValidator
, Activ::HeapMessage::ReadHelper
, Activ::HeapMessage::WriteHelper
  • GetOpenInterest()
: Activ::ContentPlatform::ContentGatewayApi::HistoryBar
, Activ::ContentPlatform::ContentGatewayApi::OptionBar
  • GetOpenPrice()
: Activ::ContentPlatform::ContentGatewayApi::HistoryBar
, Activ::ContentPlatform::ContentGatewayApi::IntradayBar
, Activ::ContentPlatform::ContentGatewayApi::HistoryBar
  • GetOsId() : Activ::IProcess
  • GetPartialBitUpdateList() : Activ::ContentPlatform::Feed::SymbolRecordField
  • GetPeriodLeft() : Activ::Timeout
  • GetPeriodLength() : Activ::MessageRateThrottler
  • GetPermissionId()
: Activ::ContentPlatform::ContentServerApi::RecordUpdateHelper< MESSAGE_VALIDATOR >
, Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator
, Activ::ContentPlatform::Feed::RecordMessageHeaderValidator
, Activ::ContentPlatform::Feed::RecordMessageValidator
, Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator
, Activ::ContentPlatform::Feed::SymbolRecordMessageValidator
, Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator
  • GetPermissionInfo()
: Activ::ContentPlatform::ContentGatewayApi::MetaDataRequestHelper
, Activ::ContentPlatform::ContentServerApi::ContentServerClient
, Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient
  • GetPointer()
: Activ::IMappedMemory
, Activ::SharedObject< T >
  • GetPort() : Activ::IpAddress
  • GetPortId() : Activ::Address
  • GetPosition() : Activ::File
  • GetPrevious() : Activ::Database::ITable
  • GetPreviousPartial() : Activ::Database::ITable
  • GetPrice() : Activ::ContentPlatform::ContentGatewayApi::Tick
  • GetPrimaryIndexNumber() : Activ::Database::ITable
  • GetPrimaryKey() : Activ::Database::Record
  • GetPriority() : Activ::Thread
  • GetPrivate() : Activ::Application
  • GetProcess()
: Activ::ISystem
, Activ::SystemProxy
  • GetProperties() : Activ::ContentPlatform::Feed::TableTemplateIndex
  • GetRandomConfirmation() : Activ::UiIo
  • GetRational() : Activ::TRational
  • GetRealValue()
: Activ::IniFileParser
, Activ::IniFileParser::ConstKeyIterator
, Activ::IniFileParser::ConstSectionIterator
  • GetRealValueList()
: Activ::IniFileParser::ConstKeyIterator
, Activ::IniFileParser::ConstSectionIterator
, Activ::IniFileParser
  • GetRecordLength() : Activ::Database::ITable
  • GetRecordMessageBuilder() : Activ::ContentPlatform::ContributionServerApi::ContributionServerClient
  • GetRelationshipInfoList() : Activ::ContentPlatform::ContentGatewayApi::MetaDataRequestHelper
  • GetRemoteAddress() : Activ::IpSocket
  • GetRequestDistributionLogging() : Activ::IHeap
  • GetRequestId()
: Activ::SyncRequestId
, Activ::HeapMessage
  • GetResetType() : Activ::ContentPlatform::Feed::TableTemplate
  • GetResponse()
: Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestHelper< MESSAGE_TYPE_VALUE, REQUEST_PARAMETERS >
, Activ::ContentPlatform::ContentGatewayApi::NewsRequestHelper
, Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryRequestHelper
, Activ::SyncRequestId
, Activ::ContentPlatform::ContributionGatewayApi::PublishRequestHelper< MESSAGE_TYPE_VALUE, REQUEST_PARAMETERS, RESPONSE_PARAMETERS >
  • GetResponseAddress() : Activ::RequestId
  • GetReturnAddress() : Activ::HeapMessage
  • GetRule()
: Activ::ContentPlatform::Feed::TableTemplate::ConstRuleIterator
, Activ::ContentPlatform::Feed::TableTemplate
  • GetRules() : Activ::ContentPlatform::ContributionGatewayApi::PublishSymbolRecordParameters::Field
  • GetRuleSet()
: Activ::ContentPlatform::ContributionGatewayApi::PublishSymbolRecordParameters::Field
, Activ::ContentPlatform::Feed::SymbolRecordField
  • GetSearchOrder() : Activ::Database::Database
  • GetSecond()
: Activ::Time
, Activ::BaseTime
, Activ::DateTime
  • GetSectionName()
: Activ::LicenseServiceApi
, Activ::IniFileParser
  • GetSellerId() : Activ::ContentPlatform::ContentGatewayApi::Tick
  • GetSequence() : Activ::ContentPlatform::ContentGatewayApi::FieldSet
  • GetSerializedBodyLength()
: Activ::BinaryString
, Activ::IFieldType
, Activ::Rational
, Activ::Blob
, Activ::CrcBlob
, Activ::Date
, Activ::DateTime
, Activ::TextArray
, Activ::Time
, Activ::TRational
, Activ::BinaryArray
, Activ::DateTime
, Activ::TextString
, Activ::UInt
, Activ::Time
, Activ::SInt
  • GetSerializedLength()
: Activ::UInt
, Activ::ContentPlatform::ContentGatewayApi::Tick
, Activ::IFieldType
, Activ::ContentPlatform::ContentGatewayApi::IntradayBar
, Activ::ContentPlatform::ContentGatewayApi::OptionBar
, Activ::BinaryString
, Activ::DateTime
, Activ::SInt
, Activ::Time
, Activ::TRational
, Activ::Subject
, Activ::DateTime
, Activ::TextArray
, Activ::CrcBlob
, Activ::Address
, Activ::Blob
, Activ::TextString
, Activ::Time
, Activ::Rational
, Activ::Date
, Activ::BinaryArray
, Activ::ContentPlatform::ContentGatewayApi::FieldSet
, Activ::ContentPlatform::ContentGatewayApi::HistoryBar
  • GetSerializedTrend() : Activ::TRational::SerializedTrendDefinitions
  • GetServiceInstance() : Activ::Service
  • GetServiceLocation()
: Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient
, Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
  • GetSettings()
: Activ::IpManager
, Activ::ContentPlatform::ContributionServerApi::ContributionServerClient
  • GetShifted() : Activ::BitField< T, OFFSET_VALUE, LENGTH_VALUE >
  • GetShortTableNumber() : Activ::ContentPlatform::Feed::CompressedMessageDefinitions
  • GetSignedIntegral() : Activ::UiIo
  • GetSignedValue()
: Activ::IniFileParser::ConstSectionIterator
, Activ::IniFileParser
, Activ::IniFileParser::ConstKeyIterator
  • GetSignedValueList()
: Activ::IniFileParser::ConstKeyIterator
, Activ::IniFileParser
, Activ::IniFileParser::ConstSectionIterator
  • GetSize()
: Activ::File
, Activ::IMappedMemory
, Activ::BinaryArray
, Activ::TextArray
, Activ::TextString
, Activ::ContentPlatform::ContentGatewayApi::Tick
, Activ::Blob
, Activ::CrcBlob
, Activ::SharedObject< T >
, Activ::ContentPlatform::ContentGatewayApi::Tick
, Activ::BinaryString
, Activ::ContentPlatform::Feed::TableTemplateList
, Activ::File
  • GetSizeCompressed()
: Activ::CrcBlob
, Activ::Blob
  • GetSizeDecompressed()
: Activ::Blob
, Activ::CrcBlob
  • GetSizeWhenDecompressed()
: Activ::Blob
, Activ::CrcBlob
  • GetSocketHandle()
: Activ::RouterServiceApi::Udp
, Activ::IpSocket
, Activ::UdpComponent
  • GetSocketOption() : Activ::IpSocket
  • GetSourceAddress() : Activ::HeapMessage
  • GetSpecification()
: Activ::Database::IIndex
, Activ::Database::FieldList::ConstIterator
, Activ::Database::Database
  • GetStartTime() : Activ::Timeband
  • GetState()
: Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient
, Activ::IEndPoint
, Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
, Activ::TcpListener
, Activ::IProcess
  • GetStats()
: Activ::IHeap
, Activ::ISyncEndPoint
, Activ::IProcess
, Activ::IEndPoint
, Activ::SystemMonitor
, Activ::ObjectPool< T, INITIAL_FREE_LIST_SIZE, MAX_FREE_LIST_SIZE >
  • GetStatusCode() : Activ::HeapMessage
  • GetStrikePrice() : Activ::ContentPlatform::ContentGatewayApi::OptionBar
  • GetString() : Activ::UiIo
  • GetStringValue()
: Activ::IniFileParser::ConstKeyIterator
, Activ::IniFileParser
, Activ::IniFileParser::ConstSectionIterator
  • GetStringValueList()
: Activ::IniFileParser
, Activ::IniFileParser::ConstSectionIterator
, Activ::IniFileParser::ConstKeyIterator
  • GetSubject() : Activ::HeapMessage
  • GetSubName() : Activ::IniFileParser::ConstSectionIterator
  • GetSubscriptionInfo() : Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
  • GetSubscriptions() : Activ::PubSubServiceApi
  • GetSymbol()
: Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator
, Activ::ContentPlatform::ContentServerApi::SymbolRecordUpdate
, Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator
, Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator
, Activ::ContentPlatform::Feed::SymbolRecordMessageValidator
  • GetSymbolId() : Activ::ContentPlatform::ContentGatewayApi::TimeSeriesCookie
  • GetSymbolRecordField()
: Activ::ContentPlatform::Feed::SymbolRecordFieldListValidator
, Activ::ContentPlatform::Feed::SymbolRecordFieldListValidator::ConstIterator
, Activ::ContentPlatform::Feed::SymbolRecordMessageValidator
  • GetSymbolRecordMessageBuilder() : Activ::ContentPlatform::ContributionServerApi::ContributionServerClient
  • GetSystem()
: Activ::IEndPoint
, Activ::IHeap
, Activ::IProcess
  • GetSystemHeap()
: Activ::SystemProxy
, Activ::ISystem
  • GetSystemInfo()
: Activ::SystemProxy
, Activ::ISystem
  • GetSystemName()
: Activ::ISystem
, Activ::SystemProxy
  • GetTable()
: Activ::Database::Database
, Activ::Database::Database::ConstIterator
, Activ::Database::Database::Iterator
  • GetTableId()
: Activ::ContentPlatform::Feed::TableTemplateMessageValidator
, Activ::ContentPlatform::Feed::TableTemplateList::ConstIterator
, Activ::Database::Database::Iterator
, Activ::Database::Database::ConstIterator
  • GetTableIdList() : Activ::Database::Database
  • GetTableInfoList() : Activ::ContentPlatform::ContentGatewayApi::MetaDataRequestHelper
  • GetTableNumber()
: Activ::ContentPlatform::ContentServerApi::RecordUpdateHelper< MESSAGE_VALIDATOR >
, Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator
, Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator
  • GetTablePointer() : Activ::Database::FieldListObject
  • GetTableSpecification()
: Activ::Database::ITable
, Activ::ContentPlatform::ContentGatewayApi::MetaDataRequestHelper
  • GetTableTemplate()
: Activ::ContentPlatform::Feed::RecordMessageHeaderValidator
, Activ::ContentPlatform::Feed::TableTemplateList::ConstIterator
, Activ::ContentPlatform::Feed::TableTemplateList
, Activ::ContentPlatform::Feed::SymbolRecordMessageValidator
, Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator
, Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator
, Activ::ContentPlatform::Feed::RecordMessageValidator
, Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator
  • GetTableTemplateField()
: Activ::ContentPlatform::Feed::TableTemplateFieldListValidator
, Activ::ContentPlatform::Feed::TableTemplateMessageValidator
, Activ::ContentPlatform::Feed::TableTemplateFieldListValidator::ConstIterator
  • GetTableTemplateIndex()
: Activ::ContentPlatform::Feed::TableTemplateMessageValidator
, Activ::ContentPlatform::Feed::TableTemplateIndexListValidator
  • GetTableTemplateList() : Activ::ContentPlatform::ContributionServerApi::ContributionServerClient
  • GetTemporaryPath() : Activ::File
  • GetThreadPriority() : Activ::Thread
  • GetTick()
: Activ::TRational::SerializedTrendDefinitions
, Activ::TRational
  • GetTickCount()
: Activ::ContentPlatform::ContentGatewayApi::IntradayBar
, Activ::IntervalTimer
  • GetTickType() : Activ::ContentPlatform::ContentGatewayApi::Tick
  • GetTime() : Activ::DateTime
  • GetTimeout() : Activ::CurlFtpHelper
  • GetTimeStamp() : Activ::IntervalTimer
  • GetTimeZoneOffset()
: Activ::DateTime
, Activ::Time
  • GetTotalBytes()
: Activ::ScatterBufferHelper
, Activ::WsaBufHelper
  • GetTotalMessageStats() : Activ::ContentPlatform::ContentServerApi::ContentServerClient
  • GetTotalMilliseconds()
: Activ::DateTime
, Activ::BaseTime::Duration
, Activ::Time
  • GetTotalPrice()
: Activ::ContentPlatform::ContentGatewayApi::IntradayBar
, Activ::ContentPlatform::ContentGatewayApi::HistoryBar
  • GetTotalValue()
: Activ::ContentPlatform::ContentGatewayApi::HistoryBar
, Activ::ContentPlatform::ContentGatewayApi::IntradayBar
, Activ::ContentPlatform::ContentGatewayApi::HistoryBar
  • GetTotalVolume()
: Activ::ContentPlatform::ContentGatewayApi::IntradayBar
, Activ::ContentPlatform::ContentGatewayApi::HistoryBar
, Activ::ContentPlatform::ContentGatewayApi::OptionBar
, Activ::ContentPlatform::ContentGatewayApi::IntradayBar
, Activ::ContentPlatform::ContentGatewayApi::HistoryBar
  • GetTradeThroughExemptFlag() : Activ::ContentPlatform::ContentGatewayApi::Tick
  • GetTrendOnDay()
: Activ::TRational::SerializedTrendDefinitions
, Activ::TRational
  • GetTrendOnPrevious()
: Activ::TRational::SerializedTrendDefinitions
, Activ::TRational
  • GetType()
: Activ::ContentPlatform::ContentGatewayApi::OptionBar
, Activ::ContentPlatform::Feed::TableTemplateIndex
, Activ::ContentPlatform::ContentGatewayApi::FieldSet
, Activ::ContentPlatform::ContentGatewayApi::HistoryBar
, Activ::IFieldType
, Activ::ContentPlatform::ContentGatewayApi::Tick
, Activ::ContentPlatform::ContentGatewayApi::IntradayBar
, Activ::HeapMessage
, Activ::Database::FieldList
, Activ::Database::FieldList::ConstIterator
, Activ::ContentPlatform::Feed::TableTemplate
, Activ::Database::FieldListObject
, Activ::Database::ITable
, Activ::ContentPlatform::Feed::Field
  • GetUiHeading()
: Activ::ContentPlatform::Feed::TableTemplate
, Activ::ContentPlatform::Feed::Field
  • GetUiServiceName()
: Activ::Application
, Activ::UiComponent
  • GetUiUserAddress() : Activ::UiIo
  • GetUnderlyingPrice() : Activ::ContentPlatform::ContentGatewayApi::OptionBar
  • GetUniversalField()
: Activ::ContentPlatform::Feed::TableTemplateList
, Activ::ContentPlatform::Feed::UniversalFieldList
  • GetUniversalFieldHelper() : Activ::ContentPlatform::ContentGatewayApi::MetaDataRequestHelper
  • GetUniversalFieldHelperMap() : Activ::ContentPlatform::ContentGatewayApi::MetaDataRequestHelper
  • GetUniversalFieldList() : Activ::ContentPlatform::Feed::TableTemplateList
  • GetUnshifted() : Activ::BitField< T, OFFSET_VALUE, LENGTH_VALUE >
  • GetUnsignedIntegral() : Activ::UiIo
  • GetUnsignedValue()
: Activ::IniFileParser
, Activ::IniFileParser::ConstSectionIterator
, Activ::IniFileParser::ConstKeyIterator
  • GetUnsignedValueList()
: Activ::IniFileParser
, Activ::IniFileParser::ConstSectionIterator
, Activ::IniFileParser::ConstKeyIterator
  • GetUpdateFilterMapList() : Activ::ContentPlatform::ContentServerApi::ContentServerClient
  • GetUpdateId()
: Activ::ContentPlatform::Feed::RecordMessageHeaderValidator
, Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator
, Activ::ContentPlatform::ContentServerApi::RecordUpdateHelper< MESSAGE_VALIDATOR >
, Activ::ContentPlatform::ContentGatewayApi::Tick
, Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator
, Activ::ContentPlatform::Feed::RecordMessageValidator
, Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator
, Activ::ContentPlatform::Feed::SymbolRecordMessageValidator
, Activ::ContentPlatform::ContentGatewayApi::Tick
  • GetUtc()
: Activ::Time
, Activ::DateTime
  • GetUuid() : Activ::IProcess
  • GetValue() : Activ::RegistryHelper
  • GetVersion() : Activ::ContentPlatform::Feed::TableTemplate
  • GetWeekOfYear()
: Activ::Date
, Activ::DateTime
  • GetWindowSize() : Activ::UiIo
  • GetYear()
: Activ::Date
, Activ::BaseTime
, Activ::DateTime
  • GetZero() : Activ::Timeout
  • GlobalOptionFunction : Activ::UiMenu
  • GROW_RECORDS_DEFAULT : Activ::Database::TableSpecification
Generated on Wed Oct 8 14:01:54 2008 for ACTIV C++ SDK by doxygen 1.5.4


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- h -

  • HandleIoFailure() : Activ::IpSocket
  • HandleManager() : Activ::HandleManager< T >
  • HasAllAvailable() : Activ::DynamicLibraryLoader< T >
  • HasPermissions() : Activ::UiPermissions
  • HasTick() : Activ::ContentPlatform::ContentGatewayApi::IntradayBar
  • Header : Activ::ContentPlatform::Feed::CompressedMessageDefinitions
  • HeapMessage() : Activ::HeapMessage
  • HeapMessageBuilder() : Activ::HeapMessageBuilder
  • HeapPool() : Activ::HeapPool
  • HighFields() : Activ::ContentPlatform::Feed::Rule::HighFields
  • HistoryBar() : Activ::ContentPlatform::ContentGatewayApi::HistoryBar
  • Hours()
: Activ::Time::Hours
, Activ::DateTime
Generated on Wed Oct 8 14:01:54 2008 for ACTIV C++ SDK by doxygen 1.5.4


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- i -

  • Id
: Activ::Process
, Activ::Thread
, Activ::Database::FieldSpecification
  • Identity : Activ::Database::ITable
  • IFieldType() : Activ::IFieldType
  • IFtpHelper() : Activ::IFtpHelper
  • IncrementLength() : Activ::HeapMessage
  • IncrementOffset()
: Activ::HeapMessage::ReadHelper
, Activ::HeapMessage::WriteHelper
  • IndexesToString() : Activ::ContentPlatform::Feed::TableTemplate
  • IndexFieldSpecification() : Activ::ContentPlatform::Feed::Index::IndexFieldSpecification
  • IndexNameToString() : Activ::ContentPlatform::Feed::RecordMessageHeaderValidator
  • IndexNumberToString() : Activ::ContentPlatform::Feed::RecordMessageHeaderValidator
  • IndexSpecification() : Activ::Database::IndexSpecification
  • IniFileParser : Activ::IniFileParser::ConstSectionIterator , Activ::IniFileParser
  • Initialize()
: Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator
, Activ::ContentPlatform::Feed::TableTemplateMessageValidator
, Activ::ContentPlatform::Feed::RecordFieldListBuilder
, Activ::ContentPlatform::Feed::Rule::CopyToFields
, Activ::ContentPlatform::Feed::RecordFieldListValidator
, Activ::ContentPlatform::Feed::Rule::HighFields
, Activ::ContentPlatform::Feed::RecordKeyFieldListBuilder
, Activ::ContentPlatform::Feed::Rule::LowFields
, Activ::ContentPlatform::Feed::RecordKeyFieldListValidator
, Activ::ContentPlatform::Feed::Rule::OpenFields
, Activ::ContentPlatform::Feed::RecordMessageBuilder
, Activ::ContentPlatform::Feed::Rule::CloseFields
, Activ::ContentPlatform::Feed::RecordMessageBuilder
, Activ::ContentPlatform::Feed::Rule::PriceFields
, Activ::ContentPlatform::Feed::RecordMessageBuilder
, Activ::ContentPlatform::Feed::Rule::VolumeFields
, Activ::ContentPlatform::Feed::RecordMessageHeaderValidator
, Activ::ContentPlatform::Feed::Rule
, Activ::ContentPlatform::Feed::RecordMessageHeaderValidator
, Activ::ContentPlatform::Feed::TableTemplate
, Activ::ContentPlatform::ContentGatewayApi::FieldListValidator
, Activ::ContentPlatform::Feed::RecordMessageHeaderValidator
, Activ::ContentPlatform::Feed::TableTemplate
, Activ::ContentPlatform::Feed::TableTemplateAddition
, Activ::ContentPlatform::Feed::RecordMessageValidator
, Activ::ContentPlatform::Feed::TableTemplateList
, Activ::ContentPlatform::ContentServerApi::FieldListValidator
, Activ::ContentPlatform::Feed::RecordMessageValidator
, Activ::ContentPlatform::Feed::TableTemplateList
, Activ::ContentPlatform::Feed::RecordMessageValidator
, Activ::ContentPlatform::Feed::TableTemplateList
, Activ::ContentPlatform::ContentServerApi::FieldListValidator
, Activ::ContentPlatform::Feed::SymbolRecordField
, Activ::ContentPlatform::Feed::UniversalFieldList
, Activ::ContentPlatform::Feed::SymbolRecordFieldListBuilder
, Activ::ContentPlatform::Feed::UniversalFieldList
, Activ::ContentPlatform::FeedApi::SymbolPatternHelper
, Activ::ContentPlatform::Feed::SymbolRecordFieldListValidator
, Activ::ContentPlatform::Feed::UniversalFieldList
, Activ::MessageBuilder
, Activ::ContentPlatform::Feed::SymbolRecordFieldListValidator
, Activ::MessageBuilder
, Activ::MessageRateThrottler
, Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator
, Activ::ContentPlatform::Feed::SymbolRecordMessageBuilder
, Activ::MessageRateThrottler
, Activ::MessageValidator
, Activ::ContentPlatform::Feed::SymbolRecordMessageBuilder
, Activ::Shell
, Activ::Database::FieldListObject
, Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator
, Activ::ContentPlatform::Feed::SymbolRecordMessageBuilder
, Activ::Database::FieldListObject
, Activ::Database::Key
, Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator
, Activ::Database::Key
, Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator
, Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator
, Activ::Database::Key
, Activ::Database::Record
, Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator
, Activ::Database::Record
, Activ::ContentPlatform::Feed::CompressedMessageDefinitions::FieldHeaderBuilder
, Activ::ContentPlatform::Feed::SymbolRecordMessageValidator
, Activ::Database::Record
, Activ::UdpSocket
, Activ::ContentPlatform::Feed::SymbolRecordMessageValidator
, Activ::UdpSocket
, Activ::HeapMessage::ReadHelper
, Activ::ContentPlatform::Feed::CompressedMessageDefinitions::FieldHeaderValidator
, Activ::ContentPlatform::Feed::SymbolRecordMessageValidator
, Activ::HeapMessage::ReadHelper
, Activ::HeapMessage::WriteHelper
, Activ::ContentPlatform::Feed::TableTemplateField
, Activ::HeapMessage::WriteHelper
, Activ::HeapMessageDeserializer< MESSAGE_TYPE, BUFFER_SIZE >
, Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator
, Activ::ContentPlatform::Feed::TableTemplateFieldListValidator
, Activ::CurlFtpHelper
, Activ::HandleManager< T >
, Activ::ContentPlatform::Feed::TableTemplateIndex
, Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator
, Activ::ContentPlatform::Feed::TableTemplateIndexListValidator
, Activ::ContentPlatform::Feed::TableTemplateMessageValidator
  • InitializeAdd1CumulativeValueFields() : Activ::ContentPlatform::Feed::Rule::VolumeFields
  • InitializeAdd1Fields() : Activ::ContentPlatform::Feed::Rule::VolumeFields
  • InitializeAdd2CumulativeValueFields() : Activ::ContentPlatform::Feed::Rule::VolumeFields
  • InitializeAdd2Fields() : Activ::ContentPlatform::Feed::Rule::VolumeFields
  • InitializeChangeFields() : Activ::ContentPlatform::Feed::Rule::PriceFields
  • InitializeList() : Activ::ContentPlatform::Feed::UniversalFieldList
  • InitializeSourceFields() : Activ::ContentPlatform::Feed::Rule
  • InitializeUndefined() : Activ::ContentPlatform::Feed::SymbolRecordField
  • Insert()
: Activ::MessageBuilder
, Activ::HeapMessage
  • InsertBoolean() : Activ::MessageBuilder
  • InsertInEndian() : Activ::MessageBuilder
  • InsertTableTemplate() : Activ::ContentPlatform::Feed::TableTemplateList
  • InterfaceInfo() : Activ::IpManager::InterfaceInfo
  • InterfaceInfoList : Activ::IpManager
  • IntervalTimer() : Activ::IntervalTimer
  • IntradayBar() : Activ::ContentPlatform::ContentGatewayApi::IntradayBar
  • IoCompletionManager : Activ::IoCompletionManager::Overlapped , Activ::IoCompletionManager
  • IpAddress() : Activ::IpAddress
  • IpException() : Activ::IpException
  • IpManager : Activ::IpSocket , Activ::IpManager
  • IpSocket() : Activ::IpSocket
  • IsAbsolutePeriod() : Activ::ContentPlatform::ContentGatewayApi::Period
  • IsAdd() : Activ::Database::ITable
  • IsAmfField() : Activ::ContentPlatform::Feed::Field
  • IsAmfTable() : Activ::ContentPlatform::Feed::TableTemplate
  • IsAscending() : Activ::Database::IndexSpecification::Field
  • IsComplete() : Activ::ContentPlatform::Feed::RecordKeyFieldListBuilder
  • IsCompleteResponse() : Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
  • IsComposite()
: Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderDefinitions
, Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator
, Activ::ContentPlatform::Feed::CompressedMessageHeaderDefinitions
, Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator
, Activ::ContentPlatform::Feed::SymbolRecordField
, Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions
, Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator
, Activ::ContentPlatform::Feed::SymbolRecordMessageValidator
  • IsCompositeAsk()
: Activ::ContentPlatform::Feed::CombinedQuoteMessageHeaderDefinitions
, Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator
  • IsCompositeAskAppendage() : Activ::ContentPlatform::Feed::CombinedQuoteMessageHeaderDefinitions
  • IsCompositeAskToString() : Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator
  • IsCompositeBid()
: Activ::ContentPlatform::Feed::CombinedQuoteMessageHeaderDefinitions
, Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator
  • IsCompositeBidAppendage() : Activ::ContentPlatform::Feed::CombinedQuoteMessageHeaderDefinitions
  • IsCompositeBidToString() : Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator
  • IsCompositeToString()
: Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator
, Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator
, Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator
  • IsCompressed()
: Activ::Blob
, Activ::CrcBlob
  • IsCompressedSymbol() : Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderDefinitions
  • IsCompressedSymbolDefined() : Activ::ContentPlatform::Feed::CompressedMessageDefinitions
  • IsConnected()
: Activ::CurlFtpHelper
, Activ::FtpHelper
, Activ::IFtpHelper
, Activ::SmtpHelper
  • IsContributed() : Activ::ContentPlatform::Feed::TableTemplate
  • IsContributedUniversalFieldList() : Activ::ContentPlatform::Feed::UniversalFieldList
  • IsDefaultValue()
: Activ::CommandLineParser
, Activ::CommandLineParserDetail::CommandLineParserImpl
  • IsDefined()
: Activ::ContentPlatform::Feed::SymbolRecordField
, Activ::ContentPlatform::Feed::Rule
  • IsDelete()
: Activ::ContentPlatform::Feed::SymbolRecordMessageValidator
, Activ::ContentPlatform::Feed::RecordMessageHeaderValidator
, Activ::ContentPlatform::ContentGatewayApi::NewsUpdate
, Activ::ContentPlatform::ContentGatewayApi::RecordUpdate
, Activ::ContentPlatform::ContentServerApi::RecordUpdateHelper< MESSAGE_VALIDATOR >
, Activ::ContentPlatform::Feed::CompressedMessageHeaderDefinitions
, Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator
, Activ::ContentPlatform::Feed::RecordMessageHeaderDefinitions
, Activ::ContentPlatform::Feed::RecordMessageValidator
, Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions
, Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator
  • IsDeleteToString()
: Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator
, Activ::ContentPlatform::Feed::RecordMessageHeaderValidator
, Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator
  • IsDescending() : Activ::Database::IndexSpecification::Field
  • IsDifferent()
: Activ::Time
, Activ::Rational
, Activ::BinaryArray
, Activ::BinaryString
, Activ::Blob
, Activ::CrcBlob
, Activ::Date
, Activ::DateTime
, Activ::IFieldType
, Activ::SInt
, Activ::TextArray
, Activ::TextString
, Activ::TRational
, Activ::UInt
  • IsDirectory() : Activ::File
  • IsDiskBased() : Activ::ContentPlatform::Feed::TableTemplate
  • IsDivisor() : Activ::Rational::DenominatorType
  • IsDivisorBinary() : Activ::Rational::DenominatorType
  • IsDivisorDecimal() : Activ::Rational::DenominatorType
  • IsDoNotAdd()
: Activ::ContentPlatform::Feed::RecordMessageHeaderDefinitions
, Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions
  • IsDuplicate()
: Activ::Database::IIndex
, Activ::Database::IndexSpecification
  • IsEmpty()
: Activ::ContentPlatform::ContentGatewayApi::FieldData
, Activ::ContentPlatform::Feed::UniversalFieldList
  • IsEndOfMessage()
: Activ::MessageValidator
, Activ::HeapMessageDeserializer< MESSAGE_TYPE, BUFFER_SIZE >
  • IsExpandedFormat()
: Activ::ContentPlatform::Feed::RecordMessageHeaderDefinitions
, Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions
  • IsFieldDefined()
: Activ::Database::FieldList
, Activ::ContentPlatform::Feed::FieldHeaderDefinitions
, Activ::Database::FieldList
, Activ::Database::FieldListObject
  • IsFieldDifferent()
: Activ::Database::FieldListObject
, Activ::Database::FieldList
, Activ::Database::FieldListObject
  • IsFieldPresent() : Activ::ContentPlatform::FeedApi::FieldListValidator
  • IsFieldRulesPresent() : Activ::ContentPlatform::Feed::SymbolRecordFieldHeaderDefinitions
  • IsFileNameOnly() : Activ::File
  • IsFound()
: Activ::Database::FieldListObject
, Activ::Database::ITable
, Activ::Database::FieldList
, Activ::File
  • IsHash() : Activ::Database::IndexSpecification
  • IsHigh() : Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ContentServerRuleSet
  • IsIn() : Activ::Timeband
  • IsInitialized()
: Activ::ContentPlatform::Feed::SymbolRecordField
, Activ::ContentPlatform::Feed::RecordFieldListValidator
, Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::RecordMessageBuilder
, Activ::ContentPlatform::FeedApi::FieldListValidator
, Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator
, Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::SymbolRecordMessageBuilder
, Activ::ContentPlatform::Feed::RecordMessageBuilder
, Activ::ContentPlatform::Feed::RecordMessageHeaderValidator
, Activ::ContentPlatform::Feed::RecordMessageValidator
, Activ::ContentPlatform::Feed::RecordFieldListBuilder
, Activ::ContentPlatform::Feed::TableTemplateField
, Activ::ContentPlatform::Feed::TableTemplateIndex
, Activ::ContentPlatform::Feed::RecordKeyFieldListValidator
, Activ::Des3Helper::Key
, Activ::DesHelper::Key
, Activ::ContentPlatform::Feed::SymbolRecordMessageBuilder
, Activ::Database::FieldList::ConstIterator
, Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator
, Activ::ContentPlatform::Feed::TableTemplateIndexListValidator
, Activ::ContentPlatform::Feed::SymbolRecordMessageValidator
, Activ::ContentPlatform::Feed::TableTemplateFieldListValidator
, Activ::IFieldType
, Activ::Database::FieldListObject
, Activ::ContentPlatform::Feed::SymbolRecordFieldListBuilder
, Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator
, Activ::ContentPlatform::Feed::TableTemplateMessageValidator
, Activ::ContentPlatform::Feed::RecordKeyFieldListBuilder
, Activ::ContentPlatform::Feed::SymbolRecordFieldListValidator
  • IsLatestVersion() : Activ::ContentPlatform::Feed::TableTemplate
  • IsLeapYear() : Activ::Date
  • IsLoopback() : Activ::IpAddress
  • IsLow() : Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ContentServerRuleSet
  • IsManaged() : Activ::Database::ITable
  • IsMatch()
: Activ::Database::FieldSpecification
, Activ::Database::IndexSpecification
, Activ::ContentPlatform::FeedApi::SymbolPatternHelper
  • IsMessageAttached() : Activ::HeapMessage
  • IsMulticast() : Activ::IpAddress
  • IsMultiplier() : Activ::Rational::DenominatorType
  • IsNameGreater() : Activ::FileInfo
  • IsNewRecord()
: Activ::ContentPlatform::ContentServerApi::RecordUpdateHelper< MESSAGE_VALIDATOR >
, Activ::ContentPlatform::ContentGatewayApi::NewsUpdate
, Activ::ContentPlatform::ContentGatewayApi::RecordUpdate
  • IsOpen()
: Activ::SharedObject< T >
, Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ContentServerRuleSet
, Activ::File
  • IsOpenValid() : Activ::ContentPlatform::ContentGatewayApi::HistoryBar
  • IsOutOfSequence() : Activ::ContentPlatform::ContentGatewayApi::Tick
  • IsPartialSubset() : Activ::ContentPlatform::FeedApi::FieldListValidator
  • IsPattern() : Activ::ContentPlatform::FeedApi::SymbolPatternHelper
  • IsPending() : Activ::IoCompletionManager::Overlapped
  • IsPermissionIdDefined() : Activ::ContentPlatform::Feed::CompressedMessageDefinitions
  • IsPrimaryUnique()
: Activ::Database::IIndex
, Activ::Database::IndexSpecification
  • IsPurged() : Activ::ContentPlatform::Feed::TableTemplate
  • IsRecordFileOpen() : Activ::Database::ITable
  • IsRefresh()
: Activ::ContentPlatform::Feed::RecordMessageHeaderValidator
, Activ::ContentPlatform::Feed::RecordMessageValidator
, Activ::ContentPlatform::Feed::RecordMessageHeaderDefinitions
, Activ::ContentPlatform::ContentServerApi::RecordUpdateHelper< MESSAGE_VALIDATOR >
  • IsRefreshToString() : Activ::ContentPlatform::Feed::RecordMessageHeaderValidator
  • IsRegularHour() : Activ::ContentPlatform::ContentGatewayApi::IntradayBar
  • IsRegularHourTrade() : Activ::ContentPlatform::ContentGatewayApi::Tick
  • IsRelativeCount() : Activ::ContentPlatform::ContentGatewayApi::Period
  • IsRelativePeriod() : Activ::ContentPlatform::ContentGatewayApi::Period
  • IsResponseKeyDefined() : Activ::ContentPlatform::ContentGatewayApi::ResponseBlock
  • IsRulesPresent() : Activ::ContentPlatform::ContributionGatewayApi::PublishSymbolRecordParameters::Field
  • IsShortTableNumber() : Activ::ContentPlatform::Feed::CompressedMessageDefinitions
  • IsShortTableNumberDefined() : Activ::ContentPlatform::Feed::CompressedMessageDefinitions
  • IsSizeGreater() : Activ::FileInfo
  • IsStale() : Activ::ContentPlatform::ContentServerApi::RecordUpdateHelper< MESSAGE_VALIDATOR >
  • IsSubset() : Activ::ContentPlatform::FeedApi::FieldListValidator
  • IsSystemRestartable() : Activ::AgentApplication
  • IsTableTemplate() : Activ::ContentPlatform::Feed::TableTemplate
  • IsTableTemplateAddition() : Activ::ContentPlatform::Feed::TableTemplateAddition
  • IsTemporary() : Activ::Database::ITable
  • IsTimeGreater() : Activ::FileInfo
  • IsTimeLess() : Activ::FileInfo
  • IsTrade() : Activ::ContentPlatform::ContentGatewayApi::Tick
  • IsTree()
: Activ::Database::IIndex
, Activ::Database::IndexSpecification
  • IsUnique()
: Activ::Database::IndexSpecification
, Activ::Database::IIndex
  • IsUnspecified() : Activ::IpAddress
  • IsUpdate() : Activ::Database::ITable
  • IsUsEquityOption() : Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderDefinitions
  • IsUserLoggedOn() : Activ::ContentPlatform::ContentServerApi::ContentServerClient
  • IsUtc() : Activ::BaseTime
  • IsValid()
: Activ::ScopedAddress
, Activ::Address
, Activ::SocketWrapper
  • IsValidDenominator() : Activ::Rational
  • IsValidMessageType()
: Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderDefinitions
, Activ::ContentPlatform::Feed::CompressedMessageHeaderDefinitions
, Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions
, Activ::ContentPlatform::Feed::TableTemplateMessageHeaderDefinitions
, Activ::ContentPlatform::Feed::RecordMessageHeaderDefinitions
, Activ::ContentPlatform::Feed::CombinedQuoteMessageHeaderDefinitions
, Activ::ContentPlatform::Feed::MessageHeaderDefinitions
  • IsValidNumerator() : Activ::Rational
  • IsValidResponse()
: Activ::ContentPlatform::ContentGatewayApi::ResponseBlock
, Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
, Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient
  • IsValidSerializedBodyLength()
: Activ::CrcBlob
, Activ::Date
, Activ::Blob
, Activ::UInt
, Activ::TextString
, Activ::BinaryString
, Activ::SInt
, Activ::Rational
, Activ::TRational
, Activ::DateTime
, Activ::TextArray
, Activ::BinaryArray
, Activ::Time
, Activ::IFieldType
  • IsValidTick() : Activ::TRational
  • IsValidTrend() : Activ::TRational
  • IsVWAPOnly() : Activ::ContentPlatform::ContentGatewayApi::IntradayBar
  • ITable() : Activ::Database::ITable
  • Iterator() : Activ::HeapMessage::Iterator
Generated on Wed Oct 8 14:01:54 2008 for ACTIV C++ SDK by doxygen 1.5.4


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- p -

  • Parameter : Activ::Url , Activ::CommandLineParser
  • ParameterList : Activ::Url
  • Parse() : Activ::Url
  • ParseException() : Activ::IniFileParser::ParseException
  • PartialBitUpdateList : Activ::ContentPlatform::Feed::SymbolRecordField
  • PartialByteUpdateList : Activ::ContentPlatform::Feed::SymbolRecordField
  • PartialUpdate() : Activ::ContentPlatform::Feed::SymbolRecordField::PartialUpdate
  • PartialUpdateToString() : Activ::ContentPlatform::Feed::SymbolRecordField
  • PatternMatchListRequestParameters() : Activ::ContentPlatform::ContentGatewayApi::PatternMatchListRequestParameters
  • PatternMatchRequestParameters() : Activ::ContentPlatform::ContentGatewayApi::PatternMatchRequestParameters
  • PERIOD_LENGTH_MAXIMUM : Activ::MessageRateThrottler
  • PERIOD_LENGTH_MINIMUM : Activ::MessageRateThrottler
  • PermissionIdHelper() : Activ::ContentPlatform::Feed::PermissionIdHelper
  • PermissionIdInfoMap : Activ::ContentPlatform::Feed::PermissionInfo
  • PermissionIdToString()
: Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator
, Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator
, Activ::ContentPlatform::Feed::RecordMessageHeaderValidator
, Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator
  • Policy : Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::ConnectParameters , Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::ConnectParameters
  • Populate() : Activ::SystemInfo
  • Port() : Activ::Port
  • PortIdSet : Activ::ManagedEndPoint
  • PostConnect() : Activ::TcpSocket
  • PostData()
: Activ::UdpComponent
, Activ::RouterServiceApi::Udp
  • PostDiesToThreads() : Activ::ManagedEndPoint
  • PostEmail() : Activ::SmtpHelper
  • PostEmptyResponse() : Activ::Port
  • PostGetFirstRequest() : Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestHelper< FIRST_MESSAGE_TYPE_VALUE, NEXT_MESSAGE_TYPE_VALUE, FIELD_SET_TYPE >
  • PostGetNextRequest() : Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestHelper< FIRST_MESSAGE_TYPE_VALUE, NEXT_MESSAGE_TYPE_VALUE, FIELD_SET_TYPE >
  • PostIoCompletion() : Activ::IoCompletionManager::Overlapped
  • PostMessage()
: Activ::IEndPoint
, Activ::Port
, Activ::PostMessageHelper
, Activ::SmtpHelper
  • PostMessageHelper() : Activ::PostMessageHelper
  • PostMessages() : Activ::IEndPoint
  • PostRead() : Activ::IpSocket
  • PostRequest()
: Activ::ContentPlatform::ContentGatewayApi::NewsRequestHelper
, Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestHelper< MESSAGE_TYPE_VALUE, REQUEST_PARAMETERS >
, Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryRequestHelper
, Activ::ContentPlatform::ContributionGatewayApi::PublishRequestHelper< MESSAGE_TYPE_VALUE, REQUEST_PARAMETERS, RESPONSE_PARAMETERS >
, Activ::Port
  • PostResponse() : Activ::Port
  • PostWrite() : Activ::IpSocket
  • PreLockedBreak() : Activ::TcpSocket
  • PreLockedRead() : Activ::IpSocket
  • PreLockedWrite() : Activ::IpSocket
  • PriceFields() : Activ::ContentPlatform::Feed::Rule::PriceFields
  • Printf() : Activ::ConsoleWindow
  • PrintUsage()
: Activ::CommandLineParserDetail::CommandLineParserImpl
, Activ::CommandLineParser
  • Process()
: Activ::CommandLineParser
, Activ::CommandLineParserDetail::CommandLineParserImpl
, Activ::Thread
, Activ::ManagedEndPoint
, Activ::Fiber
  • ProcessOpenServiceRequest() : Activ::Service
  • ProcessOption() : Activ::UiMenu
  • ProcessorList : Activ::Process , Activ::Thread
  • ProcessSplit()
: Activ::ContentPlatform::ContentGatewayApi::Tick
, Activ::ContentPlatform::ContentGatewayApi::HistoryBar
, Activ::ContentPlatform::ContentGatewayApi::FieldSet
, Activ::ContentPlatform::ContentGatewayApi::IntradayBar
  • Properties
: Activ::Database::DatabaseSpecification
, Activ::Database::IndexSpecification
, Activ::Database::FieldSpecification
, Activ::Database::TableSpecification
, Activ::Database::IndexSpecification::Field
  • PROPERTY_CONVERT : Activ::Database::TableSpecification
  • PROPERTY_CREATE_MUTEX : Activ::Database::DatabaseSpecification , Activ::Database::TableSpecification
  • PROPERTY_CREATE_RECORD_FILE : Activ::Database::TableSpecification
  • Proxy()
: Activ::Address::Proxy
, Activ::ScopedAddress::Proxy
  • Publish() : Activ::PubSubServiceApi
  • PublishField() : Activ::ContentPlatform::ContributionGatewayApi::PublishField
  • PublishRecordBaseParameters() : Activ::ContentPlatform::ContributionGatewayApi::PublishRecordBaseParameters
  • PublishRecordParameters() : Activ::ContentPlatform::ContributionGatewayApi::PublishRecordParameters
  • PublishSymbolRecordParameters() : Activ::ContentPlatform::ContributionGatewayApi::PublishSymbolRecordParameters
  • PutString() : Activ::UiIo
  • PutStringList() : Activ::UiIo
  • PutStringV() : Activ::UiIo
Generated on Wed Oct 8 14:01:54 2008 for ACTIV C++ SDK by doxygen 1.5.4


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- q -

  • QUOTE_NO_CONDITION : Activ::ContentPlatform::ContentGatewayApi::Tick
  • QUOTE_SAME_CONDITION : Activ::ContentPlatform::ContentGatewayApi::Tick
  • QUOTE_SAME_EXCHANGE_BIT : Activ::ContentPlatform::ContentGatewayApi::Tick
Generated on Wed Oct 8 14:01:54 2008 for ACTIV C++ SDK by doxygen 1.5.4


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- r -

  • Randomize()
: Activ::Des3Helper::Key
, Activ::Des3Helper::KeyBundle
, Activ::DesHelper::Key
  • Rational() : Activ::Rational
  • Read()
: Activ::ContentPlatform::Feed::TableTemplateList::Settings
, Activ::UdpComponent
, Activ::IpManager::Settings
, Activ::AgentApplication::Settings
, Activ::ISystem::Settings
, Activ::ManagedEndPoint::Settings
, Activ::File
, Activ::ContentPlatform::ContentServerApi::ContentServerClient::Settings
, Activ::Application::Settings
, Activ::RouterServiceApi::Udp
, Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::Settings
, Activ::ServiceAccessPoint
, Activ::ThinApplication::Settings
  • ReadBucketInfoVector() : Activ::IHeap
  • ReadDate() : Activ::ContentPlatform::ContentGatewayApi::FieldSet
  • ReadDateTime() : Activ::ContentPlatform::ContentGatewayApi::FieldSet
  • ReadHelper() : Activ::HeapMessage::ReadHelper
  • ReadInteger() : Activ::ContentPlatform::ContentGatewayApi::FieldSet
  • ReadLine()
: Activ::ConsoleWindow
, Activ::File
  • ReadRationalFromDoubleString() : Activ::ContentPlatform::ContentGatewayApi::FieldSet
  • ReadTime() : Activ::ContentPlatform::ContentGatewayApi::FieldSet
  • RealtimeRequestParameters() : Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters
  • RealtimeResponseParameters() : Activ::ContentPlatform::ContentGatewayApi::RealtimeResponseParameters
  • Record() : Activ::Database::Record
  • RecordFieldListBuilder() : Activ::ContentPlatform::Feed::RecordFieldListBuilder
  • RecordFieldListValidator() : Activ::ContentPlatform::Feed::RecordFieldListValidator
  • RecordKeyFieldListBuilder() : Activ::ContentPlatform::Feed::RecordKeyFieldListBuilder
  • RecordKeyFieldListValidator() : Activ::ContentPlatform::Feed::RecordKeyFieldListValidator
  • RecordMessageBuilder()
: Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::RecordMessageBuilder
, Activ::ContentPlatform::Feed::RecordMessageBuilder
  • RecordMessageHeaderValidator() : Activ::ContentPlatform::Feed::RecordMessageHeaderValidator
  • RecordMessageValidator() : Activ::ContentPlatform::Feed::RecordMessageValidator
  • RecordUpdate() : Activ::ContentPlatform::ContentServerApi::RecordUpdate
  • RecordUpdateHelper() : Activ::ContentPlatform::ContentServerApi::RecordUpdateHelper< MESSAGE_VALIDATOR >
  • Reduce() : Activ::ContentPlatform::ContentGatewayApi::OptionBar
  • ReferenceCounter() : Activ::ReferenceCounter
  • Register() : Activ::Service
  • RelationshipIdHelper() : Activ::ContentPlatform::Feed::RelationshipIdHelper
  • Release()
: Activ::IMutex
, Activ::ISemaphore
, Activ::HeapMessage
, Activ::ScopedAddress
  • ReleaseMemory() : Activ::ThreadSpecificPoolAllocator< T, UserAllocator, NextSize >
  • Remove()
: Activ::DirectoryRemover
, Activ::File
  • RemoveDisabledDate() : Activ::Timeband
  • RemoveProcess() : Activ::SystemMonitor
  • RemoveTableTemplate() : Activ::ContentPlatform::Feed::TableTemplateList
  • RemoveTrade() : Activ::ContentPlatform::ContentGatewayApi::IntradayBar
  • RemoveUpdateFilter() : Activ::ContentPlatform::ContentServerApi::ContentServerClient
  • Rename() : Activ::File
  • REQUEST_FLAG_REVERSE_ORDER : Activ::ContentPlatform::ContentGatewayApi::PatternMatchRequestParameters , Activ::ContentPlatform::ContentGatewayApi::PatternMatchListRequestParameters
  • RequestBlock() : Activ::ContentPlatform::ContentGatewayApi::RequestBlock
  • RequestFlags : Activ::ContentPlatform::ContentGatewayApi::PatternMatchRequestParameters , Activ::ContentPlatform::ContentGatewayApi::PatternMatchListRequestParameters
  • RequestId() : Activ::RequestId
  • RequestParameters : Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestHelper< MESSAGE_TYPE_VALUE, REQUEST_PARAMETERS > , Activ::ContentPlatform::ContributionGatewayApi::PublishRequestHelper< MESSAGE_TYPE_VALUE, REQUEST_PARAMETERS, RESPONSE_PARAMETERS >
  • RESERVED_LENGTH : Activ::TRational::SerializedTrendDefinitions
  • RESERVED_OFFSET : Activ::TRational::SerializedTrendDefinitions
  • Reset()
: Activ::ContentPlatform::Feed::SymbolRecordFieldListValidator
, Activ::BinaryArray
, Activ::BinaryString
, Activ::Blob
, Activ::CrcBlob
, Activ::Date
, Activ::IFieldType
, Activ::ContentPlatform::Feed::SymbolRecordMessageBuilder
, Activ::SInt
, Activ::TextString
, Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator
, Activ::TRational
, Activ::UInt
, Activ::ContentPlatform::Feed::SymbolRecordField
, Activ::WsaBufHelper
, Activ::ContentPlatform::Feed::RecordKeyFieldListValidator
, Activ::TextArray
, Activ::ContentPlatform::ContentGatewayApi::Tick
, Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::RecordMessageBuilder
, Activ::Time
, Activ::ContentPlatform::ContentGatewayApi::HistoryBar
, Activ::DateTime
, Activ::ContentPlatform::ContentGatewayApi::FieldSet
, Activ::ContentPlatform::ContentGatewayApi::IntradayBar
, Activ::ContentPlatform::ContentGatewayApi::OptionBar
, Activ::MessageBuilder
, Activ::ScatterBufferHelper
, Activ::Rational
, Activ::ContentPlatform::Feed::TableTemplateIndex
, Activ::ScatterBufferHelper
, Activ::ContentPlatform::Feed::TableTemplateMessageValidator
, Activ::ContentPlatform::Feed::TableTemplateFieldListValidator
, Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::SymbolRecordMessageBuilder
, Activ::Database::Record
, Activ::ContentPlatform::Feed::SymbolRecordFieldListBuilder
, Activ::ContentPlatform::Feed::RecordMessageValidator
, Activ::ContentPlatform::Feed::RecordMessageHeaderValidator
, Activ::ContentPlatform::Feed::RecordKeyFieldListBuilder
, Activ::ContentPlatform::Feed::RecordFieldListValidator
, Activ::ContentPlatform::FeedApi::FieldListValidator
, Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator
, Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator
, Activ::ContentPlatform::Feed::RecordFieldListBuilder
, Activ::Database::FieldListObject
, Activ::ContentPlatform::Feed::RecordMessageBuilder
, Activ::Database::Key
, Activ::MessageRateThrottler
, Activ::ContentPlatform::Feed::SymbolRecordMessageValidator
, Activ::ContentPlatform::Feed::TableTemplateField
, Activ::ContentPlatform::Feed::TableTemplateIndexListValidator
, Activ::MessageHandler
, Activ::MessageValidator
, Activ::ContentPlatform::Feed::TableTemplateList
  • ResetData() : Activ::Database::FieldList
  • ResetKey() : Activ::Database::IIndex
  • ResetRecord() : Activ::Database::ITable
  • ResetStats() : Activ::IHeap
  • Resize() : Activ::IFileMappedMemory
  • ResponseParameters : Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestHelper< MESSAGE_TYPE_VALUE, REQUEST_PARAMETERS > , Activ::ContentPlatform::ContributionGatewayApi::PublishRequestHelper< MESSAGE_TYPE_VALUE, REQUEST_PARAMETERS, RESPONSE_PARAMETERS >
  • RestartSystem() : Activ::AgentApplication
  • Return()
: Activ::Fiber
, Activ::ObjectPool< T, INITIAL_FREE_LIST_SIZE, MAX_FREE_LIST_SIZE >
, Activ::HeapPool
, Activ::SyncRequestId
, Activ::HeapMessage
  • ReturnAll() : Activ::ObjectPool< T, INITIAL_FREE_LIST_SIZE, MAX_FREE_LIST_SIZE >
  • Rule() : Activ::ContentPlatform::Feed::Rule
  • RULE_DOES_NOT_UPDATE_LAST_VALUE : Activ::ContentPlatform::FeedApi::FieldListValidator::Field
  • RULE_SET_CONTENT_SERVER : Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions
  • RULE_SET_COPY : Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions
  • RULE_SET_NONE : Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions
  • RULE_SET_PARTIAL_BIT_UPDATE : Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions
  • RULE_SET_PARTIAL_BYTE_UPDATE : Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions
  • RULE_SET_TRANSLATOR : Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions
  • Rules : Activ::ContentPlatform::FeedApi::FieldListValidator::Field
  • RuleSetToString() : Activ::ContentPlatform::Feed::SymbolRecordField
  • RulesToString() : Activ::ContentPlatform::Feed::TableTemplate
  • Run()
: Activ::UiComponent
, Activ::Shell
, Activ::ManagedEndPoint
, Activ::UiMenu
, Activ::Process
  • RunHelper() : Activ::ManagedEndPoint::RunHelper
  • RxOverlapped() : Activ::IpSocket::RxOverlapped
Generated on Wed Oct 8 14:01:54 2008 for ACTIV C++ SDK by doxygen 1.5.4


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- s -

  • SameAsLastCheck() : Activ::ContentPlatform::ContentGatewayApi::SymbolResponse
  • Save() : Activ::Database::ITable
  • ScaleTimeStamp() : Activ::IntervalTimer
  • ScatterBufferHelper() : Activ::ScatterBufferHelper
  • Scoped() : Activ::IntervalTimer::Scoped
  • ScopedAddress() : Activ::ScopedAddress
  • ScopedHelper() : Activ::ScopedHelper< T, D >
  • ScopedMemory() : Activ::ScopedMemory< T >
  • ScopedMutexLocker() : Activ::ScopedMutexLocker
  • ScopedMutexTryLocker() : Activ::ScopedMutexTryLocker
  • ScopedPooledObject() : Activ::ScopedPooledObject< T >
  • ScopedSubscription() : Activ::ScopedSubscription
  • ScopedVersion() : Activ::MessageHandler::ScopedVersion
  • SearchPath() : Activ::File
  • Seconds : Activ::DateTime , Activ::Time::Seconds
  • SECTION_DELIMITER : Activ::IniFileParser
  • sectionName : Activ::ISystem::Settings
  • SeekMethod : Activ::File
  • Send() : Activ::RouterServiceApi::Udp
  • SendGetFirstRequest() : Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestHelper< FIRST_MESSAGE_TYPE_VALUE, NEXT_MESSAGE_TYPE_VALUE, FIELD_SET_TYPE >
  • SendGetNextRequest() : Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestHelper< FIRST_MESSAGE_TYPE_VALUE, NEXT_MESSAGE_TYPE_VALUE, FIELD_SET_TYPE >
  • SendId : Activ::RequestId
  • SendMessage() : Activ::ISyncEndPoint
  • SendRequest()
: Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestHelper< MESSAGE_TYPE_VALUE, REQUEST_PARAMETERS >
, Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryRequestHelper
, Activ::ContentPlatform::ContributionGatewayApi::PublishRequestHelper< MESSAGE_TYPE_VALUE, REQUEST_PARAMETERS, RESPONSE_PARAMETERS >
, Activ::Port
, Activ::ContentPlatform::ContentGatewayApi::NewsRequestHelper
  • SendTo() : Activ::RouterServiceApi::Udp
  • SerializableBuffer() : Activ::SerializableBuffer< LENGTH_TYPE, MIN_LENGTH, MAX_LENGTH >
  • Serialize()
: Activ::ContentPlatform::Feed::Symbol
, Activ::SerializableContainerHelper< std::list< OBJECT_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >
, Activ::SerializableContainerHelper< std::set< OBJECT_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >
, Activ::ConsoleWindow::Coord
, Activ::SerializableContainerHelper< std::map< KEY_TYPE, MAPPED_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >
, Activ::SerializableContainerHelper< hash_map< KEY_TYPE, MAPPED_TYPE, HASH_FN >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >
, Activ::IniFileParser
, Activ::SerializableBuffer< LENGTH_TYPE, MIN_LENGTH, MAX_LENGTH >
, Activ::ISerializableMessage
, Activ::SerializableContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >
, Activ::SystemInfo
, Activ::Uuid
, Activ::Database::DatabaseSpecification::DatabaseTableSpecification
, Activ::Database::DatabaseSpecification
, Activ::Database::FieldList
, Activ::Database::FieldListObject
, Activ::Database::FieldSpecification
, Activ::Database::IndexSpecification::Field
, Activ::Database::IndexSpecification
, Activ::Database::ITable
, Activ::Database::Key
, Activ::Database::Record
, Activ::Database::TableSpecification
, Activ::BinaryArray
, Activ::BinaryString
, Activ::Blob
, Activ::CrcBlob
, Activ::Date
, Activ::ContentPlatform::ContentGatewayApi::FieldSet
, Activ::DateTime
, Activ::IFieldType
, Activ::ContentPlatform::ContentGatewayApi::HistoryBar
, Activ::IFieldType
, Activ::ContentPlatform::ContentGatewayApi::IntradayBar
, Activ::Rational
, Activ::SInt
, Activ::ContentPlatform::ContentGatewayApi::OptionBar
, Activ::TextArray
, Activ::ContentPlatform::ContentGatewayApi::RequestBlock
, Activ::TextString
, Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryRequestParameters
, Activ::Time
, Activ::TRational
, Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryResponseParameters
, Activ::UInt
, Activ::OpenServiceRequest
, Activ::ContentPlatform::ContentGatewayApi::Tick
, Activ::OpenServiceResponse
, Activ::SystemMessageEndPointIdSet
, Activ::ContentPlatform::ContentGatewayApi::DataPointAddress
, Activ::BaseTime
, Activ::UiPermissions
, Activ::ContentPlatform::ContentGatewayApi::Period
, Activ::IpAddress
, Activ::Address
, Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestParameters
, Activ::IEndPoint::Stats
, Activ::ISyncEndPoint::Stats
, Activ::ContentPlatform::ContentGatewayApi::TimeSeriesCookie
, Activ::IHeap::Stats::RequestDistributionStats
, Activ::IHeap::Stats::BucketStats
, Activ::ContentPlatform::ContentGatewayApi::TimeSeriesResponseParametersTemplate< FIELD_SET_TYPE >
, Activ::IHeap::Stats
, Activ::IProcess::Stats
, Activ::ContentPlatform::Feed::CompressedMessageDefinitions::FieldHeaderBuilder
, Activ::ISystem::SystemInfo
, Activ::ContentPlatform::Feed::CompressedMessageDefinitions::FieldHeaderBuilder
, Activ::RequestId
, Activ::Subject
, Activ::ContentPlatform::Feed::CompressedSymbol
, Activ::SerializableObjectHelper< OBJECT_TYPE >
, Activ::SerializableSmartPointerHelper< POINTER_TYPE >
, Activ::ContentPlatform::Feed::CompressedUsEquityOptionSymbol
, Activ::SerializableRawPointerHelper< POINTER_TYPE >
, Activ::SerializableContainerHelper< std::vector< OBJECT_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >
  • SerializeBody()
: Activ::BinaryArray
, Activ::BinaryString
, Activ::Blob
, Activ::CrcBlob
, Activ::Date
, Activ::DateTime
, Activ::IFieldType
, Activ::Rational
, Activ::SInt
, Activ::TextArray
, Activ::TextString
, Activ::Time
, Activ::TRational
, Activ::UInt
  • SerializedTrend : Activ::TRational::SerializedTrendDefinitions
  • SerializeLengthAndBody()
: Activ::BinaryArray
, Activ::BinaryString
, Activ::Blob
, Activ::CrcBlob
, Activ::Date
, Activ::DateTime
, Activ::IFieldType
, Activ::Rational
, Activ::SInt
, Activ::TextArray
, Activ::TextString
, Activ::Time
, Activ::TRational
, Activ::UInt
  • SerializeSpecification()
: Activ::Database::Database
, Activ::Database::FieldList
, Activ::Database::ITable
  • Service() : Activ::Service
  • ServiceAccessPoint() : Activ::ServiceAccessPoint
  • ServiceHandle() : Activ::ServiceHandle
  • ServiceId() : Activ::ServiceId
  • ServiceInstance() : Activ::ServiceInstance
  • servicePortId : Activ::LoggerDefinitions
  • ServiceSubject() : Activ::ServiceSubject
  • Set()
: Activ::IEvent
, Activ::ScatterBufferHelper
, Activ::ThreadSpecificDataBase< TYPE, DERIVED >
, Activ::Uuid
, Activ::Database::Key
, Activ::Database::Record
, Activ::BinaryArray
, Activ::BinaryString
, Activ::Blob
, Activ::CrcBlob
, Activ::Date
, Activ::DateTime
, Activ::Rational
, Activ::SInt
, Activ::TextArray
, Activ::TextString
, Activ::Time
, Activ::TRational
, Activ::UInt
, Activ::ServiceId
, Activ::Address
, Activ::RequestId
, Activ::Subject
, Activ::BitField< T, OFFSET_VALUE, LENGTH_VALUE >
, Activ::SerializableBuffer< LENGTH_TYPE, MIN_LENGTH, MAX_LENGTH >
  • SetAskPrice() : Activ::ContentPlatform::ContentGatewayApi::OptionBar
  • SetAttributes() : Activ::RequestId
  • SetBidPrice() : Activ::ContentPlatform::ContentGatewayApi::OptionBar
  • SetBufferSize()
: Activ::ConsoleWindow
, Activ::MessageBuilder
  • SetBuyerId() : Activ::ContentPlatform::ContentGatewayApi::Tick
  • SetClosePrice()
: Activ::ContentPlatform::ContentGatewayApi::HistoryBar
, Activ::ContentPlatform::ContentGatewayApi::IntradayBar
  • SetConditions() : Activ::ContentPlatform::ContentGatewayApi::Tick
  • SetCursorPosition() : Activ::ConsoleWindow
  • SetCursorVisibility() : Activ::ConsoleWindow
  • SetDate()
: Activ::ContentPlatform::ContentGatewayApi::Tick
, Activ::ContentPlatform::ContentGatewayApi::HistoryBar
, Activ::ContentPlatform::ContentGatewayApi::IntradayBar
, Activ::ContentPlatform::ContentGatewayApi::OptionBar
  • SetDateTime()
: Activ::ContentPlatform::ContentGatewayApi::IntradayBar
, Activ::ContentPlatform::ContentGatewayApi::Tick
  • SetDenominator()
: Activ::ContentPlatform::ContentGatewayApi::OptionBar
, Activ::Rational
, Activ::TRational
  • SetDestinationAddress() : Activ::HeapMessage
  • SetDisabledDateSet() : Activ::Timeband
  • SetDisplaySize() : Activ::ConsoleWindow
  • SetEnabledDateFlag() : Activ::Timeband
  • SetEnabledDaysString() : Activ::Timeband
  • SetEndPointId() : Activ::Address
  • SetEndTime() : Activ::Timeband
  • SetExchange() : Activ::ContentPlatform::ContentGatewayApi::Tick
  • SetExpirationDate() : Activ::ContentPlatform::ContentGatewayApi::OptionBar
  • SetField()
: Activ::ContentPlatform::ContentGatewayApi::FieldSet
, Activ::ContentPlatform::ContentGatewayApi::HistoryBar
, Activ::ContentPlatform::ContentGatewayApi::IntradayBar
, Activ::ContentPlatform::ContentGatewayApi::OptionBar
, Activ::ContentPlatform::ContentGatewayApi::Tick
, Activ::Database::FieldList
, Activ::Database::FieldListObject
  • SetFieldContents() : Activ::ContentPlatform::ContributionGatewayApi::PublishField
  • SetFieldRules() : Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions
  • SetFields() : Activ::Database::IIndex
  • SetFlag() : Activ::ContentPlatform::ContentGatewayApi::IntradayBar
  • SetHeap()
: Activ::RouterServiceApi::Tcp
, Activ::Port
  • SetHighPrice()
: Activ::ContentPlatform::ContentGatewayApi::HistoryBar
, Activ::ContentPlatform::ContentGatewayApi::IntradayBar
  • SetId() : Activ::Database::FieldListObject
  • SetIdentity() : Activ::Database::ITable
  • SetIndexFields()
: Activ::Database::ITable
, Activ::Database::Key
, Activ::Database::Record
  • SetIpAddress() : Activ::HeapMessage
  • SetKey()
: Activ::Des3Helper::Key
, Activ::DesHelper::Key
  • SetKeys() : Activ::Des3Helper::KeyBundle
  • SetLatestVersion() : Activ::ContentPlatform::Feed::TableTemplate
  • SetLength()
: Activ::MessageBuilder
, Activ::HeapMessage
, Activ::RequestId
  • SetLogHeader() : Activ::LoggerServiceApi
  • SetLowPrice()
: Activ::ContentPlatform::ContentGatewayApi::HistoryBar
, Activ::ContentPlatform::ContentGatewayApi::IntradayBar
  • SetMaxByteCount() : Activ::IEndPoint
  • SetMaxTxQueueSize() : Activ::RouterServiceApi::Tcp
  • SetMessageVersion() : Activ::MessageHandler
  • SetMode()
: Activ::Database::Database
, Activ::Database::ITable
  • SetMulticastLoopback()
: Activ::RouterServiceApi::Udp
, Activ::UdpComponent
, Activ::UdpSocket
  • SetMulticastTtl()
: Activ::UdpSocket
, Activ::RouterServiceApi::Udp
, Activ::UdpComponent
  • SetMulticastTxInterface()
: Activ::RouterServiceApi::Udp
, Activ::UdpComponent
, Activ::UdpSocket
  • SetName() : Activ::Thread
  • SetOffset()
: Activ::MessageValidator
, Activ::HeapMessage::ReadHelper
, Activ::HeapMessage::WriteHelper
  • SetOpenInterest()
: Activ::ContentPlatform::ContentGatewayApi::OptionBar
, Activ::ContentPlatform::ContentGatewayApi::HistoryBar
  • SetOpenPrice()
: Activ::ContentPlatform::ContentGatewayApi::HistoryBar
, Activ::ContentPlatform::ContentGatewayApi::IntradayBar
  • SetOutOfSequence() : Activ::ContentPlatform::ContentGatewayApi::Tick
  • SetPending() : Activ::IoCompletionManager::Overlapped
  • SetPortId() : Activ::Address
  • SetPosition() : Activ::File
  • SetPrice() : Activ::ContentPlatform::ContentGatewayApi::Tick
  • SetPriority() : Activ::Thread
  • SetProcessorAffinity()
: Activ::Process
, Activ::Thread
  • SetRequestDistributionLogging() : Activ::IHeap
  • SetRequestId() : Activ::HeapMessage
  • SetResponseAddress() : Activ::RequestId
  • SetReturnAddress() : Activ::HeapMessage
  • SetRuleSet() : Activ::ContentPlatform::ContributionGatewayApi::PublishSymbolRecordParameters::Field
  • SetRxBufferSize()
: Activ::RouterServiceApi::Udp
, Activ::UdpComponent
, Activ::IpSocket
  • SetSearchOrder() : Activ::Database::Database
  • SetSellerId() : Activ::ContentPlatform::ContentGatewayApi::Tick
  • SetSequence() : Activ::ContentPlatform::ContentGatewayApi::FieldSet
  • SetSize()
: Activ::ContentPlatform::ContentGatewayApi::Tick
, Activ::File
  • SetSocketOption() : Activ::IpSocket
  • SetSourceAddress() : Activ::HeapMessage
  • SetStartTime() : Activ::Timeband
  • SetState()
: Activ::IProcess
, Activ::IEndPoint
  • SetStatusCode() : Activ::HeapMessage
  • SetStrikePrice() : Activ::ContentPlatform::ContentGatewayApi::OptionBar
  • SetSubject() : Activ::HeapMessage
  • SetThreadPriority() : Activ::Thread
  • SetTick() : Activ::TRational
  • SetTickAndTrendOnPrevious() : Activ::TRational
  • SetTickCount() : Activ::ContentPlatform::ContentGatewayApi::IntradayBar
  • SetTickType() : Activ::ContentPlatform::ContentGatewayApi::Tick
  • SetTime()
: Activ::ContentPlatform::ContentGatewayApi::IntradayBar
, Activ::ContentPlatform::ContentGatewayApi::Tick
  • SetTimeout() : Activ::CurlFtpHelper
  • SetTimer() : Activ::TimerServiceApi
  • Settings()
: Activ::IpSocket::Settings
, Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::Settings
, Activ::ContentPlatform::ContentServerApi::ContentServerClient::Settings
, Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::Settings
, Activ::ContentPlatform::Feed::TableTemplateList::Settings
, Activ::AgentApplication::Settings
, Activ::Application::Settings
, Activ::ManagedEndPoint::Settings
, Activ::Timeband::Settings
, Activ::IpManager::Settings
, Activ::UdpSocket::Settings
, Activ::TcpSocket::Settings
, Activ::ISystem::Settings
, Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::Settings
, Activ::ThinApplication::Settings
  • SetTitle() : Activ::ConsoleWindow
  • SetToMiniBar()
: Activ::ContentPlatform::ContentGatewayApi::IntradayBar
, Activ::ContentPlatform::ContentGatewayApi::HistoryBar
  • SetTotalPrice()
: Activ::ContentPlatform::ContentGatewayApi::IntradayBar
, Activ::ContentPlatform::ContentGatewayApi::HistoryBar
  • SetTotalValue()
: Activ::ContentPlatform::ContentGatewayApi::HistoryBar
, Activ::ContentPlatform::ContentGatewayApi::IntradayBar
  • SetTotalVolume()
: Activ::ContentPlatform::ContentGatewayApi::OptionBar
, Activ::ContentPlatform::ContentGatewayApi::HistoryBar
, Activ::ContentPlatform::ContentGatewayApi::IntradayBar
, Activ::ContentPlatform::ContentGatewayApi::HistoryBar
, Activ::ContentPlatform::ContentGatewayApi::IntradayBar
  • SetTradeThroughExemptFlag() : Activ::ContentPlatform::ContentGatewayApi::Tick
  • SetTrendOnDay() : Activ::TRational
  • SetTrendOnPrevious() : Activ::TRational
  • SetTxBufferSize()
: Activ::UdpComponent
, Activ::RouterServiceApi::Udp
, Activ::IpSocket
  • SetType() : Activ::HeapMessage
  • SetUnderlyingPrice() : Activ::ContentPlatform::ContentGatewayApi::OptionBar
  • SetUnicastTtl()
: Activ::UdpComponent
, Activ::RouterServiceApi::Udp
, Activ::UdpSocket
  • SetUpdateId() : Activ::ContentPlatform::ContentGatewayApi::Tick
  • SetValue() : Activ::RegistryHelper
  • SHARE_FLAG_READ : Activ::File
  • SHARE_FLAG_WRITE : Activ::File
  • SharedObject() : Activ::SharedObject< T >
  • ShareFlags : Activ::File
  • Shell() : Activ::Shell
  • ShouldApplyAddRule1()
: Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ContentServerRuleSet
, Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::TranslatorRuleSet
  • ShouldApplyAddRule2()
: Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ContentServerRuleSet
, Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::TranslatorRuleSet
  • ShouldApplyChangeRule()
: Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::TranslatorRuleSet
, Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ContentServerRuleSet
  • ShouldApplyTrending()
: Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ContentServerRuleSet
, Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::TranslatorRuleSet
  • ShouldConvert() : Activ::Database::TableSpecification
  • ShouldCreateMutex()
: Activ::Database::DatabaseSpecification
, Activ::Database::TableSpecification
  • ShouldCreateRecordFile() : Activ::Database::TableSpecification
  • ShouldTestHighLow() : Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::TranslatorRuleSet
  • ShouldTestOpen() : Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::TranslatorRuleSet
  • ShouldUpdateField()
: Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::TranslatorRuleSet
, Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ContentServerRuleSet
  • Shutdown()
: Activ::UdpSocket
, Activ::Application
  • SHUTDOWN_REASON_API : Activ::Application
  • SHUTDOWN_REASON_LOGOFF : Activ::Application
  • SHUTDOWN_REASON_NOT_LICENSED : Activ::Application
  • SHUTDOWN_REASON_PROCESS_KILLED : Activ::Application
  • SHUTDOWN_REASON_UI : Activ::Application
  • SHUTDOWN_REASON_UI_RESTART : Activ::Application
  • SHUTDOWN_REASON_UPDATING : Activ::Application
  • ShutdownReason : Activ::Application
  • ShutdownSocket() : Activ::IpSocket
  • ShutdownSubject() : Activ::ShutdownSubject
  • Singleton() : Activ::Singleton< T >
  • SInt() : Activ::SInt
  • SmtpHelper() : Activ::SmtpHelper
  • SocketStats() : Activ::RouterServiceApi::Tcp::SocketStats
  • SocketWrapper() : Activ::SocketWrapper
  • Specification()
: Activ::ContentPlatform::Feed::Field::Specification
, Activ::ContentPlatform::Feed::Index::Specification
, Activ::ContentPlatform::Feed::TableTemplate::Specification
  • SplitPath() : Activ::File
  • Start()
: Activ::TcpListener
, Activ::Thread
, Activ::TcpListener
, Activ::Process
  • StartThread() : Activ::ManagedEndPoint
  • State
: Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient
, Activ::IProcess
, Activ::IEndPoint
, Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
, Activ::TcpListener
, Activ::UdpSocket
, Activ::TcpSocket
  • StateToString()
: Activ::IEndPoint
, Activ::TcpListener
, Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient
, Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
, Activ::IProcess
, Activ::TcpSocket
, Activ::UdpSocket
  • StaticCompletionHelper() : Activ::UiIo::StaticCompletionHelper
  • Stats()
: Activ::TcpSocket::Stats
, Activ::SystemMonitor::Stats
, Activ::UdpSocket::Stats
, Activ::IpSocket::Stats
  • Status : Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayResponseParameters , Activ::ContentPlatform::ContentGatewayApi::ResponseBlock
  • STATUS_SUCCESS : Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayResponseParameters , Activ::ContentPlatform::ContentGatewayApi::ResponseBlock
  • StatusCodeException() : Activ::StatusCodeException
  • StatusCodeHelper() : Activ::StatusCodeHelper
  • StatusToString()
: Activ::ContentPlatform::ContentGatewayApi::ResponseBlock
, Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayResponseParameters
  • StepFirst() : Activ::Database::ITable
  • StepNext() : Activ::Database::ITable
  • Stop()
: Activ::RouterServiceApi::Tcp
, Activ::TcpListener
  • StringLength : Activ::MessageHandler
  • StringToNotificationType() : Activ::IEndPoint
  • StringToPriority() : Activ::Thread
  • Subject() : Activ::Subject
  • SubjectLength : Activ::Subject
  • Subscribe() : Activ::PubSubServiceApi
  • SubscribeFeedParameters() : Activ::ContentPlatform::ContentGatewayApi::SubscribeFeedParameters
  • SubscribeParameters() : Activ::ContentPlatform::ContentGatewayApi::SubscribeParameters
  • SubscribeTableParameters() : Activ::ContentPlatform::ContentGatewayApi::SubscribeTableParameters
  • SubscribeToFeed() : Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
  • SubscribeToTable() : Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
  • SubscriptionMap : Activ::PubSubServiceApi
  • Subtract()
: Activ::DateTime
, Activ::Rational
, Activ::Date
, Activ::DateTime
, Activ::Time
, Activ::UInt
, Activ::DateTime
, Activ::Time
, Activ::DateTime
, Activ::Time
, Activ::SInt
  • Suspend()
: Activ::Thread
, Activ::MessageRateThrottler
  • Switch()
: Activ::CommandLineParser
, Activ::Fiber
, Activ::CommandLineParser
  • Symbol : Activ::ContentPlatform::ContentGatewayApi::SymbolId
  • SymbolDirectoryRequestParameters() : Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryRequestParameters
  • SymbolId() : Activ::ContentPlatform::ContentGatewayApi::SymbolId
  • SymbolIdCountRequestParameters() : Activ::ContentPlatform::ContentGatewayApi::SymbolIdCountRequestParameters
  • SymbolPatternHelper() : Activ::ContentPlatform::FeedApi::SymbolPatternHelper
  • SymbolPatternList : Activ::ContentPlatform::ContentServerApi::ContentServerClient::UpdateFilter
  • SymbolRecordField() : Activ::ContentPlatform::Feed::SymbolRecordField
  • SymbolRecordFieldListBuilder() : Activ::ContentPlatform::Feed::SymbolRecordFieldListBuilder
  • SymbolRecordFieldListValidator() : Activ::ContentPlatform::Feed::SymbolRecordFieldListValidator
  • SymbolRecordMessageBuilder()
: Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::SymbolRecordMessageBuilder
, Activ::ContentPlatform::Feed::SymbolRecordMessageBuilder
  • SymbolRecordMessageHeaderValidator() : Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator
  • SymbolRecordMessageValidator() : Activ::ContentPlatform::Feed::SymbolRecordMessageValidator
  • SymbolRecordUpdate() : Activ::ContentPlatform::ContentServerApi::SymbolRecordUpdate
  • SymbolToString()
: Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator
, Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator
, Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator
  • SyncRequestId() : Activ::SyncRequestId
  • SYSTEM_LOG_MODE_OFF : Activ::ISystem::Settings
  • SYSTEM_LOG_MODE_TO_AGENT : Activ::ISystem::Settings
  • SYSTEM_LOG_MODE_TO_CONSOLE : Activ::ISystem::Settings
  • SystemException() : Activ::SystemException
  • SystemInfo()
: Activ::ISystem::SystemInfo
, Activ::SystemInfo
  • SystemLogMode : Activ::ISystem::Settings
  • SystemMonitor() : Activ::SystemMonitor
Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- t -

  • TableId : Activ::Database::DatabaseSpecification
  • TableNumberList : Activ::ContentPlatform::ContentServerApi::ContentServerClient::UpdateFilter
  • TableNumberRequestParameters() : Activ::ContentPlatform::ContentGatewayApi::TableNumberRequestParameters
  • TableSpecification() : Activ::Database::TableSpecification
  • TableTemplate() : Activ::ContentPlatform::Feed::TableTemplate
  • TableTemplateAddition() : Activ::ContentPlatform::Feed::TableTemplateAddition
  • TableTemplateException() : Activ::ContentPlatform::Feed::TableTemplateException
  • TableTemplateField() : Activ::ContentPlatform::Feed::TableTemplateField
  • TableTemplateFieldListValidator() : Activ::ContentPlatform::Feed::TableTemplateFieldListValidator
  • TableTemplateIdToString()
: Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator
, Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator
, Activ::ContentPlatform::Feed::RecordMessageHeaderValidator
, Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator
  • TableTemplateIndex() : Activ::ContentPlatform::Feed::TableTemplateIndex
  • TableTemplateIndexListValidator() : Activ::ContentPlatform::Feed::TableTemplateIndexListValidator
  • TableTemplateList() : Activ::ContentPlatform::Feed::TableTemplateList
  • TableTemplateMessageValidator() : Activ::ContentPlatform::Feed::TableTemplateMessageValidator
  • TableTemplateNameToString()
: Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator
, Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator
, Activ::ContentPlatform::Feed::RecordMessageHeaderValidator
, Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator
  • TableTemplateSpecification() : Activ::ContentPlatform::Feed::TableTemplateList::TableTemplateSpecification
  • TcpListener() : Activ::TcpListener
  • TcpSocket() : Activ::TcpSocket
  • TextArray() : Activ::TextArray
  • TextString() : Activ::TextString
  • ThinApplication() : Activ::ThinApplication
  • Thread() : Activ::Thread
  • ThreadSpecificDataBase() : Activ::ThreadSpecificDataBase< TYPE, DERIVED >
  • Tick : Activ::TRational , Activ::ContentPlatform::ContentGatewayApi::Tick
  • TICK_CONDITION_LENGTH_MASK : Activ::ContentPlatform::ContentGatewayApi::Tick
  • TICK_DAY_MASK : Activ::ContentPlatform::ContentGatewayApi::Tick
  • TICK_KNOWN_EXCHANGE_BIT : Activ::ContentPlatform::ContentGatewayApi::Tick
  • TICK_LENGTH : Activ::TRational::SerializedTrendDefinitions
  • TICK_OFFSET : Activ::TRational::SerializedTrendDefinitions
  • TICK_OPTIONAL_DATA_BIT : Activ::ContentPlatform::ContentGatewayApi::Tick
  • TICK_OUT_SEQUENCE_MASK : Activ::ContentPlatform::ContentGatewayApi::Tick
  • TICK_SIZE_BYTE1 : Activ::ContentPlatform::ContentGatewayApi::Tick
  • TICK_SIZE_BYTE2 : Activ::ContentPlatform::ContentGatewayApi::Tick
  • TICK_TYPE_MASK : Activ::ContentPlatform::ContentGatewayApi::Tick
  • TickToString() : Activ::TRational
  • Time() : Activ::Time
  • Timeband() : Activ::Timeband
  • Timeout() : Activ::Timeout
  • TimeSeriesRequestParameters() : Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestParameters
  • TimeToString() : Activ::BaseTime
  • ToFormattedHeaderString() : Activ::Database::FieldSpecification
  • ToFormattedString() : Activ::Database::FieldSpecification
  • ToHexDumpString() : Activ::HeapMessage
  • ToLogString()
: Activ::Database::FieldList
, Activ::Database::FieldListObject
, Activ::Timeband
  • ToShortString() : Activ::ContentPlatform::ContentGatewayApi::Tick
  • ToStream() : Activ::Exception
  • ToString()
: Activ::Database::DatabaseSpecification::DatabaseTableSpecification
, Activ::Uuid
, Activ::Database::FieldSpecification
, Activ::OsException
, Activ::CrcBlob
, Activ::Exception
, Activ::IFieldType
, Activ::BinaryArray
, Activ::ContentPlatform::Feed::TableTemplateList
, Activ::BinaryString
, Activ::ContentPlatform::Feed::TableTemplate
, Activ::Blob
, Activ::ContentPlatform::Feed::Rule::VolumeFields
, Activ::Blob
, Activ::ContentPlatform::Feed::Rule::CloseFields
, Activ::DesHelper::Key
, Activ::ContentPlatform::Feed::Rule::LowFields
, Activ::CrcBlob
, Activ::ContentPlatform::Feed::Rule::CopyToFields
, Activ::Date
, Activ::DateTime
, Activ::Rational
, Activ::BinaryString
, Activ::ContentPlatform::Feed::RecordMessageValidator
, Activ::StatusCodeHelper
, Activ::ContentPlatform::Feed::RecordKeyFieldListValidator
, Activ::TextString
, Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator
, Activ::Time
, Activ::TRational
, Activ::Database::TableSpecification
, Activ::ContentPlatform::ContentGatewayApi::Tick
, Activ::Timeband
, Activ::ContentPlatform::ContentGatewayApi::IntradayBar
, Activ::BaseTime
, Activ::ContentPlatform::ContentGatewayApi::FieldSet
, Activ::Des3Helper::Key
, Activ::UiPermissions
, Activ::Database::FieldList
, Activ::RequestId
, Activ::ScopedAddress
, Activ::Subject
, Activ::IpAddress
, Activ::SystemException
, Activ::ContentPlatform::ContentGatewayApi::HistoryBar
, Activ::ContentPlatform::ContentGatewayApi::OptionBar
, Activ::IpException
, Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::RecordMessageBuilder
, Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::SymbolRecordMessageBuilder
, Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator
, Activ::Address
, Activ::ContentPlatform::Feed::RecordFieldListValidator
, Activ::ContentPlatform::Feed::RecordMessageHeaderValidator
, Activ::UInt
, Activ::ContentPlatform::Feed::SymbolRecordField
, Activ::Database::IndexSpecification
, Activ::Database::FieldListObject
, Activ::Database::DatabaseSpecification
, Activ::Database::DatabaseException
, Activ::StatusCodeException
, Activ::IniFileParser::ParseException
, Activ::CrtException
, Activ::ContentPlatform::Feed::SymbolRecordFieldListValidator
, Activ::ContentPlatform::Feed::TableTemplateException
, Activ::ContentPlatform::Feed::Rule
, Activ::ContentPlatform::Feed::Rule::PriceFields
, Activ::ContentPlatform::Feed::Rule::OpenFields
, Activ::ContentPlatform::Feed::Rule::HighFields
, Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator
, Activ::ContentPlatform::Feed::SymbolRecordMessageValidator
, Activ::UiIo::Attribute
, Activ::ContentPlatform::Feed::Field
, Activ::ServiceAccessPoint
, Activ::BaseTime::Duration
, Activ::ServiceId
, Activ::Rational
, Activ::ContentPlatform::Feed::UniversalFieldList
, Activ::BaseException
, Activ::TRational
, Activ::SInt
, Activ::Time
, Activ::TextArray
  • TRational() : Activ::TRational
  • Trend : Activ::TRational
  • TREND_ON_DAY_LENGTH : Activ::TRational::SerializedTrendDefinitions
  • TREND_ON_DAY_OFFSET : Activ::TRational::SerializedTrendDefinitions
  • TREND_ON_PREVIOUS_LENGTH : Activ::TRational::SerializedTrendDefinitions
  • TREND_ON_PREVIOUS_OFFSET : Activ::TRational::SerializedTrendDefinitions
  • TrendToString() : Activ::TRational
  • Try()
: Activ::IMutex
, Activ::DeferredScopedMutexLocker
  • TryFlush() : Activ::PostMessageHelper
  • TryPostMessages() : Activ::IEndPoint
  • TxOverlapped() : Activ::IpSocket::TxOverlapped
  • Type
: Activ::Database::FieldSpecification
, Activ::RegistryHelper
, Activ::Database::IndexSpecification
, Activ::ContentPlatform::Feed::PermissionInfo::PermissionIdInfo
, Activ::UiComponent
, Activ::ContentPlatform::ContentGatewayApi::SubscribeParameters
  • TYPE_ALL_FIELDS : Activ::ContentPlatform::Feed::PermissionInfo::PermissionIdInfo
  • TYPE_BINARY : Activ::RegistryHelper
  • TYPE_DEFAULT : Activ::UiComponent
  • TYPE_EXCLUDE_FIELDS : Activ::ContentPlatform::Feed::PermissionInfo::PermissionIdInfo
  • TYPE_INCLUDE_FIELDS : Activ::ContentPlatform::Feed::PermissionInfo::PermissionIdInfo
  • TYPE_MAIN : Activ::UiComponent
  • TYPE_MIDDLEWARE : Activ::UiComponent
  • TYPE_STRING : Activ::RegistryHelper
  • TYPE_UNSIGNED32 : Activ::RegistryHelper
  • TYPE_UNSUPPORTED : Activ::RegistryHelper
  • TypeToString() : Activ::LoggerDefinitions
Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- u -

  • UdpComponent() : Activ::UdpComponent
  • UdpSocket() : Activ::UdpSocket
  • UiAddAllOptions() : Activ::ContentPlatform::Feed::TableTemplateList
  • UiComponent() : Activ::UiComponent
  • UiDisplayAvailableUiComponentsByType() : Activ::UiMainComponent
  • UiDisplayTableTemplateFields() : Activ::ContentPlatform::Feed::TableTemplateList
  • UiDisplayTableTemplatesList() : Activ::ContentPlatform::Feed::TableTemplateList
  • UiDisplayUniversalFieldList() : Activ::ContentPlatform::Feed::TableTemplateList
  • UiMainComponent : Activ::UiIo , Activ::UiMainComponent
  • UiMenu : Activ::UiIo , Activ::UiMenu
  • UInt() : Activ::UInt
  • UiPermissions() : Activ::UiPermissions
  • UiReInitializeTableTemplateListFromHeaders() : Activ::ContentPlatform::Feed::TableTemplateList
  • UiReInitializeTableTemplateListFromPathList() : Activ::ContentPlatform::Feed::TableTemplateList
  • UiReInitializeTableTemplateListFromSettingsObject() : Activ::ContentPlatform::Feed::TableTemplateList
  • UNDEFINED_FIELD_ID : Activ::Database::FieldSpecification
  • UNDEFINED_FIELD_NUMBER : Activ::Database::FieldList
  • UNDEFINED_INDEX_NUMBER : Activ::Database::IndexSpecification
  • UNDEFINED_TABLE_ID : Activ::Database::DatabaseSpecification
  • UndefinedFieldContentsToString()
: Activ::ContentPlatform::Feed::RecordFieldListValidator
, Activ::ContentPlatform::Feed::RecordKeyFieldListValidator
, Activ::ContentPlatform::Feed::SymbolRecordField
  • UndefineField()
: Activ::Database::FieldList
, Activ::Database::FieldListObject
  • UndefineOnResetToString() : Activ::ContentPlatform::Feed::TableTemplate
  • UniversalFieldHelper() : Activ::ContentPlatform::Feed::UniversalFieldHelper
  • UniversalFieldList() : Activ::ContentPlatform::Feed::UniversalFieldList
  • Unsubscribe()
: Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
, Activ::PubSubServiceApi
, Activ::ScopedSubscription
  • Update()
: Activ::ContentPlatform::ContentGatewayApi::HistoryBar
, Activ::ContentPlatform::ContentGatewayApi::IntradayBar
  • UpdateFieldSetStatus : Activ::ContentPlatform::ContentGatewayApi::FieldSet
  • UpdateIdToString()
: Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator
, Activ::ContentPlatform::Feed::RecordMessageHeaderValidator
, Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator
, Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator
  • USE_CURRENT_FILE_SIZE : Activ::IFileMappedMemory
  • UtcTime() : Activ::UtcTime
  • Uuid() : Activ::Uuid
Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- v -

  • Validate()
: Activ::ContentPlatform::Feed::CompressedMessageDefinitions::FieldHeaderValidator
, Activ::Database::FieldSpecification
, Activ::Database::Key
, Activ::Database::IndexSpecification
, Activ::Database::Record
  • ValidateAsciiHexadecimalIntegral() : Activ::MessageValidator
  • ValidateAsciiHexadecimalIntegralCopy() : Activ::MessageValidator
  • ValidateBinaryIntegral() : Activ::MessageValidator
  • ValidateBinaryIntegralRange() : Activ::MessageValidator
  • ValidateBoolean() : Activ::MessageValidator
  • ValidateBytes() : Activ::MessageValidator
  • ValidateBytesCopy() : Activ::MessageValidator
  • ValidateCompressed() : Activ::ContentPlatform::Feed::CompressedMessage
  • ValidateCompressedCombinedQuote() : Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessage
  • ValidateOpenServiceRequest() : Activ::Service
  • ValidateOpenServiceResponse() : Activ::ServiceApi
  • ValidateSerializedLengthAndBody()
: Activ::BinaryArray
, Activ::BinaryString
, Activ::Blob
, Activ::CrcBlob
, Activ::Date
, Activ::DateTime
, Activ::IFieldType
, Activ::Rational
, Activ::SInt
, Activ::TextArray
, Activ::TextString
, Activ::Time
, Activ::TRational
, Activ::UInt
  • ValidateSignedAsciiIntegral() : Activ::MessageValidator
  • ValidateSignedAsciiIntegralCopy() : Activ::MessageValidator
  • ValidateSignedAsciiReal() : Activ::MessageValidator
  • ValidateSignedAsciiRealCopy() : Activ::MessageValidator
  • ValidateSignedBinaryIntegral() : Activ::MessageValidator
  • ValidateSignedBinaryIntegralCopy() : Activ::MessageValidator
  • ValidateString() : Activ::MessageValidator
  • ValidateStringCopy() : Activ::MessageValidator
  • ValidateUnsignedAsciiIntegral() : Activ::MessageValidator
  • ValidateUnsignedAsciiIntegralCopy() : Activ::MessageValidator
  • ValidateUnsignedAsciiReal() : Activ::MessageValidator
  • ValidateUnsignedAsciiRealCopy() : Activ::MessageValidator
  • ValidateUnsignedBinaryIntegral() : Activ::MessageValidator
  • ValidateUnsignedBinaryIntegralCopy() : Activ::MessageValidator
  • ValueStore() : Activ::CommandLineParserDetail::ValueStore< T >
  • VERSION : Activ::Database::DatabaseSpecification , Activ::Database::TableSpecification
  • VolumeFields() : Activ::ContentPlatform::Feed::Rule::VolumeFields
Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- w -

  • Wait()
: Activ::IEvent
, Activ::HandleManager< T >
  • WaitForCompletion()
: Activ::Thread
, Activ::Process
  • WaitForInput() : Activ::ConsoleWindow
  • WaitForState() : Activ::IProcess
  • WaitForThreadsToExit() : Activ::ManagedEndPoint
  • Walk() : Activ::DirectoryWalker
  • WasSuccessfulCompletion() : Activ::IoCompletionManager::Overlapped
  • WATCH_TYPE_ADDS_DELETES : Activ::DirectoryWatchApi
  • WATCH_TYPE_ATTRIBUTES : Activ::DirectoryWatchApi
  • WATCH_TYPE_RECURSIVE : Activ::DirectoryWatchApi
  • Write()
: Activ::File
, Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::RecordMessageBuilder
, Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::SymbolRecordMessageBuilder
  • WriteAt() : Activ::ConsoleWindow
  • WriteHelper() : Activ::HeapMessage::WriteHelper
  • WsaBufHelper() : Activ::WsaBufHelper
Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • c
  • d
  • e
  • f
  • g
  • m
  • n
  • p
  • s
  • t
  • u

- c -

  • CompletionResult : Activ::IpSocket

- d -

  • Denominator : Activ::Rational

- e -

  • EnabledDateFlag : Activ::Timeband
  • Endian : Activ::MessageHandler
  • Errors : Activ::Database::DatabaseException
  • EventType : Activ::CtrlHandler , Activ::DirectoryWatchApi
  • ExceptionHandlerType : Activ::Application::Settings

- f -

  • FieldState : Activ::ContentPlatform::Feed::CompressedMessageDefinitions
  • FileType : Activ::LoggerDefinitions
  • FilterType : Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryRequestParameters
  • FtpType : Activ::FtpHelper

- g -

  • GetBuffersResult : Activ::IpSocket

- m -

  • MatchType : Activ::ContentPlatform::ContentGatewayApi::MatchRequestParameters , Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryRequestParameters
  • MemoryModel : Activ::ISystem::Settings

- n -

  • NotificationType : Activ::IEndPoint

- p -

  • Policy : Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::ConnectParameters , Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::ConnectParameters

- s -

  • SeekMethod : Activ::File
  • ShutdownReason : Activ::Application
  • State
: Activ::IProcess
, Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient
, Activ::UdpSocket
, Activ::TcpSocket
, Activ::TcpListener
, Activ::IEndPoint
, Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
  • SystemLogMode : Activ::ISystem::Settings

- t -

  • Tick : Activ::TRational
  • Trend : Activ::TRational
  • Type
: Activ::Database::IndexSpecification
, Activ::Database::FieldSpecification
, Activ::RegistryHelper
, Activ::ContentPlatform::Feed::PermissionInfo::PermissionIdInfo
, Activ::ContentPlatform::ContentGatewayApi::SubscribeParameters
, Activ::UiComponent

- u -

  • UpdateFieldSetStatus : Activ::ContentPlatform::ContentGatewayApi::FieldSet
Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • c
  • e
  • f
  • g
  • m
  • n
  • p
  • r
  • s
  • t

- a -

  • ACTIV_DECLARE_ELEMENT_1_WITH_COMMA : Activ::LoggerDefinitions
  • ACTIV_DECLARE_VALUE_WITH_COMMA
: Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::ConnectParameters
, Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryRequestParameters
, Activ::ContentPlatform::ContentGatewayApi::MatchRequestParameters
, Activ::ContentPlatform::ContentGatewayApi::SubscribeParameters

- c -

  • COMPLETION_RESULT_CLOSE_SOCKET : Activ::IpSocket
  • COMPLETION_RESULT_OK : Activ::IpSocket

- e -

  • ENDIAN_BIG : Activ::MessageHandler
  • ENDIAN_LITTLE : Activ::MessageHandler
  • ENDIAN_LOCAL : Activ::MessageHandler
  • EVENT_TYPE_ADDED : Activ::DirectoryWatchApi
  • EVENT_TYPE_DELETED : Activ::DirectoryWatchApi
  • EVENT_TYPE_MODIFIED : Activ::DirectoryWatchApi
  • EXCEPTION_HANDLER_TYPE_FULL_MEMORY : Activ::Application::Settings
  • EXCEPTION_HANDLER_TYPE_NONE : Activ::Application::Settings
  • EXCEPTION_HANDLER_TYPE_NORMAL : Activ::Application::Settings

- f -

  • FIELD_RULE_BIT_APPLY_TRENDING : Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ContentServerRuleSet
  • FIELD_RULE_BIT_DO_NOT_APPLY_ADD_RULE_1 : Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::TranslatorRuleSet , Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ContentServerRuleSet
  • FIELD_RULE_BIT_DO_NOT_APPLY_ADD_RULE_2 : Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::TranslatorRuleSet , Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ContentServerRuleSet
  • FIELD_RULE_BIT_DO_NOT_APPLY_CHANGE_RULE : Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::TranslatorRuleSet , Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ContentServerRuleSet
  • FIELD_RULE_BIT_DO_NOT_APPLY_TRENDING : Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::TranslatorRuleSet
  • FIELD_RULE_BIT_DO_NOT_TEST_HIGH_LOW : Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::TranslatorRuleSet
  • FIELD_RULE_BIT_DO_NOT_TEST_OPEN : Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::TranslatorRuleSet
  • FIELD_RULE_BIT_DO_NOT_UPDATE_FIELD : Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::TranslatorRuleSet , Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ContentServerRuleSet
  • FIELD_RULE_BIT_IS_HIGH : Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ContentServerRuleSet
  • FIELD_RULE_BIT_IS_LOW : Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ContentServerRuleSet
  • FIELD_RULE_BIT_IS_OPEN : Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ContentServerRuleSet

- g -

  • GET_BUFFERS_RESULT_CLOSE_SOCKET : Activ::IpSocket
  • GET_BUFFERS_RESULT_NO_MORE_BUFFERS : Activ::IpSocket

- m -

  • MEMORY_MODEL_PRIVATE : Activ::ISystem::Settings
  • MEMORY_MODEL_SHARED : Activ::ISystem::Settings

- n -

  • NUMBER_OF_RULE_SETS : Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions

- p -

  • PROPERTY_CONVERT : Activ::Database::TableSpecification
  • PROPERTY_CREATE_MUTEX : Activ::Database::DatabaseSpecification , Activ::Database::TableSpecification
  • PROPERTY_CREATE_RECORD_FILE : Activ::Database::TableSpecification

- r -

  • RULE_SET_CONTENT_SERVER : Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions
  • RULE_SET_COPY : Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions
  • RULE_SET_NONE : Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions
  • RULE_SET_PARTIAL_BIT_UPDATE : Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions
  • RULE_SET_PARTIAL_BYTE_UPDATE : Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions
  • RULE_SET_TRANSLATOR : Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions

- s -

  • SHUTDOWN_REASON_API : Activ::Application
  • SHUTDOWN_REASON_LOGOFF : Activ::Application
  • SHUTDOWN_REASON_NOT_LICENSED : Activ::Application
  • SHUTDOWN_REASON_PROCESS_KILLED : Activ::Application
  • SHUTDOWN_REASON_UI : Activ::Application
  • SHUTDOWN_REASON_UI_RESTART : Activ::Application
  • SHUTDOWN_REASON_UPDATING : Activ::Application
  • SYSTEM_LOG_MODE_OFF : Activ::ISystem::Settings
  • SYSTEM_LOG_MODE_TO_AGENT : Activ::ISystem::Settings
  • SYSTEM_LOG_MODE_TO_CONSOLE : Activ::ISystem::Settings

- t -

  • TYPE_ALL_FIELDS : Activ::ContentPlatform::Feed::PermissionInfo::PermissionIdInfo
  • TYPE_BINARY : Activ::RegistryHelper
  • TYPE_DEFAULT : Activ::UiComponent
  • TYPE_EXCLUDE_FIELDS : Activ::ContentPlatform::Feed::PermissionInfo::PermissionIdInfo
  • TYPE_INCLUDE_FIELDS : Activ::ContentPlatform::Feed::PermissionInfo::PermissionIdInfo
  • TYPE_MAIN : Activ::UiComponent
  • TYPE_MIDDLEWARE : Activ::UiComponent
  • TYPE_STRING : Activ::RegistryHelper
  • TYPE_UNSIGNED32 : Activ::RegistryHelper
  • TYPE_UNSUPPORTED : Activ::RegistryHelper
Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- a -

  • AbortiveClose() : Activ::UdpSocket
  • Accept() : Activ::TcpSocket
  • Acquire()
: Activ::ISemaphore
, Activ::ScopedMutexTryLocker
, Activ::IMutex
, Activ::DeferredScopedMutexLocker
  • Add()
: Activ::Database::ITable
, Activ::DateTime
, Activ::Rational
, Activ::Database::ITable
, Activ::SInt
, Activ::Time
, Activ::Date
, Activ::Time
, Activ::DateTime
, Activ::Time
, Activ::DateTime
, Activ::UInt
, Activ::DateTime
, Activ::Database::ITable
, Activ::DateTime
  • AddCompletion() : Activ::UiIo::CompletionHelper
  • AddDescriptions() : Activ::CommandLineParser
  • AddDisabledDate() : Activ::Timeband
  • AddException() : Activ::Exception
  • AddOption() : Activ::UiMenu
  • AddProcess() : Activ::SystemMonitor
  • Address() : Activ::Address
  • AddUpdateFilter() : Activ::ContentPlatform::ContentServerApi::ContentServerClient
  • AddWatch() : Activ::DirectoryWatchApi
  • Adjust() : Activ::ContentPlatform::ContentGatewayApi::HistoryBar
  • AdjustGetBufferSize()
: Activ::ScatterBufferHelper
, Activ::HeapMessage::ReadHelper
  • AdjustSystemTime() : Activ::TimerServiceApi
  • AgentApplication() : Activ::AgentApplication
  • AllocateBuffer() : Activ::Database::FieldListObject
  • Append()
: Activ::ContentPlatform::Feed::CompressedMessageDefinitions::FieldHeaderBuilder
, Activ::MessageBuilder
, Activ::WsaBufHelper
, Activ::HeapMessage
  • AppendBoolean() : Activ::MessageBuilder
  • AppendField()
: Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::RecordMessageBuilder
, Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::SymbolRecordMessageBuilder
, Activ::ContentPlatform::Feed::RecordFieldListBuilder
, Activ::ContentPlatform::Feed::RecordKeyFieldListBuilder
, Activ::ContentPlatform::Feed::RecordMessageBuilder
, Activ::ContentPlatform::Feed::SymbolRecordFieldListBuilder
, Activ::ContentPlatform::Feed::SymbolRecordMessageBuilder
  • AppendFieldWithContentServerRuleSet()
: Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::SymbolRecordMessageBuilder
, Activ::ContentPlatform::Feed::SymbolRecordFieldListBuilder
, Activ::ContentPlatform::Feed::SymbolRecordMessageBuilder
  • AppendFieldWithNoneRuleSet()
: Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::SymbolRecordMessageBuilder
, Activ::ContentPlatform::Feed::SymbolRecordFieldListBuilder
, Activ::ContentPlatform::Feed::SymbolRecordMessageBuilder
, Activ::ContentPlatform::Feed::SymbolRecordFieldListBuilder
  • AppendFieldWithTranslatorRuleSet()
: Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::SymbolRecordMessageBuilder
, Activ::ContentPlatform::Feed::SymbolRecordMessageBuilder
, Activ::ContentPlatform::Feed::SymbolRecordFieldListBuilder
, Activ::ContentPlatform::Feed::SymbolRecordMessageBuilder
, Activ::ContentPlatform::Feed::SymbolRecordFieldListBuilder
  • AppendHeader()
: Activ::ContentPlatform::Feed::SymbolRecordMessageBuilder
, Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::RecordMessageBuilder
, Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::SymbolRecordMessageBuilder
, Activ::ContentPlatform::Feed::RecordMessageBuilder
  • AppendIndexNumber()
: Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::RecordMessageBuilder
, Activ::ContentPlatform::Feed::RecordMessageBuilder
  • AppendInEndian() : Activ::MessageBuilder
  • AppendKeyField()
: Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::RecordMessageBuilder
, Activ::ContentPlatform::Feed::RecordMessageBuilder
  • AppendRxBuffer() : Activ::IpSocket
  • AppendTxBuffer() : Activ::IpSocket
  • AppendUndefinedField()
: Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::SymbolRecordMessageBuilder
, Activ::ContentPlatform::Feed::SymbolRecordFieldListBuilder
, Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::RecordMessageBuilder
, Activ::ContentPlatform::Feed::RecordMessageBuilder
, Activ::ContentPlatform::Feed::RecordFieldListBuilder
, Activ::ContentPlatform::Feed::SymbolRecordMessageBuilder
, Activ::ContentPlatform::Feed::RecordKeyFieldListBuilder
  • AppendUndefinedKeyField()
: Activ::ContentPlatform::Feed::RecordMessageBuilder
, Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::RecordMessageBuilder
  • ApplyTableTemplateAddition()
: Activ::ContentPlatform::Feed::TableTemplateList
, Activ::ContentPlatform::Feed::TableTemplate
  • ApplyUpdate()
: Activ::ContentPlatform::ContentServerApi::FieldListValidator
, Activ::ContentPlatform::ContentGatewayApi::FieldListValidator
, Activ::ContentPlatform::ContentServerApi::FieldListValidator
, Activ::ContentPlatform::FeedApi::FieldListValidator
, Activ::ContentPlatform::ContentServerApi::FieldListValidator
  • ApplyUpdateToExistingFieldsOnly()
: Activ::ContentPlatform::FeedApi::FieldListValidator
, Activ::ContentPlatform::ContentGatewayApi::FieldListValidator
  • Assign() : Activ::IFieldType
  • AtomicInteger() : Activ::AtomicInteger
  • AtomicPointer() : Activ::AtomicPointer< T >
  • Attach()
: Activ::ScatterBufferHelper
, Activ::HeapMessage
, Activ::ScatterBufferHelper
  • AttachHandle() : Activ::IoCompletionManager
  • AttachTable() : Activ::Database::Database
Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- j -

  • JoinMulticastGroup()
: Activ::RouterServiceApi::Udp
, Activ::UdpSocket
, Activ::UdpComponent
Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- k -

  • Key()
: Activ::Database::Key
, Activ::DesHelper::Key
, Activ::Des3Helper::Key
, Activ::DesHelper::Key
, Activ::Database::Key
, Activ::Des3Helper::Key
  • KeyBundle() : Activ::Des3Helper::KeyBundle
  • KeyFieldListTitleToString() : Activ::ContentPlatform::Feed::RecordKeyFieldListValidator
  • Kill() : Activ::Process
Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- l -

  • LeaveMulticastGroup()
: Activ::RouterServiceApi::Udp
, Activ::UdpComponent
, Activ::UdpSocket
  • Listen() : Activ::RouterServiceApi::Tcp
  • LocalTime() : Activ::LocalTime
  • LockedBreak() : Activ::TcpSocket
  • LockedRead() : Activ::IpSocket
  • LockedWrite() : Activ::IpSocket
  • LogMessage() : Activ::LoggerServiceApi
  • Logoff() : Activ::ContentPlatform::ContentServerApi::ContentServerClient
  • Logon() : Activ::ContentPlatform::ContentServerApi::ContentServerClient
  • LowFields() : Activ::ContentPlatform::Feed::Rule::LowFields
Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- m -

  • MakeAbsolutePath() : Activ::File
  • MakePath() : Activ::File
  • ManagedEndPoint() : Activ::ManagedEndPoint
  • MandatoryParameterDescription() : Activ::CommandLineParserDetail::MandatoryParameterDescription< T >
  • MandatorySwitchDescription() : Activ::CommandLineParserDetail::MandatorySwitchDescription< T >
  • Menu() : Activ::UiMainComponent::Menu
  • MessageBuilder() : Activ::MessageBuilder
  • MessageHandler() : Activ::MessageHandler
  • MessageModelToString() : Activ::RequestId
  • MessageRateThrottler() : Activ::MessageRateThrottler
  • MessageStats() : Activ::ContentPlatform::ContentServerApi::ContentServerClient::MessageStats
  • MessageValidator() : Activ::MessageValidator
  • Milliseconds() : Activ::Time::Milliseconds
  • Minutes() : Activ::Time::Minutes
  • MonthToString()
: Activ::BaseTime
, Activ::Date
  • Multiply()
: Activ::SInt
, Activ::Rational
, Activ::UInt
Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- n -

  • NamePrefixToString()
: Activ::ContentPlatform::Feed::RecordFieldListValidator
, Activ::ContentPlatform::Feed::RecordKeyFieldListValidator
  • NewsRequestParameters() : Activ::ContentPlatform::ContentGatewayApi::NewsRequestParameters
  • NewsResponseParameters() : Activ::ContentPlatform::ContentGatewayApi::NewsResponseParameters
  • NotificationTypeToString() : Activ::IEndPoint
Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- o -

  • OnAccept()
: Activ::Component
, Activ::Service
, Activ::TcpSocket
  • OnAcceptAborted() : Activ::TcpSocket
  • OnAcceptFailed() : Activ::TcpSocket
  • OnBreak()
: Activ::Component
, Activ::TcpSocket
, Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
, Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient
  • OnCleanupIo() : Activ::IpSocket
  • OnConnect()
: Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
, Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient
, Activ::Component
, Activ::TcpSocket
  • OnConnectAborted() : Activ::TcpSocket
  • OnConnectFailed()
: Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
, Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient
, Activ::Component
, Activ::TcpSocket
  • OnContentGatewayInfoUpdate() : Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
  • OnCtrlEvent()
: Activ::AgentApplication
, Activ::Application
  • OnData() : Activ::Component
  • OnDirectory()
: Activ::DirectoryRemover
, Activ::DirectoryWalker
  • OnDisconnect()
: Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
, Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient
, Activ::Component
, Activ::TcpSocket
  • OnError() : Activ::UdpSocket
  • OnEvent() : Activ::CtrlHandler
  • OnFile()
: Activ::DirectoryRemover
, Activ::DirectoryWalker
  • OnFlush() : Activ::ContentPlatform::ContentServerApi::ContentServerClient
  • OnGetEqualResponse()
: Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
, Activ::ContentPlatform::ContentGatewayApi::IRealtimeResponses
  • OnGetFirstHistoryResponse()
: Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
, Activ::ContentPlatform::ContentGatewayApi::ITimeSeriesResponses
  • OnGetFirstIntradayResponse()
: Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
, Activ::ContentPlatform::ContentGatewayApi::ITimeSeriesResponses
  • OnGetFirstResponse()
: Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
, Activ::ContentPlatform::ContentGatewayApi::IRealtimeResponses
  • OnGetFirstTicksResponse()
: Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
, Activ::ContentPlatform::ContentGatewayApi::ITimeSeriesResponses
  • OnGetLastResponse()
: Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
, Activ::ContentPlatform::ContentGatewayApi::IRealtimeResponses
  • OnGetMatchResponse()
: Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
, Activ::ContentPlatform::ContentGatewayApi::IRealtimeResponses
  • OnGetMultipleEqualResponse()
: Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
, Activ::ContentPlatform::ContentGatewayApi::IRealtimeResponses
  • OnGetMultipleMatchResponse()
: Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
, Activ::ContentPlatform::ContentGatewayApi::IRealtimeResponses
  • OnGetMultiplePatternMatchListResponse()
: Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
, Activ::ContentPlatform::ContentGatewayApi::IRealtimeResponses
  • OnGetMultiplePatternMatchResponse()
: Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
, Activ::ContentPlatform::ContentGatewayApi::IRealtimeResponses
  • OnGetNewsStoriesResponse()
: Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
, Activ::ContentPlatform::ContentGatewayApi::INewsResponses
  • OnGetNextHistoryResponse()
: Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
, Activ::ContentPlatform::ContentGatewayApi::ITimeSeriesResponses
  • OnGetNextIntradayResponse()
: Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
, Activ::ContentPlatform::ContentGatewayApi::ITimeSeriesResponses
  • OnGetNextResponse()
: Activ::ContentPlatform::ContentGatewayApi::IRealtimeResponses
, Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
  • OnGetNextTicksResponse()
: Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
, Activ::ContentPlatform::ContentGatewayApi::ITimeSeriesResponses
  • OnGetPreviousResponse()
: Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
, Activ::ContentPlatform::ContentGatewayApi::IRealtimeResponses
  • OnGetRxBuffers() : Activ::IpSocket
  • OnGetSymbolsResponse()
: Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
, Activ::ContentPlatform::ContentGatewayApi::ISymbolDirectoryResponses
  • OnGetTxBuffers() : Activ::IpSocket
  • OnInitializeIo() : Activ::IpSocket
  • OnInputString() : Activ::Shell
  • OnIoCompletion() : Activ::IoCompletionManager::Overlapped
  • OnMessage()
: Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
, Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient
, Activ::AgentApplication
, Activ::Application
, Activ::Component
, Activ::ThinApplication
, Activ::UdpComponent
, Activ::Port
  • OnNewsUpdate()
: Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
, Activ::ContentPlatform::ContentGatewayApi::INewsResponses
  • OnObject()
: Activ::ISystem::IProcessEnumerator
, Activ::ISystem::IEndPointEnumerator
, Activ::ISystem::IHeapEnumerator
  • OnOption() : Activ::UiMainComponent
  • OnOutputString() : Activ::Shell
  • OnPopulateCompletionList() : Activ::UiIo::DynamicCompletionHelper
  • OnRecordUpdate()
: Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
, Activ::ContentPlatform::ContentGatewayApi::IRealtimeResponses
, Activ::ContentPlatform::ContentServerApi::ContentServerClient
  • OnReportMessage()
: Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
, Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient
  • OnRequest()
: Activ::Component
, Activ::Port
  • OnResponse()
: Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
, Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient
, Activ::Port
  • OnRxBuffers()
: Activ::IpSocket
, Activ::TcpSocket
, Activ::UdpSocket
  • OnSetSocketOptions() : Activ::IpSocket
  • OnShutdown()
: Activ::Application
, Activ::UdpSocket
  • OnSocketClose() : Activ::UdpComponent
  • OnSocketError() : Activ::UdpComponent
  • OnSymbolRecordUpdate() : Activ::ContentPlatform::ContentServerApi::ContentServerClient
  • OnThreadExit()
: Activ::ThreadSpecificDataBase< TYPE, DERIVED >
, Activ::ThreadSpecificData< TYPE, CLEANUP >
  • OnTimer()
: Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
, Activ::ContentPlatform::ContentServerApi::ContentServerClient
, Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient
, Activ::Component
  • OnTxBuffers()
: Activ::IpSocket
, Activ::TcpSocket
, Activ::UdpSocket
  • Open()
: Activ::SystemFactory
, Activ::File
, Activ::FileMappedMemoryFactory
, Activ::PagingFileMappedMemoryFactory
, Activ::SharedEventFactory
, Activ::SharedMutexFactory
, Activ::SharedObject< T >
, Activ::SharedSemaphoreFactory
, Activ::SharedCompletionPortEventFactory
  • OpenEndPoint()
: Activ::SystemProxy
, Activ::ISystem
  • OpenFields() : Activ::ContentPlatform::Feed::Rule::OpenFields
  • OpenHeap()
: Activ::SystemProxy
, Activ::ISystem
  • OpenLogFile() : Activ::LoggerServiceApi
  • OpenProcess()
: Activ::SystemProxy
, Activ::ISystem
  • OpenRecordFile() : Activ::Database::ITable
  • OpenService() : Activ::ServiceApi
  • OpenServiceRequest() : Activ::OpenServiceRequest
  • OpenServiceResponse() : Activ::OpenServiceResponse
  • operator *()
: Activ::ContentPlatform::Feed::TableTemplate::ConstFieldIterator
, Activ::ContentPlatform::Feed::TableTemplate::ConstIndexIterator
, Activ::ContentPlatform::Feed::TableTemplate::ConstRuleIterator
, Activ::ContentPlatform::Feed::TableTemplate::ConstCopyOnResetIterator
, Activ::ContentPlatform::Feed::TableTemplate::ConstUndefineOnResetIterator
, Activ::ContentPlatform::Feed::TableTemplateList::ConstIterator
, Activ::ContentPlatform::Feed::UniversalFieldList::ConstIterator
, Activ::ScatterBufferHelper::ConstIterator
, Activ::HeapMessage::Iterator
  • operator *=()
: Activ::Rational
, Activ::SInt
, Activ::UInt
  • operator Address &() : Activ::Address::Proxy
  • operator bool()
: Activ::ScopedMutexTryLocker
, Activ::DeferredScopedMutexLocker
, Activ::HeapMessage
  • operator const Address &() : Activ::ScopedAddress
  • operator const Date &() : Activ::DateTime
  • operator const Rational()
: Activ::SInt
, Activ::UInt
  • operator const Rational &() : Activ::TRational
  • operator const SInt() : Activ::UInt
  • operator const Time &() : Activ::DateTime
  • operator HANDLE() : Activ::SocketWrapper
  • operator Pointer() : Activ::AtomicPointer< T >
  • operator Proxy()
: Activ::HeapMessage
, Activ::ScopedAddress
  • operator SOCKET() : Activ::SocketWrapper
  • operator std::string() : Activ::UiIo::Attribute
  • operator T() : Activ::ScopedHelper< T, D >
  • operator Type() : Activ::AtomicInteger
  • operator!()
: Activ::ScopedMutexTryLocker
, Activ::DeferredScopedMutexLocker
, Activ::HeapMessage
  • operator!=()
: Activ::ContentPlatform::ContentGatewayApi::HistoryBar
, Activ::ContentPlatform::ContentGatewayApi::IntradayBar
, Activ::ContentPlatform::ContentGatewayApi::OptionBar
, Activ::ContentPlatform::ContentGatewayApi::Tick
, Activ::ContentPlatform::ContentGatewayApi::SymbolId
, Activ::ContentPlatform::FeedApi::FieldListValidator::ConstIterator
, Activ::ContentPlatform::Feed::RecordFieldListValidator::ConstIterator
, Activ::ContentPlatform::Feed::RecordKeyFieldListValidator::ConstIterator
, Activ::ContentPlatform::Feed::SymbolRecordFieldListValidator::ConstIterator
, Activ::ContentPlatform::Feed::TableTemplateFieldListValidator::ConstIterator
, Activ::ContentPlatform::Feed::Field
, Activ::ContentPlatform::Feed::CopyOnReset
, Activ::ContentPlatform::Feed::Rule::CopyToFields
, Activ::ContentPlatform::Feed::Rule::HighFields
, Activ::ContentPlatform::Feed::Rule::LowFields
, Activ::ContentPlatform::Feed::Rule::OpenFields
, Activ::ContentPlatform::Feed::Rule::CloseFields
, Activ::ContentPlatform::Feed::Rule::PriceFields
, Activ::ContentPlatform::Feed::Rule::VolumeFields
, Activ::ContentPlatform::Feed::Rule
, Activ::ContentPlatform::Feed::TableTemplate::ConstFieldIterator
, Activ::ContentPlatform::Feed::TableTemplate::ConstIndexIterator
, Activ::ContentPlatform::Feed::TableTemplate::ConstRuleIterator
, Activ::ContentPlatform::Feed::TableTemplate::ConstCopyOnResetIterator
, Activ::ContentPlatform::Feed::TableTemplate::ConstUndefineOnResetIterator
, Activ::ContentPlatform::Feed::TableTemplate
, Activ::ContentPlatform::Feed::TableTemplateList::ConstIterator
, Activ::ContentPlatform::Feed::UniversalFieldList::ConstIterator
, Activ::ConsoleWindow::Coord
, Activ::IniFileParser::ConstKeyIterator
, Activ::IniFileParser::ConstSectionIterator
, Activ::ScatterBufferHelper::ConstIterator
, Activ::Uuid
, Activ::Database::Database::ConstIterator
, Activ::Database::Database::Iterator
, Activ::Database::FieldList::ConstIterator
, Activ::Database::FieldSpecification
, Activ::Database::IndexSpecification::Field
, Activ::Database::IndexSpecification
, Activ::Database::Key
, Activ::Database::Record
, Activ::Database::TableSpecification
, Activ::Date
, Activ::DateTime
, Activ::Rational
, Activ::SInt
, Activ::Time
, Activ::UInt
, Activ::ServiceId
, Activ::Timeband
, Activ::BaseTime
, Activ::IpAddress
, Activ::Address
, Activ::HeapMessage::Iterator
, Activ::HeapMessage
, Activ::RequestId
, Activ::ScopedAddress
, Activ::Subject
, Activ::FileInfo
  • operator()()
: Activ::MessageBuilderVariableLengthRangeCheck< false >
, Activ::Timeout
, Activ::HeapMessageDeserializer< MESSAGE_TYPE, BUFFER_SIZE >
, Activ::ManagedEndPoint::RunHelper
, Activ::DeleteObject
, Activ::DeleteObjectArray
, Activ::DeleteAssociativeObject
, Activ::LessThanPairComparisonObject< Pair >
, Activ::EqualToPairComparisonObject< Pair >
, Activ::CaseInsensitiveLessThanStringComparisonObject
, Activ::ScopedPooledObject< T >
, Activ::StringHashCompare< TRAITS >
, Activ::SelectFirst< P >
, Activ::SelectSecond< P >
, Activ::SelectFirstFromSecond< P >
, Activ::CommandLineParserDetail::ValueStore< T >
, Activ::CommandLineParserDetail::DescriptionAppender
, Activ::MessageBuilderVariableLengthRangeCheck< true >
  • operator+()
: Activ::DateTime
, Activ::MessageBuilder
, Activ::Date
, Activ::Time
  • operator++()
: Activ::ContentPlatform::Feed::SymbolRecordFieldListValidator::ConstIterator
, Activ::ContentPlatform::Feed::RecordFieldListValidator::ConstIterator
, Activ::ContentPlatform::FeedApi::FieldListValidator::ConstIterator
, Activ::ContentPlatform::Feed::RecordFieldListValidator::ConstIterator
, Activ::ContentPlatform::Feed::RecordKeyFieldListValidator::ConstIterator
, Activ::ContentPlatform::Feed::SymbolRecordFieldListValidator::ConstIterator
, Activ::ContentPlatform::Feed::TableTemplateFieldListValidator::ConstIterator
, Activ::ContentPlatform::Feed::TableTemplate::ConstFieldIterator
, Activ::ContentPlatform::Feed::TableTemplate::ConstIndexIterator
, Activ::ContentPlatform::Feed::TableTemplate::ConstRuleIterator
, Activ::ContentPlatform::Feed::TableTemplate::ConstCopyOnResetIterator
, Activ::ContentPlatform::Feed::TableTemplate::ConstUndefineOnResetIterator
, Activ::ContentPlatform::Feed::TableTemplateList::ConstIterator
, Activ::ContentPlatform::Feed::UniversalFieldList::ConstIterator
, Activ::AtomicInteger
, Activ::IniFileParser::ConstKeyIterator
, Activ::IniFileParser::ConstSectionIterator
, Activ::ScatterBufferHelper::ConstIterator
, Activ::Database::Database::ConstIterator
, Activ::Database::Database::Iterator
, Activ::Database::FieldList::ConstIterator
, Activ::HeapMessage::Iterator
, Activ::Database::FieldList::ConstIterator
, Activ::ReferenceCounter
, Activ::Database::Database::ConstIterator
, Activ::ContentPlatform::Feed::TableTemplate::ConstUndefineOnResetIterator
, Activ::ContentPlatform::Feed::UniversalFieldList::ConstIterator
, Activ::ContentPlatform::Feed::TableTemplate::ConstRuleIterator
  • operator+=()
: Activ::MessageBuilder
, Activ::Date
, Activ::DateTime
, Activ::Rational
, Activ::SInt
, Activ::Time
, Activ::UInt
, Activ::BaseTime
  • operator-()
: Activ::Date
, Activ::DateTime
, Activ::Time
  • operator--() : Activ::AtomicInteger , Activ::ReferenceCounter
  • operator-=()
: Activ::DateTime
, Activ::Rational
, Activ::SInt
, Activ::Time
, Activ::UInt
, Activ::BaseTime
, Activ::Date
  • operator->()
: Activ::ContentPlatform::Feed::TableTemplate::ConstIndexIterator
, Activ::ContentPlatform::Feed::TableTemplate::ConstRuleIterator
, Activ::ContentPlatform::Feed::TableTemplate::ConstCopyOnResetIterator
, Activ::ContentPlatform::Feed::TableTemplateList::ConstIterator
, Activ::ContentPlatform::Feed::UniversalFieldList::ConstIterator
, Activ::AtomicPointer< T >
, Activ::HeapMessage::Iterator
, Activ::ContentPlatform::Feed::TableTemplate::ConstUndefineOnResetIterator
, Activ::ScatterBufferHelper::ConstIterator
, Activ::ContentPlatform::Feed::TableTemplate::ConstFieldIterator
  • operator/=()
: Activ::UInt
, Activ::Rational
, Activ::SInt
  • operator<()
: Activ::Address
, Activ::ContentPlatform::ContentGatewayApi::Tick
, Activ::RequestId
, Activ::SInt
, Activ::BaseTime
, Activ::Database::IndexSpecification
, Activ::Database::Key
, Activ::Uuid
, Activ::ContentPlatform::ContentGatewayApi::Tick
, Activ::ContentPlatform::ContentGatewayApi::HistoryBar
, Activ::ContentPlatform::ContentGatewayApi::IntradayBar
, Activ::ContentPlatform::ContentGatewayApi::OptionBar
, Activ::ContentPlatform::ContentGatewayApi::HistoryBar
, Activ::Date
, Activ::DateTime
, Activ::Rational
, Activ::Time
, Activ::IpAddress
, Activ::Database::FieldSpecification
, Activ::ContentPlatform::ContentGatewayApi::SymbolId
, Activ::UInt
, Activ::ServiceId
, Activ::Subject
  • operator<=()
: Activ::DateTime
, Activ::UInt
, Activ::ContentPlatform::ContentGatewayApi::Tick
, Activ::ContentPlatform::ContentGatewayApi::HistoryBar
, Activ::Time
, Activ::SInt
, Activ::Uuid
, Activ::Database::Key
, Activ::Date
, Activ::Rational
, Activ::BaseTime
, Activ::ContentPlatform::ContentGatewayApi::IntradayBar
, Activ::ContentPlatform::ContentGatewayApi::OptionBar
, Activ::Subject
  • operator=()
: Activ::Blob
, Activ::ScopedAddress
, Activ::MessageBuilder
, Activ::TextArray
, Activ::TextString
, Activ::ContentPlatform::Feed::Field
, Activ::Database::Key
, Activ::SocketWrapper
, Activ::BinaryString
, Activ::Timeband
, Activ::ContentPlatform::FeedApi::FieldListValidator
, Activ::AtomicPointer< T >
, Activ::Database::Record
, Activ::BinaryArray
, Activ::CrcBlob
, Activ::BaseTime
, Activ::HeapMessage
, Activ::ScopedAddress
, Activ::SyncRequestId
, Activ::SerializableBuffer< LENGTH_TYPE, MIN_LENGTH, MAX_LENGTH >
, Activ::RequestId
, Activ::SocketWrapper
, Activ::ScatterBufferHelper
, Activ::HeapMessage
, Activ::HeapMessage::ReadHelper
  • operator==()
: Activ::Database::Record
, Activ::ContentPlatform::Feed::Rule::OpenFields
, Activ::UInt
, Activ::ConsoleWindow::Coord
, Activ::Database::Database::ConstIterator
, Activ::ContentPlatform::Feed::TableTemplate::ConstIndexIterator
, Activ::Database::IndexSpecification::Field
, Activ::ContentPlatform::Feed::Rule::CopyToFields
, Activ::Date
, Activ::ContentPlatform::Feed::Rule::PriceFields
, Activ::ContentPlatform::ContentGatewayApi::DataPointAddress
, Activ::Database::FieldSpecification
, Activ::SInt
, Activ::ContentPlatform::Feed::Rule::LowFields
, Activ::Rational
, Activ::DateTime
, Activ::Time
, Activ::ContentPlatform::Feed::CopyOnReset
, Activ::Subject
, Activ::ContentPlatform::ContentGatewayApi::IntradayBar
, Activ::Database::Key
, Activ::Database::Database::Iterator
, Activ::ContentPlatform::Feed::Field
, Activ::HeapMessage::Iterator
, Activ::Database::FieldList::ConstIterator
, Activ::Database::IndexSpecification
, Activ::HeapMessage
, Activ::Timeband
, Activ::FileInfo
, Activ::ScatterBufferHelper::ConstIterator
, Activ::ContentPlatform::Feed::TableTemplate
, Activ::ContentPlatform::Feed::TableTemplateFieldListValidator::ConstIterator
, Activ::ContentPlatform::ContentGatewayApi::IntradayBar
, Activ::ContentPlatform::Feed::UniversalFieldList::ConstIterator
, Activ::ContentPlatform::Feed::Rule
, Activ::BaseTime
, Activ::ContentPlatform::FeedApi::FieldListValidator::ConstIterator
, Activ::IniFileParser::ConstSectionIterator
, Activ::ContentPlatform::Feed::TableTemplate::ConstCopyOnResetIterator
, Activ::ContentPlatform::Feed::TableTemplate::ConstRuleIterator
, Activ::ContentPlatform::Feed::TableTemplateList::ConstIterator
, Activ::IniFileParser::ConstKeyIterator
, Activ::RequestId
, Activ::ContentPlatform::Feed::RecordKeyFieldListValidator::ConstIterator
, Activ::ContentPlatform::Feed::Rule::HighFields
, Activ::ContentPlatform::Feed::Rule::VolumeFields
, Activ::IpAddress
, Activ::Address
, Activ::ContentPlatform::ContentGatewayApi::HistoryBar
, Activ::ContentPlatform::ContentGatewayApi::Tick
, Activ::ContentPlatform::ContentGatewayApi::Period
, Activ::ContentPlatform::Feed::SymbolRecordFieldListValidator::ConstIterator
, Activ::ContentPlatform::ContentGatewayApi::SymbolId
, Activ::ServiceId
, Activ::ContentPlatform::Feed::RecordFieldListValidator::ConstIterator
, Activ::ContentPlatform::Feed::TableTemplate::ConstFieldIterator
, Activ::ContentPlatform::ContentGatewayApi::OptionBar
, Activ::Database::TableSpecification
, Activ::ContentPlatform::Feed::TableTemplate::ConstUndefineOnResetIterator
, Activ::Uuid
, Activ::ContentPlatform::Feed::Rule::CloseFields
, Activ::ContentPlatform::ContentGatewayApi::HistoryBar
, Activ::ContentPlatform::ContentGatewayApi::Tick
, Activ::ScopedAddress
  • operator>()
: Activ::BaseTime
, Activ::ContentPlatform::ContentGatewayApi::HistoryBar
, Activ::SInt
, Activ::Subject
, Activ::UInt
, Activ::ContentPlatform::ContentGatewayApi::HistoryBar
, Activ::ContentPlatform::ContentGatewayApi::OptionBar
, Activ::Rational
, Activ::ContentPlatform::ContentGatewayApi::IntradayBar
, Activ::Database::Key
, Activ::Date
, Activ::Time
, Activ::Uuid
, Activ::DateTime
, Activ::ContentPlatform::ContentGatewayApi::IntradayBar
, Activ::ContentPlatform::ContentGatewayApi::Tick
  • operator>=()
: Activ::DateTime
, Activ::ContentPlatform::ContentGatewayApi::HistoryBar
, Activ::Database::Key
, Activ::SInt
, Activ::UInt
, Activ::Rational
, Activ::Subject
, Activ::ContentPlatform::ContentGatewayApi::IntradayBar
, Activ::Uuid
, Activ::Date
, Activ::BaseTime
, Activ::Time
, Activ::ContentPlatform::ContentGatewayApi::OptionBar
, Activ::ContentPlatform::ContentGatewayApi::Tick
  • operator|() : Activ::UiIo::Attribute
  • OptionalParameterDescription() : Activ::CommandLineParserDetail::OptionalParameterDescription< T >
  • OptionalSwitchDescription() : Activ::CommandLineParserDetail::OptionalSwitchDescription< T >
  • OptionAttributes() : Activ::UiMenu::OptionAttributes
  • OptionBar() : Activ::ContentPlatform::ContentGatewayApi::OptionBar
  • OsException() : Activ::OsException
  • Overlapped() : Activ::IoCompletionManager::Overlapped
  • Overwrite()
: Activ::MessageBuilder
, Activ::HeapMessage
, Activ::MessageBuilder
  • OverwriteBoolean() : Activ::MessageBuilder
  • OverwriteInEndian() : Activ::MessageBuilder
Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- ~ -

  • ~AgentApplication() : Activ::AgentApplication
  • ~Application() : Activ::Application
  • ~BaseTime() : Activ::BaseTime
  • ~BinaryArray() : Activ::BinaryArray
  • ~BinaryString() : Activ::BinaryString
  • ~Blob() : Activ::Blob
  • ~CommandLineParser() : Activ::CommandLineParser
  • ~CompletionHelper() : Activ::UiIo::CompletionHelper
  • ~Component() : Activ::Component
  • ~CompressedCombinedQuoteMessageHeaderValidator() : Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator
  • ~CompressedMessageHeaderValidator() : Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator
  • ~ConsoleWindow() : Activ::ConsoleWindow
  • ~ContentGatewayClient() : Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
  • ~ContentServerClient() : Activ::ContentPlatform::ContentServerApi::ContentServerClient
  • ~ContributionGatewayClient() : Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient
  • ~ContributionServerClient() : Activ::ContentPlatform::ContributionServerApi::ContributionServerClient
  • ~CrcBlob() : Activ::CrcBlob
  • ~CtrlHandler() : Activ::CtrlHandler
  • ~CurlInitializeHelper() : Activ::CurlFtpHelper::CurlInitializeHelper
  • ~Database() : Activ::Database::Database
  • ~Date() : Activ::Date
  • ~DateTime() : Activ::DateTime
  • ~DeferredScopedMutexLocker() : Activ::DeferredScopedMutexLocker
  • ~DirectoryRemover() : Activ::DirectoryRemover
  • ~DirectoryWalker() : Activ::DirectoryWalker
  • ~DynamicLibraryLoader() : Activ::DynamicLibraryLoader< T >
  • ~Enabler() : Activ::Port::Enabler
  • ~Exception() : Activ::Exception
  • ~Fiber() : Activ::Fiber
  • ~Field() : Activ::ContentPlatform::Feed::Field
  • ~FieldList() : Activ::Database::FieldList
  • ~FieldListObject() : Activ::Database::FieldListObject
  • ~FieldListValidator() : Activ::ContentPlatform::FeedApi::FieldListValidator
  • ~FieldSet() : Activ::ContentPlatform::ContentGatewayApi::FieldSet
  • ~File() : Activ::File
  • ~FtpHelper() : Activ::FtpHelper
  • ~HeapMessage() : Activ::HeapMessage
  • ~HistoryBar() : Activ::ContentPlatform::ContentGatewayApi::HistoryBar
  • ~IEndPoint() : Activ::IEndPoint
  • ~IEndPointEnumerator() : Activ::ISystem::IEndPointEnumerator
  • ~IEvent() : Activ::IEvent
  • ~IFieldType() : Activ::IFieldType
  • ~IFileMappedMemory() : Activ::IFileMappedMemory
  • ~IFtpHelper() : Activ::IFtpHelper
  • ~IHeap() : Activ::IHeap
  • ~IHeapEnumerator() : Activ::ISystem::IHeapEnumerator
  • ~IIndex() : Activ::Database::IIndex
  • ~IMappedMemory() : Activ::IMappedMemory
  • ~IMutex() : Activ::IMutex
  • ~INewsResponses() : Activ::ContentPlatform::ContentGatewayApi::INewsResponses
  • ~IniFileParser() : Activ::IniFileParser
  • ~IntradayBar() : Activ::ContentPlatform::ContentGatewayApi::IntradayBar
  • ~IoCompletionManager() : Activ::IoCompletionManager
  • ~IpManager() : Activ::IpManager
  • ~IProcess() : Activ::IProcess
  • ~IProcessEnumerator() : Activ::ISystem::IProcessEnumerator
  • ~IpSocket() : Activ::IpSocket
  • ~IRealtimeResponses() : Activ::ContentPlatform::ContentGatewayApi::IRealtimeResponses
  • ~ISemaphore() : Activ::ISemaphore
  • ~ISerializableMessage() : Activ::ISerializableMessage
  • ~ISymbolDirectoryResponses() : Activ::ContentPlatform::ContentGatewayApi::ISymbolDirectoryResponses
  • ~ISystem() : Activ::ISystem
  • ~ITable() : Activ::Database::ITable
  • ~ITimeSeriesResponses() : Activ::ContentPlatform::ContentGatewayApi::ITimeSeriesResponses
  • ~Key() : Activ::Database::Key
  • ~ManagedEndPoint() : Activ::ManagedEndPoint
  • ~MessageBuilder() : Activ::MessageBuilder
  • ~MessageHandler() : Activ::MessageHandler
  • ~MessageRateThrottler() : Activ::MessageRateThrottler
  • ~OptionBar() : Activ::ContentPlatform::ContentGatewayApi::OptionBar
  • ~Port() : Activ::Port
  • ~PostMessageHelper() : Activ::PostMessageHelper
  • ~Proxy() : Activ::ScopedAddress::Proxy
  • ~Rational() : Activ::Rational
  • ~ReadHelper() : Activ::HeapMessage::ReadHelper
  • ~Record() : Activ::Database::Record
  • ~RecordFieldListBuilder() : Activ::ContentPlatform::Feed::RecordFieldListBuilder
  • ~RecordFieldListValidator() : Activ::ContentPlatform::Feed::RecordFieldListValidator
  • ~RecordKeyFieldListBuilder() : Activ::ContentPlatform::Feed::RecordKeyFieldListBuilder
  • ~RecordKeyFieldListValidator() : Activ::ContentPlatform::Feed::RecordKeyFieldListValidator
  • ~RecordMessageBuilder()
: Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::RecordMessageBuilder
, Activ::ContentPlatform::Feed::RecordMessageBuilder
  • ~RecordMessageHeaderValidator() : Activ::ContentPlatform::Feed::RecordMessageHeaderValidator
  • ~RecordMessageValidator() : Activ::ContentPlatform::Feed::RecordMessageValidator
  • ~RegistryHelper() : Activ::RegistryHelper
  • ~RunHelper() : Activ::ManagedEndPoint::RunHelper
  • ~ScatterBufferHelper() : Activ::ScatterBufferHelper
  • ~Scoped() : Activ::IntervalTimer::Scoped
  • ~ScopedAddress() : Activ::ScopedAddress
  • ~ScopedHelper() : Activ::ScopedHelper< T, D >
  • ~ScopedMutexLocker() : Activ::ScopedMutexLocker
  • ~ScopedMutexTryLocker() : Activ::ScopedMutexTryLocker
  • ~ScopedPooledObject() : Activ::ScopedPooledObject< T >
  • ~ScopedSubscription() : Activ::ScopedSubscription
  • ~ScopedVersion() : Activ::MessageHandler::ScopedVersion
  • ~SerializableBuffer() : Activ::SerializableBuffer< LENGTH_TYPE, MIN_LENGTH, MAX_LENGTH >
  • ~Service() : Activ::Service
  • ~Settings()
: Activ::ContentPlatform::ContentServerApi::ContentServerClient::Settings
, Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::Settings
, Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::Settings
, Activ::AgentApplication::Settings
  • ~SharedObject() : Activ::SharedObject< T >
  • ~Shell() : Activ::Shell
  • ~SInt() : Activ::SInt
  • ~SmtpHelper() : Activ::SmtpHelper
  • ~SocketWrapper() : Activ::SocketWrapper
  • ~SymbolPatternHelper() : Activ::ContentPlatform::FeedApi::SymbolPatternHelper
  • ~SymbolRecordField() : Activ::ContentPlatform::Feed::SymbolRecordField
  • ~SymbolRecordFieldListBuilder() : Activ::ContentPlatform::Feed::SymbolRecordFieldListBuilder
  • ~SymbolRecordFieldListValidator() : Activ::ContentPlatform::Feed::SymbolRecordFieldListValidator
  • ~SymbolRecordMessageBuilder()
: Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::SymbolRecordMessageBuilder
, Activ::ContentPlatform::Feed::SymbolRecordMessageBuilder
  • ~SymbolRecordMessageHeaderValidator() : Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator
  • ~SymbolRecordMessageValidator() : Activ::ContentPlatform::Feed::SymbolRecordMessageValidator
  • ~SyncRequestId() : Activ::SyncRequestId
  • ~SystemMonitor() : Activ::SystemMonitor
  • ~SystemProxy() : Activ::SystemProxy
  • ~TableTemplate() : Activ::ContentPlatform::Feed::TableTemplate
  • ~TableTemplateField() : Activ::ContentPlatform::Feed::TableTemplateField
  • ~TableTemplateFieldListValidator() : Activ::ContentPlatform::Feed::TableTemplateFieldListValidator
  • ~TableTemplateIndex() : Activ::ContentPlatform::Feed::TableTemplateIndex
  • ~TableTemplateIndexListValidator() : Activ::ContentPlatform::Feed::TableTemplateIndexListValidator
  • ~TableTemplateList() : Activ::ContentPlatform::Feed::TableTemplateList
  • ~TableTemplateMessageValidator() : Activ::ContentPlatform::Feed::TableTemplateMessageValidator
  • ~TcpListener() : Activ::TcpListener
  • ~TcpSocket() : Activ::TcpSocket
  • ~TextArray() : Activ::TextArray
  • ~TextString() : Activ::TextString
  • ~ThinApplication() : Activ::ThinApplication
  • ~Thread() : Activ::Thread
  • ~ThreadSpecificDataBase() : Activ::ThreadSpecificDataBase< TYPE, DERIVED >
  • ~Tick() : Activ::ContentPlatform::ContentGatewayApi::Tick
  • ~Time() : Activ::Time
  • ~TRational() : Activ::TRational
  • ~UdpComponent() : Activ::UdpComponent
  • ~UdpSocket() : Activ::UdpSocket
  • ~UiComponent() : Activ::UiComponent
  • ~UiMainComponent() : Activ::UiMainComponent
  • ~UiMenu() : Activ::UiMenu
  • ~UInt() : Activ::UInt
  • ~UniversalFieldList() : Activ::ContentPlatform::Feed::UniversalFieldList
  • ~WsaBufHelper() : Activ::WsaBufHelper
Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- b -

  • BaseException() : Activ::BaseException
  • Begin()
: Activ::ContentPlatform::FeedApi::FieldListValidator
, Activ::ContentPlatform::Feed::RecordKeyFieldListValidator
, Activ::ContentPlatform::Feed::TableTemplateIndex
, Activ::Database::FieldListObject
, Activ::HeapMessage
, Activ::ContentPlatform::Feed::TableTemplateIndexListValidator
, Activ::ContentPlatform::Feed::SymbolRecordFieldListValidator
, Activ::ContentPlatform::Feed::TableTemplateList
, Activ::ContentPlatform::Feed::UniversalFieldList
, Activ::ContentPlatform::Feed::RecordFieldListValidator
, Activ::ContentPlatform::Feed::SymbolRecordMessageValidator
, Activ::ScatterBufferHelper
, Activ::Database::Database
, Activ::ContentPlatform::Feed::TableTemplateFieldListValidator
, Activ::Database::Database
, Activ::Database::FieldList
  • BeginCopyOnReset() : Activ::ContentPlatform::Feed::TableTemplate
  • BeginField()
: Activ::ContentPlatform::Feed::RecordMessageValidator
, Activ::ContentPlatform::Feed::TableTemplateMessageValidator
, Activ::ContentPlatform::Feed::TableTemplate
  • BeginIndex()
: Activ::ContentPlatform::Feed::TableTemplateMessageValidator
, Activ::ContentPlatform::Feed::TableTemplate
  • BeginKey() : Activ::IniFileParser::ConstSectionIterator
  • BeginKeyField()
: Activ::ContentPlatform::ContentServerApi::RecordUpdate
, Activ::ContentPlatform::Feed::RecordMessageHeaderValidator
, Activ::ContentPlatform::Feed::RecordMessageValidator
  • BeginRule() : Activ::ContentPlatform::Feed::TableTemplate
  • BeginSection() : Activ::IniFileParser
  • BeginSubSection() : Activ::IniFileParser::ConstSectionIterator
  • BeginUndefineOnReset() : Activ::ContentPlatform::Feed::TableTemplate
  • BinaryArray() : Activ::BinaryArray
  • BinaryString() : Activ::BinaryString
  • Blob() : Activ::Blob
  • BooleanSwitch() : Activ::CommandLineParser
  • BooleanSwitchDescription() : Activ::CommandLineParserDetail::BooleanSwitchDescription
  • Break() : Activ::RouterServiceApi::Tcp
  • BreakAll() : Activ::RouterServiceApi::Tcp
  • BucketStats() : Activ::IHeap::Stats::BucketStats
  • Build() : Activ::Url
  • BuildKey()
: Activ::Database::Key
, Activ::Database::IIndex
  • BuildOpenServiceResponse() : Activ::Service
Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- c -

  • CalculateCrc() : Activ::CrcBlob
  • CancelTimer() : Activ::TimerServiceApi
  • CancelTimers() : Activ::TimerServiceApi
  • CancelWatch() : Activ::DirectoryWatchApi
  • CanThreadExit()
: Activ::AgentApplication
, Activ::ManagedEndPoint
  • CheckIntegrity()
: Activ::Database::ITable
, Activ::Database::IIndex
  • ChildService() : Activ::ChildService< T >
  • CleanUp() : Activ::CurlFtpHelper
  • CleanupIo() : Activ::IpSocket
  • Clear()
: Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestParameters
, Activ::ContentPlatform::Feed::Rule::OpenFields
, Activ::Subject
, Activ::ContentPlatform::Feed::Rule::CloseFields
, Activ::ContentPlatform::ContentGatewayApi::TimeSeriesResponseParametersTemplate< FIELD_SET_TYPE >
, Activ::ContentPlatform::Feed::Rule::PriceFields
, Activ::ContentPlatform::Feed::Rule::VolumeFields
, Activ::ContentPlatform::FeedApi::FieldListValidator
, Activ::ContentPlatform::Feed::Rule
, Activ::ContentPlatform::Feed::TableTemplate
, Activ::ContentPlatform::Feed::RecordFieldListBuilder
, Activ::ContentPlatform::Feed::TableTemplateList
, Activ::ContentPlatform::Feed::UniversalFieldList
, Activ::ContentPlatform::Feed::RecordFieldListValidator
, Activ::IEvent
, Activ::Database::ITable
, Activ::ContentPlatform::Feed::RecordKeyFieldListBuilder
, Activ::BinaryArray
, Activ::BinaryString
, Activ::ContentPlatform::Feed::RecordKeyFieldListValidator
, Activ::Blob
, Activ::CrcBlob
, Activ::ContentPlatform::Feed::RecordMessageHeaderValidator
, Activ::Date
, Activ::DateTime
, Activ::ContentPlatform::ContentGatewayApi::RequestBlock
, Activ::ContentPlatform::Feed::RecordMessageValidator
, Activ::IFieldType
, Activ::Rational
, Activ::ContentPlatform::Feed::SymbolRecordFieldListBuilder
, Activ::SInt
, Activ::TextArray
, Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters
, Activ::ContentPlatform::Feed::SymbolRecordFieldListValidator
, Activ::TextString
, Activ::Time
, Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator
, Activ::TRational
, Activ::UInt
, Activ::ContentPlatform::ContentGatewayApi::RealtimeResponseParameters
, Activ::ContentPlatform::Feed::SymbolRecordMessageValidator
, Activ::ServiceAccessPoint
, Activ::ServiceId
, Activ::ContentPlatform::Feed::Rule::CopyToFields
, Activ::ServiceInstance
, Activ::ServiceHandle
, Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryResponseParameters
, Activ::ContentPlatform::Feed::Rule::HighFields
, Activ::Address
, Activ::IEndPoint
, Activ::ContentPlatform::Feed::Rule::LowFields
, Activ::RequestId
, Activ::ScopedAddress
  • ClearAllHighCounts() : Activ::IEndPoint
  • ClearDailyHighCounts() : Activ::IEndPoint
  • ClearFieldRules() : Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions
  • ClearFrom() : Activ::ConsoleWindow
  • ClearLastHighCounts() : Activ::IEndPoint
  • ClearSocketStatsHighCounts() : Activ::RouterServiceApi::Tcp
  • Clone()
: Activ::Database::ITable
, Activ::FieldTypeFactory
, Activ::HeapMessage
  • Close()
: Activ::File
, Activ::RouterServiceApi::Udp
, Activ::Service
, Activ::UdpComponent
  • CloseFields() : Activ::ContentPlatform::Feed::Rule::CloseFields
  • CloseLogFile() : Activ::LoggerServiceApi
  • CloseRecordFile() : Activ::Database::ITable
  • CloseService() : Activ::ServiceApi
  • CloseSocket() : Activ::IpSocket
  • CollateStats() : Activ::SystemMonitor
  • Columnizer() : Activ::UiIo::Columnizer
  • CommandLineParser() : Activ::CommandLineParser
  • CommandLineParserImpl() : Activ::CommandLineParserDetail::CommandLineParserImpl
  • Compare()
: Activ::TextArray
, Activ::TextString
, Activ::Time
, Activ::TRational
, Activ::UInt
, Activ::IpAddress
, Activ::ContentPlatform::ContentGatewayApi::HistoryBar
, Activ::ContentPlatform::ContentGatewayApi::IntradayBar
, Activ::ContentPlatform::ContentGatewayApi::OptionBar
, Activ::ContentPlatform::ContentGatewayApi::Tick
, Activ::Database::FieldList
, Activ::Database::IIndex
, Activ::BinaryArray
, Activ::BinaryString
, Activ::Blob
, Activ::CrcBlob
, Activ::Date
, Activ::DateTime
, Activ::IFieldType
, Activ::Rational
, Activ::SInt
, Activ::TextArray
  • CompareContentOnly() : Activ::ContentPlatform::ContentGatewayApi::Tick
  • CompareField()
: Activ::Database::FieldList
, Activ::Database::FieldListObject
  • CompareKey() : Activ::Database::FieldList
  • CompletionHelper() : Activ::UiIo::CompletionHelper
  • Component() : Activ::Component
  • CompositeAskStateToString() : Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator
  • CompositeBidStateToString() : Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator
  • CompositeFieldRulesToString() : Activ::ContentPlatform::Feed::SymbolRecordField
  • CompositeUpdateIdToString()
: Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator
, Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator
, Activ::ContentPlatform::Feed::RecordMessageHeaderValidator
, Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator
  • Compress()
: Activ::Blob
, Activ::CrcBlob
, Activ::Rational
, Activ::TRational
  • CompressedCombinedQuoteMessageHeaderValidator() : Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator
  • CompressedMessageHeaderValidator() : Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator
  • Connect()
: Activ::CurlFtpHelper
, Activ::TcpSocket
, Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
, Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient
, Activ::RouterServiceApi::Tcp
, Activ::RouterServiceApi::Udp
, Activ::UdpComponent
, Activ::TcpSocket
, Activ::UdpSocket
, Activ::FtpHelper
, Activ::IFtpHelper
, Activ::SmtpHelper
  • ConnectParameters()
: Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::ConnectParameters
, Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::ConnectParameters
  • ConsoleWindow() : Activ::ConsoleWindow
  • ConstCopyOnResetIterator() : Activ::ContentPlatform::Feed::TableTemplate::ConstCopyOnResetIterator
  • ConstFieldIterator() : Activ::ContentPlatform::Feed::TableTemplate::ConstFieldIterator
  • ConstIndexIterator() : Activ::ContentPlatform::Feed::TableTemplate::ConstIndexIterator
  • ConstIterator()
: Activ::ContentPlatform::FeedApi::FieldListValidator::ConstIterator
, Activ::ContentPlatform::Feed::RecordFieldListValidator::ConstIterator
, Activ::ContentPlatform::Feed::SymbolRecordFieldListValidator::ConstIterator
, Activ::ContentPlatform::Feed::TableTemplateFieldListValidator::ConstIterator
, Activ::ContentPlatform::Feed::TableTemplateList::ConstIterator
, Activ::ScatterBufferHelper::ConstIterator
, Activ::Database::FieldList::ConstIterator
, Activ::ContentPlatform::Feed::UniversalFieldList::ConstIterator
, Activ::ContentPlatform::Feed::RecordKeyFieldListValidator::ConstIterator
  • ConstRuleIterator() : Activ::ContentPlatform::Feed::TableTemplate::ConstRuleIterator
  • ConstUndefineOnResetIterator() : Activ::ContentPlatform::Feed::TableTemplate::ConstUndefineOnResetIterator
  • ContentGatewayClient() : Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
  • ContentServerClient() : Activ::ContentPlatform::ContentServerApi::ContentServerClient
  • ContentsPrefixToString()
: Activ::ContentPlatform::Feed::RecordFieldListValidator
, Activ::ContentPlatform::Feed::RecordKeyFieldListValidator
, Activ::ContentPlatform::Feed::SymbolRecordField
  • ContributionGatewayClient() : Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient
  • ContributionServerClient() : Activ::ContentPlatform::ContributionServerApi::ContributionServerClient
  • Convert()
: Activ::Time
, Activ::TextArray
, Activ::UInt
, Activ::Blob
, Activ::TRational
, Activ::FieldTypeFactory
, Activ::Database::ITable
, Activ::BinaryString
, Activ::BinaryArray
, Activ::CrcBlob
, Activ::IFieldType
, Activ::Rational
, Activ::SInt
, Activ::TextString
, Activ::Date
, Activ::DateTime
  • ConvertGregorianToJulianDate() : Activ::Date
  • ConvertGregorianToJulianDateTime() : Activ::DateTime
  • ConvertGregorianToJulianTime() : Activ::Time
  • ConvertJulianToGregorianDate() : Activ::Date
  • ConvertJulianToGregorianDateTime() : Activ::DateTime
  • ConvertJulianToGregorianTime() : Activ::Time
  • ConvertStringToEnabledDaysBitmap() : Activ::Timeband
  • Coord() : Activ::ConsoleWindow::Coord
  • Copy()
: Activ::HeapMessage::ReadHelper
, Activ::ScatterBufferHelper
, Activ::HeapMessage::ReadHelper
, Activ::HeapMessage::WriteHelper
, Activ::HeapMessage
, Activ::File
, Activ::ScatterBufferHelper
, Activ::Database::ITable
, Activ::HeapMessage::WriteHelper
, Activ::HeapMessage
  • CopyAsciiHexadecimalIntegralToUnsignedBinaryIntegral() : Activ::MessageValidator
  • CopyField()
: Activ::Database::FieldList
, Activ::Database::FieldListObject
, Activ::Database::FieldList
, Activ::Database::FieldListObject
, Activ::Database::FieldList
  • CopyFields()
: Activ::Database::FieldList
, Activ::Database::Key
, Activ::Database::FieldListObject
  • CopyFiles() : Activ::Database::ITable
  • CopyOnReset() : Activ::ContentPlatform::Feed::CopyOnReset
  • CopyOnResetToString() : Activ::ContentPlatform::Feed::TableTemplate
  • CopySignedAsciiIntegralToSignedBinaryIntegral() : Activ::MessageValidator
  • CopySignedAsciiRealToBinaryReal() : Activ::MessageValidator
  • CopySignedAsciiRealToNumeratorAndDivisor() : Activ::MessageValidator
  • CopySignedBinaryIntegralToSignedBinaryIntegral() : Activ::MessageValidator
  • CopyToFields() : Activ::ContentPlatform::Feed::Rule::CopyToFields
  • CopyUnsignedAsciiIntegralToUnsignedBinaryIntegral() : Activ::MessageValidator
  • CopyUnsignedAsciiRealToBinaryReal() : Activ::MessageValidator
  • CopyUnsignedAsciiRealToNumeratorAndDivisor() : Activ::MessageValidator
  • CopyUnsignedBinaryIntegralToUnsignedBinaryIntegral() : Activ::MessageValidator
  • CrcBlob() : Activ::CrcBlob
  • Create()
: Activ::PagingFileMappedMemoryFactory
, Activ::Database::ManagedTableFactory
, Activ::Database::UnmanagedTableFactory
, Activ::File
, Activ::Database::RemoteTableFactory
, Activ::Database::UnmanagedTableFactory
, Activ::PrivateMutexFactory
, Activ::Database::ManagedTableFactory
, Activ::Database::UnmanagedTableFactory
, Activ::FieldTypeFactory
, Activ::PrivateEventFactory
, Activ::RouterServiceApi::Udp
, Activ::Database::ManagedTableFactory
, Activ::SystemFactory
, Activ::Database::UnmanagedTableFactory
, Activ::SharedCompletionPortEventFactory
, Activ::PagingFileMappedMemoryFactory
, Activ::SharedObject< T >
, Activ::SharedEventFactory
, Activ::FileMappedMemoryFactory
, Activ::Database::ManagedTableFactory
, Activ::SharedSemaphoreFactory
, Activ::PrivateSemaphoreFactory
, Activ::SharedMutexFactory
  • CreateEndPoint()
: Activ::SystemProxy
, Activ::ISystem
  • CreateFieldIdLookupList() : Activ::Database::FieldList
  • CreateFieldIdMap() : Activ::Database::FieldList
  • CreateHeap()
: Activ::ISystem
, Activ::SystemProxy
  • CreateIndexes() : Activ::Database::ITable
  • CreateLocalDate() : Activ::Date
  • CreateLocalDateTime() : Activ::DateTime
  • CreateLocalTime() : Activ::Time
  • CreateNonInheritableSocket() : Activ::IpManager
  • CreatePrivateEndPoint()
: Activ::ISystem
, Activ::SystemProxy
  • CreateRecordFile() : Activ::Database::ITable
  • CreateSocket() : Activ::UdpComponent
  • CreateTable() : Activ::Database::TableSpecification
  • CreateTemporaryIndex() : Activ::Database::ITable
  • CreateUtcDate() : Activ::Date
  • CreateUtcDateTime() : Activ::DateTime
  • CreateUtcTime() : Activ::Time
  • CrtException() : Activ::CrtException
  • CtrlHandler() : Activ::CtrlHandler
  • CurlFtpHelper() : Activ::CurlFtpHelper
  • CurlInitializeHelper() : Activ::CurlFtpHelper::CurlInitializeHelper
Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- d -

  • Database() : Activ::Database::Database
  • DatabaseException() : Activ::Database::DatabaseException
  • DatabaseSpecification() : Activ::Database::DatabaseSpecification
  • DatabaseTableSpecification() : Activ::Database::DatabaseSpecification::DatabaseTableSpecification
  • Date() : Activ::Date
  • DateTime() : Activ::DateTime
  • DateToString() : Activ::BaseTime
  • DayOfWeekToString()
: Activ::Date
, Activ::BaseTime
  • Days() : Activ::Date::Days
  • Decompress()
: Activ::Blob
, Activ::CrcBlob
  • DefaultDescription() : Activ::CommandLineParserDetail::DefaultDescription< T >
  • DefaultRuleSetToString()
: Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator
, Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator
, Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator
  • DeferredScopedMutexLocker() : Activ::DeferredScopedMutexLocker
  • DefineField()
: Activ::Database::FieldListObject
, Activ::Database::FieldList
  • Delete() : Activ::Database::ITable
  • DeleteFile()
: Activ::CurlFtpHelper
, Activ::FtpHelper
, Activ::IFtpHelper
  • DeleteKey() : Activ::RegistryHelper
  • DeleteValue() : Activ::RegistryHelper
  • DenominatorType() : Activ::Rational::DenominatorType
  • Deregister() : Activ::Service
  • Description() : Activ::CommandLineParserDetail::Description< T >
  • DescriptionAppender() : Activ::CommandLineParserDetail::DescriptionAppender
  • Deserialize()
: Activ::ContentPlatform::ContentGatewayApi::TimeSeriesCookie
, Activ::RequestId
, Activ::Subject
, Activ::ContentPlatform::ContentGatewayApi::TimeSeriesResponseParametersTemplate< FIELD_SET_TYPE >
, Activ::SerializableObjectHelper< OBJECT_TYPE >
, Activ::SerializableSmartPointerHelper< POINTER_TYPE >
, Activ::ContentPlatform::ContributionGatewayApi::PublishRequestHelper< MESSAGE_TYPE_VALUE, REQUEST_PARAMETERS, RESPONSE_PARAMETERS >
, Activ::SerializableRawPointerHelper< POINTER_TYPE >
, Activ::SerializableContainerHelper< std::vector< OBJECT_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >
, Activ::ContentPlatform::Feed::CompressedMessageDefinitions::FieldHeaderValidator
, Activ::SerializableContainerHelper< std::list< OBJECT_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >
, Activ::SerializableContainerHelper< std::set< OBJECT_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >
, Activ::ContentPlatform::Feed::CompressedMessageDefinitions::FieldHeaderValidator
, Activ::SerializableContainerHelper< std::map< KEY_TYPE, MAPPED_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >
, Activ::SerializableContainerHelper< hash_map< KEY_TYPE, MAPPED_TYPE, HASH_FN >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >
, Activ::ContentPlatform::Feed::CompressedSymbol
, Activ::SerializableBuffer< LENGTH_TYPE, MIN_LENGTH, MAX_LENGTH >
, Activ::SerializableContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >
, Activ::ContentPlatform::Feed::CompressedUsEquityOptionSymbol
, Activ::ContentPlatform::Feed::Symbol
, Activ::ConsoleWindow::Coord
, Activ::IniFileParser
, Activ::ISerializableMessage
, Activ::SystemInfo
, Activ::Uuid
, Activ::Database::DatabaseSpecification::DatabaseTableSpecification
, Activ::Database::DatabaseSpecification
, Activ::Database::FieldList
, Activ::Database::FieldListObject
, Activ::Database::FieldSpecification
, Activ::Database::IndexSpecification::Field
, Activ::Database::IndexSpecification
, Activ::Database::ITable
, Activ::Database::Key
, Activ::Database::Record
, Activ::Database::TableSpecification
, Activ::BinaryArray
, Activ::ContentPlatform::ContentGatewayApi::NewsRequestHelper
, Activ::BinaryArray
, Activ::ISystem::SystemInfo
, Activ::IProcess::Stats
, Activ::IHeap::Stats
, Activ::BinaryString
, Activ::IHeap::Stats::RequestDistributionStats
, Activ::ISyncEndPoint::Stats
, Activ::ContentPlatform::ContentGatewayApi::NewsUpdateHelper
, Activ::BinaryString
, Activ::Address
, Activ::IpAddress
, Activ::UiPermissions
, Activ::Blob
, Activ::SystemMessageEndPointIdSet
, Activ::OpenServiceResponse
, Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestHelper< MESSAGE_TYPE_VALUE, REQUEST_PARAMETERS >
, Activ::Blob
, Activ::UInt
, Activ::TRational
, Activ::Time
, Activ::CrcBlob
, Activ::TextString
, Activ::TextArray
, Activ::ContentPlatform::ContentGatewayApi::RecordUpdateHelper
, Activ::CrcBlob
, Activ::Rational
, Activ::IFieldType
, Activ::Date
, Activ::ContentPlatform::ContentGatewayApi::RecordUpdateHelper
, Activ::DateTime
, Activ::IFieldType
, Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryRequestHelper
, Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestHelper< FIRST_MESSAGE_TYPE_VALUE, NEXT_MESSAGE_TYPE_VALUE, FIELD_SET_TYPE >
, Activ::SInt
, Activ::TextArray
, Activ::ContentPlatform::ContentGatewayApi::FieldSet
, Activ::ContentPlatform::ContentGatewayApi::HistoryBar
, Activ::TextString
, Activ::ContentPlatform::ContentGatewayApi::IntradayBar
, Activ::ContentPlatform::ContentGatewayApi::OptionBar
, Activ::DirectoryWatchApi
, Activ::OpenServiceRequest
, Activ::ContentPlatform::ContentGatewayApi::RequestBlock
, Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryRequestParameters
, Activ::BaseTime
, Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryResponseParameters
, Activ::ContentPlatform::ContentGatewayApi::Tick
, Activ::HeapMessageDeserializer< MESSAGE_TYPE, BUFFER_SIZE >
, Activ::IEndPoint::Stats
, Activ::ContentPlatform::ContentGatewayApi::DataPointAddress
, Activ::ContentPlatform::ContentGatewayApi::Period
, Activ::IHeap::Stats::BucketStats
, Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestParameters
  • DeserializeBody()
: Activ::IFieldType
, Activ::Date
, Activ::CrcBlob
, Activ::BinaryString
, Activ::TextArray
, Activ::BinaryArray
, Activ::SInt
, Activ::TextString
, Activ::TRational
, Activ::Time
, Activ::BinaryArray
, Activ::DateTime
, Activ::Blob
, Activ::IFieldType
, Activ::Rational
, Activ::TextArray
, Activ::TextString
, Activ::UInt
, Activ::BinaryString
, Activ::CrcBlob
  • DeserializeLengthAndBody()
: Activ::BinaryString
, Activ::BinaryArray
, Activ::Date
, Activ::Blob
, Activ::CrcBlob
, Activ::TextString
, Activ::BinaryArray
, Activ::Time
, Activ::SInt
, Activ::Blob
, Activ::BinaryString
, Activ::CrcBlob
, Activ::TextArray
, Activ::IFieldType
, Activ::TextArray
, Activ::Rational
, Activ::DateTime
, Activ::TRational
, Activ::TextString
, Activ::IFieldType
, Activ::UInt
  • DeserializeSocketStats() : Activ::RouterServiceApi::Tcp
  • DeserializeSpecification() : Activ::Database::FieldList
  • DestroyAll() : Activ::ObjectPool< T, INITIAL_FREE_LIST_SIZE, MAX_FREE_LIST_SIZE >
  • DetachTable() : Activ::Database::Database
  • DirectoryRemover() : Activ::DirectoryRemover
  • DirectoryWalker() : Activ::DirectoryWalker
  • Disable() : Activ::Port
  • Disconnect()
: Activ::SmtpHelper
, Activ::TcpSocket
, Activ::RouterServiceApi::Tcp
, Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
, Activ::FtpHelper
, Activ::UdpComponent
, Activ::CurlFtpHelper
, Activ::UdpSocket
, Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient
, Activ::RouterServiceApi::Udp
, Activ::IFtpHelper
  • DisplayFooter() : Activ::UiMenu
  • DisplayInputPrompt() : Activ::UiMenu
  • DisplayOption() : Activ::UiMenu
  • DisplayOptionPrompt() : Activ::UiMenu
  • DisplayTitle() : Activ::UiMenu
  • Divide()
: Activ::UInt
, Activ::Rational
, Activ::SInt
  • DllFunctionWrapper() : Activ::DllFunctionWrapper< NAME, TYPE, THROW_ON_ERROR >
  • DoesExist() : Activ::Process
  • Duration() : Activ::BaseTime::Duration
  • DynamicCompletionHelper() : Activ::UiIo::DynamicCompletionHelper
  • DynamicLibraryLoader() : Activ::DynamicLibraryLoader< T >
Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- e -

  • Email() : Activ::SmtpHelper::Email
  • Enable() : Activ::Port
  • EnableDisable() : Activ::UiIo
  • Enabler() : Activ::Port::Enabler
  • EnableSocketStats() : Activ::RouterServiceApi::Tcp
  • End()
: Activ::ContentPlatform::Feed::RecordKeyFieldListValidator
, Activ::ScatterBufferHelper
, Activ::Thread
, Activ::ContentPlatform::Feed::SymbolRecordFieldListValidator
, Activ::Database::Database
, Activ::ContentPlatform::Feed::SymbolRecordMessageValidator
, Activ::Database::FieldList
, Activ::Database::FieldListObject
, Activ::ContentPlatform::Feed::TableTemplateFieldListValidator
, Activ::HeapMessage
, Activ::ContentPlatform::FeedApi::FieldListValidator
, Activ::ContentPlatform::Feed::TableTemplateIndex
, Activ::ContentPlatform::Feed::TableTemplateIndexListValidator
, Activ::ContentPlatform::Feed::RecordFieldListValidator
, Activ::ContentPlatform::Feed::TableTemplateList
, Activ::ContentPlatform::Feed::UniversalFieldList
  • EndCopyOnReset() : Activ::ContentPlatform::Feed::TableTemplate
  • EndField()
: Activ::ContentPlatform::Feed::RecordMessageValidator
, Activ::ContentPlatform::Feed::TableTemplateMessageValidator
, Activ::ContentPlatform::Feed::TableTemplate
  • EndIndex()
: Activ::ContentPlatform::Feed::TableTemplateMessageValidator
, Activ::ContentPlatform::Feed::TableTemplate
  • EndKey() : Activ::IniFileParser::ConstSectionIterator
  • EndKeyField()
: Activ::ContentPlatform::Feed::RecordMessageValidator
, Activ::ContentPlatform::ContentServerApi::RecordUpdate
, Activ::ContentPlatform::Feed::RecordMessageHeaderValidator
  • EndPointSubject() : Activ::EndPointSubject
  • EndRule() : Activ::ContentPlatform::Feed::TableTemplate
  • EndSection()
: Activ::IniFileParser::ConstSectionIterator
, Activ::IniFileParser
  • EndSubSection() : Activ::IniFileParser::ConstSectionIterator
  • EndUndefineOnReset() : Activ::ContentPlatform::Feed::TableTemplate
  • EntityTypeHelper() : Activ::ContentPlatform::Feed::EntityTypeHelper
  • EnumerateKeys() : Activ::RegistryHelper
  • EnumerateObjects()
: Activ::SystemProxy
, Activ::ISystem
  • EnumerateValues() : Activ::RegistryHelper
  • Erase()
: Activ::MessageBuilder
, Activ::HeapMessage
  • EventTypeHelper() : Activ::ContentPlatform::Feed::EventTypeHelper
  • EventTypeToString()
: Activ::ContentPlatform::Feed::RecordMessageHeaderValidator
, Activ::DirectoryWatchApi
, Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator
, Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator
, Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator
  • Exception() : Activ::Exception
  • Exchange()
: Activ::AtomicInteger
, Activ::AtomicPointer< T >
  • Exec() : Activ::Process
  • ExpandPath() : Activ::File
  • Extend()
: Activ::HeapPool
, Activ::HeapMessage
  • ExtractCompressedCompositeAskState() : Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageDefinitions
  • ExtractCompressedUpdateId() : Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageDefinitions
  • ExtractFlags()
: Activ::ContentPlatform::Feed::CombinedQuoteMessageHeaderDefinitions
, Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions
, Activ::ContentPlatform::Feed::RecordMessageHeaderDefinitions
Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- f -

  • Fiber() : Activ::Fiber
  • Field()
: Activ::ContentPlatform::ContributionGatewayApi::PublishSymbolRecordParameters::Field
, Activ::ContentPlatform::Feed::IndexSpecification::Field
, Activ::ContentPlatform::FeedApi::FieldListValidator::Field
, Activ::Database::IndexSpecification::Field
, Activ::ContentPlatform::ContributionGatewayApi::PublishSymbolRecordParameters::Field
, Activ::ContentPlatform::Feed::Field
  • FieldContentsToString()
: Activ::ContentPlatform::Feed::RecordFieldListValidator
, Activ::ContentPlatform::Feed::RecordKeyFieldListValidator
, Activ::ContentPlatform::Feed::SymbolRecordField
  • FieldHeaderBuilder() : Activ::ContentPlatform::Feed::CompressedMessageDefinitions::FieldHeaderBuilder
  • FieldHeaderValidator() : Activ::ContentPlatform::Feed::CompressedMessageDefinitions::FieldHeaderValidator
  • FieldIdToString()
: Activ::ContentPlatform::Feed::RecordFieldListValidator
, Activ::ContentPlatform::Feed::RecordKeyFieldListValidator
, Activ::ContentPlatform::Feed::SymbolRecordField
  • FieldList() : Activ::Database::FieldList
  • FieldListObject() : Activ::Database::FieldListObject
  • FieldListTitleToString() : Activ::ContentPlatform::Feed::RecordFieldListValidator
  • FieldListValidator()
: Activ::ContentPlatform::ContentGatewayApi::FieldListValidator
, Activ::ContentPlatform::ContentServerApi::FieldListValidator
, Activ::ContentPlatform::FeedApi::FieldListValidator
  • FieldNameToString()
: Activ::ContentPlatform::Feed::RecordKeyFieldListValidator
, Activ::ContentPlatform::Feed::SymbolRecordField
  • FieldRulesToString() : Activ::ContentPlatform::Feed::SymbolRecordField
  • FieldSet() : Activ::ContentPlatform::ContentGatewayApi::FieldSet
  • FieldSpecification()
: Activ::ContentPlatform::Feed::CompressedMessageDefinitions::FieldSpecification
, Activ::ContentPlatform::Feed::TableTemplate::FieldSpecification
, Activ::Database::FieldSpecification
  • FieldStatusToString() : Activ::ContentPlatform::ContributionGatewayApi::PublishRecordResponseParameters::FieldError
  • FieldsToString() : Activ::ContentPlatform::Feed::TableTemplate
  • File() : Activ::File
  • FileInfo() : Activ::FileInfo
  • FindFunction() : Activ::DllFunctionWrapper< NAME, TYPE, THROW_ON_ERROR >
  • FindKey() : Activ::IniFileParser::ConstSectionIterator
  • FindPort()
: Activ::Port
, Activ::ManagedEndPoint
  • FindSection() : Activ::IniFileParser
  • FindServices() : Activ::ServiceApi
  • FindSubSection() : Activ::IniFileParser::ConstSectionIterator
  • FlagsToString()
: Activ::ContentPlatform::ContentGatewayApi::NewsUpdate
, Activ::ContentPlatform::ContentGatewayApi::ResponseBlock
, Activ::ContentPlatform::ContentGatewayApi::RecordUpdate
  • Flush()
: Activ::PostMessageHelper
, Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::RecordMessageBuilder
, Activ::IFileMappedMemory
, Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::SymbolRecordMessageBuilder
  • ForceDecimalType() : Activ::ContentPlatform::ContentGatewayApi::HistoryBar
  • ForwardMessage() : Activ::Port
  • FromString()
: Activ::UInt
, Activ::Rational
, Activ::TRational
, Activ::ContentPlatform::ContentGatewayApi::HistoryBar
, Activ::ContentPlatform::ContentGatewayApi::Tick
, Activ::Date
, Activ::UiPermissions
, Activ::CrcBlob
, Activ::SInt
, Activ::BinaryArray
, Activ::IFieldType
, Activ::TextArray
, Activ::Time
, Activ::BinaryString
, Activ::ContentPlatform::ContentGatewayApi::IntradayBar
, Activ::TextString
, Activ::DateTime
, Activ::Blob
, Activ::ContentPlatform::ContentGatewayApi::FieldSet
  • FromStringSpecial() : Activ::ContentPlatform::ContentGatewayApi::HistoryBar
  • FtpHelper() : Activ::FtpHelper
Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- g -

  • Get()
: Activ::AtomicInteger
, Activ::MessageValidator
, Activ::ScatterBufferHelper
, Activ::Database::FieldListObject
, Activ::Date
, Activ::Time
, Activ::Date
, Activ::Time
, Activ::BinaryArray
, Activ::Date
, Activ::Time
, Activ::DateTime
, Activ::Time
, Activ::TRational
, Activ::ScatterBufferHelper
, Activ::BinaryString
, Activ::DateTime
, Activ::TRational
, Activ::DateTime
, Activ::UInt
, Activ::Blob
, Activ::DateTime
, Activ::LocalTime
, Activ::IpSocket::Stats
, Activ::DateTime
, Activ::HeapMessage::ReadHelper
, Activ::ScatterBufferHelper
, Activ::ThreadSpecificDataBase< TYPE, DERIVED >
, Activ::Blob
, Activ::DateTime
, Activ::HeapMessage::ReadHelper
, Activ::HeapMessage::WriteHelper
, Activ::DateTime
, Activ::HeapMessage
, Activ::CrcBlob
, Activ::Rational
, Activ::HeapMessage
, Activ::Rational
, Activ::HeapMessage
, Activ::HeapPool
, Activ::Database::FieldListObject
, Activ::CrcBlob
, Activ::SInt
, Activ::RequestId
, Activ::Subject
, Activ::SInt
, Activ::DynamicLibraryLoader< T >
, Activ::ReferenceCounter
, Activ::Date
, Activ::TextArray
, Activ::ObjectPool< T, INITIAL_FREE_LIST_SIZE, MAX_FREE_LIST_SIZE >
, Activ::TextString
  • GetActivFieldType()
: Activ::ContentPlatform::FeedApi::FieldListValidator
, Activ::Database::FieldSpecification
, Activ::ContentPlatform::FeedApi::FieldListValidator::Field
, Activ::ContentPlatform::FeedApi::FieldListValidator
  • GetAddress()
: Activ::UiIo
, Activ::Port
  • GetAmfFieldIndex() : Activ::ContentPlatform::Feed::Field
  • GetAmfRecordSize() : Activ::ContentPlatform::Feed::TableTemplate
  • GetAmfRowIndex() : Activ::ContentPlatform::Feed::Field
  • GetAmfRowOffset() : Activ::ContentPlatform::Feed::Field
  • GetAmfTableId() : Activ::ContentPlatform::Feed::TableTemplate
  • GetAndDeleteFile()
: Activ::CurlFtpHelper
, Activ::FtpHelper
, Activ::IFtpHelper
  • GetApiInfo()
: Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
, Activ::ContentPlatform::ContentServerApi::ContentServerClient
, Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient
, Activ::ContentPlatform::ContributionServerApi::ContributionServerClient
  • GetApplication() : Activ::Component
  • GetAskPrice() : Activ::ContentPlatform::ContentGatewayApi::OptionBar
  • GetAttributes() : Activ::RequestId
  • GetBasicFileName() : Activ::Database::ITable
  • GetBidPrice() : Activ::ContentPlatform::ContentGatewayApi::OptionBar
  • GetBinary() : Activ::Uuid
  • GetBooleanValue()
: Activ::IniFileParser::ConstKeyIterator
, Activ::IniFileParser::ConstSectionIterator
, Activ::IniFileParser
  • GetBufferSize()
: Activ::ConsoleWindow
, Activ::MessageBuilder
  • GetBuyerId() : Activ::ContentPlatform::ContentGatewayApi::Tick
  • GetCacheSize() : Activ::ContentPlatform::Feed::TableTemplate
  • GetCapacity() : Activ::HeapMessage
  • GetChar() : Activ::UiIo
  • GetClosePrice()
: Activ::ContentPlatform::ContentGatewayApi::HistoryBar
, Activ::ContentPlatform::ContentGatewayApi::IntradayBar
  • GetCodeIdentifier()
: Activ::ContentPlatform::Feed::Field
, Activ::ContentPlatform::Feed::TableTemplate
  • GetCompositeAskState() : Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator
  • GetCompositeBidState() : Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator
  • GetCompositeFieldRules() : Activ::ContentPlatform::Feed::SymbolRecordField
  • GetCompositeUpdateId()
: Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator
, Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator
, Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator
, Activ::ContentPlatform::Feed::SymbolRecordMessageValidator
  • GetCompressedCompositeAskState() : Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageDefinitions
  • GetCompressedNumeratorLength() : Activ::ContentPlatform::Feed::CompressedMessageDefinitions
  • GetCompressedUpdateId() : Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageDefinitions
  • GetConditions() : Activ::ContentPlatform::ContentGatewayApi::Tick
  • GetConfirmation() : Activ::UiIo
  • GetContentGatewayInfo() : Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
  • GetContentionCount() : Activ::IMutex
  • GetContributionGatewayInfo() : Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient
  • GetCrc() : Activ::CrcBlob
  • GetCrcCompressed() : Activ::CrcBlob
  • GetCrcDecompressed() : Activ::CrcBlob
  • GetCreationDateTime() : Activ::File
  • GetCreatorProcessId() : Activ::ISyncEndPoint
  • GetCurrent()
: Activ::UtcTime
, Activ::LocalTime
  • GetCurrentId()
: Activ::Process
, Activ::Thread
  • GetCurrentLocalDate() : Activ::TimerServiceApi
  • GetCurrentLocalDateTime() : Activ::TimerServiceApi
  • GetCurrentLocalTime() : Activ::TimerServiceApi
  • GetCurrentRecords()
: Activ::Database::IIndex
, Activ::Database::ITable
  • GetCurrentUtcDate() : Activ::TimerServiceApi
  • GetCurrentUtcDateTime() : Activ::TimerServiceApi
  • GetCurrentUtcTime() : Activ::TimerServiceApi
  • GetCursorPosition() : Activ::ConsoleWindow
  • GetData()
: Activ::BinaryArray
, Activ::BinaryString
, Activ::Blob
, Activ::CrcBlob
, Activ::TextArray
, Activ::TextString
, Activ::SerializableBuffer< LENGTH_TYPE, MIN_LENGTH, MAX_LENGTH >
  • GetDatabaseFieldType() : Activ::Database::FieldSpecification
  • GetDataCompressed()
: Activ::Blob
, Activ::CrcBlob
  • GetDataDecompressed()
: Activ::Blob
, Activ::CrcBlob
  • GetDataLength()
: Activ::Database::FieldList
, Activ::Database::Key
, Activ::Database::Record
, Activ::SerializableBuffer< LENGTH_TYPE, MIN_LENGTH, MAX_LENGTH >
  • GetDataPointAddress() : Activ::ContentPlatform::ContentGatewayApi::TimeSeriesCookie
  • GetDate()
: Activ::ContentPlatform::ContentGatewayApi::HistoryBar
, Activ::ContentPlatform::ContentGatewayApi::OptionBar
, Activ::DateTime
  • GetDateTime()
: Activ::ContentPlatform::ContentGatewayApi::HistoryBar
, Activ::ContentPlatform::ContentGatewayApi::IntradayBar
, Activ::ContentPlatform::ContentGatewayApi::Tick
  • GetDay()
: Activ::Date
, Activ::DateTime
, Activ::BaseTime
  • GetDayOfWeek()
: Activ::Date
, Activ::DateTime
, Activ::BaseTime
  • GetDayOfYear()
: Activ::Date
, Activ::DateTime
  • GetDaysInMonth() : Activ::Date
  • GetDecimalPlaces() : Activ::Rational::DenominatorType
  • GetDefaultName() : Activ::ContentPlatform::ContributionServerApi::ContributionServerClient
  • GetDefaultRuleSet()
: Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator
, Activ::ContentPlatform::Feed::SymbolRecordMessageValidator
  • GetDenominator()
: Activ::ContentPlatform::ContentGatewayApi::OptionBar
, Activ::Rational
, Activ::TRational
  • GetDenominatorByBinaryPower() : Activ::Rational
  • GetDenominatorByDecimalPlaces() : Activ::Rational
  • GetDenominatorByDecimalPower() : Activ::Rational
  • GetDenominatorByDivisor() : Activ::Rational
  • GetDenominatorByMultiplier() : Activ::Rational
  • GetDenominatorByMultiplierPower() : Activ::Rational
  • GetDenominatorType() : Activ::Rational
  • GetDescription() : Activ::ContentPlatform::Feed::Field
  • GetDestinationAddress() : Activ::HeapMessage
  • GetDirectory() : Activ::Database::ITable
  • GetDirectorySeparator() : Activ::File
  • GetDisabledDateSet() : Activ::Timeband
  • GetDisabledDateSetString() : Activ::Timeband
  • GetDisplaySize() : Activ::ConsoleWindow
  • GetDivisor() : Activ::Rational::DenominatorType
  • GetDivisorDigits() : Activ::Rational::DenominatorType
  • GetDouble() : Activ::Rational
  • GetEnabledDateFlag() : Activ::Timeband
  • GetEnabledDateFlagString() : Activ::Timeband
  • GetEnabledDaysString() : Activ::Timeband
  • GetEndOfLine() : Activ::File
  • GetEndPoint() : Activ::ManagedEndPoint
  • GetEndPointId() : Activ::Address
  • GetEndTime() : Activ::Timeband
  • GetEqual()
: Activ::Database::Database
, Activ::Database::ITable
  • GetError()
: Activ::ContentPlatform::Feed::TableTemplate
, Activ::ContentPlatform::Feed::TableTemplateList
, Activ::ContentPlatform::Feed::UniversalFieldList
  • GetEventType()
: Activ::ContentPlatform::ContentServerApi::RecordUpdateHelper< MESSAGE_VALIDATOR >
, Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator
, Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator
, Activ::ContentPlatform::Feed::RecordMessageHeaderValidator
, Activ::ContentPlatform::Feed::RecordMessageValidator
, Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator
, Activ::ContentPlatform::Feed::SymbolRecordMessageValidator
  • GetExchange() : Activ::ContentPlatform::ContentGatewayApi::Tick
  • GetExpirationDate() : Activ::ContentPlatform::ContentGatewayApi::OptionBar
  • GetExtensionFunction() : Activ::IpManager
  • GetField()
: Activ::ContentPlatform::ContentGatewayApi::FieldSet
, Activ::ContentPlatform::ContentGatewayApi::HistoryBar
, Activ::ContentPlatform::ContentGatewayApi::IntradayBar
, Activ::ContentPlatform::ContentGatewayApi::OptionBar
, Activ::ContentPlatform::ContentGatewayApi::Tick
, Activ::ContentPlatform::FeedApi::FieldListValidator::ConstIterator
, Activ::ContentPlatform::FeedApi::FieldListValidator
, Activ::ContentPlatform::Feed::RecordFieldListValidator::ConstIterator
, Activ::ContentPlatform::Feed::RecordFieldListValidator
, Activ::ContentPlatform::Feed::RecordKeyFieldListValidator::ConstIterator
, Activ::ContentPlatform::Feed::RecordKeyFieldListValidator
, Activ::ContentPlatform::Feed::RecordMessageValidator
, Activ::ContentPlatform::Feed::SymbolRecordField
, Activ::ContentPlatform::Feed::TableTemplate::ConstFieldIterator
, Activ::ContentPlatform::Feed::TableTemplate
, Activ::Database::FieldList
, Activ::Database::FieldListObject
  • GetFieldContents() : Activ::ContentPlatform::ContributionGatewayApi::PublishField
  • GetFieldDefinition() : Activ::Database::FieldList
  • GetFieldHeader()
: Activ::ContentPlatform::Feed::FieldHeaderDefinitions
, Activ::ContentPlatform::Feed::SymbolRecordFieldHeaderDefinitions
  • GetFieldId()
: Activ::ContentPlatform::Feed::FieldHeaderDefinitions
, Activ::ContentPlatform::Feed::RecordFieldListValidator::ConstIterator
, Activ::ContentPlatform::Feed::RecordKeyFieldListValidator::ConstIterator
, Activ::ContentPlatform::Feed::SymbolRecordFieldListValidator::ConstIterator
, Activ::ContentPlatform::Feed::TableTemplateFieldListValidator::ConstIterator
, Activ::ContentPlatform::Feed::TableTemplate::ConstFieldIterator
, Activ::ContentPlatform::Feed::TableTemplate::ConstRuleIterator
, Activ::ContentPlatform::FeedApi::FieldListValidator::ConstIterator
  • GetFieldIdList()
: Activ::Database::FieldList
, Activ::Database::FieldListObject
, Activ::Database::IIndex
, Activ::Database::ITable
  • GetFieldLength() : Activ::Database::FieldList
  • GetFieldList()
: Activ::Database::FieldListObject
, Activ::Database::IIndex
, Activ::Database::ITable
  • GetFieldNumber() : Activ::Database::FieldList
  • GetFieldRules()
: Activ::ContentPlatform::Feed::SymbolRecordField
, Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::TranslatorRuleSet
, Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ContentServerRuleSet
  • GetFieldSpecification()
: Activ::Database::FieldList
, Activ::Database::FieldListObject
, Activ::Database::ITable
  • GetFieldSpecificationList()
: Activ::Database::FieldList
, Activ::Database::FieldListObject
, Activ::Database::IIndex
, Activ::Database::ITable
  • GetFieldType() : Activ::UiIo
  • GetFile()
: Activ::CurlFtpHelper
, Activ::FtpHelper
, Activ::IFtpHelper
  • GetFileList()
: Activ::CurlFtpHelper
, Activ::FtpHelper
, Activ::IFtpHelper
  • GetFileName()
: Activ::File
, Activ::UiIo
  • GetFirst() : Activ::Database::ITable
  • GetFirstBuffer() : Activ::WsaBufHelper
  • GetFirstField() : Activ::ContentPlatform::Feed::TableTemplate
  • GetFirstFieldId()
: Activ::Database::FieldList
, Activ::Database::FieldListObject
, Activ::Database::ITable
  • GetFirstFieldSpecification()
: Activ::Database::FieldList
, Activ::Database::ITable
  • GetFirstIndex() : Activ::ContentPlatform::Feed::TableTemplate
  • GetFirstPartial() : Activ::Database::ITable
  • GetFirstTableTemplate() : Activ::ContentPlatform::Feed::TableTemplateList
  • GetFlag() : Activ::ContentPlatform::ContentGatewayApi::IntradayBar
  • GetFlags()
: Activ::ContentPlatform::Feed::CombinedQuoteMessageHeaderDefinitions
, Activ::ContentPlatform::Feed::MessageHeaderDefinitions
, Activ::ContentPlatform::Feed::RecordMessageHeaderDefinitions
, Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions
  • GetFrequency() : Activ::IntervalTimer
  • GetFromIniFile()
: Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::Settings
, Activ::ContentPlatform::Feed::TableTemplateList::Settings
  • GetFromStringFormat()
: Activ::BinaryArray
, Activ::BinaryString
, Activ::Blob
, Activ::CrcBlob
, Activ::Date
, Activ::DateTime
, Activ::IFieldType
, Activ::Rational
, Activ::SInt
, Activ::TextArray
, Activ::TextString
, Activ::Time
, Activ::TRational
, Activ::UInt
  • GetHandle()
: Activ::File
, Activ::IEvent
, Activ::TcpListener
  • GetHeader() : Activ::ContentPlatform::Feed::CompressedMessageDefinitions
  • GetHeap() : Activ::Port
  • GetHeapId() : Activ::HeapMessage
  • GetHeapMessage() : Activ::HeapMessageBuilder
  • GetHighPrice()
: Activ::ContentPlatform::ContentGatewayApi::HistoryBar
, Activ::ContentPlatform::ContentGatewayApi::IntradayBar
  • GetHostAndPort() : Activ::IpManager
  • GetHostName() : Activ::IpManager
  • GetHostname() : Activ::SmtpHelper
  • GetHostsFileEntries() : Activ::IpManager
  • GetHour()
: Activ::DateTime
, Activ::Time
, Activ::BaseTime
  • GetId()
: Activ::ContentPlatform::Feed::Field
, Activ::ContentPlatform::Feed::TableTemplate
, Activ::Thread
, Activ::Database::FieldList::ConstIterator
, Activ::Database::FieldListObject
, Activ::ISyncEndPoint
, Activ::IHeap
, Activ::IProcess
  • GetIdentity() : Activ::Database::ITable
  • GetIndex() : Activ::ContentPlatform::Feed::TableTemplate
  • GetIndexNumber()
: Activ::ContentPlatform::ContentServerApi::RecordUpdate
, Activ::ContentPlatform::Feed::RecordMessageHeaderValidator
, Activ::ContentPlatform::Feed::RecordMessageValidator
, Activ::Database::Key
  • GetIndexPointer()
: Activ::Database::ITable
, Activ::Database::Key
  • GetIndexSpecification()
: Activ::Database::ITable
, Activ::Database::Key
  • GetIndexSpecificationList() : Activ::Database::ITable
  • GetInfinite() : Activ::Timeout
  • GetIniFileParser() : Activ::LicenseServiceApi
  • GetInitialMaxRecords() : Activ::ContentPlatform::Feed::TableTemplate
  • GetInstance()
: Activ::FileMappedMemoryFactory
, Activ::PagingFileMappedMemoryFactory
, Activ::PrivateEventFactory
, Activ::PrivateMutexFactory
, Activ::PrivateSemaphoreFactory
, Activ::SharedEventFactory
, Activ::SharedMutexFactory
, Activ::SharedSemaphoreFactory
, Activ::Database::ManagedTableFactory
, Activ::Database::RemoteTableFactory
, Activ::Database::UnmanagedTableFactory
, Activ::FieldTypeFactory
, Activ::SystemFactory
, Activ::ObjectPool< T, INITIAL_FREE_LIST_SIZE, MAX_FREE_LIST_SIZE >
  • GetInterfaceIndex() : Activ::IpAddress
  • GetInterfaceInfoList() : Activ::IpManager
  • GetIpAddress()
: Activ::UiIo
, Activ::IpManager
, Activ::HeapMessage
  • GetJulianDate() : Activ::DateTime
  • GetJulianTime()
: Activ::DateTime
, Activ::BaseTime
  • GetKey() : Activ::Database::Record
  • GetKeyBlock()
: Activ::Des3Helper::Key
, Activ::DesHelper::Key
  • GetKeyField()
: Activ::ContentPlatform::Feed::RecordMessageHeaderValidator
, Activ::ContentPlatform::Feed::RecordMessageValidator
  • GetKeyLength() : Activ::Database::IIndex
  • GetKeySchedule()
: Activ::Des3Helper::Key
, Activ::DesHelper::Key
  • GetLast() : Activ::Database::ITable
  • GetLastAccessDateTime() : Activ::File
  • GetLastPartial() : Activ::Database::ITable
  • GetLastWriteDateTime() : Activ::File
  • GetLatestTableTemplate() : Activ::ContentPlatform::Feed::TableTemplateList
  • GetLatestTableTemplateId() : Activ::ContentPlatform::Feed::TableTemplateList
  • GetLength()
: Activ::MessageBuilder
, Activ::MessageValidator
, Activ::HeapMessage::ReadHelper
, Activ::HeapMessage::WriteHelper
, Activ::HeapMessage
, Activ::RequestId
, Activ::Subject
  • GetLocal()
: Activ::DateTime
, Activ::Time
  • GetLocalAddress()
: Activ::IpSocket
, Activ::TcpListener
  • GetLocalIpAddressList() : Activ::IpManager
  • GetLowestCommonDenominator() : Activ::Rational
  • GetLowPrice()
: Activ::ContentPlatform::ContentGatewayApi::HistoryBar
, Activ::ContentPlatform::ContentGatewayApi::IntradayBar
  • GetManagedEndPoint() : Activ::Port
  • GetMatchingFieldsById() : Activ::Database::FieldListObject
  • GetMatchingFieldsByName() : Activ::Database::FieldListObject
  • GetMaximumTableNumber() : Activ::ContentPlatform::ContributionServerApi::ContributionServerClient
  • GetMaxLength()
: Activ::ContentPlatform::Feed::TableTemplateField
, Activ::ContentPlatform::Feed::Field
  • GetMaxNumber() : Activ::ContentPlatform::Feed::TableTemplate
  • GetMaxRecords() : Activ::Database::ITable
  • GetMaxSerializedBodyLength()
: Activ::BinaryArray
, Activ::BinaryString
, Activ::Blob
, Activ::CrcBlob
, Activ::Date
, Activ::DateTime
, Activ::Rational
, Activ::SInt
, Activ::TextArray
, Activ::TextString
, Activ::Time
, Activ::TRational
, Activ::UInt
  • GetMaxSerializedLength()
: Activ::TextString
, Activ::DateTime
, Activ::BinaryString
, Activ::ContentPlatform::ContentGatewayApi::FieldSet
, Activ::ContentPlatform::ContentGatewayApi::HistoryBar
, Activ::ContentPlatform::ContentGatewayApi::IntradayBar
, Activ::ContentPlatform::ContentGatewayApi::OptionBar
, Activ::ContentPlatform::ContentGatewayApi::Tick
, Activ::BinaryArray
, Activ::Blob
, Activ::CrcBlob
, Activ::Date
, Activ::Rational
, Activ::SInt
, Activ::TextArray
, Activ::Time
, Activ::TRational
, Activ::UInt
  • GetMaxThreads() : Activ::ManagedEndPoint
  • GetMaxValue() : Activ::BitField< T, OFFSET_VALUE, LENGTH_VALUE >
  • GetMaxVersion() : Activ::ContentPlatform::Feed::TableTemplate
  • GetMessage()
: Activ::IHeap
, Activ::MessageValidator
, Activ::MessageBuilder
, Activ::HeapPool
, Activ::IEndPoint
, Activ::IHeap
  • GetMessageBuilder() : Activ::HeapMessageBuilder
  • GetMessageFromList() : Activ::IHeap
  • GetMessageHeader()
: Activ::ContentPlatform::Feed::CombinedQuoteMessageHeaderDefinitions
, Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderDefinitions
, Activ::ContentPlatform::Feed::CompressedMessageHeaderDefinitions
, Activ::ContentPlatform::Feed::MessageHeaderDefinitions
, Activ::ContentPlatform::Feed::RecordMessageHeaderDefinitions
, Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions
, Activ::ContentPlatform::Feed::TableTemplateMessageHeaderDefinitions
  • GetMessageRate() : Activ::MessageRateThrottler
  • GetMessages() : Activ::IEndPoint
  • GetMessageStatsList() : Activ::ContentPlatform::ContentServerApi::ContentServerClient
  • GetMessageType() : Activ::ContentPlatform::Feed::MessageHeaderDefinitions
  • GetMessageVersion() : Activ::MessageHandler
  • GetMidnight() : Activ::LocalTime
  • GetMillisecond()
: Activ::DateTime
, Activ::Time
, Activ::BaseTime
  • GetMinimumTableNumber() : Activ::ContentPlatform::ContributionServerApi::ContributionServerClient
  • GetMinute()
: Activ::DateTime
, Activ::Time
, Activ::BaseTime
  • GetMode()
: Activ::Database::Database
, Activ::Database::ITable
  • GetMonitorServiceHeap() : Activ::Application
  • GetMonth()
: Activ::DateTime
, Activ::Date
, Activ::BaseTime
  • GetMultiplier() : Activ::Rational::DenominatorType
  • GetMultiplierPower() : Activ::Rational::DenominatorType
  • GetName()
: Activ::IniFileParser::ConstSectionIterator
, Activ::Database::Database
, Activ::Database::FieldList::ConstIterator
, Activ::Database::IIndex
, Activ::Database::ITable
, Activ::UiMenu
, Activ::ISyncEndPoint
, Activ::IProcess
, Activ::Port
, Activ::IniFileParser::ConstKeyIterator
, Activ::IHeap
, Activ::ContentPlatform::Feed::TableTemplateIndex
, Activ::ContentPlatform::Feed::TableTemplateMessageValidator
, Activ::ContentPlatform::Feed::Field
, Activ::ContentPlatform::Feed::TableTemplate
  • GetNext() : Activ::Database::ITable
  • GetNextField() : Activ::ContentPlatform::Feed::TableTemplate
  • GetNextFieldId()
: Activ::Database::FieldList
, Activ::Database::FieldListObject
, Activ::Database::ITable
  • GetNextFieldSpecification()
: Activ::Database::FieldList
, Activ::Database::ITable
  • GetNextIndex() : Activ::ContentPlatform::Feed::TableTemplate
  • GetNextPartial() : Activ::Database::ITable
  • GetNextTableTemplate() : Activ::ContentPlatform::Feed::TableTemplateList
  • GetNotificationHandle() : Activ::IEndPoint
  • GetNumber()
: Activ::ContentPlatform::Feed::TableTemplate
, Activ::Database::IIndex
, Activ::ContentPlatform::Feed::TableTemplateIndex
  • GetNumberOfBuffersInUse() : Activ::WsaBufHelper
  • GetNumberOfBytes() : Activ::IoCompletionManager::Overlapped
  • GetNumberOfFieldHeaders() : Activ::ContentPlatform::Feed::CompressedMessageDefinitions::FieldSpecification
  • GetNumberOfFields()
: Activ::ContentPlatform::FeedApi::FieldListValidator
, Activ::Database::FieldList
  • GetNumberOfGrowRecords() : Activ::ContentPlatform::Feed::TableTemplate
  • GetNumberOfIndexes() : Activ::Database::ITable
  • GetNumberOfKeyFields() : Activ::ContentPlatform::ContentServerApi::RecordUpdate
  • GetNumberOfPurgeDays() : Activ::ContentPlatform::Feed::TableTemplate
  • GetNumberOfScatterBuffersInUse() : Activ::ScatterBufferHelper
  • GetNumberOfTables() : Activ::Database::Database
  • GetNumerator()
: Activ::Rational
, Activ::TRational
, Activ::Rational
  • GetNumeratorAndDenominator() : Activ::TRational
  • GetNumeratorAndDivisor()
: Activ::TRational
, Activ::Rational
  • GetNumeratorLength() : Activ::ContentPlatform::Feed::CompressedMessageDefinitions
  • GetOffset()
: Activ::MessageValidator
, Activ::HeapMessage::WriteHelper
, Activ::HeapMessage::ReadHelper
  • GetOpenInterest()
: Activ::ContentPlatform::ContentGatewayApi::HistoryBar
, Activ::ContentPlatform::ContentGatewayApi::OptionBar
  • GetOpenPrice()
: Activ::ContentPlatform::ContentGatewayApi::HistoryBar
, Activ::ContentPlatform::ContentGatewayApi::IntradayBar
  • GetOsId() : Activ::IProcess
  • GetPartialBitUpdateList() : Activ::ContentPlatform::Feed::SymbolRecordField
  • GetPeriodLeft() : Activ::Timeout
  • GetPeriodLength() : Activ::MessageRateThrottler
  • GetPermissionId()
: Activ::ContentPlatform::Feed::RecordMessageValidator
, Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator
, Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator
, Activ::ContentPlatform::Feed::RecordMessageHeaderValidator
, Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator
, Activ::ContentPlatform::Feed::SymbolRecordMessageValidator
, Activ::ContentPlatform::ContentServerApi::RecordUpdateHelper< MESSAGE_VALIDATOR >
  • GetPermissionInfo()
: Activ::ContentPlatform::ContentGatewayApi::MetaDataRequestHelper
, Activ::ContentPlatform::ContentServerApi::ContentServerClient
, Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient
  • GetPointer()
: Activ::IMappedMemory
, Activ::SharedObject< T >
  • GetPort() : Activ::IpAddress
  • GetPortId() : Activ::Address
  • GetPosition() : Activ::File
  • GetPrevious() : Activ::Database::ITable
  • GetPreviousPartial() : Activ::Database::ITable
  • GetPrice() : Activ::ContentPlatform::ContentGatewayApi::Tick
  • GetPrimaryIndexNumber() : Activ::Database::ITable
  • GetPrimaryKey() : Activ::Database::Record
  • GetPriority() : Activ::Thread
  • GetPrivate() : Activ::Application
  • GetProcess()
: Activ::SystemProxy
, Activ::ISystem
  • GetProperties() : Activ::ContentPlatform::Feed::TableTemplateIndex
  • GetRandomConfirmation() : Activ::UiIo
  • GetRational() : Activ::TRational
  • GetRealValue()
: Activ::IniFileParser
, Activ::IniFileParser::ConstSectionIterator
, Activ::IniFileParser::ConstKeyIterator
  • GetRealValueList()
: Activ::IniFileParser::ConstKeyIterator
, Activ::IniFileParser::ConstSectionIterator
, Activ::IniFileParser
  • GetRecordLength() : Activ::Database::ITable
  • GetRecordMessageBuilder() : Activ::ContentPlatform::ContributionServerApi::ContributionServerClient
  • GetRelationshipInfoList() : Activ::ContentPlatform::ContentGatewayApi::MetaDataRequestHelper
  • GetRemoteAddress() : Activ::IpSocket
  • GetRequestDistributionLogging() : Activ::IHeap
  • GetRequestId()
: Activ::HeapMessage
, Activ::SyncRequestId
  • GetResetType() : Activ::ContentPlatform::Feed::TableTemplate
  • GetResponse()
: Activ::SyncRequestId
, Activ::ContentPlatform::ContentGatewayApi::NewsRequestHelper
, Activ::ContentPlatform::ContributionGatewayApi::PublishRequestHelper< MESSAGE_TYPE_VALUE, REQUEST_PARAMETERS, RESPONSE_PARAMETERS >
, Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestHelper< MESSAGE_TYPE_VALUE, REQUEST_PARAMETERS >
, Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryRequestHelper
  • GetResponseAddress() : Activ::RequestId
  • GetReturnAddress() : Activ::HeapMessage
  • GetRule()
: Activ::ContentPlatform::Feed::TableTemplate
, Activ::ContentPlatform::Feed::TableTemplate::ConstRuleIterator
  • GetRules() : Activ::ContentPlatform::ContributionGatewayApi::PublishSymbolRecordParameters::Field
  • GetRuleSet()
: Activ::ContentPlatform::Feed::SymbolRecordField
, Activ::ContentPlatform::ContributionGatewayApi::PublishSymbolRecordParameters::Field
  • GetSearchOrder() : Activ::Database::Database
  • GetSecond()
: Activ::DateTime
, Activ::Time
, Activ::BaseTime
  • GetSectionName()
: Activ::LicenseServiceApi
, Activ::IniFileParser
  • GetSellerId() : Activ::ContentPlatform::ContentGatewayApi::Tick
  • GetSequence() : Activ::ContentPlatform::ContentGatewayApi::FieldSet
  • GetSerializedBodyLength()
: Activ::BinaryArray
, Activ::TextArray
, Activ::TextString
, Activ::BinaryString
, Activ::DateTime
, Activ::IFieldType
, Activ::SInt
, Activ::Time
, Activ::UInt
, Activ::CrcBlob
, Activ::Blob
, Activ::Rational
, Activ::Time
, Activ::Date
, Activ::TRational
  • GetSerializedLength()
: Activ::Blob
, Activ::ContentPlatform::ContentGatewayApi::HistoryBar
, Activ::BinaryArray
, Activ::BinaryString
, Activ::Date
, Activ::Rational
, Activ::TextArray
, Activ::Time
, Activ::Address
, Activ::Subject
, Activ::UInt
, Activ::ContentPlatform::ContentGatewayApi::FieldSet
, Activ::ContentPlatform::ContentGatewayApi::Tick
, Activ::CrcBlob
, Activ::IFieldType
, Activ::TextString
, Activ::TRational
, Activ::SInt
, Activ::Time
, Activ::DateTime
, Activ::ContentPlatform::ContentGatewayApi::OptionBar
, Activ::ContentPlatform::ContentGatewayApi::IntradayBar
  • GetSerializedTrend() : Activ::TRational::SerializedTrendDefinitions
  • GetServiceInstance() : Activ::Service
  • GetServiceLocation()
: Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
, Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient
  • GetSettings()
: Activ::ContentPlatform::ContributionServerApi::ContributionServerClient
, Activ::IpManager
  • GetShifted() : Activ::BitField< T, OFFSET_VALUE, LENGTH_VALUE >
  • GetShortTableNumber() : Activ::ContentPlatform::Feed::CompressedMessageDefinitions
  • GetSignedIntegral() : Activ::UiIo
  • GetSignedValue()
: Activ::IniFileParser::ConstKeyIterator
, Activ::IniFileParser
, Activ::IniFileParser::ConstSectionIterator
  • GetSignedValueList()
: Activ::IniFileParser::ConstSectionIterator
, Activ::IniFileParser
, Activ::IniFileParser::ConstKeyIterator
  • GetSize()
: Activ::TextString
, Activ::ContentPlatform::ContentGatewayApi::Tick
, Activ::ContentPlatform::Feed::TableTemplateList
, Activ::SharedObject< T >
, Activ::BinaryString
, Activ::CrcBlob
, Activ::BinaryArray
, Activ::TextArray
, Activ::Blob
, Activ::File
, Activ::IMappedMemory
, Activ::File
, Activ::ContentPlatform::ContentGatewayApi::Tick
  • GetSizeCompressed()
: Activ::Blob
, Activ::CrcBlob
  • GetSizeDecompressed()
: Activ::Blob
, Activ::CrcBlob
  • GetSizeWhenDecompressed()
: Activ::CrcBlob
, Activ::Blob
  • GetSocketHandle()
: Activ::UdpComponent
, Activ::IpSocket
, Activ::RouterServiceApi::Udp
  • GetSocketOption() : Activ::IpSocket
  • GetSourceAddress() : Activ::HeapMessage
  • GetSpecification()
: Activ::Database::Database
, Activ::Database::IIndex
, Activ::Database::FieldList::ConstIterator
  • GetStartTime() : Activ::Timeband
  • GetState()
: Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient
, Activ::TcpListener
, Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
, Activ::IProcess
, Activ::IEndPoint
  • GetStats()
: Activ::ObjectPool< T, INITIAL_FREE_LIST_SIZE, MAX_FREE_LIST_SIZE >
, Activ::IEndPoint
, Activ::SystemMonitor
, Activ::ISyncEndPoint
, Activ::IProcess
, Activ::IHeap
  • GetStatusCode() : Activ::HeapMessage
  • GetStrikePrice() : Activ::ContentPlatform::ContentGatewayApi::OptionBar
  • GetString() : Activ::UiIo
  • GetStringValue()
: Activ::IniFileParser::ConstKeyIterator
, Activ::IniFileParser
, Activ::IniFileParser::ConstSectionIterator
  • GetStringValueList()
: Activ::IniFileParser::ConstKeyIterator
, Activ::IniFileParser::ConstSectionIterator
, Activ::IniFileParser
  • GetSubject() : Activ::HeapMessage
  • GetSubName() : Activ::IniFileParser::ConstSectionIterator
  • GetSubscriptionInfo() : Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
  • GetSubscriptions() : Activ::PubSubServiceApi
  • GetSymbol()
: Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator
, Activ::ContentPlatform::ContentServerApi::SymbolRecordUpdate
, Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator
, Activ::ContentPlatform::Feed::SymbolRecordMessageValidator
, Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator
  • GetSymbolId() : Activ::ContentPlatform::ContentGatewayApi::TimeSeriesCookie
  • GetSymbolRecordField()
: Activ::ContentPlatform::Feed::SymbolRecordMessageValidator
, Activ::ContentPlatform::Feed::SymbolRecordFieldListValidator::ConstIterator
, Activ::ContentPlatform::Feed::SymbolRecordFieldListValidator
  • GetSymbolRecordMessageBuilder() : Activ::ContentPlatform::ContributionServerApi::ContributionServerClient
  • GetSystem()
: Activ::IProcess
, Activ::IEndPoint
, Activ::IHeap
  • GetSystemHeap()
: Activ::ISystem
, Activ::SystemProxy
  • GetSystemInfo()
: Activ::ISystem
, Activ::SystemProxy
  • GetSystemName()
: Activ::ISystem
, Activ::SystemProxy
  • GetTable()
: Activ::Database::Database::ConstIterator
, Activ::Database::Database::Iterator
, Activ::Database::Database
  • GetTableId()
: Activ::Database::Database::Iterator
, Activ::ContentPlatform::Feed::TableTemplateList::ConstIterator
, Activ::Database::Database::ConstIterator
, Activ::ContentPlatform::Feed::TableTemplateMessageValidator
  • GetTableIdList() : Activ::Database::Database
  • GetTableInfoList() : Activ::ContentPlatform::ContentGatewayApi::MetaDataRequestHelper
  • GetTableNumber()
: Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator
, Activ::ContentPlatform::ContentServerApi::RecordUpdateHelper< MESSAGE_VALIDATOR >
, Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator
  • GetTablePointer() : Activ::Database::FieldListObject
  • GetTableSpecification()
: Activ::ContentPlatform::ContentGatewayApi::MetaDataRequestHelper
, Activ::Database::ITable
  • GetTableTemplate()
: Activ::ContentPlatform::Feed::SymbolRecordMessageValidator
, Activ::ContentPlatform::Feed::RecordMessageHeaderValidator
, Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator
, Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator
, Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator
, Activ::ContentPlatform::Feed::RecordMessageValidator
, Activ::ContentPlatform::Feed::TableTemplateList::ConstIterator
, Activ::ContentPlatform::Feed::TableTemplateList
  • GetTableTemplateField()
: Activ::ContentPlatform::Feed::TableTemplateFieldListValidator
, Activ::ContentPlatform::Feed::TableTemplateMessageValidator
, Activ::ContentPlatform::Feed::TableTemplateFieldListValidator::ConstIterator
  • GetTableTemplateIndex()
: Activ::ContentPlatform::Feed::TableTemplateMessageValidator
, Activ::ContentPlatform::Feed::TableTemplateIndexListValidator
  • GetTableTemplateList() : Activ::ContentPlatform::ContributionServerApi::ContributionServerClient
  • GetTemporaryPath() : Activ::File
  • GetThreadPriority() : Activ::Thread
  • GetTick()
: Activ::TRational::SerializedTrendDefinitions
, Activ::TRational
  • GetTickCount()
: Activ::ContentPlatform::ContentGatewayApi::IntradayBar
, Activ::IntervalTimer
  • GetTickType() : Activ::ContentPlatform::ContentGatewayApi::Tick
  • GetTime() : Activ::DateTime
  • GetTimeout() : Activ::CurlFtpHelper
  • GetTimeStamp() : Activ::IntervalTimer
  • GetTimeZoneOffset()
: Activ::DateTime
, Activ::Time
  • GetTotalBytes()
: Activ::ScatterBufferHelper
, Activ::WsaBufHelper
  • GetTotalMessageStats() : Activ::ContentPlatform::ContentServerApi::ContentServerClient
  • GetTotalMilliseconds()
: Activ::Time
, Activ::DateTime
, Activ::BaseTime::Duration
  • GetTotalPrice()
: Activ::ContentPlatform::ContentGatewayApi::HistoryBar
, Activ::ContentPlatform::ContentGatewayApi::IntradayBar
  • GetTotalValue()
: Activ::ContentPlatform::ContentGatewayApi::HistoryBar
, Activ::ContentPlatform::ContentGatewayApi::IntradayBar
, Activ::ContentPlatform::ContentGatewayApi::HistoryBar
, Activ::ContentPlatform::ContentGatewayApi::IntradayBar
  • GetTotalVolume()
: Activ::ContentPlatform::ContentGatewayApi::HistoryBar
, Activ::ContentPlatform::ContentGatewayApi::IntradayBar
, Activ::ContentPlatform::ContentGatewayApi::HistoryBar
, Activ::ContentPlatform::ContentGatewayApi::IntradayBar
, Activ::ContentPlatform::ContentGatewayApi::OptionBar
  • GetTradeThroughExemptFlag() : Activ::ContentPlatform::ContentGatewayApi::Tick
  • GetTrendOnDay()
: Activ::TRational::SerializedTrendDefinitions
, Activ::TRational
  • GetTrendOnPrevious()
: Activ::TRational
, Activ::TRational::SerializedTrendDefinitions
  • GetType()
: Activ::Database::FieldListObject
, Activ::ContentPlatform::ContentGatewayApi::Tick
, Activ::ContentPlatform::ContentGatewayApi::HistoryBar
, Activ::ContentPlatform::ContentGatewayApi::FieldSet
, Activ::Database::FieldList::ConstIterator
, Activ::Database::FieldList
, Activ::ContentPlatform::ContentGatewayApi::OptionBar
, Activ::ContentPlatform::Feed::Field
, Activ::ContentPlatform::Feed::TableTemplate
, Activ::ContentPlatform::Feed::TableTemplateIndex
, Activ::IFieldType
, Activ::ContentPlatform::ContentGatewayApi::IntradayBar
, Activ::Database::ITable
, Activ::HeapMessage
  • GetUiHeading()
: Activ::ContentPlatform::Feed::Field
, Activ::ContentPlatform::Feed::TableTemplate
  • GetUiServiceName()
: Activ::Application
, Activ::UiComponent
  • GetUiUserAddress() : Activ::UiIo
  • GetUnderlyingPrice() : Activ::ContentPlatform::ContentGatewayApi::OptionBar
  • GetUniversalField()
: Activ::ContentPlatform::Feed::TableTemplateList
, Activ::ContentPlatform::Feed::UniversalFieldList
  • GetUniversalFieldHelper() : Activ::ContentPlatform::ContentGatewayApi::MetaDataRequestHelper
  • GetUniversalFieldHelperMap() : Activ::ContentPlatform::ContentGatewayApi::MetaDataRequestHelper
  • GetUniversalFieldList() : Activ::ContentPlatform::Feed::TableTemplateList
  • GetUnshifted() : Activ::BitField< T, OFFSET_VALUE, LENGTH_VALUE >
  • GetUnsignedIntegral() : Activ::UiIo
  • GetUnsignedValue()
: Activ::IniFileParser::ConstKeyIterator
, Activ::IniFileParser
, Activ::IniFileParser::ConstSectionIterator
  • GetUnsignedValueList()
: Activ::IniFileParser
, Activ::IniFileParser::ConstSectionIterator
, Activ::IniFileParser::ConstKeyIterator
  • GetUpdateFilterMapList() : Activ::ContentPlatform::ContentServerApi::ContentServerClient
  • GetUpdateId()
: Activ::ContentPlatform::ContentGatewayApi::Tick
, Activ::ContentPlatform::ContentServerApi::RecordUpdateHelper< MESSAGE_VALIDATOR >
, Activ::ContentPlatform::ContentGatewayApi::Tick
, Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator
, Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator
, Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator
, Activ::ContentPlatform::Feed::RecordMessageHeaderValidator
, Activ::ContentPlatform::Feed::SymbolRecordMessageValidator
, Activ::ContentPlatform::Feed::RecordMessageValidator
  • GetUtc()
: Activ::Time
, Activ::DateTime
  • GetUuid() : Activ::IProcess
  • GetValue() : Activ::RegistryHelper
  • GetVersion() : Activ::ContentPlatform::Feed::TableTemplate
  • GetWeekOfYear()
: Activ::Date
, Activ::DateTime
, Activ::Date
  • GetWindowSize() : Activ::UiIo
  • GetYear()
: Activ::Date
, Activ::DateTime
, Activ::BaseTime
  • GetZero() : Activ::Timeout
Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- h -

  • HandleIoFailure() : Activ::IpSocket
  • HandleManager() : Activ::HandleManager< T >
  • HasAllAvailable() : Activ::DynamicLibraryLoader< T >
  • HasPermissions() : Activ::UiPermissions
  • HasTick() : Activ::ContentPlatform::ContentGatewayApi::IntradayBar
  • HeapMessage() : Activ::HeapMessage
  • HeapMessageBuilder() : Activ::HeapMessageBuilder
  • HeapPool() : Activ::HeapPool
  • HighFields() : Activ::ContentPlatform::Feed::Rule::HighFields
  • HistoryBar() : Activ::ContentPlatform::ContentGatewayApi::HistoryBar
  • Hours() : Activ::Time::Hours
Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- i -

  • IFieldType() : Activ::IFieldType
  • IFtpHelper() : Activ::IFtpHelper
  • IncrementLength() : Activ::HeapMessage
  • IncrementOffset()
: Activ::HeapMessage::ReadHelper
, Activ::HeapMessage::WriteHelper
  • IndexesToString() : Activ::ContentPlatform::Feed::TableTemplate
  • IndexFieldSpecification() : Activ::ContentPlatform::Feed::Index::IndexFieldSpecification
  • IndexNameToString() : Activ::ContentPlatform::Feed::RecordMessageHeaderValidator
  • IndexNumberToString() : Activ::ContentPlatform::Feed::RecordMessageHeaderValidator
  • IndexSpecification() : Activ::Database::IndexSpecification
  • IniFileParser() : Activ::IniFileParser
  • Initialize()
: Activ::ContentPlatform::ContentGatewayApi::FieldListValidator
, Activ::ContentPlatform::Feed::RecordMessageBuilder
, Activ::ContentPlatform::Feed::Rule::HighFields
, Activ::ContentPlatform::Feed::Rule::LowFields
, Activ::ContentPlatform::Feed::RecordMessageBuilder
, Activ::ContentPlatform::Feed::Rule::LowFields
, Activ::ContentPlatform::Feed::Rule::OpenFields
, Activ::ContentPlatform::ContentServerApi::FieldListValidator
, Activ::ContentPlatform::Feed::RecordMessageBuilder
, Activ::ContentPlatform::Feed::Rule::OpenFields
, Activ::ContentPlatform::Feed::Rule::CloseFields
, Activ::ContentPlatform::Feed::RecordMessageHeaderValidator
, Activ::ContentPlatform::Feed::Rule::CloseFields
, Activ::ContentPlatform::Feed::Rule::PriceFields
, Activ::ContentPlatform::ContentServerApi::FieldListValidator
, Activ::ContentPlatform::Feed::RecordMessageHeaderValidator
, Activ::ContentPlatform::Feed::Rule::PriceFields
, Activ::ContentPlatform::Feed::Rule::VolumeFields
, Activ::ContentPlatform::Feed::RecordMessageHeaderValidator
, Activ::ContentPlatform::Feed::Rule::VolumeFields
, Activ::ContentPlatform::Feed::Rule
, Activ::ContentPlatform::FeedApi::SymbolPatternHelper
, Activ::ContentPlatform::Feed::RecordMessageValidator
, Activ::ContentPlatform::Feed::Rule
, Activ::ContentPlatform::Feed::TableTemplate
, Activ::ContentPlatform::Feed::RecordMessageValidator
, Activ::ContentPlatform::Feed::TableTemplate
, Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator
, Activ::ContentPlatform::Feed::RecordMessageValidator
, Activ::ContentPlatform::Feed::TableTemplateAddition
, Activ::ContentPlatform::Feed::TableTemplateList
, Activ::ContentPlatform::Feed::SymbolRecordField
, Activ::ContentPlatform::Feed::TableTemplateList
, Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator
, Activ::ContentPlatform::Feed::SymbolRecordFieldListBuilder
, Activ::ContentPlatform::Feed::TableTemplateList
, Activ::ContentPlatform::Feed::SymbolRecordFieldListValidator
, Activ::ContentPlatform::Feed::TableTemplateList
, Activ::ContentPlatform::Feed::UniversalFieldList
, Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator
, Activ::ContentPlatform::Feed::SymbolRecordFieldListValidator
, Activ::ContentPlatform::Feed::UniversalFieldList
, Activ::ContentPlatform::Feed::SymbolRecordMessageBuilder
, Activ::ContentPlatform::Feed::UniversalFieldList
, Activ::ContentPlatform::Feed::CompressedMessageDefinitions::FieldHeaderBuilder
, Activ::ContentPlatform::Feed::SymbolRecordMessageBuilder
, Activ::MessageBuilder
, Activ::ContentPlatform::Feed::SymbolRecordMessageBuilder
, Activ::MessageRateThrottler
, Activ::ContentPlatform::Feed::CompressedMessageDefinitions::FieldHeaderValidator
, Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator
, Activ::MessageValidator
, Activ::Shell
, Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator
, Activ::Database::FieldListObject
, Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator
, Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator
, Activ::Database::Key
, Activ::ContentPlatform::Feed::SymbolRecordMessageValidator
, Activ::Database::Key
, Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator
, Activ::ContentPlatform::Feed::SymbolRecordMessageValidator
, Activ::Database::Record
, Activ::ContentPlatform::Feed::SymbolRecordMessageValidator
, Activ::Database::Record
, Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator
, Activ::ContentPlatform::Feed::TableTemplateField
, Activ::UdpSocket
, Activ::ContentPlatform::Feed::TableTemplateFieldListValidator
, Activ::HeapMessage::ReadHelper
, Activ::ContentPlatform::Feed::RecordFieldListBuilder
, Activ::ContentPlatform::Feed::TableTemplateIndex
, Activ::HeapMessage::WriteHelper
, Activ::ContentPlatform::Feed::TableTemplateIndexListValidator
, Activ::HeapMessageDeserializer< MESSAGE_TYPE, BUFFER_SIZE >
, Activ::CurlFtpHelper
, Activ::ContentPlatform::Feed::RecordFieldListValidator
, Activ::ContentPlatform::Feed::TableTemplateMessageValidator
, Activ::HandleManager< T >
, Activ::ContentPlatform::Feed::TableTemplateMessageValidator
, Activ::ContentPlatform::Feed::RecordKeyFieldListBuilder
, Activ::ContentPlatform::Feed::TableTemplateMessageValidator
, Activ::ContentPlatform::Feed::Rule::CopyToFields
, Activ::ContentPlatform::Feed::RecordKeyFieldListValidator
, Activ::ContentPlatform::Feed::Rule::CopyToFields
, Activ::ContentPlatform::Feed::Rule::HighFields
  • InitializeAdd1CumulativeValueFields() : Activ::ContentPlatform::Feed::Rule::VolumeFields
  • InitializeAdd1Fields() : Activ::ContentPlatform::Feed::Rule::VolumeFields
  • InitializeAdd2CumulativeValueFields() : Activ::ContentPlatform::Feed::Rule::VolumeFields
  • InitializeAdd2Fields() : Activ::ContentPlatform::Feed::Rule::VolumeFields
  • InitializeChangeFields() : Activ::ContentPlatform::Feed::Rule::PriceFields
  • InitializeList() : Activ::ContentPlatform::Feed::UniversalFieldList
  • InitializeSourceFields() : Activ::ContentPlatform::Feed::Rule
  • InitializeUndefined() : Activ::ContentPlatform::Feed::SymbolRecordField
  • Insert()
: Activ::MessageBuilder
, Activ::HeapMessage
, Activ::MessageBuilder
  • InsertBoolean() : Activ::MessageBuilder
  • InsertInEndian() : Activ::MessageBuilder
  • InsertTableTemplate() : Activ::ContentPlatform::Feed::TableTemplateList
  • InterfaceInfo() : Activ::IpManager::InterfaceInfo
  • IntervalTimer() : Activ::IntervalTimer
  • IntradayBar() : Activ::ContentPlatform::ContentGatewayApi::IntradayBar
  • IoCompletionManager() : Activ::IoCompletionManager
  • IpAddress() : Activ::IpAddress
  • IpException() : Activ::IpException
  • IpManager() : Activ::IpManager
  • IpSocket() : Activ::IpSocket
  • IsAbsolutePeriod() : Activ::ContentPlatform::ContentGatewayApi::Period
  • IsAdd() : Activ::Database::ITable
  • IsAmfField() : Activ::ContentPlatform::Feed::Field
  • IsAmfTable() : Activ::ContentPlatform::Feed::TableTemplate
  • IsAscending() : Activ::Database::IndexSpecification::Field
  • IsComplete() : Activ::ContentPlatform::Feed::RecordKeyFieldListBuilder
  • IsCompleteResponse() : Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
  • IsComposite()
: Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderDefinitions
, Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator
, Activ::ContentPlatform::Feed::CompressedMessageHeaderDefinitions
, Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator
, Activ::ContentPlatform::Feed::SymbolRecordField
, Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions
, Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator
, Activ::ContentPlatform::Feed::SymbolRecordMessageValidator
  • IsCompositeAsk()
: Activ::ContentPlatform::Feed::CombinedQuoteMessageHeaderDefinitions
, Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator
  • IsCompositeAskAppendage() : Activ::ContentPlatform::Feed::CombinedQuoteMessageHeaderDefinitions
  • IsCompositeAskToString() : Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator
  • IsCompositeBid()
: Activ::ContentPlatform::Feed::CombinedQuoteMessageHeaderDefinitions
, Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator
  • IsCompositeBidAppendage() : Activ::ContentPlatform::Feed::CombinedQuoteMessageHeaderDefinitions
  • IsCompositeBidToString() : Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator
  • IsCompositeToString()
: Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator
, Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator
, Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator
  • IsCompressed()
: Activ::Blob
, Activ::CrcBlob
  • IsCompressedSymbol() : Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderDefinitions
  • IsCompressedSymbolDefined() : Activ::ContentPlatform::Feed::CompressedMessageDefinitions
  • IsConnected()
: Activ::CurlFtpHelper
, Activ::FtpHelper
, Activ::IFtpHelper
, Activ::SmtpHelper
  • IsContributed() : Activ::ContentPlatform::Feed::TableTemplate
  • IsContributedUniversalFieldList() : Activ::ContentPlatform::Feed::UniversalFieldList
  • IsDefaultValue()
: Activ::CommandLineParser
, Activ::CommandLineParserDetail::CommandLineParserImpl
  • IsDefined()
: Activ::ContentPlatform::Feed::SymbolRecordField
, Activ::ContentPlatform::Feed::Rule
  • IsDelete()
: Activ::ContentPlatform::ContentGatewayApi::NewsUpdate
, Activ::ContentPlatform::ContentGatewayApi::RecordUpdate
, Activ::ContentPlatform::ContentServerApi::RecordUpdateHelper< MESSAGE_VALIDATOR >
, Activ::ContentPlatform::Feed::CompressedMessageHeaderDefinitions
, Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator
, Activ::ContentPlatform::Feed::RecordMessageHeaderDefinitions
, Activ::ContentPlatform::Feed::RecordMessageHeaderValidator
, Activ::ContentPlatform::Feed::RecordMessageValidator
, Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions
, Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator
, Activ::ContentPlatform::Feed::SymbolRecordMessageValidator
  • IsDeleteToString()
: Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator
, Activ::ContentPlatform::Feed::RecordMessageHeaderValidator
, Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator
  • IsDescending() : Activ::Database::IndexSpecification::Field
  • IsDifferent()
: Activ::Rational
, Activ::CrcBlob
, Activ::BinaryArray
, Activ::BinaryString
, Activ::Blob
, Activ::Date
, Activ::DateTime
, Activ::IFieldType
, Activ::SInt
, Activ::TextArray
, Activ::TextString
, Activ::Time
, Activ::TRational
, Activ::UInt
  • IsDirectory() : Activ::File
  • IsDiskBased() : Activ::ContentPlatform::Feed::TableTemplate
  • IsDivisor() : Activ::Rational::DenominatorType
  • IsDivisorBinary() : Activ::Rational::DenominatorType
  • IsDivisorDecimal() : Activ::Rational::DenominatorType
  • IsDoNotAdd()
: Activ::ContentPlatform::Feed::RecordMessageHeaderDefinitions
, Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions
  • IsDuplicate()
: Activ::Database::IIndex
, Activ::Database::IndexSpecification
  • IsEmpty()
: Activ::ContentPlatform::ContentGatewayApi::FieldData
, Activ::ContentPlatform::Feed::UniversalFieldList
  • IsEndOfMessage()
: Activ::MessageValidator
, Activ::HeapMessageDeserializer< MESSAGE_TYPE, BUFFER_SIZE >
  • IsExpandedFormat()
: Activ::ContentPlatform::Feed::RecordMessageHeaderDefinitions
, Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions
  • IsFieldDefined()
: Activ::Database::FieldList
, Activ::ContentPlatform::Feed::FieldHeaderDefinitions
, Activ::Database::FieldList
, Activ::Database::FieldListObject
  • IsFieldDifferent()
: Activ::Database::FieldListObject
, Activ::Database::FieldList
, Activ::Database::FieldListObject
  • IsFieldPresent() : Activ::ContentPlatform::FeedApi::FieldListValidator
  • IsFieldRulesPresent() : Activ::ContentPlatform::Feed::SymbolRecordFieldHeaderDefinitions
  • IsFileNameOnly() : Activ::File
  • IsFound()
: Activ::Database::FieldList
, Activ::File
, Activ::Database::FieldListObject
, Activ::Database::ITable
  • IsHash() : Activ::Database::IndexSpecification
  • IsHigh() : Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ContentServerRuleSet
  • IsIn() : Activ::Timeband
  • IsInitialized()
: Activ::ContentPlatform::FeedApi::FieldListValidator
, Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator
, Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator
, Activ::ContentPlatform::Feed::RecordFieldListValidator
, Activ::ContentPlatform::Feed::RecordKeyFieldListBuilder
, Activ::ContentPlatform::Feed::RecordMessageValidator
, Activ::ContentPlatform::Feed::RecordMessageHeaderValidator
, Activ::ContentPlatform::Feed::SymbolRecordFieldListValidator
, Activ::ContentPlatform::Feed::SymbolRecordMessageValidator
, Activ::ContentPlatform::Feed::SymbolRecordFieldListBuilder
, Activ::ContentPlatform::Feed::TableTemplateField
, Activ::ContentPlatform::Feed::TableTemplateMessageValidator
, Activ::Des3Helper::Key
, Activ::ContentPlatform::Feed::SymbolRecordMessageBuilder
, Activ::ContentPlatform::Feed::TableTemplateIndexListValidator
, Activ::Database::FieldList::ConstIterator
, Activ::ContentPlatform::Feed::RecordFieldListBuilder
, Activ::IFieldType
, Activ::DesHelper::Key
, Activ::ContentPlatform::Feed::SymbolRecordField
, Activ::Database::FieldListObject
, Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator
, Activ::ContentPlatform::Feed::RecordMessageBuilder
, Activ::ContentPlatform::Feed::TableTemplateIndex
, Activ::ContentPlatform::Feed::TableTemplateFieldListValidator
, Activ::ContentPlatform::Feed::RecordKeyFieldListValidator
, Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::RecordMessageBuilder
, Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::SymbolRecordMessageBuilder
  • IsLatestVersion() : Activ::ContentPlatform::Feed::TableTemplate
  • IsLeapYear() : Activ::Date
  • IsLoopback() : Activ::IpAddress
  • IsLow() : Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ContentServerRuleSet
  • IsManaged() : Activ::Database::ITable
  • IsMatch()
: Activ::Database::FieldSpecification
, Activ::Database::IndexSpecification
, Activ::ContentPlatform::FeedApi::SymbolPatternHelper
  • IsMessageAttached() : Activ::HeapMessage
  • IsMulticast() : Activ::IpAddress
  • IsMultiplier() : Activ::Rational::DenominatorType
  • IsNameGreater() : Activ::FileInfo
  • IsNewRecord()
: Activ::ContentPlatform::ContentServerApi::RecordUpdateHelper< MESSAGE_VALIDATOR >
, Activ::ContentPlatform::ContentGatewayApi::RecordUpdate
, Activ::ContentPlatform::ContentGatewayApi::NewsUpdate
  • IsOpen()
: Activ::File
, Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ContentServerRuleSet
, Activ::SharedObject< T >
  • IsOpenValid() : Activ::ContentPlatform::ContentGatewayApi::HistoryBar
  • IsOutOfSequence() : Activ::ContentPlatform::ContentGatewayApi::Tick
  • IsPartialSubset() : Activ::ContentPlatform::FeedApi::FieldListValidator
  • IsPattern() : Activ::ContentPlatform::FeedApi::SymbolPatternHelper
  • IsPending() : Activ::IoCompletionManager::Overlapped
  • IsPermissionIdDefined() : Activ::ContentPlatform::Feed::CompressedMessageDefinitions
  • IsPrimaryUnique()
: Activ::Database::IndexSpecification
, Activ::Database::IIndex
  • IsPurged() : Activ::ContentPlatform::Feed::TableTemplate
  • IsRecordFileOpen() : Activ::Database::ITable
  • IsRefresh()
: Activ::ContentPlatform::Feed::RecordMessageHeaderDefinitions
, Activ::ContentPlatform::Feed::RecordMessageHeaderValidator
, Activ::ContentPlatform::Feed::RecordMessageValidator
, Activ::ContentPlatform::ContentServerApi::RecordUpdateHelper< MESSAGE_VALIDATOR >
  • IsRefreshToString() : Activ::ContentPlatform::Feed::RecordMessageHeaderValidator
  • IsRegularHour() : Activ::ContentPlatform::ContentGatewayApi::IntradayBar
  • IsRegularHourTrade() : Activ::ContentPlatform::ContentGatewayApi::Tick
  • IsRelativeCount() : Activ::ContentPlatform::ContentGatewayApi::Period
  • IsRelativePeriod() : Activ::ContentPlatform::ContentGatewayApi::Period
  • IsResponseKeyDefined() : Activ::ContentPlatform::ContentGatewayApi::ResponseBlock
  • IsRulesPresent() : Activ::ContentPlatform::ContributionGatewayApi::PublishSymbolRecordParameters::Field
  • IsShortTableNumber() : Activ::ContentPlatform::Feed::CompressedMessageDefinitions
  • IsShortTableNumberDefined() : Activ::ContentPlatform::Feed::CompressedMessageDefinitions
  • IsSizeGreater() : Activ::FileInfo
  • IsStale() : Activ::ContentPlatform::ContentServerApi::RecordUpdateHelper< MESSAGE_VALIDATOR >
  • IsSubset() : Activ::ContentPlatform::FeedApi::FieldListValidator
  • IsSystemRestartable() : Activ::AgentApplication
  • IsTableTemplate() : Activ::ContentPlatform::Feed::TableTemplate
  • IsTableTemplateAddition() : Activ::ContentPlatform::Feed::TableTemplateAddition
  • IsTemporary() : Activ::Database::ITable
  • IsTimeGreater() : Activ::FileInfo
  • IsTimeLess() : Activ::FileInfo
  • IsTrade() : Activ::ContentPlatform::ContentGatewayApi::Tick
  • IsTree()
: Activ::Database::IndexSpecification
, Activ::Database::IIndex
  • IsUnique()
: Activ::Database::IIndex
, Activ::Database::IndexSpecification
  • IsUnspecified() : Activ::IpAddress
  • IsUpdate() : Activ::Database::ITable
  • IsUsEquityOption() : Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderDefinitions
  • IsUserLoggedOn() : Activ::ContentPlatform::ContentServerApi::ContentServerClient
  • IsUtc() : Activ::BaseTime
  • IsValid()
: Activ::SocketWrapper
, Activ::ScopedAddress
, Activ::Address
  • IsValidDenominator() : Activ::Rational
  • IsValidMessageType()
: Activ::ContentPlatform::Feed::TableTemplateMessageHeaderDefinitions
, Activ::ContentPlatform::Feed::RecordMessageHeaderDefinitions
, Activ::ContentPlatform::Feed::MessageHeaderDefinitions
, Activ::ContentPlatform::Feed::CombinedQuoteMessageHeaderDefinitions
, Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderDefinitions
, Activ::ContentPlatform::Feed::CompressedMessageHeaderDefinitions
, Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions
  • IsValidNumerator() : Activ::Rational
  • IsValidResponse()
: Activ::ContentPlatform::ContentGatewayApi::ResponseBlock
, Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
, Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient
  • IsValidSerializedBodyLength()
: Activ::BinaryString
, Activ::BinaryArray
, Activ::UInt
, Activ::CrcBlob
, Activ::Blob
, Activ::Date
, Activ::DateTime
, Activ::TextArray
, Activ::Time
, Activ::Rational
, Activ::IFieldType
, Activ::TRational
, Activ::TextString
, Activ::SInt
  • IsValidTick() : Activ::TRational
  • IsValidTrend() : Activ::TRational
  • IsVWAPOnly() : Activ::ContentPlatform::ContentGatewayApi::IntradayBar
  • ITable() : Activ::Database::ITable
  • Iterator() : Activ::HeapMessage::Iterator
Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- p -

  • Parameter() : Activ::CommandLineParser
  • Parse() : Activ::Url
  • ParseException() : Activ::IniFileParser::ParseException
  • PartialUpdate() : Activ::ContentPlatform::Feed::SymbolRecordField::PartialUpdate
  • PartialUpdateToString() : Activ::ContentPlatform::Feed::SymbolRecordField
  • PatternMatchListRequestParameters() : Activ::ContentPlatform::ContentGatewayApi::PatternMatchListRequestParameters
  • PatternMatchRequestParameters() : Activ::ContentPlatform::ContentGatewayApi::PatternMatchRequestParameters
  • PermissionIdHelper() : Activ::ContentPlatform::Feed::PermissionIdHelper
  • PermissionIdToString()
: Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator
, Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator
, Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator
, Activ::ContentPlatform::Feed::RecordMessageHeaderValidator
  • Populate() : Activ::SystemInfo
  • Port() : Activ::Port
  • PostConnect() : Activ::TcpSocket
  • PostData()
: Activ::RouterServiceApi::Udp
, Activ::UdpComponent
  • PostDiesToThreads() : Activ::ManagedEndPoint
  • PostEmail() : Activ::SmtpHelper
  • PostEmptyResponse() : Activ::Port
  • PostGetFirstRequest() : Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestHelper< FIRST_MESSAGE_TYPE_VALUE, NEXT_MESSAGE_TYPE_VALUE, FIELD_SET_TYPE >
  • PostGetNextRequest() : Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestHelper< FIRST_MESSAGE_TYPE_VALUE, NEXT_MESSAGE_TYPE_VALUE, FIELD_SET_TYPE >
  • PostIoCompletion() : Activ::IoCompletionManager::Overlapped
  • PostMessage()
: Activ::Port
, Activ::PostMessageHelper
, Activ::SmtpHelper
, Activ::IEndPoint
  • PostMessageHelper() : Activ::PostMessageHelper
  • PostMessages() : Activ::IEndPoint
  • PostRead() : Activ::IpSocket
  • PostRequest()
: Activ::ContentPlatform::ContentGatewayApi::NewsRequestHelper
, Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestHelper< MESSAGE_TYPE_VALUE, REQUEST_PARAMETERS >
, Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryRequestHelper
, Activ::ContentPlatform::ContributionGatewayApi::PublishRequestHelper< MESSAGE_TYPE_VALUE, REQUEST_PARAMETERS, RESPONSE_PARAMETERS >
, Activ::Port
  • PostResponse() : Activ::Port
  • PostWrite() : Activ::IpSocket
  • PreLockedBreak() : Activ::TcpSocket
  • PreLockedRead() : Activ::IpSocket
  • PreLockedWrite() : Activ::IpSocket
  • PriceFields() : Activ::ContentPlatform::Feed::Rule::PriceFields
  • Printf() : Activ::ConsoleWindow
  • PrintUsage()
: Activ::CommandLineParser
, Activ::CommandLineParserDetail::CommandLineParserImpl
  • Process()
: Activ::Thread
, Activ::Fiber
, Activ::CommandLineParserDetail::CommandLineParserImpl
, Activ::CommandLineParser
, Activ::ManagedEndPoint
  • ProcessOpenServiceRequest() : Activ::Service
  • ProcessOption() : Activ::UiMenu
  • ProcessSplit()
: Activ::ContentPlatform::ContentGatewayApi::IntradayBar
, Activ::ContentPlatform::ContentGatewayApi::HistoryBar
, Activ::ContentPlatform::ContentGatewayApi::Tick
, Activ::ContentPlatform::ContentGatewayApi::FieldSet
  • Proxy()
: Activ::Address::Proxy
, Activ::ScopedAddress::Proxy
  • Publish() : Activ::PubSubServiceApi
  • PublishField() : Activ::ContentPlatform::ContributionGatewayApi::PublishField
  • PublishRecordBaseParameters() : Activ::ContentPlatform::ContributionGatewayApi::PublishRecordBaseParameters
  • PublishRecordParameters() : Activ::ContentPlatform::ContributionGatewayApi::PublishRecordParameters
  • PublishSymbolRecordParameters() : Activ::ContentPlatform::ContributionGatewayApi::PublishSymbolRecordParameters
  • PutString() : Activ::UiIo
  • PutStringList() : Activ::UiIo
  • PutStringV() : Activ::UiIo
Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- r -

  • Randomize()
: Activ::Des3Helper::Key
, Activ::Des3Helper::KeyBundle
, Activ::DesHelper::Key
  • Rational() : Activ::Rational
  • Read()
: Activ::ContentPlatform::Feed::TableTemplateList::Settings
, Activ::UdpComponent
, Activ::IpManager::Settings
, Activ::AgentApplication::Settings
, Activ::ISystem::Settings
, Activ::ManagedEndPoint::Settings
, Activ::File
, Activ::ContentPlatform::ContentServerApi::ContentServerClient::Settings
, Activ::Application::Settings
, Activ::RouterServiceApi::Udp
, Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::Settings
, Activ::ServiceAccessPoint
, Activ::ThinApplication::Settings
  • ReadBucketInfoVector() : Activ::IHeap
  • ReadDate() : Activ::ContentPlatform::ContentGatewayApi::FieldSet
  • ReadDateTime() : Activ::ContentPlatform::ContentGatewayApi::FieldSet
  • ReadHelper() : Activ::HeapMessage::ReadHelper
  • ReadInteger() : Activ::ContentPlatform::ContentGatewayApi::FieldSet
  • ReadLine()
: Activ::ConsoleWindow
, Activ::File
  • ReadRationalFromDoubleString() : Activ::ContentPlatform::ContentGatewayApi::FieldSet
  • ReadTime() : Activ::ContentPlatform::ContentGatewayApi::FieldSet
  • RealtimeRequestParameters() : Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters
  • RealtimeResponseParameters() : Activ::ContentPlatform::ContentGatewayApi::RealtimeResponseParameters
  • Record() : Activ::Database::Record
  • RecordFieldListBuilder() : Activ::ContentPlatform::Feed::RecordFieldListBuilder
  • RecordFieldListValidator() : Activ::ContentPlatform::Feed::RecordFieldListValidator
  • RecordKeyFieldListBuilder() : Activ::ContentPlatform::Feed::RecordKeyFieldListBuilder
  • RecordKeyFieldListValidator() : Activ::ContentPlatform::Feed::RecordKeyFieldListValidator
  • RecordMessageBuilder()
: Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::RecordMessageBuilder
, Activ::ContentPlatform::Feed::RecordMessageBuilder
  • RecordMessageHeaderValidator() : Activ::ContentPlatform::Feed::RecordMessageHeaderValidator
  • RecordMessageValidator() : Activ::ContentPlatform::Feed::RecordMessageValidator
  • RecordUpdate() : Activ::ContentPlatform::ContentServerApi::RecordUpdate
  • RecordUpdateHelper() : Activ::ContentPlatform::ContentServerApi::RecordUpdateHelper< MESSAGE_VALIDATOR >
  • Reduce() : Activ::ContentPlatform::ContentGatewayApi::OptionBar
  • ReferenceCounter() : Activ::ReferenceCounter
  • Register() : Activ::Service
  • RelationshipIdHelper() : Activ::ContentPlatform::Feed::RelationshipIdHelper
  • Release()
: Activ::IMutex
, Activ::ISemaphore
, Activ::HeapMessage
, Activ::ScopedAddress
  • ReleaseMemory() : Activ::ThreadSpecificPoolAllocator< T, UserAllocator, NextSize >
  • Remove()
: Activ::DirectoryRemover
, Activ::File
  • RemoveDisabledDate() : Activ::Timeband
  • RemoveProcess() : Activ::SystemMonitor
  • RemoveTableTemplate() : Activ::ContentPlatform::Feed::TableTemplateList
  • RemoveTrade() : Activ::ContentPlatform::ContentGatewayApi::IntradayBar
  • RemoveUpdateFilter() : Activ::ContentPlatform::ContentServerApi::ContentServerClient
  • Rename() : Activ::File
  • RequestBlock() : Activ::ContentPlatform::ContentGatewayApi::RequestBlock
  • RequestId() : Activ::RequestId
  • Reset()
: Activ::ContentPlatform::ContentGatewayApi::Tick
, Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator
, Activ::Rational
, Activ::SInt
, Activ::TextString
, Activ::TRational
, Activ::Blob
, Activ::ContentPlatform::Feed::RecordKeyFieldListValidator
, Activ::ContentPlatform::Feed::RecordKeyFieldListBuilder
, Activ::ContentPlatform::ContentGatewayApi::HistoryBar
, Activ::CrcBlob
, Activ::IFieldType
, Activ::ContentPlatform::FeedApi::FieldListValidator
, Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::RecordMessageBuilder
, Activ::DateTime
, Activ::MessageValidator
, Activ::Database::Record
, Activ::Time
, Activ::BinaryArray
, Activ::ContentPlatform::Feed::TableTemplateField
, Activ::ContentPlatform::ContentGatewayApi::FieldSet
, Activ::UInt
, Activ::ContentPlatform::ContentGatewayApi::IntradayBar
, Activ::ContentPlatform::Feed::TableTemplateMessageValidator
, Activ::ContentPlatform::ContentGatewayApi::OptionBar
, Activ::ContentPlatform::Feed::TableTemplateFieldListValidator
, Activ::ContentPlatform::Feed::SymbolRecordMessageValidator
, Activ::TextArray
, Activ::ContentPlatform::Feed::SymbolRecordFieldListValidator
, Activ::ContentPlatform::Feed::RecordMessageValidator
, Activ::BinaryString
, Activ::Database::FieldListObject
, Activ::ContentPlatform::Feed::RecordFieldListValidator
, Activ::ScatterBufferHelper
, Activ::Database::Key
, Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::SymbolRecordMessageBuilder
, Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator
, Activ::ContentPlatform::Feed::RecordFieldListBuilder
, Activ::MessageBuilder
, Activ::WsaBufHelper
, Activ::ContentPlatform::Feed::RecordMessageBuilder
, Activ::ContentPlatform::Feed::RecordMessageHeaderValidator
, Activ::ContentPlatform::Feed::SymbolRecordFieldListBuilder
, Activ::ContentPlatform::Feed::TableTemplateIndex
, Activ::ContentPlatform::Feed::TableTemplateList
, Activ::ContentPlatform::Feed::TableTemplateIndexListValidator
, Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator
, Activ::Date
, Activ::ContentPlatform::Feed::SymbolRecordMessageBuilder
, Activ::MessageHandler
, Activ::MessageRateThrottler
, Activ::ScatterBufferHelper
, Activ::ContentPlatform::Feed::SymbolRecordField
  • ResetData() : Activ::Database::FieldList
  • ResetKey() : Activ::Database::IIndex
  • ResetRecord() : Activ::Database::ITable
  • ResetStats() : Activ::IHeap
  • Resize() : Activ::IFileMappedMemory
  • RestartSystem() : Activ::AgentApplication
  • Return()
: Activ::HeapMessage
, Activ::Fiber
, Activ::ObjectPool< T, INITIAL_FREE_LIST_SIZE, MAX_FREE_LIST_SIZE >
, Activ::SyncRequestId
, Activ::HeapPool
  • ReturnAll() : Activ::ObjectPool< T, INITIAL_FREE_LIST_SIZE, MAX_FREE_LIST_SIZE >
  • Rule() : Activ::ContentPlatform::Feed::Rule
  • RuleSetToString() : Activ::ContentPlatform::Feed::SymbolRecordField
  • RulesToString() : Activ::ContentPlatform::Feed::TableTemplate
  • Run()
: Activ::Shell
, Activ::UiComponent
, Activ::Process
, Activ::ManagedEndPoint
, Activ::UiMenu
  • RunHelper() : Activ::ManagedEndPoint::RunHelper
  • RxOverlapped() : Activ::IpSocket::RxOverlapped
Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- s -

  • SameAsLastCheck() : Activ::ContentPlatform::ContentGatewayApi::SymbolResponse
  • Save() : Activ::Database::ITable
  • ScaleTimeStamp() : Activ::IntervalTimer
  • ScatterBufferHelper() : Activ::ScatterBufferHelper
  • Scoped() : Activ::IntervalTimer::Scoped
  • ScopedAddress() : Activ::ScopedAddress
  • ScopedHelper() : Activ::ScopedHelper< T, D >
  • ScopedMemory() : Activ::ScopedMemory< T >
  • ScopedMutexLocker() : Activ::ScopedMutexLocker
  • ScopedMutexTryLocker() : Activ::ScopedMutexTryLocker
  • ScopedPooledObject() : Activ::ScopedPooledObject< T >
  • ScopedSubscription() : Activ::ScopedSubscription
  • ScopedVersion() : Activ::MessageHandler::ScopedVersion
  • SearchPath() : Activ::File
  • Seconds() : Activ::Time::Seconds
  • Send() : Activ::RouterServiceApi::Udp
  • SendGetFirstRequest() : Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestHelper< FIRST_MESSAGE_TYPE_VALUE, NEXT_MESSAGE_TYPE_VALUE, FIELD_SET_TYPE >
  • SendGetNextRequest() : Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestHelper< FIRST_MESSAGE_TYPE_VALUE, NEXT_MESSAGE_TYPE_VALUE, FIELD_SET_TYPE >
  • SendMessage() : Activ::ISyncEndPoint
  • SendRequest()
: Activ::ContentPlatform::ContributionGatewayApi::PublishRequestHelper< MESSAGE_TYPE_VALUE, REQUEST_PARAMETERS, RESPONSE_PARAMETERS >
, Activ::Port
, Activ::ContentPlatform::ContentGatewayApi::NewsRequestHelper
, Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestHelper< MESSAGE_TYPE_VALUE, REQUEST_PARAMETERS >
, Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryRequestHelper
, Activ::ContentPlatform::ContributionGatewayApi::PublishRequestHelper< MESSAGE_TYPE_VALUE, REQUEST_PARAMETERS, RESPONSE_PARAMETERS >
  • SendTo() : Activ::RouterServiceApi::Udp
  • SerializableBuffer() : Activ::SerializableBuffer< LENGTH_TYPE, MIN_LENGTH, MAX_LENGTH >
  • Serialize()
: Activ::SystemInfo
, Activ::SerializableBuffer< LENGTH_TYPE, MIN_LENGTH, MAX_LENGTH >
, Activ::SerializableContainerHelper< CONTAINER_TYPE, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >
, Activ::Uuid
, Activ::Database::DatabaseSpecification::DatabaseTableSpecification
, Activ::Database::DatabaseSpecification
, Activ::Database::FieldList
, Activ::Database::FieldListObject
, Activ::Database::FieldSpecification
, Activ::Database::IndexSpecification::Field
, Activ::Database::IndexSpecification
, Activ::Database::ITable
, Activ::Database::Key
, Activ::Database::Record
, Activ::Database::TableSpecification
, Activ::BinaryArray
, Activ::BinaryString
, Activ::ContentPlatform::ContentGatewayApi::FieldSet
, Activ::Blob
, Activ::ContentPlatform::ContentGatewayApi::HistoryBar
, Activ::CrcBlob
, Activ::ContentPlatform::ContentGatewayApi::IntradayBar
, Activ::Date
, Activ::DateTime
, Activ::ContentPlatform::ContentGatewayApi::OptionBar
, Activ::IFieldType
, Activ::ContentPlatform::ContentGatewayApi::RequestBlock
, Activ::IFieldType
, Activ::Rational
, Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryRequestParameters
, Activ::SInt
, Activ::TextArray
, Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryResponseParameters
, Activ::TextArray
, Activ::TextString
, Activ::ContentPlatform::ContentGatewayApi::Tick
, Activ::TextString
, Activ::Time
, Activ::ContentPlatform::ContentGatewayApi::DataPointAddress
, Activ::TRational
, Activ::UInt
, Activ::ContentPlatform::ContentGatewayApi::Period
, Activ::OpenServiceRequest
, Activ::OpenServiceResponse
, Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestParameters
, Activ::SystemMessageEndPointIdSet
, Activ::BaseTime
, Activ::ContentPlatform::ContentGatewayApi::TimeSeriesCookie
, Activ::UiPermissions
, Activ::IpAddress
, Activ::ContentPlatform::ContentGatewayApi::TimeSeriesResponseParametersTemplate< FIELD_SET_TYPE >
, Activ::Address
, Activ::IEndPoint::Stats
, Activ::ContentPlatform::Feed::CompressedMessageDefinitions::FieldHeaderBuilder
, Activ::ISyncEndPoint::Stats
, Activ::IHeap::Stats::RequestDistributionStats
, Activ::ContentPlatform::Feed::CompressedMessageDefinitions::FieldHeaderBuilder
, Activ::IHeap::Stats::BucketStats
, Activ::IHeap::Stats
, Activ::ContentPlatform::Feed::CompressedSymbol
, Activ::IProcess::Stats
, Activ::ISystem::SystemInfo
, Activ::ContentPlatform::Feed::CompressedUsEquityOptionSymbol
, Activ::ISystem::SystemInfo
, Activ::RequestId
, Activ::ContentPlatform::Feed::Symbol
, Activ::Subject
, Activ::SerializableObjectHelper< OBJECT_TYPE >
, Activ::ConsoleWindow::Coord
, Activ::SerializableSmartPointerHelper< POINTER_TYPE >
, Activ::SerializableRawPointerHelper< POINTER_TYPE >
, Activ::IniFileParser
, Activ::SerializableContainerHelper< std::vector< OBJECT_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >
, Activ::SerializableContainerHelper< std::list< OBJECT_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >
, Activ::ISerializableMessage
, Activ::SerializableContainerHelper< std::set< OBJECT_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >
, Activ::SerializableContainerHelper< std::map< KEY_TYPE, MAPPED_TYPE >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >
, Activ::SystemInfo
, Activ::SerializableContainerHelper< hash_map< KEY_TYPE, MAPPED_TYPE, HASH_FN >, COUNT_TYPE, MIN_LENGTH, MAX_LENGTH, OBJECT_HELPER >
, Activ::SerializableBuffer< LENGTH_TYPE, MIN_LENGTH, MAX_LENGTH >
  • SerializeBody()
: Activ::BinaryArray
, Activ::BinaryString
, Activ::Blob
, Activ::CrcBlob
, Activ::Date
, Activ::DateTime
, Activ::IFieldType
, Activ::Rational
, Activ::SInt
, Activ::TextArray
, Activ::TextString
, Activ::Time
, Activ::TRational
, Activ::UInt
  • SerializeLengthAndBody()
: Activ::BinaryArray
, Activ::BinaryString
, Activ::Blob
, Activ::CrcBlob
, Activ::Date
, Activ::DateTime
, Activ::IFieldType
, Activ::Rational
, Activ::SInt
, Activ::TextArray
, Activ::TextString
, Activ::Time
, Activ::TRational
, Activ::UInt
  • SerializeSpecification()
: Activ::Database::Database
, Activ::Database::FieldList
, Activ::Database::ITable
  • Service() : Activ::Service
  • ServiceAccessPoint() : Activ::ServiceAccessPoint
  • ServiceHandle() : Activ::ServiceHandle
  • ServiceId() : Activ::ServiceId
  • ServiceInstance() : Activ::ServiceInstance
  • ServiceSubject() : Activ::ServiceSubject
  • Set()
: Activ::IEvent
, Activ::ScatterBufferHelper
, Activ::ThreadSpecificDataBase< TYPE, DERIVED >
, Activ::Uuid
, Activ::Database::Key
, Activ::Database::Record
, Activ::BinaryArray
, Activ::BinaryString
, Activ::Blob
, Activ::CrcBlob
, Activ::Date
, Activ::DateTime
, Activ::Rational
, Activ::SInt
, Activ::TextArray
, Activ::TextString
, Activ::Time
, Activ::TRational
, Activ::UInt
, Activ::ServiceId
, Activ::Address
, Activ::RequestId
, Activ::Subject
, Activ::BitField< T, OFFSET_VALUE, LENGTH_VALUE >
, Activ::SerializableBuffer< LENGTH_TYPE, MIN_LENGTH, MAX_LENGTH >
  • SetAskPrice() : Activ::ContentPlatform::ContentGatewayApi::OptionBar
  • SetAttributes() : Activ::RequestId
  • SetBidPrice() : Activ::ContentPlatform::ContentGatewayApi::OptionBar
  • SetBufferSize()
: Activ::ConsoleWindow
, Activ::MessageBuilder
  • SetBuyerId() : Activ::ContentPlatform::ContentGatewayApi::Tick
  • SetClosePrice()
: Activ::ContentPlatform::ContentGatewayApi::HistoryBar
, Activ::ContentPlatform::ContentGatewayApi::IntradayBar
  • SetConditions() : Activ::ContentPlatform::ContentGatewayApi::Tick
  • SetCursorPosition() : Activ::ConsoleWindow
  • SetCursorVisibility() : Activ::ConsoleWindow
  • SetDate()
: Activ::ContentPlatform::ContentGatewayApi::HistoryBar
, Activ::ContentPlatform::ContentGatewayApi::IntradayBar
, Activ::ContentPlatform::ContentGatewayApi::OptionBar
, Activ::ContentPlatform::ContentGatewayApi::Tick
  • SetDateTime()
: Activ::ContentPlatform::ContentGatewayApi::IntradayBar
, Activ::ContentPlatform::ContentGatewayApi::Tick
  • SetDenominator()
: Activ::ContentPlatform::ContentGatewayApi::OptionBar
, Activ::Rational
, Activ::TRational
  • SetDestinationAddress() : Activ::HeapMessage
  • SetDisabledDateSet() : Activ::Timeband
  • SetDisplaySize() : Activ::ConsoleWindow
  • SetEnabledDateFlag() : Activ::Timeband
  • SetEnabledDaysString() : Activ::Timeband
  • SetEndPointId() : Activ::Address
  • SetEndTime() : Activ::Timeband
  • SetExchange() : Activ::ContentPlatform::ContentGatewayApi::Tick
  • SetExpirationDate() : Activ::ContentPlatform::ContentGatewayApi::OptionBar
  • SetField()
: Activ::ContentPlatform::ContentGatewayApi::FieldSet
, Activ::ContentPlatform::ContentGatewayApi::HistoryBar
, Activ::ContentPlatform::ContentGatewayApi::IntradayBar
, Activ::ContentPlatform::ContentGatewayApi::OptionBar
, Activ::ContentPlatform::ContentGatewayApi::Tick
, Activ::Database::FieldList
, Activ::Database::FieldListObject
  • SetFieldContents() : Activ::ContentPlatform::ContributionGatewayApi::PublishField
  • SetFieldRules() : Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions
  • SetFields() : Activ::Database::IIndex
  • SetFlag() : Activ::ContentPlatform::ContentGatewayApi::IntradayBar
  • SetHeap()
: Activ::Port
, Activ::RouterServiceApi::Tcp
  • SetHighPrice()
: Activ::ContentPlatform::ContentGatewayApi::HistoryBar
, Activ::ContentPlatform::ContentGatewayApi::IntradayBar
  • SetId() : Activ::Database::FieldListObject
  • SetIdentity() : Activ::Database::ITable
  • SetIndexFields()
: Activ::Database::ITable
, Activ::Database::Key
, Activ::Database::Record
  • SetIpAddress() : Activ::HeapMessage
  • SetKey()
: Activ::Des3Helper::Key
, Activ::DesHelper::Key
  • SetKeys() : Activ::Des3Helper::KeyBundle
  • SetLatestVersion() : Activ::ContentPlatform::Feed::TableTemplate
  • SetLength()
: Activ::MessageBuilder
, Activ::HeapMessage
, Activ::RequestId
  • SetLogHeader() : Activ::LoggerServiceApi
  • SetLowPrice()
: Activ::ContentPlatform::ContentGatewayApi::HistoryBar
, Activ::ContentPlatform::ContentGatewayApi::IntradayBar
  • SetMaxByteCount() : Activ::IEndPoint
  • SetMaxTxQueueSize() : Activ::RouterServiceApi::Tcp
  • SetMessageVersion() : Activ::MessageHandler
  • SetMode()
: Activ::Database::Database
, Activ::Database::ITable
  • SetMulticastLoopback()
: Activ::UdpComponent
, Activ::UdpSocket
, Activ::RouterServiceApi::Udp
  • SetMulticastTtl()
: Activ::RouterServiceApi::Udp
, Activ::UdpSocket
, Activ::UdpComponent
  • SetMulticastTxInterface()
: Activ::RouterServiceApi::Udp
, Activ::UdpComponent
, Activ::UdpSocket
  • SetName() : Activ::Thread
  • SetOffset()
: Activ::MessageValidator
, Activ::HeapMessage::ReadHelper
, Activ::HeapMessage::WriteHelper
  • SetOpenInterest()
: Activ::ContentPlatform::ContentGatewayApi::HistoryBar
, Activ::ContentPlatform::ContentGatewayApi::OptionBar
  • SetOpenPrice()
: Activ::ContentPlatform::ContentGatewayApi::HistoryBar
, Activ::ContentPlatform::ContentGatewayApi::IntradayBar
  • SetOutOfSequence() : Activ::ContentPlatform::ContentGatewayApi::Tick
  • SetPending() : Activ::IoCompletionManager::Overlapped
  • SetPortId() : Activ::Address
  • SetPosition() : Activ::File
  • SetPrice() : Activ::ContentPlatform::ContentGatewayApi::Tick
  • SetPriority() : Activ::Thread
  • SetProcessorAffinity()
: Activ::Process
, Activ::Thread
  • SetRequestDistributionLogging() : Activ::IHeap
  • SetRequestId() : Activ::HeapMessage
  • SetResponseAddress() : Activ::RequestId
  • SetReturnAddress() : Activ::HeapMessage
  • SetRuleSet() : Activ::ContentPlatform::ContributionGatewayApi::PublishSymbolRecordParameters::Field
  • SetRxBufferSize()
: Activ::RouterServiceApi::Udp
, Activ::IpSocket
, Activ::UdpComponent
  • SetSearchOrder() : Activ::Database::Database
  • SetSellerId() : Activ::ContentPlatform::ContentGatewayApi::Tick
  • SetSequence() : Activ::ContentPlatform::ContentGatewayApi::FieldSet
  • SetSize()
: Activ::ContentPlatform::ContentGatewayApi::Tick
, Activ::File
  • SetSocketOption() : Activ::IpSocket
  • SetSourceAddress() : Activ::HeapMessage
  • SetStartTime() : Activ::Timeband
  • SetState()
: Activ::IEndPoint
, Activ::IProcess
  • SetStatusCode() : Activ::HeapMessage
  • SetStrikePrice() : Activ::ContentPlatform::ContentGatewayApi::OptionBar
  • SetSubject() : Activ::HeapMessage
  • SetThreadPriority() : Activ::Thread
  • SetTick() : Activ::TRational
  • SetTickAndTrendOnPrevious() : Activ::TRational
  • SetTickCount() : Activ::ContentPlatform::ContentGatewayApi::IntradayBar
  • SetTickType() : Activ::ContentPlatform::ContentGatewayApi::Tick
  • SetTime()
: Activ::ContentPlatform::ContentGatewayApi::IntradayBar
, Activ::ContentPlatform::ContentGatewayApi::Tick
  • SetTimeout() : Activ::CurlFtpHelper
  • SetTimer() : Activ::TimerServiceApi
  • Settings()
: Activ::AgentApplication::Settings
, Activ::UdpSocket::Settings
, Activ::ManagedEndPoint::Settings
, Activ::ContentPlatform::ContentServerApi::ContentServerClient::Settings
, Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::Settings
, Activ::ThinApplication::Settings
, Activ::Timeband::Settings
, Activ::IpSocket::Settings
, Activ::TcpSocket::Settings
, Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::Settings
, Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::Settings
, Activ::Application::Settings
, Activ::IpManager::Settings
, Activ::ContentPlatform::Feed::TableTemplateList::Settings
, Activ::ISystem::Settings
  • SetTitle() : Activ::ConsoleWindow
  • SetToMiniBar()
: Activ::ContentPlatform::ContentGatewayApi::IntradayBar
, Activ::ContentPlatform::ContentGatewayApi::HistoryBar
  • SetTotalPrice()
: Activ::ContentPlatform::ContentGatewayApi::HistoryBar
, Activ::ContentPlatform::ContentGatewayApi::IntradayBar
  • SetTotalValue()
: Activ::ContentPlatform::ContentGatewayApi::HistoryBar
, Activ::ContentPlatform::ContentGatewayApi::IntradayBar
  • SetTotalVolume()
: Activ::ContentPlatform::ContentGatewayApi::IntradayBar
, Activ::ContentPlatform::ContentGatewayApi::HistoryBar
, Activ::ContentPlatform::ContentGatewayApi::OptionBar
, Activ::ContentPlatform::ContentGatewayApi::IntradayBar
  • SetTradeThroughExemptFlag() : Activ::ContentPlatform::ContentGatewayApi::Tick
  • SetTrendOnDay() : Activ::TRational
  • SetTrendOnPrevious() : Activ::TRational
  • SetTxBufferSize()
: Activ::UdpComponent
, Activ::RouterServiceApi::Udp
, Activ::IpSocket
  • SetType() : Activ::HeapMessage
  • SetUnderlyingPrice() : Activ::ContentPlatform::ContentGatewayApi::OptionBar
  • SetUnicastTtl()
: Activ::RouterServiceApi::Udp
, Activ::UdpComponent
, Activ::UdpSocket
  • SetUpdateId() : Activ::ContentPlatform::ContentGatewayApi::Tick
  • SetValue() : Activ::RegistryHelper
  • SharedObject() : Activ::SharedObject< T >
  • Shell() : Activ::Shell
  • ShouldApplyAddRule1()
: Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::TranslatorRuleSet
, Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ContentServerRuleSet
  • ShouldApplyAddRule2()
: Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::TranslatorRuleSet
, Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ContentServerRuleSet
  • ShouldApplyChangeRule()
: Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::TranslatorRuleSet
, Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ContentServerRuleSet
  • ShouldApplyTrending()
: Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ContentServerRuleSet
, Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::TranslatorRuleSet
  • ShouldConvert() : Activ::Database::TableSpecification
  • ShouldCreateMutex()
: Activ::Database::TableSpecification
, Activ::Database::DatabaseSpecification
  • ShouldCreateRecordFile() : Activ::Database::TableSpecification
  • ShouldTestHighLow() : Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::TranslatorRuleSet
  • ShouldTestOpen() : Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::TranslatorRuleSet
  • ShouldUpdateField()
: Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::TranslatorRuleSet
, Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ContentServerRuleSet
  • Shutdown()
: Activ::Application
, Activ::UdpSocket
  • ShutdownSocket() : Activ::IpSocket
  • ShutdownSubject() : Activ::ShutdownSubject
  • Singleton() : Activ::Singleton< T >
  • SInt() : Activ::SInt
  • SmtpHelper() : Activ::SmtpHelper
  • SocketStats() : Activ::RouterServiceApi::Tcp::SocketStats
  • SocketWrapper() : Activ::SocketWrapper
  • Specification()
: Activ::ContentPlatform::Feed::Index::Specification
, Activ::ContentPlatform::Feed::Field::Specification
, Activ::ContentPlatform::Feed::TableTemplate::Specification
  • SplitPath() : Activ::File
  • Start()
: Activ::Process
, Activ::TcpListener
, Activ::Thread
  • StartThread() : Activ::ManagedEndPoint
  • StateToString()
: Activ::TcpSocket
, Activ::UdpSocket
, Activ::IEndPoint
, Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient
, Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
, Activ::IProcess
, Activ::TcpListener
  • StaticCompletionHelper() : Activ::UiIo::StaticCompletionHelper
  • Stats()
: Activ::IpSocket::Stats
, Activ::TcpSocket::Stats
, Activ::SystemMonitor::Stats
, Activ::UdpSocket::Stats
  • StatusCodeException() : Activ::StatusCodeException
  • StatusCodeHelper() : Activ::StatusCodeHelper
  • StatusToString()
: Activ::ContentPlatform::ContentGatewayApi::ResponseBlock
, Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayResponseParameters
  • StepFirst() : Activ::Database::ITable
  • StepNext() : Activ::Database::ITable
  • Stop()
: Activ::TcpListener
, Activ::RouterServiceApi::Tcp
  • StringToNotificationType() : Activ::IEndPoint
  • StringToPriority() : Activ::Thread
  • Subject() : Activ::Subject
  • Subscribe() : Activ::PubSubServiceApi
  • SubscribeFeedParameters() : Activ::ContentPlatform::ContentGatewayApi::SubscribeFeedParameters
  • SubscribeParameters() : Activ::ContentPlatform::ContentGatewayApi::SubscribeParameters
  • SubscribeTableParameters() : Activ::ContentPlatform::ContentGatewayApi::SubscribeTableParameters
  • SubscribeToFeed() : Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
  • SubscribeToTable() : Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
  • Subtract()
: Activ::Rational
, Activ::Time
, Activ::DateTime
, Activ::UInt
, Activ::SInt
, Activ::Time
, Activ::DateTime
, Activ::Time
, Activ::DateTime
, Activ::Time
, Activ::Date
, Activ::DateTime
  • Suspend()
: Activ::MessageRateThrottler
, Activ::Thread
  • Switch()
: Activ::CommandLineParser
, Activ::Fiber
, Activ::CommandLineParser
  • SymbolDirectoryRequestParameters() : Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryRequestParameters
  • SymbolId() : Activ::ContentPlatform::ContentGatewayApi::SymbolId
  • SymbolIdCountRequestParameters() : Activ::ContentPlatform::ContentGatewayApi::SymbolIdCountRequestParameters
  • SymbolPatternHelper() : Activ::ContentPlatform::FeedApi::SymbolPatternHelper
  • SymbolRecordField() : Activ::ContentPlatform::Feed::SymbolRecordField
  • SymbolRecordFieldListBuilder() : Activ::ContentPlatform::Feed::SymbolRecordFieldListBuilder
  • SymbolRecordFieldListValidator() : Activ::ContentPlatform::Feed::SymbolRecordFieldListValidator
  • SymbolRecordMessageBuilder()
: Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::SymbolRecordMessageBuilder
, Activ::ContentPlatform::Feed::SymbolRecordMessageBuilder
  • SymbolRecordMessageHeaderValidator() : Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator
  • SymbolRecordMessageValidator() : Activ::ContentPlatform::Feed::SymbolRecordMessageValidator
  • SymbolRecordUpdate() : Activ::ContentPlatform::ContentServerApi::SymbolRecordUpdate
  • SymbolToString()
: Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator
, Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator
, Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator
  • SyncRequestId() : Activ::SyncRequestId
  • SystemException() : Activ::SystemException
  • SystemInfo()
: Activ::SystemInfo
, Activ::ISystem::SystemInfo
  • SystemMonitor() : Activ::SystemMonitor
Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- t -

  • TableNumberRequestParameters() : Activ::ContentPlatform::ContentGatewayApi::TableNumberRequestParameters
  • TableSpecification() : Activ::Database::TableSpecification
  • TableTemplate() : Activ::ContentPlatform::Feed::TableTemplate
  • TableTemplateAddition() : Activ::ContentPlatform::Feed::TableTemplateAddition
  • TableTemplateException() : Activ::ContentPlatform::Feed::TableTemplateException
  • TableTemplateField() : Activ::ContentPlatform::Feed::TableTemplateField
  • TableTemplateFieldListValidator() : Activ::ContentPlatform::Feed::TableTemplateFieldListValidator
  • TableTemplateIdToString()
: Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator
, Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator
, Activ::ContentPlatform::Feed::RecordMessageHeaderValidator
, Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator
  • TableTemplateIndex() : Activ::ContentPlatform::Feed::TableTemplateIndex
  • TableTemplateIndexListValidator() : Activ::ContentPlatform::Feed::TableTemplateIndexListValidator
  • TableTemplateList() : Activ::ContentPlatform::Feed::TableTemplateList
  • TableTemplateMessageValidator() : Activ::ContentPlatform::Feed::TableTemplateMessageValidator
  • TableTemplateNameToString()
: Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator
, Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator
, Activ::ContentPlatform::Feed::RecordMessageHeaderValidator
, Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator
  • TableTemplateSpecification() : Activ::ContentPlatform::Feed::TableTemplateList::TableTemplateSpecification
  • TcpListener() : Activ::TcpListener
  • TcpSocket() : Activ::TcpSocket
  • TextArray() : Activ::TextArray
  • TextString() : Activ::TextString
  • ThinApplication() : Activ::ThinApplication
  • Thread() : Activ::Thread
  • ThreadSpecificDataBase() : Activ::ThreadSpecificDataBase< TYPE, DERIVED >
  • Tick() : Activ::ContentPlatform::ContentGatewayApi::Tick
  • TickToString() : Activ::TRational
  • Time() : Activ::Time
  • Timeband() : Activ::Timeband
  • Timeout() : Activ::Timeout
  • TimeSeriesRequestParameters() : Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestParameters
  • TimeToString() : Activ::BaseTime
  • ToFormattedHeaderString() : Activ::Database::FieldSpecification
  • ToFormattedString() : Activ::Database::FieldSpecification
  • ToHexDumpString() : Activ::HeapMessage
  • ToLogString()
: Activ::Database::FieldList
, Activ::Database::FieldListObject
, Activ::Timeband
  • ToShortString() : Activ::ContentPlatform::ContentGatewayApi::Tick
  • ToStream() : Activ::Exception
  • ToString()
: Activ::ContentPlatform::Feed::UniversalFieldList
, Activ::ContentPlatform::Feed::TableTemplateList
, Activ::CrtException
, Activ::ServiceAccessPoint
, Activ::ContentPlatform::Feed::Rule
, Activ::ContentPlatform::Feed::Rule::VolumeFields
, Activ::ContentPlatform::Feed::Rule::PriceFields
, Activ::ContentPlatform::Feed::Rule::CloseFields
, Activ::ContentPlatform::Feed::Rule::OpenFields
, Activ::Rational
, Activ::ContentPlatform::Feed::Rule::HighFields
, Activ::Des3Helper::Key
, Activ::ContentPlatform::Feed::Field
, Activ::ContentPlatform::Feed::SymbolRecordMessageValidator
, Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator
, Activ::CrcBlob
, Activ::ContentPlatform::Feed::SymbolRecordField
, Activ::ContentPlatform::Feed::RecordMessageValidator
, Activ::Time
, Activ::TextString
, Activ::ContentPlatform::Feed::RecordFieldListValidator
, Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator
, Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator
, Activ::DesHelper::Key
, Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::RecordMessageBuilder
, Activ::ScopedAddress
, Activ::ContentPlatform::ContentGatewayApi::OptionBar
, Activ::IniFileParser::ParseException
, Activ::UInt
, Activ::ServiceId
, Activ::Address
, Activ::ContentPlatform::ContentGatewayApi::FieldSet
, Activ::ContentPlatform::ContentGatewayApi::HistoryBar
, Activ::TRational
, Activ::ContentPlatform::ContentGatewayApi::IntradayBar
, Activ::IpAddress
, Activ::Database::FieldList
, Activ::BaseTime
, Activ::BaseTime::Duration
, Activ::Blob
, Activ::Database::TableSpecification
, Activ::BinaryArray
, Activ::UiIo::Attribute
, Activ::ContentPlatform::ContentGatewayApi::Tick
, Activ::BinaryString
, Activ::IpException
, Activ::Uuid
, Activ::StatusCodeException
, Activ::Exception
, Activ::BaseException
, Activ::StatusCodeHelper
, Activ::Time
, Activ::IFieldType
, Activ::Subject
, Activ::ContentPlatform::Feed::Rule::LowFields
, Activ::ContentPlatform::Feed::Rule::CopyToFields
, Activ::TextArray
, Activ::ContentPlatform::Feed::SymbolRecordFieldListValidator
, Activ::SystemException
, Activ::ContentPlatform::Feed::RecordMessageHeaderValidator
, Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::SymbolRecordMessageBuilder
, Activ::TRational
, Activ::Date
, Activ::RequestId
, Activ::ContentPlatform::Feed::RecordKeyFieldListValidator
, Activ::SInt
, Activ::DateTime
, Activ::Rational
, Activ::Database::DatabaseSpecification
, Activ::Database::FieldListObject
, Activ::Database::IndexSpecification
, Activ::Database::FieldSpecification
, Activ::BinaryString
, Activ::OsException
, Activ::CrcBlob
, Activ::ContentPlatform::Feed::TableTemplateException
, Activ::DateTime
, Activ::BinaryArray
, Activ::UiPermissions
, Activ::ContentPlatform::Feed::TableTemplate
, Activ::Blob
, Activ::Database::DatabaseException
, Activ::Timeband
, Activ::Database::DatabaseSpecification::DatabaseTableSpecification
  • TRational() : Activ::TRational
  • TrendToString() : Activ::TRational
  • Try()
: Activ::IMutex
, Activ::DeferredScopedMutexLocker
  • TryFlush() : Activ::PostMessageHelper
  • TryPostMessages() : Activ::IEndPoint
  • TxOverlapped() : Activ::IpSocket::TxOverlapped
  • TypeToString() : Activ::LoggerDefinitions
Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- u -

  • UdpComponent() : Activ::UdpComponent
  • UdpSocket() : Activ::UdpSocket
  • UiAddAllOptions() : Activ::ContentPlatform::Feed::TableTemplateList
  • UiComponent() : Activ::UiComponent
  • UiDisplayAvailableUiComponentsByType() : Activ::UiMainComponent
  • UiDisplayTableTemplateFields() : Activ::ContentPlatform::Feed::TableTemplateList
  • UiDisplayTableTemplatesList() : Activ::ContentPlatform::Feed::TableTemplateList
  • UiDisplayUniversalFieldList() : Activ::ContentPlatform::Feed::TableTemplateList
  • UiMainComponent() : Activ::UiMainComponent
  • UiMenu() : Activ::UiMenu
  • UInt() : Activ::UInt
  • UiPermissions() : Activ::UiPermissions
  • UiReInitializeTableTemplateListFromHeaders() : Activ::ContentPlatform::Feed::TableTemplateList
  • UiReInitializeTableTemplateListFromPathList() : Activ::ContentPlatform::Feed::TableTemplateList
  • UiReInitializeTableTemplateListFromSettingsObject() : Activ::ContentPlatform::Feed::TableTemplateList
  • UndefinedFieldContentsToString()
: Activ::ContentPlatform::Feed::RecordFieldListValidator
, Activ::ContentPlatform::Feed::RecordKeyFieldListValidator
, Activ::ContentPlatform::Feed::SymbolRecordField
  • UndefineField()
: Activ::Database::FieldList
, Activ::Database::FieldListObject
  • UndefineOnResetToString() : Activ::ContentPlatform::Feed::TableTemplate
  • UniversalFieldHelper() : Activ::ContentPlatform::Feed::UniversalFieldHelper
  • UniversalFieldList() : Activ::ContentPlatform::Feed::UniversalFieldList
  • Unsubscribe()
: Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient
, Activ::PubSubServiceApi
, Activ::ScopedSubscription
  • Update()
: Activ::ContentPlatform::ContentGatewayApi::HistoryBar
, Activ::ContentPlatform::ContentGatewayApi::IntradayBar
  • UpdateIdToString()
: Activ::ContentPlatform::Feed::RecordMessageHeaderValidator
, Activ::ContentPlatform::Feed::CompressedMessageHeaderValidator
, Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderValidator
, Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderValidator
  • UtcTime() : Activ::UtcTime
  • Uuid() : Activ::Uuid
Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- v -

  • Validate()
: Activ::ContentPlatform::Feed::CompressedMessageDefinitions::FieldHeaderValidator
, Activ::Database::FieldSpecification
, Activ::Database::Key
, Activ::Database::IndexSpecification
, Activ::Database::Record
  • ValidateAsciiHexadecimalIntegral() : Activ::MessageValidator
  • ValidateAsciiHexadecimalIntegralCopy() : Activ::MessageValidator
  • ValidateBinaryIntegral() : Activ::MessageValidator
  • ValidateBinaryIntegralRange() : Activ::MessageValidator
  • ValidateBoolean() : Activ::MessageValidator
  • ValidateBytes() : Activ::MessageValidator
  • ValidateBytesCopy() : Activ::MessageValidator
  • ValidateCompressed() : Activ::ContentPlatform::Feed::CompressedMessage
  • ValidateCompressedCombinedQuote() : Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessage
  • ValidateOpenServiceRequest() : Activ::Service
  • ValidateOpenServiceResponse() : Activ::ServiceApi
  • ValidateSerializedLengthAndBody()
: Activ::BinaryArray
, Activ::BinaryString
, Activ::Blob
, Activ::CrcBlob
, Activ::Date
, Activ::DateTime
, Activ::IFieldType
, Activ::Rational
, Activ::SInt
, Activ::TextArray
, Activ::TextString
, Activ::Time
, Activ::TRational
, Activ::UInt
  • ValidateSignedAsciiIntegral() : Activ::MessageValidator
  • ValidateSignedAsciiIntegralCopy() : Activ::MessageValidator
  • ValidateSignedAsciiReal() : Activ::MessageValidator
  • ValidateSignedAsciiRealCopy() : Activ::MessageValidator
  • ValidateSignedBinaryIntegral() : Activ::MessageValidator
  • ValidateSignedBinaryIntegralCopy() : Activ::MessageValidator
  • ValidateString() : Activ::MessageValidator
  • ValidateStringCopy() : Activ::MessageValidator
  • ValidateUnsignedAsciiIntegral() : Activ::MessageValidator
  • ValidateUnsignedAsciiIntegralCopy() : Activ::MessageValidator
  • ValidateUnsignedAsciiReal() : Activ::MessageValidator
  • ValidateUnsignedAsciiRealCopy() : Activ::MessageValidator
  • ValidateUnsignedBinaryIntegral() : Activ::MessageValidator
  • ValidateUnsignedBinaryIntegralCopy() : Activ::MessageValidator
  • ValueStore() : Activ::CommandLineParserDetail::ValueStore< T >
  • VolumeFields() : Activ::ContentPlatform::Feed::Rule::VolumeFields
Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- w -

  • Wait()
: Activ::IEvent
, Activ::HandleManager< T >
  • WaitForCompletion()
: Activ::Thread
, Activ::Process
  • WaitForInput() : Activ::ConsoleWindow
  • WaitForState() : Activ::IProcess
  • WaitForThreadsToExit() : Activ::ManagedEndPoint
  • Walk() : Activ::DirectoryWalker
  • WasSuccessfulCompletion() : Activ::IoCompletionManager::Overlapped
  • Write()
: Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::SymbolRecordMessageBuilder
, Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::RecordMessageBuilder
, Activ::File
  • WriteAt() : Activ::ConsoleWindow
  • WriteHelper() : Activ::HeapMessage::WriteHelper
  • WsaBufHelper() : Activ::WsaBufHelper
Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions

  • ConstSectionIterator : Activ::IniFileParser::ConstKeyIterator
  • FieldList : Activ::Database::FieldList::ConstIterator
  • IniFileParser : Activ::IniFileParser::ConstSectionIterator
  • IoCompletionManager : Activ::IoCompletionManager::Overlapped
  • IpManager : Activ::IpSocket
  • operator!= : Activ::StatusCodeHelper
  • operator== : Activ::StatusCodeHelper
  • UiMainComponent : Activ::UiIo
  • UiMenu : Activ::UiIo
Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • m
  • n
  • o
  • p
  • r
  • s
  • t

- a -

  • AccessFlags : Activ::File
  • AddressSet : Activ::PubSubServiceApi
  • AddressSetList : Activ::PubSubServiceApi
  • Attribute : Activ::RequestId

- b -

  • Bitmap : Activ::UiPermissions
  • BucketInfoVector : Activ::IHeap
  • Buffer : Activ::ContentPlatform::ContentGatewayApi::FieldData

- c -

  • CompositeState : Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageDefinitions
  • CompressedNumeratorLength : Activ::ContentPlatform::Feed::CompressedMessageDefinitions
  • Condition : Activ::ScopedHelper< T, D >
  • ConstFieldIterator : Activ::ContentPlatform::Feed::RecordMessageValidator , Activ::ContentPlatform::Feed::TableTemplateMessageValidator
  • ConstIndexIterator : Activ::ContentPlatform::Feed::TableTemplateMessageValidator
  • ConstIterator : Activ::Database::FieldListObject , Activ::ContentPlatform::Feed::SymbolRecordMessageValidator
  • ConstKeyFieldIterator
: Activ::ContentPlatform::Feed::RecordMessageValidator
, Activ::ContentPlatform::ContentServerApi::RecordUpdate
, Activ::ContentPlatform::Feed::RecordMessageHeaderValidator

- d -

  • DatabaseTableSpecificationList : Activ::Database::DatabaseSpecification
  • DateSet : Activ::Timeband
  • DayOfWeek : Activ::BaseTime
  • Days : Activ::DateTime

- e -

  • EnabledDaysBitmap : Activ::Timeband
  • EventList : Activ::DirectoryWatchApi
  • EventTypeList : Activ::ContentPlatform::ContentGatewayApi::SubscribeParameters , Activ::ContentPlatform::ContentServerApi::ContentServerClient::UpdateFilter

- f -

  • FieldHeader : Activ::ContentPlatform::Feed::FieldHeaderDefinitions
  • FieldIdMap : Activ::Database::FieldList
  • FieldSetList : Activ::ContentPlatform::ContentGatewayApi::TimeSeriesResponseParametersTemplate< FIELD_SET_TYPE >
  • FieldSpecificationList : Activ::ContentPlatform::Feed::TableTemplate
  • Flags
: Activ::ContentPlatform::Feed::RecordMessageHeaderDefinitions
, Activ::ContentPlatform::Feed::CombinedQuoteMessageHeaderDefinitions
, Activ::ContentPlatform::ContributionGatewayApi::PermissionInfo
, Activ::ContentPlatform::ContributionGatewayApi::PublishRecordBaseParameters
, Activ::ContentPlatform::ContentGatewayApi::ContentGatewayInfo
, Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestParameters
, Activ::ContentPlatform::ContentGatewayApi::DataPointAddress
, Activ::ContentPlatform::ContentGatewayApi::SymbolResponse
, Activ::ContentPlatform::ContentGatewayApi::RecordUpdate
, Activ::ContentPlatform::ContentGatewayApi::ResponseBlock
, Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters
, Activ::ContentPlatform::ContentGatewayApi::RequestBlock
, Activ::ContentPlatform::ContentGatewayApi::NewsUpdate
, Activ::ContentPlatform::ContentGatewayApi::NewsRequestParameters
, Activ::IEvent
, Activ::ConsoleWindow
, Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions

- g -

  • GlobalOptionFunction : Activ::UiMenu

- h -

  • Header : Activ::ContentPlatform::Feed::CompressedMessageDefinitions
  • Hours : Activ::DateTime

- i -

  • Id
: Activ::Process
, Activ::Thread
, Activ::Database::FieldSpecification
  • Identity : Activ::Database::ITable
  • InterfaceInfoList : Activ::IpManager

- k -

  • KeyField : Activ::ContentPlatform::ContentServerApi::RecordUpdate
  • KeyFieldList : Activ::ContentPlatform::ContentServerApi::RecordUpdate

- m -

  • MessageHeader : Activ::ContentPlatform::Feed::MessageHeaderDefinitions
  • MessageVersion : Activ::MessageHandler
  • Milliseconds : Activ::DateTime
  • Minutes : Activ::DateTime

- n -

  • Number : Activ::Database::IndexSpecification

- o -

  • ObjectType : Activ::SerializableSmartPointerHelper< POINTER_TYPE >

- p -

  • Parameter : Activ::Url
  • ParameterList : Activ::Url
  • PartialBitUpdateList : Activ::ContentPlatform::Feed::SymbolRecordField
  • PartialByteUpdateList : Activ::ContentPlatform::Feed::SymbolRecordField
  • PermissionIdInfoMap : Activ::ContentPlatform::Feed::PermissionInfo
  • PortIdSet : Activ::ManagedEndPoint
  • ProcessorList : Activ::Thread , Activ::Process
  • Properties
: Activ::Database::IndexSpecification::Field
, Activ::Database::IndexSpecification
, Activ::Database::FieldSpecification
, Activ::Database::DatabaseSpecification
, Activ::Database::TableSpecification

- r -

  • RequestFlags : Activ::ContentPlatform::ContentGatewayApi::PatternMatchRequestParameters , Activ::ContentPlatform::ContentGatewayApi::PatternMatchListRequestParameters
  • RequestParameters : Activ::ContentPlatform::ContributionGatewayApi::PublishRequestHelper< MESSAGE_TYPE_VALUE, REQUEST_PARAMETERS, RESPONSE_PARAMETERS > , Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestHelper< MESSAGE_TYPE_VALUE, REQUEST_PARAMETERS >
  • ResponseParameters : Activ::ContentPlatform::ContributionGatewayApi::PublishRequestHelper< MESSAGE_TYPE_VALUE, REQUEST_PARAMETERS, RESPONSE_PARAMETERS > , Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestHelper< MESSAGE_TYPE_VALUE, REQUEST_PARAMETERS >
  • Rules : Activ::ContentPlatform::FeedApi::FieldListValidator::Field

- s -

  • Seconds : Activ::DateTime
  • SendId : Activ::RequestId
  • SerializedTrend : Activ::TRational::SerializedTrendDefinitions
  • ShareFlags : Activ::File
  • Status : Activ::ContentPlatform::ContentGatewayApi::ResponseBlock , Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayResponseParameters
  • StringLength : Activ::MessageHandler
  • SubjectLength : Activ::Subject
  • SubscriptionMap : Activ::PubSubServiceApi
  • Symbol : Activ::ContentPlatform::ContentGatewayApi::SymbolId
  • SymbolPatternList : Activ::ContentPlatform::ContentServerApi::ContentServerClient::UpdateFilter

- t -

  • TableId : Activ::Database::DatabaseSpecification
  • TableNumberList : Activ::ContentPlatform::ContentServerApi::ContentServerClient::UpdateFilter
Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • c
  • d
  • e
  • f
  • g
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- a -

  • ACCESS_FLAG_READ : Activ::File
  • ACCESS_FLAG_WRITE : Activ::File
  • anonymousName : Activ::Port
Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • c
  • d
  • e
  • f
  • g
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- m -

  • m_acceptPosted : Activ::TcpSocket::Stats
  • m_add1CumulativeValue : Activ::ContentPlatform::Feed::Rule::VolumeFields
  • m_add1Price : Activ::ContentPlatform::Feed::Rule::VolumeFields
  • m_add1Volume : Activ::ContentPlatform::Feed::Rule::VolumeFields
  • m_add2CumulativeValue : Activ::ContentPlatform::Feed::Rule::VolumeFields
  • m_add2Price : Activ::ContentPlatform::Feed::Rule::VolumeFields
  • m_add2Volume : Activ::ContentPlatform::Feed::Rule::VolumeFields
  • m_addressLength : Activ::IpAddress
  • m_agentScope : Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::ConnectParameters , Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::ConnectParameters
  • m_amfFieldIndex : Activ::ContentPlatform::Feed::Field::Specification , Activ::ContentPlatform::Feed::TableTemplate::FieldSpecification
  • m_amfRecordSize : Activ::ContentPlatform::Feed::TableTemplate::Specification
  • m_amfRowIndex : Activ::ContentPlatform::Feed::Field::Specification , Activ::ContentPlatform::Feed::TableTemplate::FieldSpecification
  • m_amfRowOffset : Activ::ContentPlatform::Feed::Field::Specification , Activ::ContentPlatform::Feed::TableTemplate::FieldSpecification
  • m_amfTableId : Activ::ContentPlatform::Feed::TableTemplate::Specification
  • m_applicationHeapBucketInfo : Activ::ThinApplication::Settings
  • m_attributeQuery : Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::ConnectParameters , Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::ConnectParameters
  • m_attributes : Activ::ServiceInstance
  • m_averageCpuUsage : Activ::SystemMonitor::Stats::ProcessInfo , Activ::SystemMonitor::Stats
  • m_bccAddressList : Activ::SmtpHelper::Email
  • m_bitsPerSecond : Activ::IpManager::InterfaceInfo
  • m_blockSize : Activ::IHeap::BucketInfo
  • m_boostVersion : Activ::SystemInfo
  • m_bucketStatsVector : Activ::IHeap::Stats
  • m_buffer : Activ::ContentPlatform::ContentGatewayApi::FieldData
  • m_bufferSize : Activ::Database::FieldListObject
  • m_buildConfiguration
: Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::ApiInfo
, Activ::ContentPlatform::ContentServerApi::ContentServerClient::ApiInfo
, Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::ApiInfo
, Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::ApiInfo
  • m_buildDateTime
: Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::ApiInfo
, Activ::ContentPlatform::ContentServerApi::ContentServerClient::ApiInfo
, Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::ApiInfo
, Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::ApiInfo
  • m_buyerId : Activ::ContentPlatform::ContentGatewayApi::Tick
  • m_byteCount : Activ::IEndPoint::Stats
  • m_byteCountDailyHigh : Activ::IEndPoint::Stats
  • m_byteCountHigh : Activ::IEndPoint::Stats
  • m_byteCountLastHigh : Activ::IEndPoint::Stats
  • m_cachedFieldIdList : Activ::Database::IndexSpecification
  • m_cacheSize : Activ::Database::TableSpecification
  • m_ccAddressList : Activ::SmtpHelper::Email
  • m_closeFields : Activ::ContentPlatform::Feed::Rule
  • m_closeOnTxCompletion : Activ::IpSocket::Stats , Activ::IpSocket
  • m_closePosted : Activ::IpSocket::Stats , Activ::IpSocket
  • m_codeIdentifier
: Activ::ContentPlatform::ContentGatewayApi::RelationshipInfo
, Activ::ContentPlatform::Feed::Field::Specification
, Activ::ContentPlatform::Feed::TableTemplate::Specification
, Activ::ContentPlatform::Feed::TableTemplateList::TableTemplateSpecification
, Activ::ContentPlatform::Feed::EntityTypeHelper
, Activ::ContentPlatform::Feed::EventTypeHelper
, Activ::ContentPlatform::Feed::PermissionIdHelper
, Activ::ContentPlatform::Feed::RelationshipIdHelper
, Activ::ContentPlatform::Feed::UniversalFieldHelper
  • m_columnSpacing : Activ::UiIo::Columnizer
  • m_compositeAskState : Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessage
  • m_compositeBidState : Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessage
  • m_compositeUpdateId : Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessage , Activ::ContentPlatform::Feed::CompressedMessage
  • m_computerName : Activ::SystemInfo
  • m_condition
: Activ::ContentPlatform::Feed::Rule::CopyToFields
, Activ::ContentPlatform::Feed::Rule::HighFields
, Activ::ContentPlatform::Feed::Rule::LowFields
, Activ::ContentPlatform::Feed::Rule::OpenFields
, Activ::ContentPlatform::Feed::Rule::CloseFields
, Activ::ContentPlatform::Feed::Rule
  • m_conditions : Activ::ContentPlatform::ContentGatewayApi::Tick
  • m_connectPosted : Activ::TcpSocket::Stats
  • m_context : Activ::ContentPlatform::ContentGatewayApi::RelationshipInfo
  • m_contextSwitchRate : Activ::SystemMonitor::Stats
  • m_copyIfUndefined : Activ::ContentPlatform::Feed::CopyOnReset
  • m_copyToFields : Activ::ContentPlatform::Feed::Rule
  • m_count
: Activ::ContentPlatform::ContentGatewayApi::Period
, Activ::ContentPlatform::Feed::Rule::PriceFields
, Activ::IHeap::Stats::RequestDistributionStats
  • m_cpuUsageList : Activ::SystemMonitor::Stats
  • m_createMutex : Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::Settings , Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::Settings
  • m_createSystemLog : Activ::AgentApplication::Settings
  • m_creatorProcessId : Activ::IEndPoint::Stats
  • m_cumulativePrice : Activ::ContentPlatform::Feed::Rule::PriceFields
  • m_currentVersion : Activ::OpenServiceRequest
  • m_databaseTableSpecificationList : Activ::Database::DatabaseSpecification
  • m_dataLength : Activ::ScatterBufferHelper::ScatterBuffer , Activ::Database::FieldList
  • m_dataPointAddress : Activ::ContentPlatform::ContentGatewayApi::Period
  • m_date
: Activ::ContentPlatform::Feed::Rule::CopyToFields
, Activ::ContentPlatform::Feed::Rule::HighFields
, Activ::ContentPlatform::Feed::Rule::LowFields
, Activ::ContentPlatform::Feed::Rule::CloseFields
, Activ::ContentPlatform::Feed::Rule
  • m_dateTime : Activ::ContentPlatform::ContentGatewayApi::Tick , Activ::ContentPlatform::ContentGatewayApi::Period
  • m_defaultBuffer : Activ::Database::FieldListObject
  • m_defaultRuleSet : Activ::ContentPlatform::ContributionGatewayApi::PublishSymbolRecordParameters
  • m_defaultValue : Activ::CommandLineParserDetail::DefaultDescription< T >
  • m_delayPeriod : Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestParameters , Activ::ContentPlatform::Feed::PermissionLevelData
  • m_description
: Activ::ContentPlatform::Feed::Field::Specification
, Activ::ContentPlatform::Feed::UniversalFieldHelper
, Activ::CommandLineParserDetail::Description< T >
  • m_directory : Activ::FileInfo
  • m_directoryServiceSettings : Activ::AgentApplication::Settings
  • m_disabledDateSet : Activ::Timeband::Settings
  • m_diskInfoList : Activ::SystemMonitor::Stats
  • m_diskName : Activ::SystemMonitor::Stats::DiskInfo
  • m_distributionVector : Activ::IHeap::Stats
  • m_enableCtrlHandler : Activ::Application::Settings
  • m_enabledDateFlag : Activ::Timeband::Settings
  • m_enabledDaysBitmap : Activ::Timeband::Settings
  • m_enableUiService : Activ::AgentApplication::Settings
  • m_enableWindowsOverlappedOperations : Activ::IpManager::Settings
  • m_endDate : Activ::ContentPlatform::ContentGatewayApi::NewsRequestParameters
  • m_endPointIdSet : Activ::SystemMessageEndPointIdSet
  • m_endTime : Activ::Timeband::Settings
  • m_entityType : Activ::ContentPlatform::ContentGatewayApi::SymbolResponse , Activ::ContentPlatform::Feed::EntityTypeHelper
  • m_entityTypeList : Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryRequestParameters
  • m_error
: Activ::ContentPlatform::Feed::Rule::LowFields
, Activ::ContentPlatform::Feed::Rule::OpenFields
, Activ::ContentPlatform::Feed::Rule::CloseFields
, Activ::ContentPlatform::Feed::Rule::PriceFields
, Activ::ContentPlatform::Feed::Rule::VolumeFields
, Activ::ContentPlatform::Feed::Rule
, Activ::ContentPlatform::Feed::Rule::CopyToFields
, Activ::ContentPlatform::Feed::Rule::HighFields
  • m_errorCode : Activ::Exception
  • m_eventType
: Activ::ContentPlatform::ContentGatewayApi::RecordUpdate
, Activ::ContentPlatform::Feed::EventTypeHelper
, Activ::DirectoryWatchApi::Event
  • m_eventTypeList : Activ::ContentPlatform::ContentGatewayApi::SubscribeParameters , Activ::ContentPlatform::ContentServerApi::ContentServerClient::UpdateFilter
  • m_exceptionHandlerType : Activ::Application::Settings
  • m_exchange
: Activ::ContentPlatform::ContentGatewayApi::Tick
, Activ::ContentPlatform::Feed::Rule::CopyToFields
, Activ::ContentPlatform::Feed::Rule::HighFields
, Activ::ContentPlatform::Feed::Rule::LowFields
, Activ::ContentPlatform::Feed::Rule::OpenFields
, Activ::ContentPlatform::Feed::Rule::CloseFields
, Activ::ContentPlatform::Feed::Rule
  • m_extendedUiShutdown : Activ::AgentApplication::Settings
  • m_failoverSeconds : Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::ConnectParameters , Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::ConnectParameters
  • m_feedSubscriptionCount : Activ::ContentPlatform::ContentGatewayApi::SubscriptionInfo
  • m_fieldData
: Activ::ContentPlatform::ContentGatewayApi::NewsStory
, Activ::ContentPlatform::ContentGatewayApi::ResponseBlock
, Activ::ContentPlatform::ContentGatewayApi::RecordUpdate
  • m_fieldErrorList : Activ::ContentPlatform::ContributionGatewayApi::PublishRecordResponseParameters
  • m_fieldFilterType : Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestParameters
  • m_fieldId
: Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryRequestParameters
, Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryResponseParameters
, Activ::ContentPlatform::ContributionGatewayApi::PublishField
, Activ::ContentPlatform::FeedApi::FieldListValidator::Field
, Activ::ContentPlatform::Feed::CompressedMessageDefinitions::FieldSpecification
, Activ::ContentPlatform::Feed::IndexSpecification::Field
, Activ::ContentPlatform::Feed::UniversalFieldHelper
, Activ::Database::IndexSpecification::Field
  • m_fieldIdList
: Activ::ContentPlatform::ContentGatewayApi::NewsRequestParameters
, Activ::ContentPlatform::ContentGatewayApi::RequestBlock
, Activ::ContentPlatform::Feed::PermissionInfo::PermissionIdInfo
  • m_fieldIdMap : Activ::Database::FieldList
  • m_fieldList
: Activ::ContentPlatform::ContributionGatewayApi::PublishSymbolRecordParameters
, Activ::ContentPlatform::ContributionGatewayApi::PublishRecordParameters
, Activ::Database::FieldList
  • m_fieldNoList : Activ::Database::FieldList
  • m_fieldSpecificationList
: Activ::ContentPlatform::Feed::TableTemplate::Specification
, Activ::ContentPlatform::Feed::TableTemplateList::TableTemplateSpecification
, Activ::Database::TableSpecification
  • m_fieldStatus : Activ::ContentPlatform::FeedApi::FieldListValidator::Field
  • m_file : Activ::Exception
  • m_fileTime : Activ::FileInfo
  • m_filterType : Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryRequestParameters
  • m_firstFailLocalDateTime : Activ::IHeap::Stats
  • m_firstRunFails : Activ::IHeap::Stats::BucketStats
  • m_flags
: Activ::ContentPlatform::ContentGatewayApi::NewsRequestParameters
, Activ::ContentPlatform::ContentGatewayApi::NewsUpdate
, Activ::ContentPlatform::ContentGatewayApi::RequestBlock
, Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters
, Activ::ContentPlatform::ContentGatewayApi::ResponseBlock
, Activ::ContentPlatform::ContentGatewayApi::RecordUpdate
, Activ::ContentPlatform::ContentGatewayApi::SymbolResponse
, Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestParameters
, Activ::ContentPlatform::ContentGatewayApi::ContentGatewayInfo
  • m_freeMemory : Activ::SystemInfo
  • m_freeMemoryPercent : Activ::SystemMonitor::Stats
  • m_fromAddress : Activ::IpSocket , Activ::SmtpHelper::Email
  • m_function : Activ::Exception
  • m_handle : Activ::IpSocket
  • m_hasMutex : Activ::IEndPoint::Stats
  • m_heapBucketInfoVector : Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::Settings , Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::Settings
  • m_hexDump : Activ::HeapMessage::Stats
  • m_highestThreadCpuUsage : Activ::SystemMonitor::Stats::ProcessInfo
  • m_highestThreadCpuUsageId : Activ::SystemMonitor::Stats::ProcessInfo
  • m_highestVersion : Activ::OpenServiceRequest
  • m_highFields : Activ::ContentPlatform::Feed::Rule
  • m_id
: Activ::ContentPlatform::Feed::Field::Specification
, Activ::ContentPlatform::Feed::Index::IndexFieldSpecification
, Activ::ContentPlatform::Feed::TableTemplate::FieldSpecification
, Activ::ContentPlatform::Feed::TableTemplate::Specification
, Activ::Database::FieldListObject
, Activ::Database::FieldSpecification
, Activ::IProcess::Stats
  • m_idealBucketFails : Activ::IHeap::Stats
  • m_identity : Activ::Database::ITable
  • m_indexFieldSpecificationList : Activ::ContentPlatform::Feed::Index::Specification , Activ::Database::IndexSpecification
  • m_indexNumber : Activ::ContentPlatform::ContributionGatewayApi::PublishRecordParameters
  • m_indexSpecificationList
: Activ::ContentPlatform::Feed::TableTemplate::Specification
, Activ::ContentPlatform::Feed::TableTemplateList::TableTemplateSpecification
, Activ::Database::DatabaseSpecification::DatabaseTableSpecification
  • m_infoString : Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::ConnectParameters , Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::ConnectParameters
  • m_iniFileName : Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::Settings
  • m_initialMaxRecords : Activ::Database::TableSpecification
  • m_initialPortListSize : Activ::ManagedEndPoint::Settings
  • m_inTxQueueBytes : Activ::RouterServiceApi::Tcp::SocketStats
  • m_inTxQueueHighBytes : Activ::RouterServiceApi::Tcp::SocketStats
  • m_inTxQueueHighMessages : Activ::RouterServiceApi::Tcp::SocketStats
  • m_inTxQueueMessages : Activ::RouterServiceApi::Tcp::SocketStats
  • m_ipAddressList : Activ::IpManager::InterfaceInfo
  • m_ipManager : Activ::IpSocket
  • m_isAmfField : Activ::ContentPlatform::Feed::Field::Specification , Activ::ContentPlatform::Feed::TableTemplate::FieldSpecification
  • m_isAmfTable : Activ::ContentPlatform::Feed::TableTemplate::Specification
  • m_isComposite : Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessage , Activ::ContentPlatform::Feed::CompressedMessage
  • m_isCompositeAsk : Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessage
  • m_isCompositeBid : Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessage
  • m_isDelete : Activ::ContentPlatform::Feed::CompressedMessage
  • m_isInitialized : Activ::Database::FieldListObject , Activ::IFieldType
  • m_isLatestVersion : Activ::ContentPlatform::Feed::TableTemplate::Specification , Activ::ContentPlatform::Feed::TableTemplateList::TableTemplateSpecification
  • m_isManaged : Activ::Database::TableSpecification
  • m_isSizeField : Activ::ContentPlatform::Feed::CompressedMessageDefinitions::FieldSpecification
  • m_key1 : Activ::Des3Helper::KeyBundle
  • m_key2 : Activ::Des3Helper::KeyBundle
  • m_key3 : Activ::Des3Helper::KeyBundle
  • m_keyFieldList : Activ::ContentPlatform::ContributionGatewayApi::PublishRecordParameters
  • m_lastFailLocalDateTime : Activ::IHeap::Stats
  • m_licenseServiceSettings : Activ::AgentApplication::Settings
  • m_line : Activ::Exception
  • m_localAddress : Activ::IpSocket::Stats , Activ::IpSocket
  • m_location : Activ::Url
  • m_loggerServiceSettings : Activ::AgentApplication::Settings
  • m_logonFlags : Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::ConnectParameters
  • m_lowFields : Activ::ContentPlatform::Feed::Rule
  • m_lowFreeBlocks : Activ::IHeap::Stats::BucketStats
  • m_managedEndPointSettings : Activ::Application::Settings
  • m_matchData : Activ::ContentPlatform::ContentGatewayApi::SymbolResponse
  • m_matchType : Activ::ContentPlatform::ContentGatewayApi::MatchRequestParameters , Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryRequestParameters
  • m_maxFieldSets : Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestParameters
  • m_maxLength
: Activ::ContentPlatform::Feed::Field::Specification
, Activ::ContentPlatform::Feed::TableTemplate::FieldSpecification
, Activ::ContentPlatform::Feed::UniversalFieldHelper
, Activ::Database::FieldSpecification
  • m_maxRecordsPerResponse : Activ::ContentPlatform::ContentGatewayApi::NewsRequestParameters
  • m_maxRequestSize : Activ::IHeap::Stats
  • m_maxResponseBlocks : Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters
  • m_maxSize : Activ::IHeap::Stats::RequestDistributionStats
  • m_maxThreads : Activ::ManagedEndPoint::Settings
  • m_memoryModel : Activ::ISystem::Settings , Activ::ISystem::SystemInfo
  • m_memoryUsage : Activ::IHeap::Stats
  • m_messageCount : Activ::IEndPoint::Stats
  • m_messageCountDailyHigh : Activ::IEndPoint::Stats
  • m_messageCountHigh : Activ::IEndPoint::Stats
  • m_messageCountLastHigh : Activ::IEndPoint::Stats
  • m_messageRate : Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::Settings
  • m_messageValidator : Activ::ContentPlatform::ContentGatewayApi::FieldListValidator
  • m_messageVersion : Activ::ContentPlatform::ContentGatewayApi::FieldData
  • m_middlewareDate : Activ::SystemInfo
  • m_middlewareVersion : Activ::SystemInfo
  • m_middlewareVersionValue : Activ::SystemInfo
  • m_minFreePortIdListSize : Activ::ManagedEndPoint::Settings
  • m_minimumTimerResolution : Activ::ISystem::Settings
  • m_minSize : Activ::IHeap::Stats::RequestDistributionStats
  • m_mode : Activ::Database::ITable
  • m_monitorServiceSettings : Activ::AgentApplication::Settings
  • m_mutexContentionCount
: Activ::RouterServiceApi::Tcp::SocketStats
, Activ::IpSocket::Stats
, Activ::IEndPoint::Stats
, Activ::IHeap::Stats
  • m_name
: Activ::ContentPlatform::ContentGatewayApi::RelationshipInfo
, Activ::ContentPlatform::ContentServerApi::ContentServerClient::MessageStats
, Activ::ContentPlatform::ContentServerApi::ContentServerClient::UpdateFilterMap
, Activ::ContentPlatform::Feed::PermissionInfo::PermissionIdInfo
, Activ::ContentPlatform::Feed::Field::Specification
, Activ::ContentPlatform::Feed::Index::Specification
, Activ::ContentPlatform::Feed::TableTemplate::Specification
, Activ::ContentPlatform::Feed::TableTemplateList::TableTemplateSpecification
, Activ::ContentPlatform::Feed::EntityTypeHelper
, Activ::ContentPlatform::Feed::EventTypeHelper
, Activ::ContentPlatform::Feed::PermissionIdHelper
, Activ::ContentPlatform::Feed::RelationshipIdHelper
, Activ::ContentPlatform::Feed::UniversalFieldHelper
, Activ::CommandLineParserDetail::Description< T >
, Activ::SystemMonitor::Stats::ProcessInfo
, Activ::Database::DatabaseSpecification
, Activ::Database::FieldSpecification
, Activ::Database::IndexSpecification
, Activ::Database::TableSpecification
, Activ::IProcess::Stats
, Activ::FileInfo
  • m_netChange : Activ::ContentPlatform::Feed::Rule::PriceFields
  • m_newsStory : Activ::ContentPlatform::ContentGatewayApi::NewsUpdate
  • m_newsSubscriptionMap : Activ::ContentPlatform::ContentGatewayApi::SubscriptionInfo
  • m_nFields : Activ::Database::FieldList
  • m_nGrowRecords : Activ::Database::TableSpecification
  • m_notificationType : Activ::IEndPoint::Stats , Activ::ManagedEndPoint::Settings
  • m_notifier : Activ::CommandLineParserDetail::Description< T >
  • m_number
: Activ::ContentPlatform::Feed::Index::Specification
, Activ::ContentPlatform::Feed::TableTemplateList::TableTemplateSpecification
, Activ::Database::IndexSpecification
  • m_numberOfColumns : Activ::UiIo::Columnizer
  • m_numberOfIoThreads : Activ::IpManager::Settings
  • m_numberOfLines : Activ::UiIo::Columnizer
  • m_numberOfProcessorCores : Activ::SystemInfo
  • m_numberOfProcessorPackages : Activ::SystemInfo
  • m_numberOfProcessorThreads : Activ::SystemInfo
  • m_numberOfRecords
: Activ::ContentPlatform::ContentGatewayApi::NewsRequestParameters
, Activ::ContentPlatform::ContentGatewayApi::TableNumberRequestParameters
, Activ::ContentPlatform::ContentGatewayApi::SymbolIdCountRequestParameters
  • m_numBlocks : Activ::IHeap::BucketInfo
  • m_numFreeBlocks : Activ::IHeap::Stats::BucketStats
  • m_offset : Activ::IniFileParser::ParseException , Activ::Database::FieldSpecification
  • m_openFields : Activ::ContentPlatform::Feed::Rule
  • m_osId : Activ::IProcess::Stats
  • m_osName : Activ::SystemInfo
  • m_outSequence : Activ::ContentPlatform::ContentGatewayApi::Tick
  • m_pagesInOutRate : Activ::SystemMonitor::Stats
  • m_parameterList : Activ::Url
  • m_parentService : Activ::ChildService< T >
  • m_password
: Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::ConnectParameters
, Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::ConnectParameters
, Activ::IFtpHelper
  • m_path : Activ::DirectoryWatchApi::Event , Activ::Url
  • m_pathList : Activ::ContentPlatform::Feed::TableTemplateList::Settings
  • m_pData : Activ::ScatterBufferHelper::ScatterBuffer , Activ::Database::FieldListObject
  • m_peakCpuUsage : Activ::SystemMonitor::Stats
  • m_percentChange : Activ::ContentPlatform::Feed::Rule::PriceFields
  • m_periodList : Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestParameters
  • m_periodType : Activ::ContentPlatform::ContentGatewayApi::Period
  • m_permissionId
: Activ::ContentPlatform::Feed::PermissionIdHelper
, Activ::ContentPlatform::ContentGatewayApi::ResponseBlock
, Activ::ContentPlatform::ContentGatewayApi::RecordUpdate
, Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessage
, Activ::ContentPlatform::Feed::CompressedMessage
  • m_permissionIdList : Activ::ContentPlatform::ContentGatewayApi::NewsStory , Activ::ContentPlatform::ContributionGatewayApi::PermissionInfo
  • m_permissionLevel
: Activ::ContentPlatform::ContentGatewayApi::SubscribeFeedParameters
, Activ::ContentPlatform::ContentGatewayApi::NewsRequestParameters
, Activ::ContentPlatform::ContentGatewayApi::SubscribeTableParameters
, Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters
, Activ::ContentPlatform::ContentGatewayApi::ResponseBlock
, Activ::ContentPlatform::ContentGatewayApi::RecordUpdate
  • m_permissionLevelData : Activ::ContentPlatform::ContentGatewayApi::ResponseBlock , Activ::ContentPlatform::ContentGatewayApi::RecordUpdate
  • m_permissionLevelInfo : Activ::ContentPlatform::Feed::PermissionInfo
  • m_permissionLevelList : Activ::ContentPlatform::ContentGatewayApi::ContentGatewayInfo
  • m_pFieldList : Activ::Database::FieldListObject
  • m_pFtpHelper : Activ::FtpHelper
  • m_pHeap : Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::Settings , Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::Settings
  • m_physicalMemory : Activ::SystemInfo
  • m_pIFieldType : Activ::ContentPlatform::FeedApi::FieldListValidator::Field
  • m_platformType : Activ::SystemInfo
  • m_pMutex : Activ::IpSocket
  • m_policy : Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::ConnectParameters , Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::ConnectParameters
  • m_port : Activ::IFtpHelper
  • m_previousDayChange : Activ::ContentPlatform::Feed::Rule::PriceFields
  • m_previousDayTrend : Activ::ContentPlatform::Feed::Rule
  • m_price : Activ::ContentPlatform::ContentGatewayApi::Tick
  • m_priceFields : Activ::ContentPlatform::Feed::Rule
  • m_processInfoMap : Activ::SystemMonitor::Stats
  • m_processorAffinityList : Activ::ISystem::Settings
  • m_processorInfoList : Activ::SystemInfo
  • m_processStartupIniFile : Activ::AgentApplication::Settings
  • m_processVersion : Activ::ISystem::Settings
  • m_properties
: Activ::Database::FieldSpecification
, Activ::ContentPlatform::Feed::Index::Specification
, Activ::ContentPlatform::Feed::IndexSpecification::Field
, Activ::Database::DatabaseSpecification
, Activ::Database::IndexSpecification::Field
, Activ::Database::IndexSpecification
, Activ::Database::TableSpecification
  • m_protocol : Activ::Url , Activ::IpAddress
  • m_pTable : Activ::Database::FieldListObject
  • m_pTableTemplate
: Activ::ContentPlatform::Feed::Rule::HighFields
, Activ::ContentPlatform::Feed::Rule::CopyToFields
, Activ::ContentPlatform::Feed::Rule::LowFields
, Activ::ContentPlatform::Feed::Rule::OpenFields
, Activ::ContentPlatform::Feed::Rule::CloseFields
, Activ::ContentPlatform::Feed::Rule::VolumeFields
, Activ::ContentPlatform::Feed::Rule
, Activ::ContentPlatform::Feed::Rule::PriceFields
  • m_pubSubServiceSettings : Activ::AgentApplication::Settings
  • m_query : Activ::ContentPlatform::ContentGatewayApi::NewsRequestParameters
  • m_receivedUpdateCount : Activ::ContentPlatform::ContentServerApi::ContentServerClient::MessageStats
  • m_recordFilterType : Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestParameters
  • m_recordLength : Activ::Database::TableSpecification
  • m_relationshipId
: Activ::ContentPlatform::ContentGatewayApi::RelationshipInfo
, Activ::ContentPlatform::ContentGatewayApi::RequestBlock
, Activ::ContentPlatform::ContentGatewayApi::ResponseBlock
, Activ::ContentPlatform::ContentGatewayApi::RecordUpdate
, Activ::ContentPlatform::Feed::RelationshipIdHelper
  • m_remoteAddress : Activ::IpSocket::Stats , Activ::IpSocket
  • m_requestBlockList : Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters
  • m_requestKey : Activ::ContentPlatform::ContentGatewayApi::RecordUpdate
  • m_reservedPortIdSet : Activ::ManagedEndPoint::Settings
  • m_resetTime : Activ::ContentPlatform::ContentServerApi::ContentServerClient::Settings
  • m_resolvedKey : Activ::ContentPlatform::ContentGatewayApi::ResponseBlock
  • m_responseBlockList : Activ::ContentPlatform::ContentGatewayApi::RealtimeResponseParameters
  • m_responseKey : Activ::ContentPlatform::ContentGatewayApi::ResponseBlock
  • m_routerServiceSettings : Activ::AgentApplication::Settings
  • m_rules : Activ::ContentPlatform::FeedApi::FieldListValidator::Field
  • m_rxBuffers : Activ::IpSocket
  • m_rxBytes
: Activ::RouterServiceApi::Tcp::SocketStats
, Activ::IpSocket::Stats
, Activ::IpSocket
  • m_rxFlags : Activ::IpSocket
  • m_rxOverlapped : Activ::IpSocket
  • m_rxPosted : Activ::IpSocket::Stats
  • m_schedulerInfo : Activ::SystemInfo
  • m_searchString : Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryRequestParameters
  • m_secondRunFails : Activ::IHeap::Stats::BucketStats
  • m_sectionName : Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::Settings
  • m_sellerId : Activ::ContentPlatform::ContentGatewayApi::Tick
  • m_sequence : Activ::ContentPlatform::Feed::IndexSpecification::Field
  • m_seriesType : Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestParameters
  • m_server : Activ::IFtpHelper
  • m_serviceAccessPointList : Activ::ServiceInstance
  • m_serviceAddress : Activ::ServiceHandle
  • m_serviceHandleList : Activ::ContentPlatform::Feed::TableTemplateList::Settings
  • m_serviceId
: Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::ConnectParameters
, Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::ConnectParameters
, Activ::ServiceHandle
, Activ::ServiceInstance
  • m_serviceIdList : Activ::ContentPlatform::Feed::TableTemplateList::Settings
  • m_serviceLocationIniFile : Activ::AgentApplication::Settings
  • m_setConsoleTitle : Activ::ISystem::Settings
  • m_shouldCork : Activ::IpSocket::Settings
  • m_shouldReInitializeOnReset : Activ::ContentPlatform::Feed::TableTemplateList::Settings
  • m_shouldTerminateOnError : Activ::ContentPlatform::Feed::TableTemplateList::Settings
  • m_size
: Activ::FileInfo
, Activ::ContentPlatform::Feed::Rule::CopyToFields
, Activ::ContentPlatform::Feed::Rule
, Activ::ContentPlatform::ContentGatewayApi::Tick
  • m_smallBlockHeapThreshold : Activ::ISystem::Settings
  • m_source : Activ::ContentPlatform::Feed::Rule , Activ::ContentPlatform::Feed::CopyOnReset
  • m_specifiedInterval : Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestParameters
  • m_startDate : Activ::ContentPlatform::ContentGatewayApi::NewsRequestParameters
  • m_startSymbol : Activ::ContentPlatform::ContentGatewayApi::NewsRequestParameters
  • m_startTime : Activ::Timeband::Settings
  • m_state
: Activ::IProcess::Stats
, Activ::TcpSocket
, Activ::UdpSocket
, Activ::TcpSocket::Stats
, Activ::UdpSocket::Stats
  • m_status
: Activ::ContentPlatform::ContentGatewayApi::ResponseBlock
, Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayResponseParameters
, Activ::ContentPlatform::Feed::Rule::CloseFields
  • m_subject : Activ::SmtpHelper::Email
  • m_subscribeParameters : Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters
  • m_subscriptionCookie : Activ::ContentPlatform::ContentGatewayApi::RealtimeResponseParameters
  • m_subscriptionCookieList : Activ::ContentPlatform::ContentGatewayApi::NewsUpdate
  • m_symbol
: Activ::ContentPlatform::ContentGatewayApi::SymbolId
, Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessage
, Activ::ContentPlatform::ContentGatewayApi::NewsStory
, Activ::ContentPlatform::ContributionGatewayApi::PublishSymbolRecordParameters
, Activ::ContentPlatform::Feed::CompressedMessage
  • m_symbolId
: Activ::ContentPlatform::ContentGatewayApi::SymbolResponse
, Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestParameters
, Activ::ContentPlatform::ContentGatewayApi::SymbolIdCountRequestParameters
, Activ::ContentPlatform::ContentGatewayApi::RecordUpdate
, Activ::ContentPlatform::ContentGatewayApi::SymbolIdMatchRequestParameters
  • m_symbolIdList : Activ::ContentPlatform::ContentGatewayApi::SymbolIdListMatchRequestParameters
  • m_symbolPatternList : Activ::ContentPlatform::ContentServerApi::ContentServerClient::UpdateFilter
  • m_symbolResponseList : Activ::ContentPlatform::ContentGatewayApi::SymbolDirectoryResponseParameters
  • m_symbolSubscriptionMap : Activ::ContentPlatform::ContentGatewayApi::SubscriptionInfo
  • m_symbolSubscriptionQuota : Activ::ContentPlatform::ContentGatewayApi::PermissionInfo
  • m_systemHeapBucketInfo : Activ::AgentApplication::Settings
  • m_systemInfo : Activ::ContentPlatform::ContentGatewayApi::ContentGatewayInfo , Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayInfo
  • m_systemLogMaxSize : Activ::AgentApplication::Settings
  • m_systemLogMode : Activ::ISystem::Settings
  • m_systemLogNumberOfBackups : Activ::AgentApplication::Settings
  • m_systemLogType : Activ::AgentApplication::Settings
  • m_systemLogUniqueName : Activ::AgentApplication::Settings
  • m_systemName : Activ::ISystem::Settings , Activ::ISystem::SystemInfo
  • m_systemVersion : Activ::ISystem::SystemInfo , Activ::AgentApplication::Settings
  • m_tableClientHeapBucketInfo : Activ::ContentPlatform::Feed::TableTemplateList::Settings
  • m_tableCodeIdentifier : Activ::ContentPlatform::ContentGatewayApi::TableInfo
  • m_tableId : Activ::Database::DatabaseSpecification::DatabaseTableSpecification
  • m_tableIdentity : Activ::Database::FieldListObject
  • m_tableName : Activ::ContentPlatform::ContentGatewayApi::TableInfo
  • m_tableNumber
: Activ::ContentPlatform::ContentGatewayApi::PatternMatchRequestParameters
, Activ::ContentPlatform::ContentGatewayApi::SymbolId
, Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessage
, Activ::ContentPlatform::Feed::CompressedMessage
, Activ::ContentPlatform::ContentGatewayApi::PatternMatchListRequestParameters
, Activ::ContentPlatform::ContributionGatewayApi::PublishRecordBaseParameters
, Activ::ContentPlatform::ContentGatewayApi::TableNumberRequestParameters
, Activ::ContentPlatform::ContentGatewayApi::TableInfo
  • m_tableNumberList : Activ::ContentPlatform::ContentGatewayApi::SubscribeTableParameters , Activ::ContentPlatform::ContentServerApi::ContentServerClient::UpdateFilter
  • m_tableSpecification : Activ::Database::DatabaseSpecification::DatabaseTableSpecification
  • m_tableSubscriptionMap : Activ::ContentPlatform::ContentGatewayApi::SubscriptionInfo
  • m_tableTemplateListSettings : Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::Settings
  • m_tableTemplateServiceId : Activ::ContentPlatform::ContentServerApi::ContentServerClient::Settings
  • m_target
: Activ::ContentPlatform::Feed::CopyOnReset
, Activ::ContentPlatform::Feed::Rule::OpenFields
, Activ::ContentPlatform::Feed::Rule::CloseFields
, Activ::ContentPlatform::Feed::Rule::LowFields
, Activ::ContentPlatform::Feed::Rule::CopyToFields
, Activ::ContentPlatform::Feed::Rule::HighFields
  • m_text : Activ::SmtpHelper::Email
  • m_threadPriority : Activ::ManagedEndPoint::Settings
  • m_threadProcessorAffinityList : Activ::ManagedEndPoint::Settings
  • m_tickType : Activ::ContentPlatform::ContentGatewayApi::Tick
  • m_time
: Activ::ContentPlatform::Feed::Rule
, Activ::ContentPlatform::Feed::Rule::LowFields
, Activ::ContentPlatform::Feed::Rule::OpenFields
, Activ::ContentPlatform::Feed::Rule::CopyToFields
, Activ::ContentPlatform::Feed::Rule::HighFields
  • m_timerServiceSettings : Activ::AgentApplication::Settings
  • m_toAddress : Activ::IpSocket
  • m_toAddressList : Activ::SmtpHelper::Email
  • m_totalCurrentFreeBlocks : Activ::IHeap::Stats
  • m_totalErrorCount : Activ::ContentPlatform::ContentServerApi::ContentServerClient::MessageStats
  • m_totalFails : Activ::IHeap::Stats
  • m_totalIgnoredCount : Activ::ContentPlatform::ContentServerApi::ContentServerClient::MessageStats
  • m_totalLowFreeBlocks : Activ::IHeap::Stats
  • m_totalProcessedCount : Activ::ContentPlatform::ContentServerApi::ContentServerClient::MessageStats
  • m_tradeThroughExemptFlag : Activ::ContentPlatform::ContentGatewayApi::Tick
  • m_twinFieldId : Activ::ContentPlatform::Feed::CompressedMessageDefinitions::FieldSpecification
  • m_txBuffers : Activ::IpSocket
  • m_txBytes
: Activ::IpSocket::Stats
, Activ::IpSocket
, Activ::RouterServiceApi::Tcp::SocketStats
  • m_txFlags : Activ::IpSocket
  • m_txOverlapped : Activ::IpSocket
  • m_txPosted : Activ::IpSocket::Stats
  • m_txQueueBytes : Activ::RouterServiceApi::Tcp::SocketStats
  • m_txQueueHighBytes : Activ::RouterServiceApi::Tcp::SocketStats
  • m_txQueueHighMessages : Activ::RouterServiceApi::Tcp::SocketStats
  • m_txQueueMessages : Activ::RouterServiceApi::Tcp::SocketStats
  • m_type
: Activ::IpAddress
, Activ::ContentPlatform::Feed::UniversalFieldHelper
, Activ::Database::FieldSpecification
, Activ::ContentPlatform::Feed::TableTemplate::Specification
, Activ::ContentPlatform::ContentGatewayApi::SubscribeParameters
, Activ::ContentPlatform::Feed::Field::Specification
, Activ::ContentPlatform::Feed::PermissionInfo::PermissionIdInfo
, Activ::Database::IndexSpecification
, Activ::ContentPlatform::Feed::Index::Specification
, Activ::ContentPlatform::Feed::TableTemplateList::TableTemplateSpecification
  • m_udpSettings : Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::Settings
  • m_uiPermissions : Activ::UiMenu::OptionAttributes
  • m_uiServiceSettings : Activ::AgentApplication::Settings
  • m_unrecognizedUpdateCount : Activ::ContentPlatform::ContentServerApi::ContentServerClient::MessageStats
  • m_updateFilterMap : Activ::ContentPlatform::ContentServerApi::ContentServerClient::UpdateFilterMap
  • m_updateId
: Activ::ContentPlatform::Feed::CompressedMessage
, Activ::ContentPlatform::ContentGatewayApi::Tick
, Activ::ContentPlatform::ContentGatewayApi::NewsUpdate
, Activ::ContentPlatform::ContentGatewayApi::RecordUpdate
, Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessage
  • m_updateRequestId : Activ::ContentPlatform::ContentGatewayApi::SubscribeTableParameters
  • m_upTimeSeconds : Activ::ISystem::SystemInfo
  • m_url
: Activ::ServiceHandle
, Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::ConnectParameters
, Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::ConnectParameters
  • m_usagePercentage : Activ::SystemMonitor::Stats::DiskInfo
  • m_userId : Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::ConnectParameters , Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::ConnectParameters
  • m_username : Activ::IFtpHelper
  • m_userType : Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::ConnectParameters , Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::ConnectParameters
  • m_utcStartupDateTime : Activ::ISystem::SystemInfo
  • m_validPart : Activ::IniFileParser::ParseException
  • m_value
: Activ::Time::Hours
, Activ::Time::Minutes
, Activ::Time::Milliseconds
, Activ::Time::Seconds
, Activ::Date::Days
  • m_version
: Activ::ContentPlatform::ContentServerApi::ContentServerClient::ApiInfo
, Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayClient::ApiInfo
, Activ::ContentPlatform::ContentGatewayApi::ContentGatewayClient::ApiInfo
, Activ::ContentPlatform::Feed::TableTemplateList::TableTemplateSpecification
, Activ::IProcess::Stats
, Activ::ContentPlatform::ContentGatewayApi::ContentGatewayInfo
, Activ::ContentPlatform::ContributionServerApi::ContributionServerClient::ApiInfo
  • m_virtualMemorySize : Activ::SystemMonitor::Stats::ProcessInfo
  • m_volumeFields : Activ::ContentPlatform::Feed::Rule
  • m_windowsDpcProcessorAffinityMask : Activ::SystemInfo
  • m_workingSetSize : Activ::SystemMonitor::Stats::ProcessInfo
  • MAPPING_FLAG_READ_ONLY : Activ::IMappedMemory
  • MAPPING_FLAG_UNIQUE : Activ::IMappedMemory
  • MAX_INDEX_NAME_LENGTH : Activ::ContentPlatform::Feed::TableTemplateMessageHeaderDefinitions
  • MAX_LENGTH : Activ::Subject
  • MAX_NAME_LENGTH : Activ::ContentPlatform::Feed::TableTemplateMessageHeaderDefinitions
  • MAX_NUMERATOR : Activ::Rational
  • MAX_PRINTABLE_ASCII : Activ::MessageHandler
  • MAX_SERIALIZED_BODY_LENGTH_UNDEFINED : Activ::IFieldType
  • MAX_SYMBOL_LENGTH
: Activ::ContentPlatform::Feed::CompressedMessageHeaderDefinitions
, Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderDefinitions
, Activ::ContentPlatform::Feed::CombinedQuoteMessageHeaderDefinitions
, Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions
  • MESSAGE_HEADER_FLAGS_COMPOSITE_LENGTH
: Activ::ContentPlatform::Feed::CompressedMessageHeaderDefinitions
, Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderDefinitions
, Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions
  • MESSAGE_HEADER_FLAGS_COMPOSITE_OFFSET
: Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions
, Activ::ContentPlatform::Feed::CompressedMessageHeaderDefinitions
, Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderDefinitions
  • MESSAGE_HEADER_FLAGS_COMPRESSED_SYMBOL_LENGTH : Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderDefinitions
  • MESSAGE_HEADER_FLAGS_COMPRESSED_SYMBOL_OFFSET : Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderDefinitions
  • MESSAGE_HEADER_FLAGS_DELETE_LENGTH
: Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions
, Activ::ContentPlatform::Feed::RecordMessageHeaderDefinitions
, Activ::ContentPlatform::Feed::CompressedMessageHeaderDefinitions
  • MESSAGE_HEADER_FLAGS_DELETE_OFFSET
: Activ::ContentPlatform::Feed::RecordMessageHeaderDefinitions
, Activ::ContentPlatform::Feed::CompressedMessageHeaderDefinitions
, Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions
  • MESSAGE_HEADER_FLAGS_REFRESH_LENGTH : Activ::ContentPlatform::Feed::RecordMessageHeaderDefinitions
  • MESSAGE_HEADER_FLAGS_REFRESH_OFFSET : Activ::ContentPlatform::Feed::RecordMessageHeaderDefinitions
  • MESSAGE_HEADER_FLAGS_RESERVED_LENGTH : Activ::ContentPlatform::Feed::TableTemplateMessageHeaderDefinitions
  • MESSAGE_HEADER_FLAGS_RESERVED_OFFSET : Activ::ContentPlatform::Feed::TableTemplateMessageHeaderDefinitions
  • MESSAGE_HEADER_FLAGS_US_EQUITY_OPTION_LENGTH : Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderDefinitions
  • MESSAGE_HEADER_FLAGS_US_EQUITY_OPTION_OFFSET : Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderDefinitions
  • MESSAGE_TYPE
: Activ::DirectoryWatchApi
, Activ::ContentPlatform::Feed::TableTemplateMessageHeaderDefinitions
, Activ::ContentPlatform::Feed::CompressedCombinedQuoteMessageHeaderDefinitions
, Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestHelper< MESSAGE_TYPE_VALUE, REQUEST_PARAMETERS >
, Activ::ContentPlatform::Feed::CombinedQuoteMessageHeaderDefinitions
, Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions
, Activ::ContentPlatform::Feed::RecordMessageHeaderDefinitions
  • MESSAGE_TYPE_LENGTH : Activ::ContentPlatform::Feed::MessageHeaderDefinitions
  • MESSAGE_TYPE_OFFSET : Activ::ContentPlatform::Feed::MessageHeaderDefinitions
  • MESSAGE_VERSION_UNDEFINED : Activ::MessageHandler
  • MIN_NUMERATOR : Activ::Rational
  • MIN_PRINTABLE_ASCII : Activ::MessageHandler
  • MONTHS_PER_YEAR : Activ::Date
Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • c
  • d
  • e
  • f
  • g
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- n -

  • NUMBER_PER_DAY
: Activ::Time::Hours
, Activ::Time::Minutes
, Activ::Time::Milliseconds
, Activ::Time::Seconds
  • NUMBER_PER_HOUR
: Activ::Time::Minutes
, Activ::Time::Seconds
, Activ::Time::Milliseconds
  • NUMBER_PER_MINUTE : Activ::Time::Seconds , Activ::Time::Milliseconds
  • NUMBER_PER_SECOND : Activ::Time::Milliseconds
  • NUMERATOR_LENGTH_16_BITS : Activ::ContentPlatform::Feed::CompressedMessageDefinitions
  • NUMERATOR_LENGTH_32_BITS : Activ::ContentPlatform::Feed::CompressedMessageDefinitions
  • NUMERATOR_LENGTH_64_BITS : Activ::ContentPlatform::Feed::CompressedMessageDefinitions
  • NUMERATOR_LENGTH_8_BITS : Activ::ContentPlatform::Feed::CompressedMessageDefinitions
Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • c
  • d
  • e
  • f
  • g
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- o -

  • OPTIONAL_DATA_HAS_BUYER_ID : Activ::ContentPlatform::ContentGatewayApi::Tick
  • OPTIONAL_DATA_HAS_OTHER_LENGTH : Activ::ContentPlatform::ContentGatewayApi::Tick
  • OPTIONAL_DATA_HAS_SELLER_ID : Activ::ContentPlatform::ContentGatewayApi::Tick
  • OPTIONAL_DATA_HAS_TRADE_EXEPTION_FLAG : Activ::ContentPlatform::ContentGatewayApi::Tick
Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • c
  • d
  • e
  • f
  • g
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- c -

  • CACHE_COMPLETE : Activ::Database::TableSpecification
Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • c
  • d
  • e
  • f
  • g
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- d -

  • DAYS_PER_MONTH : Activ::Date
  • DAYS_PER_WEEK : Activ::Date
  • DEFAULT_FILENAME : Activ::ContentPlatform::Feed::UniversalFieldList
  • DEFAULT_FTP_LOW_SPEED_LIMIT : Activ::IFtpHelper
  • DEFAULT_FTP_LOW_SPEED_TIME : Activ::IFtpHelper
  • DEFAULT_FTP_PORT : Activ::IFtpHelper
  • DEFAULT_FTP_TIMEOUT : Activ::IFtpHelper
  • DEFAULT_MAX_FIELD_SETS : Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestParameters
  • DEFAULT_MAX_RECORDS_PER_RESPONSE : Activ::ContentPlatform::ContentGatewayApi::NewsRequestParameters
  • DEFAULT_MAX_RESPONSE_BLOCKS : Activ::ContentPlatform::ContentGatewayApi::RealtimeRequestParameters
  • defaultComponentId : Activ::Component
  • defaultTimeout : Activ::Port
Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • c
  • d
  • e
  • f
  • g
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- e -

  • emptyRequestId : Activ::RequestId
  • emptyServiceAccessPointList : Activ::Service
  • emptyUuid : Activ::Uuid
Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • c
  • d
  • e
  • f
  • g
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- f -

  • FIELD_ID_LENGTH : Activ::ContentPlatform::Feed::FieldHeaderDefinitions
  • FIELD_ID_OFFSET : Activ::ContentPlatform::Feed::FieldHeaderDefinitions
  • FIELD_RESERVED_LENGTH : Activ::ContentPlatform::Feed::FieldHeaderDefinitions
  • FIELD_RESERVED_OFFSET : Activ::ContentPlatform::Feed::FieldHeaderDefinitions
  • FIELD_RULE_APPLY_TRENDING : Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ContentServerRuleSet
  • FIELD_RULE_BITMASK_IS_HIGH : Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ContentServerRuleSet
  • FIELD_RULE_BITMASK_IS_LOW : Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ContentServerRuleSet
  • FIELD_RULE_BITMASK_IS_OPEN : Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ContentServerRuleSet
  • FIELD_RULE_CLEAR_ALL : Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions
  • FIELD_RULE_DO_NOT_APPLY_ADD_RULE_1 : Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::TranslatorRuleSet , Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ContentServerRuleSet
  • FIELD_RULE_DO_NOT_APPLY_ADD_RULE_2 : Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::TranslatorRuleSet , Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ContentServerRuleSet
  • FIELD_RULE_DO_NOT_APPLY_CHANGE_RULE : Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::TranslatorRuleSet , Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ContentServerRuleSet
  • FIELD_RULE_DO_NOT_APPLY_TRENDING : Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::TranslatorRuleSet
  • FIELD_RULE_DO_NOT_TEST_HIGH_LOW : Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::TranslatorRuleSet
  • FIELD_RULE_DO_NOT_TEST_OPEN : Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::TranslatorRuleSet
  • FIELD_RULE_DO_NOT_UPDATE_FIELD : Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::TranslatorRuleSet , Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions::ContentServerRuleSet
  • FIELD_RULE_SET_ALL : Activ::ContentPlatform::Feed::SymbolRecordRuleDefinitions
  • FIELD_RULES_PRESENT_LENGTH : Activ::ContentPlatform::Feed::SymbolRecordFieldHeaderDefinitions
  • FIELD_RULES_PRESENT_OFFSET : Activ::ContentPlatform::Feed::SymbolRecordFieldHeaderDefinitions
  • FIELD_STATUS_INVALID_TYPE : Activ::ContentPlatform::ContributionGatewayApi::PublishRecordResponseParameters::FieldError
  • FIELD_TYPE
: Activ::SInt
, Activ::TextArray
, Activ::TextString
, Activ::Time
, Activ::TRational
, Activ::UInt
, Activ::BinaryArray
, Activ::BinaryString
, Activ::Blob
, Activ::CrcBlob
, Activ::Date
, Activ::DateTime
, Activ::Rational
  • FIELD_UNDEFINED_LENGTH : Activ::ContentPlatform::Feed::FieldHeaderDefinitions
  • FIELD_UNDEFINED_OFFSET : Activ::ContentPlatform::Feed::FieldHeaderDefinitions
  • FILE_FLAG_CREATE_ALWAYS : Activ::IFileMappedMemory
  • FILE_FLAG_DELETE_AT_CLOSE : Activ::IFileMappedMemory
  • FILE_FLAG_OPEN_EXISTING : Activ::IFileMappedMemory
  • FILE_FLAG_READ_ONLY : Activ::IFileMappedMemory
  • FLAG_ALL_EXCHANGE_CODES : Activ::ContentPlatform::ContributionGatewayApi::PermissionInfo
  • FLAG_ALL_TABLE_NUMBERS : Activ::ContentPlatform::ContributionGatewayApi::PermissionInfo
  • FLAG_DELETE
: Activ::ContentPlatform::ContentGatewayApi::NewsUpdate
, Activ::ContentPlatform::ContentGatewayApi::RecordUpdate
, Activ::ContentPlatform::ContributionGatewayApi::PublishRecordBaseParameters
  • FLAG_HISTORY_SERVICE_CHANGED : Activ::ContentPlatform::ContentGatewayApi::ContentGatewayInfo
  • FLAG_IGNORE_ALIAS : Activ::ContentPlatform::ContentGatewayApi::TimeSeriesRequestParameters
  • FLAG_IMMEDIATE_REFRESH : Activ::ConsoleWindow
  • FLAG_INCLUDE_EXPIRED : Activ::ContentPlatform::ContentGatewayApi::NewsRequestParameters
  • FLAG_MANUAL : Activ::IEvent
  • FLAG_NEWS_SERVER_SERVICE_CHANGED : Activ::ContentPlatform::ContentGatewayApi::ContentGatewayInfo
  • FLAG_NO_AUTOSCROLL : Activ::ConsoleWindow
  • FLAG_NONE
: Activ::ContentPlatform::ContributionGatewayApi::PublishRecordBaseParameters
, Activ::ContentPlatform::ContentGatewayApi::ResponseBlock
, Activ::ContentPlatform::ContributionGatewayApi::PermissionInfo
  • FLAG_REFRESH : Activ::ContentPlatform::ContentGatewayApi::RecordUpdate
  • FLAG_RELATIONSHIP_ID : Activ::ContentPlatform::ContentGatewayApi::RecordUpdate
  • FLAG_REQUEST_KEY : Activ::ContentPlatform::ContentGatewayApi::RecordUpdate
  • FLAG_STALE : Activ::ContentPlatform::ContentGatewayApi::ResponseBlock , Activ::ContentPlatform::ContentGatewayApi::RecordUpdate
  • FLAG_SYMBOL_DIRECTORY_SERVICE_CHANGED : Activ::ContentPlatform::ContentGatewayApi::ContentGatewayInfo
  • FLAGS_COMPOSITE_ASK_APPENDAGE_LENGTH : Activ::ContentPlatform::Feed::CombinedQuoteMessageHeaderDefinitions
  • FLAGS_COMPOSITE_ASK_APPENDAGE_OFFSET : Activ::ContentPlatform::Feed::CombinedQuoteMessageHeaderDefinitions
  • FLAGS_COMPOSITE_ASK_LENGTH : Activ::ContentPlatform::Feed::CombinedQuoteMessageHeaderDefinitions
  • FLAGS_COMPOSITE_ASK_OFFSET : Activ::ContentPlatform::Feed::CombinedQuoteMessageHeaderDefinitions
  • FLAGS_COMPOSITE_BID_APPENDAGE_LENGTH : Activ::ContentPlatform::Feed::CombinedQuoteMessageHeaderDefinitions
  • FLAGS_COMPOSITE_BID_APPENDAGE_OFFSET : Activ::ContentPlatform::Feed::CombinedQuoteMessageHeaderDefinitions
  • FLAGS_COMPOSITE_BID_LENGTH : Activ::ContentPlatform::Feed::CombinedQuoteMessageHeaderDefinitions
  • FLAGS_COMPOSITE_BID_OFFSET : Activ::ContentPlatform::Feed::CombinedQuoteMessageHeaderDefinitions
  • FLAGS_DO_NOT_ADD_LENGTH : Activ::ContentPlatform::Feed::RecordMessageHeaderDefinitions , Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions
  • FLAGS_DO_NOT_ADD_OFFSET : Activ::ContentPlatform::Feed::RecordMessageHeaderDefinitions , Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions
  • FLAGS_EXPANDED_FORMAT_LENGTH : Activ::ContentPlatform::Feed::RecordMessageHeaderDefinitions , Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions
  • FLAGS_EXPANDED_FORMAT_OFFSET : Activ::ContentPlatform::Feed::SymbolRecordMessageHeaderDefinitions , Activ::ContentPlatform::Feed::RecordMessageHeaderDefinitions
  • FLAGS_LENGTH : Activ::ContentPlatform::Feed::MessageHeaderDefinitions
  • FLAGS_OFFSET : Activ::ContentPlatform::Feed::MessageHeaderDefinitions
Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • c
  • d
  • e
  • f
  • g
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- g -

  • GROW_RECORDS_DEFAULT : Activ::Database::TableSpecification
Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • c
  • d
  • e
  • f
  • g
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- p -

  • PERIOD_LENGTH_MAXIMUM : Activ::MessageRateThrottler
  • PERIOD_LENGTH_MINIMUM : Activ::MessageRateThrottler
Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • c
  • d
  • e
  • f
  • g
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- q -

  • QUOTE_NO_CONDITION : Activ::ContentPlatform::ContentGatewayApi::Tick
  • QUOTE_SAME_CONDITION : Activ::ContentPlatform::ContentGatewayApi::Tick
  • QUOTE_SAME_EXCHANGE_BIT : Activ::ContentPlatform::ContentGatewayApi::Tick
Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • c
  • d
  • e
  • f
  • g
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- r -

  • REQUEST_FLAG_REVERSE_ORDER : Activ::ContentPlatform::ContentGatewayApi::PatternMatchRequestParameters , Activ::ContentPlatform::ContentGatewayApi::PatternMatchListRequestParameters
  • RESERVED_LENGTH : Activ::TRational::SerializedTrendDefinitions
  • RESERVED_OFFSET : Activ::TRational::SerializedTrendDefinitions
  • RULE_DOES_NOT_UPDATE_LAST_VALUE : Activ::ContentPlatform::FeedApi::FieldListValidator::Field
Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • c
  • d
  • e
  • f
  • g
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- s -

  • SECTION_DELIMITER : Activ::IniFileParser
  • sectionName : Activ::ISystem::Settings
  • servicePortId : Activ::LoggerDefinitions
  • SHARE_FLAG_READ : Activ::File
  • SHARE_FLAG_WRITE : Activ::File
  • STATUS_SUCCESS : Activ::ContentPlatform::ContentGatewayApi::ResponseBlock , Activ::ContentPlatform::ContributionGatewayApi::ContributionGatewayResponseParameters
Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • c
  • d
  • e
  • f
  • g
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- t -

  • TICK_CONDITION_LENGTH_MASK : Activ::ContentPlatform::ContentGatewayApi::Tick
  • TICK_DAY_MASK : Activ::ContentPlatform::ContentGatewayApi::Tick
  • TICK_KNOWN_EXCHANGE_BIT : Activ::ContentPlatform::ContentGatewayApi::Tick
  • TICK_LENGTH : Activ::TRational::SerializedTrendDefinitions
  • TICK_OFFSET : Activ::TRational::SerializedTrendDefinitions
  • TICK_OPTIONAL_DATA_BIT : Activ::ContentPlatform::ContentGatewayApi::Tick
  • TICK_OUT_SEQUENCE_MASK : Activ::ContentPlatform::ContentGatewayApi::Tick
  • TICK_SIZE_BYTE1 : Activ::ContentPlatform::ContentGatewayApi::Tick
  • TICK_SIZE_BYTE2 : Activ::ContentPlatform::ContentGatewayApi::Tick
  • TICK_TYPE_MASK : Activ::ContentPlatform::ContentGatewayApi::Tick
  • TREND_ON_DAY_LENGTH : Activ::TRational::SerializedTrendDefinitions
  • TREND_ON_DAY_OFFSET : Activ::TRational::SerializedTrendDefinitions
  • TREND_ON_PREVIOUS_LENGTH : Activ::TRational::SerializedTrendDefinitions
  • TREND_ON_PREVIOUS_OFFSET : Activ::TRational::SerializedTrendDefinitions
Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • c
  • d
  • e
  • f
  • g
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- u -

  • UNDEFINED_FIELD_ID : Activ::Database::FieldSpecification
  • UNDEFINED_FIELD_NUMBER : Activ::Database::FieldList
  • UNDEFINED_INDEX_NUMBER : Activ::Database::IndexSpecification
  • UNDEFINED_TABLE_ID : Activ::Database::DatabaseSpecification
  • USE_CURRENT_FILE_SIZE : Activ::IFileMappedMemory
Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • c
  • d
  • e
  • f
  • g
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- v -

  • VERSION : Activ::Database::DatabaseSpecification , Activ::Database::TableSpecification
Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • c
  • d
  • e
  • f
  • g
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- w -

  • WATCH_TYPE_ADDS_DELETES : Activ::DirectoryWatchApi
  • WATCH_TYPE_ATTRIBUTES : Activ::DirectoryWatchApi
  • WATCH_TYPE_RECURSIVE : Activ::DirectoryWatchApi
Generated on Wed Oct 8 14:01:55 2008 for ACTIV C++ SDK by doxygen 1.5.4


  • File List
  • File Members
  • All
  • Functions
  • Defines
  • a
  • f
  • m
  • p
  • t
  • u

- a -

  • ACTIV_AGENT_SCOPE_LIST : External.h
  • ACTIV_ARRAY_SIZE : Activ.h
  • ACTIV_BASE_EXCEPTION_LIST : BaseException.h
  • ACTIV_BREAK_IF : StatusCodes.h
  • ACTIV_BREAK_IF_AND_IF : StatusCodes.h
  • ACTIV_BREAK_IF_OR_IF : StatusCodes.h
  • ACTIV_CONTENT_GATEWAY_API_VERSION_STRING : ActivContentGatewayApi.h
  • ACTIV_CONTENT_GATEWAY_API_VERSION_VALUE : ActivContentGatewayApi.h
  • ACTIV_CONTENT_GATEWAY_CLIENT_STATE_LIST : ContentGatewayClient.h
  • ACTIV_CONTENT_PLATFORM_MESSAGE_CLASS_LIST : MessageClasses.h
  • ACTIV_CONTENT_SERVER_API_VERSION_STRING : ActivContentServerApi.h
  • ACTIV_CONTENT_SERVER_API_VERSION_VALUE : ActivContentServerApi.h
  • ACTIV_CONTINUE_IF : StatusCodes.h
  • ACTIV_CONTINUE_IF_AND_IF : StatusCodes.h
  • ACTIV_CONTINUE_IF_OR_IF : StatusCodes.h
  • ACTIV_CONTRIBUTION_GATEWAY_API_STRING : ActivContributionGatewayApi.h
  • ACTIV_CONTRIBUTION_GATEWAY_API_VERSION_VALUE : ActivContributionGatewayApi.h
  • ACTIV_CONTRIBUTION_GATEWAY_CLIENT_STATE_LIST : ContributionGatewayClient.h
  • ACTIV_CONTRIBUTION_GATEWAY_RESPONSE_STATUS_LIST : PublishTypes.h
  • ACTIV_CONTRIBUTION_GATEWAY_USER_TYPE_LIST : Types.h
  • ACTIV_CONTRIBUTION_SERVER_API_VERSION_STRING : ContributionServerClient.h
  • ACTIV_CONTRIBUTION_SERVER_API_VERSION_VALUE : ContributionServerClient.h
  • ACTIV_DATABASE_API : External.h
  • ACTIV_DATABASE_EXCEPTION_LIST : DatabaseException.h
  • ACTIV_DATABASE_FIELD_ENUM : FieldSpecification.h
  • ACTIV_DATABASE_FIELD_SPECIFICATION : FieldSpecification.h
  • ACTIV_DATABASE_FIELD_TYPE_ENUM : FieldSpecification.h
  • ACTIV_DATABASE_FIELD_TYPE_LIST : FieldSpecification.h
  • ACTIV_DATABASE_FIELD_TYPE_SPECIFICATION : FieldSpecification.h
  • ACTIV_DATABASE_INDEX_ENUM : IndexSpecification.h
  • ACTIV_DATABASE_INDEX_ENUM_WITH_CACHE : IndexSpecification.h
  • ACTIV_DATABASE_INDEX_FIELD : IndexSpecification.h
  • ACTIV_DATABASE_INDEX_SPECIFICATION : IndexSpecification.h
  • ACTIV_DATABASE_INDEX_SPECIFICATION_WITH_CACHE : IndexSpecification.h
  • ACTIV_DAY_LIST : Date.h
  • ACTIV_DEBUG_ONLY : Activ.h
  • ACTIV_DECLARE_CONSTANT_ELEMENT_1 : Activ.h
  • ACTIV_DECLARE_CONTRIBUTION_GATEWAY_RESPONSE_STATUS : PublishTypes.h
  • ACTIV_DECLARE_DLL_FUNCTION : DynamicLibraryLoader.h
  • ACTIV_DECLARE_ELEMENT_1_WITH_COMMA : Activ.h
  • ACTIV_DECLARE_ELEMENT_2_WITH_COMMA : Activ.h
  • ACTIV_DECLARE_FIELD_STATUS : PublishTypes.h
  • ACTIV_DECLARE_FIELD_TYPE_ENUMERATIONS : ActivFieldTypes.h
  • ACTIV_DECLARE_HIDDEN_ELEMENT_1 : Activ.h
  • ACTIV_DECLARE_HIDDEN_ELEMENT_2 : Activ.h
  • ACTIV_DECLARE_HIDDEN_VALUE_WITH_COMMA : Activ.h
  • ACTIV_DECLARE_INDEX_PROPERTIES_ENUMERATIONS : IndexNumbers.h
  • ACTIV_DECLARE_INDEX_TYPE_ENUMERATIONS : IndexNumbers.h
  • ACTIV_DECLARE_INTRUSIVE_PTR_TYPEDEF : IntrusivePtrHelper.h
  • ACTIV_DECLARE_LOG_TYPE : ActivBase.h
  • ACTIV_DECLARE_MESSAGE_CLASS : MessageTypes.h
  • ACTIV_DECLARE_MESSAGE_TYPE : MessageTypes.h
  • ACTIV_DECLARE_RESPONSE_BLOCK_STATUS : RealtimeTypes.h
  • ACTIV_DECLARE_STATUS_CODE : StatusCodes.h
  • ACTIV_DECLARE_TABLE_RESET_TYPE_ENUMERATIONS : TableResetTypes.h
  • ACTIV_DECLARE_TABLE_TYPE_ENUMERATIONS : TableTypes.h
  • ACTIV_DECLARE_UNINITIALIZED_VARIABLE : GCC.h , Intel.h , SunPro.h , VisualC.h
  • ACTIV_DECLARE_VALUE_WITH_COMMA : Activ.h
  • ACTIV_DEFAULT_SYSTEM_HEAP_BUCKET_INFO : AgentApplication.h
  • ACTIV_DENOMINATOR_ENUMERATION : Rational.h
  • ACTIV_DENOMINATOR_LIST : Rational.h
  • ACTIV_DENOMINATOR_SPECIFICATION : Rational.h
  • ACTIV_DESERIALIZE_OBJECT : SerializableContainerHelperDetail.h
  • ACTIV_DO_STRINGIZE : Activ.h
  • ACTIV_ENHANCED_DEBUG_ONLY : Activ.h
  • ACTIV_EXCEPTION : Exception.h
  • ACTIV_FEED_DECLARE_COMPRESSED_MESSAGE_FIELD_SPECIFICATION : CompressedMessageDefinitions.h
  • ACTIV_FEED_INDEX_SPECIFICATION_PROPERTIES_LIST : IndexSpecification.h
  • ACTIV_FEED_INDEX_SPECIFICATION_TYPE_LIST : IndexSpecification.h
  • ACTIV_FEED_MESSAGE_TYPE_LIST : ActivFeedMessageHandler.h
  • ACTIV_FIELD_OFFSET : Activ.h
  • ACTIV_FIELD_SET_FILTER_STATUS_LIST : FieldSet.h
  • ACTIV_FIELD_SET_TYPE_LIST : FieldSet.h
  • ACTIV_FIELD_SIZE : Activ.h
  • ACTIV_FIELD_STATUS_LIST : PublishTypes.h
  • ACTIV_FIELD_STATUS_TYPE_LIST : FieldStatus.h
  • ACTIV_FIELD_TYPE_LIST : ActivFieldTypes.h
  • ACTIV_FORCE_INLINE : GCC.h , SunPro.h , VisualC.h
  • ACTIV_HISTORY_ADJUSTMENT_TYPE_LIST : HistoryBar.h
  • ACTIV_IENDPOINT_NOTIFICATION_TYPE_LIST : IEndPoint.h
  • ACTIV_IENDPOINT_STATE_LIST : IEndPoint.h
  • ACTIV_INDEX_PROPERTIES_LIST : IndexNumbers.h
  • ACTIV_INDEX_TYPE_LIST : IndexNumbers.h
  • ACTIV_INTRUSIVE_PTR_HELPER_ADD_REFERENCE_COUNTER : IntrusivePtrHelper.h
  • ACTIV_INTRUSIVE_PTR_HELPER_REFERENCE_COUNTER_NAME : IntrusivePtrHelper.h
  • ACTIV_IP_EXCEPTION_LIST : IpException.h
  • ACTIV_IP_SOCKET_STATE_LIST : TcpSocket.h
  • ACTIV_IPROCESS_STATE_LIST : IProcess.h
  • ACTIV_LOG_TYPE_LIST : ActivBase.h
  • ACTIV_MAKE_VERSION_VALUE : Activ.h
  • ACTIV_MESSAGE_CLASS_LIST : MessageTypes.h
  • ACTIV_MIDDLEWARE_VERSION_STRING : Activ.h
  • ACTIV_MIDDLEWARE_VERSION_VALUE : Activ.h
  • ACTIV_MONTH_LIST : Date.h
  • ACTIV_NEVER_INLINE : GCC.h , SunPro.h , VisualC.h
  • ACTIV_RELEASE_ONLY : Activ.h
  • ACTIV_RESPONSE_BLOCK_FLAG_LIST : RealtimeTypes.h
  • ACTIV_RESPONSE_BLOCK_STATUS_LIST : RealtimeTypes.h
  • ACTIV_RETHROW : Exception.h
  • ACTIV_RETURN_FALSE_IF : StatusCodes.h
  • ACTIV_RETURN_FALSE_IF_AND_IF : StatusCodes.h
  • ACTIV_RETURN_FALSE_IF_OR_IF : StatusCodes.h
  • ACTIV_RETURN_IF : StatusCodes.h
  • ACTIV_RETURN_IF_AND_IF : StatusCodes.h
  • ACTIV_RETURN_IF_OR_IF : StatusCodes.h
  • ACTIV_RETURN_RESULT_IF : StatusCodes.h
  • ACTIV_RETURN_RESULT_IF_AND_IF : StatusCodes.h
  • ACTIV_RETURN_RESULT_IF_OR_IF : StatusCodes.h
  • ACTIV_RETURN_TRUE_IF : StatusCodes.h
  • ACTIV_RETURN_TRUE_IF_AND_IF : StatusCodes.h
  • ACTIV_RETURN_TRUE_IF_OR_IF : StatusCodes.h
  • ACTIV_RETURN_VALUE_IF : StatusCodes.h
  • ACTIV_RETURN_VALUE_IF_AND_IF : StatusCodes.h
  • ACTIV_RETURN_VALUE_IF_OR_IF : StatusCodes.h
  • ACTIV_SERIALIZE_OBJECT : SerializableContainerHelperDetail.h
  • ACTIV_STATUS_CODE_LIST : StatusCodes.h
  • ACTIV_SYSTEM_EXCEPTION_LIST : SystemException.h
  • ACTIV_TABLE_RESET_TYPE_LIST : TableResetTypes.h
  • ACTIV_TABLE_TYPE_LIST : TableTypes.h
  • ACTIV_TCP_LISTENER_STATE_LIST : TcpListener.h
  • ACTIV_TEMPLATE_API : GCC.h , VisualC.h , SunPro.h , Intel.h
  • ACTIV_TEMPLATE_SELF : VisualC.h , SunPro.h , GCC.h
  • ACTIV_THROW : Exception.h
  • ACTIV_THROW_ERROR_IF : Exception.h
  • ACTIV_THROW_RESULT_IF : StatusCodeException.h
  • ACTIV_THROW_RESULT_IF_AND_IF : StatusCodeException.h
  • ACTIV_THROW_RESULT_IF_OR_IF : StatusCodeException.h
  • ACTIV_THROW_TABLE_TEMPLATE_EXCEPTION_IF : TableTemplateException.h
  • ACTIV_THROW_TABLE_TEMPLATE_EXCEPTION_IF_AND_IF : TableTemplateException.h
  • ACTIV_TICK_LIST : TRational.h
  • ACTIV_TIME_SERIES_HISTORY_FIELD_FILTER_TYPE_LIST : TimeSeriesTypes.h
  • ACTIV_TIME_SERIES_HISTORY_SERIES_TYPE_LIST : TimeSeriesTypes.h
  • ACTIV_TIME_SERIES_INTRADAY_FIELD_FILTER_TYPE_LIST : TimeSeriesTypes.h
  • ACTIV_TIME_SERIES_INTRADAY_RECORD_FILTER_TYPE_LIST : TimeSeriesTypes.h
  • ACTIV_TIME_SERIES_INTRADAY_SERIES_TYPE_LIST : TimeSeriesTypes.h
  • ACTIV_TIME_SERIES_PERIOD_TYPE_LIST : TimeSeriesTypes.h
  • ACTIV_TIME_SERIES_TICK_RECORD_FILTER_TYPE_LIST : TimeSeriesTypes.h
  • ACTIV_TIME_SERIES_TICK_SERIES_TYPE_LIST : TimeSeriesTypes.h
  • ACTIV_TREND_LIST : TRational.h
  • ACTIV_UDP_SOCKET_STATE_LIST : UdpSocket.h
  • ACTIV_USER_TYPE_LIST : Types.h

- f -

  • FIELDSETLIST_FIND_MODE_LIST : FieldSet.h
  • FILE_TYPE_LIST : LoggerDefinitions.h

- m -

  • MakeMessageType : MessageTypes.h
  • MATCH_REQUEST_MATCH_TYPE_LIST : RealtimeTypes.h

- p -

  • POLICY_TYPE_LIST : ContentGatewayClient.h , ContributionGatewayClient.h

- t -

  • TICK_TYPE_LIST : Tick.h

- u -

  • UI_PERMISSIONS_LIST : UiPermissions.h
  • UPDATE_FIELDSET_STATUS_LIST : FieldSet.h
Generated on Wed Oct 8 14:02:12 2008 for ACTIV C++ SDK by doxygen 1.5.4


  • File List
  • File Members
  • All
  • Functions
  • Defines

  • intrusive_ptr_add_ref() : IntrusivePtrHelper.h
  • intrusive_ptr_release() : IntrusivePtrHelper.h
  • operator<<() : Field.h , TableSpecification.h , IndexSpecification.h , FieldSpecification.h , FieldListObject.h , DatabaseSpecification.h , Exception.h , IndexSpecification.h , Index.h
Generated on Wed Oct 8 14:02:12 2008 for ACTIV C++ SDK by doxygen 1.5.4


ACTIV C++ SDK Documentation

1.8.11.0

Generated on Wed Oct 8 14:01:44 2008 for ACTIV C++ SDK by doxygen 1.5.4


Activ::ContentPlatform::Feed::PermissionLevelData Member List

This is the complete list of members for Activ::ContentPlatform::Feed::PermissionLevelData, including all inherited members.

m_delayPeriod Activ::ContentPlatform::Feed::PermissionLevelData

Generated on Wed Oct 8 14:02:06 2008 for ACTIV C++ SDK by doxygen 1.5.4